Что такое Корпоративный портал Битрикс24
1 / 401
Корпоративный портал Битрикс24 (КП) - это программное обеспечение, предоставляющее сотрудникам компании, клиентам и простым пользователям доступ к различной служебной информации компании. Доступ может быть организован как из внутренних, так и из внешних сетей с целью организации производственной деятельности.

Объем корпоративной информации, доступной для конкретного пользователя программы, ограничивается в соответствии с имеющимся у него уровнем прав. Корпоративный портал предоставляет возможности внутренних коммуникаций и интеграции сторонних приложений.

Отличие корпоративного портала от схожих по типу программ

Не надо путать корпоративный портал с созвучным ему понятием портал в Интернете и с корпоративной информационной системой.

В интернете есть свое понятие портал. Под ним подразумевается очень большой по содержанию и функционалу проект. Основное отличие обычного веб-сайта от веб-портала - наличие интерактивных сервисов, таких как почта, поиск, погода, новости, форумы, обсуждения, голосования и т. д. Примером такого веб-портала может служить Яндекс.

Битрикс24, в котором вам предстоит работать, - это не веб-портал потому что:

  • доступ к корпоративному порталу в полном объеме ограничен только сотрудниками компании;
  • КП имеет функционал, не типичный для веб-сайтов, но необходимый для функционирования компании.

Кроме этого необходимо различать корпоративный портал и корпоративную информационную систему.

Корпоративная информационная система - совокупность содержащейся в корпоративных базах данных информации и обеспечивающих обработку этой информации технологий и технических средств.

Корпоративный портал - это дополнение, расширение традиционной корпоративной информационной системы. Так как позволяет организовывать управление бизнес-процессами на основе обработки этой корпоративной информации. Пример корпоративной информационной системы - «1С:Предприятие».

Если быть точным, то любую корпоративную информационную систему можно назвать системой совместной работы. Разница только в степени охвата бизнес-процессов компании. В корпоративном портале упор делается именно на совместную деятельность всех сотрудников компании, а не просто на доступ к информации какой-то их части.

Примечание: Корпоративные порталы это не столько новый класс корпоративных приложений, сколько новая эффективная технология, позволяющая существенно расширить функциональные возможности корпоративных систем и создавать новые подсистемы с недостижимыми ранее свойствами.

Битрикс24

Битрикс24 - программа, использующая различные инструменты организации групповой и индивидуальной работы:

  • знакомые по Интернету веб-инструменты (мгновенные сообщения, облака тегов, форумы, блоги);
  • единое файловое хранилище с контролем версий;
  • единый календарь и задачи как инструмент планирования деятельности;
  • неограниченное количество рабочих групп, возможность пользователям самостоятельно создавать и модерировать группы;
  • гибкая система настройки прав;
  • морфологический поиск, который существенно облегчает сотрудникам жизнь.
  • и многие другие.

Битрикс24 работает в любых браузерах. Для устаревших версий браузеров, а также для операционных систем линейки Mac есть некоторые ограничения в функционале.

Редакции

Битрикс24 выпускается в различных редакциях, функционал которых различается:

  • Проект - бесплатная облачная редакция с необходимым базовым функционалом.
  • Проект+ - платная облачная редакция с расширенным базовым функционалом.
  • Команда - платная облачная редакция с расширенным функционалом и неограниченным числом сотрудников.
  • Компания - самая функциональная платная облачная редакция.
  • Корпоративный портал - платная коробочная редакция с полным функционалом.
  • Холдинг - платная коробочная редакция для компаний с территориально распределёнными подразделениями.

Облачный сервис или коробка

Битрикс24 может быть в виде сервиса или коробочной версии. "Сервис" или "коробка" - это технические термины. Для сотрудников компаний, работающих с Битрикс24 они имеют значение только в плане доступности того или иного функционала.

Примечания:
  1. В курсе термины сервис, коробка, корпоративный портал (или просто портал) нужно воспринимать как синонимы.
  2. В описании части функционала встречаются упоминания о версиях продукта. (Например: Начиная с версии 14.5.2 типовые отчеты теперь нельзя редактировать.) Эти упоминания относятся к коробочной версии и, если вы используете Битрикс24 как сервис, то вам на них обращать внимание нет необходимости.

Внимание! В рамках этого курса рассматриваются все возможности продукта. Для младших редакций часть описанного функционала не будет доступна. Перед изучением курса выясните у администратора какая редакция у вас используется и какой функционал вам доступен.

© «Битрикс», 2001-2008, «1C-Битрикс», 2008-2017 1С-Битрикс


Сравнение редакций Битрикс24
2 / 401
Существует 6 вариантов представления Битрикс24 - 4 «облачных» (Проект, Проект+, Команда, Компания) и 2 «коробочных» (Корпоративный портал, Холдинг). Редакции продукта различаются набором функциональных возможностей. Различия наглядно представлены в таблице сравнения.

 | Облако |  |  |  | Коробка
 | Проект | Проект+ | Команда | Компания | Корпоративный портал | Холдинг
Стоимость продукта | Бесплатно | Платные тарифы
Количество зарегистрированных пользователей | Неограниченно |  |  |  | 25+ | 25+
Дополнительные пользователи |  |  |  |  | Стоимость дополнительного пользователя
Место | 5Гб+ | 24Гб+ | 100Гб+ | Неограниченно
 | Внутренние и внешние коммуникации компании
Социальная сеть компании Мгновенные сообщения Групповой бизнес-чат Видеозвонки (до 4-х человек одновременно) Битрикс24.Почта | Функционал доступен для всех редакций Сравнение интранет и экстранет пользователя
Телефония | + | Расширенная телефония
Внешние пользователи, группы экстранет | - | - | Неограниченно
Открытые линии | 1 линия | 1 линия | 2 линии | Неограниченно
 | Управление задачами и проектами
Управление задачами, проектами, учет времени, контроль сроков Шаблоны задач, создание задачи из комментария в Живой ленте и с помощью e-mail, чек-листы Занятость сотрудников по задачам | Функционал доступен для всех редакций
Зависимости между задачами в диаграмме Ганта | - | Расширенные задачи
Пользовательские поля | - | - | + | + | + | +
 | CRM
Клиенты, продажи, аналитические отчеты Счета онлайн Интеграция с телефонией | Функционал доступен для всех редакций
Интеграция с интернет-магазином | 1 магазин |  | Неограниченно
Автоматизация бизнес-процессов в CRM, роботы и триггеры | - | + (только для лидов) | + | + | + | +
1C-трекер Email-трекер Виджет на сайт | Функционал доступен для всех редакций
CRM-формы | 1 | 2 | 4 | неограниченно
Мультиворонки (направления сделок) | - | - | 2 | неограниченно
Конвертация между сделками, счетами, предложениями Расширенный поиск дубликатов История всех изменений с возможностью восстановления, журнал доступа сотрудников к данным в CRM, просмотр больше 5 000 записей в CRM Обзвон по списку клиентов | - | + | + | + | + | +
Интеграция с 1С Рассылки по базе клиентов Продажа услуг | - | - | + | + | + | +
И другие полезные возможности | - | - | + | + | + | +
 | Телефония
Аренда виртуального номера, привязка собственного номера Неограниченное число входящих линий, маршрутизация звонков Встроенная интеграция с CRM Подключение своей АТС, подключение телефонного аппарата Настройка по рабочему времени, голосовые сообщения для приветствия и автоответчика Запись разговора (до 100 в месяц) | Функционал доступен для всех редакций
Запись всех звонков без ограничений (более 100 в месяц) Одновременный звонок на всех свободных сотрудников в очереди Оценка разговора клиентом Определение источника звонка по номеру телефона в CRM | - | + | + | + | + | +
Распределение прав доступа к звонкам и настройкам телефонии Аналитика и отчеты по звонкам Голосовое меню | - | - | + | + | + | +
И другие полезные возможности | - | - | + | + | + | +
 | Планирование и учет рабочего времени
Календари (общие и персональные) Планировщик коллективных встреч и собраний Синхронизация календарей с MS Outlook, Google, iOS, MacOS, Android | Функционал доступен для всех редакций
Рабочие отчеты руководителю Учет рабочего времени Отчеты по рабочему времени Собрания и планерки | - | - | - | + | + | +
Резервирование переговорных | Недоступно в "облаке" |  |  |  | Доступно в "коробке"
И другие полезные возможности | - | - | + | + | + | +
 | Совместная работа с документами
Битрикс24.Диск для совместной работы Он-лайн редактирование в GoogleDocs, MS Office Online или на компьютере Поиск по содержимому документов История изменений Обмен документами Права доступа | Функционал доступен для всех редакций
Блокировка документов Отключение публичных ссылок | - | - | + | + | + | +
 | HR: Управление персоналом
Базовый функционал: список сотрудников, телефонный справочник, персональная страница, график отсутствий, геймификация, пульс компании и т.д. | Доступен для всех редакций
Обучение и тестирование сотрудников Новости компании, подписка на новости Сервис сбора идей Карьера и вакансии для сотрудников Доска объявлений компании Внутренние заявки Просмотр зарплатных листков и отпусков Служба техподдержки сотрудников | Функционал недоступен в «облаке» |  |  |  | Функционал доступен в «коробке»
 | Автоматизация бизнес-процессов компании
Визуальный конструктор бизнес-процессов Бизнес-процессы в CRM Бизнес-процессы в общих документах | - | - | + | + | + | +
Универсальные списки | - | - | - | + | + | +
Документооборот Командировки и отпуска Утверждение счетов Send&Save. Архив почты на портале | Функционал недоступен в «облаке» |  |  |  | Функционал доступен в «коробке»
Многодепартаментность | - | - | - | - | - | +
 | Приложения для Битрикс.24
Мобильные приложения Десктоп-приложение Каталог веб-приложений Rest API для создания приложений | Функционал доступен для всех редакций
Открытый API и исходный код Каталог веб-приложений для «коробки» | Недоступно в «облаке» |  |  |  | Доступно в «коробке»
 | Интеграции
Интеграция с MS Office, MS Office Online, MS Outlook. Интеграция с GoogleDocs, Google (контакты, календари) Интеграция с MacOS, iOS, Android Подключение внешних АТС | Функционал доступен для всех редакций
Подключение внешних почтовых сервисов | Доступно в «облаке» |  |  |  | Недоступно в «коробке»
Коннектор к MS Exchange Server 2007/2010 Интеграция с MS Exchange Web Mail Коннектор к MS SharePoint Интеграция с «1С:ЗУП» Active Directory/LDAP интегратор + NTLM | Функционал недоступен в «облаке» |  |  |  | Функционал доступен в «коробке»
 | Безопасность и надежность
SSL-сертификат Проактивная защита (WAF - Web Application Firewal) Разграничение прав доступа пользователей Двухэтапная авторизация (OTP) Физическое разделение данных разных клиентов | Функционал доступен для всех редакций
Облачный бекап | - | - | - | - | 20Гб+ | 50Гб+
 |  |  |  |  | Стоимость дополнительного места в облаке под бекап сайта
Ограничение доступа по IP | - | - | + | + | + | +
Персональный генератор одноразовых паролей (OTP) | Недоступно в «облаке» |  |  |  | Доступно в «коробке»
Повышенная защита дата-центров (SAS 70 Type II) Ежедневное резервное копирование в реальном режиме | Функционал доступен в «облаке» |  |  |  | Функционал недоступен в «коробке»
 | Масштабирование
Виртуальная машина (полностью настроенное и протестированное серверное окружение для оптимальной работы Битрикс24) | - | - | - | - | + | +
Веб-кластер | - | - | - | - | - | +
Другие функции и возможности


Сравнение интранет и экстранет пользователя
3 / 401

Экстранет – инструмент, который позволяет компании осуществлять конфиденциальную связь с поставщиками, дистрибьюторами и другими внешними пользователями без допуска их к внутрикорпоративной информации.

В экстранете сотрудники компании могут приглашать внешних пользователей и обсуждать с ними вопросы в рабочей группе (в форумах, блогах), совместно работать с общими документами, планировать активность в календаре, ставить задачи и следить за их выполнением, публиковать отчеты и т.д.

Хоть возможности экстранет-пользователей достаточно схожи с возможностями обычных сотрудников, но они имеют некоторые ограничения. В таблице представлено сравнение возможностей интранет и экстранет пользователей, сгруппированное по функционалу левого меню:

Функционал | Интранет | Экстранет | Примечания
Общее
Просмотр чужого профиля | + | + | Доступно: Информация профиля, Диск, Задачи, Сообщения.
Живая лента | + | + | Пользователю экстранета доступен весь функционал кроме благодарностей и событий календаря. Видны все сообщения групп и сообщения и события, адресованные лично ему.
Задачи | + | + | Пользователь экстранета может ставить задачи всем, кто есть в списке Сотрудники и Контакты. В рамках группы может ставить задачи только участникам этой группы.
Календарь | + | – |
Мой диск | + | + | Пользователь экстранета может настроить права доступа на свои папки и файлы. Не может "расшарить" свои личные папки. На него также нельзя "расшарить" папку (опция диска "Сделать общей").
Почта | + | – |
Сообщения | + | + | Пользователь экстранета может писать только тем, кто есть в контакт-листе (Сотрудники и Контакты) и может писать на группу.
Бизнес процессы | + | – |
Фотографии | + | + |
CRM | + | – |
Группы
Группы | + | – |
Группы экстранет | + | + | Пользователь экстранета видит весь контент группы (если иное не приписано настройками). Права на доступ (контент) ограничены только настройками самой группы. В рамках группы доступен следующий функционал: Диск, Задачи, Календарь, Сообщения, Фото, Списки, Wiki.
Компания
Сотрудники | + | + | Список доступных сотрудников компании, которые вместе с пользователем экстранета состоят в общих группах.
Контакты | – | + | Список доступных внешних экстранет-пользователей (не сотрудников компании), которые вместе состоят в общих группах.
Общий диск | + | – |
Структура компании | + | – |
Рабочее время | + | – |
Списки | + | – | Пользователь экстранета может использовать функционал списков только в рамках групп.
Собрания и планерки | + | – |
График отсутствий | + | – |
Коммуникации
Настройка уведомлений | + | + |
Мгновенные сообщения / Звонки / Видеозвонки | + | + | Пользователь экстранета может писать только тем, кто есть в контакт-листе (Сотрудники и Контакты). Возможность совершения звонков/видеозвонков зависит типа браузера.
Телефония | + | – |
Битрикс24 Network | + | + | Доступен, как и обычному сотруднику. На портале присутствует ссылка на профиль в Битрикс24 Network.
Мобильное приложение | + | + | Контент и права аналогичны версии в браузере.
Десктоп-приложение | + | + | Возможности аналогичны версии в браузере.

Ссылки по теме:

  • Группы экстранет


Как отформатирован текст в курсе
4 / 401

В учебном курсе используются свои правила форматирования текста с целью облегчить восприятие информации нашими пользователями. На этой странице описаны эти правила, чтобы вам было легче ориентироваться.

Форматирование текста

Жирный шрифт используется для выделения важных в смысловом значении слов, терминов, фраз и предложений. То есть то, что особенно важно в контексте описываемого функционала:

  • Ключевое смысловое слово, фраза.
  • Термины, названия элементов интерфейса: кнопки, вкладки, поля, горячие клавиши, формат или название файла.
  • Название курса, глав курса, разделов и страниц сайтов. (Как правило название глав или курсов даются ссылкой, но иногда это бывает излишним.)
Примеры использования жирного шрифта
Пример названия курса или главы | Изучение курса позволяет освоить основные методы администрирования системы, а так же пополнить знания по темам, изученным в курсе Контент-менеджер.
Пример названий элементов интерфейса: | При этом у компонента Список новостей нужно настроить входные параметры так, чтобы он мог формировать ссылки на страницу детальной новости (с кодом новости). Для этого нужно в группе параметров Шаблоны ссылок в поле URL страницы детального просмотра задать путь к этой странице, а также название параметра, в котором будет передаваться код новости для показа.
Пример ключевой фразы, слова | При регистрации сервера обязательно укажите Домен для NTLM авторизации. Он должен полностью (включая регистр) совпадать с названием домена.

Курсив используется для выделения:

  • Названия продуктов компании 1С-Битрикс, других программ и технологических платформ.
  • Названия методов, классов, функций и событий, если нет их описания в API доке. (Если описание есть, то название метода или класса оформляется ссылкой на страницу документации.)
  • Пространство имён в новом ядре D7.
  • Ключевое слово, фраза, термин, если использование жирного шрифта не желательно по каким-то причинам.
Примеры использования курсива
Пример названия метода: | Усовершенствованные методы буферизации в шаблоне позволяют более не использовать CBitrixComponentTemplate::EndViewTarget() ввиду того, что конец шаблона вызывает завершение буферизации автоматически. (Если страница метода в документации есть, то будет так: Перед подключением компонента ко всем значениям параметров применяется функция htmlspecialcharsEx.)
Пример названий продуктов и платформ: | Чтобы научиться эффективно работать в Bitrix Framework, нужно не сравнивать то, что вы знаете по другим системам, а стараться понять как то или иное реализуется в этой системе. В плане обучения «сравнительный» подход не работает. Просто отвлекитесь от старых знаний и изучите новую систему используя только знания PHP и сайтостроения, а не сравнивая идеологии и технологии.
Пример пространства имён в D7: | При необходимости модуль может организовывать подпространства внутри своего пространства имен. Например, Bitrix\Main\IO, Bitrix\Forum\SomeName\SomeNameTwo.

Подчёркивание текста так же применяется для выделения ключевого слова, фразы, но в случаях когда использование жирного шрифта и курсива не желательно по каким-либо причинам. Этот способ выделения используется крайне редко.

Серый фон текста используется для выделения:

  • путей в рамках файловой системы.
  • атрибутов, тегов html, параметров функций, переменных, значения полей и настроек и листинга кода, который нет смысла помещать в стиль для листинга.
Примеры использования серого фона
Пример выделения путей в рамках файловой системы: | Результаты кеширования сохраняются в виде файлов в каталоге /bitrix/cache/.
Пример выделения атрибутов, тегов и так далее: | Если в компоненте написать код: $arParams = & $arSomeArray; то переменная $arParams будет отвязана от члена класса компонента и привязана к массиву $arSomeArray.

Синий курсив с > используется для подсветки путей в продукте. То есть пути выглядят так же как они оформлены в административном отделе системы.

Примеры использования синего курсива
Пример оформления путей в административном отделе системы: Файлы кеша можно удалить в административной части на закладке Очистка файлов кеша страницы Настройки > Настройки продукта > Автокеширование.

Синий шрифт используется для подсветки УРЛ без создания собственно ссылки - псевдо УРЛ.

Примеры использования синего шрифта
Пример псевдо УРЛ: При помощи access_token приложение совершает запросы к REST-сервису до его истечения.
https://имя_портала.bitrix24.ru/rest/user.current?auth=код_авторизации

Форматирование текста цветом используется в случаях, когда надо выделять информацию, относящуюся к разным сущностям в паралелльных процессах.

Примеры использования цветного шрифта
Цветной шрифт:
  • Настроить инфоблок на контроллере:

    ........

  • На подключенном сайте надо создать инфоблок с таким же значением внешнего кода, как и на контроллере. Кроме привязки к сайту, названия и внешнего кода необходимо настроить и права доступа к инфоблоку.

    ......

Форматирование абзацев текста

Форматирование целых абзацев текста используется для выделения какой-либо информации с целью указать направленность этой информации.

Определения каких либо сущностей, явлений, терминов и так далее выводится в абзацах такого вида:

Статическая информация – это информация, которая редко изменяется с течением времени. Например, рекламные тексты, история компании, контактная информация и т.п. Статическая информация создается, редактируется, дополняется и удаляется пользователями, обладающими правом на редактирование страниц сайта. Такое редактирование производится, как правило, в визуальном редакторе непосредственно в тексте самой страницы.

В Примечании размещается информация, поясняющая текст на странице, на которую стоит обратить внимание. Это могут быть примеры, расширенное объяснение, уточнение, ссылка на дополнительную информацию. Например:

Примечание: этот способ относится только к приложениям третьего типа. Приложения первого и второго типов получают и продлевают авторизацию автоматически.

Предупреждения - это информация, имеющая критическое значение для работы того или иного функционала продукта. Например:

Важно! Если курс был деактивирован, то результаты тестов и сертификаты по этому курсу будут недоступны пользователям. Если курс был удален, то результаты тестов и сертификаты этого курса будут также удалены.

В особо важных случаях в этом виде форматирования может использоваться красный шрифт.

В спойлерах размещается информация, которая имеет вторичное значение, но может быть полезна "для общего развития". Для открытия спойлера надо просто кликнуть на "+" в спойлере:

Задание окна для открытия ссылки при редактировании в режиме кода (для ознакомления)

В коде каждый из пунктов этого списка задается с помощью атрибута target тега <a>. Атрибут target может принимать соответственно следующие значения:

  • _blank;
  • _parent;
  • _self;
  • _top.

Чтобы избежать лишней прокрутки экрана, в спойлерах может быть размещена большая по объёму информация.

Видеоролики могут располагаться как в спойлерах, так и в отдельных абзацах. Если видео размещено в отдельных абзацах, то оно открывается во всплывающем окне:

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Управление валютами

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.


Поддержка24
5 / 401

Для обучения работе в сервисе Битрикс24 создана специальная служба Поддержки24. К ней можно обратиться нажатием на кнопку со знаком вопроса в "шапке" сервиса:

По нажатию - откроется окно с контекстной справкой.

Контекстная справка - информация о функционале, открываемая "по месту требования". То есть в разделе Задачи откроется окно с информацией только о задачах, в разделе Календари - только о календарях.

С помощью Меню слева вы можете перемещаться по Поддержке24.

Почитайте готовые ответы - это список быстрых вопросов и ответов. Здесь собраны типовые вопросы и ответы, которые поступали в службу поддержки сервиса Битрикс24.

Посмотрите Видеоролики - список видеороликов и вебинаров с общим рассказом о функционале и приёмах работы.

Учебный курс по Битрикс24 - список уроков из учебного курса Пользователь Битрикс24 с детальным и подробным описанием функционала.

Попробуйте подходящие Приложения24 - список сторонних приложений, которые могут быть установлены на портал.

Быстрый поиск поиск по всем справочным материалам. Иногда с его помощью можно быстрее получить ответ.

Расскажите, что вы искали и не нашли - форма для отправки запроса на разъяснение тех или иных возможностей сервиса Битрикс24.

Для администраторов в самом низу будет отображаться ещё и форма для обращения в поддержку компании "1С-Битрикс".

После клика по названию статьи, откроется сама статья. Есть несколько особенностей:

  1. Для изучения функционала бывает полезно одновременно с чтением повторять действия, описанные в статье. Чтобы сделать это воспользуйтесь ссылкой Открыть в новой вкладке:

    Статья откроется в новой вкладке, а на самом сервисе Битрикс24 вы сможете повторять действия, описанные в ней.

    Рекомендуется пользоваться этой опцией, так как функционал курсов имеет более широкие возможности, чем Поддержка24.

  2. Вы можете высказать своё отношение к статье с помощью специальных кнопок:

Если вы написали запрос в Поддержку24, то по получению ответа вы будете уведомлены об этом.


Словарь терминов
6 / 401

Каждая программа имеет свои термины, используемые в работе. Чтобы без проблем ориентироваться в учебном курсе, в помощь вам приведен словарь терминов.

  • Авторизация
  • Библиотека документов
  • Бизнес-процесс
  • Битрикс24
  • Веб-мессенджер
  • Визуальный редактор
  • Воронка продаж
  • Гаджет
  • Главная страница
  • График отсутствий
  • Живая лента
  • Задачи
  • Компания
  • Контакт
  • Лид
  • Рабочий день
  • Мгновенные сообщения
  • Обращение
  • Переговорная
  • Планировщик событий
  • Подписка
  • Пользовательские поля
  • Рабочая группа
  • Рабочий стол
  • Рабочий отчет
  • Рассылка
  • Регистрация
  • Рейтинг
  • Роль
  • Сделка
  • Открытые линии
  • Собрания и планерки
  • Событие
  • Справочник
  • Структура компании
  • Тариф
  • Фильтр
  • Центр уведомлений
  • Цепочка навигации
  • Экстранет
  • CalDav
  • CRM
  • RSS-лента
  • Wiki
  • Send&Save
  • Телефония

Термин | Описание
Авторизация | Процесс подтверждения прав доступа к функционалу Битрикс24. Возможен только после регистрации.
Библиотека документов | Раздел Битрикс24, позволяющий организовать коллективный доступ и работу над документами и файлами.
Бизнес-процесс | Процесс обработки документа, для которого задана одна точка входа и несколько точек выхода и последовательность действий (шагов, этапов, функций), совершаемых в заданном порядке и в определенных условиях.
Битрикс24 | Программный продукт в виде сервиса компании "1С-Битрикс", предназначенный для совместной работы. Сервис ориентирован на компании малого и среднего бизнеса.
Веб-мессенджер | Интерактивный инструмент, позволяющий обмениваться мгновенными сообщениями с другими пользователями Битрикс24 и получать информацию о событиях в системе Битрикс 24.
Визуальный редактор | Инструмент, имеющий средства для составления и оформления сообщений, а также позволяющий оценить их визуальное представление до непосредственной отправки.
Воронка продаж | Страница, на которой представлено количественное соотношение всех сделок в CRM на разных стадиях.
Гаджет | Особый программный элемент, выполняющий функцию вывода определенных данных.
Главная страница | Страница, куда выводится текущая информация по событиям в вашей компании.
График отсутствий | Страница, на которой автоматически выводится вся информация об отсутствиях работников на рабочем месте.
Живая лента | Страница, на которой выводятся последние события системы: новости, комментарии, новые файлы, системные события и т.д..
Задачи | Инструмент для организации персональной и групповой работы. Задачи обладают свойствами: контроля по времени, к, приоритету выполнения, ролями и другими.
Компания | Запись в CRM о компании, которая имеет какую-то форму сотрудничества (либо может иметь сотрудничество) с вашей компанией.
Контакт | Запись о личности, с которой было общение по поводу профессиональной деятельности.
Лид | Запись в CRM о какой-либо форме контакта (телефон, e-mail, очная встреча и так далее), которая имеет потенциальную возможность перерасти в сделку.
Мгновенные сообщения | Способ общения сотрудников в Битрикс24, представляющий собой обмен персональными сообщениями.
Обращение | Заявка в техническую поддержку по какому-либо вопросу.
Открытые линии | Способ коммуникации с клиентами компании, посетителями сайта, с помощью которого собираются сообщения из разных каналов (мессенджеры, соцсети) в Битрикс24, распределяются по правилам очереди между сотрудниками и незаметно сохраняются в CRM.
Send&Save | Технология добавления e-mail в события какой-либо сущности CRM.
Переговорная | Помещение в офисе компании для проведения коллективных мероприятий.
Планировщик событий | Функционал Битрикс24, предназначенный для помощи в организации коллективных событий с учетом занятости его участников.
Подписка | Сервис, уведомляющий пользователя о различных событиях в Битрикс24.
Пользовательские поля | Параметры сущностей CRM, создаваемые сотрудниками.
Рабочий день | Панель для учета ежедневого рабочего времени сотрудника.
Рабочая группа | Виртуальное объединение людей для решения или обсуждения общих вопросов, целей и задач.
Рабочий стол | Основная (главная) страница Битрикс24.
Рабочий отчет | Запись, охватывающая определенный временной интервал и подтверждаемая руководителем, содержащая информацию о рабочем времени сотрудника, выполняемых и завершенных им задачах.
Рассылка | Присылаемые сотруднику сообщения о событиях в Битрикс24 в соответствии с его подпиской.
Регистрация | Процедура, в результате которой человек становится пользователем Битрикс24 с определёнными правами доступа к определённому объёму функций.
Рейтинг | Характеристика контента, прямо пропорциональная его популярности. Увеличивается путем нажатия сотрудниками кнопки Мне нравится.
Роль | Совокупность прав на действия с сущностями и настройками CRM.
Сделка | Запись о работе с клиентом, компанией по поводу продажи товара или оказания услуги.
Собрания и планерки | Инструмент, автоматизирующий подготовку к собранию, его ведение и контроль за исполнением поставленных на собрании целей, хранение истории, обеспечивающий "прозрачность" всего процесса для руководства.
Событие | Любое изменение в записях: Контакт, Лид, Компания.
Справочник | Список значений параметров, относящихся к той или иной сущности CRM.
Структура компании | Наглядное графическое представление иерархии филиалов, подразделений и отделов компании в виде схемы.
Тариф | Битрикс24, функционал которого настроен на определенные специализированные задачи, связанные со спецификой работы компании.
Телефония | Связь по протоколу IP, присутствующая в Битрикс24. Позволяет звонить на стационарные и мобильные телефоны России, стран СНГ, США и Европы.
Фильтр | Программный компонент, позволяющий из множества элементов выделить те, которые соответствуют определенным параметрам.
Центр уведомлений | Часть веб-мессенджера, показывающая уведомления системы, касающиеся непосредственно текущего сотрудника:
Цепочка навигации или «Хлебные крошки» | Элемент навигации, представляющий собой путь по Битрикс24 от его «корня».
Экстранет | Расширение системы, которое позволяет компании осуществлять конфиденциальную связь с поставщиками, дистрибьюторами и другими внешними пользователями без доступа к внутрикорпоративной информации.
CalDAV | Интернет-стандарт, позволяющий клиентам получать коллективный доступ к информации и осуществлять планирование на удаленном сервере.
RSS-лента | Сервис для сбора информационных RSS-потоков в одном удобном для чтения месте.
Wiki | Раздел проекта, структуру и содержимое которого пользователи могут сообща изменять с помощью инструментов, предоставляемых самой системой.
CRM | Cистема, предназначенная для повышения уровня продаж, оптимизации маркетинга и улучшения обслуживания клиентов. В CRM сохраняется информация о клиентах и история взаимоотношений с ними для последующего анализа результатов.


Видеоматериалы
7 / 401

На странице собраны все видеоматериалы, которые есть в составе учебного курса. Ролики, помеченные как "интерактивные", требуют в ходе просмотра выполнения определённых действий пользователем.

Примечание: Некоторые видеоролики созданы на примере устаревшего интерфейса и постепенно заменяются актуальными. Эти материалы помечены *. Принципиально работа продукта в разных интерфейсах не меняется, но возможны расхождения в названиях команд, расположении кнопок и некоторые другие несовпадения.

Название видеоролика | Длительность, мин:сек | Размер файла, Мб | Относится к уроку
Основные сведения
Настройки двухэтапной авторизации на портале | 2:04 | 49.49 | Подключение пользователем двухэтапной авторизации
Пароли приложений | 2:51 | 55.39 | Пароли приложений
Видеозвонки | 3:45 | 97.14 | Видеозвонки
Пульс компании. Панели | 4:28 | 96.04 | Пульс компании
Переключатель Люди-Компания. Параметры пульса | 3:02 | 65.93 | Пульс компании
Битрикс24.Network | 3:29 | 36.5 | Битрикс24.Network
Сообщения | 5:41 | 80.47 | Сообщения
Комментарии. Дополнительные виды сообщений | 3:27 | 59.7 | Работа с комментариями к сообщению
Отчет по рабочему времени | 3:40 | 65.75 | Отчет по рабочему времени
Мгновенные сообщения
Бизнес-чат: Панели на странице. Настройки | 4:27 | 91.17 | Внешний вид
Новый чат. Форматирование текста. Работа с файлами | 6:34 | 125.94 | Диалоги (чаты)
Демонстрация экрана | 1:58 | 65.13 | Демонстрация экрана
Десктопное приложение Битрикс24 | 5:39 | 126.47 | Десктопное приложение Битрикс24
Мобильное приложение Битрикс24 | 3:05 | 82.72 | Мобильное приложение Битрикс24
Интеграция с почтой
Создание бесплатного почтового ящика | 1:50 | 26.12 | Создание бесплатного почтового ящика
Компания
График отсутствий | 3:16 | 67.84 | График отсутствий
Рабочие отчёты | 3:36 | 67.94 | Рабочие отчёты
Подключение папки как сетевого диска в ОС Windows | 4:47 | 100.23 | Работа с документами в ОС Windows
Общий диск
Мой Диск | 4:52 | 98.03 | Мой Диск
Интерфейс работы с документами | 2:31 | 50.39 | Интерфейс и инструменты работы с документами
Инструменты работы с документами | 2:18 | 40.6 | Интерфейс и инструменты работы с документами
Создание и редактирование папок и файлов | 3:33 | 52.83 | Создание и редактирование папок и файлов
Удаление и восстановление папок и файлов | 3:47 | 66.69 | Удаление и восстановление папок и файлов
Дополнительные операции с документами | 3:31 | 72.36 | Дополнительные операции с документами
CRM
Аналитические отчеты в CRM | 3:13 | 72.36 | Аналитические отчеты по сделкам
1C-трекер | 4:03 | 12.1 | 1С-трекер
Универсальные списки
Пример настройки универсального списка | 4:31 | 10.65 | Пример настройки Универсального списка
Типы полей универсального списка | 3:24 | 10.05 | Пример настройки Универсального списка
Бизнес-процессы
Выполнение бизнес-процессов | 3:33 | 60.93 | Бизнес-процессы
Работа с бизнес-процессами организации | 3:00 | 53.62 | Бизнес-процессы
Дизайнер бизнес-процессов | 5:08 | 77.94 | Визуальный конструктор
Создание шаблона последовательного бизнес-процесса | 2:13 | 28.7 | Создание шаблона последовательного бизнес-процесса
Создание шаблона бизнес-процесса со статусами | 4:20 | 73.4 | Создание шаблона бизнес-процесса со статусами
Общая схема работы бизнес-процесса со статусами | 3:15 | 41.02 | Создание шаблона бизнес-процесса со статусами
Собрания и планерки
Создание собрания | 4:07 | 75.48 | Создание собрания
Ведение собрания | 2:08 | 39.02 | Ведение собрания
Управление почтой | 4:34 | 82.4 | Управление почтой
Примеры использования
Пример создания отчета | 4:17 | 59.4 | Отчёты

Название видеоролика | Длительность, мин:сек | Относится к уроку
Основные сведения
Как зарегистрировать свой сервис Битрикс24 * | 2:14 | Как зарегистрировать свой сервис
Работа с пользователями * | 2:58 | Приглашение, авторизация и увольнение пользователей
Уровни доступа * | 1:08 | Уровни доступа
Работа с формами отчетов * | 3:30 | Формы отчётов
"Моя страница" в Битрикс24 * | 1:17 | Моя страница
Инструменты поиска * | 2:39 | Поиск
Инструменты Битрикс24
Рабочий день * | 4:16 | Инструмент Рабочий день
Задачи
Список задач * | 9:08 | Список задач
Работа с задачами * | интерактивный видеоролик | Просмотр задачи
Создание задачи * | интерактивный видеоролик | Создание задачи
Работа с шаблонами задач * | интерактивный видеоролик | Шаблоны задач
Экспорт задач * | интерактивный видеоролик | Экспорт задач
Пример работы с задачами * | интерактивный видеоролик | Пример работы с задачами
Работа с конструктором отчетов * | 6:04 | Конструктор отчетов
Календари
Работа с календарями * | 3:08 | Календари
События и задачи * | 7:19 | События и задачи
Внешние соединения * | интерактивный видеоролик | Внешние соединения
Подключение к Битрикс24 внешних календарей * | интерактивный видеоролик | Внешние соединения
Соединение календарей сервиса с MS Outlook * | интерактивный видеоролик | Внешние соединения
Экспорт календарей Битрикс24 (iCal) * | интерактивный видеоролик | Внешние соединения
Соединение календарей сервиса с мобильными устройствами * | интерактивный видеоролик | Внешние соединения
Группы
Создание групп * | интерактивный видеоролик | Все группы
Работа с группами * | интерактивный видеоролик | Работа с группами
Вступление в группу * | интерактивный видеоролик | Работа с группами
Отправка сообщений в группе * | интерактивный видеоролик | Работа с группами
Выход из группы * | интерактивный видеоролик | Работа с группами
Функционал группы * | интерактивный видеоролик | Функционал группы
Поиск * | интерактивный видеоролик | Функционал группы
Управление группами * | интерактивный видеоролик | Управление группами
Wiki
Общий вид вики-страницы * | интерактивный видеоролик | Основные понятия
Создание первой страницы в Wiki * | интерактивный видеоролик | Создание страницы
История редактирования * | интерактивный видеоролик | Редактирование страницы и история
Работа с категориями в Wiki * | интерактивный видеоролик | Категории
Сотрудники
Сотрудники * | интерактивный видеоролик | Сотрудники
Поиск по алфавиту * | интерактивный видеоролик | Сотрудники
Экспорт в Excel * | интерактивный видеоролик | Сотрудники
Синхронизация с Outlook * | интерактивный видеоролик | Сотрудники
Синхронизировать CardDAV * | интерактивный видеоролик | Сотрудники
Структура компании
Просмотр структуры компании * | интерактивный видеоролик | Структура компании
Редактирование структуры компании * | интерактивный видеоролик | Структура компании
Документы
Создание и удаление папки * | интерактивный видеоролик | Работа с документами в веб-браузере
Загрузка документов * | интерактивный видеоролик | Работа с документами в веб-браузере
Изменение свойств документа * | интерактивный видеоролик | Работа с документами в веб-браузере
Публичные ссылки * | интерактивный видеоролик | Работа с документами в веб-браузере
Запуск бизнес-процесса * | интерактивный видеоролик | Работа с документами в веб-браузере
История изменений * | интерактивный видеоролик | Работа с документами в веб-браузере
Удаление документов * | интерактивный видеоролик | Работа с документами в веб-браузере
Работа с корзиной * | интерактивный видеоролик | Работа с документами в веб-браузере
Подключение папки как сетевого диска * | интерактивный видеоролик | Работа с документами в ОС Windows
Подключение папки с помощью мастера добавления сетевого подключения * | интерактивный видеоролик | Работа с документами в ОС Windows
Отсоединение папки, подключенной как сетевой диск * | интерактивный видеоролик | Работа с документами в ОС Windows


Основные сведения
8 / 401

В главе приводятся основные сведения о сервисе Битрикс24, которые необходимо знать пользователю перед началом работы:

  • Как зарегистрировать свой сервис;
  • Структура страниц сервиса;
  • Как настроить портал;
  • Как пользователю зарегистрироваться и авторизоваться;
  • Система прав доступа к информации;
  • Поиск;
  • Как посылать сообщения сотрудникам;
  • Работа с формами отчета;
  • Как учитывается рабочее время сотрудников;
  • О рейтингах;


Как зарегистрировать свой сервис
9 / 401

Регистрация собственного портала возможна через сайты bitrix24.net и bitrix24.ru, через социальную сеть Битрикс Нетворк.

Сервис Битрикс24 доступен во многих доменных зонах, например: *.bitrix24.ru, *.bitrix24.com, *.bitrix24.de, *.bitrix24.ua, *.bitrix24.eu, *.bitrix24.by, *.bitrix24.kz и др. с соответствующими языками интерфейса. Возможно использование сервиса как по бесплатной, так и по платной схеме лицензирования.

Регистрация на сайтах

Видеоролик "Как зарегистрировать свой сервис" через сайт bitrix24.ru

В ролике внешний вид форм - устаревший, но процесс в целом соответствует действительности.

Интерактивный видеоролик (требуется выполнение действий пользователем). Продолжительность 2 минуты 14 секунд. Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если нет возможности прослушать, то с помощью кнопки СС можно включить текстовое сопровождение.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Для регистрации своего сервиса необходимо на любой странице указанных сайтов воспользоваться формой заявки по кнопке Начать бесплатно:

Внимание! Внимательно подходите к выбору e-mail для регистрации. Не рекомендуется использовать личный адрес, так как:
  • Все администраторские уведомления сотрудникам и пользователям экстранета будут рассылаться с этого адреса.
  • Пользователь, чей e-mail был использован в качестве заявки на приглашение, получает максимально возможные права на управление порталом. Он становится администратором. Все остальные пользователи получают минимальные права. Если этот пользователь будет уволен из компании, то он "уйдёт" вместе с этими правами. Замена e-mail администратора возможна, но только один раз. (См. раздел 5.)
Рекомендуется завести отдельный, специально для этого предназначенный адрес электронной почты. Такой, чтобы его можно было при необходимости передать другому сотруднику, который будет выполнять обязанности администратора портала.

По почтовому адресу, указанному при регистрации будет отправлено письмо с кодом подтверждения. Перейдите по ссылке из письма, чтобы завершить регистрацию и начать работать с Битрикс24. Далее откроется форма регистрации в которой вам нужно заполнить данные необходимые для создания портала:

Система проверит введённые данные и при правильном заполнении создастся ваш облачный корпоративный портал.

Регистрация портала через Битрикс24.Network

Если вы уже состоите в сети Битрикс24.Network, то регистрация нового портала доступна вам через сеть.

Все дальнейшие действия по регистрации аналогичны регистрации через сайт www.bitrix24.ru.

Первый вход

Для первого входа необходимо ввести использовавшийся для заявки адрес электронной почты и созданный пароль:

Примечание: На одном и том же портале можно использовать разные языки интерфейса для разных пользователей. Для этого после входа на портал пользователь должен выбрать нужный ему язык интерфейса в низу страницы:

При первом входе как администратора, так и обычного пользователя вы увидите окно гида, рассказывающее о сервисе и его возможностях.

Примечание: Для тарифного плана Компания доступен функционал Собственный домен, когда у вашего корпоративного портала будет собственный домен, а не домен третьего уровня, принадлежащий сервису Битрикс24. То есть не abcd.bitrix24.ru, a abcd.ru (если, естественно, этот домен свободен).


Структура страниц портала
10 / 401

Структура страниц портала одинакова на всех страницах:

  • 1 - Кнопка вызова карты проекта.
  • 2 - Название портала.
  • 3 - Панель поиска.
  • 4 - Панель Рабочий день.
  • 5 - Меню Личного раздела.
  • 6 - Инструмент Поддержка24.
  • 7 - Левая колонка: основное меню. Инструмент для перехода по страницам портала. Разделы меню можно настроить, свернуть и развернуть для более удобной работы.
  • 8 - Локальное меню выбранной страницы. В некоторых разделах появляются команды этой страницы. Может отсутствовать на некоторых страницах.
  • 9 - Гаджет для приглашения сотрудников.
  • 10- Панель чата и уведомлений.
  • 11 - Гаджет Пульс компании.
  • 12 - Название открытой страницы с некоторыми инструментами управления страницы (фильтр, некоторые команды).
  • 13 - Зона гаджетов.
  • 14 - Информационная зона. В этом месте выводится вся информация на портале.

Примечание: На внутренних страницах портала зоны 9, 11, 13 отсутствуют.

Меню

Меню - инструмент для навигации по порталу. В Битрикс24 навигацию можно осуществлять разными способами. Если вы привыкли к классическому меню, то воспользуйтесь кнопкой 1 для вызова карты сайта. Левое меню можно условно назвать "интеллектуальным" за его способность подстраиваться под потребности и привычки пользователя. Меню настраивается сотрудником под себя, у каждого будет свой индивидуальное меню, в котором есть только то, что нужно ему. Вплоть до того, что можно сделать любую страницу портала Главной.

Для настройки меню нажмите на Настроить меню и воспользуйтесь командами:

  • Настроить меню - позволяет перемещать пункты меню, скрывать их, либо сделать какую-то из страниц главной, вместо Живой ленты. Для администраторов доступно добавление либо удаление некоторых страниц у всех сотрудников сразу.
  • Свернуть меню - меню свернётся влево, освободив на 20% пространство окна браузера для информации на портале.
  • Удалить текущую страницу из левого меню - удаляет открытую в данный момент страницу. Доступно не для всех пунктов меню.
  • Добавить ссылку - добавление любой страницы портала в меню. По этой команде открывается окно, в котором нужно добавить название ссылки и саму ссылку.
  • Вернуть меню по умолчанию - возврат меню в исходный вид. При этом возможен выбор одного из трёх предстановленных вариантов меню: Коммуникации (главная - Живая лента), CRM (главная - СтартCRM), Задачи (главная - список Задач). Выбор предустановленного варианта доступен только администраторам портала.

Добавить новый пункт в меню можно несколькими способами. Самый простой: перейти на нужную страницу и кликнуть на звёздочку правее названия страницы:

Однако такой способ работает не для всех страниц. Например, руководитель отдела хочет добавить в меню страницу со списком задач, которые он поручил сотрудникам. Такая ссылка есть в локальном меню и имеет сложный вид, который запомнить невозможно:

Скопируйте этот адрес из адресной строки браузера, воспользуйтесь командой Добавить ссылку в Настроить меню для добавления ссылки и её названия:

Новый пункт будет добавлен.

Администратор портала может настроить меню для всех сотрудников:

  • Выбором предустановленного варианта.
  • С помощью добавленных пунктов меню - всё, что добавил администратор, можно установить для всех сотрудников.

Пункты, которые редко используются, рекомендуется скрывать под Ещё.

Примечание: Если у вас были ранее настроены пункты в Избранном, то все они сохраняться и появятся в новом меню.

Локальное меню

В отличие от основного меню, которое единое на весь портал, локальное меню меняется в зависимости от раздела. Оно также может быть отредактировано под потребности пользователя: порядок следования пунктов может быть изменён, сами пункты могут быть скрыты или, наоборот, вынесены. Пункт локального меню, вынесенный на первую позицию, станет главной страницей этого раздела.

Под ссылкой Ещё прячутся другие пункты локального меню, если они не уместились в строке, и команды для настройки верхнего меню и возврата исходного вида меню.

Приглашение сотрудников

Приглашение сотрудников не администратором портала доступно если в настройках портала включена опция Разрешить всем приглашать пользователей на портал. В этом случае виден соответствующий гаджет и под меню появится кнопка Пригласить сотрудников +.

Название открытой страницы

В этой зоне выводится не только название, но и дополнительные команды и кнопки, которые принадлежат тому или иному инструменту, открытому в самой информационной зоне. Например, в Задачах выводятся поиск и команды для создания задач:


Приглашение, авторизация и увольнение пользователей
11 / 401
Видеоролик о том, как работать с пользователями

Интерактивный видеоролик (требуется выполнение действий пользователем). Продолжительность 2 минуты 58 секунд. Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если нет возможности прослушать, то с помощью кнопки СС можно включить текстовое сопровождение.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Приглашение сотрудников

Пригласить сотрудника самым простым способом можно с помощью кнопки Пригласить сотрудников. По этой команде откроется форма добавления сотрудника:

В этой форме можно зарегистрировать на портале внешнего пользователя (либо добавить уже имеющегося сотрудника) сразу в нужные группы или в структуру компании.

На закладке Пригласить по e-mail введите адреса электронной почты нужных сотрудников, введите текст приглашения и нажмите Пригласить. Приглашённые получат письмо.

Перейдя по указанной в письме ссылке пользователю нужно будет заполнить форму с указанием персональных данных. После чего сотрудник получит доступ к корпоративному порталу.

Примечание: при необходимости можно послать вторичное приглашение со страницы Компания > Сотрудники > Приглашённые. Если приглашенный сотрудник, еще не авторизовывался на портале, то его можно просто удалить. Для этого необходимо в списке приглашенных сотрудников, удалить нужного пользователя:

На закладке Быстрая регистрация администратор портала может разрешить самостоятельную регистрацию на портале для пользователей. В этом случае пользователи смогут сами регистрироваться на портале. Однако администратор имеет возможность заблокировать вступление таких пользователей.

Авторизация на портале

Для авторизации нужно ввести в адресной строке браузера адрес вашего портала, откроется форма авторизации:

Примечание: Для авторизации на портале через социальные сервисы необходимо предварительно заполнить соответствующие поля в разделе Социальные сети. После связи аккаунта пользователя портала с аккаунтами социальных сервисов будет доступна авторизация с помощью Twitter, Facebook, Google и LiveID.

После привязки аккаунта к социальной сети возможны проблемы с авторизацией на вашем портале. В первую очередь, проверьте, верный ли аккаунт социальной сети вы используете. Если у вас несколько аккаунтов в одной соц.сети, которая привязана к порталу, то попробуйте использовать другой.

Если используется правильный аккаунт, то самая частая причина ошибки - некорректная привязка портала к вашему аккаунту. В этом случае выполните следующие действия:

  • Авторизуйтесь в Битрикс24.Network, используя привязанную сеть.
  • Перейдите в свой профиль и отвяжите аккаунт этой социальной сети:

  • Разавторизуйтесь в Битрикс24.Network.
  • Авторизуйтесь заново с использованием нужной социальной сети.

Если вы забыли пароль, воспользуйтесь ссылкой ЗАБЫЛИ ПАРОЛЬ?. По этой ссылке откроется форма, в которой нужно указать email, который был использован для входа на портал Битрикс24. На указанный адрес придёт письмо с контрольной строкой и регистрационными данными. (Письмо может попасть в папку Спам вашего почтового клиента.) Пройдя по ссылке заполните форму для изменения старого пароля на новый.

Увольнение сотрудников

Число приглашённых на портал (включая администратора) не может превышать число пользователей вашего тарифного плана. Если вы набрали полное число пользователей, а потом кто-то уволился и на его место пришёл другой, то прежнего сотрудника нужно "уволить" с портала. При этом сама учетная запись прежнего сотрудника останется в списках пользователей (хотя по ней и нельзя будет зайти и работать на портале). Также сохраняются все данные уволенного пользователя: файлы, сообщения, задачи и прочее.

Уволить кого-либо может только сотрудник с правами администратора.

Самый простой способ уволить сотрудника - это перейти на страницу Компания > Сотрудники, в общем списке найти нужного сотрудника и "уволить" его с помощью контекстного меню:

Возможности удалить сотрудников из списка уволенных нет, так как за каждым аккаунтом закреплены задачи, сообщения, файлы. После увольнения сотрудника все они сохраняются на портале: они могут содержать важную информацию для компании.


Двухэтапная авторизация (OTP)
12 / 401

В целях защиты бизнеса от злоумышленников в продукты «1C-Битрикс» встроена дополнительная защита - с использованием двухэтапной авторизации.

Двухэтапная (двухфакторная) авторизация - это два фактора защиты. Первый - это основной пароль пользователя. Второй фактор защиты - это секретный код, который пользователь получает в своем мобильном телефоне (через Bitrix OTP, приложения для OTP по стандарту HOTP, а также аппаратные устройства).

Современные угрозы:

  • Похищение логинов и паролей шпионскими программами и с помощью бот-сетей.
  • Подбор паролей по словарю.
  • Похищение с помощью вирусов паролей, запомненных в браузере.

Система одноразовых паролей дополняет стандартную систему авторизации и позволяет значительно усилить систему безопасности продуктов «1С-Битрикс».

При каждой авторизации пользователь получает новый секретный код, что исключает возможность его получения злоумышленниками. При включении системы OTP в продукте «1C-Битрикс» можно авторизоваться только с использованием дополнительного одноразового пароля.

В продуктах «1C-Битрикс» поддерживаются два алгоритма генерации одноразовых паролей:

  • по счетчику (HMAC-Based One-time Password, HOTP) - код будет доступен до тех пор, пока пользователь не запросит новый;
  • по времени (Time-based One-time Password, TOTP) - код будет доступен в течение 30 секунд с момента его получения, после чего он автоматически обновится.

Внимание! Перед подключением двухэтапной (двухфакторной) авторизации проверьте правильность установленного времени и часового пояса в вашем мобильном устройстве.

Перечень некоторых совместимых приложений:

Устройство | Приложение | Примечания
Apple iOS | Bitrix24 OTP Google Authenticator FreeOTP Authenticator | iOS 6.0 и выше. По времени (TOTP) и по счетчику (HOTP). iOS 5.0 и выше. По времени (TOTP) и по счетчику (HOTP). iOS 7.0 и выше. По времени (TOTP) и по счетчику (HOTP).
Google Android | Bitrix24 OTP Google Authenticator FreeOTP Authenticator | Android 3.0 и выше. По времени (TOTP) и по счетчику (HOTP). Android 2.2 и выше. По времени (TOTP) и по счетчику (HOTP). Android 4.0 и выше. По времени (TOTP) и по счетчику (HOTP).
J2ME | Google Authentification in Java Mobile, j2me Google Authenticator for J2ME phones | Для мобильных с J2ME. По времени (TOTP), ручной ввод секретного ключа. Для мобильных с J2ME на основе LWUIT-GUI. По времени (TOTP), ручной ввод секретного ключа.
Palm OS | Google Authenticator for Palm OS | По времени (TOTP), ручной ввод секретного ключа.
MS Windows Phone | Authenticator | MS Windows Phone 7.5 и выше. По времени (TOTP).
MS Windows | WinAuth | MS Windows 7|8, .NET Framework 4. По времени (TOTP), портативность, защита приложения паролем.


Подключение пользователем двухэтапной авторизации
13 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Настройки двухэтапной авторизации на портале

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Для включения двухэтапной авторизации в облачном сервисе Битрикс24 и Битрикс24 в коробке необходимо перейти на страницу Безопасность (Моя страница > Безопасность) профиля пользователя:

Далее на специальной странице Безопасность, следуя простой инструкции, подключается двухэтапная авторизация:

Для продолжения подключения двухэтапной авторизации понадобится приложение Bitrix24 OTP или аналоги.

Внимание! Перед подключением двухэтапной авторизации проверьте правильность установленного времени и часового пояса в вашем мобильном устройстве.

После подключения двухэтапной авторизации пользователь может ее отключить на странице Безопасность либо Бессрочно, либо на срок от 1 до 10 дней.

Примечание: Опция отключения двухэтапной авторизации будет доступна пользователю, если администратор портала не включил принудительное использование двухэтапной авторизации для всех на портале.

Также пользователь может авторизовать другой телефон, старая связка авторизации с одноразовым паролем при этом будет автоматически деактивирована.

Примечание: В случае, когда пользователь не может воспользоваться своим устройством для входа на сайт, можно просто на время отключить двухэтапную авторизацию для него. Для этого обратитесь к администратору.


Резервные коды
14 / 401

Функционал резервных кодов используется для доступа на сайт, в тех случаях, когда нет возможности использовать устройство двухэтапной авторизации. Например, при утере брелка или телефона с приложением.

Примечание: Для включения функционала резервных кодов обратитесь к администратору сайта.

Для получения списка резервных кодов необходимо перейти в раздел Моя страница и перейти по ссылке Резервные коды:

Где можно их Распечатать, Сохранить в текстовый файл или Сгенерировать новые коды:

Действительны только коды, созданные последними.


Мобильное приложение Bitrix24 OTP
15 / 401

Компания «1С-Битрикс» разработала новое мобильное приложение Bitrix OTP для поддержки двухэтапной (двухфакторной) авторизации. Приложение генерирует секретные коды для входа на порталы и сайты под управлением «Битрикс24» и «1С-Битрикс» и позволяет обойтись без использования аппаратных устройств (например, Aladdin eToken PASS) или соответствующих программных аналогов.

Новое мобильное приложение Bitrix OTP работает быстро и не требует ввода избыточных данных. Данные для подключения в приложение можно ввести как вручную, так и автоматически с использованием QR-кода.

Подключение мобильного устройства

Внимание! Перед подключением двухэтапной (двухфакторной) авторизации проверьте правильность установленного времени и часового пояса в вашем мобильном устройстве.

  1. Для начала необходимо скачать приложение Bitrix24 OTP:

    Ссылки для скачивания:

    Примечание: Подключить двухэтапную (двухфакторную) авторизацию на портале или сайте можно с помощью других программных средств.

  2. После запуска приложения выбирается удобный способ получения кода:
    • Сканировать QR-код

      Для того, чтобы сканировать код, поднесите камеру мобильного телефона к монитору с картинкой QR-кода на странице подключения OTP и подождите, пока приложение сканирует код.

    • Ввести данные вручную

      Если вам не удалось сканировать код, выберите ручной ввод данных.

      При ручном вводе необходимо указать:

      • Адрес сайта вида www.site.ru или портала Битрикс24 вида example.bitrix24.ru;
      • E-mail, с которым был зарегистрирован пользователь на сайте или портале;
      • Секретный ключ, который указан на картинке (можно не обращать внимания на пробелы);
      • выбрать тип ключа:
        • по времени - означает, что код будет доступен в течение 30 секунд с момента его получения, после чего он автоматически обновится;
          • или
        • по счетчику - означает, что код будет доступен до тех пор, пока пользователь не запросит новый.

        Внимание! Тип ключа, используемый на проекте, зависит от настроек администратора.

  3. Скопируйте этот код в буфер обмена, если вход осуществляется c помощью мобильного устройства:

    Или введите полученный код на странице подключения в браузере:

    Внимание! Если используется тип ключа по счетчику, то нужно будет ввести второй код подтверждения, нажав соответствующую кнопку.

  4. Двухэтапная авторизация на сайте или портале успешно подключена.

Авторизация с помощью приложения

Приложение запоминает аккаунты пользователей продуктов «1С-Битрикс». Для авторизации на сайте или портале необходимо:

  • Ввести в поле авторизации логин и пароль:

  • Получить одноразовый код для входа на сайт или портал, выбрав аккаунт из списка в приложении:

  • Ввести полученный одноразовый код в соответствующее поле:

    Примечание: Опция Запомнить одноразовый пароль позволяет сохранять авторизацию до тех пор, пока не нажата кнопка Выход из учетной записи, либо на срок, согласно настройкам прав группы пользователей.

  • Все, авторизация на сайте или портале успешно произведена.

Внимание! При авторизации через соцсети будет запрашиваться OTP.

Для редактирования или удаления аккаунта из списка приложения нужно смахнуть влево нужный пункт:

Внимание! Все генеририруемые приложением Bitrix24 OTP коды доступа являются одноразовыми, повторное их использование для авторизации невозможно.


Настройки для администратора «Битрикс24»
16 / 401

Система OTP включается и отключается на портале администратором сразу для всех пользователей. Включить эту опцию администратор не сможет пока не настроит OTP для самого себя.

Для включения двухэтапной авторизации для всех на портале нужно перейти в раздел Настройки портала (Настройки > Настройки портала) и включить опцию Требовать подключение двухэтапной авторизации у всех сотрудников.

В опции Укажите период, в течение которого все сотрудники должны будут включить двухэтапную авторизацию указывается максимальный период, после которого не подключившие двухэтапную авторизацию пользователи не смогут зайти на портал. В таком случае нужно будет обратиться к администратору портала.

Администратор может отключить двухэтапную авторизацию в профиле отдельного сотрудника, если это необходимо, Бессрочно либо на срок от 1 до 10 дней.


Пароли приложений
17 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Пароли приложений

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

При включенной двухэтапной (двухфакторной) авторизации нужно ввести специальный одноразовый код подтверждения. Некоторые приложения (MS Outlook, XMPP/Jabber-клиенты и т.п) или внешние службы, с которыми нужно работать под аккаунтом портала, не поддерживают одноразовые коды подтверждения. Поэтому для таких случаев используются пароли приложений.

Примечание: Только для облачного сервиса Битрикс24 и «Битрикс24 в коробке», для продуктов «1С-Битрикс: Управление сайтом» функционала Пароли приложений нет.

Пароли приложений можно создать для:

  • Календаря - синхронизация событий календаря, общий список запланированных дел.
  • CRM - возможность настроить обмен данными с другими программами.
  • Списка сотрудников - синхронизация списка сотрудников с телефонной книгой в мобильном телефоне или с другими программами.
  • Документов - для редактирования документов некоторые версии MS Office требуют логин и пароль.
  • Сервисов Microsoft Outlook - настройка синхронизации календаря, контактов или задач в MS Outlook.
  • Клиентов XMPP/Jabber - для использования в Jabber-клиентах, чтобы общаться внутри корпоративного портала.
  • Десктопного приложения - для безопасной работы с десктоп-приложением.
  • Мобильного приложения - для безопасной работы с мобильным приложением.

Для получения паролей приложений нужно:

  1. Зайти на страницу Моя страница:

  2. Перейти по ссылке Пароли приложений, выбрать необходимое приложение, добавить описание (необязательно) и нажать кнопку Получить пароль:

  3. В появившемся окне скопировать или перепечатать 16-значный пароль в окно авторизации нужного приложения (логин при этом используется текущий от портала):

    Внимание! По правилам безопасности пароль не может храниться в открытом виде, поэтому он доступен только в момент его получения. Не закрывайте окно, пока пароль не будет скопирован или введен в соответствующем поле.

  4. После чего в списке появится запись о выданном пароле, когда последний раз была авторизация и с какого ip был вход:

  5. Для удаления ненужного пароля нужно нажать на кнопку Удалить.

Примечание: Все сгенерированные пароли приложений действительны бессрочно. Неиспользуемые пароли можно удалить в целях безопасности.


Решение проблем, связанных с OTP
18 / 401

Использование OTP может создать проблемы в случае:

  • Утери телефона
  • Сбоя в настройках времени на телефоне
    •

    Утеря телефона

    В случае утери телефона для доступа на портал вам помогут Резервные коды. К сожалению, наличием резервных кодов пользователи озадачиваются только тогда, когда телефон уже утерян.

    Если утерян телефон у обычного сотрудника, то администратор может отменить ему ОТП для входа на портал на время, нужное для настройки нового телефона. Для настройки нового телефона нужно воспользоваться ссылкой У меня поменялся телефон:

    Если утерян телефон у администратора, то следует действовать так:

    • Если есть второй администратор, то он может снять на время ограничение по OTP для первого в его профиле.
    • Обратиться в техподдержку компании Битрикс и указать свой портал Битрикс24, логин и пароль без одноразового кода. Одноразовый доступ будет отключён для этого портала.

      Примечание: Этот вариант действует только для платных тарифов!

    Внимание! Если у вас бесплатный тариф, то в случае одного администратора на портале у вас есть все шансы потерять портал и всю информацию на нём. Будьте очень внимательны при работе с включённым OTP!

    Сбой в настройках времени

    Внимание! ОТР допускает расхождение времени на устройстве со временем сервера не более одной минуты.

    Одноразовые пароли создаются на основе времени, следовательно, при расхождении времени на вашем устройстве и на сервере Битрикс24 или сайта вы не получите верного кода доступа. Что делать в случае ошибки доступа?

    Если вы пользуетесь приложением Bitrix OTP или FreeOTP:

    Ваш телефон на Android

    1. Перейти в Настройки > Дата и время.
    2. Проверить установлено ли автоматическое получение времени (Automatic date & time).
    3. Проверить установлено ли автоматическое получение часового пояса (Automatic time zone). В некоторых ситуациях автоматическое получение часового пояса использовать проблематично. В этом случае ни в коем случае нельзя переводить время вручную, достаточно снять флажок автоматического получения часового пояса и выбрать правильный часовой пояс самостоятельно.

    Ваш телефон на iOS

    1. Перейдите в меню Настройки > Основные > Дата и время > Часовой пояс.
    2. Введите название вашего или ближайшего к вам города в поисковой строке. После того как вы выберете город, на вашем смартфоне автоматически определится часовой пояс и установится дата и время. Если автоматическая синхронизация не работает:
      • Проверьте подключение к интернету.
      • В меню Настройки > Основные > Дата и время переместите переключатель Автоматически вправо.

    Бывает так, что правильный город не соответствует правильному часовому поясу, например, если ваш гаджет не получает обновлений, тогда необходимо выбрать город соответствующий правильному часовому поясу. В случае с Калининградом, это может быть, например, Иерусалим.

    Если вы пользуетесь Google Authenticator - просто запустите ручную синхронизацию времени в приложении (Settings > Time correction > Sync Now).

    Если вы используете другие приложения, то проверьте время и часовой пояс и настройте их. Главное правило для любого приложения: время, установленное при настройке OTP не должно меняться вручную.

    Примечание: При работе с коробочной версией Битрикс24 или с сайтом на основе «1С-Битрикс: Управление сайтом» нужно сверять время на телефоне с временем на вашем сервере.

    При работе на облачном портале Битрикс24 есть возможность сверки времени вашего устройства и времени сервера Битрикс24: перейдите в телефоне по адресу: http://www.1c-bitrix.ru/buy_tmp/otp.php. Там будет правильное время сервера (Real time) и время полученное с телефона. Если вы увидите что время не совпадает, то возвращайтесь к настройкам времени и проводите её заново.

    На иллюстрации выше: значение Real time отличается от значения на телефоне на 1 час и 29 секунд, ОТР работать не будет.


Уровни доступа
19 / 401

Корпоративный портал - система с разным уровнем прав доступа. И это логично. Если, например, производственные обязанности сотрудника не включают в себя работу с бухгалтерскими документами, то и доступ ему к таким документам будет излишним.

Для разграничений прав доступа к разным страницам и разделам портала создана система прав. Реализуется она через группы сотрудников, которыми заведует Администратор портала. Имеются группы:

  • Сотрудники - самая массовая и самая низкая по уровню прав группа. Не может выполнять часть операций в разделах, имеющих значение для всей компании. Например, не могут изменять рабочее время компании или подразделения. Все приглашенные при регистрации попадают в эту группу.
  • Руководитель - группа для руководителей компании. Основное отличие от сотрудников в том, что руководитель видит все документы на портале, все задачи. Этот уровень прав сотрудник получает, если через Структуру компании он назначен руководителем какого-то подразделения.
  • Администратор корпоративного портала - пользователь, обладающий правами на все, что есть на портале. Для получения этого уровня прав нужно поставить флажок в профиле пользователя.

Такая система прав позволяет организовать гибкую систему доступа к информации на корпоративном портале.

Ограничение по функциональным обязанностям

На временной или постоянной основе можно организовать доступ к документам при организации групповой работы.

Необходимо различать понятие группы сотрудников корпоративного портала как технический термин и рабочей группы как людей, выполняющих определённую задачу в рамках портала.

Группа сотрудников – это технический термин и используется только в рамках настройки работы корпоративного портала.

Присоединение к той или иной группе сотрудников и исключение из нее – это привилегия администратора портала. Присоединение к группе дает определенные права по работе в портале в целом.

Рабочая группа - это организационный, производственный термин и используется при организации работы компании.

Сотрудник всегда может узнать к какой рабочей группе (группам) он относится. Присоединение к Рабочим группам может быть осуществлено в добровольном, после согласия пользователя, порядке. Присоединение к группе дает права только на работу с документами и сервисами данной группы. Для решения какой-либо производственной задачи, организатор создает группу со статусом закрытая. После этого, все документы, обращающиеся внутри группы, станут видны только участникам группы. И никому другому.

Видеоролик "Уровни доступа"

Интерактивный видеоролик (требуется выполнение действий пользователем). Продолжительность 1 минута 8 секунд. Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если нет возможности прослушать, то с помощью кнопки СС можно включить текстовое сопровождение.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».


Формы отчётов
20 / 401
Видеоролик "Как работать с формами отчётов"

Интерактивный видеоролик (требуется выполнение действий пользователем). Продолжительность 3 минуты 30 секунд. Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если нет возможности прослушать, то с помощью кнопки СС можно включить текстовое сопровождение.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Описанный здесь формат представления данных и меню действий характерен для таких страниц и разделов портала, как: Диск, Универсальные списки, Сервисы, CRM.

Разберем формат представления на примере пункта Список контактов в CRM:

1 - контекстная панель.
Названия, функции и количество кнопок могут различаться в зависимости от содержания страницы и прав сотрудника.

2 - таблица элементов.
С помощью нее группируется и отображается информация. Названия полей и информация зависят от контента.

Столбец, по данным которого произведена сортировка записей, отмечен темным цветом со стрелкой. Направление стрелки указывает направление сортировки: элементы таблицы расположены по убыванию (стрелка направлена вниз) или по возрастанию (стрелка направлена вверх).

3 - колонка флажков.
Позволяет выбрать один или более элементов для выполнения над ними каких-либо действий с помощью Панели быстрых команд (5). Установка флажка в заголовке таблицы приводит к выбору всех элементов таблицы, отображаемых на данной странице.

4 - колонка Меню действий
Содержит кнопки [image], нажатие на которые приводит к появлению контекстного меню. В этом меню можно выбрать желаемое действие, допустимое над элементом таблицы. Тип допустимых действий определяется содержанием страницы. Так, элементы таблицы страницы Список контактов (CRM > Контакты > Список контактов) предполагают такие действия:

5 - Панель быстрых команд.
Обратите особое внимание на команду Быстрое редактирование в этой панели. С ее помощью можно изменить наиболее важные и часто используемые свойства одновременно всех отмеченных элементов, отображаемых в таблице. Что наиболее важно, это дает возможность правки свойств элементов, не покидая текущей формы отчета (то есть, без переключения в форму редактирования). Рекомендуется пользоваться этими возможностями только для групповых операций небольших по объему параметров.

Действия над отмеченными элементами производятся путем выбора требуемой команды в панели групповых операций, расположенной ниже таблицы. Чтобы применить действие сразу ко всем элементам таблицы нужно установить флажок в поле Для всех.

Настройка списка

Любой список на портале можно настроить по содержанию и по оформлению. Такая настройка называется Представление.

Настройки списка задаются с помощью меню, вызываемого в заголовке Меню действий (4):

Самый простой способ настроить вид списка - это с помощью списка колонок выбрать нужные для отображения. Так как для разных случаев требуется разные колонки, то есть смысл создать несколько Представлений на разные случаи жизни.

Проще всего это сделать с помощью команды Настроить список. По этой команде откроется окно настройки нового представления:

В этом окне добавьте/удалите нужные/ненужные поля в Выбранных колонках, расставьте их в нужном порядке, настройте остальные поля и дайте название новому представлению. Сохранив представление вы сможете пользоваться им в дальнейшем.

В самом списке можно разместить колонки в нужном порядке простым перемещением колонки с помощью указателя мыши:


Моя страница
21 / 401
Видеоролик "Моя страница"

Интерактивный видеоролик (требуется выполнение действий пользователем). Продолжительность 1 минута 17 секунд. Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если нет возможности прослушать, то с помощью кнопки СС можно включить текстовое сопровождение.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Для каждого сотрудника доступна Моя страница, на которой представлена как служебная, так и его личная информация.

В верхней части страницы расположены ссылки на файлы, календари, сообщения и всё остальное, что относится к странице сотрудника.

При просмотре своей страницы ссылки относятся к вам и аналогичны ссылкам в левом меню Мои инструменты.

Просмотр своей страницы

Чтобы открыть свою страницу, используйте пункт Моя страница меню Личной страницы:

пункт Моя страница

Просмотр чужой страницы

Для просмотра данных другого сотрудника нужно воспользоваться ссылкой с его именем. При наведении курсора на такую ссылку, в зависимости от её расположения, во всплывающей подсказке будет отображена краткая информация о пользователе.

После перехода по такой ссылке будет отображена страница выбранного сотрудника:

Редактирование профиля

Для изменения данных профиля сотрудника воспользуйтесь либо командой Изменить личные данные в меню Личной страницы, либо командой Редактировать профиль в Действиях:

Изменение данных профиля

После чего откроется форма редактирования личных данных в которой и производятся все изменения.

Примечание: Поля Права и Подразделения доступны сотруднику с правами Руководитель и выше.

Внимание! Смена пароля пользователя производится через Битрикс24.Network.

Режим администратора

В Битрикс24 по умолчанию пользователь с правами администратора (тот, кому в настройках профиля другой администратор установил флажок в поле Разрешить пользователю администрировать портал) присутствует в качестве обычного сотрудника, т.е. ему не доступны действия, связанные с правами администратора - не видны скрытые группы, в которых они не состоят, чужие задачи, отчеты и т.п.

Если администратору понадобится административные привилегии, их можно включить в профиле пользователя Моя страница с помощью команды Режим администратора в Действиях.

Ссылка "Режим администратора"

При этом на всех страницах портала будет показано оповещение:

Для выхода из режима администратора необходимо нажать соответствующую ссылку этого уведомления.


Фотографии
22 / 401
В разделе Фото располагается личная фотогалерея сотрудника, которая позволяет:
  • сортировать фото по альбомам (с возможностью создания вложенных альбомов);
  • загружать в них фото;

    Примечание: добавление фотографии к своему профилю (загрузка аватара) осуществляется на странице редактирования профиля.
  • делать подписи к фотографиям;
  • при просмотре оставлять отзывы и голосовать за понравившиеся фото;
  • вести обсуждение и т.д.

Важно! В сервисе Битрикс24 недоступно создание общей фотогалерии компании. Можно создавать корпоративные альбомы в рамках рабочих групп.

Примечание: загрузка изображения для рабочей группы осуществляется в форме ее создания/редактирования.


Создание фотоальбома
23 / 401

В фотогалерее есть возможность добавлять альбомы в общий список, а также создавать вложенные альбомы (в другой – корневой альбом), т.е. многоуровневую иерархию альбомов, если это требуется.

  • Создание альбома
  • Создание вложенного альбома
    •

    Создание альбома

    Для добавления альбома в общий список служит ссылка Добавить альбом, расположенная в верхней части страницы.

    Задайте название альбома и по желанию - описание.

    Форма "Свойства альбома"

    По умолчанию все сотрудники сервиса Битрикс24 могут просматривать альбом, но в случае необходимости доступ к нему можно ограничить по паролю. Для этого отметьте опцию Ограничить доступ к альбому по паролю и в поле Пароль введите пароль, по которому будет осуществляться доступ к альбому:

    Форма "Свойства альбома"

    Важно! При загрузке в альбом фотографий автоматически создается запись в Живой ленте на всех сотрудников с данным событием (сам факт создания/редактирования альбома в Живой ленте не отображается). Если при создании альбома или в настройках альбома включить опцию Ограничить доступ по паролю, то в Живой ленте событие о загрузке в него фотографий не отобразится.

    в результате рядом с названием альбома будет отображаться надпись закрытый альбом

    Вид альбома с паролем

    Если другой пользователь захочет просмотреть этот альбом, то ему будет предложено ввести пароль:

    Сообщение о закрытом альбоме

    Примечание: Администратор сервиса Битрикс24 может просматривать и запароленные альбомы.

    Создание вложенного альбома

    Для создания вложенного альбома, нужно перейти к просмотру того альбома, в который должен быть вложен новый альбом и воспользоваться ссылкой Добавить альбом.

    Выполните действия по созданию альбома, описанные выше и после этого новый альбом будет создан внутри текущего.

    Примечание: перемещение личных фотоальбомов, например, в рабочие группы невозможно.


Загрузка фотографий
24 / 401

Для загрузки фотографий перейдем к просмотру альбома и воспользуемся ссылкой Загрузить фото. Откроется форма загрузки фотографий:

Внешний вид формы до версии 14.5

Упрощенная форма загрузки фотографий до версии 14.5 модуля Фотогалерея выглядела следующим образом:

Загрузка фотографий возможна с использованием двух форм: упрощенной и формы множественной загрузки. Переключение между формами осуществляется с помощью ссылки, расположенной в правом верхнем углу формы. При использовании упрощенной формы загрузки фотографии добавляются в рабочую область с помощью «drag'n'drop» либо выбираются из диалогового окна, открывающегося с помощью кнопки Загрузить (если рабочая область еще пуста).

Для добавления дополнительных фотографий можно также воспользоваться механизмом «drag'n'drop» либо нажать кнопку Добавить еще.

При наведении курсора мыши на фотографию можно задать ее описание, изменить фотографию, выполнить поворот или удалить.

Примечание: если выбрано действие изменить, то фотография будет открыта в новом окне для редактирования:

  • с помощью соответствующего поля можно изменить описание фотографии;
  • - поворот фотографии против часовой стрелки;
  • - поворот по часовой стрелки;
  • - вертикальное отражение изображения;
  • - горизонтальное отражение изображения;
  • - обрезка фотографии;
  • - градация в сером цвете;
  • - добавление подписи к фотографии.

Кнопки Применить и Отменить позволяют сохранить или отменить внесенные изменения.

По кнопке Загрузить все фотографии из рабочей области будут загружены в указанный существующий или новый альбом.

Форма множественной загрузки выглядит следующим образом:

Форма загрузки фотографий

Фотографии добавляются в рабочую область по кнопке Добавить изображения, причем для выбора нескольких фотографий необходимо удерживать нажатой кнопку Ctrl.

При нажатии на ссылку Дополнительные настройки становятся доступными следующие возможности форматирования фотографий:

  • видимость фотографий в альбоме;
  • выбор размера отправляемых фотографий - доступны следующие размеры фотографий:
    • 1280х960;
    • 1024х768;
    • 800х600.
  • добавление авторского знака - здесь может быть введено любое слово или символ, который будет нанесен на фото.

По кнопке Загрузить все фотографии из рабочей области будут загружены в указанный существующий или новый альбом.

Примечание: в процессе загрузки каждая фотография генерируется в двух видах:

  • предпросмотр (эскиз или анонс) - минимальный размер;
  • оригинал (максимальный размер).
Кроме того, если используется форма множественной загрузки, то вне зависимости от формата добавляемых фотографий в альбом они будут загружены в формате *.jpg.


Режимы просмотра фотографий
25 / 401
  • Просмотр альбома
  • Просмотр фотографии
  • Страница просмотра оригинала фотографии
    •

    Просмотр альбома

    Из списка альбомов по клику на имени альбома можно перейти к просмотру эскизов фотографий:

    На данной странице можно загрузить новые фотографии, изменить свойства альбома, удалить альбом, добавить обложку альбома. Выбор осуществляется с помощью ссылок сверху. Кроме того, можно изменить порядок следования фотографий путем их перетаскивания.

    Примечание: Подробнее про управление фотографиями смотрите в уроке Управление альбомами раздел Управление фотографиями.

    Просмотр фотографии

    При клике по анонсу фотографии открывается окно детального просмотра фотографии:

    В данном режиме просмотра доступны следующие элементы управления:

    • 1 - закрытие окна детального просмотра фотографии;
    • 2 - переход к предыдущей/следующей фотографии альбома;
    • 3 - увеличение/уменьшение масштаба фотографии, закрытие окна детального просмотра фотографии;
    • 4 - кнопка Слайдер включает/отключает режим просмотра фотографий по эскизам;
    • 5 - в этой области отображается описание фотографии, которое можно сменить, нажав на кнопку [image];
    • 6 - ссылка Мне нравится, позволяющая проголосовать за фотографию, и кнопка Слайд-шоу с помощью которой можно запустить/остановить показ фотографий в режим слайд-шоу с выбором интервала смены слайдов;
    • 7 - область показа и ввода комментариев к фотографии;
    • 8 - область свойств фотографии: альбом, автор, количество просмотров и время добавления в альбом;
    • 9 - область редактирования фотографии: изменение свойств фотографии, удаление, увеличение масштаба и показ оригинала (в отдельном окне); с помощью кнопок [image] можно вращать фотографию (после закрытия фотография будет сохранена);
    • 10 - с помощью кнопки [image] можно свернуть/развернуть области комментариев, свойств и редактирования фотографии;
    • 11 - с помощью кнопки [image] можно сменить фон окна детального просмотра на темный и наоборот.

    Страница просмотра оригинала фотографии

    Страница просмотра оригинала открывается в отдельном окне и имеет вид:

    Слева имеется шкала для смены фона окна просмотра. Для закрытия окна необходимо кликнуть по фотографии.


Управление альбомами
26 / 401
  • Редактирование основных свойств альбома
  • Управление альбомом
  • Изменение альбома
    •

    Редактирование основных свойств альбома

    Перейти к редактированию основных свойств альбома можно прямо со страницы с альбомами по ссылке Изменить, не заходя во внутрь каждого. Здесь же можно и удалить альбом по ссылке Удалить.

    Управление альбомом

    Управление альбомом также возможно с помощью группы ссылок, которая отображается вверху страницы просмотра содержимого альбома:

    где:

    • Изменить альбом - переход к форме изменения альбома;
    • Добавить альбом - создание вложенного альбома внутри текущего;
    • Загрузить фото - переход к форме загрузки фотографий;

    Изменение альбома

    Для изменения свойств альбома можно воспользоваться ссылкой Изменить альбом, после чего откроется форма Изменение альбома.

    Форма "Изменение альбома"

    Большинство опций в этой форме понятны без объяснений, отметим лишь возможность групповых операций над выбранными фотографиями.

    В режиме редактирования альбома отмеченные фотографии можно удалить или перенести в другой альбом с помощью соответствующих ссылок, расположенных внизу страницы:


Поиск
27 / 401
Видеоролик "Инструменты поиска"

Интерактивный видеоролик (требуется выполнение действий пользователем). Продолжительность 2 минуты 39 секунд. Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если нет возможности прослушать, то с помощью кнопки СС можно включить текстовое сопровождение.

Инструментов поиска в рамках корпоративного портала несколько:

  • Общий поиск - форма расположена на каждой странице портала.
  • Локальный поиск - форма расположена справа на каждой странице портала, где возможен локальный поиск.

Общий поиск

Общий поиск на портале может выполняться по самым различным элементам:

  • по сообщениям,
  • офисным документам,
  • пользователям,
  • по новостям,
  • и так далее.

Форма поиска располагается по центру "шапки" каждой страницы портала и имеет следующий вид:

После введения в строку поискового запроса вы будете перенаправлены на страницу поиска. Например, при введении в форму поиска слова "vmbitrix" нашлись сообщения форума и документы, содержащие это слово.

Если в поисковую строку ввести фамилию пользователя, то будет найдена его карточка.

Примечание: для поиска сотрудников существует отдельная страница, позволяющая задать разнообразные условия поиска.

Результаты поиска можно отсортировать по:

  • Релевантности - точности совпадения;
  • Дате - дате изменения документа.

Подсказки в поиске

При вводе в поле поиска текста система выводит подсказки по видам информации:

Примечание: При использовании поиска возможна ситуация когда создаётся ощущение неправильной работы системы поиска.

Например, при неполном наборе слова в поисковой строке в списке подсказок вам выведется искомая вами информация.

На иллюстрации выше на введённое "мал" вывелась самая разнообразная информация от сотрудников до конкретных сообщений. В частности показал и сотрудника Ивана Малышина. Но, если не набрав фамилию полностью, оставив в поисковой строке только "мал", вы нажмёте кнопку поиска, то данный сотрудник не будет отображён в результатах поиска.

Дело в том, что результат поиска в выпадающем меню и итоговый результат поиска по клику на кнопку Поиска - это разные результаты, так как они формируются по разным поисковым индексам. В приведенном примере поиск находит сообщения по фразе "мал", так как в индекс подсказок записываются неизменяемые основы слов. То есть даже несмотря на то, что фамилия у сотрудника "Малышин", основа будет "мал" и поэтому поиск найдет сообщение.

В общем поисковом индексе результат зависит от морфологии. В случае с поиском по запросу "мал" основы слова нет, поэтому поиск не выдает результат. Он найдет сообщение и сотрудника только если полностью указать основу, в этом случае Малышин.

Локальные поиск и фильтр

Локальный поиск производит поиск только среди элементов раздела, где он расположен. В Задачах он будет искать только среди задач, Лид или Контакт CRM в этом поиске не найти. Поле поиска расположено у правой границы экрана на тех страницах, где такой поиск возможен. Как правило он ищет только по названиям. Для более эффективного поиска нужного элемента лучше воспользоваться фильтром, который позволяет составлять достаточно сложные запросы поиска.

В некоторых разделах фильтр расположен в правой колонке. Все поля - интуитивно понятны и в комментариях не нуждаются. Вот, например, какой поиск в разделе Собрания и планёрки:

В некоторых разделах Битрикс24 фильтр обладает очень большими возможностями по фильтрации, так что пришлось создать простую и расширенную форму фильтра, как в Задачах, например.


Рейтинги
28 / 401

Система позволяет проголосовать за понравившийся контент (сообщение, комментарий, фотография и.т.д.) с помощью кнопки Мне нравится, тем самым увеличивая его рейтинг. Благодаря этому контент, при поиске с помощью соответствующего функционала портала, будет отображаться выше, чем схожие результаты.

Также в блоке Популярное, расположенного в правой части страницы Живая лента, будут отображаться сообщения с высоким рейтингом. Информация в этом блоке обновляется каждые 8 дней, а каждый час проходит проверка на новые, более популярные сообщения.

Примечание: Внешний вид элементов оценки контента и работа системы рейтингов может различаться, в зависимости от настроек, заданных администратором.

При наведении на символ ★ будет отображен список сотрудников, которым тоже понравился этот контент. Список строится на основе иерархии компании. Самым первым отображается Ваше имя, затем идут начальники, после обычные сотрудники. Если авторитет одинаков (например, равноценные начальники или обычные сотрудники), то сортировка идет по схеме - чей контент больше нравится, тот и выше. Так как список строится на основе иерархии, то для каждого сотрудника, в зависимости от его положения в компании, сортировка в нем будет разной.


Пульс компании
29 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Пульс компании. Панели.

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Пульс компании - способ контроля за использованием сотрудниками инструментов корпоративного портала. Он отображает общие показатели активности сотрудников вашей компании на выбранный временной период. Пульс использует понятия: Рейтинг, Активность и Вовлечённость. Любое из них может высчитываться в зависимости от выбранного инструмента, пользователя и периода времени.

В работе Пульса учитывается деятельность только сотрудников компании, участники Экстранета в отчёты не попадают.

Изменения в Пульсе отображаются с разным временным интервалом после события. Если смотреть по конкретному пользователю, то моментально. По компании на часовом графике (Сегодня) - в течение минуты, на дневных графиках (Неделя и Месяц) - в течение часа.

Пульс компании представлен в виде двух инструментов: виджета и собственно Пульса. Оба они показывают как используется корпоративный портал в компании, но показывают по разному: первый инструмент отображает текущее состояние, а второй - статистику.

Виджет

Виджет расположен в правой колонке главной страницы и выводит, в отличие от Пульса, только суммарные данные по компании без деления по сотрудникам, подразделениям, инструментам:

Первое число - это Активность, второе - Вовлеченность. Данные выводятся только за последний час и потому могут расходиться с аналогичными данными в Пульсе, который рассчитывается по выбранному временному интервалу. Значения Активности и Вовлечённости в виджете пересчитываются раз в минуту, но на странице автоматически не меняются, только при перезагрузке страницы.

Рейтинг в виджете не отображается.

По клику указателем мыши на виджете откроется Пульс компании.

Пульс компании

  1. Название инструмента, данные по которому отображаются (Лайки, CRM и так далее). Если выводятся обобщённые данные, то пишется Пульс компании. Обратите внимание на знак вопроса рядом с названием. При клике указателем мыши на этот знак появится всплывающая подсказка. Такая подсказка есть во многих местах Пульса.
  2. Выбор периода времени, за который нужно отображать данные. По умолчанию отображается за "Сегодня".
  3. Переключатель вывода данных по отдельным пользователям, либо по компании.
  4. Название компании.
  5. Вывод данных по Рейтингу, Активности, Вовлечённости.
  6. График с данными.
  7. Выбор инструментов.

Периоды времени

Показания данных с учётом различного периода времени позволяют оценить в динамике как осваиваются те или иные инструменты корпоративного портала. При выборе временного периода более чем за день, в графике можно просмотреть данные по Активности и Вовлечённости за каждый день, указав указателем мыши на нужную дату:

При использовании периодов Неделя и Месяц возможен быстрый переход на конкретную дату. Для этого достаточно навести указатель мыши на нужную дату и кликнуть.

Переключатель Люди-Компания

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Переключатель Люди-Компания. Параметры пульса.

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Если интересуют личные данные конкретного сотрудника, то с помощью переключателя выберите его либо через поиск, либо через структуру компании.

После выбора Пульс сменит свой вид.

Во-первых, на графике появляются четыре линии:

  • голубой - график выбранного сотрудника.
  • оранжевый - график просматривающего сотрудника, то есть ваш.
  • зелёный - график компании в целом.
  • серый - график отдела, в котором работает выбранный сотрудник.

Во-вторых, вместо показателей Вовлечённости выводится среднее значение по данному инструменту в рамках отдела и компании.

Например, так будет выглядеть график по конкретному пользователю по использованию Задач:

Что рассчитывается

Пульс использует понятия: Рейтинг, Активность и Вовлечённость. Любое из них может высчитываться в зависимости от выбранного инструмента, пользователя и периода времени.

Рейтинг - строится по индивидуальной Активности сотрудников, которые как минимум один раз пользовались инструментами корпоративного портала в выбранный период времени. То есть это список самых активных сотрудников.

Активность - сумма различных действий, которые совершили сотрудники на портале, используя любой из инструментов, за выбранный период времени. По индексу можно сделать вывод, как активно сотрудники применяют инструменты сервиса.

Вовлечённость - ключевой индикатор, по которому можно судить, насколько полно сотрудники освоили возможности корпоративного портала. Показывает, какой процент от всех сотрудников компании пользуется хотя бы четырьмя из представленных инструментов.

Рейтинг

По каждому инструменту в отдельности, а так же по общему рейтингу можно просмотреть статистику по пользователям:

В рейтинг попадают все сотрудники, которые проявили активность в выбранном инструменте более 3 раз. Например, в задачах: создали задачу, написали 2 комментария к ней.

В общем рейтинге отображается дополнительно и число используемых инструментов.

Вкладка Не вовлечённые - это список сотрудников, которые используют менее 4-х инструментов, либо, в случае рейтинга по инструментам, не используют инструмент совсем.

Выбор инструментов

При анализе работы используются семь параметров, учитывается общее число:

  • Социальная сеть - опубликованных сообщений и комментариев.
  • Лайки - отметок "Мне нравится" у сообщений, комментариев, задач и других элементов поставленных сотрудником.
  • Задачи и проекты - изменений в задачах (создание новой задачи, комментарии, смена сроков и т.п.).
  • Чат и видео - отправленных сообщений и звонков. (Учитываются как сообщения, отправленные через мессенджер, так и сообщения, отправленные через сервер XMPP.)
  • Диск - файлов, загруженных или измененных в Битрикс.Диск.
  • Мобильная версия - действий в мобильном приложении (учитывается всё: сообщения, изменения в задачах, CRM и т.д.).
  • CRM - действий в CRM (изменения по делам, сделкам, лидам и т.п.).

При выборе того или иного инструмента внизу появляется ссылка Рассказать. По клику на эту ссылку откроется сообщения, описывающее данный функционал. Администраторы и Руководители могут отредактировать это сообщение.


Битрикс24.Network
30 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Битрикс24. Network

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Сотрудники портала в своей работе с клиентами и контрагентами могут использовать сеть Битрикс24.Network.

Битрикс24.Network - сеть для бизнес-коммуникаций, которая объединяет в одной среде партнеров, коллег, поставщиков и других контрагентов, который позволяет свести использование различных инструментов для общения к минимуму и хранить историю общения в одном месте.

Регистрация в сети осуществляется по ссылке https://www.bitrix24.net. При необходимости можно привязать свои аккаунты в других соцсетях к Битрикс24.Network, в этом случае у вас появится возможность использовать ваши контакты из этих сетей.

Примечание: есть возможность привязки профиля Битрикс24.Network к пользователю коробочной версии Битрикс24 как внешней соцсети (наравне с Facebook и другими), и, соответственно, авторизация через него.

Переход к странице сети из действующих порталов сервиса Битрикс24 осуществляется по команде Моя страница Битрикс24.Network из меню Личная страница:

пункт Моя страница

По этой команде вы перейдёте на свою страницу в этой сети:

Персональная страница Битрикс24.Network

Битрикс24.Network - это, по сути, мессенджер с возможностями чата, голосовых и видеозвонков, используемых для бизнес-коммуникаций. Все возможности мессенджера доступны не только пользователям Битрикс24, но и тем, кто был приглашен участниками. Портал работает на разных языках.

Работа с Битрикс24.Network

Работа с мессенджером Битрикс24.Network абсолютно аналогична с работой обычного мессенджера сервиса Битрикс24, за исключением возможностей Битрикс24.Диск, перехода к Живой ленте и телефонии. Если у вас уже установлено десктопное приложение, то общение лучше осуществлять через него.

Если сообщения от вашего корреспондента не были по каким-то причинам доставлены вовремя (вы не в сети, например), то эти сообщения придут вам по e-mail. Особенность в том, что сообщения придут на языке интерфейса Битрикс24.Network, которое использует ваш клиент. Например, клиент использует испанский интерфейс, сообщение в электронной почте будет выглядеть так (хотя переписка идёт на русском языке):

С вашей персональной страницы в сети можно быстро перейти к любому из ваших порталов, создать новый и задать параметры единого входа на все порталы в которых вы работаете.

кнопка перехода на порталы

Для объединения аккаунтов:

  1. Зайдите на страницу Единый вход,
  2. Добавьте все свои аккаунты (e-mail + пароль),
  3. Установите один из e-mail основным.

Внимание!:
  1. Смена пароля у вашего корпоративного портала Битрикс24 возможна только через профиль в Битрикс24.Network, ссылка Редактировать профиль.
  2. Нельзя привязывать к своему аккаунту больше 7 порталов.

Приглашение в Битрикс24.Network

Чтобы пригласить коллег в сеть достаточно воспользоваться кнопкой "Пригласить в Network" и либо пригласить по электронной почте, либо, если контакт есть у вас в какой-либо из социальных сетей, найти через строку поиска.

При приглашении вы можете послать ссылку на свою персональную страницу-визитку, чтобы потенциальный партнёр мог познакомиться с вами поближе. Визитка не просто расскажет о вас, а позволит собеседнику быстро перейти в сеть, зарегистрироваться и написать вам сообщение или позвонить.

Настройки

Настройки параметров Битрикс24.Network аналогичны настройкам Бизнес-чата, только добавляются параметры Приватности:


Живая лента
31 / 401
  • Избранное
  • Следить / Больше не следить
  • Панель фильтра
  • Умное слежение
  • Сообщение
    • Меню действий сообщения
    • Меню действий файлов
    • Создание/редактирование сообщения
  • Настройка уведомлений

Живая лента представляет из себя страницу, на которой выводятся последние события портала: новости, комментарии, новые файлы, системные события и.т.д.

Новые, непросмотренные сообщения выделяются цветом:

Количество новых событий в Живой ленте отображается рядом с соответствующим пунктом в левом меню, в начале ленты и на панели фильтра над лентой:

Количество новых событий в живой ленте

По умолчанию на странице отображаются все типы событий в хронологическом порядке. Новый комментарий автоматически поднимает сообщение наверх в Живой ленте.

Примечание: Если при просмотре ленты вместо правильного текста появляются нечитаемые символы, то, скорее всего, в браузере жестко указана какая-либо кодировка - необходимо указать автоматический выбор кодировки в браузере.

Избранное

Добавить (или убрать) сообщение в Избранное очень просто:

  • нужно кликнуть на уголок сообщения для добавления в избранное:

    Добавить в Избранное

  • и второй раз для удаления из избранного:

    Убрать из Избранного

Следить / Больше не следить

Если вы не хотите, чтобы каждое новое событие (комментарий, например) в конкретном сообщении автоматически поднимало его вверх в Живой ленте, то можно нажать на ссылку Больше не следить. Чтобы продолжить следить за активностью в сообщении, нажмите ссылку Следить.

Панель фильтра

На странице Живой ленты присутствует фильтр, позволяющий быстро переключаться между типами событий:

  • Все сообщения - показывать все сообщения в Живой ленте, на просмотр которых есть права;
  • Дела - показывать все рабочие события, на которые есть права, - отчеты, задачи, комментарии по задачам и т.п;
  • Избранное - показывать события, занесенные пользователем в Избранное;
  • Мое - показывать события, созданные лично пользователем.
  • Важное - показывать все важные объявления.
  • Бизнес-процессы - показывать события бизнес-процессов, на которые есть права просмотра.
  • Экстранет - показывать экстранет-события, на которые есть права просмотра.
  • Фильтр... - отображать события по определенным критериям.
  • Включить "Умное слежение" - сообщения ленты будут подниматься наверх только для событий, в которых вы являетесь автором, получателем или упомянуты в тексте (см. ниже).
  • Включить "Экспертный режим" - теперь задачи не будут отображаться в Живой ленте, и вы сможете работать с задачами непосредственно из раздела "Задачи". Все уведомления по задачам, как и прежде, будут приходить в виде уведомлений в чате.

С помощью кнопки Фильтр можно выбрать Автора, Группу, Сотрудника, Отдел или Почтовых пользователей (те, кто указываются в поле Кому в сообщении), Дату события:

Также при выборе Автора есть возможность поиска и в комментариях.

Умное слежение

Умное слежение - полезная функция для сотрудников, которые участвуют во многих задачах, проектах и просто не в состоянии отследить все сообщения и комментарии в Живой ленте. Опция включается пунктом Умное слежение в меню панели фильтра.

При выключенном режиме Умное слежение сотрудник следит за всеми сообщениями, кроме тех, за которыми он решил не следить вручную (опции Следить \ Больше не следить).

При включенном режиме Умное слежение сотрудник следит только за:

  • сообщениями, автором которых он является;
  • сообщениями, в которых он оставил комментарий;
  • сообщениями, в которых он был выбран лично в качестве получателя;
  • сообщениями, в которых он был упомянут в самом сообщении или в комментарии к нему.

Статус слежения отображается в Живой ленте в строке под каждым событием: если видна ссылка Больше не следить - то значит сотрудник следит за данным событием; если Следить - то сотрудник не следит за данным событием.

Примечание: Умное слежение не скрывает информацию из Живой ленты, а всего лишь акцентирует внимание только на тех событиях, которые могут быть важны для сотрудника.

Примечание: Если в среднем страница Живой ленты (20 записей) "уйдет вниз" у пользователя меньше, чем за 4 часа, то ему будет предложено включить Умное слежение через центр уведомлений.

Сообщения

Для каждого сообщения указывается его Автор, в виде ссылки на его личную страницу, тип сообщения, получатель, название сообщения в виде ссылки на него.

Если сообщение большое, то с помощью кнопки [image] можно просмотреть его целиком.

Просмотр сообщения целиком

В нижней части события отображается превью фотографий, прикрепленные к сообщению файлы с меню действия над файлами, дата/время события, ссылка для голосования Мне нравится и счетчик количества со списком проголосовавших за данное событие, меню действий события.

Если к сообщению были добавлены комментарии, то они тоже будут отображены в Живой ленте, причем длинные комментарии сокращаются, чтобы не занимать много места в ленте. Для просмотра полного текста комментария воспользуйтесь кнопкой [image].

С помощью ссылки Добавить комментарий комментарии можно добавлять прямо в Живой ленте.

Меню действий сообщения

Под каждым сообщением есть ссылка Еще - меню действий над сообщением:

Меню действий сообщения

  • Добавить/Убрать в Избранное - добавляет (удаляет) данное сообщение в (из) избранное (-ого);
  • Перейти к сообщению - позволяет перейти в детальный просмотр данного сообщения (такой же пункт есть и у комментария - Ссылка на комментарий);
  • Добавить получателей - позволяет добавить новых получателей данного сообщения (сотрудник, отдел, группа);
  • Редактировать - переход к форме редактирования сообщения (пункт меню будет виден, если у пользователя есть соответствующие права);
  • Удалить - удаление данного сообщения (пункт меню будет виден, если у пользователя есть соответствующие права).
  • Удалить из Живой ленты - удаление данного сообщения из Живой ленты для всех сотрудников (пункт меню будет виден, если у пользователя есть соответствующие права).

    Важно! Само сообщение из самого источника не удаляется, оно удаляется только из Живой ленты для всех пользователей.

  • Создать задачу - создание задачи с текстом сообщения в качестве описания задачи. Подробнее с процессом создания можно узнать в этом уроке.

Меню действий файлов

Справа от ссылки на файл есть ссылка Еще - меню действий над файлом:

Меню действий файла

  • Просмотреть - позволяет просмотреть файл;
  • Редактировать - переход к редактированию файла с помощью ранее настроенного инструмента для редактирования данных файлов (пункт меню будет виден, если у пользователя есть соответствующие права);
  • Сохранить на Битрикс24.Диск - файл будет сохранен в ваш персональный файловый архив в папку Загрузки и будет предложено перейти к файлу или редактированию;
  • Скопировать на локальный компьютер - открывает окно загрузки файла на компьютер;
  • История - открывает окно с отображением предыдущих изменений документа.

Создание/редактирование сообщения

Создание и редактирование сообщений подробно описано в уроке Сообщения.

Настройка уведомлений

Можно выбрать события, о которых вы хотели бы получать уведомления - на почту, или только на портале, или совсем отписаться от уведомления на почту.

Уведомления можно настроить прямо из Живой ленты. Для этого необходимо воспользоваться пунктом меню Настройка уведомлений, который позволяет произвести настройку уведомлений:

Меню "Настройка уведомлений"

Доступны 2 режима настройки:

  • Простой режим, позволяющий настраивать получение уведомлений на:
    • Сайт, мобильное и десктопное приложения;
    • Электронную почту;
    • Внешние клиенты (XMPP, Jabber) - только для «Битрикс24 в коробке».

  • Расширенный режим, позволяющий сделать настройки уведомлений для различных инструментов портала:


Локальное меню создания сообщения в Живой ленте
32 / 401

Локальное меню создания сообщения представляет собой верхнее меню в Живой ленте:

  • Сообщение
  • Задача
  • Событие (напоминание)
  • Опрос
  • Файл
  • Благодарность
  • Важное сообщение
  • Бизнес-процессы

Сообщение

Для создания сообщения выберите пункт меню Сообщение, откроется форма создания сообщения:

Примечание: Подробнее о работе с задачами можно прочесть в главе Сообщения.

Задача

Для создания задачи выберите пункт меню Задача, откроется дополнительная форма:

Заполните все основные параметры задачи, укажите участников и др параметры, отправьте им приглашение.

Примечание: Подробнее о работе с задачами можно прочесть в главе Создание задачи.

Событие (напоминание)

Для создания события выберите пункт меню Событие, откроется дополнительная форма:

Заполните необходимые поля: Название, Описание события. пригласите участников, укажите время и место проведения.

С помощью планировщика можно подобрать удачное время проведения.

Автору события будут приходить уведомления о решении приглашенного сотрудника участвовать или нет в событии.

Опрос

Для создания опроса выберите пункт меню Опрос, откроется дополнительная форма для темы и предполагаемых ответов:

Заполните необходимые поля - Вопрос и Ответы. В одном сообщении можно создать несколько опросов.

Автору опроса будут приходить уведомления об участии сотрудников в опросе.

В одном опросе может быть несколько вопросов. Для добавления дополнительных вопросов необходимо нажать на ссылку Добавить вопрос.

Файл

Чтобы вставить в сообщение файлы или картинку, выберите пункт Файл в меню Еще, откроется дополнительная форма для добавления объектов в сообщение - это может быть как файл, так и картинка. Если загружается картинка, то она автоматически будет отображена в сообщении:

Действия с файлами аналогичны описанным в главе Сообщения.

Благодарность

Для создания поощрения сотрудника выберите пункт Благодарность в меню Еще:

Заполните поле Кто награждается, выбрав сотрудника из структуры компании. С помощью ссылки Другая можно выбрать значок благодарности. В одном сообщении для выражения благодарности можно выбрать несколько сотрудников.

Важное сообщение

Для создания какого-либо важного объявления на портале выберите пункт Важное сообщение в меню Еще:

После отправки объявления оно появится в специальном виджете в правом верхнем углу портала.

После прочтения объявления можно нажать кнопку Прочитал(ла) и это объявление больше не будет показываться.

Бизнес-процессы

Для запуска бизнес-процесса выберите пункт Процессы в меню Еще, откроется дополнительное меню:

Выберите один из предустановленных бизнес-процессов либо создайте новый бизнес-процесс.

По пункту меню Настройки можно перейти к настройкам отображения предустановленных бизнес-процессов.


Сообщения
33 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Сообщения

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

На портале вы можете создавать сообщения, адресованные сотрудникам, а также увидеть комментарии к ним:

Создаваемые вами сообщения будут отображаться в разделе Живая лента.


Работа с сообщениями
34 / 401
  • Детальный просмотр сообщения
  • Создание сообщения
  • Редактирование и удаление сообщения

Детальный просмотр сообщения

Для детального просмотра какого-либо сообщения и комментариев к нему кликните на его заголовок на странице Сообщения, либо, в случае отсутствия такового, воспользуйтесь пунктом меню Еще - Перейти к сообщению, либо кликните по дате его создания:

Кнопки Все, Мои, Мне, расположенные в верхней части страницы Сообщения позволяют произвести соответствующую фильтрацию сообщений.

Если пользователь является пользователем экстранета , то его имя выделяется цветом (а также группа экстранета):

Создание сообщения

Для создания сообщений кликните левой кнопкой мыши в текстовом поле с надписью Написать сообщение, после чего данное поле примет следующий вид:

  • Чтобы добавить к сообщению тему, нажмите на кнопку Тема сообщения [image] в правом нижнем углу поля ввода. После этого появится дополнительное текстовое поле Тема сообщения:

    Чтобы убрать это поле, нужно щелкнуть по крестику в нем или же на эту кнопку снова.

  • Задайте сам текст сообщения. Чтобы вызвать упрощенный визуальный редактор, нажмите на кнопку Визуальный редактор [image] в правом нижнем углу поля ввода. После этого появится панель упрощенного визуального редактора:

    Чтобы снова убрать панель редактора, можно щелкнуть по крестику на ней или же на эту кнопку снова.

  • - нажмите данную иконку, если хотите добавить к сообщению какие-либо объекты - это может быть как файл, так и картинка. Если загружается картинка, то она автоматически будет отображена в сообщении.

    После этого снизу появится область:

    • Загрузить файл или картинку - загрузить файл в сообщение с компьютера: с помощью окна выбора файла или перетащить файл в область с помощью Drag'n'drop;

      Примечание: Перетягивание файлов поддерживается не во всех браузерах.

    • Найти в Битрикс24 - можно вставить в сообщение один или несколько файлов (с помощью кнопки Ctrl), выбрав их из структуры файлов портала.

      По этой ссылке открывается окно Битрикс24.Диск, в диалоге выбора которого по умолчанию первыми перечислены Недавние файлы, то есть те, с которыми сотрудник вел работу в последнее время. Также возможен быстрый переход к выбору файлов из Моего Диска, Общего диска и Дисков групп.

    • Загрузить из внешнего диска - возможность загрузить файлы с внешних источников: OneDrive, Google Drive, Dropbox, Box.com, Office365 и Яндекс.Диск.

      Внимание! Для загрузки документов из OneDrive, Google Drive, Dropbox, Box.com, Office365 и Яндекс.Диск необходимо иметь аккаунты в этих сервисах - на этапе загрузки файла будет предложено авторизоваться в этих сервисах. Загруженный файл будет сохранен в Битрикс24.Диск в папку Загруженные и все дальнейшие изменения на стороне внешнего диска не будут отслеживаться.

    • Создать с помощью - возможность создать файлы: Документ, Таблица, Презентация сразу на портале с помощью ассоциированных с этими файлами установленных программ на компьютере или с помощью онлайн-сервисов Google Docs, Office365 или MS Office Web Apps без установки офисных пакетов.

      Примечание: Для создания документов в Google Docs, Office365 или MS Office Web Apps необходимо иметь аккаунты в этих службах - на этапе создания файла будет предложено авторизоваться в этих сервисах.

      После работы с документом вас спросят нажать Сохранить как и выбрать имя файла для сохранения документа на портал:

      После окончания процесса загрузки отобразится место хранения загруженного файла. По умолчанию это Мой Диск / Созданные файлы. Папку хранения можно изменить, нажав по ссылке левой кнопкой мыши, после чего откроется диалоговое окно - в нем зайдите в папку Диска, в которой хотите сохранить файл и нажмите Выбрать текущую папку:

    Кроме того, можно переименовать прикрепленный файл. Для наведите курсор на имя прикрепляемого файла, кликните по появившейся пиктограмме карандаша рядом с полем имени и откорректируйте его.

  • - данная иконка позволяет добавить в сообщение гиперссылку. После ее нажатия появится окно:

    В нижнем поле введите адрес ссылки в интернет-пространстве, а в верхнем - сам текст ссылки, который будет виден сотрудникам.

  • - нажмите данную иконку, если хотите вставить в сообщение видео. После ее нажатия откроется форма добавления видео:

    Укажите ссылку на видеоролик, и, при необходимости, задайте ширину и высоту плеера в пикселях, в котором будет проигрываться видео, в противном случае ролик будет воспроизведен в окне плеера стандартного размера.

    Примечание: Собственные видеоролики можно загрузить в библиотеку документов, затем для нужного видео-файла в меню действий выбрать Скопировать ссылку, и вставить ее в форму добавления видео.

  • - нажмите данную иконку, если хотите оформить в сообщении выделенный текст как цитату:

  • - иконка предназначена для добавления упоминания какого-либо сотрудника в вашем сообщении. После отправки он получит уведомление о том, что был упомянут:

    После того, как вы кликните по иконке, появится окно выбора сотрудников:

    В нем вы можете указать как последних сотрудников, ранее выбранных вами (закладка Последние), либо других, из структуры портала (в том числе и сотрудников Экстранет - они появятся в закладке Сотрудники и отделы - Экстранет). Можете просто начать вводить имя/фамилию, и система автоматически предложит вам подходящих людей.

    Примечание: Во вкладке Последние список адресатов формируется из двух условных групп: сначала выводится первая группа по дате последней активности пользователей в данном событии, затем вторая группа пользователей, состоящая из тех, с кем вы общались на портале последнее время (Бизнес-чат не учитывается).

    Примечание: вставить упоминание сотрудника можно, начав писать его имя с @ или +.

    Выбранные вами сотрудники будут появляться в виде ссылок:

    Число упоминаний ограничивается лишь количеством сотрудников.

    Примечание: сформированную системой ссылку можно изменять произвольным образом (например, вместо Карпов Андрей - Андрей (ИТ-Отдел)).

    Ссылки на упоминания будут видны в живой ленте всем, кому доступен просмотр сообщения.

  • - данная иконка предназначена для добавления тегов к сообщению для лучшей индексации его модулем поиска. После ее нажатия появится форма добавления тега:

    Впишите нужный тег и нажмите клавишу Enter, после чего под сообщением появится панель тегов:

    Вы можете добавлять еще теги, нажимая ссылку Добавить еще, а также удалять уже добавленный тег, кликая крестик рядом с его именем.

  • Кому - здесь можно ограничить доступ сотрудников к просмотру вашего сообщения.

    Примечание: по умолчанию сообщение адресуется всем сотрудникам.

    Чтобы разрешить просмотр сообщения только определенным сотрудникам, уберите табличку Все сотрудники, нажав крестик на ней.

    Примечание: в случае, если вы будете добавлять сотрудников, не закрыв перед этим табличку Все сотрудники, то доступ к сообщению будет у всех сотрудников.

    Кликните появившуюся ссылку Добавить еще, после чего откроется окно:

    Начните вводить имя или фамилию нужного сотрудника, либо выберите группы или отделы вашей компании, которым будет разрешен доступ к сообщению. Все они появятся в поле Кому.

    Примечание: вы можете писать непосредственно в группы, выбрав нужную на закладке Мои группы.

Опубликуйте сообщение с помощью кнопки Отправить.

Редактирование и удаление сообщения

Редактирование созданного сообщения выполняется аналогично созданию нового с помощью пункта меню Редактировать:

Удаление сообщения производится с помощью пункта Удалить.


Работа с комментариями к сообщению
35 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Комментарии. Дополнительные виды сообщений.

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

  • Комментарии к сообщениям
  • Управление комментариями

Комментарии к сообщениям

Комментарии к сообщению отображаются как в общем списке, так и на странице детального просмотра, ниже самого сообщения.

Чтобы добавить комментарий, нажмите Добавить комментарий внизу сообщения. Откроется форма добавления комментария, представляющая собой более упрощенный вид формы добавления сообщения:

Введите комментарий и нажмите Отправить. Чтобы закрыть форму нажмите Отменить.

С помощью кнопки [image] в правом нижнем углу поля ввода комментария можно также вызвать упрощенный визуальный редактор.

Если нажать на ссылку Ответить, то в ваше сообщение будет вставлено имя автора этого комментария:

Если упомянутый в комментарии к сообщению живой ленты пользователь не имеет доступа к сообщению, то он автоматически добавляется в его получатели.

Управление комментариями

Для управления комментариями нажмите на появляющуюся при наведении стрелку:

  • Ссылка на комментарий - позволяет скопировать точный путь к выбранному комментарию.
  • Редактировать - позволяет отредактировать комментарий, аналогично его созданию.
  • Скрыть - позволяет скрыть комментарий, после чего он не будет отображаться на сайте.

    Чтобы снова сделать комментарий видимым для всех, выберите пункт Показать в том же меню.

    Внимание! Пункты меню Скрыть/Показать, а также скрытые сообщения отображаются только в режиме детального просмотра сообщения для сотрудников, которые обладают на это правами: администратор портала, владелец группы, модератор группы, автор сообщения.

  • Удалить - нажмите, чтобы удалить комментарий.
  • Создать задачу - нажмите, чтобы создать задачу с текстом комментария в качестве описания.

Примечание: Если открыто конкретное сообщение, то следить за обсуждением помогает функционал живых комментариев - новые комментарии будут появляться автоматически без обновления страницы.


«Богатые ссылки» (Rich-ссылки)
36 / 401
  • «Богатые ссылки» в Живой ленте
  • «Богатые ссылки» в Бизнес-чате
  • Настройки «богатых ссылок»

«Богатые ссылки» в Живой ленте

«Богатые ссылки» позволяют сделать сообщение в Живой ленте и в комментариях более содержательным и красивым. Сообщение не нужно оформлять каким-то особым способом - ссылка на какой-либо ресурс, как правило, автоматически преобразуется в содержательный блок c информацией из ссылки:

Примечание: Ресурс, на который указывается ссылка, должен поддерживать определенный формат, в противном случае в сообщении будет показана обычная ссылка на ресурс.

Если по каким-либо причинам в сообщении не нужен такой блок с подробной информацией о ссылке, то вывод «богатой ссылки» можно отключить на этапе создания сообщения или в процессе его редактирования - нужно лишь нажать на иконку крестика в предпросмотре данной ссылки и сохранить сообщение:

В «богатых ссылках» могут отображаться не только внешние ссылки, но и данные внутри «Битрикс24» - задачи, некоторые сущности из CRM, сообщения в Живой ленте и др:

«Богатые ссылки» в Бизнес-чате

Бизнес-чат и Десктопное приложение Битрикс24 также поддерживают «богатые ссылки» как в чатах:

Так и в уведомлениях:

Если по каким-то причинам вы не хотите видеть «богатую ссылку» в уже отправленном сообщении, то она удаляется нажатием иконки-крестика.

Примечание: Поддержку «богатых ссылок» в Бизнес-чате можно отключить (или включить) глобально сразу для всех сообщений и уведомлений. Для этого необходимо обратиться к администратору. Подробнее об этом можно прочитать здесь.

Настройки «богатых ссылок»

Администратор может централизованно включать и выключать функционал «богатых ссылок» на всем портале, при этом включается (или отключается) возможность использования «богатых ссылок» как в Бизнес-чате, так и в Живой ленте:

  • Облачный сервис Битрикс24:

    Опция Включить богатые ссылки в Настройки > Настройки портала:

  • Продукт Битрикс24 в коробке:

    В административном интерфейсе портала опция Включить богатые ссылки в настройках Главного модуля (Настройки > Настройки продукта > Настройки модулей > Главный модуль):


Отправка сообщения на e-mail
37 / 401

Внимание Администраторов!
  1. Для общения с внешними пользователями через email в продуктах «Битрикс24 в коробке» (и на тарифном плане Компания с услугой Свой домен облачного сервиса «Битрикс24») портал должен быть доступен из Интернета, а для домена портала должна быть обязательно указана MX-запись почтового сервера Битрикс24: mail-001.bitrix24.com - для этого обратитесь к администратору вашего домена. Для остальных тарифных планов облачного сервиса «Битрикс24» никаких настроек делать не нужно.
  2. Если Битрикс24 в коробке работает по протоколу https, то валидный сертификат - обязательное условие.

С 16-ой версии продуктов «Битрикс24» появилась возможность общения на портале с внешними пользователями, у которых нет учетной записи ни на портале, ни в Битрикс24.Нетворк.

Все очень просто, для этого нужен лишь e-mail адресата.

При написании сообщения в Живой ленте портала в качестве получателя указывается e-mail-адрес:

Примечание: Если вводимый email-адрес не использовался на портале (не присоединен к какому-либо сотруднику или контакту), то выводится форма запроса имени и фамилии:

Сообщение с внешним получателем появится в Живой ленте отправителя:

А получатель сообщения получит e-mail в свой почтовый ящик:

Для дальнейшего общения получателю письма нужно нажать на кнопку или ссылку Добавить комментарий, откроется специальный диалог общения на портале, где можно уже написать ответ:

Общение пользователя портала с внешним пользователем через e-mail ничем не отличается от общения в Живой ленте - можно также добавить получателей к диалогу, прикрепить картинку, файл и др.:

При каждом новом сообщении в диалоге внешнему получателю высылается e-mail, в котором есть полный диалог и ссылка с возможностью перехода на портал к данному диалогу:

Примечание: Ссылка на диалог в письме уникальна, право на просмотр данного диалога имеют только участвующие в данном диалоге пользователи.


Отправка e-mail в Живую ленту
38 / 401

Внимание! Для отправки e-mail писем в Живую ленту в продуктах «Битрикс24 в коробке» (и на тарифном плане Компания с услугой Свой домен облачного сервиса «Битрикс24») портал должен быть доступен из Интернета, а для домена портала должна быть обязательно указана MX-запись почтового сервера Битрикс24: mail-001.bitrix24.com - для этого обратитесь к администратору вашего домена. Для остальных тарифных планов облачного сервиса «Битрикс24» никаких настроек делать не нужно.

Чтобы обсудить с коллегами какое-либо полученное электронное письмо, можно просто переслать его в портал, в Живую ленту.

Для этого нужен лишь специальный e-mail. Получить его можно в разделе Моя страница, нажав на ссылку Показать:

Примечание: Данный email-адрес является уникальным для каждого сотрудника и пользователя Экстранет, использовать его, кроме как для пересылки электронных писем в Живую ленту, не имеет смысла.

После этого уникальный e-mail появится в поле Для создания поста в Живой ленте:

Далее этот email-адрес можно использовать для пересылки в Живую ленту электронных писем:

Данное письмо будет отправлено в Живую ленту, отправитель будет назначен автором и получателем такого сообщения, текст письма и все приложенные файлы будут автоматически опубликованы:

Примечание: Если пользователь Экстранета отправляет электронное письмо на портал, то оно появится в Живой ленте Экстранета.

Затем можно отредактировать сообщение, добавить нужных получателей и привлечь к обсуждению своих коллег или внешних получателей:


Задачи
39 / 401

Раздел Задачи служит для создания и просмотра личных задач, поставленных сотруднику/сотрудником.

Задачи - инструмент для организации персональной и групповой работы. Задачи обладают свойствами: контроля по времени, контроля по эффективности работы, приоритету выполнения, ролями и другими.

Работа с задачами доступна сотрудникам с любым уровнем прав.

Работа с задачами использует механизм ролей:

  • Ответственный - сотрудник, которому была непосредственно поставлена задача.
  • Постановщик - сотрудник, который поставил задачу (например, начальник отдела).
  • Соисполнитель - сотрудник, которому была поставлена та же задача, что и другому сотруднику (например, задача была поставлена на весь отдел, сотрудники которого и будут соисполнителями).
    Cоисполнителям назначаются права ответственного (возможность начинать задачу, завершать и т.д.).
  • Наблюдатель - сотрудник, который получает уведомления о ходе задачи, но не может участвовать в ней или изменять ее (например, начальник отдела, который должен получать информацию о выполненных задачах другого отдела).
    Наблюдатели имеют возможность самостоятельно прекратить наблюдение за задачей.

Задачи поддерживают отправку различных уведомлений средствами модуля Веб-мессенджер.

Выбрать желаемые уведомления и способ их доставки можно в форме настроек Веб-мессенджера:

Видео

Видеозапись с вебинара, в которой рассказывается о задачах и работе с ними:

Примечание: Функционал в продукте может меняться со временем и отличаться от показанного в ролике.

Список ссылок по теме:

  • Пример использования проектов и Задач 2.0 (видео).


Список задач
40 / 401

Для отображения и работы с задачами используется список задач, панель фильтра, диаграмма Ганта, а также кнопки управления. Сами задачи в списке открываются в слайдере, открывающимся из правой части экрана. Ознакомьтесь с его возможностями:


Элементы управления
41 / 401

В уроке рассмотрены следующие элементы управления:

  • Кнопки управления
  • Панель задач
  • Панель режимов просмотра
  • Панель счетчиков

Кнопки управления

Для управления задачами в списке используются следующие элементы управления:

  • - Кнопка Добавить задачу, которая позволяет создать новую задачу в специальной форме;
  • - Кнопка Добавить задачу по шаблону, которая позволяет создать задачу по заранее подготовленному шаблону;

    Ссылка с названием задачи позволяет перейти к форме создания новой задачи с уже заполненными полями, согласно шаблону.

    Ссылка Список всех шаблонов позволяет перейти на страницу, на которой отображается список шаблонов задач.

  • Строка поиска задачи по ее названию или идентификатору.

Панель задач

Данная панель содержит:

  • кнопки переключения режима просмотра списка задач, в зависимости от роли: ответственный, соисполнитель, постановщик, наблюдатель;
  • кнопку режима отображения всех задач, к которым вы причастны (вне зависимости от роли);
  • кнопку перехода к списку избранных задач;
  • кнопку Руковожу, которая отображается только для тех сотрудников, у которых есть подчиненные;
  • кнопку Занятость, для перехода к графику занятости по задачам;
  • кнопки перехода к проектам и отчетам;
  • кнопку Еще, открывающую меню настройки кнопок панели. Те, которые отражать не нужно можно скрыть, перетащив их сюда.

Счетчики

Над кнопками отображаются счетчики, которые показывают общее количество задач для соответствующей роли, которые требуют внимания:

Делаю

  • еще не просмотренные;
  • просроченные;
  • почти просроченные (до крайнего срока которых осталось меньше 24 часов);
  • без крайнего срока.

Поручил

  • требующие контроля (проверки);
  • просроченные (ответственным);
  • без крайнего срока.

Помогаю

  • еще не просмотренные;
  • просроченные;
  • почти просроченные (до крайнего срока которых осталось меньше 24 часов).

Наблюдаю

  • просроченные.

Подробная информация по счетчикам отображается на панели счетчиков.

Панель режимов просмотра

На этой панели расположена форма создания быстрых задач. Чтобы создать быструю задачу нужно ввести ее название в форме.

Заполнив форму и нажав клавишу Enter быстрая задача будет сохранена.

Если необходимо также заполнить дополнительные поля для быстрой задачи, то можно развернуть расширенную форму по нажатию кнопки [image].

Создание быстрых задач в версиях ниже 16.0.0.
Быструю задачу можно создать по нажатию кнопки [image] прямо в списке задач. В открывшейся форме необходимо заполнить параметры задачи:

Создание быстрой задачи

Панель режимов просмотра также кратко поясняет выбранную выше роль и содержит следующие элементы управления:

  • - кнопка, которая позволяет отфильтровать задачи в списке их по статусу:
    • все - все задачи, к которым вы причастны;
    • в работе - задачи, которые выполняются на данный момент;
    • отложенные - задачи, выполнение которых было приостановлено;
    • завершенные - задачи, которые были завершены.

    • Примечание: Для ролей Делаю и Поручил имеется возможность выбирать всех или же конкретного постановщика/ответственного, задачи которого будут отображаться в списке:

  • - кнопка, которая позволяет выбрать визуальную форму представления задач на странице:
    • Список - режим представления задач на странице в виде списка;
    • Диаграмма Ганта - режим представления, при котором задачи отображаются в виде ленточной диаграммы;
    • Группировать подзадачи - режим отображения, при котором подзадачи группируются и находятся внутри задачи.

      В этом режиме по умолчанию все подзадачи свернуты:

      Задача со свернутыми подзадачами

      Для того чтобы развернуть подзадачи, нажмите на кнопку [image], под которой отображается их общее количество. После чего подзадачи будут отображены ниже базовой задачи:

      Задача с развернутыми подзадачами

      Если режим Группировать подзадачи не включен, то подзадачи не группируются и находятся в списке вместе с задачами.

      Примечание: Если при создании задачи была использована опция Копировать задачу нескольким ответственным, то будут созданы копии основной задачи в виде подзадач и основная задача, отмеченная иконкой [image]. Эта иконка будет отображаться в обоих режимах представления задач, но только рядом с родительской задачей.

      Примечание: Подробнее про подзадачи смотрите в уроке Создание задачи.

Примечание: Для режима отображения всех задач на панели присутствует специальная кнопка:

Она служит для вызова панели фильтра, с помощью которой можно осуществлять более расширенную фильтрацию задач.

Панель счетчиков

На этой панели отображается детальная информация по счетчикам. С помощью соответствующих ссылок можно дополнительно отфильтровать задачи в списке.

Управление задачами из живой ленты.

Для работы с задачами разработан удобный виджет, отображающийся рядом с вашей живой лентой. Он наглядно группирует задачи подобно тому, как они группируются в панели задач, а также содержит счетчики задач для каждой из ролей сотрудника. Для просмотра каждой из групп задач нужно кликнуть по соответствующей ей строке.

Каждая строка содержит два счетчика:

  • - общее количество задач для пользователя.
  • - задачи, требующие внимания пользователя (просроченные, непросмотренные, без крайнего срока)

Перейти к созданию задачи можно, щелкнув по кнопке [image] данного виджета.


Список задач
42 / 401

В уроке рассмотрены следующие элементы списка задач:

  • Список задач
  • Панель групповых операций

Список задач

Внимание! В списке задач отображаются только те задачи, к которым вы непосредственно причастны (являетесь постановщиком, исполнителем или наблюдателем).

Просмотреть такие задачи, можно:
  • на личной странице сотрудника, раздел Задачи;
  • на своей личной странице в Расширенном представлении фильтра;
  • на странице группы, раздел Задачи.

    Примечание: Если в настройках группы для функционала задачи в поле Кто может просматривать все задачи указаны разрешающие права, то в рамках группы можно просматривать не только задачи, к которым вы причастны, но и чужие задачи.

Примечание:

Администратор портала при просмотре страницы Мои инструменты > Задачи может видеть все задачи сотрудников, установив в расширенном режиме фильтра опцию показать задачи подчиненных.
При просмотре же страницы Группы > [название_группы] > Задачи опция показать задачи подчиненных позволяет отобразить все задачи сотрудников в данной группе.

Начальник отдела с помощью описанных выше опций может просматривать лишь задачи только для своих подчиненных.

Начальник отдела, вдобавок, имеет те же права на задачи, что и сами подчиненные:
  • может видеть задачи, в которых сотрудник его отдела является постановщиком, ответственным, наблюдателем;
  • может редактировать задачи, менять ответственных и.т.д., если постановщиком является его подчиненный;
  • может делегировать задачу подчиненного самому себе.

Задачи по проектам (рабочим группам) группируются, причем в списке выделено название рабочей группы (выделено на рисунке красным цветом). С помощью соответствующих ссылок можно прямо в списке задач создать новую задачу в выбранном проекте.

Задачи без привязки к какой-либо рабочей группе отображаются в списке без группировки (выделено на рисунке зеленым цветом).

Форма списка имеет следующие поля:

  • Колонка выбора задач для выполнения групповых операций над ними.

    С помощью опции, расположенной непосредственно в заголовке колонки, можно выбрать все задачи, которые отображены на странице.

  • Колонка Задачи

    <название_задачи> - ссылка, позволяющая перейти на страницу просмотра задачи. Для более удобного представления задачи, в соответствии с их статусом, отмечены разным цветом:

    • зеленый - назначенные, но не принятые задачи;
    • синий - принятые сотрудником задачи;
    • черный - задачи, которые уже выполняются;
    • красный - просроченные задачи;
    • серый - завершенные или приостановленные задачи;
    • оранжевый - отклоненные задачи или задачи, ожидающие контроля.

    После названия задачи могут отображаться дополнительные иконки

    Дополнительные иконки после названия задачи

    которые означают:

    • - количество изменений задачи с момента ее последнего просмотра;
    • - количество комментариев к задаче.
    • - вложенные файлы.

    Для задач, которые используют учет затраченного времени, в списке также будет отображаться таймер, который показывает время выполнения задачи / время, отведенное на ее выполнение:

    Внимание! Одновременно может быть запущен только один таймер, чтобы избежать ошибок при учете времени выполнения задач.

    • Для ответственного таймер одновременно является и кнопкой, которая позволяет запускать / приостанавливать учет времени:

      /

      Примечание: эта кнопка также переводит статус задачи в "выполняется", а также автоматически помещает запущенную задачу в план на день.

    • Для остальных сотрудников он имеет следующий вид:

    • Если на выполнение задачи было затрачено времени больше, чем отведено, то таймер будет выглядеть следующим образом:

    Примечание: Если нажать на кнопку Завершить рабочий день при запущенном таймере выполнения некоторой задачи, то этот таймер будет автоматически поставлен на паузу.

    Меню действий:

    Пример меню действий

    Примечание: Меню действий также можно вызвать, кликнув правой кнопкой мыши по строке с задачей.

    • Просмотреть - переход к форме просмотра выбранной задачи;
    • Редактировать* - переход к форме изменения задачи;
    • Создать подзадачу - переход к форме создания подзадачи внутри выбранной задачи;
    • Создать быструю подзадачу - быстрое создание подзадачи прямо в списке задач;
    • Добавить в избранное - добавление задачи в избранное;
    • Начать выполнение - начало выполнения задачи;
    • Завершить - завершение (закрытие) задачи;
    • Принять работу* - принятие выполненной сотрудником задачи, которая требует Принять работу после завершения задачи;
    • Доделать* - повторная постановка задачи, которая требует Принять работу после завершения задачи, сотруднику с целью ее доделывания;
    • Отложить - временное приостановление задачи. Задача будет отложена пока пользователь не решит продолжить ее исполнение;
    • Возобновить - возобновление работы над завершенной задачей;
    • Копировать - переход к форме создания копии задачи на основе текущей (по умолчанию создается как подзадача);
    • Добавить в план рабочего дня - добавление задачи в отчет инструмента Рабочий день;
    • Удалить* - удаление задачи.

      • Важно! Восстановить удаленную задачу невозможно.

    Примечание: Пункты меню действий, отмеченные *, доступны только постановщику задачи.

    Статус выполнения задачи:

    • - задача ожидает принятия подчиненным*;
    • - выполненная задача ожидает принятия руководителем;
    • - требуется принять работу*;
    • - требуется принять задачу;
    • - задача выполняется;
    • - кнопка, позволяющая Начать выполнение задачи.

      • Примечание: Статусы, отмеченные *, доступны только постановщику задачи.

    Меню важности задачи:

    • - обычная задача;
    • - важная задача.

  • Колонка Срок - отображается крайний срок выполнения поставленной задачи.

  • Колонка Ответственный

    <имя_сотрудника> - ссылка, позволяющая перейти на личную страницу сотрудника, которому назначена задача.

  • Колонка Постановщик

    <имя_сотрудника> - ссылка, позволяющая перейти на личную страницу сотрудника, который назначил задачу.

  • Последняя колонка (безымянная)

    Меню выбора оценки выполненной задачи:

    • - нет оценки;
    • - положительная оценка;
    • - отрицательная оценка.

    Флажок статуса завершения задачи:

    • - кнопка, позволяющая завершить задачу прямо из списка задач;
    • - иконка, информирующая о том, что задача завершена.

Для сортировки по какой-либо из этих колонок кликните на ее заголовок, после чего в нем будет отображено направление сортировки в виде символа ↑ или ↓:

Сортировка задач в колонке

Примечание: Сортировка доступна не для всех колонок.

Колонки в списке также можно перетаскивать и менять их размеры:

С помощью соответствующего меню можно выбрать те колонки, которые будут отображаться в списке:

При наведении курсора мыши на название задачи в списке всплывет окно с информацией по задаче:

Панель групповых операций

Данная панель расположена под списком задач и позволяет выполнять следующие операции для отмеченных задач:

  • Завершить задачу;
  • Указать крайний срок;
  • Перенести крайний срок вперед;
  • Перенести крайний срок назад;
  • Сменить ответственного;
  • Сменить постановщика;
  • Добавить наблюдателя;
  • Добавить соисполнителя;
  • Добавить в избранное;
  • Удалить из избранного;
  • Указать группу;
  • Удалить.

С помощью опции Для всех можно применить требуемое действие сразу для всех задач списка (включая их подзадачи), в том числе на других страницах.


Диаграмма Ганта
43 / 401

Диаграмма Ганта - особый вид графического представления задач:

В этом режиме можно c помощью удобного графического интерфейса проводить редактирование сроков выполнения задач, а также производить планирование их исполнения. Например, перетаскивать мышью сроки начала и конца выполняющихся задач, сдвигать задачу во времени, передвигать крайний срок. Также ленту удобно прокручивать по временной шкале, просто прижав ее курсором мыши.

При наведении курсора мыши на отдельную задачу в ленте всплывает окно с главной информацией (название, постановщик, ответственный, сроки, статус, приоритет). Полоска задачи подкрашивается в соответствии с ее статусом (выполняется, просрочена, завершена). Отображаются крайние сроки по каждой задаче и «флажки» у тех, что завершились. С помощью ссылки Подробности можно перейти к просмотру задачи.

Кроме того, у каждой задачи в списке есть свое командное меню, с помощью которого можно просмотреть, отредактировать или удалить задачу, добавить ей крайний срок или тут же создать подзадачу. Вызвать его можно с помощью правого клика по нужной задаче на диаграмме или с помощью всплывающей кнопки Меню действий рядом с названием задачи в левой части формы.

Из этого же меню можно начать выполнение новой задачи, добавить в план рабочего дня, возобновить завершенную, делегировать ее коллеге, принять у подчиненного и выполнять другие доступные действия.

Кроме того, в диаграмме Ганта можно устанавливать зависимости между задачами. Можно устанавливать связи от старта или финиша основной задачи до старта или финиша зависимой. Зависимость устанавливается простым перетягиванием левой кнопки мышки. Удалить зависимость можно, дважды кликнув на ней левой кнопкой мыши и выбрав Удалить.

Важно! При изменении сроков выполнения зависимой задачи основная задача останется без изменений. Однако если будут изменены сроки выполнения основной задачи, то сроки исполнения зависимой сдвинутся автоматически.

Моя сортировка

Для работы с диаграммой Ганта так же доступен режим сортировки Моя сортировка, в котором задачи в списке можно сортировать вручную, перетаскивая их с помощью мышки.

При работе с данным режимом будут доступны следующие элементы работы со списком задач:

  • 1 - зажав данную кнопку можно переместить данную задачу в необходимое место в списке задач;
  • 2 - переместить задачу на уровень выше в зависимостях. Так, например, сделать некоторую подзадачу отдельной независимой задачей.
  • 3 - сделать задачу подазадачей для задачи, находящейся выше;

    • © «Битрикс», 2001-2008, «1C-Битрикс», 2008-2017 1С-Битрикс


Панель фильтра
44 / 401

Задачи в списке отображаются в соответствии с параметрами фильтра.

Форма фильтра имеет 2 режима представления: Обычный и Расширенный.

  • Обычный режим представления формы фильтра
  • Расширенный режим представления формы фильтра
    •

    В нижней части формы фильтра в обоих режимах представления присутствуют следующие ссылки:

    • Шаблоны - ссылка, позволяющая перейти на страницу Мои шаблоны, на которой отображается список шаблонов задач;
    • Отчеты - ссылка, позволяющая перейти на страницу просмотра Отчетов.
    • Экспорт списка в Excel - ссылка, позволяющая экспортировать список задач в Excel;
    • Экспорт списка в Outlook - ссылка, позволяющая экспортировать задачи в Outlook.

    Обычный режим представления формы фильтра

    Этот режим представления используется для быстрой навигации среди задач (отображения в списке), в зависимости от их типа и статуса.

    Обычный вид фильтра

    • Мои задачи - все задачи, в которых вы задействованы каким-либо образом;
      • Поставленные мне - все задачи, к которым вы причастны в качестве ответственного или соисполнителя;
        • Я ответственный - задачи, которые были назначены только вам;
        • Я соисполнитель - задачи, которые были назначены вам и еще нескольким сотрудникам;
      • Созданные мной - все задачи, созданные вами;
      • Наблюдаемые - все задачи, в которых вы, будете получать информацию о ходе задачи, поставленной другим сотрудником;
    • Отложенные - задачи, выполнение которых было приостановлено.
    • Завершенные - задачи, которые были завершены.
    • Все - все задачи, к которым вы причастны.

    Мои фильтры - секция, в которой можно создать и применить собственные фильтры.

    Для создания собственного фильтра необходимо воспользоваться соответствующей ссылкой, после чего откроется форма Создание нового фильтра:

    В фильтре можно использовать как единичные условия, так и целые группы условий, а также выбирать каким образом они должны использоваться: вместе (И) или же должно быть использовано какое-то одно условие (ИЛИ).

    • Ссылка Добавить условие позволяет добавить единичное условие, например, в случае создания простого фильтра.
    • Ссылка Добавить группу условий позволяет добавить целую группу, состоящую из простых условий. Это, например, может быть полезно, когда нужно осуществить выбор из двух сложных условий. В этом случае необходимо использовать 2 группы режим ИЛИ.

    Для изменения созданного ранее фильтра необходимо воспользоваться соответствующей кнопкой, расположенной около названия фильтра:

    Расширенный режим представления формы фильтра

    Этот режим представления используется для поиска задачи по каким-либо параметрам.

    Расширенный вид фильтра

    Назначение большинства полей фильтра ясно из их названия.

    Примечание: В расширенном фильтре при поиске старых задач можно также выбирать и уволенных сотрудников, причастных к задачам.

    Опция показать задачи подчиненных позволяет отобразить все доступные для просмотра сотруднику задачи (личные задачи, задачи в группах, и.т.д).

    Опция показать задачи, в которых я не участвую позволяет отобразить задачи, которые вам доступны, но вы к ним непосредственно не причастны. Например, те доступные задачи группы, в которых вы никак не участвуете.


Просмотр задачи
45 / 401
  • Описание задачи
  • Элементы управления задачей
  • Информационная панель

Сотрудник может просматривать только те задачи, к которым он причастен. Например, задачи, в которых он соисполнитель или задачи назначенные группе, в которой он состоит.

Для просмотра задачи кликните на ее заголовок в списке задач, после чего откроется окно просмотра задачи:

Нажмите на рисунок, чтобы увеличить

Примечание: Для постановщика задачи при ее просмотре доступны дополнительные ссылки и элементы управления.

Описание задачи

В центральной части страницы расположено описание задачи, чек-лист, группа задачи и элементы CRM (если заполнены соответствующие поля при создании задачи):

Кликнув на область в углу формы можно добавить данную задачу в Избранное. Кликнув в той же области по уже добавленной задаче, можно удалить задачу из Избранного.

Чек-лист позволяет создавать собственный список, пункты которого можно отмечать как выполненные. Его можно использовать, например, для учета этапов выполнения какой-либо задачи или же перечисления чего-либо.

Пункты чек-листа нумеруются автоматически и поддерживают операцию сортировки/перетаскивания. Также пункты чек-листа можно визуально разделять на группы с помощью ссылки разделитель.

Примечание: если в чек-листе будет указаны ссылка, то по ней можно будет перейти прямо из чек-листа.

Ниже можно указать рабочую группу/проект, в рамках которой будет создана задача, или же привязать какой-либо элемент из CRM.

Элементы управления задачей

- таймер, отображающий затраченное время / время, отведенное на выполнение задачи. Зеленым цветом текст отображается только для ответственного. Для приостановленных задач ответственного и всех остальных сотрудников, имеющих доступ к задаче, текст имеет серый цвет. В случае если на выполнение задачи было затрачено времени больше, чем отведено, то текст будет иметь красный цвет.

Таймер доступен только для задач, при создании которых была отмечена опция учета времени.

Под описанием задачи расположены элементы управления:

  • - кнопка Завершить, позволяющая завершить выполнение задачи;
  • - кнопка Начать выполнение, позволяющая начать выполнение задачи;
  • - кнопка Начать учет моего времени, позволяющая начать выполнение задачи с учетом затраченного времени;
  • - кнопка На паузу, позволяющая приостановить учет затраченного времени;
  • - кнопка Ещё содержит набор дополнительных операций для работы с задачей:
    • Копировать - ссылка, позволяющая создать новую задачу на основе существующей;
    • Добавить подзадачу - ссылка для создания подзадачи текущей задачи;
    • Делегировать - ссылка, позволяющая ответственному за выполнение задачи делегировать её другому сотруднику, а самому при этом стать наблюдателем.

      Делегировать задачу можно любому другому сотруднику.

      Примечание: Начальник отдела может сам себе делегировать (забрать) задачи своих подчиненных.

    • Отложить - ссылка, позволяющая временно приостановить выполнение задачи.

Если вы являетесь создателем задачи, то для вас будут доступны другие элементы управления задачей:

  • - кнопка Завершить, позволяющая завершить выполнение задачи;
  • * - кнопка Принять работу, позволяющая принять выполненную сотрудником задачу;
  • * - кнопка Доделать, позволяющая повторно поставить сотруднику задачу с целью ее доделывания;
  • - кнопка Ещё содержит набор дополнительных операций для работы с задачей;
    • Копировать - ссылка, позволяющая создать новую задачу на основе существующей;
    • Добавить подзадачу - ссылка для создания подзадачи текущей задачи;
    • Удалить - ссылка, позволяющая удалить задачу. Удалённую задачу восстановить невозможно.
  • Редактировать - ссылка, позволяющая перейти к форме создания/редактирования задачи;

Примечание: Элементы управления, отмеченные *, доступны только при постановке задачи, которая требует Принять работу после завершения задачи (при создании была отмечена соответствующая опция).

Примечание: Если просматриваемая задача содержит подзадачи, то на странице просмотра будет отображен соответствующий список, действия которого аналогичны обычному списку задач:

Под элементами управления расположена переключаемая форма, которая позволяет:

  • добавить Комментарий ;

    Кроме того, вы можете воспользоваться дополнительными командами, позволяющими сделать следующее:

    • - прикрепить файл к комментарию;
    • - добавить ссылку к комментарию;
    • - добавить видео;
    • - оформить текст в виде цитаты, если вы обмениваетесь комментариями с другими сотрудниками;
    • - упомянуть в комментарии конкретного пользователя;
    • - включить/выключить использование визуального редактора в комментарии.
  • просмотреть Историю изменений задачи;

    В истории фиксируется когда, кем и какие изменения были сделаны, переходы задачи из статуса в статус, добавление комментариев к задаче.

  • указать Затраченное время на выполнение задачи.

    Добавление нового периода времени и комментария к нему, а также их редактирование производится с помощью соответствующих элементов управления, расположенных в правой части колонки Комментарий.

    Если у задачи несколько соисполнителей, время, затраченное на выполнение задачи, будет суммироваться.

    При этом, если задача находится в статусе Выполняется и она включена в План на день, то в течение рабочего дня, с момента ее старта, будет вестись автоматический подсчет времени исполнения. С закрытием рабочего дня в списке затраченного времени появится соответствующая запись с комментарием Учет рабочего времени.

    Если задача не была закрыта в этом рабочем дне, то общий подсчет затраченного времени продолжится с открытием следующего рабочего дня, по закрытии которого будет также создана запись с указанием затраченного времени за день.

    Для задач с учетом времени записи в список будет добавляться автоматически при любой остановке таймера (пауза, завершение задачи).

По умолчанию в форме отображается ссылка Добавить комментарий.

Информационная панель

В правой части страницы расположена информационная панель. В ней отображается основная информация о поставленной задаче и следующие элементы управления:

  • поле Крайний срок - позволяет изменить дату, до которой должна быть выполнена задача;

    Примечание: Крайний срок может изменить:
    • постановщик задачи;
    • сотрудник, которому назначена задача, но только если при её создании постановщик отметил опцию Разрешить ответственному менять сроки.

  • в поле Напоминание можно настроить параметры оповещения о задаче.
  • в поле Наблюдатели с помощью ссылки наблюдать можно стать наблюдателем для текущей задачи.

Для создателя задачи будут доступны дополнительные элементы управления задачей на этой панели:

Информационная панель

  • поле Крайний срок - позволяет изменить дату, до которой должна быть выполнена задача;
  • поле Напоминание - позволяет настроить параметры оповещения о задаче;
  • поле Оценка - позволяет выставить задаче оценку;
  • в поле Ответственный по ссылке сменить можно назначить другого сотрудника, ответственного за исполнение задачи;;
  • кнопка Добавить соисполнителей - позволяет добавить к задаче еще сотрудников, которые буду также ее выполнять;
  • кнопка Добавить наблюдателей - позволяет добавить к задаче сотрудников, которые будут получать уведомления о ходе задачи, но не смогут участвовать в ней или изменять ее;
  • в поле Теги доступна ссылка добавить, которая позволяет добавить теги к задаче. Подробнее про добавление тегов смотрите в разделе Создание задач.

Примечание: Для задач с учетом затраченного времени на панели отображаются дополнительные поля:


Создание задачи
46 / 401

Создание задач

Для создания новой задачи используйте кнопку Добавить задачу на странице список задач.

После чего откроется краткая форма Новая задача:

Примечание: перейти к данной форме также можно из любой страницы, нажав на кнопку, высвечивающуюся при наведении на пункт меню Задачи.

  • В поле Введите название задачи указывается название.

    Примечание: Данное поле обязательно для заполнения.

  • Ссылка Это важная задача позволяет обозначить особенно важные для выполнения задачи. Важные задачи выделяются в списке красным.

  • При необходимости заполняется детальное описание задачи. Можно воспользоваться дополнительными командами, позволяющими сделать следующее:
    • - загрузить файл:

      • Загрузить файл или картинку - выбрать файл на жестком диске.
      • Найти в Битрикс24 - использовать для загрузки файла Битрикс24.Диск.
      • Загрузить из внешнего диска - использование внешних облачных дисков Dropbox, Google Drive, OneDrive и Яндекс.Диск.
      • Создать с помощью программ на компьютере - выбрав данную опцию можно создать загружаемый файл в появившейся форме.
    • - добавить ссылку;
    • - оформить текст в виде цитаты;
    • - упомянуть конкретного пользователя;
    • Чек-лист позволяет создавать собственный список, пункты которого можно отмечать, как выполненные. Его можно использовать, например, для учета этапов выполнения какой-либо задачи или же перечисления чего-либо.

      Ссылка добавить добавляет новый пункт к чек-листу. Ссылка разделитель позволяет визуально группировать пункты чек-листа.

    • - включить/выключить использование визуального редактора.
  • В поле Ответственный указывается сотрудник, которому назначается задача. Если будет указано более одного сотрудника, то каждому будет поставлена собственная задача.

    Примечание: Поставить задачу от имени другого человека можно только на себя.

    Форма выбора позволяет:

    • выбрать сотрудника из списка последних сотрудников, которым назначались задачи с помощью кнопки Последние;
    • выбрать сотрудника из структуры компании с помощью кнопки Сотрудники и отделы.
  • С помощью ссылки Постановщик можно изменить постановщика задачи, другими словами задача будет создана от имени другого сотрудника. По умолчанию там указано Ваше имя.

    Примечание: Например, можно создать самому себе задачу от имени другого пользователя, если он по каким-либо причинам не может ее создать.

    С помощью ссылки Наблюдатели указываются сотрудники, которые будут получать уведомления о ходе задачи, но не смогут участвовать. Уведомления будут приходить в качестве личных сообщений.

    С помощью ссылки Соисполнители укажите, если необходимо, сотрудников, которые тоже будут выполнять эту задачу.

    Примечание: ответственными за исполнение задач, наблюдателями и соисполнителями можно назначать и почтовых пользователей, не присутствующих на портале. Для этого нужно ввести адрес пользователя в соответствующее поле и добавить новый контакт.

    На указанный адрес будет прислано уведомление о назначенной задаче, вся информация по ней и ссылка на саму задачу.

    Для формы создания быстрых задач, в том числе и в диаграмме Ганта, также можно назначать ответственными почтовых пользователей.

  • Поле Крайний срок позволяет настроить срок выполнения задачи, если необходимо, с помощью календаря.

    С помощью ссылки Планирование сроков можно указать дополнительные параметры касательно сроков выполнения задачи:

    Примечание: Продолжительность задачи можно указать как с помощью полей Начать задачу с и Завершение, так и с помощью полей Начать задачу с и Длительность, причем во втором случае в поле Завершение дата окончания задачи подставится автоматически.

    Ссылка Еще позволяет указать дополнительные настройки создаваемой задачи:

  • Опция Разрешить ответственному менять сроки позволяет ответственному сотруднику изменять срок в поставленной ему задаче.
  • Опция Пропустить выходные и праздничные дни игнорирует нерабочие дни при планировании сроков. Настроить выходные рабочие дни можно нажав на кнопку настроить.
  • Установите опцию Принять работу после завершения задачи, если хотите проверять выполненные ответственным задачи. При установленной опции, после выполнения задачи ответственным, она будет не закрыта, а будет ожидать вашего контроля. Об этом будет свидетельствовать соответствующий статус и цвет задачи в списке задач.
  • При установке опции Добавить себе в избранное созданная задача будет в избранном.
  • Если необходимо, то задачу можно Добавить в план рабочего дня инструмента Рабочий день. Эта опция доступна только если вы являетесь ответственным в задаче.
    • Примечание: Опция доступна при создании задачи. Задачу, созданную ранее, добавить в план дня можно с помощью инструмента Рабочий день.
  • При установленной опции Сроки определяются сроками подзадач сроки исполнения задачи будут автоматически рассчитываться на основе ее подзадач. Датой начала задачи будет самая ранняя из дат начала у подзадач, а окончания - самая поздняя из дат завершения.
  • Если установить опцию Автоматически завершать задачу при завершении подзадач (и наоборот), то задача будет автоматически завершена, когда будут завершены все ее подзадачи. Так же работает и в обратном направлении - все подзадачи будут автоматически завершены, когда будет завершена основная задача.

Нажав на вкладку Дополнительно можно настроить дополнительные параметры задачи:

Каждый из дополнительных параметров можно отобразить в форме по умолчанию, нажав на кнопку у соответствующего параметра:

  • В поле Проект указывается проект/группа, в которой будет создана задача.
  • С помощью опции Учет времени можно включить подсчет времени, затрачиваемого на задачу, и задать время ее выполнения.

    Для сотрудника, ответственного за задачу, таймер производит отсчет в реальном времени, и только он может приостанавливать/запускать его с помощью соответствующих элементов управления. Начальник сотрудника, ответственного за выполнение задачи, не может запустить или остановить таймер. При смене ответственного таймер и его показания закрепляются за новым сотрудником. При завершении рабочего дня таймер автоматически останавливается.

    Другими словами таймер останавливается для ответственного только по его воле или же при потере прав, например, при удалении задачи.

    Для всех остальных, кроме ответственного, имеющих доступ к этой задаче будет отображаться время, которое было зафиксировано в последний раз при остановке таймера (пауза, завершение задачи, делегирование).

    Примечание: После включения учета времени:
    • В списке задач появятся соответствующие иконки со временем;
    • В инструменте Рабочий день будет отображен список задач с "учетом времени";
    • При просмотре самой задачи изменятся некоторые элементы управления, а в журнал будет заноситься информация по затраченному времени.

  • Ссылка Напомнить о задаче позволяет добавить к задаче уведомление, которое будет отправлено на e-mail или в качестве мгновенного сообщения.

    Если у задачи установлен крайний срок, то напоминание может быть отправлено за указанное количество дней или часов до его наступления. Если крайний срок не указан, то напоминание можно назначить на конкретную дату и время.

    Примечание для коробочной версии Битрикс 24: Напоминания работают в интранете и экстранете.

  • Ссылка Повторять задачу позволяет автоматически создавать новую (независимую) задачу (включая задачу нескольким ответственным) через заданные промежутки времени. Выбрав опцию Сделать задачу регулярной можно перейти к настройкам создаваемого шаблона.

  • Опция Гант служит для создания связей задач на диаграмме Ганта. Ссылка + Добавить предшествующую задачу позволяет указать задачу, для которой данная задача будет зависимой.

  • К задаче можно привязать какие-либо элементы CRM с помощью соответствующего поля.

    Важно! Задача, привязанная к сущности CRM, отобразится в карточке сущности на закладке Дела и появится на странице Мои дела ответственного за ее выполнение. Дальнейшее редактирование\удаление такой задачи также будет отображаться и в CRM.

  • С помощью ссылки Сделать подзадачей можно указать задачу, по отношению к которой текущая задача будет создана в качестве подзадачи.

  • Если необходимо, то с помощью ссылки Теги и соответствующей формы добавьте к задаче необходимые теги.

    Примечание: Теги позволяют значительно упростить поиск задач с помощью расширенного режима представления формы фильтра.

    • Сначала теги необходимо создать.

      Для этого напишите требуемые теги через запятую в форме тегов и нажмите кнопку [+]:

      после чего новые теги будут доступны сразу в форме выбора тегов:

    • Для того чтоб добавить теги к задаче, просто выберите их в форме тегов и нажмите кнопку Выбрать.

    Примечание:
    • Для редактирования тегов в форме тегов нажмите кнопку Редактировать теги, после чего можно будет исправить теги в полях формы или удалить их с помощью кнопки х.

      Затем нажмите кнопку Сохранить изменения.

    • Для изменения тегов задачи используйте ссылку изменить, после чего в форме отметьте желаемые теги.

      Изменение тегов задачи

    • Для удаления тегов из задачи просто снимите отметки со всех тегов в форме.

  • Администратор портала может также добавлять к задаче Пользовательские поля.

    Пользовательское поле - инструмент, позволяющий добавлять к объектам системы поля, не предусмотренные штатным функционалом.

  • Опция Связанные задачи позволяет указать задачи, имеющие отношение к данной. Опция используется для отслеживания связей задач.


Создание задачи с помощью e-mail
47 / 401

Внимание! Для отправки e-mail писем в Живую ленту в продуктах «Битрикс24 в коробке» (и на тарифном плане Компания с услугой Свой домен облачного сервиса «Битрикс24») портал должен быть доступен из Интернета, а для домена портала должна быть обязательно указана MX-запись почтового сервера Битрикс24: mail-001.bitrix24.com - для этого обратитесь к администратору вашего домена. Для остальных тарифных планов облачного сервиса «Битрикс24» никаких настроек делать не нужно.

Создать задачу можно через электронное письмо, переслав его на портал.

Для этого нужен лишь специальный e-mail Для создания задачи. Получить его можно в разделе Моя страница, нажав на ссылку показать:

Примечание: Данный email-адрес является уникальным для каждого сотрудника и пользователя Экстранет, использовать его, кроме как для создания задач, не имеет смысла.

После этого уникальный e-mail появится в поле Для создания задачи:

Далее этот email-адрес можно использовать для создания задачи. Название задачи нужно указать в теме письма. В теле письма указывается подробное описание задачи и необходимую информацию для её выполнения:

На основании письма будет создана задача. Постановщиком и Ответственным будет назначен тот, на чей адрес было отправлено сообщение. Данную задачу уже можно будет редактировать по своему усмотрению:

Нажмите на рисунок, чтобы увеличить


Создание задачи из комментария в Живой ленте
48 / 401

Создание задачи доступно на основе комментария записи в Живой ленте. Рассмотрим пример.

Для того, чтобы создать задачу, необходимо во вкладке Ещё выбрать ссылку Создать задачу.

Примечание: создавать задачу можно на основе как своих, так и чужих комментариев. При этом список ссылок во вкладке Еще будет меняться.

О создании задачи пользователю будет выведено специальное уведомление.

Посмотреть на созданную задачу, а также перейти к ее редактированию можно при нажатии на кнопку Перейти к задаче.

Когда задача будет создана, к записи в Живой ленте будет добавлен соответствующий комментарий.


Шаблоны задач
49 / 401
Видеоролик по работе с задачами

Внимание: содержание ролика может несколько отличаться от текущего.

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если нет возможности прослушать звуковое сопровождение, то с помощью значка [image] в правом верхнем углу ролика можно просмотреть текст.

Шаблоны позволяют упростить создание однотипных задач.

Для перехода на страницу со списком шаблонов воспользуйтесь ссылкой Список всех шаблонов кнопки Добавить задачу по шаблону или ссылкой Шаблоны на панели фильтра.

Создание шаблона задачи

Для создания нового шаблона используется кнопка Добавить шаблон.

Процесс создания шаблона аналогичен созданию обычной задачи.

Опция Крайний срок через ... дней после создания задачи позволяет указать в шаблоне дату крайнего срока, которая будет автоматически задаваться для создаваемой по шаблону задачи путем прибавления указанного количества дней к дате ее создания.

Примечание: Если при создании шаблона отметить опцию Повторять задачу каждый, то новые задачи будут создаваться автоматически, в зависимости от указанных настроек. Для того чтобы задачи больше не создавались, необходимо удалить исходный шаблон.

Также, при создании задачи с повтором, она автоматически превратится в шаблон.

Шаблоны, как и сами задачи, можно прикреплять к элементам CRM.

Также имеется возможность создавать чек-листы и в шаблонах задач.

Кроме того, администратору сайта доступна опция Шаблон задачи для вновь добавляемого сотрудника. Эта задача будет автоматически ставиться новому сотруднику при его приеме на работу и добавлению его на портал.

Примечание: данная возможность пока не присутствует в "коробочной" версии Битрикс24.

Также существует возможность делиться своими шаблонами задач с другими сотрудниками.

Есть 2 уровня доступа:

  1. Полный доступ к шаблону задачи - пользователь, наделенный такими правами, может просматривать шаблон, редактировать его и создавать задачи по шаблону;
  2. Чтение шаблона задачи - пользователю доступны только просмотр шаблона и создание задачи. Редактировать шаблон он не может.

Создание задачи на основе шаблона

Создание задачи по шаблону сводится к тому, что необходимо выбрать желаемый шаблон с помощью кнопки Добавить задачу по шаблону на странице со списком задач, и затем в открывшейся форме создания задачи с уже заполненными согласно шаблону полями нажать кнопку Поставить задачу.

Редактирование шаблона

Для того, чтобы отредактировать шаблон, необходимо перейти в Список всех шаблонов и с помощью пункта меню действий у соответствующего шаблона выбрать пункт Редактировать.

Создание шаблонов с подзадачами

Важной функцией шаблонов является то, что можно создавать комплексные задачи, содержащие в себе подзадачи. Это значительно экономит время в случае, если вам нужно регулярно выполнять какую-то важную работу и не теряться во множестве задач в процессе выполнения.

Для того чтобы создать подзадачу, нужно выбрать нужный вам шаблон и нажать кнопку Добавить подзадачу для шаблона.

Просматривать шаблоны вместе с их подзадачами можно так же как и обычные задачи.


Экспорт задач
50 / 401
Интерактивный видеоролик по экспорту задач

Внимание: содержание ролика может несколько отличаться от текущего.

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если нет возможности прослушать звуковое сопровождение, то с помощью значка [image] в правом верхнем углу ролика можно просмотреть текст.

  • Экспорт списка задач в Excel
  • Экспорт задач в Outlook

Экспорт задач осуществляется с помощью ссылок, расположенных на панели фильтра.

Экспорт задач в Excel

Экспорт списка задач в Excel будет полезен тем пользователям, которые захотят построить на основе этих данных свои отчеты, графики или, например, распечатать список.

В сгенерированный xls-файл попадают все задачи попадающие под текущий фильтр.

Экспорт задач в Outlook

Внимание! Для полноценной интеграции портала с Outlook требуется версия не ниже Outlook 2007.

Для двусторонней синхронизации задач портала с задачами MS Outlook необходимо:

  • Воспользоваться ссылкой Экспорт списка в Outlook на панели фильтра.
  • По этой команде запустится MS Outlook, при этом будет выведено следующее предупреждение:

  • Нажмите кнопку Да для продолжения подключения задач, либо кнопку Дополнительно... для вызова диалога дополнительной настройки параметров:

  • Введите Имя папки (название задач) и Описание задач и нажмите кнопку OK.

    После этого вам нужно будет ввести свои авторизационные данные - логин и пароль - для работы на портале, и в результате в MS Oulook будут добавлены задачи, в данном случае Мария Бражникова - Рабочие задачи:

    Примечание: Настройка экспорта производится только один раз, после чего задачи на портале будут автоматически синхронизироваться с MS Outlook.

При добавлении новой задачи в MS Outlook она будет автоматически добавлена в список задач на портале.

Для этого выполните следующее:

  • В меню Создать выберите пункт Задача:

  • Заполните поля: Назначено, Тема, Дата начала, Срок и Описание.

    Внимание! В поле Назначено необходимо указывать адрес электронной почты пользователя портала. Для удобства можно импортировать контакты в адресную книгу MS Outlook и потом выбирать ответственного в поле Назначено уже из адресной книги.
  • Нажмите кнопку Сохранить и закрыть.

После чего задача появится в списке задач в MS Outlook и на портале.

Как уже было сказано, синхронизация с Outlook выполняется автоматически, если задача создана со стороны программы. Если же задача была создана на портале, то в Outlook она передается при клике по кнопке Доставить почту (Сервис > Отправить/получить > Доставить почту).

При синхронизации задач передаются те поля, которые поддерживает Outlook и наоборот.
На данный момент синхронизируются только основные поля: Название, Описание, Статус, Приоритет, Ответственный, Крайний срок, Планируемая дата начала.

Примечание: При синхронизации задач, которые были изменены на стороне Outlook, на портале будут обновлены только те поля задачи, на изменение которых у пользователя есть права на портале. Другими словами можно изменить только те поля, что и на самом портале.

Например, синхронизация не пройдет, если пользователь не является постановщиком и пытается переименовать задачу.


Проекты
51 / 401

На странице Проекты отображается распределение задач по статусам для проектов/групп, в которых вы состоите.

В колонках таблицы для статусов отображается общее количество задач и количество задач, требующих внимания (счетчики).

Ссылка еще хх участник позволяет просмотреть список все сотрудников, состоящих в группе.


Руковожу
52 / 401

Если вы являетесь руководителем отдела, то на панели задач для вас будет доступна кнопка Руковожу, которая позволяет просматривать задачи подчиненных по отделам и подотделам.

В колонках таблицы для каждой роли отображается общее количество задач и количество задач, требующих внимания (счетчики).

Для перехода к просмотру задач сотрудника соответствующей роли нужно воспользоваться ссылкой в колонке.


Отчеты
53 / 401

Обычный сотрудник строит отчет только по своим задачам. Он может посмотреть свои данные по эффективности и сравнить с итоговыми результатами своего подразделения. Руководители подразделений - строят отчеты по задачам всех проектов, которые находятся в их ведении, директор - по всем задачам, в любом разрезе, начиная от сотрудника и отделов до всей компании.

Примечание: отчеты создаются индивидуально каждым пользователем для себя, поэтому для других они невидимы.

Для просмотра доступных отчетов используйте ссылку Отчеты на панели задач.


Конструктор отчетов
54 / 401

Универсальный конструктор отчетов - это отдельный модуль, который позволяет сотрудникам самим конструировать отчеты для разных объектов и в дальнейшем многократно их запускать. Отчеты изменяются в реальном времени, в зависимости от хода выполнения задач.

  • Просмотр отчетов
  • Типовые отчеты
  • Пользовательские поля
  • Создание нового отчета
    •
    Интерактивный видеоролик о работе с Конструктором отчётов

    Внимание: содержание ролика может несколько отличаться от текущего.

    Интерактивный видеоролик (требуется выполнение действий пользователем). Продолжительность 6 минут 4 секунды. Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

    Ролик озвучен. Если нет возможности прослушать звуковое сопровождение, то с помощью значка [image] в правом верхнем углу ролика можно просмотреть текст.

    Просмотр отчетов

    Список отчетов

    С помощью меню действий в списке отчетов можно Редактировать, Удалять или Копировать отчеты.

    Для просмотра отчета используйте ссылку с его названием.

    Отчет

    Для сортировки данных отчета по какой-либо колонке достаточно кликнуть на её заголовок, после чего он изменит цвет фона. Также в нем будет отображено направление сортировки в виде символа ↑ или ↓.

    Под таблицей расположена итоговая информация по всему отчету, которая подсчитывается только для численных данных.

    Чтобы сохранить отчет в виде файла .xls либо открыть этот файл для просмотра или печати в каком-либо приложении, нажмите Экспорт Excel.

    Типовые отчеты

    При первом обращении к сервису создания отчетов система сообщает, что у него нет ни одного сконструированного отчета и предлагает создать Типовые отчеты.

    Примечание: Для разных типов отчетов (Задачи, CRM) в поставке продукта идут свои типовые отчеты.

    Примечание: Начиная с версии 14.5.2 типовые отчеты теперь нельзя редактировать. При необходимости, можно создать копии типовых отчетов и уже их изменить под свои потребности.

    Пользовательские поля

    Примечание: На данный момент пользовательские поля поддерживаются в отчетах CRM для Сделок, Лидов и Счетов.

    Начиная с версии 14.5.2, в отчетах появилась возможность использовать пользовательские поля, причем как для построения самого отчета, так и в качестве полей фильтра.

    Для удобства, в форме редактирования отчета, такие поля выделены другим цветом:

    Внимание! С версии 15.5.0 добавлена поддержка множественных пользовательских полей, но при работе с ними будет доступен не весь функционал работы с пользовательскими полями.

    Внимание! После удаления пользовательского поля в системе невозможно будет построить отчеты, связанные с этим полем. Для возобновления возможности построения таких отчетов необходимо перейти к их форме редактирования и удалить из нее несуществующие пользовательские поля.

    Создание нового отчета

    Отчет строится автоматически - достаточно его один раз создать и настроить.

    Для этого используйте ссылку Добавить отчет на странице со списком отчетов, после чего откроется форма создания отчета:

    При создании нового отчета необходимо ввести его название, и указать отчетный период (временной интервал, неделя, месяц и т.д.).

    Секция Колонки позволяет настроить колонки, отображаемые в отчете:

    • Опция Вычислить колонку позволяет отображать в отчете вычисленную величину, например, сумму или количество уникальных значений в колонке.

      Примечание: Вычисляемая величина зависит от конкретного типа данных.

    • Кнопки со стрелками позволяют изменить порядок следования колонок в итоговом отчете.
    • Для изменения названия колонки или же ее удаления используются соответствующие элементы управления, которые отображаются после её названия при наведении курсора.

      Примечание: Для численных типов данных доступна возможность выражать данные колонки в процентах с помощью элемента управления %:

    • Ссылка Добавить позволяет добавить в отчет новую колонку. За раз можно добавить сразу несколько колонок, отметив их в форме.

    Примечание: с версии 15.6.0 модуля Задач в отчеты можно включать загруженные документы и закрепленные за соответствующей задаче элементы CRM.

    Секция Фильтр позволяет настроить параметры фильтрации отчета:

    • Кнопки + и - позволяют добавить еще одно условие для фильтра или удалить текущее.

      При добавлении нескольких условий, над ними появится выпадающий список, который позволяет Ограничить результаты, выводимые в отчете по всем или любому из добавленных условий.

    • Кнопка И / Или позволяет построить дерево условий:

      На приведенном примере для построения отчета применится условие:
      (Сотрудник = Бандурин и Приоритет = Высокий) или (Сотрудник = Тихомиров и Приоритет = Низкий).

      Примечание: Уровень вложенности условий искусственно ограничен 4-мя уровнями, чтобы не усложнять интерфейс.

    • Опция Изменять фильтр в отчете позволяет вывести отмеченные условия на панель фильтра и изменять их уже непосредственно при просмотре отчета.
    • С помощью соответствующей опции можно ограничить Максимальное количество элементов, выводимых в отчете.

    Опция Выводить диаграмму позволяет строить диаграммы для колонок с отмеченной опцией Вычислить колонку:

    Примечание: построение диаграмм доступно не для всех типов данных.

    При просмотре отчета легенда позволяет выбрать, какие данные будут отображаться на диаграмме.

    Конструктор позволяет предварительный просмотр отчета - вы можете тут же поправить свой отчет и обновить предпросмотр.

    В секции Общий доступ можно указать сотрудников или целые группы, которым также будет доступен шаблон созданного отчета. Обратите внимание, что будет доступен именно шаблон, а не ваш личный отчет. Нажав на кнопку Добавить еще укажите тех, кому также будет доступен созданный вами отчет.

    Настройки общего доступа


Типовые отчеты
55 / 401

Типовые отчеты - шаблоны наиболее часто используемых отчетов, входящие в состав продуктов «1C-Битрикс».

Занятость по проектам

Отчет содержит информацию о том, сколько задач исполняется сотрудником по каждому проекту, а также общее время выполнения задач. В фильтре можно выбрать проекты, информацию о которых вы хотите включить в отчет.

Задачи на месяц

Отчет содержит список задач, которые необходимо выполнить в данном месяце. В отчет включаются текущие, отложенные к этому месяцу, а так же просроченные, но еще не выполненные задачи, которые нужно выполнить как можно скорее. Также отчет содержит даты создания, даты начала и конца выполнения задач, а так же крайние сроки выполнения каждой из них.

Отчет по эффективности

Отчет помогает оценить эффективность сотрудника за указанный период. В отчете содержится количество новых, завершенных и пребывающих в работе задач, а также ключевые поля, по которым и оценивается эффективность сотрудника:

  • Просрочено - указывается процент невыполненных в срок задач от общего числа задач в работе.
  • Оценено - процент задач, которым была поставлена оценка, к общему числу задач в работе.
  • Эффективность - процент положительно оцененных задач от общего числа задач в работе.

Задачи за прошлый месяц

В данном отчете содержатся выполненные задачи за прошедший месяц, а так же информация по ним (приоритет, затраченное время, статус и оценка). В отчете можно выводить не только выполненные задачи, если задать нужное значение для поля Статус в фильтре.

Ресурсный учет по задачам

Отчёт показывает список задач в рамках проекта, а также затраты времени на их исполнение.

Ресурсный учет по исполнителям

Отчёт показывает сколько времени затратил каждый исполнитель на выполнение задач с ресурсным учётом. Можно так же посмотреть затраты ресурсов по каждому из исполняемых проектов.


Пример создания отчета
56 / 401

Допустим, руководителю отдела хочется проверить, как его сотрудники исполняли в прошедшем месяце его особо важные поручения по некоторому проекту. Создадим отчет, который будет решать данную задачу:

  • В поле Отчетный период выберем вариант интервал и с помощью элемента управления календарь укажем конкретные сроки. Задачи, активные в этот интервал времени, попадут в отчет. То есть все, кроме тех, что были завершены ранее даты начала интервала.
  • В секции Колонки с помощью ссылки Добавить выберем из формы нужные колонки, и затем, с помощью кнопок со стрелками, расположим их в нужном порядке. Для колонок В статусе: Завершена, В статусе: В работе и В статусе: Просрочена выберем опцию Вычислить колонку, и укажем вычислить сумму. Таким образом, будет наглядно видно, сколько задач сотрудник сделал, сколько у него осталось задач, и в исполнении скольких задач он не уложился по срокам.
  • Для опции Сортировать по колонке укажем Ответственный: Ф.И.О.

    • В секции Фильтр настроим ограничение выводимых результатов в конечном отчете по следующей логике:

    (Проект = Продажи), (Постановщик = Андрей Горетов) и ((Приоритет = Высокий) или (Приоритет = Средний))

  • С помощью ссылки Выберите поле укажем Проект - Выбрать..., а затем с помощью появившейся ссылки Выбрать отметим нужный проект или группу (в нашем случае Продажи).
  • Для условия Проект установим опцию Изменять фильтр в отчете, чтобы руководитель мог быстро сменить проект для которого он хочет проверить работу своих подчиненных, в случае, если проектов несколько.
  • С помощью кнопки + добавим второе условие. Аналогичным образом в полях условия выбираем Постановщик - Андрей Горетов.
  • В появившемся сверху списке Ограничить результаты по выбираем всем, это позволит применить сразу все условия фильтра для выводимых результатов в отчете. Вариант любому позволит выводить в отчет те результаты, которые попадают под действие любого из условий фильтра.

  • Для добавления дополнительных условий нажмем на кнопку И / Или. Это позволит создать следующую логику:
    (Приоритет = Высокий) или (Приоритет = Средний)
  • Устанавливаем в первом дополнительном условии следующие опции Приоритет, Равно, Высокий;
  • Во втором - Приоритет, Равно, Средний;
  • В списке из следующих условий выполняются необходимо выбрать вариант Любое.

В итоге получим отчет следующего вида:


Занятость по задачам
57 / 401

Для задач есть возможность посмотреть Занятость. В этом режиме графически отображаются задачи со сроками их выполнения. Чтобы задача отобразилась в этом режиме, для неё необходимо указать даты начала выполнения и завершения через Планирование сроков.

  • В поле Задача можно указать статус задач, которые должны отображаться в графике.
  • Отображаемые задачи можно отфильтровать по отделам, указав нужный в поле По отделу.
  • Если нужно посмотреть занятость отдельного пользователя, его нужно указать в поле Сотрудника.

    Примечание: для руководителя также занятость всех его подчиненных. Если пользователь не является руководителем, то ему будет видно только сроки исполнения задачи, но полную информацию о ней он не сможет получить.

  • В поле За период нужно указать даты начала и конца отчетного периода. Если период исполнения задачи пересекается с выбранным периодом, то они будут отображены.

    Важно! Максимальный интервал между датами - 90 дней. Если интервал будет больше, то даты будут автоматически изменены.


Пример работы с задачами
58 / 401

От имени руководителя Отдела продаж создадим важную задачу с конкретными сроками выполнения для сотрудников отдела Бухгалтерия, находящегося в Калининграде. При этом информация о выполнении этой задачи должна будет поступать директору, находящемуся в Москве.

Задача будет поставлена с указанием контроля ее выполнения, и не будет закрыта, пока все сотрудники не выполнят ее и руководитель отдела продаж не подтвердит это.

Также, каждый из сотрудников должен будет создать чек-лист внутри задачи, в соответствии с его обязанностями.

Порядок действий по созданию задачи для руководителя Отдела продаж

  • Создадим новую задачу и укажем ее название и описание.

  • Укажем, что задача является важной.

  • Перечислим всех ответственных, которым будет поставлена своя отдельная копия задачи.

  • Добавим в наблюдатели руководителя отдела продаж в Москве, чтобы он получал информацию о выполнении задач.

  • Откроем ссылку Планирование сроков.

    Укажем сроки выполнения задачи.

  • Нажав на ссылку Еще, установим опцию Принять работу после завершения задачи для того, чтобы при завершении задачи сотрудником она не закрывалась, а ждала контроля постановщика.

  • Добавим к задаче Теги. Создадим их с помощью ссылки Добавить и формы тегов.

    Перечислим все необходимые теги и добавим их к задаче.

  • После ввода всех настроек нажмем кнопку Поставить задачу.

Созданная задача будет выглядеть следующим образом.

Порядок действий по выполнению задачи для сотрудника Бухгалтерии

После постановки задачи она появится в списке задач ответственного сотрудника.

При просмотре она будет иметь следующий вид.

Также сотрудник получит уведомление, оповещающее о новой задаче.

Ответственный сотрудник должен составить чек-лист. По мере исполнения задачи пункты чек-листа можно будет вычеркивать.

  • Приступим к выполнению задачи, нажав кнопку Начать выполнение.
  • С помощью ссылки Добавить комментарий добавим сообщение о проделанной работе.

  • К комментарию также прикрепим файл, который будет доступен для скачиваний всем участникам исполнения задачи.

  • Затем, с помощью кнопки Завершить «закроем» задачу.

Так как постановщиком была установлена опция Принять работу после завершения задачи, то задача не будет завершена, о чем будет свидетельствовать соответствующий значок и цвет в списке задач.

И только после проверки руководителем отдела продаж, задача будет окончательно закрыта. Если руководитель примет решение отправить задачу на доработку, то ответственный пользователь также получит об этом уведомление.

Порядок действий по принятию задачи для руководителя Отдела продаж

Как только сотрудник приступит к выполнению задачи, в списке задач будет отображен соответствующий значок.

После того, как он завершит выполнение, то руководителю придет уведомление об этом.

В счетчиках задач отобразится количество задач, требующих контроля.

Руководитель может оценить работу сотрудника отправить на доработку или же принять ее.


Пример использования группировки задач
59 / 401

Полученное сообщение: Как группировать задачи в проектах (группах)? К примеру есть n-групп. Каждая группа это коттеджный поселок. В каждом поселке есть пул задач по строительству канализации, электричества, газопровода, водопровода, задачи отдела маркетинга и т.д. Как их можно сгруппировать внутри группы? Только используя теги и потом фильтры для просмотра?

Реализовать данное задание можно стандартными инструментами модуля Задач:

  • Создадим несколько групп, каждая из которых будет соответствовать некоторому коттеджному поселку.

    Нажмите на рисунок, чтобы увеличить

  • При создании задач в поле Проект будем указывать, что они выполняются в рамках одной из созданных ранее групп.

    Нажмите на рисунок, чтобы увеличить

  • Задачи созданные в рамках групп автоматически группируются в списке задач, поэтому можно сразу увидеть, какие задачи к какому проекту относятся.

    Нажмите на рисунок, чтобы увеличить

  • На странице Проекты можно посмотреть количество задач, выполняемых в рамках каждой группы в табличном виде.

    Нажмите на рисунок, чтобы увеличить

  • Если необходимо добавить еще больше уровней группировки задач, то их можно использовать в виде подзадач для какой-то основной задачи.

    Нажмите на рисунок, чтобы увеличить


Чат и звонки
60 / 401

Внутренние коммуникации в продуктах компании "1С-Битрикс" представлены несколькими решениями: встроенный Веб-мессенджер позволяет писать, звонить и видеть коллегу через корпоративный портал, а мобильное и десктопное приложения позволяют сотрудникам всегда оставаться на связи.

В данной главе представлены описания и принципы работы с функционалом внутренних коммуникаций на портале.


Бизнес-чат
61 / 401

Интерактивный инструмент Бизнес-чат позволяет эффективно общаться и получать информацию прямо через браузер:

  • пользователи портала общаются посредством мгновенных персональных сообщений, в том числе и групповых чатов (как в интернет-мессенджерах), с сотрудниками компании и с внешними экстранет-пользователями;
  • пользователи портала общаются посредством видео- и аудиозвонков, а также могут пользоваться возможностями IP-телефонии;
  • список контактов формируется согласно структуре компании, также доступен поиск контактов;
  • центр нотификации выводит информацию о новых событиях на любой странице портала;
  • с помощью статусов индицируется присутствие сотрудника на портале (онлайн);
  • присутствующие на портале сотрудники ведут «живой» диалог;
  • c помощью простых настроек можно управлять способами доставки уведомлений, отображением контакт-листа и др.
  • в общении в чате можно обмениваться файлами и «богатыми ссылками»;
  • в общении в чате можно использовать быстрые клавиши и BB-коды;
  • не работающим в текущий момент на портале пользователям сообщения доставляются позже;
  • ведется архив сообщений диалогов пользователей просмотреть архив личной переписки можно с помощью кнопки «История сообщений» в окне диалога.

Внимание! Все непрочитанные в Бизнес-чате уведомления автоматически отправляются на почту сотрудника. Т.е. если вы не авторизованы на портале, но на ваше имя пришло уведомление о новой задаче или сообщении, то в течение 10 минут это уведомление будет отправлено на почту.

Помимо встроенного в портал Бизнес-чата есть десктопное приложение Битрикс24 для Windows и Mac OS X и мобильное приложение Битрикс24.


Внешний вид
62 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Бизнес-чат: Панели на странице. Настройки

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Панель быстрого доступа и уведомлений

Панель быстрого доступа и уведомлений размещается справа на портале по всей высоте окна браузера:

На панели присутствуют кнопки, рядом с которыми также отображается счетчик непрочитанных сообщений и уведомлений:

1 - вызывает окно Центра уведомлений, в котором выводится информация о различных событиях на портале.

2 - вызывает окно чатов Открытых линий.

3 - вызывает окно Бизнес-чата с Поиском контактов.

4 - вызывает чат с конкретным человеком.

5 - вызывает окно набора номера (иконка будет активна, если настроена телефония на портале).

Внешний вид окна Бизнес-чата

Окно Бизнес-чата отображается поверх портала.

С помощью кнопок управления окном можно:

  • Установить приложения Бизнес-чата на различные платформы - ссылки доступны по иконкам платформ.
  • Закрыть окно Бизнес-чата (также можно закрыть нажатием клавиши Esc).
  • Фон - выбрать один из нескольких предустановленных фонов.

Бизнес-чат

Окно Бизнес-чата состоит из трех основных частей - панели Управления, панели Контактов и окна Диалога.

  • Панель Управления - здесь отображаются кнопки управления и счетчики:
    • - Сообщения: отображает счетчик личных сообщений в Бизнес-чате и осуществляет переход в диалог последнего чата;
    • - Открытые линии: отображает счетчик обращений новых через Открытую линию (появляется, если включена опция Открытые линии выделять в отдельный список в Настройках Бизнес-чата);
    • - Уведомления: отображает счетчик уведомлений на портале и осуществляет переход в окно уведомлений;
    • - Телефонный звонок: открывает окно набора телефонного номера;
    • - Настройки: открывает окно настроек Бизнес-чата;
    • - Живая лента: отображает счетчик сообщений в Живой ленте и осуществляет переход в Живую ленту портала;
  • Панель Контактов:
    • 1 - панель поиска контактов и создания чатов.
    • 2 - контакт-лист.
    • 3 - панель установки статуса.
  • Окно Диалогов:
    • 4 - панель информации о чате: аватарка контакта\чата, тема чата, контроль уведомлений и архив чата.
    • 5 - окно диалога.
    • 6 - панель визуального редактора и ввода сообщения.


Настройки Бизнес-чата
63 / 401

Настройки Бизнес-чата

Настройки Бизнес-чата доступны по кнопке [image] в боковой части контакт-листа.

На закладке Основные настраиваются опции:

  • Показать/скрыть сообщения в списке "Последние" - можно показать/скрыть вывод текста последнего сообщения под аватаром пользователя в списке контактов .
  • Показать/скрыть отсутствующих пользователей - можно показать/скрыть вывод в списке контактов отсутствующих сотрудников.
  • Открытые линии выделять в отдельный список - при включении опции справа в меню будет доступна отдельная иконка, где будут помещены все дилоги открытых линий, тем самым разговоры с коллегами не будут мешать разговору с клиентами;
  • Формат списка открытых линий:
    • Разделен на неотвеченные/отвеченные - в списке диалогов в первую очередь будут показаны ожидающие вашего ответа, даже если вы уже просмотрели сообщение, но не ответили на него.
    • Сортировка диалогов от старых к новым - сортировка выполняется по дате создания диалога. Соответственно новые попадают в конец списка.
    • Диалоги с последними сообщениями сверху - сортировка выполняется по дате последнего сообщения в диалоге.
  • Загружать/не загружать последние сообщения;
  • Загружать/не загружать историю уведомлений;
  • Автоматическое прочтение уведомлений - если у вас большой поток уведомлений, отключите эту опцию "Автоматическое прочтение уведомлений" и контролируйте прочтение вручную. Это позволит использовать уведомления как "to-do" лист и не пропустить важные события;
  • Использовать большие смайлы - можно включить/отключить использование больших смайлов в чатах;
  • Включить/отключить звуковые оповещения - можно включить/отключить проигрывание звуков при получении каких-либо уведомлений;
  • Включить уведомление о появлении в сети - если важно знать, когда кто-то появляется в сети, активируйте эту опцию. Если вам не требуется отслеживать всех пользователей, вы можете активировать опцию только для определенных пользователей;
  • Сочетание клавиш для отправки сообщения - можно выбрать клавиатурные сочетания отправки сообщений: Ctrl+Enter или Enter;
  • Цвет фона вашего диалога в мобильном чате - можно выбрать цвет диалога в чатах мобильного приложения (данным цветом будет отображаться диалог у вашего собеседника).
  • Запускать приложение при клике на панель быстрого доступа - если десктоп-приложение запущено, то при клике на панели быстрого досупа на иконке собеседника будет открываться чат в десктоп-приложнии.

На закладке Уведомления настраиваются опции различных оповещений:

  • Простой режим, позволяющий настраивать получение уведомлений на:
    • Сайт, мобильное и десктопное приложения;
    • Электронную почту;
    • Внешние клиенты (XMPP, Jabber) - только для «Битрикс24 в коробке»;
    • Push-уведомления (мобильное приложение).

  • Расширенный режим, позволяющий сделать настройки уведомлений для различных инструментов портала:

Примечaние: Отключённые уведомления не сохраняются в истории.

На закладке Оборудование настраиваются опции микрофона и вебкамеры:

Выбор микрофона и вебкамеры

Поcле выбора микрофона и вебкамеры в окне появится индикатор уровня звука с микрофона и изображение с вебкамеры:

Проверка микрофона и вебкамеры

Примечaние: Выбранное оборудование привязывается к браузеру, а не к пользователю, т.е, если сменится компьютер или браузер, то настраивать вебкамеру и микрофон потребуется заново.


Контакт-лист
64 / 401
  • Контакт-лист
  • Поиск контактов
  • Контекстное меню контакта

Контакт-лист

Контакт лист Бизнес-чата может принимать несколько видов в зависимости от действий:

  • Вид по умолчанию - в данном виде контакт-лист состоит из чатов, сгруппированных по дате последнего диалога:

  • Курсор мыши в поле поиска - в данном виде показываются все виды диалогов, сгруппированных по типу чата: Открытые чаты, Закрытые чаты, Телефонные звонки, Чаты один на один, Внешние чаты один на один:

Все сотрудники компании уже присутствуют в списке контактов Бизнес-чата и разбиты по группам согласно структуре компании. Если сотрудник участвует в одной из групп, то он увидит в списке группы, в которые входит, и контакты видимых ему групп.

Новые сотрудники, только что принятые на работу в компанию, автоматически появляются в этом списке (как только отдел кадров добавит их в структуру компании на портале).

Поиск контактов

Если необходимо быстро найти в контакт-листе Бизнес-чата сотрудника, необходимо в поле поиска ввести несколько первых букв его имени или фамилии, отдела. Также возможен поиск групповых чатов в контакт-листе. Мгновенный поиск отфильтрует список и выведет результаты:

Примечание: Поиск чатов, контактов по имени, фамилии и отделу компании осуществляется даже в случае неверно выбранной раскладки клавиатуры.

Контекстное меню контакта

Контекстное меню контакта вызывается с помощью правой кнопки мыши и позволяет: написать сообщение, сделать видеозвонок, перейти в профиль пользователя на портале.


Диалоги (чаты)
65 / 401
  • Типы чатов
  • Цветные чаты
  • Диалоги
  • Просмотренные сообщения
  • Горячие клавиши и форматирование сообщений
  • Работа с файлами
  • Чат с самим собой
  • Групповые чаты
  • Богатые ссылки
  • Внешние (экстранет) пользователи

Чат - это диалог с одним или несколькими сотрудниками.

Типы чатов

Чаты в Битрикс24 бывают трех видов:

  1. Чат один на один - виден только вам и вашему собеседнику.

    Аватарка такого чата по умолчанию выглядит как аватарка c профилем человека. Если собеседник имеет собственную иконку, то она будет отображаться в диалоге:

  2. Закрытый чат - групповой чат, виден только приглашенным пользователям. В чате можно обсуждать рабочие вопросы, которые касаются конкретных людей.

    Аватарка такого чата по умолчанию выглядит как аватарка c замком. Если чат имеет собственную иконку, то замок будет отображен в ее нижней части:

  3. Открытый чат - групповой чат, виден всем сотрудникам. В чате можно обсуждать важные рабочие моменты, интересные всей компании. Уведомление о созданном чате будет отправлено в Общий чат. Коллеги смогут посмотреть переписку чата и при желании вступить в него.

    Аватарка такого чата по умолчанию выглядит как аватарка c рупором. Если чат имеет собственную иконку, то рупор будет отображен в ее нижней части:

  4. Общий чат - разновидность Открытого чата, который доступен по умолчанию сразу всем сотрудникам при создании портала.

    Аватарка Общего чата выглядит как аватарка c числом 24, ее изменить нельзя, также как и название этого чата:

    Примечание: Администратор портала может ограничить в настройках портала доступ определенным сотрудникам на отправку сообщений в этот чат, но читать сообщения в данном чате могут все сотрудники. Также Администратор портала может удалять сообщения в Общем чате.

    Примечание: Чат-боты не включены в Общий чат, таким образом общение с ними в Общем чате невозможно.

    Внимание! Если в компании больше 500 человек:
    • Облачный сервис «Битрикс24» - в Общий чат писать может только админ (можно поменять в настройках портала).
    • «Битрикс24 в коробке» - Общего чата на портале нет.

Цветные чаты

Для удобства восприятия и визуального поиска чатов каждому новому чату случайным образом присваивается цвет:

  • Если это Чат один на один и у собеседника нет аватарки, то цвет иконки собеседника выбирается случайным образом:

  • Если это Групповой чат, то цвет иконки чата по умолчанию выбирается случайным образом, а также согласно цвету выставляется название чата и порядковый номер в системе (позже название и иконку чата можно сменить):

Также цветом различается поле ввода сообщения в зависимости от приватности чата:

  • Если это Закрытый чат с сотрудниками, то поле ввода сообщения будет подсвечено серым цветом:

  • Если это Открытый чат с сотрудниками, то поле ввода сообщения будет подсвечено голубым цветом:

  • Если это Чат с внешними пользователями, то поле ввода сообщения будет подсвечено светло-коричневым цветом:

  • Если это Чат с чат-ботом, то поле ввода сообщения будет подсвечено фиолетовым цветом:

  • Если это Открытая линия, то поле ввода сообщения будет подсвечено зеленым цветом:

Диалоги (чаты)

Для создания нового чата нужно нажать кнопку Cоздать чат и выбрать нужный тип чата:

Далее нужно пригласить в него собеседника, указав фамилию, имя, e-mail или ник из его профиля:

Приглашать в чат можно не только сотрудников, но и своих клиентов, партнеров, поставщиков, у которых есть портал Битрикс24 (учетная запись Битрикс24.Нетворк):

Ранее состоявшийся диалог можно открыть с помощью клика на нужном чате в окне контактов Бизнес-чата.

Чаты с сотрудниками сгруппированы по дате последнего сообщения в данном чате по вкладкам в окне контактов. Вкладки и сами сообщения содержат аватары коллег. Это позволяет c легкостью переключаться между диалогами.

Если вы напишете сообщение отсутствующему сотруднику в оффлайн, то по возвращении коллеги на портал оно будет доставлено, также это сообщение будет присутствовать в истории диалога.

При наведении на сообщение в окне диалога появляется иконка меню действий над данным сообщением. Пункты меню зависят от того, чье это сообщение:

  • собственное - Цитировать, Редактировать или Удалить.
  • собеседник - Цитировать или Отметить как непрочитанное.

При написании сообщения можно упоминать сотрудника в Бизнес-чате. Для этого просто нажмите клавишу на клавиатуре + или @ или нажмите иконку - будет выведен диалог, где можно найти и выбрать нужного человека:

Просмотренные сообщения

Вы всегда увидите, кто прочитал ваше сообщение с помощью статуса Сообщение просмотрено:

Если вы перешли в диалог, понимаете, что адресованное сообщение важное, но у вас сейчас недостаточно времени для ответа, то можно отметить сообщения как непрочитанное, опция доступна в контекстном меню рядом с сообщением:

Сообщение подсветится как непрочитанное и появится иконка нового сообщения:

Горячие клавиши и форматирование сообщений

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Новый чат. Форматирование текста. Работа с файлами.

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

В Бизнес-чате есть возможность использовать горячие клавиши, Windows (Mac):

  • CTRL + T (Command + T), CTRL + E (Command + E) (в Chrome) - позволяет изменить раскладку выделенного текста;
  • CTRL + B (Command + B), CTRL + I (Command + I), CTRL + U (Command + U), CTRL + S (Command + S) - для жирного, наклонного, подчеркнутого или зачеркнутого текста;
  • стрелка вверх - быстрое редактирование предыдущего сообщения;
  • клик в поле поиска контакта - в контакт-листе откроются блоки чатов по 3 чата каждого вида: Открытые чаты, Закрытые чаты, Телефонные звонки, Чаты один на один, Экстранет-чаты, Открытые линии;
  • клик по аватарке пользователя в окне чата - в поле ввода сообщения вставляется упоминание имени пользователя с возможностью Написать сообщение и просмотреть Историю сообщений;
  • CTRL (Command) + клик по аватарке пользователя в окне чата - в поле ввода сообщения вставляется упоминание о пользователе с возможностью Написать сообщение и просмотреть Историю сообщений, но при этом можно изменить текст обращения.
    Примечание: Если выключены уведомления в чате или у сотрудника выбран статус Не беспокоить и отправлено сообщение с упоминанием о пользователе, то уведомление все равно всплывет.

И еще BB-коды для форматирования выделенного текста в сообщении:

  • [b]жирный[/b] (Ctrl + B, Command + B): жирный;
  • [i]курсив[/i] (Ctrl + I, Command + I): курсив;
  • [u]подчеркивание[/u] (Ctrl + U, Command + I): подчеркивание;
  • [s]зачеркивание[/s] (Ctrl + S, Command + S): зачеркивание;
  • >>: текст после двух угловых скобок будет отображен в чате как цитата;
  • [url=http://1c-bitrix.ru]1C-Битрикс[/url]: 1C-Битрикс (если в тексте сообщения указана прямая ссылка, то она автоматически преобразуется в кликабельную ссылку в диалоге);
  • ссылка на картинку: если указана прямая ссылка на картинку в тексте сообщения, то превью этой картинки будет показано в диалоге.
  • [icon=адрес-вашей ссылки title=описание]: если вы хотите отправить иконку в чат, вы выбираете нужную иконку например на сайте эмоджи http://emojipedia.org, и копируете ссылку на этот смайл, далее вставляете BB-код в чат (поддерживаются форматы: .svg, .png, .gif и .jpg ):

    После этого данная иконка будет доступна в наборах смайлов и ей можно будет пользоваться как обычным смайликом:

Также в чате доступен функционал лайков и смайлов (нажав на иконку [image], появится соответствующий выбор).

Обратите внимание, справа, в нижней части окна диалогов, есть возможность сменить сочетание клавиш для отправки сообщения Ctrl+Enter или Enter нажатием на область надписи Ctrl+Enter. Также можно изменять размер поля ввода текста, потянув за верхний край.

Чат с самим собой

В список чатов Один-на-один добавлен собственный контакт. Теперь этот чат можно использовать в качестве черновика сообщений, заметок, важных ссылок и файлов - они будут всегда под рукой и доступны только вам, в вашем личном чате.

Групповые чаты

В любой момент в Бизнес-чате можно пригласить коллег в чат и быстро обсудить текущую задачу. Участники в чате обмениваются сообщениями, которые видят все, сразу же получают ответы на свой вопрос. Также для каждого чата хранится своя история, которую можно позже просмотреть. Поиск групповых чатов осуществляется аналогично поиску сотрудников в контакт-листе. В контакт-листе есть отдельная вкладка для всех групповых чатов сотрудника. Участники чата выбираются из числа сотрудников компании, с помощью того же удобного диалога, который используется при написании сообщения нескольким коллегам из «Живой ленты».

Примечание: Чтобы присоединившемуся к беседе сотруднику стали видны ранние сообщения от участников группового чата, нужно включить опцию Показать историю диалога.

Или, наоборот, исключить сотрудника из чата, если он уже не нужен в обсуждении. Собственные сообщения участникам в окне диалогов подсвечиваются другим фоном. Аватарка создателя группового чата будет выделена специальным индикатором:

Сменить тему группового чата можно, кликнув на название, а изменить аватарку группового чата, кликнув на его иконку:

В групповом чате можно Oтключить оповещения, если кликнуть по соответствующей кнопке:

Примечание: Помимо групповых чатов на портале можно осуществлять и групповые звонки.

Работа с файлами

Бизнес-чат позволяет загружать файлы прямо в диалог. Для этого нужно кликнуть по соответствующей кнопке возле поля ввода сообщения и Выбрать на компьютере или Выбрать на моем Диске нужный файл:

После загрузки файл отобразится в диалоге, также его можно будет Скачать на компьютер или Сохранить на Диск по ссылкам:

Есть и более быстрый вариант загрузки файла или картинки в диалог - просто перенесите с помощью drag&drop на область Бизнес-чата нужный файл:

Если необходимо продублировать файл из одного чата в другой, достаточно его скопировать через контекстное меню и вставить в другой диалог:

Богатые ссылки

«Богатые ссылки» позволяют сделать сообщение более содержательным и красивым. Сообщение не нужно оформлять каким-то особым способом - ссылка на какой-либо ресурс, как правило, автоматически преобразуется в содержательный блок c информацией из ссылки:

А также и в уведомлениях:

Если по каким-то причинам вы не хотите видеть «богатую ссылку» в уже отправленном сообщении, то она удаляется нажатием иконки-крестика.

Примечание: Поддержку «богатых ссылок» в Бизнес-чате можно отключить (или включить) глобально сразу для всех сообщений и уведомлений. Для этого необходимо обратиться к администратору. Подробнее об этом можно прочитать здесь.

Внешние (экстранет) пользователи

Общение с внешними (экстранет) пользователями не отличается от общения с сотрудниками компании, но при этом в чате такие пользователи выделяются светло-коричневым цветом: в Контакт-листе, в названии диалога, а также поле ввода сообщения с набираемым в нем текстом:


Команды (slash-команды)
66 / 401

Slash-команды (команды, начинающиеся с символа "/") позволяют быстро создавать запросы для вывода или получения какой-либо информации, форматировать сообщения.

Чтобы использовать slash-команду, необходимо в поле ввода сообщения ввести символ "/" или нажать на кнопку [image], далее выбрать из меню нужную команду или напечатать ее:

По умолчанию на портале Битрикс24 представлены следующие slash-команды:

  • Группа «Чат и звонки»
    • /me сообщение - текст сообщения будет выделен курсивом;
    • /loud сообщение - текст сообщения будет выделен жирным начертанием;
    • >> сообщение - текст сообщения будет отображен в чате как цитата.
  • Группа «Чаты»
    • /rename новый заголовок - переименование заголовка текущего группового чата (команда доступна только в групповых чатах)
  • Группа «Диалог»
    • /startTrackStatus - включение режима отслеживания у данного пользователя статуса «Онлайн» (команда доступна только в чате один на один)
    • /stopTrackStatus - выключение режима отслеживания у данного пользователя статуса «Онлайн» (команда доступна только в чате один на один)
  • Группа «Giphy»
    • /giphy текст - опубликовать подходящее изображение по теме "текст".
  • Скрытые команды:
    • /disable welcome - отключить приветственное сообщение от чат-бота "Марта" (например, уведомления Марты о задачах при начале рабочего дня).
    • /enable welcome - включить приветственное сообщение от чат-бота "Марта".

Примечание: Количество и функции команд могут меняться в зависимости от того, с кем происходит общение - с одним сотрудником, c несколькими сотрудниками в групповом чате или же с чат-ботом.


Чат-боты
67 / 401
  • Чат-боты
  • Список всех чат-ботов
  • Добавление чат-бота
  • Удаление чат-бота

Чат-боты представляют из-себя автоматизированных помощников (виртуальных собеседников), которые реагируют на обращение к ним и отвечают в персональных или групповых чатах, помогая получить информацию в зависимости от назначения данного чат-бота.

Общение с чат-ботами происходит также, как с сотрудниками портала.

По умолчанию на каждом портале присутствуют 3 чат-бота:

  • Марта - виртуальный личный помощник, помогающий осваивать сервис Битрикс24:

  • Giphy - находит подходящее по смыслу изображение на любую тему и выводит его в чат:

  • Реквизиты контрагента - помогает найти реквизиты организации или ИП по их ИНН или ОГРН и выводит их в чат:

Внимание! Штатные чат-боты Битрикс24 в коробочной версии будут работать только если администратором портала установлен модуль Чат-боты.

Список всех чат-ботов

Найти всех чат-ботов в Бизнес-чате, присутствующих на портале, можно, кликнув в поле Поиска и прокрутив вниз список контактов до секции Чат-боты:

Добавление чат-бота

Для добавления чат-ботов на портал нужно:

  • Перейти в раздел портала Приложения
  • Далее перейти в категорию Чат-боты, выбрать нужный чат-бот и нажать кнопку Установить:

  • Согласиться на установку чат-бота:

  • После успешной установки в Общем чате для всех сотрудников появится уведомление о новом чат-боте на портале:

Удаление чат-бота

Для удаления чат-бота с портала нужно:

  • Перейти в раздел портала Все приложения > Покупки, выбрать чат-бота и нажать кнопку Удалить

  • Либо перейти в карточку приложения данного чат-бота и нажать кнопку Удалить:

Внимание! Добавлять или удалять чат-ботов на портале может пользователь с правами Администратора портала.


Статусы
68 / 401

На портале существует несколько статусов пользователей:

  • Онлайн - пользователь в сети, готов к общению (статус выставляется автоматически либо вручную).
  • Отсутствует - пользователь отсутствует (статус выставляется пользователем вручную).
  • Отошел - пользователь отошел от компьютера (статус выставляется автоматически).

    Если навести на иконку пользователя в окне личного сообщения, то будет показано сколько времени отсутствует данный пользователь:

    Примечание: Данный тип статуса присваивается порталом автоматически через 10 мин неактивности пользователя и только в том случае, если у отсутствующего запущено Десктопное приложение Битрикс24.

  • Мобильный телефон - пользователь запустил мобильное приложение Bitrix24 и доступен на мобильном устройстве. Данный статус отображается 3 минуты. Если пользователь продолжит работать в мобильном приложении более 3 минут, то статус продлевается (статус выставляется автоматически).
  • Не беспокоить - пользователь занят, у него не будут всплывать новые сообщения, а также звуковые уведомления, но сам индикатор будет отображать количество новых сообщений (статус выставляется пользователем вручную).

    Примечание: Если выключены уведомления в чате или у сотрудника выбран статус Не беспокоить и отправлено сообщение с упоминанием о пользователе, то уведомление все равно всплывет.

  • Нет в сети - пользователя нет в сети (статус выставляется автоматически).

    • Пользовательские статусы Онлайн/Отсутствую/Не беспокоить устанавливаются с помощью одноименного меню в нижней части контакт-листа:


Центр уведомлений
69 / 401
  • Центр уведомлений
  • Уведомления браузера

Центр уведомлений

Центр уведомлений Бизнес-чата выводит всплывающие сообщения от пользователей портала, а также информацию о приглашениях, например, в группу или на встречу, сообщает о новых «лайках», поставленных бизнес-процессах, задачах и прочих событиях на портале. В том числе, и о событиях в Экстранете для сотрудников, которые работают с партнерами и клиентами в экстранет-группах. Сообщения выводятся в верхнем правом углу страницы:

Уведомления-подтверждения не стираются мгновенно, а остаются на текущую сессию пользователя, поэтому, если вы пропустили какое-то интерактивное действие в уведомлении, можно это сделать позднее. Для просмотра истории нотификаций необходимо кликнуть на кнопку панели уведомлений либо в окне Бизнес-чата на кнопку Уведомления:

Чтобы прочитать ранние уведомления, нужно в окне уведомлений нажать кнопку Загрузить более ранние уведомления.

Примечание: При отправке сообщений из Живой ленты пользователю также отправляются уведомления, если он указан в адресатах или если адресовано группе, на которую подписан пользователь.

Уведомления браузера

Также есть возможность получать уведомления на любой вкладке браузера при открытой вкладке с порталом. Для этого необходимо включить данную возможность во всплывающем сообщении поверх окна Бизнес-чата:

Согласиться на данное действие в браузере:

Теперь уведомления будут всплывать в нижнем правом углу на любой вкладке браузера без необходимости быть всегда на вкладке с порталом (пока вкладка с порталом не закрыта в браузере):

Чтобы отключить уведомления браузера, нужно на всплывающем уведомлении кликнуть правой кнопкой мыши и выбрать Отключить уведомления от <портала>:


История сообщений
70 / 401
  • История сообщений
  • Архив сообщений чата с уволенным сотрудником

История сообщений

Чтобы попасть в историю сообщений, необходимо нажать кнопку [image] История сообщений в верхнем правом углу диалога.

  • Поиск по истории позволяет с помощью первых четырех букв слова найти все сообщения, в тексте которых есть эти буквы.
  • Поиск по дате позволяет вывести все сообщения на определенную дату.
  • Поиск по названию файла осуществляет поиск по загруженным в данном чате файлам.

В истории сообщений доступно также меню действий над файлами, которое позволяет Скачать, Сохранить на Диск или Удалить файл. Для вызова данного меню нужно навести курсор на строку, показывающую объем файла, и кликнуть на иконку меню.

Чтобы удалить всю истории сообщений с данным контактом, нужно нажать кнопку [image] в правом верхнем углу и согласиться на удаление:

Архив сообщений чата с уволенным сотрудником

Чтобы посмотреть архив сообщений с уволенным сотрудником, нужно зайти в раздел портала Сотрудники, перейти во вкладку Уволенные и в меню сотрудника выбрать История переписки:

Либо в профиле пользователя также выбрать в меню пункт История переписки:

После чего откроется окно с архивом сообщений чата с уволенным сотрудником.


Видеозвонки
71 / 401

В версии 12.5 продукта появилcя функционал видеозвонков через браузер, позволяющий звонить коллегам и видеть собеседника через корпоративный портал. Для осуществления бесплатного звонка достаточно зайти на портал, в Бизнес-чате выбрать сотрудника и нажать специальную кнопку. Вы будете общаться через браузер без установки плагинов и дополнений - благодаря поддержке WebRTC.

Внимание: На данный момент функционал видеозвонков доступен только для браузеров версий (и выше): Google Chrome v29, Mozilla Firefox v27, Opera v18, Яндекс.Браузер v13. А также для осуществления голосового и видеозвонка необходим микрофон и видеокамера.

Вниманию администраторов. При работе по протоколу https в десктопном приложении сертификат SSL должен быть валидный, не выдавать ошибку в Chrome.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Видеозвонки

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Звонки и видеозвонки сотрудникам

Чтобы позвонить сотруднику:

  • Найдите сотрудника в списке контактов Бизнес-чата и инициируйте простой голосовой звонок или видеозвонок с помощью клика правой кнопкой мыши на иконке:

  • Подтвердите доступ к аудио- и видео-устройствам:

  • Установится соединение, и, если коллега ваш не занят, в браузере откроется окно видеосвязи:

Во время видеосвязи с коллегой можно распахнуть окно на весь экран и потом его «схлопнуть» обратно. Или перейти в обычный чат, чтобы отправить коллеге текстовое сообщение. Также можно, не закрывая окно видеосвязи, написать что-то другому сотруднику.

Все это время видеосвязь не рвется. Видеозвонок сворачивается в узкую полоску в верхней части окна сообщений Бизнес-чата, и вы продолжаете видеть собеседника в маленьком видео-окне.

В отличие от Телефонии видео и обычные звонки не записываются.

Групповые звонки

Для осуществления группового звонка (аудио- или видеозвонка) необходимо создать групповой чат и потом выбрать в меню Видеозвонок или Звонок:

Примечание: Также можно позже пригласить сотрудника в созданный видеочат.

В результате чего будет осуществлен групповой звонок всем участникам группового чата:

Внимание: Пока что лимит на количество участников групповых звонков - 4 сотрудника. В групповом чате с количеством сотрудников больше 4, кнопка группового звонка будет недоступна.

Примечание: Если один сотрудник участвует в видеозвонке со смартфона, используя мобильное приложение, то на экране он видит не всех участников группового звонка, а только одного - инициатора звонка.

История звонков

Если кто-то звонил в ваше отсутствие, вы получите сообщение Бизнес-чата об этом. Информация о пропущенных звонках хранится в истории Бизнес-чата.

Особенности

Как уже было сказано выше, функционал видеозвонков доступен на данный момент только для браузеров версий (и выше): Google Chrome v29, Mozilla Firefox v27, Opera v18, Яндекс.Браузер v13. Поэтому при звонке коллеге, который использует другой браузер или младшую версию, будет выводиться соответствующее уведомление:


Демонстрация экрана
72 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Демонстрация экрана

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Планерки и обсуждения текущих задач с возможностью демонстрации экрана будут намного эффективнее.

Демонстрация экрана будет полезна при:

  • обсуждения документов;
  • демонстрации презентаций;
  • обучения новых сотрудников;
  • настройки приложений и функционала;
  • для удаленной работы с партнерами в Экстранете и др.

Для демонстрации экрана нужно во время видео- или аудиозвонка нажать на кнопку Демонстрация экрана:

Через несколько секунд коллега увидит рабочий стол вашего компьютера:

Во время демонстрации экрана можно:

  • в реальном времени видеть то, что показывает коллега на его рабочем столе;
  • показать свой экран с необходимыми пояснениями;
  • обсуждать все голосом;
  • обмениваться текстовыми сообщениями.

Работу функционала демонстрации экрана также можно увидеть в данном ролике:

Внимание: Демонстрация своего экрана доступна только пользователям обновленного десктопного приложения (версий 3.4.0.30/Windows, 3.3.10.28/Mac OS X и выше). Пользователи браузеров или десктоп-приложений старых версий получат всплывающее уведомление о необходимости обновления:


Десктопное приложение Битрикс24
73 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Десктопное приложение Битрикс24

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Десктопное приложение Битрикс24 для Windows и Mac OS X

С десктопным приложением для Windows и Mac OS X можно закрыть браузер с порталом и при этом оставаться на связи. Приложение всегда держит в курсе текущих событий: позволяет получать самые важные нотификации о новых событиях в «Живой ленте», лайках и комментариях к ним, о поставленных задачах и ходе их выполнения.

Чтобы начать пользоваться десктопным приложением Битрикс24 необходимо:

  • Перейти в раздел Приложения по адресу: https://www.bitrix24.ru/apps/mobile-and-desktop-apps.php, скачать дистрибутив под свою операционную систему и установить его.

    Примечание: Скачать приложение Битрикс24 можно также с помощью виджета в правом верхнем углу портала:

  • После установки на Рабочем столе системы появится иконка приложения.
  • При запуске приложения откроется окно авторизации, где необходимо ввести:
    • адрес вашего портала «Битрикс24 в коробке».
    • логин (если используется «Битрикс24 в коробке») или e-mail (если используется облачный сервис «Битрикс24»).
    • пароль.

    Выбор портала («Битрикс24 в коробке» или облачный сервис «Битрикс24») осуществляется по ссылке внизу окна авторизации:

  • Если на портале включена двухэтапная авторизация, то понадобится еще ввести одноразовый код:

  • После запуска окно приложения можно свернуть в нижнюю панель, в панели задач вывести значок:

В окне приложения есть 2 панели:

В верхней панели отображается вкладки Бизнес-чата на подключенных порталах.

В боковой панели отображается кнопки управления приложением:

  • - Сообщения: отображает счетчик личных сообщений в Бизнес-чате и осуществляет переход в диалог последнего чата;
  • - Открытые линии: отображает счетчик обращений новых через Открытую линию (появляется, если включена опция Открытые линии выделять в отдельный список в Настройках Бизнес-чата);
  • - Уведомления: отображает счетчик уведомлений на портале и осуществляет переход в окно уведомлений;
  • - Телефонный звонок: открывает окно набора телефонного номера;
  • - Битрикс24.Диск: открывает окно Битрикс24.Диск;
  • - Настройки: открывает окно настроек приложения;
  • - Живая лента: отображает счетчик сообщений в Живой ленте и осуществляет переход в Живую ленту портала;
  • - Сменить пользователя: позволяет выйти из учетной записи приложения в окно авторизации.
  • - Мои Битрикс24: позволяет подключить дополнительные порталы к бизнес-чату, которые будут доступные в отдельных вкладках приложения.

Остальные функции приложения Битрикс24 для Windows и Mac OS X аналогичны встроенному в портал Бизнес-чату.

Дополнительные возможности десктоп-приложения Битрикс24

  1. Многопортальность:

    К десктоп-приложению можно подключить несколько порталов, включая сервис Битрикс24 Network, и общаться в каждом портале, переключая вкладки чатов.

    Для этого нужно:

    • Нажать на кнопку Мои Битрикс24 внизу боковой панели приложения:

    • В появившемся окне нажать на кнопку Добавить и авторизоваться в нужном Корпоративном портале или Битрикс24:

    • Используя учетную запись от сервиса Битрикс24 Network, можно выбрать портал из списка порталов вашего аккаунта Битрикс24 Network:

    • После авторизации портала появится новая вкладка другого портала:

    Неактивные порталы можно включать в меню выбора порталов по той же кнопке Мои Битрикс24, выбрав их из списка:

    Чтобы отключить портал, нужно снять галочку с портала:

    Чтобы удалить портал из списка, нужно нажать на крестик:

    В меню выбора порталов есть группировка по профилям, а также можно сортировать порталы вручную, перетаскивая элементы списка в нужном порядок.

    Примечание: Текущий портал нельзя удалить из списка или деактивировать, для этого нужно сначала перейти на другою вкладку

  2. Десктоп-приложение может работать в одном из режимов:
    • Компактный режим (минимальная ширина окна приложения) - контакт-лист с чатами схлопывается до ширины иконок чатов, а при удерживании несколько секунд курсора мыши на нужном чате в панели контактов появится список контактов в полную ширину:

    • Обычный режим - список контактов отображается сразу в полную ширину:

    Примечание: В приложении для Mac OS X доступен еще один режим - split-view.

  3. Помимо основных настроек Бизнес-чата для приложения есть дополнительные настройки:

    • Включить уведомление о дне рождения - в контакт-листе будет показана аватарка сотрудника, который в данный день празднует день рождения;
    • Включить автозапуск программы - старт приложения при загрузке операционной системы.

    А также отдельная вкладка Битрикс24.Диск, где можно настроить опции синхронизации файлов с порталом:

  4. В десктоп-приложении, помимо цитирования сообщения, можно еще сообщение скопировать в буфер обмена и вставить в любой чат. Для этого необходимо кликнуть правой кнопкой мыши на нужном сообщении и выбрать пункт Копировать сообщение:

    Далее это сообщение можно вставить в любой чат.

  5. Если кликнуть правой кнопкой мыши на иконке в области уведомлений, то появится меню приложения:

    • Пункт меню Настройки вызывает настройки приложения (см. Настройки Бизнес-чата).
    • Пункт меню Битрикс24.Диск позволяет подключить одноименный функционал Битрикс24.Диск.
    • Если у вас есть новые личные Сообщения, Уведомления или сообщения в Живой ленте на портале, то их количество будет указано около соответствующих пунктов, кликнув по которым, вы сможете их прочитать.
    • Пункт меню Сихронизировать сейчас позволяет принудительно запустить синхронизацию личных файлов в Битрикс24.Диске.
    • Чтобы посмотреть версию и проверить вручную наличие обновления приложения, необходимо выбрать пункт меню О программе.

    • Пункты меню Сменить пользователя и Закрыть приложение позволяют деавторизоваться и закрыть приложение соответственно.

    Примечание: При авторизации в приложении для Windows или Mac OS X, уведомления и сообщения не будут всплывать в панели Бизнес-чата портала, но их всегда можно просмотреть на портале.

  6. Битрикс24.Диск

    Из десктопного приложения можно подключить Битрикс24.Диск и работать с файлами на портале с любого устройства. Битрикс24.Диск доступен пользователям Windows и Mac OS X и подключается к компьютеру как отдельная папка.

  7. Горячие клавиши и форматирование текста

    В десктопном приложении есть возможность использовать горячие клавиши, Windows (Mac):

    • ALT + 1 (Option +1), ALT + 2 (Option + 2),... ALT + 0 (Option + 0) - позволяет открыть последние вкладки переписки;
    • CTRL + T (Command + T) - позволяет изменить раскладку выделенного текста;
    • стрелка вверх - быстрое редактирование предыдущего сообщения;
    • клик в поле поиска контакта - в контакт-листе откроются блоки чатов по 3 чата каждого вида: Открытые чаты, Закрытые чаты, Телефонные звонки, Чаты один на один, Экстранет-чаты;
    • ALT (Option) + клик в поле поиска контакта - в контакт-листе откроются контакты всей компании в формате подразделений структуры компании, Групповые чаты и Эстранет;
    • CTRL + R (Command + R) - обновление окна приложения;
    • CTRL + B (Command + B), CTRL + I (Command + I), CTRL + U (Command + U), CTRL + S (Command + S) - для жирного, наклонного, подчеркнутого или зачеркнутого текста;
    • клик по аватарке пользователя в окне чата - в поле ввода сообщения вставляется упоминание имени пользователя с возможностью Написать сообщение и просмотреть Историю сообщений;
    • CTRL (Command) + клик по аватарке пользователя в окне чата - в поле ввода сообщения вставляется упоминание о пользователе с возможностью Написать сообщение и просмотреть Историю сообщений, но при этом можно изменить текст обращения.

      Примечание: Если выключены уведомления в чате или приложение находится в статусе Не беспокоить уведомление все равно всплывет.

    А также BB-коды для форматирования выделенного текста в сообщении:

    • [b]жирный[/b] (Ctrl + B, Command + B): жирный;
    • [i]курсив[/i] (Ctrl + I, Command + I): курсив;
    • [u]подчеркивание[/u] (Ctrl + U, Command + I): подчеркивание;
    • [s]зачеркивание[/s] (Ctrl + S, Command + S): зачеркивание;
    • >>: текст после двух угловых скобок будет отображен в чате как цитата;
    • [url=http://1c-bitrix.ru]1C-Битрикс[/url]: 1C-Битрикс (если в тексте сообщения указана прямая ссылка, то она автоматически преобразуется в кликабельную ссылку в диалоге);
    • ссылка на картинку: если указана прямая ссылка на картинку в тексте сообщения, то превью этой картинки будет показано в диалоге.
    • [icon=адрес-вашей ссылки title=описание]: если вы хотите отправить иконку в чат, вы выбираете нужную иконку например на сайте эмоджи http://emojipedia.org, и копируете адрес ссылки, далее вставляете этот BB-код в чат:

      После этого данная иконка будет доступна в наборах смайлов:

Удаление приложения

Удаление десктопного приложения для Windows выполняется стандартным для этой операционной системы способом: через Панель управления > Удаление программы.

Удаление десктопного приложения для Mac OS имеет свой порядок:

  1. Закройте десктопное приложение и перейдите в раздел Расширения Системных настроек:

  2. Снимите флажок с Bitrix Finder Extension:

  3. Удалите десктопное приложение штатным способом.

Примечание: О настройке запуска приложения Битрикс24 для Windows с использование прокси-сервера читайте в курсе администратора.

Примечание: Решение технических вопросов по работе с десктопным приложением Битрикс24 см. на странице Типовые вопросы на сайте сервиса.


Мобильное приложение Bitrix24
74 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Мобильное приложение Битрикс24

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

С мобильным приложением могут работать как пользователи сервиса Битрикс24, так и владельцы коробочного продукта Битрикс24 в коробке. Мобильное приложение разработано под iOS и Android.

Внимание! Если Битрикс24 в коробке установлен в шаблоне Lite, то мобильное приложение работать с таким порталом не будет.

Основной функционал мобильного приложения Bitrix24:

  • Общение на портале в режиме реального времени;
  • Аудио- и видеозвонки;
  • Работа в Живой ленте;
  • Контакты сотрудников;
  • Управление задачами;
  • Работа с файлами;
  • Календарь и события;
  • Мобильная CRM;
  • Push-уведомления
    • и многое другое.

    Примечание: Подробнее о возможностях мобильного приложения см. тут.

    Чтобы начать работать с мобильным приложением Bitrix24, необходимо его предварительно скачать:

    Далее необходимо авторизоваться:

    • Адрес портала - в это поле вводится адрес портала (например, site.ru или 192.168.1.1);
    • Логин или email - указывается ваш логин (если это «Битрикс24 в коробке»), или e-mail (если это облачный сервис «Битрикс24»);
    • Пароль - пароль для доступа на портал.

    Примечание: Ссылка Зарегистрироваться позволяет зарегистрировать новый «Битрикс24» прямо из мобильного приложения. И сразу пригласить на новый портал своих коллег.

    Если на портале включена двухэтапная авторизация, то понадобится еще ввести одноразовый код:

    Работать на портале с помощью мобильного приложения Bitrix24 очень легко:


Синхронизация контактов
75 / 401

Мобильное приложение позволяет синхронизировать контакты телефона с контактами из Битрикс24.

Синхронизация с телефонами на ОС Android

Синхронизация возможна двумя способами: вручную и автоматически. На данный момент рекомендуется выполнять синхронизацию вручную.

Синхронизация вручную

  • Откройте список аккаунтов в Настройках телефона. В разных моделях этот пункт может называться по разному: Аккаунты или Учётные записи. Например, так:

  • Откройте диалог создания нового аккаунта, и выберите Битрикс24:

  • Задайте параметры аккаунта и сохраните их:

    Учётная запись появится в общем списке и начнётся синхронизация контактов.
  • Если синхронизация не началась, то зайдите в учётную запись и запустите синхронизацию вручную:

После завершения синхронизации в списке контактов появится группа вашего портала со всеми контактами:

Автоматическая синхронизация

  • После открытия вашего портала на смартфоне перейдите на страницу Список сотрудников.
  • Приложение предложит вам синхронизировать контакты:

  • При выборе Да приложение само создаст учётную запись и проведёт автоматическую синхронизацию контактов.

Синхронизация с телефонами Apple

Синхронизация контактов на устройствах Apple выполняется с помощью протокола CardDAV


Битрикс24.Софтфон
76 / 401

Все возможности Битрикс24.Телефонии сохраняются и для разговоров через Мобильное приложение Битрикс24.

CRM и Телефония в мобильном приложении Битрикс24 тесно интегрированы. Ведется запись разговоров, автоматическое направление звонка на ответственного, очередность и многое другое.

Битрикс24.Софтфон - это функционал мобильного приложения Битрикс24, позволяющий принимать или осуществлять аудиозвонки на мобильные или стационарные телефоны.

  • Совершение звонка
  • Разговор
  • Управление звонком

Совершение звонка

Для совершения звонка c помощью Битрикс24.Софтфон необходимо:

  • Перейти в раздел Чаты и звонки из главного меню (кнопка [image] или свайп вправо) или с помощью кнопки [image] или свайп влево, нажать кнопку с трубкой телефона. Далее на экране появится клавиатура набора телефонного номера:

  • После набора номера осуществляется звонок. После завершения разговора звонок отобразится в истории чата.
  • Можно повторно позвонить по этому же номеру или сделать звонок из истории чата. Для этого нужно перейти в нужный чат, нажать кнопку Позвонить и выбрать способ звонка:

  • Также позвонить можно из мобильной CRM, телефонный номер можно найти в карточке контакта или в контактах компании CRM:

  • Если одновременно со звонком с мобильного приложения Битрикс24.Софтфон будет открыт браузер со страницей портала, то в Бизнес-чате будет продублирован звонок, где можно cоздать новый контакт или лид либо работать с уже известным контактом CRM:

Разговор

Во время разговора экраны Битрикс24.Софтфон выглядят по-разному:

  • Собеседник есть в системе как контакт в CRM и c ним связана какая-либо сделка CRM:

    Здесь будет отображаться информация о контакте (имя, фамилия, должность, аватарка, если эта информация есть в CRM), текущая сделка (если она есть),

    C помощью одноименных кнопок можно Перейти в сделку или Перейти в контакт:

    Примечание: Кнопка Перейти в сделку будет видна, если с этим контактом связана какая-либо сделка CRM.

  • Собеседника нет в вашей CRM и это новый контакт:

    Здесь будет отображаться информация: номер контакта, длительность разговора.

Управление звонком

Управление во время разговора самим звонком осуществляется кнопками в нижней части экрана:

  • - положить трубку, закончить разговор.
  • - выключить/включить громкую связь.
  • - выключить/включить микрофон.
  • - выключить/включить удержание вызова (будет включена музыка ожидания).
  • - показать/скрыть клавиатуру.
  • - скрыть форму звонка, звонок продолжается, можно использовать другие функции приложения.

    Примечание: После скрытия формы звонка, поверх экрана появится аватарка контакта с длительностью текущего звонка. Ее можно передвигать в любое место экрана, нажатие на нее возвращает форму звонка.

Внимание! Запись звонков, интеграция с CRM, фиксация звонков от клиентов CRM, создание контактов при звонке с нового номера и другие возможности будут доступны в Битрикс24.Софтфон только после аренды номера или подключения SIP ATC. Для этого необходимо обратиться к администратору вашего портала.


Битрикс24.Диск
77 / 401

Битрикс24.Диск позволяет:

  • Работать с файлами, где бы вы ни находились, с любого устройства.
  • Отправить файлы коллегам, обсуждать, совместно редактировать, отслеживать историю изменений.
  • Работать с файлами на своем компьютере (при этом все изменения автоматически окажутся у ваших коллег).

Подключается Битрикс24.Диск на персональном компьютере как отдельная папка (по умолчанию - \Мои Документы\Bitrix24\, вы можете изменить папку, пройдя по ссылке изменить директорию при отключенной синхронизации файлов) в одноименной закладке десктопного приложения Битрикс24 с помощью кнопки Подключить:

Таким образом можно подключить несколько папок, если вы работаете в нескольких порталах. Каждая папка будет синхронизироваться со своим порталом.

Если Битрикс24.Диск находится в состоянии Включено, то синхронизация происходит автоматически при любом изменении, добавлении, обновлении файлов в папке, подключенной к Диску. Кроме того, в любой момент можно вручную синхронизировать файлы, кликнув правой клавишей мыши на значок Диска в Панели задач и выбрав пункт Синхронизировать сейчас.

Панель управления

Панель управления состоит из двух кнопок:

  • Открыть проводник Windows - при клике откроется папка, где можно хранить свои файлы (по умолчанию - \Мои Документы\Bitrix24\):

Добавьте документ в эту папку - и он синхронизируется с вашими файлами на портале:

Подробнее работа с файлами на портале описана в соответствующей главе (Интерфейс и инструменты работы с документами, Создание и редактирование папок и файлов, Совместная работа с документами, Удаление и восстановление папок и файлов, Дополнительные операции с документами и другие).

  • Перейти в Битрикс24 - при клике по этой кнопке в браузере будет открыта страница Мой диск портала, под учетной записью которого вы авторизованы в десктопном приложении.

Настройки

Настройки Битрикс24.Диска вызываются с помощью кнопки [image] бокового меню и перехода в одноименную закладку:

Здесь можно выбрать действие по клику на имени файла в "Истории загрузок", а также включить/отключить синхронизацию файлов полностью или отдельных личных/общих папок

Папки, отключенные от синхронизации, не отображаются в Проводнике Windows на вашем локальном компьютере.

В Настройках на закладке Уведомления можно также отключить уведомления о загрузках и изменениях файлов:

Отключение синхронизации файлов

Для отключения синхронизации файлов с Битрикс24.Диск нужно снять птичку с опции "Включить Битрикс24.Диск" в настройках приложения. Локальные файлы останутся нетронутыми.

Внимание! Если пользователь отключал Битрикс24.Диск, то при следующем подключении будут сравниваться списки файлов на сервере и локально, и отсутствующие на одной стороне файлы и папки будут переданы с другой стороны. Таким образом могут быть загружены устаревшие и удаленные версии файлов и папок. Во избежание этого не следует отключать синхронизацию без настоятельной необходимости.

История

Лог всех изменений показывается в области истории. Также из этой области можно открыть файл для просмотра или редактирования:

При отключении синхронизации обнуляется история загрузок файлов. То есть файлы не будут доступны из этой области, но по-прежнему будут доступны на Моем Диске и в папке локального компьютера.


Использование IP-телефонии
78 / 401

В Битрикс24 есть функционал звонков на стационарные и мобильные телефоны как России и стран СНГ, так и США и Европу.

Внимание: На данный момент функционал ip-телефонии доступен для версий браузеров (и выше): Google Chrome 29, Mozilla Firefox 27, Opera 18, Яндекс.Браузер 13. А также для осуществления голосового звонка необходима гарнитура с микрофоном. Технические требования для сети указаны здесь.

Ограниченное использование Google Chrome с версии 47 для Битрикс24 в коробке
Google Chrome с версии 47 отключает WebRTC на всех сайтах, кто не использует протокол HTTPS. Это означает что для всех коробочных версий Битрикс24, у кого не стоит HTTPS сертификат, перестанет работать телефония и внутренние звонки.

Для решения проблемы, необходимо будет приобрести и настроить HTTPS сертификат для сайта. Либо использовать другие браузеры. Для пользователей это будет выглядеть, как "Невозможно получить доступ к веб-камере или микрофону".

Для клиентов Битрикс24 облачной версии - это предупреждение не актуально.

Внимание: Тарифы на звонки опубликованы на сайте Битрикс24.

Внимание: Пользователи Экстранета не могут совершать звонки.

Для корректной работы IP-телефонии необходимо что бы в вашей операционной системе было актуально время. Для этого включите синхронизацию времени в настройках ваших операционных систем или попросите администратора синхронизировать локальный сервер времени.

Для работы телефонии используется штатное оборудование вашего компьютера. Если на компьютере есть несколько устройств, то можно указать какое из них использовать.

  • Звоните вы
  • Звонят вам
  • Если подключён телефонный аппарат
    •

    Звоните вы

    Звонки совершать в Битрикс24 просто:

    • C помощью:
      • кнопки Телефон в окне Бизнес-чата :

    • Десктопного приложения Битрикс24:

    После набора номера и нажатия кнопки Позвонить будет осуществлен звонок:

    Звонят вам

    При звонке клиента на портал система автоматически перенаправит звонок менеджеру согласно правилам настройки номера. У менеджера всплывёт такое окно (если номер звонящего есть в CRM):

    либо такое (если номер не известен для CRM):

    Примечание: Если телефонный номер неизвестен для CRM, то, в зависимости от настроек маршрутизации, либо будет автоматически создан лид и задача на его обработку, либо будет предложено вручную создать лид. Ответственным за новый лид назначается тот, кто ответил на этот звонок. Если звонок произошёл в нерабочее время, то ответственный за новый лид назначается по правилам очереди.

    После ответа звонящему откроется окно Бизнес-чата:

    Если номер известен для CRM, то будет выведен список сущностей CRM, привязанных к этому контакту, а также кнопки перехода к этим сущностям. То есть менеджер может в один клик получить всю информацию о звонящем и состоянии дел, сделок, счетов, связанных с ним.

    Панель управления позволяет:

    1. Завершить звонок.
    2. Отключить/включить микрофон.
    3. Поставить звонок на ожидание.
    4. Переадресовать звонок другому сотруднику.

      Перенаправление на другой номер сотрудника
      Если в профиле сотрудника указано несколько телефонов, то есть возможность выбора на какой телефон перенаправить звонок:

    5. Вызвать цифровую клавиатуру для дополнительных действий (например: задать IVR).
    6. Открыть текстовый чат с абонентом.
    7. Развернуть окно во весь экран.
    8. Задать комментарий к звонку.

    Информация о входящих и исходящих звонках фиксируется как событие в Ленте CRM и во всех сущностях, где встречается данный номер (лиды, контакты и так далее), а также в последней открытой активной сделке, привязанной к сущности с этим номером. В описании события будет указано: дата и время звонка, ответственный, клиент, тема, длительность и статус звонка. Также может быть приложен файл с записью разговора, если такая опция была указана в управлении номерами. Запись можно прослушать непосредственно в Ленте CRM, или работать с нею как с файлом из Общего диска.

    Кроме того, во вкладку Дела соответствующего Клиента CRM добавляется запись о входящем или исходящем телефонном звонке.

    Если подключён телефонный аппарат

    Если у вас подключён к Битрикс24 телефонный аппарат, то работа с входящим звонком не меняется. Вы можете ответить как через браузер, так и через аппарат.

    В случае исходящего звонка вы можете набирать номер как с аппарата, так и с десктопного приложения, но соединение происходит по разному. Если набор номера был осуществлён с десктопного приложения, то нужно дождаться одиночного звонка телефонного аппарата и только потом снять трубку и разговаривать с клиентом. В обоих случаях на экране компьютера появится карточка клиента из CRM.

    Если вы не в офисе и не можете воспользоваться телефонным аппаратом (например, звонок осуществляется с ноутбука из интернет-кафе), то после набора номера в форме звонка необходимо нажать на кнопку с зелёным телефоном, чтобы отключить телефонный аппарат в офисе:

    Отключение телефона в офисе действует одни сутки. Если нужно опять начать говорить с аппарата раньше этого времени, нужно будет нажать опять на эту кнопку.


Группы
79 / 401

Группы - виртуальное объединение людей для решения или обсуждения общих вопросов, целей и задач.

Пункт главного меню Группы представлен ссылкой на страницу по умолчанию Мои группы. При переходе по этой ссылке появится возможность Создать группу, нажав соответствующую кнопку в правом верхнем углу страницы.

Создать группу, задать её название, определить видимость, открытость и другие параметры может пользователь, имеющий права Сотрудник и выше.

Сотрудникам с разными правами доступа к группе доступен различный функционал. Ниже в таблице приведены функции (Функционал), соответствующие различным сотрудникам (Права пользователя).

Примечание: Администратор портала имеет полные права на все группы портала, даже если он не является Участником, Владельцем или Модератором данных групп.

Функционал | Права пользователя
Просмотр описания видимой группы | Любой сотрудник
Просмотр невидимой группы | Участник группы, Владелец группы, Модератор группы, Администратор портала
Просмотр модераторов, участников видимой группы | Любой сотрудник
Вступить в открытую группу | Любой сотрудник
Вступить в закрытую группу | Любой сотрудник (после одобрения Модератором, Владельцем группы, Администратором портала)
Выйти из группы | Любой участник
Пригласить в группу | Зависит от настроек группы
Редактировать состав | Владелец группы, Администратор портала
Управление запросами на вступление в группу | Зависит от настроек группы
Управление приглашениями вступить в группу | Зависит от настроек группы
Редактирование группы | Владелец группы, Администратор портала
Создать группу | Любой сотрудник
Редактирование настроек группы | Владелец группы, Администратор портала
Редактирование модераторов | Владелец группы, Администратор портала
Удалить группу | Владелец группы, Администратор портала
Написать сообщение (или воспользоваться сервисом, доступным в группе) | Любой участник
Подключение хранилища группы к личному диску | Любой сотрудник с правами на хранилище не ниже Изменение


Все группы
80 / 401

На странице Мои группы располагаются группы, в которых вы состоите. Это группы, которые вы создали, либо в которые вступили:

В верхней части имеется фильтр, позволяющий переключаться между группами:

  • Все группы - отображает страницу со всеми видимыми пользователю группами;
  • Мои группы - отображает страницу со всеми группами, в которых состоит пользователь или является их создателем;
  • Архивные - отображает страницу с устаревшими группами, которые их владельцы отправили в архив;
  • Экстранет - отображает страницу с видимыми пользователю группами в Экстранете;
  • По тегам - отображает страницу со всеми видимыми пользователю группами с возможностью найти их по тегам.

На странице Все группы располагаются все видимые на портале пользователю группы:

Поиск групп

Поиск групп осуществляется по разделам (Мои группы, Все группы, Архивные, Экстранет) и по тегам, а также есть полнотекстовый поиск групп по названию и их описанию:

Просмотр групп

Щелкнув по значку любой группы можно перейти на страницу группы для детального просмотра (профиль группы):

На закладке Основное представлена информация о группе, ее модераторах, участниках, типе группы, а также выведены последние отчеты, обсуждения и ближайшие задачи группы.

В продукте используются группы следующих типов:

  • открытая группа - вступить в группу может любой желающий пользователь или сотрудник компании;
  • закрытая группа - вступить в группу можно только после одобрения модератором (администратором) группы;
  • видимая группа - наличие группы видно всем пользователям или сотрудникам компании;
  • невидимая группа - группа видна только членам группы;
  • архивная группа - группа может быть архивной (например, если активность в ней давно отсутствует).

Создание групп

Видеоролик "Создание групп"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если нет возможности прослушать, то с помощью кнопки СС можно включить текстовое сопровождение.

Примечание: Создание групп доступно пользователям с правами не ниже Могут создавать рабочие группы.
Если вам необходимо создать группу, но не хватает прав, то обратитесь к администратору портала.

Для создания новой группы, кликните по кнопке [image]:

После щелчка вы попадете на страницу создания новой группы:

  • Заполните следующие поля формы вкладки Описание:

    • Название группы - укажите, как будет называться новая группа.
    • Описание группы - введите информацию о группе, о темах, в ней обсуждаемых.
    • Загрузить изображение - выберите картинку, которой будет представлена ваша группа на портале, нажав на одноименную кнопку.
    • Группа видна всем - при отмеченной опции группа будет отображаться у любого пользователя, у которого есть доступ на корпоративный портал. В противном случае группа будет видна только ее участникам и сотрудникам с правами не ниже Администрация портала.
    • Открыта для свободного вступления - вступать в группу можно без предварительного одобрения заявки на участие администратором группы.
    • Группа доступна в экстранете - при отмеченной опции группа будет доступна в экстранете внешним пользователям.
    • Тематика группы - выберите тему новой группы из представленных в списке (только в продукте «Битрикс24 в Коробке»).

      Примечание: если для создаваемой группы нет подходящей темы, то для создания новой темы обратитесь к администратору.

  • Вкладка Возможности

    На этой вкладке необходимо выбрать какие сервисы будут доступны в группе.

  • Вкладка Участники

    На этой вкладке можно пригласить участников группы, выбрав их из структуры компании или с помощью поиска.

  • Вкладка Дополнительно

    • Приглашать пользователей в группу могут: - выбор тех членов группы, кто имеет право высылать приглашения на вступление в группу:

      По умолчанию выставлено Все члены группы.

    • Ключевые слова - перечень слов, кратко характеризующих темы и вопросы вашей группы, они будут учитываться при поисковых запросах.

  • После указания всех необходимых параметров для создания группы нажмите кнопку Создать группу. Если вы передумали создавать новую группу, нажмите Отмена.


Работа с группами
81 / 401

Работа с группами (Интерактивный видеоролик)

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если у вас нет возможности прослушать, то ориентируйтесь на всплывающий текст: он дублирует звуковое сопровождение.

Для взаимодействия с интересующей группой, необходимо перейти к просмотру группы, щелкнув по ее названию или изображению:

После перехода откроется страница профиля группы:

Примечание: по отношению к группе сотрудник может быть владельцем группы, модератором группы, участником группы, пользователем из черного списка, и пользователем, не состоящим в группе. В этом уроке возможности описаны с точки зрения участника группы, либо человека, еще не вступившего в нее. Пользователю из черного списка часть функционала будет недоступна.

  • Вступление в группу
  • Отправка сообщений
  • Выход из группы
    •

    Вступление в группу

    Вступление в группу (Интерактивный видеоролик)

    Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

    Ролик озвучен. Если у вас нет возможности прослушать, то ориентируйтесь на всплывающий текст: он дублирует звуковое сопровождение.

    Для того чтобы вступить в группу, выполните следующие действия:

    • Нажмите на кнопку Вступить в группу, расположенную на закладке Основное страницы просмотра группы либо выберете одноименный пункт меню Действия:

    • Если группа является открытой, т.е. в нее может вступить любой желающий, то вы сразу присоединяетесь к группе.

      Если группа является закрытой, то необходимо заполнить форму запроса на присоединение к группе:

      Обязательно заполните поле Сообщение.

      Модератор (или администратор) группы получит сообщение в Центре уведомлений, где может сразу Принять или Отказать вступление пользователя в группу:

      Также запрос на вступление в группу можно увидеть и подтвердить в уведомлениях Бизнес-чата:

      После того, как модератор группы (или администратор) одобрит ваш запрос, вы получите соответствующее сообщение через Центр уведомлений и станете членом группы:

    Отправка сообщений

    Отправка сообщений (Интерактивный видеоролик)

    Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

    Ролик озвучен. Если у вас нет возможности прослушать, то ориентируйтесь на всплывающий текст: он дублирует звуковое сопровождение.

    Вы можете послать сообщение всем участникам группы, установив курсор в поле Написать сообщение.

    Примечание: Если владелец группы поставил запрет на отсылку сообщений для тех, кто не состоит в группе, то вы не сможете отослать сообщение в группу.

    Если поле доступно, то после установки курсора появится окно отправки сообщений:

    Примечание: Подробнее про создание сообщений можно прочитать в разделе Сообщения.

    Примечание: Если при отправке сообщения в поле Кому был указана невидимая группа, то сотрудники, не состоящие в невидимой группе, в качестве получателя увидят Скрытый получатель:

    Приложенные к сообщению файлы по умолчанию будут загружены в личный Диск автора сообщения.

    Выход из группы

    Выход из группы (Интерактивный видеоролик)

    Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

    Ролик озвучен. Если у вас нет возможности прослушать, то ориентируйтесь на всплывающий текст: он дублирует звуковое сопровождение.

    Чтобы выйти из состава участников группы, необходимо:

    • Нажать кнопку Действия и выбрать пункт меню Покинуть группу:

    • Нажать Покинуть группу для подтверждения своего решения:


Функционал группы
82 / 401

Функционал группы (Интерактивный видеоролик)

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если у вас нет возможности прослушать, то ориентируйтесь на всплывающий текст: он дублирует звуковое сопровождение.

После того, как вы зашли в профиль группы, можно увидеть меню группы:

В нем представлены следующие вкладки:

  • Основное - Это главная вкладка профиля группы, на ней размещена основная информация и меню управления\взаимодействия с группой.
  • Диск - В данном разделе вы можете просматривать, хранить и создавать файлы. Подробнее смотрите на странице Мой Диск раздела Мои инструменты.

    Примечание: Функционал Бизнес-процессов необходимо активизировать для каждой Группы отдельно.

  • Задачи - Здесь вы можете узнавать о поставленных задачах и менять их статус.
  • Календарь - На вкладке Календарь можно узнавать о грядущих и прошедших событиях в группе. Работа с календарем описана в одноименной главе.

    Примечание: событие календаря группы будет отображено и в личных календарях участников события.

  • Сообщения - Данный раздел дает возможность обмениваться сообщениями с другими участниками группы. Подробнее об использовании сообщений смотрите в уроке Сообщения.
  • Фото - Здесь расположены альбомы группы. Подробнее об использовании фотогалереи смотрите в подразделе Фото раздела Мои инструменты.
  • Списки - Здесь вы можете просматривать и при наличии достаточных прав (являетесь владельцем группы) создавать списки каких-либо элементов. Подробнее о работе со списками смотрите здесь.
  • Wiki - База знаний, сборник статей, создаваемых для обобщения и накопления знаний. Подробнее о работе с функционалом Wiki вы можете прочитать в уроке здесь.
  • Обсуждения (только для коробочной версии Битрикс24) - Обсуждение различных тем. Подробнее о работе с функционалом Форумов вы можете прочитать в главе курса Администратор. Модули.

Поиск

Поиск (Интерактивный видеоролик)

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если у вас нет возможности прослушать, то ориентируйтесь на всплывающий текст: он дублирует звуковое сопровождение.

Поиск внутри группы осуществляется несколькими способами:

Можно выполнить поиск, щелкая по ключевым словам в облаке тегов, построенным на основе тегов в событиях группы:

Если нужных слов для поиска в облаке тегов нет, введите их в поле поиска и нажмите Enter:

Можно ограничить поиск каким-либо одним функционалом, либо определенной датой изменения. Для этого нажмите ссылку Расширенный поиск, после чего появятся дополнительные настройки поиска:

В поле По функционалу в открывающемся списке выберите, в каком функционале следует производить поиск:

В поле По дате изменения для выставления даты используйте кнопку [image].

Поставьте дату только в первое текстовое поле, чтобы поиск осуществлялся в период с нее по текущее число. Поставьте дату только во второе текстовое поле, если хотите чтобы в результатах поиска были все измененные до этого числа записи. Поставьте даты в оба текстовых поля, если хотите осуществить поиск за конкретно определенный период.

Уведомления

Подписка на уведомления событий группы очень проста - для этого нужно нажать на кнопку [image]:

Настройку отправки уведомлений о событиях в группе (Сайт и приложения, Электронная почта) можно сделать в расширенных настройках уведомлений на портале. За это отвечает опция Активность и обновления в группе:

Информацию о группе

Справа от меню группы можно посмотреть ее участников и узнать другую информацию о группе, а также отредактировать модераторов и пригласить в группу (при наличии соответствующих прав):

Посмотреть список участников также можно, нажав на кнопку Действия группы и в появившемся меню выбрать Участники:


Управление группами
83 / 401

Управлением группами (Интерактивный видеоролик)

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если у вас нет возможности прослушать, то ориентируйтесь на всплывающий текст: он дублирует звуковое сопровождение.

Внимание! Вы можете управлять группами, если являетесь ее владельцем, модератором или администратором.

Управление группой осуществляется с помощью соответствующего меню, вызываемого с помощью клика на кнопку Действия. Если вы обладаете правами владельца группы, то на главной странице группы, под логотипом, увидите такое меню:

  • Пригласить в группу
  • Редактировать группу
  • Изменить настройки
  • Удалить группу
  • Редактировать состав
  • Приглашения и запросы

Внимание! В зависимости от прав, некоторые пункты будут отсутствовать в списке.

Рассмотрим те пункты меню, которых мы не касались в предыдущих уроках:

Пригласить в группу

После щелчка левой кнопкой мыши по данной ссылке вы попадете на страницу, с которой можно выслать приглашения сотрудникам на вступление в группу:

Отправить приглашение сотруднику можно с помощью кнопок Последние и Сотрудники и отделы.

Пригласить в группу можно также Всех сотрудники отдела с подотделами, выбрав одноименную опцию:

Внимание! Включение в группу без согласия сотрудника невозможно.

Редактировать группу

После клика откроется страница редактирования группы, аналогичная той, что появляется при создании группы..

Параметр Сделать архивной группой - если отметить эту опцию, то группа не будет отображаться у участников и в общем списке групп. Найти ее можно будет на странице Архивные в раздела Группы, где хранятся все архивные группы, либо с помощью поискового запроса.

Изменить настройки

После перехода по ссылке вы окажетесь на странице, где можно менять названия сервисов и уровни доступа к функционалу сервисов группы:

Внимание! Внимательно настраивайте функционал групп. Например, в настройках задач группы по умолчанию установлено Кто может просматривать все задачи: Все члены группы, т.е все участники группы могут видеть задачи всех членов данной группы. Некоторым участникам группы это может не понравиться.

.

Удалить группу

Нажмите на эту ссылку, если вы хотите удалить группу. После клика откроется форма подтверждения удаления группы:

При удалении группы удаляются также её Диск, Календарь и все события группы из календарей участников.

Редактировать состав

На данной странице можно:

  • назначить какого-либо сотрудника модератором группы;
  • исключить сотрудника из группы;
  • сменить владельца группы;
  • заблокировать и разблокировать участника группы, на заблокированного сотрудника будет действовать запрет на просмотр группы, чтение ее содержимого и на повторное вступление в нее (если сотрудник был уже исключен из нее);
  • пригласить пользователей в группу.

Для этого необходимо пометить соответствующего сотрудника галочкой рядом с его именем и нажать соответствующую кнопку в меню Действия.

Примечание: исключить из группы владельца группы может только администратор портала. Причем сначала нужно назначить нового владельца, и только потом исключать старого.

Приглашения и запросы

На этой странице отображаются все высланные приглашения и запросы на вступление в группу, если в группе не разрешено свободное вступление без одобрения модератором:

Также на этой странице можно пригласить в группу или отменить приглашение.


Группы экстранет
84 / 401

Внимание! Для бесплатной лицензии Проект и платной Проект+ облачного сервиса Битрикс24 функционал группы Экстранет недоступен.

Экстранет – инструмент, который позволяет компании осуществлять конфиденциальную связь с поставщиками, дистрибьюторами и другими внешними пользователями без допуска их к внутрикорпоративной информации.

Экстранет - это:

  • единая точка доступа к информации для наших сотрудников, клиентов, партнеров;
  • конфиденциальность общения;
  • совместная работа в едином пространстве (в том числе и удаленно);
  • безопасный доступ внешних пользователей к данным рабочей группы;
  • прозрачность и документируемость коммуникаций.

В Экстранете сотрудники компании могут приглашать внешних пользователей и обсуждать с ними вопросы в рабочей группе (в форумах, блогах), совместно работать с общими документами, планировать активность в календаре, ставить задачи и следить за их выполнением, публиковать отчеты и т.д.

Работа в Экстранете реализована через механизм рабочих групп в разделе Группы экстранета. Все сообщения из этих групп дублируются в общую живую ленту, так что переходить в этот раздел обычным сотрудникам нет необходимости. Все типовые операции по работе с группами экстранета, как и с обычными группами можно выполнить с помощью меню быстрых команд Добавить.

Приглашение пользователей в Экстранет.

Пригласить пользователя в Экстранет можно только с помощью функционала рабочих групп. Пользователей можно пригласить как непосредственно при создании рабочей группы, так в любой момент после создания рабочей группы на закладке Основное страницы уже существующей группы (меню Действия > Пригласить в группу).

В обоих случаях откроется одна и та же форма:

  • Заполните поля формы:
    • Пригласить сотрудников компании - в поле укажите часть фамилии, имени или отчества сотрудников корпоративного портала или воспользуйтесь ссылками Последние или Сотрудники и отделы;
    • Пригласить внешних пользователей, которые уже зарегистрированы на портале - в поле укажите часть фамилии, имени или отчества уже зарегистрированных внешних сотрудников корпоративного портала или воспользуйтесь ссылками Последние или Внешние сотрудники;
    • Пригласить нового сотрудника по e-mail - в поле укажите E-mail внешних пользователей;
    • Добавить нового сотрудника - в поле укажите E-mail, фамилию и имя внешнего пользователя. Если поставить галочку Отправить данные для входа на указанный e-mail, то внешнему пользователю в письме придет ссылка на переход регистрации на портале, в противном случае - сотрудник будет только зарегистрирован на портале как внешний пользователь.

      • Примечание: адреса должны быть указаны в формате xxx@site.com или "name lastname" <xxx@site.com>.

  • Нажмите на кнопку Создать группу (если добавление пользователей происходит при создании группы) или Отправить приглашение (если пользователи добавляются в существующую группу).

После отправки приглашения сотрудникам и внешним пользователям уже добавленным в пользователи сайта экстранета придет типовое приглашение в группу.

Внешние пользователи, не являющиеся пользователями сайта экстранета, получат приглашение по электронной почте. Им надо будет пройти по имеющейся в письме ссылке и заполнить форму авторизации:

После этого приглашенный человек сможет зайти на сайт экстранета и принять приглашение на работу в группе.

Примечание: приглашать пользователей в группу могут любые участники (если это разрешено настройками группы). Если приглашать в группу могут только модераторы и владельцы, а приглашает обычный пользователь, то внешний пользователь будет допущен на портал, но не включён в группу. Если приглашающий не является сотрудником, ему не доступно поле выбора пользователей Сотрудники компании.

Для удобства пользователей экстранета с большим числом групп в общем списке отображаются только 50 групп, все остальные разворачиваются по клику на Все группы. Группы сортируются по названию, порядок из размещения можно менять так же как меняется порядок пунктов в меню.

Сообщения из групп экстранета (название группы и имя экстранет-пользователя) в Живой ленте выделяются цветом.

Внимание! Поле Компания в профиле пользователя экстранета имеет одну особенность. Оно видно в режиме просмотра, но редактировать его администратор может только в режиме экстранета, то есть если только пропишет в адресной строке /extranet/. Например, в адрес http://****.bitrix24.ru/contacts/personal/user/35/edit/ добавить extranet/ и получить: http://****.bitrix24.ru/extranet/contacts/personal/user/35/edit/.

Ссылки по теме:

  • Сравнение интранет и экстранет пользователя


База знаний (Wiki)
85 / 401
База знаний (Wiki) — раздел портала, структуру и содержимое которого пользователи могут сообща изменять с помощью инструментов, предоставляемых самим порталом.

Wiki идеально подходит для создания базы знаний, технических заданий и подготовки различных документов, над которыми происходит совместная работа нескольких пользователей.

Каждая страничка имеет комментарии и систему контроля версий. Первая функция позволяет обсуждать контент странички не покидая страницы. Вторая - контролировать, кто и какие изменения внес, и, если нужно, вернуться к одной из предыдущих версий.

Возможности Базы знаний

Wiki позволяет:

  • Редактирование вики-страниц разными пользователями как с помощью вики-разметки, так и с помощью визуального редактора.
  • Автоматическое построение оглавления.
  • Вставлять изображения в страницу.
  • Возможность задавать категории и тэги страницам.
  • Искать интересующую категорию.
  • Комментировать вики-страницы.
  • Вести историю изменений страницы.
  • Сравнивать разные версии вики-страниц.
  • Восстанавливать вики-страницу до более ранней версии.
  • Искать вики-страницы с помощью стандартной формы поиска.


Основные понятия
86 / 401

Основные понятия и термины:

  • Внутренняя ссылка – гиперссылка на вики-страницу в рамках одного вики-сайта. В тексте вики-страницы помечается обычным для гиперссылок синим цветом.
  • Красная ссылка – внутренняя ссылка на несуществующую (еще не созданную) вики-страницу. В тексте вики-страницы помечается красным цветом.
  • Внешняя ссылка – гиперссылка на внешний сайт.
  • Вики разметка – разметка, которая позволяет легко и быстро размечать в тексте структурные элементы и гиперссылки; форматировать и оформлять отдельные элементы.
  • В Категорию объединяют схожие по смыслу страницы. Одна страница может быть в нескольких категориях. Категории могут быть вложенными.
  • Тегами помечают страницы для быстрого поиска нужной страницы.
  • Версия – одна из сохраненных правок вики-страницы.
  • Текущая версия – последняя версия вики-страницы, которая в данный момент видна на сайте.

Общий вид вики-страницы

Видеоролик "Общий вид вики-страницы"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

Вики-страница состоит из:

  1. Контекстной панели, кнопки которой позволяет:
    • История - просмотреть версии страниц в их историческом развитии. Кнопка не отображается, если не установлен модуль Бизнес-процессов.
    • Создать - создать новую страницу.
    • Править - редактировать содержание страницы.
    • Переименовать - переименовывается название страницы (категории). Изменения отображаются сразу на всех страницах, где есть упоминание о переименованной странице.
    • Удалить - удалить страницу. Удаление вики-страницы удалит ее саму и всю историю ее изменений. Все ссылки на эту страницу в других вики-страницах перестанут работать, т.е. станут "красными ссылками".
  2. Оглавление. Формируется автоматически, если на странице есть не менее 5 заголовков.
  3. Заголовок. Заголовки могут быть различного уровня.
  4. Внутренняя или Внешняя ссылки.
  5. Красная ссылка - ссылка на еще не созданную страницу.
  6. Категории. Список категорий, к которым привязана данная страница.
  7. Рейтинги. Голосование за статью. Вид может отличаться, зависит от настроек, сделанных администратором.
  8. Теги. Список тегов, которые соответствуют данной странице.
  9. Комментарии. Добавленные комментарии к статье.


Создание страницы
87 / 401

Создание первой страницы

Видеоролик "Создание первой страницы"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

Если еще не создано ни одной страницы, посетитель сайта увидит Главную страницу в таком виде:

Для создания первой страницы нажмите красную ссылку Создать или кнопку [image]. По этой команде откроется форма создания страницы с упрощенным визуальным редактором.

Текст рекомендуется добавлять с помощью упрощенного визуального редактора. В режиме Текст вместо привычного форматирования выводится специальная wiki-разметка, понятная программистам и программе. В режиме Визуальный редактор текст отображается сразу отформатированным.

Упрощенный визуальный редактор имеет кнопки, недоступные в других модулях системы:

  • Формат - доступна вставка заголовка вплоть до 6-го уровня вложений
  • Ввод внутренней гиперссылки. По этой кнопке создается внутренняя гиперссылка на пока еще не созданную страницу (красная ссылка). Название гиперссылки и название создаваемой страницы могут не совпадать.

    Примечание: В поле Ссылка нужно вводить не URL адрес ссылки, а название страницы, на которую вы хотите сослаться.
  • Указать категорию. Указываются категория для страницы. Можно выбрать из списка уже существующих, можно добавить новую. Каждой странице можно назначить несколько категорий воспользовавшись этой кнопкой несколько раз.

  • Ваша подпись и момент времени. Кнопка вставляет имя и фамилию автора статьи (в том виде как он зарегистрирован в системе), дату и время создания (правки) статьи.
  • Игнорировать Wiki-форматирование. Текст отображается без учёта Вики-форматирования.
  • Оформление текста в виде кода. Позволяет вводить в текст сообщения программные коды без их искажения при просмотре.

Примечание: Wiki допускает настройку переадресации страниц. Если по каким-то причинам страница не должна отображаться, но удалять её нежелательно, то можно использовать переадресацию. Для этого необходимо в режиме текста добавить на страницу выражение #REDIRECT [[**********]]. Вместо звёздочек вставьте имя страницы, на которую производится перенаправление. Редактирование исходной страницы становится доступным только администратору.

Заполните текстом страницу и нажмите Опубликовать. Страница будет создана.

Создание страницы из Красной ссылки

Для создания новой страницы по красной ссылке просто нажмите на нее. Откроется форма создания новой страницы.

Примечание: Возможен вариант, когда связанная страница создается не по красной ссылке, а самостоятельно по кнопке Создать. В этом случае произойдет автоматическая привязка вновь созданной страницы к существующей ссылке. И наоборот: можно сначала создать страницу, а потом создать на нее гиперссылки на других страницах.

Примечание: При создании (редактировании) страницы в рамках рабочей группы доступна опция Опубликовать в живой ленте. Если флажок установлен, то любое действие над данной страницей будет отмечено в Живой ленте сообщением. Статья, которая предварительно редактировалась без галочки, при установке галочки все равно остается скрытой.


Редактирование страницы и история
88 / 401

Редактирование страницы

Для редактирования страницы необходимо воспользоваться кнопкой Править. По этой кнопке откроется форма правки, аналогичная форме создания страницы. Изменения вступят в силу сразу после опубликования исправленной страницы.

Примечание: Изменение названия страницы через кнопку Править отразится на URL ведущем на страницу. Соответственно все ссылки на измененную страницу в других вики-страницах перестанут работать, т.е. станут "красными ссылками". Если необходимо изменить название страницы с сохранением всех ссылок, то воспользуйтесь кнопкой Переименовать.

При правке страницы можно добавить комментарий к конкретной версии. Этот комментарий будет отображён в списке изменений.

История версий

Видеоролик "История редактирования"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

Если в системе установлен модуль Бизнес-процессы, то возможно ведение истории изменений и сравнение версий страниц. Список всех текущих версий можно просмотреть по кнопке История.

Можно выбрать любые две версии и сравнить их между собой. При сравнении красным цветом отобразится то что удалено из старой версии в сравнении с новой, а зеленым, что добавлено в новую версию в сравнении со старой.

Ссылка Восстановить до текущей позволит более раннюю версию сделать текущей версией.

Если над документом работает одновременно несколько человек, то на сайте отобразится версия, законченная последней. Все остальные версии будут сохранены в истории.


Категории и теги
89 / 401

Категории

Категории - один из механизмов классификации создаваемых страниц. Категории могут иметь подкатегории. Вложенность подкатегорий не ограничена.

Видеоролик "Категории"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже.

Ролик озвучен.

Категории создаются при создании (редактировании) страниц (кнопка Указать категорию) и выводятся под текстом страницы. Ссылка Категории отображается под текстом страницы независимо от того добавлена ли конкретная страница в какую либо категорию. По этой ссылке можно перейти к общему списку категорий.

Если страница категории не создана, она будет высвечиваться красной ссылкой, как и в случае с обычными страницами. Для создания страницы категории необходимо кликнуть по красной ссылке, а затем воспользоваться ссылкой Создать в тексте под панелью (а не кнопкой Создать на Контекстной панели страницы!).

Создавая страницу категории можно задать какая категория будет для нее старшей. Для этого воспользуйтесь кнопкой [image] Указать категорию.

Примечание: На странице категории происходит указание вышестоящей категории, а не подкатегорий, которые должны входить в эту категорию.

Если ошибочно был назначен неверный порядок иерархии, подчиненность можно сменить. Для этого нужно сначала отвязать одну категорию от другой, а потом только задавать новые отношения иерархии.

Для удаления категории нужно вручную удалить текст [[Категория:_название категории_]] с wiki-страницы.

Теги

Теги - инструмент для поиска страниц штатными поисковыми механизмами.

Примечание: Теги недоступны в Wiki, работающей в рамках модуля Социальная сеть.

Теги добавляются при редактировании страницы. При этом появляется список уже использованных в системе тегов с указанием числа страниц с выбранным тегом.

Примечание: Для коробочной версии Битрикс24 существует способ создавать автоматически формируемые списки страниц. Для реализации такой задачи надо обратиться к администратору.


Пошаговый пример создания статьи в Wiki
90 / 401

Создадим и наполним раздел "Рецепты" в Wiki в группе "Кулинария".

  • Переходим в группу, кликаем на пункте Wiki в меню.
  • На главной странице нажимаем копку
  • Вводим заголовок страницы Рецепты, в поле текста 5 строк: Салаты, Супы, Вторые блюда, Выпечка, Напитки и оформляем их в виде заголовка. Добавляем теги: рецепты, приготовить, блюда, суп, салат.

  • Добавляем и форматируем тексты определений в каждый раздел.

  • Задаем внутренние гиперссылки для тех понятий, для которых будут созданы отдельные соответствующие страницы.

  • Из получившихся красных ссылок

    • создаем соответствующие страницы.

  • Указываем категорию для страницы.

  • Заполняем страницу нужным текстом, картинками, с помощью визуального редактора форматируем страницу в соответствии с предпочтениями или корпоративными стандартами.

  • После нажатия на копку [image] получаем готовую страницу, где можно проверить наполнение информацией, форматирование, переходы по ссылкам и т.д.

  • Нажав на ссылку Категории в конце страницы, можно проверить состав и наполненность категорий, корректность переходов по страницам.

  • В случае необходимости, страницы можно отредактировать или восстановить какую-либо из предыдущих версий.


Бизнес-процессы
91 / 401

Бизнес-процесс - это процесс обработки документа, для которого задана одна точка входа и несколько точек выхода и последовательность действий (шагов, этапов, функций), совершаемых в заданном порядке и в определенных условиях.

Другими словами Бизнес-процесс – последовательность действий, направленных на получение заданного результата.

Бизнес-процессы в Битрикс24 можно найти в следующих местах:

  • Библиотека документов
  • CRM
  • Универсальные списки

Документы

В системе все бизнес-процессы работают с так называемыми документами. Это может быть файл (библиотека документов), элемент списка (универсальные списки) или же элемент CRM.

Настройки прав на бизнес-процессы

Для корректной работы бизнес-процессов необходимо произвести настройки прав доступа для пользователей.

При создании бизнес-процесса при выборе пользователей в настройках действий в форме Вставка значений выводятся только те пользователи, которые имеют соответствующий уровень доступа к типу документа, для которых создаётся бизнес-процесс.

Например, если в настройках библиотеки документов для определённой группы пользователей будет выставлен уровень прав Чтение, то они не будут иметь доступа к работе с бизнес-процессами, хотя могут просматривать файлы.

Видео

Видеозаписи с вебинаров, в которых рассказывается о том, что такое бизнес-процессы, как с ними работать, а также рассмотрены примеры их использования:

Примечание: Функционал в продукте может меняться со временем и отличаться от показанного в ролике.


Работа с бизнес-процессами
92 / 401

Бизнес процессы организации предназначены для автоматизации деятельности организации. По умолчанию создано и представлено пять типовых бизнес-процессов:

  • Счет на оплату
  • Заявление на отпуск
  • Заявление на командировку
  • Исходящие документы
  • Выдача наличных

Администратор может изменять и копировать, а для редакции продукта Компания и создавать собственные, бизнес-процессы.

Важно! Если вы не можете работать с бизнес-процессами организации на портале, обратитесь к Администратору портала.

Примечание: Создание нового бизнес-процесса организации, а также редактирование и настройка уже существующих доступно только при наличии необходимой квалификации и соответствующих прав доступа (по умолчанию - только для Администратора).

Работа с бизнес-процессами осуществляется через пункт меню Бизнес-процессы.

Задания бизнес-процессов

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Выполнение бизнес-процессов

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Как только появятся процессы, требующие внимания, их количество будет отражено рядом с пунктом меню Бизнес-процессы. Выполнение назначенных заданий по бизнес-процессам организации, как и заданий по бизнес-процессам документов, осуществляется на закладке Задания бизнес-процессов (Бизнес-процессы> Задания бизнес-процессов). Перейдя на закладку можно увидеть любую информацию о бизнес-процессе, вывод которой можно настроить, щелкнув правой кнопкой мыши по шапке таблицы. Также приведено описание действий, которые необходимо сделать.

Подробную информацию о каждом действии можно получить:

  • Выбрав соответствующую команду в меню действий.

  • Кликнув правой кнопкой мыши по строке действия.

  • Дважды кликнув левой кнопкой мыши по строке действия.

Пользуясь фильтром процессов можно найти необходимые процессы в списке. Руководитель подразделения может найти процессы, выполняемые его подчиненными, и делегировать их.

Процессы в ленте

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Работа с бизнес-процессами организации

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

На странице Процессы в ленте (Бизнес-процессы> Процессы в ленте) пользователь может просмотреть и запустить бизнес-процессы, к которым у него есть доступ (для старых версий коробочного Битрикс24 список процессов располагается во вкладке Сервисы > Процессы). Также в этом разделе администратор может указать, какие из этих процессов будут доступны для вызова прямо из Живой ленты.

Важно! В Живой ленте для вас будут отображаться только те процессы, для которых у вашей группы пользователей есть необходимые права доступа. Если вы не можете работать с бизнес-процессами организации на портале, обратитесь к Администратору портала.

Мои процессы

Вызвать бизнес-процессы на исполнение можно также через закладку Бизнес-процессы> Мои процессы. Эта страница хранит все процессы, которые были вызваны вами, включая историю их исполнения и полную информацию о них.

Расположение вкладки Мои процессы в старых версиях коробочного Битрикс24

После нажатия на данную кнопку будет предложено заполнить поля с входными параметрами вашего процесса. Однако настройки параметров работы (Кто утверждает, Кто оплачивает и т.п.) должны быть предварительно проведены, иначе бизнес-процесс не начнет свое выполнение.

Все активные

На странице Все активные (Бизнес-процессы> Все активные) можно увидеть список активных запущенных процессов. На этой странице можно следить за выполнением запущенных процессов, контролировать зависшие. Обычный пользователь будет видеть список процессов запущенных только им самим. Администратору портала будет видно все процессы запущенные на портале, которые он может удалить в случае зависания.

1 - можно выбрать модули, для которых были запущены процессы. Также можно выбрать зависшие процессы.

2 - для поиска определенных задач можно воспользоваться фильтром.

3 - настроить отображение колонок списка можно, кликнув правой кнопкой по шапке таблицы.

4 - с помощью меню действий можно перейти к документу (и удалить для администратора).

Примечание: Подробнее про работу с бизнес-процессами можно посмотреть в отдельном курсе Бизнес-процессы.


Бизнес-процессы в живой ленте
93 / 401

Важной особенностью бизнес-процессов в Битрикс 24 является то, что их можно удобно и быстро использовать прямо из живой ленты. Но для этого использование бизнес-процессов в ленте должно быть разрешено администратором. Те процессы, которые использовать не разрешено выводиться в данном меню не будут. После этого нужно выбрать из списка бизнес-процесс, появляющийся по нажатию на вкладку Процессы.

Для того, чтобы бизнес-процесс начал свое выполнение необходимо произвести настройку параметров его работы. Для процесса Счет на оплату форма настройки будет иметь следующий вид.

После того, как вы выберете нужный вам процесс в правой части живой ленты появится значок настроек процесса.

  • Настроить параметры Бизнес-процесса - команда, позволяющая перенастроить заданные параметры. Доступна обычным пользователям только при наличии особых прав их рабочей группы

    • Важно! Остальные команды может выполнить только администратор.

  • Делегировать настройки параметров - позволяет передать права по настраиванию бизнес-процесса другому сотруднику, не являющемуся администратором.
  • Дизайнер Бизнес-процесса - переход к редактированию процесса с помощью Дизайнера.
  • Расширенные настройки - переход к окну детального просмотра процесса, содержащему полные возможности редактирования процесса.

Когда вы запустите бизнес-процесс, вы получите об этом уведомление прямо в живую ленту. Каждый шаг исполнения процесса также будет фиксироваться в ленте.

Также сотрудники могут обмениваться информацией об исполнении бизнес-процесса, оставляя комментарии в процессе работы.

Виджет со счетчиками процессов

Для удобства работы с бизнес-процессами присутствует специальный виджет, расположенный рядом с живой лентой.

Каждая строка виджета содержит счетчик процессов, разделенных на группы. Чтобы посмотреть процессы по интересующей вас группе нужно кликнуть по строке с ее названием.

  • Ждут реакции - количество текущих процессов, ожидающих выполнения пользователем. Общее количество также разделяется по отдельным группам, относительно функционала работы: CRM, Списки, Документы, Процессы (бизнес-процессы организации).
  • Мои процессы - общее количество запущенных самим пользователем процессов.

Примечание: данный виджет отображается только в том случае, если есть запущенные вами процессы или активные задания по бизнес-процессам. В противном случае данный виджет отображаться не будет.


Типы бизнес-процессов
94 / 401

При помощи модуля Бизнес-процессы могут быть описаны два типа бизнес-процессов: последовательный и со статусами.


Последовательный бизнес-процесс
95 / 401

Последовательный бизнес-процесс — действия выполняются одно за другим от точки входа до точки выхода.

Последовательный бизнес-процесс представляет собой бизнес-процесс как набор шагов, которые следует выполнять по порядку до тех пор, пока они все не завершатся. Он похож на обычную блок-схему, описывающую алгоритм решения задачи.

Последовательный бизнес-процесс начинает работу, выполняя находящееся в нем первое дочернее действие, и продолжается до тех пор, пока не выполнит все остальные дочерние действия.


Бизнес-процесс со статусами
96 / 401

Бизнес-процесс со статусами (так же известный как машина состояний или автомат на состояниях) — начала и конца не имеет, в процессе работы происходит переход из одного состояния в другое.

Бизнес-процесс со статусами представляет собой набор состояний, переходов и действий. Одно состояние обозначается как начальное состояние. В процессе выполнения процесс переходит из одного состояния в другое, основываясь на событиях.

При переходе бизнес-процесса в любой из статусов выполняется последовательный подпроцесс для инициализации этого статуса. После чего бизнес-процесс становится в ожидание одного из определенных в данном статусе событий. Список возможных событий и их названия могут быть получены для отображения в пользовательском интерфейсе. На каждое событие может быть получен список групп пользователей, которые имеют право отправлять данное событие.

При возникновении события выполняется последовательный подпроцесс, соответствующий принятому событию (связанный с ним).

Среди действий подпроцесса может быть действие по установке нового статуса. В этом случае бизнес-процесс переводится в новый статус. Если такого действия нет, то текущий статус считается конечным и бизнес-процесс завершается.

Если для данного статуса определен последовательный подпроцесс для финализации этого статуса, то он выполняется непосредственно перед выходом из данного статуса (перед переходом в другой статус).

Ссылки по теме:
  • Создание шаблона бизнес-процесса со статусами
  • Пример использования бизнес-процесса со статусами для организации обработки и доработки документа


Выбор типа бизнес-процесса
97 / 401

Практически любая возникающая задача может быть решена как с помощью последовательного бизнес-процесса, так и с помощью бизнес-процесса со статусами. Выбор не оптимального типа бизнес-процесса для конкретной задачи существенно усложнит шаблон бизнес-процесса.

Тип последовательный бизнес-процесс выбирается в том случае, если просто необходимо выполнить определенную последовательность действий.

Тип бизнес-процесс со статусами выбирается в том случае, если бизнес-процесс (документ) может находиться в разных состояниях, переходы между которыми осуществляются по определенным правилам. При этом появляется возможность автоматически контролировать права на доступ к документу в разных состояниях и на выполнение переходов между состояниями. Для каждого состояния может быть задан набор событий, при возникновении которых выполняются соответствующие подпроцессы.


Типовые бизнес-процессы для документов
98 / 401
Типовые бизнес-процессы - образцы часто используемых процессов, которые включены в состав продуктов «1C-Битрикс», содержащих модуль Бизнес-процессы.

Типовые бизнес-процессы включены в состав как неизменяемые процессы. Их можно настроить на работу с нужными сотрудниками, но нельзя изменить схему прохождения документа.

Изменение шаблонов типовых бизнес-процессов, а также создание собственных шаблонов возможно с помощью Дизайнера бизнес-процессов.

Типовые бизнес-процессы для документов

  • Двухэтапное утверждение (последовательный процесс)
    Нажмите на рисунок, чтобы увеличить
Рекомендуется для ситуаций утверждения документа с предварительной экспертной оценкой. В рамках процесса на первом этапе документ утверждается экспертом. Если им документ не утвержден, то он возвращается на доработку. Если утвержден, то документ передается для принятия решения группой сотрудников простым большинством голосов. Если документ не принят на втором этапе голосования, то он возвращается автору на доработку и повторяется процесс утверждения.
  • Экспертная оценка (последовательный процесс)
    Нажмите на рисунок, чтобы увеличить
Рекомендуется для ситуаций, когда для принятия решения по документу лицу, принимающему решение, нужна экспертная оценка по документу. В рамках процесса назначается экспертная группа, каждый участник которой может высказать свое мнение по документу. Мнения передаются лицу, принимающему решение, который утверждает или нет документ.
  • Ознакомление с документом (последовательный процесс)
    Нажмите на рисунок, чтобы увеличить
Предназначен для ситуаций, когда группу сотрудников нужно ознакомить с каким-то документом. В рамках процесса задается группа работников, которая должна быть поставлена в известность. Дается право оставлять комментарии.
  • Простое утверждение/голосование (последовательный процесс)
    Нажмите на рисунок, чтобы увеличить
Рекомендуется для ситуаций, когда требуется принятие решения простым большинством голосов. В его рамках можно включить в список голосующих нужных сотрудников, дать возможность комментировать свое решение голосовавшим. По окончании голосования всем участникам сообщается принятое решение.
  • Утверждение документа со статусами (бизнес-процесс со статусами)
    Нажмите на рисунок, чтобы увеличить
Прохождение документом цепочки утверждения со статусами.
  • Публикация на подключенных сайтах (последовательный процесс, который доступен только в старших редакциях Бизнес-процессы и Холдинг)
    Нажмите на рисунок, чтобы увеличить
Позволяет опубликовать элемент инфоблока на подключенных сайтах. Документ предварительно публикуется на сайте контроллера.
  • Утверждение по первому голосу (последовательный процесс)
    Нажмите на рисунок, чтобы увеличить
Рекомендуется для ситуаций, когда достаточно одного экспертного мнения из некоторого сообщества. В рамках этого процесса задается список сотрудников, имеющих право принять решение c уведомлением о начавшемся процессе. Процесс считается завершенным по первому отозвавшемуся сотруднику.


Дизайнер бизнес-процессов
99 / 401

Дизайнер бизнес-процессов предназначен для проектирования, создания и изменения бизнес-процессов.

Механизм проектирования бизнес-процессов реализован за счет визуального программирования по технологии drag&drop, понятной и известной любому пользователю компьютера. Шаблон бизнес-процессов создается в особом визуальном конструкторе, который позволяет пользователю, не владеющему программированием, задать нужный порядок бизнес-процесса, отобразить его специфичные потребности с помощью простых графических схем.

Создание бизнес-процессов - это программирование, хоть и без написания кода (в большинстве случаев). Помимо знания предметной области, в которой проектируется шаблон, и знания реального процесса, который нужно автоматизировать, требуется постановка задачи, алгоритмирование и тестирование. Для этого нужны определенные навыки и базовая подготовка.

Созданный шаблон бизнес-процесса может быть выполнен автоматически или вручную, в зависимости от настроек. В любое время может одновременно выполняться несколько экземпляров бизнес-процесса, и система занимается управлением выполнения этих экземпляров, сохраняя и восстанавливая их состояние по требованию. Ведется лог каждого экземпляра бизнес-процесса для дальнейшего анализа работы схемы и корректировки ее под новые условия.

Примечание: Если проектируемый процесс будет иметь сложную структуру, то лучше использовать Бизнес-процесс со статусами.


Визуальный конструктор
100 / 401

Визуальный конструктор - инструмент, входящий в состав Дизайнера бизнес-процессов, который позволяет создавать и редактировать шаблоны бизнес-процессов.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Дизайнер бизнес-процессов

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Переход к визуальному конструктору

Для разных типов документов переход к визуальному конструктору может отличаться. Обычно это кнопка или пункт меню с подписью Бизнес-процессы.

Например, для списков будет следующий вид:

Внешний вид визуального конструктора

Внешний вид визуального конструктора

Примечание: Вид визуального конструктора будет отличаться в зависимости от того, какой процесс редактируется.

Визуальный конструктор состоит из следующих областей:

  • контекстная панель (1)
  • основная рабочая область (2)
  • панель действий конструктора (3)
  • кнопки управления (4)

Контекстная панель

Контекстная панель визуального конструктора состоит из следующего набора кнопок:

  • Параметры шаблона - позволяет задать/изменить основные параметры и параметры запуска бизнес-процесса;
  • Список шаблонов - позволяет перейти к списку шаблонов бизнес-процессов;
  • Создать шаблон <тип_бизнес-процесса> - позволяет перейти к созданию одного из типов бизнес-процессов:
    • Бизнес-процесс со статусами - длительный бизнес-процесс с разделением прав доступа при работе с документами в разных статусах;
    • Последовательный бизнес-процесс - простой бизнес-процесс, позволяющий запустить документ в последовательную обработку.
  • Экспорт - позволяет экспортировать текущий шаблон бизнес-процесса;
  • Импорт - позволяет импортировать шаблон бизнес-процесса взамен текущего.

Основная рабочая область

Внешний вид основной рабочей области зависит от типа бизнес процесса:

  • В случае шаблона со статусами основная рабочая область будет иметь вид:

    Визуальный конструктор, процесс со статусами

    При редактировании каждого отдельного действия будет открываться форма редактирования последовательного подпроцесса.

  • В случае с последовательным процессом основная рабочая область будет иметь вид:

    Визуальный конструктор, последовательный процесс

Создание и редактирование шаблона бизнес-процесса, т.е. добавление некоторых действий, осуществляется простым перетягиванием действия на основную рабочую область конструктора в нужном месте шаблона бизнес-процесса:

Основная рабочая область

Или же можно воспользоваться меню, которое доступно при нажатии на "треугольник":

Основная рабочая область

Для удаления ненужного действия служит кнопка X, а для выполнения детальной настройки размещенного в шаблоне действия служит кнопка X.

Примечание: Для экономии места на экране некоторые действия можно сворачивать с помощью соответствующей кнопки.

Панель действий конструктора

Панель действий визуального конструктора содержит набор действий, из которых и производится конструирование шаблона.

Подробное описание всех действий смотрите в главе Действия.

Кнопки управления

Если осуществляется создание/редактирование шаблона последовательного бизнес-процесса, то отображаются следующие кнопки:

  • Сохранить - служит для сохранения шаблона и переходу к списку шаблонов.
  • Применить - служит для сохранения шаблона и продолжения процесса редактирования шаблона.
  • Отменить - служит для отмены внесенных изменений и переходу к списку шаблонов.

Если же выполняется создание/редактирование шаблона бизнес-процесса со статусами, то отображается только кнопка Вернуться к настройке статусов, которая служит для перехода к схеме шаблона, где и выполняется сохранение/отмена внесенных изменений в статусы и их действия.

Примечание: Если шаблон был изменен, но не сохранен, то при попытке покинуть страницу появится предупреждение возможной потере несохраненных данных, с возможностью сохранить изменения.


Форма "Вставка значения"
101 / 401

При работе с бизнес-процессом в параметрах действий, параметрах шаблона и настройках статуса можно указывать как собственный текст, заданный вручную, так и использовать различные переменные, поля документа и прочие данные, которые не нужно задавать вручную. Для этого используется специальная форма Вставка значения:

  • Параметры шаблона - вставка параметров шаблона, которые задаются для конкретного шаблона в соответствующей форме, доступной по кнопке Параметры шаблона на контекстной панели визуального конструктора бизнес-процесса. Значением параметра будет то, что введет пользователь в соответствующих полях при запуске бизнес-процесса.
  • Переменные - вставка пользовательских переменных, которые могут изменяться по ходу выполнения бизнес-процесса.
    Пример: дополнительное числовое поле, заполняемое пользователем в процессе выполнения бизнес-процесса.
  • Константы - вставка заранее заданных констант, которые остаются неизменными в процессе исполнения бизнес-процесса. Их значение задается в параметрах шаблона и пользователь, не имеющий доступа к изменению процессов не может менять их значение.
  • Поля документа - вставка значения какого-либо поля документа, участвующего в бизнес-процессе.
    Например: Дата создания или Кем создан.
  • Дополнительные результаты - вставка результатов выполнения некоторых действий. Не все действия после их выполнения предоставляют дополнительные результаты. В списке отображаются сразу все доступные результаты для всех действий, добавленных в текущий процесс, если они их поддерживают.
  • Пользователи - вставка пользователя или группы пользователей, которые будут причастны к выполнению бизнес-процесса. Можно выбрать несколько пользователей/групп пользователей. Для этого в качестве разделителя используется символ ;.
  • Категории пользователей - позволяет более подробно указать пользователей, которые будут причастны к выполнению бизнес-процесса. В том числе можно выбрать Отдел или Группу соцсети.
Примечание: можно вставлять как отдельные группы пользователей, так и целые отделы и группы социальной сети. Для этого в настройках прав доступа к элементам и разделам процесса нужно указать группы, которые вы хотите чтобы отображались в форме. Любая помещенная в эту вкладку группа вне зависимости от указанного уровня доступа будет отображаться в списке. Данная возможность пока недоступна в бизнес процессах в универсальных списках.

Следующие значения недоступны напрямую из формы, но могут быть использованы при проектировании шаблона бизнес-процесса:

  • {=Workflow:ID} - идентификатор бизнес-процесса;
  • {=User:ID} - идентификатор текущего пользователя в формате user_[номер_пользователя_в_системе];
  • {=Template:TargetUser} - параметр, в котором содержится идентификатор пользователя, запустившего бизнес-процесс в формате user_[номер_пользователя_в_системе];
  • {=System:Now} - текущая дата со временем на сервере;
  • {=System:NowLocal} - текущая дата со временем у клиента (учитывается часовой пояс);
  • {=System:Date} - текущая дата без времени;
  • {=Document:DETAIL_PAGE_URL} - позволяет получить ссылку на страницу детального просмотра документа, при условии, что в настройках инфоблока корректно заполнен URL страницы детального просмотра.

    • Примечание: Некоторые Примеры работы с выражениями рассмотрены в соответствующем уроке главы.

Использование некоторых значений полей контактов/компаний (для облачной версии)

В рамках бизнес-процессов для сделок в CRM можно использовать некоторые значения из полей контакта или компании, которые связаны с этой сделкой.

Для Контактов можно использовать следующие значения:

  • {=Document:CONTACT_ID} - ID контакта;
  • {=Document:CONTACT_TYPE_ID} - ID типа контакта;
  • {=Document:CONTACT_NAME} - имя контакта;
  • {=Document:CONTACT_SECOND_NAME} - фамилия контакта;
  • {=Document:CONTACT_LAST_NAME} - отчетство контакта;
  • {=Document:CONTACT_FULL_NAME} - ФИО контакта;
  • {=Document:CONTACT_ADDRESS} - фактический адрес контакта.

Для Компаний можно воспользоваться следующими значениями:

  • {=Document:COMPANY_ID} - ID компании;
  • {=Document:COMPANY_TITLE} - Название компании;
  • {=Document:COMPANY_INDUSTRY} - ID сферы деятельности;
  • {=Document:COMPANY_REVENUE} - годовой оборот;
  • {=Document:COMPANY_CURRENCY_ID} - ID валюты;
  • {=Document:COMPANY_TYPE} - ID типа компании;
  • {=Document:COMPANY_ADDRESS} - фактический адрес компании;
  • {=Document:COMPANY_BANKING_DETAILS} - банковские реквизиты.

Модификация типов данных

Для параметров и переменных шаблона, а так же полей документа используется модификатор _printable, преобразующий значения в понятную пользователю строку.

Для переменной типа пользователь это выглядит следующим образом:

{=Variable:user}
{=Variable:user_printable}

Результат, если значение переменной равно Автор:

author
Автор

Если для поля документа или параметра доступен такой вариант отображения, то он будет представлен в форме Вставка значения. Если же печатная форма не предусмотрена, то можно запросить вывод печатной формы от любого значения (переменная, дополнительный результат и т.п.).

Пример: {=Variable:Datetime > date, printable} // перевод даты в печатную форму

Кроме того, можно преобразовывать не только в печатную форму, но и менять тип данных.

{=Variable:string>date} // преобразование строки в дату

Таблица преобразования типов данных

Начальный/конечный | bool (Да/Нет) | date (Дата) | datetime (Дата/Время) | double (Число) | int (Целое число) | file (Файл) | select (Список) | string (Строка) | text (Текст) | user (Пользователь)
bool (Да/Нет) | --- | x | x | 1 или 0 | 1 или 0 | х | х | Y или N | Y или N | x
date (Дата) | x | --- | по формату | timeslamp | timeslamp | x | x | по формату | по формату | x
datetime (Дата/Время) | x | по формату | --- | timeslamp | timeslamp | x | x | по формату | по формату | x
double (Число) | 0==N !0==Y | из timeslamp | из timeslamp | --- | (int) | x | x | (string) | (string) | user_<ID>
int (Целое число) | 0==N !0==Y | из timeslamp | из timeslamp | (float) | --- | x | x | (string) | (string) | user_<ID>
file (Файл) | x | x | x | x | x | --- | x | x | x | x
select (Список) | Y или N | x | x | (float) | (int) | x | --- | (string) | (string) | user_<ID> group_<CODE> <ID>
string (Строка) | Y или N | strtotime | strtotime | (float) | (int) | x | x | --- | (string) | user_<ID> group_<CODE> <ID>
text (Текст) | Y или N | strtotime | strtotime | (float) | (int) | x | x | (string) | --- | user_<ID> group_<CODE> <ID>
user (Пользователь) | x | x | x | ID | ID | x | x | (string) | (string) | ---

Примечание: все выражения в тексте автоматически преобразуются к строке, при отсутствии дополнительных идентификаторов.

Примечание: при преобразовании типа Список в Строку или Текст берутся значения списка, при преобразовании Списка в Список - ключи списка. Для получения значения ключа списка нужно использовать конвертирование, например: {=Variable:Select > select}.

Для данных типа Пользователь также есть возможность преобразования в формат friendly. В таком случае будет выводиться только имя и фамилия пользователя, без его ID и логина.

Пример: {=Document:CREATED_BY} > User_1

{=Document:CREATED_BY > printable} > Иван Иванов [1]

{=Document:CREATED_BY > friendly} > Иван Иванов

Важно! Для версий модуля до 15.6.0 преобразование типов данных, в том числе и запрос печатной формы для значений, не имеющих таковой, возможно с помощью переменных и действия PHP-код.

Примечание: Для вставки одного и того же значения в разные действия шаблона не обязательно всегда пользоваться формой Вставка значения. Достаточно скопировать текст, вставленный с помощью этой формы, и использовать его дальше.

Решение некоторых проблем (для коробочной версии)

Если для документа было создано дополнительное поле и оно по каким-либо причинам не отображается в форме Вставка значения, то необходимо перейти к настройкам инфоблока в административной части сайта (Контент > Инфоблоки > Типы инфоблоков > [требуемый_инфоблок], закладка Свойства), и в параметрах свойств этого поля отметить опцию Выводить на странице списка элементов поле для фильтрации по этому свойству:.

Если этого не сделать, то будет невозможным использовать это свойство в бизнес-процессах.


Вычисление значений выражений в параметрах действий
102 / 401

В системе имеется возможность вычислять значения выражений в параметрах действий, для этого необходимо поставить знак = в поле перед операциями.

Пример: =6^2 + {=Document:PROPERTY_NUM}/2 или =if({Document:ID}=5, "текст1", "текст2").

В каждом поле можно использовать сразу несколько разных вычислений. В случае, если нужно не только произвести вычисление, но так же вывести дополнительные данные (значение переменных, текст), то необходимо использовать оператор конкатенации (&), а текст писать в кавычках (").

Пример: ="Ответ:" & (1+3) или ="Автор: " & {=Document:CREATED_BY} & ", " & "Конечный срок: " & Dateadd({=Document:DATE_CREATE}, "1d")

Примечание: С версии 15.6.0 вычисляемые значения можно просто размещать в тексте, поместив вычисление в конструкцию {{=...}}. Например: Вам необходимо оформить документы до {{=DateAdd({=Document:CREATED}, '5d')}}.

Примечание: Синтаксис символьных операторов аналогичен синтаксису соответствующих php-функций.

Доступны следующие операторы:

  • + - сложение;
  • - - вычитание;
  • * - умножение;
  • / - деление;
  • = - равно;
  • <> - не равно;
  • < - меньше;
  • > - больше;
  • <= - меньше или равно;
  • >= - больше или равно;
  • () - порядок действий;
  • & - оператор конкатенации, который возвращает строку, представляющую собой соединение левого и правого аргумента;
  • ^ - возведение в степень;
  • % - вычисление процентов;
  • true - правда;
  • false - ложь;
  • and - логический оператор И;
  • or - логический оператор ИЛИ.

    Пример: =if(or({=Variable:aaa}>2, {=Variable:bbb}<10), "yes", "no")
  • not - отрицание;
  • min - наименьшее значение;
  • abs - вычисление модуля;
  • dateadd - Добавляет заданное количество дней, месяцев, лет, часов, минут и секунд к указанной дате.

    Синтаксис: =dateadd([начальная_дата], [что_добавлять]);

    Варианты написания: y, year, years, m, month, months, d, day, days, h, hour, hours, i, min, minute, minutes, s, second, seconds.
    При написании можно использовать верхний или нижний регистр.

    Примеры: =Dateadd({=Document:DATE_CREATE}, "-2d"), =Dateadd({=Document:DATE_CREATE}, "2 days 3 minutes").

    В случае, если необходимое для добавления количество единиц времени содержится в поле, переменной и т.п., то необходимо использовать оператор конкатенации &.

    Например: =DateAdd({=Document:DATE_CREATE}, {=Variable:WHAT2ADD} & "y 10h")
  • datediff - Позволяет вычислить разницу между двумя датами.

    Синтаксис: =datediff([первая дата], [вторая дата], [как выводить разницу]);

    Разницу можно выводить в разных единицах, в зависимости от решаемых вами задач.

    Примеры: =datediff({=Variable:Variable1}, {=Variable:Variable2},'%m month, %d days')

    • Внимание! Данный оператор работает только с параметрами типа Дата/Время.

  • if - условие.

    Синтаксис: =if([условие], [результат_в_случае_выполнения_условия], [результат_в_случае_не_выполнения_условия]);

    Пример: =if ({=Variable:Variable1_printable}>0, "да", "нет")

    При сравнении значений переменных также возможно сравнивать переменные с разным типом данных. Однако сравниваемые переменные должны соответствовать таблице преобразования типов.

  • intval - возвращает целое значение переменной;

    Пример: =intval("234j4hv5jhv43v53jk4vt5hj4") вернет 234
  • substr - возвращает подстроку.

    • Внимание! Если синтаксис выражения будет неправильным, то оно будет отображено как текст.

  • merge - Позволяет объединять массивы.

    Синтаксис: = merge({=массив_1}, {=массив_2});

    Пример: = merge({=Document:FILES}, {=Variable:file}).

  • AddWorkDays - функция добавляет N рабочих дней к указанной дате.

    Синтаксис: =addworkdays([дата, к которой будут добавляться дни], [количество добавляемых рабочих дней]).

    Пример:

    {{=addworkdays('07.03.2016', 1)}} - результат: 09.03.2016 00:00:00, т.к. в настройках сайта 8 марта - выходной.

    {{=addworkdays('05.02.2016 16:14:00', 1)}} - результат: т.к. 05.02.2016 - пятница, то результат: 08.02.2016 16:14:00 - понедельник.

  • isWorkDay - проверяет, является ли дата рабочим днем (по Календарю).

    Синтаксис: =if(isWorkDay([проверяемая дата]), [сообщение, если дата является рабочим днем], [сообщение, если не является]).

    Пример:

    {{=if(isWorkDay({=Template:Parameter1}), 'Да', 'Нет')}} - в параметре содержится дата 28.04.2016. Результат - Да, т.к. это рабочий день.

  • isWorkTime - аналогична функции isWorkDay, но для типов данных Дата/Время.

    Синтаксис: =if(isWorkDay([проверяемая дата со временем]), [сообщение, если дата со временем является попадает на рабочее время], [сообщение, если не попадает]).

    Пример:

    {{=if(isWorkTime({=Template:Parameter1}), 'Да', 'Нет')}} - в параметре содержится дата со временем 27.04.2016 15:00:00. Результат - Да, т.к. это рабочее время.

  • WorkDateAdd - добавляет заданное количество рабочих дней, часов и минут к указанной дате.

    Синтаксис: =WorkDateAdd([начальная_дата], [что_добавлять]).

    Варианты написания: d, day, days, h, hour, hours, i, min, minute, minutes. Допустимо написание как в верхнем, так и в нижнем регистре.

    Пример:

    =WorkDateAdd({=Template:Parameter1}, "2d") - в параметре содержится дата 28.04.2016. Результат - 02.05.2016 09:00:00, т.к. 30.04 и 1.05 - это выходные дни, то они будут пропущены. 09:00:00 - начало рабочего дня. Настроить список выходных дней и начало рабочего дня можно в Настройках портала.


Примеры работы с выражениями
103 / 401

Использование переменных в ссылках

В полях действий, поддерживающих тег [url], можно использовать собственные переменные для создания ссылок:
    [url=http://{=Variable:Domain}/{=Variable:Path}]название ссылки[/url]
где: {=Variable:Domain} и {=Variable:Path} - переменные, содержащие адрес сервера и требуемый путь.

Создание прямой ссылки на страницу с заданием

Данную ссылку можно использовать, например, для отправки пользователю сообщения о том, что ему необходимо выполнить задание в рамках бизнес-процесса.

    Ссылка на страницу с заданием: [url=http://[адрес_портала]/company/personal/bizproc/{=Workflow:ID}/]ссылка на страницу просмотра документа[/url]

Создание ссылки на страницу детального просмотра документа

Данную ссылку можно использовать, например, для отправки пользователю сообщения из которого он бы смог перейти непосредственно к просмотру документа.

    Ссылка на страницу детального просмотра документа: [url]{=Document:DETAIL_PAGE_URL}[/url]

Примечание: Выражение {=Document:DETAIL_PAGE_URL} будет формировать нужную ссылку при условии, что в настройках инфоблока корректно заполнен URL страницы детального просмотра.

Проверка корректности времени

    =if(and((intval(substr({=Template:Parameter1}, 0, 2)) >= 0), (intval(substr({=Template:Parameter1}, 0, 2)) < 25), (substr({=Template:Parameter1}, 2, 1) = ":"), (intval(substr({=Template:Parameter1}, 3, 2)) >= 0), (intval(substr({=Template:Parameter1}, 3, 2)) < 60)), {=Template:Parameter1}, "время указано неправильно")

Если в параметре {=Template:Parameter1} передается время (в 24 часовом формате чч:мм, например "21:45"), то будет возвращено его значение. Иначе вернется "время указано неправильно".

Данное выражение можно использовать для полей документа, переменных или параметров шаблона.


Пример вычисления числовых значений с последующей записью в поля документа
104 / 401

Рассмотрим небольшой пример работы с полями документа и вычислением их значений. Для простоты будем использовать функционал списков (описанные ниже действия будут применимы и к другим типам документов, например, CRM).

За основу возьмем сообщение с форума:

"Доброго времени суток, может кто сталкивался с такой задачей, нужно чтоб во время оформления сделки высчитывалась чистая прибыль, т.е. от заложенной суммы сделки вычитался налог усн (6%), вычитались затраты на подряд (если они есть) и все это потом записывалось в отчет менеджера по проведенной сделке."

  • Создадим новый список, а в нем набор следующих полей типа число:

    • Сумма,
    • Затраты на подряд,
    • Налог (6%). Считается автоматически,
    • Итоговая сумма. Считается автоматически.

    Поле Затраты на подряд будет не обязательным к заполнению. Если оно будет содержать значения, то они будут учитываться в расчетах, в противном случае - не будут.

    Примечание: В зависимости от настроек PHP, значения полей типа число могут отображаться в Экспоненциальной форме записи.

  • Создадим шаблон последовательного бизнес-процесса и настроим его на запуск при добавлении нового элемента.
  • Добавим и настроим первое действие Изменение документа, которое будет вычислять налог от общей суммы следующим образом:

    Поле: Налог (6%). Считается автоматически,

    Значение: ={=Document:PROPERTY_s}*0.06,

    где

    {=Document:PROPERTY_s} является значением поля Сумма.

  • Добавим и настроим второе действие Изменение документа, которое будет вычислять итоговую сумму с учетом всех вычетов:

    Поле: Итоговая сумма. Считается автоматически,

    Значение: ={=Document:PROPERTY_s}-{=Document:PROPERTY_contract}-{=Document:PROPERTY_tax},

    где

    {=Document:PROPERTY_s} является значением поля Сумма,
    {=Document:PROPERTY_contract} является значением поля Затраты на подряд,
    {=Document:PROPERTY_tax} является значением поля Налог (6%). Считается автоматически.

Шаблон для ознакомления: Скачать

Примечание: Перед импортом шаблона ознакомьтесь с материалом урока Экспорт и импорт.


Шаблоны бизнес-процессов
105 / 401

Шаблон БП представляет собой последовательность шагов (действий) от начального к конечному, которые будут выполняться один за другим. Необходимо таким образом и в таком порядке составить шаги (действия), чтобы реализовать нужный нам алгоритм и получить необходимый результат.

Шаблоны бизнес-процессов используются для быстрой и эффективной настройки формы бизнес-процесса согласно потребностям сотрудника. При создании бизнес-процесса на основе шаблона происходит не только изменение внешнего вида бизнес-процесса, но и заполнение его некоторыми начальными параметрами.

Процесс проектирования шаблона бизнес-процесса можно разделить на два этапа:

  • первый - это задание основных параметров шаблона бизнес-процесса;
  • второй - это конструирование шаблона, по которому будет выполняться бизнес-процесс.


Настройка параметров шаблона
106 / 401

Форма настройки параметров шаблона бизнес-процесса разделена на несколько закладок, с помощью которых задаются параметры запуска и настройки бизнес-процесса.

  • Основное
  • Параметры
  • Переменные
  • Константы
  • Доступ

Основное

На закладке Основное указываются название шаблона бизнес-процесса, его описание и определяются параметры автоматического запуска:

Бизнес-процесс может быть автоматически запущен при создании и/или при изменении элемента информационного блока. Если оба флага сняты, то бизнес-процесс может быть запущен только вручную.

Параметры

Параметры используются для явного указания каких-либо значений, которые будут использованы во время исполнения данного процесса. Значения параметров задаются непосредственно перед запуском бизнес-процесса в специальных полях.

Чтобы добавить параметр запуска процесса, следует нажать ссылку Добавить параметр на закладке Параметры и заполнить следующие поля:

  • Идентификатор - символьный идентификатор параметра;
  • Название - название параметра;
  • Описание - произвольное описание параметра;
  • Тип - с помощью выпадающего списка указывается тип данных параметра запуска;
  • Обязательный - если опция отмечена, то обязательно должно быть указано значение данного параметра для запуска бизнес-процесса;
  • Множественный - при отмеченной опции может быть задано несколько значений параметра;
  • Значение по умолчанию - в зависимости от выбранного типа данных указывается значение параметра, используемое по умолчанию.

    Примечание: для некоторых типов данных значение по умолчанию можно указать с помощью кнопки [...], по нажатии которой открывается форма Вставка значения.

Для сохранения параметра служит кнопка OK. В результате параметр создастся и отобразится в общем списке:

Описанным способом создаются все необходимые параметры запуска бизнес-процесса. С помощью ссылок Изменить и Удалить, расположенных в колонке Действия для каждого параметра, можно соответственно отредактировать или удалить требуемый параметр.

С помощью ссылок Выше/Ниже можно упорядочить большой список параметров. На сам бизнес-процесс порядок расположения параметров не влияет.

Переменные

Переменные используются для временного хранения данных, необходимых для выполняемого процесса. Значения переменных хранятся до тех пор, пока выполняется бизнес-процесс. После его завершения они все стираются.

Поэтому если необходимо куда-то сохранять переменную, например файл, который пользователь должен добавить на определенном этапе, то следует использовать действие Изменение документа. С помощью него можно сохранять значение переменной в предварительно созданное дополнительное поле документа соответствующего типа (файл, например).

Переменные создаются аналогично, как и параметры бизнес-процесса: по ссылке Добавить переменную на закладке откроется форма создания переменной.

Константы

Константы нужны для хранения информации, значение которой не должно меняться во время исполнения данного процесса. Их значение нужно настраивать до запуска бизнес-процесса.

Константы добавляются по ссылке Добавить константу на соответствующей закладке. При этом откроется вкладка создания константы.

В поле Значение константы нужно указать, какое значение будет иметь константа в процессе исполнения бизнес-процесса.

После заполнения необходимых полей нужно нажать ОК, чтобы сохранить созданную константу. Когда вы добавили все константы нужно нажать Сохранить.

Доступ

На закладке Доступ для пользователей задаются начальные права, которые будут установлены для документа при его запуске. Причем права доступа могут быть заданы как явно, так и с помощью переменных.

Если используется упрощенная (старая) версия прав, то они устанавливаются жестко извне (настройки доступа к инфоблокам/спискам/и.т.д.). Единственный вариант, позволяющий устанавливать права прямо из бизнес-процесса - это установка для документа права бизнес-процессы извне. В этом случае с помощью закладки Доступ или действия Установка прав можно менять права по ходу выполнения процесса.

Если используются расширенные права, то из бизнес-процесса можно только добавлять новые права на документ, которые будут оставаться у документа даже после выполнения процесса. Переопределить права, которые были установлены извне, внутри бизнес-процесса нельзя.


Создание шаблона последовательного бизнес-процесса
107 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Создание шаблона последовательного бизнес-процесса

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

При проектировании шаблона последовательного бизнес-процесса после настройки и сохранения его параметров сразу становится доступным визуальный конструктор для конструирования шаблона.

Конструирование шаблона выполняется путем добавления в рабочую область необходимых действий с последующей настройкой их параметров:

Настройка параметров каждого действия осуществляется в специальной форме, открываемой с помощью кнопки [image], причем набор параметров зависит от конкретного действия.

Пример настройки параметров для действия "Почтовое сообщение"

Заполните необходимые поля. Для упрощения процедуры заполнения полей служит кнопка [image], при нажатии которой открывается зависящая от типа поля форма Вставка значения.

Для выбора значения откройте нужную группу, затем выберите необходимое значение и нажмите кнопку Вставить (либо дважды кликнете по выбранному значению). Для вставки нескольких значений необходимо повторно вызвать форму выбора значения. Значение или его код будут подставлены в настраиваемое поле (На иллюстрации выше такой код выделен красной рамочкой).

По окончании настройки параметров действия, сохраните его. Система вернется к созданию (редактированию) шаблона бизнес-процесса.

Когда в шаблон будут добавлены и настроены все необходимые действия, не забудьте сохранить его. Шаблон отобразится в списке всех шаблонов бизнес-процессов.


Создание шаблона бизнес-процесса со статусами
108 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Создание шаблона бизнес-процесса со статусами

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

При проектировании шаблона бизнес-процесса со статусами, после настройки его параметров осуществляется переход к конструированию непосредственно самого шаблона в 2 этапа:

  1. Создание необходимых статусов;
  2. Настройка действий внутри каждого статуса и создание связей между статусами;
  3. Настройка прав доступа для статуса.
Также будет рассмотрено следующее:
  • Общая схема работы
  • Небольшой пример настройки статуса

Создание статусов

Создание статусов выполняется на главной странице построения шаблона бизнес-процесса

Для этого:

  • Нажмите кнопку Добавить статус для создания нового статуса:

    Важно! Бизнес-процесс всегда будет начинаться с первого созданного статуса. Изменить статус, с которого будет начинаться процесс, в последующем невозможно.

  • В форме создания статуса указывается его название и права доступа к документу (элементу бизнес-процесса) в данном статусе:

  • Сохраните статус.

Аналогичным образом добавляются все необходимые вам статусы.

Например, могут быть добавлены следующие статусы в шаблон:

Настройка действий внутри каждого статуса и создание связей между статусами

После того, как все статусы созданы, следует настроить операции и действия (подпроцессы), которые будут выполняться в каждом статусе, а также создать связи между статусами.

Для каждого статуса может быть настроено следующее:

  • Команда, позволяет пользователю вручную запускать подпроцесс. Внешний вид элемента управления, с помощью которого пользователем будет запускаться команда, зависит от места запуска бизнес-процесса и типа документа. Команду можно использовать, например, для определения того, как должен исполняться бизнес-процесс. Или как подпроцесс, который нужно выполнить только при определенных условиях.

    Действие сходно по смыслу действию Команда для шаблона последовательных бизнес-процессов.

  • Выполнение через заданное время - позволяет отложить выполнение подпроцесса на заданное в обработчике время. Данное действие удобно использовать, например, если необходимо автоматически выполнить какие-то действия без участия сотрудников.

    Действие сходно по смыслу действию Пауза в выполнении для шаблона последовательных бизнес-процессов.

  • Обработчик входа в данный статус - отдельный последовательный бизнес-процесс, всегда выполняемый автоматически при входе в данный статус.
  • Обработчик выхода из данного статуса - отдельный последовательный бизнес-процесс, всегда выполняемый автоматически при выходе из данного статуса. Например, можно отправлять информационное сообщение, что процесс вышел из текущего статуса.

Настройка прав доступа для статуса

По умолчанию бизнес-процесс использует права документа, но в каждом статусе можно дополнительно указать права, которые будут добавлены к правам документа именно в этом статусе.

Рассмотрим пример настройки прав для документа и определенного статуса на основе списков

В настройках списка укажем следующие права доступа:

  • Сотрудники = добавление;
  • Автор = чтение.

После такой настройки прав работа со списком будет следующей:
Сотрудник сможет добавлять элементы списка и просматривать только свои, но он не сможет видеть текущий статус бизнес-процесса на соответствующей вкладке при детальном просмотре элемента списка.

Примечание: Смысл в том, что права на список и права у бизнес-процесса - это разные права. И по правилам списков (инфоблоков) они "не знают" такой тип пользователя как Автор (это понятие только для бизнес-процессов).

Решение проблемы с отображением статуса бизнес-процесса на соответствующей вкладке детального просмотра элемента списка:

В настройках прав требуемого статуса укажем, что право на чтение имеет Автор. В этом случае права из бизнес-процесса добавятся к правам на список, и произойдет сопоставление понятия Автор с конкретным пользователем и его правами в списке.

После такой настройки пользователь сможет просматривать статус бизнес-процесса, когда тот будет находиться в требуемом статусе.

Общая схема работы

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Общая схема работы бизнес-процесса со статусами

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

При входе в статус первым всегда выполняется Обработчик входа в данный статус, если он задан. После выполнения всех внутренних действий статуса бизнес-процесс переходит в режим ожидания. Для дальнейшего продолжения процесса можно воспользоваться подпроцессами Выполнение через заданное время и Команда.

Примечание: если в Обработчике входа в данный статус уже добавлен переход к другому статусу прерывающий выполнение текущего, то после него сразу будет выполняться Обработчик выхода из данного статуса. Подпроцессы Выполнение через заданное время и Команда будут в таком случае пропущены.

Если статус не является конечным, то переход от одного статуса к другому (создание связей) с помощью действия Установить статус, которое должно располагаться внутри подпроцесса, предполагающего такой переход.

При выходе из статуса автоматически будет выполнен подпроцесс Обработчик выхода из данного статуса, если он создан.

Небольшой пример настройки статуса

Например, рассмотрим добавление команды для статуса Черновик.

Для этого:

  • В выпадающем меню для данного статуса выберите пункт Команду. Откроется форма настройки основных параметров команды:

  • Укажите название команды и пользователей, которые могут выполнить данную команду. Если документ должен сменить статус после выполнения команды, то выберите необходимый статус с помощью выпадающего списка. Список статусов формируется из статусов бизнес-процесса.
  • Сохраните параметры команды.

В результате будет создано действие в статусе и связь между статусами:

Поскольку команда - это собственный последовательный бизнес-процесс, то данный процесс необходимо создать.

Для этого:

  • Кликнете по названию команды. Откроется визуальный конструктор:

    • В конструкторе уже содержится действие Установить статус, так как в ходе выполнения команды происходит смена статуса бизнес-процесса. В схему команды добавьте необходимые вам действия и выполните их настройку.

    Примечание: создание отдельного бизнес-процесса в каждом статусе выполняется аналогично созданию последовательного бизнес-процесса.

    Когда подпроцесс создан, то для возврата на главную страницу создания шаблона бизнес-процесса со статусами служит кнопка Вернуться к настройке статусов.

  • Для настройки действий в каждом статусе повторите описанные выше шаги.

  • По окончании выполнения необходимых настроек не забудьте сохранить шаблон с помощью кнопки Сохранить, доступной на главной странице со статусами бизнес-процесса.


Пример использования параметров шаблона
109 / 401

Необходимо, чтобы при запуске бизнес-процесса пользователь имел возможность явно указывать сотрудника, которому будет адресовано почтовое сообщение, отсылаемое в ходе выполнения процесса. Рассмотрим как это можно реализовать на примере штатного бизнес-процесса Ознакомление с документом в котором это уже сделано.

  • В форме Параметры шаблона на закладке Параметры создан параметр:

  • В действии Почтовое сообщение указан в поле Получатель созданный параметр (Форма Вставка значений, группа значений Параметры шаблона):

В результате при запуске бизнес процесса у пользователя будут запрашиваться дополнительные параметры:


Пример использования бизнес-процесса со статусами для организации обработки и доработки документа
110 / 401

В данном примере мы будем рассматривать только принцип создания и использования статусов, опустив прочие настройки.

Рассматриваемый бизнес-процесс позволяет утверждать документ в цикле, запрашивая требуемую информацию в случае доработки, а также отображает автору и проверяющему комментарии, которые они оставляют при выполнении соответствующих заданий.

Порядок действий:

  • Создадим 3 статуса: Рассмотрение документа, Доработка, Утвержден.
  • В каждом добавим по подпроцессу Вход в статус.

Настройка статуса Рассмотрение документа

  • Перейдем в статус и добавим действие Утверждение документа. В параметрах действия заполним все обязательные поля.

    Поле Описание задания пока оставим пустым, мы к нему вернемся позже.

  • Добавим действия Установить статус в каждую ветку утверждения документа, после чего произведем их настройку для статусов Утвержден и Доработка.

В результате должен получиться следующий процесс:

В случае если проверяющий сотрудник утвердит документ, то бизнес процесс перейдет в статус Утвержден, иначе - в статус Доработка.

Настройка статуса Доработка

  • Перейдем в статус и добавим действие Запрос дополнительной информации. В параметрах действия заполним все обязательные поля.

    В Поле Описание задания, используя форму Вставка значения, добавим комментарий, который будет оставлен проверяющим после выполнения действия Утверждение документа (Значение Утверждение документа > Комментарий в группе Дополнительные результаты).

  • Вернемся в статус Рассмотрение документа к настройке действия Утверждение документа. В поле Описание задания, используя форму Вставка значения, добавим комментарий, который будет оставлен автором после выполнения действия Запрос дополнительной информации (см. выше).
  • Добавим действие Установить статус и произведем его настройку для статуса Рассмотрение.

В результате в этом статусе мы получим от автора нужные исправления/комментарии и отправим документ на повторное утверждение.

Настройка статуса Утвержден

  • В этом статусе можно, например, добавить действия для оповещения автора о результатах утверждения документа.

В итоге, после всех настроек, наш бизнес процесс со статусами будет выглядеть следующим образом:

Шаблон для ознакомления: Скачать


Экспорт и импорт
111 / 401

Процесс переноса шаблона с одного проекта на другой достаточно простой, для этого необходимо воспользоваться соответствующими кнопками на контекстной панели дизайнера бизнес-процессов.

Примечание: Перенос шаблона с одной установки на другую подразумевает наличие администраторских прав.

Но перед этим в проекте, куда будет импортироваться шаблон, необходимо создать такие же типы документов (инфоблок/список/и.т.д.) как и в проекте, откуда экспортируется шаблон.

Внимание! Нельзя экспортировать шаблон процесса с одним типом документа в процесс с другим. Пример: экспортировать шаблон из CRM в Списки.

Примечание: В связи с особенностью работы модуля списков импорт шаблона бизнес-процесса для них нужно проводить с некоторыми условиями.

Наиболее простой вариант - это изначально создать и настроить список, поля и шаблон бизнес-процесса:

  • Создавать пользовательские поля в исходном списке не через интерфейс списков, а прямо через интерфейс конструктора бизнес-процессов;
  • После экспорта шаблона из исходного списка в новый обязательно проверить все действия, где используются пользовательские поля.

Если же пользовательские поля исходного списка были уже ранее созданы через публичный интерфейс самих списков, то импорт нужно проводить по следующей схеме:

  • Создать и настроить новый список также как и исходный;
  • Создать и настроить через публичный интерфейс модуля списков такие же поля, как и в исходном списке;
  • Задать для пользовательских полей и их значений (например, для полей типа список) такие же идентификаторы, как и в исходном списке через административную часть сайта;
  • Импортировать шаблон бизнес-процесса;
  • Обязательно проверить получившийся после импорта шаблон, особенно те действия, где используются пользовательские поля.

При несоблюдении указанных условий шаблон и пользовательские поля могут некорректно импортироваться.


Действия
112 / 401

Последовательный бизнес-процесс строится из набора действий. Каждое действие выполняет определенную функцию и имеет собственные параметры.

Внимание! Состав действий зависит от установленных в системе модулей.

Настройка параметров действия

Настройка параметров действия производится в соответствующей форме, которая вызывается с помощью двойного клика по тексту заголовка действия или с помощью кнопки [image] расположенной на нем.

Общие моменты для большинства действий

  • Поле Заголовок - позволяет задать заголовок действия, который будет отображен в визуальном конструкторе.

    Примечание: Для одинаковых действий следует задавать разные заголовки. Это упростит дальнейшую работу с процессом.
    Например: Дополнительные результаты в форме Вставка значения сгруппированы именно по заголовкам действий.

  • [Ид] - ссылка, позволяющая просмотреть/изменить уникальный идентификатор действия. Например, его можно использовать при просмотре истории выполнения бизнес-процесса в административной части сайта.

    В поле допустимо вводить только буквы латинского алфавита, цифры и символ подчеркивания.

  • Поля выбора пользователей/групп. Пользователя можно задать непосредственно вручную. Для этого нужно указать в поле его идентификатор в квадратных скобках, например [1]. Указание группы пользователей отличается тем, что скобки использовать не нужно.

  • Поля Описание задания позволяют использовать следующие теги bb-code: [img], [url], [b], [i], [s], [u].

    Тег [url] можно использовать и в уведомлениях, например, в поле Текст сообщения действия Сообщение соц.сети.

  • В любых действиях, где есть возможность множественного выбора либо полей, либо условий доступен выбор только из одной сущности. Например, в действии Цикл выход из цикла можно организовать либо по сочетанию группы полей, либо по сочетанию группы условий.

Ссылки по теме:
  • Создание собственных действий


Обработка документа
113 / 401

В группе собраны действия, связанные с этапами обработки документа.


Публикация на подключенных сайтах
114 / 401

Действие позволяет опубликовать элемент инфоблока на подключенных сайтах.

Примечание: Действие относится к модулю Контроллер, подробнее ознакомиться с работой модуля можно в уроке Контроллер сайтов.

Описание Параметров

Тип выбора сайтов - указывается, на каких сайтах будет опубликован элемент инфоблока

  • Все сайты;
  • Сайты принадлежащие определенным группам;
  • Выбранные сайты из одной группы.

Синхронизировать элементы

  • немедленно - элементы будут синхронизированы немедленно;
  • используя задачи - синхронизация будет происходить с использованием задач.

Важно! С версии 15.5.0 Дизайнера бизнес-процессов данное действие включено только для модуля Инфоблоки.


Создание элемента списка
115 / 401

Действие позволяет создать элемент указанного списка.

Описание параметров

Тип документа - выбор инфоблока создаваемого элемента. В зависимости от выбранного типа будет предложено заполнить необходимые поля.


Запуск бизнес-процесса
116 / 401

Действие позволяет запустить другой шаблон бизнес-процесса.

Описание параметров

ID документа - идентификатор документа, над которым будет запускаться бизнес-процесс.

Примечание: Для запуска бизнес-процесса над сущностями CRM нужно перед ID добавлять префикс CONTACT_, COMPANY_, DEAL_, LEAD_.

Сущность - на какой сущности будет запущен бизнес-процесс (зависит от созданных шаблонов бизнес-процессов).

Тип документа - тип документа сущности (для Списков/Процессов - инфоблоки, для Диска - список хранилищ).

Шаблон - выбрать шаблон запускаемого бизнес-процесса. Набор доступных шаблонов будет различным в зависимости от типа документа.

Ожидать завершения бизнес-процесса - бизнес-процесс будет ожидать выполнения запущенного действия процессом, чтобы продолжить свое исполнение.


Создание нового документа
117 / 401

Действие позволяет создать новый документ с заданными параметрами.

Описание Параметров

В зависимости от типа документа, поля могут отличаться.

Например, для бизнес-процесса в инфоблоках в качестве документа будет создан новый элемент инфоблока. Соответственно поля в форме настройки параметров действия будут аналогичны полям в форме создания элемента инфоблока для конкретного типа инфоблоков.


Удаление документа
118 / 401

Действие удаляет документ, по поводу которого запущен бизнес-процесс.


Блокировка документа
119 / 401

Действие позволяет заблокировать документ от действий других бизнес-процессов.

Блокировка документа происходит для действий других процессов, а не пользователей. Другой пользователь, если он обладает правами на изменение, сможет отредактировать документ.

Примечание: Не забудьте разблокировать документ после проведения всех нужных операций с помощью соответствующего действия.

Примечание: Возможность блокировки зависит от типа документа.

Важно! С версии 15.5.0 Дизайнера бизнес-процессов данное действие исключено для модуля Диск.


Публикация документа
120 / 401

Действие публикует документ и переводит его в статус опубликован.

Примечание: Возможность публикации зависит от типа документа.

Важно! С версии 15.5.0 Дизайнера бизнес-процессов данное действие исключено для модуля CRM.


Сохранение истории документа
121 / 401

Действие позволяет создать слепок документа с внесенными на момент запуска действия изменениями. Доступно автоматическое задание названия копии с настройками параметров.

Описание Параметров

Название записи в историю - указывается название версии документа, под которым он будет сохранен в истории. Это позволит отличить его от других версий.

Оставьте поле пустым для того, чтобы название бралось из документа.

Важно! С версии 15.5.0 Дизайнера бизнес-процессов данное действие исключено для модуля Диск.


Изменение документа
122 / 401

Действие позволяет в автоматическом режиме изменить любой параметр (поле) документа.

Описание Параметров

Ссылка Добавить условие позволяет добавить в форму еще один из параметров документа, который необходимо будет изменить выполняемому действию.

Ссылка Добавить поле позволяет добавить собственный новый параметр непосредственно в документ. Эти действия приведут к созданию новых свойств документа.

Пример: Для документов типа инфоблоки это приведет к созданию дополнительных полей элемента инфоблока.


Разблокировка документа
123 / 401

Действие разблокирует документ для других бизнес-процессов.

Примечание: Если не разблокировать документ, то он будет недоступен для других действий бизнес-процесса.

Важно! С версии 15.5.0 Дизайнера бизнес-процессов данное действие исключено для модуля Диск.


Снятие документа с публикации
124 / 401

Действие снимает документ с публикации.

Противоположно действию Публикация документа.

Важно! С версии 15.5.0 Дизайнера бизнес-процессов данное действие исключено для модуля CRM.


Задания
125 / 401

В группе содержатся действия, создающие задания бизнес-процессов для пользователей.


Утверждение документа
126 / 401

Действие позволяет произвести утверждение документа, для которого запущен бизнес-процесс. В зависимости от результата (утвержден документ или нет) возможно 2 варианта развития дальнейших действий.

Примечание: Бизнес-процесс будет поставлен в ожидание (приостановлен), пока кто-либо из указанных пользователей не выполнит задание (утвердит или отклонит заявку) или не выйдет время (см. опцию Период утверждения).

Описание Параметров

Утверждают сотрудники - указываются пользователи, которые должны утвердить документ.

Тип утверждения - выбирается, по какому принципу будет утверждаться документ указанными выше пользователями:
  • Все сотрудники - утвердить должны все пользователи указанные выше;
  • Любой сотрудник - утвердить должен любой из пользователей, указанных выше;
  • Голосование сотрудников - утверждение производится методом голосования среди указанных выше пользователей.

    Для варианта Голосование сотрудников доступны поля Более скольки процентов голосов необходимо для принятия решения и Ожидать, чтобы проголосовали все указанные сотрудники.

    Последнее поле можно использовать для автоматизации передавая в него значения Y или N. Если выбран вариант да, то действие будет ожидать, пока не проголосуют все указанные выше сотрудники. Если выбран вариант нет, то действие будет ожидать, пока не наберется указанный процент голосов.

Название задания - задается название задания по утверждению документа, которое будет поставлено указанным пользователям. Именно оно будет отображаться в интерфейсе для пользователей.

Описание задания - указывается описание или пояснения к заданию. Содержимое данного поля будет отображаться в интерфейсе для пользователей. Рекомендуется в этом поле указывать полную информацию о действии, которое необходимо выполнить пользователю. Это поможет избежать путаницу в случае нескольких однотипных действий.

Устанавливать текст статуса - позволяет изменить текст статуса документа на произвольный. Это может, например, позволить отслеживать на каком этапе сейчас находится бизнес-процесс.

Текст статуса - задается текст статуса.
Можно использовать следующие модификаторы в тексте статуса: #PERCENT# - процент, #VOTED# - ознакомлено человек, #TOTAL# - всего должно быть ознакомлено, #APPROVERS# - список утвердивших, #REJECTERS# - список отклонивших.

Текст кнопки подтверждения в задании и Текст кнопки отказа в задании позволяют задать собственный текст для соответствующих кнопок.

Показывать поле ввода комментария - опция позволяет разрешить пользователям оставлять собственные комментарии к назначенному заданию. Например, какие-либо замечания касаемо утверждаемого документа. Содержимое поля можно получить после выполнения действия с помощью соответствующей опции в форме Вставка значения - Дополнительные результаты (см. ниже).

Обязательность комментария - опция позволяет назначить добавление комментария при выполнении действия обязательным. Можно включить обязательность комментария только для утверждения или отклонения документа.

Метка для поля комментария - подпись для поля с комментарием.

Период утверждения - Можно задать период, если до окончания которого документ не будет утвержден либо отвергнут, то документ будет автоматически отвергнут. Пустое значение или 0 - отсутствие периода.

Период утверждения: Если до окончания периода документ не будет утвержден либо отвергнут, то документ будет автоматически отвергнут. Пустое значение или 0 - отсутствие периода - позволяет установить время, в течение которого действие будет ожидать выполнения.

Ограничить доступ - делает текст задания видимым только для исполнителя задания и не показывает его в живой ленте. Это очень полезная опция, если нужно, например, передать исполнителю конфиденциальную информацию: пароли, пин-коды и т.п.

Примечание: При выполнении задания по утверждению несколькими сотрудниками в публичной части история изменения документа, включая комментарии других утверждающих, будет отображена в зависимости от прав на документ.

Например
Eсли в Списке для определенной группы пользователей задать право только на добавление, то историю изменения (и комментарии соответственно), пользователь этой группы при выполнении задания не увидит:

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • Комментарий;
  • Сколько проголосовало;
  • Сколько должно проголосовать;
  • Процент проголосовавших;
  • Процент утвердивших;
  • Процент отклонивших;
  • Количество утвердивших;
  • Количество отклонивших;
  • Последний голосовавший;
  • Утвердили пользователи;
  • Отклонили пользователи;
  • Автоматическое отклонение - поле будет содержать 1, если документ был автоматически отклонен (см. Период утверждения).


Запрос доп.информации (с отклонением)
127 / 401

Действие создает задание, в ходе которого у пользователя (или пользователей) будет запрошена дополнительная информация необходимая для выполнения бизнес-процесса. В отличии от стандартного действия Запрос дополнительной информации пользователь может отклонить ввод информации.

Описание Параметров

Заполняют сотрудники - указываются пользователи, один из которых (первый кто приступит к его выполнению) должен указать дополнительную информацию.

Другими словами задание будет доступно всем указанным пользователям до тех пор, пока кто-то один не начнет его выполнять. После этого оно автоматически отменится у всех остальных сотрудников.

Название задания - задается название задания по заполнению дополнительной информации, которое будет поставлено указанным пользователям. Именно оно будет отображаться в интерфейсе для пользователей.

Описание задания - указывается описание или пояснения к заданию. Содержимое данного поля будет отображаться в интерфейсе для пользователей. Рекомендуется в этом поле указывать полную информацию о действии, которое необходимо выполнить пользователю. Это поможет избежать путаницу в случае нескольких однотипных действий.

Текст кнопки в задании - позволяет задать собственный текст для кнопки, соответствующей вводу информации.

Текст кнопки отклонения в задании - позволяет задать собственный текст для кнопки, соответствующей отклонению ввода информации.

Тип отклонения - указывается принцип, по которому будет проводиться отклонение ввода информации:

  1. Все сотрудники - запрос информации будет проводиться, пока все указанные сотрудники его не отклонят;
  2. Любой сотрудник - при первом же отклонении каким-либо сотрудником другие сотрудники запросы не получают.

Показывать поле ввода комментария - опция позволяет разрешить пользователям оставлять собственные комментарии к назначенному заданию. Например, какие-либо примечания касаемо задания. Содержимое поля можно получить после выполнения действия с помощью соответствующей опции в форме Вставка значения - Дополнительные результаты (см. ниже).

Обязательность комментария - опция позволяет назначить добавление комментария при выполнении действия обязательным.

Метка для поля комментария - подпись для поля с комментарием.

Устанавливать текст статуса - позволяет изменить текст статуса документа на произвольный. Это может, например, позволить отслеживать на каком этапе сейчас находится бизнес-процесс.

Текст статуса - задается текст статуса.

Период ожидания информации: По окончании периода задание будет автоматически завершено. Пустое значение или 0 - отсутствие периода. - позволяет установить время, в течение которого действие будет ожидать выполнения.

Ограничить доступ - делает текст задания видимым только для исполнителя задания и не показывает его в живой ленте. Это очень полезная опция, если нужно, например, передать исполнителю конфиденциальную информацию: пароли, пин-коды и т.п.

Раздел Поля позволяет добавить собственные поля, которые будет необходимо заполнить пользователям в ходе выполнения задания.

Содержимое полей после выполнения действия можно получить в форме Вставка значения - Переменные.

Переменные

В этом разделе можно получить содержимое дополнительных полей, созданных в разделе Поля.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • Комментарий.
  • Автоматическое завершение.
  • Пользователь, предоставивший информацию.


Запрос дополнительной информации
128 / 401

Действие создает задание, в ходе которого у пользователя будет запрошена дополнительная информация необходимая для выполнения бизнес-процесса.

Описание Параметров

Заполняют сотрудники - указываются пользователи, один из которых (первый кто приступит к его выполнению) должен указать дополнительную информацию.

Другими словами задание будет доступно всем указанным пользователям до тех пор, пока кто-то один не начнет его выполнять. После этого оно автоматически отменится у всех остальных сотрудников.

Название задания - задается название задания по заполнению дополнительной информации, которое будет поставлено указанным пользователям. Именно оно будет отображаться в интерфейсе для пользователей.

Описание задания - указывается описание или пояснения к заданию. Содержимое данного поля будет отображаться в интерфейсе для пользователей. Рекомендуется в этом поле указывать полную информацию о действии, которое необходимо выполнить пользователю. Это поможет избежать путаницу в случае нескольких однотипных действий.

Текст кнопки в задании - позволяют задать собственный текст для соответствующей кнопки.

Показывать поле ввода комментария - опция позволяет разрешить пользователям оставлять собственные комментарии к назначенному заданию. Например, какие-либо примечания касаемо задания. Содержимое поля можно получить после выполнения действия с помощью соответствующей опции в форме Вставка значения - Дополнительные результаты (см. ниже).

Обязательность комментария - опция позволяет назначить добавление комментария при выполнении действия обязательным.

Метка для поля комментария - подпись для поля с комментарием.

Устанавливать текст статуса - позволяет изменить текст статуса документа на произвольный. Это может, например, позволить отслеживать на каком этапе сейчас находится бизнес-процесс.

Текст статуса - задается текст статуса.

Период ожидания информации: По окончании периода задание будет автоматически завершено. Пустое значение или 0 - отсутствие периода. - позволяет установить время, в течение которого действие будет ожидать выполнения.

Ограничить доступ - делает текст задания видимым только для исполнителя задания и не показывает его в живой ленте. Это очень полезная опция, если нужно, например, передать исполнителю конфиденциальную информацию: пароли, пин-коды и т.п.

Раздел Поля позволяет добавить собственные поля, которые будет необходимо заполнить пользователям в ходе выполнения задания.

Содержимое полей после выполнения действия можно получить в форме Вставка значения - Переменные.

Переменные

В этом разделе можно получить содержимое дополнительных полей, созданных в разделе Поля.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • Комментарий.
  • Автоматическое завершение.
  • Пользователь, предоставивший информацию.
  • Измененные поля.


Ознакомление с документом
129 / 401

Действие позволяет создать для выбранных пользователей задание по ознакомлению с документом и возможностью оставить отзыв на него. В ходе выполнения задания ведется вычисление процента ознакомившихся.

Описание Параметров

Ознакомить пользователей - указываются пользователи, которые должны ознакомиться с документом.

Название задания - задается название задания по ознакомлению с документом. Именно оно будет отображаться в интерфейсе для пользователей.

Описание задания - указывается описание или пояснения к заданию. Содержимое данного поля будет отображаться в интерфейсе для пользователей. Рекомендуется в этом поле указывать полную информацию о действии, которое необходимо выполнить пользователю. Это поможет избежать путаницу в случае нескольких однотипных действий.

Должны ознакомиться

  • Все сотрудники - задача не будет выполнена пока с документом не ознакомятся все пользователи, указанные выше;
  • Любой сотрудник - с документом должен ознакомиться любой из пользователей, указанных выше.

Устанавливать текст статуса - позволяет изменить текст статуса документа на произвольный. Это может, например, позволить отслеживать на каком этапе сейчас находится бизнес-процесс.

Текст статуса - задается текст статуса.
Можно использовать следующие модификаторы в тексте статуса: #PERCENT# - процент, #REVIEWED# - ознакомлено человек, #TOTAL# - всего должно быть ознакомлено, #REVIEWERS# - кто ознакомлен

Текст кнопки в задании - позволяют задать собственный текст для соответствующей кнопки.

Показывать поле ввода комментария - опция позволяет разрешить пользователям оставлять собственные комментарии к назначенному заданию. Например, какие-либо примечания касаемо задания. Содержимое поля можно получить после выполнения действия с помощью соответствующей опции в форме Вставка значения - Дополнительные результаты (см. ниже).

Обязательность комментария - опция позволяет назначить добавление комментария при выполнении действия обязательным.

Метка для поля комментария - подпись для поля с комментарием.

Период ознакомления - можно задать период, если до окончания которого пользователи не будут ознакомлены с документом, то задание по ознакомлению будет автоматически завершено. Пустое значение или 0 - отсутствие периода.

Период ознакомления: По окончании периода ознакомление будет автоматически завершено. Пустое значение или 0 - отсутствие периода. - позволяет установить время, в течение которого действие будет ожидать выполнения.

Ограничить доступ - делает текст задания видимым только для исполнителя задания и не показывает его в живой ленте. Это очень полезная опция, если нужно, например, передать исполнителю конфиденциальную информацию: пароли, пин-коды и т.п.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • Комментарий;
  • Сколько ознакомлено;
  • Сколько должно быть ознакомлено;
  • Автоматическое ознакомление - поле будет содержать 1, если задание по ознакомлению было автоматически завершено (см. Период ознакомления);
  • Последний ознакомившийся - ID последнего пользователя ознакомившегося с документом.


Конструкции
130 / 401

В группе собраны управляющие конструкции.


Команда
131 / 401

Действие, выполнение которого зависит от пользователей. Для них будет создан соответствующий элемент управления.

Примечание: Команда прерывает бизнес-процесс и ожидает действий от пользователя.

Команду можно использовать и отдельно, но тогда нужно будет оповестить пользователя, например, с помощью сообщения соц. сети, что ему необходимо выполнить эту команду. Тип и вид элемента управления зависит от документа и места, где был запущен бизнес-процесс.

Описание Параметров

Выполнить команду могут - позволяет ограничить круг пользователей, которым будет доступна эта команда.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • Пользователь, отправивший команду.

Пример использования действия

В данном примере, после выполнения блока действий, бизнес процесс остановится и будет ждать, пока пользователь с помощью команды не решит, по какой ветке будут развиваться события.


Условие
132 / 401

Конструкция позволяет направить бизнес-процесс по разным сценариям в зависимости от заданных условий.

Проверка условий начинается слева направо. Если условие выполняется, то действия, расположенные в ветке под ним, будут исполнены. Если же какое-либо условие не выполняется, то будет произведен переход к условию, расположенному правее и так до тех пор, пока какое-либо условие не будет выполнено.

Тип условия - PHP код

В качестве условия указывается код.

В случае если указанный PHP код вернет значение true, то будет выполнена ветка действий условия, если возвратится false, то будет произведен переход к следующему условию.

Примечание: Задавать PHP-код может только пользователь с правами администратора.

Внимание! Для этого типа условия можно использовать только PHP-код. Параметры типа {=Variable:Variable2_printable} не поддерживаются.

Также результатом выполнения кода в условии должно быть логическое выражение (true или false).

Тип условия - Поле документа

Ветка действий условия будет выполнена, если совпадут параметры, связанные с полями документа.

Тип условия - Значение переменной

Ветка действий условия будет выполнена, если совпадут параметры, связанные с переменными бизнес-процесса.

Примечание: В этом типе могут быть использованы значения, как переменных, так и параметров шаблона.

Тип условия - Истина

Ветка действий будет выполнена сразу. Это условие выполняется всегда.

Тип условия - Было изменено

Если бизнес-процесс запускается при изменении документа, то есть возможность определять внутри него измененные поля. Ветка условий будет выполняться, если в поле были внесены какие-то изменения.

Примечание: Данный тип условий может быть применим только после дополнительных настроек модуля.

Как настроить этот тип условия (для разработчика)
Для того, чтобы можно было использовать данный тип условия, нужна реализация на стороне модуля, который работает с процессом. При старте процесса необходимо передавать массив изменившихся полей через параметр CBPDocument::PARAM_MODIFIED_DOCUMENT_FIELDS:
CBPDocument::StartWorkflow(
   $arDocumentState["TEMPLATE_ID"],
   BizProcDocument::getDocumentComplexId($arParams["IBLOCK_TYPE_ID"], $arResult["ELEMENT_ID"]),
   array_merge($arBizProcParametersValues[$arDocumentState["TEMPLATE_ID"]], array(
      CBPDocument::PARAM_TAGRET_USER => "user_".intval($GLOBALS["USER"]->GetID()),
      CBPDocument::PARAM_MODIFIED_DOCUMENT_FIELDS => $modifiedFields
   )),
   $arErrorsTmp
);

А для того, чтобы новое условие появилось в редакторе для настройки, необходимо реализовать в документе его поддержку:

public static function isFeatureEnabled($documentType, $feature)
{
   return in_array($feature, array(\CBPDocumentService::FEATURE_MARK_MODIFIED_FIELDS));
}

Внимание! Если ни одно из условий не выполнится, то, бизнес-процесс продолжит выполнять действия расположенные под конструкцией Условие. Другими словами он ее "перескочит".

Объединение условий

Для типов условия Поле документа и Значение переменной возможно объединять условия по правилу И / ИЛИ. При выборе И ветка условий будет исполняться при выполнении обоих условий, а при ИЛИ - любое из указанных.


Параллельное ожидание действия
133 / 401

Конструкция позволяющая направить бизнес-процесс по разным сценариям в зависимости от того, какое из событий наступит раньше.

Для выбора ветки действий в этой конструкции первыми должны быть обязательно использованы действия Команда или Пауза.

Другими словами, какое из этих действий в разных ветках произойдет раньше, то нижележащая цепочка того и будет выполнена.

Действие Пауза позволяет продолжить выполнение бизнес-процесса через определенное время в случае, если ни одна из команд не будет выполнена. Иначе бизнес-процесс просто остановится и будет ожидать выполнения какой-либо команды внутри конструкции.


Параллельное выполнение
134 / 401

Конструкция, позволяющая выполнять параллельные сценарии бизнес-процесса.

Если какая-либо из веток внутри конструкции не будет выполнена, то бизнес-процесс остановится и будет ожидать ее исполнения.

Пример использования: параллельное ознакомление с документом разных групп пользователей.


Установить статус
135 / 401

Действие позволяет перевести бизнес-процесс в другой статус, которое доступно только для бизнес-процессов со статусами.

Примечание: В параметрах действия доступны только заранее созданные статусы.

В действии также доступна опция Прервать выполнение текущего статуса, которая позволяет немедленно перейти к новому статусу, не дожидаясь полной отработки предыдущего.

Подробнее про использование действия смотрите в главе Создание шаблона бизнес-процесса со статусами.


Цикл
136 / 401

Конструкция выполняет свои поддействия до тех пор, пока выполняется заданное условие.

Другими словами цикл работает пока условие истино (true), иначе (false) происходит выход из цикла.

Тип условия - PHP код

В качестве условия указывается код.

В случае если указанный PHP код вернет значение true, то цикл продолжит работу, если возвратится false, то будет произведен выход из цикла.

Примечание: Задавать PHP-код может только пользователь с правами администратора.

Тип условия - Поле документа

Цикл будет продолжать свою работу, пока совпадают параметры, связанные с полями документа.

Тип условия - Значение переменной

Цикл будет продолжать свою работу, пока совпадают параметры, связанные с переменными бизнес-процесса.

Примечание: В этом типе могут быть использованы значения, как переменных, так и параметров шаблона.

Тип условия - Истина

Внимание! В этом случае цикл будет выполняться всегда!

Примечание: Подробнее посмотреть работу цикла можно в уроке Пример использования цикла для утверждения документа.

Внимание! Для облачной версии Битрикс24 количество итераций цикла ограничено 1000.


Уведомления
137 / 401

В группе собраны все виды уведомления о событии.


График отсутствия
138 / 401

Действие позволяет добавить событие в график отсутствия.

Примечание: Действие относится к продукту Корпоративный портал и работает только там.

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.

Пользователь - указывается пользователь, для которого будет занесено событие в график отсутствия.


Информационный звонок
139 / 401

Действие позволяет совершить информационный звонок на указанный номер.

Примечание: Действие работает только при работающей телефонии.

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.

Номер абонента - указывается конкретный номер или строковое поле в документе, в котором указан номер телефона.

Ожидать результата - Приостановить или нет действие Бизнес-процесса пока не будет завершено выполнение информационного звонка.


Календарь
140 / 401

Действие позволяет добавить событие в календарь.

Примечание: Данное действие устарело и используется только со старой версией календарей, которые не используют модуль Календарь событий.

Для текущей версии календаря следует использовать действие Событие календаря.

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.

Пользователь - указывается пользователь, для которого будет создано событие в календаре.


Событие календаря
141 / 401

Действие позволяет добавить событие в календарь (используется для модуля Календарь событий).

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.

Тип календаря (не обязательно) - задается тип календаря, в котором будет создано событие.
Доступные типы календарей можно посмотреть в настройках модуля (Настройки > Настройки продукта > Настройки модулей > Календарь событий, закладка "Типы календарей").

Примечание: Для создания события в личном календаре пользователя тип user указывать не обязательно т.к. по умолчанию при пустом поле событие будет создано именно в этом календаре.

ID владельца календаря (не обязательно) - указывается идентификатор владельца календаря.
В случае создания события в календаре группы указывается ее идентификатор (см. пример ниже).

Примечание: Данное поле актуально, только если Тип календаря не равен user.

Пользователь - указывается пользователь, для которого будет создано событие в календаре.

Пример:

Для создания события в группе (которая, например, имеет адрес http://site_domen/workgroups/group/5/), помимо основных полей, необходимо заполнить поля следующим образом:
  • Тип календаря (не обязательно): group
  • ID владельца календаря (не обязательно): 5

Внимание! Получить значение поля ID секции календаря (не обязательно) можно из базы данных, из исходного кода страницы или из анализа AJAX запроса. Поэтому данное поле лучше заполнять программисту.


Уведомление пользователя
142 / 401

Действие позволяет отправлять сообщения на сайт /XMPP/e-mail.

Если пользователь использует XMPP, то сообщение придет ему туда, иначе оно будет отправлено на сайт в качестве уведомления (если пользователь там авторизован). Если пользователь не авторизован на сайте, то дополнительно текст сообщения будет отправлен по электронной почте.

Описание Параметров

Текст уведомления для сайта - задается текст сообщения, который будет отображаться в качестве уведомления на сайте, если пользователь не использует XMPP.
Для текста доступно форматирование BBCode ([b], [i], [s], [u], [url]).

Текст уведомления для email/jabber - задается текст сообщения для e-mail/XMPP, который будет отправлен, если пользователь не авторизован на сайте. Текст сообщения можно задать как отличный от текста уведомления для сайта, так и такой же, оставив для этого поле пустым.

Тип уведомления - позволяет указать от кого придет сообщение: от конкретного человека или же это будет системное сообщение.


Почтовое сообщение
143 / 401

Действие позволяет отослать уведомление о событии на e-mail, указанный в настройках действия.

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.

Тип сообщения - указывается, как будет отправлено сообщение: в виде текста или с использованием html.

Кодировка - Задается кодировка отправляемого сообщения.

Способ отправки - выбирается способ отправки сообщения:

  • Прямая отправка - сообщение будет отправлено сразу;
  • Отправка через систему сообщений - сообщение будет отправлено через встроенную почтовую систему. Отправка может произойти не сразу.

Сайт шаблона сообщения - указывается сайт шаблона сообщения для отправки его через встроенную почтовую систему. На разных сайтах могут быть разные шаблоны почтовых сообщений.

Примечание: Если отправка сообщения осуществляется через систему сообщений и не проходит, то в первую очередь необходимо проверить выбранный шаблон сообщения.

Разделитель почтовых адресов - указывается символ, которым можно разделить почтовые адреса получателей при групповой рассылке.


Установить текст статуса
144 / 401

Действие позволяет изменить текст статуса документа, что облегчает отслеживание состояния документа в общем списке бизнес-процессов во время выполнения бизнес-процесса.

Также в большинстве случаев статус можно посмотреть, перейдя к детальному просмотру документа, для которого запущен бизнес-процесс.

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.


Сообщение соц.сети
145 / 401

Действие, которое позволяет отправить уведомление о событии указанному пользователю/группе пользователей через модуль социальной сети.

Примечание: Отправителя сообщения может изменить только администратор. Иначе в поле будет указан текущий пользователь, который попытается изменить отправителя.

Если пользователь не активен в течение 10 минут, то сообщение будет отправлено на почту.

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.


Контроль
146 / 401

Действие позволяет отправить уведомление руководителю ответственного за сущность менеджера.

Примечание: данное действие доступно для Сделок и Лидов в бизнес-процессах в CRM.

Параметры действия

Текст сообщения - текст уведомления, отправляемого руководителю.

Отправить руководителю - выбирать ли непосредственного начальника ответственного менеджера, согласно структуре компании.

Дополнительные получатели - дополнительные пользователи, которым будет отправлено уведомление. Если руководителем не является непосредственный начальник, то здесь указывается кому нужно отправить уведомление.


Задача
147 / 401

Действие позволяет создать задачу.

Примечание: Действие относится к модулю Задачи.

Описание Параметров

Настройка параметров действия аналогична созданию новой задачи в публичной части сайта.

Остановить процесс на время выполнения задачи - при отмеченной опции бизнес-процесс будет остановлен до тех пор, пока созданная задача не перейдет в статус Завершена.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • ID задачи;
  • Дата завершения задачи;
  • Пользователь, закрывший задачу.


Сообщение в живую ленту
148 / 401

Действие позволяет отправлять сообщения в Живую ленту указанному пользователю или группе пользователей.

Описание параметров

Автор - от чьего имени будет размещена запись в Живой ленте.

Внимание! Если вдруг в этом поле окажется несколько авторов, то автором записи будет тот, кто указан в поле первым.

Получатели - пользователи, группы пользователей или отделы, в чьих живых лентах будет размещена создаваемая запись.

Тема сообщения - с какой темой будет размещено сообщение.

Текст сообщения - содержание сообщения. Для сообщения поддерживается работа с BB-кодами.

Целевой сайт - в Живой ленте какого сайта публиковать данное сообщение.


Диск
149 / 401

В группе собраны действия для работы с объектами диска.


Детально об объекте Диска
150 / 401

Действие позволяет получить детальную информацию об объекте. Полученная информация используется в качестве дополнительных результатов для других действий.

Описание параметров

Исходный объект - файл или папка на диске, информацию о которых необходимо получить;

Папка или файл Диска - можно указать дополнительные данные для действия, например ID ранее созданной папки.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • Тип объекта;
  • Название;
  • Размер в байтах;
  • Размер (форматированное);
  • URL для просмотра;
  • URL для загрузки.


Загрузить в Диск
151 / 401

Действие загружает файл в хранилище Диска.

Описание параметров

Куда загрузить - куда именно нужно загрузить файл. Возможны следующие варианты:

  • Диск пользователя - в этом случае так же указывается и пользователь, в диск которого будет загружаться файл;
  • Диск группы соцсети - файл будет загружен в диск указанной группы;
  • Общий диск - файл будет загружаться в выбранный общий диск;
  • Папка диска - файл будет загружен в папку на Диске.

Файл для загрузки - необходимо указать сам загружаемый файл;

Загружать от имени - от чьего имени будет загружен файл на диск.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • ID файлов Диска;
  • URL для просмотра;
  • URL для загрузки.


Удалить объект Диска
152 / 401

Действие удаляет объект Диска.

Описание параметров

Исходный объект - файл или папка, которые должны быть удалены;

Папка или файл Диска - можно указать дополнительные данные для действия, например ID ранее созданной папки;

Удалять от имени - от чьего имени будет удален файл.


Копировать/Переместить в Диске
153 / 401

Действие позволяет копировать элементы или перемещать их в Диске.

Описание параметров

Исходный объект - файл или папка, которые будут скопированы;

Папка или файл Диска - можно указать дополнительные данные для действия, например ID созданной ранее папки;

Тип операции - какая операция будет производиться: Перемещение или Копирование.

Куда - куда будет произведено копирование/перемещение. Возможны следующие варианты:

  • Диск пользователя - в этом случае так же указывается и пользователь в, диск которого будет загружаться файл;
  • Диск группы соцсети - файл будет загружен в диск указанной группы;
  • Общий диск - файл будет загружаться в выбранный общий диск;
  • Папка диска - необходимо указать папку, в которую будет загружен файл.

Выполнять от имени - от чьего имени будет выполняться операция.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • ID объектов Диска;
  • URL для просмотра;
  • URL для загрузки.


Загрузить новую версию в Диск
154 / 401

Загружает новую версию документа на Диск.

Описание параметров

Файл Диска - файл на диске, который будет обновлен;

Файл для загрузки - новая версия обновляемого файла на диске;

Загружать от имени - от чьего имени будет произведено обновление.


Создать папку в Диске
155 / 401

Действие создает папку в Диске.

Описание параметров

Где создать - где будет создана папка. Возможны следующие варианты:

  • Диск пользователя - в этом случае также указывается и пользователь, в диск которого будет загружаться файл;
  • Диск группы соцсети - файл будет загружен в диск указанной группы;
  • Общий диск - файл будет загружаться в выбранный общий диск;
  • Папка диска - необходимо указать папку, в которую будет загружен файл.

Название папки - как будет называться созданная папка;

Создатель папки - от чьего имени будет создана папка.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • ID папки Диска;
  • URL папки.


CRM
156 / 401
В группе собраны действия для работы с CRM.


Создание новой компании
157 / 401

Действие аналогично действиям в публичной части CRM по созданию новой компании.

Примечание: если при создании элемента появляются неописанные поля, то это заведенные на портале Пользовательские поля.


Создание нового контакта
158 / 401

Действие аналогично действиям в публичной части CRM по созданию нового контакта.

Примечание: если при создании элемента появляются неописанные поля, то это заведенные на портале Пользовательские поля.


Реклама Яндекс
159 / 401

Добавляет email и телефонные номера в рекламный сегмент Яндекс.Аудитории.

Важно! Роботы рекламы не настраиваются через дизайнер бизнес-процессов. Они настраиваются отдельно в CRM в разделе Автоматизация.


Сменить ответственного
160 / 401

Действие позволяет сменить ответственного за сущность, на которой был запущен бизнес-процесс.

Параметры действия

Новый ответственный - указывается новый ответственный за сущность.


Создать на основании
161 / 401

Действие позволяет создать новую сделку на основании лида.

Примечание: действие доступно только в бизнес-процессах лидов.

Параметры действия

Создать на основании - выбирается тип сущности, который будет создан на основании лида (пока что доступно только создание сделки).

Направление сделки - указывается направление создаваемой сделки.


Выбор данных crm
162 / 401

Действие позволяет получить значения полей некоторой сущности. Выбранные поля будут доступны в форме Вставки значения во вкладке Дополнительные результаты.

Параметры действия

ID сущности - уникальный идентификатор.

Тип сущности - для каких типов записей (Контакты, Лиды, Сделки, Компании) будет осуществляться выборка полей.

Выберите поля - укажите, какие из полей будут выбраны.

Версия для печати - укажите эту опцию, если вы хотите получить значения полей в форме, понятной человеку.


Задание
163 / 401

Действие создает дело для ответственного менеджера.

Примечание: действие доступно для Лидов и Сделок.

Параметры действия

Тема - название создаваемого дела.

Описание - подробная информация о содержании дела.

Ответственный - менеджер, отвечающий за создаваемое дело.

Важное дело - указать для дела повышенную важность. Важные дела в списке дел помечаются значком [image].

Автоматически завершать дело при переходе в другой статус - при выборе данной опции дело будет считаться завершенным, как только статус Лида/Сделки изменится.


Ожидание статуса лида
164 / 401

Действие приостанавливает выполнение бизнес-процесса, пока не будет достигнут указанный статус лида.

ID лида - идентификатор лида.

Статус - укажите статус, по достижении которого процесс продолжит свое выполнение.


Отправить SMS
165 / 401

Действие позволяет отправить SMS клиенту.

Примечание: действие доступно для Лидов и Сделок.

Параметры действия

Текст сообщения - что будет отправлено клиенту.

Провайдер - с помощью какого провайдера нужно отправить сообщение. Провайдера необходимо установить через Маркетпелейс.


Реклама Вконтакте
166 / 401

Добавляет e-mail и телефонные номера в рекламную аудиторию Вконтакте.

Важно! Роботы рекламы не настраиваются через дизайнер бизнес-процессов. Они настраиваются отдельно в CRM в разделе Автоматизация.


Реклама Google AdWords
167 / 401

Добавляет e-mail и телефонные номера в рекламную аудиторию Google AdWords.

Важно! Роботы рекламы не настраиваются через дизайнер бизнес-процессов. Они настраиваются отдельно в CRM в разделе Автоматизация.


Реклама Facebook
168 / 401

Добавляет e-mail и телефонные номера в рекламную аудиторию Facebook.

Важно! Роботы рекламы не настраиваются через дизайнер бизнес-процессов. Они настраиваются отдельно в CRM в разделе Автоматизация.


Отправить письмо
169 / 401

Действие позволяет отправить письмо клиенту.

Параметры действия

Тема - тема письма.

Текст письма - текст письма.


Запланировать звонок
170 / 401

Действие позволяет запланировать звонок клиенту.

Описание параметров

Тема - название события.

Дата начала - дата и время начала звонка.

Дата завершения - дата и время завершения звонка.

Описание - детальное описание назначения звонка.

Напомнить за - количество единиц времени, за которое будет выслано уведомление.

Интервал напоминания - выбор единиц времени.

Ответственный - сотрудник, ответственный за звонок клиенту.

Важное дело - указать высокую важность события.


Запланировать встречу
171 / 401

Действие позволяет запланировать встречу с клиентом.

Описание параметров

Тема встречи - название события.

Дата начала - дата и время начала встречи.

Дата завершения - дата и время завершения встречи.

Описание - детальное описание создаваемой встречи.

Место - место проведения встречи.

Напомнить за - количество единиц времени, за которое будет выслано уведомление.

Интервал напоминания - выбор единиц времени.

Ответственный - сотрудник, ответственный за встречу с клиентом.

Важное дело - указать высокую важность события.


Создание новой сделки
172 / 401

Действие аналогично действиям в публичной части CRM по созданию новой сделки.

Примечание: если при создании элемента появляются неописанные поля, то это заведенные на портале Пользовательские поля.


Сменить статус
173 / 401

Действие позволяет сменить статус лида или сделки и немедленно прервать исполнение процесса.

Параметры действия

Изменить на статус - какой статус для записи нужно установить.


Создание нового лида
174 / 401

Действие аналогично действиям в публичной части CRM по созданию нового лида.

Примечание: если при создании элемента появляются неописанные поля, то это заведенные на портале Пользовательские поля.


Запись события в crm
175 / 401

Действие позволяет создать запись события в CRM.

Действие выполняется только в контексте бизнес-процессов, работающих в CRM.


Ожидание стадии сделки
176 / 401

Действие приостанавливает выполнение бизнес-процесса пока не будет достигнута указанная стадия сделки.

Описание параметров

ID сделки - ID сделки. Для удобства можно использовать Форму вставки значения.

Стадия - нужно указать стадию, по достижении которой процесс продолжит свое выполнение.

Действие выполняется только в контексте бизнес-процессов, работающих в CRM.

См. также:

  • Пример использования действия "Ожидание стадии сделки"


Прочее
177 / 401

В группе собраны все остальные команды.


Пауза в выполнении
178 / 401

Действие позволяет отложить выполнение следующего действия на заданное время.

Описание Параметров

Режим:

  • Промежуток - указывается промежуток времени, через который продолжится выполнение бизнес-процесса;
  • Время - указывается конкретное время возобновления бизнес-процесса.

Примечание: Если в режиме Время, на момент выполнения действия, указанная дата имеет место в прошлом (например был указан прошлый год, а действие начало выполняться в текущем), то будет произведен автоматический переход к следующему за "паузой в выполнении" действию. Другими словами процесс "перескочит" через него.


Блок действий
179 / 401

Блок действий предназначен для группировки набора действий в один блок, который можно свернуть для экономии места.

Обратите внимание на это действие. Оно позволяет существенно сэкономить трудозатраты на типовых блоках действий при создании шаблона бизнес-процесса. Однажды созданный и настроенный блок действий можно сохранить в группе Мои действия и многократно использовать.


Выбор сотрудника
180 / 401

Действие позволяет в автоматическом режиме выбрать сотрудника для дальнейшего использования его в процессе.

Примечание: Действие определяет отсутствие сотрудника согласно записям, которые отображаются на странице График отсутствий.

Описание Параметров

Тип:

  • случайный - выбор обычного сотрудника случайным образом;
  • начальник - выбор начальника для указанного сотрудника.

Из пользователей - указываются пользователи или группы, из которых будет выбран один сотрудник.

Для пользователя - указывается пользователь, для которого будет выбран начальник.

Уровень начальника (чем больше, тем выше уровень) - выбирается уровень начальника для указанного пользователя.

Резервные пользователи - Указываются пользователи, которые будут выбраны в случае невозможности выбора из основных пользователей, указанных выше. Например, если указанная в поле Из пользователей группа не содержит сотрудников, то будет выбран кто-то из резервных пользователей.

Пропускать отсутствующих - позволяет автоматически пропускать отсутствующих сотрудников, например, если они в отпуске.

Пропускать с завершенным рабочим днем - позволяет автоматически пропускать сотрудников, завершивших рабочий день.

Если невозможно выбрать основного начальника, например, в случае отпуска, и опция Пропускать отсутствующих равна Да, то действие автоматически продолжит выбирать начальника, но уже более высокого уровня. Если будет недоступен и начальник самого верхнего уровня, то выбор будет производиться уже из сотрудников, указанных в поле Резервные пользователи.

Если опция Пропускать отсутствующих равна Нет, то действие завершится и, независимо от отсутствия, будет выбран начальник соответствующего уровня.

Если все начальники будут недоступны или у сотрудника нет начальника, то действие вернет пустое значение.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • Выбранный сотрудник.


Создание группы
181 / 401

Действие позволяет создать рабочую группу.

Описание параметров

Название группы - необходимо указать название создаваемой группы.

Владелец группы - необходимо выбрать пользователя, который будет владельцем группы. Важно то, что у группы может быть только один Владелец.

Участники группы - необходимо выбрать участников группы. Можно выбрать как отдельных пользователей, так отделы и членов другой рабочей группы.


WebHook
182 / 401

Действие позволяет добавить WebHook.

Параметры действия

Хендлер - URL, который нужно использовать при отправке данных из Битрикс24.


Запись в отчет
183 / 401

Действие позволяет добавлять в отчет и лог, соответственно, произвольные записи.

Запись в отчет удобно использовать, например, во время отладки бизнес-процесса, сохраняя в отчет данные на нужном этапе.

Описание Параметров

Загрузить отчет для доступа из бизнес-процесса - позволяет получить содержимое всего отчета в рамках бизнес-процесса для дальнейших действий (например, отправить по почте) используя форму Вставка значения, секция Дополнительные результаты. В противном случае данные отчета нельзя будет получить в рамках бизнес-процесса и просмотреть возможно будет только в логе.

Опцию Загрузить отчет для доступа из бизнес-процесса логично использовать на этапе завершения бизнес-процесса для формирования конечного отчета без лишних запросов к базе.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • Отчет;

В секции Дополнительные результаты на каждую запись в отчет будет создана своя переменная, и если для действия была отмечена опция Загрузить отчет для доступа из бизнес-процесса, то с её помощью можно будет получить отчет, который уже был сформирован на этапе этого действия. Отчет каждого последующего действия будет включать отчет предыдущих действий. Если опция не была отмечена, то переменная будет пустой.


Изменение переменных
184 / 401

Действие позволяет изменить значения переменных, заданных в настройках шаблона .

Описание Параметров

В выпадающих списках выбираются переменные и устанавливаются для них необходимые значения.


Установка прав
185 / 401

Действие позволяет устанавливать права на доступ к документу.

Описание Параметров

Право на операцию "..." имеют - установка права документа для указанных пользователей/групп пользователей.

Примечание: Для разных типов документов существуют разные типы прав.

Перезаписать - позволяет не добавлять права, а производить их замену. В данном случае производится работа только с правами, которые устанавливаются внутри бизнес-процесса.

Если для документа используется упрощенная (старая) версия прав, то они устанавливаются жестко извне (настройки доступа к инфоблокам/спискам/и.т.д.). Единственный вариант, позволяющий устанавливать права прямо из бизнес-процесса - это установка для документа права бизнес-процессы извне. В этом случае с помощью закладки Доступ или действия Установка прав можно менять права по ходу выполнения процесса.

Если используются расширенные права доступа, то из бизнес-процесса можно только добавлять новые права на документ, которые будут оставаться у документа даже после выполнения процесса. Переопределить права, которые были установлены извне, внутри бизнес-процесса нельзя.

Важно! С версии 15.5.0 Дизайнера бизнес-процессов данное действие исключено для модулей Диск и CRM.


Прерывание процесса
186 / 401

Действие позволяет прекратить выполнение бизнес-процесса.

Важно! Продолжить выполнение процесса с того места, где он был прерван нельзя. Для выполнения всех последующий после прерывания операций придется запускать бизнес-процесс заново.

Описание параметров:

Текст статуса - устанавливает текст статуса действия.


Мои действия
187 / 401

Мои действия позволяют сохранять настроенные действия/конструкции и использовать их повторно.

Также этот блок удобно использовать для копирования действий внутри шаблона бизнес-процесса. Достаточно перетянуть в него нужные действия, после чего их можно будет многократно использовать, перетянув обратно в рабочую область дизайнера бизнес-процессов.

Действия, добавленные в этот блок, сохраняются вместе с шаблоном и могут быть потом повторно использованы при последующем редактировании.

Ссылки по теме:
  • Создание собственных действий


Примеры работы с действиями
188 / 401


Пример использования цикла для утверждения документа
189 / 401

Документ будет проходить процедуру утверждения до тех пор, пока он не будет исправлен и одобрен начальством. В случае не утверждения будет запрошена дополнительная информация, после чего он будет опять направлен на утверждение.

Пример достаточно упрощен, и описание будет касаться только работы конструкции Цикл.

Примечание: В данном примере цикл будет использовать тип условия - Поле документа.

Порядок действий:

  • Первым делом добавим действие Изменение документа

    В его параметрах, с помощью ссылки Добавить поле создадим для документа дополнительное поле типа список с названием Результат утверждения. Укажем 2 варианта значений поля с новой строки: на рассмотрении и утвержден.

    Именно по значению этого поля и будет приниматься решение - выходить из цикла или нет.

    Затем в параметрах действия Изменение документа выберем созданное поле Результат утверждения и установим для него значение равное на рассмотрении.

  • Добавим действие Цикл

    В параметрах укажем следующее: тип условия - поле документа; условие - равно; значение - на рассмотрении.

  • В цикле добавим действие Утверждение документа:
    • В ветку Да добавляем действие Изменение документа, в параметрах которого для поля Результат утверждения выбираем значение утвержден. Этим самым мы заставим процесс больше не входить в цикл.
    • После этого действия можно поставить требуемые действия.

      Примечание: В процессе изучения работы конструкции Цикл можно на этом этапе использовать действие Запись в отчет. Это позволит в журнале отследить, какое именно решение было принято и как цикл продолжил свою работу дальше.

    • В ветку Нет добавляем действие Запрос дополнительной информации. Оно будет использоваться, например, для указания информации о правках старой версии документа или каких-либо еще замечаний связанных с повторным рассмотрением документа.
    • После этого добавляем действие Изменение документа, в параметрах которого для поля Результат утверждения выбираем значение на рассмотрении. Этим самым мы заставим процесс повторно войти в цикл. Также в этом действии мы обновим значения полей документа на значения, полученные из предыдущего действия, тем самым отправив на рассмотрение уже измененный документ.
    • При необходимости укажем в этой ветке тоже дополнительные действия.

      Примечание: В процессе изучения работы конструкции Цикл можно на этом этапе использовать действие Запись в отчет. Это позволит в журнале отследить, какое именно решение было принято и как цикл продолжил свою работу дальше.

  • После конструкции Цикл установим действие, которое будет оповещать нас о том, что цикл завершил свою работу (документ может постоянно отклоняться и соответственно выхода из цикла не будет). В качестве оповещения выберем, например, действие Установить текст статуса или же Почтовое сообщение.


Пример работы с переменными и дополнительными результатами действий
190 / 401

Рассмотрим пример создания простого шаблона последовательного бизнес-процесса, в котором у пользователя будет запрошена дополнительная информация, и затем она будет использована для записи в отчет и установку статуса документа.

Порядок действий:

  • Добавим действие Запрос дополнительной информации
  • Перейдем к форме настройки параметров действия, заполним обязательные поля и добавим новые поля с помощью соответствующей ссылки:
    • Дата начала, тип Дата/Время;

    • Количество, тип Число;

    • Согласованно?, тип Список.

    Примечание: В рамках действия мы создаем поля, которые будут отображены пользователю. Заполняя эти поля, пользователь задает нужные значения переменных.

    Изменить поля можно в параметрах действия или же воспользовавшись кнопкой Параметры шаблона на контекстной панели дизайнера бизнес-процессов:

  • Добавим действие Запись в отчет. Вызовем окно настроек действия и, используя форма Вставка значений, вставим в поле Текст заданные выше переменные (группа Переменные) и комментария (группа Дополнительные параметры)

    В результате должно получиться следующее:

  • Добавим действие Установить текст статуса, в котором укажем следующее:

  • Запустим бизнес-процесс на исполнение и введем требуемые данные.

  • Во вкладке Мои процессы можно посмотреть статус завершенного бизнес-процесса:

  • Перейдем к просмотру журнала исполнения процесса, там будет отображена запись, содержащая значения переменных:


Пример использования действия "Выбор сотрудника"
191 / 401

Рассмотрим небольшой пример использования действия Выбор сотрудника.

В нашем случае оно будет использоваться для выбора начальника, который в дальнейшем должен утвердить документ.

Если непосредственный начальник находится в отпуске, то будет выбран вышестоящий начальник и так далее. Когда действие, таким образом, дойдет до генерального директора, или начальник не будет вообще выбран (в случае отсутствия всего начальства), то утверждающим документ будет назначен заместитель начальника.

  • Создадим новый шаблон, а в нем 2 переменные типа Пользователь:

    • Начальник, которая будет меняться по ходу процесса;
    • Заместитель, которая будет практически постоянной, и меняться должна вручную в случае ухода в отпуск заместителя.
      Укажем для нее по умолчанию сотрудника, который будет отвечать за утверждение документа в случае отсутствия начальства.

  • Первым добавим действие Выбор сотрудника.

    В параметрах укажем, что будет производиться выбор непосредственного начальника для Автора с пропуском отсутствующих:

  • Добавим действие Изменение переменной.

    В параметрах укажем, что значение переменной Начальник будет равно сотруднику, который был выбран действием Выбор сотрудника (форма Вставка значения - Дополнительные результаты - Выбор сотрудника - Выбранный сотрудник):

  • Добавим конструкцию Условие и создадим в ней 3 ветви. Нумерация условий в действии будет такой же, как и порядок их выполнения действием: слева на право.
    1. В первой ветке определим условие, при котором в случае выбора генерального директора ответственным бы назначался заместитель.

      Для этого в самом условии укажем генерального директора:

      а после добавим действие Изменение переменной, в котором укажем, что значение переменной Начальник будет равно значению переменной Заместитель:

    2. Во второй ветке определим условие, при котором заместитель будет утверждать документ, в случае отсутствия всего начальства.

      Для этого в самом условии укажем, что значение переменной Начальник должно быть пустым:

      Примечание: Это связанно с особенностью работы действия Выбор сотрудника, которое возвращает пустое значение выбранного сотрудника, если ни один начальник не был выбран (например, все начальство отсутствует).

      Затем добавим действие Изменение переменной, которое настраивается аналогичным образом, как и в предыдущей ветке.

      После, например, для заместителя добавим уведомление о том, что все начальство отсутствует.

    3. В последней ветке условия мы не будем менять сотрудников, в результате у нас значение переменной Начальник останется равно результату работы действия Выбор сотрудника.

В результате спроектированный шаблон должен выглядеть следующим образом:


Ручной переход по действиям процесса с помощью "Ознакомления с документом"
192 / 401
В ряде случаев может быть полезным, в целях обучения пользователей работе с созданным бизнес-процессом, включить в шаблон, на первое время, ручной переход от задания к заданию. То есть с помощью, например, действия Ознакомление с документом создать обязательный шаг ручного переключения бизнес-процесса следующему исполнителю.

В публичной части это будет выглядеть так:

Маленький минус использования этого действия в том, что ссылку Перейти к документу удалить нельзя.


Пример использования действия "Ожидание стадии сделки"
193 / 401

Вопрос с форума: Добрый день! Подскажите, есть ли возможность воплотить в битриксе следующую задумку. Создаем бизнес-процесс, который будет запускаться при изменении стадии сделки на, например, "составление договора" и будет выходить список какой договор составить: 1. договор №1; 2. договор №2, и т.д., далее при кликании на нужный вид договора, запускался конструктор документов. На практике я сделала бизнес процесс, который запускает конструктор документов при изменении стадии сделки, но в нашей организации разные договоры для разных видов деятельности, поэтому как можно сделать выбор в рамках бизнес-процесса? или это нельзя сделать автоматически при изменении стадии сделки?

Бизнес-процессы автоматически запускаются либо при создании элемента, либо при любом его изменении. Поэтому настроить бизнес-процесс на автозапуск при изменении какого-то определенного поля, в том числе и стадии сделки, нельзя. Но данную задачу можно решить с помощью действия Ожидание стадии сделки.

Это действие мы поставим первым в шаблоне. Таким образом, бизнес-процесс будет запущен при создании элемента, но выполняться действия начнут только при достижении сделкой определенной стадии. Если по какой-либо причине сделка не достигнет этой стадии, то последующие действия не будут выполняться.

Чтобы выбрать необходимый тип документа, будем использовать действие Запрос дополнительной информации. Для этого создадим в нем переменную типа Список.

В зависимости от выбранного типа будет создаваться соответствующий документ. Выбор будет осуществляться с помощью действия Условия. Настроить значения полей создаваемого документа можно с помощью Формы "Вставка значения". Полученный бизнес-процесс выглядит следующим образом.


Пример использования действия "Утверждение документа"
194 / 401

Действие Утверждение документа можно использовать для автоматизации процесса распределения работ. Например, у нас стоит следующая задача:

Необходимо уведомить несколько сотрудников о наличии работы, которую нужно выполнить. Работа будет назначена первому сотруднику, который возьмется за ее выполнение. Как только кто-то один берет на себя эту работу другим она уже не предлагается. В случае, если никто не согласился, то процесс повторяется.

Шаблон полученного процесса выглядит следующим образом:

Порядок действий:

  • В данном шаблоне будет использоваться Цикл. Т.к. голосование будет повторяться до тех пор, пока кто-либо из сотрудников не возьмет на себя работу.
  • Остановимся на настройках действия Утверждение документа подробнее:

    В поле Утверждают сотрудники укажем тех сотрудников, которым будет выслано уведомление.

    Тип утверждения - выберем Голосование сотрудников. Можно было бы воспользоваться стандартной функцией и в данном поле указать Любой. Но это будет крайне непрактично т.к. в нашем примере используется цикл, который будет вновь и вновь запрашивать действие сотрудника, если тот не утвердит документ. Поэтому сначала надо дать возможность принять решение всем сотрудникам, после чего при необходимости повторить утверждение.

    Более скольки процентов голосов необходимо для принятия решения - в данном поле укажем 0. Поэтому как только любой пользователь из указанных утвердит документ, а в нашем случае согласится взять на себя работу, то голосование прекратится.

    Ожидать, чтобы проголосовали все указанные сотрудники - укажем Да, таким образом, цикл голосования может повториться только после того, как все проголосуют.

  • После того, как сотрудник утвердил документ, ему будет ставиться Задача. Сотрудника, утвердившего документ, можно указать используя Дополнительные результаты предыдущего действия с помощью формы Вставка значения.

  • Действие Изменение переменной используется только для того, чтобы контролировать выход из цикла.


Распространенные ошибки при работе с бизнес-процессами
195 / 401

Бизнес процессы - важнейший инструмент, который позволяет автоматизировать рабочие процессы компании. Однако их использование требует определенного навыка и осторожности. В противном случае бизнес-процессы могут создать значительную нагрузку на проект.

На каждом физическом сервере в Битрикс24 одновременно работает несколько порталов, и аномальная нагрузка от одного из них негативно влияет на остальные. Одной из причин аномальной нагрузки могут стать бизнес-процессы.

Для предотвращения подобных ситуаций были введены технические ограничения количества запущенных экземпляров бизнес процесса на одном документе - не более двух. Это означает, что всего одновременно работающих экземпляров бизнес-процессов может быть много, но на каждый конкретный документ - не более двух.

В связи с этим, рекомендуется проверить и скорректировать свои бизнес-процессы. В противном случае, при выявление аномальной нагрузки создаваемой бизнес-процессами, портал может быть заблокирован согласно пункту 8.1 лицензионного соглашения.

Рассмотрим наиболее распространенные ошибки при проектирование бизнес-процессов, которые могут увеличить нагрузку на портал:

  1. Изменения различных полей документа несколькими действиями — достаточно часто встречающая ошибка. Конечно, можно изменять каждое поле документа отдельным действием, однако это значительно увеличивает количество выполняемых запросов при работе бизнес-процесса.

    Рекомендуется изменять все необходимые поля документа в рамках одного действия.

  2. Зацикливание — необходимо тщательно проверять отсутствие зацикливания бизнес-процессов, особенно если используются паузы. В этом случае бизнес процесс не зависнет во время выполнения и ошибку можно не заметить. Но в случае запуска бизнес-процесса на создание документа с ошибкой в условии выхода из цикла, постепенно накопится большое количество экземпляров бизнес-процесса, запущенных для разных документов. Еще более опасный вариант, когда это случается для бизнес-процессов на изменение документа. В этом случае можно быстро накопить большое количество работающих экземпляров бизнес-процесса даже на небольшом количестве документов.

    В некоторых случаях необходимо предусматривать отдельное условие прекращения выполнения циклов, которое обеспечит выход из него, даже если основное условие по каким-либо причинам не было выполнено за разумное время/циклы. Например, на рисунке ниже бизнес-процесс прекращается после того как время обработки лида становится больше 1000 минут, несмотря на то, что статус лида еще не изменился на нужный. Это позволяет останавливать бизнес-процесс, если он не был обработан в рамках разумного времени, например, по причине увольнения ответственного.

  3. Использование проверки статуса в цикле с паузой — бывает, что вместо действия Ожидание стадии сделки используется цикл с паузой. В этом случае при запуске процесса на создание документа, накапливается большое число запущенных экземпляров шаблона бизнес-процесса, для разных документов. При постоянном частом подъеме из паузы они создают нагрузку и в определенный момент могут привести к неработоспособности проекта.

    Правильнее в данном случае использовать действие Ожидание стадии сделки. В этом случае бизнес-процесс проснется только во время смены статуса документа на нужный и не будет создавать нагрузку все остальное время.

  4. Некорректное использование пауз и заданий — данная ошибка случается часто для бизнес-процессов, которые запускаются при изменении документа.

    Использование данных действий может нарушить идеологию и целостность бизнес-процесса, ведь, пока бизнес-процесс будет ожидать их исполнения, исходный документ может быть снова изменен. Поэтому бизнес-процессы, запускаемые на изменение, должны отрабатывать без каких-либо ожиданий и пауз и прекращать свое существование. Если же в бизнес-процессе, запускаемом на изменение, есть паузы, ожидание действий, запрос информации, то можно смело говорить, что бизнес-процесс работает неправильно.

  5. Ошибки при работе с Параллельным ожидания действия – очень часто возникают сложности при работе с этой конструкцией. При ее использовании процесс будет выполняться по той ветке, которая следует за первой выполненной Командой. Но если ни одна из команд не выполнена, то и процесс зависнет и исполняться дальше не будет. Чтобы такого не происходило, всегда стоит добавлять ветку, содержащую Паузу в выполнении. Таким образом, бизнес-процесс продолжит свое исполнение по истечению указанного в нем времени, даже если ни одна из команд не будет выполнена.

    6. © «Битрикс», 2001-2008, «1C-Битрикс», 2008-2017 1С-Битрикс


Каталог примеров
196 / 401

В главе приведены примеры использования бизнес-процессов.

Посмотреть примеры работ с отдельными действиями можно в разделе Примеры работы с действиями.

Внимание! Обязательно производите сверку и настройку под себя импортируемых шаблонов бизнес-процессов.


Пример использования бизнес-процессов и списков
197 / 401

В данном уроке будет рассмотрен пример создания сервиса сбора и размещения заявок на закупку согласно ТЗ на портале.

ТЗ по размещению заявок на закупку на портале
  1. Общие требования к функционалу
    1. Требуется создать область для размещения, обработки и хранения заявок на закупку. Заявка на закупку представляет собой карточку, состоящую из набора именованных полей определенного типа. Заявка на закупку также может содержать неограниченное количество файлов (а может и не содержать ни одного).
    2. Любой пользователь (входящий в определенную группу доступа) может создать заявку на закупку. Данный пользователь в дальнейшем рассматривается как автор заявки.
    3. В дальнейшем, никакой программной обработки заявок не производится.
  2. Требования к работе с данными
    1. Заявка состоит из следующих полей (символом ‘*’ отмечены поля, обязательные к заполнению):
      1. Тип закупки* (выбор из списка: «менее 100.000 руб», «100.000 руб и более»)
      2. Предмет закупки* (строка)
      3. Стоимость, руб (целое число)
      4. Обоснование* (многострочное поле)
      5. Выбранный поставщик* (строка)
      6. Потенциальные поставщики* (многострочное поле)
      7. Статус закупки* (выбор из списка: «на согласовании», «одобрена», «отклонена»).
      8. Инициатор* (автор заявки)
        Желательно, чтобы это поле заполнялось автоматически при вводе заявки.
      9. Непосредственный руководитель* (выбор из списка пользователей)
        Желательно, чтобы это поле заполнялось автоматически при вводе заявки.
      10. Бюджетный контролер* (выбор из списка пользователей)
        Желательно, чтобы выбор производился из ограниченного списка пользователей
      11. Юрист* (выбор из списка пользователей)
        Желательно, чтобы выбор производился из ограниченного списка пользователей
      12. Главный бухгалтер* (выбор из списка пользователей)
        Желательно, чтобы это поле заполнялось автоматически при вводе заявки.
      13. Финансовый директор* (выбор из списка пользователей)
        Желательно, чтобы это поле заполнялось автоматически при вводе заявки.
    2. Пользователи должны иметь возможность редактировать свои (и, в отдельных случаях, чужие) заявки. При этом в системе должны сохраняться: дата и время создания, дата и время изменения, автор и автор последнего изменения.
    3. Любой пользователь (п 1.2) должен иметь доступ к списку заявок, автором которых он является. Доступ к списку заявок, созданных другими пользователями, должен быть предоставлен только пользователям – членам определенной группы (как на чтение, так и на редактирование). Допускается разделение доступа на уровне интерфейса
    4. Область просмотра заявок должна представлять собой таблицу. Колонки таблицы соответствуют полям заявки.
      1. В рамках области просмотра должны быть представлены следующие поля (в указанном порядке)
        • Дата создания
        • Тип закупки
        • Предмет закупки
        • Стоимость, руб
        • Инициатор
        • Выбранный поставщик
      2. В таблице должна быть представлена группировка/сортировка по статусу закупки.
      3. Интерфейс должен предоставлять фильтрацию по значению полей заявок (как минимум: выбор значения фильтра из списка возможных значений), по любому полю, если его тип отличен от «многострочный текст».
      4. Дополнительные требования (желательно). Пользователь с правами конфигуратора системы должен иметь возможность (не прибегая к средствами разработки PHP):
        • Создавать другие представления данных, подходящие под описание п. 2.4, с произвольным набором полей, сортировок, группировок, фильтров.
        • Проводить массовые операции с заявками (например – удаление всех заявок, отвечающих критериям определенного фильтра).
        • Создавать новые типы закупки и настраивать доступность полей в зависимости от типа.
        • Редактировать состав полей заявки.
  3. Прочие требования
    1. Необходимо предусмотреть функционал оповещений – пользователи, входящие в определенную группу, должны получать оповещения внесении любых изменений в какую-либо заявку. Оповещение должно содержать значения всех полей заявки.
    2. В качестве групп пользователей, упомянутых в данных требованиях, должна быть возможность использовать ранее созданные группы портала (которые используются для предоставления доступа к другим ресурсам).

Согласно условиям ТЗ наиболее подходящим под задачу функционалом будут штатные списки.

Перед прочтением урока желательно ознакомиться с работой и особенностью универсальных списков, которые располагаются в разделе левого меню Компания.


Подготовка списка и его настройка
198 / 401

Подготовка списка и его настройка

  • Создадим новый список с поддержкой бизнес-процессов:

    и произведем настройку подписей.

    В данном примере мы не будем использовать разделы, поэтому их не переименовываем.

  • Добавим требуемые поля согласно ТЗ (Настройки списка > Поля списка > Добавить поле). Не забудем отметить нужные поля, как обязательные к заполнению.

    Пример настройки поля типа список:

    В обязательных полях, которые будут заполняться автоматически, установим в поле Значение по умолчанию текст-пояснение:

    Примечание: Такими полями будут Инициатор, Непосредственный руководитель, Главный бухгалтер, Финансовый директор.

    Пример настройки поля с автоматическим значением по умолчанию, равному дате и времени создания заявки:

    ТЗ не требует выбора пользователей системы, поэтому укажем требуемых сотрудников текстом с использованием поля типа список:

    Примечание: Такими полями будут Бюджетный контролер, Юрист.

    В результате создания полей, согласно ТЗ, получится следующее:

Теперь форма создания новой заявки будет иметь следующий вид:


Настройка внешнего вида и доступа для списка
199 / 401

Настройка внешнего вида списка и фильтра

  • Настроим внешний вид списка согласно ТЗ:

  • Настроим фильтр:

Настройка прав доступа к списку

Перейдем опять к настройке списка на закладку Доступ и укажем права доступа следующим образом:

  • чтобы только сотрудники требуемой группы смогли добавлять заявки

    Bitrix24: Все сотрудники отдела с подотделами - Добавление

  • право на просмотр и изменение своих заявок будет у автора (причем в этом случае разные авторы смогут видеть и редактировать только свои заявки)

    Автор - Изменение

  • читать и изменять любые заявки сможет сотрудник, ответственный за сервис

    Ответственный сотрудник - Изменение

В результате получим следующее:


Создание бизнес-процессов
200 / 401

Для работы с заявками мы создадим 2 шаблона последовательных бизнес процессов. Один будет запускаться при создании заявки, а второй - при ее изменении.

БП для создания заявки на закупку

Произведем настройку параметров шаблона:

  • на вкладке Основное укажем название и отметим опцию автоматически запускать при добавлении:

  • На вкладке Переменные создадим новые обязательные переменные типа Привязка к сотруднику, в которых явно зададим 3 неизменных на момент создания заявки сотрудников: Главный бухгалтер, Финансовый директор, Проверяющий (сотрудник ответственный за сервис заявок).

    Эти сотрудники в ходе процесса будут автоматически подставляться в карточку заявок.

    Внимание! В случае ухода в отпуск или смены сотрудника необходимо будет произвести в этих полях соответствующие изменения.

    Примечание: Вынесение сотрудников в переменные позволит централизованно произвести их замену сразу по всему шаблону.

  • Также создадим еще пару переменных типа Привязка к сотруднику для дальнейшей автоматизации, но уже без явного указания обязательности и значения по умолчанию: Инициатор, Непосредственный руководитель.

В результате получим следующее:

Перейдем к непосредственному созданию шаблона бизнес-процесса:

  • В основную область конструктора бизнес-процессов добавим действие Выбор сотрудника для вычисления начальника для автора, чтоб в будущем записать его имя в заявку автоматически.

  • Добавим действие Изменение документа, которое будет записывать нужные поля в карточке заявки.
    • Для поля документа Статус закупки выберем на согласовании. Это поможет избежать ошибки, если сотрудник при заполнении заявки укажет иной статус.
    • Для поля документа Инициатор с помощью формы Вставка значения в секции Пользователи выберем Автор.
    • Для поля документа Непосредственный руководитель с помощью формы Вставка значения в секции Дополнительные результаты выберем результат Выбранный сотрудник действия Выбор начальника:

    • Для полей Главный бухгалтер и Финансовый директор с помощью формы Вставка значения укажем соответствующие им переменные.

    В результате получим следующее:

    После выполнения этого действия в заявку будут автоматически внесены требуемые пользователи и статус, не зависимо от того, что было указано при ее заполнении.

  • Добавим действие Сообщение соц.сети, которое будет отправлять уведомление сотруднику, ответственному за сервис заявок о том, что создана новая заявка. Также в сообщении будут указаны значения всех полей заявки.

В итоге получим следующую схему шаблона бизнес-процесса:

БП для изменения заявки на закупку

Произведем настройку параметров шаблона:

  • На вкладке Основное укажем название и отметим опцию автоматически запускать при изменении:

  • На вкладке Переменные создадим новую обязательную переменную типа Привязка к сотруднику, в которой явно зададим Проверяющего (сотрудника ответственного за сервис заявок).

Перейдем к непосредственному созданию шаблона бизнес-процесса:

  • В основную область конструктора бизнес-процессов добавим действие Сообщение соц.сети, которое будет отправлять уведомление сотруднику, ответственному за сервис заявок о том, что заявка изменена. Также в сообщении будут указаны новые значения всех полей заявки.

  • Добавим конструкцию Условие и создадим 3 условия: Одобрена, На согласовании, Отклонена. Это позволит отправлять автору разные сообщения о статусе его заявки.
  • Настроим условие Одобрена. Для этого в поле Поле документа укажем, что условие будет выполняться, если статус закупки будет равен одобрена.

  • Аналогичным образом настроим условия для оставшихся вариантов статуса закупки.

    • Добавим действие Сообщение соц.сети в ветки условий Одобрена и Отклонена. Тем самом мы будем оповещать автора о том, что заявка на закупку после ее изменения перешла в эти статусы.

  • Произведем настройку действия Сообщение соц.сети для ветки условия Одобрена:

  • Аналогичным образом произведем настройку действия и для ветки условия Отклонена, изменив лишь часть текста сообщения.

В итоге получим следующую схему шаблона бизнес-процесса:


Пример бизнес-процесса со статусами по созданию счета для клиента в CRM
201 / 401

Рассмотрим пример бизнес-процесса со статусами по созданию счета для клиента в CRM согласно ТЗ.

ТЗ по созданию счета для клиента на портале

  1. Менеджер по продажам начинает бизнес-процесс и заполняет поля:

    • Название сделки,
    • Менеджер по продажам,
    • Менеджер по закупкам,
    • Клиент (название),
    • Сумма сделки,
    • Адрес доставки.

  2. Менеджер по закупкам продолжает процесс и заполняет поля:

    • Поставщик (название),
    • Поставщик (контактное лицо),
    • Сумма закупки,
    • Срок поставки от поставщика,
    • Вес отправления,
    • Объем отправления,
    • Адрес отгрузки,
    • Счет от поставщика, опционально (номер и вложение),
    • Договор от поставщика, опционально (номер и вложение).
  3. Менеджер по продажам изучает ответ от менеджера по закупкам.

    Выставление срока поставки для клиента. Сверяются сроки поставки, если срок поставки до клиента равен или > срок поставки до поставщика +5 дней, процесс продолжается, иначе открывается поле комментирования сроков поставки, комментарии обязателен. Заполняются следующие поля:

    • Срок поставки до клиента.

  4. Юрист изучает договор вложенный менеджером по закупке (в случае его наличия) и создает договор для клиента. Заполняются следующие поля:

    • Договор для клиента (номер и вложение),
    • Договор от поставщика, опционально (номер и вложение).

  5. Процесс переходит менеджеру по продажам, согласование договора. Заполняются следующие поля:

    • Договор для клиента (номер и вложение).

  6. Процесс переходит менеджеру по закупкам, согласование договора. Заполняются следующие поля:

    • Договор для клиента (номер и вложение).

  7. Процесс переходит в бухгалтерию — создание и прикрепление счета для клиента. Заполняются следующие поля:

    • Счет для клиента (номер и вложение).
  8. Процесс переходит помощнику руководителя, который должен иметь возможность получить для печати всех документов сделки.

    После печати обязательно добавление сканов договора и счета для клиента с подписью и печатью, после этого скнаны сохраняются, процесс возвращается менеджеру по продажам вместе со сканами счетов и договора.

    • Счет для клиента (номер и вложение),
    • Договор для клиента (номер и вложение).

Примечание: Данный пример подразумевает, что составитель бизнес-процесса знаком с CRM и бизнес-процессами со статусами.

Шаблон для ознакомления: Скачать


Настройки CRM
202 / 401

Прежде всего, необходимо произвести настройки в самой CRM. Они будут состоять из нескольких этапов:

  • Создание и настройка пользовательских полей
  • Настройка прав доступа
  • Настройка формы создания сделки
    •

    Создание и настройка пользовательских полей

    В качестве основы будем использовать такую сущность CRM, как Сделка. Поэтому первым делом мы создадим и настроим пользовательские поля для карточки сделки согласно ТЗ (CRM > Настройки > Пользовательские поля > Сделка > Список полей).

    Значения по умолчанию для полей устанавливать не будем. Все необходимое будет заполнено автоматически, по мере выполнения процесса.

    В итоге в форме будет всего 2 поля, которые требуют обязательного заполнения: Название (обязательно к заполнению всегда) и Адрес доставки. Остальные поля буду заполнены автоматически, а также посредством выполнения заданий разными участниками процесса.

    Настройка прав доступа

    Укажем пользователей/группы пользователей, которые будут иметь доступ к бизнес-процессам (менеджеры, юрист, бухгалтер и остальные, согласно ТЗ) на странице Права доступа (CRM > Настройки > Права)

    В нашем примере это будет группа Моя компания: Сотрудники, это позволит в дальнейшем, при создании шаблона бизнес-процесса, выбирать в нем любого сотрудника.

    Внимание! В описании далее и самом шаблоне-примере для всех участвующих в процессе сотрудников задан по умолчанию сотрудник с идентификатором 1. Это позволит сразу ознакомиться со всем процессом, не создавая и не настраивая других пользователей.

    Настройка формы создания сделки

    Перейдем к форме создания новой сделки (CRM > Сделки > Список сделок) и произведем ее настройку согласно ТЗ:

    В итоге должны получить следующий вид:


Создание бизнес-процесса
203 / 401

Создание бизнес-процесса тоже будет состоять из нескольких этапов:

  • Начальные настройки
  • Статусы шаблона
    •

    Создадим новый шаблон бизнес-процесса со статусами для сделки на странице CRM – Настройки - Бизнес-процессы.

    После чего перейдем к настройке его параметров.

    Начальные настройки

    • Укажем в параметрах шаблона, что процесс будет автоматически запускаться при добавлении новой сделки.
    • Создадим новые переменные типа Привязка к пользователю:
      • Менеджер по продажам (*),
      • Менеджер по закупкам (*),
      • Юрист (*),
      • Бухгалтер (*),
      • Логист (*),
      • Помощник руководителя (*).

      Для всех них по умолчанию укажем требуемых сотрудников (в нашем случае это пользователь с идентификатором 1).

      Эти переменные буду использоваться для автоматического внесения требуемых сотрудников в карточку сделки, а так же позволят заменять сразу по всему бизнес-процессу отсутствующих сотрудников, например, ушедшего в отпуск юриста.

    • Создадим переменную Адрес портала (*) типа Строка и укажем для нее значение по умолчанию, равное адресу портала.

      Например: http://myportal.com.

      Эта переменная в дальнейшем будет использоваться для формирования ссылок.

    В результате список переменных должен будет выглядеть следующим образом:

    Остальные переменные будут созданы по мере необходимости. Это будут переменные, в которых будут храниться значения полей действия Запрос дополнительной информации. Названия этих переменных пронумерованы, согласно этапу, на котором в них заносятся значения.

    Кроме этого будет использоваться переменная Флаг "Поля Пусты", про которую будет написано ниже.

    Статусы шаблона

    Начальный статус

    Подпроцесс первого статуса начинается с Блока действий.

    Он используется для группировки однотипных действий, которые будут проверять, указаны ли требуемые сотрудники в форме Сделка, а также будут автоматически записывать в пустые поля пользователей из переменных Менеджер по продажам (*), и.т.д. Это позволит автоматизировать заполнение формы, позволяя каждый раз не указывать всех необходимых сотрудников, которые, в большинстве случаем одни и те же.

    Проверка полей состоит в непосредственной проверке поля на то, что оно пустое, и дальнейшей записи в это поле сотрудника из переменной, которая была задана в начале создания шаблона бизнес-процесса (Менеджер по продажам (*), и.т.д.).

    Таким образом, если, например, Юрист в сделке тот же, что и всегда, то менеджеру не нужно будет заполнять это поле в форме сделки. Оно будет заполнено автоматически из бизнес-процесса. Если же Юрист должен отличаться от заданного по умолчанию, то менеджер вручную заполняет соответствующее поле, и тогда автоматической записи из переменной происходить не будет.

    Этап 1 - Менеджер по продажам

    Этап начинается с действий по проверке заполнения требуемых от менеджера по продажам полей. Если поле окажется пустым, то будет изменено значение специальной переменная Флаг "Поля пусты" на Да (в Параметрах шаблона по умолчанию значение этой переменной задается как Нет).

    После проверки полей идет условие, по которому, если значение переменной Флаг "Поля пусты" равно Да, то сначала значение этой переменной будет сброшено на Нет, а затем Менеджеру по продажам будет выставлено задание, в котором от него потребуется заполнить эти поля. После чего будет произведен опять переход на начало этапа.

    Если же поля окажутся заполнены, то значение переменной Флаг "Поля пусты" будет сброшено на Нет и процесс перейдет на следующий этап.

    Этап 2 - Менеджер по закупкам

    На этом этапе менеджеру будет выставляться задание по заполнению требуемых полей, согласно ТЗ. Для этого будет использоваться действия Запрос дополнительной информации и дополнительные поля (переменные), которые указываются прямо в этом действии. После выполнения задания, значения этих переменных будут сохранены в поля Сделки.

    Также менеджер по продажам будет уведомлен через "Веб-Мессенджер" о том, что менеджер по закупкам заполнил требуемые поля. В сообщении будут указаны значения этих полей и ссылки на Поставщика и приложенные файлы.

    Рассмотрим эти ссылки поподробнее:

    • Для автоматического формирования ссылки на карточку просмотра сделки будет использоваться следующее выражение

      [url]{=Variable:domain_printable}/crm/deal/show/{=Document:ID}/[/url]

      где {=Variable:domain_printable} будет являться значением переменной Адрес портала (*), которая была ранее задана при создании шаблона бизнес-процесса, а {=Document:ID} - Идентификатор сделки, который входит в стандартный набор полей сделки.

    • Для автоматического формирования ссылки на карточку просмотра поставщика будет использоваться следующее выражение

      [url]{=Variable:domain_printable}/crm/company/show/{=Document:UF_CRM_1369312906}/[/url]

      где {=Document:UF_CRM_1369312906} будет являться значением поля Поставщик (название).

    • Для автоматического формирования ссылки на файл из поля сделки Счет от поставщика будет использоваться следующее выражение

      [url]{=Variable:domain_printable}/bitrix/components/bitrix/crm.deal.show/show_file.php?ownerId={=Document:ID}&fieldName=UF_CRM_1369315496&fileId={=Document:UF_CRM_1369315496}/[/url]

      где {=Document:UF_CRM_1369315496} будет являться значением поля Счет от поставщика (файл). Также идентификатор этого поля используется для параметра &fieldName=UF_CRM_1369315496 ссылки.

    Этап 3 - Менеджер по продажам

    Действия аналогичны действиям предыдущего этапа, с той разницей, что задается другой сотрудник и поля, которые ему необходимо заполнить.

    Этап 3а - Комментарий относительно сроков доставки

    На этом этапе сверяются сроки поставки. Если срок поставки до клиента равен или больше срока поставки до поставщика +5 дней, то процесс продолжается, иначе менеджеру по продажам выставляется задание (Ознакомление с документом), в котором он должен будет оставить комментарий по поводу сроков поставки. После чего его комментарий будет записан в сделку.

    Проверка осуществляется следующим образом: если значение поля документа Срок поставки до клиента не меньше чем вычисленное выражение =Dateadd({=Document:UF_CRM_1369314998}, "5d") (где {=Document:UF_CRM_1369314998} - поле сделки Срок поставки от поставщика), то никаких действий выполняться не будет. Во всех остальных случаях менеджеру по продажам будет выставлено задание.

    Этап 4 - Этап 8

    Действия аналогичны действиям 3-го этапа, с той разницей, что задается другой сотрудник и поля, которые ему необходимо заполнить.


Пример бизнес-процесса для подачи заявки на отпуск
204 / 401

В данном уроке рассмотрен пример создания сервиса по работе с заявками на отпуск, который основан на базе Универсальных списков.

Краткий алгоритм работы

После того как сотрудник заполнит данные заявки, она автоматически направляется на утверждение его начальнику.

Если начальником является директор компании, то заявка утверждается или отклоняется им. Если же начальником не является директор компании, то сначала заявка будет утверждаться непосредственным начальником сотрудника, а затем и директором компании.

В процессе утверждения бухгалтеру, директору и начальнику высылаются оповещения с указанием информации касательно заявки на отпуск (используются данные из полей самой заявки).

После утверждения/отклонения заявки для соответствующей переменной устанавливается/не устанавливается нужное значение, на основе которого потом будут произведены действия по оповещению требуемых сотрудников, установке соответствующих статусов для заявки и записи в график отсутствия.

Примечание: Процесс подразумевает, что в компании используется структура с несколькими уровнями начальства и одним главным директором.

Шаблон для ознакомления: Скачать

Настройка списка

Необходимо создать следующие поля списка:

  • Номер - типа Счетчик;
  • С - типа Дата/Время (обязательное);
  • По - типа Дата/Время (обязательное);
  • Тип отпуска - типа Список (обязательное), со значениями: Очередной, За свой счет, Учебный;
  • Доп.инф. - типа Название (обязательное). Данное поле создано потому, что тип Название обязательный и удалить его невозможно.

    Значение по умолчанию: нет.

Используемые переменные

  • Автор (applicant) типа Пользователь - используется для указания автора заявки на отпуск;

    Значение по умолчанию: Автор.
  • Начальник (deptchief) типа Пользователь - используется для хранения начальника, который будет выбран для автора в ходе выполнения бизнес-процесса;
  • Директор (ceo) типа Пользователь - используется для указания директора компании;

    Значение по умолчанию: указывается_соответствующий_сотрудник_компании.
  • Бухгалтер (accountant) типа Пользователь - используется для указания бухгалтера компании;

    Значение по умолчанию: указывается_соответствующий_сотрудник_компании.
  • Утверждено? (approved) типа Да/Нет - используется в качестве флага, отображающего статус заявки. На его основе производится выбор дальних действий над заявкой после ее утверждения;

    Значение по умолчанию: Нет.
  • Кем отклонено (rejectedby) типа Пользователь - используется для хранения пользователя, отклонившего заявку на отпуск;
  • Ссылка (link) типа Строка - используется формирования ссылки для перехода к просмотру заявки на отпуск. Эта ссылка будет использоваться в тексте оповещения сотрудников, участвующих в процессе.

    Значение по умолчанию: http://адрес_портала/company/personal/bizproc/.

Настройка шаблона

  • Необходимо проставить свои поля (взамен тех, что будут после импорта шаблона) во всех действиях шаблона (через форму Вставка значения);

    Также замену полей необходимо произвести и в тексте сообщений:

  • Необходимо задать для переменных Директор, Бухгалтер и Ссылка свои Значения по умолчанию.

Общая схема работы бизнес-процесса

  • Первым делом идет действие по выбору начальника для автора.

    В случае если непосредственный начальник отсутствует, то будет выбран вышестоящий начальник, для этого в параметрах действия для опции пропускать отсутствующих выбрано значение да.

  • Следующее действие (Роли) производит запись в переменные следующих пользователей:
    • Автор - сотрудник, который создал заявку на отпуск. Указывается с помощью выражения {=Document:CREATED_BY};
    • Начальник - сотрудник, который был выбран предыдущим действием (выбор начальника). Указывается с помощью формы Вставка значения (Дополнительные результаты - Выбор начальника - Выбранный начальник).

  • Далее следует действие по установке прав. В нем для основных сотрудников разрешается доступ на чтение к заявке на отпуск.

  • Следующим идет условие (Выбранный начальник?), по которому, в зависимости от того, какой именно начальник был выбран (действие выбор начальника), будут выполняться различные ветви последовательности действий.

    • Выполнение первой ветки условия происходит, если значение переменной Начальник равно значению переменной Директор.

      Далее Бухгалтеру и Директору будут отправлены уведомления, после чего заявка будет отправлена на рассмотрение Директору.

      В случае одобрения заявки значение переменной Утверждено? будет установлено на да.

      В противном случае в качестве значения переменной Кем отклонено будет установлен сотрудник, отклонивший заявку - Директор.

    • Если условие 1-й ветки не будет выполнено, то тогда будет произведен переход к проверке условия 2-й ветки. Ее выполнение происходит, если значение переменной Начальник равно сотруднику, который был выбран действием выбор начальника.

      Таким образом, происходит проверка, что переменная Начальник не пуста и не равна Директору.

      Далее Начальнику будут отправлены уведомления, после чего заявка будет отправлена ему на рассмотрение.

      В случае отклонения в качестве значения переменной Кем отклонено будет установлен сотрудник, отклонивший заявку - Начальник.

      В случае одобрения заявки будет выполнено последующее ее согласование с директором, аналогично 1-й ветки условия.

    • 3-я ветка условия будет выполняться в последнюю очередь, при условии, что переменная Начальник будет пуста.

      В этом случае Бухгалтеру и Директору будут отправлены уведомления, после чего заявка будет отправлена на рассмотрение Директору.

  • Следующей конструкцией будет опять условие.

    В этот раз выбор ветки с действиями будет производиться в зависимости от значения переменной Утверждено?, которое по умолчанию равно нет, но может быть изменено на да в ходе выполнения предыдущего условия.

    • В случае если значение переменной Утверждено? равно да, то тогда Бухгалтеру, Начальнику и Автору будут отправлены сообщения, оповещающие о том, что заявка на отпуск была одобрена.

      Затем заявка будет опубликована в списке заявок со статусом "одобрена".

      После в график отсутствия будет занесена соответствующая запись и установлен соответствующий статус для заявки, на чем и завершится процесс.

    • В случае если значение переменной Утверждено? равно нет, то тогда Начальнику и Автору будут отправлены сообщения, оповещающие о том, что заявка на отпуск была отклонена.

      После чего будет установлен соответствующий статус для заявки, на чем и завершится процесс.


Организация почасовой занятости сотрудников
205 / 401

Рассмотрим следующий сценарий работы. После поступления заказа от клиента, руководитель выставляет для ознакомления задачу, а желающие ее сделать сотрудники указывают количество часов, необходимое для ее выполнения. Руководитель выбирает исполнителя, исходя из этих данных и ставки сотрудника за час работы.

С использованием инструментария Битрикс24 реализация может выглядеть следующим образом. После того, как с клиентом заключен договор на оказание услуг, руководитель добавляет сделку, в которой описаны детали проекта. Это запускает бизнес-процесс, который демонстрирует данное описание заранее выбранным двум работникам, каждому из которых предлагается указать время выполнения задания и свою ставку работы за час. Вся эта информация передается руководителю, который на ее основании выбирает ответственного за решение задачи. После этого, на имя выбранного сотрудника, приходит задача с описанием проекта и крайним сроком, полученным путем прибавки указанного сотрудником количества часов к текущему времени.

После получения заказа руководитель добавляет сделку, в комментариях к которой подробно описывается суть задачи. Запускается заранее созданный бизнес-процесс на добавление сделки:

Первым идет действие Ознакомление с документом (название в бизнес-процессе - Ознакомление с заданием). В нем указаны сотрудники, которым будет выслано данное ознакомление. Название задания формируется из заголовка сделки. В описании задания будет показана информация из поля Комментарии сделки. В поле Период ознакомления указано время, по истечении которого ознакомление будет автоматически завершено и бизнес-процесс пойдет дальше. Это сделано во избежание ступора бизнес-процесса, если один из сотрудников, по какой-либо причине, не подтверждает свое ознакомление с задачей.

Указанные в действии сотрудники видят следующее сообщение:

Затем начинает свое выполнение конструкция из параллельного выполнения. Итог ее работы заключается в том, что оба сотрудника получают запрос на количество часов, необходимое им для выполнения задачи:

В запросе дополнительной информации создано поле, в котором сохраняется указываемое сотрудником количество часов:

В следующем действии (Изменение переменной ...) ветки, в заранее созданную строковую переменную (Часы Егора и Часы Семена), записывается выражение, которое будет использовано в итоговой постановке задачи:

Действие Определение исполнителя представляет собой запрос дополнительной информации, посылаемый руководителю. В поле Описание задания указано следующее:

{=A20475_27092_57458_46652:Comments}

Число часов, указанных Раевским: {=Variable:egor_hours_printable}

Число часов, указанных Семеном: {=Variable:semen_hours_printable}

В действии создается переменная Сотрудник типа привязка к пользователю:

Руководитель увидит форму следующего содержания:

Далее, в зависимости от значения переменной Сотрудник, в заранее созданную в параметрах шаблона бизнес-процесса строковую переменную Итоговые часы, сохраняется число часов, указанным тем, или другим сотрудником:

Значение переменной Итоговые часы используется в постановке задачи (поле Крайний срок):

=Dateadd({=System:Now}, {=Variable:Variable1})

Также в добавлении задачи в качестве описания и названия применяются такие поля исходной сделки, как Комментарий и Название, а ответственный назначается из переменной Сотрудник:


Примеры бизнес-процессов, созданные пользователями (ссылки)
206 / 401

В данном уроке собраны ссылки на сторонние примеры использования бизнес-процессов, которые могут показаться полезными.

Внимание! Компания "1С-Битрикс" не несет ответственность за шаблоны бизнес-процессов, созданные другими пользователями. По вопросам, связанным с работой таких шаблонов, обращайтесь к их авторам.

  • Автоматическое приведение телефонного номера лида/контакта к требуемому виду, Бизнес-процесс. Преобразование телефона к формату 7XXXXXXXXXX (Форум Битрикс24)


Календарь
207 / 401

С помощью ссылки Календарь вы можете организовать несколько собственных календарей, события которых можно просматривать на одной сетке. Кроме того, в сетку календаря могут быть добавлены ваши задачи:

Настройка доступа к вашим календарям настраивается отдельно для каждого календаря в форме его создания (редактирования).

Настройки календаря

Нажатие на пиктограмму [image] осуществит переход к пользовательским настройкам календаря:

  • Ваш часовой пояс - указать часовой пояс календаря;

  • Календарь для приглашений - если сотрудника приглашают принять участие в каком-либо событии, то это событие будет добавлено в указанный календарь;
  • Использовать визуальное выделение (мигание) неподтвержденных событий - при отмеченной опции неподтвержденные события будут визуально выделены (будут мигать);
  • Показывать события, в которых вы отказались принять участие - снимите галочку, если не хотите видеть в календаре события, от участия в которых вы отказались;
  • Отображать прошедшие события приглушенными - при отмеченной опции будет визуальное затенение в календаре тех событий, которые уже прошли.
  • Настроить избранные календари - после нажатия откроется форма настройки отображения избранных календарей:

    Здесь вы можете добавить в избранное календарь какого-либо пользователя или групп, в которых вы состоите. Для этого необходимо отметить их галочками.

    Примечание: Календарь компании подключен как избранный у каждого сотрудника по умолчанию.

    Для добавления календаря сотрудника нажмите Добавить календари пользователя и в появившейся форме начните вводить имя, логин или электронный адрес этого пользователя и вам будут отображены подходящие сотрудники:

    Выберите нужного пользователя, нажмите Добавить и отметьте галочкой его календарь в форме настройки избранных календарей.

    Примечание: не все календари могут быть доступны для просмотра. Если календари выбранных вами сотрудников не являются открытыми, то вы будете оповещены об этом соответствующим сообщением:

  • Настроить внешние календари (CallDAV) - позволяет выполнить подключение внешнего календаря;
  • Очистить персональные настройки - нажмите на ссылку, если хотите вернуться к настройкам интерфейса по умолчанию. Подтвердите свое решение в появившемся окне.


Календари
208 / 401

У вас есть возможность создавать разные календари для разных типов событий, отображать их на общей сетке и добавлять важные календари в избранные, для быстрого доступа к ним.

  • Добавление новых календарей
  • Добавление календарей в избранные
  • Управление календарями
Интерактивный видеоролик о работе с календарями

Интерактивный видеоролик (требуется выполнение действий пользователем). Продолжительность 3 минуты 8 секунд. Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если нет возможности прослушать звуковое сопровождение, то с помощью значка [image] в правом верхнем углу ролика можно просмотреть текст.

Добавление новых календарей

Перейти к добавлению нового календаря можно двумя способами.

  • Нажмите добавить на области списка календарей:

  • или после нажатия стрелки рядом с кнопкой Добавить выберите в меню пункт новый календарь:

Откроется форма следующего вида:

  • Обязательно укажите Название календаря, по желанию введите Описание и укажите цвет.
  • Вы можете разрешить добавлять в данный календарь приглашения на события от всех пользователей и добавить его в список избранных календарей.
  • Если отметить опцию Разрешить экспорт календаря, то календарь можно будет экспортировать в календари MS Outlook в формате iCal. При этом в поле Экспортировать события можно задать период времени относительно момента экспорта, за который будут экспортированы события.

    Внимание! Для полноценной интеграции требуется версия MS Outlook 2007 и выше.

На закладке Права доступа настраиваются права доступа к календарю для пользователей:

Ссылка Добавить служит для выбора групп и/или пользователей, которым необходимо назначить некоторое право доступа к календарю.

Для коробочного Битрикс24

Важно! Помните о том, что права доступа к типу календарей, заданные администратором в настройках модуля, перекрывают по значимости права доступа непосредственно к конкретному календарю данного типа.

Добавление календарей в избранные

Для быстрого доступа к календарям их можно добавить в список избранных.

Если у вас еще нет избранных календарей, то для добавления календаря в избранные следует в меню его действий выбрать пункт Добавить в избранные:

Либо можно добавить календари в избранные с помощью специальной формы настройки избранных календарей. Перейти к этой форме можно одним из двух способов:

  • кликнув по кнопке меню настроек [image] и выбрав пункт Настроить избранные календари;
  • если уже имеются избранные календари, то нажав ссылку настроить:

Примечание: Календарь компании подключен как избранный у каждого сотрудника по умолчанию.

Для удаления календарей из избранных используйте следующие варианты:

Удаление календаря из избранных не удаляет сам календарь. Таким образом, удалить календарь группы можно только со страницы профиля группы.

Управление календарями

Основные действия с календарем можно совершить через его меню действий:

  • Редактировать - переход к форме редактирования календаря. Форма редактирования аналогична форме добавления календаря, за исключением отсутствия опции Добавить в избранные и наличия ссылки Удалить календарь.
  • Добавить в избранные/Убрать из избранных - добавление либо удаление календарей из избранных;
  • Соединить с Outlook - двухсторонняя синхронизация событий календаря с MS Outlook;
  • Экспорт (iCal) - экспорт данных календаря в формате iCal.

    Данный пункт меню доступен, если в настройках календаря отмечена опция Разрешить экспорт календаря;
  • Удалить - удаление выбранного календаря. При удалении календаря группы события этого календаря удаляются также из календарей участников группы.


События и задачи
209 / 401

В каждый из календарей можно добавлять события несколькими способами, а для планирования коллективных событий можно использовать Планировщик событий.

  • Добавление событий
  • Управление событиями
  • Планировщик событий
Интерактивный видеоролик по событиям и задачам

Интерактивный видеоролик (требуется выполнение действий пользователем). Продолжительность 7 минут 19 секунд. Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если нет возможности прослушать звуковое сопровождение, то с помощью значка [image] в правом верхнем углу ролика можно просмотреть текст.

В календарях также отображаются все задачи, в которых сотрудник является ответственным. Они помечаются специальным значком:

В списке календарей задачи всегда находятся внизу и обозначены розовым цветом. Подробную информацию по работе с задачами смотрите в разделе Задачи.

Добавление событий

Мероприятия могут быть однодневными или занимать несколько дней. Добавить событие можно из живой ленты или CRM. Из календаря это можно сделать одним из двух способов.

Способ 1

  • В сетке календаря выберите день события и кликните по нему. Откроется окно добавления события:

  • Укажите Название события, выберите Календарь, к которому относится это событие, задайте вашу предполагаемую занятость в нем в поле Занятость.

    • Примечание: если событие должно быть многодневным, то нажмите ссылку Редактировать (смотрите Способ 2).

    Или же выберите в календаре день начала события, кликните по нему, и, не отпуская кнопку мыши, проведите курсор до дня окончания события. После отпускания кнопки мыши появится форма создания события с указанным периодом времени.

  • Нажмите кнопку Добавить.

Способ 2

  • Нажмите на кнопку Добавить, расположенную в верхнем правом углу календаря. Либо кликните стрелочку рядом с ней и в открывшемся меню выберите новое событие:

    Откроется окно добавления нового события:

  • Проверьте и поменяйте, если необходимо, ваш часовой пояс. Если событие планируется в другом часовом поясе, укажите его, выбрав нужное значение из списка. Имеется возможность указать разные часовые пояса начала и окончания мероприятия. Если указаны разные часовые пояса, то при просмотре события рядом с его временем располагается пиктограмма [image] .
  • Укажите дату\время начала и окончания мероприятия. Можно задать время начала и окончания мероприятия, кликнув по полю со значением времени:

    С помощью стрелок на циферблате, или полей для ввода времени, установите необходимое время и нажмите кнопку Вставить.

    Внимание! Следует иметь в виду, что часовая стрелка не может занимать промежуточное положение, поэтому 12:55 на часах будет выглядеть как без пяти двенадцать.

    Если мероприятие запланировано на весь день, можно отметить это галочкой в одноименной опции.

  • На закладке Описание задайте краткое описание события (для форматирования текста описания можно использовать элементы панели инструментов). Аналогично сообщениям, к событию можно прикрепить файл, вставить ссылку или видео, а также создать и прикрепить документ.
  • На закладке Участники можно пригласить сотрудников к участию в событии.

    Примечание: детальное планирование событий осуществляется с помощью Планировщика событий.

    Для этого нажмите на ссылку Добавить сотрудников, группы или отделы, введите несколько букв имени (фамилии, имени или отчества), выберите сотрудника из выпадающего списка, либо из структуры компании (Сотрудники и отделы). Повторите операцию, пока все нужные сотрудники не появятся под записью Участники. Как только участников события становится больше одного, в окне появляется Планировщик событий:

    Примечание: в коробочной версии Битрикс24 текст приглашения и настройки события, расположенные ниже списка участников, видны при редактировании события.

    Текст приглашения для всех участников можно добавить с помощью ссылки Добавить текст приглашения, по нажатии которой будет отображено поле для ввода текста.

    Это открытая встреча - поставьте галочку, если хотите разрешить свободное присоединение участников к событию.

    Оповещать о подтверждении/отказе участников - оставьте галочку в данной опции, если хотите, чтобы вам приходили уведомления с информацией об отказе или подтверждении участия сотрудников в событии.

    Запросить повторное подтверждение участия (отображается при редактировании события) - при отмеченной опции изменение события приведет к повторному оповещению всех участников события.

    Указанным сотрудникам будет отправлено соответствующее сообщение с приглашением, посредством которого они согласятся или откажутся от участия в событии. В форме просмотра и редактирования события это будет отображено одним из статусов: Подтвердили, Отказались, Еще думают.

    Внимание! Приглашение отправляется только при указании отдельных пользователей в событии. Если в участники событий приглашается группа или отдел, то сотрудникам не будет отправлено уведомление.

    Событие, в котором принимают участие несколько сотрудников, помечается в календаре пиктограммой [image].

  • На закладке Дополнительно настраиваются дополнительные параметры события:

    • Повторяемость события - позволяет задать повтор события (каждый день/неделю/месяц/год) и ограничить время повтора события;

      Примечание: установленное напоминание будет срабатывать при каждом повторе события.

    • Важность события - позволяет указать значимость события (Высокая, Нормальная, Низкая);
    • Частное событие - делает информацию о событии недоступной (кроме времени проведения, занятости, важности, отметки о частном событии и комментариев).
    • Цвет - выберите цвет события и текста в общей календарной сетке;
    • Элементы CRM - нажав Выбрать, вы можете привязать какую-либо сущность CRM к событию, после чего событие будет помечено специальным значком crm и добавлено к выбранной сущности, а также отображено на странице Мои дела ответственного за данное событие.

      • Важно! Поле Элементы CRM будет доступно только если сотрудник имеет доступ к CRM.

  • Нажмите кнопку Сохранить.

В итоге cобытие появится в создаваемом календаре. Участникам события в Живую ленту придет уведомление, в котором они могут подтвердить свое участие, либо отказаться от него. Комментарии к событию можно оставлять прямо из ленты.

Кроме того, как только пользователь будет выбран участником события ему будет прислано уведомление, из которого он также может принять решение о своем участии в событии.

Количество неподтвержденных событий отображает специальный счетчик пункта Календарь в левом меню

При клике на этот счетчик происходит переход в календарь, где неподтвержденные события выделяются мерцающим (если мигание задано в настройках) красным цветом и знаком вопроса:

Здесь также можно просмотреть подробное описание события и подтвердить своё участие, нажав кнопку

Ближайшие события, в которых принимает участие сотрудник, отображаются на главной странице портала в специальном виджете

откуда можно по клику быстро перейти к его просмотру:

Управление событиями

Управление созданным событием календаря осуществляется с помощью инструментов, доступных при наведении курсора мыши на событие:

  • - позволяет перейти к форме редактирования события, аналогичной форме создания события.
  • - позволяет удалить событие. При удалении события, в котором участвуют несколько сотрудников, появится предупреждение:

    После подтверждения событие удаляется из календарей всех участников.

    Примечание: при удалении события, связанного с какой-либо сущностью CRM, запись о его удалении появляется на закладке История соответствующей сущности.

    Обратите внимание: Редактировать и удалять события календаря может не только его владелец, но и сотрудник, обладающий соответствующими правами доступа на календарь.

  • Чтобы просмотреть событие, щелкните по любому месту события, свободному от пиктограмм удаления и редактирования. Из формы просмотра, кроме добавления комментариев, можно перейти к редактированию и удалению события с помощью соответствующих ссылок:

    Примечание: о новых комментариях вы можете узнавать, просматривая новые сообщения живой ленты. В центр нотификаций уведомления приходить не будут.

Зажав левой кнопкой мыши событие, вы можете перетаскивать его по календарю.

Внимание! Учтите, что если напоминание уже срабатывало, то при переносе события на другой день оно восстановлено не будет.

Планировщик событий

На портале сотрудникам удобно планировать коллективные (общие) события, контролируя занятость или отсутствие приглашенных сотрудников в офисе. Для этого в продукте реализован Планировщик событий. Он автоматически активируется на закладке Участники формы создания/редактирования события, как только количество участников события становится больше одного.

В результате на сетке планировщика можно будет просмотреть коллективное событие.

Если у выбранных сотрудников не запланировано на время создаваемого/редактируемого события дел или отсутствия, то их соответствующие интервалы времени на сетке планировщика будут отображены зеленым цветом, в противном случае - красным. Если планируемое событие пересекается с интервалами отсутствия или других событий сотрудников, то на сетке временной интервал события будет отображен оранжевым цветом:

После изменения времени общего события (например, перемещения его по сетке при помощи мыши в "зеленую" зону всех сотрудников) с учетом занятости/отсутствия сотрудников, временной интервал планируемого события будет отображен голубым цветом.

Примечание: управление мышью:


Календарь компании
210 / 401
В Битрикс24 каждый сотрудник имеет возможность запланировать событие для всей компании сразу. Для этого у пользователей подключен Календарь компании. Он доступен в разделе меню Календарь:

По умолчанию для каждого сотрудника установлены права на просмотр и добавление событий в Календарь компании. Также по умолчанию Календарь компании подключен к списку избранных календарей сотрудника. В случае необходимости, администратор портала может отредактировать эти права и настройки через "шестеренку" в меню календаря:

Добавленное любым сотрудником событие будет доступно для просмотра также любому пользователю. Но поскольку доступность для просмотра не означает обязательность участия в событии, участников необходимо персонально уведомить. Например, о директорском совещании начальников отделов могут знать все, но принимать участие в нём будут конкретные сотрудники. Поэтому, как и в случае любого другого календаря, при планировании события следует приглашать сотрудников на закладке Участники, где также можно выбрать и участие всех сотрудников:

Приглашенным участникам будет выслано уведомление о событии, а на главной странице портала в специальном виджете Ближайшие события для них будет отображаться напоминание.

Дополнительная информация

  • Календарь компании


Синхронизация и внешние соединения
211 / 401

Внешние соединения (Интерактивный видеоролик)

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен.

К Битрикс24 могут быть подключены ваши личные внешние календари, а также настроена синхронизация с Google календарем, MS Outlook, MS Exchange и мобильными устройствами. Кроме того, события Календаря могут быть экспортированы в iCal.

Панель возможных синхронизаций отображается на странице Календаря справа, под списком доступных календарей:

Для коробочного Битрикс24

Примечание: функционал соединения календарей с мобильными устройствами и Microsoft Exchange зависит от настроек портала и может быть недоступен для конкретной реализации портала компании. При возникновении трудностей обратитесь к администратору портала.

  • Подключение к Битрикс24 внешних календарей
  • Синхронизация с Google календарем
  • Синхронизация с Mac OSX
  • Синхронизация с iPhone
  • Синхронизация с Andriod
  • Синхронизация с MS Outlook
  • Синхронизация с Microsoft Exchange
  • Экспорт календарей (iCal)

Подключение к Битрикс24 внешних календарей

Подключение к Битрикс24 внешних календарей (Интерактивный видеоролик)

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен.

Вы можете подключать внешние календари по протоколу CalDAV (например, календари Google).

Для подключения внешнего календаря используйте пункт меню внешний календарь (CalDav):

Поcле чего в форме Список подключений внешних календарей укажите:

  • Название календаря;
  • Адрес подключения ко внешнему календарю;
    • Например, для календарей Google он будет иметь вид https://www.google.com/calendar/dav/YOUREMAIL@DOMAIN.COM/user
  • Имя пользователя и Пароль, для подключения к календарю.
  • Нажмите кнопку Сохранить.

В случае правильно указанных параметров и корректных настроек безопасности CalDav-сервера в списке календарей появится внешний календарь, а в сетке будут события из него.

Примечание: При подключении внешних календарей передаются события, но не напоминания.

Синхронизация с Google календарем

Для синхронизации с Google календарем следует кликнуть по ссылке подключить в соответствующем пункте панели синхронизаций. При первом подключении будет предложено выбрать Google-аккаунт, события которого вы хотите видеть в сетке своего календаря на портале, и разрешить доступ к нему:

После обновления страницы на панели синхронизации вы увидите информацию о дате и времени синхронизации, а события Google календаря появятся в сетке:

Примечание: Календари из Google Calendar, подключенные по подписке, не участвуют в отображении занятости в планировщике событий.

Дальнейшая синхронизация происходит автоматически при добавлении/редактировании событий в календаре на портале или в Google календаре.

Для отключения Google календаря от портала следует выбрать соответствующий пункт в меню календаря:

Синхронизация с Mac OSX

Для того, чтобы ваши календари появились в приложении iCal для MacOSX следуйте рекомендациям, появляющимся при нажатии ссылки подключить на кнопке MacOSX на панели синхронизации:

Синхронизация с iPhone

Соединение календарей Битрикс24 с мобильными устройствами (Интерактивный видеоролик)

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен.

Битрикс24 позволяет подключать календари к устройствам Apple по протоколу CalDav. Для этого на панели синхронизации кликните ссылку подключить на кнопке iPhone и получите рекомендации по подключению:

Для того чтобы добавить выбранный календарь в устройство Apple, выполните следующие действия:

  • На устройстве Apple, зайдите в Настройки и перейдите на вкладку Учетные записи

  • Нажмите на кнопку добавления новой учетной записи

  • Выберите тип учетной записи CalDAV.

  • В настройках параметров учетной записи введите адрес портала вида https://адрес_портала:порт а также ваши логин и пароль

    • Примечание: Устройства Apple с новой версией iOS дальше подключатся сами. В старых версиях iOS необходимо указать ссылку (пункт 4 рекомендации по подключению), сгенерированную на портале, в Дополнительных настройках учетной записи.

  • В настройках соединения к серверу, необходимо указать протокол https;

  • В качестве типа авторизации следует использовать SSL.

Синхронизация с Android

Алгоритм синхронизации для Android подробно описан во всплывающем окне, которое активируется при нажатии на ссылку подключить на кнопке Android на панели синхронизации.

В соответствии с алгоритмом следует выбрать Битрикс24:

Указать адрес портала, логин и пароль пользователя:

Отметить галочкой, что именно следует синхронизировать:

Получить синхронизированные события и просматривать их в календаре мобильного устройства:

В дальнейшем синхронизация происходит автоматически, добавление и изменение событий возможно как на портале, так и в календаре Android. При необходимости отключения синхронизации следует воспользоваться специальной ссылкой:

Синхронизация с MS Outlook

Соединение календарей сервиса с MS Outlook (Интерактивный видеоролик)

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если нет возможности прослушать звуковое сопровождение, то с помощью значка [image] в правом верхнем углу ролика можно просмотреть текст.

Внимание! Для полноценной интеграции Битрикс24 с MS Outlook требуется версия Outlook 2007 и выше.

При настройке соединения календарей сервиса Битрикс24 с MS Outlook выполняется двусторонняя синхронизация событий календарей (например, личного или календарей сотрудников) с календарями MS Outlook.

Для этого выполните следующее:

  • На панели синхронизаций Календаря портала нажмите ссылку подключить на кнопке MS Outlook и выберите требуемый календарь:

  • Запустится MS Outlook, при этом будет выведено следующее предупреждение:

  • Нажмите кнопку Да для продолжения подключения календаря, либо кнопку Дополнительно... для вызова диалога дополнительной настройки параметров.
  • Введите Имя папки (название календаря) и Описание календаря и нажмите кнопку OK.

    • В результате в MS Outlook будет добавлен календарь, события которого будут отображены на сетке календаря:

  • Аналогичным образом выполняется экспорт нескольких календарей. Если события нескольких календарей отобразить на одной сетке, то календарь примет вид, схожий с календарем портала:

При добавлении нового события в календарь MS Outlook это событие будет автоматически добавлено в календарь Битрикс24.

Для этого выполните следующее:

  • В сетке календаря выберите день события проведения мероприятия и дважды кликнете по нему. Откроется окно добавления нового события:

  • Заполните поля: Тема, Начало, Конец и Описание.
  • Нажмите кнопку Сохранить и закрыть.

В результате новое событие будет добавлено в календарь MS Outlook:

После добавления события в календарь MS Outlook автоматически произойдет синхронизация с календарем портала. Ход синхронизации будет отображен в нижнем правом углу MS Outlook:

В календаре портала также появится это событие.

Управление событием возможно как в MS Outlook, так и в календаре портала.

В MS Outlook дважды кликните по событию, которое необходимо изменить. В открывшемся окне измените событие. Нажмите кнопку Сохранить и закрыть.

Для удаления события в календаре MS Outlook выберите событие, в меню действий укажите пункт Удалить.

После редактирования или удаления произойдет автоматическая синхронизация, событие будет изменено или удалено как в календаре MS Outlook, так и на портале.

Для отключения календаря следует удалить его из Outlook. Перейдите в раздел Календарь, кликните правой кнопкой мыши по наименованию календаря, и в выпадающем меню выберите пункт Удалить календарь:

После подтверждения удаления синхронизация будет отключена.

Синхронизация с Microsoft Exchange

Для коробочного Битрикс24

Синхронизация с Microsoft Exchange возможна только в том случае, если Microsoft Exchange Server подключен администратором портала, о чем будет свидетельствовать пункт в панели внешних подключений:

Cсылка подключить служит для выполнения синхронизации календарей вручную.

Примечание: если у вас отображается следующая надпись:

то это значит, что соединение с Exchange лишь включено, но не настроено. При возникновении проблем синхронизации в таком случае обратитесь к администратору портала.

Примечание: если в панели синхронизаций отсутствует надпись о MS Exchange, то соединение c Microsoft Exchange невозможно.

Примечание: Если при попытке синхронизации возникает ошибка ErrorFolderNotFound, то решение смотрите в курсе администратора.

Экспорт календарей Битрикс24 (iCal)

Экспорт календарей сервиса Битрикс24 (iCal) (Интерактивный видеоролик)

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен.

Если в настройках собственных календарей разрешен экспорт (опция Разрешить экспорт календаря (iCal)), то в меню действий календарей доступен пункт Экспорт (iCal):

Чтобы экспортировать календари выполните следующее:

  • Нажмите на пункт меню Экспорт (iCal) нужного календаря.
  • Скопируйте ссылку в буфер обмена:

    • Ссылка для экспорта календаря

  • Запустите MS Outlook и перейдите к разделу Календарь.
  • На закладке Папка выберите Открыть календарь > Из Интернета...

  • В окне Создание подписки на Интернет-календарь вставьте ссылку на календарь из буфера обмена:

  • Нажмите кнопку ОК. Откроется окно с вопросом: Добавить этот Интернет-календарь в Outlook и подписаться на обновления? По кнопке Дополнительно можно указать Имя папки и Описание импортируемого календаря.
  • Сохраните внесенные данные. Подключение календаря выполнено.

В результате в календаре MS Outlook будут доступны для просмотра события подключенного календаря. Добавление и изменение событий выполняется только на портале.


Мой Диск
212 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Мой Диск

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

На странице Мой Диск содержится ваш персональный файловый архив, доступ к которому для других сотрудников вы можете задать самостоятельно для разных файлов и папок:

По умолчанию у пользователя созданы папки:

  • Загруженные файлы - в этой папке хранятся файлы, загружаемые вами в сообщения\задачи на портале. Папка и файлы скрыты от всех пользователей, кроме владельца. Для других пользователей доступ к файлам возможен через сообщение или задачу, к которым был прикреплен файл. Данная папка не синхронизируется с локальной папкой вашего компьютера.

    Примечание: удаление файлов из папки Загруженные файлы в Корзину не ведет к удалению их из сообщений Живой ленты, Задач и проч. Но при выборе опции Удалить навсегда или при удалении из Корзины файл будет удален системно, то есть из всех событий, в которых участвует.

  • Сохраненные файлы - в этой папке содержатся файлы, сохраненные вами при нажатии кнопки "Сохранить на Битрикс24.Диск" внутри портала:

  • Бизнес-чат - сохраненные файлы - в этой папке содержатся файлы, сохраненные вами при нажатии кнопки "Сохранить на Диск" в бизнес-чате:

Примечание: Папки Сохраненные файлы и Бизнес-чат - сохраненные файлы не отображаются в вашем Диске до тех пор, пока вы не сохраните в них какой-либо файл на вашем локальном компьютере.

На странице Мой Диск также могут размещаться папки Загрузки и Общие файлы, если они были автоматически созданы в более ранних версиях Моего Диска.

Свойства папки Загрузки аналогичны свойствам папки Загруженные файлы.

Доступ к папке Общие файлы по умолчанию имеют другие сотрудники в режиме Чтение. Общие файлы можно просматривать только на странице личных файлов сотрудника (ссылка Мой Диск в профиле).

Остальные папки и файлы недоступны другим пользователям, но при желании к ним тоже можно настроить доступ.

Внимание! Следует иметь в виду, что пользователь с правами администратора Корпоративного портала может иметь доступ ко всем файлам любого сотрудника при включении режима администратора.

Вы можете сделать личную папку общей, выбрав соответствующий пункт в меню действий:

В появившемся окне выберите сотрудников, для которых будет открыт доступ:

Добавьте сотрудников и группы, которым следует открыть доступ к этой папке, укажите уровень доступа (Чтение, Добавление, Редактирование, Полный доступ). После этого сотрудники, которых вы подключили, получат соответствующее уведомление [image] , а сама папка появится в их личных дисках.

При вступлении в группу ее хранилище появится в вашем диске. Физически это означает, что вашему диску передается ссылка на папку, но сама папка не копируется на диск. Для подключения диска\папки открытой видимой группы, не вступая в нее, нажмите в контекстном меню соответствующую кнопку:

Общие папки в разделе Мой Диск будут помечены пиктограммой [image], а на вашем локальном компьютере - специальным символом [image] .

При необходимости можно отключить папку от Диска, выбрав в контекстном меню пункт Отключить и подтвердив свое намерение во всплывающем окне:

Вы можете управлять настройками своей личной библиотеки. Переход к настройкам осуществляется по ссылке Настроить список в меню действий контекстной панели:

Простая настройка отображения/скрытия колонок списка может осуществляться по нажатию значка "шестеренки" в заголовке таблицы:

Операции с файлами, настройка прав доступа и подключение общей папки к личному диску рассмотрены здесь.


Общий диск
213 / 401

Организация коллективного доступа и работы с документами

Средства сервиса «Битрикс24» позволяют организовать коллективный доступ и работу над документами. В разделе может быть несколько папок, права доступа к которым могут быть различными для отдельных групп сотрудников, рабочих групп и отдельных сотрудников.

По умолчанию доступ к папкам и файлам Общего диска установлен следующим образом:

  • Администраторы - Полный доступ
  • Автор - Редактирование
  • Все авторизованные пользователи - Редактирование
  • Всем сотрудникам - Чтение

Администратор портала может настроить доступ к библиотеке общих документов. Для этого, находясь на странице Общий диск, следует выбрать соответствующий пункт меню - "шестеренку" настроек:

В открывшейся форме настройте права нужным образом:

  • Чтение - разрешен только просмотр содержимого библиотеки документов.
  • Добавление - разрешен просмотр и добавление файлов в библиотеку.
  • Редактирование - разрешены все возможные действия с содержимым библиотеки документов, а также подключение папки как сетевого диска, но нельзя менять настройки и права доступа.
  • Полный доступ - разрешены все возможные действия с библиотекой документов.

Помните о том, что по умолчанию вложенные папки и файлы Общих документов будут наследовать эти права.

Сотрудник, которому был дан доступ к папке, файлу или Диску, получит об этом уведомление - всплывающее сообщение - нотификацию. Он может принять или отказаться от подключения.

Если сотрудник обладает правами на папку библиотеки не ниже Редактирование, то он может подключить ее (или входящие в нее разделы) к личному Диску, выбрав соответствующий пункт в меню действий папки:

Количество доступного места для Общего диска и его файлов зависит от редакции вашего «Битрикс24». При заполнении приобретенного места или прекращении абонентской платы за место в облаке для младших редакций, перестанут быть доступны многие функции портала - написание сообщений в Живую ленту, публикация файлов и др. Для возобновления полной функциональности следует либо внести абонплату (оплатить дополнительное место), либо очистить место самостоятельно - удалить ненужные, устаревшие, поврежденные и др. файлы и/или их версии.


Работа с документами в веб-браузере
214 / 401
Для полноценной работы с документами на Корпоративном портале существует множество самых разнообразных и широких возможностей.


Интерфейс и инструменты работы с документами
215 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Интерфейс работы с документами

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

В списке файлов доступна постраничная навигация - внизу списка обозначена текущая страница, по ссылке можно перейти на предыдущую или следующую страницу, а также увидеть информацию по количеству и общему объему файлов, количеству отмеченных файлов.

Имеется несколько вариантов перемещения по папкам и переноса файлов между папками.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Инструменты работы с документами

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

  • Можно переходить по уровням вложенности папок, используя двойной клик на иконке папки.
    • При этом точное местоположение отображается в правом окне Мой Диск или в верхней панели:

  • Можно передвигаться непосредственно по папкам, кликая на их наименование в верхней панели или в правом окне Мой Диск. В окне Мой диск папки, имеющие вложенные папки, обозначены стрелочками слева от названия. Направление стрелочки указывает, открыта ли вложенная папка (стрелка вниз) или нет (стрелка вправо).
  • Перетаскивать файлы между папками можно с помощью механизма Drag'n'drop. Нужный файл следует захватить за иконку и, перетащив в нужную папку, отпустить клавишу мыши.

Групповые операции с документами

Панель групповых операций с документами аналогична по внешнему виду и функционалу таким же панелям других сущностей, то есть имеет кнопки Для всех (в верхней панели), Редактировать, Удалить. Отличает её наличие функции Перенести/Скопировать и возможность выбора папки назначения. Все эти действия можно производить как с группой файлов, отмеченных флажками, так и с одиночным файлом.

Для группы файлов существует возможность их одновременного скачивания в виде архива. Для этого следует отметить нужные файлы флажками и нажать кнопку Скачать на правой боковой панели меню, затем нажать "Сохранить файл" в появившемся окне скачивания. Файл будет сохранен с именем archive и датой скачивания.

Таким же образом, в виде архива, можно скачать файлы, прикрепленные к сообщениям в Живой ленте, комментариям, календарям, задачам:

Поиск документов

Поиск документа (файла, папки) осуществляется заданием его имени (части имени) в строке поиска. По мере ввода поискового запроса в выпадающем списке появляются соответствующие ему результаты. Можно перейти к найденной сущности, кликнув по ней в списке.

Или же можно вывести все результаты на экран и выбрать нужный из них.


Создание и редактирование папок и файлов
216 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Фрейм "IFRAME"
Создание и редактирование папок и файлов

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

  • Действия с папками
  • Загрузка документов
  • Создание и редактирование документов

Действия с папками

Перечень доступных действий с папками зависит от настройки прав пользователя.

  • Для создания папки нажмите кнопку Создать папку, расположенную на контекстной панели, откроется форма создания новой папки:

    • Введите в поле Название имя создаваемой папки. Нажмите кнопку Создать. В разделе Общий диск вы можете сразу задать права доступа на эту папку. После перезагрузки страницы созданная папка отобразится в таблице элементов.

  • Для изменения прав доступа к папке нажмите на кнопку Действия рядом с ней и выберите пункт меню Общий доступ. В открывшейся форме настройте параметры доступа путем добавления нужных прав:

Загрузка документов

Для выполнения загрузки документов перейдите в папку, в которую необходимо загрузить документы. Нажмите кнопку Загрузить, расположенную на контекстной панели, откроется папка на вашем компьютере, подключенная к Битрикс24.Диск. Выбор папки и файлов для загрузки осуществляется обычным способом, после чего следует нажать кнопку Открыть.

Индикатор загрузки позволяет наблюдать и управлять процессом - удалять из загрузки, приостанавливать, возобновлять, загружать еще.

Внимание! Имя файла (папки) не должно содержать символов \ / \ \ : * ? \ " ' | { } % & ~ . Не допускается загрузка на сервер файлов с расширениями .exe, .php, .lnk, .tmp, .ini, .pl.

При попытке загрузить такие файлы (создать такие папки) будет выдано сообщение о том, что название содержит недопустимые символы, либо файл не будет синхронизирован с Диском, а в Проводнике будет отмечен красным крестиком [image].

Создание и редактирование документов

Вы можете создавать файлы формата Документ(.doc), Таблица(.xls), Презентация(.ppt) с помощью программ на компьютере или же сервисов Google Docs, MS Office Online непосредственно в разделе Мой Диск на портале. Документ будет одновременно сохранен на портале и на жестком диске локального компьютера.

Также можно настроить удобный для вас способ работы с документами - Локально или В облаке. Для этого, находясь на странице Мой диск, следует выбрать соответствующий пункт меню - "шестеренку" настроек:

В открывшейся форме выберите нужный способ работы:

В соответствии с этим выбором документы будут создаваться и/или редактироваться с помощью программ на вашем компьютере либо с помощью Google Docs или MS Office Online.

После нажатия кнопки Создать документ появляется окно выбора сервиса и формата документа:

  • При выборе создания документа с помощью программ на компьютере будет запущено соответствующее приложение на вашем компьютере, в нем будет создан и открыт на редактирование новый документ:

Документу будет присвоено стандартное имя, которое впоследствии можно изменить на желаемое через меню действий или редактирование отмеченных записей.

  • При выборе для создания документа сервиса Google Docs будет запущено соответствующее он-лайн приложение, после завершения работы с которым портал предложит сохранить документ:

    • При сохранении можно сразу задать желаемое имя для документа.

  • Создание и сохранение документов с помощью сервисов MS Office Online и Office365полностью аналогичны работе с Google Docs. При первом запуске MS Office Online или Office365 будет запрошен ввод данных учетной записи Майкрософт.

  • Открыть документ для просмотра можно, кликнув на его название на портале. Далее можно перейти к его редактированию, нажав кнопку

    и выбрав сервис для редактирования. При включенной синхронизации все изменения в документах отображаются оперативно и на портале, и на диске вашего компьютера, вне зависимости от вашего географического местоположения.


Совместная работа с документами
217 / 401

Документы также могут редактироваться одновременно несколькими пользователями. Совместное редактирование доступно для разделов Общий диск и Диск группы, если при настройке способа работы с документами выбрано В облаке.

Права доступа к файлам могут быть различными для отдельных групп сотрудников, рабочих групп и отдельных сотрудников.

Владелец файла или сотрудник, обладающий правом Полный доступ, может гибко настраивать права доступа к конкретному файлу. Для этого следует перейти по ссылке Общий доступ в меню действий файла

и задать права, как описано здесь.

При открытии документа на редактирование несколькими пользователями одновременно, у каждого из них в поле документа будут отображены цветные метки [image] в тех позициях, где находятся курсоры коллег.

При этом метки будут подписаны данными учетной записи сервиса, выбранного для редактирования (Google Docs или MS Office Online), если сотрудник авторизован на сервисе. В противном случае - каким-либо условным именем. Метки с их цветом и условным обозначением также будут продублированы в меню сервиса, например [image] и [image] .

Если же по каким-либо причинам одновременное редактирование документа несколькими пользователями нежелательно, то возможна блокировка документа (если в Настройках портала включена опция Разрешить блокировать документ для редактирования). Для этого в меню действий файла следует выбрать пункт "Заблокировать". Появится сообщение о блокировке и файл будет отмечен специальным значком:

Таким же значком будет помечен файл в синхронизированной через Битрикс24.Диск папке вашей операционной системы.

При попытке редактирования и сохранения заблокированного файла другим пользователем, ему будет продемонстрировано предупреждение:

После окончания редактирования и сохранения блокировку документа можно отменить, выбрав в меню действий файла пункт "Разблокировать".

В таблице истории изменений документа отображается название файла, его размер, точное время изменения и имя пользователя, редактировавшего файл. Из этой таблицы можно обратиться к любой версии - скачать её, удалить или восстановить.


Удаление и восстановление папок и файлов
218 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Удаление и восстановление папок и файлов

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

  • Удаление документов
  • Работа с Корзиной

Удаление документов

  • Для удаления документов нажмите кнопку Действия в строке с документом, который нужно удалить. Выберите действие Удалить в выпадающем списке. Вы можете переместить документ в Корзину, либо удалить безвозвратно:

    • Доступна также групповая операция удаления. Вы можете отметить папки и файлы, которые требуется удалить, нажать крестик на нижней панели управления, и по запросу переместить файлы и папки в корзину или отменить действие.

    Примечание: Для Диска установлена защита от случайного удаления. Если на документ установлен общий доступ, то удаление файла на локальном компьютере не удаляет документ для других участников Общего доступа - он останется доступным для них. На локальном компьютере файл больше не появится - он отключается от синхронизации с Диском.

    Внимание! Удаление файла на Диске удаляет его для всех участников Общего доступа. Перемещение файла в Корзину отменяет доступ для всех участников.

    Работа с корзиной

    Чтобы восстановить документ из Корзины, необходимо перейти в Корзину с помощью функции Показать: Корзину на контекстной панели.

    Вид Корзины может быть настроен так же, как настройка представления списка.

    Затем в меню действий документа выбрать команду Восстановить.

    Также можно воспользоваться кнопкой группового восстановления файлов и папок на правой панели.

    После этого документы будут восстановлены каждый в свою первоначальную папку.

    Внимание! Настройки Общего доступа не восстанавливаются при восстановлении файлов.

    Примечание: Учтите, что документы из Общий диск и из Мой диск удаляются в разные корзины, каждые в свою собственную.

    Срок хранения файлов в корзине не ограничен. Поэтому целесообразность их хранения оценивается пользователем самостоятельно. Так как количество доступного места для Общего диска и его файлов лимитировано для младших редакций «Битрикс24», то может потребоваться очистка корзины.

    При групповом удалении папок и файлов из корзины будет запрошено согласие на удаление документов навсегда.

    Чтобы очистить корзину полностью, необходимо нажать кнопку [image]. Система выдаст подтверждение на удаление и после согласия произведет очистку Корзины.

    Внимание! Для восстановления документа из корзины и очистки Корзины необходимо иметь соответствующие права. По умолчанию этот функционал доступен только администратору.


Публичные ссылки
219 / 401

Публичные ссылки

Для любого файла можно получить публичную ссылку, по которой файл может быть скачан даже неавторизованным в облаке пользователем.

Способы получения публичной ссылки:

  • Кликнуть на меню действий и выбрать пункт Получить публичную ссылку

Поверх списка будет активировано окно, содержащее ссылку Настройки и публичную ссылку, которую можно скопировать:

  • Отметить файл в колонке флажков, включить публичную ссылку, передвинув переключатель в правом меню в положение вкл и скопировать публичную ссылку из окна:

Перейдя по ссылке Настройки, вы сможете ограничить доступ к файлу по времени на заданное количество часов (минут, дней) или защитить его паролем.

Пользователь, которому будет передана ссылка, при переходе по ней сможет просмотреть фрагмент файла, скачать файл или поделиться ссылкой на него:

Сервис, с помощью которого просматривается файл, задается параметром Просматривать документы с помощью в Настройках портала.

Список файлов, для которых включена публичная ссылка, может быть просмотрен отдельно, с помощью функции Показать: Публичные файлы в контекстном меню. В этом списке можно также увидеть количество скачиваний каждого из таких файлов.

Примечание: Для документов в Общем диске, Моем диске и Дисках групп формируются разные списки публичных файлов, для каждого свой.

Пользователь, имеющий доступ к файлу, может отключить публичную ссылку, передвинув переключатель в положение выкл. В этом случае ранее полученная публичная ссылка станет неактивной, то есть просмотреть или скачать файл по ней станет невозможно. При необходимости можно снова включить публичную ссылку, она будет являться уникальной, так как генерируется заново при каждом включении.


Дополнительные операции с документами
220 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Фрейм "IFRAME"
Дополнительные операции с документами

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

  • Внутренние ссылки
  • Участие документа в бизнес-процессах
  • Пользовательские поля
  • История изменений

Внутренние ссылки

Для совместной работы над документами может использоваться внутренняя ссылка. Для её получения следует нажать кнопку Скопировать ссылку в форме просмотра документа.

Внутренняя ссылка может быть использована сотрудником, авторизованном на КП и имеющим соответствующие права, для работы с файлом - редактирования, копирования, в том числе на свой локальный компьютер, и т.д. При этом не нужно искать непосредственно сам файл в каталогах общего диска.

Участие документа в бизнес-процессах

Если функционал Бизнес-процессов включен, то для запуска бизнес-процесса нажмите на кнопку Действия [image] в строке с документом, выберите пункт меню Бизнес-процессы и шаблон бизнес-процесса:

Внимание! Данный пункт меню доступен при созданных бизнес-процессах. Для раздела Мой Диск бизнес-процессы недоступны.

Откроется страница Запуск бизнес-процесса, позволяющая задать параметры бизнес-процесса и запустить его.

Примечание: Элементы управления, связанные с бизнес-процессами, могут отсутствовать, если администратор системы не разрешил использование данного функционала.

Документ, участвующий в бизнес-процессах, помечается в папке Общий диск в режиме списка знаком [image]. При наведении курсора на этот знак появляется подсказка о количестве бизнес-процессов и заданий, в которых участвует документ.

Кликнув на число бизнес-процессов или заданий, можно перейти к просмотру соответствующих списков:

Число активных заданий бизнес-процессов также отображает цифра рядом с пунктом левого меню Бизнес-процессы. Кликнув по ней, можно перейти в список заданий:

Функционал, доступный из соответствующих списков, зависит от текущего статуса и шаблона бизнес-процесса.

Перемещение документа в Корзину не влияет на его статус в бизнес-процессе. Удаление документа навсегда удаляет также связанные с этим документом задания в бизнес-процессах.

Пользовательские поля

Если в каком-либо шаблоне бизнес-процесса используется действие [image] , то у документа Общего диска могут быть заданы или изменены Пользовательские поля. В форме просмотра свойств документа эти поля можно отредактировать.

История изменений

История изменения документа содержится в форме просмотра его свойств. Для просмотра свойств документа нажмите на кнопку Действия [image] в строке с документом и выберите пункт меню Открыть. Или дважды щелкните мышкой на иконке документа. Откроется форма свойств документа.

Из этой формы можно скачать, отредактировать документ, загрузить новую версию. Или просмотреть историю изменений документа:

Используя меню действий, можно восстановить или удалить более раннюю версию документа с помощью пунктов Восстановить или Удалить соответственно.

Примечания:
  1. Количество хранимых версий документов, как и количество документов, задается параметром Максимальное количество записей в истории документа в Настройках портала. Если же в параметре указано "Неограниченно", то лимитом является объем доступного места в облаке/тарифе хостинга. При невозможности синхронизации из-за отсутствия места имеет смысл удалить устаревшие версии документов.
  2. Если пользователь загружает новую версию документа и если между правками этого документа от одного и того же пользователя прошло меньше 5 минут, то последняя версия файла и новая загруженная версия склеиваются.


Работа с документами в ОС Windows
221 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Подключение папки как сетевого диска в ОС Windows
  • Подключение папки как сетевого диска через Битрикс24
  • Подключение папки как сетевого диска через Проводник
  • Подключение папки с помощью мастера добавления сетевого размещения
  • Отключение папки
  • Действия с документами\папками
  • Настройка общего доступа к папке

Любая папка из раздела Общий диск, доступ к которой разрешен в соответствии с правами пользователя, может быть подключена к любому компьютеру из сети как сетевой диск. Это справедливо для ОС Windows XP и выше.

Примечание: При подключении библиотеки документов в качестве сетевого диска на портале для них также будет доступен функционал бизнес-процессов.

Например, можно сделать так, что при загрузке нового файла "на сетевой диск" на портале автоматически будет запускаться определенный шаблон бизнес-процесса и выполнять требуемые действия.

Подключение общего диска как сетевого диска через Битрикс24

Для подключения общего диска, находясь в любом его разделе, выберите в меню настроек [image] пункт Сетевой диск:

Примечание: аналогично можно подключить Мой диск.

Появится окно подключения, скопируйте адресную строку из него:

Через команду Пуск > Выполнить вашей операционной системы Windows вызовите приложение cmd и вставьте в командную строку скопированную вами строчку после команды net use z:

Внимание! В случае сообщения, что имя локального устройства уже используется, смените букву сетевого диска (например с Z на Q).

Нажмите Enter, затем введите пароль от вашего аккаунта Битрикс24 и снова нажмите Enter.

Внимание! При вводе пароля символы могут не отображаться.

Внимание! Если пароль содержит кириллические символы, то подключение папки как сетевого диска невозможно. В этом случае следует сменить пароль через редактирование профиля или воспользоваться паролями приложений.

В случае успешного подключения вы увидите соответствующее сообщение в командной строке, а в сетевом размещении появится подключенный вами диск:

Подключение папки как сетевого диска через Проводник

Важно! Этот метод подключения в Windows XP работает с некоторыми ограничениями. В случае возникновения проблем обратитесь к Администратору портала.

Интерактивный видеоролик по подключению папки

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

р

Для подключения папки как сетевого диска запустите Проводник. Выберите в меню пункт Сервис > Подключить сетевой диск. Откроется диалог подключения сетевого диска:

В поле Диск назначьте букву для подключаемой папки.

В поле Папка введите путь до библиотеки: http://<ваш_сервер>/docs/shared/.

Примечание: путь до папки можно скопировать из адресной строки браузера, находясь в нужной папке.

Если необходимо, чтобы папка подключалась для просмотра при каждом запуске системы, установите флажок Восстанавливать при входе в систему.

Если вы хотите подключиться под неактивной в данный момент учетной записью, поставьте галочку в поле Использовать другие учетные данные, после чего откроется диалог операционной системы для авторизации:

Нажмите кнопку Готово, после чего в отдельном окне проводника откроется папка с документами:

Последующие открытия папки можно осуществлять через Проводник Windows, где папка отображается в виде отдельного диска, либо через любой файловый менеджер.

Внимание! При работе с сетевым диском возможны ограничения на работу с файлами размером больше определенного значения. Это ограничения операционной системы, а не 1С-Битрикс. По умолчанию в реестре стоит ограничение, нужно его увеличить до максимального значения. Для снятия ограничения в ветке реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters у параметра FileSizeLimitInBytes поставьте значение ffffffff.

Данная информация даётся только для сведения. Решение о её применении вы принимаете сами и под свою ответственность.

Если вы не умеете работать с реестром ОС Windows, то обратитесь к администратору.

Подключение папки с помощью мастера добавления сетевого размещения

Интерактивный видеоролик по подключению папки с помощью мастера

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

р

В диалоге подключения сетевого диска (см. здесь) пройдите по ссылке Подключение к сайту, на котором можно хранить документы и изображения, после чего запустится мастер добавления сетевого размещения:

Нажмите Далее, появится новое окно:

Нажмите Далее и в следующем окне укажите сетевой адрес ресурса, либо адрес в интернете:

Нажмите Далее и в следующем окне напишите имя для этого сетевого размещения:

Нажмите Далее, появится окно завершения настройки:

Нажмите Готово, после чего в отдельном окне проводника откроется подключенная папка.

Последующие открытия папки можно осуществлять через Проводник Windows, где папка отображается в виде отдельного диска, либо через любой файловый менеджер.

Отключение папки

Интерактивный видеоролик по отключению папки

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

р

Для отключения папки, подключенной как сетевой диск, нажмите на нее правой кнопкой мыши и выберите Отключить:

Чтобы отключить папку, подключенную с помощью мастера добавления сетевого размещения, кликните по ней правой кнопкой мыши и выберите Удалить:

Действия с документами\папками

Находясь в синхронизированной через Битрикс24.Диск папке вашей операционной системы, кликните по произвольному документу правой кнопкой мыши:

Открывшееся контекстное меню предоставляет вам несколько возможностей:

  • Битрикс24: Скопировать публичную ссылку - вы получаете публичную ссылку на документ в буфер обмена, о чем вам будет сообщено в соответствующем диалоговом окне. По данной ссылке документ может быть просмотрен или скачан любым пользователем.
  • Обсудить в Битрикс24 - данный документ будет добавлен в автоматически загруженном в вашем браузере сообщении живой ленты:

    Перед отправкой вам остается только добавить текст сообщения и выбрать получателей.

  • Открыть в Битрикс24 - документ будет открыт на портале в режиме просмотра.

Для файлов и папок, не синхронизируемых через Битрикс24.Диск, есть возможность сохранения на ваш Диск. Для этого нажмите правой кнопкой мыши по такому файлу\папке и выберите в контекстном меню пункт Отправить в Битрикс24:

После этого объект появится у вас на Диске.

Настройка общего доступа к папке

Вы можете перейти к диалогу настройки общего доступа синхронизируемой через Битрикс24.Диск папки непосредственно из окна проводника Windows.

Для этого кликните правой кнопкой мышки по нужной папке:

В открывшемся контекстном меню выберите пункт Битрикс24: Настроить общий доступ. После клика по нему левой кнопкой мыши, в браузере будет открыт диалог настройки общего доступа к папке.


Бизнес-процессы
222 / 401
Бизнес-процесс - это процесс обработки документа, для которого задана одна точка входа и несколько точек выхода и последовательность действий (шагов, этапов, функций), совершаемых в заданном порядке и в определенных условиях.

Инструмент Бизнес-процессы интегрирован с Общими документами и включает в себя действия, позволяющие согласовать, утвердить и опубликовать некоторый документ. Для создания новых и редактирования шаблонов бизнес-процессов используется Дизайнер бизнес-процессов.

Примечание: Функционал Бизнес-процессы, помимо Общего диска, также доступен и для Диска групп.

Включение бизнес-процессов

По умолчанию Бизнес-процессы не включены. Для их включения:

  • С помощью кнопки настроек вызовите диалог настройки свойств Общего диска:
  • Поставьте флажок в поле Активировать бизнес-процессы
  • Сохраните внесённые изменения.
После этого в меню кнопки настроек появится возможность работы с Бизнес-процессами:

Примечание: Работа с бизнес-процессами распространяется и на подключение общих документов как сетевого диска.
Другими словами, при работе с файлами через сетевой диск на портале для них можно создавать и запускать различные шаблоны бизнес-процессов.

Создание шаблонов типовых бизнес-процессов

Типовые бизнес-процессы - образцы часто используемых процессов, которые включены в состав сервиса Битрикс24 по умолчанию.

Типовые шаблоны бизнес-процессов создаются автоматически при установке продуктов «1C-Битрикс». Если по каким-либо причинам типовые процессы не были созданы при установке, то их можно создать следующим образом в Общем диске.

  • перейти на страницу Общий диск (Диски> Общий диск) ;
  • перейти к списку шаблонов бизнес-процессов с помощью пункта Бизнес процессы, находящегося в меню настроек, которое расположено в правой части окна:

    Примечание: Для персональных документов в разделе Мой диск бизнес-процессы включить нельзя.

  • воспользоваться соответствующей ссылкой для создания шаблонов бизнес-процессов.

    Удаление шаблонов типовых бизнес-процессов

    • Для удаления шаблона бизнес-процесса используйте пункт меню действий Удалить:

      • Важно: удалить шаблон незавершенного бизнес-процесса нельзя. То есть, если бизнес-процесс запущен на каком-то документе, то шаблон этого процесса не удаляется.

    Дизайнер бизнес-процессов

    Дизайнер предназначен для проектирования, создания и изменения бизнес-процессов.

    Механизм проектирования бизнес-процессов реализован за счет визуального программирования по технологии drag&drop, понятной и известной любому пользователю компьютера. Шаблон бизнес-процессов создается в особом визуальном конструкторе, который позволяет сотруднику, не владеющему программированием, задать нужный порядок бизнес-процесса, отобразить его специфичные потребности с помощью простых графических схем.

    Примечание: Создание БП - это программирование, хоть и без написания кода (в большинстве случаев). Требуется постановка задачи, алгоритмирование, тестирование - для этого нужны определенные навыки и базовая подготовка.

    Созданный шаблон бизнес-процесса может быть выполнен автоматически или вручную, в зависимости от настроек. В любое время может одновременно выполняться несколько экземпляров бизнес-процесса, и система занимается управлением выполнения этих экземпляров, сохраняя и восстанавливая их состояние по требованию. Ведется лог каждого экземпляра бизнес-процесса для дальнейшего анализа работы схемы и корректировки ее под новые условия.

    Визуальный конструктор - инструмент Дизайнера бизнес-процессов, который позволяет создавать и редактировать шаблоны бизнес-процессов.

    Для вызова визуального конструктора необходимо:

    • нажать кнопку настроек в контекстном меню Общего диска и выбрать пункт меню Бизнес-процессы:

    • на странице Шаблоны бизнес-процессов используйте кнопки контекстной панели Создать <тип_бизнес-процесса> или команду меню действий Изменить:

      Подробнее прочитать о работе с дизайнером можно в этом уроке.

    Внимание! В данном уроке бизнес-процессы рассмотрены с точки зрения работы с диском. Если вам необходима полная и подробная информация о создании и настройке бизнес-процессов, то ее можно получить из отдельного курса.

    Полезные ссылки:

    • Типы бизнес-процессов
    • Список действий
    • Шаблоны бизнес-процессов


Почта
223 / 401
Внимание! Отправка почты с Битрикс24 имеет ограничения на количество отправленных писем с одного адреса в течение получаса. На данный момент это ограничение составляет 100 писем. Ограничение может меняться в зависимости от нагрузки.

Сервис Битрикс24 позволяет интегрировать сторонние почтовые ящики. Работа с почтой этих почтовых ящиков на данный момент ведётся не в интерфейсе корпоративного портала, а в веб-интерфейсе подключаемого почтового сервиса. А в Битрикс24 у пункта Почта будет выводиться число новых сообщений. Битрикс позволяет подключить к одному пользователю только один почтовый ящик.

Подключение почтового ящика производится по протоколу IMAP. Для этого используйте пункт Почта в левом меню, либо пункт меню личной страницы:

Примечание: Пользователю с администраторскими правами доступно подключение и управление корпоративной почтой (пункт меню Управление почтовыми ящиками). Это управление осуществляется по аналогии с управлением почтой в облачной версии Битрикс24.

Нажмите Подключить в области Почтовые сервисы:

Затем кликните по иконке вашего почтового сервиса, введите данные учетной записи и задайте настройки интеграции с CRM:

Нажмите Подключить и в случае успешной авторизации вы увидите соответствующее сообщение:

По ссылке Перейти в почту в новом окне откроется ваш почтовый аккаунт.

После этого в вашем левом меню будет показано количество новых писем, а щелчок по пункту Почта левой кнопкой мыши откроет новую вкладку в браузере для просмотра почты:

Примечание: В новой вкладке откроется веб-интерфейс вашего почтового сервиса.

Примечание: Если рядом с пунктом меню появляется восклицательный знак: , это значит, что при проверке почты произошла ошибка .

Позднее вы всегда можете перейти к удалению\настройке\проверке интеграции с почтой с помощью личного меню, упомянутого в начале урока:

Например, вы можете изменить пароль или указать адреса, почта с которых не должна передаваться на ваш портал:

IMAP и MS Exchange

При использовании почтового сервера, не указанного в списке логотипов, или существующего корпоративного почтового сервера воспользуйтесь, соответственно кнопкой IMAP или MS Exchange. Кроме логина и пароля в обоих случаях вам нужно будет указать параметры сервера:

Где:

  • Адрес веб-интерфейса почтового сервера - вида https://owa.company.ru (https://company.ru/owa), уточните у администратора.
  • Адрес сервера - адрес вашего IMAP сервера (уточните у администратора).
  • Порт - указать порт защищенного соединения.
  • Защищенное соединение - да, если есть.

После подключения сервера необходимо будет вновь вести логин и пароль в открывшемся окне веб-клиента для запоминания учётных данных в файлах cookie.


Создание бесплатного почтового ящика
224 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Создание бесплатного почтового ящика

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Битрикс24 дает возможность создания неограниченного по размеру почтового ящика с защитой от спама и антивирусом. Для этого перейдите к настройкам интеграции почты.

Важно! Администратор вашего Битрикс24 всегда будет иметь полный доступ к создаваемому почтовому ящику. Используйте этот почтовый ящик только для работы.

Нажмите Подключить в области @bitrix24.ru:

Ниже введите имя вашего будущего ящика и пароль:

Примечание: в случае ввода недопустимого имени система сообщит об этом до непосредственного подключения ящика:

После завершения ввода нажмите кнопку Подключить. Завершите регистрацию, заполнив появившуюся форму:

Вы будете оповещены об успешном завершении регистрации соответствующим окошком:

Количество новых писем будет отображаться в левом меню вашего Битрикс24:

Чтобы перейти к вашему почтовому ящику, кликните по данному пункту меню, либо воспользуйтесь сайтом Яндекса:


Настройка Outlook для подключения почты Битрикс24
225 / 401

Чтобы вы могли работать с вашим почтовым ящиком Битрикс24 через Outlook, необходимо добавить в него вашу учетную запись почты. Это можно сделать в разделе Файл программы Outlook, кликнув по соответствующей кнопке:

Затем выберите ручную настройку и нажмите Далее:

Выберите пункт Электронная почта Интернета:

Примечание: если у вас подключен собственный домен, то следует выбрать второй вариант списка и обратиться к администратору.

Нажмите кнопку Далее.

В следующем окне следует указать все необходимые настройки:

Разберем некоторые из них:

  • Адрес электронной почты - укажите адрес подключаемого ящика.
  • Тип учетной записи - рекомендуется выбирать IMAP:

  • Сервер входящей почты - для Яндекса это imap.yandex.ru.

    Примечание: при работе по протоколу POP3 следует указать pop.yandex.ru.

  • Сервер исходящей почты - для Яндекса это smtp.yandex.ru.
  • Пользователь - полностью введите имя вашего почтового ящика на Битрикс24.
  • Пароль - укажите пароль от вашего почтового ящика Битрикс24.

Нажмите на кнопку Другие настройки... и на закладке Сервер исходящей почты укажите параметры как на скриншоте ниже:

На закладке Дополнительно выставьте порты и тип шифрованного подключения в соответствии с показанным на скриншоте ниже:

Примечание: для типа учетной записи POP3 указываются следующие порты:
  • POP3-сервер: 995;
  • SMTP-сервер: 465.

Сохраните внесенные изменения и нажмите Далее.

Вы будете оповещены о результатах проверки почты:

Успешное создание учетной записи завершится окном следующего содержания:

Теперь подключенный ящик будет показываться в Outlook:


CRM
226 / 401

Сопровождение потенциального клиента от первого контакта до совершения сделки обычно выполняется с помощью CRM.

Что такое CRM?

Система управления взаимодействием с клиентами (или CRM, сокр. от англ. Customer Relationship Management System) — система, предназначенная для повышения уровня продаж, оптимизации маркетинга и улучшения обслуживания клиентов. В CRM сохраняется информация о клиентах и история взаимоотношений с ними для последующего анализа результатов.

Вы можете посмотреть сценарии реального использования CRM менеджерами компаний в разделе сценарии использования CRM.


Этапы внедрения CRM
227 / 401

Внедрение CRM - процесс настройки программного обеспечения под определенные условия использования, а также обучения пользователей работе с программным продуктом.

В общем случае, внедрение CRM в повседневную работу организации требует выполнения следующих шагов:

  • Настройка CRM под конкретный бизнес
  • Наполнение CRM данными
  • Начало работы
  • Интегрирование CRM с другими программными средствами, используемыми в организации

Настройка CRM под конкретный бизнес

Поскольку виды бизнеса и технологии ведения дел могут существенно отличаться, то не всегда предустановленные в CRM значения устроят пользователя. Скорее всего, потребуется настроить:

  • Справочники (CRM > Настройки > Справочники)

Можно задать собственные наименования, количество, порядок следования для стадий сделки, источников лидов, статусов счетов, типов контактов и компаний и прочего.

Подробнее о работе со справочниками - в уроке Справочники.

  • Товары (CRM > Товары)

Основная информация о товарах хранится в каталоге, где можно добавлять товары и разделы, менять представление списка, редактировать товары.

Подробнее о заполнении каталога товаров - в уроке Товары.

Для корректной подачи коммерческого предложения, выставления счета, оформления сделки понадобится настроить также Единицы измерения (CRM > Настройки > Единицы измерения) и Налоги (CRM > Настройки > Налоги).

  • Шаблоны (CRM > Настройки > Почтовые шаблоны)

При отправке типовых писем, а особенно при осуществлении массовых рассылок, приходится часто повторять один и тот же текст, например, формулы приветствия или прощания. В то же время, более благоприятное впечатление производят персонализированные письма, то есть, как минимум, включающие имя адресата. В почтовых шаблонах можно настроить автоматическую вставку имени адресата в приветствие, имени и фамилии менеджера в подпись, краткого анонса в тему письма.

Подробнее о настройке почтовых шаблонов - в уроке Почтовые шаблоны.

  • Реквизиты (CRM > Настройки > Пользовательские поля)

При отправке клиентам коммерческих предложений, счетов, при оформлении сделок часто приходится использовать стандартные реквизиты - например, ИНН, логотип, печать и подпись ответственного лица. Их можно определить и настроить в разделе Пользовательские поля, а затем использовать в формах документов.

Таким же образом можно настроить и в дальнейшем использовать реквизиты заказчика, клиента.

  • Формы документов

Используя настроенные пользовательские поля, можно создать и сохранить удобные и принятые в корпоративной документации формы документов - счетов, предложений, сделок, карточек клиента и компании.

Кроме того, создавать поля и задавать их характеристики (множественность, обязательность, отображение в списках) можно непосредственно при настройке формы.

Для удобства работы с выборками сущностей по определенным критериям следует настроить фильтры. Их также можно сохранить для каждой формы документа и в дальнейшем оперативно применять.

  • Права доступа

Права доступа требуется настроить в соответствии с организационной структурой компании. То есть продумать распределение ролей сотрудников, отделов, проектов и установить на странице CRM > Настройки > Права доступа соответствующие значения.

Подробно действия по управлению доступом к сущностям и настройкам CRM описаны в уроке Права доступа.

Таким образом можно разграничить права между отделами, установить права на конкретные документы и действия с ними, закрыть доступ к ЦРМ конкретным сотрудникам и т.п.

Наполнение CRM данными

Для получения данных о клиентах наиболее удобным является применение CRM-форм, разработка которых полностью интегрирована в Битрикс24 и не требует специальных навыков и знаний. Формы создаются в специальном конструкторе, доступ к ним может быть организован как по публичной ссылке, так и с помощью размещения HTML-кода на странице сайта. При заполнении формы клиентом данные сразу попадают в CRM, что позволяет довольно быстро наполнить CRM данными "с нуля".

Если же в работе компании уже использовались какие-либо структурированные данные, относящиеся к управлению взаимоотношениями с клиентами, то их можно импортировать в CRM Битрикс24. Для этого используются следующие методы:

  • Встроенный функционал импорта. Позволяет импортировать Контакты, Компании, Сделки, Лиды. Импорт осуществляется из специально подготовленного файла .csv. Кроме того, импорт Контактов может осуществляться списком непосредственно из vCard (в формате vCard), GMail, Outlook, Yandex, Yahoo! Mail, Mail.Ru.
  • Приложения Маркетплейс. Разработаны приложения для переноса данных из Basecamp, Zoho CRM, Yammer, Мегаплан.

Начало работы

В общем случае, возможны два основных сценария работы с CRM. Они отличаются сущностью, с которой начинается работа, то есть "точкой входа" или стартовым пунктом. Начинать работу можно с лида или со сделки.

Лид - потенциальный клиент, визитка, первоначальные "сырые" данные, результат заполнения какой-то формы - это сущность, над которой надо поработать, чтобы получить клиента.

Лид является основным документом, если у организации имеются источники постоянного получения лидов. Например:

- используется телефония, в качестве лидов фиксируются как входящие, так и пропущенные звонки.

- база данных с "холодными" лидами в виде файлов,например, импортирование данных контакт-листа из почты.

- лэндинги.

- веб-формы. То есть создается форма на сайте, сопоставляются ее поля с карточкой лида, автоматически получаем новый лид из заполненной на сайте формы.

- почта. Подключаем свой домен, интегрируем почту с CRM, новые входящие письма становятся новыми лидами, повторные письма автоматически прикрепляются как события к контактам или компаниям в CRM.

- другие приложения, например, из Маркетплейс.

Порядок работы, если "точкой входа" является лид, будет таким. Завести лид, конвертировать его в контакт или компанию, направить контакту коммерческое предложение, далее счет. После утверждения счета заключить и оформить сделку, отмечать её стадии. После закрытия сделка будет учитываться в отчете менеджера.

Сделка - заказ клиента, в котором менеджер фиксирует контактное лицо (контакт, компания), выбранные товары или услуги, обозначает вероятность заключения сделки и стремится пройти все стадии и успешно закрыть сделку.

Сделка является основным документом, если у компании нет постоянного источника получения лидов.

Порядок работы, если "точкой входа" является сделка, будет следующим: одновременно с оформлением сделки завести контакт или компанию, направлять им коммерческие предложения и счета. Продвигать сделку по стадиям. После закрытия сделка будет учитываться в отчете менеджера.

Для минимизации количества рутинных операций по заведению лидов, контактов, оформлению коммерческих предложений и др. в CRM удобно использовать бизнес-процессы.

Для совмещения обоих подходов в CRM Битрикс24 внедрены CRM-формы. Они позволяют создавать несколько сущностей одновременно при заполнении полей формы.

Интегрирование CRM с другими программными средствами, используемыми в организации

В настройках CRM предусмотрена возможность интегрировать систему с:

  • интернет-магазином для создания заказов в магазине через сделки в CRM, а также импорта сущностей из магазина в CRM;
  • "1С: Предприятие" для обмена счетами и товарами;
  • веб-формой для создания и обработки лидов;
  • почтой для добавления писем к событиям сущности;
  • телефонией для повседневной работы менеджера.

Кроме того, используя методы REST API можно создавать интеграции практически с любым сайтом для полноценной работы с любыми сущностями CRM. Например:

  • "1С: Зарплата и управление персоналом" (только для коробочной версии) для заполнения кадровой базы данных
  • различными страницами лендинга (landing page) для получения лидов

В главе Сценарии использовании CRM приведены несколько примеров настройки параметров системы CRM под требования различных бизнесов.


Общие сведения
228 / 401

Для начала определимся с терминами, понимание которых в рамках CRM может отличаться от общеупотребительного:

  • Лента:
    • Лента сущности - перечень дел и событий сущности, отображающийся на закладке ее формы просмотра;
    • Лента CRM - список дел и событий, на которые подписан пользователь, отображающийся на отдельной странице системы CRM.
  • Дело - задача, письмо, звонок или встреча, привязанные к какой-либо сущности CRM.
  • Контакт - запись о личности, с которой было общение по поводу профессиональной деятельности, Визитная карточка другими словами.
  • Компания - запись о компании, которая имеет какую-то форму сотрудничества (либо может иметь сотрудничество) с вашей компанией.
  • Лид - запись о какой либо форме контакта (телефон, e-mail, очная встреча и так далее), которая имеет потенциальную возможность перерасти в сделку.
  • Событие - какая-либо информация, влияющая на сущность.
  • Сделка - запись о работе с Клиентом, Компанией по поводу продажи товара.
  • Предложение - сущность, ориентированная на ознакомление клиента с предметом потенциальной сделки.


Функционал раздела
229 / 401

Для различных ролей доступ к CRM несколько различается.

Ниже в таблице приведен функционал, соответствующий различным ролям сотрудников по умолчанию, и указаны соответствующие страницы:

Функционал | Страница | Права пользователя
Мониторинг событий в Ленте | CRM > Лента | Сотрудник
Мониторинг списка Мои дела | CRM > Мои дела | Сотрудник
Добавление событий | Страницы разделов контакты, компании, лиды, сделки, либо страница детального просмотра сущности | Сотрудник
Поиск сущности | Фильтр, пресеты на страницах сущностей, поиск CRM | Сотрудник
Настройки CRM | CRM > Настройки | Менеджер
Добавление групп пользователей, ролей, назначение прав доступа | CRM > Настройки > Права доступа | Администратор
Действия с сущностями | Страницы сущностей | Менеджер
Контроль дубликатов | Страницы сущностей | Менеджер
Настройка и редактирование полей формы | Профиль сущности | Менеджер
Настройка и редактирование пользовательских полей | CRM > Настройки > Пользовательские поля | Менеджер
Сохранение, сброс настроек профиля | Профиль сущности | Менеджер
Добавление лида | CRM > Лиды | Менеджер
Конвертация лида | CRM > Лиды | Менеджер
Удаление сущности | Страницы сущностей | Менеджер
Добавление сделки | CRM > Сделки | Менеджер
Направления сделок | CRM > Сделки | Администратор портала, пользователи в соответствии с настройкой прав.
Настройка аналитических отчетов по сделкам | CRM > Сделки | Менеджер
Интеграция с интернет-магазином | CRM > Настройки > Интернет-магазины | Администратор
Управление товарами и разделами | CRM > Товары | Менеджер
Управление валютами | CRM > Настройки > Валюты | Менеджер
Управление налогами и местоположениями | CRM > Настройки > Налоги и местоположения | Менеджер
Управление единицами измерения | CRM > Настройки > Единицы измерения | Менеджер
Выставление счёта | CRM > Счета | Менеджер
Интеграция с 1С:Предприятие | CRM > Настройки > Интеграция с 1С:Предприятие | Администратор
Интеграция с почтой | CRM > Настройки > Интеграция с почтой | Администратор
Настройка почтовых шаблонов | CRM > Настройки > Почтовые шаблоны | Менеджер
Действия с шаблонами бизнес-процессов | CRM > Настройки > Бизнес-процессы | Менеджер
Работа с отчетами | CRM > Отчеты | Руководство
Просмотр диаграммы Воронка продаж | CRM > Воронка продаж | Руководство


Поиск
230 / 401

Поиск любой сущности CRM может быть осуществлен с помощью фильтрации таблицы этой сущности по любому из полей или их сочетанию. Рассмотрим поиск на примере контактов. Отличия настройки фильтра для других сущностей оговариваются отдельно.

  • Фильтр
  • Пресеты
  • Использование поиска CRM

Фильтр

Поиск контактов можно осуществить на странице Контакты с помощью панели поиска, расположенной над контекстной панелью:

Используйте предустановленные пресеты, либо разверните панель фильтра и укажите другие условия поиска:

  • Найти - введите полностью или частично имя, фамилию, электронный адрес или телефон, и в соседнем поле, нажав на поле со стрелочками, укажите среди каких данных осуществлять поиск:

    Примечание: Обратите внимание, что не для всех полей работает прямой поиск по вхождению (по совпадению нескольких символов или части поля). Например, для поиска по фрагменту телефонного номера следует окружить искомый фрагмент символами %.
  • Список компаний - нажмите ссылку Выбрать и вы попадете на вкладку Поиск, где левым щелчком мыши можно указать компанию, контакты с которой требуется найти. Если вы начнете вводить символы в текстовое поле, то система автоматически отобразит те компании, которые содержат их в своем названии:

    Вкладка Последние отображает последние из ранее выбранных компаний.

  • Тип контакта - выделите левым щелчком мыши тип контактов, по которому производить поиск. Зажав клавишу ctrl можно выделить несколько типов.
  • Дата изменения - нажмите на поле со стрелочками и в выпадающем списке укажите дату или период времени, за который произошло последнее изменение искомого контакта.

    При выборе варианта за послед. указывается число дней, измененные контакты за которое (от текущей даты), следует вывести.

    В случае выбора варианта за послед. для поля Предполагаемая дата закрытия в списке Сделок, выборка сверху ограничивается текущей датой, исключая сделки, ожидающие закрытия в будущем.

    При выборе варианта точно в появляющемся соседнем поле с помощью календаря можно указать дату изменения контакта:

    При выборе позже и раньше, укажите дату, позже или раньше которой были произведены изменения искомого контакта.

    Вариант Интервал с помощью календарей позволяет задать временной промежуток, за который были совершены изменения контакта.

  • Создан CRM-формой - те сущности, которые могут быть созданы автоматически из CRM-формы (см. Дополнительные параметры формы), могут быть также отфильтрованы в списке по этому признаку и по конкретной CRM-форме.
  • UTM метки - по одной или нескольким UTM-меткам можно отобрать сущности, созданные из CRM-форм, размещенных на конкретных страницах.

С помощью кнопки [image] можно добавлять\убирать новые условия на панель фильтра. При нажатии на неё будет развернут список всех полей сущности, доступных для фильтрации.

Для лидов, контактов и компаний возможна также фильтрация по наличию/отсутствию номера телефона и e-mail адреса. Для этого нужно выбрать соответствующие пункты из списка полей

и отметить "птичками" параметры поиска:

Нажмите Отмена для очистки всех полей поиска и вывода всех сущностей в список.

Нажмите Найти для начала поиска. Будут выведены контакты, удовлетворяющие условиям поиска.

Если по заданным критериям контактов не найдено, будет выведено соответствующее сообщение:

Пресеты

В системе уже имеются предустановленные фильтры Измененные мной и Мои контакты, кликнув по которым можно произвести поиск по уже выставленным параметрам:

Для пользователя CRM есть возможность сохранить фильтры с собственноручно настроенными параметрами поиска. Для этого нужно выбрать нужные настройки фильтра и нажать на закладку с плюсом:

Введите название нового предустановленного фильтра и нажмите Сохранить, после чего добавленный вами пресет появится в виде новой закладки на панели фильтра.

Для изменения настроек фильтра и его удаления используйте кнопку снизу:

  • Сохранить - выберите данный пункт для сохранения внесенных изменений в настройки фильтра.
  • Сохранить как - выберите данный пункт для сохранения внесенных изменений в новом фильтре с другим названием.
  • Удалить - нажмите чтобы удалить выбранный фильтр.

Чтобы убрать все параметры поиска, кроме поля Найти, щелкните по пункту Скрыть все условия. Чтобы показывались все имеющиеся параметры поиска, нажмите Показать все условия.

Примечание: есть возможность фильтрации сущностей по пользовательским полям, а сделок и лидов - по товарам.

Использование поиска CRM

На любой странице CRM есть специальный поиск для сущностей, в результатах которого не будет "лишних" данных портала:

Также сущности CRM можно искать через общий поиск:


Профили
231 / 401
  • Профиль контакта:
    • О контакте
    • Настройка и редактирование полей формы
    • Закладка "Лента"
    • Закладка "Дела"
    • Закладка "Сделки"
    • Закладка "Предложения"
    • Закладка "Реквизиты"
    • Закладка "Счета"
    • Закладка "Компании"
    • Закладка "Лиды"
    • Закладка "Бизнес-процессы"
    • Закладка "Связи"
    • Закладка "История"
    • Контекстная панель
  • Профиль компании
  • Профиль сделки\лида
  • Профиль предложения
  • Профиль счёта

Профиль контакта

Со страницы списка контактов можно посмотреть профиль любого лица из списка контактов. О том, как перейти к просмотру профиля, написано в уроке Контакты.

Об управлении формой, представленной на странице профиля контакта, можно узнать из урока Формы отчетов.

О контакте

Здесь вы можете узнать информацию о данном лице. Некоторая информация представлена в виде ссылок. При наведении курсора на ссылку можно просмотреть данные по соответствующей сущности, а при нажатии на ссылку - перейти к форме редактирования.

Примечание: в различных контактах поля могут отличаться, в зависимости от вносимых при добавлении (редактировании) контакта данных.

Настройка и редактирование полей формы

Вы можете скрывать некоторые поля и удалять разделы с помощью "крестика" и редактировать их название с помощью пиктограммы карандаша справа от поля, менять их месторасположение, перетаскивая за значок меню действий слева от поля. В том числе, необходимые поля можно разместить в "шапке" формы контакта, а "шапку" закрепить с помощью "гвоздика". В этом случае информация, размещенная в "шапке" будет всегда видна при прокручивании формы.

Примечание: Поля из вкладок формы не могут быть размещены в "шапке".

Вы можете как отредактировать информацию в форме, так и изменить настройку самой формы с помощью пиктограммы карандаша в контекстной панели.

При редактировании формы в конце раздела О контакте (Компания, О сделке, О предложении и т.п.) появятся ссылки Добавить поле, Добавить раздел и Показать поле.

При клике по ссылке Показать поле демонстрируется список из доступных для данной сущности справочников и пользовательских полей, если они были созданы заранее.

Клик по ссылке Добавить раздел позволяет добавить новый раздел и сразу настроить его название и расположение.

Кликнув по ссылке Добавить поле можно перейти к добавлению и настройке пользовательского поля.

Сначала следует выбрать тип поля из списка:

Примечание: Не все типы полей доступны при добавлении поля в форму. Полный перечень типов полей доступен при добавлении пользовательского поля из раздела CRM > Настройки > Пользовательские поля.

Затем ввести его наименование и нажать кнопку Сохранить. Далее можно ввести значение поля для данного контакта, и продолжить добавление полей:

Добавленные поля сохраняются в перечне пользовательских полей той сущности, в форму которой они были добавлены и удалить их можно будет только из этого перечня.

По умолчанию настроенная под индивидуальные требования форма сохраняется для всех записей данной сущности только для настроившего её пользователя. В списке действий в заголовке формы можно выбрать сохранение настроек для всех пользователей, сброс настроек, т.е. возврат к стандартным настройкам, или же сброс настроек для всех пользователей.

Закладка "Лента"

На данной закладке можно просмотреть историю событий данного контакта и просроченные\невыполненные дела:

События в ленте расположены в хронологическом порядке и закрыты от редактирования.

Из Ленты вы можете создавать дела для контакта.

Сообщения, созданные на закладке Лента, публикуются в общей Ленте CRM.

Закладка "Дела"

Здесь вы можете производить различные действия с делами контакта, а также добавлять новые события, задачи и писать письма.

По умолчанию показаны все дела, в том числе и дела лидов, если контакт был получен путем конвертации лида. Однако можно отфильтровать отображаемые на данной закладке дела:

Под понятием Мои текущие\выполненные дела подразумеваются дела, в которых вы являетесь ответственным.

Закладка "Сделки"

Здесь представлены сделки с данным контактом.

Здесь же возможно редактирование сделок и добавление новых.

Закладка "Предложения"

На данной закладке можно просмотреть и добавить предложения данному контакту.

Закладка "Реквизиты

Здесь можно удалить, копировать, отредактировать или добавить новые реквизиты контакта. При добавлении реквизитов следует выбрать шаблон из доступных.

При добавлении и редактировании реквизитов в специальной форме будут представлены те поля, которые были заданы при настройке шаблонов реквизитов. После их заполнения следует сохранить реквизиты.

Закладка "Счета"

На данной закладке вы можете управлять счетами для данного контакта и создавать новые на основе его данных.

Также здесь указывается сумма оплаченных данным контактом счетов.

Закладка "Компании"

На данной закладке расположена информация о компании, в которой работает контакт.

Вы можете работать с компанией с помощью ее меню действий:

Закладка "Лиды"

На этой закладке указаны лиды, которые были сконвертированы в данный контакт.

Примечание: вкладки Лиды может не быть, если в контакт не было сконвертировано ни одного лида.

Закладка "Бизнес-процессы"

На данной вкладке можно работать с шаблонами бизнес-процессов.

Закладка "Связи"

На этой вкладке собраны все сущности, тем или иным способом связанные с контактом:

Закладка "История"

На данной вкладке приведены события и действия, связанные с контактом и произведенные над ним:

Здесь же вы можете добавить событие к контакту с помощью кнопки + Событие и осуществить выборку событий с помощью кнопки Фильтр. Удалить ненужную запись из Истории можно, выбрав в меню действий команду Удалить.

Контекстная панель

Контекстная панель представлена в следующем виде:

  • Портрет - открывает страницу с виджетами Портрет контакта, где в графическом виде представлены инструменты контроля нагрузки и качества обслуживания.
  • Следить - подписывает вас на трансляцию событий данного контакта в вашу ленту CRM.
  • Редактировать - позволит вам редактировать контакт. О полях, которые будут в форме редактирования контакта, вы можете прочитать в уроке Добавить контакт.
  • Копировать - при нажатии на эту кнопку информация о контакте копируется, открывается форма добавления нового контакта, поля которой будут заполнены скопированными данными.
  • Еще - открывает доступ к пунктам Добавить контакт, Добавить сделку и Удалить контакт.

Профиль компании

Закладки профиля компании и контекстная панель полностью аналогичны таковым для профиля контакта.

На закладке История, во второй таблице, представлена история изменения контактов компании.

Примечание: вкладка Лиды не отображается, если с компанией не связано ни одного лида.

Профиль сделки\лида

Закладки профиля сделки\лида аналогичны таковым для профилей контакта и компании.

Примечание: в профиле сделки закладки Лиды не будет, если сделка не получена путем конвертации лида. Для лидов нет закладки Счета.

Находясь в профиле сущности вы можете прямо там редактировать компании, контакты, действия, счета или лиды. Для этого перейдите на соответствующую закладку и в меню действий нужной сущности выберите пункт меню Редактировать.

На закладке Товар перечислены товары сделки\лида. Нажмите Добавить строку чтобы добавить еще:

На закладке Автоматизация можно настроить роботов и триггеры на изменение статуса сделки\лида.

Лид можно конвертировать в контакт, компанию и/или сделку непосредственно из его профиля с помощью соответствующей кнопки на контекстной панели.

Профиль предложения

Закладки профиля предложения аналогичны таковым для профилей сделки\лида.

На закладках Товары, Сделки, Счет, Связи, История можно работать с соответствующими сущностями.

Профиль счёта

Профиль счёта представлен в следующем виде:

При нажатии кнопки Отправить по Email будет открыта форма создания письма, к которому будет приложен счёт в формате .pdf. В поле От кого и Кому будет выставлен ваш и клиента электронный адрес соответственно.

При нажатии кнопки Ссылка на счет выдана ссылка на онлайн счет.


Старт CRM
232 / 401

Страница Старт CRM имеет двойное назначение. Во-первых, она демонстрирует основные возможности CRM пользователям, только начинающим освоение системы. Во-вторых, для менеджеров отдела продаж она служит индикатором эффективности работы отдела, т.к. наглядно представляет все основные показатели и процессы в продажах - входящие коммуникации, количество лидов, которые нуждаются в обработке, ситуацию с продажами и повторными продажами за выбранный период.

При переходе к CRM страница Старт по умолчанию включается первой. В её верхней части графический элемент из цветных блоков в общем виде демонстрирует направление движения продажи по этапам - от первого контакта (коммуникации) с клиентом через обработку лида и работу со сделкой к желаемому итогу - денежным поступлениям от продажи.

Слева перечислены все возможные каналы коммуникаций с клиентами, в том числе подключенные на вашем портале открытые линии. Даже если какая-либо открытая линия в данный момент выключена, она отображается в перечне:

Подсчет данных ведется по отчетному периоду и другим параметрам, указанным в фильтре. Цифры в цветных блоках являются суммой цифр в колонках и обозначают следующее:

- доступны 75 каналов коммуникаций, из них подключены 25. Не подключенные открытые линии отображаются серым цветом, имеются ссылки для их подключения;

- было выполнено 2 звонка - один с помощью телефонии, другой через виджет Обратный звонок. Клик по цифре в колонке переводит на страницу Мои дела, отфильтрованную по этим звонкам, где содержится подробная информация о них;

- ждут обработки 5 лидов, из них 4 получены через CRM-формы (какие именно, можно узнать, раскрыв список CRM-форм кликом по плюсу), 1 с помощью Обратного звонка. Клик по цифре в колонке переводит на страницу Лиды, отфильтрованную по каналу получения, где содержится подробная информация о них;

- в работе находится 1 сделка, полученная через CRM-форму "Заявка на кредит". Клик по цифре в колонке переводит на страницу Список сделок, отфильтрованную по каналу получения, где содержится подробная информация о ней;

- продажи за указанный в фильтре период составили 12500 руб., сделки были получены через канал коммуникации CRM-форм "Контактные данные". Клик по цифре в колонке переводит на страницу Список сделок, отфильтрованную по каналу получения, где содержится подробная информация о сделках.

Нижняя часть страницы Старт CRM содержит виджеты аналитических отчетов.

По умолчанию имеются виджеты:

  • круговая диаграмма Количество дел, сгруппированных по каналам коммуникации;
  • Сумма выигранных сделок и Сумма сделок в работе за отчетный период;
  • график Сумма выигранных сделок в течение отчетного периода;
  • гистограмма Сделки в работе по сотрудникам, включающие в себя сделки в работе и выигранные сделки в течение отчетного периода.

Все виджеты могут быть настроены на отображение нужной информации, как описано в соответствующем уроке.


Лента
233 / 401

Данный инструмент, на странице CRM > Лента предназначен для удобного мониторинга событий CRM, обсуждения их с коллегами, а также для работы с сущностями.

Изначально активен режим Моё, при котором пользователю показываются следующие события:

  • автором которых является сам пользователь;
  • в которых он значится адресатом;
  • является ответственным за сущности, с которыми эти события происходили. Чтобы не видеть события какой-либо сущности, используйте кнопку [image] формы ее просмотра;
  • к сущностям, за которыми он следит.
Примечание: Пользователь не может отказаться следить за сущностями, автором которых он является.

При переключении на режим Вся CRM будут показаны все события, просмотр которых не ограничен правами доступа пользователя.

Для выборки событий ленты CRM можно использовать фильтр:

При выборе значения Фильтр... можно осуществить поиск событий по дате и автору:

Написание сообщений в ленту CRM осуществляется аналогично таковому для живой ленты. При выборе получателей сообщения вы можете указать сущности CRM, в ленту которых это сообщение будет добавлено:

Начните вводить название сущности и она отобразится в форме выбора.

Важно! Для выбора доступны только те сущности, к которым вы имеете права доступа. Дела доступны ответственным в живой ленте CRM вне зависимости от их доступа к сущностям, к которым привязаны дела.

Из ленты вы также можете создавать звонки, задачи, встречи, e-mail.

В области Нужно сделать показаны пять наиболее просроченных дел. Если просроченных дел нет, то выводятся дела с наиболее близким к текущему крайним сроком выполнения. При отметке галочкой дело переводится в статус завершенного.

Цифры в красных кружках на панели счетчиков возле сущностей CRM обозначают:

  • для Моих дел - количество невыполненных дел с установленным сроком завершения, за которые вы являетесь ответственным;
  • для Лидов - сумма лидов без дел и лидов с просроченными делами, за которые вы являетесь ответственным. Подсчитываются только лиды, созданные вами;
  • для Контактов - количество контактов, имеющих невыполненные дела с истекшим сроком завершения, за которые вы являетесь ответственным;
  • для Компаний - количество компаний с просроченными делами, за которые вы являетесь ответственным;
  • для Сделок - суммируются сделки, за которые вы являетесь ответственным, не имеющие дел и сделки с просроченными делами, за которые вы являетесь ответственным.


Мои дела
234 / 401

На странице CRM > Мои дела представлен список запланированных и выполненных дел: задач, писем, встреч, звонков, визитов:

В случае, если до появления в системе связи дел с календарем, у вас уже имелись календарные события и задачи с привязкой на сущности CRM, то на странице Мои дела вы увидите информационную табличку с предложением провести конвертацию таких событий и задач в дела (доступно только администраторам):

Различные типы дел помечены разными пиктограммами.

Перечень пиктограмм

- задача

- входящее письмо

- исходящее письмо

- встреча

- входящий звонок

- исходящий звонок

- запись встречи с визит-трекера

- история сообщений чата открытой линии

- заполнение CRM-формы

- импорт контакта из 1с

Кликнув на дело в списке, можно подробно просмотреть все данные о нём отдельном окне:

На странице Мои дела можно поставить задачу, аналогично созданию задачи в Живой ленте. Создаваемая задача будет иметь в названии префикс CRM.

Также можно написать письмо и отправить его с интегрированного почтового ящика:

Можно запланировать звонок или встречу, воспользовавшись планировщиком событий.

Запланированные звонки/встречи и поставленные задачи попадают в календарь и также имеют в названии префикс CRM:

При наличии соответствующих прав вы можете просмотреть дела другого сотрудника. Для этого на странице Мои дела укажите в фильтре интересующего сотрудника в поле Ответственный и нажмите Найти:

С помощью меню действий вы можете:

  • Просмотреть дело - нажмите, чтобы перейти в режим просмотра дела.
  • Редактировать дело - нажмите, чтобы перейти в форму редактирования параметров дела.
  • Отметить как выполненное - выберите данный пункт, если дело закончено, после чего оно будет помечено флажком:

  • Удалить - нажмите, чтобы удалить дело из списка.

Примечание: для задач в меню действий отсутствует пункт Редактировать дело, и отличается форма просмотра, через которую и можно произвести редактирование задачи.

С помощью панели групповых действий вы можете отметить несколько дел как выполненные/невыполненные, а также сменить ответственного сотрудника. Отметьте нужные дела галочками в колонке флажков, выберите соответствующий пункт в меню групповых действий, в пустом поле введите/выберите нового ответственного, нажмите кнопку Применить. Если поле будет оставлено пустым, то ответственный не будет сменен.

Перевести просроченные\невыполненные дела в статус завершенных можно в ленте CRM.

По нажатию кнопки [image] происходит переход к странице Сводный отчет по делам:

Нажмите на рисунок, чтобы увеличить

Расположение виджетов на странице, работа с ними и настройка аналогичны работе со страницей Аналитические отчеты по сделкам.


Визит-трекер
235 / 401

Визит-трекер предназначен для офлайновой работы с клиентами, то есть фиксации личных встреч и посещений клиентов в CRM. Его основные функции:

  • автоматическое создание нового лида (контакта, компании);
  • распознавание по лицу;
  • автоматическая аудиозапись встречи;
  • фиксирование визита как дела в CRM.

Визит-трекер может быть включен из любой сущности, в форме просмотра которой имеется вкладка Дела, т.е. из Лида, Контакта, Компании, Сделки, а также со страницы CRM > Мои дела с помощью специальной кнопки +Визит:

Подготовка к работе визит-трекера заключается в подключении к вашему компьютеру и настройке веб-камеры и микрофона.

После этого вы можете включить визит-трекер в момент начала разговора с клиентом нажатием на кнопку +Визит. Перед началом записи следует согласиться с условиями использования сервиса:

Запущенный визит-трекер представляет из себя всплывающее окно, где отображается процесс аудио-записи:

Во время работы визит-трекера доступны следующие функции:

  • фотографирование клиента:

  • поиск профиля клиента Вконтакте:

  • создание Лида, Контакта или Компании, прикрепление фотографии к карточке клиента в CRM:

Из окна визит-трекера можно также сразу создать сделку или счет с этим клиентом.

В любой момент вы можете прослушать запись визита, чтобы уточнить какие-то моменты:

При следующем посещении система распознает клиента и поможет вам восстановить в памяти всю историю взаимодействия с ним. Таким образом, никакая информация о клиенте не будет потеряна.


Контакты
236 / 401

Любая сделка начинается с установления контакта с частным лицом, или человеком, представляющим какую-либо компанию.

О фильтре контактов вы можете прочитать в уроке Поиск.

В разделе Контакты вы можете осуществлять различные операции с имеющимися контактами, а также добавлять новые.

Данная страница представлена в следующем виде:

Примечание: В редакции "Проект" в списке сущностей максимум может отображаться 5000 элементов. Остальные будут храниться, но не будут видны, если не применять фильтры.

Примечание: По умолчанию список сущностей отсортирован следующим образом:
  • ближайшие невыполненные дела текущего пользователя
  • ближайшие невыполненные дела других пользователей
  • дата создания сущности

Красным цветом выделены невыполненные дела контакта с истекшим сроком завершения, за которые вы являетесь ответственным. Количество контактов, имеющих такие дела, отображается в главном меню CRM на красном кружке на панели счетчиков:

Используя колонку Дела, можно совершать следующие действия:

Двойной щелчок по любой свободной области контакта приведет к открытию страницы профиля контакта в CRM. Точно такой же результат даст щелчок левой кнопкой мыши по имени или фамилии контакта.

Клик по названию компании откроет страницу профиля этой компании.

Если вы хотите написать электронное письмо какому-либо контакту, щелкните по значению столбца Рабочий e-mail, это запустит ваш почтовый клиент, где в поле адреса получателя будет прописан e-mail контакта.

Вы можете осуществить звонок с помощью IP-телефонии Битрикс24. Для этого нажмите на иконку телефонной трубки рядом с номером:

Примечание: если администратор Битрикс24 разрешил запись разговоров, то звонок будет сохранен в папке Телефония: записи звонков Общего диска.

Меню действий

Помимо пункта Просмотреть контакт, пройдя по которому вы сможете увидеть информацию о контакте, меню действий включает в себя:

  • Редактировать контакт - после клика по данному пункту появится форма редактирования контакта. О значениях полей формы редактирования контакта вы можете подробнее узнать в уроке Добавить контакт.
  • Копировать контакт - при копировании откроется форма добавления контакта, в которую будут продублированы данные копируемого контакта.
  • Добавить событие - о добавлении событий вы можете прочитать в соответствующей главе.

  • Добавить задачу - о добавлении задач вы можете прочитать в уроке Создание задачи.

  • Написать письмо - выберите данный пункт чтобы отправить письмо на e-mail, закрепленный за контактом.

  • Добавить звонок/встречу - позволяет добавить событие в календарь.
  • Бизнес-процесс - позволяет перейти к просмотру текущей информации о бизнес-процессах для данного контакта.

  • Новый бизнес-процесс - позволяет запустить новый бизнес-процесс по заранее созданному шаблону.
  • Добавить сделку - о добавлении сделки вы можете прочитать в уроке Добавить сделку.
  • Сделать предложение - создать коммерческое предложение для данного контакта.
  • Выставить счёт - создать счёт для данного контакта.
  • Удалить контакт - после нажатия появится окошко подтверждения, нажмите в нем Удалить контакт и он будет удален из CRM.
    • Внимание! Удаленные контакты восстановить нельзя.

Контекстная панель

Панель наверху списка называется контекстной. В ней доступны следующие кнопки:

  • Добавить контакт - позволяет добавить новый контакт в базу.
  • Настройки. Нажав на иконку шестеренки можно осуществить импорт и экспорт контактов, настроить список и колонки списка, произвести некоторые другие действия:

Панель групповых операций

Панель внизу списка называется панелью быстрых команд или панелью групповых операций. В ней доступны следующие действия:

Действия могут быть применены к отмеченным строкам, либо ко всем, если установлена галочка "Для всех".

Пиктограмма карандаша позволяет осуществить одновременное редактирование некоторых полей отмеченных контактов.

Также возможно групповое удаление отмеченных записей.

По нажатию кнопки [image] происходит переход к странице Сводный отчет по контактам:

Расположение виджетов на странице, работа с ними и настройка аналогичны работе со станицей Аналитические отчеты по сделкам.


Добавить контакт
237 / 401

Добавить новый контакт можно несколькими способами:

  • нажав на кнопку Добавить контакт на Контекстной панели раздела CRM>Контакты;
  • в форме детального просмотра контакта с помощью кнопки Еще;
  • чтобы сразу причислить контакт к какой-либо компании, на странице Список компаний кликните левой кнопкой мыши в меню действий по пункту Добавить контакт;
  • нажав на "+", появляющийся при наведении курсора мыши на иконку контактов в главном меню CRM:

  • из формы создания сделки/лида;
  • из формы импорта контактов с помощью ссылки
  • автоматически - при заполнении соответствующим образом настроенной CRM-формы;
  • в мобильном приложении - с помощью функции распознавания визиток;
  • автоматически из визит-трекера.

В любом из вышеперечисленных случаев откроется страница добавления контакта:

Заполните поля формы, чтобы добавить новый контакт в CRM:

Примечание:

Если элемент формы является полем со списком [image], то состав списка можно задавать и настраивать в соответствующем Справочнике.

  • Обращение - выберите из подключенного справочника предпочитаемое контактом обращение.
  • Фамилия - укажите фамилию контактного лица.
  • Имя - укажите имя контактного лица.
  • Отчество - укажите отчество контактного лица.
  • Фотография - если на компьютере имеется фотография человека, с которым установлено сотрудничество, нажмите кнопку Обзор и выберите ее.
  • Дата рождения - зафиксируйте это значение, чтобы вовремя поздравить клиента с днем рождения, а также своевременно предложить свои услуги или товары.
  • E-mail - напишите электронный адрес данного контакта. Вы можете указать вид этого e-mail, нажав на пиктограмму стрелочки и выбрав из списка Рабочий (стоит по умолчанию), Частный, Другой. Если вы хотите написать несколько адресов, нажмите ссылку Добавить, после чего появится еще одно поле для ввода e-mail. При сохранении контакта поле E-mail будет проверено на корректность, т.е. отсутствие кириллических символов, наличие знака @ и т.д., поэтому будьте внимательны при добавлении адреса.

    Нажмите крестик, если хотите очистить поле от символов или удалить добавленное поле.

  • Телефон - укажите номер телефона, по которому можно связаться с данным лицом. Указание дополнительных номеров, типа номера, очистка поля, осуществляется также, как для E-mail, за исключением проверки на корректность. Таким образом, в поле номера телефона могут быть введены любые символы, но если телефон не существует или некорректен, абонент не сможет быть определен при звонке на подключенную к CRM телефонию. Поэтому рекомендуется указывать номер телефона в международном или национальном формате, начиная с +7 или 8. Хотя возможны и другие написания. Главное, чтобы сохранялся порядок: код страны (810, 8, +7, 7, 007) + код региона + номер. Пример: 8104012334455 или +74012334455, 0074012334455 - один и тот же номер.
  • Сайт - введите адрес сайта клиента. Изначально выставлено три поля для указания адреса сайта в сети Internet (Корпоративный, Facebook, Twitter), однако вы можете добавить еще, выставив другой тип, нажав на пиктограмму стрелочки и выбрав из выпадающего списка нужное значение поля:

    Нажмите крестик, если хотите очистить поле от символов или удалить добавленное поле.

  • Мессенджер - здесь можно указать клиент сообщений данного контактного лица. Добавление дополнительного мессенджера, указание типа, очистка поля, производится аналогично указанию данных для E-mail.
  • Компания - укажите компанию, в которой работает добавляемый контакт. Если компания уже есть в CRM, то нажмите Выбрать и выберите или найдите ее в появившемся окне:

    Если нужной компании нет, то нажмите Создать и заполните поля формы добавления компании в новом окне. После нажатия Сохранить компания будет привязана к контакту в предыдущем окне:

    Таким образом, к одному контакту может быть привязано несколько компаний.

    Просмотреть привязанные компании можно непосредственно в основной части формы, листая окно компаний с помощью стрелок:

    Также привязанные к контакту компании можно просмотреть в шапке формы просмотра/редактирования контакта.Там же можно увидеть общее количество привязанных компаний:

    При этом клик по названию компании открывает форму просмотра компаний.

    Примечание: с версии 16.5.7 модуля CRM появилась возможность добавлять к контакту несколько компаний через бизнес-процессы.

  • Должность - укажите должность в фирме лица, с которым установлена связь.
  • Адрес - введите местонахождения клиента, или его компании.
  • Комментарий - используя редактор, вы можете ввести произвольный комментарий к данному контакту.
  • Доступен для всех - отметьте опцию, чтобы сделать контакт открытым. Это может понадобиться при разграничении прав доступа (подробнее об этом читайте в уроке Права доступа).

    Внимание! Отмеченная опция Доступен для всех открывает контакт для тех сотрудников, которым назначена такая же роль, как ответственному за контакт.

  • Участвует в экспорте контактов - снимите галочку, если не хотите, чтобы данный контакт можно было экспортировать куда-либо в общем списке.

В секции Реквизиты контакта настраиваются поля, содержащие обязательные данные контакта. Перечень полей зависит от выбранного шаблона реквизитов, то есть поля для Организации и ИП - разные:

Поля реквизитов можно редактировать, добавлять, скрывать или показывать аналогично Настройке и редактированию полей формы. При изменении названия поля новое название будет сохранено в специальной графе шаблона реквизитов под наименованием Название в шаблоне и будет использоваться в форме контакта.

Примечание: скрытие поля не удаляет поле в шаблоне. Скрытое поле можно будет при необходимости вновь активировать в форме контакта, использовав ссылку Показать поле.

Внимание! Пользователь без права редактирования настроек не может добавить новые поля, а может отобразить только те, которые были скрыты и присутствуют в шаблоне.

В полях секции Дополнительно вы можете настроить следующие опции:

  • Тип контакта - нажмите на пиктограмму стрелочки и в выпадающем списке укажите тот тип, к которому вы относите данный контакт:

    По умолчанию стоит значение Общие контакты.

  • Ответственный - здесь указывается имя того сотрудника, который будет взаимодействовать с данным клиентом (по умолчанию указаны данные сотрудника, добавляющего контакт).

    Чтобы поменять ответственного, нажмите на данное поле и выберите нужного сотрудника в структурном дереве.

    Возможно групповое назначение ответственного. Для этого в колонке флажков выделите галочками нужные контакты и в списке действий панели быстрого редактирования выберите пункт Назначить ответственного:

    Появится новое поле, начните вводите в нем имя, и система покажет вам подходящих сотрудников:

    После этого не забудьте нажать Применить на панели быстрого редактирования.

  • Источник - нажав на пиктограмму стрелочки вы можете указать как нашли данного клиента, щелкнув левой кнопкой мыши по нужному значению:

    Примечание: при автоматическом создании Контакта, например, при заполнении CRM-формы, источник также указывается автоматически.
  • Описание - при желании введите дополнительную информацию.
  • ID - уникальный номер контакта. Он присваивается автоматически, изменить его нельзя.

Примечание: при добавлении нового контакта может осуществляться проверка на дубликаты. Подробнее об этом читайте в уроке Прочее.

Нажмите Сохранить, чтобы добавить контакт и перейти к странице со списком контактов.

Нажмите Сохранить и добавить еще, чтобы добавить контакт и перейти к форме добавления еще одного контакта.


Распознавание визиток
238 / 401

Добавить контакт также возможно через мобильное приложение Битрикс24 с помощью функции Распознавание визиток. Для этого нужно перейти на страницу СRM > Контакты и нажать на кнопку Визитка.

Рассмотрим пример распознавания визитки.

Нажмите на рисунок, чтобы увеличить

  1. Перейдем на страницу Контакты и найдем необходимую кнопку:

    Нажмите на рисунок, чтобы увеличить

    Примечание: сканировать визитку будет предложено также при выборе пункта меню Создать контакт.

    Нажмите на рисунок, чтобы увеличить

  2. После этого камеру телефона, на которой расположится рамка для ввода, нужно навести на визитку, и она считается автоматически. Когда считывание закончится, нужно нажать кнопку Распознать и начнется распознавание:

    Нажмите на рисунок, чтобы увеличить

  3. Когда визитка будет распознана, будет создан контакт, содержащий данные с нашей визитки.

    Нажмите на рисунок, чтобы увеличить

  4. При создании нашего контакта:

    Нажмите на рисунок, чтобы увеличить

    Также будет автоматически создана соответствующая контакту Компания.

    Нажмите на рисунок, чтобы увеличить


Импорт контактов
239 / 401

Импорт может осуществляться в форматах .csv или vCard. Чтобы перейти к импорту воспользуйтесь кнопкой настроек на Контекстной панели.

Примечание: о подготовке файла импорта .csv читайте в курсе Администратор сервиса Битрикс24 (коробочная версия). Для импорта нескольких email одного контакта их следует указать через пробел. Для импорта нескольких номеров телефона одного контакта их следует указать через запятую.

Поля в форме настройки параметров импорта практически совпадают для файлов .csv и vCard:

Рассмотрим некоторые поля.

  • Файл данных (формат CSV) (или vCard): - единственное обязательное для заполнения поле. Нажав на кнопку Обзор, укажите на своем компьютере местонахождение импортируемого списка контактов в формате.csv/.vcf.
  • Кодировка файла данных - выберите кодировку импортируемого файла:

  • Доступен для всех - импортируемые контакты будут помечаться как открытые.
  • Ответственный (по умолчанию) - выберите сотрудника, который будет автоматически обозначен как ответственный для всех импортируемых контактов.
  • Формат имени - выберите формат имени ответственного:

  • Шаблон импортируемого файла - нажмите на ссылку Скачать, если хотите сохранить на компьютере имеющийся в дистрибутиве файл .csv с шаблоном полей для импортируемых контактов.

    После щелчка по ссылке откроется окно сохранения файла. Нажмите Открыть если хотите просмотреть содержимое файла, и Сохранить - если хотите сохранить файл на компьютере:

  • Разделитель колонок - выберите символ разделения столбцов данных в файле:

    Примечание: при сохранении файла .csv с помощью Excel возможны проблемы с применяемым разделителем, поэтому если появится сообщение о невозможности импорта, смените разделитель колонок на Точка с запятой.

  • Первая строка содержит заголовки - установите галочку, если в первой строке импортируемого файла содержатся заголовки полей, а информация контактов записана, начиная со второй строки.
  • Пропускать пустые колонки - оставьте галочку для того, чтобы пропускались колонки с пустыми заголовками. В противном случае такие колонки будут импортироваться.

Нажмите Далее и выберите те поля, значения которых должны быть указаны в импортируемом контакте:

Важно! Поля Имя или Фамилия должны быть выбраны обязательно.

При отсутствии нужных полей в системе вы можете сами создать необходимые пользовательские поля.

Импортируемые данные могут быть, например, такими:

При необходимости укажите настройки обработки дубликатов:

Нажмите Далее, и вам будет выведено сообщение о том, какое количество контактов удалось успешно импортировать в CRM, а также число обработанных дубликатов.

Импорт контактов с помощью vCard

Для того, чтобы осуществить импорт электронных визиток из MS Outlook в контакты CRM, запустите почтовый клиент Outlook, зайдите там в Контакты и выберите нужные визитные карточки. Затем в верхней панели выберите Переслать контакт > Как визитную карточку и отправьте по E-Mail адресу CRM.

Примечание: об e-mail адресе CRM смотрите также на странице Интеграция с почтой.


Экспорт контактов
240 / 401

О запуске функции экспорта контактов читайте в уроке Контакты.

Важно! Для успешного экспорта в настройках контакта должна быть отмечена опция Участвует в экспорте контактов. С помощью панели групповых операций возможно единовременное снятие\установка данной галочки для нескольких контактов, предварительно отмеченных в колонке флажков:

Есть три варианта выбора:

  • Экспорт контактов в CSV - после выбора этого пункта появится диалоговое окно сохранения файла в формате .csv:

    Примечание: вы можете не сохранять файл, а сразу открыть его в каком-либо приложении. Для этого выберите не Сохранить файл, а Открыть в и выберите подходящую программу.

    Нажмите ОК, после чего появится диалоговое окно выбора места сохранения файла:

    Нажмите на рисунок, чтобы увеличить

    Выберите где будет храниться файл и нажмите Сохранить.

  • Экспорт контактов в Excel - после выбора этого пункта появится диалоговое окно сохранения файла в формате .xls, работа с которым аналогична экспорту в формате .csv.
  • Экспорт контактов в Outlook - выбор этого пункта позволит передать все записи таблицы списка контактов в Outlook.

    После щелчка левой кнопкой мыши по данному пункту появится окно запуска приложения:

    По умолчанию выбран Microsoft Office Outlook. Для выбора другого приложения нажмите кнопку Выбрать.

    Нажмите ОК, после чего будет выполнен запрос авторизации:

    Введите ваши учетные данные на Битрикс24 и нажмите ОК для начала отправки элементов:

    После завершения обмена данными вы сможете посмотреть экспортируемые контакты в MS Outlook:

    Нажмите на рисунок, чтобы увеличить

    Примечание: в MS Outlook чтобы перейти к экспортируемым контактам нажмите Переход > Контакты.

    Внимание! Для полноценной и безошибочной интеграции с Outlook необходим минимум Outlook 2007.

При экспорте учитывается, применен ли фильтр. Это значит, что если вы хотите экспортировать скажем только контакты с именем Иван, то перед тем, как выбрать вид экспорта в контекстном меню, вам следует с помощью поисковой панели отсортировать контакты по имени Иван.

Набор колонок в итоговом файле экспорта будет повторять колонки списка отображения контактов:

Нажмите на рисунок, чтобы увеличить

Примечание: настроить колонки списка контактов можно, нажав на кнопку настройки списка и выбрав нужный пункт меню:


Поиск и обработка дубликатов
241 / 401

Помимо поиска дублей при создании новой сущности, существует возможность поиска и обработки дублей среди уже существующих записей.

Такой поиск доступен для контактов, лидов и компаний. Поиск выполняется отдельно для каждого списка сущностей.

Для перехода к этой функции следует воспользоваться соответствующим пунктом меню кнопки настроек на контекстной панели.

После чего будет открыта страница, на которой и будет производиться поиск и работа с дубликатами:

Для того чтобы начать работу с дублями, необходимо проиндексировать данные, используя кнопку Обновить список. Индекс необходимо обновлять после добавления новых или изменения уже существующих сущностей, иначе поиск среди них производиться не будет.

После индексации можно запускать поиск с помощью кнопки Найти дубликаты.

Поиск дублей

Каждый сотрудник может запустить поиск только среди своих сущностей (среди тех, к которым имеет доступ на просмотр или редактирование). Поиск выполняется отдельно для контактов, компаний и лидов.

Поиск возможен по совпадению любых из указанных параметров: ФИО, Телефон, E-mail, Название компании (в случае компании или лида).

Примечание: Для лидов существует выбор, по какому принципу нужно искать дубли: лид выступает как физическое лицо – контакт или как юридическое лицо – компания. Если работа с лидами производится только как с контактами, то указывается ФИО, если как с компаниями, то Название компании. Если возможны оба варианта, то можно отдельно поработать с дублями по контактному лицу, а затем отдельно выполнить поиск по названию компании.

Так как полное совпадение проверяется по трем полям: Фамилия, Имя, Отчество, то в результатах поиска в первую очередь отображаются самые заполненные сущности, а затем в порядке убывания остальные.

Если заполнено только поле Фамилия, то будет проверяться совпадение только с этим полем. Если заполнено только Имя, то дубли с таким же именем искаться не будут.

Примечание: Если у сотрудника нет прав на просмотр сущности, то она не показывается совсем, так как сотрудник может искать дубли только в тех данных, к которым имеет доступ.

Алгоритм поиска дублей

При поиске дублей выделяется главная сущность и возможные дубликаты к ней. При объединении данные из дублирующихся сущностей будут перенесены/добавлены в главную.

Главная сущность в системе выбирается по следующим критериям:

  • более высокий индекс цитируемости - как часто менеджер работает с ней, как часто сущность упоминается в других контекстах: сделках, предложениях, делах.
  • дата изменения - та сущность, которая редактировалась позднее всех, считается более актуальной.
  • наполненность карточки - более полная карточка будет важнее, чем менее заполненная.

    При таком подходе на заполненность проверяются следующие поля: Телефон, E-mail, ФИО, Название компании, Адрес компании.
  • права доступа – этот параметр влияет на порядок данных. Те сущности, которые доступны пользователю только для просмотра, будут отображаться в конце списка, так как объединить их все равно нельзя.

При этом проверка выполняется именно в такой последовательности, т.е. в первую очередь, проверяется индекс цитируемости, если находится что-то по этому критерию, то такая сущность становится главной и к ней уже подбираются дубли.

Если по первому критерию не удалось выбрать одну сущность, например, есть 2 дубликата и они схожи по количеству сделок и предложений, то проверяется второй критерий – последняя дата изменения карточки контакта (компании/лида).

Только если по первым двум не удалось выявить лидера – проверяется третий критерий и берется за главную сущность та карточка, которая максимально заполнена (стандартные поля, по которым выполняется поиск: ФИО, Телефон, E-mail.)

Права доступа

В больших компаниях с клиентами могут работать несколько менеджеров, поэтому контроль дублей доступен для всех сотрудников, которые имеют доступ к данным CRM. Но каждый сотрудник видит в результате только свои данные и не может объединить схожие контакты другого сотрудника. Другими словами, каждый работает со своей базой клиентов.

Если в результатах поиска, присутствуют сущности, на которые пользователь не имеет прав редактирования и удаления (только просмотр), то для них невозможно объединение с главной сущностью. При этом, если необходимо, то можно обратиться к ответственному с помощью ссылок Написать и Позвонить в колонке Ответственный.

Примечание: Администратор может запустить поиск для каждой сущности отдельно. Он имеет доступ ко всем данным и может объединить любые сущности.

Отображение результатов поиска дубликатов

Результаты поиска дубликатов отображаются в виде списка, в котором каждая главная сущность сгруппирована со своими возможными дубликатами:

  • на первом месте, среди прочих, отображается главная сущность, в которую и будут переноситься данные из нижележащих сущностей.
  • ниже отображается детальная информация, по какому полю были найдены дубликаты.

    Примечание: Если одна и та же сущность имеет дубликаты по разным полям, то она будет дважды отображена в списке с соответствующими этим критериям дубликатами.

  • затем идет список возможных для этой сущности дублей, с пометками, если к какой-то сущности пользователь не имеет доступа на редактирование (только просмотр).

    Список строится по тем же критериям: упоминания, дата последнего изменения, максимальная наполненность карточки.
  • в самом низу группы находятся кнопки действий с дубликатами:
    • Объединить - используется для переноса данных из дубля в главную сущность.
    • Пропустить - используется для отметки выбранных сущностей как "не дубли". В этом случае, именно эти выбранные сущности по этим конкретным полям не будут больше предложены как возможные дубли. Но обратите внимание, что ниже по списку этот же элемент может быть представлен как дубль к другой сущности.

      Другими словами пропустить означает, что выделенные элементы не дубли, но при этом они могут быть дублями к другим.

    • Каждый список сортируется по алфавиту, для лидов и контактов – по ФИО, для компаний – по Названию компании.

    Объединение найденных дублей

    Внимание! Процесс объединения пока необратим. В результате объединения могут быть изменены права доступа, часть информации, такая как история, события ленты, список товаров могут быть удалены, так как основной информацией являются данные в главной сущности.

    Итак, в списке имеется главная сущность и возможные к ней дубли. При объединении, все данные будут сливаться в главную сущность, при этом множественные поля будут просто дополняться, пустые поля будут заполнены данными с дубля, а вот те поля, которые заполнены и в главной сущности и в дубле, не будут объединены.

    Если есть обычное, не множественное поле и оно заполнено в главной сущности, то в конечном результате, после объединения, именно это значение и будет сохранено. В этом случае лучше сравнить сущности между собой перед объединением, чтобы случайно не удалить важную информацию.

    При объединении контактов, имеющих привязку к разным компаниям, эти привязки также будут объединены. То есть к одному контакту будут привязаны несколько компаний.

    Все привязки к сделкам, счетам, делам, задачам, будут автоматически изменены. Если раньше сделка была связана с дублем, то после объединения в ней будет ссылка на главную сущность, в которую был слит этот дубль.

    События живой ленты о создании нового дела, счета и прочее перенесены в главную сущность не будут.

    Права доступа после объединения остаются только у главной сущности, так как все дубли будут просто удалены. Но если в результате объединения кто-то из менеджеров может потерять доступ к своему контакту, то перед объединением вам будет показано предупреждение.

    Рассмотрим пример объединения двух контактов.

    В карточке первого контакта заполнены поля:

    • Фамилия: Сидорчук
    • Имя: Пётр
    • Отчество: Алексеевич
    • Дата рождения: 24.11.1977
    • Должность: Генеральный директор
    • Телефон: 2256598464
    • Email: sidortshuk@ya.ru
    • Компания: СидорчукАвто

    В карточке второго контакта заполнены поля:

    • Фамилия: Сидорчук
    • Имя: Пётр
    • Должность: Соучредитель
    • Компания: ЗеленоградскТранс

После поиска дубликатов главной сущностью будет являться первый контакт т.к. у него, согласно критериям, в карточке заполнено больше основных полей.

После процедуры объединения дубликат (второй контакт) перестанет существовать, а у главной записи (первый контакт) будут следующие поля:

  • Фамилия: Сидорчук
  • Имя: Пётр
  • Отчество: Алексеевич
  • Дата рождения: 24.11.1977
  • Должность: Генеральный директор
  • Телефон: 2256598464
  • Email: sidortshuk@ya.ru
  • Компания: СидорчукАвто, ЗеленоградскТранс

Информация из дубля, которая отличается от той, что уже существует в главной сущности, например, значение поля Должность (Соучредитель), не будет скопирована и просто перестанет существовать.

Ссылки по теме:

  • Контроль ввода сущностей с идентичными параметрами


Компании
242 / 401

Каждый персональный контакт в большинстве случаев представляет какую-либо компанию.

В разделе Компании можно просматривать имеющиеся в системе CRM компании, добавлять новые, производить над ними различные операции:

Примечание: В редакции "Проект" в списке сущностей максимум может отображаться 5000 элементов. Остальные будут храниться, но не будут видны, если не применять фильтры.

Примечание: По умолчанию список сущностей отсортирован следующим образом:
  • ближайшие невыполненные дела текущего пользователя
  • ближайшие невыполненные дела других пользователей
  • дата создания сущности

Красным цветом выделены компании с просроченными делами, за которые вы являетесь ответственным. Количество таких компаний также отображается на панели счетчиков CRM:

Меню действий, просмотр компании, действия, доступные с помощью колонки Дела, идентичны таковым для контактов.

Импорт компаний возможен из файлов CSV и аналогичен импорту контактов.

Экспорт компаний возможен в CSV и в Excel и аналогичен экспорту контактов, за исключением того, что отсутствует возможность экспортировать в Outlook.

Поиск и обработка возможных дублей аналогична таковым для контактов.

По нажатию кнопки [image] происходит переход к странице Сводный отчет по компаниям:

Расположение виджетов на странице, работа с ними и настройка аналогичны работе со станицей Аналитические отчеты по сделкам.


Добавить компанию
243 / 401

Добавить новую компанию можно несколькими способами:

  • нажав на кнопку Добавить компанию контекстной панели страницы Компании;
  • нажав на "+", появляющийся при наведении курсора мыши на иконку компаний в главном меню CRM:

  • из формы добавления сделки;
  • из формы добавления контакта;
  • из формы добавления коммерческого предложения;
  • из формы добавления счёта;
  • автоматически из визит-трекера.

В любом из перечисленных способов откроется форма добавления компании:

Заполните следующие поля:

  • Название компании - единственное обязательное к заполнению поле, введите, как называется добавляемая компания.
  • Ответственный - здесь указывается имя того сотрудника, который будет взаимодействовать с данной компанией (по умолчанию указаны данные сотрудника, добавляющего компанию).

    Чтобы поменять ответственного, нажмите на данное поле и выберите нужного сотрудника в структурном дереве, аналогично выбору сотрудника, описанному в уроке График отсутствий.

  • Логотип - нажмите Выберите файл и выберите картинку, представляющую эту компанию.
  • Тип компании - нажмите [image] и укажите к какому типу относится добавляемая компания (по умолчанию выставлено Клиент):

  • Сфера деятельности - нажмите [image] и укажите тип деятельности, которой занимается добавляемая компания (по умолчанию выставлено Информационные технологии):

  • Кол-во сотрудников - нажмите [image] и укажите приблизительное число сотрудников, работающих в данной компании (по умолчанию выставлено менее 50):

  • Годовой оборот - с помощью цифр укажите годовой денежный оборот компании. Если данное поле оставить пустым, или заполнить словесными обозначениями, годовой оборот будет отображаться как 0.
  • Валюта - нажмите [image] и выберите валюту, в которой вы указываете годовой оборот (по умолчанию выставлено Рубль):

  • Комментарий - введите свой комментарий свободного характера.

  • Доступна для всех - отметьте опцию, чтобы сделать компанию открытой. Это может понадобиться при разграничении прав доступа (подробнее об этом читайте в уроке Права доступа).

    Внимание! Отмеченная опция Доступен для всех открывает компанию для тех сотрудников, которым назначена такая же роль, как ответственному за компанию.

Поля секций Контактная информация и Реквизиты описаны в уроке Добавить контакт и очевидны из названий.

К одной Компании могут быть добавлены несколько Контактов. На вкладке Контакты нажмите Выбрать и укажите контакты, относящиеся к данной компании:

Примечание: при добавлении новой компании может осуществляться проверка на дубликаты. Подробнее об этом читайте в уроке Прочее.

Нажмите Сохранить, чтобы добавить компанию и перейти к странице со списком компаний.

Нажмите Сохранить и добавить еще, чтобы добавить компанию и прейти к форме добавления еще одной компании.


Сделки
244 / 401

Сделки являются конечной целью и желаемым результатом работы с контактами и фирмами.

В CRM сделки можно просматривать, редактировать, экспортировать. Все сделки могут быть представлены как в виде списка, так и в наглядном графическом виде аналитических отчетов.

На данной странице по умолчанию представлен список всех сделок. Там же их можно отфильтровать по направлениям (например, Общее или Новое направление):

Нажмите на рисунок, чтобы увеличить

Примечание: В редакции "Проект" в списке сущностей максимум может отображаться 5000 элементов. Остальные будут храниться, но не будут видны, если не применять фильтры.

Примечание: По умолчанию список сущностей отсортирован следующим образом:
  • ближайшие невыполненные дела текущего пользователя
  • ближайшие невыполненные дела других пользователей
  • дата создания сущности

Красным цветом шрифта выделены дата и время невыполненного дела сделки с истекшим сроком завершения.

Розовым цветом фона выделяются колонки дел у незакрытых сделок с отсутствием дел, за которые вы являетесь ответственным.

Сумма количества сделок, за которые вы являетесь ответственным, не имеющих дел, и количества сделок с просроченными делами, за которые вы являетесь ответственным, отображается в главном меню CRM на красном кружке на панели счетчиков:

На странице списка сделок можно менять стадии сделки:

Нажмите на рисунок, чтобы увеличить

Каждая секция соответствует определенной стадии, каждая из которых идет одна за другой. Для выбора определенной стадии кликните по ней левой кнопкой мыши.

Примечание: при копировании сделки стадия новой сделки выставляется на начальную.

Можно изменить стадии одновременно для нескольких сделок. Для этого следует отметить их в колонке флажков [image], установить стадию [image] и нажать кнопку Применить [image] :

Нажмите на рисунок, чтобы увеличить

Действия, доступные с помощью колонки Дела, просмотр, импорт, экспорт сделок и меню действий идентичны таковым для контактов.

Если в одной сделке участвует несколько товаров, то каждый из них в файле экспорта будет представлен отдельной строкой, при одинаковом ID сделки:

Нажмите на рисунок, чтобы увеличить

При импорте сделок ситуация обратная - все сделки по разным товарам, идущие разными строками, но имеющие одинаковый ID, после импорта в системе CRM будут объединены в одну сделку с несколькими товарами в ней.


Добавить сделку
245 / 401
  • Группа полей "О сделке"
  • Группа полей "О контакте"
  • Группа полей "Товары сделки"

Сделку можно добавить несколькими способами:

  • с закладки Сделки формы просмотра контакта\компании;
  • нажав Добавить сделку на контекстной панели страницы Сделки;
  • выбрав пункт Добавить сделку из подменю кнопки Еще режима просмотра контакта\компании.
  • через форму просмотра предложения или его меню действий:

  • из меню действий привязанных контакта\компании, расположенных на соответствующей закладке формы просмотра компании\контакта.

    Примечание: в данном случае в сделке автоматически будет проставлена привязка к контакту и компании одновременно.
  • нажав на "+", появляющийся при наведении курсора мыши на иконку сделок в главном меню CRM:

  • из меню действий нужного контакта\компании на странице общего списка.

    Примечание: в случае контакта, к которому привязана компания - в форме добавления к нему сделки будет проставлена привязка и к компании тоже. На компании, к которым добавлены контакты, это не распространяется.

  • импортировав сделки из интернет-магазина;
  • автоматически из визит-трекера.

Внимание! При добавлении сделки способами, указанными в пп. 2 и 4, следует предварительно выбрать направление сделок.

Вам откроется форма добавления новой сделки:

Примечание: опция Связать с интернет-магазином будет доступна, если у вас настроена интеграция с интернет-магазином.

Рассмотрим добавление сделки, не привязываемой к интернет-магазину. О том, как связать сделку с заказом в электронном магазине, читайте в соответствующем уроке.

Группа параметров "О сделке"

  • Стадия сделки - нажмите [image] и укажите этап, на котором находится добавляемая сделка (по умолчанию выставляется В обработке):

    Возможна установка стадий сразу для нескольких сделок из списка. Данное действие аналогично, описанному в уроке Добавить контакт, групповому назначению ответственного.

    Примечание: при указании стадии Сделка заключена или Сделка не заключена сделка будет закрыта.

  • Валюта - нажмите [image] и выберите валюту, в которой вы указываете сумму (по умолчанию выставлено Рубль):

  • Сумма - только с помощью цифр укажите сумму сделки.
  • Вероятность, % - введите число от 0 до 100, характеризующее вероятность успешности сделки.
  • Ответственный - здесь указываются данные, идентифицирующие ответственное за данную сделку лицо. Изначально выставляется имя, фамилия, e-mail и ID сотрудника, который вносит данные о лиде. Указать другого сотрудника из структуры портала, можно нажав на ссылку Добавить из структуры. Процесс выбора сотрудника описан в уроке График отсутствий.

    Возможно групповое добавление ответственного. Оно описано в уроке Добавить контакт.

  • Дата начала - по умолчанию выставляется дата добавления сделки в CRM. Чтобы изменить ее, кликните на саму дату и выберите число, месяц и год сделки в выпадающем календаре:

  • Дата завершения - аналогично Дате начала укажите дату завершения сделки. По умолчанию выставляется дата, на неделю более поздняя, чем дата добавления сделки в CRM.
  • Тип - нажмите [image] и выберите вид сделки (по умолчанию выставляется Продажа):

    Примечание: настроить свои названия типов и стадий сделки вы можете на странице CRM > Настройки > Справочники.

  • Доступна для всех - отметьте опцию, чтобы сделать сделку открытой. Это может понадобиться при разграничении прав доступа (подробнее об этом читайте в уроке Права доступа).

    Внимание! Отмеченная опция Доступна для всех открывает сделку для тех сотрудников, которым назначена такая же роль, как ответственному за сделку. Помните, что для сделок возможна установка прав доступа по каждому статусу отдельно.

Группа параметров "О контакте"

Здесь можно выбрать контакт или компанию, с которыми заключается сделка.

  • Контакт - укажите контакты, с которыми происходило сотрудничество в процессе заключения сделки. Чтобы выбрать из уже имеющихся в CRM контактов нажмите Выбрать и найдите нужный контакт с помощью поиска, начав вводить буквы имени или фамилии в текстовое поле вверху:

    Здесь же вы можете создать новый контакт. Для этого нажмите ссылку Создать и заполните форму добавления контакта.

    После нажатия Сохранить контакт появится как в списке контактов, так и в данной форме.

    Чтобы убрать контакт из формы добавления сделки нажмите на крестик рядом с ним.

    Аналогичным образом можно выбрать или создать другие контакты, участвующие в сделке.

    Примечание: телефон и e-mail клиента не отображаются при отсутствии прав на чтение связанных контактов и компаний.

    Примечание: с версии 16.5.7 модуля CRM появилась возможность добавлять к сделке несколько контактов через бизнес-процессы.

  • Компания - аналогично контакту, вы можете указать или создать компанию, с которой была заключена сделка. В форме сделки появятся также контакты, привязанные к этой компании. Кроме того, можно добавить в сделку и другие контакты, не привязанные к данной компании:

  • Местоположение - единственное обязательное к заполнению поле. Начните вводить и выберите из списка географический объект, где расположен контакт или компания, с которыми заключается сделка.

    Примечание: Сохранение сделки допускается и без заполнения поля Местоположение, однако при этом невозможно корректное применение налогообложения. Кроме того, при создании на основании такой Сделки Счёта или Коммерческого предложения их сохранение будет невозможно, а при корректировке могут возникнуть расхождения с суммой Сделки. Таким образом настоятельно рекомендуется заполнять поле Местоположение в Сделке.

  • Комментарий - введите свой комментарий свободного характера.

Группа параметров "Товары сделки"

На этой вкладке перечисляются товары, на которые заключена сделка.

Внимание! При создании сделки на основании коммерческого предложения в список товаров новой сделки добавляются только товары, отсутствующие в созданных ранее на основании этого же предложения сделках.

Нажмите Выбрать товар, чтобы добавить товар из каталога CRM.

Примечание: следует иметь в виду, что добавление товаров влияет на сумму сделки, изменяя ее в соответствии со стоимостью добавляемых товаров и делая в дальнейшем недоступной для редактирования.

В таблице вы можете редактировать цену и количество товара, а также выбирать единицы измерения. Возможно указание дробного количества товара.

При наборе наименования в строке названия товара поддерживаются контекстный поиск:

Для уже выбранных товаров доступен элемент управления, который позволит перейти к просмотру карточки с информацией о товаре:

Если набранного товара в каталоге нет, то с помощью соответствующей кнопки можно его туда добавить:

Чтобы удалить товар, нажмите на крестик рядом с его наименованием.

Примечание: если нажать Добавить строку и заполнить необходимые данные о товаре, а потом сохранить сделку, то новый товар не окажется в каталоге CRM, но будет присутствовать в сделке.

При выставленной галочке в опции Показать скидку можно задать сумму (процент) скидки:

По кнопке Добавить новый товар, откроется окно, в котором вы сможете создать товар для каталога CRM:

Нажмите Сохранить, чтобы добавить сделку и перейти к странице со списком сделок.

Нажмите Сохранить и добавить еще, чтобы добавить сделку и перейти к форме создания новой сделки.


Направления сделок
246 / 401

Очень часто виды бизнеса и технологии ведения дел могут быть весьма разнообразны даже в рамках одной компании. Поэтому требуется функционал, позволяющий диверсифицировать деятельность, развивать и анализировать несколько направлений бизнеса и, таким образом, эффективно распределять материальные и трудовые ресурсы между различными активами.

В CRM Битрикс24 для этого предусмотрена возможность разделять Сделки по Направлениям. Этот функционал позволяет:

  • создать направление
  • отредактировать направление
  • настроить стадии сделки для каждого направления
  • удалить направление
  • задать собственный набор полей для каждого направления
  • гибко настроить права доступа
  • сформировать воронки продаж по каждому направлению отдельно

Создание направления

Создавать новые направления сделок и/или редактировать существующие могут администраторы портала, а также пользователи, которым разрешено менять настройки в CRM. Если пользователь не обладает такими правами, то создаваемая им сделка будет по умолчанию относиться к Общему направлению. Также к Общему направлению автоматически будут отнесены все сделки, созданные ранее появления функционала Направлений сделок.

Направление по умолчанию нельзя удалить, но можно отредактировать.

Создать новое направление можно несколькими путями:

- нажав кнопку [image] в разделе CRM > Настройки > С чего начать > Направления сделок

- нажав кнопку Добавить направление либо выбрав пункт Добавить направление в меню кнопки Добавить сделку на странице списка сделок:

После любого из этих действий произойдет переход на страницу Направления сделок, где в окне Создание направления следует задать название направления и порядок его сортировки, а затем сохранить

Внимание! Количество создаваемых направлений (и, соответственно, мультиворонок) зависит от тарифного плана вашего Битрикс24 и приведено на странице Сравнение редакций. По умолчанию доступно одно направление Общее, к нему относятся сделки, создаваемые без прямого указания направления, по нему же строится воронка продаж.

Созданные направления появятся на странице Список сделок в виде закладок над таблицей перечня сделок. Кликая по названию направления, можно автоматически переключать отображение сделок только выбранного направления.

Примечание: направление по умолчанию (Общее направление) не показывается на панели направлений, пока не будет создано хотя бы одно пользовательское направление.

Закладка Все сделки позволяет увидеть список сделок всех направлений, где направление указано в отдельной колонке:

После любых изменений в настройках Направлений над списком сделок появится уведомление:

Обновите статистику, чтобы стадии сделок и воронки продаж отображались корректно.

Редактирование направления

Отредактировать можно название направления и порядок его сортировки. Для этого в списке направлений CRM > Настройки > С чего начать > Направления сделок следует выбрать в контекстном меню соответствующего направления пункт Редактировать:

и задать желаемые значения:

Можно изменить, в том числе, и название направления по умолчанию, то есть Общего.

Настройка стадий

Если не заданы пользовательские направления, то есть существует только направление по умолчанию и оно не переименовано, то на странице CRM > Настройки > С чего начать > Справочники будет отображаться только один пункт Стадии сделки. В противном случае, пунктов будет столько, сколько создано направлений, и называться они будут в соответствии с наименованиями направлений:

Переход к настройке стадий направлений сделок возможен как из контекстного меню выбранного направления со страницы CRM > Настройки > С чего начать > Направления сделок

так и со страницы CRM > Настройки > С чего начать > Справочники .

По умолчанию установлены стандартные стадии сделки для нового направления:

Выбрав нужное направление, следует настроить порядок следования, количество, названия, цвет и другие параметры стадий, как описано в уроке Справочники.

Удаление направления

Для того, чтобы удалить направление сделок, следует перейти к списку направлений (со страницы CRM > Настройки > С чего начать > Направления сделок или из списка сделок по кнопке + Добавить направление) и выбрать пункт Удалить в контекстном меню.

При этом направление по умолчанию удалить нельзя, даже если оно переименовано, так как в его меню отсутствует пункт Удалить. Кроме того, направление по умолчанию отличается цветом фона:

Также нельзя удалить направление, если в нём существует хотя бы одна сделка. В этом случае будет выдано предупреждение:

В случае необходимости следует удалить сначала все сделки, созданные по данному направлению, а потом уже удалить собственно направление.

Набор полей

Для заключения сделок по разным направлениям деятельности может понадобиться разная информация. Аналогично настройке форм других сущностей CRM, вы можете удалить или добавить собственные пользовательские поля и настроить набор полей формы сделки для каждого направления отдельно.

Так как для разных направлений сделок могут быть заданы совершенно различные наборы полей, а также количество и порядок следования стадий, то поля и стадии, существующие в одном направлении, могут отсутствовать в другом. По этой причине конвертация уже созданных сделок из одного направления в другое не может быть выполнена. Направление не является полем сделки, оно присваивается автоматически, в зависимости от того, в каком списке направлений создана сделка.

Важно! Выбирать направление следует перед созданием сделки, то есть создавать сделку сразу в нужном списке.

Права доступа

Подробно настройка прав доступа описана в уроке Права.

По мере создания новых направлений сделок на страницу Управление ролью в раздел CRM > Настройки > Права > Права доступа добавляются наименования этих направлений и их стадий:

Внимание! К назначению ролей следует относиться чрезвычайно внимательно, так как именно от назначенной роли зависит возможность сотрудника просматривать, редактировать и производить другие действия с Контактами, Компаниями, Лидами, Сделками, Предложениями, Счетами, CRM-формами.

Воронки продаж

Для эффективного анализа направлений бизнеса и удобного графического представления количественного соотношения сделок на разных стадиях используются воронки продаж - мультиворонки.

Их просмотр может осуществляться как на специально выделенной странице CRM > Воронка продаж , так и в виджетах аналитических отчетов по сделкам.

  • Воронка продаж на выделенной странице помогает осуществить глубокий анализ каждого направления по отдельности. Здесь можно переключать вид воронки - классический или конверсионный, просматривать таблицы и диаграммы сделок в работе и незаключенных сделок:

    • При этом клик на наименовании стадии в таблице позволяет перейти к списку сделок данного направления, отфильтрованному по соответствующей стадии:

    В таблице также имеется информации по количеству, процентной доле, сумме сделок на каждой стадии в соответствии с выбранной моделью отображения - конверсионной (нижележащая стадия включает в себя все предыдущие) или классической (каждая стадия подсчитывается отдельно).

  • В режиме аналитических отчетов можно сравнить несколько воронок, созданных по отдельным направлениям.

    • По умолчанию включена одна воронка по Общему направлению, но можно добавить отчет в виде воронки по каждому из направлений.

    Дополнительная информация:

    • Мультиворонки и разные направления сделок
    • Карточка элемента CRM


Роботы и триггеры
247 / 401

В CRM, как системе, направленной на автоматизацию продаж, имеется довольно много рутинных, регулярно повторяющихся операций, по которым должна продвигаться сущность для получения оптимального результата. Например, при заключении торговой сделки, скорее всего, выполняются некоторые стандартные этапы - поиск покупателя, переговоры, достижение соглашения, документальное оформление, денежные расчеты.

Для автоматизации такой обработки элементов в CRM внедрены роботы и триггеры. Автоматизация с помощью роботов и триггеров доступна как с отдельной страницы CRM > Настройки > Автоматизация, так и непосредственно из профиля сделки. Действия и события, используемые в роботах и триггерах - это действия бизнес-процессов, предназначенные для работы с CRM. Подробно эти действия описаны в отдельной главе.

Внимание! Доступность роботов и триггеров для сущностей зависит от редакции Битрикс24. На данный момент роботы и триггеры доступны для редакций не ниже Проект+ (в редакции Проект+ только для лидов).

Определения роботов и триггеров в CRM отличаются от общепринятых:

Триггер (trigger, пусковая схема) - событийное средство автоматизации процессов. Определенное правило или сценарий, который срабатывает в ответ на какие-либо действия (события) со стороны клиента и переводит сущность в определенный статус.

Робот - инструмент запуска автоматического процесса при достижении сущностью определенного статуса. Когда сущность переходит в конкретный статус, срабатывает робот и выполняет заданную последовательность действий.

Проще говоря, триггеры - это действия клиента, которые продвигают сущность по стадиям, а роботы - действия системы, выполняемые, когда сущность достигает определенного статуса.

Примечание: так как роботы и триггеры привязаны к стадиям, то настраиваются они для тех сущностей, которые могут менять свой статус. В текущей версии Битрикс24 они могут быть в Лидах и Сделках.

Вы можете назначить роботов или триггеры на стадии Сделок. Настройка роботов производится на вкладке Автоматизация при просмотре Сделки:

Обратите внимание! Даже если роботы и триггеры задаются в одной Сделке какого-либо направления, тем не менее они действуют на все сделки данного направления.

Триггеры могут быть назначены на следующие действия клиента:

Триггер ставится на ту стадию, в которую должна перейти сущность после указанных действий со стороны клиента. То есть по получении письма или звонка от клиента, заполнении им CRM-формы, оплате счета или срабатывании вебхука (Webhook) произойдет переход к соответствующей стадии. Например, если в системе телефонии будет зарегистрирован звонок с телефонного номера лида, который находится на стадии "Не обработан", то может быть автоматически назначен ответственный.

Настройка собственно триггера практически не требуется. При необходимости его изменения кликните на ссылку [image], после чего в открывшемся окне можно изменить название триггера или, в случае вебхука, скопировать URL:

Примечание: триггеры работают только в направлении "вперед", то есть если сделка перешла на следующую стадию, то триггеры с предыдущих уже не сработают.

При достижении сущностью какого-либо статуса могут запускаться роботы. Настроив их один раз, можно без дальнейшего вмешательства выполнять следующие действия:

При выборе какого-либо действия открывается окно его настройки. Настройка большинства действий довольна проста и интуитивно понятна. Подробно параметры действий описаны в уроке CRM главы Бизнес-процессы. Создание робота-вебхука описано ниже в спойлере.

Создание робота-webhook

Создание робота-webhook несколько отличается от создания обычного робота и требует умения программировать. В отличие от исходящих Webhook'ов Приложений, адрес страницы обработчика указывается явно.

  1. Нажмите кнопку Настроить роботов.
  2. У нужного статуса сделки добавьте робота, выбрав тип робота Webhook. В открывшейся форме:
  3. Укажите время выполнения робота:
    • сразу - робот отработает сразу по достижении статуса;
    • после предыдущего - робот отработает после робота, стоящего перед ним;
    • время - робот отработает в выбранное время, либо до некоторого события, либо через указанное время:

  4. Далее укажите адрес обработчика и параметры, которые хотите в обработчик передать, например: https://xxxyyy.com/testhook.php?status={{Стадия сделки}}. (В примере в прямом виде передаётся стадия сделки.) Параметры разработчик указывает те, какие он будет использовать в обработчике. Значение для используемого параметра берётся из полей сущности, которую обрабатывает робот. Поля можно выбрать из окна с перечнем полей сущности, вызвав его кликом по многоточию, а можно написать прямо в URL.

  5. Сохраните созданного робота.

Например, процедура продажи в вашей компании включает себя обязательное проведение презентации продукта при личной встрече с клиентом. Для этого вы можете указать роботу, что следует Запланировать встречу на стадию сделки Предложение и в специальном окне настроить действие:

Если при настройке робота кликнуть на символ [image], то в качестве параметров можно использовать любые поля сделки, в том числе пользовательские. Их конкретные значения будут подставляться для каждой сделки:

Можно также настроить точное время отработки робота:

Когда стадия сделки изменится, отработает робот, в результате чего будет назначена встреча и произведены соответствующие записи в Ленту CRM:

и в Мои дела:

А также ответственный за сделку получит уведомление:

Если требуется выполнение более сложной или специфической последовательности действий, то, нажав ссылку [image], можно перейти к дизайнеру бизнес-процессов и создать собственный алгоритм работы.

Примечание: данная кнопка доступна только на тарифе Компания.

Дополнительная информация

  • Быстрая интеграция с Битрикс24 или волшебные вебхуки!
  • Автоматизация. Роботы и триггеры.


Добавление заказа в интернет-магазин
248 / 401

Средства системы позволяют при добавлении сделки одновременно создать заказ в вашем интернет-магазине, для которого настроена интеграция с CRM.

Для этого в форме добавления сделки отметьте опцию Связать с интернет-магазином:

Важно! Возможность связать сделку с заказом в интернет-магазине доступна только при наличии установленной интеграции между CRM и интернет-магазином.

После того, как вы поставите галочку Связать с интернет-магазином, некоторые поля добавления сделки станут недоступны. Изменится вид вкладки Товары сделки:

В случае необходимости, выберите нужный интернет-магазин, и нажмите кнопку Создать заказ в магазине, откроется форма добавления заказа:

Параметры заказа и Покупатель

  • Статус заказа - укажите стадию, на которой находится заказ.
  • Чтобы создать нового покупателя, нажмите кнопку Новый. Если покупатель уже существует в интернет-магазине, то нажмите кнопку Существующий. Откроется список покупателей:

    Укажите покупателя, дважды кликнув по нему левой кнопкой мыши, либо выбрав пункт Выбрать в меню действий.

  • Тип плательщика - в зависимости от выбранного типа плательщика (физическое или юридическое лицо) поменяются поля в секции Адрес доставки. Все поля понятны и с их заполнением не должно возникнуть проблем.

Доставка и оплата

  • Служба доставки - выберите службу доставки.

    Примечание: если в параметре Служба доставки нет вариантов выбора, убедитесь, что вы указали адрес доставки в секции Адрес доставки.

  • Стоимость доставки - подставляется автоматически после выбора службы доставки либо задайте вручную необходимое значение.
  • Идентификатор отправления - указывается идентификатор почтового отправления.
  • Способ оплаты - обязательно выберите способ оплаты заказа.

Состав заказа

Нажмите Добавить товар, откроется форма добавления товаров из интернет-магазина:

В дереве каталога выберите необходимый раздел. Затем в списке выберите необходимый товар с помощью кнопки Выбрать напротив него.

После того, как все необходимые товары добавлены, можно активировать купоны скидок, если таковые имеются. Введите их через запятую в соответствующее поле и нажмите Пересчитать для применения купона.

Когда все данные заказа указаны, нажмите Сохранить, в результате откроется форма просмотра сделки в CRM.


Аналитические отчеты по сделкам
249 / 401

Для организации наглядного представления информации по сделкам существует возможность отображать различные параметры сделок в графическом виде с помощью виджетов.

Виджет (англ. widget) – небольшая программа, которая выполняет ту или иную функцию и отображается в виде графического объекта на рабочем столе.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Аналитические отчеты в CRM

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Рассмотрим страницу виджетов подробнее:

  • Режим виджетов
  • Меню виджетов
  • Перемещение виджетов
  • Удаление виджетов
  • Настройка виджетов
  • Пример настройки виджета
  • Список виджетов

Режим виджетов

Для переключения в режим виджетов служит кнопка:

По умолчанию страница виджетов имеет демо-представление:

и соответствующее уведомление о том, что отображается демо-представление:

Вы можете скрыть демо-представление и настроить страницу по своим требованиям - установить фильтр по направлениям сделок или другим параметрам:

удалить или добавить виджеты, поменять настройки, расположить в удобном порядке, и таким образом получить необходимую аналитику в компактном и удобном графическом виде. В этом случае при следующем переходе в режим виджетов будут отображаться настроенные отчеты.

Меню виджетов

Меню активируется по кнопке [image] в заголовке окна виджетов. В режиме демо-представления оно имеет только два пункта: Выбрать раскладку и Вернуть первоначальные настройки. В режиме пользовательских отчетов меню имеет вид:

Рассмотрим пункты меню подробнее.

  • Добавить отчет

    • При выборе этого пункта меню активируется окно создания отчета

    где следует выбрать внешний вид диаграммы, а затем настроить её.

  • Выбрать раскладку

    • На выбор предлагается несколько вариантов расположения виджетов в процентном соотношении к ширине страницы:

  • Вернуть первоначальные настройки

    • Первоначальными являются настройки списка виджетов в соответствии с выбранным в списке сделок направлением сделок и установленным фильтром.

  • Вернуть демо-представление

    • Демонстрируется страница по умолчанию.

Перемещение виджетов

Чтобы переместить виджет, наведите курсор мыши на его заголовок. Удерживая нажатой левую кнопку мыши, перетащите виджет в нужное место рабочего стола. После начала перемещения появятся отрисованные пунктиром возможные места расположения виджета - справа, слева по 50% ширины экрана или по центру на 100% ширины. Выбранная ячейка подсвечивается.

Обратите внимание, что виджет будет переформатирован по размеру ячейки автоматически и это может привести к искажению графического изображения.

Удаление виджетов

Для удаления виджета следует нажать "шестеренку" в заголовке и в выпадающем меню выбрать пункт Удалить:

Настройка виджетов

Виджет может быть настроен в зависимости от типа и состава информации в нем. В общем случае виджет строится по выбранному направлению сделок, заданному отчетному периоду или фильтру, в него включается общая сумма сделок, сумма/количество/процентные соотношения по стадиям/группам стадий сделок и проч.

Выбрав пункт Настроить в выпадающем меню, в открывшемся окне Настройка виджета следует задать отчетный период или выбрать По фильтру:

Далее нужно выбрать направление сделок, стадию или группу стадий и какой именно параметр будет подсчитываться:

Кроме того, с помощью инструмента [image] можно изменить заголовок элемента виджета и цвет окна элемента с помощью инструмента

Результат настройки виджета можно увидеть после нажатия на кнопку Сохранить. Вернуть первоначальные настройки можно в любой момент, нажав соответствующую кнопку в заголовке окна виджетов:

Пример настройки виджета

Рассмотрим влияние параметров на отображаемую информацию на примере настройки группы взаимозависимых виджетов Сумма выставленных счетов, Сумма невыставленных счетов, Сумма выигранных сделок.

Например, мы хотим знать, общую сумму сделок по направлению Доставка мебели, а также сумму и количество проваленных сделок за IV квартал 2016 года.

Для этого:

  • Выбираем отчетный период Квартал, IV, 2016
  • Меняем заголовок в секции А на Сумма успешных сделок
  • Выбираем в секции А стадию Сделка заключена, что считать - Сумма сделок, устанавливаем переключатель в Сумма, выбираем направление Доставка мебели
  • Меняем заголовок в секции В на Сумма проваленных сделок
  • Выбираем в секции В группу стадий Сделка провалена, устанавливаем переключатель в Сумма, что считать - Сумма сделок, выбираем направление Доставка мебели
  • Меняем заголовок в секции C на Количество проваленных сделок
  • Выбираем в секции С группу стадий Сделка провалена, устанавливаем переключатель в Количество, что считать - Количество сделок, выбираем направление Доставка мебели

После сохранения изменения виджет будет выглядеть:

Числа на виджете являются ссылками, то есть кликнув по числу, можно перейти к отфильтрованному по отображаемому параметру списку сделок. Например, кликнув по цифре количества проваленных сделок, мы сможем увидеть, какие именно сделки провалены:

Список виджетов

Название виджета | Описание
Воронка продаж по сделкам | Отображает в графическом виде количество сделок на разных стадиях
Общая сумма сделок | Сумма сделок на всех стадиях
Сумма выигранных сделок | Сумма сделок на стадии "Сделка заключена"
Сумма сделок в работе | Результат вычитания из общей суммы сделок суммы выигранных сделок
Рейтинг по сумме выигранных сделок | Отображает место пользователя в рейтинге по сумме выигранных сделок, а также сумму сделок соседних в рейтинге мест.
Сумма выставленных счетов | Сумма выставленных счетов сделок на стадии "Сделка заключена"
Сумма невыставленных счетов | Сумма невыставленных счетов сделок на стадии "Сделка заключена"
Сумма выигранных сделок | Сумма сделок на стадии "Сделка заключена"
Контроль оплат выигранных сделок | Отображает в виде гистограммы по датам суммы выставленных и невыставленных счетов сделок на стадии "Сделка заключена"
Сделки в работе | Отображает в виде графиков по датам количество сделок в работе, количество звонков и дел по этим сделкам
Количество сделок в работе | Цифровое отображение количества сделок в работе
Количество дел | Цифровое отображение количества дел по сделкам в работе
Количество звонков | Цифровое отображение количества звонков по сделкам в работе
Количество забытых сделок | Количество сделок, предполагаемая дата закрытия которых еще не наступила и в течение отчетного периода по ним не было никаких активностей

Примечание: В таблице описаны виджеты демо-представления. Виджеты сделок конкретной CRM могут отличаться визуально и/или информационно.

Дополнительная информация

  • Аналитические отчеты в CRM


Канбан
250 / 401

Для визуализации продвижения сделок по этапам служит Канбан.

Канбан (яп. カンバン камбан) – метод организации работ (производственных, проектных), реализующий принцип «точно в срок» и способствующий равномерному распределению нагрузки между работниками (этапами работ).

Эта возможность активируется из выпадающего списка в левом верхнем углу панели управления на странице сделок, там же, где список сделок и аналитические отчеты.

Для переключения в режим канбана служит кнопка [image] .

Собственно канбан имеет вид таблицы, столбцы которой соответствуют стадиям сделки, а в ячейках расположены "стикеры" - сделки на данном этапе, в виде компактных карточек:

Для каждого из направлений сделок формируется свой канбан. В заголовках столбцов содержатся наименования стадий сделки данного направления и количество сделок в данном статусе. Если навести курсор на заголовок и нажать на карандаш [image], то можно перейти к настройке стадий сделки на страницу CRM > Настройки > С чего начать > Справочники.

Под заголовками расположена сумма сделок в данном статусе, которую они принесут, когда будут выиграны.

Каждая карточка канбана содержит основную информацию по сделке:

  • наименование - является ссылкой, кликнув на которую можно перейти к полной карточке сделки и просмотреть её подробности;
  • сумма сделки;
  • имя и фамилия контактного лица - является ссылкой, кликнув на которую можно перейти к карточке контакта с подробной информацией о нём;
  • дата начала.

Также в карточке содержится ссылка Дела, кликнув на которую можно выбрать из списка, какое дело запланировать для данной сделки. Кроме того, при наведении курсора на карточку в ней появляются символы каналов коммуникаций с контактом. Указанные для данного контакта каналы подсвечиваются синим, неуказанные остаются серыми:

Таким образом, можно сразу связаться с контактом по доступному каналу.

Основным плюсом структурирования сделок с помощью канбана является возможность динамически перемещать сделки из одного статуса в другой, отслеживая при этом изменение сумм на каждой стадии. То есть вы можете кликнуть на карточку сделки и, не отпуская клавишу мыши, перетащить её в другую стадию. При этом вверху столбца немедленно изменится сумма. Также можно переместить сделку сразу в одну из неуспешных финальных стадий - например, Сделка не заключена, Обработка приостановлена.

Неуспешные сделки больше не отображаются в канбане. Если требуется изменить неуспешный статус из финального на какой-либо другой, это можно сделать из списка сделок.

Дополнительная информация

  • Канбан в CRM


Коммерческие предложения
251 / 401

Коммерческое предложение в CRM представляет собой сущность, ориентированную на ознакомление клиента с предметом потенциальной сделки.

Менеджер, получая согласие от клиента на коммерческое предложение, может далее создавать сделку, высылать договор, выписывать счет и т.п..

Примечание: Так как конечной целью и желаемым результатом связей с контактами и фирмами является сделка, то финальный список товаров и услуг, а также итоговая сумма фиксируются в форме сделки и счета. Таким образом, первичное коммерческое предложение может существенно отличаться от сделки.

На странице CRM > Предложения представлен список предложений. Здесь возможно отслеживать и менять статусы предложений:

Способы создания предложения аналогичны методам выставления счета.

Рассмотрим форму добавления предложения:

Внимание! Отмеченная опция Доступно для всех открывает предложение для тех сотрудников, которым назначена такая же роль, как ответственному за предложение.

В группе параметров "О клиенте" можно выбрать контакт или компанию, которым направляется предложение. Или же можно создать новый контакт/компанию, кликнув на ссылку Создать и заполнив соответствующую форму добавления контакта/компании.

Аналогичным образом в группе параметров "О компании-поставщике" можно выбрать или создать компанию и её реквизиты.

Поля и наименования разделов предложения можно редактировать и удалять. Для этого используйте значки карандаша и крестика, доступные при наведении курсора мыши:

Примечание: по ссылке Показать поле можно вернуть в форму скрытые поля:

Зажав левой кнопкой мыши, поле можно переносить по форме.

Чтобы добавить свое поле, кликните по ссылке Добавить поле, появляющейся при наведении курсора мыши на область группы полей:

Выберите тип создаваемого поля. Выбрав тип Раздел, можно создать свою группу параметров предложения.

Внимание! Изменения формы добавления предложения будут сохранены даже если отменить его создание.

Вы можете отменить изменения формы, либо сохранить их для всех пользователей (доступно для администраторов), используя кнопку контекстной панели формы создания предложения:

После создания предложения его можно распечатать, скачать в виде PDF, отправить по email, выставить по нему счет или добавить событие:

Также можно создать сделку на основании коммерческого предложения, то есть конвертировать Предложение в Сделку из формы просмотра/редактирования:

или из списка Предложений:

Перед созданием Сделки следует выбрать её направление:

Внимание! При создании коммерческого предложения на основании сделки в список товаров нового предложения добавляются только товары, отсутствующие в созданных ранее на основании этой же сделки предложениях.

После отправки предложения на e-mail на ваш адрес придет копия письма в качестве подтверждения отправки.

Примечание: вид печатной формы предложения настраивается на странице CRM > Настройки > Печатные формы документов > Способы оплаты, где выбирается для редактирования предложение для компаний\контактов.

Список предложений можно экспортировать в Excel и csv аналогично экспорту контактов.

По нажатию кнопки [image] происходит переход к странице Канбан. Работа с ней аналогична работе со страницей канбана сделок.


Счета
252 / 401

В CRM (в коробочной версии - начиная с версии модуля 12.5.7) возможна работа со счетами, которые выставляются клиентам для оплаты продуктов или услуг.

На странице CRM > Счета выводится список счетов:

Примечание: В редакции "Проект" в списке сущностей максимум может отображаться 5000 элементов. Остальные будут храниться, но не будут видны, если не применять фильтры.

Цифра на пиктограмме счетов в верхнем меню CRM обозначает число незакрытых счетов, за которые текущий сотрудник является ответственным.

Аналогично стадиям сделок, в списке счетов можно менять их статусы. Счёт может быть закрыт как оплаченный, либо отклоненный:

Каждый сотрудник видит только те счета, которые определены его ролью.

Меню действий предоставляет следующие, очевидные из названия, возможности:

При выставлении/редактировании счёта есть возможность выбрать или создать как компанию-плательщик, так и компанию-продавец, кликнув на соответствующую ссылку. Создание компании подробно описано в уроке Добавить компанию.

Есть возможность распечатки счета без печати и подписей. Для этого в режиме просмотра счета выберите соответствующий пункт кнопки Печатать:

Список счетов можно экспортировать в Excel и csv аналогично экспорту контактов:

По нажатию кнопки [image] происходит переход к странице Аналитические отчёты по счетам

Расположение виджетов на странице, работа с ними и настройка аналогичны работе со станицей Аналитические отчеты по сделкам.

По нажатию кнопки [image] происходит переход к странице Канбан. Работа с ней аналогична работе со страницей канбана сделок.


Выставление счёта
253 / 401

Есть несколько способов выставления счёта клиенту:

  • через форму просмотра предложения\сделки или выбрав Создать на основании > Счёт в меню действий предложения\сделки:

  • нажав на кнопку Выставить счёт контекстной панели страницы со списком счетов;
  • нажав на "+", появляющийся при наведении курсора мыши на иконку cчетов в главном меню CRM:

  • выбрав Выставить счёт в меню действий контакта\компании;
  • нажав на кнопку Выставить счёт с закладки Счета\счёт формы просмотра контакта\сделки;

    • При использовании последних двух способов, соответствующие выбранной сущности данные будут сразу добавлены в группу полей Плательщик.

При использовании любого из вышеперечисленных способов, будет открыта форма создания счёта:

Разберем некоторые моменты заполнения счёта:

  • в обязательном поле Тема следует указать название или тему счета;
  • в обязательном поле Статус выбирается текущее состояние счёта:

    Возможно добавление\удаление статусов счёта. Читайте об этом в уроке Справочники.

  • в секции Плательщик в обязательном поле Контрагент нужно выбрать, будет ли выставляться счет контакту или компании, а также выбрать/создать контакт или компанию. После этого автоматически будет подключена форма с данными контрагента.

    Если к выбранной компании привязан контакт, то его данные также будут выведены в форме. Если контакт не привязан, то можно выбрать его из перечня или создать.

    Внимание! Если выбирается контакт, уже связанный с какой-либо компанией, то эта его связь не меняется, а для текущего счета устанавливается временная связь. Если же контакт не привязан или создается вновь, то устанавливается его связь с компанией, для которой выставляется счет.

    Примечание: телефон и e-mail контрагента не отображаются при отсутствии прав на чтение связанных контактов и компаний.

    Кроме общих сведений, в форме контрагента имеется вкладка Реквизиты, где можно выбрать, с какими реквизитами будет выставлен счет. Эти данные берутся из профиля клиента, если они были заданы на закладке Реквизиты.

  • выберите местоположение плательщика для учета заданных в системе налогов. Поле Местоположение является обязательным;
  • выберите способ оплаты, доступный для данного типа плательщика;
  • в секции Компания продавец будет автоматически задана ваша компания (то есть та, от имени которой выставляется счёт) и её реквизиты, при условии, что в Настройках ранее уже были установлены Реквизиты ваших компаний. Если таких компаний несколько, то в данной секции можно будет выбрать или создать новую;
  • в обязательном порядке следует выбрать или создать товары\услуги счёта.
Внимание! При создании счёта на основании коммерческого предложения в список товаров нового счета добавляются только товары, отсутствующие в созданных ранее на основании этого же предложения счетах.

Сохраните внесенные изменения.

Все реквизиты продавца и плательщика, а также товары, включенные в счет, будут автоматически добавлены в онлайн-счет, печатную форму счета и в файл формата .PDF, который можно скачать или отправить по e-mail:


Счета онлайн
254 / 401

Одним из наиболее быстрых и удобных способов оплаты счета является оплата онлайн.

После выставления счета и его сохранения становится доступна онлайн ссылка на счет:

Ссылка для каждого счета индивидуальна. Её можно отправить клиенту любым удобным способом - через чат, по электронной почте и т.д. Перейдя по ней, клиент увидит на отдельной странице браузера полностью сформированный счет с реквизитами плательщика и продавца, списком товаров, суммой к оплате и доступными платежными системами:

При клике по кнопке какой-либо платежной системы можно выбрать перенаправление на страницу этой системы, либо возврат к способам оплат:

Кроме быстрой электронной оплаты, клиент может здесь же скачать или распечатать счет.

После оплаты онлайн статус счета в списке CRM автоматически меняется на "Оплачен"

Дополнительная информация

  • Счета онлайн


Лиды
255 / 401

Лид - запись о какой-либо форме контакта (телефон, e-mail, очная встреча и так далее), которая имеет потенциальную возможность перерасти в сделку.

На данной странице:

Подробное описание понятия "лид"

Лид (lead, целевой лид) — потенциальный клиент, тем или иным образом отреагировавший на маркетинговую коммуникацию. К таким реакциям относятся, например, регистрация на сайте рекламодателя, заполнение клиентской анкеты, телефонный звонок поставщику услуг или товаров, собственно заказ услуг или приобретение товара.

Термином лид принято обозначать потенциального покупателя, любую контактную информацию с ним (имя, номер телефона, e-mail адрес), полученную для последующей менеджерской работы с клиентом. В русском языке наиболее близкими к термину лид является клиент, проявивший интерес, зацепка за клиента.

Первым результатом коммуникации с лидом является получение у каждого лида контактных данных, с целью последующего взаимодействия с ним и, желательно, перевода в категорию клиентов. Регистрация лидов — фиксирование отзвука со стороны потенциального клиента на маркетинговое предложение продавца. Последующий этап отработки контакта менеджерами компании — выращивание лида, заключающийся в подготовке потенциального клиента (информированию, убеждению) к покупке товара или услуги. В результате происходит преобразование потенциальных покупателей в реальные, потенциальных продаж - в реальные. Такой менеджмент называется конверсией лидов.

Таким образом, любой человек, позвонивший (зарегистрировавшийся на сайте) с любой целью, пусть даже из любопытства или для уточнения режима работы вашей организации, становится еще не клиентом (ведь он еще не купил и даже не решил что-либо купить у вас), но уже лидом, при условии, что вы получили от него минимальную информацию - имя и способ связи (e-mail, телефон, адрес в мессенджере).

представлен список всех имеющихся лидов:

Примечание: В редакции "Проект" в списке сущностей максимум может отображаться 5000 элементов. Остальные будут храниться, но не будут видны, если не применять фильтры.

Примечание: По умолчанию список сущностей отсортирован следующим образом:
  • ближайшие невыполненные дела текущего пользователя
  • ближайшие невыполненные дела других пользователей
  • дата создания сущности

В списке лидов можно менять статус любого лида, а также добавлять дела.Идентичные операции описаны в уроке Сделки.

Профиль лида аналогичен профилю сделки, за исключением вкладки Счёт. Действия, доступные из профиля лида, включая назначение роботов и триггеров, также аналогичны действиям в профиле Сделки.

Примечание: в списке лидов в колонке дел красным шрифтом выделены незавершенные дела с истекшим сроком выполнения. Цифра на иконке обозначает число лидов с незавершенной обработкой, за которые вы являетесь ответственным (если в настройках не указано иное).

Обработка лида не завершена, пока лид не переведен в какой-либо из финальных статусов (сконвертирован или некачественный лид), или же лид имеет незавершенные дела с истекшим сроком выполнения.

Розовым фоном обозначена колонка Дела у лидов с незавершенной обработкой, не имеющих дел и за которые вы являетесь ответственным.

Меню действий (за исключением конвертации), просмотр лида, действия, доступные с помощью колонки Дела, аналогичны таковым для контактов. Единственное отличие меню действий лида от меню действий контакта - наличие пункта Создать на основании.

Импорт лидов доступен из формата CSV и аналогичен импорту контактов.

Экспорт лидов доступен в CSV и в Excel и аналогичен экспорту контактов.

Поиск и обработка возможных дублей аналогична таковым для контактов.

По нажатию кнопки [image] происходит переход к странице Аналитические отчёты по лидам

Расположение виджетов на странице, работа с ними и настройка аналогичны работе со страницей Аналитические отчеты по сделкам.

Специфические отчеты для лидов и принципы их построения описаны ниже:

  • Количество активных лидов - лиды считаются активными, если в отчетный период, по которому установлен фильтр, с ними совершались какие-либо дела и/пли переход по статусам.
  • Конверсия - процент количества сконвертированных лидов от количества активных.
  • Потери - процент количества "некачественных" лидов от количества активных.

По нажатию кнопки [image] происходит переход к странице Канбан. Работа с ней аналогична работе со страницей канбана сделок.

Дополнительная информация

  • Аналитические отчеты по лидам


Добавить лид
256 / 401

Есть несколько способов добавления лида:

  • клик по кнопке Добавить лид на контекстной панели страницы со списком лидов;
  • нажав на "+", появляющийся при наведении курсора мыши на иконку лидов в главном меню CRM:

  • через rest api;
  • из входящего письма на почту;
  • из входящего звонка на номер IP-телефонии;
  • на основе заполненной веб-формы на вашем сайте; подробнее об этом читайте в курсе Администратор. Модули;
  • автоматически из визит-трекера.

В первых двух случаях возникнет форма добавления лида:

Название лида - единственное обязательное для заполнения поле. Введите имя добавляемого лида.

Группа полей "О лиде"

  • Обращение - выберите из подключенного справочника предпочитаемое лидом обращение.
  • Статус - выберите состояние вашего лида:

    Список возможных статусов лида можно настроить под ваши требования, как описано в уроке Справочники.

    Возможна установка статуса сразу для нескольких лидов из списка. Данное действие аналогично описанному в уроке Добавить контакт групповому назначению ответственного.

  • Дополнительно о статусе - введите информацию, раскрывающую выбранный статус.
  • Валюта - нажмите на пиктограмму стрелочки и в выпадающем списке выберите валюту, в которой будет совершаться сделка.

    Примечание: список валют настраивается на странице CRM > Настройки > Валюты.

  • Возможная сумма сделки - введите рассчитываемую сумму, которой будут оперировать в процессе сделки.

    Примечание: в данном поле должны быть записаны только цифры, без пробелов. В противном случае лид не добавится и будет выведено сообщение о некорректном вводе.

  • Источник - нажмите на пиктограмму стрелочки и в раскрывшемся списке выберите вариант того, как вы узнали о контакте:

    Примечание: настроить свои названия источников вы можете на странице CRM > Настройки > Справочники.

  • Дополнительно об источнике - при желании напишите дополнительную информацию об источнике.
  • Ответственный - здесь указываются данные, идентифицирующие ответственное за данный лид лицо. Изначально выставляется E-mail и ID пользователя, который вносит данные о лиде. Указать другого сотрудника из структуры портала, можно нажав на ссылку Добавить из структуры. Это делается аналогично выбору компании, описанному в уроке Поиск.

    Возможно групповое добавление ответственного. Оно описано в уроке Добавить контакт.

  • Доступен для всех - отметьте опцию, чтобы сделать лид открытым. Это может понадобиться при разграничении прав доступа.

    Внимание! Отмеченная опция Доступен для всех открывает лид для тех сотрудников, которым назначена такая же роль, как ответственному за лид. Помните, что для лидов возможна установка прав доступа по каждому статусу отдельно.

Группа полей "О контакте"

Поля данной вкладки аналогичны полям, заполняемым при добавлении контакта.

Группа полей "Дополнительно"

Здесь расположены созданные для лидов пользовательские поля.

Возможные товары

Данная вкладка аналогична таковой для добавления сделки.

Примечание: при добавлении нового лида может осуществляться проверка на дубликаты. Подробнее об этом читайте в уроке Прочее.

Для добавления нового лида и перехода на страницу со списком лидов нажмите Сохранить.

Чтобы добавить лид и перейти к созданию еще одного нажмите Сохранить и добавить еще.


Конвертация лида
257 / 401

Лид, как потенциально возможная сделка, может превратится в контакт, компанию, и, при удачном стечении обстоятельств, в сделку. Такое превращение называется конвертацией лида.

Конвертация лида - однонаправленный процесс. То есть сконвертированный лид нельзя "разконвертировать" или отменить конвертацию. Также нельзя сконвертировать контакт (компанию, сделку) в лид.

Для конвертации лида из списка лидов служит пункт Создать на основании в Меню действий:

или такой же пункт на контекстной панели в режиме просмотра/редактирования:

Далее из выпадающего списка следует выбрать, во что именно конвертировать лид:

Если в выбранном пункте конвертации присутствует Сделка, то следует выбрать и Направление сделки:

После этого будет проверено, все ли пользовательские поля лида имеются также и в выбранных сущностях. Если какие-либо поля отсутствуют, то выдается соответствующее сообщение:

Нажмите кнопку Продолжить и перейдите к формам добавления сущностей. В формах сущностей автоматически будут заполнены поля, соответствующие полям лида, проверены совпадения. Также будут созданы пользовательские поля и установлены значения по умолчанию, если они были заданы.

После заполнения необходимых полей нажмите кнопку Сохранить и соответствующие сущности будут созданы.

Сведения о них будут также сохранены в соответствующих вкладках формы редактирования лида.

Внимание! При создании компании на основании лида название компании берётся из поля "Название компании", а при его отсутствии - из поля "Название".

Сконвертированный лид отобразится в списке лидов с новым статусом Сконвертирован, этот статус нельзя изменить. Сконвертированный лид можно редактировать или конвертировать вновь, но изменения не будут отображаться в ранее созданных связанных сущностях.

Внимание! При конвертации лида в сделку в список товаров новой сделки добавляются только товары, отсутствующие в созданных ранее на основании этого же лида сделках.

Сконвертированный лид можно удалить. При удалении дела лида передаются контакту, если он был создан, а при отсутствии контакта - компании, если она была создана .


Отчеты
258 / 401

При первом обращении к данной странице вы увидите, какие типовые отчеты CRM идут в поставке:

Представлены отчеты по сделкам, товарам, лидам, счетам и делам. Доступные сотруднику данные для отчетов зависят от его прав доступа.

Сотруднику с правом доступа Менеджер доступны лишь отчеты по его собственной деятельности и воронка продаж будет составляться лишь по сделкам, где он выступает ответственным.

Сотруднику с правом доступа Начальник отдела доступны отчеты и воронка продаж по работе его подчиненных.

Сотрудникам с правами доступа Директор и Администратор доступны отчеты по всем сотрудникам компании.

Для многих отчетов доступны диаграммы.

Стандартные отчеты нельзя менять или редактировать. Для настройки стандартного отчета под требования конкретного бизнеса следует скопировать выбранный отчет с помощью команды Меню действий, а затем редактировать его. При этом можно использовать пользовательские поля, добавленные при индивидуальной настройке форм в CRM.

Внимание! С версии 15.5.0 добавлена поддержка множественных пользовательских полей, но при работе с ними будет доступен не весь функционал работы с пользовательскими полями.

Если выбрать пункт Копировать, то откроется форма создания отчета с выставленными параметрами копируемого отчета.

Чтобы просмотреть интересующий вас отчет кликните по нему левой кнопкой мыши:

Примечание: созданный отчет доступен только его автору.

Чтобы сохранить отчет в виде файла .xls, либо открыть этот файл для просмотра или печати в каком-либо приложении, нажмите Экспорт Excel:


Воронка продаж
259 / 401

На странице Воронка продаж представлено количественное соотношение всех сделок на разных стадиях в графическом и табличном виде для проведения анализа продаж компании. Наименование стадий и порядок их следования можно задать на странице Настройки -> Справочники -> Стадии сделки. Стадии сделки также являются координатными точками для построения собственно воронки продаж.

На странице выведены таблицы и диаграммы двух видов сделок: тех, которые находятся на каком-либо этапе заключения и тех, которые завершились неудачей:

В таблице Сделки в работе каждый нижележащий тип сделок включает в себя все те, что расположены выше, т.е. условно говоря считается, что сделка на стадии Сделка заключена прошла все предыдущие этапы и включена в них при подсчете статистики.

В диаграмму незаключенных сделок попадают все сделки, находящиеся на стадии Сделка не заключена и Обработка приостановлена (Настройки -> Справочники -> Стадии сделки).

Для конверсионной воронки продаж полное количество сделок получится, если сложить все сделки, находящиеся на начальной стадии ("В обработке") (80%), и незаключенные сделки (20%).

Примечание: 1% может теряться в результате остатка от деления.

Остановимся подробнее на том, как формируется воронка продаж.

Например, рассмотрим стадию Переговоры в процессе. 60% показывает, какой процент сделок от общего числа были или находятся на этой стадии. Т.е. 60% всех сделок завершили стадии В обработке и Уточнение информации. Цифра 6 указывает фактическое количество таких сделок. Высота цветной полоски визуально отображает количественное соотношение сделок на данной стадии по сравнению с другими, а в колонке Сумма написана общая сумма таких сделок.

Примечание: вы можете изменить логику построения воронки продаж, чтобы каждая нижележащая стадия не включала в себя предыдущие. Для этого измените вид воронки на классический:


Face-трекер
260 / 401

Поскольку одной из основных задач любой CRM является задача получения лидов, в Битрикс24 для этого реализованы разнообразные возможности. Одной из них является Face-трекер, то есть функция распознавания лиц, основанная на технологии нейронных сетей.

Face-трекер позволяет, один раз настроив видеокамеру, постоянно пополнять вашу CRM новыми лидами, вести подсчет новых и повторных посетителей, то есть автоматизировать учет клиентов.

При первом включении страница Face-трекера (CRM -> Face-трекер) имеет вид:

Подключите камеру, при необходимости установите драйвера, разрешите её использование:

и начинайте распознавание. Вы можете фотографировать каждого посетителя отдельно с помощью кнопки [image] или отметить пункт Автоматически делать фотографии. В этом случае каждое новое появившееся в фокусе камеры лицо будет автоматически сфотографировано (возможна задержка до нескольких секунд, в зависимости от быстродействия камеры) и распознано:

Каждому новому посетителю в случае успешного распознавания лица Face-трекер присвоит условное имя "Посетитель+порядковый номер" и предложит выполнить следующие действия:

  • сохранить в CRM
  • найти профиль Вконтакте

В CRM клиенты сохраняются как лиды с именем Посетитель+№, в качестве ответственного назначается менеджер, под авторизацией которого включен Face-трекер.

При поиске клиента Вконтакте будут найдены похожие фотографии в профилях (не только в аватарах) и упорядочены по проценту совпадения.

Вы можете пройти по ссылке на страницу Вконтакте и, если убедитесь, что человек найден правильно, выбрать его данные для записи в CRM.

Обратите внимание! Ответственность за соответствие использования информации о конкретном человеке юридическим требованиям вашей страны вы несете самостоятельно!

Условия использования сервиса

Если клиент уже был зарегистрирован в CRM, то в Face-трекере вы увидите информацию о количестве его посещений, дате и времени последнего посещения и ссылку на его профиль Вконтакте, если он существует и был ранее найден.

Статистика по новым, повторным и сохраненным в CRM посетителям выводится в отдельной секции на странице:

Также подсчитываются затраты условных "единиц распознавания".

На пробный период выделяется 1000 бесплатных единиц. Перейдя по ссылке Добавить, вы сможете заказать и оплатить дополнительные единицы распознавания.

Правила подсчета стоимости распознований в единицах описаны здесь.


CRM-формы
261 / 401

Для большинства бизнесов работа с CRM начинается с обработки лидов, поэтому одной из основных задач является автоматизация получения лидов и расширение источников их генерации. Продуктивным и удобным источником являются формы. Создание форм полностью интегрировано в CRM Битрикс24, поэтому с их помощью можно получать не только лиды, но и контакты, компании, заполнять поля сделок, счетов, предложений и проч.

Страница конструктора форм доступна из пункта CRM-формы основного меню или в разделе CRM >CRM-формы.

Примечание: этот пункт меню доступен пользователю, если для его роли установлены соответствующие права доступа.

При переходе на страницу CRM-форм имеется возможность как создать новые, так и воспользоваться предустановленными формами:

Примечание: количество используемых CRM-форм зависит от редакции продукта.

Меню действий предустановленных и созданных форм отличаются - созданные формы можно удалять и редактировать, а предустановленные только просматривать.

В случае необходимости редактирования предустановленной формы следует воспользоваться пунктом меню Создать на основании - будет создана копия формы, которую можно изменять. Если вы всё же решите использовать предустановленные формы, то обратите внимание на следующий нюанс: предустановленные формы активируются в момент первого входа на страницу CRM >CRM-формы, поэтому ответственным за создаваемые сущности назначается тот пользователь, который осуществил первый вход. Изменить ответственного в предустановленных формах впоследствии будет нельзя. Но можно изменить ответственного в уже созданной сущности, например, с помощью групповых действий в панели быстрых команд.

Все доступные на странице конструктора форм параметры можно разделить на две большие группы: основные и дополнительные. Успешная работа формы возможна и в случае настройки только основных параметров. Для такой настройки не требуются специальные знания и навыки.

Настройка же дополнительных параметров может помочь индивидуализировать форму, предварительно стратифицировать лиды, увеличить конверсию и т.д. Её выполнение рекомендуется для более опытных пользователей.

Кроме того, существует группа параметров, которые автоматически сохраняются в создаваемых из CRM-формы сущностях, но не доступны для редактирования или задания вручную при создании сущностей другими способами. К ним относятся, например, UTM-метки и признак Создан CRM-формой. Эти метки и признаки могут быть использованы для поиска и фильтрации сущностей в списках.

Что такое UTM-метки.
UTM метки – это параметры (переменные) содержащие дополнительные данные, которые добавляются к URL целевой страницы (landing page) и позволяют передать в системы веб-аналитики дополнительную информацию о характеристиках трафика. При использовании utm-меток можно отследить и проанализировать большинство источников трафика, например, определить, какой из URL-адресов обеспечивает больше всего трафика или по какой ключевой фразе перешел пользователь.
Например, ссылка https://1c-bitrix/about/?utm_source=google&utm_campain=cpc содержит 2 utm-метки - source (источник трафика) и campain (название рекламной кампании).

После создания и сохранения CRM-формы она появится в списке ваших форм, где её можно включать/выключать с помощью специальной кнопки. Здесь же можно отслеживать статистику и информацию, связанную с формой - конверсию, количество созданных CRM-сущностей, дату и время активации и т.п.

При клике по цифре, обозначающей количество созданных CRM-сущностей произойдет переход к списку конкретной сущности, отфильтрованному по признаку Создан CRM-формой.

При переходе по публичной ссылке вы увидите, как созданная форма будет выглядеть для клиентов:

После того, как форма будет заполнена клиентами, информация из неё появится в таблицах соответствующих сущностей и станет доступна для дальнейшей обработки в соответствии с целями вашей CRM.

Дополнительная информация

  • Создаем CRM-форму за минуту: без сайта и программиста
  • Разметка ссылок utm метками


Основные параметры формы
262 / 401

При создании новой формы или редактировании существующей следует настроить сущности, которые будут создаваться на основании формы:

Далее следует указать:

  • Название формы - под ним форма будет храниться в вашем CRM
  • Заголовок формы - будет виден клиенту, заполняющему форму
  • Описание формы - может включать подсказки для заполнения, информационные или рекламные сообщения и т.п.

  • Поля - из списка справа нужно выбрать поля сущностей CRM, которые должен будет заполнить посетитель. В списке перечислены все сущности и все их поля, в том числе пользовательские, то есть специально созданные для целей конкретного бизнеса. Поля можно перемещать и располагать в нужном порядке с помощью кнопки [image] слева от поля. Также можно добавить элементы формы из панели элементов справа, изменить текст на кнопке отправки формы, выбрать цвета фона и текста формы, назначить ответственного за обработку лида:

    • Каждое поле формы также можно настроить: задать название, отличное от названия поля в сущности, описание - подсказку для заполнения или шаблон ввода, указать обязательность, множественность, необходимость проверки. Шестеренка настроек [image] располагается справа от поля. Там же имеется кнопка удаления поля из формы.

    Поскольку настроено создание определенной сущности, а поля для формы могут выбираться из разных, то при сохранении CRM-формы может быть обнаружено, что какое-то из полей не существует в создаваемой в CRM сущности. В таком случае будет выдано предупреждение об этом и предложение создать такое поле:


Дополнительные параметры формы
263 / 401

В блоке настройки дополнительных параметров можно кастомизировать Подпись, Правила, Документы, Значения, Метрика, Вид, CSS, Лицензия, Действия, Код. Каждое наименование параметра является ссылкой, которая ведет на соответствующий раздел настроек.

  • Подпись - поставьте галочку, если следует убрать подпись Заряжено Битрикс24;
  • Правила для полей - здесь можно задать условия демонстрации или скрытия полей (например, запрашивать заполнение поля E-mail, если поле Телефон не заполнено);
  • Создание документов - укажите, какие сущности CRM будут создаваться из формы и какие действия будут выполнены при обнаружении дубликатов:

    • Перейти к блоку создания документов можно также по ссылке настроить в верхней части редактора формы. Там же перечислены сущности, которые будут создаваться при заполнении формы:

    Обратите внимание: при создании Сделки или Предложения автоматически будет создан Контакт.

    Примечание. Создаваемый Лид, Контакт, Компания и Предложение по-умолчанию имеют флаг "Доступен для всех". Создаваемый Контакт по-умолчанию имеют флаг "Участвует в экспорте контактов".

    Если в секции Сохранять данные из формы в документы: отмечен пункт [image] , то будет активирован блок Настройка счета, в котором указывается, следует ли создавать в качестве плательщика Контакт или Компанию, какой сервис для приема платежей онлайн будет использоваться, а также настраивается список товаров счёта.

    Примечание. Настройка платежных систем осуществляется на странице CRM > Настройки > Способы оплаты и подробно описана в уроке Способы оплаты.

    При формировании списка товаров счёта открывается окно Настройки, где можно задать название списка и перечислить товары. Товары могут быть как выбраны из каталога, так и внесены непосредственно в список. Если у каталожных товаров будет изменена цена или название, то в счёт будут внесены товары с изменениями, но в каталоге они изменены не будут.

  • Значения полей по умолчанию - при отмеченном пункте "заполнять поля в CRM автоматически при отправке формы" можно выбрать поля документов и указать их значения по умолчанию:

    • В том числе можно задать собственное название для Дела, автоматически создаваемого при создании сущности CRM из формы.

    Также можно использовать тэги для персонализации поля:

    При их использовании в момент создания сущности из CRM-формы незаметно для заполняющего форму произойдет автоматическая замена тэгов на установленные данные. Например, как на иллюстрации выше, Название лида будет заменено на Название формы (тэг %crm_form_name%), из которой он создан.

    Для каждого тэга имеется всплывающая подсказка, объясняющая его смысл:

    Другие возможности указания значений полей формы.
    Например, можно автоматически заполнять соответствующие поля CRM-формы именем, фамилией, e-mail-адресом пользователя, работающего с формой в данный момент. Эти данные могут быть взяты из авторизационных данных на сайте. Такая возможность обеспечивается разработчиком путем изменения JS-кода вставки на сайт формы.
    Важно! JS-код может быть откорректирован под особые требования клиента разработчиком, имеющим достаточный уровень квалификации и четкое понимание пожеланий клиента и способов их реализации.

  • Метрика - если вы пользуетесь системами веб-аналитики Google Analytilcs или Яндекс Метрика, а также планируете разместить CRM-форму на сайте, где установлены счетчики этих систем, то вы можете добавить имеющиеся у вас идентификаторы счетчиков в соответствующие поля:

    • Также вы можете задать создание событий для воронки Google:

    Таким образом можно осуществлять отправку событий виртуальных страниц в Google Analytilcs, указать их в настройках ГуглАналитики и получить график-воронку.

    Обратите внимание: идентификаторы Google Analytilcs и Яндекс Метрики, приведенные для примера в CRM-форме, не являются реальными и не инициализируют никакой счетчик. При установке CRM-формы на ваш сайт следует заменить их на актуальные.
  • Вид формы - здесь можно выбрать тип публичной страницы формы, включить или отключить рамочное оформление формы, а также загрузить картинку, которая будет служить фоном;
  • Свой CSS - вы можете использовать свои стили CSS, если отметите соответствующий пункт и либо зададите путь к css-файлу, либо опишете таблицу стилей непосредственно в текстовом окне:

  • Лицензионное соглашение - здесь можно выбрать, показывать ли кнопку принятия лицензионного соглашения, а также задать текст на кнопке и текст собственно лицензионного соглашения:

  • Действие после отправки формы - секция предназначена для задания сообщений при успешной или неуспешной отправке формы, а также ввода адресов ссылок для перенаправления пользователя в зависимости от результата отправки формы;
  • Ссылка и коды - здесь расположены ссылка на создаваемую форму и её HTML-коды. Публичную ссылку можно отправлять клиентам любым удобным способом. А скопировав соответствующий код и добавив его в код HTML-страницы вашего сайта, вы можете выбрать из нескольких вариантов показа формы - на странице, во всплывающем окне по ссылке, по кнопке или автоматически.

    • Обратите внимание: коды и публичная ссылка станут доступны после первого сохранения форм.


Виджет на сайт
264 / 401

Увеличение конверсии продаж - основная задача CRM. Одним из путей её решения является расширение набора каналов коммуникации клиента с менеджером компании. В Битрикс24 имеется несколько вариантов коммуникаций, в том числе размещение на сайте специального виджета для включения онлайн-чата, обратного звонка и формы обратной связи.

Примечание: установка виджета на сайт доступна для всех редакций продукта.

Страница списка виджетов доступна из пункта Виджет на сайт основного меню:

Нажмите на рисунок, чтобы увеличить

или в разделе CRM >Виджет на сайт:

Нажмите на рисунок, чтобы увеличить

Примечание: этот пункт меню доступен пользователю, если для его роли установлены соответствующие права доступа.

При переходе на страницу со списком виджетов имеется возможность как создать новый, так и воспользоваться предустановленным, настроив его в соответствии со своими потребностями:

Нажмите на рисунок, чтобы увеличить

Предустановленный виджет нельзя удалить, но можно отредактировать. Формы редактирования и создания виджета практически одинаковы:

Нажмите на рисунок, чтобы увеличить

В форме создания/редактирования можно задать основные параметры виджета, а также настроить каждый канал коммуникации отдельно.

Дополнительная информация

  • Виджет на сайт: онлайн-чат, обратный звонок и форма
  • Виджет для онлайн-чата на сайт в Открытых линиях


Основные параметры виджета
265 / 401

Основными параметрами, настраиваемыми в виджете, являются:

Нажмите на рисунок, чтобы увеличить
  • активность каналов (открытая линия, CRM-форма, обратный звонок).

    Вы можете оставить только те каналы, которые предпочитают ваши клиенты. Также следует иметь в виду, что онлайн-чат и форма обратной связи — бесплатны, для обратного звонка вы платите только за фактические звонки клиентам как за исходящие вызовы.

  • 1 - цвет фона и иконок виджета.

    Внешний вид виджета настраивается с помощью палитры. Результат сразу отображается в блоке Общий вид.

  • 2 - положение виджета на странице сайта.

    Виджет может быть расположен в одной из шести зон: сверху слева, сверху по центру, сверху справа, снизу слева, снизу по центру, снизу справа.

  • 3 - интервал перед показом виджета;

    Можно выбрать, показывать ли виджет сразу после загрузки страницы сайта или через какой-либо интервал времени от 3 секунд до 2 минут.

  • 4 - код для вставки.

    Для того, чтобы виджет появился на вашем сайте, следует скопировать его код из соответствующего окна и вставить в код шаблона вашего сайта перед закрывающим тегом </body>.

    Код для вставки будет доступен после сохранения настроек виджета.

    При размещении кода виджета в шаблоне сайта на странице появится его анимированная иконка. При нажатии на иконку экран затеняется, виджет разворачивается в несколько иконок с подсказками, соответствующих подключенным каналам:

    Нажмите на рисунок, чтобы увеличить


Настройка каналов коммуникаций и приветствия
266 / 401

На странице Редактирование виджета имеются отдельные секции для настройки доступных каналов коммуникаций:

Нажмите на рисунок, чтобы увеличить

Рис. 1.

Возможна настройка каналов:

  • 1 - Открытая линия
  • 2 - CRM-форма
  • 3 - Обратный звонок
  • 4 - Автоматическое приветствие

Каждый из каналов может быть включен или отключен с помощью кнопки [image].

Кнопка настройки 5 (Рис.1) имеется в каждой секции и предназначена для настройки конкретного канала.

Область настройки Параметров отображения 6 (Рис.1) также имеется в каждой секции и позволяет для каждого канала выбрать, на какой странице сайта его показывать. По умолчанию виджет будет демонстрироваться на всех страницах сайта.

Рис. 2.

Открытая линия

Этот канал коммуникации позволяет собирать сообщения и вопросы клиентов, поступающие из разных источников (мессенджеры, боты, соцсети), в Бизнес-чат Битрикс24. Менеджер отвечает клиентам в онлайн-чате, а они получают сообщения там, где задавали вопрос.

По клику на кнопку настройки 5 в секции 1 (Рис.1) произойдет переход на страницу настройки Открытой линии, где следует задать её название 1.1, указать подключаемые источники 1.2:

Нажмите на рисунок, чтобы увеличить

Рис. 3.

и настроить остальные разделы, как указано в уроке Открытые линии.

CRM-форма

По клику на кнопку настройки 5 в секции 2 (Рис.1) произойдет переход на страницу редактирования CRM-формы.

Создание, настройка и редактирование CRM-форм подробно описаны в соответствующем уроке.

Обратный звонок

Создание, настройка и редактирование канала Обратный звонок практически аналогичны работе с CRM-формой и доступны по клику на кнопку настройки 5 в секции 3 (Рис.1).

Настройка формы обратного звонка предполагает, что будут заданы её заголовок 3.1, текст приглашения 3.2, текст на кнопке 3.3:

Нажмите на рисунок, чтобы увеличить

Рис. 4.

Поле Телефон настраивается по клику на "шестеренку" 3.4.

В соответствующем окне можно задать его название [image], множественность и обязательность [image], способ проверки [image] и другое:

Рис. 5.

В поле Значение по умолчанию [image] можно задать телефонный код страны. Страна определится автоматически и будет обозначена в форме обратного звонка соответствующим флагом:

Внимание! Возможность настройки телефонного кода страны по умолчанию и автоматического определения страны появится в коробочных редакциях, начиная с версии CRM 17.0.

Дополнительные параметры настраиваются по клику на ссылку Дополнительно 3.5 (Рис.4).

При задании дополнительных параметров 3.5 (Рис.4) можно настроить секцию Обратный звонок. Там следует отметить соответствующий пункт [image], а также выбрать номер обратного звонка [image] (то есть один из номеров, привязанных в Телефонии) и текст [image], который будет произнесен ответственному перед началом звонка:

Нажмите на рисунок, чтобы увеличить

Рис. 6.

Таким образом, алгоритм работы по каналу Обратный звонок следующий:

  • клиент, предпочитающий телефонную связь, оставляет свой номер в форме на сайте;
  • в соответствии с настройками маршрутизации менеджер получает входящий звонок со специальным названием "Обратный звонок...";
  • при ответе менеджера фиксируется исходящий звонок клиенту;
  • все заказанные обратные звонки, вне зависимости от ответа менеджера, автоматически попадают в сущности CRM, указанные в секции Создание документов:

Нажмите на рисунок, чтобы увеличить

Рис. 7.

Автоматическое приветствие

В секции 4 (Рис.1) производится настройка автоматического приветствия посетителя на сайте:

Нажмите на рисунок, чтобы увеличить

Рис. 8.

Здесь можно сменить фамилию и имя сотрудника, приветствующего посетителя на сайте, и выбрать фото из предлагаемой коллекции. Также можно задать текст, соответствующий вашим корпоративным правилам. Другие возможности - задержка показа, исключение страниц, индивидуальные приветствия для определенных страниц - позволят вам гибко настроить и кастомизировать приветствие.


История
267 / 401
  • Таблица просмотра истории
  • Добавить событие
  • Удалить событие
  • Добавить задачу
  • Написать письмо
  • История переписки

Таблица просмотра истории

На странице CRM > История отображаются события CRM и действия, произведенные с сущностями:

На этой странице фиксируются все действия, произведенные со всеми сущностями CRM. Но добавление событий возможно в только в профиле конкретной сущности на соответствующих закладках.

Примечание: История всех изменений с возможностью восстановления доступна только для платных редакций Битрикс24.

Добавить событие

Способы добавления события аналогичны первым трем таковым, описанным в следующем уроке, с той лишь разницей, что следует выбирать Добавить событие.

Также добавить событие к сущности можно с закладки История в режиме ее просмотра.

Откроется форма добавления:

  • Тип события - выберите, какого вида добавляемое событие:
    • Информация;
    • Телефонный звонок (устарел и оставлен для обеспечения обратной совместимости);
    • Отправлен email (устарел и оставлен для обеспечения обратной совместимости).
  • ниже введите описание события;
  • Дата события - изначально будет проставлена текущая дата. Чтобы изменить дату, кликните по ней левой кнопкой мыши и она примет следующий вид:

    Далее вы можете вручную править дату и время, либо воспользоваться календарем, кликнув по соответствующей пиктограмме.

  • Прикрепить файл - выберите файлы, которые вы хотите приложить к добавляемому событию.

Примечание: при добавлении события к сделке или лиду появляются поля Стадия сделки и Статус лида соответственно. После добавления события сделка/лид переходят в указанную стадию/статус.

Для добавления события нажмите Добавить.

Удалить событие

Удалить событие, добавленное любым способом, можно либо непосредственно на закладке "История" соответствующей сущности, либо из таблицы событий. Для этого нужно выбрать в меню действий пункт Удалить:

Добавить задачу

Добавить задачу к какой-либо сущности можно несколькими способами. Рассмотрим их.

  • Путем выбора пункта Добавить задачу в меню действий.
  • В режиме просмотра сущности на закладке Дела:

  • Вы можете добавить задачу сразу нескольким сущностям из списка. Для этого отметьте их галочками в колонке флажков и выберите пункт Добавить задачу:

    Затем нажмите Применить.

В открывшейся форме, в поле наименования задачи, будет указано CRM, а в привязываемых элементах CRM - выбранная сущность:

Добавленная задача отразится в календаре ответственного за ее выполнение. Изменение задачи в календаре автоматически приведет и к ее изменению в CRM.

Добавленные задачи и события будут отображены на странице Мои дела и на закладке Дела детального просмотра сущности.

Примечание: в колонке Дела общего списка сущностей задачи будут видны только при установленном крайнем сроке выполнения.

Подробнее о добавлении задач вы можете прочитать в уроке Создание задачи.

Написать письмо

Вы можете из CRM писать и отправлять письма на e-mail, заданные в параметрах контактов, компаний и лидов. Отправляемое письмо привяжется к событиям соответствующей сущности.

Есть несколько способов перехода к форме отправки письма, они полностью аналогичны таковым для добавления события, с той лишь разницей, что следует выбирать пункт Написать письмо. Также возможна отправка писем на адреса сразу нескольких сущностей с помощью панели групповых операций:

Внимание! В сущности должен быть задан e-mail, в противном случае при попытке отправки письма будет выведено сообщение: Email адреса не найдены.

Все отправленные письма заносятся в события сущности.

Внимание! Следует иметь в виду, что при массовой рассылке писем на портале должна поддерживаться активность какое-то время после отправки, т.к. почтовые агенты работают на хитах.

Появится форма отправки письма:

  • В поле От кого будет прописан ваш e-mail. Кликнув по данному полю, помимо пользовательского e-mail, вы можете выбрать в качестве адреса отправителя e-mail шаблона CRM и Send&Save:

  • В поле Кому будет указан электронный адрес, проставленный в сущности. В случае его отсутствия, его нужно будет ввести вручную.
  • Укажите тему и введите текст письма.
  • При наличии почтовых шаблонов выберите таковой для данного письма.
  • Вы можете выбрать сделку, нажав ссылку Выбрать:

    Отправленное письмо привяжется к событиям выбранной сделки, а в полученном адресатом письме будет прописан ее служебный заголовок.

  • Также вы можете прикрепить файл к письму. Эта процедура идентична таковой для сообщений.

Чтобы послать письмо нажмите Отправить. Копия письма будет послана на адрес, указанный в поле От кого, в качестве подтверждения отправки.

Ответ на данное письмо будет направлен как на личный ящик сотрудника, так и на адрес интеграции с CRM.

История переписки

Если при просмотре дела типа E-mail, то есть отмеченного значком [image] на закладке Дела в профиле сущности выбрать кнопку [image] и написать ответ, то переписка сохранится в виде цепочки писем, с цитированием ответов и пометкой Re: в теме письма.

Кроме того, в окне переписки в секции С кем можно будет увидеть, кому еще рассылались такие письма.

Также цепочка писем фиксируется в графе Описание в таблице просмотра истории.


Добавление событий в календарь
268 / 401

Из CRM возможно добавление в календарь событий, связанных с сущностями.

Событие CRM в календарь может быть добавлено несколькими способами:

  • Нажмите Добавить звонок/встречу в меню действий какой-либо сущности CRM;
  • В режиме просмотра сущности:

  • через колонку дел списка сущностей;
  • через календарь.

Во всех перечисленных методах (кроме последнего) откроется форма добавления события. Рассмотрим добавление встречи (форма добавления звонка идентична):

Заполните поля:

  • Когда - указывается дата и время встречи. Кликните по полю с датой или пиктограмме календаря, откроется окно календаря:

    С помощью стрелочек выставьте нужный месяц и год, затем кликните по нужному числу месяца.

    Вручную укажите время встречи, либо кликните по пиктограмме часов и переводите стрелки на картинке с помощью левой кнопки мыши:

    Примечание: большая стрелка часов не может находиться в промежуточном состоянии между двумя числами, с этим связано возможное несоответствие времени, указываемого в поле, и отображаемого часами на картинке. Ориентируйтесь на время, показываемое в поле ниже картинки!

  • напомнить за - поставьте флажок и настройте, за какое время следует напомнить о событии уведомлением.
  • Где - напишите место проведения встречи.
  • С кем - в данном поле будет указан контакт (либо компания), с которым предполагается встреча. Для сделок и лидов берется контакт, указанный в их карточке.
  • Тема - укажите тему встречи и введите ниже ее описание.
  • Ответственный - кликните по значению данного поля и выберите ответственного, в делах которого отобразится добавляемая встреча. По умолчанию здесь будет указан сотрудник, добавляющий событие.
  • Сделка - нажмите Выбрать, и, аналогично выбору ответственного, укажите сделку, к делам которой будет привязана добавляемая вами встреча. Сделку можно выбрать при добавлении события к контактам или компаниям.
  • Статус - кликните по нему, чтобы изменить. Возможны два значения: Ожидается, Завершено.
  • Важность - выберите приоритет события:

  • Прикрепить файл - кликните по данной ссылке, если хотите приложить к событию какой-либо файл. Данная операция описана в разделе Сообщения.

Нажмите кнопку Сохранить, и запись появится в календаре ответственного за данную сущность:

Помимо закладки и колонки Дела, добавленное событие будет отображено на закладке История карточки сущности (только для платных редакций).

Внимание! В случае отсутствия в описании компании номера телефона, добавляемый к компании звонок будет отображаться в делах первого контакта данной компании.

Завершенные события будут оставаться в календаре, если установлены соответствующие галочки в настройках на странице Прочее.

Примечание: добавлять\редактировать\удалять календарные события CRM можно непосредственно из календаря, указывая привязку к сущностям на закладке Дополнительно:


Товары
269 / 401

На странице Товары перечислены товары, имеющиеся в системе CRM для участия в сделках:

Примечание: В редакции "Проект" в списке сущностей максимум может отображаться 5000 элементов. Остальные будут храниться, но не будут видны, если не применять фильтры.

Через меню действий товара вы можете открыть окно его детального просмотра, редактировать параметры, либо удалить:

Примечание: также вы можете использовать товары из интегрированного с CRM интернет-магазина.


Добавление товара
270 / 401

Для добавления товара нажмите кнопку Добавить товар на контекстной панели, откроется форма:

Примечание: при выставленном в системе типе налогов НДС, в данной форме будет поле выбора ставки НДС и опция включения ее в цену товара.

Заполните поля:

  • Название - введите наименование товара.
  • Описание - здесь вы можете подробнее рассказать о товаре.
  • Активен - снимите галочку, если не хотите чтобы сотрудники могли использовать товар в CRM.
  • Валюта - выберите валюту, в которой вы указываете цену на этот товар:

    Менеджер может продавать товар в валюте, отличной от указанной в его свойствах. В таком случае цена автоматически будет пересчитана.

    Примечание: добавить валюту вы можете на странице CRM > Настройки > Валюты.

  • Цена - укажите стоимость товара.
  • Единица измерения - выберите из списка, организованного на странице CRM > Настройки > Единицы измерения. Если единица измерения не будет выбрана, то автоматически будет использоваться отмеченная в этом списке "по умолчанию".
  • Раздел - выберите, в какой созданный вами раздел поместить товар:

  • Сортировка - укажите индекс сортировки, влияющий на порядковое место товара в общем списке.

Нажмите Сохранить, товар добавится и отобразится в выбранном разделе.

Нажмите Сохранить и добавить еще, чтобы добавить товар и перейти к форме добавления еще одного товара.

Для облачного сервиса Битрикс24

Для добавления новых товаров в каталог пользователю нужно обладать правом доступа CRM с разрешением на изменение настроек .

Для коробочного Битрикс24

Для добавления новых товаров в каталог пользователю нужно обладать правом CRM администратор.


Добавление раздела
271 / 401

Разделы, по которым распределены товары CRM, отображаются как папки в списке товаров.

Для добавления новой папки, нажмите Добавить раздел на контекстной панели, появится окно:

Введите название и нажмите Добавить.

Через меню действий папки вы можете удалить, либо переименовать ее:


Импорт товаров
272 / 401

Для добавления одновременно большого количества товаров доступна функция импорта. Импорт осуществляется в формате .csv. Чтобы перейти к импорту нажмите кнопку настроек на контекстной панели.

Примечание: пример подготовки файла импорта .csv подробно описан в курсе Администратор сервиса Битрикс24 (коробочная версия).

В открывшейся форме будет предложено настроить параметры импорта:

Внимание! Настоятельно рекомендуется скачать шаблон импортируемого файла и заполнить его необходимыми товарами в соответствии с заданным форматом столбцов. Если информация для какого-либо столбца отсутствует, его следует оставить пустым.

Рассмотрим некоторые поля.

  • Файл данных (формат CSV) - единственное обязательное для заполнения поле. Нажав на кнопку Обзор, укажите на своем компьютере местонахождение импортируемого списка товаров в формате .csv.
  • Кодировка файла данных - выберите кодировку импортируемого файла:

  • Шаблон импортируемого файла - нажмите на ссылку Скачать, если хотите сохранить на компьютере имеющийся в дистрибутиве файл .csv с шаблоном полей для импортируемых товаров.

    • После щелчка по ссылке откроется окно сохранения файла. Нажмите Открыть если хотите просмотреть содержимое файла, и Сохранить - если хотите сохранить файл на компьютере:

    Фрагмент шаблона импортируемого файла приведен на рисунке:

    Файл можно заполнить собственными товарами в соответствии с шаблоном с помощью MS Excel или Блокнота, сохранить с уникальным именем и расширением .csv, а затем указать в качестве Файла данных.

    Примечание: Если у товара имеется множественное свойство, то для импорта всех значений необходимо повторить строку с товаром соответствующее количество раз. При этом, начиная со второй строки, можно указывать только идентификатор товара и само значение множественного свойства, а остальные поля оставлять пустыми.

    Важно! Для корректного импорта цены товара наименование валюты в файле данных должно совпадать с идентификатором ID валют, заданных в CRM > Настройки > Валюты.

  • Разделитель колонок - выберите символ разделения столбцов данных в файле:

    • Примечание: при сохранении файла .csv с помощью Excel возможны проблемы с применяемым разделителем, поэтому если появится сообщение "В файле данных используется разделитель отличный от выбранного", смените разделитель колонок на Точка с запятой.

  • Первая строка содержит заголовки - установите галочку, если в первой строке импортируемого файла содержатся заголовки полей, а информация товаров записана, начиная со второй строки.
  • Пропускать пустые колонки - оставьте галочку для того, чтобы пропускались колонки с пустыми заголовками. В противном случае такие колонки будут импортироваться.

Нажмите Далее и выберите те поля, значения которых должны быть указаны в импортируемом товаре:

Важно! Поле Название должно быть выбрано обязательно.

Нажмите Далее, и вам будет выведено сообщение о том, какое количество товаров удалось успешно импортировать в CRM.

Соответственно, эти данные появятся в списке на странице Товары:

Примечание: импорт товаров из файла .csv предназначен не для регулярной синхронизации с внешними сервисами, а для первоначальной загрузки имеющегося большого каталога товаров. В связи с этим не рекомендуется производить повторный импорт, т.к. это может привести к дублированию товарных позиций.


Настройки
273 / 401

В данном разделе можно менять настройки, относящиеся к сущностям модуля CRM:

Примечание: по умолчанию доступ к настройкам CRM имеют сотрудники с правом crm Администратор.


С чего начать
274 / 401

Первоначальные настройки CRM под ваш конкретный бизнес доступны на странице CRM > Настройки > С чего начать.


Справочники
275 / 401
Справочник - список значений параметров, относящихся к той или иной сущности.

Справочники, которые можно настроить, располагаются в списке слева:

1 - область вкладок. Перечислены параметры, к настройке которых можно перейти, щелкнув по ним левой кнопкой мыши.

2 - значения параметров. Перечислены все допустимые значения, которые может принимать выбранный параметр. Вы можете их изменять.

- символ ключевого поля. Ключевое поле нельзя удалить или переместить, но можно изменить его название.

- кнопка изменения цвета. Цвета выбираются из активируемой при нажатии на кнопку таблицы цветов. Цвета можно менять только для статусов лида, предложения, счета и стадий сделки.

- кнопка изменения названия.

- кнопка возврата к оригинальному названию, отображается только для ключевых полей. Если вы изменили название ключевого поля, то нажав на данную кнопку, вы вернете оригинальное наименование.

- кнопка изменения положения. Захватив за эту кнопку, можно переместить поле выше или ниже по списку. При этом нумерация полей изменяется автоматически.

- кнопка удаления поля. Крестик не отображается для тех полей, удаление которых невозможно, то есть для ключевых.

Примечание: при наведении курсора мыши на кнопки удаления, изменения названия или возврата к оригинальному названию, всплывает подсказка с их значением:

Для добавления какого-либо параметра (статуса/поля/стадии) в справочник служит кнопка [image]. При нажатии на неё новому параметру присваиваются имя и цвет по умолчанию. Их сразу можно поменять на желаемые, а также задать местоположение в списке.

После настройки справочников Статусы, Стадии сделки, Статусы предложения, Статусы счета можно сразу увидеть результат настройки, то есть внешний вид успешного и неуспешного финала, шкалы, воронки:

и в случае удовлетворительного результата настройки нажать кнопку Сохранить.

После сохранения настроек все стадии для ранее внесенных записей о лидах, сделках, предложениях, счетах будут изменены соответствующим образом.


Валюты
276 / 401

На данной странице вы увидите список доступных валют:

С помощью пунктов меню действий, вы можете сделать валюту базовой, редактировать её или просмотреть. Можно также удалить любую валюту, кроме базовой:

Базовая валюта – валюта, которая будет использоваться в качестве базы для расчетов других валют. Например, если в качестве базовой будет выбран рубль, то весь курс будет отображен относительно рубля. В качестве базовой рекомендуется выбирать рубль. В этом случае отображение курса обмена валют будет в привычном для всех виде: за 1 денежную единицу – столько-то рублей.

Базовой может быть только одна валюта, поэтому если какую-либо валюту Сделать базовой, то другая валюта перестает быть таковой.

Валюта, заданная в качестве Базовой, будет применяться для расчетов при добавлении новых сделок. При изменении базовой валюты уже существующие сделки не пересчитываются.

Соответственно, при добавлении счетов будет использоваться валюта, заданная в качестве Базовой для счетов, а отчеты будут считаться в валюте, заданной как Валюта отчётов.

Обратите внимание! Изменение курса валют не приводит к пересчету уже существующих сделок/счетов. Новый курс будет использоваться только при добавлении новых сделок/счетов.

Чтобы добавить валюту, нажмите Добавить валюту на контекстной панели.

Откроется форма добавления/редактирования валюты:

Заполните поля:

  • Валюта – международно признанное трехбуквенное обозначение валюты;
  • Номинал – сумма, которая принимается за единицу при расчете валюты. Как правило, равняется 1;
  • Курс обмена (по умолч.) – курс, который будет использоваться при конвертации валют;
  • Индекс сортировки – приоритет данной валюты в общем списке валют;
  • Валюта отчётов и Базовая для счетов – данными опциями должна быть отмечена валюта, которая будет использоваться при составлении отчетов по проведенным сделкам, и валюта, в которой будет производиться выставление счета. Если снять отметки опций Валюта отчетов и Базовая для счетов со всех валют, то по умолчанию валютой отчетов и счетов автоматически назначается Базовая валюта.

Внимание! Во избежание некорректных моментов (например, невозможности удаления), следите, чтобы курс добавляемой небазовой валюты отличался от 1.

Заполните поля для языковых вариантов:

  • Название – полное название валюты для данного языка;
  • Строка формата для вывода валюты – заполняется в виде «# текст». Определяет текстовое обозначение валюты;
  • Десятичная точка при выводе, Разделитель тысяч при выводе и Свой разделитель тысяч при выводе – способы разделения частей отображения валюты.

Установка курса валют возможна до десятитысячных долей, то есть до 4 знака после запятой. В Счетах, Отчетах и Предложениях суммы округляются до сотых долей, т.е. до 2 знаков после запятой.


Местоположения
277 / 401

При оформлении счёта, добавлении сделки или выставлении коммерческого предложения на товары CRM для корректного применения налогообложения следует задавать местоположение контакта. Список местоположений расположен на странице CRM > Настройки > С чего начать > Местоположения:

Местоположения могут быть добавлены в список вручную или импортированы, отредактированы, назначены родительскими или дочерними и т.д.

В форме Добавления местоположения

обязательными являются поля Символьный код и Тип. Также следует задать родительское местоположение (если вы добавляете местоположение, иерархически ниже Страны) и название местоположения на русском и/или других языках. Возможна также географическая привязка по геоданным - долготе и широте.

На вкладке Внешние данные

можно задать почтовые индексы (ZIP-коды) и коды Яндекс.Маркет.

В форме Импорта местоположений

можно очистить все местоположения на соответствующей вкладке. А также отследить статистику существующего списка и выбрать параметры импорта, например:

  • Источник, из которого будут загружены местоположения - удаленный сервер или файл;
  • В случае выбора файла, указать его расположение и имя, вручную создать типы местоположений и внешние сервисы;
  • В случае выбора удаленного сервера, указать, какие страны и регионы будут загружены;
  • Выбрать, какие дополнительные данные (индексы и др.) будут загружены;
  • Ограничить глубину загрузки (максимальная - до улиц) местоположений.

Внимание! Загрузка местоположений до «улиц» - достаточно длительный процесс, который может занять от тридцати минут, до нескольких часов, в зависимости от настроек вашего сайта и мощности вашего хостинга.

Через меню действий в списке местоположений

доступно удаление местоположения, редактирование (форма редактирования аналогична форме добавления) и переход к дочерним местоположениям.

Примечание: Количество дочерних уровней не ограничено.


Налоги
278 / 401

При оформлении счёта, добавлении сделки или выставлении коммерческого предложения на товары CRM возможно применение налогообложения. Налоги задаются на странице CRM > Настройки > С чего начать > Налоги:

Есть два типа налогов:

  • на весь счёт целиком;
  • на каждый товар отдельно (НДС).

Примечание: Налог на товар может быть применен либо ко всему документу, т.е. для каждого товара, участвующего в документе, либо отключен для всех товаров. Одновременно, в одном документе, не могут быть товары с налогом и без него.

Чтобы выбрать нужный вам вариант налогообложения - нажмите Настроить на контекстной панели. Появится окно настройки:

В первом случае ставки налога можно настроить в зависимости от местоположения плательщика. При указании местоположения в форме выставления счёта или коммерческого предложения, будет автоматически рассчитан соответствующий налог.

Примечание: при первой загрузке страницы со списком налогов данного типа вам будет предложено создать или загрузить местоположения. Следуйте инструкциям.

Во втором случае созданные ставки НДС выбираются для каждого товара отдельно в форме создания\редактирования товара:

Если необходимо, вы можете отключить данную опцию, убедившись, что это не противоречит законодательству вашей страны.

Рассмотрим создание налога первого типа (на документ).

Нажмите Добавить налог на контекстной панели со списком налогов данного типа и заполните необходимые поля:

Мнемонический код - набор латинских символов, однозначно идентифицирующий данный налог. Используется разработчиками.

Нажмите Применить, после чего появится закладка Ставки:

Кликните Добавить ставку и заполните необходимые поля:

  • выберите тип клиента, к которому может быть применена данная ставка налога:

  • Входит в цену - снимите галочку, если цену товара вы указываете без учёта налогов;
  • в графе Местоположения выберите географическое положение плательщика, для которого будет применён данный налог. Для выбора нескольких значений используйте клавишу Ctrl.

Сохраните созданную ставку и при необходимости добавьте еще.

Теперь при выставлении счёта или коммерческого предложения и указании в нем местоположения плательщика Россия-Архангельская область будет применяться налог Северный.

Соответственно, без указания или при указании другого местоположения плательщика налог на документ применяться не будет.

Резюме:

Для корректного расчета налога при выставлении счета, коммерческого предложения, оформления сделки обратите внимание на следующие моменты:

  • На странице редактирования ставок налога должен быть отмечен галочкой пункт Активность;
  • Если цена товара задана уже с налогом, то пункт Входит в цену на странице редактирования ставок налога, также должен быть отмечен галочкой;
  • На странице редактирования ставок налога должно быть задано Местоположение региона, для которого применяется данный налог;
  • В форме добавления сделки/предложения/счета также должно быть выбрано Местоположение;
  • Следует корректно выбирать валюты, в которых назначается цена товаров и ведется расчет стоимости сделки/предложения/счета. Во избежание расхождения итоговых сумм должны быть заданы курсы всех применяемых валют относительно базовой.


Единицы измерения
279 / 401

На данной странице можно управлять единицами измерения, используемыми при работе с товарами. Представлены следующие стандартные единицы:

Чтобы добавить новую единицу измерения, нажмите Добавить на контекстной панели. Откроется форма создания:

Заполните необходимые поля.

Код представляет собой числовое значение, идентифицирующее создаваемую единицу измерения.

Отметьте опцию По умолчанию, если хотите, чтобы данная единица автоматически выставлялась при добавлении товарной позиции в сделку, коммерческое предложение или счет. При этом при добавлении товара в каталог можно будет не указывать единицу измерения товара.


Свойства товаров
280 / 401

Товары, участвующие в сделках CRM, могут обладать совершенно различными характеристиками и свойствами, в зависимости от специфики работы компании.

Для наиболее полного хранения информации о товарах имеется возможность задавать их свойства на странице CRM > Настройки > С чего начать > Свойства товаров.

Чтобы добавить свойство товара, следует нажать Добавить, после чего откроется форма добавления свойства.

Часть настроек одинакова для любых типов свойств. Это такие поля, как:

  • Идентификатор - по умолчанию задан параметр Новое.
  • Тип - укажите, значение какого типа можно будет вводить в поле. Для этого нажмите на пиктограмму стрелочки и в выпадающем списке выберите нужный тип (по умолчанию выставлено Строка).

    • Примечание: при выборе того или иного типа могут появляться или удаляться дополнительные поля настройки свойства.
  • Свойство активно - галочка в этом пункте указывает, отображать ли свойство в форме добавления товара.
  • Порядок сортировки - данный параметр определяет приоритет позиции свойства.
  • Название - укажите наименование нового свойства товаров.
  • Множественное - при отмеченной опции можно будет указывать несколько значений данного свойства.
  • Обязательное - при отмеченной опции данное свойство будет обязательным к заполнению при добавлении товара.

Другие настройки зависят от выбранного типа свойств товара. Типы могут быть выбраны из выпадающего списка:

Рассмотрим отличающиеся настройки для разных типов свойств подробнее.

  • Тип Строка предназначен для ввода строковых свойств, например, небольших описаний.
    • Размер поля для ввода значения (Строк х Столбцов) - задаются размеры поля для ввода, по вертикали и горизонтали.
    • Значение по умолчанию - в этом параметре указывается, какое значение будет стоять в новом свойстве по умолчанию.

  • Тип Число для задания числовых свойств, например, веса товара.
    • Значение по умолчанию - указывается, какое значение будет стоять в новом свойстве по умолчанию.

  • Тип Список - значение свойства нужно будет выбрать из имеющегося списка значений.
    • Количество строк (для внешнего вида "список") - указывается, сколько строк списка может быть видно без дополнительных действий.
    • Значения списка задаются в таблице, где можно указать сами значения, их коды, порядок сортировки и значение по умолчанию.

  • Тип Файл указывается, если необходимо прикреплять к товару какие-либо файлы, например, отсканированный сертификат соответствия товара.
    • Типы загружаемых файлов (расширения через запятую) - можно выбрать тип загружаемого файла из выпадающего списка (любые, Изображения, Звуки, Видео, Документы), тогда соответствующие типу расширения будут указаны автоматически. Или же задать расширения вручную.

  • Тип Привязка к элементам - выбирается, если необходимо привязывать к товару элементы какого-либо инфоблока.
    • Информационный блок - следует выбрать тип инфоблока и собственно сам инфоблок.

  • Тип HTML/текст применяется для расширенных описаний с элементами форматирования.
    • Значение по умолчанию - при необходимости можно задать значение свойства по умолчанию, используя визуальный редактор.
    • Дополнительные настройки - задается Высота окна редактора в пикселях.

  • Тип Дата/Время - нужен для указания в товаре какой-либо даты и времени, например, срока действия акции.
    • Значение по умолчанию - можно задать вручную или выбрать из календаря, нажав на соответствующую пиктограмму [image].

  • Тип Привязка к сотруднику позволит привязать товар к сотруднику, как-либо связанному с данным товаром.
    • Значение по умолчанию - можно вручную задать идентификационный номер сотрудника, или выбрать из списка, нажав на соответствующую ссылку.

  • Тип Привязка к элементам в виде списка - при выборе данного типа появляется возможность связать товар с элементами инфоблока, представленными в виде списка.
    • Информационный блок - следует выбрать тип инфоблока и собственно сам инфоблок.
    • Дополнительные настройки - задаются:
      • Высота списка - количество строк списка, видимых без дополнительных действий.
      • Ограничить по ширине (0 - не ограничивать) - ширина списка в пикселях.
      • Группировать по разделам - элементы инфоблока будут группироваться по разделам.
      • Отображать в виде списка множественного выбора - можно будет выбирать несколько значений из списка.

  • Тип Счетчик - свойство отображается в виде числа, автоматически увеличивающегося при добавлении товара.
    • Дополнительные настройки - следует поставить птичку, если Разрешается изменять значения, а также установить Текущее значение счетчика.

Заданные свойства товаров отображаются в форме добавления товара так же, как и предустановленные поля свойств товаров, для них так же доступна настройка и редактирование.


Направления сделок
281 / 401

Подробно работа со страницей CRM > Настройки > С чего начать > Направления сделок описана в уроке Направления сделок.


Шаблоны реквизитов
282 / 401

Для наиболее полного задания почтовых, платежных и банковских реквизитов контактов и компаний имеется возможность хранить их как самостоятельные сущности и подключать по необходимости, а не заполнять при создании каждого нового счёта. Можно создать несколько шаблонов реквизитов на странице CRM > Настройки > С чего начать > Шаблоны реквизитов, подключить необходимые на специальной вкладке в Контакте или Компании и выбирать из списка в документах CRM.

Список шаблонов реквизитов по умолчанию имеет вид:

Шаблон можно отредактировать:

то есть изменить его название, активность и порядок сортировки.

А также изменить список его полей:

В свою очередь, с помощью меню действий

поля в шаблоне также можно редактировать - добавлять, удалять, изменять название, порядок следования и др.

В форме редактирования поля с помощью птички Показывать в кратком списке

определяется, будет ли поле присутствовать в разделах О контакте в Сделках, О клиенте в Предложениях, Плательщик в Счетах.

Например, если в реквизитах клиента имеется несколько адресов, а также в шаблоне реквизитов для физического лица параметр Показывать в кратком списке для поля Адрес принимает значение да, то во вкладке Реквизиты в формах создания/редактирования Сделки, коммерческого Предложения, Счета будут отображены все адреса клиента и вкладка примет вид:

При добавлении поля (или шаблона) есть возможность как создать новое:

так и выбрать существующее:

После настройки шаблонов реквизитов они станут доступны для выбора на закладке "Реквизиты" в профиле контакта и компании.

Примечание: после обновления CRM до версии 16.1.0 для начала использования шаблонов реквизитов потребуется выполнить автоматический перенос ранее введенных данных в новые реквизиты для контактов и компаний отдельно. О необходимости такого переноса сообщит информационная надпись, она же содержит ссылку на запуск автоматического переноса.


Реквизиты ваших компаний
283 / 401

Для выставления cчетов и коммерческих предложений требуются реквизиты компании, принимающей оплату. Для того, чтобы не вводить эти данные вручную в каждый выставляемый счет/предложение, следует настроить Реквизиты ваших компаний. Это делается на странице CRM > Настройки > С чего начать > Реквизиты ваших компаний. Эта страница полностью аналогична списку компаний, отфильтрованных по признаку Компания продавец:

После настройки реквизитов ваших компаний они будут автоматически добавляться в секцию Компания продавец при создании счета:

и в секцию О компании-поставщике при создании коммерческого предложения:

Примечание: Если у вас имеется несколько компаний, то по умолчанию в форму счета/предложения добавляются реквизиты той из них, которая имеет наименьший идентификатор (ID).

Также вы можете выбрать или создать другую компанию-продавца, перейдя по соответствующей ссылке.

Обратите внимание! Реквизиты вашей компании, отображаемые в виртуальном счёте/предложении и те, что будут отображаться в печатной форме или счёте онлайн, могут не совпадать.

Настройка отображаемых реквизитов компании-продавца

  • Для электронной формы счета/предложения.

    • В электронной форме будут демонстрироваться те реквизиты, которые отмечены "птичкой" в графе "Показывать в кратком списке" в списке полей шаблона Продавец со страницы CRM > Настройки > С чего начать > Шаблоны реквизитов. Название реквизита берется из графы "Название в шаблоне":

  • Для печатной формы счета/предложения.

    • При создании/редактировании компании-продавца на вкладке Реквизиты задаются все необходимые данные.

    При выставлении счета/предложения в секции Способы оплаты

    выбирается, каким образом компания будет принимать оплату от данного плательщика.

    Отображение реквизитов в печатной форме или счете-онлайн регулируется настройками на странице CRM > Настройки > Способы оплаты и зависит от выбранной платежной системы:

Кроме того, для продавцов, работающих с покупателями в разных странах, будет актуальной настройка обработчика платежей в способах оплаты. Следует выбрать обработчик, соответствующий стране покупателя, так как от этого зависит формат печатной формы счета/предложения и наличие в форме набора реквизитов:

Обратите внимание! В настройках способов оплаты поля реквизитов сгруппированы по странам. Таким образом, если выбран реквизит для страны А, а реквизиты в конкретном счёте конкретного покупателя созданы по шаблону страны Б, то в печатную форму они не попадут.


Настройки форм и отчетов
284 / 401

Страница CRM > Настройки > Настройки форм и отчетов предназначена для создания собственных полей для документов CRM и указания, какие из этих полей должны участвовать в аналитических отчетах.


Пользовательские поля
285 / 401
Пользовательские поля - параметры сущностей, создаваемые сотрудниками. Так как создатели Битрикс24 не могут предусмотреть все необходимые поля (кому-то нужны одни параметры, кому-то другие), то предусмотрена возможность создания собственных полей.

Операции с пользовательскими полями полностью аналогичны действиям с предустановленными полями сущностей. То есть вы можете добавлять или удалять пользовательские поля в формы сущностей, осуществлять по ним фильтрацию и поиск и т.п.

На странице CRM > Настройки > Настройки форм и отчетов> Пользовательские поля вы можете редактировать поля, созданные в профилях сущностей, либо добавлять новые параметры, которые будут отображены в форме создания/редактирования сущности.

После перехода на страницу Пользовательские поля вам будут показаны имеющиеся сущности, для которых можно ввести настраиваемые поля:

Добавить поле

Чтобы добавить поле для какого-либо типа сущностей CRM, нажмите Добавить поле, после чего откроется форма создания нового поля:

Также добавить поле можно, нажав на кнопку Добавить поле на контекстной панели страницы Список полей.

Присутствуют следующие настройки нового поля:

  • Сортировка - данный параметр определяет приоритет позиции поля и настраивается администратором.
  • Задать названия для всех языков - поставьте галочку, чтобы ввести название нового поля на других языках.

    Внимание! При активации этой опции поля названий на всех языках, заданных в системе, станут обязательными для заполнения.
  • Название - укажите наименование нового параметра сущности на требуемых языках.
  • Обязательное - при отмеченной опции данное поле будет обязательным к заполнению для добавления новой сущности.
  • Множественное - при отмеченной опции можно будет указывать несколько значений данного нового параметра. В этом случае в форме редактирования сущности рядом с множественным полем появится кнопка

    Внимание! В случае выбора для поля параметра Множественное после сохранения поля изменить это свойство будет нельзя.
  • Показывать в фильтре - оставьте здесь галочку, чтобы можно было осуществлять поиск по значению данного поля.
  • Показывать в списке - после включения поле автоматически добавляется в настройки списка для текущего пользователя и в список по умолчанию для всех пользователей.
  • Тип - укажите значение какого типа можно будет вводить в поле. Для этого нажмите на пиктограмму стрелочки и в выпадающем списке выберите нужный тип (по умолчанию выставлено Строка):

    Примечание: при выборе того или иного типа могут появляться или удаляться дополнительные поля или вкладки.

    Внимание! Изменить выбранный тип после сохранения поля будет невозможно.

    Остановимся на некоторых типах подробнее.

    • Строка - дополнительным параметром настройки этого поля является Количество строк в поле ввода. При задании числа, отличного от 1, в форме создания/редактирования сущности высота этого символьного поля в строках будет равна заданному числу. Если символов в поле будет больше, чем вмещается в заданное количество строк, то поле оснащается элементами управления - полосой прокрутки, маркером масштабирования.

    • Список - значение нового параметра нужно будет выбрать из имеющегося списка значений.

      После указания списка как типа, появятся поля настройки внешнего вида списка. Первое - Внешний вид. Нажмите на стрелочку и в выпадающем списке выберите нужный вид списка (по умолчанию выставлено Список): .

      Если выбрать Флажки, то по своему виду список будет такой:

      Параметр Высота списка, задается целым числом больше единицы. Означает сколько пунктов списка может быть видно без дополнительных действий. Например, если выставить значение высоты списка 4, то при отображении список будет выглядеть следующим образом:

      В параметре Подпись при отсутствии значения можно переименовать пункт "не выбрано", задать для него другую подпись, которая будет отображаться, если никакое значение из списка не выбиралось.

      Перейдите на вкладку Список чтобы указать значения, которые будут перечислены в списке:

      Введите значение пункта списка в текстовое поле:

      Чтобы ввести еще одно значение списка, нажмите кнопку Добавить, после чего появится еще одно поле для ввода.

      Зеленые стрелочки слева от текстового поля позволяют управлять положением значения в списке.

      Ссылка Импортировать списком открывает большое текстовое поле, куда можно вводить значения списка, причем каждая строка является отдельным значением списка. Этим удобно пользоваться для указания большого количества пунктов списка.

      После того, как вы указали несколько значений списка и нажали Применить\Сохранить, вы можете выбрать из них то, которое будет в параметре сущности по умолчанию. Для этого на вкладке Список кликните по ссылке Значение по умолчанию, после чего появится дополнительное поле со стрелкой, после щелчка по которой в выпадающем списке введенных значений списка выберите то, которое будет стоять по умолчанию:

    • Дата\время - данный тип нужен для указания в сущности какой-либо даты и времени, и будет представлять собой поле для их ввода. К примеру можно указывать в сущности время ее создания. (Для указания только даты используйте тип Дата, настройки которого производятся аналогично.)

      При выборе данного типа для нового параметра, появятся два дополнительных поля: Значение по умолчанию и Значение.

      Кликните на пиктограмму стрелки, направленной вниз, рядом с полем Значение по умолчанию, после чего откроется список значений:

      • Нет - по умолчанию никакого значения стоять не будет.
      • Текущее время - в данном параметре нового поля будет прописана текущая на момент создания поля дата и время.
      • Заданное значение - при выборе данного варианта укажите в поле Значение фиксированную дату и время, которые будут выставлены в новом поле по умолчанию. Сделать это можно, нажав на пиктограмму календаря.
    • Файл - укажите данный тип, если хотите разрешить прикреплять к сущностям какие-либо файлы, к примеру такие как договор заключения сделки. Новое поле в форме добавления сущности будет выглядеть следующим образом:

      Нажав на кнопку Обзор можно выбрать необходимый файл из файловой структуры операционной системы.

      Прикрепленные файлы изображений в форме просмотра сущности будут отображаться в виде картинок соответствующего масштаба. Файлы других форматов, а также все файлы при просмотре списка сущности будут отображаться в виде ссылки, при клике на которую запустится соответствующая формату файла программа.

      Внимание! Следует учитывать, что хотя формат и размер прикрепляемых к сущностям файлов не ограничивается, суммарный объем таких файлов может превысить выделенное по условиям тарифа место в облаке (в зависимости от редакции вашего КП).
    • Привязка к пользователю - при выборе этого типа новое поле в форме создания сущности будет выглядеть следующим образом:

      Оно позволит привязать сущности какого-либо пользователя, как-либо связанного с данной сущностью.

    • Привязка к разделам информационных блоков - выберите данный тип поля, если хотите привязывать к сущности секции какого-либо инфоблока. В форме ее создания появится опция для выбора разделов инфоблоков.

      Это может понадобиться к примеру для того, чтобы прикрепить к сущности сделки с компьютерной фирмой секцию информационного блока со списком системных блоков.

      Укажите следующие настройки:

      В раскрывающихся списках выберите тип инфоблока и сам инфоблок. Чтобы заполнить поле Значение по умолчанию нажмите Применить, после чего будет возможность указать какой-либо раздел инфоблока в качестве значения по умолчанию.

      Значение параметров Внешний вид и Высота списка описаны выше для типа Список.

      Показывать только активные элементы - при отмеченной опции будут выводиться только разделы, указанные администратором как активные.

    • Привязка к элементам информационных блоков - выберите данный тип поля, если хотите привязывать сущность к элементам инфоблоков и в форме создания сущности была соответствующая опция. Настройки для данного типа аналогичны приведенным выше.
    • Привязка к элементам CRM - при выборе данного типа появляется возможность связать поле с какой-либо из сущностей CRM - лидом, контактом, компанией, сделкой. В форме можно будет выбрать конкретный элемент сущности из выпадающего окна.

  • Значение по умолчанию - в этом параметре указывается какое значение будет стоять в новом поле по умолчанию.

Для сохранения нового поля и перехода на страницу списка полей нажмите Сохранить. Для того чтобы сохранить поле и остаться на текущей странице нажмите Применить.

Примечание: изменение значений пользовательских полей не отображается в истории.

Задать корректный вывод нового поля можно в настройках форм.

Список полей

Чтобы просмотреть список пользовательских полей, на странице Пользовательские поля нажмите на ссылку Список полей под нужным типом сущностей. Откроется страница списка полей:

Меню действий позволяет изменить выбранное поле, либо удалить его:

Чтобы перейти обратно на страницу с перечнем типов сущностей CRM нажмите Список типов на контекстной панели.


Аналитические отчеты
286 / 401

Страница предназначена для выбора пользовательских полей, которые будут участвовать в аналитических отчетах CRM.

Количество добавляемых полей ограничено тарифным планом, о чем на странице имеется соответствующее сообщение.

При первом использовании пользовательских полей в аналитических отчетах сделок следует произвести обновление статистики, кликнув по соответствующей ссылке:

Внимание! При большом количестве сделок обновление статистики может занять значительное время.

На странице также имеется информация об общем количестве созданных и выбранных пользовательских полей. Их можно редактировать, выбирать из выпадающего списка, удалять. Также можно настроить использование пользовательского поля для итоговой суммы сделки, прибавить сумму товаров, участвующих в сделке.

В результате, выбранные пользовательские поля можно будет использовать как параметр для подсчета при настройке виджетов сделок.


Способы оплаты
287 / 401

Страница CRM > Настройки > Способы оплаты предназначена для настройки платежных систем, используемых для оплаты счетов, а также реквизитов вашей компании, логотипа, печати, подписи и т.д.

Способы оплаты используются при выставлении счёта и создании коммерческого предложения.

Первоначально в системе есть следующие методы оплаты:

Вы можете создать новый способ оплаты, нажав на ссылку Создать платежную систему, или настроить предустановленный способ под свои требования, нажав на символ меню справа от секции платежной системы и выбрав Редактировать

Формы создания и редактирования способа оплаты практически одинаковы.

Прежде всего нужно выбрать обработчик, в качестве которого может быть назначен как локализованный (зависящий от страны покупателя) внутренний документ CRM (Счет, Коммерческое предложение), так и электронный сервис приема платежей онлайн (PayPal, Яндекс.Касса). В зависимости от выбранного обработчика будет показан определенный набор полей свойств.

При заполнении полей на вкладках Продавец и Покупатель введенная информация будет помещена в реквизиты покупателя и продавца соответственно, а также использована для форматирования печатной или электронной формы счета:

На вкладке Основная задаются заголовок, назначение, вывод шапки и комментария к счету и др.

На вкладке Стили задаются отступы и фон.

Примечание: в режиме показа всех полей, значения отступов, отличные от Другое значение, не имеют смысла.

На вкладке Колонки можно задать активность и порядок сортировки колонок в таблице счета, а также задать вывод пользовательских свойств товаров.

Меняя значения полей на на вкладках вы можете сразу видеть эти изменения в макете печатной формы справа:

При выборе электронной платежной системы необходимо будет внести идентификаторы, пароли и другие реквизиты, полученные при активации счета PayPal или от Яндекса при заключении договора. Подробно настройки Яндекс.Касса и PayPal описаны в курсе Администратор.Бизнес.

Важно! При настройке подключения в профиле/личном кабинете платежной системы в полях "Check URL" и "Aviso URL" необходимо указать "https://URL_портала/bitrix/tools/sale_ps_result.php". Вместо "URL_портала" укажите домен вашего Битрикс24.

Дополнительная информация

  • Подключение Яндекс.Кассы.


Права
288 / 401

Страница CRM > Настройки > Права предназначена для назначения прав на документы различным группам сотрудников.

На странице прав доступа возможно:

  • Добавление права доступа
  • Работа с ролями
  • Детализация прав на статусы

На данной странице указаны группы пользователей и их роли в CRM.

Роль - совокупность прав на действия с сущностями и настройками CRM.

Управление доступом к CRM осуществляется за счет назначения сотрудникам (таблица слева) ролей CRM (таблица справа):

Внимание! К назначению ролей следует относиться чрезвычайно внимательно, так как именно от назначенной роли зависит возможность сотрудника просматривать, редактировать и производить другие действия с Контактами, Компаниями, Лидами, Сделками, Предложениями, Счетами, CRM-формами.

Добавление прав доступа

Вы можете добавить новую группу, либо отдельных людей, к имеющим права доступа к CRM, нажав на ссылку Добавить право доступа, после чего откроется окно выбора сотрудников:

В первой колонке выберите из какой структуры вам удобней осуществлять выборку сотрудников: Пользователи, Сотрудники и отделы, Группы социальной сети.

Во второй колонке осуществляется непосредственно выборка сотрудников. При использовании вкладки Выбрать из структуры вы увидите древовидную структуру отделов вашей компании.

Кликнув левой кнопкой мыши на каком-либо названии, вы увидите нижележащие уровни структуры.

Для выбора всех сотрудников отдела в одну группу поставьте галочку напротив одного из пунктов:

В третьей колонке показаны выбранные сотрудники или отделы:

Чтобы исключить выбранный отдел или сотрудника из списка, нажмите крестик напротив него.

После того, как нужные категории пользователей указаны, нажмите Выбрать, и они появятся в списке прав доступа c назначенными ролями Менеджер по умолчанию :

Для сохранения произведенных изменений кликните Сохранить.

Примечание: если сотруднику назначается несколько ролей, то конечное право будет получено суммированием прав этих ролей. Т.е. если в одной роли права к лидам Свои, а в другой Свои + своего отдела, то в сводной роли будут Свои + своего отдела. За исключением детализированных прав доступа на статусы, имеющих высший приоритет.

Чтобы удалить из списка право доступа, кликните на крестик напротив него.

Важно! После удаления группа или пользователь будут лишены права доступа к CRM, только если это не Администраторы.

Работа с ролями

Чтобы определить роль для сотрудника или группы, нажмите на пиктограмму стрелочки:

Данные роли дублируют приведенные в таблице Список ролей:

Чтобы редактировать роль, кликните на пиктограмму карандаша. Чтобы удалить роль, нажмите на пиктограмму крестика напротив ее названия.

Если вы хотите создать собственную роль CRM, нажмите Добавить под списком ролей и назначьте права:

  • Введите название роли в поле Роль.
  • Для контактов, компаний, предложений и счетов определите права на Чтение, Добавление, Изменение, Удаление, Экспорт и Импорт, два раза кликнув по выставленному по умолчанию праву доступа (изначально выставлено Нет доступа):

    • Нет доступа - запрет на выполнение действия.
    • Свои - можно выполнять только с теми контактами, за которые сотрудник является ответственным.

      Примечание: данное право для Добавление означает, что в настройках добавляемой сущности ответственным будет автоматически выставлен создатель, даже если при создании указывался другой сотрудник. Однако ответственного можно изменить при последующем редактировании сущности.

    • Свои + своего отдела - то же, что и право доступа Свои, вдобавок еще контакты, ответственные за которые числятся в том же отделе, что и сотрудник.
    • Свои + своего отдела + подотделов - то же, что право доступа Свои + своего отдела, вдобавок еще контакты, ответственные за которые числятся в подотделах отдела сотрудника.
    • Все открытые - то же, что право доступа Свои + своего отдела + подотделов, а также все открытые контакты, то есть те, для которых установлена галочка в опции Доступен для всех.

      Примечание: данное право для Добавление означает, что сохраненная сущность автоматически будет приписана к открытым (опция Доступен\Доступна для всех). Однако это можно изменить при последующем редактировании.

    • Все - действие можно производить над всеми контактами/CRM-формами.
  • Разрешить изменять настройки - поставьте галочку, чтобы разрешить доступ к разделу CRM > Настройки.
    • Очень важно! Особенно внимательно нужно относиться к проставлению галочки Разрешить менять настройки. Так как при её наличии в какой-либо роли пользователь, обладающий данной ролью, будет иметь доступ в том числе и к изменению прав доступа и, соответственно, сможет самостоятельно открыть себе доступ к любой сущности.

После того, как все права для роли выставлены, нажмите Сохранить, либо Применить, и добавленная роль появится в списке ролей.

Детализация прав на статусы

Для сделок и лидов есть возможность настроить права доступа как ко всем сделкам и лидам в целом, так и по каждому статусу отдельно, то есть детализировать. Для этого нажмите на пиктограмму плюса, и в раскрывшемся списке вы увидите все статусы и выставленные для них права доступа на Чтение, Добавление, Изменение, Удаление, Экспорт, Импорт:

В выпадающем списке имеется пункт: Наследовать. Изначально для статусов он выставлен по умолчанию. Это означает дублирование для статуса основного права доступа. На картинке выше основные права доступа выставлены в строке Сделка. Учитывая это, вы, к примеру, можете поменять основное право доступа на Чтение, нажать Применить, и точно такое же право будет выставлено для всех статусов.

Если же права доступа на статусы настроены не по умолчанию, то есть детализированы, то такие настройки имеют высший приоритет. Таким образом, детализированные права на статусы не суммируются с правами по умолчанию, а лишь с детализированными же правами. Даже в случае, когда права по умолчанию устанавливают больший доступ, а детализированные права - меньший, будут применены детализированные права на статусы.

Внимание! Наследуемые права на статусы суммируются с наследуемыми, детализированные - с детализированными. Детализированные права на статусы имеют более высокий приоритет, чем наследуемые.


Автоматизация
289 / 401

Страница CRM > Настройки > Автоматизация предназначена для работы с бизнес-процессами.

Также с этой страницы при клике по пиктограммам Лиды или Сделки осуществляется настройка автоматической реакции на продвижение Лидов и Сделок по стадиям с помощью роботов и триггеров, описанная в отдельном уроке.

Кликнув по пиктограмме Бизнес-процессы, можно перейти к списку шаблонов бизнес-процессов для сделок, лидов, контактов и компаний:

Для сервиса Битрикс24

О бизнес-процессах и действиях с ними вы можете узнать из главы Бизнес-процессы для администратора.

Для коробочного Битрикс24

О бизнес-процессах и действиях с ними вы можете узнать из курса Администратор корпоративного портала.

Важно! С версии 15.5.0 модуля Дизайнер бизнес-процессов для CRM исключены действия Публикация документа, Снятие документа с публикации и Установка прав.

В CRM включено несколько шаблонов бизнес-процессов: Обработка лида, Обработка контакта, Выполнение по стадиям, Сделка интернет-магазина.

Чтобы добавить шаблон для какого-либо типа сущностей пройдите по ссылке Добавить шаблон, откроется страница настройки параметров шаблона, которая подробно описана в главе Настройка параметров шаблона.

Нажмите на Список шаблонов чтобы попасть на страницу с шаблонами для данной сущности:

В меню действий можно определить параметры автоматического запуска, изменить, либо удалить шаблон:

Для бизнес-процессов были разработаны специальные действия: Запись события в CRM, Ожидание стадии сделки, Создание нового контакта, Создание нового лида, Создание новой компании, Создание новой сделки.

Примечание: в действии бизнес-процесса "Создание новой компании" создание реквизита производится на основании полей "Фактический адрес" и "Юридический адрес". В действии бизнес-процесса "Создание нового контакта" создание реквизита производится на основании полей адреса.

Настроить параметры действия можно в визуальном конструкторе.

Обратите внимение: задать направление для сделки можно только в момент её создания.

Отследить состояние запущенного бизнес-процесса можно на странице профиля сущности.


Работа с почтой
290 / 401

На странице CRM > Настройки > Работа с почтой настраивается подключение почтового ящика к CRM, а также шаблоны отправки писем на адреса сущностей CRM.


Email-трекер
291 / 401

Email-трекер позволяет интегрировать вашу входящую и исходящую почту в CRM с созданием Дел. Кроме Дел создаются и Лиды, как техническая необходимость: Дело должно быть обязательно к чему-то привязано в CRM.

Переход к настройке Email-трекера осуществляется со страницы CRM > Настройки > Работа с почтой или же по команде Настройка интеграции почты в меню личной страницы (если почта уже подключена к порталу):

Либо, если почта не подключена, можно воспользоваться страницей Почта в меню Избранного для подключения почты:

Если ящик уже подключён к вашему Битрикс24, то вам нужно воспользоваться кнопкой Включить в строке Привязка к CRM:

После этого в открывшейся форме настроек нужно указать, за сколько дней забрать почту с подключаемого ящика, и нужно ли создавать лиды для неизвестных CRM почтовых адресов.

Примечание: Если не включать опцию Создавать лид для неизвестного отправителя, то дела будут создаваться только для известных в CRM адресов, а для остальных не будут создаваться ни дела, ни лиды.

Также рекомендуется указать почтовые адреса, которые должны быть исключены из процесса обработки почты CRM. (Это логично, так как возможно, что подключаемый ящик используется для разных целей, не только для контактов с клиентами.)

Примечание: В CRM, кроме адресов из этого поля, не будут попадать письма с адресов, зарегистрированных на портале в качестве адресов пользователей порталов, а также адреса, которые сотрудники подключают для Email-трекера.

В это поле также можно добавлять целые домены. Домены добавляются в формате @mail.ru, формат *@mail.ru недопустим.

После подключения ящика он отобразится как ящик, подключённый к CRM:

Если ящик не подключён к порталу, то в процессе подключения можно сразу и задать связь с CRM. Поля настроек и отображение результата подключения будут аналогичны тому, что описаны выше.

После подключения ящика доступна настройка папок, почта из которых будет передаваться в CRM. Для этого воспользуйтесь кнопкой Настроить в строке Обрабатываются папки. (По умолчанию обрабатываются папки Входящие и Исходящие).

Форма настроек почтового ящика

В открывшемся окне можно выбрать папки для отбора почты в CRM:

После подключения трекера письма со всех неизвестных адресов будут попадать в CRM как Дела и Лиды.

Письма с адресов, которые уже зарегистрированы как адреса Лидов, Контактов или Компаний, будут прикрепляться к соответствующим сущностям в качестве Дел.

Статус полученного письма (прочитано / не прочитано) синхронизируется со статусом Дела (выполнено / не выполнено). Если удалить неотвеченное письмо, то произойдёт и удаление Дела в CRM. Лид, если он создавался для этого Дела, не менялся и к нему больше никакие Дела не привязаны, тоже удалится.

Внимание! Проверка почты Email-трекером осуществляется один раз в 10 минут. Поэтому возможна ситуация, когда письмо уже получено, но лид ещё не создан.


Интеграция с почтой
292 / 401

На данной странице представлена форма настройки интеграции Send&Save.

Send&Save - технология добавления e-mail в события какой-либо сущности.

То есть, когда на интегрированный почтовый ящик придет письмо от клиента, система проверит, прописан ли email данного клиента в профиле какой-либо сущности. В случае, если такая сущность будет обнаружена, CRM добавит полученное письмо в события найденной сущности. Если таких сущностей несколько, email добавится к каждой.

Файлы, вложенные в письмо, будут сохранены в Общем диске, в созданной по умолчанию папке Файлы с почты (Компания > Общий Диск > Файлы с почты).

Внимание! Есть ограничение на размер прикрепляемых файлов для входящей и исходящей почты: 25 Мб.

Если адрес отправителя письма на ящик CRM зарегистрирован в системе у какого-либо сотрудника, то будет выполнена проверка содержания email, и в случае обнаружения в теле письма прописанного электронного адреса, будут произведены необходимые действия в соответствии с ним (т.е. привязка письма к сущности, его содержащей, или создание нового лида).

Почтовый ящик

Внимание! Вы можете настроить только один почтовый ящик!

Для того, чтобы интегрировать какой-либо почтовый ящик с CRM, заполните следующие поля:

  • Внешний почтовый адрес - введите электронный адрес добавляемого почтового ящика. Письма контактам и компаниям CRM будут отправляться с него и ответ приходить, соответственно, тоже на него.
  • Активность - снимите галочку, если не хотите чтобы добавляемый электронный адрес мог использоваться.
  • POP3-сервер - впишите адрес почтового сервера добавляемого e-mail (например pop.rambler.ru).
  • Порт - указывается порт, по которому идет передача сообщений.
  • Защищенное соединение (SSL) - отметьте опцию, если необходимо чтобы соединение проходило по протоколу SSL.

    SSL - (англ. Secure Sockets Layer — уровень защищённых сокетов) — криптографический протокол, который обеспечивает установление безопасного соединения между клиентом и сервером.

  • Логин - укажите ваше имя для входа на почту.
  • Пароль - укажите пароль от почтового ящика.
  • Интервал проверки почты - укажите периоды проверки почты в минутах. Имейте в виду, что свежие письма могут поступать в обработку CRM с задержкой от указанного в данном параметре времени.
  • Удалять сообщения на сервере после получения - поставьте здесь галочку если не хотите чтобы пересылаемые от клиентов сообщения хранились на сервере.

    Примечание: эта настройка не действует для почты, которая находятся на Яндексе.

  • Создавать лид для неизвестного отправителя - если e-mail клиента не привязан к какой-либо сущности, то в crm будет создан лид с названием Лид из письма от.... В дальнейшем все письма от данного отправителя будут включаться в дела созданного лида.
  • Ответственный за созданный лид - указывается сотрудник, который будет выставлен ответственным за создаваемые лиды от неизвестных отправителей. Если оставить незаполненным, то в графе Ответственный будет стоять не назначен.
  • Источник лида - можно выбрать источник лида, создаваемого при регистрации входящего письма от клиента. По умолчанию источником считается Электронная почта.
  • Служебный код - выберите, следует ли где-либо прописывать служебный заголовок CRM:

Шаблон темы для определения сущности

При добавлении какого-либо из данных регулярных выражений в тему письма, e-mail добавится в события сущности, идентификатор которой нужно указать в первых скобках выражения:

Примечание: без крайней необходимости рекомендуется не изменять данные регулярные выражения.

Это означает, что если на e-mail адрес crm (поле Внешний почтовый адрес), перенаправить письмо от клиента, в тему которого вставить конструкцию вида [LID#1], то письмо привяжется к конкретному лиду независимо от заданного email. Соответственно, если тема письма не будет соответствовать данным шаблонам, то письмо привяжется к событиям всех сущностей, для которых задан этот email.

Для сохранения всех изменений, внесенных в настройки интеграции, нажмите Сохранить.

Примечание: процесс сохранения настроек интеграции CRM с вашим почтовым ящиком может затянуться. Пусть это вас не смущает, т.к. система копирует все полученные за последние 7 дней письма. Вложения в письмах, больше 16 MB, прикреплены к делам не будут.

Чтобы удалить почтовый ящик нажмите Удалить.

Примечание: после загрузки писем в CRM, в некоторых почтовых сервисах такие письма помечаются как прочитанные.

Также можно добавить e-mail к событиям сущности, указав в первой строке письма электронный адрес, приписанный к данной сущности.


Правила обработки почты в CRM
293 / 401

Для консолидации всех возможных работ с клиентом в одном месте - CRM - менеджеру необходимо получать почту от существующих и потенциальных клиентов непосредственно в CRM.

После настройки интеграции все письма, отправленные на адрес интегрированного почтового ящика, будут попадать в CRM, и информация из них будет распределяться следующим образом:

  • Если адрес отправителя

уже зарегистрирован как адрес клиента или лида в CRM, то:
    • в Мои дела появляется новое дело для этого клиента (лида)

    • соответственно, оно же появляется в форме просмотра клиента, во вкладках Дела и История
    • Сроком дела является дата и время получения письма
    • названием дела является тема письма
    • содержимым дела является содержимое письма
      • Примечание: Если лид уже сконвертирован в контакт и компанию, то дело появится только в форме просмотра контакта.

      После получения письма в CRM в почтовом клиенте оно может отмечаться как прочитанное.

  • Если адрес отправителя уже зарегистрирован как адрес сотрудника

на портале, то:

    • просматривается тело письма на предмет содержания внутри электронного адреса
    • если адрес содержится и он уже зарегистрирован на портале, то дело приписывается к этому клиенту
    • если адрес содержится и он не зарегистрирован, то создается новый лид и новое дело, приписанное к этому лиду

    • если адрес не содержится, то новая сущность не создается, но письмо в почтовом клиенте также может быть отмечено как прочитанное
    • если в теме письма содержится конструкция вида [LID#1], то письмо будет привязано как дело (во вкладке Дела формы просмотра лида) к лиду с соответствующим номером ID вне зависимости от наличия в письме электронного адреса.

  • Если адрес отправителя не зарегистрирован на портале и в настройках интеграции флажок в пункте Создавать лид для неизвестного отправителя:
    • проставлен,

то будет создан новый лид. Название лида будет установлено из темы письма, текст письма разместится в комментариях.

    • не проставлен, то новая сущность создаваться не будет.


Почтовые шаблоны
294 / 401

На данной странице представлены шаблоны отправки писем на электронные адреса сущностей CRM:

Примечание: у вас могут быть установки отправки писем, которые можно добавить в качестве почтовых шаблонов. Нажмите на ссылку добавить их в список в сообщении, которое будет на странице Почтовые шаблоны:

С помощью меню действий вы можете редактировать или удалить почтовый шаблон:

Почтовый шаблон можно выбрать в форме создания письма:

После указания почтового шаблона форма создания письма будет заполнена в соответствии с параметрами выбранного шаблона. Создание почтового шаблона рассмотрено далее.

Нажмите на контекстной панели Добавить почтовый шаблон. Откроется форма создания:

Рассмотрим некоторые поля данной формы:

  • В поле Доступен укажите кто сможет воспользоваться создаваемым шаблоном:

    Примечание: данная опция есть только у администраторов. Обычные сотрудники могут добавлять шаблоны только для себя.

  • В поле От кого укажите e-mail, который будет указан в качестве обратного адреса.
  • В поле Тема введите тему письма, которая будет прописана для данного шаблона.
  • В поле Сущность выберите сущность CRM, для которой может быть использован данный шаблон:

    Для других сущностей он будет недоступен для выбора.

  • Выбор полей - указываются параметры выбранной выше сущности, которые будут автоматически прописаны в тексте письма, использующего данный шаблон.

    Для добавления параметра сущности (в нашем случае - сделки) выберите его из общего списка:

    Затем нажмите кнопку Добавить.

    Мы добавили три параметра: ID сделки, валюту сделки и полное имя ответственного сделки. Все эти параметры отображаются в поле ниже:

Внимание! При отправке письма сразу нескольким контактам, в письме не будут автоматически проставлены данные каждого отдельного элемента, поэтому шаблоны следует использовать только при отправке письма одному клиенту.

После выбора созданного нами шаблона создаваемое для какой-либо сделки письмо будет выглядеть следующим образом:


Интеграции
295 / 401

На странице CRM > Настройки > Интеграции можно настроить обмен данными

с имеющимся интернет-магазином на платформе 1С-Битрикс или с "1С:Предприятие" в следующих редакциях: "1С:Управление торговлей", "1С:Управление небольшой фирмой", "1С:Комплексная автоматизация" и др.


Интернет-магазины
296 / 401

На странице CRM > Настройки > Интеграции > Интернет-магазины представлен список интеграций CRM с интернет-магазинами:

Интеграция CRM и интернет-магазина нужна для создания заказов в магазине через сделки в CRM, а также импорта сущностей из магазина в CRM.

В меню действий каждой интеграции представлены следующие пункты:

  • Импорт - нажмите для запуска импорта, в результате которого в CRM могут быть загружены новые сделки, контакты и компании;

    Примечание: для тех интеграций, у которых в колонке Период импорта выставлено число, импорт происходит автоматически, через указанный этим числом период времени.

  • Проверка связи - кликните данный пункт чтобы проверить связь с интернет-магазином. Сообщение о состоянии соединения появится немного выше контекстного меню:

  • Изменить - нажмите, чтобы поменять настройки интеграции со стороны CRM;
  • Удалить - нажмите, чтобы удалить связь.

Чтобы создать новую связь CRM с интернет-магазином, нажмите на контекстной панели Новая интеграция, или Мастер новой интеграции, если хотите сделать это с использованием пошагового Мастера.

Примечание: подробно о том, как настроить интеграцию, вы можете прочитать в курсе Администратор.Бизнес.


Интеграция с "1С:Предприятие"
297 / 401

Через интеграцию с 1С:Предприятие вы сможете работать со счетами и товарами.

Примечание: о требованиях к 1С вы можете прочитать на сайте 1С:Битрикс.

Реализованы следующие сценарии обмена:

  • Cчетами:
    • Счета создаются на стороне CRM
    • Счета при достижении определенного статуса отправляются в 1С
    • На стороне 1С может быть проведена оплата счета или его отгрузка, может быть изменен состав товаров счета, их стоимость и количество. Все эти данные будут автоматически отправлены в CRM при очередной синхронизации
    • Эти же изменения на стороне CRM приведут к изменениям соответствующих заказов в 1С
  • Товарами:
    • Обмен товаров реализован односторонний, то есть отслеживаются изменения только на стороне 1С, а при синхронизации эти изменения попадают в CRM

Типовая конфигурация продукта 1С:Предприятие, ред. Управление торговлей имеет встроенные механизмы для обмена данными с сайтом, разработанным на платформе 1С-Битрикс: Управление сайтом. Улучшить возможности обмена можно с помощью установки модулей обмена.

В данной главе рассматриваются оба варианта интеграции: с помощью встроенного механизма обмена данными и с помощью модуля обмена.

Примечание: если у вас более ранние версии продуктов 1С:УТ и/или 1С-Битрикс: Управление сайтом и нет возможности обновиться, то для обмена данными следует использовать возможности типовой конфигурации 1С. В этом случае часть имеющегося на текущий момент функционала по обмену данными будет вам недоступна.

Основные настройки интеграции выполняются на стороне 1С:Управление торговлей, они описаны для обоих вариантов в соответствующих уроках ниже.

На стороне CRM производятся следующие действия:

На странице Битрикс24 CRM > Настройки > Интеграции > Интеграция с "1С:Предприятие" следует разрешить обмен данными и скопировать адрес страницы синхронизации:


Интеграция с помощью встроенного механизма
298 / 401

На стороне 1С в разделе Администрирование > Настройки синхронизации данных должен быть разрешен обмен данными с сайтами:

Далее следует настроить параметры, необходимые для обмена данными между CRM и 1С. Создайте типовое соглашение для выгрузки цен (Маркетинг и планирование > Типовые соглашения с клиентами). В параметрах соглашения обязательно должны быть: пустой Cегмент клиентов, соответствующий Вид цен и отметка в пункте Доступно внешним пользователям.

В 1С:Управление торговлей перейдите на страницу Администрирование > Настройки синхронизации данных > Узлы обмена с сайтами:

Нажмите Создать и в появившейся форме на закладке Основные настройки в поле Адрес сайта вставляем скопированный адрес страницы синхронизации.

Следует отметить параметры Выгрузка товаров и Обмен заказами, а также указать имя пользователя и пароль от вашего аккаунта Битрикс24.

Примечание: Параметры Выгрузка товаров и Обмен заказами можно одновременно отмечать только для первого обмена данными. В дальнейшем для ускорения процесса обмена рекомендуется выгружать товары по мере их обновления, или же создать отдельные узлы обмена для товаров и заказов.

Скопируйте идентификатор каталога из настроек параметров импорта на портале CRM > Настройки > Интеграция с "1С:Предприятие" > Настроить синхронизацию каталога товаров с 1С :

и в форме Узел обмена с сайтами, на вкладке Выгрузка товаров, вставьте идентификатор каталога:

Также настройте другие параметры выгрузки товаров - соответствие полей импорта, настройку дерева групп.

В 1С:Управление торговлей на вкладке Обмен заказами установите значения необходимых параметров такими, какими вы их задали на предыдущих шагах интеграции:

На вкладке Дополнительно укажите соответствие статусов счетов:

На стороне CRM вы можете настроить статусы счетов при отгрузке из 1С:

Также из вкладки Обмен заказами можно запустить Настройку соответствий загружаемых документов и настроить реквизиты шапки документа, табличной части документа и т.д.

После окончания настроек запустите синхронизацию данных из формы редактирования узла обмена с сайтом:

Либо из общего списка узлов обмена, выделив нужный:

После выполнения синхронизации товары из 1С будут выгружены в Битрикс24, а счета из Битрикс24, вне зависимости от того, выставлены они Контакту или Компании, - переданы в 1С. Для каждого из счетов будет установлен заданный статус.

Внимание! Счета, которые уже были в 1С, при синхронизации не будут выгружены в Битрикс24.


Интеграция с помощью модуля обмена 5.х
299 / 401

Подробно настройки обмена данными с помощью модуля обмена 5.х описаны в курсе Администратор.Бизнес.

В общем случае, рекомендуется следующий порядок настройки обмена данными:

  • По ссылке Настройка обмена с интернет магазином открыть список узлов обмена
  • В форме создания/редактирования узла обмена заполнить поля аналогично основным настройкам.

    • Внимание! Функции Выгружать лог на сайт и Хранить файлы обмена на сайте не поддерживаются для CRM.

  • При необходимости настроить расписание обмена по соответствующей ссылке.
  • Настроить режим обмена данных на соответствующей закладке.

    • Внимание! Выгрузка пользовательских справочников и Выгрузка контрагентов не поддерживаются для CRM.

  • Выгрузка информации о номенклатуре настраивается аналогично выгрузке товаров.
  • Обмен документами настраивается аналогично обмену заказами.

По окончании всех настроек не забудьте нажать кнопку Применить. Окно закроется, можно приступать к выгрузке данных с помощью кнопки Выполнить обмен данными в форме настроек обмена данными. По окончании выгрузки в 1С будет отображено соответствующее сообщение.


1С-трекер
300 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
1С-трекер

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Модуль 1С-трекер позволяет связать офлайн-продажи с онлайн-CRM в режиме реального времени. С его помощью можно выгрузить сведения о клиентах и историю продаж из торговых систем на платформе 1С:Предприятие, любые документы и клиентов из 1С:Бухгалтерии и всех учетных систем на платформе 1С:Предприятие, идентифицировать клиента, подключить любое количество 1С к одному порталу Битрикс24.

1С-трекер предназначен для выгрузки из 1С в Битрикс24 следующих данных:

Выгружаемые объекты 1С | Создаваемые сущности CRM Битрикс24
Контрагенты, их контакты и контактная информация | Компании
Контактные лица контрагентов | Контакты
Организации | Компании
Документы | Мои дела
Все объекты | Дела

Примечание: по умолчанию выгружается только документ «Отгрузка». В настройках выгрузки можно указать, какие документы должны выгружаться. При этом документ должен иметь реквизиты «Контрагент» и «Сумма документа», а также быть включенным в Состав Плана обмена Конфигуратора 1С.

Конфигуратор 1С

При связывании 1С-трекера с Битрикс24 основные настройки производятся на стороне 1С. Порядок действий определен следующий:

  • скачать 1С-трекер по ссылке http://1c.1c-bitrix.ru/intranet/download.php или из CRM, перейдя со специальной страницы:

    При выборе модуля для скачивания обратите внимание на их совместимость с различными редакциями 1С:
    • «Бухгалтерия предприятия ред. 3.0». Модуль тестировался на релизе 3.0.43.236.
    • «Управление торговлей ред. 11». Этот модуль совместим с релизами УТ, начиная с 11.1.10, а также с ERP 2 и КА 2.0. Корректная работа с УТ других стран возможна, так как их базы аналогичны, но не гарантируется.
    • «Управление небольшой фирмой». Модуль тестировался на релизе 1.6.4.19.
      • Модули максимально отделены от типовых объектов 1С, поэтому с большой долей вероятности будет работать с другими релизами без доработок или с минимальной адаптацией.
  • распаковать и установить модуль 1С-трекер. Установка модуля стандартная, подробно описана в документации Руководство пользователя модуля «Битрикс 24 CRM + 1С» и в уроке Установка модуля обмена 5.х
  • в 1С создать новую Настройку выгрузки на портал

  • настроить выгрузку - указать название, проставить флажки напротив выгружаемых данных, выбрать выгрузку только измененных данных или полную:

  • указать ключ, полученный и скопированный на портале в разделе «1С+CRM Битрикс24»

  • настройки трекера со стороны Битрикс24 осуществляются на странице CRM > Настройки > Интеграции > Настройки трекера. Пресеты установлены по умолчанию, при необходимости можно указать собственные:

После сохранения настроек выгрузки в 1С можно запустить команду Выполнить выгрузку. В результате данные попадут в соответствующие сущности CRM:

- Контакты:

- Компании:

- Мои дела:

Дальнейшая работа с импортированными объектами в CRM не отличается от работы с непосредственно созданными на портале сущностями.

Если в настройках 1С указан адрес к веб-серверу 1С, то импортированные объекты могут быть открыты из Битрикс24 по внешней ссылке

через браузер непосредственно в базе 1С.

Дополнительная информация
  • Выгружаем данные из 1С с помощью нового модуля «1С трекер»
  • Скачать дополнительные модули для 1С
  • Руководство пользователя модуля «Битрикс 24 CRM + 1С»


Приложения
301 / 401

Со страницы CRM > Настройки > Приложения можно получить доступ к установке приложений Marketplace, относящихся к CRM. Такие приложения разбиты на две групы: Приложения для CRM и Миграция из других CRM.

Установка и обновление приложений описаны в отдельном уроке.


Другое
302 / 401

На странице CRM > Настройки > Другое > Прочие настройки собраны параметры настроек, не имеющие собственных страниц. Режим отображения настроек переключается кнопкой [image] и может быть выбран либо одностраничный

либо в виде окна с закладками.

На закладке Общие, в частности, можно задать значение по умолчанию поля Доступен/доступна/доступно для всех для лидов, контактов, компаний, сделок и предложений. А также установить представление по умолчанию списка лидов, сделок и счетов, необходимость обновления даты завершения сделки, настройки создания на основании:

На закладке Дела указывается, показывать ли в календаре завершенные встречи и совершенные звонки, а также следует ли сохранять в календаре задачи при удалении лидов, контактов, компаний и сделок:

Параметр Учитывать сделки/лиды без дел для расчета счетчиков в меню влияет на число, показываемое на иконке сделок\лидов в верхнем главном меню CRM: установка галочки приведет к тому, что будет показано общее число незакрытых (незавершенных) сделок (лидов), за которые текущий сотрудник является ответственным. При снятой галочке будет отображаться число назавершенных\незакрытых лидов\сделок, за которые текущий сотрудник является ответственным, с невыполненными делами при уже истекшем сроке выполнения.

Параметр Регистрировать сообщения как "Письма клиенту", если они пересылаются с e-mail адресов сотрудников дает возможность сохранения пересылаемых писем как исходящих.

На закладке История указывается, регистрируются ли события экспорта, просмотра и удаления сущностей в их истории. А также задается интервал группировки событий просмотра при их регистрации:

На закладке Живая лента задается возможность отображать сообщения и дела CRM в общей Живой ленте портала:

На закладке Справочники указывается, следует ли отображать устаревшие справочники. Например, справочник Продукты относится к устаревшим, т.к. в настоящее время сущность Товары является более удобной и функциональной.

На закладке Форматирование устанавливается формат имени клиента, который будет использован как при отображении в списках (контактов, лидов), так и при написании писем. Формат имени может включать обращение (господин, мистер, Mr), заданное в справочнике.

Среди прочего, можно указать преобразование номера к международному формату набора (необходимо для IP-телефонии):

Настройка поля Формат вывода ссылок "callto" должна быть конкретной: номер должен начинаться или с 7, или с 8 или с +7. Однако допускается использование ссылок такого вида: callto://+ или sip:+. В этом случае набор номера будет производиться в формате +(7.......). К номеру будет просто добавлен плюс.

При проставленной галочке в параметре Преобразовать номер к международному формату набора произвольно введенный пользователем номер телефона будет преобразован к нужному виду.

На этой же закладке задаются настройки форматирования почтового адреса клиента (лида, контакта, компании).

На закладке Контроль дубликатов включается контроль ввода сущностей с идентичными параметрами:

Для создаваемого лида или контакта проверка выполняется по ФИО (для компании/лида - названию), email и телефону. При проверке номера телефона учитываются только цифры. Даже если вы напишете в начале номера 8 вместо +7, то вы будете предупреждены о совпадении.

Примечание: если не заполнено поле Фамилия, то проверка по имени и отчеству выполняться не будет.

Аббревиатуры формы организации (например ООО, АО, ЗАО), а также дефисы, будут игнорироваться при проверке дубликатов компаний.

При включенном контроле во время добавления новой сущности система будет предупреждать о наличии совпадений:

Кликните по ссылке в данном сообщении, чтобы увидеть список совпадений.

Примечание: вы можете проигнорировать предупреждение о наличии дубля сущности и все равно ее добавить.

При копировании лида, контакта, компании контроль дубликатов производится так же, как и при создании, то есть автоматически выдается предупреждение о наличии совпадений.

Для сущностей, импортируемых или автоматически создаваемых из интегрированных программ, проверка дубликатов автоматически не запускается, её следует проводить после индексации (обновления) списка.

На закладках Номера счетов и Номера предложений указывается принцип нумерации счетов и предложений соответственно:

Ссылки по теме:

  • Поиск и обработка дубликатов


Сценарии использования CRM
303 / 401

Рассмотрим несколько случаев того, как и когда может использоваться CRM в работе менеджера.

Примечание: интерфейс облачного Битрикс 24 может отличаться от приведенных в данных уроках скриншотов.


Постоянный клиент на поддержку сайта
304 / 401

Рассмотрим сценарий использования CRM, при котором в фирму поступает звонок от потенциального клиента, нуждающегося в поддержке своего сайта. Предварительно клиент просит выслать в виде слайда схему нашего бизнес-процесса по оказанию поддержки и желает ознакомиться с техническим заданием (ТЗ).

Создаем лид: перейдите на страницу Список лидов и нажмите Добавить лид:

После того, как будет составлено ТЗ и счет для клиента, вышлем их в прикрепленных к письму файлах:

После поступления оплаты конвертируем лид в сделку:

и в контакт:

Создаем задачу в карточке сделки:

В форме создания задачи назначаем ответственного, выставляем нужные сроки.

Создайте необходимые подзадачи, выбирая в группе полей Дополнительно в качестве базовой задачи CRM: создать слайд:


Работа со сделкой из интернет-магазина
305 / 401

Рассмотрим сценарий использования CRM, при котором клиент делает заказ из публичной части интернет-магазина под управлением 1С-Битрикс: Управление сайтом:

После нажатия кнопки Оформить заказ данные о заказе по протоколу CommerceML пересылаются в CRM корпоративного портала.

Внимание! У вас должна быть настроена интеграция интернет-магазина и CRM.

В CRM у вас:

  • создастся сделка с привязкой к интернет-магазину;
  • создастся новый контакт (если такового еще нет).

При настройке интеграции интернет-магазина и CRM можно указать менеджера, который будет назначаться ответственным на сделки, связанные с заказами из магазина:

При необходимости можно настроить бизнес-процесс, при запуске которого ответственному менеджеру будет приходить уведомление о создании новой сделки.

Далее менеджер знакомится со сделкой, проверяет данные и регистрирует звонок клиенту с целью уточнения деталей:

Через определенное количество времени ответственный менеджер получает уведомление в мессенджере портала о том, что нужно совершить звонок:

При телефонном разговоре выясняется, что клиент хочет увеличить количество одного из товаров и просит доставить товар, поэтому менеджер переходит к редактированию заказа:

Внимание! Если при нажатии кнопки Изменить или Просмотреть выдается сообщение External site is not found, то вам следует изменить поле Адрес в настройках интеграции интернет-магазина и CRM, прописав в нем не буквенный адрес интернет-магазина, а его ip.

В открывшейся форме доступен весь функционал работы с заказом интернет-магазина:

После сохранения изменений состав заказа и итоговые суммы автоматически обновятся.

Далее в форме просмотра сделки идет постановка задачи курьеру на доставку заказа. В форме создания задачи задаются нужные сроки и необходимые пояснения:

Через некоторое время менеджер получает уведомление о том, что курьер выполнил задачу:

После этого менеджер переходит в форму просмотра\редактирования сделки, чтобы закрыть ее.

На закладке Товары сделки нажимает кнопку Изменить и в в форме редактирования заказа меняет статус заказа и статус оплаты:

В группе полей О сделке статус заказа автоматически сменится на Сделка заключена:


Создание сделки по звонку клиента
306 / 401

Поступает звонок от клиента, менеджер переходит на страницу создания сделки (CRM > Сделки > Добавить сделку) и начинает формировать заказ:

Можно редактировать количество и цену за единицу товара:

После того, как клиент оставил свои контактные данные, менеджер переходит к созданию нового контакта прямо из формы создания сделки:

При необходимости, аналогичным образом к сделке можно привязать компанию.

Клиент попросил доставку осуществить между 14 и 15 часами, менеджер вносит это в комментарий:

Клиент уже ждет товар, а менеджер заполняет основные поля сделки: название, стадия, сумма, ответственный и прочее:

После нажатия кнопки Сохранить вы попадете на страницу просмотра добавленной сделки:


Создание и обработка лида из веб-формы
307 / 401

Посетитель вашего сайта заполняет веб-форму:

При настроенной интеграции веб-формы с CRM, данные анкеты пересылаются через API в CRM в качестве лида. Откройте лид в режиме просмотра для проверки данных:

Укажите статус лида как В обработке и назначьте нужного менеджера.

При необходимости можно добавить товары к лиду:

С помощью кнопки Дела можно создавать действия и планировать события:

Например, создать Звонок и через определенное количество времени получить уведомление:

Менеджер добавляет задачу в окне просмотра лида:

Далее конвертирует лид в контакт (поля из лида проставляются автоматически):

и в сделку:

Товары сделки, переданные из лида, можно отредактировать тут же.


Организация работы call-центра
308 / 401
  • Постановка задачи
  • Администратор
  • Оператор
  • Контроль работы

Приведем пример работы компании, занимающейся, с периодичностью в две недели, организацией семинаров и привлечением на них сотрудников различных фирм.

Постановка задачи

В нашем примере, для выполнения этой задачи, в компании есть два оператора, занимающихся обзвоном клиентов, которых им назначает администратор. Тем компаниям, которые заинтересованы в привлечении своих сотрудников к участию в семинаре, высылается коммерческое предложение, в котором детально расписано содержание семинара и условия участия в нем. Клиентам, которых устроило данное предложение, высылается счет на оплату. Данные процедуры раз в две недели повторяются операторами для всех компаний, которые находятся под их попечением.

При этом администратор должен всегда иметь возможность отследить работу операторов и иметь доступ к информации о согласии и отказах клиентов, удалять компании, которые попросили их не беспокоить, а также добавлять новые. Проследим с самого начала как это можно организовать с помощью Битрикс 24 или вашего корпоративного портала.

Администратор

Для избежания некорректности в работе операторов, администратору следует выставить соответствующие права доступа. Создается роль CRM Оператор и ей выставляются следующие права:

Всем операторам назначается созданная роль. В нашем случае операторы могут просматривать и изменять все компании (это необходимо для возможности добавлять дела). Разрешаются произвольные действия со своими счетами. Ко всему остальному доступ закрыт, в рамках задачи данного урока больше ничего не понадобится.

Внимание! Нужно проследить за тем, чтобы операторы не состояли в других группах\отделах, которым заданы более широкие права, поскольку доступ в Битрикс 24 носит разрешительный характер.

На странице CRM > Компании администратор создает компании, занося в каждую контактные данные и назначая нужного оператора ответственным:

Примечание: в дальнейшем, добавляя нового клиента, администратор добавляет к нему дело, ставя ответственным за него нужного оператора, о чем последний будет предупрежден либо уведомлением (для задач), либо увидит в общем списке компаний грядущее дело, выделенное розовым:

После выполнения оператор закрывает данное дело с комментарием о результатах.

Администратор добавляет почтовый шаблон с детальным информированием клиентов о данном готовящемся семинаре:

Администратор создает товар, который будет использован при выставлении счета за участие в семинаре:

На странице CRM > Компании администратор выделяет все компании и на панели групповых операций выбирает действие Добавить задачу. Откроется форма постановки задачи:

Указывается срок выполнения, описание задачи, в список ответственных добавляются все операторы, задается повторение задачи каждые две недели.

Оператор

Каждый оператор получает уведомление о поставленной задаче и, заходя на страницу списка компаний, начинает обзванивать причисленные к нему, после каждого разговора добавляя к компании звонок с описанием итогов разговора и выделяя галочками в общем списке компании, заинтересованные в получении подробностей участия в семинаре:

Примечание: в качестве альтернативного варианта оператор может информировать о своих телефонных переговорах, работая с поставленной администратором задачей.

При необходимости повторного звонка, встречи или чего-то другого, оператор добавляет к компании звонок\встречу\задачу. Такие невыполненные дела будут видны в одноименной колонке общего списка компаний.

Если необходимо по просьбе клиента удалить его из базы, тогда оператор может добавить к компании такую задачу, выставив ответственным администратора.

Для тех компаний, с которыми оператор не успел или не смог связаться, с помощью панели групповых операций оператор добавляет задачу под свою ответственность, сознательно выставляя ей просроченный срок и запуская на выполнение:

Благодаря этому, в общем списке компаний эта задача будет выделена красным для всех необработанных компаний и оператор, как и администратор, будет видеть, какие компании им еще не оповещены.

Внимание! Имейте в виду, что в общем списке компаний будет видимо только одно невыполненное дело. Для просмотра остальных необходимо войти в режим детального просмотра компании.

У нас уже выделены в общем списке заинтересованные компании и на панели групповых операций выбирается Отправить письмо:

Клиентам отсылается письмо по созданному администратором шаблону к данному семинару:

Если к оговоренному сроку от клиентов приходит обратная связь в виде email, это отобразится как в виде уведомления, так и в колонке дел:

Кроме того, вся переписка фиксируется в истории событий сущности.

Примечание: если ответа по электронной почте нет, то оператор делает звонок (добавляя его к сущности) и по его итогам выполняет дальнейшие операции.

Затем оператор создает счет компании за участие в семинаре и отсылает его клиенту:

Статус счета после этого можно перевести в Отправлен клиенту. После подтверждения оплаты\неуплаты счет закрывается:

После завершения семинара оператор может обзвонить своих клиентов и расспросить о впечатлениях и пожеланиях. Данную информацию можно добавлять к компании в виде события:

Контроль работы

На странице CRM > Компании, в колонке Дела, администратор (как и операторы) видит те действия и задачи, которые операторы запланировали выполнить:

Принцип в том, что при постоянных периодических приглашениях, если не получен отказ от участия в текущем семинаре, то для каждой компании должно быть запланировано какое-либо дело (возможно несколько дел), которое будет выделено цветом в колонке Дела.

Если таковых действий нет (в нашем случае это ЗАО "МПЗК"), то администратор заходит в режим просмотра компании и просматривает дела и задачи для данной компании, а на закладке История видит детальное опись действий с компанией и их описаний:

Сразу становится понятным, почему для данной компании не запланировано никаких действий: клиент изъявил желание сам связаться через два дня.

Закладка История также позволяет отследить правку недобросовестным оператором не своих компаний и разрешить возможные спорные моменты.


Абонентское обслуживание
309 / 401

Рассмотрим, как с помощью CRM можно организовать систему абонентского обслуживания. От клиента ежемесячно приходит оплата за определенное число часов работы, заявки на которую поступают от него в течении месяца.

В процессе работы может происходить общение с клиентом для уточнения каких-либо вопросов. После окончания работы должно фиксироваться потраченное на нее время. По окончании месяца создается отчет о выполненной работе и общем затраченном на нее времени, получаемым сложением затраченного времени на каждую заявку.

Клиенты присутствуют в CRM в виде контактов. После достигнутой договоренности клиенту выставляется счет:

После оплаты клиент письмом присылает заявку на выполнение какого-либо задания на ящик CRM. При настроенной интеграции почты и CRM это письмо автоматически привяжется к нужному контакту, а ответственному за данный контакт придет соответствующее уведомление:

Пройдя по ссылке в виде темы письма, вы попадете в список дел контакта, где можно просмотреть данное письмо, переслать или ответить на него:

Далее, все еще находясь в списке дел контакта, добавьте задачу и заполните форму необходимыми данными:

Задача создается в специальной группе, созданной для проектов данного клиента. Отметьте начало выполнения задачи.

Не переходя на другую страницу, можно вести общение с клиентом по поставленной задаче с помощью электронной почты:

Аналогичным образом обрабатываются и регистрируются другие заявки клиента. После выполнения поставленные задачи завершаются.

Все общение с клиентом и работа с задачами будут зафиксированы на закладке История профиля его контакта в CRM.

Создадим отчет по выполненным задачам и затраченному на них времени, который ежемесячно предоставляется клиенту:

Важно! Имейте в виду, что автоматический подсчет времени выполнения задачи ведется только при включении задачи в план дня. Подробнее об этом читайте в соответствующем уроке.

В отчете мы оставили нужные колонки, указали сортировку по времени выполнения задачи и указали вывод в него только задач из группы, созданной для нашего клиента. Единожды созданный отчет по одному щелчку мыши будет автоматически обрабатывать новые данные по задачам каждый месяц.

Составленный отчет будет иметь следующий вид:

Можно экспортировать его в Excel и выслать клиенту.


Автоматизация исполнения проекта
310 / 401

Рассмотрим возможный сценарий использования вашего Bitrix Framework для работы над проектом после закрытия сделки.

В нашем случае работа начинается после оплаты и закрытия сделки. После того, как менеджер перевел сделку в стадию Сделка заключена, на руководителя департамента и аналитика ставятся соответствующие их должностям типовые задачи с установленными сроками выполнения, в которые должна быть перенесена первичная информация из сделки. Менеджер должен проследить за корректным выполнением этих задач.

Для реализации такого сценария мы будем использовать бизнес-процесс на изменение сделки. Чтобы исключить случаи постановки задач при изменении каких-либо других данных сделки со статусом Сделка заключена, нами будет создано пользовательское поле, в которое записывается факт перевода сделки в конечную стадию.

Создадим пользовательское поле для сделок:

Значение поля по умолчанию - 0. При переводе сделки в нужную нам стадию и постановки задач нужно будет менять его на 1. Значение 1 и будет означать факт заключения сделки.

На странице CRM > Настройки > Бизнес-процессы добавьте шаблон на изменение для сделок. Откроется форма настройки параметров шаблона:

Создадим следующую схему шаблона бизнес-процесса:

Разберем основные моменты его структуры. Сначала проверяется стадия сделки. Если она равна Сделка заключена, то осуществляется переход к проверке значения пользовательского поля Изменялась стадия сделки:

В случае, когда значение данного поля 0, переходим к постановке задач:

Постановщиком выбран ответственный за сделку менеджер, что позволит ему быть в курсе работы над проектом.

В качестве крайнего срока указано выражение =Dateadd({=System:Date}, "2 days"), которое выставляет дату крайнего срока равной текущая дата + 2 дня.

В Описание задачи копируются поля сделки, такие как Сумма в указанной валюте, Комментарий, Контакт, Компания. Это позволит ответственному за задачу руководителю департамента сразу быть в курсе дел по данной задаче:

Далее выставлены другие параметры задачи, в том числе привязка к текущей сущности CRM, то есть сделке, что может пригодиться для контроля ведущейся с ней работы.

Аналогично ставится задача аналитику, затем в действии Изменение пользовательского поля выполняется смена значения пользовательского поля Изменялась стадия сделки на 1.

Такое же действие, только с присваиванием значения 0, применено в случае, если проверка стадии сделки выявила, что стадия не является Сделка заключена. Это сделано для случая, когда сделку переводят из конечного статуса в предварительный, а затем опять в Сделка заключена. Если бы такого действия не было, то в этом случае постановка задач снова не совершилась бы, поскольку значение поля оставалось бы 1.


Сценарий автоматизации контроля оказания услуг
311 / 401

Последовательно рассмотрим, как с помощью бизнес-процесса, использующего инструменты Битрикс24, может быть реализован возможный вариант автоматизации контроля исполнения работ.

Примечание: данный сценарий для своего использования подразумевает как минимум базовые знания о бизнес-процессах и других инструментах вашего портала.

Подойдет для компаний, схема работы которых выглядит ориентировочно следующим образом:

  • продажа менеджером услуги, клиент оплачивает счет;
  • руководитель получает необходимую информацию об объекте заказчика и выбирает исполнителя;
  • передача исполнителю перечня документов для заполнения;
  • выполнение работы на объекте клиента;
  • проверка менеджером документов;
  • подготовка акта и отчета, уведомление заказчика о завершении работы;
  • менеджер доставляет клиенту акт и отчет.

Менеджер, являясь ответственным за сделку, ведет ее в CRM и после того, как клиент оплачивает счет по ней, переводит ее в стадию Оплачено.

Примечание: для создания такой стадии сделки воспользуйтесь справочниками CRM:

После смены стадии запускается бизнес-процесс на изменение сделки:

Сначала бизнес-процесс проверяет, является ли стадия сделки равной Оплачено (действие Проверка стадии сделки). Для избежания выполнения бизнес-процесса при каком-либо редактировании сделки со статусом Оплачено, предварительно было создано пользовательское поле Изменялась стадия сделки? со значением по умолчанию 0, при котором бизнес-процесс пойдет по своей основной ветке, в конце которой значение данного поля меняется на 1.

Чтобы предусмотреть ситуацию, при которой стадия сделки откатывается от Оплачено, а затем снова в нее возвращается (что требует повторного запуска бизнес-процесса), было задействовано уравнивание нулю значения поля Изменялась стадия сделки? в случае, если после изменения сделка находится в стадии, отличной от Оплачено (действие Изменение значения пользовательского поля в ветке Не оплачено).

Далее в главной ветке бизнес-процесса идет запрос дополнительной информации от начальника отдела (действие Выбор сотрудника для осмотра объекта), которому следует выбрать своего сотрудника для выезда к заказчику. Данное действие при детальном просмотре выглядит следующим образом:

В описании добавлены необходимые для руководителя данные из сделки, такие как комментарий, контакт, компания. Добавлено поле типа Привязка к пользователю, через которое идентификатор выбранного сотрудника будет сохранен в переменной Сотрудник.

При переходе бизнес-процесса к данному действию, требующему ответа от руководителя отдела, у последнего появится запрос об этом в виде цифры рядом с пунктом бизнес-процессы основного меню:

При просмотре задания руководитель будет видеть следующую форму:

В следующем действии стадия сделки меняется на В обработке (действие Сделка - "В обработке"), а руководителю, аналогично запросу на выбор сотрудника, посылается задание (действие Первичное формирование ведомости документов) на формирование ведомости документов, которые необходимо забрать у заказчика:

Составленная ведомость сохранится в переменной Список документов, созданной в форме создания запроса дополнительной информации:

Затем в бизнес-процессе ставится задача подчиненному (выбранному сотруднику):

  • бизнес-процесс приостанавливается на время выполнения задачи;
  • в качестве ответственного ставится выбранный руководителем сотрудник (переменная Сотрудник);
  • с помощью выражения =Dateadd({=System:Date}, "2 days") крайним сроком указано 2 дня от текущей даты;
  • в описание задачи перенесен список документов, составленный руководителем (переменная Список документов) и поля сделки, такие как идентификатор контакта\компании, комментарий;
  • наблюдателем выбран ответственный по сделке менеджер;
  • задача находится в группе Продажи, что позволит в дальнейшем отследить выполнение задач через данную группу;
  • задача привязывается к текущей сущности CRM (сделке).

Для ответственного задача будет выглядеть следующим образом:

После выполнения своего задания ответственный сотрудник может вложить отсканированные документы в комментарии к задаче, либо принести их лично менеджеру на проверку.

После завершения задачи запускается цикл утверждения документов менеджером:

Специально для данного цикла в параметрах шаблона бизнес-процесса была предварительно создана переменная Утверждение документов типа Да\Нет. Цикл будет выполняться до тех пор, пока значение данной переменной не изменится (т.е. произойдет утверждение документов). В случае, если менеджер не утверждает документы, ответственному сотруднику ставится задача Забрать документы на заполнение, в которой будет отображен комментарий менеджера о том, что следует исправить, внесенный им при отклонении документа (Дополнительные результаты > Утверждение документов > Комментарий).

После утверждения документов руководителю отдела ставится задача о подготовке отчета, а менеджеру, не останавливая бизнес-процесс на время выполнения задачи - о передаче акта.

Затем заказчику от имени менеджера (ответственный за сделку) отсылается письмо на электронный адрес с сообщением о завершении работы:

В в качестве адреса получателя указывается значение пользовательского поля email, предварительно созданного для сделок.

После этого следуют действия Изменение полей документа, с помощью которых меняется стадия сделки на Сделка заключена и значение пользовательского поля Изменялась стадия сделки?, о котором было сказано выше.

В нашем случае менеджер и руководитель постоянно в курсе стадии работы с клиентом, являясь либо ответственными\постановщиками, либо наблюдателями всех задач по сделке. Отследить события, текущие дела и задачи по сделке можно в форме ее просмотра (закладки Лента, Дела, История):

Примечание: вы можете скачать шаблон данного бизнес-процесса.


Реализация сценария использования абонементов на посещения
312 / 401

Рассмотрим реализацию продажи абонементов на посещения с помощью инструментов Битрикс24.

  • Постановка задачи
  • Создание сделки
  • Бизнес-процесс
  • Оповещение клиента
  • Подготовка отчета

Постановка задачи

В рассматриваемом сценарии необходимо реализовать продажу двух видов абонементов, различающихся по стоимости - на месяц и на две недели. При этом нужно вести учет посещений и отправлять ответственному менеджеру напоминания о заканчивающемся абонементе какого-либо клиента.

В данном примере, средствами Битрикс24, это сделано следующим образом. Для каждого клиента в CRM создается контакт, а под каждый абонемент - товар в каталоге CRM. При продаже абонемента контакту - создается сделка. После создания сделки запускается бизнес-процесс, который отчитывает время до окончания срока действия абонемента, и за несколько дней до его наступления ставит задачу ответственному за данную продажу менеджеру.

Создание сделки

Рассмотрим поэтапно процедуру реализации данной схемы.

В разделе товары создается абонемент:

Аналогично создается товар Двухнедельный абонемент.

Для клиента, при покупке абонемента, создается сделка:

Заполненная форма создания сделки

Заполните необходимые поля в форме создания сделки:

  • указывается название и обязательно заполняетcя поле Сумма.
  • При необходимости выбирается другой ответственный.
  • Привязка с контакту будет установлена автоматически.
  • Выбирается товар сделки.

Бизнес-процесс

Затем запускается заранее созданный бизнес-процесс с автоматическим запуском при добавлении сделки:

При создании любой сделки проверяется условие выполнения бизнес-процесса (Покупка абонемента), в котором сверяется значение поля Сумма. Рассмотрим пример ветки для месячного абонемента (для двухнедельного абонемента все сделано аналогично):

Бизнес-процесс будет выполняться дальше по данной ветке только в случае, если в поле Сумма созданной сделки прописано значение 5800. Соответственно, для двухнедельного абонемента это значение меньше.

Затем ставится пауза в выполнении на 27 дней:

Для двухнедельного абонемента пауза равна 12 дням.

По прошествии 27 дней, менеджеру, заключившему данную сделку (предполагается, что он - ответственный) ставится задача об уведомлении клиента о скором истечении срока действия его абонемента:

  • В крайнем сроке указано выражение
    =Dateadd({=System:Date}, "1 d")
    Оно устанавливает в качестве крайнего срока один день от текущей системной даты.
  • В качестве постановщика выбирается начальник отдела.
  • В описании задачи будет выведен идентификатор контакта, привязанного к сделке:
    {=Document:CONTACT_ID}
  • Вы можете прикрепить задачу к сделке, установив значение Да в поле Привязать к текущей сущности CRM.

Оповещение клиента

После окончания заданного в бизнес-процессе периода, ответственному за сделку менеджеру придет уведомление о том, что на него поставлена задача:

Найдя по ID в списке контактов нужного клиента, менеджер уведомляет его об истечении срока действия абонемента и предлагает продление.

Подготовка отчета

Учет посещений можно вести, создав отчет по делам:

В данном отчете будет учитываться любое дело (кроме события), в названии которого есть посещение. То есть, к каждому клиенту, при его визите, ответственному за него менеджеру следует добавлять дело, в названии которого будет слово посещение. В результате можно будет вести учет общего числа визитов по абонементам:


Компания
313 / 401

Раздел Компания предназначен для работы с информацией, связанной собственно с компанией.

В разделе представлены следующие страницы:

  • Сотрудники - здесь вы можете найти карточку сотрудника и\или узнать краткую информацию о нем.
  • Общие документы - раздел для работы с общими документами компании.
  • Структура компании - наглядное графическое представление иерархии филиалов, подразделений и отделов компании в виде схемы.
  • Отсутствия сотрудников по каким-либо причинам фиксируются в Графике отсутствий.
  • Отработанные часы за каждый день можно посмотреть на странице Рабочее время.
  • Рабочие отчёты - страница где выводятся отчёты сотрудников о работе за определённый период времени.
  • Планёрки и собрания - инструмент для управления собраниями.

Сотрудникам с разными правами доступа доступен различный функционал портала. Ниже в таблице приведены функции (Функционал), соответствующие различным группам сотрудников (Права пользователя), и указано, на какой странице раздела можно этим функционалом воспользоваться (Страница).

Функционал | Страница | Права пользователя
Добавление сотрудника | Компания > Сотрудники | администратор
Экспорт сотрудников в Outlook | Компания > Сотрудники | сотрудник
Экспорт сотрудников в Excel | Компания > Сотрудники | сотрудник
Доступ в папку с документами | Компания > Общие документы | В соответствии с правами, заданными администратором
Добавление/Удаление/Редактирование папки | Компания > Общие документы | В соответствии с правами, заданными администратором
Добавление/Удаление/Редактирование документа | Компания > Общие документы | В соответствии с правами, заданными администратором
Подключение папки как сетевого диска | Компания > Общие документы | сотрудник
Запуск бизнес-процессов | Компания > Общие документы | В зависимости от настроек конкретного бизнес-процесса
Создание/редактирование шаблона бизнес-процесса документов | Компания > Общие документы | администратор
Создание типовых шаблонов бизнес-процессов документов | Компания > Общие документы | администратор
Восстановление документа из "Корзины", очистка "Корзины" | Компания > Общие документы | администратор
Добавление/изменение/управление подразделениями | Компания > Структура компании | администратор
Добавление отсутствия сотрудника | Компания > График отсутствий | администратор
Создание собрания | Компания > Собрание и планёрки | сотрудник
Учет рабочего времени и выполненных задач | Любая страница портала, инструмент Рабочий день | сотрудник
Просмотр личных данных учета | Компания > Рабочее время | сотрудник
Просмотр личных данных учета и данных подразделения | Компания > Рабочее время | руководитель подразделения
Изменение данных и подтверждение нарушений | Компания > Рабочее время | руководитель подразделения
Настройка параметров учета для всей организации | Компания > Рабочее время | администратор
Настройка параметров учета для конкретного подразделения | Компания > Рабочее время | руководитель подразделения
Настройка параметров учета для отдельного сотрудника | Компания > Рабочее время | администратор
Настройка параметров отчетности | Компания > Рабочие отчеты | руководитель подразделения для своих сотрудников
Настройка и создание Универсальных списков | Компания > Списки | администратор
Настройки портала | Компания > Настройки портала | администратор


Сотрудники
314 / 401

С помощью этой страницы можно легко найти нужного сотрудника. Функционал страницы зависит от уровня прав доступа.

  • Сотрудники
    • Поиск по алфавиту
    • Поиск сотрудника
  • Экспорт в Excel
  • Синхронизация с Outlook
  • Синхронизировать CardDAV

Сотрудники

Видеоролик "Сотрудники"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

Перейдя в раздел Сотрудники (Компания > Сотрудники), на открывшейся странице вы увидите перечень сотрудников компании, расположенный в алфавитном порядке:

С помощью кнопок можно отфильтровать сотрудников: сотрудников компании и экстранета, уволенных и приглашенных.

В строке каждого сотрудника выводятся индикатор присутствия сотрудника на портале, индикатор администратора, индикатор статуса руководителя, кнопка быстрых команд.

Поиск по алфавиту

Видеоролик "Поиск по алфавиту"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

Возможен поиск сотрудников по алфавиту. Для этого предназначена Алфавитная строка:

Если выбрать букву в строке, то будут отображены только те сотрудники, фамилии которых начинаются с выбранной буквы.

Примечание: Чтобы сбросить фильтр по алфавиту, необходимо выбрать в фильтре А-Я.

Поиск сотрудника

Для поиска сотрудника на любой странице портала используйте общую панель поиска:

Экспорт в Excel

Видеоролик "Экспорт в Excel"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

Результаты поиска можно экспортировать в файл MS Exсel с помощью Экспортировать в Excel в меню Ещё.

После клика по ссылке появится диалоговое окно загрузки файла:

При нажатии кнопки Открыть будет запущен MS Excel и в нем показаны результаты поиска в соответствующем формате. Если вы хотите сохранить результаты в формате .xls на локальном носителе, нажмите Сохранить, и выберите подходящее место для сохранения файла.

Синхронизация с Outlook

Видеоролик "Синхронизация с Outlook"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

Также вы можете выполнить экспорт сотрудников в MS Outlook с помощью Синхронизировать с Outlook в меню Ещё. Далее пройдите простой и понятный мастер из нескольких шагов.

Внимание! Для полноценной интеграции Битрикс24 с Outlook требуется версия Outlook 2007 и выше.

В результате экспортированный список в MS Outlook будет иметь следующий вид:

Нажмите на рисунок, чтобы увеличить

Синхронизировать CardDAV

Видеоролик "Синхронизировать CardDAV"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

Пройдя по ссылке Синхронизировать CardDAV в меню Ещё, вам откроется окно следующего вида:

На ней представлена статическая информация о том, как с помощью модуля DAV синхронизировать календари и контакты сайта с любыми программами и устройствами, поддерживающими протоколы CalDAV и CardDAV. Эти протоколы поддерживают, например, мобильные устройства iPhone и iPad. Так же поддержка протоколов присутствует в программах Mozilla Sunbird, eM Client и некоторых других.


Структура компании
315 / 401
  • Просмотр структуры компании
  • Редактирование структуры компании

Просмотр структуры компании

Видеоролик "Просмотр структуры компании"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

На данной странице дано графическое представление структурной организации компании:

Нажмите на рисунок, чтобы увеличить

Каждый прямоугольник обозначает одну структурную единицу иерархии компании:

Помимо названия, в нем указано:

  • 1 - имя руководителя данной структурной единицы;
  • 2 - иконки сотрудников данной структурной единицы;
  • 3 - ссылка с количеством на полный список сотрудников данной структурной единицы;

По клику на ссылку с именем руководителя (1) будет отображена страница профайла руководителя.

При наведении стрелки мыши на иконку сотрудника (2) отобразится тултип с подробной информацией о нем:

При клике по ссылке с количеством сотрудников (3) откроется список всех сотрудников отдела:

У некоторых прямоугольников в нижней части присутствует ссылка, указывающая на то, что в данном случае есть еще и вложенная структура:

Посмотреть вложенные подразделения можно, щелкнув левой кнопкой мыши по этой ссылке:

Нажмите на рисунок, чтобы увеличить

По клику на ссылку с названием отдела будет отображен список сотрудников отдела, руководитель и подразделения, входящие в состав отдела:

Редактирование структуры компании

Видеоролик "Редактирование структуры компании"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

Внимание: Редактирование визуальной структуры компании может осуществлять сотрудник, обладающий правами администратора сервиса.

Тогда вверху визуальной структуры компании будет кнопка Добавить подразделение, при нажатии на которую появится диалог создания нового подразделения:

Указав название, вышестоящее подразделение и руководителя, после нажатия кнопки Добавить новое подразделение появится в общей структуре компании.

При наведении на любой отдел в структуре компании появятся кнопки управления:

  • Редактировать подразделение (диалог редактирования аналогичен созданию нового подразделения, описанного выше);
  • Добавить дочернее подразделение (диалог добавления аналогичен созданию нового подразделения, описанного выше);
  • Удалить подразделение.

Также структуру компании на портале можно редактировать простым перетаскиванием элементов структуры компании:

  • варианты добавления\перевода сотрудников, назначение руководителя:

  • варианты добавления отделов\подотделов:

Изменения структуры сопровождаются информационными сообщениями в левом верхнем углу страницы. Если назначение произведено ошибочно, его можно отменить:

Примечание: Вносимые изменения могут не сразу отображаться для обычных пользователей из-за кеширования данных.

Внимание: Если необходимо, чтобы один сотрудник числился в нескольких подразделениях компании, то это можно сделать несколькими способами:
  • в профиле сотрудника нажать Редактировать профиль и внести изменения в поле Подразделения с помощью множественного выбора (Ctrl + клик или Cmd + клик для пользователей MacOS);
  • в разделе Структура компании, удерживая клавишу Shift, перенести сотрудника в нужный отдел или подразделение;
Эти действия может осуществлять сотрудник с правами Руководитель и выше.


Универсальные списки
316 / 401

Универсальные списки - инструмент для удобного хранения и работы с любой структурированной информацией.

Инструмент доступен только для тарифного плана Компания.

Возможности инструмента:

  • конструирование произвольных хранилищ объектов;
  • фильтрация и сортировка данных, карточка и списки с настройкой колонок и полей, групповое редактирование, права доступа и т.п;
  • возможна любая иерархия хранения объектов;
  • как варианты применения: FAQ, справочники и базы знаний, списки контрагентов, структурированные архивы, библиотеки, файловые хранилища и другое.

Универсальные списки доступны для всех пользователей портала, если они расположены в разделе Компания, и только для участников рабочей группы, если они расположены в какой-то конкретной рабочей группе.

Внимание! Создавать списки могут только пользователи с правами администратора. Доступ к тем или иным спискам определяется настройками списков, заданными администратором.

В рамках Рабочих групп списки создавать могут только владельцы групп.


Создание списка
317 / 401

Для создания списка воспользуйтесь кнопкой [image] на контекстной панели страницы Списки. Откроется форма создания нового списка:

Примечание: Доступна возможность копирования уже существующего списка. Для копирования нужно перейти в настройки нужного списка, и воспользоваться командой Копировать список. Новый список будет иметь название старого с добавлением: (Копия).

Заполните поля закладок формы создания списка:

Закладка Настройки

  • Название списка - обязательное поле, введите название списка, как список должен быть виден для сотрудников компании.
  • Сортировка - введите число, определяющее порядок создаваемого списка в общем порядке всех списков. Чем выше число, тем ниже в общем порядке будет создаваемый список.
  • Картинка с помощью кнопки Обзор можно задать картинку, соответствующую списку. Картинка автоматически будет изменена в размере под дизайн сайта без искажения пропорций сторон. Если не будет использована собственная картинка, то будет установлена картинка по умолчанию из дистрибутива программы.
  • Включить поддержку бизнес-процессов - если в работе создаваемого списка планируется использование стандартных или собственных бизнес-процессов, то установка этого флажка необходима.

Закладка Подписи

На закладке можно задать название элементов и разделов создаваемого списка, чтобы облегчить сотрудникам работу. Например, если создается список Поставщики, то логично будет заменить слово элемент на поставщик, а слово раздел, на группа поставщиков, и так далее.

Закладка Доступ

Внимание! Если группа пользователей не будет обладать соответствующими правами на доступ к списку, то они не увидят соответственно и сам список на странице Списки.

Закладка Доступ позволяет настроить права доступа к элементам и разделам списка по умолчанию. Эти права потом можно перезадать в настройках доступа к каждому конкретному разделу или элементу.

С помощью ссылки Добавить выберите нужную группу или конкретного пользователя, для которых хотите поменять права доступа и установите нужные права.

  • Нет доступа - создаваемый список даже не будет виден.
  • Чтение - даёт возможность только просматривать список.
  • Просмотр в панели - просмотр элементов списка в административной части. (Доступно в Битрикс24 в коробке.)
  • Добавление - можно просматривать список и добавлять в него элементы.
  • Добавление в панели - добавление элементов списка в административной части. (Доступно в Битрикс24 в коробке.)
  • Изменение - доступен не только просмотр и добавление элементов в список, но и изменение состава списка.
  • Изменение с ограничениями - допускается не только изменять список, но и запускать бизнес-процессы по элементам списка.
  • Полный доступ - устанавливается полный уровень прав доступа к списку.

Итог: Для того чтобы пользователи смогли просматривать список, достаточно указать право на чтение в настройках списка . Таким образом, задавая права на доступ можно ограничить доступ на чтение/изменение различных списков для разных групп пользователей.

Нажмите Сохранить, список создастся и можно переходить к его настройкам.


Пример настройки Универсального списка
318 / 401

Внимание! Интерфейс сервиса в видеороликах и на рисунках учебного курса может отличаться по дизайну. Функционал сервиса при этом не меняется.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Пример настройки универсального списка

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Изменение параметров Универсального списка позволяет настроить конкретный список под решаемые задачи с помощью добавления нужных полей, которые будут отображаться в форме создания элементов списка.

Поля списка - поля, которые будут отображаться в форме создания/редактирования элемента списка. По умолчанию при создании списка автоматически создается только одно поле Название и форма создания элемента списка выглядит так:

Например, если создается список Поставщиков продукции для вашей компании, то в Универсальном списке Поставщики сотрудникам нужно будет заполнять определенный список полей. Например: форма организации, адрес, реквизиты, виды поставляемой продукции и другие. Если создается список комплектующих для определенного изделия, то нужен другой список полей. Например: количество комплектующих, цена, срок службы и так далее.

Так как создатели Битрикс24 заранее не могут знать какие поля вам потребуются, то при создании Универсального списка задается только одно поле: Название. Остальные поля нужно создавать самостоятельно.

Создание полей

Изменение параметров универсального списка доступно по кнопке [image] на контекстной панели на странице редактируемого списка. При нажатии на эту кнопку откроется форма редактирования списка, полностью аналогичная форме создания. Разница от формы создания списка будет только в том, что появится контекстная панель с дополнительными кнопками команд:

Для задания свойств универсального списка нужно воспользоваться кнопкой Поля списка. По этой кнопке откроется список полей, относящихся к универсальному списку. Напомним, что по умолчанию там только одно поле: Название.

Добавим в эту форму новое поле. Например, добавим поле Организационная форма, в которой будет задаваться тип компании поставщика: ООО, ЗАО и так далее.

Для этого:

  • Нажмите кнопку Добавить поле, откроется форма добавления поля:

    Внимание! При выборе разных типов полей в зависимости от выбранного поля могут появляться или пропадать дополнительные поля и вкладки.
  • Заполните поля формы:
    • Название - название поля, под которым оно будет видно в общем списке полей. Введите фразу организационная форма.

    • Обязательное - должно ли быть создаваемое поле обязательным для заполнения. Поставьте флажок в этом поле.
    • Множественное - должно ли создаваемое поле иметь несколько полей для заполнения. Здесь флажок не ставим, одна и та же фирма не может быть и ООО и ЗАО.
    • Тип - выбор типа поля. Выберите тип поля Список, форма перезагрузится, пропадет поле Значение по умолчанию, но появится вкладка Список.

      Внимание! После создания поля изменить его тип невозможно.

    • Перейдите на эту вкладку:

    • Заполните поля списочного свойства.

      Примечание: Если свойств очень много, а список этих свойств достаточно большой, то с помощью ссылки Импортировать списком откройте дополнительное окно, в которое можно вставить заготовленный заранее список свойств.

    • Нажмите кнопку Применить, свойства сохранятся.
    • С помощью ссылки Значение по умолчанию вызовите список добавленных свойств и установите то, свойство, которое будет использоваться чаще всего. Это свойство будет по умолчанию отображаться в этом поле.

      Примечание: Значение по умолчанию можно выставить только в случае, если создаваемое поле будет обязательным для заполнения.

    • Сортировка - порядок расположения создаваемого поля в общем списке полей. Чем выше число, тем ниже расположено будет поле. Введите любое число, в рамках примера это не важно.
    • Показывать ... - эти поля включают/отключают показ создаваемого поля в форме создания или редактирования. Поля обязательные для заполнения нельзя отключать от показа.
    • Только для чтения ... - эти поля включают/отключают показ создаваемого поля в форме создания или редактирования в режиме "для чтения" то есть, без возможности изменения.
    • Показать поле при формировании ссылки на элемент списка. - если планируется использовать ссылки на элементы в переписке, то рекомендуется использовать это поле для тех полей, которые должны отображаться в богатых ссылках.
    • Нажмите кнопку Сохранить, система вернется к списку полей.
Примечание: Если теперь открыть форму для создания элемента, то мы увидим, что там уже есть не одно, а два поля:

Создайте аналогичным способом поля для нужного вам списка.

Значения типов

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Типы полей универсального списка

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Суть значений типов понятны из их названия, однако ниже приведены значения типов, которые могут вызвать затруднения при использовании:

  • Строка - значение свойства задается в виде текстовой строки;
  • Число - значение свойства задается в виде числа;
  • Список - значение свойства выбирается из списка;
  • Файл - в качестве значения свойства используется загрузка файла с внешних источников;
  • Файл (Диск) - в качестве значения свойства используется выбор файла с Моего Диска или Общего диска;
  • Привязка к разделам - с помощью данного свойства можно задать связь между элементом данного инфоблока и разделами другого информационного блока;
  • Привязка к элементам - задание связи между элементами информационных блоков «поштучно»;
  • HTML/текст - значение свойства задается в виде текста с HTML-тегами;
  • Счетчик - аналог autoincrement для БД. При добавлении элемента инфоблока значение будет больше на единицу, чем последнее. Стартовое значение задается произвольно. Можно использовать для журналов учета входящих документов и т.п., где должна быть непрерывная нумерация документов.
  • Дата/Время - значение свойства задается в виде даты/времени;
  • Видео - задается связь между элементом списка и медиафайлом;
  • Привязка к элементам в виде списка - задание связи между элементами списком.
  • Привязка к элементам CRM - задание связи между элементами списка и элементами CRM.
  • Привязка к Яндекс.Карте - задание связи между элементами списка и местоположением на Яндекс карте.

Список ссылок по теме:

  • Использование Универсальных списков в примере KPI для отдела организации
  • Использование Универсальных списков в системах учёта.


Просмотр списка
319 / 401
  • Просмотр списка
  • Просмотр элемента списка
  • Настройки отображения списка
  • Экспорт в Excel
    •

    Просмотр списка

    Для просмотра содержимого списка используйте иконки с названием списка, расположенные на странице Списки или ссылки, расположенные в правом меню.

    В результате на странице будет отображен непосредственно сам список, панель фильтра (Поиск) и основные элементы управления:

    Примечание: Количество и состав кнопок на контекстной панели зависит от прав сотрудника на конкретный список. Если сотрудник обладает правами на изменение списка, то ему будет доступна кнопка <Добавить_элемент>. (Название может отличаться, в зависимости от настроек самого списка, на иллюстрации выше эта кнопка имеет название Добавить клиента.) Эта кнопка позволяет создать новый элемент списка.

    Просмотр элемента списка

    Для просмотра/изменения (в зависимости от прав доступа) информации об элементе списка используйте меню действий или дважды кликните по строке с желаемым элементом в списке, после чего откроется следующая форма:

    Примечание: Если вы обладаете правами на изменение списка, то форма будет иметь другой вид. Появятся дополнительные кнопки:

    Кнопка <название_списка> (В нашем примере эта кнопка называется Клиенты) на контекстной панели позволяет вернуться к просмотру списка.

    Элементы управления [image] позволяют развернуть все вкладки на одну страницу и настроить форму соответственно.

    Настройки отображения списка

    Для индивидуальных настроек отображения списка используется меню настроек списка:

    где:

    • Настроить список - позволяет изменить текущее представление списка в форме Настройка представления списка:

    • Колонки списка - позволяет отобразить/скрыть желаемые колонки списка. Для этого отметьте флажком требуемые колонки и выберите пункт меню Применить:

    • <название_представления> - выбор заранее созданного представления, которое будет определять вид списка.

    • Представления - позволяет создавать/редактировать существующие представления в форме Управление представлениями:

      Создание и редактирование представлений производится в форме Настройка представления списка, описанной выше.

    • Цветовая схема - позволяет изменить цветовую схему оформления списка.

      Примечание: Опция доступна для Битрикс24 только в шаблоне Lite.

    Экспорт в Excel

    Кнопка Экспорт в Excel создаст файл в формате xls (Microsoft Excel 97-2003) и предложит загрузить его на компьютер. В файле будут отображены только данные тех колонок, на которые настроено представление списка.


Наполнение списков содержанием
320 / 401
  • Создание элемента списка
  • Создание раздела списка
    •

    Для сортировки содержимого списка по желаемой колонке кликните по ее заголовку:

    Стрелка в заголовке будет указывать направление сортировки.

    Для выполнения основных операций над элементом списка используется меню действий:

    Примечание: Если вы обладаете правами на изменение списка, то меню будет иметь другой вид:

    Если в списке включена поддержка бизнес-процессов, то в меню будет присутствовать соответствующий пункт, позволяющий запускать Бизнес-процессы. Работа с ними аналогична работе с бизнес-процессами документов

    Создание элемента списка

    Внимание! Создавать и редактировать элементы списка могут группы сотрудников с соответствующими правами. Права задаются администратором.

    Примечание: В интерфейсе списков администратор может задать свои подписи к некоторым элементам управления. По умолчанию все элементы списка названы как Элемент, а разделы как Раздел. На скриншотах этой страницы используется такая замена элемента на клиента

    Количество и состав полей может также зависеть от настроек администратора.

    Для создания нового элемента списка воспользуйтесь кнопкой <Добавить_элемент> на контекстной панели

    После нажатия этой кнопки откроется форма создания нового элемента списка

    На закладке <Элемент> заполните поля, содержимое которых будет отображаться в строке списка

    На закладке <Раздел> укажите, если необходимо, в каком разделе будет содержаться запись списка

    Примечание: Если в списке разрешено использование бизнес-процессов, то при создании элемента списка будет доступна еще одна закладка: Бизнес-процессы.

    Создание раздела списка

    Элементы в списке можно сгруппировать по какому-либо признаку. Для этого нужно создать раздел и указать в свойствах элемента, с каким разделом он будет сопоставлен.

    Внимание! Создавать и редактировать разделы списка могут группы сотрудников с соответствующими правами. Права задаются администратором.

    Для создания нового раздела в списке воспользуйтесь кнопкой <Управление_разделами> на контекстной панели. После этого будет отображен список всех разделов для данного списка, если они существуют.

    Для создания раздела используется кнопка <Добавить_раздел>, а для изменения существующего - ссылка с названием раздела

    При создании нового раздела вам будет предложено указать его название во всплывающем окне, после чего он появится в списке разделов.

    С помощью меню действий в этом списке раздел можно Переименовать или Удалить.

    Примечание: В списке элементов для разделов отведена специальная колонка. Клик по ссылке с названием раздела приведет к просмотру отфильтрованных записей списка сопоставленных только с конкретным разделом.


Панель фильтра
321 / 401

Фильтр позволяет отобрать элементы в списке по каким-либо параметрам. По умолчанию фильтрация происходит по параметру Раздел.

Примечание: Для экономии места на экране компьютера фильтр можно свернуть.

В фильтр попадают все свойства, которые заданы при создании полей конкретного списка.

Настройка формы фильтра

Для настроек фильтра используется следующее меню:

Отметив флажком нужные поля, вы сформируете новый фильтр. Например, добавим с помощью этого меню поля Название и Руководитель. Мы получили новый фильтр. Фильтры можно сохранять, удалять. Сохранённые фильтры отображаются в виде закладок.

Внимание: Поле Раздел должно присутствовать среди параметров фильтра. Если отбор не ведется по этому полю, то его значение можно установить (любой).

Если какой-то из сохранённых фильтров активен (то есть данные отфильтрованы по нему), то закладка меняет свой цвет.

Пример создания фильтра

Создадим фильтр, включающий все поля данного списка.

  • Нажмите на закладку со знаком +, откроется окно для ввода названия нового фильтра.
  • Введите название Полный и сохраните. Создастся новая закладка и сразу же она станет активной.
  • Добавьте в закладку фильтра все поля списка.
  • Сохраните фильтр:


Бизнес-процессы в Универсальных списках
322 / 401

Бизнес процессы

Бизнес процессы в Универсальных списках могут быть типовыми либо пользовательскими. Перед использованием типовых процессов, их нужно включить и настроить. Пользователи Битрикс24 могут создать собственные Бизнес-процессы для своих Универсальных списков. (Ссылка уводит на другой курс.)

Бизнес-процессы Универсальных списков можно выполнять как на странице Избранное> Бизнес-процессы, так и при просмотре списка элементов. Есть одно отличие: при работе с бизнес процессом из просмотра списка есть возможность остановить выполнение процесса:

Бизнес-процессы в Живой ленте

Начиная с редакции Компания есть возможность добавлять в список Бизнес-процессов Живой ленты собственные Бизнес-процессы (БП). Для того, чтобы в общем списке появился ваш Бизнес-процесс нужно:

  1. Вызвать форму создания универсального списка через кнопку Создать новый на странице Компания > Процессы или на странице Компания > Списки.

    Либо воспользоваться командой Создать новый процесс в списке бизнес-процессов Живой ленты. Последний способ - рекомендуемый нами для использования.
  2. Создать и настроить новый Универсальный список:

  3. Создать необходимый Бизнес-процесс в списке:

  4. Если Бизнес-процесс создавался со страницы Компания > Списки, то необходимо с помощью кнопки [image] открыть на редактирование параметры созданного списка и по команде [image] добавить его в список Живой ленты. Кнопка видна только администратору.

    Настроить отображение БП в списке Живой ленты также можно, воспользовавшись флажком Показать в Живой ленте на странице Компания > Процессы:

    После чего Бизнес-процесс появится в списке Живой ленты.

Особенности бизнес-процессов в Живой ленте

В список процессов в Живой ленте попадают только те процессы, у которых стоит автоматический запуск При добавлении. Если шаблон настроен на ручной запуск или на запуск При изменении, то он не будет запускаться из Живой ленты, а только из списка элементов:

Если в Универсальном списке несколько бизнес-процессов с настройкой автоматического запуска При добавлении, то в списке бизнес-процессов Живой ленты отображается тот, который создан позже. Например, надо создать список с двумя БП: по одному происходит уведомление какого-либо лица о запуске процесса, а по другому процессу должны начать выполняться какие-то действия. В этом случае надо сначала создать бизнес-процесс на уведомление, а только потом - БП на действия.


Удаление списка
323 / 401

Для удаления универсального списка следует перейти в режим редактирования списка, кликнув на списке. Затем на контекстной панели на странице редактируемого списка нажать кнопку [image].

При нажатии на эту кнопку откроется форма Настройка списка, где следует нажать кнопку Удалить список

и подтвердить удаление во всплывающем окне:

Внимание! Удалять списки могут группы сотрудников с соответствующими правами. Права задаются администратором.


Как отслеживать изменение элементов
324 / 401

Достаточно частая задача - отследить изменение элемента универсального списка. Сделать это можно с помощью несложного бизнес-процесса. (Если создание шаблона Бизнес процесса вызывает затруднения, изучите главу Бизнес-процессы.)

Допустим, что нужно решить следующую бизнес-задачу. Имеется Универсальный список Поставщики со списком ваших поставщиков. В этом списке указываются товары, которые вы можете получить от них. Список Поставщики ведёт один сотрудник, продажи из этого списка осуществляют другие сотрудники. Необходимо своевременно уведомлять тех кто продаёт об изменениях товаров у компаний из этого Универсального списка. Решение этой задачи:

  1. Перейдите в список, в котором нужно отслеживать изменения.
  2. Нажмите на кнопку Бизнес-процессы на контекстной панели вашего списка работ. Откроется страница со списком шаблонов бизнес-процессов. Вам не нужны типовые шаблоны, вам нужно создать свой. Это будет довольно простой шаблон последовательного бизнес-процесса.
  3. Нажмите на кнопку Создать последовательный бизнес-процесс, откроется Форма настроек параметров шаблона:

    Настройка параметров шаблона БП

    Заполните поля нужным вам образом, единственное обязательное условие: шаблон должен запускаться на изменение, а не на создание элемента. Сохраните шаблон, откроется визуальный редактор бизнес-процессов.
  4. Добавьте в шаблон БП действие Условие и в одну из веток добавьте нужный вам вид уведомления. В примере используется Сообщение соц.сети, вы можете выбрать любой другой вид уведомлений:

    Добавленные действия в шаблон БП

  5. Настройте действия:

    Настройка Условия
    Настройка действия Условие заключается в придании названиям понятный смысл и указании для действия параметров, по каким оно будет работать. Примеры названий можно посмотреть из иллюстрации, а вот настройку параметров отметим отдельно.

    Поскольку шаблон запускается на изменение списка, нам нужно исключить вариант когда уведомление продажникам будет уходит при изменении других полей, кроме поля Товары.

    В действии Условие есть две ветки. По одной их них бизнес процесс должен пойти если изменение коснулось поля Товар. Под другой - если изменялось какое-то другое поле. Настройка обоих веток производится с помощью формы Вставка значения одинакова до задания Условия: в настройке ветки выберите тип условия Поле документа. В появившемся списке полей выберите поле Товар.

    Для ветки Не изменился в поле Условие выберите значение равно, в появившемся поле опять укажем значение Товар. (То есть мы сказали программе если поле значений каким было таким и осталось, то идём по ветке Не изменился.)

    Для ветки Изменился товар в поле Условие выберем значение было изменено. (То есть мы сказали программе если поле значений изменилось, то идём по ветке Изменился товар.)

    Сохраните настройку ветки.

    Настройка уведомления

    С помощью формы Вставка значения заполните поля. Это не должно быть сложным, суть полей ясна из названия.

  6. В конечном счёте вы должны получить такой шаблон бизнес-процесса:

Вам осталось модифировать предложенный БП под свои задачи.


Приложения Битрикс24
325 / 401

Используя Приложения для Битрикс24, вы можете легко добавить функционал для своего портала Битрикс24. Установка новых приложений происходит очень быстро и не требует дополнительных знаний или навыков.

Если вы являетесь партнером компании "1С-Битрикс", то вы можете загружать свои приложения в каталог. Для разработки собственных приложений следует ознакомится с информацией, доступной в курсе Разработчик Bitrix Framework и в документации по REST_API.


Установка и обновление приложений
326 / 401
Внимание! Если приложение разработано не компанией Битрикс, то по поводу качества работы приложения обращайтесь к разработчику приложения.

Адрес для обращений указывается на закладке Поддержка:

Выполнить установку приложений, доступных в пункте меню Приложения, может только администратор вашего портала Битрикс24.

На странице каталога приложений (Приложения > Все приложения) представлено следующее:

  • список доступных в Все приложения приложений (список просматривается по категориям);
  • все когда-либо установленные (и платные, и бесплатные, даже уже удаленные) вами приложения - ссылка Покупки;
  • обновления для установленных у вас приложений - ссылка Обновления.

Установка приложений

Для установки приложения перейдите на страницу с его детальной информацией:

Нажмите кнопку Установить. В случае необходимости система запросит разрешения на выполнение некоторых действий. Если вы разрешаете выполнение действий, то нажмите еще раз кнопку Установить. Система выполнит установку приложения. Установленное приложение отобразится в меню портала:

Использование платных приложений из чужих доменных зон
Платные приложения могут продаваться только в тех доменных зонах, в которых работают создатели этих приложений. То есть, если разработчик приложения - российская компания, то приложения, разработанные для русскоязычного Маркетплейса не показываются и не продаются в других зонах Битрикс24 (.ua, .kz, .com и так далее).

Это связано с особенностями финансовых систем разных стран.

Тем не менее, если клиент обращается напрямую к автору приложения, то автор приложения вполне может выписать такому клиенту, например из Казахстана, купон. Активировать купон можно независимо от языковой зоны и тогда приложение появится внутри портала на странице Приложения > Все приложения > Покупки. Оттуда его и можно будет поставить.

Обновление приложений

Для проверки наличия обновлений и их установки на имеющиеся у вас приложения следует воспользоваться ссылкой Обновления, расположенной на странице Приложения > Мои приложения.


Удаление приложения
327 / 401

Удалять установленные ранее приложения может только администратор сервиса Битрикс24. Для этого следует на странице каталога приложений (Приложения > Все приложения) нажать ссылку Покупки. Отобразится список всех когда-либо установленных и даже удаленных вами приложений:

Для всех установленных на Битрикс24 приложений доступна кнопка Удалить. Если же приложения были установлены, а затем удалены, то в их карточках будет отображаться кнопка Установить (из списка покупок приложения не удаляются).

Для удаления приложения нажмите кнопку Удалить, расположенную в его карточке, и подтвердите свое решение во всплывающем окне:

В результате приложение будет удалено из портала, а на странице покупок в карточке этого приложения будет отображаться кнопка Установить.


Вебхуки
328 / 401

WebHooks - упрощенный вариант rest-событий и rest-команд, без написания приложения.

В Битрикс24 существует REST API, который позволяет добавлять функционал в облачный Битрикс24, а также создавать всевозможные интеграции с внешними системами.

Для быстрой связи конкретного портала Битрикс24 с конкретной внутренней системой, отдельно взятой формой обратной связи или для трансляции в Живую ленту отчетов из своей складской системы удобнее использовать Вебхуки.

На странице Приложения > Вебхуки можно создать входящие и исходящие вебхуки.

Создание Входящего вебхука

  1. В выпадающем меню Добавить вебхук выберите Входящий вебхук.
  2. В открывшейся форме заполните поля:
    • Название и Описание - произвольные данные.
    • Права доступа - укажите, к каким модулям вебхук должен иметь доступ. Доступен множественный выбор.
  3. После сохранения появится код для авторизации вебхука:

    Внимание! Данный код является конфиденциальной информацией. Его необходимо держать в секрете.
  4. Вместе с кодом будет представлен образец URL, который нужно использовать при отправке данных из сторонней системы в Битрикс24:
    https://********.bitrix24.ru/rest/1/83te1pjdphsa9u15/profile/
    где:
    • ******** - имя вашего портала;
    • /rest/ - указание системе на то, что данный адрес относится в вебхукам;
    • /1/ - идентификатор пользователя, создавшего вебхук. Под правами этого пользователя будет работать этот вебхук.
    • /83te1pjdphsa9u15/ - секретный код;
    • /profile/ - метод REST, который вы хотите выполнить, обращаясь к вебхуку. Разработчик должен сам подобрать метод из REST API в зависимости от целей создания вебхука.
  5. Обратиться из сторонней системы по указанному адресу на Битрикс24.

    Рассмотрим пример такого обращения с задачей создать лид из формы. Надо сформировать URL в переменной $queryUrl, сформировать параметры для создания лида в переменной $queryData и после подготовительных шагов как раз и обратиться к Битрикс24 при помощи функции curl_exec. Полученный в виде JSON результат обработан:

    Пример кода обращения к Битрикс24

    <?
/**
 * Write data to log file.
 *
 * @param mixed $data
 * @param string $title
 *
 * @return bool
 */
function writeToLog($data, $title = '') {
 $log = "\n------------------------\n";
 $log .= date("Y.m.d G:i:s") . "\n";
 $log .= (strlen($title) > 0 ? $title : 'DEBUG') . "\n";
 $log .= print_r($data, 1);
 $log .= "\n------------------------\n";
 file_put_contents(getcwd() . '/hook.log', $log, FILE_APPEND);
 return true;
}

$defaults = array('first_name' => '', 'last_name' => '', 'phone' => '', 'email' => '');

if (array_key_exists('saved', $_REQUEST)) {
 $defaults = $_REQUEST;
 writeToLog($_REQUEST, 'webform');

 $queryUrl = 'https://restapi.bitrix24.ru/rest/1/31uhq2q855fk1foj/crm.lead.add.json';
 $queryData = http_build_query(array(
 'fields' => array(
 "TITLE" => $_REQUEST['first_name'].' '.$_REQUEST['last_name'],
 "NAME" => $_REQUEST['first_name'],
 "LAST_NAME" => $_REQUEST['last_name'],
 "STATUS_ID" => "NEW",
 "OPENED" => "Y",
 "ASSIGNED_BY_ID" => 1,
 "PHONE" => array(array("VALUE" => $_REQUEST['phone'], "VALUE_TYPE" => "WORK" )),
 "EMAIL" => array(array("VALUE" => $_REQUEST['email'], "VALUE_TYPE" => "WORK" )),
 ),
 'params' => array("REGISTER_SONET_EVENT" => "Y")
 ));

 $curl = curl_init();
 curl_setopt_array($curl, array(
 CURLOPT_SSL_VERIFYPEER => 0,
 CURLOPT_POST => 1,
 CURLOPT_HEADER => 0,
 CURLOPT_RETURNTRANSFER => 1,
 CURLOPT_URL => $queryUrl,
 CURLOPT_POSTFIELDS => $queryData,
 ));

 $result = curl_exec($curl);
 curl_close($curl);

 $result = json_decode($result, 1);
 writeToLog($result, 'webform result');

 if (array_key_exists('error', $result)) echo "Ошибка при сохранении лида: ".$result['error_description']."
    ";
}

?>
<fo rm method="post" action="">
    Имя: <input type="text" name="first_name" size="15" value="<?=$defaults['first_name']?>"><br/>
    Фамилия: <input type="text" name="last_name" size="15" value="<?=$defaults['last_name']?>"><br/>
    Телефон: <input type="phone" name="phone" value="<?=$defaults['phone']?>"<

    E-mail: <input type="email" name="email" value="<?=$defaults['email']?>"><br/>
    <input type="hidden" name="saved" value="yes">
    <input type="submit" value="Отправить">
</form>

    Внимание! Пример условный, в режиме copy/paste использовать не рекомендуется.

Создание исходящего вебхука

  1. В выпадающем меню Добавить вебхук выберите Исходящий вебхук.
  2. В открывшейся форме заполните поля:
    • Адрес обработчика - страница на стороннем ресурсе, куда будет обращаться вебхук.
    • Название и Описание - произвольные данные.
    • Тип события - нужно указать событие, на которое будет инициализироваться вебхук.
  3. После сохранения вебхука будет выведен Код авторизации в виде строки из случайных знаков. Этот код позволит внутри обработчика проверить, действительно ли обработчик вызван вашим Битрикс24.
  4. На странице обработчика размещаем код:

    Пример кода обработчика для события ONCRMDEALUPDATE

    <?

print_r($_REQUEST);
writeToLog($_REQUEST, 'incoming');

/**
 * Write data to log file.
 *
 * @param mixed $data
 * @param string $title
 *
 * @return bool
 */
function writeToLog($data, $title = '') {
 $log = "\n------------------------\n";
 $log .= date("Y.m.d G:i:s") . "\n";
 $log .= (strlen($title) > 0 ? $title : 'DEBUG') . "\n";
 $log .= print_r($data, 1);
 $log .= "\n------------------------\n";
 file_put_contents(getcwd() . '/hook.log', $log, FILE_APPEND);
 return true;
}

    Для проверки откройте любую сделку на редактирование и сохраните изменения, в логе отобразится примерно такая история:

    2017.01.17 12:58:29
incoming
Array
(
    [event] => ONCRMDEALUPDATE
    [data] => Array
        (
            [FIELDS] => Array
                (
                    [ID] => 662
                )

        )

    [ts] => ххх
    [auth] => Array
        (
            [domain] => ххх.bitrix24.ru
            [client_endpoint] => https://ххх.bitrix24.ru/rest/
            [server_endpoint] => https://oauth.bitrix.info/rest/
            [member_id] => ххх
            [application_token] => ххх
        )

)


Время и отчёты
329 / 401

В Битрикс24 есть ряд инструментов, направленных на учёт деятельности, связанной со временем. Эти инструменты доступны в разделе Время и отчёты.


График отсутствий
330 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
График отсутствий

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Выяснение кто есть на месте и когда будет – одна из постоянных задач, которые приходится решать любому сотруднику. Для таких задач в корпоративном портале используется инструмент Календарь. Для контроля за отсутствием сотрудников создана специальная страница, которая так и называется График отсутствий.

На этой странице автоматически выводится вся информация об отсутствиях работников на рабочем месте. Отсутствия можно проконтролировать, рассортировав все данные по данным отдела кадров (это, как правило, отпуска и отгулы) и по личным календарям (как правило, командировки, работа вне офиса и «отпросились»).

  • Представление отсутствий
  • Добавление отсутствия

Отсутствия сотрудников компании на рабочем месте по каким-либо причинам фиксируются в Графике отсутствий.

Представление отсутствий

Можно выбрать одно из трех представлений отсутствия сотрудников: День, Неделя и Месяц. То представление, которое выбрано в данный момент, выделено более темным цветом.

Чтобы не загромождать сетку таблицы при просмотре отсутствий за месяц, в ней не отображаются отсутствия длительностью менее суток.

При наведении курсора мыши на отсутствие какого-либо сотрудника, отображается краткая информация об отсутствии:

По ссылке с именем сотрудника осуществляется переход на его личную страницу.

Дату, относительно которой выводится график отсутствий, можно выставить, нажав кнопку [image] на контекстной панели, и выбрав нужную дату в выпадающем календаре:

Для перехода к другому дню/месяцу/году используйте кнопки навигации, расположенные рядом с текущей датой:

Причины отсутствий сотрудников могут быть разными. В «Битрикс24» причины называют типами отсутствий.

Для каждого типа отсутствия используется свое цветовое обозначение. C помощью кнопки Типы отсутствий, расположенной на контекстной панели, вы можете установить фильтр по типам отсутствий, сняв галочки с тех типов отсутствий, которые вас не интересуют:

По умолчанию график строится по отсутствующим сотрудникам всех подразделений компании. При необходимости вы можете просматривать график только по некоторому подразделению, в этом случае необходимо указать его с помощью выпадающего списка поля Подразделение на контекстной панели:

Добавление отсутствия

Добавить собственное отсутствие в график сотрудник может посредством личного календаря. Подробней о работе с личным календарем смотрите в разделе Календарь.

Если пользователь портала обладает правами не ниже Администратор либо входит в группу Отдел кадров и/или Администрация портала (это справедливо только для коробочной версии сервиса «Битрикс24»), то ему будет доступна кнопка:

После клика по кнопке Добавить отсутствие откроется окно:

Заполните следующие поля:

  • Чтобы выбрать соответствующего сотрудника, нажмите на ссылку Выбрать из структуры, появится окно следующего вида:

    Найти нужного сотрудника можно с помощью вкладок Последние, Выбрать из структуры или через Поиск.

  • Выберите Тип отсутствия, нажав на пиктограмму [image] и выбрав значение в выпадающем списке.
  • Обязательно заполните поле Причина отсутствия.
  • Укажите Период отсутствия, заполнив поля Начало и Окончание с помощью календарей.

Чтобы добавить отсутствие в график, нажмите кнопку Добавить.

Примечание: дополнительно отсутствия могут добавляться в график из бизнес-процессов на отпуск. Отредактировать или удалить такое отсутствие может администратор сервиса «Битрикс24» (а также пользователь группы Отдел кадров и/или Администрация портала в случае коробочной версии сервиса).


Отчёт по рабочему времени
331 / 401

Страница Отчет по рабочему времени (Время и отчёты > Рабочее время) позволяет просмотреть все данные об использовании рабочего времени.

Внимание! При необходимости учёт рабочего времени можно отключить в настройках.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Отчет по рабочему времени

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Обычный сотрудник видит данные только по своим рабочим дням. Руководитель может видеть данные по своему отделу, и может изменять данные у своих подчиненных и свои собственные.

Возможности сортировки:

  • Статистика - отображение колонок статистики;
  • Начало и конец рабочего дня - в строке будут отображаться начало и конец рабочего дня сотрудника;
  • Выбор отдела - возможность выбора в рамках структуры компании нужного отдела для просмотра.
  • Показ только списка сотрудников, либо с данными учета.

Те дни, в которые произошли неподтвержденные нарушения установленного порядка рабочего дня отмечены специальным значком: . Если нарушение подтверждено руководителем, то выводится значок: . Общий процент нарушений выводится в специальной колонке таблицы.

Примечание: Рабочие дни сотрудников, нуждающиеся в подтверждении отображаются в Живой ленте.

Колонка Процент замечаний - отношение рабочих дней с нарушениями к общему количеству рабочих дней. В колонках Рабочих дней, Рабочих часов и Процент замечаний не учитываются неподтвержденные дни.

Учет нарушений

При подсчете нарушений во всех суммах и процентах отчета участвуют только завершённые подтверждённые рабочие дни. Красным числом в скобках выводится кол-во неподтвержденных нарушений. Процент нарушений считается как отношение количества рабочих дней с нарушениями к общему количеству рабочих дней.

Нарушением считается запись о рабочем дне, которая:

  • началась позже установленного для сотрудника/подразделения/всей организации максимального времени начала рабочего дня - опоздание;
  • завершилась раньше установленного для сотрудника/подразделения/всей организации минимального времени завершения рабочего дня - ранний уход;
  • завершилась раньше чем выработана установленный для сотрудника/подразделения/всей организации минимальная продолжительность рабочего дня с учетом перерывов - невыработка.
Внимание! Нарушение - это отклонение от настроек времени рабочего дня, заданных администратором, а не нарушения трудовой дисциплины. Является ли показываемое системой нарушение рабочего времени нарушением трудовой дисциплины нужно решать в каждом отдельном случае.

Например: Сотрудник уезжая в банк в 16-00 закрыл рабочий день этим часом. В банке он пробыл до 18-00, выполняя рабочие обязанности. Система покажет нарушение рабочего времени, которое не является нарушением трудовой дисциплины.

Просмотр статистики дня

Для просмотра статистики нужно кликнуть указателем мыши на ячейке нужного дня сотрудника. Откроется форма просмотра:

Если требуется подтверждение нарушений, то у руководителя подразделения появится кнопка [image]. Руководитель может изменить время прихода, ухода и отработанного времени, добавить комментарий к отчету и с помощью этой кнопки внести изменения. Изменения возможны только для тех дней, когда сотрудник начинал рабочий день.

Если работник находится вне офиса, то есть возможность проверить по какому IP он заходил на портал и с какого часового пояса:

В разделе Задачи выводится список задач, поставленных на день и выполненных в течение дня с возможностью перехода к задаче кликом по ее названию.


Учёт рабочего времени
332 / 401

Инструмент Учет рабочего времени предназначен для организации контроля за количеством рабочего времени, затраченным сотрудником, и задачами, решенными им за рабочее время.

Примечание: Функционал доступен начиная с редакции Компания.

Сотрудникам с разными правами доступа доступен различный функционал инструмента. Ниже в таблице приведены возможности (Функционал), соответствующие различным группам сотрудников (Права доступа), и указано, на какой странице раздела портала можно этим функционалом воспользоваться (Страница).

Функционал | Страница | Права доступа
Учет рабочего времени и выполненных задач | Любая страница портала, инструмент Рабочий день | Сотрудник
Просмотр личных данных учета | Компания > Рабочее время | Сотрудник
Просмотр личных данных учета и данных подразделения | Компания > Рабочее время | Руководитель подразделения
Изменение данных и подтверждение нарушений | Компания > Рабочее время | Руководитель подразделения
Настройка параметров учета для всей организации | Компания > Рабочее время | Администратор системы
Настройка параметров учета для конкретного подразделения | Компания > Рабочее время | Руководитель подразделения
Настройка параметров учета для отдельного сотрудника | Компания > Рабочее время | Руководитель подразделения
Настройка параметров отчетности | Компания > Рабочие отчеты | Администратор, Руководитель подразделения для своих сотрудников

Для управления рабочим временем предусмотрены два инструмента: панель Рабочий день и страница Рабочее время. При необходимости учёт рабочего времени можно отключить в настройках Учёта рабочего времени.

Панель Рабочий день

Эта панель - способ учета рабочего времени и решаемых задач. Доступна для всех сотрудников и имеет общий для всех функционал. В обычном виде она свернута на Панель статусов:

На свернутой панели сотрудник увидит:

  • Текущее время;
  • Очередное событие (если задано);
  • Количество незакрытых задач этого дня.
  • Состояние учёта (Работаю, Перерыв, Завершён);

Полный вид инструмента и работа с ним описана в уроке Рабочий день.

Отчет по рабочему времени

Страница видна по-разному для сотрудников и для руководителей. Так же отличается и функционал.

Сотрудник видит данные только по своим рабочим дням (либо отдела - зависит от настроек, заданных администратором), изменить ничего не может.

Руководители могут видеть отчеты по рабочим дням как своих отделов, так и подотделов, - это зависит от настроек, заданных администратором. Работа руководителей по учету времени описана в уроке Отчет по рабочему времени.


Инструмент Рабочий день
333 / 401
Видеоролик "Рабочий день"

Интерактивный видеоролик (требуется выполнение действий пользователем). Продолжительность 4 минуты 16 секунд. Ролик может отставать от текущей версии. Более актуальное текстовое описание - ниже.

Ролик озвучен. Если нет возможности прослушать, то с помощью кнопки СС можно включить текстовое сопровождение.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Вся работа с учетом рабочего времени для сотрудника сосредоточена в панели Рабочий день. Эта панель не зависит от уровня прав сотрудника и для всех отображается одинаково.

Начало и завершение рабочего дня

Каждый сотрудник при начале рабочего дня должен произвести запуск учета рабочего времени. Для этого нужно развернуть панель Рабочий день и нажать на кнопку Начать рабочий день в этом случае отсчет времени пойдет по параметрам, заданным администраторам портала. Если необходимо начать рабочий день в другое время, то воспользуйтесь ссылкой Начать с другим временем. В этом случае будет указано другое рабочее время начала трудового дня. Завершение рабочего дня выполняется с помощью кнопки Завершить рабочий день либо ссылки Завершить с другим временем.

Примечание: Если рабочее время на компьютере сотрудника и на сервере отличаются друг от друга (а возможно отклонение на несколько минут или секунд в ту или иную сторону), то может возникнуть ситуация, когда учет рабочего времени начинается с отрицательного значения.

Случается, что сотрудник забывает или не смог закрыть рабочий день, в этом случае на следующий день он не сможет начать новый день, пока не закроет старый:

Примечание: Если предыдущий рабочий день так и не был закрыт, то в Отчете по рабочему времени этот день будет помечен словом истёк.

Если рабочий день начинается или закачивается с помощью ссылок Начать с другим временем и Завершить с другим временем, а так же завершается ранее не закрытый день, то кроме выбора времени нужно указать и причину изменения:

Примечание: Редактирование параметров рабочего дня возможно только руководителем или администратором.

Если необходимо остановить учет рабочего времени, например на перерыв на обед, то воспользуйтесь кнопкой Перерыв, которая появляется после нажатия на кнопку Начать рабочий день. Система начнет отсчет перерыва. Для возобновления учета рабочего дня нажмите на кнопку Продолжить.

Задачи с учетом времени

Если у сотрудника есть задачи с учётом времени, то выполняемая в данный момент задача будет выводиться в Учёте рабочего времени отдельной строкой. В этой строке отображается время уже потраченное на задачу, общее выделенное время, кнопка для завершения задачи и кнопка для постановки на паузу учёта времени.

План на день

Планирование рабочего дня выполняется с помощью задач. Задачи можно вводить вручную в поле введите текст задачи (и нажатием на "плюсик") и при помощи ссылки выбрать из списка.

При задании задачи из поля введите текст задачи создается быстрая задача, то есть без указания сроков выполнения, приоритетов и других параметров, свойственных обычной задаче. Созданная этим способом задача относится к личным задачам и не привязывается ни к какой рабочей группе.

При использовании ссылки выбрать из списка откроется окно со списком задач пользователя:

Полем Поиск можно воспользоваться для поиска нужной задачи. Если активным стоит Последние, то задачи будут выводиться в порядке их создания.

Выбранные и добавленные задачи появятся в закладке Планы на день. При клике указателем мыши на названии задачи появляется окно задачи.

События

Под списком задач на день отображаются события сотрудника, запланированные на день. Работа с событиями во многом похожа работе с задачами. Разница в том, что события попадают в этот список автоматически.

Создавать события можно прямо из окна Рабочий день с помощью строки новое событие с указанием периода события и выбором календаря к которому будет принадлежать это событие. При установке флажка вне офиса событие автоматически попадет в Календарь отсутствий.

При клике указателем мыши по названию события открывается дополнительное окно с информацией о событии:

При клике на название события в этом дополнительном окне корпоративный портал перейдет к вашему календарю.

Отчет за день

Закладка Отчет за день позволяет вводить отчет в простой текстовой форме. Этот отчет будет автоматически добавлен в Рабочий отчет под соответствующей датой. Отчёт можно отредактировать даже на следующий день, до тех пор, пока он, следующий рабочий день, не начат.

Завершение рабочего дня

По клику на кнопку Завершить рабочий день система сохранит время завершения рабочего дня в Отчете по рабочему времени. При необходимости можно продолжить отсчет рабочего времени с помощью кнопки Продолжить рабочий день.

Уведомление в социальных сетях

При необходимости можно настроить уведомление в социальные сети о начале и завершении рабочего дня при помощи кнопки:

Текст уведомления и сети для уведомлений можно откорректировать.


Настройки параметров рабочего дня
334 / 401

Настройка параметров рабочего дня производится как для компании в целом, так и для каждого подразделения и сотрудника в отдельности. Для компании в целом параметры настраивает администратор. Для отдельных подразделений компании и отдельных сотрудников, при необходимости, эти настройки может изменить руководитель подразделения.

Если не заданы настройки для какого-то подразделения, то для учета работы его сотрудников будут использоваться параметры вышестоящего подразделения.

Настройка параметров рабочего времени

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Настройка параметров рабочего дня

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Чтобы получить доступ к функционалу настроек воспользуйтесь кнопкой Настройка на странице Время и отчёты > Рабочее время:

После этого станут доступными кнопки вызова настроек рабочего времени подразделения и сотрудников в виде "шестеренки":

Для отключения учёта рабочего времени установите значение поля Учет рабочего времени - Выключен.

Если настройки наследуются, то "шестеренка" будет серого цвета. Если настройки отличаются от типовых, то - желтого.

Внимание! Рабочее время указывается в формате ЧЧ:ММ

Примеры.

1. В подразделении рабочий день установлен с 9:00 до 18:00 с часом на обед. В этом самом простом варианте надо установить:

  • Максимальное время начала рабочего дня на 9:00 (сотрудник должен начать работать не позже 9 утра);
  • Минимальное время завершения рабочего дня на 18:00 (сотрудник должен завершить работу не раньше 6 вечера)
  • Минимальная продолжительность рабочего дня - на 8:00 (сотрудник должен отработать не менее 8 часов за день).

2. В подразделении допускается возможность начать рабочий день в 8 утра и завершить в 17:00 или начать рабочий день в 11:00 и завершить в 20:00.

В этом случае параметры должны быть следующими:

  • Максимальное время начала рабочего дня - 11:00 (начать работу нужно не позже 11-и часов),
  • Минимальное время завершения рабочего дня на 17:00 (завершить работу нужно не ранее 17-и часов),
  • Минимальная продолжительность рабочего дня - на 8:00 (отработать не менее 8 часов, во сколько бы не был начат день).

Начать/закончить рабочий день можно и позже/раньше указанных величин. Просто в отчете по рабочему времени это будет отмечено как замечание по трудовой дисциплине.

То есть при настройке гибкого графика работы нужно учитывать "внутренние" границы рабочего дня.


Рабочие отчёты
335 / 401

Внимание! Для облачной версии сервиса Битрикс24 (лицензии Проект, Проект+ и Команда) функционал Рабочие отчеты недоступен.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Рабочие отчеты

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Отчет по рабочему времени теперь возможен не только за рабочий день, но и за выбранный интервал времени. Данные по таким отчетам выводятся на странице Рабочие отчеты:

Если отчет не утверждён, он отображается серым цветом. Если утвержден без оценки, то жёлтым. Если оценен положительно, то зеленым, если отрицательно - то красным.

Фильтры на контекстной панели видны в зависимости от уровня доступа:

  • Сотрудникам дана возможность только включать/отключать статистику.
  • Администраторы сервиса, сотрудники Отдела кадров и Руководства видят ещё и фильтр по подразделениям.

    Примечание: группы Отдел кадров и Руководство доступны только в коробочной версии сервиса Битрикс24.
  • руководители отделов дополнительно видят фильтр по сотрудникам.

Отчеты сотрудников должны быть утверждены и оценены руководителем подразделения. Для утверждения достаточно просто кликнуть по отчету в календарной сетке, откроется форма отчета:

Выберите нужную оценку и подтвердите отчет. После подтверждения отчёта сотрудник теряет возможность отредактировать свой отчет. Смена оценки отчета и редактирование отчёта старшим должностным лицом возможна и после подтверждения.

Задание параметров отчетности доступно руководителю подразделения для своих подчиненных, для сотрудников Отдела кадров и Руководства.

Примечание: группы Отдел кадров и Руководство доступны только в коробочной версии сервиса Битрикс24.

Чтобы получить доступ к функционалу настроек воспользуйтесь кнопкой Настройка. После этого станут доступными кнопки вызова настроек рабочих отчетов сотрудников в виде "шестеренки". Если настройки наследуются, то "шестеренка" будет серого цвета. Если настройки отличаются от типовых, то - желтого. В форме можно задать частоту отчетов, день и время отчета.

Окно подачи отчёта появляется автоматически при наступлении установленного времени при обновлении страницы (переходе на другую страницу портала):

Если срок отчётного периода более суток, то в панели Рабочего дня в день отчёта появляется ссылка Отчёт за день. (Необходимо обновить страницу.)

Примечание: Если был пропущен очередной отчет, то на странице Рабочие отчеты для сотрудника будет выведено сообщение:

В Рабочий отчет автоматически попадают:

  • Все ежедневные отчеты, которые заполнялись в закладке Отчет за день инструмента Рабочий день.
  • Все задачи, которые выполнялись в течение отчетного периода. Задачи в отчет можно добавлять и с помощью селектора задач выбрать из списка.

В рабочий отчет не попадают события, участие в которых не подтверждено сотрудником.

Составление отчета можно отложить на один час. Пока отчет не подтвержден руководителем, его можно отредактировать. После составления отчета сообщение о нем выведется в Живой ленте для самого сотрудника и его руководителя.

Внимание! Рабочие отчёты будут создаваться только в том случае, если работник в заданный период воспользовался Учётом рабочего времени.


Собрания и планерки
336 / 401

Внимание! Для лицензий Проект, Проект+ и Команда функционал Собрания и планерки недоступен.

Собрания и планерки - инструмент автоматизирующий подготовку к собранию, его ведение и контроль за исполнением поставленных на собрании целей, хранение истории, обеспечивающий "прозрачность" всего процесса для руководства.

В общем списке собраний цветами помечены:

  • черным - планируемые собрания;
  • серым - завершенные;
  • синим - идущие в данный момент.

Участники собрания распределяются по ролям и действуют в соответствии с ними:

  • Организатор создает собрание, распределяет обязанности между участниками и закрывает его;
  • Участники отчитываются по вопросам повестки дня;
  • Секретарь пишет отчет.
    • Примечание: Организатор собрания считается ее секретарем, пока не назначит кого-либо вместо себя.

Все накопленные материалы собрания уходят в архив и доступны в дальнейшем для просмотра участниками собрания и руководством компании. Между однотипными собраниями устанавливается связь - незакрытые вопросы из предыдущих планерок наследуются, а на текущем совещании планируется следующее.

Руководители подразделений имеют доступ к собраниям, в которых участвуют их подчиненные, даже если руководители не входят в состав участников собрания.


Создание собрания
337 / 401

Создать собрание можно как новое событие и как продолжение предыдущего собрания.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Создание собрания

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Создание нового собрания

Новое собрание создается с помощью команды Добавить собрание на странице Время и отчеты > Собрания и планерки. Откроется форма создания собрания:

Заполните поля формы. Суть большинства полей понятна из их названия. Некоторые комментарии к полям, не очевидные сразу:

  • При задании Длительности собрания не забудьте указать, в чем эта длительность - в часах или минутах.
  • Участников можно выбрать по аналогии с выбором в Задачах.
  • Секретарь может быть выбран только из участников собрания.
  • Место проведения может быть не только выбранным из имеющихся переговорных, но и добавлено вручную текстом.

Создание повестки

Для создания вопросов повестки собрания используйте область Повестка. Создание вопросов и подвопросов интуитивно понятно. Команды, которые можно использовать при создании вопросов повестки:

Нажмите на рисунок, чтобы увеличить

  1. команды смены режимов работы. В режиме Повестка создается повестка, в режиме Протокол ведется отчет по вопросам повестки и создаются дополнительные вопросы, возникшие вне повестки дня. Режим Протокол доступен для идущего в данный момент или завершенного собрания.
  2. используя это поле можно перетаскивать вопросы, меняя их очередность.
  3. используя эту кнопку можно менять вложенность вопросов, поднимая или опуская их на один уровень.
  4. установка флажка позволит одновременно с созданием вопроса повестки создать и задачу для сотрудника, ответственного за этот пункт.
  5. индикатор количества задач по данному пункту с возможностью перехода к списку задач.
  6. индикатор числа комментариев конкретного вопроса с возможностью перехода к комментариям.
  7. кнопка удаления вопроса.
  8. кнопка редактирования вопроса.
  9. список файлов, присоединенных к конкретному вопросу.
  10. кнопка добавления подвопроса.
  11. сохранить результаты редактирования.
  12. отменить результаты редактирования.
  13. открытие карточки задачи.
  14. добавление пункта повестки из уже созданной задачи или из другого собрания.

Создание собрания как продолжения предыдущего

Создание собрания как продолжения возможно не только после завершения предыдущего собрания (по ссылке Создать следующее собрание в форме завершенного собрания), но и в любой момент по команде Создать следующее собрание в общем списке собраний.

По этой ссылке открывается форма создания собрания, в которую автоматически включены из предыдущего собрания:

  • участники в тех же ролях;
  • длительность собрания;
  • место проведения;
  • описание собрания;
  • файлы, загруженные к предыдущему собранию;
  • вопросы повестки дня;

Вопросы повестки дня включаются во вновь создаваемое собрание после отметки их чекбоксами и нажатия на кнопку Выбрать вопросы. При необходимости можно добавить новые вопросы в повестку дня, так же как это делалось в случае с обычным созданием собрания.


Ведение собрания
338 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Ведение собрания

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Ведение собрания начинается с кнопки Начать собрание в форме создания/редактирования собрания. При этом форма собрания перейдет в режим Протокол. В режиме Протокол доступно:

  • Создание вопросов повестки, включенных в ходе обсуждения собрания:

  • Ведение протокола собрания в целом:

  • Ведение отчета по вопросу. Клик указателем мыши на названии вопроса откроет форму отчета ответственного за вопрос:

    В этой форме есть 4 зоны:
    • 1 - Отчеты.

      Здесь ведется отчет по выбранному вопросу. Ведение отчета доступно только ответственному за вопрос.

    • 2 - История вопроса.

      Доступна, если собрание создано из предыдущего. Историю вопроса можно свернуть, чтобы форма на экране занимала меньше места.

    • 3 - Задачи.

      Выводится список задач, привязанных к теме обсуждаемого вопроса.

    • 4 - Комментарии.

      Поле, доступное всем участникам собрания для добавления комментариев к вопросу. Файлы, прикрепленные к комментарию к вопросу будут прикреплены к вопросу в целом.

      Примечание: этот же принцип работает и по отношению к файлам, прикрепляемым к собранию.

  • Завершение вопросов и собрания. Завершение вопроса можно пометить чекбоксом. Закрытие собрания происходит по кнопке Завершить собрание.


Телефония
339 / 401

Сервис Битрикс24 даёт возможность использовать телефонию для решения производственных задач. Телефония в Битрикс24 реализована с помощью технологии WebRTC позволяющей совершать/принимать звонки прямо из браузера. Эта технология поддерживается браузерами в версиях не ниже: Google Chrome v29, Mozilla Firefox v27, Opera v18, Яндекс.Браузер v13. (К сожалению Internet Explorer не поддерживает WebRTC.)

В силу разных, зависимых от разработчиков браузеров, причин IP-телефония гарантированно корректно функционирует только в Google Chrome и Mozilla Firefox. В Opera и Яндекс.Браузер работа нестабильная от версии к версии браузеров.

Как работает телефония в Битрикс24

Для понимания работы Телефонии схематично поясним её алгоритм.

Основой работы всей телефонии является Контроллер телефонии, расположенный на сервере "1С-Битрикс". Именно он производит первичную маршрутизацию звонка (от голосовых серверов до портала Битрикс24), контроль за лицензиями.

При начале звонка с портала (телефонного аппарата), клиент сначала подключается к голосовым серверам Voximplant. Затем голосовые сервера подключаются к Контроллеру что бы проверить лицензию. После проверки Контроллер передаёт настройки подключения обратно в звонок.

Коротко это можно описать так: Voximplant -> Контроллер -> Voximplant. Эта цепочка занимает не много времени. На данный момент такая схема работает только для исходящих звонков. Для входящих путь чуть длиннее Voximplant -> Контроллер -> ваш портал Битрикс24 -> Контроллер -> Voximplant. Время на данную коммуникацию при входящих звонках занимает 1-2 секунды.

В случае если контроллер в данный момент не доступен, то реализуется возможность работы телефонии без контроллера. Раз в сутки в аккаунт телефонии (на голосовых серверах Voximplant) Контроллер сохраняет секретный ключ и адрес портала. Если с Контроллером телефонии все в порядке то работа осуществляется по обычной схеме. Но если до Контроллера не получилось достучаться по каким-то причинам, то происходит переход на режим прямого доступа через упомянутые ключи. Для клиента же обычный звонок и звонок в режиме прямого доступа - ничем не отличается, он даже не будет знать что что-то было не так.

В логе звонка, при работе без контроллера, будет вот такая запись:

Звонки с Битрикс24 можно осуществлять разными способами:

  • Голосовые и видео звонки с Бизнес-чата или Десктопного приложения внутри компании
  • IP телефония на стационарные и мобильные телефоны
  • IP телефония с помощью офисных АТС
    •

    Настройки локальной сети

    Использование телефонии требует правильной настройки локальной сети, откуда совершаются звонки. Для каждого из видов звонков есть свои требования по настройкам, которые указаны на страницах с описанием конкретного способа. Но есть и общие требования. Для корректной работы необходимо, чтобы в вашей сети были открыты определённые порты и адреса.

    Внимание! Часть требуемых для открытия адресов выставляются оператором связи Voximplant. Эти адреса могут меняться. В текущей документации отслеживаются эти изменения. Администраторам порталов рекомендуется при возникновении проблем со связью первым делом проверять актуальность открытых в вашей сети адресов.
    • порты: 443 TCP, 1935 TCP, 5060 TCP, 5060 UDP, 1935 UDP, 3478 UDP, 8000-48000 UDP.
    • адреса:
      46.137.125.240 | 46.137.97.175 | 46.137.123.236 | 69.167.178.6 | 176.34.103.175
      Требования по адресам от компании Voximplant:
      149.11.34.27 | 38.122.236.126 | 95.163.65.5 | 89.184.82.92 | 198.27.75.221 | 77.244.209.10 | 10.77.32.18 | 185.164.148.249 | 142.0.196.148 | 203.195.120.44 | 80.93.190.218 | 141.8.185.3 | 173.0.146.133 | 69.167.178.6 | 188.138.61.27
      149.11.44.91 | 95.213.221.98 | 89.184.82.181 | 77.244.209.11 | 185.106.81.244 | 203.195.121.227 | 80.93.190.219 | 69.167.178.80
      149.56.83.166 | 95.213.228.3 | 89.184.65.247 | 185.105.163.75 | 80.93.190.220
      149.56.83.167 | 95.163.65.3 | 89.219.34.163 | 185.164.148.248
      95.213.223.205
      95.163.65.6
      95.163.65.4
      95.213.221.99
      95.213.228.2
      95.213.223.204
      95.213.198.99

    Примечание: Данные требования распространяются на firewall и антивирус.

    Для корректной работы телефонии (мобильная телефония, телефония в браузере и десктоп клиенте) необходимо что бы в операционной системе пользователя было актуально время. Администратору следует проверить включена ли синхронизация времени в настройках операционных систем пользователей или синхронизировать локальный сервер времени.

    Голосовые и видео звонки с Бизнес-чата или Десктопного приложения внутри компании

    Самый простой и доступный способ общения. Не требует никаких настроек со стороны пользователя или администратора портала. Всё работает "из коробки" и бесплатно. Для осуществления голосового и видеозвонка необходим микрофон и видеокамера. Возможны групповые видеозвонки (до 4-х участников).

    К недостаткам способа можно отнести ограниченность числа возможных абонентов: пользователи вашего портала (в том числе и пользователи экстранета) и контакты из сети Битрикс24Network. Для звонков по этому способу нет возможности вести запись разговора штатными методами Битрикс24.

    Подробнее о звонках с Бизнес-чата или Десктопного приложения.

    IP телефония

    IP телефония - дальнейшее развитие технологии голосовых и видеозвонков. Она имеет больше возможностей чем голосовые и видео звонки и так же осуществляется с Бизнес-чата или Десктопного приложения. Этот способ позволяет звонить на любые стационарные и мобильные телефоны.

    Внимание! В отличие от голосовых звонков, IP-телефония - платная услуга, реализуемая с помощью оператора связи Voximplant, который обеспечивает соединение и отвечает за устойчивость IP-телефонии.

    Без аренды отдельного телефонного номера возможны только исходящие звонки. Если нужно осуществлять и входящие, то необходимо арендовать телефонный номер. Есть возможность скрывать арендованный номер и заменять его для ваших клиентов на любой существующий офисный номер. (Либо таким образом можно скрыть номер базовой станции.) Арендовав номер для приема входящих звонков и привязав его в качестве обратного получается полноценное телефонное решение.

    Используя эту телефонию вы имеете возможность создать удобные правила обработки звонков: маршрутизацию и сохранение записи разговоров. Настройка маршрутизации позволяет:

    • Перенаправить входящий звонок на конкретного сотрудника.
    • Перенаправить звонок менеджеру, закреплённому за этим номером.
    • Задать очередь сотрудников и число гудков, которые должны пройти до переадресации к следующему в очереди сотруднику.
    • Указать сервису что делать, если никто из очереди сотрудников не ответил на входящий звонок.

    Тарифы установлены отдельно для России, СНГ, Европы и США. Оплата за трафик производится оператору VoxImplant через Битрикс24.

    Битрикс24 позволяет вам вести детализацию звонков с просмотром даты, времени, стоимости звонка, а так же с файлом записи. Возможность записи звонков управляется администратором портала. Большой архив записей может существенно уменьшить свободное место на диске.

    Пользователи Экстранета не могут звонить через ваш портал.

    Подробнее об IP телефонии

    IP телефония с помощью офисных АТС

    Есть возможность подключить к вашему порталу офисные или облачные АТС. В этом случае используются уже имеющиеся у вас офисные номера, которые отображаются для ваших клиентов так же как раньше. Пользователи портала после такой интеграции перестают применять IP-телефоны и используют вместо них микрофоны на компьютерах.

    Этот вид телефонии так же позволяет осуществлять бесплатные входящие звонки. Платная ежемесячная лицензия требуется только на исходящие звонки, оплата за трафик осуществляется по расценкам ваших операторов связи через системы оплаты самих операторов связи.

    IP телефония с помощью офисных АТС позволяет:

    • Все входящие звонки перенаправлять в портал Битрикс24. Звонки идентифицируются, обрабатываются по вашим правилам, фиксируются в CRM, записываются. К ним всегда можно вернуться при необходимости.
    • Совершать исходящие звонки из Битрикс24 через каналы присоединенные к вашей IP-АТС с фиксацией и обработкой, как и в случае со входящими.

    Минусы такой интеграции:

    • Полностью выводится из эксплуатации внутренняя часть имеющейся IP-АТС. (Она рассматривается только с точки зрения некоего блока ответственного за внешние линии.)
    • Необходимость дополнительных платежей.

    Настройка SIP подключения различна для облачных и офисных АТС. Для тестирования функционала вам доступны бесплатные минуты для исходящих звонков.


Баланс и статистика
340 / 401

На странице Телефония > Баланс и статистика можно отслеживать состояние счёта и контролировать расходы.

Баланс

С помощью кнопки Пополнить можно перейти к форме пополнения счёта. Пополнить счёт можно только суммой, кратной 1000 рублей. Заполните поля формы, нажмите Оформить заказ и оплатите заказ.

Если по каким-то причинам не была произведена оплата аренды номера в нужный срок, то работа номера блокируется. Блокировка номера означает, что не будут приниматься/отправляться входящие и исходящие звонки. Но номер не снимается с арендатора в течение двух месяцев.

Внеся оплату в течение этого времени можно подключить к своему Битрикс24 старый номер. В этом случае отсчёт аренды номера пойдёт с даты фактической оплаты.

Оплата услуг работает по принципу автопродления, то есть, если у пользователя истёк номер по времени аренды, то новые добавленные деньги пойдут на его продление в первую очередь, а только потом на оплату трафика.

Виджет Регулярные платежи выводит информацию о сроке, до которого произведена оплата арендованных номеров.

Виджет SIP Коннектор информирует о количестве имеющихся в распоряжении бесплатных минут, а также о сроке окончания аренды после оплаты:

Статистика

На странице также доступна обобщённая (по месяцам) и детальная (по каждому звонку) статистика звонков. Гаджет Расходы показывает три последних месяца, когда использовалась телефония.

По ссылке Детализация откроется список всех осуществлённых звонков:

При просмотре детальной статистики, если администратором было разрешено производить запись звонка, можно прослушать файл с записью разговора (колонка Запись).

Если кликнуть по фамилии сотрудника, то включится фильтр и будут выведены только звонки этого сотрудника. Аналогичную фильтрацию можно провести по статусам звонков, либо по обоим параметрам вместе.

При просмотре детальной статистики также можно обратиться к логу каждого конкретного звонка (колонка Журнал). Эта опция очень полезна администраторам при настройке АТС на работу через сервис Битрикс24.

Примечание: Если звонок был сброшен до того как система успела определить сотрудника, ответственного за этот звонок, в колонке Сотрудник будет прочерк.

Данные, выводимые на странице можно отфильтровать и экспортировать в формате Excel (доступно только на платных тарифах сервиса и в коробочной версии):


Управление номерами
341 / 401

На странице Телефония > Управление номерами производятся настройки портала на использование телефонии.

Привязка номера

Привязка номера - это указание номера, который будет высвечиваться у абонента в качестве номера, с которого ему звонят. Чтобы не было соблазна указывать номер "от фонаря" предусмотрена процедура проверки, при которой система совершает звонок на этот номер, диктует цифровой код который надо вводить при регистрации линии.

Привязанный номер позволяет осуществлять обратные звонки.

Если не будет привязан ни какой номер, то в качестве исходящего будет отображаться базовый номер станции.

Настройка номера производится по аналогии с настройкой арендованного номера за исключением опции переадресации и обработки добавочного номера. При этом учтите, что на привязанный номер не может быть входящих звонков. Например, настройка Очереди - для арендованного это очередь для входящих и обратных, а для привязанного - только для обратных.

Арендовать номер

Компания может взять в аренду "красивый" номер, который может привязать к своему порталу. Для этого достаточно выбрать страну, регион и один из предложенных номеров. Список стран и регионов постоянно расширяется.

Выбрав и подключив номер произведите настройку маршрутизации и обработки входящих звонков.

Если в номере отпала необходимость, его можно удалить. Удаление номера отложенное по времени, он отключается через сутки. Это сделано специально чтобы спасать владельцев компании от необдуманных решений или случайных ошибочных действий. Об отключении номера сообщается письмом на контактный e-mail портала.

Текст письма об отключении номера
Вы отправили запрос на отключение телефонного номера +74951340483 от вашего Битрикс24. Номер будет отключен через 24 часа.

Если вы отключили номер по ошибке, пожалуйста, отмените отключение в настройках телефонии (в течение суток после запроса на отключение): https://******.bitrix24.ru/settings/telephony/settings.php?MODE=RENT

Обратите внимание, если к моменту отключения номера у вас остается оплаченный период аренды, эти деньги возвращены не будут. Повторно арендовать этот номер можно будет не раньше, чем через 3 месяца после отключения

Пока номер не отключен из интерфейса, он все еще активен и с него можно делать звонки, принимать и оплачивать.

Примечание: Оплачивая номер только на один месяц его можно использовать для какой-то рекламной компании, не обременяя обычные рабочие номера. А после компании - отключить.

Примечание: Битрикс24 поддерживает звонки на номера в международном формате. Для России автоматически заменяется ведущая 8 на +7 и поддерживается звонок на короткий номер в некоторых городах.

Подключить SIP АТС

Функционал подключения офисной или облачной АТС.

Настройка номеров

После аренды номера или подключения SIP АТС можно произвести настройку этих номеров на работу с Битрикс24: маршрутизацию звонков и мелодии для звонка.

Маршрутизация звонков позволяет выстроить очередь из сотрудников, по которым будет распределяться входящие звонки. Мелодии для звонков можно задать свои для каждого вида операций со звонком.

Значения полей при настройке маршрутизации:

  • Обработка добавочного номера - установленный флажок в поле даст указание сервису Битрикс24 перенаправлять входящий звонок на конкретного сотрудника, если был набран номер этого сотрудника, а так же что делать, если сотрудник не отвечает на звонок.
  • Проверять номер по базе CRM - установленный флажок включит проверку входящего номера по базе CRM и перенаправит звонок менеджеру, закреплённому за этим номером. Так же можно задать действия на случай, если сотрудник не отвечает на звонок и что делать, если номер не найден в базе CRM.

    Чтобы при ручном перенаправлении звонка лид создавался на имя ответственного сотрудника, а не сотрудника, принявшего звонок, используйте опцию Автоматически менять ответственного за лид, при ручном перенаправлении звонка на другого сотрудника.

    Для платных тарифов доступна опция Источник для нового лида. При аренде отдельного номера для каких-либо целей (например, для рекламной компании на веб-сайте) можно указать источник лида. Таким образом можно выявлять самые успешные каналы для лидов.

  • Очередь - задание собственно очереди сотрудников и задание числа гудков, которые должны пройти до переадресации к следующему в очереди сотруднику. Возможны два вида очереди: Равномерно и Строго по очереди.
    • Равномерно: порядок следования сотрудников в списке не имеет значения, звонки будут распределяться между сотрудниками в очереди: если предыдущий звонок был сотруднику А, то следующий придет сотруднику Б и так далее.

      Особенность работы очереди в режиме Равномерно

      Звонок распределяется по пользователям в зависимости от времени их последнего звонка:

      • оператор1 - отвечал в 15-10
      • оператор2 - отвечал в 13-20
      • оператор3 - отвечал в 14-40

      Следующий звонок поступит на оператора 2, а не на оператора 1, т.к. он отвечал самым последним, следующий на оператора 3, а только потом на первого.

    • Строго по очереди: порядок следования сотрудников в списке имеет значение, все звонки направляются на первого сотрудника, если он не отвечает, то на второго и так далее по очереди. Если нужно поменять порядок следования, то нужно удалить старый список сотрудников и добавить их заново в нужной очерёдности. Бесконечная очередь в этом режиме не доступна, связь прервётся после окончания списка сотрудников.
    • Одновременно всем - звонок поступит одновременно всем свободным сотрудникам из очереди, и клиенту ответит тот, кто первым примет звонок. (Выбор этой опции недоступен для бесплатного тарифа.)

    Примечание: Опция Не направлять звонок на сотрудника, если не начат рабочий день или установлен перерыв позволяет направлять звонки только реально работающим сотрудникам. Она доступна только на тарифах с учётом рабочего времени.

  • Обработка неотвеченного вызова - указание что делать если никто из очереди сотрудников не ответил на входящий звонок. Значение Вернуть обратно в очередь этого поля зацикливает входящий звонок до ответа на него сотрудником.
  • Сохранять запись всех разговоров - при установленном флажке все разговоры будут доступны в статистике звонков и сохранены в папке Общем диске > Телефония: записи звонков. Объём этой папки учитывается в рамках общего места на портале, то есть хранение бесплатно пока не исчерпано бесплатное место.

    Имя файла записи формируется по шаблону: дата_время_номер. Например: 2014-06-10_01-55-19__7************.flv.

    Примечание: доступ к этой папке ограничен администраторами портала, и если есть необходимость можно в настройках папки открыть доступ и другим сотрудникам.

    Сам факт записи разговора согласно законодательству РФ не является незаконным. Под действие запрещающих статей законодательства может попасть использование записи в каких либо целях. Законность использования записи будет определяться исходя из конкретной ситуации. Во избежание возможных проблем лучше предупреждать клиента о том, что ведётся запись с помощью опции Проигрывать предупреждение о начале записи при входящем звонке. (Обратите внимание, что предупреждение автоматически срабатывает только при входящем звонке. При исходящем менеджер должен предупредить о записи лично.)

    Внимание! Имеется ограничение на количество записей разговоров для бесплатного тарифа. Будут записаны 100 первых звонков в каждый календарный месяц. Для платных тарифов такого ограничения нет.
  • Оценка качества обслуживания - инструмент оценки работы менеджера клиентом. При включении опции после завершения звонка клиенту будет предложено дать оценку работе менеджера. Голосовые сообщения этой опции настраиваются в разделе Мелодии. (Выбор этой опции недоступен для бесплатного тарифа.)

    Примечание: Просмотр оценок возможен на странице Детализация звонков.

Настройка времени

В нерабочее время клиентам выводится звуковое сообщение, заданное в разделе Настройка времени. Этот сигнал будет выводиться в соответствии с настройками, заданными в этом же разделе.

Поля настроек интуитивно понятны и в комментариях нуждается только поле Обработка звонка во внерабочее время. Оно предлагает на выбор:

  • Включить автоответчик по умолчанию, включается указанная мелодия.
  • Перенаправить на указанный номер - появится поле для ввода номера.
  • Завершить звонок - данный вызов не тарифицируется, это важно для 8-800, которые платят деньги за входящие. Выбор этого значения позволяет спасти владельца федерального номера от мошеничества.

Голосовое сопровождение мелодии звонка автоматически выставляется на язык портала. При необходимости его можно поменять.

Номер для перенаправления

Опция доступна только для SIP-телефонии и используется, когда подключенная sip-телефония не может совершать исходящие вызовы (например, просрочена оплата). В этом случае не работает перенаправление на мобильный или стационарные телефоны. Опция позволяет перенаправить звонки на другую SIP-телефонию или арендованный или привязанный номер.

Внимание! В перенаправленном вызове определяется номер, который указан для перенаправления, а не номер звонящего. Битрикс24 не является оператором связи и не имеет возможности подменять номер на любой другой. Подмена возможна только на подтверждённый через привязку номер, а в случае перевода звонка с одного sip на другой подмена вообще не представляется возможной.


Права доступа
342 / 401
Внимание! Управление правами доступно в коробочной версии Битрикс24 и на платных тарифах (кроме Проект+) облачной версии.

Администратор портала имеет возможность настроить права доступа к Телефонии. Управление доступом осуществляется по ролям на странице Телефония > Права доступа:

По умолчанию имеются роли: Администратор, Директор, Начальник отдела и Менеджер. Администратор обладает максимальным количеством прав, Менеджер - минимальным.

Примечание: для сохранения обратной совместимости, администраторы портала всегда имеют максимальные права доступа, независимо от назначенной им роли.

При необходимости по ссылке Добавить в Списке ролей можно создать свою роль со своими параметрами (либо отредактировать имеющуюся роль) :

Для создания роли введите её название в поле Роль и укажите права, необходимые для этой роли.

По умолчанию для всех сотрудников компании заданы права роли Менеджер и только администраторам установлено право Администратор. При необходимости можно задать своё распределение ролей с помощью ссылки Добавить право доступа. Если пользователю назначено несколько ролей, то реальные права доступа строятся по принципу объединения прав ролей, а не пересечения.

Внимание администраторов и разработчиков! При использовании REST API телефонии имеют значение заданные на этой странице права. То есть внешнее приложение может работать для одних пользователей, но не работать для других.


Пользователи
343 / 401

Примечание: Страница доступна только администратору сервиса.

На странице Телефония > Пользователи производится настройка внутренних номеров для переадресации звонков в компанию на конкретных сотрудников.

Для этого достаточно воспользоваться ссылкой Изменить в строке нужного сотрудника. Откроется форма настройки, в которой нужно указать конкретный номер переадресации:

Примечание: если одинаковый номер привязан для звонков и через Битрикс24 и через свою АТС, то звонить через свою АТС не получится, звонки будут уходить через Битрикс24.

Также переадресовать звонок другому сотруднику можно непосредственно из панели Бизнес-чата при приеме входящего звонка.

Клиент может звонить сразу своему менеджеру по внутреннему номеру. Чтобы такое было возможно необходимо:

  • назначить сотруднику внутренний номер;
  • включить опцию Обработка добавочного номера в настройках маршрутизации звонков.

Если сотрудник будет работать через телефонный аппарат, а не звонить с компьютера, то необходимо установить Вкл в опции Подключить телефонный аппарат и использовать появившиеся данные для настройки телефонного аппарата. Значение поля Пароль можно поменять.

При увольнении сотрудника у его учётной записи будет деактивироваться привязка к телефонному аппарату. Добавочный номер не будет активен, его можно будет выдать другому сотруднику. Звонок на него не будет направляться ни по правилам СРМ, ни по правилам маршрутизации звонков. Но, тем не менее, администратору необходимо сменить в СРМ ответственного и удалить уволенного из очереди.


Телефонные аппараты и софтфон
344 / 401

Настольные аппараты

Сотрудники компании могут при звонках с сервиса Битрикс24 использовать привычные настольные телефонные аппараты. Использование аппаратов ускоряет работу телефонии на сервисе. Для этого необходимо настроить эти устройства на работу с Битрикс24.

В настройках пользователя после включения опции поддержки телефонных аппаратов выдается адрес сервера, логин и пароль. Эти данные нужно указать в телефоне. После этого, аппарат регистрируется на серверах телефонии и начнёт работать.

Работать в Битрикс24 может любой SIP телефон. Число моделей таких телефонов велико, протестировать все их на работу в сервисе крайне сложно. Список проверенных на работу телефонов - в таблице ниже.

DECT телефоны можно подключать через SIP шлюз (VoIP SIP адаптеры). Протестирована работа на Linksys PAP2T.

При использовании аппарата сотрудник не обязательно должен быть онлайн на портале, но в этом случае ему не будет доступна карточка звонка.

Так же возможно использование телефонии на софтфонах под Windows, iOS, Android: Media-5, Zoiper, CSipSimple и другие.

Внимание! Поддержка софтфонов находится в бета-режиме, стабильная работа гарантируется только с телефонными аппаратами .

Список проверенных аппаратов
Производитель | Модель | Производитель | Модель | Производитель | Модель
Linksys | SPA3102 | Siemens Gigaset | C610A | Panasonic | KX_TGP-500
 | PAP2T |  | A510IP |  | KX-UT113RU
 | SPA921 |  | al110 | Jabra | PRO™ 930
Grandstream | GXP-2140 | Escene | ES290 | SkypеMate | USB-W1DL
 | DP715 |  | ES320 |  |
 | GXP1405 | D-Link | DHP-150S |  |
 | GXP1400 | Cisco | SPA 303 |  |
 | GXV3175 |  | SPA122 |  |

Внимание! Возможны ситуации, когда в каких-то конкретных условиях не работают указанные выше аппараты вообще или на отдельных рабочих местах. Эта проблема может возникать по множеству причин: от неисправности механической или электронной частей конкретного аппарата до проблем конкретной телефонной линии или локальной сети. (Например, настройки локальной сети позволяют выходить с интернет строго с определенных IP адресов, и те адреса, которые выдаются на подключаемых аппаратах, просто не прописаны в фаерволле.)
В силу этого компания Битрикс не гарантирует 100% работу телефонных аппаратов и не решает проблем с такими конкретными подключениями.

Если есть проблемы при переводе звонка через sip-аппарат,
то в решении этих проблем может помочь знание того, как происходит переадресация звонка через аппарат.

В переадресации участвуют три стороны:

  1. Тот, кто переводит (Transferor)
  2. Кого переводит (Transferee)
  3. На кого переводят (Transfer target)

В момент совершения переаресации sip-аппарат обменивается рядом sip-сообщений с оператором связи Voximplant. По результатам этого обмена Voximplant:

  • объединяет медиа-потоки Transferree и Transfer target
  • разъединяет медиа-потоки Transferree и Transferor
  • во все три плеча отправляет событие CallEvents.TransferComplete с указание роли этого плеча в переводе.

Если в журнале звонка данное событие отсутствует (и клиент нажимает правильные кнопки для перевода), то:

  • либо у клиента аппарат формирует нестандартные сип-команды,
  • либо у клиента какие-то сетевые проблемы.

В этом случае, лог такого звонка надо отправлять в техподдержку Битрикс24, разобраться что именно приходило от аппарата клиента, может только оператор связи Voximplant.

Битрикс софтфон

Телефонию можно использовать и с мобильных устройств. Для этого лучше всего использовать Мобильное приложение с его возможностями софтфона.


Примеры настроек телефонов
345 / 401

Ниже представлены примеры для конкретных телефонных аппаратов. Настройки других телефонов можно проводить по аналогии с этими примерами.

DLink DPH-150S

Необходимые поля:

  1. Адрес сервера - это значение поля Сервер в карточке пользователя.
  2. Порт сервера - стандартный 5060.
  3. Имя учётной записи - это значение поля Логин в карточке пользователя.
  4. Пароль - значение поля Пароль в карточке пользователя
  5. Номер телефона - это значение поля Логин в карточке пользователя.

Сisco SPA303

Настройки осуществляются в режиме администратора

Необходимые поля:

  1. SIP PORT - стандартный 5060.
  2. Proxy - это значение поля Сервер в карточке пользователя.
  3. USER ID, AUTH ID - это значение поля Логин в карточке пользователя.
  4. Password - значение поля Пароль в карточке пользователя
  5. USE AUTH ID - в положении Вкл.

Gigaset C610A

Настройки осуществляются на двух формах:

и по нажатию на откроется форма:

Необходимые поля:

  1. Имя входа в систему, Имя пользователя - это значение поля Логин в карточке пользователя.
  2. Пароль для входа в систему - значение поля Пароль в карточке пользователя
  3. Домен, Адрес прокси сервера - это значение поля Сервер в карточке пользователя.
  4. Порт прокси сервера, Порт сервера регистрации - стандартный 5060.

Gigaset A510IP

Настройки осуществляются на двух формах:

Необходимые поля:

  1. Имя входа в систему, Имя пользователя - это значение поля Логин в карточке пользователя.
  2. Пароль для входа в систему - значение поля Пароль в карточке пользователя
  3. Домен, Адрес прокси сервера - это значение поля Сервер в карточке пользователя.
  4. Порт прокси сервера, Порт сервера регистрации - стандартный 5060.

Linksys SPA921

Необходимые поля:

  1. Порт сервера - стандартный 5060.
  2. Адрес сервера - это значение поля Сервер в карточке пользователя.
  3. Имя учётной записи и пароль - это значение поля Логин в карточке пользователя и пароль.
  4. Номер телефона - это значение поля Логин в карточке пользователя.

Panasonic, аппараты серии KX
  1. Подключить телефонный аппарат к интернету.
  2. Зайти в настройках: Сервис IP > Настройки сети > Настройки IP и запомнить присвоенный аппарату IP адрес (например: 192.168.0.101).
  3. Зайти в настройках: Сервис IP > Настройки сети > Встроен.Web и выбрать Вкл..
  4. Ввести присвоенный телефону IP-адрес в адресную строку и указать реквизиты доступа по умолчанию:
    • пользователь: admin
    • пароль: adminpass
  5. Задать настройки как на изображении:
    1. Номер телефона - указывается внутренний номер сотрудника (только цифры) из карточки пользователя.
    2. ID - это значение поля Логин в карточке пользователя.
    3. Пароль - это значение поля Пароль в карточке пользователя и пароль.
    4. Адреса серверов - это значение поля Сервер в карточке пользователя.
    5. Порты серверов - стандартный 5060.

Внимание! Русскоязычный и англоязычный интерфейсы настроек могут отличаться порядком следования полей и их набором по группам. Поэтому механическое заполнение полей "по порядку следования" не обеспечивает правильных настроек. Ниже даны названия полей в англоязычном интерфейсе и значения для их заполнения.

Все поля, в названиях которых есть server address, service domain должны заполняться значением из поля Сервер в карточке пользователя.

Все поля, в названиях которых есть server port заполняются стандартным значением 5060.

Все поля вида phone numder, sip uri и authentification id должны заполняться значением из поля Логин.

Все поля с password должны заполняться значением из поля Пароль.

Yealink, все модели

Примечание: Перед настройкой аппаратов рекомендуется сбрасывать настройки до заводских.

  1. Настройка аккаунта осуществляется через веб-интерфейс. Для входа в веб-интерфейс необходимо знать IP-адрес телефона, для этого нужно нажать кнопку ОК на телефонном аппарате. На экране телефона появится следующее окно:

  2. IP-адрес из первой строки нужно ввести в адресной строке браузера и ввести логин и пароль пользователя, по умолчанию:
    • логин - admin
    • пароль - admin
  3. В открывшемся окне настройки SIP-регистрации осуществляются в разделе Аккаунт:

  4. Заполните необходимые поля:
    1. Аккаунт должен быть включён
    2. Поля Лейбл и Отображаемое имя не используются в регистрации, поэтому в них можно записать любую информацию.
    3. Имя регистрации и Имя пользователя - значение берется из поля Логин в карточке пользователя.
    4. Пароль - значение берется из поля Пароль в карточке пользователя
    5. Адрес SIP-сервера - значение берется из поля Сервер в карточке пользователя.
    6. Порт - порт используется стандартный 5060

Escene
  1. На телефонном аппарате нажимаем Меню и, затем, цифру 1. Во второй строке будет указан IP адрес, к которому подключен данный телефон.
  2. IP-адрес нужно ввести в адресной строке браузера и ввести логин и пароль пользователя, по умолчанию:
    • логин - root
    • пароль - root
  3. Переходим во вкладку SIP аккаунты и выбираем, какую линию настроим. Телефон поддерживает привязку 2-х аккаунтов, выбираем любой, например, Аккаунт 1:

  4. В открывшейся форме заполните необходимые поля:

    1. Отображаемое имя - вводим имя пользователя телефона
    2. Имя и Имя пользователя - значение берется из поля Логин в карточке пользователя.
    3. Пароль - значение берется из поля Пароль в карточке пользователя
    4. SIP-сервер - значение берется из поля Сервер в карточке пользователя.
    5. Остальные настройки установлены по умолчанию.

Примечание: Клавиши горячего набора настраиваются во вкладке Настройки телефона >Горячая линия.

Cisco SPA122

Тестирование настроек производилось для сети MTT. Для работы с вашей сетью замените параметры настроек из примера на параметры вашей сети.

Откройте интерфейс настроек Cisco SPA122 по адресу 192.168.15.1 используя ваш логин и пароль для администратора устройства.

Примечание: Не рекомендуется использовать режим настроек Quick Setup, так как он не заполняет некоторые необходимые поля.

Заведите в Сisco SPA122 параметры вашей локальной сети. Делается это в Network Setup > Internet Settings в поле Default Gateway. В разделе DNS укажите укажите используемые вами DNS сервера. На иллюстрации пример для локальной сети 192.168.0.1:

Примечание: На иллюстрации адрес устройства сменён с 192.168.15.1 на 192.168.0.22. В результате этого можно отказаться от настройки NAT в локальной сети.

В разделе Network Setup > Network Service в поле Networking Service параметр NAT замените на Bridge.

В разделе Voice > SIP в блоке RTP Parameters указываем порты:
RTP Port Min: 1024,
RTP Port Max: 65455.

В вашем Bitrix24 получите данные для настройки (Телефония > Пользователи).

В разделе Voice > Line1 устанавливаем параметры:

В блоке SIP Settings
SIP Transport: UPD,
SIP Port: 5060,
EXT SIP Port: 5060.

В блоке Proxy and Registration:
Proxy: ip.наш_набор_цифр.bitrixphone.com (значение поля Сервер формы настроек пользователя),
Register Expires: 3600,
Proxy Fallback Intvl: 3600.

В блоке Subscriber Information:
Display Name: ваш логин (значение поля Логин формы настроек пользователя, на иллюстрации - phone15, у вас будет другой)
Password: вводите свой пароль (значение поля Пароль формы настроек пользователя)
Auth ID: ваш логин (значение поля Логин формы настроек пользователя)
User ID: ваш логин (значение поля Логин формы настроек пользователя)
Use Auth ID: yes.

В блоке Audio Configuration:
Preferred Codec: G711u
Second Preferred Codec: G711a
Third Preferred Codec: G729a.

Примечание: Дополнительно можно настроить Dial Plan, это позволит не набирать постоянно код своего города.


Настройки телефонии
346 / 401

Страница для настройки параметров телефонии.

Загрузка документов

В соответствии с законодательством некоторых стран, телефонный оператор требует предоставить юридические документы для работы с арендованными номерами. Если в вашей стране есть такое законодательно требование, то будет активна кнопка Загрузить документы. По нажатию на кнопку откроется форма для загрузки документов. Для физических и юридических лиц формы и требования к документам разные.

На текущий момент требования к загрузке документов действуют только для РФ.

Внимание! Компания "1С-Битрикс" не собирает и не хранит загружаемые документы. Эти данные передаются вашему оператору связи.

Настройка номеров по-умолчанию

При настройке пользователей нужно заполнять поле Номер для исходящего звонка. Это тот номер, который отобразится у клиента как исходящий. Для упрощения работы при настройках пользователей можно использовать Номер по умолчанию, который будет отображаться сразу у всех пользователей. А при необходимости, заменять его на другой в настройках конкретного сотрудника.

Настройка интерфейса звонков

В зависимости от условий работы и привычек пользователей можно настроить вид чата для телефонных звонков. Возможны варианты: не отображать звонки вообще, отображать в едином или в отдельном для каждого номера чатах.

Интеграция с CRM

Выбор момента для запуска бизнес-процесса по созданию лида. Если выбрать В момент поступления звонка, то ответсвенным за лид будет тот, кто снял трубку. Если выбрать В момент окончания звонка, то ответственным будет последний говоривший с клиентом.

Чёрный список

Битрикс24 позволяет блокировать звонки телефонных хулиганов. Для этого необходимо активизировать опцию Автоматически блокировать телефонные номера злоумышленников в нерабочее время на странице Телефония > Чёрный список и задать для этой опции параметры.

Блокировка номера постоянная и не снимается. Поэтому очень важно дать правильное сообщение в автоответчике для нерабочего времени, чтобы избежать ошибочной блокировки номеров клиентов. При блокировании номера администратор будет уведомлён об этом.

Если известны конкретные телефонные номера, приём звонков с которых нежелателен, то их можно включить в "Черный список".


Настройка офисной АТС
347 / 401
Внимание! Настройка АТС (для коробочной версии Битрикс24) должна производиться после настройки модуля для работы с облачной телефонией Телефония (voximplant).

SIP Коннектор позволит подключить к Битрикс24 офисные АТС. (Число подключаемых АТС не ограничено.) Для тестирования функционала вам доступны бесплатные минуты. Если вы собираетесь использовать АТС для исходящих звонков, необходимо оплатить лицензию по кнопке Оплатить подключение модуля для исходящей связи. Число бесплатных минут и срок активной лицензии выводится на странице Баланс и статистика в разделе Телефония.

Логика работы SIP Коннектор'а следующая:

  • При совершении исходящего звонка из портала, Битрикс24 попытается присоединится к серверу, указанному вами в разделе Исходящие звонки формы настроек, и, авторизовавшись с логином/паролем, совершить звонок
  • Для приема в портал входящего звонка необходимо создать на своей IP-АТС транк с параметрами, которые вам предоставлены в разделе Входящие звонки формы настроек, и отправлять в этот транк все поступающие в АТС звонки.

Для обработки звонков, кроме настроек в Битрикс24, необходимо будет выполнить настройки на стороне офисной АТС и на сетевом экране (firewall) вашей локальной сети.

  • Настройки офисной АТС
  • Настройки Firewall локальной сети
    •

    Настройка облачной и офисных АТС различаются. Для настройки каждой из них нужно использовать свою кнопку:

    Настройки в Битрикс24

    Воспользуйтесь кнопкой Подключить офисную АТС. И заполните поля формы для подключения:

    Где:

    • Название подключения - Произвольное название соединения. Необязательное поле.
    • Адрес сервера - это IP адрес вашей АТС.
    • Логин и Пароль - данные для доступ к АТС.

    Нажмите Подключить. Данные сохраняться, система перейдёт к настройкам маршрутизации.

    Настройка офисных АТС

    Рассмотрим настройку офисной АТС на примере Asterisk. Для настройки АТС данные берутся из блока Входящие звонки:

    • Создание транка. В файле sip.conf необходимо создать запись следующего вида:

      [voximplant]
dtmfmode=rfc2833
;далее вместо youraccount необходимо использовать имя Вашей учетной записи в поле Сервер (см. иллюстрацию выше).
fromdomain= youraccount
type=friend
host= youraccount
; в качестве значения полей типа user используется значение поля Логин
fromuser=asterisk
username=asterisk
; в качестве значения пароля используется значение из поля Пароль
secret=mypass
insecure=port,invite
conext=contex-internal
disallow=all
nat=yes
allow=ulaw&alaw

      В этой записи нужно менять значения только у домена, пароля и параметра nat, который ставится в yes/no, в зависимости от того используется ли у вас сеть NAT или нет.

      В качестве примера приведём образец настроек по данным с иллюстрации выше:

      [voximplant]

dtmfmode=rfc2833
fromdomain=ip.b24-6864-1386141129.bitrixphone.com
type=friend
host=ip.b24-6864-1386141129.bitrixphone.com
fromuser=sip1
username=sip1
secret=1fe00170274c5a6151a11553df7618d8
insecure=port,invite
conext=contex-internal
disallow=all
nat=yes
allow=ulaw&alaw
      Внимание! До версии модуля 15.1.3 в настройках вашей офисной АТС использовалось в поле Адрес сервера incoming вместо ip (например: incoming.b24-6864-1386141129.bitrixphone.com). Вы можете продолжать использовать это обозначение и далее, но модуль будет работать значительно медленнее.

      Настройки применяются командой в консоли Asterisk:

      sip reload

    • Настройка звонков из Asterisk в VoxImplant. Звонки осуществляются с помощью следующей команды, которую необходимо прописать в файле extensions.conf:

      Dial(SIP/voximplant/${EXTEN})

      В таком случае он поступит в Битрикс24 как звонок на тот номер, на который он изначально пришел в Asterisk.

      Настройки применяются командой в консоли Asterisk:

      dialplan reload

    Настройки Firewall локальной сети

    По умолчанию для SIP используется порт 5060, а для медиа (RTP) 10000-20000 порты. Однако универсальную рекомендацию дать сложно, так как порт 5060 может быть как TCP, так и UDP. Это зависит от существующих настроек локальной сети.

    Обычно для SIP важно, чтобы исходящий трафик был разрешен (с АТС например), а входящие коннекты будут работать автоматически. RTP обычно используется как UDP (чтобы могли теряться пакеты и при этом данные продолжали передаваться)

    Сами порты можно настраивать в свойствах АТС: какой там задан, такой нужно открывать и в Firewall.

    Список ссылок по теме:

    • Интеграция 3CX Phone System и Bitrix24 (статья на Хабре)


Настройки для работы с Билайном через Asterisk
348 / 401

Из-за технических особенностей платформы, используемой оператором связи Билайн, при подключении SIP-коннектора с данными АТС Билайн имеется ряд ограничений:

  • Невозможно совершать исходящие звонки
  • Завершение звонка в Битрикс24 не приводит к завершению звонка в трубке клиента портала.

Чтобы обойти эти ограничения, необходимо использовать промежуточную АТС Asterisk. Рассмотрим пример настройки. Допустим, Билайн выдал телефонный номер 4951234567 на прокси sip.beeline.ru и пароль qwerty.

После установки завершение звонка в Б24 (коробка) не приводит к завершению звонка в трубке клиента портала. необходимо произвести ее конфигурацию:

  1. Регистрируем Asterisk как пользователя Билайн. Для этого добавляем в файл sip.conf, обычно находящийся в папке /etc/asterisk/, следующую строку:
    register => 4951234567:qwerty:4951234567@sip.beeline.ru@sip.beeline.ru/4951234567

    Добавить эту строку нужно строго сразу после строки [general].

  2. Создаем транки для Битрикс24 и Билайн. Для этого в том же файле sip.conf (в самом конце) необходимо прописать следующие настройки:
    [bitrix24-in]

type=user
context=bitrix24
secret=thepassword
diasllow=all
allow=ulaw
allow=alaw

[bitrix24-out]
type=peer
host=ip.b24-xxxx-yyyyyyyyyyy.bitrixphone.com ← значения этого и последующего параметров берутся из конфигурации Офисной АТС Битрикс24 (настройки для входящих звонков)
secret=c8ba30344aa1241e653ce05e56c66d53
username=sipZZ
fromuser=sipZZ
fromdomain=ip.b24-xxxx-yyyyyyyyyyy.bitrixphone.com

[4951234567]
type=peer
insecure=invite
deny=0.0.0.0/0.0.0.0
permit=195.239.174.100/255.255.255.255
host=sip.beeline.ru
username=4951234567
secret=qwerty
fromuser=4951234567
fromdomain=sip.beeline.ru
context=beeline
  3. Настроим прохождение звонков из Битрикс24 в Билайн. В файле extensions.conf в папке /etc/asterisk/ прописываем следующие строки:
    [bitrix24]

exten => _X.,1,Set(CALLERID(num)=4951234567)
exten => _X.,2,Dial(SIP/${EXTEN}@4951234567)

[beeline]
exten => _X.,1,Dial(SIP/4951234567@bitrix24-out)
  4. Вводим настройки для исходящих звонков в SIP-коннектор Битрикс (режим Офисная АТС):
    • Название подключения - Beeline
    • Адрес сервера: публичный IP-адрес сервера, на котором установлен Asterisk
    • Логин - bitrix24-in
    • Пароль - thepassword (он задавался в пункте 2)
  5. Перезапуск Asterisk.


Настройки FreePBX
349 / 401

Рассмотрим пример настройки FreePBX для телефонии через Битрикс24.

Для работы FreePBX достаточно в настройках создать:

  1. Транк с настройками из Битрикс24;
  2. Входящий маршрут, перенаправляющий звонки в этот транк.

Создание транка

При создании транка обязательными являются поля Trunk Name и Outbound CallerID. При этом название транка обязательно должно быть: voximplant. А в качестве номера указывается номер, привязанный к порталу в 11-изначном формате.

Код самого транка (поле PEER Details) аналогичен коду, используемому при настройке SIP, с указанием ваших параметров:

disallow=all
allow=ulaw&alaw
dtmfmode=rfc2833
fromdomain=ip.*.bitrixphone.com
type=friend
host=ip.*.bitrixphone.com
fromuser=sip*
username=sip*
secret=*
insecute=port,invite
conext=contex-internal
nat=yes
qualify=yes

Создание входящего маршрута

При создании маршрута нужно указать номер телефона, привязанный к порталу (поле DID Number) и выбрать созданный ранее транк voximplant (поле Set Destination).


Настройка облачной АТС
350 / 401
Внимание! Настройка АТС (для коробочной версии Битрикс24) должна производиться после настройки модуля для работы с облачной телефонией Телефония (voximplant).

К Битрикс24 можно подключить облачные АТС (не более 5). Под подключением понимается использование одного sip-логина. То есть, если в рамках подключения 4-х АТС имеется по 15 номеров на каждую АТС, но в рамках одной АТС все они обращаются к одному sip-логину, то такие подключения будут работать.

Каждое подключение облачной АТС не ограничено по количеству входящих линий, то есть на это подключение можно направлять неограниченное количество звонков (но число звонков может быть ограничено вашим оператором).

Для тестирования функционала вам доступны бесплатные минуты для исходящих звонков. Число бесплатных минут и срок активной лицензии выводится на странице Баланс и статистика в разделе Телефония.

Внимание! Если после тестирования вас устроила работа сервиса и вы собираетесь использовать АТС для исходящих звонков, необходимо оплатить лицензию по кнопке Оплатить подключение модуля для исходящей связи.

На текущий момент протестирована и проверена работа следующих АТС:

SIPNET | Tekmi | Telphin (только "Телфин.Офис") | MANGO
zadarma.com | Youmagic.pro | Интертелеком | telecom.kz
Дом.ру | MTT Бизнес |  |

Для обработки звонков, кроме настроек в Битрикс24, необходимо будет выполнить настройки на сетевом экране (firewall) вашей локальной сети.

  • Настройки в Битрикс24
  • Настройки Firewall локальной сети
    •

    Настройка облачной и офисных АТС различаются. Для настройки каждой из них нужно использовать свою кнопку:

    Настройки в Битрикс24

    Воспользуйтесь кнопкой Подключить облачную АТС. И заполните поля формы для подключения:

    Где:

    • Название подключения - Произвольное название соединения. Необязательное поле.

      Исключение: Для SIPNET это поле - обязательное. В нём должен быть указан номер, привязанный к порталу. Этот номер должен обязательно быть в международном 11-изначном формате: некоторые национальные операторы могут присылать номер в национальном формате.
    • Адрес сервера - это IP адрес вашей АТС.
    • Логин и Пароль - данные для доступ к АТС.

    Примечание. Для подключения некоторых облачных АТС требуется указание дополнительных параметров авторизации. Они доступны по ссылке Дополнительные поля: пользователь для авторизации (указываются данные из поля auth user в настройках облачной АТС) и прокси-сервер (указываются данные из поля sip outbound proxy в настройках облачной АТС).

    Нажмите Подключить. Данные сохранятся, система перейдёт к настройкам маршрутизации.

    Подключение АТС происходит не сразу, оно проходит несколько статусов:

    • в обработке: Идет процесс подключения, через несколько минут вы сможете принимать входящие вызовы.
    • получение данных: Идет процесс получения данных о текущем статусе, пожалуйста, подождите.
    • ошибка: Во время подключения произошла ошибка. В первую очередь, проверьте корректность указанных вами параметров подключения. Причину ошибки можно увидеть, если навести курсор мыши на слово ошибка. Появится сноска с информацией. Вам необходимо передать эту информацию своему оператору АТС, чтобы решить проблему.

    Примечание: Настройка телефонии через MANGO требует изменения настроек в личном кабинете Манго Офис. Подключение Мегафона, требует использование услуги Мультифон.

    Настройки Firewall локальной сети

    По умолчанию для SIP используется порт 5060, а для медиа (RTP) 10000-20000 порты. Однако универсальную рекомендацию дать сложно, так как порт 5060 может быть как TCP, так и UDP. Это зависит от существующих настроек локальной сети.

    Обычно для SIP важно, чтобы исходящий трафик был разрешен (с АТС например), а входящие коннекты будут работать автоматически. RTP обычно используется как UDP (чтобы могли теряться пакеты и при этом данные продолжали передаваться)

    Сами порты можно настраивать в свойствах АТС: какой там задан, такой нужно открывать и в Firewall.


Подключение Mango АТС
351 / 401

Использование облачной АТС Mango в Битрикс24 требует дополнительных настроек в личном кабинете Манго Офис.

  1. Зайдите в личный кабинет Манго Офис и в разделе Мои продукты и выберите виртуальную АТС, которую необходимо подключить к вашему порталу.

  2. В настройках АТС, в разделе Настройка SIP > Безопасность установить флажок в Свободный доступ. Соединения по протоколу SIP возможны с любых IP-адресов.

  3. Необходимо создать нового сотрудника (ссылка Сотрудники и группы).

    В открывшейся форме:

      нажимаем Добавить сотрудника и заполняем форму:

    • Фамилия и имя сотрудника - любое название, например, Интеграция с Битрикс24;
    • Внутренний номер - присваивается автоматически;
    • Выберите на что принимать звонки - значение на софтфон (компьютер) и не создавать учетную запись, я настрою ее самостоятельно;
    • Выберите линию для исходящих звонков - в выпадающем меню выберите ту линию, которая будет подключена к Битрикс24, т.е. на которую будут приходить звонки.
    И сохраните запись.
  4. В списке Сотрудники и группы появится только что созданная запись. Нажмите по этой записи для создания учетной записи SIP.

    В открывшейся форме:

    • Разрешать вход в личный кабинет по учетным записям SIP - отключить флажок
    • Нажать Создать в Учётные записи SIP. Откроется форма настроек записи SIP:

    • Адрес - произвольное значение.
    • сервер - выбрать используемый сервер.
    • пароль - произвольный пароль.
      • Внимание! указанные данные, нужно запомнить. Их нужно будет указать их на странице подключения АТС в Битрикс24.

      Сохраните запись

    В закладке Телефония выберите исходящий номер для совершения звонков.

    Сохраните все настройки.
  5. Вернитесь на главную страницу Личного кабинета и выберите Обработка входящих звонков > Распределение звонков, приветствие, голосовое меню.

  6. На вкладке Настройки для входящих линий укажите номер, выбранный раннее при настройке учетной записи SIP.
  7. Здесь же удалите все правила обработки кроме Отбой.
  8. Создайте новое правило (Добавить) типа Переадресация.

    В форме создания правила нужно указать ранее созданного сотрудника Интеграция с Битрикс24:

    Сохраните правило.

Настройки в Манго офис завершены.

При настройке облачной АТС в Битрикс24:

  • Название подключения - любое значение, которое будет отображаться в списке доступных номеров при настройке.
  • Адрес сервера - значение, которое было выбрано на 6 шаге в поле SIP-адрес после знака @.
  • Логин - значение, которое было указано в поле SIP-адрес перед знаком @
  • Пароль - пароль для учетной записи SIP.

Если все данные указаны корректно и статус подключения подтверждает, что интеграция настроена , вы можете приступить к детальной настройке: маршрутизации звонков, очереди, проверке номера по базе CRM и т.д.


Подключение Новой телефонии (Ростелеком)
352 / 401

Перед подключением необходимо настроить Asterisk (freepbx, Elastiks) на работу в локальной сети.

Для подключения Новой телефонии от Ростелеком как облачную АТС создайте Extension с произвольным именем. например 101. В этом Extention, если используется NAT, пропишите в NAT Mode или Force Rport или Automatic Force boot.DTMF Signaling - пропишите auto.

Создайте транк (Trunks), где пропишите:

Trunk Name +7ХХХХХХХХХХ
Outbound CallerID +7ХХХХХХХХХХ

Где ХХХХХХХ ваш номер.

В секции Outgoing имя транка 8ХХХХХХХХХХ.

В секции Pear Details укажите:

username=пользователь в Ростелекоме
type=peer
trustrpid=yes
sendrpid=no
secret=ваш пароль от пользователя в Ростелекоме
insecure=port,invite
host=адрес сервера
fromuser=пользователь в Ростелекоме
fromdomain=адрес сервера Ростелекома
dtmfmode=auto
disallow=all
context=from-trunk
allow=alaw&ulaw&gsm

В секции incoming укажите имя from-trunk.

В секции User Details всё удалите.

В секции Registration поле Register string укажите: пароль от пользователя в Ростелекоме@адрес сервера/7номер телефона.
Пример:
user1:password@******.**.rt.ru/7ХХХХХХХХХХ.

В настройках телефонии Битрикс24, создайте подключение к облачной АТС, где:

  • Название подключения - любое;
  • Адрес сервера - IP Extension Asterisk'а;
  • Логин - логин Extension;
  • Пароль - пароль Extension.

Примечание: Если будут проблемы при использовании NAT - проверьте iptables и ваш роутер.


Подключение Мегафона
353 / 401

Мегафон позволяет подключиться по двум услугам: Мультифон и Виртуальная АТС. Для пользователей Битрикс24 есть разница в использовании: в услуге Мультифон есть ограничения, связанные с самим сервисом компании Мегафон.

Услуга Мультифон

Внимание! На данный момент у оператора Мегафон есть проблемы с совместимостью с АТС Мультифон при интеграции. В результате чего не работают исходящие звонки.

Подключение телефонии от Мегафона возможно с помощью сервиса Мультифон от этого провайдера. Эта услуга представляет собой, фактически, многоканальную IP-телефонию для клиентов Мегафон.

Настройки Мегафона

Прежде всего, необходимо подключить услугу Мультифон к вашему существующему номеру Мегафон. Как это сделать узнайте на странице этой услуги на сайте Мегафона. Рекомендуется способ подключения через USSD-команду *137#. В ответной sms прийдёт пароль для дальнейшей настройки.

Настройки в Битрикс24

Воспользуйтесь кнопкой Подключить облачную АТС. И заполните поля формы для подключения, используя данные из настроек SIP Мультифона (отображены в инструкции Мегафона):

Где:

  • Название подключения - Произвольное название соединения. Необязательное поле.
  • Адрес сервера - это IP адрес вашей АТС.
  • Логин - номер подключаемого телефона.
  • Пароль - пароль, полученный по sms.

Нажмите Подключить. Данные сохранятся, система перейдёт к настройкам маршрутизации.

Подключение АТС происходит не сразу, оно проходит несколько статусов:

  • в обработке: Идет процесс подключения, через несколько минут вы сможете принимать входящие вызовы.
  • получение данных: Идет процесс получения данных о текущем статусе, пожалуйста, подождите.
  • ошибка: Во время подключения произошла ошибка. В первую очередь, проверьте корректность указанных вами параметров подключения. Причину ошибки можно увидеть, если навести курсор мыши на слово ошибка. Появится сноска с информацией. Вам необходимо передать эту информацию своему оператору АТС, чтобы решить проблему.

Корпоративная услуга Виртуальная АТС

Необходимо активировать корпоративную услугу Виртуальная АТС от Мегафона.

Внимание! После подключения Виртуальной АТС отключается услуга Мультифон!

АТС создается со своим поддоменом: domain.megapbx.ru. При создании логина (вида login@domain.megapbx.ru) используйте минимум 2 символа. На данный момент проверка при авторизации "Виртуальная АТС" не даст авторизоваться пользователям с логином длиной менее чем в 2 символа (например, x@domain.megapbx.ru).

Для настройки телефонии в Битрикс24 используйте следующие данные:

  • адрес сервера: domain.megapbx.ru
  • логин: login (без @domain.megapbx.ru)
  • пароль: password


Подключение SIPNET
354 / 401

Настройки на SIPNET

В кабинете SIPNET перейдите в раздел меню Мои услуги > Управление звонками и выставите пункт Никогда не переадресовывать звонки, после чего сохраните внесенные изменения.

После этого перейти в раздел меню Мои услуги > Запись звонков и проверить отсутствие галок пунктов исходящих и входящих звонков. После этого сохраните изменения.

Внимание! При подключении SIPNET к Bitrix24 никогда не включайте в настройках SIPNET запись звонков. Это является причиной некорректной связи, а именно, при входящей связи звонящий не услышит ни голос менеджера, ни даже автоответчика. При этом в детализации звонков Битрикс24 аудиозапись будет вполне нормальной и с голосами обеих сторон.

Настройки в Битрикс24

Для настройки подключения используйте следующие данные:

  • Название подключения - любое
  • Адрес сервера - sipnet.ru
  • Логин - ваш логин от SIPNET (SIP-номер)
  • Пароль - пароль от учетной записи SIPNET


Подключение Дом.ru
355 / 401

Действия по подключению облачной АТС Дом.ru имеет свои особенности.

  • Необходимо написать заявление в Дом.ru с просьбой зарегистрировать IP-адрес 69.167.178.6. Это IP-адрес оператора Voixplant, через который осуществляется связь с Битрикс24. Как правило, доступ к облачной АТС имеет только ваш офисный IP-адрес, а подключение через стороннюю программу облачная АТС блокирует. Это делается через вашего курирующего менеджера Дом ру.

    Внимание! Указанный IP-адрес может быть изменён компанией Voixplant без каких либо уведомлений.

  • Обратиться после этого в техподдержку Дом.ru и попросить подключить одну или несколько внутренних линий к звонкам через данный IP.

    Внимание! Одна внутренняя линия не может быть зарегистрирована на два разных IP.

  • Далее необходимо получить данные для настройки облачной АТС в Битрикс24.

    Адрес сервера. В информационном листке (Облачная АТС > Настройки > Информационный листок) есть ссылка на файл, в котором указаны IP-адреса вашего региона. Из всего списка выберите любой из них и используйте его при настройке облачной АТС в Битрикс24.

    Пароль - значение для этого поля - это поле Пин-код в Учётных данных сотрудника:

    Логин - значение для поля составное, вида: _внутренний_номер_$_название_атс_. Где "внутренний номер" - это трёхзначный код с одноимённого поля в Учётных данных сотрудника, "название атс" - это значение поля АТС в вашем личном кабинете:

    Например: 201$erteleko_4606812.

  • Используйте эти данные при настройке облачной АТС


Подключение МТТ Бизнес
356 / 401

Настройки МТТ Бизнес

Для интеграции с Битрикс24 можно использовать существующее рабочее место (SIP ID), либо создать для этих целей новое.

  • В Личном Кабинете администратора выберите: Настройки > Рабочие места > Создать рабочее место.
  • В открывшемся окне задайте имя (в примере: Битрикс24), и выберите номер, который будет определяться при звонке из вашего портала.
    • По умолчанию - номер определяется настройками лицевого счета.
    • конкретный номер - один из приобретенных на лицевой счет или добавленных в качестве определяемых по запросу.

Для настройки входящих звонков перейдите в раздел «Входящая связь» и настройте переадресацию номера, который вы хотите использовать в Битрикс24:

  • Выберите пункт На рабочее место:

  • Выберите рабочее место, настройки которого вы будете использовать при интеграции с сервисом Битрикс24, например, созданное выше рабочее место Битрикс24.
Внимание! Для использования исходящей телефонии в Битрикс24 необходимо оплатить подключение SIP Коннектора.

Настройки Битрикс24

При настройке Облачной АТС в вашем портале используйте данные, полученные в настройках рабочего места МТТ Бизнес. Из настроек рабочего места:

в Битрикс24:


Решение проблем с телефонией и видеозвонками
357 / 401

При решении проблем с видео и аудио связью нужно понимать что связь - многофакторная система, проблема может быть на самом разном уровне. Виноваты могут быть и оператор связи (Voixplant), и сети (локальные и Web), и конечное оборудование клиента и так далее. Оптимальный способ поиска проблемы - поочерёдная проверка всех составляющих этого процесса.

Примечание: Компания 1c-Битрикс не является оператором связи и не отвечает за качество работы IP-телефонии.

Ниже приведены несколько методов проверки элементов связи и описание процессов, происходящих при звонках. Надеемся, что это поможет при решении проблем.

Проверка настроек локальной сети

В любом случае нужно начать поиск проблем с проверки настроек локальной сети, файерволлов и антивирусов. Важно помнить, что в случае телефонии нужно отслеживать актуальность IP-адресов по требованиям от Voximplant'а. Эти требования периодически меняются, компания Битрикс отслеживает эти изменения. Таблица адресов и портов, которые должны быть открыты на главной странице раздела Телефония всегда актуальна.

Логи Битрикс24

Одним из инструментов анализа связи могут быть логи, которые ведёт Битрикс24. Логи можно просмотреть в колонке Журнал по ссылке Детализация на странице Баланс и статистика.

Примечание: При использовании Битрикс24 в коробке необходимо для ведения логов в настройках NGINX установить параметр proxy_ignore_client_abort on;.

Как проверить качество связи между двумя конкретными пирами в реальной сетевой обстановке

Иногда при выяснении причин плохой связи при видеозвонках подозрение падает на особенности клиентского оборудования - гарнитуру, камеру, особенности драйверов и тому подобного. Например, клиент жалуется: "со временем звук начинает хрипеть, а затем и вовсе пропадает, хотя видео едет". Одна из возможных причин: проблемы гарнитуры пользователя. Вот в этом случае можно запустить у того же клиента Десктопное приложение в тестовом режиме с тестовым медиа (исключающим влияние не корректно работающей гарнитуры) и запустить ещё один сеанс связи с тем же собеседником. Если в этом режиме связь не пропадает, то подозрение укрепляется. Если пропадает все равно, то дело скорее всего в NAT/Firewall, некорректно работе WebRTC, TURN и так далее, и гарнитуру менять бесполезно.

Есть способ протестировать связь теми же участниками, но с "виртуальными" медиаустройствами, исключающими влияние реального медиа-оборудования, и таким образом подтвердить или опровергнуть подозрения.

Для этого запустите Bitrix24.exe (десктопное приложение) с ключом --use-fake-device-for-media-stream:

Bitrix24.exe --use-fake-device-for-media-stream

При запуске с ключом встроенный Chrome будет сам генерировать тестовое видео и аудио. Видео покажет динамически закрашиваемый круг и счетчики, а аудио будет передавать периодический тоновый сигнал.

Либо можно организовать трансляцию аудио и видео из файлов для тестирования с более сложным медиа-потоком:

Bitrix24.exe --use-fake-device-for-media-stream --use-file-for-fake-video-capture="waterfall_cif.y4m" --use-file-for-fake-audio-capture="a2002011001-e02.wav"

К тестовым файлам есть особые требования: видео в формате y4m, аудио в формате wav с дискретизацией 44.1 КГц.

Если тестовые файлы отображаются и озвучиваются хорошо, то это говорит о проблемах с оборудованием.

Настройки мессенджера

Кроме технических проблем с оборудованием возможна некорректная настройка мессенджера. В этом случае:

  • Нужно зайти в настройки мессенжера, вкладка Оборудование.
  • Явно выбрать нужную гарнитуру и нажать сохранить изменения.
  • Либо попробовать убрать флажок Автоматически регулировать параметры микрофона и сохранить изменения.

Проблемы при переводе звонка через sip-аппарат

Если есть проблемы при переводе звонка через sip-аппарат, то в решении этих проблем может помочь знание того, как происходит переадресация звонка через аппарат.

В переадресации участвуют три стороны:

  1. Тот, кто переводит (Transferor)
  2. Кого переводит (Transferee)
  3. На кого переводят (Transfer target)

В момент совершения переаресации sip-аппарат обменивается рядом sip-сообщений с оператором связи Voximplant. По результатам этого обмена Voximplant:

  • объединяет медиа-потоки Transferree и Transfer target
  • разъединяет медиа-потоки Transferree и Transferor
  • во все три плеча отправляет событие CallEvents.TransferComplete с указание роли этого плеча в переводе.

Если в журнале звонка данное событие отсутствует (и клиент нажимает правильные кнопки для перевода), то:

  • либо у клиента аппарат формирует нестандартные сип-команды,
  • либо у клиента какие-то сетевые проблемы.

В этом случае, лог такого звонка надо отправлять в техподдержку Битрикс24, разобраться что именно приходило от аппарата клиента, может только оператор связи Voximplant.


Открытые линии
358 / 401

Открытые линии - способ коммуникации с клиентами компании, посетителями сайта, с помощью которого собираются сообщения из разных каналов (мессенджеры, соцсети) в Битрикс24, распределяются по правилам очереди между сотрудниками и незаметно сохраняются в CRM.

Где можно использовать Открытые линии:

  • Предпродажные консультации клиентов через цифровые каналы.
  • Поддержка продаж через онлайн-чат на сайте, соцсети и мессенджеры.
  • Поддержка клиентов (одноуровневые и многоуровневые).
  • Дополнительный источник лидов для CRM.
  • Повторные продажи по данным в CRM.


Как работают Открытые линии
359 / 401

Как работают Открытые линии:

  • Вы подключаете к Открытой линии свои группы Вконтакте, страницы Facebook, бота в Telegram, бoта Битрикс24.Network, онлайн-чат на сайте и другие цифровые каналы.
  • Сообщения от клиентов этих каналов поступают в Открытую линию в Битрикс24 и распределяются по правилам очереди между сотрудниками в режиме реального времени.
  • Сотрудники видят вопросы клиентов в Бизнес-чате Битрикс24, отвечают там, а клиенты получают ответ там, где задали вопрос - Вконтакте, Facebook, Telegram-е, в своем Бизнес-чате или в чате на сайте.
  • Контакты клиентов и история общения с ними автоматически сохраняются в CRM. Если вопрос поступает от клиента, который уже есть в CRM, он попадет напрямую менеджеру, ответственному за этого клиента.

Маршрутизация и очередь:

  • Для каждой открытой линии назначается своя очередь из сотрудников, которые отвечают на вопросы клиентов.
  • Распределение сообщений идет строго по очереди или равномерно.
  • Сообщение можно перенаправить в другую Открытую линию или другому сотруднику.
  • К диалогу с клиентом можно подключить других сотрудников (в открытом или в скрытом режиме).
  • Сообщения без ответа возвращаются обратно в очередь (автоматически через указанное время или вручную).
  • Если у сотрудника не начат рабочий день или перерыв, сообщение ему отправлено не будет.

CRM работает незаметно:

  • Контакты нового клиента автоматически фиксируются в CRM как новый лид.
  • История переписки сохраняется в карточке клиента.
  • Вопрос от клиента, который есть в базе CRM, поступит ответственному менеджеру.
  • У вас есть вся статистика обращений через открытые линии для анализа уровня удовлетворенности ваших клиентов.


Управление открытыми линиями
360 / 401

Управление открытыми линиями на портале происходит на одноименной странице (пункт главного меню портала Открытые линии > Список):

Справа от каждой Открытой линии выводятся ее данные:

  • Дата создания
  • Дата и автор последнего редактирования линии
  • Количество созданных Лидов
  • Подключенные каналы
  • Ссылка на Статистику данной линии
  • Количество операторов в очереди
  • Кнопки редактирования и включения/отключения линии

Краткая статистика показывает:

  • всего обращений
  • сколько из них закрыто
  • сколько в работе
  • всего сообщений

Создание Открытой линии

Чтобы создать новую Открытую линию, нужно нажать на кнопку Создать открытую линию:

Далее откроется страница Настройка открытой линии.

Редактирование настроек Открытой линии

Чтобы отредактировать настройки Открытой линии, нужно кликнуть на названии линии или нажать на кнопку Редактировать:

Чтобы удалить Открытую линию, нужно нажать на крестик справа.


Создание открытой линии на портале
361 / 401

Внимание! Производить настройку Открытых линий может пользователь с правами администратора портала.

Примечание: Количество Открытых линий в облачном сервисе Битрикс24 зависит от тарифного плана, а в коробочной версии Битрикс24 это количество - не ограничено.

Внимание! Особенности подключения каналов открытых линий для продуктов «1С-Битрикс»:
  1. Облачный сервис Битрикс24: все настройки привязаны к доменному имени портала. При смене домена портала через Техподдержку, нужно будет заново настроить каналы открытых линий.
  2. Битрикс24 в коробке: все настройки привязаны к лицензионному ключу, который должен быть обязательно активен. При смене его на другой, настройки каналов открытых линий сбрасываются.

    При неактивном лицензионном ключе:

    • Настраивать и создавать Открытые линии можно без ограничений.
    • Онлайн-чат работает без ограничений.
    • Каналы коммуникаций исчезают из виджета CRM.
    • Сообщения на портал из настроенных каналов продолжают приходить.
    • Настроить каналы нельзя - будет выдаваться ошибка (кроме Онлайн-чата).
    • Нельзя ответить на сообщения - они не доставляются.

Для настройки открытых линий в публичной части необходимо:

Перейти в раздел Управление открытыми линиями (пункт главного меню портала Открытые линии > Список) и нажать на кнопку Создать открытую линию:

Далее откроется страница Настройка открытой линии, разделенная на группы опций:

  • Открытые линии - общие настройки

    Здесь указывается Название линии, которое будет видно вам в чате (клиент этого не увидит), и показываются Каналы. К каждой Открытой линии можно подключить несколько каналов. Иконка подключенного канала будет цветной.

  • Маршрутизация обращения

    1. Проверять клиента по базе CRM

      Если клиент найден в вашей CRM, то вопрос от него поступит напрямую ответственному за этого клиента. Даже если этого сотрудника нет в «Очереди».

      Если клиент не найден в CRM, то можно создать новый лид автоматически или вручную. В окне чата с клиентом будет ссылка для ручного создания лида, в этому случае в лид передадутся имя/фамилия клиента и история переписки в этом чате.

      Обратите внимание, что новый лид автоматически будет создан только при получении информации, необходимой для обратного обращения к клиенту. Если клиент обратился через соцсеть или внешний мессенджер (т.е. когда есть, куда обратно написать ответ), лид будет создан. Но, например, при подключения Онлайн-чата на сайт, клиент напишет там и уйдет с сайта, то обратно клиенту уже не написать, он просто никак не получит сообщение, поэтому такой лид CRM автоматически не зафиксирует.

      Также здесь выбирается Источник для нового лида. Если оставить в качестве источника нового лида Источник открытой линии, то при создании нового лида будет автоматически указан в CRM источник, откуда написал клиент: Facebook, Skype, Telegram и т.д.

    2. Очередь

      Здесь можно указать, кому из сотрудников будут поступать сообщения с открытых линий.

      Доступно несколько режимов очереди:

      • Равномерно - порядок сотрудников не имеет значения, обращения будут равномерно распределяться между сотрудниками в очереди.
      • Строго по очереди - порядок сотрудников имеет значение, каждое новое обращение будет направлено на первого сотрудника в очереди и только если он не ответит - на следующего.
      • Одновременно всем - обращения будут распределены на всех сотрудников в очереди (обратите внимание: в таком режиме активируется бесконечная очередь).

      Время до перехода к следующему сотруднику определяете вы сами из диапазона от 1 минуты до получаса. Можно также выбрать опцию Не направлять обращение на сотрудника, если не начат рабочий день или установлен перерыв.

      Опция При обращении клиента, назначить ответственным чат-бота позволяет сделать так, чтобы чат-бот выступал в качестве первой линии поддержки - сначала все сообщения будут поступать к нему, а только потом сотрудникам в очередь.

      Примечание: Данную опцию можно будет активировать только когда на портале установлен специальный чат-бот. Загрузить новых чат-ботов можно в магазине Приложения24.

      Обратите внимание, что в Очередь могут быть добавлены только бизнес-пользователи, количество которых зависит либо от тарифного плана облачного сервиса Битрикс24, либо от редакции коробочной версии Битрикс24.

    3. Обработка неотвеченного обращения

      Если никто из сотрудников не смог ответить на сообщение, то клиенту можно отправить автоматический ответ (например, с просьбой немного подождать), вернуть его сообщение обратно в очередь или ничего не делать. Стандартный текст сообщения можно изменить.

      Вернуть обратно в очередь означает, что сообщение клиента будет передаваться между сотрудниками в очереди, пока ему не ответят.

    4. Вся история сообщений сохраняется автоматически в чате и в карточке клиента. Дополнительно все фиксируется в статистике открытых линий, которая доступна администратору.

  • Настройка рабочего времени

    Вы можете задать рабочее время для Открытой линии: часовой пояс, время работы, выходные и праздничные дни.

    Если сообщение пришло в нерабочее время, клиенту можно отправить автоматический ответ (вы сами пишите текст) или ничего не делать.

  • Настройка действий

    Здесь можно задать приветственное сообщение - текст вы также можете написать свой или воспользоваться тем, что уже задан.

    После завершения диалога тоже можно отправить сообщение клиентам, например, попросить оценить качество обслуживания.

    Диалог в чате можно завершать автоматически. Например, если клиент долго не отвечает. И точно также выбрать какие действий нужно выполнить.

  • Подключение каналов коммуникаций

    Сейчас уже можно подключить следующие мессенджеры и социальные сети:

    • Онлайн-чат
    • Битрикс24.Network
    • Viber
    • Telegram
    • Вконтакте
    • Facebook: Сообщения
    • Facebook: Комментарии
    • Instagram
    • Microsoft Bot Framework (Skype, Slack, Kik, GroupMe, SMS, Office365, email и др)

    Список будет расширяться, как только другие мессенджеры откроют свой API.

  • Ошибки подключения каналов

    При возникновении ошибок подключения каналов есть справа ссылка Обновить, позволяющая перерегистрировать каналы портала на сервере коннекторов:

    Примечание: В продукте Битрикс24 в коробке нужно в первую очередь проверить в настройках модуля верность указания доменного имени с протоколом и убедиться, что данный адрес доступен из Интернета.

    • После подключения каналов все обращения клиентов будут приходить в ваш Бизнес-чат на портале и обрабатываться в соответствии с настройками.


Подключение каналов открытых линий
362 / 401

Внимание! Производить настройку Открытых линий может пользователь с правами администратора портала.

Примечание: Количество Открытых линий в облачном сервисе Битрикс24 зависит от тарифного плана, а в коробочной версии Битрикс24 это количество - не ограничено.

Внимание! Особенности подключения каналов открытых линий для продуктов «1С-Битрикс»:
  • Облачный сервис Битрикс24: все настройки привязаны к доменному имени портала. При смене домена портала через Техподдержку, нужно будет заново настроить каналы открытых линий.
  • Битрикс24 в коробке: все настройки привязаны к лицензионному ключу. При смене его на другой, настройки каналов открытых линий сбрасываются.

Внимание! Если не удается подключить каналы и происходит ошибка, то нужно:
  • Облачный сервис Битрикс24: нажать ссылку Обновить. Нажатие этой ссылки приводит к перерегистрации портала на сервере коннекторов.
  • Битрикс24 в коробке: в первую очередь в настройках модуля Коннекторы для внешних мессенджеров проверить верность указания доменного имени с протоколом и убедиться, что данный адрес доступен из интернета..


Подключение Онлайн-чата
363 / 401

Онлайн-чат позволяет коммуницировать с клиентами с любой публичной страницы сайта или портала. Можно подключить к отрытой линии публичную страницу с чатом компании, а ссылку на эту страницу использовать в качестве подписи в письме, указать на визитке или просто делиться ссылкой на чат в социальных сетях и других сервисах.

Для подключения необходимо:

  • Выбрать канал подключения Онлайн-чат, нажать кнопку Подключить:

  • Откроется страница с детальной настройкой Онлайн-чата:

    Здесь можно задать Публичную ссылку на чат на вашем портале Битрикс24, нажать кнопку Копировать для копирования адреса в буфер обмена. Далее с помощью кнопки Сохранить нужно сохранить настройки адреса публичной страницы с чатом.

    Технически, этого достаточно, чтобы Онлайн-чат заработал и чтобы сотрудник мог получать сообщения со страницы чата.

  • Также можно задать дополнительные настройки, чтобы ваша страница выглядела красивее:

    • Вид чата - можно загрузить картинку, которая будет установлена фоном на публичной странице с чатом.
    • Свой CSS - можно указать Путь к CSS-файлу на внешний ресурс или добавить в поле Текст CSS код своего css-стиля.
    • Подпись - опция позволяет показывать или прятать логотип «Работает с Битрикс24» внизу страницы.
    • Виджет на сайт - можно скопировать данный код виджета на страницу своего собственного сайта, не относящегося к вашему порталу, например сайт компании.
  • Настройка Онлайн-чата закончена:

    Для повторной настройки канала Онлайн-чат нужно кликнуть на ссылку Изменить, для удаления канала - Отключить.

Клиент заходит на публичную страницу, которую вы настроили и общается с оператором:

У оператора весь диалог происходит в Бизнес-чате на портале (в декстоп- и в мобильном приложении Битрикс24):

Внимание! Пользователь не сможет написать в онлайн-чат, если в браузере он уже авторизован на вашем портале Битрикс24. Ему нужно будет открыть онлайн-чат в другом браузере или выйти со своего аккаунта Битрикс24.

Внимание! Для подключения Открытых линий в коробочной версии Битрикс24 необходимо сделать предварительные настройки сервера и модулей портала.


Подключение Битрикс24.Network
364 / 401

Канал Битрикс24.Network позволяет создать открытую линию в сети Битрикс24.Network.

Клиент может найти канал через поиск в Бизнес-чате как по названию канала (если канал публичный), так и по специальному секретному коду, и подключиться к нему.

Для подключения необходимо:

  • Выбрать канал подключения Битрикс24.Network, нажать кнопку Подключить:

  • Откроется страница с детальной настройкой Онлайн-чата:

    • Название - название чата, которое будет отображаться у клиента в качестве Контакта. Выбирайте название чата точным и правильным, т.к по нему будет осуществляться поиск, и он будет отображаться в контакт-листе или в заголовке диалога с клиентом.
    • Краткое описание - краткое описание чата. Также будет видно клиенту в контакт-листе или в заголовке чата.
    • Приветственное сообщение - сообщение, которое получит в клиент после того, как напишет первое сообщение в чате.

      Примечание: В приветственном сообщении можно использовать placeholder - #USER_NAME#, тогда в сообщении будет обращение к клиенту по имени.

    • Аватар - можно загрузить свою иконку чата для удобства поиска клиентом вашего чата.
    • Доступен в поиске - если включена данная опция, то данный чат будет доступен в поиске контактов Бизнес-чата по Названию чата.
    • Код для поиска - указав данный код в поиске контактов Бизнес-чата, пользователь найдет вашу линию, даже если она не доступна в поиске, т.е если опция Доступен в поиске выключена. Вы можете организовать закрытую линию поддержки, убрав отображение ее в поиске.
  • Настройка канала Битрикс24.Network закончена:

    Для повторной настройки канала Битрикс24.Network нужно кликнуть на ссылку Изменить, для удаления канала - Отключить.

Клиент ищет в поиске контактов Бизнес-чата ваш чат - либо по Названию (если данный чат публичный), либо по известному ему секретному Коду для поиска:

И общается с оператором:

У оператора весь диалог также происходит в Бизнес-чате на портале (в декстоп- и в мобильном приложении Битрикс24):

Внимание! Для подключения Открытых линий в коробочной версии Битрикс24 необходимо сделать предварительные настройки сервера и модулей портала.


Подключение Telegram
365 / 401

Канал Telegram позволяет создать открытую линию c помощью чат-бота Telegram.

Внимание! Особенности подключения канала Telegram:
  1. На один аккаунт Telegram можно создать не более 20 чат-ботов.
  2. Файлы более 20 Мб не принимаются (из-за технического ограничения Telegram API). В этом случае соответствующий текст будет отправлен оператору. и он должен попросить клиента переслать файл иным путем.
  3. В случае, если одинаковый token был указан на нескольких порталах и/или облачных порталах, то работать будет только последний успешно подключенный портал. Остальные порталы отключаются и коннектор помечается как «аварийный».

Для подключения канала необходимо создать своего бота в Telegram или подключить уже существующего:

  • Если у вас еще нет бота, то его можно создать c помощью кнопки Создать новый бот. Следуя подробной инструкции, через несколько шагов вы получите token, который нужно будет ввести в соответствующее поле:

  • Если у вас есть чат-бот Telegram, но вы не знаете token, то нажмите кнопку Есть бот, узнать токен, инструкция поможет вам его получить:

  • Если у вас уже есть token чат-бота Telegram, то нажмите кнопку Я знаю токен и введите его в соответствующее поле:

    За кнопкой Я знаю токен скрывается форма настройки, где можно протестировать соединение и зарегистрировать бота (если это не произошло автоматически). Если удалось только сохранить данные, но тестирование не прошло: это означает либо, что токен указан не верно, либо что не удалось серверу коннекторов соединиться с порталом.

  • Настройка канала Telegram закончена:

    Для повторной настройки канала Telegram нужно кликнуть на ссылку Изменить, для удаления канала - Отключить.

Клиент в своем клиенте Telegram находит вашего чат-бота или заходит по прямой ссылке на чат-бот и общается с оператором:

У оператора весь диалог также происходит в Бизнес-чате на портале (в декстоп- и в мобильном приложении Битрикс24):

Внимание! Для подключения Открытых линий в коробочной версии Битрикс24 необходимо сделать предварительные настройки сервера и модулей портала.


Подключение Вконтакте
366 / 401

Канал Вконтакте позволяет создать открытую линию, используя публичную страницу в соцсети Вконтакте.

Внимание! Особенности подключения канала Вконтакте:
  1. Подключение происходит от имени пользователя Вконтакте, под аккаунтом которого сейчас авторизован администратор портала.
  2. При отключении пользователя, происходит автоматическое отключение группы Вконтакте от канала.
  3. Если пользователь потерял административные права доступа к группе Вконтакте, то при открытии страницы настроек канала произойдет его автоматическое отключение.
  4. Выводится список доступных групп, публичных страниц, мероприятий.
  5. Общение ведется только через Сообщение групп, публичных страниц, мероприятий, но не на Стене этих групп, страниц и мероприятий!
  6. Чтобы подключить группу, нужно быть авторизованным под тем же пользователем, который был привязан.
  7. В случае, если происходит подключение группы, которая была уже подключена где-то в Битрикс24 (не важно, облако или коробка), то на остальных порталах коннектор отключается и коннектор помечается как «аварийный».

Для примера подключим заранее созданную группу Вконтакте - Диваны&Диваны:

  • Нужно выбрать канал подключения Вконтакте, нажать кнопку Подключить:

  • Далее нужно авторизоваться под аккаунтом администратора группы Вконтакте:

    Внимание! Иногда при попытке подключения группы Вконтакте в браузере Chrome на этапе авторизации под пользователем в открывшемся окне можно наблюдать текст ошибки {«error»:«invalid_request»,«error_description»:«Security Error»}. Проблема возникает из-за старой сессии авторизации ВКонтакте в браузере Chrome. Для устранения нужно всего лишь перелогиниться в социальной сети:
    1. Заходим на VK.com, проходим авторизацию;
    2. Выходим из своего аккаунта путем нажатия кнопки «Выйти», справа вверху;
    3. Снова проходим авторизацию во ВКонтакте;
    4. Идем в настройки ОЛ, коннектор ВКонтакте и подключаем.

  • Соглашаемся на предоставление доступа приложения Bitrix24 Open Channels к вашему аккаунту Вконтакте:

  • Выбираем нужную группу из списка и жмем кнопку Подключить группу:

  • Соглашаемся на предоставление доступа приложения Bitrix24 Open Channels к группе Вконтакте:

  • Аналогичным образом подключаются публичные страницы и мероприятия Вконтакте.
  • Настройка канала Вконтакте закончена:

    Для повторной настройки канала Вконтакте нужно кликнуть на ссылку Изменить, для удаления канала - Отключить.

Клиент заходит в группу, публичную страницу или мероприятие Вконтакте, нажимает там кнопку Написать сообщение и общается с оператором:

Внимание! Общение ведется только через Сообщение в группе, на публичных страницах, мероприятиях, а не на Стене!

  • У оператора весь диалог также происходит в Бизнес-чате на портале (в декстоп- и в мобильном приложении Битрикс24):

    Открытые линии полностью поддерживают виджеты Вконтакте

    Вконтакте предлагает несколько виджетов, которые вы можете поставить на свой сайт, чтобы принимать сообщения в группу не только из Вконтакта, а напрямую с вашего сайта. Сейчас виджеты такие:

    • Написать сообщение (Напишите нам).
    • Сообщения группы.
    • Написать продавцу (для товара, когда можно со страницы товара отправить сообщение для группы).

    Все эти виджеты совместимы с открытыми линиями в Битрикс24. Для работы с ними ничего дополнительно настраивать не требуется. Если ваша группа Вконтакте уже подключена к Открытым линиям, то виджет автоматически заработает. Если нет, нужно просто подключить канал Вконтакте обычным способом.

    Все виджеты настраиваются на стороне Вконтакте.

    Пример, как будет выглядеть виджет группы на сайте:

    И при диалоге:

    Внимание! Для подключения Открытых линий в коробочной версии Битрикс24 необходимо сделать предварительные настройки сервера и модулей портала.


Подключение Facebook: Сообщения
367 / 401

Канал Facebook: Сообщения позволяет создать открытую линию, используя функционал Сообщения на публичной странице в соцсети Facebook.

Внимание! Особенности подключения канала Facebook: Сообщения:
  1. Подключение происходит от имени пользователя Facebook, под аккаунтом которого сейчас авторизован администратор портала.
  2. При отключении пользователя, происходит автоматическое отключение публичной страницы Facebook от канала.
  3. Если пользователь потерял административные права доступа к публичной странице Facebook, то при открытии страницы настроек канала произойдет его автоматическое отключение.
  4. Выводится только список доступных публичных страниц! Группы и другие сущности подключить к отрытой линии нельзя!
  5. Общение ведется только через Сообщение на публичной странице, а не на Стене этой страницы!
  6. После авторизации под пользователем Facebook, теперь любой администратор портала Битрикс24, имеющий доступ к настройкам открытых линий, может подключать и отключать публичные страницы.
  7. Авторизация под пользователем «живет» только 60 дней, если не менять настройки подключения, то чат будет продолжать работать. Но для изменения настроек после истечения периода 60 дней нужно повторно авторизоваться под этим же пользователем.
  8. В случае, если происходит подключение публичной страницы, которая была уже подключена где-то в портале Битрикс24 (не важно, облако или коробка), то на остальных порталах коннектор отключается и помечается как «аварийный».

Для подключения канала необходимо:

  • Выбрать канал подключения Facebook: Сообщения, нажать кнопку Подключить страницу:

    Внимание! Вы должны являться администратором этой страницы.

  • Далее нужно авторизоваться под аккаунтом администратора публичной страницы Facebook:

  • Согласиться на предоставление прав приложению Bitrix24 Open Channels к странице Facebook:

  • Если у вас нет ни одной публичной страницы Facebook, то с помощью кнопки Создать вы перейдете к созданию страницы Facebook:

  • Если у вас уже есть публичные страницы Facebook, то будет выведен их список. Выбираем нужную страницу и жмем кнопку Подключить страницу:

  • Настройка канала Facebook: Сообщения закончена:

    Для повторной настройки канала Facebook: Сообщения нужно кликнуть на ссылку Изменить, для удаления канала - Отключить.

Клиент заходит на вашу публичную страницу в Facebook, выбирает функционал Сообщение и общается с оператором:

Внимание! Общение ведется только через Сообщение на публичной странице, а не на Стене этой страницы!

У оператора весь диалог также происходит в Бизнес-чате на портале (в декстоп- и в мобильном приложении Битрикс24):

Внимание! Для подключения Открытых линий в коробочной версии Битрикс24 необходимо сделать предварительные настройки сервера и модулей портала.


Подключение Facebook: Комментарии
368 / 401

Канал Facebook: Комментарии позволяет создать открытую линию, используя функционал комментариев к постам на публичной странице в соцсети Facebook.

Внимание! Особенности подключения канала Facebook: Комментарии:
  1. Подключение происходит от имени пользователя Facebook, под аккаунтом которого сейчас авторизован администратор портала.
  2. При отключении пользователя, происходит автоматическое отключение публичной страницы Facebook от канала.
  3. Если пользователь потерял административные права доступа к публичной странице Facebook, то при открытии страницы настроек канала произойдет его автоматическое отключение.
  4. Выводится только список доступных публичных страниц! Группы и другие сущности подключить к отрытой линии нельзя!
  5. Общение ведется только через комментарии к постам на Стене этой публичной страницы.
  6. После авторизации под пользователем Facebook, теперь любой администратор портала Битрикс24, имеющий доступ к настройкам открытых линий, может подключать и отключать публичные страницы.
  7. Авторизация под пользователем «живет» только 60 дней, если не менять настройки подключения, то чат будет продолжать работать. Но для изменения настроек после истечения периода 60 дней нужно повторно авторизоваться под этим же пользователем.
  8. В случае, если происходит подключение публичной страницы, которая была уже подключена где-то в портале Битрикс24 (не важно, облако или коробка), то на остальных порталах коннектор отключается и помечается как «аварийный».

Для подключения канала необходимо:

  • Выбрать канал подключения Facebook: Комментарии, нажать кнопку Подключить страницу:

    Внимание! Вы должны являться администратором этой страницы.

  • Далее нужно авторизоваться под аккаунтом администратора публичной страницы Facebook:

  • Согласиться на предоставление прав приложению Bitrix24 Open Channels Comments к странице Facebook:

  • Если у вас нет ни одной публичной страницы Facebook, то с помощью кнопки Создать вы перейдете к созданию страницы Facebook:

  • Если у вас уже есть публичные страницы Facebook, то будет выведен их список. Выбираем нужную страницу и жмем кнопку Подключить страницу:

  • Настройка канала Facebook: Комментарии закончена:

    Для повторной настройки канала Facebook: Комментарии нужно кликнуть на ссылку Изменить, для удаления канала - Отключить.

Клиент заходит на вашу публичную страницу в Facebook, пишет комментарий к посту и общается с оператором:

Внимание! Общение ведется только через Комментарии на Стене публичной страницы!

У оператора весь диалог также происходит в Бизнес-чате на портале (в декстоп- и в мобильном приложении Битрикс24):

Внимание! Для подключения Открытых линий в коробочной версии Битрикс24 необходимо сделать предварительные настройки сервера и модулей портала.


Подключение Instagram
369 / 401

Открытые линии Битрикс24 позволяют собирать комментарии из социальной сети Instagram.

Внимание! Особенности подключения канала Instagram:
  1. Забираются только комментарии клиентов, т.е. сообщения, оставленные от имени подключенного аккаунта, не дублируются в портал. Это не может создать каких-либо сложностей, если вы отвечаете через свой Битрикс24.
  2. Комментарии забираются на портал не непрерывно, а каждые 15 минут.
  3. Забираются комментарии только к последним 99 постам.
  4. Комментарии начинают забираться только с момента подключения коннектора, поэтому более старые комментарии на портал не попадут.
  5. Отправлять с портала можно не более 60 ответных комментариев. Учитывайте, что в Instagram есть ограничение на размер комментария в 300 символов. Ответ, превышающий этот лимит, будет автоматически разделен на несколько сообщений, в зависимости от длины комментария.
  6. Ответный комментарий может содержать не более 4 хэштегов (т. е. слов, начинающихся с #) и 1 гиперсылки.
  7. Ответный комментарий не может состоять только из всех заглавных букв.

Рассмотрим пример подключения заранее созданного аккаунта Instagram.

  • Выберем канал подключения Instagram и нажмем кнопку Подключить:

  • Авторизуемся под нашим аккаунтом, соглашаемся на предоставление к нему доступа для Bitrix24:

  • Если авторизация прошла успешно, то наш аккаунт отобразится в форме:

  • После того, как аккаунт будет подключен, полученный комментарий отобразится в Бизнес-чате ответственного сотрудника. Сотрудник может либо Ответить на полученный комментарий, либо Пропустить его, либо Переадресовать другому сотруднику:

    Примечание: Удалять нежелательные сообщения можно также прямо из Бизнес-чата.

  • Сотрудник может оставлять свои сообщения в чате и они отобразятся в подключенном аккаунте Instagram:

    Важно! Общение происходит только через комментарии. Подключение к Instagram Direct не предусмотрено.

Внимание! Для подключения Открытых линий в коробочной версии Битрикс24 необходимо сделать предварительные настройки сервера и модулей портала.


Подключение Viber
370 / 401

Открытые линии Битрикс24 позволяют работать с публичными чатами Viber.

Внимание! Для работы открытых линий клиент Viber должен быть обновлен не ниже, чем до версии 6.5.

Внимание! Для управления лентой публичного аккаунта нужно использовать приложения Viber. Этот функционал никак не синхронизируется с Битрикс24.

Рассмотрим процесс подключения Viber к открытым линиям.

  • Выберем канал подключения Viber. Первым делом нам нужно зарегистрировать публичный аккаунт. Если вы уже регистрировались, то проверьте, нет ли кнопки добавления публичного аккаунта у вас в приложении.

  • Для начала необходимо перейти по ссылке и заполнить форму заявки:

    • Full Name - полное имя.
    • Viber Phone Number - необходимо указать номер телефона, на который зарегистрирован действующий аккаунт Viber. Этот аккаунт будет администратором создаваемого публичного аккаунта. Позже можно будет добавить других администраторов.
    • Email address - действующий адрес электронной почты.
    • Country - страна.
    • Согласитесь с лицензионными условиями.

    После отправки потребуется некоторое время на рассмотрение заявки. Как правило, все происходит в течение 10 минут. После того, как ваша заявка будет одобрена, вы получите соответствующее сообщение в свой Viber (только в мобильное приложение под iOS или android):

  • Теперь необходимо получить ключ подключения публичного аккаунта Viber к открытым линиям Битрикс24. Для начала необходимо создать сам публичный аккаунт.

    Как создать публичный аккаунт

    На Android

    На iOS

    Ключ можно найти в информации о публичном аккаунте.

    Как посмотреть информацию о публичном аккаунте

    На Android

    На iOS

    Полученный ключ необходимо ввести в соответствующее поле и нажать кнопку Сохранить.

  • Если введенный ключ верен, то вы перейдете к следующему шагу:

    Viber подключен к открытым линиям Битрикс24.

Внимание! Для подключения Открытых линий в коробочной версии Битрикс24 необходимо сделать предварительные настройки сервера и модулей портала.


Подключение Microsoft Bot Framework
371 / 401

Microsoft Bot Framework позволяет включить следующие каналы в Открытые линии: Skype, Slack, Kik, GroupMe, Twilio, Web Chat, E-mail, Telegram, Facebook Messenger, Direct Line.

Внимание! Особенности подключения каналов в Microsoft Bot Framework:
  1. Skype - автоматически создается при создании Microsoft Bot Framework. Не нуждается в дополнительной настройке. Создается бот. Боту могут писать только пользователи, имеющие обновленную версию Skype (более 7.27.66.101).
  2. Slack - создается бот Slack, который можно добавить к любой компании по ссылке.
  3. Kik - создается бот в мессенджере Kik, который можно добавить, отсканировав QR-код в приложении, полученный по ссылке.
  4. Groupme - создается бот, который можно добавить к разговорам только вашей компании, для которой он был создан. Нельзя использовать для общения с произвольными клиентами.
  5. Twilio - возможность получать смс в открытую линию и отвечать. Пользователю отправляется ответное смс. Поддерживается передача файлов. Актуально для США, так как выдается американский телефонный номер. Для ответа, аккаунт на Twilio должен быть оплачен.
  6. Веб-чат - можно разместить чат в произвольном месте сайта, используя код, выданный в подключении Microsoft Bot Framework.
  7. Электронная почта - получение почты в открытую линию и возможность отвечать, отправляя почтовые сообщения. Работает только с почтовыми ящиками, заведенными в рамках Office365!
  8. Telegram - подключение бота Telegram. Рекомендуется использовать коннектор Telegram, так как он имеет более глубокую интеграцию. Но данный канал в рамках Microsoft Bot Framework также поддерживается Открытыми линиями Битрикс24.
  9. Facebook messenger - коннектор Facebook, но с подключением на более низком уровне. Рекомендуем использовать коннектор Facebook: Сообщения. Чтобы данный коннектор полноценно заработал, нужно чтобы созданное приложение Facebook прошло модерацию.
  10. Directline - возможность самостоятельно подключить любой канал «из вне» и писать в открытую линию, а также получать ответные сообщения.
  11. В случае, если одинаковый Bot-handle был указан на нескольких порталах и/или облачных порталах, то работать будет только последний успешно подключенный портал. Остальные порталы отключаются и коннектор помечается как «аварийный».
  12. Microsoft Bot Framework нужно отправлять на модерацию для того, чтобы:
    • Бот появился в каталоге ботов: https://bots.botframework.com (можно отправить на модерацию без размещения).
    • Снять ограничение на 100 пользователей в боте Skype.

Для подключения канала необходимо создать своего бота в Microsoft Bot или подключить уже существующего:

  • Если у вас еще нет бота, то его можно создать c помощью кнопки Создать новый бот. Следуя подробной инструкции, через несколько шагов вы подключите бота к Открытой линии:

  • Если у вас есть Microsoft Bot и вы знаете Bot handle, Microsoft App ID и Секретный пароль приложения, то нажмите кнопку Есть бот, заполнить форму, инструкция поможет вам ввести эти данные в необходимые поля:

  • Настройка канала Microsoft Bot закончена:

    Для повторной настройки канала Microsoft Bot нужно кликнуть на ссылку Изменить, для удаления канала - Отключить.

По умолчанию при подключении Microsoft Bot к открытой линии создается бот Skype.

Для подключения остальных каналов, поддерживаемых Microsoft Bot, нужно перейти в раздел My bots и в группе каналов Add another channel подключить нужный канал.

Далее можно указать публичные ссылки на каналы, которые подключили на стороне Microsoft:

Чтобы они отображались в виджете (онлайн-чате) на сайте.

Клиент переходит по ссылке на нужный ему канал коммуникации (в примере - Skype), добавляет контакт бота себе в контакт-лист Skype и общается с оператором:

У оператора весь диалог также происходит в Бизнес-чате на портале (в декстоп- и в мобильном приложении Битрикс24):

Внимание! Для того, чтобы снять ограничение на 100 пользователей в боте Skype, нужно отправить бот на модерацию - заполнить описание бота и нажать кнопку Publish в разделе My bots. Бот появился в каталоге ботов: https://bots.botframework.com (можно отправить на модерацию без размещения).

Внимание! Для подключения Открытых линий в коробочной версии Битрикс24 необходимо сделать предварительные настройки сервера и модулей портала.


Виджет на сайт
372 / 401

Управление виджетами на портале происходит на странице Список виджетов (пункт главного меню портала Открытые линии > Виджет на сайт):

Справа от каждого Виджета выводятся его данные:

  • Дата создания
  • Дата и автор последнего редактирования виджета
  • Положение на странице
  • Отображение на странице

На самом Виджете отображаются подключенные каналы, если какой-то канал отключен, то он затенен:

  • Открытая линия
  • CRM-форма
  • Обратный звонок

Создание Виджета

Чтобы создать новый Виджет, нужно нажать на кнопку Создать виджет:

Далее откроется страница Создания Виджета.

Редактирование настроек Виджета

Чтобы отредактировать настройки Виджета, нужно или кликнуть на названии Виджета, или нажать на кнопку Редактировать, или выбрать одноименный пункт в меню Виджета:

Создать на основании позволяет создать копию выбранного Виджета с таким же настройками.

Чтобы удалить Виджет, нужно нажать на крестик справа.

Код на сайт

Чтобы поставить Виджет на сторонний сайт, то понадобится данный код. Скопируйте код и поместите его в код шаблона вашего сайта перед закрывающим тегом </body>.Код уникальный для каждого портала и виджета.


Права доступа
373 / 401

Примечание: Распределение прав доступа сотрудников к работе с открытыми линиями в облачном сервисе «Битрикс24» доступно в тарифах Команда и Компания.

Примечание: Для настройки прав доступа к открытым линиям необходимо права администратора портала.

Настройка доступа к Открытым линиям осуществляется на странице Права доступа (Главное меню > Открытые линии > Еще > Права доступа):

Права доступа к Открытым линиям выдаются на:

  • Список открытых линий - Просмотр\Изменение
  • Подключение каналов коммуникаций - Изменение
  • Статистика разговоров - Просмотр
  • История разговора - Просмотр
  • Подключение к разговору - Выполнение
  • Общие настройк - Изменение

На странице уже имеются предустановленные роли: Администратор, Директор и Менеджер. Администратор обладает максимальным количеством прав, Менеджер - минимальным:

Создать роль

С помощью ссылки Добавить в Списке ролей можно создать свою роль со своими параметрами (а также отредактировать или удалить имеющуюся роль):

Добавить право доступа

С помощью ссылки Добавить право доступа в можно задать своё распределение ролей (а также удалить имеющееся право). Права доступа можно назначить Группам пользователей, Пользователям, Сотрудникам и отделам и Группам социальной сети.:

Примечание: Если назначено несколько ролей, то реальные права доступа строятся по принципу объединения прав ролей, а не пересечения.


Детальная статистика
374 / 401

Примечание: Доступ к просмотру детальной статистики открытых линий регулируется правами доступа открытых линий. По умолчанию доступ на просмотр имеют роли: Администратор, Директор, Менеджер.

Детальная статистика открытых линий отображается на одноименной странице Главное меню > Открытые линии > Еще > Детальная статистика:

В таблице статистики отображается полная информация по всем чатам открытых линий всех сотрудников, доступна фильтрация по различным условиям и экспорт в Excel.

По ссылкам внутри таблицы статистики можно:

  • Посмотреть Историю переписки - это история диалога только выбранной сессии:

  • Открыть диалог - это история всего диалога, всех сессий с данным клиентом:

  • Если во время диалога контакт был занесен в CRM, то можно перейти в карточку лида:

Краткую статистику можно всегда посмотреть на странице Управление открытыми линиями (пункт главного меню портала Открытые линии > Список):

  • всего обращений
  • сколько из них закрыто
  • сколько в работе
  • всего сообщений


Чат-трекер
375 / 401

Одна из главных задач - это узнавать клиента. Битрикс24 поддерживает связь со многими каналами коммуникаций. Клиент может написать вам в любой: сегодня в ВКонтакте, завтра в Facebook, а через неделю в Онлайн-чате. Чат-трекер в Битрикс24 автоматически распознает клиента в любом из каналов, объединит все диалоги с ним в один профиль и сохранит в CRM.

Возможности Чат-трекера:

  • Автопоиск по тексту сообщения в чате Открытых линий: номер телефона, e-mail, имя/фамилия.
  • Автоматическое сохранение данных в CRM;
  • Если клиент не найден в базе, в CRM будет создан новый Лид.
  • Подсказки из CRM («богатые ссылки»): если клиента узнали, в чате появляется сводка о клиенте.

Как это работает

  1. Например, клиент пишет вам со страницы ВКонтакте. Автоматически создается Лид в CRM по имени и фамилии клиента:

    Нажмите на рисунок, чтобы увеличить

    Во время этого разговора клиент указывает телефонный номер, он также присоединяется в данный лид.
  2. Спустя некоторое время клиент связывается с вами через Facebook, система его уже узнает, клиент указывает e-mail, который автоматически добавляется в его карточку:

    Нажмите на рисунок, чтобы увеличить

  3. Затем клиент снова связывается с вами уже через Онлайн-чат, и здесь мы его опять узнаем по e-mail-у, который он оставил в разговоре:

    Нажмите на рисунок, чтобы увеличить

  4. А в CRM (CRM > Лиды > Список лидов > {Название лида}) мы видим, что автоматически создался лид со всеми контактами клиента, полученными из чата:

    Нажмите на рисунок, чтобы увеличить

Таким образом, все данные в чатах Открытых линий, позволяющие узнать клиента (имя и фамилия, телефонный номер, e-mail), автоматически записываются в карточку CRM, при этом сохраняется история разговора. Все это помогает узнать клиента при обращении в вашу компанию и позволит в дальнейшем правильно делать клиенту предложения.

Примечание: Для бесплатного тарифа Проект доступно 100 распознаваний в месяц.


Настройки портала
376 / 401

Настройки портала как сервиса включают в себя несколько моментов:

  • Собственно настройки портала;
  • Использование своего доменного имени;
  • Настройки двухэтапной авторизации;
  • Настройки файервола локальной сети;
  • Настройки почты.
  • Настройки Лицензии.
  • Настройки телефонии.
  • Настройки левого меню.
  • Настройки параметров рабочего дня;
  • Настройки списков (выполняются для каждого раздела);
  • Настройка персонального календаря;
  • Настройка рабочих групп;
  • Настройки CRM;
  • Интеграция с AD/LDAP и MS Exchange;

Примечание: При необходимости перехода с Битрикс24 на коробочную версию продукта «1С-Битрикс: Корпоративный портал» нужно будет также произвести определённые настройки.

Настройка файрвола локальной сети

Политика безопасности компании может ограничивать доступ в Интернет на все адреса, кроме разрешённых. Для полноценной работы сотрудников в сервисе Битрикс24 для них должны быть открыты:

  • *.bitrix24.ru
  • *.cloudfront.net
  • *.bitrix24.com (используются некоторые сервисы)
  • bitrix*.cdnvideo.ru
  • *.bitrix.info (для работы ботов, телефонии и открытых линий)
  • bitrix-client-backups.s3-eu-west-1.amazonaws.com


Настройки портала
377 / 401

Настройка портала как сервиса и контроль за его текущим состоянием выполняется на страницах раздела Настройки > Настройки портала, где можно внести изменения в название компании и переименовать кнопки голосования за контент, сменить электронную почту администратора, убрать из названия портала "24", добавить свой логотип, настроить параметры даты и времени и доступа к файлам через внешние сервисы и другие настройки.

Настройки

Секция настроек отвечающих за отображение данных на портале. Значения настроек понятны из их описания, но уточним некоторые нюансы:

  • Показывать надпись "24" в логотипе компании. Флажок у этой настройки отключит вывод надписи "24" в названии компании. Доступен только для платных (кроме Проект+ тарифов.).
  • Разрешить редактировать документы, которые участвуют в обсуждениях, задачах, комментариях или других событиях, всем участникам, по умолчанию. Флажок у этой настройки разрешит пользователям изменять документы. Это общая настройка для портала в целом, если она отключена, то редактирование запрещено на всём портале. В каждом отдельном событии есть своя опция по отключению редактирования.
  • Выходные и праздничные дни в году. Данные вводятся без пробелов, через точку. Между собой даты разделяются запятой: 1.01,2.01,7.01,23.02,8.03.
  • Тип вашей организации - выбор способа обращения к пользователям портала в меню, в заголовках, сообщениях. Доступны три варианта: для коммерческой организации, для различных тематических сообществ и для некоммерческих учреждений.
  • Просматривать документы с помощью - указание для портала службы, через которую будут просматриваться документы на странице публичной ссылки.
  • Разрешить редактировать документы - администратор имеет возможность отключить/включить для всего портала в целом опцию редактирования приложенных документов. При отключенной администратором возможности редактирования каждый автор сообщения, задачи и так далее, может разрешить редактировать документы в своём сообщении, задаче и так далее.
  • Автоматически подключать Диск группы при вступлении пользователя в группу. Опция позволит отключить автоматическое подключение папки группы, при вступлении в группу нового участника. Позволяет избежать большого трафика передачи файлов для новых участников группы.
  • Максимальное количество записей в истории документа - указание лимита хранимых на портале версий файла. При превышении этого количества старые версии файла автоматически удаляются.
  • Разрешать адресовать "Всем" сообщения в Живой ленте. По умолчанию писать сообщения "Всем" может любой пользователь портала. В этой настройке можно либо отключить возможность адресации сообщений на всех, либо ограничить число тех, кто обладает этим правом удалив ненужные группы и пользователей и добавив нужных.
  • Отображать адресацию "Всем" по умолчанию. Если есть ограничения на написание сообщения для всех пользователей, то есть смысл отключить адресацию "Всем" из формы написания сообщения. Это делается в этой настройке.
  • Разрешать отправлять сообщения в "Общий чат" - при включённой опции каждый пользователь портала может писать сообщения в Общий чат. Если необходимо ограничить эту возможность, то нужно снять флажок с опции и с помощью ссылки Добавить разрешить писать только нужным пользователям.
  • Включить богатые ссылки - разрешение на использование функционала богатая ссылка.
  • Разрешить быструю регистрацию - при включённой опции любой пользователь Bitrix.Network 2.0 может добавить себя на любой портал, чей адрес ему известен. После одобрения администраторами портала, пользователю откроется доступ на портал.
  • Разрешить всем приглашать пользователей на портал - разрешение на приглашение могут отправлять любые пользователи портала.
  • Ряд настроек по уведомлению о принятии на работу нового сотрудника позволяет настроить вывод такого уведомления в Общем чате и Живой ленте.

Настройки безопасности

Поле Требовать подключение двухэтапной авторизации у всех сотрудников включает Двухэтапную авторизацию для сотрудников портала. Администратор имеет возможность задать срок, в течение которого пользователь обязан перейти на этот вид авторизации.

Перед настройкой OTP для сотрудников администратор должен настроить двухэтапную авторизацию для себя.

Сервисы

Если у вас есть инструменты, которые не используются в вашей компании или вы хотели бы внедрять их постепенно, вы можете отключить некоторые функции в этом разделе.

Примечание: Доступно только на верхних тарифных планах Компания и Команда.

Ограничения по IP

Если есть потребность ограничить доступ к порталу из посторонних мест, то воспользуйтесь этой настройкой. С помощью ссылки Добавить выберите нужных пользователей или подразделения и разрешите им доступ только с определённых IP. С принципами ограничения доступа можно познакомиться здесь.

Примечание: Доступно только на верхних тарифных планах Компания и Команда.

Логотип компании

Секция для загрузки логотипа вашей компании для отображения на портале.


Управление почтой
378 / 401

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Управление почтой

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Страница Настройки > Управление почтой позволяет администратору производить настройку почты, используемой сотрудниками портала.

Примечание: Доступ к настройкам почты возможен и через меню личной страницы.

Команда Настройка интеграции почты - настройка личной почты.

Команда Управление почтовыми ящиками видна только администратору, позволяет управлять почтовыми ящиками компании.

Почтовые адреса в зоне @bitrix24.ru предназначены для корпоративного, а не личного использования. Поэтому доступ к ним у администратора - полный, вплоть до смены пароля. Предупреждайте об этом пользователей при создании для них почтовых аккаунтов!

Внимание! Право управления почтовым ящиком есть только у администратора портала, на котором ящик был создан. У пользователя (если к нему привязан почтовый ящик и есть доступ к порталу), есть право работать с ящиком и менять пароль. И есть возможность авторизоваться в ящике со стороны Яндекса и всячески им управлять (пока ящик существует и пользователь знает пароль к нему).

Рекомендуется имена почтовым адресам давать не по имени текущего исполнителя должности, а по самой должности. То есть не karpov@bitrix24.ru, а, например, sysadmin_bitrixdoc@bitrix24.ru. В этом случае при смене исполнителя и переназначении адреса для нового сотрудника не будет возникать недоумений по поводу адреса.

Примечание: Возможно использование одного ящика для нескольких сотрудников, правда, не в интерфейсе Битрикс24. Такая потребность может возникнуть, к примеру, у колл-центров. Для такого использования достаточно пользователям войти на Яндекс.Почту и авторизоваться под одним аккаунтом.

Доступно использование одного ящика для нескольких порталов. Ящик привязывается к порталу, на котором он был создан. На другом портале его можно только подключить как IMAP-ящик, указав пароль, но не управлять им.

На "основном" портале, администратор может отключить ящик от пользователя поменяв пароль, либо удалить его. На втором портале ящик, соответственно станет недоступным.

Управление почтовыми ящиками

Если воспользоваться ссылкой Добавить почтовый ящик в Фильтре, ящик создатся без привязки к конкретному сотруднику. Созданный ящик впоследствии можно назначить любому пользователю портала.

Если включена опция, разрешающая сотрудникам подключать ящики к CRM, то рекомендуется в поле Исключить из обработки адреса добавить адреса, сообщения из которых не будут попадать в CRM (на случай ошибочных подключений своих ящиков к CRM пользователями).

В качестве "Текущего адреса" у пользователей указываются любой email, если он подключен к пользователю. Это может быть ящик в @bitrix24, в своем домене или просто IMAP-ящик.

Если необходимо создать почтовый ящик в зоне @bitrix24.ru (либо домене, подключённом к порталу), то воспользуйтесь ссылкой Создать, откроется форма создания почтового ящика:

Заполните поля формы и сохраните форму, почтовый адрес создастся и им можно будет пользоваться.

Примечание: При смене сотрудника рекомендуется не создавать новый почтовый ящик, а привязывать к новому исполнителю старый почтовый ящик со всей сохранившейся перепиской.

Доступны действия по изменению пароля и удалению почтового ящика. Удалить ящик можно как из зоны @bitrix24.ru так и из домена, подключённом к порталу.

Подключение домена

Привязка домена по ссылке Подключить домен приведёт на форму подключения домена. Возможно подключение уже существующего домена к Яндекс.Почте и Битрикс24, регистрация и подключение нового бесплатного домена.

Подключение существующего домена к Яндекс.Почта и Битрикс24 требует прохождение несложного мастера из двух шагов. Если корпоративная почта уже подключена к Яндекс.Почта, то подключение к Битрикс24 потребует заполнения формы и для получения токена, который используется для подключения.

При регистрации домена:

  • При регистрации выберите имя домена для вашей компании. Отнеситесь к этому серьезно, так как на один Битрикс24 разрешено регистрировать только один домен. Если вы допустите ошибку, то исправить будет нельзя.
  • После успешного выбора имени, дождитесь пока пройдет регистрация. Это может занять от пары часов до нескольких суток.
  • После подключения администратор сможет регистрировать ящики сотрудникам. Либо, если отмечен соответствующий флажок, сотрудники сами себе смогут регистрировать почтовые ящики.
Внимание! Зарегистрированный домен только для ПОЧТЫ. Его нельзя использовать для сайта или других целей, только регистрировать ящики и работать с ними через Яндекс почту.

К Битрикс24 можно подключить только один домен.

На текущий момент домен регистрируется только на год.

Для платных тарифов продление домена осуществляется бесплатно и автоматически.Для бесплатных тарифов продление домена не выполняется. Для продления можно перейти на любой платный тариф или перевести домен на свое имя и продлить его самостоятельно на www.reg.ru/. Передача домена происходит через запрос в поддержку Битрикс24.


Доменное имя
379 / 401

Собственное имя домена

Битрикс24 позволяет использовать портал с собственным доменом, например использовать my.intranet.ru вместо intranet.bitrix24.ru. Данная возможность предоставляется только тарифу Компания (лицензия Партнер или Бизнес школа не подходят).

Чтобы изменить доменное имя необходимо сделать следующее:

  1. Приобрести домен 3-го уровня или выше. Обратите внимание, домен должен быть обязательно третьего уровня.
  2. Создать обращение в техподдержку от имени администратора портала. В обращении прислать SSL-сертификат:
    • закрытый ключ (private key)
    • сам сертификат (public key)
    • цепочку сертификатов до корня CA (certificate chain)

    Внимание! Закрытый ключ (private key) должен быть не зашифрован (без пароля).
    Если вы уже присылали закрытый ключ (private key), сам сертификат (public key), цепочку сертификатов до корня CA (certificate chain) для домена уровня ниже, чем третий, то в этом случае необходимо выслать повторно новый SSL, но уже для домена 3-го уровня.

    Требования к сертификату:
    • Сертификат обязательно должен быть выданным известным CA. Самоподписанные сертификаты для смены доменного имени не подойдут.
    • Цепочка сертификатов обязательна. Без нее домен не будет переименован.
    • Если срок действия сертификата заканчивается, его продление через запрос в техподдержку также обязательно, в противном случае, после окончания срока действия сертификата доменное имя будет сразу же возвращено на первоначальное.
  3. Указать точное название собственного домена, на который осуществляется переход.

Смена доменного имени

Смена домена (например с example.bitrix24.ru на test.bitrix24.ru, где test - новое название портала) возможна только на платных тарифных планах Компания и Команда. Для смены нужно только создать запрос в ТП и указать название старого домена и нового.

Для бесплатного тарифа Проект, партнерской лицензии (Партнер) или демо-режима Компании решением проблемы о смене имени с example.bitrix24.ru на test.bitrix24.ru может быть создание нового портала test.bitrix24.ru и прекращение использования портала example.bitrix24.ru.

Если в течение 50 дней ваш example.bitrix24.ru не будет использоваться (не будет ни одного захода на портал сотрудников вашей компании), то данные и домен будут удалены.

Внимание! Учтите, что смена домена может привести к неожиданным результатам:
  • перестанут работать коннекторы для Открытых линий, их нужно будет удалить при переносе.
  • перестанут работать веб-виджеты (Онлайн чат, срм-формы, обратный звонок), нужно будет заново перепривязать их к сайту, если они где-то установлены.
  • публичные страницы (онлайн-чат, срм-формы), нужно будет изменить адреса, если они где-то указывались.

Смена доменной зоны

Изменение доменной зоны возможно через ТП только с ru на ua, при полном исчерпании внесённых средств на телефонию и только один раз.


Мой Тариф
380 / 401

Раздел Мой тариф - это информация о вашем портале в сервисе Битрикс24 и история его заказов.

На странице Мой Битрикс24 указывается используемый вид лицензии, срок её окончания, справочные данные по использованию выделенного места и количеству пользователей и форма для ввода купона продления лицензии.

Ограничения при возврате с платной лицензии на бесплатную
При переходе на платную лицензию становится доступным любое число пользователей. Если по каким-то причинам будет осуществлён возврат на бесплатную версию, то работа пользователей будет ограничена. Ограничение заключается в том, что на портале смогут работать только 12 авторизовавшихся сотрудников из всех существующих. То есть: на портале зарегистрировано 25 человек. На портале авторизовалось и могут, соответственно, работать только 12 из них. Если один из этих двенадцати вышел из портала, то в работу может вступить любой из 13-и оставшихся.

Если при возврате на бесплатную лицензию размер ваших файлов и других данных превышает лимит бесплатного тарифа, то все данные будут доступны, но только для просмотра и удаления. Вы не сможете загружать новые документы, создавать задачи, заносить информацию в CRM или писать сообщения, но сможете их удалять. Для восстановления функционала вам надо будет удалить часть файлов, сообщений и прочего. Как только объём данных уменьшится до бесплатного лимита, работа портала возобновиться.

Если использовался свой домен, то он будет отключён.

Пользователи

Использование портала ограничивается по количеству активных пользователей. Под активными пользователями понимаются, пользователи, зарегистрированные как собственно пользователи портала. Пользователи Экстранета, уволенные пользователи, неавторизованные зарегистрированные пользователи превышающие тарифный план (см. выше Ограничения при возврате с платной лицензии на бесплатную) активными пользователями не являются.

Место в облаке

Расход за выделенным местом контролируется по месту, занятому Базой данных и другими файлами. Занято базой данных - это: задачи, письма, информация в СРМ без файлов. Занято другим - файлы, которые находятся на портале.

Если по каким-то причинам абонентная плата за дополнительное место не была внесена, то на портале ничего не будет удалено, но не будет возможности работать: не будут писаться сообщения, ставиться задачи, нельзя работать с файлами и так далее. Только после того, как пользователи удалят сами часть файлов, сообщений и прочего или компания докупит место, работа станет вновь доступной.

Место в облаке может заканчиваться из-за большого количества писем и вложений в них, с которыми вы работаете в CRM. Для освобождения места можно удалить старые письма или вложения (папка Компания > Общий Диск > Файлы с почты, файлы которые были прикреплены через сообщение или комментарий в ЖЛ (папка Мой Диск > Загрузки), файлы, которые были загружены в папку Мой Диск > Общий диск. После удаления файлов необходимо удалить их также из корзины.

Если некоторые данные на портале были удалены, то актуальная информация о месте на диске обновиться через сутки.

Демо-режим

При желании есть возможность попробовать все возможности сервиса Битрикс24: экстранет, учет рабочего времени, рабочие отчеты и многое другое. Для этого включите демо-режим сроком на один месяц и все инструменты автоматически будут активированы на вашем портале:

Все данные, которые будут созданы вами во время тестового периода, будут сохранены, но по окончанию демо-режима деактивированы. Если в последующем вы решите перейти на платный тариф, данные будут восстановлены.

На этой же странице в разделе Выбор лицензии можно ознакомиться с составом лицензий, обновить текущую лицензию, перейти на другую и ознакомиться с историей ваших заказов.

Страница Список заказов - история ваших заказов. В разделе Активировать лицензию вводится купон лицензии, приобретённый для продления.

Страница Расширенные тарифы - уведомляет о всех доступных тарифных планах и о скором появлении нового функционала.


Примеры использования
381 / 401

В главе публикуются примеры и сценарии использования сервиса Битрикс24.


Общая База знаний для портала
382 / 401

Для Базы знаний, как правило, используется механизм Wiki. В сервисе Битрикс24 Wiki имеется только в Группах. А если нужна База знаний для всех сотрудников? Базы знаний для всего портала как отдельного инструмента нет. Выхода в такой ситуации два.

Wiki в открытой для всех группе

Создайте группу с параметрами: открытая для всех, видимая всем:

В закладке Возможности отключите весь функционал кроме Wiki и Поиска:

Пригласите всех сотрудников в группу на закладке Участники. (Если сотрудников очень много, возможно, что проще будет написать объявление в Живой ленте.)

Права доступа в закладке Дополнительно оставьте по умолчанию.

Для удобства использования разместите группу База знаний самой первой в списке групп. Вы получите такой вид вашей общекорпоративной Базы знаний:

Осталось только наполнить её содержанием.

Универсальные списки как База знаний

Технология Wiki достаточно специфична для использования и требует привыкания сотрудников. Базу знаний можно организовать на основе Универсальных списков. Плюсом такого решения является более понятная обычному пользователю структура и вид, минусом - более сложный доступ к Базе Знаний.

В разделе Компания > Списки создайте список База знаний. При создании списка отключите поддержку БП.

На закладке Подписи измените название элементов на "вопросы", а раздел на "глава", чтобы использовать привычные обычному сотруднику понятия:

А на закладке Права укажите для всех сотрудников Чтение, а для тех, кто будет создавать Базу знаний - Изменение:

Создайте два поля для вопросов: поле Вопрос и поле Ответ. Поле Ответ - тип Детальный текст:

Создайте нужные разделы и перейдите к наполнению Базы знаний.

Если настроить фильтры, то работа с Базой знаний станет более удобной. В конечном итоге получим такой вариант:

Пункт меню Списки можно поднять на самый верх раздела Компания, в этом случае доступ к ним будет несколько облегчён.


Организация работы редакции
383 / 401
Интерактивный видеоролик "Организация работы редакции"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

Постановка задачи

Рассмотрим, как сервис Битрикс 24 может помочь организовать работу редакции, занимающейся публикацией различных материалов на своем сайте.

Схема функционирования редакции описана ниже. Наша задача (задача администратора Битрикс 24) - настроить эту схему с помощью доступного функционала таким образом, чтобы были реализованы все требования.

Менеджеры, с помощью электронной почты или телефонной связи, получают заказы на создание какой-либо статьи. Данные заказы редактором распределяются между копирайтерами с учетом их компетентности и занятости. В процессе работы над контентом другие копирайтеры, редактор и руководство могут просматривать готовящийся материал, оставлять свои комментарии, предлагать какие-либо дополнения (фото, видео, опросы и пр.). После того, как материал будет готов (к заранее установленному сроку), редактор его просматривает и публикует, либо дает команду на доработку. Процесс сотрудничества с заказчиком фиксируется менеджером в системе.

Все сотрудники редакции по ходу работы взаимодействуют между собой, но мы выделили заголовками момент вступления в свои обязанности каждого из них.

Менеджер

За изначальную возьмем ситуацию, когда у каждого менеджера имеются свои контакты\компании, от которых именно он принимает заказы. При настроенной интеграции почтового ящика с CRM, письмо от заказчика о том, что нужна заметка, автоматически будет добавлено к делам нужной сущности, ответственным за которую является какой-либо менеджер:

О данном событии ответственному менеджеру придет уведомление в центр нотификаций:

Оповещение о новом письме

Из формы просмотра контакта менеджер может добавить сделку:

В дальнейшем менеджер по ходу процесса может вносить всю необходимую информацию прямо в сделку.


Редактор
384 / 401

Затем в дело должен включиться редактор. При просмотре дела менеджер пересылает ему данное письмо:

В окошке создания письма указывается email редактора, выбирается заранее созданная для таких писем универсальная сделка Продажа статьи (т.к. указание сделки является обязательным) и пишутся все необходимые пояснения:

В полученном письме редактор видит всю необходимую информацию от заказчика и решает, кому из копирайтеров доверить ее создание.

Как только редактор примет решение, он создает задачу, назначая нужного копирайтера ответственным, указывая крайний срок выполнения и добавляя в основное описание задачи свои рекомендации:

Создание новой задачи

Менеджер, переславший письмо, делается наблюдателем, а к задаче в параметре Элементы CRM добавляется контакт (т.е. непосредственный заказчик):


Копирайтер
385 / 401

Копирайтер, получив задачу и начав ее выполнение (о чем через оповещения станет известно редактору и менеджеру), начинает выполнение заказанной работы прямо в живой ленте:

Создание сообщения в живой ленте

Примечание: сейчас возможно выполнение функций копирайтера с помощью внешних сервисов работы с документами.

Для своей работы копирайтер может использовать весь функционал живой ленты, а также есть возможность выбирать тех сотрудников редакции, которым будет доступен просмотр и комментирование этой статьи. При упоминании отдельных сотрудников, им будет приходить уведомление. В нашем случае статья адресована всем сотрудникам.

При публикации статьи в живой ленте это будет видно тем сотрудникам, которым доступен просмотр. Они могут оставлять свои отзывы и комментарии:

Комментарий к сообщению в Живой ленте

После опубликации статьи в живой ленте копирайтер может вносить в нее изменения в соответствии с новой информацией или отзывами:

Завершение работы

После того, как работа будет закончена, копирайтер завершает поставленную ему задачу, о чем менеджер и редактор будут оповещены уведомлением и сообщением в живой ленте.

Примечание: для удобства редактора копирайтер может оставлять ссылку на свое сообщение в комментариях к задаче. Увидеть ссылку можно, используя меню сообщения:

Ссылка на сообщение

Редактор принимает работу и закрывает выполнение задачи, либо выставляет требование доработки.

В обоих случаях исполнитель и менеджер получат уведомление, последний закрывает сделку.


Организация работы отдела маркетинга
386 / 401

Рассмотрим пример совместной работы с документами как сценарий выполнения задачи отделом по рекламе.

Интерактивный видеоролик "Организация работы отдела маркетинга"

Интерактивный видеоролик (требуется выполнение действий пользователем). Ролик может отставать от текущей версии программы. Более актуальное текстовое описание - ниже. Ролик озвучен.

В нашем случае перед маркетологом стоит задача создания рекламного буклета, который перед своей публикацией должен быть согласован с начальником отдела маркетинга и директором. Руководство должно иметь возможность ознакомиться с ее конечным результатом работы маркетолога, обсудить и внести свои правки в буклет.

Маркетолог создает сообщение в живую ленту и прикладывает к нему созданный им рекламный буклет, а в качестве получателей указывает директора и начальника отдела:

Примечание: файл можно выбрать из документов Битрикс24, так и загрузить с локального диска компьютера.

Маркетолог разрешает получателям сообщения редактировать приложенные документы, отмечая соответствующую опцию.

После отправки сообщения адресаты получат уведомления и увидят его в живой ленте:

Править буклет можно и из окна его просмотра:

В файл буклета вносятся необходимые изменения:

К главному сообщению будет автоматически добавлен комментарий с приложенной новой версией файла:

Примечание: внесенные изменения коснутся и первоначальной версии файла.

Всю дальнейшую совместную работу над документом можно выполнять прямо в сервисе Битрикс24 до тех пор, пока не будет получен необходимый результат.


Пример организации дежурств
387 / 401

Одна из частых производственных задач - организация дежурств. Рассмотрим пример, как это можно сделать с помощью Битрикс24.

Решаемые задачи по дежурству могут быть самые разнообразные, в примере реализуем обобщенный вариант, функционал которого может присутствовать в любом подобном процессе, с таким алгоритмом работы:

Техническое задание:
  1. Ответственный сотрудник составляет план дежурств на выбранный период с постановкой задачи на каждое дежурство.
  2. График дежурств отображается в специальном календаре.
  3. Каждому сотруднику, назначенному на дежурство, ставится задача с указанием работ на дежурство.
  4. По выполнении работ сотрудник составляет отчёт о дежурстве в созданной задаче.
  5. По составлении отчёта контролирующий сотрудник проводит проверку и документирование сделанного. При необходимости работа возвращается на исправление.
  6. Организатор работ имеет возможность составить отчёт о работе всех или любого из сотрудников.
  7. Процесс должен быть максимально автоматизирован.

В процессе создания механизма будем описывать дополнительные возможности, которые можно реализовать при необходимости.

Примечание: "По жизни" реальные исполнители редко работают с корпоративным порталом. В этом случае рекомендуется воспользоваться сценарием Компьютер у ответственного сотрудника этого урока для выдачи заданий на дежурство.

Задачу будем решать с помощью таких инструментов Битрикс24 как:

  • Рабочие группы - для объединения в виртуальное сообщество лиц, причастных к решению нашей заадчи.
  • Универсальные списки - для создания собственно заданий на дежурство.
  • Задачи - для постановки задач для исполнителей.
  • Календарь - для визуального представления графика дежурств.
  • Отчёты - инструмент учёта работы за нужный период.
  • Бизнес-процессы - инструмент автоматизации работы.

Примечание: В примере не будут упоминаться подробности по работе с тем или иным функционалом. Мы считаем, что вы уже освоили инструменты Битрикс24. Если у вас всё же возникают вопросы о подробном выполнении той или иной операции, то воспользуйтесь ссылками, которые есть в тексте, они ведут на описания выполнения этих операций.


Создание рабочей группы
388 / 401

Создайте рабочую группу нужного вам типа (закрытая, видимая и так далее) под условным названием "Дежурство". Включите в её состав нужных сотрудников. Рекомендуется при создании группы отключить весь ненужный функционал. Например, в рамках решаемой задачи минимально необходимый функционал это: Задачи, Универсальные списки, Календарь. О необходимости остального функционала принимайте решение исходя из своих потребностей.

Примечания:
  1. Если объектов, по которым нужно организовать дежурства, несколько, то лучше создавать на каждый из них свою группу, хотя возможны и варианты сведения всех объектов в одну группу.
  2. Если в дежурстве будут принимать участие сторонние специалисты, не входящие в состав вашей организации, то при создании группы отметьте опцию Группа доступна в экстранете, а нужных специалистов пригласите в экстранет.
  3. Если вы используете платные тарифы Битрикс24 с ограниченным числом пользователей и сотрудники-исполнители не входят в число внутренних пользователей, то создаваемую группу также сделайте группой экстранета, а исполнителей пригласите как сотрудников экстранета.

В зависимости от регламента управления дежурством нужно назначить одного или нескольких сотрудников модераторами группы. Модератором должен быть тот человек, в чьи функциональные обязанности будет входить составление графика дежурств и постановка задач на дежурство.

В зависимости от политики безопасности компании, при создании группы на закладке Дополнительно укажите, кто может приглашать в группу.

Теоретически уже можно приступать к работе по организации дежурств. Но процесс будет трудоёмкий: нужно отдельно создать событие в календаре, задачу для исполнителя, уведомить каким-либо способом исполнителя. Использование Универсальных списков и Бизнес-процессов позволит автоматизировать всё это.


Создание списка для ведения дежурств
389 / 401

Собственно назначение на дежурство будет производиться с помощью инструмента Универсальный список.

Примечание:

Если в одной группе ведётся учёт дежурств по разным объектам, то имеется возможность на каждый из объектов создать свой Список и создать свой Календарь для каждого объекта. При этом появляется возможность добавлять события по разным объектам в разные календари в рамках одной группы. Такой подход позволяет быстро, при необходимости, отключить отображение событий по ненужным объектам.

Однако такая настройка требует навыков программиста и в этом примере рассматриваться не будет. Поэтому рекомендуем использовать один календарь, а разделение событий по объектам реализовать за счёт названия событий.

Например так:

Создание списка

Перейдите с главной страницы созданной группы по ссылке Списки на страницу Списки и создайте универсальный список с названием Дежурства.

При создании списка:

  • Оставьте флажок в поле Включить поддержку бизнес-процессов. Без этого будет невозможно автоматизировать работу.
  • На закладке Подписи можно изменить подписи к элементам и разделам. Например, заменить "элемент" на "дежурство", а "раздел" на "месяц". В последнем случае можно будет использовать фильтрацию элементов (дежурств) по месяцам. Это может облегчить поиск нужного дежурства через какое-то время, когда их накопится много.
  • На закладке Доступ задайте необходимые по вашей политике безопасности права. В нашем случае это будет: Изменение для владельца группы, Изменение с ограничениями для модератора и Чтение для обычных сотрудников.

Откройте вновь созданный список: его нужно настроить. С помощью кнопки [image] на контекстной панели списка откройте форму настроек списка. В этой форме при необходимости можно исправить параметры списка. Мы же создадим нужные поля.

Мы не знаем, какие поля нужны каждой конкретной компании в организации дежурства, но как минимум необходимы поля:

  • Дежурный - тип: Привязка к пользователю, обязательное, не множественное. В этом поле будут выбираться исполнители.

    Примечание: Это поле может быть множественным, если на дежурство заступает несколько человек. В этом случае надо будет учесть при настройке Бизнес-процесса, кто из участников будет получать задачу на дежурство и писать отчёт по ней.

  • Дата дежурства - тип: Дата, обязательное, в этом поле будет указываться дата дежурства.

    Примечание: Если дежурство не имеет чётких временных границ по часам, то есть смысл использовать тип поля Дата и время.

  • Комментарий - тип Детальный текст, в этом поле можно ставить задачу на дежурство.

    Примечание: Тип поля Комментарий зависит от объёмов и типа текста, которые будут использоваться. То есть от ваших потребностей. Если объёмы информации большие, есть картинки или чертежи, то, возможно, есть смысл использовать тип Файл. Если работы типовые и периодические, то, возможно, есть смысл создать отдельный Универсальный список с описанием этих работ, а в поле Комментарий использовать тип Привязка к элементам.

  • Завершение работ - тип Список. Это поле необходимо для того, чтобы Бизнес-процесс, шаблон которого мы создадим позже, понял, когда ему нужно закрываться. В список вносим два значения: Не выполнено и Выполнено. По умолчанию ставим значение Не выполнено, флажок Показывать в форме добавления снимаем, чтобы поле не отвлекало внимание сотрудника, составляющего график дежурств.

В качестве дополнительного поля создадим поле Крайний срок. Предполагаем, что после дежурства сотрудники не смогут сразу составить отчёт о дежурстве, например, сильно устают. Им нужно назначить срок, далее которого они не могут затягивать сдачу отчёта. Это поле имеет тип Дата, обязательное.

Итак, имеем:

При необходимости можно создать и использовать другие поля для создания элемента дежурство. Это зависит от ваших задач. Например:

  • если дежурные должны посетить несколько объектов на разных территориях, то можно создать поле Объект с типом Привязка к Яндекс.Карте, где указывать такие объекты;
  • если необходимо в каждом дежурстве указывать других сотрудников, например в качестве консультантов, то можно создать поле Консультант с типом Привязка к пользователю;
  • если нужно установить разных проверяющих, в зависимости от типа работ, то можно создать поле Контролирующий с типом Привязка к пользователю.
  • если нужно учитывать разные виды работ (например, отличать работу по настройке от непосредственного ремонта или замены оборудования), то можно создать поле Вид работ с типом Список.

Иерархия разделов

Сущность Разделы, котороую при создании Списка мы переименовали в месяцы, позволяет создавать вложения любой глубины. Например, структура может быть такой:

В этом случае поиск конкретных дежурств в списке можно осуществлять по месяцам, если нет информации о конкретной дате:


Создание Бизнес-процесса
390 / 401

Создание Бизнес-процесса

С целью автоматизации работы по составлению графика дежурств и постановке задач по ним создадим пользовательский Бизнес-процесс. (Далее - БП)

Примечание: Детально о работе с Бизнес-процессами, с их созданием и настройкой можно ознакомится в отдельном курсе.

Откройте вновь созданный список График дежурств. На контекстной панели списка воспользуйтесь кнопкой Бизнес-процессы, откроется список шаблонов Бизнес-процессов, пока пустой, с предложением создать типовые шаблоны:

Для решения нашей задачи типовые БП не подходят. Воспользуйтесь кнопкой Создать последовательный Бизнес-процесс. Откроется Дизайнер бизнес-процессов и форма для создания шаблона БП. В нашем случае процесс настройки параметров шаблона будет несложным:

  • Дайте название шаблону, например Организация дежурства.
  • Укажите автоматический запуск БП при создании элемента.

Примечание: Остальные закладки использовать необязательно. Единственное, что может потребоваться - это настройка прав доступа, если этого потребует политика безопасности компании. Как правило, хватает прав на ограничение доступа к самому Универсальному списку График дежурств и доступа к самой группе Дежурства.

Теперь можно приступать к самому шаблону. Мы будем использовать в его создании следующие Действия:

  • Событие календаря - для добавления в календарь события;
  • Задача - для постановки задачи исполнителям и контролёрам;
  • в зависимости от предпочитаемого способа уведомления исполнителя: Почтовое сообщение, Сообщение соц.сети или Уведомление пользователя;
  • Цикл - для организации проверки исполнения и исправления или доделки работ;
  • Запрос дополнительной информации - для управления самим циклом;
  • Условие - для организации проверки исполнения и исправления или доделки работ внутри цикла;
  • Изменение документа - для смены значения поля элемента.
Шаблон выглядит так:

Действие Условие свёрнуто для экономии места, детально его содержание будет показано в уроке Контролирующая часть.

Условно разделим шаблон на две части: исполнительскую и контролирующую. Исполнительская - это то, что происходит до действия Цикл (в Шаблоне это действие переименовано в Цикл проверки.) Контролирующая - это то, что идёт в цикле.

После добавления всех действий в шаблон БП нужно произвести их настройку. Для этого используйте значок [image] на панели действия, который открывает форму настройки.

Примечание: Большинство настроек в действиях Бизнес-процессов производятся с помощью Формы вставки значений, которая открывается по кнопке с многоточием у правого края каждого поля. Далее в описании мы не будем постоянно упоминать эту форму, а будем просто называть группу полей из неё.

При использовании значений из этой формы система автоматически подставляет в поля код, понятный ей. Например: {=Document:PROPERTY_DQNIKBN}. Менять этот код вручную не рекомендуется, если вы не отадёте себе отчёта в том, что произойдёт в результате замены.

Внимание! В процессе создания и настройки БП рекомендуется периодически проводить проверку работы настроенной части бизнес-процесса. Для этого просто создаются элементы списка и шаблон БП должен выполнить то, что уже сделано. В ходе работы может накопиться большое число созданных элементов списка, событий в календаре и задач, которые нужно будет удалить перед началом работы. Учтите, что удаление элементов в универсальном списке не приводит к автоматическому удалению событий и задач, созданных этим элементом. Тестовые события и задачи придётся удалять вручную дополнительно.


Исполнительская часть
391 / 401

Исполнительская часть предусматривает такой технологический процесс:

  • Ответственный сотрудник составляет план дежурств на определённый период с постановкой задачи.
  • План дежурств отображается в Календаре группы, исполнители и проверяющие могут в любой момент уточнить сроки дежурств.
  • При заступлении на дежурство начинается выполнение Задачи, после сдачи отчёта о дежурстве Задача закрывается.

Создание исполнительской части

При создании исполнительской части будут использоваться три действия:

  • Событие календаря - для добавления в календарь события.
  • Задача - для постановки задачи исполнителям.
  • В зависимости от предпочитаемого способа уведомления исполнителя: Почтовое сообщение, Сообщение соц.сети или Уведомление пользователя. Сообщение соц.сети рекомендуется использовать, если исполнитель точно работает на портале и увидит это сообщение.

    Примечание: Действие по уведомлению исполнителей может отсутствовать, если непосредственные исполнители не работают на портале и их уведомление производится по сценарию Компьютер у ответственного сотрудника этого урока.

В этой части шаблона порядок следования действий не имеет значения.

Настройка действий исполнительской части

Настройка действия События календаря. В форме настройки в поле:

  • Тип календаря - укажите group. Это идентификатор того, что используется календарь группы, а не персональный календарь.
  • ID владельца календаря - укажите ID созданной вами группы. ID указывается в адресной строке браузера. Например: если группа Дежурства имеет адрес в браузере: https://ваш_портал.bitrix24.ru/workgroups/group/36/, то ID Группы - 36.
  • Пользователь - указывается тот сотрудник, от имени которого будет создаваться событие календаря. Если есть необходимость, то можно указать конкретного человека (например, начальника исполнителя) с помощью группы полей Пользователи, а можно в этой же форме выбрать значение автор, тогда в качестве автора события будет тот, кто создал дежурство в списке График дежурства.
  • Название события - в группе Поля документа выберите значение Название элемента, система сама подставит в поле код: {=Document:NAME}.
  • Описание события - вставьте произвольный текст, например: Дежурство на объекте УК-29. Для уточнения задания на дежурство можно добавить поле Текст для просмотра из этой же группы, система сама подставит код: {=Document:DETAIL_TEXT}.

    Примечание: Добавленное поле Текст для просмотра будет автоматически подставлять тот текст, который вы введёте при создании дежурства в поле Комментарий при создании дежурства. То есть, если в это поле добавлен текст: "Провести регламентное обслуживание ТО №5 для агрегата CTR-28", то в описании события календаря будет выведен такой текст:
    Дежурство на объекте УК-29. Провести регламентное обслуживание ТО №5 для агрегата CTR-28.

    Как видите, первая часть сообщения взята из формы настройки Действия Событие календаря, а вторая часть - из поля Комментарий, заполненного при создании дежурства.

    Внимание! Согласно ТЗ график дежурств составляется заранее на некоторый период. Вполне вероятно, что за время между составлением графика и началом какого-либо дежурства необходимо внести изменение в список работ этого дежурства. Учтите, что в этом случае требуется изменение текста не только элемента Универсального списка, но и редактирование События календаря и Задачи.
  • Дата начала - обязательное поле, в котором указываем значение Дата дежурства группы Поля документа.

Примечание: Настройка действия произведена. Рекомендуется создать один элемент списка Дежурства и проверить, создастся ли событие в календаре. Результат проверки - создано событие:

Настройка действия Уведомление пользователя. В форме настроек в поле:

  • Заголовок - переименуйте действие, чтобы при просмотре шаблона БП было понятно, что оно выполняет. Например в Уведомление дежурных.
  • Отправитель уведомления - кто будет указываться отправителем уведомления из группы Пользователи. Это не обязательно тот человек, который создаёт дежурства в графике дежурств. Это может быть и руководитель исполнителя. Если постановщиком задачи должен быть тот, кто и создаёт дежурства, то нужно выбрать значение Автор.
  • Получатель уведомления - укажите, кому высылать уведомление. Выберем значение Дежурный (группа Поля документа). Система вставит код типа: {=Document:PROPERTY_DQNIKAK}.
  • Текст уведомления для сайта и Текст уведомления для email/jabber оформляем одинаково. Добавляем текст: Вы назначены дежурным на и далее ставим Дату дежурства и затем: Задача на дежурство и далее ставим Текст для просмотра, оба значения из группы Поля документа. Получится примерно такое: Вы назначены дежурным на {=Document:PROPERTY_DQNSVDZ}. Задача на дежурство: {=Document:DETAIL_TEXT}.

Примечание: Создайте один один элемент списка Дежурства и проверьте, придёт ли уведомление. Результат проверки:

Настройка действия Задачи. В форме настроек в поле:

  • Заголовок - переименуйте действие, чтобы при просмотре шаблона БП было понятно, что оно выполняет. Например в Задача исполнителю.
  • Остановить процесс на время выполнения задачи - установите Да. Выполнение БП в этом случае будет приостановлено до тех пор, пока не закроется созданная этим действием Задача.
  • Название задачи - выведите Дежурство и выберите значение Дата дежурства группы Поля документа. В результате в поле будет стоять примерно такое: Дежурство {=Document:PROPERTY_DQNIKBN}, реальное название создаваемой задачи задачи будет: Дежурство _дата_.
  • Постановщик - укажите сотрудника, от имени которого будет поставлена задача (группа полей Пользователи). Как и в случае с Уведомлением, это не обязательно должен быть тот сотрудник, который составляет график дежурства.
  • Ответственный - укажите, на кого должна быть создана задача. Предположительно, это тот же человек, который и выполняет дежурство. Значит, выберем значение Дежурный (группа Поля документа). Система вставит код типа: {=Document:PROPERTY_DQNIKAK}.

    Примечание: Если дежурит несколько человек, то в поле Соисполнители можно указать всех причастных.

  • Начало и Окончание - указываем значение Дата дежурства группы Поля документа. Система подставит примерно такой код: {=Document:PROPERTY_DQNIKBN}{=Document:PROPERTY_DQNIKBN}.
  • Крайний срок - указываем значение поля Крайний срок группы Поля документа. Система подставит примерно такой код: {=Document:PROPERTY_DQOGWDP}.
  • Описание задачи - добавьте текст, который будет общим для любой задачи. Например:Создать отчёт о дежурстве. Далее добавим два поля: Дата дежурства и Текст для просмотра из группы Поля документа. В результате будем иметь такой текст задачи: Создать отчёт о дежурстве _дата_. _Текст из поля Комментарий_.

    Примечание: При задании описания можно использовать html-теги для форматирования текста.

  • Задача в проекте (группе) - укажите группу Дежурства, созданную в рамках нашего сценария.
  • Настройка полей действия Задача в целом завершена. Если вам необходимо, то для остальных полей задайте нужные вам значения, принципиальной роли для нашего сценария они не играют.

Примечание: Создайте один один элемент списка Дежурства и проверьте, создастся ли задача. Результат проверки - создана задача:

Теперь переходим к контролирующей части БП.


Контролирующая часть
392 / 401

Контролирующая часть предусматривает такой технологический процесс:

  • После того, как исполнитель выполнит новую Задачу, контролирующий сотрудник получает уведомление о начале его этапа работ.
  • Контролирующий сотрудник проверяет выполнение работ исполнителем.
  • Если работы выполнены в полном объёме и в надлежащем качестве, то выполняется документирование выполненных работ.
  • Если работы требуют исправления или доделывания, то задаётся задача на новые работы. После выполнения новой задачи исполнителем вновь проводится проверка контролирующим сотрудником.
  • После выполнения всех работ в полном объёме БП закрывается.

Создание контролирующей части

Примечание: Проверка настройки этой части БП одиночными действиями, как мы это делали в Исполнительской части, трудна в организации. Поэтому проверку будем выполнять после настройки всего БП в целом.

При создании контролирующей части будут использоваться действия:

  • Цикл - так как возможно многократное неполное либо неправильное выполнение работ с необходимостью исправлений;
  • Условие - для проверки выполнения работ и, при необходимости, возврата работы исполнителю;
  • Запрос дополнительной информации - для управления процессом доделки и исправления сделанных работ.
  • Изменение документа - для управления Циклом.
  • Задача - для постановки задачи исполнителям.
  • В зависимости от предпочитаемого способа уведомления исполнителя: Почтовое сообщение, Сообщение соц.сети или Уведомление пользователя. Сообщение соц.сети рекомендуется использовать, если исполнитель точно работает на портале и увидит это сообщение.
Контролирующая часть БП:

В ходе работы рекомендуется придерживаться описываемого ниже порядка. Дело в том, что в настройке ряда действий используются параметры, созданные или заданные в действиях выше, и при нарушении описываемого порядка вы просто не сможете произвести нужные настройки.

Настройка действий Сообщение соц.сети. Действие встречается три раза. В форме настроек в поле:

  • Заголовок - переименуйте действие, чтобы при просмотре шаблона БП было понятно, что оно выполняет. Например, в Уведомление проверяющего.
  • Отправитель уведомления - кто будет указываться отправителем уведомления из группы Пользователи.
  • Получатель уведомления - укажите, кому высылать уведомление. Если это конкретный сотрудник, то укажите его. Если сотрудник меняется, то укажите поле из группы Поля документа

    Примечание:
    • Возможна ситуация, когда контролирующих несколько или они разные (например, в зависимости от вида работ). В этом случае, возможно, есть смысл завести дополнительное поле Контролирующий в настройках Универсального списка и при создании дежурства указывать, кто должен выполнять эту функцию.
    • В последнем сообщении, уведомляющем всех о завершении работ, вероятно, нужно указать всех принимавших участие.

  • Текст сообщения: составьте по аналогии с тем, что делали раньше, например, такое: Дежурство от {=Document:PROPERTY_DQNSVDZ}. Отчёт составлен. Вам поставлена задача на проверку и документирование работ. Выполнены работы: {=A98489_43534_12059_87173:Comments}.
    или (при успешном завершении работ):
    Все работы выполнены, поздравление и пожелания успехов всем участвовавшим!

    Примечание: При составлении описания мы несколько забежали вперёд и вставили значение поля, которого у нас ещё нет: {=A98489_43534_12059_87173:Comments}. Как получить значение этого поля смотрите в описании задачи для исполнителя при доделке работ - ветка Нужна доработка.

Задание цикла

Описание технологического процесса предусматривает, что возможен многократный возврат работы на переделку или доделку. Реализовать этот момент можно с помощью действия Цикл. Добавьте это действие в Шаблон БП, теперь его надо настроить на выход из цикла. Для этого мы предусмотрели при настройке Универсального списка поле Завершение работ. По умолчанию в этом поле ставится значение Не выполнено. Значит, выход из цикла будет осуществлён, когда контролирующий сотрудник поставит у этого поля значение Выполнено.

В форме настроек действия Цикл:
  • Заголовок - переименуйте действие, чтобы при просмотре шаблона БП было понятно, что оно выполняет. В нашем случае: Цикл проверки.
  • Тип условия - выберите Поля документа.
  • Поле документа - выберите созданное нами поле Завершение работ.
  • Условие - установите значение Равно.
  • Значение - установите значение Не выполнено.

Данные настройки означают, что цикл будет продолжаться всегда, пока значение поля Завершение работ не будет сменено с Не выполнено на Выполнено

Все последующие действия должны быть размещены внутри Цикла. Кроме последнего сообщения о завершении работ.

Уведомление и постановка задачи контролирующему

Уведомление и постановка задачи контролирующему выполняются по аналогии с уведомлением и постановкой задачи исполнителю.

Запрос дополнительной информации

Это действие создаёт параметры для управления циклом. Следующее за ним действие Условие должно на основании "чего-то" понять, что делать: заканчивать БП или снова создавать задачи для исполнителя на доделку. Вот это "что-то" и задаётся в Запросе дополнительной информации.

В форме настроек действия Запрос дополнительной информации:
  • Заголовок - переименуйте действие, чтобы при просмотре шаблона БП было понятно, что оно выполняет. В нашем случае: Отправить на доделку?.
  • Заполняют сотрудники - указывается, кто должен заполнить поле. По логике организации дежурства это должен быть сотрудник, контролирующий исполнение. Если это конкретный человек, то укажите его. Если вы создавали в Универсальном списке поле Контролирующий, то укажите его.
  • Название задания - указывается текст, который будет виден на странице задания. Он формулирует суть того, что должен сделать контролирующий. В нашем случае пусть будет:
  • Описание задания - если суть задания невозможно сформулировать в названии, то в этом поле можно дать пояснение. Напишем: Выберите: "Нет" если работа вами принимается. Выберите: "Да" если работа нуждается в доработке. В этом случае рекомендуем указать причины возврата в поле "Причины возврата".
  • Показывать поле ввода комментария - будет показываться поле для добавления комментариев.
  • Метка для поля комментария - введите: Причины возврата
  • Поля - здесь создаётся тот параметр, который будет использоваться действием Условие. Нажмите Добавить поле.

    В открывшейся форме:

    • Название - дайте название полю, по этому названию вы будете выбирать поле в дальнейших настройках. В нашем случае: Отправить на доделку?.
    • Код - на латинице любое буквенное обозначение. Это поле имеет значение только для системы, в интерфейсе оно нигде не видно.
    • Тип - установите Да/Нет
    • Значение по-умолчанию - не устанавливайте. Можно, теоретически, установить какое-то из значений, но лучше всё же не устанавливать, так как в этом случае выбор контролирующим сотрудником "да" или "нет" будет ответственным, нельзя будет списать на то, "что я просто нажал Сохранить и так получилось".

Настройка действия Условие

Разместите действие Условие. При необходимости переименуйте его, мы оставим название прежним. Настройка Условия производится в собственно линиях условий. По умолчанию в этом действии таких линий две. Их может быть сколько угодно, но в рамках нашего задания двух вполне достаточно. Назовём одно условие Нужна доработка, а второе Не нужна доработка. Откройте на редактирование поочерёдно оба действия.

В этой форме:
    (в скобках указываются значения для второго условия)
  • Заголовок введите Нужна доработка (Не нужна доработка)
  • Тип условия - Значение переменной (аналогично)
  • Свойство или переменная - Отправить на доделку? (аналогично). Эта переменная была создана нами в действии Запросе дополнительной информации ранее.
  • Условие - равно (аналогично).
  • Значение - Да (Нет)

То есть мы задали, что при выборе контролирующим сотрудником в действии Запросе дополнительной информации варианта "Да" БП пойдёт по одной ветке условия, а при выборе "Нет" - по другой. Теперь нам нужно задать действия в обоих ветках условия.

Ветка Нужна доработка

В этой ветке размещаем два действия: Задача и Уведомление пользователя. Как настраивать эти действия вы уже знаете. Единственное изменение есть для действия Задача: при задании описания задачи включите в него поле Комментарий из группы Дополнительные результаты:

Поле Комментарий

В этом случае в текст задачи будет добавляться текст из поля Причины возврата, который добавил контролирующий сотрудник при возврате работы на доделку.

Примечание: Мы не затронули вопросы сроков задачи. В реальном производственном процессе это важный момент. Но вы уже в состоянии настроить эти сроки самостоятельно.

Ветка Не нужна доработка

В этой ветке ставим одно единственное действие Изменение документа. В этом действии мы совершим изменение значения поля Завершение работ, что позволит завершить действие цикла.

В форме настройки действия:
  • Заголовок - переименуйте действие, чтобы при просмотре шаблона БП было понятно, что оно выполняет.
  • В поле ниже выберите значение Завершение работ и установите значение для него - Выполнено.

Собственно, настройка БП завершена. Проверим теперь его работу.


Как работает БП
393 / 401

Посмотрим как работает Бизнес-процесс и какие действия должен выполнять сотрудник в той или иной роли. Предполагаем, что ролей будет две: Исполнитель и Организатор-контролёр.
Исполнитель - тот, кто непосредственно производит работы по дежурству.
Организатор-контролёр - составляющий график дежурств и проверяющий работы сотрудник.

Примечание: В реальном производстве ролей может быть больше. Например, Организатор-контролёр может быть разделён на отдельные роли Организатор и Контролёр соответственно. Могут добавиться роли Консультант и Снабженец. И так далее, в зависимости от конкретного производственного процесса.

Этапы | Действия
1 | Организатор-контролёр составляет график дежурств, например, на месяц вперёд. График отображается в календаре рабочей группы.
2
Каждый Исполнитель может в любой момент уточнить срок и задачу своего дежурства.

При этом ему приходит уведомление о каждой дате дежурства.

И ставится задача.
3 | Исполнитель выходит на дежурство, выполняет указанные работы, создаёт отчёт о дежурстве, закрывает задачу.
4 Организатор-контролёр:

получает уведомление о выполненной исполнителем задаче.

Ему ставится задача на проверку сделанных работ.
5 Организатор-контролёр проверяет выполненные работы, закрывает задачу. После закрытия у него в пункте меню Бизнес-процессы

появляется счётчик заданий:

6 Организатор-контролёр:

Перейдя на страницу Бизнес-процессы видит задание для выполнения

Воспользовавшись кнопкой "Приступить" контролёр переходит к выполнению задания:
В зависимости от принятого решения выставляется либо Да, либо Нет. Если указано Да, то необходимо указать причины возврата, а система переходит к этапу 7. Если указано Нет, то система переходит к этапу 9.
7 Исполнитель

получает уведомление

и задачу на исправление работ
8 | Исполнитель выполняет работы, составляет отчёт и закрывает задачу. Система переходит к этапу 4
9 | Бизнес-процесс автоматически устанавливает значение Выполнено для поля Завершение работ у элемента списка График дежурств и выходит из цикла.
10 Всем участникам процесса приходит уведомление о завершении работ:


Отчёты
394 / 401

Любой организации необходимо анализировать свою деятельность. Например, нужно проанализировать эффективность того или иного сотрудника, выполняющего дежурства. Вообще-то нормальный руководитель всегда сам знает, кто у него как работает, но для убедительности желательно иметь объективные данные. Это можно сделать с помощью Отчётов.

Задача: вывести отчёт о количестве задач, возвращаемых на доработку после дежурства.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Пример создания отчета

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Создание отчёта

Перейдите на страницу Задачи группы Дежурства. С помощью кнопки [image] откройте список отчётов.

С помощью ссылки Добавить отчёт откройте форму создания отчёта.

Форма создания отчёта в заполненном состоянии

Заполните поля:

  • Название отчёта - укажите, например, Анализ частоты переделки работ на дежурстве.
  • Описание отчета - комментарий к отчёту, например, Кто работает небрежнее и чаще переделывает.
  • В секции Колонки оставьте только две строки:
    • Название - потому что по нему будет разделяться задача на доделку от задачи на дежурство. В этой строке поставьте флажок у чекбокса Вычислить колонку, так как нам важно число задач.
    • Ответственный - потому что нам надо видеть общее число задач на доделку по исполнителям.

  • В секции Фильтр создайте такие настройки:
    • Ограничить результаты по всем условиям. То есть будут выводится только те элементы, которые отвечают всем набранным условиям. С помощью Выберите поле, и в дальнейшем кнопок +, создайте такие значения фильтра:
    • Проект. Значение условия: равно, с помощью Выбрать указываем созданную нами группу Дежурства. Это строка означает, что в отчёт попадут только задачи из этой группы. Снимем флажок с Изменять фильтр в отчете, так как мы не собираемся менять группу в отчёте. Поле Проект после снятия флажка не будет отображаться в настройках фильтра отчёта.
    • Два поля Дата завершения. Одно поле со значением Больше или равно, другое со значением Меньше или равно. Таким образом, мы можем задать диапазон дат закрытия задачи, по которым нам нужно составить отчёт. В этом поле и во всех остальных флажок с поля Изменять фильтр в отчете не снимаем, так как нам, возможно, понадобится менять данные при просмотре отчёта.
    • Ответственный - это поле нужно, чтобы мы могли построить отчёт по одному исполнителю. Если оно будет пустое, то отчёт строится по всем сразу.
    • Название, значение Содержит, в поле следом введите: на доделку.

      Примечание: В форме настройки действия Задача при настройке шаблона Бизнес-процесса, мы задаём название задачи. Следовательно, все задачи, созданные БП будут иметь одинаковое название, отличающееся только переменными. (В нашем случае переменная - это дата дежурства.) В случае задачи на переделку мы так и написали: Задача на доделку {=Document:PROPERTY_DQNSVDZ}. Вот по этой фразе на доделку мы и будем отделять задачи на дежурство от задач на переделку.

    • Теги, значение Равно. Виды работ могут быть разными. Для облегчённого поиска задач с тем или иным видом работ удобно применять теги. Например, для работ связанных с настройкой оборудования использовать тег настройка, для работ по замене: замена. Если работа производится по какому-то конкретному оборудованию, то используется тег с названием оборудования. В этом случае нахождение задачи становится несложным делом: достаточно выбрать нужные теги.

      Примечание: К сожалению, на данный момент нет возможности устанавливать теги автоматически из БП, поэтому их нужно добавлять вручную, открыв задачу на редактирование.

  • Выводить диаграмму - для наглядности можно включить и настроить отображение отчёта в виде диаграммы.

Работа с отчётом

Работа с отчётом проста: надо настроить фильтр под нужные вам условия. Например, на рисунке снизу выведено число задач по доделке работ, связанных с ремонтом по всем исполнителям за период в 9 месяцев 2015 года:


Как быть с сотрудниками которые работают только в оффлайне
395 / 401

Компаний, полностью работающие в виртуальной среде крайне мало. У подавляющего большинства фирм есть работники, в чьи профессиональные обязанности не входит работа за компьютером. Однако эти сотрудники - неотъемлемая часть бизнес-процессов компании. Как организовать взаимодействие таких сотрудников и офиса?

Самый простой вариант - выдать им по планшету и оплатить за счёт компании доступ в Интернет. В этом случае работник постоянно имеет доступ к порталу, получать указания и давать обратную связь. Кроме того, такой вариант позволяет использовать он-лайн сервисы, интегрированные в портал, например бесплатный 2GIS MAP.

Но такой вариант не устроит многих. Дорого и как быть, если сотрудник работает там, где нет Интернета?

Компьютер и принтер в общем доступе

Самый простой, но не самый лучший вариант: поставить в офисе компании компьютер и принтер (или интернет-киоск) для общего доступа. Сотрудник, приходя на работу, авторизуется, начинает рабочий день, просматривает Живую ленту компании, распечатывает свои задания и выезжает "в поле". После окончания работы - вновь авторизуется, заполняет формы отчётов и задач, завершает рабочий день.

Вариант плох тем, что:

  • Высок риск того, что сотрудник не выйдет из своего аккаунта и дискредитирует его.
  • Сложность доступа сотрудников к компьютеру утром и вечером, если сотрубников много, а компьютер один.
  • Большие потери времени сотрудников на печать.
  • Риск "непрофильного" использования компьютера и принтера.
  • Необходимость обучения сотрудников работе на портале и естественная потеря времени (производительности) в первоначальный период. С вытекающим недовольством со стороны работников: естественный человеческий консерватизм.

Компьютер у ответственного сотрудника

Более правильным будет вариант, когда все задачи по работе "в поле" ставятся на одного ответственного сотрудника: офис-менеджера, мастера, бригадира и так далее. Этот сотрудник имеет доступ и к порталу и к принтеру. Обязанность такого сотрудника: подготовить к началу рабочего дня все задания, раздать их исполнителям и принять задачи после завершения рабочего дня. Для этого можно просто использовать опцию Печать браузера (горячие клавиши Ctrl+p) либо платное приложение Печать списка задач. При этом для систематизации и организации работ можно использовать разные инструменты портала: Задачи, Группы, Бизнес-процессы, Календари.

В этом случае сотрудники работают с привычной им бумажной формой.

Для связи с сотрудниками "в поле" можно использовать как обычную IP- телефонию с записью всех звонков. Требуется только завести контакты сотрудников в CRM и вести учёт работы в ней.

Либо с помощью sms-уведомлений. Для этого есть бесплатные приложения: SMS4B и SMSBiz.


KPI для отдела организации
396 / 401

Организация эффективной работы - одна из задач руководителя подразделения. Рассмотрим пример использования Битрикс24 для организации работы отдела с учетом KPI.

Ключевые показатели эффективности - (англ. Key Performance Indicators, KPI) — система оценки, которая помогает организации определить достижение стратегических и тактических (операционных) целей. Использование ключевых показателей эффективности даёт организации возможность оценить своё состояние и помочь в оценке реализации стратегии. КПЭ позволяют производить контроль деловой активности сотрудников и компании в целом в реальном времени. Для термина «key performance indicators (KPI)» используется русский перевод "ключевые показатели эффективности" (КПЭ).

При внедрении KPI руководителю надо решить следующие задачи:

  • Создать систему учёта выполнения работ;
  • Создать коэффициенты, позволяющие учитывать различия между задачами;
  • Создать понятную для руководителей и сотрудников систему подсчёта премий;
  • Создать прозрачную для руководителей и сотрудников систему вывода отчётов;

Всё это можно осуществить с помощью инструментов сервиса Битрикс24:

  • Рабочие группы;
  • Задачи;
  • Конструктор отчётов;

Примечание: Сервис Битрикс24 обладает ограниченным функционалом в сравнении с продуктом 1С-Битрикс: Корпоративный портал. В коробочном продукте возможна реализация KPI в более полном объеме.

Пример создан на основе реального опыта. В тексте будут использованы фрагменты текста из реального "Положения об использовании KPI".

Итак:

Цитата из Положения об использовании KPI:

Система KPI вводится с целью:

  • повысить продуктивность работы сотрудников;
  • подключить к работе интерес самих сотрудников;
  • создать систему, позволяющую более эффективным сотрудникам получать большую компенсацию за свой труд.

Суммы, начисленные по предлагаемой схеме, добавляются к текущей оплате. Расчёт производится ежемесячно.

Сотрудники отдела обладают свободой в выборе задач для текущей работы, ориентируясь на установленные приоритеты и коэффициенты.

Далее оговорите какие-то свои, специфичные условия внедрения системы.

Как работает система в целом

  1. Создаётся задача, определяющая объем работ. Задача может быть создана руководителем, сотрудником, автоматически из списка работ.
  2. Задача выполняется ответственным за её исполнение.
  3. Руководитель проверяет выполнение задачи и добавляет коэффициенты за её выполнение.
  4. По истечении отчётного периода с помощью корпоративного портала составляется отчёт по выполненным задачам.
  5. Руководитель отдела по данным отчёта составляет ведомость премий и передаёт в бухгалтерию.


Создание рабочей группы
397 / 401

Для организации работ нужно прежде всего создать рабочую группу отдела, куда будут включены все сотрудники отдела, а также другие сотрудники, имеющие отношение к работе вашего отдела. Например, те, кто может ставить задачи для вас, либо контролировать исполнение, либо оказывать консультации и так далее.

Уровень открытости и видимости определите исходя из потребностей вашего отдела. Оптимальный вариант: закрытая, видимая группа. В этом случае сообщения из группы не попадают в Живую ленту портала и не "замусоривают" её для других сотрудников, и любой из сотрудников может, при необходимости, найти группу в списке и попроситься у владельца или модератора в её состав.

Владельцем группы должен быть руководитель подразделения, в этом случае ему будут принадлежать вся полнота "власти" в Рабочей группе. В крайнем случае руководитель подразделения может быть не владельцем, а модератором группы.

  • Создайте Рабочую группу и включите в неё всех заинтересованных лиц.
  • Выполните другие работы по настройке функционала групп под ваши потребности.

Вне темы: Функционал Рабочих групп позволяет не только организовать работы отдела, как это описано в примере, но и использовать другие инструменты для накопления опыта. Например:
  • использовать механизм Wiki для описания регламента работы отдела:

  • Или механизм Сообщений для сохранения опыта работы:

  • Или механизм Файлы хранения общих документов отдела.


Механизм учёта выполненных работ
398 / 401

Для организации системы KPI необходимо вести учёт работ выполненных сотрудниками.

Цитата из Положения об использовании KPI:

Глава 2. Механизм учета выполненных работ

Задачи

Учёт ведётся на основе задач, создаваемых в рамках рабочей группы корпоративного портала: Название вашей группы. Задачи сотрудникам ставятся как самими сотрудниками, так и руководителем отдела.

По умолчанию приоритет у создаваемой задачи – низкий. Руководитель отдела может повышать приоритет задачи, чтобы ориентировать сотрудника на нужные работы.

Работы, являющиеся обязательными и выполняющиеся без учёта приоритета в первую очередь:

  • Работа 1
  • Работа 2
  • Работа 3

Отчётность

Отчётность составляется руководителем отдела на основе закрытых в течение отчётного месяца задач.

Особенности учёта. Здесь надо расписать особенности учёта работ в вашем отделе, например:

  • Задача не включается в учёт премии, если она не закрыта. Работа выполнена, но не закрыта в текущем месяце - не будет в учёте. Допускается закрытие в следующем месяце после выполнения, но не более. Закрывайте вовремя!
  • В комментариях к задаче сотрудником обязательно указывается выполненная работа в форме: (Укажите ваши требования к отчёту о выполнении задачи. Например: модуль, по которому выполнена работа, версия модуля, УРЛ страницы курса либо документации, вид работы). Неуказание этих данных – учёт выполнения задачи по базовой ставке, без коэффициентов.
  • Если задача закрыта, но нет отчёта и руководитель не нашёл следов работы в документации – незачёт задачи.
  • Нерабочие задачи, типа «Полить цветы» не берутся в расчёт.
  • Задача может быть возвращена на доделку при проверке. Она, естественно, не попадёт в отчёт.
  • Другие ваши требования

Виды работ

Здесь надо написать ваши условия выполнения всех видов работ отдела. Например:

Вид работ 1

Основной задачей отдела является своевременное обновление базовой документации по продуктам. Задачи по обновлениям выполняются в первую очередь, не смотря на наличие задач с приоритетом Средний и Высокий. Невыполнение задач по обновлениям в сроки регламента наказываются штрафами.

Задачи по обновлениям имеют название вида: «Обновление, дата, модуль».

Вид работ 2

...

Для реализации системы учёта выполненных работ используется инструменты Задачи и Конструктор отчётов. Это штатные инструменты Битрикс24, позволяющие создавать прозрачные для всех отчёты по задачам, имеющие механизмы задания сроков, уведомлений, напоминаний и так далее.

Создание задач

Все работы в отделе выполняются с обязательной постановкой задачи на каждую работу. Сократить время на постановку задач можно используя заранее созданные шаблоны.

Задачи могут создаваться как руководителем отдела и назначаться конкретному исполнителю, самими сотрудниками на себя. В последнем случае необходимо, чтобы сотрудники либо создавали задачу от имени руководителя, либо, как минимум ставили его в список наблюдающих.

Обязательное условие! Задача должна создаваться в рамках рабочей группы отдела. В противном случае у руководителя будут большие затраты времени на отслеживание задач и включение их в месячную ведомость.

Не рекомендуется создавать задачи на нескольких сотрудников соисполнителями. В этом случае задача будет засчитываться в отчёте только основному исполнителю. Если необходимо распределить работы в рамках одной задачи между несколькими сотрудниками лучше использовать механизм подзадач.

Банальности: название задачи должно быть понятным, описание работ в тексте задачи - конкретным и чётким.

Поля в форме создания задачи, минимально необходимые для системы KPI:

Исполнение задачи и отчет по ней

Отчёт по выполнению задачи производится с помощью Комментариев к задаче:

Исполнитель отчитывается здесь о выполнении, руководитель выносит свое решение о приеме/не приёме задачи с пояснением своего решения:

После выполнения работы задача закрывается, выставляется, если нужно, оценка работе.


Механизм учёта сложности задач
399 / 401

При использовании Задач внешне всё просто: руководитель (или сотрудник самостоятельно) создаёт задачу, сотрудник выполняет её и закрывает задачу. Руководитель учитывает результат в премии. Но "по жизни" всё несколько сложнее. Задачи могут быть разными по:

  • сложности или объёму работ;
  • приоритету по выполнению;
  • качеству выполнения;
  • другим причинам.

Всё это нужно учитывать при составлении месячного отчёта по KPI, иначе вам не избежать недовольства в коллективе, что может привести к обратному эффекту: снижению производительности.

Решение этой проблемы типовое: введите коэффициенты, позволяющие увеличивать/уменьшать ставку премии за выполнение задачи. Сложнее обосновать и сделать понятными эти коэффициенты для сотрудников и администрации.

Примечание: Крайне сложно сразу задать значения коэффициентов "на все случаи жизни". Исправление значений коэффициентов - обязательный момент в работе системы, который позволяет корректировать как справедливость учёта, так и направленность системы на тот или иной результат работы сотрудников.

Считается, что наиболее эффективны системы с числом коэффициентов от 3 до 5. В описываемом примере используется три критерия, позволяющие учитывать разнородность задач. Это критерии конкретного использования, возможно вам, в вашем случае надо пересмотреть их или придумать (добавить) иные критерии.

Сложность

Самый трудный вид коэффициента, так как требует чёткого понимания трудозатрат на каждый вид работы, выполняемый сотрудниками. Иначе трудно составить более-менее справедливую систему значений.

Коэффициент имеет 5 значений, в которых учитывается каждый вид работ отдела с указанием количественного показателя.

Коэффициент сложности
Значение | Объёмы работ
 | Вид работ 1 | Вид работ 2 | Вид работ 3 | Вид работ 4 | Вид работ 5 | Вид работ 6 | Вид работ 7
1 | до n единиц | до t единиц | до t единиц |  | до n единиц | до n единиц | любая
2 | до m единиц | до r единиц | до r единиц | до x единиц | до m единиц | свыше n единиц |
3 | свыше m единиц | свыше r единиц | до e единиц | до y единиц | до k единиц |  |
4 |  |  | свыше e единиц | свыше y единиц | до l единиц |  |
5 |  |  |  |  | свыше l единиц |  |

Варьируя численными показателями, условиями "до" и "свыше", местоположением этих условий можно получить нужное сочетание выполненных работ, соответствующих определённому значению коэффициента.

Примечание: В Виде работ 7 используется значение любая. Значит любая задача этого вида работ оцениватеся в 1. Такой вид работ можно применить, например, к организационным задачам, выполняемым руководителем отдела.

Для учёта этого коэффициента в задачах нет штатного механизма. Необходимо будет вести его учёт в комментариях к задаче.

Приоритет

Разные виды работ имеют разную важность для компании. Руководитель отдела может менять приоритет задачи, поставленной сотруднику. Это указывает на важность и на более высокую премию за срочную работу.

В инструменте задач есть штатный механизм Приоритет:

изменяя который можно указывать сотрудникам важность задачи и изменять коэффициент, увеличивающий премию за выполнение срочной работы.

Примечание: В описанном примере за 1 берётся самый низкий статус Приоритета. Но никто не мешает вам назначить другие значения.

В итоге может получиться такая таблица значений коэффициента:

Приоритет | Значения коэффициента
Низкий | 1
Средний | 2
Высокий | 3

Оценка выполнения задачи

Для оценки выполнения задачи можно использовать штатные оценки в Задачах:

Коэффициент выставляется руководителем отдела и служит инструментом оценки труда сотрудника. Выставление оценки должно сопровождаться пояснением о причинах такой оценки. Ставки коэффициента корректируется в соответствии с накоплением опыта работы системы.

Для начала можно применить такие значения коэффициента:

Оценка | Значения коэффициента
Нет оценки | 1
Положительная | 1,5
Отрицательная | 0,5


Механизм начисления премий
400 / 401

Простая и понятная система подсчёта премий - это тоже важный момент. Формула должна быть такой, чтобы любой сотрудник или вышестоящий руководитель мог без особых временных и интеллектуальных затрат проверить верность подсчётов.

Пример такой формулы:

Цитата из Положения об использовании KPI:

Примерная формула начисления премии состоит из сумм выполненных задач, умноженных на коэффициенты за вычетом штрафных санкций:

Премия = ((С1 * П1 * О1) + (С2 * П2 * О2) + …) * БС – (10% * Чпд * БС)
Где:
  • С* - коэффициент сложности задачи;
  • П* - приоритет задачи;
  • О* - оценка выполнения задачи;
  • БС – базовая ставка;
  • Чпд – число просроченных дней.

Базовая ставка

Базовая ставка - это основа для расчётов премий. Она может (и должна) меняться с течением времени. На начальном этапе она устанавливается равной N рублям.

Регламент и штрафные санкции

Время выполнения задачи - тоже важный момент. Для учёта этого параметра можно ввести дополнительный коэффициент, если этого требует специфика работы отдела. И понижать/повышать стоимость премии за каждую задачу в зависимости от срока выполнения. Для этого можно использовать параметры задачи: Крайний срок и Дата завершения:

А возможен другой вариант: контрольные сроки исполнения и штрафные санкции за их превышение. Именно этот вариант и реализован в нашем примере:

Цитата из Положения об использовании KPI:

Основной задачей отдела является своевременное обновление базовой документации по продуктам. Поэтому устанавливаются контрольные сроки по выполнению этих обязанностей. Если этот срок нарушен, то с премиального фонда сотрудника снимается по 10% за каждый просроченный рабочий день.

Контрольные сроки зависят от номера изменений релиза продуктов. Предварительные сроки устанавливаются следующие:

  • При смене третьей цифры в номере релиза – 3 рабочих дня.
  • При смене второй и первой цифры в номере релиза – 7 рабочих дней;

При больших объемах работ, что характерно для смены второй и первой цифры сроки исполнения для сотрудников могут изменяться по согласованию с руководителем отдела.

Определить просрочена задача или нет можно сравнив дату начала выполнения и дату завершения.


Отчёты и контроль
401 / 401

Система должна подводить итоги ежемесячно. Значит ежемесячно должны составляться отчёты о выполненной работе. Для этого можно использовать штатный механизм Битрикс 24: Конструктор отчётов.

Примечание: Согласуйте с бухгалтерией сроки подачи отчётов. Вряд ли это будет месяц с 1-го по 1-ое. Для удобства расчётов и гарантии попадания премии в ЗП отчётного месяца ведомость, скорее всего придётся подавать в последних числах месяца, например, с 28-го по 28-е.

Создание отчёта

Опишем пошагово создание отчёта для KPI.

  • Перейдите на страницу Задачи рабочей группы вашего отдела.
  • С помощью кнопки Отчёты перейдите к отчётам.

  • С помощью кнопки Добавить отчёт откройте форму создания отчёта.
  • Заполните поля Название и Описание. В поле Отчётный период выберите за всё время.

  • Настройте секцию Колонки. У вас должны быть поля:
    • Название;
    • Ответственный;
    • Приоритет;
    • Оценка.

    Если в вашем варианте KPI учитывается время исполнения задачи, то необходимо ещё добавить колонки Дата завершения и Крайний срок.

    Выберите удобную для вас сортировку списка. Например, по полю Ответственный.
  • Настройте фильтр. В нем нужно учесть фильтрацию по полям: Статус, Проект, Ответственный. А так же временные параметры Дата завершения со значением Больше или равно и Дата завершения со значением Меньше или равно для задания интервала по которым надо фильтровать задачи.

    У поля Ответственный и обоих полей Дата завершения должен стоять флажок в Изменять фильтр в отчете. В этом случае вы сможете делать выборки по конкретным сотрудникам отдела и временному интервалу.

  • Сохраните отчёт.

Вы создали средство для быстрой выборки из всех задач только тех, которые нужны вам для учёта в KPI. Любой из сотрудников или администрации может создать по описанному алгоритму аналогичный отчёт у себя и контролировать учёт задач.

Работа с отчётом

Отчёт формируется автоматически после выставления в поле фильтра интервала интересующих вас дат. Кроме этого можно отфильтровать список по конкретному сотруднику.

В самом отчёте подводить конкретные финансовые итоги невозможно. Это нужно делать в MS Excel. Для этого используйте кнопку Экспорт Excel. Экспортированные данные можно свести в отдельном файле, например, такого вида: образец.

Контроль за выполнением

Контроль за состоянием дел - одна из обязанностей руководителя подразделения. Организация этого процесса - отдельная тема, мы коснёмся этого только в плане стоящей перед нами задачи и с использованием инструментов Битрикс24.

Живая лента и панель уведомлений

Создание и любое изменение в задаче обязательно отображаются в Живой ленте корпоративного портала. Этот механизм информативен, но не всегда удобен, так как требует частого посещения страницы с Живой лентой.

Удобнее использовать Панель уведомлений, доступную на любой странице портала. В ней выводится тот же список изменений и событий. Но этот список можно редактировать и удалять ненужные сообщения, оставляя под контролем только то, что нужно:


Пользователь сервиса Битрикс24
0 / 401

Курс создан для пользователей облачного сервиса Битрикс24. В нём рассмотрены настройки, способы работы и основные сценарии работы с функционалом сервиса. То есть курс предназначен для тех кто уже работает в Битрикс24. Если вы хотите ознакомится с тем как внедрить наш сервис в работу вашей компании, то для вас создан курс Внедрение корпоративного портала.

Возможны некоторые несоответствия в отображении интерфейсов сервиса.

В курсе есть учебные озвученные интерактивные видеоролики. То есть при их просмотре требуется выполнение действий пользователем. В силу постоянно обновляющегося функционала сервиса информация в видеоролике может отставать от действующей версии. Мы отслеживаем эти изменения, но отставание возможно в силу трудоёмкости работ. Текстовая версия курса - всегда соответствует реальному функционалу сервиса.

Внимание! В курсе приводится описание полного функционала сервиса. Для бесплатной лицензии Проект и лицензии Команда часть функционала недоступна. Сравнение лицензий.

На каждой странице курса авторизованный на сайте посетитель может дать комментарий к содержимому страницы. Комментарий - не форум, там не ведётся обсуждений или разъяснений. Это инструмент для сообщений нам об ошибках, неточностях. Для отправки комментария воспользуйтесь расположенной в правом нижнем углу окна браузера кнопкой:

Кроме учебного курса пользователям будет полезно пользоваться Базой знаний техподдержки.

Для преподавания оффлайн

Если данный курс берётся в качестве основы для оффлайного преподавания, то рекомендуемая продолжительность: 3 дня (21 академический час).

Примечание: в рамках курса слова сайт и корпоративный портал являются синонимами.