Публичный интерфейс
1 / 45

Для управления информацией, представленной на страницах сайта, служит Панель управления, подключаемая вверху страницы после авторизации пользователя в системе:

Нажмите на рисунок, чтобы увеличить

Панель управления поддерживает 4 режима работы системы. Из них три - это режимы работы публичного раздела сайта, а четвертый - это переход в административную часть:

  • Режим Просмотр служит для просмотра страниц сайта, также позволяет выполнять типовые операции по сайту.
  • Режим Редактирование содержит расширенный набор действий и операций по сайту (управление доступом, работа с документооборотом и др.). Режим предназначен для использования редакторами сайта.
  • Режим Разработка также относится к одному из режимов работы публичной части. Режим включает все действия, доступные в режимах Просмотр и Редактирование, и содержит дополнительные возможности (управление компонентами, стилями шаблона сайта, отладочная информация). Режим предназначен для разработчиков.
  • Закладка Панель управления позволяет перейти в административный раздел сайта, который предоставляет полный набор возможностей по управлению и настройке сайта.
© «Битрикс», 2001-2008, «1C-Битрикс», 2008-2014 1С-Битрикс


Режим Просмотр
2 / 45

Режим Просмотр - это состояние административной панели, которое служит для просмотра страниц в том виде, как они будут доступны простым пользователям. В этом режиме также можно выполнять основные операции по управлению содержанием сайта:

  • Создание страницы или раздела:

    Страницы, разделы или включаемые области для страниц и разделов, а также форум с использованием режима ЧПУ создаются из публичной части с помощью мастера. С его помощью пользователь, не имеющий подготовки, сможет создать страницу или раздел, последовательно внося данные на каждом шаге мастера. Содержание страницы создается в визуальном редакторе, загружаемом прямо в публичной части.

  • Редактирование текущей страницы и изменение свойств страницы или раздела:

    Редактирование страницы производится либо в визуальном редакторе, либо в виде HTML-кода без визуального представления. Свойства страницы или раздела изменяются в специальной форме. Все формы загружаются прямо в публичной части. После сохранения изменения сразу вступают в силу.

  • По кнопке [image] можно управлять структурой сайта непосредственно в публичном разделе сайта:

    Примечание: данная функция доступна только тем пользователям, которые обладают правами на изменение корневого раздела сайта.

    Вы можете добавлять, удалять страницы и разделы, управлять свойствами и доступом к разделам, редактировать страницы. Все необходимые формы загружаются прямо в публичной части. После сохранения все изменения сразу вступают в силу.

  • Инструменты для поисковой оптимизации сайта доступны по кнопке [image]. При ее нажатии прямо в публичном разделе загружается форма Инструменты для поисковой оптимизации страницы:

    Нажмите на рисунок, чтобы увеличить

    Используя данные инструменты, вы можете просматривать статистику страницы (адрес, размер в байтах, количество слов), статистику переходов на нее, статистику индексации страницы и сайта поисковыми системами, статистику сайтов, ссылающихся на эту страницу, изменять заголовок, задавать ключевые слова, описание, производить анализ продвигаемых слов.

  • Редактирование меню:

    Вы можете отредактировать пункты меню в форме из публичной части:

    После сохранения изменения сразу вступят в силу.

  • Получение информации по статистике данного сайта:

    Вы можете получить минимальную информацию по статистике сайта. Есть возможность построить график посещаемости данной страницы, а также вывести статистику переходов по ссылкам с данной страницы.

  • Управление кешем страницы:

  • Изменение профиля текущего пользователя выполняется по кнопке [image], при этом открывается форма редактирования параметров пользователя в административном разделе сайта.
  • Кнопка [image] служит для завершения авторизованного сеанса работы текущего пользователя.

В случае необходимости административная панель может быть временно скрыта:

Развернуть ее в нужный момент можно по стрелке вниз:

Панель может быть зафиксирована вверху экрана:

Кроме того, административная панель позволяет переходить на заранее определенную страницу административной части. Это выполняется с помощью кнопки Пуск. Разделы административной части подгружаются динамически:

Таким образом, вы можете сразу перейти, например, на страницу со списком заказов:

Нажмите на рисунок, чтобы увеличить


Режим Редактирование
3 / 45

Режим Редактирование создан специально для изменения содержания страниц и разделов на сайте. Он включает в себя все возможности режима Просмотр, а также дополнительно позволяет:

  • Создать страницу или раздел не только в публичном разделе с помощью мастера, но и в административном разделе с помощью традиционных форм:

  • Изменить страницу или свойства раздела также можно с помощью мастера из публичного раздела или в административном разделе с помощью форм редактирования:

  • Управлять структурой сайта из публичной части или перейти в административный раздел для управления текущим разделом сайта:

  • Управлять доступом к текущей странице или разделу из публичной части:

  • Удалить текущую страницу: .
  • Создать, изменить или просмотреть историю изменений текущей страницы через Документооборот:

Кроме того, в режиме Редактирование удобно переходить к изменению содержимого страницы и ее свойств прямо из рабочей области:

С помощью двойного клика мыши по странице (вне областей компонентов) также будет осуществлен переход к ее изменению в редакторе.

В режиме Редактирование вся информация, размещенная во включаемых областях и компонентах, доступна для быстрого редактирования:

Вы можете:

  • Отредактировать включаемые области:

  • Управлять содержанием компонентов, размещенных на странице.

    Например, меню действий компонента, выводящего структуру разделов инфоблока Каталог книг, содержит такие операции:

    При выборе действия Добавить книгу подгружается форма редактирования элемента в публичной части:

    Нажмите на рисунок, чтобы увеличить

    После сохранения элемент будет добавлен и опубликован в публичной части.


Режим Разработка
4 / 45

Режим предназначен для использования разработчиками сайта, т.к. предоставляет возможности по изменению внешнего облика сайта (настройки параметров компонентов, изменение стилей шаблона сайта и др.)

Режим Разработка содержит все действия из режимов Просмотр и Редактирование и дополнительно позволяет:

  • Редактировать текущую страницу в режиме полного php-кода:

  • Редактировать параметры компонентов, использованных на текущей странице:

  • Редактировать шаблон: изменить стили сайта и стили шаблона в форме из публичной части или перейти к полному редактированию шаблона в нужном разделе панели управления:

  • Расширены возможности работы с кешем: можно обновить кеш компонентов:

  • Режим предоставляет разработчику отладочную информацию, которая позволяет оценить время отработки различных областей на странице, компонентов или всей страницы в целом:

Компоненты и включаемые области выделены на странице и для каждой имеется определенный набор действий, доступный по клику на иконку [image]:

В режиме Разработка доступны следующие действия над компонентами (например, для компонента Меню (bitrix:menu)):

  • Редактировать параметры компонента в форме из публичной части. После сохранения установленные настройки будут сразу применены.
  • Копировать шаблон компонента.
  • Редактировать шаблон компонента - позволяет изменить текущий шаблон. Однако если применен системный шаблон, то его необходимо сначала скопировать в шаблон сайта.
  • Другие действия, набор которых зависит от специфики данного компонента.

Примечание: подробно о работе с компонентами смотрите в разделе Компоненты 2.0 (начальные сведения).


Административный интерфейс
5 / 45

Административный раздел - раздел системы, содержащий интерфейс для управления модулями системы, структурой, содержанием, посетителями и другими составляющими сайта. Недоступен для просмотра обычным посетителям сайта.

В главе рассмотрены основные элементы интерфейса Административного раздела системы, позволяющие осуществлять полное управление содержанием и настройками сайта. (В документации иногда может использоваться выражение "Административная часть" как синоним Административного раздела.)

Для перехода в Административный раздел служит закладка [image], расположенная на Панели управления в публичном разделе сайта.


Элементы административного раздела
6 / 45

Интерфейс административного раздела системы "1С-Битрикс: Управление сайтом" логически разграничен на области, обеспечивающие доступ к функциональным возможностям системы.

Интерфейс системы построен по иерархическому принципу: вышестоящие области интерфейса переключают зависимые области в тот или иной режим работы. Это позволяет скрыть функциональные возможности системы, в которых нет потребности в данный момент, и вынести на первый план требуемые функции. Такая организация интерфейса обеспечивает его наглядность и неперегруженность.

Административная панель управления

Функционал панели:

Команды Панели управления
 | Служит для быстрого доступа к страницам административного раздела.
 | Закладка Сайт - переход в публичный раздел.
 | Закладка Администрирование.
 | Индикатор свободного места. Виден только на SAAS решениях.
 | Переход к изменению профиля текущего пользователя в форме административного раздела. Ссылка Выйти завершает авторизованный сеанс в административном разделе.
 | Позволяет закрепить административную панель управления. Эта кнопка расположена на правом конце панели.
 | Добавляет текущую страницу в список избранного. Страница добавляется со всеми активными в данный момент настройками фильтра.
 | Открывает форму настроек активного модуля, либо позволяет перейти к настройкам интерфейса административной части. Например, если открыт раздел Управление структурой, эта кнопка открывает форму настроек модуля Управление структурой.
 | Открывает (в отдельном окне) соответствующую страницу системы помощи с сайта компании 1С-Битрикс.
 | Открывает форму получения обновлений системы. Если в настройках Главного модуля выставлена автопроверка обновлений, то, при наличии обновлений, зеленая иконка меняется на анимированную красную иконку. Кроме этого появится всплывающее окно с информацией об обновлениях.
 | Позволяет переключиться на другой (установленный в системе) язык административного интерфейса.
 | Позволяет перейти к списку невыполненных заданий в модуле Бизнес-процессы. Кнопка отображается на панели, если установлен модуль Бизнес-процессы и у текущего пользователя есть невыполненные задания.
 | Поиск в Панели управления по пунктам меню и настройкам модулей.

Административная панель управления содержит общие элементы, которые могут понадобиться при управлении сайтом.

Команды Панели управления
 | Служит для быстрого доступа к страницам административного раздела.
 | Режим служит для просмотра страниц. В этом режиме можно выполнять основные операции по управлению содержанием сайта. Если удерживать клавишу Shift, публичный раздел откроется в новом окне браузера. Подробнее...
 | Режим служит для изменения содержания страниц. Подробнее...
 | Режим предназначен для использования разработчиками сайта, т.к. предоставляет возможности по изменению внешнего облика сайта (настройки параметров компонентов, изменение стилей шаблона сайта и др.) Подробнее...
 | Открывает административный раздел сайта - служит для полного управление настройками системы, отдельных модулей и контентом сайтов.
 | Добавляет текущую страницу в список избранного. Страница добавляется со всеми активными в данный момент настройками фильтра.
 | Открывает форму настроек активного модуля. Например, если открыт раздел Управление структурой, эта кнопка открывает форму настроек модуля Управление структурой.
 | Открывает (в отдельном окне) соответствующую страницу системы помощи с сайта компании 1С-Битрикс.
 | Открывает форму получения обновлений системы. Если в настройках Главного модуля выставлена автопроверка обновлений, то, при наличии обновлений, зеленая иконка меняется на анимированную красную иконку. Кроме этого появится всплывающее окно с информацией об обновлениях.
 | Позволяет переключиться на другой (установленный в системе) язык административного интерфейса.
 | Переход к изменению профиля текущего пользователя в форме административного раздела.
 | Завершает авторизованный сеанс в административном разделе.
 | Позволяет перейти к списку невыполненных заданий в модуле Бизнес-процессы. Кнопка отображается на панели, если установлен модуль Бизнес-процессы и у текущего пользователя есть невыполненные задания.
 | Позволяет закрепить административную панель управления. Эта кнопка расположена на правом конце панели.

Административное меню

С помощью этой панели можно выбрать обособленный набор функций, относящийся к определенной функциональной части системы. В зависимости от того, установлены ли те или иные модули, состав административного меню может различаться.

Рабочий стол - инструмент для организации удобного управления работой сайта с помощью произвольно размещаемых гаджетов.

Набор функций Контент содержит инструменты для управления информационными блоками, структурой сайта (т.е. папками и файлами), а также настройки документооборота и управления документами.

Набор функций Сервисы наиболее зависим от наличия в системе тех или иных модулей. Полный набор функций позволяет управлять опросами, веб-формами, рекламой, рассылками, техподдержкой, форумами и почтовой системой.

Набор функций Магазин позволяет осуществить продажу товаров и услуг с сайта.

Набор функций Веб-аналитика полностью посвящен функциям сбора, обработки и отображения статистики по сайтам. Этот раздел присутствует, только если установлен модуль Веб-аналитика.

Набор функций Marketplace позволяет обновлять систему, устанавливать и обновлять партнерские модули и решения.

Набор функций Настройки позволяет управлять пользователями, валютами интернет-магазина, шаблонами, получать обновления системы, а также настраивать прочие параметры сайта и системы.

Примечание: в административном меню Эрмитажа до v.11 отсутствует пункт Marketplace.

Меню функций

Содержимое этой панели зависит от того, какой пункт меню выбран в предыдущей области.

Выбирая пункты дерева-меню, можно получить доступ непосредственно к тем функциям, которым они соответствуют. При этом, рабочая область (4) будет отображать интерфейс для работы именно с этими функциями.

Такое дерево-меню строится системой динамически с использованием технологии AJAX. Код, ответственный за построение меню, опрашивает все установленные в системе модули, которые, в свою очередь, возвращают данные, необходимые для добавления пунктов меню. Поэтому при открытии страницы административного раздела или развертывании узла меню в первый раз (например, списка информационных блоков), меню может появиться с некоторой задержкой, о чем будет выведено соответствующее предупреждение.

В случае необходимости административное меню и меню функций могут быть временно скрыты/развернуты с помощью соответствующих стрелок. Стрелки появляются при наведении указателя мыши к черте, разделяющей Меню функций и Рабочую область. С помощью кнопки, можно свернуть Меню функций, с помощью курсора придать ему нужную ширину.

Основная рабочая область

Рабочая область - это основная область, в которой происходит большинство операций по управлению сайтом:

  • просмотр элементов, составляющих контент сайта (например, информационных блоков, баннеров и т.п.);
  • добавление контента;
  • создание и удаление папок и файлов;
  • настройка меню и т.д.

Такие операции реализуются формами двух основных видов:

  • формы отчетов (или списки элементов) - предназначены для просмотра элементов в форме таблиц, а также, в отдельных случаях (например, формы статистики) - в форме графиков и диаграмм;
  • формы редактирования - применяются для добавления и правки элементов контента, а также для задания настроек модулей и системы в целом.

Формы, отображаемые в рабочей области, имеют общие элементы. Ознакомьтесь с их функциями - это значительно облегчит дальнейшую работу с сайтом.

Для удобства текущего управления сайтом рекомендуется настроить Рабочий стол в Основной рабочей области.

Пиктограмма [image], расположенная рядом с названием, содержит ссылку на текущую страницу (с учетом переходов по AJAX). Скопировать ссылку в буфер обмена можно, нажав на пиктограмме правой кнопкой мыши и выбрав команду Копировать ярлык. Ссылка на страницу может понадобиться вам, например, при обращении в службу технической поддержки компании 1C-Битрикс.

Контекстная панель

Если отображаемая форма позволяет производить какие-либо действия в отношении отображаемых элементов, ниже фильтра на форме может располагаться контекстная панель, содержащая такие команды. Контекстные панели могут отображаться как на формах отчетов, так и на формах редактирования. Например, форма отчета на странице Каталог книг (Контент > Информ. блоки > Типы информ. блоков > Каталог книг) имеет такую контекстную панель:

  • кнопка Настроить выводит диалоговое окно, в котором пользователь может выбрать колонки, которые требуется отобразить в таблице отчета данной формы, а также задать некоторые параметры, применяемые по умолчанию (поле и направление сортировки и т.п.).
  • кнопка Excel позволяет выполнить экспорт элементов формы отчета в Microsoft Excel.


Форма отчета (Списки элементов)
7 / 45

Форма отчета (Списки элементов)

Список элементов выводится при выборе какого-либо пункта в меню функций. В списках отображена подробная (обычно - наиболее важная) информация об элементах. Например, выбрав пункт Баннеры в разделе Сервисы, пользователь получает информацию об имеющихся в системе баннерах:

На странице со списком элементов обычно выводится фильтр, контекстная панель, сам список элементов и панель действий под списком.


Фильтр
8 / 45

Фильтр - средство для поиска данных, предназначенное для отбора информации, отображаемой в списках элементов. Указав критерии поиска (отбора) в фильтре, можно найти и показать не все, а только требуемые данные (обычно - записи базы данных).

Типичный фильтр выглядит так:

Кнопка Показать фильтр отображает фильтр и все критерии поиска. Нажатие кнопки Свернуть фильтр скрывает его, оставляя видимой лишь панель управления фильтра. Нажав кнопку Дополнительно, можно выбрать, какие поля фильтра следует показать, а какие - скрыть.

Для поиска в поля можно вводить неполные параметры. Например, если ввести "справ", то поиск выберет все элементы, содержащие в названии эту часть слова: Справка, Справочная информация, Справить дело и так далее.

Параметры, по которым фильтр может отображать данные будут различными для разных форм. Различно и их число. По умолчанию показывается всегда одно поле: Имя (или аналог этого понятия).

Элементов в таблице может быть очень много и даже после фильтрации. Для удобства просмотра предусмотрена возможность вывода на странице разного количества элементов: от 20 до всех сразу. Выбор количества выводимых элементов, а так же кнопки для перемещения по страницам списка, размещен между контекстной панелью и самой таблицей.


Таблица элементов
9 / 45

Таблица элементов - основное средство для группировки и отображения информации в системе. Они бывают самые разные, в зависимости от типа элементов. Несмотря на свое разнообразие,таблицы имеют схожие поля.

Колонка флажков

Колонка флажков позволяет выбрать один или более элементов для выполнения над ними каких-либо действий. Установка флажка в заголовке таблицы приводит к выбору всех элементов таблицы, отображаемых на данной странице.

Действия над отмеченными элементами производятся путем выбора требуемой команды в панели действий, расположенной ниже таблицы. Чтобы применить действие сразу ко всем элементам таблицы, нужно установить флажок в поле Для всех:

Примечание: Для группового выбора есть несколько дополнительных инструментов. Это флажок Для всех на Панели действий внизу Таблицы элементов и флажок в колонке Отметить все в заглавной строке Таблицы элементов. Разница между этими флажками в том, что первый отмечает все элементы таблицы, даже те, которые отображены на других страницах. А второй отмечает только элементы на открытой странице.

Меню действий

Колонка Меню действий содержит кнопки, нажатие на которые приводит к появлению контекстного меню, в котором можно выбрать желаемое действие, допустимое над элементом таблицы. Например, элементы таблицы страницы Статьи (Контент > Статьи > Статьи) предполагают такие действия:

Настройка списка элементов

Таблицы элементов разных форм отчета тоже, как Фильтр, могут отличаться между собой по числу и названию колонок. Вид таблицы зависит от типа выводимых данных и ваших настроек.

Кнопка Настроить, расположенная на контекстной панели списка элементов, вызывает диалог в котором пользователь может выбрать колонки, которые требуется отобразить в таблице отчёта данной формы, а также задать некоторые параметры, применяемые по умолчанию:

Полностью удалять все параметры из поля Выбранные колонки – нельзя, должна оставаться хоть одна колонка. Кроме изменяемых колонок в Таблице элементов есть и постоянные, неудаляемые. Это Колонка флажков и Колонка действий.

По умолчанию настройки каждой таблицы сохраняются для текущего авторизованного пользователя. Установка флажка в поле Установить данные настройки по умолчанию для всех пользователей позволяет применить выбранные параметры формы для всех зарегистрированных пользователей, имеющих доступ к административному разделу.

Для применения выбранных настроек нажмите кнопку Сохранить. Для возврата к настройкам таблицы по умолчанию нажмите Сбросить.


Пример быстрого редактирования группы элементов
10 / 45

Допустим, необходимо отредактировать список новостей из новостного инфоблока: изменить порядок их вывода, поменять название, одну новость сделать неактивной на определенный промежуток времени, и одну новость удалить. Рассмотрим как это сделать наиболее быстрым способом.

В административном разделе зайдите на страницу со списком элементов инфоблока новостей:

В меню действий новости, которую требуется удалить, выберите Удалить:

Нажмите ОK в окне подтверждения и новость будет удалена.

Отметьте все оставшиеся новости, выставив галочку в поле Отметить все/Снять отметку у всех:

Примечание: для удаления, активации\деактивации всех элементов инфоблока, в том числе размещенных на нескольких страницах, удобно использовать опцию Для всех. Кроме того, вы можете изменять количество элементов, выводимых на одну страницу списка, выставив нужное значение в поле На странице.

Примечание: При отметке хотя бы одной новости станет видна Панель действий каким бы большим не был список элементов.

На панели групповых действий нажмите Редактировать, после чего изменится вид списка элементов инфоблока, и их станет возможно редактировать прямо на данной странице.

Непосредственно в колонке Название отредактируйте заголовок нужной новости:

Поменяйте порядок сортировки другой новости:

Снимите галочку активности, чтобы сделать на время новость недоступной для просмотра в публичном разделе:

Нажмите Сохранить и все внесенные вами изменения вступят в силу.


Форма редактирования элемента
11 / 45

Этот тип форм применяется для изменения элементов контента сайта или для настройки системных параметров. Например, выбрав пункт Изменить меню действий информационного блока, можно открыть форму детальной правки этого инфоблока.

В отличие от Форм отчета, которые более-менее типовые, Формы редактирования настолько разнообразны, что даже невозможно показать – относительно типовой образец. В форме может быть много полей и закладок. Но функции у них у всех одинаковые: создание каких-либо элементов и их редактирование.

Поскольку элементы контента (или формы настроек системных модулей) могут иметь большое число изменяемых свойств, многие формы редактирования реализованы при помощи страниц свойств или вкладок.

Страницы свойств, с момента своего появления, крайне широко используются при построении пользовательского интерфейса. Их применение позволяет разбить многочисленные свойства элемента на логические группы и, таким образом, сделать интерфейс более легким и понятным. Обычно свойства сгруппированы так, что на первых страницах свойств (в порядке слева направо) помещаются наиболее часто используемые, а на последних - другие, дополнительные параметры.

Иллюстрация показывает часть формы со страницами свойств информационного блока:

Для краткости, в справочной системе используется термин вкладка как синоним страницы свойств.

Если пользователю удобнее просматривать все поля формы в одной вкладке, то для показа всех полей в одном окне (или возврата в табулярный режим) предназначена кнопка в правой части области закладок:

Отображение всех полей формы на разных закладках:

Отображение всех полей формы на одной закладке:

Поля, обязательные для заполнения, в формах редактирования выделяются жирным шрифтом.

Настройка форм

Внешний вид формы можно настроить для удобства редактирования: изменить состав и количество вкладок и полей. (На данный момент это доступно только для некоторых типов форм: элементы инфоблока, разделы инфоблока и пользователи.) Для того чтобы вернуть вид настроек форме по умолчанию используйте кнопку:

кнопка "Отменить действие настроек формы на время сессии"


Рабочий стол
12 / 45

Рабочий стол - инструмент для организации удобного управления работой сайта с помощью произвольно размещаемых гаджетов.

Система запоминает настройки Рабочего стола для каждого пользователя.

Нажмите на рисунок, чтобы увеличить

Гаджеты

Гаджет – особый программный элемент, выполняющий функцию вывода определенных данных.

Гаджетом еще называют современные электронные приборы типа мобильного телефона, карманного компьютера и других. В «1С-Битрикс: Управление сайтом» описываемые программные элементы называют гаджетами по аналогии с похожими программными элементами от компании Google. Аналогичные программные элементы для операционной системы Windows называются виджеты. Но так как «1С-Битрикс: Управление сайтом» может быть установлен не только на ОС Windows, но и на ОС Linux и другие, то решено не использовать термин «виджет».

С помощью гаджетов на странице может быть представлена самая разнообразная информация.

Список гаджетов
Список гаджетов
Название | Функционал
Группа Личное. Гаджеты для работы с персональными инструментами
Заметки
    Создание/изменение текстовых заметок.
Избранные ссылки
    Создание собственного мини-каталога ссылок.
Группа Внешние сервисы. Сервисы для получения информации из Интернета
RSS лента
    Вывод сообщений с внешнего источника.
Прогноз погоды
  • Прогноз погоды по выбранной местности.
  • Быстрый переход к сервису Яндекс.Погода.
Гаджеты Google
    Добавление гаджетов Google.
Задачи и события | Гаджет для получения информации о задачах с портала Битрикс24
Группа Контент. Гаджеты раздела Контент.
Элементы инфоблока
  • Вывод списка элементов инфоблока согласно настройкам гаджета.
  • Быстрый переход к форме редактирования элемента.
Группа Магазин. Гаджеты раздела Магазин.
Заказы
  • Вывод списка элементов инфоблока согласно настройкам гаджета.
  • Быстрый переход к форме редактирования элемента.
Статистика по товарам | Вывод статистики по самым продаваемым и самым просматриваемым товарам.
Графики по продажам | Графики по доходу и по количеству.
Мобильное приложение | Работа с мобильным приложением.
Группа Веб-аналитика. Гаджеты раздела Веб-аналитика.
Статистика
  • Вывод статистики заказов и списка заказов.
  • Быстрый переход к соответствующим страницам раздела.
Группа Настройки. Гаджеты раздела Настройки Административной части
О системе | Информация о системе, обновлении, числе пользователей и другая.
Монитор производительности
  • Вывод текущей оценки производительности.
  • Быстрый переход к Панели производительности.
Монитор качества | Вывод оценок Монитора качества.
Проактивная защита
  • Вывод текущего уровня защиты.
  • Быстрый переход к Панели безопасности.
Marketplace | Переход к выбору решений из каталога.
Битрикс24 | Подключение Битрикс24
Инспектор сайтов | Переход к настройкам Инспектора. Текущая информация по Инспектору.

Примечание: В таблице описаны штатные гаджеты системы. Разработчики проектов на Bitrix Framework могут создать свои гаджеты и размещать их в системе.


Визуальный редактор
13 / 45

Глава курса знакомит контент-менеджера с правилами и возможностями работы в визуальном HTML-редакторе, который позволяет управлять информационным содержанием страницы в режиме реального времени через браузер. Большим преимуществом редактора является возможность работать с визуальными компонентами: размещать их на странице и настраивать их параметры, определяющие внешний вид динамически меняющейся информации. Также визуальный редактор обладает другими обширными средствами редактирования страниц.

WYSIWYG (произносится как «ви-зи-виг», от англ. What You See Is What You Get — «что видишь, то и получишь») — способ редактирования, при котором корректируемый материал в процессе редактирования выглядит в точности так же, как и конечный результат.

Визуальный редактор в "1С-Битрикс: Управление сайтом" является штатным функционалом и не требует дополнительной установки. Администратор сайта может запретить использование редактора в некоторых случаях. Если Визуальный редактор недоступен, то обратитесь к администратору.

Редактор работает с браузерами:

  • Internet Explorer версии 7 и выше;
  • Firefox версии 3.x и выше;
  • Opera версии 10.x и выше;
  • Safari версии 5 и выше;
  • Google Chrome версии 7 и выше.

Используя редактор, можно формировать и изменять содержание статических и динамических страниц, уроков обучающих курсов, элементов информационных блоков и других элементов.


Внешний вид редактора
14 / 45

Рассмотрим внешний вид редактора и его панели подробнее. Визуальный редактор, открываемый из Публичной части и из Административного раздела несколько различается по функционалу. Будем описывать окно редактора в Административном разделе, т.к. в нем доступен несколько более широкий набор кнопок и возможностей, чем в Публичной части.

Панель инструментов

Общая панель инструментов визуального редактора состоит из нескольких меньших панелей, в каждой из которых объединены кнопки по своему назначению. Детальное описание панелей приводится на страницах с описанием конкретных видов работ.

  • Стандартные

  • Шаблон сайта

  • Управление и настройки

  • Стиль

  • Форматирование

В административном разделе на каждой из этих панелек имеются специальные области для перемещения панели в любое место окна редактора.

При наведении курсора на выделенную область курсор меняет внешний вид.

Теперь вы можете перетаскивать панель в любую область редактора. После переноса вы можете ее закрыть, нажав на кнопку Х в правом верхнем углу панели.

Восстановить отображение панели можно с помощью кнопки [image] Настройки.

Примечание: Подробнее о настройке внешнего вида смотрите в уроке Настройка внешнего вида редактора.

Внимание! Состав и набор кнопок на панели инструментов может отличаться, в зависимости от режима работы редактора и настроек администратора.

Панель задач

Панель задач может состоять из нескольких закладок: Компоненты и Сниппеты.

Примечание: В версии продукта до 9.5 присутствует закладка Компоненты 1.0. Она позволяет добавлять на страницу компоненты 1.0, которые устарели и не рекомендуются к использованию.

Отображать и скрывать панели Компоненты и Сниппеты можно с помощью соответствующих кнопок панели 6. Доступны следующие действия управления панелью задач:

  • По кнопке Свернуть можно временно скрыть панель. Вернуть ее можно, используя кнопки панели 6.
  • Кнопка Обновить закешированные данные позволяет сбросить кеш, например, если были добавлены собственные компоненты.
  • Кнопка Настроить вызывает форму настройки внешнего вида редактора, которая также доступна по кнопке [image] Настройки панели инструментов.
  • Кнопка Закрыть закрывает отображаемую панель. Восстановить ее отображение можно с помощью формы настройки редактора (кнопка [image]).

Ниже вы можете познакомиться с видео-роликом, в котором подробно рассматриваются внешний вид редактора и его панели. (2 минуты 17 секунд, 7.86 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.

Панель переключения режимов редактирования

Панель переключения режимов редактирования состоит из следующих кнопок:

Кнопка [image] служит для перехода от визуального режима к работе с исходным кодом. В режиме работы с исходным кодом не все кнопки панели редактирования доступны. Можно работать только с панелью Управление и настройки [image], а также доступными остаются кнопки [image] и [image]. Остальные кнопки панели редактирования заблокированы.

Кнопка [image] служит для перехода обратно к режиму визуального редактирования.

Кнопка [image] служит для перехода в совмещенный режим редактирования, при котором можно работать одновременно и с визуальной частью, и с исходным кодом:

При работе с исходным кодом и в совмещенном режиме редактирования становится доступной кнопка [image], которая служит для переноса не поместившейся на текущей строке части кода на следующие строки. Заметим, что эта кнопка присутствует и работает только в браузере Internet Explorer.

Внимание! Режим работы с исходным кодом рекомендуется использовать только подготовленным пользователям.

Панель отображения свойств объектов (Свойства)

В области Свойства отображаются свойства того объекта, на котором установлен курсор мыши в данный момент. Это может быть визуальный компонент, тогда в области Свойства можно будет настроить параметры этого компонента. Панель Свойства также является скрывающейся, что регулируется кнопкой панели 6. Доступны следующие действия управления панелью Свойства:

  • По кнопке Свернуть можно временно скрыть панель. Вернуть ее можно, используя кнопки панели 6.
  • Кнопка Настроить вызывает форму настройки внешнего вида редактора, которая также доступна по кнопке [image] Настройки панели инструментов.

Ниже вы можете познакомиться с видео-роликом, в котором подробно рассматриваются внешний вид редактора и его панели. (2 минуты 17 секунд, 7.86 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.

Кнопки панели инструментов визуального HTML-редактора

Кнопка | Описание
Стандартные
 | Переключение в полноэкранный режим.
 | Изменение настроек визуального редактора.
 | Вставить из Word. Позволяет очистить добавляемый текст от дополнительных элементов форматирования (например, стилей).
 | Вставить фрагмент как текст.
 | Выделить все на странице.
 | Отменить выполненное действие.
 | Вернуть отменённое действие.
 | Отобразить или скрыть границы таблиц.
 | Создать таблицу.
 | Добавить якорь.
 | Вставить гиперссылку.
 | Удалить гиперссылку.
 | Добавить изображение.
 | Вставить специальный символ.
 | Вставить разрыв страницы для печати.
 | Вставить разделитель страниц <BREAK/>.
 | Вставить Flash-ролик.
Стиль
 | Уровень (формат) текста. Например, Normal, Heading1, Heading2, ... .
 | Шрифт.
 | Размер шрифта.
 | Полужирный.
 | Курсив.
 | Подчёркнутый.
 | Удалить форматирование.
 | Оптимизировать HTML-код.
Форматирование
 | Добавить горизонтальный разделитель.
 | Выравнивание абзаца по левому краю.
 | Выравнивание абзаца по центру.
 | Выравнивание абзаца по правому краю.
 | Выравнивание абзаца по ширине.
 | Нумерованный список.
 | Маркированный список.
 | Уменьшить отступ.
 | Увеличить отступ.
 | Цвет фона.
 | Цвет текста.
Режимы редактирования
 | Переключение в режим визуального редактирования.
 | Переключение в режим редактирования исходного кода страницы.
 | Переключение в совмещённый режим редактирования.
Шаблон сайта
 | Шаблон сайта.
Управление и настройки
 | Сохранение изменений и выход из визуального редактора.
 | Выход из редактора без сохранения.
 | Создание новой страницы.
 | Сохранить и продолжить редактирование.
 | Сохранить под другим именем.
 | Переход к редактированию параметров страницы.


Настройка внешнего вида редактора
15 / 45

Работая с визуальным редактором, вы можете настроить его внешний вид, который будет автоматически запомнен:

  • определить отображаемые панели;
  • отключить ненужные в данный момент панели задач или панели инструментов.

Для этого служит кнопка [image] Настройки панели инструментов. По нажатии на эту кнопку появляется диалоговое окно Настройки визуального редактора:

Форма настроек состоит из трех закладок:

  • Панели инструментов - служит для настройки показа панели инструментов. Есть возможность отключить ненужные в данный момент панели (снимая флаги рядом с названием панелей). Панель Стандартные отключить невозможно.

    Примечание: При запуске визуального редактора из публичной части закладка Панели инструментов не будет выведена. Т.е. регулировать набор панелек будет невозможно.

  • Панели задач

    Работая с опциями данной закладки, можно отключить отображение ненужных на данный момент панелей задач.

  • Дополнительные настройки

    Опция Показывать подсказки к параметрам компонентов управляет отображением всплывающих подсказок к настройкам компонентов при их изменении в панели Свойства.

    Опция Использовать визуальные эффекты позволяет при необходимости отключить визуальные эффекты, снизив, таким образом, нагрузку на систему.

Кнопка Восстановить по умолчанию позволяет восстановить отображение всех панелей визуального редактора в исходном виде.

Обратите внимание! Вы можете значительно ускорить загрузку визуального редактора, отключив не используемые панели инструментов и панели задач. Это можно выполнить в форме настройки редактора либо воспользовавшись крестиками в самом редакторе.

Примечание: Внешний вид редактора может быть настроен и администратором. Если вы не видите части кнопок или панелей, то обратитесь к администратору сайта.

Администратор сайта может в случае необходимости включить и полноэкранный режим работы визуального редактора.

Ниже вы можете познакомиться с видео-роликом, в котором наглядно демонстрируется процесс настройки внешнего вида редактора. (2 минуты 28 секунд, 7.09 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.


Режимы работы
16 / 45

Визуальный HTML редактор может быть вызван как из публичной части сайта, так и из административного раздела, и он служит следующим целям:

  1. Для редактирования страниц;
  2. Для редактирования текстовых описаний внутри формы, например, для редактирования элементов информационных блоков;
  3. Для редактирования шаблона сайта.

    Примечание: Возможность редактирования шаблона сайта предназначена для администраторов сайта, то есть специалиста, разбирающегося в вопросах вёрстки. Контент-менеджеру выполнять эту работу не рекомендуется.


Редактирование страницы
17 / 45

Редактировать страницу с помощью визуального HTML-редактора можно как из Публичной части, так и из Административного раздела (если имеется соответствующий доступ).

Примечание: Если к редактированию страниц имеют отношение несколько человек, то замечаниями по поводу текстов, картинок и прочего можно обмениваться с помощью удобного инструмента Веб-стикеры.

Редактирование страниц из публичного раздела

Для того, чтобы перейти к редактированию текущей страницы, нажмите кнопку Изменить страницу на Административной панели.

В Публичной части загрузится окно редактора над поверхностью сайта.

Редактирование страниц из административного раздела

Вы также можете работать с визуальным редактором в Административном разделе.

Для того, чтобы перейти к редактированию текущей страницы в Административном разделе, выберите в меню Изменить страницу пункт В панели управления.

Примечание: Редактирование страниц из административного раздела подробно рассмотрено в курсе Администратор. Базовый, урок Редактирование страниц из административного раздела.

Ниже вы можете познакомиться с видео-роликом, наглядно демонстрирующим способы редактирования страницы. (3 минуты 3 секунды, 10.46 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.


Редактирование текстовых описаний
18 / 45

Следующим режимом работы редактора является его использование для редактирования текстовых описаний внутри формы, например, для редактирования элементов информационных блоков.

Используя режимы работы публичного интерфейса можно добавлять/изменять элементы или разделы инфоблоков.

Приведем пример управления новостями.

  • Для этого перейдите в Режим правки.

  • Наведите курсор мыши на внутреннюю область страницы, где размещены новости.
  • На появившейся Панели компонента выберите кнопку Добавить новость/раздел.

Загрузится форма добавления, в которой можно использовать визуальный редактор.

Форма добавления новости

Аналогичный режим редактирования возможен для веб-форм:

Для редактирования уроков обучающих курсов также удобно использовать визуальный редактор:

Также визуальный редактор используется в других модулях системы: Опросы, голосования, Подписка, рассылки и др.

Внимание! Возможность использования визуального редактора может быть отключена администратором сайта. Кроме того, редактор может быть не виден, если в форме снят флажок с чекбокса Визуальный редактор.


Работа с текстом
19 / 45
Визуальный редактор обладает широкими возможностями для редактирования текста. В данной главе будут рассмотрены основные операции по работе с текстом такие, как:
  • форматирование текста веб-страниц, используя набор основных инструментов текстового редактора MS Word;
  • вставка текста напрямую из редактора MS Word с автоматической очисткой кода;
  • проверка орфографии и грамматики текстов сайта в визуальном редакторе.

Также будет рассмотрено создание таблиц и ссылок.


Форматирование текста
20 / 45

Визуальный редактор предоставляет различные средства форматирования текста. Опишем подробнее кнопки и выпадающие списки панели форматирования:

Стили шаблонов сайта

При переходе к редактированию страницы из административного раздела в списке шаблонов [image] будет выбран шаблон по умолчанию. Его таблица стилей (файл styles.css) будет подключена для использования для данной страницы.

Для каждого шаблона задается своя таблица стилей (файл styles.css). При смене шаблона в этом окне визуальный редактор подгрузит стили выбранного шаблона.

Для каждого из стилей шаблона может быть задано название. В визуальном редакторе описанные стили могут выводится как с названиями, так и без них в зависимости от настроек Визуального редактора в модуле Управление структурой.

Примечание: Все стили шаблона разделены на две таблицы стилей, хранящиеся в двух разных файлах. Один из них носит название styles.css и содержит стили для представления внутреннего содержания страниц на сайте. Во втором – с именем template_styles.css – описаны стили для представления шаблона дизайна. Эти стили отображаются при редактировании шаблона сайта с помощью визуального редактора.

Внимание! Выпадающий список шаблонов не предназначен для подключения шаблона дизайна к текущей странице. Условия для использования шаблонов задаются в настройках сайта. Указанный выпадающий список используется только для переключения таблиц стилей и шаблонов визуальных компонентов при редактировании содержания страницы.

Работа со стилями

Для каждого шаблона задается своя таблица стилей (файл styles.css), которые можно использовать для оформления текста. В визуальном редакторе описанные стили могут выводится как с названиями, так и без них в зависимости от настроек модуля Управление структурой.

В выпадающем списке можно выбрать необходимый стиль для текста или другого элемента страницы.

Разработчики и администраторы сайтов, как люди технические, используют технически верные названия стилей на латинице. Такие названия стилей для контент-менеджеров могут быть не совсем удобны и понятны. Визуальный редактор допускает изменение названий стилей на кириллические. Если у вас недостаточно прав, обратитесь за помощью к администратору сайта.

Для изменения названий стилей:

  • Откройте для редактирования используемый шаблон сайта.
  • Перейдите на вкладку Стили сайта.
  • В нижней части вкладки в области Описания стилей в поле Имя стиля введите действующее имя стиля. В поле Название стиля введите название стиля под которым вы хотите его видеть в визуальном редакторе.
  • Нажмите кнопку Еще. Откроется еще одна строка в этой области.
  • Повторите описанные выше действия для каждого из стилей, которые нуждаются в переименовании.

  • Сохраните внесенные изменения.

Теперь стили будут отображаться под выбранными вами названиями.

Работа с заголовками

В визуальном редакторе есть возможность управлять заголовками в тексте. Для этого существует выпадающий список, в котором можно выбрать нужное выделение заголовка:

Значение Normal из списка выбрано по умолчанию, оно соответствует отсутствию заголовка.

Таблица соответствий внешнего вида заголовка и его кода

Heading 1

<h1>Heading 1</h1>

Heading 2

<h2>Heading 2</h2>

Heading 3

<h3>Heading 3</h3>

Heading 4

<h4>Heading 4</h4>
Heading 5
<h5>Heading 5</h5>
Heading 6
<h6>Heading 6</h6>
Preformatted
<pre>Preformatted</pre>

Шрифты

В визуальном редакторе доступны следующие шрифты:

Задание шрифта при редактировании в режиме кода

<font face="font_name"> TEXT </font>

где font_name заменяется на название выбранного шрифта из списка доступных: Times New Roman, Courier, Arial, Tahoma, Verdana или Georgia.

Цвет фона текста задается по кнопке [image].

Задание цвета фона текста при редактировании в режиме кода

Выполнение действия происходит с использованием стиля для тега <font>. Например, при редактировании в режиме кода при выделении фона текста желтым цветом код будет выглядеть так:

<font style="BACKGROUND-COLOR: #ffff00">ТЕКСТ</font>

Цвет самого текста задается по кнопке [image].

Задание цвета текста при редактировании в режиме кода

Это действие выполняется помощью атрибута color тега <font>. Например, при редактировании в режиме кода при выделении текста желтым цветом код будет выглядеть так:

<font color="#3366ff">ТЕКСТ</font>

Размер шрифта

В редакторе могут быть использованы следующие размеры шрифтов:

Задание размера шрифта при редактировании в режиме кода

<font size="size_number">TEXT</font>

где size_number заменяется на размер шрифта от 1 до 7. Например, в визуальной части текст medium соответствует коду: <font size="4">medium</font>

Кнопки форматирования

Рассмотрим, с помощью каких тегов реализуется различное написание текста.

Кнопка | Текст | Теги
 | Жирный | <strong>Жирный</strong>
 | Курсив | <em>Курсив</em>
 | Подчеркнутый | <u>Подчеркнутый</u>

Кнопка [image] удаляет текстовое форматирование, т.е. удаляет тег <font> со всеми его атрибутами, отменяет выделение жирным, курсивом, подчеркивание.

Кнопка [image] позволяет вставить горизонтальный разделитель. В коде это действие выполняется с помощью тега <hr>

Кнопка [image] Оптимизировать HTML-код убирает пустые HTML-теги.
Список убираемых пустых тегов: b, em, font, h1, h2, h3, i, li, ol, p, small, span, strong, u, ul и т.д.

Выравнивание текста

Кнопка | Текст | Теги
 | По левому краю | <p align="left">По левому краю</p>
 | По правому краю | <p align="right">По правому краю</p>
 | По центру | <p align="center">По центру</p>
 | Выравниваем по ширине | <p align="justify">Выравниваем по ширине</p>

Списки элементов

В визуальном редакторе есть возможность создать два вида списков: нумерованный и маркированный. Первый вариант создается с помощью кнопки [image] и выглядит так:

  1. первый
  2. второй
  3. третий
Нумерованный список при редактировании в режиме кода

<ol>
  <li>первый </li>
  <li>второй </li>
  <li>третий </li>
</ol>

Второй вид, маркированный список, создается с помощью кнопки [image] и выглядит так:

  • первый
  • второй
  • третий
Маркированный список при редактировании в режиме кода

<ul>
  <li>первый </li>
  <li>второй </li>
  <li>третий </li>
</ul>

Сдвиг текста

В редакторе есть возможность увеличить отступ от края с помощью кнопки [image], а затем его можно уменьшить с помощью кнопки [image].

Сдвиг текста вправо при редактировании в режиме кода

<blockquote dir="ltr" style="MARGIN-RIGHT: 0px">
  <p>ТЕКСТ</p>
</blockquote>

Кнопка [image] сдвигает текст влево и убирает из кода тег <blockquote>

Примечание: в визуальном редакторе в области Свойства есть возможность просматривать и редактировать свойства того объекта, на котором установлен курсор мыши в данный момент. Для разных объектов набор свойств не одинаков. Например, для текста в панели Свойства представлены такие параметры:

Если выделено изображение, то:

А если выделить ссылку в рабочей области, то в Свойствах отобразится следующее:

Ниже вы можете познакомиться с видео-роликами, наглядно показывающим различные средства форматирования текста.

1. (3 минуты 24 секунды, 15.45 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.

2. (3 минуты 14 секунд, 9.78 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.


Копирование и вставка текста
21 / 45

Для копирования и вставки текста служат следующие кнопки:

Кнопка | Действие
 | Позволяет вырезать выделенный фрагмент и поместить его в буфер обмена.
 | С помощью этой кнопки можно скопировать какой-нибудь фрагмент в буфер обмена.
 | Вставляет фрагмент из буфера обмена.
 | Вставляет фрагмент из редактора MS Word. Позволяет очистить добавляемый текст от дополнительных элементов форматирования (например, стилей, шрифтов, дополнительных отступов).
 | Вставляет фрагмент как текст.
 | Позволяет выделить все содержимое страницы.

Рассмотрим разницу между возможными режимами вставки текста, скопировав текст из редактора MS Word в визуальный редактор разными способами. Пусть мы хотим скопировать из MS Word следующий текст:

Скопируем этот фрагмент в буфер и вставим его в содержание страницы тремя разными способами:

  1. При вставке текста из редактора MS Word по кнопке [image] Вставить появляется вопрос:

    При ответе OK действия редактора будут теми же, что и при вставке текста по кнопке [image] Вставить из Word. Работа в этом случае подробно описана ниже.

    Если на вопрос Хотите ли Вы очистить текст перед вставкой? ответить Отмена, то текст будет вставлен без удаления каких-либо элементов форматирования:

    В этом случае код будет таким:

    <p style="LINE-HEIGHT: normal; MARGIN: 12pt 0cm 3pt; mso-outline-level: 2" class="MsoNormal">
    <b><i><span style="FONT-FAMILY: &quot;Arial&quot;,&quot;sans-serif&quot;; COLOR: black; FONT-SIZE: 18pt;
     mso-fareast-font-family: 'Times New Roman'; mso-fareast-language: RU">
    Осень
    </span></i></b><b>
    <span style="FONT-FAMILY: &quot;Times New Roman&quot;,&quot;serif&quot;; FONT-SIZE: 18pt;
     mso-fareast-font-family: 'Times New Roman'; mso-fareast-language: RU">
          <p></p>
        </span></b></p>

    <p style="LINE-HEIGHT: normal; TEXT-INDENT: 35.4pt; MARGIN: 0cm 0cm 0pt" class="MsoNormal">
    <span style="FONT-FAMILY: &quot;Arial&quot;,&quot;sans-serif&quot;; FONT-SIZE: 9pt;
    mso-fareast-font-family: 'Times New Roman'; mso-fareast-language: RU">
    Еще очень тепло, но наступление осени ощущается в каждом дуновении ветерка.
    Деревья сбрасывают обожженную за лето листву. Кажется, что стволы темнеют,
    они устали и хотят спать. Неугомонные мелкие паучки с невероятной скоростью плетут паутины,
    и ты, не видя, срываешь их ловушки&hellip;
    </span><span style="FONT-FAMILY: &quot;Times New Roman&quot;,&quot;serif&quot;; FONT-SIZE: 12pt;
    mso-fareast-font-family: 'Times New Roman'; mso-fareast-language: RU"> </span>
    <span style="FONT-FAMILY: &quot;Arial&quot;,&quot;sans-serif&quot;; FONT-SIZE: 12pt;
    mso-fareast-font-family: 'Times New Roman'; mso-fareast-language: RU">
        <p></p>
      </span></p>

    <p></p>

    Как видим, при таком варианте вставки многое в коде является лишним. Это приводит к передаче лишней, незначимой информации, что в свою очередь увеличивает время ее загрузки.

    Если копировать текст из редактора MS Word с помощью комбинации клавиш Ctrl+Insert или Ctrl+C, а вставлять при помощи Shift+Insert и Ctrl+V соответственно, то редактор будет реагировать как в случае вставки текста по кнопке [image].

    Если вставлять текст из браузера при помощи этой же кнопки [image] Вставить, то он скопируется с сохранением форматирования без каких-либо предупреждений. Скопируем из браузера следующий фрагмент:

    Вставим его в содержание страницы с помощью кнопки [image]. Внешне он будет таким же как и в браузере, откуда мы его копировали. Код этого фрагмента текста будет таким:
    <ul>
    <li><strong><font class="text">15% </font></strong><font class="text">-
    при покупке товаров на сумму больше чем на $500</font> </li>

    <li><strong><font class="text">20% </font></strong><font class="text">-
    при покупке товаров на сумму больше чем на $800</font> </li>

    <li><strong><font class="text">25% </font></strong><font class="text">-
    при покупке товаров на сумму больше чем на $1500</font> </li>

    </ul>
    Код этого фрагмента текста – стандартные HTML-теги без дополнительного форматирования.
  2. По нажатии на кнопку [image] Вставить из Word появляется диалоговое окно для установки уровней очистки текста от тегов редактора MS Word. Отметим, что пустые теги (<span></span>, <p></p>), незначащие стили, все размеры шрифта и некоторое другое форматирование будет удалено автоматически. Это позволяет сократить размер страницы и увеличить скорость ее загрузки, при этом сохранив основное оформление текста.

    В данном диалоге, работая с опциями, можно управлять уровнями очистки кода копируемого фрагмента: удалять или сохранять определения шрифтов, стилей, отступы.

    Если отключить все опции, т.е. сохранить определения шрифтов, стилей и отступы, то в диалоговом окне можно увидеть HTML-код до изменения.

    После нажатия кнопки Сохранить текст в визуальном редакторе будет выглядеть так:

  3. Если вставлять "как текст", т.е. по кнопке [image] Вставить как текст, то удаляется вообще какое-либо форматирование. Как видим, осталось только выделение абзацев:

    Код в этом случае будет таким:

    Осень
    <br />
    Еще очень тепло, но наступление осени ощущается в каждом дуновении ветерка.
    Деревья сбрасывают обожженную за лето листву.
    Кажется, что стволы темнеют, они устали и хотят спать.
    Неугомонные мелкие паучки с невероятной скоростью плетут паутины,
    и ты, не видя, срываешь их ловушки&hellip;
    <br />
    То есть, при вставке текста по кнопке [image] любое форматирование будет удалено, не зависимо от источника копирования.
Примечание: в любой момент (до сохранения изменений) вы можете отменить выполненные действия с помощью кнопки [image] и заново повторить действие после отмены по кнопке [image].

Ниже вы можете познакомиться с двумя видео-роликами, наглядно демонстрирующими способы копирования и вставки текста.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик. (3 минуты 1 секунда, 12.01 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик. (1 минута 51 секунда, 5.05 Мб.)


Проверка орфографии
22 / 45

Визуальный редактор предоставляет возможность проверки орфографии введенного текста. Возможны 2 способа проверки:

  • С помощью редактора MS Word (проверка производится на компьютере пользователя);
  • С помощью pSpell (проверка производится в браузере, при условии если pSpell установлен на сервере).
Примечание: Способ проверки орфографии задается администратором сайта.

По умолчанию в визуальном редакторе будет проводиться проверка орфографии с помощью редактора Microsoft Word, если он установлен на компьютере пользователя.

Наиболее предпочтительным методом является проверка с помощью редактора MS Word, т.к второй способ требует пересылку слов для проверки на сервер.

Примечание: Некоторые браузеры обладают встроенной системой проверки орфографии, например Mozilla Firefox.

Проверка орфографии с помощью редактора MS Word

Перейти к проверке орфографии можно с помощью кнопки [image] Проверить орфографию. В случае, если орфография проверяется с помощью редактора MS Word, пользователь получит предупреждение о том, что на данной странице будет использован компонент ActiveX, который выполняет взаимодействие с редактором MS Word:

Диалог: использование компонента ActiveX

Необходимо подтвердить использование компонента на данной странице (кнопка Да). И после этого появляется форма проверки орфографии:

Форма проверки орфографии

Здесь вы можете исправлять ошибки и продвигаться дальше по тексту с помощью кнопок этой формы. После того, как проверка всей страницы закончена, появляется сообщение об этом:

Проверки орфографии завершена

Внимание! При попытке проверить орфографию (после нажатия кнопки [image] Проверить орфографию) может возникнуть предупреждение:

В этом случае необходимо разрешить загрузку ActiveX компонента в настройках безопасности браузера или добавить сайт, на котором производится проверка орфографии, в зону Trusted sites (Надежные узлы).

Ниже вы можете познакомиться с видео-роликом, наглядно демонстрирующим способы работы с системой проверки орфографии. (2 минуты 2 секунды, 17.59 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.

Проверка орфографии с помощью pSpell

В случае, если орфография проверяется с помощью редактора pSpell, откроется форма проверки орфографии:

Форма проверки орфографии pSpell

С помощью кнопки Добавить можно занести неизвестное системе слово в словарь.

Ниже вы можете познакомиться с видео-роликом, наглядно демонстрирующим способы работы с системой проверки орфографии. (1 минута 44 секунд, 6.99 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.


Добавление специальных символов
23 / 45

Кнопка [image] Вставить специальный символ предназначена для вставки специальных символов. При нажатии на нее появляется таблица различных специальных символов. При наведении курсора мыши на символ, его увеличенное изображение вместе с названием появляется в правом верхнем углу таблицы:

При единичном клике по нужному символу он появится на странице.

Ниже вы можете познакомиться с видео-роликом, наглядно демонстрирующим способы добавления специальных символов. (29 секунд, 2.55 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».
Загрузить ролик.


Работа с таблицами
24 / 45

При работе с визуальным редактором есть возможность создавать и редактировать таблицы с использованием специального интерфейса без непосредственного написания HTML-тегов.

Создание новой таблицы

Рассмотрим создание новой таблицы подробнее.

  • Выберите место на странице, где бы вы хотели видеть таблицу, установите в это место курсор и нажмите кнопку [image] Вставить таблицу панели редактирования. Появится диалоговое окно:

  • Заполните следующие поля формы:
    • Количество Строк и Столбцов;
    • Ширина и Высота таблицы в пикселях или в процентах;
    • Толщина рамки;
    • Выравнивание таблицы;
    • Стиль (В списке перечислены все стили, определенные в системе);
    • Параметры Cellpadding и Cellspacing.
  • После указания всех желаемых параметров нажмите кнопку Сохранить.

Пустая таблица появится на странице. Теперь можете приступать к ее заполнению.

Редактирование существующей таблицы

Если толщина границы равна 0, то просмотреть структуру таблицы можно с помощью кнопки [image] Показать границы таблиц.

Чтобы отредактировать структуру существующей таблицы, подведите указатель мыши к таблице и кликните правой кнопкой. Появится контекстное меню:

Контекстное меню таблицы

В нем вы можете выбрать любой нужный пункт для редактирования таблицы или изменить свойства таблицы по вашему усмотрению. Отдельно сгруппированы действия с ячейкой, строкой и столбцом.

Примечание: набор пунктов контекстного меню зависит от объекта, на котором расположен указатель мыши, когда вызывается меню. Например, если вызвать контекстное меню на картинке, которая расположена в таблице, то меню будет содержать и пункты редактирования таблицы и пункт редактирования картинки. Оно примет вид:

Пункты меню таблицы

Примечание: при выделении таблицы мышью, в области Свойства можно будет редактировать параметры таблицы:
  • стиль написания текста,
  • выравнивание содержимого ячеек,
  • перенос по словам, цвет фона,
  • ширину и высоту текущей ячейки таблицы,
  • размеры таблицы.
Перемещение по таблице возможно с помощью выделенной цепочки. При нажатии на отдельные теги цепочки станут доступны свойства соответствующей строки или столбца.

Примечание: при выделении таблицы, можно также изменить ее размер, потянув за уголок курсором мыши.

Примечание: в браузере Mozilla Firefox есть дополнительная возможность вставлять столбцы и строки, а также удалять их. При редактировании страницы нажмите (для наглядности) кнопку [image], щелкните мышью по ячейке таблицы. Она выделится следующим образом:

Дополнительная возможность в браузере Mozilla Firefox

И теперь, пользуясь стрелками влево и вправо, можно вставлять столбцы соответственно слева и справа от выделенной ячейки. Аналогично, с помощью стрелок вверх и вниз можно вставлять строки. А нажимая на крестик между стрелками, можно удалить строку или столбец.

Ниже вы можете познакомиться с видео-роликом, наглядно демонстрирующим процесс создания и редактирования таблиц с использованием специального интерфейса. (2 минуты 46 секунд, 7.74 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.


Работа с гиперссылками
25 / 45

Для создания и изменения гиперссылок также предусмотрены отдельные кнопки панели редактирования:

Кнопка | Действие
 | Позволяет создать якорь (закладку) в нужном месте страницы, для создания ссылки именно на это место страницы
 | Позволяет создать ссылку
 | Удаляет ссылку

Рассмотрим предназначение этих кнопок подробнее.

Создание ссылки

Для создания ссылки нажмите на кнопку [image] Ссылка, после чего откроется диалоговое окно создания ссылки на страницу или документ на сервере. В системе возможно создание четырех типов гиперссылок.

Ссылка на документ на сервере

  • В выпадающем списке Тип выберите Ссылка на документ на сервере.

    Ссылка на документ на сервере

  • Укажите или загрузите документ, на который будет ссылаться создаваемая ссылка. Для этого нажмите кнопку [image], чтобы выбрать документ из Структуры сайта или выберите пункт меню кнопки Выбрать из медиабиблиотеки.

    Действия по выбору/загрузке документа аналогичны действиям, подробно описанным в уроке Загрузка и размещение изображения

  • В выпадающем списке Открыть ссылку в укажите окно, в котором будет открываться ссылка.

    Окно, в котором будет открываться ссылка

    Задание окна для открытия ссылки при редактировании в режиме кода

    В коде каждый из пунктов этого списка задается с помощью атрибута target тега <a>. Атрибут target может принимать соответственно следующие значения:

    • _blank;
    • _parent;
    • _self;
    • _top.
  • Отметьте опцию Не учитывать ссылку поисковиками (nofollow, noindex), если хотите, чтобы ссылка не учитывалась поисковыми системами при индексировании страницы.
  • Заполните, по желанию, поле Всплывающая подсказка, текст которого будет появляться при наведении курсора мыши на ссылку. В коде она вводится с помощью атрибута title тега <a>.
  • Укажите один из описанных в продукте Стиль для написания слова или фразы, являющихся ссылками
  • Задайте, по желанию, атрибуты ID и Rel

Ссылка на другой сайт

  • В выпадающем списке Тип выберите Ссылка на другой сайт, после чего диалоговое окно изменит вид.

    Ссылка на документ на сервере

  • Укажите Текст ссылки и Адрес ссылки
  • Выберите опцию Фиксировать переход в статистике и заполните открывшиеся поля для того, чтобы события перехода по ссылке регистрировались в статистике.
  • Задайте остальные параметры аналогично Ссылке на документ на сервере
Задание ссылки на сайт в режиме кода

В режиме кода ссылку на другой сайт можно задать в виде:

<a href="http://_адрес_сайта_" target="_blank">адрес сайта</a>

Ссылка внутри данного документа

Для создания ссылки внутри документа сначала необходимо создать на странице закладку (или якорь).

  • Для этого установите курсор указателя мыши в необходимое место и нажмите на кнопку [image] Якорь панели инструментов. Появится диалог создания якоря.

  • Введите название якоря (закладки). Пусть это будет page_setting.

    Примечание: для задания якорей лучше использовать латинский шрифт.

  • Нажмите кнопку Сохранить, после чего на странице появится изображение якоря.

    Задание якоря в режиме кода

    В коде якорь задается с помощью атрибута name тега <a>:

    <a name="history"></a>

Ниже вы можете познакомиться с видео-роликом, наглядно демонстрирующим процесс создания и изменения гиперссылок. (2 минуты 48 секунд, 9.75 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.

Теперь создайте ссылку на этот якорь

    Для этого:
  • Выделите слово, которое будет служить ссылкой (например: "Сайт") и нажмите кнопку [image] Ссылка. Появится диалог создания ссылки как в случае Ссылка на документ на сервере.
  • В поле Тип выберите из списка вариант Ссылка внутри данного документа. Диалог примет вид:

    Форма создания ссылки внутри данного документа

  • В поле Закладка в выпадающем списке будут доступны все закладки (якоря), созданные на данной странице. Выберите необходимую закладку и укажите Текст ссылки
  • Заполните, по желанию, все остальные поля формы.
  • После того, как указаны все параметры, нажмите кнопку Сохранить.

Теперь в публичной части при нажатии на ссылку будет осуществлен переход к закладке на данной странице.

Электронный адрес

Среди возможных типов ссылок есть пункт Электронный адрес (EMail). Выбрав этот тип, с помощью формы можно создать ссылку отправки электронного сообщения. При клике по этой ссылке будет запущена та почтовая программа, которая установлена в настройках браузера по умолчанию.

Для создания такой ссылки выполните следующее:

  • Напишите текст ссылки, выделите его и нажмите кнопку [image] Ссылка на панели редактирования. Появится диалог создания ссылки как в случае Ссылка на документ на сервере.
  • В поле Тип выберите из списка вариант Электронный адрес (EMail). Диалог примет вид:

    Форма создания ссылки на "Электронный адрес (EMail)"

  • Заполните поля формы и нажмите кнопку Сохранить

После сохранения ссылки и выхода из редактора по этой ссылке будет запущена почтовая программа с заполненным полем адресата.

Задание ссылки на отправку электронного сообщения в режиме кода

В коде такая ссылка создается так:

<a href="mailto:info@1c-bitrix.ru" title="написать письмо">Текст ссылки</a>

Примечание: после создания гиперссылки редактировать ее параметры можно в панели Свойства и в контекстном меню, если установить указатель мыши на ссылку.

Удалить ссылку можно, поставив курсор мыши на эту ссылку и нажав кнопку [image] Удалить ссылку панели редактирования, а также через контекстное меню.

Ниже вы можете познакомиться с видео-роликом, наглядно демонстрирующим процесс создания и изменения гиперссылок. (2 минуты 2 секунды, 12.56 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.


Работа с графикой
26 / 45

В этой главе рассматривается принцип работы с графическими данными, которые могут располагаться в рабочей области страницы. Подробно описываются формы добавления изображений и роликов, окно менеджера файлов.


Загрузка и размещение изображения
27 / 45

HTML-редактор позволяет загружать графику с локального диска и размещать ее на веб-странице. Процесс размещения изображения очень прост:

  • Выберите место для изображения на странице, установите курсор в эту позицию и нажмите кнопку [image] Изображение на панели редактора. Появится диалог:

    • Выбор изображения из медиабиблиотеки

  • Перейдите к форме загрузки изображения из медиабиблиотеки, нажав кнопку [image]. Появится окно Медиабиблиотека:

  • Укажите изображение и нажмите кнопку Выбрать. После чего закроется окно выбора файла из медиабиблиотеки, и путь к выбранному файлу будет указан в поле Путь к изображению формы загрузки изображения. Изображение появится в окне предпросмотра, а также будет указана его ширина и высота, которые задаются в коде с помощью атрибутов width и height тега <img> соответственно:

    Форма загрузки изображения

    • Выбор изображения из структуры сайта

  • Перейдите к форме загрузки изображения из структуры сайта, выбрав пункт меню Выбрать из структуры сайта кнопки [image]. Появится окно Менеджера файлов:

    Нажмите на рисунок, чтобы увеличить

    Окно Менеджера файлов разделено в нижней части на две закладки: Открыть файл и Загрузить файл.

    • На закладке Открыть файл вы можете открыть один из файлов, находящихся на сервере. На закладке Загрузить файл можно загрузить файл с локального компьютера.

  • Для загрузки файла с локального компьютера перейдите на закладку Загрузить файл.

    Нажмите на рисунок, чтобы увеличить

  • В одноименном поле укажите путь к файлу на локальном компьютере. Для выбора файла воспользуйтесь кнопкой Обзор. Поле Имя файла на сервере заполнится автоматически. Если опция Открыть файл после загрузки не отмечена, то файл будет загружен в указанную папку.
    При отмеченной опции указанный файл будет загружен в выбранную папку, одновременно с этим закроется окно менеджера файлов, и путь к выбранному файлу будет указан в поле Путь к изображению формы загрузки изображения. Изображение появится в окне предпросмотра, а также будет указана его ширина и высота, которые задаются в коде с помощью атрибутов width и height тега <img> соответственно.

    • Ниже вы можете познакомиться с видео-роликом, наглядно показывающим процесс размещения изображения на веб-странице. (2 минуты 2 секунды, 6.08 Мб.)

    Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

    Загрузить ролик.

    Далее в форме Новый рисунок заполните следующие поля:

    • Название (title) – служит для ввода всплывающей подсказки к рисунку. Подсказка будет выведена при наведении курсора независимо от того, показан сам рисунок или нет.

    • Альтернативный текст – позволяет получить текстовую информацию об изображении при отключенной в браузере загрузке изображений. Поскольку загрузка изображений происходит после получения браузером информации о нем, то альтернативный текст появляется раньше самого рисунка. Некоторые браузеры также отображают альтернативный текст в виде подсказки, появляющейся при наведении курсора мыши на изображение.

      Альтернативный текст в режиме кода
      В HTML-тегах альтернативный текст задается с помощью атрибута alt тега <img>, т.е. HTML-код вставки изображения с альтернативным текстом "Обсуждение" будет таким:
      <img src="/images/Picture1.jpg" height="222" alt="Обсуждение" width="200"/>

    • Горизонтальный отступ и Вертикальный отступ. Если задать эти параметры отличными от нуля, то изменение положения изображения сразу отображается в окне предпросмотра.

      Задание отступов в режиме кода

      В коде эти параметры задаются с помощью атрибутов hspace и vspace тега <img>. HTML-код вставки изображения c горизонтальным отступом 30 пикселей и вертикальным отступом 5 пикселей имеет вид:

      <img src="/images/Picture4.jpg" title="Светофор" hspace="30" vspace="5" border="0" align="left" alt="Светофор" width="96" height="152"/>

    • Вокруг изображения можно добавить рамку, цвет которой совпадает с цветом текста на веб-странице, ее толщину в пикселях задают в поле Толщина рамки.

      Рамка в режиме кода
      В HTML коде этот параметр задается с помощью атрибута border тега <img>.
    • Параметр выравнивание дает возможность указывать положение изображения относительно текста или других изображений на веб-странице. В форме вставки изображения в визуальном редакторе этот параметр может принимать следующие значения:

      Выравнивание в режиме кода

      В коде этот параметр задается с помощью атрибута align тега <img>.

      Представим в виде таблицы подробное описание значений этого атрибута:

      Значение | Описание
      bottom | Нижняя граница изображения выравнивается по базовой линии текстовой строки. Это значение установлено по умолчанию.
      left | Изображение располагается по левому краю родительского элемента.
      middle | Середина изображения выравнивается по базовой линии текущей строки текста.
      right | Изображение выравнивается по правому краю родительского элемента.
      top | Верхняя граница изображения выравнивается по самому высокому элементу текущей строки.

      Ниже вы можете познакомиться с видео-роликом, наглядно показывающим процесс размещения изображения на веб-странице. (2 минуты 6 секунд, 7.75 Мб.)

      Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

      Загрузить ролик.

Если вы выбираете среди изображений уже загруженных в систему, то, кликнув мышью по названию изображения в окне менеджера файлов, "миниатюра" этого изображения с размерами появится в левом нижнем углу окна менеджера файлов. Одновременно с этим будет заполнено поле Имя файла:

Нажмите на рисунок, чтобы увеличить

В данном случае содержимое менеджера файлов представлено в виде списка.
Далее после нажатия кнопки Открыть путь к выбранному изображению будет записан в поле Путь к изображению формы загрузки изображения, а окно менеджера файлов закроется.

Отметим, что менеджер файлов запоминает последнюю открывавшуюся директорию. В каждый последующий раз он открывает то место иерархии, в котором была закончена работа в предыдущий раз.

В менеджере файлов есть возможность установить один из трех режимов просмотра файлов:

Выбор режима просмотра файлов

Также в менеджере файлов есть возможность выбрать параметр сортировки элементов: по имени, типу, по размеру файлов или папок, по дате создания.

Выбор режима сортировки файлов

Изменить порядок сортировки можно с помощью кнопки [image].

При Детальном режиме просмотра для каждого элемента папки (директории) указывается название, размер, дата изменения, тип:

Нажмите на рисунок, чтобы увеличить

При просмотре в режиме Предпросмотра для каждого элемента создается уменьшенная миниатюра. В этом режиме удобно просматривать изображения:

Нажмите на рисунок, чтобы увеличить

Примечание Если сайт подключен к облачному хранилищу, то при загрузке файлов станет доступным выпадающее окно с выбором хранилища, откуда нужно загрузить файл.

Ниже вы можете познакомиться с видео-роликом, наглядно показывающим процесс размещения изображения на веб-странице. (2 минуты 38 секунд, 6.7 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.


Загрузка и размещение flash ролика
28 / 45

Кроме загрузки и размещения изображений, HTML-редактор позволяет разместить на странице flash-ролики. Процесс загрузки и размещения ролика аналогичен процессу загрузки/размещения изображения:

  • Для размещения ролика служит кнопка [image] Вставить Flash, при нажатии на которую открывается форма:

    Форма загрузки ролика

    На закладке Основные параметры указывается путь к выбранному файлу, а внешний вид ролика представлен в окне предпросмотра. Кроме того, при помощи полей Ширина и Высота, вы можете указать ширину и высоту окна данного ролика.

  • Перейдите к форме загрузки ролика, нажав на кнопку [image]. Появляется окно менеджера файлов:

    Нажмите на рисунок, чтобы увеличить

  • С помощью данного окна выберите файл, находящийся на сервере, либо загрузите с локального компьютера, после чего информация о выбранном ролике будет отображена в форме Вставка Flash:

  • На закладке Дополнительные параметры задайте ряд дополнительных свойств ролика. Например: название ролика, качество показа, вид окна.

  • На закладке HTML код можно самостоятельно ввести код вызова ролика.

Ниже вы можете познакомиться с видеоматериалом, наглядно показывающим процесс размещения ролика на веб-странице. (1 минута 36 секунд, 5.32 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.


Панель задач
29 / 45

При редактировании страниц сайта панель задач по умолчанию состоит из двух закладок: Компоненты и Сниппеты.

При редактировании элементов информационных блоков, уроков обучающих курсов и т.д. панель задач содержит только Сниппеты.


Компоненты
30 / 45
Компонент - программный код, оформленный в специальную оболочку, позволяющую визуальными средствами системы вставлять и настраивать код в шаблон сайта или на его страницы.

Компоненты являются блоками, с помощью которых строится публичная часть сайта. Они позволяют многократно использовать единожды написанный и отлаженный код в рамках одного сайта или на разных сайтах. С помощью визуальных средств среды «1C-Битрикс: Управление сайтом» можно размещать и настраивать компоненты без написания кода. Поставляемые с продуктом системные компоненты регулярно обновляются, при этом расширяется их функционал и исправляются возможные ошибки.

Для работы с компонентами служит панель Компоненты.

Примечание: панель компонентов и работа с ними подробно рассмотрена в главе Работа с компонентами главы Компоненты 2.0 (начальные сведения).


Сниппеты
31 / 45
Сниппеты - инструмент визуального редактора, позволяющий вставлять в документ заранее подготовленный и часто используемый фрагмент текста, верстки или кода.

Сниппеты очень удобны для тех, кто ежедневно работает с содержанием сайта в визуальном редакторе. Используя этот механизм, можно создать ряд подготовленных таблиц, сверстанных форм, которые можно перетаскивать из панели сниппетов и далее редактировать только текст или таблицу.

Сниппеты редактируются, добавляются и удаляются прямо в визуальном редакторе. К ним можно делать рисунки. Доступно объединение их в многоуровневой структуре, чтобы пользователям было удобно ориентироваться в большом количестве заготовок.

Физически сниппеты хранятся в папке /snippets/ соответствующего шаблона либо в шаблоне по умолчанию (.default).

Для работы со сниппетами служит панель Сниппеты.

Создание нового сниппета

  • Для создания нового сниппета используйте ссылку Добавить сниппет, расположенная на панели задач Сниппеты

    Ссылка "Добавить сниппет"

    Откроется форма Добавление сниппета.

  • На закладке Основные параметры укажите Название, которое будет отображаться в визуальном редакторе, и сам Код сниппета.

    Закладка "Основные параметры"

  • На закладке Размещение заполните поля формы.
    • Шаблон – выбирается шаблон сайта, в котором создается сниппет. Это может быть шаблон по умолчанию либо текущий шаблон;
    • Имя файла – указывается имя файла, в котором хранится код сниппета. Можно указать собственное или оставить то имя, которое предложила система. Код сниппета будет сохранен в этом файле (*.snp)
    • Размещение – из списка выбирается папка (группа) любого уровня, в которой будет храниться сниппет.
    • Установите опцию Создать новую подгруппу и введите Имя новой подгруппы для того, чтобы сохранить сниппет в отдельной подгруппе.

      • Опция "Создать новую подгруппу"

      Внимание! Название в поле Имя новой подгруппы необходимо указывать только латинскими буквами.
  • На закладке Дополнительные параметры укажите, по желанию, Рисунок и Описание. Может быть добавлено только одно изображение.

После сохранения новый сниппет будет сразу отображен в дереве визуального редактора в общем списке или в указанной в настройках подгруппе:

Ниже вы можете познакомиться с видео-роликом, наглядно демонстрирующим способы применения сниппетов. (2 минуты 35 секунд, 7.28 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.

Редактирование сниппета

Выберете из списка сниппет, который необходимо отредактировать, и кликнете по нему мышью. После чего в панели Свойства будут отражены:

  • название сниппета вместе с именем файла его кода;
  • кнопки управления: Редактировать сниппет [image] и Удалить сниппет [image];
  • код сниппета.

Примечание: eсли для сниппета заданы описание и рисунок, то они также будут отражены в панели Свойства:

Дополнительные параметры сниппета

Для перехода к редактированию служит кнопка [image]. Форма Редактирование сниппета, по сути, является формой добавления сниппета, за исключением того, что отредактировать размещение сниппета невозможно.

Для удаления нужно выбрать в списке необходимый сниппет, кликнуть по нему и воспользоваться кнопкой [image], которая отображается в панели Свойства. Вся информация о сниппете будет удалена.

Примечание: если из подгруппы был удален последний сниппет, то она не удаляется и в визуальном редакторе не отображается. Однако подгруппа будет входить в список размещений формы Добавление сниппета.

Ниже вы можете познакомиться с видео-роликом, наглядно демонстрирующим способы применения сниппетов. (2 минуты 37 секунд, 12.93 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.


Разбиение страниц
32 / 45
Дополнительные кнопки панели Стандартные [image] отображаются при использовании визуального редактора только из Административного раздела для изменения страниц, элементов инфоблоков и т.д. Кнопки предназначены для добавления разделителей на страницы.

  • Разрыв страницы для печати [image] - позволяет осуществить разбиение одной страницы при печати на несколько страниц, в зависимости от количества установленных разделителей.

    Для размещения этого разрыва выберите место на странице, установите курсор и нажмите на кнопку [image], после чего в рабочей области редактора появится следующее изображение:

    При просмотре страницы в публичной части сайта линия разрыва отображаться не будет, но при переходе к печати страница будет разделена в указанном месте.

  • Разделитель страниц [image] - позволяет осуществить разбиение текста при просмотре в публичной части сайта. Число страниц зависит от количества установленных разделителей.

    При добавлении разделителя на страницу в рабочей области редактора появляется изображение:

    При просмотре в публичной части текст будет разделен на несколько страниц в указанных разделителем местах.

    Внимание! Использование разделителя страниц возможно только при работе с описанием элементов информационных блоков.

Ниже вы можете познакомиться с видео-роликом, наглядно показывающим способы разбиения страниц. ( 1 минута 35 секунд, 5.22 Мб.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузить ролик.


Упрощенный редактор
33 / 45
Упрощенный HTML-редактор - это элемент управления, представляющий облегченную версию визуального редактора с упрощенными возможностями и ускоренным быстродействием. Редактор можно встраивать в любую форму, в том числе в публичном разделе. Реализован как компонент Упрощенный HTML-редактор (bitrix:fileman.light_editor).

Внешний вид

Редактор состоит из поля для ввода текста и панели инструментов. Панель инструментов редактора может произвольно перемещаться.

Панель инструментов упрощенного редактора содержит следующие элементы управления:

Кнопка | Описание
 | Жирный.
 | Курсив.
 | Подчёркнутый.
 | Удалить форматирование.
 | Ссылка.
 | Удалить ссылку.
 | Изображение.
 | Вставить видео.
 | Цвет фона.
 | Цвет шрифта.
 | По левому краю.
 | По центру.
 | По правому краю.
 | По ширине.
 | Нумерованный список.
 | Список с маркерами.
 | Уменьшить отступ.
 | Увеличить отступ.
 | Формат.
 | Шрифт.
 | Размер шрифта.


Форматирование текста
34 / 45

Упрощенный HTML-редактор позволяет производить несложное форматирование текста. Он автоматически подключается в формах, не требующих возможностей полного редактора, например, комментарии к сообщениям блога. С помощью инструментов редактора можно:

  • задать начертание текста с помощью кнопок Жирный, Курсив и Подчеркнутый:

  • Удалить форматирование ( [image]);
  • вставить Ссылку ( [image]) и Удалить ссылку ( [image]):

  • выбрать Цвет шрифта ( [image]) и Цвет фона ( [image]) с помощью палитры цветов:

  • задать выравнивание текста с помощью кнопок По левому краю, По центру, По правому краю или По ширине:

  • создать Нумерованный список ( [image]) или Список с маркерами ( [image]);
  • задать отступ текста с помощью кнопок Уменьшить отступ ( [image]) и Увеличить отступ ( [image]);
  • применить Формат текста:

  • выбрать Шрифт:

  • указать Размер шрифта:

    • © «Битрикс», 2001-2008, «1C-Битрикс», 2008-2014 1С-Битрикс


Загрузка изображений
35 / 45

Упрощенный HTML-редактор позволяет загружать графику и размещать ее на странице. Процесс размещения изображения очень прост:

  • Выберите место для изображения на странице, установив туда курсор, и нажмите кнопку Параметры изображения на панели инструментов. Откроется диалог Параметры изображения:

  • Укажите расположение картинки в поле Путь к изображению. (Вручную или с помощью кнопки [image]. С помощью этой кнопки можно выбрать изображения только из Медиабиблиотеки.)
  • В поле Всплывающая подсказка укажите текст, который будет отображен при наведении курсора мыши на изображение.
  • Задайте Выравнивание изображения.
  • Если отмечена опция Сохранять пропорции, то значения полей Размеры (Ш х В) будут заполнены автоматически. Также можно указать другие размеры.
  • Нажмите кнопку Сохранить.

В результате добавленное изображение будет отображено в упрощенном редакторе:


Загрузка медиафайлов
36 / 45

Упрощенный HTML-редактор позволяет загружать видео и размещать его на странице. Процесс размещения видео довольно прост:

  • Выберите место для видео на странице, установив туда курсор, и нажмите кнопку [image] на панели инструментов. Откроется диалог Параметры видео:

  • В поле Путь к видеофайлу укажите расположение файла. (Вручную или с помощью кнопки [image]. С помощью этой кнопки можно выбрать изображения только из Медиабиблиотеки.)
  • Укажите Путь к рисунку предпросмотра.
  • Задайте размер окна плеера, заполнив поля Размеры (Ш х В).
  • Нажмите кнопку Сохранить.

В результате добавленное видео будет отображено в упрощенном редакторе.


Работа с компонентами
37 / 45

В данной главе курса рассказывается о работе с компонентами: их размещении, настройке, управлении параметрами в разных интерфейсах.

Примечание: Права на работу с определенными компонентами могут быть ограничены администратором сайта. В этом случае контент-менеджер просто не увидит иконок компонентов в визуальном редакторе.


Панель компонентов в визуальном редакторе
38 / 45

Для быстрого размещения компонентов на странице разработан интерфейс на базе визуального HTML-редактора.

Все визуальные компоненты расположены на специальной панели компонентов. Отображение этой панели зависит от настроек визуального редактора (переход к настройкам осуществляется при помощи кнопки [image]).

Чтобы панель компонентов отображалась в редакторе, она должна быть отмечена флагом на закладке Панели задач формы Настройки визуального редактора:

Внимание! Закладка Компоненты отображается только при редактировании статических страниц. При редактировании полей элементов информационных блоков закладка недоступна, так как использование компонентов в информационных блоках не допускается.

Закладка Компоненты в визуальном редакторе вызывается с помощью кнопки [image]. Все компоненты сгруппированы по разделам (Контент, Сервис, Общение, Магазин, Служебные), которые в свою очередь состоят из подразделов.

Доступны следующие действия управления закладкой Компоненты на панели задач:

  • По кнопке [image] Свернуть можно временно скрыть панель. Вернуть ее можно, используя кнопку [image].
  • Кнопка Обновить закешированные данные позволяет сбросить кеш, например, если были добавлены собственные компоненты.
  • Кнопка Настроить вызывает форму настройки внешнего вида редактора, которая также доступна по кнопке [image] Настройки панели инструментов визуального редактора.
  • Кнопка Закрыть закрывает отображаемую панель. Восстановить ее отображение можно с помощью формы настройки редактора (кнопка [image]).

Компоненты 1.0 до v.9.5
В версии продукта до 9.5 присутствует закладка Компоненты 1.0. Она позволяет добавлять на страницу компоненты 1.0, которые устарели и не рекомендуются к использованию.


Размещение и настройка компонентов в визуальном редакторе
39 / 45

Простые компоненты в визуальном редакторе представлены желтыми иконками, например, компонент [image] Альбом.
Комплексные компоненты представлены фиолетовыми иконками, например, комплексный компонент [image] Фотогалерея 2.0.

Размещение компонента

При создании/редактировании страницы с помощью визуального HTML-редактора можно выбрать подходящий компонент из списка и переместить его в рабочую область страницы:

Настройки компонента

Вызвать Настройки выбранного компонента, можно двумя способами:

  • Установить курсор на значок компонента размещенного в рабочей области страницы, тогда в панели Свойства будет выведен список настроек данного компонента:

  • Использовать диалог Параметры компонента, который можно вызвать, дважды кликнув на иконке компонента в рабочей области страницы:

1. Для удобства настройки компонента его параметры разделены по группам. Например, Шаблон компонента, Основные параметры и т.д . Количество групп параметров и их содержимое зависит от конкретного компонента. Используя кнопки [image] и [image] рядом с названием группы параметров, вы можете скрывать и вновь отображать группы параметров.

2. При настройке параметров компонента выполняется работа с полями различных типов:

  • выбор элемента из выпадающего списка;

    Для некоторых полей типа Выпадающий список возможен выбор значения (другое)–>. В этом случае необходимо ввести код в поле, расположенное рядом.

  • выбор нескольких элементов из множественного списка (удерживая нажатой клавишу Ctrl);
  • снятие или отметка некоторой опции (поле типа CheckBox);
  • ввод информации в текстовую строку.

3. Рядом с полями расположены значки [image], при наведении курсора мыши на которые отображаются подсказки по заполнению полей.

Настройка вывода свойств элементов инфоблока осуществляется в поле Свойства. Это поле в комплексных компонентах встречаться несколько раз, например, в Настройках списка и в Настройках детального просмотра:

Кроме того, параметры компонента могут быть настроены непосредственно в режиме редактирования исходного кода страницы: кнопка [image] на панели инструментов визуального HTML-редактора.

Внимание! Этот способ не рекомендуется к использованию контент-менеджерами, это способ для разработчиков сайтов.

Полезная информация:
  • Если на странице расположены несколько компонентов, каждый из которых может устанавливать заголовок страницы, то заголовок страницы будет установлен последним компонентом.
  • Если на странице расположено несколько визуальных компонентов, добавляющих свои кнопки в Административную панель, то для того, чтобы избежать перегруженности Административной панели кнопками, в настройках этих компонентов для свойства Добавлять в админ. панель кнопки для данного компонента флаг должен быть снят.
  • Подробную информацию о параметрах конкретных компонентов можно найти в Документации пользователя.


Управление компонентами
40 / 45

В главе описаны управление компонентами, меню команд.


Старый интерфейс (до версии 9.5)
41 / 45

Для любого компонента при переходе в режим разработки и настройки сайта (закладка Разработка) отображается специальная кнопка для его управления:

Примечание: Для комплексного компонента отображается несколько кнопок. Это связано с принципом построения комплексного компонента. Самая верхняя кнопка служит для управления комплексным компонентом целиком. Для управления отдельным его подкомпонентом отображаются дополнительные кнопки.

Нажатие на кнопку управления компонента вызывает меню, содержащее основные команды:

Рассмотрим команды компонента, служащие для его управления:

– редактирование параметров данного компонента. Команда отображается всегда для любого компонента, за исключением подкомпонентов в составе комплексного. По нажатии отображается форма настройки параметров, где можно изменить настройки компонента без перехода к режиму редактирования страницы.

– копирование шаблона компонента. Команда отображается всегда. По нажатии появляется диалоговое окно, где указывается имя шаблона компонента, и в какой шаблон сайта осуществить копирование.

– редактирование текущей страницы шаблона. Команда отображается, если применен пользовательский шаблон. По нажатии происходит переход к редактированию шаблона.

– редактирование CSS-файла шаблона. Команда отображается, если применен пользовательский шаблон.

– очистка кеша компонента.

Набор команд по управлению компонентом зависит от его типа. Например, кроме управления компонентом меню, можно провести настройку пунктов меню:

– редактировать пункты меню.

– создать меню в текущем разделе.

Если компонент выводит информацию из некоторого инфоблока, то дополнительно в меню такого компонента могут отображаться следующие команды:

– добавить элемент, например, новость, статью, ссылку, товар и т.д.

– добавить раздел.

Практически на всех сайтах размещена реклама и используются веб-формы. Поэтому для удобства управления этими составляющими сайтов для компонентов добавлены следующие команды:

  • для рекламных баннеров:

    – редактировать данный баннер.

    – отфильтрованный список баннеров.

  • для веб-форм:

    – редактировать шаблон веб-формы.

    – редактировать параметры веб-формы.


Управление параметрами компонента
42 / 45

В главе описаны управление параметрами размещенных на страницах сайта компонентов.


Старый интерфейс (до версии 9.5)
43 / 45

Управление параметрами размещенных на страницах сайта компонентов возможно из публичного раздела в режиме Разработка с помощью специальной формы. Переход к форме можно выполнить одним из двух способов:

  1. Нажать на кнопку управления необходимого компонента [image] и выбрать команду [image] Редактировать параметры компонента.
  2. На административной панели нажать кнопку Компоненты и в выпадающем списке выбрать имя необходимого компонента.

    Примечание: Выпадающий список компонентов строится в соответствии с размещенными на текущей странице компонентами.

В результате откроется форма следующего вида:

Форма редактирования параметров компонента аналогична отображаемой для данного компонента панели Свойства из визуального редактора. Для сохранения внесенных изменений служит кнопка Сохранить, для отмены произведенных настроек - Отменить.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».


Примеры работы с компонентами
44 / 45

Комплексные компоненты

Новостной раздел можно создать с помощью комплексного компонента [image] Новости (bitrix:news). Этот компонент нужно просто установить на страницу (например, index.php) и настроить набор его параметров. При этом настроить обязательно необходимо только поля группы Основные параметры, где указывается Тип инфоблока и сам используемый инфоблок. Все остальные параметры компонента можно оставить как есть.

Настроив параметры компонента должным образом, в публичной части имеем тот же результат:

Страница со списком новостей | Страница детального просмотра новости

Таким образом, для создания новостного раздела физически создается одна страница, а логически несколько.

Простые компоненты

Рассмотрим создание новостного раздела с помощью простых компонентов. Особенностью создания такого раздела будет то, что придётся создавать несколько физических страниц и производить дополнительную настройку простых компонентов. При использовании комплексного компонента этих действий можно избежать.

Для этого необходимо создать, например, страницу списка новостей index.php, на которой разместим компонент [image] Список новостей (bitrix:news.list). Этот компонент выводит на странице, где он размещен, заголовок, текст анонса и прочие параметры новостей в зависимости от настроек компонента. Каждый элемент списка новостей - ссылка на просмотр детальной информации.

Страница с детальной информацией должна быть создана отдельно, например, detail.php, на которой надо разместить компонент [image] Новость детально (bitrix:news.detail).

При этом у компонента Список новостей нужно настроить входные параметры так, чтобы он мог формировать ссылки на страницу детальной новости (с кодом новости). Для этого нужно в группе параметров Шаблоны ссылок в поле URL страницы детального просмотра задать путь к этой странице, а также название параметра, в котором будет передаваться код новости для показа:

detail.php?ID=#ELEMENT_ID#

В данном случае страница detail.php должна находиться в том же разделе, что и страница со списком новостей.

Для компонента детальной новости нужно настроить входные параметры так, чтобы он мог формировать ссылку на главную страницу:

index.php?ID=#IBLOCK_ID#

Примечание: Обратите внимание, что все адреса страниц указываются без слеша в начале адреса.

Кроме того, во входных параметрах компонента детальной новости (поле ID новости группы параметров Основные параметры) нужно задать php-код, возвращающий ID новости:

={$_REQUEST["ELEMENT_ID"]}

Настроив параметры компонентов должным образом, в публичной части имеем результат:

Страница со списком новостей | Страница детального просмотра новости


Создание новых страниц и разделов
45 / 45

В рамках файловой структуры сайта страница - это файл, а раздел - это папка. Соответственно, создавая страницу вы создаете файл, создавая раздел - папку.

Примечание: В данном случае речь идет о статических страницах сайта. Динамические страницы, создаваемые комплексными компонентами работают по другому принципу и не создают файлов и разделов.

Создавать раздел или страницу можно как с Публичной части, так и с Административного раздела. Контент-менеджеру рекомендуется работать с Публичной части.

Создание страниц

Из публичного раздела сайта создание страницы выполняется с помощью удобного мастера. Его запуск можно осуществить в любом из режимов публичного раздела, выбрав пункт Страницу в меню команд кнопки Создать:

Для навигации по шагам мастера служат кнопки Назад и Далее. Когда все параметры страницы заданы, то для создания служит кнопка Готово, а для прерывания работы мастера - кнопка Отмена. Кроме того, количество шагов мастера может быть разным в зависимости от выбранных вами настроек.

Первый шаг. Создание собственно страницы.
  • В открывшемся окне мастера укажите Имя файла и задайте произвольный Заголовок страницы.
  • Если сразу после создания страницы необходимо перейти к ее редактированию, то отметьте опцию перейти к редактированию. В этом случае по окончании работы мастера откроется визуальный редактор, с помощью которого выполняется наполнение страницы содержимым.
  • Для добавления страницы в меню отметьте опцию добавить пункт меню. Создание пункта меню выполняется на следующем шаге.
 Нажмите на рисунок, чтобы увеличить
Второй шаг. Создание пункта меню.
  • Укажите Имя нового пункта меню. По умолчанию в поле подставляется заголовок страницы.
  • Выберите Тип меню, в которое будет добавлен новый пункт.
  • Укажите, перед каким пунктом меню должен быть добавлен новый пункт.
 Нажмите на рисунок, чтобы увеличить
Третий шаг. Задание свойств страницы.
  • Значения свойств страницы наследуются из раздела, в котором она создана. Для изменения свойства кликнете по полю и укажите необходимое вам значение.
  • Если необходимо, то задайте Теги страницы, которые будут использоваться при ее поиске.
 Нажмите на рисунок, чтобы увеличить
Четвертый шаг. Редактирование страницы.
  • Используя средства визуального редактора, наполните страницу содержимым. На странице может быть размещена как статическая, так и динамическая информация.
  • Сохраните внесенные данные с помощью кнопки Сохранить.
 Нажмите на рисунок, чтобы увеличить

Видеоролик "Создание новой страницы"

Скачать ролик (10,5 Мб, длительность 4 мин. 26 сек.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс». Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Кроме того, вы можете ознакомится с видеороликом "Редактирование страницы" (9,9 Мб, длительность 2 мин. 52 сек.), в котором описаны возможные режимы редактирования страницы.

Создание разделов

В общем случае сайт представляет собой совокупность нескольких страниц, как правило, распределенных по тематическим разделам. В рамках системы разделы - это папки, включенные в структуру сайта. Разделы могут содержать подразделы, отдельные страницы и файлы:

Нажмите на рисунок, чтобы увеличить Нажмите на рисунок, чтобы увеличить

Названия разделов используются в цепочке навигации, а также при отображении логической структуры сайта. Создать новый раздел можно как из административной, так и из публичной части сайта.

Для перехода к созданию нового раздела из публичной части сайта вызовите меню команд кнопки Создать, расположенной на административной панели, и выберите пункт Раздел:

Откроется мастер, с помощью которого будет создан новый раздел в текущем (открытом в данный момент) разделе сайта:

В процессе создания нового каталога независимо от того, в каком разделе сайта (публичном или административном) он создается, вы можете:

  • указать название раздела сайта, соответствующего данной папке. Указанное название будет использоваться в качестве пункта цепочки навигации, ссылающегося на созданный раздел:

  • добавить ссылку на создаваемый раздел в меню сайта:

  • создать индексную страницу раздела.

Внимание! При создании раздела автоматически создается страница index.php, которая и отображается на сайте как главная страница раздела. Удаление этой страницы приведет к тому, что раздел станет недоступен для просмотра.


Интерфейс до версии 9.5
0 / 45

Основным учебным материалом для контент-менеджеров сайтов на основе "1С-Битрикс: Управление сайтом" является курс Контент-менеджер. Система "1С-Битрикс: Управление сайтом" постоянно развивается и совершенствуется. Как в своём функционале, так и в интерфейсах, с которыми приходится работать пользователям и контент-менеджерам. Но достаточно большое число сайтов в российском интернете работают на старых версиях нашей системы, с необновлённым интерфейсом.

Если у вас такой сайт, то рекомендуется начинать изучение системы с этого учебного курса. В этом курсе описан только интерфейс "1С-Битрикс: Управление сайтом" до версии 9.5. Все приёмы и методы работы можно изучить в курсе Контент-менеджер, они полностью аналогичны.

Курс Интерфейс до версии 9.5 - не сертифицируемый, то есть без тестов.

Скачать материалы курса в формате CHM. Файлы формата CHM обновляются ежемесячно, тем не менее, возможно некоторое отставание их от онлайновой версии курса.

Если не видно содержание файла CHM
Внимание! Если вы не видите содержимое файла формата .chm, то причина - настройки безопасности операционной системы: скачанные из интернета файлы находятся под наблюдением системы, которая ограничивает доступ к ним.

Чтобы отключить подобное отношение к файлу необходимо:

  • перейти в свойства файла на вкладку Общие. Внизу у Вас отобразится сообщение о том, что этот файл был заблокирован системой с целью защиты компьютера.

  • нажать кнопку Разблокировать.

Отсутствие кнопки Разблокировать возможно в двух случаях:

  1. Файл лежит не локально, а на сетевом ресурсе.
  2. Если файл лежит на локальном диске, но путь к нему содержит спецсимволы (# и прочие).