Основные сведения

1С-Битрикс: Управление сайтом ASP.NET
Основные сведения
Send Feedback

Этот раздел содержит основные сведения по архитектуре продукта.

Послать комментарий по теме: Справочная служба

(c) «1C-Битрикс», 2010


Агенты

Агенты
Send Feedback

Агенты - это задания (сервисные функции, написанные на .NET), которые должны быть исполнены в определенный момент времени с заданной периодичностью. Для управления этими заданиями (агентами) существует служба Планировщика.

В этом разделе

Раздел "Агенты" содержит следующие статьи:

Понятие агента

Периодичность агентов

Исполнители агентов

Служба планировщика


Понятие агента

Понятие агента
Смотри также Send Feedback

Тема содержит следующие разделы.

  • Работа службы планировщика
  • Объявление агентов
  • Примеры
  • Похожие темы

Агенты - это задания (сервисные функции, написанные на .NET), которые должны быть исполнены в определенный момент времени с заданной периодичностью. Для управления этими заданиями (агентами) существует служба Планировщика.

Работа службы планировщика

Служба Планировщика запускается при старте приложения и работает в фоновом режиме. Большую часть времени служба находится в спящем режиме, активируясь в нужные моменты времени чтобы запустить того или иного агента.

Временная точность запуска агентов зависит от равномерности и плотности посещаемости сайта и настроек web-сервера, связанных с перезапуском и остановкой приложения. Если равномерность и плотность посещаемости сайта достаточно высока для того, чтобы не происходило остановки приложения, то агенты будут запущены точно в заданное время.

Объявление агентов

Агенты являются сущностями типа BXSchedulerAgent. Поэтому для создания, редактирования и удаления агентов используются методы, характерные для всех сущностей.

Каждый агент должен иметь исполнителя. Исполнитель - это класс, реализующий интерфейс IBXAgentExecutor и имеющий конструктор по умолчанию. В методе Execute(BXSchedulerAgent, BXParamsBag<(Of <<'(Object>)>>)) этого класса задается собственно код, который должен быть выполнен при запуске агента.

Примеры

Проверка агента на существование и создание, в случае его отсутствия:

CopyC#
if (BXSchedulerAgent.GetByName("sample_agent") == null)
{
    BXSchedulerAgent a = new BXSchedulerAgent("sample_agent");
    a.Active = true;
    a.Periodic = false;
    a.Period = TimeSpan.FromDays(1);
    a.Parameters["Count"] = 5000;
    a.StartTime = DateTime.Now;
    a.SetClassNameAndAssembly(typeof(SampleAgentExecutor));
    a.Save();
}

Пример объявления класса исполнителя:

CopyC#
public class SampleAgentExecutor : IBXAgentExecutor
{
    public bool Execute(BXSchedulerAgent agent, BXParamsBag<object> parameters)
     {
        ...
        //Делаем полезную работу
        ...

        //Результат работы агента может зависеть от параметров
        if (parameters.Get("RunOnce", true))
        {
            //Если агент исполняется единожды, то удаляем его из системы
            agent.Delete();
            return false;
        }
        return true;
    }
}

Смотри также

Ссылка

BXScheduler
BXSchedulerAgent
IBXAgentExecutor

Дополнительная информация

Понятие сущности


Периодичность агентов
Смотри также Send Feedback

Тема содержит следующие разделы.

  • Периодичность агентов
  • Похожие темы

Агенты могут выполняться единожды или с заданной периодичностью.

Периодичность агентов

По умолчанию агент будет выполняться с определенным периодом. Для того чтобы выполнить агента только один раз, необходимо удалить его из системы в коде исполнителя и вернуть значение false.

Т.к. невозможно выполнить агента в назначенное время с абсолютной точностью, необходимо особо обрабатывать ситуации, когда момент запуска был просрочен. Такие ситуации могут быть обработаны 2-мя штатными способами. Какой из способов будет применен определяется свойством Periodic класса BXSchedulerAgent.

Если Periodic выставлено в true, то время следующего запуска агента будет рассчитано исходя из запланированного времени старта. В таком случае агент будет "наверстывать" пропущенные запуски, что актуально для таких задач, как сбор статистики, регулярные расчеты, рассылка почты и т. д., т.е. задачи, для которых имеет значение количество запусков.

Если Periodic выставлено в false, то время следующего запуска агента будет рассчитано исходя из фактического времени старта. В таком случае "наверстывания" пропущенных запусков не произойдет. Такие агенты рекомендуется использовать для задач, для которых не имеет значение количество запусков, например, очистка кеша.

Временной промежуток между запусками с точностью до секунд задается свойством Period типа [TimeSpan] класса BXSchedulerAgent.

Смотри также

Ссылка

BXSchedulerAgent


Исполнители агентов

Исполнители агентов
Смотри также Send Feedback

Тема содержит следующие разделы.

  • Объявление исполнителя
  • Привязка исполнителя к агенту
  • Похожие темы

Исполнитель - это класс, реализующий интерфейс IBXAgentExecutor и имеющий конструктор по умолчанию

Объявление исполнителя

В методе Execute(BXSchedulerAgent, BXParamsBag<(Of <<'(Object>)>>)) этого класса задается собственно код, который должен быть выполнен при запуске агента. Например, исполнитель, производящий удаление файлов из некоторой папки выглядит следующим образом:

CopyC#
public class TempCleanExecutor : IBXAgentExecutor
{
    public bool Execute(BXSchedulerAgent agent, BXParamsBag<object> parameters)
    {
        string path = HostingEnvironment.MapPath("~/temp");
        foreach(string file in Directory.GetFiles(path))
            File.Delete(file);
        return true;
    }
}

Метод Execute(BXSchedulerAgent, BXParamsBag<(Of <<'(Object>)>>)) исполнителя получает в качестве аргументов ссылку на запущенного агента и набор параметров, с которыми данный агент был запущен. Поведение исполнителя может варьироваться в зависимости от входных параметров. Например:

CopyC#
public class TempCleanExecutor : IBXAgentExecutor
 {
     public bool Execute(BXSchedulerAgent agent, BXParamsBag<object> parameters)
     {

         if (!parameters.ContainsKey("Path"))
             return true;
         string path = HostingEnvironment.MapPath(parameters.Get<string>("Path"));

         foreach(string file in Directory.GetFiles(path))
             File.Delete(file);
         return true;
     }
 }

Исполнитель может удалить агента, вызвавшего его. В таком случае метод Execute(BXSchedulerAgent, BXParamsBag<(Of <<'(Object>)>>)) должен вернуть false. Например:

CopyC#
public class TempCleanExecutor : IBXAgentExecutor
 {
     public bool Execute(BXSchedulerAgent agent, BXParamsBag<object> parameters)
     {

         if (parameters.ContainsKey("Path"))
         {
             string path = HostingEnvironment.MapPath(parameters.Get<string>("Path"));

             foreach(string file in Directory.GetFiles(path))
                 File.Delete(file);
        }
        agent.Delete();
        return false;
     }
 }

Привязка исполнителя к агенту

Привязка исполнителя к агенту происходит средствами рефлексии. Для этого агенту нужно задать полное имя класса исполнителя и сборку, в которой этот класс объявлен. Имя сборки может быть полным и сокращенным. В случае полного имени сборки могут возникнуть осложнения с выполнением агентов при обновлении системы через SiteUpdate, если параметры сборки (версия, культура, публичный ключ), в которой объявлен исполнитель будут изменены. По этой же причине не рекомендуется объявлять исполнителей в файлах из папки App_Code. Чтобы привязать исполнителя к агенту необходимо воспользоваться свойствами Assembly и ClassName класса BXSchedulerAgent:

CopyC#
BXScheduler agent = new BXSchedulerAgent("sample_agent");
agent.Assembly = "MyAssembly";
agent.ClassName = "MyNamespace.MyExecutor"
agent.Save();

Для сохранения целостности рекомендуется задавать связь с исполнителем средствами рефлексии:

CopyC#
BXScheduler agent = new BXSchedulerAgent("sample_agent");
agent.Assembly = typeof(MyExecutor).Assembly.GetName().Name;
agent.ClassName = typeof(MyExecutor).FullName;
agent.Save();

Можно также воспользоваться методом SetClassNameAndAssembly(Type) класса BXSchedulerAgent:

CopyC#
BXScheduler agent = new BXSchedulerAgent("sample_agent");
agent.SetClassNameAndAssembly(typeof(MyExecutor));
agent.Save();

Смотри также

Ссылка

IBXAgentExecutor
BXSchedulerAgent


Служба планировщика
Смотри также Send Feedback

Тема содержит следующие разделы.

  • Служба планировщика
  • Похожие темы

Служба планировщика

Служба Планировщика запускается при старте приложения в отдельном потоке с низким приоритетом и производит периодическую проверку агентов, которые необходимо запустить. После запуска агентов служба рассчитывает время, оставшееся для запуска следующего агента и приостанавливает свой поток на этот временной промежуток, но не более 2 мин. При изменении состояния агентов происходит принудительное пробуждение планировщика для проверки агентов.

За работу с планировщиком отвечает класс BXScheduler. Который содержит методы и свойства, позволяющие управлять состоянием службы: запускать, останавливать, производить принудительную проверку.

Смотри также

Ссылка

BXScheduler
BXSchedulerAgent


Локализация

Локализация
Send Feedback

Продукт "1С-Битрикс: Управление сайтом ASP.NET" содержит встроенный механизм локализации системных компонентов и элементов административной части продукта. В каждый момент исполнения в коде доступен словарь языковых фраз, определяемый контекстом исполнения.

В этом разделе

Раздел "Локализация" содержит следующие статьи:

Механизм локализации

Рекомендации по расположению языковых файлов

API для работы с локализацией


Механизм локализации

Механизм локализации
Send Feedback

Тема содержит следующие разделы.

  • Размещение языковых файлов
  • Контексты исполнения

Продукт "1С-Битрикс: Управление сайтом ASP.NET" содержит встроенный механизм локализации системных компонентов и элементов административной части продукта. В каждый момент исполнения в коде доступен словарь языковых фраз, определяемый контекстом исполнения.

Размещение языковых файлов

Языковые фразы хранятся в ресурсных файлах с расширением .lang в формате XML. Местоположение этих файлов может быть различным, в зависимости от соглашения, однако языковые файлы должны:

  • Располагаться в подпапках папки ~/bitrix/

  • Содержать в своем пути подпуть /lang/{идентификатор языка}/

Например, локализация для страницы административного интерфейса ~/bitrix/admin/FileMan.aspx для русского языка может находиться в файле ~/bitrix/admin/lang/ru/FileMan.aspx.lang

Контексты исполнения

В системе локализации выделяется 2 контекста исполнения: случай когда текущий класс имеет привязку к расположению на сервере, например, страница или пользовательский элемент управления т.е. шаблонные элементы управления, располагающиеся непосредственно в папках сайта, и случай, когда текущий класс не имеет привязки к расположению на сервере, например произвольный элемент управления или внутренний API модуля.

Контекст конкретного физического пути

В первом случае, когда известно некоторое расположение на сервере, имя языкового файла получается следующим образом:

  1. К исходному имени файла добавляется расширение .lang, например, для ~/bitrix/admin/FileMan.aspx получаем ~/bitrix/admin/FileMan.aspx.lang

  2. Добавляется подпуть /lang/{идентификатор языка}/ в получившийся путь между именем файла и путем ~/bitrix/. Так, например, для русского языка мы получаем 2 варианта: ~/bitrix/admin/lang/ru/FileMan.aspx.lang и ~/bitrix/lang/ru/admin/FileMan.aspx.lang (оба полученных файла могут использоваться для локализации страницы ~/bitrix/admin/FileMan.aspx)

Дополнительно к файлам, полученным добавлением расширения .lang для получения языковых фраз могут использоваться фразы из файлов include.lang, расположенных либо в той же папке, что и языковой файл, соответствующий шаблонному элементу управления, либо сразу в папке /lang/{идентификатор языка/}, например, для ~/bitrix/lang/ru/admin/FileMan.aspx.lang это будут файлы ~/bitrix/lang/ru/admin/include.lang и ~/bitrix/lang/ru/include.lang соответственно.

Т.к. одному расположению на сервере могут соответствовать несколько языковых файлов, то ресурсы из этих файлов берутся в зависимости от приоритета языкового файла, который определяется следующим образом:

  1. Из 2-х языковых файлов, соответствующих одному расположению на сервере тот имеет больший приоритет, у которого подпуть /lang/{идентификатор языка}/ расположен дальше от корня, например, путь ~/bitrix/admin/lang/ru/FileMan.aspx.lang имеет больший приоритет чем ~/bitrix/lang/ru/admin/FileMan.aspx.lang .

  2. В случае, когда подпуть равноудален от корня, то наивысший приоритет имеет файл, полученный из исходного, добавлением расширения .lang, затем файл include.lang, расположенный в той же папке, что и предыдущий файл, и наименьший приоритет имеет файл include.lang, расположенный непосредственно в папке /lang/{идентификатор языка}/.

Таким образом для русского языка и пути ~/bitrix/admin/FileMan.aspx языковые файлы по убыванию приоритета располагаются следующим образом:

  1. ~/bitrix/admin/lang/ru/FileMan.aspx.lang

  2. ~/bitrix/admin/lang/ru/include.lang

  3. ~/bitrix/lang/ru/admin/FileMan.aspx.lang

  4. ~/bitrix/lang/ru/admin/include.lang

  5. ~/bitrix/lang/ru/include.lang

Контекст модуля

В случае, когда расположение на сервере неизвестно, языковые ресурсы берутся в зависимости от модуля из следующих файлов, расположенных в порядке убывания приоритета:

  1. ~/bitrix/modules/{имя модуля}/lang/{идентификатор языка}/include.lang

  2. ~/bitrix/lang/{идентификатор языка}/include.lang


Рекомендации по расположению языковых файлов

Рекомендации по расположению языковых файлов
Смотри также Send Feedback

Тема содержит следующие разделы.

  • Рекомендации
  • Похожие темы

Рекомендации

Разработчикам различных частей продукта рекомендованы следующие пути расположения языковых файлов:

Компонент системы

Расположение языковых файлов

Компонент

~/bitrix/components/{путь к компоненту}/lang/{идентификатор языка}/...

Шаблон компонента

~/bitrix/components/{путь к компоненту}/templates/{имя шаблона компонента}/lang/{идентификатор языка}/...

~/bitrix/templates/{имя шаблона сайта}/components/{путь к компоненту}/{имя шаблона компонента}/lang/{идентификатор языка}/...

Шаблон сайта

~/bitrix/templates/{имя шаблона сайта}/lang/{идентификатор языка}/...

Модуль

~/bitrix/modules/{имя модуля}/lang/{идентификатор языка}/...

Прочие компоненты системы

~/bitrix/lang/{идентификатор языка}/...

Смотри также

Дополнительная информация

Механизм локализации


API для работы с локализацией

API для работы с локализацией
Смотри также Send Feedback

Тема содержит следующие разделы.

  • API локализации
  • Похожие темы

API локализации

Доступ к API локализации осуществляется через свойства и методы класса BXLoc. При помощи методов GetMessage()()()() и GetModuleMessage()()()() можно получить языковую фразу по ее идентификатору для текущего языка.

CopyC#
protected void Page_LoadComplete(object sender, EventArgs e)
{
    Title = string.Format(
         "{0} - {1}",
        BXLoc.GetModuleMessage("main", "Module.Name"),
        BXLoc.GetMessage(this, "PageTitle")
    );
 }

Текущий язык определяется из настроек в административной части. Узнать текущий язык можно при помощи свойства CurrentLocale класса BXLoc.

CopyC#
protected void Page_LoadComplete(object sender, EventArgs e)
{
    if (string.Equals(BXLoc.CurrentLocale, "ru", StringComparison.InvariantCultureIgnoreCase))
        Title = "Текущий язык - русский";
    else
        Title = "Текущий язык имеет идентификатор \"" + BXLoc.CurrentLocale + "\"";
 }

В базовые классы для страниц (BXPage) и пользовательских элементов управления (BXControl, на основе которого реализованы компоненты) встроена поддержка локализации. Для этого реализованы метод GetMessage(String) для BXPage и метод GetMessage(String) для BXControl, которые возвращают языковую фразу по ее идентификатору в закодированном для HTML виде, а также метод GetMessageRaw(String) для BXPage и метод GetMessageRaw(String) для BXControl, которые возвращают языковую фразу без кодирования.

Смотри также

Ссылка

BXLoc
BXPage
BXControl

Дополнительная информация

Механизм локализации


Сущности

Сущности
Send Feedback

Сущность - это логическая единица хранения и обработки информации, представляющая собой активный субъект системы и соответствующая записи в таблице сущностей этого типа в базе данных системы. Например, сущностями являются элементы информационного блока, сайты, языки и т.п.

Сущность всегда соответствует записи таблицы базы данных с первичным ключем.

В этом разделе

Раздел "Сущности" содержит следующие статьи:

Понятие сущности

Коллекции сущностей

Схемы сущностей

Загрузка сущностей

Сохранение сущностей

Сложные запросы на выборку

Набираемые свойства


Понятие сущности

Понятие сущности
Смотри также Send Feedback

Тема содержит следующие разделы.

  • Описание сущности
  • Пример сущности
  • Функционал сущности
  • Похожие темы

Сущность - это логическая единица хранения и обработки информации, представляющая собой активный субъект системы и соответствующая записи в таблице сущностей этого типа в базе данных системы. Например, сущностями являются элементы информационного блока, сайты, языки и т.п.

Сущность всегда соответствует записи таблицы базы данных с первичным ключем.

Описание сущности

Сущность должна наследовать базовый класс сущности BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>.

Пример сущности

Сущность информационного блока:

CopyC#
public class BXIBlock
    : BXEntity<BXIBlock, BXIBlockCollection, BXIBlock.Scheme>
{

}

где:

  • BXIBlock - сущность информационного блока,

  • BXIBlockCollection - коллекция сущностей информационных блоков,

  • BXIBlock.Scheme - схема сущности информационного блока.

Функционал сущности

Каждая сущность умеет загружать свои параметры из базы данных и сохранять их обратно.

У каждой сущности должны быть определены свойства код модуля и код сущности

CopyC#
public abstract string ModuleId
{
  get;
}

public abstract string EntityId
{
  get;
}

которые однозначно определяют сущность и участвуют в отправке команд изменения сущности.

Смотри также

Ссылка

BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
BXEntity


Коллекции сущностей

Коллекции сущностей
Смотри также Send Feedback

Тема содержит следующие разделы.

  • Описание коллекции сущностей
  • Примеры
  • Похожие темы

Коллекция сущностей представляет собой набор сущностей заданного типа.

Описание коллекции сущностей

Коллекция сущностей должна наследовать базовый класс коллекции сущностей BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>.

Примеры

Коллекция сущностей информационного блока:

CopyC#
public class BXIBlockCollection
  : BXEntityCollection<BXIBlock, BXIBlockCollection, BXIBlock.Scheme>
{

}

где:

  • BXIBlock - сущность информационного блока,

  • BXIBlockCollection - коллекция сущностей информационных блоков,

  • BXIBlock.Scheme - схема сущности информационного блока.

Смотри также

Ссылка

BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>


Схемы сущностей

Схемы сущностей
Send Feedback

Тема содержит следующие разделы.

  • Описание схемы сущности
  • Реализация схемы
  • Примеры
  • Связаные сущности
  • Примеры
  • Вычисляемые поля
  • Примеры
  • Связки
  • Примеры
  • Применение связок
  • Примеры

Схема сущности представляет собой описание хранилища сущности в базе данных. Другими словами, схема сущности является схемой соответствия между сущностью (в бизнес-логике приложения) и представлением этой сущности в базе данных.

Описание схемы сущности

Схема сущности должна наследовать базовый класс схемы сущности BXScheme.

Обычно схема сущности оформляется подклассом класса сущности.

Реализация схемы

В статическом конструкторе схемы необходимо установить название таблицы сущности в базе данных, а так же псевдоним этой таблицы для формирования запросов, с помощью статического метода SetTable.

CopyC#
void BXScheme<Scheme>.SetTable( string table, string tableAlias )

Кроме того в этом же конструкторе необходимо описать список полей таблицы, соответствующий полям сущности, с помощью метода AddField.

CopyC#
void BXScheme<Scheme>.AddField( string key, BXSchemeFieldBase field )

где:

  • key - ключ поля, соответствующий названию поля сущности,

  • field - описание поля таблицы.

Описание поля сущности представляет собой экземпляр класса BXTableField, который наследует класс BXSchemeFieldBase.

CopyC#
// Для поля с типом без указания размера
new BXTableField( string fieldName, SqlDbType fieldType, bool fieldAllowNull )
// Для поля с типом без указания размера, со значением по умолчанию
new BXTableField( string fieldName, SqlDbType fieldType, bool fieldAllowNull, object defaultValue )
// Для поля с типом с указанием размера
new BXTableField( string fieldName, SqlDbType fieldType, int fieldLength, bool fieldAllowNull )
// Для поля с типом с указанием размера, со значением по умолчанию
new BXTableField( string fieldName, SqlDbType fieldType, int fieldLength, bool fieldAllowNull, object defaultValue )
// Для первичного ключа
new BXTableField( string fieldName, SqlDbType fieldType, int fieldLength, bool fieldAllowNull, bool fieldIsPrimaryKey, bool fieldIsIdentity )

Необходимо с помощью свойств схемы описать публичный доступ к полям сущности.

CopyC#
public BXSchemeFieldBase SomeField
{
  get { return GetField("SomeField"); }
}

Примеры

Схема сущности информационного блока:

CopyC#
public class BXIBlock
  : BXEntity<BXIBlock, BXIBlockCollection, BXIBlock.Scheme>
{
  public class Scheme : BXScheme<Scheme>
  {
    static Scheme()
    {
      SetTable("b_IBlock", "ib");

      AddField("ID", new BXTableField("ID", SqlDbType.Int, 0, false, true, true));
      AddField("TypeId", new BXTableField("TypeId", SqlDbType.Int, false));
      AddField("UpdateDate", new BXTableField("UpdateDate", SqlDbType.DateTime, true));
      AddField("Name", new BXTableField("Name", SqlDbType.NVarChar, 255, false));
      AddField("Active", new BXTableField("Active", SqlDbType.Char, 1, false, "Y"));

      . . .
    }

    public BXSchemeFieldBase ID
    {
      get { return GetField("ID"); }
    }

    public BXSchemeFieldBase UpdateDate
    {
      get { return GetField("UpdateDate"); }
    }

    public BXSchemeFieldBase Name
    {
      get { return GetField("Name"); }
    }

    public BXSchemeFieldBase Active
    {
      get { return GetField("Active"); }
    }

    . . .
  }
  . . .
}

Связаные сущности

Связи между сущностями указываются, если сущности связаны один-к-одниму или один-ко-многим и связанная сущность может участвовать в запросе к данной сущности. Например, сущность "язык" является связанной для сущности "сайт", так как они связаны между собой в отношении один-ко-многим и в выборке сущностей "сайт" может участвовать фильтр по полям сущности "язык".

Для регистрации связанных сущностей необходимо в статический конструктор схемы добавить описание связи со связанной сущностью, аналогичное описанию связи с полем таблицы, с помощью метода AddField.

CopyC#
void BXScheme<Scheme>.AddField( string key, BXSchemeFieldBase field )

где:

  • key - ключ поля, соответствующий названию поля сущности,

  • field - описание связи со связанной сущностью.

Описание связи со связанной сущностью представляет собой экземпляр класса BXSchemeField, который наследует класс BXSchemeFieldBase.

CopyC#
new BXSchemeField( string name, Type schemeType, BXSchemeFieldBase.BXAssignField assignTo )

где:

  • name - ключ поля, соответствующий ключу поля сущности,

  • schemeType - тип связанной сущности,

  • assignTo - описание характера связи.

Описание характера связи представляет собой экземпляр класса BXAssignField.

CopyC#
new BXSchemeFieldBase.BXAssignField( BXSchemeFieldBase assignTo, string joinField, string assignAlias, bool separateQuery )

где:

  • assignTo - поле сущности, с которым связана данная связанная сущность,

  • joinField - название поля связанной сущности, по которому осуществляется связь,

  • assignAlias - псевдоним связи для формирования запроса,

  • separateQuery - если равен false, то связь будет формироваться автоматически без подзапросов, если true - то будут подготовлены данные для подзапроса, который необходимо будет сформировать самостоятельно.

Необходимо с помощью свойств схемы описать публичный доступ к полям сущности.

CopyC#
public SomeJoinedEntity.Scheme SomeJoinedEntity
{
  get { return ((BXSchemeField)GetField("SomeJoinedEntity")).Scheme as SomeJoinedEntity.Scheme; }
}

Примеры

У сущности "сайт" есть поле "LanguageId", в которое записывается код сущности "язык". То есть каждый сайт относится к какому-нибудь языку, к каждому языку может относиться произвольное число сайтов. Для того, чтобы в сущности "сайт" описать связь к сущности "язык" и иметь таким образом возможность фильтровать или сортировать сайты по полям языка, необходимо добавить в сущность "сайт" следующий код

CopyC#
public class BXSite : BXEntity<BXSite, BXSiteCollection, BXSite.Scheme>
{
  public class Scheme : BXScheme<Scheme>
  {
    static Scheme()
    {
      . . .

      AddField(
        "Language",
        new BXSchemeField(
          "Language",
          typeof(BXLanguage),
          new BXSchemeFieldBase.BXAssignField(
            Scheme.SelectField("LanguageId"),
            "ID",
            "lng",
            false
          )
        )
      );
    }

    public BXLanguage.Scheme Language
    {
      get { return ((BXSchemeField)GetField("Language")).Scheme as BXLanguage.Scheme; }
    }

    . . .
}

Вычисляемые поля

У схемы могут быть поля, которые не имеют соответствия среди полей таблицы. Эти поля могут участвовать в формировании запросов на выборку сущностей. В случае использования вичисляемого поля в фильтре, списке выборки или условиях сортировки, в запрос подставляется не само это поле, а строковое значение, которое это поле сформирует.

Для регистрации вычисляемого поля необходимо в статический конструктор схемы добавить описание вычисляемого поля, аналогичное описанию связи с полем таблицы, с помощью метода AddField.

CopyC#
void BXScheme<Scheme>.AddField( string key, BXSchemeFieldBase field )

где:

  • key - ключ поля, соответствующий названию поля сущности,

  • field - описание вычисляемого поля.

Описание вычисляемого поля представляет собой экземпляр класса BXCalculatedField, который наследует класс BXSchemeFieldBase.

CopyC#
new BXCalculatedField( string fieldName, SqlDbType? type, BXCalculatedField.GetCustomFilterMethod customFilterMethod, BXCalculatedField.GetCustomOrderByMethod customOrderByMethod, BXCalculatedField.GetCustomSelectMethod customSelectMethod )

где:

  • fieldName - ключ поля, соответствующий ключу поля сущности,

  • type - тип вычисляемого поля (как правило null),

  • customFilterMethod - делегат для подстановки в фильтр запроса,

  • customOrderByMethod - делегат для подстановки в сортировку запроса,

  • customSelectMethod - делегат для подстановки в список выборки.

Делегаты имеют следующее описание

CopyC#
public delegate KeyValuePair<string, SqlParameter[]> GetCustomFilterMethod(BXSqlFilterOperators operation, object value);
public delegate KeyValuePair<string, SqlParameter[]> GetCustomSelectMethod();
public delegate KeyValuePair<string, SqlParameter[]> GetCustomOrderByMethod(BXOrderByDirection direction);

где возвращаемые строки - это строки, которые будут добавлены в соответствующее место запроса, а возвращаемые массивы параметров будут добавлены в параметры запроса.

Необходимо с помощью свойств схемы описать публичный доступ к полям сущности

CopyC#
public BXSchemeFieldBase SomeCalculatedField
{
    get { return GetField("SomeCalculatedField"); }
}

Примеры

У сущности "сайт" есть строковое поле "Directory". Необходимо дать возможность в запросе на выборку сущностей "сайт" сортировать эти сущности по длине содержимого поля "Directory". Для этого необходимо добавить в сущность "сайт" следующий код

CopyC#
public class BXSite : BXEntity<BXSite, BXSiteCollection, BXSite.Scheme>
{
  public class Scheme : BXScheme<Scheme>
  {
    static Scheme()
    {
      . . .

      AddField(
        "DirectoryLength",
        new BXCalculatedField(
          "DirectoryLength",
          null,
          null,
          delegate(BXOrderByDirection direction)
          {
            return new KeyValuePair<string, SqlParameter[]>(
              String.Format("LEN(st.Directory) {0}", ((direction == BXOrderByDirection.Asc) ? "ASC" : "DESC")),
              null
            );
          },
          null
        )
      );
    }

    public BXSchemeFieldBase DirectoryLength
    {
      get { return GetField("DirectoryLength"); }
    }

    . . .
}

Связки

Связкой является таблица-связка, организующая связь типа многие-ко-многим между сущностями. Например, сущность "информационный блок" связана с сущностью "сайт" в отношении многие-ко-многим. При выборке списка сущностей "информационный блок" можно задавать фильтр по полям сущности "сайт".

Связка должна наследовать базовый класс связки BXLinkedEntity.

Обычно класс связки объявляется подклассом класса сущности.

В классе связки необходимо определить схему таблицы-связки аналогично тому, как определяется схема для сущности. Кроме того необходимо определить свойства связки для доступа к полям связки аналогично свойствам сущности.

Так же необходимо определить коллекцию связок аналогично коллекции сущностей.

В классе сущности необходимо определить свойство, через которое будет осуществляться доступ к данным связки. Данные связки выбираются по запросу с помощью метода GetLinkedValue<(Of <<'(T>)>>)(String).

CopyC#
LinkedEntityCollectionType BXEntity<EntityType, EntityCollectionType, EntryScheme>.GetLinkedValue<LinkedEntityCollectionType>( string key )

Примеры

Информационый блок связан с сайтами отношением многие-ко-многим. Для описания связки необходимо определить в классе информационного блока подклассы

CopyC#
public class BXIBlock
  : BXEntity<BXIBlock, BXIBlockCollection, BXIBlock.Scheme>
{
  . . .
  public class BXInfoBlockSiteCollection : BXEntityCollection<BXInfoBlockSite, BXInfoBlockSiteCollection, BXInfoBlockSite.Scheme>
  {
    public BXInfoBlockSiteCollection()
    {
    }

    public void Add(string siteId)
    {
      this.Add(new BXInfoBlockSite(siteId));
    }
  }

  public class BXInfoBlockSite : BXLinkedEntity<BXInfoBlockSite, BXInfoBlockSiteCollection, BXInfoBlockSite.Scheme>
  {
    public class Scheme : BXScheme<Scheme>
    {
      static Scheme()
      {
        SetTable("b_IBlockInSite", "ibis");

        AddField("IBlockId", new BXTableField("IBlockId", SqlDbType.Int, false));
        AddField("SiteId", new BXTableField("SiteId", SqlDbType.VarChar, 50, false));
      }

      public BXSchemeFieldBase InfoBlockId
      {
        get { return GetField("IBlockId"); }
      }

      public BXSchemeFieldBase SiteId
      {
        get { return GetField("SiteId"); }
      }
    }

    public override string ModuleId
    {
      get { return "iblock"; }
    }

    public override string EntityId
    {
      get { return "InfoBlockSite"; }
    }

    public int InfoBlockId
    {
      get { return GetValue<int>("IBlockId"); }
      set { SetValue("IBlockId", value); }
    }

    public string SiteId
    {
      get { return this.TextEncoder.Encode(GetValue<string>("SiteId")); }
      set { SetValue("SiteId", value); }
    }

    public BXInfoBlockSite()
    {
    }

    public BXInfoBlockSite(string siteId)
    {
      this.SiteId = siteId;
    }
  }

  . . .

  public BXInfoBlockSiteCollection Sites
  {
    get
    {
      return GetLinkedValue<BXInfoBlockSiteCollection>("Sites");
    }
  }

  . . .
}

Применение связок

Для регистрации связок необходимо в статический конструктор схемы сущности добавить описание связи со связкой, аналогичное описанию связи с полем таблицы, с помощью метода AddField.

CopyC#
void BXScheme<Scheme>.AddField( string key, BXSchemeFieldBase field )

где:

  • key - ключ поля, соответствующий названию поля сущности,

  • field - описание связи со связкой.

Описание связи со связкой представляет собой экземпляр класса BXLinkedField, который наследует класс BXSchemeFieldBase.

CopyC#
BXLinkedField.BXLinkedField( string name, Type entityType, BXSchemeFieldBase linkedField, string mainFieldKey, BXSchemeFieldBase.BXAssignField assignTo )

где:

  • name - ключ поля, соответствующий ключу поля сущности,

  • entityType - тип связки,

  • linkedField - поле связки, которое связано с сущностью,

  • mainFieldKey - название поля сущности, которое связано со связкой,

  • assignTo - описание характера связи.

Описание характера связи представляет собой экземпляр класса BXAssignField.

CopyC#
new BXSchemeFieldBase.BXAssignField( BXSchemeFieldBase assignTo, string joinField, string assignAlias, bool separateQuery )

где:

  • assignTo - поле сущности, с которым связана данная связка,

  • joinField - название поля связки, по которому осуществляется связь,

  • assignAlias - псевдоним связи для формирования запроса,

  • separateQuery - если равен false, то связь будет формироваться автоматически без подзапросов, если true - то будут подготовлены данные для подзапроса, который необходимо будет сформировать самостоятельно.

Необходимо с помощью свойств схемы описать публичный доступ к полям сущности.

CopyC#
public SomeLinkedEntity.Scheme Link
{
  get { return ((BXLinkedField)GetField("Link")).Scheme as SomeLinkedEntity.Scheme; }
}

Примеры

Сущности "информационный блок" и "сайт" связаны отношением многие-ко-многим с помощью промежуточной связки (таблицы-связки). Для того, чтобы в сущности "информационный блок" описать связь к сущности "сайт" и иметь таким образом возможность фильтровать информационные блоки по сайтам, необходимо описать связку и добавить в сущность "информационный блок" следующий код

CopyC#
public class BXIBlock : BXEntity<BXIBlock, BXIBlockCollection, BXIBlock.Scheme>
{
  public class Scheme : BXScheme<Scheme>
  {
    static Scheme()
    {
      . . .

      AddField(
        "Sites",
        new BXLinkedField(
          "Sites",
          typeof(BXInfoBlockSite),
          BXInfoBlockSite.Fields.InfoBlockId,
          "ID",
          new BXSchemeFieldBase.BXAssignField(
            Scheme.SelectField("ID"),
            "IBlockId",
            "lng",
            false
          )
        )
      );
    }

    public BXInfoBlockSite.Scheme Sites
    {
      get { return ((BXLinkedField)GetField("Sites")).Scheme as BXInfoBlockSite.Scheme; }
    }

    . . .
  }
}


Загрузка сущностей

Загрузка сущностей
Send Feedback

Тема содержит следующие разделы.

  • Методы выборки списка сущностей по фильтру
  • Методы выборки сущности по первичному ключу

Каждая сущность умеет загружать свои параметры из базы данных.

Методы выборки списка сущностей по фильтру

Выборка коллекции сущностей по фильтру осуществляется с помощью метода GetList()()()().

CopyC#
EntityCollectionType BXEntity<EntityType, EntityCollectionType, EntryScheme>.GetList( BXFilter filter, BXOrderBy orderBy )
EntityCollectionType BXEntity<EntityType, EntityCollectionType, EntryScheme>.GetList( BXFilter filter, BXOrderBy orderBy, BXSelect select, BXQueryParams queryParams )
EntityCollectionType BXEntity<EntityType, EntityCollectionType, EntryScheme>.GetList( BXFilter filter, BXOrderBy orderBy, BXSelect select, BXQueryParams queryParams, IBXTextEncoder textEncoder )

Например, выборка всех активных сущностей "сайт", отсортированая по названию сайта, может быть осуществлена следующим образом:

CopyC#
BXSiteCollection coll = BXSite.GetList(
    new BXFilter(
        new BXFilterItem(BXSite.Fields.Active, BXSqlFilterOperators.Equal, true)
    ),
    new BXOrderBy(
        new BXOrderByPair(BXSite.Fields.Name, BXOrderByDirection.Asc)
    )
);

Статический метод выборки списка сущностей по фильтру сводится к виртуальному методу GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder)

CopyC#
EntityCollectionType BXEntity<EntityType, EntityCollectionType, EntryScheme>.GetListInternal( BXFilter filter, BXOrderBy orderBy, BXSelect select, BXQueryParams queryParams, IBXTextEncoder textEncoder )

и может быть переопределен в конкретной реализации сущности. Таким образом выборка по фильтру конкретной сущности может осуществляться не стандартным образом. Стандартная реализация метода выборки списка сущностей по фильтру не поддерживает подзапросы.

Стандартная выборка по фильтру происходит следующим образом:

  1. Вызывается виртуальный метод PrepareSelectForGetList(BXSelect%)

    CopyC#
    void BXEntity<EntityType, EntityCollectionType, EntryScheme>.PrepareSelectForGetList( ref BXSelect select )

    который заполняет список выбираемых полей BXSelect всеми полями сущности, если этот список пуст. Этот метод может быть переопределен в конкретной сущности для реализации другого алгоритма заполнения списка выбираемых полей.

  2. Для формирования части FROM запроса вызывается виртуальный метод PrepareFromForGetList(String, BXSchemeBase, BXFilter, BXOrderBy, BXSelect)

    CopyC#
    string BXEntity<EntityType, EntityCollectionType, EntryScheme>.PrepareFromForGetList( string key, BXSchemeBase scheme, BXFilter filter, BXOrderBy orderBy, BXSelect select )

    Этот метод может быть переопределен в конкретной сущности для реализации другого алгоритма формирования части FROM запроса.

  3. Для формирования списка параметров запроса вызывается виртуальный метод PrepareParametersForGetList(BXFilter, BXOrderBy, BXSelect)

    CopyC#
    SqlParameter[] BXEntity<EntityType, EntityCollectionType, EntryScheme>.PrepareParametersForGetList( BXFilter filter, BXOrderBy orderBy, BXSelect select )

    Этот метод может быть переопределен в конкретной сущности для реализации другого алгоритма формирования списка параметров запроса.

  4. Выполняется запрос к базе и создается коллекция сущностей.

Методы выборки сущности по первичному ключу

Выборка сущности по первичному ключу осуществляется с помощью метода GetById()()()():

CopyC#
EntityType BXEntity<EntityType, EntityCollectionType, EntryScheme>.GetById( object id)
EntityType BXEntity<EntityType, EntityCollectionType, EntryScheme>.GetById( object id, IBXTextEncoder textEncoder )

Например, выборка сущности "сайт" с кодом "company" может быть осуществлена следующим образом:

CopyC#
BXSite site = BXSite.GetById("company");

Статический метод выборки сущности по первичному ключу сводится к виртуальному методу GetByIdInternal(Object, IBXTextEncoder)

CopyC#
EntityType BXEntity<EntityType, EntityCollectionType, EntryScheme>.GetByIdInternal( object id, IBXTextEncoder textEncoder )

и может быть переопределен в конкретной реализации сущности. Таким образом выборка по первичному ключу конкретной сущности может осуществляться не стандартным образом. Стандартная реализация метода выборки по первичному ключу сводится к вызову метода выборки по фильтру.


Сохранение сущностей

Сохранение сущностей
Send Feedback

Тема содержит следующие разделы.

  • Сохранение новой сущности
  • Сохранение существующей сущности
  • Сохранение сущности
  • Удаление существующей сущности
  • Удаление существующей сущности статическим методом.
  • Удаление существующих сущностей по фильтру.

Каждая сущность умеет сохраняться в соответствующей таблице базы данных.

Сохранение новой сущности

Сохранение новой сущности осуществляется с помощью метода Create()()()()

CopyC#
void BXEntity<EntityType, EntityCollectionType, EntryScheme>.Create(  )
void BXEntity<EntityType, EntityCollectionType, EntryScheme>.Create( BXSqlConnection conn, BXSqlTransaction trans )

Например, создание и сохранение в базе сущности "сайт" можно осуществить следующим образом:

CopyC#
BXSite site = new BXSite("company");
site.Name = "Моя компания";
site.Active = true;
site.Sort = 150;
site.Create();

Метод сохранения новой сущности является виртуальным и может быть переопределен в конкретной реализации сущности. Таким образом сохранение конкретной сущности может осуществляться не стандартным образом.

Стандартное сохранение новой сущности происходит следующим образом:

  1. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnBeforeCreate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Cancel, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для того, чтобы была возможность корректно отменить сохранение сущности. Обработчики этой команды не должны модифицировать данные, так как нет гарантий, что один из обработчиков не отменит сохранение.

  2. Вызывается виртуальный метод VerifyEntry()()()():

    CopyC#
    BXModifyStatus BXEntity<EntityType, EntityCollectionType, EntryScheme>.VerifyEntry(  )

    который проверяет соответствие параметров сущности и ее схемы. Производятся следующие проверки полей сущности:

    • если поле является первичным ключем и у него установлен флаг Identity, то в параметрах сущности не должно быть заданого значения для этого поля;

    • если поле является первичным ключем и у него не установлен флаг Identity, то в параметрах сущности должно быть задано значение для этого поля;

    • если поле является обязательным и у него не задано значение по умолчанию, то в параметрах сущности должно быть задано значение для этого поля;

    • если поле является строковым, у него задано ограничение по длине и задано значение этого поля, то значение не должно быть длинее указанного ограничения.

    Если метод VerifyEntry()()()() вернул отличный от BXModifyStatusResult.Success статус, то сохранение преравается и выбрасывается исключение типа BXEventException.

  3. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnCreate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций перед сохранением новой сущности.

  4. Производится сохранение сущности и ее связок.

  5. Выполняется виртуальный метод CreateAdditionalEntities(BXSqlConnection, BXSqlTransaction):

    CopyC#
    void BXEntity<EntityType, EntityCollectionType, EntryScheme>.CreateAdditionalEntities( BXSqlConnection conn, BXSqlTransaction trans )

    который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется в рамках транзакции сохранения сущности.

  6. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnAfterCreate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций после сохранения новой сущности.

  7. Выполняется виртуальный метод CreateAfterSuccess()()()():

    CopyC#
    void BXEntity<EntityType, EntityCollectionType, EntryScheme>.CreateAfterSuccess(  )

    который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется после закрытия соединения, в котором сохранялась сущность.

Сохранение существующей сущности

Сохранение (обновление) существующей сущности осуществляется с помощью метода Update()()()()

CopyC#
void BXEntity<EntityType, EntityCollectionType, EntryScheme>.Update(  )
void BXEntity<EntityType, EntityCollectionType, EntryScheme>.Update( BXSqlConnection conn, BXSqlTransaction trans )

Например, загрузку, изменение и сохранение в базе сущности "сайт" можно осуществить следующим образом

CopyC#
BXSite site = BXSite.GetById("company");
site.Name = "Моя компания";
site.Active = true;
site.Sort = 150;
site.Update();

Метод сохранения существующей сущности является виртуальным и может быть переопределен в конкретной реализации сущности. Таким образом сохранение конкретной сущности может осуществляться не стандартным образом.

Стандартное сохранение существующей сущности происходит следующим образом:

  1. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnBeforeUpdate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Cancel, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для того, чтобы была возможность корректно отменить сохранение сущности. Обработчики этой команды не должны модифицировать данные, так как нет гарантий, что один из обработчиков не отменит сохранение.

  2. Вызывается виртуальный метод VerifyEntry()()()():

    CopyC#
    BXModifyStatus BXEntity<EntityType, EntityCollectionType, EntryScheme>.VerifyEntry(  )

    который проверяет соответствие параметров сущности и ее схемы. Производятся следующие проверки полей сущности:

    • если поле является первичным ключем, то в параметрах сущности должно быть задано значение для этого поля;

    • если поле является строковым, у него задано ограничение по длине и задано значение этого поля, то значение не должно быть длинее указанного ограничения.

    Если метод VerifyEntry()()()() вернул отличный от BXModifyStatusResult.Success статус, то сохранение преравается и выбрасывается исключение типа BXEventException.

  3. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnUpdate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций перед сохранением существующей сущности.

  4. Производится сохранение сущности и ее связок.

  5. Выполняется виртуальный метод UpdateAdditionalEntities(BXSqlConnection, BXSqlTransaction)

    CopyC#
    void BXEntity<EntityType, EntityCollectionType, EntryScheme>.UpdateAdditionalEntities( BXSqlConnection conn, BXSqlTransaction trans )

    который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется в рамках транзакции сохранения сущности.

  6. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnAfterUpdate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций после сохранения существующей сущности.

  7. Выполняется виртуальный метод UpdateAfterSuccess()()()():

    CopyC#
    void BXEntity<EntityType, EntityCollectionType, EntryScheme>.UpdateAfterSuccess(  )

    который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется после закрытия соединения, в котором сохранялась сущность.

Сохранение сущности

Сохранение как новой, так и существующей сущности может осуществляться с помощью метода Save()()()()

CopyC#
void BXEntity<EntityType, EntityCollectionType, EntryScheme>.Save(  )

Этот метод вызывает метод Create()()()(), если свойство IsNew сущности установлено в значение true, и вызывает метод Update()()()() в противном случае. Свойство IsNew сущности устанавливается автоматически.

Удаление существующей сущности

Удаление существующей сущности осуществляется с помощью метода Delete()()()():

CopyC#
void BXEntity<EntityType, EntityCollectionType, EntryScheme>.Delete(  )
void BXEntity<EntityType, EntityCollectionType, EntryScheme>.Delete( BXSqlConnection conn, BXSqlTransaction trans )

Например, удаление сущности "сайт" можно осуществить следующим образом:

CopyC#
BXSite site = BXSite.GetById("company");
site.Delete();

Метод удаления существующей сущности является виртуальным и может быть переопределен в конкретной реализации сущности. Таким образом удаление конкретной сущности может осуществляться не стандартным образом.

Стандартное удаление существующей сущности происходит следующим образом:

  1. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnBeforeDelete, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Cancel, то удаление сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для того, чтобы была возможность корректно отменить удаление сущности. Обработчики этой команды не должны модифицировать данные, так как нет гарантий, что один из обработчиков не отменит удаление.

  2. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnDelete, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то удаление сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций перед удалением существующей сущности.

  3. Выполняется виртуальный метод DeleteAdditionalEntities(BXSqlConnection, BXSqlTransaction):

    CopyC#
    void BXEntity<EntityType, EntityCollectionType, EntryScheme>.DeleteAdditionalEntities( BXSqlConnection conn, BXSqlTransaction trans )

    который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется в рамках транзакции удаления сущности.

  4. Производится удаление сущности и ее связок.

  5. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnAfterDelete, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций после удаления существующей сущности.

  6. Выполняется виртуальный метод DeleteAfterSuccess()()()():

    CopyC#
    void BXEntity<EntityType, EntityCollectionType, EntryScheme>.DeleteAfterSuccess(  )

    который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется после закрытия соединения, в котором удалялась сущность.

Удаление существующей сущности статическим методом.

Удаление существующей сущности статическим методом осуществляется с помощью статического метода Delete(Object).

CopyC#
void BXEntity<EntityType, EntityCollectionType, EntryScheme>.Delete( object id )

Например, удаление сущности "сайт" можно осуществить следующим образом:

CopyC#
site.Delete("company");

Алгоритм удаления сущности статическим методом совпадает с описаным выше алгоритмом удаления сущности.

Удаление существующих сущностей по фильтру.

Удаление существующих сущностей по фильтру осуществляется с помощью статического метода Delete(BXFilter)

CopyC#
void BXEntity<EntityType, EntityCollectionType, EntryScheme>.Delete( BXFilter filter )

Например, удаление всех не активных сущностей "сайт" можно осуществить следующим образом:

CopyC#
BXSite.Delete(
  new BXFilter(
    new BXFilterItem(BXSite.Fields.Active, BXSqlFilterOperators.Equal, false)
  )
);

При удалении сущностей по фильтру в стандартной реализации не удаляются никакие связанные данные и не отправляются никакие команды. Поэтому стандартная реализация подходит не для всех сущностей. Для реализации удаления сущностей по фильтру в конкретной реализации сущности необходимо перекрыть виртуальный метод DeleteInternal(BXFilter):

CopyC#
void BXEntity<EntityType, EntityCollectionType, EntryScheme>.DeleteInternal( BXFilter filter )


Сложные запросы на выборку

Сложные запросы на выборку
Send Feedback

Тема содержит следующие разделы.

  • Подзапросы
  • Часть FROM запроса
  • Часть WHERE запроса

В случае необходимости построения сложных запросов на выборку коллекции сущностей, которые не поддерживаются базовым классом сущностей, необходимо при реализации конкретной сущности перегрузить внутренний метод выборки GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder):

CopyC#
protected virtual EntityCollectionType GetListInternal(
  BXFilter filter,
  BXOrderBy orderBy,
  BXSelect select,
  BXQueryParams queryParams,
  IBXTextEncoder textEncoder
)

Пример простого перегруженного метода для сущности SomeEntity:

CopyC#
protected override SomeEntityCollection GetListInternal(BXFilter filter, BXOrderBy orderBy,
  BXSelect select, BXQueryParams queryParams, IBXTextEncoder textEncoder)
{
  // Заполним список выборки всеми полями сущности, если этот список пуст
  this.PrepareSelectForGetList(ref select);

  // Если выборка ограничивается страницей, подсчитаем количество выбираемых записей
  int topValues = 0;
  if (queryParams != null && queryParams.AllowPaging)
    topValues = queryParams.PagingStartIndex + queryParams.PagingRecordCount;

  // Начинаем формировать строку запроса
  StringBuilder sb = new StringBuilder();
  sb.Append("SELECT ");
  if (topValues > 0)
    sb.Append(String.Format("TOP {0} ", topValues));
  sb.AppendLine(select.SelectString);

  // Формируем часть FROM запроса
  sb.Append(
    this.PrepareFromForGetList(string.Empty, SomeEntity.Fields, filter, orderBy, select)
  );

  // Если есть фильтр, то добавляем его в запрос
  if (filter != null)
    if (filter.FilterString.ContainsKey(String.Empty))
      sb.AppendLine(String.Format("WHERE {0}", filter.FilterString[String.Empty]));

  // Если есть условия сортировки, то добавляем их в запрос
  if (orderBy != null)
    if (!String.IsNullOrEmpty(orderBy.OrderByString))
      sb.AppendLine(String.Format("ORDER BY {0}", orderBy.OrderByString));

  // Формируем массив параметров запроса
  SqlParameter[] parameters = this.PrepareParametersForGetList(filter, orderBy, select);

  // Вызываем выполнение запроса и заполнение коллекции сущностей
  return SomeEntity.ExecuteSql(sb.ToString(), parameters, queryParams, textEncoder);
}

Подзапросы

В случае наложения фильтра на связанную сущность (таблицу), в которой может быть более одной записи, соответствующей экземпляру данной сущности (записи таблицы), необходимо применение подзапросов. В противном случае могут быть порождены дублирующие сущности. Подзапросы автоматически не поддерживаются базовым методом выборки типа [Overload:M:Bitrix.DataLayer.BXEntity`3.GetList]. Для реализации подзапросов необходимо перегрузить внутренний метод выборки GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder).

Для того, чтобы условия фильтрации связанной сущности (таблицы) выделялись из общего фильтра, необходимо при задании поля схемы этой сущности (таблицы) в конструкторе связывающего объекта установить флаг выделения запроса в значение true.

CopyC#
AddField(
  "Sections",
  new BXLinkedField(
    "Sections",
    typeof(BXInfoBlockElementSection),
    BXInfoBlockElementSection.Fields.ElementId,
    "ID",
    new BXSchemeFieldBase.BXAssignField(
      Scheme.SelectField("ID"),
      "ElementId",
      "elm",
      true
    )
  )
);

AddField(
  "IBlock",
  new BXSchemeField(
    "IBlock",
    typeof(BXIBlock),
    new BXSchemeFieldBase.BXAssignField(
      Scheme.SelectField("IBlockID"),
      "ID",
      "eb",
      true
    )
  )
);

При наложении условий фильтра основной фильтр будет сформирован в пустом ключе словаря фильтров. А фильтр на связанные сущности, требующие подзапросов, будет сформирован в ключах словаря фильтров, соответствующих названиям таблиц связанных сущностей.

CopyC#
StringBuilder sb = new StringBuilder();

. . .

// Формируем часть FROM запроса
sb.Append(this.PrepareFromForGetList(string.Empty, SomeEntity.Fields, filter, orderBy, select));

if (filter != null)
{
  // Добавим в строку запроса основной фильтр
  if (filter.FilterString.ContainsKey(String.Empty))
    sb.AppendLine(String.Format("WHERE {0}", filter.FilterString[String.Empty]));

  // Добавим в строку запроса подзапрос
  if (filter.FilterString.ContainsKey(SomeEntity.Fields.FieldsTable))
  {
    sb.AppendLine(
      String.Format(
        "{0} {1} IN (SELECT elm_{2} {3} WHERE {4}) ",
        filter.FilterString.ContainsKey(String.Empty) ? " AND" : " WHERE",
        SomeEntity.Fields.ID.QueryName,
        SomeEntity.SomeLinkedEntity.Fields.ElementId.QueryName,
        this.PrepareFromForGetList(SomeEntity.Fields.FieldsTable,
      SomeEntity.SomeLinkedEntity.Fields, filter, orderBy, select),
        filter.FilterString[SomeEntity.Fields.FieldsTable]
      )
    );
  }
}

. . .

Часть FROM запроса

Часть FROM запроса формируется с помощью метода PrepareFromForGetList(String, BXSchemeBase, BXFilter, BXOrderBy, BXSelect):

CopyC#
protected virtual string PrepareFromForGetList(
  string key,
  BXSchemeBase scheme,
  BXFilter filter,
  BXOrderBy orderBy,
  BXSelect select
)

Для формирования части FROM основного запроса необходимо в качестве ключа передать пустую строку. Для формирования части FROM подзапросов необходимо в качестве ключа передать строку, соответствующую соединению основной сущности (таблицы сущности) и связанной сущности (таблицы связанной сущности). Эти строка формируется из названий таблиц, участвующих в связи.

CopyC#
// Часть FROM основного запроса сущности SomeEntity
string mainFrom = this.PrepareFromForGetList(string.Empty, SomeEntity.Fields, filter, orderBy, select);

// Часть FROM подзапроса к связке SomeLinkedEntity для сущности SomeEntity
string subFrom = this.PrepareFromForGetList(SomeEntity.Fields.FieldsTable,
  SomeEntity.SomeLinkedEntity.Fields, filter, orderBy, select)

// Часть FROM подзапроса к сущности, связанной с сущностью SomeEntity с помощью связки SomeLinkedEntity
string k = String.Format("{0}.{1}", SomeEntity.SomeLinkedEntity.Fields.FieldsTable, SomeEntity.Fields.FieldsTable);
string subFrom = this.PrepareFromForGetList(k, SomeEntity.SomeLinkedEntity.Fields, filter, orderBy, select)

Часть WHERE запроса

Часть WHERE запроса формируется с помощью свойства FilterString()()()() объекта фильтра.

CopyC#
Dictionary<string, string> FilterString { get; }

Для формирования части WHERE основного запроса необходимо в качестве ключа передать пустую строку. Для формирования части WHERE подзапросов необходимо в качестве ключа передать строку, соответствующую соединению основной сущности (таблицы сущности) и связанной сущности (таблицы связанной сущности). Эти строка формируется из названий таблиц, участвующих в связи.

CopyC#
// Часть WHERE основного запроса сущности SomeEntity
string mainWhere = String.Format("WHERE {0}", filter.FilterString[String.Empty]);

// Часть WHERE подзапроса к связке SomeLinkedEntity для сущности SomeEntity
string subWhere = String.Format("WHERE {0}", filter.FilterString[SomeEntity.Fields.FieldsTable]);

// Часть WHERE подзапроса к сущности, связанной с сущностью SomeEntity с помощью связки SomeLinkedEntity
string k = String.Format("{0}.{1}", SomeEntity.SomeLinkedEntity.Fields.FieldsTable, SomeEntity.Fields.FieldsTable);
string subFrom = String.Format("WHERE {0}", filter.FilterString[k]);


Набираемые свойства

Набираемые свойства
Send Feedback

Тема содержит следующие разделы.

  • Выборка значений свойств одним запросом с выборкой сущности, фильтр по значениям свойств

Базовый класс сущности поддерживает набираемые свойства. Для того, чтобы включить механизм набираемых свойств в конкретной сущности, необходимо переопределить свойство CustomFieldsKey()()()() и метод GetCustomFieldsKeyInternal(String). Свойство CustomFieldsKey()()()() должно возвращать ключ набираемых свойств для данной сущности, а метод GetCustomFieldsKeyInternal(String) должен уметь формировать ключ на основании параметра.

CopyC#
protected override string CustomFieldsKey
{
  get
  {
    if (this.IBlockId > 0)
      return String.Format("IBlock_{0}", this.IBlockId);

    return null;
  }
}

protected override string GetCustomFieldsKeyInternal(string id)
{
  if (!String.IsNullOrEmpty(id) && !"0".Equals(id, StringComparison.InvariantCultureIgnoreCase))
    return String.Format("IBlock_{0}", id);

  return null;
}

После этого у сущности станет доступно свойство CustomFields()()()()

CopyC#
public virtual BXCustomFieldCollection CustomFields { get; }

возвращающее коллекцию набираемых свойств сущности, и CustomValues

CopyC#
public virtual BXCustomPropertyCollection CustomValues { get; }

возвращающее коллекцию значений набираемых свойств сущности.

Выборка значений свойств одним запросом с выборкой сущности, фильтр по значениям свойств

Базовый класс сущности поддерживает выборку значений набираемых свойств сущности в одном запросе с выборкой сущности. Кроме того поддерживаются фильтры по набираемым свойствам.

CopyC#
string text = "\r\n";

BXIBlockElementCollection col = BXIBlockElement.GetList(
  new BXFilter(
    new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, 5),
    new BXFilterItem(BXIBlockElement.Fields.Active, BXSqlFilterOperators.Equal, "Y"),
    new BXFilterItem(
      new BXSchemeCustomField(BXIBlockElement.GetCustomFieldsKey(5), "UF_AUTHORS", BXIBlockElement.Fields.ID),
      BXSqlFilterOperators.GreaterOrEqual,
      "26"
    )
  ),
  new BXOrderBy(
    new BXOrderByPair(BXIBlockElement.Fields.Sort, BXOrderByDirection.Asc),
    new BXOrderByPair(
      new BXSchemeCustomField(BXIBlockElement.GetCustomFieldsKey(5), "UF_PUBLISHER", BXIBlockElement.Fields.ID),
      BXOrderByDirection.Asc
    )
  ),
  new BXSelect(
    BXIBlockElement.Fields.ID,
    BXIBlockElement.Fields.Name,
    BXIBlockElement.Fields.IBlock.ID,
    new BXSchemeCustomField(BXIBlockElement.GetCustomFieldsKey(5), "UF_YEAR", BXIBlockElement.Fields.ID)
  ),
  new BXQueryParams(new BXPagingOptions(0, 5))
);

foreach (BXIBlockElement el in col)
  text += String.Format("{0}, {1}, {2}, {3}\r\n", el.Id, el.Name, el.IBlockId, el.GetValue<string>("CT_UF_YEAR"));

Поле набираемого свойства описывается объектом типа BXSchemeCustomField

CopyC#
public class BXSchemeCustomField : BXSchemeFieldBase

конструктор которого имеет следующий вид

CopyC#
public BXSchemeCustomField(
  string customFieldKey,
  string name,
  BXSchemeFieldBase joinField
)

где

customFieldKey - это ключ набираемых свойств для данной сущности,

name - код конкретного набираемого свойства,

joinField - поле сущности, по которому происходит связь со значениями набираемый свойств (обычно первичный ключ).


Создание компонента

Создание компонента
Send Feedback

В этом разделе описан процесс создания компонента.

В этом разделе

Этапы создания компонента:

Создание простого компонента

Создание шаблона компонента

Настройка описания компонента

Настройка расширенного описания компонента

Добавление стилей и скриптов к шаблону

Добавление кеширования


Создание простого компонента
Send Feedback

Компонент представляет собой класс, унаследованный от BXComponent и расположенный в файле ~/bitrix/components/пространство_имен/имя_компонента/component.ascx В этом руководстве мы создадим компонент tutorial:sample.list, который, соответственно, будет располагаться по пути ~/bitrix/components/tutorial/sample.list/component.ascx.

Создание простого компонента

  1. В папке ~/bitrix/components создаем папку tutorial, а в ней - подпапку sample.list.

  2. В созданной папке ~/bitrix/components/tutorial/sample.list создаем новый пользовательский элемент управления (Web User Control) c именем component.ascx c CodeBehind-файлом (флажок Place code in separate file выставлен). В результате мы должны получить 2 файла: component.ascx и component.ascx.cs, со следующим содержимым:

    CopyC#
    <%@ Control Language="C#" AutoEventWireup="true" CodeFile="component.ascx.cs" Inherits="bitrix_components_tutorial_sample.list_component" %>
    CopyC#
    using System;
using System.Data;
using System.Configuration;
using System.Collections;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;

public partial class bitrix_components_tutorial_sample.list_component : System.Web.UI.UserControl
{
    protected void Page_Load(object sender, EventArgs e)
    {

    }
}

  3. Созданный пользовательский элемент управления еще не является компонентом, потому что не унаследован от класса BXComponent. Кроме того, данный файл просто не скомпилируется компилятором, т.к. сгенерированное имя класса bitrix_components_tutorial_sample.list_component недопустимо. Поэтому дадим классу компонента правильное имя и сделаем для него базовым классом BXComponent вместо UserControl.

    Для однообразности нотации и уменьшения вероятности совпадения имени класса компонента с именем какого-нибудь уже существующего класса рекомендуется применять следующие правила именования:

    • Все слова в названиях пространств имен и именах классов начинаются с заглавной буквы и пишутся слитно, без знаков препинания. Например, для компонента tutorial:sample.list название пространства имен будет Tutorial, а имя класса будет SampleListComponent (см. ниже).

    • Имя класса компонента заканчивается на слово Component. Т.е. для компонента tutorial:sample.list имя класса будет SampleListComponent

    • Пространство имен компонента должно соответствовать пространству имен его класса. Т.е. если компонент называется tutorial:sample.list, то его класс SampleListComponent будет располагаться в пространстве имен Tutorial.

    В результате содержимое файла component.ascx.cs должно иметь следующий вид:

    CopyC#
    using System;
using System.Collections;
using System.Configuration;
using System.Data;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.HtmlControls;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;

using Bitrix.UI;

namespace Tutorial
{
    public partial class SampleListComponent : BXComponent
    {
        protected void Page_Load(object sender, EventArgs e)
        {

        }
    }
}

    Соответствующим образом поправим имя родительского класса в файле component.ascx. Должно получиться следующее:

    CopyC#
    <%@ Control Language="C#" AutoEventWireup="true" CodeFile="component.ascx.cs" Inherits="Tutorial.SampleListComponent" %>

  4. Обработчик события Load компонента (метод Page_Load или перегрузка метода OnLoad(EventArgs)) - это то место, где компонент может выполнить какую-нибудь полезную работу и подключить свой шаблон. На этом этапе компоненту уже доступны значения параметров компонента, но еще не произошла обработка событий различных элементов управления.

    Дополним наш компонент выборкой списка элементов инфоблока и сделаем в нем публичное свойство через которое мы сможем обратиться к выборке из шаблона компонента. После выборки подключим к компоненту шаблон при помощи метода IncludeComponentTemplate()()()().

    CopyC#
    using System;
using System.Collections;
using System.Configuration;
using System.Data;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.HtmlControls;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;

using Bitrix.DataLayer;
using Bitrix.IBlock;
using Bitrix.UI;

namespace Tutorial
{
    public partial class SampleListComponent : BXComponent
    {
        const int IBlockId = 21;
        BXIBlockElementCollection elements;

        public BXIBlockElementCollection Elements
        {
            get
            {
                return elements;
            }
        }

        protected void Page_Load(object sender, EventArgs e)
        {
            elements = BXIBlockElement.GetList(
                new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, IBlockId)),
                new BXOrderBy(new BXOrderByPair(BXIBlockElement.Fields.CreateDate, BXOrderByDirection.Desc))
            );

            IncludeComponentTemplate();
        }
    }
}

  5. Для того чтобы шаблон компонента мог получить доступ к свойствам компонента, шаблон должен знать к какому классу принадлежит обслуживающий его компонент. Для этой цели в файле, где мы описали класс компонента, опишем еще и базовый класс для всех шаблонов этого компонента. Класс шаблона будет унаследован от обобщенного класса BXComponentTemplate<(Of <(<'T>)>)>, в котором мы явно укажем класс родительского компонента.

    Базовый класс шаблона назовем по тем же правилам, что и класс компонента, только имя класса будет заканчивается на слово Template. Т.е. создадим класс SampleListTemplate и разместим его в пространстве имен Tutorial. В результате должно получиться следующее:

    CopyC#
    using System;
using System.Collections;
using System.Configuration;
using System.Data;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.HtmlControls;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;

using Bitrix.DataLayer;
using Bitrix.IBlock;
using Bitrix.UI;

namespace Tutorial
{
    public partial class SampleListComponent : BXComponent
    {
        const int IBlockId = 21;
        BXIBlockElementCollection elements;

        public BXIBlockElementCollection Elements
        {
            get
            {
                return elements;
            }
        }

        protected void Page_Load(object sender, EventArgs e)
        {
            elements = BXIBlockElement.GetList(
                new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, IBlockId)),
                new BXOrderBy(new BXOrderByPair(BXIBlockElement.Fields.CreateDate, BXOrderByDirection.Desc))
            );

            IncludeComponentTemplate();
        }
    }

    public class SampleListTemplate : BXComponentTemplate<SampleListComponent>
    {

    }
}

В результате мы получили простой компонент, который делает выборку элементов из определенного инфоблока. Компонент пока недоступен в визуальном редакторе (см. Настройка описания компонента), но уже может быть размещен на странице при помощи вставки <bx:IncludeComponent runat="server" ID="IncludeComponent1" ComponentName="tutorial:sample.list" />. Компонент ничего не выводит, потому что задачей вывода HTML занимается шаблон компонента, о чем рассказывается в разделе "Создание шаблона компонента"


Создание шаблона компонента
Send Feedback

В то время как компонент производит выборку данных и реагирует на действия пользователей, формированием HTML и отправкой компоненту оповещений о пользовательских действиях занимается шаблон компонента. В разделе "Создание простого компонента" было рассмотрено создание компонента tutorial:sample.list. В этом разделе описывается процесс создания шаблона по умолчанию для компонента tutorial:sample.list.

Создание шаблона компонента

  1. Шаблон компонента может располагаться в следующих папках, перечисленных в порядке убывания приоритета:

    1. В шаблоне текущего сайта. Например, в папке ~/bitrix/templates/имя_шаблона_сайта/components/пространство_имен_компонента/имя_компонента/имя_шаблона/

      В шаблоне сайта по умолчанию. Например, в папке ~/bitrix/templates/.default/components/пространство_имен_компонента/имя_компонента/имя_шаблона/

      В папке компонента - т.н. системный шаблон. Например, в папке ~/bitrix/components/пространство_имен_компонента/имя_компонента/templates/имя_шаблона/

    Если компонент расположен в составе комплексного компонента, то шаблон компонента сперва ищется в составе темы шаблона текущего комплексного компонента. Например, в папке путь_к_шаблону_комплексного_компонента/пространство_имен_компонента/имя_компонента/имя_шаблона/.

    Если для компонента не удалось найти текущий шаблон, то во всех выше перечисленных местах ищется шаблон компонента по умолчанию (с именем .default).

  2. Создадим папку для системного шаблона по умолчанию (~/bitrix/components/tutorial/sample.list/templates/.default/), а в ней пользовательский элемент управления (Web User Control) c именем template.ascx без CodeBehind-файла (флажок Place code in separate file снят). В результате мы должны получить файл со следующим содержимым:

    CopyC#
    <%@ Control Language="C#" ClassName="template" %>

<script runat="server">

</script>

  3. Для того чтобы в шаблоне компонента получить доступ к свойствам компонента необходимо в ASCX-файле шаблона сделать ссылку на файл с родительским компонентом Для этого перед директивой <%@ Control %> вставим следующую директиву:

    CopyC#
    <%@ Reference VirtualPath="~/bitrix/components/tutorial/sample.list/component.ascx" %>
<%@ Control Language="C#" ClassName="template" %>

<script runat="server">

</script>

    Обязательно в атрибуте VirtualPath указываем полный виртуальный путь к файлу компонента, чтобы при копировании шаблона компонента в другую папку ссылка оставалась действительной.

  4. После указания ссылки на файл родительского компонента нам стали доступны все классы, объявленные в нем. Поэтому мы можем смело наследовать наш шаблон от базового класса, который был объявлен в разделе "Создание простого компонента". Тогда мы сможем обращаться к свойствам компонента через свойство Component. Для этого изменим директиву <%@ Control %> соответствующим образом:

    CopyC#
    <%@ Reference VirtualPath="~/bitrix/components/tutorial/sample.list/component.ascx" %>
<%@ Control Language="C#" Inherits="Tutorial.SampleListTemplate" %>

<script runat="server">

</script>

  5. Теперь мы можем обратиться к свойству Elements нашего компонента посредством конструкции Component.Elements, получить выборку выборке элементов инфоблока и вывести ее в HTML разметке. Для этого воспользуемся стандартными средствами разметки ASPX. Выведем заголовки и анонсы для выбранных элементов следующим образом:

    CopyC#
    <%@ Reference VirtualPath="~/bitrix/components/tutorial/sample.list/component.ascx" %>
<%@ Control Language="C#" Inherits="Tutorial.SampleListTemplate" %>
<%@ Import Namespace="Bitrix.IBlock" %>

<% foreach (BXIBlockElement element in Component.Elements) { %>
    <div>
        <h1><%= element.Name %></h1>
        <p><%= element.PreviewText %></p>
    </div>
<% } %>

В результате мы получили системный шаблон по умолчанию для компонента tutorial:sample.list, который формирует HTML представление для выборки элементов инфоблока. Разместив компонент в теле ASPX страницы при помощи вставки <bx:IncludeComponent runat="server" ID="IncludeComponent1" ComponentName="tutorial:sample.list" Template=".default" />, мы можем пронаблюдать работу компонента и шаблона.


Настройка описания компонента
Send Feedback

В разделе "Создание простого компонента" было рассмотрено создание компонента tutorial:sample.list. Однако созданный компонент производит строго определенную выборку данных, что затрудняет повторное использование компонента. Кроме того компонент недоступен в визуальном редакторе. В этом разделе описывается процесс задания параметров и базового описания для компонента tutorial:sample.list.

Настройка описания компонента

  1. Описание компонента задается при помощи перегрузки 2-х методов: PreLoadComponentDefinition()()()() и LoadComponentDefinition()()()().

    Метод PreLoadComponentDefinition()()()() вызывается каждый раз в жизненном цикле компонента и должен содержать базовые описания, необходимые для работы компонента, такие как объявления параметров компонента и их значения по умолчанию. Компонент не гарантирует, что значения параметров будут доступны при вызове этого метода.

    Метод LoadComponentDefinition()()()() вызывается только в случаях, когда необходимо более детальное описание компонента, например, для редактирования параметров компонента через интерфейс или настройки компонента в визуальном редакторе. Этот метод может содержать нагруженные операции, такие как запросы к базе данных. На момент вызова метода уже доступны значения параметров компонента, поэтому компонент может поменять или дополнить свое описание основываясь на предоставленных значениях.

    В рамках этого раздела рассматривается только использование метода PreLoadComponentDefinition()()()(). Пример перегрузки метода LoadComponentDefinition()()()() рассмотрен в разделе "Настройка расширенного описания компонента".

  2. Параметр компонента - это некоторое именованное строковое значение, которое мы можем задать при размещении компонента на странице и затем воспользоваться им в ходе работы компонента. Несмотря на то, что значение параметра компонента задается в разметке страницы строкой, в коде компонента оно может быть приведено к числу, к булеву значению, к списку значений и т.д.

    Добавим к нашему компоненту 2 параметра - идентификатор инфоблока, из которого производится выборка, и количество элементов в выборке. Назовем их соответственно IBlockId и Count. Описания параметров задаются при помощи свойства компонента ParamsDefinition. Наши параметры будут задаваться при помощи текстового поля и иметь понятное название и значение по-умолчанию. Оба параметра относятся к группе "Основные". Определим метод PreLoadComponentDefinition()()()() следующим образом:

    CopyC#
    protected override void PreLoadComponentDefinition()
{
    ParamsDefinition["IBlockId"] = new BXParamText("Идентификатор инфоблока", "0", BXCategory.Main);
    ParamsDefinition["Count"] = new BXParamText("Количество выводимых элементов", "10", BXCategory.Main);
}

  3. Модифицируем код компонента таким образом, чтобы он производил выборку на основе заданных значений параметров компонента. Доступ к значениям параметров осуществляется посредством свойства Parameters. В результате метод Page_Load изменится следующим образом:

    CopyC#
    protected void Page_Load(object sender, EventArgs e)
{
    elements = BXIBlockElement.GetList(
        new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, Parameters.GetInt("IBlockId"))),
        new BXOrderBy(new BXOrderByPair(BXIBlockElement.Fields.CreateDate, BXOrderByDirection.Desc)),
        null,
        new BXQueryParams(new BXPagingOptions(0, Parameters.GetInt("Count")))
    );

    IncludeComponentTemplate();
}

    Теперь, если мы разместим компонент на странице вставкой <bx:IncludeComponent runat="server" ID="IncludeComponent1" ComponentName="tutorial:sample.list" Template=".default" IBlockId="21" />, мы увидим вывод первых 10 элементов из инфоблока с идентификатором 21. Значение параметра IBlockId было задан явно, а для параметра Count было взято значение по умолчанию.

    Параметры размещенного компонента можно настроить через визуальный редактор или через режим "Разработка" в публичной части сайта.

  4. Чтобы сделать работу с параметрами компонента еще более комфортной, а код компонента более надежным, рекомендуется валидировать параметры компонента перед их использованием. Хорошим стилем является проверка параметров сразу перед их попаданием в основной код. Это можно сделать либо объявив отдельный метод с проверкой значений параметров и вызывать его в самом начале метода Page_Load, либо объявить для каждого параметра свойство и проводить валидацию при обращении к свойству.

    Объявим для параметров IBlockId и Count соответствующие свойства и удостоверимся, что IBlockId всегда не отрицательный, а Count не меньше 5. Подправим код компонента соответствующим образом:

    CopyC#
    public int IBlockId
{
    get
    {
        return Math.Max(0, Parameters.GetInt("IBlockId"));
    }
}
public int Count
{
    get
    {
        return Math.Max(5, Parameters.GetInt("Count"));
    }
}

protected void Page_Load(object sender, EventArgs e)
{
    elements = BXIBlockElement.GetList(
        new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, IBlockId)),
        new BXOrderBy(new BXOrderByPair(BXIBlockElement.Fields.CreateDate, BXOrderByDirection.Desc)),
        null,
        new BXQueryParams(new BXPagingOptions(0, Count))
    );

    IncludeComponentTemplate();
}

    Теперь параметры в выборке будут иметь гарантированно валидные значения, что упростит понимание кода в более сложных компонентах.

  5. Осталось настроить некоторые параметры для корректного отображения в редакторах, а именно, отображаемое имя компонента, краткое описание, значок и секцию в визуальном редакторе. Для этого служат соответственно свойства Title, Description, Icon и Group.

    Свойство Icon может быть задано как при помощи виртуального пути вида ~/bitrix/components/tutorial/sample.list/component.gif, так и в виде пути, относительно папки с компонентом, например component.gif. Стандартный размер значка для компонента - 32 x 16 пикселей.

    Чтобы компонент появился в списке компонентов в визуальном редакторе, он должен быть размещен в какой-либо секции. Иерархия секций компонента должна обязательно составлять ровно 2 уровня: главная секция верхнего уровня и ее подсекция. Некоторый секции верхнего уровня заранее предопределены и доступны через свойства класса BXComponentGroup. Секция уникально определяется символьным идентификатором. Для того чтобы 2 компонента оказались в одной секции необходимо, чтобы эти секции имели одинаковый идентификатор.

    Назовем наш компонент "Список элементов", зададим ему описание, произвольный значок и поместим его в секцию Обучение->Контент. Изменим соответствующим образом метод PreLoadComponentDefinition()()()():

    CopyC#
    protected override void PreLoadComponentDefinition()
{
    Title = "Список элементов";
    Description = "Демонстрационный компонент, который выводит список элементов инфоблока.";
    Icon = "component.gif";
    Group = new BXComponentGroup("tutorial-content", "Контент", 100, new BXComponentGroup("tutorial", "Обучение", 1000, null));

    ParamsDefinition["IBlockId"] = new BXParamText("Идентификатор инфоблока", "0", BXCategory.Main);
    ParamsDefinition["Count"] = new BXParamText("Количество выводимых элементов", "10", BXCategory.Main);
}

  6. Для того, чтобы компонент появился в визуальном редакторе, при входе в него необходимо в меню кликнуть на пункте "Обновить закэшированные данные".

В результате у компонента tutorial:sample.list появилось 2 параметра, которые можно настроить при помощи визуального редактора или через публичную часть в режиме "Разработка". Кроме того, компонент появился в списке компонентов визуального редактора с заданным нами именем и значком. Полный код файла component.ascx.cs приведен ниже:

CopyC#
using System;
using System.Collections;
using System.Configuration;
using System.Data;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.HtmlControls;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;

using Bitrix.DataLayer;
using Bitrix.IBlock;
using Bitrix.UI;
using Bitrix.Components;

namespace Tutorial
{
    public partial class SampleListComponent : BXComponent
    {
        BXIBlockElementCollection elements;

        public int IBlockId
        {
            get
            {
                return Math.Max(0, Parameters.GetInt("IBlockId"));
            }
        }
        public int Count
        {
            get
            {
                return Math.Max(5, Parameters.GetInt("Count"));
            }
        }
        public BXIBlockElementCollection Elements
        {
            get
            {
                return elements;
            }
        }

        protected void Page_Load(object sender, EventArgs e)
        {
            elements = BXIBlockElement.GetList(
                new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, IBlockId)),
                new BXOrderBy(new BXOrderByPair(BXIBlockElement.Fields.CreateDate, BXOrderByDirection.Desc)),
                null,
                new BXQueryParams(new BXPagingOptions(0, Count))
            );

            IncludeComponentTemplate();
        }
        protected override void PreLoadComponentDefinition()
        {
            Title = "Список элементов";
            Description = "Демонстрационный компонент, который выводит список элементов инфоблока.";
            Icon = "component.gif";
            Group = new BXComponentGroup("tutorial-content", "Контент", 100, new BXComponentGroup("tutorial", "Обучение", 1000, null));

            ParamsDefinition["IBlockId"] = new BXParamText("Идентификатор инфоблока", "0", BXCategory.Main);
            ParamsDefinition["Count"] = new BXParamText("Количество выводимых элементов", "10", BXCategory.Main);
        }
    }

    public class SampleListTemplate : BXComponentTemplate<SampleListComponent>
    {

    }
}


Настройка расширенного описания компонента
Send Feedback

В разделе "Настройка описания компонента" было рассмотрено задание минимально необходимого описания для компонента tutorial:sample.list. В этом разделе будет рассмотрено задание расширенного описания компонента, которое позволит более удобно настраивать компонент при помощи редакторов.

Настройка расширенного описания компонента

  1. Для того чтобы компонент было удобно настраивать, мы будем задавать параметр IBlockId при помощи раскрывающегося списка. Для этого подправим метод PreLoadComponentDefinition()()()() соответствующим образом, заменив тип параметра с BXParamText на BXParamSingleSelection:

    CopyC#
    protected override void PreLoadComponentDefinition()
{
    Title = "Список элементов";
    Description = "Демонстрационный компонент, который выводит список элементов инфоблока.";
    Icon = "component.gif";
    Group = new BXComponentGroup("tutorial-content", "Контент", 100, new BXComponentGroup("tutorial", "Обучение", 1000, null));

    ParamsDefinition["IBlockId"] = new BXParamSingleSelection("Идентификатор инфоблока", "0", BXCategory.Main);
    ParamsDefinition["Count"] = new BXParamText("Количество выводимых элементов", "10", BXCategory.Main);
}

  2. Необходимо теперь заполнить описание параметра предопределенными значениями. Это нагруженная операция, которая требует запроса к базе данных и должна выполняться только когда параметры компонента редактируются при помощи редактора свойств. Поэтому предопределенные значения должны быть заданы в методе LoadComponentDefinition()()()(). Список предопределенных значений задается посредством свойства Values класса BXParam. Стоит отметить, что свойство Values доступно как для чтения, так и для записи и может иметь значение null.

    Перегрузим метод LoadComponentDefinition()()()() следующим образом:

    CopyC#
    protected override void LoadComponentDefinition()
{
    List<BXParamValue> iblockValues = new List<BXParamValue>();
    iblockValues.Add(new BXParamValue("- не задан -", "0"));
    foreach (BXIBlock iblock in BXIBlock.GetList(null, null, null, null, BXTextEncoder.EmptyTextEncoder))
        iblockValues.Add(new BXParamValue(iblock.Name, iblock.Id.ToString()));
    ParamsDefinition["IBlockId"].Values = iblockValues;
}

    Теперь, открыв параметры компонента в редакторе, можно настроить идентификатор инфоблока при помощи раскрывающегося списка.

  3. Дополним компонент еще одним параметром, который не будет явно участвовать в выборке, но облегчит настройку компонента в редакторе. Это будет IBlockTypeId - идентификатор типа инфоблока, при помощи которого мы будем фильтровать список предопределенных значений идентификаторов самих инфоблоков. Объявим параметр аналогично параметру IBlockId:

    CopyC#
    protected override void PreLoadComponentDefinition()
{
    Title = "Список элементов";
    Description = "Демонстрационный компонент, который выводит список элементов инфоблока.";
    Icon = "component.gif";
    Group = new BXComponentGroup("tutorial-content", "Контент", 100, new BXComponentGroup("tutorial", "Обучение", 1000, null));

    ParamsDefinition["IBlockTypeId"] = new BXParamSingleSelection("Тип инфоблока", "0", BXCategory.Main);
    ParamsDefinition["IBlockId"] = new BXParamSingleSelection("Идентификатор инфоблока", "0", BXCategory.Main);
    ParamsDefinition["Count"] = new BXParamText("Количество выводимых элементов", "10", BXCategory.Main);
}

protected override void LoadComponentDefinition()
{
    List<BXParamValue> iblockTypeValues = new List<BXParamValue>();
    iblockTypeValues.Add(new BXParamValue("- не задан -", "0"));
    foreach (BXIBlockType iblockType in BXIBlockType.GetList(null, null, null, null, BXTextEncoder.EmptyTextEncoder))
        iblockTypeValues.Add(new BXParamValue(iblockType.Translations[BXLoc.CurrentLocale].Name, iblockType.Id.ToString()));
    ParamsDefinition["IBlockTypeId"].Values = iblockTypeValues;

    List<BXParamValue> iblockValues = new List<BXParamValue>();
    iblockValues.Add(new BXParamValue("- не задан -", "0"));
    foreach (BXIBlock iblock in BXIBlock.GetList(null, null, null, null, BXTextEncoder.EmptyTextEncoder))
        iblockValues.Add(new BXParamValue(iblock.Name, iblock.Id.ToString()));
    ParamsDefinition["IBlockId"].Values = iblockValues;
}

  4. Теперь мы можем изменить запрос по выборке предопределенных значений для идентификаторов инфоблока, основываясь на значении параметра IBlockTypeId. На момент вызова метода LoadComponentDefinition()()()() компоненту уже доступны значения параметров, пожтому мы можем смело их использовать. Отметим также, что при изменении значения параметра IBlockTypeId в редакторе необходимо заново перезадать описания параметров (в нашем случае должен измениться список предопределенных значений для параметра IBlockId). Сделать это можно при помощи свойства RefreshOnDirty класса BXParam. В результате метод LoadComponentDefinition()()()() будет выглядить следующим образом:

    CopyC#
    protected override void LoadComponentDefinition()
{
    List<BXParamValue> iblockTypeValues = new List<BXParamValue>();
    iblockTypeValues.Add(new BXParamValue("- не задан -", "0"));
    foreach (BXIBlockType iblockType in BXIBlockType.GetList(null, null, null, null, BXTextEncoder.EmptyTextEncoder))
        iblockTypeValues.Add(new BXParamValue(iblockType.Translations[BXLoc.CurrentLocale].Name, iblockType.Id.ToString()));
    ParamsDefinition["IBlockTypeId"].Values = iblockTypeValues;

    ParamsDefinition["IBlockTypeId"].RefreshOnDirty = true;

    int iblockTypeId = Math.Max(0, Parameters.GetInt("IBlockTypeId"));
    BXFilter filter =
        iblockTypeId > 0
        ? new BXFilter(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId))
        : null;

    List<BXParamValue> iblockValues = new List<BXParamValue>();
    iblockValues.Add(new BXParamValue("- не задан -", "0"));
    foreach (BXIBlock iblock in BXIBlock.GetList(filter, null, null, null, BXTextEncoder.EmptyTextEncoder))
        iblockValues.Add(new BXParamValue(iblock.Name, iblock.Id.ToString()));
    ParamsDefinition["IBlockId"].Values = iblockValues;
}

В результате параметры компонента tutorial:sample.list теперь настраиваются посредством раскрывающихся списков, которые формируются на основе уже заданных значений параметров компонента. Полный код файла component.ascx.cs приведен ниже:

CopyC#
using System;
using System.Collections;
using System.Collections.Generic;
using System.Configuration;
using System.Data;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.HtmlControls;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;

using Bitrix.Components;
using Bitrix.DataLayer;
using Bitrix.IBlock;
using Bitrix.Services;
using Bitrix.Services.Text;
using Bitrix.UI;

namespace Tutorial
{
    public partial class SampleListComponent : BXComponent
    {
        BXIBlockElementCollection elements;

        public int IBlockId
        {
            get
            {
                return Math.Max(0, Parameters.GetInt("IBlockId"));
            }
        }
        public int Count
        {
            get
            {
                return Math.Max(5, Parameters.GetInt("Count"));
            }
        }
        public BXIBlockElementCollection Elements
        {
            get
            {
                return elements;
            }
        }

        protected void Page_Load(object sender, EventArgs e)
        {
            elements = BXIBlockElement.GetList(
                new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, IBlockId)),
                new BXOrderBy(new BXOrderByPair(BXIBlockElement.Fields.CreateDate, BXOrderByDirection.Desc)),
                null,
                new BXQueryParams(new BXPagingOptions(0, Count))
            );

            IncludeComponentTemplate();
        }
        protected override void PreLoadComponentDefinition()
        {
            Title = "Список элементов";
            Description = "Демонстрационный компонент, который выводит список элементов инфоблока.";
            Icon = "component.gif";
            Group = new BXComponentGroup("tutorial-content", "Контент", 100, new BXComponentGroup("tutorial", "Обучение", 1000, null));

            ParamsDefinition["IBlockTypeId"] = new BXParamSingleSelection("Тип инфоблока", "0", BXCategory.Main);
            ParamsDefinition["IBlockId"] = new BXParamSingleSelection("Идентификатор инфоблока", "0", BXCategory.Main);
            ParamsDefinition["Count"] = new BXParamText("Количество выводимых элементов", "10", BXCategory.Main);
        }
        protected override void LoadComponentDefinition()
        {
            List<BXParamValue> iblockTypeValues = new List<BXParamValue>();
            iblockTypeValues.Add(new BXParamValue("- не задан -", "0"));
            foreach (BXIBlockType iblockType in BXIBlockType.GetList(null, null, null, null, BXTextEncoder.EmptyTextEncoder))
                iblockTypeValues.Add(new BXParamValue(iblockType.Translations[BXLoc.CurrentLocale].Name, iblockType.Id.ToString()));
            ParamsDefinition["IBlockTypeId"].Values = iblockTypeValues;

            ParamsDefinition["IBlockTypeId"].RefreshOnDirty = true;

            int iblockTypeId = Math.Max(0, Parameters.GetInt("IBlockTypeId"));
            BXFilter filter =
                iblockTypeId > 0
                ? new BXFilter(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId))
                : null;

            List<BXParamValue> iblockValues = new List<BXParamValue>();
            iblockValues.Add(new BXParamValue("- не задан -", "0"));
            foreach (BXIBlock iblock in BXIBlock.GetList(filter, null, null, null, BXTextEncoder.EmptyTextEncoder))
                iblockValues.Add(new BXParamValue(iblock.Name, iblock.Id.ToString()));
            ParamsDefinition["IBlockId"].Values = iblockValues;
        }
    }

    public class SampleListTemplate : BXComponentTemplate<SampleListComponent>
    {

    }
}


Добавление стилей и скриптов к шаблону

Добавление стилей и скриптов к шаблону
Send Feedback

В разделе "Создание шаблона компонента" было рассмотрено создание шаблона .default для компонента tutorial:sample.list. Шаблон компонента может отображаться на любой странице в любом ее месте, при этом шаблон компонента может содержать значительное количество стилей и javascript. Для того чтобы отделить стили и скрипты от верстки шаблона, система компонентов содержит механизм для подключения внешних CSS и JS файлов.

Добавление стилей и скриптов к шаблону компонента

  1. Шаблон компонента автоматически подключает к странице файл style.css, расположенный в папке шаблона, если он существует. Файл style.css гарантированно подключается перед файлами стилей шаблона сайта. Поэтому стили компонента могут быть, при необходимости, перекрыты стилями сайта. В нашем случае создадим файл ~/bitrix/components/tutorial/sample.list/templates/.default/style.css со следующим содержимым:

    CopyXML
    div.tutorial-sample-list
{
    border: none;
    margin: 10px;
}

div.tutorial-sample-list h1
{
    font-family: sans-serif;
    font-size: larger;
    font-weight: bold;
    cursor: pointer;
}

div.tutorial-sample-list h1.off
{
    color: Gray;
}

div.tutorial-sample-list p
{
    font-family: serif;
    font-size: medium;
}

  2. Шаблон компонента автоматически подключает к странице файл script.js, расположенный в папке шаблона, если он существует. В нашем случае создадим файл ~/bitrix/components/tutorial/sample.list/templates/.default/script.js со следующим содержимым:

    CopyJScript.NET
    if (typeof(Tutorial) == 'undefined')
    var Tutorial = {};

if (typeof(Tutorial.SampleList) == 'undefined')
    Tutorial.SampleList = {};

Tutorial.SampleList.Toggle = function(title)
{
    for(text = title.nextSibling; text != null; text = text.nextSibling)
        if (text.tagName == 'P')
        {
            if (text.style.display == 'none')
            {
                text.style.display = '';
                title.className = '';
            }
            else
            {
                text.style.display = 'none';
                title.className = 'off';
            }
            break;
        }
}

  3. Соответствующим образом изменим файл template.ascx:

    CopyC#
    <%@ Reference VirtualPath="~/bitrix/components/tutorial/sample.list/component.ascx" %>
<%@ Control Language="C#" Inherits="Tutorial.SampleListTemplate" %>
<%@ Import Namespace="Bitrix.IBlock" %>
<% foreach (BXIBlockElement element in Component.Elements) { %>
    <div class="tutorial-sample-list" >
        <h1 onclick="Tutorial.SampleList.Toggle(this)"><%= element.Name %></h1>
        <p><%= element.PreviewText %></p>
    </div>
<% } %>

  4. Теперь если мы разместим компонент tutorial:sample.list на какой-нибудь странице сайта и подключим к нему шаблон .default, мы увидим, что шаблон оформлен в соответствии с описанными стилями, а при клике на заголовке элемента инфоблока срабатывают заданные нами скрипты.

    Если мы откроем исходный HTML код страницы, мы увидим строку вида <link rel="stylesheet" type="text/css" href="/WebSite/bitrix/components/tutorial/sample.list/templates/.default/style.css?t=633619359309044114" /> в заголовке страницы и строку вида <script src="/WebSite/bitrix/components/tutorial/sample.list/templates/.default/script.js?t=633619366197584114" type="text/javascript"></script> в теле страницы.

В результате мы получили шаблон компонента tutorial:sample.list, который подключает для своего отображения внешние стили и скрипты.


Добавление кеширования

Добавление кеширования
Send Feedback

В предыдущих разделах было рассмотрено создание компонента tutorial:sample.list и шаблона по умолчанию для него. Для того чтобы сформировать список элементов инфоблока, компоненту необходимо совершить запрос к базе данных, что является затратной операцией. Для того чтобы увеличить производительность в компонентах реализован режим кеширования.

Компоненты поддерживают 2 механизма кеширования: кеширование HTML вывода и кеширование данных. Кеширование данных по умолчанию поддерживает базовые типы, для поддержки нестандартных типов необходимо реализовать в них интерфейс IBXSerializable и публичный конструктор с сигнатурой public (System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StreamingContext context). Поддержка нестандартных типов данных в этом разделе не рассматривается.

Добавление поддержки кеширования в компонент

  1. Механизм кеширования компонента управляется двумя предопределенными параметрами: CacheMode и CacheDuration.

    Параметр CacheMode может принимать следующие значения:

    • None - кеширование компонента выключено;

    • Auto - кеширование компонента определяется глобальной настройкой;

    • Custom - кеширование компонента включено.

    Длительность хранения кеша в секундах определяется параметром CacheDuration.

    Даже если описания этих параметров не заданы, они все равно могут быть заданы в теле страницы напрямую. Для параметров кеширования в классе компонента есть свойства-обертки: CacheMode и CacheDuration.

    Добавить описания параметров кеширования можно при помощи предопределенного статического свойства Cache()()()() класса BXParametersDefinition()()()():

    CopyC#
    protected override void PreLoadComponentDefinition()
{
    Title = "Список элементов";
    Description = "Демонстрационный компонент, который выводит список элементов инфоблока.";
    Icon = "component.gif";
    Group = new BXComponentGroup("tutorial-content", "Контент", 100, new BXComponentGroup("tutorial", "Обучение", 1000, null));

    ParamsDefinition.Add(BXParametersDefinition.Cache);

    ParamsDefinition["IBlockTypeId"] = new BXParamSingleSelection("Тип инфоблока", "0", BXCategory.Main);
    ParamsDefinition["IBlockId"] = new BXParamSingleSelection("Идентификатор инфоблока", "0", BXCategory.Main);
    ParamsDefinition["Count"] = new BXParamText("Количество выводимых элементов", "10", BXCategory.Main);
}

    Теперь можно выставить параметры кеширования при помощи редактора параметров компонента.

  2. Состояние, закеширован ли компонент или нет определяется при помощи метода IsCached(array<Object>[]()[][]). Ключ, по которому закеширован компонента определяется исходя из значений параметров компонента и дополнительных параметров, перечисленных в вызове метода IsCached(array<Object>[]()[][]). Добавим проверку на кеширование в код компонента:

    CopyC#
    protected void Page_Load(object sender, EventArgs e)
{
    if (!IsCached())
    {
        elements = BXIBlockElement.GetList(
            new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, IBlockId)),
            new BXOrderBy(new BXOrderByPair(BXIBlockElement.Fields.CreateDate, BXOrderByDirection.Desc)),
            null,
            new BXQueryParams(new BXPagingOptions(0, Count))
        );
        IncludeComponentTemplate();
    }
}

    Стоит обратить внимание, что подключение шаблона компонента происходит только когда компонент незакеширован. В противном случае HTML вывод шаблона будет взят из кеша и реальный шаблон подключаться не будет. Если же вынести вызов метода IncludeComponentTemplate()()()() за пределы условного оператора, то шаблон компонента будет подключаться всегда и, соответственно, HTML кеширование производиться не будет, а компонент должен предоставлять шаблону данные из кеша данных.

    Даже когда шаблон компонента закеширован и, соответственно, не подключается, файлы стилей и скриптов шаблона компонента подключаются к странице в любом случае.

  3. Бывает необходимость кешировать данные, которые извлекаются при помощи нагруженных операций, например, при помощи запроса к БД, но явным образом не участвуют в формировании HTML. Такое бывает, например, когда компонент выставляет заголовок страницы. В таком случае необходимо использовать кеширование данных посредством свойства ComponentCache. Все данные хранящиеся в ComponentCache должны быть примитивными, либо поддерживать интерфейс IBXSerializable, о чем было сказано выше. Изменим код компонента так, чтобы он задавал заголовок странице и кешировал его:

    CopyC#
    protected void Page_Load(object sender, EventArgs e)
{
    if (!IsCached())
    {
        elements = BXIBlockElement.GetList(
            new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, IBlockId)),
            new BXOrderBy(new BXOrderByPair(BXIBlockElement.Fields.CreateDate, BXOrderByDirection.Desc)),
            null,
            new BXQueryParams(new BXPagingOptions(0, Count))
        );
        ComponentCache["ElementsCount"] = elements.Count;
        BXUser user = ((BXIdentity)BXPrincipal.Current.Identity).User;
        ComponentCache["User"] = user.LastName + " " + user.FirstName;

        IncludeComponentTemplate();
    }

    Page.Title = string.Format("Выбрано элементов: {0} ({1})", ComponentCache["ElementsCount"], ComponentCache["User"]);
}

  4. В текущем состоянии компонент кеширует имя пользователя, под управлением которого этот кеш был создан. Однако некоторые выборки компонента могут различаться в зависимости от прав, которыми обладает тот или иной пользователь. Для каждой такой выборки необходимо создавать свой кеш. Задать особые параметры ключа кеширования можно, передавая аргументы в вызов метода IsCached(array<Object>[]()[][]). Добавим в кеш компонента привязку к имени пользователя, модифицировав соответствующим образом вызов IsCached(array<Object>[]()[][]).

    CopyC#
    protected void Page_Load(object sender, EventArgs e)
{
    if (!IsCached(BXPrincipal.Current.Identity.Name))
    {
        elements = BXIBlockElement.GetList(
            new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, IBlockId)),
            new BXOrderBy(new BXOrderByPair(BXIBlockElement.Fields.CreateDate, BXOrderByDirection.Desc)),
            null,
            new BXQueryParams(new BXPagingOptions(0, Count))
        );
        ComponentCache["ElementsCount"] = elements.Count;
        BXUser user = ((BXIdentity)BXPrincipal.Current.Identity).User;
        ComponentCache["User"] = user.LastName + " " + user.FirstName;

        IncludeComponentTemplate();
    }

    Page.Title = string.Format("Выбрано элементов: {0} ({1})", ComponentCache["ElementsCount"], ComponentCache["User"]);
}

В результате мы получили компонент tutorial:sample.list, который кеширует свои данные и HTML вывод в зависимости от имени текущего пользователя. Полный код файла component.ascx.cs приведен ниже:

CopyC#
using System;
using System.Collections;
using System.Collections.Generic;
using System.Configuration;
using System.Data;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.HtmlControls;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;

using Bitrix.Components;
using Bitrix.DataLayer;
using Bitrix.IBlock;
using Bitrix.Services;
using Bitrix.Services.Text;
using Bitrix.UI;
using Bitrix.Security;

namespace Tutorial
{
    public partial class SampleListComponent : BXComponent
    {
        BXIBlockElementCollection elements;

        public int IBlockId
        {
            get
            {
                return Math.Max(0, Parameters.GetInt("IBlockId"));
            }
        }
        public int Count
        {
            get
            {
                return Math.Max(5, Parameters.GetInt("Count"));
            }
        }
        public BXIBlockElementCollection Elements
        {
            get
            {
                return elements;
            }
        }

        protected void Page_Load(object sender, EventArgs e)
        {
            if (!IsCached(BXPrincipal.Current.Identity.Name))
            {
                elements = BXIBlockElement.GetList(
                    new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, IBlockId)),
                    new BXOrderBy(new BXOrderByPair(BXIBlockElement.Fields.CreateDate, BXOrderByDirection.Desc)),
                    null,
                    new BXQueryParams(new BXPagingOptions(0, Count))
                );
                ComponentCache["ElementsCount"] = elements.Count;
                BXUser user = ((BXIdentity)BXPrincipal.Current.Identity).User;
                ComponentCache["User"] = user.LastName + " " + user.FirstName;

                IncludeComponentTemplate();
            }

            Page.Title = string.Format("Выбрано элементов: {0} ({1})", ComponentCache["ElementsCount"], ComponentCache["User"]);
        }
        protected override void PreLoadComponentDefinition()
        {
            Title = "Список элементов";
            Description = "Демонстрационный компонент, который выводит список элементов инфоблока.";
            Icon = "component.gif";
            Group = new BXComponentGroup("tutorial-content", "Контент", 100, new BXComponentGroup("tutorial", "Обучение", 1000, null));

            ParamsDefinition.Add(BXParametersDefinition.Cache);

            ParamsDefinition["IBlockTypeId"] = new BXParamSingleSelection("Тип инфоблока", "0", BXCategory.Main);
            ParamsDefinition["IBlockId"] = new BXParamSingleSelection("Идентификатор инфоблока", "0", BXCategory.Main);
            ParamsDefinition["Count"] = new BXParamText("Количество выводимых элементов", "10", BXCategory.Main);
        }
        protected override void LoadComponentDefinition()
        {
            List<BXParamValue> iblockTypeValues = new List<BXParamValue>();
            iblockTypeValues.Add(new BXParamValue("- не задан -", "0"));
            foreach (BXIBlockType iblockType in BXIBlockType.GetList(null, null, null, null, BXTextEncoder.EmptyTextEncoder))
                iblockTypeValues.Add(new BXParamValue(iblockType.Translations[BXLoc.CurrentLocale].Name, iblockType.Id.ToString()));
            ParamsDefinition["IBlockTypeId"].Values = iblockTypeValues;

            ParamsDefinition["IBlockTypeId"].RefreshOnDirty = true;

            int iblockTypeId = Math.Max(0, Parameters.GetInt("IBlockTypeId"));
            BXFilter filter =
                iblockTypeId > 0
                ? new BXFilter(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId))
                : null;

            List<BXParamValue> iblockValues = new List<BXParamValue>();
            iblockValues.Add(new BXParamValue("- не задан -", "0"));
            foreach (BXIBlock iblock in BXIBlock.GetList(filter, null, null, null, BXTextEncoder.EmptyTextEncoder))
                iblockValues.Add(new BXParamValue(iblock.Name, iblock.Id.ToString()));
            ParamsDefinition["IBlockId"].Values = iblockValues;
        }
    }

    public class SampleListTemplate : BXComponentTemplate<SampleListComponent>
    {

    }
}


Создание модуля

Создание модуля
Send Feedback

В этом разделе будет подробно рассмотрено создание модуля системы на примере модуля "Информация о футбольных матчах"

Постановка задачи

Необходимо создать систему отображения информации о футбольных матчах на сайте. Должена быть обеспечена следующая функциональность:

1. Администратор и редакторы сайта должны иметь возможность добавлять и редактировать информацию о футбольных матчах. Должна быть возможность ограничить права групп пользователей на доступ к матчам. Нужны следующие права:

  • Просмотр матчей в публичной части сайта
  • Редактирование информации о матчах в публичной части сайта
  • Управление информацией о матчах в административной части сайта

2. Пользователи должны иметь возможность просматривать список матчей в виде отсортированной таблицы с постраничной навигацией.

3. Пользователи должны иметь возможность просматривать детальную информацию о матчах, переходя по ссылке "Детальная информация" в списке матчей.

Этапы создания модуля

  • Подготовка к работе над модулем
  • Создание класса модуля
  • Создание сущностей
  • Создание языковых файлов модуля
  • Создание административных страниц модуля
  • Создание компонентов


Подготовка к работе над модулем
Смотри также Send Feedback

В этом документе описана последовательность действий, которые необходимо выполнить перед началом работы над модулем.

Подготовка к работе над модулем

  1. Установим дистрибутив "1C-Битрикс Управление Сайтом ASP.NET", при необходимости настроим виртуальный каталог в IIS на папку дистрибутива.
  2. Для удобства разработки в Visual Studio откроем веб-сайт (виртуальный каталог) в который установлен дистрибутив.
  3. В созданное решение добавим новый проект – Class Library, укажем требуемое имя модуля, в нашем случае MyCompany.FBInfo
  4. Добавим ссылки на сборки Main, Search из директории /Bin установленного дистрибутива в список ссылок созданного проекта.
  5. В папке /bitrix/modules сайта создадим папку для модуля, которая будет содержать все необходимые файлы, назовем ее MyCompany.FbInfo по названию модуля.

  6. В папку MyCompany.FBInfo добавим конфигурационные файлы dependencies.config и module.config следующего вида:

    Dependencies.config:

    CopyXML
    <?xml version="1.0" encoding="utf-8" ?>
<dependencies>
  <module id="Main" version="5.0.2"></module>
  <module id="Security" version="5.0.0"></module>
</dependencies>

    Мы указали две зависимости для модуля MyCompany.FBInfo – от системных модулей Main версии 5.0.2 и Security версии 5.0.0.

    Module.config:

    CopyXML
    <?xml version="1.0" encoding="utf-8" ?>
<module>
    <name>MyCompany.FBInfo</name>
    <version>1.0.0</version>
</module>

    В module.config мы просписали имя и версию модуля.

Примечание:
Для исключения совпадения имен рекомендуется называть сборки модулей {имя компании}.{имя сборки}, папки модулей - {имя компании}.{имя модуля}

Смотри также

Дополнительная информация

Структура файлов модуля


Структура файлов модуля
Send Feedback

В этом документе описана структура файлов типового модуля.

Структура файлов модуля

В общем случае модуль имеет следующую файловую структуру:

Файл/папка | Содержание и назначение
/{папка модуля}/module.config | Содержит базовую информацию о модуле, его версию. По наличию этого файла система определяет наличие модуля.
/{папка модуля}/dependencies.config | Определяет зависимости данного модуля от других модулей, с указанием их версий. Используется при установке и удалении модуля.
/{папка модуля}/assemblies.config | Содержит информацию о сборках, используемых модулем.
/{папка модуля}/options.ascx | Ascx - контрол, представляющий собой страницу настроек модуля в административной части. Доступен в меню административной части, пункт Настройки продукта - Настройки модулей - {Имя модуля}
/{папка модуля}/Install/ | Содержит файлы, необходимые для инсталляции модуля - .NET сборку, SQL - скрипты, aspx и ascx файлы.
/{папка модуля}/Install/db/ | Содержит SQL - скрипты install.sql и uninstall.sql, выполняющиеся при установке и удалении модуля соответственно.
/{папка модуля}/Install/bin/ | Содержит .NET сборку модуля. При установке сборка копируется из этой папки в папку /Bin/ сайта.
/{папка модуля}/Install/system/ | Содержит структуру, аналогичную структуре папки /bitrix/ сайта, включает административные страницы, языковые файлы, контролы и компоненты.


Создание класса модуля
Смотри также Send Feedback

Любой модуль "1С-Битрикс Управление Сайтом ASP.NET" должен содержать класс, производный от BXModule - класс модуля. Он является основой модуля и реализует базовые возможности, такие как работа с событиями, идентификация, доступ к инсталлятору.

Создание класса модуля

Рассмотрим листинг класса FBInfoModule, который содержит базовую инфраструктуру модуля:

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using Bitrix.Modules;
using Bitrix.Services;
using System.Web;
using Bitrix.Configuration;

namespace MyCompany.FBInfo
{
    public class FBInfoModule: BXModule
    {
        public static class FBInfoModuleConfiguration
        {
            internal const string ConstantId = "fbinfo";

            /// <summary>
            /// Код модуля
            /// </summary>
            public static readonly string Id = ConstantId;
            /// <summary>
            /// Имя модуля
            /// </summary>
            public static string Name
            {
                get { return FBInfoModule.GetMessage("Module.Name"); }
            }

            public static string Description
            {
                get { return FBInfoModule.GetMessage("Module.Description"); }
            }

            public static readonly string Path = BXConfigurationUtility.GetModulePath(Id);

        }

        public static new string GetMessage(string key)
        {
            return GetMessage(key, false);
        }

        public static string GetMessage(string key, bool encode)
        {
            if (String.IsNullOrEmpty(key))
                throw new ArgumentNullException("key");

            string message = BXLoc.GetModuleMessage(FBInfoModuleConfiguration.Id, key);
            if (encode)
                message = HttpUtility.HtmlEncode(message);

            return message;
        }

        /// <summary>
        /// операции модуля ( права )
        /// </summary>
        public static class Operations
        {
            /// <summary>
            /// просмотр футбольных матчей в публичной части
            /// </summary>
            public static readonly string PublicView = "FBInfoPublicView";
            /// <summary>
            /// редактирование матча в публичной части
            /// </summary>
            public static readonly string PublicEdit = "FBInfoPublicEdit";
            /// <summary>
            /// управление матчами в административной части
            /// </summary>
            public static readonly string AdminManagement = "FBInfoAdminManagement";
        }

        // Переопределенные члены BXmodule

        public override string ModuleId
        {
            get
            {
                return FBInfoModuleConfiguration.Id;
            }
        }

        public override string Name
        {
            get
            {
                return FBInfoModuleConfiguration.Name;
            }
        }

        public override string Description
        {
            get
            {
                return FBInfoModuleConfiguration.Description;
            }
        }

        public override void ReceiveMessage(BXCommand command)
        {
        }

        public override BXModuleInstaller GetInstaller()
        {
            return new FBInfoModuleInstaller(this);
        }

    }
}

Для удобства хранения конфигурации модуля в нем объявлен вложенный статический класс FBInfoModuleConfiguration , в котором собрано базовое описание модуля. В процессе дальнейшей разработки в этот класс добавляются необходимые глобальные объекты, например константы и словари, содержащие конфигурационные данные. В базовом варианте модуля класс FBInfoModuleConfiguration имеет вид:

CopyC#
public static class FBInfoModuleConfiguration
    {
        internal const string ConstantId = "fbinfo";

        /// <summary>
        /// Код модуля
        /// </summary>
        public static readonly string Id = ConstantId;
        /// <summary>
        /// Имя модуля
        /// </summary>
        public static string Name
        {
            get { return FBInfoModule.GetMessage("Module.Name"); }
        }

        public static string Description
        {
            get { return FBInfoModule.GetMessage("Module.Description"); }
        }

        public static readonly string Path = BXConfigurationUtility.GetModulePath(Id);

    }

где:

  • public static string Name - Имя модуля
  • public static string Description – Описание модуля
  • public static readonly string Path – путь к папке модуля

Интересной и важной частью базового кода модуля является метод ReceiveMessage, определенный в интерфейсе IBXMessageReceiver:

CopyC#
public override void ReceiveMessage(BXCommand command)
{
}

Этот метод будет вызван при обработке модулем какого-либо системного события, в параметре command при вызове метода будет содержаться информация о событии. Обработка событий будет подробно рассмотрена далее в этом руководстве при разработке административных страниц .

Метод GetInstaller служит для получения экземпляра класса инсталлятора модуля, он будет вызван при инсталляции:

CopyC#
public override BXModuleInstaller GetInstaller()
    {
        return new FBInfoModuleInstaller(this);
    }

Смотри также

Дополнительная информация

Создание инсталлятора модуля


Создание инсталлятора модуля

Создание инсталлятора модуля
Send Feedback

Каждый модуль "1С – Битрикс Управление Сайтом ASP.NET" должен содержать класс – инсталлятор, производный от BXModuleInstaller. Методы этого класса будут выполняться в определенной последовательности и предназначены для выполнения действий по установке и удалению модуля – копирования/удаления файлов модуля, компонентов, а также запуска SQL–скриптов модуля и выполнения других необходимых операций.

Создание класса инсталлятора модуля

Добавим в проект файл FBInfoModuleInstaller.cs, содержащий следующий код:

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using Bitrix.Modules;
using Bitrix.Security;
using Bitrix.DataLayer;

namespace MyCompany.FBInfo
{
    public class FBInfoModuleInstaller : BXModuleInstaller
    {
        public FBInfoModuleInstaller(BXModule module)
            : base(module)
        {
        }

        public override void InstallDB()
        {
            string[] operationNames = FBInfoModule.Operations.GetNames();
            BXRoleOperation operation;
            foreach (string operationName in operationNames)
                if (BXRoleOperationManager.GetByName(operationName) == null)
                    operation = BXRoleOperationManager.Create(operationName, FBInfoModule.FBInfoModuleConfiguration.Id);
            base.InstallDB();
        }

        public override void UninstallDB()
        {
            var operations = BXRoleOperationManager.GetList(
                new BXFormFilter(
                    new BXFormFilterItem("ModuleId", FBInfoModule.FBInfoModuleConfiguration.Id, BXSqlFilterOperators.Equal)
                ),
                null
            );

            foreach( var operation in operations )
                BXRoleOperationManager.Delete(operation.OperationId);

            base.UninstallDB();
        }

        public override void InstallData()
        {
            var adminRoleName = "Admin";
            var guestRoleName = "Guest";

            var operations = new Dictionary<string, string[]>(2);
            operations[adminRoleName] = FBInfoModule.Operations.GetNames();
            operations[guestRoleName] = new string[1] { FBInfoModule.Operations.PublicView };

            BXRole role;
            foreach (var oper in operations[adminRoleName])
                if ((role = BXRoleManager.GetByName(adminRoleName)) != null && !role.GetOperations().Exists(x => x.OperationName.Equals(oper,StringComparison.OrdinalIgnoreCase)))
                    BXRoleManager.AddRolesToOperations(new string[] { adminRoleName },new string[] {oper});
        }

    }
}

Методы InstallDB()()()() и UninstallDB()()()() выполняются соответственно при инсталляции и деинсталляции модуля. В них рекумендуется выполнять работу с базой данных системы, например, добавлять или удалять записи в таблицах. В данном случае в InstallDB()()()() мы добавляем необходимые операции (права) нашего модуля, а в InstallDB()()()() мы эти права удаляем.

Метод InstallData()()()() служит для выполнения добавления в базу данных начальной информации. В нем наш модуль привязывает свои операции к определенным ролям, то есть осуществляет выдачу ролям соответствующих прав.


Создание сущностей
Смотри также Send Feedback

В этом разделе будет рассмотрено создание сущностей, необходимых для реализации логики модуля.

Создание сущностей

  • Команда
  • Игрок
  • Гол
  • Матч

Смотри также

Дополнительная информация

Сущности


Команда

Команда
Смотри также Send Feedback

В этом документе будет рассмотрено создание сущности "Футбольная команда"

Создание класса-сущности "Футбольная команда"

Рассмотрим создание класса сущности “Команда” (FBTeam). Файл Entities/FBTeam.cs.

Каждая сущность должна содержать в себе класс-схему, который описывает таблицу в строке которой будет храниться сущность, в нашем случае это таблица fbinfo_Team. Рассмотрим класс – схему подробно:

CopyC#
          // класс-схема, описывает таблицу в строке которой хранится сущность
public class Scheme : BXScheme<Scheme>
{
    // в статическом конструкторе описывается таблица сущности
    static Scheme()
    {

        SetTable("fbinfo_Team", "FBINFO_TEAM");
        AddField("TeamId", new BXTableField("TeamId", SqlDbType.Int, 0, false, true, true));
        AddField("Name", new BXTableField("Name", SqlDbType.NVarChar, 50, false));
        AddField("City", new BXTableField("City", SqlDbType.NVarChar, 50, false));
    }
    // публичные свойства для обращения к полям схемы
    public BXSchemeFieldBase TeamId
    {
        get { return GetField("TeamId"); }
    }

    public BXSchemeFieldBase Name
    {
        get { return GetField("Name"); }
    }

    public BXSchemeFieldBase City
    {
        get { return GetField("City"); }
    }
}

Метод SetTable("fbinfo_Team", "FBINFO_TEAM") в конструкторе устанавливает имя таблицы в строке которой хранится сущность и алиас для использования в SQL – запросе ( должен быть уникальным для предотвращения коллизии имен ).

Методы AddField определяют свойства полей таблицы – имя поля, тип данных, размер, спецификацию идентифицирующего столбца. Из различных перегрузок метода можно выбрать требуемый для любого типа данных из MS SQL Server.

Для работы с классом схемы в нем объявлены публичные свойства, предоставляющие доступ к описанию таблицы:

CopyC#
public BXSchemeFieldBase TeamId
{
get { return GetField("TeamId"); }
}

public BXSchemeFieldBase Name
{
get { return GetField("Name"); }
}

public BXSchemeFieldBase City
{
get { return GetField("City"); }
}

Рассмотрим далее полный листинг кода файла FBTeam.cs:

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using Bitrix.DataLayer;
using System.Data;

namespace MyCompany.FBInfo.Entities
{
    public class FBTeam : BXEntity<FBTeam,FBTeamCollection,FBTeam.Scheme>
    {
        // класс-схема, описывает таблицу в строке которой хранится сущность
        public class Scheme : BXScheme<Scheme>
        {
            // в статическом конструкторе описывается таблица сущности
            static Scheme()
            {
                SetTable("fbinfo_Team", "FBINFO_TEAM");
                AddField("TeamId", new BXTableField("TeamId", SqlDbType.Int, 0, false, true, true));
                AddField("Name", new BXTableField("Name", SqlDbType.NVarChar, 50, false));
                AddField("City", new BXTableField("City", SqlDbType.NVarChar, 50, false));
            }
            // публичные свойства для обращения к полям схемы
            public BXSchemeFieldBase TeamId
            {
                get { return GetField("TeamId"); }
            }

            public BXSchemeFieldBase Name
            {
                get { return GetField("Name"); }
            }

            public BXSchemeFieldBase City
            {
                get { return GetField("City"); }
            }
        }

        // публичные свойства для работы с полями сущности
        public int TeamId
        {
            get { return GetValue<int>("TeamId"); }
            set { SetValue("TeamId", value); }
        }

        public string Name
        {
            get { return GetValue<string>("Name"); }
            set { SetValue("Name", value); }
        }

        public string City
        {
            get { return GetValue<string>("City"); }
            set { SetValue("City", value); }
        }

        // переопределенные члены BXEntity

        public override string EntityId
        {
            get { return "FBTeam"; }
        }

        public override string ModuleId
        {
            get { return "FBInfo"; }
        }

    protected override string CustomFieldsKey
        {
            get { return "FBTeam"; }
        }

        protected override string GetCustomFieldsKeyInternal(string id)
        {
            return "FBTeam";
        }
    }

    public class FBTeamCollection : BXEntityCollection<FBTeam, FBTeamCollection, FBTeam.Scheme>
    {
    }
}
          }

Кроме кода схемы сущность содержит публичные свойства для доступа к полям, например:

CopyC#
public string Name
{
  get { return GetValue<string>("Name"); }
    set { SetValue("Name", value); }
}

а также переопределенные свойства BXEntity:

EntityId – идентификатор сущности, используется в различных частях системы, в частности, при создании событий.

CopyC#
public override string EntityId
{
  get { return "FBTeam"; }
}

ModuleId – идентификатор модуля, к которому пренадлежит сущность. Используется в ядре и модуле поиска.

CopyC#
public override string ModuleId
{
  get { return "fbinfo"; }
}

GetCustomFieldsKeyInternal, CustomFieldsKey - служат для работы с набираемыми свойствами. Определяют имя таблицы, хранящей данные набираемых свойств.

Внимание:
Метод GetCustomFieldsKeyInternal и свойство CustomFieldsKey должны быть обязательно переопределены, иначе набираемые свойства не будут работать.

Сущность также содержит обязательное определение коллекции:

CopyC#
public class FBTeamCollection : BXEntityCollection<FBTeam, FBTeamCollection, FBTeam.Scheme>
  {
  }

Смотри также

Ссылка

BXEntity

Дополнительная информация

Сущности


Игрок

Игрок
Смотри также Send Feedback

В этом документе будет рассмотрено создание сущности "Игрок футбольной команды"

Создание класса-сущности "Игрок футбольной команды"

Рассмотрим создание класса-сущности FBPlayer, который представляет собой сущность “Игрок” (файл BXPlayer.cs).

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using Bitrix.DataLayer;
using System.Data;

namespace MyCompany.FBInfo.Entities
{
    public class FBPlayer: BXEntity<FBPlayer, FBPlayerCollection, FBPlayer.Scheme>
    {
        public class Scheme : BXScheme<Scheme>
        {
            static Scheme()
            {
                SetTable("fbinfo_Player", "FBINFO_PLAYER");
                AddField("PlayerId", new BXTableField("PlayerId", SqlDbType.Int, 0, false, true, true));
                AddField("Name", new BXTableField("Name", SqlDbType.NVarChar, 50, false));
                AddField("Number", new BXTableField("Number", SqlDbType.TinyInt, false));
                AddField("TeamId", new BXTableField("TeamId", SqlDbType.Int, true));

                AddField("Team",

                    new BXSchemeField(
                        "Team",
                        typeof(FBTeam),
                        new BXSchemeFieldBase.BXAssignField(
                            Scheme.SelectField("TeamId"),
                            "TeamId",
                            "FBINFO_TEAM",
                            false,
                            BXSchemeJoinType.Left
                        )
                    )
                );
            }
            // публичные свойства для обращения к полям схемы

            public BXSchemeFieldBase PlayerId
            {
                get { return GetField("PlayerId"); }
            }

            public BXSchemeFieldBase TeamId
            {
                get { return GetField("TeamId"); }
            }

            public BXSchemeFieldBase Name
            {
                get { return GetField("Name"); }
            }

            public BXSchemeFieldBase Number
            {
                get { return GetField("Number"); }
            }

            public FBTeam.Scheme Team
            {
                get { return ((BXSchemeField)GetField("Team")).Scheme as FBTeam.Scheme; }
            }
        }

        public int PlayerId
        {
            get
            {
                return GetValue<int>("PlayerId");
            }
            set
            {
                SetValue("PlayerId", value);
            }
        }

        public string Name
        {
            get
            {
                return GetValue<string>("Name");
            }
            set
            {
                SetValue("Name", value);
            }
        }

        public short Number
        {
            get
            {
                return GetValue<short>("Number");
            }
            set
            {
                SetValue("Number", value);
            }
        }

        public int TeamId
        {
            get
            {
                return GetValue<int>("TeamId");
            }
            set
            {
                SetValue("TeamId", value);
            }
        }

        public FBTeam Team
        {
            get
            {
                return GetJoinedEntity<FBTeam, FBTeamCollection, FBTeam.Scheme>("Team", "Team", "TeamId");
            }
        }

        // переопределенные члены BXEntity

        public override string EntityId
        {
            get { return "FBPlayer"; }
        }

        public override string ModuleId
        {
            get { return "FBInfo"; }
        }

    protected override string CustomFieldsKey
        {
            get { return "FBPlayer"; }
        }

        protected override string GetCustomFieldsKeyInternal(string id)
        {
            return "FBPlayer";
        }

    }
    public class FBPlayerCollection : BXEntityCollection<FBPlayer, FBPlayerCollection, FBPlayer.Scheme>
    {
    }
}

Как видно из приведенного листинга, большая часть класса FBPlayer написана аналогично классу FBTeam. Рассмотрим далее лишь те части кода, где есть существенные отличия, а именно описания поля-связки Игрок – Команда, которое связывает экземпляр класса FBPlayer с экземпляром класса FBTeam.

В статическом конструкторе класса-схемы сущности появился не встречавшийся в FBTeam вызов метода AddField(String, BXSchemeFieldBase):

CopyC#
AddField("Team",
  new BXSchemeField(
    "Team",
    typeof(FBTeam),
    new BXSchemeFieldBase.BXAssignField(
      Scheme.SelectField("TeamId"),
      "TeamId",
      "FBINFO_TEAM",
      false
    )
  )
);

Вторым аргументом в AddField передан класс BXSchemeField, который представляет собой определение поля для связки сущностей.

Описание конструктора выглядит следующим образом:

CopyC#
BXSchemeField.BXSchemeField(    string name, Type schemeType, BXSchemeFieldBase assignTo)

где:

  • name – название поля
  • schemeType – тип связанной сущности
  • assignTo – экземпляр класса BXAssignField, который описывает поле другой сущности ( в нашем случае эта сущность – FBTeam ) по которому происходит связывание.

И наконец, конструктор класса BXAssignField, который содержит информацию о внешнем поле:

CopyC#
BXSchemeFieldBase.BXAssignField(BXSchemeFieldBase assignTo, string joinField, string assignAlias, bool separateQuery)

Также иначе выглядит публичное свойство для доступа к экземпляру класса FBTeam - команде игрока:

CopyC#
public FBTeam Team
{
  get
  {
    return GetJoinedEntity<FBTeam,FBTeamCollection,FBTeam.Scheme>("Team", "Team", "TeamId");
    }
}

Метод GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String) выполняет запрос к связанной сущности, с использованием продвинутой ”ленивой загрузки”:

CopyC#
protected JoinedEntityType GetJoinedEntity<JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>(string key, string path, string criterionKey)

где:

  • key – имя поля схемы, в которое записывается полученная сущность
  • path – путь к связанной сущности в схеме относительно данной сущности, имеет синтаксис подобный XPath. Для пояснения значения этого аргумента рассмотрим небольшой пример:

    Пусть мы решили добавить в структуру проекта еще одну сущность – тренера команды. Тогда связки сущностей будут выглядеть так Игрок -> Команда -> Тренер.

    В случае непосредственной связки Игрок –> Команда поле с именем Team уже присутсвует в схеме FBPlayer, поэтому в качестве пути указываем его. Если бы нам требовалось напрямую получить значение связки Игрок -> Тренер, это можно было бы сделать, указав в соответствующем вызове GetJoinedEntity Path = “Team/Trainer” где Trainer – имя поля-связки Команда -> Тренер в схеме FBTeam.

  • criterionKey – имя поля в схеме сущности, по которому происходит связывание.

Смотри также

Ссылка

BXEntity

Дополнительная информация

Сущности


Гол

Гол
Смотри также Send Feedback

В этом документе будет рассмотрено создание класса-сущности "Гол"

Создание класса-сущности "Гол"

Создадим далее сущность, представляющую собой гол в матче.

Рассмотрим листинг FBGoal.cs:

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using Bitrix.DataLayer;
using System.Data;

namespace MyCompany.FBInfo.Entities
{
    public class FBGoal : BXEntity<FBGoal, FBGoalCollection, FBGoal.Scheme>
    {
        // класс-схема, описывает таблицу в строке которой хранится сущность
        public class Scheme : BXScheme<Scheme>
        {
            // в статическом конструкторе описывается таблица сущности
            static Scheme()
            {
                SetTable("fbinfo_Goal", "FBINFO_GOAL");
                AddField("GoalId", new BXTableField("GoalId", SqlDbType.Int, 0, false, true, true));
                AddField("PlayerId", new BXTableField("PlayerId", SqlDbType.Int, false));
                AddField("MatchId", new BXTableField("MatchId", SqlDbType.Int, false));
                AddField("TeamId", new BXTableField("TeamId", SqlDbType.Int, false));
                AddField("GoalTime", new BXTableField("GoalTime", SqlDbType.TinyInt, false));

                AddField("Player",

                    new BXSchemeField(
                        "Player",
                        typeof(FBPlayer),
                        new BXSchemeFieldBase.BXAssignField(
                            Scheme.SelectField("PlayerId"),
                            "PlayerId",
                            "GP",
                            false
                        )
                    )
                );

                AddField("Match",
                    new BXSchemeField(
                        "Match",
                        typeof(FBMatch),
                        new BXSchemeFieldBase.BXAssignField(
                            Scheme.SelectField("MatchId"),
                            "MatchId",
                            "FB_MATCH",
                            false
                            )
                        )
                    );

                AddField("Team",
                    new BXSchemeField(
                        "Team",
                        typeof(FBTeam),
                        new BXSchemeFieldBase.BXAssignField(
                            Scheme.SelectField("TeamId"),
                            "TeamId",
                            "FB_TEAM",
                            false
                            )
                        )
                    );
            }
            // публичные свойства для обращения к полям схемы
            public BXSchemeFieldBase GoalId
            {
                get { return GetField("GoalId"); }
            }

            public BXSchemeFieldBase PlayerId
            {
                get { return GetField("PlayerId"); }
            }

            public BXSchemeFieldBase GoalTime
            {
                get { return GetField("GoalTime"); }
            }

            public FBPlayer.Scheme Player
            {
                get
                {
                    return (FBPlayer.Scheme)((BXSchemeField)GetField("Player")).Scheme;
                }
            }

            public FBMatch.Scheme Match
            {
                get
                {
                    return (FBMatch.Scheme)((BXSchemeField)GetField("Match")).Scheme;
                }
            }

            public FBTeam.Scheme Team
            {
                get
                {
                    return (FBTeam.Scheme)((BXSchemeField)GetField("Team")).Scheme;
                }
            }

        }

        // публичные свойства для работы с полями сущности
        public int GoalId
        {
            get { return GetValue<int>("GoalId"); }
            set { SetValue("GoalId", value); }
        }

        public byte GoalTime
        {
            get { return GetValue<byte>("GoalTime"); }
            set { SetValue("GoalTime", value); }
        }

        public FBPlayer Player
        {
            get
            {
                return GetJoinedEntity<FBPlayer, FBPlayerCollection, FBPlayer.Scheme>("Player", "Player", "PlayerId");
            }
        }

        public FBMatch Match
        {
            get
            {
                return GetJoinedEntity<FBMatch, FBMatchCollection, FBMatch.Scheme>("Match", "Match", "MatchId");
            }
        }

        public FBTeam Team
        {
            get
            {
                return GetJoinedEntity<FBTeam, FBTeamCollection, FBTeam.Scheme>("Team", "Team", "TeamId");
            }
        }

        // переопределенные члены BXEntity

        public override string EntityId
        {
            get { return "FBGoal"; }
        }

        public override string ModuleId
        {
            get { return "FBInfo"; }
        }

    protected override string CustomFieldsKey
        {
            get { return "FBGoal"; }
        }

        protected override string GetCustomFieldsKeyInternal(string id)
        {
            return "FBGoal";
        }
    }

    public class FBGoalCollection : BXEntityCollection<FBGoal, FBGoalCollection, FBGoal.Scheme>
    {
    }
}

Смотри также

Ссылка

BXEntity

Дополнительная информация

Сущности


Матч

Матч
Смотри также Send Feedback

В этом документе будет рассмотрено создание класса-сущности "Футбольный матч"

Создание класса-сущности "Футбольный матч"

Рассмотрим листинг файла FBMatch.cs:

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using Bitrix.DataLayer;
using System.Data;
using Bitrix.Security;

namespace MyCompany.FBInfo.Entities
{
    // Сущность FBMatch - футбольный матч
    public class FBMatch: BXEntity<FBMatch,FBMatchCollection,FBMatch.Scheme>
    {
        // класс-схема, описывает таблицу в строке которой хранится сущность
        public class Scheme : BXScheme<Scheme>
        {
            // в статическом конструкторе описывается таблица сущности
            static Scheme()
            {
                SetTable("fbinfo_Match", "FBINFO_MATCH");

                AddField("MatchId", new BXTableField("MatchId", SqlDbType.Int, 0, false, true, true));

                AddField("FirstTeamId", new BXTableField("FirstTeamId", SqlDbType.Int, false));
                AddField("SecondTeamId", new BXTableField("SecondTeamId", SqlDbType.Int, false));

                AddField("Location", new BXTableField("Location", SqlDbType.NVarChar, 50, false));

                AddField("FirstTeamGoals", new BXTableField("FirstTeamGoals", SqlDbType.Int, false, 0));
                AddField("SecondTeamGoals", new BXTableField("SecondTeamGoals", SqlDbType.Int, false, 0));

                AddField("BeginTime", new BXTableField("BeginTime", SqlDbType.DateTime, true));
                AddField("EndTime", new BXTableField("EndTime", SqlDbType.DateTime, true));
                AddField("CreatedBy", new BXTableField("CreatedBy", SqlDbType.Int, false));

                AddField("CreatedByUser",

                    new BXSchemeField(
                        "CreatedByUser",
                        typeof(BXUser),
                        new BXSchemeFieldBase.BXAssignField(
                            Scheme.SelectField("CreatedBy"),
                            "ID",
                            "PU",
                            false
                        )
                    )
                );

                AddField("FirstTeam",
                    new BXSchemeField(
                        "FirstTeam",
                        typeof(FBTeam),
                        new BXSchemeFieldBase.BXAssignField(
                            Scheme.SelectField("FirstTeamId"),
                            "TeamId",
                            "FT",
                            false
                        )
                    )
                );

                AddField("SecondTeam",
                    new BXSchemeField(
                        "SecondTeam",
                        typeof(FBTeam),
                        new BXSchemeFieldBase.BXAssignField(
                            Scheme.SelectField("SecondTeamId"),
                            "TeamId",
                            "ST",
                            false
                        )
                    )
                );
            }
            // публичные свойства для обращения к полям схемы

            public BXSchemeFieldBase MatchId
            {
                get { return GetField("MatchId"); }
            }

            public BXSchemeFieldBase FirstTeamGoals
            {
                get { return GetField("FirstTeamGoals"); }
            }

            public BXSchemeFieldBase SecondTeamGoals
            {
                get { return GetField("SecondTeamGoals"); }
            }

            public BXSchemeFieldBase Location
            {
                get { return GetField("Location"); }
            }

            public BXSchemeFieldBase BeginTime
            {
                get { return GetField("BeginTime"); }
            }

            public BXSchemeFieldBase EndTime
            {
                get { return GetField("EndTime"); }
            }

            public BXSchemeFieldBase CreatedBy
            {
                get { return GetField("CreatedBy"); }
            }

            public FBTeam.Scheme FirstTeam
            {
                get { return ((BXSchemeField)GetField("FirstTeam")).Scheme as FBTeam.Scheme; }
            }

            public FBTeam.Scheme SecondTeam
            {
                get { return ((BXSchemeField)GetField("SecondTeam")).Scheme as FBTeam.Scheme; }
            }

            public BXUser.Scheme CreatedByUser
            {
                get { return ((BXSchemeField)GetField("CreatedByUser")).Scheme as BXUser.Scheme; }
            }

        }

        // публичные свойства для работы с полями сущности
        public int MatchId
        {
            get { return GetValue<int>("MatchId"); }
            set { SetValue("MatchId", value); }
        }

        public int FirstTeamId
        {
            get { return GetValue<int>("FirstTeamId"); }
            set { SetValue("FirstTeamId", value); }
        }

        public int SecondTeamId
        {
            get { return GetValue<int>("SecondTeamId"); }
            set { SetValue("SecondTeamId", value); }
        }

        public byte FirstTeamGoals
        {
            get { return GetValue<byte>("FirstTeamGoals"); }
            set { SetValue("FirstTeamGoals", value); }
        }

        public byte SecondTeamGoals
        {
            get { return GetValue<byte>("SecondTeamGoals"); }
            set { SetValue("SecondTeamGoals", value); }
        }

        public string Location
        {
            get { return GetValue<string>("Location"); }
            set { SetValue("Location", value); }
        }

        public DateTime BeginTime
        {
            get { return GetValue<DateTime>("BeginTime"); }
            set { SetValue("BeginTime", value); }
        }

        public DateTime EndTime
        {
            get { return GetValue<DateTime>("EndTime"); }
            set { SetValue("EndTime", value); }
        }

        public int CreatedBy
        {
            get { return GetValue<int>("CreatedBy"); }
            set { SetValue("CreatedBy", value); }
        }

        public FBTeam FirstTeam
        {
            get
            {
                return GetJoinedEntity<FBTeam, FBTeamCollection, FBTeam.Scheme>("FirstTeam", "FirstTeam", "FirstTeamId");
            }
        }

        public FBTeam SecondTeam
        {
            get
            {
                return GetJoinedEntity<FBTeam, FBTeamCollection, FBTeam.Scheme>("SecondTeam", "SecondTeam", "SecondTeamId");
            }
        }

        public BXUser CreatedByUser
        {
            get
            {
                return GetJoinedEntity<BXUser, BXUserCollection, BXUser.Scheme>("CreatedByUser", "CreatedByUser", "CreatedBy");
            }
        }

        // переопределенные члены BXEntity

        public override string EntityId
        {
            get { return "FBMatch"; }
        }

        public override string ModuleId
        {
            get { return "FBInfo"; }
        }

    protected override string CustomFieldsKey
        {
            get { return "FBMatch"; }
        }

        protected override string GetCustomFieldsKeyInternal(string id)
        {
            return "FBMatch";
        }

    }

    public class FBMatchCollection : BXEntityCollection<FBMatch, FBMatchCollection, FBMatch.Scheme>
    {
    }
}

Смотри также

Ссылка

BXEntity

Дополнительная информация

Сущности


Создание языковых файлов модуля

Создание языковых файлов модуля
Send Feedback

Этот документ содержит описание создания языковых файлов модуля

Языковые файлы модуля

Локализация в "1С-Битрикс Управление Сайтом ASP.NET" основана на использовании языковых файлов с расширением .lang. Они представляют собой XML файлы с простой структурой:

CopyXML
<?xml version="1.0" encoding="utf-8"?>
<resources>
    <data name="<идентификатор фразы>"><![CDATA[<Текст фразы на нужном языке>]]></data>
</resources>

Создадим в папке модуля подпапку lang, в ней папку ru (ru – идентификатор русского языка), а в ней файл include.lang, содержащий следующий XML:

CopyXML
<?xml version="1.0" encoding="utf-8"?>
<resources>
    <data name="Module.Name"><![CDATA[Футбольные матчи]]></data>
          <data name="Module.Description"><![CDATA[Модуль отображения информации о футбольных матчах на сайте]]></data>
          </resources>


Создание административных страниц модуля
Смотри также Send Feedback

Для управления модулем в административной части используются административные страницы .aspx, производные от класса BXAdminPage.

В этом разделе будет показан процесс создания четырех страниц, которые позволят добавлять, удалять и редактировать игроков и матчи, а также просматривать их список по различным фильтрам.

Создание административных страниц модуля

  • Страница "Список игроков"
  • Страница "Создание-редактирование игрока"
  • Страница "Список матчей"
  • Страница "Создание-редактирование матча"
  • Отображение страниц в меню

Смотри также

Дополнительная информация

Отображение страниц в меню


Страница "Список игроков"

Страница "Список игроков"
Send Feedback

В этом документе будет рассмотрено создание административной страницы "Список игроков", которая позволит просматривать игроков с применением фильтров, а также удалять и переходить к их созданию и редактированию.

Создание административной страницы "Список игроков" FBPlayerList.aspx

Добавим в каталог /bitrix/admin/ новую страницу - FBPlayerList.aspx. В последствии, когда страница будет написана, мы поместим ее в папку с модулем, из которой она будет копироваться в папку /bitrix/admin/ при установке.

Добавим в aspx файл следующий код:

CopyC#
<%@ Page Language="C#" AutoEventWireup="false" MasterPageFile="~/bitrix/admin/AdminMasterPage.master" CodeFile="FBPlayerList.aspx.cs"
Inherits="bitrix_modules_fbinfo_Install_System_Admin_FBPlayerList" %>

<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" runat="server">
    <asp:UpdatePanel ID="UpdatePanel" runat="server">

        <ContentTemplate>
        <bx:BXValidationSummary ID="ErrorMessage" runat="server" CssClass="errorSummary"
                HeaderText="<%$ Loc:Kernel.Error %>" ValidationGroup="GridView" />
            <br />
        <% if (!HasFatalErrors)
           { %>
            <bx:BXAdminFilter ID="ItemFilter" runat="server" AssociatedGridView="ItemGrid">
                <bx:BXTextBoxStringFilter Key="Name" Text="<%$ LocRaw:FilterText.Name %>" Visibility="AlwaysVisible" />
                <bx:BXTextBoxFilter Key="PlayerId" Text="ID" ValueType="Integer" />
            </bx:BXAdminFilter>
            <bx:BXContextMenuToolbar ID="ItemListToolbar" runat="server">
                <Items>
                    <bx:BXCmSeparator SectionSeparator="true" />
                    <bx:BXCmImageButton ID="AddButton" Text="<%$ LocRaw:ActionText.Add %>" Title="<%$ LocRaw:ActionTitle.Add %>"
                        CssClass="context-button icon btn_new" Href="FBPlayerEdit.aspx" />
                </Items>
            </bx:BXContextMenuToolbar>
            <bx:BXPopupPanel ID="PopupPanelView" runat="server">
                <Commands>
                    <bx:CommandItem UserCommandId="edit" Default="True" IconClass="edit" ItemText="<%$ LocRaw:PopupText.Edit %>"
                        ItemTitle="<%$ LocRaw:PopupTitle.Edit %>" OnClickScript="window.location.href = 'FBPlayerEdit.aspx?id=' + UserData['PlayerId']; return false;" />
                    <bx:CommandItem UserCommandId="delete" Default="False" IconClass="delete" ItemText="<%$ LocRaw:PopupText.Delete %>"
                        ItemTitle="<%$ LocRaw:PopupTitle.Delete %>" ShowConfirmDialog="true" ConfirmDialogText="<%$ LocRaw:PopupConfirmDialogText.Delete %>" />
                </Commands>
            </bx:BXPopupPanel>
            <br />
            <bx:BXGridView ID="ItemGrid" runat="server" ContentName="<%$ LocRaw:TableTitle %>"
                AllowSorting="True" AllowPaging="True" DataKeyNames="PlayerId" SettingsToolbarId="ItemListToolbar"
                PopupCommandMenuId="PopupPanelView" ContextMenuToolbarId="MultiActionMenuToolbar"
                DataSourceID="ItemGrid" OnSelect="ItemGrid_Select" OnSelectCount="ItemGrid_SelectCount"
                OnDelete="ItemGrid_Delete" OnRowDataBound="ItemGrid_RowDataBound">
                <Columns>
                    <asp:BoundField DataField="PlayerId" HeaderText="ID" SortExpression="PlayerId" ReadOnly="True" />
                    <asp:TemplateField HeaderText="<%$ LocRaw:ColumnHeaderText.Name %>" SortExpression="Name">
                        <ItemTemplate>
                            <%# ((FBInfo.Entities.FBPlayer)Container.DataItem).Name %>
                        </ItemTemplate>
                    </asp:TemplateField>
                    <asp:TemplateField HeaderText="<%$ LocRaw:ColumnHeaderText.Team %>" SortExpression="Team.Name">
                        <ItemTemplate>
                            <%# ((FBInfo.Entities.FBPlayer)Container.DataItem).Team != null ?  ((FBInfo.Entities.FBPlayer)Container.DataItem).Team.Name : "-" %>
                        </ItemTemplate>
                    </asp:TemplateField>
                </Columns>
                <AjaxConfiguration UpdatePanelId="UpdatePanel" />
            </bx:BXGridView>
            <bx:BXMultiActionMenuToolbar ID="MultiActionMenuToolbar" runat="server" ValidationGroup="GridView">
                <Items>
                    <bx:BXMamImageButton CommandName="delete" ShowConfirmDialog="true" ConfirmDialogText="<%$ LocRaw:ActionConfirmDialogText.Delete %>"
                        ConfirmDialogTextAll="<%$ LocRaw:ActionConfirmDialogTextAll.Delete %>" EnabledCssClass="context-button icon delete"
                        DisabledCssClass="context-button icon delete-dis" Title="<%$ LocRaw:ActionTitle.Delete %>" />
                </Items>
            </bx:BXMultiActionMenuToolbar>
            <%} %>
        </ContentTemplate>
    </asp:UpdatePanel>
</asp:Content>

Затем перейдем к codebehind файлу FBPlayerList.aspx.cs и добавим в него код:

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Web;
using System.Web.UI;
using System.Web.UI.WebControls;
using Bitrix.Security;
using MyCompany.FBInfo;
using Bitrix.UI;
using MyCompany.FBInfo.Entities;
using Bitrix.DataLayer;
using Bitrix.Services.Text;

public partial class bitrix_modules_fbinfo_Install_System_Admin_FBPlayerList : Bitrix.UI.BXAdminPage
{
    bool hasFatalErrors = false;

    protected bool HasErrors
    {
        get { return hasFatalErrors; }
    }

    protected override void OnInit(EventArgs e)
    {
        base.OnInit(e);
        if (!BXPrincipal.Current.IsCanOperate(FBInfoModule.Operations.AdminManagement))
        {
            ErrorMessage.AddErrorMessage(GetMessageRaw("Error.Unauthorized"));
            hasFatalErrors = true;
        }
    }

    protected override void OnLoad(EventArgs e)
    {
        base.OnLoad(e);
        MasterTitle = Page.Title = GetMessage("PageTitle");
    }

    protected void ItemGrid_Select(object sender, BXSelectEventArgs e)
    {
        var f = new BXFilter(ItemFilter.CurrentFilter, FBPlayer.Fields);

        var playerList = FBPlayer.GetList(
            f,
            new BXOrderBy(FBPlayer.Fields, string.IsNullOrEmpty(e.SortExpression) ? "PlayerId" : e.SortExpression),
            new BXSelectAdd(FBPlayer.Fields.Team),
            new BXQueryParams(e.PagingOptions),
            BXTextEncoder.EmptyTextEncoder
            ).ToList<FBPlayer>();

        e.Data = playerList;
    }

    protected void ItemGrid_SelectCount(object sender, BXSelectCountEventArgs e)
    {
        e.Count = FBPlayer.Count(new BXFilter(ItemFilter.CurrentFilter, FBPlayer.Fields));
    }

    protected void ItemGrid_RowDataBound(object sender, GridViewRowEventArgs e)
    {
        if (e.Row.RowType != DataControlRowType.DataRow)
            return;

        BXGridViewRow row = (BXGridViewRow)e.Row;
        var player = (FBPlayer)row.DataItem;

        row.UserData.Add("PlayerId", player.PlayerId);
    }

    protected void ItemGrid_Delete(object sender, BXDeleteEventArgs e)
    {
        FBPlayerCollection col;
        try
        {
            BXFilter filter = (e.Keys == null)
                ? new BXFilter(ItemFilter.CurrentFilter, FBPlayer.Fields)
                : new BXFilter(new BXFilterItem(FBPlayer.Fields.PlayerId, BXSqlFilterOperators.Equal, e.Keys["PlayerId"]));
            col = FBPlayer.GetList(filter, null);
        }
        catch (Exception ex)
        {
            ErrorMessage.AddErrorMessage(ex.Message);
            return;
        }
        bool errorTextAdded = false;
        foreach (var item in col)
        {
            try
            {
                item.Delete();
                e.DeletedCount++;
            }
            catch
            {
                if (!errorTextAdded)
                {
                    ErrorMessage.AddErrorMessage(GetMessage("Player.DeleteFailure"));
                    errorTextAdded = true;
                }
            }
        }
    }
}

В методе OnInit

CopyC#
protected override void OnInit(EventArgs e)
{
  base.OnInit(e);
  if (!BXPrincipal.Current.IsCanOperate(FBInfoModule.Operations.AdminManagement))
  {
    ErrorMessage.AddErrorMessage(GetMessageRaw("Error.Unauthorized"));
    hasFatalErrors = true;
  }
}

выполняется проверка прав с помощью метода IsCanOperate класса BXPrincipal. В случае, если проверка прошла неудачно, устанавливается флаг наличия фатальных ошибок, который в aspx странице определяет, выводить ли элементы управления - список, кнопки, и тд.

Краткое описание методов - обработчиков событий элемента BXGridView ( грида )

Метод | Выполняемые операции
ItemGrid_SelectCount | Вызывается, когда грид должен получить количество отображаемых элементов. В методе выполняется метод Count(BXFilter), получающий количество сущностей по фильтру.
ItemGrid_Select | Вызывается, когда грид должен получить список отображаемых элементов. В методе выполняется метод GetList(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder), получающий список сущностей по фильтру.
ItemGrid_RowDataBound | В этом методе мы заполняем свойство UserData строки грида для использование его затем во всплывающей панели BXPopupPanel.
ItemGrid_Delete | Вызывается при удалении строк грида. Для каждой удаляемой строки вызываем метод Delete()()()(), удаляющий соответствующую строке сущность.

Метод ItemGrid_Delete содержит в себе вызов метода GetList(BXFilter, BXOrderBy):

CopyC#
BXFilter filter = (e.Keys == null)
? new BXFilter(ItemFilter.CurrentFilter, FBPlayer.Fields)
: new BXFilter(new BXFilterItem(FBPlayer.Fields.PlayerId, BXSqlFilterOperators.Equal, e.Keys["PlayerId"]));
col = FBPlayer.GetList(filter, null);

аргументами метода GetList(BXFilter, BXOrderBy) являются экземпляры классов BXFilter и BXOrderBy соответственно. Как видно из листинга, фильтр создается либо с использованием ItemFilter.CurrentFilter ( текущий фильтр элемента управления BXAdminFilter, расположенного на aspx странице ), либо, если указана конкретная запись в гриде, соответствующая ей сущность будет выбрана по идентификатору, для чего создается фильтр:

CopyC#
new BXFilter(new BXFilterItem(FBPlayer.Fields.PlayerId, BXSqlFilterOperators.Equal, e.Keys["PlayerId"]));

Вторым аргументом вызова GetList(BXFilter, BXOrderBy) указан null, что означает указание сортировки по умолчанию.

Создадим далее языковой файл для нашей страницы, и добавим в него языковые фразы, которые мы использовали:

CopyXML
        <?xml version="1.0" encoding="utf-8"?>
<resources>
    <data name="PageTitle"><![CDATA[Список игроков]]></data>
          <data name="FilterText.Name"><![CDATA[Имя игрока]]></data>
          <data name="FilterText.Team"><![CDATA[Команда]]></data>
          <data name="ActionText.Add"><![CDATA[Новый игрок]]></data>
          <data name="ActionTitle.Add"><![CDATA[Добавить информацию об игроке]]></data>
          <data name="PopupText.Edit"><![CDATA[Изменить информацию об игроке]]></data>
          <data name="PopupTitle.Edit"><![CDATA[Изменение информации об игроке]]></data>
          <data name="PopupText.Delete"><![CDATA[Удалить информацию об игроке]]></data>
          <data name="PopupTitle.Delete"><![CDATA[Удаление информации об игроке]]></data>
          <data name="PopupConfirmDialogText.Delete"><![CDATA[Вы действительно хотите удалить информацию об игроке?]]></data>
          <data name="ColumnHeaderText.Name"><![CDATA[Имя]]></data>
          <data name="ColumnHeaderText.Team"><![CDATA[Команда]]></data>
          <data name="ActionConfirmDialogText.Delete"><![CDATA[Вы действительно хотите удалить отмеченные записи?]]></data>
          <data name="ActionConfirmDialogTextAll.Delete"><![CDATA[Вы уверены, что хотите УДАЛИТЬ ВСЕ ЗАПИСИ из списка?]]></data>
          <data name="ActionTitle.Delete"><![CDATA[Удалить записи]]></data>
          <data name="Error.Unauthorized"><![CDATA[Не достаточно прав для выполнения операции]]></data>
          </resources>


Страница "Создание-редактирование игрока"

Страница "Создание-редактирование игрока"
Send Feedback

В этом документе будет рассмотрено создание страницы "Создание-Редактирование игрока", реализующей типичные операции над сущностями - создание, редактирование, удаление.

Создание страницы "Создание-Редактирование игрока" FBPlayerEdit.aspx

Добавим в каталог /bitrix/admin/ новую страницу - FBPlayerEdit.aspx. В последствии, когда страница будет написана, мы поместим ее в папку с модулем, из которой она будет копироваться в папку /bitrix/admin/ при установке.

Добавим в aspx файл следующий код:

CopyC#
<%@ Page Language="C#" MasterPageFile="~/bitrix/admin/AdminMasterPage.master"
    AutoEventWireup="false" CodeFile="FBPlayerEdit.aspx.cs" Inherits="bitrix_admin_FBPlayerEdit" %>

<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" Runat="Server">
    <bx:BXContextMenuToolbar ID="EditToolbar" runat="server" OnCommandClick="OnToolBarButtonClick">
        <Items>
            <bx:BXCmSeparator ID="ListButton" runat="server" SectionSeparator="true" />
            <bx:BXCmImageButton CssClass="context-button icon btn_list" CommandName="list"
                Text="<%$ LocRaw:ActionText.GoBack %>" Title="<%$ LocRaw:ActionTitle.GoBack %>" Href="FBPlayerList.aspx" />
            <bx:BXCmSeparator SectionSeparator="true" />
            <bx:BXCmImageButton ID="AddButton" CssClass="context-button icon btn_new" CommandName="add"
                Text="<%$ LocRaw:Kernel.Add %>" Title="<%$ LocRaw:ActionTitle.Add %>" Href="FBPlayerEdit.aspx" />
            <bx:BXCmSeparator SectionSeparator="true" />
            <bx:BXCmImageButton ID="DeleteButton" CssClass="context-button icon btn_delete" CommandName="delete"
                Text="<%$ LocRaw:Kernel.Delete %>" Title="<%$ LocRaw:ActionTitle.Delete %>" ShowConfirmDialog="true" ConfirmDialogText="<%$ LocRaw:ActionConfirmDialogText.Delete %>"/>
        </Items>
    </bx:BXContextMenuToolbar>
    <bx:BXValidationSummary ID="errorMessage" runat="server" CssClass="errorSummary" HeaderText="<%$ Loc:Kernel.Error %>" ValidationGroup="Main" />
    <bx:BXTabControl ID="TabControl" runat="server" OnCommand="OnTabControlCommand" ValidationGroup="Main">
        <bx:BXTabControlTab ID="MainSettingsTab" Runat="server" Selected="True" Text="<%$ LocRaw:TabText.MainSettings %>" Title="<%$ LocRaw:TabTitle.MainSettings %>">
            <table class="edit-table" cellspacing="0" cellpadding="0" border="0">
                <% if (EntityId > 0){ %>
                <tr valign="top"><td class="field-name" width="25%">ID:</td><td width="30%"><%= EntityId.ToString() %></td></tr>
                <% } %>

                <tr valign="top" title="<%= GetMessage("FieldTooltip.Name") %>">
                    <td class="field-name"><span class="required">*</span><%= GetMessage("FieldLabel.Name") %>:</td>
                    <td>
                        <asp:TextBox ID="Name" runat="server" Width="350px" />
                        <asp:RequiredFieldValidator ID="NameRequiredValidator" runat="server" ValidationGroup="Main"
                        ControlToValidate="Name" ErrorMessage="<%$ Loc:Message.NameNotSpecified %>" Display="Dynamic">*</asp:RequiredFieldValidator>
                    </td>
                    <td></td>
                </tr>

                <tr valign="top" title="<%= GetMessage("FieldTooltip.Team") %>">
                    <td class="field-name"><%= GetMessage("FieldLabel.Team")%>:</td>
                    <td>
                        <asp:DropDownList ID="TeamList" runat="server" >
                        </asp:DropDownList>
                    </td>
                    <td></td>
                </tr>
            </table>
        </bx:BXTabControlTab>
    </bx:BXTabControl>

</asp:Content>

Затем перейдем к codebehind файлу FBPlayerEdit.aspx.cs и добавим в него код:

CopyC#
using System;
using System.Collections.Generic;
using System.Web;
using System.Web.UI;
using System.Web.UI.WebControls;
using Bitrix.UI;
using System.Text;
using Bitrix.Security;
using Bitrix.Services;
using MyCompany.FBInfo.Entities;
using Bitrix.DataLayer;
using MyCompany.FBInfo;

public partial class bitrix_admin_FBPlayerEdit : BXAdminPage
{
    List<FBTeam> allTeams;

    List<FBTeam> AllTeams
    {
        get
        {
            if (allTeams != null)
                return allTeams;
            return allTeams = FBTeam.GetList(null, new BXOrderBy(new BXOrderByPair(FBTeam.Fields.Name, BXOrderByDirection.Asc)));
        }
    }

  protected override void OnInit(EventArgs e)
  {
    base.OnInit(e);
        if (!BXPrincipal.Current.IsCanOperate(FBInfoModule.Operations.AdminManagement))
        {
            this.errorMessageText = GetMessageRaw("Error.Unauthorized");
            return;
        }
        TeamList.Items.Add(new ListItem(GetMessageRaw("NotSelected"), string.Empty));

    foreach (var team in AllTeams)
            TeamList.Items.Add(new ListItem(team.Name, team.TeamId.ToString()));
  }

    FBPlayer entity;

    protected FBPlayer Entity
    {
        get { return entity; }
    }

    int? entityId = null;
    protected int EntityId
    {
        get
        {
            if (this.entityId.HasValue)
                return entityId.Value;

            string str = Request.QueryString["id"];
            if (string.IsNullOrEmpty(str))
                this.entityId = 0;
            else
            {
                try
                {
                    this.entityId = Convert.ToInt32(Request.QueryString["id"]);
                }
                catch
                {
                    this.entityId = 0;
                }
            }
            return this.entityId.Value;
        }
    }

    protected override void OnLoad(EventArgs e)
    {
        base.OnLoad(e);

        MasterTitle = Page.Title = EntityId == 0 ? GetMessage("PageTitle.Creation") : string.Concat(GetMessage("PageTitle.Modification"), " #", EntityId.ToString());

        if (EntityId == 0)
            this.entity = new FBPlayer();
        else if ((this.entity = FBPlayer.GetById(EntityId)) == null)
        {
            this.editorError = FBPlayerEditorError.IsNotFound;
            this.errorMessageText = GetMessageRaw("Message.PlayerIsNotFound");
            return;
        }

        if (!IsPostBack)
        {
            if (!this.entity.IsNew)
            {
                Name.Text = this.entity.Name;
                ListItem teamItem = TeamList.Items.FindByValue(this.entity.TeamId.ToString());
                if (teamItem != null)
                    teamItem.Selected = true;
            }
        }
    }

    protected override void OnPreRender(EventArgs e)
    {
        base.OnPreRender(e);

        if (EditorError != FBPlayerEditorError.None)
        {
            errorMessage.AddErrorMessage(ErrorMessageText);
            if (EntityId > 0 && EditorError == FBPlayerEditorError.IsNotFound)
                TabControl.Visible = false;
        }

    }

    private string errorMessageText = string.Empty;
    protected string ErrorMessageText
    {
        get { return this.errorMessageText; }
    }

        private FBPlayerEditorError editorError = FBPlayerEditorError.None;
        protected FBPlayerEditorError EditorError
    {
        get { return this.editorError; }
    }

    protected void OnToolBarButtonClick(object sender, CommandEventArgs e)
    {
        if (e.CommandName == "delete")
        {
            try
            {
                if (Entity != null)
                    Entity.Delete();

                GoBack("~/bitrix/admin/FBPlayerList.aspx");
            }
            catch (Exception ex)
            {
                this.errorMessageText = ex.Message;
                this.editorError = FBPlayerEditorError.Deleting;
            }
        }
    }

    protected void OnTabControlCommand(object sender, BXTabControlCommandEventArgs e)
    {
        switch (e.CommandName)
        {
            case "save":
                {
                    if (IsValid && EditorError == FBPlayerEditorError.None)
                    {
                        TrySave();
                        if (EditorError == FBPlayerEditorError.None)
                            GoBack("~/bitrix/admin/FBPlayerList.aspx");
                    }
                }
                break;
            case "apply":
                {
                    if (IsValid && EditorError == FBPlayerEditorError.None)
                    {
                        TrySave();
                        if (EditorError == FBPlayerEditorError.None && Entity != null)
                            Response.Redirect(string.Format("FBPlayerEdit.aspx?id={0}&tabindex={1}", Entity.PlayerId.ToString(), TabControl.SelectedIndex));
                    }
                }
                break;
            case "cancel":
                GoBack();
                break;
        }
    }

    void TrySave()
    {
        if (this.editorError != FBPlayerEditorError.None)
            return;

        if (this.entity == null)
        {
            this.editorError = FBPlayerEditorError.IsNotFound;
            this.errorMessageText = GetMessageRaw("Message.PlayerIsNotFound");
            return;
        }

        try
        {
            this.entity.Name = Name.Text;
            int teamId = 0;
            if (!String.IsNullOrEmpty(TeamList.SelectedValue) && int.TryParse(TeamList.SelectedValue, out teamId))
                this.entity.TeamId = teamId;

            this.entity.Save();
            this.entityId = this.entity.PlayerId;
        }
        catch (Exception exc)
        {
            this.errorMessageText = exc.Message;
            this.editorError = this.entity.IsNew ? FBPlayerEditorError.Creation : FBPlayerEditorError.Modification;
        }
    }
}

public enum FBPlayerEditorError
{
    None = 0,
    IsNotFound = -1,
    Creation = -2,
    Modification = -3,
    Deleting = -4
}

Создадим языковой файл для нашей страницы, и добавим в него языковые фразы, которые мы использовали:

CopyXML
<?xml version="1.0" encoding="utf-8"?>
<resources>
    <data name="NotSelected"><![CDATA[-- не выбрано --]]>></data>
          <data name="PageTitle.Creation"><![CDATA[Добавление информации об игроке]]></data>
          <data name="PageTitle.Modification"><![CDATA[Редактирование информации об игроке]]></data>
          <data name="ActionText.GoBack"><![CDATA[Список игроков]]></data>
          <data name="ActionTitle.GoBack"><![CDATA[Вернуться к списку игроков]]></data>
          <data name="ActionTitle.Add"><![CDATA[Добавить информацию об игроке]]></data>
          <data name="ActionTitle.Delete"><![CDATA[Удалить информацию об игроке]]></data>
          <data name="ActionConfirmDialogText.Delete"><![CDATA[Вы действительно желаете удалить эту запись?]]></data>
          <data name="TabTitle.MainSettings"><![CDATA[Информация об игроке]]></data>
          <data name="TabText.MainSettings"><![CDATA[Основные параметры]]></data>
          <data name="FieldTooltip.Name"><![CDATA[Имя игрока]]></data>
          <data name="FieldLabel.Name"><![CDATA[Имя]]></data>
          <data name="FieldTooltip.Team"><![CDATA[Команда в которой выступает игрок]]></data>
          <data name="FieldLabel.Team"><![CDATA[Команда]]></data>
          <data name="Message.NameNotSpecified"><![CDATA[Не указано имя игрока]]></data>
          <data name="Message.PlayerIsNotFound"><![CDATA[Не удалось найти информацию об игроке]]></data>
          <data name="Error.Unauthorized"><![CDATA[Не достаточно прав для выполнения операции]]></data>
          </resources>


Страница "Список матчей"

Страница "Список матчей"
Send Feedback

В этом документе будет рассмотрено создание административной страницы "Список матчей"

Создание страницы "Список матчей"

Добавим в каталог /bitrix/admin/ новую страницу - FBMatchList.aspx. В последствии, когда страница будет написана, мы поместим ее в папку с модулем, из которой она будет копироваться в папку /bitrix/admin/ при установке.

Добавим в aspx файл следующий код:

CopyC#
<%@ Page Language="C#" AutoEventWireup="false" MasterPageFile="~/bitrix/admin/AdminMasterPage.master" CodeFile="FBMatchList.aspx.cs"
Inherits="bitrix_modules_fbinfo_Install_System_Admin_FBMatchList" %>

<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" runat="server">
    <asp:UpdatePanel ID="UpdatePanel" runat="server">

        <ContentTemplate>
        <bx:BXValidationSummary ID="ErrorMessage" runat="server" CssClass="errorSummary"
                HeaderText="<%$ Loc:Kernel.Error %>" ValidationGroup="GridView" />
            <br />
        <% if (!HasErrors)
           { %>
            <bx:BXAdminFilter ID="ItemFilter" runat="server" AssociatedGridView="ItemGrid">
                <bx:BXTextBoxFilter Key="MatchId" Text="ID" ValueType="Integer" />
                <bx:BXTextBoxStringFilter Key="FirstTeam.Name" Text="<%$ LocRaw:FilterText.FirstTeam %>"  Visibility="AlwaysVisible" />
                <bx:BXTextBoxStringFilter Key="SecondTeam.Name" Text="<%$ LocRaw:FilterText.SecondTeam %>" Visibility="AlwaysVisible" />
            </bx:BXAdminFilter>
            <bx:BXContextMenuToolbar ID="ItemListToolbar" runat="server">
                <Items>
                    <bx:BXCmSeparator SectionSeparator="true" />
                    <bx:BXCmImageButton ID="AddButton" Text="<%$ LocRaw:ActionText.Add %>" Title="<%$ LocRaw:ActionTitle.Add %>"
                        CssClass="context-button icon btn_new" Href="FBMatchEdit.aspx" />
                </Items>
            </bx:BXContextMenuToolbar>
            <bx:BXPopupPanel ID="PopupPanelView" runat="server">
                <Commands>
                    <bx:CommandItem UserCommandId="edit" Default="True" IconClass="edit" ItemText="<%$ LocRaw:PopupText.Edit %>"
                        ItemTitle="<%$ LocRaw:PopupTitle.Edit %>" OnClickScript="window.location.href = 'FBMatchEdit.aspx?id=' + UserData['MatchId']; return false;" />
                    <bx:CommandItem UserCommandId="delete" Default="False" IconClass="delete" ItemText="<%$ LocRaw:PopupText.Delete %>"
                        ItemTitle="<%$ LocRaw:PopupTitle.Delete %>" ShowConfirmDialog="true" ConfirmDialogText="<%$ LocRaw:PopupConfirmDialogText.Delete %>" />
                </Commands>
            </bx:BXPopupPanel>
            <br />
            <bx:BXGridView ID="ItemGrid" runat="server" ContentName="<%$ LocRaw:TableTitle %>"
                AllowSorting="True" AllowPaging="True" DataKeyNames="MatchId" SettingsToolbarId="ItemListToolbar"
                PopupCommandMenuId="PopupPanelView" ContextMenuToolbarId="MultiActionMenuToolbar"
                DataSourceID="ItemGrid" OnSelect="ItemGrid_Select" OnSelectCount="ItemGrid_SelectCount"
                OnDelete="ItemGrid_Delete" OnRowDataBound="ItemGrid_RowDataBound">
                <Columns>
                    <asp:BoundField DataField="MatchId" HeaderText="ID" SortExpression="MatchId" ReadOnly="True" />
                    <asp:TemplateField HeaderText="<%$ LocRaw:ColumnHeaderText.FirstTeam %>" SortExpression="FirstTeam.Name">
                        <ItemTemplate>
                            <%# ((MyCompany.FBInfo.Entities.FBMatch)Container.DataItem).FirstTeam.Name %>
                        </ItemTemplate>
                    </asp:TemplateField>
                    <asp:TemplateField HeaderText="<%$ LocRaw:ColumnHeaderText.SecondTeam %>" SortExpression="SecondTeam.Name">
                        <ItemTemplate>
                            <%# ((MyCompany.FBInfo.Entities.FBMatch)Container.DataItem).SecondTeam.Name %>
                        </ItemTemplate>
                    </asp:TemplateField>
                </Columns>
                <AjaxConfiguration UpdatePanelId="UpdatePanel" />
            </bx:BXGridView>
            <bx:BXMultiActionMenuToolbar ID="MultiActionMenuToolbar" runat="server" ValidationGroup="GridView">
                <Items>
                    <bx:BXMamImageButton CommandName="delete" ShowConfirmDialog="true" ConfirmDialogText="<%$ LocRaw:ActionConfirmDialogText.Delete %>"
                        ConfirmDialogTextAll="<%$ LocRaw:ActionConfirmDialogTextAll.Delete %>" EnabledCssClass="context-button icon delete"
                        DisabledCssClass="context-button icon delete-dis" Title="<%$ LocRaw:ActionTitle.Delete %>" />
                </Items>
            </bx:BXMultiActionMenuToolbar>
            <%} %>
        </ContentTemplate>
    </asp:UpdatePanel>
</asp:Content>

Перейдем к файлу FBMatchList.aspx.cs и добавим в него код:

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Web;
using System.Web.UI;
using System.Web.UI.WebControls;
using Bitrix.Security;
using MyCompany.FBInfo;
using MyCompany.FBInfo.Entities;
using Bitrix.UI;
using Bitrix.DataLayer;
using Bitrix.Services.Text;

public partial class bitrix_modules_fbinfo_Install_System_Admin_FBMatchList : Bitrix.UI.BXAdminPage
{
    bool hasErrors = false;

    protected bool HasErrors
    {
        get { return hasErrors; }
    }

    protected override void OnInit(EventArgs e)
    {
        base.OnInit(e);
        if (!BXPrincipal.Current.IsCanOperate(FBInfoModule.Operations.AdminManagement))
        {
            ErrorMessage.AddErrorMessage(GetMessageRaw("Error.Unauthorized"));
            hasErrors = true;
        }
    }

    protected override void OnLoad(EventArgs e)
    {
        base.OnLoad(e);
        MasterTitle = Page.Title = GetMessage("PageTitle");
    }

    protected void ItemGrid_Select(object sender, BXSelectEventArgs e)
    {
        var f = new BXFilter(ItemFilter.CurrentFilter, FBMatch.Fields);

        var matchList = FBMatch.GetList(
            f,
            new BXOrderBy(FBMatch.Fields, string.IsNullOrEmpty(e.SortExpression) ? "MatchId" : e.SortExpression),
            new BXSelectAdd(FBMatch.Fields.FirstTeam,FBMatch.Fields.SecondTeam),
            new BXQueryParams(e.PagingOptions),
            BXTextEncoder.EmptyTextEncoder
            ).ToList<FBMatch>();

        e.Data = matchList;
    }

    protected void ItemGrid_SelectCount(object sender, BXSelectCountEventArgs e)
    {
        e.Count = FBMatch.Count(new BXFilter(ItemFilter.CurrentFilter, FBMatch.Fields));
    }

    protected void ItemGrid_RowDataBound(object sender, GridViewRowEventArgs e)
    {
        if (e.Row.RowType != DataControlRowType.DataRow)
            return;

        BXGridViewRow row = (BXGridViewRow)e.Row;
        var match = (FBMatch)row.DataItem;

        row.UserData.Add("MatchId", match.MatchId);
    }

    protected void ItemGrid_Delete(object sender, BXDeleteEventArgs e)
    {
        FBMatchCollection col;
        try
        {
            BXFilter filter = (e.Keys == null)
                ? new BXFilter(ItemFilter.CurrentFilter, FBMatch.Fields)
                : new BXFilter(new BXFilterItem(FBMatch.Fields.MatchId, BXSqlFilterOperators.Equal, e.Keys["MatchId"]));
            col = FBMatch.GetList(filter, null);
        }
        catch (Exception ex)
        {
            ErrorMessage.AddErrorMessage(ex.Message);
            return;
        }
        bool errorTextAdded = false;
        foreach (var item in col)
        {
            try
            {
                item.Delete();
                e.DeletedCount++;
            }
            catch
            {
                if (!errorTextAdded)
                {
                    ErrorMessage.AddErrorMessage(GetMessage("Match.DeleteFailure"));
                    errorTextAdded = true;
                }
            }
        }
    }
}

Создадим языковой файл для страницы и добавим в него список использованных фраз:

CopyXML
<?xml version="1.0" encoding="utf-8"?>
          <resources>
            <data name="PageTitle"><![CDATA[Список матчей]]></data>
          <data name="FilterText.FirstTeam"><![CDATA[Команда 1]]></data>
          <data name="FilterText.SecondTeam"><![CDATA[Команда 2]]></data>
          <data name="ActionText.Add"><![CDATA[Новый матч]]></data>
          <data name="ActionTitle.Add"><![CDATA[Добавить информацию о матче]]></data>
          <data name="PopupText.Edit"><![CDATA[Изменить информацию о матче]]></data>
          <data name="PopupTitle.Edit"><![CDATA[Изменение информации о матче]]></data>
          <data name="PopupText.Delete"><![CDATA[Удалить информацию о матче]]></data>
          <data name="PopupTitle.Delete"><![CDATA[Удаление информации о матче]]></data>
          <data name="PopupConfirmDialogText.Delete"><![CDATA[Вы действительно хотите удалить информацию о матче?]]></data>
          <data name="ColumnHeaderText.SecondTeam"><![CDATA[Команда 2]]></data>
          <data name="ColumnHeaderText.FirstTeam"><![CDATA[Команда 1]]></data>
          <data name="ActionConfirmDialogText.Delete"><![CDATA[Вы действительно хотите удалить отмеченные записи?]]></data>
          <data name="ActionConfirmDialogTextAll.Delete"><![CDATA[Вы уверены, что хотите УДАЛИТЬ ВСЕ ЗАПИСИ из списка?]]></data>
          <data name="ActionTitle.Delete"><![CDATA[Удалить записи]]></data>
          <data name="Error.Unauthorized"><![CDATA[Не достаточно прав для выполнения операции]]></data>
          </resources>


Страница "Создание-редактирование матча"

Страница "Создание-редактирование матча"
Send Feedback

В этом документе будет рассмотрено создание страницы "Создание-Редактирование матча", реализующей типичные операции над сущностями - создание, редактирование, удаление.

Также будет показано добавление на страницу возожности редактировать набираемые свойства сущности.

Создание страницы "Создание-Редактирование матча" FBMatchEdit.aspx

Добавим в каталог /bitrix/admin/ новую страницу - FBMatchEdit.aspx. В последствии, когда страница будет написана, мы поместим ее в папку с модулем, из которой она будет копироваться в папку /bitrix/admin/ при установке.

Добавим в aspx файл следующий код:

CopyC#
<%@ Page Language="C#" MasterPageFile="~/bitrix/admin/AdminMasterPage.master"
AutoEventWireup="false" CodeFile="FBMatchEdit.aspx.cs" Inherits="bitrix_admin_FBMatchEdit" %>

<%@ Register Src="~/bitrix/controls/Main/CustomFieldList.ascx" TagName="CustomFieldList" TagPrefix="bx" %>

<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" Runat="Server">
    <bx:BXContextMenuToolbar ID="EditToolbar" runat="server" OnCommandClick="OnToolBarButtonClick">
        <Items>
            <bx:BXCmSeparator ID="ListButton" runat="server" SectionSeparator="true" />
            <bx:BXCmImageButton CssClass="context-button icon btn_list" CommandName="list"
                Text="<%$ LocRaw:ActionText.GoBack %>" Title="<%$ LocRaw:ActionTitle.GoBack %>" Href="FBMatchList.aspx" />
            <bx:BXCmSeparator SectionSeparator="true" />
            <bx:BXCmImageButton ID="AddButton" CssClass="context-button icon btn_new" CommandName="add"
                Text="<%$ LocRaw:Kernel.Add %>" Title="<%$ LocRaw:ActionTitle.Add %>" Href="FBPlayerEdit.aspx" />
            <bx:BXCmSeparator SectionSeparator="true" />
            <bx:BXCmImageButton ID="DeleteButton" CssClass="context-button icon btn_delete" CommandName="delete"
                Text="<%$ LocRaw:Kernel.Delete %>" Title="<%$ LocRaw:ActionTitle.Delete %>" ShowConfirmDialog="true" ConfirmDialogText="<%$ LocRaw:ActionConfirmDialogText.Delete %>"/>
        </Items>
    </bx:BXContextMenuToolbar>
    <bx:BXValidationSummary ID="errorMessage" runat="server" CssClass="errorSummary" HeaderText="<%$ Loc:Kernel.Error %>" ValidationGroup="Main" />
    <bx:BXTabControl ID="TabControl" runat="server" OnCommand="OnTabControlCommand" ValidationGroup="Main">
        <bx:BXTabControlTab ID="MainSettingsTab" Runat="server" Selected="True" Text="<%$ LocRaw:TabText.MainSettings %>" Title="<%$ LocRaw:TabTitle.MainSettings %>">
            <table class="edit-table" cellspacing="0" cellpadding="0" border="0">
                <% if (EntityId > 0){ %>
                <tr valign="top"><td class="field-name" width="25%">ID:</td><td width="30%"><%= EntityId.ToString() %></td></tr>
                <% } %>
                <tr class="heading">
                    <td colspan="3"><%= GetMessage("Header.Teams") %></td>
                </tr>
                <tr valign="top">
                    <td class="field-name"><span class="required">*</span><%= GetMessage("FirstTeam")%>:</td>
                    <td>
                    <asp:DropDownList ID="FirstTeamList" runat="server" >
                        </asp:DropDownList>
                        <asp:RequiredFieldValidator ID="RequiredFieldValidator2" runat="server" ValidationGroup="Main"
                        ControlToValidate="FirstTeamList" ErrorMessage="<%$ Loc:Message.FirstTeamNotSpecified %>" Display="Dynamic">*</asp:RequiredFieldValidator>
                    </td>
                </tr>
                <tr valign="top">
                    <td class="field-name"><span class="required">*</span><%=  GetMessage("SecondTeam")%>:</td>
                    <td>
                        <asp:DropDownList ID="SecondTeamList" runat="server" >
                        </asp:DropDownList>
                        <asp:RequiredFieldValidator ID="RequiredFieldValidator3" runat="server" ValidationGroup="Main"
                        ControlToValidate="SecondTeamList" ErrorMessage="<%$ Loc:Message.SecondTeamNotSpecified %>" Display="Dynamic">*</asp:RequiredFieldValidator>
                        <asp:CompareValidator runat="server" ID="SecondTeamListCV" ErrorMessage="<%$ Loc:Message.MatchWithSameTeam %>" Operator="NotEqual"
                        ControlToValidate="SecondTeamList" ControlToCompare="FirstTeamList" ValidationGroup="Main"></asp:CompareValidator>
                    </td>
                </tr>
                <tr class="heading">
                    <td colspan="3"><%= GetMessage("Header.Goals") %></td>
                </tr>
                <tr valign="top" title="<%= GetMessage("FieldTooltip.Goals") %>">
                    <td class="field-name"><span class="required">*</span><%= GetMessage("FirstTeam")%>:</td>
                    <td>
                        <asp:TextBox ID="FirstTeamGoals" runat="server" Width="50px" />
                        <asp:RequiredFieldValidator ID="FirstTeamGoalsRFV" runat="server" ValidationGroup="Main"
                        ControlToValidate="FirstTeamGoals" ErrorMessage="<%$ Loc:Message.GoalNotSpecified %>" Display="Dynamic">*</asp:RequiredFieldValidator>
                        <asp:RegularExpressionValidator ID="FirstTeamGoalsRV" runat="server" ValidationGroup="Main"
                        ControlToValidate="FirstTeamGoals" ValidationExpression="^[1-9][0-9]*$" ErrorMessage="<%$ Loc:Message.GoalIsNotNumber %>"
                        Display="Dynamic">*</asp:RegularExpressionValidator>
                    </td>
                    <td></td>
                </tr>
                <tr>
                    <td class="field-name"><span class="required">*</span><%=GetMessage("SecondTeam")%>:</td>
                    <td>
                        <asp:TextBox ID="SecondTeamGoals" runat="server" Width="50px" />
                        <asp:RequiredFieldValidator ID="SecondTeamGoalsRFV" runat="server" ValidationGroup="Main"
                        ControlToValidate="SecondTeamGoals" ErrorMessage="<%$ Loc:Message.GoalNotSpecified %>" Display="Dynamic">*</asp:RequiredFieldValidator>
                        <asp:RegularExpressionValidator ID="SecondTeamGoalsRV" runat="server" ValidationGroup="Main"
                        ControlToValidate="SecondTeamGoals" ValidationExpression="^[1-9][0-9]*$" ErrorMessage="<%$ Loc:Message.GoalIsNotNumber %>"
                        Display="Dynamic">*</asp:RegularExpressionValidator>
                    </td>
                    <td></td>
                </tr>
                <tr class="heading">
                    <td colspan="3"><%= GetMessage("Header.Additional") %></td>
                </tr>
                <tr>
                    <td class="field-name"><span class="required">*</span><%=GetMessage("Location")%>:</td>
                    <td><asp:TextBox ID="Location" runat="server" Width="350px" />
                    <asp:RequiredFieldValidator ID="RequiredFieldValidator1" runat="server" ValidationGroup="Main"
                        ControlToValidate="Location" ErrorMessage="<%$ Loc:Message.LocationNotSpecified %>" Display="Dynamic">*</asp:RequiredFieldValidator>
                    </td>
                </tr>

            </table>
        </bx:BXTabControlTab>
        <bx:BXTabControlTab ID="BXTabControlTab1" Runat="server" Text="<%$ LocRaw:TabText.CustomFields %>" Title="<%$ LocRaw:TabTitle.CustomFields %>">
        <table class="edit-table" cellspacing="0" cellpadding="0" border="0">
            <%
                if (CustomFieldList.HasItems)
                {
                %>
                <tr valign="top">
                    <td colspan="2" align="center">
                        <asp:UpdatePanel ID="UpdatePanel2" runat="server" UpdateMode="Conditional">
                        <ContentTemplate>
                            <bx:CustomFieldList ID="CustomFieldList" runat="server" EditMode="false" ValidationGroup="Main" />
                        </ContentTemplate>
                        </asp:UpdatePanel>
                    </td>
                </tr>
                <%
                }
                %>
        </table>
        </bx:BXTabControlTab>
    </bx:BXTabControl>

</asp:Content>

Рассмотрим подробно код, подключающий редактирование набираемых свойств:

CopyC#
<table class="edit-table" cellspacing="0" cellpadding="0" border="0">
    <%
      if (CustomFieldList.HasItems)
      {
      %>
      <tr valign="top">
          <td colspan="2" align="center">
              <asp:UpdatePanel ID="UpdatePanel2" runat="server" UpdateMode="Conditional">
              <ContentTemplate>
                  <bx:CustomFieldList ID="CustomFieldList" runat="server" EditMode="false" ValidationGroup="Main" />
              </ContentTemplate>
              </asp:UpdatePanel>
          </td>
      </tr>
      <%
      }
      %>
</table>

Контрол BXCustomFieldList предоставляет удобное средство для редактирования набираемых свойств сущности. Он выводит их список, и после редактирования предоставляет коллекцию набираемых свойств с заполненными значениями. Для организации работы необходимо разместить контрол на странице, что мв и сделали. Рассмотрим далее код файла FBMatchEdit.aspx.cs и работу с контролом в нем:

CopyC#
using System;
using System.Collections.Generic;
using System.Web;
using System.Web.UI;
using System.Web.UI.WebControls;
using Bitrix.UI;
using System.Text;
using Bitrix.Security;
using Bitrix.Services;
using MyCompany.FBInfo.Entities;
using Bitrix.DataLayer;
using MyCompany.FBInfo;
using Bitrix;

public partial class bitrix_admin_FBMatchEdit : BXAdminPage
{
    List<FBTeam> allTeams;

    List<FBTeam> AllTeams
    {
        get
        {
            if (allTeams != null)
                return allTeams;
            return allTeams = FBTeam.GetList(null, new BXOrderBy(new BXOrderByPair(FBTeam.Fields.Name, BXOrderByDirection.Asc)));
        }
    }

    protected override void OnInit(EventArgs e)
    {
        base.OnInit(e);

        if (!BXPrincipal.Current.IsCanOperate(FBInfoModule.Operations.AdminManagement))
        {
            this.editorError = FBMatchEditorError.Unauthorized;
            this.errorMessageText = GetMessageRaw("Error.Unauthorized");
            return;
        }

        if (EntityId == 0)
            this.entity = new FBMatch();
        else
            {

                FBMatchCollection matchCol = FBMatch.GetList(
                        new BXFilter(new BXFilterItem(FBMatch.Fields.MatchId, BXSqlFilterOperators.Equal, EntityId)),
                        null,
                        new BXSelectAdd(FBMatch.Fields.CustomFields.DefaultFields, FBMatch.Fields.FirstTeam, FBMatch.Fields.SecondTeam),
                        null);

                if (matchCol.Count == 0)
                {

                    this.editorError = FBMatchEditorError.IsNotFound;
                    this.errorMessageText = GetMessageRaw("Message.MatchIsNotFound");
                    return;
                }

                entity = matchCol[0];
            }

        FirstTeamList.Items.Add(new ListItem(GetMessageRaw("NotSelected"), string.Empty));
        SecondTeamList.Items.Add(new ListItem(GetMessageRaw("NotSelected"), string.Empty));

        foreach (var team in AllTeams)
        {
            FirstTeamList.Items.Add(new ListItem(team.Name, team.TeamId.ToString()));
            SecondTeamList.Items.Add(new ListItem(team.Name, team.TeamId.ToString()));
        }

        CustomFieldList.EntityId = FBMatch.GetCustomFieldsKey();

        CustomFieldList.Load(entity.CustomValues);
    }

    FBMatch entity;

    protected FBMatch Entity
    {
        get { return this.entity; }
    }

    int? entityId = null;
    protected int EntityId
    {
        get
        {
            if (this.entityId.HasValue)
                return entityId.Value;

            string str = Request.QueryString["id"];
            if (string.IsNullOrEmpty(str))
                this.entityId = 0;
            else
            {
                try
                {
                    this.entityId = Convert.ToInt32(Request.QueryString["id"]);
                }
                catch
                {
                    this.entityId = 0;
                }
            }
            return this.entityId.Value;
        }
    }

    public string FirstTeamName
    {
        get
        {
            return (entity != null && entity.FirstTeam != null ? entity.FirstTeam.Name : GetMessage("FirstTeam"));
        }
    }

    public string SecondTeamName
    {
        get
        {
            return (entity != null && entity.SecondTeam !=null ? entity.SecondTeam.Name : GetMessage("SecondTeam"));
        }
    }

    protected override void OnLoad(EventArgs e)
    {
        base.OnLoad(e);

        MasterTitle = Page.Title = EntityId == 0 ? GetMessage("PageTitle.Creation") : string.Concat(GetMessage("PageTitle.Modification"), " #", EntityId.ToString());

        if (!IsPostBack)
        {

            if (!this.entity.IsNew)
            {
                FirstTeamGoals.Text = Entity.FirstTeamGoals.ToString();
                SecondTeamGoals.Text = Entity.SecondTeamGoals.ToString();
                Location.Text = Entity.Location;

                ListItem teamItem = FirstTeamList.Items.FindByValue(this.entity.FirstTeamId.ToString());
                if (teamItem != null)
                    teamItem.Selected = true;

                teamItem = SecondTeamList.Items.FindByValue(this.entity.SecondTeamId.ToString());
                if (teamItem != null)
                    teamItem.Selected = true;
            }
        }
    }

    protected override void OnPreRender(EventArgs e)
    {
        base.OnPreRender(e);

        if (EditorError != FBMatchEditorError.None)
        {
            errorMessage.AddErrorMessage(ErrorMessageText);
            if (EntityId > 0 && EditorError == FBMatchEditorError.IsNotFound)
                TabControl.Visible = false;
        }
    }

    private string errorMessageText = string.Empty;
    protected string ErrorMessageText
    {
        get { return this.errorMessageText; }
    }

    private FBMatchEditorError editorError = FBMatchEditorError.None;
    protected FBMatchEditorError EditorError
    {
        get { return this.editorError; }
    }

    protected void OnToolBarButtonClick(object sender, CommandEventArgs e)
    {
        if (e.CommandName == "delete")
        {
            try
            {
                if (Entity != null)
                    Entity.Delete();

                GoBack("~/bitrix/admin/FBMatchList.aspx");
            }
            catch (Exception ex)
            {
                this.errorMessageText = ex.Message;
                this.editorError = FBMatchEditorError.Deleting;
            }
        }
    }

    protected void OnTabControlCommand(object sender, BXTabControlCommandEventArgs e)
    {
        switch (e.CommandName)
        {
            case "save":
                {
                    if (IsValid && EditorError == FBMatchEditorError.None)
                    {
                        TrySave();
                        if (EditorError == FBMatchEditorError.None)
                            GoBack("~/bitrix/admin/FBMatchList.aspx");
                    }
                }
                break;
            case "apply":
                {
                    if (IsValid && EditorError == FBMatchEditorError.None)
                    {
                        TrySave();
                        if (EditorError == FBMatchEditorError.None && Entity != null)
                            Response.Redirect(string.Format("FBMatchEdit.aspx?id={0}&tabindex={1}", Entity.MatchId.ToString(), TabControl.SelectedIndex));
                    }
                }
                break;
            case "cancel":
                GoBack();
                break;
        }
    }

    void TrySave()
    {
        if (this.editorError != FBMatchEditorError.None)
            return;

        if (this.entity == null)
        {
            this.editorError = FBMatchEditorError.IsNotFound;
            this.errorMessageText = GetMessageRaw("Message.MatchIsNotFound");
            return;
        }

        try
        {
            this.entity.Location = Location.Text;

            byte i = 0;
            if (byte.TryParse(FirstTeamGoals.Text, out i))
                this.entity.FirstTeamGoals = i;

            if (byte.TryParse(SecondTeamGoals.Text, out i))
                this.entity.SecondTeamGoals = i;

            this.entity.CreatedBy = (BXPrincipal.Current.Identity as BXIdentity).User.UserId;

            int teamId = 0;

            if (!String.IsNullOrEmpty(FirstTeamList.SelectedValue) && int.TryParse(FirstTeamList.SelectedValue, out teamId))
                this.entity.FirstTeamId = teamId;

            if (!String.IsNullOrEmpty(SecondTeamList.SelectedValue) && int.TryParse(SecondTeamList.SelectedValue, out teamId))
                this.entity.SecondTeamId = teamId;

            if (CustomFieldList.HasItems)
                this.entity.CustomValues.Override(CustomFieldList.Save());

            this.entity.Save();
            this.entityId = this.entity.MatchId;
        }
        catch (Exception exc)
        {
            this.errorMessageText = exc.Message;
            this.editorError = this.entity.IsNew ? FBMatchEditorError.Creation : FBMatchEditorError.Modification;
        }
    }
}

public enum FBMatchEditorError
{
    None = 0,
    IsNotFound = -1,
    Creation = -2,
    Modification = -3,
    Deleting = -4,
    Unauthorized = -5
}

В методе OnInit появился следующий фрагмент кода:

CopyC#
CustomFieldList.EntityId = FBMatch.GetCustomFieldsKey();

CustomFieldList.Load(entity.CustomValues);

Здесь выполняется привязка контрола BXCustomFieldList к сущности FBMatch, а затем вызывается метод CustomFieldList.Load для загрузки значений набираемых свойств сущности в контрол.

Для сохранения набираемых свойств в методе TrySave коллекция CustomValues сущности заполняется значениями из контрола:

CopyC#
if (CustomFieldList.HasItems)
this.entity.CustomValues.Override(CustomFieldList.Save());
Примечание:
В момент выполнения this.entity.CustomValues.Override(CustomFieldList.Save()) не происходит сохранения набираемых свойств. Чтобы они сохранились, нужно вызвать метод entity.Save()

Создадим языковой файл для нашей страницы, и добавим в него языковые фразы, которые мы использовали:

CopyXML
<?xml version="1.0" encoding="utf-8"?>
 <resources>
   <data name="PageTitle.Creation"><![CDATA[Добавление информации о матче]]></data>
 <data name="PageTitle.Modification"><![CDATA[Редактирование информации о матче]]></data>
 <data name="ActionText.GoBack"><![CDATA[Список матчей]]></data>
 <data name="NotSelected"><![CDATA[-- не выбрано --]]></data>
 <data name="ActionTitle.GoBack"><![CDATA[Вернуться к списку матче]]></data>
 <data name="ActionTitle.Add"><![CDATA[Добавить информацию о матче]]></data>
 <data name="ActionTitle.Delete"><![CDATA[Удалить информацию о матче]]></data>
 <data name="ActionConfirmDialogText.Delete"><![CDATA[Вы действительно желаете удалить эту запись?]]></data>
 <data name="TabTitle.MainSettings"><![CDATA[Информация о матче]]></data>
 <data name="TabText.MainSettings"><![CDATA[Основные параметры]]></data>
 <data name="FieldToolTop.Goals"><![CDATA[Информация о забитых голах]]></data>
 <data name="Header.Goals"><![CDATA[Голы в матче]]></data>
 <data name="Message.GoalNotSpecified"><![CDATA[Не указано число голов]]></data>
 <data name="Message.GoalIsNotNumber"><![CDATA[Значение поля должно быть целым числом]]></data>
 <data name="Message.MatchIsNotFound"><![CDATA[Не удалось найти информацию о матче]]></data>
 <data name="Error.Unauthorized"><![CDATA[Не достаточно прав для выполнения операции]]></data>
 <data name="FirstTeam"><![CDATA[Первая команда]]></data>
 <data name="SecondTeam"><![CDATA[Вторая команда]]></data>
 <data name="Header.Teams"><![CDATA[Команды]]></data>
 <data name="Header.Additional"><![CDATA[Дополнительно]]></data>
 <data name="Header.CustomFields"><![CDATA[Пользовательские поля]]></data>
 <data name="TabText.CustomFields"><![CDATA[Пользовательские поля]]></data>
 <data name="Tabtitle.CustomFields"><![CDATA[Пользовательские поля]]></data>
 <data name="Location"><![CDATA[Место проведения матча]]></data>
 <data name="Message.LocationNotSpecified"><![CDATA[Не указано место проведения матча]]></data>
 <data name="Message.MatchWithSameTeam"><![CDATA[Команды матча должны быть различными]]></data>
 <data name="Message.FirstTeamNotSpecified"><![CDATA[Не указана первая команда]]></data>
 <data name="Message.SecondTeamNotSpecified"><![CDATA[Не указана вторая команда]]></data>
 </resources>


Отображение страниц в меню

Отображение страниц в меню
Send Feedback

В этом документе будет рассмотрена последовательность действий, которую необходимо выполнить для отображения созданных страниц в административном меню.

Отображение административных страниц в меню

Построение административного меню основано на событиях. Когда меню должно быть показано пользователю, система генерирует событие с именем Bitrix.Modules.BXAdminMenuManager.OnBuildAdminMenu. После генерации (отправки) события у подписанных на событие классов вызывается метод ReceiveMessage, в котором классы добавляют в результат вызова события элементы меню.

Для того, чтобы административные страницы появились в меню, нам необходимо выполнить ряд операций:

  1. Пометим класс FBInfoModule атрибутом BXMessageReceiver с указанием имени события, которое нужно обработать:

    CopyC#
    [BXModuleAsEventListener("Bitrix.Modules.BXAdminMenuManager.OnBuildAdminMenu", "FBInfo")]
public class FBInfoModule: BXModule

    Вторым аргументом атрибута указано имя модуля.

  2. В методе ReceiveMessage вызовем обработчик создания меню:

    CopyC#
    public override void ReceiveMessage(BXCommand command)
{
    switch (command.Action.ToLowerInvariant())
    {
        case "bitrix.modules.bxadminmenumanager.onbuildadminmenu":
            command.AddCommandResult(this.GetType().FullName, new BXCommandResult(BXCommandResultType.Ok, this.GetAdminMenu()));
            break;
    }
}

    Метод AddCommandResult(String, BXCommandResult) добавляет результат обработки события BXCommandResult, который содержит в себе статус выполнения обработки BXCommandResultType и коллекцию пунктов административного меню, которую мы создадим в методе GetAdminMenu.

  3. Реализуем непосредственную обработку события создания меню (метод GetAdminMenu)

    CopyC#
    public BXAdminMenuItemCollection GetAdminMenu()
    {
        BXAdminMenuItemCollection collection = new BXAdminMenuItemCollection();

  // проверим права на доступ к административной части модуля
        if (BXPrincipal.Current.IsCanOperate(Operations.AdminManagement))
        {
    // добавляем корневой элемент меню ( раздел ), который сгруппирует все страницы модуля
            BXAdminMenuItem item = new BXAdminMenuItem(FBInfoModuleConfiguration.Id, GetMessage("FBinfo.Menu.Section.Title"), "/bitrix/admin/FBMatchList.aspx", "global_menu_services");
            item.ModuleId = this.ModuleId;
    // установка значков меню
            item.Icon = "fbinfo_menu_icon";
            item.PageIcon = "fbinfo_page_icon";
            collection.Add(item);
    // добавление страницы "Список Матчей"
            collection.Add(
                new BXAdminMenuItem(
                    "fbmatch_list",
                    GetMessage("FBInfo.Menu.Match.List"),
                    "/bitrix/admin/FBMatchList.aspx",
                    FBInfoModuleConfiguration.Id,
                    new string[] { "/bitrix/admin/FBMatchEdit.aspx" },
                    10,
                    false,
                    this.ModuleId
                )
            );
    // добавление страницы "Список игроков"
            collection.Add(
                new BXAdminMenuItem(
                    "fbplayer_list",
                    GetMessage("FBInfo.Menu.Player.List"),
                    "/bitrix/admin/FBPlayerList.aspx",
                    FBInfoModuleConfiguration.Id,
                    new string[] { "/bitrix/admin/FBPlayerEdit.aspx" },
                    20,
                    false,
                    this.ModuleId
                )
            );

        }

        return collection;
    }

    Класс BXAdminMenuItem описывает пункт административного меню.

    Конструктор класса выглядит следующим образом:

    CopyC#
    BXAdminMenuItem(string itemID, string title, string url, string parentItem)

    где:

    • string ItemID - идентификатор пункта меню
    • string title - название пункта меню
    • string url - адрес, на который ссылается пункт
    • string parentItem - идентификатор родительского пункта

    При добавлении дочерних страниц мы воспользовались другой перегрузкой конструктора BXAdminMenuItem:

    CopyC#
    BXAdminMenuItem(string itemID, string title, string url, string parentItem, string[] additionalUrls, int sort, bool dynamic, string moduleID)

    в котором к уже описанным добавились параметры:

    • string[] additionalUrls - дополнительные адреса, на которых раскрывать данный пункт меню. В нашем случае для каждой страницы списка в дополнительных адресах мы указали соответствующую страницу создания-редактирования.
    • int sort - сортировка пункта
    • bool dynamic - если установлено в true, пункт меню будет подгружать список своих потомков по требованию.
    • string moduleID - идентификатор модуля

    За отображение иконок пунктов отвечают свойства Icon ( иконка в меню ) и PageIcon ( крупная иконка в списке пунктов меню раздела ):

    Иконки в административной части

    Эти свойства задают ID HTML-элемента - ссылки, на которую с помощью CSS накладывается изображение иконки.


Создание компонентов

Создание компонентов
Send Feedback

Создание компонента подробно описано в теме Создание простого компонента. В этой секции будет рассмотрено создание двух компонентов, реализующих функиональность модуля в публичной части.

Создание компонентов модуля "Футбольные матчи"

  • Список футбольных матчей
  • Футбольный матч детально
  • Использование набираемых свойств
  • Организация взаимодействия между компонентами


Список футбольных матчей

Список футбольных матчей
Смотри также Send Feedback

Необходимо создать компонент, выводящий список футбольных матчей в публичной части сайта. Настройки компонента должны включать в себя сортировку и настройки постраничной навигации.

Создание класса компонента

  1. В component.ascx.cs, согласно рекомендациям, переименуем класс компонента в MatchListComponent и укажем для него namespace MyCompany.FBInfo. Укажем родительский класс компонента - BXComponent. После этого файл должен выглядеть следующим образом:

    CopyC#
    using System;
using System.Collections.Generic;
using System.Linq;
using System.Web;
using System.Web.UI;
using System.Web.UI.WebControls;
using Bitrix.UI;
using MyCompany.FBInfo;
using Bitrix.Components;
using MyCompany.FBInfo.Entities;

namespace MyCompany.FBInfo
{

public partial class MatchListComponent : BXComponent
{

protected void Page_Load(object sender, EventArgs e)
{
}
}
}

    Исправим далее имя класса-предка в атрибуте Inherits в файле component.ascx на "FBInfo.MatchListComponent":

    CopyC#
    <%@ Control="" Language="C#" AutoEventWireup="true" CodeFile="component.ascx.cs" Inherits="FBInfo.MatchListComponent" %>

  2. Добавим описание компонента (метод PreLoadComponentDefinition()()()()). Нам необходимо добавить стандартное описание, а также параметры:

    • Поле сотировки
    • Направление сортировки
    • Настройки постраничной навигации - количество записей на странице, порядок наполнения страниц и тд.

    Работа с параметрами подробно описана в теме Описание компонента. Рассмотрим код метода PreLoadComponentDefinition()()()():
    CopyC#
            protected override void PreLoadComponentDefinition()
  {
      Title = GetMessageRaw("Title");
      Description = GetMessageRaw("Description");
      Icon = "images/icon.gif";
      Group = FBInfoModule.FBInfoModuleConfiguration.GetComponentGroup();

//ссылка на страницу детального просмотра матча
      ParamsDefinition.Add(
          "DetailUrl",
          new BXParamText(
              GetMessageRaw("Param.DetailUrl"),
              "detail.aspx?match=#MatchId#",
              BXCategory.Main
              )
          );

      // Поле для сортировки матчей
      ParamsDefinition.Add(
          "SortField",
          new BXParamSingleSelection(
              GetMessageRaw("Param.SortField"),
              "MatchId",
              BXCategory.Main
              )
      );
      // направление сортировки матчей
      ParamsDefinition.Add(
          "SortDirection",
          new BXParamSingleSelection(
              GetMessageRaw("Param.SortDirection"),
              "DESC",
              BXCategory.Main
              )
      );

      ParamsDefinition.Add(BXParametersDefinition.Paging);

      BXParametersDefinition.SetPaging(ParamsDefinition, ClientID, BXParametersDefinition.PagingParamsOptions.DisableLoad | BXParametersDefinition.PagingParamsOptions.DisableShowAll);
      BXParametersDefinition.SetPagingUrl(ParamsDefinition, ClientID, BXParametersDefinition.PagingParamsOptions.DisableLoad | BXParametersDefinition.PagingParamsOptions.DisableShowAll);
  }

    Мы создали три параметра - два выпадающих списка с одиночным выбором и параметр-строку, а также добавили в список параметры постраничной навигации, которые для удобства работы вынесены в отдельную группу BXParametersDefinition.Paging.

  3. Далее в методе LoadComponentDefinition()()()() мы должны заполнить выпадающие списки значениями и установить настройки постраничной навигации:

    CopyC#
    protected override void LoadComponentDefinition()
      {
          // направления сортировки
          ParamsDefinition["SortDirection"].Values = new List<BXParamValue>
          {
              new BXParamValue(GetMessage("Param.SortDirection.Asc"), "ASC"),
              new BXParamValue(GetMessage("Param.SortDirection.Desc"), "DESC")
          };

          // поля сортировки
          ParamsDefinition["SortField"].Values = new List<BXParamValue>
          {
              new BXParamValue(GetMessage("Param.SortField.MatchId"),"MatchId"),
              new BXParamValue(GetMessage("Param.SortField.BeginTime"),"BeginTime")
          };

          BXParametersDefinition.SetPaging(ParamsDefinition, ClientID, BXParametersDefinition.PagingParamsOptions.DisablePreLoad | BXParametersDefinition.PagingParamsOptions.DisableShowAll);
          BXParametersDefinition.SetPagingUrl(ParamsDefinition, ClientID, BXParametersDefinition.PagingParamsOptions.DisablePreLoad | BXParametersDefinition.PagingParamsOptions.DisableShowAll);
      }

  4. Дополним код компонента вспомогательным классом-оберткой над классом сущности FBMatch, который кроме самой сущности матча будет содержать ссылку на страницу детального просмотра, а также строку, содержащую дату матча.

    CopyC#
    public class MatchWrapper
    {
        FBMatch match;
        string detailUrl;
        string beginDateString;

        public MatchWrapper(FBMatch match, string detailUrl)
        {
            if (match == null)
                throw new ArgumentException("match");

            this.match = match;
            this.detailUrl = detailUrl;
        }

        public FBMatch Match
        {
            get { return match; }
            set
            {
                if (value == null)
                    throw new ArgumentException("value");
                match = value;
            }
        }

        public string DetailUrl
        {
            get { return detailUrl; }
            set { detailUrl = value; }
        }

        public string BeginDateString
        {
            get
            {
                return beginDateString ?? (beginDateString = match.BeginTime != null ? match.BeginTime.ToShortDateString() : String.Empty);
            }
         }
}

  5. Рассмотрим метод Page_Load, в котором происходит основная работа компонента:

    CopyC#
    protected void Page_Load(object sender, EventArgs e)
      {

          if (!BXPrincipal.Current.IsCanOperate(FBInfoModule.Operations.PublicView))
          {
              Errors.Add(GetMessage("Error.Unauthorized"));
          }

          BXPagingParams pagingParams = PreparePagingParams();

          bool legal;
          BXParamsBag<object> replace = new BXParamsBag<object>();
          int count = FBMatch.Count(null);

          BXQueryParams queryParams = PreparePaging(
              pagingParams,
              delegate
              {
                  return count;
              },
              replace,
              out legal
          );
          if (!legal)
          {
              Errors.Add(GetMessage("Error.InvalidPage"));
              return;
          }

          var orderBy = new BXOrderBy(FBMatch.Fields, SortField + " " + SortDirection);
          var matchesCollection = FBMatch.GetList(null, orderBy, new BXSelectAdd(FBMatch.Fields.FirstTeam, FBMatch.Fields.SecondTeam), queryParams);

          replace.Clear();
          matches = new List<MatchWrapper>();
          foreach (var match in matchesCollection)
          {
              replace["MatchId"] = match.MatchId;
              var wrapper = new MatchWrapper(match, ResolveTemplateUrl(DetailUrl, replace));
              matches.Add(wrapper);
          }

          IncludeComponentTemplate();
      }

    В начале метода проверяем права пользователя на просмотр матчей в публичной части:

    CopyC#
    if (!BXPrincipal.Current.IsCanOperate(FBInfoModule.Operations.PublicView))
{
Errors.Add(GetMessage("Error.Unauthorized"));
}

    далее выполняем операции по подготовке постаничной навигации:

    CopyC#
    BXPagingParams pagingParams = PreparePagingParams();

bool legal;
BXParamsBag<object>
  replace = new BXParamsBag<object>();
      int count = FBMatch.Count(null);

      BXQueryParams queryParams = PreparePaging(
          pagingParams,
          delegate
          {
              return count;
          },
          replace,
          out legal
      );
      if (!legal)
      {
          Errors.Add(GetMessage("Error.InvalidPage"));
          return;
      }

    Метод PreparePagingParams()()()() создает экземпляр класса BXComponent и заполняет его значениями из параметров компонента и входных данных:

    CopyC#
    BXPagingParams pagingParams = PreparePagingParams();

    Далее необходимо получить общее количество матчей, чтобы определить допустимый диапазон страниц:

    CopyC#
    int count = FBMatch.Count(null);

    Метод PreparePaging()()()() создает экземпляр класса BXQueryParams и определяет допустимость текущей страницы:

    CopyC#
    BXQueryParams queryParams = PreparePaging(
pagingParams,
delegate
{
return count;
},
replace,
out legal
);
if (!legal)
{
Errors.Add(GetMessage("Error.InvalidPage"));
return;
}

    Далее выполняется собственно выборка необходимых элементов с использованием метода GetList()()()() и заполнения списка объектов-оберток для матчей:

    CopyC#
    var orderBy = new BXOrderBy(FBMatch.Fields, SortField + " " + SortDirection);
      var matchesCollection = FBMatch.GetList(null, orderBy, new BXSelectAdd(FBMatch.Fields.FirstTeam, FBMatch.Fields.SecondTeam), queryParams);

      replace.Clear();
      matches = new List<MatchWrapper>();
      foreach (var match in matchesCollection)
      {
          replace["MatchId"] = match.MatchId;
          var wrapper = new MatchWrapper(match, ResolveTemplateUrl(DetailUrl, replace));
          matches.Add(wrapper);
      }

    Полный листинг файла component.ascx.cs:

    CopyC#
    using System;
using System.Collections.Generic;
using System.Linq;
using System.Web;
using System.Web.UI;
using System.Web.UI.WebControls;
using Bitrix.UI;
using FBInfo;
using FBInfo.Entities;
using Bitrix.Components;
using Bitrix.DataLayer;
using Bitrix.DataTypes;
using Bitrix.Security;

namespace FBInfo
{

    public partial class MatchListComponent : BXComponent
    {

        List<MatchWrapper> matches;

        List<string> errors;

        public IList<string> Errors
        {
            get { return errors ?? (errors = new List<string>()); }
        }

        public IList<MatchWrapper> Matches
        {
            get { return matches; }
        }

        protected void Page_Load(object sender, EventArgs e)
        {

            if (!BXPrincipal.Current.IsCanOperate(FBInfoModule.Operations.PublicView))
            {
                Errors.Add(GetMessage("Error.Unauthorized"));
            }

            BXPagingParams pagingParams = PreparePagingParams();

            bool legal;
            BXParamsBag<object> replace = new BXParamsBag<object>();
            int count = FBMatch.Count(null);

            BXQueryParams queryParams = PreparePaging(
                pagingParams,
                delegate
                {
                    return count;
                },
                replace,
                out legal
            );
            if (!legal)
            {
                Errors.Add(GetMessage("Error.InvalidPage"));
                return;
            }

            var orderBy = new BXOrderBy(FBMatch.Fields, SortField + " " + SortDirection);
            var matchesCollection = FBMatch.GetList(null, orderBy, new BXSelectAdd(FBMatch.Fields.FirstTeam, FBMatch.Fields.SecondTeam), queryParams);

            replace.Clear();
            matches = new List<MatchWrapper>();
            foreach (var match in matchesCollection)
            {
                replace["MatchId"] = match.MatchId;
                var wrapper = new MatchWrapper(match, ResolveTemplateUrl(DetailUrl, replace));
                matches.Add(wrapper);
            }

            IncludeComponentTemplate();
        }

        string SortField
        {
            get { return Parameters.GetString("SortField", String.Empty); }
        }

        string SortDirection
        {
            get { return Parameters.GetString("SortDirection", String.Empty); }
        }

        public string DetailUrl
        {
            get { return Parameters.GetString("DetailUrl", String.Empty); }
        }

        protected override void PreLoadComponentDefinition()
        {
            Title = GetMessageRaw("Title");
            Description = GetMessageRaw("Description");
            Icon = "images/icon.gif";
            Group = FBInfoModule.FBInfoModuleConfiguration.GetComponentGroup();

            ParamsDefinition.Add(
                "DetailUrl",
                new BXParamText(
                    GetMessageRaw("Param.DetailUrl"),
                    "detail.aspx?match=#MatchId#",
                    BXCategory.Main
                    )
                );

            // Поле для сортировки матчей
            ParamsDefinition.Add(
                "SortField",
                new BXParamSingleSelection(
                    GetMessageRaw("Param.SortField"),
                    "MatchId",
                    BXCategory.Main
                    )
            );
            // направление сортировки матчей
            ParamsDefinition.Add(
                "SortDirection",
                new BXParamSingleSelection(
                    GetMessageRaw("Param.SortDirection"),
                    "DESC",
                    BXCategory.Main
                    )
            );

            ParamsDefinition.Add(BXParametersDefinition.Paging);

            BXParametersDefinition.SetPaging(ParamsDefinition, ClientID, BXParametersDefinition.PagingParamsOptions.DisableLoad | BXParametersDefinition.PagingParamsOptions.DisableShowAll);
            BXParametersDefinition.SetPagingUrl(ParamsDefinition, ClientID, BXParametersDefinition.PagingParamsOptions.DisableLoad | BXParametersDefinition.PagingParamsOptions.DisableShowAll);
        }

        protected override void LoadComponentDefinition()
        {
            // направления сортировки
            ParamsDefinition["SortDirection"].Values = new List<BXParamValue>
            {
                new BXParamValue(GetMessage("Param.SortDirection.Asc"), "ASC"),
                new BXParamValue(GetMessage("Param.SortDirection.Desc"), "DESC")
            };

            // поля сортировки
            ParamsDefinition["SortField"].Values = new List<BXParamValue>
            {
                new BXParamValue(GetMessage("Param.SortField.MatchId"),"MatchId"),
                new BXParamValue(GetMessage("Param.SortField.BeginTime"),"BeginTime")
            };

            BXParametersDefinition.SetPaging(ParamsDefinition, ClientID, BXParametersDefinition.PagingParamsOptions.DisablePreLoad | BXParametersDefinition.PagingParamsOptions.DisableShowAll);
            BXParametersDefinition.SetPagingUrl(ParamsDefinition, ClientID, BXParametersDefinition.PagingParamsOptions.DisablePreLoad | BXParametersDefinition.PagingParamsOptions.DisableShowAll);
        }
    }

    public class MatchWrapper
    {
        FBMatch match;
        string detailUrl;
        string beginDateString;

        public MatchWrapper(FBMatch match, string detailUrl)
        {
            if (match == null)
                throw new ArgumentException("match");

            this.match = match;
            this.detailUrl = detailUrl;
        }

        public FBMatch Match
        {
            get { return match; }
            set
            {
                if (value == null)
                    throw new ArgumentException("value");
                match = value;
            }
        }

        public string DetailUrl
        {
            get { return detailUrl; }
            set { detailUrl = value; }
        }

        public string BeginDateString
        {
            get
            {
                return beginDateString ?? (beginDateString = match.BeginTime != null ? match.BeginTime.ToShortDateString() : String.Empty);
            }
         }
    }
}

Создание шаблона компонента

Шаблон компонента представляет собой отдельный элемент управления ascx (контрол), производный от класса BXComponentTemplate.

Основная задача шаблона - вывести данные в удобном пользователю виде, а также предоставить пользователю способ взаимодействия с компонентом при помощи форм, кнопок, и тд. Компонент может иметь любое количество шаблонов, которые могут выводить данныеи элементы управления с использованием разной HTML-разметки, стилей, и тд.

Процесс создания шаблона подробно описан в теме Создание шаблона компонента

Создание шаблона компонента

  1. В папке /components/fbinfo/match.list/ создадим папку templates. Эта папка содержит шаблоны компонента.

  2. В созданной папке templates создадим папку .default. В этой папке создадим новый элемент управления (ascx контрол) с именем template.ascx и codebehind-файлом.

  3. Рассмотрим листинги файлов шаблона. Codebehind-файл template.ascx.cs выглядит следующим образом:

    CopyC#
    using System;
using System.Collections.Generic;
using System.Linq;
using System.Web;
using System.Web.UI;
using System.Web.UI.WebControls;
using Bitrix.UI;
using FBInfo;

public partial class bitrix_modules_fbinfo_Install_System_Components_fbinfo_FBInfoMatchList_templates_default_template : BXComponentTemplate<MatchListComponent>
{
    protected void Page_Load(object sender, EventArgs e)
    {

    }
}

    Перейдем к листингу файла template.ascx:

    CopyC#
    <%@ Control Language="C#" AutoEventWireup="true" CodeFile="template.ascx.cs" Inherits="bitrix_modules_fbinfo_Install_System_Components_fbinfo_FBInfoMatchList_templates_default_template" %>
<%@ Reference Control="~/bitrix/components/fbinfo/match.list/component.ascx" %>

<% if (Component.Errors.Count > 0 ){ %>

    <div class="error-message">
    <ul>
    <%foreach (string msg in Component.Errors)
   { %>
   <li><%=msg %></li>
    <%} %>
    </ul>
    </div>

<% return;
   } %>

<div class="page-navigation">
    <bx:IncludeComponent runat="server" ID="HeaderPager" ComponentName="bitrix:system.pager" Template="<%$ Parameters:PagingTemplate %>" CurrentPosition="top"  />
</div>

<table class="matches" cellpadding="5">
<tr class="matches-header">
    <td><%=GetMessage("MatchTime") %></td>
    <td><%=GetMessage("Teams") %></td>
    <td><%=GetMessage("Location") %></td>
    <td><%=GetMessage("Result") %></td>
    <td>&nbsp;</td>
</tr>
<% foreach ( var wrapper in Component.Matches ) {%>
<tr class="matches-body">
    <td><%= wrapper.BeginDateString %></td>
    <td><%= wrapper.Match.FirstTeam.Name %>&nbsp;-&nbsp;<%=wrapper.Match.SecondTeam.Name %></td>
    <td><%= wrapper.Match.Location %></td>
    <td class="match-result"><%= wrapper.Match.FirstTeamGoals.ToString()%>&nbsp;:&nbsp;<%=wrapper.Match.SecondTeamGoals.ToString()%></td>
    <td><a href="<%=wrapper.DetailUrl %>"><%=GetMessage("DetailUrlText") %></a></td>
</tr>
<%} %>
</table>

<div class="page-navigation">
        <bx:IncludeComponent runat="server" ID="FooterPager" ComponentName="bitrix:system.pager" Template="<%$ Parameters:PagingTemplate %>" CurrentPosition="bottom" />
</div>

    Как видно из листинга, разметка шаблонов состоит из четырех частей:

    1. Проверка на наличие ошибок в компоненте, и, если таковые были, выводит их пользователю и завершает выполнение методом return:
      CopyXML
      <% if (Component.Errors.Count0 ){ %>

    <div class="error-message">
    <ul>
    <%foreach (stringmsg inComponent.Errors)
   { %>
   <li><%=msg %></li>
    <%} %&gt;
    &lt;/ul>
    </div>

<% return;
   } %>
    2. Подключение компонента systen.pager, выводящего постраничную навигацию, над таблицей матчей:
      CopyXML
      <div class="page-navigation">
   <bx:IncludeComponent runat="server" ID="HeaderPager" ComponentName="bitrix:system.pager" Template="<%$ Parameters:PagingTemplate %>" CurrentPosition="top"  />
 </div>
    3. Вывод html-таблицы с данными о матчах:
      CopyXML
      <table class="matches" cellpadding="5">
<tr class="matches-header">
    <td><%=GetMessage(&quot;MatchTime") %></td>
    <td><%=GetMessage("Teams") %></td>
    <td><%=GetMessage("Location") %></td>
    <td><%=GetMessage("Result") %></td>
    <td>&nbsp;</td>
</tr>
<% foreach ( var wrapper in Component.Matches ) {%>
<tr class="matches-body">
    <td><%= wrapper.BeginDateString %></td>
    <td><%= wrapper.Match.FirstTeam.Name %>&nbsp;-&nbsp;<%=wrapper.Match.SecondTeam.Name %></td>
    <td><%= wrapper.Match.Location %></td>
    <td class="match-result"><%= wrapper.Match.FirstTeamGoals.ToString()%>&nbsp;:&nbsp;<%=wrapper.Match.SecondTeamGoals.ToString()%></td>
    <td><a href="&lt;%=wrapper.DetailUrl"><%=GetMessage("DetailUrlTexta></td>
</tr>
<%} %&gt;
&lt;/table>

Языковые файлы компонента и шаблона

Языковой файл компонента

  1. В папку /component добавим папку /lang

  2. В папку /component/lang добавим папку /ru - по идентификатору языка.

  3. В папку /component/lang/ru добавим файл component.ascx.lang, содержащий следующий XML:

    CopyXML
    <?xml version="1.0" encoding="utf-8"?>
<resources>
    <data name="Title"><![CDATA[Список матчей]]></data>
  <data name="Description"><![CDATA[Список футбольных матчей]]></data>
  <data name="Group"><![CDATA[Футбольные матчи]]></data>
  <data name="Param.SortDirection"><![CDATA[Направление сортировки]]></data>
  <data name="Param.SortDirection.Asc"><![CDATA[По возрастанию]]></data>
  <data name="Param.SortDirection.Desc"><![CDATA[По убыванию]]></data>
  <data name="Param.SortField"><![CDATA[Поле сортировки]]></data>
  <data name="Param.SortField.MatchId"><![CDATA[ID матча]]></data>
  <data name="Param.SortField.BeginTime"><![CDATA[Время начала матча]]></data>
  <data name="Param.DetailUrl"><![CDATA[Ссылка на страницу детального просмотра]]></data>
  <data name="Error.Unauthorized"><![CDATA[Не достаточно прав для выполнения операции]]></data>
  <data name="Error.InvalidPage"><![CDATA[Страница не существует]]></data>
</resources>

Языковой файл шаблона

  1. В папку /component/templates/.default добавим папку /lang

  2. В папку /component/templates/.default/lang добавим папку /ru - по идентификатору языка.

  3. В папку /component/templates/.default/lang/ru добавим файл template.ascx.lang, содержащий следующий XML:

    CopyXML
    <?xml version="1.0" encoding="utf-8"?>
<resources>
  <data name="DetailUrlText"><![CDATA[Подробная информация]]></data>
  <data name="MatchTime"><![CDATA[Дата]]></data>
  <data name="Teams"><![CDATA[Команды]]></data>
  <data name="Result"><![CDATA[Счет]]></data>
  <data name="Location"><![CDATA[Место проведения]]></data>
</resources>

Файл стилей шаблона

Создадим в папке /templates/.default файл styles.css, содержащий следующий код:

Copy
table.matches
{
  text-align: center;
  font-family: Verdana;
  font-weight: normal;
  font-size: 11px;
  color: #404040;
  width: 500px;
  background-color: #fafafa;
  border: 1px #6699CC solid;
  border-collapse: collapse;
  border-spacing: 0px;
}

tr.matches-header td
{
  border-bottom: 1px solid #6699CC;
  border-left: 1px solid #6699CC;
  background-color: #BEC8D1;
  text-align: left;
  font-family: Verdana;
  font-weight: bold;
  font-size: 11px;
  color: #404040;
}

tr.matches-body td
{
  border-bottom: 1px solid #9CF;
  border-top: 0px;
  border-left: 1px solid #9CF;
  border-right: 0px;
  text-align: left;
  font-family: Verdana, sans-serif, Arial;
  font-weight: normal;
  font-size: 11px;
  color: #404040;
  background-color: #fafafa;
}

tr.matches-body td.match-result
{
    text-align:center;
    text-indent:0;
}

Смотри также

Дополнительная информация

Создание шаблона компонента

Послать комментарий по теме: Справочная служба

(c) «1C-Битрикс», 2010


Футбольный матч детально

Футбольный матч детально
Send Feedback

Рассмотрим создание компонента, который будет отображать информацию о матче детально. Компонент в базовом варианте должен выводить информацию о счете и голах.

Код файлов компонента

Добавим в папку /bitrix/components/fbinfo папку match.detail, в которой создадим структуру файлов компонента. В файл component.ascx.cs добавим следующий код:

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Web;
using System.Web.UI;
using System.Web.UI.WebControls;
using Bitrix.UI;
using MyCompany.FBInfo;
using MyCompany.FBInfo.Entities;
using Bitrix.Components;
using Bitrix.DataLayer;
using Bitrix.DataTypes;
using Bitrix.Security;

namespace FBInfo
{

    public partial class MatchDetailComponent : BXComponent
    {
        List<string> errors;

        public IList<string> Errors
        {
            get { return errors ?? (errors = new List<string>()); }
        }

        public int MatchId
        {
            get { return Parameters.GetInt("MatchId", 0); }
        }

        protected void Page_Load(object sender, EventArgs e)
        {

            if (!BXPrincipal.Current.IsCanOperate(FBInfoModule.Operations.PublicView))
            {
                Errors.Add(GetMessage("Error.Unauthorized"));
                return;
            }

            if ( MatchId == 0 )
            {
                Errors.Add(GetMessage("Error.MatchNotFound"));
                return;
            }

            var matches = FBMatch.GetList(new BXFilter(new BXFilterItem(FBMatch.Fields.MatchId,BXSqlFilterOperators.Equal,MatchId)),
                null,
                new BXSelectAdd(FBMatch.Fields.SecondTeam, FBMatch.Fields.FirstTeam),null);

            if (matches.Count == 0)
            {
                Errors.Add(GetMessage("Error.MatchNotFound"));
                return;
            }

            Match = new MatchInfo(matches[0]);

            //голы команд

            if (Match.Match.FirstTeamGoals > 0 || Match.Match.SecondTeamGoals > 0)
            {
                var goals = FBGoal.GetList(new BXFilter(new BXFilterItem(FBGoal.Fields.Match.MatchId, BXSqlFilterOperators.Equal, Match.Match.MatchId)),
                                            new BXOrderBy(new BXOrderByPair(FBGoal.Fields.GoalTime, BXOrderByDirection.Asc)));
                foreach (var goal in goals)
                {
                    if (goal.Team.TeamId == Match.Match.FirstTeam.TeamId)
                        Match.FirstTeamGoals.Add(goal);

                    if (goal.Team.TeamId == Match.Match.SecondTeam.TeamId)
                        Match.SecondTeamGoals.Add(goal);
                }
            }

            IncludeComponentTemplate();
        }

        MatchInfo match;

        public MatchInfo Match
        {
            get { return match; }
            set { match = value; }
        }

        protected override void PreLoadComponentDefinition()
        {
            Title = GetMessageRaw("Title");
            Description = GetMessageRaw("Description");
            Icon = "images/icon.gif";
            Group = FBInfoModule.FBInfoModuleConfiguration.GetComponentGroup();

            ParamsDefinition.Add(
                "MatchId",
                new BXParamText(
                    GetMessageRaw("Param.MatchId"),
                    "",
                    BXCategory.Main
                )
            );

        }
    }

    public class MatchInfo
    {
        FBMatch match;

        List<FBGoal> firstTeamGoals;
        List<FBGoal> secondTeamGoals;
        int matchTime;

        public MatchInfo(FBMatch match)
        {
            if (match == null)
                throw new ArgumentException("match");

            this.match = match;
            this.matchTime = -1;
        }

        public int MatchTime
        {
            get
            {
                if (matchTime != -1)
                    return matchTime;
                if (match.BeginTime == null || match.EndTime == null) return 0;
                var time = match.EndTime.Subtract(match.BeginTime);
                return matchTime = time.Minutes + time.Hours * 60;
            }
        }

        public List<FBGoal> FirstTeamGoals
        {
            get { return firstTeamGoals ?? (firstTeamGoals = new List<FBGoal>()); }
        }

        public List<FBGoal> SecondTeamGoals
        {
            get { return secondTeamGoals ?? (secondTeamGoals = new List<FBGoal>()); }
        }

        public FBMatch Match
        {
            get { return match; }
            set
            {
                if (value == null)
                    throw new ArgumentException("value");
                match = value;
            }
        }

    }
}

Изменим файл component.ascx чтобы он выглядел следующим образом:

CopyC#
<%@ Control Language="C#" AutoEventWireup="true" CodeFile="component.ascx.cs" Inherits="FBInfo.MatchDetailComponent" %>

В файл component.ascx.lang добавим использованные в компоненте языковые фразы:

CopyXML
<?xml version="1.0" encoding="utf-8"?>
<resources>
    <data name="Title"><![CDATA[Матч детально]]></data>
  <data name="Description"><![CDATA[Просмотр детальной информации о матче]]></data>
  <data name="Group"><![CDATA[Футбольные матчи]]></data>
  <data name="Error.Unauthorized"><![CDATA[Не достаточно прав для выполнения операции]]></data>
  <data name="Error.MatchNotFound"><![CDATA[Матч не найден]]></data>
</resources>

Код файлов шаблона

В файл template.ascx добавим следующий код:

CopyC#
          <%@ Control Language="C#" AutoEventWireup="true" CodeFile="template.ascx.cs" Inherits="FBInfoDetailListTemplate" %>
<%@ Reference Control="~/bitrix/components/fbinfo/match.detail/component.ascx" %>

<% if (Component.Errors.Count > 0 ){ %>

    <div class="error-message">
    <ul>
    <%foreach (string msg in Component.Errors)
   { %>
   <li><%=msg %></li>
    <%} %>
    </ul>
    </div>

<% return;
   } %>
<span class="match-detail-main-header">
<%= Component.Match.Match.FirstTeam.Name %>&nbsp;-&nbsp;<%= Component.Match.Match.SecondTeam.Name %>&nbsp;
<%= Component.Match.Match.FirstTeamGoals.ToString() %>&nbsp;:&nbsp;<%= Component.Match.Match.SecondTeamGoals.ToString() %>
</span>
<table class="match-detail" width="50%">
<tr>
    <td><%= Component.Match.Match.FirstTeam.Name %></td>
    <td><%= Component.Match.Match.SecondTeam.Name %></td>
</tr>
<tr class="matches-detail-header">
    <td colspan="2">
    <%= GetMessage("Goals") %>:
    </td>
</tr>
<tr>
    <td>
    <% if ( Component.Match.Match.FirstTeamGoals > 0 ){ %>
        <ul class="match-detail-goals">
        <% foreach ( var goal in Component.Match.FirstTeamGoals ){ %>
        <li><%= goal.Player.Name %>&nbsp;<%= goal.GoalTime %>'</li>
        <%} %>
        </ul>
    <%} %>
    </td>
    <td>
        <% if ( Component.Match.Match.SecondTeamGoals > 0 ){ %>
        <ul class="match-detail-goals">
        <% foreach ( var goal in Component.Match.SecondTeamGoals ){ %>
        <li><%= goal.Player.Name %>&nbsp;<%= goal.GoalTime %>'</li>
        <%} %>
        </ul>
    <%} %>
    </td>
</tr>
</table>

В файл template.ascx.lang добавим использованные в шаблоне языковые фразы:

CopyXML
<?xml version="1.0" encoding="utf-8"?>
<resources>
  <data name="Goals"><![CDATA[Голы]]></data>
</resources>

В файл style.css добавим стили шаблона:

Copy
table.match-detail
{
    font-family: Verdana;
    font-weight: normal;
    font-size: 11px;
    color: #404040;
    background-color: #fafafa;
    border: 1px #6699CC solid;
    border-collapse: collapse;
    border-spacing: 0px;
    margin-top:10px;
}

ul.match-detail-goals
{
    list-style-type:none;
}

span.match-detail-main-header
{
    font-family:Verdana;
    font-size:15px;
    font-weight:bold;
}

tr.matches-detail-header td
{
    border-bottom: 1px solid #6699CC;
    border-top: 1px solid #6699CC;
    border-left: 1px solid #6699CC;
    background-color: #BEC8D1;
    text-align: left;
    font-family: Verdana;
    font-weight: bold;
    font-size: 11px;
    color: #404040;
}


Использование набираемых свойств

Использование набираемых свойств
Send Feedback

В этом документе будет рассмотрено расширение функциональности компонента Список футбольных матчей за счет применения фильтра по набираемым свойствам сущности "матч" (FBMatch).

При разработке списков объектов для отображения на сайте нередко встречается необходимость часть элементов не показывать в зависимости от некоторого условия. Для реализации данного функционала нам потребуется добавить к сущности "матч" набираемое свойство "Показывать в списке", по которому мы затем сделаем фильтр в компоненте.

Еще одна распространенная задача - добавление дополнительной информации к сущности. Например, нам нужно выводить в списке матчей также стадион, на котором состоялся матч. В этом случае удобно использовать набираемое свойство, которое мы добавим к сущности "матч".

Добавление набираемых свойств к сущности

Нам необходимо добавить к сущности "Матч" два набираемых свойства - "Показывать в списке" и "Стадион".

  1. В административной части сайта в левом меню перейдем в пункт "Настройки".

  2. Раскроем раздел "Настройки продукта" и выберем пункт "Пользовательские поля".

    В открывшемся списке отображаются все пользовательские ( набираемые ) свойства сущностей.

  3. Нажмем кнопку "Добавить" в верхней части списка. Откроется форма добавления нового поля.

    Для создания поля "Показывать в списке" заполним форму следующим образом:

    Добавление набираемого свойства

    Примечание:
    Поле "Объект" должно содержать свойство EntityId, переопределенное в конкретной сущности, в нашем случае EntityId возвращает значение FBTeam.

    Внимание:
    Поле "Значение по умолчанию" отвечает за значение поля в редакторах сущности. Поэтому при добавлении поля значение, установленное по умолчанию, не будет записано в БД.

  4. Аналогично создадим поле "Стадион" типа "строка" для этой же сущности.

Фильтр по набираемым свойствам в компоненте списка

Добавим в компонент Список футбольный матчей возможность фильтровать вывод по набираемым свойствам:

  1. В метод PreLoadComponentDefinition добавим определение новых параметров:

    CopyC#
    ParamsDefinition.Add("FilterByCustomProperty",
new BXParamYesNo(
    GetMessageRaw("Param.FilterByCustomProperty"),
    false,
    BXCategory.CustomField,
    new ParamClientSideActionGroupViewSwitch(ClientID, "FilterByCustomProperty", "FilterByCustomProperty", string.Empty)
    )
);

ParamsDefinition.Add("CustomPropertyFilterSettings",
    new BXParamCustomFieldFilter(
        GetMessageRaw("Param.CustomPropertyFilterSettings"),
        string.Empty,
        BXCategory.CustomField,
        string.Empty,
        new ParamClientSideActionGroupViewMember(ClientID, "CustomPropertyFilterSettings", new string[] { "FilterByElementCustomProperty" })
        )
    );

    Параметр FilterByCustomProperty включает фильтр по набираемым свойствам.

    Параметр CustomPropertyFilterSettings задает настройки фильтра.

  2. Добавим в языковой файл component.ascx.lang фразы названий параметров:

    CopyXML
    <data name="Param.FilterByCustomProperty"><![CDATA[Фильтровать по набираемым свойствам матчей]]></data>
<data name="Param.CustomPropertyFilterSettings"><![CDATA[Настройки фильтра]]></data>

  3. В метод LoadComponentDefinition добавим код настройки фильтра набираемых свойств:

    CopyC#
    BXParamCustomFieldFilter cfParamFilter = ParamsDefinition["CustomPropertyFilterSettings"] as BXParamCustomFieldFilter;
cfParamFilter.EntityId = FBMatch.GetCustomFieldsKey();

  4. Теперь, открыв диалог с настройкой параметров компонента, мы увидим фильтр по набираемым свойствам, в котором можно указать необходимые значения для свойств "Стадион" и "Показывать в публичной части":

    Фильтр по набираемым свойствам

  5. Модифицируем далее методPage_Load компонента так, чтобы выборка сущностей учитывала фильтр по набираемым свойствам и вместе с выборкой сущности выбиралось набираемое свойство "Стадион":

    CopyC#
    protected void Page_Load(object sender, EventArgs e)
        {

            if (!BXPrincipal.Current.IsCanOperate(FBInfoModule.Operations.PublicView))
            {
                Errors.Add(GetMessage("Error.Unauthorized"));
                return;
            }

            BXPagingParams pagingParams = PreparePagingParams();

            bool legal;
            BXParamsBag<object> replace = new BXParamsBag<object>();

            var orderBy = new BXOrderBy(FBMatch.Fields, SortField + " " + SortDirection);

            var matchFilter = new BXFilter();

            if (CustomPropertyFilterSettings != null && CustomPropertyFilterSettings.Count > 0)
            {
                BXCustomFieldCollection cFields = BXCustomEntityManager.GetFields(FBMatch.GetCustomFieldsKey());
                foreach (KeyValuePair<string, object> kv in CustomPropertyFilterSettings)
                {
                    BXCustomField cField;
                    if (!cFields.TryGetValue(kv.Key, out cField))
                        continue;

                    matchFilter.Add(new BXFilterItem(FBMatch.Fields.CustomFields.DefaultFields.GetFieldByKey(kv.Key),
                        cField.Multiple ? BXSqlFilterOperators.In : BXSqlFilterOperators.Equal, kv.Value));
                }
            }

            int count = FBMatch.Count(matchFilter);

            BXQueryParams queryParams = PreparePaging(
                pagingParams,
                delegate
                {
                    return count;
                },
                replace,
                out legal
            );
            if (!legal)
            {
                Errors.Add(GetMessage("Error.InvalidPage"));
                return;
            }
      // выборка сущностей вместе с набираемым свойством "Матч"
            var matchesCollection = FBMatch.GetList(matchFilter, orderBy,
                new BXSelectAdd(
                    FBMatch.Fields.FirstTeam,
                    FBMatch.Fields.SecondTeam,
                    FBMatch.Fields.CustomFields.DefaultFields.GetFieldByKey("STADIUM")),
                queryParams);

            replace.Clear();
            matches = new List<MatchWrapper>();
            foreach (var match in matchesCollection)
            {
                replace["MatchId"] = match.MatchId;
                var wrapper = new MatchWrapper(match, ResolveTemplateUrl(DetailUrl, replace));
                matches.Add(wrapper);
            }

            IncludeComponentTemplate();
        }
    Примечание:
    Рекомендуется выбирать набираемые свойства сущности, добавляя их в BXSelectAdd метода GetList выборки сущности, как показано выше. Это снизит количество запросов к серверу БД, так как при обращении к набираемому свойству, которое не было выбрано, будет происходить отдельный SQL-запрос к базе данных.

Теперь, отредактировав через административную страницу свойства "Показывать в публичной части" у матчей, мы можем, установив фильтр по этому свойству в компоненте, скрывать или показывать определенные матчи.

Отображение набираемых свойств в шаблоне компонента

Мы добавили к сущности "Матч" набираемое свойство "Стадион". Теперь изменим шаблон .default компонента match.list (Список футбольных матчей) так, чтобы он отображал информацию о стадионе, на котором был сыгран матч:

CopyC#
        <%@ Control Language="C#" AutoEventWireup="true" CodeFile="template.ascx.cs" Inherits="FBInfoMatchListTemplate" %>
<%@ Reference Control="~/bitrix/components/fbinfo/match.list/component.ascx" %>

<% if (Component.Errors.Count > 0 ){ %>

    <div class="error-message">
    <ul>
    <%foreach (string msg in Component.Errors)
   { %>
   <li><%=msg %></li>
    <%} %>
    </ul>
    </div>

<% return;
   } %>

<div class="page-navigation">
    <bx:IncludeComponent runat="server" ID="HeaderPager" ComponentName="bitrix:system.pager" Template="<%$ Parameters:PagingTemplate %>" CurrentPosition="top"  />
</div>

<table class="matches" cellpadding="5">
<tr class="matches-header">
    <td><%=GetMessage("MatchTime") %></td>
    <td><%=GetMessage("Teams") %></td>
    <td><%=GetMessage("Location") %></td>
    <td><%=GetMessage("Result") %></td>
    <td><%=GetMessage("Stadium") %></td>
    <td>&nbsp;</td>
</tr>
<% foreach ( var wrapper in Component.Matches ) {%>
<tr class="matches-body">
    <td><%= wrapper.BeginDateString %></td>
    <td><%= wrapper.Match.FirstTeam.Name %>&nbsp;-&nbsp;<%=wrapper.Match.SecondTeam.Name %></td>
    <td><%= wrapper.Match.Location %></td>
    <td class="match-result"><%= wrapper.Match.FirstTeamGoals.ToString()%>&nbsp;:&nbsp;<%=wrapper.Match.SecondTeamGoals.ToString()%></td>
    <td><%= wrapper.Match.CustomPublicValues.GetHtml("STADIUM") %></td>
    <td><a href="<%=wrapper.DetailUrl %>"><%=GetMessage("DetailUrlText") %></a></td>

</tr>
<%} %>
</table>

<div class="page-navigation">
        <bx:IncludeComponent runat="server" ID="FooterPager" ComponentName="bitrix:system.pager" Template="<%$ Parameters:PagingTemplate %>" CurrentPosition="bottom" />
</div>

Мы добавили еще один заголовок в таблицу:

CopyC#
<td><%=GetMessage("Stadium") %></td>

и один столбец с выводом набираемого свойства:

CopyC#
<td><%= wrapper.Match.CustomPublicValues.GetHtml("STADIUM") %></td>

Метод GetHtml списка набираемых свойств CustomPublicValues предназначен для вывода данных, которые содержит набираемое свойство. Он возвращает корректный HTML с данными для любого типа набираемых свойств, в том числе множественных. Метод принимает на вход идентификатор набираемого свойства (не зависит от регистра).


Организация взаимодействия между компонентами

Организация взаимодействия между компонентами
Send Feedback

В документах Футбольный матч детально и Список футбольных матчей было показано создание двух простых компонентов, организующих вывод информации о футбольных матчах. В этом документе будет рассмотрена организация взаимодействия между двумя этими компонентами.

Организация взаимодействия между компонентами.

  1. Добавим на сайт две aspx страницы - list.aspx и detail.aspx

  2. В list.aspx добавим компонент match.list, указав в параметре "Ссылка на детальную информацию" ссылку на detail.aspx: detail.aspx?match=#MatchId#. #MatchId# - шаблон подстановки, компонент match.list при формировании ссылок на детальный просмотр автоматически заменит выражение #MatchId# на идентификатор соответствующего матча.

  3. В detail.aspx добавим компонент match.detail, в параметре ID матча укажем подстановку вида Request:match. При загрузке компонент match.detail проверит строку запроса, и установит свой параметр MatchId равным значению параметра match. Если параметра в строке запроса не будет, либо его значение не приводится к Int, параметр компонента будет иметь значение по умолчанию.

  4. Теперь, находясь на странице list.aspx, переходя по ссылке "Детальная информация", мы попадаем на страницу detail.aspx, и компонент match.detail отображает детальную информацию о матче.


Создание решения

Создание решения
Send Feedback

Решение представляет собой готовый типовой сайт, который может быть использован как базовый при создании решения для конкретного клиента. Он может содержать демонстрационные данные и иметь несколько шаблонов. Решение также может содержать мастер, который предоставляет возможность гибкой пошаговой настройки решения в процессе установки.

Система 1С-Битрикс Управление Сайтом ASP.NET" работает с решениями как со специфическими модулями, обладающими всеми свойствами модуля, кроме наличия dll-файла.

В этом разделе

  • Структрура файлов решения
  • Процесс создания решения


Структрура файлов решения

Структрура файлов решения
Send Feedback

В этом документе будет рассмотрена структура файлов решения

Структура файлов решения

Файл/папка | Содержание и назначение
/{папка модуля}/module.config | Содержит базовую информацию о модуле, его версию. По наличию этого файла система определяет наличие модуля.
/{папка модуля}/dependencies.config | Определяет зависимости данного модуля от других модулей, с указанием их версий. Используется при установке и удалении модуля.
/{папка модуля}/assemblies.config | Содержит информацию о сборках, используемых модулем.
/{папка модуля}/options.ascx | ascx - контрол, представляющий собой страницу настроек модуля в административной части. Доступен в меню административной части, пункт Настройки продукта - Настройки модулей - {Имя модуля}
/{папка модуля}/solutions.ru.config | Конфигурационный файл, специфический для решения. Содержит путь к папке решения, описание и информацию о значке решения, который будет отображен в списке при установке.
/{папка модуля}/lang/{идентификатор языка} | Языковые фразы, необходимые для мастера установки решения
/{папка модуля}/{папка решения} | Папка решения содержит файлы, необходимые для установки.
/{папка модуля}/{папка решения}/custom_steps_1 | Содержит часть шагов мастера установки решения. Эта часть запускается после выбора пользователем решения и до выбора шаблона.
/{папка модуля}/{папка решения}/custom_steps_2 | Содержит часть шагов мастера установки решения. Эта часть запускается после выбора пользователем шаблона и до копирования шаблона.
/{папка модуля}/{папка решения}/custom_steps_3 | Содержит часть шагов мастера установки решения. Эта часть запускается после копирования шаблона.
/{папка модуля}/{папка решения}/custom_steps_{номер}/{название шага}.ascx | Шаг мастера. Представляет собой ascx-контрол, наследуемый от BXWizardStepStandardHtmlControl
/{папка модуля}/{папка решения}/custom_steps_{номер}/wizard.xml | Описывает последовательность шагов мастера.
/{папка модуля}/{папка решения}/data | Содержит данные решения, разделенные на две части: данные о структуре ( необходимые инфоблоки, блог, форум, и тд. ) и демонстрационные данные, которыми можно заполнить сайт при установке решения.
/{папка модуля}/{папка решения}/images | Содержит изображения, которые будут отображены в мастере - изображение решения в списке, изображения шаблонов.
/{папка модуля}/{папка решения}/public | Содержит сайт
/{папка модуля}/{папка решения}/templates | Содержит шаблоны сайта
/{папка модуля}/{папка решения}/tools | Содержит инструменты - классы для импорта инфоблоков и блогов из xml.


Процесс создания решения

Процесс создания решения
Send Feedback

В этом документе описана процедура создания решения.

Создание решения

  1. Собираем сайт - создаем шаблоны сайта, страницы, шаблоны компонентов, инфоблоки, форумы, блоги, другие сущности. Собранный сайт помещаем в папку /{папка модуля}/{папка решения}/public. Шаблоны сайта помещаем в /{папка модуля}/{папка решения}/templates.

  2. Создаем xml-файлы с информацией и структурой сущностей, необходимых для решения, помещаем файлы в /{папка модуля}/{папка решения}/data

  3. Создаем мастер - файлы шагов и wizard.xml. Помещаем шаги в папку /{папка модуля}/{папка решения}/custom_steps{номер}

  4. Создаем языковые файлы

  5. Создаем конфигурационные файлы решения

  6. Если требуется, создаем страницу настроек решения

  7. Создаем необходимые изображения для отображения решения в списке, а также изображения для шаблонов


Библиотека классов

Библиотека классов
Send Feedback

Пространство имен

Пространство имен | Описание
Bitrix.Components | Содержит классы, связанные с реализацией механизма компонентов и абстрагированные от документной модели WebForms.
Bitrix.DataLayer | Содержит классы обеспечивающие доступ к данным.
Bitrix.DataTypes | Содержит различные повсеместно используемые структуры данных.
Bitrix.IBlock | Содержит классы для управления инфоблоками.
Bitrix.IO | Содержит классы, отвечающие за работу с файловой системой и средствами ввода/вывода.
Bitrix.Services | Содержит классы, реализующие различные служебные механизмы.
Bitrix.Services.Text | Содержит набор утилит для работы с текстом.
Bitrix.UI | Содержит классы, обеспечивающие работу с документной моделью WebForms ASP.NET


Пространство имен Bitrix.Components

Пространство имен Bitrix.Components
Send Feedback
Содержит классы, связанные с реализацией механизма компонентов и абстрагированные от документной модели WebForms.

Классы

Класс | Описание
BXComponentManager | Класс, содержащий набор вспомогательных методов для работы с компонентами
BXComponentParameters | Хранилище параметров компонента, предоставляющее методы для интерпретации различных форматов данных и внутренние механизмы для работы системы компонентов. Cм. Parameters
BXParam | Класс, описывающий параметры компонента
BXParamMultiSelection | Класс параметра компонента, представленного списком значений с множественной выборкой.
BXParamMultiSelectionWithText | Класс параметра компонента, представленного списком значений с множественной выборкой и дополнительными текстовыми полями.
BXParamSingleSelection | Класс параметра компонента, представленного раскрывающимся списком.
BXParamSingleSelectionWithText | Класс параметра компонента, представленного раскрывающимся списком с дополнительным текстовым полем.
BXParamSort | Класс параметра компонента задающего порядок сортировки
BXParamText | Класс параметра компонента, представленного обыкновенным текстовым полем
BXParamValue | Класс, представляющий предопределенное значение для параметра компонента
BXParamYesNo | Класс параметра компонента, представляющего значение "да/нет"

Перечисления

Перечисление | Описание
BXCacheMode | Режим кеширования компонента.
BXParamType | Стандартные типы отображения параметров


Перечисление BXCacheMode

Перечисление BXCacheMode
Смотри также Send Feedback
Режим кеширования компонента.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public enum BXCacheMode

Члены

Название члена | Описание
Auto | Автоматический.
Custom | Пользовательский.
None | Не кешировать.

Смотри также

Пространство имен Bitrix.Components


Класс BXComponentManager

Класс BXComponentManager
Члены Пример Смотри также Send Feedback
Класс, содержащий набор вспомогательных методов для работы с компонентами

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static class BXComponentManager

Примеры

Формирование ссылки по шаблону:

CopyC#
BXParamsBag<object> request;

...

ComponentCache["PagingDefaultPageUrl"] = BXComponentManager.MakeLink(defaultPageTemplate, request);

Загрузка компонента по имени:

CopyC#
BXComponent instance = Page.LoadControl(BXComponentManager.GetPath(ComponentName)) as BXComponent;

Иерархия наследования

System..::..Object
Bitrix.Components..::..BXComponentManager

Смотри также

Члены BXComponentManager
Пространство имен Bitrix.Components


Члены BXComponentManager

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXComponentManager
Класс BXComponentManager Методы Смотри также Send Feedback

Тип BXComponentManager предоставляет следующие возможности.

Методы

Имя | Описание
CreateInstance | Создает экземпляр компонента по его имени.
Exists | Определяет существует ли в системе компонент с таким именем.
GetFolder | Возвращает виртуальный путь к папке с компонентом по его имени. Заканчивается на '/'.
GetName | Получение имени компонента по его виртуальному пути.
GetPath | Возвращает виртуальный путь к компоненту по его имени.
GetTemplatePath | Возвращает виртуальный путь к шаблону по имени компонента, имени шаблона компонента и имени шаблона сайта.
GetTemplates | Возвращает словарь всех шаблонов для компонента.
GetTemplateVirtualDir | Возвращает виртуальный путь к папке шаблона для компонента (без '/' на конце).
MakeLink | Перегруженный.
Map | Перегруженный.
MapVariable | Перегруженный.

Смотри также

Класс BXComponentManager
Пространство имен Bitrix.Components


Методы BXComponentManager

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXComponentManager
Класс BXComponentManager Смотри также Send Feedback

Тип BXComponentManager предоставляет следующие возможности.

Методы

Имя | Описание
CreateInstance | Создает экземпляр компонента по его имени.
Exists | Определяет существует ли в системе компонент с таким именем.
GetFolder | Возвращает виртуальный путь к папке с компонентом по его имени. Заканчивается на '/'.
GetName | Получение имени компонента по его виртуальному пути.
GetPath | Возвращает виртуальный путь к компоненту по его имени.
GetTemplatePath | Возвращает виртуальный путь к шаблону по имени компонента, имени шаблона компонента и имени шаблона сайта.
GetTemplates | Возвращает словарь всех шаблонов для компонента.
GetTemplateVirtualDir | Возвращает виртуальный путь к папке шаблона для компонента (без '/' на конце).
MakeLink | Перегруженный.
Map | Перегруженный.
MapVariable | Перегруженный.

Смотри также

Класс BXComponentManager
Пространство имен Bitrix.Components


Метод CreateInstance

Метод BXComponentManager..::.CreateInstance
Класс BXComponentManager Пример Смотри также Send Feedback
Создает экземпляр компонента по его имени.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXComponent CreateInstance(
    string componentName
)

Параметры

componentName
Type: System..::..String
Имя компонента, например "bitrix:system.PublicMenu"

Возвращаемое значение

Если не удалось создать экземпляр компонента, то возвращается null

Примеры

Получение списка параметров для компонента "bitrix:system.PublicMenu"

CopyC#
Dictionary<string, string> componentParameters = new Dictionary<string,string>();

BXComponent component = BXComponentManager.CreateInstance("bitrix:system.PublicMenu");
component.ForcePreLoadComponentDefinition();

foreach(KeyValuePair<string, BXParam> def in  component.ParamsDefinition)
    componentParameters.Add(def.Key, def.Value.Title);

Смотри также

Класс BXComponentManager
Пространство имен Bitrix.Components


Метод Exists

Метод BXComponentManager..::.Exists
Класс BXComponentManager Пример Смотри также Send Feedback
Определяет существует ли в системе компонент с таким именем.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static bool Exists(
    string componentName
)

Параметры

componentName
Type: System..::..String
Имя компонента, например "bitrix:system.PublicMenu"

Возвращаемое значение

true, если компонент существует, иначе false

Примеры

Динамическое добавление компонента

CopyC#
if (BXComponentManager.Exists("bitrix:system.PublicMenu"))
    {
        IncludeComponent component = new IncludeComponent();
        component.ComponentName = "bitrix:system.PublicMenu";
        component.Attributes["Template"] = ".default";
        component.Attributes["MenuName"] = "left";

        Controls.Add(component);
    }

Смотри также

Класс BXComponentManager
Пространство имен Bitrix.Components


Метод GetFolder

Метод BXComponentManager..::.GetFolder
Класс BXComponentManager Пример Смотри также Send Feedback
Возвращает виртуальный путь к папке с компонентом по его имени. Заканчивается на '/'.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetFolder(
    string componentName
)

Параметры

componentName
Type: System..::..String
Имя компонента, например "bitrix:system.PublicMenu"

Возвращаемое значение

Виртуальный путь к папке вида "~/bitrix/components/bitrix/system.PublicMenu/". Реузльтирующая строка заканчивается на '/'.

Примеры

Добавление произвольной кнопки в верхнюю панель сайта:

CopyC#
public override void CreatePublicPanelMenu(BXPublicPanelMenuSectionList sectionList)
{
    if (sectionList == null)
        throw new ArgumentNullException("sectionList");

    //Создаем секцию
    BXPublicPanelMenuSection section = sectionList.FindByID("CustomMenuSection");
    if (section == null)
    {
        BXPublicPanelMenuSectionInfo sectionInfo = new BXPublicPanelMenuSectionInfo("CustomMenuSection", 100);
        section = new BXPublicPanelMenuSection(sectionInfo);
        sectionList.Add(section);
    }

    //Создаем кнопку
    BXPublicPanelMenu button = section.FindByID("CustomMenuButton");
    if (button == null)
    {
        button = new BXPublicPanelMenu();
        button.ID = "CustomMenuButton";
        button.BackgroundImagePath = BXPath.Combine(BXComponentManager.GetFolder(Name), "images/icon.gif");
        button.Caption = "Моя кнопка";
        button.Hint = "Добавленная мной кнопка";
        button.ShowMode = BXShowMode.NonView;
        section.Add(button);
    }
}

Смотри также

Класс BXComponentManager
Пространство имен Bitrix.Components


Метод GetName

Метод BXComponentManager..::.GetName
Класс BXComponentManager Пример Смотри также Send Feedback
Получение имени компонента по его виртуальному пути.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetName(
    string virtualPath
)

Параметры

virtualPath
Type: System..::..String
Виртуальный путь к файлу компонента, например "~/bitrix/components/bitrix/system.PublicMenu/component.ascx".

Возвращаемое значение

Имя компонента, например "bitrix:system.PublicMenu"

Примеры

Получение имени текущего компонента:

CopyC#
string componentName = BXComponentManager.GetName(this.AppRelativeVirtualPath);

Смотри также

Класс BXComponentManager
Пространство имен Bitrix.Components


Метод GetPath

Метод BXComponentManager..::.GetPath
Класс BXComponentManager Пример Смотри также Send Feedback
Возвращает виртуальный путь к компоненту по его имени.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetPath(
    string componentName
)

Параметры

componentName
Type: System..::..String
Имя компонента, например "bitrix:system.PublicMenu"

Возвращаемое значение

Виртуальный путь вида "~/bitrix/components/bitrix/system.PublicMenu/component.ascx".

Примеры

Проверка на существования файла компонента:

CopyC#
if (BXSecureIO.FileExists(BXComponentManager.GetPath("bitrix:system.PublicMenu")))
{
    //Файл с компонентом существует
}

Смотри также

Класс BXComponentManager
Пространство имен Bitrix.Components


Метод GetTemplatePath

Метод BXComponentManager..::.GetTemplatePath
Класс BXComponentManager Пример Смотри также Send Feedback
Возвращает виртуальный путь к шаблону по имени компонента, имени шаблона компонента и имени шаблона сайта.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetTemplatePath(
    string componentName,
    string componentTemplate,
    string componentPage,
    string siteTemplate,
    BXComponent parent
)

Параметры

componentName
Type: System..::..String
Имя компонента. Имя должно иметь следующий вид bitrix:system.PublicMenu
componentTemplate
Type: System..::..String
Имя шаблона компонента
componentPage
Type: System..::..String
Имя страницы для комплексного компонента. Если пустое, то будет искаться шаблон простого компонента.
siteTemplate
Type: System..::..String
Имя шаблона сайта
parent
Type: Bitrix.UI..::..BXComponent
Родительский компонент, или null, если родительский компонент отсутствует

Возвращаемое значение

Если подходящий шаблон найден, то возвращается путь к нему, например, "~/bitrix/components/bitrix/system.PublicMenu/templates/tabs/template.ascx"; иначе null.

Примеры

Получение пути к файлу шаблона компонента:

CopyC#
string templatePath = BXComponentManager.GetTemplatePath(this.Name, this.Template, null, BXSite.CurrentTemplate, this.Component);
if (string.IsNullOrEmpty(templatePath))
    templatePath = BXComponentManager.GetTemplatePath(this.Name, BXConfigurationUtility.Constants.DefaultTemplate, null, BXSite.CurrentTemplate, this.Component);

Исключения

Исключение | Условие
BXComponentTemplateNotFoundException | Возникает, когда в существующем шаблоне отсутствует файл шаблона или страницы шаблона.

Смотри также

Класс BXComponentManager
Пространство имен Bitrix.Components


Метод GetTemplates

Метод BXComponentManager..::.GetTemplates
Класс BXComponentManager Пример Смотри также Send Feedback
Возвращает словарь всех шаблонов для компонента.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXParamsBag<BXComponentTemplate> GetTemplates(
    string componentName,
    string siteTemplate
)

Параметры

componentName
Type: System..::..String
Имя компонента, например "bitrix:system.PublicMenu".
siteTemplate
Type: System..::..String
Имя шаблона сайта, например "web20".

Возвращаемое значение

Словарь вида "имя шаблона" -> "экземпляр шаблона"

Заметки

Метод не учитывает темы комплексных компонентов.

Для найденных шаблонов комплексных компонентов в словарь вносятся фиктивные экземпляры класса BXComponentTemplate с заданным свойством TemplateName. Для найденных шаблонов простых компонентов в словарь вносятся реальные экземпляры шаблонов.

Если для компонента существует несколько шаблонов с одинаковым именем, то в словаре будет содержаться наиболее приоритетный шаблон.

Примеры

Получение списка шаблонов для компонента постранички и установка предопределенных значений для соответствующего параметра компонента

CopyC#
BXParamsBag<BXComponentTemplate> pagerComponentTemplates = BXComponentManager.GetTemplates("bitrix:system.pager", BXSite.CurrentTemplate);
if (pagerComponentTemplates.Count > 0)
{
    List<BXParamValue> pagerComponentTemplatesList = new List<BXParamValue>();
    foreach (string pagerComponentTemplateName in pagerComponentTemplates.Keys)
    {
        string title = !string.Equals(pagerComponentTemplateName, BXConfigurationUtility.Constants.DefaultTemplate, StringComparison.Ordinal) ? pagerComponentTemplateName : BXLoc.GetModuleMessage("main", "Kernel.Default");
        pagerComponentTemplatesList.Add(new BXParamValue(title, pagerComponentTemplateName));
    }
    ParamsDefinition["PagingTemplate"].Values = pagerComponentTemplatesList;
}

Смотри также

Класс BXComponentManager
Пространство имен Bitrix.Components


Метод GetTemplateVirtualDir

Метод BXComponentManager..::.GetTemplateVirtualDir
Класс BXComponentManager Пример Смотри также Send Feedback
Возвращает виртуальный путь к папке шаблона для компонента (без '/' на конце).

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetTemplateVirtualDir(
    string componentName,
    string componentTemplate,
    string siteTemplate,
    BXComponent parent
)

Параметры

componentName
Type: System..::..String
Имя компонента, например "bitrix:system.PublicMenu"
componentTemplate
Type: System..::..String
Имя шаблона компонента, например "flat"
siteTemplate
Type: System..::..String
Имя шаблона сайта, например "web20"
parent
Type: Bitrix.UI..::..BXComponent
Родительский компонент, если компонент находится внутри комплексного; иначе null

Возвращаемое значение

Виртуальный путь к папке компонента (без '/' на конце), например "~/bitrix/templates/web20/components/bitrix/system.PublicMenu/flat" или null, если папку не удалось найти.

Примеры

Копирование шаблона компонента в новый шаблон сайта:

CopyC#
string sourceDir = BXComponentManager.GetTemplateVirtualDir("bitrix:system.PublicMenu", ".default", ".default", null);
if (string.IsNullOrEmpty(sourceDir))
    return;

string destinationDir = "~/bitrix/templates/new_template/components/bitrix/system.PublicMenu/.default";

if (BXSecureIO.DirectoryExists(destinationDir))
    return;

BXSecureIO.DirectoryEnsureExists(destinationDir);
BXSecureIO.DirectoryCopy(sourceDir, destinationDir);

Смотри также

Класс BXComponentManager
Пространство имен Bitrix.Components


Метод MakeLink

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentManager..::.MakeLink
Класс BXComponentManager Смотри также Send Feedback

Лист перегрузки

Имя | Описание
MakeLink(String, BXParamsBag<(Of <<'(Object>)>>)) | Конструирование ссылки по шаблону с заменой специальных выражений (#...#) на значения соответствующих параметров из словаря
MakeLink(String, Object) | Конструирование ссылки по шаблону с заменой специальных выражений (#...#) на значения параметра. Внимание! Не использовать, если параметров больше чем 1
MakeLink(String, String) | Конструирование абсолютной ссылки из папки ЧПУ и шаблона ЧПУ
MakeLink(String, String, BXParamsBag<(Of <<'(Object>)>>)) | Конструирование ссылки из нескольких частей с заменой специальных выражений(#...#) на соответствующие параметры
MakeLink(String, String, Object) | Конструирование ссылки из нескольких частей с заменой специальных выражений (#...#) на значения параметра. Внимание! Не использовать, если параметров больше чем 1

Смотри также

Класс BXComponentManager
Члены BXComponentManager
Пространство имен Bitrix.Components


Метод MakeLink (String, BXParamsBag(Object))

Метод BXComponentManager..::.MakeLink (String, BXParamsBag<(Of <(<'Object>)>)>)
Класс BXComponentManager Пример Смотри также Send Feedback
Конструирование ссылки по шаблону с заменой специальных выражений (#...#) на значения соответствующих параметров из словаря

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string MakeLink(
    string template,
    BXParamsBag<Object> parameters
)

Параметры

template
Type: System..::..String
Шаблон ссылки
parameters
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь с параметрами

Возвращаемое значение

Сформированная ссылка

Примеры

Формирование ссылки на страницу элемента:

CopyC#
BXParamsBag<object> vars = new BXParamsBag<object>();
vars.Add("ElementId", 2);

string url;
if (EnableSef)
    url = BXComponentManager.MakeLink(
        Parameters.Get("SefFolder"),
        "/#ElementId#.aspx",
        vars
    );
else
    url = BXComponentManager.MakeLink(
        BXSefUrlManager.CurrentUrl.AbsolutePath + "?element=#ElementId#",
        vars
    );

Смотри также

Класс BXComponentManager
Перегрузка MakeLink
Пространство имен Bitrix.Components


Метод MakeLink (String, Object)

Метод BXComponentManager..::.MakeLink (String, Object)
Класс BXComponentManager Пример Смотри также Send Feedback
Конструирование ссылки по шаблону с заменой специальных выражений (#...#) на значения параметра. Внимание! Не использовать, если параметров больше чем 1

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string MakeLink(
    string template,
    Object parameter
)

Параметры

template
Type: System..::..String
Шаблон ЧПУ
parameter
Type: System..::..Object
Значение параметра

Возвращаемое значение

Сформированная ссылка

Заметки

Рекомендуется использовать метод MakeLink(String, BXParamsBag<(Of <<'(Object>)>>)).

Примеры

Формирование ссылки на страницу элемента:

CopyC#
int elementId = 2;

string url;
if (EnableSef)
    url = BXComponentManager.MakeLink(
        Parameters.Get("SefFolder"),
        "/#ElementId#.aspx",
        elementId
    );
else
    url = BXComponentManager.MakeLink(
        BXSefUrlManager.CurrentUrl.AbsolutePath + "?element=#ElementId#",
        elementId
    );

Смотри также

Класс BXComponentManager
Перегрузка MakeLink
Пространство имен Bitrix.Components


Метод MakeLink (String, String)

Метод BXComponentManager..::.MakeLink (String, String)
Класс BXComponentManager Пример Смотри также Send Feedback
Конструирование абсолютной ссылки из папки ЧПУ и шаблона ЧПУ

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string MakeLink(
    string root,
    string template
)

Параметры

root
Type: System..::..String
Путь к папке ЧПУ относительно корня приложения
template
Type: System..::..String
Шаблон ЧПУ

Возвращаемое значение

Сформированная ссылка

Примеры

Формирование шаблона ссылки на страницу элемента:

CopyC#
string linkTemplate;

if (EnableSef)
    linkTemplate = BXComponentManager.MakeLink(Parameters.Get("SefFolder"), "/#ElementId#.aspx");
else
    linkTemplate = BXSefUrlManager.CurrentUrl.AbsolutePath + "?element=#ElementId#";

ComponentCache["ElementLinkTemplate"] = linkTemplate;

Смотри также

Класс BXComponentManager
Перегрузка MakeLink
Пространство имен Bitrix.Components


Метод MakeLink (String, String, BXParamsBag(Object))

Метод BXComponentManager..::.MakeLink (String, String, BXParamsBag<(Of <(<'Object>)>)>)
Класс BXComponentManager Пример Смотри также Send Feedback
Конструирование ссылки из нескольких частей с заменой специальных выражений(#...#) на соответствующие параметры

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string MakeLink(
    string root,
    string template,
    BXParamsBag<Object> parameters
)

Параметры

root
Type: System..::..String
Путь к корню
template
Type: System..::..String
Шаблон ЧПУ
parameters
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь с параметрами

Возвращаемое значение

Сформированная ссылка

Примеры

Формирование ссылки на страницу элемента:

CopyC#
BXParamsBag<object> vars = new BXParamsBag<object>();
vars.Add("ElementId", 2);

string url;
if (EnableSef)
    url = BXComponentManager.MakeLink(
        Parameters.Get("SefFolder"),
        "/#ElementId#.aspx",
        vars
    );
else
    url = BXComponentManager.MakeLink(
        BXSefUrlManager.CurrentUrl.AbsolutePath + "?element=#ElementId#",
        vars
    );

Смотри также

Класс BXComponentManager
Перегрузка MakeLink
Пространство имен Bitrix.Components


Метод MakeLink (String, String, Object)

Метод BXComponentManager..::.MakeLink (String, String, Object)
Класс BXComponentManager Пример Смотри также Send Feedback
Конструирование ссылки из нескольких частей с заменой специальных выражений (#...#) на значения параметра. Внимание! Не использовать, если параметров больше чем 1

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string MakeLink(
    string root,
    string template,
    Object parameter
)

Параметры

root
Type: System..::..String
Путь к корню
template
Type: System..::..String
Шаблон ЧПУ
parameter
Type: System..::..Object
Значение параметра

Возвращаемое значение

Сформированная ссылка

Заметки

Рекомендуется использовать метод MakeLink(String, String, BXParamsBag<(Of <<'(Object>)>>)).

Примеры

Формирование ссылки на страницу элемента:

CopyC#
int elementId = 2;

string url;
if (EnableSef)
    url = BXComponentManager.MakeLink(
        Parameters.Get("SefFolder"),
        "/#ElementId#.aspx",
        elementId
    );
else
    url = BXComponentManager.MakeLink(
        BXSefUrlManager.CurrentUrl.AbsolutePath + "?element=#ElementId#",
        elementId
    );

Смотри также

Класс BXComponentManager
Перегрузка MakeLink
Пространство имен Bitrix.Components


Метод Map

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentManager..::.Map
Класс BXComponentManager Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Map(BXParamsBag<(Of <<'(String>)>>), String) | Возвращает ключ соответствующий текущим параметрам содержащимся в Request
Map(String, BXParamsBag<(Of <<'(String>)>>), String) | Возвращает ключ шаблона ЧПУ соответствующий текущей ссылке RawUrl
Map(String, BXParamsBag<(Of <<'(String>)>>), String, String) | Возвращает ключ шаблона ЧПУ соответствующий ссылке

Смотри также

Класс BXComponentManager
Члены BXComponentManager
Пространство имен Bitrix.Components


Метод Map (BXParamsBag(String), String)

Метод BXComponentManager..::.Map (BXParamsBag<(Of <(<'String>)>)>, String)
Класс BXComponentManager Пример Смотри также Send Feedback
Возвращает ключ соответствующий текущим параметрам содержащимся в Request

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string Map(
    BXParamsBag<string> mappingRule,
    string defaultCode
)

Параметры

mappingRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Словарь ключ + имя параметра в запросе
defaultCode
Type: System..::..String
Ключ по умолчанию.

Возвращаемое значение

Ключ в словаре или ключ по умолчанию, если соответствующий параметр в словаре не был найден.

Заметки

Используется при реализации механизмов контроллера в комплексных компонентах.

Примеры

Определение страницы в комплексном компоненте:

CopyC#
string page;
BXParamsBag<object> vars = new BXParamsBag<object>();
if (EnableSef)
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "/#ElementCode#.aspx");
    map.Add("section", "/#SectionCode#/");
    page = BXComponentManager.Map(Parameters.Get("SefFolder"), map, null);

    if (page != null)
        BXComponentManager.MapVariable(BXPath.ToVirtualAbsolutePath(BXPath.Combine(Parameters.Get("SefFolder"), map[page])), vars);
}
else
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "element");
    map.Add("section", "section");
    page = BXComponentManager.Map(map, null);

    BXParamsBag<string> varMap = new BXParamsBag<string>();
    varMap.Add("ElementCode", "element");
    varMap.Add("SectionCode", "element");
    BXComponentManager.MapVariable(varMap, vars);
}

switch (page)
{
    case "detail":

        //Здесь должен быть код

        break;
    case "section":

        //Здесь должен быть код

        break;
    default:

        // Здесь должен быть код

        break;
}

Смотри также

Класс BXComponentManager
Перегрузка Map
Пространство имен Bitrix.Components


Метод Map (String, BXParamsBag(String), String)

Метод BXComponentManager..::.Map (String, BXParamsBag<(Of <(<'String>)>)>, String)
Класс BXComponentManager Пример Смотри также Send Feedback
Возвращает ключ шаблона ЧПУ соответствующий текущей ссылке RawUrl

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string Map(
    string rootFolder,
    BXParamsBag<string> mappingRule,
    string defaultCode
)

Параметры

rootFolder
Type: System..::..String
Каталог ЧПУ (относительно корня сайта), может быть равен null
mappingRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Словарь ключ - шаблон ЧПУ (если rootFolder не пустой) или ключ - имя параметра в запросе (если rootFolder пустой)
defaultCode
Type: System..::..String
Ключ по умолчанию.

Возвращаемое значение

Ключ в словаре или ключ по умолчанию, если соответствующий шаблон в словаре не был найден.

Заметки

Если каталог ЧПУ пустой или не задан, то разбор будет происходить по параметрам в строке запроса

Рекомендуется использовать метод MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String)

Используется при реализации механизмов контроллера в комплексных компонентах.

Примеры

Определение страницы в комплексном компоненте:

CopyC#
string page;
BXParamsBag<object> vars = new BXParamsBag<object>();
if (EnableSef)
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "/#ElementCode#.aspx");
    map.Add("section", "/#SectionCode#/");
    page = BXComponentManager.Map(Parameters.Get("SefFolder"), map, null);

    if (page != null)
        BXComponentManager.MapVariable(BXPath.ToVirtualAbsolutePath(BXPath.Combine(Parameters.Get("SefFolder"), map[page])), vars);
}
else
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "element");
    map.Add("section", "section");
    page = BXComponentManager.Map(map, null);

    BXParamsBag<string> varMap = new BXParamsBag<string>();
    varMap.Add("ElementCode", "element");
    varMap.Add("SectionCode", "element");
    BXComponentManager.MapVariable(varMap, vars);
}

switch (page)
{
    case "detail":

        //Здесь должен быть код

        break;
    case "section":

        //Здесь должен быть код

        break;
    default:

        // Здесь должен быть код

        break;
}

Смотри также

Класс BXComponentManager
Перегрузка Map
Пространство имен Bitrix.Components


Метод Map (String, BXParamsBag(String), String, String)

Метод BXComponentManager..::.Map (String, BXParamsBag<(Of <(<'String>)>)>, String, String)
Класс BXComponentManager Пример Смотри также Send Feedback
Возвращает ключ шаблона ЧПУ соответствующий ссылке

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string Map(
    string rootFolder,
    BXParamsBag<string> mappingRule,
    string defaultCode,
    string currentUri
)

Параметры

rootFolder
Type: System..::..String
Каталог ЧПУ (относительно корня сайта)
mappingRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Словарь ключ - шаблон ЧПУ (если rootFolder не пустой) или ключ - имя параметра в запросе (если rootFolder пустой)
defaultCode
Type: System..::..String
Ключ по умолчанию.
currentUri
Type: System..::..String
Ссылка, для которой будет произведен поиск ЧПУ

Возвращаемое значение

Ключ в словаре или ключ по умолчанию, если соответствующий шаблон в словаре не был найден.

Заметки

Если каталог ЧПУ пустой или не задан, то разбор будет происходить по параметрам в строке запроса

Рекомендуется использовать метод MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String).

Используется при реализации механизмов контроллера в комплексных компонентах.

Примеры

Определение страницы в комплексном компоненте:

CopyC#
string url = BXSefUrlManager.CurrentUrl.ToString();
string page;
BXParamsBag<object> vars = new BXParamsBag<object>();
if (EnableSef)
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "/#ElementCode#.aspx");
    map.Add("section", "/#SectionCode#/");
    page = BXComponentManager.Map(Parameters.Get("SefFolder"), map, null, url);

    if (page != null)
        BXComponentManager.MapVariable(BXPath.ToVirtualAbsolutePath(BXPath.Combine(Parameters.Get("SefFolder"), map[page])), vars, url);
}
else
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "element");
    map.Add("section", "section");
    page = BXComponentManager.Map(map, null, url);

    BXParamsBag<string> varMap = new BXParamsBag<string>();
    varMap.Add("ElementCode", "element");
    varMap.Add("SectionCode", "element");
    BXComponentManager.MapVariable(varMap, vars, url);
}

switch (page)
{
    case "detail":

        //Здесь должен быть код

        break;
    case "section":

        //Здесь должен быть код

        break;
    default:

        // Здесь должен быть код

        break;
}

Смотри также

Класс BXComponentManager
Перегрузка Map
Пространство имен Bitrix.Components


Метод MapVariable

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentManager..::.MapVariable
Класс BXComponentManager Смотри также Send Feedback

Лист перегрузки

Имя | Описание
MapVariable(String, BXParamsBag<(Of <<'(Object>)>>)) | Выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь
MapVariable(BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>)) | Вытаскивает из Request переменные, которые описаны в mappingRule и помещает в словарь.
MapVariable(String, BXParamsBag<(Of <<'(Object>)>>), String) | Выполняет разбор ссылки по шаблону ЧПУ и складывает переменные в словарь
MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>)) | Определяет нужный шаблон ЧПУ. А затем выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь.
MapVariable(BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), Boolean) | Вытаскивает из строки запроса переменные, которые описаны в mappingRule и помещает в словарь.
MapVariable(BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String) | Вытаскивает из Request переменные, которые описаны в mappingRule и помещает в словарь.
MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String) | Определяет нужный шаблон ЧПУ. А затем выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь.
MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String, String) | Определяет нужный шаблон ЧПУ. А затем выполняет разбор ссылки по шаблону ЧПУ и складывает переменные в словарь.

Смотри также

Класс BXComponentManager
Члены BXComponentManager
Пространство имен Bitrix.Components


Метод MapVariable (String, BXParamsBag(Object))

Метод BXComponentManager..::.MapVariable (String, BXParamsBag<(Of <(<'Object>)>)>)
Класс BXComponentManager Пример Смотри также Send Feedback
Выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void MapVariable(
    string sefuTemplate,
    BXParamsBag<Object> variables
)

Параметры

sefuTemplate
Type: System..::..String
Шаблон ЧПУ
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные

Заметки

Рекомендуется использовать метод MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String)

Используется при реализации механизмов контроллера в комплексных компонентах.

Примеры

Определение страницы в комплексном компоненте:

CopyC#
string page;
BXParamsBag<object> vars = new BXParamsBag<object>();
if (EnableSef)
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "/#ElementCode#.aspx");
    map.Add("section", "/#SectionCode#/");

    page = BXComponentManager.Map(Parameters.Get("SefFolder"), map, null);
    if (page != null)
        BXComponentManager.MapVariable(BXPath.ToVirtualAbsolutePath(BXPath.Combine(Parameters.Get("SefFolder"), map[page])), vars);
}
else
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "element");
    map.Add("section", "section");
    page = BXComponentManager.Map(null, map, null);

    BXParamsBag<string> varMap = new BXParamsBag<string>();
    varMap.Add("ElementCode", "element");
    varMap.Add("SectionCode", "element");
    BXComponentManager.MapVariable(varMap, vars);
}

switch (page)
{
    case "detail":

        //Здесь должен быть код

        break;
    case "section":

        //Здесь должен быть код

        break;
    default:

        // Здесь должен быть код

        break;
}

Смотри также

Класс BXComponentManager
Перегрузка MapVariable
Пространство имен Bitrix.Components


Метод MapVariable (BXParamsBag(String), BXParamsBag(Object))

Метод BXComponentManager..::.MapVariable (BXParamsBag<(Of <(<'String>)>)>, BXParamsBag<(Of <(<'Object>)>)>)
Класс BXComponentManager Пример Смотри также Send Feedback
Вытаскивает из Request переменные, которые описаны в mappingRule и помещает в словарь.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void MapVariable(
    BXParamsBag<string> mappingRule,
    BXParamsBag<Object> variables
)

Параметры

mappingRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Словарь ключ - имя параметра в Request
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные

Примеры

Определение страницы в комплексном компоненте:

CopyC#
string page;
BXParamsBag<object> vars = new BXParamsBag<object>();
if (EnableSef)
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "/#ElementCode#.aspx");
    map.Add("section", "/#SectionCode#/");
    page = BXComponentManager.Map(Parameters.Get("SefFolder"), map, null);

    if (page != null)
        BXComponentManager.MapVariable(BXPath.ToVirtualAbsolutePath(BXPath.Combine(Parameters.Get("SefFolder"), map[page])), vars);
}
else
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "element");
    map.Add("section", "section");
    page = BXComponentManager.Map(null, map, null);

    BXParamsBag<string> varMap = new BXParamsBag<string>();
    varMap.Add("ElementCode", "element");
    varMap.Add("SectionCode", "element");
    BXComponentManager.MapVariable(varMap, vars);
}

switch (page)
{
    case "detail":

        //Здесь должен быть код

        break;
    case "section":

        //Здесь должен быть код

        break;
    default:

        // Здесь должен быть код

        break;
}

Смотри также

Класс BXComponentManager
Перегрузка MapVariable
Пространство имен Bitrix.Components


Метод MapVariable (String, BXParamsBag(Object), String)

Метод BXComponentManager..::.MapVariable (String, BXParamsBag<(Of <(<'Object>)>)>, String)
Класс BXComponentManager Пример Смотри также Send Feedback
Выполняет разбор ссылки по шаблону ЧПУ и складывает переменные в словарь

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void MapVariable(
    string sefuTemplate,
    BXParamsBag<Object> variables,
    string currentUri
)

Параметры

sefuTemplate
Type: System..::..String
Шаблон ЧПУ
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные
currentUri
Type: System..::..String
Ссылка, для которой производится разбор.

Примеры

Определение страницы в комплексном компоненте:

CopyC#
string url = BXSefUrlManager.CurrentUrl.ToString();
string page;
BXParamsBag<object> vars = new BXParamsBag<object>();
if (EnableSef)
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "/#ElementCode#.aspx");
    map.Add("section", "/#SectionCode#/");
    page = BXComponentManager.Map(Parameters.Get("SefFolder"), map, null, url);

    if (page != null)
        BXComponentManager.MapVariable(BXPath.ToVirtualAbsolutePath(BXPath.Combine(Parameters.Get("SefFolder"), map[page])), vars, url);
}
else
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "element");
    map.Add("section", "section");
    page = BXComponentManager.Map(map, null, url);

    BXParamsBag<string> varMap = new BXParamsBag<string>();
    varMap.Add("ElementCode", "element");
    varMap.Add("SectionCode", "element");
    BXComponentManager.MapVariable(varMap, vars, url);
}

switch (page)
{
    case "detail":

        //Здесь должен быть код

        break;
    case "section":

        //Здесь должен быть код

        break;
    default:

        // Здесь должен быть код

        break;
}

Смотри также

Класс BXComponentManager
Перегрузка MapVariable
Пространство имен Bitrix.Components


Метод MapVariable (String, BXParamsBag(String), BXParamsBag(Object))

Метод BXComponentManager..::.MapVariable (String, BXParamsBag<(Of <(<'String>)>)>, BXParamsBag<(Of <(<'Object>)>)>)
Класс BXComponentManager Пример Смотри также Send Feedback
Определяет нужный шаблон ЧПУ. А затем выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string MapVariable(
    string rootFolder,
    BXParamsBag<string> mappingUrlRule,
    BXParamsBag<Object> variables
)

Параметры

rootFolder
Type: System..::..String
Корневая папка для ЧПУ
mappingUrlRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Правила преобразования текущей ссылки к шаблону ЧПУ
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные

Возвращаемое значение

Ключ в словаре mappingUrlRule по которому произошел разбор или null, если соответствующий шаблон не был найден.

Заметки

Используется при реализации механизмов контроллера в комплексных компонентах.

Примеры

Разбор ЧПУ для определения страницы комплексного компонента и получения параметров из ЧПУ

CopyC#
string page;
BXParamsBag<object> vars = new BXParamsBag<object>();
if (EnableSef)
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "/#ElementCode#.aspx");
    map.Add("section", "/#SectionCode#/");

    page = BXComponentManager.MapVariable(Parameters.Get("SefFolder"), map, vars);
}

Смотри также

Класс BXComponentManager
Перегрузка MapVariable
Пространство имен Bitrix.Components


Метод MapVariable (BXParamsBag(String), BXParamsBag(Object), Boolean)

Метод BXComponentManager..::.MapVariable (BXParamsBag<(Of <(<'String>)>)>, BXParamsBag<(Of <(<'Object>)>)>, Boolean)
Класс BXComponentManager Смотри также Send Feedback
Вытаскивает из строки запроса переменные, которые описаны в mappingRule и помещает в словарь.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void MapVariable(
    BXParamsBag<string> mappingRule,
    BXParamsBag<Object> variables,
    bool handleNoValueParams
)

Параметры

mappingRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Словарь ключ - имя параметра в Request
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные
handleNoValueParams
Type: System..::..Boolean
Флаг обработки параметров без значений (например "all" в "list.aspx?all")

Смотри также

Класс BXComponentManager
Перегрузка MapVariable
Пространство имен Bitrix.Components


Метод MapVariable (BXParamsBag(String), BXParamsBag(Object), String)

Метод BXComponentManager..::.MapVariable (BXParamsBag<(Of <(<'String>)>)>, BXParamsBag<(Of <(<'Object>)>)>, String)
Класс BXComponentManager Пример Смотри также Send Feedback
Вытаскивает из Request переменные, которые описаны в mappingRule и помещает в словарь.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void MapVariable(
    BXParamsBag<string> mappingRule,
    BXParamsBag<Object> variables,
    string currentUri
)

Параметры

mappingRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Словарь ключ - имя параметра в Request
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные
currentUri
Type: System..::..String
Ссылка, для которой производится разбор.

Примеры

Определение страницы в комплексном компоненте:

CopyC#
string url = BXSefUrlManager.CurrentUrl.ToString();
string page;
BXParamsBag<object> vars = new BXParamsBag<object>();
if (EnableSef)
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "/#ElementCode#.aspx");
    map.Add("section", "/#SectionCode#/");
    page = BXComponentManager.Map(Parameters.Get("SefFolder"), map, null, url);

    if (page != null)
        BXComponentManager.MapVariable(BXPath.ToVirtualAbsolutePath(BXPath.Combine(Parameters.Get("SefFolder"), map[page])), vars, url);
}
else
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "element");
    map.Add("section", "section");
    page = BXComponentManager.Map(map, null, url);

    BXParamsBag<string> varMap = new BXParamsBag<string>();
    varMap.Add("ElementCode", "element");
    varMap.Add("SectionCode", "element");
    BXComponentManager.MapVariable(varMap, vars, url);
}

switch (page)
{
    case "detail":

        //Здесь должен быть код

        break;
    case "section":

        //Здесь должен быть код

        break;
    default:

        // Здесь должен быть код

        break;
}

Смотри также

Класс BXComponentManager
Перегрузка MapVariable
Пространство имен Bitrix.Components


Метод MapVariable (String, BXParamsBag(String), BXParamsBag(Object), String)

Метод BXComponentManager..::.MapVariable (String, BXParamsBag<(Of <(<'String>)>)>, BXParamsBag<(Of <(<'Object>)>)>, String)
Класс BXComponentManager Пример Смотри также Send Feedback
Определяет нужный шаблон ЧПУ. А затем выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string MapVariable(
    string rootFolder,
    BXParamsBag<string> mappingUrlRule,
    BXParamsBag<Object> variables,
    string defaultCode
)

Параметры

rootFolder
Type: System..::..String
Корневая папка для ЧПУ
mappingUrlRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Правила преобразования текущей ссылки к шаблону ЧПУ
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные
defaultCode
Type: System..::..String
Ключ по умолчанию

Возвращаемое значение

Ключ в словаре mappingUrlRule по которому произошел разбор, или ключ по умолчанию, если соответствующий шаблон не был найден.

Заметки

Используется при реализации механизмов контроллера в комплексных компонентах.

Примеры

Разбор ЧПУ для определения страницы комплексного компонента и получения параметров из ЧПУ

CopyC#
string page;
BXParamsBag<object> vars = new BXParamsBag<object>();
if (EnableSef)
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "/#ElementCode#.aspx");
    map.Add("section", "/#SectionCode#/");

    page = BXComponentManager.MapVariable(Parameters.Get("SefFolder"), map, vars, "default");
}

Смотри также

Класс BXComponentManager
Перегрузка MapVariable
Пространство имен Bitrix.Components


Метод MapVariable (String, BXParamsBag(String), BXParamsBag(Object), String, String)

Метод BXComponentManager..::.MapVariable (String, BXParamsBag<(Of <(<'String>)>)>, BXParamsBag<(Of <(<'Object>)>)>, String, String)
Класс BXComponentManager Пример Смотри также Send Feedback
Определяет нужный шаблон ЧПУ. А затем выполняет разбор ссылки по шаблону ЧПУ и складывает переменные в словарь.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string MapVariable(
    string rootFolder,
    BXParamsBag<string> mappingUrlRule,
    BXParamsBag<Object> variables,
    string defaultCode,
    string currentUri
)

Параметры

rootFolder
Type: System..::..String
Корневая папка для ЧПУ
mappingUrlRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Правила преобразования текущей ссылки к шаблону ЧПУ
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные
defaultCode
Type: System..::..String
Ключ по умолчанию
currentUri
Type: System..::..String
Ссылка для разбора

Возвращаемое значение

Ключ в словаре mappingUrlRule по которому произошел разбор, или ключ по умолчанию, если соответствующий шаблон не был найден.

Заметки

Используется при реализации механизмов контроллера в комплексных компонентах.

Примеры

Разбор ЧПУ для определения страницы комплексного компонента и получения параметров из ЧПУ

CopyC#
string page;
BXParamsBag<object> vars = new BXParamsBag<object>();
if (EnableSef)
{
    BXParamsBag<string> map = new BXParamsBag<string>();
    map.Add("detail", "/#ElementCode#.aspx");
    map.Add("section", "/#SectionCode#/");

    page = BXComponentManager.MapVariable(Parameters.Get("SefFolder"), map, vars, "default", BXSefUrlManager.CurrentUrl.ToString());
}

Смотри также

Класс BXComponentManager
Перегрузка MapVariable
Пространство имен Bitrix.Components


Класс BXComponentParameters

Класс BXComponentParameters
Члены Пример Смотри также Send Feedback
Хранилище параметров компонента, предоставляющее методы для интерпретации различных форматов данных и внутренние механизмы для работы системы компонентов. Cм. Parameters

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXComponentParameters : BXParamsBag<string>,
    IDictionary<string, string>, ICollection<KeyValuePair<string, string>>,
    IEnumerable<KeyValuePair<string, string>>, IEnumerable

Примеры

Оборачивание прямого обращения к параметру компонента в строго типизированное свойство:

CopyC#
public int NewsCount
{
    get { return Parameters.Get<int>("PagingRecordsPerPage"); }
}

Передача параметров и кешированных результатов работы родительского компонента в качестве параметров дочернего компонента с помощью серверных выражений:

CopyC#
<bx:IncludeComponent runat="server"
    ID="IncludeComponent1"
    ComponentName="bitrix:news.list"
    PageId="<%$ Results:PageId %>"
    PageShowAll="<%$ Results:PageShowAll %>"
    UrlTemplatesNews="<%$ Results:UrlTemplatesNews %>"
    UrlTemplatesNewsPage="<%$ Results:UrlTemplatesNewsPage %>"
    UrlTemplatesNewsShowAll="<%$ Results:UrlTemplatesNewsShowAll %>"
    ParentSectionId="<%$ Results:SectionId %>"
    DetailUrl="<%$ Results:UrlTemplatesDetail %>"
    SectionUrl="<%$ Results:UrlTemplatesSection %>"
    ParamSection = "<%$ Parameters:ParamSection %>"
    ShowPreviewText="<%$ Parameters:ListShowPreviewText%>"
    ShowTitle="<%$ Parameters:ListShowTitle%>"
    ShowDetailText="<%$ Parameters:ListShowDetailText%>"
    ShowPreviewPicture="<%$ Parameters:ListShowPreviewPicture%>"
    SetTitle="<%$ Parameters:ListSetTitle%>"
    ShowDate="<%$ Parameters:ListShowDate%>"
    ActiveDateFormat="<%$ Parameters:ActiveDateFormat%>"
/>

Иерархия наследования

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Bitrix.Components..::..BXComponentParameters

Смотри также

Члены BXComponentParameters
Пространство имен Bitrix.Components


Члены BXComponentParameters

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXComponentParameters
Класс BXComponentParameters Конструкторы Методы Смотри также Send Feedback

Тип BXComponentParameters предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXComponentParameters |

Методы

Имя | Описание
Add | Добавляет новый элемент в словарь или перезаписывает существующий. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
Assign | Очищает словарь и наполняет его данными из другого словаря. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
Get | Перегруженный.
GetBool | Перегруженный.
GetDouble | Перегруженный.
GetEnum | Перегруженный.
GetFloat | Перегруженный.
GetInt | Перегруженный.
GetList | Перегруженный.
GetListInt | Перегруженный.
GetListString | Перегруженный.
GetLong | Перегруженный.
GetString | Перегруженный.
Override | Перекрыть значениями из пользовательского словаря (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
ToList<(Of <<'(R>)>>) | Формирует список на основе значений, хранящихся в данном словаре. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
ToString | Сериализует словарь в строку. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetBool | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetDouble | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetFloat | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetInt | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetLong | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetString | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetValue<(Of <<'(R>)>>) | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)

Смотри также

Класс BXComponentParameters
Пространство имен Bitrix.Components


Конструктор BXComponentParameters

Конструктор BXComponentParameters
Класс BXComponentParameters Смотри также Send Feedback

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXComponentParameters()

Смотри также

Класс BXComponentParameters
Пространство имен Bitrix.Components


Методы BXComponentParameters

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXComponentParameters
Класс BXComponentParameters Смотри также Send Feedback

Тип BXComponentParameters предоставляет следующие возможности.

Методы

Имя | Описание
Add | Добавляет новый элемент в словарь или перезаписывает существующий. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
Assign | Очищает словарь и наполняет его данными из другого словаря. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
Get | Перегруженный.
GetBool | Перегруженный.
GetDouble | Перегруженный.
GetEnum | Перегруженный.
GetFloat | Перегруженный.
GetInt | Перегруженный.
GetList | Перегруженный.
GetListInt | Перегруженный.
GetListString | Перегруженный.
GetLong | Перегруженный.
GetString | Перегруженный.
Override | Перекрыть значениями из пользовательского словаря (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
ToList<(Of <<'(R>)>>) | Формирует список на основе значений, хранящихся в данном словаре. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
ToString | Сериализует словарь в строку. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetBool | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetDouble | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetFloat | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetInt | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetLong | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetString | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
TryGetValue<(Of <<'(R>)>>) | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)

Смотри также

Класс BXComponentParameters
Пространство имен Bitrix.Components


Метод Get

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentParameters..::.Get
Класс BXComponentParameters Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Get(String, T) |
Get(String) | Возвращает значение по ключу или значение по умолчанию для типа, если такого ключа не существует. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
Get(String, T) | Возвращает значение по ключу или defaultValue, если такого ключа не существует. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)

Смотри также

Класс BXComponentParameters
Члены BXComponentParameters
Пространство имен Bitrix.Components


Метод GetBool

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentParameters..::.GetBool
Класс BXComponentParameters Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetBool(String) | Приводит значение по ключу к булевому значению или возвращает false, если такого ключа не существует или приведение не удалось. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
GetBool(String, Boolean) | Приводит значение по ключу к булевому значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)

Смотри также

Класс BXComponentParameters
Члены BXComponentParameters
Пространство имен Bitrix.Components


Метод GetDouble

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentParameters..::.GetDouble
Класс BXComponentParameters Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetDouble(String) | Приводит значение по ключу к вещественному значению или возвращает 0, если такого ключа не существует или приведение не удалось. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
GetDouble(String, Double) | Приводит значение по ключу к вещественному значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)

Смотри также

Класс BXComponentParameters
Члены BXComponentParameters
Пространство имен Bitrix.Components


Метод GetEnum

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentParameters..::.GetEnum
Класс BXComponentParameters Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetEnum<(Of <<'(TEnum>)>>)(String) | Интерпретирует значение параметра как элемент перечисления.
GetEnum<(Of <<'(TEnum>)>>)(String, TEnum) | Интерпретирует значение параметра как элемент перечисления.

Смотри также

Класс BXComponentParameters
Члены BXComponentParameters
Пространство имен Bitrix.Components


Метод GetEnum(TEnum) (String)

Метод BXComponentParameters..::.GetEnum<(Of <(<'TEnum>)>)> (String)
Класс BXComponentParameters Пример Смотри также Send Feedback
Интерпретирует значение параметра как элемент перечисления.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public TEnum GetEnum<TEnum>(
    string parameterName
)

Параметры

parameterName
Type: System..::..String
Имя параметра.

Параметры типа

TEnum
Тип перечисления

Возвращаемое значение

Элемент перечисления или значение по умолчанию для перечисления, если параметра с таким именем не существует или параметр не может быть интерпретирован как элемент перечисления указанного типа.

Примеры

Описание свойства-обертки над параметром типа перечисление:

CopyC#
public SizeInterpolationMode SizeDistribution
{
    get
    {
        return GetEnum<SizeInterpolationMode>("SizeDistribution");
    }
}

public enum SizeInterpolationMode
{
    None,
    Linear,
    Exponential
}

Смотри также

Класс BXComponentParameters
Перегрузка GetEnum
Пространство имен Bitrix.Components


Метод GetEnum(TEnum) (String, TEnum)

Метод BXComponentParameters..::.GetEnum<(Of <(<'TEnum>)>)> (String, TEnum)
Класс BXComponentParameters Пример Смотри также Send Feedback
Интерпретирует значение параметра как элемент перечисления.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public TEnum GetEnum<TEnum>(
    string parameterName,
    TEnum defaultValue
)

Параметры

parameterName
Type: System..::..String
Имя параметра.
defaultValue
Type: TEnum
Значение по умолчанию

Параметры типа

TEnum
Тип перечисления

Возвращаемое значение

Элемент перечисления или defaultValue, если параметра с таким именем не существует или параметр не может быть интерпретирован как элемент перечисления указанного типа.

Примеры

Описание свойства-обертки над параметром типа перечисление:

CopyC#
public SizeInterpolationMode SizeDistribution
{
    get
    {
        return GetEnum("SizeDistribution", SizeInterpolationMode.Linear);
    }
}

public enum SizeInterpolationMode
{
    None,
    Linear,
    Exponential
}

Смотри также

Класс BXComponentParameters
Перегрузка GetEnum
Пространство имен Bitrix.Components


Метод GetFloat

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentParameters..::.GetFloat
Класс BXComponentParameters Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetFloat(String) | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
GetFloat(String, Single) | (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)

Смотри также

Класс BXComponentParameters
Члены BXComponentParameters
Пространство имен Bitrix.Components


Метод GetInt

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentParameters..::.GetInt
Класс BXComponentParameters Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetInt(String) | Приводит значение по ключу к 32-битному целочисленному значению или возвращает 0, если такого ключа не существует или приведение не удалось. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
GetInt(String, Int32) | Приводит значение по ключу к 32-битному целочисленному значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)

Смотри также

Класс BXComponentParameters
Члены BXComponentParameters
Пространство имен Bitrix.Components


Метод GetList

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentParameters..::.GetList
Класс BXComponentParameters Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetList(String) | Устаревший. Интерпретирует значение параметра как CSV список значений.
GetList(String, List<(Of <<'(Object>)>>)) | Устаревший. Интерпретирует значение параметра как CSV список значений.

Смотри также

Класс BXComponentParameters
Члены BXComponentParameters
Пространство имен Bitrix.Components


Метод GetList (String)

Метод BXComponentParameters..::.GetList (String)
Класс BXComponentParameters Смотри также Send Feedback
Интерпретирует значение параметра как CSV список значений.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
[ObsoleteAttribute("use GetListString method instead")]
public List<Object> GetList(
    string parameterName
)

Параметры

parameterName
Type: System..::..String
Имя параметра.

Возвращаемое значение

Список значений или пустой список, если параметра с таким именем не существует.

Заметки

Данный метод устарел и не рекомендуется к использованию. Рекомендуется использовать метод GetListString(String).

Смотри также

Класс BXComponentParameters
Перегрузка GetList
Пространство имен Bitrix.Components


Метод GetList (String, List(Object))

Метод BXComponentParameters..::.GetList (String, List<(Of <(<'Object>)>)>)
Класс BXComponentParameters Смотри также Send Feedback
Интерпретирует значение параметра как CSV список значений.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
[ObsoleteAttribute("use GetListString method instead")]
public List<Object> GetList(
    string parameterName,
    List<Object> defaultValue
)

Параметры

parameterName
Type: System..::..String
Имя параметра.
defaultValue
Type: System.Collections.Generic..::..List <(Of <(<' Object >)>)>
Значение по умолчанию.

Возвращаемое значение

Список значений или defaultValue, если параметра с таким именем не существует.

Заметки

Данный метод устарел и не рекомендуется к использованию. Рекомендуется использовать метод GetListString(String, List<(Of <<'(String>)>>)).

Смотри также

Класс BXComponentParameters
Перегрузка GetList
Пространство имен Bitrix.Components


Метод GetListInt

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentParameters..::.GetListInt
Класс BXComponentParameters Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetListInt(String) | Интерпретирует значение параметра как CSV список целочисленных значений.
GetListInt(String, List<(Of <<'(Int32>)>>)) | Интерпретирует значение параметра как CSV список целочисленных значений.

Смотри также

Класс BXComponentParameters
Члены BXComponentParameters
Пространство имен Bitrix.Components


Метод GetListInt (String)

Метод BXComponentParameters..::.GetListInt (String)
Класс BXComponentParameters Пример Смотри также Send Feedback
Интерпретирует значение параметра как CSV список целочисленных значений.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public List<int> GetListInt(
    string parameterName
)

Параметры

parameterName
Type: System..::..String
Имя параметра.

Возвращаемое значение

Список значений или пустой список, если параметра с таким именем не существует или параметр не может быть интерпретирован как CSV список.

Заметки

Возвращаемый список состоит только из тех значений, которые удалось привести к целому числу.

Примеры

Вывод элементов из нескольких инфоблоков, заданных в настройках компонента:

CopyC#
int[] iblocks = Parameters.GetListInt("IBlocks");
BXIBlockElementCollection elements = BXIBlockElement.GetList(
    new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.In, iblocks)),
    new BXOrderBy(new BXOrderByPair(BXIBlockElement.Fields.UpdateDate, BXOrderByDirection.Desc))
);

Смотри также

Класс BXComponentParameters
Перегрузка GetListInt
Пространство имен Bitrix.Components


Метод GetListInt (String, List(Int32))

Метод BXComponentParameters..::.GetListInt (String, List<(Of <(<'Int32>)>)>)
Класс BXComponentParameters Пример Смотри также Send Feedback
Интерпретирует значение параметра как CSV список целочисленных значений.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public List<int> GetListInt(
    string parameterName,
    List<int> defaultValue
)

Параметры

parameterName
Type: System..::..String
Имя параметра.
defaultValue
Type: System.Collections.Generic..::..List <(Of <(<' Int32 >)>)>
Список по умолчанию.

Возвращаемое значение

Список значений или список по умолчанию, если параметра с таким именем не существует или параметр не может быть интерпретирован как CSV список.

Заметки

Возвращаемый список состоит только из тех значений, которые удалось привести к целому числу.

Примеры

Вывод элементов из нескольких инфоблоков, заданных в настройках компонента:

CopyC#
List<int> iblocks = Parameters.GetListInt("IBlocks", null);
BXIBlockElementCollection elements =
    (iblocks != null && iblocks.Count != 0)
    ? BXIBlockElement.GetList(
        new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.In, iblocks)),
        new BXOrderBy(new BXOrderByPair(BXIBlockElement.Fields.UpdateDate, BXOrderByDirection.Desc))
    )
    : new BXIBlockElementCollection();

Смотри также

Класс BXComponentParameters
Перегрузка GetListInt
Пространство имен Bitrix.Components


Метод GetListString

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentParameters..::.GetListString
Класс BXComponentParameters Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetListString(String) | Интерпретирует значение параметра как CSV список значений.
GetListString(String, List<(Of <<'(String>)>>)) | Интерпретирует значение параметра как CSV список значений.

Смотри также

Класс BXComponentParameters
Члены BXComponentParameters
Пространство имен Bitrix.Components


Метод GetListString (String)

Метод BXComponentParameters..::.GetListString (String)
Класс BXComponentParameters Пример Смотри также Send Feedback
Интерпретирует значение параметра как CSV список значений.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public List<string> GetListString(
    string parameterName
)

Параметры

parameterName
Type: System..::..String
Имя параметра.

Возвращаемое значение

Список значений или пустой список, если параметра с таким именем не существует или параметр не может быть интерпретирован как CSV список.

Примеры

Вывод пользовательских свойств, выбранных при настройке компонента:

CopyC#
<%
    Bitrix.BXCustomProperty property;
    foreach (string p in Parameters.GetListString("Properties"))
    if (element.CustomValues.TryGetValue(p, out property)
    {
%>
    <%= property.UserLikeName %>:  <%= property.Value %>
    <br />
<%
    }
%>

Смотри также

Класс BXComponentParameters
Перегрузка GetListString
Пространство имен Bitrix.Components


Метод GetListString (String, List(String))

Метод BXComponentParameters..::.GetListString (String, List<(Of <(<'String>)>)>)
Класс BXComponentParameters Пример Смотри также Send Feedback
Интерпретирует значение параметра как CSV список значений.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public List<string> GetListString(
    string parameterName,
    List<string> defaultValue
)

Параметры

parameterName
Type: System..::..String
Имя параметра.
defaultValue
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
Значение по умолчанию

Возвращаемое значение

Список значений или defaultValue, если параметра с таким именем не существует или параметр не может быть интерпретирован как CSV список.

Примеры

Вывод пользовательских свойств, выбранных при настройке компонента:

CopyC#
<%
    Bitrix.BXCustomProperty property;
    foreach (string p in (Parameters.GetListString("Properties", null) ?? new List<string>()))
    if (element.CustomValues.TryGetValue(p, out property)
    {
%>
    <%= property.UserLikeName %>:  <%= property.Value %>
    <br />
<%
    }
%>

Смотри также

Класс BXComponentParameters
Перегрузка GetListString
Пространство имен Bitrix.Components


Метод GetLong

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentParameters..::.GetLong
Класс BXComponentParameters Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetLong(String) | Приводит значение по ключу к 64-битному целочисленному значению или возвращает 0, если такого ключа не существует или приведение не удалось. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
GetLong(String, Int64) | Приводит значение по ключу к 64-битному целочисленному значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)

Смотри также

Класс BXComponentParameters
Члены BXComponentParameters
Пространство имен Bitrix.Components


Метод GetString

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentParameters..::.GetString
Класс BXComponentParameters Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetString(String) | Приводит значение по ключу к строковому значению или возвращает null, если такого ключа не существует или приведение не удалось. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)
GetString(String, String) | Приводит значение по ключу к строковому значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось. (Унаследовано от BXParamsBag<(Of <(<'T>)>)>)

Смотри также

Класс BXComponentParameters
Члены BXComponentParameters
Пространство имен Bitrix.Components


Класс BXParam

Класс BXParam
Члены Смотри также Send Feedback
Класс, описывающий параметры компонента

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXParam : IBXChangeable

Иерархия наследования

System..::..Object
Bitrix.Components..::..BXParam
Bitrix.Components..::..BXParamMultiSelection
Bitrix.Components..::..BXParamMultiSelectionWithText
Bitrix.Components..::..BXParamSingleSelection
Bitrix.Components..::..BXParamSingleSelectionWithText
Bitrix.Components..::..BXParamSort
Bitrix.Components..::..BXParamText
Bitrix.Components..::..BXParamYesNo

Смотри также

Члены BXParam
Пространство имен Bitrix.Components


Члены BXParam

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXParam
Класс BXParam Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXParam предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXParam | Перегруженный.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр.
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента.
DefaultValue | Возвращает значение параметра по умолчанию
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра.
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра
SelectedValue | Возвращает или устанавливает текущее значение параметра
Title | Возвращает или устанавливает заголовок параметра.
Type | Возвращает или устанавливает тип параметра.
Values | Возвращает или устанавливает список предопределенных значений параметра
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе.

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Конструктор BXParam

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXParam
Класс BXParam Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXParam(String, BXParamType, String, BXCategory, IEnumerable<(Of <<'(BXParamValue>)>>)) | Создает новый экземпляр класса BXParam.
BXParam(String, BXParamType, String, BXCategory, IEnumerable<(Of <<'(BXParamValue>)>>), ParamClientSideAction) | Создает новый экземпляр класса.

Смотри также

Класс BXParam
Члены BXParam
Пространство имен Bitrix.Components


Конструктор BXParam (String, BXParamType, String, , IEnumerable(BXParamValue))

Конструктор BXParam (String, BXParamType, String, , IEnumerable<(Of <(<'BXParamValue>)>)>)
Класс BXParam Смотри также Send Feedback
Создает новый экземпляр класса BXParam.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParam(
    string title,
    BXParamType type,
    string value,
    BXCategory category,
    IEnumerable<BXParamValue> possibleValues
)

Параметры

title
Type: System..::..String
Заголовок параметра
type
Type: Bitrix.Components..::..BXParamType
Тип параметра
value
Type: System..::..String
Значение параметра по умолчанию
category
Type: BXCategory
Категория, к которой относится параметр компонента
possibleValues
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BXParamValue >)>)>
Список предопределенных значений параметра

Смотри также

Класс BXParam
Перегрузка BXParam
Пространство имен Bitrix.Components


Конструктор BXParam (String, BXParamType, String, , IEnumerable(BXParamValue), )

Конструктор BXParam (String, BXParamType, String, , IEnumerable<(Of <(<'BXParamValue>)>)>, )
Класс BXParam Смотри также Send Feedback
Создает новый экземпляр класса.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParam(
    string title,
    BXParamType type,
    string value,
    BXCategory category,
    IEnumerable<BXParamValue> possibleValues,
    ParamClientSideAction clientSideAction
)

Параметры

title
Type: System..::..String
Заголовок параметра
type
Type: Bitrix.Components..::..BXParamType
Тип параметра
value
Type: System..::..String
Значение параметра по умолчанию
category
Type: BXCategory
Категория, к которой относится параметр компонента
possibleValues
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BXParamValue >)>)>
Список предопределенных значений параметра
clientSideAction
Type: ParamClientSideAction
Особое поведение параметра в редакторе на стороне клиента

Смотри также

Класс BXParam
Перегрузка BXParam
Пространство имен Bitrix.Components


Методы BXParam

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXParam
Класс BXParam Смотри также Send Feedback

Тип BXParam предоставляет следующие возможности.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Метод AdjustPresentation

Метод BXParam..::.AdjustPresentation
Класс BXParam Смотри также Send Feedback
Настраивает представление параметра в соответствии с его особым поведением

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
[ObsoleteAttribute("this method does nothing")]
public void AdjustPresentation(
    BXComponent component
)

Параметры

component
Type: Bitrix.UI..::..BXComponent
Компонент, для параметров которого производится настройка

Заметки

Устаревший. Не производит никаких действий. Оставлен для обеспечения совместимости.

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Свойства BXParam

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXParam
Класс BXParam Смотри также Send Feedback

Тип BXParam предоставляет следующие возможности.

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр.
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента.
DefaultValue | Возвращает значение параметра по умолчанию
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра.
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра
SelectedValue | Возвращает или устанавливает текущее значение параметра
Title | Возвращает или устанавливает заголовок параметра.
Type | Возвращает или устанавливает тип параметра.
Values | Возвращает или устанавливает список предопределенных значений параметра
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе.

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Свойство Category

Свойство BXParam..::.Category
Класс BXParam Смотри также Send Feedback
Возвращает категорию к которой относится параметр.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXCategory Category { get; }

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Свойство ClientSideAction

Свойство BXParam..::.ClientSideAction
Класс BXParam Смотри также Send Feedback
Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public ParamClientSideAction ClientSideAction { get; set; }

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Свойство DefaultValue

Свойство BXParam..::.DefaultValue
Класс BXParam Смотри также Send Feedback
Возвращает значение параметра по умолчанию

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string DefaultValue { get; set; }

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Свойство IsDirty

Свойство BXParam..::.IsDirty
Класс BXParam Смотри также Send Feedback
Возвращает или устанавливает, изменялось ли значение параметра.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool IsDirty { get; set; }

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Свойство RefreshOnDirty

Свойство BXParam..::.RefreshOnDirty
Класс BXParam Смотри также Send Feedback
Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool RefreshOnDirty { get; set; }

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Свойство SelectedValue

Свойство BXParam..::.SelectedValue
Класс BXParam Смотри также Send Feedback
Возвращает или устанавливает текущее значение параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string SelectedValue { get; set; }

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Свойство Title

Свойство BXParam..::.Title
Класс BXParam Смотри также Send Feedback
Возвращает или устанавливает заголовок параметра.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Title { get; set; }

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Свойство Type

Свойство BXParam..::.Type
Класс BXParam Смотри также Send Feedback
Возвращает или устанавливает тип параметра.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamType Type { get; set; }

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Свойство Values

Свойство BXParam..::.Values
Класс BXParam Смотри также Send Feedback
Возвращает или устанавливает список предопределенных значений параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public List<BXParamValue> Values { get; set; }

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Свойство Visible

Свойство BXParam..::.Visible
Класс BXParam Смотри также Send Feedback
Возвращает или устанавливает, отображается ли параметр в редакторе.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool Visible { get; set; }

Смотри также

Класс BXParam
Пространство имен Bitrix.Components


Класс BXParamMultiSelection

Класс BXParamMultiSelection
Члены Пример Смотри также Send Feedback
Класс параметра компонента, представленного списком значений с множественной выборкой.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXParamMultiSelection : BXParam

Примеры

CopyC#
protected override void PreLoadComponentDefinition()
{

    ...

    ParamsDefinition.Add(
        "GroupPermissions",
        new BXParamMultiSelection(
            "Роли, имеющие права на просмотр",
            "1",
            BXCategory.AdditionalSettings
        )
    );

    ...
}

Иерархия наследования

System..::..Object
Bitrix.Components..::..BXParam
Bitrix.Components..::..BXParamMultiSelection

Смотри также

Члены BXParamMultiSelection
Пространство имен Bitrix.Components


Члены BXParamMultiSelection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXParamMultiSelection
Класс BXParamMultiSelection Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXParamMultiSelection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXParamMultiSelection | Перегруженный.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamMultiSelection
Пространство имен Bitrix.Components


Конструктор BXParamMultiSelection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXParamMultiSelection
Класс BXParamMultiSelection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXParamMultiSelection(String, String, BXCategory) | Создает экземпляр класса параметра
BXParamMultiSelection(String, String, BXCategory, IEnumerable<(Of <<'(BXParamValue>)>>)) | Создает экземпляр класса параметра
BXParamMultiSelection(String, String, BXCategory, IEnumerable<(Of <<'(BXParamValue>)>>), ParamClientSideAction) | Создает экземпляр класса параметра

Смотри также

Класс BXParamMultiSelection
Члены BXParamMultiSelection
Пространство имен Bitrix.Components


Конструктор BXParamMultiSelection (String, String, )

Конструктор BXParamMultiSelection (String, String, )
Класс BXParamMultiSelection Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamMultiSelection(
    string title,
    string value,
    BXCategory category
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..String
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр

Смотри также

Класс BXParamMultiSelection
Перегрузка BXParamMultiSelection
Пространство имен Bitrix.Components


Конструктор BXParamMultiSelection (String, String, , IEnumerable(BXParamValue))

Конструктор BXParamMultiSelection (String, String, , IEnumerable<(Of <(<'BXParamValue>)>)>)
Класс BXParamMultiSelection Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamMultiSelection(
    string title,
    string value,
    BXCategory category,
    IEnumerable<BXParamValue> possibleValues
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..String
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр
possibleValues
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BXParamValue >)>)>
Список предопределенных значений

Смотри также

Класс BXParamMultiSelection
Перегрузка BXParamMultiSelection
Пространство имен Bitrix.Components


Конструктор BXParamMultiSelection (String, String, , IEnumerable(BXParamValue), )

Конструктор BXParamMultiSelection (String, String, , IEnumerable<(Of <(<'BXParamValue>)>)>, )
Класс BXParamMultiSelection Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamMultiSelection(
    string title,
    string value,
    BXCategory category,
    IEnumerable<BXParamValue> possibleValues,
    ParamClientSideAction clientSideAction
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..String
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр
possibleValues
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BXParamValue >)>)>
Список предопределенных значений
clientSideAction
Type: ParamClientSideAction
Особое поведение параметра в редакторе на стороне клиента

Смотри также

Класс BXParamMultiSelection
Перегрузка BXParamMultiSelection
Пространство имен Bitrix.Components


Методы BXParamMultiSelection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXParamMultiSelection
Класс BXParamMultiSelection Смотри также Send Feedback

Тип BXParamMultiSelection предоставляет следующие возможности.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Смотри также

Класс BXParamMultiSelection
Пространство имен Bitrix.Components


Свойства BXParamMultiSelection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXParamMultiSelection
Класс BXParamMultiSelection Смотри также Send Feedback

Тип BXParamMultiSelection предоставляет следующие возможности.

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamMultiSelection
Пространство имен Bitrix.Components


Класс BXParamMultiSelectionWithText

Класс BXParamMultiSelectionWithText
Члены Пример Смотри также Send Feedback
Класс параметра компонента, представленного списком значений с множественной выборкой и дополнительными текстовыми полями.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXParamMultiSelectionWithText : BXParam

Примеры

CopyC#
protected override void PreLoadComponentDefinition()
{

    ...

    ParamsDefinition.Add(
        "ELProperties",
        new BXParamMultiSelectionWithText(
            "Отображаемые пользовательские свойства",
            "",
            BXCategory.ListSettings
        )
    );

    ...
}

Иерархия наследования

System..::..Object
Bitrix.Components..::..BXParam
Bitrix.Components..::..BXParamMultiSelectionWithText

Смотри также

Члены BXParamMultiSelectionWithText
Пространство имен Bitrix.Components


Члены BXParamMultiSelectionWithText

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXParamMultiSelectionWithText
Класс BXParamMultiSelectionWithText Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXParamMultiSelectionWithText предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXParamMultiSelectionWithText | Перегруженный.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamMultiSelectionWithText
Пространство имен Bitrix.Components


Конструктор BXParamMultiSelectionWithText

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXParamMultiSelectionWithText
Класс BXParamMultiSelectionWithText Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXParamMultiSelectionWithText(String, String, BXCategory) | Создает экземпляр класса параметра
BXParamMultiSelectionWithText(String, String, BXCategory, IEnumerable<(Of <<'(BXParamValue>)>>)) | Создает экземпляр класса параметра
BXParamMultiSelectionWithText(String, String, BXCategory, IEnumerable<(Of <<'(BXParamValue>)>>), ParamClientSideAction) | Создает экземпляр класса параметра

Смотри также

Класс BXParamMultiSelectionWithText
Члены BXParamMultiSelectionWithText
Пространство имен Bitrix.Components


Конструктор BXParamMultiSelectionWithText (String, String, )

Конструктор BXParamMultiSelectionWithText (String, String, )
Класс BXParamMultiSelectionWithText Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamMultiSelectionWithText(
    string title,
    string value,
    BXCategory category
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..String
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр

Смотри также

Класс BXParamMultiSelectionWithText
Перегрузка BXParamMultiSelectionWithText
Пространство имен Bitrix.Components


Конструктор BXParamMultiSelectionWithText (String, String, , IEnumerable(BXParamValue))

Конструктор BXParamMultiSelectionWithText (String, String, , IEnumerable<(Of <(<'BXParamValue>)>)>)
Класс BXParamMultiSelectionWithText Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamMultiSelectionWithText(
    string title,
    string value,
    BXCategory category,
    IEnumerable<BXParamValue> possibleValues
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..String
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр
possibleValues
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BXParamValue >)>)>
Список предопределенных значений

Смотри также

Класс BXParamMultiSelectionWithText
Перегрузка BXParamMultiSelectionWithText
Пространство имен Bitrix.Components


Конструктор BXParamMultiSelectionWithText (String, String, , IEnumerable(BXParamValue), )

Конструктор BXParamMultiSelectionWithText (String, String, , IEnumerable<(Of <(<'BXParamValue>)>)>, )
Класс BXParamMultiSelectionWithText Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamMultiSelectionWithText(
    string title,
    string value,
    BXCategory category,
    IEnumerable<BXParamValue> possibleValues,
    ParamClientSideAction clientSideAction
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..String
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр
possibleValues
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BXParamValue >)>)>
Список предопределенных значений
clientSideAction
Type: ParamClientSideAction
Особое поведение параметра в редакторе на стороне клиента

Смотри также

Класс BXParamMultiSelectionWithText
Перегрузка BXParamMultiSelectionWithText
Пространство имен Bitrix.Components


Методы BXParamMultiSelectionWithText

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXParamMultiSelectionWithText
Класс BXParamMultiSelectionWithText Смотри также Send Feedback

Тип BXParamMultiSelectionWithText предоставляет следующие возможности.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Смотри также

Класс BXParamMultiSelectionWithText
Пространство имен Bitrix.Components


Свойства BXParamMultiSelectionWithText

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXParamMultiSelectionWithText
Класс BXParamMultiSelectionWithText Смотри также Send Feedback

Тип BXParamMultiSelectionWithText предоставляет следующие возможности.

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamMultiSelectionWithText
Пространство имен Bitrix.Components


Класс BXParamSingleSelection

Класс BXParamSingleSelection
Члены Пример Смотри также Send Feedback
Класс параметра компонента, представленного раскрывающимся списком.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXParamSingleSelection : BXParam

Примеры

CopyC#
protected override void PreLoadComponentDefinition()
{

    ...

    ParamsDefinition.Add(
        "IBlockTypeId",
        new BXParamSingleSelection(
            "Тип инфоблока",
            "",
            BXCategory.Main
        )
    );

    ...
}

Иерархия наследования

System..::..Object
Bitrix.Components..::..BXParam
Bitrix.Components..::..BXParamSingleSelection

Смотри также

Члены BXParamSingleSelection
Пространство имен Bitrix.Components


Члены BXParamSingleSelection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXParamSingleSelection
Класс BXParamSingleSelection Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXParamSingleSelection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXParamSingleSelection | Перегруженный.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamSingleSelection
Пространство имен Bitrix.Components


Конструктор BXParamSingleSelection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXParamSingleSelection
Класс BXParamSingleSelection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXParamSingleSelection(String, String, BXCategory) | Создает экземпляр класса параметра
BXParamSingleSelection(String, String, BXCategory, IEnumerable<(Of <<'(BXParamValue>)>>)) | Создает экземпляр класса параметра
BXParamSingleSelection(String, String, BXCategory, IEnumerable<(Of <<'(BXParamValue>)>>), ParamClientSideAction) | Создает экземпляр класса параметра

Смотри также

Класс BXParamSingleSelection
Члены BXParamSingleSelection
Пространство имен Bitrix.Components


Конструктор BXParamSingleSelection (String, String, )

Конструктор BXParamSingleSelection (String, String, )
Класс BXParamSingleSelection Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamSingleSelection(
    string title,
    string value,
    BXCategory category
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..String
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр

Смотри также

Класс BXParamSingleSelection
Перегрузка BXParamSingleSelection
Пространство имен Bitrix.Components


Конструктор BXParamSingleSelection (String, String, , IEnumerable(BXParamValue))

Конструктор BXParamSingleSelection (String, String, , IEnumerable<(Of <(<'BXParamValue>)>)>)
Класс BXParamSingleSelection Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamSingleSelection(
    string title,
    string value,
    BXCategory category,
    IEnumerable<BXParamValue> possibleValues
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..String
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр
possibleValues
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BXParamValue >)>)>
Список предопределенных значений

Смотри также

Класс BXParamSingleSelection
Перегрузка BXParamSingleSelection
Пространство имен Bitrix.Components


Конструктор BXParamSingleSelection (String, String, , IEnumerable(BXParamValue), )

Конструктор BXParamSingleSelection (String, String, , IEnumerable<(Of <(<'BXParamValue>)>)>, )
Класс BXParamSingleSelection Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamSingleSelection(
    string title,
    string value,
    BXCategory category,
    IEnumerable<BXParamValue> possibleValues,
    ParamClientSideAction clientSideAction
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..String
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр
possibleValues
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BXParamValue >)>)>
Список предопределенных значений
clientSideAction
Type: ParamClientSideAction
Особое поведение параметра в редакторе на стороне клиента

Смотри также

Класс BXParamSingleSelection
Перегрузка BXParamSingleSelection
Пространство имен Bitrix.Components


Методы BXParamSingleSelection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXParamSingleSelection
Класс BXParamSingleSelection Смотри также Send Feedback

Тип BXParamSingleSelection предоставляет следующие возможности.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Смотри также

Класс BXParamSingleSelection
Пространство имен Bitrix.Components


Свойства BXParamSingleSelection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXParamSingleSelection
Класс BXParamSingleSelection Смотри также Send Feedback

Тип BXParamSingleSelection предоставляет следующие возможности.

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamSingleSelection
Пространство имен Bitrix.Components


Класс BXParamSingleSelectionWithText

Класс BXParamSingleSelectionWithText
Члены Пример Смотри также Send Feedback
Класс параметра компонента, представленного раскрывающимся списком с дополнительным текстовым полем.

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXParamSingleSelectionWithText : BXParam

Примеры

CopyC#
protected override void PreLoadComponentDefinition()
{

    ...

    ParamsDefinition.Add(
        "PropertyDescription",
        new BXParamSingleSelectionWithText(
            "Установить описание страницы из пользовательского свойства",
            "",
            BXCategory.AdditionalSettings
        )
    );

    ...
}

Иерархия наследования

System..::..Object
Bitrix.Components..::..BXParam
Bitrix.Components..::..BXParamSingleSelectionWithText

Смотри также

Члены BXParamSingleSelectionWithText
Пространство имен Bitrix.Components


Члены BXParamSingleSelectionWithText

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXParamSingleSelectionWithText
Класс BXParamSingleSelectionWithText Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXParamSingleSelectionWithText предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXParamSingleSelectionWithText | Перегруженный.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamSingleSelectionWithText
Пространство имен Bitrix.Components


Конструктор BXParamSingleSelectionWithText

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXParamSingleSelectionWithText
Класс BXParamSingleSelectionWithText Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXParamSingleSelectionWithText(String, String, BXCategory) | Создает экземпляр класса параметра
BXParamSingleSelectionWithText(String, String, BXCategory, IEnumerable<(Of <<'(BXParamValue>)>>)) | Создает экземпляр класса параметра

Смотри также

Класс BXParamSingleSelectionWithText
Члены BXParamSingleSelectionWithText
Пространство имен Bitrix.Components


Конструктор BXParamSingleSelectionWithText (String, String, )

Конструктор BXParamSingleSelectionWithText (String, String, )
Класс BXParamSingleSelectionWithText Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamSingleSelectionWithText(
    string title,
    string value,
    BXCategory category
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..String
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр

Смотри также

Класс BXParamSingleSelectionWithText
Перегрузка BXParamSingleSelectionWithText
Пространство имен Bitrix.Components


Конструктор BXParamSingleSelectionWithText (String, String, , IEnumerable(BXParamValue))

Конструктор BXParamSingleSelectionWithText (String, String, , IEnumerable<(Of <(<'BXParamValue>)>)>)
Класс BXParamSingleSelectionWithText Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamSingleSelectionWithText(
    string title,
    string value,
    BXCategory category,
    IEnumerable<BXParamValue> possibleValues
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..String
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр
possibleValues
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BXParamValue >)>)>
Список предопределенных значений

Смотри также

Класс BXParamSingleSelectionWithText
Перегрузка BXParamSingleSelectionWithText
Пространство имен Bitrix.Components


Методы BXParamSingleSelectionWithText

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXParamSingleSelectionWithText
Класс BXParamSingleSelectionWithText Смотри также Send Feedback

Тип BXParamSingleSelectionWithText предоставляет следующие возможности.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Смотри также

Класс BXParamSingleSelectionWithText
Пространство имен Bitrix.Components


Свойства BXParamSingleSelectionWithText

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXParamSingleSelectionWithText
Класс BXParamSingleSelectionWithText Смотри также Send Feedback

Тип BXParamSingleSelectionWithText предоставляет следующие возможности.

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamSingleSelectionWithText
Пространство имен Bitrix.Components


Класс BXParamSort

Класс BXParamSort
Члены Пример Смотри также Send Feedback
Класс параметра компонента задающего порядок сортировки

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXParamSort : BXParam

Примеры

CopyC#
protected override void PreLoadComponentDefinition()
{

    ...

    ParamsDefinition.Add(
        "SortBy",
        new BXParamSingleSelection(
            "Параметр сортировки",
            "Sort",
            BXCategory.DataSource
        )
    );

    ParamsDefinition.Add(
        "SortOrder",
        new BXParamSort(
            "Порядок сортировки",
            BXCategory.DataSource
        )
    );

    ...
}

Иерархия наследования

System..::..Object
Bitrix.Components..::..BXParam
Bitrix.Components..::..BXParamSort

Смотри также

Члены BXParamSort
Пространство имен Bitrix.Components


Члены BXParamSort

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXParamSort
Класс BXParamSort Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXParamSort предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXParamSort | Перегруженный.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamSort
Пространство имен Bitrix.Components


Конструктор BXParamSort

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXParamSort
Класс BXParamSort Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXParamSort(String, BXCategory) | Создает параметр сортировки с начальным значением по убыванию
BXParamSort(String, Boolean, BXCategory) | Создает параметр сортировки
BXParamSort(String, Boolean, BXCategory, ParamClientSideAction) | Создает параметр сортировки

Смотри также

Класс BXParamSort
Члены BXParamSort
Пространство имен Bitrix.Components


Конструктор BXParamSort (String, )

Конструктор BXParamSort (String, )
Класс BXParamSort Смотри также Send Feedback
Создает параметр сортировки с начальным значением по убыванию

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamSort(
    string title,
    BXCategory category
)

Параметры

title
Type: System..::..String
Название параметра
category
Type: BXCategory
Категория параметра

Смотри также

Класс BXParamSort
Перегрузка BXParamSort
Пространство имен Bitrix.Components


Конструктор BXParamSort (String, Boolean, )

Конструктор BXParamSort (String, Boolean, )
Класс BXParamSort Смотри также Send Feedback
Создает параметр сортировки

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamSort(
    string title,
    bool desc,
    BXCategory category
)

Параметры

title
Type: System..::..String
Название параметра
desc
Type: System..::..Boolean
Флаг направления сортировки по умолчанию. Если true - то по убыванию, иначе по возрастанию
category
Type: BXCategory
Категория параметра

Смотри также

Класс BXParamSort
Перегрузка BXParamSort
Пространство имен Bitrix.Components


Конструктор BXParamSort (String, Boolean, , )

Конструктор BXParamSort (String, Boolean, , )
Класс BXParamSort Смотри также Send Feedback
Создает параметр сортировки

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamSort(
    string title,
    bool desc,
    BXCategory category,
    ParamClientSideAction clientSideAction
)

Параметры

title
Type: System..::..String
Название параметра
desc
Type: System..::..Boolean
Флаг направления сортировки по умолчанию. Если true - то по убыванию, иначе по возрастанию
category
Type: BXCategory
Категория параметра
clientSideAction
Type: ParamClientSideAction
Особое поведение параметра в редакторе на стороне клиента

Смотри также

Класс BXParamSort
Перегрузка BXParamSort
Пространство имен Bitrix.Components


Методы BXParamSort

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXParamSort
Класс BXParamSort Смотри также Send Feedback

Тип BXParamSort предоставляет следующие возможности.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Смотри также

Класс BXParamSort
Пространство имен Bitrix.Components


Свойства BXParamSort

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXParamSort
Класс BXParamSort Смотри также Send Feedback

Тип BXParamSort предоставляет следующие возможности.

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamSort
Пространство имен Bitrix.Components


Класс BXParamText

Класс BXParamText
Члены Пример Смотри также Send Feedback
Класс параметра компонента, представленного обыкновенным текстовым полем

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXParamText : BXParam

Примеры

CopyC#
protected override void PreLoadComponentDefinition()
{

    ...

    ParamsDefinition.Add(
        "DetailUrl",
        new BXParamText(
            "Ссылка на элемент",
            "NewsDetail.aspx?id=#ELEMENT_ID#",
            BXCategory.Sef
        )
    );

    ...
}

Иерархия наследования

System..::..Object
Bitrix.Components..::..BXParam
Bitrix.Components..::..BXParamText

Смотри также

Члены BXParamText
Пространство имен Bitrix.Components


Члены BXParamText

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXParamText
Класс BXParamText Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXParamText предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXParamText | Перегруженный.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamText
Пространство имен Bitrix.Components


Конструктор BXParamText

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXParamText
Класс BXParamText Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXParamText(String, String, BXCategory) | Создает экземпляр класса параметра
BXParamText(String, String, BXCategory, ParamClientSideAction) | Создает экземпляр класса параметра

Смотри также

Класс BXParamText
Члены BXParamText
Пространство имен Bitrix.Components


Конструктор BXParamText (String, String, )

Конструктор BXParamText (String, String, )
Класс BXParamText Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamText(
    string title,
    string value,
    BXCategory category
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..String
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр

Смотри также

Класс BXParamText
Перегрузка BXParamText
Пространство имен Bitrix.Components


Конструктор BXParamText (String, String, , )

Конструктор BXParamText (String, String, , )
Класс BXParamText Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamText(
    string title,
    string value,
    BXCategory category,
    ParamClientSideAction clientSideAction
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..String
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр
clientSideAction
Type: ParamClientSideAction
Особое поведение параметра в редакторе на стороне клиента

Смотри также

Класс BXParamText
Перегрузка BXParamText
Пространство имен Bitrix.Components


Методы BXParamText

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXParamText
Класс BXParamText Смотри также Send Feedback

Тип BXParamText предоставляет следующие возможности.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Смотри также

Класс BXParamText
Пространство имен Bitrix.Components


Свойства BXParamText

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXParamText
Класс BXParamText Смотри также Send Feedback

Тип BXParamText предоставляет следующие возможности.

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamText
Пространство имен Bitrix.Components


Перечисление BXParamType

Перечисление BXParamType
Смотри также Send Feedback
Стандартные типы отображения параметров

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public enum BXParamType

Члены

Название члена | Описание
YesNo | Флажок
Text | Текстовое поле
SingleSelection | Раскрывающийся список
MultiSelection | Список с множественным выбором
MultiSelectionWithText | Список с множественным выбором и дополнительными текстовыми полями
SingleSelectionWithText | Раскрывающийся список с дополнительным текстовым полем
DoubleList | Сдвоенный список
MultilineText | Многострочный текст
CustomFieldFilter | Фильтр по пользовательским полям
GoogleMapsInitialState | Исходное состояние карты GoogleMaps (центр, точки, тип карты, масштаб)
YandexMapsInitialState | Исходное состояние карты YandexMaps (центр, точки, тип карты, масштаб)

Смотри также

Пространство имен Bitrix.Components


Класс BXParamValue

Класс BXParamValue
Члены Пример Смотри также Send Feedback
Класс, представляющий предопределенное значение для параметра компонента

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public sealed class BXParamValue

Примеры

CopyC#
protected override void LoadComponentDefinition()
{

    ...

    List<BXParamValue> iblocks = new List<BXParamValue>();
    BXIBlockCollection iblockCollection = BXIBlock.GetList(iblockFilter, new BXOrderBy(new BXOrderByPair(BXIBlock.Fields.Sort, BXOrderByDirection.Asc)));
    foreach (BXIBlock b in iblockCollection)
        iblocks.Add(new BXParamValue(b.Name, b.Id.ToString()));

    ParamsDefinition["IBlockId"].Values = iblocks;

    ...
}

Иерархия наследования

System..::..Object
Bitrix.Components..::..BXParamValue

Смотри также

Члены BXParamValue
Пространство имен Bitrix.Components


Члены BXParamValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXParamValue
Класс BXParamValue Конструкторы Свойства Смотри также Send Feedback

Тип BXParamValue предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXParamValue | Создает экземпляр класса для предопределенного значения параметра компонента

Свойства

Имя | Описание
Title | Возвращает или устанавливает заголовок для предопределенного значения
Value | Возвращает или устанавливает собственно значение параметра компонента

Смотри также

Класс BXParamValue
Пространство имен Bitrix.Components


Конструктор BXParamValue

Конструктор BXParamValue
Класс BXParamValue Смотри также Send Feedback
Создает экземпляр класса для предопределенного значения параметра компонента

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamValue(
    string title,
    string value
)

Параметры

title
Type: System..::..String
Заголовок для предопределенного значения
value
Type: System..::..String
Собственно значение параметра компонента

Смотри также

Класс BXParamValue
Пространство имен Bitrix.Components


Свойства BXParamValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXParamValue
Класс BXParamValue Смотри также Send Feedback

Тип BXParamValue предоставляет следующие возможности.

Свойства

Имя | Описание
Title | Возвращает или устанавливает заголовок для предопределенного значения
Value | Возвращает или устанавливает собственно значение параметра компонента

Смотри также

Класс BXParamValue
Пространство имен Bitrix.Components


Свойство Title

Свойство BXParamValue..::.Title
Класс BXParamValue Смотри также Send Feedback
Возвращает или устанавливает заголовок для предопределенного значения

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Title { get; set; }

Смотри также

Класс BXParamValue
Пространство имен Bitrix.Components


Свойство Value

Свойство BXParamValue..::.Value
Класс BXParamValue Смотри также Send Feedback
Возвращает или устанавливает собственно значение параметра компонента

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Value { get; set; }

Смотри также

Класс BXParamValue
Пространство имен Bitrix.Components


Класс BXParamYesNo

Класс BXParamYesNo
Члены Пример Смотри также Send Feedback
Класс параметра компонента, представляющего значение "да/нет"

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXParamYesNo : BXParam

Примеры

CopyC#
protected override void PreLoadComponentDefinition()
{

    ...

    ParamsDefinition.Add(
        "SetPageTitle",
        new BXParamYesNo(
            "Устанавливать заголовок страницы",
            true,
            BXCategory.AdditionalSettings
        )
    );

    ...
}

Иерархия наследования

System..::..Object
Bitrix.Components..::..BXParam
Bitrix.Components..::..BXParamYesNo

Смотри также

Члены BXParamYesNo
Пространство имен Bitrix.Components


Члены BXParamYesNo

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXParamYesNo
Класс BXParamYesNo Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXParamYesNo предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXParamYesNo | Перегруженный.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamYesNo
Пространство имен Bitrix.Components


Конструктор BXParamYesNo

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXParamYesNo
Класс BXParamYesNo Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXParamYesNo(String, Boolean, BXCategory) | Создает экземпляр класса параметра
BXParamYesNo(String, Boolean, BXCategory, ParamClientSideAction) | Создает экземпляр класса параметра

Смотри также

Класс BXParamYesNo
Члены BXParamYesNo
Пространство имен Bitrix.Components


Конструктор BXParamYesNo (String, Boolean, )

Конструктор BXParamYesNo (String, Boolean, )
Класс BXParamYesNo Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamYesNo(
    string title,
    bool value,
    BXCategory category
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..Boolean
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр

Смотри также

Класс BXParamYesNo
Перегрузка BXParamYesNo
Пространство имен Bitrix.Components


Конструктор BXParamYesNo (String, Boolean, , )

Конструктор BXParamYesNo (String, Boolean, , )
Класс BXParamYesNo Смотри также Send Feedback
Создает экземпляр класса параметра

Пространство имен: Bitrix.Components
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamYesNo(
    string title,
    bool value,
    BXCategory category,
    ParamClientSideAction clientSideAction
)

Параметры

title
Type: System..::..String
Заголовок параметра
value
Type: System..::..Boolean
Значение по умолчанию
category
Type: BXCategory
Категория, к которой принадлежит параметр
clientSideAction
Type: ParamClientSideAction
Особое поведение параметра в редакторе на стороне клиента

Смотри также

Класс BXParamYesNo
Перегрузка BXParamYesNo
Пространство имен Bitrix.Components


Методы BXParamYesNo

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXParamYesNo
Класс BXParamYesNo Смотри также Send Feedback

Тип BXParamYesNo предоставляет следующие возможности.

Методы

Имя | Описание
AdjustPresentation | Устаревший. Настраивает представление параметра в соответствии с его особым поведением (Унаследовано от BXParam)

Смотри также

Класс BXParamYesNo
Пространство имен Bitrix.Components


Свойства BXParamYesNo

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXParamYesNo
Класс BXParamYesNo Смотри также Send Feedback

Тип BXParamYesNo предоставляет следующие возможности.

Свойства

Имя | Описание
Category | Возвращает категорию к которой относится параметр. (Унаследовано от BXParam)
ClientSideAction | Возвращает или устанавливает особое поведение параметра в редакторе на стороне клиента. (Унаследовано от BXParam)
DefaultValue | Возвращает значение параметра по умолчанию (Унаследовано от BXParam)
IsDirty | Возвращает или устанавливает, изменялось ли значение параметра. (Унаследовано от BXParam)
RefreshOnDirty | Возвращает или устанавливает, обновлять ли настройки параметров компонента при изменении значения текущего параметра (Унаследовано от BXParam)
SelectedValue | Возвращает или устанавливает текущее значение параметра (Унаследовано от BXParam)
Title | Возвращает или устанавливает заголовок параметра. (Унаследовано от BXParam)
Type | Возвращает или устанавливает тип параметра. (Унаследовано от BXParam)
Values | Возвращает или устанавливает список предопределенных значений параметра (Унаследовано от BXParam)
Visible | Возвращает или устанавливает, отображается ли параметр в редакторе. (Унаследовано от BXParam)

Смотри также

Класс BXParamYesNo
Пространство имен Bitrix.Components


Пространство имен Bitrix.DataLayer

Пространство имен Bitrix.DataLayer
Send Feedback
Содержит классы обеспечивающие доступ к данным.

Классы

Класс | Описание
BXEntity | Абстрактный класс сущности системы.
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> | BXEntity - базовый класс любой сущности системы.
BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> | BXEntityCollection - базовый класс коллекции сущностей системы.
BXFilter | Определяет условия выборки списка сущностей. Содержит элементы вида "Поле схемы - Оператор - Значение".
BXFilterBase | Базовый класс фильтра
BXFilterItem | Элемент фильтра. Определяет одно из его условий вида {имя поля таблицы}={значение}.
BXOrderBy | Служит для формирования "ORDER BY" строки sql запроса
BXOrderByPair | Класс - хранилище. Содержит информации о поле и направлении сортировки
BXPagingOptions |
BXQueryParams | Параметры запроса. Определяет количество записей для выборки и индекс ( номер ) первого элемента в выборке
BXSelect | Выборка
BXSelectAdd | BXSelect в режиме Add()()()()

Перечисления

Перечисление | Описание
BXOrderByDirection | Направление сортировки


Класс BXEntity

Класс BXEntity
Члены Смотри также Send Feedback
Абстрактный класс сущности системы.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
[SerializableAttribute]
public abstract class BXEntity

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXEntity
Bitrix.DataLayer..::..BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>

Смотри также

Члены BXEntity
Пространство имен Bitrix.DataLayer


Члены BXEntity

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXEntity
Класс BXEntity Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXEntity предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXEntity |

Методы

Имя | Описание
Create | Перегруженный.
Delete | Перегруженный.
GetFields | Получить схему
GetValues |
Save | Перегруженный.
TrySetFields | Установить схему
TrySetValues |
Update | Перегруженный.

Свойства

Имя | Описание
CustomFields | Возвращает список набираемых свойств сущности.
CustomFieldsKey |
CustomPublicValues | Модификатор значений набираемых свойств
CustomValues | Набираемые свойства
EntityOriginContext |
JoinedEntityMap | Набор отражений для связанных сущностей
TextEncoder |
ValueMap | Набор отражений для значений

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Конструктор BXEntity

Конструктор BXEntity
Класс BXEntity Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXEntity()

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Методы BXEntity

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXEntity
Класс BXEntity Смотри также Send Feedback

Тип BXEntity предоставляет следующие возможности.

Методы

Имя | Описание
Create | Перегруженный.
Delete | Перегруженный.
GetFields | Получить схему
GetValues |
Save | Перегруженный.
TrySetFields | Установить схему
TrySetValues |
Update | Перегруженный.

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Метод Create

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity..::.Create
Класс BXEntity Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Create()()()() | Добавляет новую сущность в базу данных в новой транзакции.
Create(BXSqlConnection, BXSqlTransaction) | Добавляет новую сущность в базу данных, используя указанное соединение.

Смотри также

Класс BXEntity
Члены BXEntity
Пространство имен Bitrix.DataLayer


Метод Create

Метод BXEntity..::.Create
Класс BXEntity Смотри также Send Feedback
Добавляет новую сущность в базу данных в новой транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract void Create()

Смотри также

Класс BXEntity
Перегрузка Create
Пространство имен Bitrix.DataLayer


Метод Create (, )

Метод BXEntity..::.Create (, )
Класс BXEntity Смотри также Send Feedback
Добавляет новую сущность в базу данных, используя указанное соединение.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract void Create(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Смотри также

Класс BXEntity
Перегрузка Create
Пространство имен Bitrix.DataLayer


Метод Delete

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity..::.Delete
Класс BXEntity Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Delete()()()() | Удаляет текущую сущность из базы данных в новой транзакции.
Delete(BXSqlConnection, BXSqlTransaction) | Удаляет текущую сущность из базы данных, используя указанное соединение.

Смотри также

Класс BXEntity
Члены BXEntity
Пространство имен Bitrix.DataLayer


Метод Delete

Метод BXEntity..::.Delete
Класс BXEntity Смотри также Send Feedback
Удаляет текущую сущность из базы данных в новой транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract void Delete()

Смотри также

Класс BXEntity
Перегрузка Delete
Пространство имен Bitrix.DataLayer


Метод Delete (, )

Метод BXEntity..::.Delete (, )
Класс BXEntity Смотри также Send Feedback
Удаляет текущую сущность из базы данных, используя указанное соединение.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract void Delete(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Смотри также

Класс BXEntity
Перегрузка Delete
Пространство имен Bitrix.DataLayer


Метод GetFields

Метод BXEntity..::.GetFields
Класс BXEntity Смотри также Send Feedback
Получить схему

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual BXSchemeBase GetFields()

Возвращаемое значение

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Метод GetValues

Метод BXEntity..::.GetValues
Класс BXEntity Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract IDictionary<string, Object> GetValues()

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity..::.Save
Класс BXEntity Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет сущность в базе данных в новой транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет.
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет сущность в базе данных в указанной транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет.

Смотри также

Класс BXEntity
Члены BXEntity
Пространство имен Bitrix.DataLayer


Метод Save

Метод BXEntity..::.Save
Класс BXEntity Смотри также Send Feedback
Сохраняет сущность в базе данных в новой транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract void Save()

Смотри также

Класс BXEntity
Перегрузка Save
Пространство имен Bitrix.DataLayer


Метод Save (, )

Метод BXEntity..::.Save (, )
Класс BXEntity Смотри также Send Feedback
Сохраняет сущность в базе данных в указанной транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract void Save(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Смотри также

Класс BXEntity
Перегрузка Save
Пространство имен Bitrix.DataLayer


Метод TrySetFields

Метод BXEntity..::.TrySetFields
Класс BXEntity Смотри также Send Feedback
Установить схему

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual bool TrySetFields(
    BXSchemeBase scheme
)

Параметры

scheme
Type: BXSchemeBase

Возвращаемое значение

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Метод TrySetValues

Метод BXEntity..::.TrySetValues
Класс BXEntity Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract bool TrySetValues(
    BXEntity sourceEntity,
    string sourceKeyPrefix
)

Параметры

sourceEntity
Type: Bitrix.DataLayer..::..BXEntity
sourceKeyPrefix
Type: System..::..String

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Метод Update

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity..::.Update
Класс BXEntity Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Update()()()() | Изменяет существующую сущность в базе данных в новой транзакции.
Update(BXSqlConnection, BXSqlTransaction) | Изменяет существующую сущность в базе данных в указанной транзакции.

Смотри также

Класс BXEntity
Члены BXEntity
Пространство имен Bitrix.DataLayer


Метод Update

Метод BXEntity..::.Update
Класс BXEntity Смотри также Send Feedback
Изменяет существующую сущность в базе данных в новой транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract void Update()

Смотри также

Класс BXEntity
Перегрузка Update
Пространство имен Bitrix.DataLayer


Метод Update (, )

Метод BXEntity..::.Update (, )
Класс BXEntity Смотри также Send Feedback
Изменяет существующую сущность в базе данных в указанной транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract void Update(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Смотри также

Класс BXEntity
Перегрузка Update
Пространство имен Bitrix.DataLayer


Свойства BXEntity

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXEntity
Класс BXEntity Смотри также Send Feedback

Тип BXEntity предоставляет следующие возможности.

Свойства

Имя | Описание
CustomFields | Возвращает список набираемых свойств сущности.
CustomFieldsKey |
CustomPublicValues | Модификатор значений набираемых свойств
CustomValues | Набираемые свойства
EntityOriginContext |
JoinedEntityMap | Набор отражений для связанных сущностей
TextEncoder |
ValueMap | Набор отражений для значений

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Свойство CustomFields

Свойство BXEntity..::.CustomFields
Класс BXEntity Смотри также Send Feedback
Возвращает список набираемых свойств сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual BXCustomFieldCollection CustomFields { get; }

Заметки

Для работы с набираемыми свойствами у конкретной сущности должно быть переопределено свойство [!:Bitrix.DataLayer.BXEntity<EntityType, EntityCollectionType, EntryScheme>.CustomFieldsKey]. Это свойство должно вернуть ключ для набираемых свойств конкретной сущности.

Список набираемых свойств выбирается один раз при первом обращении к свойству CustomFields.

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Свойство CustomFieldsKey

Свойство BXEntity..::.CustomFieldsKey
Класс BXEntity Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual string CustomFieldsKey { get; }

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Свойство CustomPublicValues

Свойство BXEntity..::.CustomPublicValues
Класс BXEntity Смотри также Send Feedback
Модификатор значений набираемых свойств

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual BXCustomPropertyValueModificator CustomPublicValues { get; }

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Свойство CustomValues

Свойство BXEntity..::.CustomValues
Класс BXEntity Смотри также Send Feedback
Набираемые свойства

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual BXCustomPropertyCollection CustomValues { get; }

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Свойство EntityOriginContext

Свойство BXEntity..::.EntityOriginContext
Класс BXEntity Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXEntityOriginContext EntityOriginContext { get; set; }

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Свойство JoinedEntityMap

Свойство BXEntity..::.JoinedEntityMap
Класс BXEntity Смотри также Send Feedback
Набор отражений для связанных сущностей

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected internal abstract IBXJoinedEntityMap JoinedEntityMap { get; set; }

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Свойство TextEncoder

Свойство BXEntity..::.TextEncoder
Класс BXEntity Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract IBXTextEncoder TextEncoder { get; protected internal set; }

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Свойство ValueMap

Свойство BXEntity..::.ValueMap
Класс BXEntity Смотри также Send Feedback
Набор отражений для значений

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected internal abstract IBXEntityValueMap ValueMap { get; set; }

Смотри также

Класс BXEntity
Пространство имен Bitrix.DataLayer


Класс BXEntity(EntityType, EntityCollectionType, EntryScheme)

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены Пример Смотри также Send Feedback
BXEntity - базовый класс любой сущности системы.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
[SerializableAttribute]
public abstract class BXEntity<EntityType, EntityCollectionType, EntryScheme> : BXEntity
where EntityType : new(), BXEntity<EntityType, EntityCollectionType, EntryScheme>
where EntityCollectionType : new(), BXEntityCollection<EntityType, EntityCollectionType, EntryScheme>
where EntryScheme : new(), BXScheme<EntryScheme>

Параметры типа

EntityType
Класс сущности
EntityCollectionType
Класс коллекции сущностей
EntryScheme
Класс схемы сущности

Заметки

Базовый класс сущности поддерживает следующие типы выборок:

  • выборка типа GetList - выборка коллекции сущностей по фильтру,

  • выборка типа GetById - выборка сущности по первичному ключу,

  • выборка типа Count - выборка количества сущностей, удовлетворяющих фильтру.

Примеры

Сущность информационного блока:

CopyC#
public class BXIBlock
    : BXEntity<BXIBlock, BXIBlockCollection, BXIBlock.Scheme>
{
}

где:

  • BXIBlock - сущность информационного блок,

  • BXIBlockCollection - коллекция сущностей информационных блоков,

  • BXIBlock.Scheme - схема сущности информационного блока.

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXEntity
Bitrix.DataLayer..::..BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Bitrix.IBlock..::..BXIBlock
Bitrix.IBlock..::..BXIBlockElement
Bitrix.IBlock..::..BXIBlockSection
Bitrix.IBlock..::..BXIBlockType
Bitrix.IO..::..BXFile
Bitrix.Services..::..BXSchedulerAgent

Смотри также

Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Члены BXEntity(EntityType, EntityCollectionType, EntryScheme)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Конструкторы Методы Поля Свойства Смотри также Send Feedback

Тип BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> | Перегруженный.

Методы

Имя | Описание
Count | Статический метод выборки типа Count. Вычисляет количество сущностей в базе данных, удовлетворяющих указанному фильтру.
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count.
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции.
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции.
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции.
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции.
DeleteCustomProperties |
DeleteEntityLinks | Удаление сущностей-связок
DeleteInternal | Перегруженный.
DoCreate |
DoDelete |
DoUpdate |
ExecuteSql | Перегруженный.
ExecuteSqlNonQuery | Перегруженный.
ExecuteSqlScalar | Выполняет запрос выборки типа Count. Возвращает число записей.
GetById | Перегруженный.
GetByIdInternal | Перегруженный.
GetCustomFieldsKey | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства.
GetDateTime |
GetFields | (Переопределяет BXEntity..::..GetFields()()()())
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue | Перегруженный.
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) |
GetList | Перегруженный.
GetListInternal | Перегруженный.
GetValue | Перегруженный.
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком.
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком.
GetValues | (Переопределяет BXEntity..::..GetValues()()()())
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader.
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess'
OnInit | Вызывается после инициализации полей сущности значениями из БД
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки.
PrepareParametersForGetList | Подготавливает список параметров для выборки.
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности.
Save | Перегруженный.
SaveCustomProperties |
SaveEntityLinks | Сохранение сущностей-связок
SendOnActionCommand | Отправляет команду On перед изменением сущности.
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности.
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности.
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным.
SetValue | Перегруженный.
SetXmlValue |
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь
TrySetFields | (Переопределяет BXEntity..::..TrySetFields(BXSchemeBase))
TrySetValues | (Переопределяет BXEntity..::..TrySetValues(BXEntity, String))
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции.
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции.
VerifyEntry | Проверяет корректность сущности перед сохранением.

Поля

Имя | Описание
_isDirty |
_map | Список отражений для связанных сущностей
_valueMap |
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false.
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком.

Свойства

Имя | Описание
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Унаследовано от BXEntity)
CustomPublicValues | (Переопределяет BXEntity..::..CustomPublicValues)
CustomValues | Возвращает список значений набираемых свойств сущности. (Переопределяет BXEntity..::..CustomValues)
EntityId | Возвращает код сущности. Должен быть переопределен в конкретной сущности.
EntityKey | Возвращает значение первичного ключа сущности.
EntityOriginContext | (Унаследовано от BXEntity)
EntitySingleton | Возвращает статический экземпляр новой сущности.
Fields | Возвращает схему сущности.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false.
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false.
IsReadOnly |
JoinedEntityMap | Набор отражений для связанных сущностей (Переопределяет BXEntity..::..JoinedEntityMap)
ModuleId | Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Переопределяет BXEntity..::..TextEncoder)
ValueMap | Набор отражений для полей (Переопределяет BXEntity..::..ValueMap)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Конструктор BXEntity(EntityType, EntityCollectionType, EntryScheme)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>()()()() | Инициализирует новый экземпляр сущности.
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>(IBXTextEncoder) | Инициализирует новый экземпляр сущности с указанным кодировщиком.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Конструктор BXEntity(EntityType, EntityCollectionType, EntryScheme)

Конструктор BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Инициализирует новый экземпляр сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXEntity()

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Конструктор BXEntity(EntityType, EntityCollectionType, EntryScheme) ()

Конструктор BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> ()
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Инициализирует новый экземпляр сущности с указанным кодировщиком.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXEntity(
    IBXTextEncoder textEncoder
)

Параметры

textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей сущности

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Поля BXEntity(EntityType, EntityCollectionType, EntryScheme)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Тип BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> предоставляет следующие возможности.

Поля

Имя | Описание
_isDirty |
_map | Список отражений для связанных сущностей
_valueMap |
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false.
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Поле _isDirty

Поле BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::._isDirty
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected bool _isDirty

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Поле _map

Поле BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::._map
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Список отражений для связанных сущностей

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected IBXJoinedEntityMap _map

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Поле _valueMap

Поле BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::._valueMap
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected IBXEntityValueMap _valueMap

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Поле isNew

Поле BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.isNew
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected bool isNew

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Поле values

Поле BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.values
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected Dictionary<string, Object> values

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Методы BXEntity(EntityType, EntityCollectionType, EntryScheme)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Тип BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> предоставляет следующие возможности.

Методы

Имя | Описание
Count | Статический метод выборки типа Count. Вычисляет количество сущностей в базе данных, удовлетворяющих указанному фильтру.
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count.
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции.
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции.
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции.
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции.
DeleteCustomProperties |
DeleteEntityLinks | Удаление сущностей-связок
DeleteInternal | Перегруженный.
DoCreate |
DoDelete |
DoUpdate |
ExecuteSql | Перегруженный.
ExecuteSqlNonQuery | Перегруженный.
ExecuteSqlScalar | Выполняет запрос выборки типа Count. Возвращает число записей.
GetById | Перегруженный.
GetByIdInternal | Перегруженный.
GetCustomFieldsKey | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства.
GetDateTime |
GetFields | (Переопределяет BXEntity..::..GetFields()()()())
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue | Перегруженный.
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) |
GetList | Перегруженный.
GetListInternal | Перегруженный.
GetValue | Перегруженный.
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком.
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком.
GetValues | (Переопределяет BXEntity..::..GetValues()()()())
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader.
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess'
OnInit | Вызывается после инициализации полей сущности значениями из БД
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки.
PrepareParametersForGetList | Подготавливает список параметров для выборки.
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности.
Save | Перегруженный.
SaveCustomProperties |
SaveEntityLinks | Сохранение сущностей-связок
SendOnActionCommand | Отправляет команду On перед изменением сущности.
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности.
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности.
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным.
SetValue | Перегруженный.
SetXmlValue |
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь
TrySetFields | (Переопределяет BXEntity..::..TrySetFields(BXSchemeBase))
TrySetValues | (Переопределяет BXEntity..::..TrySetValues(BXEntity, String))
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции.
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции.
VerifyEntry | Проверяет корректность сущности перед сохранением.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод Count

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Count
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Статический метод выборки типа Count. Вычисляет количество сущностей в базе данных, удовлетворяющих указанному фильтру.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static int Count(
    BXFilter filter
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
Объект типа BXFilter, содержащий фильтр, накладываемый на сущность. Может быть равен null.

Возвращаемое значение

Число записей, удовлетворяющих условию.

Примеры

CopyC#
int cnt = BXIBlockElement.Count(
    new BXFilter(
        new BXFilterItem(BXIBlockElement.Fields.Active, BXSqlFilterOperators.Equal, "Y"),
        new BXFilterItem(BXIBlockElement.Fields.IBlock.Sites.SiteId, BXSqlFilterOperators.Equal, "ru")
    )
);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод CountInternal

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.CountInternal
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual int CountInternal(
    BXFilter filter
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
Объект типа BXFilter, содержащий фильтр, накладываемый на сущность. Может быть равен null.

Возвращаемое значение

Число записей, удовлетворяющих условию.

Заметки

Все статические методы типа Count (вычисляющие количество сущностей в базе данных, удовлетворяющих указанному фильтру), обращаются к методу CountInternal. Этот метод является виртуальным и может быть переопределен в классе конкретной сущности для реализации нестандартной выборки.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод Create

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Create
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Create()()()() | Добавляет новую сущность в базу данных в новой транзакции. (Переопределяет BXEntity..::..Create()()()())
Create(BXSqlConnection, BXSqlTransaction) | Добавляет новую сущность в базу данных, используя указанное соединение. (Переопределяет BXEntity..::..Create(BXSqlConnection, BXSqlTransaction))

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод Create

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Create
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Добавляет новую сущность в базу данных в новой транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override void Create()

Заметки

Подробное описание метода можно посмотреть на странице Create(BXSqlConnection, BXSqlTransaction)

Примеры

CopyC#
BXSite site = new BXSite("company");
site.Name = "Моя компания";
site.Active = true;
site.Sort = 150;
site.Create();

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка Create
Пространство имен Bitrix.DataLayer
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..Create(BXSqlConnection, BXSqlTransaction)


Метод Create (, )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Create (, )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Добавляет новую сущность в базу данных, используя указанное соединение.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override void Create(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Заметки

Метод сохранения новой сущности является виртуальным и может быть переопределен в конкретной реализации сущности. Таким образом сохранение конкретной сущности может осуществляться не стандартным образом.

Стандартное сохранение новой сущности происходит следующим образом:

  1. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnBeforeCreate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Cancel, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для того, чтобы была возможность корректно отменить сохранение сущности. Обработчики этой команды не должны модифицировать данные, так как нет гарантий, что один из обработчиков не отменит сохранение.

  2. Вызывается виртуальный метод VerifyEntry()()()(), который проверяет соответствие параметров сущности и ее схемы. Производятся следующие проверки полей сущности:

    • если поле является первичным ключем и у него установлен флаг Identity, то в параметрах сущности не должно быть заданого значения для этого поля,

    • если поле является первичным ключем и у него не установлен флаг Identity, то в параметрах сущности должно быть задано значение для этого поля,

    • если поле является обязательным и у него не задано значение по умолчанию, то в параметрах сущности должно быть задано значение для этого поля,

    • если поле является строковым, у него задано ограничение по длине и задано значение этого поля, то значение не должно быть длинее указанного ограничения.

    Если метод VerifyEntry()()()() вернул отличный от BXModifyStatusResult.Success статус, то сохранение преравается и выбрасывается исключение типа BXEventException.

  3. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnCreate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций перед сохранением новой сущности.

  4. Производится сохранение сущности и ее связок.

  5. Выполняется виртуальный метод CreateAdditionalEntities(BXSqlConnection, BXSqlTransaction), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется в рамках транзакции сохранения сущности.

  6. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnAfterCreate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций после сохранения новой сущности.

  7. Выполняется виртуальный метод CreateAfterSuccess()()()(), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется после закрытия соединения, в котором сохранялась сущность.

Примеры

CopyC#
BXSite site = new BXSite("company");
site.Name = "Моя компания";
site.Active = true;
site.Sort = 150;
site.Create();

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка Create
Пространство имен Bitrix.DataLayer
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..Create()()()()


Метод CreateAdditionalEntities

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.CreateAdditionalEntities
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void CreateAdditionalEntities(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Заметки

Этот метод ничего не делает в базовой реализации сущности, но может быть переопределен в конкретной сущности.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод CreateAfterSuccess

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.CreateAfterSuccess
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void CreateAfterSuccess()

Заметки

Этот метод ничего не делает в базовой реализации сущности, но может быть переопределен в конкретной сущности.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод Delete

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Delete
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Delete()()()() | Удаляет текущую сущность из базы данных в новой транзакции. (Переопределяет BXEntity..::..Delete()()()())
Delete(Object) | Статический метод удаляет сущности из базы данных по первичному ключу id.
Delete(BXFilter) | Статический метод удаляет сущности из базы данных по фильтру. При этом в реализации по умолчанию не удаляются никакие связанные данные и не отправляются никакие команды.
Delete(BXSqlConnection, BXSqlTransaction) | Удаляет текущую сущность из базы данных, используя указанное соединение. (Переопределяет BXEntity..::..Delete(BXSqlConnection, BXSqlTransaction))
Delete(BXFilter, BXSqlConnection, BXSqlTransaction) |

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод Delete

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Delete
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Удаляет текущую сущность из базы данных в новой транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override void Delete()

Заметки

Подробное описание метода можно посмотреть на странице Delete(BXSqlConnection, BXSqlTransaction)

Примеры

CopyC#
BXSite site = BXSite.GetById("company");
site.Delete();

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка Delete
Пространство имен Bitrix.DataLayer
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..Delete(BXSqlConnection, BXSqlTransaction)


Метод Delete (Object)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Delete (Object)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Статический метод удаляет сущности из базы данных по первичному ключу id.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void Delete(
    Object id
)

Параметры

id
Type: System..::..Object
Первичный ключ удаляемой сущности.

Заметки

Статический метод удаления сущности из базы данных по первичному ключу сводится к виртуальному методу DeleteInternal(BXFilter). Поэтому он может быть переопределен в конкретной реализации сущности. Таким образом удаление конкретной сущности может осуществляться не стандартным образом.

Алгоритм работы статического метода удаления сущности совпадает с алгоритмом работы динамического метода Delete(BXSqlConnection, BXSqlTransaction).

Примеры

CopyC#
site.Delete("company");

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка Delete
Пространство имен Bitrix.DataLayer


Метод Delete (BXFilter)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Delete (BXFilter)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Статический метод удаляет сущности из базы данных по фильтру. При этом в реализации по умолчанию не удаляются никакие связанные данные и не отправляются никакие команды.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void Delete(
    BXFilter filter
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
Объект типа BXFilter, содержащий фильтр, накладываемый на удаляемые сущности.

Заметки

Статический метод удаления сущности из базы данных по фильтру сводится к виртуальному методу DeleteInternal(BXFilter). Поэтому он может быть переопределен в конкретной реализации сущности. Таким образом удаление конкретной сущности может осуществляться не стандартным образом.

Примеры

CopyC#
BXSite.Delete(
    new BXFilter(
        new BXFilterItem(BXSite.Fields.Active, BXSqlFilterOperators.Equal, false)
    )
);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка Delete
Пространство имен Bitrix.DataLayer


Метод Delete (, )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Delete (, )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Удаляет текущую сущность из базы данных, используя указанное соединение.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override void Delete(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Заметки

Метод удаления существующей сущности является виртуальным и может быть переопределен в конкретной реализации сущности. Таким образом удаление конкретной сущности может осуществляться не стандартным образом.

Стандартное удаление существующей сущности происходит следующим образом:

  1. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnBeforeDelete, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Cancel, то удаление сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для того, чтобы была возможность корректно отменить удаление сущности. Обработчики этой команды не должны модифицировать данные, так как нет гарантий, что один из обработчиков не отменит удаление.

  2. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnDelete, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то удаление сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций перед удалением существующей сущности.

  3. Выполняется виртуальный метод DeleteAdditionalEntities(BXSqlConnection, BXSqlTransaction), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется в рамках транзакции удаления сущности.

  4. Производится удаление сущности и ее связок.

  5. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnAfterDelete, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций после удаления существующей сущности.

  6. Выполняется виртуальный метод DeleteAfterSuccess()()()(), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется после закрытия соединения, в котором удалялась сущность.

Примеры

CopyC#
BXSite site = BXSite.GetById("company");
site.Delete();

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка Delete
Пространство имен Bitrix.DataLayer
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..Delete()()()()


Метод Delete (BXFilter, , )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Delete (BXFilter, , )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void Delete(
    BXFilter filter,
    BXSqlConnection con,
    BXSqlTransaction tran
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
con
Type: BXSqlConnection
tran
Type: BXSqlTransaction

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка Delete
Пространство имен Bitrix.DataLayer


Метод DeleteAdditionalEntities

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.DeleteAdditionalEntities
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void DeleteAdditionalEntities(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Заметки

Этот метод ничего не делает в базовой реализации сущности, но может быть переопределен в конкретной сущности.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод DeleteAfterSuccess

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.DeleteAfterSuccess
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void DeleteAfterSuccess()

Заметки

Этот метод ничего не делает в базовой реализации сущности, но может быть переопределен в конкретной сущности.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод DeleteCustomProperties

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.DeleteCustomProperties
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void DeleteCustomProperties(
    BXSqlConnection con,
    BXSqlTransaction tran
)

Параметры

con
Type: BXSqlConnection
tran
Type: BXSqlTransaction

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод DeleteEntityLinks

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.DeleteEntityLinks
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Удаление сущностей-связок

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void DeleteEntityLinks(
    BXSqlConnection con,
    BXSqlTransaction tran
)

Параметры

con
Type: BXSqlConnection
tran
Type: BXSqlTransaction

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод DeleteInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.DeleteInternal
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
DeleteInternal(Object) | Внутренний метод удаления сущностей по первичному ключу id, который вызывается статическим методом Delete(Object).
DeleteInternal(BXFilter) | Внутренний метод удаления сущностей по фильтру, который вызывается статическим методом Delete(BXFilter). При удалении не отправляются никакие комманды и не удаляются дополнительные данные.
DeleteInternal(BXFilter, BXSqlConnection, BXSqlTransaction) |

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод DeleteInternal (Object)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.DeleteInternal (Object)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Внутренний метод удаления сущностей по первичному ключу id, который вызывается статическим методом Delete(Object).

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void DeleteInternal(
    Object id
)

Параметры

id
Type: System..::..Object
Первичный ключ удаляемой сущности.

Заметки

Все статические методы удаления сущностей по первичному ключу, обращаются к методу DeleteInternal. Этот метод является виртуальным и может быть переопределен в классе конкретной сущности для реализации нестандартного удаления.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка DeleteInternal
Пространство имен Bitrix.DataLayer


Метод DeleteInternal (BXFilter)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.DeleteInternal (BXFilter)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Внутренний метод удаления сущностей по фильтру, который вызывается статическим методом Delete(BXFilter). При удалении не отправляются никакие комманды и не удаляются дополнительные данные.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void DeleteInternal(
    BXFilter filter
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
Объект типа BXFilter, содержащий фильтр, накладываемый на сущность. Может быть равен null.

Заметки

Все статические методы удаления сущностей по фильтру, обращаются к методу DeleteInternal. Этот метод является виртуальным и может быть переопределен в классе конкретной сущности для реализации нестандартного удаления.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка DeleteInternal
Пространство имен Bitrix.DataLayer


Метод DeleteInternal (BXFilter, , )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.DeleteInternal (BXFilter, , )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void DeleteInternal(
    BXFilter filter,
    BXSqlConnection con,
    BXSqlTransaction tran
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
con
Type: BXSqlConnection
tran
Type: BXSqlTransaction

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка DeleteInternal
Пространство имен Bitrix.DataLayer


Метод DoCreate

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.DoCreate
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void DoCreate(
    BXSqlTransactionHelper sql
)

Параметры

sql
Type: BXSqlTransactionHelper

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод DoDelete

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.DoDelete
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void DoDelete(
    BXSqlTransactionHelper sql
)

Параметры

sql
Type: BXSqlTransactionHelper

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод DoUpdate

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.DoUpdate
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void DoUpdate(
    BXSqlTransactionHelper sql
)

Параметры

sql
Type: BXSqlTransactionHelper

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод ExecuteSql

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.ExecuteSql
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ExecuteSql(String, array<SqlParameter>[]()[][], BXQueryParams, IBXTextEncoder) | Статический метод выполняет запрос выборки типа GetList и GetById. Возвращает коллекцию сущностей.
ExecuteSql(String, array<SqlParameter>[]()[][], BXQueryParams, IBXTextEncoder, BXSchemeBase, IBXEntityValueMap) | Статический метод выполняет запрос выборки типа GetList и GetById. Возвращает коллекцию сущностей.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод ExecuteSql (String, SqlParameter[], BXQueryParams, )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.ExecuteSql (String, array<SqlParameter>[]()[][], BXQueryParams, )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Статический метод выполняет запрос выборки типа GetList и GetById. Возвращает коллекцию сущностей.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected static EntityCollectionType ExecuteSql(
    string commandText,
    SqlParameter[] parameters,
    BXQueryParams queryParams,
    IBXTextEncoder textEncoder
)

Параметры

commandText
Type: System..::..String
Текст sql команды.
parameters
Type: array< System.Data.SqlClient..::..SqlParameter >[]()[][]
Параметры sql команды.
queryParams
Type: Bitrix.DataLayer..::..BXQueryParams
Параметры запроса.
textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей сущности.

Возвращаемое значение

Возвращает коллекцию сущностей.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка ExecuteSql
Пространство имен Bitrix.DataLayer


Метод ExecuteSql (String, SqlParameter[], BXQueryParams, , , )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.ExecuteSql (String, array<SqlParameter>[]()[][], BXQueryParams, , , )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Статический метод выполняет запрос выборки типа GetList и GetById. Возвращает коллекцию сущностей.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected static EntityCollectionType ExecuteSql(
    string commandText,
    SqlParameter[] parameters,
    BXQueryParams queryParams,
    IBXTextEncoder textEncoder,
    BXSchemeBase scheme,
    IBXEntityValueMap valueMap
)

Параметры

commandText
Type: System..::..String
Текст sql команды.
parameters
Type: array< System.Data.SqlClient..::..SqlParameter >[]()[][]
Параметры sql команды.
queryParams
Type: Bitrix.DataLayer..::..BXQueryParams
Параметры запроса.
textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей сущности.
scheme
Type: BXSchemeBase
Схема сущности
valueMap
Type: IBXEntityValueMap
Отражения значений

Возвращаемое значение

Возвращает коллекцию сущностей.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка ExecuteSql
Пространство имен Bitrix.DataLayer


Метод ExecuteSqlNonQuery

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.ExecuteSqlNonQuery
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ExecuteSqlNonQuery(String, array<SqlParameter>[]()[][]) | Выполняет запрос, который не возвращает значений.
ExecuteSqlNonQuery(String, array<SqlParameter>[]()[][], BXSqlTransaction) | Выполняет запрос, который не возвращает значений.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод ExecuteSqlNonQuery (String, SqlParameter[])

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.ExecuteSqlNonQuery (String, array<SqlParameter>[]()[][])
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Выполняет запрос, который не возвращает значений.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected static void ExecuteSqlNonQuery(
    string commandText,
    SqlParameter[] parameters
)

Параметры

commandText
Type: System..::..String
Текст sql команды.
parameters
Type: array< System.Data.SqlClient..::..SqlParameter >[]()[][]
Параметры sql команды.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка ExecuteSqlNonQuery
Пространство имен Bitrix.DataLayer


Метод ExecuteSqlNonQuery (String, SqlParameter[], )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.ExecuteSqlNonQuery (String, array<SqlParameter>[]()[][], )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Выполняет запрос, который не возвращает значений.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected static void ExecuteSqlNonQuery(
    string commandText,
    SqlParameter[] parameters,
    BXSqlTransaction tran
)

Параметры

commandText
Type: System..::..String
Текст sql команды.
parameters
Type: array< System.Data.SqlClient..::..SqlParameter >[]()[][]
Параметры sql команды.
tran
Type: BXSqlTransaction
Транзакция.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка ExecuteSqlNonQuery
Пространство имен Bitrix.DataLayer


Метод ExecuteSqlScalar

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.ExecuteSqlScalar
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Выполняет запрос выборки типа Count. Возвращает число записей.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected static int ExecuteSqlScalar(
    string commandText,
    SqlParameter[] parameters
)

Параметры

commandText
Type: System..::..String
Текст sql команды.
parameters
Type: array< System.Data.SqlClient..::..SqlParameter >[]()[][]
Параметры sql команды.

Возвращаемое значение

Возвращает целое число.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetById

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetById
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetById(Object) | Выбирает сущность по ее коду id. Используется кодировщик по умолчанию для текстовых полей сущности.
GetById(Object, IBXTextEncoder) | Выбирает сущность по ее коду id. В textEncoder передается кодировщик текстовых полей сущности.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetById (Object)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetById (Object)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Выбирает сущность по ее коду id. Используется кодировщик по умолчанию для текстовых полей сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static EntityType GetById(
    Object id
)

Параметры

id
Type: System..::..Object
Код выбираемой сущности.

Возвращаемое значение

Сущность с указанным в параметрах кодом. Если сущность с таким кодом не найдена, то возвращается значение null.

Заметки

Метод сводится к вызову виртуального метода GetByIdInternal(Object, IBXTextEncoder), поэтому в конкретной реализации сущности алгоритм его работы может быть изменен.

Примеры

CopyC#
BXIBlockElement el = BXIBlockElement.GetById(128);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetById
Пространство имен Bitrix.DataLayer
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetById(Object, IBXTextEncoder)
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetByIdInternal(Object, IBXTextEncoder)


Метод GetById (Object, )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetById (Object, )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Выбирает сущность по ее коду id. В textEncoder передается кодировщик текстовых полей сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static EntityType GetById(
    Object id,
    IBXTextEncoder textEncoder
)

Параметры

id
Type: System..::..Object
Код выбираемой сущности.
textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей сущности.

Возвращаемое значение

Сущность с указанным в параметрах кодом. Если сущность с таким кодом не найдена, то возвращается значение null.

Заметки

Метод сводится к вызову виртуального метода GetByIdInternal(Object, IBXTextEncoder), поэтому в конкретной реализации сущности алгоритм его работы может быть изменен.

Примеры

CopyC#
BXIBlockElement el = BXIBlockElement.GetById(128, BXTextEncoder.XmlTextEncoder);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetById
Пространство имен Bitrix.DataLayer
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetById(Object)
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetByIdInternal(Object, IBXTextEncoder)


Метод GetByIdInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetByIdInternal
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetByIdInternal(Object, IBXTextEncoder) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById.
GetByIdInternal(Object, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetByIdInternal (Object, )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetByIdInternal (Object, )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual EntityType GetByIdInternal(
    Object id,
    IBXTextEncoder textEncoder
)

Параметры

id
Type: System..::..Object
Первичный ключ выбираемой сущности.
textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей сущности.

Возвращаемое значение

Сущность с указанным первичным ключем.

Заметки

Все статические методы типа GetById обращаются к методу GetByIdInternal. Этот метод является виртуальным и может быть переопределен в классе конкретной сущности для реализации нестандартной выборки.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetByIdInternal
Пространство имен Bitrix.DataLayer
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetById(Object)
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetById(Object, IBXTextEncoder)


Метод GetByIdInternal (Object, , )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetByIdInternal (Object, , )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual EntityType GetByIdInternal(
    Object id,
    IBXTextEncoder textEncoder,
    BXSchemeBase scheme
)

Параметры

id
Type: System..::..Object
Первичный ключ выбираемой сущности.
textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей сущности.
scheme
Type: BXSchemeBase
Схема сущности

Возвращаемое значение

Сущность с указанным первичным ключем.

Заметки

Все статические методы типа GetById обращаются к методу GetByIdInternal. Этот метод является виртуальным и может быть переопределен в классе конкретной сущности для реализации нестандартной выборки.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetByIdInternal
Пространство имен Bitrix.DataLayer
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetById(Object)
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetById(Object, IBXTextEncoder)


Метод GetCustomFieldsKey

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetCustomFieldsKey
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetCustomFieldsKey()()()() | Статический метод возвращает ключ для набираемых свойств сущности. Обычно применяется как параметр конструктора сущности BXSchemeCustomField.
GetCustomFieldsKey(Int32) | Статический метод возвращает ключ для набираемых свойств сущности по числовому коду. Обычно применяется как параметр конструктора сущности BXSchemeCustomField.
GetCustomFieldsKey(String) | Статический метод возвращает ключ для набираемых свойств сущности по строковому коду. Обычно применяется как параметр конструктора сущности BXSchemeCustomField.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetCustomFieldsKey

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetCustomFieldsKey
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Статический метод возвращает ключ для набираемых свойств сущности. Обычно применяется как параметр конструктора сущности BXSchemeCustomField.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetCustomFieldsKey()

Возвращаемое значение

Строка, содержащая ключ.

Заметки

Статический метод сводится к виртуальному методу GetCustomFieldsKeyInternal(String). Этот метод должен быть переопределен в конкретной реализации сущности, поддерживающей набираемые свойства.

Пример использования можно посмотреть на странице описания метода GetCustomFieldsKey(Int32).

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetCustomFieldsKey
Пространство имен Bitrix.DataLayer
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetCustomFieldsKey(Int32)
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetCustomFieldsKey(String)


Метод GetCustomFieldsKey (Int32)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetCustomFieldsKey (Int32)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Статический метод возвращает ключ для набираемых свойств сущности по числовому коду. Обычно применяется как параметр конструктора сущности BXSchemeCustomField.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetCustomFieldsKey(
    int id
)

Параметры

id
Type: System..::..Int32
Код.

Возвращаемое значение

Строка, содержащая ключ.

Заметки

Статический метод сводится к виртуальному методу GetCustomFieldsKeyInternal(String). Этот метод должен быть переопределен в конкретной реализации сущности, поддерживающей набираемые свойства.

Примеры

CopyC#
BXIBlockElementCollection col = BXIBlockElement.GetList(
    new BXFilter(
        new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, 5),
        new BXFilterItem(new BXSchemeCustomField(BXIBlockElement.GetCustomFieldsKey(5), "UF_AUTHORS", BXIBlockElement.Fields.ID), BXSqlFilterOperators.GreaterOrEqual, "26")
    ),
    new BXOrderBy(
        new BXOrderByPair(BXIBlockElement.Fields.Sort, BXOrderByDirection.Asc),
        new BXOrderByPair(new BXSchemeCustomField(BXIBlockElement.GetCustomFieldsKey(5), "UF_PUBLISHER", BXIBlockElement.Fields.ID), BXOrderByDirection.Asc)
    ),
    new BXSelect(
        BXIBlockElement.Fields.ID,
        BXIBlockElement.Fields.Name,
        BXIBlockElement.Fields.IBlock.ID,
        new BXSchemeCustomField(BXIBlockElement.GetCustomFieldsKey(5), "UF_YEAR", BXIBlockElement.Fields.ID)
    ),
    new BXQueryParams(new BXPagingOptions(0, 5))
);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetCustomFieldsKey
Пространство имен Bitrix.DataLayer
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetCustomFieldsKey()()()()
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetCustomFieldsKey(String)


Метод GetCustomFieldsKey (String)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetCustomFieldsKey (String)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Статический метод возвращает ключ для набираемых свойств сущности по строковому коду. Обычно применяется как параметр конструктора сущности BXSchemeCustomField.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetCustomFieldsKey(
    string id
)

Параметры

id
Type: System..::..String
Параметр ключа.

Возвращаемое значение

Строка, содержащая ключ.

Заметки

Статический метод сводится к виртуальному методу GetCustomFieldsKeyInternal(String). Этот метод должен быть переопределен в конкретной реализации сущности, поддерживающей набираемые свойства.

Пример использования можно посмотреть на странице описания метода GetCustomFieldsKey(Int32).

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetCustomFieldsKey
Пространство имен Bitrix.DataLayer
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetCustomFieldsKey(Int32)
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetCustomFieldsKey()()()()


Метод GetCustomFieldsKeyInternal

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetCustomFieldsKeyInternal
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual string GetCustomFieldsKeyInternal(
    string id
)

Параметры

id
Type: System..::..String
Параметр ключа.

Возвращаемое значение

Строка, содержащая код.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetDateTime

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetDateTime
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public DateTime GetDateTime(
    string columnName,
    DateTimeKind kind
)

Параметры

columnName
Type: System..::..String
kind
Type: System..::..DateTimeKind

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetFields

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetFields
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override BXSchemeBase GetFields()

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetJoinedEntity

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetJoinedEntity
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String) | Запрос присоединённой сущности
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String, BXSchemeBase) | Запрос присоединённой сущности

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetJoinedEntity(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType) (String, String, String)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetJoinedEntity<(Of <(<'JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>)> (String, String, String)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Запрос присоединённой сущности

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected JoinedEntityType GetJoinedEntity<JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>(
    string key,
    string path,
    string criterionKey
)
where JoinedEntityType : new(), BXEntity<JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>
where JoinedEntityCollectionType : new(), BXEntityCollection<TLEClass, TLECollection, TLEScheme>
where JoinedEntitySchemeType : new(), BXScheme<TLEScheme>

Параметры

key
Type: System..::..String
path
Type: System..::..String
criterionKey
Type: System..::..String

Параметры типа

JoinedEntityType
JoinedEntityCollectionType
JoinedEntitySchemeType

Возвращаемое значение

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetJoinedEntity
Пространство имен Bitrix.DataLayer


Метод GetJoinedEntity(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType) (String, String, String, )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetJoinedEntity<(Of <(<'JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>)> (String, String, String, )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Запрос присоединённой сущности

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected JoinedEntityType GetJoinedEntity<JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>(
    string key,
    string path,
    string criterionKey,
    BXSchemeBase scheme
)
where JoinedEntityType : new(), BXEntity<JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>
where JoinedEntityCollectionType : new(), BXEntityCollection<TLEClass, TLECollection, TLEScheme>
where JoinedEntitySchemeType : new(), BXScheme<TLEScheme>

Параметры

key
Type: System..::..String
path
Type: System..::..String
criterionKey
Type: System..::..String
scheme
Type: BXSchemeBase

Параметры типа

JoinedEntityType
JoinedEntityCollectionType
JoinedEntitySchemeType

Возвращаемое значение

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetJoinedEntity
Пространство имен Bitrix.DataLayer


Метод GetJoinedEntityCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetJoinedEntityCollection
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String) | Запрос коллекции присоединённых сущностей
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType, JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>)(String, String, String) | Запрос коллекции присоединённых сущностей

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetJoinedEntityCollection(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType) (String, String)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetJoinedEntityCollection<(Of <(<'JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>)> (String, String)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Запрос коллекции присоединённых сущностей

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected JoinedEntityCollectionType GetJoinedEntityCollection<JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>(
    string key,
    string path
)
where JoinedEntityType : new(), BXLinkedEntity<TLEClass, TLECollection, TLEScheme>
where JoinedEntityCollectionType : new(), BXEntityCollection<TLEClass, TLECollection, TLEScheme>
where JoinedEntitySchemeType : new(), BXScheme<TLEScheme>

Параметры

key
Type: System..::..String
path
Type: System..::..String

Параметры типа

JoinedEntityType
JoinedEntityCollectionType
JoinedEntitySchemeType

Возвращаемое значение

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetJoinedEntityCollection
Пространство имен Bitrix.DataLayer


Метод GetJoinedEntityCollection(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType, JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType) (String, String, String)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetJoinedEntityCollection<(Of <(<'JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType, JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>)> (String, String, String)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Запрос коллекции присоединённых сущностей

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected JoinedEntityCollectionType GetJoinedEntityCollection<JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType, JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>(
    string key,
    string path,
    string linkKey
)
where JoinedEntityType : new(), BXEntity<JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>
where JoinedEntityCollectionType : new(), BXEntityCollection<TLEClass, TLECollection, TLEScheme>
where JoinedEntitySchemeType : new(), BXScheme<TLEScheme>
where JoinedEntityLinkType : new(), BXLinkedEntity<JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>
where JoinedEntityLinkCollectionType : new(), BXEntityCollection<JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>
where JoinedEntityLinkSchemeType : new(), BXScheme<JoinedEntityLinkSchemeType>

Параметры

key
Type: System..::..String
path
Type: System..::..String
linkKey
Type: System..::..String

Параметры типа

JoinedEntityType
JoinedEntityCollectionType
JoinedEntitySchemeType
JoinedEntityLinkType
JoinedEntityLinkCollectionType
JoinedEntityLinkSchemeType

Возвращаемое значение

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetJoinedEntityCollection
Пространство имен Bitrix.DataLayer


Метод GetLinkedValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetLinkedValue
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetLinkedValue<(Of <<'(TLEClass, TLECollection, TLEScheme>)>>)(String) |
GetLinkedValue<(Of <<'(T>)>>)(String) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetLinkedValue(TLEClass, TLECollection, TLEScheme) (String)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetLinkedValue<(Of <(<'TLEClass, TLECollection, TLEScheme>)>)> (String)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected TLECollection GetLinkedValue<TLEClass, TLECollection, TLEScheme>(
    string key
)
where TLEClass : new(), BXLinkedEntity<TLEClass, TLECollection, TLEScheme>
where TLECollection : new(), BXEntityCollection<TLEClass, TLECollection, TLEScheme>
where TLEScheme : new(), BXScheme<TLEScheme>

Параметры

key
Type: System..::..String

Параметры типа

TLEClass
TLECollection
TLEScheme

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetLinkedValue
Пространство имен Bitrix.DataLayer


Метод GetLinkedValue(T) (String)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetLinkedValue<(Of <(<'T>)>)> (String)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected T GetLinkedValue<T>(
    string key
)
where T : new()

Параметры

key
Type: System..::..String
Ключ связки.

Параметры типа

T
Тип коллекции связок.

Возвращаемое значение

Возвращает коллекцию связок.

Примеры

CopyC#
public BXInfoBlockElementSectionCollection Sections
{
    get
    {
        return GetLinkedValue<BXInfoBlockElementSectionCollection>("Sections");
    }
}

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetLinkedValue
Пространство имен Bitrix.DataLayer


Метод GetLinkedValueCollection(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetLinkedValueCollection<(Of <(<'JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>)>
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected JoinedEntityLinkCollectionType GetLinkedValueCollection<JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>(
    string key,
    string path
)
where JoinedEntityLinkType : new(), BXLinkedEntity<TLEClass, TLECollection, TLEScheme>
where JoinedEntityLinkCollectionType : new(), BXEntityCollection<TLEClass, TLECollection, TLEScheme>
where JoinedEntityLinkSchemeType : new(), BXScheme<TLEScheme>

Параметры

key
Type: System..::..String
path
Type: System..::..String

Параметры типа

JoinedEntityLinkType
JoinedEntityLinkCollectionType
JoinedEntityLinkSchemeType

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetList

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetList
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetList(BXFilter, BXOrderBy) | Выбирает коллекцию сущностей по фильтру, отсортированную в соответствии с указанной сортировкой. Выбираются все поля сущности. Используется кодировщик по умолчанию для текстовых полей сущности.
GetList(BXFilter, BXOrderBy, BXSelect, BXQueryParams) | Выбирает коллекцию сущностей по фильтру filter, отсортированную в соответствии с указанной сортировкой orderBy. Выбираемые поля сущности передаются в списке select, условия на выборку - в queryParams. Используется кодировщик по умолчанию для текстовых полей сущности.
GetList(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder) | Выбирает коллекцию сущностей по фильтру filter, отсортированную в соответствии с указанной сортировкой orderBy. Выбираемые поля сущности передаются в списке select, условия на выборку - в queryParams. В textEncoder передается кодировщик текстовых полей сущности.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetList (BXFilter, BXOrderBy)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetList (BXFilter, BXOrderBy)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Выбирает коллекцию сущностей по фильтру, отсортированную в соответствии с указанной сортировкой. Выбираются все поля сущности. Используется кодировщик по умолчанию для текстовых полей сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static EntityCollectionType GetList(
    BXFilter filter,
    BXOrderBy orderBy
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
Фильтр, накладываемый на коллекцию сущностей.
orderBy
Type: Bitrix.DataLayer..::..BXOrderBy
Условия сортировки коллекции сущностей.

Возвращаемое значение

Коллекция сущностей, удовлетворяющая параметрам метода.

Заметки

Метод сводится к вызову виртуального метода GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder), поэтому его алгоритм может быть переопределен при реализации конкретной сущности.

Примеры

CopyC#
BXIBlockElementCollection col = BXIBlockElement.GetList(
    new BXFilter(
        new BXFilterItem(BXIBlockElement.Fields.Active, BXSqlFilterOperators.Equal, "Y"),
        new BXFilterItem(BXIBlockElement.Fields.IBlock.Sites.SiteId, BXSqlFilterOperators.Equal, "ru")
    ),
    new BXOrderBy(
        new BXOrderByPair(BXIBlockElement.Fields.Sort, BXOrderByDirection.Asc)
    )
);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetList
Пространство имен Bitrix.DataLayer


Метод GetList (BXFilter, BXOrderBy, BXSelect, BXQueryParams)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetList (BXFilter, BXOrderBy, BXSelect, BXQueryParams)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Выбирает коллекцию сущностей по фильтру filter, отсортированную в соответствии с указанной сортировкой orderBy. Выбираемые поля сущности передаются в списке select, условия на выборку - в queryParams. Используется кодировщик по умолчанию для текстовых полей сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static EntityCollectionType GetList(
    BXFilter filter,
    BXOrderBy orderBy,
    BXSelect select,
    BXQueryParams queryParams
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
Фильтр, накладываемый на коллекцию сущностей.
orderBy
Type: Bitrix.DataLayer..::..BXOrderBy
Условия сортировки коллекции сущностей.
select
Type: Bitrix.DataLayer..::..BXSelect
Список выбираемых полей сущности.
queryParams
Type: Bitrix.DataLayer..::..BXQueryParams
Параметры выборки.

Возвращаемое значение

Коллекция сущностей, удовлетворяющая параметрам метода.

Заметки

Метод сводится к вызову виртуального метода GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder), поэтому его алгоритм может быть переопределен при реализации конкретной сущности.

Примеры

CopyC#
BXIBlockElementCollection col = BXIBlockElement.GetList(
    new BXFilter(
        new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, 5),
        new BXFilterItem(new BXSchemeCustomField(BXIBlockElement.GetCustomFieldsKey(5), "UF_AUTHORS", BXIBlockElement.Fields.ID), BXSqlFilterOperators.GreaterOrEqual, "26")
    ),
    new BXOrderBy(
        new BXOrderByPair(BXIBlockElement.Fields.Sort, BXOrderByDirection.Asc),
        new BXOrderByPair(new BXSchemeCustomField(BXIBlockElement.GetCustomFieldsKey(5), "UF_PUBLISHER", BXIBlockElement.Fields.ID), BXOrderByDirection.Asc)
    ),
    new BXSelect(
        BXIBlockElement.Fields.ID,
        BXIBlockElement.Fields.Name,
        BXIBlockElement.Fields.IBlock.ID,
        new BXSchemeCustomField(BXIBlockElement.GetCustomFieldsKey(5), "UF_YEAR", BXIBlockElement.Fields.ID)
    ),
    new BXQueryParams(new BXPagingOptions(0, 5))
);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetList
Пространство имен Bitrix.DataLayer


Метод GetList (BXFilter, BXOrderBy, BXSelect, BXQueryParams, )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetList (BXFilter, BXOrderBy, BXSelect, BXQueryParams, )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Выбирает коллекцию сущностей по фильтру filter, отсортированную в соответствии с указанной сортировкой orderBy. Выбираемые поля сущности передаются в списке select, условия на выборку - в queryParams. В textEncoder передается кодировщик текстовых полей сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static EntityCollectionType GetList(
    BXFilter filter,
    BXOrderBy orderBy,
    BXSelect select,
    BXQueryParams queryParams,
    IBXTextEncoder textEncoder
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
Фильтр, накладываемый на коллекцию сущностей.
orderBy
Type: Bitrix.DataLayer..::..BXOrderBy
Условия сортировки коллекции сущностей.
select
Type: Bitrix.DataLayer..::..BXSelect
Список выбираемых полей сущности.
queryParams
Type: Bitrix.DataLayer..::..BXQueryParams
Параметры выборки.
textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей сущности.

Возвращаемое значение

Коллекция сущностей, удовлетворяющая параметрам метода.

Заметки

Метод сводится к вызову виртуального метода GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder), поэтому его алгоритм может быть переопределен при реализации конкретной сущности.

Примеры

CopyC#
BXIBlockElementCollection col = BXIBlockElement.GetList(
    new BXFilter(
        new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, 5),
        new BXFilterItem(new BXSchemeCustomField(BXIBlockElement.GetCustomFieldsKey(5), "UF_AUTHORS", BXIBlockElement.Fields.ID), BXSqlFilterOperators.GreaterOrEqual, "26")
    ),
    new BXOrderBy(
        new BXOrderByPair(BXIBlockElement.Fields.Sort, BXOrderByDirection.Asc),
        new BXOrderByPair(new BXSchemeCustomField(BXIBlockElement.GetCustomFieldsKey(5), "UF_PUBLISHER", BXIBlockElement.Fields.ID), BXOrderByDirection.Asc)
    ),
    new BXSelect(
        BXIBlockElement.Fields.ID,
        BXIBlockElement.Fields.Name,
        BXIBlockElement.Fields.IBlock.ID,
        new BXSchemeCustomField(BXIBlockElement.GetCustomFieldsKey(5), "UF_YEAR", BXIBlockElement.Fields.ID)
    ),
    new BXQueryParams(new BXPagingOptions(0, 5)),
    BXTextEncoder.EmptyTextEncoder
);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetList
Пространство имен Bitrix.DataLayer


Метод GetListInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetListInternal
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList.
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetListInternal (BXFilter, BXOrderBy, BXSelect, BXQueryParams, )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetListInternal (BXFilter, BXOrderBy, BXSelect, BXQueryParams, )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual EntityCollectionType GetListInternal(
    BXFilter filter,
    BXOrderBy orderBy,
    BXSelect select,
    BXQueryParams queryParams,
    IBXTextEncoder textEncoder
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
Фильтр, накладываемый на коллекцию сущностей.
orderBy
Type: Bitrix.DataLayer..::..BXOrderBy
Условия сортировки коллекции сущностей.
select
Type: Bitrix.DataLayer..::..BXSelect
Список выбираемых полей сущности.
queryParams
Type: Bitrix.DataLayer..::..BXQueryParams
Параметры выборки.
textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей сущности.

Возвращаемое значение

Коллекция сущностей, удовлетворяющая параметрам метода.

Заметки

Все статические методы типа GetList обращаются к методу GetListInternal. Этот метод является виртуальным и может быть переопределен в классе конкретной сущности для реализации нестандартной выборки.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetListInternal
Пространство имен Bitrix.DataLayer
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetList(BXFilter, BXOrderBy)
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetList(BXFilter, BXOrderBy, BXSelect, BXQueryParams)
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetList(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder)


Метод GetListInternal (BXFilter, BXOrderBy, BXSelect, BXQueryParams, , )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetListInternal (BXFilter, BXOrderBy, BXSelect, BXQueryParams, , )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual EntityCollectionType GetListInternal(
    BXFilter filter,
    BXOrderBy orderBy,
    BXSelect select,
    BXQueryParams queryParams,
    IBXTextEncoder textEncoder,
    BXSchemeBase scheme
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
Фильтр, накладываемый на коллекцию сущностей.
orderBy
Type: Bitrix.DataLayer..::..BXOrderBy
Условия сортировки коллекции сущностей.
select
Type: Bitrix.DataLayer..::..BXSelect
Список выбираемых полей сущности.
queryParams
Type: Bitrix.DataLayer..::..BXQueryParams
Параметры выборки.
textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей сущности.
scheme
Type: BXSchemeBase
Схема сущности

Возвращаемое значение

Коллекция сущностей, удовлетворяющая параметрам метода.

Заметки

Все статические методы типа GetList обращаются к методу GetListInternal. Этот метод является виртуальным и может быть переопределен в классе конкретной сущности для реализации нестандартной выборки.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetListInternal
Пространство имен Bitrix.DataLayer
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetList(BXFilter, BXOrderBy)
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetList(BXFilter, BXOrderBy, BXSelect, BXQueryParams)
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetList(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder)


Метод GetValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetValue
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetValue(String) | Возвращает значение поля сущности. Значение не модифицировано кодировщиком.
GetValue<(Of <<'(T>)>>)(String) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetValue (String)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetValue (String)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Возвращает значение поля сущности. Значение не модифицировано кодировщиком.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Object GetValue(
    string columnName
)

Параметры

columnName
Type: System..::..String
Код поля.

Возвращаемое значение

Возвращает значение поля сущности. Значение не модифицировано кодировщиком. В случае отсутствия значения с указанным кодом возвращается null.

Примеры

CopyC#
public object Sort
{
    get { return GetValue("Sort"); }
    set { SetValue("Sort", value); }
}

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetValue
Пространство имен Bitrix.DataLayer


Метод GetValue(T) (String)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetValue<(Of <(<'T>)>)> (String)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public T GetValue<T>(
    string columnName
)

Параметры

columnName
Type: System..::..String
Код поля.

Параметры типа

T
Тип значения поля.

Возвращаемое значение

Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. В случае отсутствия значения с указанным кодом возвращается значение по умолчанию для данного типа T.

Примеры

CopyC#
public string Id
{
    get { return this.TextEncoder.Encode(GetValue<string>("ID")); }
    set { SetValue("ID", value); }
}

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка GetValue
Пространство имен Bitrix.DataLayer


Метод GetValueOfEnumOrDefault(T)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetValueOfEnumOrDefault<(Of <(<'T>)>)>
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public T GetValueOfEnumOrDefault<T>(
    string columnName,
    T defaultValue,
    bool isFlags
)

Параметры

columnName
Type: System..::..String
defaultValue
Type: T
isFlags
Type: System..::..Boolean

Параметры типа

T

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetValueOrDefault(T)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetValueOrDefault<(Of <(<'T>)>)>
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public T GetValueOrDefault<T>(
    string columnName,
    T defaultValue
)

Параметры

columnName
Type: System..::..String
defaultValue
Type: T

Параметры типа

T

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод GetValues

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.GetValues
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override IDictionary<string, Object> GetValues()

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод InitializeFromReader

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.InitializeFromReader
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Инициализирует сущность на основании объекта BXSqlDataReader.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected void InitializeFromReader(
    BXSqlDataReader reader
)

Параметры

reader
Type: BXSqlDataReader
Объекта BXSqlDataReader.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод InitializeFromSequentialReader

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.InitializeFromSequentialReader
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess'

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected void InitializeFromSequentialReader(
    BXSqlDataReader reader
)

Параметры

reader
Type: BXSqlDataReader
Reader BXSqlDataReader.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод OnInit

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.OnInit
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Вызывается после инициализации полей сущности значениями из БД

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void OnInit()

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод PrepareFromForGetList

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.PrepareFromForGetList
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Подготавливает часть FROM запроса для выборки.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual string PrepareFromForGetList(
    string key,
    BXSchemeBase scheme,
    BXFilter filter,
    BXOrderBy orderBy,
    BXSelect select
)

Параметры

key
Type: System..::..String
Ключ запроса. Для основного запроса равен пустой строке. Для подзапросов составляется из имен связанных таблиц.
scheme
Type: BXSchemeBase
Схема основной таблицы запроса.
filter
Type: Bitrix.DataLayer..::..BXFilter
Фильтр запроса.
orderBy
Type: Bitrix.DataLayer..::..BXOrderBy
Сортировка запроса.
select
Type: Bitrix.DataLayer..::..BXSelect
Список полей запроса.

Возвращаемое значение

Строка, содержащая часть FROM запроса на выборку.

Примеры

CopyC#
StringBuilder sb = new StringBuilder();
sb.Append("SELECT ");
sb.AppendLine(select.SelectString);
sb.Append(this.PrepareFromForGetList(string.Empty, BXIBlockElement.Fields, filter, orderBy, select));
if (filter != null)
    if (filter.FilterString.ContainsKey(String.Empty))
        sb.AppendLine(String.Format("WHERE {0}", filter.FilterString[String.Empty]));
if (orderBy != null)
    if (!String.IsNullOrEmpty(orderBy.OrderByString))
        sb.AppendLine(String.Format("ORDER BY {0}", orderBy.OrderByString));
SqlParameter[] parameters = this.PrepareParametersForGetList(filter, orderBy, select);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод PrepareParametersForGetList

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.PrepareParametersForGetList
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Подготавливает список параметров для выборки.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual SqlParameter[] PrepareParametersForGetList(
    BXFilter filter,
    BXOrderBy orderBy,
    BXSelect select
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
Фильтр запроса.
orderBy
Type: Bitrix.DataLayer..::..BXOrderBy
Сортировка запроса.
select
Type: Bitrix.DataLayer..::..BXSelect
Список полей запроса.

Возвращаемое значение

Массив параметров запроса на выборку.

Примеры

CopyC#
StringBuilder sb = new StringBuilder();
sb.Append("SELECT ");
sb.AppendLine(select.SelectString);
sb.Append(this.PrepareFromForGetList(string.Empty, BXIBlockElement.Fields, filter, orderBy, select));
if (filter != null)
    if (filter.FilterString.ContainsKey(String.Empty))
        sb.AppendLine(String.Format("WHERE {0}", filter.FilterString[String.Empty]));
if (orderBy != null)
    if (!String.IsNullOrEmpty(orderBy.OrderByString))
        sb.AppendLine(String.Format("ORDER BY {0}", orderBy.OrderByString));
SqlParameter[] parameters = this.PrepareParametersForGetList(filter, orderBy, select);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод PrepareSelectForGetList

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.PrepareSelectForGetList
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void PrepareSelectForGetList(
    ref BXSelect select
)

Параметры

select
Type: Bitrix.DataLayer..::..BXSelect %
Список полей типа BXSelect, переданый в метод выборки.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Save
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет сущность в базе данных в новой транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Переопределяет BXEntity..::..Save()()()())
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет сущность в базе данных в указанной транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Переопределяет BXEntity..::..Save(BXSqlConnection, BXSqlTransaction))

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод Save

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Save
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Сохраняет сущность в базе данных в новой транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override void Save()

Заметки

Этот метод вызывает метод Create()()()(), если свойство IsNew сущности установлено в значение true, и вызывает метод Update()()()() в противном случае. Свойство IsNew сущности устанавливается автоматически.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка Save
Пространство имен Bitrix.DataLayer


Метод Save (, )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Save (, )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Сохраняет сущность в базе данных в указанной транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override void Save(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Заметки

Этот метод вызывает метод Create(BXSqlConnection, BXSqlTransaction), если свойство IsNew сущности установлено в значение true, и вызывает метод Update(BXSqlConnection, BXSqlTransaction) в противном случае. Свойство IsNew сущности устанавливается автоматически.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка Save
Пространство имен Bitrix.DataLayer


Метод SaveCustomProperties

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.SaveCustomProperties
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void SaveCustomProperties(
    BXSqlConnection con,
    BXSqlTransaction tran
)

Параметры

con
Type: BXSqlConnection
tran
Type: BXSqlTransaction

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод SaveEntityLinks

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.SaveEntityLinks
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Сохранение сущностей-связок

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void SaveEntityLinks(
    BXSqlConnection con,
    BXSqlTransaction tran,
    bool deleteExisted
)

Параметры

con
Type: BXSqlConnection
tran
Type: BXSqlTransaction
deleteExisted
Type: System..::..Boolean

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод SendOnActionCommand

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.SendOnActionCommand
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Отправляет команду On перед изменением сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected void SendOnActionCommand(
    string commandType,
    Dictionary<string, Object> commandParams
)

Параметры

commandType
Type: System..::..String
Тип команды. Возможные значения: Create, Update, Delete.
commandParams
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
Словарь дополнительных параметров команды.

Заметки

Отправляется команда Bitrix.{ModuleId}.{EntityId}.On{CommandType}, где {ModuleId} - код модуля сущности (задается при реализации конкретной сущности), {EntityId} - код сущности (задается при реализации конкретной сущности), а {CommandType} - тип команды. В параметрах команды передаются:

  • в параметре с ключом Entity - сущность,

  • в параметре с ключом EntityValues - значения полей сущности.

Примеры

CopyC#
this.SendOnActionCommand("Update", null);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод SendOnAfterActionCommand

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.SendOnAfterActionCommand
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Отправляет команду OnAfter после изменения сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected void SendOnAfterActionCommand(
    string commandType,
    Dictionary<string, Object> commandParams
)

Параметры

commandType
Type: System..::..String
Тип команды. Возможные значения: Create, Update, Delete.
commandParams
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
Словарь дополнительных параметров команды.

Заметки

Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnAfter{CommandType}, где {ModuleId} - код модуля сущности (задается при реализации конкретной сущности), {EntityId} - код сущности (задается при реализации конкретной сущности), а {CommandType} - тип команды. В параметрах команды передаются:

  • в параметре с ключом Entity - сущность,

  • в параметре с ключом EntityValues - значения полей сущности.

Примеры

CopyC#
this.SendOnAfterActionCommand("Delete", null);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод SendOnBeforeActionCommand

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.SendOnBeforeActionCommand
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Отправляет команду OnBefore перед изменением сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected void SendOnBeforeActionCommand(
    string commandType,
    Dictionary<string, Object> commandParams
)

Параметры

commandType
Type: System..::..String
Тип команды. Возможные значения: Create, Update, Delete.
commandParams
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
Словарь дополнительных параметров команды.

Заметки

Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnBefore{CommandType}, где {ModuleId} - код модуля сущности (задается при реализации конкретной сущности), {EntityId} - код сущности (задается при реализации конкретной сущности), а {CommandType} - тип команды. В параметрах команды передаются:

  • в параметре с ключом Entity - сущность,

  • в параметре с ключом EntityValues - значения полей сущности.

Примеры

CopyC#
this.SendOnBeforeActionCommand("Create", null);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод SetReadOnly

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.SetReadOnly
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void SetReadOnly()

Примеры

CopyC#
BXIBlock ib = BXIBlock.GetById(28);
ib.SetReadOnly();
ib.Save();  // throw new ReadOnlyException

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод SetValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.SetValue
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
SetValue(KeyValuePair<(Of <<'(String, Object>)>>), Boolean) |
SetValue(String, Object) | Устанавливает значение поля сущности.
SetValue(String, Object, Boolean) | Устанавливает значение поля сущности.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод SetValue (KeyValuePair(String, Object), Boolean)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.SetValue (KeyValuePair<(Of <(<'String, Object>)>)>, Boolean)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected internal void SetValue(
    KeyValuePair<string, Object> kv,
    bool markAsDirty
)

Параметры

kv
Type: System.Collections.Generic..::..KeyValuePair <(Of <(<' String, Object >)>)>
markAsDirty
Type: System..::..Boolean

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка SetValue
Пространство имен Bitrix.DataLayer


Метод SetValue (String, Object)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.SetValue (String, Object)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Устанавливает значение поля сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected internal void SetValue(
    string columnName,
    Object value
)

Параметры

columnName
Type: System..::..String
Код поля сущности.
value
Type: System..::..Object
Значение.

Примеры

CopyC#
public BXTextType PreviewTextType
{
get { return ("T".Equals(GetValue("PreviewTextType"), StringComparison.InvariantCultureIgnoreCase) ? BXTextType.Text : BXTextType.Html); }
set { SetValue("PreviewTextType", ((value == BXTextType.Text) ? "T" : "H")); }
}

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка SetValue
Пространство имен Bitrix.DataLayer


Метод SetValue (String, Object, Boolean)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.SetValue (String, Object, Boolean)
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Устанавливает значение поля сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected internal void SetValue(
    string columnName,
    Object value,
    bool markAsDirty
)

Параметры

columnName
Type: System..::..String
Код поля сущности
value
Type: System..::..Object
Значение
markAsDirty
Type: System..::..Boolean
Пометить эту сущность как изменённую

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка SetValue
Пространство имен Bitrix.DataLayer


Метод SetXmlValue

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.SetXmlValue
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected internal void SetXmlValue(
    string columnName,
    IBXXmlExternalizable source,
    bool markAsDirty
)

Параметры

columnName
Type: System..::..String
source
Type: IBXXmlExternalizable
markAsDirty
Type: System..::..Boolean

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод TryResolveMultipleJoin(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.TryResolveMultipleJoin<(Of <(<'JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>)>
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Разрешить множественную связь

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected bool TryResolveMultipleJoin<JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>(
    string path,
    out JoinedEntityCollectionType result
)
where JoinedEntityType : new(), BXEntity<JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>
where JoinedEntityCollectionType : new(), BXEntityCollection<TLEClass, TLECollection, TLEScheme>
where JoinedEntitySchemeType : new(), BXScheme<TLEScheme>

Параметры

path
Type: System..::..String
Путь к присоединённой сущности в контексте этой сущности
result
Type: JoinedEntityCollectionType%

Параметры типа

JoinedEntityType
Тип присоединённой сущности
JoinedEntityCollectionType
Тип коллекции присоединённой сущности
JoinedEntitySchemeType
Тип схемы присоединённой сущности

Возвращаемое значение

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод TryResolveSingleJoin(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType)

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.TryResolveSingleJoin<(Of <(<'JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>)>
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Разрешить одинарную связь

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected bool TryResolveSingleJoin<JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>(
    string path,
    out JoinedEntityType result
)
where JoinedEntityType : new(), BXEntity<JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>
where JoinedEntityCollectionType : new(), BXEntityCollection<TLEClass, TLECollection, TLEScheme>
where JoinedEntitySchemeType : new(), BXScheme<TLEScheme>

Параметры

path
Type: System..::..String
Путь к присоединённой сущности в контексте этой сущности
result
Type: JoinedEntityType%

Параметры типа

JoinedEntityType
Тип присоединённой сущности
JoinedEntityCollectionType
Тип коллекции присоединённой сущности
JoinedEntitySchemeType
Тип схемы присоединённой сущности

Возвращаемое значение

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод TrySetFields

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.TrySetFields
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override bool TrySetFields(
    BXSchemeBase scheme
)

Параметры

scheme
Type: BXSchemeBase

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод TrySetValues

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.TrySetValues
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override bool TrySetValues(
    BXEntity sourceEntity,
    string sourceKeyPrefix
)

Параметры

sourceEntity
Type: Bitrix.DataLayer..::..BXEntity
sourceKeyPrefix
Type: System..::..String

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод Update

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Update
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Update()()()() | Изменяет существующую сущность в базе данных в новой транзакции. (Переопределяет BXEntity..::..Update()()()())
Update(BXSqlConnection, BXSqlTransaction) | Изменяет существующую сущность в базе данных в указанной транзакции. (Переопределяет BXEntity..::..Update(BXSqlConnection, BXSqlTransaction))

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод Update

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Update
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Изменяет существующую сущность в базе данных в новой транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override void Update()

Заметки

Описание алгоритма изменения сущности можно посмотреть на странице метода Update(BXSqlConnection, BXSqlTransaction).

Примеры

CopyC#
BXSite site = BXSite.GetById("company");
site.Name = "Моя компания";
site.Active = true;
site.Sort = 150;
site.Update();

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка Update
Пространство имен Bitrix.DataLayer


Метод Update (, )

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Update (, )
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Изменяет существующую сущность в базе данных в указанной транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override void Update(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Заметки

Метод сохранения существующей сущности является виртуальным и может быть переопределен в конкретной реализации сущности. Таким образом сохранение конкретной сущности может осуществляться не стандартным образом.

Стандартное сохранение существующей сущности происходит следующим образом:

  1. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnBeforeUpdate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Cancel, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для того, чтобы была возможность корректно отменить сохранение сущности. Обработчики этой команды не должны модифицировать данные, так как нет гарантий, что один из обработчиков не отменит сохранение.

  2. Вызывается виртуальный метод VerifyEntry()()()(), который проверяет соответствие параметров сущности и ее схемы. Производятся следующие проверки полей сущности:

    • если поле является первичным ключем, то в параметрах сущности должно быть задано значение для этого поля,

    • если поле является строковым, у него задано ограничение по длине и задано значение этого поля, то значение не должно быть длинее указанного ограничения.

    Если метод VerifyEntry()()()() вернул отличный от BXModifyStatusResult.Success статус, то сохранение преравается и выбрасывается исключение типа BXEventException.

  3. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnUpdate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций перед сохранением существующей сущности.

  4. Производится сохранение сущности и ее связок.

  5. Выполняется виртуальный метод UpdateAdditionalEntities(BXSqlConnection, BXSqlTransaction), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется в рамках транзакции сохранения сущности.

  6. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnAfterUpdate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций после сохранения существующей сущности.

  7. Выполняется виртуальный метод UpdateAfterSuccess()()()(), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется после закрытия соединения, в котором сохранялась сущность.

Примеры

CopyC#
BXSite site = BXSite.GetById("company");
site.Name = "Моя компания";
site.Active = true;
site.Sort = 150;
site.Update();

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка Update
Пространство имен Bitrix.DataLayer


Метод UpdateAdditionalEntities

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.UpdateAdditionalEntities
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void UpdateAdditionalEntities(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Заметки

Этот метод ничего не делает в базовой реализации сущности, но может быть переопределен в конкретной сущности.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод UpdateAfterSuccess

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.UpdateAfterSuccess
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void UpdateAfterSuccess()

Заметки

Этот метод ничего не делает в базовой реализации сущности, но может быть переопределен в конкретной сущности.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод VerifyEntry

Метод BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.VerifyEntry
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Проверяет корректность сущности перед сохранением.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual BXModifyStatus VerifyEntry()

Возвращаемое значение

Объект типа BXModifyStatus, содержащий статус проверки. Если метод VerifyEntry() вернул отличный от BXModifyStatusResult.Success статус, то сохранение прерывается и выбрасывается исключение типа BXEventException.

Заметки

Алгоритм проверки корректности при сохранении новой сущности следующий:

  • если поле является первичным ключем и у него установлен флаг Identity, то в параметрах сущности не должно быть заданого значения для этого поля,

  • если поле является первичным ключем и у него не установлен флаг Identity, то в параметрах сущности должно быть задано значение для этого поля,

  • если поле является обязательным и у него не задано значение по умолчанию, то в параметрах сущности должно быть задано значение для этого поля,

  • если поле является строковым, у него задано ограничение по длине и задано значение этого поля, то значение не должно быть длинее указанного ограничения.

Алгоритм проверки корректности при изменении существующей сущности следующий:

  • если поле является первичным ключем, то в параметрах сущности должно быть задано значение для этого поля,

  • если поле является строковым, у него задано ограничение по длине и задано значение этого поля, то значение не должно быть длинее указанного ограничения.

Примеры

CopyC#
BXModifyStatus status = this.VerifyEntry();
status.TryThrowException();

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойства BXEntity(EntityType, EntityCollectionType, EntryScheme)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Тип BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> предоставляет следующие возможности.

Свойства

Имя | Описание
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Унаследовано от BXEntity)
CustomPublicValues | (Переопределяет BXEntity..::..CustomPublicValues)
CustomValues | Возвращает список значений набираемых свойств сущности. (Переопределяет BXEntity..::..CustomValues)
EntityId | Возвращает код сущности. Должен быть переопределен в конкретной сущности.
EntityKey | Возвращает значение первичного ключа сущности.
EntityOriginContext | (Унаследовано от BXEntity)
EntitySingleton | Возвращает статический экземпляр новой сущности.
Fields | Возвращает схему сущности.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false.
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false.
IsReadOnly |
JoinedEntityMap | Набор отражений для связанных сущностей (Переопределяет BXEntity..::..JoinedEntityMap)
ModuleId | Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Переопределяет BXEntity..::..TextEncoder)
ValueMap | Набор отражений для полей (Переопределяет BXEntity..::..ValueMap)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство CustomPublicValues

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.CustomPublicValues
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override BXCustomPropertyValueModificator CustomPublicValues { get; }

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство CustomValues

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.CustomValues
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Возвращает список значений набираемых свойств сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override BXCustomPropertyCollection CustomValues { get; }

Заметки

Для работы с набираемыми свойствами у конкретной сущности должно быть переопределено свойство [!:Bitrix.DataLayer.BXEntity<EntityType, EntityCollectionType, EntryScheme>.CustomFieldsKey]. Это свойство должно вернуть ключ для набираемых свойств конкретной сущности.

Список значений набираемых свойств выбирается один раз при первом обращении к свойству CustomValues.

Примеры

CopyC#
BXIBlockElement el = BXIBlockElement.GetById(128, BXTextEncoder.XmlTextEncoder);
StringBuilder sb = new StringBuilder();
foreach (KeyValuePair kvp in el.CustomValues)
{
    sb.AppendFormat("{0}=", kvp.Key);
    if (kvp.Value.IsMultiple)
    {
        if (kvp.Value.Values.Count > 0)
        {
            sb.Append(kvp.Value.Values[0].ToString());
            for (int j = 1; j < kvp.Value.Values.Count; j++)
                sb.AppendFormat(", {0}", kvp.Value.Values[j].ToString());
        }
    }
    else
    {
        sb.Append(kvp.Value.Value);
    }
    sb.Append("");
}

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство EntityId

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.EntityId
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Возвращает код сущности. Должен быть переопределен в конкретной сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract string EntityId { get; }

Заметки

Это свойство используется для формирования названий команд, отправляемых при сохранении сущности в базу данных или удалении из базы данных.

Примеры

CopyC#
public class BXIBlockElement
    : BXEntity
{
    . . .

    public override string ModuleId
    {
        get { return "iblock"; }
    }

    public override string EntityId
    {
        get { return "IBlockElement"; }
    }

    . . .
}

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство EntityKey

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.EntityKey
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Возвращает значение первичного ключа сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual Object EntityKey { get; }

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство EntitySingleton

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.EntitySingleton
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Возвращает статический экземпляр новой сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected static EntityType EntitySingleton { get; }

Заметки

Возвращает статический экземпляр новой сущности, который используется для доступа к динамическим методам сущности из статических методов. Пригодные для доступа динамические методы не должны зависеть от конкретного экземпляра сущности.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство Fields

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Fields
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Возвращает схему сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static EntryScheme Fields { get; }

Заметки

Это свойство используется для получения полей сущности, которые далее передаются параметрами в фильтры, условия сортировки, выборки и бругие методы работы с сущностями.

Примеры

CopyC#
BXIBlockElementCollection col = BXIBlockElement.GetList(
    new BXFilter(
        new BXFilterItem(BXIBlockElement.Fields.Active, BXSqlFilterOperators.Equal, "Y"),
        new BXFilterItem(BXIBlockElement.Fields.IBlock.Sites.SiteId, BXSqlFilterOperators.Equal, "ru")
    ),
    new BXOrderBy(
        new BXOrderByPair(BXIBlockElement.Fields.Sort, BXOrderByDirection.Asc)
    )
);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство IsDirty

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.IsDirty
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool IsDirty { get; protected internal set; }

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство IsNew

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.IsNew
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual bool IsNew { get; protected internal set; }

Заметки

Это свойство используется в методе Save для того, чтобы определить, нужно ли вставить в базу новую сущность или нужно изменить существующую.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство IsReadOnly

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.IsReadOnly
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool IsReadOnly { get; }

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство JoinedEntityMap

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.JoinedEntityMap
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Набор отражений для связанных сущностей

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected internal override IBXJoinedEntityMap JoinedEntityMap { get; set; }

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство ModuleId

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.ModuleId
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract string ModuleId { get; }

Заметки

Это свойство используется для формирования названий команд, отправляемых при сохранении сущности в базу данных или удалении из базы данных.

Примеры

CopyC#
public class BXIBlockElement
    : BXEntity
{
    . . .

    public override string ModuleId
    {
        get { return "iblock"; }
    }

    public override string EntityId
    {
        get { return "IBlockElement"; }
    }

    . . .
}

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство TextEncoder

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.TextEncoder
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Пример Смотри также Send Feedback
Возвращает кодировщик текстовых полей сущности.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override IBXTextEncoder TextEncoder { get; protected internal set; }

Заметки

Кодировщик текстовых полей сущности служит для преобразования значений текстовых полей сущности к безопасному виду. Безопасный вид значения текстового поля зависит от последующего применения этого значения. Другими словами, значение, которое приведено к безопасному виду для одного применения, не обязательно будет безопасным для другого.

Кодировщик текстовых полей сущности устанавливается при создании сущности: в конструкторе сущности или в методе выборки сущности из базы данных.

По умолчанию используется кодировщик DefaultEncoder()()()(), который является кодировщиком для вывода текста в браузер. Так же доступны следующие кодировщики:

  • EmptyTextEncoder()()()() - не кодирует текст, возвращая его в исходном виде,

  • XmlTextEncoder()()()() - кодирует текст для вывода в XML документ,

  • HtmlTextEncoder()()()() - для вывода текста в браузер (совпадает с кодировщиком по умолчанию).

Есть возможность создать собственные нестандартные кодировщики, реализовав интерфейс IBXTextEncoder.

Примеры

CopyC#
BXIBlockElement el = BXIBlockElement.GetById(128, BXTextEncoder.XmlTextEncoder);

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство ValueMap

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.ValueMap
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Набор отражений для полей

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected internal override IBXEntityValueMap ValueMap { get; set; }

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Свойство Values

Свойство BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Values
Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Dictionary<string, Object> Values { get; }

Заметки

Для программирования в публичной части сайта должны по возможности использоваться свойства сущности, которые возвращают типизированые данные в подготовленном виде. Свойство Values обеспечивает доступ к значениям полей сущности в сыром виде.

Смотри также

Класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Класс BXEntityCollection(EntityType, EntityCollectionType, EntryScheme)

Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены Пример Смотри также Send Feedback
BXEntityCollection - базовый класс коллекции сущностей системы.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract class BXEntityCollection<EntityType, EntityCollectionType, EntryScheme> : List<EntityType>,
    IBXEntityCollection
where EntityType : new(), BXEntity<EntityType, EntityCollectionType, EntryScheme>
where EntityCollectionType : new(), BXEntityCollection<EntityType, EntityCollectionType, EntryScheme>
where EntryScheme : new(), BXScheme<EntryScheme>

Параметры типа

EntityType
Класс сущности
EntityCollectionType
Класс коллекции сущностей
EntryScheme
Класс схемы сущности

Примеры

Коллекция сущностей информационного блока:

CopyC#
public class BXIBlockCollection : BXEntityCollection<BXIBlock, BXIBlockCollection, BXIBlock.Scheme>
{
    public BXIBlockCollection()
    {
    }
}

где:

  • BXIBlock - сущность информационного блок,

  • BXIBlockCollection - коллекция сущностей информационных блоков,

  • BXIBlock.Scheme - схема сущности информационного блока.

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<'EntityType>)>)>
Bitrix.DataLayer..::..BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Bitrix.IBlock..::..BXIBlock..::..BXInfoBlockSiteCollection
Bitrix.IBlock..::..BXIBlockCollection
Bitrix.IBlock..::..BXIBlockElement..::..BXInfoBlockElementSectionCollection
Bitrix.IBlock..::..BXIBlockElementCollection
Bitrix.IBlock..::..BXIBlockSectionCollection
Bitrix.IBlock..::..BXIBlockType..::..BXInfoBlockTypeLangCollection
Bitrix.IBlock..::..BXIBlockTypeCollection
Bitrix.IO..::..BXFileCollection
Bitrix.Services..::..BXSchedulerAgentCollection

Смотри также

Члены BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Члены BXEntityCollection(EntityType, EntityCollectionType, EntryScheme)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Конструкторы Методы Смотри также Send Feedback

Тип BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> | Перегруженный.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции.
ToDataTable | Перегруженный.

Смотри также

Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Конструктор BXEntityCollection(EntityType, EntityCollectionType, EntryScheme)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>()()()() | Инициализирует новый экземпляр коллекции сущностей.
BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>(IEnumerable<(Of <<'(EntityType>)>>)) | Инициализирует новый экземпляр коллекции сущностей. Заполняет коллекцию сущностями.

Смотри также

Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Конструктор BXEntityCollection(EntityType, EntityCollectionType, EntryScheme)

Конструктор BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Инициализирует новый экземпляр коллекции сущностей.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXEntityCollection()

Смотри также

Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Конструктор BXEntityCollection(EntityType, EntityCollectionType, EntryScheme) (IEnumerable(EntityType))

Конструктор BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> (IEnumerable<(Of <(<'EntityType>)>)>)
Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Инициализирует новый экземпляр коллекции сущностей. Заполняет коллекцию сущностями.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXEntityCollection(
    IEnumerable<EntityType> list
)

Параметры

list
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' EntityType >)>)>
Коллекция сущностей.

Смотри также

Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Методы BXEntityCollection(EntityType, EntityCollectionType, EntryScheme)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Тип BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> предоставляет следующие возможности.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции.
ToDataTable | Перегруженный.

Смотри также

Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Save
Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет все сущности коллекции.
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет все сущности коллекции, используя указанное соединение.

Смотри также

Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод Save

Метод BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Save
Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Сохраняет все сущности коллекции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void Save()

Заметки

Сохранение происходит путем вызова метода Save()()()() каждой из сущностей коллекции.

Смотри также

Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка Save
Пространство имен Bitrix.DataLayer


Метод Save (, )

Метод BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.Save (, )
Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Сохраняет все сущности коллекции, используя указанное соединение.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void Save(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Заметки

Сохранение происходит путем вызова метода Save(BXSqlConnection, BXSqlTransaction) каждой из сущностей коллекции.

Смотри также

Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка Save
Пространство имен Bitrix.DataLayer


Метод SetValue

Метод BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.SetValue
Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Устанавливает значение поля всех сущностей коллекции.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void SetValue(
    string columnName,
    Object value
)

Параметры

columnName
Type: System..::..String
Ключ поля сущности, значение которого устанавливается.
value
Type: System..::..Object
Значение.

Смотри также

Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод ToDataTable

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.ToDataTable
Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ToDataTable()()()() | Приводит коллекцию к типу DataTable.
ToDataTable(BXPagingOptions) | Приводит коллекцию к типу DataTable с применением опций постраничной навигации.

Смотри также

Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Члены BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Пространство имен Bitrix.DataLayer


Метод ToDataTable

Метод BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.ToDataTable
Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Приводит коллекцию к типу DataTable.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual DataTable ToDataTable()

Возвращаемое значение

Объект типа DataTable

Заметки

Метод является виртуальным и может быть переопределен в конкретной реализации сущности. Таким образом приведение конкретной сущности может осуществляться не стандартным образом.

Смотри также

Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка ToDataTable
Пространство имен Bitrix.DataLayer


Метод ToDataTable (BXPagingOptions)

Метод BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::.ToDataTable (BXPagingOptions)
Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)> Смотри также Send Feedback
Приводит коллекцию к типу DataTable с применением опций постраничной навигации.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual DataTable ToDataTable(
    BXPagingOptions paging
)

Параметры

paging
Type: Bitrix.DataLayer..::..BXPagingOptions
Объект типа BXPagingOptions, содержащий опции постраничной навигации.

Возвращаемое значение

Объект типа DataTable

Заметки

Метод является виртуальным и может быть переопределен в конкретной реализации сущности. Таким образом приведение конкретной сущности может осуществляться не стандартным образом.

Смотри также

Класс BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
Перегрузка ToDataTable
Пространство имен Bitrix.DataLayer


Класс BXFilter

Класс BXFilter
Члены Смотри также Send Feedback
Определяет условия выборки списка сущностей. Содержит элементы вида "Поле схемы - Оператор - Значение".

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
[SerializableAttribute]
public class BXFilter : BXFilterBase

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXFilterBase
Bitrix.DataLayer..::..BXFilter

Смотри также

Члены BXFilter
Пространство имен Bitrix.DataLayer


Члены BXFilter

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXFilter
Класс BXFilter Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXFilter предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXFilter | Перегруженный.

Методы

Имя | Описание
Add | Добавляет к фильтру элемент (Унаследовано от BXFilterBase)
BuildCountSql | Возвращает строку запроса количества строк ( SELECT COUNT(*) ... ) формируемую фильтром (Унаследовано от BXFilterBase)
GetConditionString | (Унаследовано от BXFilterBase)
GetFilterExpressionCombiningLogic | (Переопределяет BXFilterBase..::..GetFilterExpressionCombiningLogic()()()())
GetFilterItems | Возвращает массив элементов фильтра (Унаследовано от BXFilterBase)
GetRawFilterString | Возвращает sql, созданный фильтром (Унаследовано от BXFilterBase)
Prepare | Подготовка внутренних параметров фильтра (Унаследовано от BXFilterBase)
SearchItem | Ищет в фильтре поле схемы сущности (Унаследовано от BXFilterBase)
SetCustomConditionBuilder | (Унаследовано от BXFilterBase)

Свойства

Имя | Описание
AboutOrderByOutput | (Унаследовано от BXFilterBase)
FilterKey | (Унаследовано от BXFilterBase)
FilterParameter | (Унаследовано от BXFilterBase)
FilterString | (Унаследовано от BXFilterBase)
FilterTables | (Унаследовано от BXFilterBase)
OrderBy | Получает или устанавливает объект-определение сортировки ( поле и направление ) (Унаследовано от BXFilterBase)
QueryParams | Получает или устанавливает объект-определение параметров запроса (Унаследовано от BXFilterBase)
RootScheme | Корневая схема Требуется при контейнеризации присоединяемых сущностей (Унаследовано от BXFilterBase)

Смотри также

Класс BXFilter
Пространство имен Bitrix.DataLayer


Конструктор BXFilter

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXFilter
Класс BXFilter Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXFilter()()()() |
BXFilter(BXFilterCollection) |
BXFilter(array<IBXFilterItem>[]()[][]) |
BXFilter(BXFormFilter, BXSchemeBase) |
BXFilter(IBXFilterItem, IBXFilterItem) |

Смотри также

Класс BXFilter
Члены BXFilter
Пространство имен Bitrix.DataLayer


Конструктор BXFilter

Конструктор BXFilter
Класс BXFilter Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFilter()

Смотри также

Класс BXFilter
Перегрузка BXFilter
Пространство имен Bitrix.DataLayer


Конструктор BXFilter ()

Конструктор BXFilter ()
Класс BXFilter Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFilter(
    BXFilterCollection filter
)

Параметры

filter
Type: BXFilterCollection

Смотри также

Класс BXFilter
Перегрузка BXFilter
Пространство имен Bitrix.DataLayer


Конструктор BXFilter ([])

Конструктор BXFilter (array<>[]()[][])
Класс BXFilter Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFilter(
    params IBXFilterItem[] items
)

Параметры

items
Type: array<IBXFilterItem>[]()[][]

Смотри также

Класс BXFilter
Перегрузка BXFilter
Пространство имен Bitrix.DataLayer


Конструктор BXFilter (, )

Конструктор BXFilter (, )
Класс BXFilter Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFilter(
    BXFormFilter filter,
    BXSchemeBase scheme
)

Параметры

filter
Type: BXFormFilter
scheme
Type: BXSchemeBase

Смотри также

Класс BXFilter
Перегрузка BXFilter
Пространство имен Bitrix.DataLayer


Конструктор BXFilter (, )

Конструктор BXFilter (, )
Класс BXFilter Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFilter(
    IBXFilterItem filterLeft,
    IBXFilterItem filterRight
)

Параметры

filterLeft
Type: IBXFilterItem
filterRight
Type: IBXFilterItem

Смотри также

Класс BXFilter
Перегрузка BXFilter
Пространство имен Bitrix.DataLayer


Методы BXFilter

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXFilter
Класс BXFilter Смотри также Send Feedback

Тип BXFilter предоставляет следующие возможности.

Методы

Имя | Описание
Add | Добавляет к фильтру элемент (Унаследовано от BXFilterBase)
BuildCountSql | Возвращает строку запроса количества строк ( SELECT COUNT(*) ... ) формируемую фильтром (Унаследовано от BXFilterBase)
GetConditionString | (Унаследовано от BXFilterBase)
GetFilterExpressionCombiningLogic | (Переопределяет BXFilterBase..::..GetFilterExpressionCombiningLogic()()()())
GetFilterItems | Возвращает массив элементов фильтра (Унаследовано от BXFilterBase)
GetRawFilterString | Возвращает sql, созданный фильтром (Унаследовано от BXFilterBase)
Prepare | Подготовка внутренних параметров фильтра (Унаследовано от BXFilterBase)
SearchItem | Ищет в фильтре поле схемы сущности (Унаследовано от BXFilterBase)
SetCustomConditionBuilder | (Унаследовано от BXFilterBase)

Смотри также

Класс BXFilter
Пространство имен Bitrix.DataLayer


Метод GetFilterExpressionCombiningLogic

Метод BXFilter..::.GetFilterExpressionCombiningLogic
Класс BXFilter Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override BXFilterExpressionCombiningLogic GetFilterExpressionCombiningLogic()

Смотри также

Класс BXFilter
Пространство имен Bitrix.DataLayer


Свойства BXFilter

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXFilter
Класс BXFilter Смотри также Send Feedback

Тип BXFilter предоставляет следующие возможности.

Свойства

Имя | Описание
AboutOrderByOutput | (Унаследовано от BXFilterBase)
FilterKey | (Унаследовано от BXFilterBase)
FilterParameter | (Унаследовано от BXFilterBase)
FilterString | (Унаследовано от BXFilterBase)
FilterTables | (Унаследовано от BXFilterBase)
OrderBy | Получает или устанавливает объект-определение сортировки ( поле и направление ) (Унаследовано от BXFilterBase)
QueryParams | Получает или устанавливает объект-определение параметров запроса (Унаследовано от BXFilterBase)
RootScheme | Корневая схема Требуется при контейнеризации присоединяемых сущностей (Унаследовано от BXFilterBase)

Смотри также

Класс BXFilter
Пространство имен Bitrix.DataLayer


Класс BXFilterBase

Класс BXFilterBase
Члены Смотри также Send Feedback
Базовый класс фильтра

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract class BXFilterBase : IBXFilter,
    IBXFilterItem

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXFilterBase
Bitrix.DataLayer..::..BXFilter

Смотри также

Члены BXFilterBase
Пространство имен Bitrix.DataLayer


Члены BXFilterBase

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXFilterBase
Класс BXFilterBase Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXFilterBase предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXFilterBase | Перегруженный.

Методы

Имя | Описание
Add | Добавляет к фильтру элемент
BuildCountSql | Возвращает строку запроса количества строк ( SELECT COUNT(*) ... ) формируемую фильтром
GetConditionString |
GetFilterExpressionCombiningLogic |
GetFilterItems | Возвращает массив элементов фильтра
GetRawFilterString | Возвращает sql, созданный фильтром
Prepare | Подготовка внутренних параметров фильтра
SearchItem | Ищет в фильтре поле схемы сущности
SetCustomConditionBuilder |

Свойства

Имя | Описание
AboutOrderByOutput |
FilterKey |
FilterParameter |
FilterString |
FilterTables |
OrderBy | Получает или устанавливает объект-определение сортировки ( поле и направление )
QueryParams | Получает или устанавливает объект-определение параметров запроса
RootScheme | Корневая схема Требуется при контейнеризации присоединяемых сущностей

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Конструктор BXFilterBase

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXFilterBase
Класс BXFilterBase Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXFilterBase()()()() |
BXFilterBase(BXFilterCollection) |
BXFilterBase(array<IBXFilterItem>[]()[][]) |
BXFilterBase(BXFormFilter, BXSchemeBase) |
BXFilterBase(IBXFilterItem, IBXFilterItem) |

Смотри также

Класс BXFilterBase
Члены BXFilterBase
Пространство имен Bitrix.DataLayer


Конструктор BXFilterBase

Конструктор BXFilterBase
Класс BXFilterBase Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFilterBase()

Смотри также

Класс BXFilterBase
Перегрузка BXFilterBase
Пространство имен Bitrix.DataLayer


Конструктор BXFilterBase ()

Конструктор BXFilterBase ()
Класс BXFilterBase Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFilterBase(
    BXFilterCollection filter
)

Параметры

filter
Type: BXFilterCollection

Смотри также

Класс BXFilterBase
Перегрузка BXFilterBase
Пространство имен Bitrix.DataLayer


Конструктор BXFilterBase ([])

Конструктор BXFilterBase (array<>[]()[][])
Класс BXFilterBase Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFilterBase(
    params IBXFilterItem[] items
)

Параметры

items
Type: array<IBXFilterItem>[]()[][]

Смотри также

Класс BXFilterBase
Перегрузка BXFilterBase
Пространство имен Bitrix.DataLayer


Конструктор BXFilterBase (, )

Конструктор BXFilterBase (, )
Класс BXFilterBase Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFilterBase(
    BXFormFilter filter,
    BXSchemeBase scheme
)

Параметры

filter
Type: BXFormFilter
scheme
Type: BXSchemeBase

Смотри также

Класс BXFilterBase
Перегрузка BXFilterBase
Пространство имен Bitrix.DataLayer


Конструктор BXFilterBase (, )

Конструктор BXFilterBase (, )
Класс BXFilterBase Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFilterBase(
    IBXFilterItem filterLeft,
    IBXFilterItem filterRight
)

Параметры

filterLeft
Type: IBXFilterItem
filterRight
Type: IBXFilterItem

Смотри также

Класс BXFilterBase
Перегрузка BXFilterBase
Пространство имен Bitrix.DataLayer


Методы BXFilterBase

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXFilterBase
Класс BXFilterBase Смотри также Send Feedback

Тип BXFilterBase предоставляет следующие возможности.

Методы

Имя | Описание
Add | Добавляет к фильтру элемент
BuildCountSql | Возвращает строку запроса количества строк ( SELECT COUNT(*) ... ) формируемую фильтром
GetConditionString |
GetFilterExpressionCombiningLogic |
GetFilterItems | Возвращает массив элементов фильтра
GetRawFilterString | Возвращает sql, созданный фильтром
Prepare | Подготовка внутренних параметров фильтра
SearchItem | Ищет в фильтре поле схемы сущности
SetCustomConditionBuilder |

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Метод Add

Метод BXFilterBase..::.Add
Класс BXFilterBase Смотри также Send Feedback
Добавляет к фильтру элемент

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void Add(
    IBXFilterItem f
)

Параметры

f
Type: IBXFilterItem
Добавляемый элемент

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Метод BuildCountSql

Метод BXFilterBase..::.BuildCountSql
Класс BXFilterBase Смотри также Send Feedback
Возвращает строку запроса количества строк ( SELECT COUNT(*) ... ) формируемую фильтром

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string BuildCountSql()

Возвращаемое значение

Строка с sql-кодом

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Метод GetConditionString

Метод BXFilterBase..::.GetConditionString
Класс BXFilterBase Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual string GetConditionString()

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Метод GetFilterExpressionCombiningLogic

Метод BXFilterBase..::.GetFilterExpressionCombiningLogic
Класс BXFilterBase Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract BXFilterExpressionCombiningLogic GetFilterExpressionCombiningLogic()

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Метод GetFilterItems

Метод BXFilterBase..::.GetFilterItems
Класс BXFilterBase Смотри также Send Feedback
Возвращает массив элементов фильтра

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public IBXFilterItem[] GetFilterItems()

Возвращаемое значение

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Метод GetRawFilterString

Метод BXFilterBase..::.GetRawFilterString
Класс BXFilterBase Смотри также Send Feedback
Возвращает sql, созданный фильтром

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string GetRawFilterString()

Возвращаемое значение

Строка с sql-кодом

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Метод Prepare

Метод BXFilterBase..::.Prepare
Класс BXFilterBase Смотри также Send Feedback
Подготовка внутренних параметров фильтра

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void Prepare()

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Метод SearchItem

Метод BXFilterBase..::.SearchItem
Класс BXFilterBase Смотри также Send Feedback
Ищет в фильтре поле схемы сущности

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Nullable<KeyValuePair<BXSqlFilterOperators, Object>> SearchItem(
    BXSchemeFieldBase field
)

Параметры

field
Type: BXSchemeFieldBase
Поле схемы сущности дял поиска

Возвращаемое значение

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Метод SetCustomConditionBuilder

Метод BXFilterBase..::.SetCustomConditionBuilder
Класс BXFilterBase Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void SetCustomConditionBuilder(
    BXFilterCustomConditionBuilder builder
)

Параметры

builder
Type: BXFilterCustomConditionBuilder

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Свойства BXFilterBase

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXFilterBase
Класс BXFilterBase Смотри также Send Feedback

Тип BXFilterBase предоставляет следующие возможности.

Свойства

Имя | Описание
AboutOrderByOutput |
FilterKey |
FilterParameter |
FilterString |
FilterTables |
OrderBy | Получает или устанавливает объект-определение сортировки ( поле и направление )
QueryParams | Получает или устанавливает объект-определение параметров запроса
RootScheme | Корневая схема Требуется при контейнеризации присоединяемых сущностей

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Свойство AboutOrderByOutput

Свойство BXFilterBase..::.AboutOrderByOutput
Класс BXFilterBase Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool AboutOrderByOutput { get; }

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Свойство FilterKey

Свойство BXFilterBase..::.FilterKey
Класс BXFilterBase Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string FilterKey { get; }

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Свойство FilterParameter

Свойство BXFilterBase..::.FilterParameter
Класс BXFilterBase Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public SqlParameter[] FilterParameter { get; }

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Свойство FilterString

Свойство BXFilterBase..::.FilterString
Класс BXFilterBase Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Dictionary<string, string> FilterString { get; }

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Свойство FilterTables

Свойство BXFilterBase..::.FilterTables
Класс BXFilterBase Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Dictionary<string, List<BXFrom>> FilterTables { get; }

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Свойство OrderBy

Свойство BXFilterBase..::.OrderBy
Класс BXFilterBase Смотри также Send Feedback
Получает или устанавливает объект-определение сортировки ( поле и направление )

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXOrderBy OrderBy { get; set; }

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Свойство QueryParams

Свойство BXFilterBase..::.QueryParams
Класс BXFilterBase Смотри также Send Feedback
Получает или устанавливает объект-определение параметров запроса

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXQueryParams QueryParams { get; set; }

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Свойство RootScheme

Свойство BXFilterBase..::.RootScheme
Класс BXFilterBase Смотри также Send Feedback
Корневая схема Требуется при контейнеризации присоединяемых сущностей

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeBase RootScheme { get; set; }

Смотри также

Класс BXFilterBase
Пространство имен Bitrix.DataLayer


Класс BXFilterItem

Класс BXFilterItem
Члены Смотри также Send Feedback
Элемент фильтра. Определяет одно из его условий вида {имя поля таблицы}={значение}.

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
[SerializableAttribute]
public class BXFilterItem : IBXFilterItem

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXFilterItem

Смотри также

Члены BXFilterItem
Пространство имен Bitrix.DataLayer


Члены BXFilterItem

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXFilterItem
Класс BXFilterItem Конструкторы Методы Поля Свойства Смотри также Send Feedback

Тип BXFilterItem предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXFilterItem |

Методы

Имя | Описание
BuildCustomString | Перегруженный.
GetRawFilterString |
SearchItem |

Поля

Имя | Описание
filterField |
filterOperator |
filterValue |

Свойства

Имя | Описание
FilterKey |
FilterParameter |
FilterString |
FilterTables |

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Конструктор BXFilterItem

Конструктор BXFilterItem
Класс BXFilterItem Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFilterItem(
    BXSchemeFieldBase filterField,
    BXSqlFilterOperators filterOperator,
    Object filterValue
)

Параметры

filterField
Type: BXSchemeFieldBase
filterOperator
Type: BXSqlFilterOperators
filterValue
Type: System..::..Object

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Поля BXFilterItem

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXFilterItem
Класс BXFilterItem Смотри также Send Feedback

Тип BXFilterItem предоставляет следующие возможности.

Поля

Имя | Описание
filterField |
filterOperator |
filterValue |

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Поле filterField

Поле BXFilterItem..::.filterField
Класс BXFilterItem Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase filterField

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Поле filterOperator

Поле BXFilterItem..::.filterOperator
Класс BXFilterItem Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSqlFilterOperators filterOperator

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Поле filterValue

Поле BXFilterItem..::.filterValue
Класс BXFilterItem Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Object filterValue

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Методы BXFilterItem

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXFilterItem
Класс BXFilterItem Смотри также Send Feedback

Тип BXFilterItem предоставляет следующие возможности.

Методы

Имя | Описание
BuildCustomString | Перегруженный.
GetRawFilterString |
SearchItem |

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Метод BuildCustomString

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFilterItem..::.BuildCustomString
Класс BXFilterItem Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BuildCustomString(String, SqlDbType, BXSqlFilterOperators, Object, String, ICollection<(Of <<'(SqlParameter>)>>)) |
BuildCustomString(String, SqlDbType, Boolean, BXSqlFilterOperators, Object, String, ICollection<(Of <<'(SqlParameter>)>>)) |
BuildCustomString(String, SqlDbType, Boolean, Boolean, BXSqlFilterOperators, Object, String, ICollection<(Of <<'(SqlParameter>)>>)) |

Смотри также

Класс BXFilterItem
Члены BXFilterItem
Пространство имен Bitrix.DataLayer


Метод BuildCustomString (String, SqlDbType, , Object, String, ICollection(SqlParameter))

Метод BXFilterItem..::.BuildCustomString (String, SqlDbType, , Object, String, ICollection<(Of <(<'SqlParameter>)>)>)
Класс BXFilterItem Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string BuildCustomString(
    string customSql,
    SqlDbType type,
    BXSqlFilterOperators op,
    Object value,
    string paramPrefix,
    ICollection<SqlParameter> paramStorage
)

Параметры

customSql
Type: System..::..String
type
Type: System.Data..::..SqlDbType
op
Type: BXSqlFilterOperators
value
Type: System..::..Object
paramPrefix
Type: System..::..String
paramStorage
Type: System.Collections.Generic..::..ICollection <(Of <(<' SqlParameter >)>)>

Смотри также

Класс BXFilterItem
Перегрузка BuildCustomString
Пространство имен Bitrix.DataLayer


Метод BuildCustomString (String, SqlDbType, Boolean, , Object, String, ICollection(SqlParameter))

Метод BXFilterItem..::.BuildCustomString (String, SqlDbType, Boolean, , Object, String, ICollection<(Of <(<'SqlParameter>)>)>)
Класс BXFilterItem Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string BuildCustomString(
    string customSql,
    SqlDbType type,
    bool isNullable,
    BXSqlFilterOperators op,
    Object value,
    string paramPrefix,
    ICollection<SqlParameter> paramStorage
)

Параметры

customSql
Type: System..::..String
type
Type: System.Data..::..SqlDbType
isNullable
Type: System..::..Boolean
op
Type: BXSqlFilterOperators
value
Type: System..::..Object
paramPrefix
Type: System..::..String
paramStorage
Type: System.Collections.Generic..::..ICollection <(Of <(<' SqlParameter >)>)>

Смотри также

Класс BXFilterItem
Перегрузка BuildCustomString
Пространство имен Bitrix.DataLayer


Метод BuildCustomString (String, SqlDbType, Boolean, Boolean, , Object, String, ICollection(SqlParameter))

Метод BXFilterItem..::.BuildCustomString (String, SqlDbType, Boolean, Boolean, , Object, String, ICollection<(Of <(<'SqlParameter>)>)>)
Класс BXFilterItem Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string BuildCustomString(
    string customSql,
    SqlDbType type,
    bool isNullable,
    bool ignoreNullValues,
    BXSqlFilterOperators op,
    Object value,
    string paramPrefix,
    ICollection<SqlParameter> paramStorage
)

Параметры

customSql
Type: System..::..String
type
Type: System.Data..::..SqlDbType
isNullable
Type: System..::..Boolean
ignoreNullValues
Type: System..::..Boolean
op
Type: BXSqlFilterOperators
value
Type: System..::..Object
paramPrefix
Type: System..::..String
paramStorage
Type: System.Collections.Generic..::..ICollection <(Of <(<' SqlParameter >)>)>

Смотри также

Класс BXFilterItem
Перегрузка BuildCustomString
Пространство имен Bitrix.DataLayer


Метод GetRawFilterString

Метод BXFilterItem..::.GetRawFilterString
Класс BXFilterItem Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string GetRawFilterString()

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Метод SearchItem

Метод BXFilterItem..::.SearchItem
Класс BXFilterItem Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Nullable<KeyValuePair<BXSqlFilterOperators, Object>> SearchItem(
    BXSchemeFieldBase field
)

Параметры

field
Type: BXSchemeFieldBase

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Свойства BXFilterItem

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXFilterItem
Класс BXFilterItem Смотри также Send Feedback

Тип BXFilterItem предоставляет следующие возможности.

Свойства

Имя | Описание
FilterKey |
FilterParameter |
FilterString |
FilterTables |

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Свойство FilterKey

Свойство BXFilterItem..::.FilterKey
Класс BXFilterItem Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string FilterKey { get; }

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Свойство FilterParameter

Свойство BXFilterItem..::.FilterParameter
Класс BXFilterItem Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public SqlParameter[] FilterParameter { get; }

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Свойство FilterString

Свойство BXFilterItem..::.FilterString
Класс BXFilterItem Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Dictionary<string, string> FilterString { get; }

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Свойство FilterTables

Свойство BXFilterItem..::.FilterTables
Класс BXFilterItem Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Dictionary<string, List<BXFrom>> FilterTables { get; }

Смотри также

Класс BXFilterItem
Пространство имен Bitrix.DataLayer


Класс BXOrderBy

Класс BXOrderBy
Члены Смотри также Send Feedback
Служит для формирования "ORDER BY" строки sql запроса

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXOrderBy : Dictionary<BXSchemeFieldBase, BXOrderByDirection>

Иерархия наследования

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<'BXSchemeFieldBase, BXOrderByDirection >)>)>
Bitrix.DataLayer..::..BXOrderBy

Смотри также

Члены BXOrderBy
Пространство имен Bitrix.DataLayer


Члены BXOrderBy

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXOrderBy
Класс BXOrderBy Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXOrderBy предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXOrderBy | Перегруженный.

Методы

Имя | Описание
Add | Перегруженный.
ContainsKey | Определяет, содержит ли объект данное поле таблицы

Свойства

Имя | Описание
OrderByString | Возвращает строку sql, формируемую экземпляром

Смотри также

Класс BXOrderBy
Пространство имен Bitrix.DataLayer


Конструктор BXOrderBy

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXOrderBy
Класс BXOrderBy Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXOrderBy(array<BXOrderByPair>[]()[][]) |
BXOrderBy(BXSchemeBase, String) |

Смотри также

Класс BXOrderBy
Члены BXOrderBy
Пространство имен Bitrix.DataLayer


Конструктор BXOrderBy (BXOrderByPair[])

Конструктор BXOrderBy (array<BXOrderByPair>[]()[][])
Класс BXOrderBy Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXOrderBy(
    params BXOrderByPair[] items
)

Параметры

items
Type: array< Bitrix.DataLayer..::..BXOrderByPair >[]()[][]

Смотри также

Класс BXOrderBy
Перегрузка BXOrderBy
Пространство имен Bitrix.DataLayer


Конструктор BXOrderBy (, String)

Конструктор BXOrderBy (, String)
Класс BXOrderBy Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXOrderBy(
    BXSchemeBase scheme,
    string sortExpression
)

Параметры

scheme
Type: BXSchemeBase
sortExpression
Type: System..::..String

Смотри также

Класс BXOrderBy
Перегрузка BXOrderBy
Пространство имен Bitrix.DataLayer


Методы BXOrderBy

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXOrderBy
Класс BXOrderBy Смотри также Send Feedback

Тип BXOrderBy предоставляет следующие возможности.

Методы

Имя | Описание
Add | Перегруженный.
ContainsKey | Определяет, содержит ли объект данное поле таблицы

Смотри также

Класс BXOrderBy
Пространство имен Bitrix.DataLayer


Метод Add

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXOrderBy..::.Add
Класс BXOrderBy Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Add(BXSchemeBase, String) | Добавляет параметр сортировки
Add(BXSchemeFieldBase, String) | Добавляет параметр сортировки
Add(BXSchemeBase, String, String) | Добавляет параметр сортировки

Смотри также

Класс BXOrderBy
Члены BXOrderBy
Пространство имен Bitrix.DataLayer


Метод Add (, String)

Метод BXOrderBy..::.Add (, String)
Класс BXOrderBy Пример Смотри также Send Feedback
Добавляет параметр сортировки

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void Add(
    BXSchemeBase scheme,
    string sortExpression
)

Параметры

scheme
Type: BXSchemeBase
схема сущности
sortExpression
Type: System..::..String
строка сотировки

Примеры

CopyC#
orderBy.Add(BXBlog.Fields,"ID DESC");

Смотри также

Класс BXOrderBy
Перегрузка Add
Пространство имен Bitrix.DataLayer


Метод Add (, String)

Метод BXOrderBy..::.Add (, String)
Класс BXOrderBy Пример Смотри также Send Feedback
Добавляет параметр сортировки

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void Add(
    BXSchemeFieldBase field,
    string sortOrder
)

Параметры

field
Type: BXSchemeFieldBase
sortOrder
Type: System..::..String
порядок сортировки

Примеры

CopyC#
orderBy.Add(BXBlog.Fields.ID, "DESC");

Смотри также

Класс BXOrderBy
Перегрузка Add
Пространство имен Bitrix.DataLayer


Метод Add (, String, String)

Метод BXOrderBy..::.Add (, String, String)
Класс BXOrderBy Пример Смотри также Send Feedback
Добавляет параметр сортировки

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void Add(
    BXSchemeBase scheme,
    string sortField,
    string sortOrder
)

Параметры

scheme
Type: BXSchemeBase
схема сущности
sortField
Type: System..::..String
поле схемы
sortOrder
Type: System..::..String
порядок сортировки

Примеры

CopyC#
orderBy.Add(BXBlog.Fields, "ID", "DESC");

Смотри также

Класс BXOrderBy
Перегрузка Add
Пространство имен Bitrix.DataLayer


Метод ContainsKey

Метод BXOrderBy..::.ContainsKey
Класс BXOrderBy Смотри также Send Feedback
Определяет, содержит ли объект данное поле таблицы

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool ContainsKey(
    BXTableField key
)

Параметры

key
Type: BXTableField

Возвращаемое значение

Смотри также

Класс BXOrderBy
Пространство имен Bitrix.DataLayer


Свойства BXOrderBy

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXOrderBy
Класс BXOrderBy Смотри также Send Feedback

Тип BXOrderBy предоставляет следующие возможности.

Свойства

Имя | Описание
OrderByString | Возвращает строку sql, формируемую экземпляром

Смотри также

Класс BXOrderBy
Пространство имен Bitrix.DataLayer


Свойство OrderByString

Свойство BXOrderBy..::.OrderByString
Класс BXOrderBy Смотри также Send Feedback
Возвращает строку sql, формируемую экземпляром

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string OrderByString { get; }

Смотри также

Класс BXOrderBy
Пространство имен Bitrix.DataLayer


Перечисление BXOrderByDirection

Перечисление BXOrderByDirection
Смотри также Send Feedback
Направление сортировки

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public enum BXOrderByDirection

Члены

Название члена | Описание
Asc | По возрастанию
Desc | По убыванию

Смотри также

Пространство имен Bitrix.DataLayer


Класс BXOrderByPair

Класс BXOrderByPair
Члены Смотри также Send Feedback
Класс - хранилище. Содержит информации о поле и направлении сортировки

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXOrderByPair

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXOrderByPair

Смотри также

Члены BXOrderByPair
Пространство имен Bitrix.DataLayer


Члены BXOrderByPair

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXOrderByPair
Класс BXOrderByPair Конструкторы Свойства Смотри также Send Feedback

Тип BXOrderByPair предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXOrderByPair |

Свойства

Имя | Описание
Direction | Направление сортировки
Field | Поле сортировки

Смотри также

Класс BXOrderByPair
Пространство имен Bitrix.DataLayer


Конструктор BXOrderByPair

Конструктор BXOrderByPair
Класс BXOrderByPair Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXOrderByPair(
    BXSchemeFieldBase field,
    BXOrderByDirection direction
)

Параметры

field
Type: BXSchemeFieldBase
direction
Type: Bitrix.DataLayer..::..BXOrderByDirection

Смотри также

Класс BXOrderByPair
Пространство имен Bitrix.DataLayer


Свойства BXOrderByPair

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXOrderByPair
Класс BXOrderByPair Смотри также Send Feedback

Тип BXOrderByPair предоставляет следующие возможности.

Свойства

Имя | Описание
Direction | Направление сортировки
Field | Поле сортировки

Смотри также

Класс BXOrderByPair
Пространство имен Bitrix.DataLayer


Свойство Direction

Свойство BXOrderByPair..::.Direction
Класс BXOrderByPair Смотри также Send Feedback
Направление сортировки

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXOrderByDirection Direction { get; }

Смотри также

Класс BXOrderByPair
Пространство имен Bitrix.DataLayer


Свойство Field

Свойство BXOrderByPair..::.Field
Класс BXOrderByPair Смотри также Send Feedback
Поле сортировки

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Field { get; }

Смотри также

Класс BXOrderByPair
Пространство имен Bitrix.DataLayer


Класс BXPagingOptions

Класс BXPagingOptions
Члены Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXPagingOptions

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXPagingOptions

Смотри также

Члены BXPagingOptions
Пространство имен Bitrix.DataLayer


Члены BXPagingOptions

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXPagingOptions
Класс BXPagingOptions Конструкторы Поля Смотри также Send Feedback

Тип BXPagingOptions предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXPagingOptions |

Поля

Имя | Описание
maximumRows |
startRowIndex |

Смотри также

Класс BXPagingOptions
Пространство имен Bitrix.DataLayer


Конструктор BXPagingOptions

Конструктор BXPagingOptions
Класс BXPagingOptions Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXPagingOptions(
    int startRowIndex,
    int maximumRows
)

Параметры

startRowIndex
Type: System..::..Int32
maximumRows
Type: System..::..Int32

Смотри также

Класс BXPagingOptions
Пространство имен Bitrix.DataLayer


Поля BXPagingOptions

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXPagingOptions
Класс BXPagingOptions Смотри также Send Feedback

Тип BXPagingOptions предоставляет следующие возможности.

Поля

Имя | Описание
maximumRows |
startRowIndex |

Смотри также

Класс BXPagingOptions
Пространство имен Bitrix.DataLayer


Поле maximumRows

Поле BXPagingOptions..::.maximumRows
Класс BXPagingOptions Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int maximumRows

Смотри также

Класс BXPagingOptions
Пространство имен Bitrix.DataLayer


Поле startRowIndex

Поле BXPagingOptions..::.startRowIndex
Класс BXPagingOptions Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int startRowIndex

Смотри также

Класс BXPagingOptions
Пространство имен Bitrix.DataLayer


Класс BXQueryParams

Класс BXQueryParams
Члены Смотри также Send Feedback
Параметры запроса. Определяет количество записей для выборки и индекс ( номер ) первого элемента в выборке

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXQueryParams

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXQueryParams

Смотри также

Члены BXQueryParams
Пространство имен Bitrix.DataLayer


Члены BXQueryParams

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXQueryParams
Класс BXQueryParams Конструкторы Поля Свойства Смотри также Send Feedback

Тип BXQueryParams предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXQueryParams | Перегруженный.

Поля

Имя | Описание
AllowPaging | Разрешить постраничное отображение
PagingRecordCount | Количество элементов на странице
PagingStartIndex | Индекс первого выбираемого элемента
Transaction | Транзакция в которой должен быть выполнен запрос

Свойства

Имя | Описание
PagingType | Тип запроса постраничной навигации

Смотри также

Класс BXQueryParams
Пространство имен Bitrix.DataLayer


Конструктор BXQueryParams

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXQueryParams
Класс BXQueryParams Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXQueryParams()()()() |
BXQueryParams(BXPagingOptions) |
BXQueryParams(BXPagingOptions, String) |

Смотри также

Класс BXQueryParams
Члены BXQueryParams
Пространство имен Bitrix.DataLayer


Конструктор BXQueryParams

Конструктор BXQueryParams
Класс BXQueryParams Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXQueryParams()

Смотри также

Класс BXQueryParams
Перегрузка BXQueryParams
Пространство имен Bitrix.DataLayer


Конструктор BXQueryParams (BXPagingOptions)

Конструктор BXQueryParams (BXPagingOptions)
Класс BXQueryParams Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXQueryParams(
    BXPagingOptions pagingOptions
)

Параметры

pagingOptions
Type: Bitrix.DataLayer..::..BXPagingOptions

Смотри также

Класс BXQueryParams
Перегрузка BXQueryParams
Пространство имен Bitrix.DataLayer


Конструктор BXQueryParams (BXPagingOptions, String)

Конструктор BXQueryParams (BXPagingOptions, String)
Класс BXQueryParams Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXQueryParams(
    BXPagingOptions pagingOptions,
    string tableModifiers
)

Параметры

pagingOptions
Type: Bitrix.DataLayer..::..BXPagingOptions
tableModifiers
Type: System..::..String

Смотри также

Класс BXQueryParams
Перегрузка BXQueryParams
Пространство имен Bitrix.DataLayer


Поля BXQueryParams

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXQueryParams
Класс BXQueryParams Смотри также Send Feedback

Тип BXQueryParams предоставляет следующие возможности.

Поля

Имя | Описание
AllowPaging | Разрешить постраничное отображение
PagingRecordCount | Количество элементов на странице
PagingStartIndex | Индекс первого выбираемого элемента
Transaction | Транзакция в которой должен быть выполнен запрос

Смотри также

Класс BXQueryParams
Пространство имен Bitrix.DataLayer


Поле AllowPaging

Поле BXQueryParams..::.AllowPaging
Класс BXQueryParams Смотри также Send Feedback
Разрешить постраничное отображение

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool AllowPaging

Смотри также

Класс BXQueryParams
Пространство имен Bitrix.DataLayer


Поле PagingRecordCount

Поле BXQueryParams..::.PagingRecordCount
Класс BXQueryParams Смотри также Send Feedback
Количество элементов на странице

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int PagingRecordCount

Смотри также

Класс BXQueryParams
Пространство имен Bitrix.DataLayer


Поле PagingStartIndex

Поле BXQueryParams..::.PagingStartIndex
Класс BXQueryParams Смотри также Send Feedback
Индекс первого выбираемого элемента

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int PagingStartIndex

Смотри также

Класс BXQueryParams
Пространство имен Bitrix.DataLayer


Поле Transaction

Поле BXQueryParams..::.Transaction
Класс BXQueryParams Смотри также Send Feedback
Транзакция в которой должен быть выполнен запрос

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSqlTransaction Transaction

Смотри также

Класс BXQueryParams
Пространство имен Bitrix.DataLayer


Свойства BXQueryParams

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXQueryParams
Класс BXQueryParams Смотри также Send Feedback

Тип BXQueryParams предоставляет следующие возможности.

Свойства

Имя | Описание
PagingType | Тип запроса постраничной навигации

Смотри также

Класс BXQueryParams
Пространство имен Bitrix.DataLayer


Свойство PagingType

Свойство BXQueryParams..::.PagingType
Класс BXQueryParams Смотри также Send Feedback
Тип запроса постраничной навигации

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXPagingType PagingType { get; set; }

Смотри также

Класс BXQueryParams
Пространство имен Bitrix.DataLayer


Класс BXSelect

Класс BXSelect
Члены Смотри также Send Feedback
Выборка

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXSelect : List<Object>

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Object >)>)>
Bitrix.DataLayer..::..BXSelect
Bitrix.DataLayer..::..BXSelectAdd

Смотри также

Члены BXSelect
Пространство имен Bitrix.DataLayer


Члены BXSelect

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXSelect
Класс BXSelect Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXSelect предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXSelect | Перегруженный.

Методы

Имя | Описание
AboutFieldContainerization |
Prepare | Подготовить поля
SetCustomBuilder | Установить "заказной" построитель

Свойства

Имя | Описание
EnableMultipleJoinedEntityFieldsContainerization | Включить контейнеризацию для множественных присоединяемых сущностей
FieldPreparationMode | Запрос режима подготовки полей для выборки
RootScheme | Корневая схема Требуется при контейнеризации присоединяемых сущностей
SelectString |
ValueMap |

Смотри также

Класс BXSelect
Пространство имен Bitrix.DataLayer


Конструктор BXSelect

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXSelect
Класс BXSelect Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXSelect()()()() |
BXSelect(array<BXSchemeFieldBase>[]()[][]) |
BXSelect(BXSelectFieldPreparationMode) |
BXSelect(array<Object>[]()[][]) |
BXSelect(BXSelectFieldPreparationMode, array<BXSchemeFieldBase>[]()[][]) |
BXSelect(BXSelectFieldPreparationMode, array<Object>[]()[][]) |

Смотри также

Класс BXSelect
Члены BXSelect
Пространство имен Bitrix.DataLayer


Конструктор BXSelect

Конструктор BXSelect
Класс BXSelect Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSelect()

Смотри также

Класс BXSelect
Перегрузка BXSelect
Пространство имен Bitrix.DataLayer


Конструктор BXSelect ([])

Конструктор BXSelect (array<>[]()[][])
Класс BXSelect Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSelect(
    params BXSchemeFieldBase[] items
)

Параметры

items
Type: array<BXSchemeFieldBase>[]()[][]

Смотри также

Класс BXSelect
Перегрузка BXSelect
Пространство имен Bitrix.DataLayer


Конструктор BXSelect ()

Конструктор BXSelect ()
Класс BXSelect Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSelect(
    BXSelectFieldPreparationMode fieldPreparationMode
)

Параметры

fieldPreparationMode
Type: BXSelectFieldPreparationMode

Смотри также

Класс BXSelect
Перегрузка BXSelect
Пространство имен Bitrix.DataLayer


Конструктор BXSelect (Object[])

Конструктор BXSelect (array<Object>[]()[][])
Класс BXSelect Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSelect(
    params Object[] items
)

Параметры

items
Type: array< System..::..Object >[]()[][]

Смотри также

Класс BXSelect
Перегрузка BXSelect
Пространство имен Bitrix.DataLayer


Конструктор BXSelect (, [])

Конструктор BXSelect (, array<>[]()[][])
Класс BXSelect Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSelect(
    BXSelectFieldPreparationMode fieldPreparationMode,
    params BXSchemeFieldBase[] items
)

Параметры

fieldPreparationMode
Type: BXSelectFieldPreparationMode
items
Type: array<BXSchemeFieldBase>[]()[][]

Смотри также

Класс BXSelect
Перегрузка BXSelect
Пространство имен Bitrix.DataLayer


Конструктор BXSelect (, Object[])

Конструктор BXSelect (, array<Object>[]()[][])
Класс BXSelect Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSelect(
    BXSelectFieldPreparationMode fieldPreparationMode,
    params Object[] items
)

Параметры

fieldPreparationMode
Type: BXSelectFieldPreparationMode
items
Type: array< System..::..Object >[]()[][]

Смотри также

Класс BXSelect
Перегрузка BXSelect
Пространство имен Bitrix.DataLayer


Методы BXSelect

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXSelect
Класс BXSelect Смотри также Send Feedback

Тип BXSelect предоставляет следующие возможности.

Методы

Имя | Описание
AboutFieldContainerization |
Prepare | Подготовить поля
SetCustomBuilder | Установить "заказной" построитель

Смотри также

Класс BXSelect
Пространство имен Bitrix.DataLayer


Метод AboutFieldContainerization

Метод BXSelect..::.AboutFieldContainerization
Класс BXSelect Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected bool AboutFieldContainerization(
    BXSchemeFieldBase field
)

Параметры

field
Type: BXSchemeFieldBase

Смотри также

Класс BXSelect
Пространство имен Bitrix.DataLayer


Метод Prepare

Метод BXSelect..::.Prepare
Класс BXSelect Смотри также Send Feedback
Подготовить поля

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected void Prepare()

Смотри также

Класс BXSelect
Пространство имен Bitrix.DataLayer


Метод SetCustomBuilder

Метод BXSelect..::.SetCustomBuilder
Класс BXSelect Смотри также Send Feedback
Установить "заказной" построитель

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void SetCustomBuilder(
    BXSelectCustomBuilder customBuilder
)

Параметры

customBuilder
Type: BXSelectCustomBuilder

Смотри также

Класс BXSelect
Пространство имен Bitrix.DataLayer


Свойства BXSelect

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXSelect
Класс BXSelect Смотри также Send Feedback

Тип BXSelect предоставляет следующие возможности.

Свойства

Имя | Описание
EnableMultipleJoinedEntityFieldsContainerization | Включить контейнеризацию для множественных присоединяемых сущностей
FieldPreparationMode | Запрос режима подготовки полей для выборки
RootScheme | Корневая схема Требуется при контейнеризации присоединяемых сущностей
SelectString |
ValueMap |

Смотри также

Класс BXSelect
Пространство имен Bitrix.DataLayer


Свойство EnableMultipleJoinedEntityFieldsContainerization

Свойство BXSelect..::.EnableMultipleJoinedEntityFieldsContainerization
Класс BXSelect Смотри также Send Feedback
Включить контейнеризацию для множественных присоединяемых сущностей

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool EnableMultipleJoinedEntityFieldsContainerization { get; set; }

Смотри также

Класс BXSelect
Пространство имен Bitrix.DataLayer


Свойство FieldPreparationMode

Свойство BXSelect..::.FieldPreparationMode
Класс BXSelect Смотри также Send Feedback
Запрос режима подготовки полей для выборки

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSelectFieldPreparationMode FieldPreparationMode { get; }

Смотри также

Класс BXSelect
Пространство имен Bitrix.DataLayer


Свойство RootScheme

Свойство BXSelect..::.RootScheme
Класс BXSelect Смотри также Send Feedback
Корневая схема Требуется при контейнеризации присоединяемых сущностей

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeBase RootScheme { get; set; }

Смотри также

Класс BXSelect
Пространство имен Bitrix.DataLayer


Свойство SelectString

Свойство BXSelect..::.SelectString
Класс BXSelect Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string SelectString { get; }

Смотри также

Класс BXSelect
Пространство имен Bitrix.DataLayer


Свойство ValueMap

Свойство BXSelect..::.ValueMap
Класс BXSelect Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public IBXEntityValueMap ValueMap { get; }

Смотри также

Класс BXSelect
Пространство имен Bitrix.DataLayer


Класс BXSelectAdd

Класс BXSelectAdd
Члены Смотри также Send Feedback
BXSelect в режиме Add()()()()

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXSelectAdd : BXSelect

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Object >)>)>
Bitrix.DataLayer..::..BXSelect
Bitrix.DataLayer..::..BXSelectAdd

Смотри также

Члены BXSelectAdd
Пространство имен Bitrix.DataLayer


Члены BXSelectAdd

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXSelectAdd
Класс BXSelectAdd Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXSelectAdd предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXSelectAdd | Перегруженный.

Методы

Имя | Описание
AboutFieldContainerization | (Унаследовано от BXSelect)
Prepare | Подготовить поля (Унаследовано от BXSelect)
SetCustomBuilder | Установить "заказной" построитель (Унаследовано от BXSelect)

Свойства

Имя | Описание
EnableMultipleJoinedEntityFieldsContainerization | Включить контейнеризацию для множественных присоединяемых сущностей (Унаследовано от BXSelect)
FieldPreparationMode | Запрос режима подготовки полей для выборки (Унаследовано от BXSelect)
RootScheme | Корневая схема Требуется при контейнеризации присоединяемых сущностей (Унаследовано от BXSelect)
SelectString | (Унаследовано от BXSelect)
ValueMap | (Унаследовано от BXSelect)

Смотри также

Класс BXSelectAdd
Пространство имен Bitrix.DataLayer


Конструктор BXSelectAdd

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXSelectAdd
Класс BXSelectAdd Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXSelectAdd()()()() |
BXSelectAdd(array<BXSchemeFieldBase>[]()[][]) |
BXSelectAdd(array<Object>[]()[][]) |

Смотри также

Класс BXSelectAdd
Члены BXSelectAdd
Пространство имен Bitrix.DataLayer


Конструктор BXSelectAdd

Конструктор BXSelectAdd
Класс BXSelectAdd Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSelectAdd()

Смотри также

Класс BXSelectAdd
Перегрузка BXSelectAdd
Пространство имен Bitrix.DataLayer


Конструктор BXSelectAdd ([])

Конструктор BXSelectAdd (array<>[]()[][])
Класс BXSelectAdd Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSelectAdd(
    params BXSchemeFieldBase[] items
)

Параметры

items
Type: array<BXSchemeFieldBase>[]()[][]

Смотри также

Класс BXSelectAdd
Перегрузка BXSelectAdd
Пространство имен Bitrix.DataLayer


Конструктор BXSelectAdd (Object[])

Конструктор BXSelectAdd (array<Object>[]()[][])
Класс BXSelectAdd Смотри также Send Feedback

Пространство имен: Bitrix.DataLayer
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSelectAdd(
    params Object[] items
)

Параметры

items
Type: array< System..::..Object >[]()[][]

Смотри также

Класс BXSelectAdd
Перегрузка BXSelectAdd
Пространство имен Bitrix.DataLayer


Методы BXSelectAdd

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXSelectAdd
Класс BXSelectAdd Смотри также Send Feedback

Тип BXSelectAdd предоставляет следующие возможности.

Методы

Имя | Описание
AboutFieldContainerization | (Унаследовано от BXSelect)
Prepare | Подготовить поля (Унаследовано от BXSelect)
SetCustomBuilder | Установить "заказной" построитель (Унаследовано от BXSelect)

Смотри также

Класс BXSelectAdd
Пространство имен Bitrix.DataLayer


Свойства BXSelectAdd

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXSelectAdd
Класс BXSelectAdd Смотри также Send Feedback

Тип BXSelectAdd предоставляет следующие возможности.

Свойства

Имя | Описание
EnableMultipleJoinedEntityFieldsContainerization | Включить контейнеризацию для множественных присоединяемых сущностей (Унаследовано от BXSelect)
FieldPreparationMode | Запрос режима подготовки полей для выборки (Унаследовано от BXSelect)
RootScheme | Корневая схема Требуется при контейнеризации присоединяемых сущностей (Унаследовано от BXSelect)
SelectString | (Унаследовано от BXSelect)
ValueMap | (Унаследовано от BXSelect)

Смотри также

Класс BXSelectAdd
Пространство имен Bitrix.DataLayer


Пространство имен Bitrix.DataTypes

Пространство имен Bitrix.DataTypes
Send Feedback
Содержит различные повсеместно используемые структуры данных.

Классы

Класс | Описание
BXParamsBag<(Of <(<'T>)>)> | Класс представляющий обобщенный словарь со строковым ключом, нечувствительным к регистру.

Делегаты

Делегат | Описание
BXParamsBag<(Of <(<'T>)>)>..::..ItemConverter<(Of <(<'R>)>)> | Класс делегата для преобразования элемента словаря в значение другого типа.


Класс BXParamsBag(T)

Класс BXParamsBag<(Of <(<'T>)>)>
Члены Пример Смотри также Send Feedback
Класс представляющий обобщенный словарь со строковым ключом, нечувствительным к регистру.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
[SerializableAttribute]
public class BXParamsBag<T> : Dictionary<string, T>,
    ISerializable, IXmlSerializable

Параметры типа

T
Тип хранимых значений.

Заметки

Класс предоставляет дополнительные методы для интерпретации хранящихся в нем значений. См. подробнее метод Get<(Of <<'(R>)>>)(String, R)

Класс поддерживает сериализацию в строку посредством класса BXSerializer. Сериализация работает только для определенных типов значений. Подробнее см. в описании класса BXSerializer. Сериализовать словарь можно методом ToString()()()(). Создать словарь из сериализованной строки можно методом FromString(String) или конструктором класса BXParamsBag<(Of <(<'T>)>)>(String)

Примеры

Пример использования класса:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 31337);

int a = bag.Get("hello");
bool b = bag.GetBool("HELLO");

//a == 31337
//b == true

Иерархия наследования

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, T>)>)>
Bitrix.DataTypes..::..BXParamsBag<(Of <(<'T>)>)>
Bitrix.Components..::..BXComponentParameters

Смотри также

Члены BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes
BXSerializer


Члены BXParamsBag(T)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXParamsBag<(Of <(<'T>)>)>
Класс BXParamsBag<(Of <(<'T>)>)> Конструкторы Методы Смотри также Send Feedback

Тип BXParamsBag<(Of <(<'T>)>)> предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXParamsBag<(Of <(<'T>)>)> | Перегруженный.

Методы

Имя | Описание
Add | Добавляет новый элемент в словарь или перезаписывает существующий.
Assign | Очищает словарь и наполняет его данными из другого словаря.
FromString | Восстанавливает словарь из сериализованного представления.
Get | Перегруженный.
GetBool | Перегруженный.
GetDouble | Перегруженный.
GetFloat | Перегруженный.
GetInt | Перегруженный.
GetLong | Перегруженный.
GetString | Перегруженный.
Override | Перекрыть значениями из пользовательского словаря
ToList<(Of <<'(R>)>>) | Формирует список на основе значений, хранящихся в данном словаре.
ToParamsBag | Перегруженный.
ToString | Сериализует словарь в строку. (Переопределяет Object..::..ToString()()()())
TryGetBool |
TryGetDouble |
TryGetFloat |
TryGetInt |
TryGetLong |
TryGetString |
TryGetValue<(Of <<'(R>)>>) |

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Конструктор BXParamsBag(T)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXParamsBag<(Of <(<'T>)>)>
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXParamsBag<(Of <(<'T>)>)>()()()() | Создает новый экземпляр класса.
BXParamsBag<(Of <(<'T>)>)>(IDictionary<(Of <<'(String, T>)>>)) | Создает словарь и наполняет его данными из другого словаря.
BXParamsBag<(Of <(<'T>)>)>(String) | Создает новый экземпляр класса и заполняет его десериализованными значениями.
BXParamsBag<(Of <(<'T>)>)>(SerializationInfo, StreamingContext) | Воссоздает словарь из сериализованных данных.

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Члены BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Конструктор BXParamsBag(T)

Конструктор BXParamsBag<(Of <(<'T>)>)>
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Создает новый экземпляр класса.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamsBag()

Примеры

Пример использования класса:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 31337);

int a = bag.Get("hello");
bool b = bag.GetBool("HELLO");

//a == 31337
//b == true

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Конструктор BXParamsBag(T) (IDictionary(String, T))

Конструктор BXParamsBag<(Of <(<'T>)>)> (IDictionary<(Of <(<'String, T>)>)>)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Создает словарь и наполняет его данными из другого словаря.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamsBag(
    IDictionary<string, T> source
)

Параметры

source
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, T >)>)>
Словарь-источник.

Примеры

Создание словаря на основе словаря-источника:

CopyC#
Dictionary<string, string> dic = new Dictionary<string,string>();
dic.Add("Hello", "aaa");
dic.Add("World", "bbb");

BXParamsBag<string> bag = new BXParamsBag<string>(dic);

string a = bag.Get("Hello");
string b = bag.Get("World");

//a == "aaa"
//b == "bbb"

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Конструктор BXParamsBag(T) (String)

Конструктор BXParamsBag<(Of <(<'T>)>)> (String)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Создает новый экземпляр класса и заполняет его десериализованными значениями.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamsBag(
    string input
)

Параметры

input
Type: System..::..String
Сериализованный в строку словарь.

Примеры

Восстановление слабо типизированного словаря:

CopyC#
BXParamsBag<object> bag = new BXParamsBag<object>();
bag.Add("Hello", 31337);
bag.Add("World", "31337");
string serialized = bag.ToString();

BXParamsBag<object> restored = new BXParamsBag<object>(serialized);
object a = restored.Get("Hello");
object b = restored.Get("World");

//a == 31337
//b == "31337"

Восстановление строго типизированного словаря:

CopyC#
BXParamsBag<int[]> bag = new BXParamsBag<int[]>();
bag.Add("Hello", new int[] {1, 2});
bag.Add("World", new int[] {3, 4, 5});
string serialized = bag.ToString();

//serialized == "p:a:i:2:{s:\"Hello\";a:i:2:{i:1;i:2;};s:\"World\";a:i:3:{i:3;i:4;i:5;};};"

BXParamsBag<int[]> restored = new BXParamsBag<int[]>(serialized);
int[] a = restored.Get("Hello");
int[] b = restored.Get("World");

//a == {1, 2}
//b == {3, 4, 5}

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Конструктор BXParamsBag(T) (SerializationInfo, StreamingContext)

Конструктор BXParamsBag<(Of <(<'T>)>)> (SerializationInfo, StreamingContext)
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback
Воссоздает словарь из сериализованных данных.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXParamsBag(
    SerializationInfo info,
    StreamingContext context
)

Параметры

info
Type: System.Runtime.Serialization..::..SerializationInfo
Объект SerializationInfo, содержащий сведения, которые требуются для сериализации словаря
context
Type: System.Runtime.Serialization..::..StreamingContext
Структура StreamingContext, содержащая исходный и конечный объекты для сериализованного потока, связанного со словарем

Заметки

Подробнее см. Dictionary<(Of <(<'TKey, TValue>)>)>(SerializationInfo, StreamingContext)

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes
Dictionary<(Of <(<'TKey, TValue>)>)>..::..Dictionary<(Of <(<'TKey, TValue>)>)>(SerializationInfo, StreamingContext)


Методы BXParamsBag(T)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXParamsBag<(Of <(<'T>)>)>
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Тип BXParamsBag<(Of <(<'T>)>)> предоставляет следующие возможности.

Методы

Имя | Описание
Add | Добавляет новый элемент в словарь или перезаписывает существующий.
Assign | Очищает словарь и наполняет его данными из другого словаря.
FromString | Восстанавливает словарь из сериализованного представления.
Get | Перегруженный.
GetBool | Перегруженный.
GetDouble | Перегруженный.
GetFloat | Перегруженный.
GetInt | Перегруженный.
GetLong | Перегруженный.
GetString | Перегруженный.
Override | Перекрыть значениями из пользовательского словаря
ToList<(Of <<'(R>)>>) | Формирует список на основе значений, хранящихся в данном словаре.
ToParamsBag | Перегруженный.
ToString | Сериализует словарь в строку. (Переопределяет Object..::..ToString()()()())
TryGetBool |
TryGetDouble |
TryGetFloat |
TryGetInt |
TryGetLong |
TryGetString |
TryGetValue<(Of <<'(R>)>>) |

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод Add

Метод BXParamsBag<(Of <(<'T>)>)>..::.Add
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback
Добавляет новый элемент в словарь или перезаписывает существующий.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void Add(
    string key,
    T value
)

Параметры

key
Type: System..::..String
Ключ элемента.
value
Type: T
Значение элемента.

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод Assign

Метод BXParamsBag<(Of <(<'T>)>)>..::.Assign
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Очищает словарь и наполняет его данными из другого словаря.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void Assign(
    IDictionary<string, T> source
)

Параметры

source
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, T >)>)>
Словарь-источник.

Заметки

Перед наполнением данными текущий словарь будет очищен.

Примеры

Копирование данных из одного словаря в другой:

CopyC#
Dictionary<string, string> dic = new Dictionary<string, string>();
dic.Add("Hello", "aaa");
dic.Add("World", "bbb");

BXParamsBag<string> bag = new BXParamsBag<string>();
bag.Assign(dic);

string a = bag.Get("Hello");
string b = bag.Get("World");

//a == "aaa"
//b == "bbb"

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод FromString

Метод BXParamsBag<(Of <(<'T>)>)>..::.FromString
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Восстанавливает словарь из сериализованного представления.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXParamsBag<T> FromString(
    string serialized
)

Параметры

serialized
Type: System..::..String
Сериализованное в строку представление словаря.

Возвращаемое значение

Восстановленный из строки словарь.

Примеры

Сериализация и восстановление строго типизированного словаря:

CopyC#
BXParamsBag<int[]> bag = new BXParamsBag<int[]>();
bag.Add("Hello", new int[] { 1, 2 });
bag.Add("World", new int[] { 3, 4, 5 });
string serialized = bag.ToString();

//serialized == "p:a:i:2:{s:\"Hello\";a:i:2:{i:1;i:2;};s:\"World\";a:i:3:{i:3;i:4;i:5;};};"

BXParamsBag<int[]> restored1 = new BXParamsBag<int[]>(serialized);
int[] a1 = restored1.Get("Hello");
int[] b1 = restored1.Get("World");

//a1 == {1, 2}
//b1 == {3, 4, 5}

BXParamsBag<int[]> restored2 = BXParamsBag<int[]>.FromString(serialized);
int[] a2 = restored2.Get("Hello");
int[] b2 = restored2.Get("World");

//a2 == {1, 2}
//b2 == {3, 4, 5}

Исключения

Исключение | Условие
System..::..InvalidCastException | Возникает, если восстановленное значение нельзя привести к BXParamsBag<(Of <(<'T>)>)>.
System.Runtime.Serialization..::..SerializationException | Возникает, если представленный в аргументе serialized объект не удалось восстановить.

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод Get

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXParamsBag<(Of <(<'T>)>)>..::.Get
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Get(String) | Возвращает значение по ключу или значение по умолчанию для типа, если такого ключа не существует.
Get<(Of <<'(R>)>>)(String) | Приводит значение по ключу к требуемому типу или возвращает значение по умолчанию для требуемого типа, если такого ключа не существует или приведение не удалось.
Get<(Of <<'(R>)>>)(String, R) | Приводит значение по ключу к требуемому типу или возвращает defaultValue, если такого ключа не существует или приведение не удалось.
Get(String, T) | Возвращает значение по ключу или defaultValue, если такого ключа не существует.

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Члены BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод Get (String)

Метод BXParamsBag<(Of <(<'T>)>)>..::.Get (String)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Возвращает значение по ключу или значение по умолчанию для типа, если такого ключа не существует.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public T Get(
    string key
)

Параметры

key
Type: System..::..String
Ключ

Возвращаемое значение

Значение параметра или default(T), если такого ключа не существует

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка Get
Пространство имен Bitrix.DataTypes


Метод Get(R) (String)

Метод BXParamsBag<(Of <(<'T>)>)>..::.Get<(Of <(<'R>)>)> (String)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Приводит значение по ключу к требуемому типу или возвращает значение по умолчанию для требуемого типа, если такого ключа не существует или приведение не удалось.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public R Get<R>(
    string key
)

Параметры

key
Type: System..::..String
Ключ.

Параметры типа

R
Требуемый тип результата.

Возвращаемое значение

Значение параметра или default(R), если такого ключа не существует или приведение не удалось.

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка Get
Пространство имен Bitrix.DataTypes


Метод Get(R) (String, R)

Метод BXParamsBag<(Of <(<'T>)>)>..::.Get<(Of <(<'R>)>)> (String, R)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Приводит значение по ключу к требуемому типу или возвращает defaultValue, если такого ключа не существует или приведение не удалось.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public R Get<R>(
    string key,
    R defaultValue
)

Параметры

key
Type: System..::..String
Ключ.
defaultValue
Type: R
Значение по умолчанию.

Параметры типа

R
Требуемый тип результата.

Возвращаемое значение

Значение параметра или defaultValue, если такого ключа не существует или приведение не удалось.

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка Get
Пространство имен Bitrix.DataTypes


Метод Get (String, T)

Метод BXParamsBag<(Of <(<'T>)>)>..::.Get (String, T)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Возвращает значение по ключу или defaultValue, если такого ключа не существует.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public T Get(
    string key,
    T defaultValue
)

Параметры

key
Type: System..::..String
Ключ
defaultValue
Type: T
Значение по умолчанию.

Возвращаемое значение

Значение параметра или defaultValue, если такого ключа не существует

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка Get
Пространство имен Bitrix.DataTypes


Метод GetBool

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXParamsBag<(Of <(<'T>)>)>..::.GetBool
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetBool(String) | Приводит значение по ключу к булевому значению или возвращает false, если такого ключа не существует или приведение не удалось.
GetBool(String, Boolean) | Приводит значение по ключу к булевому значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось.

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Члены BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод GetBool (String)

Метод BXParamsBag<(Of <(<'T>)>)>..::.GetBool (String)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Приводит значение по ключу к булевому значению или возвращает false, если такого ключа не существует или приведение не удалось.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool GetBool(
    string key
)

Параметры

key
Type: System..::..String
Ключ.

Возвращаемое значение

Значение параметра или false, если такого ключа не существует или приведение не удалось.

Заметки

Строковые значения "Y" и "N" преобразовываются в true и false соответственно.

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка GetBool
Пространство имен Bitrix.DataTypes


Метод GetBool (String, Boolean)

Метод BXParamsBag<(Of <(<'T>)>)>..::.GetBool (String, Boolean)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Приводит значение по ключу к булевому значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool GetBool(
    string key,
    bool defaultValue
)

Параметры

key
Type: System..::..String
Ключ.
defaultValue
Type: System..::..Boolean
Значение по умолчанию.

Возвращаемое значение

Значение параметра или defaultValue, если такого ключа не существует или приведение не удалось.

Заметки

Строковые значения "Y" и "N" преобразовываются в true и false соответственно.

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка GetBool
Пространство имен Bitrix.DataTypes


Метод GetDouble

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXParamsBag<(Of <(<'T>)>)>..::.GetDouble
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetDouble(String) | Приводит значение по ключу к вещественному значению или возвращает 0, если такого ключа не существует или приведение не удалось.
GetDouble(String, Double) | Приводит значение по ключу к вещественному значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось.

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Члены BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод GetDouble (String)

Метод BXParamsBag<(Of <(<'T>)>)>..::.GetDouble (String)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Приводит значение по ключу к вещественному значению или возвращает 0, если такого ключа не существует или приведение не удалось.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public double GetDouble(
    string key
)

Параметры

key
Type: System..::..String
Ключ.

Возвращаемое значение

Значение параметра или 0, если такого ключа не существует или приведение не удалось.

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка GetDouble
Пространство имен Bitrix.DataTypes


Метод GetDouble (String, Double)

Метод BXParamsBag<(Of <(<'T>)>)>..::.GetDouble (String, Double)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Приводит значение по ключу к вещественному значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public double GetDouble(
    string key,
    double defaultValue
)

Параметры

key
Type: System..::..String
Ключ.
defaultValue
Type: System..::..Double
Значение по умолчанию.

Возвращаемое значение

Значение параметра или defaultValue, если такого ключа не существует или приведение не удалось.

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка GetDouble
Пространство имен Bitrix.DataTypes


Метод GetFloat

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXParamsBag<(Of <(<'T>)>)>..::.GetFloat
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetFloat(String) |
GetFloat(String, Single) |

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Члены BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод GetFloat (String)

Метод BXParamsBag<(Of <(<'T>)>)>..::.GetFloat (String)
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public float GetFloat(
    string key
)

Параметры

key
Type: System..::..String

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка GetFloat
Пространство имен Bitrix.DataTypes


Метод GetFloat (String, Single)

Метод BXParamsBag<(Of <(<'T>)>)>..::.GetFloat (String, Single)
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public float GetFloat(
    string key,
    float defaultValue
)

Параметры

key
Type: System..::..String
defaultValue
Type: System..::..Single

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка GetFloat
Пространство имен Bitrix.DataTypes


Метод GetInt

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXParamsBag<(Of <(<'T>)>)>..::.GetInt
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetInt(String) | Приводит значение по ключу к 32-битному целочисленному значению или возвращает 0, если такого ключа не существует или приведение не удалось.
GetInt(String, Int32) | Приводит значение по ключу к 32-битному целочисленному значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось.

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Члены BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод GetInt (String)

Метод BXParamsBag<(Of <(<'T>)>)>..::.GetInt (String)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Приводит значение по ключу к 32-битному целочисленному значению или возвращает 0, если такого ключа не существует или приведение не удалось.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int GetInt(
    string key
)

Параметры

key
Type: System..::..String
Ключ.

Возвращаемое значение

Значение параметра или 0, если такого ключа не существует или приведение не удалось.

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка GetInt
Пространство имен Bitrix.DataTypes


Метод GetInt (String, Int32)

Метод BXParamsBag<(Of <(<'T>)>)>..::.GetInt (String, Int32)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Приводит значение по ключу к 32-битному целочисленному значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int GetInt(
    string key,
    int defaultValue
)

Параметры

key
Type: System..::..String
Ключ.
defaultValue
Type: System..::..Int32
Значение по умолчанию.

Возвращаемое значение

Значение параметра или defaultValue, если такого ключа не существует или приведение не удалось.

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка GetInt
Пространство имен Bitrix.DataTypes


Метод GetLong

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXParamsBag<(Of <(<'T>)>)>..::.GetLong
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetLong(String) | Приводит значение по ключу к 64-битному целочисленному значению или возвращает 0, если такого ключа не существует или приведение не удалось.
GetLong(String, Int64) | Приводит значение по ключу к 64-битному целочисленному значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось.

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Члены BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод GetLong (String)

Метод BXParamsBag<(Of <(<'T>)>)>..::.GetLong (String)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Приводит значение по ключу к 64-битному целочисленному значению или возвращает 0, если такого ключа не существует или приведение не удалось.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public long GetLong(
    string key
)

Параметры

key
Type: System..::..String
Ключ.

Возвращаемое значение

Значение параметра или 0, если такого ключа не существует или приведение не удалось.

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка GetLong
Пространство имен Bitrix.DataTypes


Метод GetLong (String, Int64)

Метод BXParamsBag<(Of <(<'T>)>)>..::.GetLong (String, Int64)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Приводит значение по ключу к 64-битному целочисленному значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public long GetLong(
    string key,
    long defaultValue
)

Параметры

key
Type: System..::..String
Ключ.
defaultValue
Type: System..::..Int64
Значение по умолчанию.

Возвращаемое значение

Значение параметра или defaultValue, если такого ключа не существует или приведение не удалось.

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка GetLong
Пространство имен Bitrix.DataTypes


Метод GetString

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXParamsBag<(Of <(<'T>)>)>..::.GetString
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetString(String) | Приводит значение по ключу к строковому значению или возвращает null, если такого ключа не существует или приведение не удалось.
GetString(String, String) | Приводит значение по ключу к строковому значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось.

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Члены BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод GetString (String)

Метод BXParamsBag<(Of <(<'T>)>)>..::.GetString (String)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Приводит значение по ключу к строковому значению или возвращает null, если такого ключа не существует или приведение не удалось.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string GetString(
    string key
)

Параметры

key
Type: System..::..String
Ключ.

Возвращаемое значение

Значение параметра или null, если такого ключа не существует или приведение не удалось.

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка GetString
Пространство имен Bitrix.DataTypes


Метод GetString (String, String)

Метод BXParamsBag<(Of <(<'T>)>)>..::.GetString (String, String)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Приводит значение по ключу к строковому значению или возвращает defaultValue, если такого ключа не существует или приведение не удалось.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string GetString(
    string key,
    string defaultValue
)

Параметры

key
Type: System..::..String
Ключ.
defaultValue
Type: System..::..String
Значение по умолчанию.

Возвращаемое значение

Значение параметра или defaultValue, если такого ключа не существует или приведение не удалось.

Примеры

Чтение значений из словаря и их различная интерпретация:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Hello", 123);

int a1 = bag.Get("Hello", 88);
int i1 = bag.GetInt("Hello", 99);
long l1 = bag.GetLong("World", 111);
bool b1 = bag.GetBool("Hello", true);
string s1 = bag.GetString("Hello", "aaa");
double d1 = bag.GetDouble("Hello", 2.71828);
float f1 = bag.Get<double>("Hello", 3.14);

int a2 = bag.Get("World", 88);
int i2 = bag.GetInt("World", 99);
long l2 = bag.GetLong("World", 111);
bool b2 = bag.GetBool("World", true);
string s2 = bag.GetString("World", "aaa");
double d2 = bag.GetDouble("World", 2.71828);
float f2 = bag.Get<double>("World", 3.14);

// a1 == 123
// i1 == 123
// l1 == 123
// b1 == true
// s1 == "123"
// d1 = 123.0
// f1 == 123.0

// a2 == 88
// i2 == 99
// l2 == 111
// b2 == true
// s2 == "aaa"
// d2 == 2.71828
// f2 == 3.14

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка GetString
Пространство имен Bitrix.DataTypes


Метод Override

Метод BXParamsBag<(Of <(<'T>)>)>..::.Override
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback
Перекрыть значениями из пользовательского словаря

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void Override(
    IDictionary<string, T> source
)

Параметры

source
Type: System.Collections.Generic..::..IDictionary <(Of <(<' String, T >)>)>

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод ToList(R)

Метод BXParamsBag<(Of <(<'T>)>)>..::.ToList<(Of <(<'R>)>)>
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Формирует список на основе значений, хранящихся в данном словаре.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public List<R> ToList<R>(
    BXParamsBag<(Of <(<'T>)>)>..::..ItemConverter<R> converter
)

Параметры

converter
Type: Bitrix.DataTypes..::..BXParamsBag<(Of <(<'T>)>)>..::..ItemConverter <(Of <(<'R>)>)>
Делегат для преобразования элемента.

Параметры типа

R
Тип элемента формируемого списка.

Возвращаемое значение

Сформированный список.

Примеры

Преобразование словаря в список строк:

CopyC#
BXParamsBag<bool> bag = new BXParamsBag<bool>();
bag.Add("Foo", true);
bag.Add("Bar", false);

List<string> s = bag.ToList<string>(delegate(string key, bool value)
{
    return string.Format("{0}: {1}", key, value ? "On" : "Off");
});

// s[0] == "Foo: On"
// s[1] == "Bar: Off"

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes
Bitrix.DataTypes..::..BXParamsBag<(Of <(<'T>)>)>..::..ItemConverter<(Of <(<'R>)>)>


Метод ToParamsBag

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXParamsBag<(Of <(<'T>)>)>..::.ToParamsBag
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ToParamsBag<(Of <<'(R>)>>)(BXParamsBag<(Of <<'(T>)>>)..::..ItemConverter<(Of <<'(KeyValuePair<(Of <<'(String, R>)>>)>)>>)) | Формирует словарь на основе значений, хранящихся в данном словаре.
ToParamsBag<(Of <<'(R>)>>)(BXParamsBag<(Of <<'(T>)>>)..::..ItemConverter<(Of <<'(R>)>>)) | Формирует словарь на основе значений, хранящихся в данном словаре.

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Члены BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод ToParamsBag(R) (BXParamsBag(T).ItemConverter(KeyValuePair(String, R)))

Метод BXParamsBag<(Of <(<'T>)>)>..::.ToParamsBag<(Of <(<'R>)>)> (BXParamsBag<(Of <(<'T>)>)>..::..ItemConverter<(Of <(<'KeyValuePair<(Of <(<'String, R>)>)>>)>)>)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Формирует словарь на основе значений, хранящихся в данном словаре.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamsBag<R> ToParamsBag<R>(
    BXParamsBag<(Of <(<'T>)>)>..::..ItemConverter<KeyValuePair<string, R>> converter
)

Параметры

converter
Type: Bitrix.DataTypes..::..BXParamsBag<(Of <(<'T>)>)>..::..ItemConverter <(Of <(<' KeyValuePair <(Of <(<' String, R>)>)>>)>)>
Делегат для преобразования элемента.

Параметры типа

R
Тип элемента значения в формируемом словаре.

Возвращаемое значение

Сформированный словарь.

Примеры

Преобразование словаря целочисленных значений в словарь целочисленных значений с измененными ключами:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Foo", 12);
bag.Add("Bar", 21);

BXParamsBag<int> b = bag.ToParamsBag<int>(delegate(string key, int value)
{
    List<char> chars = new List<char>(key.ToCharArray()); //Мы не ищем легких путей
    chars.Reverse();
    return new KeyValuePair<string, int>(new string(chars.ToArray()), value / 3);
});

// b["ooF"] == 4
// b["raB"] == 7

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка ToParamsBag
Пространство имен Bitrix.DataTypes
Bitrix.DataTypes..::..BXParamsBag<(Of <(<'T>)>)>..::..ItemConverter<(Of <(<'R>)>)>


Метод ToParamsBag(R) (BXParamsBag(T).ItemConverter(R))

Метод BXParamsBag<(Of <(<'T>)>)>..::.ToParamsBag<(Of <(<'R>)>)> (BXParamsBag<(Of <(<'T>)>)>..::..ItemConverter<(Of <(<'R>)>)>)
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Формирует словарь на основе значений, хранящихся в данном словаре.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamsBag<R> ToParamsBag<R>(
    BXParamsBag<(Of <(<'T>)>)>..::..ItemConverter<R> converter
)

Параметры

converter
Type: Bitrix.DataTypes..::..BXParamsBag<(Of <(<'T>)>)>..::..ItemConverter <(Of <(<'R>)>)>
Делегат для преобразования элемента.

Параметры типа

R
Тип элемента значения в формируемом словаре.

Возвращаемое значение

Сформированный словарь.

Примеры

Преобразование словаря целочисленных значений в словарь строковых значений:

CopyC#
BXParamsBag<int> bag = new BXParamsBag<int>();
bag.Add("Foo", 12);
bag.Add("Bar", 21);

BXParamsBag<string> b = bag.ToParamsBag<string>(delegate(string key, int value)
{
    return string.Format("{0}'s value is {1}", key, value);
});

// b["Foo"] == "Foo's value is 12"
// b["Bar"] == "Bar's value is 21"

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Перегрузка ToParamsBag
Пространство имен Bitrix.DataTypes
Bitrix.DataTypes..::..BXParamsBag<(Of <(<'T>)>)>..::..ItemConverter<(Of <(<'R>)>)>


Метод ToString

Метод BXParamsBag<(Of <(<'T>)>)>..::.ToString
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Сериализует словарь в строку.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string ToString()

Возвращаемое значение

Сериализованное в строку представление словаря.

Заметки

Сериализация работает только для определенных типов значений. Подробнее см. в описании класса BXSerializer.

Примеры

Сериализация и восстановление строго типизированного словаря:

CopyC#
BXParamsBag<int[]> bag = new BXParamsBag<int[]>();
bag.Add("Hello", new int[] { 1, 2 });
bag.Add("World", new int[] { 3, 4, 5 });
string serialized = bag.ToString();

//serialized == "p:a:i:2:{s:\"Hello\";a:i:2:{i:1;i:2;};s:\"World\";a:i:3:{i:3;i:4;i:5;};};"

BXParamsBag<int[]> restored1 = new BXParamsBag<int[]>(serialized);
int[] a1 = restored1.Get("Hello");
int[] b1 = restored1.Get("World");

//a1 == {1, 2}
//b1 == {3, 4, 5}

BXParamsBag<int[]> restored2 = BXParamsBag<int[]>.FromString(serialized);
int[] a2 = restored2.Get("Hello");
int[] b2 = restored2.Get("World");

//a2 == {1, 2}
//b2 == {3, 4, 5}

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод TryGetBool

Метод BXParamsBag<(Of <(<'T>)>)>..::.TryGetBool
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool TryGetBool(
    string key,
    out bool value
)

Параметры

key
Type: System..::..String
value
Type: System..::..Boolean %

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод TryGetDouble

Метод BXParamsBag<(Of <(<'T>)>)>..::.TryGetDouble
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool TryGetDouble(
    string key,
    out double value
)

Параметры

key
Type: System..::..String
value
Type: System..::..Double %

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод TryGetFloat

Метод BXParamsBag<(Of <(<'T>)>)>..::.TryGetFloat
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool TryGetFloat(
    string key,
    out float value
)

Параметры

key
Type: System..::..String
value
Type: System..::..Single %

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод TryGetInt

Метод BXParamsBag<(Of <(<'T>)>)>..::.TryGetInt
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool TryGetInt(
    string key,
    out int value
)

Параметры

key
Type: System..::..String
value
Type: System..::..Int32 %

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод TryGetLong

Метод BXParamsBag<(Of <(<'T>)>)>..::.TryGetLong
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool TryGetLong(
    string key,
    out long value
)

Параметры

key
Type: System..::..String
value
Type: System..::..Int64 %

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод TryGetString

Метод BXParamsBag<(Of <(<'T>)>)>..::.TryGetString
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool TryGetString(
    string key,
    out string value
)

Параметры

key
Type: System..::..String
value
Type: System..::..String %

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Метод TryGetValue(R)

Метод BXParamsBag<(Of <(<'T>)>)>..::.TryGetValue<(Of <(<'R>)>)>
Класс BXParamsBag<(Of <(<'T>)>)> Смотри также Send Feedback

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool TryGetValue<R>(
    string key,
    out R value
)

Параметры

key
Type: System..::..String
value
Type: R%

Параметры типа

R

Смотри также

Класс BXParamsBag<(Of <(<'T>)>)>
Пространство имен Bitrix.DataTypes


Делегат BXParamsBag(T).ItemConverter(R)

Делегат BXParamsBag<(Of <(<'T>)>)>..::..ItemConverter<(Of <(<'R>)>)>
Класс BXParamsBag<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Класс делегата для преобразования элемента словаря в значение другого типа.

Пространство имен: Bitrix.DataTypes
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public delegate R ItemConverter<R>(
    string key,
    T value
)

Параметры

key
Type: System..::..String
Ключ элемента словаря.
value
Type: T
Значение элемента словаря.

Параметры типа

R
Тип результата преобразования.

Возвращаемое значение

Значение типа T, полученное в результате преобразования элемента.

Примеры

Преобразование словаря в список строк:

CopyC#
BXParamsBag<bool> bag = new BXParamsBag<bool>();
bag.Add("Foo", true);
bag.Add("Bar", false);

List<string> s = bag.ToList<string>(delegate(string key, bool value)
{
    return string.Format("{0}: {1}", key, value ? "On" : "Off");
});

// s[0] == "Foo: On"
// s[1] == "Bar: Off"

Смотри также

Пространство имен Bitrix.DataTypes
BXParamsBag<(Of <(<'T>)>)>..::..ToList<(Of <<'(R>)>>)(BXParamsBag<(Of <<'(T>)>>)..::..ItemConverter<(Of <<'(R>)>>))
BXParamsBag<(Of <(<'T>)>)>..::..ToParamsBag<(Of <<'(R>)>>)(BXParamsBag<(Of <<'(T>)>>)..::..ItemConverter<(Of <<'(KeyValuePair<(Of <<'(String, R>)>>)>)>>))


Пространство имен Bitrix.IBlock

Пространство имен Bitrix.IBlock
Send Feedback
Содержит классы для управления инфоблоками.

Классы

Класс | Описание
BXIBlock | Класс определяет сущность "инфоблок". Инфоблок представляет собой хранилище однотипной информации (объектов бизнес-логики), сортированной по разделам. Как сущность, инфоблок реализует операции, типовые для сущностей (см. класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
BXIBlock..::..BXInfoBlockSite | Класс сущности-связки "сайт инфоблока".
BXIBlock..::..BXInfoBlockSite..::..Scheme | Схема сущности-связки "сайт инфоблока".
BXIBlock..::..BXInfoBlockSiteCollection | Коллекция для связки "сайт инфоблока". Содержит связки типа BXIBlock..::..BXInfoBlockSiteCollection
BXIBlock..::..IndexSynchronizer |
BXIBlock..::..Operations | Содержит константы для прав на операции с инфоблоками, наличие которых у пользователя можно проверить методом IsUserCanOperate(String). Дополнительным параметром метода является идентификатор инфоблока
BXIBlock..::..Scheme | Схема сущности "инфоблок".
BXIBlockCaptionsInfo | Содержит в подписи к инфоблокам
BXIBlockCollection | Коллекция инфоблоков. См. BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
BXIBlockCommonCollection | Обобщенная коллекция для сущностей типа BXIBlockElement и BXIBlockSection.
BXIBlockElement | Класс определяет сущность "элемент инфоблока".
BXIBlockElement..::..BXInfoBlockElementSection | Класс определяет сущность-связку "раздел элемента инфоблока.
BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme | Схема сущности-связки "раздел элемента инфоблока".
BXIBlockElement..::..BXInfoBlockElementSectionCollection | Коллекция для связки "раздел элемента инфоблока". Содержит связки типа BXIBlockElement..::..BXInfoBlockElementSection
BXIBlockElement..::..Scheme | Класс схемы для сущности "элемент инфоблока".
BXIBlockElement..::..SchemeCustomFieldSet |
BXIBlockElementCollection | Коллекция элементов инфоблока. См. BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
BXIBlockElementEditor |
BXIBlockElementFieldPublicEditor | Предоставляет средства для редактирования стандартных полей элемента инфоблока (Название, Текст анонса и др.)
BXIBlockIndexController |
BXIBlockModule | Класс модуля "Информационные блоки".
BXIBlockModuleConfiguration |
BXIBlockSection | Класс определяет сущность "раздел инфоблока".
BXIBlockSection..::..Scheme | Класс схемы для сущности "раздел инфоблока".
BXIBlockSection..::..SchemeCustomFieldSet |
BXIBlockSectionCollection | Коллекция элементов инфоблока. См. BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>
BXIBlockType | Класс определяет сущность "тип инфоблока".
BXIBlockType..::..BXInfoBlockTypeLang | Класс сущности-связки "локализация типа инфоблока".
BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme | Схема сущности-связки "локализация типа инфоблока".
BXIBlockType..::..BXInfoBlockTypeLangCollection | Коллекция для связки "локализация типа инфоблока". Содержит связки типа BXIBlockType..::..BXInfoBlockTypeLang
BXIBlockType..::..Scheme | Схема сущности "тип инфоблока".
BXIBlockTypeCollection | Коллекция типов инфоблоков. См. BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>

Перечисления

Перечисление | Описание
BXIBlock..::..IndexSynchronizerAction |


Класс BXIBlock

Класс BXIBlock
Члены Пример Смотри также Send Feedback
Класс определяет сущность "инфоблок". Инфоблок представляет собой хранилище однотипной информации (объектов бизнес-логики), сортированной по разделам. Как сущность, инфоблок реализует операции, типовые для сущностей (см. класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXIBlock : BXEntity<BXIBlock, BXIBlockCollection, BXIBlock..::..Scheme>

Примеры

Выборка всех инфоблоков, принадлежащих определенному типу:

CopyC#
int iblockTypeId;

BXIBlockCollection iblocks = BXIBlock.GetList(
    new BXFilter(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId, iblockTypeId)),
    null
);

Создание нового инфоблока:

CopyC#
int iblockTypeId;

BXIBlock iblock = new BXIBlock();
iblock.TypeId =  iblockTypeId;
iblock.Name = "Автомобили";
iblock.Code = "autos";
iblock.Sites.Add(BXSite.Current.Id);

iblock.ElementName = "Модель автомобиля";
iblock.ElementsName = "Модели автомобилей";
iblock.SectionName = "Производитель автомобиля";
iblock.SectionsName = "Производители автомобилей";

iblock.Description = "Автомобили, сортированные по производителям";
iblock.DescriptionType = BXTextType.Text;

iblock.Save();

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXEntity
Bitrix.DataLayer..::..BXEntity <(Of <(<'BXIBlock, BXIBlockCollection, BXIBlock..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlock

Смотри также

Члены BXIBlock
Пространство имен Bitrix.IBlock


Члены BXIBlock

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlock
Класс BXIBlock Конструкторы Методы Поля Свойства Смотри также Send Feedback

Тип BXIBlock предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlock | Перегруженный.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Удаляет связанные с инфоблоком элементы, разделы, настройки прав и т.д. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..DeleteAdditionalEntities(BXSqlConnection, BXSqlTransaction))
DeleteAfterSuccess | Удаляет связанные с инфоблоком полнотекстовые индексы. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..DeleteAfterSuccess()()()())
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFields | Возвращает список пользовательских полей для элементов инфоблока.
GetCustomFieldsKeyInternal | Возвращает ключ для пользовательских полей элементов инфоблока. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetCustomFieldsKeyInternal(String))
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetSectionCustomFields | Возвращает список пользовательских полей для разделов инфоблока.
GetSectionsCustomKey | Возвращает ключ для пользовательских полей разделов инфоблока.
GetSites | Запрос сайтов, к которым привязан данный инфоблок
GetTree | Возвращает список разделов инфоблока, в порядке обхода иерархии.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsUserCanOperate | Перегруженный.
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetSiteIds |
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Обновляет инфоблок в базе данных и при необходимости индексирует контент. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..UpdateAfterSuccess()()()())
VerifyEntry | Здесь происходит сохранение значений подписей инфоблока из CaptionsInfo в строку (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..VerifyEntry()()()())

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Свойства

Имя | Описание
Active | Возвращает или устанавливает, активен ли инфоблок.
CaptionsInfo | Свойство для получения подписей инфоблока, поля закодированы текущим кодировщиком сущности
Code | Возвращает или устанавливает символьный код инфоблока. Закодировано кодировщиком.
CreateDate | Возвращает или устанавливает дату создания инфоблока.
CustomFields | Возвращает список пользовательских полей для элементов текущего инфоблока.
CustomFieldsKey | Возвращает ключ для пользовательских свойств элементов данного инфоблока. (Переопределяет BXEntity..::..CustomFieldsKey)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает null. Запрещает стандартную выборку значений для пользовательских свойств. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..CustomValues)
Description | Возвращает или устанавливает описание инфоблока. Закодировано кодировщиком.
DescriptionType | Возвращает или устанавливает тип описания инфоблока, задаваемого свойством Description.
ElementName | Возвращает или устанавливает текст заголовока для подписи типа "Элемент". Закодировано кодировщиком.
ElementsCount | Возвращает количество всех элементов в инфоблоке.
ElementsName | Возвращает или устанавливает текст заголовока для подписи типа "Элементы". Закодировано кодировщиком.
EntityId | Возвращает "InfoBlock". (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..EntityId)
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
Id | Возвращает или устанавливает уникальный идентификатор инфоблока. Первичный ключ.
Image | Возвращает сущность "файл" для инфоблока, заданную свойством ImageId.
ImageId | Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится изображение для инфоблока.
IndexContent | Возвращает или устанавливает, необходимо ли индексировать содержимое элементов инфоблока для полнотекстового поиска.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ModuleId | Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..ModuleId)
Name | Возвращает или устанавливает название инфоблока. Обязательный параметр. Закодировано кодировщиком.
SectionName | Возвращает или устанавливает текст заголовока для подписи типа "Раздел". Закодировано кодировщиком.
SectionsCount | Возвращает количество всех разделов в инфоблоке.
SectionsName | Возвращает или устанавливает текст заголовока для подписи типа "Разделы". Закодировано кодировщиком.
Sites | Возвращает список связок "сайт инфоблока" (см. BXIBlock..::..BXInfoBlockSite)
Sort | Возвращает или устанавливает порядок сортировки инфоблока.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Type | Запрос типа инфоблока
TypeId | Возвращает или устанавливает идентификатор типа инфоблока (см. BXIBlockType).
UpdateDate | Возвращает или устанавливает дату последнего изменения инфоблока.
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
XmlCaptionsInfo | Свойство для получения Xml поля с подписями инфоблока
XmlId | Возвращает или устанавливает идентификатор инфоблока для экспорта в XML. Закодировано кодировщиком.

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Конструктор BXIBlock

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXIBlock
Класс BXIBlock Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXIBlock()()()() | Создает экземпляр сущности "инфоблок" с кодировщиком по умолчанию.
BXIBlock(IBXTextEncoder) | Создает экземпляр сущности "инфоблок".
BXIBlock(Int32, String) | Создает экземпляр сущности "инфоблок" с кодировщиком по умолчанию.
BXIBlock(Int32, String, IBXTextEncoder) | Создает экземпляр сущности "инфоблок".

Смотри также

Класс BXIBlock
Члены BXIBlock
Пространство имен Bitrix.IBlock


Конструктор BXIBlock

Конструктор BXIBlock
Класс BXIBlock Смотри также Send Feedback
Создает экземпляр сущности "инфоблок" с кодировщиком по умолчанию.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlock()

Смотри также

Класс BXIBlock
Перегрузка BXIBlock
Пространство имен Bitrix.IBlock


Конструктор BXIBlock ()

Конструктор BXIBlock ()
Класс BXIBlock Смотри также Send Feedback
Создает экземпляр сущности "инфоблок".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlock(
    IBXTextEncoder textEncoder
)

Параметры

textEncoder
Type: IBXTextEncoder
Кодировщик текста для сущности.

Смотри также

Класс BXIBlock
Перегрузка BXIBlock
Пространство имен Bitrix.IBlock


Конструктор BXIBlock (Int32, String)

Конструктор BXIBlock (Int32, String)
Класс BXIBlock Смотри также Send Feedback
Создает экземпляр сущности "инфоблок" с кодировщиком по умолчанию.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlock(
    int typeId,
    string name
)

Параметры

typeId
Type: System..::..Int32
Идентификатор типа инфоблока.
name
Type: System..::..String
Название инфоблока.

Смотри также

Класс BXIBlock
Перегрузка BXIBlock
Пространство имен Bitrix.IBlock


Конструктор BXIBlock (Int32, String, )

Конструктор BXIBlock (Int32, String, )
Класс BXIBlock Смотри также Send Feedback
Создает экземпляр сущности "инфоблок".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlock(
    int typeId,
    string name,
    IBXTextEncoder textEncoder
)

Параметры

typeId
Type: System..::..Int32
Идентификатор типа инфоблока.
name
Type: System..::..String
Название инфоблока.
textEncoder
Type: IBXTextEncoder
Кодировщик текста для сущности.

Смотри также

Класс BXIBlock
Перегрузка BXIBlock
Пространство имен Bitrix.IBlock


Поля BXIBlock

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXIBlock
Класс BXIBlock Смотри также Send Feedback

Тип BXIBlock предоставляет следующие возможности.

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Методы BXIBlock

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlock
Класс BXIBlock Смотри также Send Feedback

Тип BXIBlock предоставляет следующие возможности.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Удаляет связанные с инфоблоком элементы, разделы, настройки прав и т.д. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..DeleteAdditionalEntities(BXSqlConnection, BXSqlTransaction))
DeleteAfterSuccess | Удаляет связанные с инфоблоком полнотекстовые индексы. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..DeleteAfterSuccess()()()())
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFields | Возвращает список пользовательских полей для элементов инфоблока.
GetCustomFieldsKeyInternal | Возвращает ключ для пользовательских полей элементов инфоблока. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetCustomFieldsKeyInternal(String))
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetSectionCustomFields | Возвращает список пользовательских полей для разделов инфоблока.
GetSectionsCustomKey | Возвращает ключ для пользовательских полей разделов инфоблока.
GetSites | Запрос сайтов, к которым привязан данный инфоблок
GetTree | Возвращает список разделов инфоблока, в порядке обхода иерархии.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsUserCanOperate | Перегруженный.
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetSiteIds |
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Обновляет инфоблок в базе данных и при необходимости индексирует контент. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..UpdateAfterSuccess()()()())
VerifyEntry | Здесь происходит сохранение значений подписей инфоблока из CaptionsInfo в строку (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..VerifyEntry()()()())

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Метод Create

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlock..::.Create
Класс BXIBlock Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Create()()()() | Добавляет новую сущность в базу данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create(BXSqlConnection, BXSqlTransaction) | Добавляет новую сущность в базу данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock
Члены BXIBlock
Пространство имен Bitrix.IBlock


Метод Delete

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlock..::.Delete
Класс BXIBlock Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Delete()()()() | Удаляет текущую сущность из базы данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete(BXSqlConnection, BXSqlTransaction) | Удаляет текущую сущность из базы данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock
Члены BXIBlock
Пространство имен Bitrix.IBlock


Метод DeleteAdditionalEntities

Метод BXIBlock..::.DeleteAdditionalEntities
Класс BXIBlock Смотри также Send Feedback
Удаляет связанные с инфоблоком элементы, разделы, настройки прав и т.д.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override void DeleteAdditionalEntities(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Заметки

Этот метод ничего не делает в базовой реализации сущности, но может быть переопределен в конкретной сущности.

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Метод DeleteAfterSuccess

Метод BXIBlock..::.DeleteAfterSuccess
Класс BXIBlock Смотри также Send Feedback
Удаляет связанные с инфоблоком полнотекстовые индексы.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override void DeleteAfterSuccess()

Заметки

Этот метод ничего не делает в базовой реализации сущности, но может быть переопределен в конкретной сущности.

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Метод DeleteInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlock..::.DeleteInternal
Класс BXIBlock Смотри также Send Feedback

Лист перегрузки

Имя | Описание
DeleteInternal(Object) | Внутренний метод удаления сущностей по первичному ключу id, который вызывается статическим методом Delete(Object). (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter) | Внутренний метод удаления сущностей по фильтру, который вызывается статическим методом Delete(BXFilter). При удалении не отправляются никакие комманды и не удаляются дополнительные данные. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter, BXSqlConnection, BXSqlTransaction) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock
Члены BXIBlock
Пространство имен Bitrix.IBlock


Метод GetByIdInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlock..::.GetByIdInternal
Класс BXIBlock Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetByIdInternal(Object, IBXTextEncoder) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal(Object, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock
Члены BXIBlock
Пространство имен Bitrix.IBlock


Метод GetCustomFields

Метод BXIBlock..::.GetCustomFields
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает список пользовательских полей для элементов инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXCustomFieldCollection GetCustomFields(
    int iblockId
)

Параметры

iblockId
Type: System..::..Int32
Идентификатор инфоблока.

Возвращаемое значение

Коллекция пользовательских полей.

Примеры

Заполнение списка предопределенными названиями полей:

CopyC#
int iblockId;
ListBox items;

foreach (BXCustomField field in BXIBlock.GetCustomFields(iblockId))
    items.Items.Add(new ListItem(
        field.TextEncoder.Decode(field.EditFormLabel),
        field.Name
    ));

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Метод GetCustomFieldsKeyInternal

Метод BXIBlock..::.GetCustomFieldsKeyInternal
Класс BXIBlock Смотри также Send Feedback
Возвращает ключ для пользовательских полей элементов инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override string GetCustomFieldsKeyInternal(
    string id
)

Параметры

id
Type: System..::..String
Идентификатор инфоблока в строковой форме.

Возвращаемое значение

Строка, содержащая код.

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Метод GetJoinedEntity

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlock..::.GetJoinedEntity
Класс BXIBlock Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String, BXSchemeBase) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock
Члены BXIBlock
Пространство имен Bitrix.IBlock


Метод GetJoinedEntityCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlock..::.GetJoinedEntityCollection
Класс BXIBlock Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType, JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>)(String, String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock
Члены BXIBlock
Пространство имен Bitrix.IBlock


Метод GetListInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlock..::.GetListInternal
Класс BXIBlock Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock
Члены BXIBlock
Пространство имен Bitrix.IBlock


Метод GetSectionCustomFields

Метод BXIBlock..::.GetSectionCustomFields
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает список пользовательских полей для разделов инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXCustomFieldCollection GetSectionCustomFields(
    int iblockId
)

Параметры

iblockId
Type: System..::..Int32
Идентификатор инфоблока.

Возвращаемое значение

Коллекция пользовательских полей.

Примеры

Заполнение списка предопределенными названиями полей:

CopyC#
int iblockId;
ListBox items;

foreach (BXCustomField field in BXIBlock.GetSectionCustomFields(iblockId))
    items.Items.Add(new ListItem(
        field.TextEncoder.Decode(field.EditFormLabel),
        field.Name
    ));

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Метод GetSectionsCustomKey

Метод BXIBlock..::.GetSectionsCustomKey
Класс BXIBlock Смотри также Send Feedback
Возвращает ключ для пользовательских полей разделов инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetSectionsCustomKey(
    int id
)

Параметры

id
Type: System..::..Int32
Идентификатор инфоблока в строковой форме.

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Метод GetSites

Метод BXIBlock..::.GetSites
Класс BXIBlock Смотри также Send Feedback
Запрос сайтов, к которым привязан данный инфоблок

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSiteCollection GetSites()

Возвращаемое значение

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Метод GetTree

Метод BXIBlock..::.GetTree
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает список разделов инфоблока, в порядке обхода иерархии.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockSectionCollection GetTree(
    int depthLevel
)

Параметры

depthLevel
Type: System..::..Int32
Верхняя исключающая граница для глубины выборки иерархии.

Возвращаемое значение

Заметки

При depthLevel, равном 0 будут выбраны все уровни вложенности разделов. Для выбора, например, всех разделов верхнего уровня, необходимо задать значение параметра depthLevel, равное 2 (т.е. выбрать все уровни с глубиной < 2)

Выборка не учитывает активность и другие параметры разделов инфоблока.

Примеры

Вывод иерархии разделов инфоблока в коде ASPX-страницы:

CopyC#
<%
    BXIBlock iblock;

    int depth = 0;
    foreach (BXIBlockSection section in iblock.GetTree(0))
    {
        while (depth < section.DepthLevel)
        {
            %><ul><%
            depth++;
        }
        while (depth > section.DepthLevel)
        {
            %></ul><%
            depth--;
        }

        %><li><%= section.Name %></li><%
    }
    while (depth > 0)
    {
        %></ul><%
        depth--;
    }
%>

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Метод IsUserCanOperate

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlock..::.IsUserCanOperate
Класс BXIBlock Смотри также Send Feedback

Лист перегрузки

Имя | Описание
IsUserCanOperate(String) | Возвращает, может ли операция над текущим инфоблоком быть произведена текущим пользователем.
IsUserCanOperate(Int32, String) | Возвращает, может ли операция над инфоблоком быть произведена текущим пользователем.

Смотри также

Класс BXIBlock
Члены BXIBlock
Пространство имен Bitrix.IBlock


Метод IsUserCanOperate (String)

Метод BXIBlock..::.IsUserCanOperate (String)
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает, может ли операция над текущим инфоблоком быть произведена текущим пользователем.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool IsUserCanOperate(
    string operation
)

Параметры

operation
Type: System..::..String
Операция, которую нужно проверить.

Возвращаемое значение

true, если пользователь может совершить операцию; иначе false

Заметки

Метод требует наличия контекста исполнения HTTP (см. HttpContext)

Список операций доступен через константы класса BXIBlock..::..Operations.

Примеры

Проверка текущего пользователя на наличие права просматривать инфоблок в публичной части сайта:

CopyC#
BXIBlock iblock;

if (iblock.IsUserCanOperate(BXIBlock.Operations.IBlockPublicRead))
{
    // Делаем работу
}
CopyC#
int iblockId;

if (BXIBlock.IsUserCanOperate(iblockId, BXIBlock.Operations.IBlockPublicRead))
{
    // Делаем работу
}

Смотри также

Класс BXIBlock
Перегрузка IsUserCanOperate
Пространство имен Bitrix.IBlock


Метод IsUserCanOperate (Int32, String)

Метод BXIBlock..::.IsUserCanOperate (Int32, String)
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает, может ли операция над инфоблоком быть произведена текущим пользователем.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static bool IsUserCanOperate(
    int iblockId,
    string operation
)

Параметры

iblockId
Type: System..::..Int32
Идентификатор инфоблока.
operation
Type: System..::..String
Операция, которую нужно проверить.

Возвращаемое значение

true, если пользователь может совершить операцию; иначе false

Заметки

Метод требует наличия контекста исполнения HTTP (см. HttpContext)

Список операций доступен через константы класса BXIBlock..::..Operations.

Примеры

Проверка текущего пользователя на наличие права просматривать инфоблок в публичной части сайта:

CopyC#
BXIBlock iblock;

if (iblock.IsUserCanOperate(BXIBlock.Operations.IBlockPublicRead))
{
    // Делаем работу
}
CopyC#
int iblockId;

if (BXIBlock.IsUserCanOperate(iblockId, BXIBlock.Operations.IBlockPublicRead))
{
    // Делаем работу
}

Смотри также

Класс BXIBlock
Перегрузка IsUserCanOperate
Пространство имен Bitrix.IBlock


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlock..::.Save
Класс BXIBlock Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет сущность в базе данных в новой транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет сущность в базе данных в указанной транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock
Члены BXIBlock
Пространство имен Bitrix.IBlock


Метод SetSiteIds

Метод BXIBlock..::.SetSiteIds
Класс BXIBlock Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void SetSiteIds(
    string[] siteIds
)

Параметры

siteIds
Type: array< System..::..String >[]()[][]

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Метод SetValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlock..::.SetValue
Класс BXIBlock Смотри также Send Feedback

Лист перегрузки

Имя | Описание
SetValue(KeyValuePair<(Of <<'(String, Object>)>>), Boolean) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object, Boolean) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock
Члены BXIBlock
Пространство имен Bitrix.IBlock


Метод Update

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlock..::.Update
Класс BXIBlock Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Update()()()() | Изменяет существующую сущность в базе данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update(BXSqlConnection, BXSqlTransaction) | Изменяет существующую сущность в базе данных в указанной транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock
Члены BXIBlock
Пространство имен Bitrix.IBlock


Метод UpdateAfterSuccess

Метод BXIBlock..::.UpdateAfterSuccess
Класс BXIBlock Смотри также Send Feedback
Обновляет инфоблок в базе данных и при необходимости индексирует контент.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override void UpdateAfterSuccess()

Заметки

Этот метод ничего не делает в базовой реализации сущности, но может быть переопределен в конкретной сущности.

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Метод VerifyEntry

Метод BXIBlock..::.VerifyEntry
Класс BXIBlock Смотри также Send Feedback
Здесь происходит сохранение значений подписей инфоблока из CaptionsInfo в строку

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override BXModifyStatus VerifyEntry()

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойства BXIBlock

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlock
Класс BXIBlock Смотри также Send Feedback

Тип BXIBlock предоставляет следующие возможности.

Свойства

Имя | Описание
Active | Возвращает или устанавливает, активен ли инфоблок.
CaptionsInfo | Свойство для получения подписей инфоблока, поля закодированы текущим кодировщиком сущности
Code | Возвращает или устанавливает символьный код инфоблока. Закодировано кодировщиком.
CreateDate | Возвращает или устанавливает дату создания инфоблока.
CustomFields | Возвращает список пользовательских полей для элементов текущего инфоблока.
CustomFieldsKey | Возвращает ключ для пользовательских свойств элементов данного инфоблока. (Переопределяет BXEntity..::..CustomFieldsKey)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает null. Запрещает стандартную выборку значений для пользовательских свойств. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..CustomValues)
Description | Возвращает или устанавливает описание инфоблока. Закодировано кодировщиком.
DescriptionType | Возвращает или устанавливает тип описания инфоблока, задаваемого свойством Description.
ElementName | Возвращает или устанавливает текст заголовока для подписи типа "Элемент". Закодировано кодировщиком.
ElementsCount | Возвращает количество всех элементов в инфоблоке.
ElementsName | Возвращает или устанавливает текст заголовока для подписи типа "Элементы". Закодировано кодировщиком.
EntityId | Возвращает "InfoBlock". (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..EntityId)
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
Id | Возвращает или устанавливает уникальный идентификатор инфоблока. Первичный ключ.
Image | Возвращает сущность "файл" для инфоблока, заданную свойством ImageId.
ImageId | Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится изображение для инфоблока.
IndexContent | Возвращает или устанавливает, необходимо ли индексировать содержимое элементов инфоблока для полнотекстового поиска.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ModuleId | Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..ModuleId)
Name | Возвращает или устанавливает название инфоблока. Обязательный параметр. Закодировано кодировщиком.
SectionName | Возвращает или устанавливает текст заголовока для подписи типа "Раздел". Закодировано кодировщиком.
SectionsCount | Возвращает количество всех разделов в инфоблоке.
SectionsName | Возвращает или устанавливает текст заголовока для подписи типа "Разделы". Закодировано кодировщиком.
Sites | Возвращает список связок "сайт инфоблока" (см. BXIBlock..::..BXInfoBlockSite)
Sort | Возвращает или устанавливает порядок сортировки инфоблока.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Type | Запрос типа инфоблока
TypeId | Возвращает или устанавливает идентификатор типа инфоблока (см. BXIBlockType).
UpdateDate | Возвращает или устанавливает дату последнего изменения инфоблока.
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
XmlCaptionsInfo | Свойство для получения Xml поля с подписями инфоблока
XmlId | Возвращает или устанавливает идентификатор инфоблока для экспорта в XML. Закодировано кодировщиком.

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство Active

Свойство BXIBlock..::.Active
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает или устанавливает, активен ли инфоблок.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool Active { get; set; }

Примеры

Выборка всех активных инфоблоков, упорядоченных по индексу сортировки:

CopyC#
int iblockTypeId;
BXIBlockCollection iblocks = BXIBlock.GetList(
    new BXFilter(
        new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId),
        new BXFilterItem(BXIBlock.Fields.Active, BXSqlFilterOperators.Equal, "Y")
    ),
    new BXOrderBy(
        new BXOrderByPair(BXIBlock.Fields.Sort, BXOrderByDirection.Asc)
    )
);

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство CaptionsInfo

Свойство BXIBlock..::.CaptionsInfo
Класс BXIBlock Смотри также Send Feedback
Свойство для получения подписей инфоблока, поля закодированы текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockCaptionsInfo CaptionsInfo { get; }

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство Code

Свойство BXIBlock..::.Code
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает или устанавливает символьный код инфоблока. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Code { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Примеры

Создание нового инфоблока:

CopyC#
int iblockTypeId;

BXIBlock iblock = new BXIBlock();
iblock.TypeId =  iblockTypeId;
iblock.Name = "Автомобили";
iblock.Code = "autos";
iblock.Sites.Add(BXSite.Current.Id);

iblock.ElementName = "Модель автомобиля";
iblock.ElementsName = "Модели автомобилей";
iblock.SectionName = "Производитель автомобиля";
iblock.SectionsName = "Производители автомобилей";

iblock.Description = "Автомобили, сортированные по производителям";
iblock.DescriptionType = BXTextType.Text;

iblock.Save();

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство CreateDate

Свойство BXIBlock..::.CreateDate
Класс BXIBlock Смотри также Send Feedback
Возвращает или устанавливает дату создания инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public DateTime CreateDate { get; set; }

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство CustomFields

Свойство BXIBlock..::.CustomFields
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает список пользовательских полей для элементов текущего инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXCustomFieldCollection CustomFields { get; }

Примеры

Заполнение списка предопределенными названиями полей:

CopyC#
BXIBlock iblock;
ListBox items;

foreach (BXCustomField field in iblock.CustomFields)
    items.Items.Add(new ListItem(
        field.TextEncoder.Decode(field.EditFormLabel),
        field.Name
    ));

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство CustomFieldsKey

Свойство BXIBlock..::.CustomFieldsKey
Класс BXIBlock Смотри также Send Feedback
Возвращает ключ для пользовательских свойств элементов данного инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override string CustomFieldsKey { get; }

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство CustomValues

Свойство BXIBlock..::.CustomValues
Класс BXIBlock Смотри также Send Feedback
Возвращает null. Запрещает стандартную выборку значений для пользовательских свойств.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override BXCustomPropertyCollection CustomValues { get; }

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство Description

Свойство BXIBlock..::.Description
Класс BXIBlock Смотри также Send Feedback
Возвращает или устанавливает описание инфоблока. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Description { get; set; }

Заметки

Может содержать текст или HTML, что определяется свойством DescriptionType.

Значение данного свойства закодировано кодировщиком в зависмости от значения свойства DescriptionType.

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство DescriptionType

Свойство BXIBlock..::.DescriptionType
Класс BXIBlock Смотри также Send Feedback
Возвращает или устанавливает тип описания инфоблока, задаваемого свойством Description.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXTextType DescriptionType { get; set; }

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство ElementName

Свойство BXIBlock..::.ElementName
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает или устанавливает текст заголовока для подписи типа "Элемент". Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ElementName { get; set; }

Заметки

Данный текст должен использоваться вместо подписи "Элемент" в различных местах пользовательского интерфейса.

Значение данного свойства закодировано кодировщиком.

Примеры

Создание нового инфоблока:

CopyC#
int iblockTypeId;

BXIBlock iblock = new BXIBlock();
iblock.TypeId =  iblockTypeId;
iblock.Name = "Автомобили";
iblock.Code = "autos";
iblock.Sites.Add(BXSite.Current.Id);

iblock.ElementName = "Модель автомобиля";
iblock.ElementsName = "Модели автомобилей";
iblock.SectionName = "Производитель автомобиля";
iblock.SectionsName = "Производители автомобилей";

iblock.Description = "Автомобили, сортированные по производителям";
iblock.DescriptionType = BXTextType.Text;

iblock.Save();

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство ElementsCount

Свойство BXIBlock..::.ElementsCount
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает количество всех элементов в инфоблоке.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int ElementsCount { get; }

Заметки

Свойство производит запрос к базе данных по первому обращению.

Свойство имеет смысл только для уже существующих инфоблоков.

Примеры

Подсчет количества элементов и разделов инфоблока:

CopyC#
<%
    int iblockId;
    BXIBlock iblock = BXIBlock.GetById(iblockId);
%>
<%= iblock.ElementsCount %> == <%= BXIBlockElement.Count(new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId))) %><br />
<%= iblock.SectionsCount %> == <%= BXIBlockSection.Count(new BXFilter(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId))) %><br />

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство ElementsName

Свойство BXIBlock..::.ElementsName
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает или устанавливает текст заголовока для подписи типа "Элементы". Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ElementsName { get; set; }

Заметки

Данный текст должен использоваться вместо подписи "Элементы" в различных местах пользовательского интерфейса.

Значение данного свойства закодировано кодировщиком.

Примеры

Создание нового инфоблока:

CopyC#
int iblockTypeId;

BXIBlock iblock = new BXIBlock();
iblock.TypeId =  iblockTypeId;
iblock.Name = "Автомобили";
iblock.Code = "autos";
iblock.Sites.Add(BXSite.Current.Id);

iblock.ElementName = "Модель автомобиля";
iblock.ElementsName = "Модели автомобилей";
iblock.SectionName = "Производитель автомобиля";
iblock.SectionsName = "Производители автомобилей";

iblock.Description = "Автомобили, сортированные по производителям";
iblock.DescriptionType = BXTextType.Text;

iblock.Save();

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство EntityId

Свойство BXIBlock..::.EntityId
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает "InfoBlock".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string EntityId { get; }

Заметки

Это свойство используется для формирования названий команд, отправляемых при сохранении сущности в базу данных или удалении из базы данных.

Примеры

CopyC#
public class BXIBlockElement
    : BXEntity
{
    . . .

    public override string ModuleId
    {
        get { return "iblock"; }
    }

    public override string EntityId
    {
        get { return "IBlockElement"; }
    }

    . . .
}

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство Id

Свойство BXIBlock..::.Id
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает или устанавливает уникальный идентификатор инфоблока. Первичный ключ.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Id { get; set; }

Примеры

Выборка элементов для конкретного инфоблока:

CopyC#
BXIBlock iblock;

BXIBlockElementCollection items = BXIBlockElement.GetList(
    new BXFilter(
        new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblock.Id)
    ),
    null
)

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство Image

Свойство BXIBlock..::.Image
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает сущность "файл" для инфоблока, заданную свойством ImageId.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile Image { get; }

Заметки

Свойство производит запрос к базе данных при первом обращении.

Примеры

Вывод изображения для инфоблока в ASPX-странице

CopyC#
<%
    int iblockId;
    Bitrix.IBlock.BXIBlock iblock = Bitrix.IBlock.BXIBlock.GetById(iblockId);
    if (iblock.Image != null)
    {
        %>
    <img alt="<%= iblock.Name %>" src="<%= iblock.Image.FilePath %>" />
        <%
    }
%>

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство ImageId

Свойство BXIBlock..::.ImageId
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится изображение для инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int ImageId { get; set; }

Примеры

Загрузка изображения для инфоблока:

CopyC#
FileUpload fileUpload;
int iblockId;

if (!fileUpload.HasFile)
    return;

BXFile file = new BXFile(fileUpload.PostedFile, "up", "iblock", "");
if (file.ValidateAsImage(0, 0, 0) != BXFileValidationResult.Valid)
    return;
file.Save();

BXIBlock iblock = BXIBlock.GetById(iblockId);
iblock.ImageId = file.Id;
iblock.Save();

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство IndexContent

Свойство BXIBlock..::.IndexContent
Класс BXIBlock Смотри также Send Feedback
Возвращает или устанавливает, необходимо ли индексировать содержимое элементов инфоблока для полнотекстового поиска.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool IndexContent { get; set; }

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство ModuleId

Свойство BXIBlock..::.ModuleId
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string ModuleId { get; }

Заметки

Это свойство используется для формирования названий команд, отправляемых при сохранении сущности в базу данных или удалении из базы данных.

Примеры

CopyC#
public class BXIBlockElement
    : BXEntity
{
    . . .

    public override string ModuleId
    {
        get { return "iblock"; }
    }

    public override string EntityId
    {
        get { return "IBlockElement"; }
    }

    . . .
}

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство Name

Свойство BXIBlock..::.Name
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает или устанавливает название инфоблока. Обязательный параметр. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Name { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Примеры

Создание нового инфоблока:

CopyC#
int iblockTypeId;

BXIBlock iblock = new BXIBlock();
iblock.TypeId =  iblockTypeId;
iblock.Name = "Автомобили";
iblock.Code = "autos";
iblock.Sites.Add(BXSite.Current.Id);

iblock.ElementName = "Модель автомобиля";
iblock.ElementsName = "Модели автомобилей";
iblock.SectionName = "Производитель автомобиля";
iblock.SectionsName = "Производители автомобилей";

iblock.Description = "Автомобили, сортированные по производителям";
iblock.DescriptionType = BXTextType.Text;

iblock.Save();

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство SectionName

Свойство BXIBlock..::.SectionName
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает или устанавливает текст заголовока для подписи типа "Раздел". Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string SectionName { get; set; }

Заметки

Данный текст должен использоваться вместо подписи "Раздел" в различных местах пользовательского интерфейса.

Значение данного свойства закодировано кодировщиком.

Примеры

Создание нового инфоблока:

CopyC#
int iblockTypeId;

BXIBlock iblock = new BXIBlock();
iblock.TypeId =  iblockTypeId;
iblock.Name = "Автомобили";
iblock.Code = "autos";
iblock.Sites.Add(BXSite.Current.Id);

iblock.ElementName = "Модель автомобиля";
iblock.ElementsName = "Модели автомобилей";
iblock.SectionName = "Производитель автомобиля";
iblock.SectionsName = "Производители автомобилей";

iblock.Description = "Автомобили, сортированные по производителям";
iblock.DescriptionType = BXTextType.Text;

iblock.Save();

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство SectionsCount

Свойство BXIBlock..::.SectionsCount
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает количество всех разделов в инфоблоке.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int SectionsCount { get; }

Заметки

Свойство производит запрос к базе данных по первому обращению.

Свойство имеет смысл только для уже существующих инфоблоков.

Примеры

Подсчет количества элементов и разделов инфоблока:

CopyC#
<%
    int iblockId;
    BXIBlock iblock = BXIBlock.GetById(iblockId);
%>
<%= iblock.ElementsCount %> == <%= BXIBlockElement.Count(new BXFilter(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId))) %><br />
<%= iblock.SectionsCount %> == <%= BXIBlockSection.Count(new BXFilter(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId))) %><br />

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство SectionsName

Свойство BXIBlock..::.SectionsName
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает или устанавливает текст заголовока для подписи типа "Разделы". Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string SectionsName { get; set; }

Заметки

Данный текст должен использоваться вместо подписи "Разделы" в различных местах пользовательского интерфейса.

Значение данного свойства закодировано кодировщиком.

Примеры

Создание нового инфоблока:

CopyC#
int iblockTypeId;

BXIBlock iblock = new BXIBlock();
iblock.TypeId =  iblockTypeId;
iblock.Name = "Автомобили";
iblock.Code = "autos";
iblock.Sites.Add(BXSite.Current.Id);

iblock.ElementName = "Модель автомобиля";
iblock.ElementsName = "Модели автомобилей";
iblock.SectionName = "Производитель автомобиля";
iblock.SectionsName = "Производители автомобилей";

iblock.Description = "Автомобили, сортированные по производителям";
iblock.DescriptionType = BXTextType.Text;

iblock.Save();

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство Sites

Свойство BXIBlock..::.Sites
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает список связок "сайт инфоблока" (см. BXIBlock..::..BXInfoBlockSite)

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlock..::..BXInfoBlockSiteCollection Sites { get; }

Примеры

Создание нового инфоблока:

CopyC#
int iblockTypeId;

BXIBlock iblock = new BXIBlock();
iblock.TypeId =  iblockTypeId;
iblock.Name = "Автомобили";
iblock.Code = "autos";
iblock.Sites.Add(BXSite.Current.Id);

iblock.ElementName = "Модель автомобиля";
iblock.ElementsName = "Модели автомобилей";
iblock.SectionName = "Производитель автомобиля";
iblock.SectionsName = "Производители автомобилей";

iblock.Description = "Автомобили, сортированные по производителям";
iblock.DescriptionType = BXTextType.Text;

iblock.Save();

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство Sort

Свойство BXIBlock..::.Sort
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает или устанавливает порядок сортировки инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Sort { get; set; }

Примеры

Переупорядочивание инфоблоков по имени:

CopyC#
int iblockTypeId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlock.Fields.Name, BXOrderByDirection.Asc);

int i = 0;
foreach (BXIBlock iblock in BXIBlock.GetList(filter, orderBy))
{
    iblock.Sort = (i += 10);
    iblock.Save();
}

Выборка всех активных инфоблоков, упорядоченных по индексу сортировки:

CopyC#
int iblockTypeId;
BXIBlockCollection iblocks = BXIBlock.GetList(
    new BXFilter(
        new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId),
        new BXFilterItem(BXIBlock.Fields.Active, BXSqlFilterOperators.Equal, "Y")
    ),
    new BXOrderBy(
        new BXOrderByPair(BXIBlock.Fields.Sort, BXOrderByDirection.Asc)
    )
);

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство Type

Свойство BXIBlock..::.Type
Класс BXIBlock Смотри также Send Feedback
Запрос типа инфоблока

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockType Type { get; }

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство TypeId

Свойство BXIBlock..::.TypeId
Класс BXIBlock Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор типа инфоблока (см. BXIBlockType).

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int TypeId { get; set; }

Примеры

Создание нового инфоблока:

CopyC#
int iblockTypeId;

BXIBlock iblock = new BXIBlock();
iblock.TypeId =  iblockTypeId;
iblock.Name = "Автомобили";
iblock.Code = "autos";
iblock.Sites.Add(BXSite.Current.Id);

iblock.ElementName = "Модель автомобиля";
iblock.ElementsName = "Модели автомобилей";
iblock.SectionName = "Производитель автомобиля";
iblock.SectionsName = "Производители автомобилей";

iblock.Description = "Автомобили, сортированные по производителям";
iblock.DescriptionType = BXTextType.Text;

iblock.Save();

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство UpdateDate

Свойство BXIBlock..::.UpdateDate
Класс BXIBlock Смотри также Send Feedback
Возвращает или устанавливает дату последнего изменения инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public DateTime UpdateDate { get; set; }

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство XmlCaptionsInfo

Свойство BXIBlock..::.XmlCaptionsInfo
Класс BXIBlock Смотри также Send Feedback
Свойство для получения Xml поля с подписями инфоблока

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string XmlCaptionsInfo { get; set; }

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Свойство XmlId

Свойство BXIBlock..::.XmlId
Класс BXIBlock Смотри также Send Feedback
Возвращает или устанавливает идентификатор инфоблока для экспорта в XML. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string XmlId { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Смотри также

Класс BXIBlock
Пространство имен Bitrix.IBlock


Класс BXIBlock.BXInfoBlockSite

Класс BXIBlock..::..BXInfoBlockSite
Класс BXIBlock Члены Смотри также Send Feedback
Класс сущности-связки "сайт инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXInfoBlockSite : BXLinkedEntity<BXIBlock..::..BXInfoBlockSite, BXIBlock..::..BXInfoBlockSiteCollection, BXIBlock..::..BXInfoBlockSite..::..Scheme>

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXEntity
Bitrix.DataLayer..::..BXEntity <(Of <(<' EntityType, EntityCollectionType, EntryScheme >)>)>
BXLinkedEntity<(Of <(<'BXIBlock..::..BXInfoBlockSite, BXIBlock..::..BXInfoBlockSiteCollection, BXIBlock..::..BXInfoBlockSite..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlock..::..BXInfoBlockSite

Смотри также

Члены BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Члены BXIBlock.BXInfoBlockSite

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlock..::..BXInfoBlockSite
Класс BXIBlock..::..BXInfoBlockSite Конструкторы Методы Поля Свойства Смотри также Send Feedback

Класс определяет сущность "инфоблок". Инфоблок представляет собой хранилище однотипной информации (объектов бизнес-логики), сортированной по разделам. Как сущность, инфоблок реализует операции, типовые для сущностей (см. класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Тип BXIBlock..::..BXInfoBlockSite предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlock..::..BXInfoBlockSite | Перегруженный.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
VerifyEntry | Проверяет корректность сущности перед сохранением. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Свойства

Имя | Описание
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Унаследовано от BXEntity)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityId | Возвращает "InfoBlockSite". (Переопределяет BXLinkedEntityEntityId()()()())
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
InfoBlockId | Возвращает идентификатор инфоблока, к коророму привязан сайт.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ModuleId | (Переопределяет BXLinkedEntityModuleId()()()())
SiteId | Возвращает или устанавливает идентификатор сайта, привязанного к инфоблоку. Закодировано кодировщиком.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Конструктор BXIBlock.BXInfoBlockSite

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXIBlock..::..BXInfoBlockSite
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXIBlock..::..BXInfoBlockSite()()()() | Конструктор сущности-связки.
BXIBlock..::..BXInfoBlockSite(String) | Конструктор сущности-связки.

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Члены BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Конструктор BXIBlock.BXInfoBlockSite

Конструктор BXIBlock..::..BXInfoBlockSite
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback
Конструктор сущности-связки.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXInfoBlockSite()

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Перегрузка BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Конструктор BXIBlock.BXInfoBlockSite (String)

Конструктор BXIBlock..::..BXInfoBlockSite (String)
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback
Конструктор сущности-связки.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXInfoBlockSite(
    string siteId
)

Параметры

siteId
Type: System..::..String
Идентификатор сайта.

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Перегрузка BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Поля BXIBlock.BXInfoBlockSite

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXIBlock..::..BXInfoBlockSite
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Тип BXIBlock..::..BXInfoBlockSite предоставляет следующие возможности.

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Методы BXIBlock.BXInfoBlockSite

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlock..::..BXInfoBlockSite
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Тип BXIBlock..::..BXInfoBlockSite предоставляет следующие возможности.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
VerifyEntry | Проверяет корректность сущности перед сохранением. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Метод Create

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockSite..::.Create
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Create()()()() | Добавляет новую сущность в базу данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create(BXSqlConnection, BXSqlTransaction) | Добавляет новую сущность в базу данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Члены BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Метод Delete

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockSite..::.Delete
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Delete()()()() | Удаляет текущую сущность из базы данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete(BXSqlConnection, BXSqlTransaction) | Удаляет текущую сущность из базы данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Члены BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Метод DeleteInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockSite..::.DeleteInternal
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Лист перегрузки

Имя | Описание
DeleteInternal(Object) | Внутренний метод удаления сущностей по первичному ключу id, который вызывается статическим методом Delete(Object). (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter) | Внутренний метод удаления сущностей по фильтру, который вызывается статическим методом Delete(BXFilter). При удалении не отправляются никакие комманды и не удаляются дополнительные данные. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter, BXSqlConnection, BXSqlTransaction) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Члены BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Метод GetByIdInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockSite..::.GetByIdInternal
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetByIdInternal(Object, IBXTextEncoder) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal(Object, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Члены BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Метод GetJoinedEntity

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockSite..::.GetJoinedEntity
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String, BXSchemeBase) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Члены BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Метод GetJoinedEntityCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockSite..::.GetJoinedEntityCollection
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType, JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>)(String, String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Члены BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Метод GetListInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockSite..::.GetListInternal
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Члены BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockSite..::.Save
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет сущность в базе данных в новой транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет сущность в базе данных в указанной транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Члены BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Метод SetValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockSite..::.SetValue
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Лист перегрузки

Имя | Описание
SetValue(KeyValuePair<(Of <<'(String, Object>)>>), Boolean) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object, Boolean) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Члены BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Метод Update

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockSite..::.Update
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Update()()()() | Изменяет существующую сущность в базе данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update(BXSqlConnection, BXSqlTransaction) | Изменяет существующую сущность в базе данных в указанной транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Члены BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Свойства BXIBlock.BXInfoBlockSite

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlock..::..BXInfoBlockSite
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Тип BXIBlock..::..BXInfoBlockSite предоставляет следующие возможности.

Свойства

Имя | Описание
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Унаследовано от BXEntity)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityId | Возвращает "InfoBlockSite". (Переопределяет BXLinkedEntityEntityId()()()())
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
InfoBlockId | Возвращает идентификатор инфоблока, к коророму привязан сайт.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ModuleId | (Переопределяет BXLinkedEntityModuleId()()()())
SiteId | Возвращает или устанавливает идентификатор сайта, привязанного к инфоблоку. Закодировано кодировщиком.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Свойство EntityId

Свойство BXIBlock..::..BXInfoBlockSite..::.EntityId
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback
Возвращает "InfoBlockSite".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string EntityId { get; }

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Свойство InfoBlockId

Свойство BXIBlock..::..BXInfoBlockSite..::.InfoBlockId
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback
Возвращает идентификатор инфоблока, к коророму привязан сайт.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int InfoBlockId { get; }

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Свойство ModuleId

Свойство BXIBlock..::..BXInfoBlockSite..::.ModuleId
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string ModuleId { get; }

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Свойство SiteId

Свойство BXIBlock..::..BXInfoBlockSite..::.SiteId
Класс BXIBlock..::..BXInfoBlockSite Смотри также Send Feedback
Возвращает или устанавливает идентификатор сайта, привязанного к инфоблоку. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string SiteId { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Смотри также

Класс BXIBlock..::..BXInfoBlockSite
Пространство имен Bitrix.IBlock


Класс BXIBlock.BXInfoBlockSite.Scheme

Класс BXIBlock..::..BXInfoBlockSite..::..Scheme
Класс BXIBlock..::..BXInfoBlockSite Члены Смотри также Send Feedback
Схема сущности-связки "сайт инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class Scheme : BXScheme<BXIBlock..::..BXInfoBlockSite..::..Scheme>

Иерархия наследования

System..::..Object
BXSchemeBase
BXScheme<(Of <(<'BXIBlock..::..BXInfoBlockSite..::..Scheme>)>)>
Bitrix.IBlock..::..BXIBlock..::..BXInfoBlockSite..::..Scheme

Смотри также

Члены BXIBlock..::..BXInfoBlockSite..::..Scheme
Пространство имен Bitrix.IBlock


Члены BXIBlock.BXInfoBlockSite.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlock..::..BXInfoBlockSite..::..Scheme
Класс BXIBlock..::..BXInfoBlockSite..::..Scheme Конструкторы Свойства Смотри также Send Feedback

Класс сущности-связки "сайт инфоблока".

Тип BXIBlock..::..BXInfoBlockSite..::..Scheme предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlock..::..BXInfoBlockSite..::..Scheme |

Свойства

Имя | Описание
InfoBlockId | Описание поля "Идентификатор инфоблока"
Site |
SiteId | Описание поля "Идентификатор сайта"

Смотри также

Класс BXIBlock..::..BXInfoBlockSite..::..Scheme
Пространство имен Bitrix.IBlock


Конструктор BXIBlock.BXInfoBlockSite.Scheme

Конструктор BXIBlock..::..BXInfoBlockSite..::..Scheme
Класс BXIBlock..::..BXInfoBlockSite..::..Scheme Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Scheme()

Смотри также

Класс BXIBlock..::..BXInfoBlockSite..::..Scheme
Пространство имен Bitrix.IBlock


Свойства BXIBlock.BXInfoBlockSite.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlock..::..BXInfoBlockSite..::..Scheme
Класс BXIBlock..::..BXInfoBlockSite..::..Scheme Смотри также Send Feedback

Тип BXIBlock..::..BXInfoBlockSite..::..Scheme предоставляет следующие возможности.

Свойства

Имя | Описание
InfoBlockId | Описание поля "Идентификатор инфоблока"
Site |
SiteId | Описание поля "Идентификатор сайта"

Смотри также

Класс BXIBlock..::..BXInfoBlockSite..::..Scheme
Пространство имен Bitrix.IBlock


Свойство InfoBlockId

Свойство BXIBlock..::..BXInfoBlockSite..::..Scheme..::.InfoBlockId
Класс BXIBlock..::..BXInfoBlockSite..::..Scheme Смотри также Send Feedback
Описание поля "Идентификатор инфоблока"

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase InfoBlockId { get; }

Смотри также

Класс BXIBlock..::..BXInfoBlockSite..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Site

Свойство BXIBlock..::..BXInfoBlockSite..::..Scheme..::.Site
Класс BXIBlock..::..BXInfoBlockSite..::..Scheme Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Scheme Site { get; }

Смотри также

Класс BXIBlock..::..BXInfoBlockSite..::..Scheme
Пространство имен Bitrix.IBlock


Свойство SiteId

Свойство BXIBlock..::..BXInfoBlockSite..::..Scheme..::.SiteId
Класс BXIBlock..::..BXInfoBlockSite..::..Scheme Смотри также Send Feedback
Описание поля "Идентификатор сайта"

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase SiteId { get; }

Смотри также

Класс BXIBlock..::..BXInfoBlockSite..::..Scheme
Пространство имен Bitrix.IBlock


Класс BXIBlock.BXInfoBlockSiteCollection

Класс BXIBlock..::..BXInfoBlockSiteCollection
Класс BXIBlock Члены Смотри также Send Feedback
Коллекция для связки "сайт инфоблока". Содержит связки типа BXIBlock..::..BXInfoBlockSiteCollection

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXInfoBlockSiteCollection : BXEntityCollection<BXIBlock..::..BXInfoBlockSite, BXIBlock..::..BXInfoBlockSiteCollection, BXIBlock..::..BXInfoBlockSite..::..Scheme>

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<' BXIBlock..::..BXInfoBlockSite >)>)>
Bitrix.DataLayer..::..BXEntityCollection <(Of <(<' BXIBlock..::..BXInfoBlockSite, BXIBlock..::..BXInfoBlockSiteCollection, BXIBlock..::..BXInfoBlockSite..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlock..::..BXInfoBlockSiteCollection

Смотри также

Члены BXIBlock..::..BXInfoBlockSiteCollection
Пространство имен Bitrix.IBlock


Члены BXIBlock.BXInfoBlockSiteCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlock..::..BXInfoBlockSiteCollection
Класс BXIBlock..::..BXInfoBlockSiteCollection Конструкторы Методы Смотри также Send Feedback

Класс определяет сущность "инфоблок". Инфоблок представляет собой хранилище однотипной информации (объектов бизнес-логики), сортированной по разделам. Как сущность, инфоблок реализует операции, типовые для сущностей (см. класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Тип BXIBlock..::..BXInfoBlockSiteCollection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlock..::..BXInfoBlockSiteCollection | Конструктор класса.

Методы

Имя | Описание
Add | Добавляет связку "сайт инфоблока" в коллекцию по идентификатору сайта (см. BXSite)
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.
ToList | Формирует список идентификаторов сайтов (см. BXSite) из связок типа "сайт инфоблока".

Смотри также

Класс BXIBlock..::..BXInfoBlockSiteCollection
Пространство имен Bitrix.IBlock


Конструктор BXIBlock.BXInfoBlockSiteCollection

Конструктор BXIBlock..::..BXInfoBlockSiteCollection
Класс BXIBlock..::..BXInfoBlockSiteCollection Смотри также Send Feedback
Конструктор класса.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXInfoBlockSiteCollection()

Смотри также

Класс BXIBlock..::..BXInfoBlockSiteCollection
Пространство имен Bitrix.IBlock


Методы BXIBlock.BXInfoBlockSiteCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlock..::..BXInfoBlockSiteCollection
Класс BXIBlock..::..BXInfoBlockSiteCollection Смотри также Send Feedback

Тип BXIBlock..::..BXInfoBlockSiteCollection предоставляет следующие возможности.

Методы

Имя | Описание
Add | Добавляет связку "сайт инфоблока" в коллекцию по идентификатору сайта (см. BXSite)
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.
ToList | Формирует список идентификаторов сайтов (см. BXSite) из связок типа "сайт инфоблока".

Смотри также

Класс BXIBlock..::..BXInfoBlockSiteCollection
Пространство имен Bitrix.IBlock


Метод Add

Метод BXIBlock..::..BXInfoBlockSiteCollection..::.Add
Класс BXIBlock..::..BXInfoBlockSiteCollection Пример Смотри также Send Feedback
Добавляет связку "сайт инфоблока" в коллекцию по идентификатору сайта (см. BXSite)

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void Add(
    string siteId
)

Параметры

siteId
Type: System..::..String
Идентификатор сайта.

Примеры

Создание нового инфоблока:

CopyC#
int iblockTypeId;

BXIBlock iblock = new BXIBlock();
iblock.TypeId =  iblockTypeId;
iblock.Name = "Автомобили";
iblock.Code = "autos";
iblock.Sites.Add(BXSite.Current.Id);

iblock.ElementName = "Модель автомобиля";
iblock.ElementsName = "Модели автомобилей";
iblock.SectionName = "Производитель автомобиля";
iblock.SectionsName = "Производители автомобилей";

iblock.Description = "Автомобили, сортированные по производителям";
iblock.DescriptionType = BXTextType.Text;

iblock.Save();

Смотри также

Класс BXIBlock..::..BXInfoBlockSiteCollection
Пространство имен Bitrix.IBlock


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockSiteCollection..::.Save
Класс BXIBlock..::..BXInfoBlockSiteCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет все сущности коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет все сущности коллекции, используя указанное соединение. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSiteCollection
Члены BXIBlock..::..BXInfoBlockSiteCollection
Пространство имен Bitrix.IBlock


Метод ToDataTable

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockSiteCollection..::.ToDataTable
Класс BXIBlock..::..BXInfoBlockSiteCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ToDataTable()()()() | Приводит коллекцию к типу DataTable. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable(BXPagingOptions) | Приводит коллекцию к типу DataTable с применением опций постраничной навигации. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlock..::..BXInfoBlockSiteCollection
Члены BXIBlock..::..BXInfoBlockSiteCollection
Пространство имен Bitrix.IBlock


Метод ToList

Метод BXIBlock..::..BXInfoBlockSiteCollection..::.ToList
Класс BXIBlock..::..BXInfoBlockSiteCollection Пример Смотри также Send Feedback
Формирует список идентификаторов сайтов (см. BXSite) из связок типа "сайт инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public List<string> ToList()

Возвращаемое значение

Список идентификаторов сайтов.

Примеры

Проверка инфоблока на принадлежность текущему сайту:

CopyC#
BXIBlock iblock;

if (iblock.Sites.ToList().Contains(BXSite.Current.Id))
{
    // Выполняем работу
}

Смотри также

Класс BXIBlock..::..BXInfoBlockSiteCollection
Пространство имен Bitrix.IBlock


Класс BXIBlock.IndexSynchronizer

Класс BXIBlock..::..IndexSynchronizer
Класс BXIBlock Члены Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class IndexSynchronizer : IBXAgentExecutor

Иерархия наследования

System..::..Object
Bitrix.IBlock..::..BXIBlock..::..IndexSynchronizer

Смотри также

Члены BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Члены BXIBlock.IndexSynchronizer

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlock..::..IndexSynchronizer
Класс BXIBlock..::..IndexSynchronizer Конструкторы Методы Свойства Смотри также Send Feedback

Класс определяет сущность "инфоблок". Инфоблок представляет собой хранилище однотипной информации (объектов бизнес-логики), сортированной по разделам. Как сущность, инфоблок реализует операции, типовые для сущностей (см. класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Тип BXIBlock..::..IndexSynchronizer предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlock..::..IndexSynchronizer |

Методы

Имя | Описание
Execute |
ResolveContentPresence |

Свойства

Имя | Описание
Action |
Agent |
Block |
BlockId |
ElementId |
HasContent |
IsContentPresenceResolved |

Смотри также

Класс BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Конструктор BXIBlock.IndexSynchronizer

Конструктор BXIBlock..::..IndexSynchronizer
Класс BXIBlock..::..IndexSynchronizer Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public IndexSynchronizer()

Смотри также

Класс BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Методы BXIBlock.IndexSynchronizer

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlock..::..IndexSynchronizer
Класс BXIBlock..::..IndexSynchronizer Смотри также Send Feedback

Тип BXIBlock..::..IndexSynchronizer предоставляет следующие возможности.

Методы

Имя | Описание
Execute |
ResolveContentPresence |

Смотри также

Класс BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Метод Execute

Метод BXIBlock..::..IndexSynchronizer..::.Execute
Класс BXIBlock..::..IndexSynchronizer Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool Execute(
    BXSchedulerAgent agent,
    BXParamsBag<Object> parameters
)

Параметры

agent
Type: Bitrix.Services..::..BXSchedulerAgent
parameters
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>

Принадлежности

IBXAgentExecutor..::..Execute(BXSchedulerAgent, BXParamsBag<(Of <<'(Object>)>>))

Смотри также

Класс BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Метод ResolveContentPresence

Метод BXIBlock..::..IndexSynchronizer..::.ResolveContentPresence
Класс BXIBlock..::..IndexSynchronizer Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void ResolveContentPresence()

Смотри также

Класс BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Свойства BXIBlock.IndexSynchronizer

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlock..::..IndexSynchronizer
Класс BXIBlock..::..IndexSynchronizer Смотри также Send Feedback

Тип BXIBlock..::..IndexSynchronizer предоставляет следующие возможности.

Свойства

Имя | Описание
Action |
Agent |
Block |
BlockId |
ElementId |
HasContent |
IsContentPresenceResolved |

Смотри также

Класс BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Свойство Action

Свойство BXIBlock..::..IndexSynchronizer..::.Action
Класс BXIBlock..::..IndexSynchronizer Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlock..::..IndexSynchronizerAction Action { get; }

Смотри также

Класс BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Свойство Agent

Свойство BXIBlock..::..IndexSynchronizer..::.Agent
Класс BXIBlock..::..IndexSynchronizer Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchedulerAgent Agent { get; }

Смотри также

Класс BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Свойство Block

Свойство BXIBlock..::..IndexSynchronizer..::.Block
Класс BXIBlock..::..IndexSynchronizer Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlock Block { get; }

Смотри также

Класс BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Свойство BlockId

Свойство BXIBlock..::..IndexSynchronizer..::.BlockId
Класс BXIBlock..::..IndexSynchronizer Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int BlockId { get; }

Смотри также

Класс BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Свойство ElementId

Свойство BXIBlock..::..IndexSynchronizer..::.ElementId
Класс BXIBlock..::..IndexSynchronizer Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int ElementId { get; set; }

Смотри также

Класс BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Свойство HasContent

Свойство BXIBlock..::..IndexSynchronizer..::.HasContent
Класс BXIBlock..::..IndexSynchronizer Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool HasContent { get; }

Смотри также

Класс BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Свойство IsContentPresenceResolved

Свойство BXIBlock..::..IndexSynchronizer..::.IsContentPresenceResolved
Класс BXIBlock..::..IndexSynchronizer Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool IsContentPresenceResolved { get; }

Смотри также

Класс BXIBlock..::..IndexSynchronizer
Пространство имен Bitrix.IBlock


Перечисление BXIBlock.IndexSynchronizerAction

Перечисление BXIBlock..::..IndexSynchronizerAction
Класс BXIBlock Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public enum IndexSynchronizerAction

Члены

Название члена | Описание
Auto | Авто
Build | Построить индекс
Remove | Удалить индекс
Rebuild | Перестроить

Смотри также

Пространство имен Bitrix.IBlock


Класс BXIBlock.Operations

Класс BXIBlock..::..Operations
Класс BXIBlock Члены Пример Смотри также Send Feedback
Содержит константы для прав на операции с инфоблоками, наличие которых у пользователя можно проверить методом IsUserCanOperate(String). Дополнительным параметром метода является идентификатор инфоблока

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static class Operations

Примеры

Проверка текущего пользователя на наличие права просматривать инфоблок в публичной части сайта:

CopyC#
BXIBlock iblock;

if (iblock.IsUserCanOperate(BXIBlock.Operations.IBlockPublicRead))
{
    // Делаем работу
}
CopyC#
int iblockId;

if (BXIBlock.IsUserCanOperate(iblockId, BXIBlock.Operations.IBlockPublicRead))
{
    // Делаем работу
}

Иерархия наследования

System..::..Object
Bitrix.IBlock..::..BXIBlock..::..Operations

Смотри также

Члены BXIBlock..::..Operations
Пространство имен Bitrix.IBlock


Члены BXIBlock.Operations

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlock..::..Operations
Класс BXIBlock..::..Operations Методы Поля Смотри также Send Feedback

Класс определяет сущность "инфоблок". Инфоблок представляет собой хранилище однотипной информации (объектов бизнес-логики), сортированной по разделам. Как сущность, инфоблок реализует операции, типовые для сущностей (см. класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Тип BXIBlock..::..Operations предоставляет следующие возможности.

Методы

Имя | Описание
GetNames | Запрос имён всех операций

Поля

Имя | Описание
IBlockAdminRead | Обозначает право на просмотр свойств, разделов и элементов инфоблока, а также типов инфоблоков.
IBlockManageAdmin | Обозначает право на добавление, изменение и удаление инфоблоков и типов инфоблоков.
IBlockModifyElements | Обозначает право на добавление, изменение и удаление элементов инфоблока.
IBlockModifySections | Обозначает право на добавление, изменение и удаление разделов инфоблока.
IBlockPublicRead | Обозначает право на просмотр инфоблока в публичной части сайта.

Смотри также

Класс BXIBlock..::..Operations
Пространство имен Bitrix.IBlock


Поля BXIBlock.Operations

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXIBlock..::..Operations
Класс BXIBlock..::..Operations Смотри также Send Feedback

Тип BXIBlock..::..Operations предоставляет следующие возможности.

Поля

Имя | Описание
IBlockAdminRead | Обозначает право на просмотр свойств, разделов и элементов инфоблока, а также типов инфоблоков.
IBlockManageAdmin | Обозначает право на добавление, изменение и удаление инфоблоков и типов инфоблоков.
IBlockModifyElements | Обозначает право на добавление, изменение и удаление элементов инфоблока.
IBlockModifySections | Обозначает право на добавление, изменение и удаление разделов инфоблока.
IBlockPublicRead | Обозначает право на просмотр инфоблока в публичной части сайта.

Смотри также

Класс BXIBlock..::..Operations
Пространство имен Bitrix.IBlock


Поле IBlockAdminRead

Поле BXIBlock..::..Operations..::.IBlockAdminRead
Класс BXIBlock..::..Operations Смотри также Send Feedback
Обозначает право на просмотр свойств, разделов и элементов инфоблока, а также типов инфоблоков.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string IBlockAdminRead

Смотри также

Класс BXIBlock..::..Operations
Пространство имен Bitrix.IBlock


Поле IBlockManageAdmin

Поле BXIBlock..::..Operations..::.IBlockManageAdmin
Класс BXIBlock..::..Operations Смотри также Send Feedback
Обозначает право на добавление, изменение и удаление инфоблоков и типов инфоблоков.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string IBlockManageAdmin

Смотри также

Класс BXIBlock..::..Operations
Пространство имен Bitrix.IBlock


Поле IBlockModifyElements

Поле BXIBlock..::..Operations..::.IBlockModifyElements
Класс BXIBlock..::..Operations Смотри также Send Feedback
Обозначает право на добавление, изменение и удаление элементов инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string IBlockModifyElements

Смотри также

Класс BXIBlock..::..Operations
Пространство имен Bitrix.IBlock


Поле IBlockModifySections

Поле BXIBlock..::..Operations..::.IBlockModifySections
Класс BXIBlock..::..Operations Смотри также Send Feedback
Обозначает право на добавление, изменение и удаление разделов инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string IBlockModifySections

Смотри также

Класс BXIBlock..::..Operations
Пространство имен Bitrix.IBlock


Поле IBlockPublicRead

Поле BXIBlock..::..Operations..::.IBlockPublicRead
Класс BXIBlock..::..Operations Смотри также Send Feedback
Обозначает право на просмотр инфоблока в публичной части сайта.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string IBlockPublicRead

Смотри также

Класс BXIBlock..::..Operations
Пространство имен Bitrix.IBlock


Методы BXIBlock.Operations

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlock..::..Operations
Класс BXIBlock..::..Operations Смотри также Send Feedback

Тип BXIBlock..::..Operations предоставляет следующие возможности.

Методы

Имя | Описание
GetNames | Запрос имён всех операций

Смотри также

Класс BXIBlock..::..Operations
Пространство имен Bitrix.IBlock


Метод GetNames

Метод BXIBlock..::..Operations..::.GetNames
Класс BXIBlock..::..Operations Смотри также Send Feedback
Запрос имён всех операций

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string[] GetNames()

Возвращаемое значение

Смотри также

Класс BXIBlock..::..Operations
Пространство имен Bitrix.IBlock


Класс BXIBlock.Scheme

Класс BXIBlock..::..Scheme
Класс BXIBlock Члены Смотри также Send Feedback
Схема сущности "инфоблок".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class Scheme : BXScheme<BXIBlock..::..Scheme>

Иерархия наследования

System..::..Object
BXSchemeBase
BXScheme<(Of <(<'BXIBlock..::..Scheme>)>)>
Bitrix.IBlock..::..BXIBlock..::..Scheme

Смотри также

Члены BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Члены BXIBlock.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlock..::..Scheme
Класс BXIBlock..::..Scheme Конструкторы Свойства Смотри также Send Feedback

Класс определяет сущность "инфоблок". Инфоблок представляет собой хранилище однотипной информации (объектов бизнес-логики), сортированной по разделам. Как сущность, инфоблок реализует операции, типовые для сущностей (см. класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Тип BXIBlock..::..Scheme предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlock..::..Scheme |

Свойства

Имя | Описание
Active | Описание поля "Активен?" ("Y" или "N").
CheckPermissions | Описание поля "Выбирать только разрешенные для публичного просмотра?".
Code | Описание поля "Символьный код".
CreateDate | Описание поля "Дата создания".
Description | Описание поля "Описание".
DescriptionType | Описание поля "Тип описания" ("T" или "H").
ElementName | Описание поля "Название элемента".
ElementsName | Описание поля "Название группы элементов".
ID | Описание поля "Идентификатор инфоблока". Первичный ключ.
ImageId | Описание поля "Идентификатор файла с изображением".
IndexContent | Описание поля "Индексировать контент?".
Name | Описание поля "Название инфоблока".
SectionName | Описание поля "Название раздела".
SectionsName | Описание поля "Название группы разделов".
Sites | Описание поля "Связанные сайты".
Sort | Описание поля "Порядок сортировки".
Type | Описание поля "Тип инфоблока".
UpdateDate | Описание поля "Дата изменения".
XmlCaptionInfo | Описание поля "Информация о подписях" Хранит данные о подписях инфоблока ( Элемент, элементы, раздел, разделы и тд. ) В XML формате, для доступа используется объект CaptionsInfo
XmlId | Описание поля "Идентификатор для XML".

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Конструктор BXIBlock.Scheme

Конструктор BXIBlock..::..Scheme
Класс BXIBlock..::..Scheme Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Scheme()

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойства BXIBlock.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlock..::..Scheme
Класс BXIBlock..::..Scheme Смотри также Send Feedback

Тип BXIBlock..::..Scheme предоставляет следующие возможности.

Свойства

Имя | Описание
Active | Описание поля "Активен?" ("Y" или "N").
CheckPermissions | Описание поля "Выбирать только разрешенные для публичного просмотра?".
Code | Описание поля "Символьный код".
CreateDate | Описание поля "Дата создания".
Description | Описание поля "Описание".
DescriptionType | Описание поля "Тип описания" ("T" или "H").
ElementName | Описание поля "Название элемента".
ElementsName | Описание поля "Название группы элементов".
ID | Описание поля "Идентификатор инфоблока". Первичный ключ.
ImageId | Описание поля "Идентификатор файла с изображением".
IndexContent | Описание поля "Индексировать контент?".
Name | Описание поля "Название инфоблока".
SectionName | Описание поля "Название раздела".
SectionsName | Описание поля "Название группы разделов".
Sites | Описание поля "Связанные сайты".
Sort | Описание поля "Порядок сортировки".
Type | Описание поля "Тип инфоблока".
UpdateDate | Описание поля "Дата изменения".
XmlCaptionInfo | Описание поля "Информация о подписях" Хранит данные о подписях инфоблока ( Элемент, элементы, раздел, разделы и тд. ) В XML формате, для доступа используется объект CaptionsInfo
XmlId | Описание поля "Идентификатор для XML".

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Active

Свойство BXIBlock..::..Scheme..::.Active
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Активен?" ("Y" или "N").

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Active { get; }

Заметки

При использовании в фильтре необходимо указывать значения "Y" и "N" вместо true или false.

Примеры

Получение списка активных инфоблоков, принадлежащих определенному типу и сайту:

CopyC#
int iblockTypeId;
string siteId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId));
filter.Add(new BXFilterItem(BXIBlock.Fields.Active, BXSqlFilterOperators.Equal, "Y"));
filter.Add(new BXFilterItem(BXIBlock.Fields.Sites.SiteId, BXSqlFilterOperators.Equal, siteId));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlock.Fields.Sort, BXOrderByDirection.Asc);

BXIBlockCollection iblocks = BXIBlock.GetList(filter, orderBy);

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство CheckPermissions

Свойство BXIBlock..::..Scheme..::.CheckPermissions
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Выбирать только разрешенные для публичного просмотра?".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase CheckPermissions { get; }

Заметки

Если равно true, то выбирает те инфоблоки, для которых пользователь обладает правом на операцию IBlockRead.

При использовании в фильтре поле должно обязательно использоваться в виде равенства true/"Y"

Примеры

Выборка элементов из инфоблоков, для которых разрешен просмотр в публичной части:

CopyC#
BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.CheckPermissions, BXSqlFilterOperators.Equal, true));

BXIBlockCollection iblocks = BXIBlock.GetList(filter, null);

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Code

Свойство BXIBlock..::..Scheme..::.Code
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Символьный код".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Code { get; }

Примеры

Получение инфоблока по его символьному коду:

CopyC#
BXIBlock GetByCode(string code)
{
    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlock.Fields.Code, BXSqlFilterOperators.Equal, code));

    BXIBlockCollection iblocks = BXIBlock.GetList(filter, null);
    return iblocks.Count != 0 ? iblocks[0] : null;
}

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство CreateDate

Свойство BXIBlock..::..Scheme..::.CreateDate
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Дата создания".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase CreateDate { get; }

Примеры

Получение списка недавно добавленных инфоблоков:

CopyC#
BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.CreateDate, BXSqlFilterOperators.GreaterOrEqual, DateTime.Now.AddDays(-14)));

BXIBlockCollection iblocks = BXIBlock.GetList(filter, null);

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Description

Свойство BXIBlock..::..Scheme..::.Description
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Описание".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Description { get; }

Примеры

Получение инфоблоков, у которых описание содержит HTML со словом "битрикс":

CopyC#
string word = "битрикс";

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.Description, BXSqlFilterOperators.Like, word));
filter.Add(new BXFilterItem(BXIBlock.Fields.DescriptionType, BXSqlFilterOperators.Equal, "H"));

BXIBlockCollection iblocks = BXIBlock.GetList(filter, null);

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство DescriptionType

Свойство BXIBlock..::..Scheme..::.DescriptionType
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Тип описания" ("T" или "H").

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase DescriptionType { get; }

Заметки

При использовании в фильтре необходимо указывать значения "T" - для текста и "H" - для HTML.

Примеры

Получение инфоблоков, у которых описание содержит HTML со словом "битрикс":

CopyC#
string word = "битрикс";

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.Description, BXSqlFilterOperators.Like, word));
filter.Add(new BXFilterItem(BXIBlock.Fields.DescriptionType, BXSqlFilterOperators.Equal, "H"));

BXIBlockCollection iblocks = BXIBlock.GetList(filter, null);

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ElementName

Свойство BXIBlock..::..Scheme..::.ElementName
Класс BXIBlock..::..Scheme Смотри также Send Feedback
Описание поля "Название элемента".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ElementName { get; }

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ElementsName

Свойство BXIBlock..::..Scheme..::.ElementsName
Класс BXIBlock..::..Scheme Смотри также Send Feedback
Описание поля "Название группы элементов".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ElementsName { get; }

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ID

Свойство BXIBlock..::..Scheme..::.ID
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор инфоблока". Первичный ключ.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ID { get; }

Примеры

Получение списка элементов инфоблока:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ImageId

Свойство BXIBlock..::..Scheme..::.ImageId
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор файла с изображением".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ImageId { get; }

Примеры

Получение списка инфоблоков, у которых задано изображение:

CopyC#
int iblockTypeId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId));
filter.Add(new BXFilterItem(BXIBlock.Fields.ImageId, BXSqlFilterOperators.NotEqual, null));

BXIBlockCollection iblocks = BXIBlock.GetList(filter, null);

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство IndexContent

Свойство BXIBlock..::..Scheme..::.IndexContent
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Индексировать контент?".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase IndexContent { get; }

Примеры

Получение списка инфоблоков, индексируемых для полнотекстового поиска:

CopyC#
BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.IndexContent, BXSqlFilterOperators.Equal, "Y"));

BXIBlockCollection iblocks = BXIBlock.GetList(filter, null);

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Name

Свойство BXIBlock..::..Scheme..::.Name
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Название инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Name { get; }

Примеры

Переупорядочивание инфоблоков по имени:

CopyC#
int iblockTypeId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlock.Fields.Name, BXOrderByDirection.Asc);

int i = 0;
foreach (BXIBlock iblock in BXIBlock.GetList(filter, orderBy))
{
    iblock.Sort = (i += 10);
    iblock.Save();
}

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство SectionName

Свойство BXIBlock..::..Scheme..::.SectionName
Класс BXIBlock..::..Scheme Смотри также Send Feedback
Описание поля "Название раздела".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase SectionName { get; }

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство SectionsName

Свойство BXIBlock..::..Scheme..::.SectionsName
Класс BXIBlock..::..Scheme Смотри также Send Feedback
Описание поля "Название группы разделов".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase SectionsName { get; }

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Sites

Свойство BXIBlock..::..Scheme..::.Sites
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Связанные сайты".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlock..::..BXInfoBlockSite..::..Scheme Sites { get; }

Примеры

Получение списка активных инфоблоков, принадлежащих определенному типу и сайту:

CopyC#
int iblockTypeId;
string siteId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId));
filter.Add(new BXFilterItem(BXIBlock.Fields.Active, BXSqlFilterOperators.Equal, "Y"));
filter.Add(new BXFilterItem(BXIBlock.Fields.Sites.SiteId, BXSqlFilterOperators.Equal, siteId));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlock.Fields.Sort, BXOrderByDirection.Asc);

BXIBlockCollection iblocks = BXIBlock.GetList(filter, orderBy);

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Sort

Свойство BXIBlock..::..Scheme..::.Sort
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Порядок сортировки".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Sort { get; }

Примеры

Получение списка активных инфоблоков, принадлежащих определенному типу и сайту:

CopyC#
int iblockTypeId;
string siteId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId));
filter.Add(new BXFilterItem(BXIBlock.Fields.Active, BXSqlFilterOperators.Equal, "Y"));
filter.Add(new BXFilterItem(BXIBlock.Fields.Sites.SiteId, BXSqlFilterOperators.Equal, siteId));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlock.Fields.Sort, BXOrderByDirection.Asc);

BXIBlockCollection iblocks = BXIBlock.GetList(filter, orderBy);

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Type

Свойство BXIBlock..::..Scheme..::.Type
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Тип инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockType..::..Scheme Type { get; }

Примеры

Получение списка активных инфоблоков, принадлежащих определенному типу и сайту:

CopyC#
int iblockTypeId;
string siteId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId));
filter.Add(new BXFilterItem(BXIBlock.Fields.Active, BXSqlFilterOperators.Equal, "Y"));
filter.Add(new BXFilterItem(BXIBlock.Fields.Sites.SiteId, BXSqlFilterOperators.Equal, siteId));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlock.Fields.Sort, BXOrderByDirection.Asc);

BXIBlockCollection iblocks = BXIBlock.GetList(filter, orderBy);

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство UpdateDate

Свойство BXIBlock..::..Scheme..::.UpdateDate
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Дата изменения".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase UpdateDate { get; }

Примеры

Получение списка недавно измененных инфоблоков:

CopyC#
BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.UpdateDate, BXSqlFilterOperators.GreaterOrEqual, DateTime.Now.AddDays(-14)));

BXIBlockCollection iblocks = BXIBlock.GetList(filter, null);

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство XmlCaptionInfo

Свойство BXIBlock..::..Scheme..::.XmlCaptionInfo
Класс BXIBlock..::..Scheme Смотри также Send Feedback
Описание поля "Информация о подписях" Хранит данные о подписях инфоблока ( Элемент, элементы, раздел, разделы и тд. ) В XML формате, для доступа используется объект CaptionsInfo

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase XmlCaptionInfo { get; }

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Свойство XmlId

Свойство BXIBlock..::..Scheme..::.XmlId
Класс BXIBlock..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор для XML".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase XmlId { get; }

Примеры

Получение инфоблока по его идентификатору для XML:

CopyC#
BXIBlock GetByXmlId(string xmlId)
{
    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlock.Fields.XmlId, BXSqlFilterOperators.Equal, xmlId));

    BXIBlockCollection iblocks = BXIBlock.GetList(filter, null);
    return iblocks.Count != 0 ? iblocks[0] : null;
}

Смотри также

Класс BXIBlock..::..Scheme
Пространство имен Bitrix.IBlock


Класс BXIBlockCaptionsInfo

Класс BXIBlockCaptionsInfo
Члены Смотри также Send Feedback
Содержит в подписи к инфоблокам

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXIBlockCaptionsInfo

Иерархия наследования

System..::..Object
Bitrix.IBlock..::..BXIBlockCaptionsInfo

Смотри также

Члены BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Члены BXIBlockCaptionsInfo

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockCaptionsInfo
Класс BXIBlockCaptionsInfo Конструкторы Методы Поля Свойства Смотри также Send Feedback

Тип BXIBlockCaptionsInfo предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockCaptionsInfo | Конструктор, параметр - Encoder для кодировки полей объекта - подписей инфоблока

Методы

Имя | Описание
Load | Разбирает строку xmlString ( передается значение поля XmlCaptionsInfo ) и записывает подписи в свойства объекта
Save | Возвращает xml для записи в поле инфоблока - XmlCaptionsInfo

Поля

Имя | Описание
addElementTag |
addSectionTag |
changeElementTag |
changeSectionTag |
deleteElementTag |
deleteSectionTag |
elementListTag |
elementNameTag |
elementsNameTag |
modifyingElementTag |
modifyingSectionTag |
newElementTag |
newSectionTag |
rootNodeName |
sectionListTag |
sectionNameTag |
sectionsNameTag |

Свойства

Имя | Описание
AddElement | Подпись инфоблока "Добавить элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности
AddSection | Подпись инфоблока "Добавить раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности
ChangeElement | Подпись инфоблока "Изменить элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности
ChangeSection | Подпись инфоблока "Изменить раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности
DeleteElement | Подпись инфоблока "Удалить элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности
DeleteSection | Подпись инфоблока "Удалить раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности
ElementList | Подпись инфоблока "Список элементов" ЗАКОДИРОВАНО текущим кодировщиком сущности
ElementName | Подпись инфоблока "Элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности
ElementsName | Подпись инфоблока "Элементы" ЗАКОДИРОВАНО текущим кодировщиком сущности
IsLoaded | Свойство показывает, загружены ли XML - данные в объект
ModifyingElement | Подпись инфоблока "Редактирование элемента" ЗАКОДИРОВАНО текущим кодировщиком сущности
ModifyingSection | Подпись инфоблока "Редактирование раздела" ЗАКОДИРОВАНО текущим кодировщиком сущности
NewElement | Подпись инфоблока "Новый элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности
NewSection | Подпись инфоблока "Новый раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности
SectionList | Подпись инфоблока "Список разделов" ЗАКОДИРОВАНО текущим кодировщиком сущности
SectionName | Подпись инфоблока "Раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности
SectionsName | Подпись инфоблока "Разделы" ЗАКОДИРОВАНО текущим кодировщиком сущности

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Конструктор BXIBlockCaptionsInfo

Конструктор BXIBlockCaptionsInfo
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Конструктор, параметр - Encoder для кодировки полей объекта - подписей инфоблока

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockCaptionsInfo(
    IBXTextEncoder Encoder
)

Параметры

Encoder
Type: IBXTextEncoder

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поля BXIBlockCaptionsInfo

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXIBlockCaptionsInfo
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Тип BXIBlockCaptionsInfo предоставляет следующие возможности.

Поля

Имя | Описание
addElementTag |
addSectionTag |
changeElementTag |
changeSectionTag |
deleteElementTag |
deleteSectionTag |
elementListTag |
elementNameTag |
elementsNameTag |
modifyingElementTag |
modifyingSectionTag |
newElementTag |
newSectionTag |
rootNodeName |
sectionListTag |
sectionNameTag |
sectionsNameTag |

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле addElementTag

Поле BXIBlockCaptionsInfo..::.addElementTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string addElementTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле addSectionTag

Поле BXIBlockCaptionsInfo..::.addSectionTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string addSectionTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле changeElementTag

Поле BXIBlockCaptionsInfo..::.changeElementTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string changeElementTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле changeSectionTag

Поле BXIBlockCaptionsInfo..::.changeSectionTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string changeSectionTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле deleteElementTag

Поле BXIBlockCaptionsInfo..::.deleteElementTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string deleteElementTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле deleteSectionTag

Поле BXIBlockCaptionsInfo..::.deleteSectionTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string deleteSectionTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле elementListTag

Поле BXIBlockCaptionsInfo..::.elementListTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string elementListTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле elementNameTag

Поле BXIBlockCaptionsInfo..::.elementNameTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string elementNameTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле elementsNameTag

Поле BXIBlockCaptionsInfo..::.elementsNameTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string elementsNameTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле modifyingElementTag

Поле BXIBlockCaptionsInfo..::.modifyingElementTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string modifyingElementTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле modifyingSectionTag

Поле BXIBlockCaptionsInfo..::.modifyingSectionTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string modifyingSectionTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле newElementTag

Поле BXIBlockCaptionsInfo..::.newElementTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string newElementTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле newSectionTag

Поле BXIBlockCaptionsInfo..::.newSectionTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string newSectionTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле rootNodeName

Поле BXIBlockCaptionsInfo..::.rootNodeName
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string rootNodeName

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле sectionListTag

Поле BXIBlockCaptionsInfo..::.sectionListTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string sectionListTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле sectionNameTag

Поле BXIBlockCaptionsInfo..::.sectionNameTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string sectionNameTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Поле sectionsNameTag

Поле BXIBlockCaptionsInfo..::.sectionsNameTag
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string sectionsNameTag

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Методы BXIBlockCaptionsInfo

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockCaptionsInfo
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Тип BXIBlockCaptionsInfo предоставляет следующие возможности.

Методы

Имя | Описание
Load | Разбирает строку xmlString ( передается значение поля XmlCaptionsInfo ) и записывает подписи в свойства объекта
Save | Возвращает xml для записи в поле инфоблока - XmlCaptionsInfo

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Метод Load

Метод BXIBlockCaptionsInfo..::.Load
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Разбирает строку xmlString ( передается значение поля XmlCaptionsInfo ) и записывает подписи в свойства объекта

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void Load(
    string xmlString
)

Параметры

xmlString
Type: System..::..String

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Метод Save

Метод BXIBlockCaptionsInfo..::.Save
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Возвращает xml для записи в поле инфоблока - XmlCaptionsInfo

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Save()

Возвращаемое значение

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойства BXIBlockCaptionsInfo

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockCaptionsInfo
Класс BXIBlockCaptionsInfo Смотри также Send Feedback

Тип BXIBlockCaptionsInfo предоставляет следующие возможности.

Свойства

Имя | Описание
AddElement | Подпись инфоблока "Добавить элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности
AddSection | Подпись инфоблока "Добавить раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности
ChangeElement | Подпись инфоблока "Изменить элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности
ChangeSection | Подпись инфоблока "Изменить раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности
DeleteElement | Подпись инфоблока "Удалить элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности
DeleteSection | Подпись инфоблока "Удалить раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности
ElementList | Подпись инфоблока "Список элементов" ЗАКОДИРОВАНО текущим кодировщиком сущности
ElementName | Подпись инфоблока "Элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности
ElementsName | Подпись инфоблока "Элементы" ЗАКОДИРОВАНО текущим кодировщиком сущности
IsLoaded | Свойство показывает, загружены ли XML - данные в объект
ModifyingElement | Подпись инфоблока "Редактирование элемента" ЗАКОДИРОВАНО текущим кодировщиком сущности
ModifyingSection | Подпись инфоблока "Редактирование раздела" ЗАКОДИРОВАНО текущим кодировщиком сущности
NewElement | Подпись инфоблока "Новый элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности
NewSection | Подпись инфоблока "Новый раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности
SectionList | Подпись инфоблока "Список разделов" ЗАКОДИРОВАНО текущим кодировщиком сущности
SectionName | Подпись инфоблока "Раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности
SectionsName | Подпись инфоблока "Разделы" ЗАКОДИРОВАНО текущим кодировщиком сущности

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство AddElement

Свойство BXIBlockCaptionsInfo..::.AddElement
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Добавить элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string AddElement { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство AddSection

Свойство BXIBlockCaptionsInfo..::.AddSection
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Добавить раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string AddSection { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство ChangeElement

Свойство BXIBlockCaptionsInfo..::.ChangeElement
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Изменить элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ChangeElement { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство ChangeSection

Свойство BXIBlockCaptionsInfo..::.ChangeSection
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Изменить раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ChangeSection { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство DeleteElement

Свойство BXIBlockCaptionsInfo..::.DeleteElement
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Удалить элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string DeleteElement { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство DeleteSection

Свойство BXIBlockCaptionsInfo..::.DeleteSection
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Удалить раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string DeleteSection { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство ElementList

Свойство BXIBlockCaptionsInfo..::.ElementList
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Список элементов" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ElementList { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство ElementName

Свойство BXIBlockCaptionsInfo..::.ElementName
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ElementName { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство ElementsName

Свойство BXIBlockCaptionsInfo..::.ElementsName
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Элементы" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ElementsName { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство IsLoaded

Свойство BXIBlockCaptionsInfo..::.IsLoaded
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Свойство показывает, загружены ли XML - данные в объект

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool IsLoaded { get; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство ModifyingElement

Свойство BXIBlockCaptionsInfo..::.ModifyingElement
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Редактирование элемента" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ModifyingElement { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство ModifyingSection

Свойство BXIBlockCaptionsInfo..::.ModifyingSection
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Редактирование раздела" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ModifyingSection { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство NewElement

Свойство BXIBlockCaptionsInfo..::.NewElement
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Новый элемент" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string NewElement { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство NewSection

Свойство BXIBlockCaptionsInfo..::.NewSection
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Новый раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string NewSection { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство SectionList

Свойство BXIBlockCaptionsInfo..::.SectionList
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Список разделов" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string SectionList { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство SectionName

Свойство BXIBlockCaptionsInfo..::.SectionName
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Раздел" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string SectionName { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Свойство SectionsName

Свойство BXIBlockCaptionsInfo..::.SectionsName
Класс BXIBlockCaptionsInfo Смотри также Send Feedback
Подпись инфоблока "Разделы" ЗАКОДИРОВАНО текущим кодировщиком сущности

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string SectionsName { get; set; }

Смотри также

Класс BXIBlockCaptionsInfo
Пространство имен Bitrix.IBlock


Класс BXIBlockCollection

Класс BXIBlockCollection
Члены Пример Смотри также Send Feedback
Коллекция инфоблоков. См. BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXIBlockCollection : BXEntityCollection<BXIBlock, BXIBlockCollection, BXIBlock..::..Scheme>

Примеры

Выборка всех инфоблоков, принадлежащих определенному типу:

CopyC#
int iblockTypeId;

BXIBlockCollection iblocks = BXIBlock.GetList(
    new BXFilter(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId, iblockTypeId)),
    null
);

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<' BXIBlock >)>)>
Bitrix.DataLayer..::..BXEntityCollection <(Of <(<' BXIBlock, BXIBlockCollection, BXIBlock..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlockCollection

Смотри также

Члены BXIBlockCollection
Пространство имен Bitrix.IBlock


Члены BXIBlockCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockCollection
Класс BXIBlockCollection Конструкторы Методы Смотри также Send Feedback

Тип BXIBlockCollection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockCollection | Конструктор по умолчанию.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Смотри также

Класс BXIBlockCollection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockCollection

Конструктор BXIBlockCollection
Класс BXIBlockCollection Смотри также Send Feedback
Конструктор по умолчанию.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockCollection()

Смотри также

Класс BXIBlockCollection
Пространство имен Bitrix.IBlock


Методы BXIBlockCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockCollection
Класс BXIBlockCollection Смотри также Send Feedback

Тип BXIBlockCollection предоставляет следующие возможности.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Смотри также

Класс BXIBlockCollection
Пространство имен Bitrix.IBlock


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockCollection..::.Save
Класс BXIBlockCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет все сущности коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет все сущности коллекции, используя указанное соединение. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockCollection
Члены BXIBlockCollection
Пространство имен Bitrix.IBlock


Метод ToDataTable

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockCollection..::.ToDataTable
Класс BXIBlockCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ToDataTable()()()() | Приводит коллекцию к типу DataTable. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable(BXPagingOptions) | Приводит коллекцию к типу DataTable с применением опций постраничной навигации. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockCollection
Члены BXIBlockCollection
Пространство имен Bitrix.IBlock


Класс BXIBlockCommonCollection

Класс BXIBlockCommonCollection
Члены Пример Смотри также Send Feedback
Обобщенная коллекция для сущностей типа BXIBlockElement и BXIBlockSection.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXIBlockCommonCollection : List<BXEntity>

Примеры

Выборка списка разделов и элементов инфоблока:

CopyC#
int iblockId;

BXFormFilter formFilter = new BXFormFilter();
formFilter.Add("IBlockId", iblockId, BXSqlFilterOperators.Equal);

BXIBlockCommonCollection items = BXIBlockSection.GetMixedList(formFilter, "Id ASC");

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<' BXEntity >)>)>
Bitrix.IBlock..::..BXIBlockCommonCollection

Смотри также

Члены BXIBlockCommonCollection
Пространство имен Bitrix.IBlock


Члены BXIBlockCommonCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockCommonCollection
Класс BXIBlockCommonCollection Конструкторы Смотри также Send Feedback

Тип BXIBlockCommonCollection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockCommonCollection | Конструктор по умолчанию.

Смотри также

Класс BXIBlockCommonCollection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockCommonCollection

Конструктор BXIBlockCommonCollection
Класс BXIBlockCommonCollection Смотри также Send Feedback
Конструктор по умолчанию.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockCommonCollection()

Смотри также

Класс BXIBlockCommonCollection
Пространство имен Bitrix.IBlock


Класс BXIBlockElement

Класс BXIBlockElement
Члены Пример Смотри также Send Feedback
Класс определяет сущность "элемент инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXIBlockElement : BXEntity<BXIBlockElement, BXIBlockElementCollection, BXIBlockElement..::..Scheme>

Заметки

Элемент инфоблока является единицой типизированной информации и является аналогом записи в таблице базы данных, в то вермя как аналогом самой таблицы является инфоблок. Элемент инфоблока имеет ряд предопределенных свойств и может быть расширен пользовательскими свойствами.

Элементы инфоблока принадлежат какому-то инфоблоку и могут располагаться в одном или нескольких разделах (см. BXIBlockElementCollection)

Примеры

Выборка всех элементов инфоблока:

CopyC#
const int IBlockId;

protected BXIBlockElementCollection GetElements()
{
    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, IBlockId));

    BXOrderBy orderBy = new BXOrderBy();
    orderBy.Add(BXIBlockElement.Fields.Sort, BXOrderByDirection.Asc);

    return BXIBlockElement.GetList(filter, orderBy);
}

Вывод элементов инфоблока в теле ASPX-страницы:

CopyC#
<%
    foreach (BXIBlockElement element in GetElements())
    {
    %>
    <h3><%= element.Name %></h3>
    <p style="overflow: hidden">
        <% if (element.PreviewImage != null) { %>
            <img src="<%= element.PreviewImage.FilePath %>" alt="<%= element.PreviewImage.Description %>" style="float: left; width: 64px" />
        <% } %>
        <%= element.PreviewText %>
    </p>
    <hr />
    <%
    }
 %>

Выборка активных на данный момент элементов из раздела инфоблока:

CopyC#
const int IBlockId;
const int SectionId;

protected BXIBlockElementCollection GetElements()
{
    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, IBlockId));
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.Sections.Section.ID, BXSqlFilterOperators.Equal, SectionId));
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.Active, BXSqlFilterOperators.Equal, "Y"));
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.ActiveDate, BXSqlFilterOperators.Equal, null));

    BXOrderBy orderBy = new BXOrderBy();
    orderBy.Add(BXIBlockElement.Fields.Sort, BXOrderByDirection.Asc);

    return BXIBlockElement.GetList(filter, orderBy);
}

Создание нового элемента инфоблока с привязкой к разделу:

CopyC#
    const int IBlockId;
    const int SectionId;

    private void AddIBlockElement()
    {
        BXIBlockElement element = new BXIBlockElement();
        element.Name = "Lorem ipsum";
        element.IBlockId = IBlockId;
        element.Sections.Add(SectionId);

        element.PreviewTextType = BXTextType.Text;
        element.PreviewText =
@"Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/preview.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Preview Image");
            file.ValidateAsImage(100*1024, 100, 100);
            file.Save();

            element.PreviewImageId = file.Id;
        }

        element.DetailTextType = BXTextType.Html;
        element.DetailText =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/detail.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Detail Image");
            file.ValidateAsImage(2 * 1024 * 1024, 2000, 2000);
            file.Save();

            element.DetailImageId = file.Id;
        }

        element.ActiveFromDate = new DateTime(2009, 1, 1);

        element.Save();
    }

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXEntity
Bitrix.DataLayer..::..BXEntity <(Of <(<'BXIBlockElement, BXIBlockElementCollection, BXIBlockElement..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlockElement

Смотри также

Члены BXIBlockElement
Пространство имен Bitrix.IBlock


Члены BXIBlockElement

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockElement
Класс BXIBlockElement Конструкторы Методы Поля Свойства Смотри также Send Feedback

Тип BXIBlockElement предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockElement | Перегруженный.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..CountInternal(BXFilter))
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..CreateAfterSuccess()()()())
CreateCustomFieldIfNeed |
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..DeleteAfterSuccess()()()())
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetCustomFieldsKeyInternal(String))
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetSections |
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IncViewsCount | Перегруженный.
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..UpdateAfterSuccess()()()())
VerifyEntry | (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..VerifyEntry()()()())

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Свойства

Имя | Описание
Active | Возвращает или устанавливает, активен ли элемент инфоблока.
ActiveFromDate | Возвращает или устанавливает, дату и время начала активности элемента инфоблока.
ActiveToDate | Возвращает или устанавливает, дату и время окончания активности элемента инфоблока.
Code | Возвращает или устанавливает символьный код элемента инфоблока. Закодировано кодировщиком.
CreateDate | Возвращает или устанавливает дату создания элемента инфоблока.
CreatedBy | Возвращает или устанавливает идентификатор пользователя, создавшего элемент инфоблока. (см. BXUser)
CreatedByUser | Возвращает пользователя, создавшего элемент инфоблока.
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Переопределяет BXEntity..::..CustomFieldsKey)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DetailImage | Возвращает сущность "файл" для элемента инфоблока, заданную свойством DetailImageId.
DetailImageId | Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится изображение для детального описания элемента инфоблока.
DetailText | Возвращает или устанавливает текст детального описания инфоблока. Закодировано кодировщиком.
DetailTextType | Возвращает или устанавливает тип текста детального описания инфоблока (текст или HTML).
EntityId | Возвращает "IBlockElement". (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..EntityId)
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
IBlock | Запрос инфоблока
IBlockId | Возвращает или устанавливает идентификатор инфоблока, к которому принадлежит элемент. (см. BXIBlock)
Id | Возвращает или устанавливает идентификатор элемента инфоблока. Первичный ключ.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ModifiedBy | Возвращает или устанавливает идентификатор пользователя, изменившего элемент инфоблока. (см. BXUser)
ModifiedByUser | Возвращает пользователя, изменившего элемент инфоблока.
ModuleId | Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..ModuleId)
Name | Возвращает или устанавливает название элемента инфоблока. Закодировано кодировщиком.
PreviewImage | Возвращает сущность "файл" для элемента инфоблока, заданную свойством PreviewImageId.
PreviewImageId | Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится изображение для анонса элемента инфоблока.
PreviewText | Возвращает или устанавливает текст анонса инфоблока. Закодировано кодировщиком.
PreviewTextType | Возвращает или устанавливает тип текста анонса инфоблока (текст или HTML).
Properties | Возвращает коллекцию пользовательских свойств. См. свойство CustomValues.
Sections | Возвращает коллекцию связок "раздел элемента инфоблока" для данного элемента.
Sort | Возвращает или устанавливает порядок сортировки элемента инфоблока.
Tags | Возвращает или устанавливает теги элемента инфоблока. Закодировано кодировщиком.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateDate | Возвращает или устанавливает дату последнего изменения элемента инфоблока.
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ViewsCount | Возвращает или устанавливает количество просмотров элемента (для фотогалереи ).
XmlId | Возвращает или устанавливает идентификатор элемента инфоблока для экспорта в XML. Закодировано кодировщиком.

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElement

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXIBlockElement
Класс BXIBlockElement Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXIBlockElement()()()() | Создает экземпляр сущности "элемент инфоблока"
BXIBlockElement(IBXTextEncoder) | Создает экземпляр сущности "элемент инфоблока" с выбранным кодировщиком текстовых полей.
BXIBlockElement(Int32, String) | Создает экземпляр сущности "элемент инфоблока".
BXIBlockElement(Int32, String, IBXTextEncoder) | Создает экземпляр сущности "элемент инфоблока" с выбранным кодировщиком текстовых полей.

Смотри также

Класс BXIBlockElement
Члены BXIBlockElement
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElement

Конструктор BXIBlockElement
Класс BXIBlockElement Смотри также Send Feedback
Создает экземпляр сущности "элемент инфоблока"

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockElement()

Смотри также

Класс BXIBlockElement
Перегрузка BXIBlockElement
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElement ()

Конструктор BXIBlockElement ()
Класс BXIBlockElement Смотри также Send Feedback
Создает экземпляр сущности "элемент инфоблока" с выбранным кодировщиком текстовых полей.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockElement(
    IBXTextEncoder textEncoder
)

Параметры

textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей.

Смотри также

Класс BXIBlockElement
Перегрузка BXIBlockElement
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElement (Int32, String)

Конструктор BXIBlockElement (Int32, String)
Класс BXIBlockElement Смотри также Send Feedback
Создает экземпляр сущности "элемент инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockElement(
    int iblockId,
    string name
)

Параметры

iblockId
Type: System..::..Int32
Идентификатор родительского инфоблока.
name
Type: System..::..String
Название элемента инфоблока.

Смотри также

Класс BXIBlockElement
Перегрузка BXIBlockElement
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElement (Int32, String, )

Конструктор BXIBlockElement (Int32, String, )
Класс BXIBlockElement Смотри также Send Feedback
Создает экземпляр сущности "элемент инфоблока" с выбранным кодировщиком текстовых полей.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockElement(
    int iblockId,
    string name,
    IBXTextEncoder textEncoder
)

Параметры

iblockId
Type: System..::..Int32
Идентификатор родительского инфоблока.
name
Type: System..::..String
Название элемента инфоблока.
textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей.

Смотри также

Класс BXIBlockElement
Перегрузка BXIBlockElement
Пространство имен Bitrix.IBlock


Поля BXIBlockElement

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXIBlockElement
Класс BXIBlockElement Смотри также Send Feedback

Тип BXIBlockElement предоставляет следующие возможности.

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Методы BXIBlockElement

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockElement
Класс BXIBlockElement Смотри также Send Feedback

Тип BXIBlockElement предоставляет следующие возможности.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..CountInternal(BXFilter))
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..CreateAfterSuccess()()()())
CreateCustomFieldIfNeed |
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..DeleteAfterSuccess()()()())
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetCustomFieldsKeyInternal(String))
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetSections |
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IncViewsCount | Перегруженный.
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..UpdateAfterSuccess()()()())
VerifyEntry | (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..VerifyEntry()()()())

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Метод CountInternal

Метод BXIBlockElement..::.CountInternal
Класс BXIBlockElement Смотри также Send Feedback
Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override int CountInternal(
    BXFilter filter
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
Объект типа BXFilter, содержащий фильтр, накладываемый на сущность. Может быть равен null.

Возвращаемое значение

Число записей, удовлетворяющих условию.

Заметки

Производит подсчет количества элементов инфоблока с учетом особых полей.

Все статические методы типа Count (вычисляющие количество сущностей в базе данных, удовлетворяющих указанному фильтру), обращаются к методу CountInternal. Этот метод является виртуальным и может быть переопределен в классе конкретной сущности для реализации нестандартной выборки.

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Метод Create

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockElement..::.Create
Класс BXIBlockElement Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Create()()()() | Добавляет новую сущность в базу данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create(BXSqlConnection, BXSqlTransaction) | Добавляет новую сущность в базу данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement
Члены BXIBlockElement
Пространство имен Bitrix.IBlock


Метод CreateAfterSuccess

Метод BXIBlockElement..::.CreateAfterSuccess
Класс BXIBlockElement Смотри также Send Feedback
Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override void CreateAfterSuccess()

Заметки

Добавляет полнотекстовый индекс для элемента инфоблока.

Этот метод ничего не делает в базовой реализации сущности, но может быть переопределен в конкретной сущности.

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Метод CreateCustomFieldIfNeed

Метод BXIBlockElement..::.CreateCustomFieldIfNeed
Класс BXIBlockElement Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXCustomField CreateCustomFieldIfNeed(
    int blockId,
    string name,
    string typeId
)

Параметры

blockId
Type: System..::..Int32
name
Type: System..::..String
typeId
Type: System..::..String

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Метод Delete

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockElement..::.Delete
Класс BXIBlockElement Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Delete()()()() | Удаляет текущую сущность из базы данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete(BXSqlConnection, BXSqlTransaction) | Удаляет текущую сущность из базы данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement
Члены BXIBlockElement
Пространство имен Bitrix.IBlock


Метод DeleteAfterSuccess

Метод BXIBlockElement..::.DeleteAfterSuccess
Класс BXIBlockElement Смотри также Send Feedback
Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override void DeleteAfterSuccess()

Заметки

Удаляет полнотекстовый индекс для элемента инфоблока.

Этот метод ничего не делает в базовой реализации сущности, но может быть переопределен в конкретной сущности.

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Метод DeleteInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockElement..::.DeleteInternal
Класс BXIBlockElement Смотри также Send Feedback

Лист перегрузки

Имя | Описание
DeleteInternal(Object) | Внутренний метод удаления сущностей по первичному ключу id, который вызывается статическим методом Delete(Object). (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter) | Внутренний метод удаления сущностей по фильтру, который вызывается статическим методом Delete(BXFilter). При удалении не отправляются никакие комманды и не удаляются дополнительные данные. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter, BXSqlConnection, BXSqlTransaction) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement
Члены BXIBlockElement
Пространство имен Bitrix.IBlock


Метод GetByIdInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockElement..::.GetByIdInternal
Класс BXIBlockElement Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetByIdInternal(Object, IBXTextEncoder) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal(Object, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement
Члены BXIBlockElement
Пространство имен Bitrix.IBlock


Метод GetCustomFieldsKeyInternal

Метод BXIBlockElement..::.GetCustomFieldsKeyInternal
Класс BXIBlockElement Смотри также Send Feedback
Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override string GetCustomFieldsKeyInternal(
    string id
)

Параметры

id
Type: System..::..String
Параметр ключа.

Возвращаемое значение

Строка, содержащая код.

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Метод GetJoinedEntity

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockElement..::.GetJoinedEntity
Класс BXIBlockElement Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String, BXSchemeBase) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement
Члены BXIBlockElement
Пространство имен Bitrix.IBlock


Метод GetJoinedEntityCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockElement..::.GetJoinedEntityCollection
Класс BXIBlockElement Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType, JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>)(String, String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement
Члены BXIBlockElement
Пространство имен Bitrix.IBlock


Метод GetListInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockElement..::.GetListInternal
Класс BXIBlockElement Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder))
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement
Члены BXIBlockElement
Пространство имен Bitrix.IBlock


Метод GetListInternal (BXFilter, BXOrderBy, BXSelect, BXQueryParams, )

Метод BXIBlockElement..::.GetListInternal (BXFilter, BXOrderBy, BXSelect, BXQueryParams, )
Класс BXIBlockElement Смотри также Send Feedback
Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override BXIBlockElementCollection GetListInternal(
    BXFilter filter,
    BXOrderBy orderBy,
    BXSelect select,
    BXQueryParams queryParams,
    IBXTextEncoder textEncoder
)

Параметры

filter
Type: Bitrix.DataLayer..::..BXFilter
Фильтр, накладываемый на коллекцию сущностей.
orderBy
Type: Bitrix.DataLayer..::..BXOrderBy
Условия сортировки коллекции сущностей.
select
Type: Bitrix.DataLayer..::..BXSelect
Список выбираемых полей сущности.
queryParams
Type: Bitrix.DataLayer..::..BXQueryParams
Параметры выборки.
textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей сущности.

Возвращаемое значение

Коллекция сущностей, удовлетворяющая параметрам метода.

Заметки

Производит выборку списка элементов инфоблока с учетом особых полей.

Все статические методы типа GetList обращаются к методу GetListInternal. Этот метод является виртуальным и может быть переопределен в классе конкретной сущности для реализации нестандартной выборки.

Смотри также

Класс BXIBlockElement
Перегрузка GetListInternal
Пространство имен Bitrix.IBlock
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetList(BXFilter, BXOrderBy)
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetList(BXFilter, BXOrderBy, BXSelect, BXQueryParams)
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetList(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder)


Метод GetSections

Метод BXIBlockElement..::.GetSections
Класс BXIBlockElement Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockSectionCollection GetSections()

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Метод IncViewsCount

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockElement..::.IncViewsCount
Класс BXIBlockElement Смотри также Send Feedback

Лист перегрузки

Имя | Описание
IncViewsCount(Int32) |
IncViewsCount(Int32, BXSqlTransaction) | Метод увеличивает счетчик показов элемента инфоблока обновляя только поле ViewsCount

Смотри также

Класс BXIBlockElement
Члены BXIBlockElement
Пространство имен Bitrix.IBlock


Метод IncViewsCount (Int32)

Метод BXIBlockElement..::.IncViewsCount (Int32)
Класс BXIBlockElement Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void IncViewsCount(
    int inc
)

Параметры

inc
Type: System..::..Int32

Смотри также

Класс BXIBlockElement
Перегрузка IncViewsCount
Пространство имен Bitrix.IBlock


Метод IncViewsCount (Int32, )

Метод BXIBlockElement..::.IncViewsCount (Int32, )
Класс BXIBlockElement Смотри также Send Feedback
Метод увеличивает счетчик показов элемента инфоблока обновляя только поле ViewsCount

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void IncViewsCount(
    int inc,
    BXSqlTransaction trans
)

Параметры

inc
Type: System..::..Int32
trans
Type: BXSqlTransaction

Смотри также

Класс BXIBlockElement
Перегрузка IncViewsCount
Пространство имен Bitrix.IBlock


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockElement..::.Save
Класс BXIBlockElement Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет сущность в базе данных в новой транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет сущность в базе данных в указанной транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement
Члены BXIBlockElement
Пространство имен Bitrix.IBlock


Метод SetValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockElement..::.SetValue
Класс BXIBlockElement Смотри также Send Feedback

Лист перегрузки

Имя | Описание
SetValue(KeyValuePair<(Of <<'(String, Object>)>>), Boolean) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object, Boolean) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement
Члены BXIBlockElement
Пространство имен Bitrix.IBlock


Метод Update

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockElement..::.Update
Класс BXIBlockElement Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Update()()()() | Изменяет существующую сущность в базе данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update(BXSqlConnection, BXSqlTransaction) | Изменяет существующую сущность в базе данных в указанной транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement
Члены BXIBlockElement
Пространство имен Bitrix.IBlock


Метод UpdateAfterSuccess

Метод BXIBlockElement..::.UpdateAfterSuccess
Класс BXIBlockElement Смотри также Send Feedback
Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override void UpdateAfterSuccess()

Заметки

Добавляет полнотекстовый индекс для элемента инфоблока.

Этот метод ничего не делает в базовой реализации сущности, но может быть переопределен в конкретной сущности.

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Метод VerifyEntry

Метод BXIBlockElement..::.VerifyEntry
Класс BXIBlockElement Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override BXModifyStatus VerifyEntry()

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойства BXIBlockElement

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockElement
Класс BXIBlockElement Смотри также Send Feedback

Тип BXIBlockElement предоставляет следующие возможности.

Свойства

Имя | Описание
Active | Возвращает или устанавливает, активен ли элемент инфоблока.
ActiveFromDate | Возвращает или устанавливает, дату и время начала активности элемента инфоблока.
ActiveToDate | Возвращает или устанавливает, дату и время окончания активности элемента инфоблока.
Code | Возвращает или устанавливает символьный код элемента инфоблока. Закодировано кодировщиком.
CreateDate | Возвращает или устанавливает дату создания элемента инфоблока.
CreatedBy | Возвращает или устанавливает идентификатор пользователя, создавшего элемент инфоблока. (см. BXUser)
CreatedByUser | Возвращает пользователя, создавшего элемент инфоблока.
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Переопределяет BXEntity..::..CustomFieldsKey)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DetailImage | Возвращает сущность "файл" для элемента инфоблока, заданную свойством DetailImageId.
DetailImageId | Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится изображение для детального описания элемента инфоблока.
DetailText | Возвращает или устанавливает текст детального описания инфоблока. Закодировано кодировщиком.
DetailTextType | Возвращает или устанавливает тип текста детального описания инфоблока (текст или HTML).
EntityId | Возвращает "IBlockElement". (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..EntityId)
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
IBlock | Запрос инфоблока
IBlockId | Возвращает или устанавливает идентификатор инфоблока, к которому принадлежит элемент. (см. BXIBlock)
Id | Возвращает или устанавливает идентификатор элемента инфоблока. Первичный ключ.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ModifiedBy | Возвращает или устанавливает идентификатор пользователя, изменившего элемент инфоблока. (см. BXUser)
ModifiedByUser | Возвращает пользователя, изменившего элемент инфоблока.
ModuleId | Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..ModuleId)
Name | Возвращает или устанавливает название элемента инфоблока. Закодировано кодировщиком.
PreviewImage | Возвращает сущность "файл" для элемента инфоблока, заданную свойством PreviewImageId.
PreviewImageId | Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится изображение для анонса элемента инфоблока.
PreviewText | Возвращает или устанавливает текст анонса инфоблока. Закодировано кодировщиком.
PreviewTextType | Возвращает или устанавливает тип текста анонса инфоблока (текст или HTML).
Properties | Возвращает коллекцию пользовательских свойств. См. свойство CustomValues.
Sections | Возвращает коллекцию связок "раздел элемента инфоблока" для данного элемента.
Sort | Возвращает или устанавливает порядок сортировки элемента инфоблока.
Tags | Возвращает или устанавливает теги элемента инфоблока. Закодировано кодировщиком.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateDate | Возвращает или устанавливает дату последнего изменения элемента инфоблока.
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ViewsCount | Возвращает или устанавливает количество просмотров элемента (для фотогалереи ).
XmlId | Возвращает или устанавливает идентификатор элемента инфоблока для экспорта в XML. Закодировано кодировщиком.

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство Active

Свойство BXIBlockElement..::.Active
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает, активен ли элемент инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool Active { get; set; }

Примеры

Создание нового элемента инфоблока с указанием периода активности:

CopyC#
int iblockId;
BXIBlockElement element = new BXIBlockElement();

element.Name = "Элемент";
element.IBlockId = iblockId;

element.Active = true;
element.ActiveFromDate = DateTime.Now;
element.ActiveToDate = DateTime.Now.AddMonths(1);

element.Save();

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство ActiveFromDate

Свойство BXIBlockElement..::.ActiveFromDate
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает, дату и время начала активности элемента инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public DateTime ActiveFromDate { get; set; }

Заметки

Если дата не задана, то возвращается или устанавливается значение DateTime.MinValue

Примеры

Создание нового элемента инфоблока с указанием периода активности:

CopyC#
int iblockId;
BXIBlockElement element = new BXIBlockElement();

element.Name = "Элемент";
element.IBlockId = iblockId;

element.Active = true;
element.ActiveFromDate = DateTime.Now;
element.ActiveToDate = DateTime.Now.AddMonths(1);

element.Save();

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство ActiveToDate

Свойство BXIBlockElement..::.ActiveToDate
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает, дату и время окончания активности элемента инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public DateTime ActiveToDate { get; set; }

Заметки

Если дата не задана, то возвращается или устанавливается значение DateTime.MinValue

Примеры

Создание нового элемента инфоблока с указанием периода активности:

CopyC#
int iblockId;
BXIBlockElement element = new BXIBlockElement();

element.Name = "Элемент";
element.IBlockId = iblockId;

element.Active = true;
element.ActiveFromDate = DateTime.Now;
element.ActiveToDate = DateTime.Now.AddMonths(1);

element.Save();

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство Code

Свойство BXIBlockElement..::.Code
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает символьный код элемента инфоблока. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Code { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Примеры

Вывод списка элементов инфоблока:

CopyC#
<table>
    <%
    int iblockId;

    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));

    foreach (BXIBlockElement el in BXIBlockElement.GetList(filter, null))
    {
        %>
        <tr>
            <td><%= el.Name %></td>
            <td><%= el.Code %></td>
            <td><%= el.XmlId %></td>
            <td><%= el.Active ? "X" : "" %></td>
            <td>
                <%= el.ActiveFromDate != DateTime.MinValue ? " from " + el.ActiveFromDate : "" %>
                <%= el.ActiveToDate != DateTime.MinValue ? " to " + el.ActiveToDate : ""%>
            </td>
            <td>
                Created:
                <% if (el.CreatedBy != 0) { %> <%= el.CreatedByUser.UserName %> <% } %>
                <%= el.CreateDate %>
            </td>
            <td>
                Modified:
                <% if (el.ModifiedBy != 0) { %> <%= el.ModifiedByUser.UserName%> <% } %>
                <%= el.UpdateDate %>
            </td>
            <td><%= el.Tags %></td>
        </tr>
        <%
    }
    %>
</table>

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство CreateDate

Свойство BXIBlockElement..::.CreateDate
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает дату создания элемента инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public DateTime CreateDate { get; set; }

Заметки

Если дата не указана явно, то она будет автоматически записана в БД при сохранении.

Примеры

Вывод списка элементов инфоблока:

CopyC#
<table>
    <%
    int iblockId;

    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));

    foreach (BXIBlockElement el in BXIBlockElement.GetList(filter, null))
    {
        %>
        <tr>
            <td><%= el.Name %></td>
            <td><%= el.Code %></td>
            <td><%= el.XmlId %></td>
            <td><%= el.Active ? "X" : "" %></td>
            <td>
                <%= el.ActiveFromDate != DateTime.MinValue ? " c " + el.ActiveFromDate : "" %>
                <%= el.ActiveToDate != DateTime.MinValue ? " по " + el.ActiveToDate : ""%>
            </td>
            <td>
                Создан:
                <% if (el.CreatedBy != 0) { %> <%= el.CreatedByUser.UserName %> <% } %>
                <%= el.CreateDate %>
            </td>
            <td>
                Изменен:
                <% if (el.ModifiedBy != 0) { %> <%= el.ModifiedByUser.UserName%> <% } %>
                <%= el.UpdateDate %>
            </td>
        </tr>
        <%
    }
    %>
</table>

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство CreatedBy

Свойство BXIBlockElement..::.CreatedBy
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор пользователя, создавшего элемент инфоблока. (см. BXUser)

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int CreatedBy { get; set; }

Заметки

Перед сохранением элемента инфоблока идентификатор должен быть задан явно.

Примеры

Вывод списка элементов инфоблока:

CopyC#
<table>
    <%
    int iblockId;

    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));

    foreach (BXIBlockElement el in BXIBlockElement.GetList(filter, null))
    {
        %>
        <tr>
            <td><%= el.Name %></td>
            <td><%= el.Code %></td>
            <td><%= el.XmlId %></td>
            <td><%= el.Active ? "X" : "" %></td>
            <td>
                <%= el.ActiveFromDate != DateTime.MinValue ? " from " + el.ActiveFromDate : "" %>
                <%= el.ActiveToDate != DateTime.MinValue ? " to " + el.ActiveToDate : ""%>
            </td>
            <td>
                Created:
                <% if (el.CreatedBy != 0) { %> <%= el.CreatedByUser.UserName %> <% } %>
                <%= el.CreateDate %>
            </td>
            <td>
                Modified:
                <% if (el.ModifiedBy != 0) { %> <%= el.ModifiedByUser.UserName%> <% } %>
                <%= el.UpdateDate %>
            </td>
            <td><%= el.Tags %></td>
        </tr>
        <%
    }
    %>
</table>

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство CreatedByUser

Свойство BXIBlockElement..::.CreatedByUser
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает пользователя, создавшего элемент инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXUser CreatedByUser { get; }

Примеры

Вывод списка элементов инфоблока:

CopyC#
<table>
    <%
    int iblockId;

    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));

    foreach (BXIBlockElement el in BXIBlockElement.GetList(filter, null))
    {
        %>
        <tr>
            <td><%= el.Name %></td>
            <td><%= el.Code %></td>
            <td><%= el.XmlId %></td>
            <td><%= el.Active ? "X" : "" %></td>
            <td>
                <%= el.ActiveFromDate != DateTime.MinValue ? " from " + el.ActiveFromDate : "" %>
                <%= el.ActiveToDate != DateTime.MinValue ? " to " + el.ActiveToDate : ""%>
            </td>
            <td>
                Created:
                <% if (el.CreatedBy != 0) { %> <%= el.CreatedByUser.UserName %> <% } %>
                <%= el.CreateDate %>
            </td>
            <td>
                Modified:
                <% if (el.ModifiedBy != 0) { %> <%= el.ModifiedByUser.UserName%> <% } %>
                <%= el.UpdateDate %>
            </td>
            <td><%= el.Tags %></td>
        </tr>
        <%
    }
    %>
</table>

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство CustomFieldsKey

Свойство BXIBlockElement..::.CustomFieldsKey
Класс BXIBlockElement Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override string CustomFieldsKey { get; }

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство DetailImage

Свойство BXIBlockElement..::.DetailImage
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает сущность "файл" для элемента инфоблока, заданную свойством DetailImageId.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile DetailImage { get; }

Примеры

Вывод детального описания элемента инфоблока в ASPX-странице:

CopyC#
<% BXIBlockElement el; %>

<h2><%= el.Name %></h2>
<p style="overflow: hidden">
    <% if (el.DetailImage != null) { %>
        <img src="<%= el.DetailImage.FilePath %>" alt="<%= el.DetailImage.Description %>" style="float: left; width: 64px" />
    <% } %>
    <%= el.DetailText%>
</p>

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство DetailImageId

Свойство BXIBlockElement..::.DetailImageId
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится изображение для детального описания элемента инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int DetailImageId { get; set; }

Примеры

Создание нового элемента инфоблока с привязкой к разделу:

CopyC#
    const int IBlockId;
    const int SectionId;

    private void AddIBlockElement()
    {
        BXIBlockElement element = new BXIBlockElement();
        element.Name = "Lorem ipsum";
        element.IBlockId = IBlockId;
        element.Sections.Add(SectionId);

        element.PreviewTextType = BXTextType.Text;
        element.PreviewText =
@"Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/preview.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Preview Image");
            file.ValidateAsImage(100*1024, 100, 100);
            file.Save();

            element.PreviewImageId = file.Id;
        }

        element.DetailTextType = BXTextType.Html;
        element.DetailText =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/detail.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Detail Image");
            file.ValidateAsImage(2 * 1024 * 1024, 2000, 2000);
            file.Save();

            element.DetailImageId = file.Id;
        }

        element.ActiveFromDate = new DateTime(2009, 1, 1);

        element.Save();
    }

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство DetailText

Свойство BXIBlockElement..::.DetailText
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает текст детального описания инфоблока. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string DetailText { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком в зависимости от значения свойства DetailTextType.

Примеры

Создание нового элемента инфоблока с привязкой к разделу:

CopyC#
    const int IBlockId;
    const int SectionId;

    private void AddIBlockElement()
    {
        BXIBlockElement element = new BXIBlockElement();
        element.Name = "Lorem ipsum";
        element.IBlockId = IBlockId;
        element.Sections.Add(SectionId);

        element.PreviewTextType = BXTextType.Text;
        element.PreviewText =
@"Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/preview.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Preview Image");
            file.ValidateAsImage(100*1024, 100, 100);
            file.Save();

            element.PreviewImageId = file.Id;
        }

        element.DetailTextType = BXTextType.Html;
        element.DetailText =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/detail.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Detail Image");
            file.ValidateAsImage(2 * 1024 * 1024, 2000, 2000);
            file.Save();

            element.DetailImageId = file.Id;
        }

        element.ActiveFromDate = new DateTime(2009, 1, 1);

        element.Save();
    }

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство DetailTextType

Свойство BXIBlockElement..::.DetailTextType
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает тип текста детального описания инфоблока (текст или HTML).

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXTextType DetailTextType { get; set; }

Примеры

Создание нового элемента инфоблока с привязкой к разделу:

CopyC#
    const int IBlockId;
    const int SectionId;

    private void AddIBlockElement()
    {
        BXIBlockElement element = new BXIBlockElement();
        element.Name = "Lorem ipsum";
        element.IBlockId = IBlockId;
        element.Sections.Add(SectionId);

        element.PreviewTextType = BXTextType.Text;
        element.PreviewText =
@"Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/preview.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Preview Image");
            file.ValidateAsImage(100*1024, 100, 100);
            file.Save();

            element.PreviewImageId = file.Id;
        }

        element.DetailTextType = BXTextType.Html;
        element.DetailText =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/detail.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Detail Image");
            file.ValidateAsImage(2 * 1024 * 1024, 2000, 2000);
            file.Save();

            element.DetailImageId = file.Id;
        }

        element.ActiveFromDate = new DateTime(2009, 1, 1);

        element.Save();
    }

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство EntityId

Свойство BXIBlockElement..::.EntityId
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает "IBlockElement".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string EntityId { get; }

Заметки

Это свойство используется для формирования названий команд, отправляемых при сохранении сущности в базу данных или удалении из базы данных.

Примеры

CopyC#
public class BXIBlockElement
    : BXEntity
{
    . . .

    public override string ModuleId
    {
        get { return "iblock"; }
    }

    public override string EntityId
    {
        get { return "IBlockElement"; }
    }

    . . .
}

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство IBlock

Свойство BXIBlockElement..::.IBlock
Класс BXIBlockElement Смотри также Send Feedback
Запрос инфоблока

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlock IBlock { get; }

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство IBlockId

Свойство BXIBlockElement..::.IBlockId
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор инфоблока, к которому принадлежит элемент. (см. BXIBlock)

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int IBlockId { get; set; }

Заметки

Значение обязательно должно быть задано перед сохранением элемента инфоблока.

Примеры

Создание нового элемента инфоблока с указанием периода активности:

CopyC#
int iblockId;
BXIBlockElement element = new BXIBlockElement();

element.Name = "Элемент";
element.IBlockId = iblockId;

element.Active = true;
element.ActiveFromDate = DateTime.Now;
element.ActiveToDate = DateTime.Now.AddMonths(1);

element.Save();

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство Id

Свойство BXIBlockElement..::.Id
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор элемента инфоблока. Первичный ключ.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Id { get; set; }

Примеры

Обновление элемента инфоблока:

CopyC#
int elementId;

BXIBlockElement element = new BXIBlockElement();
element.Id = elementId;
element.Name = "Обновленный заголовок";
element.Update();

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство ModifiedBy

Свойство BXIBlockElement..::.ModifiedBy
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор пользователя, изменившего элемент инфоблока. (см. BXUser)

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int ModifiedBy { get; set; }

Заметки

Перед сохранением элемента инфоблока идентификатор должен быть задан явно.

Примеры

Вывод списка элементов инфоблока:

CopyC#
<table>
    <%
    int iblockId;

    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));

    foreach (BXIBlockElement el in BXIBlockElement.GetList(filter, null))
    {
        %>
        <tr>
            <td><%= el.Name %></td>
            <td><%= el.Code %></td>
            <td><%= el.XmlId %></td>
            <td><%= el.Active ? "X" : "" %></td>
            <td>
                <%= el.ActiveFromDate != DateTime.MinValue ? " from " + el.ActiveFromDate : "" %>
                <%= el.ActiveToDate != DateTime.MinValue ? " to " + el.ActiveToDate : ""%>
            </td>
            <td>
                Created:
                <% if (el.CreatedBy != 0) { %> <%= el.CreatedByUser.UserName %> <% } %>
                <%= el.CreateDate %>
            </td>
            <td>
                Modified:
                <% if (el.ModifiedBy != 0) { %> <%= el.ModifiedByUser.UserName%> <% } %>
                <%= el.UpdateDate %>
            </td>
            <td><%= el.Tags %></td>
        </tr>
        <%
    }
    %>
</table>

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство ModifiedByUser

Свойство BXIBlockElement..::.ModifiedByUser
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает пользователя, изменившего элемент инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXUser ModifiedByUser { get; }

Примеры

Вывод списка элементов инфоблока:

CopyC#
<table>
    <%
    int iblockId;

    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));

    foreach (BXIBlockElement el in BXIBlockElement.GetList(filter, null))
    {
        %>
        <tr>
            <td><%= el.Name %></td>
            <td><%= el.Code %></td>
            <td><%= el.XmlId %></td>
            <td><%= el.Active ? "X" : "" %></td>
            <td>
                <%= el.ActiveFromDate != DateTime.MinValue ? " from " + el.ActiveFromDate : "" %>
                <%= el.ActiveToDate != DateTime.MinValue ? " to " + el.ActiveToDate : ""%>
            </td>
            <td>
                Created:
                <% if (el.CreatedBy != 0) { %> <%= el.CreatedByUser.UserName %> <% } %>
                <%= el.CreateDate %>
            </td>
            <td>
                Modified:
                <% if (el.ModifiedBy != 0) { %> <%= el.ModifiedByUser.UserName%> <% } %>
                <%= el.UpdateDate %>
            </td>
            <td><%= el.Tags %></td>
        </tr>
        <%
    }
    %>
</table>

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство ModuleId

Свойство BXIBlockElement..::.ModuleId
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string ModuleId { get; }

Заметки

Это свойство используется для формирования названий команд, отправляемых при сохранении сущности в базу данных или удалении из базы данных.

Примеры

CopyC#
public class BXIBlockElement
    : BXEntity
{
    . . .

    public override string ModuleId
    {
        get { return "iblock"; }
    }

    public override string EntityId
    {
        get { return "IBlockElement"; }
    }

    . . .
}

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство Name

Свойство BXIBlockElement..::.Name
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает название элемента инфоблока. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Name { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Примеры

Создание нового элемента инфоблока с привязкой к разделу:

CopyC#
    const int IBlockId;
    const int SectionId;

    private void AddIBlockElement()
    {
        BXIBlockElement element = new BXIBlockElement();
        element.Name = "Lorem ipsum";
        element.IBlockId = IBlockId;
        element.Sections.Add(SectionId);

        element.PreviewTextType = BXTextType.Text;
        element.PreviewText =
@"Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/preview.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Preview Image");
            file.ValidateAsImage(100*1024, 100, 100);
            file.Save();

            element.PreviewImageId = file.Id;
        }

        element.DetailTextType = BXTextType.Html;
        element.DetailText =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/detail.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Detail Image");
            file.ValidateAsImage(2 * 1024 * 1024, 2000, 2000);
            file.Save();

            element.DetailImageId = file.Id;
        }

        element.ActiveFromDate = new DateTime(2009, 1, 1);

        element.Save();
    }

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство PreviewImage

Свойство BXIBlockElement..::.PreviewImage
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает сущность "файл" для элемента инфоблока, заданную свойством PreviewImageId.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile PreviewImage { get; }

Примеры

Вывод списка анонсов элементов в ASPX-странице:

CopyC#
<%
    BXIBlockElementCollection elements;

     foreach (BXIBlockElement el in elements)
    {
%>
<h4><%= el.Name %></h4>
<p style="overflow: hidden">
    <% if (el.PreviewImage != null) { %>
        <img src="<%= el.PreviewImage.FilePath %>" alt="<%= el.PreviewImage.Description %>" style="float: left; width: 64px" />
    <% } %>
    <%= el.PreviewText%>
</p>
<%
    }
%>

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство PreviewImageId

Свойство BXIBlockElement..::.PreviewImageId
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится изображение для анонса элемента инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int PreviewImageId { get; set; }

Примеры

Создание нового элемента инфоблока с привязкой к разделу:

CopyC#
    const int IBlockId;
    const int SectionId;

    private void AddIBlockElement()
    {
        BXIBlockElement element = new BXIBlockElement();
        element.Name = "Lorem ipsum";
        element.IBlockId = IBlockId;
        element.Sections.Add(SectionId);

        element.PreviewTextType = BXTextType.Text;
        element.PreviewText =
@"Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/preview.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Preview Image");
            file.ValidateAsImage(100*1024, 100, 100);
            file.Save();

            element.PreviewImageId = file.Id;
        }

        element.DetailTextType = BXTextType.Html;
        element.DetailText =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/detail.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Detail Image");
            file.ValidateAsImage(2 * 1024 * 1024, 2000, 2000);
            file.Save();

            element.DetailImageId = file.Id;
        }

        element.ActiveFromDate = new DateTime(2009, 1, 1);

        element.Save();
    }

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство PreviewText

Свойство BXIBlockElement..::.PreviewText
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает текст анонса инфоблока. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string PreviewText { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком в зависимости от значения свойства PreviewTextType.

Примеры

Создание нового элемента инфоблока с привязкой к разделу:

CopyC#
    const int IBlockId;
    const int SectionId;

    private void AddIBlockElement()
    {
        BXIBlockElement element = new BXIBlockElement();
        element.Name = "Lorem ipsum";
        element.IBlockId = IBlockId;
        element.Sections.Add(SectionId);

        element.PreviewTextType = BXTextType.Text;
        element.PreviewText =
@"Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/preview.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Preview Image");
            file.ValidateAsImage(100*1024, 100, 100);
            file.Save();

            element.PreviewImageId = file.Id;
        }

        element.DetailTextType = BXTextType.Html;
        element.DetailText =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/detail.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Detail Image");
            file.ValidateAsImage(2 * 1024 * 1024, 2000, 2000);
            file.Save();

            element.DetailImageId = file.Id;
        }

        element.ActiveFromDate = new DateTime(2009, 1, 1);

        element.Save();
    }

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство PreviewTextType

Свойство BXIBlockElement..::.PreviewTextType
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает тип текста анонса инфоблока (текст или HTML).

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXTextType PreviewTextType { get; set; }

Примеры

Создание нового элемента инфоблока с привязкой к разделу:

CopyC#
    const int IBlockId;
    const int SectionId;

    private void AddIBlockElement()
    {
        BXIBlockElement element = new BXIBlockElement();
        element.Name = "Lorem ipsum";
        element.IBlockId = IBlockId;
        element.Sections.Add(SectionId);

        element.PreviewTextType = BXTextType.Text;
        element.PreviewText =
@"Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/preview.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Preview Image");
            file.ValidateAsImage(100*1024, 100, 100);
            file.Save();

            element.PreviewImageId = file.Id;
        }

        element.DetailTextType = BXTextType.Html;
        element.DetailText =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/detail.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Detail Image");
            file.ValidateAsImage(2 * 1024 * 1024, 2000, 2000);
            file.Save();

            element.DetailImageId = file.Id;
        }

        element.ActiveFromDate = new DateTime(2009, 1, 1);

        element.Save();
    }

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство Properties

Свойство BXIBlockElement..::.Properties
Класс BXIBlockElement Смотри также Send Feedback
Возвращает коллекцию пользовательских свойств. См. свойство CustomValues.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXCustomPropertyCollection Properties { get; }

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство Sections

Свойство BXIBlockElement..::.Sections
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает коллекцию связок "раздел элемента инфоблока" для данного элемента.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockElement..::..BXInfoBlockElementSectionCollection Sections { get; }

Примеры

Создание нового элемента инфоблока с привязкой к разделу:

CopyC#
    const int IBlockId;
    const int SectionId;

    private void AddIBlockElement()
    {
        BXIBlockElement element = new BXIBlockElement();
        element.Name = "Lorem ipsum";
        element.IBlockId = IBlockId;
        element.Sections.Add(SectionId);

        element.PreviewTextType = BXTextType.Text;
        element.PreviewText =
@"Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/preview.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Preview Image");
            file.ValidateAsImage(100*1024, 100, 100);
            file.Save();

            element.PreviewImageId = file.Id;
        }

        element.DetailTextType = BXTextType.Html;
        element.DetailText =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        using (FileStream fileStream = new FileStream(BXPath.MapPath("~/images/detail.jpg"), FileMode.Open))
        {
            BXFile file = new BXFile(fileStream, "preview.jpg", "iblock", "iblock", "Detail Image");
            file.ValidateAsImage(2 * 1024 * 1024, 2000, 2000);
            file.Save();

            element.DetailImageId = file.Id;
        }

        element.ActiveFromDate = new DateTime(2009, 1, 1);

        element.Save();
    }

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство Sort

Свойство BXIBlockElement..::.Sort
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает порядок сортировки элемента инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Sort { get; set; }

Примеры

Пересортировка элементов инфоблока по названию:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));

BXOrderBy sort = new BXOrderBy();
sort.Add(BXIBlockElement.Fields.Name, BXOrderByDirection.Asc);

int sortIndex = 0;
foreach (BXIBlockElement element in BXIBlockElement.GetList(filter, sort))
{
    element.Sort = (sortIndex += 10);
    element.Save();
}

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство Tags

Свойство BXIBlockElement..::.Tags
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает теги элемента инфоблока. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Tags { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

При установленном модуле "Поиск" теги могут быть проиндексированы. В этом случае теги должны быть разделены запятой.

Примеры

Вывод списка элементов инфоблока:

CopyC#
<table>
    <%
    int iblockId;

    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));

    foreach (BXIBlockElement el in BXIBlockElement.GetList(filter, null))
    {
        %>
        <tr>
            <td><%= el.Name %></td>
            <td><%= el.Code %></td>
            <td><%= el.XmlId %></td>
            <td><%= el.Active ? "X" : "" %></td>
            <td>
                <%= el.ActiveFromDate != DateTime.MinValue ? " from " + el.ActiveFromDate : "" %>
                <%= el.ActiveToDate != DateTime.MinValue ? " to " + el.ActiveToDate : ""%>
            </td>
            <td>
                Created:
                <% if (el.CreatedBy != 0) { %> <%= el.CreatedByUser.UserName %> <% } %>
                <%= el.CreateDate %>
            </td>
            <td>
                Modified:
                <% if (el.ModifiedBy != 0) { %> <%= el.ModifiedByUser.UserName%> <% } %>
                <%= el.UpdateDate %>
            </td>
            <td><%= el.Tags %></td>
        </tr>
        <%
    }
    %>
</table>

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство UpdateDate

Свойство BXIBlockElement..::.UpdateDate
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает дату последнего изменения элемента инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public DateTime UpdateDate { get; set; }

Заметки

Если дата не указана явно, то она будет автоматически записана в БД при сохранении.

Примеры

Вывод списка элементов инфоблока:

CopyC#
<table>
    <%
    int iblockId;

    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));

    foreach (BXIBlockElement el in BXIBlockElement.GetList(filter, null))
    {
        %>
        <tr>
            <td><%= el.Name %></td>
            <td><%= el.Code %></td>
            <td><%= el.XmlId %></td>
            <td><%= el.Active ? "X" : "" %></td>
            <td>
                <%= el.ActiveFromDate != DateTime.MinValue ? " from " + el.ActiveFromDate : "" %>
                <%= el.ActiveToDate != DateTime.MinValue ? " to " + el.ActiveToDate : ""%>
            </td>
            <td>
                Created:
                <% if (el.CreatedBy != 0) { %> <%= el.CreatedByUser.UserName %> <% } %>
                <%= el.CreateDate %>
            </td>
            <td>
                Modified:
                <% if (el.ModifiedBy != 0) { %> <%= el.ModifiedByUser.UserName%> <% } %>
                <%= el.UpdateDate %>
            </td>
            <td><%= el.Tags %></td>
        </tr>
        <%
    }
    %>
</table>

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство ViewsCount

Свойство BXIBlockElement..::.ViewsCount
Класс BXIBlockElement Смотри также Send Feedback
Возвращает или устанавливает количество просмотров элемента (для фотогалереи ).

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int ViewsCount { get; set; }

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Свойство XmlId

Свойство BXIBlockElement..::.XmlId
Класс BXIBlockElement Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор элемента инфоблока для экспорта в XML. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string XmlId { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Примеры

Вывод списка элементов инфоблока:

CopyC#
<table>
    <%
    int iblockId;

    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));

    foreach (BXIBlockElement el in BXIBlockElement.GetList(filter, null))
    {
        %>
        <tr>
            <td><%= el.Name %></td>
            <td><%= el.Code %></td>
            <td><%= el.XmlId %></td>
            <td><%= el.Active ? "X" : "" %></td>
            <td>
                <%= el.ActiveFromDate != DateTime.MinValue ? " from " + el.ActiveFromDate : "" %>
                <%= el.ActiveToDate != DateTime.MinValue ? " to " + el.ActiveToDate : ""%>
            </td>
            <td>
                Created:
                <% if (el.CreatedBy != 0) { %> <%= el.CreatedByUser.UserName %> <% } %>
                <%= el.CreateDate %>
            </td>
            <td>
                Modified:
                <% if (el.ModifiedBy != 0) { %> <%= el.ModifiedByUser.UserName%> <% } %>
                <%= el.UpdateDate %>
            </td>
            <td><%= el.Tags %></td>
        </tr>
        <%
    }
    %>
</table>

Смотри также

Класс BXIBlockElement
Пространство имен Bitrix.IBlock


Класс BXIBlockElement.BXInfoBlockElementSection

Класс BXIBlockElement..::..BXInfoBlockElementSection
Класс BXIBlockElement Члены Смотри также Send Feedback
Класс определяет сущность-связку "раздел элемента инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXInfoBlockElementSection : BXLinkedEntity<BXIBlockElement..::..BXInfoBlockElementSection, BXIBlockElement..::..BXInfoBlockElementSectionCollection, BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme>

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXEntity
Bitrix.DataLayer..::..BXEntity <(Of <(<' EntityType, EntityCollectionType, EntryScheme >)>)>
BXLinkedEntity<(Of <(<'BXIBlockElement..::..BXInfoBlockElementSection, BXIBlockElement..::..BXInfoBlockElementSectionCollection, BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlockElement..::..BXInfoBlockElementSection

Смотри также

Члены BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Члены BXIBlockElement.BXInfoBlockElementSection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockElement..::..BXInfoBlockElementSection
Класс BXIBlockElement..::..BXInfoBlockElementSection Конструкторы Методы Поля Свойства Смотри также Send Feedback

Класс определяет сущность "элемент инфоблока".

Тип BXIBlockElement..::..BXInfoBlockElementSection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockElement..::..BXInfoBlockElementSection | Перегруженный.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
VerifyEntry | Проверяет корректность сущности перед сохранением. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Свойства

Имя | Описание
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Унаследовано от BXEntity)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ElementId | Возвращает идентификатор элемента инфоблока, который привязан к разделу.
EntityId | Возвращает "InfoBlockElementSection". (Переопределяет BXLinkedEntityEntityId()()()())
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ModuleId | (Переопределяет BXLinkedEntityModuleId()()()())
SectionId | Возвращает или устанавливает идентификатор раздела инфоблока, к которому привязан элемент.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElement.BXInfoBlockElementSection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXIBlockElement..::..BXInfoBlockElementSection
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXIBlockElement..::..BXInfoBlockElementSection()()()() | Конструктор сущности-связки.
BXIBlockElement..::..BXInfoBlockElementSection(Int32) | Конструктор сущности-связки.

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Члены BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElement.BXInfoBlockElementSection

Конструктор BXIBlockElement..::..BXInfoBlockElementSection
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback
Конструктор сущности-связки.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXInfoBlockElementSection()

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Перегрузка BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElement.BXInfoBlockElementSection (Int32)

Конструктор BXIBlockElement..::..BXInfoBlockElementSection (Int32)
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback
Конструктор сущности-связки.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXInfoBlockElementSection(
    int sectionId
)

Параметры

sectionId
Type: System..::..Int32
Идентификатор раздела инфоблока.

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Перегрузка BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Поля BXIBlockElement.BXInfoBlockElementSection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXIBlockElement..::..BXInfoBlockElementSection
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Тип BXIBlockElement..::..BXInfoBlockElementSection предоставляет следующие возможности.

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Методы BXIBlockElement.BXInfoBlockElementSection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockElement..::..BXInfoBlockElementSection
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Тип BXIBlockElement..::..BXInfoBlockElementSection предоставляет следующие возможности.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
VerifyEntry | Проверяет корректность сущности перед сохранением. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Метод Create

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockElementSection..::.Create
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Create()()()() | Добавляет новую сущность в базу данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create(BXSqlConnection, BXSqlTransaction) | Добавляет новую сущность в базу данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Члены BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Метод Delete

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockElementSection..::.Delete
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Delete()()()() | Удаляет текущую сущность из базы данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete(BXSqlConnection, BXSqlTransaction) | Удаляет текущую сущность из базы данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Члены BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Метод DeleteInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockElementSection..::.DeleteInternal
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
DeleteInternal(Object) | Внутренний метод удаления сущностей по первичному ключу id, который вызывается статическим методом Delete(Object). (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter) | Внутренний метод удаления сущностей по фильтру, который вызывается статическим методом Delete(BXFilter). При удалении не отправляются никакие комманды и не удаляются дополнительные данные. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter, BXSqlConnection, BXSqlTransaction) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Члены BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Метод GetByIdInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockElementSection..::.GetByIdInternal
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetByIdInternal(Object, IBXTextEncoder) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal(Object, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Члены BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Метод GetJoinedEntity

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockElementSection..::.GetJoinedEntity
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String, BXSchemeBase) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Члены BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Метод GetJoinedEntityCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockElementSection..::.GetJoinedEntityCollection
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType, JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>)(String, String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Члены BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Метод GetListInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockElementSection..::.GetListInternal
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Члены BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockElementSection..::.Save
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет сущность в базе данных в новой транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет сущность в базе данных в указанной транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Члены BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Метод SetValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockElementSection..::.SetValue
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
SetValue(KeyValuePair<(Of <<'(String, Object>)>>), Boolean) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object, Boolean) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Члены BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Метод Update

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockElementSection..::.Update
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Update()()()() | Изменяет существующую сущность в базе данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update(BXSqlConnection, BXSqlTransaction) | Изменяет существующую сущность в базе данных в указанной транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Члены BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Свойства BXIBlockElement.BXInfoBlockElementSection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockElement..::..BXInfoBlockElementSection
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Тип BXIBlockElement..::..BXInfoBlockElementSection предоставляет следующие возможности.

Свойства

Имя | Описание
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Унаследовано от BXEntity)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ElementId | Возвращает идентификатор элемента инфоблока, который привязан к разделу.
EntityId | Возвращает "InfoBlockElementSection". (Переопределяет BXLinkedEntityEntityId()()()())
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ModuleId | (Переопределяет BXLinkedEntityModuleId()()()())
SectionId | Возвращает или устанавливает идентификатор раздела инфоблока, к которому привязан элемент.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Свойство ElementId

Свойство BXIBlockElement..::..BXInfoBlockElementSection..::.ElementId
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback
Возвращает идентификатор элемента инфоблока, который привязан к разделу.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int ElementId { get; }

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Свойство EntityId

Свойство BXIBlockElement..::..BXInfoBlockElementSection..::.EntityId
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback
Возвращает "InfoBlockElementSection".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string EntityId { get; }

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Свойство ModuleId

Свойство BXIBlockElement..::..BXInfoBlockElementSection..::.ModuleId
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string ModuleId { get; }

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Свойство SectionId

Свойство BXIBlockElement..::..BXInfoBlockElementSection..::.SectionId
Класс BXIBlockElement..::..BXInfoBlockElementSection Смотри также Send Feedback
Возвращает или устанавливает идентификатор раздела инфоблока, к которому привязан элемент.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int SectionId { get; set; }

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection
Пространство имен Bitrix.IBlock


Класс BXIBlockElement.BXInfoBlockElementSection.Scheme

Класс BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme
Класс BXIBlockElement..::..BXInfoBlockElementSection Члены Смотри также Send Feedback
Схема сущности-связки "раздел элемента инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class Scheme : BXScheme<BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme>

Иерархия наследования

System..::..Object
BXSchemeBase
BXScheme<(Of <(<'BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme>)>)>
Bitrix.IBlock..::..BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme

Смотри также

Члены BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme
Пространство имен Bitrix.IBlock


Члены BXIBlockElement.BXInfoBlockElementSection.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme
Класс BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme Конструкторы Свойства Смотри также Send Feedback

Класс определяет сущность-связку "раздел элемента инфоблока.

Тип BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme |

Свойства

Имя | Описание
ElementId | Описание поля "Идентификатор элемента инфоблока"
Section | Описание поля "Связанный раздел инфоблока"

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElement.BXInfoBlockElementSection.Scheme

Конструктор BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme
Класс BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Scheme()

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойства BXIBlockElement.BXInfoBlockElementSection.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme
Класс BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme Смотри также Send Feedback

Тип BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme предоставляет следующие возможности.

Свойства

Имя | Описание
ElementId | Описание поля "Идентификатор элемента инфоблока"
Section | Описание поля "Связанный раздел инфоблока"

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ElementId

Свойство BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme..::.ElementId
Класс BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme Смотри также Send Feedback
Описание поля "Идентификатор элемента инфоблока"

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ElementId { get; }

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Section

Свойство BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme..::.Section
Класс BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme Смотри также Send Feedback
Описание поля "Связанный раздел инфоблока"

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockSection..::..Scheme Section { get; }

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme
Пространство имен Bitrix.IBlock


Класс BXIBlockElement.BXInfoBlockElementSectionCollection

Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection
Класс BXIBlockElement Члены Смотри также Send Feedback
Коллекция для связки "раздел элемента инфоблока". Содержит связки типа BXIBlockElement..::..BXInfoBlockElementSection

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXInfoBlockElementSectionCollection : BXEntityCollection<BXIBlockElement..::..BXInfoBlockElementSection, BXIBlockElement..::..BXInfoBlockElementSectionCollection, BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme>

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<' BXIBlockElement..::..BXInfoBlockElementSection >)>)>
Bitrix.DataLayer..::..BXEntityCollection <(Of <(<' BXIBlockElement..::..BXInfoBlockElementSection, BXIBlockElement..::..BXInfoBlockElementSectionCollection, BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlockElement..::..BXInfoBlockElementSectionCollection

Смотри также

Члены BXIBlockElement..::..BXInfoBlockElementSectionCollection
Пространство имен Bitrix.IBlock


Члены BXIBlockElement.BXInfoBlockElementSectionCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockElement..::..BXInfoBlockElementSectionCollection
Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection Конструкторы Методы Смотри также Send Feedback

Класс определяет сущность "элемент инфоблока".

Тип BXIBlockElement..::..BXInfoBlockElementSectionCollection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockElement..::..BXInfoBlockElementSectionCollection | Конструктор класса.

Методы

Имя | Описание
Add | Добавляет связку "раздел элемента инфоблока" в коллекцию по идентификатору раздела инфоблока (см. BXIBlockSection).
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.
ToList | Формирует список идентификаторов разделов (см. BXIBlockSection) из связок типа "раздел элемента инфоблока".

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElement.BXInfoBlockElementSectionCollection

Конструктор BXIBlockElement..::..BXInfoBlockElementSectionCollection
Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection Смотри также Send Feedback
Конструктор класса.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXInfoBlockElementSectionCollection()

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection
Пространство имен Bitrix.IBlock


Методы BXIBlockElement.BXInfoBlockElementSectionCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockElement..::..BXInfoBlockElementSectionCollection
Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection Смотри также Send Feedback

Тип BXIBlockElement..::..BXInfoBlockElementSectionCollection предоставляет следующие возможности.

Методы

Имя | Описание
Add | Добавляет связку "раздел элемента инфоблока" в коллекцию по идентификатору раздела инфоблока (см. BXIBlockSection).
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.
ToList | Формирует список идентификаторов разделов (см. BXIBlockSection) из связок типа "раздел элемента инфоблока".

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection
Пространство имен Bitrix.IBlock


Метод Add

Метод BXIBlockElement..::..BXInfoBlockElementSectionCollection..::.Add
Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection Пример Смотри также Send Feedback
Добавляет связку "раздел элемента инфоблока" в коллекцию по идентификатору раздела инфоблока (см. BXIBlockSection).

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void Add(
    int sectionId
)

Параметры

sectionId
Type: System..::..Int32
Идентификатор раздела инфоблока.

Примеры

Привязка элемента к разделу:

CopyC#
BXIBlockElement element;
int sectionId;

if (!element.Sections.Exists(delegate (BXIBlockElement.BXInfoBlockElementSection section)
{
    return section.SectionId == sectionId;
}))
    element.Sections.Add(sectionId);
element.Save();

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection
Пространство имен Bitrix.IBlock


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockElementSectionCollection..::.Save
Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет все сущности коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет все сущности коллекции, используя указанное соединение. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection
Члены BXIBlockElement..::..BXInfoBlockElementSectionCollection
Пространство имен Bitrix.IBlock


Метод ToDataTable

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockElementSectionCollection..::.ToDataTable
Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ToDataTable()()()() | Приводит коллекцию к типу DataTable. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable(BXPagingOptions) | Приводит коллекцию к типу DataTable с применением опций постраничной навигации. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection
Члены BXIBlockElement..::..BXInfoBlockElementSectionCollection
Пространство имен Bitrix.IBlock


Метод ToList

Метод BXIBlockElement..::..BXInfoBlockElementSectionCollection..::.ToList
Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection Пример Смотри также Send Feedback
Формирует список идентификаторов разделов (см. BXIBlockSection) из связок типа "раздел элемента инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public List<int> ToList()

Возвращаемое значение

Список идентификаторов разделов инфоблока.

Примеры

Проверка инфоблока на принадлежность текущему сайту:

CopyC#
BXIBlockElement element;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.ID, BXSqlFilterOperators.In, element.Sections.ToList().ToArray()));

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..BXInfoBlockElementSectionCollection
Пространство имен Bitrix.IBlock


Класс BXIBlockElement.Scheme

Класс BXIBlockElement..::..Scheme
Класс BXIBlockElement Члены Смотри также Send Feedback
Класс схемы для сущности "элемент инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class Scheme : BXScheme<BXIBlockElement..::..Scheme>

Иерархия наследования

System..::..Object
BXSchemeBase
BXScheme<(Of <(<'BXIBlockElement..::..Scheme>)>)>
Bitrix.IBlock..::..BXIBlockElement..::..Scheme

Смотри также

Члены BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Члены BXIBlockElement.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockElement..::..Scheme
Класс BXIBlockElement..::..Scheme Конструкторы Методы Свойства Смотри также Send Feedback

Класс определяет сущность "элемент инфоблока".

Тип BXIBlockElement..::..Scheme предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockElement..::..Scheme |

Методы

Имя | Описание
CreateCustomFieldSet | (Переопределяет BXSchemeCreateCustomFieldSet()()()())
GetCustomField | Формирует описание для набираемого свойства элемента инфоблока, которое может затем использоваться в выборках.

Свойства

Имя | Описание
Active | Описание поля "Активен?". ("Y" или "N")
ActiveDate | Описание поля "В интервале активности?". Вычисляемое поле.
ActiveFromDate | Описание поля "Дата начала активности".
ActiveToDate | Описание поля "Дата окончания активности".
Code | Описание поля "Символьный код".
CreateDate | Описание поля "Дата создания".
CreatedBy | Описание поля "Идентификатор пользователя, создавшего элемент".
DetailImage | Детальное изображение элемента инфоблока
DetailImageId | Описание поля "Идентификатор детального изображения".
DetailText | Описание поля "Детальный текст".
DetailTextType | Описание поля "Тип детального текста". ("T" или "H")
IBlock | Описание поля "Родительский инфоблок". Связанное поле.
ID | Описание поля "Идентификатор элемента". Первичный ключ.
IncludeParentSections | Описание поля "Включать родительские секции в фильтр?". Вычисляемое поле.
InRootSection | Описание поля "Принадлежит корневому разделу?". Вычисляемое поле.
ModifiedBy | Описание поля "Идентификатор пользователя, изменившего элемент".
Name | Описание поля "Название элемента инфоблока".
PreviewImage | изображение анонса элемента инфоблока
PreviewImageId | Описание поля "Идентификатор изображения анонса".
PreviewText | Описание поля "Текст анонса".
PreviewTextType | Описание поля "Тип текста анонса". ("T" или "H")
Sections | Описание поля "Связанные разделы". Связанное поле.
Sort | Описание поля "Порядок сортировки".
Tags | Описание поля "Теги".
UpdateDate | Описание поля "Дата последнего изменения".
XmlId | Описание поля "Идентификатор для XML".

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElement.Scheme

Конструктор BXIBlockElement..::..Scheme
Класс BXIBlockElement..::..Scheme Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Scheme()

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Методы BXIBlockElement.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockElement..::..Scheme
Класс BXIBlockElement..::..Scheme Смотри также Send Feedback

Тип BXIBlockElement..::..Scheme предоставляет следующие возможности.

Методы

Имя | Описание
CreateCustomFieldSet | (Переопределяет BXSchemeCreateCustomFieldSet()()()())
GetCustomField | Формирует описание для набираемого свойства элемента инфоблока, которое может затем использоваться в выборках.

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Метод CreateCustomFieldSet

Метод BXIBlockElement..::..Scheme..::.CreateCustomFieldSet
Класс BXIBlockElement..::..Scheme Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override BXSchemeCustomFieldSet CreateCustomFieldSet()

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Метод GetCustomField

Метод BXIBlockElement..::..Scheme..::.GetCustomField
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Формирует описание для набираемого свойства элемента инфоблока, которое может затем использоваться в выборках.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeCustomField GetCustomField(
    int iblockId,
    string fieldName
)

Параметры

iblockId
Type: System..::..Int32
Идентификатор инфоблока.
fieldName
Type: System..::..String
Имя пользовательского поля.

Возвращаемое значение

Описание пользовательского поля для сущности.

Примеры

Выборка элементов инфоблока на основе значений пользовательских свойств:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterItem(BXIBlockElement.Fields.GetCustomField(iblockId, "AUTHOR"), BXSqlFilterOperators.Equal, "Булгаков"));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockElement.Fields.GetCustomField(iblockId, "YEAR"), BXOrderByDirection.Desc);

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, orderBy);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойства BXIBlockElement.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockElement..::..Scheme
Класс BXIBlockElement..::..Scheme Смотри также Send Feedback

Тип BXIBlockElement..::..Scheme предоставляет следующие возможности.

Свойства

Имя | Описание
Active | Описание поля "Активен?". ("Y" или "N")
ActiveDate | Описание поля "В интервале активности?". Вычисляемое поле.
ActiveFromDate | Описание поля "Дата начала активности".
ActiveToDate | Описание поля "Дата окончания активности".
Code | Описание поля "Символьный код".
CreateDate | Описание поля "Дата создания".
CreatedBy | Описание поля "Идентификатор пользователя, создавшего элемент".
DetailImage | Детальное изображение элемента инфоблока
DetailImageId | Описание поля "Идентификатор детального изображения".
DetailText | Описание поля "Детальный текст".
DetailTextType | Описание поля "Тип детального текста". ("T" или "H")
IBlock | Описание поля "Родительский инфоблок". Связанное поле.
ID | Описание поля "Идентификатор элемента". Первичный ключ.
IncludeParentSections | Описание поля "Включать родительские секции в фильтр?". Вычисляемое поле.
InRootSection | Описание поля "Принадлежит корневому разделу?". Вычисляемое поле.
ModifiedBy | Описание поля "Идентификатор пользователя, изменившего элемент".
Name | Описание поля "Название элемента инфоблока".
PreviewImage | изображение анонса элемента инфоблока
PreviewImageId | Описание поля "Идентификатор изображения анонса".
PreviewText | Описание поля "Текст анонса".
PreviewTextType | Описание поля "Тип текста анонса". ("T" или "H")
Sections | Описание поля "Связанные разделы". Связанное поле.
Sort | Описание поля "Порядок сортировки".
Tags | Описание поля "Теги".
UpdateDate | Описание поля "Дата последнего изменения".
XmlId | Описание поля "Идентификатор для XML".

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Active

Свойство BXIBlockElement..::..Scheme..::.Active
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Активен?". ("Y" или "N")

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Active { get; }

Заметки

При использовании в фильтре необходимо указывать значения "Y" и "N" вместо true или false.

Примеры

Выборка всех активных элементов инфоблока:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterItem(BXIBlockElement.Fields.Active, BXSqlFilterOperators.Equal, "Y"));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ActiveDate

Свойство BXIBlockElement..::..Scheme..::.ActiveDate
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "В интервале активности?". Вычисляемое поле.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ActiveDate { get; }

Заметки

При использовании в фильтре формирует проверку, находится ли текущая дата в интервале активности.

При использовании в фильтре поле должно обязательно использоваться в виде равенства true или "Y"

Примеры

Выборка всех активных элементов инфоблока:

CopyC#
int iblockId;

BXFilter filter = new BXFilter(
    new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId),
    new BXFilterItem(BXIBlockElement.Fields.Active, BXSqlFilterOperators.Equal, "Y"),
    new BXFilterItem(BXIBlockElement.Fields.ActiveDate, BXSqlFilterOperators.Equal, true)
);

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ActiveFromDate

Свойство BXIBlockElement..::..Scheme..::.ActiveFromDate
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Дата начала активности".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ActiveFromDate { get; }

Примеры

Выборка всех активных в настоящий момент элементов из инфоблока:

CopyC#
int iblockId;
DateTime now = DateTime.Now;

BXFilter filter = new BXFilter(
    new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId),
    new BXFilterItem(BXIBlockElement.Fields.Active, BXSqlFilterOperators.Equal, "Y"),
    new BXFilterOr(
        new BXFilterItem(BXIBlockElement.Fields.ActiveFromDate, BXSqlFilterOperators.LessOrEqual, now),
        new BXFilterItem(BXIBlockElement.Fields.ActiveFromDate, BXSqlFilterOperators.Equal, null)
    ),
    new BXFilterOr(
        new BXFilterItem(BXIBlockElement.Fields.ActiveToDate, BXSqlFilterOperators.GreaterOrEqual, now),
        new BXFilterItem(BXIBlockElement.Fields.ActiveToDate, BXSqlFilterOperators.Equal, null)
    )
);

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ActiveToDate

Свойство BXIBlockElement..::..Scheme..::.ActiveToDate
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Дата окончания активности".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ActiveToDate { get; }

Примеры

Выборка всех активных в настоящий момент элементов из инфоблока:

CopyC#
int iblockId;
DateTime now = DateTime.Now;

BXFilter filter = new BXFilter(
    new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId),
    new BXFilterItem(BXIBlockElement.Fields.Active, BXSqlFilterOperators.Equal, "Y"),
    new BXFilterOr(
        new BXFilterItem(BXIBlockElement.Fields.ActiveFromDate, BXSqlFilterOperators.LessOrEqual, now),
        new BXFilterItem(BXIBlockElement.Fields.ActiveFromDate, BXSqlFilterOperators.Equal, null)
    ),
    new BXFilterOr(
        new BXFilterItem(BXIBlockElement.Fields.ActiveToDate, BXSqlFilterOperators.GreaterOrEqual, now),
        new BXFilterItem(BXIBlockElement.Fields.ActiveToDate, BXSqlFilterOperators.Equal, null)
    )
);

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Code

Свойство BXIBlockElement..::..Scheme..::.Code
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Символьный код".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Code { get; }

Примеры

Поиск элемента инфоблока по символьному коду и коду раздела:

CopyC#
int iblockId;
string sectionCode = "nokia";
string elementCode = "n70";

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterItem(BXIBlockElement.Fields.Sections.Section.Code, BXSqlFilterOperators.Equal, sectionCode));
filter.Add(new BXFilterItem(BXIBlockElement.Fields.Code, BXSqlFilterOperators.Equal, elementCode));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);
BXIBlockElement element = elements.Count != 0 ? elements[0] : null;

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство CreateDate

Свойство BXIBlockElement..::..Scheme..::.CreateDate
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Дата создания".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase CreateDate { get; }

Примеры

Выборка всех созданных сегодня элементов в инфоблоке:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterItem(BXIBlockElement.Fields.CreateDate, BXSqlFilterOperators.GreaterOrEqual, DateTime.Today));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство CreatedBy

Свойство BXIBlockElement..::..Scheme..::.CreatedBy
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор пользователя, создавшего элемент".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase CreatedBy { get; }

Примеры

Выборка всех созданных текущим пользователем за последнюю неделю элементов во всех инфоблоках:

CopyC#
int userId = ((BXIdentity)HttpContext.Current.User.Identity).Id;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockElement.Fields.CreateDate, BXSqlFilterOperators.GreaterOrEqual, DateTime.Today.AddDays(-7)));
filter.Add(new BXFilterItem(BXIBlockElement.Fields.CreatedBy, BXSqlFilterOperators.Equal, userId));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство DetailImage

Свойство BXIBlockElement..::..Scheme..::.DetailImage
Класс BXIBlockElement..::..Scheme Смотри также Send Feedback
Детальное изображение элемента инфоблока

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile..::..Scheme DetailImage { get; }

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство DetailImageId

Свойство BXIBlockElement..::..Scheme..::.DetailImageId
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор детального изображения".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase DetailImageId { get; }

Примеры

Выборка всех элементов инфоблока, у которых задано хотя бы одно изображение:

CopyC#
int iblockId;

BXFilter filter = new BXFilter(
    new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId),
    new BXFilterOr(
        new BXFilterItem(BXIBlockElement.Fields.PreviewImageId, BXSqlFilterOperators.NotEqual, null),
        new BXFilterItem(BXIBlockElement.Fields.DetailImageId, BXSqlFilterOperators.NotEqual, null)
    )
);

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство DetailText

Свойство BXIBlockElement..::..Scheme..::.DetailText
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Детальный текст".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase DetailText { get; }

Примеры

Выборка всех элементов, которые содержат слово "битрикс" в названии, анонсе или детальном тексте:

CopyC#
string word = "битрикс";

BXFilter filter = new BXFilter(new BXFilterOr(
    new BXFilterItem(BXIBlockElement.Fields.Name, BXSqlFilterOperators.Like, word),
    new BXFilterItem(BXIBlockElement.Fields.PreviewText, BXSqlFilterOperators.Like, word),
    new BXFilterItem(BXIBlockElement.Fields.DetailText, BXSqlFilterOperators.Like, word)
));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство DetailTextType

Свойство BXIBlockElement..::..Scheme..::.DetailTextType
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Тип детального текста". ("T" или "H")

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase DetailTextType { get; }

Заметки

При использовании в фильтре необходимо указывать значения "T" - для текста и "H" - для HTML.

Примеры

Выборка элементов инфоблока, контент которых задан строго в текстовом формате:

CopyC#
int iblockId;

BXFilter filter = new BXFilter(
    new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId),
    new BXFilterItem(BXIBlockElement.Fields.PreviewTextType, BXSqlFilterOperators.Equal, "T"),
    new BXFilterItem(BXIBlockElement.Fields.DetailTextType, BXSqlFilterOperators.Equal, "T")
);

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство IBlock

Свойство BXIBlockElement..::..Scheme..::.IBlock
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Родительский инфоблок". Связанное поле.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlock..::..Scheme IBlock { get; }

Заметки

Элемент инфоблока связан с одним инфоблоком.

Поле "Родительский инфоблок" позволяет задать фильтр принадлежности элемента к инфоблоку с определенными свойствами.

Примеры

Выборка элементов из инфоблоков, созданных за последнюю неделю:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.CreateDate, BXSqlFilterOperators.GreaterOrEqual, DateTime.Today.AddDays(-7)));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ID

Свойство BXIBlockElement..::..Scheme..::.ID
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор элемента". Первичный ключ.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ID { get; }

Примеры

Выборка всех элементов, добавленных в инфоблок после данного:

CopyC#
BXIBlockElement element;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, element.IBlockId));
filter.Add(new BXFilterItem(BXIBlockElement.Fields.ID, BXSqlFilterOperators.Greater, element.Id));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство IncludeParentSections

Свойство BXIBlockElement..::..Scheme..::.IncludeParentSections
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Включать родительские секции в фильтр?". Вычисляемое поле.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase IncludeParentSections { get; }

Заметки

При использовании в фильтре совместно с фильтром по разделам (см. Sections) добавляет к разделам элемента еще и всю иерархию родительских разделов элемента.

При использовании в фильтре поле должно обязательно использоваться в виде равенства true или "Y"

Примеры

Выборка всех элементов из определенного раздела инфоблока или его подразделов:

CopyC#
int iblockId;
int sectionId;

BXFilter filter = new BXFilter(
    new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId),
    new BXFilterItem(BXIBlockElement.Fields.Sections.Section.ID, BXSqlFilterOperators.Equal, sectionId),
    new BXFilterItem(BXIBlockElement.Fields.IncludeParentSections, BXSqlFilterOperators.Equal, true)
);

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство InRootSection

Свойство BXIBlockElement..::..Scheme..::.InRootSection
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Принадлежит корневому разделу?". Вычисляемое поле.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase InRootSection { get; }

Заметки

Если равно true, то выбирает те элементы, которые располагаются в корневом разделе инфоблока.

При использовании в фильтре поле должно обязательно использоваться в виде равенства/неравенства true/"Y" или false/"N"

Примеры

Выборка всех элементов из определенного раздела инфоблока или его подразделов:

CopyC#
int iblockId;
int sectionId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
if (sectionId != 0)
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.Sections.Section.ID, BXSqlFilterOperators.Equal, sectionId));
else
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.InRootSection, BXSqlFilterOperators.Equal, true));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ModifiedBy

Свойство BXIBlockElement..::..Scheme..::.ModifiedBy
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор пользователя, изменившего элемент".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ModifiedBy { get; }

Примеры

Выборка всех измененных текущим пользователем сегодня элементов во всех инфоблоках:

CopyC#
int userId = ((BXIdentity)HttpContext.Current.User.Identity).Id;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockElement.Fields.UpdateDate, BXSqlFilterOperators.GreaterOrEqual, DateTime.Today));
filter.Add(new BXFilterItem(BXIBlockElement.Fields.ModifiedBy, BXSqlFilterOperators.Equal, userId));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Name

Свойство BXIBlockElement..::..Scheme..::.Name
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Название элемента инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Name { get; }

Примеры

Выборка всех элементов, которые содержат слово "битрикс" в названии, анонсе или детальном тексте:

CopyC#
string word = "битрикс";

BXFilter filter = new BXFilter(new BXFilterOr(
    new BXFilterItem(BXIBlockElement.Fields.Name, BXSqlFilterOperators.Like, word),
    new BXFilterItem(BXIBlockElement.Fields.PreviewText, BXSqlFilterOperators.Like, word),
    new BXFilterItem(BXIBlockElement.Fields.DetailText, BXSqlFilterOperators.Like, word)
));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство PreviewImage

Свойство BXIBlockElement..::..Scheme..::.PreviewImage
Класс BXIBlockElement..::..Scheme Смотри также Send Feedback
изображение анонса элемента инфоблока

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile..::..Scheme PreviewImage { get; }

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство PreviewImageId

Свойство BXIBlockElement..::..Scheme..::.PreviewImageId
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор изображения анонса".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase PreviewImageId { get; }

Примеры

Выборка всех элементов инфоблока, у которых задано хотя бы одно изображение:

CopyC#
int iblockId;

BXFilter filter = new BXFilter(
    new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId),
    new BXFilterOr(
        new BXFilterItem(BXIBlockElement.Fields.PreviewImageId, BXSqlFilterOperators.NotEqual, null),
        new BXFilterItem(BXIBlockElement.Fields.DetailImageId, BXSqlFilterOperators.NotEqual, null)
    )
);

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство PreviewText

Свойство BXIBlockElement..::..Scheme..::.PreviewText
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Текст анонса".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase PreviewText { get; }

Примеры

Выборка всех элементов, которые содержат слово "битрикс" в названии, анонсе или детальном тексте:

CopyC#
string word = "битрикс";

BXFilter filter = new BXFilter(new BXFilterOr(
    new BXFilterItem(BXIBlockElement.Fields.Name, BXSqlFilterOperators.Like, word),
    new BXFilterItem(BXIBlockElement.Fields.PreviewText, BXSqlFilterOperators.Like, word),
    new BXFilterItem(BXIBlockElement.Fields.DetailText, BXSqlFilterOperators.Like, word)
));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство PreviewTextType

Свойство BXIBlockElement..::..Scheme..::.PreviewTextType
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Тип текста анонса". ("T" или "H")

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase PreviewTextType { get; }

Заметки

При использовании в фильтре необходимо указывать значения "T" - для текста и "H" - для HTML.

Примеры

Выборка элементов инфоблока, контент которых задан строго в текстовом формате:

CopyC#
int iblockId;

BXFilter filter = new BXFilter(
    new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId),
    new BXFilterItem(BXIBlockElement.Fields.PreviewTextType, BXSqlFilterOperators.Equal, "T"),
    new BXFilterItem(BXIBlockElement.Fields.DetailTextType, BXSqlFilterOperators.Equal, "T")
);

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Sections

Свойство BXIBlockElement..::..Scheme..::.Sections
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Связанные разделы". Связанное поле.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockElement..::..BXInfoBlockElementSection..::..Scheme Sections { get; }

Заметки

Элемент инфоблока может быть связан с несколькими разделами.

Поле "Связанные разделы" позволяет задать фильтр принадлежности элемента к разделам с определенными свойствами.

Если данное поле использовано в фильтре, то элементы, принадлежащие корневому разделу выбраны не будут. См. поле InRootSection.

Примеры

Выборка элементов из активных разделов инфоблока:

CopyC#
int iblockId;

BXFilter filter = new BXFilter(
    new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId),
    new BXFilterItem(BXIBlockElement.Fields.Sections.Section.ActiveGlobal, BXSqlFilterOperators.Equal, "Y")
);

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Sort

Свойство BXIBlockElement..::..Scheme..::.Sort
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Порядок сортировки".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Sort { get; }

Примеры

Упорядоченная выборка всех элементов инфоблока:

CopyC#
const int IBlockId;

protected BXIBlockElementCollection GetElements()
{
    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, IBlockId));

    BXOrderBy orderBy = new BXOrderBy();
    orderBy.Add(BXIBlockElement.Fields.Sort, BXOrderByDirection.Asc);

    return BXIBlockElement.GetList(filter, orderBy);
}

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Tags

Свойство BXIBlockElement..::..Scheme..::.Tags
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Теги".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Tags { get; }

Примеры

Выборка всех элементов, которые содержат тег "битрикс":

CopyC#
string tag = "битрикс";

BXFilter filter = new BXFilter(
    new BXFilterItem(BXIBlockElement.Fields.Tags, BXSqlFilterOperators.Like, tag)
);

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство UpdateDate

Свойство BXIBlockElement..::..Scheme..::.UpdateDate
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Дата последнего изменения".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase UpdateDate { get; }

Примеры

Выборка всех изменившихся за последнюю неделю элементов из всех инфоблоков:

CopyC#
BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockElement.Fields.UpdateDate, BXSqlFilterOperators.GreaterOrEqual, DateTime.Today.AddDays(-7)));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Свойство XmlId

Свойство BXIBlockElement..::..Scheme..::.XmlId
Класс BXIBlockElement..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор для XML".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase XmlId { get; }

Примеры

Поиск элемента инфоблока по XML идентификатору:

CopyC#
string xmlId = "{DEFD1DD7-AC6D-4760-849F-5772926B616C}";

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockElement.Fields.XmlId, BXSqlFilterOperators.Equal, xmlId));

BXIBlockElementCollection elements = BXIBlockElement.GetList(filter, null);
BXIBlockElement element = elements.Count != 0 ? elements[0] : null;

Смотри также

Класс BXIBlockElement..::..Scheme
Пространство имен Bitrix.IBlock


Класс BXIBlockElement.SchemeCustomFieldSet

Класс BXIBlockElement..::..SchemeCustomFieldSet
Класс BXIBlockElement Члены Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class SchemeCustomFieldSet : BXSchemeCustomFieldSet

Иерархия наследования

System..::..Object
BXSchemeCustomFieldSet
Bitrix.IBlock..::..BXIBlockElement..::..SchemeCustomFieldSet

Смотри также

Члены BXIBlockElement..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Члены BXIBlockElement.SchemeCustomFieldSet

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockElement..::..SchemeCustomFieldSet
Класс BXIBlockElement..::..SchemeCustomFieldSet Конструкторы Методы Свойства Смотри также Send Feedback

Класс определяет сущность "элемент инфоблока".

Тип BXIBlockElement..::..SchemeCustomFieldSet предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockElement..::..SchemeCustomFieldSet |

Методы

Имя | Описание
PrepareOwnerEntityId | (Переопределяет BXSchemeCustomFieldSetPrepareOwnerEntityId(String))

Свойства

Имя | Описание
OwnerEntityRelatedFields | (Переопределяет BXSchemeCustomFieldSetOwnerEntityRelatedFields()()()())

Смотри также

Класс BXIBlockElement..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElement.SchemeCustomFieldSet

Конструктор BXIBlockElement..::..SchemeCustomFieldSet
Класс BXIBlockElement..::..SchemeCustomFieldSet Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public SchemeCustomFieldSet(
    BXSchemeBase ownerScheme
)

Параметры

ownerScheme
Type: BXSchemeBase

Смотри также

Класс BXIBlockElement..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Методы BXIBlockElement.SchemeCustomFieldSet

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockElement..::..SchemeCustomFieldSet
Класс BXIBlockElement..::..SchemeCustomFieldSet Смотри также Send Feedback

Тип BXIBlockElement..::..SchemeCustomFieldSet предоставляет следующие возможности.

Методы

Имя | Описание
PrepareOwnerEntityId | (Переопределяет BXSchemeCustomFieldSetPrepareOwnerEntityId(String))

Смотри также

Класс BXIBlockElement..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Метод PrepareOwnerEntityId

Метод BXIBlockElement..::..SchemeCustomFieldSet..::.PrepareOwnerEntityId
Класс BXIBlockElement..::..SchemeCustomFieldSet Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override string PrepareOwnerEntityId(
    string sourceOwnerEntityId
)

Параметры

sourceOwnerEntityId
Type: System..::..String

Смотри также

Класс BXIBlockElement..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Свойства BXIBlockElement.SchemeCustomFieldSet

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockElement..::..SchemeCustomFieldSet
Класс BXIBlockElement..::..SchemeCustomFieldSet Смотри также Send Feedback

Тип BXIBlockElement..::..SchemeCustomFieldSet предоставляет следующие возможности.

Свойства

Имя | Описание
OwnerEntityRelatedFields | (Переопределяет BXSchemeCustomFieldSetOwnerEntityRelatedFields()()()())

Смотри также

Класс BXIBlockElement..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Свойство OwnerEntityRelatedFields

Свойство BXIBlockElement..::..SchemeCustomFieldSet..::.OwnerEntityRelatedFields
Класс BXIBlockElement..::..SchemeCustomFieldSet Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override BXSchemeFieldBase[] OwnerEntityRelatedFields { get; }

Смотри также

Класс BXIBlockElement..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Класс BXIBlockElementCollection

Класс BXIBlockElementCollection
Члены Пример Смотри также Send Feedback
Коллекция элементов инфоблока. См. BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXIBlockElementCollection : BXEntityCollection<BXIBlockElement, BXIBlockElementCollection, BXIBlockElement..::..Scheme>

Примеры

Выборка активных на данный момент элементов из раздела инфоблока:

CopyC#
const int IBlockId;
const int SectionId;

protected BXIBlockElementCollection GetElements()
{
    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.IBlock.ID, BXSqlFilterOperators.Equal, IBlockId));
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.Sections.Section.ID, BXSqlFilterOperators.Equal, SectionId));
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.Active, BXSqlFilterOperators.Equal, "Y"));
    filter.Add(new BXFilterItem(BXIBlockElement.Fields.ActiveDate, BXSqlFilterOperators.Equal, null));

    BXOrderBy orderBy = new BXOrderBy();
    orderBy.Add(BXIBlockElement.Fields.Sort, BXOrderByDirection.Asc);

    return BXIBlockElement.GetList(filter, orderBy);
}

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<' BXIBlockElement >)>)>
Bitrix.DataLayer..::..BXEntityCollection <(Of <(<' BXIBlockElement, BXIBlockElementCollection, BXIBlockElement..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlockElementCollection

Смотри также

Члены BXIBlockElementCollection
Пространство имен Bitrix.IBlock


Члены BXIBlockElementCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockElementCollection
Класс BXIBlockElementCollection Конструкторы Методы Смотри также Send Feedback

Тип BXIBlockElementCollection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockElementCollection | Конструктор по умолчанию.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Смотри также

Класс BXIBlockElementCollection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElementCollection

Конструктор BXIBlockElementCollection
Класс BXIBlockElementCollection Смотри также Send Feedback
Конструктор по умолчанию.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockElementCollection()

Смотри также

Класс BXIBlockElementCollection
Пространство имен Bitrix.IBlock


Методы BXIBlockElementCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockElementCollection
Класс BXIBlockElementCollection Смотри также Send Feedback

Тип BXIBlockElementCollection предоставляет следующие возможности.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Смотри также

Класс BXIBlockElementCollection
Пространство имен Bitrix.IBlock


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockElementCollection..::.Save
Класс BXIBlockElementCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет все сущности коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет все сущности коллекции, используя указанное соединение. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElementCollection
Члены BXIBlockElementCollection
Пространство имен Bitrix.IBlock


Метод ToDataTable

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockElementCollection..::.ToDataTable
Класс BXIBlockElementCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ToDataTable()()()() | Приводит коллекцию к типу DataTable. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable(BXPagingOptions) | Приводит коллекцию к типу DataTable с применением опций постраничной навигации. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockElementCollection
Члены BXIBlockElementCollection
Пространство имен Bitrix.IBlock


Класс BXIBlockElementEditor

Класс BXIBlockElementEditor
Члены Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract class BXIBlockElementEditor : BXControl

Иерархия наследования

System..::..Object
System.Web.UI..::..Control
System.Web.UI..::..TemplateControl
System.Web.UI..::..UserControl
BXControl
Bitrix.IBlock..::..BXIBlockElementEditor

Смотри также

Члены BXIBlockElementEditor
Пространство имен Bitrix.IBlock


Члены BXIBlockElementEditor

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockElementEditor
Класс BXIBlockElementEditor Конструкторы Методы Смотри также Send Feedback

Тип BXIBlockElementEditor предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockElementEditor |

Методы

Имя | Описание
GetErrorMessages |
HandleSaving |
IsEnabled |
IsValid |

Смотри также

Класс BXIBlockElementEditor
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElementEditor

Конструктор BXIBlockElementEditor
Класс BXIBlockElementEditor Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXIBlockElementEditor()

Смотри также

Класс BXIBlockElementEditor
Пространство имен Bitrix.IBlock


Методы BXIBlockElementEditor

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockElementEditor
Класс BXIBlockElementEditor Смотри также Send Feedback

Тип BXIBlockElementEditor предоставляет следующие возможности.

Методы

Имя | Описание
GetErrorMessages |
HandleSaving |
IsEnabled |
IsValid |

Смотри также

Класс BXIBlockElementEditor
Пространство имен Bitrix.IBlock


Метод GetErrorMessages

Метод BXIBlockElementEditor..::.GetErrorMessages
Класс BXIBlockElementEditor Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract string[] GetErrorMessages()

Смотри также

Класс BXIBlockElementEditor
Пространство имен Bitrix.IBlock


Метод HandleSaving

Метод BXIBlockElementEditor..::.HandleSaving
Класс BXIBlockElementEditor Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract void HandleSaving(
    BXIBlockElement element
)

Параметры

element
Type: Bitrix.IBlock..::..BXIBlockElement

Смотри также

Класс BXIBlockElementEditor
Пространство имен Bitrix.IBlock


Метод IsEnabled

Метод BXIBlockElementEditor..::.IsEnabled
Класс BXIBlockElementEditor Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract bool IsEnabled()

Смотри также

Класс BXIBlockElementEditor
Пространство имен Bitrix.IBlock


Метод IsValid

Метод BXIBlockElementEditor..::.IsValid
Класс BXIBlockElementEditor Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract bool IsValid()

Смотри также

Класс BXIBlockElementEditor
Пространство имен Bitrix.IBlock


Класс BXIBlockElementFieldPublicEditor

Класс BXIBlockElementFieldPublicEditor
Члены Смотри также Send Feedback
Предоставляет средства для редактирования стандартных полей элемента инфоблока (Название, Текст анонса и др.)

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract class BXIBlockElementFieldPublicEditor

Иерархия наследования

System..::..Object
Bitrix.IBlock..::..BXIBlockElementFieldPublicEditor

Смотри также

Члены BXIBlockElementFieldPublicEditor
Пространство имен Bitrix.IBlock


Члены BXIBlockElementFieldPublicEditor

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockElementFieldPublicEditor
Класс BXIBlockElementFieldPublicEditor Конструкторы Методы Смотри также Send Feedback

Тип BXIBlockElementFieldPublicEditor предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockElementFieldPublicEditor |

Методы

Имя | Описание
Load |
Render |
Save |
Validate |

Смотри также

Класс BXIBlockElementFieldPublicEditor
Пространство имен Bitrix.IBlock


Конструктор BXIBlockElementFieldPublicEditor

Конструктор BXIBlockElementFieldPublicEditor
Класс BXIBlockElementFieldPublicEditor Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXIBlockElementFieldPublicEditor()

Смотри также

Класс BXIBlockElementFieldPublicEditor
Пространство имен Bitrix.IBlock


Методы BXIBlockElementFieldPublicEditor

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockElementFieldPublicEditor
Класс BXIBlockElementFieldPublicEditor Смотри также Send Feedback

Тип BXIBlockElementFieldPublicEditor предоставляет следующие возможности.

Методы

Имя | Описание
Load |
Render |
Save |
Validate |

Смотри также

Класс BXIBlockElementFieldPublicEditor
Пространство имен Bitrix.IBlock


Метод Load

Метод BXIBlockElementFieldPublicEditor..::.Load
Класс BXIBlockElementFieldPublicEditor Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract void Load(
    BXIBlockElement iblockElement,
    BXParamsBag<Object> settings
)

Параметры

iblockElement
Type: Bitrix.IBlock..::..BXIBlockElement
settings
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>

Смотри также

Класс BXIBlockElementFieldPublicEditor
Пространство имен Bitrix.IBlock


Метод Render

Метод BXIBlockElementFieldPublicEditor..::.Render
Класс BXIBlockElementFieldPublicEditor Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract string Render(
    string formFieldName,
    string uniqueID
)

Параметры

formFieldName
Type: System..::..String
uniqueID
Type: System..::..String

Смотри также

Класс BXIBlockElementFieldPublicEditor
Пространство имен Bitrix.IBlock


Метод Save

Метод BXIBlockElementFieldPublicEditor..::.Save
Класс BXIBlockElementFieldPublicEditor Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract void Save(
    string formFieldName,
    BXIBlockElement iblockElement,
    BXCustomPropertyCollection properties
)

Параметры

formFieldName
Type: System..::..String
iblockElement
Type: Bitrix.IBlock..::..BXIBlockElement
properties
Type: BXCustomPropertyCollection

Смотри также

Класс BXIBlockElementFieldPublicEditor
Пространство имен Bitrix.IBlock


Метод Validate

Метод BXIBlockElementFieldPublicEditor..::.Validate
Класс BXIBlockElementFieldPublicEditor Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public abstract bool Validate(
    string formFieldName,
    ICollection<string> errors
)

Параметры

formFieldName
Type: System..::..String
errors
Type: System.Collections.Generic..::..ICollection <(Of <(<' String >)>)>

Смотри также

Класс BXIBlockElementFieldPublicEditor
Пространство имен Bitrix.IBlock


Класс BXIBlockIndexController

Класс BXIBlockIndexController
Члены Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static class BXIBlockIndexController

Иерархия наследования

System..::..Object
Bitrix.IBlock..::..BXIBlockIndexController

Смотри также

Члены BXIBlockIndexController
Пространство имен Bitrix.IBlock


Члены BXIBlockIndexController

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockIndexController
Класс BXIBlockIndexController Методы Смотри также Send Feedback

Тип BXIBlockIndexController предоставляет следующие возможности.

Методы

Имя | Описание
DescribeIndexers |
EnumerateIndexers |
RunIndexers |

Смотри также

Класс BXIBlockIndexController
Пространство имен Bitrix.IBlock


Методы BXIBlockIndexController

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockIndexController
Класс BXIBlockIndexController Смотри также Send Feedback

Тип BXIBlockIndexController предоставляет следующие возможности.

Методы

Имя | Описание
DescribeIndexers |
EnumerateIndexers |
RunIndexers |

Смотри также

Класс BXIBlockIndexController
Пространство имен Bitrix.IBlock


Метод DescribeIndexers

Метод BXIBlockIndexController..::.DescribeIndexers
Класс BXIBlockIndexController Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void DescribeIndexers(
    BXCommand command
)

Параметры

command
Type: BXCommand

Смотри также

Класс BXIBlockIndexController
Пространство имен Bitrix.IBlock


Метод EnumerateIndexers

Метод BXIBlockIndexController..::.EnumerateIndexers
Класс BXIBlockIndexController Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void EnumerateIndexers(
    BXCommand command
)

Параметры

command
Type: BXCommand

Смотри также

Класс BXIBlockIndexController
Пространство имен Bitrix.IBlock


Метод RunIndexers

Метод BXIBlockIndexController..::.RunIndexers
Класс BXIBlockIndexController Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void RunIndexers(
    BXCommand command
)

Параметры

command
Type: BXCommand

Смотри также

Класс BXIBlockIndexController
Пространство имен Bitrix.IBlock


Класс BXIBlockModule

Класс BXIBlockModule
Члены Смотри также Send Feedback
Класс модуля "Информационные блоки".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXIBlockModule : BXModule

Заметки

Класс реализует поддержку модульности в продукте. Класс является точкой входа для системы событий и реализует механизм настроек для API информационных блоков, поддержку административного меню и обработку различных внутренних событий системы.

Иерархия наследования

System..::..Object
BXModule
Bitrix.IBlock..::..BXIBlockModule

Смотри также

Члены BXIBlockModule
Пространство имен Bitrix.IBlock


Члены BXIBlockModule

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockModule
Класс BXIBlockModule Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXIBlockModule предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockModule |

Методы

Имя | Описание
GetMessage | Перегруженный.
ReceiveMessage | (Переопределяет BXModuleReceiveMessage(BXCommand))

Свойства

Имя | Описание
Description | (Переопределяет BXModuleDescription()()()())
ModuleId | (Переопределяет BXModuleModuleId()()()())
Name | (Переопределяет BXModuleName()()()())

Смотри также

Класс BXIBlockModule
Пространство имен Bitrix.IBlock


Конструктор BXIBlockModule

Конструктор BXIBlockModule
Класс BXIBlockModule Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockModule()

Смотри также

Класс BXIBlockModule
Пространство имен Bitrix.IBlock


Методы BXIBlockModule

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockModule
Класс BXIBlockModule Смотри также Send Feedback

Тип BXIBlockModule предоставляет следующие возможности.

Методы

Имя | Описание
GetMessage | Перегруженный.
ReceiveMessage | (Переопределяет BXModuleReceiveMessage(BXCommand))

Смотри также

Класс BXIBlockModule
Пространство имен Bitrix.IBlock


Метод GetMessage

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockModule..::.GetMessage
Класс BXIBlockModule Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetMessage(String) | Возвращает языковую фразу для модуля "Информационные блоки"
GetMessage(String, Boolean) | Возвращает языковую фразу для модуля "Информационные блоки"
GetMessage(String, String) | Возвращает языковую фразу для модуля "Информационные блоки"
GetMessage(String, String, Boolean) | Возвращает языковую фразу для модуля "Информационные блоки"

Смотри также

Класс BXIBlockModule
Члены BXIBlockModule
Пространство имен Bitrix.IBlock


Метод GetMessage (String)

Метод BXIBlockModule..::.GetMessage (String)
Класс BXIBlockModule Смотри также Send Feedback
Возвращает языковую фразу для модуля "Информационные блоки"

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetMessage(
    string key
)

Параметры

key
Type: System..::..String
Имя ресурса.

Возвращаемое значение

Cтрока с языковой фразой, соответствующей имени ресурса, или значение по умолчанию (зависит от параметра IsDebugMode), если ресурс с данным именем не найден.

Смотри также

Класс BXIBlockModule
Перегрузка GetMessage
Пространство имен Bitrix.IBlock


Метод GetMessage (String, Boolean)

Метод BXIBlockModule..::.GetMessage (String, Boolean)
Класс BXIBlockModule Смотри также Send Feedback
Возвращает языковую фразу для модуля "Информационные блоки"

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetMessage(
    string key,
    bool encode
)

Параметры

key
Type: System..::..String
Имя ресурса.
encode
Type: System..::..Boolean
Кодировать языковую фразу для вывода в HTML?

Возвращаемое значение

Cтрока с языковой фразой, соответствующей имени ресурса, или значение по умолчанию (зависит от параметра IsDebugMode), если ресурс с данным именем не найден.

Смотри также

Класс BXIBlockModule
Перегрузка GetMessage
Пространство имен Bitrix.IBlock


Метод GetMessage (String, String)

Метод BXIBlockModule..::.GetMessage (String, String)
Класс BXIBlockModule Смотри также Send Feedback
Возвращает языковую фразу для модуля "Информационные блоки"

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetMessage(
    string file,
    string key
)

Параметры

file
Type: System..::..String
Имя специфического языкового файла модуля.
key
Type: System..::..String
Имя ресурса.

Возвращаемое значение

Cтрока с языковой фразой, соответствующей имени ресурса, или значение по умолчанию (зависит от параметра IsDebugMode), если ресурс с данным именем не найден.

Заметки

Файл, задаваемый параметром file должен иметь расширение .lang и располагается в папке модуля. Например, для значения file, равного "UI" фразы будут искаться, например, в файле "~/bitrix/modules/iblock/lang/ru/UI.lang"

Если значение параметра file равно null или String.Empty, фраза будет искаться в языковом файле модуля."

Смотри также

Класс BXIBlockModule
Перегрузка GetMessage
Пространство имен Bitrix.IBlock


Метод GetMessage (String, String, Boolean)

Метод BXIBlockModule..::.GetMessage (String, String, Boolean)
Класс BXIBlockModule Смотри также Send Feedback
Возвращает языковую фразу для модуля "Информационные блоки"

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetMessage(
    string file,
    string key,
    bool encode
)

Параметры

file
Type: System..::..String
Имя специфического языкового файла модуля.
key
Type: System..::..String
Имя ресурса.
encode
Type: System..::..Boolean
Кодировать языковую фразу для вывода в HTML?

Возвращаемое значение

Cтрока с языковой фразой, соответствующей имени ресурса, или значение по умолчанию (зависит от параметра IsDebugMode), если ресурс с данным именем не найден.

Заметки

Файл, задаваемый параметром file должен иметь расширение .lang и располагается в папке модуля. Например, для значения file, равного "UI" фразы будут искаться, например, в файле "~/bitrix/modules/iblock/lang/ru/UI.lang"

Если значение параметра file равно null или String.Empty, фраза будет искаться в языковом файле модуля."

Смотри также

Класс BXIBlockModule
Перегрузка GetMessage
Пространство имен Bitrix.IBlock


Метод ReceiveMessage

Метод BXIBlockModule..::.ReceiveMessage
Класс BXIBlockModule Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override void ReceiveMessage(
    BXCommand command
)

Параметры

command
Type: BXCommand

Смотри также

Класс BXIBlockModule
Пространство имен Bitrix.IBlock


Свойства BXIBlockModule

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockModule
Класс BXIBlockModule Смотри также Send Feedback

Тип BXIBlockModule предоставляет следующие возможности.

Свойства

Имя | Описание
Description | (Переопределяет BXModuleDescription()()()())
ModuleId | (Переопределяет BXModuleModuleId()()()())
Name | (Переопределяет BXModuleName()()()())

Смотри также

Класс BXIBlockModule
Пространство имен Bitrix.IBlock


Свойство Description

Свойство BXIBlockModule..::.Description
Класс BXIBlockModule Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string Description { get; }

Смотри также

Класс BXIBlockModule
Пространство имен Bitrix.IBlock


Свойство ModuleId

Свойство BXIBlockModule..::.ModuleId
Класс BXIBlockModule Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string ModuleId { get; }

Смотри также

Класс BXIBlockModule
Пространство имен Bitrix.IBlock


Свойство Name

Свойство BXIBlockModule..::.Name
Класс BXIBlockModule Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string Name { get; }

Смотри также

Класс BXIBlockModule
Пространство имен Bitrix.IBlock


Класс BXIBlockModuleConfiguration

Класс BXIBlockModuleConfiguration
Члены Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static class BXIBlockModuleConfiguration

Иерархия наследования

System..::..Object
Bitrix.IBlock..::..BXIBlockModuleConfiguration

Смотри также

Члены BXIBlockModuleConfiguration
Пространство имен Bitrix.IBlock


Члены BXIBlockModuleConfiguration

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockModuleConfiguration
Класс BXIBlockModuleConfiguration Поля Свойства Смотри также Send Feedback

Тип BXIBlockModuleConfiguration предоставляет следующие возможности.

Поля

Имя | Описание
UploadDirectoryName | Имя каталога для изображений принадлежащих инфоблокам

Свойства

Имя | Описание
IBlockCustomEntityId |
IBlockElementCustomEntityId |
IBlockSectionCustomEntityId |
ModuleId |
Name |

Смотри также

Класс BXIBlockModuleConfiguration
Пространство имен Bitrix.IBlock


Поля BXIBlockModuleConfiguration

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXIBlockModuleConfiguration
Класс BXIBlockModuleConfiguration Смотри также Send Feedback

Тип BXIBlockModuleConfiguration предоставляет следующие возможности.

Поля

Имя | Описание
UploadDirectoryName | Имя каталога для изображений принадлежащих инфоблокам

Смотри также

Класс BXIBlockModuleConfiguration
Пространство имен Bitrix.IBlock


Поле UploadDirectoryName

Поле BXIBlockModuleConfiguration..::.UploadDirectoryName
Класс BXIBlockModuleConfiguration Смотри также Send Feedback
Имя каталога для изображений принадлежащих инфоблокам

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static readonly string UploadDirectoryName

Смотри также

Класс BXIBlockModuleConfiguration
Пространство имен Bitrix.IBlock


Свойства BXIBlockModuleConfiguration

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockModuleConfiguration
Класс BXIBlockModuleConfiguration Смотри также Send Feedback

Тип BXIBlockModuleConfiguration предоставляет следующие возможности.

Свойства

Имя | Описание
IBlockCustomEntityId |
IBlockElementCustomEntityId |
IBlockSectionCustomEntityId |
ModuleId |
Name |

Смотри также

Класс BXIBlockModuleConfiguration
Пространство имен Bitrix.IBlock


Свойство IBlockCustomEntityId

Свойство BXIBlockModuleConfiguration..::.IBlockCustomEntityId
Класс BXIBlockModuleConfiguration Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string IBlockCustomEntityId { get; }

Смотри также

Класс BXIBlockModuleConfiguration
Пространство имен Bitrix.IBlock


Свойство IBlockElementCustomEntityId

Свойство BXIBlockModuleConfiguration..::.IBlockElementCustomEntityId
Класс BXIBlockModuleConfiguration Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string IBlockElementCustomEntityId { get; }

Смотри также

Класс BXIBlockModuleConfiguration
Пространство имен Bitrix.IBlock


Свойство IBlockSectionCustomEntityId

Свойство BXIBlockModuleConfiguration..::.IBlockSectionCustomEntityId
Класс BXIBlockModuleConfiguration Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string IBlockSectionCustomEntityId { get; }

Смотри также

Класс BXIBlockModuleConfiguration
Пространство имен Bitrix.IBlock


Свойство ModuleId

Свойство BXIBlockModuleConfiguration..::.ModuleId
Класс BXIBlockModuleConfiguration Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string ModuleId { get; }

Смотри также

Класс BXIBlockModuleConfiguration
Пространство имен Bitrix.IBlock


Свойство Name

Свойство BXIBlockModuleConfiguration..::.Name
Класс BXIBlockModuleConfiguration Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string Name { get; }

Смотри также

Класс BXIBlockModuleConfiguration
Пространство имен Bitrix.IBlock


Класс BXIBlockSection

Класс BXIBlockSection
Члены Пример Смотри также Send Feedback
Класс определяет сущность "раздел инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXIBlockSection : BXEntity<BXIBlockSection, BXIBlockSectionCollection, BXIBlockSection..::..Scheme>

Заметки

Раздел инфоблока является единицей структурной организации элементов инфоблока. Другими словами раздел инфоблока объединяет в себе несколько элементов инфоблока и образует иерархическую структуру с другими разделами инфоблока. Один и тот же элемент инфоблока может принадлежать к нескольким разделам, а раздел может не содержать ни одного элемента.

Элементы инфоблока принадлежат какому-то инфоблоку и могут располагаться в одном или нескольких разделах (см. BXIBlockElementCollection)

Примеры

Выборка всех глобально активных разделов инфоблока:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.ActiveGlobal, BXSqlFilterOperators.Equal, "Y"));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, orderBy);

Вывод иерархии активных разделов инфоблока в ASPX-странице:

CopyC#
<ul>
    <li>Верхний узел
    <%
        int iblockId;

        int d = 0;
        foreach (BXIBlockSection section in BXIBlockSection.GetTree(iblockId, 0, true, BXTextEncoder.HtmlTextEncoder))
        {
            if (d == section.DepthLevel)
            {
                %><%= "</li>" %><%
            }
            else if (d < section.DepthLevel)
                while (d < section.DepthLevel)
                {
                    %><ul><%
                    d++;
                }
            else
            {
                while (d > section.DepthLevel)
                {
                    %><%= "</li></ul>" %><%
                    d--;
                }
                %><%= "</li>" %><%
            }
            %><li><%= section.Name %><%
        }
        while (d > 0)
        {
            %></li></ul><%
            d--;
        }
    %>
    </li>
</ul>

Импорт или обновление структуры инфоблока из XML:

CopyC#
void ImportSection(int iblockCode, int parentSectionId, XmlNode node)
{
    string xmlId = node.Attributes["id"].Value;
    BXIBlockSection section = GetByXmlId(iblockCode, xmlId);
    if (section == null)
    {
        section = new BXIBlockSection();
        section.IBlockId = iblockCode;
        section.XmlId = xmlId;
    }

    section.SectionId = parentSectionId;

    if (node.Attributes["name"] != null)
        section.Name = node.Attributes["name"].Value;

    XmlNode description = node.SelectSingleNode("description");
    if (description != null)
    {
        BXTextType type = BXTextType.Text;
        if (description.Attributes["type"] != null
            && string.Equals(description.Attributes["type"].Value, "HTML", StringComparison.OrdinalIgnoreCase))
            type = BXTextType.Html;
        section.DescriptionType = type;
        section.Description = (type == BXTextType.Text) ? description.InnerText : description.InnerXml;
    }

    section.Save();

    foreach(XmlNode subnode in node.SelectNodes("section"))
        ImportSection(iblockCode, section.Id, subnode);
}

void ImportXml(int iblockCode, string filename)
{
    XmlDocument doc = new XmlDocument();
    doc.Load(filename);
    foreach(XmlNode node in doc.DocumentElement.SelectNodes("section"))
        ImportSection(iblockCode, 0, node);
}
CopyXML
<?xml version="1.0" encoding="utf-8" ?>
<sections>
    <section id="{31CDBF90-F766-44a0-A6F2-88793ECF50D0}" name="Root Level 1">
        <description type="Text">Description 1</description>
    </section>
    <section id="{67F05F7A-85AF-4f1f-B051-4B63A3E32DC2}" name="Root Level 2">
        <description type="Text">Description 2</description>
        <section id="{EBC2B17E-AE74-42c5-99B5-D701EC4ED572}" name="Root Level 2 - Sub 1">
            <description type="Text">Description 2.1</description>
        </section>
        <section id="{48AD64F8-A3DC-4cdf-B25A-AE87E77D2D3B}" name="Root Level 2 - Sub 2">
            <description type="Text">Description 2.2</description>
        </section>
    </section>
    <section id="{80799C28-AE0C-49a9-BF80-8B68BDBF25F6}" name="Root Level 3">
        <description type="Text">Description 3</description>
    </section>
</sections>

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXEntity
Bitrix.DataLayer..::..BXEntity <(Of <(<'BXIBlockSection, BXIBlockSectionCollection, BXIBlockSection..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlockSection

Смотри также

Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Члены BXIBlockSection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockSection
Класс BXIBlockSection Конструкторы Методы Поля Свойства Смотри также Send Feedback

Тип BXIBlockSection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockSection | Перегруженный.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CountMixed | Производит подсчет числа элементов и разделов инфоблока, удовлетворяющих по нетипизированному фильтру и строке сортировки.
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..DeleteAdditionalEntities(BXSqlConnection, BXSqlTransaction))
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetCustomFieldsKeyInternal(String))
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetMixedList | Перегруженный.
GetNavChain | Перегруженный.
GetTree | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
VerifyEntry | (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..VerifyEntry()()()())

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Свойства

Имя | Описание
Active | Возвращает или устанавливает, активен ли раздел.
ActiveGlobal | Возвращает, активен ли раздел, с учетом активности родительских разделов.
Code | Возвращает или устанавливает символьный код раздела инфоблока. Закодировано кодировщиком.
CreateDate | Возвращает или устанавливает дату создания раздела инфоблока.
CreatedBy | Возвращает или устанавливает ID пользователя создавшего раздел
CreatedByUser | Возвращает пользователя, создавшего раздел инфоблока.
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Переопределяет BXEntity..::..CustomFieldsKey)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DepthLevel | Возвращает глубину вложенности раздела инфоблока в структуре "Вложенные множества".
Description | Возвращает или устанавливает описание раздела инфоблока. Закодировано кодировщиком.
DescriptionType | Возвращает или устанавливает тип текста описания раздела инфоблока (текст или HTML).
DetailImage | Возвращает сущность "файл" для раздела инфоблока, заданную свойством DetailImageId.
DetailImageId | Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится детальное изображение для раздела инфоблока.
ElementsCount | Возвращает количество непосредственных элементов в разделе инфоблока.
EntityId | Возвращает "IBlockSection". (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..EntityId)
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
IBlock | Запрос инфоблока
IBlockId | Возвращает или устанавливает идентификатор родительского инфоблока. Обязательное свойство.
Id | Возвращает или устанавливает идентификатор раздела инфоблока. Первичный ключ.
Image | Возвращает сущность "файл" для раздела инфоблока, заданную свойством ImageId.
ImageId | Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится изображение для раздела инфоблока.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
LeftMargin | Возвращает левую границу раздела инфоблока в структуре "Вложенные множества".
ModifiedBy | Возвращает или устанавливает ID пользователя изменившего раздел
ModifiedByUser | Возвращает пользователя, изменившего раздел инфоблока.
ModuleId | Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..ModuleId)
Name | Возвращает или устанавливает название раздела инфоблока. Обязательное свойство. Закодировано кодировщиком.
RightMargin | Возвращает правую границу раздела инфоблока в структуре "Вложенные множества".
SectionId | Возвращает или устанавливает идентификатор родительского раздела инфоблока.
SectionsCount | Возвращает количество непосредственных подразделов в разделе инфоблока.
Sort | Возвращает или устанавливает порядок сортировки элемента инфоблока:
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateDate | Возвращает или устанавливает дату последнего изменения свойств раздела.
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
XmlId | Возвращает или устанавливает идентификатор элемента инфоблока для экспорта в XML. Закодировано кодировщиком.
XmlTagName | Имя Xml тега

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockSection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXIBlockSection
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXIBlockSection()()()() | Создает экземпляр сущности "элемент инфоблока"
BXIBlockSection(IBXTextEncoder) | Создает экземпляр сущности "элемент инфоблока" с выбранным кодировщиком текстовых полей.
BXIBlockSection(Int32, Int32, String) | Создает экземпляр сущности "элемент инфоблока"
BXIBlockSection(Int32, Int32, String, IBXTextEncoder) | Создает экземпляр сущности "элемент инфоблока" с выбранным кодировщиком текстовых полей.

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockSection

Конструктор BXIBlockSection
Класс BXIBlockSection Смотри также Send Feedback
Создает экземпляр сущности "элемент инфоблока"

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockSection()

Смотри также

Класс BXIBlockSection
Перегрузка BXIBlockSection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockSection ()

Конструктор BXIBlockSection ()
Класс BXIBlockSection Смотри также Send Feedback
Создает экземпляр сущности "элемент инфоблока" с выбранным кодировщиком текстовых полей.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockSection(
    IBXTextEncoder textEncoder
)

Параметры

textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей.

Смотри также

Класс BXIBlockSection
Перегрузка BXIBlockSection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockSection (Int32, Int32, String)

Конструктор BXIBlockSection (Int32, Int32, String)
Класс BXIBlockSection Смотри также Send Feedback
Создает экземпляр сущности "элемент инфоблока"

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockSection(
    int iblockId,
    int sectionId,
    string name
)

Параметры

iblockId
Type: System..::..Int32
Идентификатор родительского инфоблока.
sectionId
Type: System..::..Int32
Идентификатор родительского раздела.
name
Type: System..::..String
Название раздела.

Заметки

Параметр sectionId может равняться 0 для разделов верхнего уровня.

Смотри также

Класс BXIBlockSection
Перегрузка BXIBlockSection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockSection (Int32, Int32, String, )

Конструктор BXIBlockSection (Int32, Int32, String, )
Класс BXIBlockSection Смотри также Send Feedback
Создает экземпляр сущности "элемент инфоблока" с выбранным кодировщиком текстовых полей.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockSection(
    int iblockId,
    int sectionId,
    string name,
    IBXTextEncoder textEncoder
)

Параметры

iblockId
Type: System..::..Int32
Идентификатор родительского инфоблока.
sectionId
Type: System..::..Int32
Идентификатор родительского раздела.
name
Type: System..::..String
Название раздела.
textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей.

Заметки

Параметр sectionId может равняться 0 для разделов верхнего уровня.

Смотри также

Класс BXIBlockSection
Перегрузка BXIBlockSection
Пространство имен Bitrix.IBlock


Поля BXIBlockSection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXIBlockSection
Класс BXIBlockSection Смотри также Send Feedback

Тип BXIBlockSection предоставляет следующие возможности.

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Методы BXIBlockSection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockSection
Класс BXIBlockSection Смотри также Send Feedback

Тип BXIBlockSection предоставляет следующие возможности.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CountMixed | Производит подсчет числа элементов и разделов инфоблока, удовлетворяющих по нетипизированному фильтру и строке сортировки.
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..DeleteAdditionalEntities(BXSqlConnection, BXSqlTransaction))
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..GetCustomFieldsKeyInternal(String))
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetMixedList | Перегруженный.
GetNavChain | Перегруженный.
GetTree | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
VerifyEntry | (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..VerifyEntry()()()())

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Метод CountMixed

Метод BXIBlockSection..::.CountMixed
Класс BXIBlockSection Пример Смотри также Send Feedback
Производит подсчет числа элементов и разделов инфоблока, удовлетворяющих по нетипизированному фильтру и строке сортировки.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static int CountMixed(
    BXFormFilter filter
)

Параметры

filter
Type: BXFormFilter
Нетипизированный фильтр.

Возвращаемое значение

Количество элементов или разделов, удовлетворяющих фильтру.

Примеры

Вывод содержимого корневого раздела инфоблока с разбиением на страницы:

CopyC#
<%
    int iblockId;

    int pageSize = 5;
    BXFormFilter filter = new BXFormFilter();
    filter.Add("IBlockId", iblockId, BXSqlFilterOperators.Equal);
    filter.Add("SectionId", 0, BXSqlFilterOperators.Equal);

    int count = BXIBlockSection.CountMixed(filter);
    if (count > 0)
    {
        int pages = ((count - 1) / pageSize) + 1;

        int curPage;
        int.TryParse(Request.QueryString["page"], out curPage);
        curPage = Math.Max(Math.Min(curPage, pages), 1);

        BXQueryParams queryParams = new BXQueryParams(new BXPagingOptions((curPage - 1) * pageSize, pageSize));

        BXIBlockCommonCollection items = BXIBlockSection.GetMixedList(filter, "Name DESC", queryParams, BXTextEncoder.HtmlTextEncoder);
%>
    Страница <%= curPage %> из <%= pages %><br />
    <ul>
        <%
        foreach (BXEntity entity in items)
        {
            BXIBlockSection section = entity as BXIBlockSection;
            if (section != null)
            {
        %>
            <li>Раздел "<%= section.Name %>"</li>
        <%
                continue;
            }

            BXIBlockElement element = (BXIBlockElement)entity;
        %>
            <li>Элемент "<%= element.Name %>"</li>
        <%
        }
        %>
    </ul>
<%
    }
%>

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Метод Create

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSection..::.Create
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Create()()()() | Добавляет новую сущность в базу данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create(BXSqlConnection, BXSqlTransaction) | Добавляет новую сущность в базу данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Метод Delete

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSection..::.Delete
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Delete()()()() | Удаляет текущую сущность из базы данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete(BXSqlConnection, BXSqlTransaction) | Удаляет текущую сущность из базы данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Метод DeleteAdditionalEntities

Метод BXIBlockSection..::.DeleteAdditionalEntities
Класс BXIBlockSection Смотри также Send Feedback
Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override void DeleteAdditionalEntities(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Заметки

Удаляет связанные с разделом подразделы, а также элементы (если они привязаны только к текущему разделу).

Этот метод ничего не делает в базовой реализации сущности, но может быть переопределен в конкретной сущности.

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Метод DeleteInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSection..::.DeleteInternal
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
DeleteInternal(Object) | Внутренний метод удаления сущностей по первичному ключу id, который вызывается статическим методом Delete(Object). (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter) | Внутренний метод удаления сущностей по фильтру, который вызывается статическим методом Delete(BXFilter). При удалении не отправляются никакие комманды и не удаляются дополнительные данные. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter, BXSqlConnection, BXSqlTransaction) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Метод GetByIdInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSection..::.GetByIdInternal
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetByIdInternal(Object, IBXTextEncoder) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal(Object, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Метод GetCustomFieldsKeyInternal

Метод BXIBlockSection..::.GetCustomFieldsKeyInternal
Класс BXIBlockSection Смотри также Send Feedback
Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override string GetCustomFieldsKeyInternal(
    string id
)

Параметры

id
Type: System..::..String
Параметр ключа.

Возвращаемое значение

Строка, содержащая код.

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Метод GetJoinedEntity

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSection..::.GetJoinedEntity
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String, BXSchemeBase) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Метод GetJoinedEntityCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSection..::.GetJoinedEntityCollection
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType, JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>)(String, String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Метод GetListInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSection..::.GetListInternal
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Метод GetMixedList

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSection..::.GetMixedList
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetMixedList(BXFormFilter, String) | Производит выборку элементов и разделов инфоблока по нетипизированному фильтру и строке сортировки.
GetMixedList(BXFormFilter, String, BXQueryParams) | Производит выборку элементов и разделов инфоблока по нетипизированному фильтру и строке сортировки.
GetMixedList(BXFormFilter, String, BXQueryParams, BXTextEncoder) | Производит выборку элементов и разделов инфоблока по нетипизированному фильтру и строке сортировки.

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Метод GetMixedList (, String)

Метод BXIBlockSection..::.GetMixedList (, String)
Класс BXIBlockSection Пример Смотри также Send Feedback
Производит выборку элементов и разделов инфоблока по нетипизированному фильтру и строке сортировки.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXIBlockCommonCollection GetMixedList(
    BXFormFilter filter,
    string sortOrder
)

Параметры

filter
Type: BXFormFilter
Нетипизированный фильтр.
sortOrder
Type: System..::..String
Строка сортировки.

Возвращаемое значение

Коллекция сущностей BXIBlockSection и BXIBlockElement упорядоченная по типу сущности и строке сортировки.

Примеры

Вывод содержимого корневого раздела инфоблока с разбиением на страницы:

CopyC#
<%
    int iblockId;

    int pageSize = 5;
    BXFormFilter filter = new BXFormFilter();
    filter.Add("IBlockId", iblockId, BXSqlFilterOperators.Equal);
    filter.Add("SectionId", 0, BXSqlFilterOperators.Equal);

    int count = BXIBlockSection.CountMixed(filter);
    if (count > 0)
    {
        int pages = ((count - 1) / pageSize) + 1;

        int curPage;
        int.TryParse(Request.QueryString["page"], out curPage);
        curPage = Math.Max(Math.Min(curPage, pages), 1);

        BXQueryParams queryParams = new BXQueryParams(new BXPagingOptions((curPage - 1) * pageSize, pageSize));

        BXIBlockCommonCollection items = BXIBlockSection.GetMixedList(filter, "Name DESC", queryParams, BXTextEncoder.HtmlTextEncoder);
%>
    Страница <%= curPage %> из <%= pages %><br />
    <ul>
        <%
        foreach (BXEntity entity in items)
        {
            BXIBlockSection section = entity as BXIBlockSection;
            if (section != null)
            {
        %>
            <li>Раздел "<%= section.Name %>"</li>
        <%
                continue;
            }

            BXIBlockElement element = (BXIBlockElement)entity;
        %>
            <li>Элемент "<%= element.Name %>"</li>
        <%
        }
        %>
    </ul>
<%
    }
%>

Смотри также

Класс BXIBlockSection
Перегрузка GetMixedList
Пространство имен Bitrix.IBlock


Метод GetMixedList (, String, BXQueryParams)

Метод BXIBlockSection..::.GetMixedList (, String, BXQueryParams)
Класс BXIBlockSection Пример Смотри также Send Feedback
Производит выборку элементов и разделов инфоблока по нетипизированному фильтру и строке сортировки.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXIBlockCommonCollection GetMixedList(
    BXFormFilter filter,
    string sortOrder,
    BXQueryParams queryParams
)

Параметры

filter
Type: BXFormFilter
Нетипизированный фильтр.
sortOrder
Type: System..::..String
Строка сортировки.
queryParams
Type: Bitrix.DataLayer..::..BXQueryParams
Параметры выборки.

Возвращаемое значение

Коллекция сущностей BXIBlockSection и BXIBlockElement упорядоченная по типу сущности и строке сортировки.

Примеры

Вывод содержимого корневого раздела инфоблока с разбиением на страницы:

CopyC#
<%
    int iblockId;

    int pageSize = 5;
    BXFormFilter filter = new BXFormFilter();
    filter.Add("IBlockId", iblockId, BXSqlFilterOperators.Equal);
    filter.Add("SectionId", 0, BXSqlFilterOperators.Equal);

    int count = BXIBlockSection.CountMixed(filter);
    if (count > 0)
    {
        int pages = ((count - 1) / pageSize) + 1;

        int curPage;
        int.TryParse(Request.QueryString["page"], out curPage);
        curPage = Math.Max(Math.Min(curPage, pages), 1);

        BXQueryParams queryParams = new BXQueryParams(new BXPagingOptions((curPage - 1) * pageSize, pageSize));

        BXIBlockCommonCollection items = BXIBlockSection.GetMixedList(filter, "Name DESC", queryParams, BXTextEncoder.HtmlTextEncoder);
%>
    Страница <%= curPage %> из <%= pages %><br />
    <ul>
        <%
        foreach (BXEntity entity in items)
        {
            BXIBlockSection section = entity as BXIBlockSection;
            if (section != null)
            {
        %>
            <li>Раздел "<%= section.Name %>"</li>
        <%
                continue;
            }

            BXIBlockElement element = (BXIBlockElement)entity;
        %>
            <li>Элемент "<%= element.Name %>"</li>
        <%
        }
        %>
    </ul>
<%
    }
%>

Смотри также

Класс BXIBlockSection
Перегрузка GetMixedList
Пространство имен Bitrix.IBlock


Метод GetMixedList (, String, BXQueryParams, )

Метод BXIBlockSection..::.GetMixedList (, String, BXQueryParams, )
Класс BXIBlockSection Пример Смотри также Send Feedback
Производит выборку элементов и разделов инфоблока по нетипизированному фильтру и строке сортировки.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXIBlockCommonCollection GetMixedList(
    BXFormFilter filter,
    string sortOrder,
    BXQueryParams queryParams,
    BXTextEncoder textEncoder
)

Параметры

filter
Type: BXFormFilter
Нетипизированный фильтр.
sortOrder
Type: System..::..String
Строка сортировки.
queryParams
Type: Bitrix.DataLayer..::..BXQueryParams
Параметры выборки.
textEncoder
Type: BXTextEncoder
Кодировщик текстовых полей.

Возвращаемое значение

Коллекция сущностей BXIBlockSection и BXIBlockElement упорядоченная по типу сущности и строке сортировки.

Примеры

Вывод содержимого корневого раздела инфоблока с разбиением на страницы:

CopyC#
<%
    int iblockId;

    int pageSize = 5;
    BXFormFilter filter = new BXFormFilter();
    filter.Add("IBlockId", iblockId, BXSqlFilterOperators.Equal);
    filter.Add("SectionId", 0, BXSqlFilterOperators.Equal);

    int count = BXIBlockSection.CountMixed(filter);
    if (count > 0)
    {
        int pages = ((count - 1) / pageSize) + 1;

        int curPage;
        int.TryParse(Request.QueryString["page"], out curPage);
        curPage = Math.Max(Math.Min(curPage, pages), 1);

        BXQueryParams queryParams = new BXQueryParams(new BXPagingOptions((curPage - 1) * pageSize, pageSize));

        BXIBlockCommonCollection items = BXIBlockSection.GetMixedList(filter, "Name DESC", queryParams, BXTextEncoder.HtmlTextEncoder);
%>
    Страница <%= curPage %> из <%= pages %><br />
    <ul>
        <%
        foreach (BXEntity entity in items)
        {
            BXIBlockSection section = entity as BXIBlockSection;
            if (section != null)
            {
        %>
            <li>Раздел "<%= section.Name %>"</li>
        <%
                continue;
            }

            BXIBlockElement element = (BXIBlockElement)entity;
        %>
            <li>Элемент "<%= element.Name %>"</li>
        <%
        }
        %>
    </ul>
<%
    }
%>

Смотри также

Класс BXIBlockSection
Перегрузка GetMixedList
Пространство имен Bitrix.IBlock


Метод GetNavChain

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSection..::.GetNavChain
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetNavChain(Int32) | Производит выборку цепочки иерархии родительских разделов для раздела инфоблока (включая сам раздел).
GetNavChain(Int32, IBXTextEncoder) | Производит выборку цепочки иерархии родительских разделов для раздела инфоблока (включая сам раздел).

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Метод GetNavChain (Int32)

Метод BXIBlockSection..::.GetNavChain (Int32)
Класс BXIBlockSection Пример Смотри также Send Feedback
Производит выборку цепочки иерархии родительских разделов для раздела инфоблока (включая сам раздел).

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXIBlockSectionCollection GetNavChain(
    int sectionId
)

Параметры

sectionId
Type: System..::..Int32
Идентификатор раздела инфоблока.

Возвращаемое значение

Коллекция сущностей BXIBlockSection, упроядоченная по полю DepthLevel

Примеры

Вывод навигационной цепочки для элемента инфоблока в ASPX-странице:

CopyC#
<%
    BXIBlockElement element;

    BXIBlock iblock = BXIBlock.GetById(element.IBlockId, element.TextEncoder);
%>
<%= iblock.Name %> &rarr;
<%
    if (element.Sections.Count > 0)
        foreach (BXIBlockSection section in BXIBlockSection.GetNavChain(element.Sections[0].SectionId, element.TextEncoder))
        {
            %><%= section.Name %> &rarr; <%
        }
%>
<%= element.Name %>

Смотри также

Класс BXIBlockSection
Перегрузка GetNavChain
Пространство имен Bitrix.IBlock


Метод GetNavChain (Int32, )

Метод BXIBlockSection..::.GetNavChain (Int32, )
Класс BXIBlockSection Пример Смотри также Send Feedback
Производит выборку цепочки иерархии родительских разделов для раздела инфоблока (включая сам раздел).

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXIBlockSectionCollection GetNavChain(
    int sectionId,
    IBXTextEncoder textEncoder
)

Параметры

sectionId
Type: System..::..Int32
Идентификатор раздела инфоблока.
textEncoder
Type: IBXTextEncoder
Кодировщик для текстовых полей.

Возвращаемое значение

Коллекция сущностей BXIBlockSection, упроядоченная по полю DepthLevel

Примеры

Вывод навигационной цепочки для элемента инфоблока в ASPX-странице:

CopyC#
<%
    BXIBlockElement element;

    BXIBlock iblock = BXIBlock.GetById(element.IBlockId, element.TextEncoder);
%>
<%= iblock.Name %> &rarr;
<%
    if (element.Sections.Count > 0)
        foreach (BXIBlockSection section in BXIBlockSection.GetNavChain(element.Sections[0].SectionId, element.TextEncoder))
        {
            %><%= section.Name %> &rarr; <%
        }
%>
<%= element.Name %>

Смотри также

Класс BXIBlockSection
Перегрузка GetNavChain
Пространство имен Bitrix.IBlock


Метод GetTree

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSection..::.GetTree
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetTree(Int32) | Производит выборку всех разделов инфоблока отсортированных в порядке обхода "Родитель - 1-й ребенок - ... - N-й ребенок".
GetTree(Int32, Int32) | Производит выборку разделов инфоблока с определенной глубиной вложенности отсортированных в порядке обхода "Родитель - 1-й ребенок - ... - N-й ребенок".
GetTree(Int32, Int32, Boolean) | Производит выборку разделов инфоблока с определенной глубиной вложенности и заданной активностью отсортированных в порядке обхода "Родитель - 1-й ребенок - ... - N-й ребенок".
GetTree(Int32, Int32, Boolean, IBXTextEncoder) | Производит выборку разделов инфоблока с определенной глубиной вложенности и заданной активностью отсортированных в порядке обхода "Родитель - 1-й ребенок - ... - N-й ребенок" с заданным кодировщиком текстовых полей.

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Метод GetTree (Int32)

Метод BXIBlockSection..::.GetTree (Int32)
Класс BXIBlockSection Пример Смотри также Send Feedback
Производит выборку всех разделов инфоблока отсортированных в порядке обхода "Родитель - 1-й ребенок - ... - N-й ребенок".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXIBlockSectionCollection GetTree(
    int iblockId
)

Параметры

iblockId
Type: System..::..Int32
Идентификатор родительского инфоблока.

Возвращаемое значение

Коллекция сущностей BXIBlockSection, упорядоченная по полю DepthLevel

Примеры

Пример использования см. в описании метода GetTree(Int32, Int32, Boolean, IBXTextEncoder)

Смотри также

Класс BXIBlockSection
Перегрузка GetTree
Пространство имен Bitrix.IBlock


Метод GetTree (Int32, Int32)

Метод BXIBlockSection..::.GetTree (Int32, Int32)
Класс BXIBlockSection Пример Смотри также Send Feedback
Производит выборку разделов инфоблока с определенной глубиной вложенности отсортированных в порядке обхода "Родитель - 1-й ребенок - ... - N-й ребенок".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXIBlockSectionCollection GetTree(
    int iblockId,
    int depthLevel
)

Параметры

iblockId
Type: System..::..Int32
Идентификатор родительского инфоблока.
depthLevel
Type: System..::..Int32
Глубина выборки (0 - для неограниченной).

Возвращаемое значение

Коллекция сущностей BXIBlockSection, упорядоченная по полю DepthLevel

Заметки

Для того чтобы выбрать все разделы без ограничения по глубине вложенности, необходимо задать depthLevel равным 0.

Для того чтобы выбрать все разделы верхнего уровня, необходимо задать depthLevel равным 1 и т.д.

Примеры

Пример использования см. в описании метода GetTree(Int32, Int32, Boolean, IBXTextEncoder)

Смотри также

Класс BXIBlockSection
Перегрузка GetTree
Пространство имен Bitrix.IBlock


Метод GetTree (Int32, Int32, Boolean)

Метод BXIBlockSection..::.GetTree (Int32, Int32, Boolean)
Класс BXIBlockSection Пример Смотри также Send Feedback
Производит выборку разделов инфоблока с определенной глубиной вложенности и заданной активностью отсортированных в порядке обхода "Родитель - 1-й ребенок - ... - N-й ребенок".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXIBlockSectionCollection GetTree(
    int iblockId,
    int depthLevel,
    bool activeGlobalOnly
)

Параметры

iblockId
Type: System..::..Int32
Идентификатор родительского инфоблока.
depthLevel
Type: System..::..Int32
Глубина выборки (0 - для неограниченной).
activeGlobalOnly
Type: System..::..Boolean
Выбирать только глобально активные разделы?

Возвращаемое значение

Коллекция сущностей BXIBlockSection, упорядоченная по полю DepthLevel

Заметки

Для того чтобы выбрать все разделы без ограничения по глубине вложенности, необходимо задать depthLevel равным 0.

Для того чтобы выбрать все разделы верхнего уровня, необходимо задать depthLevel равным 1 и т.д.

Примеры

Пример использования см. в описании метода GetTree(Int32, Int32, Boolean, IBXTextEncoder)

Смотри также

Класс BXIBlockSection
Перегрузка GetTree
Пространство имен Bitrix.IBlock
BXIBlockSection..::..ActiveGlobal


Метод GetTree (Int32, Int32, Boolean, )

Метод BXIBlockSection..::.GetTree (Int32, Int32, Boolean, )
Класс BXIBlockSection Пример Смотри также Send Feedback
Производит выборку разделов инфоблока с определенной глубиной вложенности и заданной активностью отсортированных в порядке обхода "Родитель - 1-й ребенок - ... - N-й ребенок" с заданным кодировщиком текстовых полей.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXIBlockSectionCollection GetTree(
    int iblockId,
    int depthLevel,
    bool activeGlobalOnly,
    IBXTextEncoder textEncoder
)

Параметры

iblockId
Type: System..::..Int32
Идентификатор родительского инфоблока.
depthLevel
Type: System..::..Int32
Глубина выборки (0 - для неограниченной).
activeGlobalOnly
Type: System..::..Boolean
Выбирать только глобально активные разделы?
textEncoder
Type: IBXTextEncoder
Кодировщик текста для сущностей в выборке.

Возвращаемое значение

Коллекция сущностей BXIBlockSection, упорядоченная по полю DepthLevel

Заметки

Для того чтобы выбрать все разделы без ограничения по глубине вложенности, необходимо задать depthLevel равным 0.

Для того чтобы выбрать все разделы верхнего уровня, необходимо задать depthLevel равным 1 и т.д.

Примеры

Вывод иерархии активных разделов инфоблока в ASPX-странице:

CopyC#
<ul>
    <li>Верхний узел
    <%
        int iblockId;

        int d = 0;
        foreach (BXIBlockSection section in BXIBlockSection.GetTree(iblockId, 0, true, BXTextEncoder.HtmlTextEncoder))
        {
            if (d == section.DepthLevel)
            {
                %><%= "</li>" %><%
            }
            else if (d < section.DepthLevel)
                while (d < section.DepthLevel)
                {
                    %><ul><%
                    d++;
                }
            else
            {
                while (d > section.DepthLevel)
                {
                    %><%= "</li></ul>" %><%
                    d--;
                }
                %><%= "</li>" %><%
            }
            %><li><%= section.Name %><%
        }
        while (d > 0)
        {
            %></li></ul><%
            d--;
        }
    %>
    </li>
</ul>

Смотри также

Класс BXIBlockSection
Перегрузка GetTree
Пространство имен Bitrix.IBlock
BXIBlockSection..::..ActiveGlobal


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSection..::.Save
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет сущность в базе данных в новой транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет сущность в базе данных в указанной транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Метод SetValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSection..::.SetValue
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
SetValue(KeyValuePair<(Of <<'(String, Object>)>>), Boolean) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object, Boolean) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Метод Update

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSection..::.Update
Класс BXIBlockSection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Update()()()() | Изменяет существующую сущность в базе данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update(BXSqlConnection, BXSqlTransaction) | Изменяет существующую сущность в базе данных в указанной транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockSection
Члены BXIBlockSection
Пространство имен Bitrix.IBlock


Метод VerifyEntry

Метод BXIBlockSection..::.VerifyEntry
Класс BXIBlockSection Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override BXModifyStatus VerifyEntry()

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойства BXIBlockSection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockSection
Класс BXIBlockSection Смотри также Send Feedback

Тип BXIBlockSection предоставляет следующие возможности.

Свойства

Имя | Описание
Active | Возвращает или устанавливает, активен ли раздел.
ActiveGlobal | Возвращает, активен ли раздел, с учетом активности родительских разделов.
Code | Возвращает или устанавливает символьный код раздела инфоблока. Закодировано кодировщиком.
CreateDate | Возвращает или устанавливает дату создания раздела инфоблока.
CreatedBy | Возвращает или устанавливает ID пользователя создавшего раздел
CreatedByUser | Возвращает пользователя, создавшего раздел инфоблока.
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Переопределяет BXEntity..::..CustomFieldsKey)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DepthLevel | Возвращает глубину вложенности раздела инфоблока в структуре "Вложенные множества".
Description | Возвращает или устанавливает описание раздела инфоблока. Закодировано кодировщиком.
DescriptionType | Возвращает или устанавливает тип текста описания раздела инфоблока (текст или HTML).
DetailImage | Возвращает сущность "файл" для раздела инфоблока, заданную свойством DetailImageId.
DetailImageId | Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится детальное изображение для раздела инфоблока.
ElementsCount | Возвращает количество непосредственных элементов в разделе инфоблока.
EntityId | Возвращает "IBlockSection". (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..EntityId)
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
IBlock | Запрос инфоблока
IBlockId | Возвращает или устанавливает идентификатор родительского инфоблока. Обязательное свойство.
Id | Возвращает или устанавливает идентификатор раздела инфоблока. Первичный ключ.
Image | Возвращает сущность "файл" для раздела инфоблока, заданную свойством ImageId.
ImageId | Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится изображение для раздела инфоблока.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
LeftMargin | Возвращает левую границу раздела инфоблока в структуре "Вложенные множества".
ModifiedBy | Возвращает или устанавливает ID пользователя изменившего раздел
ModifiedByUser | Возвращает пользователя, изменившего раздел инфоблока.
ModuleId | Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..ModuleId)
Name | Возвращает или устанавливает название раздела инфоблока. Обязательное свойство. Закодировано кодировщиком.
RightMargin | Возвращает правую границу раздела инфоблока в структуре "Вложенные множества".
SectionId | Возвращает или устанавливает идентификатор родительского раздела инфоблока.
SectionsCount | Возвращает количество непосредственных подразделов в разделе инфоблока.
Sort | Возвращает или устанавливает порядок сортировки элемента инфоблока:
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateDate | Возвращает или устанавливает дату последнего изменения свойств раздела.
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
XmlId | Возвращает или устанавливает идентификатор элемента инфоблока для экспорта в XML. Закодировано кодировщиком.
XmlTagName | Имя Xml тега

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство Active

Свойство BXIBlockSection..::.Active
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает, активен ли раздел.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool Active { get; set; }

Примеры

Создание раздела в текущем разделе инфоблока:

CopyC#
        BXIBlockSection parentSection;

        BXIBlockSection section = new BXIBlockSection();
        section.IBlockId = parentSection.IBlockId;
        section.Name = "Lorem Ipsum";
        section.DescriptionType = BXTextType.Html;
        section.Description =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        section.SectionId = parentSection.Id;

        using (FileStream file = new FileStream(MapPath("~/image.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "image.png", "", "iblock", "Малый Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.ImageId = image.Id;
            }
        }

        using (FileStream file = new FileStream(MapPath("~/detail.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "detail.png", "", "iblock", "Большой Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.DetailImageId = image.Id;
            }
        }

        section.Active = true;
        section.Code = "ipsum";
        section.XmlId = Guid.NewGuid().ToString();

        section.Save();

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство ActiveGlobal

Свойство BXIBlockSection..::.ActiveGlobal
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает, активен ли раздел, с учетом активности родительских разделов.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool ActiveGlobal { get; }

Заметки

На основе свойств SectionId и Active при сохранении сущности в БД вычисляется значение свойства ActiveGlobal для соответствующих разделов.

Примеры

Вывод структуры всех инфоблоков в ASPX-странице:

CopyC#
<ul>
<%
BXIBlockCollection iblocks = BXIBlock.GetList(
    null,
    new BXOrderBy(
        new BXOrderByPair(BXIBlock.Fields.Type.ID, BXOrderByDirection.Asc),
        new BXOrderByPair(BXIBlock.Fields.ID, BXOrderByDirection.Asc)
    )
);

int i = 0;
int depth = 0;
BXIBlock iblock = null;

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.IBlock.Type.ID, BXOrderByDirection.Asc);
orderBy.Add(BXIBlockSection.Fields.IBlock.ID, BXOrderByDirection.Asc);
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

foreach (BXIBlockSection section in BXIBlockSection.GetList(null, orderBy))
{
    if (iblock == null || section.IBlockId != iblock.Id)
    {
        while (depth > 0)
        {
            %><%= "</li></ul>" %><%
            depth--;
        }

        while (iblock == null || iblock.Id != section.IBlockId)
        {
            iblock = iblocks[i++];
            %>
                <li><b><%= iblock.Name %> (<%= iblock.Id %>)</b></li>
            <%
        }
    }
    while (depth < section.DepthLevel)
    {
        %><%= "<ul>" %><%
        depth++;
    }
    while (depth > section.DepthLevel)
    {
        %><%= "</ul>" %><%
        depth--;
    }
    %>
    <li>
        <span style="<%= section.ActiveGlobal ? "" : "color: Gray" %>">
            <i><%= section.Name %></i>
            (<%= section.Id %>, создан <%= section.CreateDate %>, изменен <%= section.UpdateDate %>)
        </span>
    </li>
    <%
}
while (depth > 0)
{
    %><%= "</ul>" %><%
    depth--;
}
for(int k = i; k < iblocks.Count; k++)
{
    iblock = iblocks[i++];
    %><li><b><%= iblock.Name %> (<%= iblock.Id %>)</b></li><%
}
%>
</ul>

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство Code

Свойство BXIBlockSection..::.Code
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает символьный код раздела инфоблока. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Code { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Примеры

Создание раздела в текущем разделе инфоблока:

CopyC#
        BXIBlockSection parentSection;

        BXIBlockSection section = new BXIBlockSection();
        section.IBlockId = parentSection.IBlockId;
        section.Name = "Lorem Ipsum";
        section.DescriptionType = BXTextType.Html;
        section.Description =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        section.SectionId = parentSection.Id;

        using (FileStream file = new FileStream(MapPath("~/image.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "image.png", "", "iblock", "Малый Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.ImageId = image.Id;
            }
        }

        using (FileStream file = new FileStream(MapPath("~/detail.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "detail.png", "", "iblock", "Большой Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.DetailImageId = image.Id;
            }
        }

        section.Active = true;
        section.Code = "ipsum";
        section.XmlId = Guid.NewGuid().ToString();

        section.Save();

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство CreateDate

Свойство BXIBlockSection..::.CreateDate
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает дату создания раздела инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public DateTime CreateDate { get; set; }

Примеры

Вывод структуры всех инфоблоков в ASPX-странице:

CopyC#
<ul>
<%
BXIBlockCollection iblocks = BXIBlock.GetList(
    null,
    new BXOrderBy(
        new BXOrderByPair(BXIBlock.Fields.Type.ID, BXOrderByDirection.Asc),
        new BXOrderByPair(BXIBlock.Fields.ID, BXOrderByDirection.Asc)
    )
);

int i = 0;
int depth = 0;
BXIBlock iblock = null;

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.IBlock.Type.ID, BXOrderByDirection.Asc);
orderBy.Add(BXIBlockSection.Fields.IBlock.ID, BXOrderByDirection.Asc);
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

foreach (BXIBlockSection section in BXIBlockSection.GetList(null, orderBy))
{
    if (iblock == null || section.IBlockId != iblock.Id)
    {
        while (depth > 0)
        {
            %><%= "</li></ul>" %><%
            depth--;
        }

        while (iblock == null || iblock.Id != section.IBlockId)
        {
            iblock = iblocks[i++];
            %>
                <li><b><%= iblock.Name %> (<%= iblock.Id %>)</b></li>
            <%
        }
    }
    while (depth < section.DepthLevel)
    {
        %><%= "<ul>" %><%
        depth++;
    }
    while (depth > section.DepthLevel)
    {
        %><%= "</ul>" %><%
        depth--;
    }
    %>
    <li>
        <span style="<%= section.ActiveGlobal ? "" : "color: Gray" %>">
            <i><%= section.Name %></i>
            (<%= section.Id %>, создан <%= section.CreateDate %>, изменен <%= section.UpdateDate %>)
        </span>
    </li>
    <%
}
while (depth > 0)
{
    %><%= "</ul>" %><%
    depth--;
}
for(int k = i; k < iblocks.Count; k++)
{
    iblock = iblocks[i++];
    %><li><b><%= iblock.Name %> (<%= iblock.Id %>)</b></li><%
}
%>
</ul>

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство CreatedBy

Свойство BXIBlockSection..::.CreatedBy
Класс BXIBlockSection Смотри также Send Feedback
Возвращает или устанавливает ID пользователя создавшего раздел

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int CreatedBy { get; set; }

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство CreatedByUser

Свойство BXIBlockSection..::.CreatedByUser
Класс BXIBlockSection Смотри также Send Feedback
Возвращает пользователя, создавшего раздел инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXUser CreatedByUser { get; }

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство CustomFieldsKey

Свойство BXIBlockSection..::.CustomFieldsKey
Класс BXIBlockSection Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override string CustomFieldsKey { get; }

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство DepthLevel

Свойство BXIBlockSection..::.DepthLevel
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает глубину вложенности раздела инфоблока в структуре "Вложенные множества".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int DepthLevel { get; }

Примеры

Заметки

Для разделов верхнего уровня будет иметь значение 1.

Выборка раздела вместе с его подразделами до 2-го уровня вложенности в порядке обхода иерархии дерева "Родитель - 1-й ребенок - ... - N-й ребенок":

CopyC#
BXIBlockSection section;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, section.IBlockId));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.LeftMargin, BXSqlFilterOperators.GreaterOrEqual, section.LeftMargin));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.RightMargin, BXSqlFilterOperators.LessOrEqual, section.RightMargin));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.DepthLevel, BXSqlFilterOperators.LessOrEqual, section.DepthLevel + 2));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, orderBy);

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство Description

Свойство BXIBlockSection..::.Description
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает описание раздела инфоблока. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Description { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком в зависимости от значения свойства DetailTextType.

Примеры

Создание раздела в текущем разделе инфоблока:

CopyC#
        BXIBlockSection parentSection;

        BXIBlockSection section = new BXIBlockSection();
        section.IBlockId = parentSection.IBlockId;
        section.Name = "Lorem Ipsum";
        section.DescriptionType = BXTextType.Html;
        section.Description =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        section.SectionId = parentSection.Id;

        using (FileStream file = new FileStream(MapPath("~/image.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "image.png", "", "iblock", "Малый Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.ImageId = image.Id;
            }
        }

        using (FileStream file = new FileStream(MapPath("~/detail.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "detail.png", "", "iblock", "Большой Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.DetailImageId = image.Id;
            }
        }

        section.Active = true;
        section.Code = "ipsum";
        section.XmlId = Guid.NewGuid().ToString();

        section.Save();

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство DescriptionType

Свойство BXIBlockSection..::.DescriptionType
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает тип текста описания раздела инфоблока (текст или HTML).

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXTextType DescriptionType { get; set; }

Примеры

Создание раздела в текущем разделе инфоблока:

CopyC#
        BXIBlockSection parentSection;

        BXIBlockSection section = new BXIBlockSection();
        section.IBlockId = parentSection.IBlockId;
        section.Name = "Lorem Ipsum";
        section.DescriptionType = BXTextType.Html;
        section.Description =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        section.SectionId = parentSection.Id;

        using (FileStream file = new FileStream(MapPath("~/image.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "image.png", "", "iblock", "Малый Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.ImageId = image.Id;
            }
        }

        using (FileStream file = new FileStream(MapPath("~/detail.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "detail.png", "", "iblock", "Большой Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.DetailImageId = image.Id;
            }
        }

        section.Active = true;
        section.Code = "ipsum";
        section.XmlId = Guid.NewGuid().ToString();

        section.Save();

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство DetailImage

Свойство BXIBlockSection..::.DetailImage
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает сущность "файл" для раздела инфоблока, заданную свойством DetailImageId.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile DetailImage { get; }

Примеры

Вывод разделов инфоблока в ASPX-странице:

CopyC#
<%
    int iblockId;

    foreach (BXIBlockSection section in BXIBlockSection.GetTree(iblockId, 0))
    {
        BXFile file = section.Image ?? section.DetailImage;
%>
    <div style="border: solid 1px black; margin: 5px 0px; width: 300px; height: 100px; overflow:hidden; margin-left:<%= (section.DepthLevel - 1) * 25 %>px">
        <div style="width: 50px; float: left">
            <img src="<%= file != null ? file.FilePath : "" %>" alt="<%= file != null ? file.Description : "" %>" style="width: 100%"/>
        </div>
        <div style="width: 245px; float: right">
            <h4 style="margin: 0px"><%= section.Name %></h4>
            <small>
                Элементов - <%= section.ElementsCount %>,
                разделов - <%= section.SectionsCount %>
            </small>
            <div style="margin-top: 5px; color: Gray; font-size: 0.5em"><%= section.Description %></div>
        </div>
    </div>
<%
    }
%>

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство DetailImageId

Свойство BXIBlockSection..::.DetailImageId
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится детальное изображение для раздела инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int DetailImageId { get; set; }

Примеры

Создание раздела в текущем разделе инфоблока:

CopyC#
        BXIBlockSection parentSection;

        BXIBlockSection section = new BXIBlockSection();
        section.IBlockId = parentSection.IBlockId;
        section.Name = "Lorem Ipsum";
        section.DescriptionType = BXTextType.Html;
        section.Description =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        section.SectionId = parentSection.Id;

        using (FileStream file = new FileStream(MapPath("~/image.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "image.png", "", "iblock", "Малый Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.ImageId = image.Id;
            }
        }

        using (FileStream file = new FileStream(MapPath("~/detail.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "detail.png", "", "iblock", "Большой Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.DetailImageId = image.Id;
            }
        }

        section.Active = true;
        section.Code = "ipsum";
        section.XmlId = Guid.NewGuid().ToString();

        section.Save();

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство ElementsCount

Свойство BXIBlockSection..::.ElementsCount
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает количество непосредственных элементов в разделе инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int ElementsCount { get; }

Заметки

Свойство производит запрос к БД при первом обращении.

Примеры

Вывод разделов инфоблока в ASPX-странице:

CopyC#
<%
    int iblockId;

    foreach (BXIBlockSection section in BXIBlockSection.GetTree(iblockId, 0))
    {
        BXFile file = section.Image ?? section.DetailImage;
%>
    <div style="border: solid 1px black; margin: 5px 0px; width: 300px; height: 100px; overflow:hidden; margin-left:<%= (section.DepthLevel - 1) * 25 %>px">
        <div style="width: 50px; float: left">
            <img src="<%= file != null ? file.FilePath : "" %>" alt="<%= file != null ? file.Description : "" %>" style="width: 100%"/>
        </div>
        <div style="width: 245px; float: right">
            <h4 style="margin: 0px"><%= section.Name %></h4>
            <small>
                Элементов - <%= section.ElementsCount %>,
                разделов - <%= section.SectionsCount %>
            </small>
            <div style="margin-top: 5px; color: Gray; font-size: 0.5em"><%= section.Description %></div>
        </div>
    </div>
<%
    }
%>

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство EntityId

Свойство BXIBlockSection..::.EntityId
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает "IBlockSection".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string EntityId { get; }

Заметки

Это свойство используется для формирования названий команд, отправляемых при сохранении сущности в базу данных или удалении из базы данных.

Примеры

CopyC#
public class BXIBlockElement
    : BXEntity
{
    . . .

    public override string ModuleId
    {
        get { return "iblock"; }
    }

    public override string EntityId
    {
        get { return "IBlockElement"; }
    }

    . . .
}

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство IBlock

Свойство BXIBlockSection..::.IBlock
Класс BXIBlockSection Смотри также Send Feedback
Запрос инфоблока

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlock IBlock { get; }

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство IBlockId

Свойство BXIBlockSection..::.IBlockId
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор родительского инфоблока. Обязательное свойство.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int IBlockId { get; set; }

Примеры

Создание раздела в текущем разделе инфоблока:

CopyC#
        BXIBlockSection parentSection;

        BXIBlockSection section = new BXIBlockSection();
        section.IBlockId = parentSection.IBlockId;
        section.Name = "Lorem Ipsum";
        section.DescriptionType = BXTextType.Html;
        section.Description =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        section.SectionId = parentSection.Id;

        using (FileStream file = new FileStream(MapPath("~/image.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "image.png", "", "iblock", "Малый Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.ImageId = image.Id;
            }
        }

        using (FileStream file = new FileStream(MapPath("~/detail.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "detail.png", "", "iblock", "Большой Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.DetailImageId = image.Id;
            }
        }

        section.Active = true;
        section.Code = "ipsum";
        section.XmlId = Guid.NewGuid().ToString();

        section.Save();

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство Id

Свойство BXIBlockSection..::.Id
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор раздела инфоблока. Первичный ключ.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Id { get; set; }

Примеры

Обновление раздела:

CopyC#
int sectionId;

BXIBlockSection section = new BXIBlockSection();
section.Id = sectionId;
section.Name = "Новое название";

section.Update();

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство Image

Свойство BXIBlockSection..::.Image
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает сущность "файл" для раздела инфоблока, заданную свойством ImageId.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile Image { get; }

Примеры

Вывод разделов инфоблока в ASPX-странице:

CopyC#
<%
    int iblockId;

    foreach (BXIBlockSection section in BXIBlockSection.GetTree(iblockId, 0))
    {
        BXFile file = section.Image ?? section.DetailImage;
%>
    <div style="border: solid 1px black; margin: 5px 0px; width: 300px; height: 100px; overflow:hidden; margin-left:<%= (section.DepthLevel - 1) * 25 %>px">
        <div style="width: 50px; float: left">
            <img src="<%= file != null ? file.FilePath : "" %>" alt="<%= file != null ? file.Description : "" %>" style="width: 100%"/>
        </div>
        <div style="width: 245px; float: right">
            <h4 style="margin: 0px"><%= section.Name %></h4>
            <small>
                Элементов - <%= section.ElementsCount %>,
                разделов - <%= section.SectionsCount %>
            </small>
            <div style="margin-top: 5px; color: Gray; font-size: 0.5em"><%= section.Description %></div>
        </div>
    </div>
<%
    }
%>

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство ImageId

Свойство BXIBlockSection..::.ImageId
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор сущности "файл" (см. BXFile), в которой хранится изображение для раздела инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int ImageId { get; set; }

Примеры

Создание раздела в текущем разделе инфоблока:

CopyC#
        BXIBlockSection parentSection;

        BXIBlockSection section = new BXIBlockSection();
        section.IBlockId = parentSection.IBlockId;
        section.Name = "Lorem Ipsum";
        section.DescriptionType = BXTextType.Html;
        section.Description =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        section.SectionId = parentSection.Id;

        using (FileStream file = new FileStream(MapPath("~/image.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "image.png", "", "iblock", "Малый Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.ImageId = image.Id;
            }
        }

        using (FileStream file = new FileStream(MapPath("~/detail.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "detail.png", "", "iblock", "Большой Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.DetailImageId = image.Id;
            }
        }

        section.Active = true;
        section.Code = "ipsum";
        section.XmlId = Guid.NewGuid().ToString();

        section.Save();

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство LeftMargin

Свойство BXIBlockSection..::.LeftMargin
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает левую границу раздела инфоблока в структуре "Вложенные множества".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int LeftMargin { get; }

Примеры

Выборка раздела вместе с его подразделами до 2-го уровня вложенности в порядке обхода иерархии дерева "Родитель - 1-й ребенок - ... - N-й ребенок":

CopyC#
BXIBlockSection section;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, section.IBlockId));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.LeftMargin, BXSqlFilterOperators.GreaterOrEqual, section.LeftMargin));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.RightMargin, BXSqlFilterOperators.LessOrEqual, section.RightMargin));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.DepthLevel, BXSqlFilterOperators.LessOrEqual, section.DepthLevel + 2));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, orderBy);

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство ModifiedBy

Свойство BXIBlockSection..::.ModifiedBy
Класс BXIBlockSection Смотри также Send Feedback
Возвращает или устанавливает ID пользователя изменившего раздел

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int ModifiedBy { get; set; }

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство ModifiedByUser

Свойство BXIBlockSection..::.ModifiedByUser
Класс BXIBlockSection Смотри также Send Feedback
Возвращает пользователя, изменившего раздел инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXUser ModifiedByUser { get; }

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство ModuleId

Свойство BXIBlockSection..::.ModuleId
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string ModuleId { get; }

Заметки

Это свойство используется для формирования названий команд, отправляемых при сохранении сущности в базу данных или удалении из базы данных.

Примеры

CopyC#
public class BXIBlockElement
    : BXEntity
{
    . . .

    public override string ModuleId
    {
        get { return "iblock"; }
    }

    public override string EntityId
    {
        get { return "IBlockElement"; }
    }

    . . .
}

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство Name

Свойство BXIBlockSection..::.Name
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает название раздела инфоблока. Обязательное свойство. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Name { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Примеры

Создание раздела в текущем разделе инфоблока:

CopyC#
        BXIBlockSection parentSection;

        BXIBlockSection section = new BXIBlockSection();
        section.IBlockId = parentSection.IBlockId;
        section.Name = "Lorem Ipsum";
        section.DescriptionType = BXTextType.Html;
        section.Description =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        section.SectionId = parentSection.Id;

        using (FileStream file = new FileStream(MapPath("~/image.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "image.png", "", "iblock", "Малый Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.ImageId = image.Id;
            }
        }

        using (FileStream file = new FileStream(MapPath("~/detail.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "detail.png", "", "iblock", "Большой Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.DetailImageId = image.Id;
            }
        }

        section.Active = true;
        section.Code = "ipsum";
        section.XmlId = Guid.NewGuid().ToString();

        section.Save();

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство RightMargin

Свойство BXIBlockSection..::.RightMargin
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает правую границу раздела инфоблока в структуре "Вложенные множества".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int RightMargin { get; }

Примеры

Выборка раздела вместе с его подразделами до 2-го уровня вложенности в порядке обхода иерархии дерева "Родитель - 1-й ребенок - ... - N-й ребенок":

CopyC#
BXIBlockSection section;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, section.IBlockId));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.LeftMargin, BXSqlFilterOperators.GreaterOrEqual, section.LeftMargin));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.RightMargin, BXSqlFilterOperators.LessOrEqual, section.RightMargin));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.DepthLevel, BXSqlFilterOperators.LessOrEqual, section.DepthLevel + 2));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, orderBy);

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство SectionId

Свойство BXIBlockSection..::.SectionId
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор родительского раздела инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int SectionId { get; set; }

Заметки

Для разделов верхнего уровня свойство имеет значение 0.

На основе свойств SectionId, Sort и Name при сохранении сущности в БД вычисляются значения свойств LeftMargin, RightMargin и DepthLevel для соответствующих разделов.

На основе свойств SectionId и Active при сохранении сущности в БД вычисляется значение свойства ActiveGlobal для соответствующих разделов.

Примеры

Создание раздела в текущем разделе инфоблока:

CopyC#
        BXIBlockSection parentSection;

        BXIBlockSection section = new BXIBlockSection();
        section.IBlockId = parentSection.IBlockId;
        section.Name = "Lorem Ipsum";
        section.DescriptionType = BXTextType.Html;
        section.Description =
@"<b>Неверно:</b>
<p>
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod
tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis
nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat,
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim
qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi
</p>
<b>Верно:</b>
<p>
Sed ut perspiciatis, unde omnis iste natus error sit voluptatem accusantium doloremque
laudantium, totam rem aperiam eaque ipsa, quae ab illo inventore veritatis et quasi
architecto beatae vitae dicta sunt, explicabo. nemo enim ipsam voluptatem, quia voluptas sit,
aspernatur aut odit aut fugit, sed quia consequuntur magni dolores eos, qui ratione
voluptatem sequi nesciunt, neque porro quisquam est, qui dolorem ipsum, quia dolor sit,
amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt,
ut labore et dolore magnam aliquam quaerat voluptatem. ut enim ad minima veniam, quis nostrum
exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur?
quis autem vel eum iure reprehenderit, qui in ea voluptate velit esse, quam nihil molestiae
consequatur, vel illum, qui dolorem eum fugiat, quo voluptas nulla pariatur?
</p>";

        section.SectionId = parentSection.Id;

        using (FileStream file = new FileStream(MapPath("~/image.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "image.png", "", "iblock", "Малый Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.ImageId = image.Id;
            }
        }

        using (FileStream file = new FileStream(MapPath("~/detail.png"), FileMode.Open))
        {
            BXFile image = new BXFile(file, "detail.png", "", "iblock", "Большой Lorem Ipsum");
            image.ContentType = "image";

            if (image.ValidateAsImage(0, 0, 0) == BXFileValidationResult.Valid)
            {
                image.Save();
                section.DetailImageId = image.Id;
            }
        }

        section.Active = true;
        section.Code = "ipsum";
        section.XmlId = Guid.NewGuid().ToString();

        section.Save();

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство SectionsCount

Свойство BXIBlockSection..::.SectionsCount
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает количество непосредственных подразделов в разделе инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int SectionsCount { get; }

Заметки

Свойство производит запрос к БД при первом обращении.

Примеры

Вывод разделов инфоблока в ASPX-странице:

CopyC#
<%
    int iblockId;

    foreach (BXIBlockSection section in BXIBlockSection.GetTree(iblockId, 0))
    {
        BXFile file = section.Image ?? section.DetailImage;
%>
    <div style="border: solid 1px black; margin: 5px 0px; width: 300px; height: 100px; overflow:hidden; margin-left:<%= (section.DepthLevel - 1) * 25 %>px">
        <div style="width: 50px; float: left">
            <img src="<%= file != null ? file.FilePath : "" %>" alt="<%= file != null ? file.Description : "" %>" style="width: 100%"/>
        </div>
        <div style="width: 245px; float: right">
            <h4 style="margin: 0px"><%= section.Name %></h4>
            <small>
                Элементов - <%= section.ElementsCount %>,
                разделов - <%= section.SectionsCount %>
            </small>
            <div style="margin-top: 5px; color: Gray; font-size: 0.5em"><%= section.Description %></div>
        </div>
    </div>
<%
    }
%>

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство Sort

Свойство BXIBlockSection..::.Sort
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает порядок сортировки элемента инфоблока:

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Sort { get; set; }

Заметки

На основе свойств SectionId, Sort и Name при сохранении сущности в БД вычисляются значения свойств LeftMargin, RightMargin и DepthLevel для соответствующих разделов.

Примеры

Упорядочивание разделов инфоблока верхнего уровня по дате создания:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.DepthLevel, BXSqlFilterOperators.Equal, 1));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.CreateDate, BXOrderByDirection.Asc);

int i = 0;
foreach (BXIBlockSection section in BXIBlockSection.GetList(filter, orderBy))
{
    section.Sort = (i += 10);
    section.Save();
}

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство UpdateDate

Свойство BXIBlockSection..::.UpdateDate
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает дату последнего изменения свойств раздела.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public DateTime UpdateDate { get; set; }

Заметки

Если дата не указана явно, то она будет автоматически записана в БД при сохранении.

Примеры

Вывод структуры всех инфоблоков в ASPX-странице:

CopyC#
<ul>
<%
BXIBlockCollection iblocks = BXIBlock.GetList(
    null,
    new BXOrderBy(
        new BXOrderByPair(BXIBlock.Fields.Type.ID, BXOrderByDirection.Asc),
        new BXOrderByPair(BXIBlock.Fields.ID, BXOrderByDirection.Asc)
    )
);

int i = 0;
int depth = 0;
BXIBlock iblock = null;

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.IBlock.Type.ID, BXOrderByDirection.Asc);
orderBy.Add(BXIBlockSection.Fields.IBlock.ID, BXOrderByDirection.Asc);
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

foreach (BXIBlockSection section in BXIBlockSection.GetList(null, orderBy))
{
    if (iblock == null || section.IBlockId != iblock.Id)
    {
        while (depth > 0)
        {
            %><%= "</li></ul>" %><%
            depth--;
        }

        while (iblock == null || iblock.Id != section.IBlockId)
        {
            iblock = iblocks[i++];
            %>
                <li><b><%= iblock.Name %> (<%= iblock.Id %>)</b></li>
            <%
        }
    }
    while (depth < section.DepthLevel)
    {
        %><%= "<ul>" %><%
        depth++;
    }
    while (depth > section.DepthLevel)
    {
        %><%= "</ul>" %><%
        depth--;
    }
    %>
    <li>
        <span style="<%= section.ActiveGlobal ? "" : "color: Gray" %>">
            <i><%= section.Name %></i>
            (<%= section.Id %>, создан <%= section.CreateDate %>, изменен <%= section.UpdateDate %>)
        </span>
    </li>
    <%
}
while (depth > 0)
{
    %><%= "</ul>" %><%
    depth--;
}
for(int k = i; k < iblocks.Count; k++)
{
    iblock = iblocks[i++];
    %><li><b><%= iblock.Name %> (<%= iblock.Id %>)</b></li><%
}
%>
</ul>

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство XmlId

Свойство BXIBlockSection..::.XmlId
Класс BXIBlockSection Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор элемента инфоблока для экспорта в XML. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string XmlId { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Примеры

Импорт или обновление структуры инфоблока из XML:

CopyC#
void ImportSection(int iblockCode, int parentSectionId, XmlNode node)
{
    string xmlId = node.Attributes["id"].Value;
    BXIBlockSection section = GetByXmlId(iblockCode, xmlId);
    if (section == null)
    {
        section = new BXIBlockSection();
        section.IBlockId = iblockCode;
        section.XmlId = xmlId;
    }

    section.SectionId = parentSectionId;

    if (node.Attributes["name"] != null)
        section.Name = node.Attributes["name"].Value;

    XmlNode description = node.SelectSingleNode("description");
    if (description != null)
    {
        BXTextType type = BXTextType.Text;
        if (description.Attributes["type"] != null
            && string.Equals(description.Attributes["type"].Value, "HTML", StringComparison.OrdinalIgnoreCase))
            type = BXTextType.Html;
        section.DescriptionType = type;
        section.Description = (type == BXTextType.Text) ? description.InnerText : description.InnerXml;
    }

    section.Save();

    foreach(XmlNode subnode in node.SelectNodes("section"))
        ImportSection(iblockCode, section.Id, subnode);
}

void ImportXml(int iblockCode, string filename)
{
    XmlDocument doc = new XmlDocument();
    doc.Load(filename);
    foreach(XmlNode node in doc.DocumentElement.SelectNodes("section"))
        ImportSection(iblockCode, 0, node);
}
CopyXML
<?xml version="1.0" encoding="utf-8" ?>
<sections>
    <section id="{31CDBF90-F766-44a0-A6F2-88793ECF50D0}" name="Root Level 1">
        <description type="Text">Description 1</description>
    </section>
    <section id="{67F05F7A-85AF-4f1f-B051-4B63A3E32DC2}" name="Root Level 2">
        <description type="Text">Description 2</description>
        <section id="{EBC2B17E-AE74-42c5-99B5-D701EC4ED572}" name="Root Level 2 - Sub 1">
            <description type="Text">Description 2.1</description>
        </section>
        <section id="{48AD64F8-A3DC-4cdf-B25A-AE87E77D2D3B}" name="Root Level 2 - Sub 2">
            <description type="Text">Description 2.2</description>
        </section>
    </section>
    <section id="{80799C28-AE0C-49a9-BF80-8B68BDBF25F6}" name="Root Level 3">
        <description type="Text">Description 3</description>
    </section>
</sections>

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Свойство XmlTagName

Свойство BXIBlockSection..::.XmlTagName
Класс BXIBlockSection Смотри также Send Feedback
Имя Xml тега

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string XmlTagName { get; }

Смотри также

Класс BXIBlockSection
Пространство имен Bitrix.IBlock


Класс BXIBlockSection.Scheme

Класс BXIBlockSection..::..Scheme
Класс BXIBlockSection Члены Смотри также Send Feedback
Класс схемы для сущности "раздел инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class Scheme : BXScheme<BXIBlockSection..::..Scheme>

Иерархия наследования

System..::..Object
BXSchemeBase
BXScheme<(Of <(<'BXIBlockSection..::..Scheme>)>)>
Bitrix.IBlock..::..BXIBlockSection..::..Scheme

Смотри также

Члены BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Члены BXIBlockSection.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockSection..::..Scheme
Класс BXIBlockSection..::..Scheme Конструкторы Методы Свойства Смотри также Send Feedback

Класс определяет сущность "раздел инфоблока".

Тип BXIBlockSection..::..Scheme предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockSection..::..Scheme |

Методы

Имя | Описание
CreateCustomFieldSet | (Переопределяет BXSchemeCreateCustomFieldSet()()()())
GetCustomField | Формирует описание для набираемого свойства раздела инфоблока, которое может затем использоваться в выборках.

Свойства

Имя | Описание
Active | Описание поля "Активен?". ("Y" или "N")
ActiveGlobal | Описание поля "Активен с учетом родительских разделов?". Вычисляется автоматически. ("Y" или "N")
Code | Описание поля "Символьный код".
CreateDate | Описание поля "Дата создания элемента".
DepthLevel | Описание поля "Глубина вложенности раздела". Вычисляется автоматически.
Description | Описание поля "Описание раздела инфоблока".
DescriptionType | Описание поля "Тип текста описания раздела инфоблока". ("T" или "H")
DetailImageId | Описание поля "Идентификатор детального изображения раздела инфоблока".
IBlock | Описание поля "Родительский инфоблок". Связанное поле.
ID | Описание поля "Идентификатор секции". Первичный ключ.
ImageId | Описание поля "Идентификатор изображения раздела инфоблока".
LeftMargin | Описание поля "Левая граница вложенного раздела". Вычисляется автоматически.
Name | Описание поля "Название раздела инфоблока". Обязательное поле.
RightMargin | Описание поля "Правая граница вложенного раздела". Вычисляется автоматически.
SectionId | Описание поля "Идентификатор родительского раздела инфоблока".
Sort | Описание поля "Порядок сортировки".
UpdateDate | Описание поля "Дата последнего изменения".
XmlId | Описание поля "Идентификатор для XML".

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Конструктор BXIBlockSection.Scheme

Конструктор BXIBlockSection..::..Scheme
Класс BXIBlockSection..::..Scheme Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Scheme()

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Методы BXIBlockSection.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockSection..::..Scheme
Класс BXIBlockSection..::..Scheme Смотри также Send Feedback

Тип BXIBlockSection..::..Scheme предоставляет следующие возможности.

Методы

Имя | Описание
CreateCustomFieldSet | (Переопределяет BXSchemeCreateCustomFieldSet()()()())
GetCustomField | Формирует описание для набираемого свойства раздела инфоблока, которое может затем использоваться в выборках.

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Метод CreateCustomFieldSet

Метод BXIBlockSection..::..Scheme..::.CreateCustomFieldSet
Класс BXIBlockSection..::..Scheme Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override BXSchemeCustomFieldSet CreateCustomFieldSet()

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Метод GetCustomField

Метод BXIBlockSection..::..Scheme..::.GetCustomField
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Формирует описание для набираемого свойства раздела инфоблока, которое может затем использоваться в выборках.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeCustomField GetCustomField(
    int iblockId,
    string fieldName
)

Параметры

iblockId
Type: System..::..Int32
Идентификатор инфоблока.
fieldName
Type: System..::..String
Имя пользовательского поля.

Возвращаемое значение

Описание пользовательского поля для сущности.

Примеры

Выборка разделов инфоблока на основе значений пользовательских свойств:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.GetCustomField(iblockId, "AUTHOR"), BXSqlFilterOperators.Equal, "Булгаков"));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.GetCustomField(iblockId, "YEAR"), BXOrderByDirection.Desc);

BXIBlockSectionCollection elements = BXIBlockSection.GetList(filter, orderBy);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойства BXIBlockSection.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockSection..::..Scheme
Класс BXIBlockSection..::..Scheme Смотри также Send Feedback

Тип BXIBlockSection..::..Scheme предоставляет следующие возможности.

Свойства

Имя | Описание
Active | Описание поля "Активен?". ("Y" или "N")
ActiveGlobal | Описание поля "Активен с учетом родительских разделов?". Вычисляется автоматически. ("Y" или "N")
Code | Описание поля "Символьный код".
CreateDate | Описание поля "Дата создания элемента".
DepthLevel | Описание поля "Глубина вложенности раздела". Вычисляется автоматически.
Description | Описание поля "Описание раздела инфоблока".
DescriptionType | Описание поля "Тип текста описания раздела инфоблока". ("T" или "H")
DetailImageId | Описание поля "Идентификатор детального изображения раздела инфоблока".
IBlock | Описание поля "Родительский инфоблок". Связанное поле.
ID | Описание поля "Идентификатор секции". Первичный ключ.
ImageId | Описание поля "Идентификатор изображения раздела инфоблока".
LeftMargin | Описание поля "Левая граница вложенного раздела". Вычисляется автоматически.
Name | Описание поля "Название раздела инфоблока". Обязательное поле.
RightMargin | Описание поля "Правая граница вложенного раздела". Вычисляется автоматически.
SectionId | Описание поля "Идентификатор родительского раздела инфоблока".
Sort | Описание поля "Порядок сортировки".
UpdateDate | Описание поля "Дата последнего изменения".
XmlId | Описание поля "Идентификатор для XML".

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Active

Свойство BXIBlockSection..::..Scheme..::.Active
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Активен?". ("Y" или "N")

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Active { get; }

Заметки

При использовании в фильтре необходимо указывать значения "Y" и "N" вместо true или false.

Примеры

Выборка активных непосредственных подразделов раздела инфоблока:

CopyC#
BXIBlockSection section;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.SectionId, BXSqlFilterOperators.Equal, section.Id));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.Active, BXSqlFilterOperators.Equal, "Y"));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.DepthLevel, BXSqlFilterOperators.Equal, section.DepthLevel + 1));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.Sort, BXOrderByDirection.Asc);

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, orderBy);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ActiveGlobal

Свойство BXIBlockSection..::..Scheme..::.ActiveGlobal
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Активен с учетом родительских разделов?". Вычисляется автоматически. ("Y" или "N")

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ActiveGlobal { get; }

Заметки

При использовании в фильтре необходимо указывать значения "Y" и "N" вместо true или false.

Примеры

Выборка всех глобально активных разделов инфоблока:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.ActiveGlobal, BXSqlFilterOperators.Equal, "Y"));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, orderBy);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Code

Свойство BXIBlockSection..::..Scheme..::.Code
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Символьный код".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Code { get; }

Примеры

Поиск раздела инфоблока по символьному коду:

CopyC#
BXIBlockSection GetByCode(int iblockCode, string code)
{
    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockCode));
    filter.Add(new BXFilterItem(BXIBlockSection.Fields.Code, BXSqlFilterOperators.Equal, code));

    BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, null);
    return sections.Count != 0 ? sections[0] : null;
}

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство CreateDate

Свойство BXIBlockSection..::..Scheme..::.CreateDate
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Дата создания элемента".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase CreateDate { get; }

Примеры

Выборка разделов, которые были добавлены за последний месяц:

CopyC#
BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.CreateDate, BXSqlFilterOperators.GreaterOrEqual, DateTime.Now.AddMonths(-1)));

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, null);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство DepthLevel

Свойство BXIBlockSection..::..Scheme..::.DepthLevel
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Глубина вложенности раздела". Вычисляется автоматически.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase DepthLevel { get; }

Заметки

Свойство является частью реализации структуры "Вложенные множества" и вычисляется автоматически.

Для разделов верхнего уровня будет иметь значение 1.

Примеры

Выборка раздела вместе с его подразделами до 2-го уровня вложенности в порядке обхода иерархии дерева "Родитель - 1-й ребенок - ... - N-й ребенок":

CopyC#
BXIBlockSection section;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, section.IBlockId));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.LeftMargin, BXSqlFilterOperators.GreaterOrEqual, section.LeftMargin));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.RightMargin, BXSqlFilterOperators.LessOrEqual, section.RightMargin));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.DepthLevel, BXSqlFilterOperators.LessOrEqual, section.DepthLevel + 2));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, orderBy);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Description

Свойство BXIBlockSection..::..Scheme..::.Description
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Описание раздела инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Description { get; }

Примеры

Выборка разделов инфоблока, содержащих слово "битрикс" в названии или описании в виде текста:

CopyC#
int iblockId;
string word = "битрикс";

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterOr(
    new BXFilterItem(BXIBlockSection.Fields.Name, BXSqlFilterOperators.Like, word),
    new BXFilterItem(BXIBlockSection.Fields.Description, BXSqlFilterOperators.Like, word)
));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.DescriptionType, BXSqlFilterOperators.Equal, "T"));

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, null);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство DescriptionType

Свойство BXIBlockSection..::..Scheme..::.DescriptionType
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Тип текста описания раздела инфоблока". ("T" или "H")

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase DescriptionType { get; }

Заметки

При использовании в фильтре необходимо указывать значения "T" - для текста и "H" - для HTML.

Примеры

Выборка разделов инфоблока, содержащих слово "битрикс" в названии или описании в виде текста:

CopyC#
int iblockId;
string word = "битрикс";

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterOr(
    new BXFilterItem(BXIBlockSection.Fields.Name, BXSqlFilterOperators.Like, word),
    new BXFilterItem(BXIBlockSection.Fields.Description, BXSqlFilterOperators.Like, word)
));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.DescriptionType, BXSqlFilterOperators.Equal, "T"));

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, null);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство DetailImageId

Свойство BXIBlockSection..::..Scheme..::.DetailImageId
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор детального изображения раздела инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase DetailImageId { get; }

Примеры

Выборка разделов инфоблока, содержащих хотя бы одно изображение:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterOr(
    new BXFilterItem(BXIBlockSection.Fields.DetailImageId, BXSqlFilterOperators.NotEqual, null),
    new BXFilterItem(BXIBlockSection.Fields.ImageId, BXSqlFilterOperators.NotEqual, null)
));

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, null);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство IBlock

Свойство BXIBlockSection..::..Scheme..::.IBlock
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Родительский инфоблок". Связанное поле.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlock..::..Scheme IBlock { get; }

Примеры

Выборка иерархии разделов для всех инфоблоков определенного типа:

CopyC#
int iblockTypeId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.IBlock.ID, BXOrderByDirection.Asc);
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, orderBy);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ID

Свойство BXIBlockSection..::..Scheme..::.ID
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор секции". Первичный ключ.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ID { get; }

Примеры

Выборка разделов, добавленных после текущего:

CopyC#
BXIBlockSection section;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, section.IBlockId));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.ID, BXSqlFilterOperators.Greater, section.Id));

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, null);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ImageId

Свойство BXIBlockSection..::..Scheme..::.ImageId
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор изображения раздела инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ImageId { get; }

Примеры

Выборка разделов инфоблока, содержащих хотя бы одно изображение:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterOr(
    new BXFilterItem(BXIBlockSection.Fields.DetailImageId, BXSqlFilterOperators.NotEqual, null),
    new BXFilterItem(BXIBlockSection.Fields.ImageId, BXSqlFilterOperators.NotEqual, null)
));

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, null);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство LeftMargin

Свойство BXIBlockSection..::..Scheme..::.LeftMargin
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Левая граница вложенного раздела". Вычисляется автоматически.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase LeftMargin { get; }

Заметки

Свойство является частью реализации структуры "Вложенные множества" и вычисляется автоматически.

Для разделов одного уровня вложенности значения левой и правой границы формируются на основе полей Sort и Name

Примеры

Выборка раздела вместе с его подразделами до 2-го уровня вложенности в порядке обхода иерархии дерева "Родитель - 1-й ребенок - ... - N-й ребенок":

CopyC#
BXIBlockSection section;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, section.IBlockId));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.LeftMargin, BXSqlFilterOperators.GreaterOrEqual, section.LeftMargin));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.RightMargin, BXSqlFilterOperators.LessOrEqual, section.RightMargin));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.DepthLevel, BXSqlFilterOperators.LessOrEqual, section.DepthLevel + 2));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, orderBy);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Name

Свойство BXIBlockSection..::..Scheme..::.Name
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Название раздела инфоблока". Обязательное поле.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Name { get; }

Примеры

Выборка разделов инфоблока, содержащих слово "битрикс" в названии или описании в виде текста:

CopyC#
int iblockId;
string word = "битрикс";

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterOr(
    new BXFilterItem(BXIBlockSection.Fields.Name, BXSqlFilterOperators.Like, word),
    new BXFilterItem(BXIBlockSection.Fields.Description, BXSqlFilterOperators.Like, word)
));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.DescriptionType, BXSqlFilterOperators.Equal, "T"));

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, null);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство RightMargin

Свойство BXIBlockSection..::..Scheme..::.RightMargin
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Правая граница вложенного раздела". Вычисляется автоматически.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase RightMargin { get; }

Заметки

Свойство является частью реализации структуры "Вложенные множества" и вычисляется автоматически.

Для разделов одного уровня вложенности значения левой и правой границы формируются на основе полей Sort и Name

Примеры

Выборка раздела вместе с его подразделами до 2-го уровня вложенности в порядке обхода иерархии дерева "Родитель - 1-й ребенок - ... - N-й ребенок":

CopyC#
BXIBlockSection section;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, section.IBlockId));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.LeftMargin, BXSqlFilterOperators.GreaterOrEqual, section.LeftMargin));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.RightMargin, BXSqlFilterOperators.LessOrEqual, section.RightMargin));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.DepthLevel, BXSqlFilterOperators.LessOrEqual, section.DepthLevel + 2));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, orderBy);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство SectionId

Свойство BXIBlockSection..::..Scheme..::.SectionId
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор родительского раздела инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase SectionId { get; }

Заметки

Для выборки разделов верхнего уровня необходимо использовать фильтр по null.

Примеры

Выборка активных непосредственных подразделов раздела инфоблока:

CopyC#
BXIBlockSection section;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.SectionId, BXSqlFilterOperators.Equal, section.Id));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.Active, BXSqlFilterOperators.Equal, "Y"));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.DepthLevel, BXSqlFilterOperators.Equal, section.DepthLevel + 1));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.Sort, BXOrderByDirection.Asc);

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, orderBy);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Sort

Свойство BXIBlockSection..::..Scheme..::.Sort
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Порядок сортировки".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Sort { get; }

Примеры

Выборка всех глобально активных разделов инфоблока:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.ActiveGlobal, BXSqlFilterOperators.Equal, "Y"));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, orderBy);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство UpdateDate

Свойство BXIBlockSection..::..Scheme..::.UpdateDate
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Дата последнего изменения".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase UpdateDate { get; }

Примеры

Выборка разделов, свойства которых изменились за последний месяц:

CopyC#
BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.UpdateDate, BXSqlFilterOperators.GreaterOrEqual, DateTime.Now.AddMonths(-1)));

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, null);

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Свойство XmlId

Свойство BXIBlockSection..::..Scheme..::.XmlId
Класс BXIBlockSection..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор для XML".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase XmlId { get; }

Примеры

Поиск раздела инфоблока по идентификатору для XML:

CopyC#
BXIBlockSection GetByXmlId(int iblockCode, string xmlId)
{
    BXFilter filter = new BXFilter();
    filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockCode));
    filter.Add(new BXFilterItem(BXIBlockSection.Fields.XmlId, BXSqlFilterOperators.Equal, xmlId));

    BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, null);
    return sections.Count != 0 ? sections[0] : null;
}

Смотри также

Класс BXIBlockSection..::..Scheme
Пространство имен Bitrix.IBlock


Класс BXIBlockSection.SchemeCustomFieldSet

Класс BXIBlockSection..::..SchemeCustomFieldSet
Класс BXIBlockSection Члены Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class SchemeCustomFieldSet : BXSchemeCustomFieldSet

Иерархия наследования

System..::..Object
BXSchemeCustomFieldSet
Bitrix.IBlock..::..BXIBlockSection..::..SchemeCustomFieldSet

Смотри также

Члены BXIBlockSection..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Члены BXIBlockSection.SchemeCustomFieldSet

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockSection..::..SchemeCustomFieldSet
Класс BXIBlockSection..::..SchemeCustomFieldSet Конструкторы Методы Свойства Смотри также Send Feedback

Класс определяет сущность "раздел инфоблока".

Тип BXIBlockSection..::..SchemeCustomFieldSet предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockSection..::..SchemeCustomFieldSet |

Методы

Имя | Описание
PrepareOwnerEntityId | (Переопределяет BXSchemeCustomFieldSetPrepareOwnerEntityId(String))

Свойства

Имя | Описание
OwnerEntityRelatedFields | (Переопределяет BXSchemeCustomFieldSetOwnerEntityRelatedFields()()()())

Смотри также

Класс BXIBlockSection..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Конструктор BXIBlockSection.SchemeCustomFieldSet

Конструктор BXIBlockSection..::..SchemeCustomFieldSet
Класс BXIBlockSection..::..SchemeCustomFieldSet Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public SchemeCustomFieldSet(
    BXSchemeBase ownerScheme
)

Параметры

ownerScheme
Type: BXSchemeBase

Смотри также

Класс BXIBlockSection..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Методы BXIBlockSection.SchemeCustomFieldSet

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockSection..::..SchemeCustomFieldSet
Класс BXIBlockSection..::..SchemeCustomFieldSet Смотри также Send Feedback

Тип BXIBlockSection..::..SchemeCustomFieldSet предоставляет следующие возможности.

Методы

Имя | Описание
PrepareOwnerEntityId | (Переопределяет BXSchemeCustomFieldSetPrepareOwnerEntityId(String))

Смотри также

Класс BXIBlockSection..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Метод PrepareOwnerEntityId

Метод BXIBlockSection..::..SchemeCustomFieldSet..::.PrepareOwnerEntityId
Класс BXIBlockSection..::..SchemeCustomFieldSet Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override string PrepareOwnerEntityId(
    string sourceOwnerEntityId
)

Параметры

sourceOwnerEntityId
Type: System..::..String

Смотри также

Класс BXIBlockSection..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Свойства BXIBlockSection.SchemeCustomFieldSet

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockSection..::..SchemeCustomFieldSet
Класс BXIBlockSection..::..SchemeCustomFieldSet Смотри также Send Feedback

Тип BXIBlockSection..::..SchemeCustomFieldSet предоставляет следующие возможности.

Свойства

Имя | Описание
OwnerEntityRelatedFields | (Переопределяет BXSchemeCustomFieldSetOwnerEntityRelatedFields()()()())

Смотри также

Класс BXIBlockSection..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Свойство OwnerEntityRelatedFields

Свойство BXIBlockSection..::..SchemeCustomFieldSet..::.OwnerEntityRelatedFields
Класс BXIBlockSection..::..SchemeCustomFieldSet Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override BXSchemeFieldBase[] OwnerEntityRelatedFields { get; }

Смотри также

Класс BXIBlockSection..::..SchemeCustomFieldSet
Пространство имен Bitrix.IBlock


Класс BXIBlockSectionCollection

Класс BXIBlockSectionCollection
Члены Пример Смотри также Send Feedback
Коллекция элементов инфоблока. См. BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXIBlockSectionCollection : BXEntityCollection<BXIBlockSection, BXIBlockSectionCollection, BXIBlockSection..::..Scheme>

Примеры

Выборка всех активных глобально на данный момент разделов инфоблока:

CopyC#
int iblockId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId));
filter.Add(new BXFilterItem(BXIBlockSection.Fields.ActiveGlobal, BXSqlFilterOperators.Equal, "Y"));

BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc);

BXIBlockSectionCollection sections = BXIBlockSection.GetList(filter, orderBy);

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<' BXIBlockSection >)>)>
Bitrix.DataLayer..::..BXEntityCollection <(Of <(<' BXIBlockSection, BXIBlockSectionCollection, BXIBlockSection..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlockSectionCollection

Смотри также

Члены BXIBlockSectionCollection
Пространство имен Bitrix.IBlock


Члены BXIBlockSectionCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockSectionCollection
Класс BXIBlockSectionCollection Конструкторы Методы Смотри также Send Feedback

Тип BXIBlockSectionCollection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockSectionCollection | Конструктор по умолчанию.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Смотри также

Класс BXIBlockSectionCollection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockSectionCollection

Конструктор BXIBlockSectionCollection
Класс BXIBlockSectionCollection Смотри также Send Feedback
Конструктор по умолчанию.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockSectionCollection()

Смотри также

Класс BXIBlockSectionCollection
Пространство имен Bitrix.IBlock


Методы BXIBlockSectionCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockSectionCollection
Класс BXIBlockSectionCollection Смотри также Send Feedback

Тип BXIBlockSectionCollection предоставляет следующие возможности.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Смотри также

Класс BXIBlockSectionCollection
Пространство имен Bitrix.IBlock


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSectionCollection..::.Save
Класс BXIBlockSectionCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет все сущности коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет все сущности коллекции, используя указанное соединение. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockSectionCollection
Члены BXIBlockSectionCollection
Пространство имен Bitrix.IBlock


Метод ToDataTable

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockSectionCollection..::.ToDataTable
Класс BXIBlockSectionCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ToDataTable()()()() | Приводит коллекцию к типу DataTable. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable(BXPagingOptions) | Приводит коллекцию к типу DataTable с применением опций постраничной навигации. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockSectionCollection
Члены BXIBlockSectionCollection
Пространство имен Bitrix.IBlock


Класс BXIBlockType

Класс BXIBlockType
Члены Пример Смотри также Send Feedback
Класс определяет сущность "тип инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXIBlockType : BXEntity<BXIBlockType, BXIBlockTypeCollection, BXIBlockType..::..Scheme>

Заметки

Тип инфоблока представляет собой сущность для группировки инфоблоков, схожих по назначению. Например, группа новостных инфоблоков для разных сайтов или разных разделов сайта может принадлежать одному типу инфоблока "Новости". Как сущность, тип инфоблока реализует операции, свойственные всем сущностям (см. класс BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Примеры

Выборка всех типов инфоблоков в системе:

CopyC#
BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockType.Fields.Sort, BXOrderByDirection.Asc);

BXIBlockTypeCollection types = BXIBlockType.GetList(null, orderBy);

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXEntity
Bitrix.DataLayer..::..BXEntity <(Of <(<'BXIBlockType, BXIBlockTypeCollection, BXIBlockType..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlockType

Смотри также

Члены BXIBlockType
Пространство имен Bitrix.IBlock


Члены BXIBlockType

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockType
Класс BXIBlockType Конструкторы Методы Поля Свойства Смотри также Send Feedback

Тип BXIBlockType предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockType | Перегруженный.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
VerifyEntry | Проверяет корректность сущности перед сохранением. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Свойства

Имя | Описание
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Переопределяет BXEntity..::..CustomFieldsKey)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityId | Возвращает "InfoBlockType". (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..EntityId)
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
Id | Возвращает или устанавливает идентификатор типа инфоблока. Первичный ключ.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ModuleId | Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..ModuleId)
Sort | Возвращает или устанавливает порядок типа инфоблока.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Translations | Возвращает коллекцию связок "локализация типа инфоблока" для данного типа инфоблока.
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
XmlId | ID для XML

Смотри также

Класс BXIBlockType
Пространство имен Bitrix.IBlock


Конструктор BXIBlockType

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXIBlockType
Класс BXIBlockType Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXIBlockType()()()() | Создает экземпляр сущности "тип инфоблока".
BXIBlockType(IBXTextEncoder) | Создает экземпляр сущности "тип инфоблока" с выбранным кодировщиком текстовых полей.
BXIBlockType(String, Boolean, Int32) | Создает экземпляр сущности "тип инфоблока".
BXIBlockType(String, Boolean, Int32, IBXTextEncoder) | Создает экземпляр сущности "тип инфоблока" с выбранным кодировщиком текстовых полей.

Смотри также

Класс BXIBlockType
Члены BXIBlockType
Пространство имен Bitrix.IBlock


Конструктор BXIBlockType

Конструктор BXIBlockType
Класс BXIBlockType Смотри также Send Feedback
Создает экземпляр сущности "тип инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockType()

Смотри также

Класс BXIBlockType
Перегрузка BXIBlockType
Пространство имен Bitrix.IBlock


Конструктор BXIBlockType ()

Конструктор BXIBlockType ()
Класс BXIBlockType Смотри также Send Feedback
Создает экземпляр сущности "тип инфоблока" с выбранным кодировщиком текстовых полей.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockType(
    IBXTextEncoder textEncoder
)

Параметры

textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей.

Смотри также

Класс BXIBlockType
Перегрузка BXIBlockType
Пространство имен Bitrix.IBlock


Конструктор BXIBlockType (String, Boolean, Int32)

Конструктор BXIBlockType (String, Boolean, Int32)
Класс BXIBlockType Смотри также Send Feedback
Создает экземпляр сущности "тип инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockType(
    string name,
    bool haveSections,
    int sort
)

Параметры

name
Type: System..::..String
Параметр не используется.
haveSections
Type: System..::..Boolean
Параметр не используется.
sort
Type: System..::..Int32
Порядок сортировки.

Смотри также

Класс BXIBlockType
Перегрузка BXIBlockType
Пространство имен Bitrix.IBlock


Конструктор BXIBlockType (String, Boolean, Int32, )

Конструктор BXIBlockType (String, Boolean, Int32, )
Класс BXIBlockType Смотри также Send Feedback
Создает экземпляр сущности "тип инфоблока" с выбранным кодировщиком текстовых полей.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockType(
    string name,
    bool haveSections,
    int sort,
    IBXTextEncoder textEncoder
)

Параметры

name
Type: System..::..String
Параметр не используется.
haveSections
Type: System..::..Boolean
Параметр не используется.
sort
Type: System..::..Int32
Порядок сортировки.
textEncoder
Type: IBXTextEncoder
Кодировщик текстовых полей.

Смотри также

Класс BXIBlockType
Перегрузка BXIBlockType
Пространство имен Bitrix.IBlock


Поля BXIBlockType

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXIBlockType
Класс BXIBlockType Смотри также Send Feedback

Тип BXIBlockType предоставляет следующие возможности.

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType
Пространство имен Bitrix.IBlock


Методы BXIBlockType

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockType
Класс BXIBlockType Смотри также Send Feedback

Тип BXIBlockType предоставляет следующие возможности.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
VerifyEntry | Проверяет корректность сущности перед сохранением. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType
Пространство имен Bitrix.IBlock


Метод Create

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockType..::.Create
Класс BXIBlockType Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Create()()()() | Добавляет новую сущность в базу данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create(BXSqlConnection, BXSqlTransaction) | Добавляет новую сущность в базу данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType
Члены BXIBlockType
Пространство имен Bitrix.IBlock


Метод Delete

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockType..::.Delete
Класс BXIBlockType Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Delete()()()() | Удаляет текущую сущность из базы данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete(BXSqlConnection, BXSqlTransaction) | Удаляет текущую сущность из базы данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType
Члены BXIBlockType
Пространство имен Bitrix.IBlock


Метод DeleteInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockType..::.DeleteInternal
Класс BXIBlockType Смотри также Send Feedback

Лист перегрузки

Имя | Описание
DeleteInternal(Object) | Внутренний метод удаления сущностей по первичному ключу id, который вызывается статическим методом Delete(Object). (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter) | Внутренний метод удаления сущностей по фильтру, который вызывается статическим методом Delete(BXFilter). При удалении не отправляются никакие комманды и не удаляются дополнительные данные. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter, BXSqlConnection, BXSqlTransaction) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType
Члены BXIBlockType
Пространство имен Bitrix.IBlock


Метод GetByIdInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockType..::.GetByIdInternal
Класс BXIBlockType Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetByIdInternal(Object, IBXTextEncoder) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal(Object, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType
Члены BXIBlockType
Пространство имен Bitrix.IBlock


Метод GetJoinedEntity

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockType..::.GetJoinedEntity
Класс BXIBlockType Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String, BXSchemeBase) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType
Члены BXIBlockType
Пространство имен Bitrix.IBlock


Метод GetJoinedEntityCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockType..::.GetJoinedEntityCollection
Класс BXIBlockType Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType, JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>)(String, String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType
Члены BXIBlockType
Пространство имен Bitrix.IBlock


Метод GetListInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockType..::.GetListInternal
Класс BXIBlockType Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType
Члены BXIBlockType
Пространство имен Bitrix.IBlock


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockType..::.Save
Класс BXIBlockType Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет сущность в базе данных в новой транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет сущность в базе данных в указанной транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType
Члены BXIBlockType
Пространство имен Bitrix.IBlock


Метод SetValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockType..::.SetValue
Класс BXIBlockType Смотри также Send Feedback

Лист перегрузки

Имя | Описание
SetValue(KeyValuePair<(Of <<'(String, Object>)>>), Boolean) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object, Boolean) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType
Члены BXIBlockType
Пространство имен Bitrix.IBlock


Метод Update

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockType..::.Update
Класс BXIBlockType Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Update()()()() | Изменяет существующую сущность в базе данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update(BXSqlConnection, BXSqlTransaction) | Изменяет существующую сущность в базе данных в указанной транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType
Члены BXIBlockType
Пространство имен Bitrix.IBlock


Свойства BXIBlockType

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockType
Класс BXIBlockType Смотри также Send Feedback

Тип BXIBlockType предоставляет следующие возможности.

Свойства

Имя | Описание
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Переопределяет BXEntity..::..CustomFieldsKey)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityId | Возвращает "InfoBlockType". (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..EntityId)
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
Id | Возвращает или устанавливает идентификатор типа инфоблока. Первичный ключ.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ModuleId | Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..ModuleId)
Sort | Возвращает или устанавливает порядок типа инфоблока.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Translations | Возвращает коллекцию связок "локализация типа инфоблока" для данного типа инфоблока.
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
XmlId | ID для XML

Смотри также

Класс BXIBlockType
Пространство имен Bitrix.IBlock


Свойство CustomFieldsKey

Свойство BXIBlockType..::.CustomFieldsKey
Класс BXIBlockType Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override string CustomFieldsKey { get; }

Заметки

Возвращает null.

Смотри также

Класс BXIBlockType
Пространство имен Bitrix.IBlock


Свойство EntityId

Свойство BXIBlockType..::.EntityId
Класс BXIBlockType Пример Смотри также Send Feedback
Возвращает "InfoBlockType".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string EntityId { get; }

Заметки

Это свойство используется для формирования названий команд, отправляемых при сохранении сущности в базу данных или удалении из базы данных.

Примеры

CopyC#
public class BXIBlockElement
    : BXEntity
{
    . . .

    public override string ModuleId
    {
        get { return "iblock"; }
    }

    public override string EntityId
    {
        get { return "IBlockElement"; }
    }

    . . .
}

Смотри также

Класс BXIBlockType
Пространство имен Bitrix.IBlock


Свойство Id

Свойство BXIBlockType..::.Id
Класс BXIBlockType Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор типа инфоблока. Первичный ключ.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Id { get; set; }

Примеры

Вывод списка инфоблоков с локализацией на текущем языке:

CopyC#
<%
    foreach (BXIBlockType type in BXIBlockType.GetList(null, null))
    {
        BXIBlockType.BXInfoBlockTypeLang translation = type.Translations[BXLoc.CurrentLocale];
        BXIBlockCollection iblocks = BXIBlock.GetList(
            new BXFilter(
                new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, type.Id)
            ),
            null
        );
        %>
        <div>
            <h4><%= translation.Name%></h4>
            <ul>
                <%
                    foreach(BXIBlock iblock in iblocks)
                    {
                        %>
                        <li>
                            <strong><%= iblock.Name %>:</strong>
                            <%= translation.ElementName %> - <%= iblock.ElementsCount %>,
                            <%= translation.SectionName %> - <%= iblock.SectionsCount %>
                        </li>
                        <%
                    }
                %>
            </ul>
        </div>
        <%
    }
%>

Смотри также

Класс BXIBlockType
Пространство имен Bitrix.IBlock


Свойство ModuleId

Свойство BXIBlockType..::.ModuleId
Класс BXIBlockType Пример Смотри также Send Feedback
Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string ModuleId { get; }

Заметки

Это свойство используется для формирования названий команд, отправляемых при сохранении сущности в базу данных или удалении из базы данных.

Примеры

CopyC#
public class BXIBlockElement
    : BXEntity
{
    . . .

    public override string ModuleId
    {
        get { return "iblock"; }
    }

    public override string EntityId
    {
        get { return "IBlockElement"; }
    }

    . . .
}

Смотри также

Класс BXIBlockType
Пространство имен Bitrix.IBlock


Свойство Sort

Свойство BXIBlockType..::.Sort
Класс BXIBlockType Пример Смотри также Send Feedback
Возвращает или устанавливает порядок типа инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Sort { get; set; }

Примеры

Cортировка типов инфоблока по локализованному названию:

CopyC#
BXIBlockTypeCollection types = BXIBlockType.GetList(null, null);
types.Sort(delegate(BXIBlockType a, BXIBlockType b)
{
    return string.Compare(a.Translations[BXLoc.CurrentLocale].Name, b.Translations[BXLoc.CurrentLocale].Name, true);
});
for (int i = 0; i < types.Count; i++)
{
    types[i].Sort = (i + 1) * 100;
    types[i].Save();
}

Смотри также

Класс BXIBlockType
Пространство имен Bitrix.IBlock


Свойство Translations

Свойство BXIBlockType..::.Translations
Класс BXIBlockType Пример Смотри также Send Feedback
Возвращает коллекцию связок "локализация типа инфоблока" для данного типа инфоблока.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockType..::..BXInfoBlockTypeLangCollection Translations { get; }

Примеры

Вывод списка инфоблоков с локализацией на текущем языке:

CopyC#
<%
    foreach (BXIBlockType type in BXIBlockType.GetList(null, null))
    {
        BXIBlockType.BXInfoBlockTypeLang translation = type.Translations[BXLoc.CurrentLocale];
        BXIBlockCollection iblocks = BXIBlock.GetList(
            new BXFilter(
                new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, type.Id)
            ),
            null
        );
        %>
        <div>
            <h4><%= translation.Name%></h4>
            <ul>
                <%
                    foreach(BXIBlock iblock in iblocks)
                    {
                        %>
                        <li>
                            <strong><%= iblock.Name %>:</strong>
                            <%= translation.ElementName %> - <%= iblock.ElementsCount %>,
                            <%= translation.SectionName %> - <%= iblock.SectionsCount %>
                        </li>
                        <%
                    }
                %>
            </ul>
        </div>
        <%
    }
%>

Смотри также

Класс BXIBlockType
Пространство имен Bitrix.IBlock


Свойство XmlId

Свойство BXIBlockType..::.XmlId
Класс BXIBlockType Смотри также Send Feedback
ID для XML

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string XmlId { get; set; }

Смотри также

Класс BXIBlockType
Пространство имен Bitrix.IBlock


Класс BXIBlockType.BXInfoBlockTypeLang

Класс BXIBlockType..::..BXInfoBlockTypeLang
Класс BXIBlockType Члены Смотри также Send Feedback
Класс сущности-связки "локализация типа инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXInfoBlockTypeLang : BXLinkedEntity<BXIBlockType..::..BXInfoBlockTypeLang, BXIBlockType..::..BXInfoBlockTypeLangCollection, BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme>

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXEntity
Bitrix.DataLayer..::..BXEntity <(Of <(<' EntityType, EntityCollectionType, EntryScheme >)>)>
BXLinkedEntity<(Of <(<'BXIBlockType..::..BXInfoBlockTypeLang, BXIBlockType..::..BXInfoBlockTypeLangCollection, BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlockType..::..BXInfoBlockTypeLang

Смотри также

Члены BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Члены BXIBlockType.BXInfoBlockTypeLang

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockType..::..BXInfoBlockTypeLang
Класс BXIBlockType..::..BXInfoBlockTypeLang Конструкторы Методы Поля Свойства Смотри также Send Feedback

Класс определяет сущность "тип инфоблока".

Тип BXIBlockType..::..BXInfoBlockTypeLang предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockType..::..BXInfoBlockTypeLang | Перегруженный.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
VerifyEntry | Проверяет корректность сущности перед сохранением. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Свойства

Имя | Описание
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Унаследовано от BXEntity)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ElementName | Возвращает или устанавливает локализованное название для элемента инфоблока. Закодировано кодировщиком.
EntityId | Возвращает "InfoBlockTypeLang". (Переопределяет BXLinkedEntityEntityId()()()())
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
LanguageId | Возвращает или устанавливает идентификатор языка локализации. Закодировано кодировщиком.
ModuleId | (Переопределяет BXLinkedEntityModuleId()()()())
Name | Возвращает или устанавливает локализованное название типа инфоблока. Закодировано кодировщиком.
SectionName | Возвращает или устанавливает локализованное название для раздела инфоблока. Закодировано кодировщиком.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TypeId | Возвращает идентификатор типа инфоблока, к которому привязана локализация.
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Конструктор BXIBlockType.BXInfoBlockTypeLang

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXIBlockType..::..BXInfoBlockTypeLang
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXIBlockType..::..BXInfoBlockTypeLang()()()() | Конструктор сущности-связки.
BXIBlockType..::..BXInfoBlockTypeLang(String, String, String, String) | Конструктор сущности-связки.

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Члены BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Конструктор BXIBlockType.BXInfoBlockTypeLang

Конструктор BXIBlockType..::..BXInfoBlockTypeLang
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback
Конструктор сущности-связки.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXInfoBlockTypeLang()

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Перегрузка BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Конструктор BXIBlockType.BXInfoBlockTypeLang (String, String, String, String)

Конструктор BXIBlockType..::..BXInfoBlockTypeLang (String, String, String, String)
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback
Конструктор сущности-связки.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXInfoBlockTypeLang(
    string languageId,
    string name,
    string sectionName,
    string elementName
)

Параметры

languageId
Type: System..::..String
Идентификатор языка.
name
Type: System..::..String
Локализованное название типа инфоблока.
sectionName
Type: System..::..String
Локализованное название для раздела инфоблока.
elementName
Type: System..::..String
Локализованное название для элемента инфоблока.

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Перегрузка BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Поля BXIBlockType.BXInfoBlockTypeLang

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXIBlockType..::..BXInfoBlockTypeLang
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Тип BXIBlockType..::..BXInfoBlockTypeLang предоставляет следующие возможности.

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Методы BXIBlockType.BXInfoBlockTypeLang

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockType..::..BXInfoBlockTypeLang
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Тип BXIBlockType..::..BXInfoBlockTypeLang предоставляет следующие возможности.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
VerifyEntry | Проверяет корректность сущности перед сохранением. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Метод Create

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockTypeLang..::.Create
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Create()()()() | Добавляет новую сущность в базу данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create(BXSqlConnection, BXSqlTransaction) | Добавляет новую сущность в базу данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Члены BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Метод Delete

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockTypeLang..::.Delete
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Delete()()()() | Удаляет текущую сущность из базы данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete(BXSqlConnection, BXSqlTransaction) | Удаляет текущую сущность из базы данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Члены BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Метод DeleteInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockTypeLang..::.DeleteInternal
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Лист перегрузки

Имя | Описание
DeleteInternal(Object) | Внутренний метод удаления сущностей по первичному ключу id, который вызывается статическим методом Delete(Object). (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter) | Внутренний метод удаления сущностей по фильтру, который вызывается статическим методом Delete(BXFilter). При удалении не отправляются никакие комманды и не удаляются дополнительные данные. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter, BXSqlConnection, BXSqlTransaction) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Члены BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Метод GetByIdInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockTypeLang..::.GetByIdInternal
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetByIdInternal(Object, IBXTextEncoder) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal(Object, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Члены BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Метод GetJoinedEntity

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockTypeLang..::.GetJoinedEntity
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String, BXSchemeBase) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Члены BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Метод GetJoinedEntityCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockTypeLang..::.GetJoinedEntityCollection
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType, JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>)(String, String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Члены BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Метод GetListInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockTypeLang..::.GetListInternal
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Члены BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockTypeLang..::.Save
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет сущность в базе данных в новой транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет сущность в базе данных в указанной транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Члены BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Метод SetValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockTypeLang..::.SetValue
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Лист перегрузки

Имя | Описание
SetValue(KeyValuePair<(Of <<'(String, Object>)>>), Boolean) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object, Boolean) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Члены BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Метод Update

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockTypeLang..::.Update
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Update()()()() | Изменяет существующую сущность в базе данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update(BXSqlConnection, BXSqlTransaction) | Изменяет существующую сущность в базе данных в указанной транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Члены BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Свойства BXIBlockType.BXInfoBlockTypeLang

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockType..::..BXInfoBlockTypeLang
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Тип BXIBlockType..::..BXInfoBlockTypeLang предоставляет следующие возможности.

Свойства

Имя | Описание
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Унаследовано от BXEntity)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ElementName | Возвращает или устанавливает локализованное название для элемента инфоблока. Закодировано кодировщиком.
EntityId | Возвращает "InfoBlockTypeLang". (Переопределяет BXLinkedEntityEntityId()()()())
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
LanguageId | Возвращает или устанавливает идентификатор языка локализации. Закодировано кодировщиком.
ModuleId | (Переопределяет BXLinkedEntityModuleId()()()())
Name | Возвращает или устанавливает локализованное название типа инфоблока. Закодировано кодировщиком.
SectionName | Возвращает или устанавливает локализованное название для раздела инфоблока. Закодировано кодировщиком.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TypeId | Возвращает идентификатор типа инфоблока, к которому привязана локализация.
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Свойство ElementName

Свойство BXIBlockType..::..BXInfoBlockTypeLang..::.ElementName
Класс BXIBlockType..::..BXInfoBlockTypeLang Пример Смотри также Send Feedback
Возвращает или устанавливает локализованное название для элемента инфоблока. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ElementName { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Примеры

Вывод списка инфоблоков с локализацией на текущем языке:

CopyC#
<%
    foreach (BXIBlockType type in BXIBlockType.GetList(null, null))
    {
        BXIBlockType.BXInfoBlockTypeLang translation = type.Translations[BXLoc.CurrentLocale];
        BXIBlockCollection iblocks = BXIBlock.GetList(
            new BXFilter(
                new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, type.Id)
            ),
            null
        );
        %>
        <div>
            <h4><%= translation.Name%></h4>
            <ul>
                <%
                    foreach(BXIBlock iblock in iblocks)
                    {
                        %>
                        <li>
                            <strong><%= iblock.Name %>:</strong>
                            <%= translation.ElementName %> - <%= iblock.ElementsCount %>,
                            <%= translation.SectionName %> - <%= iblock.SectionsCount %>
                        </li>
                        <%
                    }
                %>
            </ul>
        </div>
        <%
    }
%>

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Свойство EntityId

Свойство BXIBlockType..::..BXInfoBlockTypeLang..::.EntityId
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback
Возвращает "InfoBlockTypeLang".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string EntityId { get; }

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Свойство LanguageId

Свойство BXIBlockType..::..BXInfoBlockTypeLang..::.LanguageId
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback
Возвращает или устанавливает идентификатор языка локализации. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string LanguageId { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Свойство ModuleId

Свойство BXIBlockType..::..BXInfoBlockTypeLang..::.ModuleId
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string ModuleId { get; }

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Свойство Name

Свойство BXIBlockType..::..BXInfoBlockTypeLang..::.Name
Класс BXIBlockType..::..BXInfoBlockTypeLang Пример Смотри также Send Feedback
Возвращает или устанавливает локализованное название типа инфоблока. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Name { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Примеры

Вывод списка инфоблоков с локализацией на текущем языке:

CopyC#
<%
    foreach (BXIBlockType type in BXIBlockType.GetList(null, null))
    {
        BXIBlockType.BXInfoBlockTypeLang translation = type.Translations[BXLoc.CurrentLocale];
        BXIBlockCollection iblocks = BXIBlock.GetList(
            new BXFilter(
                new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, type.Id)
            ),
            null
        );
        %>
        <div>
            <h4><%= translation.Name%></h4>
            <ul>
                <%
                    foreach(BXIBlock iblock in iblocks)
                    {
                        %>
                        <li>
                            <strong><%= iblock.Name %>:</strong>
                            <%= translation.ElementName %> - <%= iblock.ElementsCount %>,
                            <%= translation.SectionName %> - <%= iblock.SectionsCount %>
                        </li>
                        <%
                    }
                %>
            </ul>
        </div>
        <%
    }
%>

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Свойство SectionName

Свойство BXIBlockType..::..BXInfoBlockTypeLang..::.SectionName
Класс BXIBlockType..::..BXInfoBlockTypeLang Пример Смотри также Send Feedback
Возвращает или устанавливает локализованное название для раздела инфоблока. Закодировано кодировщиком.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string SectionName { get; set; }

Заметки

Значение данного свойства закодировано кодировщиком.

Примеры

Вывод списка инфоблоков с локализацией на текущем языке:

CopyC#
<%
    foreach (BXIBlockType type in BXIBlockType.GetList(null, null))
    {
        BXIBlockType.BXInfoBlockTypeLang translation = type.Translations[BXLoc.CurrentLocale];
        BXIBlockCollection iblocks = BXIBlock.GetList(
            new BXFilter(
                new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, type.Id)
            ),
            null
        );
        %>
        <div>
            <h4><%= translation.Name%></h4>
            <ul>
                <%
                    foreach(BXIBlock iblock in iblocks)
                    {
                        %>
                        <li>
                            <strong><%= iblock.Name %>:</strong>
                            <%= translation.ElementName %> - <%= iblock.ElementsCount %>,
                            <%= translation.SectionName %> - <%= iblock.SectionsCount %>
                        </li>
                        <%
                    }
                %>
            </ul>
        </div>
        <%
    }
%>

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Свойство TypeId

Свойство BXIBlockType..::..BXInfoBlockTypeLang..::.TypeId
Класс BXIBlockType..::..BXInfoBlockTypeLang Смотри также Send Feedback
Возвращает идентификатор типа инфоблока, к которому привязана локализация.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int TypeId { get; }

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang
Пространство имен Bitrix.IBlock


Класс BXIBlockType.BXInfoBlockTypeLang.Scheme

Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme
Класс BXIBlockType..::..BXInfoBlockTypeLang Члены Смотри также Send Feedback
Схема сущности-связки "локализация типа инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class Scheme : BXScheme<BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme>

Иерархия наследования

System..::..Object
BXSchemeBase
BXScheme<(Of <(<'BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme>)>)>
Bitrix.IBlock..::..BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme

Смотри также

Члены BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme
Пространство имен Bitrix.IBlock


Члены BXIBlockType.BXInfoBlockTypeLang.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme
Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme Конструкторы Свойства Смотри также Send Feedback

Класс сущности-связки "локализация типа инфоблока".

Тип BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme |

Свойства

Имя | Описание
ElementName | Описание поля "Локализованное название элемента инфоблока".
LanguageId | Описание поля "Идентификатор языка локализации".
Name | Описание поля "Локализованное название типа инфоблока".
SectionName | Описание поля "Локализованное название раздела инфоблока".
TypeId | Описание поля "Идентификатор типа инфоблока".

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme
Пространство имен Bitrix.IBlock


Конструктор BXIBlockType.BXInfoBlockTypeLang.Scheme

Конструктор BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme
Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Scheme()

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme
Пространство имен Bitrix.IBlock


Свойства BXIBlockType.BXInfoBlockTypeLang.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme
Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme Смотри также Send Feedback

Тип BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme предоставляет следующие возможности.

Свойства

Имя | Описание
ElementName | Описание поля "Локализованное название элемента инфоблока".
LanguageId | Описание поля "Идентификатор языка локализации".
Name | Описание поля "Локализованное название типа инфоблока".
SectionName | Описание поля "Локализованное название раздела инфоблока".
TypeId | Описание поля "Идентификатор типа инфоблока".

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ElementName

Свойство BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme..::.ElementName
Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme Смотри также Send Feedback
Описание поля "Локализованное название элемента инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ElementName { get; }

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme
Пространство имен Bitrix.IBlock


Свойство LanguageId

Свойство BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme..::.LanguageId
Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme Смотри также Send Feedback
Описание поля "Идентификатор языка локализации".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase LanguageId { get; }

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Name

Свойство BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme..::.Name
Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme Смотри также Send Feedback
Описание поля "Локализованное название типа инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Name { get; }

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme
Пространство имен Bitrix.IBlock


Свойство SectionName

Свойство BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme..::.SectionName
Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme Смотри также Send Feedback
Описание поля "Локализованное название раздела инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase SectionName { get; }

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme
Пространство имен Bitrix.IBlock


Свойство TypeId

Свойство BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme..::.TypeId
Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme Смотри также Send Feedback
Описание поля "Идентификатор типа инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase TypeId { get; }

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme
Пространство имен Bitrix.IBlock


Класс BXIBlockType.BXInfoBlockTypeLangCollection

Класс BXIBlockType..::..BXInfoBlockTypeLangCollection
Класс BXIBlockType Члены Смотри также Send Feedback
Коллекция для связки "локализация типа инфоблока". Содержит связки типа BXIBlockType..::..BXInfoBlockTypeLang

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXInfoBlockTypeLangCollection : BXEntityCollection<BXIBlockType..::..BXInfoBlockTypeLang, BXIBlockType..::..BXInfoBlockTypeLangCollection, BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme>

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<' BXIBlockType..::..BXInfoBlockTypeLang >)>)>
Bitrix.DataLayer..::..BXEntityCollection <(Of <(<' BXIBlockType..::..BXInfoBlockTypeLang, BXIBlockType..::..BXInfoBlockTypeLangCollection, BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlockType..::..BXInfoBlockTypeLangCollection

Смотри также

Члены BXIBlockType..::..BXInfoBlockTypeLangCollection
Пространство имен Bitrix.IBlock


Члены BXIBlockType.BXInfoBlockTypeLangCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockType..::..BXInfoBlockTypeLangCollection
Класс BXIBlockType..::..BXInfoBlockTypeLangCollection Конструкторы Методы Свойства Смотри также Send Feedback

Класс определяет сущность "тип инфоблока".

Тип BXIBlockType..::..BXInfoBlockTypeLangCollection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockType..::..BXInfoBlockTypeLangCollection | Конструктор класса.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Свойства

Имя | Описание
Item | Возвращает связку "локализация типа инфоблока" для инфоблока по идентификатору языка.

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLangCollection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockType.BXInfoBlockTypeLangCollection

Конструктор BXIBlockType..::..BXInfoBlockTypeLangCollection
Класс BXIBlockType..::..BXInfoBlockTypeLangCollection Смотри также Send Feedback
Конструктор класса.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXInfoBlockTypeLangCollection()

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLangCollection
Пространство имен Bitrix.IBlock


Методы BXIBlockType.BXInfoBlockTypeLangCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockType..::..BXInfoBlockTypeLangCollection
Класс BXIBlockType..::..BXInfoBlockTypeLangCollection Смотри также Send Feedback

Тип BXIBlockType..::..BXInfoBlockTypeLangCollection предоставляет следующие возможности.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLangCollection
Пространство имен Bitrix.IBlock


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockTypeLangCollection..::.Save
Класс BXIBlockType..::..BXInfoBlockTypeLangCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет все сущности коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет все сущности коллекции, используя указанное соединение. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLangCollection
Члены BXIBlockType..::..BXInfoBlockTypeLangCollection
Пространство имен Bitrix.IBlock


Метод ToDataTable

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXInfoBlockTypeLangCollection..::.ToDataTable
Класс BXIBlockType..::..BXInfoBlockTypeLangCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ToDataTable()()()() | Приводит коллекцию к типу DataTable. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable(BXPagingOptions) | Приводит коллекцию к типу DataTable с применением опций постраничной навигации. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLangCollection
Члены BXIBlockType..::..BXInfoBlockTypeLangCollection
Пространство имен Bitrix.IBlock


Свойства BXIBlockType.BXInfoBlockTypeLangCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockType..::..BXInfoBlockTypeLangCollection
Класс BXIBlockType..::..BXInfoBlockTypeLangCollection Смотри также Send Feedback

Тип BXIBlockType..::..BXInfoBlockTypeLangCollection предоставляет следующие возможности.

Свойства

Имя | Описание
Item | Возвращает связку "локализация типа инфоблока" для инфоблока по идентификатору языка.

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLangCollection
Пространство имен Bitrix.IBlock


Свойство Item

Свойство BXIBlockType..::..BXInfoBlockTypeLangCollection..::.Item
Класс BXIBlockType..::..BXInfoBlockTypeLangCollection Пример Смотри также Send Feedback
Возвращает связку "локализация типа инфоблока" для инфоблока по идентификатору языка.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockType..::..BXInfoBlockTypeLang this[
    string lang
] { get; }

Параметры

lang
Type: System..::..String
Идентификатор языка.

Возвращаемое значение

Экземпляр сущности-связки "локализация типа инфоблока"

Заметки

В случае, когда в коллекции нет нужной локализации, будет возвращена случайная локализация.

В случае, когда в коллекции вообще нет ни одной локализации, будет возвращена заглушка.

Примеры

Вывод списка инфоблоков с локализацией на текущем языке:

CopyC#
<%
    foreach (BXIBlockType type in BXIBlockType.GetList(null, null))
    {
        BXIBlockType.BXInfoBlockTypeLang translation = type.Translations[BXLoc.CurrentLocale];
        BXIBlockCollection iblocks = BXIBlock.GetList(
            new BXFilter(
                new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, type.Id)
            ),
            null
        );
        %>
        <div>
            <h4><%= translation.Name%></h4>
            <ul>
                <%
                    foreach(BXIBlock iblock in iblocks)
                    {
                        %>
                        <li>
                            <strong><%= iblock.Name %>:</strong>
                            <%= translation.ElementName %> - <%= iblock.ElementsCount %>,
                            <%= translation.SectionName %> - <%= iblock.SectionsCount %>
                        </li>
                        <%
                    }
                %>
            </ul>
        </div>
        <%
    }
%>

Смотри также

Класс BXIBlockType..::..BXInfoBlockTypeLangCollection
Пространство имен Bitrix.IBlock


Класс BXIBlockType.Scheme

Класс BXIBlockType..::..Scheme
Класс BXIBlockType Члены Смотри также Send Feedback
Схема сущности "тип инфоблока".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class Scheme : BXScheme<BXIBlockType..::..Scheme>

Иерархия наследования

System..::..Object
BXSchemeBase
BXScheme<(Of <(<'BXIBlockType..::..Scheme>)>)>
Bitrix.IBlock..::..BXIBlockType..::..Scheme

Смотри также

Члены BXIBlockType..::..Scheme
Пространство имен Bitrix.IBlock


Члены BXIBlockType.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockType..::..Scheme
Класс BXIBlockType..::..Scheme Конструкторы Свойства Смотри также Send Feedback

Класс определяет сущность "тип инфоблока".

Тип BXIBlockType..::..Scheme предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockType..::..Scheme |

Свойства

Имя | Описание
ID | Описание поля "Идентификатор типа инфоблока". Первичный ключ.
Sort | Описание поля "Порядок сортировки".
Translations | Описание поля "Связанная локализация". Связанное поле.

Смотри также

Класс BXIBlockType..::..Scheme
Пространство имен Bitrix.IBlock


Конструктор BXIBlockType.Scheme

Конструктор BXIBlockType..::..Scheme
Класс BXIBlockType..::..Scheme Смотри также Send Feedback

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Scheme()

Смотри также

Класс BXIBlockType..::..Scheme
Пространство имен Bitrix.IBlock


Свойства BXIBlockType.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXIBlockType..::..Scheme
Класс BXIBlockType..::..Scheme Смотри также Send Feedback

Тип BXIBlockType..::..Scheme предоставляет следующие возможности.

Свойства

Имя | Описание
ID | Описание поля "Идентификатор типа инфоблока". Первичный ключ.
Sort | Описание поля "Порядок сортировки".
Translations | Описание поля "Связанная локализация". Связанное поле.

Смотри также

Класс BXIBlockType..::..Scheme
Пространство имен Bitrix.IBlock


Свойство ID

Свойство BXIBlockType..::..Scheme..::.ID
Класс BXIBlockType..::..Scheme Пример Смотри также Send Feedback
Описание поля "Идентификатор типа инфоблока". Первичный ключ.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ID { get; }

Примеры

Получение списка инфоблоков, принадлежащих определенному типу:

CopyC#
int iblockTypeId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId));

BXIBlockCollection iblocks = BXIBlock.GetList(filter, null);

Смотри также

Класс BXIBlockType..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Sort

Свойство BXIBlockType..::..Scheme..::.Sort
Класс BXIBlockType..::..Scheme Пример Смотри также Send Feedback
Описание поля "Порядок сортировки".

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Sort { get; }

Примеры

Получение списка инфоблоков, принадлежащих определенному типу:

CopyC#
int iblockTypeId;

BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId));

BXIBlockCollection iblocks = BXIBlock.GetList(filter, null);

Смотри также

Класс BXIBlockType..::..Scheme
Пространство имен Bitrix.IBlock


Свойство Translations

Свойство BXIBlockType..::..Scheme..::.Translations
Класс BXIBlockType..::..Scheme Пример Смотри также Send Feedback
Описание поля "Связанная локализация". Связанное поле.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockType..::..BXInfoBlockTypeLang..::..Scheme Translations { get; }

Заметки

Название типа инфоблока, типов элементов и разделов может быть задано на разных языках, зарегистрированных в системе. См. BXLanguage.

Поле "Связанная локализация" позволяет задать фильтр наличия у типа инфоблока той или иной локализации.

Примеры

Выборка тех типов инфоблоков, для которых задана локализация на немецком языке:

CopyC#
BXFilter filter = new BXFilter();
filter.Add(new BXFilterItem(BXIBlockType.Fields.Translations.LanguageId, BXSqlFilterOperators.Equal, "de"));

BXIBlockTypeCollection types = BXIBlockType.GetList(filter, null);

Смотри также

Класс BXIBlockType..::..Scheme
Пространство имен Bitrix.IBlock


Класс BXIBlockTypeCollection

Класс BXIBlockTypeCollection
Члены Пример Смотри также Send Feedback
Коллекция типов инфоблоков. См. BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXIBlockTypeCollection : BXEntityCollection<BXIBlockType, BXIBlockTypeCollection, BXIBlockType..::..Scheme>

Примеры

Выборка всех типов инфоблоков в системе:

CopyC#
BXOrderBy orderBy = new BXOrderBy();
orderBy.Add(BXIBlockType.Fields.Sort, BXOrderByDirection.Asc);

BXIBlockTypeCollection types = BXIBlockType.GetList(null, orderBy);

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<' BXIBlockType >)>)>
Bitrix.DataLayer..::..BXEntityCollection <(Of <(<' BXIBlockType, BXIBlockTypeCollection, BXIBlockType..::..Scheme >)>)>
Bitrix.IBlock..::..BXIBlockTypeCollection

Смотри также

Члены BXIBlockTypeCollection
Пространство имен Bitrix.IBlock


Члены BXIBlockTypeCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXIBlockTypeCollection
Класс BXIBlockTypeCollection Конструкторы Методы Смотри также Send Feedback

Тип BXIBlockTypeCollection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXIBlockTypeCollection | Конструктор по умолчанию.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Смотри также

Класс BXIBlockTypeCollection
Пространство имен Bitrix.IBlock


Конструктор BXIBlockTypeCollection

Конструктор BXIBlockTypeCollection
Класс BXIBlockTypeCollection Смотри также Send Feedback
Конструктор по умолчанию.

Пространство имен: Bitrix.IBlock
Сборка: IBlock (in IBlock.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXIBlockTypeCollection()

Смотри также

Класс BXIBlockTypeCollection
Пространство имен Bitrix.IBlock


Методы BXIBlockTypeCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXIBlockTypeCollection
Класс BXIBlockTypeCollection Смотри также Send Feedback

Тип BXIBlockTypeCollection предоставляет следующие возможности.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Смотри также

Класс BXIBlockTypeCollection
Пространство имен Bitrix.IBlock


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockTypeCollection..::.Save
Класс BXIBlockTypeCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет все сущности коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет все сущности коллекции, используя указанное соединение. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockTypeCollection
Члены BXIBlockTypeCollection
Пространство имен Bitrix.IBlock


Метод ToDataTable

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXIBlockTypeCollection..::.ToDataTable
Класс BXIBlockTypeCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ToDataTable()()()() | Приводит коллекцию к типу DataTable. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable(BXPagingOptions) | Приводит коллекцию к типу DataTable с применением опций постраничной навигации. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXIBlockTypeCollection
Члены BXIBlockTypeCollection
Пространство имен Bitrix.IBlock


Пространство имен Bitrix.IO

Пространство имен Bitrix.IO
Send Feedback
Содержит классы, отвечающие за работу с файловой системой и средствами ввода/вывода.

Классы

Класс | Описание
BXFile | Класс, который предоставляет возможность работать с файлами как с сущностями
BXFile..::..Scheme | Схема сущности файла
BXFileCollection | Класс коллекции для сущности BXFile
BXFileInfo | Предоставляет методы для получения информации о файлах.

Перечисления

Перечисление | Описание
BXFileType | Перечисление, содержащее различные типы файлов.
BXFileValidationResult | Результат проверки соответствия файла заданным условиям.


Класс BXFile

Класс BXFile
Члены Пример Смотри также Send Feedback
Класс, который предоставляет возможность работать с файлами как с сущностями

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXFile : BXEntity<BXFile, BXFileCollection, BXFile..::..Scheme>

Примеры

Загрузка изображения, переданного через элемент управления FileUpload:

CopyC#
if (Upload.HasFile)
{
    fImage = new BXFile(Upload.PostedFile, "iblock", "iblock", null);
    if (fImage.ValidateAsImage(0, 0, 0) != BXFileValidationResult.Valid)
        throw new Exception("Файл не является допустимым файлом изображения");

    BXSecureIO.DemandUpload(fImage.FileVirtualPath);
    fImage.Save();
}

Создание сущности файла на основе файла с жесткого диска:

CopyC#
using (FileStream fileStream = new FileStream(filePath, FileMode.Open))
{
    BXFile file = new BXFile(fileStream, fileName, "userfiles", "main", null);
    BXSecureIO.DemandUpload(file.FileVirtualPath);
    file.Save();
}

Отрисовка картинки из сущности файла в шаблоне компонента или aspx-странице:

CopyC#
<img
    class="preview_picture"
     border="0"
     src="<%= image.FilePath %>"
    width="<%= image.Width %>"
    height="<%= image.Height %>"
    alt="<%= image.Description %>"
    style="float:left"
/>

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXEntity
Bitrix.DataLayer..::..BXEntity <(Of <(<'BXFile, BXFileCollection, BXFile..::..Scheme >)>)>
Bitrix.IO..::..BXFile

Смотри также

Члены BXFile
Пространство имен Bitrix.IO


Члены BXFile

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXFile
Класс BXFile Конструкторы Методы Поля Свойства Смотри также Send Feedback

Тип BXFile предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXFile | Перегруженный.

Методы

Имя | Описание
ClearFile | Удаляет источник файла из несохраненной сущности.
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
FileAction | Обрабатывает очередь операций с файлами в БД.
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFileTimestamp | Возвращает количество тиков, соответствующее дате последнего изменения файла
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetFile | Перегруженный.
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Validate | Перегруженный.
ValidateAsImage | Перегруженный.
VerifyEntry | Проверяет корректность сущности перед сохранением. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..VerifyEntry()()()())

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UploadFolder | Виртуальный путь к папке загрузки файлов.
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Свойства

Имя | Описание
ContentType | MIME-тип файла.
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Унаследовано от BXEntity)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Description | Описание файла. Закодировано кодировщиком.
EntityId | Имя сущности. Возвращает "File" (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..EntityId)
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
FileName | Возвращает имя файла, который фактически хранится на диске или будет сохранен.
FileNameOriginal | Оригинальное имя файла.
FilePath | Абсолютный путь к файлу. Закодировано кодировщиком.
FileSize | Размер файла в байтах.
FileVirtualPath | Виртуальный путь к файлу.
Folder | Возвращает имя подпапки, в которой расположен или будет расположен сохраняемый файл.
Height | Высота изображения в пикселах. Для фалов с MIME-типом 'image/*'.
Id | Уникальный идентификатор файла. Первичный ключ.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ModuleId | Имя модуля. Возвращает "Main". (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..ModuleId)
OwnerModuleId | Идентификатор модуля, которому принадлежит файл.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateDate | Дата последнего обновления файла.
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Width | Ширина изображения в пикселах. Для фалов с MIME-типом 'image/*'.

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Конструктор BXFile

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXFile
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXFile()()()() | Создает сущность файла.
BXFile(IBXTextEncoder) | Создает сущность файла.
BXFile(HttpPostedFile, String) | Создает сущность файла.
BXFile(IBXTextEncoder, HttpPostedFile, String) | Создает сущность файла.
BXFile(Stream, String, String) | Создает сущность файла.
BXFile(IBXTextEncoder, Stream, String, String) | Создает сущность файла.
BXFile(HttpPostedFile, String, String, String) | Создает сущность файла.
BXFile(IBXTextEncoder, HttpPostedFile, String, String, String) | Создает сущность файла.
BXFile(Stream, String, String, String, String) | Создает сущность файла.
BXFile(IBXTextEncoder, Stream, String, String, String, String) | Создает сущность файла.
BXFile(Stream, String, String, String, String, String) | Создает сущность файла.
BXFile(IBXTextEncoder, Stream, String, String, String, String, String) | Создает сущность файла.

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Конструктор BXFile

Конструктор BXFile
Класс BXFile Смотри также Send Feedback
Создает сущность файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile()

Смотри также

Класс BXFile
Перегрузка BXFile
Пространство имен Bitrix.IO


Конструктор BXFile ()

Конструктор BXFile ()
Класс BXFile Смотри также Send Feedback
Создает сущность файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile(
    IBXTextEncoder encoder
)

Параметры

encoder
Type: IBXTextEncoder
Кодировщик для некоторых свойств сущности. Может быть равен null.

Смотри также

Класс BXFile
Перегрузка BXFile
Пространство имен Bitrix.IO


Конструктор BXFile (HttpPostedFile, String)

Конструктор BXFile (HttpPostedFile, String)
Класс BXFile Смотри также Send Feedback
Создает сущность файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile(
    HttpPostedFile file,
    string path
)

Параметры

file
Type: System.Web..::..HttpPostedFile
Источник файла.
path
Type: System..::..String
Подпапка, в которой будет располагаться файл.

Смотри также

Класс BXFile
Перегрузка BXFile
Пространство имен Bitrix.IO


Конструктор BXFile (, HttpPostedFile, String)

Конструктор BXFile (, HttpPostedFile, String)
Класс BXFile Смотри также Send Feedback
Создает сущность файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile(
    IBXTextEncoder encoder,
    HttpPostedFile file,
    string path
)

Параметры

encoder
Type: IBXTextEncoder
Кодировщик для некоторых свойств сущности. Может быть равен null.
file
Type: System.Web..::..HttpPostedFile
Источник файла.
path
Type: System..::..String
Подпапка, в которой будет располагаться файл.

Смотри также

Класс BXFile
Перегрузка BXFile
Пространство имен Bitrix.IO


Конструктор BXFile (Stream, String, String)

Конструктор BXFile (Stream, String, String)
Класс BXFile Смотри также Send Feedback
Создает сущность файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile(
    Stream file,
    string filename,
    string path
)

Параметры

file
Type: System.IO..::..Stream
Источник файла.
filename
Type: System..::..String
Исходное имя файла.
path
Type: System..::..String
Подпапка, в которой будет располагаться файл.

Смотри также

Класс BXFile
Перегрузка BXFile
Пространство имен Bitrix.IO


Конструктор BXFile (, Stream, String, String)

Конструктор BXFile (, Stream, String, String)
Класс BXFile Смотри также Send Feedback
Создает сущность файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile(
    IBXTextEncoder encoder,
    Stream file,
    string filename,
    string path
)

Параметры

encoder
Type: IBXTextEncoder
Кодировщик для некоторых свойств сущности. Может быть равен null.
file
Type: System.IO..::..Stream
Источник файла.
filename
Type: System..::..String
Исходное имя файла.
path
Type: System..::..String
Подпапка, в которой будет располагаться файл.

Смотри также

Класс BXFile
Перегрузка BXFile
Пространство имен Bitrix.IO


Конструктор BXFile (HttpPostedFile, String, String, String)

Конструктор BXFile (HttpPostedFile, String, String, String)
Класс BXFile Смотри также Send Feedback
Создает сущность файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile(
    HttpPostedFile file,
    string path,
    string moduleId,
    string description
)

Параметры

file
Type: System.Web..::..HttpPostedFile
Источник файла.
path
Type: System..::..String
Подпапка, в которой будет располагаться файл. Может быть равна null.
moduleId
Type: System..::..String
Идентификатор модуля, к которому принадлежит файл.
description
Type: System..::..String
Описание файла. Может быть равно null.

Смотри также

Класс BXFile
Перегрузка BXFile
Пространство имен Bitrix.IO


Конструктор BXFile (, HttpPostedFile, String, String, String)

Конструктор BXFile (, HttpPostedFile, String, String, String)
Класс BXFile Смотри также Send Feedback
Создает сущность файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile(
    IBXTextEncoder encoder,
    HttpPostedFile file,
    string path,
    string moduleId,
    string description
)

Параметры

encoder
Type: IBXTextEncoder
Кодировщик для некоторых свойств сущности. Может быть равен null.
file
Type: System.Web..::..HttpPostedFile
Источник файла.
path
Type: System..::..String
Подпапка, в которой будет располагаться файл.
moduleId
Type: System..::..String
Идентификатор модуля, к которому принадлежит файл.
description
Type: System..::..String
Описание файла. Может быть равно null.

Смотри также

Класс BXFile
Перегрузка BXFile
Пространство имен Bitrix.IO


Конструктор BXFile (Stream, String, String, String, String)

Конструктор BXFile (Stream, String, String, String, String)
Класс BXFile Смотри также Send Feedback
Создает сущность файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile(
    Stream file,
    string filename,
    string path,
    string moduleId,
    string description
)

Параметры

file
Type: System.IO..::..Stream
Источник файла.
filename
Type: System..::..String
Исходное имя файла.
path
Type: System..::..String
Подпапка, в которой будет располагаться файл. Может быть равна null.
moduleId
Type: System..::..String
Идентификатор модуля, к которому принадлежит файл.
description
Type: System..::..String
Описание файла. Может быть равно null.

Смотри также

Класс BXFile
Перегрузка BXFile
Пространство имен Bitrix.IO


Конструктор BXFile (, Stream, String, String, String, String)

Конструктор BXFile (, Stream, String, String, String, String)
Класс BXFile Смотри также Send Feedback
Создает сущность файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile(
    IBXTextEncoder encoder,
    Stream file,
    string filename,
    string path,
    string moduleId,
    string description
)

Параметры

encoder
Type: IBXTextEncoder
Кодировщик для некоторых свойств сущности. Может быть равен null.
file
Type: System.IO..::..Stream
Источник файла.
filename
Type: System..::..String
Исходное имя файла.
path
Type: System..::..String
Подпапка, в которой будет располагаться файл.
moduleId
Type: System..::..String
Идентификатор модуля, к которому принадлежит файл.
description
Type: System..::..String
Описание файла. Может быть равно null.

Смотри также

Класс BXFile
Перегрузка BXFile
Пространство имен Bitrix.IO


Конструктор BXFile (Stream, String, String, String, String, String)

Конструктор BXFile (Stream, String, String, String, String, String)
Класс BXFile Смотри также Send Feedback
Создает сущность файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile(
    Stream file,
    string filename,
    string path,
    string moduleId,
    string description,
    string contentType
)

Параметры

file
Type: System.IO..::..Stream
Источник файла.
filename
Type: System..::..String
Исходное имя файла.
path
Type: System..::..String
Подпапка, в которой будет располагаться файл. Может быть равна null.
moduleId
Type: System..::..String
Идентификатор модуля, к которому принадлежит файл.
description
Type: System..::..String
Описание файла. Может быть равно null.
contentType
Type: System..::..String
MIME-тип файла.

Смотри также

Класс BXFile
Перегрузка BXFile
Пространство имен Bitrix.IO


Конструктор BXFile (, Stream, String, String, String, String, String)

Конструктор BXFile (, Stream, String, String, String, String, String)
Класс BXFile Смотри также Send Feedback
Создает сущность файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFile(
    IBXTextEncoder encoder,
    Stream file,
    string filename,
    string path,
    string moduleId,
    string description,
    string contentType
)

Параметры

encoder
Type: IBXTextEncoder
Кодировщик для некоторых свойств сущности. Может быть равен null.
file
Type: System.IO..::..Stream
Источник файла.
filename
Type: System..::..String
Исходное имя файла.
path
Type: System..::..String
Подпапка, в которой будет располагаться файл. Может быть равна null.
moduleId
Type: System..::..String
Идентификатор модуля, к которому принадлежит файл.
description
Type: System..::..String
Описание файла. Может быть равно null.
contentType
Type: System..::..String
MIME-тип файла.

Смотри также

Класс BXFile
Перегрузка BXFile
Пространство имен Bitrix.IO


Поля BXFile

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXFile
Класс BXFile Смотри также Send Feedback

Тип BXFile предоставляет следующие возможности.

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UploadFolder | Виртуальный путь к папке загрузки файлов.
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Поле UploadFolder

Поле BXFile..::.UploadFolder
Класс BXFile Смотри также Send Feedback
Виртуальный путь к папке загрузки файлов.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public const string UploadFolder

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Методы BXFile

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXFile
Класс BXFile Смотри также Send Feedback

Тип BXFile предоставляет следующие возможности.

Методы

Имя | Описание
ClearFile | Удаляет источник файла из несохраненной сущности.
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
FileAction | Обрабатывает очередь операций с файлами в БД.
GetByIdInternal | Перегруженный.
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFileTimestamp | Возвращает количество тиков, соответствующее дате последнего изменения файла
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetFile | Перегруженный.
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Validate | Перегруженный.
ValidateAsImage | Перегруженный.
VerifyEntry | Проверяет корректность сущности перед сохранением. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..VerifyEntry()()()())

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Метод ClearFile

Метод BXFile..::.ClearFile
Класс BXFile Смотри также Send Feedback
Удаляет источник файла из несохраненной сущности.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void ClearFile()

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Метод Create

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFile..::.Create
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Create()()()() | Добавляет новую сущность в базу данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create(BXSqlConnection, BXSqlTransaction) | Добавляет новую сущность в базу данных, используя указанное соединение. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..Create(BXSqlConnection, BXSqlTransaction))

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Метод Create (, )

Метод BXFile..::.Create (, )
Класс BXFile Пример Смотри также Send Feedback
Добавляет новую сущность в базу данных, используя указанное соединение.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override void Create(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Заметки

Метод сохранения новой сущности является виртуальным и может быть переопределен в конкретной реализации сущности. Таким образом сохранение конкретной сущности может осуществляться не стандартным образом.

Стандартное сохранение новой сущности происходит следующим образом:

  1. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnBeforeCreate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Cancel, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для того, чтобы была возможность корректно отменить сохранение сущности. Обработчики этой команды не должны модифицировать данные, так как нет гарантий, что один из обработчиков не отменит сохранение.

  2. Вызывается виртуальный метод VerifyEntry()()()(), который проверяет соответствие параметров сущности и ее схемы. Производятся следующие проверки полей сущности:

    • если поле является первичным ключем и у него установлен флаг Identity, то в параметрах сущности не должно быть заданого значения для этого поля,

    • если поле является первичным ключем и у него не установлен флаг Identity, то в параметрах сущности должно быть задано значение для этого поля,

    • если поле является обязательным и у него не задано значение по умолчанию, то в параметрах сущности должно быть задано значение для этого поля,

    • если поле является строковым, у него задано ограничение по длине и задано значение этого поля, то значение не должно быть длинее указанного ограничения.

    Если метод VerifyEntry()()()() вернул отличный от BXModifyStatusResult.Success статус, то сохранение преравается и выбрасывается исключение типа BXEventException.

  3. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnCreate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций перед сохранением новой сущности.

  4. Производится сохранение сущности и ее связок.

  5. Выполняется виртуальный метод CreateAdditionalEntities(BXSqlConnection, BXSqlTransaction), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется в рамках транзакции сохранения сущности.

  6. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnAfterCreate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций после сохранения новой сущности.

  7. Выполняется виртуальный метод CreateAfterSuccess()()()(), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется после закрытия соединения, в котором сохранялась сущность.

Примеры

CopyC#
BXSite site = new BXSite("company");
site.Name = "Моя компания";
site.Active = true;
site.Sort = 150;
site.Create();

Смотри также

Класс BXFile
Перегрузка Create
Пространство имен Bitrix.IO
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..Create()()()()


Метод Delete

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFile..::.Delete
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Delete()()()() | Удаляет текущую сущность из базы данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete(BXSqlConnection, BXSqlTransaction) | Ставит файл на очередь удаления из БД. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..Delete(BXSqlConnection, BXSqlTransaction))

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Метод Delete (, )

Метод BXFile..::.Delete (, )
Класс BXFile Пример Смотри также Send Feedback
Ставит файл на очередь удаления из БД.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override void Delete(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Текущее соединение с БД.
trans
Type: BXSqlTransaction
Текущая транзакция.

Заметки

Метод удаления существующей сущности является виртуальным и может быть переопределен в конкретной реализации сущности. Таким образом удаление конкретной сущности может осуществляться не стандартным образом.

Стандартное удаление существующей сущности происходит следующим образом:

  1. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnBeforeDelete, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Cancel, то удаление сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для того, чтобы была возможность корректно отменить удаление сущности. Обработчики этой команды не должны модифицировать данные, так как нет гарантий, что один из обработчиков не отменит удаление.

  2. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnDelete, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то удаление сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций перед удалением существующей сущности.

  3. Выполняется виртуальный метод DeleteAdditionalEntities(BXSqlConnection, BXSqlTransaction), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется в рамках транзакции удаления сущности.

  4. Производится удаление сущности и ее связок.

  5. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnAfterDelete, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций после удаления существующей сущности.

  6. Выполняется виртуальный метод DeleteAfterSuccess()()()(), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется после закрытия соединения, в котором удалялась сущность.

Примеры

CopyC#
BXSite site = BXSite.GetById("company");
site.Delete();

Смотри также

Класс BXFile
Перегрузка Delete
Пространство имен Bitrix.IO
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..Delete()()()()


Метод DeleteInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFile..::.DeleteInternal
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
DeleteInternal(Object) | Внутренний метод удаления сущностей по первичному ключу id, который вызывается статическим методом Delete(Object). (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter) | Внутренний метод удаления сущностей по фильтру, который вызывается статическим методом Delete(BXFilter). При удалении не отправляются никакие комманды и не удаляются дополнительные данные. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter, BXSqlConnection, BXSqlTransaction) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Метод FileAction

Метод BXFile..::.FileAction
Класс BXFile Смотри также Send Feedback
Обрабатывает очередь операций с файлами в БД.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void FileAction()

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Метод GetByIdInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFile..::.GetByIdInternal
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetByIdInternal(Object, IBXTextEncoder) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal(Object, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Метод GetFileTimestamp

Метод BXFile..::.GetFileTimestamp
Класс BXFile Пример Смотри также Send Feedback
Возвращает количество тиков, соответствующее дате последнего изменения файла

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static long GetFileTimestamp(
    string filePath
)

Параметры

filePath
Type: System..::..String
Путь к файлу (физический или виртуальный)

Возвращаемое значение

Количество тиков, соответствующее дате последнего изменения файла

Примеры

Метод для добавления ссылки на js-файл в страницу:

CopyC#
void RegisterVersionedScript(string virtualPath)
{
    ScriptManager.RegisterClientScriptInclude(
        Page,
        Page.GetType(),
        virtualPath,
        VirtualPathUtility.ToAbsolute(virtualPath) + "?v=" + BXFile.GetFileTimestamp(virtualPath)
    );
}

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Метод GetJoinedEntity

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFile..::.GetJoinedEntity
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String, BXSchemeBase) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Метод GetJoinedEntityCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFile..::.GetJoinedEntityCollection
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType, JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>)(String, String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Метод GetListInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFile..::.GetListInternal
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFile..::.Save
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет сущность в базе данных в новой транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет сущность в базе данных в указанной транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Метод SetFile

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFile..::.SetFile
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
SetFile(Stream, String) | Устанавливает источник файла, который будет сохранен в системе.
SetFile(HttpPostedFile, String) | Устанавливает источник файла, который будет сохранен в системе.

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Метод SetFile (Stream, String)

Метод BXFile..::.SetFile (Stream, String)
Класс BXFile Пример Смотри также Send Feedback
Устанавливает источник файла, который будет сохранен в системе.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void SetFile(
    Stream file,
    string path
)

Параметры

file
Type: System.IO..::..Stream
Источник файла.
path
Type: System..::..String
Подпапка, в которую необходимо сохранить файл. Может быть равна null.

Заметки

Используется только на несохраненных файлах.

Фактическое сохранение файла происходит при сохранении сущности.

Сохранение файла не освобождает источник. Необходимо самостоятельно освободить источник после сохранения файла.

Примеры

CopyC#
BXFile file = new BXFile();
file.FileNameOriginal = "myimage.jpg";
file.ContentType = "image/jpeg";
file.OwnerModuleId = "main";
file.Description = "Мое изображение";
using (FileStream data = new FileStream(MapPath("~/myimage.jpg"), FileMode.Open))
{
    file.SetFile(data, "images");
    BXSecureIO.DemandWrite(file.FileVirtualPath);
    file.Save();
}

Смотри также

Класс BXFile
Перегрузка SetFile
Пространство имен Bitrix.IO


Метод SetFile (HttpPostedFile, String)

Метод BXFile..::.SetFile (HttpPostedFile, String)
Класс BXFile Пример Смотри также Send Feedback
Устанавливает источник файла, который будет сохранен в системе.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void SetFile(
    HttpPostedFile file,
    string path
)

Параметры

file
Type: System.Web..::..HttpPostedFile
Источник файла.
path
Type: System..::..String
Подпапка, в которую необходимо сохранить файл. Может быть равна null.

Заметки

Используется только на несохраненных файлах.

Фактическое сохранение файла происходит при сохранении сущности.

Примеры

Загрузка изображения, переданного через элемент управления FileUpload:

CopyC#
if (Upload.HasFile)
{
    BXFile file = new BXFile();
    file.FileNameOriginal = "myimage.jpg";
    file.ContentType = "image/jpeg";
    file.OwnerModuleId = "main";
    file.Description = "Мое изображение";

    file.SetFile(Upload.PostedFile, "images");
    BXSecureIO.DemandWrite(file.FileVirtualPath);
    file.Save();
}

Смотри также

Класс BXFile
Перегрузка SetFile
Пространство имен Bitrix.IO


Метод SetValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFile..::.SetValue
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
SetValue(KeyValuePair<(Of <<'(String, Object>)>>), Boolean) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object, Boolean) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Метод Update

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFile..::.Update
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Update()()()() | Изменяет существующую сущность в базе данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update(BXSqlConnection, BXSqlTransaction) | Изменяет существующую сущность в базе данных в указанной транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Метод Validate

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFile..::.Validate
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Validate(array<String>[]()[][], Int32, array<String>[]()[][]) | Проверяет файл на соответствие заданным критериям.
Validate(String, Int32, String, array<String>[]()[][], Int32, array<String>[]()[][]) | Проверяет файл на соответствие заданным критериям.

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Метод Validate (String[], Int32, String[])

Метод BXFile..::.Validate (array<String>[]()[][], Int32, array<String>[]()[][])
Класс BXFile Пример Смотри также Send Feedback
Проверяет файл на соответствие заданным критериям.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFileValidationResult Validate(
    string[] allowedExtensions,
    int maxFileSize,
    string[] allowedContentTypes
)

Параметры

allowedExtensions
Type: array< System..::..String >[]()[][]
Массив разрешенных расширений файла (например {".jpg", ".png", ".gif"}). Если равен null, проверка пропускается.
maxFileSize
Type: System..::..Int32
Максимальный размер файла в байтах. Если равен 0, проверка пропускается.
allowedContentTypes
Type: array< System..::..String >[]()[][]
Массив разрешенных MIME-типов файла. Если равен null, проверка пропускается.

Возвращаемое значение

Результат проверки (комбинированое значение флагов BXFileValidationResult).

Примеры

Загрузка текстового файла, переданного через элемент управления FileUpload с ограничением в 1 МБ:

CopyC#
if (Upload.HasFile)
{
    file = new BXFile(Upload.PostedFile, "iblock", "iblock", null);
    if (file.Validate(new string[] { ".txt", "*.html", ".js", ".css" }, 1048576, new string[] { "text" }) != BXFileValidationResult.Valid)
        throw new Exception("Файл не является допустимым текстовым файлом");

    BXSecureIO.DemandUpload(file.FileVirtualPath);
    file.Save();
}

Смотри также

Класс BXFile
Перегрузка Validate
Пространство имен Bitrix.IO


Метод Validate (String, Int32, String, String[], Int32, String[])

Метод BXFile..::.Validate (String, Int32, String, array<String>[]()[][], Int32, array<String>[]()[][])
Класс BXFile Смотри также Send Feedback
Проверяет файл на соответствие заданным критериям.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXFileValidationResult Validate(
    string name,
    int size,
    string contentType,
    string[] allowedExtensions,
    int maxSize,
    string[] allowedContentTypes
)

Параметры

name
Type: System..::..String
имя файла
size
Type: System..::..Int32
размер файла
contentType
Type: System..::..String
тип (mime-type)
allowedExtensions
Type: array< System..::..String >[]()[][]
Массив разрешенных расширений файла (например {".jpg", ".png", ".gif"}). Если равен null, проверка пропускается.
maxSize
Type: System..::..Int32
Максимальный размер файла в байтах. Если равен 0, проверка пропускается.
allowedContentTypes
Type: array< System..::..String >[]()[][]
Массив разрешенных MIME-типов файла. Если равен null, проверка пропускается.

Возвращаемое значение

Результат проверки (комбинированое значение флагов BXFileValidationResult).

Смотри также

Класс BXFile
Перегрузка Validate
Пространство имен Bitrix.IO


Метод ValidateAsImage

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFile..::.ValidateAsImage
Класс BXFile Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ValidateAsImage(Int32, Int32, Int32) | Проверяет файл с изображением на соответствие заданным критериям.
ValidateAsImage(String, String, Stream, Int32, Int32, Int32) | Проверяет файл с изображением на соответствие заданным критериям.

Смотри также

Класс BXFile
Члены BXFile
Пространство имен Bitrix.IO


Метод ValidateAsImage (Int32, Int32, Int32)

Метод BXFile..::.ValidateAsImage (Int32, Int32, Int32)
Класс BXFile Пример Смотри также Send Feedback
Проверяет файл с изображением на соответствие заданным критериям.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFileValidationResult ValidateAsImage(
    int maxFileSize,
    int maxWidth,
    int maxHeight
)

Параметры

maxFileSize
Type: System..::..Int32
Максимальный размер файла в байтах. Если равен 0, проверка пропускается.
maxWidth
Type: System..::..Int32
Максимальная ширина картинки. Если равен 0, проверка пропускается.
maxHeight
Type: System..::..Int32
Максимальная высота картинки. Если равен 0, проверка пропускается.

Возвращаемое значение

Результат проверки (комбинированое значение флагов BXFileValidationResult).

Примеры

Загрузка изображения, переданного через элемент управления FileUpload с ограничением в 100 КБ и максимальным размером 100x100:

CopyC#
if (Upload.HasFile)
{
    fImage = new BXFile(Upload.PostedFile, "iblock", "iblock", null);
    if (fImage.ValidateAsImage(102400, 100, 100) != BXFileValidationResult.Valid)
        throw new Exception("Файл не является допустимым файлом изображения");

    BXSecureIO.DemandUpload(fImage.FileVirtualPath);
    fImage.Save();
}

Смотри также

Класс BXFile
Перегрузка ValidateAsImage
Пространство имен Bitrix.IO


Метод ValidateAsImage (String, String, Stream, Int32, Int32, Int32)

Метод BXFile..::.ValidateAsImage (String, String, Stream, Int32, Int32, Int32)
Класс BXFile Смотри также Send Feedback
Проверяет файл с изображением на соответствие заданным критериям.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXFileValidationResult ValidateAsImage(
    string name,
    string contentType,
    Stream stream,
    int maxFileSize,
    int maxWidth,
    int maxHeight
)

Параметры

name
Type: System..::..String
имя файла
contentType
Type: System..::..String
тип (mime-type)
stream
Type: System.IO..::..Stream
поток файла
maxFileSize
Type: System..::..Int32
Максимальный размер файла в байтах. Если равен 0, проверка пропускается.
maxWidth
Type: System..::..Int32
Максимальная ширина картинки. Если равен 0, проверка пропускается.
maxHeight
Type: System..::..Int32
Максимальная высота картинки. Если равен 0, проверка пропускается.

Возвращаемое значение

Результат проверки (комбинированое значение флагов BXFileValidationResult).

Смотри также

Класс BXFile
Перегрузка ValidateAsImage
Пространство имен Bitrix.IO


Метод VerifyEntry

Метод BXFile..::.VerifyEntry
Класс BXFile Пример Смотри также Send Feedback
Проверяет корректность сущности перед сохранением.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override BXModifyStatus VerifyEntry()

Возвращаемое значение

Объект типа BXModifyStatus, содержащий статус проверки. Если метод VerifyEntry() вернул отличный от BXModifyStatusResult.Success статус, то сохранение прерывается и выбрасывается исключение типа BXEventException.

Заметки

Алгоритм проверки корректности при сохранении новой сущности следующий:

  • если поле является первичным ключем и у него установлен флаг Identity, то в параметрах сущности не должно быть заданого значения для этого поля,

  • если поле является первичным ключем и у него не установлен флаг Identity, то в параметрах сущности должно быть задано значение для этого поля,

  • если поле является обязательным и у него не задано значение по умолчанию, то в параметрах сущности должно быть задано значение для этого поля,

  • если поле является строковым, у него задано ограничение по длине и задано значение этого поля, то значение не должно быть длинее указанного ограничения.

Алгоритм проверки корректности при изменении существующей сущности следующий:

  • если поле является первичным ключем, то в параметрах сущности должно быть задано значение для этого поля,

  • если поле является строковым, у него задано ограничение по длине и задано значение этого поля, то значение не должно быть длинее указанного ограничения.

Примеры

CopyC#
BXModifyStatus status = this.VerifyEntry();
status.TryThrowException();

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойства BXFile

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXFile
Класс BXFile Смотри также Send Feedback

Тип BXFile предоставляет следующие возможности.

Свойства

Имя | Описание
ContentType | MIME-тип файла.
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Унаследовано от BXEntity)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Description | Описание файла. Закодировано кодировщиком.
EntityId | Имя сущности. Возвращает "File" (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..EntityId)
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
FileName | Возвращает имя файла, который фактически хранится на диске или будет сохранен.
FileNameOriginal | Оригинальное имя файла.
FilePath | Абсолютный путь к файлу. Закодировано кодировщиком.
FileSize | Размер файла в байтах.
FileVirtualPath | Виртуальный путь к файлу.
Folder | Возвращает имя подпапки, в которой расположен или будет расположен сохраняемый файл.
Height | Высота изображения в пикселах. Для фалов с MIME-типом 'image/*'.
Id | Уникальный идентификатор файла. Первичный ключ.
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ModuleId | Имя модуля. Возвращает "Main". (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..ModuleId)
OwnerModuleId | Идентификатор модуля, которому принадлежит файл.
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateDate | Дата последнего обновления файла.
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Width | Ширина изображения в пикселах. Для фалов с MIME-типом 'image/*'.

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство ContentType

Свойство BXFile..::.ContentType
Класс BXFile Пример Смотри также Send Feedback
MIME-тип файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ContentType { get; set; }

Примеры

Создание и сохранение новой сущности файла:

CopyC#
BXFile file = new BXFile();
file.FileNameOriginal = "myimage.jpg";
file.ContentType = "image/jpeg";
file.OwnerModuleId = "main";
file.Description = "Мое изображение";
using (FileStream data = new FileStream(MapPath("~/myimage.jpg"), FileMode.Open))
{
    file.SetFile(data, "images");
    BXSecureIO.DemandWrite(file.FileVirtualPath);
    file.Save();
}

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство Description

Свойство BXFile..::.Description
Класс BXFile Пример Смотри также Send Feedback
Описание файла. Закодировано кодировщиком.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Description { get; set; }

Примеры

Отрисовка картинки из сущности файла в шаблоне компонента или aspx-странице:

CopyC#
<img
    class="preview_picture"
    border="0"
    src="<%= image.FilePath %>"
    width="<%= image.Width %>"
    height="<%= image.Height %>"
    alt="<%= image.Description %>"
    style="float:left"
/>

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство EntityId

Свойство BXFile..::.EntityId
Класс BXFile Смотри также Send Feedback
Имя сущности. Возвращает "File"

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string EntityId { get; }

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство FileName

Свойство BXFile..::.FileName
Класс BXFile Смотри также Send Feedback
Возвращает имя файла, который фактически хранится на диске или будет сохранен.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string FileName { get; }

Заметки

При сохранении сущности для файла может генерироваться уникальное имя. Это определяется настройками продукта (см. BXOptionManager). Если значение настройки "SaveOriginalFileName" для модуля "main" равно "Y", то в качестве имени сохраняемого файла будет использоваться оригинальное имя файла, заданное свойством FileNameOriginal. Если при этом значение настройки "ConvertOriginalFileName" для модуля "main" равно "Y", то неразрешенные символы в имени файла будут заменены на символ "_"

Виртуальный путь к физическому файлу (FileVirtualPath) будет иметь вид "UploadFolder/Folder/FileName", например "~/upload/iblock/da0/da0bde10ebba96267ed2a7726c8cf333.jpg"

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство FileNameOriginal

Свойство BXFile..::.FileNameOriginal
Класс BXFile Пример Смотри также Send Feedback
Оригинальное имя файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string FileNameOriginal { get; set; }

Примеры

Создание и сохранение новой сущности файла:

CopyC#
BXFile file = new BXFile();
file.FileNameOriginal = "myimage.jpg";
file.ContentType = "image/jpeg";
file.OwnerModuleId = "main";
file.Description = "Мое изображение";
using (FileStream data = new FileStream(MapPath("~/myimage.jpg"), FileMode.Open))
{
    file.SetFile(data, "images");
    BXSecureIO.DemandWrite(file.FileVirtualPath);
    file.Save();
}

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство FilePath

Свойство BXFile..::.FilePath
Класс BXFile Пример Смотри также Send Feedback
Абсолютный путь к файлу. Закодировано кодировщиком.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string FilePath { get; }

Примеры

Отрисовка картинки из сущности файла в шаблоне компонента или aspx-странице:

CopyC#
<img
    class="preview_picture"
    border="0"
    src="<%= image.FilePath %>"
    width="<%= image.Width %>"
    height="<%= image.Height %>"
    alt="<%= image.Description %>"
    style="float:left"
/>

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство FileSize

Свойство BXFile..::.FileSize
Класс BXFile Смотри также Send Feedback
Размер файла в байтах.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int FileSize { get; }

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство FileVirtualPath

Свойство BXFile..::.FileVirtualPath
Класс BXFile Смотри также Send Feedback
Виртуальный путь к файлу.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string FileVirtualPath { get; }

Заметки

Виртуальный путь к физическому файлу (FileVirtualPath) будет иметь вид "UploadFolder/Folder/FileName", например "~/upload/iblock/da0/da0bde10ebba96267ed2a7726c8cf333.jpg"

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство Folder

Свойство BXFile..::.Folder
Класс BXFile Смотри также Send Feedback
Возвращает имя подпапки, в которой расположен или будет расположен сохраняемый файл.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Folder { get; }

Заметки

Виртуальный путь к физическому файлу (FileVirtualPath) будет иметь вид "UploadFolder/Folder/FileName", например "~/upload/iblock/da0/da0bde10ebba96267ed2a7726c8cf333.jpg"

Задать подпапку можно параметром path конструктора сущности, например, BXFile(HttpPostedFile, String), или метода SetFile(HttpPostedFile, String). При первом сохранении сущности к имени папки будет добавлены подпапка с именем, состоящим из трех символов латинского алфавита и цифр. Например, папка "iblock" превратится в "iblock/d08" для файла "da0bde10ebba96267ed2a7726c8cf333.jpg"

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство Height

Свойство BXFile..::.Height
Класс BXFile Пример Смотри также Send Feedback
Высота изображения в пикселах. Для фалов с MIME-типом 'image/*'.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Height { get; set; }

Примеры

Отрисовка картинки из сущности файла в шаблоне компонента или aspx-странице:

CopyC#
<img
    class="preview_picture"
    border="0"
    src="<%= image.FilePath %>"
    width="<%= image.Width %>"
    height="<%= image.Height %>"
    alt="<%= image.Description %>"
    style="float:left"
/>

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство Id

Свойство BXFile..::.Id
Класс BXFile Пример Смотри также Send Feedback
Уникальный идентификатор файла. Первичный ключ.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Id { get; }

Примеры

Создание элемента инфоблока и задание детального изображения:

CopyC#
BXFile file = new BXFile();
file.FileNameOriginal = "myimage.jpg";
file.ContentType = "image/jpeg";
file.OwnerModuleId = "main";
file.Description = "Мое изображение";
using (FileStream data = new FileStream(BXPath.MapPath("~/myimage.jpg"), FileMode.Open))
{
    file.SetFile(data, "images");
    BXSecureIO.DemandWrite(file.FileVirtualPath);
    file.Save();
}

BXIBlockElement element = new BXIBlockElement(1, "Моя картинка");
element.DetailImageId = file.Id;
element.Save();

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство ModuleId

Свойство BXFile..::.ModuleId
Класс BXFile Смотри также Send Feedback
Имя модуля. Возвращает "Main".

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string ModuleId { get; }

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство OwnerModuleId

Свойство BXFile..::.OwnerModuleId
Класс BXFile Пример Смотри также Send Feedback
Идентификатор модуля, которому принадлежит файл.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string OwnerModuleId { get; set; }

Примеры

Создание и сохранение новой сущности файла:

CopyC#
BXFile file = new BXFile();
file.FileNameOriginal = "myimage.jpg";
file.ContentType = "image/jpeg";
file.OwnerModuleId = "main";
file.Description = "Мое изображение";
using (FileStream data = new FileStream(MapPath("~/myimage.jpg"), FileMode.Open))
{
    file.SetFile(data, "images");
    BXSecureIO.DemandWrite(file.FileVirtualPath);
    file.Save();
}

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство UpdateDate

Свойство BXFile..::.UpdateDate
Класс BXFile Смотри также Send Feedback
Дата последнего обновления файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public DateTime UpdateDate { get; }

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Свойство Width

Свойство BXFile..::.Width
Класс BXFile Пример Смотри также Send Feedback
Ширина изображения в пикселах. Для фалов с MIME-типом 'image/*'.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Width { get; set; }

Примеры

Отрисовка картинки из сущности файла в шаблоне компонента или aspx-странице:

CopyC#
<img
    class="preview_picture"
    border="0"
    src="<%= image.FilePath %>"
    width="<%= image.Width %>"
    height="<%= image.Height %>"
    alt="<%= image.Description %>"
    style="float:left"
/>

Смотри также

Класс BXFile
Пространство имен Bitrix.IO


Класс BXFile.Scheme

Класс BXFile..::..Scheme
Класс BXFile Члены Смотри также Send Feedback
Схема сущности файла

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class Scheme : BXScheme<BXFile..::..Scheme>

Иерархия наследования

System..::..Object
BXSchemeBase
BXScheme<(Of <(<'BXFile..::..Scheme>)>)>
Bitrix.IO..::..BXFile..::..Scheme

Смотри также

Члены BXFile..::..Scheme
Пространство имен Bitrix.IO


Члены BXFile.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXFile..::..Scheme
Класс BXFile..::..Scheme Конструкторы Свойства Смотри также Send Feedback

Класс, который предоставляет возможность работать с файлами как с сущностями

Тип BXFile..::..Scheme предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXFile..::..Scheme |

Свойства

Имя | Описание
ContentType | MIME-тип файла
Description | Описание файла.
FileName | Текущее имя файла.
FileNameOriginal | Исходное имя файла.
FileSize | Размер файла.
Folder | Папка, в которой сейчас расположен файл.
Height | Высота картинки, для файлов с MIME-типом 'image/*'
Id | Уникальный идентификатор файла. Первичный ключ.
OwnerModuleId | Идентификатор, модуля, к которому принадлежит файл
UpdateDate | Дата последнего обновления файла.
Width | Ширина картинки, для файлов с MIME-типом 'image/*'

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Конструктор BXFile.Scheme

Конструктор BXFile..::..Scheme
Класс BXFile..::..Scheme Смотри также Send Feedback

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Scheme()

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Свойства BXFile.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXFile..::..Scheme
Класс BXFile..::..Scheme Смотри также Send Feedback

Тип BXFile..::..Scheme предоставляет следующие возможности.

Свойства

Имя | Описание
ContentType | MIME-тип файла
Description | Описание файла.
FileName | Текущее имя файла.
FileNameOriginal | Исходное имя файла.
FileSize | Размер файла.
Folder | Папка, в которой сейчас расположен файл.
Height | Высота картинки, для файлов с MIME-типом 'image/*'
Id | Уникальный идентификатор файла. Первичный ключ.
OwnerModuleId | Идентификатор, модуля, к которому принадлежит файл
UpdateDate | Дата последнего обновления файла.
Width | Ширина картинки, для файлов с MIME-типом 'image/*'

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Свойство ContentType

Свойство BXFile..::..Scheme..::.ContentType
Класс BXFile..::..Scheme Смотри также Send Feedback
MIME-тип файла

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ContentType { get; }

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Свойство Description

Свойство BXFile..::..Scheme..::.Description
Класс BXFile..::..Scheme Смотри также Send Feedback
Описание файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Description { get; }

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Свойство FileName

Свойство BXFile..::..Scheme..::.FileName
Класс BXFile..::..Scheme Смотри также Send Feedback
Текущее имя файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase FileName { get; }

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Свойство FileNameOriginal

Свойство BXFile..::..Scheme..::.FileNameOriginal
Класс BXFile..::..Scheme Смотри также Send Feedback
Исходное имя файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase FileNameOriginal { get; }

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Свойство FileSize

Свойство BXFile..::..Scheme..::.FileSize
Класс BXFile..::..Scheme Смотри также Send Feedback
Размер файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase FileSize { get; }

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Свойство Folder

Свойство BXFile..::..Scheme..::.Folder
Класс BXFile..::..Scheme Смотри также Send Feedback
Папка, в которой сейчас расположен файл.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Folder { get; }

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Свойство Height

Свойство BXFile..::..Scheme..::.Height
Класс BXFile..::..Scheme Смотри также Send Feedback
Высота картинки, для файлов с MIME-типом 'image/*'

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Height { get; }

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Свойство Id

Свойство BXFile..::..Scheme..::.Id
Класс BXFile..::..Scheme Смотри также Send Feedback
Уникальный идентификатор файла. Первичный ключ.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Id { get; }

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Свойство OwnerModuleId

Свойство BXFile..::..Scheme..::.OwnerModuleId
Класс BXFile..::..Scheme Смотри также Send Feedback
Идентификатор, модуля, к которому принадлежит файл

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase OwnerModuleId { get; }

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Свойство UpdateDate

Свойство BXFile..::..Scheme..::.UpdateDate
Класс BXFile..::..Scheme Смотри также Send Feedback
Дата последнего обновления файла.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase UpdateDate { get; }

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Свойство Width

Свойство BXFile..::..Scheme..::.Width
Класс BXFile..::..Scheme Смотри также Send Feedback
Ширина картинки, для файлов с MIME-типом 'image/*'

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Width { get; }

Смотри также

Класс BXFile..::..Scheme
Пространство имен Bitrix.IO


Класс BXFileCollection

Класс BXFileCollection
Члены Пример Смотри также Send Feedback
Класс коллекции для сущности BXFile

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXFileCollection : BXEntityCollection<BXFile, BXFileCollection, BXFile..::..Scheme>

Примеры

Коллекция сущностей информационного блока:

CopyC#
public class BXIBlockCollection : BXEntityCollection<BXIBlock, BXIBlockCollection, BXIBlock.Scheme>
{
    public BXIBlockCollection()
    {
    }
}

где:

  • BXIBlock - сущность информационного блок,

  • BXIBlockCollection - коллекция сущностей информационных блоков,

  • BXIBlock.Scheme - схема сущности информационного блока.

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<' BXFile >)>)>
Bitrix.DataLayer..::..BXEntityCollection <(Of <(<' BXFile, BXFileCollection, BXFile..::..Scheme >)>)>
Bitrix.IO..::..BXFileCollection

Смотри также

Члены BXFileCollection
Пространство имен Bitrix.IO


Члены BXFileCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXFileCollection
Класс BXFileCollection Конструкторы Методы Смотри также Send Feedback

Тип BXFileCollection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXFileCollection |

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Смотри также

Класс BXFileCollection
Пространство имен Bitrix.IO


Конструктор BXFileCollection

Конструктор BXFileCollection
Класс BXFileCollection Смотри также Send Feedback

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFileCollection()

Смотри также

Класс BXFileCollection
Пространство имен Bitrix.IO


Методы BXFileCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXFileCollection
Класс BXFileCollection Смотри также Send Feedback

Тип BXFileCollection предоставляет следующие возможности.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Смотри также

Класс BXFileCollection
Пространство имен Bitrix.IO


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFileCollection..::.Save
Класс BXFileCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет все сущности коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет все сущности коллекции, используя указанное соединение. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXFileCollection
Члены BXFileCollection
Пространство имен Bitrix.IO


Метод ToDataTable

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXFileCollection..::.ToDataTable
Класс BXFileCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ToDataTable()()()() | Приводит коллекцию к типу DataTable. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable(BXPagingOptions) | Приводит коллекцию к типу DataTable с применением опций постраничной навигации. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXFileCollection
Члены BXFileCollection
Пространство имен Bitrix.IO


Класс BXFileInfo

Класс BXFileInfo
Члены Смотри также Send Feedback
Предоставляет методы для получения информации о файлах.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public sealed class BXFileInfo

Иерархия наследования

System..::..Object
Bitrix.IO..::..BXFileInfo

Смотри также

Члены BXFileInfo
Пространство имен Bitrix.IO


Члены BXFileInfo

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXFileInfo
Класс BXFileInfo Конструкторы Методы Смотри также Send Feedback

Тип BXFileInfo предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXFileInfo |

Методы

Имя | Описание
GetFileTimestamp | Возвращает количество тиков, соответствующее дате последнего изменения файла
GetFileType | Возвращает набор флагов, описывающий тип файла
GetImageExtensions | Возвращает список возможных расширений файлов с изображениями.
TryGetImageMimeType |

Смотри также

Класс BXFileInfo
Пространство имен Bitrix.IO


Конструктор BXFileInfo

Конструктор BXFileInfo
Класс BXFileInfo Смотри также Send Feedback

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXFileInfo()

Смотри также

Класс BXFileInfo
Пространство имен Bitrix.IO


Методы BXFileInfo

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXFileInfo
Класс BXFileInfo Смотри также Send Feedback

Тип BXFileInfo предоставляет следующие возможности.

Методы

Имя | Описание
GetFileTimestamp | Возвращает количество тиков, соответствующее дате последнего изменения файла
GetFileType | Возвращает набор флагов, описывающий тип файла
GetImageExtensions | Возвращает список возможных расширений файлов с изображениями.
TryGetImageMimeType |

Смотри также

Класс BXFileInfo
Пространство имен Bitrix.IO


Метод GetFileTimestamp

Метод BXFileInfo..::.GetFileTimestamp
Класс BXFileInfo Пример Смотри также Send Feedback
Возвращает количество тиков, соответствующее дате последнего изменения файла

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static long GetFileTimestamp(
    string filePath
)

Параметры

filePath
Type: System..::..String
Путь к файлу (физический или виртуальный)

Возвращаемое значение

Количество тиков, соответствующее дате последнего изменения файла

Примеры

Метод для добавления ссылки на js-файл в страницу:

CopyC#
void RegisterVersionedScript(string virtualPath)
{
    ScriptManager.RegisterClientScriptInclude(
        Page,
        Page.GetType(),
        virtualPath,
        VirtualPathUtility.ToAbsolute(virtualPath) + "?v=" + BXFileInfo.GetFileTimestamp(virtualPath)
    );
}

Смотри также

Класс BXFileInfo
Пространство имен Bitrix.IO


Метод GetFileType

Метод BXFileInfo..::.GetFileType
Класс BXFileInfo Пример Смотри также Send Feedback
Возвращает набор флагов, описывающий тип файла

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXFileType GetFileType(
    string filePath
)

Параметры

filePath
Type: System..::..String
Путь к файлу (физический или виртуальный)

Возвращаемое значение

Набор флагов BXFileType, описывающий тип файла

Примеры

Открытие страницы редактирования файла:

CopyC#
BXFileType type = BXFileInfo.GetFileType(path);
if ((type & BXFileType.Menu) != BXFileType.Unknown)
    Response.Redirect(VirtualPathUtility.ToAbsolute("~/bitrix/admin/MenuEdit.aspx") + "?path=" + HttpUtility.UrlEncode(path));
else if ((type & (BXFileType.Text | BXFileType.Page)) != BXFileType.Unknown)
    Response.Redirect(VirtualPathUtility.ToAbsolute("~/bitrix/admin/FileManEdit.aspx") + "?path=" + HttpUtility.UrlEncode(path));

Смотри также

Класс BXFileInfo
Пространство имен Bitrix.IO


Метод GetImageExtensions

Метод BXFileInfo..::.GetImageExtensions
Класс BXFileInfo Пример Смотри также Send Feedback
Возвращает список возможных расширений файлов с изображениями.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static ReadOnlyCollection<string> GetImageExtensions()

Возвращаемое значение

Коллекцию строк, доступную только для чтения.

Заметки

Расширения заданы в нижнем регистре и не содержат '.' в начале.

Примеры

Проверка, является ли файл изображением:

CopyC#
bool IsImage(string physicalPath)
{
    string ext = Path.GetExtension(physicalPath);
    if (string.IsNullOrEmpty(ext))
        return false;
    return BXFileInfo.GetImageExtensions().Contains(ext.TrimStart('.').ToLowerInvariant());
}

Смотри также

Класс BXFileInfo
Пространство имен Bitrix.IO


Метод TryGetImageMimeType

Метод BXFileInfo..::.TryGetImageMimeType
Класс BXFileInfo Смотри также Send Feedback

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static bool TryGetImageMimeType(
    string filename,
    out string mimeType
)

Параметры

filename
Type: System..::..String
mimeType
Type: System..::..String %

Смотри также

Класс BXFileInfo
Пространство имен Bitrix.IO


Перечисление BXFileType

Перечисление BXFileType
Смотри также Send Feedback
Перечисление, содержащее различные типы файлов.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
[FlagsAttribute]
public enum BXFileType

Члены

Название члена | Описание
Unknown | Неизвестный тип файла.
Executable | Файл, содержимое которого может каким-нибудь образом повлиять на исполнение кода в продукте. К таким файлам относятся компилируемые файлы, файлы библиотек, настроечные файлы продукта.
Image | Файл изображения.
Page | Файл страницы, которая может быть открыта пользователем, например html или aspx.
Menu | Файл меню.
Config | Файл настроек.
Text | Текстовый файл, содержимое которого не интерпретируется сервером особым способом. Например, txt, css, js.
AspxPage | Файл страницы, обрабатываемый сервером, которая может быть открыта пользователем, например aspx.
Archive | Архивный файл.
Template | Шаблонный файл ASP.NET, например aspx, ascx или master.
ServerText | Текстовый файл, содержимое которого интерпретируется сервером особым способом, например, компилируется Пример: cs, ashx, aspx.
ExcludedFromExecutable | Файл, являющийся исключением из исполняемых
TextFormat | Файл, представленный в текстовом формате, например, html, menu, config, js, css, aspx, master.

Смотри также

Пространство имен Bitrix.IO


Перечисление BXFileValidationResult

Перечисление BXFileValidationResult
Смотри также Send Feedback
Результат проверки соответствия файла заданным условиям.

Пространство имен: Bitrix.IO
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
[FlagsAttribute]
public enum BXFileValidationResult

Члены

Название члена | Описание
Valid | Файл соответствует заданным условиям
InvalidExtension | Файл имеет неверное расширение
InvalidSize | Файл имеет неверный размер
InvalidContentType | Файл имеет неверный MIME-тип
InvalidHeight | Изображение имеет неверную высоту
InvalidWidth | Изображение иеет неверную ширину
InvalidImage | Файл не является изображением

Заметки

Возвращается в результате вызова методов BXFile.Validate и BXFile.ValidateAsImage

Смотри также

Пространство имен Bitrix.IO
BXFile..::..Validate(array<String>[]()[][], Int32, array<String>[]()[][])
BXFile..::..ValidateAsImage(Int32, Int32, Int32)


Пространство имен Bitrix.Services

Пространство имен Bitrix.Services
Send Feedback
Содержит классы, реализующие различные служебные механизмы.

Классы

Класс | Описание
BXLoc | Класс для работы с системой локализации.
BXScheduler | Класс, управляющий исполнением агентов
BXSchedulerAgent | Сущность агента
BXSchedulerAgent..::..Scheme | Схема сущности "агент"
BXSchedulerAgentCollection | Коллекция агентов планировщика.
BXSefUrlManager | Предоставляет доступ к состоянию системы обработки адресов и ЧПУ
BXSefUrlRule | Класс правила обработки адреса запроса.
BXSefUrlRuleCollection | Хранит правила обработки адресов с учетом порядка.
BXSefUrlRuleManager | Обеспечивает доступ к правилам обработки адресов (см. BXSefUrlRule).

Интерфейсы

Интерфейс | Описание
IBXAgentExecutor | Интерфейс исполнителя агента. Содержит код, подлежащий исполнению при запуске агента.


Класс BXLoc

Класс BXLoc
Члены Смотри также Send Feedback
Класс для работы с системой локализации.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXLoc

Иерархия наследования

System..::..Object
Bitrix.Services..::..BXLoc

Смотри также

Члены BXLoc
Пространство имен Bitrix.Services


Члены BXLoc

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXLoc
Класс BXLoc Методы Свойства Смотри также Send Feedback

Тип BXLoc предоставляет следующие возможности.

Методы

Имя | Описание
GetMessage | Перегруженный.
GetModuleMessage | Перегруженный.
ResetCultureCache | Сбрасывает кешированное состояние культуры

Свойства

Имя | Описание
CurrentCulture | Возвращает языковую культуру для текущего языка
CurrentLocale | Возвращает или устанавливает идентификатор языка локализации в текущем контексте
DefaultLocale | Язык по умолчанию.
IsDebugMode | Возвращает, происходит ли возврат языковых фраз в отладочном режиме.
Locales | Список всех языков, зарегистрированных в системе.

Смотри также

Класс BXLoc
Пространство имен Bitrix.Services


Методы BXLoc

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXLoc
Класс BXLoc Смотри также Send Feedback

Тип BXLoc предоставляет следующие возможности.

Методы

Имя | Описание
GetMessage | Перегруженный.
GetModuleMessage | Перегруженный.
ResetCultureCache | Сбрасывает кешированное состояние культуры

Смотри также

Класс BXLoc
Пространство имен Bitrix.Services


Метод GetMessage

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXLoc..::.GetMessage
Класс BXLoc Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetMessage(String, String) | Возвращает ресурс, соответствующий данному виртуальному пути
GetMessage(TemplateControl, String) | Возвращает ресурс, специфичный для шаблонного элемента управления
GetMessage(String, String, Boolean) | Возвращает ресурс, соответствующий данному виртуальному пути
GetMessage(String, String, String) | Возвращает ресурс, соответствующий данному виртуальному пути
GetMessage(TemplateControl, String, Boolean) | Возвращает ресурс, специфичный для шаблонного элемента управления
GetMessage(String, String, String, Boolean) | Возвращает ресурс, соответствующий данному виртуальному пути
GetMessage(String, TemplateControl, String, Boolean) | Возвращает ресурс, специфичный для шаблонного элемента управления

Смотри также

Класс BXLoc
Члены BXLoc
Пространство имен Bitrix.Services


Метод GetMessage (String, String)

Метод BXLoc..::.GetMessage (String, String)
Класс BXLoc Смотри также Send Feedback
Возвращает ресурс, соответствующий данному виртуальному пути

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetMessage(
    string virtualPath,
    string id
)

Параметры

virtualPath
Type: System..::..String
Виртуальный путь
id
Type: System..::..String
Имя ресурса

Возвращаемое значение

Фраза, соответствующая имени ресурса и текущему языку

Смотри также

Класс BXLoc
Перегрузка GetMessage
Пространство имен Bitrix.Services


Метод GetMessage (TemplateControl, String)

Метод BXLoc..::.GetMessage (TemplateControl, String)
Класс BXLoc Смотри также Send Feedback
Возвращает ресурс, специфичный для шаблонного элемента управления

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetMessage(
    TemplateControl control,
    string id
)

Параметры

control
Type: System.Web.UI..::..TemplateControl
Элемент управления (страница, пользовательский элемент управления, компонент, ...)
id
Type: System..::..String
Имя ресурса

Возвращаемое значение

Фраза, соответствующая имени ресурса и текущему языку

Смотри также

Класс BXLoc
Перегрузка GetMessage
Пространство имен Bitrix.Services


Метод GetMessage (String, String, Boolean)

Метод BXLoc..::.GetMessage (String, String, Boolean)
Класс BXLoc Смотри также Send Feedback
Возвращает ресурс, соответствующий данному виртуальному пути

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetMessage(
    string virtualPath,
    string id,
    bool nullIfNotFound
)

Параметры

virtualPath
Type: System..::..String
Виртуальный путь
id
Type: System..::..String
Имя ресурса
nullIfNotFound
Type: System..::..Boolean
Возвращать null, если ресурс не найден (в противном случае возвращается строка вида <##lang.resourceId##>)

Возвращаемое значение

Фраза, соответствующая имени ресурса и текущему языку

Смотри также

Класс BXLoc
Перегрузка GetMessage
Пространство имен Bitrix.Services


Метод GetMessage (String, String, String)

Метод BXLoc..::.GetMessage (String, String, String)
Класс BXLoc Смотри также Send Feedback
Возвращает ресурс, соответствующий данному виртуальному пути

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetMessage(
    string locale,
    string virtualPath,
    string id
)

Параметры

locale
Type: System..::..String
Языковой идентификатор
virtualPath
Type: System..::..String
Виртуальный путь
id
Type: System..::..String
Имя ресурса

Возвращаемое значение

Фраза, соответствующая имени ресурса и языковому идентификатору

Смотри также

Класс BXLoc
Перегрузка GetMessage
Пространство имен Bitrix.Services


Метод GetMessage (TemplateControl, String, Boolean)

Метод BXLoc..::.GetMessage (TemplateControl, String, Boolean)
Класс BXLoc Смотри также Send Feedback
Возвращает ресурс, специфичный для шаблонного элемента управления

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetMessage(
    TemplateControl control,
    string id,
    bool nullIfNotFound
)

Параметры

control
Type: System.Web.UI..::..TemplateControl
Элемент управления (страница, пользовательский элемент управления, компонент, ...)
id
Type: System..::..String
Имя ресурса
nullIfNotFound
Type: System..::..Boolean
Возвращать null, если ресурс не найден (в противном случае возвращается строка вида <##lang.resourceId##>)

Возвращаемое значение

Фраза, соответствующая имени ресурса и текущему языку

Смотри также

Класс BXLoc
Перегрузка GetMessage
Пространство имен Bitrix.Services


Метод GetMessage (String, String, String, Boolean)

Метод BXLoc..::.GetMessage (String, String, String, Boolean)
Класс BXLoc Смотри также Send Feedback
Возвращает ресурс, соответствующий данному виртуальному пути

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetMessage(
    string locale,
    string virtualPath,
    string id,
    bool nullIfNotFound
)

Параметры

locale
Type: System..::..String
Языковой идентификатор
virtualPath
Type: System..::..String
Виртуальный путь
id
Type: System..::..String
Имя ресурса
nullIfNotFound
Type: System..::..Boolean
Возвращать null, если ресурс не найден (в противном случае возвращается строка вида <##lang.resourceId##>)

Возвращаемое значение

Фраза, соответствующая имени ресурса и языковому идентификатору

Смотри также

Класс BXLoc
Перегрузка GetMessage
Пространство имен Bitrix.Services


Метод GetMessage (String, TemplateControl, String, Boolean)

Метод BXLoc..::.GetMessage (String, TemplateControl, String, Boolean)
Класс BXLoc Смотри также Send Feedback
Возвращает ресурс, специфичный для шаблонного элемента управления

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetMessage(
    string locale,
    TemplateControl control,
    string id,
    bool nullIfNotFound
)

Параметры

locale
Type: System..::..String
Языковой идентификатор
control
Type: System.Web.UI..::..TemplateControl
Элемент управления (страница, пользовательский элемент управления, компонент, ...)
id
Type: System..::..String
Имя ресурса
nullIfNotFound
Type: System..::..Boolean
Возвращать null, если ресурс не найден (в противном случае возвращается строка вида <##lang.resourceId##>)

Возвращаемое значение

Фраза, соответствующая имени ресурса и языковому идентификатору

Смотри также

Класс BXLoc
Перегрузка GetMessage
Пространство имен Bitrix.Services


Метод GetModuleMessage

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXLoc..::.GetModuleMessage
Класс BXLoc Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetModuleMessage(String, String) | Возвращает ресурс специфичный для модуля
GetModuleMessage(String, String, Boolean) | Возвращает ресурс специфичный для модуля
GetModuleMessage(String, String, String) | Возвращает ресурс специфичный для модуля
GetModuleMessage(String, String, String, Boolean) | Возвращает ресурс специфичный для модуля

Смотри также

Класс BXLoc
Члены BXLoc
Пространство имен Bitrix.Services


Метод GetModuleMessage (String, String)

Метод BXLoc..::.GetModuleMessage (String, String)
Класс BXLoc Смотри также Send Feedback
Возвращает ресурс специфичный для модуля

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetModuleMessage(
    string moduleId,
    string id
)

Параметры

moduleId
Type: System..::..String
Имя модуля
id
Type: System..::..String
Имя ресурса

Возвращаемое значение

Фраза, соответствующая имени ресурса и текущему языку

Смотри также

Класс BXLoc
Перегрузка GetModuleMessage
Пространство имен Bitrix.Services


Метод GetModuleMessage (String, String, Boolean)

Метод BXLoc..::.GetModuleMessage (String, String, Boolean)
Класс BXLoc Смотри также Send Feedback
Возвращает ресурс специфичный для модуля

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetModuleMessage(
    string moduleId,
    string id,
    bool nullIfNotFound
)

Параметры

moduleId
Type: System..::..String
Имя модуля
id
Type: System..::..String
Имя ресурса
nullIfNotFound
Type: System..::..Boolean
Возвращать null, если ресурс не найден (в противном случае возвращается строка вида <##lang.resourceId##>)

Возвращаемое значение

Фраза, соответствующая имени ресурса и текущему языку

Смотри также

Класс BXLoc
Перегрузка GetModuleMessage
Пространство имен Bitrix.Services


Метод GetModuleMessage (String, String, String)

Метод BXLoc..::.GetModuleMessage (String, String, String)
Класс BXLoc Смотри также Send Feedback
Возвращает ресурс специфичный для модуля

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetModuleMessage(
    string locale,
    string moduleId,
    string id
)

Параметры

locale
Type: System..::..String
Языковой идентификатор
moduleId
Type: System..::..String
Имя модуля
id
Type: System..::..String
Имя ресурса

Возвращаемое значение

Фраза, соответствующая имени ресурса и языковому идентификатору

Смотри также

Класс BXLoc
Перегрузка GetModuleMessage
Пространство имен Bitrix.Services


Метод GetModuleMessage (String, String, String, Boolean)

Метод BXLoc..::.GetModuleMessage (String, String, String, Boolean)
Класс BXLoc Смотри также Send Feedback
Возвращает ресурс специфичный для модуля

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GetModuleMessage(
    string locale,
    string moduleId,
    string id,
    bool nullIfNotFound
)

Параметры

locale
Type: System..::..String
Языковой идентификатор
moduleId
Type: System..::..String
Имя модуля
id
Type: System..::..String
Имя ресурса
nullIfNotFound
Type: System..::..Boolean
Возвращать null, если ресурс не найден (в противном случае возвращается строка вида <##lang.resourceId##>)

Возвращаемое значение

Фраза, соответствующая имени ресурса и языковому идентификатору

Смотри также

Класс BXLoc
Перегрузка GetModuleMessage
Пространство имен Bitrix.Services


Метод ResetCultureCache

Метод BXLoc..::.ResetCultureCache
Класс BXLoc Смотри также Send Feedback
Сбрасывает кешированное состояние культуры

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void ResetCultureCache()

Смотри также

Класс BXLoc
Пространство имен Bitrix.Services


Свойства BXLoc

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXLoc
Класс BXLoc Смотри также Send Feedback

Тип BXLoc предоставляет следующие возможности.

Свойства

Имя | Описание
CurrentCulture | Возвращает языковую культуру для текущего языка
CurrentLocale | Возвращает или устанавливает идентификатор языка локализации в текущем контексте
DefaultLocale | Язык по умолчанию.
IsDebugMode | Возвращает, происходит ли возврат языковых фраз в отладочном режиме.
Locales | Список всех языков, зарегистрированных в системе.

Смотри также

Класс BXLoc
Пространство имен Bitrix.Services


Свойство CurrentCulture

Свойство BXLoc..::.CurrentCulture
Класс BXLoc Смотри также Send Feedback
Возвращает языковую культуру для текущего языка

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static CultureInfo CurrentCulture { get; }

Смотри также

Класс BXLoc
Пространство имен Bitrix.Services


Свойство CurrentLocale

Свойство BXLoc..::.CurrentLocale
Класс BXLoc Смотри также Send Feedback
Возвращает или устанавливает идентификатор языка локализации в текущем контексте

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string CurrentLocale { get; set; }

Смотри также

Класс BXLoc
Пространство имен Bitrix.Services


Свойство DefaultLocale

Свойство BXLoc..::.DefaultLocale
Класс BXLoc Смотри также Send Feedback
Язык по умолчанию.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string DefaultLocale { get; }

Смотри также

Класс BXLoc
Пространство имен Bitrix.Services


Свойство IsDebugMode

Свойство BXLoc..::.IsDebugMode
Класс BXLoc Смотри также Send Feedback
Возвращает, происходит ли возврат языковых фраз в отладочном режиме.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool IsDebugMode { get; }

Смотри также

Класс BXLoc
Пространство имен Bitrix.Services


Свойство Locales

Свойство BXLoc..::.Locales
Класс BXLoc Смотри также Send Feedback
Список всех языков, зарегистрированных в системе.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static ReadOnlyCollection<string> Locales { get; }

Поле значения

Все локали

Смотри также

Класс BXLoc
Пространство имен Bitrix.Services


Класс BXScheduler

Класс BXScheduler
Члены Смотри также Send Feedback
Класс, управляющий исполнением агентов

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public sealed class BXScheduler

Иерархия наследования

System..::..Object
Bitrix.Services..::..BXScheduler

Смотри также

Члены BXScheduler
Пространство имен Bitrix.Services


Члены BXScheduler

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXScheduler
Класс BXScheduler Методы Свойства Смотри также Send Feedback

Тип BXScheduler предоставляет следующие возможности.

Методы

Имя | Описание
Check | Вынуждает начать процесс обработки агентов
Start | Запускает планировщик
Stop | Останавливает планировщик

Свойства

Имя | Описание
IsActive | Возвращает состояние планировщика

Смотри также

Класс BXScheduler
Пространство имен Bitrix.Services


Методы BXScheduler

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXScheduler
Класс BXScheduler Смотри также Send Feedback

Тип BXScheduler предоставляет следующие возможности.

Методы

Имя | Описание
Check | Вынуждает начать процесс обработки агентов
Start | Запускает планировщик
Stop | Останавливает планировщик

Смотри также

Класс BXScheduler
Пространство имен Bitrix.Services


Метод Check

Метод BXScheduler..::.Check
Класс BXScheduler Смотри также Send Feedback
Вынуждает начать процесс обработки агентов

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void Check()

Смотри также

Класс BXScheduler
Пространство имен Bitrix.Services


Метод Start

Метод BXScheduler..::.Start
Класс BXScheduler Смотри также Send Feedback
Запускает планировщик

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void Start()

Смотри также

Класс BXScheduler
Пространство имен Bitrix.Services


Метод Stop

Метод BXScheduler..::.Stop
Класс BXScheduler Смотри также Send Feedback
Останавливает планировщик

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void Stop()

Смотри также

Класс BXScheduler
Пространство имен Bitrix.Services


Свойства BXScheduler

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXScheduler
Класс BXScheduler Смотри также Send Feedback

Тип BXScheduler предоставляет следующие возможности.

Свойства

Имя | Описание
IsActive | Возвращает состояние планировщика

Смотри также

Класс BXScheduler
Пространство имен Bitrix.Services


Свойство IsActive

Свойство BXScheduler..::.IsActive
Класс BXScheduler Смотри также Send Feedback
Возвращает состояние планировщика

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static bool IsActive { get; }

Поле значения

true - если планировщик запущен, иначе - false

Смотри также

Класс BXScheduler
Пространство имен Bitrix.Services


Класс BXSchedulerAgent

Класс BXSchedulerAgent
Члены Смотри также Send Feedback
Сущность агента

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXSchedulerAgent : BXEntity<BXSchedulerAgent, BXSchedulerAgentCollection, BXSchedulerAgent..::..Scheme>

Иерархия наследования

System..::..Object
Bitrix.DataLayer..::..BXEntity
Bitrix.DataLayer..::..BXEntity <(Of <(<'BXSchedulerAgent, BXSchedulerAgentCollection, BXSchedulerAgent..::..Scheme >)>)>
Bitrix.Services..::..BXSchedulerAgent

Смотри также

Члены BXSchedulerAgent
Пространство имен Bitrix.Services


Члены BXSchedulerAgent

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXSchedulerAgent
Класс BXSchedulerAgent Конструкторы Методы Поля Свойства Смотри также Send Feedback

Тип BXSchedulerAgent предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXSchedulerAgent | Перегруженный.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Execute | Находит сопоставленного агенту исполнителя и запускает его
GenerateGuidName | Генерирует уникальное имя для агента на основе GUID
GetByIdInternal | Перегруженный.
GetByName | Находит агента по его имени
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetClassNameAndAssembly | Устанавливает имя класса исполнителя и имя сборки по типу
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
VerifyEntry | Проверяет корректность сущности перед сохранением. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Свойства

Имя | Описание
Active | Активен ли агент
Assembly | Имя сборки, в которой расположен исполнитель агента
ClassName | Имя класса исполнителя агента
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Унаследовано от BXEntity)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityId | Возвращает код сущности. Должен быть переопределен в конкретной сущности. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..EntityId)
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
Id | Идентификатор агента. Первичный ключ
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
LastUpdated | Дата последнего обновления агента
ModuleId | Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..ModuleId)
Name | Уникальный символьный идентификатор агента
Parameters | Список параметров агента
Period | Период запуска агента
Periodic | Является ли агент периодическим
StartTime | Время следующего запуска агента
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Конструктор BXSchedulerAgent

[image]

1С-Битрикс: Управление сайтом ASP.NET
Конструктор BXSchedulerAgent
Класс BXSchedulerAgent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
BXSchedulerAgent()()()() | Конструктор класса.
BXSchedulerAgent(String) | Конструктор класса. Создает агента с заданным именем.

Смотри также

Класс BXSchedulerAgent
Члены BXSchedulerAgent
Пространство имен Bitrix.Services


Конструктор BXSchedulerAgent

Конструктор BXSchedulerAgent
Класс BXSchedulerAgent Смотри также Send Feedback
Конструктор класса.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchedulerAgent()

Смотри также

Класс BXSchedulerAgent
Перегрузка BXSchedulerAgent
Пространство имен Bitrix.Services


Конструктор BXSchedulerAgent (String)

Конструктор BXSchedulerAgent (String)
Класс BXSchedulerAgent Смотри также Send Feedback
Конструктор класса. Создает агента с заданным именем.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchedulerAgent(
    string name
)

Параметры

name
Type: System..::..String
Символьное имя агента

Исключения

Исключение | Условие
System..::..ArgumentNullException | Происходит если name равен null

Смотри также

Класс BXSchedulerAgent
Перегрузка BXSchedulerAgent
Пространство имен Bitrix.Services


Поля BXSchedulerAgent

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXSchedulerAgent
Класс BXSchedulerAgent Смотри также Send Feedback

Тип BXSchedulerAgent предоставляет следующие возможности.

Поля

Имя | Описание
_isDirty | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_map | Список отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
_valueMap | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
isNew | Содержит true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае содержит false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
values | Содержит словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Методы BXSchedulerAgent

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXSchedulerAgent
Класс BXSchedulerAgent Смотри также Send Feedback

Тип BXSchedulerAgent предоставляет следующие возможности.

Методы

Имя | Описание
CountInternal | Внутренний метод выборки типа Count, который вызывается статическими методами выборки типа Count. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create | Перегруженный.
CreateAdditionalEntities | Этот метод вызывается после добавления новой сущности в базу данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CreateAfterSuccess | Этот метод вызывается после добавления новой сущности в базу данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete | Перегруженный.
DeleteAdditionalEntities | Этот метод вызывается перед удалением сущности из базы данных непосредственно после открытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteAfterSuccess | Этот метод вызывается после удаления сущности из базы данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteEntityLinks | Удаление сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal | Перегруженный.
DoCreate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoDelete | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DoUpdate | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Execute | Находит сопоставленного агенту исполнителя и запускает его
GenerateGuidName | Генерирует уникальное имя для агента на основе GUID
GetByIdInternal | Перегруженный.
GetByName | Находит агента по его имени
GetCustomFieldsKeyInternal | Возвращает ключ для набираемых свойств сущности. Этот метод используется статическим методом GetCustomFieldsKey()()()(). Должен быть переопределен в конкретной сущности, если сущность поддерживает набираемые свойства. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetDateTime | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity | Перегруженный.
GetJoinedEntityCollection | Перегруженный.
GetLinkedValue<(Of <<'(T>)>>) | Возвращает коллекцию типа T значений из таблицы-связки, связанных с данной сущностью. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetLinkedValueCollection<(Of <<'(JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal | Перегруженный.
GetValue<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOfEnumOrDefault<(Of <<'(T>)>>) | Возвращает значение перечисления поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValueOrDefault<(Of <<'(T>)>>) | Возвращает значение поля сущности, приводя его к типу, если оно найдено или определённое пользователем значение по умолчанию T. Значение не модифицировано кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromReader | Инициализирует сущность на основании объекта BXSqlDataReader. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
InitializeFromSequentialReader | Инициализирует сущность на основании объекта BXSqlDataReader. Осуществляет чтение из BXSqlDataReader в режиме 'CommandBehavior.SequentialAccess' (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
OnInit | Вызывается после инициализации полей сущности значениями из БД (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareFromForGetList | Подготавливает часть FROM запроса для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareParametersForGetList | Подготавливает список параметров для выборки. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
PrepareSelectForGetList | Подготавливает список полей типа BXSelect для выборки: если список полей пуст, то он заполняется списком всех полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save | Перегруженный.
SaveCustomProperties | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SaveEntityLinks | Сохранение сущностей-связок (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnActionCommand | Отправляет команду On перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnAfterActionCommand | Отправляет команду OnAfter после изменения сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SendOnBeforeActionCommand | Отправляет команду OnBefore перед изменением сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetClassNameAndAssembly | Устанавливает имя класса исполнителя и имя сборки по типу
SetReadOnly | Переводит сущность в состояние только для чтения. Изменить представление сущности в базе становится невозможным. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue | Перегруженный.
SetXmlValue | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveMultipleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить множественную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TryResolveSingleJoin<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>) | Разрешить одинарную связь (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetFields | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
TrySetValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update | Перегруженный.
UpdateAdditionalEntities | Этот метод вызывается после изменения существующей сущности в базе данных непосредственно перед закрытием транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
UpdateAfterSuccess | Этот метод вызывается после изменения существующей сущности в базе данных и после успешного закрытия транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
VerifyEntry | Проверяет корректность сущности перед сохранением. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Метод Create

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSchedulerAgent..::.Create
Класс BXSchedulerAgent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Create()()()() | Добавляет новую сущность в базу данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Create(BXSqlConnection, BXSqlTransaction) | Заполняет автоматические поля, создает сущность в БД и запускает проверку в планировщике (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..Create(BXSqlConnection, BXSqlTransaction))

Смотри также

Класс BXSchedulerAgent
Члены BXSchedulerAgent
Пространство имен Bitrix.Services


Метод Create (, )

Метод BXSchedulerAgent..::.Create (, )
Класс BXSchedulerAgent Пример Смотри также Send Feedback
Заполняет автоматические поля, создает сущность в БД и запускает проверку в планировщике

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override void Create(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Заметки

Метод сохранения новой сущности является виртуальным и может быть переопределен в конкретной реализации сущности. Таким образом сохранение конкретной сущности может осуществляться не стандартным образом.

Стандартное сохранение новой сущности происходит следующим образом:

  1. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnBeforeCreate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Cancel, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для того, чтобы была возможность корректно отменить сохранение сущности. Обработчики этой команды не должны модифицировать данные, так как нет гарантий, что один из обработчиков не отменит сохранение.

  2. Вызывается виртуальный метод VerifyEntry()()()(), который проверяет соответствие параметров сущности и ее схемы. Производятся следующие проверки полей сущности:

    • если поле является первичным ключем и у него установлен флаг Identity, то в параметрах сущности не должно быть заданого значения для этого поля,

    • если поле является первичным ключем и у него не установлен флаг Identity, то в параметрах сущности должно быть задано значение для этого поля,

    • если поле является обязательным и у него не задано значение по умолчанию, то в параметрах сущности должно быть задано значение для этого поля,

    • если поле является строковым, у него задано ограничение по длине и задано значение этого поля, то значение не должно быть длинее указанного ограничения.

    Если метод VerifyEntry()()()() вернул отличный от BXModifyStatusResult.Success статус, то сохранение преравается и выбрасывается исключение типа BXEventException.

  3. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnCreate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций перед сохранением новой сущности.

  4. Производится сохранение сущности и ее связок.

  5. Выполняется виртуальный метод CreateAdditionalEntities(BXSqlConnection, BXSqlTransaction), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется в рамках транзакции сохранения сущности.

  6. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnAfterCreate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций после сохранения новой сущности.

  7. Выполняется виртуальный метод CreateAfterSuccess()()()(), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется после закрытия соединения, в котором сохранялась сущность.

Примеры

CopyC#
BXSite site = new BXSite("company");
site.Name = "Моя компания";
site.Active = true;
site.Sort = 150;
site.Create();

Смотри также

Класс BXSchedulerAgent
Перегрузка Create
Пространство имен Bitrix.Services
BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..Create()()()()


Метод Delete

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSchedulerAgent..::.Delete
Класс BXSchedulerAgent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Delete()()()() | Удаляет текущую сущность из базы данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Delete(BXSqlConnection, BXSqlTransaction) | Удаляет текущую сущность из базы данных, используя указанное соединение. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgent
Члены BXSchedulerAgent
Пространство имен Bitrix.Services


Метод DeleteInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSchedulerAgent..::.DeleteInternal
Класс BXSchedulerAgent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
DeleteInternal(Object) | Внутренний метод удаления сущностей по первичному ключу id, который вызывается статическим методом Delete(Object). (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter) | Внутренний метод удаления сущностей по фильтру, который вызывается статическим методом Delete(BXFilter). При удалении не отправляются никакие комманды и не удаляются дополнительные данные. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
DeleteInternal(BXFilter, BXSqlConnection, BXSqlTransaction) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgent
Члены BXSchedulerAgent
Пространство имен Bitrix.Services


Метод Execute

Метод BXSchedulerAgent..::.Execute
Класс BXSchedulerAgent Смотри также Send Feedback
Находит сопоставленного агенту исполнителя и запускает его

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool Execute()

Возвращаемое значение

Продолжать дальнейшую обработку агента

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Метод GenerateGuidName

Метод BXSchedulerAgent..::.GenerateGuidName
Класс BXSchedulerAgent Смотри также Send Feedback
Генерирует уникальное имя для агента на основе GUID

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string GenerateGuidName()

Возвращаемое значение

Имя для агента, построенное на базе GUID

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Метод GetByIdInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSchedulerAgent..::.GetByIdInternal
Класс BXSchedulerAgent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetByIdInternal(Object, IBXTextEncoder) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetByIdInternal(Object, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetById (выборка сущности по первичному ключу), который вызывается статическими методами выборки типа GetById. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgent
Члены BXSchedulerAgent
Пространство имен Bitrix.Services


Метод GetByName

Метод BXSchedulerAgent..::.GetByName
Класс BXSchedulerAgent Смотри также Send Feedback
Находит агента по его имени

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXSchedulerAgent GetByName(
    string name
)

Параметры

name
Type: System..::..String
Символьное имя агента

Возвращаемое значение

Экземпляр агента или null, если агента с заданным именем не существует

Исключения

Исключение | Условие
System..::..ArgumentNullException | Происходит если name равен null

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Метод GetJoinedEntity

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSchedulerAgent..::.GetJoinedEntity
Класс BXSchedulerAgent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntity<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String, String, BXSchemeBase) | Запрос присоединённой сущности (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgent
Члены BXSchedulerAgent
Пространство имен Bitrix.Services


Метод GetJoinedEntityCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSchedulerAgent..::.GetJoinedEntityCollection
Класс BXSchedulerAgent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType>)>>)(String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetJoinedEntityCollection<(Of <<'(JoinedEntityType, JoinedEntityCollectionType, JoinedEntitySchemeType, JoinedEntityLinkType, JoinedEntityLinkCollectionType, JoinedEntityLinkSchemeType>)>>)(String, String, String) | Запрос коллекции присоединённых сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgent
Члены BXSchedulerAgent
Пространство имен Bitrix.Services


Метод GetListInternal

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSchedulerAgent..::.GetListInternal
Класс BXSchedulerAgent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
GetListInternal(BXFilter, BXOrderBy, BXSelect, BXQueryParams, IBXTextEncoder, BXSchemeBase) | Внутренний метод выборки типа GetList (выборка коллекции сущностей по фильтру), который вызывается статическими методами выборки типа GetList. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgent
Члены BXSchedulerAgent
Пространство имен Bitrix.Services


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSchedulerAgent..::.Save
Класс BXSchedulerAgent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет сущность в базе данных в новой транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет сущность в базе данных в указанной транзакции. Если это новая сущность, то вставляет соответствующую запись, иначе - изменяет. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgent
Члены BXSchedulerAgent
Пространство имен Bitrix.Services


Метод SetClassNameAndAssembly

Метод BXSchedulerAgent..::.SetClassNameAndAssembly
Класс BXSchedulerAgent Смотри также Send Feedback
Устанавливает имя класса исполнителя и имя сборки по типу

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void SetClassNameAndAssembly(
    Type type
)

Параметры

type
Type: System..::..Type
Тип исполнителя

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Метод SetValue

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSchedulerAgent..::.SetValue
Класс BXSchedulerAgent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
SetValue(KeyValuePair<(Of <<'(String, Object>)>>), Boolean) | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
SetValue(String, Object, Boolean) | Устанавливает значение поля сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgent
Члены BXSchedulerAgent
Пространство имен Bitrix.Services


Метод Update

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSchedulerAgent..::.Update
Класс BXSchedulerAgent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Update()()()() | Изменяет существующую сущность в базе данных в новой транзакции. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Update(BXSqlConnection, BXSqlTransaction) | Заполняет автоматические поля, обновляет сущность в БД и запускает проверку в планировщике (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..Update(BXSqlConnection, BXSqlTransaction))

Смотри также

Класс BXSchedulerAgent
Члены BXSchedulerAgent
Пространство имен Bitrix.Services


Метод Update (, )

Метод BXSchedulerAgent..::.Update (, )
Класс BXSchedulerAgent Пример Смотри также Send Feedback
Заполняет автоматические поля, обновляет сущность в БД и запускает проверку в планировщике

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override void Update(
    BXSqlConnection conn,
    BXSqlTransaction trans
)

Параметры

conn
Type: BXSqlConnection
Соединение с базой данных.
trans
Type: BXSqlTransaction
Транзакция.

Заметки

Метод сохранения существующей сущности является виртуальным и может быть переопределен в конкретной реализации сущности. Таким образом сохранение конкретной сущности может осуществляться не стандартным образом.

Стандартное сохранение существующей сущности происходит следующим образом:

  1. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnBeforeUpdate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Cancel, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для того, чтобы была возможность корректно отменить сохранение сущности. Обработчики этой команды не должны модифицировать данные, так как нет гарантий, что один из обработчиков не отменит сохранение.

  2. Вызывается виртуальный метод VerifyEntry()()()(), который проверяет соответствие параметров сущности и ее схемы. Производятся следующие проверки полей сущности:

    • если поле является первичным ключем, то в параметрах сущности должно быть задано значение для этого поля,

    • если поле является строковым, у него задано ограничение по длине и задано значение этого поля, то значение не должно быть длинее указанного ограничения.

    Если метод VerifyEntry()()()() вернул отличный от BXModifyStatusResult.Success статус, то сохранение преравается и выбрасывается исключение типа BXEventException.

  3. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnUpdate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то сохранение сущности будет прервано и будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций перед сохранением существующей сущности.

  4. Производится сохранение сущности и ее связок.

  5. Выполняется виртуальный метод UpdateAdditionalEntities(BXSqlConnection, BXSqlTransaction), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется в рамках транзакции сохранения сущности.

  6. Отправляется команда Bitrix.{ModuleId}.{EntityId}.OnAfterUpdate, где {ModuleId} - код модуля, а {EntityId} - код сущности, заданные в данной сущности в виде свойств. Если какие-либо из обработчиков команды вернули результат BXCommandResultType.Error, то будет выброшено исключение типа BXEventException, содержащее сообщения всех таких обработчиков. Сообщение должно быть записано обработчиком в свойство результата выполнения команды.

    Данная команда применяется для выполнения произвольных дополнительных операций после сохранения существующей сущности.

  7. Выполняется виртуальный метод UpdateAfterSuccess()()()(), который по умолчанию ничего не делает, но может быть переопределен при реализации конкретной сущности. Этот метод выполняется после закрытия соединения, в котором сохранялась сущность.

Примеры

CopyC#
BXSite site = BXSite.GetById("company");
site.Name = "Моя компания";
site.Active = true;
site.Sort = 150;
site.Update();

Смотри также

Класс BXSchedulerAgent
Перегрузка Update
Пространство имен Bitrix.Services


Свойства BXSchedulerAgent

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXSchedulerAgent
Класс BXSchedulerAgent Смотри также Send Feedback

Тип BXSchedulerAgent предоставляет следующие возможности.

Свойства

Имя | Описание
Active | Активен ли агент
Assembly | Имя сборки, в которой расположен исполнитель агента
ClassName | Имя класса исполнителя агента
CustomFields | Возвращает список набираемых свойств сущности. (Унаследовано от BXEntity)
CustomFieldsKey | (Унаследовано от BXEntity)
CustomPublicValues | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
CustomValues | Возвращает список значений набираемых свойств сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityId | Возвращает код сущности. Должен быть переопределен в конкретной сущности. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..EntityId)
EntityKey | Возвращает значение первичного ключа сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
EntityOriginContext | (Унаследовано от BXEntity)
Id | Идентификатор агента. Первичный ключ
IsDirty | Наличие отметки об изменении сущности с момента чтения из БД Имеет смысл только при IsNew == false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsNew | Возвращает true, если это вновь созданная сущность и она не имеет представления в базе данных. В противном случае возвращает false. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
IsReadOnly | (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
JoinedEntityMap | Набор отражений для связанных сущностей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
LastUpdated | Дата последнего обновления агента
ModuleId | Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности. (Переопределяет BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>..::..ModuleId)
Name | Уникальный символьный идентификатор агента
Parameters | Список параметров агента
Period | Период запуска агента
Periodic | Является ли агент периодическим
StartTime | Время следующего запуска агента
TextEncoder | Возвращает кодировщик текстовых полей сущности. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ValueMap | Набор отражений для полей (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Values | Возвращает словарь значений полей сущности. Значения не модифицированы кодировщиком. (Унаследовано от BXEntity<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Свойство Active

Свойство BXSchedulerAgent..::.Active
Класс BXSchedulerAgent Смотри также Send Feedback
Активен ли агент

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool Active { get; set; }

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Свойство Assembly

Свойство BXSchedulerAgent..::.Assembly
Класс BXSchedulerAgent Смотри также Send Feedback
Имя сборки, в которой расположен исполнитель агента

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Assembly { get; set; }

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Свойство ClassName

Свойство BXSchedulerAgent..::.ClassName
Класс BXSchedulerAgent Смотри также Send Feedback
Имя класса исполнителя агента

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ClassName { get; set; }

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Свойство EntityId

Свойство BXSchedulerAgent..::.EntityId
Класс BXSchedulerAgent Пример Смотри также Send Feedback
Возвращает код сущности. Должен быть переопределен в конкретной сущности.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string EntityId { get; }

Заметки

Это свойство используется для формирования названий команд, отправляемых при сохранении сущности в базу данных или удалении из базы данных.

Примеры

CopyC#
public class BXIBlockElement
    : BXEntity
{
    . . .

    public override string ModuleId
    {
        get { return "iblock"; }
    }

    public override string EntityId
    {
        get { return "IBlockElement"; }
    }

    . . .
}

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Свойство Id

Свойство BXSchedulerAgent..::.Id
Класс BXSchedulerAgent Смотри также Send Feedback
Идентификатор агента. Первичный ключ

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Id { get; }

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Свойство LastUpdated

Свойство BXSchedulerAgent..::.LastUpdated
Класс BXSchedulerAgent Смотри также Send Feedback
Дата последнего обновления агента

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public DateTime LastUpdated { get; }

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Свойство ModuleId

Свойство BXSchedulerAgent..::.ModuleId
Класс BXSchedulerAgent Пример Смотри также Send Feedback
Возвращает код модуля сущности. Должен быть переопределен в конкретной сущности.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override string ModuleId { get; }

Заметки

Это свойство используется для формирования названий команд, отправляемых при сохранении сущности в базу данных или удалении из базы данных.

Примеры

CopyC#
public class BXIBlockElement
    : BXEntity
{
    . . .

    public override string ModuleId
    {
        get { return "iblock"; }
    }

    public override string EntityId
    {
        get { return "IBlockElement"; }
    }

    . . .
}

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Свойство Name

Свойство BXSchedulerAgent..::.Name
Класс BXSchedulerAgent Смотри также Send Feedback
Уникальный символьный идентификатор агента

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Name { get; set; }

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Свойство Parameters

Свойство BXSchedulerAgent..::.Parameters
Класс BXSchedulerAgent Смотри также Send Feedback
Список параметров агента

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParamsBag<Object> Parameters { get; }

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Свойство Period

Свойство BXSchedulerAgent..::.Period
Класс BXSchedulerAgent Смотри также Send Feedback
Период запуска агента

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public TimeSpan Period { get; set; }

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Свойство Periodic

Свойство BXSchedulerAgent..::.Periodic
Класс BXSchedulerAgent Смотри также Send Feedback
Является ли агент периодическим

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool Periodic { get; set; }

Заметки

Период запуска агента задается свойством Period

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Свойство StartTime

Свойство BXSchedulerAgent..::.StartTime
Класс BXSchedulerAgent Смотри также Send Feedback
Время следующего запуска агента

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public DateTime StartTime { get; set; }

Смотри также

Класс BXSchedulerAgent
Пространство имен Bitrix.Services


Класс BXSchedulerAgent.Scheme

Класс BXSchedulerAgent..::..Scheme
Класс BXSchedulerAgent Члены Смотри также Send Feedback
Схема сущности "агент"

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class Scheme : BXScheme<BXSchedulerAgent..::..Scheme>

Иерархия наследования

System..::..Object
BXSchemeBase
BXScheme<(Of <(<'BXSchedulerAgent..::..Scheme>)>)>
Bitrix.Services..::..BXSchedulerAgent..::..Scheme

Смотри также

Члены BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Члены BXSchedulerAgent.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXSchedulerAgent..::..Scheme
Класс BXSchedulerAgent..::..Scheme Конструкторы Свойства Смотри также Send Feedback

Сущность агента

Тип BXSchedulerAgent..::..Scheme предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXSchedulerAgent..::..Scheme | Конструктор схемы сущности агента планировщика.

Свойства

Имя | Описание
Active | Описание поля "Активность".
Assembly | Описание поля "Имя сборкаи, в которой расположен класс исполнителя агента".
ClassName | Описание поля "Имя класса исполнителя агента".
Id | Описание поля "Идентификатор агента".
LastUpdated | Описание поля "Дата последнего изменения".
Name | Описание поля "Уникальный символьный идентификатор агента".
Parameters | Описание поля "Параметры агента".
Period | Описание поля "Период агента".
Periodic | Описание поля "Периодичность".
StartTime | Описание поля "Время следующего запуска".

Смотри также

Класс BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Конструктор BXSchedulerAgent.Scheme

Конструктор BXSchedulerAgent..::..Scheme
Класс BXSchedulerAgent..::..Scheme Смотри также Send Feedback
Конструктор схемы сущности агента планировщика.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Scheme()

Смотри также

Класс BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Свойства BXSchedulerAgent.Scheme

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXSchedulerAgent..::..Scheme
Класс BXSchedulerAgent..::..Scheme Смотри также Send Feedback

Тип BXSchedulerAgent..::..Scheme предоставляет следующие возможности.

Свойства

Имя | Описание
Active | Описание поля "Активность".
Assembly | Описание поля "Имя сборкаи, в которой расположен класс исполнителя агента".
ClassName | Описание поля "Имя класса исполнителя агента".
Id | Описание поля "Идентификатор агента".
LastUpdated | Описание поля "Дата последнего изменения".
Name | Описание поля "Уникальный символьный идентификатор агента".
Parameters | Описание поля "Параметры агента".
Period | Описание поля "Период агента".
Periodic | Описание поля "Периодичность".
StartTime | Описание поля "Время следующего запуска".

Смотри также

Класс BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Свойство Active

Свойство BXSchedulerAgent..::..Scheme..::.Active
Класс BXSchedulerAgent..::..Scheme Смотри также Send Feedback
Описание поля "Активность".

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Active { get; }

Смотри также

Класс BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Свойство Assembly

Свойство BXSchedulerAgent..::..Scheme..::.Assembly
Класс BXSchedulerAgent..::..Scheme Смотри также Send Feedback
Описание поля "Имя сборкаи, в которой расположен класс исполнителя агента".

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Assembly { get; }

Смотри также

Класс BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Свойство ClassName

Свойство BXSchedulerAgent..::..Scheme..::.ClassName
Класс BXSchedulerAgent..::..Scheme Смотри также Send Feedback
Описание поля "Имя класса исполнителя агента".

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase ClassName { get; }

Смотри также

Класс BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Свойство Id

Свойство BXSchedulerAgent..::..Scheme..::.Id
Класс BXSchedulerAgent..::..Scheme Смотри также Send Feedback
Описание поля "Идентификатор агента".

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Id { get; }

Смотри также

Класс BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Свойство LastUpdated

Свойство BXSchedulerAgent..::..Scheme..::.LastUpdated
Класс BXSchedulerAgent..::..Scheme Смотри также Send Feedback
Описание поля "Дата последнего изменения".

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase LastUpdated { get; }

Смотри также

Класс BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Свойство Name

Свойство BXSchedulerAgent..::..Scheme..::.Name
Класс BXSchedulerAgent..::..Scheme Смотри также Send Feedback
Описание поля "Уникальный символьный идентификатор агента".

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Name { get; }

Смотри также

Класс BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Свойство Parameters

Свойство BXSchedulerAgent..::..Scheme..::.Parameters
Класс BXSchedulerAgent..::..Scheme Смотри также Send Feedback
Описание поля "Параметры агента".

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Parameters { get; }

Смотри также

Класс BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Свойство Period

Свойство BXSchedulerAgent..::..Scheme..::.Period
Класс BXSchedulerAgent..::..Scheme Смотри также Send Feedback
Описание поля "Период агента".

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Period { get; }

Смотри также

Класс BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Свойство Periodic

Свойство BXSchedulerAgent..::..Scheme..::.Periodic
Класс BXSchedulerAgent..::..Scheme Смотри также Send Feedback
Описание поля "Периодичность".

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase Periodic { get; }

Смотри также

Класс BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Свойство StartTime

Свойство BXSchedulerAgent..::..Scheme..::.StartTime
Класс BXSchedulerAgent..::..Scheme Смотри также Send Feedback
Описание поля "Время следующего запуска".

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchemeFieldBase StartTime { get; }

Смотри также

Класс BXSchedulerAgent..::..Scheme
Пространство имен Bitrix.Services


Класс BXSchedulerAgentCollection

Класс BXSchedulerAgentCollection
Члены Смотри также Send Feedback
Коллекция агентов планировщика.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXSchedulerAgentCollection : BXEntityCollection<BXSchedulerAgent, BXSchedulerAgentCollection, BXSchedulerAgent..::..Scheme>

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<' BXSchedulerAgent >)>)>
Bitrix.DataLayer..::..BXEntityCollection <(Of <(<' BXSchedulerAgent, BXSchedulerAgentCollection, BXSchedulerAgent..::..Scheme >)>)>
Bitrix.Services..::..BXSchedulerAgentCollection

Смотри также

Члены BXSchedulerAgentCollection
Пространство имен Bitrix.Services


Члены BXSchedulerAgentCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXSchedulerAgentCollection
Класс BXSchedulerAgentCollection Конструкторы Методы Смотри также Send Feedback

Тип BXSchedulerAgentCollection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXSchedulerAgentCollection |

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Смотри также

Класс BXSchedulerAgentCollection
Пространство имен Bitrix.Services


Конструктор BXSchedulerAgentCollection

Конструктор BXSchedulerAgentCollection
Класс BXSchedulerAgentCollection Смотри также Send Feedback

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSchedulerAgentCollection()

Смотри также

Класс BXSchedulerAgentCollection
Пространство имен Bitrix.Services


Методы BXSchedulerAgentCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXSchedulerAgentCollection
Класс BXSchedulerAgentCollection Смотри также Send Feedback

Тип BXSchedulerAgentCollection предоставляет следующие возможности.

Методы

Имя | Описание
Save | Перегруженный.
SetValue | Устанавливает значение поля всех сущностей коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable | Перегруженный.

Смотри также

Класс BXSchedulerAgentCollection
Пространство имен Bitrix.Services


Метод Save

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSchedulerAgentCollection..::.Save
Класс BXSchedulerAgentCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Save()()()() | Сохраняет все сущности коллекции. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
Save(BXSqlConnection, BXSqlTransaction) | Сохраняет все сущности коллекции, используя указанное соединение. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgentCollection
Члены BXSchedulerAgentCollection
Пространство имен Bitrix.Services


Метод ToDataTable

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSchedulerAgentCollection..::.ToDataTable
Класс BXSchedulerAgentCollection Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ToDataTable()()()() | Приводит коллекцию к типу DataTable. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)
ToDataTable(BXPagingOptions) | Приводит коллекцию к типу DataTable с применением опций постраничной навигации. (Унаследовано от BXEntityCollection<(Of <(<'EntityType, EntityCollectionType, EntryScheme>)>)>)

Смотри также

Класс BXSchedulerAgentCollection
Члены BXSchedulerAgentCollection
Пространство имен Bitrix.Services


Класс BXSefUrlManager

Класс BXSefUrlManager
Члены Смотри также Send Feedback
Предоставляет доступ к состоянию системы обработки адресов и ЧПУ

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static class BXSefUrlManager

Иерархия наследования

System..::..Object
Bitrix.Services..::..BXSefUrlManager

Смотри также

Члены BXSefUrlManager
Пространство имен Bitrix.Services


Члены BXSefUrlManager

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXSefUrlManager
Класс BXSefUrlManager Методы Свойства Смотри также Send Feedback

Тип BXSefUrlManager предоставляет следующие возможности.

Методы

Имя | Описание
PermanentRedirect |
RefreshComponentSefState | Перегруженный.

Свойства

Имя | Описание
CurrentUrl | Возвращает ссылку по которой произошел запрос.

Смотри также

Класс BXSefUrlManager
Пространство имен Bitrix.Services


Методы BXSefUrlManager

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXSefUrlManager
Класс BXSefUrlManager Смотри также Send Feedback

Тип BXSefUrlManager предоставляет следующие возможности.

Методы

Имя | Описание
PermanentRedirect |
RefreshComponentSefState | Перегруженный.

Смотри также

Класс BXSefUrlManager
Пространство имен Bitrix.Services


Метод PermanentRedirect

Метод BXSefUrlManager..::.PermanentRedirect
Класс BXSefUrlManager Смотри также Send Feedback

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void PermanentRedirect(
    string url
)

Параметры

url
Type: System..::..String

Смотри также

Класс BXSefUrlManager
Пространство имен Bitrix.Services


Метод RefreshComponentSefState

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSefUrlManager..::.RefreshComponentSefState
Класс BXSefUrlManager Смотри также Send Feedback

Лист перегрузки

Имя | Описание
RefreshComponentSefState()()()() | Обновляет состояние правил обработки адресов для компонентов на страницах, размещенных на сайте.
RefreshComponentSefState(String) | Обновляет состояние правил обработки адресов для компонентов на страницах, размещенных на сайте.

Смотри также

Класс BXSefUrlManager
Члены BXSefUrlManager
Пространство имен Bitrix.Services


Метод RefreshComponentSefState

Метод BXSefUrlManager..::.RefreshComponentSefState
Класс BXSefUrlManager Смотри также Send Feedback
Обновляет состояние правил обработки адресов для компонентов на страницах, размещенных на сайте.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void RefreshComponentSefState()

Заметки

Это длительный процесс. Сначала удаляются все правила обработки адресов, привязанные к компонентам на страницах. Затем все публичные ASPX-страницы сайта сканируются на наличие компонентов, у которых параметр "EnableSef" имеет значение true. Для этих страниц создаются соответствующие правила обработки адресов.

Смотри также

Класс BXSefUrlManager
Перегрузка RefreshComponentSefState
Пространство имен Bitrix.Services


Метод RefreshComponentSefState (String)

Метод BXSefUrlManager..::.RefreshComponentSefState (String)
Класс BXSefUrlManager Смотри также Send Feedback
Обновляет состояние правил обработки адресов для компонентов на страницах, размещенных на сайте.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void RefreshComponentSefState(
    string siteId
)

Параметры

siteId
Type: System..::..String
Идентификатор сайта, для которого обновлять ЧПУ

Заметки

Для корректной работы метода необходимо наличие текущего HttpRequest в контексте.

Это длительный процесс. Сначала удаляются все правила обработки адресов, привязанные к компонентам на страницах. Затем все публичные ASPX-страницы сайта сканируются на наличие компонентов, у которых параметр "EnableSef" имеет значение true. Для этих страниц создаются соответствующие правила обработки адресов.

Если производится попытка обновить ЧПУ для сайта, который настроен на другое веб-приложения, обновление сайта производиться не будет.

Если siteId равен null, то будут обновлены все сайты обрабатываемые текущим веб-приложением.

Смотри также

Класс BXSefUrlManager
Перегрузка RefreshComponentSefState
Пространство имен Bitrix.Services


Свойства BXSefUrlManager

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXSefUrlManager
Класс BXSefUrlManager Смотри также Send Feedback

Тип BXSefUrlManager предоставляет следующие возможности.

Свойства

Имя | Описание
CurrentUrl | Возвращает ссылку по которой произошел запрос.

Смотри также

Класс BXSefUrlManager
Пространство имен Bitrix.Services


Свойство CurrentUrl

Свойство BXSefUrlManager..::.CurrentUrl
Класс BXSefUrlManager Пример Смотри также Send Feedback
Возвращает ссылку по которой произошел запрос.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static Uri CurrentUrl { get; }

Заметки

Ссылка соответствует действительному адресу, по которой пришел запрос на сервер, а не адресу текущего обработчика. Т.е., если на сервер пришел запрос с адресом "http://www.contoso.com/foo/bar/", который механизмом обработки адресов был перенаправлен на обработчик "~/foobar.aspx", то CurrentUrl вернет именно "http://www.contoso.com/foo/bar/", а не "http://www.contoso.com/foobar.aspx", как это делает свойство HttpRequest.Url

В случае работы механизма AJAX компонентов CurrentUrl будет содержать не действительный адрес запроса, по которому произошел PostBack формы, а предполагаемый адрес страницы которая должна быть открыта при помощи AJAX. Т.е. если AJAX PostBack произошел на странице "http://www.contoso.com/foo/bar/" (соответственно на саму себя) с целью вывести содержимое страницы "http://www.contoso.com/foo/bar/21/", то CurrentUrl будет содержать именно "http://www.contoso.com/foo/bar/21/"

Примеры

Формирование шаблонов ссылок в комплексном компоненте:

CopyC#
string path = BXSefUrlManager.CurrentUrl.AbsolutePath;

ComponentCache["UrlTemplateAlbum"] = string.Format("{0}?{1}=#AlbumId#", path, urlToPage["album"]);
ComponentCache["UrlTemplateAlbumPage"] = string.Format("{0}?{1}=#AlbumId#&{2}=#PageId#", path, urlToPage["album"], Parameters.Get<string>("ParamAlbumPage", "Page"));
ComponentCache["UrlTemplateAlbumShowAll"] = string.Format("{0}?{1}=#AlbumId#&{2}=", path, urlToPage["album"], Parameters.Get<string>("ParamAlbumShowAll", "Page"));
ComponentCache["UrlTemplateAlbumEdit"] = string.Format("{0}?{1}=#AlbumId#", path, urlToPage["album.edit"]);
ComponentCache["UrlTemplatePhoto"] = string.Format("{0}?{1}=#PhotoId#", path, urlToPage["photo"]);
ComponentCache["UrlTemplatePhotoEdit"] = string.Format("{0}?{1}=#PhotoId#", path, urlToPage["photo.edit"]);
ComponentCache["UrlTemplateUpload"] = string.Format("{0}?{1}=#AlbumId#", path, urlToPage["upload"]);

Смотри также

Класс BXSefUrlManager
Пространство имен Bitrix.Services


Класс BXSefUrlRule

Класс BXSefUrlRule
Члены Пример Смотри также Send Feedback
Класс правила обработки адреса запроса.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXSefUrlRule : ICloneable

Примеры

Регистрация компонентом правила обработки адреса:

CopyC#
class SomeComponent : BXComponent
{
    void RegisterRule()
{
    string helperId = "Component-" + ID;

    BXFormFilter filter = new BXFormFilter();
    filter.Add("SiteId", DesignerSite, BXSqlFilterOperators.Equal);
    filter.Add("ComponentName", Name, BXSqlFilterOperators.Equal);
    filter.Add("Path", Request.AppRelativeCurrentExecutionFilePath, BXSqlFilterOperators.Equal);
    filter.Add("HelperId", helperId, BXSqlFilterOperators.Equal);
    BXSefUrlRuleCollection rules =  BXSefUrlRuleManager.GetList(filter);

    BXSefUrlRuleManager.BeginUpdate();

    BXSefUrlRule rule;
    if (col.Count != 0)
        rule = rules[0];
    else
    {
        BXSefUrlRule rule = new BXSefUrlRule();
        rule.ComponentName = Name;
        rule.Path = Request.AppRelativeCurrentExecutionFilePath;
        rule.HelperId = helperId;
        rule.SiteId = DesignerSite;
    }

    dir = VirtualPathUtility.GetDirectory(Request.AppRelativeCurrentExecutionFilePath);
    rule.MatchExpression = "^" + BXStringUtility.RegexEncode(dir) + @"/(?<action>[^\/\?]+)(?:/(?<id>[^\/\?]+))?/?(?:\?(?<query>.*))?" + "$";
    rule.ReplaceExpression = Request.AppRelativeCurrentExecutionFilePath + "?action=${action}&id=${id}&${query}";
    rule.Sort = 500;

    if (rule.Id == -1)
        BXSefUrlRuleManager.Add(rule);

    BXSefUrlRuleManager.EndUpdate();
}
}

Иерархия наследования

System..::..Object
Bitrix.Services..::..BXSefUrlRule

Смотри также

Члены BXSefUrlRule
Пространство имен Bitrix.Services


Члены BXSefUrlRule

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXSefUrlRule
Класс BXSefUrlRule Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXSefUrlRule предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXSefUrlRule | Создает новый экземпляр правила.

Методы

Имя | Описание
Clone | Создает копию правила обработки адреса.

Свойства

Имя | Описание
ComponentName | Возвращает или устанавливает имя компонента, создавшего правило.
HelperId | Возвращает или устанавливает вспомогательный идентификатор. Назначение идентификатора оставлено на усмотрение разработчика.
Id | Возвращает временный уникальный идентификатор правила обработки адреса.
Ignore | Возвращает или устанавливает, является ли правило исключением из правил обработки адресов.
MatchExpression | Возвращает или устанавливает регулярное выражение, которое используется для проверки совпадения правила.
MatchRegex | Возвращает экземпляр регулярного выражения, соответствующий свойству MatchExpression.
Path | Возвращает или устанавливает виртуальный путь относительно приложения к странице, на которой расположен, создавший правило.
ReplaceExpression | Возвращает или устанавливает выражение замены, при помощи которого будет обработан адрес запроса.
SiteId | Возвращает или устанавливает идентификатор сайта, к которому принадлежит данное правило.
Sort | Возвращает или устанавливает индекс сортировки для правила.

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Конструктор BXSefUrlRule

Конструктор BXSefUrlRule
Класс BXSefUrlRule Смотри также Send Feedback
Создает новый экземпляр правила.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSefUrlRule()

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Методы BXSefUrlRule

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXSefUrlRule
Класс BXSefUrlRule Смотри также Send Feedback

Тип BXSefUrlRule предоставляет следующие возможности.

Методы

Имя | Описание
Clone | Создает копию правила обработки адреса.

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Метод Clone

Метод BXSefUrlRule..::.Clone
Класс BXSefUrlRule Пример Смотри также Send Feedback
Создает копию правила обработки адреса.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSefUrlRule Clone()

Возвращаемое значение

Новый экземпляр класса BXSefUrlRule, который является копией оригинального.

Заметки

Новый экземпляр не добавляется во временное хранилище и, соответственно, не имеет временного идентификатора (см. Id).

Примеры

Копирование правил из одного сайта в другой:

CopyC#
string newSiteId;

BXFormFilter filter = new BXFormFilter();
filter.Add("SiteId", BXSite.Current.Id, BXSqlFilterOperators.Equal);

BXSefUrlRuleCollection rules = BXSefUrlRuleManager.GetList(filter);
for (int i = 0; i < rules.Count; i++)
{
    rules[i] = rules[i].Clone();
    rules[i].SiteId = newSiteId;
}
BXSefUrlRuleManager.Add(rules);

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Свойства BXSefUrlRule

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXSefUrlRule
Класс BXSefUrlRule Смотри также Send Feedback

Тип BXSefUrlRule предоставляет следующие возможности.

Свойства

Имя | Описание
ComponentName | Возвращает или устанавливает имя компонента, создавшего правило.
HelperId | Возвращает или устанавливает вспомогательный идентификатор. Назначение идентификатора оставлено на усмотрение разработчика.
Id | Возвращает временный уникальный идентификатор правила обработки адреса.
Ignore | Возвращает или устанавливает, является ли правило исключением из правил обработки адресов.
MatchExpression | Возвращает или устанавливает регулярное выражение, которое используется для проверки совпадения правила.
MatchRegex | Возвращает экземпляр регулярного выражения, соответствующий свойству MatchExpression.
Path | Возвращает или устанавливает виртуальный путь относительно приложения к странице, на которой расположен, создавший правило.
ReplaceExpression | Возвращает или устанавливает выражение замены, при помощи которого будет обработан адрес запроса.
SiteId | Возвращает или устанавливает идентификатор сайта, к которому принадлежит данное правило.
Sort | Возвращает или устанавливает индекс сортировки для правила.

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Свойство ComponentName

Свойство BXSefUrlRule..::.ComponentName
Класс BXSefUrlRule Пример Смотри также Send Feedback
Возвращает или устанавливает имя компонента, создавшего правило.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ComponentName { get; set; }

Заметки

Параметр не является обязательным и может быть null.

Свойство используется механизмом ЧПУ компонентов для поиска соответствующих правил.

Примеры

Регистрация компонентом правила обработки адреса:

CopyC#
class SomeComponent : BXComponent
{
    void RegisterRule()
{
    string helperId = "Component-" + ID;

    BXFormFilter filter = new BXFormFilter();
    filter.Add("SiteId", DesignerSite, BXSqlFilterOperators.Equal);
    filter.Add("ComponentName", Name, BXSqlFilterOperators.Equal);
    filter.Add("Path", Request.AppRelativeCurrentExecutionFilePath, BXSqlFilterOperators.Equal);
    filter.Add("HelperId", helperId, BXSqlFilterOperators.Equal);
    BXSefUrlRuleCollection rules =  BXSefUrlRuleManager.GetList(filter);

    BXSefUrlRuleManager.BeginUpdate();

    BXSefUrlRule rule;
    if (col.Count != 0)
        rule = rules[0];
    else
    {
        BXSefUrlRule rule = new BXSefUrlRule();
        rule.ComponentName = Name;
        rule.Path = Request.AppRelativeCurrentExecutionFilePath;
        rule.HelperId = helperId;
        rule.SiteId = DesignerSite;
    }

    dir = VirtualPathUtility.GetDirectory(Request.AppRelativeCurrentExecutionFilePath);
    rule.MatchExpression = "^" + BXStringUtility.RegexEncode(dir) + @"/(?<action>[^\/\?]+)(?:/(?<id>[^\/\?]+))?/?(?:\?(?<query>.*))?" + "$";
    rule.ReplaceExpression = Request.AppRelativeCurrentExecutionFilePath + "?action=${action}&id=${id}&${query}";
    rule.Sort = 500;

    if (rule.Id == -1)
        BXSefUrlRuleManager.Add(rule);

    BXSefUrlRuleManager.EndUpdate();
}
}

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Свойство HelperId

Свойство BXSefUrlRule..::.HelperId
Класс BXSefUrlRule Пример Смотри также Send Feedback
Возвращает или устанавливает вспомогательный идентификатор. Назначение идентификатора оставлено на усмотрение разработчика.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string HelperId { get; set; }

Заметки

Свойство возвращает пустую строку, если было установлено в null.

Свойство также используется механизмом ЧПУ компонентов для поиска соответствующих правил.

Примеры

Регистрация компонентом правила обработки адреса:

CopyC#
class SomeComponent : BXComponent
{
    void RegisterRule()
{
    string helperId = "Component-" + ID;

    BXFormFilter filter = new BXFormFilter();
    filter.Add("SiteId", DesignerSite, BXSqlFilterOperators.Equal);
    filter.Add("ComponentName", Name, BXSqlFilterOperators.Equal);
    filter.Add("Path", Request.AppRelativeCurrentExecutionFilePath, BXSqlFilterOperators.Equal);
    filter.Add("HelperId", helperId, BXSqlFilterOperators.Equal);
    BXSefUrlRuleCollection rules =  BXSefUrlRuleManager.GetList(filter);

    BXSefUrlRuleManager.BeginUpdate();

    BXSefUrlRule rule;
    if (col.Count != 0)
        rule = rules[0];
    else
    {
        BXSefUrlRule rule = new BXSefUrlRule();
        rule.ComponentName = Name;
        rule.Path = Request.AppRelativeCurrentExecutionFilePath;
        rule.HelperId = helperId;
        rule.SiteId = DesignerSite;
    }

    dir = VirtualPathUtility.GetDirectory(Request.AppRelativeCurrentExecutionFilePath);
    rule.MatchExpression = "^" + BXStringUtility.RegexEncode(dir) + @"/(?<action>[^\/\?]+)(?:/(?<id>[^\/\?]+))?/?(?:\?(?<query>.*))?" + "$";
    rule.ReplaceExpression = Request.AppRelativeCurrentExecutionFilePath + "?action=${action}&id=${id}&${query}";
    rule.Sort = 500;

    if (rule.Id == -1)
        BXSefUrlRuleManager.Add(rule);

    BXSefUrlRuleManager.EndUpdate();
}
}

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Свойство Id

Свойство BXSefUrlRule..::.Id
Класс BXSefUrlRule Пример Смотри также Send Feedback
Возвращает временный уникальный идентификатор правила обработки адреса.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Id { get; }

Заметки

Временный идентификатор назначается при добавлении нового правила во временное хранилище (см. Add(BXSefUrlRule)) или загрузке правил из постоянного хранилища (см. Load()()()()).

Временный идентификатор актуален до тех пор пока соответвующее правило не будет удалено из временного хранилища (см. Delete(BXSefUrlRule)) или хранилище не будет перезагружено (см. Load()()()()).

Для правил, не размещенных во временном хранилище идентификатор равен -1.

Примеры

Регистрация компонентом правила обработки адреса:

CopyC#
class SomeComponent : BXComponent
{
    void RegisterRule()
{
    string helperId = "Component-" + ID;

    BXFormFilter filter = new BXFormFilter();
    filter.Add("SiteId", DesignerSite, BXSqlFilterOperators.Equal);
    filter.Add("ComponentName", Name, BXSqlFilterOperators.Equal);
    filter.Add("Path", Request.AppRelativeCurrentExecutionFilePath, BXSqlFilterOperators.Equal);
    filter.Add("HelperId", helperId, BXSqlFilterOperators.Equal);
    BXSefUrlRuleCollection rules =  BXSefUrlRuleManager.GetList(filter);

    BXSefUrlRuleManager.BeginUpdate();

    BXSefUrlRule rule;
    if (col.Count != 0)
        rule = rules[0];
    else
    {
        BXSefUrlRule rule = new BXSefUrlRule();
        rule.ComponentName = Name;
        rule.Path = Request.AppRelativeCurrentExecutionFilePath;
        rule.HelperId = helperId;
        rule.SiteId = DesignerSite;
    }

    dir = VirtualPathUtility.GetDirectory(Request.AppRelativeCurrentExecutionFilePath);
    rule.MatchExpression = "^" + BXStringUtility.RegexEncode(dir) + @"/(?<action>[^\/\?]+)(?:/(?<id>[^\/\?]+))?/?(?:\?(?<query>.*))?" + "$";
    rule.ReplaceExpression = Request.AppRelativeCurrentExecutionFilePath + "?action=${action}&id=${id}&${query}";
    rule.Sort = 500;

    if (rule.Id == -1)
        BXSefUrlRuleManager.Add(rule);

    BXSefUrlRuleManager.EndUpdate();
}
}

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Свойство Ignore

Свойство BXSefUrlRule..::.Ignore
Класс BXSefUrlRule Пример Смотри также Send Feedback
Возвращает или устанавливает, является ли правило исключением из правил обработки адресов.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool Ignore { get; set; }

Заметки

При совпадении с правилом-исключением механизм ЧПУ передаст управление стандартному механизму ASP.NET для получения обработчика запроса.

Данный тип правил полезен, когда обработка правил ЧПУ препятствует нормальной работе обработчиков, зарегистрированных в web.config.

Примеры

Регистрация правила-исключения для *.asmx запросов (такое правило уже добавлено в стандартные исключения):

CopyC#
BXSefUrlRule rule = new BXSefUrlRule();
rule.SiteId = BXSite.Current.Id;
rule.MatchExpression = @"\/[^\/]*.asmx(\/|$|\?)";
rule.Ignore = true;

BXSefUrlRuleManager.Add(rule);

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Свойство MatchExpression

Свойство BXSefUrlRule..::.MatchExpression
Класс BXSefUrlRule Пример Смотри также Send Feedback
Возвращает или устанавливает регулярное выражение, которое используется для проверки совпадения правила.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string MatchExpression { get; set; }

Заметки

Регулярное выражение проверяется против виртуального пути относительно приложения для текущего запроса соединенного со строкой запроса. Т.е. для приложения, расположенного по адресу http://www.contoso.com/myapp в случае запроса вида http://www.contoso.com/myapp/section/page.aspx?query=something регулярное выражение будет проверяться против строки ~/section/page.aspx?query=something.

Для запроса к корню приложения (http://www.contoso.com/myapp) регулярное выражение будет проверяться против строки ~/.

Правила, для которых регулярное выражение равно null обрабатываться не будут.

Регулярное выражение, определяемое свойством, должно использовать синтаксис регулярных выражений .NET Framework.

Примеры

Регистрация компонентом правила обработки адреса:

CopyC#
class SomeComponent : BXComponent
{
    void RegisterRule()
{
    string helperId = "Component-" + ID;

    BXFormFilter filter = new BXFormFilter();
    filter.Add("SiteId", DesignerSite, BXSqlFilterOperators.Equal);
    filter.Add("ComponentName", Name, BXSqlFilterOperators.Equal);
    filter.Add("Path", Request.AppRelativeCurrentExecutionFilePath, BXSqlFilterOperators.Equal);
    filter.Add("HelperId", helperId, BXSqlFilterOperators.Equal);
    BXSefUrlRuleCollection rules =  BXSefUrlRuleManager.GetList(filter);

    BXSefUrlRuleManager.BeginUpdate();

    BXSefUrlRule rule;
    if (col.Count != 0)
        rule = rules[0];
    else
    {
        BXSefUrlRule rule = new BXSefUrlRule();
        rule.ComponentName = Name;
        rule.Path = Request.AppRelativeCurrentExecutionFilePath;
        rule.HelperId = helperId;
        rule.SiteId = DesignerSite;
    }

    dir = VirtualPathUtility.GetDirectory(Request.AppRelativeCurrentExecutionFilePath);
    rule.MatchExpression = "^" + BXStringUtility.RegexEncode(dir) + @"/(?<action>[^\/\?]+)(?:/(?<id>[^\/\?]+))?/?(?:\?(?<query>.*))?" + "$";
    rule.ReplaceExpression = Request.AppRelativeCurrentExecutionFilePath + "?action=${action}&id=${id}&${query}";
    rule.Sort = 500;

    if (rule.Id == -1)
        BXSefUrlRuleManager.Add(rule);

    BXSefUrlRuleManager.EndUpdate();
}
}

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Свойство MatchRegex

Свойство BXSefUrlRule..::.MatchRegex
Класс BXSefUrlRule Пример Смотри также Send Feedback
Возвращает экземпляр регулярного выражения, соответствующий свойству MatchExpression.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Regex MatchRegex { get; }

Примеры

Регистрация компонентом правила обработки адреса:

CopyC#
BXSefUrlRule FindMatch()
{
    foreach (BXSefUrlRule rule in BXSefUrlRuleManager.GetRulesForSite(BXSite.Current.Id))
        if (rule.MatchRegex.IsMatch(HttpContext.Current.Request.AppRelativeCurrentExecutionFilePath))
            return rule;

    return null;
}

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Свойство Path

Свойство BXSefUrlRule..::.Path
Класс BXSefUrlRule Пример Смотри также Send Feedback
Возвращает или устанавливает виртуальный путь относительно приложения к странице, на которой расположен, создавший правило.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Path { get; set; }

Заметки

Свойство не является обязательным и может быть null.

В случае если специально не задан шаблон замены (ReplaceExpression) для правила, то механизм ЧПУ произведет перенаправление по заданному пути.

Свойство используется механизмом ЧПУ компонентов для поиска соответствующих правил.

Примеры

Регистрация компонентом правила обработки адреса:

CopyC#
class SomeComponent : BXComponent
{
    void RegisterRule()
{
    string helperId = "Component-" + ID;

    BXFormFilter filter = new BXFormFilter();
    filter.Add("SiteId", DesignerSite, BXSqlFilterOperators.Equal);
    filter.Add("ComponentName", Name, BXSqlFilterOperators.Equal);
    filter.Add("Path", Request.AppRelativeCurrentExecutionFilePath, BXSqlFilterOperators.Equal);
    filter.Add("HelperId", helperId, BXSqlFilterOperators.Equal);
    BXSefUrlRuleCollection rules =  BXSefUrlRuleManager.GetList(filter);

    BXSefUrlRuleManager.BeginUpdate();

    BXSefUrlRule rule;
    if (col.Count != 0)
        rule = rules[0];
    else
    {
        BXSefUrlRule rule = new BXSefUrlRule();
        rule.ComponentName = Name;
        rule.Path = Request.AppRelativeCurrentExecutionFilePath;
        rule.HelperId = helperId;
        rule.SiteId = DesignerSite;
    }

    dir = VirtualPathUtility.GetDirectory(Request.AppRelativeCurrentExecutionFilePath);
    rule.MatchExpression = "^" + BXStringUtility.RegexEncode(dir) + @"/(?<action>[^\/\?]+)(?:/(?<id>[^\/\?]+))?/?(?:\?(?<query>.*))?" + "$";
    rule.ReplaceExpression = Request.AppRelativeCurrentExecutionFilePath + "?action=${action}&id=${id}&${query}";
    rule.Sort = 500;

    if (rule.Id == -1)
        BXSefUrlRuleManager.Add(rule);

    BXSefUrlRuleManager.EndUpdate();
}
}

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Свойство ReplaceExpression

Свойство BXSefUrlRule..::.ReplaceExpression
Класс BXSefUrlRule Пример Смотри также Send Feedback
Возвращает или устанавливает выражение замены, при помощи которого будет обработан адрес запроса.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ReplaceExpression { get; set; }

Заметки

Выражение замены используется совместно с регулярным выражением совпадения, задаваемым свойством MatchExpression. Например, правило с регулярным выражением ^~/(?'lang'en|ru)/(?'path'[^\?]*)(?:\?(?'query'.*))?$ и выражением замены ~/${path}?lang=${lang}&${query} будет подменять запросы вида http://foo.bar/ru/news.aspx на запросы вида http://foo.bar/news.aspx?lang=ru&.

Выражение, определяемое свойством, должно использовать синтаксис выражений замены для регулярных выражений .NET Framework.

Примеры

Регистрация компонентом правила обработки адреса:

CopyC#
class SomeComponent : BXComponent
{
    void RegisterRule()
{
    string helperId = "Component-" + ID;

    BXFormFilter filter = new BXFormFilter();
    filter.Add("SiteId", DesignerSite, BXSqlFilterOperators.Equal);
    filter.Add("ComponentName", Name, BXSqlFilterOperators.Equal);
    filter.Add("Path", Request.AppRelativeCurrentExecutionFilePath, BXSqlFilterOperators.Equal);
    filter.Add("HelperId", helperId, BXSqlFilterOperators.Equal);
    BXSefUrlRuleCollection rules =  BXSefUrlRuleManager.GetList(filter);

    BXSefUrlRuleManager.BeginUpdate();

    BXSefUrlRule rule;
    if (col.Count != 0)
        rule = rules[0];
    else
    {
        BXSefUrlRule rule = new BXSefUrlRule();
        rule.ComponentName = Name;
        rule.Path = Request.AppRelativeCurrentExecutionFilePath;
        rule.HelperId = helperId;
        rule.SiteId = DesignerSite;
    }

    dir = VirtualPathUtility.GetDirectory(Request.AppRelativeCurrentExecutionFilePath);
    rule.MatchExpression = "^" + BXStringUtility.RegexEncode(dir) + @"/(?<action>[^\/\?]+)(?:/(?<id>[^\/\?]+))?/?(?:\?(?<query>.*))?" + "$";
    rule.ReplaceExpression = Request.AppRelativeCurrentExecutionFilePath + "?action=${action}&id=${id}&${query}";
    rule.Sort = 500;

    if (rule.Id == -1)
        BXSefUrlRuleManager.Add(rule);

    BXSefUrlRuleManager.EndUpdate();
}
}

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Свойство SiteId

Свойство BXSefUrlRule..::.SiteId
Класс BXSefUrlRule Пример Смотри также Send Feedback
Возвращает или устанавливает идентификатор сайта, к которому принадлежит данное правило.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string SiteId { get; set; }

Заметки

Свойство является обязательным. Значение свойства не должно быть null.

При обработке адреса запроса используются только те правила, которые принадлежат к сайту которому принадлежит запрос.

Примеры

Регистрация компонентом правила обработки адреса:

CopyC#
class SomeComponent : BXComponent
{
    void RegisterRule()
{
    string helperId = "Component-" + ID;

    BXFormFilter filter = new BXFormFilter();
    filter.Add("SiteId", DesignerSite, BXSqlFilterOperators.Equal);
    filter.Add("ComponentName", Name, BXSqlFilterOperators.Equal);
    filter.Add("Path", Request.AppRelativeCurrentExecutionFilePath, BXSqlFilterOperators.Equal);
    filter.Add("HelperId", helperId, BXSqlFilterOperators.Equal);
    BXSefUrlRuleCollection rules =  BXSefUrlRuleManager.GetList(filter);

    BXSefUrlRuleManager.BeginUpdate();

    BXSefUrlRule rule;
    if (col.Count != 0)
        rule = rules[0];
    else
    {
        BXSefUrlRule rule = new BXSefUrlRule();
        rule.ComponentName = Name;
        rule.Path = Request.AppRelativeCurrentExecutionFilePath;
        rule.HelperId = helperId;
        rule.SiteId = DesignerSite;
    }

    dir = VirtualPathUtility.GetDirectory(Request.AppRelativeCurrentExecutionFilePath);
    rule.MatchExpression = "^" + BXStringUtility.RegexEncode(dir) + @"/(?<action>[^\/\?]+)(?:/(?<id>[^\/\?]+))?/?(?:\?(?<query>.*))?" + "$";
    rule.ReplaceExpression = Request.AppRelativeCurrentExecutionFilePath + "?action=${action}&id=${id}&${query}";
    rule.Sort = 500;

    if (rule.Id == -1)
        BXSefUrlRuleManager.Add(rule);

    BXSefUrlRuleManager.EndUpdate();
}
}

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Свойство Sort

Свойство BXSefUrlRule..::.Sort
Класс BXSefUrlRule Пример Смотри также Send Feedback
Возвращает или устанавливает индекс сортировки для правила.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int Sort { get; set; }

Заметки

При обработке адреса, правила проверяются в порядке возрастания индекса сортировки.

Примеры

Регистрация компонентом правила обработки адреса:

CopyC#
class SomeComponent : BXComponent
{
    void RegisterRule()
{
    string helperId = "Component-" + ID;

    BXFormFilter filter = new BXFormFilter();
    filter.Add("SiteId", DesignerSite, BXSqlFilterOperators.Equal);
    filter.Add("ComponentName", Name, BXSqlFilterOperators.Equal);
    filter.Add("Path", Request.AppRelativeCurrentExecutionFilePath, BXSqlFilterOperators.Equal);
    filter.Add("HelperId", helperId, BXSqlFilterOperators.Equal);
    BXSefUrlRuleCollection rules =  BXSefUrlRuleManager.GetList(filter);

    BXSefUrlRuleManager.BeginUpdate();

    BXSefUrlRule rule;
    if (col.Count != 0)
        rule = rules[0];
    else
    {
        BXSefUrlRule rule = new BXSefUrlRule();
        rule.ComponentName = Name;
        rule.Path = Request.AppRelativeCurrentExecutionFilePath;
        rule.HelperId = helperId;
        rule.SiteId = DesignerSite;
    }

    dir = VirtualPathUtility.GetDirectory(Request.AppRelativeCurrentExecutionFilePath);
    rule.MatchExpression = "^" + BXStringUtility.RegexEncode(dir) + @"/(?<action>[^\/\?]+)(?:/(?<id>[^\/\?]+))?/?(?:\?(?<query>.*))?" + "$";
    rule.ReplaceExpression = Request.AppRelativeCurrentExecutionFilePath + "?action=${action}&id=${id}&${query}";
    rule.Sort = 500;

    if (rule.Id == -1)
        BXSefUrlRuleManager.Add(rule);

    BXSefUrlRuleManager.EndUpdate();
}
}

Смотри также

Класс BXSefUrlRule
Пространство имен Bitrix.Services


Класс BXSefUrlRuleCollection

Класс BXSefUrlRuleCollection
Члены Пример Смотри также Send Feedback
Хранит правила обработки адресов с учетом порядка.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXSefUrlRuleCollection : List<BXSefUrlRule>

Примеры

Выборка правил обработки адресов:

CopyC#
BXFormFilter filter = new BXFormFilter();
filter.Add("SiteId", BXSite.Current.Id, BXSqlFilterOperators.Equal);
filter.Add("ComponentName", "bitrix:news", BXSqlFilterOperators.Equal);

BXFormOrderBy orderBy = new BXFormOrderBy("Sort", "ASC", "Path", "ASC");

BXQueryParams queryParams = new BXQueryParams(new BXPagingOptions(5, 10));

BXSefUrlRuleCollection rules = BXSefUrlRuleManager.GetList(filter, orderBy, queryParams);
for (int i = 0; i < rules.Count; i++)
    rules[i].HelperId = "OrderedRule-" + i;
BXSefUrlRuleManager.Save();

Иерархия наследования

System..::..Object
System.Collections.Generic..::..List <(Of <(<' BXSefUrlRule >)>)>
Bitrix.Services..::..BXSefUrlRuleCollection

Смотри также

Члены BXSefUrlRuleCollection
Пространство имен Bitrix.Services


Члены BXSefUrlRuleCollection

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXSefUrlRuleCollection
Класс BXSefUrlRuleCollection Конструкторы Смотри также Send Feedback

Тип BXSefUrlRuleCollection предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXSefUrlRuleCollection | Создает новую коллекцию правил обработки адресов.

Смотри также

Класс BXSefUrlRuleCollection
Пространство имен Bitrix.Services


Конструктор BXSefUrlRuleCollection

Конструктор BXSefUrlRuleCollection
Класс BXSefUrlRuleCollection Смотри также Send Feedback
Создает новую коллекцию правил обработки адресов.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXSefUrlRuleCollection()

Смотри также

Класс BXSefUrlRuleCollection
Пространство имен Bitrix.Services


Класс BXSefUrlRuleManager

Класс BXSefUrlRuleManager
Члены Смотри также Send Feedback
Обеспечивает доступ к правилам обработки адресов (см. BXSefUrlRule).

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static class BXSefUrlRuleManager

Заметки

Хранение правил обработки адресов организовано по 2-х уровневой модели. Правила находятся во временном хранилище, которое позволяет быстро сделать нужную выборку и созраняются в постоянное хранилище, из которого они могут быть загружены при перезапуске приложения.

Иерархия наследования

System..::..Object
Bitrix.Services..::..BXSefUrlRuleManager

Смотри также

Члены BXSefUrlRuleManager
Пространство имен Bitrix.Services


Члены BXSefUrlRuleManager

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXSefUrlRuleManager
Класс BXSefUrlRuleManager Методы Свойства Смотри также Send Feedback

Тип BXSefUrlRuleManager предоставляет следующие возможности.

Методы

Имя | Описание
Add | Перегруженный.
BeginUpdate | Включает режим обновления постоянного хранилища.
Count | Перегруженный.
Delete | Перегруженный.
EndUpdate | Выключает режим обновления.
Get | Возвращает правило из временного хранилища по временному идентификатору.
GetList | Перегруженный.
GetRulesForSite | Перечисляет правила для конкретного сайта, упорядоченные по индексу сортировки.
Load | Загружает правила обработки адресов из постоянного хранилища во временное.
Save | Сохраняет изменившиеся правила из временного хранилища в постоянное.

Свойства

Имя | Описание
IsUpdating | Возвращает, находится ли постоянное хранилище в режиме обновления.

Смотри также

Класс BXSefUrlRuleManager
Пространство имен Bitrix.Services


Методы BXSefUrlRuleManager

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXSefUrlRuleManager
Класс BXSefUrlRuleManager Смотри также Send Feedback

Тип BXSefUrlRuleManager предоставляет следующие возможности.

Методы

Имя | Описание
Add | Перегруженный.
BeginUpdate | Включает режим обновления постоянного хранилища.
Count | Перегруженный.
Delete | Перегруженный.
EndUpdate | Выключает режим обновления.
Get | Возвращает правило из временного хранилища по временному идентификатору.
GetList | Перегруженный.
GetRulesForSite | Перечисляет правила для конкретного сайта, упорядоченные по индексу сортировки.
Load | Загружает правила обработки адресов из постоянного хранилища во временное.
Save | Сохраняет изменившиеся правила из временного хранилища в постоянное.

Смотри также

Класс BXSefUrlRuleManager
Пространство имен Bitrix.Services


Метод Add

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSefUrlRuleManager..::.Add
Класс BXSefUrlRuleManager Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Add(BXSefUrlRule) | Добавляет новое правило во временное хранилище.
Add(BXSefUrlRuleCollection) | Добавляет все правила из коллекции во временное хранилище.

Смотри также

Класс BXSefUrlRuleManager
Члены BXSefUrlRuleManager
Пространство имен Bitrix.Services


Метод Add (BXSefUrlRule)

Метод BXSefUrlRuleManager..::.Add (BXSefUrlRule)
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Добавляет новое правило во временное хранилище.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void Add(
    BXSefUrlRule rule
)

Параметры

rule
Type: Bitrix.Services..::..BXSefUrlRule
Правило обработки адреса.

Заметки

Правила, уже находящиеся во временном хранилище повторно добавлены не будут.

Если режим обновления не включен, то постоянное хранилище автоматически будет обновлено.

Примеры

Регистрация компонентом правила обработки адреса:

CopyC#
class SomeComponent : BXComponent
{
    void RegisterRule()
{
    string helperId = "Component-" + ID;

    BXFormFilter filter = new BXFormFilter();
    filter.Add("SiteId", DesignerSite, BXSqlFilterOperators.Equal);
    filter.Add("ComponentName", Name, BXSqlFilterOperators.Equal);
    filter.Add("Path", Request.AppRelativeCurrentExecutionFilePath, BXSqlFilterOperators.Equal);
    filter.Add("HelperId", helperId, BXSqlFilterOperators.Equal);
    BXSefUrlRuleCollection rules =  BXSefUrlRuleManager.GetList(filter);

    BXSefUrlRuleManager.BeginUpdate();

    BXSefUrlRule rule;
    if (col.Count != 0)
        rule = rules[0];
    else
    {
        BXSefUrlRule rule = new BXSefUrlRule();
        rule.ComponentName = Name;
        rule.Path = Request.AppRelativeCurrentExecutionFilePath;
        rule.HelperId = helperId;
        rule.SiteId = DesignerSite;
    }

    dir = VirtualPathUtility.GetDirectory(Request.AppRelativeCurrentExecutionFilePath);
    rule.MatchExpression = "^" + BXStringUtility.RegexEncode(dir) + @"/(?<action>[^\/\?]+)(?:/(?<id>[^\/\?]+))?/?(?:\?(?<query>.*))?" + "$";
    rule.ReplaceExpression = Request.AppRelativeCurrentExecutionFilePath + "?action=${action}&id=${id}&${query}";
    rule.Sort = 500;

    if (rule.Id == -1)
        BXSefUrlRuleManager.Add(rule);

    BXSefUrlRuleManager.EndUpdate();
}
}

Исключения

Исключение | Условие
System..::..ArgumentNullException | Возникает, если rule равен null.

Смотри также

Класс BXSefUrlRuleManager
Перегрузка Add
Пространство имен Bitrix.Services


Метод Add (BXSefUrlRuleCollection)

Метод BXSefUrlRuleManager..::.Add (BXSefUrlRuleCollection)
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Добавляет все правила из коллекции во временное хранилище.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void Add(
    BXSefUrlRuleCollection rules
)

Параметры

rules
Type: Bitrix.Services..::..BXSefUrlRuleCollection
Коллекция правил обработки адресов.

Заметки

Правила, уже находящиеся во временном хранилище повторно добавлены не будут.

Если режим обновления не включен, то постоянное хранилище автоматически будет обновлено.

Примеры

Копирование правил из одного сайта в другой:

CopyC#
string newSiteId;

BXFormFilter filter = new BXFormFilter();
filter.Add("SiteId", BXSite.Current.Id, BXSqlFilterOperators.Equal);

BXSefUrlRuleCollection rules = BXSefUrlRuleManager.GetList(filter);
for (int i = 0; i < rules.Count; i++)
{
    rules[i] = rules[i].Clone();
    rules[i].SiteId = newSiteId;
}
BXSefUrlRuleManager.Add(rules);

Исключения

Исключение | Условие
System..::..ArgumentNullException | Возникает, если rules равен null.

Смотри также

Класс BXSefUrlRuleManager
Перегрузка Add
Пространство имен Bitrix.Services


Метод BeginUpdate

Метод BXSefUrlRuleManager..::.BeginUpdate
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Включает режим обновления постоянного хранилища.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void BeginUpdate()

Заметки

В режиме обновления изменение свойств правил из временного хранилища не вызывает обновления постоянного хранилища. Сохранение правил в постоянное хранилище происходит при выходе из режима обновления.

При вызове метода изменяется счетчик режима обновлений, что позволяет делать вложенные вызовы методов BeginUpdate()()()() и EndUpdate()()()().

Примеры

Регистрация компонентом правила обработки адреса:

CopyC#
class SomeComponent : BXComponent
{
    void RegisterRule()
{
    string helperId = "Component-" + ID;

    BXFormFilter filter = new BXFormFilter();
    filter.Add("SiteId", DesignerSite, BXSqlFilterOperators.Equal);
    filter.Add("ComponentName", Name, BXSqlFilterOperators.Equal);
    filter.Add("Path", Request.AppRelativeCurrentExecutionFilePath, BXSqlFilterOperators.Equal);
    filter.Add("HelperId", helperId, BXSqlFilterOperators.Equal);
    BXSefUrlRuleCollection rules =  BXSefUrlRuleManager.GetList(filter);

    BXSefUrlRuleManager.BeginUpdate();

    BXSefUrlRule rule;
    if (col.Count != 0)
        rule = rules[0];
    else
    {
        BXSefUrlRule rule = new BXSefUrlRule();
        rule.ComponentName = Name;
        rule.Path = Request.AppRelativeCurrentExecutionFilePath;
        rule.HelperId = helperId;
        rule.SiteId = DesignerSite;
    }

    dir = VirtualPathUtility.GetDirectory(Request.AppRelativeCurrentExecutionFilePath);
    rule.MatchExpression = "^" + BXStringUtility.RegexEncode(dir) + @"/(?<action>[^\/\?]+)(?:/(?<id>[^\/\?]+))?/?(?:\?(?<query>.*))?" + "$";
    rule.ReplaceExpression = Request.AppRelativeCurrentExecutionFilePath + "?action=${action}&id=${id}&${query}";
    rule.Sort = 500;

    if (rule.Id == -1)
        BXSefUrlRuleManager.Add(rule);

    BXSefUrlRuleManager.EndUpdate();
}
}

Смотри также

Класс BXSefUrlRuleManager
Пространство имен Bitrix.Services


Метод Count

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSefUrlRuleManager..::.Count
Класс BXSefUrlRuleManager Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Count()()()() | Подсчитывает количество правил, расположенных во временном хранилище.
Count(BXFormFilter) | Подсчитывает количество правил, расположенных во временном хранилище, удовлетворяющих заданному фильтру.

Смотри также

Класс BXSefUrlRuleManager
Члены BXSefUrlRuleManager
Пространство имен Bitrix.Services


Метод Count

Метод BXSefUrlRuleManager..::.Count
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Подсчитывает количество правил, расположенных во временном хранилище.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static int Count()

Возвращаемое значение

Количество правил во временном хранилище.

Примеры

Подсчет количества страниц в выборке по фильтру:

CopyC#
int perPage = 10;

BXFormFilter filter = new BXFormFilter();
filter.Add("SiteId", BXSite.Current.Id, BXSqlFilterOperators.Equal);

int total = BXSefUrlRuleManager.Count(filter);

int pages = total != 0 ? ((total - 1) / perPage + 1) : 0;

Смотри также

Класс BXSefUrlRuleManager
Перегрузка Count
Пространство имен Bitrix.Services


Метод Count ()

Метод BXSefUrlRuleManager..::.Count ()
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Подсчитывает количество правил, расположенных во временном хранилище, удовлетворяющих заданному фильтру.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static int Count(
    BXFormFilter filter
)

Параметры

filter
Type: BXFormFilter
Фильтр правил. Может быть равен null.

Возвращаемое значение

Количество правил во временном хранилище.

Примеры

Подсчет количества страниц в выборке по фильтру:

CopyC#
int perPage = 10;

BXFormFilter filter = new BXFormFilter();
filter.Add("SiteId", BXSite.Current.Id, BXSqlFilterOperators.Equal);

int total = BXSefUrlRuleManager.Count(filter);

int pages = total != 0 ? ((total - 1) / perPage + 1) : 0;

Смотри также

Класс BXSefUrlRuleManager
Перегрузка Count
Пространство имен Bitrix.Services


Метод Delete

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSefUrlRuleManager..::.Delete
Класс BXSefUrlRuleManager Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Delete(BXFormFilter) | Удаляет правило из временного хранилища.
Delete(BXSefUrlRule) | Удаляет правило из временного хранилища.

Смотри также

Класс BXSefUrlRuleManager
Члены BXSefUrlRuleManager
Пространство имен Bitrix.Services


Метод Delete ()

Метод BXSefUrlRuleManager..::.Delete ()
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Удаляет правило из временного хранилища.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static int Delete(
    BXFormFilter filter
)

Параметры

filter
Type: BXFormFilter
Фильтр правил обработки адресов. Может быть равен null.

Возвращаемое значение

Количество удаленных правил из временного хранилища.

Заметки

Если режим обновления не включен, то постоянное хранилище автоматически будет обновлено.

Примеры

Удаление компонентом правил обработки адресов:

CopyC#
class SomeComponent : BXComponent
{
    void UnregisterRule()
    {
        string helperId = "Component-" + ID;

        BXFormFilter filter = new BXFormFilter();
        filter.Add("SiteId", DesignerSite, BXSqlFilterOperators.Equal);
        filter.Add("ComponentName", Name, BXSqlFilterOperators.Equal);
        filter.Add("Path", Request.AppRelativeCurrentExecutionFilePath, BXSqlFilterOperators.Equal);
        filter.Add("HelperId", helperId, BXSqlFilterOperators.Equal);

        BXSefUrlRuleManager.Delete(filter);
    }
}

Смотри также

Класс BXSefUrlRuleManager
Перегрузка Delete
Пространство имен Bitrix.Services


Метод Delete (BXSefUrlRule)

Метод BXSefUrlRuleManager..::.Delete (BXSefUrlRule)
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Удаляет правило из временного хранилища.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static int Delete(
    BXSefUrlRule rule
)

Параметры

rule
Type: Bitrix.Services..::..BXSefUrlRule
Правило обработки адреса.

Возвращаемое значение

Количество удаленных правил из временного хранилища (1 - если правило было удалено, 0 - если нет).

Заметки

Если режим обновления не включен, то постоянное хранилище автоматически будет обновлено.

Примеры

Удаление правил, которые обрабатывабт заданный адрес:

CopyC#
string virtualPath = "~/foo/bar/";

BXSefUrlRuleManager.BeginUpdate();

foreach (BXSefUrlRule rule in BXSefUrlRuleManager.GetList())
    if (rule.MatchRegex.IsMatch(virtualPath))
        BXSefUrlRuleManager.Delete(rule);

BXSefUrlRuleManager.EndUpdate();

Исключения

Исключение | Условие
System..::..ArgumentNullException | Возникает, если rule равен null.

Смотри также

Класс BXSefUrlRuleManager
Перегрузка Delete
Пространство имен Bitrix.Services


Метод EndUpdate

Метод BXSefUrlRuleManager..::.EndUpdate
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Выключает режим обновления.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void EndUpdate()

Заметки

В режиме обновления изменение свойств правил из временного хранилища не вызывает обновления постоянного хранилища. Сохранение правил в постоянное хранилище происходит при выходе из режима обновления.

При вызове метода изменяется счетчик режима обновлений, что позволяет делать вложенные вызовы методов BeginUpdate()()()() и EndUpdate()()()().

Примеры

Регистрация компонентом правила обработки адреса:

CopyC#
class SomeComponent : BXComponent
{
    void RegisterRule()
{
    string helperId = "Component-" + ID;

    BXFormFilter filter = new BXFormFilter();
    filter.Add("SiteId", DesignerSite, BXSqlFilterOperators.Equal);
    filter.Add("ComponentName", Name, BXSqlFilterOperators.Equal);
    filter.Add("Path", Request.AppRelativeCurrentExecutionFilePath, BXSqlFilterOperators.Equal);
    filter.Add("HelperId", helperId, BXSqlFilterOperators.Equal);
    BXSefUrlRuleCollection rules =  BXSefUrlRuleManager.GetList(filter);

    BXSefUrlRuleManager.BeginUpdate();

    BXSefUrlRule rule;
    if (col.Count != 0)
        rule = rules[0];
    else
    {
        BXSefUrlRule rule = new BXSefUrlRule();
        rule.ComponentName = Name;
        rule.Path = Request.AppRelativeCurrentExecutionFilePath;
        rule.HelperId = helperId;
        rule.SiteId = DesignerSite;
    }

    dir = VirtualPathUtility.GetDirectory(Request.AppRelativeCurrentExecutionFilePath);
    rule.MatchExpression = "^" + BXStringUtility.RegexEncode(dir) + @"/(?<action>[^\/\?]+)(?:/(?<id>[^\/\?]+))?/?(?:\?(?<query>.*))?" + "$";
    rule.ReplaceExpression = Request.AppRelativeCurrentExecutionFilePath + "?action=${action}&id=${id}&${query}";
    rule.Sort = 500;

    if (rule.Id == -1)
        BXSefUrlRuleManager.Add(rule);

    BXSefUrlRuleManager.EndUpdate();
}
}

Смотри также

Класс BXSefUrlRuleManager
Пространство имен Bitrix.Services


Метод Get

Метод BXSefUrlRuleManager..::.Get
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Возвращает правило из временного хранилища по временному идентификатору.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXSefUrlRule Get(
    int id
)

Параметры

id
Type: System..::..Int32

Возвращаемое значение

Правило обработки адреса или null, если правило не было найдено.

Примеры

Изменение правила обработки адреса:

CopyC#
int id;

BXSefUrlRule rule = BXSefUrlRuleManager.Get(id);
if (rule != null)
    rule.HelperId = rule.Id.ToString();
BXSefUrlRuleManager.Save();

Смотри также

Класс BXSefUrlRuleManager
Пространство имен Bitrix.Services


Метод GetList

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXSefUrlRuleManager..::.GetList
Класс BXSefUrlRuleManager Смотри также Send Feedback

Лист перегрузки

Имя | Описание
GetList()()()() | Возвращает список правил всех правил из временного хранилища.
GetList(BXFormFilter) | Возвращает список правил из временного хранилища, выбранных по фильтру.
GetList(BXFormFilter, BXFormOrderBy) | Возвращает упорядоченный список правил из временного хранилища, выбранных по фильтру.
GetList(BXFormFilter, BXFormOrderBy, BXQueryParams) | Возвращает упорядоченный список правил из временного хранилища, выбранных по фильтру и дополнительныи параметрам.

Смотри также

Класс BXSefUrlRuleManager
Члены BXSefUrlRuleManager
Пространство имен Bitrix.Services


Метод GetList

Метод BXSefUrlRuleManager..::.GetList
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Возвращает список правил всех правил из временного хранилища.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXSefUrlRuleCollection GetList()

Возвращаемое значение

Коллекция правил обработки адресов.

Примеры

Удаление правил, которые обрабатывабт заданный адрес:

CopyC#
string virtualPath = "~/foo/bar/";

BXSefUrlRuleManager.BeginUpdate();

foreach (BXSefUrlRule rule in BXSefUrlRuleManager.GetList())
    if (rule.MatchRegex.IsMatch(virtualPath))
        BXSefUrlRuleManager.Delete(rule);

BXSefUrlRuleManager.EndUpdate();

Смотри также

Класс BXSefUrlRuleManager
Перегрузка GetList
Пространство имен Bitrix.Services


Метод GetList ()

Метод BXSefUrlRuleManager..::.GetList ()
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Возвращает список правил из временного хранилища, выбранных по фильтру.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXSefUrlRuleCollection GetList(
    BXFormFilter filter
)

Параметры

filter
Type: BXFormFilter
Фильтр правил. Может быть равен null.

Возвращаемое значение

Коллекция правил обработки адресов.

Примеры

Копирование правил из одного сайта в другой:

CopyC#
string newSiteId;

BXFormFilter filter = new BXFormFilter();
filter.Add("SiteId", BXSite.Current.Id, BXSqlFilterOperators.Equal);

BXSefUrlRuleCollection rules = BXSefUrlRuleManager.GetList(filter);
for (int i = 0; i < rules.Count; i++)
{
    rules[i] = rules[i].Clone();
    rules[i].SiteId = newSiteId;
}
BXSefUrlRuleManager.Add(rules);

Смотри также

Класс BXSefUrlRuleManager
Перегрузка GetList
Пространство имен Bitrix.Services


Метод GetList (, )

Метод BXSefUrlRuleManager..::.GetList (, )
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Возвращает упорядоченный список правил из временного хранилища, выбранных по фильтру.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXSefUrlRuleCollection GetList(
    BXFormFilter filter,
    BXFormOrderBy sort
)

Параметры

filter
Type: BXFormFilter
Фильтр правил. Может быть равен null.
sort
Type: BXFormOrderBy
Порядок сортировки. Может быть равен null.

Возвращаемое значение

Коллекция правил обработки адресов.

Примеры

Выборка правил обработки адресов:

CopyC#
BXFormFilter filter = new BXFormFilter();
filter.Add("SiteId", BXSite.Current.Id, BXSqlFilterOperators.Equal);
filter.Add("ComponentName", "bitrix:news", BXSqlFilterOperators.Equal);

BXFormOrderBy orderBy = new BXFormOrderBy("Sort", "ASC", "Path", "ASC");

BXQueryParams queryParams = new BXQueryParams(new BXPagingOptions(5, 10));

BXSefUrlRuleCollection rules = BXSefUrlRuleManager.GetList(filter, orderBy, queryParams);
for (int i = 0; i < rules.Count; i++)
    rules[i].HelperId = "OrderedRule-" + i;
BXSefUrlRuleManager.Save();

Смотри также

Класс BXSefUrlRuleManager
Перегрузка GetList
Пространство имен Bitrix.Services


Метод GetList (, , BXQueryParams)

Метод BXSefUrlRuleManager..::.GetList (, , BXQueryParams)
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Возвращает упорядоченный список правил из временного хранилища, выбранных по фильтру и дополнительныи параметрам.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static BXSefUrlRuleCollection GetList(
    BXFormFilter filter,
    BXFormOrderBy sort,
    BXQueryParams queryParams
)

Параметры

filter
Type: BXFormFilter
Фильтр правил. Может быть равен null.
sort
Type: BXFormOrderBy
Порядок сортировки. Может быть равен null.
queryParams
Type: Bitrix.DataLayer..::..BXQueryParams
Особые параметры запроса. Может быть равен null.

Возвращаемое значение

Коллекция правил обработки адресов.

Примеры

Выборка правил обработки адресов:

CopyC#
BXFormFilter filter = new BXFormFilter();
filter.Add("SiteId", BXSite.Current.Id, BXSqlFilterOperators.Equal);
filter.Add("ComponentName", "bitrix:news", BXSqlFilterOperators.Equal);

BXFormOrderBy orderBy = new BXFormOrderBy("Sort", "ASC", "Path", "ASC");

BXQueryParams queryParams = new BXQueryParams(new BXPagingOptions(5, 10));

BXSefUrlRuleCollection rules = BXSefUrlRuleManager.GetList(filter, orderBy, queryParams);
for (int i = 0; i < rules.Count; i++)
    rules[i].HelperId = "OrderedRule-" + i;
BXSefUrlRuleManager.Save();

Смотри также

Класс BXSefUrlRuleManager
Перегрузка GetList
Пространство имен Bitrix.Services


Метод GetRulesForSite

Метод BXSefUrlRuleManager..::.GetRulesForSite
Класс BXSefUrlRuleManager Пример Смотри также Send Feedback
Перечисляет правила для конкретного сайта, упорядоченные по индексу сортировки.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static IEnumerable<BXSefUrlRule> GetRulesForSite(
    string siteId
)

Параметры

siteId
Type: System..::..String
Идентификатор сайта.

Возвращаемое значение

IEnumerable<(Of <(<'T>)>)>, который перечисляет правила обработки адресов (см. BXSefUrlRule).

Заметки

Метод оптимизирован для быстрой выборки правил обработки адресов, принадлежащих определенному сайту в порядке, заданном индексом сортировки.

Примеры

Поиск совпавшего правила для обработки текущего запроса:

CopyC#
BXSefUrlRule FindMatch()
{
    foreach (BXSefUrlRule rule in BXSefUrlRuleManager.GetRulesForSite(BXSite.Current.Id))
        if (rule.MatchRegex.IsMatch(HttpContext.Current.Request.AppRelativeCurrentExecutionFilePath))
            return rule;

    return null;
}

Исключения

Исключение | Условие
System..::..ArgumentNullException | Возникает, если siteId равен null.

Смотри также

Класс BXSefUrlRuleManager
Пространство имен Bitrix.Services


Метод Load

Метод BXSefUrlRuleManager..::.Load
Класс BXSefUrlRuleManager Смотри также Send Feedback
Загружает правила обработки адресов из постоянного хранилища во временное.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void Load()

Заметки

При загрузке правила, ранее находившиеся во временном хранилище удаляются из него, а их временные идентификаторы (см. Id) выставляются в "-1".

Загруженные правила будут иметь временные идентификаторы (см. Id), которые не обязательно будут совпадать с идентификаторами предыдущих правил.

Смотри также

Класс BXSefUrlRuleManager
Пространство имен Bitrix.Services


Метод Save

Метод BXSefUrlRuleManager..::.Save
Класс BXSefUrlRuleManager Смотри также Send Feedback
Сохраняет изменившиеся правила из временного хранилища в постоянное.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static void Save()

Заметки

Метод не гарантирует сохранения всех правил, находящихся во временном хранилище. Гарантировано будут записаны все изменившиеся, добавленные или удаленные правила.

Смотри также

Класс BXSefUrlRuleManager
Пространство имен Bitrix.Services


Свойства BXSefUrlRuleManager

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXSefUrlRuleManager
Класс BXSefUrlRuleManager Смотри также Send Feedback

Тип BXSefUrlRuleManager предоставляет следующие возможности.

Свойства

Имя | Описание
IsUpdating | Возвращает, находится ли постоянное хранилище в режиме обновления.

Смотри также

Класс BXSefUrlRuleManager
Пространство имен Bitrix.Services


Свойство IsUpdating

Свойство BXSefUrlRuleManager..::.IsUpdating
Класс BXSefUrlRuleManager Смотри также Send Feedback
Возвращает, находится ли постоянное хранилище в режиме обновления.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static bool IsUpdating { get; }

Заметки

При выходе из режима обновления происходит сохранение правил в постоянное хранилище.

Смотри также

Класс BXSefUrlRuleManager
Пространство имен Bitrix.Services


Интерфейс IBXAgentExecutor

Интерфейс IBXAgentExecutor
Члены Смотри также Send Feedback
Интерфейс исполнителя агента. Содержит код, подлежащий исполнению при запуске агента.

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public interface IBXAgentExecutor

Смотри также

Члены IBXAgentExecutor
Пространство имен Bitrix.Services


Члены IBXAgentExecutor

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены IBXAgentExecutor
Интерфейс IBXAgentExecutor Методы Смотри также Send Feedback

Тип IBXAgentExecutor предоставляет следующие возможности.

Методы

Имя | Описание
Execute | Обработчик агента

Смотри также

Интерфейс IBXAgentExecutor
Пространство имен Bitrix.Services


Методы IBXAgentExecutor

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы IBXAgentExecutor
Интерфейс IBXAgentExecutor Смотри также Send Feedback

Тип IBXAgentExecutor предоставляет следующие возможности.

Методы

Имя | Описание
Execute | Обработчик агента

Смотри также

Интерфейс IBXAgentExecutor
Пространство имен Bitrix.Services


Метод Execute

Метод IBXAgentExecutor..::.Execute
Интерфейс IBXAgentExecutor Смотри также Send Feedback
Обработчик агента

Пространство имен: Bitrix.Services
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
bool Execute(
    BXSchedulerAgent agent,
    BXParamsBag<Object> parameters
)

Параметры

agent
Type: Bitrix.Services..::..BXSchedulerAgent
Агент, который вызвал исполнителя
parameters
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь входных параметров, задается разработчиком при регистрации агента

Возвращаемое значение

Производить ли дальнейшую обработку агента

Заметки

Если в ходе отработки агент был удален, необходимо вернуть false, в противном случае необходимо вернуть true, чтобы рассчитать время следующего запуска и поставить агента в очередь на исполнение.

Смотри также

Интерфейс IBXAgentExecutor
Пространство имен Bitrix.Services


Пространство имен Bitrix.Services.Text

Пространство имен Bitrix.Services.Text
Send Feedback
Содержит набор утилит для работы с текстом.

Перечисления

Перечисление | Описание
BXTextType | Содержит список допустимых представлений текстовых данных.


Перечисление BXTextType

Перечисление BXTextType
Смотри также Send Feedback
Содержит список допустимых представлений текстовых данных.

Пространство имен: Bitrix.Services.Text
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public enum BXTextType

Члены

Название члена | Описание
Text | Простой текст. Данные, представленные в виде простого текста должны кодироваться перед выводом в HTML.
Html | HTML.

Смотри также

Пространство имен Bitrix.Services.Text


Пространство имен Bitrix.UI

Пространство имен Bitrix.UI
Send Feedback
Содержит классы, обеспечивающие работу с документной моделью WebForms ASP.NET

Классы

Класс | Описание
BXComponent | Базовый класс для всех компонентов в системе
BXComponentTemplate | Базовый класс для шаблона компонента
BXComponentTemplate<(Of <(<'T>)>)> | Обобщенный базовый класс для шаблона компонента

Структуры

Структура | Описание
BXComponent..::..BXPagingParams | Содержит входные параметры постраничного разбиения

Делегаты

Делегат | Описание
BXComponent..::..GetTotalCountMethod | Делегат для подсчета количества элементов в источнике данных


Класс BXComponent

Класс BXComponent
Члены Пример Смотри также Send Feedback
Базовый класс для всех компонентов в системе

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXComponent : BXControl

Примеры

Компонент выбора сайта:

CopyC#
public partial class SiteSelector : BXComponent
{
    List<SiteInfo> siteInfos = new List<SiteInfo>();
    protected void Page_Load(object sender, EventArgs e)
    {
        BXSiteCollection sites = BXSite.GetList(null, null);
        foreach (BXSite site in sites)
        {
            SiteInfo siteInfo = new SiteInfo();

            siteInfo.directory = site.Directory;
            siteInfo.id = site.Id;
            siteInfo.name = site.SiteName;
            siteInfo.isSelected = BXSite.Current != null && string.Equals(BXSite.Current.Id, site.Id, StringComparison.InvariantCultureIgnoreCase);
            siteInfo.domains = BXSiteDomain.GetList(new BXFilter(new BXFilterItem(BXSiteDomain.Fields.ID, BXSqlFilterOperators.Equal, site.Id)), null).ConvertAll<string>(delegate(BXSiteDomain input) { return input.Domain; });

            siteInfos.Add(siteInfo);
        }

        IncludeComponentTemplate();
    }

    protected override void PreLoadComponentDefinition()
    {
        Title = GetMessage("Выбор сайта");
        Description = GetMessage("Позволяет сменить сайт и показывает текущий сайт");
        Icon = "images/selector.gif";
    }

    public class SiteInfo
    {
        internal string id;
        internal string name;
        internal string directory;
        internal bool isSelected;
        internal List<string> domains;

        public string Id
        {
            get
            {
                return id;
            }
        }
        public string Name
        {
            get
            {
                return name;
            }
        }
        public string Directory
        {
            get
            {
                return directory;
            }
        }
        public bool IsSelected
        {
            get
            {
                return isSelected;
            }
        }
        public ReadOnlyCollection<string> Domains
        {
            get
            {
                return domains.AsReadOnly();
            }
        }

        internal SiteInfo()
        {

        }
    }

    public new class Template : BXComponentTemplate<SiteSelector>
    {
        public ReadOnlyCollection<SiteInfo> Sites
        {
            get
            {
                return Component.siteInfos.AsReadOnly();
            }
        }
    }
}

Иерархия наследования

System..::..Object
System.Web.UI..::..Control
System.Web.UI..::..TemplateControl
System.Web.UI..::..UserControl
BXControl
Bitrix.UI..::..BXComponent

Смотри также

Члены BXComponent
Пространство имен Bitrix.UI


Члены BXComponent

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXComponent
Класс BXComponent Конструкторы Методы Свойства События Смотри также Send Feedback

Тип BXComponent предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXComponent | Создает новый экземпляр компонента.

Методы

Имя | Описание
AbortCache | Отменяет кеширование компонента для текущего запроса
AddedControl | (Переопределяет Control..::..AddedControl(Control, Int32))
ClearCache | Принудительно очищает кеш компонента
CombineLink | Конструирование ссылки из нескольких частей c формированием абсолютного пути
CreatePublicPanelMenu | Создает кнопки в публичной верхней панели.
EnsureComponentDefinition | Перегруженный.
ForceLoadComponentDefinition | Вызывает заполнение расширенных определений параметров компонента. Предназначен для вызова из редакторов.
ForceLoadTemplateDefinition |
ForcePreLoadComponentDefinition | Перегруженный.
ForcePreLoadTemplateDefinition |
GetCacheOutput |
IncludeComponentTemplate | Перегруженный.
IsCached | Проверяет, закеширован ли компонент и загружает данные из кеша
LoadComponentDefinition | Переопределив этот метод, можно добавить произвольный параметр в компонент или расширить определение уже существующих параметров.
MakeLink | Перегруженный.
Map | Перегруженный.
MapVariable | Перегруженный.
OnPreRender | (Переопределяет Control..::..OnPreRender(EventArgs))
PopulatePublicPanelMenu | Наполняет кнопки в публичной верхней панели опциями.
PreLoadComponentDefinition | Переопределив этот метод, можно добавить произвольный параметр в компонент.
PrepareCacheKey |
PreparePaging | Перегруженный.
PreparePagingParams | Перегруженный.
ProcessCommand | Обрабатывает команду, пришедшую из шаблона компонента.
ProcessMessage | Обрабатывает событие системы. Может быть вызвано вне контекста исполнения.
RedirectTemplateUrl |
Render | (Переопределяет Control..::..Render(HtmlTextWriter))
ResetParameters | Сбрасывает параметры на установки по умолчанию
ResolvePagingHelper | Перегруженный.
ResolveTemplateUrl |
ResolveTemplateUrlDelegate |
SetCacheOutput |
SetParameterValue |

Свойства

Имя | Описание
BaseCacheKey |
CacheDuration | Возвращает или устанавливает продолжительность кеширования компонента в секундах для значения Custom свойства CacheMode.
CacheKey |
CacheMode | Возвращает или устанавливает режим кеширования компонента.
Component | Компонент, который является родителем данного компонента, если компонент является частью комплексного компонента
ComponentCache | Возвращает словарь, в который компонент может помещать результаты выполнения своего кода для дальнейшего кеширования.
ComponentRoot | Абсолютный путь к папке, в которой лежит файл компонента. Без символа '/' на конце.
ComponentTemplate | Возвращает подключенный к компоненту шаблон.
DefaultTemplatePage |
Description | Описание компонента.
DesignerLang | Возвращает текущий язык, в контексте которого работает компонент. Поддерживается также в режиме визуального редактора.
DesignerSite | Возвращает текущий сайт, в контексте которого работает компонент. Поддерживается также в режиме визуального редактора.
DesignerUrl |
EnableSef | Возвращает, включен ли режим ЧПУ компонента.
Group | Группа, в которой располагается компонент в панели компонентов визуального редактора
Icon | Иконка компонента в тулбаре. Путь указывается относительно папки, в которой находится компонент. Если требуется задать путь к иконке относительно корня приложения, то первым символом в ссылке должен быть "~/"
IsComponentDefinitionDirty | Возвращает, необходима ли перегрузка определений параметров компонента.
IsComponentDesignMode | Возвращает, находится ли компонент в режиме визуального редактора и должен ли быть отображен особенным образом.
IsRenderedFromCache | Флаг отрисовки компонента из кеша
Name | Системное имя компонента. Например, для компонента меню это свойство вернет bitrix:system.PublicMenu
Note | Заметка про компонент.
Paging |
Parameters | Параметры компонента.
ParamsDefinition | Возвращает словарь параметров компонента и их описаний.
PopupMenuInfo | Возвращает описание контекстного меню компонента для режимов Редактора и Разработчика сайта.
Results | Устаревший. В этот словарь компонент может помещать результаты выполнения своего кода.
Root | Абсолютный путь к корню веб-приложения. Заменяет символ ~. Без символа '/' на конце.
SortIndex | Индекс сортировки
Template | Имя шаблона компонента.
TemplateFolder | Возвращает виртуальный путь к папке с шаблоном компонента. Оканчивается на "/".
TemplatePath | Возвращает виртуальный путь к шаблону компонента
Title | Название компонента, которое отображается в режиме редактирования.

События

Имя | Описание
TemplateIncluded | Срабатывает после того, как компонент подключил свой шаблон.

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Конструктор BXComponent

Конструктор BXComponent
Класс BXComponent Смотри также Send Feedback
Создает новый экземпляр компонента.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXComponent()

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Методы BXComponent

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXComponent
Класс BXComponent Смотри также Send Feedback

Тип BXComponent предоставляет следующие возможности.

Методы

Имя | Описание
AbortCache | Отменяет кеширование компонента для текущего запроса
AddedControl | (Переопределяет Control..::..AddedControl(Control, Int32))
ClearCache | Принудительно очищает кеш компонента
CombineLink | Конструирование ссылки из нескольких частей c формированием абсолютного пути
CreatePublicPanelMenu | Создает кнопки в публичной верхней панели.
EnsureComponentDefinition | Перегруженный.
ForceLoadComponentDefinition | Вызывает заполнение расширенных определений параметров компонента. Предназначен для вызова из редакторов.
ForceLoadTemplateDefinition |
ForcePreLoadComponentDefinition | Перегруженный.
ForcePreLoadTemplateDefinition |
GetCacheOutput |
IncludeComponentTemplate | Перегруженный.
IsCached | Проверяет, закеширован ли компонент и загружает данные из кеша
LoadComponentDefinition | Переопределив этот метод, можно добавить произвольный параметр в компонент или расширить определение уже существующих параметров.
MakeLink | Перегруженный.
Map | Перегруженный.
MapVariable | Перегруженный.
OnPreRender | (Переопределяет Control..::..OnPreRender(EventArgs))
PopulatePublicPanelMenu | Наполняет кнопки в публичной верхней панели опциями.
PreLoadComponentDefinition | Переопределив этот метод, можно добавить произвольный параметр в компонент.
PrepareCacheKey |
PreparePaging | Перегруженный.
PreparePagingParams | Перегруженный.
ProcessCommand | Обрабатывает команду, пришедшую из шаблона компонента.
ProcessMessage | Обрабатывает событие системы. Может быть вызвано вне контекста исполнения.
RedirectTemplateUrl |
Render | (Переопределяет Control..::..Render(HtmlTextWriter))
ResetParameters | Сбрасывает параметры на установки по умолчанию
ResolvePagingHelper | Перегруженный.
ResolveTemplateUrl |
ResolveTemplateUrlDelegate |
SetCacheOutput |
SetParameterValue |

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод AbortCache

Метод BXComponent..::.AbortCache
Класс BXComponent Пример Смотри также Send Feedback
Отменяет кеширование компонента для текущего запроса

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void AbortCache()

Заметки

В компонентах, которые используют кеширование важно, с точки зрения безопасности, производить кеширование только при валидных входных параметрах - иначе злоумышленник сможет создать на сайте большое количество файлов кеша, и переполнить доступное файловое пространство или замедлить работу файловой сиситемы.

Примеры

Выборка элементов инфоблока с кешированием и постраничным разбиением:
CopyC#
BXPagingParams pagingParams = PreparePagingParams(
    Parameters.Get("PageID", HttpContext.Current.Request.QueryString["page"]),
    Parameters.Get("PageShowAll", HttpContext.Current.Request.QueryString["showall"] != null)
);

if (!IsCached(pagingParams))
{
    BXFilter elementFilter;
    BXOrderBy elementOrder;

    ...

    bool isLegalPage;
    BXQueryParams queryParams = PreparePaging(
        pagingParams,
        delegate
        {
            return BXIBlockElement.Count(elementFilter);
        },
        new BXParamsBag<object>(),
        "PageID",
        Parameters.Get<string>("UrlTemplatesNews", Request.FilePath),
        Parameters.Get<string>("UrlTemplatesNewsPage", "?page=#PageID#"),
        Parameters.Get<string>("UrlTemplatesNewsShowAll", "?showall="),
        out isLegalPage
    );
    if (!isLegalPage)
        AbortCache();
    BXIBlockElementCollection items = BXIBlockElement.GetList(elementFilter, elementOrder, null, queryParams);
    ComponentCache["Items"] = items;

    ...

}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод AddedControl

Метод BXComponent..::.AddedControl
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override void AddedControl(
    Control control,
    int index
)

Параметры

control
Type: System.Web.UI..::..Control
index
Type: System..::..Int32

Заметки

Переопределение этого метода позволяет избавиться от ошибки отрисовки контролов, если коллекция контролов блокируется.

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод ClearCache

Метод BXComponent..::.ClearCache
Класс BXComponent Пример Смотри также Send Feedback
Принудительно очищает кеш компонента

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void ClearCache()

Примеры

Подписка на событие очистки кеша компонентов страницы:

CopyC#
protected override void OnInit(EventArgs e)
{
    base.OnInit(e);

    BXHitEvent.Register("Bitrix.Main.BXPublicPanel.RefreshComponentCache", RefreshComponentCache);
}

private void RefreshComponentCache(BXCommand command)
{
    ClearCache();
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод CombineLink

Метод BXComponent..::.CombineLink
Класс BXComponent Пример Смотри также Send Feedback
Конструирование ссылки из нескольких частей c формированием абсолютного пути

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string CombineLink(
    string root,
    string template
)

Параметры

root
Type: System..::..String
Путь к папке ЧПУ относительно корня приложения
template
Type: System..::..String
Шаблон ЧПУ

Возвращаемое значение

Сформированная абсолютная ссылка

Заметки

Можно также использовать BXUri.Combine

Примеры

CopyC#
BXParamsBag<object> replaceItems = new BXParamsBag<object>();
replaceItems["SectionId"] = Results.Get<string>("SectionId", "");
ComponentCache["UrlTemplatesNews"] = CombineLink(SefFolder, MakeLink(SefSection, replaceItems));

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI
BXUri


Метод CreatePublicPanelMenu

Метод BXComponent..::.CreatePublicPanelMenu
Класс BXComponent Пример Смотри также Send Feedback
Создает кнопки в публичной верхней панели.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual void CreatePublicPanelMenu(
    BXPublicPanelMenuSectionList sectionList
)

Параметры

sectionList
Type: BXPublicPanelMenuSectionList
Список секций в публичной верхней панели.

Заметки

Предназначен для переопределения в компонентах.

Примеры

Создание отдельной секции для инфоблоков в публичной верхней панели, добавление в секцию кнопки и наполнение списка доступных действий:
CopyC#
private string IBlockListSectionId
{
    get
    {
        return "IBlockListMenuSection";
    }
}

private string IBlockListButtonMenuId
{
    get
    {
        return String.Format("IBlockListButtonMenu_{0}", IBlockId);
    }
}

private BXPopupMenuItem[] GetMenuItems()
{
    BXPopupMenuItem[] menuItems = new BXPopupMenuItem[1];

    menuItems[0] = new BXPopupMenuItem();
    menuItems[0].BackgroundImagePath = BXPath.Combine(BXComponentManager.GetFolder(Name), "/images/new_element.gif");
    menuItems[0].ID = String.Format("element_new_{0}", IBlockId);
    menuItems[0].Text = String.Format(GetMessageRaw("AddNewElement"), String.IsNullOrEmpty(IBlockElementName) ? GetMessageRaw("IBlockElementName") : IBlockElementName.ToLower());
    menuItems[0].ClientClickScript =
        String.Format(
            "jsUtils.Redirect(arguments, '{0}?iblock_id={1}&type_id={2}&{3}={4}')",
            VirtualPathUtility.ToAbsolute("~/bitrix/admin/IBlockElementEdit.aspx"),
            IBlockId,
            IBlockTypeId,
            BXConfigurationUtility.Constants.BackUrl,
            UrlEncode(BXSefUrlManager.CurrentUrl.PathAndQuery)
        );

    return menuItems;
}

public override void CreatePublicPanelMenu(BXPublicPanelMenuSectionList sectionList)
{
    if (sectionList == null)
        throw new ArgumentNullException("sectionList");

    if (!BXIBlock.IsUserCanOperate(IBlockId, BXIBlock.Operations.IBlockAdminRead) ||
        !BXIBlock.IsUserCanOperate(IBlockId, BXIBlock.Operations.IBlockModifyElements))
        return;

    //Creating section
    BXPublicPanelMenuSection iblockListSection = sectionList.FindByID(IBlockListSectionId);
    if (iblockListSection == null)
    {
        BXPublicPanelMenuSectionInfo sectionInfo = new BXPublicPanelMenuSectionInfo(IBlockListSectionId, 100);
        iblockListSection = new BXPublicPanelMenuSection(sectionInfo);
        sectionList.Add(iblockListSection);
    }

    //Creating button
    BXPublicPanelMenu listButtonMenu = iblockListSection.FindByID(IBlockListButtonMenuId);
    if (listButtonMenu == null)
    {
        listButtonMenu = new BXPublicPanelMenu();
        listButtonMenu.ID = IBlockListButtonMenuId;
        listButtonMenu.BackgroundImagePath = BXPath.Combine(BXComponentManager.GetFolder(Name), "/images/iblock.gif");
        listButtonMenu.Caption = IBlockName;
        listButtonMenu.Hint = IBlockName;
        listButtonMenu.ShowMode = BXShowMode.NonView;
        iblockListSection.Add(listButtonMenu);
    }
}

public override void PopulatePublicPanelMenu(BXPublicPanelMenuSectionList sectionList)
{
    if (sectionList == null)
        throw new ArgumentNullException("sectionList");

    if (!BXIBlock.IsUserCanOperate(IBlockId, BXIBlock.Operations.IBlockAdminRead) ||
        !BXIBlock.IsUserCanOperate(IBlockId, BXIBlock.Operations.IBlockModifyElements))
        return;

    //Finding button
    BXPublicPanelMenuSection iblockListSection = sectionList.FindByID(IBlockListSectionId);
    if (iblockListSection == null)
        return;

    BXPublicPanelMenu listButtonMenu = iblockListSection.FindByID(IBlockListButtonMenuId);
    if (listButtonMenu == null)
        return;

    if (listButtonMenu.PopupMenu == null)
        listButtonMenu.PopupMenu = new BXPopupMenuV2();

    //Populating menu
    BXPopupMenuItem[] menuItems = GetMenuItems();
    for (int menuIndex = 0; menuIndex < menuItems.Length; menuIndex++)
        if (!Array.Exists(listButtonMenu.PopupMenu.Items, delegate(BXPopupMenuBaseItem item) { return item.ID == menuItems[menuIndex].ID; }))
            listButtonMenu.PopupMenu.AddItem(menuItems[menuIndex]);
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод EnsureComponentDefinition

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponent..::.EnsureComponentDefinition
Класс BXComponent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
EnsureComponentDefinition()()()() | Производит загрузку определений параметров компонента, если необходимо.
EnsureComponentDefinition(Boolean) |

Смотри также

Класс BXComponent
Члены BXComponent
Пространство имен Bitrix.UI


Метод EnsureComponentDefinition

Метод BXComponent..::.EnsureComponentDefinition
Класс BXComponent Смотри также Send Feedback
Производит загрузку определений параметров компонента, если необходимо.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void EnsureComponentDefinition()

Смотри также

Класс BXComponent
Перегрузка EnsureComponentDefinition
Пространство имен Bitrix.UI


Метод EnsureComponentDefinition (Boolean)

Метод BXComponent..::.EnsureComponentDefinition (Boolean)
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void EnsureComponentDefinition(
    bool loadTemplate
)

Параметры

loadTemplate
Type: System..::..Boolean

Смотри также

Класс BXComponent
Перегрузка EnsureComponentDefinition
Пространство имен Bitrix.UI


Метод ForceLoadComponentDefinition

Метод BXComponent..::.ForceLoadComponentDefinition
Класс BXComponent Пример Смотри также Send Feedback
Вызывает заполнение расширенных определений параметров компонента. Предназначен для вызова из редакторов.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void ForceLoadComponentDefinition()

Примеры

Создание элементов управления на основе определений параметров компонента:

CopyC#
component.ForcePreLoadComponentDefinition();
component.ForceLoadComponentDefinition();
foreach (KeyValuePair<string, BXParam> p in component.ParamsDefinition)
    switch (p.Value.Type)
    {
        case BXParamType.SingleSelection:
            DropDownList list = new DropDownList();
            foreach (BXParamValue v in p.Value.Values)
                list.Items.Add(new ListItem(v.Title, v.Value));
            list.SelectedValue = p.Value.SelectedValue;
            Controls.Add(list);
            break;

        // Какой-то код

    }

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод ForceLoadTemplateDefinition

Метод BXComponent..::.ForceLoadTemplateDefinition
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void ForceLoadTemplateDefinition()

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод ForcePreLoadComponentDefinition

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponent..::.ForcePreLoadComponentDefinition
Класс BXComponent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ForcePreLoadComponentDefinition()()()() | Вызывает заполнение определений параметров компонента.
ForcePreLoadComponentDefinition(Boolean) | Вызывает заполнение определений параметров компонента и, при указании, копирует значения по умолчанию из ParamsDefinition в Parameters. Предназначен для вызова из редакторов.

Смотри также

Класс BXComponent
Члены BXComponent
Пространство имен Bitrix.UI


Метод ForcePreLoadComponentDefinition

Метод BXComponent..::.ForcePreLoadComponentDefinition
Класс BXComponent Пример Смотри также Send Feedback
Вызывает заполнение определений параметров компонента.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void ForcePreLoadComponentDefinition()

Примеры

Копирование шаблона для компонента документа:

CopyC#
protected override void OnInit(EventArgs e)
{
    base.OnInit(e);

    BXComponent component = BXComponentManager.CreateInstance("bitrix:system.PublicMenu");
    component.ForcePreLoadComponentDefinition();
    component.ResetParameters();
    component.Parameters["Template"] = "flat";

    component.TemplateIncluded += new EventHandler(component_TemplateIncluded);
    component.Process(null);
}

void component_TemplateIncluded(object sender, EventArgs e)
{
    BXComponent component = sender as BXComponent;
    BXSecureIO.DirectoryCopy(component.TemplateFolder, "~/bitrix/templates/my_site/components/bitrix/system.PublicMenu/newTemplate");
}

Смотри также

Класс BXComponent
Перегрузка ForcePreLoadComponentDefinition
Пространство имен Bitrix.UI


Метод ForcePreLoadComponentDefinition (Boolean)

Метод BXComponent..::.ForcePreLoadComponentDefinition (Boolean)
Класс BXComponent Пример Смотри также Send Feedback
Вызывает заполнение определений параметров компонента и, при указании, копирует значения по умолчанию из ParamsDefinition в Parameters. Предназначен для вызова из редакторов.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void ForcePreLoadComponentDefinition(
    bool resetParameters
)

Параметры

resetParameters
Type: System..::..Boolean
true, если коприровать значения по умолчанию; иначе false

Примеры

Создание компонента "bitrix:system.PublicMenu" вручную:

CopyC#
BXComponent component = BXComponentManager.CreateInstance("bitrix:system.PublicMenu");
component.ForcePreLoadComponentDefinition(true);
component.CacheMode = BXCacheMode.Custom;
component.CacheDuration = 30;
component.Parameters["Template"] = "tabs";
placeholder.Controls.Add(component.Process(null));

Смотри также

Класс BXComponent
Перегрузка ForcePreLoadComponentDefinition
Пространство имен Bitrix.UI


Метод ForcePreLoadTemplateDefinition

Метод BXComponent..::.ForcePreLoadTemplateDefinition
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void ForcePreLoadTemplateDefinition()

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод GetCacheOutput

Метод BXComponent..::.GetCacheOutput
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual string GetCacheOutput()

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод IncludeComponentTemplate

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponent..::.IncludeComponentTemplate
Класс BXComponent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
IncludeComponentTemplate()()()() | Подключает шаблон к компоненту.
IncludeComponentTemplate(String) | Подключает шаблон к комплексному компоненту.

Смотри также

Класс BXComponent
Члены BXComponent
Пространство имен Bitrix.UI


Метод IncludeComponentTemplate

Метод BXComponent..::.IncludeComponentTemplate
Класс BXComponent Пример Смотри также Send Feedback
Подключает шаблон к компоненту.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected void IncludeComponentTemplate()

Примеры

Подключение шаблона компонента:

CopyC#
protected void Page_Load(object sender, EventArgs e)
{

    // Подготовка данных для шаблона
    ...

    IncludeComponentTemplate();
}

Подключение шаблона компонента c кешированием данных и обработкой шаблона при каждом запросе:

CopyC#
protected void Page_Load(object sender, EventArgs e)
{
    if (!IsCached())
    {

        // Подготовка данных для шаблона
        ...

    }
    IncludeComponentTemplate();
}

Подключение шаблона компонента с кешированием данных и HTML выводом:

CopyC#
protected void Page_Load(object sender, EventArgs e)
{
    if (!IsCached())
    {

        // Подготовка данных для шаблона
        ...

        IncludeComponentTemplate();
    }
}

Смотри также

Класс BXComponent
Перегрузка IncludeComponentTemplate
Пространство имен Bitrix.UI


Метод IncludeComponentTemplate (String)

Метод BXComponent..::.IncludeComponentTemplate (String)
Класс BXComponent Пример Смотри также Send Feedback
Подключает шаблон к комплексному компоненту.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected void IncludeComponentTemplate(
    string componentPage
)

Параметры

componentPage
Type: System..::..String
Имя страницы комплексного компонента, например "detail" для страницы detail.ascx

Примеры

Разбор ЧПУ и подключение вида (страницы из шаблона комплексного компонента) для компонента "Новости":
CopyC#
protected void Page_Load(object sender, EventArgs e)
{
    if (!EnableSef)
        return;

    BXParamsBag<string> templates = new BXParamsBag<string>();
    templates["detail"] = "/#SectionId#/news-#ElementId#/";
    templates["section"] = "/section/#SectionId#/";
    templates["section.page"] = "/#SectionId#/page-#PageId#";
    templates["section.showall"] = "/#SectionId#/all";
    templates["news.page"] = "/#PageId#";
    templates["news.showall"] = "/all";
    templates["sectionrss"] = "/rss-section/#SectionId#/";
    templates["rss"] = "/rss/";

    string template = MapVariable(SefFolder, templates, ComponentCache, "news");
    string page = template;
    int i = page.IndexOf('.');
    if (i != -1)
        page = page.Remove(i);

    //Fill component cache to transfer it to the views
    ComponentCache["PageShowAll"] = (template == "news.showall" || template == "section.showall");

    if (page == "section" || page == "sectionrss")
    {
        BXParamsBag<object> replaceItems = new BXParamsBag<object>();
        replaceItems["SectionId"] = ComponentCache.Get("SectionId", string.Empty);
        ComponentCache["UrlTemplatesNews"] = MakeLink(SefFolder, templates["section"], replaceItems);
        ComponentCache["UrlTemplatesNewsPage"] = MakeLink(SefFolder, templates["section.page"], replaceItems);
        ComponentCache["UrlTemplatesNewsShowAll"] = MakeLink(SefFolder, templates["section.showall"], replaceItems);
        ComponentCache["UrlTemplatesSectionRss"] = MakeLink(SefFolder, templates["sectionrss"], replaceItems);
    }
    else
    {
        ComponentCache["UrlTemplatesNews"] = CombineLink(SefFolder, string.Empty);
        ComponentCache["UrlTemplatesNewsPage"] = CombineLink(SefFolder, templates["news.page"]);
        ComponentCache["UrlTemplatesNewsShowAll"] = CombineLink(SefFolder, templates["news.showall"]);
    }

    ComponentCache["UrlTemplatesDetail"] = CombineLink(SefFolder, templates["detail"]);
    ComponentCache["UrlTemplatesSection"] = CombineLink(SefFolder, templates["section"]);
    ComponentCache["UrlTemplatesRss"] = CombineLink(SefFolder, templates["rss"]);

    IncludeComponentTemplate(page);
}

Смотри также

Класс BXComponent
Перегрузка IncludeComponentTemplate
Пространство имен Bitrix.UI


Метод IsCached

Метод BXComponent..::.IsCached
Класс BXComponent Пример Смотри также Send Feedback
Проверяет, закеширован ли компонент и загружает данные из кеша

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual bool IsCached(
    params Object[] parameters
)

Параметры

parameters
Type: array< System..::..Object >[]()[][]
Список дополнительных значений, которые влияют на формирование ключа в кеше

Возвращаемое значение

true, если данные компонента загружены из кеша, в противном случае false

Заметки

Ключ кеширования формируется на основе значений параметров компонента и дополнительных значений аргумента parameters

Примеры

Подключение шаблона компонента:

CopyC#
protected void Page_Load(object sender, EventArgs e)
{

    // Подготовка данных для шаблона
    ...

    IncludeComponentTemplate();
}

Подключение шаблона компонента c кешированием данных и обработкой шаблона при каждом запросе:

CopyC#
protected void Page_Load(object sender, EventArgs e)
{
    if (!IsCached())
    {

        // Подготовка данных для шаблона
        ...

    }
    IncludeComponentTemplate();
}

Подключение шаблона компонента с кешированием данных и HTML выводом:

CopyC#
protected void Page_Load(object sender, EventArgs e)
{
    if (!IsCached())
    {

        // Подготовка данных для шаблона
        ...

        IncludeComponentTemplate();
    }
}

Определение параметров постраничного разбиения и кеширование компонента с учетом этих параметров:

CopyC#
BXPagingParams pagingParams = PreparePagingParams(
    Parameters.Get("PageID", HttpContext.Current.Request.QueryString["page"]),
    Parameters.Get("PageShowAll", HttpContext.Current.Request.QueryString["showall"] != null)
);

if (!this.IsCached(pagingParams))
{

    // Какой-то код

}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод LoadComponentDefinition

Метод BXComponent..::.LoadComponentDefinition
Класс BXComponent Пример Смотри также Send Feedback
Переопределив этот метод, можно добавить произвольный параметр в компонент или расширить определение уже существующих параметров.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void LoadComponentDefinition()

Заметки

Этот метод вызывается только в режиме редактирования.

При вызове метода уже доступны значения параметров компонента.

Примеры

Расширенное описание параметров для компонента меню
CopyC#
protected override void LoadComponentDefinition()
{
    string siteId = null;
    if (!IsComponentDesignMode)
    {
        if (BXSite.Current != null)
            siteId = BXSite.Current.Id;
    }
    else
        siteId = DesignerSite;

    if (!string.IsNullOrEmpty(siteId))
    {
        foreach (KeyValuePair<string, string> p in BXPublicMenu.GetMenuTypes(siteId))
        {
            ParamsDefinition["MenuName"].Values.Add(new BXParamValue(string.Format("{0} ({1})", p.Value, p.Key.ToLowerInvariant()), p.Key.ToLowerInvariant()));
            ParamsDefinition["SubMenuName"].Values.Add(new BXParamValue(string.Format("{0} ({1})", p.Value, p.Key.ToLowerInvariant()), p.Key.ToLowerInvariant()));
        }
    }
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод MakeLink

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponent..::.MakeLink
Класс BXComponent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
MakeLink(String) | Замена специальных выражений (#...#) на значение соответствующих параметров из ComponentCache
MakeLink(String, BXParamsBag<(Of <<'(Object>)>>)) | Замена специальных выражений (#...#) на значение соответствующих параметров из словаря с параметрами
MakeLink(String, Object) | Конструирование ссылки из нескольких частей с заменой специальных выражений (#...#) на значения параметра. Внимание! Не использовать, если параметров больше чем 1
MakeLink(String, String) | Конструирование ссылки из нескольких частей с заменой специальных выражений( #...#) на соответствующие значения параметров из ComponentCache
MakeLink(String, String, BXParamsBag<(Of <<'(Object>)>>)) | Конструирование ссылки из нескольких частей с заменой специальных выражений( #...#) на соответствующие параметры
MakeLink(String, String, Object) | Конструирование ссылки из нескольких частей с заменой ВСЕХ специальных выражений(#...#) на значения параметра. Внимание! Не использовать, если параметров больше чем 1.

Смотри также

Класс BXComponent
Члены BXComponent
Пространство имен Bitrix.UI


Метод MakeLink (String)

Метод BXComponent..::.MakeLink (String)
Класс BXComponent Смотри также Send Feedback
Замена специальных выражений (#...#) на значение соответствующих параметров из ComponentCache

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string MakeLink(
    string template
)

Параметры

template
Type: System..::..String
Шаблон ссылки

Возвращаемое значение

Сформированная по шаблону ссылка

Заметки

Рекомендуется передавать словарь параметров явно при помощи метода MakeLink(String, BXParamsBag<(Of <<'(Object>)>>)).

Смотри также

Класс BXComponent
Перегрузка MakeLink
Пространство имен Bitrix.UI


Метод MakeLink (String, BXParamsBag(Object))

Метод BXComponent..::.MakeLink (String, BXParamsBag<(Of <(<'Object>)>)>)
Класс BXComponent Пример Смотри также Send Feedback
Замена специальных выражений (#...#) на значение соответствующих параметров из словаря с параметрами

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string MakeLink(
    string template,
    BXParamsBag<Object> parameters
)

Параметры

template
Type: System..::..String
Шаблон ссылки
parameters
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь с параметрами

Возвращаемое значение

Сформированная ссылка

Примеры

CopyC#
BXParamsBag<object> vars = new BXParamsBag<object>();
vars.Add("ElementId", elementId);

string url;
if (Parameters.Get<bool>("EnableSEF"))
    url = MakeLink(
        Parameters.Get<string>("SEFFolder"),
        Parameters.Get<string>("SefNewsTemplate"),
        vars
    );
else
    url = MakeLink(
        string.Format("{0}?{1}=#ElementId#", BXSefUrlManager.CurrentUrl.AbsolutePath, Parameters.Get<string>("ParamNews")),
        vars
    );

Смотри также

Класс BXComponent
Перегрузка MakeLink
Пространство имен Bitrix.UI


Метод MakeLink (String, Object)

Метод BXComponent..::.MakeLink (String, Object)
Класс BXComponent Смотри также Send Feedback
Конструирование ссылки из нескольких частей с заменой специальных выражений (#...#) на значения параметра. Внимание! Не использовать, если параметров больше чем 1

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string MakeLink(
    string template,
    Object parameter
)

Параметры

template
Type: System..::..String
Шаблон ссылки
parameter
Type: System..::..Object
Значение параметра

Возвращаемое значение

Сформированная по шаблону ссылка

Заметки

Внимание! Не использовать, если параметров больше чем 1.

Рекомендуется передавать словарь параметров вместо одного параметра при помощи метода MakeLink(String, BXParamsBag<(Of <<'(Object>)>>)).

Смотри также

Класс BXComponent
Перегрузка MakeLink
Пространство имен Bitrix.UI


Метод MakeLink (String, String)

Метод BXComponent..::.MakeLink (String, String)
Класс BXComponent Смотри также Send Feedback
Конструирование ссылки из нескольких частей с заменой специальных выражений( #...#) на соответствующие значения параметров из ComponentCache

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string MakeLink(
    string root,
    string template
)

Параметры

root
Type: System..::..String
Путь к папке ЧПУ
template
Type: System..::..String
Шаблон ЧПУ

Возвращаемое значение

Сформированная ссылка

Заметки

Рекомендуется передавать словарь параметров явно при помощи метода MakeLink(String, String, BXParamsBag<(Of <<'(Object>)>>)).

Смотри также

Класс BXComponent
Перегрузка MakeLink
Пространство имен Bitrix.UI


Метод MakeLink (String, String, BXParamsBag(Object))

Метод BXComponent..::.MakeLink (String, String, BXParamsBag<(Of <(<'Object>)>)>)
Класс BXComponent Пример Смотри также Send Feedback
Конструирование ссылки из нескольких частей с заменой специальных выражений( #...#) на соответствующие параметры

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string MakeLink(
    string root,
    string template,
    BXParamsBag<Object> parameters
)

Параметры

root
Type: System..::..String
Путь к папке ЧПУ
template
Type: System..::..String
Шаблон ЧПУ
parameters
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь с параметрами

Возвращаемое значение

Сформированная ссылка

Примеры

CopyC#
BXParamsBag<object> vars = new BXParamsBag<object>();
vars.Add("ElementId", elementId);

string url;
if (Parameters.Get<bool>("EnableSEF"))
    url = MakeLink(
        Parameters.Get<string>("SEFFolder"),
        Parameters.Get<string>("SefNewsTemplate"),
        vars
    );
else
    url = MakeLink(
        string.Format("{0}?{1}=#ElementId#", BXSefUrlManager.CurrentUrl.AbsolutePath, Parameters.Get<string>("ParamNews")),
        vars
    );

Смотри также

Класс BXComponent
Перегрузка MakeLink
Пространство имен Bitrix.UI


Метод MakeLink (String, String, Object)

Метод BXComponent..::.MakeLink (String, String, Object)
Класс BXComponent Смотри также Send Feedback
Конструирование ссылки из нескольких частей с заменой ВСЕХ специальных выражений(#...#) на значения параметра. Внимание! Не использовать, если параметров больше чем 1.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public static string MakeLink(
    string root,
    string template,
    Object parameter
)

Параметры

root
Type: System..::..String
Путь к папке ЧПУ
template
Type: System..::..String
Шаблон ЧПУ
parameter
Type: System..::..Object
Значение параметра

Возвращаемое значение

Сформированная ссылка

Заметки

Внимание! Не использовать, если параметров больше чем 1.

Рекомендуется передавать словарь параметров вместо одного параметра при помощи метода MakeLink(String, String, BXParamsBag<(Of <<'(Object>)>>)).

Смотри также

Класс BXComponent
Перегрузка MakeLink
Пространство имен Bitrix.UI


Метод Map

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponent..::.Map
Класс BXComponent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
Map(BXParamsBag<(Of <<'(String>)>>), String) | Возвращает ключ соответствующий текущим параметрам содержащимся в Request
Map(String, BXParamsBag<(Of <<'(String>)>>), String) | Возвращает ключ шаблона ЧПУ соответствующий текущей ссылке RawUrl

Смотри также

Класс BXComponent
Члены BXComponent
Пространство имен Bitrix.UI


Метод Map (BXParamsBag(String), String)

Метод BXComponent..::.Map (BXParamsBag<(Of <(<'String>)>)>, String)
Класс BXComponent Пример Смотри также Send Feedback
Возвращает ключ соответствующий текущим параметрам содержащимся в Request

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Map(
    BXParamsBag<string> mappingRule,
    string defaultCode
)

Параметры

mappingRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Словарь ключ + имя параметра в запросе
defaultCode
Type: System..::..String
Ключ по умолчанию.

Возвращаемое значение

Ключ для которого был найден параметр в Request или defaultCode, если не удалось найти параметр

Заметки

Используется при реализации механизмов контроллера в комплексных компонентах.

Примеры

CopyC#
if (!EnableSef)
{
    BXParamsBag<string> urlToPage = new BXParamsBag<string>();
    urlToPage["detail"] = ParamNews;
    urlToPage["section"] = ParamSection;
    urlToPage["news.page"] = ParamPage;
    urlToPage["news.showall"] = ParamShowAll;
    urlToPage["rss"] = "rss";
    urlToPage["sectionrss"] = "sectionrss";

    string page = Map(urlToPage, "news");

    ...

}

Смотри также

Класс BXComponent
Перегрузка Map
Пространство имен Bitrix.UI


Метод Map (String, BXParamsBag(String), String)

Метод BXComponent..::.Map (String, BXParamsBag<(Of <(<'String>)>)>, String)
Класс BXComponent Смотри также Send Feedback
Возвращает ключ шаблона ЧПУ соответствующий текущей ссылке RawUrl

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Map(
    string rootFolder,
    BXParamsBag<string> mappingRule,
    string defaultCode
)

Параметры

rootFolder
Type: System..::..String
Каталог ЧПУ (относительно корня сайта)
mappingRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Словарь ключ -> шаблон ЧПУ (если rootFolder задан) или ключ -> имя параметра в запросе (если rootFolder равен null или пустой строке)
defaultCode
Type: System..::..String
Ключ по умолчанию.

Возвращаемое значение

Ключ шаблона ЧПУ соответствующий текущей ссылке или defaultCode, если не удалось распознать шаблон

Заметки

Рекомендуется использовать метод MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String) вместо.

Смотри также

Класс BXComponent
Перегрузка Map
Пространство имен Bitrix.UI
BXComponent..::..MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String)


Метод MapVariable

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponent..::.MapVariable
Класс BXComponent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
MapVariable(String) | Выполняет разбор ЧПУ и складывает переменные в ComponentCache.
MapVariable(BXParamsBag<(Of <<'(String>)>>)) | Вытаскивает из Request переменные, которые описаны в mappingRule и помещает в ComponentCache.
MapVariable(String, BXParamsBag<(Of <<'(Object>)>>)) | Выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь
MapVariable(String, BXParamsBag<(Of <<'(String>)>>)) | Определяет нужный шаблон ЧПУ. А затем выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в ComponentCache.
MapVariable(BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>)) | Вытаскивает из Request переменные, которые описаны в mappingRule и помещает в словарь.
MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>)) | Определяет нужный шаблон ЧПУ. А затем выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь.
MapVariable(String, String, BXParamsBag<(Of <<'(Object>)>>)) | Выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь
MapVariable(BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String) | Вытаскивает из Request переменные, которые описаны в mappingRule и помещает в словарь.
MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String) | Определяет нужный шаблон ЧПУ. А затем выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь.
MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String, String) | Определяет нужный шаблон ЧПУ. А затем выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь.

Смотри также

Класс BXComponent
Члены BXComponent
Пространство имен Bitrix.UI


Метод MapVariable (String)

Метод BXComponent..::.MapVariable (String)
Класс BXComponent Смотри также Send Feedback
Выполняет разбор ЧПУ и складывает переменные в ComponentCache.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void MapVariable(
    string sefuTemplate
)

Параметры

sefuTemplate
Type: System..::..String
Шаблон ЧПУ

Заметки

Рекомендуется явно передавать словарь для переменных при помощи метода MapVariable(String, BXParamsBag<(Of <<'(Object>)>>)) или использовать метод MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String), который находит подходящий шаблон и производит его разбор.

Смотри также

Класс BXComponent
Перегрузка MapVariable
Пространство имен Bitrix.UI


Метод MapVariable (BXParamsBag(String))

Метод BXComponent..::.MapVariable (BXParamsBag<(Of <(<'String>)>)>)
Класс BXComponent Смотри также Send Feedback
Вытаскивает из Request переменные, которые описаны в mappingRule и помещает в ComponentCache.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void MapVariable(
    BXParamsBag<string> mappingRule
)

Параметры

mappingRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Ключ - имя параметра в Request, значение - имя параметра в variables

Заметки

Рекомендуется передавать словарь для переменных явно при помощи метода MapVariable(BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>)).

Смотри также

Класс BXComponent
Перегрузка MapVariable
Пространство имен Bitrix.UI


Метод MapVariable (String, BXParamsBag(Object))

Метод BXComponent..::.MapVariable (String, BXParamsBag<(Of <(<'Object>)>)>)
Класс BXComponent Смотри также Send Feedback
Выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void MapVariable(
    string sefuTemplate,
    BXParamsBag<Object> variables
)

Параметры

sefuTemplate
Type: System..::..String
Шаблон ЧПУ
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные

Заметки

Рекомендуется использовать метод MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String), который находит подходящий шаблон и производит его разбор.

Смотри также

Класс BXComponent
Перегрузка MapVariable
Пространство имен Bitrix.UI


Метод MapVariable (String, BXParamsBag(String))

Метод BXComponent..::.MapVariable (String, BXParamsBag<(Of <(<'String>)>)>)
Класс BXComponent Смотри также Send Feedback
Определяет нужный шаблон ЧПУ. А затем выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в ComponentCache.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void MapVariable(
    string rootFolder,
    BXParamsBag<string> mappingUrlRule
)

Параметры

rootFolder
Type: System..::..String
Корневая папка для ЧПУ
mappingUrlRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Правила преобразования текущей ссылки к шаблону ЧПУ

Заметки

Рекомендуется передавать словарь для переменных явно при помощи метода MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String).

Смотри также

Класс BXComponent
Перегрузка MapVariable
Пространство имен Bitrix.UI


Метод MapVariable (BXParamsBag(String), BXParamsBag(Object))

Метод BXComponent..::.MapVariable (BXParamsBag<(Of <(<'String>)>)>, BXParamsBag<(Of <(<'Object>)>)>)
Класс BXComponent Пример Смотри также Send Feedback
Вытаскивает из Request переменные, которые описаны в mappingRule и помещает в словарь.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void MapVariable(
    BXParamsBag<string> mappingRule,
    BXParamsBag<Object> variables
)

Параметры

mappingRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Ключ - имя параметра в Request, значение - имя параметра в variables
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные

Примеры

CopyC#
BXParamsBag<string> urlToPage = new BXParamsBag<string>();
urlToPage["detail"] = ParamNews;
urlToPage["section"] = ParamSection;
urlToPage["news.page"] = ParamPage;
urlToPage["news.showall"] = ParamShowAll;
urlToPage["rss"] = "rss";
urlToPage["sectionrss"] = "sectionrss";

string page = Map(urlToPage, "news");

BXParamsBag<string> variableAlias = new BXParamsBag<string>();
switch (page)
{
    case "detail":
        variableAlias["ElementId"] = ParamNews;
        break;
    case "section":
        variableAlias["SectionId"] = ParamSection;
        variableAlias["PageId"] = ParamPage;
        variableAlias["PageShowAll"] = ParamShowAll;
        break;
    case "rss":
        break;
    case "sectionrss":
        variableAlias["SectionId"] = "sectionrss";
        break;
    default:
        variableAlias["PageId"] = ParamPage;
        variableAlias["PageShowAll"] = ParamShowAll;
        break;
}

BXParamsBag<object> vars = new BXParamsBag<object>();
MapVariable(variableAlias, vars);

Смотри также

Класс BXComponent
Перегрузка MapVariable
Пространство имен Bitrix.UI


Метод MapVariable (String, BXParamsBag(String), BXParamsBag(Object))

Метод BXComponent..::.MapVariable (String, BXParamsBag<(Of <(<'String>)>)>, BXParamsBag<(Of <(<'Object>)>)>)
Класс BXComponent Смотри также Send Feedback
Определяет нужный шаблон ЧПУ. А затем выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string MapVariable(
    string rootFolder,
    BXParamsBag<string> mappingUrlRule,
    BXParamsBag<Object> variables
)

Параметры

rootFolder
Type: System..::..String
Корневая папка для ЧПУ
mappingUrlRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Правила преобразования текущей ссылки к шаблону ЧПУ
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные

Возвращаемое значение

Ключ в словаре mappingUrlRule по которому произошел разбор или null, если подходящий шаблон не был найден.

Заметки

Для примеров использования см. метод MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String).

Смотри также

Класс BXComponent
Перегрузка MapVariable
Пространство имен Bitrix.UI


Метод MapVariable (String, String, BXParamsBag(Object))

Метод BXComponent..::.MapVariable (String, String, BXParamsBag<(Of <(<'Object>)>)>)
Класс BXComponent Смотри также Send Feedback
Выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void MapVariable(
    string rootFolder,
    string sefUrl,
    BXParamsBag<Object> variables
)

Параметры

rootFolder
Type: System..::..String
Корневая папка для ЧПУ
sefUrl
Type: System..::..String
Шаблон ЧПУ
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные

Заметки

Рекомендуется использовать метод MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String), который находит подходящий шаблон и производит его разбор.

Смотри также

Класс BXComponent
Перегрузка MapVariable
Пространство имен Bitrix.UI


Метод MapVariable (BXParamsBag(String), BXParamsBag(Object), String)

Метод BXComponent..::.MapVariable (BXParamsBag<(Of <(<'String>)>)>, BXParamsBag<(Of <(<'Object>)>)>, String)
Класс BXComponent Смотри также Send Feedback
Вытаскивает из Request переменные, которые описаны в mappingRule и помещает в словарь.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void MapVariable(
    BXParamsBag<string> mappingRule,
    BXParamsBag<Object> variables,
    string currentUri
)

Параметры

mappingRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Ключ - имя параметра в Request, значение - имя параметра в variables
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные
currentUri
Type: System..::..String
Текущая ссылка (если null, то возьмется текущая ссылка запроса)

Заметки

Пример использования см. в описании метода MapVariable(BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>)).

Смотри также

Класс BXComponent
Перегрузка MapVariable
Пространство имен Bitrix.UI


Метод MapVariable (String, BXParamsBag(String), BXParamsBag(Object), String)

Метод BXComponent..::.MapVariable (String, BXParamsBag<(Of <(<'String>)>)>, BXParamsBag<(Of <(<'Object>)>)>, String)
Класс BXComponent Пример Смотри также Send Feedback
Определяет нужный шаблон ЧПУ. А затем выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string MapVariable(
    string rootFolder,
    BXParamsBag<string> mappingUrlRule,
    BXParamsBag<Object> variables,
    string defaultCode
)

Параметры

rootFolder
Type: System..::..String
Корневая папка для ЧПУ
mappingUrlRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Правила преобразования текущей ссылки к шаблону ЧПУ
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные
defaultCode
Type: System..::..String
Ключ по умолчанию

Возвращаемое значение

Ключ в словаре mappingUrlRule по которому произошел разбор или defaultCode, если подходящий шаблон не был найден.

Примеры

CopyC#
if (EnableSef)
{
    BXParamsBag<string> urlToPage = new BXParamsBag<string>();
    BXParamsBag<object> variables = new BXParamsBag<object>();

    urlToPage["detail"] = SefNews;
    urlToPage["section"] = SefSection;
    urlToPage["section.page"] = SefSectionPage;
    urlToPage["section.showall"] = SefSectionShowAll;
    urlToPage["news.page"] = SefPage;
    urlToPage["news.showall"] = SefShowAll;

    string page = MapVariable(SefFolder, urlToPage, variables, "news");

    ...

}

Смотри также

Класс BXComponent
Перегрузка MapVariable
Пространство имен Bitrix.UI


Метод MapVariable (String, BXParamsBag(String), BXParamsBag(Object), String, String)

Метод BXComponent..::.MapVariable (String, BXParamsBag<(Of <(<'String>)>)>, BXParamsBag<(Of <(<'Object>)>)>, String, String)
Класс BXComponent Смотри также Send Feedback
Определяет нужный шаблон ЧПУ. А затем выполняет разбор текущей ссылки по шаблону ЧПУ и складывает переменные в словарь.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string MapVariable(
    string rootFolder,
    BXParamsBag<string> mappingUrlRule,
    BXParamsBag<Object> variables,
    string defaultCode,
    string currentUri
)

Параметры

rootFolder
Type: System..::..String
Корневая папка для ЧПУ
mappingUrlRule
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>
Правила преобразования текущей ссылки к шаблону ЧПУ
variables
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Словарь, в который будут помещены переменные
defaultCode
Type: System..::..String
Ключ по умолчанию
currentUri
Type: System..::..String
Текущая ссылка (если null, то возьмется текущая ссылка запроса)

Возвращаемое значение

Ключ в словаре mappingUrlRule по которому произошел разбор или defaultCode, если подходящий шаблон не был найден.

Заметки

Для примеров использования см. метод MapVariable(String, BXParamsBag<(Of <<'(String>)>>), BXParamsBag<(Of <<'(Object>)>>), String).

Смотри также

Класс BXComponent
Перегрузка MapVariable
Пространство имен Bitrix.UI


Метод OnPreRender

Метод BXComponent..::.OnPreRender
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override void OnPreRender(
    EventArgs e
)

Параметры

e
Type: System..::..EventArgs

Заметки

Метод формирует особый шаблон, когда компонент закеширован.

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод PopulatePublicPanelMenu

Метод BXComponent..::.PopulatePublicPanelMenu
Класс BXComponent Пример Смотри также Send Feedback
Наполняет кнопки в публичной верхней панели опциями.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual void PopulatePublicPanelMenu(
    BXPublicPanelMenuSectionList sectionList
)

Параметры

sectionList
Type: BXPublicPanelMenuSectionList
Список секций в публичной верхней панели.

Заметки

Предназначен для переопределения в компонентах.

Примеры

Создание отдельной секции для инфоблоков в публичной верхней панели, добавление в секцию кнопки и наполнение списка доступных действий:
CopyC#
private string IBlockListSectionId
{
    get
    {
        return "IBlockListMenuSection";
    }
}

private string IBlockListButtonMenuId
{
    get
    {
        return String.Format("IBlockListButtonMenu_{0}", IBlockId);
    }
}

private BXPopupMenuItem[] GetMenuItems()
{
    BXPopupMenuItem[] menuItems = new BXPopupMenuItem[1];

    menuItems[0] = new BXPopupMenuItem();
    menuItems[0].BackgroundImagePath = BXPath.Combine(BXComponentManager.GetFolder(Name), "/images/new_element.gif");
    menuItems[0].ID = String.Format("element_new_{0}", IBlockId);
    menuItems[0].Text = String.Format(GetMessageRaw("AddNewElement"), String.IsNullOrEmpty(IBlockElementName) ? GetMessageRaw("IBlockElementName") : IBlockElementName.ToLower());
    menuItems[0].ClientClickScript =
        String.Format(
            "jsUtils.Redirect(arguments, '{0}?iblock_id={1}&type_id={2}&{3}={4}')",
            VirtualPathUtility.ToAbsolute("~/bitrix/admin/IBlockElementEdit.aspx"),
            IBlockId,
            IBlockTypeId,
            BXConfigurationUtility.Constants.BackUrl,
            UrlEncode(BXSefUrlManager.CurrentUrl.PathAndQuery)
        );

    return menuItems;
}

public override void CreatePublicPanelMenu(BXPublicPanelMenuSectionList sectionList)
{
    if (sectionList == null)
        throw new ArgumentNullException("sectionList");

    if (!BXIBlock.IsUserCanOperate(IBlockId, BXIBlock.Operations.IBlockAdminRead) ||
        !BXIBlock.IsUserCanOperate(IBlockId, BXIBlock.Operations.IBlockModifyElements))
        return;

    //Creating section
    BXPublicPanelMenuSection iblockListSection = sectionList.FindByID(IBlockListSectionId);
    if (iblockListSection == null)
    {
        BXPublicPanelMenuSectionInfo sectionInfo = new BXPublicPanelMenuSectionInfo(IBlockListSectionId, 100);
        iblockListSection = new BXPublicPanelMenuSection(sectionInfo);
        sectionList.Add(iblockListSection);
    }

    //Creating button
    BXPublicPanelMenu listButtonMenu = iblockListSection.FindByID(IBlockListButtonMenuId);
    if (listButtonMenu == null)
    {
        listButtonMenu = new BXPublicPanelMenu();
        listButtonMenu.ID = IBlockListButtonMenuId;
        listButtonMenu.BackgroundImagePath = BXPath.Combine(BXComponentManager.GetFolder(Name), "/images/iblock.gif");
        listButtonMenu.Caption = IBlockName;
        listButtonMenu.Hint = IBlockName;
        listButtonMenu.ShowMode = BXShowMode.NonView;
        iblockListSection.Add(listButtonMenu);
    }
}

public override void PopulatePublicPanelMenu(BXPublicPanelMenuSectionList sectionList)
{
    if (sectionList == null)
        throw new ArgumentNullException("sectionList");

    if (!BXIBlock.IsUserCanOperate(IBlockId, BXIBlock.Operations.IBlockAdminRead) ||
        !BXIBlock.IsUserCanOperate(IBlockId, BXIBlock.Operations.IBlockModifyElements))
        return;

    //Finding button
    BXPublicPanelMenuSection iblockListSection = sectionList.FindByID(IBlockListSectionId);
    if (iblockListSection == null)
        return;

    BXPublicPanelMenu listButtonMenu = iblockListSection.FindByID(IBlockListButtonMenuId);
    if (listButtonMenu == null)
        return;

    if (listButtonMenu.PopupMenu == null)
        listButtonMenu.PopupMenu = new BXPopupMenuV2();

    //Populating menu
    BXPopupMenuItem[] menuItems = GetMenuItems();
    for (int menuIndex = 0; menuIndex < menuItems.Length; menuIndex++)
        if (!Array.Exists(listButtonMenu.PopupMenu.Items, delegate(BXPopupMenuBaseItem item) { return item.ID == menuItems[menuIndex].ID; }))
            listButtonMenu.PopupMenu.AddItem(menuItems[menuIndex]);
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод PreLoadComponentDefinition

Метод BXComponent..::.PreLoadComponentDefinition
Класс BXComponent Пример Смотри также Send Feedback
Переопределив этот метод, можно добавить произвольный параметр в компонент.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void PreLoadComponentDefinition()

Заметки

Этот метод вызывается при каждом обращении к компоненту.

Примеры

Описание параметров для компонента меню
CopyC#
protected override void PreLoadComponentDefinition()
{
    Title = GetMessage("Title");
    Description = GetMessage("Description");
    Icon = "component.gif";

    Group = new BXComponentGroup("system_menu", GetMessage("Group"), 100, BXComponentGroup.Utility);

    ParamsDefinition["Depth"] = new BXParamText(GetMessageRaw("ComponentParam.Title.MenuDepth"), "1", BXCategory.Main);
    ParamsDefinition["MenuName"] = new BXParamSingleSelection(GetMessageRaw("ComponentParam.Title.MenuType"), "top", BXCategory.Main);
    ParamsDefinition["SubMenuName"] = new BXParamSingleSelection(GetMessageRaw("ComponentParam.Title.SubmenuType"), "left", BXCategory.Main);
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод PrepareCacheKey

Метод BXComponent..::.PrepareCacheKey
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected void PrepareCacheKey(
    Object[] parameters
)

Параметры

parameters
Type: array< System..::..Object >[]()[][]

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод PreparePaging

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponent..::.PreparePaging
Класс BXComponent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
PreparePaging(BXComponent..::..BXPagingParams, BXComponent..::..GetTotalCountMethod, BXParamsBag<(Of <<'(Object>)>>), Boolean%) | Подготавливает параметры запроса, необходимые для постраничного разбиения, и задает параметры компонента постраничной навигации.
PreparePaging(BXComponent..::..BXPagingParams, BXComponent..::..GetTotalCountMethod, BXParamsBag<(Of <<'(Object>)>>), String, String, String, String) | Подготавливает параметры запроса, необходимые для постраничного разбиения, и задает параметры компонента постраничной навигации.
PreparePaging(BXComponent..::..GetTotalCountMethod, BXParamsBag<(Of <<'(Object>)>>), String, Boolean, String, String, String) | Устаревший. Подготавливает параметры запроса, необходимые для постраничного разбиения, и задает параметры компонента постраничной навигации.
PreparePaging(BXComponent..::..BXPagingParams, BXComponent..::..GetTotalCountMethod, BXParamsBag<(Of <<'(Object>)>>), String, String, String, String, Boolean%) | Подготавливает параметры запроса, необходимые для постраничного разбиения, и задает параметры компонента постраничной навигации.

Смотри также

Класс BXComponent
Члены BXComponent
Пространство имен Bitrix.UI


Метод PreparePaging (BXComponent.BXPagingParams, BXComponent.GetTotalCountMethod, BXParamsBag(Object), Boolean)

Метод BXComponent..::.PreparePaging (BXComponent..::..BXPagingParams, BXComponent..::..GetTotalCountMethod, BXParamsBag<(Of <(<'Object>)>)>, Boolean%)
Класс BXComponent Пример Смотри также Send Feedback
Подготавливает параметры запроса, необходимые для постраничного разбиения, и задает параметры компонента постраничной навигации.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXQueryParams PreparePaging(
    BXComponent..::..BXPagingParams pagingParams,
    BXComponent..::..GetTotalCountMethod count,
    BXParamsBag<Object> request,
    out bool isLegalPage
)

Параметры

pagingParams
Type: Bitrix.UI..::..BXComponent..::..BXPagingParams
Параметры постраничного разбиения.
count
Type: Bitrix.UI..::..BXComponent..::..GetTotalCountMethod
Функция для подсчета количества элементов в источнике данных.
request
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Набор входных параметров. Используется для формирования ссылок.
isLegalPage
Type: System..::..Boolean %
Существует ли данная страница в источнике данных

Возвращаемое значение

Параметры запроса для выборки элементов.

Заметки

Шаблоны ссылок для постраничной навигации берутся из стандартных параметров компонента (BXParametersDefinition.PagingUrl). Параметры постраничного разбиения можно получить при помощи PreparePagingParams(String, Boolean).

Примеры

Выборка элементов инфоблока с кешированием и постраничным разбиением:

CopyC#
protected void Page_Load(object sender, EventArgs e)
{
    BXPagingParams pagingParams = PreparePagingParams();

    if (IsCached(((BXPrincipal)Page.User).GetAllRoles(true), pagingParams))
        return;

    BXFilter elementFilter = new BXFilter(
        new BXFilterItem(BXIBlockElement.Fields.Active, BXSqlFilterOperators.Equal, "Y"),
        new BXFilterItem(BXIBlockElement.Fields.CheckPermissions, BXSqlFilterOperators.Equal, "Y")
    );

    bool isLegalPage;
    BXQueryParams queryParams = PreparePaging(
        pagingParams,
        delegate { return BXIBlockElement.Count(elementFilter); },
        new BXParamsBag<object>(),
        out isLegalPage
    );

    if (!isLegalPage)
        AbortCache();

    BXIBlockElementCollection iblockElements = BXIBlockElement.GetList(elementFilter, null, null, queryParams);
    foreach (BXIBlockElement iblockElement in iblockElements)
    {
        //Код
    }

    IncludeComponentTemplate();
}

Смотри также

Класс BXComponent
Перегрузка PreparePaging
Пространство имен Bitrix.UI
BXComponent..::..PreparePagingParams(String, Boolean)


Метод PreparePaging (BXComponent.BXPagingParams, BXComponent.GetTotalCountMethod, BXParamsBag(Object), String, String, String, String)

Метод BXComponent..::.PreparePaging (BXComponent..::..BXPagingParams, BXComponent..::..GetTotalCountMethod, BXParamsBag<(Of <(<'Object>)>)>, String, String, String, String)
Класс BXComponent Пример Смотри также Send Feedback
Подготавливает параметры запроса, необходимые для постраничного разбиения, и задает параметры компонента постраничной навигации.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXQueryParams PreparePaging(
    BXComponent..::..BXPagingParams pagingParams,
    BXComponent..::..GetTotalCountMethod count,
    BXParamsBag<Object> request,
    string pageKey,
    string defaultPageTemplate,
    string pageTemplate,
    string showAllTemplate
)

Параметры

pagingParams
Type: Bitrix.UI..::..BXComponent..::..BXPagingParams
Параметры постраничного разбиения.
count
Type: Bitrix.UI..::..BXComponent..::..GetTotalCountMethod
Функция для подсчета количества элементов в источнике данных.
request
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Набор входных параметров. Используется для формирования ссылок.
pageKey
Type: System..::..String
Ключ в наборе входных параметров для номера текущей страницы. Используется для формирования ссылок.
defaultPageTemplate
Type: System..::..String
Шаблон ссылки на страницу по умолчанию
pageTemplate
Type: System..::..String
Шаблон ссылки на конкретную страницу
showAllTemplate
Type: System..::..String
Шаблон ссылки на режим отображения всех страниц

Возвращаемое значение

Параметры запроса для выборки элементов.

Заметки

Параметры постраничного разбиения можно получить при помощи PreparePagingParams(String, Boolean).

Для увеличения безопасности рекомендуется использовать версию метода PreparePaging(BXComponent..::..BXPagingParams, BXComponent..::..GetTotalCountMethod, BXParamsBag<(Of <<'(Object>)>>), String, String, String, String, Boolean%) и отменять кеширование при помощи метода AbortCache()()()() в случае если isLegalPage не равно true

Примеры

Выборка элементов инфоблока с кешированием и постраничным разбиением:

CopyC#
BXPagingParams pagingParams = PreparePagingParams(
    Parameters.Get("PageID", HttpContext.Current.Request.QueryString["page"]),
    Parameters.Get("PageShowAll", HttpContext.Current.Request.QueryString["showall"] != null)
);

if (!IsCached(pagingParams))
{
    BXFilter elementFilter;
    BXOrderBy elementOrder;

    ...

    BXQueryParams queryParams = PreparePaging(
        pagingParams,
        delegate
        {
            return BXIBlockElement.Count(elementFilter);
        },
        new BXParamsBag<object>(),
        "PageID",
        Parameters.Get<string>("UrlTemplatesNews", Request.FilePath),
        Parameters.Get<string>("UrlTemplatesNewsPage", "?page=#PageID#"),
        Parameters.Get<string>("UrlTemplatesNewsShowAll", "?showall="),
    );
    BXIBlockElementCollection items = BXIBlockElement.GetList(elementFilter, elementOrder, null, queryParams);
    ComponentCache["Items"] = items;

    ...

}

Смотри также

Класс BXComponent
Перегрузка PreparePaging
Пространство имен Bitrix.UI
BXComponent..::..PreparePagingParams(String, Boolean)


Метод PreparePaging (BXComponent.GetTotalCountMethod, BXParamsBag(Object), String, Boolean, String, String, String)

Метод BXComponent..::.PreparePaging (BXComponent..::..GetTotalCountMethod, BXParamsBag<(Of <(<'Object>)>)>, String, Boolean, String, String, String)
Класс BXComponent Смотри также Send Feedback
Подготавливает параметры запроса, необходимые для постраничного разбиения, и задает параметры компонента постраничной навигации.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
[ObsoleteAttribute("Use PreparePaging with PagingParams")]
protected BXQueryParams PreparePaging(
    BXComponent..::..GetTotalCountMethod count,
    BXParamsBag<Object> request,
    string pageKey,
    bool showAll,
    string defaultPageTemplate,
    string pageTemplate,
    string showAllTemplate
)

Параметры

count
Type: Bitrix.UI..::..BXComponent..::..GetTotalCountMethod
Функция для подсчета количества элементов в источнике данных.
request
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Набор входных параметров. Используется для подготовки параметров запроса и формирования ссылок.
pageKey
Type: System..::..String
Ключ в наборе входных параметров для номера текущей страницы
showAll
Type: System..::..Boolean
Показывать ли все страницы
defaultPageTemplate
Type: System..::..String
Шаблон ссылки на страницу по умолчанию
pageTemplate
Type: System..::..String
Шаблон ссылки на конкретную страницу
showAllTemplate
Type: System..::..String
Шаблон ссылки на режим отображения всех страниц

Возвращаемое значение

Параметры запроса для выборки элементов

Заметки

Устаревшее. Используйте PreparePaging(BXComponent..::..BXPagingParams, BXComponent..::..GetTotalCountMethod, BXParamsBag<(Of <<'(Object>)>>), String, String, String, String, Boolean%).

Смотри также

Класс BXComponent
Перегрузка PreparePaging
Пространство имен Bitrix.UI
BXComponent..::..PreparePaging(BXComponent..::..BXPagingParams, BXComponent..::..GetTotalCountMethod, BXParamsBag<(Of <<'(Object>)>>), String, String, String, String, Boolean%)


Метод PreparePaging (BXComponent.BXPagingParams, BXComponent.GetTotalCountMethod, BXParamsBag(Object), String, String, String, String, Boolean)

Метод BXComponent..::.PreparePaging (BXComponent..::..BXPagingParams, BXComponent..::..GetTotalCountMethod, BXParamsBag<(Of <(<'Object>)>)>, String, String, String, String, Boolean%)
Класс BXComponent Пример Смотри также Send Feedback
Подготавливает параметры запроса, необходимые для постраничного разбиения, и задает параметры компонента постраничной навигации.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXQueryParams PreparePaging(
    BXComponent..::..BXPagingParams pagingParams,
    BXComponent..::..GetTotalCountMethod count,
    BXParamsBag<Object> request,
    string pageKey,
    string defaultPageTemplate,
    string pageTemplate,
    string showAllTemplate,
    out bool isLegalPage
)

Параметры

pagingParams
Type: Bitrix.UI..::..BXComponent..::..BXPagingParams
Параметры постраничного разбиения.
count
Type: Bitrix.UI..::..BXComponent..::..GetTotalCountMethod
Функция для подсчета количества элементов в источнике данных.
request
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Набор входных параметров. Используется для формирования ссылок.
pageKey
Type: System..::..String
Ключ в наборе входных параметров для номера текущей страницы. Используется для формирования ссылок.
defaultPageTemplate
Type: System..::..String
Шаблон ссылки на страницу по умолчанию
pageTemplate
Type: System..::..String
Шаблон ссылки на конкретную страницу
showAllTemplate
Type: System..::..String
Шаблон ссылки на режим отображения всех страниц
isLegalPage
Type: System..::..Boolean %
Существует ли данная страница в источнике данных

Возвращаемое значение

Параметры запроса для выборки элементов.

Заметки

Параметры постраничного разбиения можно получить при помощи PreparePagingParams(String, Boolean).

Примеры

Выборка элементов инфоблока с кешированием и постраничным разбиением:
CopyC#
BXPagingParams pagingParams = PreparePagingParams(
    Parameters.Get("PageID", HttpContext.Current.Request.QueryString["page"]),
    Parameters.Get("PageShowAll", HttpContext.Current.Request.QueryString["showall"] != null)
);

if (!IsCached(pagingParams))
{
    BXFilter elementFilter;
    BXOrderBy elementOrder;

    ...

    bool isLegalPage;
    BXQueryParams queryParams = PreparePaging(
        pagingParams,
        delegate
        {
            return BXIBlockElement.Count(elementFilter);
        },
        new BXParamsBag<object>(),
        "PageID",
        Parameters.Get<string>("UrlTemplatesNews", Request.FilePath),
        Parameters.Get<string>("UrlTemplatesNewsPage", "?page=#PageID#"),
        Parameters.Get<string>("UrlTemplatesNewsShowAll", "?showall="),
        out isLegalPage
    );
    if (!isLegalPage)
        AbortCache();
    BXIBlockElementCollection items = BXIBlockElement.GetList(elementFilter, elementOrder, null, queryParams);
    ComponentCache["Items"] = items;

    ...

}

Смотри также

Класс BXComponent
Перегрузка PreparePaging
Пространство имен Bitrix.UI
BXComponent..::..PreparePagingParams(String, Boolean)


Метод PreparePagingParams

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponent..::.PreparePagingParams
Класс BXComponent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
PreparePagingParams()()()() | Формирует параметры постраничного разбиения из входных данных.
PreparePagingParams(String, Boolean) | Формирует параметры постраничного разбиения из входных данных.

Смотри также

Класс BXComponent
Члены BXComponent
Пространство имен Bitrix.UI


Метод PreparePagingParams

Метод BXComponent..::.PreparePagingParams
Класс BXComponent Пример Смотри также Send Feedback
Формирует параметры постраничного разбиения из входных данных.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXComponent..::..BXPagingParams PreparePagingParams()

Возвращаемое значение

Параметры постраничного разбиения

Заметки

Номер страницы и флаг отображения всех страниц берутся из стандартных параметров постраничной навигации (BXParametersDefinition.PagingUrl). Может использоваться как дополнительный параметр кеширования компонента в методе IsCached(array<Object>[]()[][]).

Примеры

Определение параметров постраничного разбиения и кеширование компонента с учетом этих параметров:

CopyC#
BXPagingParams pagingParams = PreparePagingParams();
if (IsCached(((BXPrincipal)Page.User).GetAllRoles(true), pagingParams))
{
    SetTemplateCachedData();
    return;
}
//Какой-то код
IncludeComponentTemplate();

Смотри также

Класс BXComponent
Перегрузка PreparePagingParams
Пространство имен Bitrix.UI
BXComponent..::..IsCached(array<Object>[]()[][])


Метод PreparePagingParams (String, Boolean)

Метод BXComponent..::.PreparePagingParams (String, Boolean)
Класс BXComponent Пример Смотри также Send Feedback
Формирует параметры постраничного разбиения из входных данных.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXComponent..::..BXPagingParams PreparePagingParams(
    string page,
    bool showAll
)

Параметры

page
Type: System..::..String
Строка, содержащая номер страницы
showAll
Type: System..::..Boolean
Отображать ли все страницы

Возвращаемое значение

Параметры постраничного разбиения

Заметки

Может использоваться как дополнительный параметр кеширования компонента в методе IsCached(array<Object>[]()[][]).

Примеры

Определение параметров постраничного разбиения и кеширование компонента с учетом этих параметров:

CopyC#
BXPagingParams pagingParams = PreparePagingParams(
    Parameters.Get("PageID", HttpContext.Current.Request.QueryString["page"]),
    Parameters.Get("PageShowAll", HttpContext.Current.Request.QueryString["showall"] != null)
);

if (!this.IsCached(pagingParams))
{

    // Какой-то код

}

Смотри также

Класс BXComponent
Перегрузка PreparePagingParams
Пространство имен Bitrix.UI
BXComponent..::..IsCached(array<Object>[]()[][])


Метод ProcessCommand

Метод BXComponent..::.ProcessCommand
Класс BXComponent Пример Смотри также Send Feedback
Обрабатывает команду, пришедшую из шаблона компонента.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual bool ProcessCommand(
    string commandName,
    BXParamsBag<Object> commandParameters,
    List<string> commandErrors
)

Параметры

commandName
Type: System..::..String
Имя команды
commandParameters
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>
Параметры команды
commandErrors
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
Список, в который компонент выводит ошибки

Возвращаемое значение

Успешно ли обработана команда

Заметки

Набор допустимых команд определяется разработчиком компонента.

Примеры

Обработка команд в компоненте "bitrix:system.login":

CopyC#
public override bool ProcessCommand(string commandName, BXParamsBag<object> commandParameters, List<string> commandErrors)
{
    if (commandName.Equals("login", StringComparison.InvariantCultureIgnoreCase))
    {
        string providerName = null;

        string login = (string)commandParameters["Login"];
        string val1 = (string)commandParameters["Password"];
        bool remember = (bool)commandParameters["Remember"];

        try
        {
            if (BXAuthentication.Authenticate(login, val1, out providerName))
            {
                BXAuthentication.SetAuthCookie(login, providerName, remember);
                Response.Redirect(Request.Url.ToString(), true);
            }
            else
            {
                commandErrors.Add("Неверный логин или пароль!");
            }
        }
        catch (Exception e)
        {
            commandErrors.Add(e.Message);
        }
    }
    if (commandName.Equals("logout", StringComparison.InvariantCultureIgnoreCase))
    {
        BXAuthentication.SignOut();

        BXPage page = Page as BXPage;
        if (page != null)
            page.Redirect(Request.Url.ToString());
        else
        {
            try
            {
                Response.Redirect(Request.Url.ToString(), true);
            }
            catch (System.Threading.ThreadAbortException)
            {
            }
        }
    }
    return false;
}

Оотправка команды шаблоном компонента "bitrix:system.login" по нажатию кнопки:

CopyC#
protected void LoginButton_Click(object sender, EventArgs e)
{
    if (Page.IsValid)
    {
        BXParamsBag<object> par = new BXParamsBag<object>();
        par.Add("Login", LoginField.Text);
        par.Add("Password", PasswordField.Text);
        par.Add("Remember", CheckBoxRemember.Checked);

        List<string> err = new List<string>();

        if (!Component.ProcessCommand("login", par, err))
        {
            foreach (string kvp in err)
                errorMessage.AddErrorMessage(kvp);
        }
    }
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод ProcessMessage

Метод BXComponent..::.ProcessMessage
Класс BXComponent Пример Смотри также Send Feedback
Обрабатывает событие системы. Может быть вызвано вне контекста исполнения.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual void ProcessMessage(
    BXCommand cmd,
    bool executionContext,
    string executionVirtualPath
)

Параметры

cmd
Type: BXCommand
Произошедшее событие.
executionContext
Type: System..::..Boolean
true - если метод вызывается в контексте реального исполняемого компонента, false - если метод вызывается вне контекста запроса
executionVirtualPath
Type: System..::..String
Виртуальный путь к предполагаемой странице, на которой располагается компонент

Заметки

Метод предназначен для перегрузки в конкретных компонентах.

Независимо от присутствия контекста исполнения компоненту доступна заполненная коллекция Parameters.

Примеры

Обработка компонентом события предоставления ссылки для результата поиска

CopyC#
public override void ProcessMessage(BXCommand cmd, bool executionContext, string executionVirtualPath)
{
    if (string.Equals(cmd.Action, "Bitrix.Search.ProvideUrl", StringComparison.OrdinalIgnoreCase))
    {
        if (cmd.Parameters.Get<string>("moduleId") != "iblock")
            return;
        if (IBlockId < 0 || cmd.Parameters.Get<int>("itemGroup") != IBlockId)
            return;
        int elementId = cmd.Parameters.Get("itemId", -1);
        if (elementId < 0)
            return;

        BXParamsBag<object> p = new BXParamsBag<object>();
        p.Add("ElementId", elementId);

        string url;
        if (Parameters.Get<bool>("EnableSEF"))
            url = MakeLink(Parameters.Get<string>("SEFFolder"), Parameters.Get<string>("Sef_News"), p);
        else
            url = MakeLink(string.Format("{0}?{1}=#ElementId#", VirtualPathUtility.ToAbsolute(executionVirtualPath), Parameters.Get<string>("ParamNews")), p);
        cmd.AddCommandResult("bitrix:news@" + executionVirtualPath, new BXCommandResult(BXCommandResultType.Ok, url));
    }
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод RedirectTemplateUrl

Метод BXComponent..::.RedirectTemplateUrl
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void RedirectTemplateUrl(
    string template,
    BXParamsBag<Object> parameters
)

Параметры

template
Type: System..::..String
parameters
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод Render

Метод BXComponent..::.Render
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override void Render(
    HtmlTextWriter writer
)

Параметры

writer
Type: System.Web.UI..::..HtmlTextWriter

Заметки

Если к компоненту подключен шаблон, происходит отрисовка шаблона. В противном случае отрисовывается сам компонент.

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод ResetParameters

Метод BXComponent..::.ResetParameters
Класс BXComponent Смотри также Send Feedback
Сбрасывает параметры на установки по умолчанию

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void ResetParameters()

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод ResolvePagingHelper

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponent..::.ResolvePagingHelper
Класс BXComponent Смотри также Send Feedback

Лист перегрузки

Имя | Описание
ResolvePagingHelper(Int32, BXComponent..::..BXPagingParams) |
ResolvePagingHelper(String, Int32, Int32, BXParamsBag<(Of <<'(String>)>>)) |

Смотри также

Класс BXComponent
Члены BXComponent
Пространство имен Bitrix.UI


Метод ResolvePagingHelper (Int32, BXComponent.BXPagingParams)

Метод BXComponent..::.ResolvePagingHelper (Int32, BXComponent..::..BXPagingParams)
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXPagingHelper ResolvePagingHelper(
    int totalCount,
    BXComponent..::..BXPagingParams pagingParams
)

Параметры

totalCount
Type: System..::..Int32
pagingParams
Type: Bitrix.UI..::..BXComponent..::..BXPagingParams

Смотри также

Класс BXComponent
Перегрузка ResolvePagingHelper
Пространство имен Bitrix.UI


Метод ResolvePagingHelper (String, Int32, Int32, BXParamsBag(String))

Метод BXComponent..::.ResolvePagingHelper (String, Int32, Int32, BXParamsBag<(Of <(<'String>)>)>)
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXPagingHelper ResolvePagingHelper(
    string name,
    int totalCount,
    int recordsPerPage,
    BXParamsBag<string> specialOptions
)

Параметры

name
Type: System..::..String
totalCount
Type: System..::..Int32
recordsPerPage
Type: System..::..Int32
specialOptions
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' String >)>)>

Смотри также

Класс BXComponent
Перегрузка ResolvePagingHelper
Пространство имен Bitrix.UI


Метод ResolveTemplateUrl

Метод BXComponent..::.ResolveTemplateUrl
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ResolveTemplateUrl(
    string template,
    BXParamsBag<Object> parameters
)

Параметры

template
Type: System..::..String
parameters
Type: Bitrix.DataTypes..::..BXParamsBag <(Of <(<' Object >)>)>

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод ResolveTemplateUrlDelegate

Метод BXComponent..::.ResolveTemplateUrlDelegate
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ResolveTemplateUrlDelegate(
    string template,
    Converter<string, string> valueResolver
)

Параметры

template
Type: System..::..String
valueResolver
Type: System..::..Converter <(Of <(<' String, String >)>)>

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод SetCacheOutput

Метод BXComponent..::.SetCacheOutput
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void SetCacheOutput(
    string output
)

Параметры

output
Type: System..::..String

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Метод SetParameterValue

Метод BXComponent..::.SetParameterValue
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public void SetParameterValue(
    string key,
    string value,
    bool setComponentDefinitionDirty
)

Параметры

key
Type: System..::..String
value
Type: System..::..String
setComponentDefinitionDirty
Type: System..::..Boolean

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойства BXComponent

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXComponent
Класс BXComponent Смотри также Send Feedback

Тип BXComponent предоставляет следующие возможности.

Свойства

Имя | Описание
BaseCacheKey |
CacheDuration | Возвращает или устанавливает продолжительность кеширования компонента в секундах для значения Custom свойства CacheMode.
CacheKey |
CacheMode | Возвращает или устанавливает режим кеширования компонента.
Component | Компонент, который является родителем данного компонента, если компонент является частью комплексного компонента
ComponentCache | Возвращает словарь, в который компонент может помещать результаты выполнения своего кода для дальнейшего кеширования.
ComponentRoot | Абсолютный путь к папке, в которой лежит файл компонента. Без символа '/' на конце.
ComponentTemplate | Возвращает подключенный к компоненту шаблон.
DefaultTemplatePage |
Description | Описание компонента.
DesignerLang | Возвращает текущий язык, в контексте которого работает компонент. Поддерживается также в режиме визуального редактора.
DesignerSite | Возвращает текущий сайт, в контексте которого работает компонент. Поддерживается также в режиме визуального редактора.
DesignerUrl |
EnableSef | Возвращает, включен ли режим ЧПУ компонента.
Group | Группа, в которой располагается компонент в панели компонентов визуального редактора
Icon | Иконка компонента в тулбаре. Путь указывается относительно папки, в которой находится компонент. Если требуется задать путь к иконке относительно корня приложения, то первым символом в ссылке должен быть "~/"
IsComponentDefinitionDirty | Возвращает, необходима ли перегрузка определений параметров компонента.
IsComponentDesignMode | Возвращает, находится ли компонент в режиме визуального редактора и должен ли быть отображен особенным образом.
IsRenderedFromCache | Флаг отрисовки компонента из кеша
Name | Системное имя компонента. Например, для компонента меню это свойство вернет bitrix:system.PublicMenu
Note | Заметка про компонент.
Paging |
Parameters | Параметры компонента.
ParamsDefinition | Возвращает словарь параметров компонента и их описаний.
PopupMenuInfo | Возвращает описание контекстного меню компонента для режимов Редактора и Разработчика сайта.
Results | Устаревший. В этот словарь компонент может помещать результаты выполнения своего кода.
Root | Абсолютный путь к корню веб-приложения. Заменяет символ ~. Без символа '/' на конце.
SortIndex | Индекс сортировки
Template | Имя шаблона компонента.
TemplateFolder | Возвращает виртуальный путь к папке с шаблоном компонента. Оканчивается на "/".
TemplatePath | Возвращает виртуальный путь к шаблону компонента
Title | Название компонента, которое отображается в режиме редактирования.

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство BaseCacheKey

Свойство BXComponent..::.BaseCacheKey
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected string BaseCacheKey { get; }

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство CacheDuration

Свойство BXComponent..::.CacheDuration
Класс BXComponent Пример Смотри также Send Feedback
Возвращает или устанавливает продолжительность кеширования компонента в секундах для значения Custom свойства CacheMode.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int CacheDuration { get; set; }

Заметки

Свойство возвращает значение параметра "CacheDuration" компонента.

Примеры

Создание компонента "bitrix:system.PublicMenu" вручную:

CopyC#
BXComponent component = BXComponentManager.CreateInstance("bitrix:system.PublicMenu");
component.ForcePreLoadComponentDefinition(true);
component.CacheMode = BXCacheMode.Custom;
component.CacheDuration = 30;
component.Parameters["Template"] = "tabs";
placeholder.Controls.Add(component.Process(null));

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI
BXComponent..::..CacheMode


Свойство CacheKey

Свойство BXComponent..::.CacheKey
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected string CacheKey { get; }

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство CacheMode

Свойство BXComponent..::.CacheMode
Класс BXComponent Пример Смотри также Send Feedback
Возвращает или устанавливает режим кеширования компонента.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXCacheMode CacheMode { get; set; }

Заметки

Свойство возвращает значение параметра "CacheMode" компонента.

Продолжительность кеширования компонента в секундах для значения Custom определяется свойством CacheDuration.

Примеры

Создание компонента "bitrix:system.PublicMenu" вручную:

CopyC#
BXComponent component = BXComponentManager.CreateInstance("bitrix:system.PublicMenu");
component.ForcePreLoadComponentDefinition(true);
component.CacheMode = BXCacheMode.Custom;
component.CacheDuration = 30;
component.Parameters["Template"] = "tabs";
placeholder.Controls.Add(component.Process(null));

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство Component

Свойство BXComponent..::.Component
Класс BXComponent Пример Смотри также Send Feedback
Компонент, который является родителем данного компонента, если компонент является частью комплексного компонента

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXComponent Component { get; }

Примеры

Обращение к кешированным результатам работы родительского компонента из дочерненго

CopyC#
if (this.Component != null)
{
    int recCount = Component.Results.Get("PagingTotalRecordCount", -1);

    //Здесь должен быть код

}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство ComponentCache

Свойство BXComponent..::.ComponentCache
Класс BXComponent Пример Смотри также Send Feedback
Возвращает словарь, в который компонент может помещать результаты выполнения своего кода для дальнейшего кеширования.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXComponentResults ComponentCache { get; }

Примеры

Задание компонентом заголовка страницы:

CopyC#
public string ElementName
{
    get
    {
        return ComponentCache.Get<string>("ElementName");
    }
    set
    {
        ComponentCache["ElementName"] = value;
    }
}

protected override void OnLoad(EventArgs e)
{
    if (!IsCached())
    {
        // Какой-то код

        ElementName = element.Name;

        // Какой-то код

        IncludeComponentTemplate();
    }

    if (Parameters.Get("SetTitle", false) && ElementName != null)
    {
        ((BXPublicPage)Page).BXTitle = BXTextEncoder.DefaultEncoder.Decode(ElementName);
    }
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство ComponentRoot

Свойство BXComponent..::.ComponentRoot
Класс BXComponent Пример Смотри также Send Feedback
Абсолютный путь к папке, в которой лежит файл компонента. Без символа '/' на конце.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string ComponentRoot { get; }

Заметки

Не содержит символ '/' на конце. Для сайта, установленного из дистрибутива с настройками по умолчанию вернет строку вида "/BitDotNet/bitrix/components/bitrix/system.PublicMenu". Для веб-узла, расположенного в корне вернет "/bitrix/components/bitrix/system.PublicMenu".

Примеры

Неправильная запись пути - <img src="/website/bitrix/components/menu/images/logo.gif"/>

Правильная запись пути - <img src="<%= ComponentRoot %>/images/logo.gif"/>

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство ComponentTemplate

Свойство BXComponent..::.ComponentTemplate
Класс BXComponent Смотри также Send Feedback
Возвращает подключенный к компоненту шаблон.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXComponentTemplate ComponentTemplate { get; }

Поле значения

Экземпляр шаблона или null, если шаблон не был найден.

Заметки

Факт подключения шаблона к компоненту можно отследить при помощи события TemplateIncluded

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство DefaultTemplatePage

Свойство BXComponent..::.DefaultTemplatePage
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual string DefaultTemplatePage { get; }

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство Description

Свойство BXComponent..::.Description
Класс BXComponent Пример Смотри также Send Feedback
Описание компонента.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Description { get; set; }

Примеры

Задание описания компонента:

CopyC#
protected override void PreLoadComponentDefinition()
{
    Title = "Разделы и элементы";
    Description = "Выводит элементы инфоблока сгруппированные по разделам";
    Note = "Учебный компонент";
    Group = new BXComponentGroup("tutorial-content", "Контент", 100, new BXComponentGroup("tutorial", "Обучение", 1000, null));
    Icon = "component.png";

    ParamsDefinition.Add(BXParametersDefinition.Cache);

    ParamsDefinition.Add("IBlockType", new BXParamSingleSelection("Тип инфоблока", "", BXCategory.Main));
    ParamsDefinition.Add("IBlock", new BXParamSingleSelection("Инфоблок", "", BXCategory.Main));
    ParamsDefinition.Add("IBlockSection", new BXParamSingleSelection("Раздел инфоблока", "", BXCategory.Main));
    ParamsDefinition.Add("Depth", new BXParamText("Глубина выборки", "1", BXCategory.Main));

    ParamsDefinition.Add("SectionUrlTemplate", new BXParamText("Ссылка на раздел", "?section=#SectionId#", BXCategory.UrlSettings));
    ParamsDefinition.Add("ElementUrlTemplate", new BXParamText("Ссылка на элемент", "?element=#ElementId#", BXCategory.UrlSettings));
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство DesignerLang

Свойство BXComponent..::.DesignerLang
Класс BXComponent Пример Смотри также Send Feedback
Возвращает текущий язык, в контексте которого работает компонент. Поддерживается также в режиме визуального редактора.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string DesignerLang { get; }

Примеры

Выборка предопределенных значений для списка пользовательских свойств:

CopyC#
BXIBlock iblock = BXIBlock.GetById(iblockId);
List<BXParamValue> values = new List<BXParamValue>();
foreach (BXCustomField field in iblock.CustomFields)
    values.Add(new BXParamValue(field.Localization[DesignerLang].EditFormLabel, field.Name));

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство DesignerSite

Свойство BXComponent..::.DesignerSite
Класс BXComponent Пример Смотри также Send Feedback
Возвращает текущий сайт, в контексте которого работает компонент. Поддерживается также в режиме визуального редактора.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string DesignerSite { get; }

Примеры

Выборка инфоблоков:

CopyC#
BXFilter iblockFilter = new BXFilter();
iblockFilter.Add(new BXFilterItem(BXIBlock.Fields.Active, BXSqlFilterOperators.Equal, "Y"));
iblockFilter.Add(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId));

string designerSite = DesignerSite;
if (!string.IsNullOrEmpty(designerSite))
    iblockFilter.Add(new BXFilterItem(BXIBlock.Fields.Sites.SiteId, BXSqlFilterOperators.Equal, designerSite));

//Собственно выборка
BXIBlockCollection iblockCollection = BXIBlock.GetList(
    iblockFilter,
    new BXOrderBy(new BXOrderByPair(BXIBlock.Fields.Sort, BXOrderByDirection.Asc)),
);

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство DesignerUrl

Свойство BXComponent..::.DesignerUrl
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Uri DesignerUrl { get; }

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство EnableSef

Свойство BXComponent..::.EnableSef
Класс BXComponent Пример Смотри также Send Feedback
Возвращает, включен ли режим ЧПУ компонента.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool EnableSef { get; }

Заметки

Свойство возвращает значение параметра "EnableSef" компонента.

Продолжительность кеширования компонента в секундах для значения Custom определяется свойством CacheDuration.

Примеры

Формирование ссылки на страницу элемента:

CopyC#
BXParamsBag<object> vars = new BXParamsBag<object>();
vars.Add("ElementId", 2);

string url;
if (EnableSef)
    url = MakeLink(
        Parameters.Get("SefFolder"),
        "/#ElementId#.aspx",
        vars
    );
else
    url = MakeLink(
        BXSefUrlManager.CurrentUrl.AbsolutePath + "?element=#ElementId#",
        vars
    );

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство Group

Свойство BXComponent..::.Group
Класс BXComponent Пример Смотри также Send Feedback
Группа, в которой располагается компонент в панели компонентов визуального редактора

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXComponentGroup Group { get; set; }

Заметки

Предопределенные группы верхнего уровня можно получить через статические свойства класса BXComponentGroup.

Примеры

Задание описания компонента:

CopyC#
protected override void PreLoadComponentDefinition()
{
    Title = "Разделы и элементы";
    Description = "Выводит элементы инфоблока сгруппированные по разделам";
    Note = "Учебный компонент";
    Group = new BXComponentGroup("tutorial-content", "Контент", 100, new BXComponentGroup("tutorial", "Обучение", 1000, null));
    Icon = "component.png";

    ParamsDefinition.Add(BXParametersDefinition.Cache);

    ParamsDefinition.Add("IBlockType", new BXParamSingleSelection("Тип инфоблока", "", BXCategory.Main));
    ParamsDefinition.Add("IBlock", new BXParamSingleSelection("Инфоблок", "", BXCategory.Main));
    ParamsDefinition.Add("IBlockSection", new BXParamSingleSelection("Раздел инфоблока", "", BXCategory.Main));
    ParamsDefinition.Add("Depth", new BXParamText("Глубина выборки", "1", BXCategory.Main));

    ParamsDefinition.Add("SectionUrlTemplate", new BXParamText("Ссылка на раздел", "?section=#SectionId#", BXCategory.UrlSettings));
    ParamsDefinition.Add("ElementUrlTemplate", new BXParamText("Ссылка на элемент", "?element=#ElementId#", BXCategory.UrlSettings));
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство Icon

Свойство BXComponent..::.Icon
Класс BXComponent Пример Смотри также Send Feedback
Иконка компонента в тулбаре. Путь указывается относительно папки, в которой находится компонент. Если требуется задать путь к иконке относительно корня приложения, то первым символом в ссылке должен быть "~/"

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Icon { get; set; }

Примеры

Задание описания компонента:

CopyC#
protected override void PreLoadComponentDefinition()
{
    Title = "Разделы и элементы";
    Description = "Выводит элементы инфоблока сгруппированные по разделам";
    Note = "Учебный компонент";
    Group = new BXComponentGroup("tutorial-content", "Контент", 100, new BXComponentGroup("tutorial", "Обучение", 1000, null));
    Icon = "component.png";

    ParamsDefinition.Add(BXParametersDefinition.Cache);

    ParamsDefinition.Add("IBlockType", new BXParamSingleSelection("Тип инфоблока", "", BXCategory.Main));
    ParamsDefinition.Add("IBlock", new BXParamSingleSelection("Инфоблок", "", BXCategory.Main));
    ParamsDefinition.Add("IBlockSection", new BXParamSingleSelection("Раздел инфоблока", "", BXCategory.Main));
    ParamsDefinition.Add("Depth", new BXParamText("Глубина выборки", "1", BXCategory.Main));

    ParamsDefinition.Add("SectionUrlTemplate", new BXParamText("Ссылка на раздел", "?section=#SectionId#", BXCategory.UrlSettings));
    ParamsDefinition.Add("ElementUrlTemplate", new BXParamText("Ссылка на элемент", "?element=#ElementId#", BXCategory.UrlSettings));
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство IsComponentDefinitionDirty

Свойство BXComponent..::.IsComponentDefinitionDirty
Класс BXComponent Смотри также Send Feedback
Возвращает, необходима ли перегрузка определений параметров компонента.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool IsComponentDefinitionDirty { get; }

Заметки

Нужен только при отладке. В остальных случаях достаточно EnsureComponentDefinition().

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство IsComponentDesignMode

Свойство BXComponent..::.IsComponentDesignMode
Класс BXComponent Пример Смотри также Send Feedback
Возвращает, находится ли компонент в режиме визуального редактора и должен ли быть отображен особенным образом.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool IsComponentDesignMode { get; }

Примеры

Выставляем заголовок страницы только когда компонент работает в обычном режмие:

CopyC#
if (!IsComponentDesignMode)
    ((BXPublicPage)Page).BXTitle = "Страница с моим компонентом";

Выводим RSS только в режиме просмотра. В режиме редактора, разработчика и в визуальном редакторе выводим содержимое RSS в виде HTML:

CopyC#
if (IsComponentDesignMode || BXConfigurationUtility.IsDesignMode)
{
    HtmlTextWriter writer2 = new HtmlTextWriter(new System.IO.StringWriter(System.Globalization.CultureInfo.CurrentCulture));
    base.Render(writer2);
    if (BXConfigurationUtility.IsDesignMode)
        writer.Write("<pre style='width:500px;overflow:scroll;'>");
    else
        writer.Write("<pre>");
    writer.Write(HttpUtility.HtmlEncode(writer2.InnerWriter.ToString())+"</pre>");
}
else
{
    Response.Buffer = true;
    writer.Flush();
    Response.Clear();
    HtmlTextWriter writer2 = new HtmlTextWriter(new System.IO.StringWriter(System.Globalization.CultureInfo.CurrentCulture));
    base.Render(writer2);
    Response.ContentType = "text/xml";
    Response.Write(writer2.InnerWriter.ToString());
    Response.End();
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство IsRenderedFromCache

Свойство BXComponent..::.IsRenderedFromCache
Класс BXComponent Смотри также Send Feedback
Флаг отрисовки компонента из кеша

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool IsRenderedFromCache { get; }

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство Name

Свойство BXComponent..::.Name
Класс BXComponent Пример Смотри также Send Feedback
Системное имя компонента. Например, для компонента меню это свойство вернет bitrix:system.PublicMenu

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Name { get; set; }

Примеры

Получение пути к файлу шаблона для компонента:

CopyC#
string templatePath = BXComponentManager.GetTemplatePath(
    component.Name,
    component.Template,
    siteTemplate,
    componentPage,
    component.Component
);

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство Note

Свойство BXComponent..::.Note
Класс BXComponent Пример Смотри также Send Feedback
Заметка про компонент.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Note { get; set; }

Примеры

Задание описания компонента:

CopyC#
protected override void PreLoadComponentDefinition()
{
    Title = "Разделы и элементы";
    Description = "Выводит элементы инфоблока сгруппированные по разделам";
    Note = "Учебный компонент";
    Group = new BXComponentGroup("tutorial-content", "Контент", 100, new BXComponentGroup("tutorial", "Обучение", 1000, null));
    Icon = "component.png";

    ParamsDefinition.Add(BXParametersDefinition.Cache);

    ParamsDefinition.Add("IBlockType", new BXParamSingleSelection("Тип инфоблока", "", BXCategory.Main));
    ParamsDefinition.Add("IBlock", new BXParamSingleSelection("Инфоблок", "", BXCategory.Main));
    ParamsDefinition.Add("IBlockSection", new BXParamSingleSelection("Раздел инфоблока", "", BXCategory.Main));
    ParamsDefinition.Add("Depth", new BXParamText("Глубина выборки", "1", BXCategory.Main));

    ParamsDefinition.Add("SectionUrlTemplate", new BXParamText("Ссылка на раздел", "?section=#SectionId#", BXCategory.UrlSettings));
    ParamsDefinition.Add("ElementUrlTemplate", new BXParamText("Ссылка на элемент", "?element=#ElementId#", BXCategory.UrlSettings));
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство Paging

Свойство BXComponent..::.Paging
Класс BXComponent Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXPaging Paging { get; }

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство Parameters

Свойство BXComponent..::.Parameters
Класс BXComponent Пример Смотри также Send Feedback
Параметры компонента.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXComponentParameters Parameters { get; }

Заметки

Параметры компонента представлены строковыми значениями и должны быть предварительно приведены к надлежащим типам. Это можно сделать, например, методами класса BXComponentParameters.

Параметры компонента могут быть настроены через визуальный редактор, редактор параметров компонента в публичной части сайта в режиме разработчика, вручную как атрибуты IncludeComponent.

Параметры компонента передаются от компонентов к шаблонам, а также наследуются дочерними компонентами от родительских компонентов. Способ наследования определяется свойством IncludeComponent.OverrideMode а также . редактор параметров компонента в публичной части сайта в режиме разработчика, вручную как атрибуты IncludeComponent.

Примеры

Создание типизированных оберток для параметров компонента:

CopyC#
public int IBlockId
{
    get
    {
        return Math.Max(Parameters.Get<int>("IBlock"), 0);
    }
}
public int IBlockSectionId
{
    get
    {
        return Math.Max(Parameters.Get<int>("IBlockSection"), 0);
    }
}
public int Depth
{
    get
    {
        return Math.Max(Parameters.Get<int>("Depth"), 1);
    }
}
public string SectionUrlTemplate
{
    get
    {
        return Parameters.Get<string>("SectionUrlTemplate");
    }
}
public string ElementUrlTemplate
{
    get
    {
        return Parameters.Get<string>("ElementUrlTemplate");
    }
}

Формирование ссылки на элемент в комплексном компоненте:

CopyC#
if (Parameters.Get<bool>("EnableSEF"))
    url = MakeLink(
        Parameters.Get<string>("SEFFolder"),
        Parameters.Get<string>("SEF_URL_TEMPLATES_element", "#SECTION_ID#/#ELEMENT_ID#/")
    )
else
    url = MakeLink(
        string.Format(
            "{0}?{1}=#SECTION_ID#&{2}=#ELEMENT_ID#",
            VirtualPathUtility.ToAbsolute(executionVirtualPath),
            Parameters.Get<string>("VARIABLE_ALIASES_SECTION_ID", "SECTION_ID"),
            Parameters.Get<string>("VARIABLE_ALIASES_ELEMENT_ID", "ELEMENT_ID")
        ),
        ComponentCache
    );

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI
Bitrix.Components..::..BXComponentParameters
IncludeComponent


Свойство ParamsDefinition

Свойство BXComponent..::.ParamsDefinition
Класс BXComponent Пример Смотри также Send Feedback
Возвращает словарь параметров компонента и их описаний.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXParametersDefinition ParamsDefinition { get; }

Примеры

Задание описания компонента:

CopyC#
protected override void PreLoadComponentDefinition()
{
    Title = "Разделы и элементы";
    Description = "Выводит элементы инфоблока сгруппированные по разделам";
    Note = "Учебный компонент";
    Group = new BXComponentGroup("tutorial-content", "Контент", 100, new BXComponentGroup("tutorial", "Обучение", 1000, null));
    Icon = "component.png";

    ParamsDefinition.Add(BXParametersDefinition.Cache);

    ParamsDefinition.Add("IBlockType", new BXParamSingleSelection("Тип инфоблока", "", BXCategory.Main));
    ParamsDefinition.Add("IBlock", new BXParamSingleSelection("Инфоблок", "", BXCategory.Main));
    ParamsDefinition.Add("IBlockSection", new BXParamSingleSelection("Раздел инфоблока", "", BXCategory.Main));
    ParamsDefinition.Add("Depth", new BXParamText("Глубина выборки", "1", BXCategory.Main));

    ParamsDefinition.Add("SectionUrlTemplate", new BXParamText("Ссылка на раздел", "?section=#SectionId#", BXCategory.UrlSettings));
    ParamsDefinition.Add("ElementUrlTemplate", new BXParamText("Ссылка на элемент", "?element=#ElementId#", BXCategory.UrlSettings));
}

Задание расширенного описания компонента:

CopyC#
//Метод возвращает предопределенных значений для типов инфоблоков
private List<BXParamValue> GetIBlockTypeParamValues()
{
    List<BXParamValue> values = new List<BXParamValue>();

    //Пустое значение
    values.Add(new BXParamValue("-", ""));

    //Собственно выборка всех типов инфоблока
    BXIBlockTypeCollection typeCollection = BXIBlockType.GetList(
        null,
        new BXOrderBy(new BXOrderByPair(BXIBlockType.Fields.Sort, BXOrderByDirection.Asc)),
        null,
        null,
        BXTextEncoder.EmptyTextEncoder
    );
    foreach (BXIBlockType t in typeCollection)
        values.Add(new BXParamValue(t.Translations[BXLoc.CurrentLocale].Name, t.Id.ToString()));

    return values;
}

//Метод возвращает предопределенных значений для инфоблоков определенного типа
private List<BXParamValue> GetIBlockParamValues(int iblockTypeId)
{
    List<BXParamValue> values = new List<BXParamValue>();

    BXFilter iblockFilter = new BXFilter();
    iblockFilter.Add(new BXFilterItem(BXIBlock.Fields.Active, BXSqlFilterOperators.Equal, "Y"));

    //Если предоставлен корректный ID типа инфоблока, то выбираем только инфоблоки этого типа
    if (iblockTypeId > 0)
        iblockFilter.Add(new BXFilterItem(BXIBlock.Fields.Type.ID, BXSqlFilterOperators.Equal, iblockTypeId));

    //Если можно определить сайт, на котором расположен компонент, то выбираем только инфоблоки, принадлежащие этому сайту
    string designerSite = DesignerSite;
    if (!string.IsNullOrEmpty(designerSite))
        iblockFilter.Add(new BXFilterItem(BXIBlock.Fields.Sites.SiteId, BXSqlFilterOperators.Equal, designerSite));

    //Собственно выборка
    BXIBlockCollection iblockCollection = BXIBlock.GetList(
        iblockFilter,
        new BXOrderBy(new BXOrderByPair(BXIBlock.Fields.Sort, BXOrderByDirection.Asc)),
        null,
        null,
        BXTextEncoder.EmptyTextEncoder
    );
    foreach (BXIBlock b in iblockCollection)
        values.Add(new BXParamValue(b.Name, b.Id.ToString()));

    return values;
}

//Метод возвращает предопределенных значений для секций определенного инфоблока
private List<BXParamValue> GetIBlockSectionParamValues(int iblockId)
{

    List<BXParamValue> values = new List<BXParamValue>();

    //Пустое значение - соответствует корневому разделу инфоблока
    values.Add(new BXParamValue("-", ""));

    //Если задан некорректный ID инфоблока, производить выборку бессмысленно
    if (iblockId <= 0)
        return values;

    //Собственно выборка секций, упорядоченных по вложенности
    BXIBlockSectionCollection sections = BXIBlockSection.GetList(
        new BXFilter(
            new BXFilterItem(BXIBlockSection.Fields.IBlock.ID, BXSqlFilterOperators.Equal, iblockId),
            new BXFilterItem(BXIBlockSection.Fields.Active, BXSqlFilterOperators.Equal, "Y")
        ),
        new BXOrderBy(
            new BXOrderByPair(BXIBlockSection.Fields.LeftMargin, BXOrderByDirection.Asc)
        ),
        null,
        null,
        BXTextEncoder.EmptyTextEncoder
    );
    foreach (BXIBlockSection section in sections)
        values.Add(new BXParamValue(new string('-', section.DepthLevel - 1) + " " + section.Name, section.Id.ToString()));

    return values;
}

protected override void LoadComponentDefinition()
{
    // Редактор свойств компонента должен обновить список свойств компонента при изменении типа инфоблока
    ParamsDefinition["IBlockType"].RefreshOnDirty = true;
    // Задаем список предопределенных типов инфоблоков
    ParamsDefinition["IBlockType"].Values = GetIBlockTypeParamValues();

    // Редактор свойств компонента должен обновить список свойств компонента при изменении инфоблока
    ParamsDefinition["IBlock"].RefreshOnDirty = true;
    // Задаем список предопределенных инфоблоков
    ParamsDefinition["IBlock"].Values = GetIBlockParamValues(Parameters.Get("IBlockType", 0));

    // Задаем список предопределенных секций инфоблока
    ParamsDefinition["IBlockSection"].Values = GetIBlockSectionParamValues(Parameters.Get("IBlock", 0));
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство PopupMenuInfo

Свойство BXComponent..::.PopupMenuInfo
Класс BXComponent Пример Смотри также Send Feedback
Возвращает описание контекстного меню компонента для режимов Редактора и Разработчика сайта.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual BXComponentPopupMenuInfo PopupMenuInfo { get; }

Заметки

Используется в компонентах чтобы задать собственные пункты контекстного меню компонента для режимов Редактора и Разработчика сайта.

Примеры

Добавление кнопки "Добавить новость" в контекстное меню
CopyC#
private BXPopupMenuItem[] GetMenuItems()
{
    BXPopupMenuItem[] menuItems = new BXPopupMenuItem[1];

    menuItems[0] = new BXPopupMenuItem();
    menuItems[0].BackgroundImagePath = BXPath.Combine(BXComponentManager.GetFolder(Name), "/images/new_element.gif");
    menuItems[0].ID = String.Format("element_new_{0}", IBlockId);
    menuItems[0].Text = String.Format(GetMessageRaw("AddNewElement"), String.IsNullOrEmpty(IBlockElementName) ? GetMessageRaw("IBlockElementName") : IBlockElementName.ToLower());
    menuItems[0].ClientClickScript =
        String.Format(
            "jsUtils.Redirect(arguments, '{0}?iblock_id={1}&type_id={2}&{3}={4}')",
            VirtualPathUtility.ToAbsolute("~/bitrix/admin/IBlockElementEdit.aspx"),
            IBlockId,
            IBlockTypeId,
            BXConfigurationUtility.Constants.BackUrl,
            UrlEncode(BXSefUrlManager.CurrentUrl.PathAndQuery)
        );

    return menuItems;
}
public override BXComponentPopupMenuInfo PopupMenuInfo
{
    get
    {
        BXComponentPopupMenuInfo info = base.PopupMenuInfo;

        if (BXIBlock.IsUserCanOperate(IBlockId, BXIBlock.Operations.IBlockAdminRead) &&
            BXIBlock.IsUserCanOperate(IBlockId, BXIBlock.Operations.IBlockModifyElements) && !isErrorOccured)
        {
            info.CreateCustomPopupMenuItems = delegate(BXShowMode showMode)
            {
                if (showMode != BXShowMode.View)
                    return GetMenuItems();
                else
                    return null;
            };
        }
        return info;
    }
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство Results

Свойство BXComponent..::.Results
Класс BXComponent Смотри также Send Feedback
В этот словарь компонент может помещать результаты выполнения своего кода.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
[ObsoleteAttribute("use ComponentCache")]
public BXComponentResults Results { get; }

Заметки

Устаревшее. Используйте ComponentCache вместо.

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство Root

Свойство BXComponent..::.Root
Класс BXComponent Пример Смотри также Send Feedback
Абсолютный путь к корню веб-приложения. Заменяет символ ~. Без символа '/' на конце.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Root { get; }

Заметки

Не содержит символ '/' на конце. Для сайта, установленного из дистрибутива с настройками по умолчанию вернет строку вида "/BitDotNet". Для веб-узла, расположенного в корне вернет "".

Примеры

Неправильная запись пути - <img src="/website/images/logo.gif"/>

Правильная запись пути - <img src="<%= Root %>/images/logo.gif"/>

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство SortIndex

Свойство BXComponent..::.SortIndex
Класс BXComponent Смотри также Send Feedback
Индекс сортировки

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int SortIndex { get; set; }

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство Template

Свойство BXComponent..::.Template
Класс BXComponent Пример Смотри также Send Feedback
Имя шаблона компонента.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Template { get; }

Примеры

Получение пути к файлу шаблона для компонента:

CopyC#
string templatePath = BXComponentManager.GetTemplatePath(
    component.Name,
    component.Template,
    siteTemplate,
    componentPage,
    component.Component
);

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство TemplateFolder

Свойство BXComponent..::.TemplateFolder
Класс BXComponent Пример Смотри также Send Feedback
Возвращает виртуальный путь к папке с шаблоном компонента. Оканчивается на "/".

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string TemplateFolder { get; }

Поле значения

Возвращает значение вида "~/bitrix/templates/site_template/components/bitrix/system.PublicMenu/.default/"

Примеры

Подключение компонентом особых стилей из папки с шаблоном:

CopyC#
BXPage.RegisterStyle(TemplateFolder + "extrastyle.css");

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство TemplatePath

Свойство BXComponent..::.TemplatePath
Класс BXComponent Пример Смотри также Send Feedback
Возвращает виртуальный путь к шаблону компонента

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string TemplatePath { get; }

Примеры

Переход на страницу редактирования шаблона компонента

CopyC#
Response.Redirect(VirtualPathUtility.ToAbsolute("~/bitrix/admin/FileManEdit.aspx") + "?path=" + HttpUtility.UrlEncode(TemplatePath));

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Свойство Title

Свойство BXComponent..::.Title
Класс BXComponent Пример Смотри также Send Feedback
Название компонента, которое отображается в режиме редактирования.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string Title { get; set; }

Примеры

Задание описания компонента:

CopyC#
protected override void PreLoadComponentDefinition()
{
    Title = "Разделы и элементы";
    Description = "Выводит элементы инфоблока сгруппированные по разделам";
    Note = "Учебный компонент";
    Group = new BXComponentGroup("tutorial-content", "Контент", 100, new BXComponentGroup("tutorial", "Обучение", 1000, null));
    Icon = "component.png";

    ParamsDefinition.Add(BXParametersDefinition.Cache);

    ParamsDefinition.Add("IBlockType", new BXParamSingleSelection("Тип инфоблока", "", BXCategory.Main));
    ParamsDefinition.Add("IBlock", new BXParamSingleSelection("Инфоблок", "", BXCategory.Main));
    ParamsDefinition.Add("IBlockSection", new BXParamSingleSelection("Раздел инфоблока", "", BXCategory.Main));
    ParamsDefinition.Add("Depth", new BXParamText("Глубина выборки", "1", BXCategory.Main));

    ParamsDefinition.Add("SectionUrlTemplate", new BXParamText("Ссылка на раздел", "?section=#SectionId#", BXCategory.UrlSettings));
    ParamsDefinition.Add("ElementUrlTemplate", new BXParamText("Ссылка на элемент", "?element=#ElementId#", BXCategory.UrlSettings));
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


События BXComponent

[image]

1С-Битрикс: Управление сайтом ASP.NET
События BXComponent
Класс BXComponent Смотри также Send Feedback

Тип BXComponent предоставляет следующие возможности.

События

Имя | Описание
TemplateIncluded | Срабатывает после того, как компонент подключил свой шаблон.

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Событие TemplateIncluded

Событие BXComponent..::.TemplateIncluded
Класс BXComponent Пример Смотри также Send Feedback
Срабатывает после того, как компонент подключил свой шаблон.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public event EventHandler TemplateIncluded

Примеры

Копирование шаблона для компонента документа:

CopyC#
protected override void OnInit(EventArgs e)
{
    base.OnInit(e);

    BXComponent component = BXComponentManager.CreateInstance("bitrix:system.PublicMenu");
    component.ForcePreLoadComponentDefinition();
    component.ResetParameters();
    component.Parameters["Template"] = "flat";

    component.TemplateIncluded += new EventHandler(component_TemplateIncluded);
    component.Process(null);
}

void component_TemplateIncluded(object sender, EventArgs e)
{
    BXComponent component = sender as BXComponent;
    BXSecureIO.DirectoryCopy(component.TemplateFolder, "~/bitrix/templates/my_site/components/bitrix/system.PublicMenu/newTemplate");
}

Смотри также

Класс BXComponent
Пространство имен Bitrix.UI


Структура BXComponent.BXPagingParams

Структура BXComponent..::..BXPagingParams
Класс BXComponent Члены Смотри также Send Feedback
Содержит входные параметры постраничного разбиения

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected struct BXPagingParams

Смотри также

Члены BXComponent..::..BXPagingParams
Пространство имен Bitrix.UI


Члены BXComponent.BXPagingParams

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXComponent..::..BXPagingParams
Структура BXComponent..::..BXPagingParams Методы Поля Смотри также Send Feedback

Базовый класс для всех компонентов в системе

Тип BXComponent..::..BXPagingParams предоставляет следующие возможности.

Методы

Имя | Описание
GetHashCode | (Переопределяет ValueType..::..GetHashCode()()()())

Поля

Имя | Описание
AllowPaging | Разрешено ли постраничное разбиение
Page | Входной номер страницы (или null, если он отсутствует)
RecordsPerPage | Количество записей на одной странице
ShowAll | Показывать ли все страницы

Смотри также

Структура BXComponent..::..BXPagingParams
Пространство имен Bitrix.UI


Поля BXComponent.BXPagingParams

[image]

1С-Битрикс: Управление сайтом ASP.NET
Поля BXComponent..::..BXPagingParams
Структура BXComponent..::..BXPagingParams Смотри также Send Feedback

Тип BXComponent..::..BXPagingParams предоставляет следующие возможности.

Поля

Имя | Описание
AllowPaging | Разрешено ли постраничное разбиение
Page | Входной номер страницы (или null, если он отсутствует)
RecordsPerPage | Количество записей на одной странице
ShowAll | Показывать ли все страницы

Смотри также

Структура BXComponent..::..BXPagingParams
Пространство имен Bitrix.UI


Поле AllowPaging

Поле BXComponent..::..BXPagingParams..::.AllowPaging
Структура BXComponent..::..BXPagingParams Смотри также Send Feedback
Разрешено ли постраничное разбиение

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool AllowPaging

Смотри также

Структура BXComponent..::..BXPagingParams
Пространство имен Bitrix.UI


Поле Page

Поле BXComponent..::..BXPagingParams..::.Page
Структура BXComponent..::..BXPagingParams Смотри также Send Feedback
Входной номер страницы (или null, если он отсутствует)

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public Nullable<int> Page

Смотри также

Структура BXComponent..::..BXPagingParams
Пространство имен Bitrix.UI


Поле RecordsPerPage

Поле BXComponent..::..BXPagingParams..::.RecordsPerPage
Структура BXComponent..::..BXPagingParams Смотри также Send Feedback
Количество записей на одной странице

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public int RecordsPerPage

Смотри также

Структура BXComponent..::..BXPagingParams
Пространство имен Bitrix.UI


Поле ShowAll

Поле BXComponent..::..BXPagingParams..::.ShowAll
Структура BXComponent..::..BXPagingParams Смотри также Send Feedback
Показывать ли все страницы

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool ShowAll

Смотри также

Структура BXComponent..::..BXPagingParams
Пространство имен Bitrix.UI


Методы BXComponent.BXPagingParams

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXComponent..::..BXPagingParams
Структура BXComponent..::..BXPagingParams Смотри также Send Feedback

Тип BXComponent..::..BXPagingParams предоставляет следующие возможности.

Методы

Имя | Описание
GetHashCode | (Переопределяет ValueType..::..GetHashCode()()()())

Смотри также

Структура BXComponent..::..BXPagingParams
Пространство имен Bitrix.UI


Метод GetHashCode

Метод BXComponent..::..BXPagingParams..::.GetHashCode
Структура BXComponent..::..BXPagingParams Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public override int GetHashCode()

Смотри также

Структура BXComponent..::..BXPagingParams
Пространство имен Bitrix.UI


Делегат BXComponent.GetTotalCountMethod

Делегат BXComponent..::..GetTotalCountMethod
Класс BXComponent Смотри также Send Feedback
Делегат для подсчета количества элементов в источнике данных

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public delegate int GetTotalCountMethod()

Возвращаемое значение

Количество элементов в источнике данных с учетом текущих фильтров

Смотри также

Пространство имен Bitrix.UI


Класс BXComponentTemplate

Класс BXComponentTemplate
Члены Пример Смотри также Send Feedback
Базовый класс для шаблона компонента

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXComponentTemplate : BXControl

Заметки

Рекомендуется для каждого компонента компонента создавать отдельный класс шаблона (в котором можно объявить специфические строго типизированные методы и свойства), который унаследован от обобщенного класса шаблона.

Примеры

Определение класса шаблона вместе с классом компонента:

CopyC#
using System;
using System.Data;
using System.Configuration;
using System.Collections;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;
using Bitrix.UI;
using Bitrix.Components;

namespace Tutorial
{
    public partial class IBlockHierarchyComponent : BXComponent
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            ...
        }
    }

    public class IBlockHierarchyTemplate : BXComponentTemplate<IBlockHierarchyComponent>
    {

    }
}

Определение шаблона, который унаследован от класса, объявленного вместе с компонентом:

CopyC#
<%@ Reference Control="~/bitrix/components/tutorial/iblock.hierarchy/component.ascx" %>
<%@ Control Language="C#" Inherits="Tutorial.IBlockHierarchyTemplate" %>

<script runat="server">

</script>

Иерархия наследования

System..::..Object
System.Web.UI..::..Control
System.Web.UI..::..TemplateControl
System.Web.UI..::..UserControl
BXControl
Bitrix.UI..::..BXComponentTemplate
Bitrix.UI..::..BXComponentTemplate<(Of <(<'T>)>)>

Смотри также

Члены BXComponentTemplate
Пространство имен Bitrix.UI


Члены BXComponentTemplate

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXComponentTemplate
Класс BXComponentTemplate Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXComponentTemplate предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXComponentTemplate | Создает экземпляр класса шаблона компонента.

Методы

Имя | Описание
LoadTemplateDefinition |
OnPreRender | (Переопределяет Control..::..OnPreRender(EventArgs))
PreLoadTemplateDefinition |
PrepareDesignMode | Перегруженный.
Render | Дополняет базовый метод Render обработкой режима визуального редактора. (Переопределяет Control..::..Render(HtmlTextWriter))

Свойства

Имя | Описание
Component | Возвращает компонент, которому принадлежит этот шаблон. Рекомендуется наследовать шаблон от конкретизированного класса BXComponentTemplate<(Of <(<'T>)>)> и использовать его свойство Component.
CurrentWriter | Возвращает текущий HtmlTextWriter во время отрисовки шаблона и null в остальное время
IsComponentDesignMode | Возвращает true, если компонент редактируется в редакторе и должен быть отображен особенным образом.
MinimalHeight | Возвращает или устанавливает минимальную высоту шаблона компонента в режиме визуального редактора.
MinimalWidth | Возвращает или устанавливает минимальную ширину шаблона компонента в режиме визуального редактора.
Parameters | Возвращает словарь параметров компонента.
Results | Устаревший. Возвращает словарь результатов выполнения кода компонента.
StartHeight | Возвращает или устанавливает начальную высоту шаблона компонента в режиме визуального редактора.
StartWidth | Возвращает или устанавливает начальную ширину шаблона компонента в режиме визуального редактора.
TemplateName | Возвращает имя шаблона, например ".default"
Title | Возвращает название шаблона

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Конструктор BXComponentTemplate

Конструктор BXComponentTemplate
Класс BXComponentTemplate Смотри также Send Feedback
Создает экземпляр класса шаблона компонента.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXComponentTemplate()

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Методы BXComponentTemplate

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXComponentTemplate
Класс BXComponentTemplate Смотри также Send Feedback

Тип BXComponentTemplate предоставляет следующие возможности.

Методы

Имя | Описание
LoadTemplateDefinition |
OnPreRender | (Переопределяет Control..::..OnPreRender(EventArgs))
PreLoadTemplateDefinition |
PrepareDesignMode | Перегруженный.
Render | Дополняет базовый метод Render обработкой режима визуального редактора. (Переопределяет Control..::..Render(HtmlTextWriter))

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Метод LoadTemplateDefinition

Метод BXComponentTemplate..::.LoadTemplateDefinition
Класс BXComponentTemplate Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected internal virtual void LoadTemplateDefinition(
    BXParametersDefinition def
)

Параметры

def
Type: BXParametersDefinition

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Метод OnPreRender

Метод BXComponentTemplate..::.OnPreRender
Класс BXComponentTemplate Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override void OnPreRender(
    EventArgs e
)

Параметры

e
Type: System..::..EventArgs

Заметки

Метод регистрирует скрипты и стили шаблона компонента.

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Метод PreLoadTemplateDefinition

Метод BXComponentTemplate..::.PreLoadTemplateDefinition
Класс BXComponentTemplate Смотри также Send Feedback

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected internal virtual void PreLoadTemplateDefinition(
    BXParametersDefinition def
)

Параметры

def
Type: BXParametersDefinition

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Метод PrepareDesignMode

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentTemplate..::.PrepareDesignMode
Класс BXComponentTemplate Смотри также Send Feedback

Лист перегрузки

Имя | Описание
PrepareDesignMode()()()() | Задает настройки отображения для визуального редактора
PrepareDesignMode(HtmlTextWriter) | Передает настройки отображения визуальному редактору

Смотри также

Класс BXComponentTemplate
Члены BXComponentTemplate
Пространство имен Bitrix.UI


Метод PrepareDesignMode

Метод BXComponentTemplate..::.PrepareDesignMode
Класс BXComponentTemplate Пример Смотри также Send Feedback
Задает настройки отображения для визуального редактора

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void PrepareDesignMode()

Заметки

Перегружая этод метод можно задать настройки отображения в визуальном редакторе и загрузить демо данные на случай, если компонент настроен неправильно.

Метод вызывается непосредственно перед отрисовкой шаблона в режиме дизайнера.

Примеры

Переопределение в дочернем классе шаблона
CopyC#
protected override void PrepareDesignMode()
{
    MinimalWidth = "175";
    MinimalHeight = "45";
    StartWidth = "300px";
    StartHeight = "170px";

    if (data == null)
        LoadDemoData();
}

Смотри также

Класс BXComponentTemplate
Перегрузка PrepareDesignMode
Пространство имен Bitrix.UI


Метод PrepareDesignMode (HtmlTextWriter)

Метод BXComponentTemplate..::.PrepareDesignMode (HtmlTextWriter)
Класс BXComponentTemplate Пример Смотри также Send Feedback
Передает настройки отображения визуальному редактору

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected virtual void PrepareDesignMode(
    HtmlTextWriter writer
)

Параметры

writer
Type: System.Web.UI..::..HtmlTextWriter
Выходной Html поток, в который будут записаны настройки

Заметки

Метод выполняет работу по передаче параметров визуальному редактору, поэтому в перегруженном методе необходимо вызвать метод родительского класса после того как будут настроены параметры.

Рекомендуется использовать метод PrepareDesignMode()()()().

Примеры

Переопределение в дочернем классе шаблона
CopyC#
protected override void PrepareDesignMode(HtmlTextWriter writer)
{
    MinimalWidth = "175";
    MinimalHeight = "45";
    StartWidth = "300px";
    StartHeight = "170px";

    // Обязательно вызываем базовый метод после задания параметров
    base.PrepareDesignMode(writer);
}

Смотри также

Класс BXComponentTemplate
Перегрузка PrepareDesignMode
Пространство имен Bitrix.UI


Метод Render

Метод BXComponentTemplate..::.Render
Класс BXComponentTemplate Смотри также Send Feedback
Дополняет базовый метод Render обработкой режима визуального редактора.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected override void Render(
    HtmlTextWriter writer
)

Параметры

writer
Type: System.Web.UI..::..HtmlTextWriter

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Свойства BXComponentTemplate

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXComponentTemplate
Класс BXComponentTemplate Смотри также Send Feedback

Тип BXComponentTemplate предоставляет следующие возможности.

Свойства

Имя | Описание
Component | Возвращает компонент, которому принадлежит этот шаблон. Рекомендуется наследовать шаблон от конкретизированного класса BXComponentTemplate<(Of <(<'T>)>)> и использовать его свойство Component.
CurrentWriter | Возвращает текущий HtmlTextWriter во время отрисовки шаблона и null в остальное время
IsComponentDesignMode | Возвращает true, если компонент редактируется в редакторе и должен быть отображен особенным образом.
MinimalHeight | Возвращает или устанавливает минимальную высоту шаблона компонента в режиме визуального редактора.
MinimalWidth | Возвращает или устанавливает минимальную ширину шаблона компонента в режиме визуального редактора.
Parameters | Возвращает словарь параметров компонента.
Results | Устаревший. Возвращает словарь результатов выполнения кода компонента.
StartHeight | Возвращает или устанавливает начальную высоту шаблона компонента в режиме визуального редактора.
StartWidth | Возвращает или устанавливает начальную ширину шаблона компонента в режиме визуального редактора.
TemplateName | Возвращает имя шаблона, например ".default"
Title | Возвращает название шаблона

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Свойство Component

Свойство BXComponentTemplate..::.Component
Класс BXComponentTemplate Пример Смотри также Send Feedback
Возвращает компонент, которому принадлежит этот шаблон. Рекомендуется наследовать шаблон от конкретизированного класса BXComponentTemplate<(Of <(<'T>)>)> и использовать его свойство Component.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXComponent Component { get; }

Примеры

Обработка нажатия по кнопке поиска в шаблоне компонента "bitrix:search.form"

CopyC#
protected void Search_Click(object sender, EventArgs args)
{
    BXParamsBag<object> p = new BXParamsBag<object>();
    p.Add("query", query.Text);

    Component.ProcessCommand("search", p, new List<string>());
}

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Свойство CurrentWriter

Свойство BXComponentTemplate..::.CurrentWriter
Класс BXComponentTemplate Смотри также Send Feedback
Возвращает текущий HtmlTextWriter во время отрисовки шаблона и null в остальное время

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected HtmlTextWriter CurrentWriter { get; }

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Свойство IsComponentDesignMode

Свойство BXComponentTemplate..::.IsComponentDesignMode
Класс BXComponentTemplate Пример Смотри также Send Feedback
Возвращает true, если компонент редактируется в редакторе и должен быть отображен особенным образом.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public bool IsComponentDesignMode { get; }

Примеры

Определение особых параметров отрисовки для шаблона компонента "bitrix:news.detail"

CopyC#
public class NewsDetailTemplate : BXComponentTemplate<NewsDetail>
{
    protected override void Render(HtmlTextWriter writer)
    {
        if (IsComponentDesignMode && Component.Element == null)
            writer.Write("Необходимо настроить компонент.");
        else
            base.Render(writer);
    }
}

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Свойство MinimalHeight

Свойство BXComponentTemplate..::.MinimalHeight
Класс BXComponentTemplate Пример Смотри также Send Feedback
Возвращает или устанавливает минимальную высоту шаблона компонента в режиме визуального редактора.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string MinimalHeight { get; set; }

Заметки

Минимальная высота шаблона настраивается перегрузкой метода PrepareDesignMode()()()().

Примеры

Настройка шаблона компонента "bitrix:system.PublicMenu" для отображения в визуальном редакторе:

CopyC#
protected override void PrepareDesignMode()
{
    MinimalWidth = "85";
    MinimalHeight = "45";
    StartWidth = "100%";
    StartHeight = "45";

    if (ComponentCache["menu"] == null)
    {
        //Добавляем данные
        BXPublicMenuItemCollection menu = new BXPublicMenuItemCollection();

        for (int i = 0; i < 5; i++)
        {
            BXPublicMenuItem item = new BXPublicMenuItem();
            item.Link = "/bitrix";
            item.Title = string.Format("Bitrix {0}", i + 1);
            menu.Add(item);
        }

        ComponentCache["menu"] = menu;
    }
}

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Свойство MinimalWidth

Свойство BXComponentTemplate..::.MinimalWidth
Класс BXComponentTemplate Пример Смотри также Send Feedback
Возвращает или устанавливает минимальную ширину шаблона компонента в режиме визуального редактора.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string MinimalWidth { get; set; }

Заметки

Минимальная ширина шаблона настраивается перегрузкой метода PrepareDesignMode()()()().

Примеры

Настройка шаблона компонента "bitrix:system.PublicMenu" для отображения в визуальном редакторе:

CopyC#
protected override void PrepareDesignMode()
{
    MinimalWidth = "85";
    MinimalHeight = "45";
    StartWidth = "100%";
    StartHeight = "45";

    if (ComponentCache["menu"] == null)
    {
        //Добавляем данные
        BXPublicMenuItemCollection menu = new BXPublicMenuItemCollection();

        for (int i = 0; i < 5; i++)
        {
            BXPublicMenuItem item = new BXPublicMenuItem();
            item.Link = "/bitrix";
            item.Title = string.Format("Bitrix {0}", i + 1);
            menu.Add(item);
        }

        ComponentCache["menu"] = menu;
    }
}

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Свойство Parameters

Свойство BXComponentTemplate..::.Parameters
Класс BXComponentTemplate Пример Смотри также Send Feedback
Возвращает словарь параметров компонента.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public BXComponentParameters Parameters { get; }

Примеры

Включение компонента постранички в шаблон компонента:

CopyC#
 <% if (Results.Get<bool>("PagingShow")
        && !"top".Equals(Parameters.Get<string>("PagingPosition"), StringComparison.InvariantCultureIgnoreCase))
   {  %>
<bx:IncludeComponent
 runat="server"
 ID="FooterPager"
 ComponentName="bitrix:system.pager"
 Template="<%$ Parameters:PagingTemplate %>"
  />
<% } %>

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Свойство Results

Свойство BXComponentTemplate..::.Results
Класс BXComponentTemplate Смотри также Send Feedback
Возвращает словарь результатов выполнения кода компонента.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
[ObsoleteAttribute("Use direct properties of component template instead")]
public BXParamsBag<Object> Results { get; }

Заметки

Данное свойство является устаревшим и возвращает кеш компонента. Рекомендуется объявлять свойства, содержащие результаты работы компонента, непосредственно в базовом классе шаблона этого компонента и использовать их из тела шаблона напрямую.

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Свойство StartHeight

Свойство BXComponentTemplate..::.StartHeight
Класс BXComponentTemplate Пример Смотри также Send Feedback
Возвращает или устанавливает начальную высоту шаблона компонента в режиме визуального редактора.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string StartHeight { get; set; }

Заметки

Начальная высота шаблона настраивается перегрузкой метода PrepareDesignMode()()()().

Примеры

Настройка шаблона компонента "bitrix:system.PublicMenu" для отображения в визуальном редакторе:

CopyC#
protected override void PrepareDesignMode()
{
    MinimalWidth = "85";
    MinimalHeight = "45";
    StartWidth = "100%";
    StartHeight = "45";

    if (ComponentCache["menu"] == null)
    {
        //Добавляем данные
        BXPublicMenuItemCollection menu = new BXPublicMenuItemCollection();

        for (int i = 0; i < 5; i++)
        {
            BXPublicMenuItem item = new BXPublicMenuItem();
            item.Link = "/bitrix";
            item.Title = string.Format("Bitrix {0}", i + 1);
            menu.Add(item);
        }

        ComponentCache["menu"] = menu;
    }
}

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Свойство StartWidth

Свойство BXComponentTemplate..::.StartWidth
Класс BXComponentTemplate Пример Смотри также Send Feedback
Возвращает или устанавливает начальную ширину шаблона компонента в режиме визуального редактора.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string StartWidth { get; set; }

Заметки

Начальная ширина шаблона настраивается перегрузкой метода PrepareDesignMode()()()().

Примеры

Настройка шаблона компонента "bitrix:system.PublicMenu" для отображения в визуальном редакторе:

CopyC#
protected override void PrepareDesignMode()
{
    MinimalWidth = "85";
    MinimalHeight = "45";
    StartWidth = "100%";
    StartHeight = "45";

    if (ComponentCache["menu"] == null)
    {
        //Добавляем данные
        BXPublicMenuItemCollection menu = new BXPublicMenuItemCollection();

        for (int i = 0; i < 5; i++)
        {
            BXPublicMenuItem item = new BXPublicMenuItem();
            item.Link = "/bitrix";
            item.Title = string.Format("Bitrix {0}", i + 1);
            menu.Add(item);
        }

        ComponentCache["menu"] = menu;
    }
}

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Свойство TemplateName

Свойство BXComponentTemplate..::.TemplateName
Класс BXComponentTemplate Смотри также Send Feedback
Возвращает имя шаблона, например ".default"

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public string TemplateName { get; }

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Свойство Title

Свойство BXComponentTemplate..::.Title
Класс BXComponentTemplate Пример Смотри также Send Feedback
Возвращает название шаблона

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public virtual string Title { get; }

Примеры

Задание названия шаблона в классе шаблона конкретного компонента:

CopyC#
public class MyComponentTemplate : BXComponentTemplate<MyComponent>
{
    public override string Title
    {
        get { return "Название моего шаблона"; }
    }
}

Смотри также

Класс BXComponentTemplate
Пространство имен Bitrix.UI


Класс BXComponentTemplate(T)

Класс BXComponentTemplate<(Of <(<'T>)>)>
Члены Пример Смотри также Send Feedback
Обобщенный базовый класс для шаблона компонента

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public class BXComponentTemplate<T> : BXComponentTemplate
where T : BXComponent

Параметры типа

T
Класс компонента, для которого предназначен шаблон

Заметки

Подробнее см. класс BXComponentTemplate

Примеры

Определение класса шаблона вместе с классом компонента:

CopyC#
using System;
using System.Data;
using System.Configuration;
using System.Collections;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;
using Bitrix.UI;
using Bitrix.Components;

namespace Tutorial
{
    public partial class IBlockHierarchyComponent : BXComponent
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            ...
        }
    }

    public class IBlockHierarchyTemplate : BXComponentTemplate<IBlockHierarchyComponent>
    {

    }
}

Иерархия наследования

System..::..Object
System.Web.UI..::..Control
System.Web.UI..::..TemplateControl
System.Web.UI..::..UserControl
BXControl
Bitrix.UI..::..BXComponentTemplate
Bitrix.UI..::..BXComponentTemplate<(Of <(<'T>)>)>

Смотри также

Члены BXComponentTemplate<(Of <(<'T>)>)>
Пространство имен Bitrix.UI
Bitrix.UI..::..BXComponentTemplate


Члены BXComponentTemplate(T)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Члены BXComponentTemplate<(Of <(<'T>)>)>
Класс BXComponentTemplate<(Of <(<'T>)>)> Конструкторы Методы Свойства Смотри также Send Feedback

Тип BXComponentTemplate<(Of <(<'T>)>)> предоставляет следующие возможности.

Конструкторы

Имя | Описание
BXComponentTemplate<(Of <(<'T>)>)> | Создает экземпляр класса шаблона компонента.

Методы

Имя | Описание
LoadTemplateDefinition | (Унаследовано от BXComponentTemplate)
OnPreRender | (Унаследовано от BXComponentTemplate)
PreLoadTemplateDefinition | (Унаследовано от BXComponentTemplate)
PrepareDesignMode | Перегруженный.
Render | Дополняет базовый метод Render обработкой режима визуального редактора. (Унаследовано от BXComponentTemplate)

Свойства

Имя | Описание
Component | Возвращает компонент, которому принадлежит этот шаблон.
CurrentWriter | Возвращает текущий HtmlTextWriter во время отрисовки шаблона и null в остальное время (Унаследовано от BXComponentTemplate)
IsComponentDesignMode | Возвращает true, если компонент редактируется в редакторе и должен быть отображен особенным образом. (Унаследовано от BXComponentTemplate)
MinimalHeight | Возвращает или устанавливает минимальную высоту шаблона компонента в режиме визуального редактора. (Унаследовано от BXComponentTemplate)
MinimalWidth | Возвращает или устанавливает минимальную ширину шаблона компонента в режиме визуального редактора. (Унаследовано от BXComponentTemplate)
Parameters | Возвращает словарь параметров компонента. (Унаследовано от BXComponentTemplate)
Results | Устаревший. Возвращает словарь результатов выполнения кода компонента. (Унаследовано от BXComponentTemplate)
StartHeight | Возвращает или устанавливает начальную высоту шаблона компонента в режиме визуального редактора. (Унаследовано от BXComponentTemplate)
StartWidth | Возвращает или устанавливает начальную ширину шаблона компонента в режиме визуального редактора. (Унаследовано от BXComponentTemplate)
TemplateName | Возвращает имя шаблона, например ".default" (Унаследовано от BXComponentTemplate)
Title | Возвращает название шаблона (Унаследовано от BXComponentTemplate)

Смотри также

Класс BXComponentTemplate<(Of <(<'T>)>)>
Пространство имен Bitrix.UI


Конструктор BXComponentTemplate(T)

Конструктор BXComponentTemplate<(Of <(<'T>)>)>
Класс BXComponentTemplate<(Of <(<'T>)>)> Смотри также Send Feedback
Создает экземпляр класса шаблона компонента.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
protected BXComponentTemplate()

Смотри также

Класс BXComponentTemplate<(Of <(<'T>)>)>
Пространство имен Bitrix.UI


Методы BXComponentTemplate(T)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Методы BXComponentTemplate<(Of <(<'T>)>)>
Класс BXComponentTemplate<(Of <(<'T>)>)> Смотри также Send Feedback

Тип BXComponentTemplate<(Of <(<'T>)>)> предоставляет следующие возможности.

Методы

Имя | Описание
LoadTemplateDefinition | (Унаследовано от BXComponentTemplate)
OnPreRender | (Унаследовано от BXComponentTemplate)
PreLoadTemplateDefinition | (Унаследовано от BXComponentTemplate)
PrepareDesignMode | Перегруженный.
Render | Дополняет базовый метод Render обработкой режима визуального редактора. (Унаследовано от BXComponentTemplate)

Смотри также

Класс BXComponentTemplate<(Of <(<'T>)>)>
Пространство имен Bitrix.UI


Метод PrepareDesignMode

[image]

1С-Битрикс: Управление сайтом ASP.NET
Метод BXComponentTemplate<(Of <(<'T>)>)>..::.PrepareDesignMode
Класс BXComponentTemplate<(Of <(<'T>)>)> Смотри также Send Feedback

Лист перегрузки

Имя | Описание
PrepareDesignMode()()()() | Задает настройки отображения для визуального редактора (Унаследовано от BXComponentTemplate)
PrepareDesignMode(HtmlTextWriter) | Передает настройки отображения визуальному редактору (Унаследовано от BXComponentTemplate)

Смотри также

Класс BXComponentTemplate<(Of <(<'T>)>)>
Члены BXComponentTemplate<(Of <(<'T>)>)>
Пространство имен Bitrix.UI


Свойства BXComponentTemplate(T)

[image]

1С-Битрикс: Управление сайтом ASP.NET
Свойства BXComponentTemplate<(Of <(<'T>)>)>
Класс BXComponentTemplate<(Of <(<'T>)>)> Смотри также Send Feedback

Тип BXComponentTemplate<(Of <(<'T>)>)> предоставляет следующие возможности.

Свойства

Имя | Описание
Component | Возвращает компонент, которому принадлежит этот шаблон.
CurrentWriter | Возвращает текущий HtmlTextWriter во время отрисовки шаблона и null в остальное время (Унаследовано от BXComponentTemplate)
IsComponentDesignMode | Возвращает true, если компонент редактируется в редакторе и должен быть отображен особенным образом. (Унаследовано от BXComponentTemplate)
MinimalHeight | Возвращает или устанавливает минимальную высоту шаблона компонента в режиме визуального редактора. (Унаследовано от BXComponentTemplate)
MinimalWidth | Возвращает или устанавливает минимальную ширину шаблона компонента в режиме визуального редактора. (Унаследовано от BXComponentTemplate)
Parameters | Возвращает словарь параметров компонента. (Унаследовано от BXComponentTemplate)
Results | Устаревший. Возвращает словарь результатов выполнения кода компонента. (Унаследовано от BXComponentTemplate)
StartHeight | Возвращает или устанавливает начальную высоту шаблона компонента в режиме визуального редактора. (Унаследовано от BXComponentTemplate)
StartWidth | Возвращает или устанавливает начальную ширину шаблона компонента в режиме визуального редактора. (Унаследовано от BXComponentTemplate)
TemplateName | Возвращает имя шаблона, например ".default" (Унаследовано от BXComponentTemplate)
Title | Возвращает название шаблона (Унаследовано от BXComponentTemplate)

Смотри также

Класс BXComponentTemplate<(Of <(<'T>)>)>
Пространство имен Bitrix.UI


Свойство Component

Свойство BXComponentTemplate<(Of <(<'T>)>)>..::.Component
Класс BXComponentTemplate<(Of <(<'T>)>)> Пример Смотри также Send Feedback
Возвращает компонент, которому принадлежит этот шаблон.

Пространство имен: Bitrix.UI
Сборка: Main (in Main.dll) Version: 5.0.3.0 (5.0.3.0)

Синтаксис

C#
public T Component { get; }

Примеры

Повсеместное использование свойств компонента в шаблоне компонента "bitrix:news.detail":

CopyC#
<%@ Reference Control="~/bitrix/components/bitrix/news.detail/component.ascx" %>
<%@ Control Language="C#" AutoEventWireup="true" Inherits="NewsDetailTemplate" %>
<%@ Import namespace="System.Collections.Generic"%>
<%@ Import namespace="System.ComponentModel"%>
<%@ Import namespace="Bitrix.IBlock"%>

<%if(Component.Element != null)
{%>
    <div class="news-detail">
    <%
        if (Component.DetailImage != null && Component.ShowDetailPicture)
        {
        %>
            <img class="detail_picture" border="0" src="<%= Component.DetailImage.FilePath %>" width="<%= Component.DetailImage.Width %>"
                height="<%= Component.DetailImage.Height %>" alt="<%= Component.DetailImage.Description %>" />
        <%
        }
        else if (Component.PreviewImage != null && Component.ShowPreviewPicture)
        {
        %>
            <img class="detail_picture" border="0" src="<%= Component.PreviewImage.FilePath %>" width="<%= Component.PreviewImage.Width %>"
                height="<%= Component.PreviewImage.Height %>" alt="<%= Component.PreviewImage.Description %>" />
        <%
        }

        if (Component.ShowDate)
        {%>
            <span class="news-date-time"><%= Component.DisplayDate%></span>
        <%
        }

        if (Component.ShowTitle)
        {%>
            <h3><%= Component.Element.Name %></h3>
        <%
        }

        if (Component.ShowPreviewText && !String.IsNullOrEmpty(Component.Element.PreviewText))
        {
        %>
            <p><%= Component.Element.PreviewText %></p>
        <%}

        %>

        <p><%= !String.IsNullOrEmpty(Component.Element.DetailText) ? Component.Element.DetailText : Component.Element.PreviewText %></p>
        <div style="clear: both"></div>
        <br />
        <%
        if (Component.Properties != null)
        {
            foreach (KeyValuePair<string, Dictionary<string, string>> kvp in Component.Properties)
            {
                if (kvp.Value.ContainsKey("Value") && !String.IsNullOrEmpty(kvp.Value["Value"]))
                {
                    %><span class="news-element-property"><%= kvp.Value["Name"] + ":" %>&nbsp;<span><%= kvp.Value["Value"] %></span></span> <%
                }
            }
        }%>
    </div>
<%} %>

Смотри также

Класс BXComponentTemplate<(Of <(<'T>)>)>
Пространство имен Bitrix.UI