Основные сведения

"1C-Битрикс: Управление сайтом ASP.NET" - технологическое ядро для создания и управления сайтами. Использование этой системы управления содержимым сайта - экономичный способ разработки, поддержки и развития интернет-проекта.

Программный продукт "1C-Битрикс: Управление сайтом ASP.NET" может быть использован корпоративными заказчиками и индивидуальными разработчиками в качестве фундамента для создания новых проектов и управления уже существующими сайтами.

Основные возможности "1C-Битрикс: Управление сайтом ASP.NET":

  • управление структурой и содержанием сайта;
  • публикация новостей, пресс-релизов и другой часто обновляемой информации;
  • управление показом рекламы на сайте;
  • создание и управление форумами и блогами;
  • осуществление других операций по управлению интернет-проектом.

Продукт позволяет минимизировать расходы на сопровождение веб-сайта за счет простоты управления статической и динамической информацией. Для управления проектом вам не потребуются дополнительные услуги специалистов в области веб-дизайна. С помощью "1C-Битрикс: Управление сайтом ASP.NET" управлять веб-сайтом сможет штатный сотрудник компании, обычный пользователь персонального компьютера без специальных навыков программирования и HTML-вёрстки.

© «Битрикс», 2001-2008, «1C-Битрикс», 2008-2010 1С-Битрикс: Управление сайтом ASP.NET


Справочная система и документация

Справочная система "1C-Битрикс: Управление сайтом ASP.NET" предназначена как для пользователей продукта, так и для разработчиков сайтов. Некоторые разделы документации могут оказаться полезными посетителям сайтов.

Справочная документация представляет собой описание интерфейса системы управления сайтом, ее основных модулей и наиболее типичных операций. Также в ней содержится полное описание прикладного программного интерфейса "1C-Битрикс: Управление сайтом ASP.NET". Благодаря чему документация может использоваться программистами при разработке сайтов и заказных модулей.

Вместе с тем, представленная документация не содержит такой специфической информации, как запуск системы, её конфигурирование и т.п. Сведения об этом доступны в виде отдельных руководств и могут быть быть загружены с сервера компании "1C-Битрикс".

Комплект доступных руководств постоянно расширяется. Наиболее полный набор доступен по следующему адресу: http://dev.1c-bitrix.ru/docs/asp.php.


Реализация и системные требования

Система "1C-Битрикс: Управление сайтом ASP.NET" разработана на языке программирования C#. Продукт может эффективно работать на любой Windows платформе.

Минимальные технические требования:

  • ОС: Windows XP Professional / Vista (кроме Home Basic) / Seven / Server 2003 / Server 2008;
  • База данных: MS SQL Server 2005 / 2008;
  • IIS 5.1 и выше;
  • Microsoft .NET Framework 2.0 и выше (рекомендуется .NET Framework 3.5);
  • Microsoft ASP.NET AJAX Extensions 1.0.

Для управления сайтом, созданным с помощью продукта "1C-Битрикс: Управление сайтом ASP.NET", можно использовать браузеры Internet Explorer не ниже версии 6 и Mozilla FireFox не ниже версии 1.5.


Начало работы и авторизация

Управление сайтом осуществляется как в публичной части, так и в административном разделе. Для начала работы пользователю необходимо авторизоваться на сайте. Сделать это можно как в публичной чаcти, так и в административной.

Публичная часть

Для авторизации:

  • Воспользуйтесь специальной формой для авторизации, расположенной в публичном разделе сайта:

  • В форме авторизации введите ваш логин (имя доступа) и пароль.
  • Нажмите кнопку Войти.

После успешной авторизации можно приступить к работе в публичном разделе продукта.

Система "1С-Битрикс: Управление сайтом ASP.NET" позволяет осуществлять быстрый доступ к управлению сайтом непосредственно из публичного раздела. Для этого необходимо использовать Административную панель, содержащую набор кнопок для управления параметрами и элементами сайта:

Административная панель отображается только для авторизованных пользователей. Набор кнопок, выводимый на эту панель, зависит от уровня доступа пользователя к управлению ресурсами сайта. Полный набор кнопок отображается для администраторов сайта.

Административная часть

Доступ в административный раздел возможен только пользователям, которые имеют достаточные права доступа.

Для авторизации:

  • Воспользуйтесь специальной формой для авторизации, расположенной в административной части, перейти к которой можно указав в адресной строке браузера http://<ваш_сайт>/bitrix/admin/Login.aspx:

  • В форме авторизации введите ваш логин (имя доступа) и пароль.
  • При отмеченной опции Запомнить меня на этом компьютере вам не придеться проходить процедуру авторизации при каждом входе в систему.
  • Нажмите кнопку Войти.

После успешной авторизации можно приступить к работе в административном разделе продукта. При этом административная панель будет иметь другой вид:


Элементы публичного интерфейса

В этом разделе

  • Режим Просмотр
  • Режим Редактирование
  • Режим Разработка

    • Три режима работы публичного интерфейса (Просмотр, Редактирование и Разработка) позволяют выполнять основные операции по управлению и расширению контента сайта и разделяют действия, необходимые контент-менеджеру (редактору) и разработчику.

    Интерфейс реализуется с помощью административной панели, которая отображается вверху страниц сайта после того, как пользователь авторизуется в системе и при условии наличия у пользователя достаточного уровня прав для управления контентом сайта:

    В случае необходимости административная панель может быть временно скрыта:

    Развернуть ее в нужный момент можно по стрелке вниз:

    Панель может быть зафиксирована вверху экрана: . Тогда при прокрутке страницы панель остается доступной на экране.

    Административная панель позволяет переходить на определенную страницу административной части одним кликом. Это выполняется с помощью кнопки Пуск. При этом разделы административной части подгружаются динамически:

    Таким образом, вы можете одним кликом перейти на любую страницу административного раздела, например, на страницу с каталогом книг.

    Режим Просмотр

    Состояние административной панели, которое служит для просмотра страниц в том виде, как они будут доступны простым пользователям. В этом режиме редакторы сайта могут выполнять основные операции по управлению содержанием сайта:

    • Создание страницы или раздела:

      Страница и раздел из публичной части создаются с помощью Мастера. С его помощью пользователь, не имеющий подготовки, сможет создать страницу или раздел, последовательно внося данные на каждом шаге мастера. Содержание страницы создается в визуальном редакторе, загружаемом прямо в публичной части.

    • Редактирование текущей страницы и изменение свойств страницы или раздела:

    • Редактирование меню:

    • Управлять кешем страницы:

    Все формы настройки и редактирования загружаются прямо в публичной части, над поверхностью сайта. Это позволяет сразу видеть внесенные изменения.

    Режим Редактирование

    Режим Редактирование создан специально для изменения содержания страниц и разделов на сайте. Режим предоставляет для этого более широкие возможности, чем режим Просмотр.

    Например, создать страницу можно как с помощью мастера из публичного раздела, так и в административной части с помощью традиционной формы редактирования страницы:

    Перейти к редактированию страницы и изменению свойств страницы/раздела можно как в публичной части, так и в административной:

    Режим Редактирование дополнительно позволяет:

    • Управлять доступом к текущей странице или разделу из публичной части:

    • Удалить текущую страницу:

    • Изменить пункты меню:

    • Управлять кешем страницы:

    В режиме Редактирование для всех компонентов, использованных на странице, выведен набор действий по управлению содержанием:

    Например, меню действий компонента, выводящего структуру разделов инфоблока Новости, содержит такие операции:

    При выборе действия Добавить элемент открывается форма редактирования элемента в административной части и после сохранения новая информация будет сразу опубликована на странице.

    Режим Разработка

    Режим предназначен для использования разработчиками сайта, т.к. предоставляет возможности по изменению внешнего облика сайта (настройки параметров компонентов, изменение стилей шаблона сайта и др.)

    Режим Разработка содержит все действия из режимов Просмотр и Редактирование и дополнительно позволяет:

    • Редактировать исходный код страницы как в публичной части, так и в административной:

    • Редактировать параметры компонентов, использованных на текущей странице:

    • Редактировать шаблон: изменить стили сайта и стили шаблона можно в форме из публичной части, а также в административной части:

    • Режим предоставляет разработчику отладочную информацию, которая позволяет оценить статистику SQL запросов, просмотреть карту сайта и дерево меню:

    Компоненты выделены на странице, при этом для каждого имеется определенный набор команд управления, доступный по клику на иконку [image]:

    Набор команд для управления компонентом зависит от специфики каждого компонента. Например, для компонента Меню (bitrix:system.PublicMenu) доступны такие команды:


Элементы административного интерфейса

В этом разделе

  • Административная панель
  • Административное меню
  • Меню функций
  • Рабочая область
  • Ссылка на текущую страницу
  • Контекстная панель
  • Формы отчётов
  • Фильтр
  • Таблица элементов
  • Колонка флажков
  • Меню действий
    •
  • Формы редактирования
  • Поведение мыши по умолчанию
    •

    Интерфейс административного раздела системы "1C-Битрикс: Управление сайтом ASP.NET" разграничен на логические области, обеспечивающие доступ к различным функциональным возможностям системы. Интерфейс системы построен по иерархическому принципу: вышестоящие области интерфейса переключают зависимые области в тот или иной режим работы. Это позволяет скрыть функциональные возможности системы, в которых нет потребности в данный момент, и вынести на первый план требуемые функции.

    Интерфейс содержит следующие области:

    Административная панель

    Элемент | Описание
 | Служит для быстрого доступа к страницам административного раздела.
 | Открывает публичный раздел сайта (т.е. раздел, доступный посетителям). Удерживая клавишу Shift, можно открыть публичный раздел в новом окне браузера.
 | Открывает раздел редактирования основных элементов сайта (страниц, разделов, меню). Удерживая клавишу Shift, можно открыть раздел в новом окне браузера.
 | Открывает раздел с полным набором действий по редактированию сайта (страниц, разделов, меню, компонентов, включаемых областей). Удерживая клавишу Shift, можно раздел в новом окне браузера.
 | Открывает административный раздел для управления всеми возможностями сайта.
 | Открывает форму настроек активного модуля. Например, если открыт раздел Структура сайта, эта кнопка открывает форму настроек Главного модуля.
 | Открывает форму получения обновлений системы.
 | Позволяет переключиться на другой (установленный в системе) язык административного интерфейса.
 | Завершает авторизованный сеанс в Административном разделе.

    Административное меню

    С помощью этой панели можно выбрать обособленный набор функций, относящийся к определённой функциональной части системы. В зависимости от того, установлены ли те или иные модули, набор функций может различаться.

    Набор функций Контент содержит инструменты для управления информационными блоками и структурой сайта (папками и файлами).

    Набор функций Сервисы наиболее зависим от наличия в системе тех или иных модулей. Полный набор функций позволяет управлять рекламой, форумами и блогами.

    Набор функций Настройки позволяет управлять пользователями, шаблонами, получать обновления системы, а также настраивать прочие параметры сайта и системы.

    Меню функций

    Содержимое этой панели зависит от того, какой набор функций выбран в Административном меню. Например, выбрав набор Контент, мы можем получить такой вид панели:

    Обратите внимание на то, что такое дерево-меню строится системой динамически с использованием технологии AJAX. Код, ответственный за построение меню, опрашивает все установленные в системе модули, которые, в свою очередь, возвращают данные, необходимые для добавления пунктов меню. Поэтому, при открытии страницы Административного раздела или развёртывании узла меню в первый раз (например, списка информационных блоков), меню может появиться с некоторой задержкой, о чем будет выведено соответствующее предупреждение.

    Выбирая пункты дерева-меню, можно получить доступ непосредственно к тем функциям, которым они соответствуют. При этом, рабочая область будет отображать интерфейс для работы именно с этими функциями.

    Рабочая область

    Рабочая область - это основная область, в которой происходит большинство операций по управлению сайтом:

    • просмотр элементов, составляющих контент сайта (например, информационных блоков, баннеров и т.п.);
    • добавление контента;
    • создание и удаление папок и файлов;
    • настройка меню и т.д.

    Такие операции реализуются формами двух основных видов:

    • Формы отчетов - предназначены для просмотра элементов в форме таблиц;
    • Формы редактирования - применяются для добавления и правки элементов контента, а также для задания настроек модулей и системы в целом.

    Формы, отображаемые в рабочей области, имеют общие элементы. Ознакомьтесь с их функциями - это значительно облегчит дальнейшую работу с сайтом.

    Ссылка на текущую страницу

    Эта пиктограмма ( [image], на странице вверху справа) содержит ссылку на текущую страницу (с учётом переходов по AJAX). Скопировать ссылку в буфер обмена можно, нажав на пиктограмме правой кнопкой мыши и выбрав команду Копировать ярлык (Копировать ссылку). Ссылка на страницу может понадобиться вам, например, при обращении с службу технической поддержки компании "1C-Битрикс".

    Контекстная панель

    Контекстные панели могут отображаться как на формах отчетов, так и на формах редактирования. Если отображаемая форма позволяет производить какие-либо действия в отношении отображаемых элементов, ниже фильтра на форме может располагаться контекстная панель, содержащая такие команды. Например, форма отчета для инфоблока Новости компании (Контент > Новости > Новости компании) имеет такую контекстную панель:

    Кнопки панели этой формы позволяют:

    • добавить новый новостной раздел;
    • добавить новый элемент (новость);
    • изменить свойства инфоблока;
    • настроить внешннй вид отчетной формы.

    Обратите внимание на то, что большинство контекстных панелей содержат кнопку Настроить. Кнопка Настроить выводит диалоговое окно, в котором пользователь может выбрать колонки, которые требуется отобразить в таблице отчёта данной формы, а также задать некоторые параметры, применяемые по умолчанию:

    Поле | Описание
    Колонки таблицы
    Доступный колонки | Список доступных колонок, которые могут быть отображены в таблице отчётной формы. Для перемещения колонок в список выбранных отметьте необходимые колонки и нажмите кнопку >.
    Выбранные колонки | Список выбранных колонок. Для перемещения колонки вверх списка служит кнопка Выше, вниз - Ниже. Для удаления колонки из выбранных используйте кнопку Удалить.
    Параметры по умолчанию
    Упорядочить по полю Поле, по которому будет производиться сортировка списка элементов формы:
    • Название;
    • Акт.;
    • Начало активности;
    • Окончание активности;
    • Сорт.;
    • Символьный код;
    • Внешний ключ;
    • Дата изменения;
    • Дата создания;
    • ID.
    Направление сортировки списка элементов формы:
    • По возрастанию;
    • По убыванию.
    Записей на странице | Количество записей формы, отображаемых на одной странице. Весь список записей будет отображен с помощью постраничной навигации.
    Общие настройки
    Установить данные настройки по умолчанию для всех пользователей | При отмеченной опции данные настройки будут установлены как настройки по умолчанию для всех пользователей. Удалить настройки по умолчанию можно с помощью кнопки [image].
    Кнопка | Описание
Сохранить | Сохранение внесённых изменений.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений.
По умолчанию | Возврат первоначальных значений по умолчанию.

    Примечание: настройки каждой отдельной формы сохраняются для текущего авторизованного пользователя.

    Формы отчётов

    Формы отчётов обычно выводятся при выборе какого-либо пункта дерева меню функций. Формы отчётов показывают подробную (обычно - наиболее важную) информацию об отображаемых элементах. Например, выбрав пункт Список форумов в разделе Форумы, пользователь получает полный отчет об имеющихся в системе форумах:

    Формы отчетов имеют следующие общие элементы:

    • Фильтр;
    • Таблица элементов;
    • Колонка флажков;
    • Меню действий.

    Фильтр

    Фильтр - своего рода средство поиска данных, предназначенное для отбора информации, отображаемой в таблицах форм. Введя критерии поиска (отбора) в фильтр, можно найти и показать не все, а только требуемые данные.

    Типичный фильтр системы выглядит так:

    Кнопка Показать фильтр отображает фильтр и все критерии поиска. Нажатие на кнопку Свернуть фильтр скрывает его, оставляя видимой лишь панель управления фильтра. Нажав на кнопку Дополнительно, можно выбрать, какие поля фильтра следует показать, а какие - скрыть.

    Таблица элементов

    Таблица элементов - основное средство группировки и отображения информации в системе. Несмотря на разнообразие, многие таблицы имеют схожие поля.

    Колонка флажков

    Колонка флажков позволяет выбрать один или более элементов для выполнения над ними каких-либо действий. Установка флажка в заголовке таблицы приводит к выбору всех элементов таблицы:

    Действия над отмеченными элементами производятся с помощью инструментов, расположенных на панели операций:

    Примечание: количество инструментов на панели операций зависит от формы отчета.

    Обратите особое внимание на инструмент Быстрое редактирование. С его помощью можно изменить наиболее важные и часто используемые свойства одновременно для всех отмеченных элементов, отображаемых в таблице. Это даёт возможность правки свойств элементов, не покидая текущей формы отчёта (то есть, без переключения в форму редактирования).

    Например, находясь на странице Список форумов можно отметить для быстрой правки форумы Гостевой форум и Общий форум:

    После нажатия на кнопку Быстрое редактирование отображаемые в отчете и доступные для изменения значения станут отображаться как поля ввода:

    Отредактировав параметры элементов, нажмите кнопку Сохранить для внесения изменений.

    Меню действий

    Колонка Меню действий содержит кнопки [image], нажатие на которые приводит к появлению контекстного меню, в котором можно выбрать желаемое действие, допустимое над элементом таблицы. Например, элементы таблицы формы Новости: Информационные блоки предполагают такие действия:

    Формы редактирования

    Этот тип форм применяется для изменения элементов контента сайта или для настройки системных параметров. Например, выбрав пункт Изменить меню действий информационного блока, можно открыть форму детальной правки этого инфоблока.

    Поскольку элементы контента (или формы настроек системных модулей) могут иметь большое число изменяемых свойств, многие формы редактирования реализованы при помощи страниц свойств или вкладок. Страницы свойств крайне широко используются при построении пользовательского интерфейса. Их применение позволяет разбить многочисленные свойства элемента на логические группы и, таким образом, сделать интерфейс более легким и понятным. Обычно свойства сгруппированы таким образом, что на первых страницах свойств (в порядке слева направо) помещаются наиболее часто используемые, а на последних - дополнительные параметры.

    Следующий рисунок показывает пример формы со страницами свойств (вкладками) информационного блока:

    Поведение мыши по умолчанию

    По умолчанию пользовательский интерфейс системы реализует следующие операции в ответ на действия, совершаемые при помощи мыши:

    • левый клик на кнопке меню действий либо правый клик на строке таблицы отчёта - вывод меню действий;
    • Ctrl + правая кнопка - выводит стандартное меню браузера;
    • двойной клик на строке таблицы отчёта - открывает форму редактирования.


Завершение работы

Чтобы закончить сеанс и перейти в режим неавторизованной работы нажмите на кнопку Выйти, расположенную на административной панели

- в публичном разделе:

- или в административном разделе:


Завершение работы

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Контент

  • Информационные блоки
  • Управление структурой


Управление структурой

Система управления структурой сайта представляет собой Менеджер файлов, который позволяет создавать новые страницы, новые каталоги (разделы сайта), копировать, перемещать, удалять файлы и папки, редактировать текст страниц и многое другое.

Для управления структурой веб-сайта не обязательно владеть специальными знаниями программирования и веб-вёрстки. Используя кнопки управления, можно управлять структурой сайта, меню, редактировать содержание, создавать новые страницы и распределять права доступа.


Менеджер файлов

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Поля менеджера файлов
  • Операции над папками и файлами
    •

    Управление структурой "1C-Битрикс: Управление сайтом ASP.NET" осуществляется в Менеджере файлов: Контент > Структура сайта.

    Менеджер файлов организован подобно правой панели Проводника Windows и представляет собой каталог физических папок и файлов. Предназначен для быстрого доступа к файлам и папкам пользователям системы.

    Информация об имени файла или папки, размере, дате последнего изменения, уровне прав доступа к файлу/папке показаны в форме таблицы. Нажав на название папки (оно представлено в виде ссылки), можно перейти внутрь этой папки. C помощью щелчка по названию файла, можно открыть данный файла для редактирования.

    Форма поиска

    Поиск файлов и папок в соответствии с указанными условиями.

    Поле | Описание
Имя | Поиск файла или папки по имени.
Расширение | Поиск файла по расширению.
Изменен | Позволяет отобрать элементы списка, которые были изменены в течение указанного периода времени.
Тип | Поиск можно задать либо по файлам, либо по папкам, либо по всем элементам списка.

    Чтобы отобрать файлы/папки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех элементов нажмите кнопку Отменить.

    Контекстная панель

    Служит для управления содержимым папки, а также настройки ее свойств.

    Кнопка | Описание
Новая папка | Переход к форме создания новой папки в текущем каталоге.
Новый файл | Переход к созданию новго файла в текущей папке.
Загрузить файл | Переход к форме загрузки файла(-ов) в текущую папку с локального компьютера.
Добавить меню | Переход к форме добавления/редактирования меню данного раздела/подраздела.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Свойства папки | Переход к просмотру и изменению свойств текущей папки (изменение заголовка раздела и значений свойств страниц раздела).
Доступ для текущей папки | Переход к форме настройка прав доступа к текущей папке для заданных в системе ролей пользователей.
Показать права на доступ | Поле позволяет показать в колонке Разрешения уровень прав доступа к отображаемым файлам и папкам для выбранной роли пользователей.
Путь | В поле будет отображен путь текущей папки. Чтобы перейти в определённую директорию сайта, укажите путь к папке в этом поле и нажмите кнопку OK.

    Поля менеджера файлов

    Поле | Описание
    Колонка флажков | Выбор файлов и папок, к которым предполагается применить какое-либо правило или действие.
    Действия Действия, которые можно произвести над папками:
    • Открыть - открыть папку в менеджере файлов;
    • Переименовать - изменить название выбранной папки;
    • Удалить - удалить выбранную папку;
    • Доступ - переход к форме изменения прав доступа к данной папке.

    Действия, которые можно произвести над:
    1. страницой (.aspx, .html и т.д.):

      • Редактировать - изменение файла в визуальном редакторе;
      • Редактировать как текст - изменение файла в текстовом формате;
      • Редактировать исходный текст - изменение исходного кода файла;
      • Просмотр файла - просмотр содержимого файла;
      • Переименовать - изменить название файла;
      • Удалить - удаление файла;
      • Доступ - переход к форме изменения прав доступа к данному файлу.

    2. меню (<имя_меню>.menu):

      • Редактировать меню - переход к форме редактирования меню;
      • Редактировать исходный текст - изменение исходного кода файла меню;
      • Просмотр файла - просмотр содержимого файла;
      • Переименовать - изменить название файла;
      • Удалить - удаление меню;
      • Доступ - переход к форме изменения прав доступа к данному меню.

    3. текстовым файлом (.config, .txt и т.д.):

      • Редактировать исходный текст - изменение исходного кода текстового файла;
      • Просмотр файла - просмотр содержимого файла;
      • Переименовать - изменить название файла;
      • Удалить - удаление файла;
      • Доступ - переход к форме изменения прав доступа к данному файлу.

    4. файлом (.png, .jpg, .mp3, и т.д.):

      • Просмотр файла - просмотр содержимого файла;
      • Переименовать - изменить название файла;
      • Удалить - удаление файла;
      • Доступ - переход к форме изменения прав доступа к данному файлу.
    Имя | Название папки или файла.
    Размер | Размер файла в байтах.
    Дата модификации | Дата и время последнего изменения файла или папки.
    Разрешения | Права доступа к файлам и папка для выбранной роли пользователей или для текущего пользователя.
    Тип | Тип элемента списка: Файл или Папка.

    Операции над папками и файлами

    К каждому файлу и папке, отображаемым в Менеджере файлов, можно применить различные операции по изменению их расположения и свойств.

    Чтобы осуществить любое из действий над файлами и папками, следует выделить требуемые файлы и папки флажками в Колонке флажков. После этого для выполнения операций можно воспользоваться инструментами, расположенными на панели операции над элементами списка:

    Инструмент Описание
    Применение выбранного действия ко всем элементам в списке.
    Настройка права доступа для выбранных элементов.
    Быстрое редактирование выбранных элементов непосредственно в списке (и т.ч. переименование файлов и папок).
    Удаление выбранных элементов.
    Список действий, доступных для выполнения над выбранными элементами:
    • Копировать - копирование выбранных элементов в указанную директорию;
    • Переместить - перемещение выбранных элементов в указанную директорию.
    Для выбора папки можно воспользоваться кнопкой [...].

    Для выполнения выбранного действия служит кнопка Применить.


Создание новой папки

В этом разделе

  • Административная часть
  • Контекстная панель
  • Форма создания новой папки
  • Кнопки управления
  • Пример создания раздела
    •
  • Публичная часть
  • Мастер создания нового раздела
    •

    Административная часть

    Форма предназначена для создания новой папки в административном разделе.

    Контекстная панель

    Кнопка | Описание
Назад | Переход в папку, открытую в данный момент в Менеджере файлов.

    Форма создания новой папки

    Поле | Описание
Имя папки | Название новой папки. Указывается только латинскими буквами, цифрами или следующими символами: !, (, ), [, ], {, }, -, ., _, ~.
Название раздела | Название нового раздела, как он будет показан в цепочке навигации в публичной части.
Создать пункт меню | При отмеченной опции ссылка на создаваемый раздел будет добавлена в указанное ниже меню.
Тип меню | Тип меню, в которое должна быть добавлена ссылка на создаваемый раздел.
Название пункта меню | Название пункта меню, как он будет показан в публичной части сайта.
Создать индексную страницу раздела | При отмеченной опции после создания раздела в нем будет создан файл Default.aspx (индексная страница раздела). Это позволит открывать раздел сайта без указания имени страницы. Например: http://yoursite.ru/company_news - пользователи будут автоматически перенаправляться на индексную страницу раздела Новости компании.
Шаблон страницы | Шаблон, на основе которого будет создана индексная страница.
Редактировать страницу | При отмеченной опции после создания раздела откроется визуальный редактор, в котором можно будет изменить и наполнить созданную индексную страницу.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение новой папки.
Применить | Сохранение параметров новой папки. Продолжение редактирования параметров.
Отменить | Отмена внесённых изменений. Возврат в Менеджер файлов.

    Пример создания раздела

    1. В административной части перейдите в Менеджер файлов: Контент > Структура сайта.
    2. Нажмите на кнопку Новая папка, расположенную на контекстной панели.
    3. В открывшейся форме укажите:
      • Имя папки. Используйте только латинские буквы, цифры или следующие символы: !, (, ), [, ], {, }, -, ., _, ~.
      • Название раздела. Именно это название будет отображено в цепочке навигации в качестве ссылки на созданный раздел.
      • Отметьте флажком поле Создать пункт меню.
      • Выберите Тип меню и задайте Название пункта меню в соответствующих полях.
      • Установите флаг в поле Создать индексную страницу раздела, чтобы добавить в новую папку файл Default.aspx. При открытии нового раздела сайта в браузере по умолчанию первой будет показана эта страница.
      • Выберите шаблон индексной страницы. В дистрибутив продукта включен шаблон страниц Стандартная страница, который применяется для всех страниц сайта и представляет собой пустой шаблон без определённого стиля.
      • Установите флаг в поле Редактировать страницу, чтобы приступить к редактированию индексной страницы непосредственно после сохранения раздела.
      • Нажмите кнопку Сохранить.
    4. Отредактируйте индексную страницу по своему усмотрению и сохраните внесеные изменения.

    В результате будет создана папка (раздел), содержащая следующие файлы: Default.aspx - индексная страница раздела, <название_типа_меню>.menu - файл содержащий код построения меню данного раздела, section.config - файл конфигурации раздела.

    Публичная часть

    В публичной части новая папка (раздел) создается с помощью команды Раздел меню кнопки Создать, расположенной на административной панели:

    При этом новая папка будет создана в той папке, которая открыта в настоящее время. Например, если у вас открыта страница /content/news/, то новая папка будет добавлена в раздел /content/news/.

    Мастер создания нового раздела

    Создание нового раздела в публичной части выполняется с помощью Мастера в несколько шагов.

    Шаг первый

    Основные параметры раздела.

    Поле | Описание
Имя папки | Название новой папки. Указывается только латинскими буквами, цифрами или следующими символами: !, (, ), [, ], {, }, -, ., _, ~.
Заголовок раздела | Название нового раздела, как он будет показан в цепочке навигации в публичной части.
перейти к редактированию индексной страницы | При отмеченной опции после создания раздела откроется визуальный редактор, в котором можно будет изменить и наполнить созданную индексную страницу.
добавить пункт меню | При отмеченной опции будет создан пункт меню со ссылкой на создаваемый раздел. Если опция не отмечена, то кнопка Готово активна и возможно завершение работы Мастера. Если опция не отмечена и работа Мастера продолжается, то второй шаг будет пропущен.

    Обратите внимание! Ссылка Создать новый раздел в Панели управления позволяет перейти в административный раздел к форме создания новой папки в текущей директории.

    Шаг второй

    Параметры пункта меню.

    Поле | Описание
Имя нового пункта | Название пункта меню, как он будет показан в публичной части сайта.
Тип меню | Тип меню, в которое должна быть добавлена ссылка на создаваемый раздел.
Вставить перед пунктом | Выбор месторасположения нового пункта в меню.

    После второго шага возможно завершение работы Мастера с помошью кнопки Готово.

    Шаг третий

    Параметры свойств раздела.

    Свойства раздела определяют дополнительные характеристика раздела. Например, значения свойства Ключевые слова используются в качестве ключевых слов для всех страниц данного раздела. Типы свойств задаются в форме настроек Главного модуля.

    Поле | Описание
Типы свойств | В соответствующих полях указываются зачения свойств.

    При завершении работы Мастера (нажатием на кнопку Готово) раздел будет создан и будет открыта индексная страница для редактирования.


Создание и редактирование файла

В этом разделе

  • Административная часть
  • Контекстная панель
  • Форма создания нового файла
  • Кнопки управления
  • Пример создания страницы
    •
  • Публичная часть
  • Мастер создания новой страницы
    •

    Создать новый либо отредактировать уже существующий файл можно как в административном, так и в публичном разделе.

    Административная часть

    Форма предназначена для создания новой или редактирования уже существующей страницы в административном разделе.

    Контекстная панель

    Кнопка | Описание
Назад | Переход в папку, открытую в данный момент в Менеджере файлов.

    Форма создания нового файла

    Поле | Описание
    Закладка "Редактирование"
    Имя файла | Имя создаваемого файла (с указанием расширения). Например, news.aspx.
    Заголовок страницы | Произвольный заголовок страницы. Указанный заголовок будет выводиться в теле страницы.
    В области будет отображен редактор для страниц, с помощью которого можно создать/изменить страницу.

    Примечание: редактор для страниц по умолчанию указывается в настройках Главного модуля на закладке Управление структурой.
    Закладка "Свойства"
    Закладка предназначена для задания/редактирования значений свойств страницы. Свойства страницы определяют дополнительные характеристика страницы. Типы свойств задаются в форме настроек Главного модуля.
    Поле | Описание
Свойство | Название свойства.
Значение | Поле для задания значения свойства.
    Закладка "Дополнительно"
    Примечание: закладка отображается при создании новой страницы.
    Добавить пункт меню | При отмеченной опции пункт, ссылающийся на созданную страницу, будет добавлен в меню текущего раздела сайта.
    Добавить страницу в меню | Выберите тип меню, в которое будет добавлена ссылка на созданную страницу.
    Пункт меню Укажите, каким образом ссылка на страницу будет добавлена в меню:
    • Добавить новый - будет создан новый пункт меню. При этом необходимо заполнить поля Название нового пункта и Вставить перед пунктом;
    • Привязать к существующему - ссылка на страницу будет добавлена в существующий пункт меню. При этом необходимо заполнить поле Добавить к пункту.
    Название нового пункта | Название нового пункта меню, ссылающегося на созданную страницу.
    Вставить перед пунктом | В поле можно указать положение пункта в меню. Например, если выбрать значение поля (последний пункт), то создаваемый пункт будет добавлен последним пунктом в меню раздела.
    Добавить к пункту | Поле для выбора существующего пункта меню, в который будет добавлена ссылка на созданную страницу.
    Закладка "Кодировка"
    Примечание: закладка отображается при редактировании страницы.
    На закладке можно изменить параметры кодировки страницы.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение страницы.
Применить | Сохранение выполненных изменений. Продолжение редактирования страницы.
Отменить | Отмена внесённых изменений. Возврат в Менеджер файлов.

    Пример создания страницы

    1. В административной части перейдите в Менеджер файлов: Контент > Структура сайта.
    2. Нажмите на кнопку Новый файл, расположенную на контекстной панели.
    3. В открывшейся форме укажите:
      • Имя файла. Используйте только латинские буквы, цифры или следующие символы: !, (, ), [, ], {, }, -, ., _, ~.
      • Заголовок страницы.
      • С помощью визуального редактора заполните содержимым создаваемую страницу.
      • На закладке Свойства задайте свойства для новой страницы.
      • На закладке Дополнительно можно добавить пункт в меню для текущего раздела сайта, ссылающийся на созданную страницу. Для этого отметьте опцию Добавить пункт меню и заполните необходимые поля.
    4. Нажмите на кнопку Сохранить, чтобы добавить новый файл в текущую папку, или Применить, чтобы сохранить файл в текущей папке и продолжить его редактирование.

    Публичная часть

    В публичной части новая страница создается с помощью команды Страница меню кнопки Создать, расположенной на административной панели:

    При этом новая страница будет создана в той папке, которая открыта в настоящее время. Например, если у вас открыто /content/news/, то новая страничка будет добавлена в раздел /content/news/.

    Мастер создания новой страницы

    Создание новой страницы в публичной части выполняется с помощью Мастера в несколько шагов.

    Шаг первый

    Основные параметры страницы.

    Поле | Описание
Имя файла | Название нового файла. Указывается только латинскими буквами, цифрами или следующими символами: !, (, ), [, ], {, }, -, ., _, ~.
Заголовок страницы | Заголовок новой страницы, как он будет отображен в публичной части.
перейти к редактированию | При отмеченной опции после создания страницы откроется визуальный редактор, в котором можно будет изменить и наполнить созданную страницу.
добавить пункт меню | При отмеченной опции будет создан пункт меню со ссылкой на создаваемую страницу. Если опция не отмечена, то кнопка Готово активна и возможно завершение работы Мастера. Если опция не отмечена и работа Мастера продолжается, то второй шаг будет пропущен.

    Обратите внимание! Ссылка Создать новую страницу в Панели управления позволяет перейти в административный раздел к форме создания новой странице в текущей директории.

    Шаг второй

    Параметры пункта меню.

    Поле | Описание
Имя нового пункта | Название пункта меню, как он будет показан в публичной части сайта.
Тип меню | Тип меню, в которое должна быть добавлена ссылка на создаваемую страницу.
Вставить перед пунктом | Выбор месторасположения нового пункта в меню.

    После второго шага возможно завершение работы Мастера с помошью кнопки Готово.

    Шаг третий

    Параметры свойств страницы.

    Свойства страницы определяют дополнительные характеристика страницы. Типы свойств задаются в форме настроек Главного модуля.

    Поле | Описание
Типы свойств | В соответствующих полях указываются зачения свойств.

    При завершении работы Мастера (нажатием на кнопку Готово) страница будет создана и будет открыт визуальный редактор для редактирования содержания страницы.


Загрузка файлов

В этом разделе

  • Загрузка файлов
  • Поля формы
  • Кнопки управления
    •
  • Пример загрузки
    •

    Загрузка файлов

    Вы можете загрузить на сайт любой файл с локального компьютера. Файл будет загружен в каталог, который открыт в текущий момент в менеджере файлов.

    Поля формы

    Поле | Описание
Имя файла для сохранения | Имя, которое будет присвоено файлу после загрузки на сайт. По умолчанию указывается оригинальное имя загружаемого файла.
Файл для загрузки | С помощью кнопки Обзор в данном поле указывается имя и путь к загружаемому файлу.

    Кнопки управления

    Кнопка | Описание
Сохранить | Загрузка выбранных файлов. Переход в папку, в которую была выполнена загрузка.
Применить | Загрузка выбранных файлов. Очистка полей формы для выбора следующих файлов для загрузки.
Отменить | Отмена загрузки файлов. Переход в папку, открытую в данный момент в менеджере файлов.

    Пример загрузки изображений на сайт

    1. Откройте Менеджер файлов и перейдите в папку /images/ (все изображения рекомендуется загружать в эту папку).
    2. Нажмите на кнопку Загрузить файл, расположенную на контекстной панели.
    3. В открывшейся форме нажмите кнопку Обзор и выберите файл на локальном диске. После этого в поле Имя файла для сохранения появится название выбранного файла, а в поле Файл для загрузки будет указан путь к данному файлу на вашем локальном диске. При необходимости измените имя, которое будет присвоено файлу после загрузки.
    4. Нажмите кнопку Сохранить.


Создание и редактирование меню

В этом разделе

  • Административная часть
  • Контекстная панель
  • Форма редактирования меню
  • Упрощенный режим
  • Расширенный режим
    •
  • Кнопки управления
    •
  • Публичная часть
  • Редактирование пунктов меню
    •

    Редактирование пунктов меню возможно как в административном, так и в публичном разделе. В административной части меню можно отредактировать одним из трех способов: с помощью формы в упрощенном или в расширенном режиме, либо как код текстового файла.

    Административная часть

    Форма предназначена для создания нового или редактирования уже существующего меню.

    Контекстная панель

    Кнопка | Описание
Каталог | Переход в папку, открытую в данный момент в Менеджере файлов.
Расширенный режим/Упрощенный режим | Переключение между режимами редактирования меню.
Редактировать как файл | Переключение в режим редактирования кода меню.

    Форма редактирования меню

    Упрощенный режим

    Форма служит интерфейсом для создания пунктов меню в упрощённом режиме. Для добавления новых пунктов следует заполнить поля таблицы и сохранить внесённые изменения.

    Поле | Описание
    Тип меню | Тип создаваемого/редактируемого меню.
    Пункты меню
    Поле | Описание
Название | Название пункта меню, как оно будет показано в меню в публичной части.
Ссылка | Ссылка на страницу или раздел сайта.
Сортировка | Порядок сортировки пунктов меню. Меньшее число соответствует более высокому пложению.
Удалить | Чтобы удалить пункт меню, установите флаг в это поле и нажмите кнопку Сохранить или Применить.

    Расширенный режим

    Форма редактирования пунктов меню в расширенном режиме позволяет изменять значения дополнительных параметров пунктов меню.

    Поле | Описание
    Тип меню | Тип создаваемого/редактируемого меню.
    Пункты меню
    Название | Название пункта меню, как оно будет показано в меню в публичной части.
    Ссылка | Ссылка на страницу или раздел сайта.
    Сортировка | Порядок сортировки пунктов меню. Меньшее число соответствует более высокому пложению.
    Удалить | Чтобы удалить пункт меню, установите флаг в это поле и нажмите кнопку Сохранить или Применить.
    Доп. ссылки для подсветки Указываются страницы сайта, при переходе на которые также будет подсвечиваться (выделяться) создаваемый пункт меню.

    Например, пункт меню Nokia ссылается на страницу со списком телефонов соответствующей марки (/catalog/phone/section.aspx).Если вы хотите, чтобы при просмотре детальной информации о каждой модели телефона также выделялся пункт меню Nokia, то в этом поле нужно указать путь к странице с детальной информацией о модели телефона (например, /catalog/phone/element.aspx).

    Путь к страницам задается относительно корня сайта. Если все страницы, при переходе на которые должен быть подсвечен пункт меню, хранятся в одной папке сайта, то в поле Доп. ссылки для подсветки можно указать путь к данной папке относительно корня сайта. Например, /catalog/phone/.
    Тип условия Тип условия, при выполнении которого пункт меню будет показываться посетителям:
    • [без условия]: пункт меню будет отображен без какого-либо условия;
    • Для папки или файла: страница или подраздел текущего раздела сайта, в котором будет показываться данный пункт меню;
    • Для ролей пользователей: роли пользователей, для которых будет показываться данный пункт;
    • Период времени: дата или период времени, в течение которого пункт меню будет показан;
    • Параметр в URL: параметр в URL страницы, при наличии которого пункт меню будет показан.
    Условие | Условие, при выполнении которого будет отображаться пункт меню.
    Параметры | Параметры, используемые при построении пункта меню. В поле Название указывается название параметра, а в поле Значение - значение параметра.

    Кнопка Вставить добавляет в форму еще один пункт меню.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение нового меню. Возврат в Менеджер файлов.
Применить | Применение внесённых изменений. Продолжение редактирования пунктов меню.
Отменить | Отмена внесённых изменений. Возврат в Менеджер файлов.

    Публичная часть

    Редактирование пунктов меню

    Создание или редактирование пунктов меню в публичном разделе выполняется с помощью команд меню кнопки Меню, расположенной на административной панели:

    Также перейти к редактированию пунктов меню можно в режимах Разработка или Редактирование с помощью меню команд компонента Меню (bitrix:system.PublicMenu):

    Вне зависимости от выбранного способа будет открыта форма редактирования меню, которая имеет вид:

    Поле | Описание
Название | Имя пункта меню.
Ссылка | Ссылка на пункт меню.
Инструмент | Описание
Перетащить пункт меню мышью | Инструмент для изменения положения пункта меню в общем порядке способом Drag&Drop.
Открыть диалог выбора файла | Переход к диалогу выбору ссылки на раздел или страницу, по которой будет осуществлен переход при выборе данного пункта меню.
Передвинуть пункт выше | Инструменты для пошагового изменения положения пунктов меню относительно друг друга.
Передвинуть пункт ниже
Удалить пункт меню | Удаление пункта меню.

    Добавить новые пункты с помощью кнопки Вставить пункт.

    Обратите внимание! Ссылка Редактировать меню в Панели управления позволяет перейти в административный раздел к форме редактирования меню.

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений.
Отменить | Отмена внесённых изменений.


Свойства папки

В этом разделе

  • Контекстная панель
  • Форма свойств папки
  • Кнопки управления
    •

    Перейти к форме управления свойствами текущей папки можно с помощью кнопки [image] Свойства папки, расположенной на контекстной панели Менеджера файлов.

    Контекстная панель

    Кнопка | Описание
Каталог | Переход в папку, открытую в данный момент в Менеджере файлов.

    Форма свойств папки

    Форма предназначена для задания/редактирования заголовка и значений свойств папки. Свойства определяют дополнительные характеристика папки. Типы свойств задаются в форме настроек Главного модуля.

    Поле | Описание
    Заголовок | Заголовок папки, отображаемый в цепочки навигации в качестве ссылки на соответствующий раздел.
    Свойства папки
    Поле | Описание
Свойство | Название свойства.
Значение | Поле для задания значения свойства.

    Примечание: кнопка Ещё... позволяет добавить пустую строку для создания нового свойства папки (данное свойство будет использоваться только для текущей папки). При создании свойства в поле Свойство необходимо указать код (мнемоническое имя) свойства. Код свойства задается символами латинского алфавита.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение свойств папки. Возврат в Менеджер файлов.
Применить | Сохранение внесённых изменений. Продолжение редактирования свойств папки.
Отменить | Отмена внесённых изменений. Возврат в Менеджер файлов.


Права доступа

В этом разделе

  • Права доступа к файлам и папкам
  • Управление доступом из административной части
  • Контекстная панель
  • Форма настроек прав доступа к файлам и папкам
  • Кнопки управления
    •
  • Управление доступом из публичной части
    •

    Права доступа к файлам и папкам

    Право доступа - набор правил, определяющих, каким уровнем доступа к папке или файлу обладает та или иная роль пользователей. Права доступа обладают свойством "наследования": если для текущего раздела/страницы явно не задан уровень прав, то устанавливается то право, которое задано для вышележащего раздела.

    Управление доступом пользователей к файлам и папкам сайта выполняется как в административной, так и в публичной части.

    Управление доступом из административной части

    В административной части управление доступом выполняется с помощью Менеджера файлов: Контент > Структура сайта.

    Изменить права доступа можно несколькими способами:

    - для файла:
    • выбрать пункт Доступ меню действий файла;
    • установить флаг в поле рядом с названием файла и воспользоваться инструментом [image], расположенным на панели операции.
    - для папки:
    • выбрать пункт Доступ меню действий папки;
    • установить флаг в поле рядом с названием папки и воспользоваться инструментом [image], расположенным на панели операции;
    • нажмите на кнопку [image] Доступ для текущей папки, расположенную на контекстной панели.

    После этого будет открыта форма редактирования прав доступа к выбранному файлу или папке (или нескольким файлам и папкам).

    Контекстная панель

    Кнопка | Описание
Вернуться к списку файлов | Переход в Менеджер файлов.

    Форма настроек прав доступа к файлам и папкам

    Поле | Описание
    (1) | Список ролей пользователей, для которых можно задать права доступа к папке/файлу.
    (2) | Если роли нет в списке, то её можно добавить с помощью выпадающего списка.
    (3) Право доступа для выбранной роли:
    • - разрешить операцию;
    • - отменить операцию;
    • - наследовать состояние операции "Разрешить";
    • - наследовать состояние операции "Запретить".
    Примечание: значение уровня прав со знаками серого цвета ( [image] и [image]) наследуются из вышележащего раздела.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение выполненных настроек. Возврат в Менеджер файлов.
Применить | Сохранение выполненных настроек. Продолжение изменения прав доступа.
Отменить | Отмена внесённых изменений. Возврат в Менеджер файлов.

    Управление доступом из публичной части

    В публичной части уровень доступа к текущему разделу/странице устанавливается в режимах Редактирование или Разработка с помощью меню команд кнопки Доступ:

    При этом будет открыта форма редактирования прав доступа к выбранному файлу или папке полностью аналогичная форме редактирования в административном разделе.


Визуальный редактор

В этом разделе

  • Закладка "Редактирование"
  • Настройки интерфейса редактора
  • Кнопки панели инструментов редактора
  • Закладка "Свойства"
  • Закладка "Кодировка"
  • Кнопки управления

  • Загрузка графики на сайт
  • Визуальные компоненты

    • Специальный программный модуль реализует визуальный редактор, позволяющий изменять текст и графику веб-страницы в режиме реального времени через браузер. Вы сможете размещать внутри страницы изображения, форматировать текст, добавлять таблицы, делать разметку и т.д. Внешнее оформление созданных вами страниц не будет отличаться от уже существующих. На базе изменений (удаление, создание, редактирование) редактор генерирует код. Обновление страницы в публичном разделе сайта выполняется автоматически после сохранения изменений.

    При редактировании выполняется изменение только внутренней (рабочей) области страницы, что позволяет сохранить общий дизайн сайта. Управлять сайтом с помощью визуального редактора вы можете с любого компьютера, на котором установлен Internet Explorer (версии 6 и выше) и Mozilla FireFox (версии 1.5 и выше).

    При редактировании страницы в административном разделе форма визуального редактора разделена на три закладки:

    • Редактирование;
    • Свойства;
    • Кодировка.

    Закладка "Редактирование"

    Закладка содержит окно визуального редактора и предназначена для создания и редактирования информационного содержания документа. Меню окна редактора имеет очень удобный интерфейс, представляющий собой типовой набор действий текстового редактора MS Word:

    Редактор может иметь различный функционал, в зависимости от прав доступа конкретного пользователя и способа открытия редактора. Для удобства работы окно визуального редактора разделено на три области:

    • Редактирование;
    • Свойства;
    • Визуальные компоненты.

    Последние две области можно свернуть и вновь открыть, воспользовавшись кнопками Компоненты и Свойства в нижней панели редактора.

    Настройка интерфейса редактора

    Редактор имеет регулируемый интерфейс, в котором можно включить или отключить панели:

    Панель | Описание
Стандартные | Неотключаемая панель с основными командами: настройка внешнего вида редактора, добавление таблицы, вставка изображения и т.д.
Стиль | Управление стилями текста.
Форматирование | Управление форматированием текста.
Режимы редактирования | Выбор одного из трех режимов редактирования: Режим визуального редактирования, Режим редактирования исходного кода, Совмещенный режим редактирования.
Шаблон сайта | Позволяет переключать таблицы стилей и шаблоны компонентов, относящиеся к разным шаблонам сайта. Только стили и шаблоны компонентов выбранного шаблона сайта могут быть использованы на текущей странице.
Управление и настройки | Панель команд администратора, которая содержит кнопки сохранения и выхода из редактора. В зависимости от уровня доступа может быть не видна.
Области наполнения страницы | Управление областями наполнения страницы.

    Настройка интерфейса редактора осуществляется вызовом диалога Настройки визуального редактора с помощью кнопки [image]. Форма настроек состоит из трех закладок, с помощью которых можно управлять содержимым панелей визуального редактора.

    Настройки визуального редактора
Панели инструментов
Стандартные | Неотключаемая панель.
Стиль | Можно отключить.
Форматирование | Можно отключить.
Режимы редактирования | Можно отключить.
Шаблон сайта | Можно отключить.
Управление и настройки | Можно отключить.
Области наполнения страницы | Можно отключить.
Запоминать положения панелей инструментов | При отмеченной опции положение панелей задач будет сохранено.
Панели задач
Компоненты | Неотключаемая панель.
Свойства | Можно отключить
Запоминать положения панелей задач | При отмеченной опции положение панелей задач будет сохранено.
Дополнительные настройки
Показывать подсказки к параметрам компонентов | При отмеченной опции будут показаны подсказки к параметрам компонентов.
Использовать визуальные эффекты | При отмеченной опции будут использоваться визуальные эффекты. Опцию рекомендуется снять для слабых машин.

    Кнопки панели инструментов редактора

    Кнопка | Описание
Стандартные
 | Переключение в полноэкранный режим.
 | Изменение настроек визуального редактора.
 | Вставить из Word. Позволяет очистить добавляемый текст от дополнительных элементов форматирования (например, стилей).
 | Вставить фрагмент как текст.
 | Выделить все на странице.
 | Отменить выполненное действие.
 | Вернуть отменённое действие.
 | Отобразить или скрыть границы таблиц.
 | Создать таблицу.
 | Добавить якорь.
 | Вставить гиперссылку.
 | Удалить гиперссылку.
 | Добавить изображение.
 | Вставить специальный символ.
 | Вставить разрыв страницы для печати.
 | Вставить разделитель страниц.
 | Вставить Flash-ролик.
Стиль
 | Уровень (формат) текста. Например, Heading1, Heading2, ..., Normal.
 | Шрифт.
 | Размер шрифта.
 | Полужирный.
 | Курсив.
 | Подчёркнутый.
 | Удалить форматирование.
 | Оптимизировать HTML-код.
Форматирование
 | Добавить горизонтальный разделитель.
 | Выравнивание абзаца по левому краю.
 | Выравнивание абзаца по центру.
 | Выравнивание абзаца по правому краю.
 | Выравнивание абзаца по ширине.
 | Нумерованный список.
 | Маркированный список.
 | Уменьшить отступ.
 | Увеличить отступ.
 | Цвет фона.
 | Цвет текста.
Режимы редактирования
 | Переключение в режим визуального редактирования.
 | Переключение в режим редактирования исходного кода страницы.
 | Переключение в совмещённый режим редактирования.
Шаблон сайта
 | Шаблон сайта.
Управление и настройки
 | Сохранение изменений и выход из визуального редактора.
 | Выход из редактора без сохранения.
 | Создание новой страницы.
 | Сохранить и продолжить редактирование.
 | Сохранить под другим именем.
 | Переход к редактированию параметров страницы.
Области наполнения страницы
 | Основная редактируемая область в шаблоне сайта.

    Закладка "Свойства"

    Закладка предназначена для задания и редактирования значений свойств страницы: ключевых слов, описания и т.д.

    Поле | Описание
Свойство | Название свойства.
Значение | Поле для задания значения свойства.

    Закладка "Кодировка"

    На закладке можно настроить параметры кодировки страницы.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение созданной страницы.
Применить | Сохранение выполненных изменений. Продолжение редактирования страницы.
Отменить | Отмена внесённых изменений. Выход из редактора.

    Загрузка графики на сайт

    Визуальный редактор позволяет загружать графику с локального диска и размещать ее на веб-странице. Процесс размещения изображения очень прост:

    1. Выберите место для изображения на странице, установив туда позицию курсора, и нажмите кнопку [image] на панели редактора. Откроется диалог Вставить рисунок:

    2. Перейдите к форме загрузки изображения, нажав кнопку рядом с полем Путь к изображению. Откроется окно Выберите файл.
    3. С помощью Менеджера файлов укажите путь к изображению, имя файла и папку на сервере, в которое оно будет сохранено. Нажмите кнопку Сохранить.
    4. Если необходимо, то укажите дополнительные параметры изображения. Например: Ширина, Высота, Горизонтальный отступ, Вертикальный отступ, Толщина рамки, Выравнивание.
    5. Нажмите кнопку Сохранить.

    Визуальные компоненты

    Компоненты являются блоками, с помощью которых строится публичная часть сайта. Они позволяют повторно использовать единожды написанный и отлаженный код в рамках одного сайта или на разных сайтах. Визуальные средства среды "1C-Битрикс: Управление сайтом ASP.NET" позволяют размещать и настраивать компоненты без написания кода. Поставляемые с продуктом системные компоненты регулярно обновляются, при этом расширяется функционал компонентов и исправляются возможные ошибки.

    Компоненты делятся на простые и комплексные. Простые (обычные, одностраничные) компоненты создают какую-либо область на одной странице. Комплексные (сложные, многостраничные) компоненты создают разделы сайта, например, новостной раздел или раздел фотогалереи.

    Для быстрого размещения компонентов на странице разработан специальный интерфейс в рамках визуального редактора. При редактировании страницы можно выбрать подходящий компонент из списка и переместить его в рабочую область страницы:

    Компоненты включают набор параметров, определяющих поведение компонента. Основная особенность компонентов заключается в том, что они позволяют управлять данными параметрами через визуальный интерфейс продукта: после размещения компонента в рабочей области внизу страницы отобразится панель свойств компонента. Например, панель свойств компонента Новости (bitrix:news) имеет следующий вид:

    Если панель свойств не отображается, следует выделить компонент, кликнув по нему указателем мыши. После установки требуемых свойств, страница готова к отображению. В области Свойства производится настройка компонента.


Описание модуля

Информационные блоки - модуль, позволяющий управлять и каталогизировать различные типы (блоки) однородной информации. Примерами информационных блоков могут быть:

  • новости;
  • каталог продукции;
  • фотогалереи;
  • список вакансий и другая информация.

Часто обновляемую информацию удобнее всего размещать в виде информационных блоков.

Модуль информационных блоков реализует следующую иерархическую модель построения хранилищ информации:

Типы инфоблоков создаются в форме Типы информационных блоков и отображаются в меню административной части в разделе Контент:

Размещение информации в информационных блоках выполняется через интерфейс Административного раздела. В специальных полях нужно лишь указывать данные, которые запросит система. После сохранения изменений, новые данные будут размещены в соответствующем разделе сайта.

На сайте может быть создано любое количество типов информационных блоков, например: новости, каталог и другие. Вы можете сами создавать новые типы информационных блоков и инфоблоки, наполнить инфоблоки разделами и элементами в зависимости от тематики сайта.

Модуль включает в себя следующие компоненты:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Каталог
Каталог (комплексный компонент) | catalogue | Комплексный компонент осуществляет вывод полного каталога элементов из определенного инфоблока.
Элемент каталога детально | catalogue.element.detail | Компонент выводит детальную информацию по элементу каталога.
Элементы раздела | catalogue.element.list | Компонент выводит список элементов раздела с указанным набором свойств.
Структура разделов | catalogue.section.tree | Компонент выводит дерево разделов информационного блока.
Инфоблоки
Разделы и элементы | iblock.hierarchy | Выводит элементы инфоблока, сгруппированные по разделам.
Добавление элементов
Форма добавления / редактирования | iblock.element.webform | Выводит форму добавления/редактирования элемента информационного блока.
Список моих элементов | iblock.myElement.list | Выводит список доступных пользователю элементов указанного инфоблока и позволяет с помощью ссылок Добавить, Редактировать и Удалить добавлять/редактировать/удалять элементы.
Мои элементы (комплексный компонент) | iblock.myElements | Комплексный компонент осуществляет вывод списка элементов указанного инфоблока, добавление/редактирование/удаление элементов в зависимости от роли пользователя.
Медиа
Медиагалерея (комплексный компонент) | media.gallery | Комплексный компонент позволяет получить полнофункциональную медиагалерею, создавая физически только одну страницу.
Элемент медиагалереи | media.gallery.element.detail | Служит для отображения элемента медиагалереи.
Список элементов медиагалереи | media.gallery.element.list | Служит для отображения списка элементов медиагалереи.
Медиа-проигрыватель | media.player | Осуществляет проигрывание медиафайлов различных форматов.
Новости
Новости | news | Позволяет создать полнофункциональный новостной раздел на сайте.
Новость детально | news.detail | Выводит детальное описание новости.
Лента | news.line | Выводит список статей и новостей с датой и заголовком со ссылкой на страницу с подробной информацией
Список новостей | news.list | Выводит список новостей из одного информационного блока.
Фотогалерея
Фотогалерея | photogallery | Позволяет получить полнофункциональную фотогалерею, создавая физически только одну страницу.
RSS
RSS инфоблока | iblock.rss | Выводит RSS информационного блока в заданном формате.
Показ новостей из RSS | rss.show | Предназначен для показа RSS новостей с другого сайта в заданном формате.


Настройки модуля

Форма настроек модуля Информационные блоки (Настройки > Настройки продукта > Настройки модулей > Информационные блоки) предназначена для задания глобальных параметров модуля.

Форма "Настройка параметров модуля"

Поле | Описание
Использовать визуальный редактор | При отмеченной опции для редактирования наполнения информационных блоков будет использоваться визуальный редактор, позволяющий изменять форматирование текста (размер, шрифт и т.д.), вставлять изображения и т.д.
Совместный просмотр секций и элементов | При отмеченной опции будет использоваться режим совместного просмотра секций и элементов, который напоминает функционирование проводника Windows: элементы и подразделы определённого раздела могут быть просмотрены лишь внутри этого раздела.
Максимальная глубина меню разделов | Указывается максимальное количество отображаемых разделов информационных блоков в левом меню административного раздела. Позволяет избегать перегруженности меню.

Кнопки управления

Кнопка | Описание
Применить | Сохранение внесённых изменений. Продолжение редактирования параметров модуля.
Сохранить | Сохранение внесённых изменений.


Типы информационных блоков

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список типов инфоблоков
    •

    Управление типами инфоблоков осуществляется на странице Типы информ. блоков (Контент > Информ. блоки > Типы информ. блоков).

    Форма поиска

    Форма позволяет выполнить поиск типов инфоблоков, соответствующих указанным параметрам.

    Поле | Описание
ID | Поиск можно задать по диапазону идентификаторов типов инфоблоков.
Есть разделы | Поиск можно задать по типам инфоблоков, содержащим разделы, не содержащим разделы либо по всем.

    Чтобы отобрать типы информационных блоков по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех типов инфоблоков нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Добавить новый тип | Переход на страницу с формой создания нового типа информационных блоков.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список типов информационных блоков

    Поле | Описание
    Колонка флажков | Выбор типов инфоблоков, к которым предполагается применить какое-либо правило или действие.
    Действия Доступные действия:
    • Информационные блоки - переход на страницу со списком информационных блоков данного типа;
    • Изменить - переход к редактированию типа информационных блоков;
    • Удалить - удаление типа инфоблоков.
    ID | Идентификатор типа информационного блока.
    Название | Произвольное осмысленное название типа информационных блоков.
    Сорт. | Относительный "вес" типа информационных блоков, определяющий его положение в списке.
    Содержит разделы | Признак того, что инфоблоки данного типа могут иметь (Да)/не иметь (Нет) иерархической структуры (элементы инфоблоков сгруппированы или не сгруппированы по разделам и подразделам).


Создание и редактирование типов информационных блоков

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Кнопки управления
  • Пример создание нового типа инфоблоков
    •

    Контекстная панель

    Кнопка | Описание
Список типов | Переход на страницу со списком типов инфоблоков.
Новый тип | Переход к форме создания нового типа информационных блоков. Кнопка отображается при редактировании существующего типа инфоблоков.
Удалить тип | Удаление редактируемого типа инфоблоков. Кнопка отображается при редактировании существующего типа инфоблоков.

    Форма редактирования

    Форма предназначена для создания нового или редактирования параметров уже существующего типа инфоблоков.

    Поле | Описание
    ID | Идентификатор типа инфоблоков. Поле отображается при редактировании существующего типа инфоблоков.
    Индекс сортировки | Относительный "вес", влияющий на порядок расположения типов информационных блоков в левом меню административного раздела.
    Использовать древовидный классификатор элементов по разделам | При отмеченной опции информационные блоки данного типа будут иметь иерархическую структуру, т.е. они могут быть разбиты по разделам и подразделам. Такая организация элементов может быть применена, например, для объединения товаров в группы или классификации растений по родам, видам и т.п.
    Языкозависимые названия и заголовки объектов
    Поле | Описание
Язык | Список языков, используемых в системе. Названия типов информационных блоков указываются отдельно для каждого языка.
*Название | Название типа инфоблоков для данного языка (например, News - Новости).

    * - поля, обязательные для заполнения.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Возврат к списку типов информационных блоков.
Применить | Применение внесённых изменений. Продолжение редактирования параметров типа инфоблоков.
Отменить | Отмена внесённых изменений. Возврат к списку типов информационных блоков.

    Создание нового типа информационного блока

    1. В Административной части перейдите на страницу Типы информ. блоков (Контент > Информ. блоки > Типы информ. блоков).
    2. Нажмите на кнопку Добавить новый тип, расположенную на контекстной панели.
    3. В открывшейся форме заполните следующие поля:

      • Установите Индекс сортировки.
      • Если подразумевается, что информационные блоки создаваемого типа будут иметь иерархическую структуру (т.е. содержать разделы и подразделы), то установите флаг в поле Использовать древовидный классификатор элементов по разделам.
      • Обязательно укажите Название типа информационных блоков для разных языков.
    4. Нажмите кнопку Сохранить.

    После сохранения новый тип информационных блоков будет добавлен в административное меню секции Контент:


Информационные блоки

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список информационных блоков
    •

    Для перехода к списку информационных блоков определённого типа выберите в секции Контент название типа инфоблоков.

    Страница со списком информационных блоков служит для управления инфоблоками определённого типа. С помощью этой страницы можно:

    • легко добавлять инфоблоки выбранного типа;
    • переходить к наполнению блоков данными (например, вручную добавлять новые статьи, медиафайлы и т.д.);
    • изменять свойства элементов (например, изменять описание элемента);
    • выполнять прочие операции, связанные с информационным наполнением сайта.

    Форма поиска

    Форма позволяет выполнить поиск инфоблоков, соответствующих указанным параметрам.

    Поле | Описание
Название | Поиск можно задать по названию инфоблока.
Сайты | Сайт(ы), на котором используются отбираемые информационные блоки.
Активен | Поиск можно задать по активным, неактивным или по всем инфоблокам данного типа.
ID | Поиск можно задать по идентификатоу инфоблока в системе.
Мнемонический код | Поиск можно задать по мнемоническому (символьному) коду информационного блока.
Индексируется | Поиск инфоблоков, элементы которых индексируются, либо поиск инфоблоков, элементы которых не индексируются, либо отображение всех инфоблоков.

    Чтобы отобрать инфоблоки данного типа по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех инфоблоков данного типа нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Добавить инфоблок | Переход на страницу с формой создания нового информационного блока данного типа.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список информационных блоков

    Поле | Описание
    Колонка флажков | Выбор инфоблоков, к которым предполагается применить какое-либо правило или действие.
    Действия Доступные действия:
    • Разделы - переход на страницу со списком разделов информационных блоков данного типа;
    • Элементы - переход на страницу со списком элементов информационных блоков данного типа;
    • Изменить - переход к форме редактированию информационных блоков;
    • Удалить - удаление инфоблоков.
    ID | Идентификатор информационного блока.
    Название | Название информационного блока.
    Сорт. | Относительный "вес", влияющий на порядок показа информационных блоков в списке.
    Акт. | Признак активности инфоблока. Если поле отмечено, содержимое инфоблока доступно для показа в публичной части сайта.
    Символьный код | Символьный (мнемонический) код информационного блока.
    Элементов | Количество элементов в данном информационном блоке.
    Разделов | Количество разделов в данном информационном блоке.
    Сайт | Сайт(ы), на которых используется информационный блок.
    Дата изменения | Дата и время последнего изменения инфоблока.
    Индексировать элементы | Определяется возможность индексации элементов информационного блока для внутреннего поиска.


Создание и редактирование инфоблока

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Закладка "Инфоблок"
  • Закладка "Свойства"
  • Закладка "Доступ"
  • Закладка "Подписи"
    •
  • Кнопки управления
  • Пример создание нового инфоблока
    •

    Форма позволяет создавать новый или редактировать уже существующий информационный блок выбранного типа.

    Контекстная панель

    Кнопка | Описание
Список инфоблоков | Переход на страницу со списком информационных блоков соответствующего типа.
Новый инфоблок | Переход к форме создания нового информационного блока. Кнопка отображается при редактировании существующего инфоблока.
Удалить инфоблок | Удаление редактируемого инфоблока. Кнопка отображается при редактировании существующего инфоблока.

    Форма редактирования

    Закладка "Инфоблок"

    Закладка предназначена для настройки общих параметров информационного блока.

    Поле | Описание
ID | Идентификатор информационного блока. Поле отображается при редактировании существующего инфоблока.
Изменен | Дата и время последнего изменения инфоблока. Поле отображается при редактировании существующего инфоблока.
Активен | Признак активности инфоблока. При отмеченной опции содержимое инфоблока доступно для показа в публичной части сайта.
Символьный код | Символьный (мнемонический) код информационного блока. При создании нового информационного блока можно указать его символьный код, представляющий собой произвольный набор символов алфавита, понятный администратору сайта. Например, символьный код информационного блока Новости компании может быть таким: company_news.
*Сайты | Сайт(ы), на которых используется информационный блок.
*Название | Название информационного блока.
Индекс сортировки | Относительный "вес", влияющий на порядок показа информационного блока в списке.
Внешний ключ | Ключ, который может использовать для связи с внешними источниками.
Индексировать для поиска | При отмеченной опции будет разрешено индексировать поиском контент инфоблока. Примечание: при включении понадобится переиндексация всего контента сайта или переиндексация контента этого информационного блока.
Переиндексировать | При отмеченной опции контент инфоблока будет переиндексирован.
Описание
Изображение | Изображение, ассоциируемое с данным инфоблоком. С помощью кнопки Обзор можно загрузить данное изображение.
Text / HTML | Выбор формата для создания/изменения описания инфоблока.
Использовать визуальный редактор | При отмеченной опции описание инфоблока можно будет создать/изменить с помощью визуального редактора.

    * - поля, обязательные для заполнения.

    Закладка "Свойства"

    Закладка служит создания и настройки свойств элементов и разделов текущего инфоблока.

    Поле | Описание
    ID | Идентификатор свойства элементов информационного блока. Значение поля отображается при редактировании существующего инфоблока.
    Код* | Символьный (мнемонический) код свойства.
    Название* | Произвольное название свойства элементов инфоблока.
    Акт. | Признак активности свойства элементов инфоблока (если свойство активно, оно может быть выбрано для показа в публичной части сайта).
    Тип Тип свойства:
    • Вещественное число - значение свойства задается в виде вещественного числа;
    • Да/Нет - задается значение свойства по умолчанию;
    • Дата/Время - значение свойства задается в виде даты/времени;
    • Перечисление - значение свойства выбирается из списка;
    • Ссылка на раздел инфоблока - с помощью данного свойства можно задать связь между элементом данного инфоблока и разделами другого информационного блока;
    • Ссылка на элемент инфоблока - с помощью данного свойства можно задать связь между элементом данного инфоблока и элементами другого информационного блока;
    • Строка - значение свойства задается в виде текстовой строки;
    • Уникальный идентификатор - значение свойства задается в виде GUID;
    • Файл - в качестве значения свойства используется файл;
    • Целое число - значение свойства задается в виде целого числа.
    Множ. | При отмеченной опции значение поля будет множественным. Указывается только для нового поля.
    Сорт. | Индекс сортировки, определяющий положение поля в общем списке.
    Изм. | Кнопка [...] позволяет перейти к форме детальной настройки свойства и задать дополнительные значения свойства.
    Удал. | Для удаления свойства нажмите на кнопку [image] в строке свойства. После подтверждения свойство будет удалено.

    * - поля, обязательные для заполнения.

    Закладка "Доступ"

    Закладка предназначена для управления уровнем доступа ролей пользователей к задачам и операциям для данного инфоблока.

    Поле | Описание
    (1) | Список ролей пользователей, для которых можно задать права доступа к задачам и операциям данного инфоблока.
    (2) | Если роли нет в списке, то её можно добавить с помощью выпадающего списка.
    (3) Право доступа для выбранной роли:
    • - задача или операция назначена для текущего инфоблока;
    • - задача или операция назначена для всех инфоблоков;
    • - задача или операция не назначена.

    Закладка "Подписи"

    На данной закладке выполняется задание произвольных подписей и заголовков объектам (разделы и элементы) инфоблока.

    Примечание: текст, указанный на вкладке Подписи, появится на кнопках добавления элемента/раздела, удаления элемента/раздела и т.д., а также в фильтрах и заголовках страниц административной части.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение параметров информационного блока. Возврат к списку инфоблоков данного типа.
Применить | Применение внесённых изменений. Продолжение редактирования параметров информационного блока.
Отменить | Отмена внесённых изменений. Возврат к списку информационных блоков данного типа.


Разделы и элементы информационного блока

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список объектов инфоблока
    •

    Если при создании типа инфоблока была отмечена опция Использовать древовидный классификатор элементов по разделам, то помимо конкретных элементов каждый инфоблок может содержать разделы и подразделы. Например, инфоблок Новости может содержать разделы В мире, Кино, Технологии и т.д.

    Элемент раздела инфоблока - сущность, не поддающаяся дальнейшей классификации в пределах созданной иерархии. Например, элемент Коврик для мыши раздела Аксессуары.

    С данной страницы можно управлять объектами иерархии (разделами и элементами) выбранного информационного блока.

    Форма поиска

    Форма позволяет выполнить поиск объектов (элементов и разделов) инфоблока, соответствующих указанным параметрам.

    Поле | Описание
Название | Поиск по названию объекта инфоблока.
Раздел | Поиск объектов инфоблока в указанном разделе.
ID (начальный и конечный) | Поиск можно задать по диапазону идентификаторов объектов инфоблоков, указав начальный, конечный либо оба идентификатора.
Дата изменения (DD.MM.YYYY) | Поиск можно задать по дате изменения объекта инфоблока (в формате DD.MM.YYYY).
Символьный код | Поиск объекта инфоблока по символьному (мнемоническому) коду.
Внешний код | Поиск объекта инфоблока по ключу, который используется для связи с внешними источниками.
Кто изменил | Поиск объектов инфоблока по автору изменений.
Дата создания (DD.MM.YYYY) | Поиск можно задать по дате создания объекта инфоблока (в формате DD.MM.YYYY).
Активен | Позволяет отобрать активные, неактивные или все объекты информационного блока.
Описание | Поиск можно задать по описанию объектов инфоблока.
Теги | Поиск можно задать по тегам элементов инфоблока.
Кто создал | Поиск объектов инфоблока по автору создания.

    Чтобы отобрать объекты инфоблока по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех объектов инфоблока нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Добавить раздел | Переход к форме создания нового раздела или подраздела для данного информационного блока.
Добавить элемент | Переход к форме создания нового элемента для данного информационного блока.
Свойства инфоблока | Переход к форме редактирования параметров данного информационного блока.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список объектов информационного блока

    Поле | Описание
    Колонка флажков | Выбор объектов инфоблока, к которым предполагается применить какое-либо правило или действие.
    Действия Доступные действия:

  • для раздела:
    • Изменить - переход к форме редактирования раздела инфоблока;
    • Удалить - удаление раздела инфоблока.
  • для элемента:
    • Изменить - переход к форме редактирования элемента инфоблока;
    • Удалить - удаление элемента инфоблока.
    Название | Название объекта инфоблока.
    Акт. Признак активности объекта:
    • Да - активен;
    • Нет - не активен.
    Начало активности | Дата и время начала активности элемента.
    Окончание активности | Дата и время окончания активности элемента.
    Описание для анонса | Альтернативный текст изображения анонса элемента.
    Детальное описание | Подробное описание объекта.
    Сорт. | Относительный "вес", определяющий положение объекта в списке.
    Символьный код | Символьный (мнемонический) код объекта информационного блока.
    Внешний ключ | Ключ, который может использовать для связи с внешними источниками.
    Теги | Теги (слова или словосочетания) элемента инфоблока.
    Детальная картинка | Детальное изображение, ассоциируемое с элементом инфоблока.
    Картинка для анонса | Изображение, ассоциируемое с анонсом объекта инфоблока.
    Элементов | Количество элементов в разделе/подразделе.
    Разделов | Количество разделов/подразделов инфоблока.
    Дата изменения | Дата и время последнего изменения объекта.
    Кем изменена | Логин и имя пользователя, который совершил последние изменения.
    Дата создания | Дата и время создания объекта.
    Кем создана | Логин и имя пользователя, который создал объект.
    ID | Идентификатор объекта.


Создание и редактирование раздела инфоблока

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Закладка "Раздел"
  • Закладка "Дополнительно"
    •
  • Кнопки управления
    •

    Форма позволяет создать новый или изменить уже существующий раздел информационного блока выбранного типа.

    Контекстная панель

    Кнопка | Описание
Список разделов | Переход на страницу со списком разделов информационного блока соответствующего типа.
Добавить раздел | Переход к форме создания нового раздела информационного блока. Кнопка отображается при редактировании существующего раздела инфоблока.
Удалить раздел | Удаление редактируемого раздела инфоблока. Кнопка отображается при редактировании существующего раздела инфоблока.

    Форма редактирования

    Закладка "Раздел"

    Закладка предназначена для настройки общих параметров раздела информационного блока.

    Поле | Описание
ID | Идентификатор раздела информационного блока. Поле отображается при редактировании существующего раздела инфоблока.
Изменена | Дата и время последнего изменения параметров раздела. Поле отображается при редактировании существующего раздела инфоблока.
Активен | Признак активности раздела информационного блока. При отмеченной опции содержимое раздела инфоблока доступно для показа в публичной части сайта.
Родительский раздел | Раздел, дочерним элементом которого является этот раздел.
*Название | Название раздела.
Описание
Изображение | Изображение, ассоциируемое с данным разделом инфоблока. С помощью кнопки Обзор можно загрузить данное изображение.
Text / HTML | Выбор формата для создания/изменения описания раздела инфоблока.
Использовать визуальный редактор | При отмеченной опции описание раздела инфоблока можно будет создать/изменить с помощью визуального редактора.

    * - поля, обязательные для заполнения.

    Закладка "Дополнительно"

    Закладка предназначена для настройки дополнительных параметров раздела информационного блока.

    Поле | Описание
Индекс сортировки | Относительный "вес", влияющий на положение раздела в списке разделов инфоблока.
Символьный код | Символьный (мнемонический) код раздела информационного блока.
Внешний ключ | Ключ, который может использовать для связи с внешними источниками.
Детальное изображение | Детальное изображение, ассоциируемое с данным разделом информационного блока. С помощью кнопки Обзор можно загрузить данное детальное изображение.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение параметров раздела информационного блока. Возврат к списку разделов инфоблока данного типа.
Применить | Применение внесённых изменений. Продолжение редактирования параметров раздела информационного блока.
Отменить | Отмена внесённых изменений. Возврат к списку разделов информационного блока данного типа.


Создание и редактирование элемента инфоблока

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Закладка "Элемент"
  • Закладка "Анонс"
  • Закладка "Подробно"
  • Закладка "Разделы"
  • Закладка "Дополнительно"
    •
  • Кнопки управления
    •

    Форма позволяет создать новый или изменить уже существующий элемент информационного блока выбранного типа.

    Контекстная панель

    Кнопка | Описание
Список элементов | Переход на страницу со списком элементов информационного блока соответствующего типа.
Добавить элемент | Переход к форме создания нового элемента информационного блока. Кнопка отображается при редактировании существующего элемента инфоблока.
Удалить элемент | Удаление редактируемого элемента инфоблока. Кнопка отображается при редактировании существующего элемента инфоблока.

    Форма редактирования

    Закладка "Элемент"

    Закладка предназначена для настройки общих параметров элемента информационного блока.

    Поле | Описание
ID | Идентификатор элемента информационного блока. Поле отображается при редактировании существующего элемента инфоблока.
Изменена | Дата и время последнего изменения параметров элемента инфоблока. Поле отображается при редактировании существующего элеменита инфоблока.
Активен | Признак активности элемента инфоблока. Активный элемент доступен для отображения в публичной части сайта.
Период активности | Дата начала и конца периода, в течении которого элемент инфоблока будет активным. После окончания периода элемент инфоблока станет неактивным и не будет показан в публичной части сайта.
*Название | Название элемента инфоблока, как оно отображается в публичной части.
Значения свойств
<название_свойства> | Имя свойства элемента инфоблока. Свойства элемента задаются в форме создания/редактирования инфоблока.
<значение_свойства> | Значение свойства для данного элемента инфоблока.

    * - поля, обязательные для заполнения.

    Закладка "Анонс"

    Закладка служит для задания краткого описание элемента. Созданное описание может использоваться, например, для характеристики каждого элемента при показе списка элементов в публичной части сайта.

    Поле | Описание
Изображение | Изображение, ассоциируемое с анонсом элемента инфоблока. С помощью кнопки Обзор можно загрузить данное изображение.
Описание | Альтернативный текст изображения анонса.
Содержание анонса
Text / HTML | Выбор формата для создания/изменения описания анонса элемента инфоблока.
Использовать визуальный редактор | При отмеченной опции описание анонса элемента инфоблока можно будет создать/изменить с помощью визуального редактора.

    Закладка "Подробно"

    Закладка служит для создания подробного описания элемента инфоблока. Например, полного текста новости, детального описания книги и т.д.

    Поле | Описание
Изображение | Детальное изображение, ассоциируемое с элементом инфоблока. С помощью кнопки Обзор можно загрузить данное изображение.
Описание | Альтернативный текст детального изображения элемента инфоблока.
Text / HTML | Выбор формата для создания/изменения полного детального описания элемента инфоблока.
Использовать визуальный редактор | При отмеченной опции полное описание элемента инфоблока можно будет создать/изменить с помощью визуального редактора.

    Закладка "Разделы"

    Закладка служит для выбора одного или нескольких разделов инфоблока, к которым относится элемент инфоблока.

    Поле | Описание
Разделы | Раздел(ы), к которым привязан элемент.

    Закладка "Дополнительно"

    Закладка предназначена для настройки дополнительных параметров элемента информационного блока.

    Поле | Описание
Индекс сортировки | Относительный "вес", влияющий на положение элемента в списке элементов инфоблока. Чем меньше вес сортировки, тем выше будет отображаеться элемент.
Символьный код | Символьный (мнемонический) код элемента информационного блока.
Внешний ключ | Ключ, который может использовать для связи с внешними источниками.
Теги | Слова или словосочетания (разделенные запятой), с помощью которых будет формироваться поиск по тегам.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение параметров элемента информационного блока. Возврат к списку объектов инфоблока данного типа.
Применить | Применение внесённых изменений. Продолжение редактирования параметров элемента информационного блока.
Отменить | Отмена внесённых изменений. Возврат к списку объектов информационного блока данного типа.


Создание и редактирование элемента инфоблока

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты

  • RSS
  • Добавление элементов
  • Инфоблоки
  • Каталог
  • Медиа
  • Новости
  • Фотогалерея


Структура разделов

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Каталог

  • Каталог (комплексный компонент)
  • Структура разделов
  • Элемент каталога детально
  • Элементы раздела


Каталог (комплексный компонент)

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Каталог::Каталог (комплексный компонент)

Комплексный компонент осуществляет вывод полного каталога элементов из определенного инфоблока. Его функциональность объединяет возможности нескольких одностраничных компонентов. Расположив комплексный компонент на одной странице можно получить полнофункциональный каталог. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="catalogue1"
 runat="server"
 componentname="bitrix:catalogue"
 template=".default"
 IBlockTypeId="18"
 IBlockId="24"
 AddAdminPanelButtons="True"
 SetPageTitle="True"
 RootSectionTitle=""
 GenerateMenu="True"
 GenerateMenuType="left"
 EnableSEF="True"
 SEFFolder="/test/"
 SectionIdVariable="section_id"
 ElementIdVariable="element_id"
 PageIdVariable="page"
 ShowAllVariable="showall"
 ElementDetailTemplate="/#SectionId#/item-#ElementId#/"
 ElementListTemplate="/#SectionId#/"
 CommonListPageTemplate="/page-#pageId#"
 CommonListShowAllTemplate="/all"
 SectionListPageTemplate="/#SectionId#/page-#pageId#"
 SectionListShowAllTemplate="/#SectionId#/all"
 EnableAjax="True"
 DisplaySearchResults="True"
 ListSortBy="ID"
 ListSortOrder="Desc"
 ShowSubElements="True"
 ShowAllElementsOnIndex="True"
 ActiveFilter="Active"
 ActiveDateFilter="All"
 ListProperties="'SOURCE'"
 DetailProperties="'SOURCE'"
 PropertyKeywords="-"
 PropertyDescription="-"
 DepthLevel="2"
 ShowCounters="True"
 IncludeParentSections="True"
 ShowTopElements="True"
 TopElementCount="6"
 TopSortBy="ID"
 TopSortOrder="Desc"
 TopProperties="'SOURCE'"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingAllowAll="True"
 PagingRecordsPerPage="5"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока, каталог элементов которого будет выведен.
Дополнительные настройки
Добавлять в админ. панель кнопки для данного компонента | AddAdminPanelButtons | [True|False] При отмеченной опции в административную панель будут добавлены кнопки для данного компонента.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установливаться при переходе к разделам - <название_раздела>, к детальному просмотру элемента - <название_элемента>.
Заголовок корневого раздела | RootSectionTitle | Указывается заголовок корневого раздела каталога.
Строить меню | GenerateMenu | [True|False] При отмеченной опции будет построено меню, элементами которого будут являтся разделы инфоблока.
Тип меню GenerateMenuType Указывается тип меню:
  • Верхнее (top);
  • Левое (left).
Управление адресами страниц
Включить поддержку ЧПУ EnableSEF [True|False] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить следущие параметры: SEFFolder, <имя>Template.

Если режим поддержки ЧПУ выключен, то необходимо настроить следущие параметры: <имя>Variable.
Каталог ЧПУ (относительно корня сайта) | SEFFolder | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
<страница> <имя>Template Указываются адреса следующих страниц:
  • ElementDetailTemplate - страница детального просмотра элемента;
  • ElementListTemplate - страница списка элементов раздела;
  • CommonListPageTemplate - отдельная страница в общем списке элементов (на главной странице каталога);
  • CommonListShowAllTemplate - страница всех элементов в общем списке;
  • SectionListPageTemplate - отдельная страница в списке элементов раздела;
  • SectionListShowAllTemplate - страница всех элементов раздела.
Идентификатор <имя> <имя>Variable Указываются следующие идентификаторы:
  • SectionIdVariable - идентификатор раздела;
  • ElementIdVariable - идентификатор элемента;
  • PageIdVariable - идентификатор страницы списка;
  • ShowAllVariable - идентификатор показа полного списка.
Настройки AJAX
Включить режим AJAX | EnableAjax | [True|False] При установленной опции для компонента будет включен режим AJAX.
Настройки поиска
Использовать для отображения результатов поиска | DisplaySearchResults | [True|False] При отмеченной опции компонент будет формировать ссылки на сообщения, найденные в результате поиска по каталогу.
Настройки списка
Сортируем по полю ListSortBy Указывается поле, по которому будет производиться сортировка списка элементов каталога:
  • ID - по идентификатору элемента;
  • Name - по названию элемента;
  • ActiveFromDate - по дате начала активности;
  • ActiveToDate - по дате окончания активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения;
  • SOURCE - по источнику.
Направление сортировки ListSortOrder Указывается направление сортировки списка элементов каталога:
  • По возрастанию (Asc);
  • По убыванию (Desc).
Показывать элементы подразделов раздела | ShowSubElements | [True|False] При отмеченной опции будут показаны все элементы подразделов раздела каталога.
Выводить все элементы информационного блока, если не указан раздел | ShowAllElementsOnIndex | [True|False] При отмеченной опции будут выведены все элементы информационного блока, если не указан раздел.
Выбирать элементы по активности ActiveFilter Указывается какие элементы будут отображены в списке:
  • только активные (Active);
  • только неактивные (NotActive);
  • все (All).
Выбирать элементы по периоду активности ActiveDateFilter Указывается какие элементы с периодом активности будут отображены в списке:
  • только активные (Active);
  • только неактивные (NotActive);
  • все (All).
Свойства | ListProperties | Указываются свойства инфоблока, которые будут отражены при показе списка элементов каталога.
Настройки детального просмотра
Свойства | DetailProperties | Указываются свойства инфоблока, которые будут отражены при детальном просмотре элемента каталога.
Установить ключевые слова страницы из свойства | PropertyKeywords | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова для страницы.
Установить описание страницы из свойства | PropertyDescription | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится детальное описание страницы.
Структура разделов
Максимальная отображаемая глубина разделов | DepthLevel | Указывается максимальная глубина отображаемых разделов.
Показывать количество элементов в разделе | ShowCounters | [True|False] При отмеченной опции будет показано количество элементов в разделе.
Показывать родительские разделы для текущего (выбранного) уровня | IncludeParentSections | [True|False] При отмеченной опции будут показаны родительские разделы для текущего (выбранного) уровня
Настройки TOP'а
Выводить топ элементов ShowTopElements [True|False] При отмеченной опции будет выведен TOP элементов инфоблока.

Если TOP'а элементов отображен, то необходимо настроить следущие параметры: TopElementCount, TopSortBy, TopSortOrder, TopProperties.
Количество элементов на странице | TopElementCount | Указывается количество элементов, отображаемых на одной странице TOP’а.
Сортируем по полю TopSortBy Указывается поле, по которому будет производиться сортировка TOP’а элементов каталога:
  • ID - по идентификатору элемента;
  • Name - по названию элемента;
  • ActiveFromDate - по дате начала активности;
  • ActiveToDate - по дате окончания активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения;
  • SOURCE - по источнику.
Направление сортировки TopSortOrder Указывается направление сортировки TOP’а элементов каталога:
  • По возрастанию (Asc);
  • По убыванию (Desc).
Свойства | TopProperties | Указываются свойства инфоблока, которые будут отражены при показе TOP’а элементов каталога.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение каталога.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingAllowAll, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Разрешить просмотр всех страниц | PagingAllowAll | [True|False] При отмеченной опции будет разрешен просмотр всех страниц.
Количество записей на странице | PagingRecordsPerPage | Указывается количество записей, отображаемых на одной странице. Весь список записей будет выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Элемент каталога детально

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Каталог::Элемент каталога детально

Компонент выводит детальную информацию по элементу каталога. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="catalogueelement_detail1"
 runat="server"
 componentname="bitrix:catalogue.element.detail"
 template=".default"
 IBlockTypeId="18"
 IBlockId="24"
 ElementId="348"
 ElementCode=""
 Properties="'SOURCE'"
 PropertyKeywords="-"
 PropertyDescription="-"
 AddAdminPanelButtons="True"
 SetPageTitle="True"
 Template_BackTitle="Вернуться к списку"
 Template_BackUrlTemplate=""
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока, элемент которого будет выведен.
ID элемента | ElementId | Указывается идентификатор элемента, который будет отображен.
Символическое имя элемента | ElementCode | Указывается символьный код элемента, который будет отображен.
Дополнительные настройки
Выводить свойства | Properties | Указываются свойства инфоблока, которые должны быть отражены при показе его элементов.
Установить ключевые слова страницы из свойства | PropertyKeywords | Ключевые слова страницы будут установлены из указанного свойства.
Установить описание страницы из свойства | PropertyDescription | Описание страницы будет установлено из указанного свойства.
Добавлять в админ. панель кнопки для данного компонента | AddAdminPanelButtons | [True|False] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установлено <название_элемента>.
Настройки ссылок
Заголовок ссылки возврата | Template_BackTitle | Указывается заголовок ссылки возврата
Шаблон ссылки возврата | Template_BackUrlTemplate | Указывается шаблон ссылки возврата (шаблон ссылки, по которой будет осуществлен переход после выполнения операции).
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Элементы раздела

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Каталог::Элементы раздела

Компонент выводит список элементов раздела с указанным набором свойств. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="catalogueelement_list1"
 runat="server"
 componentname="bitrix:catalogue.element.list"
 template=".default"
 IBlockTypeId="18"
 IBlockId="24"
 SectionId="0"
 SectionCode=""
 SortBy="ID"
 SortOrder="Desc"
 ShowSubElements="True"
 ShowAllElementsOnIndex="True"
 ActiveFilter="Active"
 ActiveDateFilter="All"
 Properties="'SOURCE'"
 AddAdminPanelButtons="True"
 SetPageTitle="True"
 SectionElementListUrl="list.aspx?section_id=#SECTION_ID#"
 ElementDetailUrl="detail.aspx?section_id=#SECTION_ID#&element_id=#ELEMENT_ID#"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingAllowAll="True"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingShowAll="<%$ Request:showall%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 PagingShowAllTemplate="?showall=y"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока, элементы которого будут выведены.
ID раздела | SectionId | Указывается идентификатор раздела, элементы которого будут отображены.
Символический код раздела | SectionCode | Указывается символьный код раздела, элементы которого будут отображены.
Источник данных
Сортируем по полю SortBy Указывается поле, по которому будет производиться сортировка элементов раздела:
  • ID - по идентификатору элемента;
  • Name - по названию элемента;
  • ActiveFromDate - по дате начала активности;
  • ActiveToDate - по дате окончания активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения;
  • SOURCE - по источнику.
Направление сортировки SortOrder Указывается направление сортировки элементов раздела:
  • По возрастанию (Asc);
  • По убыванию (Desc).
Показывать элементы подразделов раздела | ShowSubElements | [True|False] При отмеченной опции будут показаны все элементы подразделов раздела.
Выводить все элементы информационного блока, если не указан раздел | ShowAllElementsOnIndex | [True|False] При отмеченной опции будут выведены все элементы информационного блока, если не указан раздел.
Выбирать элементы по активности ActiveFilter Указывается какие элементы будут отображены в списке:
  • только активные (Active);
  • только неактивные (NotActive);
  • все (All).
Выбирать элементы по периоду активности ActiveDateFilter Указывается какие элементы с периодом активности будут отображены в списке:
  • только активные (Active);
  • только неактивные (NotActive);
  • все (All).
Дополнительные настройки
Свойства | Properties | Указываются свойства инфоблока, которые будут отражены при показе элементов разделов.
Добавлять в админ. панель кнопки для данного компонента | AddAdminPanelButtons | [True|False] При отмеченной опции в административную панель будут добавлены кнопки для данного компонента.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установлено <название_раздела>.
Управление адресами страниц
Раздел | SectionElementListUrl | Указывается шаблон пути к странице с содержимым раздела инфоблока.
Детальная информация | ElementDetailUrl | Указывается шаблон пути к странице с детальной информацией элемента инфоблока.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение элементов раздела.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Разрешить просмотр всех страниц | PagingAllowAll | [True|False] При отмеченной опции будет разрешен просмотр всех страниц.
Количество записей на странице | PagingRecordsPerPage | Указывается количество элементов раздела, отображаемых на одной странице. Весь список элементов будет отображен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ элементов раздела. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Показать все элементы | PagingShowAll | Задется способ отображения всех элементов раздела. Обычно задается в виде <%$ Request:showall%>, чтобы показ всех элементов выполнялся из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу списка элементов раздела.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам списка элементов раздела.
Страница просмотра всех элементов | PagingShowAllTemplate | Задается шаблон пути к странице просмотра всех элементов раздела.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Структура разделов

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Каталог::Структура разделов

Компонент выводит дерево разделов информационного блока. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="cataloguesection_tree1"
 runat="server"
 componentname="bitrix:catalogue.section.tree"
 template=".default"
 IBlockTypeId="18"
 IBlockId="24"
 SectionId=""
 SectionCode=""
 DepthLevel="2"
 ShowCounters="True"
 CountSubElements="True"
 IncludeParentSections="True"
 AddAdminPanelButtons="True"
 Template_RootTitle=""
 Template_RootUrl=""
 SectionUrl="?section_id=#SECTION_ID#"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока, дерево разделов которого будут выводиться.
Идентификатор раздела | SectionId | Указывается идентификатор раздела, дерево которого будет отображено.
Мнемонический код раздела | SectionCode | Указывается мнемонический (символьный) код раздела, дерево которого будет отображено.
Дополнительные настройки
Максимальная отображаемая глубина разделов | DepthLevel | Указывается максимальная глубина отображаемых разделов.
Показывать количество элементов в разделе | ShowCounters | [True|False] При отмеченной опции будет показано количество элементов в разделе.
Считать элементы в подразделах раздела | CountSubElements | [True|False] При отмеченной опции элементы в подразделах раздела будут посчитаны и добавлены к числу элементов текущего раздела.
Показывать родительские разделы для текущего (выбранного) уровня | IncludeParentSections | [True|False] При отмеченной опции будут показаны родительские разделы для текущего (выбранного) уровня
Добавлять в админ. панель кнопки для данного компонента | AddAdminPanelButtons | [True|False] При отмеченной опции в административную панель будут добавлены кнопки для данного компонента.
Заголовок ссылки корневого раздела | Template_RootTitle | Указывается заголовок ссылки корневого раздела.
Ссылка на корневой раздел | Template_RootUrl | Указывается ссылка на корневой раздел.
Настройки ссылок
Адрес страницы с содержимым раздела | SectionUrl | Указывается шаблон пути к странице с содержимым раздела инфоблока.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Список новостей

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Новости

  • Лента
  • Новости
  • Новость детально
  • Список новостей


Новости

Компонент позволяет создать полнофункциональный новостной раздел на сайте. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="news1"
 runat="server"
 componentname="bitrix:news"
 template=".default"
 IBlockTypeId="18"
 IBlockId="24"
 PagingRecordsPerPage="5"
 SortBy1="ActiveFromDate"
 SortBy2="ID"
 SortOrder1="Desc"
 SortOrder2="Desc"
 DisplayPanel="True"
 ShowActiveElements="True"
 IncludeSubsections="True"
 UsePermissions="True"
 GroupPermissions="'Admin';'AdminUser';'BXAdvertisingAdmin';'BXBlogAdmin';'BXForumAdmin';'Editor';'User'"
 GenerateMenu="True"
 GenerateMenuType="left"
 ListShowPreviewText="True"
 ListShowDetailText="True"
 ListShowPreviewPicture="True"
 PreviewTruncateLen="0"
 ListShowTitle="True"
 ListSetTitle="True"
 ListShowDate="True"
 ActiveDateFormat="dd.MM.yyyy"
 HideLinkWhenNoDetail="True"
 PropertyCode="'SOURCE'"
 DetailShowTitle="True"
 DetailSetTitle="True"
 DetailShowDetailPicture="True"
 DetailShowPreviewPicture="True"
 DetailShowPreviewText="True"
 DetailShowDate="True"
 DetailActiveDateFormat="dd.MM.yyyy"
 IBlockUrlTitle="Вернуться в список новостей"
 DetailPropertyCode="'SOURCE'"
 UseRss="True"
 RssElementsCount="20"
 RssDaysCount="3"
 EnableSEF="True"
 SEFFolder="/test/"
 ParamSection="section"
 ParamNews="news"
 ParamPage="page"
 ParamShowAll="showall"
 Sef_News="/#SectionId#/news-#ElementId#/"
 Sef_Rss="/rss/"
 Sef_Section="/#SectionId#/"
 Sef_Rss_Section="/rss/#SectionId#/"
 Sef_Page="/page-#pageId#"
 Sef_ShowAll="/all"
 Sef_Section_Page="/#SectionId#/page-#pageId#"
 Sef_Section_ShowAll="/#SectionId#/all"
 EnableAjax="True"
 DisplaySearchResults="True"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingAllowAll="True"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока (используется только для проверки) | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
Количество новостей на странице | PagingRecordsPerPage | Указывается количество новостей, отображаемых на одной странице.
Источник данных
Поле для первой сортировки новостей SortBy1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • Name - по названию новости;
  • ActiveFromDate - по дате начала активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения.
Поле для второй сортировки новостей SortBy2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • Name - по названию новости;
  • ActiveFromDate - по дате начала активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения.
Направление для первой сортировки новостей SortOrder1 Указывается направление для первой сортировки новостей:
  • Asc - по возрастанию;
  • Desc - по убыванию.
Направление для второй сортировки новостей SortOrder2 Указывается направление для второй сортировки новостей:
  • Asc - по возрастанию;
  • Desc - по убыванию.
Дополнительные настройки
Добавлять в админ. панель кнопки для данного компонента | DisplayPanel | [True|False] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Показывать только активные на данный момент элементы | ShowActiveElements | [True|False] При отмеченной опции будут показаны только активные на данный момент элементы.
Включать элементы из подразделов | IncludeSubsections | [True|False] При отмеченной опции будут отображены элементы подразделов раздела.
Использовать дополнительное ограничение доступа | UsePermissions | [True|False] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Роли пользователей, имеющие доступ к детальной информации, указываются в парметре GroupPermissions.
Роли пользователей, имеющие доступ к детальной информации | GroupPermissions | Указываются роли пользователей, имеющие доступ к детальной информации элементов инфоблока (новостей).
Строить меню | GenerateMenu | [True|False] При отмеченной опции будет построено меню, элементами которого будут являтся разделы инфоблока.
Тип меню GenerateMenuType Указывается тип меню:
  • Верхнее;
  • Левое.
Настройки списка
Выводить текст анонса | ListShowPreviewText | [True|False] При отмеченной опции будет выведен текст анонса новости.
Выводить детальное описание, если нет текста анонса | ListShowDetailText | [True|False] При отмеченной опции будет выведено детальное описание новости, если нет текста анонса.
Выводить изображение для анонса | ListShowPreviewPicture | [True|False] При отмеченной опции будет выведено изображения для анонса, если оно задано.
Максимальная длина анонса для вывода (только для типа текст) | PreviewTruncateLen | Указывается максимальная длина анонса для вывода (только для типа текст). При превышении параметра остаток текста будет отсечен.
Выводить название элемента | ListShowTitle | [True|False] При отмеченной опции будет выведено название элемента.
Устанавливать заголовок страницы | ListSetTitle | [True|False] При отмеченной опции будет установлен заголовок страницы в соотвес
Выводить дату элемента | ListShowDate | [True|False] При отмеченной опции будет отображена дата новости в списке.
Формат показа даты | ActiveDateFormat | Указывается формат показа даты, отображаемой в списке новостей.
Скрывать ссылку, если нет детального описания | HideLinkWhenNoDetail | [True|False] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
Свойства | PropertyCode | Указываются свойства, которые будут отображены на странице списка элементов.
Настройки детального просмотра
Выводить название элемента | DetailShowTitle | [True|False] При отмеченной опции будет выведено название новости.
Устанавливать заголовок страницы | DetailSetTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установлено название новости.
Выводить детальное изображение | DetailShowDetailPicture | [True|False] При отмеченной опции будет выведено детальное изображение для новости, если оно задано.
Выводить изображение для анонса | DetailShowPreviewPicture | [True|False] При отмеченной опции будет выведено изображения для анонса, если оно задано.
Выводить текст анонса | DetailShowPreviewText | [True|False] При отмеченной опции будет выведен текст анонса новости.
Выводить дату элемента | DetailShowDate | [True|False] При отмеченной опции будет отображена дата новости.
Формат показа даты | DetailActiveDateFormat | Указывается формат показа даты, отображаемой при детальном просмотре новости.
Название ссылки просмотра списка элементов | IBlockUrlTitle | Указывается название ссылки просмотра списка элементов (новостей).
Свойства для детального просмотра | DetailPropertyCode | Указываются свойства, которые будут отображены на странице детального просмотра новости.
Настройки RSS
Разрешить RSS | UseRss | [True|False] При отмеченной опции будет разрешен экспорт в RSS и доступны поля для спецификации настроек RSS.
Количество новостей для экспорта | RssElementsCount | Задается количество новостей для экспорта.
Количество дней для экспорта | RssDaysCount | Указывается количество дней для экспорта новостей.
Управление адресами страниц
Включить поддержку ЧПУ EnableSEF [True|False] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить следущие параметры: SEFFolder, Sef_<имя>.

Если режим поддержки ЧПУ выключен, то необходимо настроить следущие параметры: Param<имя>.
Каталог ЧПУ (относительно корня сайта) | SEFFolder | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
<страница> Sef_<имя> Указываются адреса следующих страниц:
  • Sef_News - страница детального просмотра;
  • Sef_Rss - страница RSS;
  • Sef_Section - страница раздела;
  • Sef_Rss_Section - страница RSS раздела;
  • Sef_Page - отдельная страница в списке новостей;
  • Sef_ShowAll - все страницы в списке новостей;
  • Sef_Section_Page - отдельная страница в списке новостей раздела;
  • Sef_Section_ShowAll - все страницы в списке новостей раздела.
Идентификатор/параметр <имя> Param<имя> Указываются следующие идентификаторы/параметры:
  • ParamSection - идентификатор раздела;
  • ParamNews - идентификатор новости;
  • ParamPage - параметр страницы для списка;
  • ParamShowAll - параметр показа полного списка новостей.
Настройки AJAX
Включить режим AJAX | EnableAjax | [True|False] При установленной опции для компонента будет включен режим AJAX.
Настройки поиска
Использовать для отображения результатов поиска | DisplaySearchResults | [True|False] При отмеченной опции компонент будет формировать ссылки на сообщения, найденные в результате поиска по новостям.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка новостей.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingAllowAll, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Разрешить просмотр всех страниц | PagingAllowAll | [True|False] При отмеченной опции будет разрешен просмотр всех страниц.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Новость детально

Компонент выводит детальное описание новости. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="newsdetail1"
 runat="server"
 componentname="bitrix:news.detail"
 template=".default"
 IBlockTypeId="18"
 IBlockId="21"
 ElementId="328"
 SetTitle="True"
 ShowTitle="True"
 ShowDetailPicture="True"
 ShowPreviewText="True"
 ShowPreviewPicture="True"
 ShowActiveElements="True"
 ShowDate="True"
 ActiveDateFormat="dd.MM.yyyy"
 DisplayPanel="True"
 PropertyCode="'SOURCE'"
 UsePermissions="True"
 GroupPermissions="'Admin';'AdminUser';'BXAdvertisingAdmin';'BXBlogAdmin';'BXForumAdmin';'Editor';'User'"
 IBlockUrl="News.aspx?id=#IBLOCK_ID#"
 IBlockUrlTitle="Вернуться в список новостей"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока (используется только для проверки) | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
ID новости | ElementId | Указывается идентификатор новости, детальный вид которой будет отображен.
Дополнительные настройки
Устанавливать заголовок страницы | SetTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установлено название новости.
Показывать заголовок новости | ShowTitle | [True|False] При отмеченной опции будет выводиться заголовок новости.
Выводить детальное изображение | ShowDetailPicture | [True|False] При отмеченной опции будет выведено детальное изображение новости, если оно задано.
Выводить текст анонса | ShowPreviewText | [True|False] При отмеченной опции будет выведен текст анонса новости.
Выводить изображение для анонса | ShowPreviewPicture | [True|False] При отмеченной опции будет выведено изображения для анонса, если оно задано.
Показывать только активные на данный момент элементы | ShowActiveElements | [True|False] При отмеченной опции будут показаны только активные на данный момент элементы.
Показывать дату элемента | ShowDate | [True|False] При отмеченной опции будет отображена дата новости.
Формат показа даты | ActiveDateFormat | Указывается формат показа даты.
Добавлять в админ. панель кнопки для данного компонента | DisplayPanel | [True|False] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Свойства | PropertyCode | Указываются свойства, которые будут отображены на странице детального просмотра новости.
Использовать дополнительное ограничение доступа | UsePermissions | [True|False] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока (новости). Роли пользователей, имеющие доступ к детальной информации, указываются в парметре GroupPermissions.
Роли пользователей, имеющие доступ к детальной информации | GroupPermissions | Указываются роли пользователей, имеющие доступ к детальной информации элементов инфоблока (новостей).
Управление адресами страниц
URL страницы просмотра списка элементов | IBlockUrl | Указывается шаблон ссылки на страницу просмотра списка элементов (новостей).
Название ссылки просмотра списка элементов | IBlockUrlTitle | Указывается название ссылки просмотра списка элементов (новостей).
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Лента

Компонент выводит список статей и новостей с датой и заголовком со ссылкой на страницу с подробной информацией. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="newsline1"
 runat="server"
 componentname="bitrix:news.line"
 template=".default"
 IBlockTypeId="18"
 IBlockIds="'24'"
 NewsCount="5"
 SortBy1="ActiveFromDate"
 SortBy2="Sort"
 SortOrder1="Desc"
 SortOrder2="Desc"
 DetailUrl="NewsDetail.aspx?id=#ELEMENT_ID#"
 ActiveDateFormat="dd.MM.yyyy"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока (используется только для проверки) | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
Количество новостей на странице | PagingRecordsPerPage | Указывается количество новостей, отображаемых на одной странице.
Источник данных
Поле для первой сортировки новостей SortBy1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • Name - по названию новости;
  • ActiveFromDate - по дате начала активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения.
Поле для второй сортировки новостей SortBy2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • Name - по названию новости;
  • ActiveFromDate - по дате начала активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения.
Направление для первой сортировки новостей SortOrder1 Указывается направление для первой сортировки новостей:
  • Asc - по возрастанию;
  • Desc - по убыванию.
Направление для второй сортировки новостей SortOrder2 Указывается направление для второй сортировки новостей:
  • Asc - по возрастанию;
  • Desc - по убыванию.
Управление адресами страниц
URL страницы детального просмотра | DetailUrl | Указывается шаблон ссылки на страницу детального просмотра новости.
Настройки списка
Формат показа даты | ActiveDateFormat | Указывается формат показа даты.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Список новостей

Компонент выводит список новостей из одного информационного блока. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="newslist1"
 runat="server"
 componentname="bitrix:news.list"
 template=".default"
 IBlockTypeId="18"
 IBlockId="21"
 PagingRecordsPerPage="5"
 ShowPreviewText="True"
 ShowDetailText="True"
 ShowPreviewPicture="True"
 PreviewTruncateLen=""
 ShowTitle="True"
 SetTitle="True"
 ShowDate="True"
 ActiveDateFormat="dd.MM.yyyy"
 HideLinkWhenNoDetail="True"
 PropertyCode="'SOURCE'"
 SortBy1="ActiveFromDate"
 SortBy2="Sort"
 SortOrder1="Desc"
 SortOrder2="Desc"
 DisplayPanel="True"
 UsePermissions="True"
 GroupPermissions="'Admin';'AdminUser';'BXAdvertisingAdmin';'BXBlogAdmin';'BXForumAdmin';'Editor';'User'"
 ShowActiveElements="True"
 ParentSectionId="0"
 IncludeSubsections="True"
 DetailUrl="NewsDetail.aspx?id=#ELEMENT_ID#"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingAllowAll="True"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока (используется только для проверки) | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
Количество новостей на странице | PagingRecordsPerPage | Указывается количество новостей, отображаемых на одной странице.
Настройки списка
Выводить текст анонса | ShowPreviewText | [True|False] При отмеченной опции будет выведен текст анонса новости.
Выводить детальное описание, если нет текста анонса | ShowDetailText | [True|False] При отмеченной опции будет выведено детальное описание новости, если нет текста анонса.
Выводить изображение для анонса | ShowPreviewPicture | [True|False] При отмеченной опции будет выведено изображения для анонса, если оно задано.
Максимальная длина анонса для вывода (только для типа текст) | PreviewTruncateLen | Указывается максимальная длина анонса для вывода (только для типа текст). При превышении параметра остаток текста будет отсечен.
Показывать заголовок новости | ShowTitle | [True|False] При отмеченной опции будет выводиться заголовок новости.
Устанавливать заголовок страницы | SetTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установлено имя инфоблока, из которого будет выводится список новостей.
Выводить дату элемента | ShowDate | [True|False] При отмеченной опции будет выводится дата новости.
Формат показа даты | ActiveDateFormat | Указывается формат показа даты.
Скрывать ссылку, если нет детального описания | HideLinkWhenNoDetail | [True|False] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
Свойства | PropertyCode | Указываются свойства, которые будут отображены на странице списка элементов (новостей).
Источник данных
Поле для первой сортировки новостей SortBy1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • Name - по названию новости;
  • ActiveFromDate - по дате начала активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения.
Поле для второй сортировки новостей SortBy2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • Name - по названию новости;
  • ActiveFromDate - по дате начала активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения.
Направление для первой сортировки новостей SortOrder1 Указывается направление для первой сортировки новостей:
  • Asc - по возрастанию;
  • Desc - по убыванию.
Направление для второй сортировки новостей SortOrder2 Указывается направление для второй сортировки новостей:
  • Asc - по возрастанию;
  • Desc - по убыванию.
Дополнительные настройки
Добавлять в админ. панель кнопки для данного компонента | DisplayPanel | [True|False] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Использовать дополнительное ограничение доступа | UsePermissions | [True|False] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Роли пользователей, имеющие доступ к детальной информации, указываются в парметре GroupPermissions.
Роли пользователей, имеющие доступ к детальной информации | GroupPermissions | Указываются роли пользователей, имеющие доступ к детальной информации элементов инфоблока (новостей).
Показывать только активные на данный момент элементы | ShowActiveElements | [True|False] При отмеченной опции будут показаны только активные на данный момент элементы.
ID раздела | ParentSectionId | Указывается идентификатор раздела информаионнго блока, элементы (новости) которого будут отображены в списке.
Включать элементы из подразделов | IncludeSubsections | [True|False] При отмеченной опции будут отображены элементы подразделов раздела.
Управление адресами страниц
URL страницы детального просмотра | DetailUrl | Указывается шаблон ссылки на страницу детального просмотра новости.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка новостей.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingAllowAll, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Разрешить просмотр всех страниц | PagingAllowAll | [True|False] При отмеченной опции будет разрешен просмотр всех страниц.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Мои элементы (комплексный компонент)

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Добавление элементов

  • Мои элементы (комплексный компонент)
  • Список моих элементов
  • Форма добавления / редактирования


Форма добавления / редактирования

Компонент выводит форму добавления/редактирования элемента информационного блока. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="iblockelement_webform1"
 runat="server"
 componentname="bitrix:iblock.element.webform"
 template=".default"
 IBlockTypeId="18"
 IBlockId="24"
 ElementId="382"
 EditFields="Name;ActiveFromDate;ActiveToDate;Sections;PreviewText;PreviewImage;DetailText;DetailImage;Captcha;PROPERTY_SOURCE"
 RequiredFields="'Name';'ActiveFromDate';'ActiveToDate'"
 EnableActivationPeriodProcessing="True"
 DaysBeforeActivationPeriodStart="0"
 ActivationPeriodLengthInDays="0"
 MannerOfUserIdentification="Custom"
 CustomUserId="0"
 RolesAuthorizedToManage="'Admin'"
 RolesAuthorizedToAdminister="'Admin'"
 MaxUserElements="0"
 MannerOfIssueModificationPermission="Always"
 RolesAuthorizedToManageOfActivation="'Admin'"
 ElementActiveAfterSave="Active"
 MannerOfUserAssociation="IBlockProperty"
 UserAssociatedByCustomIBlockProperty=""
 MaxSectionSelect="3"
 OnlyLeafSelect="False"
 MaxFileSizeUpload="1024"
 ActiveFromDateShowTime="True"
 ActiveToDateShowTime="True"
 NameFieldMacros="#DetailText#-#DateCreate#-#CreatedBy#"
 TextBoxSize="30"
 CreateButtonTitle="Добавить"
 UpdateButtonTitle="Сохранить"
 SuccessMessageAfterCreateElement="Элемент успешно добавлен"
 SuccessMessageAfterUpdateElement="Элемент успешно изменен"
 RedirectPageUrl=""
 ActiveCustomTitle=""
 NameCustomTitle="Название"
 ActiveFromDateCustomTitle=""
 ActiveToDateCustomTitle=""
 SectionsCustomTitle=""
 PreviewTextCustomTitle=""
 PreviewImageCustomTitle=""
 DetailTextCustomTitle=""
 DetailImageCustomTitle=""
 CaptchaCustomTitle=""
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока, для элемента которого будет отображена форма добавления или редактирования.
ID редактируемого элемента (0 - добавить новый элемент) | ElementId | Указывается идентификатор редактируемого элемента (при этом поля формы будут заполнены данными этого элемента). Если указать 0, то поля отображаемой формы будут пустые.
Поля, выводимые на редактирование | EditFields | Указываются поля формы добавления/редактирования элемента, которые будут доступны пользователю для редактирования.
Поля, обязательные для заполнения | RequiredFields | Указываются поля формы добавления/редактирования элемента, информация которых будет обязательной для заполнения.
Устанавливать период активности для создаваемых элементов | EnableActivationPeriodProcessing | [True|False] При отмеченной опции можно будет установить период активности для создаваемых элементов. В этом случае необходимо настроить параметры DaysBeforeActivationPeriodStart и ActivationPeriodLengthInDays.
Количество дней до начала периода активности ("0" или пустое значение - "Начало периода активности со дня создания") | DaysBeforeActivationPeriodStart | Указывается количество дней до начала периода активности для создаваемых элементов. Если указать 0 или пустое значени, то период активности будет начат со дня создания.
Период активности ("0" или пустое значение - "Окончание периода активности не контролируется") | ActivationPeriodLengthInDays | Указывается период активности для создаваемых элементов. Если указать 0 или пустое значени, то окончание периода активности не будет контролироваться.
Параметры доступа
Идентификация пользователя MannerOfUserIdentification Указывается идентификация пользователя, которому будет разрешено добавлять/редактировать элементов инфоблока:
  • текущий (Current) - при этом необходимо задать значения параметров MaxUserElements и MannerOfIssueModificationPermission;
  • указанный (Custom) - при этом указать идентификатор можно в параметре CustomUserId.
Идентификатор пользователя | CustomUserId | Указывается идентификация пользователя, которому будет разрешено добавлять/редактировать элементов инфоблока.
Роли пользователей, имеющие право на добавление/редактирование своих элементов | RolesAuthorizedToManage | Указываются роли пользователей, имеющие право на добавление/редактирование своих элементов инфоблока.
Роли пользователей, имеющие право на добавление/редактирование чужих элементов | RolesAuthorizedToAdminister | Указываются роли пользователей, имеющие право на добавление/редактирование чужих элементов инфоблока.
Роли пользователей, имеющие право на управление статусом | RolesAuthorizedToManageOfActivation | Указываются роли пользователей, имеющие право на управление статусами элементов инфоблока.
Ограничить количество добавляемых элементов для одного пользователя | MaxUserElements | Указывается максимальное количество элементов, которые может добавить один пользователь.
Разрешать редактирование своих элементов MannerOfIssueModificationPermission Пользователю будет разрешено редактирование своих элементов:
  • если элемент активен (Active);
  • если элемент не активен (NotActive);
  • всегда (Always).
Статус после сохранения (если управление статусом недоступно для пользователя) ElementActiveAfterSave Указывается статус, в который переводятся элементы после их сохранения. Возможные значения:
  • Активный (Active);
  • Неактивный (NotActive).
Привязка к пользователю MannerOfUserAssociation Задается привязка к пользователю:
  • отсутствует (NoBody);
  • создателю (CreatedBy) - привязка по создателю: пользователю будут показаны только созданные им элементы;
  • по свойству инфоблока (IBlockProperty) - привязка по свойству инфоблока. В этом случае необходимо указать свойство параметр UserAssociatedByCustomIBlockProperty.
Привязка по свойству инфоблока | UserAssociatedByCustomIBlockProperty | Указывается свойство инфоблока, по которому выполняется привязка пользователя.
Настройки полей
Ограничить количество разделов, в которые можно добавлять элемент | MaxSectionSelect | Указывается максимальное количество разделов инфоблока, в которые можно добавлять элемент.
Разрешить добавление только на последний уровень дерева разделов | OnlyLeafSelect | [True|False] При отмеченной опции будет разрешено добавлять элементы только на последний уровень дерева разделов инфоблока.
Максимальный размер загружаемых файлов, кбайт (0 - не ограничивать) | MaxFileSizeUpload | Указывается максимальный размер загружаемых файлов. Если указано 0, то размер файлов не ограничен.
Выводить время у поля Начало активности | ActiveFromDateShowTime | [True|False] При отмеченной опции в поле Начало активности будет отображено время в заданном формате.
Выводить время у поля Конец активности | ActiveToDateShowTime | [True|False] При отмеченной опции в поле Конец активности будет отображено время в заданном формате.
Шаблон для автоматического заполнения поля "Название", если оно не выбрано для показа | NameFieldMacros | Задается шаблон для автоматического заполнения поля Название, если оно не выбрано для показа.
Дополнительные настройки
Размер полей ввода | TextBoxSize | Указывается размер полей ввода формы добавления/редактирования элемента.
Название кнопки "Добавить" | CreateButtonTitle | Задается название кнопки Добавить.
Название кнопки "Сохранить" | UpdateButtonTitle | Задается название кнопки Сохранить.
Сообщение об успешном добавлении | SuccessMessageAfterCreateElement | Задается текст сообщения, который будет отображен при успешном добавление элемента.
Сообщение об успешном сохранении | SuccessMessageAfterUpdateElement | Задается текст сообщения, который будет отображен при успешном сохранении элемента.
Страница перенаправления (редиректа) после сохранения элемента | RedirectPageUrl | Указывается адрес страницы, на которую будет осуществлен переход после сохранения элемента.
Собственные названия полей
<поле_инфоблока> <имя>CustomTitle Задаются названия полей инфоблока для отображения пользователям. В полях <поле_инфоблока> может быть указано следующее:
  • ActiveCustomTitle - активен;
  • NameCustomTitle - название;
  • ActiveFromDateCustomTitle - дата начала;
  • ActiveToDateCustomTitle - дата завершения;
  • SectionsCustomTitle - раздел информационного блока;
  • PreviewTextCustomTitle - текст анонса;
  • PreviewImageCustomTitle - изображение анонса;
  • DetailTextCustomTitle - детальное описание;
  • DetailImageCustomTitle - детальное изображение;
  • CaptchaCustomTitle - код подтверждения (CAPTCHA).


Список моих элементов

Компонент выводит список доступных пользователю элементов указанного инфоблока и позволяет с помощью ссылок Добавить, Редактировать и Удалить добавлять/редактировать/удалять элементы. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="iblockmyelement_list1"
 runat="server"
 componentname="bitrix:iblock.myElement.list"
 template=".default"
 IBlockTypeId="18"
 IBlockId="24"
 MannerOfUserIdentification="Custom"
 CustomUserId="0"
 RolesAuthorizedToManage="'Admin'"
 PermitOfCreation="True"
 PermitOfModification="True"
 MannerOfIssueModificationPermission="Active"
 PermitOfDeletion="True"
 RolesAuthorizedToView="'Admin'"
 RolesAuthorizedToAdminister="'Admin'"
 MannerOfUserAssociation="IBlockProperty"
 UserAssociatedByCustomIBlockProperty=""
 SortBy="ID"
 SortOrder="Desc"
 ElementCreationUrlTitle="Добавить"
 ElementCreationUrl="./edit.aspx"
 ElementModificationUrl="./edit.aspx?elementId=#ElementId#"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingAllowAll="True"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingShowAll="<%$ Request:showall%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 PagingShowAllTemplate="?showall=y"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока, список элементов которого будет отображен.
Настройки доступа
Идентификация пользователя MannerOfUserIdentification Указывается идентификация пользователя, список элементов инфоблока которого будет отображен:
  • текущий (Current);
  • указанный (Custom) - при этом указать идентификатор можно в параметре CustomUserId.
Идентификатор пользователя | CustomUserId | Указывается идентификация пользователя, список элементов инфоблока которого будет отображен.
Роли пользователей, имеющие право смотреть свои элементы | RolesAuthorizedToManage | Указываются роли пользователей, имеющие право на просмотр своих элементов инфоблока.
Разрешить создание своих элементов | PermitOfCreation | [True|False] При отмеченной опции будут выведены ссылки на создание доступных пользователю элементов.
Разрешить редактирование своих элементов | PermitOfModification | [True|False] При отмеченной опции будут выведены ссылки на редактирование доступных пользователю элементов. При этом какие элементы будет разрешено редактировать определяется параметром .
Разрешать редактирование своих элементов MannerOfIssueModificationPermission Редактирование элементов будет разрешено:
  • если элемент активен (Active);
  • если элемент не активен (NotActive);
  • всегда (Always).
Разрешить удаление своих элементов | PermitOfDeletion | [True|False] При отмеченной опции будут выведены ссылки на удаление доступных пользователю элементов.
Роли пользователей, имеющие право на просмотр чужих элементов | RolesAuthorizedToView | Указываются роли пользователей, имеющие право на просмотр чужих элементов инфоблока.
Роли пользователей, имеющие право на добавление/редактирование/удаление чужих элементов | RolesAuthorizedToAdminister | Указываются роли пользователей, имеющие право на добавление/редактирование/удаление чужих элементов инфоблока.
Привязка к пользователю MannerOfUserAssociation Задается привязка к пользователю:
  • отсутствует (NoBody);
  • создателю (CreatedBy) - привязка по создателю: пользователю будут показаны только созданные им элементы;
  • по свойству инфоблока (IBlockProperty) - привязка по свойству инфоблока. В этом случае необходимо указать свойство параметр UserAssociatedByCustomIBlockProperty.
Привязываться к пользователю по свойству инфоблока | UserAssociatedByCustomIBlockProperty | Указывается свойство инфоблока, по которому выполняется привязка пользователя.
Источник данных
Сортируем по полю SortBy Указывается поле, по которому будет производиться сортировка списка доступных пользователю элементов указанного инфоблока:
  • ID - по идентификатору элемента;
  • Name - по названию элемента;
  • ActiveFromDate - по дате начала активности;
  • ActiveToDate - по дате окончания активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения;
  • SOURCE - по источнику.
Направление сортировки SortOrder Указывается направление сортировки списка доступных пользователю элементов указанного инфоблока:
  • По возрастанию (Asc);
  • По убыванию (Desc).
Дополнительные настройки
Название ссылки на страницу создания элемента | ElementCreationUrlTitle | Указывается название ссылки на страницу создания элемента.
Управление адресами страниц
Страница создания элемента | ElementCreationUrl | Указывается шаблон пути к странице редактирования элемента.
Страница редактирования элемента | ElementModificationUrl | Указывается шаблон пути к страница редактирования элемента.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка доступных пользователю элементов указанного инфоблока.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingAllowAll, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingShowAll, PagingIndexTemplate, PagingPageTemplate, PagingShowAllTemplate.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Разрешить просмотр всех страниц | PagingAllowAll | [True|False] При отмеченной опции будет разрешен просмотр всех страниц.
Количество записей на странице | PagingRecordsPerPage | Указывается количество записей, отображаемых на одной странице. Весь список записей будет выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ списка доступных пользователю элементов указанного инфоблока. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Показать все элементы | PagingShowAll | Задется способ отображения всех элементов списка. Обычно задается в виде <%$ Request:showall%>, чтобы показ всех элементов выполнялся из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу со списком доступных пользователю элементов указанного инфоблока.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам списка доступных пользователю элементов указанного инфоблока.
Страница просмотра всех элементов | PagingShowAllTemplate | Задается шаблон пути к странице просмотра всех элементов списка доступных пользователю элементов указанного инфоблока.


Мои элементы (комплексный компонент)

Комплексный компонент осуществляет вывод списка элементов указанного инфоблока, добавление/редактирование/удаление элементов в зависимости от роли пользователя. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="iblockmyelements1"
 runat="server"
 componentname="bitrix:iblock.myElements"
 template=".default"
 IBlockTypeId="18"
 IBlockId="24"
 MannerOfUserIdentification="Custom"
 CustomUserId="0"
 RolesAuthorizedToManage="'Admin';'AdminUser';'BXAdvertisingAdmin';'BXBlogAdmin';'BXForumAdmin';'Editor';'User'"
 PermitOfCreation="True"
 MaxUserElements="15"
 PermitOfModification="True"
 MannerOfIssueModificationPermission="Active"
 PermitOfDeletion="True"
 RolesAuthorizedToView="'Admin'"
 RolesAuthorizedToAdminister="'Admin'"
 RolesAuthorizedToManageOfActivation="'Admin'"
 ElementActiveAfterSave="Active"
 MannerOfUserAssociation="IBlockProperty"
 UserAssociatedByCustomIBlockProperty=""
 SortBy="ID"
 SortOrder="Desc"
 EditFields="Name;ActiveFromDate;ActiveToDate;Sections;PreviewText;PreviewImage;DetailText;DetailImage;Captcha;PROPERTY_SOURCE"
 RequiredFields="'Name';'ActiveFromDate';'ActiveToDate';'Sections';'PreviewText';'PreviewImage';'DetailText';'DetailImage'"
 TextBoxSize="30"
 CreateButtonTitle="Добавить"
 UpdateButtonTitle="Сохранить"
 MaxSectionSelect="3"
 OnlyLeafSelect="True"
 MaxFileSizeUpload="1024"
 ActiveFromDateShowTime="True"
 ActiveToDateShowTime="True"
 NameFieldMacros="#DetailText#-#DateCreate#-#CreatedBy#"
 ActiveCustomTitle=""
 NameCustomTitle=""
 ActiveFromDateCustomTitle=""
 ActiveToDateCustomTitle=""
 SectionsCustomTitle=""
 PreviewTextCustomTitle=""
 PreviewImageCustomTitle=""
 DetailTextCustomTitle=""
 DetailImageCustomTitle=""
 CaptchaCustomTitle=""
 EnableSEF="True"
 SEFFolder="/test/"
 RequestParamNameCreateElement="new"
 RequestParamNameModifyElement="id"
 RequestParamNamePageIndex="page"
 RequestParamNameShowAll="all"
 SefTemplateCreateElement="/new/"
 SefTemplateModifyElement="/edit-#ElementId#/"
 SefTemplatePageIndex="/page-#PageId#"
 SefTemplateShowAll="/all"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingAllowAll="True"
 PagingRecordsPerPage="5"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока, список элементов которого будет отображен.
Настройки доступа
Идентификация пользователя MannerOfUserIdentification Указывается идентификация пользователя, список элементов инфоблока которого будет отображен:
  • текущий (Current);
  • указанный (Custom) - при этом указать идентификатор можно в параметре CustomUserId.
Идентификатор пользователя | CustomUserId | Указывается идентификация пользователя, список элементов инфоблока которого будет отображен.
Роли пользователей, имеющие право смотреть свои элементы | RolesAuthorizedToManage | Указываются роли пользователей, имеющие право на просмотр своих элементов инфоблока.
Разрешить создание своих элементов | PermitOfCreation | [True|False] При отмеченной опции будут выведены ссылки на создание доступных пользователю элементов.
Ограничить количество добавляемых элементов для одного пользователя | MaxUserElements | Указывается максимальное количество элементов, которые может добавить один пользователь.
Разрешить редактирование своих элементов | PermitOfModification | [True|False] При отмеченной опции будут выведены ссылки на редактирование доступных пользователю элементов. При этом какие элементы будет разрешено редактировать определяется параметром .
Разрешать редактирование своих элементов MannerOfIssueModificationPermission Редактирование элементов будет разрешено:
  • если элемент активен (Active);
  • если элемент не активен (NotActive);
  • всегда (Always).
Разрешить удаление своих элементов | PermitOfDeletion | [True|False] При отмеченной опции будут выведены ссылки на удаление доступных пользователю элементов.
Роли пользователей, имеющие право на просмотр чужих элементов | RolesAuthorizedToView | Указываются роли пользователей, имеющие право на просмотр чужих элементов инфоблока.
Роли пользователей, имеющие право на добавление/редактирование/удаление чужих элементов | RolesAuthorizedToAdminister | Указываются роли пользователей, имеющие право на добавление/редактирование/удаление чужих элементов инфоблока.
Роли пользователей, имеющие право на управление статусом | RolesAuthorizedToManageOfActivation | Указываются роли пользователей, имеющие право на управление статусами элементов инфоблока.
Статус после сохранения (если управление статусом недоступно для пользователя) ElementActiveAfterSave Указывается статус, в который переводятся элементы после их сохранения. Возможные значения:
  • Активный (Active);
  • Неактивный (NotActive).
Привязка к пользователю MannerOfUserAssociation Задается привязка к пользователю:
  • отсутствует (NoBody);
  • создателю (CreatedBy) - привязка по создателю: пользователю будут показаны только созданные им элементы;
  • по свойству инфоблока (IBlockProperty) - привязка по свойству инфоблока. В этом случае необходимо указать свойство параметр UserAssociatedByCustomIBlockProperty.
Привязываться к пользователю по свойству инфоблока | UserAssociatedByCustomIBlockProperty | Указывается свойство инфоблока, по которому выполняется привязка пользователя.
Настройки списка
Сортируем по полю SortBy Указывается поле, по которому будет производиться сортировка списка элементов указанного инфоблока:
  • ID - по идентификатору элемента;
  • Name - по названию элемента;
  • ActiveFromDate - по дате начала активности;
  • ActiveToDate - по дате окончания активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения;
  • SOURCE - по источнику.
Направление сортировки SortOrder Указывается направление сортировки списка доступных пользователю элементов указанного инфоблока:
  • По возрастанию (Asc);
  • По убыванию (Desc).
Настройки формы редактирования
Поля, выводимые на редактирование | EditFields | Указываются поля формы элемента, которые будут доступны пользователю для редактирования.
Поля, обязательные для заполнения | RequiredFields | Указываются поля формы элемента, информация которых будет обязательной для заполнения.
Размер полей ввода | TextBoxSize | Указывается размер полей ввода формы добавления/редактирования элемента.
Название кнопки "Добавить" | CreateButtonTitle | Задается название кнопки Добавить.
Название кнопки "Сохранить" | UpdateButtonTitle | Задается название кнопки Сохранить.
Настройки полей формы
Ограничить количество разделов, в которые можно добавлять элемент | MaxSectionSelect | Указывается максимальное количество разделов инфоблока, в которые можно добавлять элемент.
Разрешить добавление только на последний уровень дерева разделов | OnlyLeafSelect | [True|False] При отмеченной опции будет разрешено добавлять элементы только на последний уровень дерева разделов инфоблока.
Максимальный размер загружаемых файлов, кбайт (0 - не ограничивать) | MaxFileSizeUpload | Указывается максимальный размер загружаемых файлов. Если указано 0, то размер файлов не ограничен.
Выводить время у поля Начало активности | ActiveFromDateShowTime | [True|False] При отмеченной опции в поле Начало активности будет отображено время в заданном формате.
Выводить время у поля Конец активности | ActiveToDateShowTime | [True|False] При отмеченной опции в поле Конец активности будет отображено время в заданном формате.
Шаблон для автоматического заполнения поля "Название", если оно не выбрано для показа | NameFieldMacros | Задается шаблон для автоматического заполнения поля Название, если оно не выбрано для показа.
Собственные названия полей формы
<поле_инфоблока> <имя>CustomTitle Задаются названия полей инфоблока для отображения пользователям. В полях <поле_инфоблока> может быть указано следующее:
  • ActiveCustomTitle - активен;
  • NameCustomTitle - название;
  • ActiveFromDateCustomTitle - дата начала;
  • ActiveToDateCustomTitle - дата завершения;
  • SectionsCustomTitle - раздел информационного блока;
  • PreviewTextCustomTitle - текст анонса;
  • PreviewImageCustomTitle - изображение анонса;
  • DetailTextCustomTitle - детальное описание;
  • DetailImageCustomTitle - детальное изображение;
  • CaptchaCustomTitle - код подтверждения (CAPTCHA).
Управление адресами страниц
Включить поддержку ЧПУ EnableSEF [True|False] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить следущие параметры: SEFFolder, SefTemplate<имя>.

Если режим поддержки ЧПУ выключен, то необходимо настроить следущие параметры: RequestParamName<имя>.
Каталог ЧПУ (относительно корня сайта) | SEFFolder | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
<страница> SefTemplate<имя> Указываются адреса следующих страниц:
  • SefTemplateCreateElement - страница создания элемента;
  • SefTemplateModifyElement - страница редактирования элемента;
  • SefTemplatePageIndex - отдельная страница в списке элементов;
  • SefTemplateShowAll - страница всех элементов в списке.
Идентификатор <имя> RequestParamName<имя> Указываются следующие идентификаторы:
  • RequestParamNameCreateElement - идентификатор создания элемента;
  • RequestParamNameModifyElement - идентификатор редактирования элемента;
  • RequestParamNamePageIndex - идентификатор страницы списка;
  • RequestParamNameShowAll - идентификатор показа полного списка.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка элементов.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingAllowAll, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Разрешить просмотр всех страниц | PagingAllowAll | [True|False] При отмеченной опции будет разрешен просмотр всех страниц.
Количество записей на странице | PagingRecordsPerPage | Указывается количество записей, отображаемых на одной странице. Весь список записей будет выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.


Разделы и элементы

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Инфоблоки

  • Разделы и элементы


Разделы и элементы

Компонент выводит элементы инфоблока, сгруппированные по разделам. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="iblockhierarchy2"
 runat="server"
 componentname="bitrix:iblock.hierarchy"
 template=".default"
 IBlockType="19"
 IBlock="23"
 IBlockSection=""
 Depth="1"
 GetElements="True"
 PagingRecordsPerPage="10"
 SetTitle="True"
 SortBy1="ID"
 SortBy2="Sort"
 SortOrder1="Desc"
 SortOrder2="Asc"
 SectionActiveFilter="Active"
 ActiveFilter="All"
 ActiveDateFilter="All"
 SectionUrlTemplate="?section=#SectionId#"
 ElementUrlTemplate="?element=#ElementId#"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingAllowAll="True"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 CacheMode="Auto"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип инфоблока | IBlockType | Указывается один из созданных в системе типов информационного блока.
Инфоблок | IBlock | Для выбранного типа инфоблока указывается идентификатор информационного блока, сгруппированные по разделам элементы которого будут выведены.
Раздел инфоблока | IBlockSection | Указывается раздел инфоблока, элементы которого будут отображены.
Глубина выборки | Depth | Указывается глубина выборки элементов разделов. Чем больше число, тем больше элементов низких уровней будут отображены.
Выбирать элементы | GetElements | [True|False] При отмеченной опции будут отображены сгруппированные элементы разделов.
Количество разделов на странице | PagingRecordsPerPage | Указывается количество разделов, отображаемых на одной странице. Весь список разделов будет выведен с помощью постраничной навигации.
Устанавливать заголовок страницы | SetTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установлено <название_инфоблока>.
Источник данных
Поле для первой сортировки разделов SortBy1 Указывается поле, по которому будет производиться первая сортировка разделов указанного инфоблока:
  • ID - по идентификатору раздела;
  • Name - по названию раздела;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения раздела.
Поле для второй сортировки разделов SortBy2 Указывается поле, по которому будет производиться вторая сортировка разделов указанного инфоблока:
  • ID - по идентификатору раздела;
  • Name - по названию раздела;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения раздела.
Направление для первой сортировки разделов SortOrder1 Указывается направление для первой сортировки разделов указанного инфоблока:
  • По возрастанию (Asc);
  • По убыванию (Desc).
Направление для второй сортировки разделов SortOrder2 Указывается направление для второй сортировки разделов указанного инфоблока:
  • По возрастанию (Asc);
  • По убыванию (Desc).
Выбирать разделы по активности SectionActiveFilter Указывается какие разделы будут отображены:
  • только активные (Active);
  • все (All);
Выбирать элементы по активности ActiveFilter Указывается какие элементы будут отображены:
  • только активные (Active);
  • только неактивные (NotActive);
  • все (All);
Выбирать элементы по периоду активности ActiveDateFilter Указывается какие элементы с периодом активности будут отображены:
  • только активные (Active);
  • только неактивные (NotActive);
  • все (All).
Настройки ссылок
Ссылка на раздел | SectionUrlTemplate | Указывается шаблон ссылки на раздел инфоблока.
Ссылка на элемент | ElementUrlTemplate | Указывается шаблон ссылки на элемент инфоблока.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение элементов инфоблока, сгруппированных по разделам.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingAllowAll, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Разрешить просмотр всех страниц | PagingAllowAll | [True|False] При отмеченной опции будет разрешен просмотр всех страниц.
Количество записей на странице | PagingRecordsPerPage | Указывается количество элементов инфоблока, отображаемых на одной странице. Весь список элементов будет выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Медиа-проигрыватель

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Медиа

  • Медиа-проигрыватель
  • Медиагалерея (комплексный компонент)
  • Список элементов медиагалереи
  • Элемент медиагалереи


Медиагалерея (комплексный компонент)

Комплексный компонент позволяет получить полнофункциональную медиагалерею, создавая физически только одну страницу. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="mediagallery1"
 runat="server"
 componentname="bitrix:media.gallery"
 template=".default"
 IBlockTypeId="22"
 IBlockId="28"
 IBlockElementPropertyForFilePath="MEDIA"
 IBlockElementPropertyForPlaylistPreviewImageFilePath="PREVIEW"
 IBlockElementPropertyForPlayerPreviewImageFilePath="PREVIEW"
 IBlockElementPropertyForDownloadingFilePath="MEDIA"
 AddAdminPanelButtons="True"
 SetPageTitle="True"
 GenerateMenu="True"
 GenerateMenuType="left"
 EnableSEF="True"
 SEFFolder="/test/"
 SectionIdVariable="section_id"
 ElementIdVariable="element_id"
 PageIdVariable="page"
 ShowAllVariable="showall"
 ElementDetailTemplate="/#SectionId#/item-#ElementId#/"
 ElementListTemplate="/#SectionId#/"
 CommonListPageTemplate="/page-#PageId#"
 CommonListShowAllTemplate="/all"
 SectionListPageTemplate="/#SectionId#/page-#PageId#"
 SectionListShowAllTemplate="/#SectionId#/all"
 ListSortBy="ID"
 ListSortOrder="Desc"
 ShowSubElements="True"
 ShowAllElementsOnIndex="True"
 ListProperties="'MEDIA';'PREVIEW'"
 DetailProperties="'MEDIA';'PREVIEW'"
 PropertyKeywords="-"
 PropertyDescription="-"
 PlayerEnableFullScreenModeSwitch="True"
 PlayerWidth="425px"
 PlayerHeight="344px"
 PlayerStretching="Proportionally"
 PlayerShowControlPanel="True"
 PlayerControlPanelBackgroundColor="FFFFFF"
 PlayerControlsColor="000000"
 PlayerControlsOverColor="000000"
 PlayerScreenColor="000000"
 PlayerVolumeLevelInPercents="90"
 PlayerBufferLengthInSeconds="10"
 PlayerEnableAutoStart="True"
 PlayerEnableRepeatMode="True"
 PlayerEnableDownloading="True"
 PlayerDownloadingLinkTargetWindow="_self"
 ShowTopElements="True"
 TopElementCount="6"
 TopSortBy="ID"
 TopSortOrder="Desc"
 TopProperties="'MEDIA';'PREVIEW'"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingAllowAll="True"
 PagingRecordsPerPage="5"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 CacheMode="Auto"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Информационный блок | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока медиагалереи.
Источник данных
Свойство, содержащее URL файла для воспроизведения | IBlockElementPropertyForFilePath | Указывается свойство инфоблока, которое содержит URL файла для воспроизведения.
Свойство, содержащее URL изображения для предв. просмотра в списке | IBlockElementPropertyForPlaylistPreviewImageFilePath | Указывается свойство инфоблока, которое содержит URL изображения для предварительного просмотра.
Свойство, содержащее URL изображения для предв. просмотра в проигрывателе | IBlockElementPropertyForPlayerPreviewImageFilePath | Указывается свойство инфоблока, которое содержит URL изображения для предварительного просмотра в проигрывателе.
Свойство, содержащее URL файла для скачивания | IBlockElementPropertyForDownloadingFilePath | Указывается свойство инфоблока, которое содержит URL файла для скачивания.
Дополнительные настройки
Добавлять в админ. панель кнопки для данного компонента | AddAdminPanelButtons | [True|False] При отмеченной опции в административную панель будут добавлены кнопки для данного компонента.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установливаться при переходе к разделам медиагалереи - <название_раздела>, к детальному просмотру элемента - <название_элемента>.
Строить меню | GenerateMenu | [True|False] При отмеченной опции будет построено меню, элементами которого будут являтся разделы инфоблока.
Тип меню GenerateMenuType Указывается тип меню:
  • Верхнее (top);
  • Левое (left).
Управление адресами страниц
Включить поддержку ЧПУ EnableSEF [True|False] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить следущие параметры: SEFFolder, <имя>Template.

Если режим поддержки ЧПУ выключен, то необходимо настроить следущие параметры: <имя>Variable.
Каталог ЧПУ (относительно корня сайта) | SEFFolder | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
<страница> <имя>Template Указываются адреса следующих страниц:
  • ElementDetailTemplate - страница детального просмотра элемента;
  • ElementListTemplate - страница списка элементов раздела;
  • CommonListPageTemplate - отдельная страница в общем списке элементов;
  • CommonListShowAllTemplate - страница всех элементов в общем списке;
  • SectionListPageTemplate - отдельная страница в списке элементов раздела;
  • SectionListShowAllTemplate - страница всех элементов раздела.
Идентификатор <имя> <имя>Variable Указываются следующие идентификаторы:
  • SectionIdVariable - идентификатор раздела;
  • ElementIdVariable - идентификатор элемента;
  • PageIdVariable - идентификатор страницы списка;
  • ShowAllVariable - идентификатор показа полного списка.
Настройки списка
Сортируем по полю ListSortBy Указывается поле, по которому будет производиться сортировка списка элементов медиагалереи:
  • ID - по идентификатору элемента;
  • Name - по названию элемента;
  • ActiveFromDate - по дате начала активности;
  • ActiveToDate - по дате окончания активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения;
  • SOURCE - по источнику;
  • <название_свойства> - по пользовательскому свойству.
Направление сортировки ListSortOrder Указывается направление сортировки списка элементов медиагалереи:
  • По возрастанию (Asc);
  • По убыванию (Desc).
Показывать элементы подразделов раздела | ShowSubElements | [True|False] При отмеченной опции будут показаны все элементы подразделов раздела.
Выводить все элементы информационного блока, если не указан раздел | ShowAllElementsOnIndex | [True|False] При отмеченной опции будут отображены все элементы информационного блока, если не указан раздел.
Свойства | ListProperties | Указываются свойства инфоблока, которые будут отражены при показе списка элементов медиагалереи.
Настройки детального просмотра
Свойства | DetailProperties | Указываются свойства инфоблока, которые будут отражены при детальном просмотре элемента медиагалереи.
Установить ключевые слова страницы из свойства | PropertyKeywords | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова для страницы.
Установить описание страницы из свойства | PropertyDescription | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится детальное описание страницы.
Разрешить полноэкранный режим | PlayerEnableFullScreenModeSwitch | [True|False] При отмеченной опции в меню управления плеером будет выведена опция для перехода в полноэкранный режим.
Ширина проигрывателя | PlayerWidth | Указывается ширина проигрывателя в пикселях (px).
Высота проигрывателя | PlayerHeight | Указывается высота проигрывателя в пикселях (px).
Подстроить размер изображения/видео под размер проигрывателя PlayerStretching Задается способ изменения размера изображения/видео в соответствии с размером проигрывателя:
  • Нет (None);
  • Пропорционально (Proportionally);
  • Диспропорционально (Disproportionally);
  • Заполнение (Fill).
Отображать панель управления | PlayerShowControlPanel | [True|False] При отмеченной опции будет отображаться панель управления плеером. В этом случае необходимо настроить следующие параметры: PlayerControlPanelBackgroundColor, PlayerControlsColor, PlayerControlsOverColor.
Цвет фона панели управления | PlayerControlPanelBackgroundColor | Указывается код цвета фона панели управления плеера.
Цвет элементов управления | PlayerControlsColor | Указывается код цвета элементов управления плеера.
Цвет элементов управления при наведении указателя мыши | PlayerControlsOverColor | Указывается код цвета элементов управления плеера, который будет отображаться при наведении указателя мыши.
Цвет экрана | PlayerScreenColor | Указывается код цвета для экрана плеера.
Уровень громкости в процентах от максимального | PlayerVolumeLevelInPercents | Указывается уровень громкости звука в процентах от максимального заданного в системе.
Размер буфера в секундах | PlayerBufferLengthInSeconds | Указывается сколько секунд воспроизведения медиафайла сохранять в буфере обмена, прежде чем начать проигрывать. Рекомендуется для медленного трафика.
Автоматически начать проигрывать | PlayerEnableAutoStart | [True|False] При отмеченной опции проигрывание медиафайла будет начато сразу после загрузки страницы.
Повторять композицию | PlayerEnableRepeatMode | [True|False] При отмеченной опции проигрывание медиафайла будет повторяться.
Разрешить скачивание | PlayerEnableDownloading | [True|False] При отмеченной опции медиафайл можно будет скачать. При этом необходимо настроить параметр PlayerDownloadingLinkTargetWindow.
Открывать ссылку для скачивания в | PlayerDownloadingLinkTargetWindow | Указывается в каком окне браузера открывать ссылку для скачивания: в текущем окне браузера (_self) или в новом окне браузера (_blank).
Настройки TOP'а
Выводить топ элементов ShowTopElements [True|False] При отмеченной опции будет выведен TOP элементов медиагалереи.

Если TOP'а элементов отображен, то необходимо настроить следущие параметры: TopElementCount, TopSortBy, TopSortOrder, TopProperties.
Количество элементов на странице | TopElementCount | Указывается количество элементов медиагалереи, отображаемых на одной странице TOP’а.
Сортируем по полю TopSortBy Указывается поле, по которому будет производиться сортировка TOP’а элементов медиагалереи:
  • ID - по идентификатору элемента;
  • Name - по названию элемента;
  • ActiveFromDate - по дате начала активности;
  • ActiveToDate - по дате окончания активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения;
  • SOURCE - по источнику;
  • <название_свойства> - по пользовательскому свойству.
Направление сортировки TopSortOrder Указывается направление сортировки TOP’а элементов медиагалереи:
  • По возрастанию (Asc);
  • По убыванию (Desc).
Свойства | TopProperties | Указываются свойства инфоблока, которые будут отражены при показе TOP’а элементов медиагалереи.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение медиагалереи.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingAllowAll, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Разрешить просмотр всех страниц | PagingAllowAll | [True|False] При отмеченной опции будет разрешен просмотр всех страниц.
Количество записей на странице | PagingRecordsPerPage | Указывается количество записей, отображаемых на одной странице. Весь список записей будет выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Элемент медиагалереи

Компонент служит для отображения элемента медиагалереи. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="mediagallery_element_detail1"
 runat="server"
 componentname="bitrix:media.gallery.element.detail"
 template=".default"
 IBlockTypeId="22"
 IBlockId="28"
 ElementId="380"
 ElementCode=""
 PlayerEnableFullScreenModeSwitch="True"
 PlayerWidth="425px"
 PlayerHeight="344px"
 PlayerStretching="Proportionally"
 PlayerShowControlPanel="True"
 PlayerControlPanelBackgroundColor="FFFFFF"
 PlayerControlsColor="000000"
 PlayerControlsOverColor="000000"
 PlayerScreenColor="000000"
 PlayerVolumeLevelInPercents="90"
 PlayerBufferLengthInSeconds="10"
 PlayerEnableAutoStart="True"
 PlayerEnableRepeatMode="True"
 PlayerEnableDownloading="True"
 PlayerDownloadingLinkTargetWindow="_blank"
 IBlockElementPropertyForFilePath="MEDIA"
 IBlockElementPropertyForPlayerPreviewImageFilePath="PREVIEW"
 IBlockElementPropertyForDownloadingFilePath="-"
 Properties="'MEDIA';'PREVIEW'"
 PropertyKeywords="-"
 PropertyDescription="-"
 AddAdminPanelButtons="True"
 SetPageTitle="True"
 CacheMode="Auto"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Информационный блок | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока медиагалереи, элемент которого будет отображен.
ID элемента | ElementId | Указывается идентификатор элемента медиагалереи.
Символическое имя элемента | ElementCode | Указывается символьный код элемента медиагалереи, который будет отображен.
Внешний вид, общие настройки
Разрешить полноэкранный режим | PlayerEnableFullScreenModeSwitch | [True|False] При отмеченной опции в меню управления плеером будет выведена опция для перехода в полноэкранный режим.
Ширина проигрывателя | PlayerWidth | Указывается ширина проигрывателя в пикселях (px).
Высота проигрывателя | PlayerHeight | Указывается высота проигрывателя в пикселях (px).
Подстроить размер изображения/видео под размер проигрывателя PlayerStretching Задается способ изменения размера изображения/видео в соответствии с размером проигрывателя:
  • Нет (None);
  • Пропорционально (Proportionally);
  • Диспропорционально (Disproportionally);
  • Заполнение (Fill).
Отображать панель управления | PlayerShowControlPanel | [True|False] При отмеченной опции будет отображаться панель управления плеером. В этом случае необходимо настроить следующие параметры: PlayerControlPanelBackgroundColor, PlayerControlsColor, PlayerControlsOverColor.
Цвет фона панели управления | PlayerControlPanelBackgroundColor | Указывается код цвета фона панели управления плеера.
Цвет элементов управления | PlayerControlsColor | Указывается код цвета элементов управления плеера.
Цвет элементов управления при наведении указателя мыши | PlayerControlsOverColor | Указывается код цвета элементов управления плеера, который будет отображаться при наведении указателя мыши.
Цвет экрана | PlayerScreenColor | Указывается код цвета для экрана плеера.
Уровень громкости в процентах от максимального | PlayerVolumeLevelInPercents | Указывается уровень громкости звука в процентах от максимального заданного в системе.
Размер буфера в секундах | PlayerBufferLengthInSeconds | Указывается сколько секунд воспроизведения медиафайла сохранять в буфере обмена, прежде чем начать проигрывать. Рекомендуется для медленного трафика.
Автоматически начать проигрывать | PlayerEnableAutoStart | [True|False] При отмеченной опции проигрывание медиафайла будет начато сразу после загрузки страницы.
Повторять композицию | PlayerEnableRepeatMode | [True|False] При отмеченной опции проигрывание медиафайла будет повторяться.
Разрешить скачивание | PlayerEnableDownloading | [True|False] При отмеченной опции медиафайл можно будет скачать. При этом необходимо настроить параметры PlayerDownloadingLinkTargetWindow и IBlockElementPropertyForDownloadingFilePath.
Открывать ссылку для скачивания в | PlayerDownloadingLinkTargetWindow | Указывается в каком окне браузера открывать ссылку для скачивания: в текущем окне браузера (_self) или в новом окне браузера (_blank).
Источник данных
Свойство, содержащее URL файла для воспроизведения | IBlockElementPropertyForFilePath | Указывается свойство инфоблока, которое содержит URL файла для воспроизведения.
Свойство, содержащее URL изображения для предв. просмотра | IBlockElementPropertyForPlayerPreviewImageFilePath | Указывается свойство инфоблока, которое содержит URL изображения для предварительного просмотра.
Свойство, содержащее URL файла для скачивания | IBlockElementPropertyForDownloadingFilePath | Указывается свойство инфоблока, которое содержит URL файла для скачивания.
Дополнительные настройки
Выводить свойства | Properties | Указываются свойства инфоблока, которые должны быть отражены при показе медиаэлемента.
Установить ключевые слова страницы из свойства | PropertyKeywords | Ключевые слова страницы будут установлены из указанного свойства.
Установить описание страницы из свойства | PropertyDescription | Описание страницы будет установлено из указанного свойства.
Добавлять в админ. панель кнопки для данного компонента | AddAdminPanelButtons | [True|False] При отмеченной опции в административную панель будут добавлены кнопки для данного компонента.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установлено <название_медиаэлемента>.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Список элементов медиагалереи

Компонент служит для отображения списка элементов медиагалереи. Компонент стандартный и входит в дистрибутив модуля.

В поставку продукта входят два шаблона компонента: по умолчанию (.default) и список воспроизведения с проигрывателем (plusPlayer). Если используется шаблон plusPlayer, то над списком медиаэлементов будет отображен проигрыватель.

Пример вызова

<bx:IncludeComponent
 id="mediagallery_element_list1"
 runat="server"
 componentname="bitrix:media.gallery.element.list"
 template="plusPlayer"
 IBlockTypeId="22"
 IBlockId="28"
 SectionId="0"
 SectionCode=""
 IBlockElementPropertyForFilePath="MEDIA"
 IBlockElementPropertyForPlaylistPreviewImageFilePath="PREVIEW"
 IBlockElementPropertyForPlayerPreviewImageFilePath="PREVIEW"
 SortBy="ID"
 SortOrder="Desc"
 ShowSubElements="True"
 ShowAllElementsOnIndex="True"
 Properties="'MEDIA';'PREVIEW'"
 AddAdminPanelButtons="True"
 SetPageTitle="True"
 SectionElementListUrl="list.aspx?section_id=#SectionId#"
 ElementDetailUrl="detail.aspx?section_id=#SectionId#&element_id=#ElementId#"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingAllowAll="True"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingShowAll="<%$ Request:showall%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 PagingShowAllTemplate="?showall=y"
 CacheMode="Auto"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Информационный блок | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока медиагалереи, элемент которого будет отображен.
Раздел | SectionId | Указывается раздел медиагалереи, список элементов которого будет отображен.
Символический код раздела | SectionCode | Указывается символьный код раздела медиагалереи, список элементов которого будет отображен.
Источник данных
Свойство, содержащее URL файла для воспроизведения | IBlockElementPropertyForFilePath | Указывается свойство инфоблока, которое содержит URL файла для воспроизведения.
Свойство, содержащее URL изображения для предв. просмотра в списке | IBlockElementPropertyForPlaylistPreviewImageFilePath | Указывается свойство инфоблока, которое содержит URL изображения для предварительного просмотра.
Свойство, содержащее URL изображения для предв. просмотра в проигрывателе | IBlockElementPropertyForPlayerPreviewImageFilePath | Указывается свойство инфоблока, которое содержит URL изображения для предварительного просмотра в проигрывателе.
Сортируем по полю SortBy Указывается поле, по которому будет производиться сортировка списка элементов медиагалереи:
  • ID - по идентификатору элемента;
  • Name - по названию элемента;
  • ActiveFromDate - по дате начала активности;
  • ActiveToDate - по дате окончания активности;
  • Sort - по индексу сортировки;
  • UpdateDate - по дате последнего изменения;
  • SOURCE - по источнику;
  • <название_свойства> - по пользовательскому свойству.
Направление сортировки SortOrder Указывается направление сортировки списка элементов медиагалереи:
  • По возрастанию (Asc);
  • По убыванию (Desc).
Показывать элементы подразделов раздела | ShowSubElements | [True|False] При отмеченной опции будут показаны все элементы подразделов раздела.
Выводить все эл-ты инф. блока, если не указан раздел | ShowAllElementsOnIndex | [True|False] При отмеченной опции будут отображены все элементы информационного блока, если не указан раздел.
Дополнительные настройки
Свойства | Properties | Указываются свойства инфоблока, которые должны быть отражены при показе списка элементов медиагалереи.
Добавлять в админ. панель кнопки для данного компонента | AddAdminPanelButtons | [True|False] При отмеченной опции в административную панель будут добавлены кнопки для данного компонента.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установливаться при переходе к разделам медиагалереи - <название_раздела>, к детальному просмотру элемента медиагалереи - <название_элемента>.
Управление адресами страниц
Раздел | SectionElementListUrl | Указывается шаблон пути к странице раздела.
Детальная информация | ElementDetailUrl | Указывается шаблон пути к странице детельной информации элемента медиагалереи.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка элементов медиагалереи.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingAllowAll, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingShowAll, PagingIndexTemplate, PagingPageTemplate, PagingShowAllTemplate.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Разрешить просмотр всех страниц | PagingAllowAll | [True|False] При отмеченной опции будет разрешен просмотр всех страниц.
Количество записей на странице | PagingRecordsPerPage | Указывается количество элементов списка, отображаемых на одной странице. Весь список элементов будет выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ списка элементов медиагалереи. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Показать все элементы | PagingShowAll | Задется способ отображения всех элементов списка. Обычно задается в виде <%$ Request:showall%>, чтобы показ всех элементов выполнялся из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу со списком элементов медиагалереи.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам списка элементов медиагалереи.
Страница просмотра всех элементов | PagingShowAllTemplate | Задается шаблон пути к странице просмотра всех элементов списка элементов медиагалереи.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Медиа-проигрыватель

Компонент осуществляет проигрывание медиафайлов различных форматов. Компонент стандартный и входит в дистрибутив модуля.

Компонент поддерживает два режима настройки: простой и расширенный. Расширенный предоставляет более обширные средства настройки.

Простой режим:

Пример вызова

<bx:IncludeComponent
 id="mediaplayer1"
 runat="server"
 componentname="bitrix:media.player"
 template=".default"
 playertype="Auto"
 sourcefilepath="~/upload/mimo.flv"
 width="425"
 height="344"
 previewimagefilepath=""
 enableadvancedsettings="False"
 enableautostart="True"
 enablerepeatmode="True"
 volumelevelinpercents="90"
 logoimagefilepath=""
 enablefullscreenmodeswitch="True"
 stretching="Proportionally"
 controlpanelbackgroundcolor="FFFFFF"
 controlscolor="000000"
 controlsovercolor="000000"
 screencolor="000000"
 flvclientclickactionname="play"
 flvstartinmutemode="False"
 flvenablehighquality="True"
 flvskinfolderpath="~/bitrix/controls/main/media.player/flv/skins"
 flvskinname="default"
 flvcontrolbarlocation="bottom"
 flvwmode="opaque"
 flvhidecontextmenu="False"
 wmvshowcontrolpanel="True"
 wmvshowstopbutton="False"
 wmvshowdigits="False"
 wmvwmode="windowless"
 bufferlengthinseconds="10"
 enabledownloading="True"
 linkfordownloadsourcefileurl="http//:www.1c-bitrix.ru/upload/mimo.flv"
 linkfordownloadsourcefiletargetwindow="_blank"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип проигрывателя playertype Указывается тип проигрывателя:
  • Определить автоматически (Auto) - если необходимо проигрывать файлы разных форматов;
  • Adobe Flash Player (Flv) - Flash плеер;
  • Windows Media Player (Wmv) - WMV плеер. Для работы WMV плеера необходимо установить Microsoft Silverlight.
Путь к файлу | sourcefilepath | Указывается путь к медиафайлу, котороый будет воспроизводиться.
Ширина | width | Указывается ширина проигрывателя в пикселях (px).
Высота | height | Указывается высота проигрывателя в пикселях (px).
Расширенный режим настройки компонента | enableadvancedsettings | [True|False] При отмеченной опции открывается полный набор настроек компонента. Опция предназначена для опытных пользователей. Позволяет расширенно настроить компонент. Для простого режима эту опцию нужно отключить.
Настройки воспроизведения
Автоматически начать проигрывать | enableautostart | [True|False] При отмеченной опции проигрывание медиафайла будет начато сразу после загрузки страницы.
Повторять композицию | enablerepeatmode | [True|False] При отмеченной опции проигрывание медиафайла будет повторяться.
Уровень громкости в процентах от максимального | volumelevelinpercents | Указывается уровень громкости звука в процентах от максимального заданного в системе.
Дополнительные настройки
Разрешить скачивание | enabledownloading | [True|False] При отмеченной опции медиафайл можно будет скачать. При этом необходимо настроить параметры linkfordownloadsourcefileurl и linkfordownloadsourcefiletargetwindow.
Ссылка для скачивания ролика | linkfordownloadsourcefileurl | Указывается прямая ссылка для скачивания медиафайла.
Открывать ссылку в | linkfordownloadsourcefiletargetwindow | Указывается в каком окне браузера открывать ссылку для скачивания: в текущем окне браузера (_self) или в новом окне браузера (_blank).

Расширенный режим:

Пример вызова

<bx:IncludeComponent
 id="mediaplayer1"
 runat="server"
 componentname="bitrix:media.player"
 template=".default"
 playertype="Auto"
 sourcefilepath="~/upload/mimo.flv"
 width="425"
 height="344"
 previewimagefilepath="~/images/mimo_preview.png"
 enableadvancedsettings="True"
 enableautostart="True"
 enablerepeatmode="True"
 volumelevelinpercents="90"
 logoimagefilepath="~/images/mimo_logo.png"
 enablefullscreenmodeswitch="True"
 stretching="Proportionally"
 controlpanelbackgroundcolor="FFFFFF"
 controlscolor="000000"
 controlsovercolor="000000"
 screencolor="000000"
 flvclientclickactionname="play"
 flvstartinmutemode="False"
 flvenablehighquality="True"
 flvskinfolderpath="~/bitrix/controls/main/media.player/flv/skins"
 flvskinname="default"
 flvcontrolbarlocation="bottom"
 flvwmode="opaque"
 flvhidecontextmenu="False"
 wmvshowcontrolpanel="True"
 wmvshowstopbutton="True"
 wmvshowdigits="True"
 wmvwmode="windowless"
 bufferlengthinseconds="10"
 enabledownloading="True"
 linkfordownloadsourcefileurl="http//:www.1c-bitrix.ru/upload/mimo.flv"
 linkfordownloadsourcefiletargetwindow="_blank"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип проигрывателя playertype Указывается тип проигрывателя:
  • Определить автоматически (Auto) - если необходимо проигрывать файлы разных форматов;
  • Adobe Flash Player (Flv) - Flash плеер;
  • Windows Media Player (Wmv) - WMV плеер. Для работы WMV плеера необходимо установить Microsoft Silverlight.
Путь к файлу | sourcefilepath | Указывается путь к медиафайлу, котороый будет воспроизводиться.
Ширина | width | Указывается ширина проигрывателя в пикселях (px).
Высота | height | Указывается высота проигрывателя в пикселях (px).
Путь к рисунку для предварительного просмотра | previewimagefilepath | Задается путь к рисунку для предварительного просмотра. Можно задать полный путь к файлу от корня сайта либо только имя файла, если он расположен в текущей директории.
Расширенный режим настройки компонента | enableadvancedsettings | [True|False] При отмеченной опции открывается полный набор настроек компонента. Опция предназначена для опытных пользователей. Позволяет расширенно настроить компонент.
Настройки воспроизведения
Автоматически начать проигрывать | enableautostart | [True|False] При отмеченной опции проигрывание медиафайла будет начато сразу после загрузки страницы.
Повторять композицию | enablerepeatmode | [True|False] При отмеченной опции проигрывание медиафайла будет повторяться.
Уровень громкости в процентах от максимального | volumelevelinpercents | Указывается уровень громкости звука в процентах от максимального заданного в системе.
Внешний вид, общие настройки
Путь к изображению авторского знака | logoimagefilepath | Задается путь к изображению авторского знака. Можно задать полный путь к файлу от корня сайта либо только имя файла, если он расположен в текущей директории.
Разрешить полноэкранный режим | enablefullscreenmodeswitch | [True|False] При отмеченной опции в меню управления плеером будет выведена опция для перехода в полноэкранный режим.
Подстроить размер изображения/видео под размер проигрывателя stretching Задается способ изменения размера изображения/видео в соответствии с размером проигрывателя:
  • Нет (None);
  • Пропорционально (Proportionally);
  • Диспропорционально (Disproportionally);
  • Заполнение (Fill).
Цвет фона панели управления | controlpanelbackgroundcolor | Указывается код цвета фона панели управления плеера.
Цвет элементов управления | controlscolor | Указывается код цвета элементов управления плеера.
Цвет элементов управления при наведении указателя мыши | controlsovercolor | Указывается код цвета элементов управления плеера, который будет отображаться при наведении указателя мыши.
Цвет экрана | screencolor | Указывается код цвета для экрана плеера.
Дополнительные настройки воспроизведения "Adobe Flash Player"
Действие при клике по экрану flvclientclickactionname Указывается действие, которое будет выполнено при клике по экрану:
  • Начать проигрывать (play) - при клике начнется проигрывание файла;
  • Перейти по ссылке (link) - при клике будет осуществлен переход по ссылке, указанной в параметре Ссылка для скачивания ролика (linkfordownloadsourcefileurl);
  • Раскрыть на полный экран (fullscreen) - при клике окно плеера будет развернуто на полный экран;
  • Отсутствует (none) - при клике по экрану действие отсуствует;
  • Выключить звук (mute) - по клику на экран будет выключен звук.
Отключать звук при старте | flvstartinmutemode | [True|False] При отмеченной опции звук не будет воспроизводиться, включить его можно будет вручную в панели управления плеера.
Высококачественное проигрывание | flvenablehighquality | [True|False] При отмеченной опции качество воспроизведения будет максимальным.
Внешний вид "Adobe Flash Player"
Путь к папке со скинами | flvskinfolderpath | Указывается путь к папке со скинами Flash плеера. Пользовательские скины должны храниться в директории, не затрагиваемой системой обновлений.
Скин | flvskinname | Указывается скин Flash плеера. Стандартный скин Flash плеера (default) доступен в любом случае.
Расположение панели управления flvcontrolbarlocation Указывается расположение панели управления плеера:
  • Внизу (bottom) - снизу окна просмотра;
  • Поверх (over) - всплывает поверх окна просмотра;
  • Не показывать (none) - панель управления будет скрыта.
Режим окна (WMode) flvwmode Указывается режим окна Flash плеера:
  • Обычный (с собственным окном) (window) - медиафайл будет проигрываться на странице в собственном прямоугольном окне. Этот вариант дает наибольший выигрыш в скорости воспроизведения анимации;
  • Непрозрачный (opaque) - медиафайл будет помещен на задний план страницы.
  • Прозрачный (transparent) - фон страницы будет "проглядывать" через все прозрачные места медиафайла при проигрывании. Этот вариант может замедлить скорость воспроизведения анимации.
Скрыть контекстное меню плеера | flvhidecontextmenu | [True|False] При отмеченной опции контекстное меню плеера будет скрыто.
Внешний вид "Windows Media Player"
Показывать панель управления | wmvshowcontrolpanel | [True|False] При отмеченной опции будет отображаться панель управления плеером.
Показывать кнопку остановки ролика | wmvshowstopbutton | [True|False] При отмеченной опции в панели управления плеера будет выведена кнопка Стоп.
Показывать текущее время воспроизведения и оставшееся время | wmvshowdigits | [True|False] При отмеченной опции будет показано текущее и оставшееся время воспроизведения медиафайла.
Режим окна wmvwmode Указывается режим окна Wmv плеера:
  • C собственным окном (window) - окно плеера будет убрано за элементы страницы;
  • Без собственного окна (windowless) - окно плеера будет отображаться непосредственно в клиентской области обозревателя или внутри специально созданного окна.
Дополнительные настройки
Размер буфера в секундах | bufferlengthinseconds | Указывается сколько секунд воспроизведения ролика сохранять в буфере обмена, прежде чем начать проигрывать. Рекомендуется для медленного трафика.
Разрешить скачивание | enabledownloading | [True|False] При отмеченной опции медиафайл можно будет скачать. При этом необходимо настроить параметры linkfordownloadsourcefileurl и linkfordownloadsourcefiletargetwindow.
Ссылка для скачивания ролика | linkfordownloadsourcefileurl | Указывается прямая ссылка для скачивания медиафайла.
Открывать ссылку в | linkfordownloadsourcefiletargetwindow | Указывается в каком окне браузера открывать ссылку для скачивания: в текущем окне браузера (_self) или в новом окне браузера (_blank).


Фотогалерея

  • Фотогалерея


Фотогалерея

Компонент позволяет получить полнофункциональную фотогалерею, создавая физически только одну страницу. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="photogallery1"
 runat="server"
 componentname="bitrix:photogallery"
 template=".default"
 IBlockTypeId="19"
 IBlockId="23"
 EnableSEF="True"
 SEFFolder="/test/"
 SEF_Album="/album/#ALBUMID#/"
 SEF_AlbumEdit="/album/edit/#ALBUMID#"
 SEF_AlbumAdd="/album/#PARENTID#/Add"
 SEF_Upload="/album/upload/#ALBUMID#"
 SEF_AlbumPage="/album/#ALBUMID#/#PAGEID#"
 SEF_AlbumShowAll="/album/#ALBUMID#/all"
 SEF_PhotoEdit="/photo/edit/#PHOTOID#"
 SEF_Photo="/photo/#PHOTOID#"
 ParamAlbum="album"
 ParamAlbumPage="page"
 ParamAlbumShowAll="showall"
 ParamAlbumEdit="AlbumEdit"
 ParamAlbumAdd="AlbumAdd"
 ParamPhoto="photo"
 ParamPhotoEdit="PhotoEdit"
 ParamSearch="SEARCH"
 ParamAlbumUpload="Upload"
 DisplaySearchResults="True"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingAllowAll="True"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 CoverWidth="75"
 CoverHeight="75"
 PreviewWidth="150"
 PreviewHeight="150"
 PhotoWidth="150"
 PhotoHeight="150"
 FlickrMode="True"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока, фотографии которого будут выводиться.
Управление адресами страниц
Включить поддержку ЧПУ EnableSEF [True|False] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить следущие параметры: SEFFolder, Sef_<имя>.

Если режим поддержки ЧПУ выключен, то необходимо настроить следущие параметры: Param<имя>.
Каталог ЧПУ (относительно корня сайта) | SEFFolder | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
<страница> Sef_<имя> Указываются адреса следующих страниц:
  • SEF_Album - страница просмотра альбома;
  • SEF_AlbumEdit - страница редактирования альбома;
  • SEF_AlbumAdd - страница создания альбома;
  • SEF_Upload - страница загрузки фотографий;
  • SEF_AlbumPage - страница альбома;
  • SEF_AlbumShowAll - страница альбома без страниц;
  • SEF_PhotoEdit - страница редактирования фотографии;
  • SEF_Photo - страница просмотр фотографии.
Переменная <имя> Param<имя> Указываются следующие переменных:
  • ParamAlbum - Альбом;
  • ParamAlbumPage - Страница альбома;
  • ParamAlbumShowAll - Показать весь альбом;
  • ParamAlbumEdit - Альбом(редактирование);
  • ParamAlbumAdd - Альбом(создание);
  • ParamPhoto - Фотография;
  • ParamPhotoEdit - Фотография(редактирование);
  • ParamSearch - Поиск;
  • ParamAlbumUpload - Загрузка фотографий.
Настройки поиска
Использовать для отображения результатов поиска | DisplaySearchResults | [True|False] При отмеченной опции компонент будет формировать ссылки на сообщения, найденные в результате поиска по фотогалерее.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение фотогалереи.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingAllow, PagingMode, PagingTemplate, PagingShowOne, PagingAllowAll, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Разрешить просмотр всех страниц | PagingAllowAll | [True|False] При отмеченной опции будет разрешен просмотр всех страниц.
Количество записей на странице | PagingRecordsPerPage | Указывается количество фотографий, отображаемых на одной странице. Все фотографии будут отображены с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Настройки фотогалереи
Ширина картинки-анонса фотоальбома (px) | CoverWidth | Указывается ширина картинки-анонса фотоальбома в пикселях (px).
Высота картинки-анонса фотоальбома (px) | CoverHeight | Указывается высота картинки-анонса фотоальбома в пикселях (px).
Ширина фотографии-анонса (px) | PreviewWidth | Указывается ширина фотографии-анонса в пикселях (px).
Высота фотографии-анонса (px) | PreviewHeight | Указывается высота фотографии-анонса в пикселях (px).
Ширина детальной фотографии (px) | PhotoWidth | Указывается ширина детальной фотографии в пикселях (px).
Высота детальной фотографии (px) | PhotoHeight | Указывается высота детальной фотографии в пикселях (px).
Режим жесткого кадрирования | FlickrMode | [True|False] При отмеченной опции изображения будут откадрированы под заданный размер.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Показ новостей из RSS

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

RSS

  • RSS инфоблока
  • Показ новостей из RSS


RSS инфоблока

Компонент выводит RSS информационного блока в заданном формате. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="iblockrss1"
 runat="server"
 componentname="bitrix:iblock.rss"
 template=".default"
 IBlockTypeId="18"
 IBlockId="24"
 IBlockSectionId="118"
 IncludeSubsections="True"
 FiltrationByActivity="NotActive"
 ItemQuantity="10"
 FeedTitle=""
 FeedDescription=""
 FeedItemTitleSourceField="Name"
 FeedItemCategoryBuildMode="IBlockSections"
 FeedItemDescriptionBuildMode="MultipleField"
 FeedItemDescriptionSourceField="Name"
 FeedItemDescriptionTemplate="<div>#Name#</div><div>#PreviewText#</div>"
 FeedUrlTemplate="/news-list.aspx"
 FeedItemUrlTemplate="/news-detail.aspx?item=#ElementId#"
 FeedItemSortMode="ID"
 FeedTtl="60"
 NoCData="False"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Тип информационного блока | IBlockTypeId | Указывается один из созданных в системе типов информационного блока.
Информационный блок | IBlockId | Для выбранного типа инфоблока указывается идентификатор информационного блока, RSS которого будет отображено в задданом формате.
Идентификатор раздела | IBlockSectionId | Указывается идентификатор раздела (числовой код) информационного блока, из элементов которого будет формироваться RSS лента.
Включать элементы из дочерних секций | IncludeSubsections | [True|False] При отмеченной опции в RSS ленту будут включены элементы из дочерних секций.
Фильтрация по активности FiltrationByActivity Указывается какие элементы инфоблока будут добавлены в RSS ленту:
  • отсутствует (None);
  • только активные (Active);
  • только неактивные (NotActive).
Количество элементов для экспорта | ItemQuantity | Указывается количество элементов RSS ленты для экспорта.
Настройки RSS
Заголовок канала | FeedTitle | Указывается заголовок канала.
Описание канала | FeedDescription | Задается произволное описание канала.
Поле заголовка сообщения FeedItemTitleSourceField Указывается поле, которое будет отображено в качестве заголовка сообщения:
  • Название элемента (Name);
  • Текст анонса (PreviewText);
  • Подробный текст (DetailText);
  • Текст анонса или подробный текст (PreviewTextOrDetailText/);
  • Подробный текст или текст анонса (DetailTextOrPreviewText);
  • Источник (SOURCE).
Категории сообщения FeedItemCategoryBuildMode Указывается способ формирования категории сообщений RSS:
  • не определять (None) - сообщения не будут группироваться по категориям;
  • составлять из разделов (IBlockSections) - категории сообщений будут сформированы с использованием названий разделов инфоблока;
  • составлять из тегов (Tags) - категории сообщений будут сформированы с использованием тегов элементов инфоблока.
Описание сообщения FeedItemDescriptionBuildMode Задается способ формирования описания сообщения:
  • брать из поля (SingleField) - описание сообщения будет взято из поля, указанному в параметре FeedItemDescriptionSourceField;
  • составлять из полей (MultipleField) - описание сообщения будет составлено из полей, указанных в параметре FeedItemDescriptionTemplate.
Поле описания сообщения FeedItemDescriptionSourceField Указывается поле, которое будет отображено в качестве описания сообщения:
  • Название элемента (Name);
  • Текст анонса (PreviewText);
  • Подробный текст (DetailText);
  • Текст анонса или подробный текст (PreviewTextOrDetailText/);
  • Подробный текст или текст анонса (DetailTextOrPreviewText);
  • Источник (SOURCE).
Шаблон описания сообщения | FeedItemDescriptionTemplate | Указывается шаблон описания сообщения (например, <div>#Name#</div><div>#PreviewText#</div>).
Шаблон ссылки на канал | FeedUrlTemplate | Указывается шаблон ссылки на RSS канал.
Шаблон ссылки на элемент | FeedItemUrlTemplate | Указывается шаблон ссылки на элемент RSS ленты.
Упорядочивать сообщения FeedItemSortMode Сообщения RSS ленты будут упорядочены:
  • по ID элемента (ID);
  • по дате создания (DateOfCreation);
  • по дате модификации (DateOfModification);
  • по дате начала активности (DateOfActivationStart).
Время жизни (в минутах) | FeedTtl | Указывается время жизни RSS ленты в минутах.
Дополнительные настройки
Не использовать CDATA | NoCData | [True|False] При отмеченной опции не будут использоваться конструкции вида <![CDATA[текст]]>.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Показ новостей из RSS

Компонент предназначен для показа RSS новостей с другого сайта в заданном формате. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="rssshow1"
 runat="server"
 componentname="bitrix:rss.show"
 template=".default"
 RssURL="http://www.1c-bitrix.ru/rss.php"
 ElementsCount="20"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
URL на RSS | RssURL | Указывается адрес сайта, с которого будет осуществляться загрузка новостей.
Количество элементов для показа | ElementsCount | Параметр определяет количество новостей для показа.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Сервисы

  • Блоги
  • Реклама, баннеры
  • Форум


Описание модуля

Модуль Блоги предоставляет следующие возможности:

  • создавать неограниченное число блогов;
  • управлять правами доступа к блогам;
  • создавать черновик сообщения;
  • создавать древовидные комментарии;
  • присоединять изображения к сообщениям.

Модуль включает в себя следующие компоненты:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Блог (комплексный компонент) | blog | Создает полноценный публичный интерфейс блогов.
Список категорий блогов | blog.category.list | Выводит список категорий блогов.
Список комментариев блогов | blog.comments | Выводит список комментариев всех блогов.
Создание/редактирование блога | blog.edit | Служит для создания нового блога либо изменения параметров и настроек уже существующего блога.
Список блогов | blog.list | Выводит список блогов.
Меню блога | blog.menu | Выводит ссылки на различные страницы блога.
Сервис MetaWeblog | blog.metaWeblog | Обеспечивает публикацию в блоги из клиентских программ, поддерживающих MetaWeblog API.
Запись блога | blog.post | Показывает запись в блоге.
Комментарии к записи | blog.post.comments | Показывает комментарии к записи в блоге.
Создание записи | blog.post.form | Предназначен для создания новой или редактирования уже существющующей записи в блоге.
Список записей блога | blog.post.list | Выводит список записей блога.
Список записей блогов текущего сайта | blog.posts | Выводит список записей блога текущего сайта.
RSS блога | blog.rss | Ввыводит RSS блога в заданном формате.


Список блогов

В этом разделе

  • Фильтр
  • Контекстная панель
  • Список блогов
    •

    На странице Список блогов (Сервисы > Блоги > Список блогов) представлена таблица со списком блогов. Она служит для добавления новых блогов, а также для перехода к управлению параметрами уже существующих блогов.

    Фильтр

    С помощью формы выполнется поиск блогов в соответствии с указанными условиями.

    Параметр | Описание
Название блога | Название блога.
Активность | Поиск можно задать по активным, неактивным или всем блогам.
ID | Поиск по идентификатору блога.
Сортировка | Поиск по индексу сортировки блога.
Адрес | Путь к блогу для данного сайта.
Внешний ключ | Ключ, который может использовать для связи с внешними источниками.
Индексация для поиска | Поиск блогов по способу индексации сообщений блога.

    Для того чтобы отобрать блоги по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех блогов нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Новый блог | Переход к форме создания нового блога.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список блогов

    Поле | Описание
    Колонка флажков | Поле для выбора блогов, к которым предполагается применить какое-либо правило или действие.
    Действия Действия над блогом:
    • Изменить блог - переход к форме редактирования блога;
    • Удалить блог - удаление блога.
    ID | Идентификатор блога.
    Название | Указывается имя пользователя блога.
    Создан | Дата создания блога.
    Обновлён | Дата последнего обновления блога.
    Активность | Признак активности блога. Если блог неактивен, то он не может быть использован.
    Владелец | Пользователь, который является владельцем блога.
    Путь | Название блога латницей, которое используется при указании пути к блогу.
    Категории | Название категории, к которой привязан блог.
    Индексация | Способ индексации сообщений блога.


Создание и редактирование блога

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Закладка "Основные параметры"
  • Закладка "Зеркалирование"
    •
  • Кнопки управления
    •

    Форма служит для создания нового или редактирования существующего блога. Каждый пользователь может завести только один блог.

    Контекстная панель

    Кнопка | Описание
Список блогов | Переход на страницу co списком блогов.
Добавить | Переход к форме создания нового блога. Кнопка отображается при редактировании существующего блога.
Удалить | Удаление редактируемого блога. Кнопка отображается при редактировании существующего блога.

    Форма редактирования

    Закладка "Основные параметры"

    Поле | Описание
    ID | Уникальный идентификатор блога. Отображается при редактировании существующего блога.
    Активность | Признак активности блога.
    *Владелец | Указывается пользователь (логин пользователя), который является владельцем блога.
    *Название | Название блога.
    *Адрес блога | Адрес блога (допускаются буквы латинского алфавита, цифры и дефис).
    Описание | Поле для ввода описания к блогу.
    Категории | Название категории, к которой относится блог.
    Уведомлять о новых комментариях | Отправка извещения о создании комментариев на e-mail владельца блога.
    Сортировка | Относительный "вес", определяющий положение блога в списке. Чем меньше значение, тем выше в списке показывается блог.
    Внешний ключ | Ключ, который может использовать для связи с внешними источниками.
    Индексировать посты для поиска Указывается способ индексации сообщений блога:
    • Не индексировать;
    • Полностью;
    • Только теги.

    * - поля, обязательные для заполнения.

    Закладка "Зеркалирование"

    Поле | Описание
Включить зеркалирование | При отмеченной опции блог будет "зеркалироваться".
Адрес RSS-потока основного блога | Указывается адрес RSS-потока основного блога.
Обновлять сообщения | При отмеченной опции сообщения блога будут обновляться.
Перенаправлять на комментарии основного блога | При отмеченной опции будет осуществляться перенаправление на комментарии основного блога.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Переход на страницу со списком блогов.
Применить | Применение внесённых изменений. Продолжение редактирования параметров блога.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Категории блогов

В этом разделе

  • Фильтр
  • Контекстная панель
  • Список групп блогов

    • На странице Категории блогов (Сервисы > Блоги > Категории блогов) представлена таблица, содержащая список категорий блогов. Она служит для добавления новых категорий, а также для перехода к редактированию существующих.

    Фильтр

    Параметр | Описание
Название категории | Поиск категории блогов, в которых встречается указанное название полностью или частично.
ID | Идентификатор категории.
Сортировка | Относительный "вес" категории.
Внешний ключ | Ключ, который может использовать для связи с внешними источниками.

    Чтобы отобрать категорию по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех категорий блогов нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Новая категория блогов | Переход к форме создания новой категории блогов.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.

    Список категорий блогов

    Поле | Описание
    Колонка флажков | Выбор категории блогов, к которой предполагается применить какое-либо правило или действие.
    Действия Действия над категорией:
    • Изменить категорию - переход к форме редактирования категории блогов;
    • Удалить категорию - удаление категории блогов.
    ID | Идентификатор категории.
    Название | Название категории.
    Сайт | Привязка категории блогов к указанному сайту.
    Сортировка | Относительный "вес", определяющий положение категории в списке. Чем меньше значение, тем выше в списке показывается категория.


Создание и редактирование категории блогов

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Категория блогов
    •
  • Кнопки управления

    • Контекстная панель

    Кнопка | Описание
Список категорий блогов | Переход на страницу со списком категорий блогов.
Добавить | Переход к форме создания новой категории блогов. Кнопка отображается при редактировании существующей категории.
Удалить | Удаление редактируемой категории блогов. Кнопка отображается при редактировании существующей категории.

    Форма редактирования

    Закладка "Категория блогов"

    Поле | Описание
ID | Уникальный идентификатор категории блогов (не редактируется).
*Название | Название категории блогов.
Сайты | Сайт, на котором будут доступны блоги даннной категории.
Сортировка | Относительный "вес", определяющий положение категории в списке. Чем меньше значение, тем выше в списке показывается категория.
Внешний ключ | Ключ, который может использовать для связи с внешними источниками.

    * - Поля, обязательные для заполнения.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Переход на страницу со списком категорий блогов.
Применить | Применение внесённых изменений. Продолжение редактирования параметров категории блогов.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Настройки модуля

Форма настроек модуля Блоги (Настройки > Настройки продукта > Настройки модулей > Блоги) предназначена для задания глобальных параметров модуля.

Закладка "Настройка параметров модуля"

Поле | Описание
Интервал между обновлениями содержания блогов-"зеркал", мин | Указывается интервал времени в минутах между обновлениями содержания блогов-"зеркал".

Кнопки управления

Кнопка | Описание
Сохранить | Сохранение внесённых изменений.
Применить | Сохранение внесённых изменений. Продолжение редактирования параметров.
По умолчанию | Установка значений параметров модуля равными значениям по умолчанию.


Пользовательские поля

На странице Пользовательские поля (Сервисы > Блоги > Пользовательские поля) можно добавлять новые, просматривать и изменять существующие, удалять ненужные пользовательскте поля блогов. Вывод значений пользовательских полей блогов в публичной части производится с помощью API продукта.

Форма поиска

Поиск пользовательских полей блогов в соответствии с указанными условиями.

Поле | Описание
Найти | Позволяет найти пользовательские поля по их основным параметрам: идентификатору или объекту. Это поле присутствует, даже если фильтр свернут.
ID | Поиск поля по ID записи.
Название поля | Поиск поля можно задать по названию.
Тип данных | Поиск поля можно задать по типу данных.
XML_ID | Поиск можно задать по внешнему идентификатору XML_ID.
Множественное | Поиск по признаку, является ли поле множественным, т.е. можно ли задать несколько значений одного поля.
Обязательное | Поиск по признаку, является ли поле обязательным для заполнения.
Фильтр | Способ отображения поля в фильтре.
Показывать в списке | Поиск по признаку, показывать ли данное поле в списке по месту применения.
Разрешать редактирование | Поиск по признаку, можно ли редактировать данное поле пользователем.
Участвует в поиске | Поиск по признаку, участвуют ли значения поля в поиске.

Чтобы отобрать пользовательские поля по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех пользовательских полей нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить для сообщения/блога | Переход к форме добавления пользовательского поля.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

Список пользовательских полей

Поле | Описание
Колонка флажков | Поле предназначено для выбора пользовательских полей, к которым предполагается применить какое-либо правило или действие.
Действия Операции, которые можно произвести над пользовательских полей:
  • Редактировать - переход к форме редактирования параметров поля;
  • Удалить - удаление поля.
ID | Уникальный идентификатор пользовательского поля.
Название поля | Код поля. Можно задать только для нового поля. Задается только латинскими буквами.
Тип данных | Один из доступных типов данных.
Сорт. | Индекс сортировки, определяющий положение поля в общем списке.
XML_ID | Внешний XML идентификатор поля.
Множественное | Признак множественности поля.
Обязательное | Признак обязательности поля для заполнения.
Фильтр | Выводится способ отображения поля в фильтре.
Показывать в списке | Параметр определяет показывать поля в списке дополнительных полей той или иной формы или нет.
Разрешать редактирование | Параметр определяет разрешать редактирование поля или нет.
Участвует в поиске | Признак участия значений поля в поиске в публичной части сайта.


Сервис MetaWeblog

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты

  • RSS блога
  • Блог (комплексный компонент)
  • Запись блога
  • Комментарии к записи
  • Меню блога
  • Сервис MetaWeblog
  • Создание записи
  • Создание/редактирование блога
  • Список блогов
  • Список записей блога
  • Список записей блогов текущего сайта
  • Список категорий блогов
  • Список комментариев блогов


Блог (комплексный компонент)

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Блог (комплексный компонент)

Комплексный компонент создает полноценный публичный интерфейс блогов. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="blog2"
 runat="server"
 componentname="bitrix:blog"
 template=".default"
 ColorCss="~/bitrix/components/bitrix/blog/templates/.default/themes/default/style.css"
 AllowToAjustBlogGroups="True"
 ObligatoryBlogGroups=""
 MaxBlogGroups="1"
 AvailableBlogGroups="'1'"
 SlugIgnoreList="admin;blog;blogs;users;user;search;posts;rss;tags;new"
 MinSlugLength="3"
 MaxSlugLength="10"
 AvailableBlogCustomFieldsForAuthor=""
 AvailableBlogCustomFieldsForModerator=""
 AvailablePostCustomFieldsForAuthor="'WEF'"
 AvailablePostCustomFieldsForModerator="'WEF'"
 SetPageTitle="True"
 DisplayMenu="True"
 DisplaySidebar="True"
 MaxWordLength="15"
 PeriodDays="30"
 PostsPerPage="10"
 BlogsPerPage="20"
 CommentsPerPage="30"
 MainPagePostCount="6"
 MainPageBlogCount="6"
 AllowMetaWeblogApi="True"
 GuestEmail="required"
 GuestCaptcha="True"
 MaximalFileSizeInKBytes="1024"
 MaximalAllFilesSizeInKBytes="8192"
 MaximalImageWidthInPixels="0"
 MaximalImageHeightInPixels="0"
 UserProfileUrl=""
 UserProfileEditUrl=""
 EnableSEF="True"
 SEFFolder="/"
 BlogVariable="blog"
 CategoryVariable="category"
 CommentVariable="comment"
 PostVariable="post"
 ActionVariable="act"
 PageVariable="page"
 UserVariable="user"
 TagsVariable="tags"
 NewPostTemplate="/#BlogSlug#/new/"
 PostListTemplate="/#BlogSlug#/"
 PostListPageTemplate="/#BlogSlug#/?page=#PageId#"
 DraftPostListTemplate="/#BlogSlug#/draft/"
 DraftPostListPageTemplate="/#BlogSlug#/draft/?page=#PageId#"
 PostTemplate="/#BlogSlug#/#PostId#/"
 PostPageTemplate="/#BlogSlug#/#PostId#/?page=#PageId###comments"
 PostEditTemplate="/#BlogSlug#/#PostId#/edit/"
 CommentReadTemplate="/#BlogSlug#/#PostId#/#CommentId#/##comment#CommentId#"
 CommentEditTemplate="/#BlogSlug#/#PostId#/#CommentId#/edit/"
 UserProfileTemplate="/users/#UserId#/"
 UserProfileEditTemplate="/users/#UserId#/edit/"
 NewBlogTemplate="/new/"
 BlogEditTemplate="/#BlogSlug#/edit/"
 BlogListTemplate="/blogs/"
 BlogListPageTemplate="/blogs/?page=#PageId#"
 CategoryBlogListTemplate="/blogs/#CategoryId#/"
 CategoryBlogListPageTemplate="/blogs/#CategoryId#/?page=#PageId#"
 NewPostListTemplate="/posts/"
 NewPostListPageTemplate="/posts/?page=#PageId#"
 PopularPostListTemplate="/posts/popular/"
 PopularPostListPageTemplate="/posts/popular/?page=#PageId#"
 DiscussPostListTemplate="/posts/discuss/"
 DiscussPostListPageTemplate="/posts/discuss/?page=#PageId#"
 SearchTagsTemplate="/posts/search/?tags=#SearchTags#"
 SearchTagsPageTemplate="/posts/search/?tags=#SearchTags#&page=#PageId#"
 SearchBlogTagsTemplate="/#BlogSlug#/search/?tags=#SearchTags#"
 SearchBlogTagsPageTemplate="/#BlogSlug#/search/?tags=#SearchTags#&page=#PageId#"
 BlogMetaWeblogApiTemplate="/#BlogSlug#/metaweblog/"
 RssAllPostsTemplate="/rss/"
 RssBlogPostsTemplate="/#BlogSlug#/rss/"
 RssBlogPostCommentsTemplate="/#BlogSlug#/#PostId#/rss/"
 DisplaySearchResults="True"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate="customizable"
 PagingShowOne="True"
 PagingTitle="Страницы:"
 PagingPosition="both"
 PagingMaxPages="5"
 PagingMinRecordsInverse="1"
 CacheMode="Auto"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Цветовая схема (или путь к CSS-файлу цветовой схемы) ColorCss Указывается цветовая схема блога:
  • Синяя;
  • Зеленая;
  • Оранжевая;
  • Красная;
  • Красная облегченная.
Выбрав пункт другое->, можно задать путь к CSS-файлу цветовой схемы оформления.
Разрешить выбор групп AllowToAjustBlogGroups [True|False] При отмеченной опции будет разрешен выбор групп, к которым может быть привязан блог.

Если опция отмечена, то необходимо настроить следущие параметры: MaxBlogGroups и AvailableBlogGroups.

Если опция не отмечена, то необходимо настроить следущие параметры: ObligatoryBlogGroups.
Максимальное количество групп, к которым может быть привязан блог | MaxBlogGroups | Указывается максимальное количество групп, к которым может быть привязан блог.
Доступные группы, к которым может быть привязан блог | AvailableBlogGroups | Указываются доступные группы, к которым может быть привязан блог.
Привязать к группам | ObligatoryBlogGroups | Указываются группы, к которым будет привязан блог.
Запрещенные адреса блогов через точку с запятой | SlugIgnoreList | Задаются запрещенные адреса блогов (через точку с запятой). Нпример: admin;blog;blogs и т.д.
Минимальная длина адреса блога | MinSlugLength | Указывается минимальная длина адреса блога.
Максимальная длина адреса блога | MaxSlugLength | Указывается максимальная длина адреса блога.
Пользовательские поля
Поля блогов доступные автору | AvailableBlogCustomFieldsForAuthor | Указываются пользовательские поля блогов, доступные автору.
Поля блогов доступные модератору | AvailableBlogCustomFieldsForModerator | Указываются пользовательские поля блогов, доступные модератору.
Поля сообщений доступные автору | AvailablePostCustomFieldsForAuthor | Указываются пользовательские поля сообщений, доступные автору.
Поля сообщений доступные модератору | AvailablePostCustomFieldsForModerator | Указываются пользовательские поля сообщений, доступные модератору.
Дополнительные настройки
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции будет установлен заголовок страницы в соответствии с её содержимым.
Показывать строку меню | DisplayMenu | [True|False] При отмеченной опции будет показана строка меню.
Показывать боковую панель блога | DisplaySidebar | [True|False] При отмеченной опции будет показана боковая панель блога.
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Количество дней для выбора популярных и обсуждаемых записей | PeriodDays | Указывается количество дней для выбора популярных и обсуждаемых записей блогов, которые будут отображены.
Количество записей, выводимых на страницу | PostsPerPage | Указывается количество записей, отображаемых на одной странице. Все записи будут выведены с помощью постраничной навигации.
Количество блогов, выводимых на страницу | BlogsPerPage | Указывается количество блогов, отображаемых на одной странице. Все блоги будут выведены с помощью постраничной навигации.
Количество комментариев к записи на странице | CommentsPerPage | Указывается количество комментариев к записи, отображаемых на одной странице. Все комментарии будут выведены с помощью постраничной навигации.
Количество записей, выводимых на главной странице блогов | MainPagePostCount | Указывается количество записей, отображаемых на главной странице.
Количество блогов, выводимых на главной странице блогов | MainPageBlogCount | Указывается количество блогов, отображаемых на главной странице.
Разрешить MetaWeblog API | AllowMetaWeblogApi | [True|False] При отмеченной опции будет разрешено использование MetaWeblog API.
Максимальный размер файла для сообщения, КБайт (максимально допустимое значение 4096) | MaximalFileSizeInKBytes | Указывается максимальный размер файла для сообщения в КБайтах. Максимально допустимое значение 4096 КБайт.
Максимальный размер всех файлов для сообщения, КБайт | MaximalAllFilesSizeInKBytes | Указывается максимальный размер всех файлов для сообщения в КБайтах.
Максимальная ширина изображения для сообщения, пиксел | MaximalImageWidthInPixels | Указывается максимальная ширина изображения для сообщения в пикселах.
Максимальная высота изображения для сообщения, пиксел | MaximalImageHeightInPixels | Указывается максимальная высота изображения для сообщения в пикселах.
Параметры гостей блога
Выводить поле "Е-Mail" в форме комментария GuestEmail Указывается способ отображения поля "Е-Mail" в форме комментария:
  • Не выводить;
  • Предлагать (visible);
  • Обязательно (required).
Справшивать код подтверждения при комментировании | GuestCaptcha | [True|False] При отмеченной опции в форме комментария будет отображено поле, необходимое для ввода кода подтверждения.
Настройки ссылок
Внешняя страница профиля пользователя | UserProfileUrl | Указывается шаблон пути к внешней странице профиля пользователя.
Внешняя страница редактирования профиля пользователя | UserProfileEditUrl | Указывается шаблон пути к внешней странице редактирования профиля пользователя.
Управление адресами страниц
Включить поддержку ЧПУ EnableSEF [True|False] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить следущие параметры: <имя>Template.

Если режим поддержки ЧПУ выключен, то необходимо настроить следущие параметры: <имя>Variable.
Каталог ЧПУ (относительно корня сайта) | SEFFolder | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
<страница> <имя>Template Указываются адреса следующих страниц:
  • NewPostTemplate - страница создания новой записи;
  • PostListTemplate - страница списка записей блога;
  • PostListPageTemplate - конкретная страница списка записей;
  • DraftPostListTemplate - страница списка черновиков блога;
  • DraftPostListPageTemplate - конкретная страница списка черновиков;
  • PostTemplate - страница чтения записи блога;
  • PostPageTemplate - конкретная страница чтения записи;
  • PostEditTemplate - страница редактирования записи;
  • CommentReadTemplate - страница просмотра комментария;
  • CommentEditTemplate - страница редактирования комментария;
  • UserProfileTemplate - страница профиля пользователя;
  • UserProfileEditTemplate - страница редактирования профиля пользователя;
  • NewBlogTemplate - страница создания нового блога;
  • BlogEditTemplate - страница редактирования блога;
  • BlogListTemplate - страница списка блогов;
  • BlogListPageTemplate - конкретная страница списка блогов;
  • CategoryBlogListTemplate - страница списка блогов категории;
  • CategoryBlogListPageTemplate - конкретная страница списка блогов категории;
  • NewPostListTemplate - страница списка новых записей;
  • NewPostListPageTemplate - конкретная страница списка новых записей;
  • PopularPostListTemplate - страница списка популярных записей;
  • PopularPostListPageTemplate - конкретная страница списка популярных записей;
  • DiscussPostListTemplate - страница списка обсуждаемых записей;
  • DiscussPostListPageTemplate - конкретная страница списка обсуждаемых записей;
  • SearchTagsTemplate - страница списка записей по тегам;
  • SearchTagsPageTemplate - конкретная страница списка записей по тегам;
  • SearchBlogTagsTemplate - страница списка записей блога по тегам;
  • SearchBlogTagsPageTemplate - конкретная страница списка записей блога по тегам;
  • BlogMetaWeblogApiTemplate - страница MetaWeblog API;
  • RssAllPostsTemplate - ссылка на RSS записей всех блогов текущего сайта;
  • RssBlogPostsTemplate - ссылка на RSS записей блога;
  • RssBlogPostCommentsTemplate - ссылка на RSS комментариев записи блога;
Идентификатор <имя> <имя>Variable Указываются следующие идентификаторы:
  • BlogVariable - идентификатор блога;
  • CategoryVariable - идентификатор категории;
  • CommentVariable - идентификатор комментария;
  • PostVariable - идентификатор записи;
  • ActionVariable - идентификатор операции;
  • PageVariable - идентификатор страницы;
  • UserVariable - идентификатор пользователя;
  • TagsVariable - идентификатор тегов.
Настройки поиска
Использовать для отображения результатов поиска | DisplaySearchResults | [True|False] При отмеченной опции компонент будет формировать ссылки на сообщения, найденные в результате поиска по блогам.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Список категорий блогов

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Список категорий блогов

Компонент выводит список категорий блогов. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="blogcategory_list1"
 runat="server"
 componentname="bitrix:blog.category.list"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/themes/default/style.css"
 DisplayLimit="0"
 ColumnCount="2"
 SortByFirst="Name"
 SortOrderFirst="Asc"
 SortBySecond="Sort"
 SortOrderSecond="Asc"
 MaxWordLength="15"
 BlogCategoryPageUrlTemplate=""
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Внешний вид
Максимальное количество отображаемых элементов | DisplayLimit | Указывается число непустых категорий блогов, которые будут выведены на странице.
Количество столбцов | ColumnCount | Указывается количество столбцов, в которые будут выведены категории.
Источник данных
Поле для первой сортировки SortByFirst Указывается поле, по которому будет происходить первая сортировка категорий блогов:
  • Id - по идентификатору;
  • Sort - по сортировке;
  • Name – по названию.
Направление для первой сортировки SortOrderFirst Задается направление для первой сортировки:
  • Asc – по возрастанию;
  • Decs – по убыванию.
Поле для второй сортировки SortBySecond Указывается поле, по которому будет происходить вторая сортировка категорий блогов:
  • Id - по идентификатору;
  • Sort - по сортировке;
  • Name – по названию.
Направление для второй сортировки SortOrderSecond Задается направление для второй сортировки:
  • Asc – по возрастанию;
  • Decs – по убыванию.
Дополнительные настройки
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Управление адресами страниц
Шаблон ссылки на страницу категории блога | BlogCategoryPageUrlTemplate | Указывается шаблон пути к странице категорий блогов.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Список комментариев блогов

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Список комментариев блогов

Компонент выводит список комментариев всех блогов. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="blogcomments1"
 runat="server"
 componentname="bitrix:blog.comments"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/themes/default/style.css"
 AuthorId="0"
 MaxWordLength="15"
 SetPageTitle="True"
 BlogUrlTemplate="Blog.aspx?blog=#blogSlug#"
 UserProfileUrlTemplate="User.aspx?user=#userId#"
 PostViewUrlTemplate="Post.aspx?post=#postId#"
 CommentUrlTemplate="Post.aspx?post=#PostId#&comment=#CommentId###comment#CommentId#"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="False"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Идентификатор автора комментариев | AuthorId | Указывается идентификатор автора комментариев, список которых будет отображен.
Дополнительные настройки
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установлено Последние комментарии.
Настройки ссылок
Шаблон пути к странице блога | BlogUrlTemplate | Задается шаблон пути к странице блога.
Шаблон пути к странице пользователя блога | UserProfileUrlTemplate | Задается шаблон пути к странице профиля пользователя блога.
Шаблон пути к странице просмотра записи | PostViewUrlTemplate | Задается шаблон пути к странице просмотра записи блога.
Шаблон пути на комментарий | CommentUrlTemplate | Задается шаблон пути к комментарию блога.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение комментарии всех блогов.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страинц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество комментариев блогов, отображаемых на одной странице. Все комментарии блогов будут выведены с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ комментариев. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу в списке комментариев всех блогов.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам в списке комментариев всех блогов.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Создание/редактирование блога

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Создание/редактирование блога

Компонент создать новый блог либо изменить параметры и настройки уже существующего блога. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="blogedit1"
 runat="server"
 componentname="bitrix:blog.edit"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/themes/default/style.css"
 BlogSlug=""
 AllowToAjustBlogGroups="True"
 ObligatoryBlogGroups=""
 MaxBlogGroups="1"
 AvailableBlogGroups=""
 SlugIgnoreList="admin;blog;blogs;users;user;search;posts;rss;tags"
 MinSlugLength="3"
 MaxSlugLength="10"
 AvailableBlogCustomFieldsForAuthor=""
 AvailableBlogCustomFieldsForModerator=""
 SetPageTitle="True"
 RedirectUrlTemplate="blog.aspx?blog=#blogSlug#"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Адрес блога | BlogSlug | Указывается адрес блога. Обычно задается в виде <%$ Request:blog%>, чтобы адрес выводился из строки запроса.
Разрешить выбор групп AllowToAjustBlogGroups [True|False] При отмеченной опции будет разрешен выбор групп, к которым может быть привязан блог.

Если опция отмечена, то необходимо настроить следущие параметры: MaxBlogGroups и AvailableBlogGroups.

Если опция не отмечена, то необходимо настроить следущие параметры: ObligatoryBlogGroups.
Количество групп, к которым может привязан блог | MaxBlogGroups | Указывается максимальное количество групп, к которым может быть привязан блог.
Доступные группы | AvailableBlogGroups | Указываются доступные группы, к которым может быть привязан блог.
Привязать к группам | ObligatoryBlogGroups | Указываются группы, к которым будет привязан блог.
Запрещенные адреса блогов через точку с запятой | SlugIgnoreList | Задаются запрещенные адреса блогов (через точку с запятой). Нпример: admin;blog;blogs и т.д.
Минимальная длина адреса блога | MinSlugLength | Указывается минимальная длина адреса блога.
Максимальная длина адреса блога | MaxSlugLength | Указывается максимальная длина адреса блога.
Пользовательские поля
Поля блогов доступные автору | AvailableBlogCustomFieldsForAuthor | Указываются пользовательские поля блогов, доступные автору.
Поля блогов доступные модератору | AvailableBlogCustomFieldsForModerator | Указываются пользовательские поля блогов, доступные модератору.
Дополнительные настройки
Устанавливать заголовок страницы SetPageTitle [True|False] При отмеченной опции в качестве заголовка страницы будет установлено:
  • Создание нового блога - при создании нового блога;
  • Редактирование блога - при редактирование параметров существующего блога.
Настройки ссылок
Шаблон ссылки возврата | RedirectUrlTemplate | Указывается шаблон ссылки возврата (шаблон ссылки, по которой будет осуществлен переход после выполнения операции).


Список блогов

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Список блогов

Компонент выводит список блогов. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="bloglist1"
 runat="server"
 componentname="bitrix:blog.list"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/themes/default/style.css"
 CategoryId="1"
 SortByFirst="ID"
 SortOrderFirst="Desc"
 SortBySecond="Sort"
 SortOrderSecond="Desc"
 MaxWordLength="15"
 SetPageTitle="True"
 BlogPageUrlTemplate=""
 BlogOwnerProfilePageUrlTemplate=""
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Источник данных
Категория блогов | CategoryId | Указывается категория, список блогов которой будет отображен. Если указать значение -- не выбрана --, то в списке будут отображены блоги всех категорий.
Поле для первой сортировки SortByFirst Указывается поле, по которому будет происходить первая сортировка списка блогов:
  • Id - по идентификатору;
  • Sort - по сортировке;
  • Name – по названию;
  • DateCreated - по дате создания;
  • DateLastPosted - по дате последней записи;
  • PostCount - по количеству записей.
Направление для первой сортировки SortOrderFirst Задается направление для первой сортировки списка блогов:
  • Asc – по возрастанию;
  • Decs – по убыванию.
Поле для второй сортировки SortBySecond Указывается поле, по которому будет происходить вторая сортировка списка блогов:
  • Id - по идентификатору;
  • Sort - по сортировке;
  • Name – по названию;
  • DateCreated - по дате создания;
  • DateLastPosted - по дате последней записи;
  • PostCount - по количеству записей.
Направление для второй сортировки SortOrderSecond Задается направление для второй сортировки списка блогов:
  • Asc – по возрастанию;
  • Decs – по убыванию.
Дополнительные настройки
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Устанавливать заголовок страницы SetPageTitle [True|False] При отмеченной опции в качестве заголовка страницы будет установлено:
  • Все блоги - если Категория блогов не указана;
  • <имя_категории> - если указана Категория блогов.
Управление адресами страниц
Шаблон ссылки на страницу блога | BlogPageUrlTemplate | Задается шаблон ссылки на страницу блога.
Шаблон ссылки на страницу профиля владельца блога | BlogOwnerProfilePageUrlTemplate | Задается шаблон ссылки на страницу профиля владельца блога.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка всех блогов.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страинц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество записей списка блогов, отображаемых на одной странице. Весь список блогов будет выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ списка блогов. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу списка блогов.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам списка блогов.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Меню блога

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Меню блога

Компонент выводит ссылки на различные страницы блога. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="blogmenu3"
 runat="server"
 componentname="bitrix:blog.menu"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/themes/default/style.css"
 BlogSlug=""
 NewPostUrlTemplate=""
 DraftPostListUrlTemplate=""
 UserBlogUrlTemplate=""
 UserBlogSettingsUrlTemplate=""
 BlogIndexUrl=""
 UserProfileUrlTemplate=""
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Адрес блога (или пустая строка для блога текущего пользователя) | BlogSlug | Указывается адрес блога или пустая строка для блога текущего пользователя.
Настройки ссылок
Страница создания нового сообщения | NewPostUrlTemplate | Указывается шаблон пути к странице создания нового сообщения блога.
Страница черновиков | DraftPostListUrlTemplate | Указывается шаблон пути к странице черновиков блога.
Страница блога текущего пользователя | UserBlogUrlTemplate | Указывается шаблон пути к странице блога текущего пользователя.
Страница настроек блога | UserBlogSettingsUrlTemplate | Указывается шаблон пути к странице настроек блога.
Главная страница блогов | BlogIndexUrl | Указывается шаблон пути к главной странице блога.
Страница профиля пользователя | UserProfileUrlTemplate | Указывается шаблон пути к странице пользователя блога.


Запись блога

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Запись блога

Компонент показывает запись в блоге. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="blogpost1"
 runat="server"
 componentname="bitrix:blog.post"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/themes/default/style.css"
 BlogSlug="company"
 PostId="4"
 MaxWordLength="15"
 SetPageTitle="True"
 BlogUrlTemplate="Blog.aspx?blog=#BlogSlug#"
 UserProfileUrlTemplate="User.aspx?user=#UserId#"
 PostViewUrlTemplate="Post.aspx?post=#PostId#"
 PostEditUrlTemplate="PostEdit.aspx?post=#PostId#"
 RssUrlTemplate="PostRss.aspx?post=#PostId#"
 SearchTagsTemplate="Tags.aspx?tags=#SearchTags#"
 DisplaySearchResults="True"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Адрес блога | BlogSlug | Указывается адрес блога.
Идентификатор записи | PostId | Указывается идентификатор записи блога.
Дополнительные настройки
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установлено <название_записи_блога>.
Настройки ссылок
Шаблон ссылки на блог | BlogUrlTemplate | Указывается шаблон ссылки на блог.
Шаблон ссылки на страницу профиля | UserProfileUrlTemplate | Указывается шаблон ссылки на страницу профиля владельца записи блога.
Шаблон ссылки на страницу просмотра записи | PostViewUrlTemplate | Указывается шаблон ссылки на страницу просмотра записи блога.
Шаблон ссылки на страницу редактирования записи | PostEditUrlTemplate | Указывается шаблон ссылки на страницу редактирования записи блога.
Шаблон ссылки на RSS комментариев записи | RssUrlTemplate | Указывается шаблон ссылки на RSS комментариев записи блога.
Шаблон пути к странице тега | SearchTagsTemplate | Указывается шаблон ссылки на страницу тега блога.
Настройки поиска
Использовать для отображения результатов поиска | DisplaySearchResults | [True|False] При отмеченной опции компонент будет формировать ссылки на сообщения, найденные в результате поиска по записям блога.


Комментарии к записи

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Комментарии к записи

Компонент показывает комментарии к записи в блоге. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="blogpost_comments1"
 runat="server"
 componentname="bitrix:blog.post.comments"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/themes/default/style.css"
 BlogSlug="company"
 PostId="3"
 CommentId="6"
 MaxWordLength="15"
 GuestEmail="required"
 GuestCaptcha="True"
 BlogUrlTemplate="Blog.aspx?blog=#BlogSlug#"
 UserProfileUrlTemplate="User.aspx?user=#UserId#"
 PostViewUrlTemplate="Post.aspx?post=#PostId#"
 PostEditUrlTemplate="PostEdit.aspx?post=#PostId#"
 CommentUrlTemplate="Post.aspx?post=#PostId#&comment=#CommentId###comment#CommentId#"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="False"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Адрес блога | BlogSlug | Указывается адрес блога.
Идентификатор записи | PostId | Указывается идентификатор записи блога.
Идентификатор комментария | CommentId | Указывается идентификатор комментария к записи блога.
Дополнительные настройки
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Параметры гостя
Выводить поле "Е-Mail" GuestEmail Указывается способ отображения поля "Е-Mail":
  • Не выводить;
  • Предлагать (visible);
  • Обязательно (required).
Выводить код подтверждения | GuestCaptcha | [True|False] При отмеченной опции в форме комментария будет отображено поле, необходимое для ввода кода подтверждения.
Настройки ссылок
Шаблон ссылки на блог | BlogUrlTemplate | Указывается шаблон ссылки на блог.
Шаблон ссылки на страницу профиля | UserProfileUrlTemplate | Указывается шаблон ссылки на страницу профиля владельца записи блога.
Шаблон ссылки на страницу просмотра записи | PostViewUrlTemplate | Указывается шаблон ссылки на страницу просмотра записи блога.
Шаблон ссылки на страницу редактирования записи | PostEditUrlTemplate | Указывается шаблон ссылки на страницу редактирования записи блога.
Шаблон ссылки на комментарий | CommentUrlTemplate | Указывается шаблон ссылки на комментарий.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение комментария к записи блога.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество комментариев к записи блога, отображаемых на одной странице. Весь список комментариев будет выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ комментария к записи блога. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу комментария к записи блога.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам комментария к записи блога.


Создание записи

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Создание записи

Компонент предназначен для создания новой или редактирования уже существющующей записи в блоге. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="blogpost_form1"
 runat="server"
 componentname="bitrix:blog.post.form"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/themes/default/style.css"
 BlogSlug="company"
 PostId="4"
 AvailablePostCustomFieldsForAuthor="'WEF'"
 AvailablePostCustomFieldsForModerator="'WEF'"
 MaxWordLength="15"
 SetPageTitle="True"
 MaximalFileSizeInKBytes="1024"
 MaximalAllFilesSizeInKBytes="8192"
 MaximalImageWidthInPixels="0"
 MaximalImageHeightInPixels="0"
 PublishUrlTemplate="Post.aspx?post=#PostId#"
 DraftUrlTemplate="Draft.aspx?post=#PostId#"
 RedirectUrlTemplate="Posts.apsx"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Адрес блога | BlogSlug | Указывается адрес блога.
Идентификатор записи | PostId | Указывается идентификатор записи блога.
Пользовательские поля
Поля сообщений доступные автору | AvailablePostCustomFieldsForAuthor | Указываются пользовательские поля сообщений, доступные автору.
Поля сообщений доступные модератору | AvailablePostCustomFieldsForModerator | Указываются пользовательские поля сообщений, доступные модератору.
Дополнительные настройки
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Устанавливать заголовок страницы SetPageTitle [True|False] При отмеченной опции в качестве заголовка страницы будет установлено:
  • Создание новой записи - при создании новой записи в блоге;
  • Редактирование записи - при редактировании уже существующей записи в блоге.
Максимальный размер файла, КБайт | MaximalFileSizeInKBytes | Указывается максимальный размер файла в КБайтах.
Максимальный размер всех файлов, КБайт | MaximalAllFilesSizeInKBytes | Указывается максимальный размер всех файлов в КБайтах.
Максимальная ширина изображения, пиксел | MaximalImageWidthInPixels | Указывается максимальная ширина изображения в пикселах.
Максимальная высота изображения, пиксел | MaximalImageHeightInPixels | Указывается максимальная высота изображения в пикселах.
Настройки ссылок
Шаблон ссылки на опубликованную запись | PublishUrlTemplate | Указывается шаблон ссылки на опубликованную запись в блоге.
Шаблон ссылки на черновик | DraftUrlTemplate | Указывается шаблон ссылки на черновик записи в блоге.
Шаблон ссылки возврата | RedirectUrlTemplate | Указывается шаблон ссылки возврата (шаблон ссылки, по которой будет осуществлен переход после выполнения операции).


Список записей блога

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Список записей блога

Компонент выводит список записей блога. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="blogpost_list1"
 runat="server"
 componentname="bitrix:blog.post.list"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/themes/default/style.css"
 BlogSlug="company"
 PublishMode="All"
 FilterByDate="True"
 FilterByYear="2009"
 FilterByMonth="9"
 FilterByDay="15"
 MaxWordLength="15"
 SetPageTitle="True"
 BlogUrlTemplate="Blog.aspx?blog=#blogSlug#"
 UserProfileUrlTemplate="User.aspx?user=#userId#"
 PostViewUrlTemplate="Post.aspx?post=#postId#"
 PostRssUrlTemplate="PostRss.aspx?post=#PostId#"
 PostEditUrlTemplate="PostEdit.aspx?post=#postId#"
 SearchTagsUrlTemplate="Tags.aspx?tags=#SearchTags#"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingRecordsPerPage="2"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="5"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Символический идентификатор блога (адрес блога) | BlogSlug | Указывается адрес блога (символический идентификатор блога), список записей которого будет отображен.
Выводить записи PublishMode Указывается какие записи блога отображать в списке:
  • Только опубликованные (Published);
  • Только черновики (Draft);
  • Все (All).
Фильтровать по дате FilterByDate [True|False] При отмеченной опции список записей блога будет отфильтрован по дате.

Если режим фильтрации включен, то необходимо настроить следущие параметры: Год (обязательно) (FilterByYear), Месяц (FilterByMonth), День (FilterByDay).
Год (обязательно) | FilterByYear | Обязательно указывается год для фильтрации списка записей блога.
Месяц | FilterByMonth | Указывается месяц для фильтрации списка записей блога.
День | FilterByDay | Указывается день для фильтрации списка записей блога.
Дополнительные настройки
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установлено <название_блога>.
Настройки ссылок
Шаблон пути к странице блога | BlogUrlTemplate | Указывается шаблон пути к странице блога.
Шаблон пути к странице пользователя блога | UserProfileUrlTemplate | Указывается шаблон пути к странице профиля пользователя блога.
Шаблон пути к странице просмотра записи | PostViewUrlTemplate | Указывается шаблон пути к странице просмотра записи блога.
Шаблон пути на RSS комментариев записи | PostRssUrlTemplate | Указывается шаблон ссылки на RSS комментариев записи блога.
Шаблон пути к странице редактирования записи | PostEditUrlTemplate | Указывается шаблон пути к странице редактирования записи блога.
Шаблон пути к странице тега | SearchTagsUrlTemplate | Указывается шаблон ссылки на страницу тега блога.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка записей блога.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество записей в списке, отображаемых на одной странице. Все записи блога будут выведены с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ записей блога. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу со списком записей блога.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам со спискам записей блога.


Список записей блогов текущего сайта

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Список записей блогов текущего сайта

Компонент выводит список записей блога за указанный период времени для текущего сайта. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="blogposts1"
 runat="server"
 componentname="bitrix:blog.posts"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/blog/templates/.default/themes/default/style.css"
 SortBy="ByComments"
 PeriodDays="30"
 Tags=""
 BlogSlug=""
 FilterByPostCustomProperty="True"
 PostCustomPropertyFilterSettings=""
 MaxWordLength="15"
 SetPageTitle="True"
 BlogUrlTemplate="Blog.aspx?blog=#blogSlug#"
 UserProfileUrlTemplate="User.aspx?user=#userId#"
 PostViewUrlTemplate="Post.aspx?post=#postId#"
 PostEditUrlTemplate="PostEdit.aspx?post=#postId#"
 PostRssUrlTemplate="PostRss.aspx?post=#PostId#"
 SearchTagsUrlTemplate="Tags.aspx?tags=#SearchTags#&searchBlog=#BlogSlug#"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="False"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Сортировать записи по SortBy Указывается способ сортировки записей:
  • Дате (ByDate);
  • Количеству просмотров (ByViews);
  • Количеству комментариев (ByComments).
Период вывода записей в днях (например, за последние 30 дней) | PeriodDays | Задается период времени, за который будут отображены записи блога текущего сайта.
Теги | Tags | Указываются теги блога.
Символический идентификатор блога (адрес блога) | BlogSlug | Указывается адрес блога (символический идентификатор блога), список записей блога для текущего сайта которого будет отображен.
Пользовательские поля
Включить фильтрацию по полям сообщений | FilterByPostCustomProperty | [True|False] При отмеченной опции будет включена фильтрация по полям сообщений.
Настройки фильтрации по полям сообщений | PostCustomPropertyFilterSettings | Изменить значение можно только в диалоге редактирования параметров в режиме Разработка публичной части.
Дополнительные настройки
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установлено <название_блога>.
Настройки ссылок
Шаблон пути к странице блога | BlogUrlTemplate | Указывается шаблон пути к странице блога.
Шаблон пути к странице пользователя блога | UserProfileUrlTemplate | Указывается шаблон пути к странице профиля пользователя блога.
Шаблон пути к странице просмотра записи | PostViewUrlTemplate | Указывается шаблон пути к странице просмотра записи блога.
Шаблон пути к странице редактирования записи | PostEditUrlTemplate | Указывается шаблон пути к странице редактирования записи блога.
Шаблон пути на RSS комментариев записи | PostRssUrlTemplate | Указывается шаблон пути на RSS комментариев записи блога.
Шаблон пути к странице тега | SearchTagsUrlTemplate | Указывается шаблон пути на страницу тега блога.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка записей блога текущего сайта.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество записей в списке, отображаемых на одной странице. Все записи блога текущего сайта будут выведены с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ записей блога. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу с записями блога текущего сайта.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам с записями блога текущего сайта.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


RSS блога

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::RSS блога

Компонент выводит RSS блога в заданном формате. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="blogrss1"
 runat="server"
 componentname="bitrix:blog.rss"
 template=".default"
 FeedTitle="Новое в блогах"
 FeedDescription="Новое в блогах сайта "Главный сайт""
 StuffType="Post"
 FiltrationType="CategoryId"
 CategoryId="0"
 BlogSlug="0"
 PostId=""
 EnablePostCut="True"
 ItemQuantity="10"
 FeedUrlTemplate=""
 FeedItemUrlTemplate=""
 FilterByPostCustomProperty="True"
 PostCustomPropertyFilterSettings=""
 FilterByPostTag="True"
 PostTagFilterSettings=""
 NoCData="False"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Заголовок канала | FeedTitle | Указывается заголовок канала.
Описание канала | FeedDescription | Задается произволное описание канала.
Выгружать StuffType Указывается какие данные будут выгружатся в RSS:
  • новые записи (Post);
  • новые комментарии (Comment).
Если выбрать новые записи, то необходимо задать значение параметра EnablePostCut.
Из FiltrationType Указывается откуда будут выгружатся данные, из которых будет формироваться RSS:
  • всех блогов сайта (None);
  • категории (CategoryId) - при этом необходимо указать категорию в параметре CategoryId;
  • блога (BlogSlug) - при этом необходимо указать блог в параметре BlogSlug;
  • записи (PostId) - при этом необходимо указать запись блога в параметре PostId.
Категория | CategoryId | Указывается категория блогов, новые комментарии или записи которой будут выгружены в RSS ленту.
Блог | BlogSlug | Указывается блог, новые комментарии или записи которого будут выгружены в RSS ленту.
Запись | PostId | Указывается запись, новые комментарии которой будут выгружены в RSS ленту.
Отображать содержимое врезки (CUT'а) | EnablePostCut | [True|False] При отмеченной опции будет отображено содержимое врезки (CUT'а).
Количество элементов | ItemQuantity | Указывается число сообщений блогов, данные из которых будут выгружены в соответствующем формате.
Шаблон ссылки на канал | FeedUrlTemplate | Указывается шаблон ссылки на RSS канал.
Шаблон ссылки на элемент | FeedItemUrlTemplate | Указывается шаблон ссылки на элемент RSS ленты.
Пользовательские поля
Включить фильтрацию по полям записей | FilterByPostCustomProperty | [True|False] При отмеченной опции будет включена фильтрация по полям записей.
Настройки фильтрации по полям записей | PostCustomPropertyFilterSettings | Изменить значение можно только в диалоге редактирования параметров в режиме Разработка публичной части.
Теги
Включить фильтрацию по тегам записей (все другие фильтры будут отключены, необходим модуль поиска) | FilterByPostTag | [True|False] При отмеченной опции будет включена фильтрация по тегам записей, при этом все другие фильтры будут отключены (необходимо наличие модуля Поиск в системе).
Настройки фильтрации по тегам записей (перечисление тегов через запятую) | PostTagFilterSettings | В поле указываются теги через запятую.
Дополнительные настройки
Не использовать CDATA | NoCData | [True|False] При отмеченной опции не будут использоваться конструкции вида <![CDATA[текст]]>.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования в секундах.


Сервис MetaWeblog

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Сервис MetaWeblog

Компонент обеспечивает публикацию в блоги из клиентских программ, поддерживающих MetaWeblog API. Компонент стандартный и входит в дистрибутив модуля.

Для облегчения повседневного редактирования записей в блогах можно использовать любые текстовые редакторы, поддерживающие MetaWeblog API, например, Windows Live Writer.

MetaWeblog API (MWA) - это интерфейс, который позволяет внешним программам управлять сообщениями в блоге.

Пример вызова

<bx:IncludeComponent
 id="blogmetaweblog1"
 runat="server"
 componentname="bitrix:blog.metaWeblog"
 template=".default"
 BlogSlug=""
 SetPageTitle="True"
 MaximalFileSizeInKBytes="1024"
 MaximalAllFilesSizeInKBytes="8192"
 MaximalImageWidthInPixels="300"
 MaximalImageHeightInPixels="300"
 BlogUrlTemplate="Blog.aspx?blog=#blogSlug#"
 PostViewUrlTemplate="Post.aspx?post=#postId#"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Адрес блога | BlogSlug | Указывается адрес блога.
Дополнительные настройки
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции будет установлен заголовок страницы в соответствии с её содержимым.
Максимальный размер файла, КБайт | MaximalFileSizeInKBytes | Указывается максимальный размер файла в КБайтах.
Максимальный размер всех файлов, КБайт | MaximalAllFilesSizeInKBytes | Указывается максимальный размер всех файлов в КБайтах.
Максимальная ширина изображения, пиксел | MaximalImageWidthInPixels | Указывается максимальная ширина изображения в пикселах.
Максимальная высота изображения, пиксел | MaximalImageHeightInPixels | Указывается максимальная высота изображения в пикселах.
Настройки ссылок
Шаблон ссылки на блог | BlogUrlTemplate | Указывается шаблон ссылки на блог.
Шаблон ссылки на пост | PostViewUrlTemplate | Указывается шаблон ссылки на запись блога.


Описание модуля

Система управления рекламой позволяет организовать показ баннеров на сайте (например, за счет внутренней ротации баннеров в пределах сайта). Вы сможете размещать как изображения баннеров, так и включать код баннера в HTML-код страницы.

Можно ограничить период показа баннера, указать количество показов, отметить, на каких страницах и в каких разделах сайта баннер будет показан, а на каких запрещён к показу.

Для каждой рекламной области можно загрузить несколько баннеров. При внутренней ротации на сайте баннеры будут выбираться для показа случайным образом. Частоту выбора того или иного баннера можно задавать с помощью коэффициента вероятности показа (веса баннера). Чем выше значение данного коэффициента, тем больше вероятность показа данной рекламы.

С помощью модуля Реклама, баннеры также можно управлять рекламой сайта.

В модуле Реклама, баннеры используются следующие термины:

  • Баннер - графическое изображение, Flash или текстовый блок рекламного характера, клик на котором обычно приводит к открытию страницы с некоторым содержимым (например, описание рекламируемого товара,услуги и т.д.);
  • Рекламная область - место в основном шаблоне сайта для показа рекламы (баннеров).

В административном интерфейсе модуля вы можете создавать новую рекламу. Для создания новых рекламных областей необходимо изменение основного шаблона сайта.

Модуль включает в себя следующие компоненты:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Баннер | advertising.banner | Выводит баннер заданной рекламной области.


Баннеры

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список баннеров
    •

    На странице Баннеры (Сервисы > Реклама > Баннеры) представлен список рекламных баннеров, имеющихся на сайте.

    Рекламный баннер – это графическое изображение, Flash или текстовый блок рекламного характера, клик на котором обычно приводит к открытию страницы с некоторым содержимым (например, описание рекламируемого товара,услуги и т.д.).

    Отклик баннера (CTR) – отношение числа кликов на баннер к числу показов этого баннера. Выражается в процентах и рассчитывается по следующей формуле: (K * 100) / S, где K – число кликов на баннер, S – число показов баннера. Баннер с CTR выше 10% считается очень удачным.

    Форма поиска

    С помощью данной формы вы можете выполнить поиск баннера в соответствии с указанными условиями.

    Поле | Описание
Название баннера | Название баннера.
ID | Идентификатор баннера.
Символьный код | Символьный код баннера.
Индикатор показа | Поиск можно задать по баннерам, показывающимися на сайте, либо по баннерам, которые не показываются на сайте, либо по всем.
Активность | Поиск можно задать по активным или неактивным баннерам.
Рекламная область | Поиск можно задать по всем рекламным областям или по одной выбранной.
Сайты | Сайты, для показа на которых предназначен баннер.
Количество показов | Количества показов баннера.
Количество посетителей | Количества посетителей, просмотревших баннер.
Количество переходов | Количество кликов по баннеру.
Внешний ключ | Ключ, который может использовать для связи с внешними источниками.

    Чтобы отобрать баннеры по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех баннеров нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Новый баннер | Переход к форме создания нового баннера.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.

    Список баннеров

    Поле | Описание
    Колонка флажков | Выбор баннеров для примения какого-либо правила или действия.
    Действия Действия над баннером:
    • Изменить баннер - переход к редактированию парметров баннера;
    • Удалить баннер - удаление баннера.
    ID | Идентификатор баннера.
    Инд. Индикатор активности баннера:
    • – баннер не показывается посетителям (например, истек заданный период активности);
    • – баннер показывается посетителям.
    Содержание | Отображается баннер с учетом типа его содержимого.
    Название | Произвольное имя баннера.
    Активность Признак активности баннера:
    • Да - баннер активен;
    • Нет - баннер неактивен.
    Вес | Относительный "вес" баннера, влияющий на вероятность выбора баннера при показе. Чем выше вес баннера, тем больше вероятность выбора данного баннера для показа.
    Область | Рекламная область баннера.
    Последний показ | Дата и время последнего показа баннера.
    Первый показ | Дата и время первого показа баннера.
    Равномерность ротации Отметка о равномерности показа баннера:
    • Да - баннер будет показан с равномерной скоростью;
    • Нет - показ баннера будет осуществляться неравномерно.
    Показано | Количество выполненных показов баннера.
    Кликнули | Количество кликов по данному баннеру.
    Посетителей | Количество посетителей, просмотревших баннер.
    CTR | Значение (в процентах) показателя отклика данного баннера.


Создание и редактирование баннера

В данном разделе

  • Контекстная панель
  • Форма редактирования
  • Основные параметры
  • Содержание
  • Таргетинг
  • Дополнительно
    •
  • Кнопки управления
  • Статистика показов баннера
    •

    Контекстная панель

    Кнопка | Описание
Список баннеров | Переход на страницу со списком баннеров.
Добавить | Переход к форме создания нового баннера.
Удалить | Удаление редактируемого баннера. Кнопка отображается при редактировании существующего баннера.

    Форма редактирования

    Форма предназначена для создания нового и изменения параметров существующего баннера. Для удобства работы форма разделена на несколько закладок. Каждая закладка содержит логически сгруппированный набор полей для управления параметрами баннера.

    Закладка "Основные параметры"

    Служит для задания основных параметров баннера.

    Поле | Описание
    Индикатор активности Индикатор активности баннера:
    • – баннер не показывается посетителям (например, истек заданный период активности);
    • – баннер показывается посетителям.
    Поле отображается в режиме редактирования существующего баннера.
    ID Идентификатор баннера.

    Поле отображается в режиме редактирования существующего баннера.
    *Название | Произвольное имя баннера.
    Активность | Признак активности баннера. Для показа в публичном разделе доступны только активные баннеры.
    *Рекламная область | Рекламная область, в которой будет выводится баннер в публичном разделе. С помощью ссылки Создать можно перейти к форме создания новой рекламной области.
    Как часто и как долго показывать
    Фиксировать число показов баннера При отмеченной опции число показов баннера будет фиксироваться. Опцию рекомендуеься включать только тогда, когда подсчет количества показов действительно необходим.

    Внимание! Включение этого параметра увеличит число запросов к БД при обращение к страницам, содержащим баннер с опцией Фиксировать число показов баннера.
    Показывать баннер Способ отображения баннера:
    • по весу;
    • с равномерной скоростью.
    При выборе показа с равномерной скоростью на основании значении параметров Интервал показа и Максимальное число показов баннера определяется количество показов баннера в день (заданное число показов баннера равномерно распределяется по указанному периоду). При этом поля Интервал показа и Максимальное число показов баннера обязательны для заполнения.
    Интервал показа | Период времени, в течение которого баннер может показываться на сайте. По истечении этого периода, баннер становится неактивным. Можно задать только начало периода, только конец периода, либо начало и конец периода.
    Вес (приоритет) | Относительный "вес" баннера, влияющий на вероятность выбора баннера при показе. Чем выше вес баннера, тем больше вероятность выбора данного баннера для показа.
    Максимальное число показов баннера | Максимальное число показов баннера. При достижении заданного значения баннер становится неактивным. Если значение не задано или рано 0, то данное ограничение не контролируется.
    Максимальное число посетителей, для которых будет показан баннер | Максимальное число посетителей, для которых будет показан баннер. При достижении заданного значения баннер становится неактивным. Если значение не задано или рано 0, то данное ограничение не контролируется.
    Максимальное число показов баннера одному посетителю | Установка ограничения на число показов баннера одному посетителю. Считается, что оптимальным количество показов баннера одному посетителю равно 4.
    Фиксировать клики на баннер | При отмеченной опции клики на баннер будут фиксироваться. Максимальное число кликов на баннер можно задать в одноименном поле, которое также станет активным.
    Максимальное число кликов на баннер | Максимальное число кликов на баннер. При достижении заданного значения баннер становится неактивным. Если значение не задано или рано 0, то данное ограничение не контролируется.

    * - поля, обязательные для заполнения.

    Закладка "Содержание"

    Служит для задания ограничений на показ баннера.

    Поле | Описание
    Тип содержимого | Способ формирования внешнего вида баннера. В зависимости от выбранного значения (Изображение, Flash, Текст или HTML или Silverlight) количество полей на данной закладке будет различаться. Описания полей для каждого типа приведено ниже.
    Изображение
    Файл | Поле для загрузки графического файла с локального компьютера.
    URL для перехода при клике на баннере | Адрес страницы, которая будет открыта по клику на баннере.
    Открыть баннер Параметр, определяющий, в каком окне будет показана страница, открытая по клику на баннер:
    • в текущем окне;
    • в новом окне.
    Текст всплывающей подсказки | Текст подсказки, которая будет появляться при наведении указателя мыши на баннер.
    Flash
    Файл | Поле для загрузки flash-файла с локального компьютера.
    Режим окна для FlashPlayer (атрибут wmode) Указывается режим окна Flash плеера:
    • Прозрачный - фон страницы будет "проглядывать" через все прозрачные места баннера при отображении;
    • Непрозрачный - баннер будет помещен на задний план страницы;
    • Обычный (с собственным окном) - баннер будет отображаться на странице в собственном прямоугольном окне.
    Требуемая версия FlashPlayer | В поле указывается требуемая версия FlashPlayer для отображения баннера.
    Альтернативное изображение для баннера | Поле для загрузки альтернативного изображения для баннера. Это изображение будет выведено, если версия Flash плеера не будет соответствовать требуемой, либо если Flash не установлен.
    URL для перехода при клике на баннере | Адрес страницы, которая будет открыта по клику на баннере.
    Открыть баннер Параметр, определяющий, в каком окне будет показана страница, открытая по клику на баннер:
    • в текущем окне;
    • в новом окне.
    Текст всплывающей подсказки | Текст подсказки, которая будет появляться при наведении указателя мыши на баннер.
    Текст или HTML
    Произвольный текст или HTML-код, который будет отображаться в качестве баннера.
    Silverlight
    Файл | Поле для загрузки silverlight-файла (файл формата .xap) с локального компьютера.
    Версия Silverlight | В поле указывается требуемая версия Silverlight для отображения баннера.
    Альтернативное изображение для баннера | Поле для загрузки альтернативного изображения для баннера. Это изображение будет выведено, если версия Silverlight не будет соответствовать требуемой, либо если Silverlight не установлен.
    URL для перехода при клике на баннере | Адрес страницы, которая будет открыта по клику на баннере.
    Открыть баннер Параметр, определяющий, в каком окне будет показана страница, открытая по клику на баннер:
    • в текущем окне;
    • в новом окне.
    Текст всплывающей подсказки | Текст подсказки, которая будет появляться при наведении указателя мыши на баннер.
    Закладка "Таргетинг"

    Настройка таргетинга рекламы. Диапазон доступных значений полей зависит от настроек контракта, к которому относиться данный баннер.

    Поле | Описание
Сайты (если не выбран ни один из сайтов, то баннер будет показываться на всех сайтах без ограничений) | Сайт или сайты, на которых будет показываться баннер. Если не выбран ни один из сайтов, то баннер будет показываться на всех сайтах без ограничений.
Шаблоны URL, только для которых баннер будет показан | Баннер будет показываться только на страницах с адресами соответствующими заданным шаблонам. Например, шаблон forum/ означает, что баннер будет показан только на страницах размещённых в директории forum. Записи вида [директория]/[страница]?[строка запроса] рассматриваются относительно веб-приложения как /[путь к веб-приложению]/[директория]/[страница]?[строка запроса].
Шаблоны URL, для которых баннер не будет показан | Баннер не будет показываться на страницах с адресами соответствующими заданным шаблонам. Например, шаблон blog/ означает, что баннер не будет показан на страницах размещённых в директории blog. Записи вида [директория]/[страница]?[строка запроса] рассматриваются относительно веб-приложения как /[путь к веб-приложению]/[директория]/[страница]?[строка запроса].
Пользовательские роли | В зависимости от выбранного значения (Показывать баннер только относящимся к выбранным ролям посетителям или Не показывать баннер относящимся к выбранным ролям посетителям) определяется право на показ (или запрет показа) баннера, относящегося к указанным ролям посетителей.
Время и дни недели для показа баннера
С помощью диаграммы можно выбрать часы и дни недели, по которым баннер доступен для показа.

    Закладка "Дополнительно"

    Создание произвольного описания, символьного кода и внешнего ключа баннера.

    Поле | Описание
Описание | Поле для ввода произвольного описания.
Символьный код | Символьный код баннера.
Внешний ключ | Ключ, который может использовать для связи с внешними источниками.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Переход на страницу со списком баннеров.
Применить | Сохранение внесённых изменений. Продолжение редактирования параметров баннера.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.

    Статистика показов баннера

    Поле | Описание
Общее количество показов баннера | В поле отображается число показов баннера. Чтобы обнулить показатели счетчика, нажмите ссылку Сбросить.
Количество посетителей, просмотревших баннер | В поле отображается количество посетителей, просмотревших баннер. Чтобы обнулить показатели счетчика, нажмите ссылку Сбросить.
Количество кликов на баннер | В поле отображается количество кликов на баннер. Чтобы обнулить показатели счетчика, нажмите ссылку Сбросить.
Отклик баннера (CTR), % | Поле содержит отклик баннера (CTR) – отношение числа кликов на баннер к числу показов этого баннера. Выражается в процентах и рассчитывается по следующей формуле: (K * 100) / S, где K – число кликов на баннер, S – число показов баннера. Баннер с CTR выше 10% считается очень удачным.


Рекламные области

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список рекламных областей
    •

    На странице Рекламные области (Сервисы > Реклама > Рекламные области) представлен список рекламных областей, имеющихся на сайте.

    Рекламная область – это именованная область в шаблоне сайта, в которой выводятся баннеры.

    Форма поиска

    С помощью данной формы вы можете выполнить поиск рекламной области в соответствии с указанными условиями.

    Поле | Описание
Название рекламной области | Название рекламной области.
ID | Идентификатор рекламной области.
Символьный код | Символьный код рекламной области.
Сортировка | Относительный "вес" рекламной области, определяющий её положение в списке.
Внешний ключ | Ключ, который может использовать для связи с внешними источниками.

    Чтобы отобрать рекламные области по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех рекламных областей нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Новая рекламная область | Переход к форме создания новой рекламной области.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.

    Список рекламных областей

    Поле | Описание
    Колонка флажков | Выбор рекламных областей для примения какого-либо правила или действия.
    Действия Действия над рекламными областями:
    • Изменить рекламную область - переход к редактированию парметров рекламной области;
    • Удалить рекламную область - удаление рекламной области.
    ID | Идентификатор рекламной области.
    Название | Название рекламной области.
    Активность Признак активности рекламной области:
    • Да - рекламная область активна;
    • Нет - рекламная область неактивна.
    Создана | Дата и время создания рекламной области.
    Обновлена | Дата и время последнего изменения рекламной области.
    Баннеров | Количество баннеров, принадлежащих к рекламной области.
    Описание | Произвольное описание рекламной области.


Создание и редактирование рекламной области

В данном разделе

  • Контекстная панель
  • Форма редактирования
  • Рекламная область
    •
  • Кнопки управления
    •

    Контекстная панель

    Кнопка | Описание
Список рекламных областей | Переход на страницу со списком рекламных областей.
Добавить | Переход к форме создания новой рекламной области.
Удалить | Удаление редактируемой рекламной области. Кнопка отображается при редактировании существующей рекламной области.

    Форма редактирования

    Форма предназначена для создания новой и изменения параметров существующей рекламной области.

    Закладка "Рекламная область"

    Поле | Описание
ID | Идентификатор рекламной области. Поле отображается в режиме редактирования существующей рекламной области.
*Символьный код | Символьный код рекламной области.
Активность | Признак активности рекламной области.
*Название | Произвольное имя рекламной области.
Описание | Произвольное описание рекламной области.
Сортировка | Относительный "вес" рекламной области, определяющий её положение в списке.
Внешний ключ | Ключ, который может использовать для связи с внешними источниками.

    * - поля, обязательные для заполнения.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Переход на страницу со списком рекламных областей.
Применить | Сохранение внесённых изменений. Продолжение редактирования параметров рекламной области.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Баннер

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты

  • Баннер


Баннер

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Баннер

Компонент выводит баннер заданной рекламной области. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="advertisingbanner1"
 runat="server"
 componentname="bitrix:advertising.banner"
 template=".default"
 Space="new"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Рекламная область | Space | Указывается рекламная область.


Описание модуля

Грамотно организованный веб-портал обычно позволяет своим посетителям общаться между собой, задавать вопросы, которые могут быть адресованы одновременно посетителям и администрации сайта. Основным средством подобной коммуникативности является Форум. Кроме того, форум - прекрасное средство привлечения дополнительных посетителей на сайт, поскольку поисковые машины обычно индексируют текстовое содержимое сообщений форума в дополнение к основному содержанию сайта.

Модуль Форум служит для создания и управления форумами сайта. Основные возможности модуля включают:

  • возможность самостоятельно строить и гибко модифицировать публичную часть (внешний вид) форума;
  • создавать необходимое число форумов;
  • гибко регулировать права доступа клиентов на чтение и отправку сообщений в форум;
  • управлять настройками форумов;
  • прочие возможности.

Модуль включает в себя следующие компоненты:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Форум (комплексный компонент) | forum | Позволяет создать полноценный публичный интерфейс форума.
Список форумов | forum.list | Выводит список форумов, сгруппированых по категориям.
Меню форума | forum.menu | Выводит сылки на различные страницы форума.
Форма создания/редактирования | forum.post.form | Выводит форму создания/редактирования темы или сообщения форума.
Список сообщений (внешний) | forum.post.list | Ввыводит список сообщений (для использования вне форума).
RSS форума | forum.rss | Выводит RSS форума в заданном формате.
Поиск по форуму | forum.search | Выводит результаты поиска по форуму.
Подписки пользователя | forum.subscription | Выводит список подписок пользователя форума.
Темы (список внешний) | forum.topic.last | Выводит cписок тем (для использования вне форума).
Список тем форума | forum.topic.list | Выводит список тем форума.
Перенос тем форума | forum.topic.move | Позволяет перенести одну или несколько тем в другой форум.
Список сообщений темы | forum.topic.read | Выводит список сообщений темы форума


Список форумов

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список форумов
    •

    Страница Список форумов (Сервисы > Форумы > Список форумов) содержит информацию о существующих форумах, позволяет создавать новые форумы и управлять существующими.

    Форма поиска

    Поиск форумов в соответствии с указанными условиями.

    Поле | Описание
Название форума | Название форума.
Сайт | Сайт, к которому относится форум.
Категория | Категория форума.
ID | Идентификатор форума.
Сортировка | Относительный "вес" форума, определяющий его положение в списке.
Символический код | Символический код форума.
Внешний ключ | Ключ, который может использовать для связи с внешними источниками.

    Чтобы отобрать форумы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех форумов нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Новый форум | Переход к форме создания нового форума.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список форумов

    Поле | Описание
    Колонка флажков | Выбор форумов, к которым предполагается применить какое-либо правило или действие.
    Действия Действия, которые можно произвести над форумом:
    • Изменить форум - переход к форме редактирования параметров форума;
    • Удалить форум - удаление форума.
    ID | Идентификатор форума в системе.
    Название | Произвольное название форума.
    Категория | Категория форума.
    Активность | Признак активности форума. Если форум неактивен, то он не может быть использован.
    Сайт | Сайт(ы), к которым относится данный форум.
    Сортировка | Порядок сортировки форума. Влияет на расположение форума в списке.
    Тем | Количество тем форума.
    Ответов | Количество ответов на темы и сообщения форума.
    Дата создания | Дата создания форума.
    BBCode | Поле информирует о разрешении/запрете использования BB-кодов.
    Смайлы | Поле информирует о разрешении/запрете смайликов на форуме.
    Индексирование | Поле информирует о разрешении/запрете индексирования для поиска сообщений форума.
    Символический код | Символический код форума.
    Внешний ключ | Ключ, который используется для связи с внешними источниками.


Создание и редактирование форума

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Форум
  • Настройки
  • Доступ
  • Кнопки управления

    • Контекстная панель

    Кнопка | Описание
Список форумов | Переход на страницу co списком форумов.
Добавить | Переход к форме создания нового форума. Кнопка отображается при редактировании существующего форума.
Удалить | Удаление редактируемого форума. Кнопка отображается при редактировании существующего форума.

    Форма редактирования

    Форма применяется как для создания новых, так и для редактирования существующих форумов.

    Закладка "Форум"

    Настройка общих параметров форума.

    Поле | Описание
ID | Уникальный идентификатор форума. Отображается при редактировании существующего форума.
Активность | Признак активности форума.
*Название | Произвольное название форума.
*Сайты | Сайт(ы), на которых будет доступен форум.
Категория | Название категории, к которой относится форум. С помощью ссылки Создать можно перейти к форме создания новой категории форума.
Описание (HTML разрешен) | Краткое описание форума (возможно использование HTML-кода).
Сортировка | Относительный "вес" форума, определяющий его положение в списке.

    * - поля, обязательные для заполнения.

    Закладка "Настройки"

    Поле | Описание
Разрешить использование BB-кодов | При отмеченной опции будет разрешено использование BB-кода (BBCode) в тексте сообщения.
Разрешить использование смайлов | При отмеченной опции будет разрешено использование смайликов в сообщении.
Индексировать для поиска | При отмеченной опции будет разрешено индексирование для поиска сообщений форума.
Переиндексировать | При отмеченной опции будет перегенерирован поисковый индекс для поиска сообщений форума.
Символический код | Символический код форума.
Внешний ключ | Ключ, который используется для связи с внешними источниками.

    Закладка "Доступ"

    Предназначена для установки прав доступа к форуму для каждой из ролей в системе.

    Поле Описание
    В таблице в левой колонке выберите роль, а в правой колонке задайте права на задачи и операции для выбранной роли.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Переход на страницу со списком форумов.
Применить | Сохранение внесённых изменений. Продолжение редактирования параметров форума.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Список категорий

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список категорий
    •

    Страница Список категорий (Сервисы > Форумы > Список категорий) содержит список существующих категорий форумов, а также позволяет перейти к созданию новой или изменению уже существующей категории форумов.

    Категории используются для группировки форумов в публичной части сайта. Например, можно объединить все форумы, имеющие отношение к различным вопросам по конкретному продукту, в одну категорию: Разработка, Лицензирование, Применение и т.д.

    Каждый форум может быть привязан к одной из категорий форумов, либо может остаться без привязки.

    Форма поиска

    Поиск категорий форумов в соответствии с указанными условиями.

    Поле | Описание
Название категории | Название категории.
ID | Идентификатор категории форумов.
Сортировка | Относительный "вес" категории форумов, определяющий положение категории в списке.
Внешний ключ | Ключ, который может использовать для связи с внешними источниками.

    Чтобы отобрать категории форумов по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех категорий нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Новая категория форумов | Переход к форме создания новой категории форумов.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список категорий форумов

    Поле | Описание
    Колонка флажков | Выбор категории форумов, к которой предполагается применить какое-либо правило или действие.
    Действия Действия, которые можно произвести над категорией форумом:
    • Изменить параметры категории - переход к форме редактирования параметров категории форума;
    • Удалить категорию - удаление категории форума.
    ID | Идентификатор категории форумов в системе.
    Название | Произвольное название категории форумов.
    Сортировка | Относительный "вес" категории форумов, определяющий положение категории в списке.
    Внешний ключ | Ключ, который используется для связи с внешними источниками.


Создание и редактирование категории

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Категория форумов
    •
  • Кнопки управления
    •

    Форма используется для создания или редактирования категории форумов, предназначенных для группировки форумов в публичной части сайта.

    Контекстная панель

    Кнопка | Описание
Список категорий | Переход на страницу co списком категорий форумов.
Добавить | Переход к форме создания новой категории форумов. Кнопка отображается при редактировании существующей категории форумов.
Удалить | Удаление редактируемой категории форумов. Кнопка отображается при редактировании существующей категории форумов.

    Форма редактирования

    Закладка "Категория форумов"

    Поле | Описание
ID | Идентификатор категории форумов. Отображается при редактировании существующей категории.
*Название | Произвольное название категории форумов.
Сортировка | Относительный "вес" категории форумов, определяющий положение категории в списке.
Внешний ключ | Ключ, который используется для связи с внешними источниками.

    * - поля, обязательные для заполнения.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Переход на страницу со списком категорий форумов.
Применить | Сохранение внесённых изменений. Продолжение редактирования параметров категорий форумов.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров категорий форумов.


Управление подпиской

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список пользователей
    •

    Страница Управление подпиской (Сервисы > Форумы > Управление подпиской) содержит информацию о пользователях, имеющих подписки на форумы.

    Форма поиска

    Поиск пользователей, имеющих подписки, в соответствии с указанными условиями.

    Поле | Описание
Логин | Поиск пользователя, имеющего подписки, по его логину.
Фамилия | Поиск пользователя, имеющего подписки, по его фамилии.
Имя | Поиск пользователя, имеющего подписки, по его имени.

    Чтобы отфильтровать список пользователей по заданным критериям поиска, нажмите кнопку Найти. Для отображения всего списка нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список пользователей

    Поле | Описание
    Колонка флажков | Выбор пользователей, имеющих подписки, к которым предполагается применить какое-либо правило или действие.
    Действия Действия, которые можно произвести над элементом списка:
    • Подписки детально - переход на страницу подписок пользователя;
    • Удалить - удаление категории форума.
    Логин | Логин пользователя.
    Участник | Логин, имя и фамилия пользователя.
    Имя | Имя пользователя.
    Фамилия | Фамилия пользователя.
    Email | Адрес электронной почты пользователя.
    Количество подписок | Количество подписок, которые имеет пользователь.


Подписки пользователя

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список подписок пользователя

    • На странице Подписки пользователя представлена информация о всех подписках выбранного пользователя.

    Форма поиска

    Поиск подписок пользователя в соответствии с указанными условиями.

    Поле | Описание
Название форума | Поиск подписок пользователя, оформленных на указанном форуме.
Название темы | Поиск подписок пользователя, оформленных в указанной теме форума.
Сайт | Поиск подписок пользователя, оформленных на форумах указанного сайта.

    Чтобы отфильтровать подписки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех подписок нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список подписок пользователя

    Поле | Описание
    Колонка флажков | Выбор подписок, к которым предполагается применить какое-либо правило или действие.
    Действия Действия, которые можно применить к элементу списка:
    • Удалить - удаление подписки пользователя.
    ID | Идентификатор подписки.
    Форум | Название форума, к которому относится подписка.
    Тема | Название темы форума.
    Тип подписки | Тип подписки.
    Сайт | Название сайта, на котором была создана подписка.


Поиск по форуму

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты

  • RSS форума
  • Меню форума
  • Перенос тем форума
  • Подписки пользователя
  • Поиск по форуму
  • Список сообщений (внешний)
  • Список сообщений темы
  • Список тем форума
  • Список форумов
  • Темы (список внешний)
  • Форма создания/редактирования
  • Форум (комплексный компонент)


Форум (комплексный компонент)

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Форум (комплексный компонент)

Комплексный компонент позволяет создать полноценный публичный интерфейс форума. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="forum1"
 runat="server"
 componentname="bitrix:forum"
 template=".default"
 ColorCss="~/bitrix/components/bitrix/forum/templates/.default/themes/default/style.css"
 AvailableForums="'1';'2'"
 GenerateMenu="True"
 GenerateMenuType="left"
 SetPageTitle="True"
 MaxWordLength="15"
 ForumListTitle="Все форумы"
 ShowNavigation="True"
 ShowMenu="True"
 GuestMenuTextTemplate="Здравствуйте, гость! <a href="Auth.aspx?ReturnUrl=#ReturnUrl#">Войти</a>"
 UserMenuTextTemplate="Здравствуйте, #UserDisplayName#!"
 GuestEmail="required"
 GuestCaptcha="True"
 ForumRulesUrl=""
 ForumHelpUrl=""
 UserProfileUrl=""
 UserProfileEditUrl=""
 EnableSEF="True"
 SEFFolder="/"
 ForumVariable="forum"
 TopicVariable="topic"
 TopicsVariable="topics"
 PostVariable="post"
 ActionVariable="act"
 PageVariable="page"
 UserVariable="user"
 NewTopicTemplate="/#i:ForumId#/new/"
 MoveTopicsTemplate="/move/?topics=#MoveTopicsIds#"
 TopicListTemplate="/#i:ForumId#/"
 TopicListPageTemplate="/#i:ForumId#/?page=#PageId#"
 TopicTemplate="/#i:ForumId#/#i:TopicId#/"
 TopicPageTemplate="/#i:ForumId#/#i:TopicId#/?page=#PageId#"
 TopicReplyTemplate="/#i:ForumId#/#i:TopicId#/reply/"
 TopicMoveTemplate="/#i:ForumId#/#i:TopicId#/move/"
 TopicEditTemplate="/#i:ForumId#/#i:TopicId#/edit/"
 PostReadTemplate="/#i:ForumId#/#i:TopicId#/#i:PostId#/##post#PostId#"
 PostQuoteTemplate="/#i:ForumId#/#i:TopicId#/#i:PostId#/quote/"
 PostEditTemplate="/#i:ForumId#/#i:TopicId#/#i:PostId#/edit/"
 UserProfileTemplate="/users/#i:UserId#/"
 UserProfileEditTemplate="/users/#i:UserId#/edit/"
 UserSubscriptionsUrlTemplate="/subscriptions/"
 UserSubscriptionsPageUrlTemplate="/subscriptions/?page=#PageId#"
 UserPostsTemplate="/users/#i:UserId#/posts/"
 UserPostsPageTemplate="/users/#UserId#/posts/?page=#PageId#"
 ForumRulesTemplate="/rules/"
 ForumHelpTemplate="/help/"
 ActiveTopicsUrlTemplate="/active/"
 ActiveTopicsPageUrlTemplate="/active/?page=#PageId#"
 UnAnsweredTopicsUrlTemplate="/unanswered/"
 UnAnsweredTopicsPageUrlTemplate="/unanswered/?page=#PageId#"
 SearchUrlTemplate="/search/"
 SearchPageUrlTemplate="/search/?page=#PageId#"
 RssTopicsAllTemplate="/rss/topics/"
 RssTopicsFromForumTemplate="/#i:ForumId#/rss/topics/"
 RssPostsFromTopicTemplate="/#i:ForumId#/#TopicId#/rss/"
 SearchStringVariable="query"
 DateIntervalVariable="period"
 ForumsVariable="forums"
 SortingVariable="sort"
 DisplaySearchResults="True"
 EnableSearch="True"
 EnableRss="True"
 RssCacheMode="Auto"
 RssCacheDuration="30"
 RssItemQuantity="20"
 RssFeedTtl="60"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate="customizable"
 PagingShowOne="True"
 PagingRecordsPerPage="25"
 PagingTitle="Страницы:"
 PagingPosition="both"
 PagingMaxPages="3"
 PagingMinRecordsInverse="1"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Цветовая схема (или путь к CSS-файлу цветовой схемы) ColorCss Указывается цветовая схема форума:
  • Бежевая;
  • Синяя;
  • Серая;
  • Зеленая;
  • Оранжевая;
  • Красная;
  • Белая.
Выбрав пункт другое->, можно задать путь к CSS-файлу цветовой схемы оформления.
Доступные форумы | AvailableForums | Указываются форумы, которые будут отображены на главной странице.
Дополнительные настройки
Строить меню | GenerateMenu | [True|False] При отмеченной опции будет построено меню, пунктами которого будут являтся ссылки на доступные форумы.
Тип меню GenerateMenuType Указывается тип меню:
  • Верхнее (top);
  • Левое (left).
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции будет установлен заголовок страницы в соответствии с её содержимым.
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Заголовок списка форумов | ForumListTitle | Указывается заголовок, отображаемый в таблице со списком форумов.
Показывать навигационную цепочку | ShowNavigation | [True|False] При отмеченной опции будет отображена навигационная цепочка.
Показывать меню форума | ShowMenu | [True|False] При отмеченной опции будет показано меню форума.
Шаблон сообщения в подменю для неавторизованного пользователя | GuestMenuTextTemplate | Задается шаблон сообщения, отображаемый в подменю для неавторизованного пользователя.
Шаблон сообщения в подменю для авторизованного пользователя | UserMenuTextTemplate | Задается шаблон сообщения, отображаемый в подменю для авторизованного пользователя.
Параметры гостей форума
Выводить поле "Е-Mail" в форме ответа GuestEmail Указывается способ отображения поля "Е-Mail" в форме ответа:
  • Не выводить;
  • Предлагать (visible);
  • Обязательно (required).
Справшивать код подтверждения при ответе | GuestCaptcha | [True|False] При отмеченной опции в форме ответа будет отображено поле, необходимое для ввода кода подтверждения.
Настройки ссылок
Страница правил форума (путь к файлу включаемой области, или ссылка на страницу) | ForumRulesUrl | Указывается путь к странице правил форума (путь к файлу включаемой области, или ссылка на страницу).
Страница помощи (путь к файлу включаемой области, или ссылка на страницу) | ForumHelpUrl | Указывается путь к странице помощи (путь к файлу включаемой области, или ссылка на страницу).
Внешняя страница профиля пользователя | UserProfileUrl | Указывается шаблон пути к внешней странице профиля пользователя.
Внешняя страница редактирования профиля пользователя | UserProfileEditUrl | Указывается шаблон пути к внешней странице редактирования профиля пользователя.
Управление адресами страниц
Включить поддержку ЧПУ EnableSEF [True|False] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить следущие параметры: <имя>Template и SearchStringVariable, DateIntervalVariable, ForumsVariable, SortingVariable.

Если режим поддержки ЧПУ выключен, то необходимо настроить следущие параметры: <имя>Variable.
Каталог ЧПУ (относительно корня сайта) | SEFFolder | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
<страница> <имя>Template Указываются адреса следующих страниц:
  • NewTopicTemplate - страница создания новой темы форума;
  • MoveTopicsTemplate - страница перемещения тем форума;
  • TopicListTemplate - страница списка тем форума;
  • TopicListPageTemplate - конкретная страница списка тем форума;
  • TopicTemplate - страница чтения темы форума;
  • TopicPageTemplate - конкретная страница чтения темы форума;
  • TopicReplyTemplate - страница ответа на сообщения форума;
  • TopicMoveTemplate - страница перемещения темы форума;
  • TopicEditTemplate - страница редактирования темы форума;
  • PostReadTemplate - страница просмотра сообщения форума;
  • PostQuoteTemplate - страница цитирования сообщения форума;
  • PostEditTemplate - страница редактирования сообщения форума;
  • UserProfileTemplate - страница профиля пользователя форума;
  • UserProfileEditTemplate - страница редактирования профиля пользователя форума;
  • UserSubscriptionsUrlTemplate - страница подписок пользователя форума;
  • UserSubscriptionsPageUrlTemplate - конкретная страница подписок пользователя форума;
  • UserPostsTemplate - страница просмотра сообщений пользователя форума;
  • UserPostsPageTemplate - конкретная страница просмотра сообщений пользователя форума;
  • ForumRulesTemplate - страница правил форума;
  • ForumHelpTemplate - страница помощи форума;
  • ActiveTopicsUrlTemplate - страница просмотра активных тем форума;
  • ActiveTopicsPageUrlTemplate - конкретная страница просмотра активных тем форума;
  • UnAnsweredTopicsUrlTemplate - страница просмотра тем форума без ответов;
  • UnAnsweredTopicsPageUrlTemplate - конкретная страница просмотра тем форума без ответов;
  • SearchUrlTemplate - страница поиска по форумам;
  • SearchPageUrlTemplate - конкретная страница поиска по форумам;
  • RssTopicsAllTemplate - страница RSS "Новые темы на всех форумах";
  • RssTopicsFromForumTemplate - страница RSS "Новые темы на форуме";
  • RssPostsFromTopicTemplate - страница RSS "Новые сообщения в теме".
Идентификатор <имя> <имя>Variable Указываются следующие идентификаторы:
  • ForumVariable - идентификатор форума;
  • TopicVariable - идентификатор темы;
  • TopicsVariable - идентификатор списка тем;
  • PostVariable - идентификатор сообщения;
  • ActionVariable - идентификатор операции;
  • PageVariable - идентификатор страницы;
  • UserVariable - идентификатор пользователя;
  • SearchStringVariable - идентификатор поискового запроса (поиск);
  • DateIntervalVariable - идентификатор временного интервала (поиск);
  • ForumsVariable - идентификатор форума (поиск);
  • SortingVariable - идентификатор сортировки (поиск).
Настройки поиска
Использовать для отображения результатов поиска | DisplaySearchResults | [True|False] При отмеченной опции компонент будет формировать ссылки на сообщения, найденные в результате поиска по форумам.
Разрешить поиск по форумам | EnableSearch | [True|False] При отмеченной опции будет разрешен поиск по форумам.
Настройки RSS
Включить RSS | EnableRss | [True|False] При отмеченной опции становится возможным экспорт данных в формате RSS.
Тип кеширования RssCacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | RssCacheDuration | Указывается время кеширования RSS ленты в секундах.
Количество элементов | RssItemQuantity | Указывается количество элементов для экспорта.
Время жизни (в минутах) | RssFeedTtl | Указывается время жизни RSS ленты в минутах.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение форума.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество записей, отображаемых на одной странице форума. Все записи форума будут выведены с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.


Список форумов

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Список форумов

Компонент выводит список форумов, сгруппированых по категориям. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="forumlist1"
 runat="server"
 componentname="bitrix:forum.list"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/themes/default/style.css"
 AvailableForums="1"
 ForumListTitle="Форумы"
 MaxWordLength="15"
 PostReadUrlTemplate="viewtopic.aspx?post=#PostId##post#PostId#"
 TopicListUrlTemplate="viewforum.aspx?forum=#ForumId#"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Дополнительные настройки
Доступные форумы | AvailableForums | Указываются форумы, которые будут отображены в списке.
Заголовок списка форумов | ForumListTitle | В поле задается заголовок, который будет выведен в таблички со списком форумов.
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Настройки ссылок
Страница чтения сообщения | PostReadUrlTemplate | Указывается шаблон ссылки на страницу чтения сообщения форума.
Страница списка тем | TopicListUrlTemplate | Указывается шаблон ссылки на страницу списка тем форума.


Меню форума

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Меню форума

Компонент выводит сылки на различные страницы форума. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="forummenu1"
 runat="server"
 componentname="bitrix:forum.menu"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/themes/default/style.css"
 GuestMenuTextTemplate="Здравствуйте, гость! <a href="Auth.aspx?ReturnUrl=#ReturnUrl#">Войти</a>"
 UserMenuTextTemplate="Здравствуйте, #UserDisplayName#!"
 ForumIndexUrl="Default.aspx"
 UserProfileUrlTemplate="profile.aspx?user=#UserId#"
 UserSubscriptionsUrlTemplate="/subscriptions/"
 SearchUrl="/search/"
 ForumRulesUrl="/rules/"
 ForumHelpUrl="/help/"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Дополнительные настройки
Шаблон сообщения в подменю для неавторизованного пользователя | GuestMenuTextTemplate | Задается шаблон сообщения, отображаемый в подменю для неавторизованного пользователя.
Шаблон сообщения в подменю для авторизованного пользователя | UserMenuTextTemplate | Задается шаблон сообщения, отображаемый в подменю для авторизованного пользователя.
Настройки ссылок
Страница списка форумов | ForumIndexUrl | Указывается адрес страницы со списком форумов.
Страница профиля пользователя | UserProfileUrlTemplate | Указывается адрес страницы просмотра профиля пользователя форума.
Страница подписок пользователя | UserSubscriptionsUrlTemplate | Указывается адрес страницы управления подпиской пользователя форума.
Страница поиска | SearchUrl | Указывается адрес страницы поиска по форуму.
Страница правил | ForumRulesUrl | Указывается адрес страницы правил форума.
Страница помощи | ForumHelpUrl | Указывается адрес страницы помощи по форуму.


Форма создания/редактирования

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Форма создания/редактирования

Компонент выводит форму создания/редактирования темы или сообщения форума. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="forumpost_form1"
 runat="server"
 componentname="bitrix:forum.post.form"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/themes/default/style.css"
 ForumId="1"
 TopicId="2"
 PostId=""
 ParentPostId=""
 Mode="edit"
 GuestEmail="required"
 GuestCaptcha="True"
 AvailableForums=""
 SetPageTitle="True"
 MaxWordLength="15"
 RedirectUrlTemplate="viewforum.aspx?forum=#ForumId#"
 PostReadUrlTemplate="viewtopic.aspx?post=#PostId###post#PostId#"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Идентификатор форума | ForumId | Указывается идентификатор форума, тема/сообщение которого будет создана/изменена. Если идентификатор не принадлежит к доступному форуму, компонент ничего не выведет.
Идентификатор темы | TopicId | Указывается идентификатор темы.
Идентификатор сообщения | PostId | Указывается идентификатор сообщения.
Идентификатор родительского сообщения | ParentPostId | Указывается идентификатор родительского сообщения.
Режим компонента Mode Указывается режим работы компонента:
  • Создание (add) - создание тем и сообщений форума;
  • Редактирование (edit) - изменение тем и сообщений форума.
Параметры гостя
Выводить поле "Е-Mail" GuestEmail Указывается способ отображения поля "Е-Mail":
  • Не выводить;
  • Предлагать (visible);
  • Обязательно (required).
Выводить код подтверждения | GuestCaptcha | [True|False] При отмеченной опции в форме комментария будет отображено поле, необходимое для ввода кода подтверждения.
Дополнительные настройки
Доступные форумы | AvailableForums | Указываются форумы, в которых можно будет создавать/редактировать сообщения или темы.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции заголовка страницы будет установлен в соответствии с её содержимым.
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Настройки ссылок
Шаблон ссылки возврата | RedirectUrlTemplate | Указывается шаблон ссылки возврата (шаблон ссылки, по которой будет осуществлен переход после выполнения операции).
Шаблон ссылки на сообщение | PostReadUrlTemplate | Указывается шаблон ссылки на страницу чтения сообщения форума.


RSS форума

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::RSS форума

Компонент выводит RSS форума в заданном формате. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="forumrss1"
 runat="server"
 componentname="bitrix:forum.rss"
 template=".default"
 FeedTitle="Новое на форумах"
 FeedDescription="Новое на форумах сайта Главный сайт"
 StuffType="Post"
 FiltrationType="None"
 CategoryId="0"
 ForumId="1"
 TopicId="2"
 ItemQuantity="10"
 FeedUrlTemplate=""
 FeedItemUrlTemplate=""
 FeedTtl="60"
 AvailableForumIdList="'1';'2'"
 NoCData="False"
 CacheMode="Auto"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Заголовок канала | FeedTitle | Указывается заголовок канала.
Описание канала | FeedDescription | Задается произволное описание канала.
Выгружать StuffType Указывается что выгружать в ленту:
  • новые темы (Topic);
  • новые сообщения (Post).
Из FiltrationType Указывается откуда в ленту будут выгружены темы/сообщения форума:
  • из всех форумов сайта (None);
  • из категории (CategoryId) - необходимо указать категорию форума, из которой будут выгружены темы/сообщения, в поле Категория;
  • из форума (ForumId) - необходимо указать форум, теиы/сообщения которого будут выгружены в ленту, в поле Форум;
  • из темы (TopicId) - необходимо указать тему форума, сообщения которой будут выгружены в ленту, в поле Темы.
Категория | CategoryId | Указывается категория форума (идентификатор категории).
Форум | ForumId | Указывается форум (идентификатор форума).
Тема | TopicId | Указывается тема форума (идентификатор темы).
Количество элементов | ItemQuantity | Указывается количество элементов ленты.
Шаблон ссылки на канал | FeedUrlTemplate | Указывается шаблон ссылки на RSS канал.
Шаблон ссылки на элемент | FeedItemUrlTemplate | Указывается шаблон ссылки на элемент RSS ленты.
Время жизни (в минутах) | FeedTtl | Указывается время жизни RSS ленты в минутах.
Дополнительные настройки
Доступные форумы | AvailableForums | Указываются форумы, RSS которых можно будет выводить.
Не использовать CDATA | NoCData | [True|False] При отмеченной опции не будут использоваться конструкции вида <![CDATA[текст]]>.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования RSS ленты в секундах.


Список тем форума

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Список тем форума

Компонент выводит список тем форума. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="forumtopic_list1"
 runat="server"
 componentname="bitrix:forum.topic.list"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/themes/default/style.css"
 ForumId="1"
 AvailableForums="'1';'2'"
 SetPageTitle="True"
 MaxWordLength="15"
 TopicUrlTemplate="viewtopic.aspx?topic=#TopicId#"
 PostReadUrlTemplate="viewtopic.aspx?post=#PostId##post#PostId#"
 NewTopicUrlTemplate="newtopic.aspx?forum=#ForumId#"
 MoveTopicsUrlTemplate="movetopics.aspx?topics=#MoveTopicsIds#"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingRecordsPerPage="5"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Идентификатор форума | ForumId | Указывается идентификатор форума, список тем которого будет отображен. Если идентификатор не принадлежит к доступному форуму, компонент ничего не выведет.
Дополнительные настройки
Доступные форумы | AvailableForums | Указываются форумы, список тем которых можно выводить.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка будет установлено <имя_форума>.
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Настройки ссылок
Шаблон ссылки на страницу чтения темы | TopicUrlTemplate | Указывается шаблон ссылки на страницу чтения темы форума.
Шаблон ссылки на сообщение | PostReadUrlTemplate | Указывается шаблон ссылки на сообщение форума.
Шаблон ссылки на страницу создания новой темы | NewTopicUrlTemplate | Указывается шаблон ссылки на страницу создания новой темы форума.
Шаблон ссылки на страницу перемещения тем | MoveTopicsUrlTemplate | Указывается шаблон ссылки на страницу перемещения тем форума.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка тем форума.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество тем форума, отображаемых на одной странице. Весь список тем форума будет выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ списка тем форума. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу в списке тем форума.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам в списке тем форума.


Перенос тем форума

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Перенос тем форума

Компонент позволяет перенести одну или несколько тем в другой форум. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="forumtopic_move1"
 runat="server"
 componentname="bitrix:forum.topic.move"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/themes/default/style.css"
 TopicsToMove="2"
 AvailableForums="'1';'2'"
 SetPageTitle="True"
 TopicUrlTemplate="viewtopic.aspx?topic=#TopicId#"
 RedirectUrlTemplate="viewforum.aspx?forum=#ForumId#"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Дополнительные настройки
Идентификаторы тем для переноса | TopicsToMove | Указывается идентификатор темы, которую необходимо перенести.
Доступные форумы | AvailableForums | Указываются форумы, темы которых можно будет переносить.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установлено Перемещение темы в новый форум.
Настройки ссылок
Шаблон ссылки на страницу чтения темы | TopicUrlTemplate | Указывается шаблон ссылки на страницу чтения темы.
Шаблон ссылки возврата | RedirectUrlTemplate | Указывается шаблон ссылки возврата (шаблон ссылки, по которой будет осуществлен переход после выполнения операции).


Список сообщений темы

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Список сообщений темы

Компонент выводит список сообщений темы форума. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="forumtopic_read1"
 runat="server"
 componentname="bitrix:forum.topic.read"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/themes/default/style.css"
 TopicId="2"
 PostId=""
 AvailableForums="'1'"
 SetPageTitle="True"
 MaxWordLength="15"
 TopicUrlTemplate="viewtopic.aspx?topic=#TopicId#"
 TopicListUrlTemplate="viewforum.aspx?forum=#ForumId#"
 TopicReplyUrlTemplate="newpost.aspx?topic=#TopicId#"
 TopicMoveUrlTemplate="movetopics.aspx?topics=#TopicId#"
 TopicEditUrlTemplate="edittopic.aspx?topic=#TopicId#"
 PostReadUrlTemplate="viewtopic.aspx?post=#PostId##post#PostId#"
 PostQuoteUrlTemplate="newpost.aspx?topic=#TopicId#&quote=#PostId#"
 PostEditUrlTemplate="editpost.aspx?post=#PostId#"
 UserProfileUrlTemplate="profile.aspx?user=#UserId#"
 UserPostsReadUrlTemplate="viewposts.aspx?user=#UserId#"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingRecordsPerPage="5"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Идентификатор темы | TopicId | Указывается идентификатор темы форума, список сообщений которой будет отображен.
Идентификатор сообщения | PostId | Указывается идентификатор сообщения форума.
Дополнительные настройки
Доступные форумы | AvailableForums | Указываются форумы, список сообщений темы которого можно выводить.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка будет установлено <имя_темы>.
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Настройки ссылок
Шаблон ссылки на страницу чтения темы | TopicUrlTemplate | Указывается шаблон ссылки на страницу чтения темы форума.
Шаблон ссылки на страницу списка тем | TopicListUrlTemplate | Указывается шаблон ссылки на страницу списка тем форума.
Шаблон ссылки на страницу ответа | TopicReplyUrlTemplate | Указывается шаблон ссылки на страницу ответа на сообщения форума.
Шаблон ссылки на страницу перемещения темы | TopicMoveUrlTemplate | Указывается шаблон ссылки на страницу перемещения темы форума.
Шаблон ссылки на страницу редактирования темы | TopicEditUrlTemplate | Указывается шаблон ссылки на страницу редактирования темы форума.
Шаблон ссылки на сообщение | PostReadUrlTemplate | Указывается шаблон ссылки на сообщение форума.
Шаблон ссылки на страницу цитирования сообщения | PostQuoteUrlTemplate | Указывается шаблон ссылки на страницу цитирования сообщения форума.
Шаблон ссылки на страницу редактирования сообщения | PostEditUrlTemplate | Указывается шаблон ссылки на страницу редактирования сообщения форума.
Шаблон ссылки на страницу профиля пользователя | UserProfileUrlTemplate | Указывается шаблон ссылки на страницу профиля пользователя форума.
Шаблон ссылки на страницу просмотра сообщений пользователя | UserPostsReadUrlTemplate | Указывается шаблон ссылки на страницу просмотра сообщений пользователя форума.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка сообщений темы форума.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество сообщений темы форума, отображаемых на одной странице. Все сообщения темы форума будут выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ списка сообщения темы форума. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу со списком сообщений темы форума.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам со списком сообщений темы форума.


Список сообщений (внешний)

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Список сообщений (внешний)

Компонент выводит список сообщений (для использования вне форума). Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="forumpost_list1"
 runat="server"
 componentname="bitrix:forum.post.list"
 template=".default"
 AuthorId="0"
 DisplayMode="AllPosts"
 GroupingOption="GroupByTopic"
 DateCreateFrom=""
 DateCreateTo=""
 Forums="'1';'2'"
 SetPageTitle="True"
 ThemeCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/themes/default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/style.css"
 SortBy="ID"
 SortDirection="Asc"
 ForumReadUrlTemplate="forum.aspx?forum=#ForumId#"
 TopicReadUrlTemplate="forum.aspx?forum=#ForumId#&topic=#TopicId#"
 PostReadUrlTemplate="forum.aspx?forum=#ForumId#&topic=#TopicId#&post=#PostId#"
 AuthorProfileUrlTemplate="forum.aspx?user=#AuthorId#"
 MaxWordLength="50"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Идентификатор автора | AuthorId | Указывается идентификатор автора сообщений, список которых будет отображен.
Режим отображения DisplayMode Указывается режим отображения сообщений:
  • Все сообщения пользователя (AllPosts);
  • Все темы пользователя (AllTopicsCreated);
  • Все темы с участием пользователя (AllTopicsParticipated);
  • Активные темы (ActiveTopics);
  • Темы без ответов (UnAnsweredTopics).
Если указан режим Все сообщения пользователя (AllPosts), то необходимо настроить параметр GroupingOption.
Группировка GroupingOption Указывается способ группировки всех сообщений пользователя:
  • Не группировать (None);
  • По теме (GroupByTopic).
Дата сообщения с | DateCreateFrom | Указывается дата и время начала периода выборки сообщений форума.
по | DateCreateTo | Указывается дата и время окончания периода выборки сообщений форума.
Доступные форумы | Forums | Указываются форумы, список сообщени которых будет отображен.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции будет установлен заголовок страницы в соответствии с её содержимым.
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Сортировать по полю темы SortBy Указывается порядок сортировки по полю темы:
  • по идентификатору (ID);
  • по дате создания (DateCreate).
Направление сортировки SortDirection Указывается направление сортировки списка сообщений форума(ов):
  • по возрастанию (Asc);
  • по убыванию (Desc).
Шаблон страницы чтения форума | ForumReadUrlTemplate | Указывается шаблон ссылки на страницы чтения форума.
Шаблон ссылки на страницу чтения темы | TopicReadUrlTemplate | Указывается шаблон ссылки на страницу чтения темы форума.
Шаблон ссылки на сообщение | PostReadUrlTemplate | Указывается шаблон ссылки на сообщение форума.
Шаблон страницы профиля автора сообщения | AuthorProfileUrlTemplate | Указывается шаблон ссылки на страницу профиля пользователя форума.
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка сообщений форумов.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество сообщений списка форумов, отображаемых на одной странице. Все сообщения списка будут выведены с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ списка сообщений форумов. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу списка сообщений форумов.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам списка сообщений форумов.


Темы (список внешний)

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Темы (список внешний)

Компонент выводит cписок тем (для использования вне форума). Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="forumtopic_last1"
 runat="server"
 componentname="bitrix:forum.topic.last"
 template=".default"
 Forums="'1';'4';'2'"
 SortBy="ID"
 SortDirection="Desc"
 TopicReadUrlTemplate="forum.aspx?forum=#ForumId#&topic=#TopicId#"
 ForumReadUrlTemplate="forum.aspx?forum=#ForumId#"
 AuthorProfileUrlTemplate="forum.aspx?user=#AuthorId#"
 MaxWordLength="50"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Форумы | Forums | Указываются форумы, список сообщений которых будет отображен.
Сортировать по полю темы SortBy Указывается порядок сортировки по полю темы:
  • по идентификатору (ID);
  • по последнему сообщению (LastPostId);
  • по названию (Name).
Направление сортировки SortDirection Указывается направление сортировки списка тем форумов:
  • по возрастанию (Asc);
  • по убыванию (Desc).
Шаблон страницы чтения темы | TopicReadUrlTemplate | Указывается шаблон ссылки на страницу чтения темы форума.
Шаблон страницы чтения форума | ForumReadUrlTemplate | Указывается шаблон ссылки на страницу чтения форума.
Шаблон страницы профиля автора сообщения | AuthorProfileUrlTemplate | Указывается шаблон ссылки на страницу профиля пользователя форума.
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка тем форума.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество тем списка форума, отображаемых на одной странице. Все темы списка будут выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ списка тем форумов. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу со списком тем форумов.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам со списком тем форумов.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования RSS ленты в секундах.


Подписки пользователя

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Подписки пользователя

Компонент выводит список подписок пользователя форума. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="forumsubscription1"
 runat="server"
 componentname="bitrix:forum.subscription"
 template=".default"
 ThemeCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/themes/default/style.css"
 UserId="1"
 AvailableForums="'1';'2'"
 SetPageTitle="True"
 MaxWordLength="15"
 ForumUrlTemplate="viewforum.aspx?forum=#ForumId#"
 TopicUrlTemplate="viewtopic.aspx?topic=#TopicId#"
 PostReadUrlTemplate="viewtopic.aspx?post=#PostId###post#PostId#"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Идентификатор пользователя | UserId | Указывается идентификатор пользователя форума, список подписок которого будет отображен.
Дополнительные настройки
Доступные форумы | AvailableForums | Указываются форумы, список подписок которых будет отображен.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка будет установлено Управление подписками.
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Настройки ссылок
Шаблон ссылки на форум | ForumUrlTemplate | Указывается шаблон ссылки на страницу форума.
Шаблон ссылки на страницу чтения темы | TopicUrlTemplate | Указывается шаблон ссылки на страницу чтения темы форума.
Шаблон ссылки на сообщение | PostReadUrlTemplate | Указывается шаблон ссылки на сообщение форума.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка подписок пользователя форума.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество подписок пользователя форума, отображаемых на одной странице. Весь список подписок пользователя форума будет выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ списка подписок пользователя форума. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу со списком подписок пользователя форума.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам со списком подписок пользователя форума.


Поиск по форуму

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Поиск по форуму

Компонент выводит результаты поиска по форуму. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="forumsearch1"
 runat="server"
 componentname="bitrix:forum.search"
 template=".default"
 SearchString="адрес"
 SortBy="ID"
 DateInterval="0"
 Forums="'1';'2'"
 SetPageTitle="True"
 ThemeCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/themes/default/style.css"
 ColorCssFilePath="~/bitrix/components/bitrix/forum/templates/.default/style.css"
 ForumReadUrlTemplate="forum.aspx?forum=#ForumId#"
 TopicReadUrlTemplate="forum.aspx?forum=#ForumId#&topic=#TopicId#"
 PostReadUrlTemplate="forum.aspx?forum=#ForumId#&topic=#TopicId#&post=#PostId#"
 MaxWordLength="50"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Строка поискового запроса | SearchString | Задается текст поискового запроса.
Сортировка SortBy Указывается способ сортировки результатов поиска по форумам:
  • по релевантности (ID);
  • по дате (Date);
  • по темам (Topic).
Интервал дат DateInterval Указывается интервал времени (в днях), за котрый будет проиходить поиск по форумам:
  • 1 день (0);
  • 3 дня (3);
  • 7 дней (7);
  • 30 дней (30);
  • За все время (-1).
Доступные форумы | Forums | Указываются форумы, по которым будет выполнятся поиск.
Устанавливать заголовок страницы | SetPageTitle | [True|False] При отмеченной опции в качестве заголовка страницы будет установлено Поиск по форуму.
Путь к CSS-файлу темы оформления | ThemeCssFilePath | Задается путь к CSS-файлу темы оформления.
Путь к CSS-файлу цветовой схемы | ColorCssFilePath | Задается путь к CSS-файлу цветовой схемы.
Шаблон страницы чтения форума | ForumReadUrlTemplate | Указывается шаблон ссылки на страницы чтения форума.
Шаблон ссылки на страницу чтения темы | TopicReadUrlTemplate | Указывается шаблон ссылки на страницу чтения темы форума.
Шаблон ссылки на сообщение | PostReadUrlTemplate | Указывается шаблон ссылки на сообщение форума.
Максимальная длина слова | MaxWordLength | Задается максимальное количество символов в слове.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение результатов поиска по форуму.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество результатов поиска по форуму, отображаемых на одной странице. Все результаты поиска будут выведены с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ результатов поиска. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу результатов поиска по форуму.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам с результатами поиска по форуму.


1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Настройки

  • Инструменты
  • Настройки продукта
  • Поиск
  • Пользователи
  • Проактивная защита
  • Система обновлений


Управление пользователями

Система "1C-Битрикс: Управление сайтом ASP.NET" позволяет создавать произвольное количество ролей пользователей с разными правами доступа к ресурсам сайта.

Система обладает широким спектром возможностей для организации совместного управления сайтом, что позволяет сократить время на его поддержку. С помощью настроек прав доступа можно организовать управление сайтом одновременно нескольким пользователям с различными правами доступа к ресурсам сайта.

Каждый зарегистрированный на сайте пользователь имеет персональные регистрационные данные: имя (логин) и пароль. Для того чтобы пользователь мог получить доступ к ресурсам сайта в соответствии с правами группы, к которой он относится, ему необходимо авторизоваться на сайте, т.е. указать свой логин и пароль в специальной форме авторизации.

Компоненты:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Аутентификация (комплексный компонент) | system.auth | Комплексный компонент позволяет зарегистрироваться на сайте, авторизоваться на сайте, получить контрольную строку для смены пароля по электронной почте и сменить пароль на новый при помощи контрольной строки.
Восстановление пароля с помощью контрольной строки | system.PasswordRecoveryAlt | Выводит форму для восстановления пароля с помощью контрольной строки.
Восстановление пароля с помощью контрольной строки (ввод) | system.PasswordRecoveryAltCode | Предназначен для восстановления пароля с помощью ввода контрольной строки.
Восстановление пароля с помощью секретного ответа | system.PasswordRecovery | Предназначен для восстановления пароля с помощью секретного ответа.
Просмотр профиля | user.profile.view | Выводит форму просмотра профиля пользователя.
Регистрация | system.register | Выводит форму регистрации нового пользователя.
Редактирование профиля | user.profile.edit | Выводит форму редактирования профиля пользователя.
Список пользователей | user.list | Выводит список пользователей сайта.
Форма авторизации | system.login | Выводит форму авторизации пользователя.


Список пользователей

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список пользователей
    •

    Страница Список пользователей (Настройки > Пользователи > Список пользователей) содержит полный список пользователей сайта и позволяет:

    • добавлять новых пользователей сайта;
    • редактировать параметры уже существующих пользователей;
    • удалять пользователей сайта.

    Форма поиска

    Форма используется для выбора из списка пользователей в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

    Поле | Описание
Логин | Поле позволяет осуществить отбор пользователей по логину.
Фамилия | Служит для отбора пользователей по фамилии.
EMail | Служит для отбора пользователей по адресу электронной почты.
ID | Идентификатор пользователя. Соответствует полю ID в списке пользователей.
Дата изменения (DD.MM.YYYY) | Позволяет отобрать пользователей, параметры которых были изменены в течение указанного периода.
Последняя авторизация (DD.MM.YYYY) | Позволяет отобрать пользователей, которые были авторизованы в течение указанного периода.
Активен | Определяется, какие пользователи будут участвовать в поиске: активные, неактивные или все.
Сайт | Сайт в системе, от имени и с использованием текстовых ресурсов которого будет производиться уведомление пользователя о каких-либо событиях.

    Чтобы отобрать пользователей по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех пользователей нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Добавить пользователя | Переход к форме создания нового пользователя.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список пользователей

    Поле | Описание
    Колонка флажков | Выбор пользователей, к которым предполагается применить какое-либо правило или действие.
    Действия Действия, которые можно произвести над пользователями:
    • Редактировать - переход к форме редактирования пользователя;
    • Удалить - удаление пользователя;
    • Удалить из провайдера - удаление пользователя из провайдера.
    ID | Идентификатор пользователя.
    Логин | Логин (имя входа) пользователя.
    E-Mail | Адрес электронной почты пользователя.
    Имя | Имя пользователя.
    Отчество | Отчество пользователя.
    Фамилия | Фамилия пользователя.
    Сайт | Сайт в системе, от имени и с использованием текстовых ресурсов которого будет производиться уведомление пользователя о каких-либо событиях.
    Дата рождения | Дата рождения пользователя.
    Активен | Признак активности пользователя.
    Заблокирован | Признак блокировки бюджета пользователя.
    Дата последнего посещения | Дата последнего посещения сайта пользователем.
    Дата регистрации | Дата регистрации пользователя.


Создание и редактирование пользователя

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Пользователь
  • Роли
  • Личные данные
  • Заметки
  • Дополнительно
  • Специальные
  • Кнопки управления

    • На странице вы можете создать нового или изменить параметры существующего пользователя сайта.

    Контекстная панель

    Кнопка | Описание
Список пользователей | Переход на страницу со списком пользователей сайта.
Добавить пользователя | Переход на страницу с формой создания нового пользователя. Кнопка отображается при редактировании существующего пользователя.
Удалить пользователя | Удаление редактируемого пользователя. Кнопка отображается при редактировании существующего пользователя.

    Форма редактирования

    Форма служит для настройки общих параметров пользователя. Все параметры сгруппированы по логическому принципу и размещены на соответствующих закладках формы.

    Закладка "Пользователь"

    Закладка служит для настройки общих параметров пользователя.

    Поле | Описание
Дата регистрации | Дата и время регистрации пользователя. Поле отображается при редактировании существующего пользователя.
Последняя авторизация | Дата и время последней авторизации (входа в систему) данного пользователя. Поле отображается при редактировании существующего пользователя.
Дата последней активности | Дата и время последней активности пользователя. Поле отображается при редактировании существующего пользователя.
Одобрен | При отмеченной опции пользователь будет активным.
Заблокирован | При отмеченной опции бюджет пользователя будет блокирован. Поле отображается при редактировании существующего пользователя.
*Провайдер авторизации | Указывается провайдер авторизации. При редактировании текщего пользователя в поле отображается имя провайдера.
*Логин | Логин пользователя, т.е. имя входа в систему.
*Пароль | Пароль пользователя (должен содержать минимум 7 символов, из них не алфавитно-цифровых - не менее 1).
Текущий пароль | Текущий пароль пользователя. Поле отображается при редактировании существующего пользователя.
Новый пароль | Поле, предназначенное для изменения текущего пароля пользователя. При изменении пароля требуется продублировать его в следующем поле (при этом пароль должен содержать минимум 7 символов, из них не алфавитно-цифровых - не менее 1). Поле отображается при редактировании существующего пользователя.
Подтверждение пароля | Поле для подтверждения нового пароля пользователя. Содержимое этого поля должно в точности соответствовать содержимому предыдущего поля.
*E-Mail | Адрес электронной почты пользователя, на который отсылаются все уведомления с сайта.
Дата последней смены пароля | Дата и время последней смены пароля пользователя. Поле отображается при редактировании существующего пользователя.

    * - поля, обязательные для заполнения.

    Закладка "Роли"

    На закладке определяется список ролей, к которым привязан пользователь, а также период времени, на который осуществляется привязка.

    Поле | Описание
Роль | Название роли, к которой может быть выполнена привязка пользователя.
Период активности | Дата начала и конца периода, на который осуществляется привязка пользователя к группе. После окончания периода активности пользователь будет автоматически удален из данной группы. Если пользователь привязывается к группе на неограниченный срок, то в поле с указывается только дата начала периода активности. Если пользователь привязывается к группе на определенный период, то в поле с указывается начало периода, а в поле по - конец периода активности.

    Закладка "Личные данные"

    На закладке указывается личная информация пользователя.

    Поле | Описание
Аватар | Аватар пользователя. С помощью кнопки Обзор можно загрузить изображение аватара пользователя.
Псевдоним | Псевдоним пользователя.
Имя | Имя пользователя.
Отчество | Отчество пользователя.
Фамилия | Фамилия пользователя.
Пол | Пол пользователя.
Дата рождения | Дата рождения пользователя.
Сайт по умолчанию | Указывается сайт в системе, от имени и с использованием текстовых ресурсов которого будет производиться уведомление пользователя о каких-либо событиях.

    Закладка "Заметки"

    Поле | Описание
Заметки | Произвольный комментарий.

    Закладка "Дополнительно"

    На закладке задаются параметры профайла пользователя для форума.

    Поле | Описание
Форум
Количество постов | В поле отображено количество постов, созданных пользователем на форуме.
Подпись | Указывается подпись пользователя на форуме, которая может содержать цитату, рисунок, слоган, ссылку на любимые сайты и т.д.

    Закладка "Специальные"

    На закладке отображаются созданные в системе дополнительные пользовательские свойства. К созданию нового пользовательского свойства можно перейти по ссылке Добавить пользовательское поле.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение параметров пользователя. Переход на страницу со списком пользователей.
Применить | Сохранение параметров пользователя. Продолжение редактирования параметров пользователя.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений.


Роли

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список ролей
    •

    Страница Роли (Настройки > Пользователи > Роли) содержит полный список ролей пользователей сайта и позволяет:

    • добавлять новые роли пользователей сайта;
    • редактировать параметры уже существующих ролей пользователей;
    • удалять роли пользователей сайта;
    • осуществлять привязку пользователей к той или иной роли.

    Форма поиска

    Форма используется для выбора из списка ролей пользователей в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

    Поле | Описание
Название | Позволяет найти роли пользователей по их названию. Это поле присутствует, даже если фильтр свернут.
Активность | Определяется, какие роли будут участвовать в поиске: активные, неактивные или все (активные и неактивные).

    Чтобы отобрать роли пользователей по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех ролей нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Добавить роль | Переход к форме создания новой роли пользователей.
Синхронизировать | Переход к форме синхронизации ролей.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список ролей

    Поле | Описание
    Колонка флажков | Выбор ролей, к которым предполагается применить какое-либо правило или действие.
    Действия Действия, которые можно произвести над ролями пользователей:
    • Редактировать - переход к форме редактирования параметров роли;
    • Удалить - удаление роли пользователей.;
    • Удалить из провайдера - удаление роли из провайдера.
    ID | Идентификатор роли пользователей.
    Название | Осмысленное название роли пользователей.
    Активность | Признак активности роли. Если роль неактивна, все пользователи в её составе полностью блокируются.
    Комментарий | Описание роли пользователей.
    Политика | Поле содержит параметры настроенной политики безопасности для данной роли.
    Эффективная политика | Поле сожержит параметры политики безопасности, которые расчитываются на основе вложенности ролей (с учетом наследований).
    Количество пользователей | Количество пользователей роли.
    Количество вложенных ролей | Количество вложенных ролей (подгрупп) роли.


Создание и редактирование роли

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Параметры роли
  • Роли
  • Политика безопасности
  • Задачи
  • Операции
    •
  • Кнопки управления

    • Форма создания/редактирования роли пользователей предназначена для настройки параметров существующей или вновь создаваемой роли пользователей.

    Контекстная панель

    Кнопка | Описание
Список ролей | Переход на страницу со списком ролей пользователей сайта.
Новая роль | Переход на страницу с формой создания новой роли пользователей. Кнопка отображается при редактировании существующей роли.
Удалить роль | Удаление редактируемой роли пользователей. Кнопка отображается при редактировании существующей роли.

    Форма редактирования

    Форма служит для настройки параметров роли пользователей. Все параметры сгруппированы по логическому принципу и размещены на соответствующих закладках формы.

    Закладка "Параметры роли"

    На данной закладке выполняется настройка основных параметров роли пользователей.

    Поле | Описание
Количество пользователей | Количество пользователей роли. Поле отображается при редактировании существующей роли.
Количество включенных ролей | Количество включенных ролей. Поле отображается при редактировании существующей роли.
Провайдер | При создании роли указывается провайдер. В режиме редактирования провайдер сменить нельзя.
*Символический идентификатор | Символьный идентификатор роли.
Название | Указывается произвольное и, в то же время, осмысленное имя роли. Например, Редакторы сайта, Рекламодатели и т.д.
Активность | При отмеченной опции роль будет активной. Если роль неактивна, все пользователи в её составе полностью блокируются.
Комментарий | Описание роли пользователей.

    * - поля, обязательные для заполнения.

    Закладка "Роли"

    Поле | Описание
Включает роли | Указываются роли из созданных в системе, которые будут включены в данную роль.

    Закладка "Политика безопасности"

    Поля данной формы служат для настройки политики безопасности для текущей роли пользователей.

    Поле | Описание
    Предопределенные настройки уровня безопасности Механизм управление уровнем безопасности позволяет защитить сайт от XSS/CSS атак.
    В данном поле можно выбрать один из предусмотренных в системе уровней безопасности. Необходимые значения параметров безопасности будут автоматически подставлены в соответствующие поля.

    Доступны следующие предопределённые уровни безопасности:
    • Не переопределять - при выборе данного уровня ко всем группам пользователей будут применены предустановленные параметры безопасности.

      Для того чтобы выполнить выборочное изменение значений параметров, снимите флаг Не переопределять рядом с нужными полями.

    • Низкий;
    • Обычный;
    • Повышенный.

    Для пользователей, принадлежащих к нескольким ролям, по каждому из пунктов политики безопасности будет действовать самое строгое правило из настроенных для этих ролей.
    Время жизни сессии (минут) | Длительность сессии в минутах. Применяется для исключения неправильной настройки времени жизни сессии на хостинге.
    Маска сети для привязки сессии | Включение данной защиты делает бесполезным перехват файла cookies с информацией о сессии. Данный тип защиты является важнейшим при защите от XSS/CSS атак.
    Максимальное количество компьютеров на которых может быть одновременно быть запомнена авторизация | Количество компьютеров, на которых разрешено одновременное запоминание авторизации пользователя. Для администраторов системы рекомендованное значение поля равно 1.
    Маска сети для привязки сохраненной авторизации | Предотвращает возможность использования файла хэша, похищенного с компьютера пользователя, с целью проникновения на сайт. Рекомендуется использовать с другими правилами по времени и числу авторизаций.
    Срок хранения авторизации, запомненной на компьютере пользователя (минут) | Длительность запоминания авторизации пользователя в минутах.
    Срок действия контрольного слова для восстановления пароля (минут) | Правило определяет время хранения контрольного слова для восстановления пароля и позволяет минимизировать риски взлома сайта через механизм восстановления при перехвате писем.

    Закладка "Задачи"

    Поле | Описание
Выполнение задач | Указываются задачи, которые могут выполнять пользователи данной роли.

    Закладка "Операции"

    На данной закладке выполняется настройка параметров роли на выполнение операции с модулями системы.

    Поле | Описание
Модуль | Название модуля системы.
Операции | Для каждого модуля системы перечислены операции, которые могут выполнять пользователи создаваемой/редактируемой роли. Установите/снимите флаги в соответствующих полях для разрешения/запрета выполнения операции пользователям роли для каждого модуля системы.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение параметров роли пользователей. Переход на страницу со списком ролей пользователей.
Применить | Сохранение параметров роли пользователей. Продолжение редактирования роли пользователей.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Задачи

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список задач
    •

    Страница Задачи (Настройки > Пользователи > Задачи) содержит список задач сайта и позволяет создавать/редактировать/удалять задачи.

    Форма поиска

    Форма используется для выбора из списка задач в соответствии с указанными условиями.

    Поле | Описание
Название | Позволяет найти задачи по их названию.

    Чтобы отобрать задачи по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех задач нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Добавить задачу | Переход к форме создания новой задачи.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список задач

    Поле | Описание
    Колонка флажков | Выбор задач, к которым предполагается применить какое-либо правило или действие.
    Действия Действия, которые можно произвести над задачами:
    • Редактировать - переход к форме редактирования задачи;
    • Удалить - удаление задачи.
    ID | Идентификатор задачи.
    Название | Осмысленное название задачи.
    Комментарий | Произвольное описание задачи.
    Количество подзадач | Количество подзадач задачи.
    Количество операций | Количество операций задачи.


Создание и редактирование задачи

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Параметры задачи
  • Подзадачи
  • Операции
    •
  • Кнопки управления

    • Форма создания/редактирования задачи предназначена для настройки параметров существующей или вновь создаваемой задачи.

    Контекстная панель

    Кнопка | Описание
Список задач | Переход на страницу со списком задач.
Новая задача | Переход на страницу с формой создания новой задачи. Кнопка отображается при редактировании существующей задачи.
Удалить задачу | Удаление редактируемой задачи. Кнопка отображается при редактировании существующей задачи.

    Форма редактирования

    Форма служит для настройки параметров задачи. Все параметры сгруппированы по логическому принципу и размещены на соответствующих закладках формы.

    Закладка "Параметры задачи"

    На данной закладке выполняется настройка основных параметров задачи.

    Поле | Описание
Количество подзадач | Количество подзадач задачи. Поле отображается при редактировании существующей задачи.
Количество операций | Количество операций задачи. Поле отображается при редактировании существующей задачи.
*Символический идентификатор | Символьный идентификатор задачи.
Название | Указывается произвольное и, в то же время, осмысленное имя задачи.
Комментарий | Описание задачи.

    * - поля, обязательные для заполнения.

    Закладка "Подзадачи"

    Поле | Описание
Выполнение подзадач | Указываются задачи из созданных в системе, которые будут выполняться как подзадачи данной задачи.

    Закладка "Операциии"

    Поле | Описание
Модуль | Название модуля системы.
Операции | Для каждого модуля системы перечислены операции, которые могут выполняться в рамках данной задачи. Укажите в соответствующих полях операции, которые могут выполняться в рамаках данной задачи для каждого модуля системы, если это необходимо.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение параметров задачи. Переход на страницу со списком задач.
Применить | Сохранение параметров задачи. Продолжение редактирования задачи.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Операции

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список операций
    •

    Страница Операции (Настройки > Пользователи > Операции) содержит список операций и позволяет создавать/редактировать/удалять операции.

    Форма поиска

    Форма используется для выбора из списка операций в соответствии с указанными условиями.

    Поле | Описание
Код | Позволяет найти операции по их коду.
Модуль | Позволяет найти операции, относящиеся к одному из модулей системы.

    Чтобы отобрать операции по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех операций нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Добавить операцию | Переход к форме создания новой операции.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список операций

    Поле | Описание
    Колонка флажков | Выбор операций, к которым предполагается применить какое-либо правило или действие.
    Действия Действия, которые можно произвести над операциями:
    • Редактировать - переход к форме редактирования операции;
    • Удалить - удаление операции.
    ID | Идентификатор операции.
    Название | Осмысленное название операции.
    Тип операции | Тип операции.
    Модуль | Модуль системы, к которому относится операция.
    Комментарий | Произвольное описание операции.


Создание и редактирование операции

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Кнопки управления

    • Форма создания/редактирования операции предназначена для настройки параметров существующей или вновь создаваемой операции.

    Контекстная панель

    Кнопка | Описание
Список операций | Переход на страницу со списком операций.
Новая операция | Переход на страницу с формой создания новой операции. Кнопка отображается при редактировании существующей операции.
Удалить операцию | Удаление редактируемой операции. Кнопка отображается при редактировании существующей операции.

    Форма редактирования

    Поле | Описание
Название | Указывается произвольное и, в то же время, осмысленное имя название операции.
Комментарий | Указывается описание операции.
Тип операции | Задается тип операции.
Модуль | Указывается один из модулей системы, к которому относится операция.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение параметров операции. Переход на страницу со списком операций.
Применить | Сохранение параметров операции. Продолжение редактирования параметров операции.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Синхронизация ролей

В этом разделе

  • Контекстная панель
  • Форма синхронизации
  • Кнопки управления

    • Форма используется для синхронизации ролей пользователей.

    Контекстная панель

    Кнопка | Описание
Список ролей | Переход на страницу со списком ролей пользователей сайта.

    Форма синхронизации

    Поле | Описание
Провайдеры авторизации | Указывается провайдер авторизации для синхронизации ролей пользователей сайта.

    Кнопки управления

    Кнопка | Описание
Сохранить | Синхронизация ролей пользователей. Переход на страницу со списком ролей пользователей сайта.
Применить | Синхронизация ролей пользователей.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Список пользователей

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты

  • Аутентификация (комплексный компонент)
  • Восстановление пароля с помощью контрольной строки
  • Восстановление пароля с помощью контрольной строки (ввод)
  • Восстановление пароля с помощью секретного ответа
  • Просмотр профиля
  • Регистрация
  • Редактирование профиля
  • Список пользователей
  • Форма авторизации


Аутентификация (комплексный компонент)

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Аутентификация (комплексный компонент)

Комплексный компонент позволяет:

  • зарегистрироваться на сайте;
  • авторизоваться на сайте;
  • получить контрольную строку для смены пароля по электронной почте;
  • сменить пароль на новый при помощи контрольной строки.
Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="systemauth1"
 runat="server"
 componentname="bitrix:system.auth"
 template=".default"
 ProfilePath="profile.aspx?user=#UserId#"
 RegistrationDoAuthentication="True"
 RegistrationRedirectUrl="profileedit.aspx?user=#UserId#"
 FirstNameFieldMode="require"
 LastNameFieldMode="require"
 DisplayNameFieldMode="show"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к профилю пользователя | ProfilePath | Указывается шаблон ссылки на профиль пользователя.
Выполнять аутентификацию после регистрации пользователя | RegistrationDoAuthentication | [True|False] При отмеченной опции пользователь после регистрации будет авторизован.
URL для перенаправления после регистрации пользователя | RegistrationRedirectUrl | Адрес ссылки, по которой будет осуществлен переход после успешной регистрации.
Настройка полей
Имя FirstNameFieldMode Указывается способ отображения поля:
  • Скрыть (hide) - поле будет скрыто;
  • Показать (show) - поле будет отображено;
  • Требовать (require) - поле будет отображено, а также обязательным для заполнения.
Фамилия LastNameFieldMode Указывается способ отображения поля:
  • Скрыть (hide) - поле будет скрыто;
  • Показать (show) - поле будет отображено;
  • Требовать (require) - поле будет отображено, а также обязательным для заполнения.
Псевдоним DisplayNameFieldMode Указывается способ отображения поля:
  • Скрыть (hide) - поле будет скрыто;
  • Показать (show) - поле будет отображено;
  • Требовать (require) - поле будет отображено, а также обязательным для заполнения.


Форма авторизации

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Форма авторизации

Компонент выводит форму авторизации пользователя. Внешний вид формы авторизации зависит от одного из трех шаблонов, которые входят в поставку продукта: Вход в портал (portal), По умолчанию (.default) и web20 (web20). Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="systemlogin1"
 runat="server"
 componentname="bitrix:system.login"
 template=".default"
 PasswordRecoveryPath="auth.aspx?auth_page=recovery"
 PasswordRecoveryCodePath="auth.aspx?auth_page=recoverycode"
 LoginRedirectPath="profileedit.aspx?user=#UserId#"
 ProfilePath="profile.aspx?user=#UserId#"
 RegisterPath="auth.aspx?auth_page=register"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к скрипту восстановления пароля | PasswordRecoveryPath | Указывается путь к скрипту восстановления пароля.
Путь к скрипту ввода контрольного слова | PasswordRecoveryCodePath | Указывается путь к скрипту ввода контрольного слова.
Путь к скрипту, на который перенаправлять после успешного входа на сайт | LoginRedirectPath | Указывается ссылка на на страницу, на которую будет перенаправлен пользователь после успешного входа на сайт.
Путь к профилю пользователя | ProfilePath | Указывается шаблон ссылки на профиль пользователя.
Путь к скрипту регистрации пользователя | RegisterPath | Указывается путь к скрипту (на страницу) регистрации нового пользователя.


Восстановление пароля с помощью секретного ответа

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Восстановление пароля с помощью секретного ответа

Компонент предназначен для восстановления пароля с помощью секретного ответа. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="systempasswordrecovery1"
 runat="server"
 componentname="bitrix:system.PasswordRecovery"
 template=".default"
 LoginLink="Auth.aspx?auth_page=login"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к скрипту авторизации | LoginLink | Указывается путь к скрипту авторизации пользователя.


Восстановление пароля с помощью контрольной строки

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Восстановление пароля с помощью контрольной строки

Компонент выводит форму для восстановления пароля с помощью контрольной строки. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="systempasswordrecoveryalt1"
 runat="server"
 componentname="bitrix:system.PasswordRecoveryAlt"
 template=".default"
 PasswordRecoveryCodeLink="Auth.aspx?auth_page=recoverycode"
 LoginLink="Auth.aspx?auth_page=login"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к скрипту ввода контрольного слова | PasswordRecoveryCodeLink | Указывается путь к скрипту ввода контрольного слова.
Путь к скрипту авторизации | LoginLink | Указывается путь к скрипту авторизации пользователя.


Восстановление пароля с помощью контрольной строки (ввод)

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Восстановление пароля с помощью контрольной строки (ввод)

Компонент предназначен для восстановления пароля с помощью ввода контрольной строки. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="systempasswordrecoveryaltcode1"
 runat="server"
 componentname="bitrix:system.PasswordRecoveryAltCode"
 template=".default"
 LoginLink="Auth.aspx?auth_page=login"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Путь к скрипту авторизации | LoginLink | Указывается путь к скрипту авторизации пользователя.


Регистрация

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Регистрация

Компонент выводит форму регистрации нового пользователя. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="systemregister1"
 runat="server"
 componentname="bitrix:system.register"
 template=".default"
 DoAuthentication="True"
 RedirectUrl=""
 FirstNameFieldMode="require"
 LastNameFieldMode="require"
 DisplayNameFieldMode="hide"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Аутентифицировать пользователя после регистрации | DoAuthentication | [True|False] При отмеченной опции пользователь после регистрации будет авторизован.
Ссылка перехода после успешной регистрации | RedirectUrl | Адрес ссылки, по которой будет осуществлен переход после успешной регистрации.
Настройка полей
Имя FirstNameFieldMode Указывается способ отображения поля:
  • Скрыть (hide) - поле будет скрыто;
  • Показать (show) - поле будет отображено;
  • Требовать (require) - поле будет отображено, а также обязательным для заполнения.
Фамилия LastNameFieldMode Указывается способ отображения поля:
  • Скрыть (hide) - поле будет скрыто;
  • Показать (show) - поле будет отображено;
  • Требовать (require) - поле будет отображено, а также обязательным для заполнения.
Псевдоним DisplayNameFieldMode Указывается способ отображения поля:
  • Скрыть (hide) - поле будет скрыто;
  • Показать (show) - поле будет отображено;
  • Требовать (require) - поле будет отображено, а также обязательным для заполнения.


Редактирование профиля

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Редактирование профиля

Компонент выводит форму редактирования профиля пользователя. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="userprofile_edit1"
 runat="server"
 componentname="bitrix:user.profile.edit"
 template=".default"
 UserId="0"
 EditFields="'LastName';'FirstName';'SecondName';'Gender';'BirthdayDate';'DisplayName';'Image';'Password';'BitrixForum_Signature'"
 RequiredFields="'LastName';'FirstName';'SecondName';'Gender';'BirthdayDate';'DisplayName';'Image';'Password';'BitrixForum_Signature'"
 RedirectPageUrl=""
 ProfileUrlTemplate="profile.aspx?user=#UserId#"
 SuccessMessage="Изменения сохранены"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Идентификатор пользователя (0 - текущий) | UserId | Указывается идентификатор пользователя. Если в поле указать 0, то будет выведена форма редактирования профиля текущего пользователя.
Редактируемые поля | EditFields | Указываются поля профиля пользователя, которые будут доступны пользователю для редактирования.
Обязательные поля | RequiredFields | Указываются поля формы редактирования профиля пользователя, информация которых будет обязательной для заполнения.
Дополнительные настройки
Ссылка на страницу перенаправления | RedirectPageUrl | Указывается адрес страницы, на которую будет осуществлен переход после сохранения изменеий.
Шаблон ссылки на профиль пользователя | ProfileUrlTemplate | Указывается шаблон ссылки на профиль пользователя.
Сообщение при успешном сохранении | SuccessMessage | Указывается текст сообщения, который будет отображен на странице при успешном сохранении профиля пользователя.


Просмотр профиля

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Просмотр профиля

Компонент выводит форму просмотра профиля пользователя. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="userprofile_view1"
 runat="server"
 componentname="bitrix:user.profile.view"
 template=".default"
 UserId="0"
 Fields="'LastName';'FirstName';'SecondName';'Gender';'BirthdayDate';'DisplayName';'Image';'BitrixForum_Posts';'BitrixForum_Signature'"
 EditProfileTitle="Изменить"
 EditProfileUrlTemplate="profileedit.aspx?user=#UserId#"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Идентификатор пользователя (0 - текущий) | UserId | Указывается идентификатор пользователя. Если в поле указать 0, то будет выведена форма просмотра профиля текущего пользователя.
Поля для показа | Fields | Указываются поля формы просмотра профиля пользователя, информация которых будет отображена.
Дополнительные настройки
Заголовок ссылки на страницу редактирования профиля пользователя | EditProfileTitle | Указывается заголовок ссылки (название ссылки) на страницу редактирования профиля пользователя.
Шаблон ссылки на страницу редактирования профиля пользователя | EditProfileUrlTemplate | Указывается шаблон ссылки на страницу редактирования профиля пользователя.


Список пользователей

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Список пользователей

Компонент выводит список пользователей сайта. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="userlist1"
 runat="server"
 componentname="bitrix:user.list"
 template=".default"
 UserProfileUrlTemplate="UserProfile.aspx?id=#UserId#"
 FilterByNameToShowUp=""
 FilterByGender="None"
 FilterByMonthOfBirth=""
 FilterByDayOfBirth=""
 SortBy="NameToShowUp"
 SortDirection="Asc"
 ProhibitedUserIds=""
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 CacheMode="None"
 CacheDuration="30"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Шаблон ссылки на профиль пользователя | UserProfileUrlTemplate | Указывается шаблон ссылки на профиль пользователя сайта.
Фильтровать по отображаемому имени | FilterByNameToShowUp | Указвается отображаемое имя, по которому будет отфильтрован список пользователей.
Фильтровать по полу FilterByGender Указывается порядок фильтрации списка по полу:
  • [без фильтрации] (None);
  • мужской (Male);
  • женский (Female).
Фильтровать по месяцу даты рождения | FilterByMonthOfBirth | Указывается месяц даты рождения (число от 01 до 12), по которому будет отфильтрован список пользователей.
Фильтровать по дню даты рождения | FilterByDayOfBirth | Указывается день даты рождения, по которому будет отфильтрован список пользователей.
Сортировка по свойству SortBy Указывается порядок сортировки по свойству:
  • Отображаемое имя (NameToShowUp);
  • Дата регистрации (CreationDate).
Направление сортировки SortDirection Указывается направление сортировки:
  • по возрастанию (Asc);
  • по убыванию (Desc).
Скрывать указанных пользователей (ИД пользователей через запятую) | ProhibitedUserIds | Пользователи (идентификаторы пользователей), указанные в данном поле через запятую будут скрыты (не будут отображены в списке).
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка пользователей сайта.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страинц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество записей списка пользователей сайта, отображаемых на одной странице. Весь список блогов будет выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ списка пользователей сайта. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу в списке.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам в списке.
Настройки кеширования
Тип кеширования CacheMode Указывается тип кеширования:
  • Авто (Auto) - действует при включенном кешировании в течение заданного времени;
  • Кешировать (Custom) - для кеширования необходимо определить время кеширования;
  • Не кешировать (None) - кеширования нет в любом случае.
Время кеширования (сек.) | CacheDuration | Указывается время кеширования RSS ленты в секундах.


Описание модуля

Главный модуль обеспечивает общее функционирование системы, взаимодействие всех модулей продукта и позволяет создавать, поддерживать и управлять неограниченным числом сайтов.

Модуль включает в себя следующие компоненты:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Включаемые области
Вставка включаемой области | includeArea | Располагается в шаблоне дизайна сайта и определяет место расположения включаемых областей страниц и разделов.
Навигация
Навигационная цепочка | system.PublicBreadCrumb | Выводит навигационную цепочку в шаблоне.
Меню | system.PublicMenu | Выводит меню указанного типа.
Карта сайта | system.PublicSiteMap | Осуществляет отображение карты сайта.
Выбор сайта | system.siteselector | Служит для переключения между сайтами, созданными на базе данной копии продукта.


Языки интерфейса

В этом разделе

  • Контекстная панель
  • Список языков
    •

    Одной из важных особенностей продукта "1С-Битрикс: Управление сайтом ASP.NET" является поддержка произвольного количества языков. Система позволяет:

    • использовать многоязычный интерфейс в административном разделе;
    • создавать произвольное количество сайтов на различных языках в рамках одной системы.

    Выбор текущего языка административного раздела сайта осуществляется с помощью меню на административной панели:

    Управление языками административного интерфейса системы осуществляется на странице Языки интерфейса (Настройки > Настройки продукта > Языки интерфейса).

    Контекстная панель

    Кнопка | Описание
Добавить | Переход к форме создания записи о новом языке.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.

    Список языков

    Поле | Описание
    Колонка флажков | Поле предназначено для выбора языков, к которым предполагается применить какое-либо правило или действие.
    Действия Операции, которые можно произвести с языком:
    • Изменить - переход к форме редактирования параметров языка;
    • Добавить копию - копирование (дуплицирование) языка;
    • Удалить - удаление языка.
    ID | Идентификатор языка в системе.
    Акт. | Признак активности. Если язык не активен, то отображение сообщений на данном языке недоступно.
    Сорт. | Относительный вес, определяющий положение языка в списке.
    Название | Произвольное название языка.
    По умолчан. | Признак использования языка по умолчанию. При открытии сайта все языковые сообщения будут именно на этом языке.
    Языковая культура Вид используемой на сайте языковой культуры.

    Примечание: под языковой культурой понимается не только язык сайта, но и способы задания дат, времени и кодировка.


Создание и редактирование языка

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Кнопки управления

    • Контекстная панель

    Кнопка | Описание
Список языков | Переход на страницу со списком языков.
Добавить язык | Переход к форме создания нового языка. Кнопка отображается при редактировании существующего языка.
Добавить копию | Копирование редактируемого языка. Кнопка отображается при редактировании существующего языка.
Удалить | Удаление редактируемого языка. Кнопка отображается при редактировании существующего языка.

    Форма редактирования

    Форма предназначена для управления параметрами языка.

    Поле | Описание
*ID | Идентификатор языка в системе. Используется для загрузки соответствующих языковых файлов, поэтому должен совпадать с идентификатором языка в системе обновлений.
Активен | Признак активности языка. Если язык неактивен, то отображение сообщений на данном языке недоступно.
*Название | Название языка.
По умолчанию | При отмеченной опции все языковые сообщения будут отображаться на этом языке.
*Сортировка | Относительный "вес", определяющий положение языка в списке.
Языковая культура | Вид используемой на сайте языковой культуры. Примечание: под языковой культурой понимается не только язык сайта, но и способы задания дат, времени и кодировка.

    * - поля, обязательные для заполнения.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Переход на страницу со списком языков.
Применить | Применение внесённых изменений. Продолжение редактирования параметров языка.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Модули

Страница Модули (Настройки > Настройки продукта > Модули) служит для инсталляции и деинсталляции модулей системы. Например, если не используется модуль Блог, то вы можете его деинсталлировать, чтобы он не занимал ресурсы системы и место в меню. Позднее вы сможете инсталлировать его вновь (дистрибутив модуля сохраняется в системе).

Поле | Описание
Действия Доступные действия над модулем:
  • Удалить;
  • Установить.
Имя модуля | Название модуля.
Версия | Текущая версия модуля.
Описание | Краткое описание предназначения модуля.
Статус Текущий статус модуля:
  • Установлен;
  • Не установлен.

Обратите внимание, что некоторые модули при деинсталляции предлагают удалить накопленные ими данные. Если в дальнейшем вы планируете использовать эти данные, то при деинсталляции модуля следует не отмечать опцию Удалить таблицы базы данных.


Настройки (Главный модуль)

  • Форма настройки модуля
  • Настройка параметров модуля
  • Управление структурой
  • Пользователи
  • Кнопки управления

    • Форма Настройки модуля служит для управления глобальными настройками как сайта в целом, так и каждого модуля в отдельности. Для удобства работы форма разделена на закладки. Каждая закладка содержит логически сгруппированный набор полей, позволяющих выполнять определённые действия по настройке выбранного модуля.

    Перейти к форме настройки модулей можно, нажав кнопку Настройки на административной панели, либо из административного меню: Настройки > Настройки продукта > Настройки модулей > <имя_модуля>.

    Глобальные настройки модулей системы зависят от характера этих модулей и описаны в соответствующих разделах помощи:

    • Блог;
    • Информационные блоки;
    • Поиск.

    Следующие модули не имеют форм настроек:

    • Реклама, баннеры;
    • Инструменты для общения;
    • Форум.

    Ниже приводится описание настроек Главного модуля.

    Форма настройки модуля

    Закладка "Настройка параметров модуля"

    Вкладка позволяет выполнить настройки общих параметров Главного модуля.

    Поле | Описание
Системные настройки
Название сайта | Название сайта.
Выполнять автокеширование | При отмеченной опции будет выполняться автокеширование.
Включить обработку 404 ошибки | При отмеченной опции будет включена обработка 404 ошибки.
Обрабатывать стандартные исключения из правил ЧПУ | При отмеченной опции будут обрабатываться стандартные исключения из правил ЧПУ.
Файлы
Пользовательские расширения исполняемых файлов (через запятую) | Указываются пользовательские расширения исполняемых файлов через запятую.
Пользовательские расширения файлов, которые не являются исполняемыми (через запятую) | Указываются пользовательские расширения файлов, которые не являются исполняемыми (через запятую).
Сохранять исходные имена загружаемых файлов | При отмеченной опции исходные имена загружаемых файлов будут сохранены.
Автоматически заменять невалидные символы в именах загружаемых файлов | При отмеченной опции невалидные символы в именах загружаемых файлов будут автоматически заменены.
Карта сайта
Тип меню карты сайта (верхний уровень) | Название типа меню карты сайт, пункты которого будут использоваться в качестве вершин карты сайта.
Тип меню карты сайта (остальные уровни) | Название типа меню карты сайт, пункты которого будут использоваться в качестве ветвей карты сайта.
Почта
Имя хоста SMTP-сервера | Указывается имя хоста SMTP-сервера.
Порт SMTP-сервера | Порт SMTP-сервера. Порт зависит от типа соединения, 25 - для обычного и 465 - для зашифрованного (с использованием SSL).
Имя пользователя | Имя пользователя SMTP-сервера.
Пароль | Пароля пользователя SMTP-сервера.
Email отправителя по умолчанию | Указывается E-mail отправителя по умолчанию, на который будет осуществляться пересылка.
Использовать SSL | При отмеченной опции будет использоваться поддержка SSL аутентификации при отправке писем.

    Закладка "Управление структурой"

    Поле | Описание
    Настройки редактора
    Кодировка по умолчанию | В списке выбирается кодировка редактора по умолчанию.
    Редактор для страниц по умолчанию Указывается тип редактора страниц по умолчанию:
    • Текстовый редактор - страницы можно будет редактировать как исходный текст файла. Режим предназначен для использования разработчиками.
    • Визуальный редактор - страницы можно будет редактировать встроенным визуальным редактором, позволяющим форматировать текст аналогично Microsoft Word.
    Основная редактируемая область в шаблоне сайта | Указывается основная редактируемая область в шаблоне сайта.
    Родительский класс для создаваемых страниц | Задается родительский класс для создаваемых страниц.
    Генерировать предварительный просмотр компонентов в визуальном редакторе | При отмеченной опции в визуальном редакторе будет генерироваться предварительный просмотр компонентов.
    Настройки для сайтов
    Настройки для сайта | В выпадающем списке доступны все созданные в системе сайты. Для каждого из созданных в системе сайтов могут быть заданы индивидуальные Типы меню и Свойства страницы.
    Типы меню Указываются используемые на сайте типы меню и их описания.
    Поле | Описание
Тип | Тип (мнемоническое имя) используемого на сайте меню. Обычно мнемонические имена типов меню назначаются, исходя из расположения меню на странице сайта (например, top, left и т.д.). Имя типа меню указывается латинскими буквами.
Название | Произвольное название (описание) типа меню.
    Свойства страницы Форма служит для создания свойств страниц сайта и задания их описания.
    Поле | Описание
Тип | Тип (мнемоническое имя) свойства. Указывается латинскими буквами.
Название | Произвольное название (описание) свойства. Указанное название будет отображаться в форме задания значений свойств для папки или страницы.

    Примечание: мнемонические имена типов свойств, используемых для управления метаданными страницы, должны соответствовать названиям соответствующих мета-тегов. Например, ключевые слова - keywords, описание - description.

    Закладка "Пользователи"

    Поле | Описание
Настройки аватара
Максимальный размер изображения (Кбайт) | Указвается максимальный размер изображения аватара в Кб.
Максимальная ширина изображения (в пикселах) | Указвается максимальная ширина изображения аватара в пикселах.
Максимальная высота изображения (в пикселах) | Указвается максимальная высота изображения аватара в пикселах.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений.
Применить | Применение внесённых изменений. Продолжение редактирования параметров модуля.


Обработка адресов

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список правил обработки адресов
    •

    Обработка адресов (UrlRewrite) применяется для того, чтобы скрипт мог отвечать не только по своему физическому, но и по любому другому указанному адресу. Адрес, по которому будет отвечать скрипт, не должен физически существовать на сервере. Если такой адрес физически существует, то будет вызван скрипт по этому адресу. Система обработки адресов запущена в этом случае не будет.

    Управление правилами преобразования адресов осуществляется на странице Обработка адресов (Настройки > Настройки продукта > Обработка адресов).

    Форма поиска

    Форма используется для выбора из списка правил обработки в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

    Поле | Описание
Сайт | Сайт, к которому принадлежит данное правило.
Шаблон совпадения | Регулярное выражение, которое используется для проверки совпадения правила.
Шаблон переадресации | Выражение замены, при помощи которого будет обработан адрес запроса.
Страница переадресации | Страница, на которую будет осуществлен переход при запросе.
Тип компонента | Имя компонента, создавшего правило.
Вспомогательный ID | Вспомогательный идентификатор.

    Чтобы отобрать правила по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех правил нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Добавить | Переход к форме создания нового правила обработки адресов.
Перезагрузить | При нажатии кнопки будут перегружены правила ЧПУ из файла, который хранится в корне сайта и имеет имя sef.<идентификатор_сайта>.config.
Обновить ЧПУ | При нажатии кнопки будут обновлены правила ЧПУ для всех компонентов на сайте.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список правил обработки адресов

    Поле | Описание
    Колонка флажков | Выбор правил, к которым предполагается применить какое-либо правило или действие.
    Действия Действия, которые можно произвести над правилами:
    • Редактировать - переход к форме редактирования параметров правила обработки адресов;
    • Удалить - удаление правила.
    Шаблон совпадения | Регулярное выражение, которое используется для проверки совпадения правила.
    Шаблон переадресации | Выражение замены, при помощи которого будет обработан адрес запроса.
    Тип компонента | Имя компонента, создавшего правило.
    Страница переадресации | Страница, на которую будет осуществлен переход при запросе.
    Вспомогательный ID | Вспомогательный идентификатор. Назначение идентификатора оставлено на усмотрение разработчика.
    Сайт | Сайт, к которому принадлежит данное правило.
    Сортировка | Индекс сортировки правила, определяющий его положении в списке.
    Исключить? | Отображает является ли правило исключением из правил обработки адресов.


Создание и редактирование правила обработки адресов

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Кнопки управления

    • Контекстная панель

    Кнопка | Описание
Список сайтов | Переход на страницу со списком правил обработки адресов.

    Форма редактирования

    Форма предназначена для управления параметрами сайта.

    Поле | Описание
Тип компонента | Имя компонента, создавшего правило. Поле отображается при редактировании существующего правила.
Страница переадресации | Страница, на которую будет осуществлен переход при запросе. Поле отображается при редактировании существующего правила.
Сайт | Указывается сайт, к которому принадлежит данное правило.
*Шаблон совпадения | Указывается регулярное выражение, которое используется для проверки совпадения правила.
Исключить правило из обработки | При отмеченной опции правило будет исключено из правил обработки адресов.
Шаблон переадресации | Выражение замены, при помощи которого будет обработан адрес запроса. Поле отображается при редактировании существующего правила.
Порядок сортировки | Указывается индекс сортировки правила, определяющий его положении в списке.
Вспомогательный ID | Вспомогательный идентификатор. Назначение идентификатора оставлено на усмотрение разработчика.

    * - поля, обязательные для заполнения.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Возврат к списку правил обработки адресов.
Применить | Применение внесённых изменений. Продолжение редактирования параметров сайта.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Пользовательские поля

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список пользовательских полей
    •

    На странице Пользовательские поля (Настройки > Настройки продукта > Пользовательские поля) можно добавлять новые поля, просматривать и изменять существующие, удалять ненужные. Вывод значений пользовательских полей в публичной части производится с помощью API продукта.

    Форма поиска

    Поиск пользовательских полей в соответствии с указанными условиями.

    Поле | Описание
    Найти | Позволяет найти пользовательские поля по их основным параметрам: идентификатору или объекту. Это поле присутствует, даже если фильтр свернут.
    ID | Поиск поля по ID записи.
    Объект | Поиск полей по объекту, например, USER, USER_PROPERTY и т.д.
    Название поля | Поиск поля можно задать по названию.
    Тип данных Поиск поля можно задать по типу данных. Предлагается следующий набор типов данных:
    • Вещественное число;
    • Да/Нет;
    • Дата/Время;
    • Перечисление;
    • Список;
    • Ссылка на раздел инфоблока;
    • Ссылка на элемент инфоблока;
    • Строка;
    • Уникальный идентификатор;
    • Файл;
    • Целое число.
    XML_ID | Поиск можно задать по внешнему идентификатору XML_ID.
    Множественное | Поиск по признаку, является ли поле множественным, т.е. можно ли задать несколько значений одного поля.
    Обязательное | Поиск по признаку, является ли поле обязательным для заполнения.
    Фильтр Способ отображения поля в фильтре:
    • Не показывать;
    • Точное совпадение;
    • Поиск по маске;
    • Поиск по подстроке.
    Показывать в списке | Поиск по признаку, показывать ли данное поле в списке по месту применения.
    Разрешать редактирование | Поиск по признаку, можно ли редактировать данное поле пользователем.
    Участвует в поиске | Поиск по признаку, участвуют ли значения поля в поиске.

    Чтобы отобрать пользовательские поля по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех пользовательских полей нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Добавить | Переход к форме добавления пользовательского поля.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список пользовательских полей

    Поле | Описание
    Колонка флажков | Поле предназначено для выбора пользовательских полей, к которым предполагается применить какое-либо правило или действие.
    Действия Операции, которые можно произвести над пользовательских полей:
    • Редактировать - переход к форме редактирования параметров поля;
    • Удалить - удаление поля.
    ID | Уникальный идентификатор пользовательского поля.
    Объект | Данное поле заполняется автоматически при переходе к созданию поля с места применения (например из формы редактирования пользователя, значение объекта - USER). Либо заполняется вручную при создании поля со страницы Пользовательские поля.
    Название поля | Код поля. Можно задать только для нового поля. Задается только латинскими буквами.
    Тип данных Один из доступных типов данных:
    • Вещественное число;
    • Да/Нет;
    • Дата/Время;
    • Перечисление;
    • Список;
    • Ссылка на раздел инфоблока;
    • Ссылка на элемент инфоблока;
    • Строка;
    • Уникальный идентификатор;
    • Файл;
    • Целое число.
    Сорт. | Индекс сортировки, определяющий положение поля в общем списке.
    XML_ID | Внешний XML идентификатор поля.
    Множественное | Признак множественности поля.
    Обязательное | Признак обязательности поля для заполнения.
    Фильтр | Выводится способ отображения поля в фильтре.
    Показывать в списке | Параметр определяет показывать поля в списке дополнительных полей той или иной формы или нет.
    Разрешать редактирование | Параметр определяет разрешать редактирование поля или нет.
    Участвует в поиске | Признак участия значений поля в поиске в публичной части сайта.


Создание и редактирование пользовательского поля

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Кнопки управления

    • Контекстная панель

    Кнопка | Описание
Назад | Переход к списку пользовательских полей.

    Форма редактирования

    Форма предназначена для управления параметрами пользовательского поля.

    Поле | Описание
    ID | Уникальный идентификатор пользовательского поля. Присваивается после сохранения.
    *Тип данных (можно задать только для нового поля) Выбирается один из возможных типов данных:
    • Вещественное число;
    • Да/Нет;
    • Дата/Время;
    • Перечисление;
    • Список;
    • Ссылка на раздел инфоблока;
    • Ссылка на элемент инфоблока;
    • Строка;
    • Уникальный идентификатор;
    • Файл;
    • Целое число.
    В зависимости от выбранного типа секция Дополнительные настройки поля будет иметь различный вид.
    *Объект | Код объекта, к которому относится поле.
    *Код поля (можно задать только для нового поля) | Код самого поля. Можно задать только для нового поля.
    XML_ID | Указывается идентификатор поля для работы с внешними источниками.
    Сортировка | Индекс сортировки, определяющий положение поля в общем списке.
    Множественное (можно задать только для нового поля) | При отмеченной опции значение поля будет множественным. Указывается только для нового поля.
    Обязательное | При отмеченной опции поле будет обязательным для заполнения.
    Показывать в фильтре списка Выбирается одна из возможностей:
    • Не показывать - поле не будет показано в фильтре;
    • Точное совпадение - поле будет показано в фильтре. Для нахождения элемента требуется точное совпадение условию поиска;
    • Поиск по маске - поле будет показано в фильтре. Для поиска элемента в списке по данному полю можно использовать маску;
    • Поиск по подстроке - поле будет показано в фильтре. Для нахождения элемента выполнятся поиск по подстроке.
    Не показывать в списке | При отмеченной опции поле не будет отображаться в списке элементов в месте применения.
    Не разрешать редактирование пользователем | При отмеченной опции значение поля нельзя редактировать, только вычислять и устанавливать через API.
    Значения поля участвуют в поиске | При отмеченной опции значения поля будут участвовать в поиске в публичной части после переиндексации сайта.
    Дополнительные настройки поля (зависят от типа)
    Вещественное число
    Точность (количество знаков после запятой) | Определяется точность числа - количество знаков после запятой.
    Значение по умолчанию | Можно определить значение по умолчанию.
    Ширина поля ввода (в символах) | Указывается ширина поля в символах, каким он будет отображен в форме, где используется данное поле.
    Минимальное значение (пустое - не проверять) | Можно установить минимальное допустимое значение. Если установлено 0, то не проверять.
    Максимальное значение (пустое - не проверять) | Можно установить максимальное допустимое значение. Если установлено 0, то не проверять.
    Да/Нет
    Значение по умолчанию | Устанавливается, что будет значением по умолчанию, Да или Нет.
    Внешний вид Выбирается один из возможных внешних видов поля:
    • Флажок;
    • Переключатели;
    • Раскрывающийся список.
    Дата/Время
    Значение по умолчанию Выбирается один из возможных вариантов:
    • нет - значения по умолчанию не будет;
    • текущее время - значением по умолчанию будет текущая дата на момент заполнения;
    • также значение по умолчанию может быть установлено вручную с использованием календаря.
    Выводить время | При отмеченной опции будет выведено время.
    Перечисление
    Внешний вид Указывается тип внешнего вида:
    • Список;
    • Флажки.
    Количество строк в списке | Указывается количество строк поля в списке.
    Ссылка на раздел инфоблока
    Количество строк | Укажите количество строк поля.
    Информационный блок | Указывается информационный блок из доступных в системе.
    Ссылка на элемент инфоблока
    Информационный блок | Указывается информационный блок из доступных в системе.
    Строка
    Тип Указывается тип пользовательского поля:
    • Tекст;
    • HTML;
    • Шаблон.
    Если выбран тип Шаблон, то необходимо заполнить поле Шаблон.
    Шаблон | В поле указываются допустимые параметры макроподстановки. Список параметров представлен ниже. Чтобы указать, нажмите поссылке с именем параметра.
    Значение по умолчанию | Можно определить значение по умолчанию.
    Ширина поля ввода (в символах) | Указывается ширина поля ввода в символах, каким он будет отображен в форме, где используется данное поле.
    Количество строчек поля ввода | Укажите количество строчек поля ввода.
    Минимальная длина строки (0 - не проверять) | Есть возможность ограничить размер строки по минимальному значению. Если 0, то не ограничивать.
    Максимальная длина строки (0 - не проверять) | Есть возможность ограничить размер строки по максимальному значению. Если 0, то не ограничивать.
    Регулярное выражение для проверки | Можно ввести регулярное выражение для ограничения вводимых значений поля. Регулярное выражение необходимо ограничить любыми удобными символами, например, /^T.+N$/ либо #^T.+N$#.
    Уникальный идентификатор
    Генерировать GUID по умолчанию | При отмеченной опции будет генерироваться уникальный идентификатор формата GUID.
    Файл
    Ширина поля ввода (в символах) | Указывается ширина поля ввода в символах, каким он будет отображен в форме, где используется данное поле.
    Максимально допустимый размер файла для загрузки (в байтах) | Указывается максимально допустимый размер файла в байтах для загрузки.
    Разрешенные расширения файла (через запятую или пробел, например: jpg,png,bmp) | Указываются допустимые расширения файлов через запятую или пробел. Например: jpg,png,bmp или jpg png bmp.
    Выводить текстовое поле с описанием | При отмеченной опции будет выведено текстовое поле с описанием.
    Целое число
    Значение по умолчанию | Можно определить значение по умолчанию.
    Ширина поля ввода (в символах) | Указывается ширина поля ввода в символах, каким он будет отображен в форме, где используется данное поле.
    Минимальное значение (пустое - не проверять) | Можно установить минимальное допустимое значение. Если установлено 0, то не проверять.
    Максимальное значение (пустое - не проверять) | Можно установить максимальное допустимое значение. Если установлено 0, то не проверять.
    Языковые настройки
    Поле служит для задания языковых настроек пользовательского поля.
    Язык | Подпись в форме редактирования | Заголовок в списке | Подпись фильтра в списке | Сообщение об ошибке (не обязательное) | Помощь
[1] | [2] | [3] | [4] | [5] | [6]
    Поле | Описание
[1] Язык | Перечислены все языки, установленные в системе.
[2] Подпись в форме редактирования | Можно определить для каждого из установленных языков подпись поля в форме редактирования. Если поле пусто в форме редактирования будет выведен код поля.
[3] Заголовок в списке | Можно определить для каждого из установленных языков подпись поля в списке, т.е. в отчетной форме. Если поле пусто в списке поле будет представлено кодом (в случае, если настроено, что поле должно отображаться в списке).
[4] Подпись фильтра в списке | Можно определить для каждого из установленных языков подпись поля в фильтре, т.е. как поле будет отображено в форме поиска. Если поле пусто в фильтре поле будет представлено кодом (в случае, если настроено, что поле должно отображаться в фильтре).
[5] Сообщение об ошибке | Сообщение об ошибке, которое будет выводиться в форме, где применяется поле. Действует для типа данных Строка, например, при несоответствии введенного значения регулярному выражению, определённому для поля.
[6] Помощь | Поле для ввода сообщений помощи. Поле ведется внутри системы, но пока нигде не выводится. Вы можете вывести его самостоятельно там, где необходимо.

    * - поля, обязательные для заполнения.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Возврат к списку пользовательских полей.
Применить | Применение внесённых изменений. Продолжение редактирования параметров поля.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Создание и редактирование шаблона сайта

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Сайты

  • Создание и редактирование сайта
  • Создание и редактирование шаблона сайта
  • Список сайтов
  • Шаблоны сайта


Список сайтов

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список сайтов
    •

    Добавление, изменение и удаление сайтов в системе выполняется с помощью формы управления сайтами на странице Список сайтов (Настройки > Настройки продукта > Сайты > Список сайтов).

    Форма поиска

    Поиск сайтов в соответствии с указанными условиями.

    Поле | Описание
Название | Название сайта.
Языки | Поиск можно задать по всем языкам, доступным в системе, или по одному выбранному.
Активен | Поиск можно задать по активным, неактивным или всем сайтам.
ID | Идентификатор сайта.

    Чтобы отобрать сайты по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех сайтов нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Добавить | Переход к форме создания нового сайта.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список сайтов

    Поле | Описание
    Колонка флажков | Выбор сайтов, к которым предполагается применить какое-либо правило или действие.
    Действия Действия, которые можно произвести над сайтом:
    • Изменить - переход к форме редактирования параметров сайта;
    • Копировать - копирование сайта;
    • Удалить - удаление сайта.
    ID | Идентификатор сайта в системе.
    Акт. | Признак активности. Если сайт неактивен, то он становится недоступным.
    Сорт. | Относительный вес, определяющий положение сайта в списке.
    Название | Произвольное название сайта.
    Папка | Путь к папке сайта. Ядро системы позволяет использовать относительные типы URL (/ru/, /s2/) для работы зеркал сайта на одном домене под управлением одной системы.
    По умолчанию | Сайт, загружаемый системой по умолчанию.


Создание и редактирование сайта

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Кнопки управления

    • Контекстная панель

    Кнопка | Описание
Список сайтов | Переход на страницу со списком сайтов.
Добавить сайт | Переход к форме создания нового сайта. Кнопка отображается при редактировании существующего сайта.
Копировать сайт | Копирование редактируемого сайта. Кнопка отображается при редактировании существующего сайта.
Удалить сайт | Удаление редактируемого сайта. Кнопка отображается при редактировании существующего сайта.

    Форма редактирования

    Форма предназначена для управления параметрами сайта.

    Поле | Описание
    *ID | Идентификатор сайта в системе.
    Активен | Активность сайта. Если сайт неактивен, то он недоступен.
    *Название | Название сайта.
    Параметры для определения сайта в публичном разделе
    *Язык | Язык, используемый для представления информации на страницах сайта.
    По умолчанию | При отмеченной опции сайт будет загружаться по умолчанию.
    Доменное имя (список доменных имен, каждое в новой строке) | Доменное имя или список доменных имен сайта (каждое с новой строки).
    Папка сайта | Путь к папке сайта. Ядро системы позволяет использовать относительные типы URL (/ru/, /s2/) для работы зеркал сайта на одном домене под управлением одной системы.
    *Сортировка | Относительный вес, влияющий на положение сайта в списке.
    Параметры
    Языковая культура Вид используемой на сайте языковой культуры.

    Примечание: под языковой культурой понимается не только язык сайта, но и способы задания дат, времени и кодировка.
    *Название сайта | Произвольное название сайта.
    URL сервера (без http://) | URL сервера, на котором размещён сайт (указывается без http://). Используется в почтовых сообщениях для идентификации отправителя (например, для автоматически сгенерированных сообщений).
    E-Mail адрес по умолчанию | Адрес отправителя сообщений сайта.
    Шаблон
    Поле служит для задания условий применения того или иного шаблона дизайна к страницам сайта.
    *Шаблон | Сорт. | Тип условия | Условие
[1] | [2] | [3] | [4]
    Поле | Описание
    [1] Шаблон | Список доступных шаблонов сайта.
    [2] Сортировка | Относительный "вес", влияющий на положение записи с условием применения шаблона в списке.
    [3] Тип условия Тип условия, при выполнении которого шаблон будет применяться к страницам сайта:
    • [без условия]: шаблон будет применяться без какого-либо условия;
    • Для папки или файла: страница или раздел, при отображении страниц которого будет использоваться данный шаблон;
    • Для ролей пользователей: роли пользователей, для которых страницы сайта будут отображаться с использованием данного шаблона;
    • Период времени: дата или период времени, в течение которого страницы сайта будут отображаться с использованием данного шаблона;
    • Параметр в URL: параметр в URL страницы, при наличии которого к странице будет применен данный шаблон.
    [4] Условие Условие, при котором шаблон будет применяться к страницам сайта.

    Примечание: для того чтобы выбранный шаблон дизайна применялся к страницам сайта по умолчанию, это поле нужно оставить пустым.

    * - поля, обязательные для заполнения.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Возврат к списку сайтов.
Применить | Применение внесённых изменений. Продолжение редактирования параметров сайта.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Шаблоны сайта

В этом разделе

  • Контекстная панель
  • Список шаблонов
    •

    Шаблон дизайна - это внешний вид сайта, в котором определяется расположение различных элементов на сайте, художественный стиль и способ отображения страниц. Включает в себя программный код, графические компоненты, таблицы стилей и дополнительные шаблоны для отображения контента.

    Управление шаблонами осуществляется на странице Шаблоны сайта (Настройки > Настройки продукта > Сайты > Шаблоны сайтов). С ее помощью вы можете создавать новые, изменять и удалять существующие шаблоны дизайна сайта.

    Контекстная панель

    Кнопки | Название
Добавить | Переход на страницу с формой создания нового шаблона сайта.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список шаблонов

    Поле | Название
    Колонка флажков | Поле предназначено для выбора шаблонов сайта, к которым предполагается применить какое-либо правило или действие.
    Действия Операции с шаблоном:
    • Изменить - переход к форме редактирования шаблона дизайна;
    • Копировать - копирование (дуплицирование) шаблона;
    • Удалить - удаление шаблона.
    ID | Идентификатор шаблона дизайна в системе.
    Название | Произвольное название шаблона.
    Описание | Произвольное описание шаблона.


Создание и редактирование шаблона сайта

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Шаблон
  • Стили сайта
  • Стили шаблона
  • Дополнительные файлы
  • Кнопки управления

    • Контекстная панель

    Кнопка | Описание
Список шаблонов | Переход на страницу со списком шаблонов сайта.
Добавить шаблон | Переход к форме создания нового шаблона. Кнопка отображается при редактировании существующего шаблона.
Копировать шаблон | Копирование редактируемого шаблона. Кнопка отображается при редактировании существующего шаблона.
Удалить шаблон | Удаление редактируемого шаблона. Кнопка отображается при редактировании существующего шаблона.

    Форма редактирования

    Для удобства работы форма создания шаблона разделена на несколько закладок. На каждой закладке выполняется определённая группа действий по настройке шаблона.

    Закладка "Шаблон"

    Поле | Описание
*ID | Идентификатор шаблона сайта. При редактировании шаблона рядом с данным полем отображается ссылка на папку шаблона. Примечание: при создании новый шаблон будет автоматически сохранен в каталоге /bitrix/templates/ в папке с именем, соответствующим идентификатору шаблона.
Название | Произвольное название шаблона.
Описание | Произвольное описание шаблона.
*Внешний вид шаблона сайта
Поле служит для создания и редактирования кода шаблона. Примечание: опция Использовать визуальный редактор служит для подключения визуального режима редактирования шаблона.

    * - поля, обязательные для заполнения.

    Закладка "Стили сайта"

    Файл стилей сайта (styles.css)
    Данное поле служит для описания таблиц каскадных стилей (CSS), используемых на страницах сайта. Описание стилей хранится в файле styles.css в папке шаблона сайта.

    Закладка "Стили шаблона"

    Файл стилей шаблона (template_styles.css)
    Данное поле служит для описания таблиц каскадных стилей (CSS), используемых в шаблоне. Описание стилей хранится в файле template_styles.css в папке шаблона сайта.

    Закладка "Дополнительные файлы"

    Дополнительные файлы (включаемые области, картинки)
    В поле указываются дополнительные файлы (картинки, шаблоны меню, шаблоны включаемых областей и др.), используемые для текущего шаблона сайта. С помощью ссылки Изменить можно перейти к редактированию существующего файла.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Возврат к списку шаблонов сайта.
Применить | Применение внесённых изменений. Продолжение редактирования параметров шаблона сайта.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Типы почтовых событий

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Почтовые события

  • Почтовые шаблоны
  • Создание и редактирование почтового шаблона
  • Типы почтовых событий


Почтовые шаблоны

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список почтовых шаблонов
    •

    При возникновении на сайте события на отправку какого-либо письма, система ищет подходящий шаблон для такого письма. Если шаблон найден, то письмо отправляется в соответствии с этим шаблоном.

    Управление почтовыми шаблонами сайтов в системе выполняется на странице Почтовые шаблоны (Настройки > Настройки продукта > Почтовые события > Почтовые шаблоны).

    Форма поиска

    Поиск почтовых шаблонов в соответствии с указанными условиями.

    Поле | Описание
Найти | Поле позволяет найти требуемые почтовые шаблоны по наиболее типичным критериям, выбираемым в списке: Тема, Отправитель, Получатель или Содержимое шаблона.
ID | Идентификатор почтового шаблона.
Тип почтового события | Поиск шаблона по типу почтового события, к которому он относится.
Дата изменения (DD.MM.YYYY) | Интервал даты последнего изменения почтового шаблона.
Сайт | Сайт(ы), на котором используется почтовый шаблон.
Активность | Поиск только активных, только неактивных или всех почтовых шаблонов.
От кого | Адрес отправителя почтового сообщения.
Кому | Адрес получателя почтового сообщения.
Скрытая копия (BCC) | Адрес получателя скрытой копии сообщения.
Тема | Поиск шаблона по теме почтового сообщения.
Тип тела сообщения | Поиск по типу тела сообщения: Html, Текст или по обоим типам.
Тело сообщения | Поиск шаблона по содержимому тела сообщения.

    Чтобы отобрать шаблоны по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех шаблонов нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Добавить | Переход к форме создания нового почтового шаблона.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список почтовых шаблонов

    Поле | Описание
    Колонка флажков | Выбор шаблонов, к которым предполагается применить какое-либо правило или действие.
    Действия Действия, которые можно произвести над шаблонами:
    • Редактировать - переход к форме редактирования параметров почтового шаблона;
    • Добавить копию - копирование почтового шаблона;
    • Удалить - удаление почтового шаблона.
    ID | Идентификатор почтового шаблона.
    Обновлен | Дата и время последнего изменения почтового шаблона.
    Активен | Признак активности. Если шаблон не активен, то данный шаблон не будет использоваться для генерации почтовых сообщений.
    Имя шаблона | Имя почтового шаблона.
    Тема письма | Тема почтового сообщения.
    Список сайтов | Идентификатор сайта, для отправки почтовых сообщений с которого используется данный шаблон.


Создание и редактирование почтового шаблона

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Кнопки управления

    • Контекстная панель

    Кнопка | Описание
Список шаблонов | Переход на страницу со списком шаблонов почтовых сообщений.
Добавить | Переход к форме создания нового почтового шаблона. Кнопка отображается при редактировании существующего почтового шаблона.
Копировать | Копирование редактируемого почтового шаблона. Кнопка отображается при редактировании существующего почтового шаблона.
Удалить | Удаление редактируемого шаблона. Кнопка отображается при редактировании существующего почтового шаблона.

    Форма редактирования

    Форма предназначена для управления параметрами почтового шаблона.

    Поле | Описание
    Последнее обновление | Дата и время последнего изменения почтового шаблона. Поле отображается при редактировании существующего почтового шаблона.
    Активен | При отмеченной опции шаблон будет активен. Если шаблон не активен, то данный шаблон не будет использоваться для генерации почтовых сообщений.
    *Сайты | Сайт (или сайты), для отправки почтовых сообщений с которого используется данный шаблон.
    *Тип почтового события | Код и название типа почтового события, при возникновении которого будет сгенерировано почтовое сообщение на основе данного шаблона.
    *Отправитель ** | Адрес отправителя почтового сообщения.
    *Адресат ** | Адрес получателя почтового сообщения.
    Скрытая копия ** | Адрес получателя скрытой копии сообщения.
    Тема ** | Тема почтового сообщения.
    Тип тела письма Указывается формат тела сообщения:
    • Текст - текстовый формат;
    • HTML - тело сообщения будет представлено в HTML формате.
    Тело сообщения
    Поле для создания информационной части (текста) сообщения.
    Доступные поля
    В данной секции представлены шаблоны переменных (изменяемых данных), которые могут быть подставлены в поля сообщения, отмеченные **.

    Например, в поле Отправитель может быть подставлен шаблон #DEFAULT_EMAIL_FROM#. Это значит, что в качестве адреса отправителя сообщения будет подставляться e-mail адрес, указанный в настройках соответствующего сайта или Главного модуля.

    * - поля, обязательные для заполнения.

    ** - значения данных полей могут быть заданы с помощью шаблонов, представленных в секции Доступные поля.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Возврат к списку почтовых шаблонов.
Применить | Применение внесённых изменений. Продолжение редактирования параметров почтового шаблона.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Типы почтовых событий

На странице Типы почтовых событий (Настройки > Настройки продукта > Почтовые события > Типы почтовых событий) в таблице отображены доступные типы почтовых событий.

Каждый почтовый шаблон привязывается к определённому типу почтового события. Тип определяет набор специальных полей, которые могут быть использованы в почтовом шаблоне. В момент создания почтового события (т.е. готового сообщения) эти поля будут инициализированы конкретными значениями.

Типы почтовых событий создаются кодом в обработчике события Bitrix.Modules.BXSystemEvents.RegisterMailEventTypes.


1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты

  • Включаемые области
  • Навигация


Вставка включаемой области

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Включаемые области

  • Вставка включаемой области


Вставка включаемой области

Компонент располагается в шаблоне дизайна сайта и определяет место расположения включаемых областей страниц и разделов. Компонент может выводить содержимое произвольного файла (например, информацию об авторских правах, название компании и т.д.). Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="includearea1"
 runat="server"
 componentname="bitrix:includeArea"
 template=".default"
 Mode="File"
 FilePath="~/test/copyright.html"
 FileName=""
 FileNameSuffix=""
 RecursiveFileSearch="True"
 AllowEditing="True"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Показывать включаемую область Mode Указывается для чего будет создана включаемая область или откуда будет выведена информация:
  • для страницы (Page) - область будет являться включаемой только для текущей страницы;;
  • для раздела (Section) - область будет являться включаемой для всего раздела;;
  • из файла (File) - показывать информацию из файла. Если компонент расположить в шаблоне дизайна сайта, то информация из файла будет выводиться на всем сайте.
Описание полей для каждого случая в зависимости от выбранного значения приведено ниже.
для страницы
Суффикс имени файла включаемой области | FileNameSuffix | Поле предназначено для указания суффикса, который будет добавляться к именам файлов включаемых областей. Страницы с таким суффиксом будут восприниматься как включаемые области.
Разрешать редактирование через публичный интерфейс | AllowEditing | [True|False] При отмеченной опции файл включаемой области можно будет редактировать в публичном интерфейсе (режимы Редактирование и Разработка).
для раздела
Имя файла области | FileName | Указывается имя файла включаемой области (можно без расширения, так как оно будет определено автоматически). Файл включаемой области может иметь следующие форматы: .ascx, .html, .htm, .txt.
Рекурсивное подключение включаемых областей разделов | RecursiveFileSearch | [True|False] При отмеченной опции если в папке более низкого уровня есть своя включаемая область, то она будет показана. Если текущий раздел не имеет своей включаемой области, то рекурсивно до корня сайта будут проверяться все разделы. Будет выведена первая встретившаяся включаемая область.
Разрешать редактирование через публичный интерфейс | AllowEditing | [True|False] При отмеченной опции файл включаемой области можно будет редактировать в публичном интерфейсе (режимы Редактирование и Разработка).
из файла
Путь к файлу области | FilePath | Указывается путь к файлу включаемой области, в котором храниться выводимая информация. Файл включаемой области может иметь следующие форматы: .ascx, .html, .htm, .txt.
Разрешать редактирование через публичный интерфейс | AllowEditing | [True|False] При отмеченной опции файл включаемой области можно будет редактировать в публичном интерфейсе (режимы Редактирование и Разработка).


Выбор сайта

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Навигация

  • Выбор сайта
  • Карта сайта
  • Меню
  • Навигационная цепочка


Навигационная цепочка

Компонент выводит навигационную цепочку в шаблоне. Настройки этого компонента позволяют регулировать уровень вложенности разделов (корень сайта - ноль). Компонент является стандартным и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="systempublicbreadcrumb1"
 runat="server"
 componentname="bitrix:system.PublicBreadCrumb"
 template=".default"
 RootItemTitle="Главная страница"
 ShowOnIndexPage="True"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Название первого пункта | RootItemTitle | Указывается название первого пункта навигационной цепочки.
Выводить цепочку навигации на главной странице сайта | ShowOnIndexPage | [True|False] При отмеченной опции цепочка навигации будет выведена на главной странице сайта.


Меню

Компонент выводит меню указанного типа. Компонент является стандартным и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="systempublicmenu1"
 runat="server"
 componentname="bitrix:system.PublicMenu"
 template="tabs"
 Depth="1"
 MenuName="top"
 SubMenuName="left"
 />

Описание параметров

Поле | Параметр | Описание
Шаблон компонента
Шаблон компонента template Указывается один из следующих шаблонов компонента, влияющий на внешний вид меню:
  • Главное меню портала (primary);
  • Дополнительное меню портала (secondary);
  • Плоское вертикальное меню (.default) (.default);
  • Плоское горизонтальное меню (flat);
  • Горизонтальное многоуровневое выпадающее меню (horizontal_multilevel);
  • Меню в виде вкладок (tabs).
Основные настройки
Глубина меню | Depth | Указывается глубина меню (уровень вложенности меню). Чем больше число, тем больше пунктов низких уровней будут отображены.
Тип меню первого уровня | MenuName | Указывается тип меню первого уровня, соответствующий данному меню.
Тип меню остальных уровней | SubMenuName | Указывается тип меню остальных уровней.


Карта сайта

Компонент выводит карту сайта. Компонент является стандартным и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="systempublicsitemap1"
 runat="server"
 componentname="bitrix:system.PublicSiteMap"
 template=".default"
 Depth="8"
 NumberOfColumns="1"
 />

Описание параметров

Поле | Параметр | Описание
Основные настройки
Глубина меню | Depth | Указывается глубина меню (максимальный уровень вложенности разделов) карты сайта. Чем больше число, тем больше пунктов низких уровней будут отображены.
Количество колонок | NumberOfColumns | Указывается количество колонок карты сайта.


Выбор сайта

Компонент Выбор сайта (bitrix:system.siteselector) включен в шаблон дизайна сайта и служит для переключения между сайтами, созданными на базе данной копии продукта.

В поставку продукта входят два шаблона компонента: по умолчанию (.default) и dropdown.

Если выбран шаблон .default, то компонент определяет путь к корневым директориям сайтов, созданных в системе, и выводит ссылки с названиями сайтов в определенном в шаблоне дизайна сайта месте. При этом ссылка с названием текущего (просматриваемого в данный момент) сайта не подсвечивается, т.е. является неактивной.

Если выбран шаблон dropdown, то переключение меду сайтами будет выполнятся с помощью выбора пункта меню с названием сайта в выпадающем списке.

Компонент является стандартным и входит в дистрибутив модуля.


Описание модуля

Модуль Поиск осуществляет индексирование и поиск информации на сайте. Вся текстовая информация, которая попадает на сайт в виде статических страниц или через модули (например, модуль Информационные блоки, модуль Форум и т.д.) автоматически индексируется. Поиск может осуществляться как по всей проиндексированной информации, так и по ее отдельным частям.

Модуль включает в себя следующие компоненты:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Форма поиска | search.form | Выводит включаемую в дизайн сайта форму поиска.
Страница поиска | search.page | Служит для создания страницы с формой поиска и показом результатов поиска.
Облако тегов | search.tags.cloud | Формирует облако тегов.


Переиндексация

Страница Переиндексация (Настройки > Поиск > Переиндексация) позволяет пересоздать поисковый индекс.

Перегенерация поискового индекса может потребоваться в самых различных ситуациях, например, после загрузки файлов по FTP. Пока индекс поиска не создан заново после подобных операций, новые страницы не будут выводиться в результатах поиска.

Закладка "Настройка"

Поле | Описание
Сайты
Все сайты | При отмеченной опции будет переиндексирована информация всех сайтов системы. Если опция не отмечена, то сайт(ы) для переиндексации указываются ниже.
Что переиндексируем
Весь контент | При отмеченной опции будет переиндексирован весь контент сайта(ов). Если опция не отмечена, то контент для переиндексации указывается в нижеследующих полях.
Блоги | При отмеченной опции будут переиндексированы блоги, адреса которых через запятую перечислены в данном поле (например: company,news). Если поле оставить пустым, то будут переиндексированы все блоги.
Форумы | При отмеченной опции будут переиндексированы форумы, указанные в данном поле. Если поле оставить пустым, то будут переиндексированы все форумы.
Информационные блоки | При отмеченной опции будет переиндексирован контент информационных блоков, указанных в данном поле. Если поле оставить пустым, то будут переиндексированы все инфоблоки.
Статические файлы | При отмеченной опции будут переиндексированы статические файлы из папок, указанных в данном поле (например: ~/content/;~/examples/). Если поле оставить пустым, то будут переиндексированы все статические файлы.
Дополнительно
Переиндексировать только измененный контент | При отмеченной опции будет переиндексирован только измененный контент.
Автоматически возобновить переиндексацию при перезапуске приложения | При отмеченной опции переиндексация будет автоматически возобновлена при перезапуске приложения.

Для того чтобы начать переиндексацию нажмите кнопку Запустить, для остановки переиндексации - кнопку Остановить.


Теги

В этом разделе

  • Форма поиска
  • Контекстная панель
  • Список тегов
    •

    Страница Теги (Настройки > Поиск > Теги) содержит информацию о существующих тегах, позволяет создавать новые теги и управлять существующими.

    Форма поиска

    Поиск тегов в соответствии с указанными условиями.

    Поле | Описание
Тег | Название тега.
ID | Идентификатор тега.
Статус | Статус тега.
Количество использований | Число использований тега.
Обновлен | Дата и время последнего изменения тега.

    Чтобы отобрать теги по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех тегов нажмите кнопку Отменить.

    Контекстная панель

    Кнопка | Описание
Новый тег | Переход к форме создания нового тега.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

    Список тегов

    Поле | Описание
    Колонка флажков | Выбор тегов, к которым предполагается применить какое-либо правило или действие.
    Действия Действия, которые можно произвести над тегом:
    • Редактировать - переход к форме редактирования параметров тега;
    • Удалить - удаление тега.
    ID | Идентификатор тега в системе.
    Тег | Произвольное название тега.
    Статус | Статус тега.
    Количество использований | Количество использований тега.
    Обновлен | Дата и время последнего изменения тега.


Создание и редактирование тега

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Закладка "Тег"
  • Кнопки управления

    • Контекстная панель

    Кнопка | Описание
Список тегов | Переход на страницу co списком тегов.
Добавить | Переход к форме создания нового тега. Кнопка отображается при редактировании существующего тега.
Удалить | Удаление редактируемого тега. Кнопка отображается при редактировании существующего тега.

    Форма редактирования

    Форма применяется как для создания новых, так и для редактирования существующих тегов.

    Закладка "Тег"

    Поле | Описание
    ID | Идентификатор тега в системе. Поле отображается при редактировании существующего тега.
    Название | Название тега.
    Статус Выберите один из возможных статусов тега:
    • Не определен - не имеет статуса вообще;
    • Разрешен - разрешенный тег;
    • Запрещен - запрещенный тег.
    Количество использований | Количество использований тега. Поле отображается при редактировании существующего тега.
    Дата изменения | Дата и время последнего изменения тега. Поле отображается при редактировании существующего тега.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Переход на страницу со списком тегов.
Применить | Сохранение внесённых изменений. Продолжение редактирования параметров тега.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений тега.


Настройки модуля

Форма настроек модуля Поиск (Настройки > Настройки продукта > Настройки модулей > Поиск) предназначена для задания глобальных параметров модуля.

Закладка "Настройка параметров модуля"

Поле | Описание
Статические файлы
Максимальный размер индексируемого документа в килобайтах | Проиндексированы будут только те документы, размер (в килобайтах) которых не превышает указанное число.
Маска включения | Файлы и Папки, которые соответствуют хотя бы одной из масок включения, будут проиндексированы поиском. Файлы и Папки, имена которых не соответствуют ни одной из указанных масок, поиском не индексируются.
Маска исключения | Файлы и Папки, которые соответствуют хотя бы одной из масок исключения, не будут проиндексированы поиском.
Теги
Поле | Описание
Сайт | Сайт, для которого будет использоваться поиск тегов.
Свойство страницы | Указывается код свойства страницы, в котором будут храниться теги.
Морфология
Использовать морфологию При отмеченной опции функция морфологического поиска станет активной.

Если эта опция активна, при создании индекса (и, соответственно, при поиске) будут учтены все формы индексируемых слов. Например, при индексации слова телефон, база данных индекса будет учитывать различие в падежных окончаниях (телефона, телефону и т.д.), а также его множественное число (телефоны, телефонов, телефонам и т.д.). Соответственно, при поиске по запросу телефон будут найдены страницы, содержащие не только слово телефон, но и слова телефона, телефону, телефоны, телефонов, телефонам и т.д.
Cимволы, по которым не производится разделение документа на слова (при морфологическом анализе) Укажите символы, которые морфологический анализатор должен рассматривать как части слов.

Алгоритм морфологического анализа разбивает предложения на слова, используя стандартные символы-разделители (пробел, точка, запятая и т.п.). В то же время, существуют символы, которые, не будучи буквами, все же являются частями слов (например, дефис в слове: ликеро-водочный).
Системные настройки
Максимальное количество документов в результатах поиска | Указывается максимальное количество документов для показа из всего результата поиска.
Использовать быстрый поиск (с ухудшенным ранжированием) | При отмеченной опции будет использоваться быстрый поиск (с ухудшенным ранжированием), при этом работа поиска ускоряется, но понижается качество поиска.

Кнопки управления

Кнопка | Описание
Применить | Сохранение внесённых изменений. Продолжение редактирования параметров.
Сохранить | Сохранение внесённых изменений.


Облако тегов

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты

  • Облако тегов
  • Страница поиска
  • Форма поиска


Форма поиска

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Форма поиска

Компонент выводит включаемую в дизайн сайта форму поиска. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="searchform1"
 runat="server"
 componentname="bitrix:search.form"
 template=".default"
 SearchUrlTemplate="~/search.aspx?q=#query#"
 />

Описание параметров

Поле | Параметр | Описание
Настройки поиска
Шаблон ссылки на результаты поиска | SearchUrlTemplate | Указывается шаблон ссылки на результаты поиска.


Страница поиска

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Страница поиска

Компонент служит для создания страницы с формой поиска и показом результатов поиска. Компонент стандартный и входит в дистрибутив модуля.

В поставку продукта входят два шаблона компонента: по умолчанию (.default) и со встроенной поддержкой облака тегов (tags). Если используется шаблон tags, то при настройке свойств компонента доступна группа параметров Параметры облака тегов.

Пример вызова

<bx:IncludeComponent
 id="searchpage1"
 runat="server"
 componentname="bitrix:search.page"
 template="tags"
 SearchFilter=""
 ParamSearch="q"
 ParamPage="page"
 ParamWhere="where"
 ParamTags="tags"
 MaxChars="500"
 HighlightDiameter="200"
 ShowFilter="True"
 ShowFilterItems="forum;iblock_23;iblock_26;iblock_shop_news;iblockt_18;iblockt_21;main"
 ShowTags="NotRejected"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="False"
 PagingRecordsPerPage="10"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 Template_NarrowSearch="True"
 Template_PagingRecordsPerPage="10"
 Template_SizeDistribution="Exponential"
 Template_SizeMin="10"
 Template_SizeMax="50"
 Template_ColorDistribution="None"
 Template_ColorMin=""
 Template_ColorMax=""
 />

Описание параметров

Поле | Параметр | Описание
Источник данных
Ограничить область поиска | SearchFilter | Параметр служит для ограничение области поиска: форумы (forum), инфоблоки (iblock), тип инфоблока (iblockt), страницы на сервере (main). Можно также выбрать несколько из перечисленных источников информации.
Настройки ссылок
Название переменной, содержащей запрос | ParamSearch | Указывается название переменной, содержащей запрос.
Название переменной, содержащей номер страницы | ParamPage | Указывается название переменной, содержащей номер страницы.
Название переменной, содержащей область поиска | ParamWhere | Указывается название переменной, содержащей область поиска.
Название переменной, содержащей теги | ParamTags | Указывается название переменной, содержащей теги.
Настройки поиска
Примерное количество символов во фрагменте результата | MaxChars | Указывается примерное количество символов во фрагменте результата.
Примерное количество символов вокруг выделенного слова во фрагменте результата | HighlightDiameter | Указывается примерное количество символов в кратком описании каждого результата поиска.
Показывать фильтр поиска | ShowFilter | [True|False] При отмеченной опции в строке с формой поиска будет выведен фильтр поиска.
Значения для фильтра | ShowFilterItems | Указываются значения, которые будут отображены в списке фильтре.
Показывать теги результатов ShowTags Указывается какие теги результатов выводить:
  • Не показывать (None);
  • Разрешенные (Approved);
  • Не запрещенные (NotRejected);
  • Все (All).
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение страницы с формой поиска и результатами поиска.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Количество записей на странице | PagingRecordsPerPage | Указывается количество результатов поиска, отображаемых на одной странице. Все результаты будут выведены с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Параметры облака тегов
Сужать область поиска | Template_NarrowSearch | [True|False] При отмеченной опции выбранные теги добавляются в фильтр поиска.
Количество выбираемых тегов | Template_PagingRecordsPerPage | Параметр определяет количество выводимых тегов в облаке.
Распределение размеров Template_SizeDistribution Указывается способ распределения размеров тегов:
  • Не вычислять (None) - распределение размеров не вычисляется;
  • Линейное (Linear) - равномерное изменение размера тегов от исходного до конечного размера тегов;
  • Экспоненциальное (Exponential) - разница между тегами с исходным и конечным размером сглаживается экспоненциально.
Исходный размер (в пикселах) | Template_SizeMin | Указывается исходный размер шрифта отображения тегов (в пикселах).
Конечный размер (в пикселах) | Template_SizeMax | Указывается конечный размер шрифта отображения тегов (в пикселах).
Распределение цветов Template_ColorDistribution Указывается способ распределения цветов тегов:
  • Не вычислять (None) - распределение цветов не вычисляется;
  • Линейное (Linear) - равномерное изменение цвета тегов от исходного до конечного цвета тегов;
  • Логарифмическое (Logarithmic) - логарифмическое изменение цвета тегов от исходного до конечного цвета тегов.
Исходный цвет тегов | Template_ColorMin | Указывается исходный цвет тегов (код цвета), дата создания которых наиболее ранняя (пример: "#C0C0C0" или "Gray").
Конечный цвет тегов | Template_ColorMax | Указывается конечный цвет тегов (код цвета), дата создания которых наиболее поздняя (пример: "#C0C0C0" или "Gray").


Облако тегов

1С-Битрикс: Управление сайтом ASP.NET Отправить отзыв по этому разделу

Компоненты::Облако тегов

Компонент формирует облако тегов. Компонент стандартный и входит в дистрибутив модуля.

Пример вызова

<bx:IncludeComponent
 id="searchtags_cloud1"
 runat="server"
 componentname="bitrix:search.tags.cloud"
 template=".default"
 Filter="'forum';'iblock_23';'iblock_25';'iblockt_20';'iblockt_21';'main'"
 SelectionSort="TagCount"
 SelectionOrder="Desc"
 Moderation="NotRejected"
 DisplaySort="Name"
 DisplayOrder="Asc"
 SizeDistribution="Exponential"
 SizeMin="10"
 SizeMax="50"
 SizePeriod=""
 ColorDistribution="Linear"
 ColorMin=""
 ColorMax=""
 TagLinkTemplate="?tag=#SearchTags#"
 PagingAllow="True"
 PagingMode="direct"
 PagingTemplate=".default"
 PagingShowOne="True"
 PagingAllowAll="True"
 PagingRecordsPerPage="5"
 PagingTitle="Страницы"
 PagingPosition="both"
 PagingMaxPages="10"
 PagingMinRecordsInverse="1"
 PagingPageID="<%$ Request:page%>"
 PagingShowAll="<%$ Request:showall%>"
 PagingIndexTemplate=""
 PagingPageTemplate="?page=#pageid#"
 PagingShowAllTemplate="?showall=y"
 />

Описание параметров

Поле | Параметр | Описание
Источник данных
Фильтр выборки | Filter | Параметр служит для фильтрации области тегов: форумы (forum), инфоблоки (iblock), тип инфоблока (iblockt), страницы на сервере (main). Можно также выбрать несколько из перечисленных источников информации.
Сортировать выборку по SelectionSort Задается спосбо сортировки выборки тегов:
  • Имя (Name) - по имени;
  • Количество использований (TagCount) - по количеству использований;
  • Дата обновления (LastUpdate) - по дате обноления.
в порядке SelectionOrder Задается порядок сортировки выборки тегов:
  • По возрастанию (Asc);
  • По убыванию (Desc).
Параметры модерирования Moderation Указывается какие теги результатов выводить:
  • Все (All).
  • Не запрещенные (NotRejected);
  • Разрешенные (Approved);
Сортировать вывод по DisplaySort Задается способ сортировки отображаемых тегов:
  • Имя (Name) - по имени;
  • Количество использований (TagCount) - по количеству использований;
  • Дата обновления (LastUpdate) - по дате обноления.
в порядке DisplayOrder Задается порядок сортировки отображаемых тегов:
  • По возрастанию (Asc);
  • По убыванию (Desc).
Параметры размера (популярность тега)
Распределение размеров SizeDistribution Указывается способ распределения размеров тегов:
  • Не вычислять (None) - распределение размеров не вычисляется;
  • Линейное (Linear) - равномерное изменение размера тегов от исходного до конечного размера тегов;
  • Экспоненциальное (Exponential) - разница между тегами с исходным и конечным размером сглаживается экспоненциально.
Исходный размер (в пикселах) | SizeMin | Указывается исходный размер шрифта отображения тегов (в пикселах).
Конечный размер (в пикселах) | SizeMax | Указывается конечный размер шрифта отображения тегов (в пикселах).
Особо выделять теги за последний период (в днях) | SizePeriod | Указывается период времени (количество дней), в течении которого теги будут выделены особо.
Параметры цвета ("возраст" тега)
Распределение цветов ColorDistribution Указывается способ распределения цветов тегов:
  • Не вычислять (None) - распределение цветов не вычисляется;
  • Линейное (Linear) - равномерное изменение цвета тегов от исходного до конечного цвета тегов;
  • Логарифмическое (Logarithmic) - логарифмическое изменение цвета тегов от исходного до конечного цвета тегов.
Исходный цвет тегов | ColorMin | Указывается исходный цвет тегов (код цвета), дата создания которых наиболее ранняя (пример: "#C0C0C0" или "Gray").
Конечный цвет тегов | ColorMax | Указывается конечный цвет тегов (код цвета), дата создания которых наиболее поздняя (пример: "#C0C0C0" или "Gray").
Настройки ссылок
Ссылка для тега | TagLinkTemplate | Указывается шаблон ссылки для тега.
Постраничное отображение
Разрешить постраничное отображение PagingAllow [True|False] При отмеченной опции будет включено постраничное отображение списка тем форума.

Если режим постраничного отображения включен, то необходимо настроить следущие параметры: PagingMode, PagingTemplate, PagingShowOne, PagingRecordsPerPage, PagingTitle, PagingPosition, PagingMaxPages, PagingMinRecordsInverse, PagingPageID, PagingIndexTemplate, PagingPageTemplate.

Если режим постраничного отображения выключен, то необходимо настроить следущие параметры: PagingRecordsPerPage.
Режим наполнения страниц PagingMode Задается режим наполнения страниц:
  • Прямой (direct);
  • Обратный (inverse).
Шаблон компонента постраничной навигации PagingTemplate Указывается шаблон компонента постраничной навигации:
  • По умолчанию (.default);
  • Продвинутая навигация (advanced);
  • Диапазон страниц (bounded);
  • Настраиваемая при помощи CSS (customizable).
Отображать в случае единственной страницы | PagingShowOne | [True|False] При отмеченной опции навигация будет отображена даже в случае единственной страницы.
Разрешить просмотр всех страниц | PagingAllowAll | [True|False] При отмеченной опции будет разрешен просмотр всех страниц.
Количество записей на странице | PagingRecordsPerPage | Указывается количество тем форума, отображаемых на одной странице. Весь список тем форума будет выведен с помощью постраничной навигации.
Заголовок переключателя страниц | PagingTitle | Указывается заголовок переключателя страниц.
Расположение переключателя страниц PagingPosition Задается расположение переключателя страниц:
  • Сверху (top);
  • Снизу (bottom);
  • Сверху и снизу (both).
Максимальное число страниц в переключателе | PagingMaxPages | Указывается максимальное количество страниц, отображаемых в переключателе.
Минимальное число элементов на странице в режиме обратного наполнения | PagingMinRecordsInverse | Задается минимальное число элементов, отображаемых на странице в режиме обратного наполнения.
Номер страницы для показа | PagingPageID | Указывается номер страницы, с которой будет начат показ облака тегов. Обычно задается в виде <%$ Request:page%>, чтобы номер выводился из строки запроса.
Показать все элементы | PagingShowAll | Задется способ отображения всех элементов облака тегов. Обычно задается в виде <%$ Request:showall%>, чтобы показ всех элементов выполнялся из строки запроса.
Первая страница в списке (пустое значение - текущая страница) | PagingIndexTemplate | Задается шаблон пути на первую страницу с облаком тегов.
Отдельная страница в списке | PagingPageTemplate | Задается шаблон пути к остальным страницам с облаком тегов.
Страница просмотра всех элементов | PagingShowAllTemplate | Задается шаблон пути к странице просмотра всех элементов облака тегов.


Описание модуля

Одной из первостепенных задач для владельцев веб-проектов является качественная и надежная защита от хакерских атак, взлома и кражи хранящейся на сайте информации.

Для этого в системе "1С-Битрикс: Управление сайтом ASP.NET" предусмотрен модуль Проактивная защита, с помощью которого реализуется целый комплекс защитных мероприятий для сайта и сторонних приложений. Уровень защиты, обеспечиваемый стандартной сборкой дистрибутива "1С-Битрикс: Управление сайтом ASP.NET", достаточно высок. Но во время реализации проектов на основе "1С-Битрикс: Управление сайтом ASP.NET" выполняется кастомизация компонентов, дописываются собственные инструменты, безопасность которых не всегда проверяется.

Модуль Проактивная защита является важным дополнением к стандартной политике безопасности продукта и существенно повышает уровень защиты веб-проекта.


Проактивный фильтр

  • Закладка "Проактивный фильтр"
  • Закладка "Активная реакция"
  • Закладка "Исключения"
  • Кнопки управления
    •

    Проактивный фильтр (Web Application Firewall) – это набор специализированных средств, которые выполняют фильтрацию трафика. Фильтр обеспечивает защиту от большинства известных атак на веб-приложения. В потоке внешних запросов пользователей проактивный фильтр распознает большинство опасных угроз и блокирует вторжения на сайт.

    Обновления проактивного фильтра доступны вместе с общими обновлениями продукта по технологии SiteUpdate.

    Примечание: обратите внимание, что некоторые действия пользователей, не представляющие угрозы, также могут выглядеть подозрительно и вызывать ложное срабатывание фильтра.

    Закладка "Проактивный фильтр"

    Включение или отключение проактивного фильтра выполняется на странице Проактивный фильтр (Настройки > Проактивная защита > Проактивный фильтр) с помощью кнопки Включить проактивную защиту (Отключить проактивную защиту).

    Закладка "Активная реакция"

    Закладка позволяет настроить действия системы при попытке вторжения на сайт.

    Поле | Описание
    Активная реакция на вторжение Задается способ реакции системы на вторжение:
    • Сделать данные безопасными - опасные данные будут модифицированы, например, select будет заменен на sel ect, а <script> на <sc ript>;
    • Очистить опасные данные - опасные данные будут удалены;
    • Оставить опасные данные как есть - с опасными данными никаких действий выполняться не будет.
    Занести попытку вторжения в журнал | При отмеченной опции попытка вторжения будет занесена в Журнал событий.

    Закладка "Исключения"

    Закладка позволяет настроить исключения из проактивного фильтра, т.е. проактивный фильтр не будет применяться на страницах, указанных на данной закладке.

    Поле | Описание
Маски исключения (например, /bitrix/* или */news/*) для сайта <имя_сайта> | Указываются маски исключения для страниц и разделов выбранного сайта или для всех сайтов сразу.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение параметров.
Применить | Сохранение параметров. Продолжение редактирования.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.


Инструменты

В поставку продукта входит набор специальных инструментов. Данный раздел содержит описание возможностей данных инструментов и способов их использования.


Журнал событий

В этом разделе

  • Форма поиска
  • Список событий
    •

    Журнал событий (Настройки > Инструменты > Журнал событий) предназначен для ведения логов событий сайта.

    Форма поиска

    Форма используется для выбора из списка событий в соответствии с указанными условиями.

    Поле | Описание
Тип | Поиск можно задать по всем типам событий либо по следующим типам: Неизвестный, Информация, Комментарий, Предупреждение, Ошибка, Критическая ошибка, Отладочный вывод и Безопасность.
Код | Поиск можно задать по коду события.
Источник | Поиск можно задать по источнику события.
Заголовок | Поиск можно задать по заголовку события.
Сообщение | Поиск можно задать по сообщению события.
Дата возникновения | Поиск можно задать по дате возникновения события, указав интервал времени в соответствующих полях.

    Чтобы отобрать события по заданным критериям поиска, нажмите кнопку Найти. Для отображения всего списка событий нажмите кнопку Отменить.

    Список событий

    Поле | Описание
# | Номер события в списке.
ID | Идентификатор события в списке.
Тип | Тип события.
Источник | Источник возникновения события.
Сообщение | Текст сообщения события.
Дата возникновения | Дата и время возникновения события.


Подписчики событий

Страница Подписчики событий (Настройки > Инструменты > Подписчики событий) содержит информацию об используемых в системе подписчиках событий, которая отображается в виде таблице со следующими полями: Шаблон события, Класс-подписчик, Сборка класса-подписчика.


Агенты

В этом разделе

  • Форма поиска
  • Список агентов
    •

    Агенты - это технология, позволяющая запускать произвольные функции (агенты) с заданной периодичностью. В самом начале загрузки каждой страницы система автоматически проверяет, есть ли агент, который нуждается в запуске и в случае необходимости - исполняет его.

    Список используемых в системе агентов приводится на странице Агенты (Настройки > Инструменты > Агенты).

    Форма поиска

    Форма используется для выбора из списка агентов в соответствии с указанными условиями.

    Поле | Описание
ID | Идентификатор агента.
Имя агента | Имя агента.
Активен | Поиск можно задать по активным или неактивным агентам.
Имя класса агента | Поиск можно задать по имени класса агента.
Имя сборки класса агента | Поиск можно задать по имени сборки класса агента.
Время запуска | Поиск можно задать по времени запуска, указав интервал времени в соответствующих полях.
Периодичность | Поле позволяет найти только периодические агенты или только непериодические агенты, или же все агенты.

    Чтобы отобрать агенты по заданным критериям поиска, нажмите кнопку Найти. Для отображения всего списка агентов нажмите кнопку Отменить.

    Список агентов

    Поле | Описание
    Действия Действия, которые можно произвести над агентами:
    • Остановить/Запустить - остановить или запустить агента;
    • Удалить - удалить агента.
    ID | Идентификатор агента.
    Имя агента | Имя агента.
    Активен Признак активности агента:
    • Да - агент активен;
    • Нет - агент неактивен.
    Имя класса агента | Поле содержит имя класса агента.
    Имя сборки класса агента | Поле содержит имя сборки класса агента.
    Параметры исполнения | Поле содержит информацию о параметрах исполнения агента.
    Время запуска | Время запуска агента.
    Периодичность Периодичность агента:
    • Да - периодические агенты;
    • Нет - непериодические агенты.
    Период запуска | Поле содержит информацию о периоде запуска агента.


Система обновлений

Система обновлений служит для осуществления взаимодействия между копией продукта (клиентом) и сервером обновлений. Основными видами взаимодействия являются:

  • обновление модулей продукта до последней версии (это позволяет получить новый функционал модулей и исправить в них возможные ошибки);
  • загрузка новых модулей, которые доступны в соответствии с лицензией;
  • регистрация копии продукта с помощью лицензионного ключа.

Переход к установке обновлений выполняется на странице Система обновлений (Настройки > Система обновлений). Также перейти на страницу обновлений продукта можно с помощью кнопки [image], расположенной на панели инструментов в административном разделе.

Важные замечания по работе системы обновлений

Система обновлений не изменяет публичную часть. Служебная область изменяется только в рамках необходимости, при этом существующие файлы и записи не изменяются (т.к. они уже могли быть изменены владельцем копии продукта под свои нужды). Ядро продукта может быть изменено системой обновлений сколь угодно сильно (при этом, конечно, обеспечивается обратная совместимость).

Примечание: если вы самостоятельно изменили хотя бы один файл ядра продукта или структуру базы данных, то автоматическая установка обновления может иметь непредсказуемый результат.

Система обновлений не собирает и не передает никаких конфиденциальных данных копии продукта, на которой она работает. Система обновлений обменивается с сервером обновлений исключительно техническими данными, напрямую необходимыми для корректной работы системы обновлений (например, текущие версии модулей).

Система обновлений производит технически сложную серьезную модификацию ядра продукта. Если эта модификация будет произведена с ошибками, то сайты, работающие на этом ядре, могут оказаться неработоспособными. Перед установкой обновлений рекомендуется убедится в наличии резервной копии как базы данных, так и скриптов ядра продукта и служебной области. Рекомендуется для проведения процедуры обновления выбирать время, когда нагрузка на сервер минимальна.

При возникновении проблем с установкой обновления вам необходимо незамедлительно обратиться в службу Технической поддержки компании "1С-Битрикс".


Настройки системы обновлений

В этом разделе

  • Контекстная панель
  • Форма редактирования
  • Закладка "Настройки системы обновлений"
  • Закладка "Автоматизация"
  • Закладка "Настройка прокси"
  • Кнопки управления

    • Контекстная панель

    Кнопка | Описание
Перейти в систему обновлений | Переход на страницу системы обновлений сайта.

    Форма редактирования

    Форма служит для настройки параметров системы обновлений. Все параметры сгруппированы по логическому принципу и размещены на соответствующих закладках формы.

    Закладка "Настройки системы обновлений"

    Поле | Описание
Адрес системы обновлений | Имя сервера, с которого выполняется обновление продукта.
Лицензионный ключ | Лицензионный ключ данной копии продукта.
Устанавливать только стабильные версии | При отмеченной опции в системе обновлений будут загружаться только стабильные версии. При снятой опции - бета-версии.
Безопасное обновление (повышенные требования к ресурсам) | При отмеченной опции будет выполняться резервное копирование файлов перед обновлением.
Язык "по умолчанию" системы обновлений | Указывается язык, используемый по умолчанию, для работы системы в автоматическом режиме. Автоматический режим работы системы обновлений задается на закладке Автоматизация.
Строка соединения с базой для системы обновлений | Указывается строка соединения с сервером, на котором работает СУБД.
Владелец базы данных | Задается логин владельца базы данных.
E-mail адрес для уведомлений о появлении обновлений | Указывается адрес электронной почты, на который будут приходить уведомлений о появлении обновлений.

    Закладка "Автоматизация"

    Поле | Описание
Автоматически закачивать обновления | При отмеченной опции будет происходить автоматическая загрузка обновлений.
Время после запуска приложения, через которое начинается первая проверка обновлений | Указывается количество секунд после запуска продукта, через которое начнется первая проверка наличия обновлений.
Периодичность проверок наличия обновлений | Указывается интервал времени в секундах, через который будет проводится проверка наличия обновлений.

    Закладка "Настройка прокси"

    Поле | Описание
Использовать прокси | При отмеченной опции обновления будут загружаться через прокси-сервер.
Адрес прокси | Адрес прокси-сервера, через который выполняется доступ к серверу обновлений (используется, например, для корпоративных сетей).
Имя пользователя | Имя пользователя для доступа к прокси-серверу.
Пароль | Пароль для доступа к прокси-серверу.
Пароль еще раз | Подтверждение введенного пароля для доступа к прокси-серверу.

    Кнопки управления

    Кнопка | Описание
Сохранить | Сохранение параметров системы обновлений.
Применить | Сохранение параметров системы обновлений. Продолжение редактирования параметров.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений.


Установка обновлений

В этом разделе

  • Контекстная панель
  • Установка обновлений
  • Установка обновлений вручную
  • Автоматическая установка обновлений
    •

    Контекстная панель

    Кнопка | Описание
Проверить обновления | Проверка наличия новых обновлений на сервере.
Изменить настройки | Переход к форме настройки параметров системы обновлений.

    Установка обновлений

    Установить обновления можно вручную либо автоматически. Способ установки обновлений определяется настройками Системы обновлений на закладке Автоматизация.

    Установка обновлений вручную

    Для установки обновлений вручную необходимо в административном разделе перейти на страницу Система обновлений (Настройки > Система обновлений) (или воспользоваться кнопкой [image], расположенной на административной панели).

    Система проверит наличие обновлений и на странице отобразится число доступных обновлений:

    Примечание: периодически обновляется сама Система обновлений. Если будет обнаружена новая версия, то сначала появится надпись о необходимости обновления Системы обновлений. После того, как Система обновлений будет обновлена, станут доступными обновления модулей.

    Нажмите на кнопку Загрузить обновления. Начнется процесс загрузки обновлений в систему.

    После того, как обновления загрузятся в систему и подготовятся к установке, можно выполнить следующие действия:

    • перейти к установке обновлений с помощью кнопки Установить обновления;
    • просмотреть доступные обновления с помощью ссылки Просмотреть доступные обновления.

    Если выбрать просмотр обновлений, то откроется список доступных обновлений:

    Установите или снимите флаги около тех обновлений, которые необходимо устанавливать.

    Примечание: в случае связанных обновлений должны быть выбраны все связанные обновления либо не выбрано ни одного.

    Для просмотра описания обновления используйте ссылку Описание для нужного обновления, при этом откроется специальное окно, содержащее информацию об обновлении:

    Для установки обновлений нажмите кнопку Установить обновления.

    После установки обновлений будет выведено соответствующее сообщение:

    Автоматическая установка обновлений

    Обновления могут быть установлены автоматически. Для этого необходимо настроить параметры Системы обновлений.

    Перейти к форме настройки параметров можно с помощью кнопки Изменить настройки, расположенной на контекстной панели страницы Система обновлений.

    На закладке Автоматизация отметьте опцию Автоматически закачивать обновления, и укажите Время после запуска приложения, через которое начинается первая проверка обновлений и Периодичность проверок наличия обновлений.

    Сохраните внесенные изменения.