Основные сведения

Основные сведения

Bitrix Framework - это созданная на основе PHP платформа для разработки веб-приложений. На этой платформе компанией «1C-Битрикс» созданы два популярных продукта: «1C-Битрикс: Управление сайтом» и «Битрикс24» (в облачной и коробочной версиях).

Документация включает в себя описание функционала обоих продуктов. Модули, компоненты и настройки, относящиеся только к "Битрикс24 в коробке" помечены знаком КП, модули относящиеся только к "1С-Битрикс: Управление сайтом" помечены знаком БУС.

На каждой странице документации авторизованный на сайте посетитель может дать комментарий к содержимому страницы. Для этого воспользуйтесь расположенной в правом нижнем углу окна браузера кнопкой:

1С-Битрикс: Управление сайтом

"1C-Битрикс: Управление сайтом" - технологическое ядро для создания и управления сайтами. Продукт может быть использован корпоративными заказчиками и индивидуальными разработчиками в качестве фундамента для создания новых проектов и управления уже существующими сайтами.

Технически "1C-Битрикс: Управление сайтом" позволяет создавать неограниченное количество сайтов [image] с применением одной копии (лицензии) продукта, размещая ядро и базу данных системы в единственном экземпляре на сервере.

Основные возможности "1C-Битрикс: Управление сайтом":

  • управление структурой и содержанием сайта;
  • публикация новостей, пресс-релизов и другой часто обновляемой информации;
  • управление показом рекламы на сайте;
  • создание и управление форумами;
  • рассылка сообщений группам подписчиков;
  • учет статистики посещений;
  • контроль за ходом рекламных кампаний;
  • осуществление других операций по управлению интернет-проектом.

Продукт позволяет минимизировать расходы на сопровождение веб-сайта за счет простоты управления статической и динамической информацией. Для управления проектом вам не потребуются дополнительные услуги специалистов в области веб-дизайна. С помощью "1C-Битрикс: Управление сайтом" управлять веб-сайтом сможет штатный сотрудник компании, обычный пользователь персонального компьютера без специальных навыков программирования и HTML-вёрстки, успешно изучивший курс учебный Контент-менеджер

Битрикс24

Битрикс24 - программный продукт для создания внутрикорпоративного информационного ресурса, решающего коммуникационные, организационные и HR-задачи компании. Реализован в виде облачного сервиса или коробочной версии.

Основные возможности Битрикс24:

  • управление информационным наполнением и структурой;
  • автоматизация бизнес-процессов организации;
  • управление задачами и поручениями, организация коллективных событий, резервирование переговорных и ресурсов, работа с электронными заявками;
  • формирование сообществ на корпоративном портале, организации совместной работы сотрудников, укрепление связей внутри сообществ, обмен мгновенными внутрипортальными сообщениями;
  • коллективный доступ к офисным документам, хранящимся на сервере, документооборот, работа с файлами через браузер и Проводник;
  • ведение клиентской базы в CRM;
  • телефония;
  • и целый ряд других возможностей и операций.

Примечание: в документации слова сайт и портал используются как синонимы.

© «Битрикс», 2001-2008, «1C-Битрикс», 2008-2022 1С-Битрикс: Управление сайтом


Реализация и системные требования

Платформа Bitrix Framework разработана на языке программирования PHP. Продукт может эффективно работать на любой UNIX или Windows платформе.

Минимальные технические требования

  • PHP версии не ниже 7.2.0 (с 1 августа 2020 года. Рекомендуемая версия PHP - 7.4.0 и выше);
  • Apache 1.3 и выше или MS IIS 5.0* и выше или Eserv 3.0 и выше;
  • MySQL 5.6 и выше.

* Для MS IIS PHP должен быть установлен как FastCGI.

В качестве базы данных используется MySQL.

Версии на базе MySQL

Эта популярная и простая в настройке версия продукта разработана в рассчете на массового потребителя. Она способна удовлетворить запросы большинства клиентов, так как обладает полным функционалом, высокой производительностью, минимальной стоимостью размещения и оптимальной ценой. Для размещения проектов, созданного на базе этой БД, можно использовать любой классический UNIX хостинг с поддержкой PHP и MySQL.

Внимание! В связи с прекращением поддержки интернет-браузера Internet Explorer 11 со стороны компании Microsoft остановлена поддержка браузера IE ниже 11 версии в платформе «1С-Битрикс: Управление сайтом» и в продукте «1С-Битрикс24»

Все версии продуктов поставляются с исходными текстами. Это дает возможность покупателю самостоятельно настраивать и разрабатывать приложения для системы.

Если вы не можете определиться с выбором платформы, обратитесь в компанию "1C-Битрикс" для консультации. Наши специалисты окажут вам необходимую помощь по всем техническим вопросам функционирования сайта на любой платформе.

Детально о системных требованиях можно познакомиться в уроке Требования к серверному программному обеспечению [image] курса Установка и настройка.


Основные сведения

Справочная система по Bitrix Framework состоит из API [image], API D7 [image], Rest API [image] и пользовательской (та, которую вы в данный момент читаете) документаций.

API документация предназначена для разработчиков и содержит описание принципов кастомизации CMS, описание классов, методов, событий, констант. REST API документация предназначена для создания собственных приложений для облачной реализации Битрикс24. Пользовательская документация содержит описание компонентов системы и описание полей настроек административной части системы.

Все виды документации предназначены только для получения справочной информации и не содержат описания принципов и сценариев работы с системой. Для изучения принципов и сценариев обратитесь к Учебным курсам.

Учебные курсы построены по принципу "от пользователя". То есть разбиты по предполагаемым ролям, которые выполняются пользователями системы:

  • Контент-менеджер [image]. (Описание интерфейсов и принципов работы системы для Контент-менеджера, то есть тех, кто работает с контентом уже готовых сайтов.)
  • Тесты на сертификат "Пользователь сервиса Битрикс24" [image].
  • Тесты на сертификат "Пользователь коробочной версии Битрикс24" [image].
  • Администратор Базовый [image] (Основные принципы администрирования в системе), Модули [image] (Описание работы с большинством модулей системы.), Бизнес [image] (Описание работы с модулями системы коммерческой направленности.).
  • Администратор КП [image]. (Администрирование коробочной версии Битрикс24)
  • Разработчик Bitrix Framework [image]. Описание принципов разработки проектов на Bitrix Framework.
  • Курс для хостеров [image]. Описание принципов настроек хостинга под Bitrix Framework
  • Технология Композитный сайт [image]. Описание технологии и принципов создания сайтов с её использованием.
  • Разработка и эксплуатация высоконагруженных проектов [image].
  • BitrixMobile [image] - создание кроссплатформенных мобильных приложений.

Для облегчения изучения системы можно также использовать видеоролики [image]. Следить за изменениями в документации можно с помощью страницы Что нового? , подписавшись на Твиттер [image] документациии а также в блоге Отдела документации [image].


Список терминов

  • Портал
  • Сайт
  • Шаблон сайта
  • Раздел сайта
  • Компонент 1.0
  • Компонент 2.0
  • Путь к компоненту
  • Включаемые области
  • Язык
  • Языковой файл
  • Шаблон страницы
  • Пролог
  • Эпилог
  • Тело страницы
  • Навигационная цепочка
  • Административная часть
  • Публичная часть
  • Режим редактирования сайта
  • Индексная страница (файл)
  • Мета-тэг
  • Локализация
  • Хост
  • Доменное имя (домен)
  • IP адрес
  • Accept-Language
  • Время в Unix-формате
  • Права в Unix системах
  • Путь относительно корня
  • Полный путь
  • Абсолютный путь
  • DocumentRoot
  • Сабмит
  • Сессия
  • HTML-безопасный вид
  • Связывание переменных
  • Дамп
  • cron (крон)
  • Буферизация
  • Постоянное соединение (persistent)
  • Почтовое событие
  • Тип почтового события
  • Почтовый шаблон
  • Бюджет пользователя
  • ЧПУ

Термин | Описание
Портал | Один набор файлов, хранящихся в каталоге /bitrix/modules/ и одна копия базы. Портал включает в себя один или более сайтов. Синонимом данного термина может служить: "экземпляр продукта", "одна инсталляция системы", "одна копия системы".
Сайт Совокупность таких понятий как:
  • учетная запись в базе данных - создаётся в административном меню "Сайты", включает в себя следующие основные параметры:
    • идентификатор - набор символов, идентифицирующий сайт
    • доменное имя - одно или более доменное имя сайта
    • папка сайта - путь к каталогу, в котором будет храниться публичная часть сайта
    • язык сайта
    • формат даты
    • формат времени
    • URL - протокол и доменное имя по умолчанию (например, "http://www.site.ru")
    • DocumentRoot - если многосайтовость организована по способу 2, то в данном параметре должен храниться путь в файловой системе сервера к корню сайта
    • условия подключения шаблонов - каждый сайт может иметь один или более шаблонов для отображения скриптов своей публичной части, каждый такой шаблон может быть подключен по тому или иному условию
  • публичная часть - совокупность скриптов (страниц), лежащих в "папке сайта" и принадлежащих этому сайту
  • настройки - каждый модуль может иметь ряд настроек, связанных с сайтом, например, у модуля "Информационные блоки" эти настройки представляют из себя привязку информационного блока к тому или иному сайту, у модуля "Техподдержка" - привязку статуса, категории и т.п. к сайту.
Шаблон сайта Синонимом можно считать - "дизайн сайта", "скин сайта". Для показа одного сайта можно использовать несколько различных шаблонов. Строго говоря, в шаблон сайта входят:
  • учетная запись в базе данных - создаётся в административном меню "Шаблоны сайта"
  • набор файлов в каталоге /bitrix/templates/ID_шаблона/, где ID_шаблона - поле "ID" в форме редактирования шаблона сайта, ниже представлена структура данного каталога:
    • /ID_модуля/ - каталог с компонентами 1.0, принадлежащими тому или иному модулю
    • /lang/ - языковые файлы, принадлежащие как данному шаблону в целом, так и отдельным компонентам
    • /images/ - каталог с изображениями данного шаблона
    • /page_templates/ - каталог с шаблонами страниц и их описанием, хранящимся в файле .content.php
    • /include_areas/ - каталог с файлами - содержимым включаемых областей;
    • header.php - пролог данного шаблона
    • footer.php - эпилог данного шаблона
    • styles.css - CSS стили, используемые на страницах сайта, когда используется данный шаблон
    • template_styles.css - CSS стили, используемые в самом шаблоне
    • .тип меню.menu_template.php - шаблон вывода меню соответствующего типа, если это версия 5.х
    • chain_template.php - шаблон по умолчанию для вывода навигационной цепочки (версия 5.х)
    • а также ряд других вспомогательных произвольных файлов, входящих в данный шаблон
Раздел сайта | Это не что иное, как каталог в файловой системе сервера. В "1С-Битрикс: Управление сайтом" структура сайта - это файловая структура сервера, поэтому страницы сайта - это файлы, а разделы сайта - соответственно, каталоги.
Компонент Является частью того или иного модуля, представляет из себя логически завершенный код, хранящийся в одном файле, принимающий ряд параметров, выполняющий ряд действий и выводящий какой-либо результат (например, в виде HTML кода). Использование компонентов является наиболее предпочтительным способом организации вывода информации как в публичной, так и в административной частях. В понятие "компонент" входят следующие элементы:
  • основной файл - подключается с помощью функции CMain::IncludeFile, представляет из себя скрипт на языке PHP, реализующий логику компонента
  • языковые файлы - используются в компоненте для представления его результата на различных языках
  • описание - это PHP код, используемый HTML редактором для визуального управления компонентом и его параметрами
Компонент 2.0 Компоненты являются блоками, с помощью которых строится публичная часть сайта.
Основные особенности компонентов версии 2.0:
  • В компонентах 2.0 могут быть разделены логика и представление. Для одной логики может быть несколько представлений, в том числе зависящих от шаблона текущего сайта.
    Логика - это сам компонент, представление - это шаблон вывода компонента.
  • Компоненты централизованно хранятся в одной папке. Это обеспечивает большую целостность и понятность структуры сайта. Папка доступна для обращений, а значит, компонент и его шаблоны могут легко подключать свои дополнительные ресурсы.
  • Компонент хранит все, что ему нужно для работы, в своей папке. Поэтому компоненты можно легко переносить между проектами. Компонент неделим.
  • Компоненты делятся на простые и комплексные. Простые служат для создания различных областей на одной странице (список новостей, топ элементов каталога, случайное фото и т.д.). А комплексные используются для создания полнофункциональных разделов сайта (полный каталог товаров, новостной раздел, форум и т.д.).
Путь к компоненту Используется в функции CMain::IncludeFile в качестве первого параметра и представляет из себя путь к основному файлу компонента относительно одного из следующих каталогов (в порядке убывания приоритета):
  • /bitrix/templates/ID шаблона сайта/
  • /bitrix/templates/.default/
  • /bitrix/modules/ID модуля/install/templates/
где:

ID шаблона сайта - идентификатор текущего шаблона сайта,
ID модуля - идентификатор модуля, которому принадлежит компонент.
Включаемые области | Это произвольный текст (HTML код), являющийся частью содержимого страницы. С данным термином связана закладка "Редактировать сайт" на панели управления, при нажатии на которую все включаемые области обрамляются рамкой с управляющими иконками в правом верхнем углу этой рамки.
Язык Это учетная запись в базе данных, доступная для редактирования в административном меню "Языки" со следующими полями:
  • Идентификатор
  • Название
  • Формат даты
  • Формат времени
  • Кодировка
Как в публичной, так и административной частях, язык в первую очередь используется в работе с языковыми файлами.
В административной части язык определяет формат времени, даты, кодировку страниц (в публичной - данные параметры определяются настройками сайта).
Языковой файл Представляет из себя PHP скрипт, хранящий переводы языковых фраз на тот или иной язык. Данный скрипт состоит из массива $MESS, ключи которого - идентификаторы языковых фраз, а значения - переводы на соответствующий язык. Для каждого языка существует свой набор языковых файлов, хранящихся, как правило, в каталогах /lang/.
Языковые файлы, как правило, используются в административных скриптах модулей и в компонентах.
Для работы с языковыми файлами предназначен модуль Перевод.
Шаблон страницы Это файл, хранящийся в одном из каталогов:
  • /bitrix/templates/ID шаблона сайта/page_templates/

  • /bitrix/templates/.default/page_templates/
Данный файл представляет из себя "заготовку" публичной страницы. Как правило, используется при создании новой страницы в модуле Управление структурой (например, в HTML редакторе). Для задания порядка сортировки шаблонов страниц используется файл .content.php, находящийся в одном из вышеуказанных каталогов.
Пролог

В общем случае под данным термином понимается верхняя левая часть страницы.

Для публичной части пролог соответствующего шаблона сайта хранится в файле /bitrix/templates/ID шаблона сайта/header.php.

Для административной части пролог хранится в файле /bitrix/modules/main/interface/prolog_admin.php.

В свою очередь, пролог может быть разделен на служебную и визуальную части. В служебной части подключаются все необходимые классы, создаётся соединение с базой, создаётся ряд служебных экземпляров объектов, таких как $USER, $APPLICATION и т.д. В визуальной части выводится верхняя левая часть страницы.

Если в публичной части необходимо подключить неразделенный пролог, то используем следующий код:

require($_SERVER["DOCUMENT_ROOT"]."/bitrix/header.php");

Если по тем или иным причинам необходимо разделить пролог на служебную (prolog_before.php) и визуальную (prolog_after.php) части, то используем следующие коды:

require($_SERVER["DOCUMENT_ROOT"].
"/bitrix/modules/main/include/prolog_before.php");
...
require($_SERVER["DOCUMENT_ROOT"].
"/bitrix/modules/main/include/prolog_after.php");
Эпилог

В общем случае под данным термином понимается нижняя правая часть страницы.

Для публичной части эпилог соответствующего шаблона сайта хранится в файле /bitrix/templates/ID шаблона сайта/footer.php.

Для административной части эпилог хранится в файле /bitrix/modules/main/interface/epilog_admin.php.

В свою очередь, эпилог может быть разделен на служебную и визуальную части. В служебной части производится ряд таких действий, как: отсылка почтовых сообщений, отработка обработчиков события OnAfterEpilog и др. В визуальной части выводится нижняя правая часть страницы.

Если в публичной части необходимо подключить неразделенный эпилог, то используем следующий код:

require($_SERVER["DOCUMENT_ROOT"]."/bitrix/footer.php");

Если по тем или иным причинам необходимо разделить эпилог на визуальную (epilog_before.php) и служебную (epilog_after.php) части, то используем следующие коды:

require($_SERVER["DOCUMENT_ROOT"].
"/bitrix/modules/main/include/epilog_before.php");
...
require($_SERVER["DOCUMENT_ROOT"].
"/bitrix/modules/main/include/epilog_after.php");
Тело страницы | Тело страницы - это часть PHP/HTML кода, расположенного в скрипте между подключениями пролога и эпилога. Тело страницы не является частью шаблона сайта и представляет из себя индивидуальное содержимое публичной либо административной страницы.
Навигационная цепочка Это элемент дизайна, предназначенный в первую очередь для улучшения навигации по сайту. Навигационная цепочка выводится, как правило, в визуальной части пролога и состоит из заголовков разделов сайта с соответствующими ссылками на них. Помимо заголовков разделов, добавляемых автоматически, вы также можете добавлять произвольные пункты в навигационную цепочку.
Административная часть Это множество скриптов, в которых подключен административный пролог и эпилог. Их подключение подразумевает:
  • данная страница не принадлежит ни одному сайту
  • в то же время она принадлежит какому-либо модулю
  • имеет строго определённый административный интерфейс
  • все параметры локализации данной страницы зависят от выбранного текущего языка
  • на этой странице используется дополнительная проверка прав, задаваемых в настройках соответствующего модуля
Публичная часть В общем случае под данным термином понимается множество скриптов, у которых подключен пролог и эпилог одного из шаблонов сайта. Их подключение подразумевает:
  • данная страница принадлежит какому-либо сайту
  • имеет интерфейс текущего шаблона сайта
  • все параметры локализации данной страницы зависят от текущего сайта
Режим редактирования сайта | Режим, при котором текущая страница публичного раздела отображается в особом виде: выделены используемые компоненты, включаемые области, редактируемые области и т.д. Каждая такая область имеет набор кнопок для быстрого перехода к редактированию данного элемента страницы.
Индексная страница (файл) Это имя файла, который будет использован веб-сервером в случае, если запрашиваемый URL заканчивается на слэш и не содержит в себе имени файла. Порядок, в котором будут искаться индексные страницы для различных веб-серверов, задается по разному, например:
  • Apache - в файле httpd.conf, параметр DirectoryIndex
  • IIS - в свойствах сайта, закладка "Documents" -> "Enable default content page"
К сожалению, в PHP значение данного параметра недоступно, поэтому для определения индексной страницы в коде необходимо пользоваться функцией GetDirIndex.
Бюджет пользователя Синонимами данного термина можно считать "регистрация пользователя", "логин пользователя". Это запись в базе данных, содержащая параметры зарегистрированного пользователя с такими обязательными полями, как:
  • логин
  • пароль
  • E-Mail
А также ряд дополнительных полей, содержащих личную информацию о пользователе, информацию по его работе, административные заметки.
Мета-тег | Мета-тег - это один из элементов HTML, позволяющий задать информацию о странице. Например, указать кодировку страницы, ее ключевые слова, автора, задать краткое описание страницы. Как правило, содержимое мета-тегов используется в служебных целях, например, роботами поисковых систем, индексирующих сайт. Мета-тег задается внутри тега <head>.
Локализация | Подразумевает представление информации в переводе на определенный язык, в соответствующей кодировке данного языка и с использованием соответствующих форматов представления данных, характерных для этого языка (например, дата, время, денежные единицы, числа и т.д.).
Хост | В применении к функциям главного модуля под данным термином понимается доменное имя или IP адрес, посредством которого можно обратиться к тому или иному сайту.
Доменное имя (домен) Строго говоря, это одно из полей DNS-таблицы (domain name service), содержащее в себе строго структурированное имя интернет-сайта, заданное по определённым правилам. Основная задача DNS-таблицы - это ассоциация доменных имен с IP адресами сайтов.

Пример доменного имени: www.bitrixsoft.ru
IP адрес Это "имя" компьютера в сети, заданное по правилам протоколов TCP/IP. IP адрес состоит из четырех октетов, часть из которых идентифицирует подсеть, в которой находится компьютер, а часть - непосредственно этот компьютер в рамках соответствующей подсети.

Пример IP адреса: 198.63.210.79 (этому адресу в DNS-таблице соответствует доменное имя - www.bitrixsoft.ru)
Accept-Language Набор языков, установленных в браузере посетителя сайта.
Их можно выставить в меню браузера:
  • для MS Internet Explorer - "Tools" -> "Internet Options" -> "General" -> "Languages";
  • для Mozilla Firefox - "Инструменты" -> "Настройки" -> "Основное" -> "Языки".
Время в Unix-формате | Количество секунд, прошедшее с 1 января 1970 года, с точностью до микросекунды. На сегодняшний день время в Unix-формате может фиксироваться только до 2038 года.
Права в Unix системах В Unix-подобных операционных системах (являющихся доминирующими на сегодняшний день для интернет-серверов) поддерживаются три вида прав - чтение, запись и выполнение, которые присваиваются каждому файлу или директории. Права эти повторяются три раза: для владельца файла, для группы пользователей, к которой владелец принадлежит, и для всех остальных пользователей. Как правило, права указываются в числовом формате:
  • 4 - чтение
  • 2 - запись
  • 1 - выполнение
Сумма этих чисел дает окончательный набор прав, например, 6 - это чтение и запись, но без выполнения, 7 - все права, 5 - чтение и выполнение.
Таким образом, например, право 764 будет означать: 7 - все права для владельца файла, 6 - чтение и запись для группы пользователей, к которой принадлежит владелец файла и 4 - чтение для всех остальных пользователей.
В PHP все права задаются в виде восьмеричных чисел, поэтому их надо задавать с обязательным указанием префикса - 0.

Пример: 0755.
Путь относительно корня Путь к файлу, начинающийся от каталога, указанного в параметре DocumentRoot в настройках веб-сервера, заданный по правилам формирования URL-адресов.

Пример: /ru/about/index.php
Полный путь Включает в себя протокол, домен, порт и путь относительно корня к странице (каталогу).

Пример: http://www.bitrixsoft.ru/ru/about/index.php
Абсолютный путь | Абсолютный путь к файлу включает в себя DocumentRoot и путь относительно корня.
DocumentRoot Путь к корню сайта в файловой системе сервера. Задается в настройках веб-сервера, например:
  • для Apache - в файле httpd.conf, параметр DocumentRoot;
  • для IIS - в свойствах сайта, закладка "Home Directory" -> "Local Path".
Сабмит | Отправка данных HTML-формы на сервер.
Сессия | Под данным термином понимается сессия PHP. Сессия может открываться в момент захода на сайт и закрывается при закрытии окна браузера. Также новая сессия открывается при авторизации пользователя, если закончить сеанс авторизации (разлогиниться) - сессия закрывается. Синонимом термина Сессия можно считать один "заход на сайт".
HTML-безопасный вид Как правило, данный термин применяют к тексту, в котором произведены следующие замены:
Исходное | Результат
< | &lt;
> | &gt;
" | &quot;
& | &amp;

Подобные замены позволяют выводить текст внутри HTML-кода, не опасаясь, что он будет интерпретирован браузером как часть этого HTML-кода.
Связывание переменных | В применении к SQL-запросам для Oracle версии, под данным термином подразумевается связывание имен переменных (либо полей таблицы) с их значениями. Как правило, подобная технология используется для полей типа BLOB, CLOB, LONG и т.п., предназначенных для хранения больших объемов данных.
Дамп В применении к базе данных под данным термином подразумевается выгрузка содержимого и, возможно, структуры таблиц в файл в определённом формате для их возможной дальнейшей загрузки обратно в данную либо любую другую базу. Для каждой базы данных существуют свои утилиты, позволяющие сделать дамп, например, для MySQL утилита mysqldump позволяет выгрузить в формате обычных SQL-запросов, для Oracle утилита exp позволяет выгрузить в своем внутреннем формате.
В применении к переменным дамп подразумевает отображение структуры и содержимого переменной в текстовом виде.
cron (крон) | В Unix-подобных операционных системах утилита cron позволяет организовать запуск скриптов по четко указанному расписанию.
Буферизация | Под термином "буферизация" в PHP понимается такой режим, при котором весь исходящий поток данных из PHP-скрипта (например, HTML-код) запоминается предварительно в памяти и не отдается в "поток", т.е. не отсылается браузеру пользователя. Буферизацию в PHP можно включить с помощью функции ob_start. В дальнейшем буферизацию можно отключить, например, с использованием функции ob_end_flush, при этом все накопленные данные будут отосланы браузеру. Буферизация позволяет произвольно манипулировать исходящим потоком данных, на этом принципе основана технология отложенных функций.
Постоянное соединение (persistent) | При создании соединения с базой в памяти создаётся дескриптор данного соединения. Если соединение обычное, то после отработки скрипта этот дескриптор удаляется, если соединение "постоянное", он остается и может быть использован другими процессами при необходимости. Достоинством "постоянного" соединения является то, что, как правило, времени на него требуется меньше, но в то же время есть недостаток - количество открытых "постоянных" соединений ограничивается в настройках базы данных и при превышении этого лимита посетитель не сможет зайти на сайт, пока не освободятся новые соединения.
Почтовое событие Это почтовое сообщение, имеющее свой тип и отправляемое по соответствующему почтовому шаблону. Почтовое событие инициализирует поля типа почтового события конкретными значениями. Порядок расположения этих полей в письме, а также текст письма определяется почтовым шаблоном.
Для создания почтового события предназначен класс CEvent.
Почтовый шаблон Определяет текст почтового сообщения, а также порядок расположения полей (placeholder'ов), заданных в типе почтового события.
Почтовые шаблоны доступны в административном меню "Настройки системы" -> "Почтовые шаблоны".
Для манипуляции почтовыми шаблонами предназначен класс CEventMessage.
Тип почтового события Определяет набор специальных полей (placeholder'ов), которые могут быть использованы в почтовом шаблоне. В момент создания почтового события эти поля будут инициализированы конкретными значениями.
Для манипуляции типами почтовых событий предназначен класс CEventType.
ЧПУ Человекопонятные URL. Веб-адреса, удобные для восприятия человеком (а также системы и методы построения таких адресов).

При формировании каждой динамической страницы система создает адрес с соответствующим целочисленным идентификатором. (Например, /bitrix/admin/iblock_element_admin.php?IBLOCK_ID=48&type=help&lang=ru&find_section_section=4972) Это вполне понятно и естественно для разработчиков и программ, но не совсем понятно и удобно для посетителей.

Концепция ЧПУ предполагает максимально лаконичные и интуитивно понятные адреса, которые показывают естественную для человека логическую структуру данных на сервере, а не её программный интерфейс с модулями и параметрами.


Сложная логика в фильтре

В некоторых полях фильтров (в основном, текстовых или символьных) можно вводить запросы.

Использование запросов

Запрос представляет из себя логическое выражение. Например, выборка пользователей по полю ФИО пользователя. Если ввести

Пётр & Иванов

то отфильтруются все пользователи, у которых в поле ФИО встречаются оба эти слова, либо полностью, либо частично. Такого же результата можно добиться, написав эти слова через пробел: Пётр Иванов.

Если нужно отфильтровать всех пользователей, у которых в поле ФИО встречается Пётр или Иванов, необходимо ввести запрос:

Пётр | Иванов

Когда необходимо использовать отрицание, предусмотрен логический оператор "~". Например:

(Пётр | Иванов) & ~Сидоров.

Данный запрос означает: вывести всех пользователей, у которых в поле ФИО встречаются сочетания букв Пётр или Иванов и в то же время не встречаются Сидоров.

В последнем запросе были использованы круглые скобки. Это обусловлено тем, что оператор "|" имеет более низкий приоритет, чем оператор "&" (см. таблицу Приоритеты логических операторов). В противном случае, если бы мы не указали круглых скобок, запрос Пётр | Иванов & ~Сидоров имел бы следующее значение: вывести всех пользователей, у которых в поле ФИО встречаются сочетания букв Иванов и не встречаются Сидоров, либо всех пользователей, у которых в поле ФИО встречается Пётр.

Вы можете использовать скобки и для построения более сложных запросов.

Помимо вышеописанных операторов, возможно использование операторов для задания масок. Например, вы не помните ФИО нужного вам человека, но точно знаете что фамилия начинается на "Пе" и заканчивается на "ова", при этом имя этого человека "Ирина" либо "Ирэна". Для описания данных условий необходимо использовать следующий запрос: Пе%ова & Ир_на. В данном запросе были использованы два оператора: "%", означающий "ноль, либо более любых символов" и оператор "_", означающий "один любой символ".

В случае, если вам необходимо использовать поиск слов, содержащих зарезервированные символы, воспользуйтесь двойными либо одинарными кавычками, например: "~NICK~" | '&Leon&'. Если вам необходимо найти фразу содержащую пробелы, выделите ее двойными либо одинарными кавычками, например: "Microsoft Internet Explorer" | 'Netscape Navigator'.

Во всех выражениях запроса регистр символов значения не имеет.

Операторы в запросах. Приоритет операторов

Оператор | Описание
& | Логический оператор "и" можно опускать: запрос Пётр & Иванов полностью эквивалентен запросу Пётр Иванов.
| | Логический оператор "или" позволяет искать записи, содержащие хотя бы один из операндов.
~ | Логический оператор "не" позволяет искать записи, не содержащие слово, указанное сразу после оператора, либо означает отрицание выражения, следующего сразу за этим оператором.
( ) | Круглые скобки задают порядок действия логических операторов.
% | Оператор задания маски. Означает "0 или более любых символов".
_ | Оператор задания маски. Означает "1 любой символ".

Приоритеты логических операторов

Оператор | Приоритет
~ | 1
& | 2
| | 3


Контент

Модули раздела
Название | Описание
Управление структурой | Служит для управления информационным наполнением и структурой сайта(ов), меню и правами доступа.
Облачные хранилища | Позволяет просматривать файлы и папки, расположенные в облачных хранилищах.
Информационные блоки | Предоставляет возможность управлять и каталогизировать различные типы (блоки) однородной информации.
Highload-блоки | Модуль для работы с произвольными наборами данных в условиях высоких нагрузок.
Документооборот | Предназначен для организации последовательной обработки статических страниц, а также динамической составляющей сайта.
Wiki | Служит для коллективной работы над контентом страницы.
Агрегатор библиотек документов (КП) | Позволяет организовать коллективный доступ к офисным документам, хранящимся на сервере, с возможностью редактировать их, сохранять изменения, вести историю версий в системе документооборота, работать с файлами через проводник. Модуль относится только к "Битрикс24 в коробке".
Задачи (КП) | Предназначен для управления задачами на портале. Модуль относится только к "Битрикс24 в коробке".
Универсальные списки | Визуальный редактор универсальных списков - инструмент для управления списками (товаров, партнеров, клиентов и т.д.).


Управление структурой. Описание модуля

Описание

Модуль Управление структурой служит для управления информационным наполнением и структурой сайта(ов), меню и правами доступа.

Система управления структурой сайта представляет собой Менеджер файлов, который позволяет создавать новые страницы, новые каталоги (разделы сайта), копировать, перемещать, удалять файлы и папки, редактировать текст страниц и многое другое.

Для управления структурой веб-сайта не обязательно владеть специальными знаниями программирования и HTML-вёрстки. Используя кнопки управления, можно управлять структурой сайта, меню, редактировать содержание, создавать новые страницы и распределять права доступа.

Компоненты модуля

Модуль включает в себя следующие компоненты 2.0:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Медиа
Медиа проигрыватель | player | Осуществляет проигрывание медиафайлов различных форматов, поддерживает проигрывание плей-листов.
Google Maps
Google: поиск по адресу | map.google.search | Осуществляет отображение карты с сервиса Google Maps и предоставляет возможность поиска по адресу. Поддержка детального поиска (по улице и дому) осуществляется в соответствии с возможностями сервиса Google Maps.
Google: настраиваемая карта | map.google.view | Осуществляет отображение карты с сервиса Google Maps. Компонент позволяет выводить саму карту, задавать на ней стартовую позицию и добавлять на карту дополнительную информацию.
Яндекс.Карты
Яндекс: поиск по адресу | map.yandex.search | Осуществляет отображение карты с сервиса Яндекс.Карты и предоставляет возможность поиска по адресу. Поддержка детального поиска (по улице и дому) осуществляется в соответствии с возможностями сервиса Яндекс.Карты.
Яндекс.Карты (системный компонент) | map.yandex.system | Осуществляет отображение карты с сервиса Яндекс.Карты.
Яндекс: настраиваемая карта | map.yandex.view | Осуществляет отображение карты с сервиса Яндекс.Карты. Компонент позволяет выводить саму карту, задавать на ней стартовую позицию и добавлять на карту дополнительную информацию.
Другое
Упрощенный HTML-редактор | fileman.light_editor | Выводит упрощенный визуальный HTML-редактор.
Системные компоненты (не описываются)
Форма авторизации | system.auth.authorize | Осуществляет вывод формы авторизации.
Форма смены пароля | system.auth.changepasswd | Осуществляет вывод форма смены пароля.
Форма отправки контрольного слова для смены пароля | system.auth.forgotpasswd | Осуществляет вывод форма отправки контрольного слова для смены пароля.
Форма регистрации | system.auth.registration | Осуществляет отображение формы регистрации.
Форма ввода настраиваемого пользовательского свойства | system.field.edit | Осуществляет ввод настраиваемого пользовательского свойства.
Форма вывода настраиваемого пользовательского свойства | system.field.view | Осуществляет вывод настраиваемого пользовательского свойства.
Шаблон постраничной навигации | system.pagenavigation | шаблон постраничной навигации.
Форма вывода сообщения об ошибке | system.show_message | Осуществляет вывод сообщения об ошибке.

Смотрите также

  • Как создать раздел и страницу
  • Как добавить страницу (раздел) через административный раздел
  • Как настроить визуальный редактор (только для старого редактора)
  • Менеджер файлов
  • Загрузка и поиск файлов
  • Документация для разработчиков по модулю Управление структурой
  • Управление структурой (учебный курс)


Управление структурой. Настройки модуля

Форма настроек модуля Управление структурой (Настройки > Настройки продукта > Настройки модулей > Управление структурой) предназначена для задания общесистемных параметров модуля. Для удобства работы форма разделена на закладки, на каждой из которых выполняется настройка определённой группы параметров модуля.

Настройки

Закладка предназначена для настройки общих параметров модуля.

Поле | Описание
Редактор страниц по умолчанию Указывается редактор страниц умолчанию. Доступны следующие редакторы:
  • Текстовый редактор - отображает сам текст файла и все HTML-теги, без включения PHP кода;
  • Редактирование PHP скрипта - отображает исходный текст файла. Предназначен исключительно для использования разработчиками.
  • Визуальный HTML редактор - открывает встроенный визуальный HTML-редактор, позволяющий форматировать текст аналогично Microsoft Word.
Расширения исполняемых файлов (для контроля доступа) | Указываются расширения исполняемых файлов через запятую для контроля доступа.
Разрешенные компоненты Указываются компоненты, которые будут показаны в визуальном редакторе.

Каждое название компонента или маска указывается с новой строки.

По умолчанию поле пустое, то есть будут отображены все компоненты. Поле - разрешающее, то есть введенные имена компонентов отображаются, остальные - нет.

Заполнять поле может только администратор сайта.

Поле фильтрует только системные компоненты, т.е. задавать здесь пространство имен (namespace) не имеет смысла. Выведены будут только компоненты из пространства имен bitrix, компоненты из других пространств имен будут проигнорированы.

Внимание! После ввода разрешенных компонентов для всех пользователей, в том числе и для администратора сайта, при редактировании страниц и сохранении изменений все неразрешенные компоненты будут удалены со страницы.

Не отображать раздел "Файлы и папки" в меню "Структура сайта" | При отмеченной опции физическая структура сайта (раздел Файлы и папки) будет не доступен, отображаться будет только логическая структура.
Включить возможность автоматического генерирования имени файлов и папок из названий при создании страниц и разделов | При отмеченной опции имена файлов или папок будут генерироваться из названий заголовков страниц или разделов.
Использовать внешний сервис для автоматического генерирования имен файлов и папок При отмеченной опции в качестве имен файлов или папок будет использован перевод названий заголовков страниц или разделов.

Внимание! Для работы с сервисом Яндекс.Перевод требуется подключение к сети интернет.

Журналировать действия пользователей | При отмеченной опции в Журнале событий (Настройки > Инструменты > Журнал событий) будет вестись журналирование действий над статическими страницами и разделами.
Использовать редактор кода с подсветкой синтаксиса | Опция позволяет включить режим подсветки синтаксиса в невизуальных режимах правки файлов Редактировать как текст и Редактировать как PHP. Также синтаксис будет подсвечивается на страницах Командная PHP-строка и SQL запрос (Настройки > Инструменты).
Настройки для сайтов
Использовать индивидуальные настройки для каждого сайта | При отмеченной опции для каждого из созданных в системе сайтов могут быть заданы индивидуальные Типы меню и Типы свойств.
Настройки для сайта | В выпадающем списке доступны все созданные в системе сайты. Выбор сайта доступен при отмеченной опции Использовать индивидуальные настройки для каждого сайта.
Типы меню В мини-форме указываются используемые на сайте типы меню и их описания.
Поле | Описание
Тип | Тип (мнемоническое имя) используемого на сайте меню. Обычно мнемонические имена типов меню назначаются, исходя из расположения меню на странице сайта (например, top, left и т.д.). Имя типа меню указывается латинскими буквами.
Название | Произвольное название (описание) типа меню.
Количество дополнительных параметров меню | Указывается количество полей для задания значений параметров, обрабатываемых в шаблоне показа меню и влияющих на представление меню.
Типы свойств В мини-форме указываются свойства страниц сайта и их описания.
Поле | Описание
Тип | Тип (мнемоническое имя) свойства. Указывается латинскими буквами.
Название | Произвольное название (описание) свойства. Указанное название будет отображаться в форме задания значений свойств для папки или страницы.

Примечание: мнемонические имена типов свойств, используемых для управления метаданными страницы, должны соответствовать названиям соответствующих мета-тегов в языке HTML. Например, ключевые слова - keywords, описание - description.

Параметры поиска файлов
Максимальный размер файлов по которым осуществляется поиск по содержимому | Задается максимальный размер файлов, по которым будет осуществляться поиск по содержимому.
Максимальное количество записей выводимых в результате поиска | Задается максимальное количество записей, которые будут выводиться в результате поиска. Для вывода неграниченного количества записей оставьте поле пустым.
Время одного шага в многошаговом поиске файлов | Задается время выполнения одного шага при многошаговом поиске в секундах. Используется при поиске большого количества файлов, тогда поиск будет происходить за несколько шагов. Результаты поиска будут выводиться в конце каждого шага.
Значение поля "Имя файла или папки" в диалоге поиска файлов по умолчанию | Указывается значение поля "Имя файла или папки", которое будет отображаться по умолчанию в диалоге поиска файлов. Для удобства поиска по умолчанию поле содержит *.php.
Параметры архивации
Время одного шага при архивации (сек): Продолжительность каждого шага архивации.

Визуальный редактор

Закладка предназначена для настройки визуального HTML-редактора [image].

Поле | Описание
Использовать новый визуальный редактор При отмеченной опции будет использоваться новый визуальный редактор.

Примечание: некоторые опции в форме при этом становятся недоступны.
Разрешить в визуальном HTML редакторе выводить стили без названий При отмеченной опции при редактировании страницы с помощью визуального HTML-редактора будут выведены в списке доступных CSS стилей в том числе и те стили, для которых не заданы названия.

Примечание: названия стилей задаются в файле .styles.php, размещённом в папке соответствующего шаблона сайта.
Отображать внешний вид стилей в выпадающем списке | При отмеченной опции названия стилей будут отображаться в соответствии с их оформлением.
По умолчанию открывать HTML редактор в полноэкранном режиме | При отмеченной опции визуальный HTML-редактор по умолчанию будет открываться в полноэкранном режиме.
Разрешить предварительный просмотр компонентов в визуальном редакторе | При отмеченной опции будет доступен предварительный просмотр результата работы компонентов при создании или редактировании страниц. В настройках самого редактора возможно отключение функции для конкретного пользователя.
Идентификатор элемента BODY области редактирования в визуальном редакторе | Задается идентификатор элемента BODY области редактирования визуального редактора для возможности реализации корректного применения стилей шаблона.
Название CSS класса для элемента BODY области редактирования в визуальном редакторе | Задается название CSS класса элемента BODY области редактирования визуального редактора для возможности реализации корректного применения стилей шаблона.
Настройка кнопок панелей инструментов редактора
Визуальный редактор Задается набор кнопок и панелей инструментов для каждого из режимов работы визуального редактора:
  • редактирование файлов в публичной части;
  • редактирование файлов в административной части;
  • редактирование шаблонов сайтов;
  • редактирование элементов инфоблоков в публичной части;
  • редактирование элементов инфоблоков в административной части;
  • редактирование рассылок;
  • редактор в модуле обучения в публичной части;
  • редактор в модуле обучения в административной части;
  • редактирование шаблонов веб-форм в административной части;
  • редактирование шаблонов веб-форм в публичной части.
Настройки преобразования содержимого
*Автоматически заменять переводы строки на <br> при переключении режимов "Текст/HTML/Визуальный редактор" | При отмеченной опции система автоматически будет заменять переводы строки при работе в режимах "Текст" и "Визуальный редактор" на тег <br>, используемый в режиме "HTML"
Скрывать исходный код компонентов 2.0 при просмотре страницы в режиме кода | При отмеченной опции исходный код компонентов 2.0 при просмотре страницы в режиме кода будет скрыт.
Группы символов, автоматически заменяемые на HTML-сущности при сохранении страницы Указываются группы символов, которые будут автоматически заменены на HTML-сущности при сохранении страницы:
  • Дополнительные символы европейских алфавитов (умляуты и пр.);
  • Символы греческого алфавита;
  • Другие символы, имеющие замену в виде html-сущностей.
*Настройки системы проверки орфографии
Использовать для проверки pSpell/aSpell Опция доступна, если на сервере установлено расширение php - pSpell и имеются библиотеки aSpell (система словарей), доступные по адресу http://aspell.sourceforge.net/ [image].

Установить расширение и загрузить дополнительные словари можно с помощью ссылок Установка pSpell [image] и Дополнительные словари [image].
Имя каталога для хранения пользовательских словарей | Необходимо указать путь к каталогу, хранящему пользовательские словари.
Использовать для каждого пользователя свой словарь | При отмеченной опции система будет запоминать настройки словаря отдельно для каждого пользователя.

* - только для нового визуального редактора

Медиабиблиотека

Поле Описание
Использовать медиабиблиотеку При отмеченной опции станет доступным [dw]функционал[/dw] [di]Функционал Медиабиблиотеки:
Размеры картинок предпросмотра в диалоговом окне медиабиблиотеки (Ш х В) | Указывается ширина и высота картинок предпросмотра загруженных в медиабиблиотеку элементов.
Другие разрешенные расширения медиафайлов (кроме перечисленных в типах медиабиблиотеки) | В поле задаются расширения доступных медиафайлов.
Максимальный размер загружаемых в медиабиблиотеку изображений (Ш х В) | Указывается максимальная ширина и высота (в пикселях) загружаемых изображений в медиабиблиотеку.
Использовать медиабиблиотеку по умолчанию при выборе медиафайлов | При отмеченной опции по умолчанию при выборе медиафайлов будет использоваться медиабиблиотека.
[/di]Медиабиблиотека, который позволяет создавать многоуровневую структуру коллекций элементов для дальнейшего использования загруженных элементов при редактировании страниц и инфоблоков. В меню административного раздела будет добавлен пункт Медиабиблиотека, где можно управлять коллекциями и элементами.
Типы содержимого медиабиблиотеки
Перечислены существующие типы содержимого медиабиблиотеки:
Поле | Описание
<название_типа> | Выводится название типа содержимого медиабиблиотеки. Для удаления выбранного типа содержимого медиабиблиотеки нажмите ссылку Удалить, а затем кнопку Сохранить.
Название2 | Название типа содержимого медиабиблиотеки.
*Символьный код12 | Символьный код типа содержимого медиабиблиотеки..
Список расширений файлов1 | Список расширений файлов, входящих в данный тип содержимого медиабиблиотеки.
Описание | Произвольное описание типа содержимого медиабиблиотеки.

Кнопка Добавить позволяет создать свой тип содержимого.

Примечание: при добавлении нового типа необходимо будет заполнить поля Название, Символьный код, Список расширений файлов и Описание, а затем нажать кнопку Сохранить.

* - поля, обязательные для заполнения.
1 - разрешено использовать только символы латинского алфавита и цифры.
2 - поля, обязательные для заполнения, при создании нового типа.

Доступ

Закладка позволяет настроить права на доступ к модулю для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Управление структурой:
  • [D] Доступ закрыт - запрет на доступ;
  • [F] Редактирование файлов и папок - доступ открыт к тем файлам и папкам, в свойствах которых разрешен доступ для данной группы пользователей;
  • [W] Полный доступ - полный доступ к ресурсам модуля.
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.
Группы редакторов по умолчанию
При создании файлов (папок) и ограничении доступа устанавливать по умолчанию полные права на файлы и папки для групп Группы пользователей, которые будут относиться к редакторам сайта. Эти группы получают по умолчанию полные права на файлы и папки при их создании.

Данные группы используются при создании новых страниц или разделов из публичной части сайта, которые будут не видны другим пользователям, пока происходит формирование и наполнение контентом страницы или раздела. Права на просмотр таких страниц задаются опцией Ограничить доступ к странице (не публиковать), которая расположена в Мастере создания новой страницы/раздела. Для вызова мастера используйте кнопки Создать раздел или Создать страницу, расположенные в публичной части сайта.


Менеджер файлов

Смотрите также:

Подробная информация в учебных курсах.

  • Как изменить свойства страниц и разделов
  • Как создать раздел и страницу
  • Как ограничить доступ к странице или разделу
  • Как добавить страницу (раздел) через административный раздел
  • Примеры создания меню
  • Загрузка и поиск файлов


Менеджер файлов

Управление структурой "1С-Битрикс: Управление сайтом" осуществляется в Менеджере файлов (Контент > Структура сайта).

Менеджер файлов организован подобно правой панели Проводника Windows и представляет собой каталог папок и файлов, на верхнем уровне иерархии которого располагаются сайты, работающие под управлением системы, система физических папок Файлы и папки и Медиабиблиотека.

Отличие между сайтами, работающими под управлением системы, и папкой Файлы и папки заключается в том, что первые представляют - логические папки, а вторая - физические. Первые созданы для быстрого доступа к файлам обычных пользователей по логике структуры сайта. Вторые - для быстрого доступа к файлам для разработчиков сайтов.

В логической структуре отображаются не все физические файлы и папки, а только те, которым задан Заголовок (поле Заголовок) при создании страницы, раздела.

Обычно веб-сайт подразделяется на разделы (Менеджером файлов разделы отображаются как папки), содержащие сгруппированные по тематике наборы файлов. Папки Менеджера файлов позволяют организовать структурированное хранение информации сайта: веб-страниц, шаблонов, фотографий и пр.

Информация об имени файла или папки, размере, дате последнего изменения, уровне прав доступа к файлу показаны в форме таблицы. Нажав на название папки (оно представлено в виде ссылки), можно перейти внутрь этой папки. C помощью двойного щелчка по названию файла, можно открыть данный файла для редактирования.

Описание и Фильтр

Поле | Описание
Имя | Поиск файлов и папок по названию.
Дата изменения | Поиск файлов и папок по интервалу даты изменения.
Тип Поиск содержимого по типу данных:
  • (все);
  • Файл;
  • Папка.
Чтобы отфильтровать сообщения по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех сообщений, нажмите кнопку Отменить.

Контекстная панель

Служит для управления содержимым папки, а также настройки ее свойств.

Кнопка | Описание
Добавить папку | Создать новую папку в текущем каталоге.
Добавить файл | Создать новый файл в текущей папке.
Добавить меню | Добавить меню в данный раздел.
Загрузить файл | Загрузить файл в текущую папку с локального компьютера.
Свойства папки | Просмотр и изменение свойств текущей папки (изменение заголовка раздела; управление правами доступа к разделу, а также значениями свойств страниц раздела).
Показать права на доступ для | Показать в колонке Права на доступ продукта уровень прав доступа к отображаемым файлам и папкам для выбранной группы пользователей. См. также Права доступа
Путь | Чтобы перейти в определённую директорию сайта, укажите путь к папке в этом поле и нажмите кнопку OK.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Поля менеджера файлов

Поле | Описание
Колонка флажков | Выбор элементов, к которым предполагается применить какое-либо правило или действие.
Действия Операции над папками:
  • Открыть - открыть папку в менеджере файлов;
  • Свойства папки - перейти к форме редактирования свойств папки;
  • Архивировать - создать архив в формате <имя_папки>.tar.gz;
  • Переименовать - изменить название папки;
  • Копировать... - копирование папки;
  • Перенести... - перенос папки;
  • Удалить - удалить выбранную папку;
  • Права на доступ продукта - переход к форме изменения прав доступа к данной папке.
Последние четыре пункта видны только в Файлах и папках.

Операции над файлами:
  • Редактировать как HTML - изменение файла в HTML-формате;
  • Редактировать как текст - изменение файла в текстовом формате;
  • Редактировать как PHP - изменение PHP-кода файла;
  • Редактировать в модуле документооборота - изменение файла с регистрацией в модуле документооборота;
  • Просмотр файла - просмотр содержимого файла, а также информации о его размере, дате последнего доступа и изменения;
  • Скачать файл - скачать файл на локальный компьютер;
  • Архивировать - создать архив в формате <имя_файла>.tar.gz;
  • Переименовать - изменить название файла. Пункт меню действует при работе с физической структурой сайта;
  • Копировать... - копирование файла;
  • Перенести... - перенос пфайла;
  • Удалить - удаление файла;
  • Права на доступ продукта - переход к форме изменения прав доступа к данному файлу.
  • Перенести в облако - перенос файла в выбранное облачное хранилище. (Доступно при подключенном облачном хранилище.)
Последние пять пунктов видны только в Файлах и папках.
Имя | Заголовок папки или файла.
Имя файла (папки) | Имя папки или файла. Данное поле доступно только для структуры сайта.
Размер файла | Размер файла в байтах.
Изменен | Дата и время последнего изменения файла или папки.
Тип Тип элемента списка:
  • Папка;
  • Файл (изображение, архив и т.д.);
  • Системный файл;
  • Текстовый документ;
  • Документ HTML;
  • Скрипт PHP.
Права на доступ продукта | Права доступа к файлам и папкам для выбранной группы пользователей.

Операции над папками и файлами

К каждому файлу и папке, отображаемым в Менеджере файлов, можно применить различные операции по изменению их расположения и свойств.

Чтобы осуществить любое из действий над файлами и папками, следует выделить требуемые файлы и папки флажками в крайнем левом поле менеджера файлов. После этого для выполнения операций можно воспользоваться командами в поле [dw]Действия[/dw][di] [image] [/di], расположенном на панели управления внизу страницы.

Выберите нужное действие в списке и нажмите кнопку Применить. После чего будет открыто окно/страница с дальнейшими действиями.

Действие | Описание
Права на доступ продукта | Переход к форме редактирования прав доступа к выбранным файлам и папкам. Для изменения прав доступа достаточно выбрать право для конкретной группы пользователей и нажать кнопку Сохранить.
Копировать... | Копирование выбранных файлов и папок. В появившемся окне укажите путь к папке, в которую следует копировать выбранные файлы/папки и нажмите кнопку Копировать.
Архивировать | Создание из выбранных файлов и папок архива в формате *.tar.gz или *.zip;. Для использования архивов типа *.zip в файле php.ini должно быть разрешено extension=php_zip.dll.
Перенести... | Перемещение выбранных файлов и папок. В появившемся окне укажите путь к папке, в которую следует перенести выбранные файлы/папки и нажмите кнопку Перенести.

Редактирование меню текущего раздела

Меню текущего раздела показываются в Менеджере как файлы с именами вида [dw]Меню типа «ХХХ»[/dw][di] [image] [/di] (например, Меню типа «top»). Чтобы перейти к редактированию меню, достаточно двойного клика по ссылке с его названием (см. Меню)

Смотрите также

  • Менеджер файлов


Права доступа

Право доступа - набор правил, определяющих каким уровнем доступа обладает та или иная группа пользователей (например, чтение - это просмотр содержимого страницы или раздела). Права доступа обладают свойством "наследования", т.е. если для текущего раздела/страницы явно не задан уровень прав, то устанавливается то право, которое задано для вышележащего раздела.

Управление доступом пользователей к страницам и разделам сайта выполняется как из публичной, так и в административной части.

Управление доступом из публичной части

Работа с правами доступа подробно описана в уроке Управление правами доступа [image] курса Контент-менеджер.

Управление доступом из административной части

В административной части управление доступом выполняется с помощью Менеджера файлов (Контент > Структура сайта > Файлы и папки).

Чтобы изменить права доступа к папке или файлу, необходимо выбрать пункт Права на доступ продукта в меню действий папки или файла либо:

  • Установить флаг в поле рядом с названием папки или файла (уровень прав доступа может быть настроен одновременно для нескольких файлов и папок);
  • Выбрать в поле Действия, расположенном на панели управления внизу страницы, пункт Права на доступ продукта и нажать кнопку Применить.

После этого будет открыта форма редактирования прав доступа к выбранному файлу или папке (или нескольким файлам и папкам). По умолчанию настройки прав доступа к папке распространяются на все вложенные файлы и папки через механизм наследования.

Контекстная панель

Кнопка | Описание
Каталог | Переход в папку, открытую в данный момент в менеджере файлов.

Поля формы

Поле | Описание
Группа | Группа пользователей сайта, для которой выполняется настройка прав доступа. Управление группами пользователей осуществляется в главном модуле на странице Группы пользователей.
Право Изменение текущего права доступа группы пользователей к файлу или разделу. Назначаются следующие уровни доступа:
  • (оставить без изменений) – права доступа изменены не будут;
  • Запрещён – доступ пользователей к данной папке или файлу закрыт;
  • Чтение – пользователям разрешено просматривать информацию файла или папки;
  • Документооборот – пользователям разрешена работа с файлами в документообороте.
  • Запись – пользователи могут создавать, изменять и удалять файлы;
  • Полный доступ – пользователям разрешается не только изменять файлы, но и управлять правами доступа других пользователей;
  • Наследовать – для выбранных файлов или папок будут назначены те же права, что и для вышележащей папки;
Текущее право | Право доступа к файлу или разделу, которым группа пользователей обладает в данный момент.

Смотрите также

  • Доступ к пунктам меню
  • Управление доступом к папкам и файлам


Редактирование меню

Редактирование пунктов меню возможно как в административном, так и в публичном разделе. В административной части меню можно отредактировать одним из трех способов: с помощью формы в упрощенном или в расширенном режиме, либо как код текстового файла.

Административная часть

Форма предназначена для создания нового или редактирования уже существующего меню.

Контекстная панель

Кнопка | Описание
Каталог | Переход в папку, открытую в данный момент в Менеджере файлов.
Расширенный режим/Упрощенный режим | Переключение между режимами редактирования меню.
Редактировать как файл | Переключение в режим редактирования кода меню.
Удалить меню | Удаление меню.

Форма редактирования меню. Упрощенный режим

Форма служит интерфейсом для создания пунктов меню в упрощённом режиме. Для добавления новых пунктов следует заполнить поля таблицы и сохранить внесённые изменения.

Поле | Описание
Тип меню | Тип создаваемого/редактируемого меню.
Пункты меню
Поле | Описание
Название | Название пункта меню, как оно будет показано в меню в публичной части.
Ссылка | Ссылка на страницу или раздел сайта.
Сортировка | Порядок сортировки пунктов меню. Меньшее число соответствует более высокому положению.
Удалить | Чтобы удалить пункт меню, установите флаг в это поле и нажмите кнопку Сохранить или Применить.

Форма редактирования меню. Расширенный режим

Форма редактирования пунктов меню в расширенном режиме позволяет изменять значения дополнительных параметров пунктов меню.

Поле | Описание
Тип меню | Тип создаваемого/редактируемого меню.
Шаблон для меню | Шаблон для создаваемого/редактируемого меню.
Пункты меню
Название | Название пункта меню, как оно будет показано в меню в публичной части.
Ссылка | Ссылка на страницу или раздел сайта.
Сортировка | Порядок сортировки пунктов меню. Меньшее число соответствует более высокому положению.
Удалить | Чтобы удалить пункт меню, установите флаг в это поле и нажмите кнопку Сохранить или Применить.
Доп. ссылки для подсветки Указываются страницы сайта, при переходе на которые также будет подсвечиваться (выделяться) создаваемый пункт меню.

Например, пункт меню Siemens ссылается на страницу со списком телефонов соответствующей марки (/catalog/phone/section.php).Если вы хотите, чтобы при просмотре детальной информации о каждой модели телефона также выделялся пункт меню Siemens, то в этом поле нужно указать путь к странице с детальной информацией о модели телефона (например, /catalog/phone/element.php).

Путь к страницам задается относительно корня сайта. Если все страницы, при переходе на которые должен быть подсвечен пункт меню, хранятся в одной папке сайта, то в поле Доп. ссылки для подсветки можно указать путь к данной папке относительно корня сайта. Например, /catalog/phone/.
Тип условия Тип условия, при выполнении которого пункт меню будет показываться посетителям:
  • [без условия]: пункт меню будет отображен без какого-либо условия;
  • Для папки или файла: страница или подраздел текущего раздела сайта, в котором будет показываться данный пункт меню;
  • Для групп пользователей: группы пользователей, для которых будет показываться данный пункт;
  • Период времени: дата или период времени, в течение которого пункт меню будет показан;
  • Параметр в URL: параметр в URL страницы, при наличии которого пункт меню будет показан;
  • Выражение PHP: произвольное условие на языке PHP. Условие должно быть указано так, как оно выглядит внутри оператора if(). При формировании страницы с помощью оператора if() осуществляется проверка условия на выполнение. Если условие выполняется (т.е. выражение принимает значение true), то пункт меню будет показан пользователю. Например, с помощью условия $USER->IsAuthorized() можно проверять, является ли текущий пользователь авторизованным на сайте.
  • [выключено]: пункт меню не будет показан.
Условие | Условие, при выполнении которого будет отображаться пункт меню.
Параметры Указываются любые параметры, используемые при построении шаблоном пункта меню. Параметры хранятся в ассоциированном массиве $PARAMS в виде пар "имя =>значение". При построении меню по шаблону, в самом шаблоне может быть добавлена проверка параметра, например:
if ($PARAMS["MY_PARAM"]=="Y")
или подставлено его значение:
<a href='".$link."'
 class='".$clrtext."'
 title='".$PARAMS["ALT"]."'>".$TEXT."". $clrimg ."</a>

В поставляемом дистрибутиве продукта для меню используется параметр Дополнительное выделение пунктов меню, позволяющий выделить первый пункт меню с помощью разделителя. Для этого в поле Название параметра необходимо указать SEPARATOR, а в поле Значение ввести Y.

Кнопка Вставить добавляет в форму еще один пункт меню.

Публичная часть

Работа с меню в публичной части сайта подробно описана в уроке Меню [image] [image] курса Контент-менеджер.

Смотрите также

  • Меню
  • Расширенный режим настройки меню
  • Примеры создания статического и динамического меню


Создание новой папки

Административная часть

Форма предназначена для создания новой папки в административном разделе.

Контекстная панель

Кнопка | Описание
Каталог | Переход в папку, открытую в данный момент в Менеджере файлов.

Форма создания новой папки

Поле | Описание
Название раздела | Название нового раздела, как он будет показан в цепочке навигации в публичной части. Кнопка [image] позволяет автоматически генерировать имена папок из названий разделов с возможностью перевода. Для этого необходимо включить опции Включить возможность автоматического генерирования имени файлов и папок из названий при создании страниц и разделов и Использовать внешний сервис для автоматического генерирования имен файлов и папок в настройках модуля Управление структурой.
Имя папки | Название новой папки. Указывается латинскими или русскими буквами (начиная с 11-й версии модуля), цифрами или символами. Недопустимо использование следующих спецсимволов: \ / ? * < > " '.
Создать пункт меню | При отмеченной опции ссылка на создаваемый раздел будет добавлена в указанное ниже меню.
Меню | Тип меню, в которое должна быть добавлена ссылка на создаваемый раздел.
Название пункта | Название пункта меню, как он будет показан в публичной части сайта.
Создать индексную страницу раздела | При отмеченной опции после создания раздела в нем будет создан файл index.php (индексная страница раздела). Это позволит открывать раздел сайта без указания имени страницы. Например: http://yoursite.ru/company_news - пользователи будут автоматически перенаправляться на индексную страницу раздела Новости компании.
Шаблон | Шаблон, на основе которого будет создана индексная страница.
Перейти к редактированию | При отмеченной опции после создания раздела откроется визуальный редактор, в котором можно будет изменить и наполнить созданную индексную страницу.

Пример создания раздела

  1. В административной части перейдите в Менеджер файлов: Контент > Структура сайта > Файлы и папки.
  2. На контекстной панели выберите Добавить, и далее Добавить папку.
  3. В открывшейся форме укажите:
    • Имя папки. Используйте латинские или русские буквы (начиная с 11-й версии модуля), цифры или символы. Недопустимо использование следующих спецсимволов: \ / ? * < > " '.
    • Название раздела. Именно это название будет отображено в цепочке навигации в качестве ссылки на созданный раздел.
    • Отметьте флажком поле Создать пункт меню.
    • Выберите Меню и задайте Название пункта в соответствующих полях.
    • Установите флаг в поле Создать индексную страницу раздела, чтобы добавить в новую папку файл index.php. При открытии нового раздела сайта в браузере по умолчанию первой будет показана эта страница.
    • Выберите шаблон индексной страницы. В дистрибутив продукта включен шаблон страниц Стандартная страница, который применяется для всех страниц сайта и представляет собой текстовое сообщение Text here... без определённого стиля.
    • Установите флаг в поле перейти к редактированию, чтобы приступить к редактированию индексной страницы непосредственно после сохранения раздела.
    • Нажмите кнопку Сохранить.
  4. Отредактируйте индексную страницу по своему усмотрению и сохраните внесенные изменения.

В результате будет создана папка (раздел), содержащая следующая файл index.php.

Публичная часть

Процедура создания нового раздела в публичной части сайта подробно описана в уроках Создание новых страниц и разделов [image] [image] и Создание новых страниц и разделов в интерфейсе до версии 9.5 [image].

Смотрите также

  • Создание и редактирование новых страниц и разделов
  • Создание новых страниц и разделов
  • Создание новых страниц и разделов в интерфейсе до версии 9.5


Свойства папки

Административный раздел

Чтобы перейти к настройке свойств папки, в менеджере файлов следует выполнить одно из двух действий:

  • воспользоваться пунктом Свойства папки меню действий необходимой папки;
  • открыть папку и воспользоваться кнопкой Свойства папки, расположенной на контекстной панели.

Страница Свойства папки служит для задания свойств, а также для управления доступом текущего раздела. Все страницы раздела наследуют заданные для раздела свойства, если им не заданы собственные.

Контекстная панель

Кнопка | Описание
Каталог | Переход к просмотру содержимого каталога, свойства которого настраиваются.

Поля формы

Форма состоит из двух закладок: Свойства каталога и Доступ.

Закладка "Свойства каталога"

Поле | Описание
Заголовок | Заголовок папки, отображаемый в цепочки навигации в качестве ссылки на соответствующий раздел.
Свойства папки
Поле | Описание
Код | Название свойства, указанное в настройках модуля Управление структурой.
Значение | Произвольное значение свойства.

Пустое поле формы служит для создания свойства, значение которого будет использоваться только для страниц данного раздела. В этом случае в поле Код указывается код (мнемоническое имя) свойства. Код свойства задается символами латинского алфавита. Кнопка Ещё добавляет строку для создания нового свойства страниц текущего раздела.

Закладка "Доступ"

Поле Описание
[Группа пользователей] Право доступа группы пользователей к данному разделу. Возможны следующие уровни доступа.
  • Запрещён - доступ запрещён в любой форме, в т.ч. чтение и просмотр свойств.
  • Чтение - пользователю разрешено просматривать содержимое папки.
  • Документооборот - пользователю разрешено редактирование документов в папке через систему документооборота.
  • Запись - пользователю разрешено самостоятельно изменять файлы папки.
  • Полный доступ - пользователю разрешено самостоятельно изменять и удалять файлы папки, а также управлять их свойствами.
  • Наследовать - уровень прав доступа пользователей к данной папке наследуется из настроек прав доступа вышележащего каталога.
Настройка доступа в поле Все группы, для которых уровень доступа Наследовать позволяет изменить уровень доступа к папке для всех групп с правом доступа Наследовать.

Публичный раздел

Работа со свойствами папки в публичной части сайта подробно описана в уроке Управление свойствами страниц и разделов [image] курса Контент-менеджер.


Создание и редактирование файла

Создать новый или отредактировать уже существующий файл можно как в административном, так и в публичном разделе.

Административный раздел

Для создания нового файла служит кнопка Добавить, расположенная на контекстной панели менеджера файлов. Чтобы отредактировать существующий файл, необходимо воспользоваться пунктом Редактировать как <режим_редактирования> меню действий необходимого файла. Доступно три режима редактирования файла:

  • Редактировать как текст;
  • Редактировать как PHP;
  • Редактировать как HTML.

Контекстная панель

Кнопка | Описание
Просмотр файла | Переключение в режим просмотра исходного кода файла. Кнопка отображается при редактировании документа.
Редактировать
  • Редактировать как текст - отображение текста файла, без включения PHP кода. Однако, в этом режиме отображаются все HTML-теги.
  • Редактировать как PHP - редактирование исходного кода файла. Режим предназначен исключительно для использования разработчиками.
  • Редактировать как HTML - редактирование документа в режиме встроенного визуального HTML-редактора [image] [image], позволяющего форматировать текст аналогично Microsoft Word.
Переименовать | Кнопка для перехода к форме задания нового имени файла. Отображается при редактировании документа.
Скачать файл | Кнопка предназначена для скачивания редактируемого файла на локальный компьютер.
Удалить файл | Удаление редактируемого файла.

В зависимости от выбранного режима редактирования, форма редактирования может принимать разный вид.

Редактировать как текст

Поле Описание
Шаблон * Шаблон, на основе которого будет создан файл. Например, Стандартная страница, Включаемая область для страницы или Включаемая область для раздела.

Поле отображается при создании нового файла.
Заголовок страницы * Произвольный заголовок страницы. Указанный заголовок будет выводиться в теле страницы.

Кнопка [image] позволяет автоматически генерировать имена файлов из заголовков страниц с возможностью перевода. Для этого необходимо включить опции Включить возможность автоматического генерирования имени файлов и папок из названий при создании страниц и разделов и Использовать переводчик Google для автоматического генерирования имен файлов и папок в настройках модуля Управление структурой.
Имя файла * Имя создаваемого файла (с указанием расширения). Например, news.php. Начиная с 11-й версии модуля поддерживаются русские буквы. Недопустимо использование следующих спецсимволов: \ / ? * < > " '.

Поле отображается при создании нового файла.
Свойства страницы
Данная секция предназначена для задания и редактирования значений свойств страницы, а также для управления значениями тегов, ключевыми словами (keywords) и описанием (description) страницы.
Поле | Описание
Свойство | Название свойства.
Значение | Поле для задания значения свойства.
Кнопка Еще... позволяет добавить пользовательское свойство, значение которого будет использоваться только для текущей страницы. В этом случае в поле Свойство задается код (мнемоническое имя) свойства символами латинского алфавита.

Примечание: Набор доступных для всех страниц свойств определяется на странице настроек модуля Управление структурой.
Текстовый редактор.
Поле для ввода содержимого страницы.

* - поле отображается только при при редактировании документа

Редактировать как PHP

Поле | Описание
Шаблон * | Шаблон, на основе которого будет создан файл. Например, Стандартная страница, Включаемая область для страницы или Включаемая область для раздела. Поле отображается при создании нового файла.
Имя файла * | Имя создаваемого файла (с указанием расширения). Например, news.php. Поле отображается при создании нового файла.
Редактирование PHP скрипта.
Поле для ввода содержимого страницы.

* - поле отображается только при при редактировании документа

Редактировать как HTML

Закладка "Редактирование"

Поле | Описание
Шаблон * | Шаблон, на основе которого будет создан файл. Например, Стандартная страница, Включаемая область для страницы или Включаемая область для раздела. Поле отображается при создании нового файла.
Заголовок страницы * | Произвольный заголовок страницы. Указанный заголовок будет выводиться в теле страницы. Кнопка [image] позволяет автоматически генерировать имена файлов из заголовков страниц с возможностью перевода. Для этого необходимо включить опции Включить возможность автоматического генерирования имени файлов и папок из названий при создании страниц и разделов и Использовать переводчик Google для автоматического генерирования имен файлов и папок в настройках модуля Управление структурой.
Имя файла * | Имя создаваемого файла (с указанием расширения). Например, news.php. Поле отображается при создании нового файла.
Визуальный HTML-редактор.
Примечание: Процесс создания и редактирования страницы с помощью визуального редактора подробно описан на странице визуального HTML-редактора [image] [image] .

* - поле отображается только при при редактировании документа

Закладка "Свойства"

Свойства страницы
Данная секция предназначена для задания и редактирования значений свойств страницы, а также для управления значениями тегов, ключевыми словами (keywords) и описанием (description) страницы.
Поле | Описание
Свойство | Название свойства.
Значение | Поле для задания значения свойства.
Кнопка Еще... позволяет добавить пользовательское свойство, значение которого будет использоваться только для текущей страницы. В этом случае в поле Свойство задается код (мнемоническое имя) свойства символами латинского алфавита.

Примечание: Набор доступных для всех страниц свойств определяется на странице настроек модуля Управление структурой.

Закладка "Меню"

Поле | Описание
Добавить страницу в меню | При отмеченной опции будет создан новый пункт меню для данного файла.
Тип меню | Выбирается тип меню. Например, Главное меню сайта [top].
Пункт меню Выбирается режим создания пункта меню:
  • Добавить новый - в меню в публичной части сайта для данного файла будет создан отдельный пункт меню;
  • Привязать к существующему - выбирается пункт меню, к которому будет привязан файл. При выборе данной опции следует заполнить поле Пункт.
Пункт | Указывается пункт в меню в публичной части сайта, к которому будет привязан файл.
Название нового пункта | Указывается название для нового пункта меню.
Вставить перед пунктом | Выбирается расположение нового пункта меню.

Пример создания нового файла

  1. На контекстной панели выберите Добавить, и далее Добавить файл. Для создания страницы будет открыт редактор, выбранный в настройках модуля Управление структурой как редактор по умолчанию.
  2. Выберите шаблон, на основе которого будет создана страница.
  3. Укажите имя файла (например, company.php).
  4. Нажмите кнопку Сохранить, чтобы добавить новый файл в текущую папку, или Применить, чтобы сохранить файл в текущей папке и продолжить его редактирование.

Публичный раздел

Процедура создания нового файла в публичной части сайта подробно описана в уроках Создание новых страниц и разделов [image] [image] и Создание новых страниц и разделов в интерфейсе до версии 9.5 [image] [image].

Смотрите также

  • Создание и редактирование новых страниц и разделов
  • Создание новых страниц и разделов
  • Создание новых страниц и разделов в интерфейсе до версии 9.5


Загрузка нового файла

Загрузка файлов

Вы можете загрузить на сайт любой файл с локального компьютера. Файл будет загружен в каталог, который открыт в текущий момент в менеджере файлов.

Поля формы

Поле | Описание
Имя файла | Имя, которое будет присвоено файлу после загрузки на сайт. По умолчанию указывается оригинальное имя загружаемого файла.
Файл для загрузки | С помощью кнопки Обзор в данном поле указывается имя и путь к загружаемому файлу.

Пример загрузки изображений на сайт

  1. Откройте Менеджер файлов и перейдите в папку /images/ (все изображения рекомендуется загружать в эту папку).
  2. Нажмите на кнопку Загрузить файл, расположенную на контекстной панели.
  3. Нажмите кнопку Добавить файл и выберите файлы на локальном диске. После этого в полях Имя файла и Файл для загрузки появится название выбранного файла. При необходимости измените имя, которое будет присвоено файлу после загрузки.
  4. Нажмите кнопку Сохранить.

Смотрите также

  • Загрузка и поиск файлов
  • Загрузка файлов


Введение

Медиабиблиотека - это менеджер для работы с медиаданными, особый способ хранения медиафайлов (изображения, презентации, аудио и видео файлы), который облегчает систематизацию хранимого материала и доступ к нему.

Медиабиблиотека расположена в Административном разделе по пути Контент > Структура сайта > Медиабиблиотека. С её помощью создается многоуровневая структура медиаколлекций, содержимое которых вы можете в дальнейшем использовать при редактировании сайта и наполнении сайта контентом.

Медиабиблиотека включают в себя следующие функциональные возможности:

  • создание многоуровневой структуры медиаданных;
  • добавление неограниченного количества медиаколлекций;
  • настройка доступа к коллекциям;
  • одиночная и пакетная загрузка элементов в медиколлекции;
  • ограничение загрузки по форматам файлов в зависимости от заданного списка;
  • использование содержимого медиабиблиотеки при наполнении сайта контентом, включая редактирование инфоблоков;
  • заполнение свойств для каждого элемента медиаколлекций;
  • возможность поиска по этим полям свойств.

Подробное описание Медиабиблиотеки смотрите в главе Медиабиблиотека [image] курса Контент-менеджер.


Контент. Облачные хранилища. Описание модуля

Раздел Облачные хранилища позволяет просматривать файлы и папки, расположенные в облачных хранилищах и доступен, если в системе установлен модуль Облачные хранилища.

Примечание: Создание и редактирование подключений к облачным хранилищам выполняется на странице Облачные хранилища (Настройки > Облачные хранилища).

Смотрите также:

  • Облачные хранилища


Облачные хранилища. Настройки модуля

Отправить отзыв по этому разделу
Контент>Облачные хранилища>Облачные хранилища. Настройки модуля

Облачные хранилища::Облачные хранилища. Настройки модуля

Форма настроек модуля Облачные хранилища (Настройки > Настройки продукта > Настройки модулей > Облачные хранилища) предназначена для задания общесистемных параметров модуля.

Закладка "Настройки"

Поле | Описание
Записывать 404 ошибки на перемещенных в облака файлах в журнал событий | Позволяет записывать в журнал сообщение об ошибке 404, которая возникает после переноса файла из локального хранилища в облачное. После такого переноса ссылка на прежнее место хранения будет "недействительна", но в системе будет произведен автоматический редирект на новое место хранения файла (в облаке). Включив данную опцию, можно сохранить в журнал сообщение о такой "недействительной" ссылке с указанием нового места хранения файла.

Закладка "Доступ"

Закладка позволяет настроить права на доступ к модулю для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю:
  • [D] Доступ закрыт - запрет на доступ;
  • [F] Выбор файлов - просмотр файлов в административной части сайта;
  • [U] Перемещение файлов - доступ на перемещение файлов в облачное хранилище;
  • [W] Полный административный доступ - полный доступ к ресурсам модуля.


Облачные хранилища

Отправить отзыв по этому разделу
Контент>Облачные хранилища

Облачные хранилища::Облачные хранилища

На странице Облачные хранилища (Настройки > Облачные хранилища) можно просмотреть список подключенных к системе контейнеров облачных хранилищ данных.

Контекстная панель

Кнопка Описание
Вид Режим просмотра содержимого:
  • Значки;
  • Список;
  • Таблица.

Список контейнеров облачных хранилищ

Поле | Описание
Название | Название контейнера, в котором хранятся данные. Ссылка позволяет перейти на страницу просмотра содержимого контейнера.
Описание | Описание контейнера.


Просмотр содержимого контейнера хранилища

Отправить отзыв по этому разделу
Контент>Облачные хранилища>Просмотр содержимого контейнера хранилища

Облачные хранилища::Просмотр содержимого контейнера хранилища

Страница позволяет просматривать файлы и папки, находящиеся в контейнере облачного хранилища.

Контекстная панель

Кнопка | Описание
Размеры каталогов | Подсчет размеров каталогов с учетом вложенности.
Новый файл | Позволяет загрузить файлы в контейнер облачного хранилища.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

Список содержимого контейнера

Поле | Описание
Колонка флажков | Выбор файлов, к которым предполагается применить какое-либо действие.
Меню действий Доступные действия:
  • Удалить - удалить файл.
Название | Название файла/папки.
Размер Размер файла/размер каталога с учетом вложенности.

Примечание: Размеры каталога будут отображены только после нажатия на соответствующую кнопку контекстной панели.


Информационные блоки. Описание модуля

Модуль Информационные блоки - это модуль, позволяющий управлять различными типами (блоками) однородной информации и каталогизировать эту информацию. Примерами информационных блоков могут быть:

  • Новости;
  • Каталог продукции;
  • Фотогалереи;
  • Список вакансий и другая информация.

Часто обновляемую информацию удобнее всего размещать в виде информационных блоков.

Модуль включает в себя следующие компоненты:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Новости
Новости (комплексный компонент) | news | Позволяет создать новостной раздел на сайте.
Календарь | news.calendar | Служит для формирования и вывода календаря новостей или событий.
Новость детально | news.detail | Осуществляет вывод детального описания новости.
Все новости | news.index | Выводит новости из различных инфоблоков.
Лента | news.line | Осуществляет вывод списка элементов инфоблоков с датой и заголовком со ссылкой на страницу с подробной информацией.
Список новостей | news.list | Выводит список новостей из одного информационного блока.
Список новостей для почты | news.list.mail | Служит для выбора списка новостей из одного информационного блока для формирования рассылки.
Фотогалерея
Фотогалерея (комплексный компонент) | photo | Позволяет получить полнофункциональную фотогалерею, создавая физически только одну страницу.
Фотография детально | photo.detail | Выводит детальную информацию по фотографии.
Случайное фото | photo.random | Служит для показа одной произвольной фотографии.
Фотографии раздела | photo.section | Выводит все фотографии из выбранного раздела.
Разделы с TOP'ом фотографий | photo.sections.top | Служит для вывода TOP'а фотографий, сгруппированных по разделам.
Каталог
Каталог (комплексный компонент) | catalog | Осуществляет вывод полного каталога товаров из определенного инфоблока.
Список сравниваемых элементов каталога | catalog.compare.list | Выводит список сравниваемых элементов каталога в виде небольшой таблицы.
Таблица сравнения | catalog.compare.result | Выводит таблицу сравниваемых элементов каталога.
Элемент каталога детально | catalog.element | Выводит детальную информацию по элементу каталога.
Фильтр по элементам | catalog.filter | Выводит форму фильтра для фильтрации элементов информационых блоков.
Список связанных элементов | catalog.link.list | Выводит список элементов, связанных с заданным.
Список информационных блоков заданного типа | catalog.main | Выводит список всех информационных блоков заданного типа.
Элементы раздела | catalog.section | Выводит список элементов раздела с указанным набором свойств.
Структура разделов | catalog.section.list | Выводит список разделов инфоблока с указанным количеством элементов в каждом разделе.
Разделы с top'ом элементов | catalog.sections.top | Выводит Top элементов сгруппированных по разделам; элементы выводятся в таблице.
Top элементов каталога | catalog.top | Выводит в таблице Top элементов из всех разделов в соответствии с заданной сортировкой (используется как правило на главной странице сайта).
Умный фильтр | catalog.smart.filter | Подготавливает фильтр для выборки из инфоблока и выводит форму фильтра для фильтрации элементов.
RSS
RSS новости (экспорт) | rss.out | Предназначен для создания страницы, которая отдает выбранные новости вашего сайта в формате RSS.
RSS новости (импорт) | rss.show | Предназначен для импорта новостей с другого сайта.
Добавление элементов
Добавление элементов инфоблока (комплексный компонент) | iblock.element.add | Осуществляет вывод списка элементов указанного инфоблока, добавление/редактирование элементов и их удаление в зависимости от прав пользователя.
Форма добавления / редактирования | iblock.element.add.form | Осуществляет вывод формы создания (редактирования) элемента указанного информационного блока.
Список своих элементов | iblock.element.add.list | Осуществляет вывод списка доступных пользователю элементов указанного инфоблока, ссылок Добавить, Редактировать, Удалить.
Инфоблоки
Голосование | iblock.vote | Реализует возможность голосования для пользователей.
Медиа
Видеотека | iblock.tv | Осуществляет вывод и поочередное проигрывание серии видеороликов в одном медиа проигрывателе.
Социальные сервисы
Комментарии к товарам | catalog.comments | Отображает форму добавления комментариев к товару.
Кнопки социальных сетей | catalog.socnets.buttons | Отображает кнопки социальных сетей.
Частые вопросы
FAQ | support.faq | Выводит FAQ категории и вопросы из инфоблока.
Вопрос FAQ | support.faq.element.detail | Выводит один вопрос FAQ из инфоблока конкретной категории.
Список вопросов FAQ из секции | support.faq.element.list | Выводит вопросы FAQ из инфоблока.
Список категорий FAQ | support.faq.section.list | Выводит список категорий FAQ из инфоблока.
Навигация
Пункты меню | menu.sections | Осуществляет дополнение созданного меню названиями разделов инфоблоков.

Смотрите также:

  • Начальные сведения [image] об Информационных блоках в курсе Контент-менеджер
  • Информационные блоки [image] для разработчиков.
  • Документация для разработчиков [image] по модулю Информационные блоки


Информационные блоки. Настройки модуля

Форма настроек модуля Информационные блоки (Настройки > Настройки продукта > Настройки модулей > Информационные блоки) предназначена для задания общесистемных параметров модуля.

Закладка "Настройки"

Поле | Описание
Системные настройки
Использовать параметры свойств в компонентах и формах | При отмеченной опции показ значений свойства настраивается сразу при [dw]редактировании[/dw][di] [image] [/di] этого свойства. Внимание! Данная настройка является глобальной для всего продукта. Перед ее включением необходимо изучить урок о параметрах свойств инфоблоков.
Журналировать действия с инфоблоками | Опция разрешает вывод данных по инфоблоку в Журнале изменений.
Путь к экспортируемым RSS файлам | Указывается путь к директории относительно корня сайта, в которой будут сохраняться экспортируемые RSS файлы.
Списки и формы редактирования элементов
Использовать визуальный редактор для изменения HTML содержимого | При отмеченной опции для редактирования и наполнения информационных блоков будет использоватья визуальный HTML-редактор, позволяющий изменять форматирование текста (размер, шрифт и т.д.), вставлять изображения и т.д.
Размер предпросмотра изображений в списках | Задается максимальная величина (в пикселах) ширины или высоты для картинки анонса и детальной картинки, отображаемых в списке элементов.
Размер предпросмотра изображений в формах редактирования | Указывается максимальная величина (в пикселах) ширины или высоты для картинки анонса и детальной картинки, отображаемых в форме редактирования элемента.
Показывать код загрузки из внешних источников | При отмеченной опции в административном разделе будет отображаться код, при помощи которого система связывает данные вашего сайта с данными из других источников (например, других каталогов в Интернете).
Разрешать выгрузку списка элементов в Excel только при наличии прав на экспорт | При отмеченной опции выгрузка списка элементов в формате файла Excel будет доступна пользователю только при наличии прав доступа на экспорт.
Включить выбор времени в календаре при быстром редактировании списков | Если опция отмечена, то при быстром редактировании [image] даты начала или конца активности элементов в выпадающем календаре можно будет указать не только дату, но и время.
Совместный просмотр разделов и элементов | При отмеченной опции станет активным [dw]режим совместного просмотра секций и элементов инфоблоков.[/dw][di]Режим напоминает функционирование проводника Windows: элементы и подразделы определённого раздела могут быть просмотрены лишь внутри этого раздела.[/di]
Максимальное количество разделов в меню | Указывается максимальное количество отображаемых разделов информационных блоков в левом меню административного раздела. Позволяет избегать перегруженности меню.
При смене флага активности элементов менять поле "Кем изменено" | Включение этой настройки обновляет значение поля Кем изменен элементов при групповом изменении активности (в административных списках элементов и разделов, импорт). По умолчанию настройка выключена и обновляется только значение поля Дата изменения. Примечание: Настройка доступна с версии 20.5.0 модуля Информационные блоки.
Пользовательские формы редактирования элементов
Использовать ID свойств в качестве ключей в массиве значений свойств, передаваемых в форму | Опция должна быть отмечена, если использовались старые версии модуля (до 16.6.1) с кастомизированной формой редактирования свойств инфоблока. Во всех остальных случаях опция не отмечается.
Импорт и экспорт данных
Максимальный уровень глубины вложенности разделов для CSV-экспорта/импорта | Задается число, определяющее максимальный уровень вложенности разделов при выполнении CSV-экспорта и импорта инфоблока.

Закладка "Кеширование"

Поле | Описание
Тегированный кеш
Сбрасывать кеш при наступлении даты начала/конца активности элементов инфоблоков | При нажатии кнопки Добавить откроется окно со списком существующих инфоблоков. Для выбранных инфоблоков будет происходить сброс кеша при наступлении даты начала или конца активности [image] [/di] их элементов.
Интервал проверки | Указывается интервал проверки наступления даты начала/конца активности элементов инфоблоков. Доступны варианты: 1, 3, 6, 12, 24 часа, либо есть возможность указать интервал вручную (в секундах).


Типы информационных блоков

Управление типами инфоблоков осуществляется на странице Типы информационных блоков (Контент > Инфоблоки > Типы инфоблоков).

Форма поиска

Форма поможет выполнить поиск типов инфоблоков, соответствующих указанным параметрам.

Поле | Описание
Название | Название типа информационного блока.
ID | Идентификатор типа информационного блока.

Чтобы отобрать типы информационных блоков по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех типов инфоблоков нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить новый тип | Переход на страницу с формой создания нового типа информационных блоков.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список типов информационных блоков

Поле | Описание
Колонка флажков | Выбор типов инфоблоков, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия:
  • Информационные блоки - переход на страницу со списком информационных блоков данного типа;
  • Изменить - переход к редактированию типа информационных блоков;
  • Удалить - удаление типа информационных блоков.
ID | Идентификатор типа информационного блока. Указывается символами латинского алфавита. Служит для выборки элементов инфоблоков того или иного типа, в том числе для показа в публичном разделе сайта.
Название | Произвольное название типа информационных блоков.
Сортировка | Относительный "вес" типа информационных блоков, определяющий его положение в списке.
Содержит разделы Признак того, что информационные блоки данного типа имеют иерархическую структуру, т.е. элементы инфоблоков могут быть сгруппированы по разделам и подразделам.
Такая организация элементов может быть применена, например, для объединения товаров в группы или классификации растений по родам, видам и т.п.
Экспорт в RSS | Признак того, что содержимое инфоблоков данного типа может экспортироваться в RSS-файл.
Файл для модификации | Путь к файлу, отвечающему за обработку полей элементов инфоблоков данного типа при сохранения.
Файл с формой редактирования | Путь к файлу-обработчику вывода интерфейса редактирования элемента.

Смотрите также

  • Типы инфоблоков


Создание и редактирование типа информационных блоков

Закладки

Форма редактирования

Типы информационных блоков в системе "1C-Битрикс: Управление сайтом" создаются и при помощи формы Новый тип информационных блоков. Каждый тип информационного блока, созданный в системе, автоматически добавляется в левое меню административного раздела:

Для изменения параметров типа инфоблоков служит форма Редактирование типа информационных блоков.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком типов информационных блоков.
Создать | Создание нового типа информационных блоков. Кнопка отображается при редактировании существующего типа инфоблоков.
Удалить | Удаление редактируемого типа информационных блоков. Кнопка отображается при редактировании существующего типа инфоблоков. Важно! Все информационные блоки данного типа также будут удалены.

Основное

Закладка служит для настройки основных параметров типа информационных блоков.

Поле | Описание
*Идентификатор (ID) | Код, однозначно идентифицирующий тип инфоблоков в системе. Должен содержать только латинские символы.
Использовать древовидный классификатор элементов по разделам При отмеченной опции информационные блоки данного типа будут иметь иерархическую структуру, т.е. они могут быть разбиты по разделам и подразделам (названия разделов и подразделов задаются в поле Разделы).

Такая организация элементов может быть применена, например, для объединения товаров в группы или классификации растений по родам, видам и т.п.
Языкозависимые названия и заголовки объектов:
Язык | *Название | Разделы | Элементы
[1] | [2] | [3] | [4]
Поле | Описание
[1] Язык | Список языков, используемых в системе. Названия типов, а также разделов и элементов информационных блоков указываются отдельно для каждого языка.
[2] *Название | Название типа инфоблоков для данного языка (например, Каталог).
[3] Разделы | Название разделов инфоблоков данного типа для этого языка (например, Группы).
[4] Элементы | Название элементов инфоблоков данного типа для этого языка (например, Товары).

* - поля, обязательные для заполнения.

Дополнительно

Поле | Описание
Использовать экспорт в RSS | Если этот флаг установлен, содержимое инфоблоков данного типа может экспортироваться в RSS-файл и сохраняться в директории, указанной в поле Путь к экспортируемым RSS файлам в форме настроек модуля Информационные блоки.
Сортировка | Относительный "вес", влияющий на порядок расположения типов информационных блоков в меню административного раздела.
Файл для редактирования элемента, позволяющий модифицировать поля перед сохранением | Полный путь к файлу, отвечающему за обработку полей элементов инфоблоков данного типа при сохранении. Может быть использован для модификации данных перед сохранением элементов в административном разделе. Важно! Это поле предназначено только для использования разработчиками. См. Пользовательские формы редактирования
Файл с формой редактирования элемента | Полный путь к файлу-обработчику вывода интерфейса редактирования элемента. Может быть использован для создания кастомизированной формы редактирования элементов данного типа. Важно! Это поле предназначено только для использования разработчиками. См. Пользовательские формы редактирования


Список информационных блоков

Форма поиска

Чтобы перейти к просмотру списка информационных блоков определённого типа, выберите название типа инфоблоков в секции Контент в меню Административного раздела.

Управление инфоблоками определенного типа осуществляется на странице Информационные блоки (Контент > Инфоблоки > Типы инфоблоков > название_типа_инфоблоков). С помощью этой формы можно:

  • легко добавлять инфоблоки выбранного типа;
  • переходить к наполнению блоков данными (например, вручную добавлять новые товары);
  • изменять свойства элементов (например, изменять описание и цены товаров);
  • выполнять прочие операции, связанные с информационным наполнением сайта.

Форма позволяет выполнить поиск информационных блоков, соответствующих указанным параметрам.

Поле | Описание
Название* | Название блока.
Сайт | Сайт(ы), на котором используются отбираемые информационные блоки.
Активность | Признак активности отбираемого информационного блока (доступна ли информация блока для просмотра в публичной части сайта).
ID | Идентификатор информационного блока в системе.
Символьный код* | Символьный код информационного блока.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать информационные блоки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех типов инфоблоков нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить инфоблок | Переход к форме создания нового информационного блока данного типа.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список информационных блоков

Поле | Описание
Колонка флажков | Выбор информационных блоков, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия:
  • Изменить - переход к редактированию информационного блока;
  • Свойства - переход к списку свойств инфоблока;
  • Бизнес-процессы - переход на страницу со списком шаблонов бизнес-процессов данного инфоблока (доступно при наличии в системе модуля Бизнес-процессы).
  • Удалить - удаление информационного блока.
Название | Название информационного блока.
Сорт. | Относительный "вес", влияющий на порядок показа информационных блоков в списке.
Акт. | Признак активности блока. Если поле отмечено, содержимое инфоблока доступно для показа в публичной части сайта.
Символьный код | Мнемонический код информационного блока, состоящий из латинских символов.
URL страницы инфоблока | Адрес страницы в публичной части для показа списка элементов инфоблока.
URL страницы элемента | Адрес страницы для просмотра детальной информации об элементе инфоблока в публичной части.
Элементов | Ссылка с количеством элементов в данном информационном блоке, ведущая на страницу списка элементов инфоблока.
Разделов | Количество разделов в данном информационном блоке.
Сайт | Сайты, на которых используется информационный блок.
Индексировать элементы | Определяется возможность индексации элементов информационного блока для внутреннего поиска.
Документооборот | Признак участия инфоблока в документообороте.
Дата изм. | Дата и время последнего изменения блока.
ID | Идентификатор информационного блока.
Шаблоны бизнес-процессов | Ссылка с количеством шаблонов бизнес-процессов, ведущая на страницу списка шаблонов бизнес-процессов.
Канонический URL элемента | Шаблон формирования канонической ссылки для элемента.


Создание и редактирование информационного блока

Закладки

Контекстная панель

Форма позволяет создавать и редактировать информационные блоки выбранного типа.

Кнопка | Описание
Вернуться в список информационных блоков | Переход на страницу со списком информационных блоков соответствующего типа.

Инфоблок

Настройка общих параметров информационного блока.

Поле | Описание
ID | Идентификатор информационного блока. Данное поле отображается только при редактировании существующего инфоблока и изменению не подлежит.
Значения свойств хранятся Таблица, в которой хранятся значения свойств:
  • в общей таблице (по умолчанию)
  • в отдельной таблице для данного информационного блока - в некоторых случаях увеличивает производительность сайта.
В режиме редактирования уже существующего информационного блока ссылка изменить место хранения свойств позволяет изменить место хранения значений свойств.
Изменена | Дата и время последней модификации инфоблока. Данное поле отображается только при редактировании существующего инфоблока.
Информационный блок активен | Признак активности информационного блока. Если поле отмечено, то инфоблок и его содержимое доступны для показа в публичной части сайта.
Символьный код Мнемонический код информационного блока, состоящий из латинских символов.

При создании нового информационного блока можно указать его символьный код, представляющий собой произвольный набор символов латинского алфавита, понятный администратору сайта. Например, символьный код информационного блока Новости компании может быть таким: company_news. Символьный код используется для выборки информации по конкретному информационному блоку или для исключения блока из выборки.
Символьный код API Специальный код для [dw]использования ORM[/dw][di]С версии 19.0.0 модуля iblock добавлена поддержка ORM при работе с элементами инфоблоков.
Подробнее [image]...[/di] в инфоблоке. Это строка от 1 до 50 символов, начинающаяся с буквы и состоящая из латинских букв и цифр.

Поле предназначено для разработчиков.

Включен доступ через REST Опция включает REST для инфоблока (по умолчанию REST выключен для всех инфоблоков). Для работы REST должно быть обязательно заполнено поле Символьный код API.

Опция предназначена для разработчиков.

*Сайты Сайты, на которых отображается информационный блок. Если инфоблок используется на разных сайтах при многосайтовости, то нужно отметить все сайты, где он будет использоваться.

Примечание: продукт [ds]«1С-Битрикс24: Интернет-магазин+CRM»[/ds][di] «1С-Битрикс24: Интернет-магазин+CRM» – это тот же самый Битрикс24 (коробочная версия корпоративного портала), но с модулями, необходимыми для работы Интернет-магазина (как в продукте «1С-Битрикс: Управление сайтом» редакции Бизнес). Таким образом, 12 сотрудников интернет-магазина могут работать с заказами в удобном интерфейсе Битрикс24. При этом можно настроить дополнительные каналы продаж в чатах и по SMS без перехода на сайт.

Подробнее [image]...[/di] тоже работает по технологии многосайтовости. Поэтому при создании торговых каталогов нужно [dw]отметить[/dw][di] [image] [/di] сайт, на котором развёрнута CRM Битрикс24, чтобы просматривать каталоги и в [dw]Битрикс24.[/dw][di] [image] [/di]

*Название | Название информационного блока.
Сортировка Индекс сортировки определяет порядок показа информационных блоков.

Обычно блоки показываются в публичной части отдельно друг от друга, но иногда возникает необходимость вывести различные блоки на одной странице сайта (например, на главной). В этом случае, чем меньше значение индекса сортировки у блока, тем выше он будет отображаться на странице.
Внешний код | Символьный код, используемый для связи инфоблока с внешним источником данных. Поле отображается при включенной опции Показывать код загрузки из внешних источников в настройках модуля Информационные блоки.
URL страницы информационного блока Адрес страницы в публичной части для показа списка элементов инфоблока (см. пример ниже). Для указания URL возможно использование следующих макросов:
  • #SITE_DIR# - корневая папка для сайта (берется из настроек сайта);
  • #SERVER_NAME# - URL сайта (берется из настроек сайта);
  • #IBLOCK_TYPE_ID# - тип инфоблока;
  • #IBLOCK_ID# - ID информационного блока;
  • #IBLOCK_CODE# - символьный код инфоблока;
  • #IBLOCK_EXTERNAL_ID# - внешний код инфоблока;
Необходимые макросы можно выбрать в списке.
URL страницы раздела Адрес страницы в публичной части сайта со списком элементов раздела данного информационного блока.
Поле будет отображаться в форме только в том случае, если для типа информационных блоков, к которому относится настраиваемый инфоблок, было выбрано свойство Использовать древовидный классификатор элементов по разделам [image].
Для указания URL возможно использование следующих макросов:
  • #SITE_DIR# - корневая папка сайта (берется из настроек сайта);
  • #SERVER_NAME# - URL сервера (берется из настроек сайта);
  • #IBLOCK_TYPE_ID# - тип инфоблока.

  • #IBLOCK_ID# - ID информационного блока;
  • #IBLOCK_CODE# - символьный код инфоблока;
  • #IBLOCK_EXTERNAL_ID# - внешний код инфоблока;

  • #ID# - ID раздела информационного блока (код группы). Оставлен с целью совместимости версий;
  • #SECTION_ID# - ID раздела информационного блока (код группы);
  • #CODE# - символьный код раздела информационного блока. Оставлен с целью совместимости версий;
  • #SECTION_CODE# - символьный код раздела информационного блока;
  • #SECTION_CODE_PATH# - путь из символьных кодов раздела;
  • #EXTERNAL_ID# - внешний код раздела информационного блока;
Необходимые макросы можно выбрать в списке.

Значение данного поля используется для формирования ссылок в модуле поиска, а также при размещении и настройке визуальных компонентов в публичной части сайта.
URL страницы детального просмотра Адрес страницы для просмотра детальной информации об элементе инфоблока в публичной части (см. пример ниже). Используется для формирования ссылок на страницу с информацией об элементе инфоблока, например, при показе результатов поиска. Возможно использование следующих макросов:
  • #SITE_DIR# - корневая папка для сайта (берется из настроек сайта);
  • #SERVER_NAME# - URL сайта (берется из настроек сайта);
  • #IBLOCK_TYPE_ID# - Тип информационного блока;

  • #IBLOCK_ID# - ID информационного блока;
  • #IBLOCK_CODE# - символьный код информационного блока;
  • #IBLOCK_EXTERNAL_ID# - внешний код информационного блока;

  • #IBLOCK_ID# - ID информационного блока;
  • #IBLOCK_CODE# - символьный код информационного блока;
  • #IBLOCK_EXTERNAL_ID# - внешний код информационного блока;

  • #ID# - ID элемента;
  • #ELEMENT_ID# - ID элемента (2);
  • #CODE# - символьный код элемента;
  • #ELEMENT_CODE# - символьный код элемента (2);
  • #EXTERNAL_ID# - внешний код элемента.
Необходимые макросы можно выбрать в списке.
Канонический URL элемента: (необходимо указать протокол, адрес сервера и путь на сайте) Шаблон формирования канонической ссылки для элемента. Возможно использование следующих макросов:
  • http:// - протокол HTTP;
  • https:// - протокол HTTPS;

  • #SITE_DIR# - корневая папка для сайта (берется из настроек сайта);
  • #SERVER_NAME# - URL сайта (берется из настроек сайта);
  • #IBLOCK_TYPE_ID# - Тип информационного блока;

  • #IBLOCK_ID# - ID информационного блока;
  • #IBLOCK_CODE# - символьный код информационного блока;
  • #IBLOCK_EXTERNAL_ID# - внешний код информационного блока;

  • #SECTION_ID# - ID раздела;
  • #SECTION_CODE# - символьный код раздела;
  • #SECTION_CODE_PATH# - путь из символьных кодов раздела;

  • #ID# - ID элемента;
  • #ELEMENT_ID# - ID элемента (2);
  • #CODE# - символьный код элемента;
  • #ELEMENT_CODE# - символьный код элемента (2);
  • #EXTERNAL_ID# - внешний код элемента.
Необходимые макросы можно выбрать в списке.
Индексировать разделы для модуля поиска Определяет возможность индексации разделов информационного блока в модуле поиска.

Для добавления в поисковый индекс уже существующих разделов необходимо задать значение поля URL страницы раздела и разрешить индексацию разделов, затем полностью переиндексировать сайт.

Для исключения раздела из поискового индекса нужно запретить индексацию разделов информационного блока (снять флажок в данном поле) и полностью переиндексировать сайт.
Индексировать элементы для модуля поиска Определяется возможность индексации элементов информационного блока для внутреннего поиска.

Для добавления элементов информационного блока в поисковый индекс необходимо задать значение поля URL страницы детального просмотра и разрешить индексацию элементов, затем полностью переиндексировать сайт.

Для исключения элементов уже существующего информационного блока из поискового индекса нужно запретить индексацию элементов блока (снять флажок в данном поле) и полностью переиндексировать сайт.
Участвует в документообороте или бизнес процессах | С помощью выпадающего списка можно указать какой модуль используется при работе с объектами данного инфоблока: документооборот или бизнес процессы. Поле появляется, если установлен и модуль Документооборот и модуль Бизнес-процессы. Если установлен только один из этих модулей, то появляется чекбокс включения в инфоблоке либо документооборота, либо бизнес-процессов.
Интерфейс привязки элемента к разделам Есть возможность выбрать один из трех интерфейсов привязки элемента к разделам:
  • Список множественного выбора: все разделы и подразделы выведены в общем списке. Для выбора нескольких разделов необходимо удерживать клавишу Ctrl.
  • Выпадающие списки: более удобный интерфейс для привязки элемента к нескольким разделам. С помощью выпадающих списков выбирается раздел для привязки и после нажатия кнопки Добавить привязка будет осуществлена. Количество привязок не ограничено.
  • Окно поиска: по нажатию на кнопку Добавить в отдельном окне появляется диалог выбора разделов. Он содержит информацию обо всех разделах инфоблока и о количестве подразделов у каждого из них. Диалог снабжен средствами для перехода по разделам для установки различных привязок.
Привязка элемента к разделам осуществляется в форме редактирования элемента.
Режим просмотра разделов и элементов Задается режим просмотра разделов и элементов:
  • из настроек модуля - используется режим просмотра, указанный в настройках модуля;
  • раздельный - элементы и разделы инфоблока отображаются по отдельности.;
  • совместный - элементы и подразделы определённого раздела отображаются вместе и могут быть просмотрены лишь внутри этого раздела (режим напоминает функционирование проводника Windows).
При отмеченной опции станет активным режим совместного просмотра секций и элементов инфоблоков. Режим напоминает функционирование проводника Windows: элементы и подразделы определённого раздела могут быть просмотрены лишь внутри этого раздела.
Файл для редактирования элемента, позволяющий модифицировать поля перед сохранением Полный путь к файлу, отвечающему за обработку полей элементов данного инфоблока. Может быть использован для модификации данных перед сохранением элементов в административном разделе.

Важно! Это поле предназначено только для использования разработчиками. См. Пользовательские формы редактирования [image] [image].

Файл с формой редактирования элемента Полный путь к файлу-обработчику вывода интерфейса редактирования элемента. Может быть использован для создания кастомизированной формы редактирования элементов данного инфоблока.

Важно! Это поле предназначено только для использования разработчиками. См. Пользовательские формы редактирования [image] [image].
Описание
Изображение | Изображение, ассоциируемое с данным информационным блоком.
Переключатель режима ввода текста Задается режим ввода текста описания информационного блока: Text, HTML или Визуальный редактор.

В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть.

* - поля, обязательные для заполнения.

SEO

На данной вкладке осуществляется настройка шаблонов SEO информации для всех разделов и элементов инфоблока.

Поле | Описание
Настройки для разделов/элементов
Шаблон META TITLE | Задается шаблон, по которому будет создаваться мета-тег TITLE для разделов/элементов инфоблока. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон META KEYWORDS | Задается шаблон, по которому будет создаваться мета-тег KEYWORDS для разделов/элементов инфоблока. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон META DESCRIPTION | Задается шаблон, по которому будет создаваться мета-тег DESCRIPTION для разделов/элементов инфоблока. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Заголовок раздела/товара Задается шаблон для создания заголовка страницы просмотра раздела или элемента (товара). Вывод данного заголовка выполняется с помощью функции ShowTitle():
<H1><?$APPLICATION->ShowTitle()?></H1>
Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Настройки для изображений разделов, детальных картинок разделов, картинок анонса элементов и для детальных картинок элементов
Шаблон ALT | Задается шаблон, по которому будет создаваться атрибут ALT для изображения. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон TITLE | Задается шаблон, по которому будет создаваться атрибут TITLE для изображения. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон имени файла Задается шаблон, по которому будет создаваться имя файла с изображением. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.

Имя файла будет формироваться с учетом следующих опций:
  • Привести к нижнему регистру - при отмеченной опции имя файла будет создано в нижнем регистре;
  • Транслитерировать - при отмеченной опции будет выполнена транслитерация имени файла;
  • Замена для пробельных символов после транслитерации - задается символ, который будет использоваться вместо пробела после транслитерации имени файла.
Управление
Очистить кеш вычисленных значений | При отмеченной опции очищается кеш шаблонов и все вносимые изменения в настройках отображаются сразу.

Поля

Задание свойств полей по умолчанию при создании новых элементов инфоблока.

При добавлении нового элемента в информационном блок вы сможете установить значения полей [image], которые будут выводится при создании элемента, а также задать обязательность для заполнения того или иного поля. Для установления свойства "обязательно для заполнения" достаточно установить флажок напротив нужного поля в колонке Обяз.. Если у поля свойство "обязательно для заполнения" установлено системно, то поле у этого свойства в колонке Обяз. не активно.

При синхронизации с 1С может возникнуть ошибка, связанная с установленым для параметра свойством Обяз.. Например, в инфоблоке стоит Обяз. для значения Картинка для анонса, а в каталоге 1С такая картинка отсутствует. Элемент в этом случае загружен не будет, несмотря на сообщение об успешной синхронизации.

Поле | Описание
Привязка к разделам Параметр привязки элементов к разделам:
  • Разрешить выбор основного раздела для привязки - установка флажка означает, что для элемента можно будет указывать основной раздел среди тех, к которым он привязан.
Активность Значения по умолчанию:
  • да - элемент будет активным;
  • нет - элемент не будет активным.
Начало активности Задание даты начала активности:
  • Не задано - дата не будет указываться;
  • Текущая дата и время - будет указана текущая дата и время;
  • Текущая дата - будет указана только текущая дата.
Окончание активности | Задание в днях срока активности элемента
Сортировка | Значения по умолчанию не имеет.
Название | Вводится текстовое сообщение.
Картинка для анонса Параметры обработки картинки для анонса:
  • Создавать картинку анонса из детальной (если не задана) - установка флажка означает, что анонсовая картинка будет задана из детальной с параметрами, определенными ниже. Если флажок в поле установлен, но анонсовая картинка загружена, то эта функция не сработает.
  • Удалять картинку анонса, если удаляется детальная - установка флажка задаст одновременное удаление подробной и анонсовой картинки. Удаляется любая анонсовая каритнка, как созданная из детальной, так и загруженная пользователем.
  • Создавать картинку анонса из детальной даже если задана - будет создана анонсовая картинка из детальной, даже в случае,е сли анонсовая задана при создании элемента.
  • Уменьшать если большая - установка флажка разрешит изменение картинки в соответствии с указанными ниже параметрами.
  • Максимальная ширина - ширина анонсовой картинки в пикселях.
  • Максимальная высота - высота анонсовой картинки в пикселях.
  • Игнорировать ошибки масштабирования - система производит изменение размеров типичных графических форматов: jpg, gif, png. Если загружена картинка другого формата, то изменения размеров не произойдет. Если установлен флажок в этом поле - будет показано изображение в исходном виде. Если не установлен - то отобразится сообщение о невозможности изменения размера.
  • Сохранять качество при масштабировании - улучшит качество обработанной картинки.
  • Качество - задается процент качества обработки картинки.
  • Наносить авторский знак в виде изображения - установка флажка разрешит нанесение на картинку графического авторского знака в соответствии с указанными ниже параметрами.
  • Путь к изображению с авторским знаком - Укажите путь до картинки, используемой в качестве авторского знака.
  • Прозрачность авторского знака - Настройка (в процентах) прозрачности авторского знака.
  • Размещение авторского знака - Выберите из возможных вариантов расположение авторского знака.
  • Наносить авторский знак в виде текста - установка флажка разрешит нанесение на картинку текстового авторского знака в соответствии с указанными ниже параметрами.
  • Содержание надписи - Текст авторского знака. Ограничений на число знаков нет, но по строкам текст не разбивается.
  • Путь к файлу шрифта - Обязательно укажите путь до файла со шрифтом (можно использовать собственные шрифты или стандартные из папки /bitrix/fonts/). Поддерживается кириллический TTF.
  • Цвет надписи - Указывается только номер цвета, без #.
  • Размер - Укажите (в процентах) какую часть картинки должна занимать надпись на изображении.
  • Размещение авторского знака - Выберите из возможных вариантов расположение авторского знака.
Внимание! Данные настройки не работают при импорте из файла.
Тип описания для анонса Указывается, в каком виде будет открываться форма для ввода текста анонса:
  • текст - текстовое поле;
  • html - визуальный редактор.
Опция Разрешить переключаться между text и html позволяет разрешить или запретить переключение между режимами ввода текста.
Описание для анонса | Вводится текстовое сообщение.
Детальная картинка Параметры обработки детальной картинки:
  • Уменьшать если большая - установка флажка разрешит изменение картинки в соответствии с указанными ниже параметрами.
  • Максимальная ширина - ширина анонсовой картинки в пикселях.
  • Максимальная высота - высота анонсовой картинки в пикселях. Изменение размера происходит с сохранением пропорций.
  • Игнорировать ошибки масштабирования - система производит изменение размеров типичных графических форматов: jpg, gif, png. Если загружена картинка другого формата, то изменения размеров не произойдет. Если установлен флажок в этом поле - будет показано изображение в исходном виде. Если не установлен - то отобразится сообщение о невозможности изменения размера.
  • Сохранять качество при масштабировании - улучшит качество обработанной картинки.
  • Качество - задается процент качества обработки картинки.
  • Наносить авторский знак в виде изображения - установка флажка разрешит нанесение на картинку графического авторского знака в соответствии с указанными ниже параметрами.
  • Путь к изображению с авторским знаком - Укажите путь до картинки, используемой в качестве авторского знака.
  • Прозрачность авторского знака - Настройка (в процентах) прозрачности авторского знака.
  • Размещение авторского знака - Выберите из возможных вариантов расположение авторского знака.
  • Наносить авторский знак в виде текста - установка флажка разрешит нанесение на картинку текстового авторского знака в соответствии с указанными ниже параметрами.
  • Содержание надписи - Текст авторского знака. Ограничений на число знаков нет, но по строкам текст не разбивается.
  • Путь к файлу шрифта - Обязательно укажите путь до файла со шрифтом (можно использовать собственные шрифты или стандартные из папки /bitrix/fonts/). Поддерживается кириллический TTF.
  • Цвет надписи - Указывается только номер цвета, без #.
  • Размер - Укажите (в процентах) какую часть картинки должна занимать надпись на изображении.
  • Размещение авторского знака - Выберите из возможных вариантов расположение авторского знака.
Внимание! Данные настройки не работают при импорте из файла.
Тип детального описания Указывается, в каком виде будет открываться форма для ввода текста детального описания элемента:
  • текст - текстовое поле;
  • html - визуальный редактор.
Опция Разрешить переключаться между text и html позволяет разрешить или запретить переключение между режимами ввода текста.
Детальное описание | Вводится текстовое сообщение.
Внешний код | Значения по умолчанию не имеет.
Символьный код Задание параметров символьного кода.
  • Если код задан, то проверять на уникальность - система будет проверять уникальность введенного кода. Опция необходима при большом количестве вводимых элементов, когда возможны совпадения символьных имен.
  • Транслитерировать из названия при добавлении элемента - система будет создавать символьное имя в виде транслитерации названия элемента.
  • Максимальная длина результата транслитерации - задание максимальной длины транслитерации в знаках. Пустое поле - длина не ограничена.
  • Приведение к регистру - независимо от вида регистра в котором вводится название, символьный код будет выведен либо в верхнем либо в нижнем регистре.
  • Замена для символа пробела - указывается символ, который будет использован вместо пробела при транслитерации названия.
  • Замена для прочих символов - указывается символ, который будет использован вместо всех остальных символов при транслитерации названия.
  • Удалять лишние символы замены - система удалит лишние символы замены (например, два подряд).
  • Использовать внешний сервис для перевода - система будет использовать Яндекс.Перевод в качестве внешнего сервиса для перевода при создании символьного кода. В противном случае используется только транслитерация.
Теги | Параметр включает функционал тегов для элементов инфоблока. При включенном параметре в форме создания / редактирования элемента на закладке SEO отобразится параметр Теги.

Свойства

Cоздание и настройка свойств элементов текущего инфоблока. Кроме того, список свойств инфоблока можно просматривать на отдельной странице, переход к которой осуществляется со страницы списка инфоблоков нужного типа (Контент > Инфоблоки > Типы инфоблоков > название_типа_инфоблоков) с помощью пункта Свойства в меню действий выбранного инфоблока.

При добавлении нового элемента в информационном блок вы сможете установить значения этих свойств. Например, на сайте можно разместить различные статьи о компании, опубликованные в СМИ. Все эти статьи могут быть представлены в одном информационном блоке – Публикации. Для элементов инфоблока Публикации можно задать следующие свойства: Автор и Источник. При добавлении статьи (элемента инфоблока) будет предложено указать значения этих свойств.

Поле | Описание
ID | Идентификатор свойства элементов информационного блока.
Название | Произвольное название свойства элементов инфоблока. Доступно 255 знаков.
Тип Тип свойства:
  • Строка - значение свойства задается в виде текстовой строки;
  • Число - значение свойства задается в виде числа;
  • Список - значение свойства выбирается из списка;
  • Файл - в качестве значения свойства используется файл;
  • Деньги - Привязка к валюте;
  • Привязка к разделам- с помощью данного свойства можно задать связь между элементом данного инфоблока и разделами другого информационного блока;
  • Привязка к элементам - задание связи между элементами информационных блоков "поштучно";
  • HTML/текст - значение свойства задается в виде текста с HTML-тегами;
  • Видео - задается связь между элементом списка и медиафайлом;
  • Дата - значение свойства задается в виде даты без указания времени;
  • Дата/Время - значение свойства задается в виде даты/времени;
  • Привязка к Яндекс.Карте - задается связь между элементом инфоблока и компонентом Яндекс.Карта;
  • Привязка к карте Google Maps - задается связь между элементом инфоблока и компонентом Google Map;
  • Привязка к пользователю - с помощью данного свойства можно задать связь между элементом данного инфоблока и пользователями системы;
  • Привязка к разделам с автозаполнением - задается связь с разделами с автозаполнением;
  • Привязка к теме форума - с помощью данного свойства можно задать связь между элементом данного инфоблока и темами форума;
  • Привязка к товарам (SKU) - задается связь с товарными предложениями;
  • Привязка к файлу (на сервере) - с помощью данного свойства можно задать связь между элементом инфоблока и файлом на сервере;
  • Привязка к элементам в виде списка - задание связи между элементами списком;
  • Привязка к элементам по XML_ID - привязка хранится как строка и значением является xml_id привязанного элемента;
  • Привязка к элементам с автозаполнением - задается связь с элементами с автозаполнением;
  • Справочник - задается связь между элементами инфоблока и записями Highload-блока. Данный тип свойства доступен только при наличии установленного модуля Highload-блоки;
  • Счетчик - Аналог autoincrement для БД. При добавлении элемента инфоблока значение будет больше на единицу, чем последнее. Стартовое значение задается произвольное. Можно использовать для журналов учета входящих документов и т.п., где должна быть непрерывная нумерация документов.
Каждый тип свойств характеризуется собственным набором параметров, настраиваемых в форме Детальное редактирование свойства.
Акт. | Признак активности свойства (если свойство активно, оно может быть выбрано для показа в публичной части сайта).
Множ. | Признак множественности свойства. Т.е. для данного свойства может быть задано несколько значений. Количество полей для ввода значений определяется в форме детального редактирования свойства (кнопка Изменить).
Обяз. | Признак обязательности свойства. Т.е. для данного свойства должно быть обязательно задано значение.
Сорт. | Относительный "вес" свойства. Влияет на положение свойства в списке.
Код | Мнемонический код свойства. Может состоять из латинских символов (рекомендуется использовать символы верхнего регистра) и цифр, но не должен начинаться с цифры.
Изм. | Кнопка, при нажатии на которую открывается форма детального редактирования свойства (см. Создание и редактирование свойства).
Удал. | Для удаления свойства установите флаг в это поле и нажмите кнопку "Сохранить".

Поля разделов

Задание свойств полей разделов по умолчанию при создании новых разделов инфоблока.

При добавлении нового раздела в информационном блок вы сможете установить значения полей, которые будут выводится при его создании, а также задать обязательность для заполнения того или иного поля. Для установления свойства "обязательно для заполнения" достаточно установить флажок напротив нужного поля в колонке Обяз.. Если у поля свойство "обязательно для заполнения" установлено системно, то поле у этого свойства в колонке Обяз. не активно.

При синхронизации с 1С может возникнуть ошибка, связанная с установленным для параметра свойством Обяз.. Например, в инфоблоке стоит Обяз. для значения Картинка для анонса, а в каталоге 1С такая картинка отсутствует. Элемент в этом случае загружен не будет, несмотря на сообщение об успешной синхронизации.

Поле | Описание
Название | Вводится текстовое сообщение.
Картинка для анонса Параметры обработки картинки для анонса:
  • Создавать картинку анонса из детальной (если не задана) - установка флажка означает, что анонсовая картинка будет задана из детальной с параметрами, определенными ниже. Если флажок в поле установлен, но анонсовая картинка загружена, то эта функция не сработает.
  • Удалять картинку анонса, если удаляется детальная - установка флажка задаст одновременное удаление подробной и анонсовой картинки. Удаляется любая анонсовая каритнка, как созданная из детальной, так и загруженная пользователем.
  • Создавать картинку анонса из детальной даже если задана - будет создана анонсовая картинка из детальной, даже в случае,е сли анонсовая задана при создании элемента.
  • Уменьшать если большая - установка флажка разрешит изменение картинки в соответствии с указанными ниже параметрами.
  • Максимальная ширина - ширина анонсовой картинки в пикселях.
  • Максимальная высота - высота анонсовой картинки в пикселях.
  • Игнорировать ошибки масштабирования - система производит изменение размеров типичных графических форматов: jpg, gif, png. Если загружена картинка другого формата, то изменения размеров не произойдет. Если установлен флажок в этом поле - будет показано изображение в исходном виде. Если не установлен - то отобразится сообщение о невозможности изменения размера.
  • Сохранять качество при масштабировании - улучшит качество обработанной картинки.
  • Качество - задается процент качества обработки картинки.
Внимание! Данные настройки не работают при импорте из файла.
Тип описания Указание в каком виде по умолчанию будет открываться форма для ввода текста описания:
  • текст - текстовое поле;
  • html - визуальный редактор.
Описание | Вводится текстовое сообщение.
Детальная картинка Параметры обработки детальной картинки:
  • Уменьшать если большая - установка флажка разрешит изменение картинки в соответствии с указанными ниже параметрами.
  • Максимальная ширина - ширина анонсовой картинки в пикселях.
  • Максимальная высота - высота анонсовой картинки в пикселях. Изменение размера происходит с сохранением пропорций.
  • Игнорировать ошибки масштабирования - система производит изменение размеров типичных графических форматов: jpg, gif, png. Если загружена картинка другого формата, то изменения размеров не произойдет. Если установлен флажок в этом поле - будет показано изображение в исходном виде. Если не установлен - то отобразится сообщение о невозможности изменения размера.
  • Сохранять качество при масштабировании - улучшит качество обработанной картинки.
  • Качество - задается процент качества обработки картинки.
Внимание! Данные настройки не работают при импорте из файла.
Внешний код | Значения по умолчанию не имеет.
Символьный код Задание параметров символьного кода.
  • Если код задан, то проверять на уникальность - система будет проверять уникальность введенного кода. Опция необходима при большом количестве вводимых элементов, когда возможны совпадения символьных имен.
  • Транслитерировать из названия при добавлении элемента - система будет создавать символьное имя в виде транслитерации названия элемента.
  • Максимальная длина результата транслитерации - задание максимальной длины транслитерации в знаках. Пустое поле - длина не ограничена. По умолчанию установлено 100 знаков.
  • Приведение к регистру - независимо от вида регистра в котором вводится название, символьный код будет выведен либо в верхнем либо в нижнем регистре.
  • Замена для символа пробела - указывается символ, который будет использован вместо пробела при транслитерации названия. По умолчанию используется символ "подчеркивание".
  • Замена для прочих символов - указывается символ, который будет использован вместо всех остальных символов при транслитерации названия. По умолчанию используется символ "подчеркивание".
  • Удалять лишние символы замены - система удалит лишние символы замены (например, два подряд).
  • Использовать внешний сервис для перевода - система будет использовать Яндекс.Перевод в качестве внешнего сервиса для перевода при создании символьного кода. В противном случае используется только транслитерация.

RSS

Настройка параметров выгрузки данных из информационного блока в RSS.

Поле | Описание
Разрешен экспорт в RSS динамически | Если опция включена, экспорт в формат RSS будет происходить без создания файла, напрямую в поток.
Действительно (часов) | Период актуальности RSS.
Разрешен экспорт в RSS файл | Если опция включена, экспорт в формат RSS будет осуществляться через создаваемый файл.
Количество экспортируемых в RSS файл элементов | Количество элементов блока, экспортируемых в RSS файл. Значение -1 принуждает экспортировать все элементы.
За сколько последних дней экспортировать в RSS файл | Количество дней, за которые будет выполняться RSS экспорт. Значение -1 принуждает экспортировать данные за весь период.
Разрешен экспорт в RSS файл в формате yandex | Включите эту опцию, если вам требуется отдавать файлы с содержимым блока в формате RSS для Yandex.
Привязка полей для выгрузки в RSS
Поле RSS | Поле RSS, в которое осуществляется экспорт.
Шаблон поля | Поле блока, из которого осуществляется экспорт.

Торговый каталог

Закладка позволяет назначить статус торгового каталога любому информационному блоку, выбрать информационные блоки для продажи контента и указать, данные из каких инфоблоков подлежат экспорту в Яндекс.Товары. Функция взаимозависимая с закладкой Каталоги [image] формы настройки модуля Каталог. То есть задать информационному блоку свойства торгового каталога можно как в этой, так и с той закладке.

Поле | Описание
Основные настройки
Является торговым каталогом | При отмеченной опции информационный блок будет настроен на использование в режиме торгового каталога.
Продажа контента | При отмеченной опции контент информационного блока будет платным.
Экспортировать в Яндекс.Товары При отмеченной опции содержимое информационного блока можно будет экспортировать в XML-файл для системы Яндекс.Товары.

Примечание: данная опция является устаревшей и имеет смысл только для старого агента.
НДС Указывается ставка НДС, которая будет использоваться как ставка НДС по умолчанию для товаров данного каталога.

Поле доступно для информационных блоков, которые являются торговым каталогом (отмечена опция Является торговым каталогом).

Ставки НДС задаются на странице Ставки НДС.
Торговые предложения
Инфоблок имеет торговые предложения При отмеченной опции станет доступным для настройки поле [dw]Инфоблок торговых предложений.[/dw][di] Инфоблок торговых предложений позволяет выбрать инфоблок, который будет использоваться для ввода/вывода товарных предложений (SKU). Выберите инфоблок из имеющихся в системе. Если инфоблока нет, то можно выбрать новый инфоблок. В этом случае появятся поля для добавления инфоблока: выбора типа инфоблока, в котором будет создан новый информационный блок, поле для названия инфоблока и поля настройки свойств нового инфоблока. При этом:
  • При создании нового инфоблока SKU он будет привязан ко всем сайтам, к которым привязан инфоблок товаров;
  • Если название инфоблока SKU не введено, оно будет создано по шаблону: Пакет предложений для <название инфоблока товаров>. (Шаблон языкозависим.);
  • Права для групп на создаваемый инфоблок SKU берутся из прав на инфоблок товаров за одним исключением: если инфоблок товаров участвует в документообороте или бизнес-процессах, в созданном инфоблоке права на редактирование в документообороте повысятся до изменения (U > W).
[/di]

Доступ

Управление уровнем прав групп пользователей на доступ к данному инфоблоку.

Режим прав доступа
Расширенное управление правами Включение расширенного режима, при котором можно задать права на доступ для разделов и элементов инфоблока.

После установки флажка необходимо нажать кнопку Применить. При этом текущие настройки будут сконвертированы в расширенные: группы полей Доступ по умолчанию и Доступ для групп пользователей заменяться на группу Права доступа .

Доступ по умолчанию
Для всех пользователей Параметр для групп пользователей, который будет действовать в группах с выбранным режимом "по умолчанию".
Доступ для групп пользователей
[группа_пользователей] Право доступа групп пользователей к управлению информационным блоком:
  • По умолчанию - доступ по умолчанию к управлению инфоблоком;
  • Нет доступа - доступ к информационному блоку запрещён;
  • Чтение - просмотр элементов информационного блока в публичной части;
  • Просмотр в панели - просмотр элементов и разделов информационного блока в административном разделе;
  • Добавление в панели - просмотр разделов и добавление новых элементов информационного блока в административном разделе;
  • Документооборот (или Бизнес процессы) - редактирование элементов через документооборот (или бизнес-процессы);
  • Изменение - право на редактирование параметров разделов и элементов информационного блока;
  • Полный доступ (изменение прав доступа) - изменение параметров разделов и элементов инфоблока, а также управление уровнем доступа других групп.
Права доступа
[группа_пользователей] Право доступа групп пользователей к управлению информационным блоком:
  • Нет доступа - доступ к информационному блоку запрещён;
  • Добавление - возможно добавление разделов и элементов;
  • Чтение - просмотр элементов информационного блока в публичной части;
  • Просмотр в панели - просмотр элементов и разделов информационного блока в административном разделе;
  • Добавление в панели - просмотр разделов и добавление новых элементов информационного блока в административном разделе;
  • Изменение с ограничениями - редактирование элементов с учетом статусов документооборота и запуском бизнес-процессов;
  • Изменение - право на редактирование параметров разделов и элементов информационного блока;
  • Полный доступ (изменение прав доступа) - изменение параметров разделов и элементов инфоблока, а также управление уровнем доступа других групп.
Заданные права доступа устанавливаются по умолчанию для разделов и элементов. Из можно изменить в форме редактирования конкретного раздела или элемента.

Подписи, Шаблоны бизнес-процессов, Журнал событий

Подписи

На данной закладке выполняется задание произвольных подписей и заголовков объектам инфоблока. Кроме того, указываются названия команд для управления объектами инфоблока.

Шаблоны бизнес-процессов

На данной закладке отображается список шаблонов бизнес-процессов, которые используются в данном инфоблоке. Ссылка с названием шаблона служит для перехода к его редактированию. С помощью ссылки Список шаблонов бизнес-процессов можно перейти на соответствующую страницу.

Примечание: данная закладка доступна только при наличии в системе модуля Бизнес-процессы и при включении в поле "Участвует в документообороте или бизнес процессах" (закладка Инфоблок) опции бизнес-процессы.

Журнал событий

Включение опций на этой странице позволяет добавлять события из инфоблока в Журнал событий.

В таблице ниже описаны значения полей для разделов. Для элементов эти значения аналогичны.

Поле | Описание
Записывать добавление раздела/элемента | В журнал вносится запись о добавлении раздела/элемента.
Записывать изменение раздела/элемента | В журнал вносится запись об изменении раздела/элемента.
Записывать удаление раздела/элемента | В журнал вносится запись об удалении раздела/элемента.

Смотрите также

  • Создание и настройка инфоблока


Разделы информационного блока

Если при создании типа информационного блока вы указали, что инфоблоки данного типа имеют иерархическую структуру, то помимо конкретных элементов (например, товаров), каждый инфоблок также может содержать разделы и подразделы.

Например, информационный блок Торговый каталог может содержать раздел Сборка компьютеров, который, в свою очередь, может включать подразделы Компьютеры и Комплектующие.

С помощью данной формы вы можете управлять элементами иерархии (разделами и подразделами) выбранного информационного блока.

Форма поиска

Форма фильтра используется для выбора из разделов инфоблока в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Название* | Поиск по названию раздела.
Раздел | Вышележащий (родительский) раздел.
ID раздела | Поиск идентификатору раздела. Доступны варианты поиска по точному совпадению, диапазону и больше / меньше чем.
Дата изменения (DD.MM.YYYY) | Поиск по дате последнего изменения параметров раздела.
Кто изменил | Поиск по автору последнего изменения.
Дата создания (DD.MM.YYYY) | Поиск по дате создания раздела.
Кто создал | Поиск по автору раздела.
Активность | Позволяет отобрать активные, неактивные или все разделы информационного блока.
Символьный код | Поиск по мнемоническому коду раздела.
Внешний код | Внешний код раздела, используемый для связи раздела с внешними источниками данных.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать разделы информационного блока по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех разделов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Элементы | Переход к списку элементов информационного блока. Кнопка доступна при снятом флаге Совместный просмотр секций и элементов в настройках модуля Информационные блоки.
Добавить элемент | Переход к форме создания нового элемента для данного информационного блока.
Добавить раздел | Переход к форме создания нового раздела или подраздела для данного информационного блока.
Шаблоны бизнес-процессов | Переход к списку шаблонов бизнес процессов для данного информационного блока. Примечание: кнопка доступна только при наличии в системе модуля Бизнес-процессы и при использовании бизнес-процессов для данного инфоблока.
Структура | Отображение разделов в виде дерева. Кнопка доступна в режиме отображения разделов в виде списка при снятом флаге Совместный просмотр секций и элементов в настройках модуля Информационные блоки.
Список | Отображение разделов в виде списка. Кнопка доступна в режиме отображения разделв в виде дерева при снятом флаге Совместный просмотр секций и элементов в настройках модуля Информационные блоки.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список разделов

Поле | Описание
Колонка флажков | Поле предназначено для выбора разделов, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия:
  • Разделы - переход к списку подразделов данного раздела. Данный пункт меню доступен только при снятом флаге Совместный просмотр секций и элементов в настройках модуля Информационные блоки.
  • Элементы - переход к списку элементов данного раздела. Данный пункт меню доступен только при снятом флаге Совместный просмотр секций и элементов в настройках модуля Информационные блоки.
  • Изменить - переход к форме редактирования раздела.
  • Удалить - удаление раздела.
Название | Название раздела.
Активность | Признак активности раздела. Если раздел активен, то информация раздела доступна для отображения в публичной части сайта.
Сорт. | Вес сортировки раздела. Определяет последовательность, в которой будут показаны разделы в публичной части сайта.
Дата изм. | Дата и время последнего изменения раздела.
ID | Идентификатор раздела.
Блокировка | Статус блокировки (если инфоблок участвует в документообороте).
Опубликован | Признак того, что раздел опубликован.

Групповые действия

Действие | Описание
активировать | Активировать разделы, которые на данный момент не активны.
деактивировать | Деактивировать активные разделы.
создать символьный код Действие создаёт символьные коды для выделенных разделов. Доступно если в настройках инфоблока [ds]выключен внешний сервис для перевода[/ds][di]Для массового создания символьных кодов удобно использовать инструмент групповой генерации символьных кодов.

Подробнее в курсе Контент-менеджер [image].[/di].
перенести в раздел | [dw]Перенести[/dw][di]Действие доступно с версии 20.5.0 модуля Информационные блоки.[/di] выбранные разделы в указанный раздел.
параметры товара* В качестве [dw]Параметра товара[/dw][di] Групповое действие Параметр товара доступно с версии 19.0.0 модуля Информационные блоки и с 19.0.0 модуля Торговый каталог. [/di] можно указать одну из следующих позиций:
  • Вес – указывается вес торгового предложения в граммах;
  • *Режим количественного учета – включается [ds]режим количественного учёта[/ds][di] Количественный учет - режим работы с товарами в интернет-магазине на базе «1С-Битрикс: Управление сайтом», позволяющий изменять количество товара как вручную, так и автоматически после оформления заказов покупателями.

    Подробнее [image]...[/di] для отмеченных торговых предложений;
  • *Разрешение покупки при отсутствии товара – при отмеченной опции товар будет по умолчанию доступен к покупке даже при нулевом количестве;
  • *Доступное количество – количество товара в данный момент;
  • *Закупочная цена – величина закупочной цены товара;
  • НДС включен в цену – проставляется признак включения [ds]НДС[/ds][di] Налог на добавленную стоимость (НДС) — косвенный налог, форма изъятия в бюджет государства части добавленной стоимости, которая создаётся на всех стадиях процесса производства товаров, работ и услуг и вносится в бюджет по мере реализации.

    Подробнее [image] [image]...[/di] в цену товара;
  • Идентификатор НДС – выбирается одна из ранее созданных [ds]ставок НДС;[/ds][di] По умолчанию в Интернет-магазин уже включены Ставки НДС: 0% и 18%. Ставка НДС может быть разной в зависимости от товара. Создадим и применим новую Ставку НДС.

    Подробнее [image] [image]...[/di]
  • Разрешение подписки на товар – при отмеченной опции для товара будет показываться кнопка [ds]подписки,[/ds][di] Начиная с версии 16.5.3 модуля Торговый каталог, в системе доступен обновленный функционал подписок на товары, временно отсутствующие в продаже.

    Для отсутствующего в магазине товара кнопка подписки будет отображаться в том случае, если в системе для него выполнены следующие настройки:

    Подробнее [image]...[/di] если он недоступен к покупке;
  • Единица измерения – выбирается из списка созданных ранее [ds]единиц измерений;[/ds][di] Настройка единиц измерения для интернет-магазина подробно описана в видео-уроке.

    Подробнее [image]...[/di]
  • Группа товаров – опция для указания групп товаров, подлежащих обязательной [ds]маркировке.[/ds][di] В РФ в соответствии с Федеральным законом от 31 декабря 2017 г. № 487-ФЗ товары подлежат обязательной маркировке, согласно утвержденному перечню.

    Первым делом в настройках товара необходимо указать группу, к которой принадлежит товар.

    Подробнее [image]...[/di]

* – параметры, помеченные звёздочкой, отображаются только при выключенном [ds]складском учёте.[/ds][di] Складской учет - режим работы с товарами в интернет-магазине на базе «1С Битрикс: Управление сайтом», позволяющий управлять складами, вести учет поступлений и списаний товара, реализовывать оборот товара на складах с помощью документов. Для редакции Малый бизнес наложено ограничение - возможно использование только одного склада.

Подробнее [image]...[/di]

изменить цены* [ds]Изменить цены[/ds][di] Функционал доступен с версии 16.5.3 модуля Информационные блоки.

Подробнее [image]...[/di] у всех товаров выбранных разделов. Опция доступна, если в настройках инфоблока включен совместный режим просмотра разделов и элементов.

* - данные поля доступны в том случае, если инфоблок является торговым каталогом.

Смотрите также

  • Разделы и элементы


Создание и редактирование раздела инфоблока

Закладки

Если при создании типа информационного блока вы указали, что инфоблок может содержать разделы, эта форма открывается всякий раз, когда вы создаете новый раздел или редактируете существующий. Часть полей не отображается при создании раздела.

Контекстная панель

Кнопка | Описание
Разделы | Переход на страницу со списком разделов инфоблока.
Добавить раздел | Переход к форме создания нового раздела информационного блока. Кнопка отображается при редактировании существующего раздела инфоблока.
Удалить раздел | Удаление редактируемого раздела инфоблока. Кнопка отображается при редактировании существующего раздела инфоблока.
Настроить | Переход к форме настройки внешнего вида формы редактирования разделов.

Раздел

Поле | Описание
ID | Идентификатор раздела в системе. Поле отображается при редактировании существующего раздела.
Создана | Дата и время создания раздела. Поле отображается при редактировании существующего раздела.
Изменена | Дата и время последнего изменения параметров раздела. Поле отображается при редактировании существующего раздела.
Раздел активен | Признак активности раздела информационного блока. При отмеченной опции содержимое раздела инфоблока доступно для показа в публичной части сайта.
Родительский раздел | Раздел, дочерним элементом которого является этот раздел.
*Название | Название раздела.
Изображение Изображение, ассоциируемое с данным разделом информационного блока. Для выбора изображения используйте кнопку Добавить файл или воспользуйтесь необходимым пунктом меню кнопки [image]:
  • Загрузить с компьютера - загрузка изображения с локального компьютера;
  • Выбрать из медиабиблиотеки - выбор изображения из Медиабиблиотеки;
  • Выбрать из структуры - выбор изображения из структуры сайта;
  • Вставить путь к файлу - указывается путь к изображению на сервере;
Описание
Переключатель режима ввода текста Задается режим ввода текста описания раздела инфоблока: Text, HTML или Визуальный редактор.

В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть на сайте.

* - поля, обязательные для заполнения.

SEO

По умолчанию все настройки SEO для раздела берутся из настроек для инфоблока (вышестоящего раздела), а с помощью данной закладки можно задать персональные настройки SEO для текущего раздела и всех его подразделов. Прежде, чем приступать к настройке того или иного шаблона, следует отметить расположенную рядом с его полем опцию Изменить для этого раздела и его подразделов.

Поле | Описание
Настройки для разделов/элементов
Шаблон META TITLE | Задается шаблон, по которому будет создаваться мета-тег TITLE для раздела/элементов раздела. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон META KEYWORDS | Задается шаблон, по которому будет создаваться мета-тег KEYWORDS для раздела/элементов раздела. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон META DESCRIPTION | Задается шаблон, по которому будет создаваться мета-тег DESCRIPTION для раздела/элементов раздела. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Заголовок раздела/товара Задается шаблон для создания заголовка страницы просмотра раздела/элемента этого раздела. Вывод данного заголовка выполняется с помощью функции ShowTitle():
<H1><?$APPLICATION->ShowTitle()?></H1>
Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Настройки для изображений разделов, детальных картинок разделов, картинок анонса элементов и для детальных картинок элементов
Шаблон ALT | Задается шаблон, по которому будет создаваться атрибут ALT для изображения. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон TITLE | Задается шаблон, по которому будет создаваться атрибут TITLE для изображения. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон имени файла Задается шаблон, по которому будет создаваться имя файла с изображением. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.

Имя файла будет формироваться с учетом следующих опций:
  • Привести к нижнему регистру - при отмеченной опции имя файла будет создано в нижнем регистре;
  • Транслитерировать - при отмеченной опции будет выполнена транслитерация имени файла;
  • Замена для пробельных символов после транслитерации - задается символ, который будет использоваться вместо пробела после транслитерации имени файла.
Управление
Очистить кеш вычисленных значений | При отмеченной опции очищается кеш шаблонов и все вносимые изменения в настройках отображаются сразу.

Дополнительно, Доп. свойства, Доступ

Закладка Дополнительно

Поле | Описание
Сортировка | Относительный "вес", влияющий на положение раздела в списке.
Внешний код | Символьный код, используемый для связи раздела с внешним источником данных. Поле отображается при включенной опции Показывать код загрузки из внешних источников в настройках модуля Информационные блоки.
Символьный код | Мнемонический код раздела, состоящий из латинских символов. Используется при выборе разделов и элементов разделов для показа в публичной части сайта.
Детальная картинка | Детальное изображение, ассоциируемое с данным разделом информационного блока. Три вкладки (Компьютер, Структура и Медиабиблиотека) позволяют загрузить изображение, используя один из соответствующих источников. Для выбора изображения используйте кнопку Обзор.

Закладка Доп. свойства

На закладке имеется ссылка Добавить пользовательское свойство для добавления нового поля для раздела инфоблока. По ссылке осуществляется переход к форме создания нового поля.

Закладка Доступ

Закладка доступна, есть в настройках инфоблока включен расширенный режим управления правами доступа. В закладке отображаются права доступа, установленные по умолчанию. Для изменения уровня прав воспользуйтесь кнопкой Добавить, выберите группу для которой будут изменены/назначены права и сохраните изменения.

Смотрите также

  • Создание и настройка инфоблока
  • Разделы: создание, расположение в меню, удаление


Элементы информационного блока

На странице представлен список элементов разделов информационного блока или самого блока. Элемент раздела - сущность, не поддающаяся дальнейшей классификации в пределах созданной вами иерархии. Например, элемент-товар Монитор раздела Комплектующие. Поля формы отличаются для разных типов инфоблоков от описанного по порядку элементов и их числу. Здесь приведено самое общее описание элементов.

Форма поиска

Форма фильтра используется для выбора из элементов инфоблока в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Название | Поиск по названию элемента.
ID (начальный и конечный) | Поиск по интервалу идентификаторов элементов.
Раздел | Вышележащий (родительский) раздел.
Включая подразделы | Вывод в списке элементов всех подразделов выбранного раздела.
Дата изменения (DD.MM.YYYY) | Поиск по дате последнего изменения параметров элемента.
Кем изменен (ID) | Поиск по автору изменения.
Дата создания (DD.MM.YYYY) | Поиск по дате создания элнмента.
Кто создал | Поиск пользователя, создавшего элемент.
Начало активности (DD.MM.YYYY) | Задается период начала активности элемента для его поиска.
Окончание активности (DD.MM.YYYY) | Задается период окончания активности элемента для его поиска.
Активность | Позволяет отобрать активные, неактивные или все элементы информационного блока.
Описание | Поиск элементов по описанию.
Символьный код | Поиск по мнемоническому коду элемента.
Внешний код | Внешний код, используемый для связи элемента с внешними источниками данных.
Теги | Поиск элементов по заданным тегам.
Статус | Поиск элемента по его статусу (при использовании документооборота).
Тип товара | Поиск товаров по их типу. Поле доступно только для инфоблока, являющего торговым каталогом.
Наличие набора | Поиск товаров по наличию к ним набора. Поле доступно только для инфоблока, являющего торговым каталогом.
Доступность | Поиск товаров по наличию на складе. Поле доступно только для инфоблока, являющего торговым каталогом.
[свойство] | Поля для фильтрации элементов по значениям свойств, для которых было задано свойство Выводить на странице списка элементов поле для фильтрации по этому свойству.

Чтобы отобрать элементы информационного блока по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех элементов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить элемент Переход к форме создания нового элемента инфоблока.

Если инфоблок является торговым каталогом, то будет будет выполнятся создание товара простого типа.
Создать другие типы товаров Доступны следующие действия:
  • Создать товар с торговыми предложениями - создание товара с торговыми предложениями (действие доступно, если для инфоблока задан инфоблок торговых предложений);
  • Создать комплект - создание основного товара и комплекта к нему;
  • Создать набор - создание основного товара и набора к нему.

Кнопка доступна, если инфоблок является торговым каталогом.
Добавить раздел | Переход к форме создания нового раздела инфоблока.
Шаблоны бизнес-процессов Переход на страницу со списком шаблонов бизнес-процессов данного инфоблока.

Примечание: кнопка доступна только при наличии в системе модуля Бизнес-процессы и при использовании бизнес-процессов для данного инфоблока.

Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список элементов

Поле | Описание
Колонка флажков | Поле предназначено для выбора элементов, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия:
  • Запустить бизнес-процесс - переход к выбору шаблона бизнес-процесса для запуска (возможно только при наличии установленного модуля Бизнес-процессы);
  • Разблокировать - освободить заблокированный элемент;
  • Изменить - переход к форме редактирования элемента инфоблока;
  • Деактивировать/Активировать - снятие/постановка флага активности для элемента без захода в форму редактирования элемента;
  • Сбросить счетчик просмотров - сброс счетчика просмотров элементов;
  • Копировать - копирование элемента (копирование выполняется в тот же раздел того же инфоблока, где находится элемент; впоследствии элемент можно будет перенести в любой другой раздел этого инфоблока);
  • История изменений - просмотреть историю изменения элемента (возможно только при наличии установленного модуля Документооборот);
  • Просмотреть - переход к просмотру элемента;
  • Удалить - удаление элемента инфоблока.
Тип товара | Указывается тип товара. Колонка доступна только для инфоблоков, являющихся торговыми каталогами.
Название | Название элемента.
Активность | Активность элемента. Активные элементы доступны для показа в публичной части сайта.
Сорт. | Относительный "вес", определяющий положение элемента в списке.
Символьный код | Мнемонический код элемента.
Внешний код Символьный код, используемый для связи элемента с внешним источником данных.

Для редакций с модулем CRM поле также содержит информацию о товарах, импортируемых из Instagram*.

* деятельность организации запрещена в Российской Федерации.

Дата изм. | Дата и время последнего изменения элемента.
Кем изменена | Логин и имя пользователя, который совершил последние изменения.
Дата создания | Время и дата создания данной записи.
Кем создана | Логин и имя пользователя, который создал запись о элементе.
ID | Идентификатор элемента.
Элементов | Данное поле доступно для отображения только при отмеченной опции Совместный просмотр секций и элементов на странице настроек модуля Информационные блоки.
Подразделов | Данное поле доступно для отображения только при отмеченной опции Совместный просмотр секций и элементов на странице настроек модуля Информационные блоки.
Начало активности | Дата и время начала активности.
Окончание активности | Дата и время окончания активности.
Количество показов | Количество показов данного элемента на сайте.
Дата первого показа | Время и дата первого показа элемента на сайте.
Картинка для анонса | Изображение, указанное в анонсе элемента.
Описание для анонса | Краткое описание элемента для анонса.
Детальная картинка | Изображение, которое выводится в детальном описании элемента.
Детальное описание | Детальное описание элемента.
Теги | Теги элемента.
Статус | Статус элемента.
Блокировка | Индикатор блокировки элемента.
Кем заблокирована | Логин и имя пользователя, заблокировавшего элемент.
Когда заблокирована | Дата и время, когда элемент был заблокирован.
Комментарий администратора | Произвольный комментарий администратора.
[свойство] | Выводятся значения свойств, если они указаны.
Доступность | Признак доступности товара к покупке.
Доступное количество* | Количество товара на складах в данный момент.
Зарезервировано* | Количество товара, оформленного в заказах, но еще не списанного со складов.
Коэф.* | Коэффициент единицы измерения товара.
Ед. измерения* | Единица измерения товара.
Доступность* | Доступность товара.
Доступное количество* | Доступное количество товара на складе.
Уменьшать количество при заказе* | Количество товара уменьшается при заказе товара или нет.
Вес (грамм)* | Вес товара в граммах.
Ширина (мм)* | Ширина товара в миллиметрах.
Длина (мм)* | Длина товара в миллиметрах.
Высота (мм)* | Высота товара в миллиметрах.
НДС включен в цену* | Признак включения НДС в цену товара.
Закупочная цена* | Величина закупочной цены товара.
Штрих-код* | Штрих-код товара.
[тип цены]* | Цена товара данного типа цены.
Количество подписок* | Количество подписок на товар.

* - данные поля доступны в том случае, если инфоблок является торговым каталогом.

Групповые действия

Действие | Описание
активировать | Активировать элементы, которые на данный момент не активны.
деактивировать | Деактивировать активные элементы.
создать символьный код Действие создаёт символьные коды для выделенных элементов. Доступно если в настройках инфоблока [ds]выключен внешний сервис для перевода[/ds][di]Для массового создания символьных кодов удобно использовать инструмент групповой генерации символьных кодов.

Подробнее в курсе Контент-менеджер [image].[/di].
сбросить счётчик просмотров | Сброс счетчика просмотров элементов.
перенести в раздел | Выбор основного раздела элемента.
добавить привязку к разделу Выбор дополнительных разделов, в которых будет отображаться элемент.

Примечание: В совместном режиме просмотра разделов и элементов групповая операция Добавить привязку к разделу [dw]игнорируется[/dw][di]С версии 20.5.0 модуля Информационные блоки.[/di] для разделов инфоблока.

заблокировать/разблокировать Опция доступна при включенном [ds]Документообороте[/ds][di] Настройка документооборота на последовательную работу над информационными блоками включает в себя шаги:
  1. Настройка прав модуля Управление структурой.
  2. Настройки разделов, участвующих в документообороте.
  3. Создание и настройка необходимых статусов для документов.

Подробнее [image] [image]...[/di] и позволяет разрешить/запретить работу с элементом.
изменить статус Опция доступна при включенном [ds]Документообороте,[/ds][di] Настройка документооборота на последовательную работу над информационными блоками включает в себя шаги:
  1. Настройка прав модуля Управление структурой.
  2. Настройки разделов, участвующих в документообороте.
  3. Создание и настройка необходимых статусов для документов.

Подробнее [image] [image]...[/di] позволяет изменить текущий статус элемента.
параметр товаров* В качестве [dw]Параметра товара[/dw][di] Групповое действие Параметр товара доступно с версии 19.0.0 модуля Информационные блоки и с 19.0.0 модуля Торговый каталог. [/di] можно указать одну из следующих позиций:
  • Вес – указывается вес торгового предложения в граммах;
  • *Режим количественного учета – включается [ds]режим количественного учёта[/ds][di] Количественный учет - режим работы с товарами в интернет-магазине на базе «1С-Битрикс: Управление сайтом», позволяющий изменять количество товара как вручную, так и автоматически после оформления заказов покупателями.

    Подробнее [image]...[/di] для отмеченных торговых предложений;
  • *Разрешение покупки при отсутствии товара – при отмеченной опции товар будет по умолчанию доступен к покупке даже при нулевом количестве;
  • *Доступное количество – количество товара в данный момент;
  • *Закупочная цена – величина закупочной цены товара;
  • НДС включен в цену – проставляется признак включения [ds]НДС[/ds][di] Налог на добавленную стоимость (НДС) — косвенный налог, форма изъятия в бюджет государства части добавленной стоимости, которая создаётся на всех стадиях процесса производства товаров, работ и услуг и вносится в бюджет по мере реализации.

    Подробнее [image] [image]...[/di] в цену товара;
  • Идентификатор НДС – выбирается одна из ранее созданных [ds]ставок НДС;[/ds][di] По умолчанию в Интернет-магазин уже включены Ставки НДС: 0% и 18%. Ставка НДС может быть разной в зависимости от товара. Создадим и применим новую Ставку НДС.

    Подробнее [image] [image]...[/di]
  • Разрешение подписки на товар – при отмеченной опции для товара будет показываться кнопка [ds]подписки,[/ds][di] Начиная с версии 16.5.3 модуля Торговый каталог, в системе доступен обновленный функционал подписок на товары, временно отсутствующие в продаже.

    Для отсутствующего в магазине товара кнопка подписки будет отображаться в том случае, если в системе для него выполнены следующие настройки:

    Подробнее [image]...[/di] если он недоступен к покупке;
  • Единица измерения – выбирается из списка созданных ранее [ds]единиц измерений;[/ds][di] Настройка единиц измерения для интернет-магазина подробно описана в видео-уроке.

    Подробнее [image]...[/di]
  • Группа товаров – опция для указания групп товаров, подлежащих обязательной [ds]маркировке.[/ds][di] В РФ в соответствии с Федеральным законом от 31 декабря 2017 г. № 487-ФЗ товары подлежат обязательной маркировке, согласно утвержденному перечню.

    Первым делом в настройках товара необходимо указать группу, к которой принадлежит товар.

    Подробнее [image]...[/di]

* – параметры, помеченные звёздочкой, отображаются только при выключенном [ds]складском учёте.[/ds][di] Складской учет - режим работы с товарами в интернет-магазине на базе «1С Битрикс: Управление сайтом», позволяющий управлять складами, вести учет поступлений и списаний товара, реализовывать оборот товара на складах с помощью документов. Для редакции Малый бизнес наложено ограничение - возможно использование только одного склада.

Подробнее [image]...[/di]

изменить цену* | Редактирование цены товара.

* - данные поля доступны в том случае, если инфоблок является торговым каталогом.

Смотрите также

  • Разделы и элементы


Создание и редактирование элемента инфоблока

Закладки

Данная форма - одно из средств для редактирования и добавления элементов информационных блоков вручную. Например, с ее помощью можно добавлять новые товары в торговый каталог, публиковать новости и т.п.

Контекстная панель

Кнопка | Описание
Список элементов | Переход на страницу со списком элементов данного инфоблока.
Копировать Копирование существующего элемента в пределах данного инфоблока. Кнопка отображается при редактировании уже существующего элемента.

Обратите внимание! При копировании элементов инфоблока НЕ копируются картинки и копирование возможно только в пределах одного инфоблока.
Действия Кнопка доступна только при редактировании существующего элемента. Доступные действия:
  • Добавить элемент - переход на страницу с формой создания нового элемента инфоблока.
  • Удалить элемент - удаление редактируемого элемента инфоблока.
  • История изменений - переход на страницу истории изменения элемента. Данный пункт доступен только в том случае, если инфоблок участвует в документообороте.
Параметры товара Если инфоблок является торговым каталогом, то данная кнопка доступна при редактировании существующего элемента. Доступные действия:
  • Товар - служит для переопределения типа товар на простой товар.
  • Товар с торговыми предложениями - служит для переопределения типа товар на товар с торговыми предложениями. Становится доступной закладка Торговые предложения.
    Данное действие недоступно для инфоблока торговых предложений.
  • Комплект - служит для переопределения типа товар на комплект. Становится доступной закладка Состав комплекта.
  • Добавить набор - служит для добавления набора рекомендуемых товаров для основного товара. При выборе данного пункта становится доступной закладка Состав набора.
  • Удалить набор - служит для удаления набора. Отображается только для существующего товара с набором.
Настроить | Переход к настройке внешнего вида формы редактирования элемента.

Число закладок формы, их вид, название и поля на них изменяются в зависимости от настроек информационного блока.

Элемент

Поле | Описание
Импортирован из | Поле содержит информацию из какого профиля Instagram* был импортирован товар. Отображается только для редакций с модулем CRM. * деятельность организации запрещена в Российской Федерации.
ID | Идентификатор элемента. Отображается только в форме редактирования.
Создан | Дата, время и пользователь, создавший элемент.
Изменен | Дата, время и пользователь, изменивший элемент.
Активность | Признак активности элемента. Активный элемент доступен для отображения в публичной части сайта.
Начало активности (DD.MM.YYYY / DD.MM.YYYY HH:MI:SS) | Начало периода активности элемента. Если поле не заполнено, то элемент считается активным с момента его сохранения.
Окончание активности (DD.MM.YYYY / DD.MM.YYYY HH:MI:SS) | Окончание периода активности элемента. Если поле не заполнено, то элемент признается бессрочно активным.
*Название | Название элемента, как оно отображается в публичной части.
Символьный код | Мнемонический код элемента.
Основной раздел | Указывается основной раздел элемента среди всех разделов, к которым он привязан. Параметр доступен, если отмечена опция Разрешить выбор основного раздела для привязки на закладке Поля формы создания/редактирования инфоблока.
*Внешний код | Код, используемый для связи инфоблока с внешним источником данных. Поле отображается при включенной опции Показывать код загрузки из внешних источников в настройках модуля Информационные блоки. Если поле отображается, то оно обязательно к заполнению.
Сортировка | Вес сортировки элемента. Чем меньше вес сортировки, тем выше отображается элемент.
Значения свойств
[название_свойства] | Имя свойства элементов инфоблока. Свойства элемента назначаются в настройках информационного блока.
[значение_свойства] | Значение свойства задается для каждого элемента инфоблока.
Связанные элементы
Если для данного элемента имеются связанные, т.е. в свойствах каких-либо инфоблоков настроена привязка к элементам данного инфоблока. Связанные элементы выведены не напрямую, а в виде ссылки в формате: [название_инфоблока]:[название_элемента]. Ссылка переводит на страницу со списком связанных элементов.

* - поля, обязательные для заполнения.

Анонс

Форма служит для задания краткого описание элемента. Созданное описание может использоваться, например, для характеристики каждого элемента при показе списка элементов в публичной части сайта.

Поле Описание
Картинка для анонса Изображение малого размера, ассоциируемое с данным элементом для предпросмотра. Для выбора изображения используйте механизм drag&drop или воспользуетесь кнопкой [image], которая предоставляет следующие возможности:
  • Загрузить с компьютера - загрузка изображения с локального компьютера;
  • Вставить путь к файлу - указывается путь к изображению на сервере;
  • Выбрать из медиабиблиотеки - выбор изображения из Медиабиблиотеки;
  • Выбрать из структуры - выбор изображения из структуры сайта;
  • Использовать кадрирование - выполнить обработку выбранного файла;
  • Закрепить поле описания - поле для описания будет закреплено под изображением;
  • Очистить - удаление изображение.
Переключатель режима ввода текста Задается режим ввода текста краткого описания элемента инфоблока: Text, HTML или Визуальный редактор. Переключение режима в одном любом элементе переключает режим во всех элементах данного инфоблока.

В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть на сайте.

Подробно

Форма служит для создания подробного описания элемента инфоблока. Например, полного текста новости, детального описания товара и т.д.

Поле Описание
Детальная картинка Крупноформатное изображение, ассоциируемое с данным элементом. Для выбора изображения используйте механизм drag&drop или воспользуетесь кнопкой [image], которая предоставляет следующие возможности:
  • Загрузить с компьютера - загрузка изображения с локального компьютера;
  • Вставить путь к файлу - указывается путь к изображению на сервере;
  • Выбрать из медиабиблиотеки - выбор изображения из Медиабиблиотеки;
  • Выбрать из структуры - выбор изображения из структуры сайта;
  • Использовать кадрирование - выполнить обработку выбранного файла;
  • Закрепить поле описания - поле для описания будет закреплено под изображением;
  • Очистить - удаление изображение.
Переключатель режима ввода текста Задается режим ввода текста подробного описания элемента инфоблока: Text, HTML или Визуальный редактор. Переключение режима в одном любом элементе переключает режим во всех элементах данного инфоблока.

В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть на сайте.

SEO

По умолчанию все настройки SEO для элемента берутся из настроек для инфоблока или из настроек для раздела, а с помощью данной закладки можно задать персональные настройки SEO для элемента. Прежде, чем приступать к настройке того или иного шаблона, следует отметить расположенную рядом с его полем опцию Изменить для этого элемента.

Поле | Описание
Шаблон META TITLE | Задается шаблон, по которому будет создаваться мета-тег TITLE для элемента. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон META KEYWORDS | Задается шаблон, по которому будет создаваться мета-тег KEYWORDS для элемента. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон META DESCRIPTION | Задается шаблон, по которому будет создаваться мета-тег DESCRIPTION для элемента. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Заголовок товара Задается шаблон для создания заголовка страницы просмотра элемента (товара). Вывод данного заголовка выполняется с помощью функции ShowTitle():
<H1><?$APPLICATION->ShowTitle()?></H1>
Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Настройки для картинок анонса элементов и для детальных картинок элементов
Шаблон ALT | Задается шаблон, по которому будет создаваться атрибут ALT для изображения. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон TITLE | Задается шаблон, по которому будет создаваться атрибут TITLE для изображения. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон имени файла Задается шаблон, по которому будет создаваться имя файла с изображением. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.

Имя файла будет формироваться с учетом следующих опций:
  • Привести к нижнему регистру - при отмеченной опции имя файла будет создано в нижнем регистре;
  • Транслитерировать - при отмеченной опции будет выполнена транслитерация имени файла;
  • Замена для пробельных символов после транслитерации - задается символ, который будет использоваться вместо пробела после транслитерации имени файла.
Дополнительно
Теги (введите слова или словосочетания, разделяя их запятыми) | Слова или словосочетания, с помощью которых формируется поиск по тегам. При написании первых букв тега в поле ввода система отображает выпадающий список с уже существующими тегами. По умолчанию в списке установлена сортировка ранее использованных тегов по частоте их применения. Установка флажка в чекбоксе справа от поля ввода включает сортировку тегов по имени.

Реклама

На закладке выполняется как привязка уже существующих рекламных объявлений к элементу инфоблока, так и создание новых объявлений, связанных с элементом. Закладка доступна только при редактировании элемента.

Примечание: закладка доступна с версии 15.0.

Поле | Описание
Вкладка Яндекс.Директ
ссылка Авторизоваться Ссылка отображается только при отсутствии авторизации в системе Яндекс. Служит для выполнения авторизации, чтобы иметь возможность приступить к управлению рекламными кампаниями и объявлениями.

В случае отсутствия рекламных кампаний, после авторизации необходимо ее создать, используя ссылку создать новую кампанию.
Связка с объявлениями Яндекс.Директ
Поле | Описание
Выберите рекламную кампанию | Необходимая рекламная кампания выбирается из списка либо создается новая по ссылке создать новую кампанию.
Выберите объявление | Необходимое объявление выбирается из списка либо создается новое по ссылке создать новое объявление.
кнопка Привязать объявление | Кнопка служит для привязки выбранного имеющегося рекламного объявления. Если объявление создается по соответствующей ссылке, то оно привязывается к элементу автоматически.
Привязанные рекламные объявления | Отображается список рекламных объявлений по кампаниям. Для удаления привязки объявления к элементу (удаляется только привязка, но не объявление из кампании) следует нажать на "крестик".

Разделы

Форма служит для выбора одного или нескольких разделов инфоблока, к которым относится элемент.

Поле | Описание
Разделы | Разделы, к которым привязан элемент. Поле не отображается, если для данного типа информационного блока в настройках модуля снят флажок "Содержит разделы" либо в инфоблоке не создан ни один раздел. Интерфейс выбора разделов устанавливается в настройках инфоблока.

Торговый каталог

Важно! Закладка отображается, если в настройках модуля Торговый каталог для данного информационного блока была установлена опция Является торговым каталогом. Но при этом она может быть недоступна при создании типа товара товар с торговыми предложениями, если в настройках модуля Торговый каталог не отмечена опция Показывать вкладку Торговый каталог для товаров, имеющих торговые предложения.

Поле | Описание
Вкладка Цены
Вкладка служит для задания стоимости товара для разных типов цен.
Использовать расширенный режим управления ценами При отмеченной опции форма принимает [dw]расширенный вид[/dw] [di]
Поле | Описание
Тип цены | Перечень доступных типов цен товара.
От | Поля служат для задания связи между количеством приобретаемых товаров и их стоимостью. Например, можно указать, что при приобретении от 1 до 5 единиц товара, товар будет продаваться по цене 500 руб./шт, а при приобретении от 6 до 10 единиц товара, стоимость товара будет равна 400 руб./шт. Количество товара может быть задано как одним числом, так и в виде диапазона.
До
Тип наценки | Поле для выбора типа наценки, используемой при формировании стоимости товара для данного типа цены. Выбор наценки для базового типа цены не производится.
Цена (за единицу) | Стоимость единицы товара для данного типа цены, при условии приобретения указанного товаров.
Валюта | Наименование валюты, в которой указана стоимость товара для данного типа цены.

Кнопка "Ещё" позволяет добавить новую стpоку для указания стоимости товаров и
условий ее применения. [/di]и позволяет задавать стоимость товара для разных типов цен с указанием дополнительных параметров, влияющих на стоимость.
Ставка НДС | С появлением встроенной поддержки НДС пользователь может задать ставки НДС в специальной форме: Магазин > Торговый каталог > Ставки НДС и установить значение ставки по умолчанию для каждого торгового каталога на странице настроек модуля Торговый каталог. В этом поле выбрано значение по умолчанию. Вы можете переопределить его вручную либо установить вариант не выбрано.
НДС включен в цену | Если опция отмечена, то подразумевается, что НДС входит в указанную цену товара.
Закупочная цена | Закупочная цена элемента (товара). Данное поле доступно для редактирования при выключенном в настройках торгового каталога складском учете.
Валюта закупочной цены | Валюта, в которой указана закупочная цена. Данное поле доступно для редактирования при выключенном в настройках торгового каталога складском учете.
*Базовая цена (BASE) | Базовая цена элемента (товара).
*Валюта базовой цены | Валюта, в которой указана базовая цена.
Далее описание полей представлено в виде таблицы:
Поле | Описание
Тип цены | Перечень доступных типов цен товара.
Тип наценки | Поле для выбора типа наценки, используемой при формировании стоимости товара для данного типа цены.
Сумма | Стоимость товара с учётом выбранного типа наценки. Стоимость товара рассчитывается по формуле [Цена] = [Базовая цена] + [Базовая цена] * [Процент наценки] / 100. Если тип наценки не выбран, то стоимость товара для данного типа цены можно ввести вручную.
Валюта | Наименование валюты, в которой указана стоимость товара для данного типа цены.
Вкладка Параметры
На вкладке указываются дополнительные сведения о продаваемом товаре, а также (если каталог настроен на продажу контента) параметры подписки на контент сайта.
Поле | Описание
Доступное количество | Сумма остатков товара на складах в данный момент.
Зарезервированное количество Количество товара, оформленного в заказах, но еще не списанного со складов.

Данный параметр отображается только при включенном механизме резервирования.
Единица измерения Задается единица измерения товара.

Поле доступно только для обычных товаров.
Коэффициент единицы измерения Коэффициент единицы измерения товара.

Поле доступно только для обычных товаров.
Параметры
Включить количественный учет Подключить количественный учет товара:
  • да;
  • нет;
  • по умолчанию (из настроек модуля Торговый каталог).
Если количественный учет данного товара отключен, то он будет продаваться всегда.
Кеш публичных компонентов сбрасывается, если меняется возможность купить товар с включенным количественным учетом.
Разрешить покупку при отсутствии товара (включая разрешение отрицательного количества товара) Возможность покупать товар при его отсутствии на складе:
  • да;
  • нет;
  • по умолчанию (из настроек модуля Торговый каталог).
Если покупка при отсутствии товара разрешена, то автоматически разрешается задавать отрицательное количество товара. Чтобы покупка была запрещена при отсутствии товара, должен быть включен количественный учет для товара.

Примечание: до версии 16.0.0 опция называлась Разрешить покупку при отсутствии товара.
Разрешить отрицательное количество товара Включить возможность установки отрицательных значений количества товаров при его покупке:
  • да;
  • нет;
  • по умолчанию (из настроек модуля Торговый каталог).
Примечание: данная опция доступна в настройках модуля Торговый каталог, если версия модуля ниже, чем 16.0.0.
Разрешить подписку при отсутствии товара Включить возможность подписки на отсутствующие товары (когда товар станет доступным для покупки, клиент получит уведомление).
  • да;
  • нет;
  • по умолчанию (из настроек модуля Торговый каталог).
Вес и размеры (доступно только для обычных товаров)
Длина (мм.) | Длина товара, заданная в мм.
Ширина (мм.) | Ширина товара, заданная в мм.
Высота (мм.) | Высота товара, заданная в мм.
Вес (грамм) | Вес единицы товара в граммах.
Расширенные параметры
Группа товаров Выбирается одна из групп товаров, подлежащих обязательной [ds]маркировке[/ds][di] В РФ в соответствии с Федеральным законом от 31 декабря 2017 г. № 487-ФЗ товары подлежат обязательной маркировке, согласно утвержденному перечню.

Подробнее [image]...[/di] (если товар относится к таким группам).
Параметры подписки (доступно, если инфоблок осуществляет продажу контента)
Тип оплаты Задается тип оплаты приобретения контента сайта. Доступно три типа оплаты:
  • одноразовая - означает, что товар приобретается покупателем один раз. В дальнейшем никаких движений по приобретенному товару не предусматривается;
  • регулярная (или "подписка") - означает, что по истечении заданного периода времени покупателю будет выставлен новый счет на продление использования товара;
  • пробный период ("триал") - предусматривает приобретение пробной версии товара (например, пробного доступа). По истечении указанного периода покупателю будет выставлен счет на покупку полной версии товара.
Длина периода оплаты | Указывается длительность периода времени, по истечении которого системой будет выставлен новый счет на приобретение товара. Значение поля задается для не одноразовых типов оплаты (регулярная и пробный период).
Единица времени периода оплаты | Определяются единицы времени, используемые для задания продолжительности периода оплаты (месяц, сутки, час и т.д.).
Пробная для (заполняется только для пробных) | В поле для товара с типом оплаты пробный период указывается полная версия товара. По истечении пробного периода пользователю будет предложено приобрести указанный товар (полную версию).
Продление без оформления заказа | Опция доступна для типа оплаты регулярная. Если она выбрана, то при продлении товара (пользования товаром) будет рассчитана сумма заказа. Но сам заказ не будет сформирован в базе системы. Опция может быть полезна при проведении небольших регулярных списаний с внутреннего счета покупателя.
Вкладка Группы
Вкладка Группы отображается для элементов торгового каталога, настроенного на режим продажи контента. Служит для управления продажей прав доступа к контенту сайта.
Поле | Описание
Включить | Поле для выбора группы пользователей, к которой будет осуществляться привязка покупателей данного товара.
Группа пользователей | Название группы пользователей, к которой будет осуществляться привязка покупателей данного товара.
Длительность приписывания | Длительность привязки покупателей к выбранной группе. По истечении указанного периода покупатель будет удален из списка пользователей данной группы. Если значение поля равно 0, то покупатели приписываются к группе на неограниченный период.
Вкладка Скидки
На вкладке Скидки представлены активные общие скидки, которые будут применены к данному товару.
Поле | Описание
ID | Идентификатор скидки.
Сайт | Идентификатор сайта, на товары которого распространяется действие данной скидки.
Активность | Признак активности скидки. Если скидка не является активной, она не может быть применена.
Название | Название скидки.
Величина | Размер скидки.
Действие | Доступные действия над скидками. С помощью ссылки Изменить вы можете перейти к редактированию параметров скидки.
Вкладка Склады
На вкладке Склады представлен список складов, на которых может храниться товар.
Поле | Описание
№ | Номер склада.
Название | Название склада.
Адрес | Адрес склада.
Количество товара | Число товара на складе.
Вкладка Штрихкод
На вкладке Штрихкод указывается информация о штрихкоде товара. Вкладка отображается, если в настройках модуля Торговый каталог отмечена опция Включить складской учет.
Поле | Описание
Каждый экземпляр товара имеет собственный штрихкод | При отмеченной опции каждая единица товара будет иметь собственный штрихкод.
Штрихкод | Штрихкод товара. Ввод возможен как вручную, так и с помощью USB-сканера.
Вкладка Подписки
На вкладке Подписки содержится информация о подписках на товар.
Поле | Описание
Количество подписок | Общее количество подписок на товар.
Количество активных подписок | Количество активных подписок на товар.
Список подписок | Ссылка посмотреть служит для перехода на страницу просмотра подписок на товары.

Торговые предложения

Важно! Закладка отображается только при создании/редактировании товаров типа товар с торговыми предложениями. Инфоблок при этом должен являться торговым каталогом и для него должен быть задан инфоблок торговых предложений. На закладке выводится список элементов [image] торговых предложений для редактируемого элемента. Список выводится без формы поиска. В этой форме можно добавить вручную [image] (кнопка Добавить элемент) или сгенерировать (кнопка Генерировать торговые положения) элементы торговых предложений, которые будут выводится как торговые предложения для данного товара. Кроме того, с помощью кнопки Добавить предложение с набором можно создать торговое предложение с набором.

Документооборот, Бизнес-процессы

Закладка Документооборот

Закладка доступна, если в настройках информационного блока указано, что он участвует в документообороте.

Поле | Описание
Создана | Дата и время создания записи элемента, а также имя пользователя, создавшего элемент.
Изменена | Дата и время последнего изменения записи элемента, а также имя пользователя, изменившего элемент.
Заблокирована | Дата и время блокирования элемента и имя пользователя, заблокировавшего элемент.
Статус | Текущий статус элемента. Создание и настройка параметров статусов выполняется в модуле Документооборот.
Комментарии
Произвольный комментарий к статусу документа (например, описание причины изменения статуса).

Закладка Бизнес-процессы

Закладка доступна только в том случае, если в системе имеется модуль Бизнес-процессы и в настройках информационного блока указано, что он участвует в бизнес-процессах.

Поле | Описание
Документ опубликован | В поле содержится информация о том, опубликован ли элемент инфоблока или нет.
<Название бизнес-процесса>
Название бизнес-процесса | Название шаблона бизнес-процесса.
Текущий статус | Статус, в котором находится бизнес-процесс в данный момент.
[параметры запуска бизнес-процесса] | Задаются значения созданных параметров запуска бизнес-процесса.

Состав комплекта, Состав набора

Закладка Состав комплекта

На данной вкладке осуществляется выбор товаров, которые входят в состав комплекта. Закладка доступна только при создании/редактировании типа товара комплект.

Поле | Описание
Товар | Товар, который входит в комплект. По кнопке [...] открывается окно выбора товара.
Количество | Указывается необходимое количество текущего товара в комплекте.
Процент скидки | Процент, который получит текущий товар, от скидки на весь товар.
Сортировка | "Вес" товара, определяющий его положение в списке.
Удалить из комплекта | При отмеченной опции товар будет удален из комплекта. Доступно только при редактировании комплекта.
кнопка Еще | Служит для добавления полей выбора входящих в комплект товаров.

Закладка Состав набора

На данной вкладке осуществляется создание набора рекомендованных товаров, которые покупаются с основным товаром. Закладка доступна при создании/редактировании типа товара набор, при создании/редактировании торгового предложения с набором или при добавлении набора к существующему товару любого типа.

Поле | Описание
Товар | Товар, который входит в набор. По кнопке [...] открывается окно выбора товара.
Количество | Указывается необходимое количество текущего товара в комплекте.
Сортировка | "Вес" товара, определяющий его положение в списке товаров набора.
Удалить из набора | При отмеченной опции товар будет удален из набора. Доступно только при редактировании набора.
кнопка Еще | Служит для добавления полей выбора входящих в набор товаров.

Доступ

Закладка доступна, если в настройках инфоблока включен расширенный режим управления правами доступа. В закладке отображаются права доступа, установленные по умолчанию. Для изменения уровня прав воспользуйтесь кнопкой Добавить, выберите группу для которой будут изменены/назначены права и сохраните изменения.

Пример создания элемента инфоблока

  • Как добавить новость на сайт


Настройка внешнего вида формы редактирования

Форма редактирования

Форма редактирования/добавления элемента инфоблока может быть изменена и настроена под потребности разработчика сайта. Измененная форма отображается действует как при добавлении/редактировании элемента в административной части, так и при добавлении/редактировании элемента в публичной части.

Форма вызывается нажатием на кнопку Настроить контекстной панели формы редактирования/добавления элемента.

Настройка формы редактирования

Поле | Описание
Поля формы
Доступные вкладки | Отображается список всех вкладок формы. При выборе конкретной вкладки в поле Доступные поля отображается список полей этой вкладки, доступные для добавления в поле Выбранные поля.
Вкладки | Отображается список активных, то есть доступных для редактирования, вкладок формы. При выборе конкретной вкладки в поле Выбранные поля отображается список полей этой вкладки, доступные для переноса в Доступные поля.
Доступные поля | Для отмеченной вкладки в списке Доступные вкладки отображаются поля, доступные для переноса в поле Выбранные поля. Список доступных полей может быть пуст, если все поля являются выбранными для текущей вкладки.
Выбранные поля | Отображается список активных, то есть доступных для редактирования, полей той вкладки, которая отмечена в списке Вкладки. Список выбранных полей может быть пуст, если ни одно из полей не выбрано из списка доступных.
Кнопки управления
Выше | Для всех полей. Перемещение элемента вверх по списку.
Ниже | Для всех полей. Перемещение элемента вниз по списку.
Изменить | Для всех полей. Изменение названия элемента.
Добавить Добавление элемента:
  • для вкладок - добавление вкладки;
  • для полей - добавление раздела вкладки.
Удалить Удаление вкладок.

Примечание: удаление созданных пользователем разделов вкладок производится простым переносом раздела из Выбранные поля в Доступные поля.

Общие настройки
Установить данные настройки по умолчанию для всех пользователей | При отмеченной опции выбранные настройки будут установлены как настройки по умолчанию для всех пользователей системы.

Работа с полями и вкладками

Для добавления нужного поля (вкладки) в форму редактирования элемента необходимо перенести его из поля Доступные поля (Доступные вкладки) в Выбранные поля (Вкладки).

Для удаления ненужного поля (вкладки) с формы редактирования элемента достаточно перенести его из поля Выбранные поля (Вкладки) в Доступные поля (Доступные вкладки).

Используя этот механизм поля можно перемещать с вкладки на вкладку.

Смотрите также

  • Настройка форм элементов и разделов под себя


Страница генерации торговых предложений

Форма генерации торговых предложений вызывается нажатием на кнопку Генерировать торговые предложения формы создания/редактирования элемента, являющегося товаром с торговыми предложениями.

Генератор SKU

Поле | Описание
Название | Название торгового предложения. Может автоматически генерироваться по правилам, заданных с помощью кнопок Свойства SKU и Свойства родителя.
Вес товара | Вес единицы сгенерированного товара в граммах.
Длина (мм.) | Длина сгенерированного товара, заданная в мм.
Ширина (мм.) | Ширина сгенерированного товара, заданная в мм.
Высота (мм.) | Высота сгенерированного товара, заданная в мм.
Ставка НДС | Указывается ставка НДС, которой облагаются сгенерированные товары.
НДС включен в цену | При отмеченной опции НДС будет включен в цену всех сгенерированных товаров.
Цена
Поле | Описание
Тип цены | Перечень доступных типов цен товара.
Цена товара | Стоимость единицы товара для данного типа цены, при условии приобретения указанного товара.
Валюта | Наименование валюты, в которой указана стоимость товара для данного типа цены.

Кнопка Еще позволяет добавить новую строку для указания стоимости товаров.
Выбор свойств (доступны только свойства типа "Список" и "Справочник")
кнопка Добавить свойство | Выбор необходимого свойства из списка доступных.
кнопка Загрузить все | Загрузка всех имеющихся в инфоблоке свойств типа "Список" и "Справочник".
<выбранные свойства> | Для каждого выбранного свойства отображается блок с названием и значениями свойства. Для удаления свойства из списка выбранных служит "крестик", расположенный в заголовке блока. Выбор необходимых значений свойства осуществляется путем установки флагов в соответствующих строках (установка или снятие флагов сразу для всех значений свойств осуществляется с помощью самой верхней опции).
Изображения (в качестве полей доступны все свойства инфоблока типа "Файл", анонсовые и детальные картинки товара)
кнопка Прикрепить изображения Переход к заполнению выбранных полей для выбранных свойств генерируемых товаров. Картинки можно задавать для каждого значения свойства отдельно или для всех значений сразу.

Важно! Нажатие этой кнопки блокирует дальнейший выбор полей, в которые можно загрузить картинки.
кнопка <название_поля> | Задается поле, в которое будет загружаться изображение.
кнопка "+" | Добавление полей, в которых можно выбрать картинки.

Смотрите также

  • Генерация предложений


Список свойств инфоблока

Форма служит для управления свойствами выбранного информационного блока. Настройка свойств также может выполняться при непосредственном редактировании инфоблока на закладке Свойства.

Форма поиска

Форма позволяет выполнить поиск информационных блоков, соответствующих указанным параметрам.

Поле | Описание
Название* | Название свойства.
Символьный код | Мнемонический код свойства, состоящий из латинских символов и цифр.
Активность | Признак активности отбираемого свойства (используется ли свойство в инфоблоке).
Поиск | Отбор свойств по признаку участия их значений в поиске по сайту.
Показывать в фильтре | Отбор свойств по следующему признаку: отображается ли на странице списка элементов поле для фильтрации по этому свойству.
Обязательное | Признак обязательности заполнения данного свойства при создании/редактировании элемента инфоблока.
Множественное | Признак множественности свойства, т.е. наличия одновременно нескольких значений данного свойства.
Внешний код | Поиск свойства по внешнему коду.
Тип | Поиск свойства по его типу.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать свойства по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех свойств нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить свойство | Переход к форме создания нового свойства элементов выбранного инфоблока.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список свойств

Поле | Описание
Колонка флажков | Выбор свойств, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия:
  • Изменить - переход к редактированию свойства;
  • Удалить - удаление свойства.
ID | Идентификатор свойства.
Название | Название свойства элементов инфоблока.
Символьный код | Мнемонический код свойства, состоящий из латинских символов и цифр.
Тип | Тип свойства.
Сортировка | Задается "вес" свойства, определяющий его положение в общем списке свойств.
Активность | Признак активности свойства.
Обязательное | Признак обязательности заполнения данного свойства при создании/редактировании элемента инфоблока.
Множественное | Признак множественности свойства, т.е. наличия одновременно нескольких значений данного свойства.
Поиск | Участвуют ли значения свойства в поиске.
Показывать в фильтре | Признак отображения на странице списка элементов поля для фильтрации по этому свойству.
Внешний код | Внешний код своства.
Имеет описание | Выводится ли поле для описания значения свойства.
Подсказка | Текст, который будет выводится в тултипе рядом с полем в форме создания элемента.


Создание и редактирование свойств инфоблока

Типы свойств

Форма позволяет выполнить детальную настройку свойств инфоблока. Поля некоторых формы могут отличаться для разных свойств. Для открытия формы нужно:

  1. Перейдите на страницу Контент > Инфоблоки > Типы инфоблоков > [Название_типа_инфоблоков].
  2. В колонке команд выбрать команду Свойства для нужного инфоблока. Откроется страница списка свойств для элементов инфоблока.
  3. На контекстной панели нажмите кнопку Добавить свойство или в меню действий конкретного свойства выберите команду Изменить.

либо:

  1. Перейдите на страницу Контент > Инфоблоки > Типы инфоблоков > [Название_типа_инфоблоков].
  2. В колонке команд выбрать команду Изменить.
  3. Перейдите на закладку Свойства.
  4. В строке с нужным свойством элемента нажмите на кнопку [...]. Откроется форма настройки свойств информационного блока.

Общие поля

Поле | Описание
ID | Идентификатор свойства.
Свойство активно | Признак активности свойства (если свойство активно, оно может быть выбрано для показа в публичной части сайта).
Порядок сортировки | Задается "вес" свойства, определяющий его положение в общем списке свойств.
Название | Название свойства элементов инфоблока. (255 знаков)
Символьный код | Мнемонический код свойства, состоящий из латинских символов и цифр.
Внешний код | Символьный код, используемый для связи инфоблока с внешним источником данных. Поле отображается при включенной опции Показывать код загрузки из внешних источников в настройках модуля Информационные блоки.
Множественное | Признак множественности свойства, т.е. наличия одновременно нескольких значений данного свойства. Например, свойство элементов Цвет панели инфоблока Мобильные телефоны может одновременно иметь следующие значения: синий, красный, черный и т.д. Примечание: начиная с версии 12.5.7 модуля Информационные блоки, свойство типа Привязка к товарам (SKU) не может быть множественным. Тип ранее созданных множественных свойств должен быть сменен на Привязка к элементами с автозаполнением.
Обязательное | Признак обязательности заполнения данного свойства при создании/редактировании элемента инфоблока.
Показывать на странице редактирования элемента | При отмеченной опции свойство будет отображаться в форме редактирования элемента.
Показывать в умном фильтре | При отмеченной опции свойство будет отображаться в умном фильтре. Недоступно для типов свойств Файл и Видео.
Вид в умном фильтре | Задается один из видов отображения (с учетом типа свойства) значений свойства в умном фильтре. Недоступно для типов свойств Файл и Видео
Показать развёрнутым | Признак отображения свойства в развернутом виде в умном фильтре. Недоступно для типов свойств Файл и Видео
Подсказка | Текст, который будет выводится в тултипе рядом с полем в форме создания элемента.

Тип свойства

Строка, Число, Привязка к:
- пользователю, сотруднику,
- файлу (на сервере),
- карте Google Maps, Яндекс.Карте
- теме форума

Поле | Описание
Значения свойств участвуют в поиске | Разрешается или запрещается индексация значений данного свойства для внутреннего поиска.
Выводить на странице списка элементов поле для фильтрации по этому свойству | Определяет возможность вывода в фильтре на странице со списком элементов отдельного поля, с помощью которого будет осуществляться фильтрация элементов по значениям данного свойства. Поле в фильтре будет иметь то же название и тип, что и данное свойство. Например, для свойства Год выпуска типа список данное поле в фильтре будет называться Год выпуска, а доступные значения поля будут представлены в виде списка.
Выводить поле для описания значения | Определяется, будет ли выводиться поле для описания данного свойства в форме создания/редактирования элементов информационного блока.
Количество полей для ввода новых множественных значений | Если данное свойство является множественным, то в этом определяется количество полей для ввода значений свойства (т.е. количество возможных значений свойства).
Размер поля для ввода значения (Строк х Столбцов) | Определяется длина и ширина поля для ввода значения данного свойства в форме создания/редактирования элементов инфоблока. Длина и ширина поля задаются числом столбцов и строк соответственно.
Значение по умолчанию | Значение данного свойства, присваиваемое всем вновь создаваемым элементам информационного блока по умолчанию.

Список

Поле | Описание
Внешний вид Форма представления списка доступных значений свойства:
  • список - значение свойства выбирается из списка;
  • флажки - значение свойства указывается с помощью флажка, устанавливаемого в поле рядом с нужным значением.
Количество строк (для внешнего вида "список") | Высота поля со списком в строках (используется, если в предыдущем поле выбрано значение список).
Значения свойств участвуют в поиске | Разрешается или запрещается индексация значений данного свойства для внутреннего поиска.
Выводить на странице списка элементов поле для фильтрации по этому свойству Определяет возможность вывода в фильтре на странице со списком элементов отдельного поля, с помощью которого будет осуществляться фильтрация элементов по значениям данного свойства.

Поле в фильтре будет иметь то же название и тип, что и данное свойство. Например, для свойства Год выпуска типа список данное поле в фильтре будет называться Год выпуска, а доступные значения поля будут представлены в виде списка.
Значения списка

Данное поле служит для создания списка доступных значений свойства.

ID | XML_ID | Значение | Сорт. | Умолч.
[1] | [2] | [3] | [4] | [5]
Поле | Описание
[1] ID | Идентификатор значения свойства в списке (не задается).
[2] XML_ID | Идентификатор значения свойства в списке. Задается символами латинского алфавита и цифрами (не должен начинаться с цифры).
[3] Значение (нет значения по умолчанию) | Поле для создания возможного значения свойства.
[4] Сорт. | Относительный "вес" возможного значения, определяющий положение значения в списке.
[5] Умолч. | Признак того, что для новых элементов инфоблока по умолчанию настраиваемое свойство будет принимать данное значение.

Файл

Поле | Описание
Значения свойств участвуют в поиске | Разрешается или запрещается индексация значений данного свойства для внутреннего поиска.
Выводить поле для описания значения | Определяется, будет ли выводиться поле для описания данного свойства в форме создания/редактирования элементов информационного блока.
Размер поля для ввода (столбцов) | Длина поля для ввода значения свойства. Задается количеством столбцов.
Типы загружаемых файлов (расширения через запятую) Список расширений (через запятую) доступных для загрузки файлов.
Типы файлов можно указать вручную через запятую или выбрать из списка. Доступно несколько вариантов подборки типов:
  • (любые) - к загрузке доступны все нижеперечисленные типы файлов;
  • Изображения - jpg, gif, bmp, png, jpeg, webp;

    Поддержка формата изображений webp доступна с версии 20.5.0 модуля Информационные блоки.

  • Звуки - mp3, wav, midi, snd, au, wma;
  • Видео - mpg, avi, wmv, mpeg, mpe, flv;
  • Документы - doc, txt, rtf.
Тип свойства "Привязка к разделам"
Выводить на странице списка элементов поле для фильтрации по этому свойству Определяет возможность вывода в фильтре на странице со списком элементов отдельного поля, с помощью которого будет осуществляться фильтрация элементов по значениям данного свойства.

Поле в фильтре будет иметь то же название и тип, что и данное свойство. Например, для свойства Год выпуска типа список данное поле в фильтре будет называться Год выпуска, а доступные значения поля будут представлены в виде списка.
Количество полей для ввода новых множественных значений | Если данное свойство является множественным, то в этом определяется количество полей для ввода значений свойства (т.е. количество возможных значений свойства).
Информационный блок | Информационный блок, к разделам которого может осуществляться привязка элементов данного инфоблока.

Привязка к элементам,
- в виде списка,
- по XML_ID,
- с автозаполнением

Поле | Описание
Тип свойства "Привязка к элементам"
Выводить на странице списка элементов поле для фильтрации по этому свойству Определяет возможность вывода в фильтре на странице со списком элементов отдельного поля, с помощью которого будет осуществляться фильтрация элементов по значениям данного свойства.

Поле в фильтре будет иметь то же название и тип, что и данное свойство. Например, для свойства Год выпуска типа список данное поле в фильтре будет называться Год выпуска, а доступные значения поля будут представлены в виде списка.
Количество полей для ввода новых множественных значений | Указывается сколько полей для множественного свойтсва должно быть в форме добавления элемента. Активно только при установленном флажке значения Множественное.
Информационный блок | Информационный блок, к элементам которого может осуществляться привязка элементов данного инфоблока.
Тип свойства "Привязка к элементам в виде списка"
Выводить на странице списка элементов поле для фильтрации по этому свойству Определяет возможность вывода в фильтре на странице со списком элементов отдельного поля, с помощью которого будет осуществляться фильтрация элементов по значениям данного свойства.

Поле в фильтре будет иметь то же название и тип, что и данное свойство. Например, для свойства Год выпуска типа список данное поле в фильтре будет называться Год выпуска, а доступные значения поля будут представлены в виде списка.
Информационный блок | Информационный блок, к элементам которого может осуществляться привязка элементов данного инфоблока.
Высота списка | Если данное свойство является множественным, то в этом определяется количество строк, отображаемых в окне множественного значения. Если число элементов значения превысит число, выбранное в этом поле, то весь список можно будет просмотреть с помощью полосы прокрутки.
Ограничить по ширине | задание в пикслах ширины окна списка. При значении равном 0 поле ограничивается длиной самого большого названия элемента.
Группировать по разделам | Если инфоблок, выбранный в поле "Информационный блок" обладает древовидной структурой, то вывод элементов в списке будет осуществляться по разделам с выделением названия раздела жирным шрифтом.
Отображать в виде списка множественного выбора | При установленной опции список привязанных элементов доступен для множественного выбора элементов в одном поле, при снятой - каждый элемент выбирается в виде отдельной строки.
Тип свойства "Привязка к элементам по XML_ID"
Значения свойств участвуют в поиске | Разрешается или запрещается индексация значений данного свойства для внутреннего поиска.
Выводить на странице списка элементов поле для фильтрации по этому свойству Определяет возможность вывода в фильтре на странице со списком элементов отдельного поля, с помощью которого будет осуществляться фильтрация элементов по значениям данного свойства.

Поле в фильтре будет иметь то же название и тип, что и данное свойство. Например, для свойства Год выпуска типа список данное поле в фильтре будет называться Год выпуска, а доступные значения поля будут представлены в виде списка.
Количество полей для ввода новых множественных значений | Если данное свойство является множественным, то в этом определяется количество полей для ввода значений свойства (т.е. количество возможных значений свойства).
Значение по умолчанию | Значение данного свойства, присваиваемое всем вновь создаваемым элементам информационного блока по умолчанию. С помощью кнопки [...] можно выбрать элементы из списка.
Тип свойства "Привязка к элементам с автозаполнением"
Выводить на странице списка элементов поле для фильтрации по этому свойству | Определяет возможность вывода в фильтре на странице со списком элементов отдельного поля, с помощью которого будет осуществляться фильтрация элементов по значениям данного свойства. Фильтрация осуществляется как по массиву значений, так и по одиночному значению.
Информационный блок | Выбирается тип информационного блока и инфоблок из которого получаются значения для свойства. Если инфоблок не выбран, то кнопка добавления элемента (раздела) выводиться не будет при указании значения свойства.
Интерфейс показа В выпадающем списке выберите один из вариантов интерфейса показа элементов:
  • Строка с автозаполнением - данные для автозаполнения отображаются в виде всплывающего окна с подсказками.
  • Строка с автозаполнением и выбор из списка - данные для автозаполнения отображаются в виде всплывающего окна с подсказками либо выбираются из окна списка.
    Данный вариант показа недоступен для типа "Привязка к разделам с автозаполнением".
  • Строка с автозаполнением и выбор из окна поиска - данные для автозаполнения отображаются в виде всплывающего окна с подсказками либо выбираются из окна поиска.
Показывать кнопку добавления элементов (разделов) Под полем строки с автозаполнением появится кнопка Добавить элемент (Добавить раздел). С помощью этой кнопки можно быстро добавить элемент (раздел) в инфоблок, выбранный в поле Информационный блок.

Данное поле не отображается для типа "Привязка к товарам (SKU)".
Брать название кнопки добавления из настроек связанного инфоблока | Название кнопки Добавить элемент (Добавить раздел) смениться на название из настроек выбранного инфоблока.
Максимальная ширина поля ввода в пикселах (0 - не ограничивать) | Можно задать ограничение ширины поля ввода.
Минимальная высота поля ввода в пикселах, если свойство множественное | Можно задать ограничение высоты поля ввода, при множественном свойстве.
Максимальная высота поля ввода в пикселах, если свойство множественное | Можно задать ограничение высоты поля ввода, при множественном свойстве. Применяется, если надо ограничить высоту формы при большом числе свойств.
Заменяемые при показе символы | Возможны проблемы с отображением названий элементов (разделов), содержащих в названии ряд символов. Например, при использовании запятой. Проблема проявляется в размножении таких названий в списке. Избежать этой ситуации можно, указав в настройках свойства перечень таких символов и выбрав символ автозамены в поле ниже. Сами названия элементов (разделов) от такой замены не меняются.
Символ, который заменит при показе запрещенные символы | В выпадающем списке или в пустом поле рядом со списком укажите символ, который заменит искажающие символы в названиях.

HTML/текст

Поле | Описание
Значения свойств участвуют в поиске | Разрешается или запрещается индексация значений данного свойства для внутреннего поиска.
Выводить на странице списка элементов поле для фильтрации по этому свойству | Определяет возможность вывода в фильтре на странице со списком элементов отдельного поля, с помощью которого будет осуществляться фильтрация элементов по значениям данного свойства. Поле в фильтре будет иметь то же название и тип, что и данное свойство. Например, для свойства Год выпуска типа список данное поле в фильтре будет называться Год выпуска, а доступные значения поля будут представлены в виде списка.
Выводить поле для описания значения | Определяется, будет ли выводиться поле для описания данного свойства в форме создания/редактирования элементов информационного блока.
Количество полей для ввода новых множественных значений | Если данное свойство является множественным, то в этом определяется количество полей для ввода значений свойства (т.е. количество возможных значений свойства).
Значение по умолчанию | Значение данного свойства, присваиваемое всем вновь создаваемым элементам информационного блока по умолчанию. Выводится в форме редактирования только при создании элемента.
Высота окна редактора | Высота окна визуального редактора в пикселях.

Видео

Поле | Описание
Значения свойств участвуют в поиске | Разрешается или запрещается индексация значений данного свойства для внутреннего поиска.
Выводить поле для описания значения | Определяется, будет ли выводиться поле для описания данного свойства в форме создания/редактирования элементов информационного блока.
Количество полей для ввода новых множественных значений | Если данное свойство является множественным, то в этом определяется количество полей для ввода значений свойства (т.е. количество возможных значений свойства).
Настраиваемые параметры плеера
Общие настройки
Размер буфера в секундах | Указывается сколько секунд воспроизведения ролика сохранять в буфере обмена, прежде чем начать проигрывать.
Расположение панели управления Указывается расположение панели управления плеера:
  • Внизу - снизу окна просмотра;
  • Не показывать - панель управления будет скрыта.
Автоматически начать проигрывать | При отмеченной опции проигрывание медиафайла(ов) будет начато сразу после загрузки страницы.
Уровень громкости в процентах от максимального | Указывается уровень громкости звука в процентах от максимального заданного в системе.
Настройки Flash-плеера
Скин | Выбирается скин Flash плеера.
Дополнительные переменные Flashvars | Указываются дополнительные переменные для плеера.
Режим окна (WMode) Указывается режим окна Flash плеера:
  • Обычный - медиафайл будет проигрываться на странице в собственном прямоугольном окне. Этот вариант дает наибольший выигрыш в скорости воспроизведения анимации;
  • Непрозрачный - медиафайл будет помещен на задний план страницы.
  • Прозрачный - фон страницы будет "проглядывать" через все прозрачные места медиафайла при проигрывании. Этот вариант может замедлить скорость воспроизведения анимации.
Настройки WMV-плеера
Цвет фона панели управления | Указывается код цвета для фона панели управления плеера.
Цвет элементов управления | Указывается код цвета для элементов управления плеера.
Цвет элементов управления при наведении указателя мыши | Указывается код цвета для элементов управления плеера при наведении указателя мыши.
Цвет экрана | Указывается код цвета для экрана плеера.
Дополнительные переменные Silverlight | Указываются дополнительные переменные для плеера.
Режим окна Указывается режим окна WMW плеера:
  • Обычный - окно плеера будет убрано за HTML элементы страницы;
  • Прозрачный - окно плеера будет отображаться непосредственно в клиентской области обозревателя или внутри специально созданного окна.

Счетчик

Поле | Описание
Выводить на странице списка элементов поле для фильтрации по этому свойству | Определяет возможность вывода в фильтре на странице со списком элементов отдельного поля, с помощью которого будет осуществляться фильтрация элементов по значениям данного свойства. Поле в фильтре будет иметь то же название и тип, что и данное свойство. Например, для свойства Год выпуска типа список данное поле в фильтре будет называться Год выпуска, а доступные значения поля будут представлены в виде списка.
Количество полей для ввода новых множественных значений | Если данное свойство является множественным, то в этом определяется количество полей для ввода значений свойства (т.е. количество возможных значений свойства).
Разрешается изменять значения | При отмеченной опции пользователю будет разрешено изменять значения счетчика.
Текущее значение счетчика | Задается начальное значение счетчика, от которого будет происходить отсчет.

Дата, Дата/Время

Поле | Описание
Значения свойств участвуют в поиске | Разрешается или запрещается индексация значений данного свойства для внутреннего поиска.
Выводить на странице списка элементов поле для фильтрации по этому свойству | Определяет возможность вывода в фильтре на странице со списком элементов отдельного поля, с помощью которого будет осуществляться фильтрация элементов по значениям данного свойства. Поле в фильтре будет иметь то же название и тип, что и данное свойство. Например, для свойства Год выпуска типа список данное поле в фильтре будет называться Год выпуска, а доступные значения поля будут представлены в виде списка.
Выводить поле для описания значения | Определяется, будет ли выводиться поле для описания данного свойства в форме создания/редактирования элементов информационного блока.
Количество полей для ввода новых множественных значений | Если данное свойство является множественным, то в этом определяется количество полей для ввода значений свойства (т.е. количество возможных значений свойства).
Подсказка в умном фильтре для посетителей | Указывается текст подсказки, отображаемой посетителям в умном фильтре.
Значение по умолчанию | Значение данного свойства, присваиваемое всем вновь создаваемым элементам информационного блока по умолчанию. С помощью кнопки Календарь можно выбрать дату из календаря.

Справочник

Тип свойства "Справочник" (доступен только при наличии установленного модуля Highload-блоки).

Поле | Описание
Значения свойства участвуют в поиске | Разрешается или запрещается индексация значений данного свойства для внутреннего поиска.
Выводить на странице списка элементов поле для фильтрации по этому свойству | Определяет возможность вывода в фильтре на странице со списком элементов отдельного поля, с помощью которого будет осуществляться фильтрация элементов по значениям данного свойства.
Выводить поле для описания значения | Определяется, будет ли выводиться поле для описания данного свойства в форме создания/редактирования элементов информационного блока.
Дополнительные настройки
Выберите справочник | Выбирается Highload-блок, который будет использоваться в качестве справочника. Если указывается значение Создать новый справочник, то становятся доступным поле Название справочника.
Название справочника | Название нового справочника (Highload-блока). Если задан кириллицей, то будет выполнена его транслитерация.
Записи справочника Создание и редактирование записей выполняется с помощью следующих полей:
Поле | Описание
Название | Название записи справочника.
Сортировка | "Вес" записи справочника, определяющий положение записи в списке.
Внешний код | Внешний код записи справочника (служит для создания связей и выгрузки в 1С).
Изображение | Картинка записи справочника. Кнопка Обзор... служит для выбора файла.
Ссылка | Ссылка на некоторую страницу. Используется при отображении записи в публичном разделе.
По умолчанию | Признак того, что именно текущая запись будет отображаться по умолчанию в списке записей в публичном разделе. По умолчанию может быть только одна запись.
Описание | Описание записи. Например, при использовании компонента брендов будет отображаться в публичном разделе при отсутствии изображения у записи.
Полное описание | Полное описание записи. Например, при использовании компонента брендов выводится в качестве всплывающей подсказки в публичном разделе.

Для удаления записи следует нажать на "крестик", расположенный в соответствующей строке записи.

Деньги

Тип свойства "Деньги" (доступен только при наличии установленного модуля Валюты).

Поле | Описание
Значения свойства участвуют в поиске | Разрешается или запрещается индексация значений данного свойства для внутреннего поиска.
Выводить на странице списка элементов поле для фильтрации по этому свойству | Определяет возможность вывода в фильтре на странице со списком элементов отдельного поля, с помощью которого будет осуществляться фильтрация элементов по значениям данного свойства.
Выводить поле для описания значения | Определяется, будет ли выводиться поле для описания данного свойства в форме создания/редактирования элементов информационного блока.
Количество полей для ввода новых множественных значений | Если данное свойство является множественным, то в этом определяется количество полей для ввода значений свойства (т.е. количество возможных значений свойства).
Подсказка в умном фильтре для посетителей | Указывается текст подсказки, отображаемой посетителям в умном фильтре.
Размер поля для ввода значения (Строк х Столбцов) | Определяется длина и ширина поля для ввода значения данного свойства в форме создания/редактирования элементов инфоблока. Длина и ширина поля задаются числом столбцов и строк соответственно.
Значение по умолчанию | Значение данного свойства, присваиваемое всем вновь создаваемым элементам информационного блока по умолчанию (указывается сумма и валюта).


Шаблоны бизнес-процессов

На странице Шаблоны бизнес-процессов представлен список шаблонов бизнес-процессов конкретного инфоблока. Для этого в настройках инфоблока должно быть указано, что он участвует в бизнес-процессах.

Переход на данную страницу осуществляется:

  • со страницы со списком элементов инфоблока с помощью кнопки контекстной панели Шаблоны бизнес-процессов;
  • со страницы со списком инфоблоков с помощью пункта Бизнес-процессы меню действий инфоблока;
  • со страницы редактирования информационного блока с помощью соответствующей ссылки на закладке Шаблоны бизнес-процессов.

Форма поиска

Форма служит для поиска шаблонов бизнес-процессов в соответствии с заданными условиями.

Поле | Описание
Название | Поиск шаблона бизнес-процесса по его названию.
Автозапуск | Поиск шаблонов бизнес-процессов по типу их запуска.

Чтобы отобрать шаблоны бизнес-процессов по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех шаблонов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Назад | Переход на страницу со списком элементов инфоблока.
Создать шаблон | Создание нового шаблона бизнес-процесса. В открывшемся меню выберите, какой тип шаблона следует создать.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирт данных из отображаемой таблицы в MS Excel.

Список шаблонов бизнес-процессов

Поле | Описание
Колонка флажков | Выбор шаблонов бизнес-процессов, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия:
  • Изменить - переход к редактированию шаблона бизнес-процесса;
  • Удалить - удаление шаблона бизнес-процесса.
ID | Идентификатор шаблона бизнес-процесса.
Название | Произвольное название шаблона бизнес-процесса.
Изменен | Дата и время последнего изменения шаблона бизнес-процесса.
Изменил | Идентификатор, логин, имя и фамилия пользователя, выполнившего последние изменения.
Автозапуск | Параметры запуска бизнес-процесса в зависимости от действий с элементами инфоблока.

Дополнительно о бизнес-процессах

  • Бизнес-процессы для администратора Б24 [image];
  • Бизнес-процессы для администратора БУС [image].


Редактирование шаблона бизнес-процесса

Форма с настройками параметров шаблона открывается автоматически при создании нового шаблона бизнес-процесса.

Контекстная панель

Кнопка | Описание
Параметры шаблона | Переход к форме настройки параметров шаблона бизнес-процесса.
Глобальные переменные | Переход к списку всех, доступных для этого шаблона, глобальных переменных.
Глобальные константы | Переход к списку всех, доступных для этого шаблона, глобальных констант.
Список шаблонов | Переход на страницу со списком шаблонов бизнес-процессов.
Создать шаблон | Создание нового шаблона бизнес-процесса. В открывшемся меню выберите, какой тип шаблона следует создать.
Экспорт | Экспорт текущего шаблона бизнес-процесса.
Импорт | Импорт шаблона бизнес-процесса взамен текущего.

Параметры шаблона

При редактировании существующего шаблона переход к данной форме осуществляется с помощью кнопки Параметры шаблона, расположенной на контекстной панели.

Поле | Описание
Вкладка "Основное"
Название | Указывается название шаблона бизнес-процесса.
Описание | Произвольное описание шаблона бизнес-процесса.
Автоматически запускать | Задается способ запуска бизнес-процесса: при добавлении элемента и/или при его редактировании. Если обе опции не отмечены, то бизнес-процесс запускается вручную.
Вкладка "Параметры"
На вкладке задаются параметры запуска бизнес-процесса с помощью ссылки Добавить параметр. Для каждого параметра заполняются следующие поля:
Поле | Описание
Идентификатор | Символьный идентификатор параметра.
Название | Название параметра запуска бизнес-процесса.
Описание | Произвольное описание параметра запуска.
Тип | Тип параметра.
Обязательный | Признак обязательности указания значения параметра для выполнения запуска бизнес-процесса.
Множественный | При отмеченной опции может быть задано несколько значений параметра.
Значение по умолчанию | Значение, подставляемое в параметр, по умолчанию.

Все созданные параметры запуска представлены в виде таблицы. Для изменения существующего параметра служит ссылка Изменить, а для удаления - Удалить.
Вкладка "Переменные"
На вкладке задаются переменные бизнес-процесса с помощью ссылки Добавить переменную. Для каждой переменной заполняются следующие поля:
Поле | Описание
Идентификатор | Символьный идентификатор переменной.
Название | Название переменной бизнес-процесса.
Описание | Произвольное описание переменной.
Тип | Тип переменной.
Обязательный | Признак обязательности указания значения переменной для выполнения запуска бизнес-процесса.
Множественный | При отмеченной опции может быть задано несколько значений переменной.
Значение по умолчанию | Значение, подставляемое в переменную, по умолчанию.

Все созданные переменные бизнес-процесса представлены в виде таблицы. Для изменения существующей переменной служит ссылка Изменить, а для удаления - Удалить.
Вкладка "Константы"
На вкладке задаются константы бизнес-процесса с помощью ссылки Добавить константу. Для каждой константы заполняются следующие поля:
Поле | Описание
Идентификатор | Символьный идентификатор константы.
Название | Название константы бизнес-процесса.
Описание | Произвольное описание константы.
Тип | Тип константы.
Обязательный | Признак обязательности указания значения константы для выполнения запуска бизнес-процесса.
Множественный | При отмеченной опции может быть задано несколько значений константы.
Значение константы | Значение константы по умолчанию.

Все созданные константы представлены в виде таблицы. Для изменения существующей константы служит ссылка Изменить, а для удаления - Удалить.
Вкладка "Доступ"
На вкладке задаются права доступа к бизнес-процессу.

Подробнее про шаблоны бизнес-процессов смотрите в соответствующей главе [image] учебного курса.

Статусы бизнес-процесса

Если при создании шаблона бизнес-процесса был указан тип Бизнес-процесс со статусами, то сначала выполняется добавление статусов, а потом их детальная настройка с помощью визуального конструктора (см. ниже).

Создание статусов выполняется с помощью кнопки Добавить статус, по нажатии которой открывается форма со следующими полями:

Поле | Описание
Заголовок | Указывается заголовок статуса документа.
Право на операцию "Чтение" имеют | С помощью кнопки [...] указываются пользователи, которые право на чтение документа в данном статусе.
Право на операцию "Запись" имеют | С помощью кнопки [...] указываются пользователи, которые право на изменение документа в данном статусе.

В каждый статус можно добавить:

  • команду;
  • выполнение через заданное время;
  • обработчик входа в данный статус;
  • обработчик выхода из данного статуса.

Визуальный конструктор

Визуальный конструктор используется как для детальной настройки каждого статуса бизнес-процесса со статусами, так и последовательного бизнес-процесса.

Визуальный конструктор состоит из следующих областей:

  • области построения блок-схемы бизнес-процесса;
  • панели конструктора, в которой располагаются сгруппированные по секциям блоки.

Смотрите также

  • Настройка инфоблоков на работу с бизнес-процессами [image];
  • Из чего состоит визуальный конструктор [image];
  • Глобальные переменные и константы [image];
  • Каталог примеров [image].


Фасетные индексы

Страница Фасетные индексы инфоблоков (Контент > Инфоблоки > Фасетные индексы) служит для создания фасетных индексов для инфоблоков, являющимися торговыми каталогами.

Важно! Создание фасетных индексов доступно только для тех каталогов, в которых есть хотя бы одно отображаемое свойство в умном фильтре.

Контекстная панель

Контекстная панель отображается только при наличии торговых каталогов, для которых необходимо создать фасетные индексы.

Кнопка | Описание
Создать все | Переход к форме создания фасетных индексов. Кнопка не отображается, если для всех торговых каталогов фасетные индексы созданы и их пересоздание не требуется.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список инфоблоков

Поле | Описание
Действия Колонка доступна только для тех каталогов, для которых необходимо создать фасетные индексы. Доступные действия:
  • Создать - переход к форме создания фасетных индексов.
ID | Идентификатор торгового каталога.
Название | Название торгового каталога.
Состояние | Если для каталога фасетный индекс создан, то отображается Работает. В противном случае - Создать.

Смотрите также

  • Фасетный поиск: улучшаем работу каталога товаров


Создание фасетных индексов

Данная форма служит для создания фасетных индексов одного или всех торговых каталогов.

Контекстная панель

Кнопка | Описание
Вернуться в список информационных блоков | Переход на страницу со списком каталогов, для которых нужно создать (или уже создан) фасетный индекс.

Поля формы

Поле | Описание
Информационный блок | Указывается торговый каталог (либо выбираются все), для которого следует создать фасетный индекс.
Шаг | Интервал одного шага создания индекса в секундах.

Кнопки управления

Кнопка | Описание
Начать | Запуск процесса создания фасетного индекса.
Остановить | Остановка процесса создания индекса.
Продолжить | Продолжение процесса создания фасетного индекса.


Переход к инфоблоку/элементу

Форма Перейти к инфоблоку / элементу (Контент > Инфоблоки > Инструменты > Перейти к инфоблоку / элементу) позволяет, зная идентификатор инфоблока/элемента, быстро перейти к его форме редактирования.

Форма поиска

Поле | Описание
Сущность | Указывается, какой вид сущности (инфоблок или элемент) необходимо найти.
ID сущности | Задается идентификатор того вида сущности, которую необходимо найти.

Если сущность с введенным идентификатором существует в системе и пользователь обладает необходимыми правами к этой сущности, то по кнопке Найти ему будет открыта страница искомой сущности (для инфоблока - страница со списком его разделов и элементов, для элемента - его форма редактирования). Если хотя бы одно из условий не будет выполнено, то будет выведено сообщение о том, что сущность не найдена.


Отправить отзыв по этому разделу

Экспорт инфоблока

  • Экспорт в формате CSV
  • Экспорт в формате XML


Экспорт в формате CSV

Форма Выгрузка информационного блока (Контент > Инфоблоки > Экспорт > CSV) предназначена для экспорта данных из инфоблока в CSV файл.

Шаг 1. Инфоблок

Поле | Описание
Информационный блок для экспорта | Выберите сначала тип информационного блока, а затем сам блок, данные из которого будут выгружены в CSV файл.

Для перехода к следующему шагу нажмите кнопку Далее.

Шаг 2. Параметры экспорта

Задание параметров выгрузки данных в CSV файл.

Поле | Описание
Задайте свойства формата файла
Разделитель полей | Укажите символы, используемые для разделения полей данных.
Первая строка содержит имена полей | Установите флаг в поле, если первая строка файла должна содержать имена выгружаемых полей.
Задайте соответствие полей в файле полям в базе
Поле | Описание
Выгружать | Для того чтобы поле могло быть выгружено в CSV файл, установите этот флаг.
Название поля | Названия выгружаемых полей. Важно! Обязательно должно быть выбрано хотя бы одно из полей Внешний код (B_IBLOCK_ELEMENT.XML_ID) или Название (B_IBLOCK_ELEMENT.NAME). Эти поля используются для сопоставления элементов в файле элементам в базе данных.
Порядок | Порядок следования полей в выгружаемом файле.
Сохранить файл данных как ...
Имя файла данных относительно корня сайта Полное имя файла (путь к файлу указывается относительно корня сайта), в который будут выгружены данные из инфоблока. Например, /upload/export_file.csv.

Важно! Если файл с указанным именем уже существует, то он будет перезаписан.

Чтобы вернуться к предыдущему шагу, воспользуйтесь кнопкой Назад. Для начала выгрузки данных нажмите кнопку Начать выгрузку.

Шаг 3. Результат

Выводится информация о результатах выгрузки данных, а также отображается ссылка для выгрузки CSV файла на локальный компьютер. Чтобы повторить выгрузку данных или экспортировать данные из другого инфоблока, нажмите кнопку Вернуться на первый шаг.

Смотрите также

  • Экпорт инфоблока в формате CSV


Экспорт в формате XML

Форма Экспорт XML (Контент > Инфоблоки > Экспорт > XML) предназначена для экспорта данных [image] из инфоблока в XML файл.

Поле | Описание
Файл для выгрузки | Путь относительно корня сайта к файлу, в который будет выгружен инфоблок. Достаточно задать только имя и инфоблок будет выгружен по указанному пути в файл <имя_файла>.xml.
Информационный блок | Указывается тип и собственно информационный блок, который необходимо экспортировать.
Длительность шага в секундах | Количество секунд выполнения шага экспорта. Если указано "0", то экспорт инфоблока будет осуществлен за один шаг.
Разделы | Выбор разделов по статусам, которые нужно выгружать.
Элементы | Выбор элементов по статусам, которые нужно выгружать.

При нажатии на кнопку Экспортировать начинается экспорт инфоблока и над формой настроек отображается ход процесса выгрузки. Кнопка Остановить экспорт служит для остановки процесса выгрузки информационного блока в случае необходимости. После завершения операции выводится соответствующее сообщение.


Отправить отзыв по этому разделу

Импорт инфоблока

  • Импорт в формате CSV
  • Импорт в формате XML


Импорт в формате CSV

Форма импорта (Контент > Инфоблоки > Импорт > CSV) предназначен для импорта данных в формате CSV в информационный блок.

Шаг 1. Файл данных

Форма предназначена для выбора загружаемого файла и информационного блока, в который будет выполняться загрузка данных.

Поле | Описание
Файл данных | С помощью кнопки Обзор выберите файл с загружаемыми данными.
Информационный блок | Выберите сначала тип информационного блока, а затем и сам блок, в который будет выполняться загрузка данных.

Шаг 2. Формат

Поле | Описание
Формат CSV файла Выберите подходящий формат CSV файла с данными:
  • с разделителями - поля разделяются специальным символом (например, запятой или пробелом);
  • фиксированная ширина полей.
В зависимости от вашего выбора необходимо заполнить соответствующую форму настроек.
С разделителями
Разделитель полей | Укажите символы, используемые для разделения полей данных.
Первая строка содержит имена полей | Установите флаг в это поле, если первая строка файла содержит имена полей данных, .
Фиксированная ширина полей
Метки разделителя | Укажите в столбик номера колонок, разделяющие поля.
Первая строка содержит имена полей | Если первая строка файла содержит имена полей данных, установите флаг в это поле.
Образцы данных
В поле представлен образец загружаемых данных.

Для возврата к предыдущему шагу воспользуйтесь кнопкой Назад. Для продолжения процедуры загрузки данных нажмите кнопку Далее.

Шаг 3. Поля

Форма служит для задания соответствия между полями инфоблока и загружаемого файла.

Поле | Описание
Задайте соответствие полей в файле полям в базе
Установите соответствие между полями загружаемого файла и полями информационного блока, в который выполняется загрузка данных.
Поле | Описание
Поля в файле | Список полей загружаемого файла.
Поля в базе | Список полей инфоблока, в который выполняется загрузка. Важно! Обязательно должно быть выбрано хотя бы одно из полей Уникальный идентификатор (B_IBLOCK_ELEMENT.XML_ID) или Название (B_IBLOCK_ELEMENT.NAME). Эти поля используются для сопоставления записей в файле записям в базе данных. Также проверьте настройки [dw]инфоблока[/dw][di] В данном примере опция Начало активности отмечена как обязательная, поэтому в создаваемом файле csv тоже должна быть колонка с указанием начала активности элемента. [/di] (Контент > Инфоблоки > Типы инфоблоков > [ваш тип инфоблока]/[ваш инфоблок]), в который Вы хотите загрузить файл: если во вкладках Поля или Поля разделов какие-либо поля отмечены как обязательные, то эти колонки должны быть обязательно и в загружаемом csv-файле.

Внимание! Убедитесь, что соответствия полей заданы корректно. В противном случае результат загрузки непредсказуем.

Дополнительные настройки
Путь к картинкам | Для загрузки элементов с иллюстрациями необходимо предварительно выгрузить картинки в какую-либо папку на сайте с помощью любого FTP-клиента. Путь к папке с изображениями нужно указать в этом поле.
Использовать настройки инфоблока для обработки изображений | При отмеченной функции изображения, добавленные при импорте, будут преобразовываться согласно настройкам инфоблока (вкладка Поля).
Путь к файлам для свойств типа файл | Указывается полный путь к файлам свойств (путь будет формироваться от корня сайта как "<путь к файлам свойств>/<имя файла>").
Товары, которых не было в файле Определяется действие выполняемое над элементами инфоблока, которые уже есть в базе, но отсутствуют в загружаемом файле:
  • деактивировать - элементы инфоблока станут неактивными;
  • удалить - элементы будут удалены;
  • не трогать - элементы будут сохранены без изменений.
Неактивные элементы / группы, которые есть в файле Выберите действие, которое будет выполнено над неактивными элементами/группами информационного блока:
  • оставить как есть - элементы/группы не будут изменены;
  • активировать - элементы/группы станут активными (т.е. доступными для показа в публичном разделе).
Время выполнения шага | Длительность одного шага загрузки данных из CSV файла в секундах. При значении "0" загрузка данных выполняется за один шаг.
Образцы данных
В поле представлен образец загружаемых данных.

Для возврата к предыдущему шагу воспользуйтесь кнопкой Назад. Для выполнения загрузки данных нажмите кнопку Загрузить данные.

Шаг 4. Результат

Выводится информация о результатах загрузки данных. Для того чтобы повторить загрузку данных или импортировать данные из другого CSV файла, нажмите кнопку Вернуться на первый шаг.

Смотри также

  • Описание процесса импорта [image] в курсе Контент-менеджер.


Импорт в формате XML

Форма импорта Импорт XML (Контент > Инфоблоки > Импорт > XML) предназначен для загрузки данных в формате XML, хранящихся в отдельном файле, в информационный блок.

Поле | Описание
*Файл для загрузки С помощью кнопки Открыть... выберите файл в формате XML с сервера или загрузите с локального компьютера.

Примечание: В файле xml путь до картинок прописывается не от корня сайта, а от импортируемой папки с изображениями, поэтому папка с изображениями и файл xml должны быть [dw]на одном уровне.[/dw][di] [image] [/di]

*Тип информационного блока Указывается информационный блок, в который будет выполняться загрузка данных.

Примечание: если загружаемый инфоблок уже существует в системе, то независимо от выбранного типа инфоблока и сайтов, он заново загружен не будет (идентификация производится по полю Внешний код в настройках инфоблока). Имеющиеся элементы будут обновлены, новые - добавлены. Над теми элементами, отсутствующими в файле, будет совершено действие, указанное в поле Действия над элементами, которых нет в файле.
Если же такого инфоблока в системе нет, то он будет создан в указанном типе и привязан к выбранным сайтам.
*Сайты, к которым будет привязан информационный блок (если будет создаваться новый) | Выберите сайты, к которым будет привязан инфоблок (если будет создаваться новый инфоблок).
Действия над элементами, которых нет в файле Определяется действие выполняемое над элементами инфоблока, которые уже есть в базе, но отсутствуют в загружаемом файле:
  • N, ничего - элементы будут сохранены без изменений;
  • A, деактивировать - элементы инфоблока станут неактивными;
  • D, удалить - элементы будут удалены.
Длительность шага в секундах (0 - выполнять импорт за один шаг) | Количество секунд выполнения шага импорта. Если указано 0, то импорт инфоблока будет осуществлен за один шаг.
Использовать настройки инфоблока для обработки изображений | При отмеченной опции изображения, добавленные при импорте, будут преобразовываться согласно настройкам инфоблока.

* - поля, обязательные для заполнения.

При нажатии на кнопку Импортировать начинается импорт инфоблока и над формой настроек отображается ход процесса загрузки.

Кнопка Остановить импорт служит для остановки процесса загрузки информационного блока при необходимости.

После того, как импорт завершен, на данной странице выводится соответствующее сообщение.

Ссылка Перейти к списку элементов позволяет перейти на страницу просмотра списка элементов инфоблока, в который производился импорт данных.


Фотогалерея 2.0. Описание модуля

Модуль Фотогалерея 2.0 позволяет работать с фотографиями в удобном режиме: сортировать фото по альбомам (с возможностью создания вложенных альбомов), загружать в них фото, делать подписи к фотографиям, при просмотре оставлять отзывы и голосовать за понравившиеся фото, а также другие возможности, которые в процессе разработки будут расширяться.

Работа модуля Фотогалерея 2.0 основана на модуле Информационные блоки, также использует модуль Блоги и Поиск для реализации специальных возможностей, таких как отзывы и работа облака тегов.

Модуль включает в себя следующие компоненты 2.0:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Фотогалерея 2.0 (комплексный компонент) | photogallery | Позволяет получить полнофункциональную фотогалерею, создавая физически только одну страницу.
Фотогалерея 2.0 (многопользовательская) (комплексный компонент) | photogallery_user | Позволяет получить полнофункциональную многопользовательскую фотогалерею, создавая физически только одну страницу.
Альбом | photogallery.section | Выводит полную информацию об одном альбоме.
Альбом (список) | photogallery.section.list | Выводит список альбомов с информацией о количестве фотографий, вложенных альбомов в каждом и ссылками на просмотр содержимого альбомов.
Панель | photogallery.user | Выводит информацию о галерее пользователя.
Фотогалерея (редактирование) | photogallery.gallery.edit | Выводит форму редактирования параметров фотогалереи пользователя.
Фотогалерея (список) | photogallery.gallery.list | Выводит список фотогалерей пользователя.
Фотогалерея (шаблоны) | photogallery.interface | Подключает библиотеку вспомогательных шаблонов. Компонент ничего не выводит.
Flash-слайдшоу | photogallery.imagerotator | Позволяет показывать фотографии в режиме слайдшоу
Альбом (редактирование обложки) | photogallery.section.edit.icon | Служит для редактирования обложки альбома.
Альбом (редактирование) | photogallery.section.edit | Позволяет отредактировать данные альбома: изменить название, дату создания, ввести описание, ограничить доступ к альбому по паролю.
Фото | photogallery.detail | Выводит детальную информацию по фотографии.
Фото (загрузка) | photogallery.upload | Служит для загрузки фотографии.
Фото (комментарии) | photogallery.detail.comment | Служит для создания комментариев к фотографии.
Фото (редактирование) | photogallery.detail.edit | Служит для редактирования свойств фотографии.
Фото (список) | photogallery.detail.list | Выводит список фотографий.
Список фото (со слайдером) | photogallery.detail.list.ex | Выводит список фотографий во всплывающем окне со слайдером и комментариями.

Смотрите также:

  • Настройка модуля Фотогалерея 2.0
  • Фотогалерея в социальной сети
  • Создание публичного интерфейса фотогалереи
  • Как наполнить фотогалерею
  • Как работать с многопользовательской фотогалереей


Фотогалерея 2.0. Настройки модуля

Форма настроек модуля Фотогалерея 2.0 (Настройки > Настройки продукта > Настройки модулей > Фотогалерея 2.0) предназначена для задания общесистемных параметров модуля.

Закладка "Настройки"

Поле | Описание
Загруженные шрифты | Отображается список загруженных в систему шрифтов, которые можно использовать для нанесения авторского знака. Ссылка Загрузить шрифты служит для выполнения процедуры загрузки шрифтов.
Дополнительные эскизы | В данной секции задаются параметры дополнительных эскизов: указываются произвольные Название, Код, Размер (px) и Качество (%) эскиза. В результате, если в компоненте выбран дополнительный эскиз, то при загрузке картинки будет создана дополнительная копия картинки указанного размера и просмотр списка фотографий альбома будет возможен в нескольких вариантах. Примечание: код эскиза не может начинаться с цифры.


Highload-блоки. Компоненты

Highload-блоки - модуль для работы с произвольными наборами данных в условиях высоких нагрузок.

Модуль включает в себя следующие компоненты 2.0:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Запись детально | highloadblock.view | Выводит детальную информацию об одной записи заданного Highload-блока.
Список записей | highloadblock.list | Выводит список записей заданного Highload-блока.

Смотрите также:

  • Настройка Highload-блока
  • Архитектура модуля


Highload-блоки

Страница Highload-блоки (Контент > Highload-блоки) служит для управления highload-блоками (сущностями модуля Highload-блоки).

Контекстная панель

Кнопка | Описание
Добавить Highload-блок | Переход к форме создания нового Highload-блока.

Список Highload-блоков

Поле | Описание
Действия Доступные действия:
  • Список записей - переход к списку записей Highload-блока.
  • Список полей - переход к списку полей Highload-блока. Открывается страница со списком пользовательских полей с установленным фильтром по объекту HLBLOCK_<ID_сущности>.
  • Изменить - переход к форме редактирования Highload-блока.
  • Удалить - удаление Highload-блока.
ID | Идентификатор сущности в модуле Highload-блоки.
Название | Название Highload-блока.


Создание и редактирование Highload-блока

Закладки

Форма служит для создания нового или редактирования существующего Highload-блока.

Контекстная панель

Кнопка | Описание
Вернуться в список | Переход на страницу со списком Highload-блоков.

Highload-блок

На данной закладке задаются основные параметры Highload-блока.

Поле | Описание
Название сущности* | Название нового Highload-блока. Должно начинаться с заглавной буквы и состоять только из латинских букв и цифр.
Название таблицы в БД* | Название таблицы, в которой будет храниться новый Highload-блок.
Поля сущности** | Ссылка с количеством полей, созданных в сущности.
Записи** | Ссылка с количеством записей, созданных в сущности.
Языкозависимые названия
[Язык_интерфейса] | Название Highload-блока для данного языка интерфейса.

* - поля, обязательные для заполнения;
** - поля, доступные при редактировании существующей сущности.

Права доступа

На данной закладке настраиваются права доступа к Highload-блоку.

Поле | Описание
[Группа_пользователей] Право доступа групп пользователей к управлению Highload-блоком:
  • Доступ запрещен - доступ к Highload-блоку запрещён;
  • Чтение - просмотр записей Highload-блока;
  • Запись - право на редактирование записей Highload-блока.
ссылка Добавить | Выбор и добавление в форму пользователей, для которых требуется задать право доступа к Highload-блоку.


Список записей Highload-блока

Страница Highload-блок "<название_highload_блока>": Список записей (Контент > Highload-блоки > <название_highload_блока>) служит для управления записями highload-блока.

Форма поиска

Форма фильтра используется для выбора из списка записей в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
ID | Поиск записи по идентификатору.
<поле_блока> | Поиск записи по значению, заданном в соответствующем поле highload-блока. Поле highload-блока отображается только в том случае, если в настройках поля разрешено показывать его в фильтре.

Чтобы отобрать записи Highload-блока по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех записей нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить запись | Переход к форме добавления новой записи.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список записей

Поле | Описание
Колонка флажков | Поле предназначено для выбора записей, к которым предполагается применить какое-либо правило или действие.
Действия Действия над записями Highload-блока.:
  • Изменить - изменение параметров записи;
  • Копировать - добавление новой записи путем копирования параметров текущей;
  • Удалить - удаление записи.
ID | Идентификатор записи Highload-блока.
<поле_блока> | Значение поля Highload-блока.


Создание и редактирование записи

Форма служит для создания новой или редактирования существующей записи Highload-блока.

Контекстная панель

Кнопка | Описание
Вернуться в список | Переход на страницу со списком записей.
Копировать | Добавление новой записи путем копирования параметров текущей. Кнопка отображается при редактировании уже существующей записи.
Действия Кнопка доступна только при редактировании существующей записи. Доступные действия:
  • Добавить - переход на страницу с формой создания новой записи Highload-блока.
  • Удалить - удаление редактируемой записи Highload-блока.

Форма редактирования

Поле | Описание
ID | Идентификатор записи. Поле отображается только при редактировании существующей записи Highload-блока.
ссылка Добавить пользовательское свойство | Переход к добавлению нового поля для Highload-блока.
<поле_блока> | Задается значение поля Highload-блока.


Отправить отзыв по этому разделу

Экспорт/импорт

  • Импорт
  • Экспорт


Импорт

Форма импорта Импорт Highload-блока (Контент > Highload-блоки > Экспорт/импорт > Импорт) предназначена для загрузки данных из файла формата XML в highload-блок.

Форма импорта

Поле | Описание
Файл для импорта | С помощью кнопки [...] выберите файл в формате XML с сервера или загрузите с локального компьютера.
Highload-блок | Указывается highload-блок, в который будет выполняться загрузка данных. Если выбрано значение -создать новый-, то в файле импорта обязательно должна содержаться структура highload-блока. В соответствии с ней в системе будет создан новый highload-блок.
Поле внешнего ключа | В параметре указывается поле, по значениям которого будет выполняться поиск записей файла в highload-блоке. Если запись найдена, то ее поля будут обновлены в соответствии со значениями в файле. Если запись отсутствует, то она будет добавлена в highload-блок. Если в параметре поле не выбрано, то все записи из файла будут добавлены в highload-блок как новые (даже если они полностью дублируются).
Импортировать структуру | При отмеченной опции будет импортирована структура highload-блока: его название, название таблицы, поля.
Импортировать данные | При отмеченной опции будут импортированы записи highload-блока.
Сохранять связи со сторонними сущностями | При отмеченной опции будут сохранены связи со сторонними сущностями, например, с разделами и элементами инфоблоков. В противном случае связи будут сброшены.

После того, как импорт завершен, на странице выводится соответствующее сообщение.

Смотрите также

  • Два инструмента для highload-блоков: импорт и экспорт


Экспорт

Форма Экспорт Highload-блока (Контент > Highload-блоки > Экспорт/импорт > Экспорт) предназначена для экспорта данных из highload-блока в файл формата XML.

Форма экпорта

Поле | Описание
Файл для экспорта | Путь относительно корня сайта к файлу, в который будет выгружен highload-блок.
Highload-блок | Указывается highload-блок, который необходимо экспортировать.
Экспортировать структуру | При отмеченной опции будет экспортирована структура highload-блока: его название, название таблицы, поля.
Экспортировать данные | При отмеченной опции будут экспортированы все записи highload-блока.

После завершения операции на странице выводится соответствующее сообщение.

Смотрите также

  • Два инструмента для highload-блоков: импорт и экспорт


Документооборот. Описание модуля

Модуль Документооборот предназначен для организации последовательной обработки статических страниц, а также динамической составляющей сайта. Использование этого модуля позволяет наладить командную работу над содержимым сайта.

Модуль реализует следующую идеологию:

  1. Документы каждого раздела сайта могут быть модифицированы в режиме документооборота. Для этого пользователь должен иметь, как минимум, право Документооборот на данный раздел.
  2. Понятие документ подразумевает копию статической страницы сайта в модуле документооборота. У одной статической страницы не может быть более одного документа. В свою очередь, редактирование статической страницы представляет собой процесс модификации документа (копии данной страницы) в модуле документооборота. В процессе модификации возможна смена статуса документа. Конечным статусом является статус #1, при достижении которого содержимое документа переносится в статическую страницу (в файл). При этом порядок смены статусов может быть произвольным. В случае создания новой страницы в первую очередь создаётся документ, затем после его публикации создаётся непосредственно сама страница.
  3. Для использования в документе ссылок на какие-либо файлы (jpeg, gif, pdf и т.д.) пользователю необходимо загрузить их в документ. После публикации документа все загруженные в него файлы переносятся в указанные каталоги.
  4. В процессе модификации документа каждое его изменение записывается в историю документа. При необходимости отменить изменения, сделанные в документе, пользователь должен скопировать необходимую ему часть документа из его истории.

Смотрите также:

  • Документооборот для страниц и разделов
  • Документооборот для инфоблоков
  • Создание новости через документооборот
  • Настройка модуля


Документооборот. Настройки модуля

Закладки

Форма настроек модуля Документооборот (Настройки > Настройки продукта > Настройки модулей > Документооборот) предназначена для задания общесистемных параметров модуля.

Настройки

Поле | Описание
Использовать HTML редактор | При отмеченной опции будет использоваться визуальный HTML-редактор для редактирования документов в режиме документооборота.
Сохранять историю изменений файлов при обычном редактировании (не в документообороте) | При отмеченной опции история изменения документов, редактирование которых выполняется в обычном режиме, будет сохранена (без использования документооборота).
Максимальное время блокировки (мин.) | Указывается максимальное время (в минутах) блокировки документа пользователем. В течении этого времени заблокированный документ будет недоступен для редактирования другим пользователям.
Сколько дней хранить документ после его публикации (отрицательное значение - хранить всегда) | Указывается период времени (в днях), в течении которого копия документа будет храниться в истории модуля Документооборот после того, как документ был переведен в статус Опубликован. Если в поле указать отрицательное значение, то время хранения копии документа будет не ограничено. Если установить флаг в поле Очистить и нажать кнопку Сохранить, то записи истории будут стерты.
Максимальное количество последних записей в истории | Указывается максимальное количество записей об изменении документа или элемента информационного блока, которое хранится в истории модуля Документооборот. Если установить флаг в поле Очистить и нажать кнопку Сохранить, то данные истории будут стерты.
Сколько дней хранить историю (отрицательное значение - хранить всегда) | Указывается максимальное количество дней, отводимых для хранения истории изменений документа и элемента информационного блока. Если в поле указать отрицательное значение, то данные истории будут храниться в течение неограниченного периода времени. Если установить флаг в поле Очистить и нажать кнопку Сохранить, то данные истории будут стерты.
Группа администраторов документооборота | Указывается группа пользователей-администраторов документооборота, которые обладают правом на редактирование, перемещение, удаление документов в любом из статусов, а также на разблокирование любых документов.

Доступ

Поле | Описание
По умолчанию | Управление уровнем доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Управление правом доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Документооборот:
  • [D] закрыт - доступ запрещён;
  • [R] просмотр без права модификации - право на просмотр файлов модуля без права модификации;
  • [U] участие в документообороте - право на редактирование файлов в режиме документооборота;
  • [W] полный доступ - право на изменение документов в любом из статусов, а также на управление параметрами модуля (в т.ч. правами доступа других пользователей).


Документы

На странице Документы (Контент > Документооборот > Документы) отображает документы, включенные в документооборот.

Под документом понимается копия страницы сайта, находящейся в стадии редактирования в режиме документооборота. После достижения документом статуса #1 (момент публикации) все изменения переносятся из документа в файл (в редактируемую страницу).

Форма поиска

Форма фильтра используется для выбора из списка документов в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Найти | Позволяет найти документы по их основным параметрам: Заголовок, Содержимое или Кем изменен. Поле присутствует, даже если фильтр свернут.
ID документа* | Поиск документов по идентификатору.
Индикатор доступа к документу Индикатор, показывающий, в каком состоянии редактирования находится документ:
  • зеленый - документ свободен для редактирования;
  • желтый - документ временно заблокирован вами. Помните, кроме вас его никто не сможет редактировать. Максимальное время блокировки устанавливается в настройках модуля Документооборот;
  • красный - документ редактируется в данный момент другим пользователем.
Дата изменения (DD.MM.YYYY) | Поиск документов по дате последнего изменения документа.
Кем изменен* | Поиск документов по пользователю, выполнившему последнее изменение документа.
Сайт | Поиск документов по сайту, в котором отображается редактируемый через модуль документ.
Имя файла* | Поиск по имени файла документа.
Заголовок* | Поиск по заголовку документа.
Содержимое* | Поиск документов по произвольному тексту, который может содержаться в документе.
Статус* | Поиск документов по статусу.
Логика между полями | Поиск документов по установленной логики между полями формы поиска.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать документы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех документов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания документа в режиме документооборота.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список документов

Поле | Описание
Колонка флажков | Выбор документов, к которым предполагается применить какое-либо правило или действие.
Действия Действия над документом:
  • Разблокировать - снятие блокировки с документа;
  • Изменить - переход к редактированию документа в режиме документооборота;
  • Просмотр - переход к просмотру документа;
  • История - переход к просмотру истории изменения документа по его идентификатору;
  • История файла - переход к просмотру истории изменения документа по его имени;
  • Удалить - удаление записи о документе из модуля Документооборот.
ID | Идентификатор документа в системе.
Инд. Индикатор, показывающий, в каком состоянии редактирования находится документ:
  • – документ свободен для редактирования;
  • – документ временно заблокирован вами. Помните, кроме вас его никто не сможет редактировать. Максимальное время блокировки устанавливается в настройках модуля Документооборот;
  • – документ редактируется в данный момент другим пользователем.
Дата изменения | Дата и время последнего изменения документа.
Кем изменен | Пользователь, выполнивший последнее изменение документа.
Заголовок | Заголовок документа.
Имя файла | Имя файла документа.
Статус | Текущий статус документа (например, Черновик).
Сайт | Сайт, на котором отображается документ.

Смотрите также

  • Работа с модулем


Создание и редактирование документа

Закладки

Создание (редактирование) страницы через документооборот выполняется с помощью специальной формы в административном разделе сайта. Переход к данной форме может быть выполнен двумя способами:

  • из административного раздела со страницы Документы с помощью кнопки Добавить, расположенной на контекстной панели (или с помощью пункта Изменить меню действий существующего документа);
  • из публичного раздела в режиме Редактирование с помощью команд Создать страницу (или Изменить страницу) кнопки Документооборот, расположенной на административной панели.

Контекстная панель

Кнопка | Описание
Список документов | Переход на страницу со списком документов.
Создать новый документ | Переход к созданию нового документа в режиме документооборота.
Удалить текущий документ | Удаление редактируемого документа.

Редактирование документа

Предназначена для редактирования самого документа.

Поле | Описание
Шаблон Выбор шаблона документа:
  • Стандартная страница;
  • Выбор включаемой области для страницы;
  • Выбор включаемой области для раздела.
Поле доступно только при создании нового документа.
Статус | Статус документа.
Создан, Изменен, Блокирован Задается дата, время и информация о пользователях, которые создали, изменили и заблокировали документ для редактирования.

Поля доступны при редактировании уже существующего документа.
*Полное имя файла | Полное имя файла (с указанием пути). При указании полного пути к файлу на сервере вам необходимо учесть, что вы должны иметь как минимум право Документооборот на указанную вами директорию. Путь к файлу можно указать с помощью кнопки [...].
Заголовок | Заголовок документа.
Переключатель режима ввода текста Задается режим ввода текста документа: Text, HTML или Визуальный редактор.

В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть.

Загруженные файлы

Для использования изображений, а также каких-либо других файлов, вам необходимо загрузить их в документ. Рекомендуется указывать имя файла без пути, тогда файл будет загружен в ту директорию, в которой находится файл редактируемого документа.

Загруженные в документ файлы можно просмотреть, скачать, либо удалить их из документа. В теле документа можно использовать как относительные пути к загруженным файлам, так и абсолютные. Помимо загруженных в документ, у вас есть возможность указать ссылки на любые файлы, расположенные на сервере.

Поле | Описание
Информация об уже загруженных файлах.
ID | Уникальный идентификатор загруженного файла.
Имя | Имя файла.
Размер | Размер файла
Загружен | Дата и время загрузки файла в документ.
Кем | Пользователь, выполнивший загрузку файла.
Уд. | Для того чтобы удалить файл, установите флаг в это поле и нажмите кнопку Применить.
Поля для загрузки файлов в документ.
Имя файла на сервере | Указывается имя, которое будет присвоено файлу после загрузки.
Имя локального файла | Указывается имя загружаемого файла (с указанием полного пути к нему). Для выбора файла используйте кнопку Обзор.

Комментарий

Служит для создания произвольного комментария к документу (например, по поводу перевода документа в другой статус).


История

На странице История (Контент > Документооборот > История) представлена история изменений документов.

Каждое сохранение документа оставляет запись в истории. Максимальное количество последних записей в истории документа можно указать в настройках модуля Документооборот. Также в настройках модуля указывается максимальное время хранения истории.

Форма поиска

Форма фильтра используется для выбора из списка записей в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Найти | Позволяет найти записи по их основным параметрам: Заголовок, Содержимое или Кем изменен. Поле присутствует, даже если фильтр свернут.
ID* | Поиск записей по идентификатору в истории изменений.
ID документа* | Поиск записей по идентификатору документа.
Дата изменения (DD.MM.YYYY) | Поиск записей по дате изменения документа (дата создания записи истории редактирования).
Кем изменен* | Поиск записей по пользователю, выполнявшему изменение документа (создавший запись истории редактирования).
Имя файла* | Поиск записей по имени файла документа.
Заголовок* | Поиск записей по заголовку документа.
Содержимое* | Поиск записей по предполагаемому содержанию (текст) документа.
Статус документа* | Поиск записей по статусу документа.
Логика между полями | Установление логики между полями формы поиска.
Сайт | Поиск записей по сайту, к которому относится документ.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать записи по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех записей нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Список документов | Переход на страницу со списком документов.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список записей

Поле | Описание
Колонка флажков | Выбор записей, к которым предполагается применить какое-либо правило или действие.
Действия Действия над записью в истории изменений:
  • Просмотр - просмотр записи;
  • Удалить - удаление записи.
ID | Идентификатор записи в истории изменений.
ID документа | Идентификатор документа.
Дата изменения | Дата изменения документа (т.е. дата создания записи в истории изменений).
Кем изменен | Пользователь, выполнивший изменение документа.
Имя файла | Имя файла документа.
Заголовок | Заголовок документа.
Статус | Статус документа в момент создания записи в истории изменений.
Сайт | Сайт, к которому относится документ.

История изменений позволяет сравнить изменения, внесенные в документы. Все сравнения производятся относительно более раннего документа. Зеленым отмечается то, что добавлено в более позднем документе, красным зачеркнутым - то что удалено из более ранего документа. Для сравнения:

  1. Установите флажки в чекбоксах тех документов, сравнение которых необходимо.
  2. Нажмите на кнопку Сравнить.

Смотрите также

  • Работа с модулем


Статусы

На странице Статусы (Контент > Документооборот > Статусы) представлены возможные статусы документов, а также элементов информационных блоков.

Статусы используются для разделения работы над документами на определённые этапы, за каждый из которых отвечает один, либо группа пользователей. Статус #1 является конечным в цепочке документооборота, он зарезервирован и не подлежит удалению. При достижении документом данного статуса все изменения, выполненные в документе, вступают в силу (т.е. документ публикуется).

Форма поиска

Форма фильтра используется для выбора из списка статусов в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Найти | Позволяет найти записи по их основным параметрам: Описание, ID или Заголовок. Поле присутствует, даже если фильтр свернут.
ID* | Поиск статуса по идентификатору.
Активен | Поиск статуса по признаку активности.
Заголовок* | Поиск статуса по заголовоку.
Описание* | Поиск статуса по предполагаемому тексту описания статуса.
Документов | Поиск статуса по количеству документов, находящихся в указанном статусе. Количество документов может быть указано как в виде диапазона, так и одним числом.
Логика между полями | Установление логики между полями формы поиска.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать статусы документов по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех статусов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания нового статуса.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список статусов

Поле | Описание
Колонка флажков | Поле предназначено для выбора статусов, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия над статусом:
  • Изменить - переход к форме редактирования параметров статуса;
  • Удалить - удаление статуса.

    Примечание: удаление конечного статуса с ID равным 1 невозможно.
ID | Идентификатор статуса.
Дата изм. | Дата последнего изменения статуса.
Акт. | Признак активности статуса. Неактивный статус не может быть применен к документу.
Сорт. | Относительный "вес", влияющий на положение статуса в общем списке.
Заголовок | Заголовок статуса.
Описание | Описание статуса.
Документов | Количество документов, находящихся в данном статусе. Ссылка с количеством документов позволяет перейти к списку документов, находящихся в данном статусе.

Пример использования статусов

У вас есть группа авторов, которые пишут статьи на сайте. Также у вас есть главный редактор, проверяющий эти статьи и публикующий их на сайте. Для организации документооборота по данной схеме вам необходимо завести 2 дополнительных статуса:

  • Draft (черновик);
  • Ready (готов к публикации).

Авторам необходимо дать возможность редактировать документы в статусе Draft и переводить их в статус Ready. Главному редактору необходимо дать возможность редактировать документы в статусе Ready, а также переводить их в статусы Draft (отправить на доработку) и в статус #1, Published (т.е. публиковать их).

Использование шаблонов почтовых сообщений позволяет каждый раз при изменении статуса документа автоматически создавать почтовое сообщение и отправлять данное сообщение ответственному пользователю. Например, сообщения о переводе документов в статус Ready могут направляться главному редактору.

Для того чтобы адрес получателя почтового сообщения подставлялся в письмо автоматически, в поле TO (Кому) почтового шаблона следует использовать следующие переменные:

  1. Письмо отсылается на адрес создателя документа (#CREATED_BY_EMAIL#).
  2. Письмо отсылается на все адреса администраторов документооборота (#ADMIN_EMAIL#).
  3. Письмо отсылается всем, кто принимал участие в редактировании документа в его текущем статусе (#BCC#).

Если в настройках текущего статуса документа указано Оповестить всех, кто имеет право редактировать (либо просматривать) документ при достижении им данного статуса, то письмо также будет отослано всем пользователям, входящим в группы, для которых установлено право редактировать документ в данном статусе (#BCC#).

Смотрите также

  • Работа с модулем


Создание и редактирование статуса

Форма предназначена для создания новых и управления параметрами уже существующих статусов документов.

Контекстная панель

Кнопка | Описание
Список статусов | Переход на страницу со списком статусов документов.
Создать новый статус | Переход к форме создания нового статуса. Кнопка отображается при редактировании уже существующего статуса документов.
Удалить текущий статус | Удаление текущего статуса. Кнопка отображается при редактировании уже существующего статуса документов.

Закладка "Параметры статуса"

Поле | Описание
Дата изменения | Дата и время последнего изменения параметров статуса. Отсутствует в форме создания нового статуса.
Документов в данном статусе | Количество документов, имеющих данный статус.
Активен | Признак активности статуса. Неактивный статус не может быть применен к документу. Отсутствует в форме редактирования статуса.
Порядок сортировки | Относительный "вес", влияющий на положение статуса в общем списке.
*Заголовок | Заголовок статуса.
Описание | Описание статуса.
Имеют право переводить документ в данный статус | Список групп пользователей, имеющих право переводить документ в данный статус. Для выбора нескольких групп использовать CTRL+ левая кнопка мыши.
Имеют право редактировать и сохранять документ в данном статусе | Список групп пользователей, имеющих право редактировать и сохранять документ в данном статусе. Для выбора нескольких групп использовать CTRL+ левая кнопка мыши.
Оповестить всех кто имеет право редактировать (либо просматривать) документ при достижении им данного статуса | Оповещение почтовым сообщением всех пользователей, обладающих правом на редактирование, о переводе документа в данный статус.

* - поля, обязательные для заполнения.


Wiki

Возможности модуля

Модуль Wiki предназначен для коллективной работы над контентом страницы.

Модуль позволяет:

  • Редактирование вики-страниц разными пользователями как с помощью вики-разметки, так и с помощью визуального редактора (HTML).
  • Автоматическое построение оглавления.
  • Вставлять изображения в страницу.
  • Возможность задавать категории и тэги страницам.
  • Искать интересующую категорию.
  • Комментировать вики страницы (требуется модуль «Форум»).
  • Вести историю изменений страницы (требуется модуль «Бизнес-процессов»).
  • Сравнивать разные версии вики-страниц (требуется модуль «Бизнес-процессов»).
  • Восстанавливать вики страницу до более ранней версии (требуется модуль «Бизнес-процессов»).
  • Искать вики страницы с помощью стандартной формы поиска (требуется модуль «Поиска»).

Модуль может работать как независимо, так и в рамках рабочих групп социальной сети.

Компоненты модуля

Модуль включает в себя следующие Компоненты 2.0:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Комплексный Wiki компонент | wiki | Комплексный компонент позволяет вести полнофункциональную работу с Wiki.
Меню | wiki.menu | Выводит меню команд.
Страница | wiki.show | Выводит основную страницу Wiki.
Редактирование | wiki.edit | Выводит форму редактирования страницы.
Категории | wiki.categories | Выводит список категорий.
История | wiki.history | Выводит историю изменений страницы.
Обсуждения | wiki.discussion | Выводит обсуждение по статье.
Сравнение версий | wiki.history.diff | Выводит выводит тексты версий для сравнения.

Смотрите также

  • Как работать с Wiki
  • Настройка Wiki


Установка модуля

Если в силу каких-то причин (например, использование версии до 9.5 и последующее обновление) не был установлен модуль Wiki, то для его установки перейдите на страницу Настройки > Настройки продукта > Модули. В общем списке найдите строку Wiki и нажмите на кнопку Установить. Откроется форма для задания данных для установки.

Параметры для установки
Создать информационный блок | Установить флажок, если заранее не было создан тип инфоблока и сам инфоблок для хранения данных Wiki.
Создать форум | Установить флажок, если заранее не было создан форум для обсуждения статей Wiki.
Создать информационный блок для соц. сети | Установить флажок, если заранее не было создан тип инфоблока и сам инфоблок для хранения данных Wiki в рамках Социальной сети.
Создать форум для соц. сети | Установить флажок, если заранее не было создан форум для обсуждения статей Wiki в рамках Социальной сети.

После установки флажков появляются дополнительные опции настройки.

Создать информационный блок
Название информационного блока | Введите название создаваемого информационного блока для Wiki.
Тип информационного блока
  • Если Тип информационного блока уже создан, то выберите его в строке Выбрать.
  • Если Тип информационного блока не создан, то введите на латинице идентификатор создаваемого типа в строке Создать.
Создать форум
Название форума | Введите название форума для обсуждения статей Wiki.
Создать информационный блок для соц.сети
Название информационного блока для соц.сети | Введите название создаваемого информационного блока для Wiki соц.сети.
Тип информационного блока для соц.сети
  • Если Тип информационного блока уже создан, то выберите его в строке Выбрать.
  • Если Тип информационного блока не создан, то введите на латинице идентификатор создаваемого типа в строке Создать.
Создать форум для соц.сети
Название форума для соц.сети | Введите название форума для обсуждения статей Wiki соц.сети.

После установки модуля необходимо сбросить управляемый кеш (страница Настройки >Настройки продукта > Автокеширование, закладка Очистка файлов кеша). В противном случае Wiki в группах социальной сети не будет отображаться.


Wiki. Настройки модуля

Закладки

Форма настроек модуля Wiki (Настройки > Настройки продукта > Настройки модулей > Wiki) предназначена для задания параметров модуля.

Настройки

Закладка задает общие параметры для модуля Wiki

Поле | Описание
Разрешить использование визуального редактора и HTML | Установленный флажок снимает ограничения на использование визуального редактора при создании и редактировании сообщений.
Максимальная ширина загружаемого изображения (пикселей) | Задание максимальной ширины загружаемого изображения при загрузке на страницу Wiki. Если параметры картинки больше указанного, то изображение уменьшится до выбранного размера.
Максимальная высота загружаемого изображения (пикселей) | Задание максимальной высоты загружаемого изображения при загрузке на страницу Wiki. Если параметры картинки больше указанного, то изображение уменьшится до выбранного размера.

Социальная сеть

Закладка задает параметры использования модуля в рамках социальной сети.

Поле | Описание
Включить поддержку социальной сети | Опция разрешает использование Wiki в рамках социальной сети.
Инфоблок | Выбор типа инфоблока и инфоблока для использования в Wiki в рамках социальной сети.
Разрешить обсуждение | Опция разрешает обсуждение статей в рамках соцсети.
ID форума для отзывов | Выбор форума для использования в обсуждении статей. Форум требуется предварительно создать.
Количество сообщений на одной странице | Ограничение числа комментариев к статье.
Использовать CAPTCHA | Разрешение на использование Captcha комментариях к статье.

Права доступа

Форма позволяет установить уровень доступа к модулю по умолчанию для всех групп пользователей сайта.

Поле | Описание
[тип_инфоблока] | Для каждого типа инфоблока системы указываются группы пользователей, которые могут управлять универсальными списками.


Агрегатор библиотек документов (КП)

Модуль Агрегатор библиотек документов позволяет организовать коллективный доступ к офисным документам, хранящимся на сервере, с возможностью редактировать их, сохранять изменения, вести историю версий в системе документооборота, работать с файлами через проводник. Под опубликованными документами можно организовать обсуждение.

Модуль относится только к "Битрикс24 в коробке".

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Агрегатор | webdav.aggregator | Служит для быстрой навигации по библиотекам документов.
Агрегатор | mobile.webdav.aggregator | Служит для быстрой навигации по библиотекам документов портала, настроенного на работу с мобильных устройств.


Агрегатор библиотек документов (КП). Настройки модуля

Закладки

Форма настроек модуля (Настройки > Настройки продукта > Настройки модулей > Библиотека документов) предназначена для задания параметров модуля.

Настройки

Поле | Описание
Расширения документов для включения пункта меню "Редактировать в MS Office" | Указываются расширения файлов, для которых в меню действий будет доступен пункт Редактировать в MS Office.
Скрывать системные файлы (начинающиеся с ".") | [Y|N] При отмеченной опции в библиотеке документов не будут отображаться системные файлы, которые во многих операционных системах начинаются с символа ".".
Журналировать действия пользователей | [Y|N] При отмеченной опции действия пользователей в библиотеке документов будут попадать в системный журнал событий.
Интеграция с модулем соц. сети | [Y|N] При отмеченной опции работа с файлами библиотеки документов не отображается в Социальной сети (например уведомления в Живой ленте о добавлении/изменении файлов в библиотеке документов).
Включить работу с документами через внешние службы (Google Viewer, Google Drive) | [Y|N] При отмеченной опции работа с документами компании будет осуществляться через Google Docs.
Разрешать работу с документами через внешние службы индивидуально в настройках библиотек групп и пользователей | [Y|N] При отмеченной опции разрешена работа с личными документами и документами рабочих групп через Google Docs. В этом случае сотрудник портала (владелец группы) самостоятельно включает/отключает работу с документами через Google Docs в настройках личной библиотеки (библиотеки рабочей группы).
Автоматически подключать Диск группы при вступлении пользователя в группу | При отмеченной опции Диск группы будет подключаться к Диску пользователя, в нее вступившего.
Путь для публичных ссылок | Путь, по которому будет формироваться адрес публичной ссылки документа.
Типы файлов
Название типа документов Указываются наименования типов файлов, которые могут быть в библиотеке документов:
  • Документы;
  • Изображения;
  • Мультимедиа.
Расширения для данного типа документов | Указываются расширения файлов, относящихся к данному типу документов.
Удалить | [Y|N] При сохранении формы настройки с данной отмеченной опцией, помеченный тип документов не будет распознаваться при использовании поиска по библиотеках документов инфоблоков.
Добавить тип файлов | При нажатии на кнопку появляется форма для добавления нового типа файлов с полями, указанными выше.

История документов

Поле | Описание
Максимальное количество записей в истории документа | Указывается наибольшее разрешенное число записей в истории об изменении документа. Для режима документооборот данная настройка производится в параметрах модуля Документооборот.
Использовать склейку истории изменений документа | [Y|N] При отмеченной опции, в истории документа, при его редактировании, будут сохраняться только первоначальная и предпоследняя его версии в указанном периоде времени.
История изменений документа склеивается в течении, секунд | Указывается количество секунд, в течении которых будет происходить "склейка" экземпляров в истории документа.


Задачи (КП). Описание модуля

Модуль Задачи предназначен для управления задачами на портале.

Модуль включает в себя следующие компоненты:

Компоненты

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Задача | tasks_task | Компонент для создания, просмотра и редактирования задачи.
Задачи | tasks.list | Компонент для отображения задач.
Изменение шаблона | tasks.template.edit | Компонент для создания и изменения шаблона задачи.
Просмотр задачи | tasks.task.detail | Компонент для отображения задачи.
Шаблоны | tasks.templates.list | Компонент для отображения шаблонов задач.
Тема (отзывы) | tasks.topic.reviews | Форма для создания отзыва к задаче, список отзывов.
Канбан задач | tasks.kanban | Компонент для отображения задач в формате виртуальной онлайн-доски для работы с проектами.
Системные компоненты (не описываются)
Отчет по эффективности | tasks.report | Компонент для отображения отчета эффективности сотрудников.
Выбор тегов к задаче | tasks.tags.selector | Компонент служит для выбора тегов к задаче.
Выбор задачи | tasks.task.selector | Компонент служит для выбора задач (в форме задачи для выбора родительской задачи). Также он используется в модуле Учет рабочего времени
Выбор сотрудников в задаче | tasks.user.selector | Компонент служит для выбора сотрудников в задаче.
Задачи (фильтр) | tasks.filter | Компонент служит для отображения фильтра в публичном интерфейсе. Устаревшая версия, сохранена для совместимости.
Задачи (фильтр v2) | tasks.filter.v2 | Компонент служит для отображения фильтра в публичном интерфейсе с поддержкой создания собственных настроек.

О работе с модулем смотрите в курсе Администратор сервиса Битрикс24 [image].

Смотрите также

  • Оповещения о задачах в живой ленте
  • Синхронизация задач с Exchange
  • Настройка помощи
  • Добавление пользовательских полей для задач


Задачи (КП). Настройки модуля

Форма настроек модуля Задачи (Настройки > Настройки продукта > Настройки модулей > Задачи) предназначена для задания общесистемных параметров модуля.

Закладка "Настройки модуля задач"

Закладка служит для задания глобальных настроек модуля.

Поле | Описание
Форум для комментариев | Указывается форум для комментариев, что позволит выводить уведомления о задачах в живую ленту.
Разрешить редактирование\удаление комментариев | При отмеченной опции пользователям будет доступна возможность редактирования и удаления собственных комментариев к задаче. Примечание при версии модуля Форум до 15.5.3 пользователю будет доступно удаление\редактирование только последнего своего комментария.
Разрешить сортировку и фильтрацию по пользовательским полям в списке задач | При отмеченной опции пользователям будет доступна возможность фильтровать задачи по пользовательским полям.
Уровень фильтрации описания задач HTML-санитайзером | Задается уровень фильтрации HTML-текста в описании задачи для безопасного вывода на экран. Данная опция актуальна для задач и шаблонов задач, созданных до версии модуля 12.5.0. В более новой версии для форматирования и безопасного вывода используются BB-codes.
Лимит кол-ва файлов в одном комментарии | Задается ограничение на количество файлов, которые можно прикрепить к комментарию для задачи. Примечание - с версии модуля 16.0.0 ограничение на количество файлов удалено.
Ссылки
Вкладка <имя_сайта>
Настройки для сайта <имя_сайта>
Шаблон ссылки на список задач пользователя | Указывается шаблон ссылки на страницу со списком задач пользователя. По умолчанию указано /company/personal/user/#user_id#/tasks/.
Шаблон ссылки на задачу пользователя | Указывается шаблон ссылки на задачу пользователя. По умолчанию указано /company/personal/user/#user_id#/tasks/task/view/#task_id#/.
Шаблон ссылки на список задач группы | Указывается шаблон ссылки на страницу со списком задач группы. По умолчанию указано /workgroups/group/#group_id#/tasks/.
Шаблон ссылки на задачу группы | Указывается шаблон ссылки на задачу группы. По умолчанию указано /workgroups/group/#group_id#/tasks/task/view/#task_id#/.


Описание

Визуальный редактор универсальных списков - инструмент для управления списками (товаров, партнеров, клиентов и т.д.). Он обладает упрощенным интерфейсом для редактирования и настройки полей и свойств. С его помощью можно создавать списки частых вопросов, справочники, базы знаний, списки контрагентов, структурированные архивы, библиотеки, файловые хранилища и т.п. Все действия, в том числе и настройка, выполняются из публичной части. В административном разделе производится только настройка доступа к спискам для определенных групп пользователей. Кроме того, для информационных блоков, используемых в списках, должны быть включены бизнес процессы.

Работа Универсальных списков основана на модуле Информационные блоки, а весь интерфейс универсальных списков организуется с помощью визуальных компонентов.

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Универсальные списки | lists | Позволяет вести полнофункциональную работу с универсальными списками, создавая физически только одну страницу.
Списки | lists.lists | Выводит таблицу универсальных списков, доступных для просмотра и изменения.
Список | lists.list | Выводит разделы и элементы универсального списка с возможностью навигации и редактирования.
Разделы списка | lists.sections | Позволяет удалить и изменить разделы универсального списка.
Редактирование элемента | lists.element.edit | Выводит форму редактирования элемента списка.
Настройки списка | lists.list.edit | Показывает форму настроек универсального списка.
Поля списка | lists.fields | Показывает поля универсального списка и позволяет их редактировать.
Настройки поля списка | lists.field.edit | Показывает форму настройки поля универсального списка.
Навигационная цепочка | lists.element.navchain | Добавляет к выводу обычного компонента Навигационная цепочка (bitrix:breadcrumb) элемент списка.
Меню списков | lists.menu | Добавляет в меню социальной сети универсальные списки.
Скачивание файла | lists.file | Скачивает файлы, привязанные к элементам списка, с проверкой прав доступа.

Смотрите также

  • Пример настройки Универсального списка
  • Бизнес-процессы и универсальные списки
  • Установка и настройка модуля универсальные списки
  • Пример использования Универсальных списков как самостоятельного инструмента


Универсальные списки. Настройки модуля

Закладки

Форма настроек модуля Универсальные списки (Настройки > Настройки продукта > Настройки модулей > Универсальные списки) предназначена для задания параметров модуля.

Права доступа

Форма позволяет установить уровень доступа к модулю Универсальные списки по умолчанию для всех групп пользователей сайта.

Поле | Описание
Группы пользователей | Выбор группы пользователей, которым в поле Тип инфоблока будут назначены инфоблоки для управления.
Тип инфоблока | Выбор инфоблока для управления той или иной группой.

Кнопка Добавить право доступа добавляет строки в таблице.

Социальная сеть

Поле | Описание
Включить поддержку социальной сети | Установленный флажок разрешает использование универсальных списков в рабочих группах социальной сети.
Тип инфоблока | Выбор инфоблока для использования его в рамках социальной сети.

Живая лента

Поле | Описание
Включить функционал работы с живой лентой | При неустановленном флажке нет кнопки Процессы в Живой Ленте и нет пунктов меню Мои процессы и Процессы. Жесткого блокирования этих страниц по правам нет, пользователь, зная прямой путь открыть страницу сможет.
Тип инфоблока для работы с живой лентой | Выбор типа инфоблока, если отличается от по умолчанию.
Папка, в которой работает компонент | Выбор папки, где расположен компонент, если отличается от по умолчанию.


Сайты

Возможности модуля

Модуль позволяет решить следующие задачи:

  • Быстро запустить ваш собственный сайт, используя обширную коллекцию готовых шаблонов.
  • Менять дизайн шаблона - фоны, шрифты, тексты, изображения и др.
  • Создавать собственные шаблоны.
  • Работать с включаемыми областями шаблонов как с отдельными страницами.
  • Использовать готовые блоки из каталога.
  • Редактировать блоки - менять палитру, шрифты, кнопки, добавлять анимацию и др.
  • Выводить на сайт данные из "1С-Битрикс: Управление сайтом", в том числе товары каталогов и др.
  • Адаптировать сайт к мобильным устройствам сразу в процессе создания.
  • Хранить создаваемый сайт на своем хостинге и домене.
В модуле
Название | Описание
Настройки модуля | Форма настроек модуля Сайты 24 (Настройки > Настройка Продукта > Настройки модулей > Сайты 24) предназначена для задания путей и кода шаблона лендингов и разделения прав на доступ к модулю.

Смотрите также

  • Сайты 24 (глава курса "Контент-менеджер")
  • Сайты 24 (урок курса "Администратор. Модули")


Сайты 24. Настройки модуля

Закладки

Форма настроек модуля Сайты 24 (Настройки > Настройка Продукта > Настройки модулей > Сайты 24) предназначена для задания путей и кода шаблона лендингов и разделения прав на доступ к модулю.

Настройки

Подробнее процесс настройки описан в учебном курсе [image].

Доступ

Закладка позволяет настроить права на доступ к модулю для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Сайты 24:
  • [D] доступ запрещен - запрет на доступ;
  • [W] полный доступ - полный доступ к ресурсам модуля.
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.


Маркетинг

Функционал раздела

Функционал раздела
Название | Описание
Пульс конверсии | Конверсия - ключевой показатель эффективности работы сайта, который показывает процентное отношение числа посетителей сайта, выполнивших на нём какие-либо целевые действия, к общему числу посетителей сайта.
Бизнес модель интернет-магазина | Инструмент прогнозирования эффективности бизнес-модели интернет-магазина.
A/B-тестирование | A/B-тестирование - один из эффективных методов маркетингового исследования, суть которого в сравнении двух представлений выбранной страницы или дизайна сайта, для того чтобы выяснить насколько изменения повысят конверсию.
Автоконтекст | Предназначен для взаимодействия и управления системой размещения поисковой и тематической рекламы Яндекс.Директ
Торговый маркетинг | Предназначен для создания акций и скидок в интернет-магазине.
Email-маркетинг | Служит для организации работы рассылок.
Реклама | Сервис создания рекламы для нужного сегмента аудитории в поисковых сервисах и социальных сетях.
Триггерные рассылки | Триггерные рассылки относятся к модулю Email-маркетинг. Функционал предназначен для автоматической отправки сайтом последовательности писем в ответ на действие пользователя или после наступления некоторого события, связанного с пользователем.
Персонализация | Облачный сервис персонализации 1С-Битрикс BigData, сохраняя полную анонимность данных, анализирует посетителей, зашедших на ваш сайт (их интересы, покупки, сходство с другими покупателями), и составляет для них персональные рекомендации.
Поисковая оптимизация | Предназначен для анализа технического исполнения сайта. Он отображает параметры, влияющие на оптимизацию и дает рекомендации по улучшению этих параметров.
Баннерная реклама | Система управления рекламой позволяет организовать показ баннеров на сайте, подключив код внешней баннерной системы, либо за счет внутренней ротации баннеров в пределах сайта.

Смотрите также

  • Маркетинг (глава курса "Администратор. Модули")
  • Автоконтекст
  • E-mail маркетинг
  • Триггерные рассылки
  • Поисковая оптимизация (SEO)
  • Баннерная реклама
  • Товарный маркетинг


Пульс конверсии

На странице Сводная страница конверсии (Маркетинг > Пульс конверсии) можно просмотреть все результаты измерений Конверсии.

Конверсия - это процентное отношение числа посетителей сайта, выполнивших на нём какие-либо целевые действия, к общему числу посетителей сайта. Соответственно, конверсия - ключевой показатель эффективности работы сайта.

Выбор периода

Вверху страницы укажите период вывода данных Конверсии. Доступны два поля для ввода начала и конца периода.

Настройки вывода данных

Поле | Описание
Конверсия для сайта | Выберите сайт, по которому нужно вывести данные.
Атрибуты Свойство посетителя сайта, которое фиксируется счетчиком. Доступно две группы атрибутов:
  • Источники с которых заходили - как пользователь попал на сайт. В группе четыре атрибута: почтовые рассылки, переходы из поисковых систем (органический трафик), переходы из контекстной рекламы и прочее.
  • Устройства с которых заходили - устройство, которым пользовался тот или иной посетитель сайта. В группе четыре атрибута: планшеты, смартфоны, десктопы и прочее.
Целевые действия Целевое действие, выполненное пользователем на сайте. Доступны три действия:
  • Оформлено заказов
  • Оплачено заказов
  • Добавлено в корзину

Данные по каждому атрибуту

Далее по каждому атрибуту из выбранной группы атрибутов представлена статистика в соответствии с целевым действием. По нажатии на название атрибута открывается страница Детальной конверсии с возможностью выбора периода и сайта.

Смотрите также:

  • Конверсия (учебный курс "Продвижение сайта и маркетинг")


Бизнес модель интернет-магазина

На странице Модель окупаемости интернет-магазина (Маркетинг > Бизнес модель интернет-магазина) расположен инструмент прогнозирования эффективности бизнес-модели интернет-магазина.

Бизнес-модель интернет-магазина - это инструмент оценки эффективности и рентабельности Вашего интернет-магазина, помогающий выбрать оптимальную стратегию развития интернет-бизнеса.

Возможности инструмента:

  • быстрая оценка успешности Вашего интернет-магазина;
  • прогнозирование стратегии развития интернет-магазина;
  • расчет оптимального среднего чека;
  • расчет стоимости привлечения одного пользователя (CPA);
  • анализ рентабельности интернет-магазина.

Выбор периода и сайта

Вверху страницы укажите период вывода данных Конверсии. Доступны два поля для ввода начала и конца периода.

В параметре Конверсия для сайта выберите сайт, для которого требуется отобразить данные конверсии.

Модель рентабельности

На странице доступен инструмент прогнозирования эффективности. Включается он нажатием кнопки [dw]Прогноз[/dw][di] [image] [/di]. После активации становятся доступны для изменения параметры:

  • Рекламный бюджет
  • Цена за переход
  • Конверсия %
  • Средний чек
  • Наценка, %
  • Прочие расходы
  • Себестоимость

Смотрите также:

  • Бизнес-модель интернет-магазина (учебный курс "Администратор. Бизнес")


Реклама

На странице Реклама (Маркетинг > Реклама) представлена информация об имеющихся в системе рекламах в поисковых сервисах и социальных сетях.

Фильтр + поиск

Используется для задания параметров отбора рекламы, которые отображаются в списке.

Чтобы отфильтровать рекламные рассылки по заданным критериям нажмите кнопку Сохранить. Для отображения всех реклам нажмите кнопку Сбросить.

Поле | Описание
Поиск
Название | Поиск реклам по названию.
Статус рассылки Поиск реклам по статусам:
  • Новая
  • Готова к отправке
  • Отправляется
  • Запланирована
  • На паузе
  • Отправлена
  • Отменена
  • Приостановлена
Создал | Поиск по автору рассылки.
Дата создания | Поиск по дате создания рекламы.
Дата окончания отправки | Поиск по дате окончания отправки рекламы.
Фильтры
Мои | Поиск собственноручно созданных рассылок.
В работе | Поиск действующих рассылок.
Завершенные | Поиск завершенных рассылок.
Все | Быстрый сброс всех фильтров.

Контекстная панель

Кнопка Описание
Создать рекламу Служит для добавления новой рекламы. По нажатии кнопки требуется выбрать вид рекламы:
  • Яндекс.Директ;
  • Google AdWords;
  • ВКонтакте;
  • Look-alike аудитория ВКонтакте;

Примечание: Реклама Look-alike аудитория ВКонтакте доступна с версии 19.0.600 модуля Email-маркетинг (sender).

Список рассылок

Колонка | Описание
Колонка флажков | Поле выбора реклам, к которым необходимо применить действие Удалить.
Действия в меню Доступные действия по нажатии на меню рекламы:
  • Редактировать - переход к форме редактирования рекламы;
  • Копировать - создаётся копия рекламы и автоматически выполняется переход к форме редактирования;
  • Удалить - удаление рекламы;
  • Опубликовать - опубликовать рекламу;
  • На паузу - поставить опубликованную (запущенную) рекламу на паузу;
  • Продолжить - продолжить рекламу (если была на паузе);
  • Отменить - отменить запущенную рекламу;
  • Получатели - открыть страницу с информацией о получателях рекламы.
ID | Идентификатор рекламы, под которым она зарегистрирована в базе данных.
Дата | Дата создания рекламы.
Название | В поле указывается название рекламы и её вид.
Создал | Имя пользователя, создавшего рекламу.
Действия В поле присутствует кнопка для выполнения действия над рекламой:
  • Опубликовать;
  • На паузу;
  • Продолжить.
А также выводится информация о дате и времени совершенного действия.
Статус В каком статусе находится реклама:
  • Отправляется;
  • На паузе;
  • Отменена.
А также показывается количество получателей рекламы, которым выполнена отправка, в % процентах.
Статистика | Переход к просмотру статистики по получателям. При нажатии на ссылку открывается [dw]статистика[/dw][di]Отображается таблица со статистикой по каждому получателю с возможностью фильтрации и поиска, а также экспорта данных в MS Excel.[/di] по получателям рассылки.

Смотрите также

  • Реклама в поисковиках и соцсетях (учебный курс "Продвижение сайта и маркетинг") [image].


Персонализация

На странице Персонализация (Маркетинг > Персонализация) выполняется проверка доступен ли сервис 1С-Битрикс BigData для использования и размещен ли на сайте компонент персонализации.

Чтобы сервис рекомендаций был доступен для использования, в настройках главного модуля должна быть отмечена опция Использовать сервис рекомендаций товаров.

Смотрите также:

  • Персонализация (учебный курс "Администратор. Бизнес")


A/B-тестирование

Возможность проведения A/B-тестов представлена специальным модулем А/B-тестирование (abtest).

A/B-тестирование - один из эффективных методов маркетингового исследования, суть которого в сравнении двух представлений выбранной страницы или дизайна сайта, для того чтобы выяснить насколько изменения повысят конверсию.

Примером может служить исследование влияния цветовой схемы кнопки купить, ее расположения и размера на конверсию сайта.

Смотрите также

  • Глава A/B тестирование [image] в курсе «Администратор. Модули».


Список A/B-тестов

На странице A/B-тестирование (Маркетинг > A/B-тестирование) представлена таблица, содержащая список всех доступных в системе A/B-тестов, а также шаблоны готовых тестов, на основе которых можно составить и провести свое А/B-тестирование.

Контекстная панель

Кнопка | Описание
Новый тест | Переход к форме добавления нового A/B-теста.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список A/B-тестов

Поле | Описание
Действия Действия над A/B-тестом:
  • Запустить - запустить A/B-тест;
  • Остановить - остановить A/B-тест;
  • Отчет - открытие страницы отчета о выполнении А/B-теста. Действие активно, только если A/B-тест был запущен хотя бы раз;
  • Изменить - редактирование A/B-теста;
  • Удалить - удаление A/B-теста.
Название | В поле отображается наименование теста и его описание, если заполнено.
Статус Вывод информации о статусе A/B-теста. В зависимости от того, запущен тест или нет, информация в этом поле меняется:
  • Тест запущен. Отображается индикатор зеленого цвета, статус Запущен, дата запуска и [dw]ожидаемая дата завершения[/dw][di]Ожидаемая дата завершения рассчитывается на основе значения параметра Длительность теста, установленного для A/B-теста.[/di], а также какой пользователь запустил тестирование. Кнопка Остановить позволяет остановить A/B-тест;
  • Тест не запущен. Отображается индикатор серого цвета, статус Ожидает. Кнопка Запустить позволяет запустить A/B-тест.

    Примечание: если тест уже был ранее запущен и остановлен, то дополнительно будет отображена дата завершения теста и пользователь, которым он остановлен.


Создание и редактирование A/B-теста

Данная форма служит для создания нового или редактирования существующего A/B-теста.

Контекстная панель

Кнопка | Описание
Список тестов | Переход на страницу со списком существующих A/B-тестов.
Новый тест | Переход к форме создания нового теста. Кнопка отображается при редактировании существующего теста.
Удалить | Удаление редактируемого теста. Кнопка отображается при редактировании существующего теста.

Общие параметры

Поле | Описание
Сайт | Сайт, для которого будет применен A/B-тест.
Название | Название теста. Если оставить поле пустым, то при сохранение название сгенерируется автоматически по шаблону Тест #[ID], где ID - идентификатор A/B-теста в системе.
Описание | Текстовое описание теста. Описание будет отражено в колонке Название в списке тестов.
Длительность теста | Из списка выбирается продолжительность выполнения теста, по окончании которой тест будет автоматически завершен (если не остановлен ранее вручную).
Трафик на тест | Указывается процент пользователей, которые участвуют в тестировании. Эта цифра означает [dw]общее количество[/dw][di]Половина от трафика будет направлена на текущий дизайн, а половина - на новый. Если указано 30%, то новый дизайн увидят только 15%.[/di] пользователей, участвующих в тестировании.
кнопка Добавить тест По нажатии кнопки появляется список вариантов теста:
  • Шаблон сайта - в тесте сравниваются шаблоны сайта. Шаблон применяется ко всему сайту.

    Если в одном А/В тестировании есть несколько тестов, направленных на сравнение шаблонов, то проверяться будут условия только первого теста.

  • Страница - в тесте сравниваются указанные страницы.

После выбора варианта, добавляется новый тест. Тестов может быть несколько. Для каждого теста нужно указать вариант А и B. Вариант А - это то, что видят все посетители сайта на данный момент, вариант В - то, что будет тестироваться.

Смотрите также

  • Настройки и запуск тестирования (учебный курс "Администратор. Модули") [image];
  • Пример A/B-тестирования страниц (учебный курс "Администратор. Модули") [image].


Автоконтекст

Страницы модуля
Название | Описание
Яндекс.Директ | Служит для управления рекламными кампаниями и объявлениями Яндекс.Директ.


Яндекс. Директ

Страницы модуля
Название | Описание
Яндекс.Директ | Служит для управления рекламными кампаниями Яндекс.Директ.
Редактирование рекламного объявления | Позволяет редактировать рекламные объявления Яндекс.Директ.
Редактирование рекламной кампании | Позволяет редактировать рекламные кампании Яндекс.Директ.
Управление объявлениями рекламной кампании | Служит для управления объявлениями рекламной кампании.


Яндекс.Директ

Страница Яндекс.Директ (Маркетинг > Автоконтекст > Яндекс.Директ) служит для управления рекламными кампаниями Яндекс.Директ.

Данные авторизации

Если данные об авторизации отсутствуют, то необходимо нажать кнопку Авторизоваться в Яндексе и ввести логин и пароль пользователя Яндекс. Затем следует скопировать код подтверждения, ввести его в появившееся поле и нажать кнопку Отправить. Отобразится информация о пользователе.

Сменить пользователя Яндекс можно с помощью соответствующей ссылки сменить авторизацию.

Контекстная панель

Кнопка | Описание
+Добавить | Служит для добавления новой кампании.
Обновить из Яндекс.Директ | Получение обновления списка кампаний из Яндекс.Директ.
Архив | Переход к просмотру архивных рекламных кампаний.
Настроить | Переход к настройке внешнего вида списка.
Excel | Выгрузка данных из отображаемого списка в Excel.

Список рекламных кампаний

Таблица списка рекламных кампаний отображает все кампании, размещенные в Яндекс.Директ. Помимо этого, правая колонка таблицы списка (Действия) содержит ссылки-команды управления конкретной кампанией. При помощи этих команд кампании могут быть отредактированы, обновлены, удалены и т.д.

Поле таблицы | Описание
Меню действий
  • Редактировать [image] - редактирование основных настроек, стратегии показов, статистики рекламной кампании.
  • Обновить - обновление информации о кампании.
  • Объявления [image] - переход к списку объявлений данной кампании.
  • Приостановить/Разрешить показ - временная остановка или возобновление показа данной рекламной кампании.
  • Архивировать - перемещение кампании в архив.
  • Удалить - удаление кампании.
ID | Идентификатор кампании, под которым она зарегистрирована в вашем списке.
Статус | Статус рекламной кампании в Яндекс.Директ.
Название рекламной кампании | Стандартное название кампании от Яндекс.Директ. Обычно включает дату создания кампании.
Номер | Уникальный номер кампании, заданный Яндекс.Директ. Изменению не подлежит. Является ссылкой, по которой можно перейти к редактированию параметров кампании на Яндекс.Директ.
Стратегия показа объявлений Выбор инструмента для привлечения целевой аудитории. В настоящее время поддерживаются следующие автоматические стратегии:
  • Недельный бюджет - заданный на неделю бюджет распределяется таким образом, чтобы на сайт перешло как можно больше посетителей.
  • Недельный пакет кликов - позволяет каждую неделю по минимальной цене получать определенное количество переходов на сайт.
  • Средняя цена клика - позволяет получить максимум кликов по средней цене, которую вы готовы платить за посетителя.
Обновлено | Дата и время обновления кампании.
Объявления | Количество объявлений в данной рекламной кампании. Клик по цифре позволяет перейти к списку объявлений, клик по плюсу - к добавлению объявления.
Показ разрешен | Индикатор активности данной рекламной кампании, переключается с помощью пункта меню действий Приостановить/Разрешить показ.
Расходы, у.е. | Сумма средств, зачисленных на баланс кампании за время ее существования.
Остаток, у.е. | Текущий баланс кампании.
Показы | Количество показов за время существования кампании.
Клики | Количество кликов за время существования кампании.
Кнопка Обновить | Обновляет информацию о кампании. Двойной клик позволяет перейти к редактированию рекламной кампании.


Редактирование рекламного объявления

Закладки

Переход к странице редактирования рекламного объявления осуществляется по ссылке Редактировать в Меню Действий или по двойному клику на кнопке Обновить.

Контекстная панель

Кнопка | Описание
Список объявлений | Возврат к списку объявлений.
+Добавить | Переход к форме создания рекламного объявления.
Удалить | Удаление редактируемого объявления.

Объявление

Настройка основных параметров объявления.

Поле | Описание
Статус | Текущий статус объявления. Может быть обновлен в соответствии с состоянием в Яндекс.Директ.
Ваше объявление | Название объявления. Может быть отредактировано. Дополнительное поле для ввода текста объявления. Дополнительное поле для отображения внешнего вида объявления в Яндексе. Цифры рядом с полями показывают, сколько символов еще доступно для ввода текста.
Ссылка в объявлении | Автоматически формируемая ссылка, по которой можно отслеживать статистику показа объявления.
Привязанные объекты | Перечень привязанных к объявлению элементов инфоблоков и ссылка привязать, по которой осуществляется переход к поиску и выбору элемента для привязывания.

Геотаргетинг

Настройка параметров географического таргетинга объявления.

Поле для отображения перечня доступных местоположений, их выбора и/или исключения, отображения выбранных/исключенных местоположений.

Ключевые слова

Выбор ключевых слов для показа объявления.

Поле для подбора слов или словосочетаний. Ключевые слова вводятся через запятую или в новой строке. Минус-слова вводятся со знаком "-" перед ними.

Кнопка для отображения поисковой статистики Яндекса. Сгенерированный отчет по статистике поиска отображает частоту запросов по выбранным ключевым словам и фразам, содержащим ключевые слова, а также что еще искали люди, искавшие ключевые слова.

Кнопка для отображения прогноза бюджета. Сгенерированный отчет по выбранным ключевым словам содержит прогноз показов, кликов, стоимости/цены кликов по каждой фразе и суммарно.

Возможно поменять приоритет и размещение объявления в поисковой выдаче Яндекса. Также возможно задать дополинтельные минус-слова для объявления.

Статистика

Информация, отображаемая в Статистике показов объявления, аналогична информации, отображаемой на закладке Статистика [image] рекламной кампании.


Редактирование рекламной кампании

Закладки

Переход к странице редактирования рекламной кампании осуществляется по ссылке Редактирование в Меню Действий или по двойному клику на кнопке Обновить.

Контекстная панель

Кнопка | Описание
Список кампаний | Возврат к списку кампаний.
+Добавить кампанию | Переход к форме добавления новой рекламной кампании.
+Добавить объявление | Переход к форме добавления объявления.
Список объявлений | Переход к таблице списка объявлений.
Удалить | Удаление редактируемой кампании.

Кампания

Поле | Описание
Статус | Текущий статус рекламной кампании. Может быть обновлен в соответствии с состоянием в Яндекс.Директ.
Название рекламной кампании | Название кампании. Может быть отредактировано.
ФИО владельца рекламной кампании | Имя и фамилия, заданные в Персональных данных аккаунта на Яндекс. Изменение ФИО владельца не влияет на данные аккаунта Яндекс.
Начало рекламной кампании | Дата начала рекламной кампании.
E-mail для уведомлений Адрес электронной почты для отправки уведомлений о событиях, связанных с кампанией. При изменении e-mail новый адрес добавляется к контактным адресам электронной почты аккаунта Яндекc.

Настройки e-mail уведомлений включают в себя:

  • Уведомлять при уровне остатка средств на кампании - задается остаток средств (в процентах) от последней оплаты.
  • Получать предупреждения о смене позиции - задается возможность и интервал (в минутах) получения предупреждений о смене позиции, на которой показывается объявление.

Стратегия показов

Настройка одной из трех поддерживаемых автоматических стратегий показов объявлений кампании. В зависимости от выбора стратегии предлагаются дополнительные настройки.

Стоимость клика (бюджета) задается в у.е. - условных единицах Яндекса.

Изменение ставок, бюджета, количества кликов в модуле Контекстная реклама отображается в Яндекс.Директ, и наоборот - изменения в Яндекс.Директ переносятся в модуль при обновлении кампании или списка кампаний.

Статистика

Поле/Кнопка | Описание
Общая статистика
  • Расходы, у.е. - сумма средств, зачисленных на баланс кампании за время ее существования.
  • Остаток, у.е. - текущий баланс кампании.
  • Показы - количество показов за время существования кампании.
  • Клики - количество кликов за время существования кампании.
Статистика по времени Выбор и настройка периода, за который отображается статистика:
  • Интервал - задаются даты начала и конца периода отображения статистики. Возможно использование элемента Календарь.
  • Прошлая неделя
  • Прошлый месяц

Выбор из списка сущности, отображаемой на графике:

  • Затраты
  • Показы
  • Клики
Показать | Загрузка статистики и отображение её на графике в соответствии с настройками.
Легенда графика Включение/выключение отображения на графике в соответствующем цвете:
  • Клики (поиск и контекстная реклама)
  • Клики (поиск)
  • Клики (контекстная реклама)


Управление объявлениями рекламной кампании

Переход к списку объявлений рекламной кампании осуществляется по ссылке Объявления в Меню Действий списка рекламных кампаний или по кнопке Список объявлений на странице редактирования рекламной кампании.

Контекстная панель

Кнопка | Описание
+Добавить объявление | Служит для добавления нового объявления в текущую кампанию.
Список кампаний | Возврат к списку кампаний.
Редактировать кампанию | Переход к форме редактирования рекламной кампании [image] .
Обновить из Яндекс.Директ | Получение обновления объявлений данной кампании из Яндекс.Директ.
Архив | Переход к просмотру архивных объявлений данной рекламной кампании.
Настроить | Переход к настройке внешнего вида списка.
Excel | Выгрузка данных из отображаемого списка в Excel.

Список объявлений

Таблица списка объявлений кампании отображает все объявления данной кампании, размещенные в Яндекс.Директ. Помимо этого, правая колонка таблицы списка (Действия) содержит ссылки-команды управления конкретным объявлением. При помощи этих команд объявления могут быть отредактированы, обновлены, отправлены на модерацию, архивированы, удалены.

Поле таблицы | Описание
Меню действий
  • Редактировать [image] - редактирование основных параметров, геотаргетинга, ключевых слов, статистики объявления.
  • Обновить - обновление информации об объявлении.
  • Отправить на модерацию - приостановка показа объявления и отправка его на автоматическую модерацию в Яндекс.Директ. После отправки объявления на модерацию, статус его меняется на "Не показывается, ожидает модерации", в меню действий появляется пункт "Приостановить показ".
  • Архивировать - перемещение объявления в архив.
  • Удалить - удаление объявления.
ID | Идентификатор объявления, под которым оно зарегистрировано в вашем списке.
Статус | Статус объявления в Яндекс.Директ.
Название | Заданное вами название объявления.
Номер | Уникальный номер объявления, заданный Яндекс.Директ. Изменению не подлежит. Является ссылкой, по которой можно перейти к редактированию объявления на Яндекс.Директ.
Показ разрешен | Индикатор Да/Нет показа данного объявления в настоящий момент. Переключается в "Нет" при активации пункта меню действий "Приостановить показ", в "Да" при активации "Разрешить показ".
Модерация | Состояние и этап автоматического модерированания (Да/Нет/В процессе/Новое).
Модерация фраз
Обновлено | Дата и время обновления объявления.
Кнопка Обновить | Обновляет информацию об объявлении. Двойной клик позволяет перейти к редактированию рекламного объявления.


Товарный маркетинг

Сущности модуля
Название | Описание
Страницы модуля
Предустановленный список маркетинговых акций | На странице представлены блоки пресетов для создания скидок на товары, доставку и оплату.
Создание и редактирование скидки с помощью мастера | Данная форма служит для создания новой и редактирования существующей скидки, которая была добавлена ранее через мастер пресетов.
Правила работы с корзиной | На странице выведена таблица, содержащая список всех доступных в системе правил работы с корзиной как созданных вручную, так и созданных через мастера пресетов.
Создание и редактирование правил работы с корзиной | Данная форма служит для создания нового или редактирования существующего правила работы с корзиной.
Купоны правил корзины | На странице представлена таблица, содержащая список всех купонов, созданных для имеющихся в системе правил корзины.
Создание и редактирование купона правила корзины | Данная форма служит для создания нового или редактирования существующего купона на правило корзины как созданное вручную, так и через мастер пресетов.
Купоны правил корзины | На странице представлена таблица, содержащая список всех купонов, созданных для имеющихся в системе правил корзины.
Подразделы модуля
Скидки каталога и магазина до конвертации | Содержит страницы с настройками скидок каталога и магазина до конвертации.


Предустановленный список маркетинговых акций

На странице Предустановленный список маркетинговых акций (Маркетинг > Товарный маркетинг > Предустановленный список маркетинговых акций) представлены блоки пресетов для создания скидок на товары, доставку и оплату.

В каждом блоке имеется кнопка Создать, с помощью которой запускается мастер создания скидки. Кнопка Список служит для перехода на страницу со списком правил корзины, отфильтрованным по выбранному пресету скидки.


Создание и редактирование скидки с помощью мастера

Данная форма служит для создания новой и редактирования существующей скидки, которая была добавлена ранее через мастер пресетов. Скидки. Наценки

Контекстная панель

Кнопка | Описание
Список пресетов | Переход на страницу, содержащую полный список пресетов скидок.

Оформи заказ на «n» рублей,
получи скидку

Поле | Описание
Шаг №1
Название скидки | Название скидки (правила работы с корзиной).
Сайт, для которого будет действовать скидка | Выбирается сайт, к заказам которого будет применяться скидка.
Шаг №2
Сумма заказа | Указывается величина суммы заказываемых товаров, начиная с которой будет действовать скидка на заказ.
Скидка на заказ | Указывается величина скидки.
Выводить предсказание, если текущий заказ больше | Указывается величина суммы заказываемых товаров, начиная с которой будет выводится предсказание на получение скидки.
Текст предсказания | Текст предсказания.
Шаг №3
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить применение скидок на текущем уровне приоритетов | При отмеченной опции другие правила с таким же уровнем приоритета, но с большей сортировкой, чем у текущего правила, применяться к заказу не будут.
Прекратить дальнейшее применение правил | При отмеченной опции правила с меньшем приоритетом, чем у текущего правила, не будут применяться к заказу.
Шаг №4
На данном шаге мастера отображается информация об успешном создании скидки.

Скидка на товары,
группы товаров

Поле | Описание
Шаг №1
Название скидки | Название скидки (правила работы с корзиной).
Сайт, для которого будет действовать скидка | Выбирается сайт, к заказам которого будет применяться скидка.
Шаг №2
Скидка | Указывается величина скидки на товары.
Товары | С помощью кнопки Добавить указываются товары, на которые будет распространяться скидка. Если товары не указаны, то скидка будет распространяться на все товары.
Разделы | С помощью кнопки Добавить указываются разделы, на все товары которых будет распространяться скидка.
Шаг №3
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить применение скидок на текущем уровне приоритетов | При отмеченной опции другие правила с таким же уровнем приоритета, но с большей сортировкой, чем у текущего правила, применяться к заказу не будут.
Прекратить дальнейшее применение правил | При отмеченной опции правила с меньшем приоритетом, чем у текущего правила, не будут применяться к заказу.
Шаг №4
На данном шаге мастера отображается информация об успешном создании скидки.

Скидка на
комбинацию товаров

Поле | Описание
Шаг №1
Название скидки | Название скидки (правила работы с корзиной).
Сайт, для которого будет действовать скидка | Выбирается сайт, к заказам которого будет применяться скидка.
Шаг №2
Скидка | Указывается величина скидки на товары, указанные в полях ниже.
Товары | С помощью кнопки Добавить указываются товары, на которые будет распространяться скидка, если в корзине имеются указанные на шаге №3 товары.
Разделы | С помощью кнопки Добавить указываются разделы, на все товары которых будет распространяться скидка, если в корзине имеются указанные на шаге №3 товары.
Текст предсказания | Указывается текст предсказания, отображаемый на детальной странице товаров рядом с кнопкой Купить.
Шаг №3
Товары | С помощью кнопки Добавить указываются товары, при добавлении которых в корзину становится доступной скидка на указанные на шаге №2 товары.
Разделы | С помощью кнопки Добавить указываются разделы, товары из которых необходимо добавить в корзину, чтобы стала доступна скидка на указанные на шаге №2 товары.
Текст предсказания | Указывается текст предсказания, который будет отображаться рядом с кнопкой Купить на детальных страницах инициирующих скидки товаров.
Шаг №4
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить применение скидок на текущем уровне приоритетов | При отмеченной опции другие правила с таким же уровнем приоритета, но с большей сортировкой, чем у текущего правила, применяться к заказу не будут.
Прекратить дальнейшее применение правил | При отмеченной опции правила с меньшем приоритетом, чем у текущего правила, не будут применяться к заказу.
Шаг №5
На данном шаге мастера отображается информация об успешном создании скидки.

Скидка на товары,
зависящая от дня недели

Поле | Описание
Шаг №1
Название скидки | Название скидки (правила работы с корзиной).
Сайт, для которого будет действовать скидка | Выбирается сайт, к заказам которого будет применяться скидка.
Шаг №2
Скидка на заказ | Указывается величина скидки на весь заказ.
Дни недели | Указываются дни недели, по которым скидка будет действовать.
Шаг №3
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить применение скидок на текущем уровне приоритетов | При отмеченной опции другие правила с таким же уровнем приоритета, но с большей сортировкой, чем у текущего правила, применяться к заказу не будут.
Прекратить дальнейшее применение правил | При отмеченной опции правила с меньшем приоритетом, чем у текущего правила, не будут применяться к заказу.
Шаг №4
На данном шаге мастера отображается информация об успешном создании скидки.

Скидка на заказ,
зависящая от дня недели

Поле | Описание
Шаг №1
Название скидки | Название скидки (правила работы с корзиной).
Сайт, для которого будет действовать скидка | Выбирается сайт, к заказам которого будет применяться скидка.
Шаг №2
Скидка | Указывается величина скидки на товары, указанные в полях ниже.
Дни недели | Указываются дни недели, по которым скидка будет действовать.
Товары | С помощью кнопки Добавить указываются товары, на которые будет распространяться скидка. Если товары не указаны, то скидка будет распространяться на все товары.
Разделы | С помощью кнопки Добавить указываются разделы, на все товары которых будет распространяться скидка.
Текст предсказания | Указывается текст предсказания, отображаемый на детальной странице товаров рядом с кнопкой Купить.
Шаг №3
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить применение скидок на текущем уровне приоритетов | При отмеченной опции другие правила с таким же уровнем приоритета, но с большей сортировкой, чем у текущего правила, применяться к заказу не будут.
Прекратить дальнейшее применение правил | При отмеченной опции правила с меньшем приоритетом, чем у текущего правила, не будут применяться к заказу.
Шаг №4
На данном шаге мастера отображается информация об успешном создании скидки.

Наценка на товары,
группы товаров

Поле | Описание
Шаг №1
Название скидки | Название наценки на товары.
Сайт, для которого будет действовать скидка | Выбирается сайт, к заказам которого будет применяться наценка.
Шаг №2
Наценка | Указывается величина наценки на товары, указанные в полях ниже.
Товары | С помощью кнопки Добавить указываются товары, на которые будет распространяться наценка. Если товары не указаны, то наценка будет распространяться на все товары.
Разделы | С помощью кнопки Добавить указываются разделы, на все товары которых будет распространяться наценка.
Шаг №3
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить применение скидок на текущем уровне приоритетов | При отмеченной опции другие правила с таким же уровнем приоритета, но с большей сортировкой, чем у текущего правила, применяться к заказу не будут.
Прекратить дальнейшее применение правил | При отмеченной опции правила с меньшем приоритетом, чем у текущего правила, не будут применяться к заказу.
Шаг №4
На данном шаге мастера отображается информация об успешном создании наценки.

Скидка на доставку
определенных товаров

Поле | Описание
Шаг №1
Название скидки | Название скидки (правила работы с корзиной).
Сайт, для которого будет действовать скидка | Выбирается сайт, к заказам которого будет применяться скидка.
Шаг №2
Скидка на доставку | Указывается величина скидки на доставку.
Служба доставки | Указываются службы доставки, для которых будут действовать скидки.
Товары | С помощью кнопки Добавить указываются товары, при заказе которых будет распространяться скидка на доставку. Если товары не указаны, то скидка на доставку будет доступна для всех товаров.
Разделы | С помощью кнопки Добавить указываются разделы, при заказе товаров которых будет распространяться скидка на доставку.
Шаг №3
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить применение скидок на текущем уровне приоритетов | При отмеченной опции другие правила с таким же уровнем приоритета, но с большей сортировкой, чем у текущего правила, применяться к заказу не будут.
Прекратить дальнейшее применение правил | При отмеченной опции правила с меньшем приоритетом, чем у текущего правила, не будут применяться к заказу.
Шаг №4
На данном шаге мастера отображается информация об успешном создании скидки.

Скидка на
доставку

Поле | Описание
Шаг №1
Название скидки | Название скидки (правила работы с корзиной).
Сайт, для которого будет действовать скидка | Выбирается сайт, к заказам которого будет применяться скидка.
Шаг №2
Сумма заказа | Указывается сумма заказа, начиная с которой будет доступна скидка на доставку.
Скидка на доставку | Указывается величина скидки на доставку.
Служба доставки | Выбирается служба доставки, на которую будет действовать скидка.
Шаг №3
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить применение скидок на текущем уровне приоритетов | При отмеченной опции другие правила с таким же уровнем приоритета, но с большей сортировкой, чем у текущего правила, применяться к заказу не будут.
Прекратить дальнейшее применение правил | При отмеченной опции правила с меньшем приоритетом, чем у текущего правила, не будут применяться к заказу.
Шаг №4
На данном шаге мастера отображается информация об успешном создании скидки.

Бесплатная
доставка

Поле | Описание
Шаг №1
Название скидки | Название скидки (правила работы с корзиной).
Сайт, для которого будет действовать скидка | Выбирается сайт, к заказам которого будет применяться скидка.
Шаг №2
Сумма заказа | Указывается величина суммы заказа, начиная с которой доставка будет бесплатной.
Служба доставки | Выбирается служба доставки, которая будет бесплатная.
Шаг №3
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить применение скидок на текущем уровне приоритетов | При отмеченной опции другие правила с таким же уровнем приоритета, но с большей сортировкой, чем у текущего правила, применяться к заказу не будут.
Прекратить дальнейшее применение правил | При отмеченной опции правила с меньшем приоритетом, чем у текущего правила, не будут применяться к заказу.
Шаг №4
На данном шаге мастера отображается информация об успешном создании скидки.

Скидка на заказ,
зависящая от платежной системы

Поле | Описание
Шаг №1
Название скидки | Название скидки (правила работы с корзиной).
Сайт, для которого будет действовать скидка | Выбирается сайт, к заказам которого будет применяться скидка.
Шаг №2
Скидка | Указывается величина скидки на оплату.
Платежная система | Указывается платежная система, для которой будет действовать скидка.
Шаг №3
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить применение скидок на текущем уровне приоритетов | При отмеченной опции другие правила с таким же уровнем приоритета, но с большей сортировкой, чем у текущего правила, применяться к заказу не будут.
Прекратить дальнейшее применение правил | При отмеченной опции правила с меньшем приоритетом, чем у текущего правила, не будут применяться к заказу.
Шаг №4
На данном шаге мастера отображается информация об успешном создании скидки.

Наценка на заказ,
зависящая от платежной системы

Поле | Описание
Шаг №1
Название скидки | Название наценка.
Сайт, для которого будет действовать скидка | Выбирается сайт, к заказам которого будет применяться наценка.
Шаг №2
Наценка на заказ | Указывается величина наценки на заказ.
Платежная система | Выбирается платежная система, на которую будет действовать наценка.
Шаг №3
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить применение скидок на текущем уровне приоритетов | При отмеченной опции другие правила с таким же уровнем приоритета, но с большей сортировкой, чем у текущего правила, применяться к заказу не будут.
Прекратить дальнейшее применение правил | При отмеченной опции правила с меньшем приоритетом, чем у текущего правила, не будут применяться к заказу.
Шаг №4
На данном шаге мастера отображается информация об успешном создании наценки.

Накопительные
скидки

Поле | Описание
Шаг №1
Название скидки | Название накопительной скидки.
Сайт, для которого будет действовать скидка | Выбирается сайт, к заказам которого будет применяться наценка.
Шаг №2
Величины скидки Указываются диапазоны сумм оплаченных в заданный период заказов и размеры скидок на текущий оформляемый заказ. Скидки указываются либо в процентах, либо в фиксированной сумме. В качестве денежной единицы используется базовая валюта.
Дополнительные поля добавляются по полю Ещё.
Период активности Временной диапазон, за который должны быть накоплены оплаченные заказы.
  • За все время - скидка будет рассчитываться за всё время после первой покупки пользователем
  • За период - укажите период времени за который будет рассчитана скидка.
  • За последние - укажите за сколько последних дней, месяцев, лет должна быть рассчитана скидка.
Не действовать, если есть скидки на товар | Установка флажка исключает товар из скидки, если на товар установлена своя скидка.
Отменять скидки на товар, если накопительная скидка больше | Скидка на товар заменяется накопительной, если накопительная больше, чем скидка на товар.
Шаг №3
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила.
Период активности | Укажите период активности самой скидки.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить применение скидок на текущем уровне приоритетов | При отмеченной опции другие правила с таким же уровнем приоритета, но с большей сортировкой, чем у текущего правила, применяться к заказу не будут.
Прекратить дальнейшее применение правил | При отмеченной опции правила с меньшем приоритетом, чем у текущего правила, не будут применяться к заказу.
Шаг №4
На данном шаге мастера отображается информация об успешном создании накопительной скидки.


Правила работы с корзиной

На странице Правила работы с корзиной (Маркетинг > Товарный маркетинг > Правила работы с корзиной) представлена таблица, содержащая список всех доступных в системе правил работы с корзиной.

Форма поиска

На странице отображаются и созданные вручную правила, и созданные через мастер пресетов.

С помощью данной формы вы можете выполнить поиск скидок в соответствии с указанными условиями.

Поле | Описание
Сайт | Указывается сайт, к заказам которого могут быть применены выбираемые правила.
Активность | Поиск правила по признаку активности.

Чтобы отобрать правила по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех правил нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить правило | Переход к форме добавления нового правила вручную.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список правил

Поле | Описание
Колонка флажков | Поле предназначено для выбора правил, к которым предполагается применить какое-либо действие.
Действия Действия над правилом:
  • Изменить - редактирование правила. Если правило было добавлено через мастер пресетов, то откроется соответствующая форма мастера.
  • Копировать - создание нового правила путем копирования параметров существующего (недоступно для скидок, созданных через мастера пресетов);
  • Деактивировать/Активировать - снятие или постановка флага активности для правила;
  • Удалить - удаление правила.
ID | Идентификатор правила.
Сайт | Название сайта(ов), к товарам которого может быть применено данное правило.
Название | Наименование данного правила.
Акт. | Признак активности правила. Если правило неактивно, то оно не может быть применено.
Приоритет применимости | Число приоритета применимости правила. Чем больше приоритет, тем раньше применится правило.
Сорт. | Относительный "вес" правила. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить прим. правил | Значение параметра прекращения применения других правил при активности данного правила.
Прекратить уровень | Значение параметра прекращения применения других скидок на текущем уровне приоритетов.
Показ в каталоге товаров [dw]Вычисляемое значение[/dw][di]Вычисляемое, то есть не изменяемое пользователем.[/di]. Показывает, может ли правило быть [ds]применено в каталоге товаров[/ds][di] Некоторые скидки можно вывести на всех четырёх этапах покупки, а некоторые будут видны только в корзине пользователя и при оформлении заказа.

Определить, будет ли созданная скидка показываться в каталоге товаров, можно в списке всех правил работы с корзиной. Система автоматически проверяет правила и выводит в столбце Показ в каталоге товаров соответствующий результат.

Подробнее [image]...[/di]. Если не может, то применяется только в корзине и заказе. По умолчанию - "нет". Чтобы сменить на "да", надо из правила удалить все условия, завязанные на корзину/заказ, в блоке действий должно быть только одно действие и это действие - не наценка.
Активна с | Дата начала активности правила.
Активна по | Дата окончания активности правила.
Кем изменено | Логин пользователя, последний раз изменявшего правило.
Дата изменения | Дата последнего изменения правила.
Купоны | Признак наличия купонов для правила.


Создание и редактирование правил работы с корзиной

Закладки

Данная форма служит для создания нового или редактирования существующего правила работы с корзиной.

Контекстная панель

Кнопка | Описание
Список правил | Переход на страницу, содержащую полный список правил.
Создать новое правило | Переход к форме создания нового правила. Кнопка отображается при редактировании существующего правила.
Копировать правило | Создание нового правила путем копирования параметров существующего правила. Кнопка отображается при редактировании правила.
Удалить правило | Удаление редактируемого правила. Кнопка отображается при редактировании существующего правила.

Общие параметры

Поле | Описание
ID | Уникальный идентификатор правила. Поле отображается при редактировании существующего правила.
Активность | Признак активности правила.
*Сайт | Название сайта, к заказам которого применяется правило.
Название | Название правила.
Период активности
  • Без ограничений - время действия правила неограничено;
  • Интервал - с помощью календаря вы можете указать дату начала и окончания действия правила.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше индекс сортировки, тем раньше применится правило в рамках одного приоритета.
Прекратить применение скидок на текущем уровне приоритетов При отмеченной опции другие правила с таким же уровнем приоритета, но с большей сортировкой, чем у текущего правила, применяться к заказу не будут.

Прекратить дальнейшее применение правил | При отмеченной опции правила с меньшем приоритетом, чем у текущего правила, не будут применяться к заказу.
* - поля, обязательные для заполнения.

Действия и условия

Поле Описание
Действия
В данной секции для выбранного действия настраиваются условия применения правила.
Добавить действие Выбирается действие:
  • Изменить стоимость доставки.
  • Предоставить подарок.
  • Изменить стоимость товаров в корзине.
все условия Указываются необходимые условия:
  • все условия;
  • любое из условий.
выполнено(ы) Указывается требуемое выполнение выбранных условий:
  • выполнено(ы);
  • не выполнено(ы).
Добавить условие Выбирается условие или группа условий.

Штатные условия
Параметры в корзине
  • Товар в корзине - выбор конкретного товара или торгового предложения.
  • Название товара в корзине - полное наименование товара.
  • Стоимость позиции - суммарная стоимость (цена * количество) товара для позиции в корзине (пример: несколько одинаковых футболок).
  • Цена товара - стоимость единицы товара.
  • Количество товара - количество в шт. для позиции в корзине.
  • Вес позиции - суммарный вес (вес единицы товара * количество) для позиции в корзине.
  • Вес товара - вес единицы товара.
  • Были применены правила корзины - варианты: да или нет. Применять правило, если другие правила корзины уже были применены, или нет.
  • Свойства товара в корзине - правило применяется, если выбранное свойство товара имеет указанный тип.

Поля и характеристики товара в инфоблоке
  • Товар - выбор конкретного товара или торгового предложения.
  • Инфоблок - выбор конкретного инфоблока.
  • Раздел - раздел, к которому привязан товар.
  • Символьный код - символьный код товара.
  • Внешний код - код, используемый для связи элемента инфоблока с внешним источником данных.
  • Название - название товара, как оно отображается в публичной части.
  • Начало активности - начало периода активности товара.
  • Окончание активности - окончание периода активности товара.
  • Сортировка - вес сортировки товара (чем меньше вес сортировки, тем выше отображается товар).
  • Описание для анонса - краткое описание товара.
  • Детальное описание - подробное описание товара.
  • Дата создания - дата создания товара.
  • Автор - пользователь, создавший товар.
  • Дата изменения - дата изменения товара.
  • Изменивший - пользователь, изменивший товар.
  • Теги - слова или словосочетания, с помощью которых формируется поиск по тегам.
  • Количество товара на складе - остаток товара на складах в данный момент.
  • Вес товара - вес единицы товара.
  • НДС - размер ставки НДС.
  • НДС включен в цену - варианты: да или нет.
  • Тип цен - выбор из доступных типов цен товара.

Примечание: Также в качестве условия можно использовать [ds]свойства[/ds][di] При создании и товаров, и торговых предложений необходимо указать их свойства (например, артикул, производитель, материал, цвет, размеры, масса и т.д.).

Подробнее [image]...[/di] инфоблока товаров или торговых предложений.

Дополнительные условия
все условия Указываются необходимые условия:
  • все условия;
  • любое из условий.
выполнено(ы) Указывается требуемое выполнение выбранных условий:
  • выполнено(ы);
  • не выполнено(ы).
Добавить условие Выбирается условие или группа условий.

Штатные условия
Дополнительные условия
  • Сумма оплаченных заказов - сумма ранее оплаченных заказов (можно указать период).
  • Количество товаров - суммарное количество всех товаров в корзине.
  • Общая стоимость товаров - общая стоимость всех товаров с учетом уже примененных правил корзины.
  • Общая исходная стоимость товаров - общая стоимость всех товаров до применения правил корзины.
  • Товары - в корзине/заказе есть/отсутствуют товары, удовлетворяющие указанным условиям.
  • Количество позиций - необходимоe для действия правила количество различных позиций товара в корзине.

Параметры заказа
  • Общая сумма заказа с доставками и налогами - общая сумма заказа, включая НДС и стоимость доставки.
  • Тип плательщика - тип плательщика, оформляющего заказ.
  • Платежная система - выбранная платёжная система.
  • Служба доставки - выбранная служба доставки.
  • Общий вес заказа - суммарный вес всех товаров заказа.

Предыдущий оплаченный заказ
  • Общая сумма заказа с доставками и налогами - общая сумма заказа, включая НДС и стоимость доставки.
  • Тип плательщика - тип плательщика, оформляющего заказ.
  • Платежная система - выбранная платёжная система.
  • Служба доставки - выбранная служба доставки.
  • Общий вес заказа - суммарный вес всех товаров заказа.

Пользователь
  • Пользователь - конкретный пользователь сайта.
  • Группы - группа пользователей сайта.

Общие условия
  • День недели - день недели, в который при оформлении заказа будет действовать данное правило.

Ограничения

Поле | Описание
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила. Если ни одна группа не выбрана, то правило будет доступно для пользователей всех групп.

Купоны

Поле Описание
Создать купоны при сохранении правила Опция доступна только при создании нового правила и, если она отмечена, то становятся доступными [dw]дополнительные поля.[/dw][di]
  • Число купонов - число купонов выбранного ниже типа для данного правила.
  • Период активности - указывается период активности купона:
    • Без ограничений - время действия купона неограничено;
    • Интервал - указывается дата начала и окончания действия купона.
    Обратите внимание, что в купоне в первую очередь учитывается период активности самого правила.
  • Тип купонов - указывается тип купонов правила:
    • на одну позицию заказа;
    • на один заказ;
    • многоразовый купон.
  • Максимальное число использований - указывается количество, определяющее сколько раз может быт применен многоразовый купон.
[/di]
В форме редактирования правила выводится список купонов. На закладке можно добавить новые купоны к правилу по кнопке Добавить или с помощью одноименной кнопки обновить список купонов.

Дополнительно

Поле | Описание
Внешний код | Символьный код, используемый для связи правила с внешним источником данных.


Купоны правил корзины

На странице Купоны правил корзины (Маркетинг > Товарный маркетинг > Купоны) представлена таблица, содержащая список всех купонов, созданных для имеющихся в системе правил корзины.

Данная страница служит для добавления новых купонов, для отображения и перехода к управлению параметрами существующих купонов.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме добавления нового купона для правила корзины.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в формат MS Excel.

Список купонов

Поле | Описание
Колонка флажков | Поле предназначено для выбора купонов, к которым предполагается применить какое-либо правило или действие.
Действия Действия над купоном:
  • Редактировать - редактирование купона;
  • Копировать - создание нового купона путем копирования параметров существующего.
  • Деактивировать/Активировать - снятие или постановка флага активности для купона;
  • Удалить - удаление купона.
ID | Идентификатор купона.
Правило | Название правила, для которого создан купон.
Купон | Код купона.
Активность | Признак активности купона. Если купон активен, то он может быть использован при покупке товаров. Одноразовый купон после использования становится неактивным.
Активен с | Дата и время, начиная с которого купон активен.
Активен по | Дата и время, по которое купон активен.
Тип купона | Вид купона.
Сколько использовать | Максимальное число использований купона.
Был использован | Количество использований купона из заданного максимального числа.
Владелец | Пользователь, к которому привязан купон.
Дата использования | Дата и время использования купона.
Кто изменил | Пользователь, последний раз вносивший изменения в параметры купона.
Дата изменения | Дата и время последнего изменения купона.
Кто создал | Пользователь, создавший купон.
Дата создания | Дата и время создания купона.
Комментарий | Комментарий по купону.


Создание и редактирование купона правила корзины

Данная форма служит для создания нового или редактирования существующего купона на правило корзины как созданное вручную, так и через мастер пресетов.

Контекстная панель

Кнопка | Описание
Список купонов | Переход на страницу, содержащую полный список купонов правил корзины.
Добавить новый | Переход к форме создания нового купона. Кнопка отображается при редактировании существующего купона.
Скопировать | Создание нового купона путем копирования параметров редактируемого купона. Кнопка отображается при редактировании существующего купона.
Удалить | Удаление редактируемого купона. Кнопка отображается при редактировании существующего купона.

Форма редактирования

Поле | Описание
ID | Уникальный идентификатор купона. Поле отображается при редактировании существующего купона.
*Активность | Признак активности купона.
*Правило корзины | В выпадающем списке выбирается одно из имеющихся в системе правил корзины, к которому будет относиться создаваемый купон.
*Купон | Код купона вводится вручную или генерируется по кнопке Сгенерировать код.
*Тип купона Указывается вид купона:
  • на одну позицию заказа - купон можно применить только к одному товару и только один раз. Если в заказе несколько товаров, то купон применяется к самому дорогому товару;
  • на один заказ - купон можно применить один раз на [dw]один любой заказ[/dw][di]Если один покупатель использовал такой купон в заказе, то другие покупатели воспользоваться им уже не смогут.[/di];
  • многоразовый - купон может применяться к заказам неограниченное количество раз (в том числе и [dw]одним покупателем[/dw][di]Функционал Многоразового купона, который может быть применён каждым пользователем один раз, пока не реализован.[/di]).
Период активности
  • Без ограничений - время действия купона не ограничено;
  • Интервал - указывается дата начала и окончания действия купона.
Обратите внимание, что в купоне в первую очередь учитывается период активности самого правила.
Владелец купона | Пользователь, к которому привязан купон. Если пользователь не задан, то купон может применить любой пользователь.
Максимальное число использований | Указывается количество, определяющее сколько раз может быт применен многоразовый купон. Поле доступно, если выбран тип купона многоразовый.
Комментарий | Пояснение к купону.
* - поля, обязательные для заполнения.


Скидки каталога и магазина до конвертации

Страницы подраздела
Название | Описание
Скидки на товар | На странице представлена таблица, содержащая список всех доступных в системе скидок, используемых для приобретения товаров по льготной цене. Данная страница служит для добавления новых скидок, а также для перехода к управлению их параметрами.
Создание и редактирование скидки на товар | Данная форма служит для создания новой или редактирования существующей скидки.
Купоны скидок на товар | На странице выводится таблица, содержащая список всех купонов, созданных для имеющихся в системе скидок.
Создание и редактирование купона | Данная форма служит для создания нового или редактирования существующего купона. Примечание: купон представляет собой разновидность скидки. Его отличие заключается в том, что купон - это уникальная последовательность символов, случайно сгенерированная. Правом на получение скидки по купону обладает покупатель, которому каким-либо образом была сообщена данная уникальная последовательность символов.
Правила работы с корзиной | Данная страница служит для добавления новых правил, а также для перехода к управлению их параметрами.
Создание и редактирование правила работы с корзиной | Данная форма служит для создания нового или редактирования существующего правила работы с корзиной.
Купоны правил корзины | Страница служит для добавления новых купонов, для отображения и перехода к управлению параметрами существующих купонов.
Создание и редактирование купона правила корзины | Данная форма предназначена для создания нового или редактирования существующего купона на правило корзины.
Накопительные скидки | С помощью данной формы Вы можете выполнить поиск накопительных скидок в соответствии с указанными условиями.
Создание и редактирование накопительной программы | Даная форма предназначена для создания новых и изменения параметров уже существующих накопительных программ.


Скидки на товар

На странице Скидки и купоны (Маркетинг > Товарный маркетинг > Скидки на товар > Скидки на товар) представлена таблица, содержащая список всех доступных в системе скидок, используемых для приобретения товаров по льготной цене. Данная страница служит для добавления новых скидок, а также для перехода к управлению их параметрами.

Форма поиска

С помощью данной формы вы можете выполнить поиск скидок в соответствии с указанными условиями.

Поле | Описание
Сайт | Указывается сайт, к товарам которого могут быть применены выбираемые скидки.
Активность | Признак активности скидки. Если скидка активна, то она может быть использована при покупке товара.
Активна в период (DD.MM.YYYY) В данных полях можно указать период активности скидки. Период активности может быть задан одним из следующих способов:
  • с помощью указания количества дней, прошедших со дня присвоения скидке статуса Активна;
  • с помощью задания дат начала и конца периода активности.
Название* | Название скидки.
Купон | Код купона.
На продление Указывается, какие скидки будут участвовать в поиске:
  • да - в поиске будут участвовать скидки, используемые при продлении подписки на контент сайта;
  • нет - в поиске не будут участвовать скидки, используемые при продлении подписки на контент сайта;
  • все- в поиске будут участвовать все скидки, в т.ч. используемые для продления подписки.
Величина | В полях для ввода данного условия можно указать минимальное и максимальное значение скидки.Фильтр по введенным значениям будет применен ко всем скидкам вне зависимости от их типа.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать скидки по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех скидок нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Новая скидка | Переход к форме добавления новой скидки.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список скидок

Поле | Описание
Колонка флажков | Поле предназначено для выбора скидок, к которым предполагается применить какое-либо правило или действие.
Действия Действия над скидкой:
  • Изменить параметры скидки - редактирование скидки;
  • Копировать скидку - копирование скидки.
  • Удалить скидку - удаление скидки.
ID | Идентификатор скидки.
Сайт | Название сайта(ов), к товарам которого может быть применена данная скидка.
Активна с | Дата начала активности скидки.
по | Дата окончания активности скидки.
Акт. | Признак активности скидки. Если скидка неактивна, то она не может быть применена.
Приоритет применимости | Число приоритета применимости скидки.
Название | Название скидки.
Сорт. | Относительный "вес" скидки. Используется для вывода скидки в общем списке.
Величина | Размер предоставляемой скидки.
Продл. | Признак использования скидки для продления подписки на контент сайта.
Кем изменена | Логин пользователя, последний раз изменявшего скидку.
Дата изменения | Дата последнего изменения скидки.

Примечание: сумма скидки вычисляется от конечной цены с уже начисленным НДС.


Создание и редактирование скидки на товар

Закладки

Данная форма служит для создания новой или редактирования существующей скидки.

Примечание: купон представляет собой разновидность скидки. Его отличие заключается в том, что купон - это уникальная последовательность символов, случайно сгенерированная. Правом на получение скидки по купону обладает покупатель, которому каким-либо образом была сообщена данная уникальная последовательность символов.

Контекстная панель

Кнопка | Описание
Список скидок | Переход на страницу, содержащую полный список скидок.
Купоны этой скидки | Переход к форме купонов на скидки с установленным фильтром по названию скидки. Кнопка отображается при редактировании существующей скидки.
Добавить новую скидку | Переход к форме создания новой скидки. Кнопка отображается при редактировании существующей скидки.
Копировать скидку | Переход к форме создания скидки путем копирования параметров текущей скидки. Кнопка отображается при редактировании существующей скидки.
Удалить скидку | Удаление редактируемой скидки. Кнопка отображается при редактировании существующей скидки.

Скидка

Поле | Описание
ID | Уникальный идентификатор скидки. Поле отображается при редактировании существующей скидки.
Активность | Признак активности скидки.
*Название | Название скидки.
Сайт | Название сайта, к товарам которого применяется скидка.
Период активности
  • Без ограничений - время действия скидки неограничено;
  • Интервал - с помощью on-line календаря Вы можете указать дату начала и окончания действия скидки.
*Тип скидки Форма задания скидки:
  • В процентах- скидка задается в процентах от стоимости товара;
  • Фиксированная сумма - будет указана сумма скидки;
  • Установить цену на товар - задается фиксированная цена на товар, которая будет после скидки.
*Величина скидки | Размер скидки. В зависимости от выбранного типа скидки, величина скидки указывается в процентах от стоимости товара или в виде фиксированной суммы/цены.
Валюта скидки | Укажите валюту скидки, если она задана в виде фиксированной суммы/цены.
Максимальная сумма скидки | Максимально возможный размер скидки. Чаще всего значение данного поля задается для типа скидки "в процентах". Максимальная сумма скидки указывается в основной валюте скидки, выбранной в предыдущем поле.
Применяется к продлению подписки | Флаг в данном поле означает, что скидка будет применяться при продлении подписки на доступ к контенту сайта.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применена скидка.
Прекратить дальнейшее применение скидок | При отмеченной опции другие скидки к товару не будут применяться (см. алгоритм применения [image]).
Краткое описание | Данное поле служит для задания краткого описания скидки. Размер описания может составлять не более 255 символов.
* - поля, обязательные для заполнения.

Условия

Поле | Описание
все условия Указываются необходимые условия:
  • все условия;
  • любое из условий.
выполнено(ы) Указывается требуемое выполнение выбранных условий:
  • выполнено(ы);
  • не выполнено(ы).
Добавить условие | Выбирается условие или группа условий.

Ограничения

Поле | Описание
Группы пользователей, которые могут воспользоваться скидкой (если ничего не выделено, то подразумеваются все) | В данном поле выбираются группы пользователей, имеющие право на использование данной скидки. Если ни одна группа не выбрана, то скидка будет доступна для пользователей всех групп.
Типы цен, к которым применима скидка (если ничего не выделено, то подразумеваются все) | В данном поле выбираются типы цен товаров, к которым может быть применена данная скидка. Если ни один тип цен не выбран, то скидка может быть применена ко всем типам цен товаров.

Купоны

Поле Описание
Создать купоны при сохранении параметров скидки При отмеченной опции становятся доступными [dw]дополнительные поля.[/dw][di]
  • Тип купона - указывается тип купона:
    • Купон на одну позицию заказа;
    • Купон на один заказ;
    • Многоразовый купон.
  • Число купонов - число купонов данного типа для данной скидки.
[/di]
Опция отображается только при создании новой скидки.
В форме редактирования скидки выводится список купонов. Список выводится без формы поиска. На закладке можно добавить новые купоны к скидке по кнопке Добавить купон или с помощью одноименной кнопки обновить список купонов.

Дополнительно

Поле | Описание
Внешний код | Символьный код, используемый для связи скидки с внешним источником данных.
Индекс сортировки | Относительный "вес" скидки. Используется для вывода элемента в общем списке.


Купоны скидок на товар

На странице Купоны на скидки (Маркетинг > Товарный маркетинг > Скидки на товар > Купоны скидок на товар) представлена таблица, содержащая список всех купонов, созданных для имеющихся в системе скидок.

Примечание: купон представляет собой разновидность скидки. Его отличие заключается в том, что купон - это уникальная последовательность символов, случайно сгенерированная. Правом на получение скидки по купону обладает покупатель, которому каким-либо образом была сообщена данная уникальная последовательность символов.

Данная страница служит для отображения имеющихся купонов и добавления новых, а также для перехода к управлению их параметрами.

Форма поиска

С помощью данной формы вы можете выполнить поиск скидок в соответствии с указанными условиями.

Поле | Описание
ID | Поиск купона по ID.
Скидка Указывается купоны какой скидки должны быть отображены в отчетной форме. Выбирается одна из имеющихся в системе скидок либо пункт Все, тогда будут отображены купоны всех скидок.

Данное поле отображается, даже если фильтр свернут.
Активность Указывается, какие купоны будут участвовать в поиске:
  • да - в поиске будут участвовать только активные купоны (с отмеченным флагом активности);
  • нет - в поиске будут участвовать только неактивные купоны;
  • все- в поиске будут участвовать все купоны, вне зависимости от флага активности.
Купон | Поиск скидки по коду купона.
Тип купона Указывается тип купона:
  • Все;
  • на одну позицию заказа;
  • на один заказ;
  • многоразовый.
.
Дата применения купона | Поиск скидки по дате применения купона.
Комментарий | Поиск скидки по комментарию к купону.

Чтобы отобрать купоны по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех купонов нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить купон | Переход к форме добавления нового купона.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в формат MS Excel.

Список купонов

Поле | Описание
Колонка флажков | Поле предназначено для выбора купонов, к которым предполагается применить какое-либо правило или действие.
Действия Действия над купоном или скидкой:
  • Изменить параметры купона - редактирование купона;
  • Удалить купон - удаление купона или скидки.
ID | Идентификатор купона.
Название скидки | Название скидки, для которой создан купон.
Активность | Признак активности купона. Если купон активен, то он может быть использован при покупке товара. Одноразовый купон после использования становится неактивным.
Купон | Сгенерированная последовательность символов, составляющая купон.
Дата применения купона | Дата и время, когда купон был использован. Автоматически устанавливается после применения одноразового купона.
Тип купона | Вид купона.
Кем изменен | Логин сотрудника, последний раз вносившего изменения в параметры купона.
Дата изменения | Дата последнего изменения купона.


Создание и редактирование купона

Данная форма служит для создания нового или редактирования существующего купона.

Примечание: купон представляет собой разновидность скидки. Его отличие заключается в том, что купон - это уникальная последовательность символов, случайно сгенерированная. Правом на получение скидки по купону обладает покупатель, которому каким-либо образом была сообщена данная уникальная последовательность символов.

Контекстная панель

Кнопка | Описание
Список купонов | Переход на страницу, содержащую полный список купонов.
Добавить новый купон | Переход к форме создания нового купона. Кнопка отображается при редактировании существующего купона.
Удалить купон | Удаление редактируемого купона. Кнопка отображается при редактировании существующего купона.

Форма редактирования

Поле | Описание
ID | Уникальный идентификатор купона. Поле отображается при редактировании существующей скидки.
*Скидка | В выпадающем списке выбирается одна из имеющихся в системе скидок, к которой будет относиться создаваемый купон.
Активность | Признак активности купона.
Тип купона Указывается вид купона:
  • Купон на одну позицию заказа - купон можно применить только к одному товару и только один раз. Если в заказе несколько товаров, то купон применяется к самому дорогому товару;
  • Купон на один заказ - купон можно применить один раз на [dw]один любой заказ[/dw][di]Если один покупатель использовал такой купон в заказе, то другие покупатели воспользоваться им уже не смогут.[/di];
  • Многоразовый купон - купон может применяться к заказам неограниченное количество раз (в том числе и [dw]одним покупателем[/dw][di]Функционал Многоразового купона, который может быть применён каждым пользователем один раз, пока не реализован.[/di]).
*Код купона | Код купона генерируется по кнопке Сгенерировать код.
Дата применения купона: (DD.MM.YYYY) | Дата и время, когда купон был использован. Автоматически устанавливается после применения одноразового купона.
Комментарий | Пояснение к купону.
* - поля, обязательные для заполнения.


Правила работы с корзиной

На странице Правила работы с корзиной (Маркетинг > Товарный маркетинг > Правила работы с корзиной > Правила работы с корзиной) представлена таблица, содержащая список всех доступных в системе правил работы с корзиной, используемых для создания различных скидок на заказ. Данная страница служит для добавления новых правил, а также для перехода к управлению их параметрами.

Форма поиска

С помощью данной формы вы можете выполнить поиск скидок в соответствии с указанными условиями.

Поле | Описание
Сайт | Указывается сайт, к заказам которого могут быть применены выбираемые правила.
Активность | Поиск правила по признаку активности.

Чтобы отобрать правила по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех правил нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить правило | Переход к форме добавления нового правила.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список правил

Поле | Описание
Колонка флажков | Поле предназначено для выбора правил, к которым предполагается применить какое-либо действие.
Действия Действия над правилом:
  • Изменить - редактирование правила;
  • Копировать - создание нового правила путем копирования параметров существующего;
  • Деактивировать/Активировать - снятие или постановка флага активности для правила;
  • Удалить - удаление правила.
ID | Идентификатор правила.
Сайт | Название сайта(ов), к товарам которого может быть применено данное правило.
Название | Наименование данного правила.
Акт. | Признак активности правила. Если правило неактивно, то оно не может быть применено.
Приоритет применимости | Число приоритета применимости правила.
Сорт. | Относительный "вес" правила. Используется при выводе правила в общем списке.
Прекратить прим. правио | Значение параметра прекращения применения других правил при активности данного правила.
Активна с | Дата начала активности правила.
Активна по | Дата окончания активности правила.
Кем изменено | Логин пользователя, последний раз изменявшего правило.
Дата изменения | Дата последнего изменения правила.
Купоны | Признак наличия купонов для правила.

Смотрите также

  • Примеры настройки правил корзины


Создание и редактирование правила работы с корзиной

Закладки

Данная форма служит для создания нового или редактирования существующего правила работы с корзиной.

Контекстная панель

Кнопка | Описание
Список правил | Переход на страницу, содержащую полный список правил.
Создать новое правило | Переход к форме создания нового правила. Кнопка отображается при редактировании существующего правила.
Копировать правило | Создание нового правила путем копирования параметров существующего правила. Кнопка отображается при редактировании правила.
Удалить правило | Удаление редактируемого правила. Кнопка отображается при редактировании существующего правила.

Общие параметры

Поле | Описание
ID | Уникальный идентификатор правила. Поле отображается при редактировании существующего правила.
Активность | Признак активности правила.
*Сайт | Название сайта, к заказам которого применяется правило.
Название | Название правила.
Период активности
  • Без ограничений - время действия правила неограничено;
  • Интервал - с помощью календаря вы можете указать дату начала и окончания действия правила.
Приоритет применимости | Чем выше числовое значение приоритета, тем раньше будет применено правило.
Индекс сортировки | Определяет порядок применения правил с одинаковым приоритетом. Чем меньше значение индекса - тем раньше будет применено правило.
Прекратить дальнейшее применение правил | При отмеченной опции другие правила не будут применяться к заказу (см. алгоритм применения [image]).
* - поля, обязательные для заполнения.

Действия и условия

Поле Описание
Действия
Добавить действие Выбирается действие:
  • Изменить стоимость доставки.
  • Изменить стоимость товаров в корзине.
  • Предоставить подарок.
все условия Указываются необходимые условия:
  • все условия;
  • любое из условий.
выполнено(ы) Указывается требуемое выполнение выбранных условий:
  • выполнено(ы);
  • не выполнено(ы).
Добавить условие Выбирается условие или группа условий.

Штатные условия
Параметры в корзине
  • Товар в корзине - выбор конкретного товара или торгового предложения.
  • Название товара в корзине - полное наименование товара.
  • Стоимость позиции - суммарная стоимость (цена * количество) товара для позиции в корзине (пример: несколько одинаковых футболок).
  • Цена товара - стоимость единицы товара.
  • Количество товара - количество в шт. для позиции в корзине.
  • Вес позиции - суммарный вес (вес единицы товара * количество) для позиции в корзине.
  • Вес товара - вес единицы товара.
  • Были применены правила корзины - варианты: да или нет. Применять правило, если другие правила корзины уже были применены, или нет.
  • Свойства товара в корзине - правило применяется, если выбранное свойство товара имеет указанный тип.

Поля и характеристики товара в инфоблоке
  • Товар - выбор конкретного товара или торгового предложения.
  • Инфоблок - выбор конкретного инфоблока.
  • Раздел - раздел, к которому привязан товар.
  • Символьный код - символьный код товара.
  • Внешний код - код, используемый для связи элемента инфоблока с внешним источником данных.
  • Название - название товара, как оно отображается в публичной части.
  • Начало активности - начало периода активности товара.
  • Окончание активности - окончание периода активности товара.
  • Сортировка - вес сортировки товара (чем меньше вес сортировки, тем выше отображается товар).
  • Описание для анонса - краткое описание товара.
  • Детальное описание - подробное описание товара.
  • Дата создания - дата создания товара.
  • Автор - пользователь, создавший товар.
  • Дата изменения - дата изменения товара.
  • Изменивший - пользователь, изменивший товар.
  • Теги - слова или словосочетания, с помощью которых формируется поиск по тегам.
  • Количество товара на складе - остаток товара на складах в данный момент.
  • Вес товара - вес единицы товара.
  • НДС - размер ставки НДС.
  • НДС включен в цену - варианты: да или нет.
  • Тип цен - выбор из доступных типов цен товара.

Примечание: Также в качестве условия можно использовать [ds]свойства[/ds][di] При создании и товаров, и торговых предложений необходимо указать их свойства (например, артикул, производитель, материал, цвет, размеры, масса и т.д.).

Подробнее [image]...[/di] инфоблока товаров или торговых предложений.

Дополнительные условия
все условия Указываются необходимые условия:
  • все условия;
  • любое из условий.
выполнено(ы) Указывается требуемое выполнение выбранных условий:
  • выполнено(ы);
  • не выполнено(ы).
Добавить условие Выбирается условие или группа условий.

Штатные условия
Дополнительные условия
  • Сумма оплаченных заказов - сумма ранее оплаченных заказов (можно указать период).
  • Количество товаров - суммарное количество всех товаров в корзине.
  • Общая стоимость товаров - общая стоимость всех товаров с учетом уже примененных правил корзины.
  • Общая исходная стоимость товаров - общая стоимость всех товаров до применения правил корзины.
  • Товары - в корзине/заказе есть/отсутствуют товары, удовлетворяющие указанным условиям.
  • Количество позиций - необходимоe для действия правила количество различных позиций товара в корзине.

Параметры заказа
  • Общая сумма заказа с доставками и налогами - общая сумма заказа, включая НДС и стоимость доставки.
  • Тип плательщика - тип плательщика, оформляющего заказ.
  • Платежная система - выбранная платёжная система.
  • Служба доставки - выбранная служба доставки.
  • Общий вес заказа - суммарный вес всех товаров заказа.

Предыдущий оплаченный заказ
  • Общая сумма заказа с доставками и налогами - общая сумма заказа, включая НДС и стоимость доставки.
  • Тип плательщика - тип плательщика, оформляющего заказ.
  • Платежная система - выбранная платёжная система.
  • Служба доставки - выбранная служба доставки.
  • Общий вес заказа - суммарный вес всех товаров заказа.

Пользователь
  • Пользователь - конкретный пользователь сайта.
  • Группы - группа пользователей сайта.

Общие условия
  • День недели - день недели, в который при оформлении заказа будет действовать данное правило.

Ограничения

Поле | Описание
Группы пользователей, на которые распространяется правило | В данном поле выбираются группы пользователей, имеющие право на применение данного правила. Если ни одна группа не выбрана, то правило будет доступно для пользователей всех групп.

Купоны

Поле Описание
Создать купоны при сохранении правила При отмеченной опции становятся доступными [dw]дополнительные поля.[/dw][di]
  • Число купонов - число купонов выбранного ниже типа для данного правила.
  • Период активности - указывается период активности купона:
    • Без ограничений - время действия купона неограничено;
    • Интервал - указывается дата начала и окончания действия купона.
    Обратите внимание, что в купоне в первую очередь учитывается период активности самого правила.
  • Тип купонов - указывается тип купонов правила:
    • на одну позицию заказа;
    • на один заказ;
    • многоразовый купон.
  • Максимальное число использований - указывается количество, определяющее сколько раз может быт применен многоразовый купон..
[/di]
Опция отображается только при создании нового правила.
В форме редактирования правила выводится список купонов. На закладке можно добавить новые купоны к правилу по кнопке Добавить или с помощью одноименной кнопки обновить список купонов.

Дополнительно

Поле | Описание
Внешний код | Символьный код, используемый для связи правила с внешним источником данных.


Купоны правил корзины

На странице Купоны правил корзины (Маркетинг > Товарный маркетинг > Правила работы с корзиной > Купоны правил корзины) представлена таблица, содержащая список всех купонов, созданных для имеющихся в системе правил корзины.

Данная страница служит для добавления новых купонов, для отображения и перехода к управлению параметрами существующих купонов.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме добавления нового купона для правила корзины.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в формат MS Excel.

Список купонов

Поле | Описание
Колонка флажков | Поле предназначено для выбора купонов, к которым предполагается применить какое-либо правило или действие.
Действия Действия над купоном:
  • Редактировать - редактирование купона;
  • Копировать - создание нового купона путем копирования параметров существующего.
  • Деактивировать/Активировать - снятие или постановка флага активности для купона;
  • Удалить - удаление купона.
ID | Идентификатор купона.
Правило | Название правила, для которой создан купон.
Купон | Код купона.
Активность | Признак активности купона. Если купон активен, то он может быть использован при покупке товаров. Одноразовый купон после использования становится неактивным.
Активен с | Дата и время, начиная с которого купон активен.
Активен по | Дата и время, по которое купон активен.
Тип купона | Вид купона.
Сколько использовать | Максимальное число использований купона.
Был использован | Количество использований купона из заданного максимального числа.
Владелец | Пользователь, к которому привязан купон.
Дата использования | Дата и время использования купона.
Кто изменил | Пользователь, последний раз вносивший изменения в параметры купона.
Дата изменения | Дата и время последнего изменения купона.


Создание и редактирование купона правила корзины

Данная форма служит для создания нового или редактирования существующего купона на правило корзины.

Контекстная панель

Кнопка | Описание
Список купонов | Переход на страницу, содержащую полный список купонов правил корзины.
Добавить новый | Переход к форме создания нового купона. Кнопка отображается при редактировании существующего купона.
Скопировать | Создание нового купона путем копирования параметров редактируемого купона. Кнопка отображается при редактировании существующего купона.
Удалить | Удаление редактируемого купона. Кнопка отображается при редактировании существующего купона.

Форма редактирования

Поле | Описание
ID | Уникальный идентификатор купона. Поле отображается при редактировании существующего купона.
*Активность | Признак активности купона.
*Правило корзины | В выпадающем списке выбирается одно из имеющихся в системе правил корзины, к которому будет относиться создаваемый купон.
*Купон | Код купона вводится вручную или генерируется по кнопке Сгенерировать код.
*Тип купона Указывается вид купона:
  • на одну позицию заказа - купон можно применить только к одному товару и только один раз. Если в заказе несколько товаров, то купон применяется к самому дорогому товару;
  • на один заказ - купон можно применить один раз на [dw]один любой заказ[/dw][di]Если один покупатель использовал такой купон в заказе, то другие покупатели воспользоваться им уже не смогут.[/di];
  • многоразовый - купон может применяться к заказам неограниченное количество раз (в том числе и [dw]одним покупателем[/dw][di]Функционал Многоразового купона, который может быть применён каждым пользователем один раз, пока не реализован.[/di]).
Период активности
  • Без ограничений - время действия купона неограничено;
  • Интервал - указывается дата начала и окончания действия купона.
Обратите внимание, что в купоне в первую очередь учитывается период активности самого правила.
Владелец купона | Пользователь, к которому привязан купон. Если пользователь не задан, то купон может применить любой пользователь.
Максимальное число использований | Указывается количество, определяющее сколько раз может быт применен многоразовый купон.
Комментарий | Пояснение к купону.
* - поля, обязательные для заполнения.


Накопительные скидки

Страница Накопительные скидки (Маркетинг > Товарный маркетинг > Накопительные скидки) служит для добавления и редактирования накопительных скидок.

Имеется возможность использования накопительных скидок после конвертации магазина. Для этого используйте Предустановленный список маркетинговых акций. Подробнее смотрите в главе Товарный маркетинг: скидки и акции курса Администратор. Бизнес.

Форма поиска

С помощью данной формы Вы можете выполнить поиск накопительных скидок в соответствии с указанными условиями.

Поле | Описание
ID | Поиск накопительной скидки по ID.
Сайт | Указывается сайт, к ценам на товары которого могут быть применены искомые накопительные скидки.
Название накопительной программы* | Поиск накопительной скидки по ее названию.
Активность | Признак активности накопительной скидки. Если накопительная скидка активна, то она может быть использована при формировании цены товара.
Валюта | Выбирается валюта накопительной скидки.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Контекстная панель

Кнопка | Описание
Новая накопительная программа | Переход к форме создания новой накопительной программы.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список накопительных программ скидок

Поле | Описание
Колонка флажков | Поле предназначено для выбора накопительных программ, к которым предполагается применить какое-либо правило или действие.
Действия Действия над накопительными программами:
  • Редактировать - редактирование накопительной программы;
  • Копировать - копирование накопительной программы;
  • Удалить - удаление накопительной программы.
ID | Идентификатор накопительной программы в базе данных.
Сайт | Сайт, к ценам на товары которого применяется накопительная программа.
Название программы | Наименование накопительной программы.
Акт. | Флаг активности накопительной программы. Только активные накопительные программы могут быть использованы.
Сорт. | Относительный "вес", определяющий положение накопительной программы в общем списке.
Кем изменена | Логин пользователя, последний раз изменявшего программу.
Дата изменения | Дата последнего изменения программы.


Создание и редактирование накопительной программы

Закладки

Даная форма предназначена для создания новых и изменения параметров уже существующих накопительных программ.

Контекстная панель

Кнопка | Описание
Список накопительных программ | Переход на страницу со списком накопительных программ.
Добавить новую программу | Переход к форме создания новой накопительной программы. Кнопка отображается при редактировании существующей программы.
Копировать программу | Переход к форме создания накопительной программы путем копирования параметров текущей. Кнопка отображается при редактировании существующей программы.
Удалить программу | Удаление редактируемой накопительной программы. Кнопка отображается при редактировании существующей программы.
Настроить | Переход к окну настройки формы редактирования. Кнопка отображается при редактировании существующей программы.

Накопительная программа

Поле | Описание
ID | Идентификатор накопительной программы в базе данных. Поле отображается только при редактировании программы.
Активность | Флаг активности. Только активные программы могут быть применены.
*Название накопительной программы | Любое название программы, дающее представление о случаях применения, величине и т.д. по желанию.
*Сайт | Сайт, к ценам на товары которого применяется накопительная программа.
* - поля, обязательные для заполнения.

Скидки накопительной программы

Поле | Описание
Период для расчета скидок Указывается период времени, за который следует произвести суммирование заказов для расчета скидки. Доступны следующие значения:
  • За все время.
  • За период. При выбранной опции становятся доступны поля Дата начала периода и Дата окончания периода.
  • За последние. При выбранной опции становится доступно поле Выбрать оплаченные заказы за последний(е).
Срок действия скидок Указывается период действия скидок. Доступны следующие значения:
  • Бессрочно.
  • Период. При выбранной опции становятся доступны поля Дата начала действия скидок и Дата окончания действия скидок.
  • Время с момента получения. При выбранной опции становится доступно поле Период действия скидок (с момента получения скидки).
*Валюта сумм оплаченных заказов и скидок | Указывается валюта, в которой оплачены заказы и выдается скидка.
Сумма оплаченных заказов | Минимальная сумма оплаченных заказов, необходимая для получения скидки.
Величина скидки | Скидка, получаемая при указанной сумме оплаченных заказов. Может быть выставлена как в процентах, так и в виде фиксированной суммы.
* - поля, обязательные для заполнения.

Ограничения

Поле | Описание
*Группы пользователей | В данном поле выбираются группы пользователей, которые могут воспользоваться скидкой.
* - поля, обязательные для заполнения.

Дополнительно

Поле | Описание
Внешний код | Символьный код, используемый для связи накопительной программы с внешним источником данных.
Сортировка | Относительный "вес" накопительной программы. Используется для вывода элемента в общем списке.


Email-маркетинг. Описание модуля

Модуль Email-маркетинг предназначен для организации работы рассылок.

Основные возможности модуля

  • Создание рассылок;
  • Возможность подписываться к рассылкам или отписываться в один клик;
  • Формирование рассылок по шаблонам;
  • Отправка писем как вручную, так и с определенной периодичностью;
  • Импорт адресов;
  • Отправка писем как через Агент (на хитах), так и через Сron - поддержка в BitrixVM\BitrixEnv v7.2 (достаточно включить соответствующую опцию в меню);
  • Поддержка вложений в письмах;
  • Поддержка компонентов для почтовых шаблонов.

Компоненты

Модуль поддерживает следующие компоненты 2.0 в визуальном редакторе рассылок:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Малая корзина для почты | sale.basket.basket.small.mail | Служит для создания списка товаров, находящихся в корзине пользователя.
Подробная информация о заказе для почты | sale.personal.order.detail.mail | Служит для вывода подробной информации по заказу.
Генерация купона на товар для почты | sale.discount.coupon.mail | Генерирует купон для правила корзины с соответствии с заданными параметрами.
Вывод товаров для почты | catalog.show.products.mail | Выводит список товаров для почты по заданным идентификаторам.
Персональные рекомендации для почты | sale.bigdata.personal.mail | Выводит список рекомендованных товаров с указанным набором свойств, цен и т.д.
Сопутствующие заказу товары | sale.bigdata.followup.mail | Выводит товары, сопутствующие ранее заказанным товарам.
Форма подписки | sender.subscribe | Создает включаемую в дизайн сайта форму для подписки на рассылки.

Смотрите также

  • Глава E-mail маркетинг [image] в курсе «Продвижение сайта и маркетинг»
  • Глава E-mail маркетинг [image] в курсе «Администратор. Модули»


E-mail маркетинг. Настройки модуля

Закладки

Форма настроек модуля Email-маркетинг (Настройки > Настройки продукта > Настройки модулей > Email-маркетинг) предназначена для задания общесистемных параметров модуля.

Настройки

Поле | Описание
Интервал в секундах для пошаговой рассылки (0 - рассылать за один шаг) | Указывается интервал в секундах для для пошаговой рассылки выпусков. Если указан 0 - то рассылка будет происходить за один шаг.
Метод автоматической отправки рассылки Указывается способ автоматической отправки выпусков:
  • Агент - автоматическая генерация выпусков осуществляется внутренними средствами системы;
  • Крон - используется при установке системы на сервер под управлением ОС Unix (предусматривает использование демона cron ОС Unix).
Количество писем для рассылки агентом за один запуск | Указывается количество писем для рассылки за один запуск при отправке с помощью Агента.
Интервал в секундах между запусками рассылки агентом (0 - запуск сразу) Указывается интервал в секундах между запусками рассылки агентом. Если указан 0, то запуск рассылок будет происходить без пауз между выпусками.
Пример:
Если в поле Количество писем для рассылки агентом за один запуск установить значение 900, а в поле Интервал в секундах между запусками рассылки агентом - 3650, то система будет отправлять максимум 900 писем в час.
Количество писем для рассылки кроном за один запуск | Указывается количество писем для рассылки за один запуск при отправке с помощью Крона
Метод проверки периодических рассылок Указывается способ автоматической генерации периодических выпусков:
  • Агент - автоматическая генерация выпусков осуществляется внутренними средствами системы;
  • Крон - используется при установке системы на сервер под управлением ОС Unix (предусматривает использование демона cron ОС Unix).
Количество потоков при отправке Опция организует многопоточность при сборке сегмента рассылки и при отправке.

Выбирается количество потоков:
  • если используется отправка на Агентах, то лучше использовать отправку в 1 поток;
  • если рассылки запускаются через Крон, то рекомендуется отправка в 10 потоков.
    Кроме выбора этой опции для работы многопоточности в cron, нужно еще добавить в cron на сервере вызов файлов:
    - для многопоточной отправки: /home/bitrix/www/bitrix/tools/sender/cron_sender.php
    - для многопоточной сборки сегмента: /home/bitrix/www/bitrix/tools/sender/group_builder.php
    Пример задания:
    * * * * * bitrix /usr/bin/php -f /home/bitrix/www/bitrix/tools/sender/cron_sender.php 10 >/dev/null 2>&1

Поле доступно с версии модуля sender 20.0.0.
Интервал проверки периодических рассылок в секундах | Указывается интервал проверки периодических рассылок в секундах.
Протокол адресов ссылок в письмах | Указывается HTTP или HTTPS в зависимости от используемого протокола.
Отслеживать прочтения и переходы по ссылкам | Опция отмечается, если Вы хотите видеть статистику прочтений и переходов по ссылкам.
Свой адрес страницы отписки | Указывается url страницы отписки, если страница или url отличается от страницы отписки по умолчанию (если используется собственный дизайн, пользовательские компоненты).
Свой адрес страницы подписки | Указывается url страницы подписки, если страница или url отличается от страницы подписки по умолчанию (если используется собственный дизайн, пользовательские компоненты).
Список адресов для поля 'От кого': Указывается cписок адресов e-mail для поля 'От кого' (From) в письмах рассылок. Данные адреса появятся в списке Последние на странице настройки шаблона выпуска. С версии 20.700.0 Главного модуля (main) добавлена возможность использовать email с [dw]IDN[/dw][di]IDN (англ. Internationalized Domain Names — интернационализованные доменные имена) — это доменные имена, которые содержат символы национальных алфавитов, например, мойсайт.рф.

Подробнее [image]...[/di], включая кириллические домены.
Список адресов для поля 'Получатели тестовой рассылки': Указывается список адресов e-mail для тестирования рассылок. Данные адреса появятся в списке Последние на странице отправки выпуска.
Заголовки письма Поля для добавления технических заголовков письма. Формат: ЗАГОЛОВОК: ЗНАЧЕНИЕ. Число заголовков не ограничено, используются любые стандартные заголовки.

Примечание. Заголовок Precedence: bulk по умолчанию включён в шаблоны писем и в дополнительном указании не нуждается.
Необходимо согласие для Email рассылок | Перед отправкой первой рассылки клиенты, которые ещё не подтвердили своё согласие, получат письмо с предложением согласиться на рассылки. Email-рассылки будут отправлены только тем клиентам, которые согласились их получать.
Количество запросов на соглашения для Email рассылок | Указывается, сколько раз пользователю может быть отправлено соглашение, прежде чем пользователь вообще не будет добавляться в рассылки (по умолчанию 1).

Доступ

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Подписка, рассылки:
  • [D] закрыт - запрет на доступ;
  • [R] просмотр всех данных модуля - разрешается только просмотр всех данных модуля;
  • [W] запись - полный доступ к ресурсам модуля.
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.


Старт

Страница Старт (Маркетинг > Email-маркетинг > Старт) имеет два назначения:

  • Вывод статистики для оценки эффективности рассылки
  • Создание новой рассылки

Фильтры

С помощью фильтров можно отобразить статистику за интересующий период времени и по авторству. После установки фильтров выводится количественные показатели соответствующих рассылок и устанавливается их Уровень эффективности по шкале от "плохо" до "отлично".

Отображаемые количественные показатели (в %):

  • Прочитанных
  • Переходы
  • Отписались
  • Подписались
  • Количество выпусков

При выставлении фильтров также выводятся графические отображения следующих характеристик:

  • Динамика эффективности
  • Прочтения
  • Клики
  • Отписки

Поле | Описание
Период Это поле фильтра позволяет выбрать период времени, за который следует отобразить статистику:
  • за неделю
  • за месяц
  • за 3 месяца
  • за 6 месяцев
  • за год
Авторство | Выбор автора (можно посмотреть либо общую статистику по всем авторам, либо свою).

Недавние выпуски

Выводится список недавних выпусков, а также есть возможность Создать новую рассылку.

Поле | Описание
Создать новую рассылку | При нажатии этой кнопки откроется мастер создания новой рассылки. Второй вариант создания рассылки - в разделе Рассылки (Маркетинг > Email-маркетинг > Рассылки) нажать кнопку Создать рассылку.

Смотрите также

  • Создание рассылки
  • Статистика: оценка эффективности рассылки


Рассылки

На странице Рассылки (Маркетинг > Email-маркетинг > Рассылки) представлена информация об имеющихся в системе рассылках.

Фильтр + поиск

Используется для задания параметров отбора рассылок, которые отображаются в списке.

Чтобы отфильтровать рассылки по заданным критериям нажмите кнопку Сохранить. Для отображения всех рассылок нажмите кнопку Отменить.

Поле | Описание
Поиск
Название | Поиск рассылок по названию.
Статус рассылки Поиск рассылок по статусу:
  • Готова к отправке
  • Отправляется
  • Запланирована
  • На паузе
  • Отправлена
  • Отменена
  • Приостановлена
Создал | Поиск по автору рассылки.
Дата создания | Поиск по дате создания рассылки.
Дата окончания отправки | Поиск по дате окончания отправки рассылки.
Кампания | Поиск рассылок по отношению к какой-либо кампании.
Тип рассылки | Поиск рассылок по способу передачи сообщений (email рассылка или SMS рассылка).
Фильтры
Мои | Поиск собственноручно созданных рассылок.
В работе | Поиск действующих рассылок.
Завершенные | Поиск завершенных рассылок.
Все | Быстрый сброс всех фильтров.

Контекстная панель

Кнопка | Описание
Создать рассылку | Служит для добавления новой рассылки.
Экспорт данных Экспорт данных из отображаемой таблицы в MS Excel.

Примечание: Статистика при экспорте разбивается на 4 колонки:
  • Общее количество получателей;
  • Успешно отправлено;
  • Количество просмотров;
  • Количество переходов.

Список рассылок

Колонка | Описание
Колонка флажков | Поле выбора рассылок, к которым необходимо применить какое-либо правило или действие.
Меню действий | Отображение меню, позволяющего Удалить рассылку.
ID | Идентификатор рассылки, под которым она зарегистрирована в базе данных.
Дата | Дата создания рассылки.
Название | Название рассылки.
Создал | Автор рассылки.
Действия Выполняемые с рассылкой действия:
  • Отправить
  • На паузу
  • Продолжить
Статус | Отображается текущее состояние рассылки, количество получателей и время до окончания отправки.
Статистика Переход к просмотру статистики и получателей рассылки по ссылкам:
  • получатели - при нажатии на ссылку открывается [dw]статистика[/dw][di]Отображается таблица со статистикой по каждому получателю с возможностью фильтрации и поиска, а также экспорта данных в MS Excel.[/di] по получателям рассылки;
  • просмотры: %, переходы: % - при нажатии на любую из ссылок открывается статистика по просмотрам и переходам рассылки. Отображаются после отправки рассылки.
Кампания | Отношение рассылки к какой-либо кампании.
Тема письма | Заголовок письма.
Отправитель | Отправитель рассылки (email).
Важность | Важность для писем в рассылке.
Параметры ссылок | Параметры ссылок (utm-метки)


Создание рассылки

Создать рассылку можно из двух разделов:

  • Рассылки (Маркетинг > Email-маркетинг > Рассылки)
  • Старт (Маркетинг > Email-маркетинг > Старт)

Можно выбрать любой из способов (процесс создания рассылок одинаков).

Выбор шаблона рассылки

Поле | Описание
Недавно использованные | Выбор шаблона из списка недавно использованных.
Предустановленные | Выбор одного из существующих (предустановленных) шаблонов, либо создание Своего HTML (визуальный редактор в этом случае будет недоступен). Примечание: Значок перца на шаблоне означает, что в нём используется свободная лексика - например, разговорные выражения или афоризмы.
Мои шаблоны | Выбор шаблона из списка собственных шаблонов.

Форма создания рассылки

Поле | Описание
Сменить шаблон | Кнопка позволяет и на данном этапе поменять шаблон рассылки.
Изменить название (значок маркера возле названия) | При нажатии на значок маркера справа от названия рассылки становится возможным изменение названия рассылки.
Кампания Выбор кампании (кампаний), в рамках которых будет проходить Ваша рассылка (кампания - система спланированных рекламных мероприятий, объединённых одной идеей и концепцией для достижения конкретной маркетинговой цели).

На этом этапе также можно создать новую кампанию и проводить рассылку уже в рамках этой новой кампании.
Выбор сегментов получателей | Выбор одного или нескольких сегментов получателей. На этом этапе можно создать новый сегмент.
Исключения | Выбор одного или нескольких сегментов получателей, которым НЕ должна прийти рассылка.
Тема письма Составление заголовка письма. Можно использовать переменные (для вызова переменных нажмите на троеточие справа от поля записи темы). Доступные переменные:
  • Имя
  • Email
  • Код пользователя
  • Название сайта
  • Код выпуска рассылки
Тело письма (Редактировать) | Работа в режиме редактирования шаблона.
Отправитель | Выбор отправителя рассылки. Для выбора доступны все email, указанные в настройках модуля E-mail маркетинг [image], и email отправителя по умолчанию из настроек Главного модуля [image]. При необходимости можно добавить нового отправителя по нажатии на соответствующий вариант.
Тело письма (Предпросмотр) Предварительный просмотр рассылки на трех устройствах:
  • смартфон
  • планшет
  • десктоп
Развернуть/свернуть | Смена форматов работы (при нажатии кнопки Развернуть скроются поле Название шаблона и кнопки Сохранить/Отмена, т.е. область редактирования станет больше).
Дополнительно При нажатии этой кнопки становятся доступны следующие опции:
  • присвоение степени Важности (нет, высокая, нормальная, низкая)
  • изменение Параметров ссылок
  • добавление Вложений (можно показывать картинки либо иконки)
  • включение возможности Отслеживания открытия письма
  • отправка Подтверждения согласия на рассылку (можно выбрать одно из существующих [ds]соглашений[/ds][di]На странице Соглашения (Настройки > Настройки продукта > Соглашения) выводятся все созданные и используемые соглашения. С неё же можно перейти к списку полученных соглашений от пользователей.

    Подробнее [image]...[/di] или создать новое)
  • Ограничить отправку по времени (во сколько начинать и заканчивать отправку рассылки)
Получатели тестовой отправки | Изменение/добавление адресов получателей тестовой отправки (тестовая отправка позволяет оценить, как эту рассылку будет видеть адресат). Тестовая отправка осуществляется после нажатия кнопок Отправить (отправка рассылки) и Отправить согласие на рассылку (отправка соглашения на получение рассылки).

Настройка времени отправки рассылки

На этом этапе можно настроить время отправки рассылки. Для этого необходимо выбрать нужное значение в поле Отправить рассылку и нажать кнопку Сохранить.

Значение | Описание
Сейчас | Рассылка начнет отправляться сразу после нажатия кнопки Сохранить.
Позже вручную | Рассылка будет отправлена после нажатия кнопки Отправить (Маркетинг > Email-маркетинг > Рассылки).
Запланировать | Можно выбрать точную дату и время запуска рассылки в отображающемся [dw]календаре.[/dw][di] [image] [/di]
Каждый день Позволяет создать периодическую рассылку, т.е. выбрать[dw] следующие параметры:[/dw][di] [image] [/di]
  • время рассылки
  • дни недели
  • число
  • месяц

    • Выбранные позиции помечаются зеленым цветом.

Примечание: Для коробочной версии Битрикс24 данная опция недоступна.

Смотрите также

  • Создание рассылки (учебный курс "Продвижение сайта и маркетинг")


Сегменты

На странице Сегменты (Маркетинг > Email-маркетинг > Сегменты) представлена информация о созданных сегментах (наборах групп пользователей, которые должны получить рассылку).

Фильтр + поиск

Используется для задания параметров отбора сегментов, которые отображаются в списке.

Чтобы отфильтровать рассылки по заданным критериям, нажмите кнопку Сохранить. Для отображения всех рассылок нажмите кнопку Отменить.

Поле | Описание
Название | Поиск сегментов по названию.
Предустановленный | Возможность отфильтровать предустановленные сегменты.
Скрытый | Фильтрация скрытых сегментов (необходимо установить значение да).

Контекстная панель

Кнопка | Описание
Создать сегмент | Служит для добавления нового сегмента.
Удалить | Служит для удаления созданных сегментов.

Список сегментов

Колонка | Описание
Колонка флажков | Поле выбора сегментов, к которым необходимо применить какое-либо правило или действие.
Меню действий | Отображение меню, позволяющего Удалить или Редактировать сегмент.
ID | Идентификатор сегмента, под которым он зарегистрирован в базе данных.
Создан | Дата создания сегмента.
Название | Название сегмента.
Использовался | Дата последнего использования сегмента.
Получателей | Количество адресов получателей рассылки.


Создание сегмента

Форма создания сегмента открывается при нажатии кнопки Создать сегмент в разделе Сегменты (Маркетинг > Email-маркетинг > Сегменты)

Форма создания сегмента

Поле | Описание
Изменить название (значок маркера возле названия) | При нажатии на значок маркера справа от названия сегмента становится возможным изменение названия этого сегмента.
Добавить фильтр Опция позволяет добавить так называемые динамические списки (списки адресов пользователей, которые формируются системой по какому-либо общему признаку, т.е. количество участников этих групп постоянно меняется, а списки рассчитываются автоматически перед запуском). Доступные фильтры:
  • [dw]Веб-формы[/dw][di] [image] [/di]

    Примечание: Требуется обязательная предварительная настройка веб-формы!

    Адреса пользователей забираются из определенной Формы, где необходимо указать Поле с именем и Поле с email данного инфоблока.

  • [dw]Инфоблоки[/dw][di] [image] [/di]

    Примечание: Требуется обязательная предварительная настройка инфоблока!

    Адреса пользователей забираются из определенного Инфоблока, где необходимо указать Поле с именем и Поле с email данного инфоблока.

  • [dw]Магазин - Покупатели[/dw][di] [image] [/di]

    Адреса пользователей собираются из определенного Сайта магазина, в зависимости от Количество оплаченных заказов, Суммы всех заказов и Дата последнего заказа.

  • [dw]Отписавшиеся[/dw][di] [image] [/di]

    Собираются адреса пользователей, отписавшихся от всех рассылок или от определенной рассылки.

  • [dw]Подписка, рассылки - Подписчики[/dw][di] [image] [/di]

    Выводятся адреса пользователей сайта, подписанных на определенные Рубрики рассылок, в зависимости от Активности подписки, статуса Подтверждения подписки и Даты добавления.

  • [dw]Получатели рассылок[/dw][di] [image] [/di]

    Адреса пользователей собираются из определенной рассылки, в зависимости от действий Отправлено, Прочитано, Переход по ссылке и Отписались.

  • [dw]Пользователи[/dw][di] [image] [/di]

    Выводятся адреса пользователей сайта из определенных Групп пользователей, по Дате регистрации или Активности.

  • [dw]Целевая распродажа товаров[/dw][di] [image] [/di]

    Выводятся адреса пользователей, кто купит или купил выбранные товары. Товары выбираются в окне выбора товаров после нажатия кнопки Выбрать товары.

Примечание: В коробочной версии продукта Битрикс24 доступны ещё два фильтра: [dw]Клиенты[/dw][di] [image] [/di] и [dw]Лиды[/dw][di] [image] [/di]. Подробнее о том, как работать с этими фильтрами, читайте [ds]в статье.[/ds][di] Сегменты можно создавать практически по любым параметрам. Если вы продаете туры, то можете создать в карточке сделки поле Любимое направление. Такого поля нет в стандартное карточке, но вы можете его добавить самостоятельно и предложить любителям жарких стран тур в Египет.

Подробнее [image]...[/di]
Свой набор адресов | Выбираются статические (загруженные вручную) наборы адресов. Также можно создать новый набор, нажав кнопку Загрузить.

Смотрите также

  • Создание сегмента (учебный курс "Продвижение сайта и маркетинг")


Кампании

Кампания - система спланированных рекламных мероприятий, объединённых одной идеей и концепцией для достижения конкретной маркетинговой цели.

Создайте новую кампанию и проводите рассылку в рамках этой кампании.

На странице Кампании (Маркетинг > Email-маркетинг > Кампании) представлена информация о созданных кампаниях.

Фильтр + поиск

Используется для задания параметров отбора кампаний, которые отображаются в списке.

Чтобы отфильтровать рассылки по заданным критериям, нажмите кнопку Сохранить. Для отображения всех рассылок нажмите кнопку Отменить.

Поле | Описание
Название | Поиск кампаний по названию.
Дата создания | Поиск кампаний по дате создания.
Активная | Поиск кампаний по их активности.
Публичная | Поиск кампаний по их публичности.
Сайт | Поиск по сайту, на котором действуют требуемые кампании.

Контекстная панель

Кнопка | Описание
Добавить кампанию | Служит для добавления новой кампании.
Удалить | Служит для удаления созданных кампаний.

Список сегментов

Колонка | Описание
Колонка флажков | Поле выбора кампаний, к которым необходимо применить какое-либо правило или действие.
Меню действий | Отображение меню, позволяющего Удалить или Редактировать сегмент.
ID | Идентификатор кампании, под которым она зарегистрирована в базе данных.
Создан | Дата создания кампании.
Название | Название кампании.
Активная | Статус действия кампании в настоящее время.
Публичная | Степень открытости кампании.
Сайт | Сайт, на котором действует кампания.


Создание кампании

Форма создания кампании открывается при нажатии кнопки Добавить кампанию в разделе Кампании (Маркетинг > Email-маркетинг > Кампании)

Форма создания кампании

Поле | Описание
Изменить название (значок маркера возле названия) | При нажатии на значок маркера справа от названия кампании становится возможным изменение названия этой кампании.
Сайт | Выбор сайта, для которого будет действовать кампания.
Активна | Отмеченная опция означает, что данная кампания будет являться действующей с момента создания.
Вывод в публичной части для подписки | При отмеченной опции в публичном разделе будет выводиться форма для подписки на рассылки этой кампании.
Описание | Содержание кампании.


Мои шаблоны

На странице Мои шаблоны (Маркетинг > Email-маркетинг > Мои шаблоны) представлена информация об имеющихся в системе шаблонов выпусков рассылки.

Фильтр+поиск

Используется для задания параметров отбора шаблонов выпуска, которые отображаются в списке.

Поле | Описание
Найти | Поиск шаблона по его ID или Названию.

Чтобы отфильтровать шаблоны рассылки по заданным критериям, нажмите кнопку Найти. Для отображения всех шаблонов рассылок нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Создать шаблон | Позволяет перейти к созданию нового шаблона.
Удалить | Служит для удаления созданного шаблона.

Мои шаблоны

Колонка | Описание
Колонка флажков | Поле выбора шаблона рассылки, к которому необходимо применить какое-либо правило или действие.
Меню действий | Отображение меню, позволяющее Редактировать или Удалить шаблон выпуска рассылки.
ID | ID шаблона.
Дата | Дата создания шаблона.
Дата использования | Дата последнего использования шаблона.
Название | Название шаблона.
Использовался | Сколько раз использовался шаблон.


Создание шаблона

Форма создания шаблона открывается при нажатии кнопки Создать шаблон в разделе Мои шаблоны (Маркетинг > Email-маркетинг > Сегменты)

Выбор шаблона

Поле | Описание
Недавно использованные | Выбор шаблона из списка недавно использованных.
Предустановленные | Выбор одного из существующих (предустановленных) шаблонов, либо создание Своего HTML (визуальный редактор в этом случае будет недоступен). Примечание: Значок перца на шаблоне означает, что в нём используется свободная лексика - например, разговорные выражения или афоризмы.
Мои шаблоны | Выбор шаблона из списка собственных шаблонов.

Форма создания шаблона

Поле | Описание
Изменить название (значок маркера возле названия) | При нажатии на значок маркера справа от названия шаблона становится возможным изменение названия шаблона.
Редактировать | Работа в режиме редактирования шаблона.
Предпросмотр Предварительный просмотр рассылки на трех устройствах:
  • смартфон
  • планшет
  • десктоп
Развернуть/свернуть | Смена форматов работы (при нажатии кнопки Развернуть скроются поле Название шаблона и кнопки Сохранить/Отмена, т.е. область редактирования станет больше).

Смотрите также

  • Создание шаблона (учебный курс "Продвижение сайта и маркетинг")


Черный список

На странице Черный список (Маркетинг > Email-маркетинг > Черный список) представлена информация об имеющихся в системе черных списках.

Фильтр

Поле | Описание
Имя | Поиск адресата по имени.
E-mail/Телефон | Поиск адресата по e-mail адресу или телефону.
Тип | Поиск адресатов по типу: либо все e-mail адреса, либо все телефоны.

Чтобы отфильтровать адреса рассылки по заданным критериям нажмите кнопку Найти. Для отображения всех рассылок нажмите кнопку Сбросить.

Контекстная панель

Кнопка | Описание
Добавить в список | Служит для добавления нового адреса в черный список.
Удалить из черного списка | Позволяет удалить адрес/телефон из черного списка.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.

Список адресов

Колонка | Описание
Колонка флажков | Поле выбора списка адресов рассылки, к которым необходимо применить какое-либо правило или действие.
Меню действий | Отображение меню, позволяющее Удалить из черного списка адрес получателя рассылки.
ID | Идентификатор адреса пользователя, под которым он зарегистрирован в базе данных.
Добавлен | Отображается дата добавления адреса в черный список.
Тип | Указывается тип адреса (e-mail адрес или телефон).
Email / Телефон | Email адрес или номер телефона получателя рассылки.
Имя | Имя адресата.


Создание черного списка

Форма создания черного списка открывается при нажатии кнопки Добавить в список в разделе Черный список (Маркетинг > Email-маркетинг > Черный список)

Форма создания черного списка

Поле | Описание
Список получателей | Укажите список email-адресов и/или телефонов, в столбик(каждая запись на новой строке). Вы можете загружать также и имена. Для этого после адреса через точку с запятой укажите имя. Пример: vasily@example.com peter@example.com;Пётр +0112233445566 +71234567890;Анна


Список адресов

На странице Список адресов (Маркетинг > Email-маркетинг > Список адресов) представлена информация об имеющихся в системе списков адресов рассылки.

Фильтр

Поле | Описание
Имя | Поиск адресата по имени.
E-mail / Телефон | Поиск адресата по e-mail адресу или телефонному номеру.
Подписан | Поиск адресатов по определенной подписке на рассылку.
Отписан | Поиск адресатов по определенной рассылкам, от которых он отписался.
Набор адресов | Поиск адресатов из определенного набора адресов.
Подписавшиеся | Поиск адресатов среди всех подписавшихся.
Отписавшиеся | Поиск адресатов среди всех отписавшихся.
Все | Поиск адресатов вне зависимости от того, подписывались/отписывались ли они на рассылки.

Чтобы отфильтровать адреса рассылки по заданным критериям нажмите кнопку Сохранить. Для отображения всех рассылок нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить в список | Служит для добавления нового адреса(ов) рассылки в список, а также для создания нового набора .
Наборы адресов | Позволяет перейти к редактированию наборов адресов.
Удалить из списка | Удаление из списка адресов.

Список адресов

Колонка | Описание
Колонка флажков | Поле выбора адресов рассылки, к которым необходимо применить какое-либо правило или действие.
Меню действий | Отображение меню, позволяющего Редактировать, Удалить из черного списка, Удалить адрес получателя рассылки, либо просмотреть Рассылки, которые ему были отправлены.
ID | ID адреса.
Добавлен | Дата добавления адресата в список.
Тип | Отображение типа адреса: либо e-mail адрес, либо телефон.
Email / Телефон | Email адрес или телефон получателя.
Имя | Имя адресата.
Статистика | Просмотр статистики активности пользователя (прочитал, кликнул, отписался и т.д.).


Добавление адресов, набора адресов

Форма загрузки адресов открывается при нажатии кнопки Добавить в список в разделе Список адресов (Маркетинг > Email-маркетинг > Список адресов)

Форма добавления адресов

Поле Описание
Список получателей Укажите список email-адресов и/или телефонов, в столбик(каждая запись на новой строке). Вы можете загружать также и имена. Для этого после адреса через точку с запятой укажите имя.
Пример:
vasily@example.com
peter@example.com;Пётр
+0112233445566
+71234567890;Анна
Загрузить в статический набор адресов Выбор набора, в который нужно поместить загружаемые адреса.
Примечание: Можно создать новый набор адресов, выбрав пункт [dw][Новый].[/dw][di] При создании нового набора нужно будет еще заполнить поле:
с названием Прописывается название нового набора
[/di]

Смотрите также

  • Добавление адресов в наборы (учебный курс "Продвижение сайта и маркетинг")


Редактирование наборов

Отредактировать наборы можно нажатием кнопки Наборы адресов в разделе Список (Маркетинг > Email-маркетинг > Список адресов)

Фильтр + поиск

Используется для задания параметров отбора сегментов, которые отображаются в списке.

Чтобы отфильтровать рассылки по заданным критериям, нажмите кнопку Сохранить. Для отображения всех рассылок нажмите кнопку Отменить.

Поле | Описание
Название | Поиск сегментов по названию.
Символьный код | Фильтрация по символьному коду.

Контекстная панель

Кнопка | Описание
Изменить | Служит для изменения названия или символьного кода наборов адресов.
Удалить | Служит для удаления наборов адресов.


Статистика

На странице Статистика рассылки (Маркетинг > Email-маркетинг > Рассылки при нажатии на просмотры: %, переходы: % в столбце Статистика списка) представлена статистика выпусков данной рассылки.

Статистика

В выводимой статистике по выпускам можно провести аналитику по рассылкам - доходят ли они до клиентов, читают ли клиенты их, кликают ли по ссылкам в рассылках и т.д.

В отчете выводятся данные:

  • Уровень эффективности рассылки (от "плохо" до "отлично")
  • Отправлено писем адресатам
  • Прочитано писем адресатами
  • Перешли по ссылкам в письме
  • С ошибкой
  • Отписалось

Также создается графическое представление в виде карты кликов.

Смотрите также

Смотрите также:

  • Статистика: оценка эффективности рассылки (учебный курс "Продвижение сайта и маркетинг")


Триггерные рассылки

Триггерные рассылки относятся к модулю Email-маркетинг (sender).

Основные возможности

Триггерная рассылка - это последовательность писем, которые отправляются сайтом автоматически в ответ на действие пользователя или после наступления некоторого события, связанного с пользователем. Использование этого инструмента увеличивает количество возвратов и повторных покупок в магазине.

Задачи, которые решают триггерные рассылки:

  • Повышение конверсии магазина;
  • Удержание существующей клиентской базы;
  • Увеличение среднего чека;
  • Экономия ресурсов;
  • Эмоциональные коммуникации с клиентами.

Смотрите также

  • Глава Триггерные рассылки [image] в курсе «Продвижение сайта и маркетинг»


Список триггерных рассылок

На странице Триггерные рассылки (Маркетинг > Триггерные рассылки) представлена информация об имеющихся в системе триггерных рассылках.

Фильтр + поиск

Используется для задания параметров отбора триггерных рассылок, которые отображаются в списке.

Чтобы отфильтровать рассылки по заданным критериям нажмите кнопку Сохранить. Для отображения всех рассылок нажмите кнопку Отменить.

Поле | Описание
Название | Поиск триггерных рассылок по названию.
Дата создания | Поиск по дате создания триггерной рассылки.
Запущена | Значения Да или Нет. Поиск запущенных или не запущенных триггерных рассылок.

Контекстная панель

Кнопка Описание
Добавить Служит для добавления новой триггерной рассылки. Новую рассылку можно создать вручную или выбрать готовый шаблон:
  • Забытая корзина;
  • Отмененный заказ;
  • Письма вдогонку;
  • Будильник-90;
  • Хулиганство;
  • Будильник-180;
  • Будильник-360.

Примечание: Справа от каждого названия шаблона есть знак вопроса, по наведении на который, появляется поясняющая информация о шаблоне.

Список рассылок

Колонка | Описание
Колонка флажков | Поле выбора триггерных рассылок, к которым необходимо применить действие Удалить.
Действия в меню Доступные действия по нажатии на меню рекламы:
  • Изменить - переход к форме редактирования триггерной рассылки;
  • Удалить - удаление триггерной рассылки;
  • Запустить - запустить рассылку писем;
  • Остановить - остановить рассылку, если запущена;
  • Письма - открыть страницу с информацией о цепочке писем рассылки;
  • Получатели - открыть страницу с информацией о получателях рассылки;
  • Статистика - открыть страницу со статистикой рассылки.
ID | Идентификатор триггерной рассылки, под которым она зарегистрирована в базе данных.
Дата создания | Дата создания триггерной рассылки.
Название | Название триггерной рассылки.
Состояние В каком состоянии триггерная рассылка. Можно:
  • Запустить
  • Остановить
Письма | Список писем триггерной рассылки и ссылка "редактировать письма".
Статистика Переход к просмотру писем, статистики и получателей триггерной рассылки по ссылкам:
  • письма - при нажатии на ссылку открывается цепочка писем триггерной рассылки от события, запускающего рассылку, до достижения цели рассылки;
  • получатели - при нажатии на ссылку открывается [dw]статистика[/dw][di]Отображается таблица со статистикой по каждому получателю с возможностью фильтрации и поиска, а также экспорта данных в MS Excel.[/di] по получателям рассылки;
  • статистика - при нажатии на ссылку открывается страница аналитики триггерных рассылок с информацией: сколько всего отправлено писем, для скольких пользователей запущено, сколько достигло цели, а также сколько прочитанных писем, переходов, писем с ошибкой и отписавшихся от рассылки. На графике показана статистика достижения цели по письмам.

Смотрите также

  • Список рассылок, создание рассылки (учебный курс "Продвижение сайта и маркетинг") [image].


Создание рассылки

Форма создания рассылки

Поле | Описание
Изменить название (значок маркера возле названия) | При нажатии на значок маркера справа от названия рассылки становится возможным изменение названия рассылки.
Сайт | Выбор сайта, для которого будет выполняться триггерная рассылка
Условие запуска Условия (что должен сделать пользователь), по которым будет запущена рассылка. Для некоторых условий доступны дополнительные параметры настройки:
Поле | Описание
Для условий Давно не заходил на сайт, Давно не покупал, Забытая корзина
Время запуска | Выберите время запуска из выпадающего списка (шаг 30 минут).
Обработать старые данные | Если отмечена эта опция, то при первом запуске рассылка дополнительно запустится ещё и для пользователей, которые не выполняли действие больше указанного количества дней.
Не заходил / Не покупал / Забыл более (дней) | Укажите количество дней, по достижении которого, пользователю отправится рассылка.
Для условия Изменение статуса заказа
Выберите статус заказа | Выберите нужный статус из выпадающего списка.
Достижение цели Выбирается цель триггерной рассылки, чего вы хотите добиться от пользователя. В выпадающем списке выберите одно из условий:
  • Уведомить, отправить все письма - просто уведомить клиента о чем-то, отправить все письма в цепочке;
  • Заход на сайт - посещение клиентом сайта;
  • Изменение статуса заказа - чтобы статус заказа изменился на: Заказ принят, Ожидается оплата, Заказ выполнен;
  • Оплата заказа - Оплата заказа - чтобы заказ был оплачен покупателем;
  • Создание нового заказа - чтобы клиент создал новый заказ.

Смотрите также

  • Список рассылок, создание рассылки (учебный курс "Продвижение сайта и маркетинг") [image];
  • Настройка рассылки (учебный курс "Продвижение сайта и маркетинг") [image].


Поисковая оптимизация. Описание модуля

Модуль Поисковая оптимизация предназначен для анализа технического исполнения сайта. Он отображает параметры, влияющие на оптимизацию и дает рекомендации по улучшению этих параметров.

Работа модуля во многом связана с модулем Веб-аналитика. Часть функционала Поисковой оптимизации в младших редакциях "1С-Битрикс: Управление сайтом", не содержащих модуль Веб-аналитика, работать не будет.

Смотрите также:

  • Рекомендации по оптимизации сайтов
  • Работа с модулем поисковой оптимизации


Поисковая оптимизация. Настройки модуля

Закладки

Форма настроек модуля Поисковая оптимизация (Настройки > Настройки продукта > Настройки модулей > Поисковая оптимизация) предназначена для задания общесистемных параметров модуля.

Регистрационные данные

Данные об авторизации сайта в Яндекс.Директ. Отображается аккаунт, с которого осуществлена авторизация, есть возможность сменить аккаунт и очистить данные. В Базе данных сайта хранятся некоторые настройки для поисковиков: access_tokenс и данные для него, host_id на стороне Яндекса, clietn_id для seo-прокси сайта и прочее. Иногда бывает надо это очистить.

Свойства страниц

Закладка предназначена для задания кодов свойств страницы.

Поле | Описание
Заголовок окна браузера | Указывается код свойства, содержащий название окна браузера. По умолчанию поле содержит title.
Описание страницы | Указывается код свойства, содержащий описание страницы. По умолчанию поле содержит description.
Публичные ключевые слова страницы | Указывается код свойства, содержащий набор ключевых слов страницы. По умолчанию поле содержит keywords.

Инструменты

Закладка предназначена для настройки параметров сбора информации.

Поле | Описание
Отображаемые счетчики | Задаются коды используемых счетчиков. Для добавления новых счетчиков надо вставить полученный от поисковой машины код в это поле. Если в коде поисковой системы есть прямое указание на домен сайта, то его рекомендуется заменить на #DOMAIN#. Если необходимо подключить собственный программный счетчик, то используйте событие OnSeoCountersGetList.
Поисковые системы, используемые для анализа | Указываются поисковые системы, используемые для анализа. Выбор нескольких систем осуществляется с помощью клавиши Ctrl. Список поисковых систем строится с помощью модуля Веб-аналитика. Добавление новых систем в список производится в модуле Веб-аналитика. На сайтах, созданных на младших редакциях "1С-Битрикс: Управление сайтом", это поле настроек отсутствует.

Доступ

Закладка позволяет настроить права доступа для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Перевод:
  • [D] Доступ запрещен - запрет на доступ;
  • [F] Анализ страниц и сайта - доступ разрешен только для анализа страниц и сайта;
  • [W] Полный доступ - полный доступ к ресурсам модуля.
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.


Управление robots.txt

Закладки

На странице Управление robots.txt (Маркетинг > Поисковая оптимизация > Настройка robots.txt) представлена форма, позволяющая сгенерерировать файл robots.txt.

Контекстная панель

Кнопка | Описание
<название_сайта> | Выбор сайта, для которого должен быть составлен файл robots.txt.

Общие правила

Данная вкладка служит для указания общих правил для индексирования сайта поисковыми системами. В поле отображается текущий набор инструкций. Любая из инструкций (кроме User-Agent: *) может быть удалена, если навести на нее курсор мыши и нажать на "крестик". Для генерации инструкций необходимо воспользоваться кнопками, расположенными рядом с полем.

Кнопка | Описание
Стартовый набор | Позволяет задать набор стандартных правил и ограничений (закрываются от индексации административные страницы, личные данные пользователя, отладочная информация). Если часть стандартного набора уже задана, то будут добавлены только необходимые отсутствующие инструкции.
Запретить файл/папку (Disallow) | Позволяет составить инструкции, запрещающие индексировать файлы и папки по маске пути. При нажатии на кнопку открывается форма со списком уже имеющихся инструкций запрета индексации. В открывшейся форме кнопка [...] позволяет выбрать файлы или папки, которые индексировать не нужно.
Разрешить файл/папку (Allow) | Позволяет указать файлы и папки, разрешенные для индексации. При нажатии на кнопку открывается форма со списком путей к файлам и папкам, разрешенных для индексации. В открывшейся форме кнопка [...] позволяет выбрать файлы или папки, которые должны быть проиндексированы.
Главное зеркало (Host) | Позволяет задать адрес главного зеркала сайта. Главное зеркало необходимо обязательно указывать, если сайт обладает несколькими зеркалами.
Интервал между запросами (Crawl-delay) | Служит для указания минимального временного интервала (в сек.) между запросами поискового робота.
Карта сайта | Позволяет задать ссылку к файлу карты сайта sitemap.xml.

Яндекс

Настройка правил и ограничений для роботов Яндекса. Настройку можно выполнить как сразу для всех роботов Яндекса (вкладка "Yandex"), так и каждого в отдельности (на вкладке с соответствующим названием робота). Внешний вид вкладок одинаков и содержит следующий набор кнопок для генерации инструкций:

Кнопка | Описание
Запретить файл/папку (Disallow) | Позволяет составить инструкции, запрещающие индексировать файлы и папки по маске пути. При нажатии на кнопку открывается форма со списком уже имеющихся инструкций запрета индексации. В открывшейся форме кнопка [...] позволяет выбрать файлы или папки, которые индексировать не нужно.
Разрешить файл/папку (Allow) | Позволяет указать файлы и папки, разрешенные для индексации. При нажатии на кнопку открывается форма со списком путей к файлам и папкам, разрешенных для индексации. В открывшейся форме кнопка [...] позволяет выбрать файлы или папки, которые должны быть проиндексированы.
Главное зеркало (Host) | Позволяет задать адрес главного зеркала сайта. Главное зеркало необходимо обязательно указывать, если сайт обладает несколькими зеркалами. Важно! Для каждого файла robots.txt обрабатывается только одна директива Host.
Интервал между запросами (Crawl-delay) | Служит для указания минимального временного интервала (в сек.) между запросами поискового робота.

Google

Настройка правил и ограничений для роботов Google. Настройка выполняется для каждого робота в отдельности (на вкладке с соответствующим названием робота). Внешний вид вкладок одинаков и содержит следующий набор кнопок для генерации инструкций:

Кнопка | Описание
Запретить файл/папку (Disallow) | Позволяет составить инструкции, запрещающие индексировать файлы и папки по маске пути. При нажатии на кнопку открывается форма со списком уже имеющихся инструкций запрета индексации. В открывшейся форме кнопка [...] позволяет выбрать файлы или папки, которые индексировать не нужно.
Разрешить файл/папку (Allow) | Позволяет указать файлы и папки, разрешенные для индексации. При нажатии на кнопку открывается форма со списком путей к файлам и папкам, разрешенных для индексации. В открывшейся форме кнопка [...] позволяет выбрать файлы или папки, которые должны быть проиндексированы.
Главное зеркало (Host) | Позволяет задать адрес главного зеркала сайта. Главное зеркало необходимо обязательно указывать, если сайт обладает несколькими зеркалами. Важно! Для каждого файла robots.txt обрабатывается только одна директива Host.

Редактировать

На данной вкладке представлено текстовое поле, в котором можно вручную отредактировать содержимое файла robots.txt.

Смотрите также

  • Генератор robots.txt


Настройка sitemap

На странице Настройка sitemap (Маркетинг > Поисковая оптимизация > Настройка sitemap.xml) представлен список различных настроек генерации карты сайта.

Контекстная панель

Кнопка | Описание
Добавить | Служит для перехода к форме добавления новой настройки генерации карты сайта.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список настроек

Колонка | Описание
Колонка флажков | Выбор настроек, к которым предполагается применить какое-либо действие.
Меню действий доступные действия:
  • Редактировать - переход к редактированию настройки генерации карты сайта;
  • Запустить - запуск генерации карты сайта sitemap.xml;
  • Удалить - удаление настройки.
ID | Идентификатор настройки.
Изменено | Дата и время последнего изменения настройки или последнего запуска генерации карты сайта.
Название | Название настройки карты сайта.
Сайт | Идентификатор и название сайта, для которого составлена настройка.
Последний запуск | Дата и время последнего запуска генерации карты сайта.
кнопка Запустить | Запуск генерации карты сайта sitemap.xml.

Смотрите также

  • Генерация файла карты сайта


Создание и редактирование настройки генерации sitemap

Закладки

Для создания и редактирования настройки генерации карты сайта используется форма одного и того же вида, отличается лишь набор кнопок на контекстной панели.

Контекстная панель

Кнопка | Описание
Список настроек | Переход на страницу со списком настроек генерации.
Удалить | Удаление настройки генерации карты сайта. Кнопка доступна при редактировании существующей настройки.

Настройки

На данной вкладке выполняются базовые настройки генерации карты сайта.

Поле | Описание
Название* | Название настройки генерации карты сайта.
Адрес карты сайта* | Указывается адрес к файлу карты сайта.
Добавить правило в robots.txt после генерации | При отмеченной опции автоматически будет добавлено правило в robots.txt со ссылкой на сгенерированную карту сайта.
Последний запуск | Дата и время последней генерации карты сайты. Если генерация по данной настройке еще не выполнялась, то будет указано значение никогда.

* - поля, обязательные для заполнения.

Файлы

На вкладке указываются файлы, которые должны быть проиндексированы.

Поле | Описание
Имя файла карты сайта с данными о файлах* | Указывается имя файла, в котором будут собраны данные о файлах сайта.
Использовать | Выбирается представление структуры сайта, с которым удобнее работать для указания файлов.
Структура сайта | Указываются файлы и папки, которые должны быть добавлены в список для индексации.
Включаемые файлы | Маски включения файлов для индексации.

* - поля, обязательные для заполнения.

Инфоблоки

Вкладка позволяет указать данные каких инфоблоков должны попасть в карту сайта. Список инфоблоков представлен для того сайта, для которого выполняются настройки генерации карты сайта.

Поле | Описание
Шаблон имени файла карты сайта с данными инфоблоков* | Шаблон, по которому будут формироваться имена файлов с данными инфоблоков.
Перечень инфоблоков
Инфоблок Название информационного блока. Если инфоблок имеет подразделы, то можно раскрыть структуру инфоблока (по "стрелочке", расположенной рядом с названием) и выполнить более детальную настройку.
Поле | Описание
Название | Название подраздела инфоблока. Если у подраздела есть свои подразделы, то можно раскрыть структуру подраздела (по "стрелочке", расположенной рядом с названием) и выполнить более детальную настройку.
Секция | Если опция отмечена, то секция будет проиндексирована.
Элементы | Если опция отмечена, то все элементы текущей секции будут проиндексированы.
Автогенерация | Если опция отмечена, то карта сайта будет автоматически обновляться при создании, изменении или удалении элементов/разделов инфоблока.
Список | При отмеченной опции в карту сайта будет добавляться адрес индексной страницы инфоблока (берется из настроек инфоблока).
Секции Если она отмечена, то все разделы инфоблока будут индексироваться. Если она не отмечена, то не все разделы будут индексироваться, а только те, которые отмечены в структуре инфоблока (структура разворачивается по "стрелочке", расположенной рядом с названием инфоблока).

Опция неактивна, если инфоблок не может содержать разделы (определяется настройками его типа) или в настройках инфоблока не задан адрес страницы раздела.
Элементы | При отмеченной опции все элементы инфоблока будут индексироваться. Если опция не отмечена, но у инфоблока есть подразделы, то развернув структуру инфоблока (по "стрелочке", расположенной рядом с названием), можно отдельно настроить индексацию элементов подразделов.

* - поля, обязательные для заполнения.

Форумы

Вкладка позволяет указать данные каких форумов должны попасть в карту сайта. Список форумов представлен для того сайта, для которого выполняются настройки генерации карты сайта.

Поле | Описание
Шаблон имени файла карты сайта с данными форумов* | Шаблон, по которому будут формироваться имена файлов с данными форумов.
Перечень форумов
Форумы | Название форума. Если опция, расположенная рядом с названием отмечена, то форум будет индексироваться.
Автогенерация | Если опция отмечена, то карта сайта будет автоматически обновляться при добавлении, обновлении и удалении сообщений/тем форума.
Темы | Если она отмечена, то при переиндексации в файл попадают последние 100 тем форума. Если не отмечена, то при переиндексации в файл попадает одна последняя тема.

* - поля, обязательные для заполнения.


Отправить отзыв по этому разделу

Поисковые системы

  • Яндекс
  • Google


Яндекс

Страница Поисковая оптимизация: Yandex (Маркетинг > Поисковая оптимизация > Поисковые системы > Яндекс) служит для подключения сайта к сервису Яндекс.Вебмастер.

Данные авторизации

Если данные об авторизации отсутствуют, то необходимо нажать кнопку Авторизоваться в Яндексе и ввести логин и пароль пользователя Яндекс. Затем следует скопировать специальный код, ввести его в появившееся поле и нажать кнопку Отправить. Отобразится информация о пользователе.

Сменить пользователя Яндекс можно с помощью соответствующей ссылки сменить авторизацию.

Список сайтов

Поле | Описание
Меню действий Доступно следующее действие:
  • Информация - просмотр информации по оптимизации сайта (доступно, если сайт привязан к Яндексу).
Домен | Домен сайта.
Сайт | Идентификатор и название сайта.
Активность | Признак активности сайта.
Привязан к аккаунту | Информация о том, привязан ли сайт к аккаунту. Если нет, то следует выполнить авторизацию, а когда авторизация пройдена, нажать ссылку привязать.
Доступ подтвержден | Информация о том, подтвержден ли доступ . Выполняется после привязки к аккаунты по ссылке привязать.

Информация по оптимизации. Закладки

Общая информация

На данной вкладке показана сводная информация, которую предоставил Яндекс.Вебмастер. Перейдя на сайт Яндекса по соответствующей ссылке Управление сайтом в Яндекс.Вебмастер, можно получить всю дополнительную информацию по сайту.

Популярные запросы

На вкладке отображаются запросы, которые привели пользователей на ваш сайт, количество показов, кликов по ним и позиция сайта по данным запросам.

Индексация

На вкладке представлена сводная статистика об индексации сайта и найденные сервисом Яндекс.Вебмастер проблемы, с которыми желательно разобраться (особенно по 404 ошибкам).

Оригинальные тексты

Данная вкладка содержит информацию о загруженных оригинальных текстах и подсказку как это сделать. Можно отправить любой уникальный текст сайта (описания товаров, стати и т.д.) в Яндекс, чтобы закрепить за этим текстом свои права. Принимается текст от 500 символов.

Важно! Текст должен принадлежать только вам и быть уникальным.


Google

Страница Поисковая оптимизация: Google (Маркетинг > Поисковая оптимизация > Поисковые системы > Google) служит для подключения сайта к сервису Google Инструменты для веб-мастеров.

Данные авторизации

Если данные об авторизации отсутствуют, то необходимо нажать кнопку Авторизоваться в Google и ввести логин и пароль аккаунта Google. Затем следует скопировать специальный код, ввести его в появившееся поле и нажать кнопку Отправить. Отобразится информация о пользователе.

Сменить пользователя Google можно с помощью соответствующей ссылки сменить авторизацию.

Список сайтов

Поле | Описание
Меню действий Доступно следующее действие:
  • Информация - просмотр информации по оптимизации сайта (доступно, если сайт привязан к Google).
Домен | Домен сайта.
Сайт | Идентификатор и название сайта.
Активность | Признак активности сайта.
Привязан к аккаунту | Информация о том, привязан ли сайт к аккаунту. Если нет, то следует выполнить авторизацию, а когда авторизация пройдена, нажать ссылку привязать.
Доступ подтвержден | Информация о том, подтвержден ли доступ . Если нет, то следует выполнить авторизацию, а когда авторизация пройдена, нажать ссылку привязать.

Информация по оптимизации. Закладки

Общая информация

На данной вкладке сервис Google отображает общую информацию по сайту: регион и главное зеркало сайта. Кроме того, с этой вкладки можно осуществить переход в сервис Инструменты для веб-мастеров и получить дополнительную информацию.

Закладка "Ключевые слова"

На вкладке отображается статистика по ключевым словам.

Закладка "Ошибки индексации"

На вкладке отображается список ошибок, которые нашел сервис Google на сайте.


Баннерная реклама. Описание модуля

Система управления рекламой позволяет организовать показ баннеров на сайте, подключив код внешней баннерной системы, либо за счет внутренней ротации баннеров в пределах сайта.

Для каждой рекламной области можно загрузить несколько баннеров. При внутренней ротации на сайте баннеры будут выбираться для показа случайным образом. Частоту выбора того или иного баннера можно задавать с помощью коэффициента вероятности показа (веса баннера). Чем выше значение данного коэффициента, тем больше вероятность показа данной рекламы.

С помощью модуля Реклама, баннеры также можно управлять показом счетчиков посещений.

В административном интерфейсе модуля вы можете создавать новую рекламу, а также новые типы рекламных блоков. Для создания новых рекламных областей необходимо изменение основного шаблона сайта.

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Баннер | advertising.banner | Выводит баннер заданного типа.

Смотрите также

  • Как разместить баннер
  • Как разрешить сторонним пользователям управлять их рекламой на вашем сайте
  • Как разместить баннеры на сайте в случае отсутствия модуля Рекламы
  • Создание рекламного контракта
  • Создание баннера
  • Документация для разработчиков по модулю Реклама, баннеры


Контракты

Страница Контракты

На странице Контракты (Маркетинг > Баннерная реклама > Контракты) представлен список рекламных контрактов.

Рекламный контракт – набор ограничений, связанных с показом баннеров. К рекламному контракту может быть привязано произвольное число пользователей, имеющих различные права на этот контракт.

Владельцы контракта – пользователи, привязанные к контракту и имеющие различные права на него. Пользователь может быть привязан к контракту только в том случае, если он входит в группу, для которой в настройках модуля Реклама, баннеры установлен уровень доступа рекламодатель.

Отклик баннеров контракта (CTR) - отношение суммарного числа кликов на баннеры контракта к суммарному числу показов этих баннеров. Выражается в процентах и рассчитывается по следующей формуле: (K * 100) / S, где K – суммарное количество кликов на все баннеры контракта, S – суммарное количество показов всех баннеров контракта. Контракт с CTR выше 10% считается удачным.

Вес контракта - число, влияющее на вероятность выбора контракта при показе баннеров. При показе баннера в публичной части сайта сначала выбирается контракт, баннер которого будет показан. При этом, чем выше вес контракта, тем больше вероятность того, что данный контракт будет выбран. После того, как определён контракт, система выбирает баннер, принадлежащий данному контракту.

Форма поиска

Форма фильтра используется для выбора из списка рекламных контрактов в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Найти | Позволяет найти рекламные контракты по их основным параметрам: ID, Заголовок и Описание. Поле присутствует, даже если фильтр свернут.
ID | Поиск рекламных контрактов по идентификатору.
Изменено (DD.MM.YYYY) | Поиск рекламных контрактов по интервалу времени возможного изменения.
Индикатор Поиск рекламных контрактов по значению индикатора:
  • красный – контракт неактивен либо истек в соответствии со своими ограничениями;
  • зеленый – контракт активен и не истек.
Сайты | Позволяет отобразить только те рекламных контракты, баннеры которых показываются только на указанных сайтах.
Количество баннеров | Поиск рекламных контрактов по интервалу количества баннеров, приписанных к контрактам.
Посетителей | Поиск рекламных контрактов по интервалу числа уникальных посетителей, которым были показаны баннеры контрактов.
Показано | Поиск рекламных контрактов по интервалу суммарного количества показов баннеров.
Кликнули | Поиск рекламных контрактов по интервалу суммарного количество кликов на баннеры.
Отклик баннеров контракта (CTR) (%) | Поиск рекламных контрактов по интервалу отклика баннеров контракта (CTR) (%).
ID, логин или имя владельца* | Поиск рекламных контрактов по идентификатору и/или логину и/или имени владельца контракта.
Заголовок* | Поиск рекламных контрактов по заголовку.
Описание* | Поиск рекламных контрактов по описанию.
Административный комментарий* | Поиск рекламных контрактов комментарию администратора.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image]. При поиске по данному полю вы можете пользоваться флагом в чекбоксе, расположенным справа от поля для поиска точного совпадения с искомой информацией.

Чтобы отобрать рекламные контракты по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех контрактов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить контракт | Переход к форме создания нового рекламного контракта.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список рекламных контрактов

Поле | Описание
Колонка флажков | Поле предназначено для выбора контрактов, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над контрактом:
  • Изменить - переход к форме редактирования параметров рекламного контракта;
  • Просмотреть - просмотр параметров контракта;
  • График - просмотр графика CTR для данного контракта;
  • Удалить - удаление контракта.

    Примечание: удаление контракта, используемого по умолчанию (с ID=1), невозможно.
ID | Идентификатор контракта.
Инд. Индикатор контракта:
  • – контракт не активен, либо истек в соответствии со своими ограничениями;
  • – контракт активен.
Изменено | Дата и время последнего изменения контракта.
Сайты | Сайты, на которых действует данный контракт.
Сорт. | Порядок показа контрактов в списке.
Акт. | Признак активности контракта. Для показа в публичном разделе сайта могут быть выбраны баннеры только активного контракта.
Вес | Относительный "вес" контракта. Влияет на вероятность выбора для показа в публичном разделе баннера, принадлежащего к данному контракту.
Заголовок | Заголовок контракта.
Баннеров | Количество баннеров, принадлежащих контракту. Ссылка с количеством баннеров позволяет перейти к списку этих баннеров.

Смотрите также

  • Контракты (учебный курс "Продвижение сайта и маркетинг")


Типы баннеров

На странице Типы баннеров (Маркетинг > Баннерная реклама > Типы баннеров) представлен список используемых в системе типов баннеров.

Тип баннера - именованная область в HTML-шаблоне сайта, в которой выводятся баннеры. Имя области в шаблоне сайта совпадает с именем типа баннера, которые требуется показывать в данной области.

Фильтр

Форма фильтра используется для выбора из списка типов баннеров в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Найти | Позволяет найти типы баннеров по их основным параметрам: ID, Имя и Описание. Поле присутствует, даже если фильтр свернут.
ID* | Поиск типов баннеров по идентификатору.
Изменено (DD.MM.YYYY) | Поиск типов баннеров по интервалу времени возможного изменения.
Активен | Поиск типов баннеров по активным, неактивным или всем типам.
Имя* | Поиск типов баннеров по имени.
Описание* | Поиск типов баннеров по описанию.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image]. При поиске по полю вы можете пользоваться чекбоксом, расположенным справа от поля для поиска точного совпадения с искомой информацией.

Чтобы отобрать типы баннеров по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех типов баннеров нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить тип | Переход к форме создания нового типа баннеров.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список типов баннеров

Поле | Описание
Колонка флажков | Выбор типов баннеров, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над типом баннеров:
  • Изменить - переход к форме редактирования типа баннеров;
  • Просмотреть - просмотр параметров типа баннеров;
  • График CTR - просмотр графика отклика для баннеров данного типа;
  • Удалить - удаление типа баннеров.
ID | Символьный идентификатор типа баннеров.
Изменено | Дата и время последнего изменения типа баннеров.
Акт. | Признак активности типа баннеров.
Сорт. | Относительный "вес", влияющий на порядок вывода типов баннеров в списке.
Имя | Произвольное имя типа баннеров.
Описание | Произвольное описание типа баннеров.
Баннеров | Количество баннеров данного типа. Ссылка с количеством баннеров позволяет перейти к списку баннеров этого типа.


Создание и редактирование типа баннеров

Контекстная панель

Кнопка | Описание
Список типов | Переход на страницу со списком типов баннеров.
График CTR типа | Просмотр графика CTR для баннеров данного типа. Кнопка отображается при редактировании существующего типа баннеров.
Просмотреть тип | Переход к форме просмотра параметров типа баннеров. Кнопка отображается при редактировании существующего типа баннеров.
Добавить тип | Переход к форме создания нового типа баннеров. Кнопка отображается при редактировании существующего типа баннеров.
Удалить тип | Удаление текущего типа баннеров. Кнопка отображается при редактировании существующего типа баннеров.

Закладка Тип баннера

Закладка служит для создания нового или редактирования существующего типа баннеров.

Примечание для разработчиков: после создания нового типа следует изменить HTML-шаблон сайта, выделив в нем место для отображения баннеров нового типа путём вызова $APPLICATION->ShowBanner(...) (более подробную информацию по функции можно посмотреть на странице документации для разработчиков).

Поле | Описание
Создан | Дата и время создания типа баннеров, а также имя пользователя, создавшего данный тип. Поле отображается при редактировании существующего типа баннеров.
Изменен | Дата и время последнего изменения типа баннеров, а также имя пользователя, выполнившего изменение. Поле отображается при редактировании существующего типа баннеров.
Активен | При отмеченной опции тип баннеров будет активным.
Порядок сортировки | Задается относительный "вес", влияющий на порядок вывода типов баннеров в списке.
*Символьный идентификатор (ID) | Указывается символьный идентификатор типа баннеров. Допустимо использование латинских букв, цифр, символа подчеркивания _. Используется для определения места показа баннеров данного типа в шаблоне сайта (см. ShowBanner).
Имя | Указывается произвольное имя типа баннеров.
Описание | Указывается произвольное описание типа баннеров.

* - поля, обязательные для заполнения.


Баннеры

Страница Баннеры

На странице Баннеры (Маркетинг > Баннерная реклама > Баннеры) представлен список рекламных баннеров, имеющихся на сайте.

Рекламный баннер – это графическое изображение или текстовый блок рекламного характера, клик на котором обычно приводит к открытию страницы с описанием рекламируемого товара или услуги.

О классификации баннеров читайте в главе Тип и группа баннера.

О том, в каких статусах может находиться баннер смотрите в уроке Создание баннера.

При переводе баннера в тот или иной статус можно указать причину смены статуса в поле Комментарий к статусу.

Пример размещения баннера на сайте рассмотрен здесь.

Отклик баннера (CTR) – отношение числа кликов на баннер к числу показов этого баннера. Выражается в процентах и рассчитывается по следующей формуле: (K * 100) / S, где K – число кликов на баннер, S – число показов баннера. Баннер с CTR выше 10% считается очень удачным.

Вес баннера - число, влияющее на вероятность выбора баннера при показе. При показе баннера в публичной части сайта сначала выбирается контракт, баннер которого будет показан. При этом, чем выше вес контракта, тем больше вероятность того, что данный контракт будет выбран. После того, как определён контракт, система выбирает баннер, принадлежащий данному контракту. Чем выше вес баннера, тем больше вероятность выбора данного баннера для показа.

Группа баннера – баннеры, обладающие каким-либо общим признаком (например, рекламируемый объект), могут быть объединены в группу. Название группы задается произвольно. Группировка баннеров применяется для удобства управления баннерами, а также при построении отчетов по рекламным компаниям.

Фильтр

Форма фильтра используется для выбора из списка баннеров в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Найти | Позволяет найти баннеры по их основным параметрам: ID, Название и Код. Поле присутствует, даже если фильтр свернут.
*ID | Поиск банеров по идентификатору.
Индикатор | Поиск баннеров по значению индикатора: – баннер неактивен (например, истек заданный период активности); – баннер активен. На значение данного индикатора влияет индикатор контракта, к которому принадлежит баннер. Если контракт имеет красный индикатор (контракт не активен), то все баннеры данного контракта будут также иметь красный индикатор.
Статус | Поиск баннеров по статусам.
Сайты | Позволяет отобразить только те баннеры, которые показываются только на указанных сайтах.
Посетителей | Поиск баннеров по интервалу числа уникальных посетителей, которым был показан тот или иной баннер.
Показано | Поиск баннеров по интервалу суммарного количества показов баннеров.
Кликнули | Поиск баннеров по интервалу суммарного количество кликов на баннеры.
Отклик баннера (CTR) (%) | Поиск баннеров по интервалу отклика баннеров (CTR) (%).
Группа* | Поиск по группе, к которой относиться баннер.
Контракт* | Поиск баннеров по рекламным контрактам.
Тип* | Поиск по типу баннера.
Название* | Поиск по имени баннера.
Код* | Поиск по коду баннера.
Комментарий* | Поиск по комментарию к баннеру.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image]. При поиске по данному полю вы можете пользоваться флагом в чекбоксе, расположенным справа от поля для поиска точного совпадения с искомой информацией.

Чтобы отобрать баннеры по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех баннеров нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить баннер | Переход к форме создания нового баннера.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список баннеров

Поле | Описание
Колонка флажков | Выбор баннеров, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над баннеров:
  • Изменить - переход к форме редактирования параметров баннера;
  • Просмотреть - просмотр параметров баннера;
  • График CTR - просмотр графика отклика для данного баннера;
  • Копировать - создание копии баннера;
  • Удалить баннер - удаление баннера.
ID | Идентификатор баннера.
Инд. Индикатор активности баннера:
  • – баннер неактивен (например, истек заданный период активности);
  • – баннер активен.
На значение данного индикатора влияет индикатор контракта, к которому принадлежит баннер. Если контракт имеет красный индикатор (контракт не активен), то все баннеры данного контракта будут также иметь красный индикатор.
Название | Название (имя) баннера.
Тип | Название типа баннера.
Акт. Признак активности баннера:
  • Да - баннер активен;
  • Нет - баннер неактивен.
Вес | Относительный "вес" баннера, влияющий на вероятность выбора баннера для показа на сайте.
Группа | Группа баннера.
Контракт | Контракт баннера.
Сайты | Сайты, на которых может быть показан данный баннер.
Статус | Текущий статус баннера.
Создан | Дата и время создания баннера.
Изменен | Дата и время последнего редактирования баннера.
Посетителей | Число посетителей.
Посетителей макс. | Максимальное число посетителей.
Показано | Количество выполненных показов баннера.
Максим. показов | Максимальное число показов баннера.
Последний показ | Дата и время последнего показа баннера.
Кликнули | Число кликов баннера.
Максим. кликов | Максимальное число кликов баннера.
Последний переход | Дата и время последнего перехода.
CTR (%) | Значение показателя отклика баннера в процентах.
Дата первого показа | Дата и время первого показа баннера.
Равномерность ротации | Отметка о равномерности показа баннера.
Комментарий | Комментарий к баннеру.


Создание и редактирование баннера

Закладки

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком баннеров.
График CTR баннера | Просмотр графика CTR для данного баннера. Кнопка отображается при редактировании существующего баннера.
Просмотреть баннер | Переход к форме просмотра параметров баннера. Кнопка отображается при редактировании существующего баннера.
Добавить баннер | Переход к форме создания нового баннера. Кнопка отображается при редактировании существующего баннера.
Копировать баннер | Копирование текущего баннера в новый. Кнопка отображается при редактировании существующего баннера.
Удалить баннер | Удаление редактируемого баннера. Кнопка отображается при редактировании существующего баннера.

Форма предназначена для создания новых и изменения параметров существующих баннеров. Для удобства работы форма разделена на несколько закладок. Каждая закладка содержит логически сгруппированный набор полей для управления параметрами баннера.

Баннер

Закладка cлужит для задания основных параметров баннера.

Поле | Описание
Статус баннера Индикатор, определяющий статус показа баннера:

- баннер не показывается;

- баннер показывается.

Поле отображается при редактировании существующего баннера.
Создан Дата и время создания баннера, а также имя пользователя, создавшего баннер.

Поле отображается при редактировании существующего баннера.
Изменен Дата и время изменения баннера, а также имя пользователя, выполнившего изменения.

Поле отображается при редактировании существующего баннера.
Контракт | Указывается контракт, к которому приписывается баннер. Перечень доступных контрактов представлен в виде поля со списком.
Активен | При отмеченной опции баннер будет активным. Для показа в публичном разделе доступны только активные баннеры.
Интервал показа (DD.MM.YYYY) | Задается период времени, в течение которого баннер может показываться на сайте. По истечении этого периода, баннер становится не активным.
Название | Указывается произвольное имя баннера.
Группа баннеров | Указывается произвольная группа баннера (в выпадающем списке вы можете выбрать одну из ранее созданных групп).
Тип баннера | Указываетя тип баннера.
Вес (приоритет) | Задается относительный "вес", влияющий на вероятность выбора баннера для показа в публичном разделе сайта.
Что показывать
Тип шаблона баннера | Способ формирования внешнего вида баннера. В зависимости от выбранного значения (Изображение, Flash (больше [dw]не поддерживается[/dw][di]Поддержка Flash-технологий официально прекращена 31.12.2020.[/di]), HTML-код, Баннер для шаблона Bootstrap, Баннер для шаблона Niva Slader, Баннер для шаблона Jssor Slader, Баннер для шаблона Parralax, Баннер для шаблона Bootstrap 4.) количество полей в секции Что показывать будет различаться. В шаблона для слайдеров и в шаблоне для Bootstrap создаётся неограниченное число слайдеров.
Расширенный режим | Изменяет возможности настроек выбранного типа баннера. Неактуален для Изображения, Flash и HTML-кода. Расширенный режим показывает html-редактор, в котором можно сделать какие угодно варианты отображения слайда, а не по заданным в системе шаблонам.
Изображение
Файл | Поле для загрузки графического файла с локального компьютера.
URL для перехода при клике на изображении | Адрес страницы, которая будет открыта по клику на баннере. В параметрах URL'а можно использовать шаблон #EVENT_GID#, заменяемый на строку, идентифицирующую посетителя (используется модулем Веб-аналитика).
Где развернуть URL (атрибут target) Параметр, определяющий, в каком окне будет показана страница, открытая по клику на баннер:
  • _self – открыть в текущем окне (по умолчанию);
  • _blank – открыть в новом окне;
  • _parent – открыть в своем фрейме;
  • _top - во всем текущем окне браузера.
Текст всплывающей подсказки | Текст подсказки, которая будет появляться при наведении указателя мыши на баннер.
Показать/скрыть дополнительный HTML-код баннера Ссылка позволяет показать либо скрыть поле для дополнительного HTML-кода баннера.

Код баннера - произвольный текст или HTML-код, который будет отображаться в качестве баннера.

В коде баннера можно использовать макросы #RANDOM1#, #RANDOM2#, #RANDOM3#, #RANDOM4#, #RANDOM5#, которые будут заменены случайными числами в момент показа в публичной части сайта данного кода. Также можно использовать следующие шаблоны:
  • #BANNER_NAME# - имя баннера;
  • #BANNER_ID# - ID баннера;
  • #CONTRACT_ID# - ID контракта;
  • #TYPE_SID# - тип баннера.
Flash
Тип шаблона баннера Flash больше [dw]не поддерживается[/dw][di]Поддержка Flash-технологий официально прекращена 31.12.2020.[/di]. При попытке добавить flash-баннер будет выведено сообщение: Плагин "Adobe Flash Player" больше не поддерживается в форме создания баннера и в публичной части сайта.

Параметры flash баннера
Файл | Поле для загрузки flash-файла с локального компьютера.
Прозрачность Указывается режим прозрачности Flash баннера:
  • transparent - фон страницы будет "проглядывать" через все прозрачные места баннера при отображении;
  • opaque - баннер будет помещен на задний план страницы;
  • window - баннер будет отображаться на странице в собственном прямоугольном окне.
Вставлять flash с помощью javascript (позволяет выводить альтернативную картинку, если отключен Flash) При отмеченной опции flash будет вставляться с помощью Javascript (позволяет выводить альтернативную картинку, если отключен Flash). При этом станут доступными [dw]дополнительные поля.[/dw][di]
  • Требуемая версия flash - указывается версия Flash, необходимая для отображения баннера;
  • Альтернативное изображение - задается путь к альтернативному изображению, которое будет показано в виде баннера, если отключен Flash.
[/di]
Установить ссылку на Flash-баннере (если внутри ролика нет ссылок) | При отмеченной опции если внутри ролика нет ссылок, то ссылка на Flash-баннере будет установлена с помощью полей URL для перехода при клике на изображении, Где развернуть URL (атрибут target) и Текст всплывающей подсказки.
URL для перехода при клике на изображении | Адрес страницы, которая будет открыта по клику на баннере. В параметрах URL'а можно использовать шаблон #EVENT_GID#, заменяемый на строку, идентифицирующую посетителя (используется модулем Веб-аналитика).
Где развернуть URL (атрибут target) Параметр, определяющий, в каком окне будет показана страница, открытая по клику на баннер:
  • _self – открыть в текущем окне (по умолчанию);
  • _blank – открыть в новом окне;
  • _parent – открыть в своем фрейме;
  • _top - во всем текущем окне браузера.
Текст всплывающей подсказки | Текст подсказки, которая будет появляться при наведении указателя мыши на баннер.
Показать/скрыть дополнительный HTML-код баннера Ссылка позволяет показать либо скрыть поле для дополнительного HTML-кода баннера.

Код баннера - произвольный текст или HTML-код, который будет отображаться в качестве баннера.

В коде баннера можно использовать макросы #RANDOM1#, #RANDOM2#, #RANDOM3#, #RANDOM4#, #RANDOM5#, которые будут заменены случайными числами в момент показа в публичной части сайта данного кода. Также можно использовать следующие шаблоны:
  • #BANNER_NAME# - имя баннера;
  • #BANNER_ID# - ID баннера;
  • #CONTRACT_ID# - ID контракта;
  • #TYPE_SID# - тип баннера.

HTML-код
Произвольный текст или HTML-код, который будет отображаться в качестве баннера.

В коде баннера можно использовать макросы #RANDOM1#, #RANDOM2#, #RANDOM3#, #RANDOM4#, #RANDOM5#, которые будут заменены случайными числами в момент показа в публичной части сайта данного кода. Также можно использовать следующие шаблоны:
  • #BANNER_NAME# - имя баннера;
  • #BANNER_ID# - ID баннера;
  • #CONTRACT_ID# - ID контракта;
  • #TYPE_SID# - тип баннера.
Баннер для шаблона Bootstrap, Niva Slader, Jssor Slader, Parralax, Bootstrap 4.
Тип слайда | Для каждого создаваемого слайда задаётся свой тип: Изображение или видео (с сайта или Youtube.)
Ссылка слайда | Адрес страницы куда ведёт клик по слайду.
Текст всплывающей подсказки | Текст всплывающей подсказки.
Где открыть ссылку | Выбор места открытия: другое окно, другая вкладка и так далее
Шаблон слайда | Выбор предустановленного шаблона показа слайда.
Группа полей Показать ... | Включает отображение какого-либо свойства. После включения появляются поля для настройки свойства.
Статус баннера
Статус Указывается один из статусов баннера, определяющий возможность показа баннера на сайте:
  • Подтвержден – в данном статусе баннер доступен для показа на сайте;
  • На рассмотрении – данный статус не позволяет показывать баннер на сайте и означает, что баннер необходимо либо перевести в статус Подтвержден, либо в статус Отклонен;
  • Отклонен – в данном статусе баннер не может быть показан на сайте.
Комментарий к статусу | Задается пояснение к изменению статуса баннера.
Оповестить об изменении статуса владельцев контракта | При отмеченной опции при изменении статуса баннера владельцу контракта, к которому относится баннер, будет отправлено почтовое сообщение по шаблону Изменился статус баннера.

Ограничения

Закладка служит для задания ограничений на показ баннера.

Поле | Описание
Фиксировать число показов баннера | При отмеченной опции число показов баннера будет фиксироваться (ограничиваться).
Показывать баннеры с равномерной скоростью При отмеченной опции баннер будет показываться с равномерной скоростью.
Для этого необходимо настроить следующие параметры:
  • указать Интервал показа (DD.MM.YYYY);
  • отметить опцию Фиксировать число показов баннера;
  • задать Максимальное число показов баннера.
Максимальное число посетителей, для которых будет показан баннер

Указывается максимальное число посетителей, для которых будет показан баннер.

При редактировании баннера рядом с данным полем отображается число посетителей, которым был показан баннер. Чтобы обнулить показатели счетчика, установите флаг в поле сбросить и нажмите кнопку Применить.

Это поле будет активно только при отмеченной опции Фиксировать число показов баннера.

Максимальное число показов данного баннера одному посетителю

Указывается максимальное число показов данного баннера одному посетителю. Считается, что оптимальным количество показов баннера одному посетителю равно 4.

Это поле будет активно только при отмеченной опции Фиксировать число показов баннера.

Максимально число показов баннера

Указывается максимально число показов баннера, при достижении которого баннер становится неактивным.

При редактировании баннера рядом с данным полем отображается число выполненных показов баннера. Чтобы обнулить показатели счетчика, установите флаг в поле сбросить и нажмите кнопку Применить.

Это поле будет активно только при отмеченной опции Фиксировать число показов баннера.

Фиксировать клики на данный баннер | При отмеченной опции клики по данному баннеру будут регистрироваться в модуле Веб-аналитика.
Максимальное число кликов на баннер Указывается максимальное число кликов на баннер, при достижении которого баннер становится неактивным.

При редактировании баннера рядом с данным полем отображается число выполненных кликов по баннеру. Для того чтобы обнулить показатели счетчика, установите флаг в поле сбросить и нажмите кнопку Применить.
Отклик баннера (CTR) (%) | В поле отображается значение показателя отклика данного баннера в процентах.

Таргетинг

Закладка служит для настройки таргетинга рекламы. Диапазон доступных значений полей зависит от настроек контракта, к которому относиться данный баннер.

Поле | Описание
Сайты | Указываются сайты, на которых будет показываться баннер.
Разделы и страницы, на которых баннер обязательно будет показан Указываются адреса разделов или страниц сайта, на которых баннер будет обязательно показан. Например: /ru/catalog/ или /ru/catalog/index.php.
Или, чтобы показать баннер только на главной странице сайта, нужно задать в первом поле полный адрес страницы (не раздела, а именно включая файл страницы): www.mysite.ru/index.php.

Адреса страниц могут быть заданы с использованием параметров. Каждый адрес раздела или страницы должен начинаться с новой строки.
Разделы и страницы, на которых баннер не будет показан Указываются адреса разделов или страниц сайта, на которых не будет показан данный баннер.

Адреса страниц могут быть заданы с использованием параметров. Каждый адрес раздела или страницы должен начинаться с новой строки.
Группы пользователей Указываются группы пользователей, для которых будет/не будет показываться данный баннер.

Для этого выберите необходимые группы пользователей и установите переключатель в одно из значений: или Не показывать баннер для выбранных групп.
Ключевые слова Задаются ключевые слова для баннера, влияющие на возможность показа баннера на страницах сайта:
  • если для страницы сайта заданы желательные ключевые слова, то баннер будет показан на странице в том случае, если хотя бы одно ключевое слово баннера присутствует в наборе желательных ключевых слов страницы;
  • если для страницы сайта заданы обязательные ключевые слова, то баннер будет показан на странице в том случае, если набор ключевых слов баннера совпадает с набором обязательных ключевых слов страницы.
Более подробная информация приводится в руководстве Управление показом баннеров с помощью ключевых слов [image].
Параметры геотаргетинга Указываются страны, регионы или города, посетителям из которых будет показываться данный баннер.

Чтобы добавить, например страну, в список, установите опцию Страны и нажмите кнопку Добавить... и в открывшейся форме укажите страну, которую требуется добавить. Для удаления выберите пункт(ы) в списке и нажмите кнопку Удалить отмеченные.
Показать только для посетителей, приходящих по следующим рекламным кампаниям Поле доступно только администраторам модуля.

Указываются рекламные компании, для посетителей которых (пришедших по определённой рекламной компании) будет показан баннер. Регистрация рекламных компаний выполняется с помощью модуля Веб-аналитика.
Показывать посетителям Указывается каким посетителям показывать баннер:
  • всем - показывать баннер всем посетителям сайта;
  • только новым - показывать баннер пользователям, впервые пришедшим на сайт;
  • только вернувшимся - показывать баннер пользователям, вернувшимся на сайт.
Время и дни недели для показа | Задаются часы и дни недели, по которым баннер доступен для показа. На диапазон доступных значений влияют ограничения, заданные для контракта, к которому относится баннер.

Примечание: наличие слэша в конце адреса влияет на выбор каталогов системой, так как включаются все адреса, начинающиеся с указанной строки.

Пример:

  • Если ввести: www.mysite.ru/dir/, то под условие будут подходить все страницы из разделов www.mysite.ru/dir/, www.mysite.ru/dir/other/ и т.п.
  • Если ввести www.mysite.ru/dir, то под условие будут подходить все страницы предыдущего примера, плюс к ним добавятся разделы вида www.mysite.ru/dir_another, www.mysite.ru/directory, и т.п., то есть, отношения к каталогу dir не имеющие.

Статистика

Внимание! С версии 21.100.0 модуля Реклама, баннеры убрана возможность фиксировать статистику по кликам на баннеры, т.е. вкладка Статистика в форме настроек баннера более НЕ доступна. Возможность считать клики на баннер оставлена в API [image] (требуется написание своего скрипта для подсчета ссылок).

Закладка служит для управления параметрами регистрации кликов на баннер в модуле Веб-аналитика. Управление параметрами доступно только администраторам сайта.

Поле | Описание
Фиксировать в статистике | При отмеченной опции будет происходить регистрация событий клика по баннеру в модуле Веб-аналитика.
Event1 | Идентификатор типа события - event1.
Event2 | Идентификатор типа события - event2.
Event3 Дополнительный параметр события.

Для создания идентификаторов типа события event1, event2, event3 можно использовать следующие макросы:
  • #BANNER_NAME# - имя баннера;
  • #BANNER_ID# - ID баннера;
  • #CONTRACT_ID# - ID контракта;
  • #TYPE_SID# - тип баннера.

Комментарий

Закладка предназначена для создания произвольного комментария к баннеру.

Кнопки управления

Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Переход на страницу со списком баннеров.
Применить | Сохранение внесённых изменений. Продолжение редактирования параметров баннера.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.

Смотрите также

  • Создание баннера (учебный курс "Продвижение сайта и маркетинг")


Баннерная реклама. Настройки модуля

Закладки

Форма настроек модуля Реклама, баннеры (Настройки > Настройки продукта > Настройки модулей > Реклама, баннеры) предназначена для задания параметров модуля.

Настройки

Поле | Описание
Не использовать ограничения контрактов при показе баннера | При отмеченной опции ограничения контрактов не будут использоваться при показе баннеров.
Не фиксировать показы всех баннеров | При отмеченной опции показы всех баннеров фиксироваться не будут.
Использовать HTML редактор для настройки баннера | При отмеченной опции будет использоваться визуальный HTML-редактор для настройки баннера.
Сколько дней хранить динамику по баннерам? | Указывается количество дней, отводимых для хранения динамики (данные о показах и кликах) по баннерам. Если установить флаг в поле Очистить и нажать кнопку Сохранить, то данные динамики по баннерам будут стерты.
Ширина графика | Ширина графика отчета (в пикселях).
Высота графика | Высота графика отчета (в пикселях).
Диаметр круговой диаграммы | Диаметр круговой диаграммы отчета (в пикселях).
На сколько дней запоминать, что посетитель посмотрел тот или иной баннер | Указывается количество дней, в течение которых посетитель считается просмотревшим тот или иной баннер.
Полное имя файла для учета кликов на баннер | Внимание! С версии 21.100.0 модуля Реклама, баннеры убрана возможность фиксировать статистику по кликам на баннеры. Параметр Полное имя файла для учета кликов на баннер более не доступен. Возможность считать клики на баннер оставлена в API [image] (требуется написание своего скрипта для подсчета ссылок). Путь к файлу, содержащему скрипт для сбора статистики по кликам на баннеры. Скрипт по умолчанию (/bitrix/rk.php) регистрирует клики в модуле Веб-аналитика (если модуль установлен), иначе предпринимается попытка зарегистрировать клик в модуле Реклама, баннеры.
Подкаталог для хранения загруженных баннеров | Указывается имя подкаталога (относительно каталога /upload/), в котором хранятся все изображения, загружаемые при создании баннеров. Если отметить опицю переместить баннеры в новый подкаталог, то все изображения, загружаемые при создании баннеров, будут перемещены в подкаталог, указанный в поле Подкаталог для хранения загруженных баннеров.

Доступ

Поле | Описание
По умолчанию | Управление уровнем доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Управление правом доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Реклама, баннеры:
  • [D] доступ закрыт - доступ запрещён;
  • [R] рекламодатель - доступ к меню и административным файлам открыт, пользователь видит только те контракты и принадлежащие им баннеры, на которые у него есть соответствующие права. Данный уровень прав используется для групп рекламодателей, размещающих свои баннеры на вашем сайте;
  • [T] менеджер баннеров - доступ к управлению всеми баннерами системы (вне зависимости от контракта);
  • [V] демо-доступ - пользователь видит все контракты, типы баннеров, баннеры, может строить любые графики, но без права модификации чего-либо (право обычно используется в демонстрационном режиме, когда пользователь может все видеть, но не имеет права что либо изменять);
  • [W] администратор рекламы - полный доступ, без каких либо ограничений.


Графики

Система "1С-Битрикс: Управление сайтом" позволяет наглядно оценить с помощью графиков ход и результаты проведения рекламной компании как по отдельным баннерам, так и в рамках определённого контракта на показ рекламы. Построение графиков выполняется в соответствующих разделах модуля Реклама, баннеры:

  • Графики по баннерам (Маркетинг > Баннерная реклама > Отчеты > Графики по баннерам);
  • Графики по контрактам (Маркетинг > Баннерная реклама > Отчеты > Графики по контрактам).

Графики позволяют отобразить информацию о количестве посетителей, просмотревших рекламу, а также данные по количеству показов, кликов и индексу отклика на рекламу (CTR). Период времени, в течение которого выполняется хранение данных, используемых для построения графиков, определяется в настройках модуля Реклама, баннеры.

По баннерам. Фильтр

Форма фильтра используется для выбора данных, на основе которых будет выполнено построение графика по баннерам.

Поле Описание
Период (DD.MM.YYYY) Указывается период времени, данные за который будут использованы при построении графика. Если значение поля не указано, то для построения графика будут использованы данные за весь доступный период.

Поле присутствует, даже если фильтр свернут.
*Что показывать Указывается, какие данные должны быть отображены на графике:
  • Посетителей (суммарно);
  • Показы;
  • [dw]Клики[/dw][di]До версии 21.100.0[/di];
  • CTR.
*Баннеры Указывается один и более баннеров, динамику по которым необходимо отобразить на графике.
В выпадающем списке можно выбрать тип графика:
  • отдельные графики – означает, что для каждого выбранного баннера будет построен отдельный график;
  • суммарный график – означает, что для всех выбранных баннеров будет построен один суммарный график.

* - обязательные параметры.

Чтобы построить график на основе выбранных параметров, нажмите кнопку Найти. Для сброса значений параметров нажмите кнопку Отменить.

По баннерам. Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

По баннерам. Пример

По баннерам. Статистика

Поле | Описание
Дата | Дата посчета статистики по баннеру.
Посетители | Количество посетителей, которым был показан баннер.
[dw]Клики[/dw][di]До версии 21.100.0[/di] | Количество кликов по данному баннеру.
CTR | Индекс отклика баннера.
Показы | Количество показов данного баннера.

По контрактам. Фильтр

Форма фильтра используется для выбор данных, на основе которых будет выполнено построение графика по контрактам.

Поле Описание
Период (DD.MM.YYYY) Указывается период времени, данные за который будут использованы при построении графика. Если значение поля не указано, то для построения графика будут использованы данные за весь доступный период.

Поле присутствует, даже если фильтр свернут.
*Что показывать Указывается, какие данные должны быть отображены на графике:
  • Посетителей (суммарно);
  • Показы;
  • [dw]Клики[/dw][di]До версии 21.100.0[/di];
  • CTR.
*Контракты Указывается один и более контрактов, динамику по приписанным баннерам которого необходимо отобразить на графике.
В выпадающем списке можно выбрать тип графика:
  • отдельные графики – означает, что для каждого выбранного контракта будет построен отдельный график;
  • суммарный график – означает, что для всех выбранных контрактов будет построен один суммарный график.

* - обязательные параметры.

Чтобы построить график на основе выбранных параметров, нажмите кнопку Найти. Для сброса значений параметров нажмите кнопку Отменить.

По контрактам. Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

По контрактам. Пример

По контрактам. Статистика

Поле | Описание
Дата | Дата посчета статистики по рекламному контракту.
Посетители | Количество посетителей, которым был показаны баннеры рекламного контракта.
CTR | Индекс отклика баннеров рекламного контракта.
Показы | Количество показов баннеров рекламного контракта.

Смотрите также

  • Построение графиков отчетов (учебный курс "Продвижение сайта и маркетинг")


Диаграммы

Система "1С-Битрикс: Управление сайтом" позволяет представить результаты проведения рекламных компаний в виде диаграмм. Построение диаграмм выполняется в соответствующих разделах модуля Реклама, баннеры:

  • Диаграммы по баннерам (Маркетинг > Баннерная реклама > Отчеты > Диаграммы баннеров);
  • Диаграммы по контрактам (Маркетинг > Баннерная реклама > Отчеты > Диаграммы контрактов).

Диаграммы позволяют наглядно сравнить количество посетителей, просмотревших различную рекламу, количество показов и кликов, а также индекс отклика на рекламу (CTR). Период времени, в течение которого выполняется хранение данных, используемых для построения диаграмм, определяется в настройках модуля Реклама, баннеры.

По баннерам. Фильтр

Форма фильтра используется для выбора данных, на основе которых будет выполнено построение диаграммы по баннерам.

Поле | Описание
Период (DD.MM.YYYY) | Указывается период времени, данные за который будут использованы при построении диаграммы. Если значение поля не указано, то для построения диаграммы будут использованы данные за весь доступный период.
*Что показывать Указывается, какие данные должны быть отображены на диаграмме:
  • Посетителей (суммарно);
  • Показы;
  • [dw]Клики[/dw][di]До версии 21.100.0[/di];
  • CTR.
Диаграмма по каждому типу данных будет представлена на отдельной закладке.
*Баннеры Выбор баннеров, данные по которым необходимо отобразить на диаграмме.

Для построения диаграммы необходимо выбрать хотя бы два баннера в списке.

* - обязательные параметры.

Чтобы построить диаграмму на основе выбранных параметров, нажмите кнопку Найти. Для сброса значений параметров нажмите кнопку Отменить.

По баннерам. Пример

По контрактам. Фильтр

Форма фильтра используется для выбора данных, на основе которых будет выполнено построение диаграммы по контрактам.

Поле | Описание
Период (DD.MM.YYYY) | Период времени, данные за который будут использованы при построении диаграммы. Если значение поля не указано, то для построения диаграммы будут использованы данные за весь доступный период.
*Что показывать Указывается, какие данные должны быть отображены на диаграмме:
  • Посетителей (суммарно);
  • Показы;
  • [dw]Клики[/dw][di]До версии 21.100.0[/di];
  • CTR.
Диаграмма по каждому типу данных будет представлена на отдельной закладке.
*Контракты | Указываются контракты, данные по которым должны быть отображены на диаграмме.

* - обязательные параметры.

Чтобы построить диаграмму на основе выбранных параметров, нажмите кнопку Найти. Для сброса значений параметров нажмите кнопку Отменить.

По контрактам. Пример

Примечание: если баннеры отсутствуют, то диаграммы не выводятся.


Создание и редактирование рекламного контракта

Закладки

Форма служит для создания новых и изменения параметров существующих рекламных контрактов.

Контекстная панель

Кнопка | Описание
Список контрактов | Переход на страницу со списком рекламных контрактов.
График CTR контракта | Просмотр графика CTR для текущего контракта. Кнопка отображается при редактировании существующего рекламного контракта.
Просмотреть параметры контракта | Переход к форме просмотра параметров контракта. Кнопка отображается при редактировании существующего рекламного контракта.
Добавить контракт | Переход к форме создания нового контракта. Кнопка отображается при редактировании существующего рекламного контракта.
Удалить контракт | Удаление текущего контракта. Кнопка отображается при редактировании существующего рекламного контракта. Нельзя удалить хранящийся по умолчанию контракт.

Контракт

Закладка предназначена для настройки основных параметров контракта.

Поле | Описание
Статус | Индикатор, определяющий статус контракта: – контракт не активен; – контракт активен. Поле отображается при редактировании существующего рекламного контракта.
Создан | Дата и время создания контракта, а также имя пользователя, создавшего контракт. Поле отображается при редактировании существующего рекламного контракта.
Изменен | Дата и время изменения контракта, а также имя пользователя, выполнившего изменение. Поле отображается при редактировании существующего рекламного контракта.
Активен | При отмеченной опции контракт будет активным. Баннеры неактивных контактов не могут быть показаны на сайте.
Период показа баннеров (DD.MM.YYYY) | Задается интервал времени, в течение которого могут показываться баннеры контракта. При истечении данного периода контракт становится неактивным.
Порядок сортировки | Указывается значение сортировки, определяющее порядок вывода контрактов в списке.
Вес (приоритет) | Указывается относительный "вес", влияющий на вероятность выбора баннеров контракта для показа в публичном разделе сайта.
Заголовок | Задается произвольный заголовок контракта.
Описание | Задается произвольное описание контракта.
Статус по умолчанию для новых баннеров и при изменении полей баннера отмеченных символом "1" | Указывается статус баннера, устанавливаемый для новых баннеров контракта либо для существующих баннеров контракта при изменении отображаемой части баннеров.
Количество баннеров контракта | Таблица, показывающая общее количество баннеров контракта (Всего) и баннеры контракта, находящиеся в разных статусах: Подтвержден, На рассмотрении и Отклонен. Ссылки с количеством баннеров позволяют перейти к спискам этих баннеров. Поле отображается при редактировании существующего рекламного контракта.

Ограничения

Закладка служит для управление ограничениями на показ рекламы, относящейся к данному контракту.

Поле | Описание
Сайты | Указываются сайты, на которых могут показываться баннеры, относящиеся к данному контракту.
Типы баннеров | Указываются типы баннеров, доступные для создания в рамках данного контракта.
Максимальное число уникальных посетителей которым будут показаны баннеры контракта | Задается ограничение на число уникальных посетителей сайта, которым будут показаны баннеры контракта. Если число уникальных посетителей, просмотревших рекламу контракта, достигает указанного значения, контракт становится неактивным. При редактировании контракта рядом с данным полем отображается число уникальных посетителей, просмотревших рекламу контракта.
Максимальное число показов баннеров контракта | Задается ограничение на суммарное количество показов всех баннеров контракта. Если суммарное число показов достигнет данного значения, контракт станет неактивным. При редактировании контракта рядом с данным полем отображается число выполненных показов баннеров контракта.
Максимальное число кликов на баннеры контракта | Задается ограничение на суммарное количество кликов на все баннеры контракта. Если суммарное число кликов достигнет данного значения, контракт станет неактивным. При редактировании контракта рядом с данным полем отображается количество выполненных кликов на баннеры контракта.
Суммарный отклик баннеров контракта (CTR) (%) | В поле отображено значение суммарного отклика баннеров контракта в процентах. Поле отображается только при редактировании уже существующего контракта.
Время и дни недели показа баннеров | Указываются часы и дни недели, по которым может выполняться показ баннеров контракта.

Таргетинг

Закладка служит для настройки таргетинга рекламы в рамках данного контракта.

Поле Описание
Разделы и страницы, только на которых должны показываться баннеры Указываются адреса разделов или страниц сайта, только на которых должны показываться баннеры контракта. Адреса страниц могут быть заданы с использованием параметров.

Каждый адрес раздела или страницы должен начинаться с новой строки.
Разделы и страницы, на которых не могут показываться баннеры Указываются адреса разделов или страниц сайта, на которых не могут показываться баннеры контракта. Адреса страниц могут быть заданы с использованием параметров.

Каждый адрес раздела или страницы должен начинаться с новой строки.
Ключевые слова Задаются ключевые слова для баннеров контракта, влияющие на возможность показа баннеров на тех или иных страницах сайта:
  • если для страницы сайта заданы желательные ключевые слова, то баннер будет показан на странице в том случае, если хотя бы одно ключевое слово баннера присутствует в наборе желательных ключевых слов страницы;
  • если для страницы сайта заданы обязательные ключевые слова, то баннер будет показан на странице в том случае, если набор ключевых слов баннера совпадает с набором обязательных ключевых слов страницы.
Более подробная информация приводится в руководстве Управление показом баннеров с помощью ключевых слов [image].

Доступ

Закладка служит для настройки прав пользователей на управление параметрами контракта, а также баннерами контракта.

Поле | Описание
Просмотр | Указываются пользователи, которым будет разрешено просматривать параметры контракта, параметры баннеров контракта, а также графики и диаграммы баннеров контракта.
Управление баннерами | Указываются пользователи, которым будет разрешено просматривать параметры контракта и выполнять создание, редактирование и удаление баннеров контракта.
Изменение прав пользователей на контракт | Указываются пользователи, которым будет разрешено редактировать параметры контракта, а также управлять правами пользователей на Просмотр и Управление баннерами для данного контракта.

Комментарий

На закладке можно указать произвольный административный комментарий к контракту.

Кнопки управления

Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Переход на страницу со списком рекламных контрактов.
Применить | Сохранение внесённых изменений. Продолжение редактирования параметров рекламного контракта.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.

Смотрите также

  • Создание контракта (учебный курс "Продвижение сайта и маркетинг")


Частые вопросы

Как использовать flash-баннеры?

Тип шаблона баннера Flash больше [dw]не поддерживается[/dw][di]Поддержка Flash-технологий официально прекращена 31.12.2020.[/di]. При попытке добавить flash-баннер будет выведено сообщение: Плагин "Adobe Flash Player" больше не поддерживается в форме создания баннера и в публичной части сайта.

Инструкция по использованию flash-баннеров
  • Предварительно flash-баннер необходимо загрузить в каталог /upload/advertising/flash/.
  • При создании баннера необходимо в коде баннера указать следующий код:

    <a
    href="../../../bitrix/click.php?id=#banner_id#&event1=banner&event2=click&event3=#banner_id#&goto=[url]">
    <div>
    <OBJECT
    classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
    codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0"
    id="banner"
    WIDTH="190"
    HEIGHT="190"
    ALIGN="">
    <PARAM NAME=movie VALUE="/upload/advertising/flash/banner.swf">
    <PARAM NAME=quality VALUE=high>
    <PARAM NAME=bgcolor VALUE=#FFFFFF>

    <EMBED
    src="../../../upload/advertising/flash/banner.swf"
    quality=high
    bgcolor=#FFFFFF
    WIDTH="190"
    HEIGHT="190"
    NAME="banner"
    ALIGN=""
    TYPE="application/x-shockwave-flash"
    PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer">
    </EMBED>
    </OBJECT>
    </div>
    </a>
    заменив при этом banner.swf на имя вашего flash-баннера и указав его размеры. В самом flash-баннере желательно не задавать ссылку для перехода. А в [URL] необходимо указать url-кодированную ссылку.

Почему у меня не считается количество посетителей, просматривающих баннеры?

Суть проблемы состоит в том, что модуль Реклама, баннеры не может уcтановить cookie для посетителя просмотревшего тот или иной баннер. Данный cookie устанавливается в функции CAdvBanner::Show, но так как в большинстве случаев, данная функция вызывается уже после того как HTML-контент страницы начинает отсылаться браузеру клиента, то в соответствии с ограничениями протокола HTTP, cookie не может быть установлен.

Проблему можно решить следующими путями:

  • Установите модуль Компрессия (если он не установлен). Данный модуль буферизирует результат парсинга, прежде чем сжать его и передать браузеру клиента. Буферизация позволит корректно учитывать посетителей просматривающих баннеры.
  • Для всех редакции, в которых есть модуль Веб-аналитика в файле /bitrix/php_interface/dbconn.php добавьте следующий PHP код:

    ob_start();
    Данная функция включает буферизацию парсинга PHP страниц, что позволит корректно учитывать посетителей.
  • Если на вашем сайте нет возможности использовать буферизацию, то учет посетителей будет работать, если в дизайне сайта (prolog_main.php, epilog_main.php) использовать следующую схему:

    <?
    // прежде чем начинается вывод страницы, необходимо получить HTML баннеров
    if (CModule::IncludeModule("advertising")):
        $strBanner_top	= CAdvBanner::Show("TOP");
        $strBanner_bottom = CAdvBanner::Show("BOTTOM");
        $strBanner_left   = CAdvBanner::Show("LEFT");
    endif;
    ?>
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head></head>
    <body>
        <?
        // выводим HTML баннеров в заранее отведенных рекламных областях
        echo $strBanner_top;
        echo $strBanner_bottom;
        echo $strBanner_left;
        ?>
    </body>
    </html>
    Т.е. перед тем как начинается вывод HTML-контента, вы предварительно запоминаете HTML всех баннеров в PHP переменных, а уже затем используете их вывод в том месте дизайна, где вам необходимо.


Магазин

Модули раздела
Название | Описание
Мастер магазина | Инструмент помощи для владельца магазина в настройке и подготовке магазина к работе.
Интернет-магазин Позволяет осуществлять продажу товаров и услуг с сайта. Интернет-магазин состоит из следующих функциональных элементов:

  • корзина товаров и услуг с возможностью добавления туда произвольных товаров и услуг;
  • процедура оформления заказа;
  • персональный раздел покупателя с возможностью просмотра сделанных заказов и настройкой профилей;
  • административный раздел для настройки параметров магазина и управления заказами клиентов.
Торговый каталог Модуль системы "1С-Битрикс: Управление сайтом", позволяющий:

  • создавать торговые каталоги товаров, услуг и всевозможного цифрового контента;
  • осуществлять продажу товаров, услуг и цифрового контента через интернет-магазин;
  • осуществлять продажу прав доступа к ресурсам сайта;
  • управлять ценами на товары и услуги торговых каталогов;
  • загружать и выгружать данные о товарах, заказах, продажах в форматах CommerceML, Froogle, Yandex и CSV (формат последнего можно настраивать при загрузке);
  • загружать и выгружать данные в любой из форматов в соответствии с созданными пользователем профилями.

Смотрите также:

  • Учебный курс "Администратор. Бизнес"


Мастер магазина

Мастер магазина - инструмент помощи для владельца магазина в настройке и подготовке магазина к работе. Детально о пользовательской части модуля смотрите в учебном курсе [image].

Форма настроек модуля (Настройки > Настройки продукта > Настройки модулей > Мастер магазина) предназначена для задания данных о веб-студии, разрабатывавшей интернет-магазин для заказчика. Данные из этих настроек будут отображены в Мастере, клиент получит возможность быстрого обращения к ТП вебстудии.

Поле | Описание
Партнер, разрабатывающий проект | Указывается название студии, разработавщей проект.
Ссылка на страницу поддержки партнера | Указывается URL страницы техподдержки студии.

Смотрите также:

  • Мастер магазина (учебный курс "Администратор. Бизнес")


Интернет-магазин. Описание модуля

К размышлению

Современный бизнес давно перешагнул порог офисов и магазинов. Можно даже утверждать, что он вышел в окно, и это не будет преувеличением или досужей метафорой - миллионы пользователей, а по сути - ваших потенциальных клиентов, проводят время в поисках товаров и услуг в Интернете, изучая предложения в окнах своих браузеров. Расширьте свой бизнес, предложите им свои товары и услуги - тем более, что с помощью системы "1C-Битрикс: Управление сайтом" это сделать так легко!

Создать свой собственный интернет-магазин вам поможет модуль Интернет-магазин, позволяющий осуществлять продажу товаров и услуг с сайта. Интернет-магазин состоит из следующих функциональных элементов:

  • корзина товаров и услуг с возможностью добавления туда произвольных товаров и услуг;
  • процедура оформления заказа;
  • персональный раздел покупателя с возможностью просмотра сделанных заказов и настройкой профилей;
  • административный раздел для настройки параметров магазина и управления заказами клиентов.

Управление параметрами интернет-магазина выполняется в разделе Настройки интернет-магазина (Магазин > Настройки магазина), а также на странице настроек модуля. Также в настройках продукта на странице Список мастеров присутствуют мастера, позволяющие настроить Интернет-магазин, загрузить базу местоположений и индексов.

Отличительные особенности интернет-магазина

Локализуемость
Все элементы интернет-магазина зависят от сайта. Так, список доступных для данного посетителя служб доставки зависит от сайта, на котором находится посетитель.

Отсутствие межмодульных зависимостей
Интернет-магазин не зависит от других модулей и может принимать в корзину товары из любого модуля или статических страниц. Модуль торгового каталога имеет набор функций, которые облегчают работу с интернет-магазином.

Полнофункциональная корзина товаров и услуг
Каждый товар при помещении его в корзину может быть дополнительно описан любым количеством произвольных параметров (свойств). Если при занесении в корзину товара была указана функция обратного вызова, то при совершении действий с корзиной для каждого товара проверяется его доступность для покупки в требуемом количестве. При помещении товара в корзину из модуля торгового каталога функция обратного вызова задается автоматически.

Многовалютность
Система позволяет гибко управлять валютами цены. Список валют определяется администратором. Для каждой валюты устанавливаются курсы (с возможностью загрузки с сайта Центрального Банка РФ), формат вывода для сайта.

Для каждого сайта назначается единая валюта пересчета цен. Таким образом, независимо от того, в какой валюте будут заноситься цены на товары, стоимость доставки, скидки и прочее, при показе в корзине и оформлении заказа эти цены будут сконвертированы в единую валюту, установленную для данного сайта. Так, для русского языка можно установить валюту RUR - рубли, при этом в русском интерфейсе все цены, которые были указаны в иностранной валюте (например, USD), будут показаны в рублях по установленному курсу.

Настройка валют для использования на сайте и, в частности, в интернет-магазине, производится при помощи модуля валют.

Важно!
Для корректной работы модуля Интернет-магазин необходимо наличие установленного в системе модуля Валюты.

Система скидок
Система управления скидками позволяет заводить несколько планов скидок, зависящих от общей стоимости заказа. Скидки могут быть заданы как в процентном, так и в фиксированном выражении. Скидка рассчитывается от общей стоимости заказа без учета стоимости доставки.

Доставка
Система доставки позволяет указывать информацию, необходимую для определения стоимости доставки. Выбор стоимости доставки осуществляется с учётом различных зон, настраиваемых индивидуально администратором магазина. Так, например, зоны доставки могут определяться по городу, по области, по стране и т.д. Количество зон доставки не ограничено. Кроме того, стоимость доставки может зависеть от общей стоимости и веса заказа. Системы доставки делятся на Настраиваемые и Автоматизированные. Для добавления настраиваемой системы доставки достаточно заполнить стандартную форму. При добавлении автоматизированной системы необходимо создать специальный обработчик системы доставки, в котором можно организовать программный рассчет стоимости доставки, также необходимо определить список профилей доставки, применимость профилей доставки к заказу и т.д.

Автоматический подсчет стоимости заказа
Стоимость заказа формируется из следующих составляющих: общая стоимость товаров в заказе (т.е. сумма произведений стоимостей на момент заказа товаров в корзине на заказанное количество данных товаров), стоимость доставки заказа (деньги, которые платятся за почтовую или курьерскую доставку). От стоимости заказа отнимается скидка на стоимость заказа (если она есть). Если в системе определены значения налогов, то они учитываются при определении стоимости заказа.

Платежные системы
Платежная система позволяет построить интерфейс для инициализации процедуры оплаты заказа электронными средствами платежа или распечатки необходимых документов для оплаты другими (не электронными) средствами платежа. Количество шаблонов платежных систем не ограничено. С дистрибутивом интернет-магазина идет набор предустановленных шаблонов платежных систем, включающий в себя поддержку платежной системы Assist (пластиковые карты, Яндекс-деньги, WebMoney), распечатку квитанций Сбербанка и некоторые другие. Все шаблоны платежных систем требуют настройки перед использованием.

Свойства заказа
При оформлении заказа система спрашивает у покупателя определённый набор параметров (свойств заказа), которые необходимы для оформления, регистрации или доставки заказа. Этот набор свойств полностью настраиваемый, неограниченный и зависит от типа покупателя, который выбирается на первом шаге оформления заказа.

Например, для покупателя типа Физическое лицо свойствами заказа могут быть:
  • фамилия и имя;
  • адрес доставки;
  • E-Mail адрес;
  • прочие свойства.
В то же время, для покупателя типа Юридическое лицо свойствами заказа могут быть:
  • название организации;
  • юридический адрес;
  • ИНН;
  • E-Mail адрес;
  • прочие свойства.
Часть свойств заказа может сохраняться в виде профиля покупателя и использоваться для облегчения заполнения формы заказа при повторных заказах.

Персональный раздел покупателя
В этом разделе покупатель имеет возможность просмотреть все свои заказы, отменить новый заказ, копировать заказы для повторного оформления, повторно распечатать необходимые документы или повторить процедуру оплаты электронными средствами платежа, просмотреть статусы заказов, просмотреть и отредактировать сохраненные профили покупателя.

Административный раздел по обработке заказов
Заказы обрабатываются по флагам Оплачен, Отменён, Разрешена доставка и статусу (Принят, В обработке, Отгружен, Доставлен и т.п.). Список статусов может быть настроен произвольно для данного сайта.

Флаги и статусы могут быть выставлены независимо друг от друга. Так, заказ может быть ещё не оплачен, но уже разрешена его доставка (наложенный платеж), или заказ оплачен, но доставка его по тем или иным причинам ещё не разрешена. Статус заказа служит для информирования покупателя и сотрудников магазина о текущем состоянии заказа.

Для заказов, оплачиваемых электронными средствами платежа, имеется возможность автоматически запросить статус платежной системы для данного заказа. Если платежная система ответит, что данный заказ оплачен и сумма оплаты совпадет с суммой заказа, то флаг Оплачен заказа автоматически поменяет своё значение на Да.

Почтовые сообщения
Оформление нового, изменение статуса существующего и отмена заказа сопровождаются почтовыми сообщениями покупателю и в отдел продаж сайта, E-Mail адрес которого задается в настройках интернет-магазина.

Интеграция с 1С
Начиная с версии продуктов "1С:Предприятие 8" редакция "Управление торговлей" версии 10.3.2 и "1С-Битрикс: Управление сайтом 6.5", редакции "Малый бизнес" и "Бизнес" поставляются со встроенными в системы штатными процедурами взаимодействия. Начиная с версии 6.5, "1С-Битрикс: Управление сайтом" поддерживает двунаправленный обмен данными с "1С:Предприятием": публикация информации из "1С", выгрузка заказов с сайта и статусов в "1С" и обратно.

Компоненты

Модуль включает в себя следующие компоненты 2.0:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Аффилиаты
Отчет аффилиата | sale.affiliate.account | Отображает движение денег на счете аффилиата.
Технические инструкции аффилиата | sale.affiliate.instructions | Служит для для вывода технических инструкций для аффилиата.
Аффилиатские планы | sale.affiliate.plans | Выводит список всех аффилиатских планов, определённых в системе.
Регистрация аффилиата | sale.affiliate.register | Служит для создания страницы регистрации аффилиата.
Отчет по программе аффилиата | sale.affiliate.report | Отображает список проданных товаров от авторизованного аффилиата за установленный период времени.
Корзина
Корзина | sale.basket.basket | Отображает список товаров, отправленных пользователем в корзину.
Ссылка на корзину | sale.basket.basket.line | В зависимости от настроек отображает ссылки на корзину пользователя и на его персональный раздел либо только на корзину.
Малая корзина для почты | sale.basket.basket.small.mail | Отображает для почты список товаров, находящихся в корзине пользователя.
Персональный раздел
Вывод полей заказа | sale.business.value.mail | Выводит список полей заказа по коду заказа.
Добавление средств на счет текущего пользователя | sale.account.pay | Позволяет добавить средства на внутренний счет текущего пользователя.
Заказы пользователя | sale.personal.order | Отображает список заказов текущего пользователя.
Отмена заказа | sale.personal.order.cancel | Позволяет отменить заказ.
Отмена подписки | sale.personal.subscribe.cancel | Позволяет отменить подписку.
Персональный раздел пользователя | sale.personal.section | Организует персональный раздел пользователя.
Пластиковые карты | sale.personal.cc | Для управления пластиковыми картами текущего пользователя.
Подписки пользователя | sale.personal.subscribe | Для управления подписками текущего пользователя.
Подробная информация о заказе | sale.personal.order.detail | Выводит подробную информацию по заказу.
Подробная информация о заказе для почты | sale.personal.order.detail.mail | Выводит подробную информацию по заказу для почты.
Профили пользователя | sale.personal.profile | Для управления профилями текущего пользователя.
Редактирование пластиковых карт | sale.personal.cc.detail | Для редактирования пластиковых карт пользователя.
Редактирование профиля | sale.personal.profile.detail | Позволяет редактировать профиль пользователя.
Список заказов | sale.personal.order.list | Выводит фильтр и список заказов пользователя.
Список пластиковых карт текущего пользователя | sale.personal.cc.list | Выводит список пластиковых карт текущего пользователя.
Список подписок текущего пользователя | sale.personal.subscribe.list | Выводит список подписок текущего пользователя.
Список профилей текущего пользователя | sale.personal.profile.list | Выводит список профилей текущего пользователя.
Счета текущего пользователя | sale.personal.account | Отображает состояние внутреннего счета текущего пользователя в доступной валюте.
Процедура оформления заказа
Калькулятор доставки (AJAX) | sale.ajax.delivery.calculator | Выводит динамический калькулятор доставки.
Одношаговое оформление заказа | sale.order.ajax | Служит для оформления заказа на одной странице с использованием технологии AJAX.
Подключение платежной системы | sale.order.payment | Осуществляет подключение платежной системы.
Смена способа оплаты | sale.order.payment.change | Осуществляет смену платежной системы для оплаты заказа.
[link=63308 ]Подключение обработчика результата платежной системы[/link] | sale.order.payment.receive | Осуществляет подключение скрипта для получения результата от платежной системы.
Привязка к местоположению: строка поиска | sale.location.selector.search | Выводит форму выбора местоположений в виде строки поиска.
Привязка к местоположению: выпадающие списки | sale.location.selector.steps | Выводит форму выбора местоположений в виде выпадающих списков
Экспорт заказов
Экспорт заказов в "1С:Предприятие" | sale.export.1c | Служит для экспорта заказов в "1С:Предприятие" в формате CommerceML v2.
Информация о товарах
Выбор товара для получения подарка | sale.gift.main.products | Отображает блок товаров, которые нужно купить для получения предложенного подарка
Подарки к выбранному товару | sale.gift.main.products | Отображает подарки к конкретному товару
Подарки к товарам в корзине | sale.gift.basket | Отображает товары, которые будут предложены в качестве подарков к текущей корзине покупателя
Подарки к товарам конкретного раздела | sale.products.gift.section | Отображает подарки к товарам заданного раздела
Генерация купона на товар для почты | sale.discount.coupon.mail | Генерирует купон для правила корзины с соответствии с заданными параметрами
Персональные рекомендации для почты | sale.discount.coupon.mail | Выводит список рекомендованных товаров для почты
Самые продаваемые товары | sale.bestsellers | Выводит список самых продаваемых товаров
Сопутствующие заказу товары для почты | sale.bigdata.followup.mail | Выводит товары, сопутствующие ранее заказанным товарам
С этим товаром покупают | sale.recommended.products | Выводит товары, которые были куплены вместе с просматриваемым товаром, с учетом минимального количества покупок
eshop
Самые продаваемые товары | sale.bestsellers | Выводит рейтинг товаров по продажам.
Индекс каталогов | store.catalog.index | Не поддерживается с версии 12.5.
Фильтр по элементам | store.catalog.filter | Не поддерживается с версии 12.5.
Специальное предложение | store.catalog.random | Не поддерживается с версии 12.5.
Системные компоненты
sale.location.selector.system |  | Не описывается.
sale.location.import |  | Не описывается.

Смотрите также

  • Как создать скидку на заказ
  • Настройка параметров выгрузки в конфигурации "Управление торговлей"
  • Создание свойства заказа
  • Создание складов
  • Создание налога
  • Как интегрировать магазин с CRM
  • Документация для разработчиков по модулю Интернет-магазин


Интернет-магазин. Настройки модуля

Закладки

После того, как вы установили модуль Интернет-магазин, сначала необходимо правильно его настроить.

Форма настроек модуля Интернет-магазин (Настройки > Настройки продукта > Настройки модулей > Интернет-магазин) предназначена для задания общесистемных параметров модуля. Для удобства работы форма разделена на закладки, на каждой из которых выполняется настройка определённой группы параметров модуля.

Настройки

Закладка служит для настройки основных параметров модуля Интернет-магазина.

Поле | Описание
Служебные настройки
E-Mail отдела продаж | Указывается адрес электронной почты, на который по умолчанию будут направляться информационные сообщения модуля Интернет-магазин. Например, сообщения об оформлении, оплате или отмене заказа и т.д.
Сохранять корзину (дней) Указывается период времени (в днях), в течение которого корзина, сформированная неавторизованным покупателем, будет сохраняться в системе. Неверно подобранное значение этого поля может сказаться на размере базы данных. При больших объемах продаж, либо большом числе пользователей рекомендуется уменьшать число дней.

Корзины авторизованных покупателей не очищаются, а специально сохраняются.

За сколько дней отображать заказы в списке | Указывается период времени (в днях), за который отобразить заказы в административном разделе (страница Магазин > Заказы)
Максимальное время блокировки заказа (минут) | Задается максимальное время, на которое можно будет заблокировать заказ для редактирования его параметров.
Ширина графиков | Указывается ширина графиков для отображения статистики по заказам.
Высота графиков | Указывается высота графиков для отображения статистики по заказам.
Путь к пользовательским файлам-обработчикам платежных систем | Если для организации оплаты заказов на сайте используются собственные платежные системы, то в этом поле необходимо указать путь к папке с файлами-обработчиками для данных платежных систем.
Фиксировать модуль Торгового каталога (catalog) в качестве каталога товаров | Если вы планируете осуществлять продажу товаров только из модуля Торговый каталог, то установите флаг в данном поле. В этом случае при формировании/редактировании заказа выбор товара будет осуществляться из списка товаров модуля Торговый каталог.
Название параметра, в котором приходит код аффилиата | Указывается название переменной, значением которой будет код аффилиата. Параметр будет входить в аффилиатскую ссылку для идентификации аффилиата, например, www.testsite.ru/index.php?partner=1.
Сколько дней помнить аффилиата для пользователя | Указывается количество дней, в течение которых система будет помнить аффилиата для пользователя.
Показывать сумму заказов в списке заказов для менеджеров магазина | При отмеченной опции для менеджеров магазина будет показана сумма заказов в списке заказов. При полном доступе к модулю Интернет-магазин эта сумма будет выведена всегда независимо от данной опции.
В карточке заказа показывать XML_ID для товара | При отмеченной опции в карточке заказа будет показан XML_ID для товара.
Показывать ID обработчика платежной системы | При отмеченной опции будет показан идентификатор обработчика платежной системы.
Путь к файлу с таблицей мер и весов | Указывается путь к файлу, содержащему массив мер и весов, например, /bitrix/modules/sale/measurements.php.
Путь к собственным обработчикам расширенных систем доставки | Указывается каталог, в котором будут храниться собственные обработчики автоматизированных систем доставки, например, /bitrix/php_interface/include/sale_delivery/.
Использовать безопасное хранение cookies | При отмеченной опции будет использоваться шифрация при сохранении идентификационной информация в файлах cookies.
Кодировать идентификатор пользователя магазина | При отмеченной опции идентификатор пользователя будет кодироваться. Для усиления безопасности магазина рекомендуется отмечать данную опцию.
Рассчитывать скидку для каждой позиции (на все количество товара) | При отмеченной опции скидка будет подсчитываться для каждой позиции заказа.
Рассчитывать налог для доставки | При отмеченной опции для доставки будет рассчитываться налог.
Сохранять просмотренные товары каталога | [Y|N] При отмеченной опции будет сохраняться информация о просмотренных товарах каталога.
Использовать совместимость для просмотренных товаров каталога | Опция используется для устаревшего компонента Просмотренные товары (sale.viewed.product). Если она отмечена, то данные для компонента sale.viewed.product будут браться из таблицы нового компонента Просмотренные товары (catalog.viewed.product). Если опция не отмечена, то будет использоваться механизм старого компонента.
Время хранения просмотренных товаров (дней) | Указывается число дней, за которое будут выводиться просмотренные товары.
Максимальное количество просмотренных товаров пользователя | Указывается максимальное число просмотренных товаров пользователя.
Разрешать добавлять новый товар в форме редактирования заказа | При отмеченной опции в форме редактирования заказа из административного режима будет можно добавлять новый товар в заказ.
Использовать пластиковые карты | [Y|N] При отмеченной опции будет разрешено использование пластиковых карт для оплаты заказов.
Отображать свойства товарных предложений в списке заказов | [Y|N] При отмеченной опции в административном разделе на странице со списком заказов в колонке с описанием товаров будут отображаться свойства торговых предложений (при их наличии).
Знаков после запятой при выводе количественного значения | Указывается сколько знаков после запятой отображать при выводе количественного значения.
Точность округления при расчетах | Указывается с точностью до каких знаков должны проводиться расчеты.
Валюта "по умолчанию" | Валюта, используемая по умолчанию для представления данных о стоимости товаров, сумме продаж и т.д. в административном разделе.
Планы аффилиатов делятся по В плане аффилиата фиксируется комиссия, которую он будет получать за привлечение клиентов и последующую продажу товаров. План может зависеть от количества проданных товаров либо от суммы продаж. Это определяется данной настройкой, ее возможные значения:
  • по количеству продаж;
  • по сумме продаж.
Включить обработку устаревших событий | [Y|N] При отмеченной опции доступна обратная совместимость старых событий магазина. Если опция отключена, то будут доступны только новые события.
Включить подробное логирование истории изменения заказа | Включение подробного логирования истории изменения заказа. Логи можно просмотреть в форме редактирования заказа во вкладке История изменений [image] [image].
Включить подробное логирование операций с заказом | Включение подробного логирования операцией с заказом. Логи можно просмотреть в форме редактирования заказа во вкладке История изменений [image] [image].
Указать сайты, которые являются магазинами | Отмечаются сайты интернет-магазинов. Указать сайт необходимо, даже если сайт в системе один.
Путь к странице, показываемой при успешной оплате | Задается адрес страницы, которая будет отображаться пользователю в случае успешной оплаты заказа.
Путь к странице, показываемой при ошибке оплаты | Задается адрес страницы, которая будет отображаться пользователю в случае возникновения ошибки при оплате заказа.
Статус, начиная с которого можно оплатить заказ | Выбирается статус из списка статусов (типа Заказ) с которого будет доступна оплата заказа. К выбору доступны как стандартные статусы, так и дополнительно созданные.
Настройки печати чеков
Печатать авансовый чек при получении оплаты | При отмеченной опции при получении оплаты всегда и безусловно печатается авансовый чек. Авансовый чек не содержит списка товаров, а лишь одну позицию "получение аванса". Если оплата производится частичная, печатается авансовый чек вне зависимости от установки этой опции. Опция доступна до версии 18.6.700.
Тип чека при получении оплаты Указывается тип чека, который будет автоматически печататься при получении оплаты:
  • Полная оплата – закрывающий чек (подтверждает факт полной оплаты) и печатающийся при передаче товара;
  • Предоплата – чек предоплаты, содержащий список товаров и печатающийся ДО передачи товаров. Предоплата может быть частичной или 100%-ной;
  • Аванс – чек аванса, не содержащий список товаров и печатающийся ДО передачи товаров. Аванс, как и предоплата, может быть частичным или 100%-ным.

Опция доступна с версии 18.6.700 вместо опции Печатать авансовый чек при получении оплаты.

При установке вариантов Предоплата или Аванс будут автоматически печататься два чека: [dw]чек оплаты[/dw][di] Печатается автоматически при получении оплаты. [/di] и [dw]чек отгрузки[/dw][di] Печатается автоматически на этапе отгрузки (при передаче заказа в службу доставки). [/di].

Примечание: Опция доступна для касс, поддерживающих [dw]ФФД 1.05[/dw][di] Данные типы чеков поддерживаются только в версии ФФД 1.05 и выше. [/di]. ФФД 1.05 поддерживают следующие штатные обработчики: 1С-Битрикс.Кассы (с поддержкой ФФД 1.05) [image], Бизнес.РУ [image], Orange Data [image] и Атол.Онлайн v4 [image].

Если в системе активны несколько касс, и среди них хотя бы одна не поддерживает ФФД 1.05, то опции "Тип чека при получении оплаты" не будет (всегда будет печататься тип "Полная оплата").

Настройки поведения корзины в публичной части
Время актуальности корзины | Период обновления данных корзины. Рекомендуется устанавливать период, отличный от "0", в течении которого информация о товарах не теряет своей актуальности (например, 60 секунд). По умолчанию данные обновляются постоянно (значение "0").
Настройки показа карточки заказа в публичной части
Разрешить просмотр заказа по ключу без авторизации Опция служит для разрешения показа карточки заказа по ссылке. Если она отмечена, то становятся доступными нижеследующие настройки показа. [dw]При включённой опции появляются дополнительные поля[/dw][di]При включённой опции "Разрешить просмотр заказа по ключу без авторизации" появляются дополнительные поля:
Статусы, при которых разрешен просмотр заказа без авторизации | Указываются статусы, заказы в которых можно показывать.
Шаблон пути к странице просмотра заказа сайта "<идентификатор_сайта>" | Задается шаблон пути к странице просмотра карточки заказа. На странице должен быть размещен компонент, отображающий детальную информацию по заказу, например, Подробная информация о заказе.
[/di]
Настройки резервирования товара
Товар резервируется Выбирается правило резервирования товара:
  • При оформлении заказа;
  • При полной оплате заказа;
  • При частичной оплате заказа;
  • При разрешении доставки;
  • При отгрузке.
Снятие резервов (через сколько дней) | Задается количество дней, через которое товар будет автоматически снят с резервов, если покупатель не выполняет никаких действий по заказу.
Настройки местоположений
Тип виджета местоположений | Указывается тип виджета местоположений (выпадающие списки или строка поиска), который используется в форме создания/редактирования местоположения, в форме выбора избранных местоположений и в форме создания/редактирования заказа.
Настройки скидок магазина
Использовать только правила корзины [Y|N] При отмеченной опции в магазине будут использоваться только правила корзины и купоны правил. Скидки на товары будут недоступны.
При включённой опции также будут игнорироваться настройки валют при расчёте цен. В этом случае будут использоваться настройки поля Точность округления при расчетах в настройках модуля Интернет-магазин.
Процентная скидка/наценка рассчитывается для полной цены товара | [Y|N] При отмеченной опции скидка/наценка будет рассчитываться для полной цены товара. Если опция отключена, то скидка/наценка будет рассчитываться от цены товара с уже примененными скидками.
Взаимодействие правил корзины со скидками других модулей Выбирается правило взаимодействия правил корзины со скидками других модулей (например, модуля Торговый каталог):
  • дополнять уже примененные скидки;
  • не действовать, если есть флаг "Прекратить дальнейшее применение скидок";
  • не действовать, если уже были применены любые скидки.
Настройки также продаваемых продуктов
Включить сбор информации о также продаваемых продуктах | Включение функции сбора информации о также продаваемых продуктах. Информацию в публичной части сайта можно вывести с помощью компонентов С этим товаром покупают или Каталог.
Список статусов, при переводе заказа в которые, товары попадают в сбор | Указываются статусы заказов, по товарам из которых будет формироваться список также продаваемых товаров.
Как часто удалять старые товары - каждые (дней) | Задается количество дней, через которое будет выполняться очистка старых данных списка также продаваемых товаров.
Число дней, в течение которых товар считается актуальным | Указывается сколько дней хранить данные о товаре, если он попал в список также продаваемых товаров.
Настройки истории изменения заказов
Удалять устаревшие записи истории изменения заказов | Включение автоматического удаления устаревших записей из истории изменения заказов.
Удалять записи старше (дней) | Указывается срок хранения записей в днях, по истечению которого записи будут удалены.
Количество записей для удаления агентом за один запуск | Указывается количество записей, которые будет удалять агент за один запуск.
Суммы для зачисления на счет
Настройка предназначена для использования компонентом Добавление средств на счет текущего пользователя (bitrix:sale.account.pay).

В таблице задаются номиналы сумм и валюта. Такие суммы можно будет приобретать на внутренний счет пользователя. Суммы могут быть любые. Валюта устанавливается для каждой суммы отдельно. Набор валют задается на странице Список валют.
Подписка на товары
Выбирается закладка с именем сайта, для которого нужно произвести настройку подписки.
Использовать уведомления о поступлении товаров | При отмеченной опции для информирования о поступлении товаров на сайте будут использоваться почтовые уведомления. Включение опции необходимо для получения пользователями уведомлений при подписке на товар.
Сохранять уведомления (дней) Указывается число дней, в течении которого будут храниться в системе запрос пользователя на уведомления о поступлении товаров.
Например, если стоит 10 дней и в течение 5 дней товар поступил - то письмо уйдёт подписчику на товар, а если товар придёт через 15 дней - то письмо не уйдёт.
Напоминания о неоплаченных заказах
Выбирается закладка с именем сайта, для которого нужно произвести настройку рассылки.
Использовать напоминания | При отмеченной опции будут отсылаться напоминания о неоплаченных заказах в соответствии с параметрами, описанными ниже.
Через какое время (дни) | Указывается количество дней после оформления заказа, по прошествии которых отсылается первое напоминание.
Как часто (дни) | Задается интервал рассылки очередных напоминаний о неоплаченном заказе.
В течении какого времени (дни) | Задается период отправки напоминаний о неоплаченных заказах.

Параметры веса

Закладка служит для настройки единиц веса.

Поле | Описание
Использовать индивидуальные настройки для каждого сайта | При отмеченной опции будут использоваться индивидуальные настройки веса для всех сайтов системы.
Настройки для сайта | Список всех сайтов системы. Для каждого из них могут быть введены свои настройки веса.
Настройка | Значение
Единица | Список всех имеющихся мер весов.
Обозначение единицы веса | Можно ввести своё обозначение единицы веса, если требуется.
Коэффициент единицы веса к грамму | Вводится обозначение единицы веса к грамму.

Адрес магазина

Закладка служит для ввода физического адреса магазина.

Поле | Описание
Использовать индивидуальные настройки для каждого сайта | При отмеченной опции будут использоваться индивидуальные настройки адреса магазина для всех сайтов системы.
Настройки для сайта | Список всех сайтов системы. Для каждого из них могут быть введены свои адреса магазина.
Настройка | Значение
Индекс | Индекс магазина.
Местоположение магазина | Из списка выбирается одно из загруженных в систему местоположений.

Пластиковые карты

Закладка служит для управления параметрами шифрации номеров пластиковых карт, используемых при оплате заказов. Закладка доступна при сохранения отмеченной опции Использовать пластиковые карты на закладке Настройки.

Поле | Описание
Абсолютный путь к файлу с ключом | Указывается полный путь к файлу с паролем для шифрации номеров пластиковых карт. Например, D:/projects/siteman/bitrix/modules/sale/install/data.php.
Алгоритм шифрования Задается алгоритм шифрования номеров пластиковых карт:
  • RC4;
  • AES (Rijndael) - для использования данного алгоритма необходимо наличие PHP модуля Mcrypt;
  • 3DES (Triple-DES) - для использования данного алгоритма необходимо наличие PHP модуля Mcrypt;

Важно! Результаты работы алгоритмов несовместимы между собой. Вы не должны менять алгоритм, если в системе уже есть зашифрованные данные.

Права на заказы

Закладка служит для управления правами пользователей на доступ к управлению заказами.

Дополнительные параметры сайтов
Сайт | Название сайта.
Валюта | Валюта, используемая в публичной части сайта. При формировании заказа стоимость товаров и сумма заказа будут представлены в валюте сайта. При этом пересчет стоимости товаров (если стоимость была задана в иной валюте) будет осуществляться по установленному в модуле Валюты курсу.
Группы, имеющие доступ к заказам сайта | Группы пользователей, обладающие правом доступа к управлению заказами сайта.

Доступ

Закладка позволяет настроить права на доступ к модулю Интернет-магазин для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Интернет-магазин:
  • [D] закрыт - запрет на доступ;
  • [P] Привязка к компании - доступ к обработке заказов, оплат, отгрузок, предназначенных для определённой компании;
  • [U] обработка заказов - доступ к обработке заказов, поступающих от покупателей;
  • [W] полный доступ - право на полный доступ к управлению модулем, в том числе на обработку заказов и управление правами доступа других групп пользователей.

Автоматизация процессов

Закладка служит для настройки смены статусов заказа и отгрузки, а также для отслеживания товарных отправлений.

Поле | Описание
Смена статуса заказа
При получении полной оплаты переводить заказ в статус | Указывается статус, в который будет переведен заказ при получении полной оплаты по нему. В списке выведены все активные статусы заказа, заданные на странице Статусы.
При получении любой оплаты переводить заказ в статус | Указывается статус, в который будет переведен заказ при получении любой части оплаты по нему. В списке выведены все активные статусы заказа, заданные на странице Статусы.
Разрешать доставку при оплате заказа | Указывается разрешать ли доставку (т.е. устанавливать флаг Доставка разрешена для всех отгрузок заказа) при полной или частичной оплате заказа (установке флага Оплачено).
При получении разрешения доставки всех отгрузок переводить заказ в статус | Указывается статус, в который будет переведен заказ при получении разрешения доставки для всех отгрузок заказа. В списке выведены все активные статусы заказа, заданные на странице Статусы.
При получении разрешения доставки любой отгрузки переводить заказ в статус | Указывается статус, в который будет переведен заказ при получении разрешения доставки для любой из отгрузок заказа. В списке выведены все активные статусы заказа, заданные на странице Статусы.
При отгрузке всех отгрузок переводить заказ в статус | Указывается статус, в который будет переведен заказ при выполнении всех его отрузок.
При отгрузке любой отгрузки переводить заказ в статус | Указывается статус, в который будет переведен заказ при выполнении хотя бы одной отгрузки .
Смена статуса отгрузки
При получении разрешения доставки переводить отгрузку в статус | Указывается статус, в который будет переведена отгрузка при получении разрешения доставки. В списке выведены все активные статусы доставки, заданные на странице Статусы.
При отгрузке любой отгрузки переводить в статус | Указывается статус, в который будет автоматически переведена текущая отгрузка, для которой установлен флаг Отгружено.
Разрешать отгрузку при разрешении доставки | При отмеченной опции разрешенная доставка товара автоматически приведет к изменению флага отгрузки в Отгружено.
Обновление статусов отгрузок при изменении статусов отправлений
Включить автоматическое обновление | При отмеченной опции автоматически будут проверяться и обновляться статусы отгрузок, для которых введен трек-номер.
Период обновления (ч) | Период, через который будет выполняться обновление статусов отгрузок.
Соответствие статусов отправлений служб доставок и статусов отгрузок
Секция доступна при включенном автоматическом обновлении статусов отгрузок.
статус_отправления | Указывается будет ли использоваться данный статус отправления и, если да, то указывается какой статус отгрузки ему будет соответствовать.

Архив

На закладке настраиваются условия архивирования заказов.

Поле | Описание
Включить регулярное архивирование заказов | При отмеченной опции будет выполняться регулярное архивирование заказов в соответствии с условиями, указанными ниже.
Количество заказов для архивирования агентом за один запуск | Указывается количество заказов, которое следует отправлять в архив за один запуск агента.
Максимальное время выполнения агента архивирования | Определяется максимальное время (в секундах) выполнения агента.
Условия архивирования
Через какое время отправлять в архив (дни) | Указывается такое количество дней, чтобы заказы, созданные более этого числа дней назад, отправлялись в архив.
Разрешить архивирование заблокированных заказов | При отмеченной опции заблокированные заказы также будут отправляться в архив.
Сайт | Указываются сайты, заказы с которых отправлять в архив.
В каких статусах отправлять в архив | Указываются статусы, заказы в которых следует отправить в архив.
Состояние заказа "Оплачен" | Определяется архивировать ли заказы в состоянии Оплачен.
Состояние заказа "Отменен" | Определяется архивировать ли заказы в состоянии Отменен.
Состояние заказа "Отгружен" | Определяется архивировать ли заказы в состоянии Отгружен.

Нумерация заказов

Закладка предназначена для создания шаблона, по которому будет генерироваться номер заказа.

Поле | Описание
Не используется | При отмеченной опции функционал генерации номера не используется, т.е. нумерация осуществляется с 1 и увеличивается на единицу в новом заказе. В противном случае доступны нижеследующие поля для настройки шаблона.
Шаблон номера | Поле содержит шаблон, по которому будет происходить нумерация заказа. Кнопки Последовательный номер, Текущий день, Текущий месяц, Текущий год, Случайный номер, Префикс, Номер заказа и Идентификатор и номер заказа пользователя позволяют добавить в шаблон соответствующие данные.
Начинать последовательный номер с Указывается любое число, с которого должна начинаться нумерация.

Поле доступно, если нажата кнопка Последовательный номер.
Увеличивать последовательный номер на Указывается число, на которое будет последовательно увеличиваться номер заказа.

Поле доступно, если нажата кнопка Последовательный номер.
Период работы нумератора Указывается период работы последовательного нумератора:
  • Постоянно;
  • В пределах дня, например, 24062013 / 5;
  • В пределах месяца, например, 062013 / 14;
  • В пределах года, например, 2013 / 31.
Поле доступно, если нажата кнопка Последовательный номер.
Длина случайной последовательности символов Задается длина номера, который будет сгенерирован случайным образом из цифр и букв латинского алфавита.

Поле доступно, если нажата кнопка Случайный номер.
Префикс Указывается префикс, который будет отображаться перед номером заказа.

Поле доступно, если нажата кнопка Префикс.

Кнопки управления

Кнопка | Описание
Сохранить | Сохранение внесённых изменений.
Отменить | Отмена внесённых изменений.
По умолчанию | Установка значений параметров модуля равными значениям по умолчанию.

Переиндексация данных

На закладке содержится служебная процедура по переиндексации правил корзины.

Кнопка | Описание
Запустить индексацию | Запуск процесса индексации правил корзины. Важно! Выполнение этой операции требуется только при возникновении проблем с правилами корзины, по рекомендации техподдержки либо после сообщения системы обновлений.

Конвертация данных

На закладке содержится служебная процедура по конвертация данных о купонах торгового каталога в заказах.

Кнопка | Описание
Запустить конвертацию | Запуск процесса конвертации данных о купонах торгового каталога в заказах. Важно! Выполнение этой операции требуется только для старых заказов сконвертированных магазинов.


Конвертация интернет-магазина

На странице Конвертация интернет-магазина (Магазин > Конвертация данных) выполняется процедура конвертации данных магазина на новую систему управления заказами с помощью пошагового мастера.

Важно! Перед запуском процесса конвертации настоятельно рекомендуется создать резервную копию сайта. После конвертации данных вернуться на старую схему работы магазина будет невозможно.

Каждый шаг мастера содержит всю необходимую ознакомительную информацию. Переход между шагами мастера осуществляется с помощью кнопки Далее. Запуск процесса конвертации выполняется по кнопке Начать конвертацию.

Обратите внимание, что во время конвертации данных публичная часть сайта будет закрыта от посетителей.

Смотрите также

  • Конвертация данных магазина [image] в курсе Администратор. Бизнес [image].


Интеграция с CRM

Данная страница служит для настройки интеграции интернет-магазина с CRM, которая включена в облачный и коробочный сервис Битрикс24. Если у вас нет CRM, то следует нажать кнопку Получить CRM в Битрикс24 (бесплатно) и создать аккаунт в Битрикс24.

Для настройки интеграции следует нажать кнопку Настроить интеграцию с CRM и заполнить поля формы:

Поле | Описание
Адрес сайта CRM | Адрес корпоративного портала или облачного сервиса Битрикс24.
Логин администратора CRM | Логин администратора портала или облачного сервиса Битрикс24.
Пароль администратора CRM | Пароль администратора портала или облачного сервиса Битрикс24.
Автоматически создать пользователя и настроить права доступа (рекомендуется) | При отмеченной опции будет автоматически создан специальный пользователь в магазине. В противном случае необходимо вручную задать логин и пароль пользователя интернет-магазина (к модулю Интернет-магазин у пользователя должен быть Полный доступ, а к модулю Торговый каталог - не ниже, чем Чтение).

По кнопке Настроить интеграцию система проверит параметры синхронизации и будет выполнена интеграция.

Детально о настройке интеграции смотрите в учебном курсе [image].


Синхронизация заказов с Б24

Данная страница служит для настройки выгрузки заказов интернет-магазина в облачный портал Битрикс24 посредством приложения Обмен с 1С-Битрикс Управление сайтом [image] [image].

Синхронизация заказов с Б24 - это отдельный функционал. Для его работы не обязательно настраивать интеграцию магазина и портала Битрикс24.

Поле | Описание
Код доступа | Код доступа к Битрикс24, который будет сгенерирован при установке и настройке приложения Обмен с 1С-Битрикс Управление сайтом [image] [image] .

Подключение возможно только по защищённому соединению (https://).

Детально о настройке синхронизации смотрите в учебном курсе [image].


Отправить отзыв по этому разделу

Заказы

  • Заказы
  • Детальный просмотр заказа
  • Редактирование и создание заказа
  • Оплаты
  • Создание и редактирование оплаты
  • Отгрузки
  • Создание и редактирование отгрузки
  • Отправка транспортных заявок
  • Печать заказов
  • Список транспортных заявок
  • Просмотр транспортной заявки
  • Архив заказов
  • Форма архивирования заказов


Заказы

Форма Заказы (Магазин > Заказы) служит для управления заказами клиентов магазина. С помощью этой формы вы можете:

  • создавать заказы;
  • просматривать заказы на товары и услуги магазина;
  • удалять и отменять заказы;
  • изменять состояния заказов и их статусы.

Форма поиска

Поиск интересующих вас заказов. По умолчанию выводится только поле Дата заказа и Дата изменения. Остальные поля подключаются по кнопке Дополнительно.

Поле | Описание
Дата заказа | Поиск по дате оформления заказа. Поле присутствует, даже если фильтр свернут.
Дата изменения | Поиск по дате изменения заказа.
Код заказа | Поиск по коду заказа.
Номер заказа | Поиск по номеру заказа.
Сайт / Валюта | Указывается, заказы из какого сайта и оплаченные какой валютой следует отображать.
Статус заказа Позволяет установить фильтр на отображение всех заказов или заказов только в определённом статусе. Например:
  • Принят;
  • В обработке;
  • Отгружен;
  • Доставлен.
Если в настройках статуса была указана цветовая маркировка - ячейка будет окрашена в указанный цвет.
Дата изменения статуса | Позволяет выбрать заказы, статус которых изменился в течение определённого периода времени. Для задания временного диапазона можно использовать либо список с количеством дней, либо поля-календари.
Оплачен | Позволяет отобразить оплаченные, неоплаченные или все заказы.
Дата оплаты | Поиск по дате оплаты заказа.
Доставка разрешена | Позволяет отобразить заказы, доставка которых разрешена, не разрешена или все заказы.
Дата разрешения доставки | Позволяет выбрать заказы, доставка которых была разрешена в течение определённого периода времени. Для задания временного диапазона можно использовать либо список с количеством дней, либо поля-календари.
Платёж авторизован в ПС | Позволяет отобразить либо все заказы, либо имеющие определённый статус авторизации в платёжной системе.
Тип плательщика | Позволяет отобразить либо все заказы, относящиеся к определенному типу плательщика.
Платёжная система | Позволяет отобразить либо все заказы, либо оплаченные с использованием определённой платёжной системы.
Служба доставки | Данное поле позволяет найти заказы, для которых используются определенные службы доставки.
Отменён | Позволяет отобразить отменённые, неотменённые или все заказы.
Покупатель | Данное поле позволяет установить фильтр по имени, фамилии покупателя. Допустимо использование специальных логических выражений [image].
Код покупателя | Данное поле позволяет установить фильтр по идентификатору покупателя в системе. Кнопка [...] открывает форму поиска покупателя в системе.
Логин покупателя | Данное поле позволяет установить фильтр по логину покупателя в системе.
Email покупателя | Данное поле позволяет установить фильтр по E-mail покупателя в системе.
Группа пользователей | Поиск по группе пользователей, к которой относится покупатель.
Код товара в заказе | Позволяет осуществить поиск заказа по коду товара, включённого в заказ.
Внешний код товара | Позволяет осуществить поиск заказа по внешнему коду проданного товара.
Офис | Позволяет осуществить поиск заказа по компании.
Ответственный | Позволяет осуществить поиск по ответственному пользователю за заказ.
Аффилиат | Позволяет отобразить заказы, сделанные от определённого аффилиата.
Купон на скидку каталога | Поиск заказов, оформленных с помощью скидки по купону.
[свойства_заказа] | Для поиска могут быть выведены свойства заказа, если в параметрах этих свойств установлен флаг Свойство доступно в фильтре по заказам. Свойства задаются на странице Свойства заказа (Магазин > Настройки магазина > Свойства заказа > Список свойств).

Чтобы отобрать заказы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех заказов нажмите кнопку Отменить.

На закладках Приоритетные, Разрешенные к отправке, Оплаченные, Подвисшие представлены предустановленные фильтры с заранее вставленными параметрами.

Контекстная панель

Кнопка | Описание
Добавить заказ | Вызов формы создания заказа.
Транспортные заявки Доступны действия:
  • Отправить выделенные - отправка заявок для выделенных флагом заказов;
  • Отправить все показанные на странице- отправка заявок для всех заказов на странице.
По нажатию кнопки открывается страница отправки транспортных заявок.
Архивирование заказов | Переход к форме архивирования заказов.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.
Настроить | Переход к диалогу настройки внешнего вида отчётной формы.

Список заказов

Форма содержит список заказов, а также значения основных полей этих заказов.

По клику на номере можно перейти в форму детального просмотра свойств заказа.

Поле | Описание
Колонка флажков | Выбор заказов, к которым предполагается применить какое-либо правило или действие.
Действия Действия над заказом:
  • Разблокировать - снятие блокировки с заказа, если он блокирован вами.
  • Просмотреть подробную информацию о заказе - просмотр подробной информации о заказе с возможностью редактирования отдельных параметров;
  • Печать документов- печать документов по заказу;
  • Отправить в архив - перенос заказа в архив;
  • Изменить параметры заказа - переход к редактированию заказа;
  • Удалить заказ - удаление заказа.
Дата создания | Дата и время создания заказа.
ID Номер заказа и доступность элемента для редактирования:
  • - заказ доступен для редактирования;
  • - заказ заблокирован вами. Для того чтобы освободить заказ, выберите пункт Разблокировать в меню столбца Действие;
  • - заказ заблокирован другим пользователем (т.е. редактирование элемента выполняется другим пользователем).
Покупатель | Имя и фамилия покупателя, указанные им при регистрации в системе, а также присвоенный данному покупателю код. Код представлен в виде ссылки на форму редактирования пользователя.
Статус | Текущий статус заказа (например, Принят, В обработке, Доставлен).
Оплачен Текущий статус оплаты заказа:
  • да - заказ оплачен;
  • нет - заказ не оплачен.
Доставка разреш. Текущий статус разрешения доставки:
  • Да - доставка разрешена;
  • Нет - доставка не разрешена.
Отменён Текущий статус отменены заказа:
  • да - заказ отменён;
  • нет - заказ не отменён.
Отгружен Текущий статус отгрузки заказа:
  • да - заказ отгружен;
  • нет - заказ не отгружен.
Проблема с заказом Имеются ли проблемы с данным заказом:
  • Да;
  • Нет.
Сумма | Общая сумма заказа с учётом применяемых скидок, налогов, а также стоимости доставки.
Позиции | Содержимое заказа.
Номер заказа | Номер заказа в соответствии с шаблоном генерации номера, указанного в настройках магазина.
Внешний заказ | Признак того, что заказ выгружен из 1С.
Ответственный | Пользователь, ответственный за выполнение заказа.
Офис | Компания, через которую выполняется заказ.

Операции над заказами

К каждому заказу, представленному в списке, можно применить определённый набор операций. Для этого отметьте нужный заказ (заказы), установив флажок в крайнее левое поле напротив заказа, затем воспользуйтесь командами в поле Действия, расположенном на панели управления внизу страницы.

Выберите необходимое действие в списке и нажмите появившуюся после этого кнопку Применить.

Действие | Описание
Обновить статусы платёжных систем | Обновить информацию о статусах заказов, для оплаты которых были выбраны платёжные системы, позволяющие запросить статус оплаты заказа.
Разрешить доставку | Установка статуса разрешения доставки заказа.
Запретить доставку | Запрещение доставки заказа.
Оплатить | Статус оплаты заказа примет значение Оплачен.
Снять оплату | Установка статуса заказа Неоплачен.
Отменить | Отмена заказа.
Снять отмену | Снятие пометки об отмене заказа.
Отправить транспортные заявки | Отправка транспортных заявок для выбранных заказов.
Перевести в статус <название_статуса> | Перевод заказа в статус <название_статуса>.
Экспортировать в CSV | Экспорт информации о заказах в CSV файл.
Экспортировать в CommerceML | Экспорт информации о заказах в XML файл.
Экспортировать в CommerceML 2.0 | Экспорт информации о заказах в XML файл.
Самостоятельная доставка до ТК | В транспортную компанию будет отправлена заявка о том, что скоро им будет передан груз из отмеченных заказов. В заказе автоматически будет проставлен идентификатор отправления, номер и дата документа отгрузки.


Детальный просмотр заказа

Закладки и секции

Контекстная панель

Кнопка | Описание
Список заказов | Переход на страницу со списком заказов магазина.
Изменить заказ | Переход на страницу с формой для редактирования заказа.
Печать заказа | Переход к форме печати документов по данному заказу.
Действия Действия с заказом:
  • Копировать заказ - создание нового заказа с теми же параметрами, что и у текущего заказа.
  • Архивировать заказ - добавление заказа в архив.
  • Удалить заказ - удаление заказа.

Заказ

Панель предназначена для быстрой навигации по секциям закладки Заказ. Панель может быть закреплена/откреплена с помощью специальной пиктограммы.

Секция "Параметры заказа"

Поле | Описание
Создан | Дата, время и имя пользователя, создавшего заказ.
Последнее изменение | Дата и время последнего изменения заказа.
Сайт | Сайт, на котором был создан заказ.
Аффилиат | Имя аффилиата, через которого пришел покупатель.
Статус заказа | Статус, в котором находится заказ.
Отмена заказа | Нажмите для отмены заказа: укажите причину отмены и нажмите кнопку Отменить заказ. Для изменения текущего статуса отмены заказа нажмите Отменить отмену заказа.

Покупатель

Поле | Описание
Покупатель | Логин и Ф.И.О. пользователя.
Тип плательщика | Тип плательщика, к которому относится покупатель.
Физическое лицо
Личные данные
Ф.И.О. | Ф.И.О. покупателя.
E-Mail | Электронный адрес для уведомлений.
Телефон | Номер телефона.
Данные для доставки
Индекс | Почтовый индекс
Местоположение | Местоположение для доставки заказа.
Город | Указан только в том случае, если его невозможно указать в поле Местоположение.
Адрес доставки | Адрес доставки заказа.
Комментарий
Комментарий покупателя к заказу | Если покупатель оставил комментарий, то он вводится в это поле.
Юридическое лицо
Данные компании
Название компании Юридический адрес ИНН КПП | Поля для ввода данных о компании.
Контактная информация
Контактное лицо | Контактное лицо.
E-Mail | Электронный адрес для уведомлений.
Телефон Факс | Поля для ввода телефона и факса компании.
Индекс | Почтовый индекс.
Город | Указан только в том случае, если его невозможно указать в поле Местоположение.
Местоположение | Местоположение для доставки заказа.
Адрес доставки | Адрес доставки заказа.
Комментарий
Комментарий покупателя к заказу | Если покупатель оставил комментарий, то он выводится в этом поле.

Отгрузка

Секция служит для добавления/редактирования документов по отгрузке товаров заказа. Каждый документ выделен в отдельный блок.

В шапке блока отгрузки доступны следующие ссылки:

  • Удалить - удаление документа отгрузки;
  • Редактировать - переход на страницу редактирования документа отгрузки;
  • Свернуть/Развернуть - отображение блока с документом отгрузки в более компактном или, наоборот, развернутом виде.

Под блоками с документами отгрузки доступна кнопка Добавить отгрузку. При ее нажатии открывается страница создания нового документа отгрузки.

Каждый блок отгрузки имеет следующие поля, представленные в таблице ниже.

Поле | Описание
Служба доставки | Служба доставки товаров заказа.
Стоимость доставки | Стоимость доставки.
Офис отгрузки | Офис, с которого выполняется отгрузка.
Доставка разрешена | Флаг разрешения доставки.
Отгрузка | Флаг отгрузки товаров заказа.
Статус документа | Статус документа отгрузки.
Идентификатор отправления | Идентификатор отправления заказа.
Номер документа отгрузки | Указывается номер документа отгрузки.
Дата документа отгрузки | Дата создания документа отгрузки.
Состав отгрузки Таблица с составом отгрузки.
Поле | Описание
№ | Порядковый номер товарной позиции в отгрузке.
Изображение | Изображение товара.
Название | Название товара. Ссылка с названием позволяет перейти к просмотру товара в административной части сайта.
Свойства | Свойства товара, передаваемые в заказ (например, ID, цвет, размер и т.д.).
Количество к отгрузке | Количество товара, которое должно быть отгружено по текущему документу отгрузки.
Склад | Склад, с которого будет выполняться отгрузка.
Отгрузка | Количество товара, отгружаемого с конкретного склада. Примечание: сумма значений в этом поле должна быть равна значению, указанному в поле Количество к отгрузке.
Штрихкод | Штрихкод товара.

Информация по оплатам

В секции отображается информация о том, какая сумма выставлена к оплате, сколько уже оплачено и сколько осталось оплатить. Кроме того, при наличии средств у покупателя на внутреннем счете, будет отображаться информация о величине остатка на нем.

Секция "Оплата"

Данная секция содержит информацию о документах по оплате заказа. Каждый документ представлен в виде отдельного блока.

В шапке блока оплаты доступны следующие ссылки:

  • Удалить - удаление документа оплаты;
  • Редактировать - переход на страницу редактирования документа оплаты;
  • Свернуть/Развернуть - отображение блока с документом оплаты в более компактном или, наоборот, развернутом виде.

Под блоками с документами оплаты доступна кнопка Добавить оплату. При ее нажатии открывается страница создания нового документа оплаты заказа.

Каждый блок оплаты имеет следующие поля, представленные в таблице ниже.

Поле | Описание
Способ оплаты | Платежная система для оплаты заказа.
Сумма к оплате | Величина вносимых средств для оплаты части или всего заказа через выбранный способ оплаты.
Статус_оплаты | Статус оплаты заказа (Не оплачено или Оплачено).
Номер документа прихода | Указывается номер платежного документа.
Дата прихода | Устанавливается дата создания платежного документа.
Принять оплату на | Компания, на которую выполняется прием оплаты.

Дополнительная информация

Поле | Описание
Ответственный | Пользователь, ответственный за выполнение заказа.
Офис | Компания, через которую будет осуществляться выполнение заказа. Поле отображается, если компания выбрана.
Комментарий менеджера | Комментарий менеджера по заказу. Комментарий не виден покупателю.

Состав заказа

Поле | Описание
Таблица с составом заказа
Поле | Описание
Изображение | Изображение товара отображается вместе со свойствами товара.
Название | Название товара. Ссылка с названием позволяет перейти к просмотру товара в административной части сайта. При наличии скидки на товар она отображается под названием товара, не использовать которую можно путем снятия соответствующего флага.
Количество | Количество товара, приобретаемое покупателем.
Остаток | Количество товара на складе.
Цена | Стоимость данной позиции заказа в единичном экземпляре.
Сумма | Общая стоимость данной позиции в заказе.
В последней строке таблицы отображаются скидки, применяемые в заказе. При необходимости их можно отключить, сняв необходимые флаги.
Промокод | Отображается название скидок, купоны по которым используются в заказе.

История изменений

Список записей об изменениях заказа с возможностью фильтрации.

Форма поиска

Поиск интересующих изменений заказа.

Поле | Описание
Пользователь | Поиск по пользователю, внесшему изменение.
Дата изменения | Поиск по дате изменения заказа.
Операция | Поиск по проведенной операции с заказом.
Показывать ключевые операции | Фильтр по операциям. При установленном значении нет в истории изменений будут показаны все операции с заказом, включая [dw]подробные логи.[/dw][di] Подробные логи показываются, если в настройках модуля Интернет-магазин (Настройки > Настройки продукта > Настройки модулей > Интернет-магазин) отмечены опции "Включить подробное логирование истории изменения заказа" и "Включить подробное логирование операций с заказом". [/di]

Чтобы отобрать изменения заказа по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех изменений заказа нажмите кнопку Отменить.

Поле | Описание
Дата изменения | Дата и время изменения заказа.
Пользователь | Имя пользователя, совершившего изменение.
Операция | Операция, проведенная с заказом.
Описание | Детальное описание выполненной операции.
Элемент сущности | Сущность (платежная система, доставка), относительно которой была выполнена операции.

Анализ заказа

Закладка доступна в режиме редактирования заказа. На ней представлена таблица с составом заказа, в которой по каждой позиции отображается информация о ходе отгрузки, и список всех связанных с заказом документов оплат и отгрузок.


Редактирование и создание заказа

Закладки и секции

Форма создания/редактирования заказа служит для создания и настройки заказа из административной части системы. Форма применяется для создания заказов сотрудниками магазинов при оформлении заказа через телефон или другими способами без посещения публичной части сайта. С помощью этой формы вы можете:

  • создать заказ;
  • изменить параметры конкретного заказа;
  • удалить заказ;
  • пересчитать заказ в соответствии с обновлением цен, скидок;
  • распечатать информацию о заказе.

Контекстная панель

Кнопка | Описание
Список заказов | Переход на страницу со списком заказов магазина.
Просмотр заказа | Переход к форме детального просмотра заказа. Кнопка доступна только при редактировании существующего заказа.
Печать заказа | Переход к форме печати документов. Кнопка доступна только при редактировании существующего заказа.
Действия Действия с редактируемым заказом:
  • Пересчитать заказ - пересчет заказа в соответствии с актуальными ценами на товары, скидками.
  • Удалить заказ - удаление заказа.

Заказ

Панель Быстрая навигацияпредназначена для быстрой навигации по секциям закладки Заказ. Панель может быть закреплена/откреплена с помощью специальной пиктограммы.

Секция Заказ служит для создания/изменения состава заказа.

Поле | Описание
Добавить товар и Новый товар... По этим кнопкам вызываются окна добавления товара в создаваемый/редактируемый заказ. Добавить товар - добавление из существующего в каталоге товара. Новый товар... - возможность добавить произвольный, даже не существующий в каталоге товар.

Примечание: кнопка Новый товар... доступна только в том случае, если в настройках модуля Интернет-магазин отмечена опция Разрешать добавлять новый товар в форме редактирования заказа.
Таблица с составом заказа Вывод данных о составе заказа с возможностью изменения параметров в каждой товарной позиции. Кроме того, можно настроить вывод необходимых столбцов [image] по кнопке, расположенной в шапке таблицы над колонкой с действиями.
Поле | Описание
Действия Доступны следующие действия с позициями в заказе:
  • Изменить - изменение параметров товара в форме, аналогичной форме Новый товар...
  • Удалить - удаление товарной позиции.
    • заказа.
Изображение | Изображение товара.
Название | Название товара. Ссылка с названием позволяет перейти к просмотру товара в административной части сайта.
Количество | Количество товара, приобретаемое покупателем.
Остаток | Количество товара на складе.
Свойства | Свойства товара, передаваемые в заказ (например, ID, цвет, размер и т.д.).
Цена | Стоимость данной позиции заказа в единичном экземпляре.
Сумма | Общая стоимость данной позиции в заказе.
Промокод | Поле для ввода купонов скидок.

Форма Новый товар

Поле | Описание
Код | Произвольный числовой код, который не должен повторятся в рамках списка товаров.
*Наименование | Название добавляемого товара
Путь к странице с детальным описанием | Вводится путь к страничке с товаром (если есть) от корня сайта.
Внешний код каталога | Символьный код, используемый для связи с внешним источником данных. Например, для взаимодействия с 1С.
Внешний код товара | Символьный код, используемый для связи с внешним источником данных. Например, для взаимодействия с 1С.
Тип цены | Указывается какая цена (оптовая, розничная и т.п.) используется в заказе для товара.
Свойства товара в заказе | Таблица со свойствами товара. новые строки добавляются по кнопке Добавить.
*Количество | Количество товара в выбранных единицах измерения.
*Цена | Цена товара в рублях.
Вес | Вес товара в граммах.
* - поля обязательные для заполнения

Покупатель

Поле | Описание
При создании заказа доступна кнопка Найти покупателя, с помощью которой происходит выбор покупателя и все поля, либо их часть, заполнятся автоматически, согласно настройкам выбранного покупателя. Для создания нового покупателя необходимо вручную заполнить все поля.
*Тип плательщика | Выбор типа плательщика. В зависимости от выбора меняется состав нижележащих полей.
Выбор профиля | Для существующего покупателя создается, либо выбирается профиль. Поле доступно только при создании заказа.
Физическое лицо
Личные данные
*Ф.И.О. | Ф.И.О. покупателя.
*E-Mail | Электронный адрес для уведомлений.
*Телефон | Номер телефона.
Данные для доставки
*Индекс | Почтовый индекс
*Местоположение | Выбор местоположения.
Город | Задается только в том случае, если он отсутствует в поле Местоположение.
*Адрес доставки | Адрес доставки заказа.
Комментарий
Комментарий покупателя к заказу | Если покупатель оставил комментарий, то он выводится в этом поле.
Юридическое лицо
Данные компании
*Название компании Юридический адрес ИНН КПП | Поля для ввода данных о компании.
Контактная информация
*Контактное лицо | Контактное лицо.
*E-Mail | Электронный адрес для уведомлений.
Телефон Факс | Поля для ввода телефона и факса компании.
*Индекс | Почтовый индекс.
Город | Задается только в том случае, если он отсутствует в поле Местоположение.
*Местоположение | Выбор местоположения.
*Адрес доставки | Адрес доставки заказа.
Комментарий
Комментарий покупателя к заказу | Если покупатель оставил комментарий, то он вводится в это поле.

* - поля, обязательные для заполнения.

Финансовая информация о заказе

Данная секция доступна при создании заказа, при его редактировании она недоступна.

В секции отображается информация о том, какая сумма выставлена к оплате, сколько уже оплачено и сколько осталось оплатить. Кроме того, при наличии средств у покупателя на внутреннем счете, будет отображаться информация о величине остатка на счете и ссылка Использовать внутренний счет. Ссылка служит для создания документа об оплате через внутренний счет (т.е. при ее нажатии заполняться поля в секции Оплата).

Отгрузка

Секция служит для создания/редактирования документов по отгрузке товаров заказа. Каждый документ выделен в отдельный блок.

Примечание: при создании заказа можно оформить только один документ отгрузки, т.е. изначально все товары попадают в одну отгрузку. Разделение отгрузки на части выполняется при просмотре существующего заказа.

При редактировании заказа в шапке блока отгрузки доступны следующие ссылки:

  • Удалить - удаление документа отгрузки;
  • Редактировать - переход на страницу редактирования документа отгрузки;
  • Свернуть/Развернуть - отображение блока с документом отгрузки в более компактном или, наоборот, развернутом виде.

Каждый блок отгрузки имеет следующие поля, представленные в таблице ниже.

Поле | Описание
*Служба доставки | Выбор службы доставки.
Стоимость доставки | Стоимость доставки.
Офис отгрузки | Офис, с которого выполняется отгрузка. При создании заказа доступна ссылка Добавить, которая служит для перехода к добавлению в систему записи об офисе отгрузке.
Доставка разрешена | Флаг разрешения доставки.
Отгрузка | Флаг отгрузки товаров заказа.
Статус документа | Статус документа отгрузки. Поле недоступно при создании заказа.
Идентификатор отправления | Идентификатор отправления заказа.
Номер документа отгрузки | Указывается номер документа отгрузки.
Дата документа отгрузки | Дата создания документа отгрузки.
Состав отгрузки Таблица с составом отгрузки отображается только при редактировании заказа.
Поле | Описание
№ | Порядковый номер товарной позиции в отгрузке
Изображение | Изображение товара.
Название | Название товара. Ссылка с названием позволяет перейти к просмотру товара в административной части сайта.
Свойства | Свойства товара, передаваемые в заказ (например, ID, цвет, размер и т.д.).
Количество к отгрузке | Количество товара, которое должно быть отгружено по текущему документу отгрузки.
Склад | Склад, с которого будет выполняться отгрузка.
Отгрузка | Количество товара, отгружаемого с конкретного склада. Примечание: сумма значений в этом поле должна быть равна значению, указанному в поле Количество к отгрузке.
Штрихкод | Штрихкод товара.

* - поля, обязательные для заполнения.

Оплата

Данная секция содержит информацию о документах по оплате заказа. Каждый документ представлен в виде отдельного блока.

В шапке блока оплаты доступны следующие ссылки:

  • Удалить - удаление документа оплаты;
  • Редактировать - переход на страницу редактирования документа оплаты (недоступно при создании заказа);
  • Свернуть/Развернуть - отображение блока с документом оплаты в более компактном или, наоборот, развернутом виде (недоступно при создании заказа).

В форме создания заказа под блоком с документом оплаты доступна кнопка Добавить оплату. При ее нажатии открывается страница создания нового документа оплаты заказа.

Каждый блок оплаты имеет следующие поля, представленные в таблице ниже.

Поле | Описание
*Способ оплаты | Выбирается метод оплаты заказа.
Сумма к оплате | Величина вносимых средств для оплаты части или всего заказа через выбранный способ оплаты.
Статус_оплаты | Статус оплаты заказа (Не оплачено или Оплачено). В форме создания заказа статус можно изменять.
Номер документа прихода | Указывается номер платежного документа.
Дата прихода | Устанавливается дата создания платежного документа.
Принять оплату на | Компания, на которую выполняется прием оплаты. При создании заказа доступна ссылка Добавить, которая служит для перехода к добавлению в систему компании.

* - поля, обязательные для заполнения.

Дополнительная информация

Добавление дополнительной информации к заказу.

Поле | Описание
Ответственный | Пользователь, ответственный за выполнение заказа. При наведении курсора мыши на имя пользователя становится доступной ссылка Изменить. При ее нажатии открывается окно выбора пользователя, который будет ответственным за заказ.
Офис | Указывается компания, через которую будет осуществляться выполнение заказа.
Комментарий
Комментарий менеджера | Текстовое поле для ввода комментария. Комментарий не виден покупателю.

Статус заказа

Поле | Описание
Создан | Дата, время и имя пользователя, создавшего заказ. Поле доступно в режиме редактирования заказа.
Последнее изменение | Дата и время последнего изменения заказа. Поле доступно в режиме редактирования заказа.
Сайт | Сайт, на котором был создан заказ. Поле доступно в режиме редактирования заказа.
Аффилиат | Имя аффилиата, через которого пришел покупатель. Поле недоступно в форме создания заказа.
Статус заказа | Статус, в котором находится заказ.

Анализ заказа

Закладка доступна в режиме редактирования заказа. На ней представлена таблица с составом заказа, в которой по каждой позиции отображается информация о ходе отгрузки, и список всех связанных с заказом документов оплат и отгрузок.

Смотрите также

  • Создание заказа из административной части (учебный курс "Администратор. Бизнес")


Оплаты

Страница Оплаты (Магазин > Заказы > Оплаты) предназначена для просмотра, переходу к изменению, а также удалению документов оплат.

Форма поиска

Поиск интересующих вас оплат. По умолчанию выводится только поле ID заказа. Остальные поля подключаются по кнопке [+].

Поле | Описание
ID заказа | Поиск по интервалу идентификаторов заказа.
Оплачено | Позволяет отобрать оплаченные и/или неоплаченные документы.
Дата оплаты | Поиск по дате оплаты заказа.
Сайт | Указывается сайт, по заказам которого отображать документы оплат.
Платежные системы | Поиск документов оплат по платежной системе.
Номер заказа | Поиск по номеру заказа.
Стоимость заказа | Отбор документов по суммам, внесенным по оплате заказов.
Валюта | Отбор документов по валюте, в которой выполнялась оплата заказа.
Номер платежного документа | Поиск по номеру платежного документа.
Код покупателя | Отбор документов по идентификатору покупателя.
Логин покупателя | Отбор документов по логину покупателя.
Email покупателя | Отбор документов по email покупателя.

Чтобы отобрать документы оплат по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех оплат нажмите кнопку Отменить.

Список оплат

Форма содержит список оплат, а также значения основных полей этих оплат.

Поле | Описание
Колонка флажков | Выбор оплат, к которым предполагается применить какое-либо правило или действие.
Действия Действия над оплатой:
  • Изменить - переход к редактированию оплаты;
  • Удалить - удаление оплаты.
Дата оплаты | Дата и время внесения оплаты.
ID | Идентификатор документа оплаты.
ID заказа | Идентификатор заказа.
Покупатель | ФИО покупателя.
Оплата заказа | Признак того, была ли внесена оплата заказа в соответствии с документом или нет.
Платежная система | Платежная система, через которую вносится оплата.
Сумма | Сумма, которую необходимо внести для оплаты.
Компания | Компания, через которую выполняется прием оплаты.
Номер платежного документа | Номер документа прихода.
Ответственный | Имя и фамилия пользователя, ответственного за выполнение оплаты заказа.


Создание и редактирование оплаты

Закладки и секции

Данная форма служит для создания и редактирования документа оплаты. Переход к форме редактирования возможен со страницы со списком оплат (Магазин > Заказы > Оплаты), со страницы просмотра или редактирования заказа. Форма создания документа оплаты открывается по кнопке Добавить оплату, расположенной в форме просмотра заказа.

Контекстная панель

Кнопка | Описание
Перейти к заказу | Переход на страницу просмотра соответствующего заказа.
Удалить | Удаление документа оплаты. Кнопка доступна только при редактировании существующей оплаты.
Список оплат | Переход на страницу со списком оплат.

Финансовая информация о заказе

В секции отображается информация о том, какая сумма выставлена к оплате, сколько уже оплачено и сколько осталось оплатить. Кроме того, при создании новой оплаты и наличии средств у покупателя на внутреннем счете, будет отображаться информация о величине остатка на счете и ссылка Использовать внутренний счет. Нажатие ссылки приводит к автоматическому заполнению полей в секции Оплата, где в качестве способа оплаты будет указано Внутренний счет, а сумма будет проставлена та, что имеется на счете (если остаток меньше необходимой суммы), или вся необходимая сумма для оплаты заказа.

Оплата

Поле | Описание
*Способ оплаты | Выбирается метод оплаты заказа.
Сумма к оплате | Величина вносимых средств для оплаты части или всего заказа через выбранный способ оплаты.
Статус_оплаты | Статус оплаты заказа (Не оплачено или Оплачено).
Номер документа прихода | Указывается номер платежного документа.
Дата прихода | Устанавливается дата создания платежного документа.
Принять оплату на | Компания, на которую выполняется прием оплаты. Если список компаний пуст, то доступна ссылка Добавить, которая служит для перехода к добавлению в систему компании.

* - поля, обязательные для заполнения.

Покупатель

В данной секции отображается информация по покупателю. Для редактирования данные покупателя недоступны в этой форме.

Поле | Описание
Покупатель | Логин и Ф.И.О. пользователя.
Тип плательщика | Тип плательщика, к которому относится покупатель.
Физическое лицо
Личные данные
Ф.И.О. | Ф.И.О. покупателя.
E-Mail | Электронный адрес для уведомлений.
Телефон | Номер телефона.
Данные для доставки
Индекс | Почтовый индекс
Местоположение | Местоположение для доставки заказа.
Город | Указан только в том случае, если его невозможно указать в поле Местоположение.
Адрес доставки | Адрес доставки заказа.
Комментарий
Комментарий покупателя к заказу | Если покупатель оставил комментарий, то он выводится в этом поле.
Юридическое лицо
Данные компании
Название компании Юридический адрес ИНН КПП | Поля для ввода данных о компании.
Контактная информация
Контактное лицо | Контактное лицо.
E-Mail | Электронный адрес для уведомлений.
Телефон Факс | Поля для ввода телефона и факса компании.
Индекс | Почтовый индекс.
Город | Указан только в том случае, если его невозможно указать в поле Местоположение.
Местоположение | Местоположение для доставки заказа.
Адрес доставки | Адрес доставки заказа.
Комментарий
Комментарий покупателя к заказу | Если покупатель оставил комментарий, то он выводится в этом поле.

Дополнительная информация

Добавление дополнительной информации к документу оплаты.

Поле | Описание
Ответственный | Пользователь, ответственный за выполнение оплаты заказа. При наведении курсора мыши на имя пользователя становится доступной ссылка Изменить. При ее нажатии открывается окно выбора пользователя, который будет ответственным за оплату заказа.
Офис | Указывается компания, через которую будет осуществляться выполнение заказа.
Комментарий
Комментарий менеджера | Текстовое поле для ввода комментария. Комментарий не виден покупателю.

Статус заказа

Поле | Описание
Статус заказа | Статус, в котором находится заказ.

История изменений

Данная закладка доступна при редактировании документа оплаты.

Форма поиска

Поиск интересующих изменений документа оплаты.

Поле | Описание
Пользователь | Поиск по пользователю, внесшему изменение.
Дата изменения | Поиск по дате изменения оплаты.
Операция | Поиск по проведенной операции.

Чтобы отобрать изменения документа оплаты по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех изменений нажмите кнопку Отменить.

Поле | Описание
Дата изменения | Дата и время изменения документа.
Пользователь | Имя пользователя, совершившего изменение.
Операция | Операция, проведенная с документом.
Описание | Детальное описание выполненной операции.

Связи документов

Закладка доступна при редактировании документа оплаты. На ней представлена таблица с составом заказа, в которой по каждой позиции отображается информация о ходе отгрузки, и список всех связанных с заказом документов оплат и отгрузок.

Смотрите также

  • Оплаты (учебный курс "Администратор. Бизнес")


Отгрузки

Страница Отгрузки (Магазин > Заказы > Отгрузки) предназначена для просмотра, переходу к изменению, а также удалению документов отгрузок.

Форма поиска

Поиск интересующих вас документов отгрузок. По умолчанию выводится только поле ID заказа. Остальные поля подключаются по кнопке [+].

Поле | Описание
ID заказа | Поиск по интервалу идентификаторов заказа.
ID отгрузки | Поиск по интервалу идентификаторов документов отгрузок.
Доставка разрешена | Позволяет отобрать документы, доставка в которых разрешена и/или в которых не разрешена.
Отгружено | Поиск документов, по которым отгрузка выполнена и/или не выполнена.
Дата отгрузки | Поиск по дате отгрузки товаров.
Номер документа отгрузки | Поиск по номеру документа отгрузки.
Стоимость доставки | Отбор документов по величине стоимости доставки.
Номер заказа | Поиск по номеру заказа.
Компания | Поиск документов по офису отгрузки.
Статус отгрузки | Отбор документов по статусу отгрузки. Если в настройках статуса была указана цветовая маркировка - ячейка будет окрашена в указанный цвет.
Код покупателя | Отбор документов по идентификатору покупателя.
Логин покупателя | Отбор документов по логину покупателя.
Email покупателя | Отбор документов по email покупателя.

Чтобы отобрать документы отгрузок по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех отгрузок нажмите кнопку Отменить.

Список отгрузок

Форма содержит список документов отгрузок, а также значения основных полей этих документов.

Поле | Описание
Колонка флажков | Выбор отгрузок, к которым предполагается применить какое-либо правило или действие.
Действия Действия над документом отгрузки:
  • Изменить - переход к редактированию документа;
  • Удалить - удаление документа.
Дата документа отгрузки | Дата создания документа отгрузки.
ID | Идентификатор документа отгрузки.
ID заказа | Идентификатор заказа.
Покупатель | ФИО покупателя.
Доставка разрешена | Информация о том, разрешена ли доставка товаров по документу отгрузки. Если доставка разрешена, то отображается имя пользователя, дата и время разрешения доставки.
Статус отгрузки | Статус отгрузки товаров.
Отгружено | Информация о том, разрешена ли отгрузка товаров. Если отгрузка разрешена, то отображается дата и время разрешения отгрузки.
Служба доставки | Служба, с помощью которой будет выполнена доставка товаров.
Стоимость доставки | Стоимость доставки товаров по данному документу отгрузки.
Компания | Компания, через которую выполняется отгрузка товара.
Номер документа отгрузки | Номер документа отгрузки.
Ответственный | Пользователь, ответственный за отгрузку.


Создание и редактирование отгрузки

Закладки и секции

Данная форма служит для создания и редактирования документа отгрузки. Переход к форме редактирования возможен со страницы со списком отгрузок (Магазин > Заказы > Отгрузки), со страницы просмотра или редактирования заказа. Форма создания документа отгрузки открывается по кнопке Добавить отгрузку, расположенной в форме просмотра заказа.

Контекстная панель

Кнопка | Описание
Перейти к заказу | Переход на страницу просмотра соответствующего заказа.
Удалить | Удаление документа отгрузки. Кнопка доступна только при редактировании существующей отгрузки.
Список отгрузок | Переход на страницу со списком отгрузок.
Распечатать | Переход на страницу для печати документа отгрузки. Кнопка доступна только при редактировании существующей отгрузки.
Транспортная заявка Доступные действия, если отгрузка входит в транспортную заявку:
  • Скачать печатные формы - скачивание печатных форм для отгрузки.
  • Скачать печатную форму Ф7П - скачивание формы Ф7П.
  • Обновить отгрузку в заявке - обновление информации об отгрузке в заявке.
  • Удалить отгрузку из заявки - удаление отгрузки транспортной заявки.

Доступные действия, если отгрузка не входит в транспортную заявку:
  • Создать новую заявку и добавить отгрузку - создание новой заявки в службу доставки, в которую будет входить данная отгрузка.
  • Добавить отгрузку в существующую заявку - добавление отгрузки в уже отправленную заявку.

Список товаров

Поле | Описание
Найти по штрихкоду | Поиск нераспределенного товара по отгрузкам по штрихкоду.
Добавить товар | Кнопка служит для вызова окна добавления нераспределенного по отгрузкам товара.
Таблица с составом отгрузки Можно настроить вывод необходимых колонок [image] по кнопке, расположенной в шапке таблицы над колонкой с действиями.
Поле | Описание
Действия Доступны следующие действия с позициями в составе отгрузки:
  • Удалить - удаление товарной позиции из состава отгрузки. Товар из состава заказа не удаляется, система запоминает его в списке нераспределенных товаров. Все нераспределенные товары будут предложены системой при формировании новой отгрузки.
Колонка флажков | Выбор отгрузок, к которым предполагается применить действие по удалению из состава отгрузки.
Изображение | Изображение товара.
Название | Название товара. Ссылка с названием позволяет перейти к просмотру товара в административной части сайта.
Свойства | Свойства товара, передаваемые в заказ (например, ID, цвет, размер и т.д.).
Количество | Количество товара, которое необходимо распределить по отгрузкам.
Количество к отгрузке | Общее количество отгружаемого товара в рамках конкретной отгрузки.
Склад Склад, с которого будет выполняться отгрузка.

Если товар имеется в наличии на нескольких складах, то будет доступна ссылка Добавить склад. При ее нажатии добавляется поле для выбора склада, с которого также будет отгружено некоторое количество товара. Таким образом, товар может быть отгружен с нескольких складов в рамках одного документа отгрузки.
Отгрузка Количество товара, отгружаемого с конкретного склада.

Важно! Сумма значений в этом поле должна быть равна значению, указанному в поле Количество к отгрузке.
Количество на складе | Количество товара, имеющееся в наличии на конкретном складе.
Штрихкод Доступны два поля:
  • Штрихкод товара - для внесения штрихкода;
  • Маркировочный код - поле для вненесения маркировочного кода. Отображается в том случае, если товар подлежит маркировке по закону № 487-ФЗ (только для Российской Федерации).
.

Статус отгрузки

Поле | Описание
Статус отгрузки | Статус, в котором находится процесс отгрузки.

Отгрузка

Поле | Описание
*Служба доставки | Выбор службы доставки.
Стоимость доставки | Стоимость доставки.
Офис отгрузки | Офис, с которого выполняется отгрузка. Если офисов в системе нет, то доступна ссылка Добавить, которая служит для перехода к добавлению в систему записи об офисе отгрузке.
Доставка разрешена | Флаг разрешения доставки.
Отгрузка | Флаг отгрузки товаров заказа.
Идентификатор отправления | Идентификатор отправления отгрузки.
Номер документа отгрузки | Указывается номер документа отгрузки.
Дата документа отгрузки | Дата создания документа отгрузки.
Заявка | Ссылка на заявку, в которую входит данная отгрузка.

* - поля, обязательные для заполнения.

Покупатель

В данной секции отображается информация по покупателю. Для редактирования данные покупателя недоступны в этой форме.

Поле | Описание
Покупатель | Логин и Ф.И.О. пользователя.
Тип плательщика | Тип плательщика, к которому относится покупатель.
Физическое лицо
Личные данные
Ф.И.О. | Ф.И.О. покупателя.
E-Mail | Электронный адрес для уведомлений.
Телефон | Номер телефона.
Данные для доставки
Индекс | Почтовый индекс
Местоположение | Местоположение для доставки заказа.
Город | Указан только в том случае, если его невозможно указать в поле Местоположение.
Адрес доставки | Адрес доставки заказа.
Комментарий
Комментарий покупателя к заказу | Если покупатель оставил комментарий, то он выводится в этом поле.
Юридическое лицо
Данные компании
Название компании Юридический адрес ИНН КПП | Поля для ввода данных о компании.
Контактная информация
Контактное лицо | Контактное лицо.
E-Mail | Электронный адрес для уведомлений.
Телефон Факс | Поля для ввода телефона и факса компании.
Индекс | Почтовый индекс.
Город | Указан только в том случае, если его невозможно указать в поле Местоположение.
Местоположение | Местоположение для доставки заказа.
Адрес доставки | Адрес доставки заказа.
Комментарий
Комментарий покупателя к заказу | Если покупатель оставил комментарий, то он вводится в это поле.

Дополнительная информация

Добавление дополнительной информации к документу отгрузки.

Поле | Описание
Ответственный | Пользователь, ответственный за выполнение отгрузки. При наведении курсора мыши на имя пользователя становится доступной ссылка Изменить. При ее нажатии открывается окно выбора пользователя, который будет ответственным за отгрузку.
Офис | Указывается компания, через которую будет осуществляться выполнение заказа.
Комментарий
Комментарий менеджера | Текстовое поле для ввода комментария. Комментарий не виден покупателю.

История изменений

Данная закладка доступна при редактировании документа отгрузки.

Форма поиска

Поиск интересующих изменений документа.

Поле | Описание
Пользователь | Поиск по пользователю, внесшему изменение.
Дата изменения | Поиск по дате изменения документа отгрузки.
Операция | Поиск по проведенной операции.

Чтобы отобрать изменения документа по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех изменений нажмите кнопку Отменить.

Поле | Описание
Дата изменения | Дата и время изменения документа.
Пользователь | Имя пользователя, совершившего изменение.
Операция | Операция, проведенная с документом.
Описание | Детальное описание выполненной операции.

Связи документов

Закладка доступна при редактировании документа отгрузки. На ней представлена таблица с составом заказа, в которой по каждой позиции отображается информация о ходе отгрузки, и список всех связанных с заказом документов оплат и отгрузок.

Смотрите также

  • Отгрузки (учебный курс "Администратор. Бизнес")


Отправка транспортных заявок

Переход на эту страницу осуществляется, когда на странице заказов выбрано действие отправки транспортных заявок.

На самой странице представлены блоки с логотипами служб доставок и кнопками Создать новую заявку и Добавить в существующую заявку:

  • По кнопке Создать новую заявку выполняется создание и отправка новой заявки в службу доставки;
  • По кнопке Добавить в существующую заявку - добавление отгрузок из выбранных заказов в уже существующую заявку.

Примечание: на текущий момент стандартный функционал транспортных заявок поддерживается только для Почты России [image].

Смотрите также:

  • Транспортные заявки (учебный курс "Администратор. Бизнес")


Печать заказов

Форма Печать документов по заказу служит для печати документов по заказам клиентов магазина. С помощью этой формы вы можете печатать документы как на основании предустановленных, так и на основании ваших собственных шаблонов. Переход к данной форме осуществляется со страницы Заказы (Магазин > Заказы), выбирая пункт Печать документов из меню действий.

Контекстная панель

Кнопка | Описание
Список заказов | Переход на страницу со списком заказов.
Изменить заказ | Переход на страницу с формой для редактирования заказа.
Подробности заказа | Переход на страницу с подробной информацией о заказе.

Форма "Печать документов"

Поле | Описание
Номер заказа | Номер заказа в системе.
Дата заказа | Дата и время оформления или последнего изменения заказа.
Сайт заказа | Сайт, на котором был оформлен данный заказ.
Статус | Текущий статус заказа.
Отменён/Оплачен/Доставка разрешена | Текущее состояние заказа.
Выводить свойства товара | [Y|N] При отмеченной опии свойства товара будут отображены в печатных формах.
В данном разделе формы представлен список позиций заказа.
Поле | Описание
Включен | Указывается, будет ли данная позиция (товар) включена в печатный документ. Некоторые шаблоны документов позволяют печатать данные не по всем, а по произвольной части товаров заказа. В данном поле вы можете указать, что в печатном документе должны присутствовать не все товарные позиции, а так же изменить их количество. Если шаблон не предусматривает печать только части заказа, то он отобразит все товарные позиции вне зависимости от установок на форме.
Название | Название товара.
Количество | Количество приобретаемого товара.
Цена | Стоимость единицы товара с учётом скидки.
Сумма | Общая стоимость данной позиции заказа.

[Налог] | Перечень налогов, применяемых к данному заказу, с указанием их сумм.
Доставка | Стоимость доставки товара.
Итого | Общая сумма заказа (включая сумму налога и стоимость доставки).
Шаблон документа Поле для выбора шаблонов, на основе которых будет выводиться печатная форма документов.
Для того чтобы выбрать более одного шаблона, используйте клавишу Ctrl.

Техническая информация для администраторов

Файлы, содержащие Пользовательские шаблоны документов, должны быть расположены в каталоге /bitrix/admin/reports/. Если в каталоге /bitrix/admin/ отсутствует папка reports - создайте её.

Файлы, содержащие Предустановленные шаблоны, находятся:

  • В каталоге /bitrix/modules/sale/reports/;
    • или
  • В каталогах /bitrix/modules/sale/[язык]/reports/. Например, для русскоязычных документов, путь к шаблонам выглядит так: /bitrix/modules/sale/ru/reports/.

В качестве шаблонов система предлагает все файлы этих каталогов с расширением .php. Если пользовательский шаблон имеет то же имя файла, что и предустановленный шаблон, то используется пользовательский шаблон. В качестве имени шаблона используется содержимое тега <title>.

Если вас не устраивает какой-либо предустановленный шаблон, то вам следует скопировать файл этого шаблона из каталога предустановленных шаблонов в каталог пользовательских шаблонов и изменить его соответствующим образом. В каталог пользовательских шаблонов можно добавить любое количество произвольных шаблонов документов.

В окне документа текст, который можно изменить, представляет собой обычные строки редактирования (input type="text"), их границы не отображаются на экране.

Шаблон документа

Шаблон документа представляет собой обычный php-скрипт. В этом скрипте доступны следующие переменные.

Переменная | Описание
$ORDER_ID | ID (код) текущего заказа.
$arOrder | Массив атрибутов заказа (ID, доставка, стоимость, дата создания и т.д.). Вы можете узнать полное содержимое этого массива для вашей версии модуля, если выполните в шаблоне документа следующий PHP код: print_r($arOrder)
$arOrderProps Массив свойств заказа. Свойства заказа настраиваются на странице управления свойствами заказа модуля продаж. Значения свойств заказа вводятся покупателями при оформлении заказа. Массив свойств заказа имеет следующую структуру:
array(
"мнемонический код
 (или ID, если мнем. код пуст) свойства"
=>
"значение свойства"
)
$arBasketIDs | Массив кодов товарных позиций в заказе (кодов соответствующих записей в корзине), которые выбраны для печати. Шаблон может не учитывать этот массив.
$arQuantities | Массив количеств товарных позиций в заказе, которые выбраны для печати. Элементы этого массива соответствуют элементам массива $arBasketIDs (т.е. товарная позиция с кодом $arBasketIDs[$i] появится в печатном документе в количестве $arQuantities[$i]). Шаблон может не учитывать этот массив.

Названием шаблона документа является содержимое тега <title> этого документа. Если у тега <title> установлен необязательный атрибут langs, то шаблон документа показывается только в том случае, если среди сайтов существуют перечисленные в качестве значения этого атрибута. Например, если в шаблоне присутствует строчка

<title langs="ru,s1">Счет-фактура</title>

то шаблон будет иметь имя Счет-фактура и будет показан только на сайтах ru или s1.


Список транспортных заявок

Страница Список транспортных заявок (Магазин > Заказы > Оплаты) предназначена для просмотра, внесения корректировок и удаления заявок.

Форма поиска

Поиск интересующих вас заявок. По умолчанию выводится только поле Идентификатор. Остальные поля подключаются по кнопке [+].

Поле | Описание
Идентификатор | Поиск по идентификатору заявки.
Служба доставки | Позволяет отобрать заявки по службам доставки.
Внешний идентификатор | Поиск по внешнему идентификатору.
Дата и время создания | Отбор заявок по дате их создания.

Чтобы отобрать транспортные заявки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех заявок нажмите кнопку Отменить.

Список заявок

Форма содержит список заявок.

Поле | Описание
Колонка флажков | Выбор заявок, к которым предполагается применить какое-либо правило или действие.
Действия Действия над заявкой:
  • Редактировать - переход к просмотру заявки;
  • Удалить - удаление заявки.
Идентификатор | Идентификатор заявки.
Дата и время создания | Дата и время создания транспортной заявки.
Служба доставки | Служба доставки, в которую отправлена заявка.
Внешний идентификатор | Внешний идентификатор заявки.
Номера заказов | Номера заказов, которые включены в заявку.
Идентификаторы отгрузок | Идентификаторы отгрузок, которые включены включены в заявку.


Просмотр транспортной заявки

Закладки

Данная форма служит для просмотра данных по заявке, скачивания пакета документов, редактирования списка входящих отрузок и изменения дня отправки в почтовое отделение.

Контекстная панель

Кнопка | Описание
К списку | Переход на страницу со списком заявок.
Действия Доступные действия:
  • Подготовка и отправка печатной формы Ф103 - переход к окну отправки печатной формы Ф103.
  • Скачать пакет документации - скачивание пакета документации по заявке.
  • Скачать печатную форму Ф103 - скачивание формы Ф103.
  • Изменение дня отправки в почтовое отделение - переход к окну изменения дня отправки в почтовое отделение.
  • Удалить заявку - удаление транспортной заявки.

Основное

Поле | Описание
Идентификатор | Идентификатор заявки.
Дата и время создания | Дата и время создания заявки.
Служба доставки | Служба доставки, в которую отправлена заявка.
Внешний идентификатор | Внешний идентификатор заявки.

Содержание

На данной закладке отображается подробная информация по заявке. Значения в поля подставляет служба доставки.

Список отгрузок

На закладке отображается список отгрузок, входящих в доставку.

Поле | Описание
Действия Действия над отгрузкой:
  • Содержание - переход к просмотру содержимого отгрузки;
  • Удалить - удаление отгрузки из заявки.
Номер заказа | Идентификатор заказа, к которому относится отгрузка.
Дата заказа | Время и дата создания заказа.
Идентификатор отгрузки | Идентификатор отгрузки.
Внешний идентификатор | Внешний идентификатор отгрузки.
Служба доставки | Служба доставки, в которую отправлена заявка.


Архив заказов

Страница Архив заказов (Магазин > Заказы > Архив) служит для переноса старых заказов в архив.

Форма поиска

Поиск интересующих вас заказов. По умолчанию выводится только поле ID записи. Остальные поля подключаются по кнопке [+].

Поле | Описание
ID заказа | Поиск по идентификатору заказа.
Номер заказа | Поиск по номеру заказа.
Дата заказа | Поиск по дате оформления заказа.
Стоимость заказа | Поиск по стоимости заказа.
Тип плательщика | Позволяет отобразить либо все заказы, относящиеся к определенному типу плательщика.
Покупатель | Данное поле позволяет установить фильтр по имени, фамилии покупателя.
Дата архивирования | Позволяет выбрать заказы по дате их архивирования.
Статус заказа Позволяет установить фильтр на отображение всех заказов или заказов только в определённом статусе. Например:
  • Принят;
  • В обработке;
  • Отгружен;
  • Доставлен.
Отменён | Позволяет отобразить отменённые, неотменённые или все заказы.
Отгружен | Позволяет отобразить отгруженные, неотгруженные или все заказы.
Оплачен | Позволяет отобразить оплаченные, неоплаченные или все заказы.
ID записи | Поиск заказа по идентификатору записи в таблице архива.
Код товара в заказе | Позволяет осуществить поиск заказа по коду товара, включённого в заказ.
Внешний код заказа | Позволяет осуществить поиск заказа по внешнему коду.

Чтобы отобрать заказы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех заказов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Архивирование заказов | Переход к форме архивирования заказов.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список архивированных заказов

Поле | Описание
Колонка флажков | Поле предназначено для выбора архивированных заказов, к которым предполагается применить какое-либо правило или действие.
Действия Действия над заказом:
  • Восстановить - восстановление заказа из архива.
  • Просмотреть подробную информацию о заказе - просмотр подробной информации о заказе;
  • Удалить заказ - удаление заказа.
ID заказа | Идентификатор заказа.
Номер заказа | Номер заказа в соответствии с шаблоном генерации номера, указанного в настройках магазина.
Дата создания | Дата и время создания заказа.
Покупатель | Имя и фамилия покупателя, указанные им при регистрации в системе.
Сумма | Общая сумма заказа с учётом применяемых скидок, налогов, а также стоимости доставки.
Статус | Статус заказа (например, Принят, В обработке, Доставлен).
Оплачен Статус оплаты заказа:
  • да - заказ оплачен;
  • нет - заказ не оплачен.
Отменён Статус отменены заказа:
  • да - заказ отменён;
  • нет - заказ не отменён.
Отгружен Статус отгрузки заказа:
  • да - заказ отгружен;
  • нет - заказ не отгружен.
Позиции | Содержимое заказа.
Дата архивирования | Дата и время добавления заказа в архив.


Форма архивирования заказов

Данная форма служит для добавления заказов в архив.

Форма архивирования

Поле | Описание
Шаг | Задается время выполнения одного шага процесса архивирования.
Через какое время отправлять в архив (дни) | Указывается такое количество дней, чтобы заказы, созданные более этого числа дней назад, добавлялись в архив.
Разрешить архивирование заблокированных заказов | При отмеченной опции заблокированные заказы также будут добавляться в архив.
Сайт | Указываются сайты, заказы с которых отправлять в архив.
Статусы заказа | Указываются статусы, заказы в которых следует добавить в архив.
Состояние заказа "Оплачен" | Определяется архивировать ли заказы в состоянии Оплачен.
Состояние заказа "Отменен" | Определяется архивировать ли заказы в состоянии Отменен.
Состояние заказа "Отгружен" | Определяется архивировать ли заказы в состоянии Отгружен.

Смотрите также

  • Архивирование заказов (учебный курс "Администратор. Бизнес")


Отправить отзыв по этому разделу

Кассы ККМ

  • Список касс
  • Редактирование параметров кассы
  • Список чеков
  • Список z-отчетов


Список касс

Отправить отзыв по этому разделу
Магазин>Интернет-магазин>Кассы ККМ>Список касс (доступно с 17.0.1)

Кассы ККМ::Список касс

С помощью данной формы вы можете выполнить поиск касс в соответствии с указанными условиями.

Форма поиска

Поле | Описание
Активность | Определяет какие кассы будут участвовать в поиске: активные, неактивные или все.

Чтобы отобрать кассы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех касс нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Сгенерировать ссылку | Служит для получения уникального URL'a, который необходимо прописать в настройках приложения 1С-Битрикс.Кассы.
Добавить кассу | Служит для добавления новой кассы в систему.
Установить из Маркетплейс | Служит для установки сторонних решений, связанных с интеграций касс.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список касс

Поле | Описание
Колонка флажков | Поле предназначено для выбора касс, к которым предполагается применить какое-либо правило или действие.
Действия Действия над кассой:
  • Изменить - изменение настроек кассы;
  • Удалить - удаление кассы.
ID | Идентификатор кассы.
Название | Название кассы.
Активность | Признак активности кассы.
Сортировка | Относительный "вес" кассы.
Дата создания | Дата создания кассы.
Номер ККМ | Номер кассы.
Статус последнего обращения | Отображается информация о том, успешно ли прошло последнее обращение сайта к кассе.
Последнее обращение | Дата и время последнего обращения сайта к кассе.


Редактирование параметров кассы

Отправить отзыв по этому разделу
Магазин>Интернет-магазин>Кассы ККМ>Редактирование параметров кассы (доступно с 17.0.1)

Кассы ККМ::Редактирование параметров кассы

Закладки

В форме редактирования кассы вы можете задать значения ее параметров.

Контекстная панель

Кнопка | Описание
Вернуться к списку касс | Переход к странице со списком касс.
Удалить кассу | Удаление редактируемой кассы.

Касса

Данная форма служит для управления основными параметрами кассы.

Поле | Описание
ID | Идентификатор кассы.
Активность | Признак активности кассы.
*Обработчик | Задается обработчик кассы.
ОФД | Указывается оператор фискальных данных, с которым работает касса.
*Название | Название кассы.
Марка ККМ | Указывается марка кассы.
Внешний идентификатор кассы | Для касс, подключенных через приложение 1С-Битрикс.Кассы значение устанавливается автоматически при подключении (это номер вашей ККМ). Для касс от сервисов Атол.Онлайн и Orange Data внешним идентификатором является код группы.
Используется офлайн | Признак использования кассы офлайн.
*Email | На Email, указанный в этом поле, будут приходить уведомления о проблемах с печатью чеков.

* - поля, обязательные для заполнения.

Ограничения

На закладке задаются ограничения по использованию текущей кассы.

Поле | Описание
кнопка Добавить ограничение | Служит для добавления ограничения путем заполнения данных во всплывающей форме. Ограничения могут быть: по компаниям и по платежным системам.
кнопка Настроить | Позволяет перейти к диалогу настройки внешнего вида таблицы со списком ограничений.
таблица со списком ограничений
Поле | Описание
Действия Действия над ограничением:
  • Редактировать - редактирование параметров ограничения во всплывающем окне;
  • Удалить - удаление ограничения.
Идентификатор | Идентификатор ограничения.
Сортировка | Относительный "вес" ограничения.
Тип ограничения | Тип ограничения.
Параметры | Параметры ограничения.

Настройки

На закладке определяются настройки НДС, оплат и печати Z-отчетов. Закладка недоступна для касс 1С.

Поле | Описание
Настройки авторизации
В секции указывается логин и пароль из полученного файла настроек для CMS. Секция доступна только для касс, работающих через сервис Атол.Онлайн.
Настройки безопасности
Секция доступна только для касс, работающих через сервис Orange Data.
Приватный ключ для подписи запросов в формате .pem | Полученный от сервиса файл private_key.xml сконвертируйте в PEM-формат и укажите его в данном поле.
Клиентский сертификат | В данном поле укажите полученный от сервиса файл <ваш_инн>.crt.
Приватный ключ SSL | Укажите файл <ваш_инн>.key.
Пароль для приватного ключа SSL | Указывается ваш пароль для ключа.
Ключ для проверки подписи | Необязательное поле. В нем указывается имя приватного ключа (чаще всего это ИНН организации). Если ключа нет, то поле заполнять не нужно.
Информация об организации
В секции указывается информация о вашей компании. Секция доступна только для касс, работающих через сервисы Атол.Онлайн и Orange Data.
Информация о клиенте
В секции настраивается, какие данные будут передаваться о клиенте в сервис (телефон или email). Секция доступна только для касс, работающих через сервисы Атол.Онлайн и Orange Data.
Настройки оплат
Секция доступна для касс, работающих через приложение 1С-Битрикс.Кассы и сервис Атол.Онлайн.
Для типов оплат указывается значение вида оплаты в кассе. Значение подставляется автоматически при подключении кассы.
Настройки ставок НДС
Для созданных в системе ставок НДС указывается значение налога в кассе. Значение подставляется автоматически при подключении кассы.
Налогообложение
Секция доступна только для касс, работающих через онлайн сервисы.
Система налогообложения | Указывается система налогооблажения, используемая в вашей компании.
Настройки печати Z-отчетов
Секция доступна только для приложения 1С-Битрикс.Кассы.
Время закрытия кассовой смены и печати Z-отчета | Указывается время закрытия кассовой смены и Z-печать отчета в ОФД.
Настройки взаимодействия
Секция доступна только для касс, работающих через сервис Orange Data.
Режим работы кассы | Указывается режим работы кассы: боевой или тестовый.

Настройки ОФД

Поле | Описание
Тестовый режим работы ОФД | При отмеченной опции касса будет работать с тестовым оператором.
Ключ безопасности | Вводится ключ, сгенерированный в личном кабинете ОФД. Параметр доступен только для касс, работающих с ОФД ЯРУС.
ИНН | Указывается ИНН продавца. Параметр доступен только для касс, работающих с OFD.RU.


Список чеков

Отправить отзыв по этому разделу
Магазин>Интернет-магазин>Кассы ККМ>Список чеков (доступно с 17.0.1)

Кассы ККМ::Список чеков

Страница Список чеков (Магазин > Кассы ККМ > Чеки за день) служит для просмотра чеков, созданных для оплат заказов.

Форма поиска

С помощью данной формы вы можете выполнить поиск чеков в соответствии с указанными условиями.

Поле | Описание
Кассы | Определяет чеки с каких касс будут участвовать в поиске.
Номер чека | Поиск чеков по номерам.
Дата создания чека | Поиск чеков по дате создания.
ID заказа | Определяет для каких заказов следует найти чеки.
Статус | Определяет чеки в каких статус будут участвовать в поиске.

Чтобы отобрать чеки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех чеков нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить чек | Служит для добавления чека вручную. Во всплывающем окне указывается идентификатор заказа, оплата, отгрузка и тип чека.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список чеков

Поле | Описание
ID | Идентификатор чека в системе.
ID заказа | Идентификатор заказа.
Название кассы | Признак кассы, с которой был напечетан чек.
Дата создания | Дата и время создания чека.
Сумма чека | Сумма чека.
Ссылка на чек | Ссылка на чек для его детального просмотра.
Статус | Статус чека. Возможны следующие: Напечатан, Не напечатан, В процессе печати и Ошибка.
Оплата | Документ оплаты заказа.
Отгрузка | Документ отгрузки.


Список z-отчетов

Отправить отзыв по этому разделу
Магазин>Интернет-магазин>Кассы ККМ>Список z-отчетов (доступно с 17.0.1)

Кассы ККМ::Список z-отчетов

Страница Z-отчеты (Магазин > Кассы ККМ > Z-отчеты) служит для просмотра данных по Z-отчетам.

Форма поиска

С помощью данной формы вы можете выполнить поиск Z-отчетов в соответствии с указанными условиями.

Поле | Описание
Кассы | Определяет Z-отчеты каких касс необходимо отобразить.
Дата создания | Отбор Z-отчетов по дате их создания.

Чтобы отобрать Z-отчеты по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех отчетов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить новый Z-отчет | Служит для создания Z-отчета вручную (необходимо при ручном закрытии смены).
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список Z-отчетов

Поле | Описание
ID | Идентификатор Z-отчета.
Название кассы | Название кассы, для которой создан Z-отчет.
Дата создания | Дата и время создания Z-отчета.
Сумма наличными | Сумма по наличному расчету.
Сумма по безналичному расчету | Сумма по безналичному расчету.
Сумма возвратов | Сумма возвратов по всем чекам в рамках текущей кассовой смены.
Общая сумма за день | Итоговая сумма чеков за день.
Нарастающий итог | Нарастающий итог по всем чекам с момента подключения кассы до создания текущего Z-отчета.

Смотрите также

  • Z-отчеты (учебный курс "Администратор. Бизнес")


Отправить отзыв по этому разделу

Покупатели

  • Список покупателей
  • Просмотр профиля покупателя
  • Редактирование профиля
  • Корзины
  • Внутренние счета покупателей
  • Создание и редактирование счета
  • Продление подписки
  • Создание и редактирование продления подписки
  • Транзакции
  • Выполнение новой транзакции
  • Пластиковые карты
  • Создание и редактирование пластиковой карты
  • Список подписок


Список покупателей

Страница Покупатели (Магазин > Покупатели > Список покупателей) служит для просмотра и редактирования информации о покупателях интернет-магазина. На данной странице можно узнать такую информацию, как:

  • сведения о заказах;
  • список профилей покупателя;
  • информация о корзине покупателя;
  • список просмотренных покупателем товаров.

Важно! Данная страница недоступна в редакции Малый бизнес.

Форма поиска

С помощью данной формы вы можете выполнить поиск покупателей в соответствии с указанными условиями.

Поле | Описание
Покупатель | Поиск по логину, имени/фамилии/отчеству или E-mail покупателя.
ID покупателя | Поиск по идентификационному номеру пользователя.
Логин | Поиск по логину покупателя на сайте.
E-mail | Поиск по электронному адресу покупателя.
Телефон | Поиск по номеру телефона покупателя.
Последняя авторизация | Фильтрация покупателей относительно даты или периода последнего посещения сайта.
Сумма оплаченных заказов | Поиск по диапазону суммы оплаченных покупателем заказов.
Количество оплаченных заказов | Поиск по количественному диапазону оплаченных покупателем заказов.
Дата последнего заказа | Фильтрация относительно даты или периода, когда покупателем был совершен последний заказ.
Группа пользователей | Фильтрация по группе пользователей на сайте, к которой относится покупатель.
Валюта | Поиск по валюте, в которой оплачивал заказы покупатель.

Остальные закладки фильтра представляют собой предустановленные фильтры, осуществляющие поиск:

  • Лучшие покупатели - покупателей с самой большой суммой оплаченных заказов;
  • Новые покупатели - покупателей, зарегистрировавшихся за последний месяц.

Чтобы отобрать покупателей по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех покупателей нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список покупателей

Поле | Описание
Действия Действия с покупателем:
  • Профиль пользователя - просмотр информации о покупателе;
  • Создать заказ - создание заказа от имени данного покупателя.
Покупатель | Имя покупателя.
E-mail | Электронный адрес покупателя.
Телефон | Телефонный номер покупателя.
Дата последнего входа | Дата и время последней авторизации покупателя на сайте.
Дата последнего заказа | Дата и время последнего заказа.
Количество оплаченных заказов | Число оплаченных покупателем заказов.
Сумма оплаченных заказов | Общая сумма оплаченных покупателем заказов.


Просмотр профиля покупателя

Закладки

Данная форма служит для просмотра профиля покупателя.

Контекстная панель

Кнопка | Описание
Список покупателей | Переход на страницу со списком покупателей.
Создать заказ | Переход к форме создания нового заказа для просматриваемого покупателя.

Общая информация

Поле | Описание
Общая информация
Логин | Логин покупателя на сайте.
E-mail | Электронный адрес покупателя.
Дата регистрации | Дата и время регистрации покупателя на сайте.
Дата последнего входа | Дата и время последней авторизации покупателя на сайте.
Группы пользователя | Перечисляются группы пользователей сайта, в которые входит покупатель.
Статистика заказов
Количество заказов (оплаченные/все) | Отношение числа оплаченных покупателем заказов к общему числу его заказов на данном сайте.
Оплаченных заказов на сумму | Показывается общая сумма оплаченных покупателем заказов.
Средняя стоимость оплаченных заказа | Отношение общей суммы оплаченных покупателем заказов к количеству оплаченных заказов.
Последние заказы
Выводится список заказов покупателя в порядке убывания даты/времени

Профили

На данной закладке представлен перечень используемых покупателем профилей.

Поле | Описание
Профиль | Название профиля.
Тип плательщика | Тип плательщика для данного профиля.
Дата обновления | Дата и время последнего изменения профиля.

Список заказов

На данной закладке представлен список всех заказов покупателя.

На закладке имеется фильтр, с помощью которого вы можете выполнить поиск заказов по следующим параметрам:

Поле | Описание
Дата добавления | Поиск по конкретной дате или временному периоду, когда был добавлен заказ.
Дата обновления | Поиск по конкретной дате или временному периоду, когда были изменены параметры заказа.
Сайт | Сайт, заказы на котором следует найти.
Статус | Поиск заказов по их статусам.
Оплачен | Поиск по отметке того, оплачен ли заказ.
Сумма заказа | Поиск по ценовому диапазону суммы заказа.
Название товара | Поиск по названию товара.

Чтобы отобрать заказы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех заказов нажмите кнопку Отменить.

Далее на на данной закладке представлен список заказов покупателя. О форме списка заказов смотрите на странице документации Заказы.

Корзина

На данной закладке представлен список товаров, на данный момент находящихся в корзине покупателя.

Поле | Описание
Колонка флажков | Поле предназначено для выбора товаров, к которым предполагается применить какое-либо действие.
Дата добавления | Дата и время добавления товара в корзину.
Название | Наименование и id товара.
Цена | Стоимость единицы товара.
Количество | Количество наименований товара.
Сайт | Сайт, на котором покупатель добавил товары в корзину. Поле отображается, если сайтов в системе большего одного.
Примечание: на закладке имеется фильтр, с помощью которого вы можете выполнить поиск товаров по названию.

Просмотренные товары

На данной закладке представлен список товаров, которые просматривал покупатель.

Поле | Описание
Действия Действия, которые можно произвести над товаром:
  • Оформить заказ - нажмите для оформления заказа с данным товаром;
  • Добавить в корзину - нажмите для добавления товара в корзину.
Дата просмотра | Дата и время просмотра товара.
Название | Наименование и id товара.
Цена | Стоимость единицы товара.
На складе | Количество товара на складах.

Примечание: на закладке имеется фильтр, с помощью которого вы можете выполнить поиск товаров по дате просмотра.


Редактирование профиля

Данная страница служит для редактирования профиля покупателя.

Контекстная панель

Кнопка | Описание
Список профайлов | Переход на форму просмотра используемых профилей покупателем.

Поля формы

Поле | Описание
Пользователь | Идентификатор, логин и ФИО пользователя, которому принадлежит данный профиль. Поле изменению не подлежит.
Профайл | Название профиля покупателя.
Личные данные
*Ф.И.О. | ФИО, используемые в данном профиле покупателя.
*E-Mail | Электронный адрес покупателя, используемый в данном профиле.
*Телефон | Номер телефона покупателя, используемый в данном профиле.
Данные для доставки
*Индекс | Индекс местоположения покупателя.
Местоположение | Местоположение покупателя.
Город | Город покупателя (если он не задан в поле Местоположение)
*Адрес доставки | Адрес доставки заказа покупателю.

* - поля, обязательные для заполнения.


Корзины

Страница Брошенные корзины пользователей (Магазин > Покупатели > Корзины) служит для просмотра корзин покупателей интернет-магазина, в которые добавлен какой-либо товар.

Форма поиска

С помощью данной формы вы можете выполнить поиск и сортировку корзин в соответствии с указанными условиями.

Поле | Описание
ID покупателя | Поиск по идентификационному номеру пользователя.
Логин покупателя | Поиск по логину покупателя на сайте.
Стоимость | Поиск по указываемому суммарному диапазону стоимости товаров в корзине.
Всего товаров | Поиск по указываемому диапазону количества товаров в корзине.
Количество наименований | Фильтрация по количеству наименований товаров в корзине.
Наличие товаров Поиск по признаку наличия товара в магазине:
  • Доступные для покупки;
  • Отложенные;
  • Ожидает поступления.
Дата добавления | Поиск по дате или временному периоду добавления товара в корзину.
Дата изменения | Поиск по дате или временному периоду изменения содержимого корзины.
Товар | Поиск товара в корзине по наименованию.
Валюта | Поиск по валюте, в которой указана стоимость товаров корзины.
.

Остальные закладки фильтра представляют собой предустановленные фильтры, осуществляющие сортировку корзин по параметрам:

  • Самые большие корзины - сортировка от большего к меньшему по количеству наименований товаров в корзине;
  • Самые ценные корзины за все время - сортировка от большего к меньшему по суммарной стоимости товара в корзине;
  • Самые ценные корзины недели - сортировка от большего к меньшему по суммарной стоимости товара в корзине, измененной за последнюю неделю.

Чтобы отобрать корзины по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех корзин нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список корзин

Поле | Описание
Действия Действия с корзиной покупателя:
  • Оформить заказ - оформление заказа из товаров корзины покупателя;
  • Профиль покупателя - просмотр профиля покупателя (профиль доступен только для зарегистрированных пользователей).
Покупатель | Имя покупателя.
Стоимость | Суммарная стоимость товаров в корзине.
Количество наименований | Число наименований товаров в корзине.
Товар | Список товаров в корзине с указанием количества штук и стоимости одной единицы.
Дата добавления | Дата и время последнего добавления товара в корзину.


Внутренние счета покупателей

Форма Внутренние счета пользователей (Магазин > Покупатели > Счета) содержит список внутренних счетов клиентов и отражает остаток средств на данных счетах.

Форма поиска

С помощью данной формы вы можете выполнить поиск внутренних счетов пользователей в соответствии с указанными условиями.

Поле | Описание
Пользователь* Поиск счета по имени, отчеству, фамилии и/или e-mail адресу пользователя-владельца счета.

Данное поле отображается, даже если фильтр свернут.
ID пользователя | Идентификационный номер пользователя-владельца счета.
Логин пользователя | Поиск счета по логину (имени входа) пользователя-владельца счета.
Валюта | Поиск счета по его валюте.
Заблокирован Поиск счета по признаку активности:
  • да - в поиске будут участвовать только заблокированные (неактивные) счета;
  • нет - в поиске будут участвовать только активные счета;
  • все- в поиске будут участвовать все счета (активные и заблокированные).

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать внутренние счета пользователей по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех счетов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить счет | Переход к форме создания нового внутреннего счета.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список счетов

Поле | Описание
Колонка флажков | Поле предназначено для выбора счетов пользователей, к которым предполагается применить какое-либо правило или действие.
Действия Действия, доступные для выполнения над внутренним счетом пользователя:
  • Изменить параметры счета - редактирование внутреннего счета пользователя;
  • Удалить счет- удаление счета.
ID | Идентификатор счета в системе.
Пользователь | Идентификатор, имя, логин и e-mail адрес пользователя-владельца счета.
Сумма на счете | Размер денежной суммы на счете (в валюте счета).
Заблокирован | Признак активности счета (т.е. доступности выполнения транзакций по счету). Для того чтобы разблокировать счет, отметьте данный счет с помощью флага в крайнем левом поле, затем выберите операцию Разблокировать на панели управления внизу страницы и нажмите кнопку Применить.
Транзакций | Количество выполненных транзакций по данному счету. При нажатии на ссылку с количеством транзакций будет открыта страница со список транзакций по данному счету.


Создание и редактирование счета

Данная форма служит для создания и настройки внутренних счетов пользователей.

Контекстная панель

Кнопка | Описание
Список счетов | Переход на страницу со списком внутренних счетов пользователей.
Добавить счет | Переход к форме создания нового внутреннего счета. Кнопка отображается при редактировании существующего счета.
Удалить счет | Удаление редактируемого счета.

Поля формы

Поле | Описание
ID | Идентификатор счета в системе. Поле отображается при редактировании существующего счета.
Дата последнего изменения | Дата и время последнего изменения параметров счета. Поле отображается при редактировании существующего счета.
*Пользователь | Идентификатор пользователя-владельца счета. При создании счета идентификатор пользователя выбирается в списке, открываемом с помощью кнопки [...].
*Сумма на счете | Общая сумма на счете и валюта счета.
Заблокировать/Разблокировать бюджет | Возможность вручную заблокировать, разблокировать счёт (бюджет) пользователя. При ручной (не автоматической) блокировке разблокирование возможно только через 1 час.
Заметки | Произвольный комментарий к создаваемому счету.
Основание изменения суммы на счете | Указывается событие, в связи с которым изменяется сумма на счете.

* - поля, обязательные для заполнения.


Продление подписки

Форма Продление подписки (Магазин > Покупатели > Продление) содержит список записей о продлении прав пользователей на пользование платным контентом сайта.

Форма поиска

Поиск записей о продлении в соответствии с указанными условиями. По умолчанию выведено только поле Пользователь. С помощью кнопки [image] можно подключить поиск по другим полям.

Поле | Описание
Пользователь* Поиск записи по имени, отчеству, фамилии и/или e-mail адресу пользователя, для которого было оформлено продление подписки.

Данное поле отображается, даже если фильтр свернут.
Код пользователя | Поиск записи по коду пользователя, для которого было оформлено продление подписки. Данный код автоматически присваивается пользователю при регистрации на сайте.
Логин пользователя | Поиск записи по логину (имени входа) пользователя, для которого было оформлено продление подписки.
Отменено Поиск записи по состоянию подписки:
  • да - в поиске участвуют отменённые записи о продлении подписки;
  • нет - в поиске участвуют действующие (активные) продления подписки;
  • все - в поиске участвуют как отменённые, так и действующие продления подписки.
Дата последнего продления Поиск по дате оформления продления подписки.
Значение поля может быть задано как количеством дней, прошедших со дня оформления подписки, так и в виде временного диапазона (с помощью on-line календаря).
Дата очередного продления Поиск по дате оформления очередного продления подписки.
Значение поля может быть задано как количеством дней, оставшихся до дня оформления очередной подписки, так и в виде временного диапазона (с помощью on-line календаря).
Номер базового заказа | Номер заказ, запись о продлении которого присутствует в списке.
Успешное продление Поиск записи по статусу продления подписки:
  • да - в поиске участвуют записи только об успешно продленной подписке;
  • нет- в поиске участвуют записи о подписке, продление которой прошло с какой-либо ошибкой;
  • все - в поиске участвуют записи обо всех продлениях подписки (успешных и неуспешных).

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать записи о продлении по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех записей нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить запись | Переход к форме создания нового продления.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список продлений подписки

Поле | Описание
Колонка флажков | Поле предназначено для выбора записей, к которым предполагается применить какое-либо правило или действие.
Действия Действия, доступные для выполнения над записью о продлении подписки:
  • Изменить параметры продления - редактирование продления подписки;
  • Удалить продление- удаление записи о продлении подписки.
ID | Идентификатор записи о продлении подписки.
Пользователь | Регистрационный код, имя и e-mail адрес пользователя, для которого было оформлено продление подписки.
Отм. Признак действительности продления подписки.
Если значение поля "Да", то продление подписки считается недействительным (т.е. продление отменяется).
Предыдущее продление | Дата и время последнего продления подписки.
Очередное продление | Дата и время предстоящего продления подписки.
Успешный платеж | Признак успешности оплаты продления подписки.


Создание и редактирование продления подписки

Данная форма служит для оформления продления подписки или изменения параметров уже оформленного продления.

Контекстная панель

Кнопка | Описание
Список записей | Переход на страницу со списком записей о продлении подписки.
Добавить новую запись | Переход к форме создания нового продления. Отображается при редактировании существующего продления.
Удалить запись | Удаление редактируемого продления.

Поля формы

Поле | Описание
ID | Идентификатор записи о продлении подписки в системе. Отображается в режиме редактирования продления подписки.
Дата последнего изменения | Дата и время последнего изменения подписки. Отображается в режиме редактирования продления подписки.
*Пользователь | Регистрационный код пользователя, для которого оформляется продление подписки. Выбор кода осуществляется из списка, открываемого с помощью кнопки [...].
Отменено | Признак недействительности продления подписки. Если выбрана данная опция, то продление подписки считается недействительным (т.е. продление отменяется).
Причины отмены | Если продление подписки отменяется, то в данном поле указываются причины отмены.
Модуль | Название модуля, право на доступ к контенту которого продлевается.
*Товар | Идентификационный номер товара, подписка на использование которого продлевается.
Название товара | Полное наименование товара.
Ссылка на товар | Ссылка на страницу с информацией о товаре.
Дата последнего продления (DD.MM.YYYY HH:MI:SS) | Дата и время оформления предыдущего продления подписки.
*Дата очередного продления (DD.MM.YYYY HH:MI:SS) | Дата и время предстоящего продления подписки.
Предыдущая попытка выполнения успешна | Признак успешности предыдущего оформления продления подписки.
Осталось попыток продления | Если продление подписки осуществляется автоматически, то в данном поле указывается количество возможных попыток продления. Если значение поля равно 0, то попытка продления подписки производиться не будет.
*Код базового заказа | Код продлеваемого заказа.
Описание | Произвольное описание записи о продлении подписки.

* - поля, обязательные для заполнения.

Смотрите также

  • Продление подписки (учебный курс "Администратор. Бизнес")


Транзакции

Форма Транзакции (Магазин > Покупатели > Транзакции) содержит список всех транзакций, выполняемых по счету клиента интернет-магазина (например, зачисление или списание денежных средств).

Форма поиска

С помощью данной формы вы можете выполнить поиск транзакций в соответствии с указанными условиями.

Поле | Описание
Пользователь* | Поиск счета по имени, отчеству, фамилии и/или e-mail адресу пользователя-владельца счета. Данное поле отображается, даже если фильтр свернут.
ID пользователя | Идентификационный номер пользователя, по счету которого была выполнена операция.
Логин пользователя | Поиск транзакции по логину (имени входа) пользователя, по счету которого была выполнена операция.
Валюта | Поиск транзакции по валюте операции.
Дата транзакции | Поиск операции по дате проведения. Возможно указание как количества дней, прошедших со дня выполнения операции, так и периода времени, в течение которого могла быть выполнена транзакция.
Номер заказа | Поиск транзакции по номеру заказа, в рамках которого она была проведена.

Чтобы отобрать транзакции по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех транзакций нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить транзакцию | Переход к форме создания новой транзакции.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список транзакций

Поле | Описание
ID | Уникальный идентификатор транзакции в системе.
Дата транзакции | Дата проведения операции по счету.
Пользователь | Регистрационный код, имя и e-mail адрес пользователя, по счету которого осуществляется данная операция.
Сумма | Сумма операции.
Заказ | Номер заказа, в рамках которого была проведена данная операция. Номер заказа представлен в виде ссылки, позволяющей перейти к форме с подробной информацией о заказе.
Тип | Тип операции по счету.
Описание | Регистрационный код, имя и логин пользователя, выполнившего транзакцию.

Смотрите также

  • Транзакции (учебный курс "Администратор. Бизнес")


Выполнение новой транзакции

Данная форма служит для проведения новой операции (транзакции) по счету клиента.

Контекстная панель

Кнопка | Описание
Список транзакций | Переход на страницу со списком транзакций.

Поля формы

Поле | Описание
*Пользователь | Идентификатор пользователя, по счету которого выполняется операция. Идентификатор пользователя выбирается в списке, открываемом с помощью кнопки [...].
*Дата транзакции (DD.MM.YYYY HH:MI:SS) | Дата и время проведения операции. Если значение поля указано для будущего периода, то операция будет выполнена при наступлении указанной даты и времени.
*Сумма | Сумма операции.
Валюта | Валюта операции.
Тип записи | Тип выполняемой операции (транзакции).
Номер заказа (если транзакция относится к заказу) | Если транзакция выполняется в рамках какого-либо заказа, то в данном поле указывается номер этого заказа.
Заметки | Произвольный комментарий к выполняемой операции.

* - поля, обязательные для заполнения.


Пластиковые карты

Внимание: Функционал Пластиковых карт НЕ рекомендуется к использованию и в ближайшее время будет удален из модуля Интернет-магазин.

Форма Пластиковые карты (Магазин > Покупатели > Пластиковые карты) содержит список всех пластиковых карт, с помощью которых клиенты магазина осуществляют оплату за товары.

Важно! Для обеспечения безопасности работы с пластиковыми картами на странице настроек модуля Интернет-магазин необходимо задать пароль для шифрования номеров карт. Если пароль не задан, то соответствующее сообщение будет выведено вверху страницы.

Форма поиска

С помощью данной формы вы можете выполнить поиск пластиковых карт в соответствии с указанными условиями.

Поле | Описание
Пользователь* Поиск счета по имени, отчеству, фамилии и/или e-mail адресу пользователя-владельца счета.

Данное поле отображается, даже если фильтр свернут.
Код пользователя | Поиск карты по коду пользователя, осуществляющего платежи. Данный код автоматически присваивается пользователю при регистрации на сайте.
Логин пользователя | Поиск карты по логину (имени входа) пользователя, осуществляющего платежи.
Активность Поиск пластиковой карты с использованием признака активности карты:
  • да - в поиске участвуют только активные (доступные для использования при оплате) карты;
  • нет- в поиске участвуют только неактивные карты;
  • все - в поиске участвуют все пластиковые карты (активные и неактивные).

Чтобы отобрать пластиковые карты по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех пластиковых карт, нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить карту | Переход к форме создания новой пластиковой карты.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список пластиковых карт

Поле | Описание
Колонка флажков | Поле предназначено для выбора пластиковых карт, к которым предполагается применить какое-либо правило или действие.
Действия Действия, доступные для выполнения над пластиковой картой:
  • Изменить параметры пластиковой карты - редактирование пластиковой карты;
  • Удалить пластиковую карту - удаление записи с параметрами пластиковой карты.
ID | Идентификатор пластиковой карты.
Пользователь | Идентификатор, имя и e-mail адрес пользователя, осуществляющего платежи с помощью данной пластиковой карты.
Акт. Признак активности пластиковой карты.
Неактивная карта не может использоваться для оплаты товаров.
Сорт. | Относительный "вес" пластиковой карты. Используется для определения положения пластиковой карты в общем списке.
Валюта | Наименование валюты, в которой осуществляются платежи с помощью данной пластиковой карты.
Тип | Наименование типа пластиковой карты.


Создание и редактирование пластиковой карты

Внимание: Функционал Пластиковых карт НЕ рекомендуется к использованию и в ближайшее время будет удален из модуля Интернет-магазин.

Данная форма служит для задания параметров новой и редактирования уже существующей пластиковой карты.

Важно! Для обеспечения безопасности работы с пластиковыми картами на странице настроек модуля Интернет-магазин необходимо задать пароль для шифрования номеров карт. Если пароль не задан, то соответствующее сообщение будет выведено вверху страницы.

Кроме того, файл с паролем шифрования пластиковых карт должен находиться вне зоны досягаемости пользователей системы для защиты от несанкционированного доступа к информации о пластиковых картах.

Контекстная панель

Кнопка | Описание
Список пластиковых карт | Переход на страницу со списком пластиковых карт.
Добавить карту | Переход к форме создания новой карты. Кнопка отображается при редактировании существующей карты.
Удалить карту | Удаление редактируемой карты.

Поля формы

Поле | Описание
ID | Идентификатор пластиковой карты в системе. Поле отображается при редактировании существующей пластиковой карты.
Дата последнего изменения | Дата и время последнего изменения записи с параметрами пластиковой карты. Поле отображается при редактировании существующей пластиковой карты.
*Пользователь | Указывается регистрационный код пользователя, осуществляющего платежи с помощью данной карты. Код пользователя выбирается из списка, открываемого с помощью кнопки [...].
Активность | Признак активности пластиковой карты. Неактивная карта не может использоваться для оплаты товаров.
Индекс сортировки | Относительный "вес" пластиковой карты. Используется при выводе данной пластиковой карте в общем списке.
*Платежная система | Выбирается платежная система, через которую осуществляются платежи по данной пластиковой карте.
Валюта, которую можно снимать с карты | Наименование валюты, в которой осуществляются платежи с помощью данной пластиковой карты.
Тип карты | Выбирается тип пластиковой карты.
*Номер карты | Номер пластиковой карты. Отображается в закодированном виде. Для просмотра доступны только 4 последних цифры номера.
Карта оканчивает действие | Указывается дата, после наступления которой карта больше не может использоваться для осуществления платежей в системе.
CVC2 | Код карты CVC2.
Минимальная сумма, которую можно снять с карты | Указывается минимальная сумма, которая может быть снята с карты за одну транзакцию (единовременно).
Максимальная сумма, которую можно снять с карты | Указывается максимальная сумма, которая может быть снята с карты за одну транзакцию (единовременно).
Валюта сумм | Валюта, в которой были указанны значения предыдущих полей (минимальная и максимальная сумма).
Описание | Произвольное описание пластиковой карты.
Последняя активизация | Дата и время последнего использования карты.

* - Поля, обязательные для заполнения.

Смотрите также

  • Пластиковые карты (учебный курс "Администратор. Бизнес")


Список подписок

С помощью данной формы (Магазин > Покупатели > Подписка на товары) вы можете управлять подписками пользователей на товары торгового каталога.

Фильтр

Форма фильтра используется для поиска подписок в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
ID | Поиск по идентификатору подписки. Поле присутствует, даже если фильтр свернут.
Пользователь | ФИО подписавшегося пользователя.
Контакт пользователя | Поиск подписки по контакту пользователя.
ID товара | Поиск по идентификатору отсутствующего товара.
Дата подписки | Поиск по дате подписки.
Дата окончания подписки | Поиск по дате окончания подписки.
Тип контакта | Поиск по типу контакта.
Активность | Поиск по активности подписки.

Чтобы отобрать подписки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех подписок нажмите кнопку Отменить.

Список подписок

Поле | Описание
Колонка флажков | Поле предназначено для выбора подписок, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия:
  • удалить - удаление подписки;
  • активировать - активация подписки;
  • деактивировать - снятие флага активности у подписки.
ID | Идентификатор подписки.
Дата подписки | Дата и время подписки на товар.
Контакт пользователя | Контакт пользователя (по умолчанию электронный адрес пользователя).
Пользователь | ФИО подписавшегося пользователя.
Тип контакта | Тип контакта (по умолчанию электронный адрес).
Активность | Признак активности подписки. Если подписка активна, то пользователю будет отправлено письмо с уведомлением о поступлении товара.
Дата окончания подписки | Дата и время окончания подписки.
ID товара | Идентификатор товара, на который подписался пользователь.
Название товара | Название товара, на который подписался пользователь.
Сайт ID | Идентификатор сайта.


Отправить отзыв по этому разделу

Аффилиаты

  • Аффилиаты
  • Создание и редактирование аффилиата
  • Планы комиссий аффилиатов
  • Создание и редактирование плана
  • Пирамиды
  • Создание и редактирование пирамиды
  • Калькуляция аффилиатов
  • Транзакции аффилиатов


Аффилиаты

На странице Магазин > Аффилиаты > Аффилиаты представлен список аффилиатов, зарегистрированных в системе.

Форма поиска

С помощью данной формы вы можете выполнить поиск аффилиатов в соответствии с указанными условиями.

Поле | Описание
Сайт | Поиск аффилиатов по сайту (или всем сайтам), на котором они зарегистрировались.
Пользователь* | Поиск аффилиата по имени, отчеству, фамилии и/или e-mail адресу пользователя-аффилиата..
План | План, по которому работает аффилиат.
Активность Поиск аффилиата по признаку активности:
  • да - в поиске будут участвовать только активные аффилиаты;
  • нет - в поиске будут участвовать только неактивные аффилиаты;
  • все- в поиске будут участвовать все аффилиаты.
Дата последней калькуляции

Задается временной интервал для поиска даты проведения калькуляции аффилиатов.

Дата регистрации

Задается временной интервал для поиска даты регистрации аффилиатов.

Аффилиат-родитель | Поиск аффилиатов по их родителю (пользователь-аффилиат, через которого проводилась регистрация). Аффилиата-родителя можно указать с помощью кнопки [...].

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать аффилиатов по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех аффилиатов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить аффилиата | Переход к форме создания нового аффилиата.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список аффилиатов

Поле | Описание
Колонка флажков | Поле предназначено для выбора аффилиатов, к которым предполагается применить какое-либо правило или действие.
Действия Действия, доступные для выполнения над аффилиатом:
  • Изменить - редактирование параметров аффилиата;
  • Удалить - удаление аффилиата.
ID | Идентификатор аффилиата в системе.
Сайт | Сайт, на котором зарегистрирован аффилиат.
Пользователь | Идентификатор, имя, логин и e-mail адрес пользователя-аффилиата.
План | План, по которому работает аффилиат.
Активность | Признак активности аффилиата.
Дата создания | Количество элементов в списке.
Выплаченная сумма | Сумма, выплаченная аффилиату.
Начисленная сумма | Сумма, начисленная аффилиату.
Дата последней калькуляции | Дата и время проведения последней калькуляции аффилиата.

Действия над аффилиатами

Действие | Описание
Калькулировать аффилиата | Начислить сумму за заказы этого аффилиата со времени последней калькуляции по текущий момент.
Калькулировать аффилиата расширенно | Откроется специальная форма калькульции аффилиата, в которой можно установить период калькуляции, а также период по заказам, за который определяется план аффилиата.
Выплатить аффилиату начисленные суммы | Осуществляется выплата начисленных сумм (перевод начисленных сумм в выплаченые суммы).
Выплатить аффилиату начисленные суммы на внутренний счет | Перевод начисленных сумм в выплаченые суммы с зачислением этих сумм на внутренний счет покупателя магазина (если внутренний счет пользователя не существует, то он будет создан).
Обнулить выплаченные суммы | Используется при выплате наличных аффилиату.
Активировать | Установка флага активности аффилиата.
Деактивировать | Снятие флага активности аффилиата. Неактивный аффилиат не участвует в работе системы, а лишь числится в списке аффилиатов.

Смотрите также

  • Страница "Аффилиаты" (учебный курс "Администратор. Бизнес")


Создание и редактирование аффилиата

Данная форма служит для создания нового и редактирования параметров уже существующего аффилиата.

Контекстная панель

Кнопка | Описание
Список аффилиатов | Переход на страницу со списком аффилиатов.
Добавить аффилиата | Переход к форме создания нового аффилиата. Кнопка отображается при редактировании существующего аффилиата.
Удалить аффилиата | Удаление редактируемого аффилиата. Кнопка отображается при редактировании существующего аффилиата.

Поля формы

Поле | Описание
ID | Идентификатор аффилиата в системе. Поле отображается при редактировании существующего аффилиата.
Дата последнего изменения | Дата и время последнего изменения параметров аффилиата. Поле отображается при редактировании существующего аффилиата.
*Сайт | Сайт, на котором зарегистрирован аффилиат.
*Пользователь | Идентификатор пользователя-аффилиата. При регистрации идентификатор пользователя выбирается в списке, открываемом с помощью кнопки [...].
Аффилиат, через которого зарегистрировался | Если регистрируется аффилиат не первого уровня, то с помощью кнопки [...] выбирается аффилиат, через которого происходит регистрация.
*План | Выберите план, в соответствии с которым аффилиат будет получать прибыль.
Фиксировать план | Опция служит для фиксирования плана, выбранного в предыдущем поле. При калькуляции аффилиатов происходит повышение плана участников, если сумма/количество дойдет до следующего. У тех, у кого план фиксирован, перехода не будет даже при достижении условий.
Активность | Отметьте опцию, чтобы аффилиат был активным.
*Дата регистрации | Укажите дату регистрации аффилиата.
Выплаченная сумма | Сумма, выплаченная аффилиату. Поле заполняется автоматически после калькуляции.
Начисленная сумма | Сумма, начисленная аффилиату. Поле заполняется автоматически после калькуляции.
Дата последней калькуляции (DD.MM.YYYY HH:MI:SS) | Дата и время, проведения последней калькуляции. Поле заполняется автоматически после калькуляции аффилиата.
Сайт аффилиата | Адрес сайта аффилиата.
Описание аффилиата | Произвольное описание аффилиата.

* - поля, обязательные для заполнения.


Планы комиссий аффилиатов

Управление планами аффилиатов осуществляется на странице Планы комиссий аффилиатов (Магазин > Аффилиаты > Планы). Планы аффилиатов могут делиться по количеству продаж или по сумме продаж. Выбор типа планов осуществляется в настройках модуля Интернет-магазин.

Важно! Решение, по которому будут делиться планы, необходимо принять в начале настройки системы и впоследствии уже не изменять, иначе калькуляция аффилиатов будет происходить некорректно.

Форма поиска

С помощью данной формы вы можете выполнить поиск планов аффилиатов в соответствии с указанными условиями.

Поле Описание
Сайт Поиск планов по сайту (или по всем сайтам), на котором они работают.

Данное поле отображается, даже если фильтр свернут.
Активность Поиск плана по признаку активности:
  • да - в поиске будут участвовать только активные планы;
  • нет - в поиске будут участвовать только неактивные планы;
  • все - в поиске будут участвовать все планы аффилиатов.

Чтобы отобрать планы комиссий по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех планов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить план | Переход к форме создания нового плана комиссий аффилиатов.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список планов

Поле | Описание
Колонка флажков | Поле предназначено для выбора планов, к которым предполагается применить какое-либо правило или действие.
Действия Действия, доступные для выполнения над планами комиссий:
  • Изменить - редактирование плана комиссий аффилиатов;
  • Удалить - удаление счета.
ID | Идентификатор плана в системе.
Сайт | Сайт, на котором работает план.
Активность | Признак активности плана.
Название | Название плана.
Комиссия аффилиата | Величина комиссии аффилиата.
При продаже не менее | Величина продаж, при которой применяется план.


Создание и редактирование плана

Закладки

Данная форма служит для создания нового и настройки параметров уже существующего плана комиссий аффилиатов.

Контекстная панель

Кнопка | Описание
Список планов | Переход на страницу со списком планов комиссий аффилиатов.
Добавить план | Переход к форме создания нового плана комиссий. Кнопка отображается при редактировании существующего плана.
Удалить план | Удаление редактируемого плана.

План

Поле | Описание
ID | Идентификатор плана в системе. Поле отображается при редактировании существующего плана.
Дата последнего изменения | Дата и время последнего изменения параметров плана. Поле отображается при редактировании существующего плана.
*Сайт | Сайт, на котором будет работать план. Заказы указанного сайта будут приниматься во внимание данного плана.
*Название плана | Укажите название плана.
Описание плана | Произвольное описание плана.
Активность | Признак активности плана. На сайте могут использоваться только активные планы.
Комиссия аффилиата | Величина комиссии аффилиата (в процентах или в одной из валют сайта).
План действует при продаже не менее | Количество товаров, которое необходимо продать, чтобы использовался данный план. Данное поле отображается, если в настройках модуля установлено, что планы делятся по количеству продаж.
План действует при продаже на сумму не менее | Сумма продаж (в базовой валюте сайта), которую необходимо набрать, чтобы использовался данный план. Данное поле отображается, если в настройках модуля установлено, что планы делятся по сумме продаж.

* - поля, обязательные для заполнения.

Группы товаров

Поле | Описание
*Группа | Указывается группа товаров, для которой будут использоваться особые комиссии.
*Комиссия аффилиата | Величина комиссии аффилиата (в процентах или в одной из валют сайта) за продажу товаров из указанной в предыдущем поле группы.
Ссылка Удалить | Служит для удаления записи таблицы.
Кнопка Добавить | Используется для добавление новой строки таблицы.

* - поля, обязательные для заполнения.

Смотрите также

  • Планы аффилиатов (учебный курс "Администратор. Бизнес")


Пирамиды

На странице Пирамиды (Магазин > Аффилиаты > Пирамида) представлен список созданных пирамид. Пирамида нужна для того, чтобы организовать многоуровневое аффилиатство. То есть, чтобы аффилиат мог зарабатывать не только на своих продажах, но и на продажах других аффилиатов, которых он привел на сайт.

Важно! На каждом сайте может быть настроена только одна пирамида.

Форма поиска

С помощью данной формы вы можете выполнить поиск пирамид в соответствии с указанными условиями.

Поле | Описание
Сайт | Поиск пирамиды по принадлежности к сайту.

Чтобы отобрать пирамиду по заданному критерию поиска, нажмите кнопку Найти. Для отображения всех пирамид нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить пирамиду | Переход к форме создания новой пирамиды.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список пирамид

Поле | Описание
Колонка флажков | Поле предназначено для выбора пирамид, к которым предполагается применить какое-либо правило или действие.
Действия Действия, доступные для выполнения над пирамидами:
  • Изменить - редактирование пирамиды;
  • Удалить - удаление пирамиды.
ID | Идентификатор пирамиды в системе.
Сайт | Сайт, на котором реализована пирамида.
Комиссия аффилиата <N> уровня (%) | Процент дохода от привлеченного аффилиата N уровня (N - номер уровня: 1, 2, 3, 4 или 5).


Создание и редактирование пирамиды

Данная форма служит для создания новой и настройки параметров уже существующей пирамиды.

Важно! На сайте может быть настроена только одна пирамида.

Если пирамида не заполнена или тарифы установлены в ноль, то аффилиаты будут получать прибыль только со своих продаж, т.е. многоуровневое аффилиатство использоваться не будет.

Контекстная панель

Кнопка | Описание
Список пирамид | Переход на страницу со списком пирамид.
Добавить пирамиду | Переход к форме создания новой пирамиды. Кнопка отображается при редактировании существующей пирамиды.
Удалить пирамиду | Удаление редактируемой пирамиды.

Поля формы

Поле | Описание
ID | Идентификатор пирамиды в системе. Отображается только при редактировании существующей пирамиды.
*Сайт | Сайт, на котором будет реализована пирамида.
Комиссия аффилиата N уровня | Процент от дохода привлеченного аффилиата N уровня (N - номер уровня: 1, 2, 3, 4 или 5).

* - поля, обязательные для заполнения.

Смотрите также

  • Пирамида (учебный курс "Администратор. Бизнес")


Калькуляция аффилиатов

Форма на странице Калькуляция аффилиатов (Магазин > Аффилиаты > Калькуляция) служит для выполнения калькуляции аффилиатов.

Контекстная панель

Кнопка | Описание
Список аффилиатов | Переход на страницу со списком аффилиатов, зарегистрированных в системе.

Поля формы

Поле | Описание
Аффилиаты | Укажите аффилиатов, для которых необходимо провести калькуляцию. Если аффилиаты не выбраны, то калькуляция производится по всем аффилиатам, имеющим заказы за указанный период.
Период калькуляции | Период проведения калькуляции. Если не указана дата начала периода калькуляции, то калькуляция начнется с момента окончания предыдущей калькуляции. Если не указана дата окончания периода калькуляции, то калькуляция будет произведена по текущий момент.
Период для определения плана | При определении плана аффилиата будут рассматриваться только те заказы, которые были отгружены в указанный в этом поле период. Если не указана дата начала периода, то за начало периода принимается дата окончания предыдущей калькуляции. Если не указана дата окончания периода, то за конец периода принимается текущий момент.
Начисленную сумму Действия с начисленной суммой аффилиату:
  • начислить и выплатить переводом на внутренний счет пользователя;
  • начислить и пометить как выплаченую;
  • только начислить.
Пошаговая калькуляция с длиной шага | Если длина шага пошаговой калькуляции больше нуля, то калькуляция будет вестись шагами длиной в указаное число секунд с перегрузкой страницы. Если ноль, то калькуляция будет выполнена за один шаг.

* - поля, обязательные для заполнения.

Смотрите также

  • Калькуляция аффилиата (учебный курс "Администратор. Бизнес")


Транзакции аффилиатов

На странице Транзакции аффилиатов (Магазин > Аффилиаты > Транзакции) представлен список всех транзакций, выполняемых по счетам аффилиатов.

Форма поиска

С помощью данной формы вы можете выполнить поиск транзакций в соответствии с указанными условиями.

Поле | Описание
Аффилиат | Поиск транзакций по аффилиату, к которому они относятся. Указание аффилиата можно осуществить с помощью кнопки [...]. Поле присутствует, даже если фильтр свернут.
Пользователь | Поиск транзакций аффилиатов по логину, имени или фамилии пользователя-аффилиата.
Дата транзакции | Период, в течение которого были выполнены транзакции.
Валюта | Укажите валюту, в которой выполнены требуемые транзакции.

Чтобы отобрать транзакции по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех транзакций нажмите кнопку Отменить.

Список транзакций

Список транзакций

Поле | Описание
ID | Идентификатор транзакции в системе.
Дата транзакции | Дата и время выполнения транзакции.
Аффилиат | Указывается идентификатор, имя, фамилия и логин пользователя-аффилиата, а также сайт, на котором он работает.
Сумма | Сумма операции.
Тип | Тип операции по счету.
Описание | Идентификатор, логин, имя и фамилия пользователя, выполнившего транзакцию.


Отчеты

Раздел Отчеты предназначен для получения статистических данных работы магазина. Данные могут быть представлены в числовом и графическом виде.

Если в системе установлен модуль конструктора отчетов, то в разделе Отчеты (Магазин > Отчеты) будет представлен пункт Список отчетов с типовыми отчетами:

  • Брошенные корзины.
  • Лучшие клиенты.
  • Новые клиенты.
  • Продажи.
  • Самые ожидаемые товары.
  • Самые просматриваемые товары.
  • Запасы товаров.
  • Прайс-лист.
  • Доходность по товарам.
  • Доходность по клиентам.
  • Запасы товаров (мобильный).
  • Прайс-лист (мобильный).
  • Запасы товаров (по складам).

Смотрите также:

  • Отчеты (учебный курс "Администратор. Бизнес")


Список отчетов

На странице (Магазин > Отчеты > Список отчетов) представлен список типовых и созданных вами отчетов. При первом обращении к этой странице будет отображено сообщение, что в системе нет ни одного сконструированного отчета, и предложено создать типовые отчеты с помощью кнопки Создать типовые отчеты.

Контекстная панель

Кнопка | Описание
Добавить отчет | Переход к созданию нового отчета.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список отчетов

Поле | Описание
Колонка флажков | Поле предназначено для выбора отчетов, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия:
  • Сформировать отчет - переход к просмотру отчета;
  • Копировать отчет - создание копии отчета (копию можно отредактировать);
  • Удалить отчет - удаление отчета.
Название отчета | Название отчета.
Дата создания | Дата создания отчета.


Конструктор отчетов

На данной странице выполняется создание нового или редактирование настроек уже существующего отчета.

Контекстная панель

Кнопка | Описание
Вернуться к списку отчетов | Переход на страницу со списком отчетов.

Форма конструктора отчета

При создании нового отчета сначала выбирается основа для построения отчета: Заказ, Покупатель, Корзина или Товар. По нажатии кнопки Продолжить отобразится форма конструктора отчета с базовым набором полей.

Поле | Описание
Название отчета | Произвольное название отчета.
Описание отчета | Описание предназначения отчета.
Отчет по магазину | Выбирается магазин, для которого составляется отчет.
Отчетный период | Выбирается период, за который будет составляться отчет.
Колонки
Данная секция позволяет настроить колонки отображаемой в отчете таблицы. Изменить порядок отображения колонок позволяют кнопки со стрелками, расположенные рядом с названием каждой колонки.
Вычислить колонку | Опция позволяет отображать в отчете вычисленную величину, например, сумму или количество уникальных значений в колонке. Вычисляемая величина зависит от конкретного типа данных.
Группировать результат по колонке | Опция позволяет группировать результаты отчета по данной колонке.
Показывать итоги | Опция служит для отображения итогов по колонке.
кнопка Добавить | Позволяет добавить в отчет новую колонку. За раз можно добавить сразу несколько колонок, отметив их в форме.
Использовать выбор колонок с разными типами цен в отчёте | Опция доступна только для сущности Товар и позволяет динамически формировать набор колонок с разными типами цен прямо при просмотре отчета с помощью опции фильтра Выводить типы цен.
Сортировать по колонке | Указывается колонка и направление для сортировки данных в таблице.
Фильтр
Данная секция позволяет настроить параметры фильтрации отчета.
Ограничить результаты по | Указывается способ ограничения результатов, выводимых в отчете: по всем или по любому условию.
Кнопки + и - | Позволяют добавить еще одно условие для фильтра или удалить текущее.
Кнопка И / Или | Позволяет построить дерево условий.
Выберите поле | Ссылка служит для добавления условия.
Изменять фильтр в отчете | Опция позволяет вывести отмеченные условия на панель фильтра и изменять их уже непосредственно при просмотре отчета.
Максимальное количество элементов | Опция служит для ограничения максимального количества элементов, выводимых в отчете.
Выводить отрицательные значения красным | При отмеченнной опции отрицательные значения в таблице будут отмечены красным цветом.
Использовать в мобильной версии | При отмеченнной опции отчет будет доступен для просмотра в мобильном приложении.
Выводить диаграмму | Опция позволяет включить и настроить диаграммы и графики, которые будут выводиться прямо под отчетом.

Смотрите также

  • Конструктор отчетов (учебный курс "Администратор. Бизнес")


Просмотр отчета

На странице Просмотр отчета "название_отчета" (Магазин > Отчеты > Список отчетов > название_отчета) выполняется просмотр данных отчета.

Контекстная панель

Кнопка | Описание
Вернуться к списку отчетов | Переход на страницу со списком отчетов.
Экспорт Excel | Экспорт данных из отображаемой таблицы в MS Excel.
Редактировать отчет | Переход к форме редактирования настроек отчета.

Фильтр

Кнопка | Описание
Отчет по магазину | Указывается магазин, по которому должен просматриваться отчет.
Отчет за период | Выбирается период, за который составляется отчет.
Валюта отчета | Указывается валюта, в которой будут отображены данные отчета.
[название_поля] | В соответствии с настройками отчета задаются условия для отображения данных.

Чтобы отобразить отчет по заданным критериям, нажмите кнопку Найти. Для сброса значений параметров нажмите кнопку Отменить.

Таблица с данными

Поле | Описание
[название_колонки] | Отображаются данные в соответствии с названием колонки и настройками отчета.

Под таблицей с данными может быть расположена итоговая информация по всему отчету, которая подсчитывается только для численных данных.


Отчеты по заказам

На странице Заказы (Магазин > Отчеты > Заказы) представлен отчет по заказам, который может быть сформирован по дням/неделям/месяцам/годам.

Фильтр

Поле | Описание
Группировать по | Указывается способ группировки заказов для отображения по ним статистики: по дням, по неделям, по месяцам или по годам. Данное поле отображается, даже если фильтр свернут.
Дата заказа | Задается период для отображения отчета по заказам.
Сайт | Выбираются сайты, в магазинах которых были сделаны заказы.

Чтобы отобрать заказы по заданным критериям поиска, нажмите кнопку Найти. Для сброса значений параметров нажмите кнопку Отменить.

Контекстная панель

Поле | Описание
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Отчет по заказам

Поле | Описание
Дата | Дата создания заказов.
Общее количество | Общее количество сделанных заказов.
Кол-во оплаченных | Количество оплаченных заказов.
Оплаченных (%) | Процентная величина оплаченных заказов из оформленных за выбранный период.
Кол-во с разрешенной доставкой | Количество заказов, в которых доставка разрешена.
Доставка разрешена (%) | Процентная величина заказов, которые можно отгружать.
Кол-во отмененных | Количество отмененных заказов.
Отмененные (%) | Процентное количество отмененных заказов из общего числа, оформленных за день/неделю/месяц/год.
<название_статуса_заказа> | Количество заказов, находящихся в статусе <название_статуса_заказа>.
Стоимость (Рубль) | Суммарная стоимость заказанных товаров.
Стоимость доставки (Рубль) | Суммарная стоимость доставки заказанных товаров.
Стоимость налогов (Рубль) | Суммарная величина налогов, взимаемых в заказах.
Стоимость оплаченных (Рубль) | Суммарная стоимость оплаченных заказов.
Стоимость с разрешенной доставкой (Рубль) | Суммарная стоимость заказов с разрешенной доставкой.
Стоимость отмененных (Рубль) | Суммарная стоимость отмененных заказов.
<название_статуса_заказа> | Суммарная стоимость заказов, находящихся в статусе <название_статуса_заказа>.


Отчеты по товарам

На странице Товары (Магазин > Отчеты > Товары) представлен отчет по приобретаемым товарам.

Фильтр

Поле | Описание
Дата заказа | Задается период для отображения отчета по заказанным товарам. Поле присутствует, даже если фильтр свернут.
Сайт | Выбираются сайты, в магазинах которых были сделаны заказы.

Чтобы отобрать товары по заданным критериям поиска, нажмите кнопку Найти. Для сброса значений параметров нажмите кнопку Отменить.

Контекстная панель

Поле | Описание
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Отчет по товарам

Поле | Описание
Идентификатор | Идентификатор товара.
Название товара | Полное название товара.
Общее количество | Отображается сумма по количеству корзин, в которых находится данный товар, и оформленных по этому товару заказов.
Количество корзин | Количество корзин, в которых находится данный товар.
Общее количество в заказах | Общее количество данного товара в заказах.
Количество заказов | Количество заказов, в которых имеется данный товар.
Количество оплаченных заказов | Количество оплаченных заказов, в которых имеется данный товар.
Оплаченных заказов (%) | Процентная величина оплаченных заказов, в которых имеется данный товар.
Кол-во заказов с разрешенной доставкой | Количество заказов, доставка которых разрешена.
Доставка заказов разрешена (%) | Процентная величина заказов данного товара, доставка которых разрешена.
Отложено | Количество отложенных заказов.
Общее количество в корзинах | Общее количество товаров в корзинах.
Общая стоимость (Рубль) | Общая стоимость данного товара во всех заказах.
Стоимость заказов (Рубль) | Суммарная стоимость заказов.
Стоимость оплаченных заказов (Рубль) | Суммарная стоимость оплаченных заказов.
Стоимость заказов с разрешенной доставкой(Рубль) | Суммарная стоимость заказов с разрешенной доставкой.
Общая стоимость товара в заказах (Рубль) | Общая стоимость товара в заказах.
Общая стоимость товара в оплаченных заказах (Рубль) | Общая стоимость товара в оплаченных заказах.
Общая стоимость товара в заказах с разрешенной доставкой (Рубль) | Общая стоимость товара в заказах с разрешенной доставкой.
Минимальная стоимость товара (Рубль) | Минимальная стоимость товара.
Максимальная стоимость товара (Рубль) | Максимальная стоимость товара.


Графики по количеству

Система "1С-Битрикс: Управление сайтом" позволяет наглядно оценить статистику по количеству заказов с помощью графиков: Магазин > Отчеты > Графики > По количеству.

Фильтр

Поле | Описание
Дата заказа | Задается период времени, по которому будет использоваться для построения графика информация о заказах. Данное поле отображается, даже если фильтр свернут.
Сайт | Выбираются сайты, в магазинах которых были сделаны заказы.
Показывать | Укажите какая информация о заказах должна быть отображена на графике.
Группировать по | Выберите способ группировки заказов для построения по ним графика: по дням, по дням недели, по неделям, по месяцам или по годам.

Чтобы построить график на основе выбранных параметров, нажмите кнопку Построить. Для сброса значений параметров нажмите кнопку Отменить.

Пример графика

© «Битрикс», 2001-2008, «1C-Битрикс», 2008-2022 1С-Битрикс: Управление сайтом


Графики по деньгам

Система "1С-Битрикс: Управление сайтом" позволяет наглядно оценить статистику по стоимости заказов с помощью графиков: Магазин > Отчеты > Графики > По деньгам.

Фильтр

Поле | Описание
Дата заказа | Задается период времени, по которому будет использоваться для построения графика информация о заказах. Поле присутствует, даже если фильтр свернут.
Сайт | Выбираются сайты, в магазинах которых были сделаны заказы.
Показывать | Укажите какая информация о заказах должна быть отображена на графике.
Группировать по | Выберите способ группировки заказов для построения по ним графика: по дням, по неделям, по месяцам или по годам.

Чтобы построить график на основе выбранных параметров, нажмите кнопку Построить. Для сброса значений параметров нажмите кнопку Отменить.

Пример графика

© «Битрикс», 2001-2008, «1C-Битрикс», 2008-2022 1С-Битрикс: Управление сайтом


Настройки интернет-магазина

В разделе Магазин > Настройки выполняется настройка основных сущностей интернет-магазина.


Платежные системы

Страница Платежные системы (Магазин > Настройки > Платежные системы) служит для настройки платежных систем, с помощью которых клиенты магазина могут оплачивать свои заказы. Данная форма позволяет:

  • просматривать список существующих платежных систем;
  • осуществлять переход к созданию новой или редактированию существующей платежной системы;
  • удалять платежные системы.

Форма поиска

С помощью данной формы вы можете выполнить поиск платежных систем в соответствии с указанными условиями.

Поле | Описание
Активность | Определяет какие платежные системы будут участвовать в поиске: активные, неактивные или все (активные и неактивные).
Тип плательщика | Определяет, платежные системы с какими настроенными для них типами плательщиков, будут участвовать в поиске.

Чтобы отобрать платежные системы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех систем нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить платежную систему | Переход к форме создания новой платежной системы.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список платежных систем

Поле | Описание
Колонка флажков | Поле предназначено для выбора платежных систем, к которым предполагается применить какое-либо правило или действие.
Действия Действия над платежной системой:
  • Изменить - изменение параметров платежной системы;
  • Удалить - удаление платежной системы.
ID | Идентификатор платежной системы.
Название | Название платежной системы.
Акт. | Признак активности платежной системы.
Сорт. | Относительный "вес" платежной системы. Влияет на положение данной системы в общем списке платежных систем.

Смотрите также

  • Платежные системы (курс "Администратор. Бизнес")


Создание и редактирование платежной системы

В форме создания и редактирования платежной системы вы можете задать или изменить значения параметров системы.

Закладка Платежная система

Данная форма служит для управления основными параметрами платежной системы.

Поле | Описание
ID | Идентификатор платежной системы. Поле отображается при редактировании существующей платежной системы.
*Обработчик | Выбирается файл-обработчик платежей, осуществляемых с помощью данной платежной системы.
*Заголовок | Заголовок платежной системы. Поле устарело, оставлено для совместимости.
*Название | Название платежной системы для отображения в административном разделе сайта и в публичной части.
Активность | Признак активности платежной системы.
Сортировка | Относительный "вес" платежной системы. Влияет на положение данной системы в общем списке платежных систем.
Описание | Текст длиной до 250 символов, информирующий клиента об особых условиях работы платежной системы.
Логотип платёжной системы | По кнопке Добавить файл выполняется добавление файла с логотипом платежной системы. Чтобы удалить логотип, следует отметить опцию Удалить файл и сохранить настройки платежной системы.
Открывать в новом окне | Флаг в данном поле означает, что если по результатам работы обработчика платежей пользователю должен быть представлен какой-либо результат (например, платежный документ), то он будет выведен в отдельном окне веб-браузера.
Тип оплаты | Параметр используется при интеграции с 1С и расчет по текущей платежной системе (наличный расчет, безналичный расчет, эквайринговая операция).
Разрешить автопересчет оплаты | При отмеченной опции разрешено изменять данные по оплате заказа. Например, при изменении службы доставки изменять сумму частичной оплаты.
Разрешить печать чеков | При отмеченной опции разрешено печатать чеки [image] при получении оплаты через данную платежную систему. В противном случае чек создаваться не будет.
Кодировка | Параметр необходим для перекодировки формы в кодировку платежной системы.
Код | Символьный код, задаваемый вручную. Используется разработчиками.
Внешний код | Внешний код платежной системы. Код генерируется автоматически.
Настройка обработчика ПС
Если выбранный вами обработчик платежной системы требует задания значений дополнительных свойств, то в секции будет выведен список этих свойств. Свойства, которые подходят для всех типов плательщиков, задаются на закладке По умолчанию. Специфичные свойства указываются на соответствующей типу плательщиков закладке. Примечание: чтобы платежная система была доступна только определенному типу плательщиков, следует задать ограничение по типу плательщиков на закладке Ограничения. Для удобства выполнения настроек заполненные свойства скрываются, но вы можете отобразить их, кликнув по ссылке [dw]Показать все.[/dw][di] [image] [/di]

* - поля, обязательные для заполнения.

Закладка Ограничения

На закладке задаются ограничения по использованию текущей платежной системы. Закладка доступна в форме редактирования существующей платежной системы.

Поле | Описание
кнопка Добавить ограничение Служит для добавления ограничения путем заполнения данных во всплывающей форме. Ограничения могут быть:
  • по типу плательщика;
  • по цене;
  • % от стоимости заказа (актуально для платёжной системы "Внутренний счёт" - указывается % от стоимости заказа, который можно оплатить с помощью средств внутреннего [ds]счёта покупателя[/ds][di] Счет покупателя - пополняемый "кошелек" пользователя в рамках магазина, с которого он проводит расчеты с магазином по мере необходимости.

    Подробнее [image]...[/di]);
  • по службе доставки;
  • по сайтам;
  • по категории товара;
  • по конкретным товарам.
кнопка Настроить | Позволяет перейти к диалогу настройки внешнего вида таблицы со списком ограничений.
таблица со списком ограничений
Поле | Описание
Действия Действия над ограничением:
  • Редактировать - редактирование параметров ограничения во всплывающем окне;
  • Удалить - удаление ограничения.
ID | Идентификатор ограничения.
Сортировка | Относительный "вес" ограничения.
Тип ограничения | Тип ограничения.
Параметры | Параметры ограничения.

Файлы-обработчики

Файлы работы с платежной системой обрабатываются следующим образом:

  • Файл-обработчик вызывается непосредственно после оформления заказа, а также при выборе клиентом функции повторения платежа в персональном разделе. Этот файл может содержать скрипт, отображающий на экране необходимый платежный документ, или форму для отправки данных электронной платежной системе. Подробности смотрите в разделе Обработка платежных систем.
  • Обработчик результатов вызывается сайтом для запроса параметров оплаты заказа у электронной платежной системы. Если платежная система не возвращает параметры заказа (успешна ли оплата, сколько реально оплачено и т.п.), то задавать обработчик результатов не нужно.

Смотрите также

  • Платежные системы (курс "Администратор. Бизнес")


Настройка возвратов

Страница Настройка возвратов (Магазин > Настройки > Платежные системы > Настройка возвратов) содержит список идентификаторов вашего магазина для различных платежных сервисов. Запись на странице появляется в том случае, если обработчик платежной системы поддерживает настройку возврата, и для него выполнены настройки подключения.

Список идентификаторов магазина

Поле | Описание
Идентификатор магазина в системе | Идентификаторов вашего магазина для платежного сервиса. Клик по идентификатору открывает страницу с подробными инструкциями для настройки возвратов.
Название обработчика | Название обработчика платежной системы.
Подключен | Признак подключения механизма возвратов.

Смотрите также:

  • Настройка возвратов (курс "Администратор. Бизнес")


Обработчики платежных систем

Структура папки обработчика

Интеграция магазина с платежными системами осуществляется через обработчики платежных систем. Системные обработчики хранятся в папке /bitrix/modules/sale/handlers/paysystem/. Папка обработчика может содержать следующие подпапки и файлы:

  • файл обработчика handler.php. Этот файл всегда должен присутствовать в папке обработчика.
    Примечание: название класса обработчика должно совпадать с названием папки обработчика и иметь окончание Handler. Например, название папки - myname, а название класса - MyNameHandler.
  • файл .decription.php - файл с описанием настроек обработчика. Этот файл всегда должен присутствовать в папке обработчика.
  • подпапку template, в которой расположен шаблон обработчика платежной системы (файл template.php). Эта подпапка может отсутствовать, если у обработчика нет шаблонов вывода.
  • подпапку lang, в которой расположены файлы языковых сообщений обработчика. Эта подпапка также может отсутствовать.

Кастомизация

Кастомизация шаблона обработчика

Информация по вопросам кастомизации шаблона представлена в уроке Кастомизация шаблона платежной системы [image] курса Разработчик Bitrix Framework.

Кастомизация обработчика

Общая методика кастомизации обработчика такова:

  • Скопируйте необходимую вам папку обработчика из /bitrix/modules/sale/handlers/paysystem/ в раздел по умолчанию /bitrix/php_interface/include/sale_payment/.
    Примечание: путь к пользовательским обработчикам платежных систем устанавливается в настройках модуля Интернет-магазин. По умолчанию он равен /bitrix/php_interface/include/sale_payment.
  • Обязательно измените название скопированной папки обработчика в разделе /bitrix/php_interface/include/sale_payment/.
  • В разделе /bitrix/php_interface/include/sale_payment/<папка_обработчика> измените файлы обработчика таким образом, чтобы они удовлетворяли вашим нуждам и соответствовали интерфейсу.
  • В форме редактирования платежной системы выберите ваш обработчик и выполните необходимые настройки.

Дополнительные сведения по кастомизации обработчика смотрите в курсе Разработчик Bitrix Framework [image].

Получение результата от платежной системы

Получение результата от платежной системы

Ответы платежных систем, обработчики которых написаны на АПИ ядра D7, обрабатываются на странице /bitrix/tools/sale_ps_result.php.

Если у вас обработчик написан на АПИ старого ядра, то вам обязательно нужно создать отдельную страницу, на ней разместить и настроить компонент Подключение обработчика результата платежной системы [image].


Компании

Форма Компании (Магазин > Настройки > Компании) служит для управления списком компаний, через которые может приниматься оплата заказа и/или осуществляться отгрузка товаров.

Форма поиска

С помощью данной формы вы можете выполнить отбор компаний в соответствии с указанными условиями.

Поле | Описание
Название | Поиск компании по названию. Поле отображается всегда, даже если фильтр свернут.
Активность | Поле определяет, какие компании будут участвовать в поиске: активные, неактивные или же все.
Местоположения | Отбор компаний по местоположению.

Чтобы отобрать компании по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех компаний нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить компанию | Переход к форме добавления новой компании.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список компаний

Поле | Описание
Колонка флажков | Поле предназначено для выбора компаний, к которым предполагается применить какое-либо правило или действие.
Действия Действия над компанией:
  • Изменить - редактирование компании;
  • Удалить - удаление компании.
ID | Идентификатор компании в системе.
Активность | Признак активности компании. Активная компания может использоваться в работе интернет-магазина.
Название | Название компании.
Расположение | Местоположение компании.
Код | Символьный код компании.

Смотрите также

  • Компании (учебные курс "Администратор. Бизнес")


Создание и редактирование компании

Закладки

Основная

Поле | Описание
ID | Идентификатор компании. Поле отображается только при редактировании существующей компании.
Дата создания | Дата и время создания компании. Поле отображается только при редактировании существующей компании.
Дата изменения | Дата и время изменения компании. Поле отображается при редактировании существующей компании, в которой уже проводились изменения после создания.
Создан пользователем | Ф.И.О. пользователя, добавившего компанию в систему. Поле отображается только при редактировании существующей компании.
Изменен пользователем | Ф.И.О. пользователя, изменившего параметры компании. Поле отображается только при редактировании существующей компании.
Активность | Признак активности компании. Только активная компания может использоваться в работе интернет-магазина.
*Название | Название компании.
Местоположение | Местоположение компании.
Адрес | Адрес компании.
Группы относящиеся к компании | Задаётся привязка групп пользователей к компании. То есть те пользователи, которые будут видеть заказы/оплаты/отгрузки данной компании.
Группы ответственного | У каждого заказа/оплаты/отгрузки есть ответственный человек. При создании заказа, автоматически подбирается соответствующая компания. В этом поле указывается группа в рамках которой будет назначен конкретный ответственный за заказ/оплату/отгрузку сотрудник.
Сортировка | Относительный "вес" компании. Служит для определения положения компании в общем списке.
Код | Символьный код компании.

* - поля, обязательные для заполнения.

Пользовательские поля

На данной закладке отображаются созданные в системе дополнительные пользовательские поля для компаний. К созданию нового пользовательского поля можно перейти по ссылке Добавить пользовательское поле.

Правила

На закладке задаются правила для автоназначения компании. Закладка доступна в форме редактирования существующей компании.

Поле | Описание
кнопка Добавить правило | Служит для добавления правила путем заполнения данных во всплывающей форме. Правила могут быть: по валюте, по сайтам, по типу привязки, по местоположению, по платежным системам, по службам доставки, по типу плательщика и по цене.
кнопка Настроить | Позволяет перейти к диалогу настройки внешнего вида таблицы со списком правил.
таблица со списком правил
Поле | Описание
Действия Действия над правилом:
  • Редактировать - редактирование параметров правила во всплывающем окне;
  • Удалить - удаление правила.
ID | Идентификатор правила.
Сортировка | Относительный "вес" правила.
Правило | Вид правила.
Параметры | Параметры правила.

Смотрите также

  • Компании (учебный курс "Администратор. Бизнес")


Типы плательщиков

Форма Тип плательщика (Магазин > Настройки > Типы плательщиков) служит для управления списком типов плательщика, которые могут осуществлять заказы на сайте. Для каждого типа плательщика создаётся собственный список свойств, которые плательщик должен заполнить при оформлении заказа, а также указываются обработчики платежных систем, с помощью которых плательщик может оплатить заказ.

Форма поиска

С помощью данной формы вы можете выполнить поиск типов плательщика в соответствии с указанными условиями.

Поле | Описание
Сайт | Позволяет отобрать типы плательщика, используемые на указанном сайте.
Активность | Позволяет осуществить поиск по признаку активности типа плательщика.

Чтобы отобрать типы плательщика по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех типов плательщика нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить тип | Переход к форме создания нового типа плательщика.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список типов плательщика

Поле | Описание
Колонка флажков | Поле предназначено для выбора типов плательщиков, к которым предполагается применить какое-либо правило или действие.
Действия Действия над типом плательщика:
  • Изменить - редактирование выбранного типа плательщика;
  • Удалить - удаление выбранного типа плательщика.
ID | Идентификатор типа плательщика.
Название | Название типа плательщика, как оно будет показано клиентам магазина при оформлении заказа.
Активность | Активность данного типа плательщика.
Сайт | Сайт, на котором действует этот тип плательщика. В зависимости от сайта клиентам магазина предоставляется на выбор разный набор типов плательщиков.
Сорт. | Относительный "вес" данного типа плательщика. Используется для определения порядка показа типов плательщика в списке.
Свойства | Ссылка для перехода к просмотру свойств заказа, заданных для данного типа плательщика.

Смотрите также

  • Типы плательщиков (учебный курс "Администратор. Бизнес")


Создание и редактирование типа плательщика

Данная форма служит для создания нового или настройки параметров уже существующего типа плательщика.

Контекстная панель

Кнопка | Описание
Список типов плательщиков | Переход на страницу со списком типов плательщика.
Создать новый тип | Переход к форме создания нового типа плательщика. Кнопка отображается при редактировании существующего типа плательщика.
Удалить тип | Удаление типа плательщика. Кнопка отображается при редактировании существующего типа плательщика.

Форма редактирования

Поле | Описание
ID | Идентификатор типа плательщика.
Активность | Признак активности. Активный тип доступен для работы в рамках интернет-магазина.
*Сайт | Сайт, на котором используется данный тип плательщика. Один тип может применяться к разным сайтам. Через указание сайта в этом поле регулируется использование в рамках сайта не только Типов плательщиков, но и платежных систем и свойств заказа.
*Название | Название типа плательщика.
Индекс сортировки | Относительный "вес", влияющий на положение типа плательщика в общем списке и в публичной части качестве типа по умолчанию. Штатно по умолчанию указывается тип Физическое лицо. Если нужно по умолчанию выводить другой тип, поставьте ему более низкое значение в этом поле.

* - поля, обязательные для заполнения.

Смотрите также

  • Типы плательщиков (учебный курс "Администратор. Бизнес")


Статусы

Форма Статусы заказа (Магазин > Настройки > Статусы) служит для управления информационными статусами заказов и статусами отгрузок заказов. Статусы отражают этапы, через которые проходит заказ во время обработки. Вы можете создавать любое количество статусов заказа в зависимости от организации процесса обработки заказа. Например, Отложен, В обработке, Отгружен, В пути.

Контекстная панель

Кнопка | Описание
Новый статус | Переход к форме создания нового статуса.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список статусов заказа

Поле | Описание
Колонка флажков | Поле предназначено для выбора статусов, к которым предполагается применить какое-либо правило или действие.
Действия Действия над статусом:
  • Изменить параметры статуса - редактирование статуса;
  • Удалить статус - удаление статуса.
Код | Уникальный символьный код статуса.
Сорт. | Относительный "вес" статуса. Используется для определения положения данного статуса в общем списке.
Название | Название и описание статуса. Эти данные будут отображаться клиентам в публичном разделе сайта.
Тип статуса | Тип статуса заказа: Заказ или Доставка.
Цвет статуса | Цвет маркировки статуса, указанный при создании.
Уведомление | Если для статуса заказа настроен почтовый шаблон для отправки почтовых уведомлений покупателю, то отображается ведущая на этот шаблон ссылка Да. В противном случае отображается значение Нет.

Обратите внимание! Существуют особые статусы заказов и отгрузок заказов, удаление которых невозможно:
  • N - начальный статус (название по умолчанию - Принят), в который заказ устанавливается при создании;
  • F - финальный статус (название по умолчанию - Выполнен), в котором заказ считается выполненным (т.е. оплаченным и доставленным).
  • DN - начальный статус документа отгрузки товаров (название по умолчанию - Ожидает обработки);
  • DF - финальный статус документа отгрузки товаров (название по умолчанию - Отгружен).

Смотрите также

  • Статусы заказов (учебный курс "Администратор. Бизнес")


Создание и редактирование информационного статуса заказа

Данная форма служит для создания новых и изменения параметров уже существующих информационных статусов заказов и статусов отгрузок заказов.

Контекстная панель

Кнопка | Описание
Список статусов | Переход на страницу со списком статусов заказа.
Добавить новый статус | Переход к форме создания нового статуса заказа. Кнопка отображается при редактировании существующего статуса.
Удалить статус | Удаление редактируемого статуса заказа. Кнопка отображается при редактировании существующего статуса.

Поля формы

Поле | Описание
*Код | Уникальный код статуса. Задается в виде 1-2 букв латинского алфавита.
Тип статуса | Выбирается тип статуса: Заказ (статус непосредственно документа заказа) или Доставка (статус для документа отгрузки).
Сортировка | Относительный "вес" статуса. Используется для определения положения данного статуса в общем списке статусов.
Отправлять почтовое уведомление пользователю при переходе заказа в этот статус | При отмеченной опции будет отправляться письмо покупателю о переводе заказа в данный статус. Для быстрого перехода к созданию/редактированию шаблона письма служит ссылка Почтовый шаблон статуса.
Цвет статуса | Цвет маркировки статуса в списке. Можно либо ввести RGB код цвета вручную либо использовать иконку для выбора (если цвет не указан - цветовая маркировка использована не будет).
*Название | Укажите название статуса для всех языков, используемых в системе.
Описание | Задайте описание статуса для всех языков, используемых в системе.
Права на доступ
Для перечисленных групп пользователей настраиваются права на доступ к заказам в данном статусе. По ссылке Группы пользователей осуществляется переход к настройке для необходимых групп прав доступа к модулю Интернет-магазин. Ссылка Уровни доступа служит для перехода к списку уровней доступа для статусов интернет-магазина, где вы можете изменить существующие или создать новые уровни.

* - поля, обязательные для заполнения.

Смотрите также

  • Статусы заказов (учебный курс "Администратор. Бизнес")


Соответствие значений бизнес-смыслу

Бизнес-смыслы - это механизм, через который осуществляется единая настройка сущностей магазина, таких как платежные системы, профили обмена с 1С и т.д.

Страница Соответствие значений бизнес-смыслу (Магазин > Настройки > Бизнес смыслы) служит для заполнения повторяющихся данных в сущностях магазина. Данная форма позволяет настроить как общие бизнес-смыслы, так и отдельно данные по профилю обмена с 1С или данные по выбранной платежной системе.

Форма фильтра

С помощью данной формы вы можете выполнить отбор полей в соответствии с указанными условиями.

Поле | Описание
Смыслы | Определяет для каких бизнес-смыслов должны быть отображены поля.

Чтобы отобрать поля по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех полей нажмите кнопку Отменить.

Форма настройки соответствий

Форма состоит из нескольких закладок:

  • закладки По умолчанию - на ней настраиваются соответствия, используемые по умолчанию для всех сущностей магазина для всех типов плательщиков.
  • закладок, соответствующих используемым в сущностях магазина типам плательщиков - в них выполняются индивидуальные настройки в соответствии с типом плательщика. Поля с настройками такие же, как и на закладке По умолчанию. Причем, если для поля отмечена опция По умолчанию, то его значение берется из соответствующего поля с первой закладки.

Перечень отображаемых полей на закладках зависит от имеющихся и настроенных у вас сущностей магазина (платежных систем, профилей 1С). Настройка каждого поля интуитивно понятна из названия и выполняется в соответствии с вашими потребностями.

Так, поля в секции Стили позволяют подставлять свой фон и задать отступы в счетах. Поля секции Колонки позволяют указать, отображать ли колонку в счете и задать порядок ее сортировки и название. Поля секция Основная определяют ключевые параметры самого счета. Все настройки перечисленных трех секций по умолчанию наследуются для всех платежных систем, которые имеют тип оплаты счет.

Секции с названиями вида Настройки подключения название_платежной_системы содержат настройки обработчиков соответствующих платежных систем. В секции Оплаты задаются соответствия колонок оплат. Настройка полей для данных по покупателю и продавцу выполняется в секциях Покупатель и Продавец соответственно. Дополнительные настройки для платежных систем выполняются в секции Остальные свойства платежных систем.

При настройке бизнес-смыслов для 1С на закладках формы отображаются настройки соответствий профилей заказа, которые располагаются на странице Интеграция с 1С.

В результате все указанные вами соответствия будут отображаться в формах редактирования сущностей магазина.


Настройка типов плательщиков для бизнес-смыслов

На странице Настройка типов плательщиков для бизнес-смыслов (Магазин > Настройки > Бизнес смыслы > Типы плательщиков) определяется какие типы плательщиков используются для сущностей магазина и указывается их соответствие физическому или юридическому лицу.

Форма настроек

Поле | Описание
Название_типа_плательщика | Для созданного в системе типа плательщика определяется каким лицом он является: физическим или юридическим. Если тип плательщика не должен использоваться в сущностях магазина, то следует указать значение Не использовать.


Интеграция с 1С

Закладки

Форма Интеграция с "1С:Предприятие" (Магазин > Настройки > Интеграция с 1С) служит для настройки параметров импорта каталога и экспорта (закладка Каталог и Экспорт каталога) и для настройки параметров обмена заказами (закладка Заказы и Профили обмена).

Каталог

Форма служит для настройки интеграции с "1С:Предприятием" на стороне "1С-Битрикс: Управление сайтом".

Поле | Описание
Тип инфоблока | В выпадающем списке списке перечислены все уже созданные в системе типы инфоблоков. При выборе пункта Создать по необходимости в случае отсутствия необходимого типа инфоблока, будет создан новый.
Привязывать вновь создаваемые инфоблоки к сайтам | Определяется сайт, к которому будут привязываться новые инфоблоки, создаваемые при импорте. Привязка может производиться либо к текущему сайту, либо к одному определённому сайту из имеющихся в системе.
Разрешить загрузку группам пользователей | Указывается группа(-ы) пользователей, обладающие правом загрузки каталога на сайт.
Загружать предложения (характеристики) в отдельный инфоблок | При отмеченной опции информация о самих товарах и предложения на товары (т.е. характеристики и цены) будут храниться в двух разных информационных блоках.
Транслитерировать символьный код из названия при добавлении элемента (товара) или раздела (групп товаров) | При загрузке данных произойдет автоматическая транслитерация символьного кода элемента или раздела.
Транслитерировать символьный код из названия при обновлении элемента (товара) или раздела (групп товаров) | При обновлении данных произойдет автоматическая замена символьного кода элемента или раздела, если он отличается от первоначального.
Замена для неалфавитных символов | Указывается символ, который будет использоваться для замены неалфавитных символов при транслитерации.
Расширенные настройки
Интервал одного шага в секундах | Указывается интервал одного шага в секундах при импорте каталога в систему. 0 - выполнять загрузку за один шаг.
Размер единовременно загружаемой части файла (в байтах) | Указывается размер в байтах - второе ограничение для пошаговой загрузки файла в систему.
Использовать сжатие zip, если доступно | При отмеченной опции данные сжимаются ZIP форматом (если доступно). Это позволяет заметно уменьшить XML файлы.
Использовать контрольные суммы элементов для оптимизации обновления каталога | Суть механизма заключается в том, что если на сайт выгружен полный каталог, то изменению подвергнуться только изменившиеся элементы, что значительно снизит нагрузку на сервер и позволит процедуре обновления отработать значительно быстрее.
Что делать с товарами, отсутствующими в файле импорта Указывается действие с элементами, которые есть в системе, но отсутствуют в файле импорта:
  • удалить - удалить такие элементы;
  • ничего - игнорировать, т.е. никаких действий не совершать;
  • деактивировать - сделать такие элементы неактивными.

Примечание: данный параметр не работает с модулем обмена версии 6.0.
Что делать с группами, отсутствующими в файле импорта Указывается действие с разделами, которые есть в системе, но отсутствуют в файле импорта:
  • удалить - удалить такие разделы;
  • ничего - игнорировать, т.е. никаких действий не совершать;
  • деактивировать - сделать такие разделы неактивными.
Примечание: при использовании модуля обмена 4.х.х.х группы, отсутствующие в файле импорта, всегда будут деактивированы независимо от настройки опции.
Цены только в инфоблоке торговых предложений Данная опция имеет смысл, если некоторые товары выгружаются без характеристик:
  • если опция отмечена, то при выгрузке товаров из 1С, цены на товары будут храниться в торговых предложениях. Т.е для каждого товара будет создано 1 торговое предложение, в котором и будет храниться цена;
  • если опция не отмечена, то для выгруженных из 1С товаров торговые предложения создаваться не будут, цена будет храниться в самом товаре.
Для тех товаров, у которых есть характеристики, будут созданы торговые предложения в соответствии с количеством характеристик и цены будет храниться в этих торговых предложениях.

Хранение самих торговых предложений определяется опцией "Выгружать предложения (характеристики) в отдельный инфоблок".
При выгрузке учитывать тип инфоблока | При отмеченной опции данные будут импортированы с учетом вышеуказанного типа инфоблоков.
Не импортировать верхний уровень группы товаров, если он единственный | [Y|N] При отмеченной опции корневой раздел инфоблока импортироваться не будет, если он единственный (т.е. все вложенные подразделы и элементы будут привязаны к верхнему уровню).
Не менять код (название) типа цены, если используется внешний код (XML_ID) | [Y|N] При отмеченной опции код (название) типа цены изменяться при синхронизации не будет, если задан внешний код.
Тегированный кеш инфоблока Настройка позволяет управлять сбросом тегированного кеша, что влияет на скорость работы сайта и обмена с 1С. Необходимо выбрать, когда сбрасывать кеш:
  • сбрасывать после [dw]каждой[/dw][di]Кеш сбрасывается каждый раз, как изменяется хотя бы один товар. Скорость работы сайта при этом ниже, чем при остальных вариантах.[/di] операции;
  • сбрасывать в конце каждого шага импорта;
  • сбрасывать после окончания импорта;
  • [dw]не сбрасывать[/dw][di]Информация на сайте не обновляется при выборе варианта Не сбрасывать.[/di].
Использовать настройки инфоблока для обработки изображений | При импорте используются параметры, заданные в инфоблоке. Настройки инфоблока при этом имеют приоритет над настройками импорта картинок, указанных в полях ниже.Таким образом, при выборе данной опции последующие поля становятся недоступны для редактирования.
Автоматически генерировать картинку анонса | При отмеченной опции "1С-Битрикс: Управление сайтом" на основании фотографий, которые поступают из "1С" будет самостоятельно генерировать картинку анонса (защита от поступления из "1С" больших фотографий).
Максимально допустимая ширина картинки анонса | При отмеченной опции Автоматически генерировать картинку анонса в данном поле определяется максимальная ширина картинки анонса в пикселях.
Максимально допустимая высота картинки анонса | При отмеченной опции Автоматически генерировать картинку анонса в данном поле определяется максимальная высота картинки анонса в пикселях.
Изменять детальную картинку | При отмеченной опции "1С-Битрикс: Управление сайтом" на основании фотографий, которые поступают из "1С" будет самостоятельно изменять детальную картинку (защита от поступления из 1С больших фотографий).
Максимально допустимая ширина детальной картинки | При отмеченной опции Изменять детальную картинку в данном поле определяется максимальная ширина детальной картинки в пикселях.
Максимально допустимая высота детальной картинки | При отмеченной опции Изменять детальную картинку в данном поле определяется максимальная высота детальной картинки в пикселях.

Экспорт каталога

Форма служит для настройки параметров экспорта каталога в "1С" на стороне системы "1С-Битрикс: Управление сайтом".

Поле | Описание
Инфоблок каталога | Указывается инфоблок каталога.
Количество элементов выгружаемых за один шаг (0 - выполнять выгрузку за один шаг) | Указывается число элементов, выгружаемых за один шаг. 0 - выполнять выгрузку за один шаг.
Интервал одного шага в секундах (0 - выполнять загрузку за один шаг) | Указывается интервал одного шага в секундах при экспорте каталога в 1С. 0 - выполнять загрузку за один шаг.
Разрешить выгрузку группам пользователей | Указывается группа(-ы) пользователей, обладающие правом выгрузки каталога в 1С.
Использовать сжатие zip, если доступно | При отмеченной опции данные сжимаются ZIP форматом (если доступно). Это позволяет заметно уменьшить файлы.

Заказы

Форма служит для настройки параметров обмена заказами с "1С" на стороне системы "1С-Битрикс: Управление сайтом".

<
Поле | Описание
Сайт, заказы которого выгружать в "1С:Предприятие" | Укажите сайт, заказы с которого вы будет принимать в "1С". Т.е. в системе можно создать несколько Интернет-магазинов, а обрабатывать их в одной "1С". Либо заказы с разных сайтов можно выгружать в разные учетные системы.
Создавать новые заказы и контрагенты из 1С | При отмеченной опции новые заказы и контрагенты из 1С будут добавляться на сайт при выполнении процедуры обмена заказами.
Сайт, на который добавлять новые заказы и контрагенты | Указываются сайты, на которые будут добавляться новые заказы и контрагенты из 1С.
Префикс номера заказа при выгрузке | Задается префикс, который будет добавляться к номеру заказа при выгрузке.
Выгружать только оплаченные заказы | При отмеченной опции в "1С" будут выгружаться только оплаченные заказы.
Выгружать только заказы c разрешенной доставкой | При отмеченной опции в "1С" будут выгружаться только заказы с разрешенной доставкой.
Менять статусы заказов по информации из 1С | При отмеченной опции статусы заказов на сайте будут изменяться в соответствии с данными из 1С (т.е. изменяется статус заказа в 1С и после выполнения обмена данными статус заказа на сайте будет изменен на тот, который был задан в 1С).
Выгружать заказы начиная со статуса | Указывается статус, начиная с которого будут выгружаться заказы в "1С". Если указано Не выбрано, то будут выгружены все заказы.
Статус, в который переводить заказ при получении отгрузки от "1С:Предприятие" | Укажите статус, в который будет переводиться заказ при условии, что в "1С" отгрузка товара по данному заказу проведена и информация об этом поступила на сайт. Данный параметр рекомендуется отключать (указать значение Не выбрано), если отмечена опция Менять статусы заказов по информации из 1С.
Заменять валюту при выгрузке в "1С:Предприятие" на | При выгрузке заказов в "1С: Предприятие" валюта товаров (т.е. наименование товаров) будет заменена на указанную. Конвертация при этом не происходит.
Наличный расчет. Платежная система для новых заказов | Указывается платежная система для новых документов оплаты заказа, которые приходят из 1С и их тип "наличный". Тип документа "наличный" или "безналичный расчет" сообщает 1С.
Безналичный расчет. Платежная система для новых заказов | Указывается платежная система для новых документов оплаты заказа, которые приходят из 1С и их тип "безналичный расчет". Тип документа "наличный" или "безналичный расчет" сообщает 1С.
Эквайринговая операция. Платежная система для новых оплат | Указывается платежная система для новых оплат, проводимых путем эквайринговой операции.
Платежная система для автоматической оплаты заказа по статусу оплаты заказа от 1С | Указывается платежная система для автоматической оплаты заказа, для которого пришел статус оплаты из 1С.
Служба доставки для новых заказов | Указывается служба доставки, которая подставляется в документы новых пришедших из 1С заказов.
Увеличивать количество продукта в корзине, если количество в доставке из 1с превышает количество в корзине | При отмеченной опции количество продукта будет увеличено в соответствии с количеством, указанном в документе доставки из 1С.
Создавать новые документы оплаты из 1с | При отмеченной опции будут создаваться новые документы оплаты для новых заказов, пришедших из 1С.
Создавать новый документы доставки из 1с | При отмеченной опции будут создаваться новые документы доставки для новых заказов, пришедших из 1С.
Создавать новый заказ при получении новой доставки из 1с, если заказ основание на сайте не найден | При отмеченной опции на сайте будет создаваться новый заказ, если из 1С будет получен документ доставки, для которого нет соответствующего документа заказа на сайте.
Группы, пользователям которых разрешена выгрузка | Выберите группы пользователей, которые будут иметь права на выгрузку заказов в "1С".
Использовать сжатие zip, если доступно | Установите флаг, чтобы при передаче данных использовалось сжатие zip, если оно доступно.
Интервал одного шага в секундах (0 - выполнять загрузку за один шаг) | Указывается интервал одного шага в секундах при обмене заказами.
Размер единовременно загружаемой части файла (в байтах) | Указывается размер единовременно загружаемой части файла в байтах.

Профили обмена

Форма служит для настройки полей экспорта в "1С". Настройки производятся отдельно для каждого типа плательщика.

Поле | Описание
Название параметра | Название параметра.
Тип | Выбирается тип параметра.
Значение | Указывается значение выбранного параметра.
По умолчанию | Если опция отмечена, то значение параметра является общим для всех бизнес-смыслов системы. Если же нужна частная настройка, то галочку необходимо снять и провести подходящую настройку для поля.
Добавить реквизит | Нажмите для добавления дополнительного параметра, который будет передан в реквизиты заказа в 1С.

Обмен данными с "1С-Предприятие 8"

Начиная с версии продуктов "1С: Предприятие 8", редакция "Управление торговлей", версия 10.3.2.4 и "1С-Битрикс: Управление сайтом" версия 6.5, редакции "Малый бизнес" и "Бизнес" поставляются со встроенными процедурами взаимодействия.

Для реализации обмена данными между "1С-Битрикс: Управление сайтом" и [dw]торговыми кофигурациями "1С"[/dw][di]Разаботаны модули обмена для продуктов 1С:

Комплексная автоматизация,
ERP Управление предприятием,
Управление нашей фирмой,
Управление производственным предприятием,
Управление торговлей.

Редакции прикладных решений и соответствующих модулей обмена приведены на странице скачивания [image]. [/di] необходимо произвести настройки с обеих сторон. Вся подробная информация представлена в курсе Интеграция с 1С [image].

Смотрите также

  • Учебный курс "Интеграция с 1С"


Печатные формы

Форма Печатные формы (Магазин > Настройки > Печатные формы) служит для настройки данных в документах по заказу, выводимых на печать.

Название параметра Тип Значение
Данные магазина
<используемый параметр> В выпадающем окне необходимо выбрать одно из значений:
  • Другое значение - на печать выведется значение указанное в колонке Значение
  • Параметр пользователя - на печать выведется значение указанное в данном параметре заказа пользователем.
  • Параметр заказа - на печать выведется значение, указанное в данном параметре заказа.
  • Свойство заказа - на печать выведется указанное свойство заказа.
 Вводится текст, который выведется на печать, если в поле Тип выбрано Другое значение, либо в выпадающем списке выбирается нужный параметр, если выбраны другие типы.
Данные покупателя
<используемый параметр> В выпадающем окне необходимо выбрать одно из значений:
  • Другое значение - на печать выведется значение указанное в колонке Значение
  • Параметр пользователя - на печать выведется значение указанное в данном параметре заказа пользователем.
  • Параметр заказа - на печать выведется значение, указанное в данном параметре заказа.
  • Свойство заказа - на печать выведется указанное свойство заказа.
 Вводится текст, который выведется на печать, если в поле Тип выбрано Другое значение, либо в выпадающем списке выбирается нужный параметр, если выбраны другие типы.

Смотрите также:

  • Печатные формы (учебный курс "Администратор. Бизнес")


Единицы измерения

На странице Единицы измерения (Магазин > Настройки > Единицы измерения) представлен список доступных в модуле единиц измерения товара.

Контекстная панель

Кнопка | Описание
Добавить из классификатора | Переход к форме добавления новой единицы измерения из классификатора.
Добавить | Переход к форме добавления новой единицы измерения вручную.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список единиц измерения

Колонка | Описание
Колонка флажков | Выбор единиц измерения, к которым предполагается применить какое-либо действие.
Меню действий Допустимые действия:
  • Редактировать - переход к редактированию единицы измерения;
  • Удалить - удаление единицы измерения.
ID | Идентификатор единицы измерения.
Код | Код единицы измерения в ОКЕИ.
Наименование единицы измерения | Наименование единицы измерения в ОКЕИ.
Условное обозначение | Условное обозначение единицы измерения (национальное).
Условное обозначение (международное) | Международное условное обозначение единицы измерения.
Кодовое буквенное обозначение (международное) | Символьное международное обозначение единицы измерения.
По умолчанию Признак использования единицы измерения по умолчанию.

Единица измерения с признаком по умолчанию [dw]автоматически[/dw][di] Проставляется автоматически, если в импортируемом файле не указано иное значение. [/di] проставляется при csv-импорте для новых товаров (с версии модуля Торговый каталог 20.0.100).

Смотрите также

  • Единицы измерения (учебный курс "Администратор. Бизнес")


Создание и редактирование единицы измерения

Если добавление единицы измерения выполняется из классификатора ОКЕИ, то используется специальная форма Добавление единицы измерения из классификатора. Для ручного создания и редактирования единицы измерения применяется форма одного и того же вида. Причем внешний вид формы редактирования не зависит от того, как добавлялась единица измерения, вручную или из классификатора.

Контекстная панель

Кнопка | Описание
Список единиц измерения | Ссылка для перехода на страницу со списком единиц измерения.
Добавить | Переход к добавлению новой единицы измерения. Кнопка доступна только при редактировании существующей единицы измерения.
Удалить | Удаление редактируемой единицы измерения. Кнопка доступна только при редактировании существующей единицы измерения.

Форма добавления единицы измерения из классификатора

Поле | Описание
Выберите раздел классификатора | В выпадающем списке выберите раздел классификатора, из которого нужно добавить единицу измерения.
Выберите подраздел классификатора | С помощью выпадающего списка укажите необходимую группу классификаторов.
<таблица_единиц_измерения> | Для выбранного раздела и подраздела классификатора отображается таблица со списком единиц измерения. Отметьте в колонке флажков те единицы измерения, которые должны быть добавлены в систему.
кнопка Добавить | Кнопка служит для добавления отмеченных в таблице единиц измерения.

Форма редактирования и ручного добавления

Поле | Описание
ID | Идентификатор единицы измерения. Отображается только при редактировании существующей единицы измерения.
По умолчанию | Если опция отмечена, то единица измерения будет использоваться по умолчанию. Единица измерения с признаком по умолчанию [dw]автоматически[/dw][di] Проставляется автоматически, если в импортируемом файле не указано иное значение. [/di] проставляется при csv-импорте для новых товаров (с версии модуля Торговый каталог 20.0.100).
Код* | Код единицы измерения в ОКЕИ.
Наименование единицы измерения* | Наименование единицы измерения в ОКЕИ.
Условное обозначение | Национальное условное обозначение единицы измерения.
Условное обозначение (международное) | Международное условное обозначение единицы измерения.
Кодовое буквенное обозначение (международное) | Символьное международное обозначение единицы измерения.

* - поля, обязательные для заполнения.


Экспорт. Детальное описание

Экспорт

Выгрузка (экспорт) данных из каталога позволяет организовать обмен данными между сайтом и другими сайтами или программами (например, с MS Excel). С помощью формы Настройка экспорта Вы можете экспортировать данные как на основании предустановленных, так и на основании Ваших собственных шаблонов экспорта. Кроме того, с помощью этой формы Вы можете задавать предустановленные профили экспорта, выносить часто используемые шаблоны и профили экспорта в меню, настраивать автоматическое выполнение экспорта с помощью агентов и cron.

Шаблоны экспорта могут иметь дополнительные настройки. Если настройки есть, то при попытке выполнить экспорт сперва будет вызван мастер экспорта, после чего произойдет уже сам экспорт. Если дополнительных настроек нет, то экспорт будет выполнен сразу. Подробную информацию по шаблонам смотрите в разделе для разработчиков [image].

Для предустановленных шаблонов и ваших собственных шаблонов, имеющих дополнительные настройки, можно создавать пользовательские профили экспорта. При выполнении пользовательского профиля мастер экспорта не вызывается, а экспорт идет на основании ранее сохраненных в профиле параметров.

Любой профиль экспорта можно добавить в левое меню административной части с помощью команды Добавить в меню, доступной в меню действий. В результате при клике в меню по пользовательскому профилю он будет открыт на редактирование, а при клике по профилю "по умолчанию" будет открыт соответствующий мастер экспорта.

Примечание. Пути для экспорта различаются для систем с установленным модулем Интернет-магазин (sale) и без него. В первом случае это будет: Магазин > Настройки > Экспорт данных, во втором: Магазин > Торговый каталог > Экспорт данных.

Агенты

Агенты - это PHP функции, которые запускаются с определённой периодичностью. В самом начале загрузки каждой страницы система автоматически проверяет, есть ли агент, который нуждается в запуске, и в случае необходимости исполняет его. Не рекомендуется вешать агенты, длительные по времени / большие по объему выгрузки. Для этих случаев лучше использовать cron.

При установке на автоматическое выполнение с помощью агентов система выводит запрос на период выполнения экспорта. С таким периодом (в часах) экспорт будет выполняться автоматически, начиная с текущего момента.

Утилита cron

Утилита cron работает в фоновом режиме и выполняет указанные задачи в указанное время. Выполнение задач с помощью cron не связано с активностью посетителей на сайте. Выполнение задач с помощью cron может быть назначено не только с определённой периодичностью, но и в строго заданное время.

Утилита cron доступна только на хостингах, работающих под операционными системами семейства UNIX.

При установке на автоматическое выполнение с помощью cron система выводит запрос на период / время выполнения экспорта и путь к интерпретатору php. Если будет указан период выполнения (в часах), то экспорт будет выполняться с таким периодом автоматически, начиная с текущего момента. Если будет указано время выполнения (часы и минуты), то экспорт будет выполняться автоматически каждый день в указанное время.

Путь к интерпретатору php может быть выяснен у хостинг-провайдера или указан в документации по хостингу.

Команда Повесить на cron добавляет соответствующую запись в конфигурационный файл /bitrix/crontab/crontab.cfg, который содержит текущий список задач для cron. После изменения набора задач, установленных на cron, необходимо заново установить конфигурационный файл. Если в форме установки на автоматическое выполнение отмечен флаг Установить автоматически, то форма пытается самостоятельно установить конфигурационный файл в cron. Автоматическая установка конфигурационного файла может не пройти (например, нет достаточных прав). В этом случае необходимо соединиться с Вашим сайтом по SSH (SSH2) или какому-либо другому аналогичному протоколу, поддерживаемому Вашим провайдером для удаленного доступа к shell, и провести установку конфигурационного файла вручную командой

crontab <полный_путь_к_конфигурационный_файл_ crontab.cfg>

Для просмотра списка установленных на cron задач нужно выполнить команду

crontab -l

Текущий список установленных на cron задач выводится так же внизу формы Настройка экспорта, если есть права на его получение.

Для удаления списка установленных на cron задач нужно выполнить команду

crontab -r

Если у Вас установлены на cron задачи, которых нет в конфигурационном файле, то при применении этого файла такие задачи будут удалены.

Оболочкой для выполнения задач на cron является файл /bitrix/php_interface/include/catalog_export/cron_frame.php. Убедитесь, что в нем прописаны правильные пути к php и корню сайта.

Смотрите также

  • Экспорт и импорт данных (учебный курс "Администратор. Бизнес")
  • Профиль экспорта (учебный курс "Администратор. Бизнес")


Настройка экспорта

В настоящее время в Интернете существует несколько торговых каталогов, содержащих информацию о наличии товаров в интернет-магазинах. Вы можете с успехом осуществлять продвижение Вашей продукции, если будете своевременно обновлять информацию о Ваших товарах в таких каталогах.

Каталоги требуют, чтобы информация о товарах отправлялась на их веб-серверы в определённом формате. Система "1C-Битрикс: Управление сайтом" позволяет автоматизировать этот процесс без привлечения услуг программистов. На данный момент в системе реализована отгрузка пользовательских торговых каталогов в следующих форматах:

  • CSV (new) - общий стандартный формат для дальнейшей обработки;
  • CSV - старая версия общего стандартного формата для дальнейшей обработки, оставлена из соображений совместимости;
  • Froogle - формат для торгового каталога семейства Google;
  • Yandex - для торгового каталога Yandex;
  • Yandex Simple - упрощённый формат торгового каталога Yandex.

Для облегчения доступа к экспорту часто используемых товарных групп в определённый формат, каждый из форматов предусматривает создание пользовательских профилей, содержащих информацию об экспортируемых группах товаров из выбираемых информационных блоков.

Если Ваш сайт работает под управлением операционной системы семейства UNIX, существует возможность наладить периодический экспорт разделов торгового каталога. Это может быть осуществлено путём привязки конкретного профиля экспорта к системной утилите cron.

Также при необходимости можно осуществить автоматическую выгрузку каталога при помощи т.н. функции-агента.

Агент - это PHP-функция, запускаемая с определённой периодичностью. Перед загрузкой каждой страницы система автоматически проверяет, есть ли агент, который нуждается в запуске, и в случае необходимости (по истечении определённого интервала времени) исполняет его.

Привязка выгрузки к утилите cron и создание агента выгрузки производится на странице Настройка экспорта. Примечание. Пути для экспорта различаются для систем с установленным модулем Интернет-магазин (sale) и без него. В первом случае это будет: Магазин > Настройки > Экспорт данных, во втором: Магазин > Торговый каталог > Экспорт данных.

Внизу страницы отображен путь к каталогу, где находятся скрипты экспорта. По умолчанию /bitrix/php_interface/include/catalog_export/.

Контекстная панель

Кнопка | Описание
Добавить профиль | Переход к форме добавления профиля для одного из данных типов экспорта.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.

Настройки экспорта

Форматы выгрузки и действия над ними организованы в виде таблицы. Ниже дано описание ее полей.

Действия | ID | Название | Файл | Профиль | Меню | Агент | Cron | Использован | Кем изменен | Дата изменения
[1] | [2] | [3] | [4] | [5] | [6] | [7] | [8] | [9] | [10] | [11]
Поле | Описание
[1] Действия Операции, которые могут быть применены к профилю/скрипту экспорта:
  • Экспортировать - запуск профиля экспорта.
  • Добавить профиль - запуск профиля импорта с возможностью сохранения схемы импорта. Действие недоступно для пользовательских профилей.
  • Список переменных - отображает в отдельном окне форму со списком экспортируемых элементов.
  • Редактировать - открывает параметры профиля для изменения. Действие доступно только для пользовательских профилей.
  • Копировать - копирует параметры профиля в форму создания нового профиля. Действие доступно только для пользовательских профилей.
  • Добавить в меню - добавление ссылки на профиль экспорта в левое меню административной части сайта. Если ссылка добавлена, то вместо данного пункта отображается Удалить из меню.
  • Создать агента - создание PHP функции-агента для автоматического экспорта с использованием данного профиля.
  • Повесить на cron - привязка профиля к системной утилите cron для автоматического экспорта.
  • Удалить профиль - удаление профиля. Действие недоступно для профиля "по умолчанию".
[2] ID | Идентификатор профиля экспорта. Для скриптов экспорта идентификатор не задается.
[3] Название Название типа профиля экспорта, например, Yandex, Froogle.

Примечание:
Для экспорта данных в файлы формата CSV доступно два типа профиля:

Export CSV(new) - данный формат экспорта доступен при установленном в системе модуле Торговый каталог версии 4.0.5 и старше. Этот формат позволяет выгружать данные с учётом группировки цен товаров, в зависимости от количества приобретаемых товаров, а также снимает ограничение с количества объединяемых таблиц, содержащих информацию о товарах. Кроме того, данный формат позволяет выгружать цены товара в валюте, указанной для каждой цены.

Export CSV- данный формат выгрузки используется в системах с версией модуля Торговый каталог ниже 4.0.5. Этот формат накладывает ограничение на количество объединяемых таблиц с информацией о товарах (не более 30), а также не позволяет осуществлять выгрузку групп цен товаров. Кроме того, этот формат позволяет выгружать цены товара только в одной, единой для всех цен товара, валюте.
Если вы не используете разбивку цен товаров торгового каталога в зависимости от количества приобретаемых единиц товара, то данный тип экспорта может быть использован и для старших (4.0.5 и выше) версий модуля Торговый каталог.
[4] Файл | Название файла - PHP скрипта, осуществляющего экспорт.
[5] Профиль Название профиля выгрузки.

Профиль "по умолчанию" перед экспортом всегда запрашивает информационный блок, который требуется выгрузить. При экспорте с использованием пользовательского профиля, экспорт осуществляется автоматически, при этом выгружается именно тот информационный блок, который был выбран при создании профиля.
[6] Меню | Указывает, помещен ли данный профиль для быстрого доступа в левое меню административной части. Поместить профиль в левое меню можно при помощи действия Добавить в меню в колонке Действия.
[7] Агент | Указывает, существует ли агент, осуществляющий в случае необходимости (по истечении определённого интервала времени) автоматическую выгрузку элементов каталога. Создать агента для профиля можно при помощи действия Создать агента в колонке Действия.
[8] Cron | Указывает, привязан ли профиль к утилите cron для автоматической периодической выгрузки. Привязка профиля к утилите cron осуществляется при помощи действия Привязать к cron в колонке Действия.
[9] Использован | Дата и время последнего экспорта с использованием данного профиля.
[10] Кем изменен | Имя пользователя, внесшего последние изменения в данный профиль.
[11] Дата изменения | Дата и время последнего изменения данного профиля.

Смотрите также

Экспорт. Детальное описание


Ручной экспорт каталогов в CSV (профиль по умолчанию)

Форма экспорта данных

Форма экспорта данных Export CSV предназначена для экспорта данных из торгового каталога в CSV формате. Данный формат экспорта устарел и остался только из соображений совместимости, в нем присутствует ограничение на число свойств и цен. Поэтому рекомендуется использовать экспорт в CSV (new).

Примечание. Пути для экспорта различаются для систем с установленным модулем Интернет-магазин (sale) и без него. В первом случае это будет: Магазин > Настройки > Экспорт данных, во втором: Магазин > Торговый каталог > Экспорт данных.

Контекстная панель

Поле | Описание
Вернуться в список | Переход на страницу со списком настроек экспорта.

Шаг 1. Инфоблок

Поле | Описание
Инфоблок | Выберите тип инфоблока и сам информационный блок, данные из которого должны быть выгружены.

Для продолжения процедуры выгрузки данных нажмите кнопку Далее.

Шаг 2. Параметры экспорта

Поле | Описание
Задайте свойства формата файла
Разделитель полей | Укажите символы, используемые для разделения полей данных.
Первая строка содержит имена полей | Установите флаг в поле, если первая строка файла должна содержать имена выгружаемых полей.
Задайте соответствие полей в файле полям в базе
Поле | Описание
Выгружать | Для того чтобы поле могло быть выгружено в CSV файл, установите этот флаг.
Название поля | Названия выгружаемых полей. Важно! Обязательно должно быть выбрано хотя бы одно из полей Внешний код (B_IBLOCK_ELEMENT.XML_ID) или Название (B_IBLOCK_ELEMENT.NAME). Эти поля используются для сопоставления элементов в файле элементам в базе данных.
Порядок | Порядок следования полей в выгружаемом файле.
Сохранить файл данных как ...
Имя файла данных Имя файла (по умолчанию путь к файлу указывается относительно каталога /bitrix/catalog_export/), в который будут выгружены данные из инфоблока.

Важно! Если файл с указанным именем уже существует, то он будет перезаписан.

Чтобы вернуться к предыдущему шагу, воспользуйтесь кнопкой Назад. Для начала выгрузки данных нажмите кнопку Начать выгрузку.

Шаг 3. Результат

После того, как выгрузка выполнилась, происходит переадресация на страницу Магазин > Торговый каталог > Экспорт данных и выводится информация о результатах выгрузки данных.


Ручной экспорт каталогов в Yandex (профиль по умолчанию)

Форма экспорта

Для выгрузки данных в формате Yandex с использованием профиля по умолчанию выберите ссылку Экспортировать в меню действий соответствующего профиля на странице со списком настроек экспорта.

Примечание. Пути для экспорта различаются для систем с установленным модулем Интернет-магазин (sale) и без него. В первом случае это будет: Магазин > Настройки > Экспорт данных, во втором: Магазин > Торговый каталог > Экспорт данных.

Контекстная панель

Поле | Описание
Вернуться в список | Переход на страницу со списком настроек экспорта.

Шаг 1. Параметры

Поле | Описание
Задайте свойства формата файла
Выберите инфоблок для экспорта | Выберите тип инфоблока и сам информационный блок, данные из которого должны быть выгружены.
Выберите группы | Отметьте те группы товаров, которые должны быть экспортированы.
Детальные настройки* С помощью кнопки настроить открывается форма Настройка дополнительных параметров.

Вкладка "Настройка выгрузки"

Поле | Описание
Тип описания Выберите тип описания товаров в вашем каталоге:
  • упрощенное;
  • vendor.model;
  • book;
  • audiobook;
  • artist.title.
Общие настройки Выберите место, откуда будет копироваться Подробное описание товара:
  • описание для анонса (PREVIEW_TEXT);
  • детальное описание (DETAIL_TEXT).
Настройки типа описания Перечень настроек зависит от выбранного типа описания:
  • Описание упрощенное не имеет настроек. Используется по умолчанию.

  • Описание vendor.model (наиболее удобный вариант с точки зрения Яндекс.Маркета) позволяет выводить разные типы товаров. В настройках этого описания представлены следующие параметры:
    • Производитель (vendor);
    • Код производителя (vendorCode);
    • Модель (model);
    • Гарантия производителя (manufacturer_warranty).
    Выберите соответствие этих параметров свойствам экспортируемого торгового каталога.

  • Описание book - специальный тип описания для книг. В настройках этого описания представлены следующие параметры:
    • Автор (author);
    • Издательство (publisher);
    • Серия (series);
    • Год издания (year);
    • Код книги (ISBN);
    • Кол-во томов (volume);
    • Номер тома (part);
    • Язык (language);
    • Переплет (binding);
    • Кол-во страниц (page_extent);
    • Оглавление (table_of_contents).
    Выберите соответствие этих параметров свойствам экспортируемого торгового каталога.

  • Описание audiobook - специальный тип описания для аудиокниг. В настройках этого описания представлены следующие параметры:
    • Автор (author);
    • Издательство (publisher);
    • Серия (series);
    • Год издания (year);
    • Код книги (ISBN);
    • Исполнитель (performed_by);
    • Тип (performance_type)
    • Язык (language);
    • Кол-во томов (volume);
    • Номер тома (part);
    • Формат аудиокниги (format);
    • Носитель (storage);
    • Время звучания (mm.ss) (recording_length);
    • Оглавление (table_of_contents).
    Выберите соответствие этих параметров свойствам экспортируемого торгового каталога.

  • Описание artist.title - специальный тип для описания музыкальной продукции. В настройках этого описания представлены следующие параметры:
    • Наименование (title);
    • Исполнитель (artist);
    • Режиссер (director);
    • Актеры (starring);
    • Оригинальное наименование (originalName);
    • Страна (country);
    • Год издания (year)
    • Носитель (media).
    Выберите соответствие этих параметров свойствам экспортируемого торгового каталога.
Дополнительные свойства для выгрузки | Выберите свойства, которые должны быть выгружены. Используя кнопку Еще, вы можете добавить любое количество свойств.
Выгрузка торговых предложений Выгрузка торговых предложений доступна только для инфоблоков с поддержкой SKU. В этом случае выбирается условие, по которому отбираются торговые предложения для выгрузки:
  • все предложения товара;
  • предложение с минимальной ценой;
  • отбор по свойству.
Условие отбора по свойству доступно в том случае, если в инфоблоке торговых предложений имеется хотя бы еще одно свойство помимо свойства привязки к товарам. В этом случае при отборе по свойству, кроме самого свойства, следует выбрать условие отбора (пусто, не пусто, равно или не равно) и заполнить поле Значения.)

Внимание: Сейчас по правилам площадки Яндекс.Маркет каждому торговому предложению должна соответствовать уникальная страница. Штатно в продукте торговые предложения не имеют уникальных URL страниц. Варианты решения на настоящий момент :
- В параметре Выгрузка торговых предложений выберите вариант предложение с минимальной ценой. В этом случае товар будет выгружен только с одним предложением, имеющим наименьшую цену;
- Воспользоваться одним из готовых решений Маркетплейса [image].

Вкладка "Валюты и цены".

Поле | Описание
Цены
Выводить цену Укажите какая цена должна выводиться: оптимальная или одного из используемых в магазине типов цен.

Оптимальная цена определяется следующим образом: выбираются все доступные типы цен, смотрятся цены этих типов, учитываются скидки и из получившихся берется минимальная.
Валюты
валюта | Отметьте нужные для экспорта валюты
курс В выпадающем списке выберите один из курсов валют:
  • (SITE) сайт - курс, заданный на сайте для данной валюты.
  • (CBRF) Центральный банк РФ - курс, установленный ЦБРФ на текущую дату по данной валюте.
  • (NBU) Национальный банк Украины - курс, установленный НБУ на текущую дату по данной валюте.
  • (NBK) Национальный банк Казахстана - курс, установленный НБК на текущую дату по данной валюте.
  • (CB) банк своего региона - курс, установленный национальным банком той страны, которая указана в настройках магазина в профиле Яндекс.Маркета.
коррекция курса | Вы можете установить процент, который будет прибавляться к полученному курсу валюты.

Вкладка "НДС"

Поле | Описание
Выгружать ставки НДС | При отмеченной опции будет выполняться выгрузка ставок НДС. Внимание! Выгрузка ставок НДС для товаров необходима только субъектам РФ, работающим по модели CPA с включенной предоплатой на Маркете. Могут быть выгружены следующие ставки НДС: 0, 10%, 18%, НДС отсутствует.
Базовая ставка на основной ассортимент | Параметр отображается при отмеченной опции Выгружать ставки НДС. Выберите нужную ставку из списка.

Кнопки управления

Поле | Описание
Сохранить | Сохранение внесенных настроек для экспорта.
Отменить | Отмена введенных настроек в форме. Будут использованы настройки по умолчанию.
Включить проверку прав доступа для группы 2 (все пользователи) | При отмеченной опции включается проверка прав доступа к товарам группы Все пользователи (в том числе неавторизованные).
Выгружать только доступные к покупке товары | При отмеченной опции в Яндекс будут выгружены только доступные к покупке товары.
Использовать в выгрузке протокол https | При отмеченной опции при выгрузке будет использоваться протокол HTTPS.
Не добавлять к ссылкам на товары реферер* | При отмеченной опции отключается добавление рефереров в ссылки на товары.
Создать выгрузку в кодировке utf-8 При отмеченной опции выгрузка выполнится в кодировке UTF-8.
Допустимые кодировки Яндекс. Маркета для файла выгрузки: UTF-8 и windows-1251.
Время выполнения шага | (сек.) Указывается время для шага. 0 - экспорт не делится по шагам и выполняется сразу. Численное значение для шага экспорта подбирается экспериментально, очень много влияющих факторов: дать конкретные рекомендации невозможно.
Доменное имя* | Указывается доменное имя для ссылок на сайт и товары. С помощью кнопки текущее можно установить ваше текущее доменное имя.
Название компании | Произвольное название компании - владельца магазина.
Сохранить в файл Задается имя файла (по умолчанию путь к файлу указывается относительно каталога /bitrix/catalog_export/), в котором будут сохранены результаты экспорта.

Важно! Если файл с указанным именем уже существует, то он будет перезаписан.

Имя профиля | Произвольное название создаваемого профиля.
* - данные поля доступны в форме только при экспорте в Yandex.

Для начала выгрузки данных нажмите кнопку Экспортировать.

Шаг 2. Результат

После того, как выгрузка выполнилась, происходит переадресация на страницу Магазин > Торговый каталог > Экспорт данных и выводится информация о результатах выгрузки данных.


Ручной экспорт каталогов в CSV (new) (профиль по умолчанию)

Форма экспорта

Форма экспорта данных Export CSV (new) предназначена для экспорта данных из торгового каталога в CSV файл.

Примечание. Пути для экспорта различаются для систем с установленным модулем Интернет-магазин (sale) и без него. В первом случае это будет: Магазин > Настройки > Экспорт данных, во втором: Магазин > Торговый каталог > Экспорт данных.

Обратите внимание, что экспорт данных будет осуществляться не только согласно настройкам самой схемы экспорта, но и согласно настройкам, заданным на закладке Экспорт/импорт формы настроек модуля Торговый каталог.

Контекстная панель

Поле | Описание
Вернуться в список | Переход на страницу со списком настроек экспорта.

Шаг 1. Инфоблок

Поле | Описание
Инфоблок | Выберите тип инфоблока и сам информационный блок, данные из которого должны быть выгружены.

Для продолжения процедуры выгрузки данных нажмите кнопку Далее.

Шаг 2. Параметры экспорта

Поле | Описание
Задайте свойства формата файла
Разделитель полей | Укажите символы, используемые для разделения полей данных.
Первая строка содержит имена полей | Установите флаг в поле, если первая строка файла должна содержать имена выгружаемых полей.
Задайте соответствие полей в файле полям в базе
Поле | Описание
Выгружать | Для того чтобы поле могло быть выгружено в CSV файл, установите этот флаг.
Название поля | Названия выгружаемых полей. Важно! Обязательно должно быть выбрано хотя бы одно из полей Внешний код (B_IBLOCK_ELEMENT.XML_ID) или Название (B_IBLOCK_ELEMENT.NAME). Эти поля используются для сопоставления элементов в файле элементам в базе данных.
Порядок | Порядок следования полей в выгружаемом файле.
Дополнительные настройки
Выгружать в свойство привязки торговых предложений к товарам внешний код товара (XML_ID) При отмеченной опции будут выгружены XML_ID товаров в свойство привязки торговых предложений.

Параметр доступен только при выгрузке инфоблока торговых предложений.
Выгружать файлы | При отмеченной опции файлы с картинками будут выгружены в отдельную папку с именем <имя_файла_данных>_files, которая будет располагаться в том же каталоге, что и сам CSV файл с данными (см. ниже).
Время выполнения шага | Прописывается [dw]число секунд[/dw][di] Указывается время меньше длительности максимального исполнения скрипта (обычно 60 секунд, но данную информацию необходимо уточнять у администратора сайта). [/di] на выполнение одного шага. Опция применяется для больших каталогов, когда большой инфоблок не успевает выгрузиться за один хит. По умолчанию 0 (выгрузить все сразу).
Сохранить файл данных как ...
Имя файла данных Имя файла (по умолчанию путь к файлу указывается относительно каталога /bitrix/catalog_export/), в который будут выгружены данные из инфоблока.

Важно! Если файл с указанным именем уже существует, то он будет перезаписан.

Чтобы вернуться к предыдущему шагу, воспользуйтесь кнопкой Назад. Для начала выгрузки данных нажмите кнопку Начать выгрузку.

Шаг 3. Результат

После того, как выгрузка выполнилась, происходит переадресация на страницу Магазин > Торговый каталог > Экспорт данных и выводится информация о результатах выгрузки данных.


Ручной экспорт каталогов в Yandex Simple (профиль по умолчанию)

Форма экспорта

Форма экспорта данных Yandex - simple предназначена для экспорта данных из торгового каталога в упрощенном формате торгового каталога Yandex.

Примечание: пути для экспорта различаются для систем с установленным модулем Интернет-магазин (sale) и без него. В первом случае это будет: Магазин > Настройки > Экспорт данных, во втором: Магазин > Торговый каталог > Экспорт данных.

Обратите внимание, что экспорт данных будет осуществляться не только согласно настройкам самой схемы экспорта, но и согласно настройкам, заданным на закладке Экспорт/импорт формы настроек модуля Торговый каталог.

Контекстная панель

Поле | Описание
Вернуться в список | Переход на страницу со списком настроек экспорта.

Шаг 1. Параметры

Поле | Описание
Перечень торговых каталогов
Поле | Описание
Каталог | Название торгового каталога.
Экспортировать в Яндекс.Товары | При отмеченной опции содержимое торгового каталога будет экспортировано в файл для каталога Yandex.

Доменное имя | Указывается доменное имя для ссылок на сайт и товары. С помощью кнопки текущее можно задать ваше текущее доменное имя.
Сохранить в файл Задается имя файла (по умолчанию путь к файлу указывается относительно каталога /bitrix/catalog_export/), в котором будут сохранены результаты экспорта.

Важно! Если файл с указанным именем уже существует, то он будет перезаписан.

Для начала выгрузки данных нажмите кнопку Экспортировать.

Шаг 2. Результат

После того, как экспорт выполнен, происходит переадресация на страницу Магазин > Торговый каталог > Экспорт данных и выводится информация о результатах выгрузки данных.


Создание профилей экспорта

Для облегчения доступа к экспорту часто используемых товарных групп в определённый формат, каждый из форматов предусматривает создание пользовательских профилей, содержащих информацию об экспортируемых группах товаров из выбираемых Вами информационных блоков.

Для создания профиля экспорта выберите ссылку Добавить профиль в контекстном меню страницы Настройка экспорта. Либо в контекстном меню любого стандартного профиля выберите пункт Добавить профиль.

Примечание. Пути для экспорта различаются для систем с установленным модулем Интернет-магазин (sale) и без него. В первом случае это будет: Магазин > Настройки > Экспорт данных, во втором: Магазин > Торговый каталог > Экспорт данных.

Создание профилей экспорта заключается в задании параметров выгрузки информации. Дополнительно требуется указать имя нового профиля, которое будет показано в списке профилей.

Смотрите также:

  • Ручной экспорт каталогов в CSV (профиль по умолчанию)
  • Ручной экспорт каталогов в Yandex и Froogle (профиль по умолчанию)
  • Ручной экспорт каталогов в Yandex Simple (профиль по умолчанию)


Автоматический экспорт каталогов в Яндекс.Товары

Модуль торгового каталога имеет возможность выгрузки каталогов товаров в XML-файл, подходящий для размещения в системе Яндекс.Товары.

Укажите в настройках модуля Торговый каталог на закладке Каталоги те каталоги, которые необходимо выгружать в XML-файл. XML-файл будет пересоздаваться с периодичностью, указанной в переменной Период экспорта в Яндекс.Товары. Готовый файл будет располагаться по адресу http://<ваш_сайт>/<ваш_каталог>/yandex.php (вместо подстроки <ваш_сайт> должен быть указан реальный адрес сайта, подстрока <ваш_каталог> берется из переменной Путь по умолчанию для экспортируемых файлов).

Готовый файл http://<ваш_сайт>/<ваш_путь>/yandex.php может принимать дополнительные параметры referer1 и referer2, которые служат для формирования ссылок на товары с учётом рекламных компаний. Например, если запросить адрес:

http://<ваш_сайт>/<ваш_каталог>/yandex.php?referer1=wizard&referer2=soft

то в выдаваемом XML-файле ссылки на страницу с детальной информацией о товаре будут иметь вид:

http://<ваш_сайт>/catalog/detail.php?ID=8192&r1=wizard&r2=soft

Если параметр referer1 не задан, то он принимает значение "yandext". Например,

http://<ваш_сайт>/catalog/detail.php?ID=8192&r1=yandext&r2=


Импорт каталогов

С помощью формы Настройка импорта Вы можете импортировать данные как на основании предустановленных, так и на основании Ваших собственных шаблонов импорта. Кроме того, с помощью этой формы Вы можете задавать предустановленные профили импорта, выносить часто используемые шаблоны и профили импорта в меню, настраивать автоматическое выполнение импорта с помощью агентов и cron.

Шаблоны импорта могут иметь дополнительные настройки. Если настройки есть, то при попытке выполнить импорт сперва будет вызван мастер импорта, после чего произойдет уже сам импорт. Если дополнительных настроек нет, то импорт будет выполнен сразу. Подробную информацию по шаблонам смотрите в разделе для разработчиков [image].

Для предустановленных шаблонов и ваших собственных шаблонов, имеющих дополнительные настройки, можно создавать пользовательские профили импорта. При выполнении пользовательского профиля мастер импорта не вызывается, а импорт идет на основании ранее сохраненных в профиле параметров.

Любой профиль импорта можно добавить в левое меню административной части с помощью команды Добавить в меню, доступной в меню действий. В результате при клике в меню по пользовательскому профилю он будет открыт на редактирование, а при клике по профилю "по умолчанию" будет открыт соответствующий мастер импорта.

Примечание. Пути для импорта различаются для систем с установленным модулем Интернет-магазин (sale) и без него. В первом случае это будет: Магазин > Настройки > Импорт данных, во втором: Магазин > Торговый каталог > Импорт данных.

См. также

  • Импорт из 1С


Настройка импорта

Система "1С-Битрикс: Управление сайтом" предусматривает наполнение и изменение торговых каталогов сайта с помощью загрузки данных из внешних файлов. Для настройки параметров импорта служит страница Настройка импорта. Примечание: пути для импорта различаются для систем с установленным модулем Интернет-магазин (sale) и без него. В первом случае это будет: Магазин > Настройки > Импорт данных, во втором: Магазин > Торговый каталог > Импорт данных.

Внизу страницы отображен путь к каталогу, где находятся скрипты импорта. По умолчанию /bitrix/php_interface/include/catalog_import/.

Контекстная панель

Кнопка | Описание
Добавить профиль | Ссылка Добавить профиль позволяет создать новый профиль импорта данного типа.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.

Настройки импорта

Действия | ID | Название | Файл | Профиль | В меню | В агентах | На сron'e | Использован | Кем изменен | Дата изменения
[1] | [2] | [3] | [4] | [5] | [6] | [7] | [8] | [9] | [10] | [11]
Поле | Описание
[1] Действия Операции, которые могут быть применены к профилю/скрипту импорта:
  • Импортировать - запуск профиля импорта;
  • Добавить профиль - запуск профиля импорта с возможностью сохранения схемы импорта. Действие недоступно для пользовательских профилей.
  • Редактировать - переход к редактированию настроек схемы импорта. Действие доступно только для пользовательских профилей.
  • Копировать - копирование существующей схемы импорта. Действие доступно только для пользовательских профилей;
  • Список переменных - отображает список импортируемых переменных в отдельном окне. Действие доступно только для пользовательских профилей.
  • Добавить в меню - добавление ссылки на профиль импорта в левое меню административной части сайта;
  • Создать агента - создание PHP функции-агента для автоматического импорта с использованием данного профиля;
  • Повесить на cron - привязка профиля к системной утилите cron для автоматического импорта;
  • Удалить профиль - удаление профиля. Действие недоступно для профиля "по умолчанию".
[2] ID | Идентификатор профиля импорта. Скрипты импорта идентификатора не имеют.
[3] Название | Название типа профиля импорта, например, CommerceML.
[4] Файл | Имя файла - PHP-скрипта, осуществляющего импорт.
[5] Профиль Название профиля импорта.

Профиль "по умолчанию" каждый раз перед началом операции предлагает указать параметры импорта. При использовании пользовательского профиля, импорт осуществляется автоматически в соответствии с параметрами, указанными при создании профиля.
[6] В меню | Указывает, помещен ли данный профиль для быстрого доступа в левое меню административной части. Поместить профиль в левое меню можно при помощи действия Добавить в меню в колонке Действия.
[7] В агентах | Указывает, существует ли агент, осуществляющий в случае необходимости (по истечении определённого интервала времени) автоматическую загрузку элементов каталога. Создать агента для профиля можно при помощи действия Создать агента в колонке Действия.
[8] В cron'е | Указывает, привязан ли профиль к утилите cron для автоматической периодической загрузки данных. Привязка профиля к утилите cron осуществляется при помощи действия Привязать к cron в колонке Действия.
[9] Использован | Дата и время последнего импорта с использованием данного профиля.
[10] Кем изменен | Имя пользователя, внесшего последние изменения в данный профиль.
[11] Дата изменения | Дата и время последнего изменения данного профиля.


Ручной импорт в формате CSV (профиль по умолчанию)

Форма импорта каталога товаров

Форма импорта данных Import CSV (new) (пункт меню действий Импортировать для Import CSV (new)) предназначен для импорта данных в формате CSV в торговый каталог. Пример файла формата CSV [image] для импорта.

Примечание: пути для импорта различаются для систем с установленным модулем Интернет-магазин (sale) и без него. В первом случае это будет: Магазин > Настройки > Импорт данных, во втором: Магазин > Торговый каталог > Импорт данных.

Обратите внимание, что импорт данных будет осуществляться не только согласно настройкам самой схемы импорта, но и согласно настройкам, заданным на закладке Экспорт/импорт формы настроек модуля Торговый каталог.

Предварительная настройка импорта

Поскольку файлы в формате CSV не содержат информации о структуре каталога и свойствах товаров внутри него, то перед загрузкой данных необходимо создать структуру торгового каталога.

Для создания структуры выполните следующие действия.

  1. Создайте и настройте требуемый информационный блок, если его ещё нет.
  2. Создайте в информационном блоке все необходимые свойства (для элементов информационного блока должны быть заданы те же свойства, что и для товаров, импортируемых из CSV файла).
  3. Настройте информационный блок на использование в качестве торгового каталога (см. Торговый каталог).
  4. Загрузите иллюстрации товаров (если они есть) на сайт.

Смотрите также

  • Импорт каталога товаров на сайт [image] (урок с видеопримером).

Контекстная панель

Поле | Описание
Вернуться в список | Переход на страницу со списком настроек импорта.

Шаг 1. Файл данных

Форма предназначена для выбора загружаемого файла и информационного блока, в который будет выполняться загрузка данных.

Поле | Описание
Файл данных | С помощью кнопки выберите файл с загружаемыми данными.
Информационный блок | Выберите сначала тип информационного блока, а затем и сам блок, в который будет выполняться загрузка данных.

Для продолжения процедуры загрузки данных нажмите кнопку Далее.

Шаг 2. Формат

Поле | Описание
Формат данных Выберите подходящий формат CSV файла с данными:
  • с разделителями - поля разделяются специальным символом (например, запятой или пробелом);
  • фиксированная ширина полей.
В зависимости от вашего выбора необходимо настроить Разделитель полей или Метки разделителя.
Разделитель полей | Укажите символы, используемые для разделения полей данных.
Метки разделителя | Укажите в столбик номера колонок, разделяющие поля.
Первая строка содержит имена полей | Если первая строка файла содержит имена полей данных, установите флаг в это поле.
Образцы данных
В поле представлен образец загружаемых данных.

Для возврата к предыдущему шагу воспользуйтесь кнопкой Назад. Для продолжения процедуры загрузки данных нажмите кнопку Далее.

Шаг 3. Поля

Форма служит для задания соответствия между полями инфоблока и загружаемого файла.

Поле | Описание
Задайте соответствие полей в файле полям в базе
Установите соответствие между полями загружаемого файла и полями информационного блока, в который выполняется загрузка данных.
Поле | Описание
Поля в файле | Список полей загружаемого файла.
Поля в базе | Список полей инфоблока, в который выполняется загрузка. Важно! Обязательно должно быть выбрано хотя бы одно из полей Уникальный идентификатор (B_IBLOCK_ELEMENT.XML_ID) или Название (B_IBLOCK_ELEMENT.NAME). Эти поля используются для сопоставления записей в файле записям в базе данных. Также проверьте настройки [dw]инфоблока[/dw][di] В данном примере опция Начало активности отмечена как обязательная, поэтому в создаваемом файле csv тоже должна быть колонка с указанием начала активности элемента. [/di] (Контент > Инфоблоки > Типы инфоблоков > [ваш тип инфоблока]/[ваш инфоблок]), в который Вы хотите загрузить файл: если во вкладках Поля или Поля разделов какие-либо поля отмечены как обязательные, то эти колонки должны быть обязательно и в загружаемом csv-файле.

Внимание! Убедитесь, что соответствия полей заданы корректно. В противном случае результат загрузки непредсказуем.

Дополнительные настройки
Путь к картинкам | Для загрузки элементов с иллюстрациями необходимо предварительно выгрузить картинки в какую-либо папку на сайте с помощью любого FTP-клиента. Путь к папке с изображениями, нужно указать в этом поле.
Использовать настройки инфоблока для обработки изображений | При отмеченной функции изображения, добавленные при импорте, будут преобразовываться согласно настройкам инфоблока.
Использовать настройки инфоблока для транслитерации символьных кодов | При отмеченной опции символьные коды будут транслитероваться согласно настройкам инфоблока (закладка Поля [image] и закладка Поля разделов [image]).
Язык для транслитерации | Выберете язык, который будет использоваться для транслитерации.
Товары, которых не было в файле Определяется выполняемое действие над товарами, которые уже есть в базе, но отсутствуют в загружаемом файле:
  • деактивировать - элементы инфоблока станут неактивными;
  • удалить - элементы будут удалены;
  • установить статус "нет в наличии" - для элемента будет установлено следующее:
    • количество на складе - 0;
    • уменьшать количество при заказе - да;
    • разрешать покупку при нулевом количестве - нет;
    • разрешать отрицательное количество товара - нет.
  • не трогать - элементы будут сохранены без изменений.
Неактивные товары / группы, которые есть в файле: Выберите действие, которое будет выполнено над неактивными товарами/группами каталога:
  • оставить как есть - товары/группы не будут изменены;
  • активировать - товары/группы станут активными (т.е. доступными для показа в публичном разделе).
Удалять существующую цену, если ее величина и валюта в файле заданы пустыми | При отмеченной опции существующая цена товара будет удалена, если величина цены и валюта заданы [dw]пустыми значениями[/dw][di] Например, ;; (т.е. между разделителями ; отсутствует значение цены). [/di] в файле. При отключенной опции цена остаётся прежней.
Свойство привязки торговых предложений к товарам содержит внешний код товара (XML_ID) Если в файле импорта свойство привязки торговых предложений к товарам содержит внешний код товара, то опция должна быть отмечена. Если свойство привязки содержит ID товаров, то опция должна быть снята.

Опция доступна только при загрузке в инфоблок торговых предложений.
Время выполнения шага | Длительность одного шага загрузки данных из CSV-файла в секундах. При значении 0 загрузка данных выполняется за один шаг. Параметр Время выполнения шага сделан для больших файлов импорта. Большой – это несколько тысяч позиций. При таких файлах рекомендуется использовать шаг в 30-60 секунд.
Название схемы импорта
Данная секция доступна, если для запуска профиля было выбрано "Добавить профиль", а не "Импортировать".
Название схемы импорта | Указывается название пользовательского профиля, под которым необходимо сохранить настройки текущего импорта данных.
Образцы данных
В поле представлен образец загружаемых данных.

Для возврата к предыдущему шагу воспользуйтесь кнопкой Назад. Для выполнения загрузки данных нажмите кнопку Загрузить данные.

Шаг 4. Результат

После того, как загрузка выполнилась, происходит переадресация на страницу Магазин > Торговый каталог > Импорт данных и выводится информация о результатах загрузки данных.


Ручной импорт в формате CommerceML (профиль по умолчанию)

Форма импорта каталога товаров

Форма импорта данных CommerceML (пункт меню действий Импортировать (или Добавить профиль) для CommerceML) предназначена для импорта данных в формате CommerceML версии 1.0 в торговый каталог.

Примечание: пути для импорта различаются для систем с установленным модулем Интернет-магазин (sale) и без него. В первом случае это будет: Магазин > Настройки > Импорт данных, во втором: Магазин > Торговый каталог > Импорт данных.

Контекстная панель

Поле | Описание
Вернуться в список | Переход на страницу со списком настроек импорта.

Шаг 1. Параметры

Форма предназначена для выбора загружаемого файла и типа информационного блока, в который будет выполняться загрузка данных.

Поле | Описание
Импорт данных в формате CommerceML
Файл данных | С помощью кнопки Выбрать выберите файл с загружаемыми данными.
Тип информационного блока | Укажите, в информационный блок какого типа загружать данные. Требуемый тип информационного блока должен быть предварительно вами создан.
Дополнительные настройки
Товары, которых нет в файле данных Определяется выполняемое действие над товарами, которые уже есть в базе, но отсутствуют в загружаемом файле:
  • удалять - элементы будут удалены;
  • деактивировать - элементы инфоблока станут неактивными;
  • оставить как есть - никаких действий с отсутствующими в файле, но имеющимися в базе товарами выполнено не будет.
Активировать товары и группы, которые есть в загружаемом файле | С помощью переключателей (да/нет) определите должны ли товары/группы стать активными (т.е. доступными для показа в публичном разделе) или их активность изменена быть не должна.
Сохранять свойства, которых нет в загружаемом файле | При отмеченной опции все свойства, которых нет в загружаемом файле, будут сохранены. В противном случае - удалены.
Конвертировать из UTF-8 | С помощью переключателей (да/нет) определите должна ли выполняться конвертация данных из UTF-8 в кодировку сайта.
Использовать настройки инфоблока для транслитерации символьных кодов | При отмеченной опции символьные коды будут транслитероваться согласно настройкам инфоблока.
Включать транслитерацию при создании инфоблока | При отмеченной опции будет включена транслитерация при создании инфоблока.
Сохранить настройки как схему
Данная секция доступна, если для запуска профиля было выбрано Добавить профиль, а не Импортировать.
Имя схемы | Указывается название пользовательского профиля, под которым необходимо сохранить настройки текущего импорта данных.

Для начала процедуры загрузки данных нажмите кнопку Начать загрузку (или Сохранить, если вместе с загрузкой данных происходит создание пользовательского профиля импорта).

Шаг 2. Результат

После того, как загрузка выполнилась, происходит переадресация на страницу Магазин > Торговый каталог > Импорт данных и выводится информация о результатах загрузки данных.


Ручной импорт в формате CommerceML MySql Fast - BETA VERS (профиль по умолчанию)

Форма импорта каталога товаров

Форма импорта данных CommerceML MySql Fast - BETA VERS (пункт меню действий Импортировать для CommerceML MySql Fast - BETA VERS) предназначена для быстрой загрузки данных в формате CommerceML версии 1.0 в торговый каталог. Примечание: пути для импорта различаются для систем с установленным модулем Интернет-магазин (sale) и без него. В первом случае это будет: Магазин > Настройки > Импорт данных, во втором: Магазин > Торговый каталог > Импорт данных.

Важно! Шаблон импорта CommerceML MySql Fast - BETA VERS работает только на MySQL-версиях продукта.

Контекстная панель

Поле | Описание
Вернуться в список | Переход на страницу со списком настроек импорта.

Шаг 1. Параметры

Форма предназначена для выбора загружаемого файла и настройки параметров импорта.

Поле | Описание
Импорт данных в формате CommerceML
Файл данных | С помощью кнопки Выбрать выберите файл с загружаемыми данными.
Тип информационного блока | Укажите, в информационный блок какого типа загружать данные. Требуемый тип информационного блока должен быть предварительно вами создан.
Дополнительные настройки
Сохранять свойства, которых нет в загружаемом файле | При выборе переключателя "Да" все свойства, которых нет в загружаемом файле, будут сохранены. В противном случае - удалены.
Сохранять данные, которых нет в загружаемом файле | При выборе переключателя "Да" все товары, которых нет в загружаемом файле, будут сохранены. В противном случае - удалены.
Активировать товары и группы, которые есть в загружаемом файле | С помощью переключателей (Да/Нет) определите должны ли товары/группы стать активными (т.е. доступными для показа в публичном разделе) или их активность изменена быть не должна.
В файле данных есть комментарии | С помощью переключателей (Да/Нет) определите должен ли выполняться поиск комментариев в XML-файле.
Вывести отладочную информацию в файл __cml_time_mark.dat | С помощью переключателей (Да/Нет) определите должна ли выводиться отладочная информация в файл __cml_time_mark.dat при выполнении процедуры импорта (файл будет располагаться в корне сайта).
Включить в отладочную информацию размер памяти | При выборе переключателя "Да" в файл с отладочной информацией будет вносится размер используемой памяти.
Использовать настройки инфоблока для транслитерации символьных кодов | При отмеченной опции символьные коды будут транслитероваться согласно настройкам инфоблока.
Включать транслитерацию при создании инфоблока | При отмеченной опции будет включена транслитерация при создании инфоблока.

Для начала процедуры загрузки данных нажмите кнопку Начать загрузку.

Шаг 2. Результат

После того, как загрузка выполнилась, происходит переадресация на страницу Магазин > Торговый каталог > Импорт данных и выводится информация о результатах загрузки данных.


Создание профилей импорта

Для облегчения доступа к импорту из файла определенного формата в некоторый каталог каждый из форматов предусматривает создание пользовательских профилей, содержащих информацию о файле с данными и о выбранном Вами типе инфоблоков.

Для создания профиля импорта выберите ссылку Добавить профиль в контекстном меню страницы Настройка импорта. Либо в контекстном меню любого стандартного профиля выберите пункт Добавить профиль.

Примечание. Пути для импорта различаются для систем с установленным модулем Интернет-магазин (sale) и без него. В первом случае это будет: Магазин > Настройки > Импорт данных, во втором: Магазин > Торговый каталог > Импорт данных.

Создание профилей импорта заключается в задании параметров загрузки данных. Дополнительно требуется указать имя нового профиля, которое будет показано в списке профилей.

Смотрите также:

  • Ручной импорт в формате CSV (профиль по умолчанию)
  • Ручной импорт в формате CommerceML (профиль по умолчанию)
  • Ручной импорт в формате CommerceML MySql Fast - BETA VERS (профиль по умолчанию)


Импорт из 1С (загрузка данных)

Импорт из "1С:Предприятие 8.х"

Начиная с версии продуктов 1С:Предприятие 8.1, редакция Управление торговлей (версия 10.3.2.4) и 1С-Битрикс: Управление сайтом версии 6.5 (редакции Малый бизнес, Бизнес) поставляются со встроенными процедурами взаимодействия и поддержкой двунаправленного обмена данными.

Обмен данными выполняется с использованием основанного на XML открытого стандарта обмена коммерческой информацией – CommerceML 2.0.

Процедура импорта каталога товаров из 1С подробно описана в курсе Интеграция с 1С [image].

Импорт из "1С:Предприятие 7.7"

"1С: Предприятие" версии 7.7 поддерживает выгрузку товаров в формате CommerceML версии 1.0. Загрузка каталога на сайт из XML-файла версии 1.0 осуществляется с помощью встроенного в модуль торгового каталога импорта CommerceML.


Отправить отзыв по этому разделу

Свойства заказа

  • Группы свойств
  • Создание и редактирование группы свойств
  • Список свойств
  • Создание и редактирование свойства заказа


Группы свойств

Страница Группы свойств (Магазин > Настройки > Свойства заказа > Группы свойств) служит для настройки групп свойств заказов. Данная группировка применяется при построении формы для ввода значений свойств заказа, что позволяет улучшить ее зрительное восприятие.
Показ группы свойств в форме заказа зависит от типа плательщика, выбранного покупателем, т.е. для каждого типа плательщика отображается самостоятельный набор групп свойств.

Форма поиска

С помощью данной формы вы можете выполнить поиск групп свойств заказа в соответствии с указанными условиями.

Поле | Описание
Тип плательщика | Поиск групп свойств по типу плательщика.

Чтобы отобрать группы свойств по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех групп свойств нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Новая группа | Переход к форме создания новой группы свойств.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список групп свойств

Поле | Описание
Колонка флажков | Поле предназначено для выбора групп свойств, к которым предполагается применить какое-либо правило или действие.
Действия Действия над группой свойств заказа:
  • Изменить группу- редактирование параметров группы свойств;
  • Удалить группу- удаление группы свойств.
ID | Идентификатор группы свойств.
Название | Название группы свойств, как оно будет показано клиенту магазина при оформлении заказа.
Тип плательщика | Тип плательщика, к которому привязана данная группа свойств.
Сорт. | Относительный "вес" группы свойств. Определяет порядок, в котором группы свойств будут выводиться при оформлении заказа.
Свойства | Ссылка для перехода к списку свойств, относящихся к данной группе.


Создание и редактирование группы свойств

Контекстная панель

Кнопка | Описание
Список групп свойств | Переход на страницу со списком групп свойств.
Создать новую группу | Переход к форме создания новой группы свойств. Кнопка отображается при редактировании существующей группы.
Удалить группу | Удаление редактируемой группы свойств. Кнопка отображается при редактировании существующей группы.

Форма редактирования

Поле | Описание
ID | Идентификатор группы свойств. Поле отображается при редактировании существующей группы.
Тип плательщика | Тип плательщика, к которому привязана данная группа свойств.
*Название | Название группы свойств, как оно будет показано клиенту магазина при оформлении заказа.
Индекс сортировки | Относительный "вес" группы свойств. Определяет порядок, в котором группы свойств будут выводиться при оформлении заказа.

* - поля, обязательные для заполнения.


Список свойств

Страница Свойства заказа (Магазин > Настройки > Свойства заказа > Список свойств) служит для настройки списка свойств заказа, значения которых должны быть указаны клиентом интернет-магазина при оформлении заказа. Набор свойств заказа зависит от типа плательщика, выбранного клиентом при оформлении заказа.

Форма поиска

С помощью данной формы вы можете выполнить поиск свойств заказа в соответствии с указанными условиями.

Поле | Описание
Тип плательщика | Поиск свойств заказа, заданных для определённого типа плательщика. Данное поле отображается, даже если фильтр свернут.
Тип свойства | Поиск свойств указанного типа (флажок, строка, список и т.д.).
Входит в профиль | Указывается, будут ли участвовать в поиске свойства, входящие в профиль покупателя.
Группа свойств | Позволяет провести поиск свойств по названию группы, к которой они относятся.
Код | Поиск свойства по мнемоническому коду.
Активность | Поиск свойств по признаку активности.
Служебное | Поиск свойств по указанию того, служебные ли они.

Чтобы отобрать свойства заказа по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех свойств нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Новое свойство | Переход к форме создания нового свойства заказа.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список свойств заказа

Поле | Описание
Колонка флажков | Поле предназначено для выбора свойств заказа, к которым предполагается применить какое-либо правило или действие.
Действия Действия над свойством заказа:
  • Изменить параметры свойства - редактирование свойства заказа;
  • Удалить свойство - удаление свойства заказа.
ID | Идентификатор свойства заказа.
Тип плательщика | Тип плательщика, которому это свойство будет предложено для заполнения при оформлении заказа.
Название | Название свойства, как оно будет показано клиенту магазина при оформлении заказа.
Код | Мнемонический код свойства.
Активность | Признак активности свойства.
Сортировка | Относительный вес свойства заказа.
Тип Тип свойства, может иметь следующие значения:
  • CHECKBOX - флажок;
  • TEXT - строка;
  • SELECT - выпадающий список выбора значения из предложенных вариантов;
  • MULTISELECT - список с возможностью множественного выбора;
  • TEXTAREA - текст;
  • LOCATION - местоположение;
  • RADIO - список переключателей.
Обяз. Обязательно ли это свойство к заполнению.

Свойства с установленными флагами Использовать как ... обязательны к заполнению вне зависимости от значения данного поля.

Группа | Группа свойств, к которой принадлежит данное свойство. Группировка свойств используется исключительно для удобства представления и заполнения свойств в заказе.
Профиль Определяет, входит ли свойство в профиль пользователя.

Если клиент уже делал заказы в магазине, то ему не обязательно будет при оформлении очередного заказа заполнять свойства, входящие в профиль пользователя. Клиент сможет выбрать один из сохраненных профилей для автоматического заполнения таких свойств заказа.

Клиент может редактировать свои профили в персональном разделе сайта. В профиль следует включать те свойства, которые обычно не меняются от заказа к заказу, либо имеют очень небольшой список вариантов (например, адрес доставки у клиента, как правило, один и его можно включить в профиль, а комплектация заказа обычно выбирается индивидуально для каждого заказа и ее включать в профиль не следует).
Служебное | Указание того, является ли свойство служебным.


Создание и редактирование свойства заказа

В данной форме вы можете задать или изменить значения полей, описывающих создаваемое или редактируемое свойство.

Контекстная панель

Кнопка | Описание
Список свойств заказа | Переход на страницу со списком свойств заказа.
Создать новое свойство | Переход к форме создания нового свойства для выбранного типа плательщика. Кнопка отображается при редактировании существующего свойства.
Удалить свойство | Удаление редактируемого свойства. Кнопка отображается при редактировании существующего свойства.

Вкладка Свойства заказа

Поле | Описание
Свойство
ID | Уникальный идентификатор. Отображается в режиме редактирования свойства.
Тип плательщика | Тип плательщика, которому это свойство будет предложено на заполнение.
Группа свойств Группа свойств, к которой принадлежит данное свойство. Группировка свойств используется исключительно для удобства представления и заполнения свойств в заказе.

Ссылка Группы свойств позволяет открыть в новом окне страницу со списком групп свойств заказа.
*Название | Название свойства, как оно будет показано клиенту магазина при оформлении заказа.
Мнемонический код Код, однозначно идентифицирующий свойство. Используется для идентификации объекта "свойство заказа" в системе.

Примечание: поле предназначено для использования разработчиками.

Активность | Признак активности. Активное свойство заказа может использоваться в работе интернет-магазина.
Служебное | Используется только в административной части. Пример: свойство для идентификатора оплаты.
Входит в профиль Определяет, входит ли свойство в профиль пользователя.

Если клиент уже делал заказы в магазине, то ему не обязательно будет при оформлении очередного заказа заполнять свойства, входящие в профиль пользователя. Клиент сможет выбрать один из сохраненных профилей для автоматического заполнения таких свойств заказа. Клиент может редактировать свои профили в персональном разделе сайта.

В профиль следует включать те свойства, которые обычно не меняются от заказа к заказу либо имеют очень небольшой список вариантов значений. Например, адрес доставки у клиента, как правило, один и его можно включить в профиль. Комплектация же заказа обычно выбирается индивидуально для каждого заказа и ее включать в профиль не следует.
Доступно в фильтре по заказам При отмеченной опции редактируемое свойство будет присутствовать в фильтре формы Заказы.

Примечание: множественное значение недоступно в фильтре.
Сортировка | Относительный "вес" свойства заказа. Используется при выводе данного свойства в общем списке свойств заказа.
Описание свойства | Текст для информирования клиента об особенностях заполнения этого свойства. Данный текст выводится рядом с полем ввода значения свойства.
Тип данных
*Тип Тип свойства, может иметь следующие значения:
  • STRING - строка;
  • NUMBER - число;
  • Y/N - да/нет;
  • ENUM - перечисление;
  • FILE - файл;
  • DATE - дата;
  • LOCATION - местоположение.
Обязательное Определяет, обязательно ли это свойство к заполнению.

Важно! Свойства с установленными флажками Использовать как... обязательны к заполнению, независимо от значения данного поля.
Множественное При отмеченной опции свойство является множественным.

Примечание: множественное значение недоступно в фильтре.
Значение по умолчанию | Значение свойства, указываемое по умолчанию.
Тип "Строка [STRING]"
Минимальная длина строки | Задается минимально допустимая длина строки. Используется для проверки строки, вводимой покупателем.
Максимальная длина строки | Задается максимально допустимая длина строки. Используется для проверки строки, вводимой покупателем.
Регулярное выражение для проверки | Указывается регулярное выражения для проверки строки, вводимой покупателем.
Много строк | [Y|N] при отмеченной опции отображается многострочное поле для заполнения покупателем.
Количество видимых символов | Ширина поля для одностроковых полей.
Использовать как название профиля [Y|N] Значение свойства будет использовано как название профиля пользователя.

Если свойство с флагом Использовать как название профиля для данного типа плательщика введено не будет, то новые профили будут называться как Профиль <дата>. Названием профиля может стать, например, свойство Фамилия получателя.
Использовать как имя плательщика | [Y|N] Значением свойства будет являться имя плательщика, которое будет проставляться в платежных документах.
Использовать как E-Mail | [Y|N] Опция определяет использовать ли значение свойства как E-mail покупателя.
Является телефоном | [Y|N] Опция определяет использовать ли значение свойства как телефон покупателя.
Использовать как почтовый индекс | [Y|N] Использовать как почтовый индекс покупателя для расчета стоимости доставки.
Является адресом | [Y|N] Опция определяет использовать ли значение свойства как адрес покупателя.
Тип "Число [NUMBER]"
Минимальное значение | Минимально допустимое значение свойства. Используется для проверки значения, вводимого покупателем.
Максимальное значение | Максимально допустимое значение свойства. Используется для проверки значения, вводимого покупателем.
Шаг Величина между допустимыми соседними значениями свойства. Используется для проверки значения, вводимого покупателем.

Например, в свойстве могут быть указаны только следующие значения: 3, 7, 11, 15. Тогда в поле Минимальное значение быть указано 3, в поле Максимальное значение - 15, а в поле Шаг - 4.
Тип "Перечисление [ENUM]"
Показывать как список элементов | [Y|N] При отмеченной опции будет показан как список элементов.
Количество видимых элементов | Высота поля для свойства.
список_значений Задается список возможных значений (вариантов выбора) свойства.
Поле | Описание
Код | Код значения свойства. Использовать только латиницу.
Название | Название (возможное значение свойства), которое будет показано клиенту.
Сорт. | Относительный "вес" значения, влияющий на положение значения в перечислении. Используется для упорядочивания значений.
Описание | Описание этого значения.
Удалить | Чтобы удалить значение свойства, установите флаг в это поле и нажмите кнопку Применить.
Тип "Файл [FILE]"
Максимальный размер файла в байтах | Указывается максимально допустимый размер файла в байтах.
Допустимые типы файлов | Перечисляются допустимые типы файлов.
Тип "Дата [DATE]"
Время | [Y|N] При отмеченной опции дата указывается вместе во временем.
Тип "Местоположение [LOCATION]"
Использовать как местоположение [Y|N] При отмеченной опции значение свойства будет использовано как местоположение покупателя для расчета стоимости доставки.

Примечание: создайте по одному свойству с флагами Использовать как местоположение для каждого типа плательщика, иначе система обработки служб доставки работать не будет.
Альтернативное поле ввода местоположения Указывается свойство заказа, которое будет использоваться как альтернативное поле для ввода местоположения, если такового нет в списке местоположений.

Поле доступно, если отмечена опция Использовать как местоположение.
Использовать как местоположение для налогов [Y|N] При отмеченной опции значение свойства будет использовано как местоположение покупателя для определения ставок налогов.

Примечание: создайте по одному свойству с флагом Использовать как местоположение для налогов для каждого типа плательщика, иначе ставки налогов определены не будут.

* - поля, обязательные для заполнения.

Вкладка Привязка свойства

Поле | Описание
Платежные системы | Указываются платежные системы, к которым должно быть привязано свойство заказа.
Службы доставки | Указываются службы доставки, с которыми связано свойство заказа.

Смотрите также

  • Создание свойства заказа


Отправить отзыв по этому разделу

Службы доставки

  • Список служб доставок
  • Создание и редактирование службы доставки
  • Список групп служб доставок
  • Создание и редактирование группы служб доставок
  • Добавление и редактирование дополнительной услуги
  • Создание и редактирование профиля


Список служб доставок

Форма Список служб доставок позволяет:

  • просматривать имеющиеся службы доставок;
  • переходить к добавлению или изменению службы доставки;
  • удалять службы доставки;

Форма поиска

С помощью данной формы вы можете выполнить поиск служб доставки в соответствии с указанными условиями. Кроме того, фильтр позволяет выполнить отбор по группам доставки, если в поле Тип указано Группа.

Поле | Описание
Название Поиск службы доставки по названию.

Данное поле отображается, даже если фильтр свернут.
Активность Указывается, какие службы будут участвовать в поиске:
  • да - в поиске будут участвовать только активные службы доставок;
  • нет - в поиске будут участвовать только неактивные службы доставок;
  • все - в поиске будут участвовать как активные, так и неактивные службы доставок.
Тип | Выбирается тип, доставки которого следует найти.
Группа | Поиск служб доставок по принадлежности к группе.
Сайт | Поиск служб доставок по доступности на сайте.

Чтобы отобрать группы или службы доставки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех записей нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Выбор типа доставки и переход к форме создания новой службы доставки.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список служб доставок

Поле | Описание
Колонка флажков | Поле предназначено для выбора служб доставок, к которым предполагается применить какое-либо правило или действие.
Действия Действия над службой доставки:
  • Копировать - создание новой службы доставки путем копирования параметров текущей службы;
  • Изменить - редактирование службы доставки;
  • Удалить - удаление службы доставки.
Название | Название службы доставки, как оно будет показано клиентам магазина при оформлении заказа.
Группа | Группа, к которой относится служба доставки.
ID | Идентификатор службы доставки.
Логотип | Логотип службы доставки.
Сортировка | Относительный "вес" службы доставки. Влияет на положение данной службы в общем списке.
Активность | Признак активности службы доставки. Неактивные службы не предлагаются для доставки товаров.
Разрешено изменение отгрузки | Флаг автоматического изменения состава отгрузки в начальном статусе при изменении заказа.
Тип | Тип службы доставки.
Сайты | Сайты, на которых доступна к использованию доставка.
Ставка НДС | Ставка НДС службы доставки.


Создание и редактирование службы доставки

Для создания и редактирования службы доставки используется одна и та же форма, но внешний вид ее несколько отличается в зависимости типа доставки. Закладки:

Общие настройки

Поле | Описание
ID | Идентификатор службы доставки. Отображается в режиме редактирования.
*Название | Название службы доставки, как оно будет показано клиентам магазина при оформлении заказа.
*Тип доставки | Тип службы доставки. Настраивается только при создании доставки из формы редактирования уже существующей службы доставки.
Активность | Признак активности службы доставки. Покупателям интернет-магазина будут доступны только активные службы доставки.
Сортировка | Относительный "вес" данной службы доставки. Используется при отображении службы в общем списке служб доставки.
Описание | Текст длиной до 250 символов, информирующий клиента об особых условиях доставки.
Группа | Группа, к которой привязана служба доставки. Ссылка Добавить служит для создания новой группы.
Логотип | Логотип службы доставки. Для добавления файла с логотипом служит кнопка Добавить файл. Удаление файла выполняется путем отметки одноименной опции и сохранения внесенных изменений.
Валюта | Валюта, в которой рассчитывается стоимость доставки.
Выбрать склады самовывоза | При отмеченной опции можно задать склады, с которых осуществляется самовывоз (см. поле ниже). Опция доступна только для настраиваемых служб доставок.
Склады самовывоза | Отмечаются склады, с которых возможен самовывоз товара. Поле доступно, если отмечена опция Выбрать склады самовывоза.
Автоматическое изменение отгрузки, находящейся в первоначальном статусе, при изменении заказа | При отмеченной опции состав отгрузки будет автоматически изменен, если отгрузка находится в первоначальном статусе и в состав заказа внесены изменения.
Ставка НДС | Указывается ставка НДС
Внешний код | Код, используемый для привязки к внешним источникам.

* - поля, обязательные для заполнения.

Настройки

На данной закладке выполняются настройки обработчика службы доставки. Набор полей зависит от типа службы доставки.

Поле | Описание
Закладка "Настройки обработчика" для настраиваемой службы доставки
Валюта | Для информации отображается валюта, в которой ведется расчет стоимости доставки (см. выполненные и сохраненные настройки на закладке Общие настройки).
Цена Сумма, которая добавляется к стоимости товаров в заказе для оплаты услуг службы доставки.
Если валюта цены отличается от валюты заказа, то происходит автоматический пересчет в валюту заказа по текущему курсу системы.
Сроки доставки Указывается период времени (в часах, днях, месяцах), в течение которого товар, после его передачи в службу доставки, будет доставлен клиенту.
Допустимо задание как диапазона значений, так и нижней или верхней границы срока доставки.
Закладка "Настройки обработчика" для автоматизированной службы доставки
Служба доставки | Название службы доставки и ее обработчика.
Описание | Описание обработчика службы доставки. Отображается только при редактировании существующей службы.
Наценка | Указывается величина наценки на стоимость доставки.
Тип наценки | Тип наценки на стоимость доставки: в % или в выбранной на закладке Общие настройки валюте.
Закладка "Настройки" для службы доставки Почта России
Тип службы доставки | Тип службы доставки. Поле не редактируется.
Токен авторизации | Токен авторизации, полученный с сайта Почты России.
Ключ авторизации | Ключ авторизации, полученный на сайте Почты России.
Точка сдачи | Выбирается место сдачи почтовых отправлений.
Показывать прецеденты невыкупа покупателя в форме заказа | При отмеченной опции будет выводиться [dw]информация о благонадёжности[/dw][di] [image] [/di] получателя (есть ли прецеденты невыкупа). Актуально для отправлений с наложенным платежом. Опция доступна с версии модуля Интернет-магазин v19.0.0.
Длина (мм) | Значение длины груза по умолчанию.
Ширина (мм) | Значение ширины груза по умолчанию.
Высота (мм) | Значение высоты груза по умолчанию.
Вес (г) | Вес груза по умолчанию.
Закладка "Настройки" для профиля службы доставки Почта России
Наименование типа профиля | Тип профиля службы доставки. Поле не редактируется.
Описание | Описание профиля.
Категория | Выбор категории профиля службы доставки.
Поддержка Он-лайн сервиса "Отправка" Параметр не редактируется. Галочка проставляется автоматически в зависимости от того, поддерживает ли данный тип отправления точка сдачи, к которой привязан пользователь.

Если галочка стоит, то такие доставки участвуют в транспортных заявках. В противном случае отгрузки не попадают в транспортные заявки, несмотря на то, что служба доставки Почта России.
Закладка "Настройки" для службы доставки СДЭК
Тип службы доставки | Тип службы доставки. Поле не редактируется.
Логин | Логин для запросов API калькуляции, полученный у СДЭК.
Пароль | Пароль для запросов API калькуляции, полученный у СДЭК.
Длина (мм) | Значение длины груза по умолчанию.
Ширина (мм) | Значение ширины груза по умолчанию.
Высота (мм) | Значение высоты груза по умолчанию.
Вес (г) | Вес груза по умолчанию.
Закладка "Настройка тарифов" для службы доставки по группам местоположений
Валюта | Для информации отображается валюта, в которой ведется расчет стоимости доставки (см. выполненные и сохраненные настройки на закладке Общие настройки).
По умолчанию | Стоимость по умолчанию для данной доставки (т.е. стоимость доставки для тех местоположений, которые не вошли в группы).
название_группы_местоположений | Стоимость данной доставки для данной группы местоположений.
Закладка "Настройки" для службы доставки СПСР-ЭКСПРЕСС
Рассчитывать стоимость сразу | При отмеченной опции стоимость доставки будет рассчитываться сразу.
Вес отгрузки по умолчанию (грамм) | Указывается значение величины веса по умолчанию.
Страхование объявления / объявленная стоимость | Указывается способ страхования груза.
Характер груза | Выбирается тип груза.
Логин | Логин аккаунта на сайте службы СПСР-ЭКСПРЕСС.
Пароль | Пароль аккаунта на сайте службы СПСР-ЭКСПРЕСС.
Индивидуальный клиентский номер | Номер для идентификации клиента, получаемый в СПСР-ЭКСПРЕСС после заключения договора.
Закладка "Настройки" для службы доставки DPD
Тип службы доставки | Служба доставки DPD (автоматически заполненное неизменяемое поле)
*Клиентский номер в системе DPD (номер вашего договора с DPD) | Указывается номер договора с DPD, полученный у менеджера DPD.
*Уникальный ключ для авторизации, полученный у сотрудника DPD | Указывается уникальный ключ для авторизации, полученный в личном кабинете DPD или у менеджера.
Место передачи груза DPD Выбирается место передачи груза в DPD:
  • Склад интернет-магазина
  • Пункт приема DPD
Длина (мм) | Значение длины груза по умолчанию.
Ширина (мм) | Значение ширины груза по умолчанию.
Высота (мм) | Значение высоты груза по умолчанию.
Вес (г) | Вес груза по умолчанию.

* - поля, обязательные для заполнения.

Профили

Данная закладка доступна только при редактировании параметров уже сохраненной любой автоматизированной службы доставки, службы доставки Почта России, СДЭК, СПСР-ЭКСПРЕСС и DPD.

Поле | Описание
кнопка Добавить профиль | Выполняет переход к добавлению нового профиля текущей службы доставки.
кнопка Настроить | Позволяет перейти к диалогу настройки внешнего вида таблицы со списком профилей.
таблица со списком профилей
Поле | Описание
Действия Действия над профилем:
  • Копировать - переход к форме добавления нового профиля путем копирования параметров текущего;
  • Редактировать - переход к форме редактирования профиля;
  • Удалить - удаление профиля.
ID | Идентификатор профиля службы доставки.
Название | Название профиля.
Активность | Признак активности профиля службы доставки. Покупателям интернет-магазина будут доступны только активные профили.
Логотип | Логотип профиля службы доставки.

Ограничения

На закладке задаются ограничения по использованию текущей службы доставки.

Поле | Описание
кнопка Добавить ограничение Служит для добавления ограничения путем заполнения данных во всплывающей форме. Ограничения могут быть:
  • исключить местоположения (профиль будет доступен для всех местоположений, кроме указанных);
  • по весу;
  • по группам пользователей;
  • по категории товара;
  • по конкретным товарам;
  • по максимальному размеру;
  • по максимальным размерам;
  • по местоположению (профиль будет доступен только для указанных местоположений);
  • по общей стоимости товаров;
  • по платёжным системам;
  • по публичной части (отображать ли профиль в публичной части сайта, либо же он доступен только в панели администратора);
  • по сайтам;
  • по типу плательщика.
кнопка Настроить | Позволяет перейти к диалогу настройки внешнего вида таблицы со списком ограничений.
таблица со списком ограничений
Поле | Описание
Действия Действия над ограничением:
  • Редактировать - редактирование параметров ограничения во всплывающем окне;
  • Удалить - удаление ограничения.
ID | Идентификатор ограничения.
Сортировка | Относительный "вес" ограничения.
Тип ограничения | Тип ограничения.
Параметры | Параметры ограничения.

Дополнительные услуги

Данная закладка доступна для настраиваемых служб доставок, службы доставки СДЭК, СПСР-ЭКСПРЕСС, DPD и по группам местоположений.

Автоматизированная служба ПЭК также имеет закладку с названием Дополнительные услуги, но ее описание смотрите ниже, поскольку она существенно отличается от текущей закладки.

Поле | Описание
кнопка Добавить доп. услугу | Выполняет переход к форме добавления дополнительной услуги.
кнопка Настроить | Позволяет перейти к диалогу настройки внешнего вида таблицы со списком услуг.
таблица со списком услуг
Поле | Описание
Действия Действия над услугой:
  • Редактировать - переход к форме редактирования дополнительной услуги;
  • Удалить - удаление дополнительной услуги.
Идентификатор | Идентификатор услуги.
Наименование | Название дополнительной услуги.
Сортировка | Относительный "вес" услуги.
Активность | Признак активности дополнительной услуги. Покупателям интернет-магазина будут доступны только активные услуги.
Тип | Тип услуги: список услуг, количественная услуга или единичная услуга.
Описание | Описание дополнительной услуги.

Прочие закладки автоматизированных служб, службы доставки Почта России, СДЭК, СПСР-ЭКСПРЕСС и DPD

Служба Закладка
DHL (USA) [dhlusa] Параметры отправлений
Поле | Описание
Тип упаковки | Выбирается один из возможных типов упаковки: DHL Express Letter, DHL Other Packaging или Собственная упаковка.
UPS [ups] Файлы таблиц
Поле | Описание
CSV-файл с зонами доставки | Указывается адрес к CSV-файлу с зонами доставки.
CSV-файл с тарифами доставки | Указывается адрес к CSV-файлу с тарифами доставки.
Новая почта [ua_post] Общие тарифы
Поле | Описание
Тариф на услугу доставки по технологии "Склад-Склад"
Стоимость оформления | Стоимость оформления доставки.
Цена за 1 кг | Цена за 1 кг заказа.
Доплата к услуге "Склад-Склад" за услугу "Склад-Дверь" или "Дверь-Склад"
весовые интервалы | Для каждого весового интервала указывается стоимость доплаты.
Тариф на услугу доставки "Дверь-Дверь"
весовые интервалы | Для каждого весового интервала указывается стоимость доставки по данной услуге.
Комиссия за объявленную ценность
Размер комиссии % | Размер процента комиссии за объявленную ценность заказа.
Минимальная сумма комиссии | Минимально взимаемая сумма комиссии.
ПЭК [pecom] Настройки обмена
Поле | Описание
Имя пользователя | Имя пользователя, используемое при регистрации в ПЭК.
Ключ для доступа к API | Ключ для доступа к API, выданный при подписании договора с ПЭК.
Наименование организации | Наименование организации.
ИНН | ИНН организации.
Город отправки (местоположения ПЭК) | Указывается город отправки заказа компанией ПЭК.
Контактный телефон | Контактный телефон.
Форма оплаты | Выбирается способ внесения оплаты: банк или касса.
Дополнительные услуги
Поле | Описание
Забор груза
Разрешить забор груза | [Y|N] При отмеченной опции ПЭК будет самостоятельно забирать груз со склада магазина.
Растентовка | [Y|N] При отмеченной опции будет выполняться растентовка кузова.
Использовать гидролифт или другую спецтехнику | [Y|N] При отмеченной опции будет использоваться гидролифт или другая спецтехника.
Доставка груза
Разрешить доставку груза | [Y|N] При отмеченной опции ПЭК будет самостоятельно доставлять груз до клиента, в противном случае клиент должен будет забрать его из офиса ПЭК.
Растентовка | [Y|N] При отмеченной опции будет выполняться растентовка кузова.
Использовать гидролифт или другую спецтехнику | [Y|N] При отмеченной опции будет использоваться гидролифт или другая спецтехника.
Плательщик | Выбирается способ взимания оплаты за доставку: через магазин или отдельный счет напрямую покупателю.
Прочее
Пломбировка груза | [Y|N] При отмеченной опции будет выполняться пломбировка груза.
Количество пломб | Указывается количество пломб для пломбировки груза.
Плательщик | Выбирается способ взимания оплаты за пломбировку: через магазин или отдельный счет напрямую покупателю.
Запалечивание груза | [Y|N] При отмеченной опции будет выполняться запалечивание груза.
Плательщик | Выбирается способ взимания оплаты за запалечивание: через магазин или отдельный счет напрямую покупателю.
Страховка | [Y|N] При отмеченной опции будет оформляться страховка груза.
Плательщик | Выбирается способ взимания оплаты за страховку: через магазин или отдельный счет напрямую покупателю.
Жесткая упаковка | [Y|N] При отмеченной опции груз будет упакован в жесткую упаковку.
Плательщик | Выбирается способ взимания оплаты за жесткую упаковку: через магазин или отдельный счет напрямую покупателю.
Почта России Трекинг
Поле | Описание
Параметры
Логин | Логин аккаунта на сайте "Почта России", используемого для подключения к сервису трекинга.
Пароль | Пароль аккаунта на сайте "Почта России", используемого для подключения к сервису трекинга.
Местоположения
Поле | Описание
Местоположений в магазине | Количество местоположений в магазине.
Местоположений поддерживается обработчиком | Количество местоположений, поддерживаемых обработчиком.
Сопоставлено | Количество сопоставленных местоположений.
кнопка Сопоставить | Запуск процесса сопоставления местоположений.
Почта России [rus_post]
устаревший обработчик 		Почтовые зоны
Поле | Описание
Почтовые зоны по умолчанию | По ссылке установить почтовые зоны будут настроены значениями по умолчанию.
название_региона | Для каждого региона указывается соответствующий ему пояс.
Общие тарифы
Поле | Описание
Посылка до 500 гр. (стандартная упаковка до 425х265х380), руб.
Пояс номер_пояса | Указывается стоимость посылки для каждого пояса.
За каждые следующие 500 гр. ( до 10 кг стандартная упаковка до 425x265x380), руб.
Пояс номер_пояса | Для каждого пояса указывается цена за каждые следующие 500 гр. посылки.
Дополнительные услуги
Разрешить тяжеловесные посылки (от 10 до 20 кг включительно, в стандартной упаковке, с максимальным размером 425x265x380 мм) | При отмеченной опции будут доступны тяжеловесные посылки.
Наценка за тяжеловесные посылки % | Величина наценки за тяжеловесные посылки в процентах.
Разрешить посылки с отметкой "Осторожно" | При отмеченной опции разрешены посылки с отметкой "Осторожно".
Наценка за посылки с отметкой "Осторожно" % | Величина наценки за посылки с отметкой "Осторожно".
Разрешить пересылку посылок с объявленной ценностью | При отмеченной опции разрешены посылки с объявленной ценностью.
Наценка за пересылку посылок с объявленной ценностью (за каждый полный или неполный 1 рубль оценочной стоимости) руб. | Величина наценки за посылки с объявленной ценностью.
Трекинг
Поле | Описание
Параметры
Логин | Логин аккаунта на сайте "Почта России", используемого для подключения к сервису отслеживания отправлений.
Пароль | Пароль аккаунта на сайте "Почта России", используемого для подключения к сервису отслеживания отправлений.
СДЭК Местоположения
Поле | Описание
Местоположений в магазине | Количество местоположений в магазине.
Местоположений поддерживается обработчиком | Количество местоположений, поддерживаемых обработчиком.
Сопоставлено | Количество сопоставленных местоположений.
кнопка Сопоставить | Запуск процесса сопоставления местоположений.
СПСР-ЭКСПРЕСС Трэкинг
Поле | Описание
Описание | Описание системы трэкинга данной службы доставки.
Бизнес смыслы
Поле | Описание
Авторизация службы доставки СПСР (для холдинга) | Из бизнес-смыслов заполняются логин, пароль и индивидуальный клиентский номер. Возможно заполнение как для всех типов плательщиков (вкладка По умолчанию), так и для разных типов плательщиков.
DPD Трэкинг
Описание
Cистема трэкинга службы доставки "DPD". Дополнительная настройка не требуется
Местоположения
Поле | Описание
Местоположений в магазине | Количество местоположений в магазине.
Местоположений поддерживается обработчиком | Количество местоположений, поддерживаемых обработчиком.
Сопоставлено | Количество сопоставленных местоположений.
кнопка Сопоставить | Запуск процесса сопоставления местоположений.


Список групп служб доставок

Форма со списком групп отображается только в том случае, если установлено значение Группа в поле Тип формы поиска. В противном случае отображается форма со списком служб доставок.

Форма поиска

С помощью данной формы вы можете выполнить поиск групп в соответствии с указанными условиями.

Поле | Описание
Название Поиск группы по названию.

Данное поле отображается, даже если фильтр свернут.
Активность Указывается, какие группы будут участвовать в поиске:
  • да - в поиске будут участвовать только активные группы;
  • нет - в поиске будут участвовать только неактивные группы;
  • все - в поиске будут участвовать как активные, так и неактивные группы.
Тип | В поле обязательно указывается значение Группа, иначе будет выполняться поиск служб доставок.
Группа | Данное поле для отбора групп настраивать не нужно, иначе поиск по группам не будет выполнен.

Чтобы отобрать группы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех записей нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания новой группы служб доставок.
Список служб доставок | Переход к просмотру списка служб доставок.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список групп

Поле | Описание
Колонка флажков | Поле предназначено для выбора служб групп, к которым предполагается применить какое-либо правило или действие.
Действия Действия над группой:
  • Копировать - создание новой группы служб доставок путем копирования параметров текущей группы;
  • Изменить - редактирование группы;
  • Удалить - удаление группы.
Название | Название группы.
ID | Идентификатор группы.
Сортировка | Относительный "вес" группы. Влияет на положение данной группы в общем списке.
Активность | Признак активности группы.


Создание и редактирование группы служб доставок

Контекстная панель

Кнопка | Описание
Список групп | Переход на страницу со списком служб доставок.
Добавить группу | Переход на страницу с формой создания новой группы. Кнопка отображается при редактировании уже группы.
Удалить группу | Удаление редактируемой группы. Кнопка отображается при редактировании уже существующей группы.

Закладка "Общие настройки"

Поле | Описание
ID | Идентификатор группы служб доставок. Отображается в режиме редактирования.
*Название | Название группы служб доставок.
Активность | Признак активности группы.
Сортировка | Относительный "вес" группы служб доставки. Влияет на положение данной группы в общем списке.
Описание | Описание группы служб доставок.

* - поля, обязательные для заполнения.


Добавление и редактирование дополнительной услуги

Контекстная панель

Кнопка | Описание
В службу доставки | Переход на страницу с формой редактирования службы доставки.

Форма редактирования

Поле | Описание
*Тип | Выбирается тип дополнительной услуги.
*Название | Название дополнительной услуги.
Описание | Описание дополнительной услуги.
Права | Отметка опции Менеджер и/или Клиент дает возможность редактировать наличие/количество услуги менеджеру или клиенту соответственно.
Список Указывается название и цена услуги, входящей в перечень данной дополнительной услуги.

Данное поле доступно, если в качестве типа услуги выбрано Список услуг.
Цена за шт. Цена услуги за одну штуку.

Данное поле доступно, если в качестве типа услуги выбрано Количественная услуга.
Цена за услугу Цена единичной услуги.

Данное поле доступно, если в качестве типа услуги выбрано Единичная услуга.
По умолчанию Если в качестве типа услуги выбрано:
  • Список услуг, то в выпадающем списке указывается услуга, которая будет предоставляться по умолчанию.
  • Количественная услуга, то в поле указывается количество данной услуги, оказываемой по умолчанию.
  • Единичная услуга, то при установке флага услуга будет оказываться по умолчанию при выборе покупателем текущего способа доставки.
Данное поле доступно при редактировании параметров уже сохраненной услуги.
Активность | Признак активности услуги. Только активные услуги будут доступны покупателям.
Сортировка | Относительный "вес" услуги. Служит для определения положения услуги в общем списке дополнительных услуг.
Мнемонический код | Символьный код услуги.

* - поля, обязательные для заполнения.


Создание и редактирование профиля

Каждая автоматизированная служба доставки имеет несколько профилей. Форма добавления/редактирования профиля повторяет форму создания/редактирования самой службы. Поэтому описание необходимых вам параметров смотрите на странице Создание и редактирования службы доставки.


Местоположения

В данной главе описан функционал местоположений, доступных с версии 14.10.1 модуля Интернет-магазин. Если у вас на сайте используются местоположения старой схемы, то документацию по ним смотрите в главе Местоположения 1.0.

Смотрите также:

  • Как загрузить местоположения для функционирования служб доставки
  • Как создать местоположение
  • Создание новой группы местоположений
  • Типы местоположений


Список местоположений

С помощью страницы Список местоположений вы можете управлять общим списком местоположений, дочерними местоположениями каждого местоположения (при наличии).

Форма поиска

С помощью данной формы вы можете выполнить поиск местоположений в соответствии с указанными условиями.

Поле | Описание
ID (от и до) | Поиск местоположений по интервалу их идентификаторов.
Символьный код | Поиск местоположений по символьному коду.
Сортировка (от и до) | Поле служит для фильтрации местоположений по интервалу значений их сортировки.
Родительское местоположение | Отбор местоположений по идентификатору родительского местоположения.
Тип (от и до) | Отбор местоположений по типу: Страна, Регион, Город и т.д.
Широта | Поиск местоположения по широте.
Долгота | Поиск местоположения по долготе.
Название (<язык_интерфейса>) | Поиск местоположений по названию.
Краткое название (<язык_интерфейса>) | Поиск местоположений по краткому названию.
Уровень | Указывается уровень для поиска местоположений.

Чтобы отобрать местоположения по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех местоположений нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить местоположение | Переход к форме создания нового местоположения.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список местоположений

Поле | Описание
Колонка флажков | Поле предназначено для выбора местоположений, к которым предполагается применить какое-либо правило или действие.
Действия Действия над местоположением:
  • Редактировать местоположение - переход к форме редактирования местоположения.
  • Копировать местоположение - переход к форме добавления местоположения, в которую будут скопированы параметры текущего местоположения.
  • Удалить местоположение- удаление местоположения.
ID | Идентификатор местоположения.
Сортировка | Относительный "вес" местоположения. Влияет на размещение местоположения в общем списке.
Тип | Тип местоположения.
Широта | Широта местоположения.
Долгота | Долгота местоположения.
Название (<язык_интерфейса>) | Название местоположения, указанное для данного языка интерфейса.
Краткое название (<язык_интерфейса>) | Краткое название местоположения, указанное для данного языка интерфейса.

Смотрите также

  • Документация по местоположениям старой схемы


Создание и редактирование местоположения

Данная форма служит для создания нового и управления параметрами уже существующего местоположения.

Контекстная панель

Кнопка | Описание
Вернуться к списку | Переход на страницу со списком местоположений.

Закладка Параметры местоположения

Поле | Описание
ID | Уникальный идентификатор местоположения. Отображается только при редактировании существующего местоположения.
*Символьный код | Уникальный символьный код местоположения.
Сортировка | Относительный "вес" местоположения. Влияет на размещение местоположения в общем списке. Если для нескольких местоположений задано одинаковое значение данного поля, то сортировка производится по алфавиту.
Родительское местоположение | Указывается родительское местоположение по отношению к данному.
*Тип | Из значений выпадающего списка выбирается тип текущего местоположения.
Геоданные
Широта | Широта местоположения.
Долгота | Долгота местоположения.
Языковые названия (<язык_интерфейса>)
*Название | Указывается полное наименование местоположения для каждого языка, используемого в системе.
*Краткое название | Задается краткое наименование страны для каждого языка, используемого в системе.

* - поля, обязательные для заполнения.

Закладка Внешние данные

Таблица внешних данных
ID | Идентификатор внешнего кода местоположения.
Код сервиса | Код внешнего сервиса, с которым система обменивается данными по местоположениям (например, код службы доставки).
Внешний код | Код местоположения в системе текущего внешнего сервиса.
Удал. | Служит для удаления заданного внешнего кода.
Кнопка "Еще" Кнопка служит для добавления новых строк в таблицу внешних данных.

Смотрите также

  • Документация по местоположениям старой схемы


Группы местоположений

Страница Группы местоположений (Магазин > Настройки > Местоположения > Группы местоположений) служит для объединения местоположений в группы. Это облегчает работу с настройкой служб доставки. Вы можете создать группу местоположений и привязать к ней все службы доставки, которые осуществляют доставку в местоположения этой группы.

Форма поиска

С помощью данной формы вы можете выполнить поиск групп местоположений в соответствии с указанными условиями.

Поле | Описание
ID (от и до) | Поиск групп по интервалу их идентификаторов.
Символьный код | Поиск групп местоположений по символьному коду.
Сортировка (от и до) | Поле служит для фильтрации групп по интервалу значений их сортировки.
Название (<язык_интерфейса>) | Поиск группы по названию на данном языке интерфейса.

Чтобы отобрать группы местоположений по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех групп местоположений нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить группу | Переход к форме создания новой группы местоположений.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список групп местоположений

Поле | Описание
Колонка флажков | Поле предназначено для выбора групп местоположений, к которым предполагается применить какое-либо правило или действие.
Действия Действия над группой местоположений:
  • Редактировать группу - переход к форме редактирования группы местоположений.
  • Копировать группу - переход к форме добавления группы местоположений, в которую будут скопированы параметры текущей группы.
  • Удалить группу - удаление группы местоположений. Удаление группы не влечет за собой удаление местоположений, входящих в эту группу.
ID | Идентификатор группы в системе.
Символьный код | Символьный код группы местоположений.
Сортировка | Относительный "вес", влияющий на положение группы в общем списке.
Название (<язык_интерфейса>) | Название группы местоположений на данном языке интерфейса.

Смотрите также

  • Документация по местоположениям старой схемы


Создание и редактирование группы местоположений

Данная форма служит для задания свойств новой и редактирования параметров уже существующей группы местоположений.

Контекстная панель

Кнопка | Описание
Вернуться к списку | Переход на страницу со списком групп местоположений.

Поля формы

Поле | Описание
ID | Уникальный идентификатор группы местоположений. Отображается только при редактировании существующей группы местоположений.
*Символьный код | Символьный код группы.
Сортировка | Относительный "вес", влияющий на положение данной группы местоположений в общем списке.
Языковые названия (<язык_интерфейса>)
*Название | Указывается наименование группы местоположений для каждого языка, используемого в системе.
Выбор местоположения
Доступные местоположения | В данной секции представлены все доступные в системе местоположения. Поиск необходимых местоположений для текущей группы можно осуществлять с помощью строки поиска или с помощью дерева местоположений. Те местоположения, которые необходимо перенести в список выбранных, следует отметить флагом и нажать кнопку >.
Выбранные местоположения | В данной секции отображается список местоположений, которые будут входить в текущую группу. Для быстрой очистки списка служит одноименная ссылка. Чтобы убрать из списка лишь некоторые местоположения, следует отметить их флагом и нажать кнопку <

* - поля, обязательные для заполнения.

Смотрите также

  • Документация по местоположениям старой схемы


Местоположения для сайтов

Страница Местоположения для сайтов (Магазин > Настройки > Местоположения > Местоположения для сайтов) служит для настройки привязки местоположений к сайтам системы.

Контекстная панель

Кнопка | Описание
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список сайтов

Поле | Описание
Действия Действия над сайтом:
  • Редактировать список местоположений - переход к форме редактирования списка местоположений для сайта.
Название сайта | Название сайта.

Смотрите также

  • Документация по местоположениям старой схемы


Выбор местоположений для сайта

Данная форма служит для привязки местоположений к сайту.

Контекстная панель

Кнопка | Описание
Вернуться к списку | Переход на страницу со списком привязок местоположений к сайтам.

Поля формы

Поле | Описание
Выбор местоположения
Доступные местоположения | В данной секции представлены все доступные в системе местоположения и созданные группы местоположений. Поиск необходимых местоположений для текущего сайта можно осуществлять с помощью строки поиска или с помощью дерева местоположений. Те местоположения и/или группы местоположений, которые необходимо перенести в список выбранных, следует отметить флагом и нажать кнопку >.
Выбранные местоположения | В данной секции отображается список из местоположений и групп, которые будут привязаны к текущему сайту. Для быстрой очистки списка служит одноименная ссылка. Чтобы убрать из списка лишь некоторые местоположения и/или группы, следует отметить их флагом и нажать кнопку <.

Смотрите также

  • Документация по местоположениям старой схемы


Избранные местоположения

Страница Избранные местоположения (Магазин > Настройки > Местоположения > Избранные местоположения) служит для настройки избранных местоположений для каждого сайта системы. Избранные местоположения выводятся отдельно для быстрого их выбора на странице оформления заказа.

Контекстная панель

Кнопка | Описание
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список сайтов

Поле | Описание
Действия Действия над сайтом:
  • Редактировать список местоположений - переход к форме редактирования списка избранных местоположений для сайта.
Название сайта | Название сайта.
Количество местоположений | Количество избранных местоположений для сайта.

Смотрите также

  • Документация по местоположениям старой схемы


Настройка избранных местоположений

Данная форма служит для выбора избранных местоположений для сайта.

Контекстная панель

Кнопка | Описание
Вернуться к списку | Переход на страницу со списком привязок избранных местоположений к сайтам.

Поля формы

Поле | Описание
Местоположение | Указывается местоположение, которое является избранным.
Сортировка | Относительный "вес", влияющий на положение данного местоположения в общем списке избранных местоположений.
Удал. | При отмеченной опции местоположение будет удалено из избранных (само местоположение из системы не удаляется). Опция доступна только для уже существующих избранных местоположений.

Смотрите также

  • Документация по местоположениям старой схемы


Типы местоположений

Страница Типы местоположений (Магазин > Настройки > Местоположения > Типы местоположений) служит для настройки типов местоположений.

Форма поиска

С помощью данной формы вы можете выполнить поиск типов местоположений в соответствии с указанными условиями.

Поле | Описание
ID (от и до) | Поиск типов местоположений по интервалу их идентификаторов.
Символьный код | Поиск типов по символьному коду.
Уровень вложенности | Поиск типов по их расположению в структуре относительно самого "крупного" созданного типа. Параметр доступен для Местоположений 2.0.
Приоритет вывода | Поле служит для фильтрации типов местоположений по интервалу значений их сортировки.
Название (<язык_интерфейса>) | Поиск типов местоположений по названию на данном языке интерфейса.

Чтобы отобрать типы местоположений по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех типов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить тип | Переход к форме создания нового типа местоположений.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список типов местоположений

Поле | Описание
Колонка флажков | Поле предназначено для выбора типов местоположений, к которым предполагается применить какое-либо правило или действие.
Действия Действия над местоположением:
  • Редактировать тип - переход к форме редактирования типа местоположений.
  • Копировать тип - переход к форме добавления типа местоположения, в которую будут скопированы параметры текущего типа.
  • Удалить тип- удаление типа местоположений.
ID | Идентификатор типа местоположений.
Сортировка | Относительный "вес" типа местоположений. Влияет на размещение типов в общем списке.
Название (<язык_интерфейса>) | Название типа местоположений, указанное на данном языке интерфейса.

Смотрите также

  • Документация по местоположениям старой схемы


Создание и редактирование типа местоположения

Данная форма служит для создания нового и редактирования параметров уже существующего типа местоположений.

Контекстная панель

Кнопка | Описание
Вернуться к списку | Переход на страницу со списком типов местоположений.

Поля формы

Поле | Описание
ID | Идентификатор типа местоположений. Отображается только при редактировании существующего типа.
*Символьный код | Символьный код типа местоположений.
**Уровень вложенности | Параметр, определяющий положение создаваемого типа местоположений в структуре относительно самого "крупного" созданного типа (например, относительно типа Страна). Чем меньше территориальная единица создаваемого типа местоположений – тем [dw]больше[/dw][di] [image] [/di] уровень вложенности.
Приоритет вывода | Относительный "вес", влияющий на положение данного типа местоположений в общем списке.
Языковые названия (<язык_интерфейса>)
*Название | Указывается наименование типа местоположений для каждого языка, используемого в системе.

* - поля, обязательные для заполнения.

** - параметр доступен для Местоположений 2.0.

Смотрите также

  • Документация по местоположениям старой схемы


Внешние сервисы

Страница Внешние сервисы (Магазин > Настройки > Местоположения > Внешние сервисы) служит для настройки списка внешних сервисов, используемых для местоположений.

Форма поиска

С помощью данной формы вы можете выполнить поиск сервисов в соответствии с указанными условиями.

Поле | Описание
ID (от и до) | Поиск сервисов по интервалу их идентификаторов.
Код сервиса | Поиск внешнего сервиса, с которым система обменивается данными по местоположениям (например, службы доставки), по его коду.

Чтобы отобрать сервисы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех сервисов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить сервис | Переход к форме создания нового сервиса.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список сервисов

Поле | Описание
Колонка флажков | Поле предназначено для выбора сервисов, к которым предполагается применить какое-либо правило или действие.
Действия Действия над местоположением:
  • Редактировать сервис - переход к форме редактирования внешнего сервиса.
  • Копировать сервис - переход к форме добавления внешнего сервиса, в которую будут скопированы параметры текущего сервиса.
  • Удалить сервис- удаление сервиса.
ID | Идентификатор внешнего сервиса.
Код сервиса | Код внешнего сервиса.

Смотрите также

  • Документация по местоположениям старой схемы


Создание и редактирование внешнего сервиса

Данная форма служит для создания нового и редактирования параметров уже существующего внешнего сервиса местоположений.

Контекстная панель

Кнопка | Описание
Вернуться к списку | Переход на страницу со списком внешних сервисов.

Поля формы

Поле | Описание
ID | Идентификатор сервиса. Отображается только при редактировании существующего сервиса.
*Код сервиса | Код внешнего сервиса, с которым система обменивается данными по местоположениям (например, код службы доставки).

* - поля, обязательные для заполнения.

Смотрите также

  • Документация по местоположениям старой схемы


Импорт местоположений

Закладки

Важно! Если вы используете старую схему местоположений, то описание страницы импорта смотрите здесь.

Страница Импорт местоположений (Магазин > Настройки > Местоположения > Импорт местоположений) предназначена для импорта местоположений, а также для быстрой очистки всего списка местоположений.

Импорт местоположений

Поле | Описание
Выбор источника местоположений
Источник местоположений Выбирается источник загрузки местоположений:
  • с удаленного сервера - при этом необходимо отметить нужные вам страны для загрузки;
  • из файла - следует указать файл с помощью кнопки Добавить файл, а также заранее вручную должны быть созданы необходимые типы местоположений и внешние сервисы.
Выбор дополнительных данных
*Почтовые индексы (ZIP-коды) | При отмеченной опции в систему будет добавлен внешний сервис ZIP (если он не был добавлен ранее) и будут загружены почтовые индексы для местоположений.
*Коды Яндекс.Маркет | При отмеченной опции в систему будет добавлен внешний сервис YAMARKET (если он не был добавлен ранее) и будут загружены коды Яндекс.Маркет для местоположений.
Выбор параметров импорта местоположений
*Загружать местоположения до | Указывается до какого включительно типа местоположений загружать местоположения стран в систему.
*Набор местоположений Выбирается набор местоположений, который нужно загрузить:
  • стандартный - только крупные регионы и города России;
  • расширенный - полный импорт с учетом мелким городов, сел и т.д.
*Не загружать округа | При отмеченной опции местоположения типа Округ не будут загружаться в систему. Таким образом, местоложения типа Область будут дочерними непосредственно для местоположений типа Страна.
Удалить все существующие местоположения | При отмеченной опции все существующие местоположения будут удалены.
Длина шага, секунды | Указывается длина одного шага загрузки местоположений в секундах.
*Поддерживать структурную целостность | При отмеченной опции будет поддерживаться структурная целостность местоположений. Таким образом, если некоторое местоположение А уже есть в системе, а затем импортируется более крупное по отношению к нему местоположение Б, то автоматически имеющееся местоположение А будет привязано к новому местоположению Б.
Кнопка Начать импорт
Кнопка служит для запуска процесса импорта местоположений в систему.

* - данные параметры доступны только при загрузке местоположений с сервера.

Очистить список местоположений

Расположенная на закладке кнопка Удаление всех местоположений служит для очистки всей базы местоположений из системы.

Пример файла для загрузки местоположений

Важно! Файл должен быть создан в кодировке UTF-8.

CODE;PARENT_CODE;TYPE_CODE;NAME.RU.NAME;EXT.YAMARKET.0;EXT.ZIP.0
kl00001;;REGION;Калининградская область;10857;
kl00011;kl00001;CITY;Калининград;22;236020
kl00021;kl00001;SUBREGION;Гусевский район;;
kl00022;kl00021;CITY;Гусев;20138;238050
kl00031;kl00001;SUBREGION;Балтийский район;;
kl00032;kl00031;CITY;Приморск;20578;238510
kl00033;kl00031;CITY;Балтийск;10858;238520
kl00041;kl00001;SUBREGION;Зеленоградский район;;
kl00042;kl00041;CITY;Зеленоградск;20139;238326
kl00051;kl00001;SUBREGION;Краснознаменский район;;
kl00052;kl00051;CITY;Краснознаменск;20140;238730
kl00061;kl00001;SUBREGION;Неманский район;;
kl00062;kl00061;CITY;Неман;20141;238710
kl00071;kl00001;SUBREGION;Гвардейский район;;
kl00072;kl00071;CITY;Неман;20136;238210
kl00081;kl00001;SUBREGION;Багратионовский район;;
kl00082;kl00081;CITY;Багратионовск;20135;238420

В первой строке указываются названия колонок. Первые три колонки являются обязательными. Первая колонка - CODE - символьный код местоположения, затем идет колонка PARENT_CODE - символьный код родительского местоположения. Следующая колонка - TYPE_CODE - тип местоположения.

Примечание: необходимые типы местоположений должны быть созданы заранеее.

Следующие колонки - это колонки NAME.LANG.NAME с названием местоположения для языка LANG (где LANG - это идентификатор языка в системе). В файле обязательно должна быть колонка NAME.RU.NAME, а колонки для остальных языков интерфейса задавать не обязательно (названия для других языков будут созданы с применением транслита автоматически).

Затем идут колонки для созданных в системе внешних сервисов - EXT.CODE.N, где CODE - код внешнего сервиса, а N - номер колонки (нумерация начинается с нуля) для значения внешнего сервиса с кодом CODE (для местоположения может быть задано несколько значений каждого внешнего сервиса).

В остальных строках файла указываются значения загружаемых данных.

Смотрите также

Смотрите также

  • Документация по местоположениям старой схемы


Переиндексация поиска местоположений

Страница Переиндексация поиска местоположений (Магазин > Настройки > Местоположения > Переиндексация поиска) предназначена для создания индексов местоположений. Они необходимы, если поиск местоположений осуществляется при помощи строки ввода. Если используются выпадающие списки, то индексы создавать не нужно.

Закладка Переиндексация

Поле | Описание
Основные настройки
Ограничить индексацию по типу | Указываются типы местоположений, для которых должны быть созданы индексы.
Ограничить индексацию по языку | Выбираются языки интерфейса системы, для которых должны быть созданы индексы.
Длина шага, секунды | Длительность одного шага создания индексов в секундах.
Кнопка Начать переиндексацию
Кнопка служит для запуска процесса создания индексов.

См. также

  • Переиндексация поиска местоположений (учебный курс)


Отправить отзыв по этому разделу

Налоги

  • Управление налогами
  • Список налогов
  • Создание и редактирование налогов
  • Ставки налогов
  • Создание и редактирование ставок налогов
  • Освобождение от налогов
  • Настройка освобождения от налогов
  • Ставки НДС
  • Создание и редактирование ставки НДС


Управление налогами

Если в системе установлены налоги, то они учитываются при определении стоимости заказа. Общая структура налогов в модуле продаж такова:

  • налоги вводятся для каждого сайта независимо. Количество налогов не ограничено;
  • ставки налогов могут зависеть от типа плательщика и его местоположения. Ставки налогов задаются в процентном виде. Количество ставок налогов не ограничено. Ставки налогов могут быть включены в цену;
  • некоторые покупатели могут иметь право не платить часть налогов. Для таких случаев необходимо настроить освобождения от налогов для групп пользователей, которым принадлежат эти покупатели и только они.

Настройка налогов

Налоги настраиваются на странице Список налогов (Магазин > Настройки > Налоги > Список налогов). На этой странице вводится список налогов, которые могут быть задействованы на сайте. Каждый налог зависит от сайта, т.е. на русском сайте будут учитываться только те налоги, которые введены для русского сайта.

Настройка ставок налогов

Ставки налогов настраиваются на странице Ставки налогов (Магазин > Настройки > Налоги > Ставки налогов). На этой странице для налогов вводятся ставки в зависимости от местоположения покупателя и его типа плательщика (тип плательщика не обязателен).

Для расчёта налогов для данного заказа будут выбираться все ставки налогов, удовлетворяющие следующим условиям:

  • налог, к которому относится данная ставка, принадлежит тому сайту, на котором производится заказ;
  • местоположение, указанное покупателем в свойстве, у которого стоит флажок Использовать как местоположение для налогов, должно входить в список местоположений, на которые действует данная ставка;
  • тип плательщика, установленный для данной ставки, совпадает с типом плательщика, выбранным покупателем при оформлении заказа, либо для данной ставки тип плательщика не установлен;
  • данная ставка налога активна.

Если страна представлена более чем одним местоположением и необходимо задать ставку налога, которая действует на всю страну, то рекомендуется создать группу местоположений, включающую все местоположения этой страны, и при вводе ставки налога указать эту группу местоположений.

Если для данного заказа указано более одной ставки налогов, то порядок применения этих ставок следующий:

  • Ставки налогов применяются по порядку в соответствии со значениями в поле Порядок применения ставок налогов, начиная с наименьшего.
  • Ставка налога с данным порядком применения применяется к сумме, в которой уже учтены все налоги с меньшим порядком применения. Другими словами действуют сложные проценты (проценты на проценты).
  • Если ставки налогов имеют один и тот же порядок применения, то они складываются, т.е. они применяются к одной и той же сумме.

Пример вычисления стоимости заказа

Пусть покупается товар стоимостью 25 рублей. Скидка при покупке на сумму более 20 рублей равна 2%. Пусть данному заказу соответствуют следующие ставки налогов:

  • Налог 1 со ставкой 18.5% и порядком применения 100;
  • Налог 2 со ставкой 2.7% и порядком применения 100;
  • Налог 3 со ставкой 3% и порядком применения 200.

Тогда стоимость товара с учётом скидки будет равна 24,5 рубля (25 - 25 * 2 / 100).

Налог 1 будет равен 4,53 рубля (24.5 * 18.5 / 100). Налог 2 будет равен 0,66 рубля (24.5 * 2.7 / 100). После применения Налога 1 и Налога 2 стоимость заказа будет равна 29,69 рублей (24.5 + 4.53 + 0.66).

Налог 3 будет равен 0,89 рубля (29.69 * 3 / 100).

После применения скидки и всех налогов стоимость заказа будет составлять 30,58 рублей (29.69 + 0.89). Далее в эту стоимость должна быть включена стоимость доставки.

Освобождение от налогов

Эта функциональная возможность применяется, если существуют покупатели, которые освобождены от уплаты части налогов. Создайте специальную группу пользователей, выберите ее на странице Освобождение от налогов (Магазин > Настройки > Налоги > Освобождение от налогов) и укажите, какие налоги не нужно применять к членам этой группы.

После поступления от покупателя документов, удостоверяющих его право на освобождение от налогов, привяжите этого покупателя к созданной специальной группе пользователей. Тогда при оформлении заказа этому покупателю будет предоставлена возможность выбора: применять освобождение от налогов или оформить заказ на общих основаниях. Если покупатель выберет применение освобождения от налогов, то при расчёте стоимости заказа ставки тех налогов, которые выбраны на странице настроек освобождения от налогов для данной специальной группы пользователей, учитываться не будут.

Смотрите также

  • Создание налога
  • Создание ставки налога
  • Не определяется ставка налога
  • Сделать для новых товаров автоматом включение НДС в цену
  • Как установить ставку НДС для всего каталога товаров


Список налогов

Страница Налоги (Магазин > Настройки > Налоги > Список налогов) служит для настройки налогов, применяемых для расчёта стоимости заказа. На этой странице вводится список налогов, которые могут быть задействованы на сайте. Каждый налог зависит от сайта. Например, на русскоязычном сайте будут учитываться только те налоги, которые введены для этого сайта.

Контекстная панель

Кнопка | Описание
Новый налог | Переход к форме создания нового налога.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список налогов

Поле | Описание
Колонка флажков | Поле предназначено для выбора налогов, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые могут быть применены к налогу:
  • Изменить параметры налога - редактирование налога;
  • Удалить налог- удаление налога.
Код | Код налога в системе.
Дата изменения | Дата и время последнего изменения налога.
Сайт | Сайт, на котором действует налог.
Название / Описание | Название налога.
Мнемонический код | Символьный код налога. Задается символами латинского алфавита.
Ставки | Количество заданных ставок налога. количество ставок представлено в виде ссылки на страницу со списком этих ставок.

См. также

  • Управление налогами
    •


Создание и редактирование налогов

Данная форма предназначена для создания нового и редактирования параметров уже существующего налога.

Контекстная панель

Кнопка | Описание
Список налогов | Переход на страницу со списком налогов.
Добавить новый налог | Переход к форме создания нового налога. (Кнопка отображается при редактировании существующего налога.)
Удалить налог | Удаление редактируемого налога. (Кнопка отображается при редактировании существующего налога.)

Поля формы

Поле | Описание
Код | Код налога в системе.
Дата изменения | Дата и время последнего изменения налога.
Сайт | Сайт, на котором действует налог.
*Название | Название налога.
Мнемонический код | Код, однозначно идентифицирующий данный налог. Используется для идентификации объекта "налог" в системе. Примечание: поле предназначено для использования разработчиками. Значение поля указывается латинскими символами.
Описание | Произвольное описание налога.

* - поля, обязательные для заполнения.


Ставки налогов

На странице Ставки налогов (Магазин > Настройки > Налоги > Ставки налогов) представлен список всех заданных ставок налогов. С помощью данной формы вы можете:

  • добавлять новые ставки налогов;
  • переходить к форме редактирования ставок;
  • удалять ставки налогов.

Форма поиска

С помощью данной формы вы можете выполнить поиск ставок налога в соответствии с указанными условиями.

Поле | Описание
Налог | Название налога, ставки для которого следует отобрать. Поле присутствует, даже если фильтр свернут.
Сайт | Сайт, на котором действует ставка.
Тип плательщика | Тип плательщика, ставки для которого следует отобрать.
Местоположение | Местоположение, ставки налогов для которых следует отобрать.

Чтобы отобрать ставки налога по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех ставок нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Новая ставка налога | Переход к форме создания новой ставки налога.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список ставок налогов

Поле | Описание
Колонка флажков | Поле предназначено для выбора ставок налога, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые могут быть применены к ставке:
  • Изменить параметры ставки налога - редактирование ставки налога;
  • Удалить ставку налога - удаление ставки налога.
ID | Код ставки налога.
Активность | Признак активности ставки налога.
Дата изменения | Дата и время последнего изменения ставки налога.
Название | Название налога, для которого задана ставка.
Тип плательщика | Тип плательщика, к которому применима данная ставка налога.
Ставка | Величина ставки налога.
Входит в цену | Указывает, включен ли данный налог в цену товара.
Порядок применения | Ставки налога с одинаковым порядком применения складываются, с разными - образуют сложные проценты (проценты на проценты).

Смотрите также

  • Управление налогами


Создание и редактирование ставок налогов

Данная форма предназначена для создания новых и редактирования уже существующих ставок налогов.

Контекстная панель

Кнопка | Описание
Список ставок налогов | Переход на страницу со списком ставок налогов.
Добавить ставку | Переход к форме создания новой ставки налога. Кнопка отображается при редактировании существующей ставки.
Удалить ставку | Удаление редактируемой ставки налога. Кнопка отображается при редактировании существующей ставки.

Поля формы

Поле | Описание
ID | Код ставки.
Дата изменения | Дата изменения ставки налога.
*Налог | Название налога, для которого задана данная ставка.
Активность | Признак активности ставки. Только активные ставки налога могут применяться при расчёте стоимости заказа.
Тип плательщика | Тип плательщика, к которому применима данная ставка налога.
*Ставка | Величина ставки налога.
Входит в цену | Указывает, включен ли данный налог в цену товара или нет.
*Порядок применения | Ставки налога с одинаковым порядком применения складываются, с разными - образуют сложные проценты (проценты на проценты). Порядок применения задается аналогично механизму сортировки: ставка с меньшим значением в этом поле применится раньше.
**Местоположения | Указываются местоположения, в которых будет применяться данная ставка налога.
**Группы местоположений | Выбирается группа(-ы), в местоположениях которой будет применяться данная ставка налогов.

* - Поля, обязательные для заполнения.

** - Обязательно указание значения хотя бы одного из данных полей, т.е. должно быть выбрано местоположение, в котором будет применяться эта ставка налога, либо группа местоположений. Возможно указание значений обоих полей одновременно.


Освобождение от налогов

Страницв Освобождение от налогов (Магазин > Настройки > Налоги > Освобождение от налогов) содержит список групп пользователей сайта, освобождаемых от уплаты каких-либо налогов при покупке товара в интернет-магазине.

Контекстная панель

Кнопка | Описание
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данные из отображаемой таблицы в MS Excel.

Список клиентов, освобождаемых от налогов

Поле | Описание
Действия Действия над записью об осовобождении от уплаты налогов:
  • Изменить освобождение от налогов - редактирование записи об освобождении от налогов для данной группы пользователей.
Код | Код записи об освобождении от уплаты налогов.
Дата изменения | Дата последнего изменения записи.
Группа пользователей | Группы пользователей сайта, к которым применяется освобождение от налогов.
Описание группы пользователей | Описание группы пользователей, заданное при создании данной группы.
Налоги | Перечень налогов, от уплаты которых освобождена данная группа пользователей.

См. также

  • Управление налогами


Настройка освобождения от налогов

Данная форма предназначена для редактирования записи об освобождении от уплаты налогов для выбранной группы пользователей.

Контекстная панель

Кнопка | Описание
Список групп пользователей | Переход на страницу со списком записей об освобождении от уплаты налогов.

Поля формы

Поле | Описание
Код | Код записи об освобождении от уплаты налогов.
Группа пользователей | Группы пользователей сайта, к которым применяется освобождение от налогов.
Описание группы пользователей | Описание группы пользователей, заданное при создании группы.
Освобождение от налогов | Список налогов, от уплаты которых может быть освобождена данная группа пользователей. Для выбора нескольких налогов удерживайте клавишу Ctrl.

Смотрите также:

  • Как освободить покупателя от налогов


Ставки НДС

Страница Ставки НДС (Магазин > Настройки > Налоги > Ставки НДС) служит для добавления и редактирования ставок НДС.

Форма поиска

С помощью данной формы Вы можете выполнить поиск ставок НДС в соответствии с указанными условиями.

Поле | Описание
ID | Поиск ставки по ID. Данное поле отображается, даже если фильтр свернут.
Активность | Признак активности ставки. Если ставка НДС активна, то она может быть использована при формировании цены товара.
Наименование* | Поиск ставки по названию.
Ставка | Поиск записей по величине ставки в процентах.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания новой ставки НДС.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список ставок НДС

Поле | Описание
Колонка флажков | Поле предназначено для выбора ставок НДС, к которым предполагается применить какое-либо правило или действие.
Действия Действия над ставками НДС:
  • Редактировать - редактирование ставки НДС;
  • Удалить - удаление ставки НДС.
ID | Идентификатор ставки НДС в базе данных.
Сорт. | Относительный "вес", определяющий положение ставок НДС в общем списке.
Акт. | Флаг активности ставок НДС. Только активные ставки могут быть использованы.
Наименование | Название ставки НДС.
Ставка | Величина ставки в процентах.


Создание и редактирование ставки НДС

Данная форма предназначена для создания новых и изменения параметров уже существующих типов цен.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком ставок НДС.
Добавить | Переход к форме создания новой ставки НДС. Кнопка отображается при редактировании существующей ставки.
Удалить | Удаление редактируемой ставки НДС. Кнопка отображается при редактировании существующей ставки.

Поля формы

Поле | Описание
ID | Идентификатор ставки НДС в базе данных. Поле отображается только при редактировании ставки.
*Наименование | Любое название ставки, дающее представление о случаях применения, величине ставки и т.д. по желанию.
*Ставка | Величина ставки в процентах.
Акт. | Флаг активности. Только активные ставки могут быть применены.
Сорт. | Порядок, в котором ставки появляются при выводе на экран.
* - поля, обязательные для заполнения.


Отправить отзыв по этому разделу

Торговые платформы

  • Товары ВКонтакте


Отправить отзыв по этому разделу

Товары ВКонтакте

  • Список профилей экспорта в магазин ВКонтакте
  • Создание и редактирование профиля экспорта


Список профилей экспорта в магазин ВКонтакте

Страница Обмен товаров с ВКонтакте - список профилей (Магазин > Настройки > Торговые платформы > Товары ВКонтакте) служит для отображения списка созданных профилей интеграции с магазином ВКонтакте. Данная страница позволяет:

  • создать новый профиль экспорта;
  • отредактировать или удалить уже существующий профиль;

Контекстная панель

Кнопка | Описание
Новый экспорт | Переход к форме создания нового профиля экспорта.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список профилей экспорта

Поле | Описание
Колонка флажков | Поле предназначено для выбора профилей экспорта, к которым предполагается применить какое-либо правило или действие.
Действия Действия над профилем:
  • Изменить - изменение параметров профиля;
  • Удалить - удаление профиля.
ID | Идентификатор профиля.
Название | Название профиля.
Акт. | Признак активности профиля экспорта.


Создание и редактирование профиля экспорта

Закладки

В форме создания и редактирования профиля экспорта вы можете задать или изменить значения параметров, необходимых для интеграции с магазином ВКонтакте.

Обмен

Данная закладка доступна только при редактировании настроенного профиля экспорта.

Поле | Описание
кнопка Запустить обмен | Запуск обмена данными.
кнопка Обмен по частям | Запуск обмена подборок или обмена товарами.
кнопка Удаление | Удаление альбомов или товаров.
Статистика
Отображается статистика по экспорту товаров.

Настройки

Данная форма служит для настройки параметров соединения с ВКонтакте.

Поле | Описание
Название | Название профиля экспорта для отображения в административном разделе сайта.
Настройки соединения
ID приложения | Идентификатор приложения ВКонтакте. Может быть получен в настройках созданного вами приложения.
Защищенный ключ | Ключ приложения ВКонтакте, необходимый для внешнего доступа к нему. Может быть получен в настройках созданного вами приложения.
После сохранения введенных данных вам станет доступна ссылка Получить ключ доступа, при нажатии на которую система затребует разрешение на доступ к вашей группе ВКонтакте. Согласитесь с требованиями и ключ доступа будет получен и сохранен. После получения ключа вам станут доступны дополнительные опции. Примечание: Если вы используете технологию [ds]многосайтовость на разных доменах[/ds][di] Многосайтовость на разных доменах – это название технологии создания сайтов, при которой ядро продукта устанавливается в папку одного из сайтов, а для остальных сайтов настраиваются символьные ссылки (симлинки). Эту технологию можно реализовать и на разных доменах, и на поддоменах. Подробнее [image] ...[/di], то для получения/переполучения ключа доступа нужно открыть административную часть интернет-магазина с того домена, который указан в настройках приложения Вконтакте (в противном случае появится ошибка "redirect_uri has wrong domain, check application settings").
Настройки ВКонтакте
Группа для импорта товаров | Выбирается группа ВКонтакте, в которую планируется произвести экспорт. Поле доступно после получения ключа доступа.
Настройки разделов каталога
Категория ВКонтакте по умолчанию | Категория для добавления товаров. Выбор производится из фиксированного списка. Настройка является обязательной для добавления товаров. Выбор и настройка разделов, которые будут экспортироваться ВКонтакте, производится на вкладке Торговые платформы формы редактирования раздела. Поле доступно после получения ключа доступа.
Настройки экспорта
Секция доступна после получения ключа доступа
Перезаписывать изменения | При включении данной опции экспорт будет перезаписывать все изменения, сделанные с товарами ВКонтакте (т.е. если вы произвели экспорт, а затем вручную изменили товар ВКонтакте, то следующий обмен приведет товар в соответствие с сайтом).
Экспортировать только доступные товары | При отмеченной опции экспортироваться будут только доступные к покупке товары.
Максимальное время выполнения одного шага | Максимальное время выполнения одного шага экспорта в секундах (при стабильной работе не рекомендуется изменять это значение).
Количество элементов, обрабатываемых за шаг (не более 25) | Количество товаров, которое обрабатывается за один шаг (при стабильной работе не рекомендуется изменять это значение).
Расширенный лог ошибок | При отмеченной опции будет составлять полный лог ошибок.

Карта экспорта

Во вкладке отображается список разделов каталога, [ds]отмеченных для экспорта[/ds][di] В административной части сайта перейдите в Магазин > Каталог товаров > Разделы и с помощью пункта контекстного меню Изменить произведите настройку экспорта каждого раздела. Необходимые нам настройки расположены на вкладке Торговые платформы.

Подробнее [image]...[/di].

Поле | Описание
Название | Название профиля экспорта для отображения в административном разделе сайта.
Альбом ВКонтакте | Название альбома Вконтакте, в который осуществляется экспорт товаров.
Количество товаров | Количество экспортируемых товаров.
Разделы каталога | Разделы каталога, товары из которых будут экспортированы в альбом Вконтакте.


Отправить отзыв по этому разделу

Цены

  • Типы цен
  • Создание и редактирование типа цены
  • Правила округления цен
  • Создание и редактирование правила округления
  • Наценки
  • Создание и редактирование наценки


Типы цен

Страница Типы цен (Магазин > Настройки > Цены > Типы цен) служит для управления типами цен, с помощью которых можно установить различные цены на товары для разных групп покупателей.

Типы цен вводятся для упрощения представления разных величин стоимости товаров. Например, Вы можете выводить и использовать различные цены для розничных и оптовых покупателей, а также дилеров.

Контекстная панель

Кнопка | Описание
Новый тип цен | Переход к форме создания нового типа цены.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы MS Excel.

Список типов цен

Поле | Описание
Колонка флажков | Поле предназначено для выбора типов цен, к которым предполагается применить какое-либо правило или действие.
Действия Действия над типом цены:
  • Изменить тип цен - редактирование типа цен;
  • Удалить тип цен - удаление типа цен.
  • Сделать базовым - установка данного типа цен в качестве [dw]базового[/dw][di] Базовая цена – основа для расчетов остальных цен. Этот тип должен присутствовать обязательно (либо один тип цен был отмечен как базовый).[/di].
ID | Идентификатор типа цены в базе данных.
Код | Языконезависимое название. Ключ - NAME.
Название | Название типа цены для разных языков.
Сорт. | Относительный "вес", определяющий положение типа цен в общем списке.
Базовый | Если данное поле имеет значение Да, то этот тип цен является базовым. Это означает, что от него рассчитываются остальные цены в системе.
Кем изменен | Имя пользователя, который изменил тип цен.
Дата изменения | Дата и время последнего изменения типа цен.
Кем создан | Имя пользователя, создавшего тип цен.
Дата создания | Дата и время создания типа цен.


Создание и редактирование типа цены

Даная форма предназначена для создания новых и изменения параметров уже существующих типов цен.

Контекстная панель

Кнопка | Описание
Список типов цен | Переход на страницу со списком типов цен.
Добавить новый тип цены | Переход к форме создания нового типа цены. Кнопка отображается при редактировании существующего типа цены.
Удалить тип цены | Удаление редактируемого типа цены. Кнопка отображается при редактировании существующего типа цены.

Поля формы

Поле | Описание
ID | Идентификатор типа цены в базе данных. Поле отображается только при редактировании типа цены.
Базовый | Если это поле имеет значение Да, то этот тип цены является базовым, т.е. от него рассчитываются остальные цены в системе. Поле не подлежит изменению.
Внешний код | Указывается внешний код типа цены.
*Код | Символьный код типа цены, который используется в административном разделе для идентификации типа цены.
Сортировка | Порядок, в котором типы цен появляются при выводе на экран.
Название | Название типа цены для разных языков.
*Группы пользователей, имеющие права на просмотр этого типа цен | Группы пользователей, обладающие правом на просмотр цен этого типа.
*Группы пользователей, имеющие права на покупку по этому типу цен | Группы пользователей, обладающие правом на покупку товаров по ценам этого типа.
* - поля, обязательные для заполнения.


Правила округления цен

Страница Правила округления цен (Магазин > Настройки > Цены > Округление) служит для управления правилами округления цен.

Форма поиска

С помощью данной формы вы можете выполнить поиск правил округления в соответствии с указанными условиями.

Поле | Описание
Тип цен | Поиск правила по тип цен.

Чтобы отобрать правила по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех правил нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания нового правила округления.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы MS Excel.

Список правил округления

Поле | Описание
Колонка флажков | Поле предназначено для выбора правил, к которым предполагается применить какое-либо правило или действие.
Действия Действия над правилом:
  • Редактировать - редактирование правила;
  • Копировать - добавление нового правила путем копирования параметров текущего;
  • Удалить - удаление правила.
ID | Идентификатор правила в базе данных.
Тип цен | Тип цены, для которого создано правило.
Цена от | Название типа цены для разных языков.
Тип округления | Тип округления.
Точность округления | Точность округления, используемая в правиле.
Кем создано | Имя пользователя, создавшего правило.
Дата создания | Дата и время создания правила.
Кем изменено | Имя пользователя, который последним изменил правило.
Дата изменения | Дата и время последнего изменения правила.


Создание и редактирование правила округления

Контекстная панель

Кнопка | Описание
Список правил | Переход на страницу со списком правил.
Добавить новое | Переход к форме создания нового правила округления. Кнопка отображается при редактировании существующего правила.
Скопировать | Переход к форме создания нового правила округления путем копирования параметров текущего. Кнопка отображается при редактировании существующего правила.
Удалить | Удаление редактируемого правила. Кнопка отображается при редактировании существующего правила.

Форма редактирования

Поле | Описание
ID | Идентификатор правила. Поле отображается при редактировании существующего правила.
*Тип цен | Тип, к ценам которого применяется правило округления.
*Минимальная цена | Цена, с которой начинает работать правило округления.
*Тип округления | Тип округления, применяемый в правиле: Математическое - по арифметическим правилам, В пользу магазина - в большую сторону, В пользу клиента - в меньшую сторону.
[dw]*Точность округления[/dw][di]Внимание! Возможны ошибки округления при печати чеков, если, например, в настройках интернет-магазина установлена точность округления при расчетах 3 и более знака и при этом не настроены / настроены неправильно правила округления цен. Как правильно настроить округление цен. [/di] | Величина, на которую результат должен делиться [dw]нацело[/dw][di]Примеры округления (тип - математическое): цена 768,67 руб. 0.01 - 768,67 0.1 - 768,7 0.2 - 768,6 1 - 769 2 - 768 10 - 770 50 - 750 100 - 800[/di].
* - поля, обязательные для заполнения.


Наценки

Страница Типы наценок (Магазин > Настройки > Цены > Наценки) служит для управления наценками и скидками в системе (далее просто наценка).

Наценка - заранее установленная в относительном выражении (например, в процентах) величина, на которую уменьшается или увеличивается цена товара для конкретного покупателя или группы покупателей.

Типом наценки называется поименованная величина наценки (например, Оптовая скидка). Имя вводится для упрощёния управления этими величинами.

Если Вы часто устанавливаете одни и те же проценты наценок для ваших товаров, введите эти проценты как типы наценок. В этом случае при выборе типа наценки для товаров система автоматически рассчитает цену на данные товары, прибавив сумму наценки к базовой цене товара. При изменении величины наценки все цены, сформированные с использованием данной наценки, могут быть автоматически пересчитаны системой.

Контекстная панель

Кнопка | Описание
Новая наценка | Переход к форме создания новой наценки.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список типов наценок

Поле | Описание
Колонка флажков | Поле предназначено для выбора наценок, к которым предполагается применить какое-либо правило или действие.
Действия Действия над наценкой:
  • Изменить параметры наценки- редактирование наценки;
  • Удалить наценку - удаление наценки.
ID | Идентификатор типа наценки в базе данных.
Название наценки | Произвольное название типа наценки. Для удобства работы рекомендуется задавать названия, отражающие смысл создаваемой наценки.
Процент | Процент наценки от базовой цены товара. Может задаваться как положительным (наценка), так и отрицательным (скидка) числом.
Пересчитать цены | Указывается, будут ли цены, сформированные с использованием данной наценки, пересчитаны автоматически при изменении величины наценки.


Создание и редактирование наценки

Контекстная панель

Кнопка | Описание
Список наценок | Переход на страницу со списком наценок.
Создать новую наценку | Переход к форме создания новой наценки. Кнопка отображается при редактировании существующей наценки.
Удалить наценку | Удаление редактируемой наценки. Кнопка отображается при редактировании существующей наценки.

Форма редактирования

Поле | Описание
ID | Идентификатор наценки. Поле отображается при редактировании существующей наценки.
*Название | Произвольное название типа наценки. Для удобства работы рекомендуется задавать названия, отражающие смысл создаваемой наценки.
Величина наценки | Процент наценки от базовой цены товара. Может задаваться как положительным (наценка), так и отрицательным (скидка) числом.
Пересчитать цены | Если в данном поле установлен флаг, то при изменении величины наценки цены, формируемые с использованием данной наценки, будут пересчитаны автоматически. Поле отображается при редактировании существующей наценки.
* - поля, обязательные для заполнения.


Торговый каталог. Описание модуля

Описание

Торговый каталог - модуль системы "1С-Битрикс: Управление сайтом", позволяющий:

  • создавать торговые каталоги товаров, услуг и всевозможного цифрового контента;
  • осуществлять продажу товаров, услуг и цифрового контента через интернет-магазин;
  • осуществлять продажу прав доступа к ресурсам сайта;
  • управлять ценами на товары и услуги торговых каталогов;
  • загружать и выгружать данные о товарах, заказах, продажах в форматах CommerceML, Froogle, Yandex и CSV (формат последнего можно настраивать при загрузке);
  • загружать и выгружать данные в любой из форматов в соответствии с созданными пользователем профилями.

Важно! Каталоги товаров формируются на основе информационных блоков, поэтому для использования модуля Торговый каталог необходимо наличие установленного в системе модуля Информационные блоки.

Настройка параметров и свойств Торгового каталога осуществляется на страницах раздела Торговый каталог (Административный раздел сайта > Магазин > Торговый каталог), а также на странице настроек модуля Торговый каталог (Настройки > Настройки продукта > Настройки модулей > Торговый каталог).

Управление ценами товаров Торгового каталога осуществляется с помощью специальных форм, расположенных на страницах настройки информационных блоков (модуль Информационные блоки).

Важно! Для корректной работы модуля Торговый каталог необходимо наличие установленного модуля Валюты.

Если Вы хотите, чтобы в вашем интернет-магазине осуществлялась продажа цифрового контента, представленного в инфоблоках системы, отметьте соответствующие информационные блоки в поле Продажа контента.

На странице настроек модуля Торговый каталог Вы также можете:

  • указать информационные блоки, данные из которых будут выгружаться в XML-файлы для системы Яндекс.Товары (см. статью Яндекс.Товары);
  • выбрать группы пользователей, права доступа к ресурсам сайта которых будут доступны для продажи.

Основные возможности модуля торгового каталога

  • Многовалютность - система позволяет гибко управлять валютами цены. Список доступных валют определяется администратором сайта. Для каждой валюты устанавливаются курсы (с возможностью загрузки с сайта Центрального Банка РФ), а также формат вывода для каждого сайта.
  • Типы цен - к одному товару можно привязать несколько цен разных типов. К каждому типу цены можно ограничить доступ на просмотр и на покупку для разных групп посетителей. Например, можно ввести розничный тип цен, который будет доступен для просмотра и покупки всем посетителям сайта, и оптовый тип цен, который будет доступен для просмотра всем посетителям, но покупать товары по которому смогут только члены группы "Оптовые покупатели".
  • Система наценок - один из типов цен торгового каталога называется базовым. Все остальные цены товара могут рассчитываться в процентном отношении к базовой цене, либо задаваться вручную. Для цен, рассчитываемых как наценка к базовой цене, возможен автоматический пересчет.
  • Загрузка данных в формате CommerceML - модуль позволяет загружать каталог товаров и цены в формате CommerceML.
    CommerceML - это единый стандарт обмена коммерческой информацией в формате XML, поддерживаемый программой "1C". Стандарт учитывает отечественную специфику и включает несколько универсальных решений, необходимых для российских Интернет-компаний и торговых организаций.
  • Загрузка и выгрузка данных в CSV файл - модуль позволяет загружать и выгружать каталог товаров и цены в CSV файл.
  • Связь с модулем Интернет-магазин - пользователь, совершающий покупку, помещает товар в корзину по самой выгодной из доступных для него цен на данный товар.

Модуль включает в себя следующие компоненты 2.0

Обратите внимание!

1. Некоторые компоненты для управления каталогами могут относиться к модулю Информационные блоки, Интернет-магазин а также к готовым отраслевым решениям. Их перечень и описание расположены на страницах Описание модуля информационные блоки, Компоненты решения Корпоративный сайт услуг, Интернет-магазин.

2. Компоненты, доступные для использования, но отсутствующие в визуальном редакторе, описываются в отдельной главе Компоненты [image].

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Импорт каталога из 1С | catalog.import.1c | Выполняет импорт данных из 1С в формате CommerceML v2.
Импорт в Highload-блоки | catalog.import.hl | Используется при обмене с 1С для выгрузки на сайт справочников.
Экспорт каталога в 1C | catalog.export.1c | Выполняет экспорт данных в 1С в формате CommerceML v2.
Вывод товаров для почты | catalog.show.products.mail | Выводит список товаров для почты по заданным идентификаторам.
Накопительные программы | catalog.discsave.info | Позволяет просмотреть список накопительных программ, распространяющихся на клиента Интернет-магазина.
Склады | catalog.store | Осуществляет вывод полного списка складов.
Список складов | catalog.store.list | Осуществляет вывод списка складов с подробной информацией.
Информация о складе | catalog.store.detail | Осуществляет вывод подробной информации о складе.
Остатки по складам | catalog.store.amount | Выводит остатки выбранного товара по складам, на которых он имеется.
Просмотренные товары | catalog.products.viewed | Выводит просмотренные пользователем товары с указанным набором свойств
Рекомендуемые товары | catalog.recommended.products | Для товара выводит список рекомендуемых к покупке вместе с ним товаров
Подписка на товары | catalog.product.subscribe | Отображает форму подписки на товар
Список товаров на которые вы подписаны | catalog.product.subscribe.list | Отображает список товаров, на которые подписан пользователь
Конструктор наборов | catalog.set.constructor | Служит для отображения заданного набора и составления собственного набора товаров

Смотрите также

  • Как настроить инфоблок на работу в режиме торгового каталога
  • Торговый каталог (учебный курс "Администратор. Бизнес")


Торговый каталог. Настройки модуля

Отправить отзыв по этому разделу
Магазин>Торговый каталог>Торговый каталог. Настройки модуля

Торговый каталог::Торговый каталог. Настройки модуля

Форма настроек модуля Торговый каталог (Настройки > Настройки продукта > Настройки модулей > Торговый каталог) предназначена для задания общесистемных параметров модуля. Для удобства работы форма разделена на закладки, на каждой из которых выполняется настройка определённой группы параметров модуля.

Настройки

Поле | Описание
Системные настройки
Включить поддержку устаревших событий | Опция отмечена по умолчанию. При снятии флажка будет отключена поддержка событий устаревших методов (методы Add, Update, Delete, GetList классов CCatalogProduct и CPrice; устарели с версии 17.6.0).
Карточка товара
Разрешать сохранять товары без цен | При отмеченной опции будет доступна возможность сохранения товара без цен.
Показывать вкладку Торговый каталог для товаров, имеющих торговые предложения При отмеченной опции вкладка Торговый каталог будет отображаться в форме редактирования товаров типа товар с торговыми предложениями. Кроме того, при отмеченной опции доступность товаров с торговыми предложениями не учитывает доступность предложений: доступность таких товаров зависит от данных, введенных на вкладке Торговый каталог.

Важно! Опция Показывать вкладку Торговый каталог для товаров, имеющих торговые предложения, начиная с версии 16.0.10, будет поддерживаться только в режиме совместимости. Таким образом, все новинки, касающиеся торговых предложений будут недоступны, если данная опция будет отмечена в настройках модуля Торговый каталог.
Устанавливать параметр "НДС включен в цену" при создании новых товаров и предложений | Если параметр отмечен флагом, то в форме создания новых товаров и торговых предложений будет сразу отмечена опция НДС включен в цену.
Значения параметров товаров по умолчанию
Важно! В данной секции для товаров задаются значения параметров, используемые по умолчанию. Вы можете переопределить эти параметры отдельно для каждого товара в форме его редактирования.
Включить количественный учет | При отмеченной опции для всех товаров будет по умолчанию включен количественный учет. Если опция не отмечена, то по умолчанию товары будут продаваться всегда.
Разрешить покупку при отсутствии товара (включая разрешение отрицательного количества товара) При отмеченной опции товар будет по умолчанию доступен к покупке даже в том случае, если его количество стало меньше либо равно нулю. Чтобы покупка была запрещена при отсутствии товара, должен быть включен количественный учет.

Примечание: до версии 16.0.0 опция называлась Разрешить покупку при отсутствии товара и не отвечала за разрешение отрицательного количества.
Разрешить подписку при отсутствии товара | При отмеченной опции будет по умолчанию доступна возможность подписки на отсутствующие товары.
Продолжительность одного шага, сек | Если у большого числа товаров в параметрах количественного учета выставлено "по умолчанию", то за один хит пересчет доступности не будет выполнен. Поэтому запускается пошаговый пересчет. Времяодного шага в этом поле предлагается, исходя из максимального времени выполнения скрипта в настройках PHP. Можно указать собственное значение, но не больше, чем предложено. Рекомендуется оставлять значение по умолчанию.
Складской учет
Включить складской учет При отмеченной опции будет включен сервис складского учета.

Для корректной работы складского учета должен быть включен количественный учет товаров (количественный учет конкретного товара определяется настройками его параметра "Включить количественный учет", а если параметр принимает значение "по умолчанию", то поведение определяется настройками модуля).
Включить резервирование Данная опция управляет общим поведением механизма резервирования товаров. Использование резервирования для конкретного товара определяется настройками его параметра "Включить количественный учет". Если параметр принимает значение "по умолчанию", то поведение определяется настройками модуля.

Если механизм резервирования товаров включен, то задаются настройки снятия товара с резервов и правило резервирования товара. Если отключен - правило уменьшения количества товара (см. параметры ниже).

Если вы работаете с 1С (складской учет на сайте отключен) и все операции с заказами проводите на стороне 1С, то для корректной работы следует отключить резервирование на сайте.

Если включен складской учет, то опция включается автоматически и отключить ее нельзя.
Товар резервируется Выбирается правило резервирования товара:
  • При оформлении заказа;
  • При полной оплате заказа;
  • При частичной оплате заказа;
  • При разрешении доставки;
  • При отгрузке.
Параметр доступен, если включен механизм резервирования товаров, и настраивается на странице настроек модуля Интернет-магазин в поле Товар резервируется.
Снятие резервов (через сколько дней) Задается количество дней, через которое товар будет автоматически снят с резервов, если покупатель не выполняет никаких действий по заказу.

Параметр доступен, если включен механизм резервирования товаров, и настраивается на странице настроек модуля Интернет-магазин.
Количество товара уменьшается Выбирается правило уменьшения количества товара:
  • При оформлении заказа;
  • При полной оплате заказа;
  • При частичной оплате заказа;
  • При разрешении доставки;
  • При отгрузке.
Параметр доступен, если отключен механизм резервирования товаров, и настраивается на странице настроек модуля Интернет-магазин в поле Товар резервируется.
Скидки
Механизм применения накопительных скидок Указывается каким образом применять накопительные скидки:
  • отменять скидки на товар, если накопительная скидка больше;
  • дополнять скидки на товар;
  • не действовать, если есть скидки на товар.
Процентная скидка рассчитывается для полной цены товара | Указывается как применяется скидка: на полную цену или на цену со скидкой. Параметр настраивается на странице настроек модуля Интернет-магазин.
Информация о просмотренных товарах
Время хранения просмотренных товаров (дней) | Указывается сколько дней хранить данные о просмотренных пользователем товарах.
Максимальное количество просмотренных товаров пользователя | Задается число, определяющее информацию о скольких просмотренных товарах хранить для пользователя.
Как часто чистить старые данные (дней) | Задается количество дней, через которое будет выполняться очистка старых данных о просмотренных товарах.
Настройки формы выбора товаров
Показывать инфоблоки торговых предложений в форме выбора товара Данная опция определяет показывать или нет инфоблоки торговых предложений в форме выбора товара.

Примечание: форма выбора товара используется в заказах, документах складского учета, скидках, правилах корзины, а также при редактировании состава наборов и комплектов.
Принудительно использовать фильтр для текстового поиска в форме выбора товара | При отмеченной опции в форме выбора товаров будет использоваться простой механизм отбора товаров через фильтр.
Показывать названия торговых предложений в списке | При отмеченной опции в форме выбора товаров будут отображаться названия торговых предложений, в противном случае - только свойства предложения.
Подписка на товары
Отправка дополнительного письма при повторном отсутствии товара | При отмеченной опции пользователям, подписавшимся на товары, будет высылаться еще одно письмо с уведомлением о том, что товар вновь стал недоступен.

Экспорт/Импорт

Поле | Описание
Общие настройки
Путь по умолчанию для экспортируемых файлов | Указывается путь от корня сайта, который будет использован как директория для хранения экспортируемых файлов.
Тип информационного блока для загрузки в формате CommerceML (из 1С) | Определяется в каталог какого типа будут выгружены данные из "1C".
Автоматически деактивировать товар при загрузке из CommerceML, если нет цены | При отмеченной опции если для товара, загружаемого из CommerceML-файла, не задана ни одна цена, то данный товар будет деактивирован.
Период экспорта в Яндекс.Товары (часов) Указывается с какой частотой данные каталогов, отмеченных в поле Экспорт в Яндекс.Товары таблицы Список информационных блоков, экспортируются в Яндекс.Товары.

Подробнее об автоматическом экспорте смотрите на странице Автоматический экспорт каталогов в Яндекс.Товары
Товары, которых нет в файле данных CommerceML Указывается действие, которое будет выполняться по умолчанию над товарами, которые уже есть в базе, но отсутствуют в загружаемом CommerceML-файле. Доступны следующие действия:
  • удалять;
  • деактивировать;
  • оставить как есть.
Например, если выбрано действие удалять, то при обновлении торгового каталога из файла CommerceML товары, отсутствующие в данном файле, будут удалены из торгового каталога.
Файл кастомизированного агента экспорта в Яндекс.Товары | Здесь можно задавать свой собственный обработчик вместо стандартного.
Экспорт / импорт из CSV
Доступные поля товара Если в базе для каждого товара создано большое количество полей, содержащих значения свойств и параметров товара, то выбор конкретных полей при экспорте или импорте может оказаться затруднительным.

Указывается, какие поля из множества хранимых в базе будут доступны для выбора при экспорте.
Доступные поля цены | Указывается, какие поля с параметрами цены будут доступны для выбора при экспорте или импорте из CSV файла.
Количество уровней групп | Указывается, сколько уровней каталога будет доступно в файлах импорта / экспорта.
Доступные поля групп | Указывается, какие поля групп из множества хранимых в базе будут доступны для выбора при экспорте или импорте из CSV файла.
Доступные валюты | Указываются валюты, доступные для экспорта и импорта.

Каталоги

Архитектура системы позволяет назначить статус торгового каталога любому информационному блоку. На данной закладке можно настроить любой из имеющихся информационных блоков на использование в качестве торгового каталога, а также выбрать информационные блоки для продажи контента и указать, данные из каких инфоблоков подлежат экспорту в Яндекс.Товары. Функция взаимозависимая с закладкой Торговый каталог формы редактирования инфоблока [image]. То есть задать информационному блоку свойства торгового каталога можно как в этой, так и в той закладке.

Поле | Описание
Перечень торговых каталогов
Информационный блок | Название информационного блока.
Является торговым каталогом | При отмеченной опции информационный блок будет настроен на использование в режиме торгового каталога.
Инфоблок торговых предложений Позволяет выбрать инфоблок, который будет использоваться для ввода/вывода товарных предложений (SKU). Выберите инфоблок из имеющихся в системе. Если инфоблока нет, то можно выбрать новый инфоблок. В этом случае появятся поля для добавления инфоблока, выбора типа инфоблока в котором будет создан новый информационный блок и поле для названия инфоблока. При этом:
  • При создании нового инфоблока SKU он будет привязан ко всем сайтам, к которым привязан инфоблок товаров;
  • Если название инфоблока SKU не введено, оно будет создано по шаблону: Пакет предложений для <название инфоблока товаров>. (Шаблон языкозависим.);
  • Права для групп на создаваемый инфоблок SKU берутся из прав на инфоблок товаров за одним исключением: если инфоблок товаров участвует в документообороте или бизнес-процессах, в созданном инфоблоке права на редактирование в документообороте повысятся до изменения (U > W).
Продажа контента | При отмеченной опции контент информационного блока будет платным.
Экспортировать в Яндекс.Товары | При отмеченной опции содержимое информационного блока можно будет экспортировать в XML-файл для системы Яндекс.Товары. Функция работает только при автоматической генерации XML-файла по расписанию, на агенте CCatalog::PreGenerateXML , но не на доступных для экспорта инфоблоков в схемах экспорта Yandex и Yandex simple.
НДС Указывается ставка НДС, которая будет использоваться как ставка НДС по умолчанию для товаров данного каталога.

Поле доступно для информационных блоков, которые являются торговым каталогом (отмечена опция Является торговым каталогом).

Ставки НДС задаются на странице Ставки НДС.

Продажа прав

На данной закладке Вы можете указать группы пользователей, права доступа к ресурсам сайта которых могут продаваться. Например, Вы можете осуществлять продажу прав на доступ к определённому разделу сайта, скачиванию файлов, управлению рекламой или любым другим ресурсам сайта и операциям над ними. При этом Вы можете определить период времени, в течение которого пользователь может работать с предоставленными ему правами.

В общем случае, чтобы организовать продажу прав доступа, необходимо выполнить следующую последовательность действий:

  • на странице Группы пользователей создать группу пользователей, наделенную необходимыми правами;
  • на странице настроек модуля Торговый каталог (закладка Продажа прав) разрешить продажу прав данной группе пользователей;
  • на странице Список пользователей привязать пользователя, купившего право доступа, к соответствующей группе и задать период времени, на который осуществляется привязка.
Поле | Описание
Группа пользователей | Название группы пользователей.
Разрешена продажа | При отмеченной опции будет осуществляться продажа прав доступа соответствующей группе пользователей.

Доступ

Закладка позволяет настроить права на доступ к модулю Торговый каталог для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Торговый каталог:
  • [D] Доступ закрыт - запрет на доступ;
  • [M] Просмотр товаров - разрешен просмотр товаров каталогов при работе с заказами в магазине, уровень предназначен для менеджеров, работающих с заказами;
  • [R] Чтение - разрешается только просмотр всех данных модуля;
  • [S]Управление складом - разрешается управление складским учетом;
  • [T] Редактирование цен - право на редактирование цен элементов торгового каталога;
  • [U] Управление импортом/экспортом - право на управление импортом/экспортом торгового каталога;
  • [W] Полный доступ - полный доступ к ресурсам модуля.
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей..

Агент Яндекс.Товары

Закладка позволяет просмотреть информацию о работе агента, либо в случае его отсутствия - добавить агент (для этого должен быть выбран экспортируемый в Яндекс.Товары инфоблок).

Кнопка | Описание
Добавить агента | Добавление агента для экспорта.

Стандартный агент теперь работает на UTF8-установках и пишет в журнал событий сообщения об ошибках (если они есть).

Переиндексация данных

На закладке содержатся служебные процедуры для переиндексации скидок, переиндексации товаров и обновления остатков комплектов.

Кнопка | Описание
Запустить индексацию | Запуск процесса индексации скидок.
Запустить | Запуск процесса индексации товаров.
Обновить остатки | Запуск процесса обновления остатков и доступности комплектов.

Очистка каталога

Важно! Закладка доступна только при выключенном складском учете.

Закладка служит для очистки доступного и зарезервированного количества товара в каталоге, обнуления остатков по складам. Таким образом, позволяет начать ведения учета с чистого листа.

Кнопка | Описание
Выберите каталог | Укажите каталог товаров, для которого должна быть проведена очистка доступного и/или зарезервированного количества.
Очистить поле "Доступное количество" | По кнопке Очистить выполняется очистка поля Доступное количество для каждого товара в каталоге. Если очистка поля уже выполнялась, то будет отображена дата и пользователь, который выполнял последнюю очистку.
Очистить поле "Зарезервированное количество" | По кнопке Очистить выполняется очистка поля Зарезервированное количество для каждого товара в каталоге. Если очистка поля уже выполнялась, то будет отображена дата и пользователь, который выполнял последнюю очистку.
Очистить остатки по складу
Выберите каталог | Укажите каталог товаров, для которого должна быть проведена очистка остатков по складам.
Выберите склад | Укажите склад, по которому должна быть проведена очистка данных, либо проведите очистку по всем складам.
Очистить остатки по складу | По кнопке Очистить выполняется очистка остатков товаров по выбранному выше складу (или всем складам). Если очистка поля уже выполнялась, то будет отображена дата и пользователь, который выполнял последнюю очистку.


Ввод цен - общая информация

Отправить отзыв по этому разделу
Магазин>Торговый каталог>Ввод цен - общая информация

Торговый каталог::Ввод цен - общая информация

Ввод цен для товаров торгового каталога (для элементов, в терминах информационных блоков) осуществляется в форме редактирования элементов модуля информационных блоков. Если данный информационный блок является торговым каталогом (осуществлена соответствующая привязка в настройках модуля торгового каталога), то при редактировании элемента этого блока есть возможность задать цены разных типов для этого элемента (в терминах торгового каталога - товара).

В поле Базовая цена введите ту цену товара, на основании которой будут рассчитываться остальные цены (например, цену поставщика).

В поле Валюта базовой цены выберите валюту, в которой установлена базовая цена.

В поле Количество на складе введите количество единиц товара, которое имеется в наличии. Заполнять это поле не обязательно.

Отметьте флаг Уменьшать количество при заказе, если Вы хотите, чтобы при каждом заказе значение в поле Количество на складе автоматически уменьшалось. При достижении значения "0" в поле Количество на складе и отмеченном флаге Уменьшать количество при заказе дальнейшие заказы данного товара станут невозможными. Если флаг Уменьшать количество при заказе не отмечен, то значение в поле Количество на складе никакой особой роли не играет.

Установите цену товара для разных типов цен.

Вы можете выбрать необходимый тип наценки. В этом случае реальная цена будет рассчитана автоматически на основании базовой цены и данного типа наценки по формуле:

[Цена] = [Базовая цена] + [Базовая цена] * [Процент наценки] / 100

Валюта реальной цены будет совпадать с валютой базовой цены. При изменении базовой цены или процента наценки реальная цена будет соответственно пересчитана.

Вы можете также установить тип наценки в значение не установлен и задать реальную цену и валюту цены вручную. В этом случае реальная цена будет фиксированной и не будет изменяться при изменении базовой цены или процентов наценок.


Отправить отзыв по этому разделу

Каталоги

  • Список товаров
  • Создание и редактирование товара
  • Разделы
  • Создание и редактирование раздела
  • Настройки каталога


Список товаров

На странице представлен список подразделов и товаров разделов каталога или список разделов и товаров самого каталога.

Форма поиска

Форма фильтра используется для поиска товаров каталога в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Название* | Поиск по названию товара. Поле присутствует, даже если фильтр свернут.
Раздел | Вышележащий (родительский) раздел.
ID (начальный и конечный) | Поиск по интервалу идентификаторов товаров.
Дата изменения | Поиск по дате последнего изменения параметров товара.
Символьный код | Поиск по символьному коду товара.
Внешний код | Внешний код, используемый для связи товара с внешними источниками данных.
Кто изменил | Поиск по автору изменения.
Дата создания | Поиск по дате создания товара.
Кто создал | Поиск пользователя, создавшего товар.
Статус | Поиск товара по его статусу (при использовании документооборота).
Начало активности | Задается период начала активности товара для его поиска.
Окончание активности | Задается период окончания активности товара для его поиска.
Активность | Позволяет отобрать активные, неактивные или все товары каталога.
Описание* | Поиск товаров по описанию.
Теги | Поиск товаров по заданным тегам.
[свойство] | Поля для фильтрации товаров по значениям свойств, для которых было задано свойство Выводить на странице списка товаров поле для фильтрации по этому свойству.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать товары информационного блока по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех товаров нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Создать товар | Переход к форме создания простого товара.
Создать другие типы товаров Доступны следующие действия:
  • Создать товар с торговыми предложениями - создание товара с торговыми предложениями (действие доступно, если для инфоблока задан инфоблок торговых предложений);
  • Создать комплект - создание основного товара и комплекта к нему;
  • Создать набор - создание основного товара и набора к нему.
Добавить раздел | Переход к форме создания нового раздела каталога.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список товаров

Поле | Описание
Колонка флажков | Поле предназначено для выбора товаров, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия:
  • Изменить - переход к форме редактирования товара или к форме редактирования раздела;
  • Деактивировать/Активировать - снятие/постановка флага активности для товара без захода в форму редактирования товара;
  • Сбросить счетчик просмотров - сброс счетчика просмотров товаров;
  • Копировать - копирование товара (копирование выполняется в тот же раздел каталога, где находится товар; впоследствии товар можно будет перенести в любой другой раздел этого каталога);
  • Просмотреть - переход к просмотру товара;
  • Удалить - удаление товара или раздела.
Тип товара | Указывается тип товара.
Название | Название товара или раздела.
Активность | Активность товара или раздела.
Сорт. | Относительный "вес", определяющий положение товара (раздела) в списке.
Символьный код | Символьный код товара (раздела).
Внешний код | Символьный код, используемый для связи товара (раздела) с внешним источником данных.
Дата изм. | Дата и время последнего изменения товара (раздела).
Кем изменена | Логин и имя пользователя, который совершил последние изменения.
Дата создания | Время и дата создания данной записи.
Кем создана | Логин и имя пользователя, который создал запись о товаре.
ID | Идентификатор товара.
Элементов | Количество товаров в разделе.
Подразделов | Количество подразделов в разделе.
Начало активности | Дата и время начала активности.
Окончание активности | Дата и время окончания активности.
Количество показов | Количество показов данного товара на сайте.
Дата первого показа | Время и дата первого показа товара на сайте.
Картинка для анонса | Изображение, указанное в анонсе товара.
Описание для анонса | Краткое описание товара для анонса.
Детальная картинка | Изображение, которое выводится в детальном описании товара.
Детальное описание | Детальное описание товара.
Теги | Теги товара.
[свойство] | Выводятся значения свойств, если они указаны.
Доступность | Признак доступности товара к покупке.
Доступное количество | Количество товара, доступное к покупке.
Коэф. | Коэффициент измерения товара.
Ед. измерения | Единица измерения товара.
Уменьшать количество при заказе | Количество товара уменьшается при заказе товара или нет.
Вес (грамм) | Вес товара в граммах.
НДС включен в цену | Признак включения НДС в цену товара.
Штрих-код | Штрих-код товара.
Закупочная цена | Величина закупочной цены товара.
[тип цены] | Цена товара данного типа цены.
Количество подписок | Количество подписок на товар.

Групповые действия

Действие | Описание
активировать | Активировать элементы, которые на данный момент не активны.
деактивировать | Деактивировать активные элементы.
сбросить счётчик просмотров | Сброс счетчика просмотров элементов.
перенести в раздел | Выбор основного раздела элемента.
добавить привязку к разделу | Выбор дополнительных разделов, в которых будет отображаться элемент.
заблокировать/разблокировать Опция доступна при включенном [ds]Документообороте[/ds][di] Настройка документооборота на последовательную работу над информационными блоками включает в себя шаги:
  1. Настройка прав модуля Управление структурой.
  2. Настройки разделов, участвующих в документообороте.
  3. Создание и настройка необходимых статусов для документов.

Подробнее [image] [image]...[/di] и позволяет разрешить/запретить работу с элементом.
изменить статус Опция доступна при включенном [ds]Документообороте,[/ds][di] Настройка документооборота на последовательную работу над информационными блоками включает в себя шаги:
  1. Настройка прав модуля Управление структурой.
  2. Настройки разделов, участвующих в документообороте.
  3. Создание и настройка необходимых статусов для документов.

Подробнее [image] [image]...[/di] позволяет изменить текущий статус элемента.
параметр товаров В качестве [dw]Параметра товара[/dw][di] Групповое действие Параметр товара доступно с версии 19.0.0 модуля Информационные блоки и с 19.0.0 модуля Торговый каталог. [/di] можно указать одну из следующих позиций:
  • Вес – указывается вес торгового предложения в граммах;
  • *Режим количественного учета – включается [ds]режим количественного учёта[/ds][di] Количественный учет - режим работы с товарами в интернет-магазине на базе «1С-Битрикс: Управление сайтом», позволяющий изменять количество товара как вручную, так и автоматически после оформления заказов покупателями.

    Подробнее [image]...[/di] для отмеченных торговых предложений;
  • *Разрешение покупки при отсутствии товара – при отмеченной опции товар будет по умолчанию доступен к покупке даже при нулевом количестве;
  • *Доступное количество – количество товара в данный момент;
  • *Закупочная цена – величина закупочной цены товара;
  • НДС включен в цену – проставляется признак включения [ds]НДС[/ds][di] Налог на добавленную стоимость (НДС) — косвенный налог, форма изъятия в бюджет государства части добавленной стоимости, которая создаётся на всех стадиях процесса производства товаров, работ и услуг и вносится в бюджет по мере реализации.

    Подробнее [image] [image]...[/di] в цену товара;
  • Идентификатор НДС – выбирается одна из ранее созданных [ds]ставок НДС;[/ds][di] По умолчанию в Интернет-магазин уже включены Ставки НДС: 0% и 18%. Ставка НДС может быть разной в зависимости от товара. Создадим и применим новую Ставку НДС.

    Подробнее [image] [image]...[/di]
  • Разрешение подписки на товар – при отмеченной опции для товара будет показываться кнопка [ds]подписки,[/ds][di] Начиная с версии 16.5.3 модуля Торговый каталог, в системе доступен обновленный функционал подписок на товары, временно отсутствующие в продаже.

    Для отсутствующего в магазине товара кнопка подписки будет отображаться в том случае, если в системе для него выполнены следующие настройки:

    Подробнее [image]...[/di] если он недоступен к покупке;
  • Единица измерения – выбирается из списка созданных ранее [ds]единиц измерений;[/ds][di] Настройка единиц измерения для интернет-магазина подробно описана в видео-уроке.

    Подробнее [image]...[/di]
  • Группа товаров – опция для указания групп товаров, подлежащих обязательной [ds]маркировке.[/ds][di] В РФ в соответствии с Федеральным законом от 31 декабря 2017 г. № 487-ФЗ товары подлежат обязательной маркировке, согласно утвержденному перечню.

    Первым делом в настройках товара необходимо указать группу, к которой принадлежит товар.

    Подробнее [image]...[/di]

* – параметры, помеченные звёздочкой, отображаются только при выключенном [ds]складском учёте.[/ds][di] Складской учет - режим работы с товарами в интернет-магазине на базе «1С Битрикс: Управление сайтом», позволяющий управлять складами, вести учет поступлений и списаний товара, реализовывать оборот товара на складах с помощью документов. Для редакции Малый бизнес наложено ограничение - возможно использование только одного склада.

Подробнее [image]...[/di]

изменить цену | Редактирование цены товара.


Создание и редактирование товара

Закладки

Данная форма - одно из средств для редактирования и добавления товаров торгового каталога вручную.

Контекстная панель

Кнопка | Описание
Товары | Переход на страницу со списком товаров данного каталога.
Копировать Копирование существующего товара в пределах данного каталога. Кнопка отображается при редактировании уже существующего товара.

Обратите внимание! При копировании товаров НЕ копируются картинки и копирование возможно только в пределах одного каталога.
Параметры товара Доступные действия:
  • Товар - служит для переопределения типа товар на простой товар.
  • Товар с торговыми предложениями - служит для переопределения типа товар на товар с торговыми предложениями. Становится доступной закладка Торговые предложения.
  • Комплект - служит для переопределения типа товар на комплект. Становится доступной закладка Состав комплекта.
  • Добавить набор - служит для добавления набора рекомендуемых товаров для основного товара. При выборе данного пункта становится доступной закладка Состав набора.
  • Удалить набор - служит для удаления набора. Отображается только для существующего товара с набором.
Действия Кнопка доступна только при редактировании существующего элемента. Доступные действия:
  • Добавить товар - переход на страницу с формой создания нового товара.
  • Удалить товар - удаление редактируемого товара.
Настроить | Переход к настройке внешнего вида формы редактирования элемента.

Товар

Поле | Описание
Активность | Признак активности товара.
Начало активности | Начало периода активности товара. Если поле не заполнено, то товар считается активным с момента его сохранения.
Окончание активности | Окончание периода активности товара. Если поле не заполнено, то товар признается бессрочно активным.
*Название | Название товара, как оно отображается в публичной части.
Символьный код | Символьный код товара.
Внешний код | Код, используемый для связи инфоблока с внешним источником данных. Поле отображается при включенной опции Показывать код загрузки из внешних источников в настройках модуля Информационные блоки.
Сортировка | Вес сортировки товара. Чем меньше вес сортировки, тем выше отображается товар.
Значения свойств
[название_свойства] | Для свойства товаров каталога задается соотствующее ему значение.
Связанные элементы
Если для данного товара имеются связанные, т.е. в свойствах каких-либо инфоблоков настроена привязка к товарам данного инфоблока. Связанные элементы выведены не напрямую, а в виде ссылки в формате: [название_инфоблока]:[название_элемента]. Ссылка переводит на страницу со списком связанных элементов.

* - поля, обязательные для заполнения.

Анонс

Форма служит для задания краткого описание товара.

Поле | Описание
Картинка для анонса | Изображение малого размера, ассоциируемое с данным товаром для предпросмотра. Для выбора изображения используйте кнопку Добавить файл.
Переключатель режима ввода текста | Задается режим ввода текста краткого описания товара инфоблока: Text, HTML или Визуальный редактор. В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть на сайте.

Подробно

Форма служит для создания подробного описания товара.

Поле | Описание
Детальная картинка | Крупноформатное изображение, ассоциируемое с данным товаром. Для выбора изображения используйте кнопку Добавить файл.
Переключатель режима ввода текста | Задается режим ввода текста подробного описания товара инфоблока: Text, HTML или Визуальный редактор. В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть на сайте.

SEO

По умолчанию все настройки SEO для товара берутся из настроек для инфоблока или из настроек для раздела, а с помощью данной закладки можно задать персональные настройки SEO для товара. Прежде, чем приступать к настройке того или иного шаблона, следует отметить расположенную рядом с его полем опцию Изменить для этого товара.

Поле | Описание
Шаблон META TITLE | Задается шаблон, по которому будет создаваться мета-тег TITLE для товара. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон META KEYWORDS | Задается шаблон, по которому будет создаваться мета-тег KEYWORDS для товара. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон META DESCRIPTION | Задается шаблон, по которому будет создаваться мета-тег DESCRIPTION для товара. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Заголовок товара Задается шаблон для создания заголовка страницы просмотра товара. Вывод данного заголовка выполняется с помощью функции ShowTitle():
<H1><?$APPLICATION->ShowTitle()?></H1>
Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Настройки для картинок анонса элементов и для детальных картинок элементов
Шаблон ALT | Задается шаблон, по которому будет создаваться атрибут ALT для изображения. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон TITLE | Задается шаблон, по которому будет создаваться атрибут TITLE для изображения. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон имени файла Задается шаблон, по которому будет создаваться имя файла с изображением. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.

Имя файла будет формироваться с учетом следующих опций:
  • Привести к нижнему регистру - при отмеченной опции имя файла будет создано в нижнем регистре;
  • Транслитерировать - при отмеченной опции будет выполнена транслитерация имени файла;
  • Замена для пробельных символов после транслитерации - задается символ, который будет использоваться вместо пробела после транслитерации имени файла.
Дополнительно
Теги (введите слова или словосочетания, разделяя их запятыми) | Слова или словосочетания, с помощью которых формируется поиск по тегам.

Разделы

Форма служит для выбора одного или нескольких разделов инфоблока, к которым относится товар.

Поле | Описание
Разделы | Разделы, к которым привязан товар.

Торговый каталог

Закладка недоступна при создании типа товара товар с торговыми предложениями, если в настройках модуля Торговый каталог не отмечена опция Показывать вкладку Торговый каталог для товаров, имеющих торговые предложения.

Поле | Описание
Вкладка Цены
Вкладка служит для задания стоимости товара для разных типов цен.
Использовать расширенный режим управления ценами | При отмеченной опции форма принимает расширенный вид и позволяет задавать стоимость товара для разных типов цен с указанием дополнительных параметров, влияющих на стоимость. Вид формы описан ниже.
Ставка НДС | С появлением встроенной поддержки НДС пользователь может задать ставки НДС в специальной форме: Магазин > Торговый каталог > Ставки НДС и установить значение ставки по умолчанию для каждого торгового каталога на странице настроек модуля Торговый каталог. В этом поле выбрано значение по умолчанию. Вы можете переопределить его вручную либо установить вариант не выбрано.
НДС включен в цену | Если опция отмечена, то подразумевается, что НДС входит в указанную цену товара.
Закупочная цена | Закупочная цена товара (товара). Данное поле доступно для редактирования при выключенном в настройках торгового каталога складском учете.
Валюта закупочной цены | Валюта, в которой указана закупочная цена. Данное поле доступно для редактирования при выключенном в настройках торгового каталога складском учете.
*Базовая цена (BASE) | Базовая цена товара (товара).
*Валюта базовой цены | Валюта, в которой указана базовая цена.
Далее описание полей представлено в виде таблицы:
Поле | Описание
Тип цены | Перечень доступных типов цен товара.
Тип наценки | Поле для выбора типа наценки, используемой при формировании стоимости товара для данного типа цены.
Сумма | Стоимость товара с учётом выбранного типа наценки. Стоимость товара рассчитывается по формуле [Цена] = [Базовая цена] + [Базовая цена] * [Процент наценки] / 100. Если тип наценки не выбран, то стоимость товара для данного типа цены можно ввести вручную.
Валюта | Наименование валюты, в которой указана стоимость товара для данного типа цены.

Если отмечена опция Использовать расширенный режим управления ценами, то форма принимает расширенный вид и позволяет задавать стоимость товара для разных типов цен с указанием дополнительных параметров, влияющих на стоимость:
Поле | Описание
Тип цены | Перечень доступных типов цен товара.
От | Поля служат для задания связи между количеством приобретаемых товаров и их стоимостью. Например, можно указать, что при приобретении от 1 до 5 единиц товара, товар будет продаваться по цене 500 руб./шт, а при приобретении от 6 до 10 единиц товара, стоимость товара будет равна 400 руб./шт. Количество товара может быть задано как одним числом, так и в виде диапазона.
До
Тип наценки | Поле для выбора типа наценки, используемой при формировании стоимости товара для данного типа цены. Выбор наценки для базового типа цены не производится.
Цена (за единицу) | Стоимость единицы товара для данного типа цены, при условии приобретения указанного товаров.
Валюта | Наименование валюты, в которой указана стоимость товара для данного типа цены.

Кнопка "Ещё" позволяет добавить новую стpоку для указания стоимости товаров и условий ее применения.
Вкладка Дополнительные параметры
На вкладке указываются дополнительные сведения о продаваемом товаре, а также (если каталог настроен на продажу контента) параметры подписки на контент сайта.
Поле | Описание
Доступное количество | Сумма остатков товара на складах в данный момент.
Зарезервированное количество Количество товара, оформленного в заказах, но еще не списанного со складов.

Данный параметр отображается только при включенном механизме резервирования.
Единица измерения Задается единица измерения товара.

Поле недоступно для комплектов.
Коэффициент единицы измерения Коэффициент единицы измерения товара.

Поле недоступно для комплектов.
Параметры
Включить количественный учет Подключить количественный учет товара:
  • да;
  • нет;
  • по умолчанию (из настроек модуля Торговый каталог).
Если количественный учет данного товара отключен, то он будет продаваться всегда.
Кеш публичных компонентов сбрасывается, если меняется возможность купить товар с включенным количественным учетом.
Разрешить покупку при отсутствии товара Возможность покупать товар при его отсутствии на складе:
  • да;
  • нет;
  • по умолчанию (из настроек модуля Торговый каталог).
Если покупка при отсутствии товара разрешена, то автоматически разрешается задавать отрицательное количество товара. Чтобы покупка была запрещена при отсутствии товара, должен быть включен количественный учет для товара.
Разрешить отрицательное количество товара Включить возможность установки отрицательных значений количества товаров при его покупке:
  • да;
  • нет;
  • по умолчанию (из настроек модуля Торговый каталог).
Если покупка при отсутствии товара разрешена, то изменить значение параметра невозможно.
Разрешить подписку при отсутствии товара Включить возможность подписки на отсутствующие товары (когда товар станет доступным для покупки, клиент получит уведомление).
  • да;
  • нет;
  • по умолчанию (из настроек модуля Торговый каталог).
Вес и размеры (доступно только для обычных товаров)
Длина (мм.) | Длина товара, заданная в мм.
Ширина (мм.) | Ширина товара, заданная в мм.
Высота (мм.) | Высота товара, заданная в мм.
Вес (грамм) | Вес единицы товара в граммах.
Расширенные параметры
Группа товаров | Указывается группа, в которую входит товар, если товар подлежит маркировке в соответствии с законом № 487-ФЗ.
Параметры подписки (доступно, если инфоблок осуществляет продажу контента)
Тип оплаты Задается тип оплаты приобретения контента сайта. Доступно три типа оплаты:
  • одноразовая - означает, что товар приобретается покупателем один раз. В дальнейшем никаких движений по приобретенному товару не предусматривается;
  • регулярная (или "подписка") - означает, что по истечении заданного периода времени покупателю будет выставлен новый счет на продление использования товара;
  • пробный период ("триал") - предусматривает приобретение пробной версии товара (например, пробного доступа). По истечении указанного периода покупателю будет выставлен счет на покупку полной версии товара.
Длина периода оплаты | Указывается длительность периода времени, по истечении которого системой будет выставлен новый счет на приобретение товара. Значение поля задается для не одноразовых типов оплаты (регулярная и пробный период).
Единица времени периода оплаты | Определяются единицы времени, используемые для задания продолжительности периода оплаты (месяц, сутки, час и т.д.).
Пробная для (заполняется только для пробных) | В поле для товара с типом оплаты пробный период указывается полная версия товара. По истечении пробного периода пользователю будет предложено приобрести указанный товар (полную версию).
Продление без оформления заказа | Опция доступна для типа оплаты регулярная. Если она выбрана, то при продлении товара (пользования товаром) будет рассчитана сумма заказа. Но сам заказ не будет сформирован в базе системы. Опция может быть полезна при проведении небольших регулярных списаний с внутреннего счета покупателя.
Вкладка Группы
Вкладка Группы отображается для товаров торгового каталога, настроенного на режим продажи контента. Служит для управления продажей прав доступа к контенту сайта.
Поле | Описание
Включить | Поле для выбора группы пользователей, к которой будет осуществляться привязка покупателей данного товара.
Группа пользователей | Название группы пользователей, к которой будет осуществляться привязка покупателей данного товара.
Длительность приписывания | Длительность привязки покупателей к выбранной группе. По истечении указанного периода покупатель будет удален из списка пользователей данной группы. Если значение поля равно 0, то покупатели приписываются к группе на неограниченный период.
Вкладка Скидки
На вкладке Скидки представлены активные общие скидки, которые будут применены к данному товару.
Поле | Описание
ID | Идентификатор скидки.
Сайт | Идентификатор сайта, на товары которого распространяется действие данной скидки.
Активность | Признак активности скидки. Если скидка не является активной, она не может быть применена.
Название | Название скидки.
Величина | Размер скидки.
Действие | Доступные действия над скидками. С помощью ссылки Изменить вы можете перейти к редактированию параметров скидки.
Вкладка Склады
На вкладке Склады представлен список складов, на которых может храниться товар.
Поле | Описание
№ | Номер склада.
Название | Название склада.
Адрес | Адрес склада.
Количество товара | Количество товара на конкретном складе.
В резерве | Резервное количество товара на конкретном складе.
Вкладка Штрихкод
На вкладке Штрихкод указывается информация о штрихкоде товара. Вкладка отображается, если в настройках модуля Торговый каталог отмечена опция Включить складской учет.
Поле | Описание
Каждый экземпляр товара имеет собственный штрихкод | При отмеченной опции каждая единица товара будет иметь собственный штрихкод.
Штрихкод | Штрихкод товара. Ввод возможен как вручную, так и с помощью USB-сканера.

Торговые предложения

Закладка отображается только при создании/редактировании товаров типа товар с торговыми предложениями. На закладке выводится список торговых предложений для редактируемого товара. В этой форме можно добавить вручную [image] (кнопка Добавить товар) или сгенерировать (кнопка Генерировать торговые положения) торговые предложения для данного товара. Кроме того, с помощью кнопки Добавить предложение с набором можно создать торговое предложение с набором.

Состав комплекта

На данной вкладке осуществляется выбор товаров, которые входят в состав комплекта. Закладка доступна только при создании/редактировании типа товара комплект.

Поле | Описание
Товар | Товар, который входит в комплект. По кнопке [...] открывается окно выбора товара.
Количество | Указывается необходимое количество текущего товара в комплекте.
Процент распределения скидки | Процент, который получит текущий товар, от скидки на весь товар.
Сортировка | "Вес" товара, определяющий его положение в списке.
Удалить из комплекта | При отмеченной опции товар будет удален из комплекта. Доступно только при редактировании комплекта.
кнопка Еще | Служит для добавления полей выбора входящих в комплект товаров.

Состав набора

На данной вкладке осуществляется создание набора рекомендованных товаров, которые покупаются с основным товаром. Закладка доступна при создании/редактировании типа товара набор, при создании/редактировании торгового предложения с набором или при добавлении набора к существующему товару любого типа.

Поле | Описание
Товар | Товар, который входит в набор. По кнопке [...] открывается окно выбора товара.
Количество | Указывается необходимое количество текущего товара в комплекте.
Сортировка | "Вес" товара, определяющий его положение в списке товаров набора.
Удалить из набора | При отмеченной опции товар будет удален из набора. Доступно только при редактировании набора.
кнопка Еще | Служит для добавления полей выбора входящих в набор товаров.

Доступ

Закладка доступна, если в настройках инфоблока включен расширенный режим управления правами доступа. В закладке отображаются права доступа, установленные по умолчанию. Для изменения уровня прав воспользуйтесь кнопкой Добавить, выберите группу для которой будут изменены/назначены права и сохраните изменения.


Разделы

Например, информационный блок Торговый каталог может содержать раздел Сборка компьютеров, который, в свою очередь, может включать подразделы Компьютеры и Комплектующие.

С помощью данной формы вы можете управлять элементами иерархии (разделами и подразделами) выбранного торгового каталога.

Форма поиска

Форма фильтра используется для поиска разделов каталога в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Название* | Поиск по названию раздела. Поле присутствует, даже если фильтр свернут.
Раздел | Вышележащий (родительский) раздел.
ID раздела | Поиск раздела по его идентификатору.
Дата изменения | Поиск по дате последнего изменения параметров раздела.
Символьный код | Поиск по мнемоническому коду раздела.
Внешний код | Внешний код раздела, используемый для связи раздела с внешними источниками данных.
Кто изменил | Поиск по автору изменения.
Дата создания | Поиск по дате создания раздела.
Кто создал | Поиск по автору раздела.
Активность | Позволяет отобрать активные, неактивные или все разделы информационного блока.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать разделы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех разделов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить товар | Переход к форме создания простого товара.
Создать другие типы товаров Доступны следующие действия:
  • Создать товар с торговыми предложениями - создание товара с торговыми предложениями (действие доступно, если для инфоблока задан инфоблок торговых предложений);
  • Создать комплект - создание основного товара и комплекта к нему;
  • Создать набор - создание основного товара и набора к нему.
Добавить раздел | Переход к форме создания нового раздела для данного торгового каталога.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список разделов

Поле | Описание
Колонка флажков | Поле предназначено для выбора разделов, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия:
  • Разделы - переход к списку подразделов данного раздела.
  • Изменить - переход к форме редактирования раздела.
  • Удалить - удаление раздела.
  • Товары - переход к списку товаров данного раздела.
Название | Название раздела.
Активность | Признак активности раздела. Если раздел активен, то информация раздела доступна для отображения в публичной части сайта.
Сортировка | Вес сортировки раздела. Определяет последовательность, в которой будут показаны разделы в публичной части сайта.
Дата изм. | Дата и время последнего изменения раздела.
ID | Идентификатор раздела.

Групповые действия

Действие | Описание
активировать | Активировать разделы, которые на данный момент не активны.
деактивировать | Деактивировать активные разделы.
создать символьный код Действие создаёт символьные коды для выделенных разделов. Доступно если в настройках инфоблока [ds]выключен внешний сервис для перевода[/ds][di]Для массового создания символьных кодов удобно использовать инструмент групповой генерации символьных кодов.

Подробнее в курсе Контент-менеджер [image].[/di].
перенести в раздел | [dw]Перенести[/dw][di]Действие доступно с версии 20.5.0 модуля Информационные блоки.[/di] выбранные разделы в указанный раздел.
параметры товара В качестве [dw]Параметра товара[/dw][di] Групповое действие Параметр товара доступно с версии 19.0.0 модуля Информационные блоки и с 19.0.0 модуля Торговый каталог. [/di] можно указать одну из следующих позиций:
  • Вес – указывается вес торгового предложения в граммах;
  • *Режим количественного учета – включается [ds]режим количественного учёта[/ds][di] Количественный учет - режим работы с товарами в интернет-магазине на базе «1С-Битрикс: Управление сайтом», позволяющий изменять количество товара как вручную, так и автоматически после оформления заказов покупателями.

    Подробнее [image]...[/di] для отмеченных торговых предложений;
  • *Разрешение покупки при отсутствии товара – при отмеченной опции товар будет по умолчанию доступен к покупке даже при нулевом количестве;
  • *Доступное количество – количество товара в данный момент;
  • *Закупочная цена – величина закупочной цены товара;
  • НДС включен в цену – проставляется признак включения [ds]НДС[/ds][di] Налог на добавленную стоимость (НДС) — косвенный налог, форма изъятия в бюджет государства части добавленной стоимости, которая создаётся на всех стадиях процесса производства товаров, работ и услуг и вносится в бюджет по мере реализации.

    Подробнее [image] [image]...[/di] в цену товара;
  • Идентификатор НДС – выбирается одна из ранее созданных [ds]ставок НДС;[/ds][di] По умолчанию в Интернет-магазин уже включены Ставки НДС: 0% и 18%. Ставка НДС может быть разной в зависимости от товара. Создадим и применим новую Ставку НДС.

    Подробнее [image] [image]...[/di]
  • Разрешение подписки на товар – при отмеченной опции для товара будет показываться кнопка [ds]подписки,[/ds][di] Начиная с версии 16.5.3 модуля Торговый каталог, в системе доступен обновленный функционал подписок на товары, временно отсутствующие в продаже.

    Для отсутствующего в магазине товара кнопка подписки будет отображаться в том случае, если в системе для него выполнены следующие настройки:

    Подробнее [image]...[/di] если он недоступен к покупке;
  • Единица измерения – выбирается из списка созданных ранее [ds]единиц измерений;[/ds][di] Настройка единиц измерения для интернет-магазина подробно описана в видео-уроке.

    Подробнее [image]...[/di]
  • Группа товаров – опция для указания групп товаров, подлежащих обязательной [ds]маркировке.[/ds][di] В РФ в соответствии с Федеральным законом от 31 декабря 2017 г. № 487-ФЗ товары подлежат обязательной маркировке, согласно утвержденному перечню.

    Первым делом в настройках товара необходимо указать группу, к которой принадлежит товар.

    Подробнее [image]...[/di]

* – параметры, помеченные звёздочкой, отображаются только при выключенном [ds]складском учёте.[/ds][di] Складской учет - режим работы с товарами в интернет-магазине на базе «1С Битрикс: Управление сайтом», позволяющий управлять складами, вести учет поступлений и списаний товара, реализовывать оборот товара на складах с помощью документов. Для редакции Малый бизнес наложено ограничение - возможно использование только одного склада.

Подробнее [image]...[/di]

изменить цены [ds]Изменить цены[/ds][di] Функционал доступен с версии 16.5.3 модуля Информационные блоки.

Подробнее [image]...[/di] у всех товаров выбранных разделов. Опция доступна, если в настройках инфоблока включен совместный режим просмотра разделов и элементов.


Создание и редактирование раздела

Закладки

Данная форма служит для создания нового или редактирования параметров существующего раздела.

Контекстная панель

Кнопка | Описание
Разделы | Переход на страницу со списком разделов каталога.
Добавить раздел | Переход к форме создания нового раздела информационного блока. Кнопка отображается при редактировании существующего раздела инфоблока.
Удалить раздел | Удаление редактируемого раздела инфоблока. Кнопка отображается при редактировании существующего раздела инфоблока.
Настроить | Переход к форме настройки внешнего вида формы редактирования разделов.

Раздел

Поле | Описание
ID | Идентификатор раздела в системе. Поле отображается при редактировании существующего раздела.
Создана | Дата и время создания раздела. Поле отображается при редактировании существующего раздела.
Изменена | Дата и время последнего изменения параметров раздела. Поле отображается при редактировании существующего раздела.
Раздел активен | Признак активности раздела информационного блока. При отмеченной опции содержимое раздела инфоблока доступно для показа в публичной части сайта.
Родительский раздел | Раздел, дочерним элементом которого является этот раздел.
*Название | Название раздела.
Изображение | Изображение, ассоциируемое с данным разделом информационного блока. Для выбора изображения используйте кнопку Добавить файл.
Описание
Переключатель режима ввода текста | Задается режим ввода текста описания раздела инфоблока: Text, HTML или Визуальный редактор. В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть на сайте.

* - поля, обязательные для заполнения.

SEO

По умолчанию все настройки SEO для раздела берутся из настроек для инфоблока (вышестоящего раздела), а с помощью данной закладки можно задать персональные настройки SEO для текущего раздела и всех его подразделов. Прежде, чем приступать к настройке того или иного шаблона, следует отметить расположенную рядом с его полем опцию Изменить для этого раздела и его подразделов.

Поле | Описание
Настройки для разделов/элементов
Шаблон META TITLE | Задается шаблон, по которому будет создаваться мета-тег TITLE для раздела/элементов раздела. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон META KEYWORDS | Задается шаблон, по которому будет создаваться мета-тег KEYWORDS для раздела/элементов раздела. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон META DESCRIPTION | Задается шаблон, по которому будет создаваться мета-тег DESCRIPTION для раздела/элементов раздела. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Заголовок раздела/товара Задается шаблон для создания заголовка страницы просмотра раздела/элемента этого раздела. Вывод данного заголовка выполняется с помощью функции ShowTitle():
<H1><?$APPLICATION->ShowTitle()?></H1>
Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Настройки для изображений разделов, детальных картинок разделов, картинок анонса элементов и для детальных картинок элементов
Шаблон ALT | Задается шаблон, по которому будет создаваться атрибут ALT для изображения. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон TITLE | Задается шаблон, по которому будет создаваться атрибут TITLE для изображения. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.
Шаблон имени файла Задается шаблон, по которому будет создаваться имя файла с изображением. Кнопка [...] служит для выбора данных, на основе которых будет создан шаблон.

Имя файла будет формироваться с учетом следующих опций:
  • Привести к нижнему регистру - при отмеченной опции имя файла будет создано в нижнем регистре;
  • Транслитерировать - при отмеченной опции будет выполнена транслитерация имени файла;
  • Замена для пробельных символов после транслитерации - задается символ, который будет использоваться вместо пробела после транслитерации имени файла.
Управление
Очистить кеш вычисленных значений | При отмеченной опции очищается кеш шаблонов и все вносимые изменения в настройках отображаются сразу.

Дополнительно

Поле | Описание
Сортировка | Относительный "вес", влияющий на положение раздела в списке.
Внешний код | Символьный код, используемый для связи раздела с внешним источником данных. Поле отображается при включенной опции Показывать код загрузки из внешних источников в настройках модуля Информационные блоки.
Символьный код | Мнемонический код раздела, состоящий из латинских символов.
Детальная картинка | Детальное изображение, ассоциируемое с данным разделом информационного блока. Для выбора изображения используйте кнопку Добавить файл.

Доп. поля

На закладке имеется ссылка Добавить пользовательское свойство для добавления нового поля для раздела инфоблока. По ссылке осуществляется переход к форме создания нового поля.

Доступ

Закладка доступна, есть в настройках инфоблока включен расширенный режим управления правами доступа. В закладке отображаются права доступа, установленные по умолчанию. Для изменения уровня прав воспользуйтесь кнопкой Добавить, выберите группу для которой будут изменены/назначены права и сохраните изменения.

Свойства элементов

Поле | Описание
ссылка "Показать наследование" | Служит для показа по отдельности тех свойств, которые наследуются от самого инфоблока, а которые относятся только к данному разделу.
Таблицы со свойствами товаров и торговых предложений
[таблица_свойств]
Поле | Описание
Название | Название свойства товаров.
Тип | Тип свойства.
Показать в умном фильтре | Признак показа свойства в умном фильтре.
Вид в умном фильтре | Задается один из видов отображения (с учетом типа свойства) значений свойства в умном фильтре.
Показать развёрнутым | Признак отображения свойства в развернутом виде в умном фильтре.
Действия | Допустимое действие со свойством товаров.
кнопка "Добавить" | Добавление свойства из уже имеющихся или создание нового.

Торговые платформы

Закладка становится доступной при подключении торговых платформ, таких как ВКонтакте и eBay.

Поле | Описание
Товары ВКонтакте
Профиль экспорта | Список всех созданных профилей экспорта в магазин ВКонтакте. Настройки выполняются для каждого профиля по отдельности.
Наследовать настройки родительского раздела | Опция указывает, использовать ли собственные настройки раздела или брать их от родительского раздела. По умолчанию настройки наследуются.
Экспортировать раздел | При отключении данной опции раздел и все дочерние разделы будут исключены из экспорта.
Альбом во ВКонтакте для добавления | По умолчанию на основе каждого раздела создается альбом во ВКонтакте. Если указать здесь другой альбом - товары будут добавляться в него, альбом для текущего раздела создан не будет.
Псевдоним альбома | Позволяет использовать псевдоним при создании альбома.
Добавить в альбом товары дочерних разделов | Опция облегчает группировку товаров по альбомам. При включении товары всех дочерних разделов будут добавлены в текущий. Альбомы для дочерних разделов созданы не будут.
Категория товаров | Настройка является обязательной для добавления товара, однако на текущий момент никак не влияет на его отображение ВКонтакте. Категория выбирается из фиксированного списка.


Настройки каталога

Данная форма служит для выполнения настроек отображения свойств товаров каталога.

Закладка "Каталог"

Поле | Описание
Название | Название каталога товаров.

Закладка "Свойства элементов"

Поле | Описание
Таблицы со свойствами товаров и торговых предложений
[таблица_свойств]
Поле | Описание
Название | Название свойства товаров.
Тип | Тип свойства.
Показать в умном фильтре | Признак показа свойства в умном фильтре.
Вид в умном фильтре | Задается один из видов отображения (с учетом типа свойства) значений свойства в умном фильтре.
Показать развёрнутым | Признак отображения свойства в развернутом виде в умном фильтре.
Действия | Допустимое действие со свойством товаров.
кнопка "Добавить" | Добавление в таблицу свойства из уже имеющихся или создание нового.


Отправить отзыв по этому разделу

Складской учет

  • Документы
  • Поставщики
  • Склады
  • Создание и редактирование документа
  • Создание и редактирование поставщика
  • Создание и редактирование склада


Документы

Форма Документы (Магазин > Складской учет > Докуметы) служит для управления документами по товарам на складах. Данная страница доступна при включенной в настройках модуля Торговый каталог опции Включить складской учет.

Форма поиска

Поиск интересующих вас документов. По умолчанию выводится только поле Сайт. Остальные поля подключаются по кнопке Дополнительные условия поиска.

Поле | Описание
Сайт | Указывается, документы по товарам какого сайта следует отображать.
Тип документа | Указывается, документы какого типа следует отображать.
Дата | Поиск по дате создания документа.
Поставщик | Поиск по поставщику.
Статус Позволяет установить фильтр на отображение всех документов или документов только в определённом статусе:
  • проведен;
  • не проведен.

Чтобы отобрать документы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех документов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Создать документ | Вызов меню выбора создаваемого типа документа.
Настроить | Переход к диалогу настройки внешнего вида отчётной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список документов

Форма содержит список документов, а также значения основных полей этих документов.

Поле | Описание
Колонка флажков | Выбор документов, к которым предполагается применить какое-либо действие.
Действия Действия над документом:
  • Просмотр - переход к форме просмотра документа (доступно только для документов в статусе проведен);
  • Изменить - переход к редактированию документа (доступно для непроведенных документов);
  • Провести - проведение документа (доступно для непроведенных документов);
  • Отменить проведение - отмена проведения документа;
  • Удалить документ - удаление документа (доступно для непроведенных документов).
ID | Идентификатор документа в базе данных.
Тип документа Выводится тип документа:
  • Приход товара на склад;
  • Перемещение товара между складами;
  • Возврат товара;
  • Списание товара;
  • Отмена резервирования.
Статус Текущий статус документа:
  • проведен;
  • не проведен.
Дата создания | Показываются дата и время создания документа.
Создатель | Показываются имя\фамилия, либо логин пользователя, создавшего документ.
Поставщик | Поставщик товара, по которому составлен документ.
Сайт | Сайт интернет-магазина.
Валюта | Валюта оплаты товаров.
Сумма | Сумма заказа.

Операции над документами

К каждому документу, представленному в списке, можно применить единственно доступную операцию на панели групповых операций - удаление. Для этого отметьте нужный документ (документы), установив флажок в крайнее левое поле напротив документа, затем воспользуйтесь кнопкой [image], расположенной на панели групповых операций.

Примечание: нельзя удалить проведенный документ.


Поставщики

Форма Поставщики (Магазин > Складской учет > Поставщики) служит для управления поставщиками товаров. Данная страница доступна при включенной в настройках модуля Торговый каталог опции Включить складской учет.

Форма поиска

Поиск нужных вам поставщиков. По умолчанию выводится только поле Тип поставщика. Остальные поля подключаются по кнопке Дополнительные условия поиска.

Поле | Описание
Наименование | Поиск по названию поставщика.
E-Mail | Поиск по электронному адресу поставщика.
Телефон | Поиск номеру телефона поставщика.
ИНН | Поиск поставщика по ИНН.
КПП | Поиск поставщика по КПП.

Чтобы отобрать поставщиков по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех поставщиков нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить поставщика | Вызов формы добавления поставщика.
Настроить | Переход к диалогу настройки внешнего вида отчётной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список поставщиков

Форма содержит список поставщиков, а также значения основных полей поставщиков.

Поле | Описание
Колонка флажков | Выбор поставщиков, к которым предполагается применить какое-либо действие.
Действия Действия над поставщиком:
  • Редактировать - переход к форме изменения поставщика;
  • Удалить - удаление поставщика.
ID | Идентификатор поставщика в системе.
Наименование | Название поставщика.
E-Mail | Электронный адрес поставщика.
Адрес | Адрес поставщика.

Операции над поставщиками

К каждому поставщику, представленному в списке, можно применить операции на панели групповых операций. Для этого отметьте нужного поставщика (поставщиков), установив флажок в крайнее левое поле, затем на панели групповых операций воспользуйтесь кнопкой [image] если хотите удалить отмеченных поставщиков, либо [image] для правки значений полей E-Mail и Адрес прямо с данной страницы.


Склады

Страница Склады (Магазин > Складской учет > Склады) служит для управления складами.

Склады вводятся для упрощения работы с товарами и учета их количества при заказах.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания нового склада.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы MS Excel.

Список складов

Поле | Описание
Колонка флажков | Поле предназначено для выбора складов, к которым предполагается применить какое-либо правило или действие.
Действия Действия над складом:
  • Редактировать - редактирование склада;
  • Удалить - удаление склада.
  • Деактивировать - снятие флага активности со склада.
  • Сделать складом по умолчанию - назначение конкретного склада новым складом по умолчанию (флаг "по умолчанию" может быть только у одного склада).
ID | Идентификатор склада в базе данных.
Сорт. | Индекс сортировки склада.
Название | Название склада.
Символьный код | Символьный код склада.
Активен | Признак активности склада.
По умолчанию | Является ли данный склад складом по умолчанию.
Адрес | Адрес склада.
Изображение | Изображение для склада.
Описание | Описание склада.
GPS широта | GPS широта расположения склада.
GPS долгота | GPS долгота расположения склада.
Телефон | Телефон склада.
График работы | График работы склада.
Дата изменения | Дата и время изменения параметров склада.
Кем изменен | Логин пользователя, изменившего параметры склада.
Дата создания | Дата и время создания склада.
Кем создан | Логин пользователя, создавшего склад.
Email | Электронный адрес склада.
Пункт выдачи | Признак использования склада в качестве пункта выдачи.
Для отгрузки | Признак использования склада для отгрузки товаров.
Сайт | Сайт, к которому привязан склад.
XML_ID | Внешний код склада.


Создание и редактирование документа

Форма создания/редактирования документа служит для создания и настройки документа из административной части системы. Форма применяется для создания и редактирования документов сотрудниками магазинов без посещения публичной части сайта.

Примечание: поля формы просмотра проведенных документов закрыты для редактирования и частично дублируют поля формы создания/редактирования документа.

Контекстная панель

Кнопка | Описание
Список документов | Переход на страницу со списком документов магазина.

Форма добавления/редактирования

Основные параметры документа.

Поле | Описание
Статус Статус документа:
  • проведен;
  • не проведен.

Поле доступно в режиме редактирования документа.

Дата | Дата и время создания документа.
* Сайт | Указывается интернет-магазин, на товары которого составлен документ.
* Валюта Выбирается валюта, в которой производится оплата товара.

Поле отображается для типа документа Приход товара на склад.

* Поставщик Выбирается поставщик товара.

Поле отображается для типа документа Приход товара на склад.

Склад-источник Указывается склад, с которого пришел товар.

Поле доступно для типов документов Перемещение товара между складами и Списание товара.

Склад-получатель Указывается склад, на который пришел товар.

Поле доступно для типов документов Приход товара на склад, Перемещение товара между складами, Возврат товара.

кнопка Найти в каталоге | По данной кнопке вызывается диалог выбора товара для добавления в документ.
ссылка найти по штрихкоду | Поиск товара по его штрихкоду.
Добавить товар | По данной кнопке вызывается диалог выбора товара для добавления в документ.
Таблица со списком товаров | Вывод данных о товарах с возможностью вручную изменять количество и склад.

* - поля, обязательные для заполнения.


Создание и редактирование поставщика

Форма создания/редактирования поставщика служит для создания и настройки поставщика из административной части системы.

Контекстная панель

Кнопка | Описание
Список поставщиков | Переход на страницу со списком поставщиков.
Добавить | Переход к форме добавления нового поставщика. Кнопка отображается при редактировании существующего поставщика.
Удалить | Удаление редактируемого поставщика. Кнопка отображается при редактировании существующего поставщика.

Форма создания\редактирования

Основные параметры поставщика.

Поле | Описание
ID Уникальный идентификатор поставщика в системе.

Поле доступно только в режиме редактирования поставщика.

* Тип поставщика Выбирается тип поставщика:
  • Физическое лицо;
  • Юридическое лицо.

В зависимости от выбранного типа будут меняться поля формы.

* Ф.И.О. Фамилия, Имя и Отчество физического лица.

Поле доступно для типа поставщика Физическое лицо.

* Название компании Наименование компании.

Поле доступно для типа поставщика Юридическое лицо.

ИНН ИНН поставщика.

Поле доступно для типа поставщика Юридическое лицо.

КПП КПП поставщика.

Поле доступно для типа поставщика Юридическое лицо.

* Контактное лицо Контактное лицо фирмы.

Поле доступно для типа поставщика Юридическое лицо.

Телефон | Телефон поставщика.
E-Mail | Электронный адрес поставщика.
Индекс | Индекс поставщика.
Адрес Адрес поставщика.

Поле доступно для типа поставщика Физическое лицо.

Юридический адрес Юридический адрес поставщика.

Поле доступно для типа поставщика Юридическое лицо.

* - поля, обязательные для заполнения.


Создание и редактирование склада

Данная форма служит для создания нового или редактирования существующего склада.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу, содержащую полный список складов.
Добавить | Переход к форме создания нового склада. Кнопка отображается при редактировании существующего склада.
Удалить | Удаление редактируемого склада. Кнопка отображается при редактировании существующего склада.

Форма редактирования

Поле | Описание
ссылка Добавить пользовательское свойство | Служит для добавления нового поля для склада. По ссылке осуществляется переход к форме создания нового поля.
ID | Уникальный идентификатор склада. Поле отображается при редактировании существующего склада.
Активен | Признак активности склада.
Пункт выдачи | При отмеченной опции склад будет использоваться в качестве пункта выдачи.
Для отгрузки | При отмеченной опции склад будет использоваться как место отгрузки товаров.
Сайт | Сайт, к которому привязан склад.
Название | Наименование склада.
Символьный код | Символьный код (XML_ID) склада.
*Адрес | Адрес склада.
Описание | Описание склада.
Телефон | Телефонный номер склада.
График работы | Указывается график работы склада.
Email | Электронный адрес склада.
GPS широта | Указывается GPS широта расположения склада.
GPS долгота | Указывается GPS долгота расположения склада.
XML_ID. | XML-идентификатор склада.
Сорт. | Индекс сортировки склада. Используется для отображения склада в списке.
Изображение | Нажмите кнопку Добавить файл чтобы прикрепить к профилю склада какой-либо файл.
* - поля, обязательные для заполнения.


Отправить отзыв по этому разделу

Компоненты

  • Импорт в Highload-блоки


Импорт в Highload-блоки

Отправить отзыв по этому разделу
Магазин>Торговый каталог>Компоненты>Импорт в Highload-блоки

Компоненты::Импорт в Highload-блоки

Описание catalog.import.hl

catalog.import.hl - компонент импорта в хайлоаблоки. Используется при обмене с 1С для выгрузки на сайт справочников.

Компонент отсутствует в визуальном редакторе.

Компонент относится к модулю Торговый каталог.

Параметры

Поле | Параметр | Описание
Желаемая максимальная длительность одного шага | INTERVAL | Указывается интервал одного шага в секундах при импорте каталога в систему. 0 - выполнять загрузку за один шаг.
Группы пользователей, которым разрешена загрузка | GROUP_PERMISSIONS | Указывается группа(-ы) пользователей, которым разрешено экспортировать инфоблок через этот компонент.
Использование сжатия | USE_ZIP | [Y|N] При отмеченной опции данные сжимаются ZIP форматом (если доступно). Это позволяет заметно уменьшить размер файлов.
Желаемый максимальный размер одного архива | FILE_SIZE_LIMIT | Указывается размер единовременно загружаемой части файла в байтах. Передаётся в 1С
Использование специального каталога | USE_TEMP_DIR | [Y|N] При отмеченной опции используется специальный каталог для временных файлов обмена.

Пример вызова

<?APPLICATION->IncludeComponent("bitrix:catalog.import.hl", "", Array(
        "INTERVAL" => COption::GetOptionString("catalog", "1C_INTERVAL", "-"),
        "GROUP_PERMISSIONS" => explode(",", COption::GetOptionString("catalog", "1C_GROUP_PERMISSIONS", "")),
        "FILE_SIZE_LIMIT" => COption::GetOptionString("catalog", "1C_FILE_SIZE_LIMIT", 200*1024),
        "USE_CRC" => COption::GetOptionString("catalog", "1C_USE_CRC", "Y"),
        "USE_ZIP" => COption::GetOptionString("catalog", "1C_USE_ZIP", "Y"),
        )
    );?>


Клиенты

Сущности раздела
Название | Описание
Коммуникации с клиентами Модуль решает следующие задачи:
  • Гибкая настройка необходимых каналов связи для каждой части сайта;
  • Настройка сценариев работы для мобильных устройств;
  • Информационная поддержка клиентов;
  • Полная интеграция с Битрикс24.CRM;
  • Динамическое управление потоком клиентов (от первого входа до повторных продаж);
  • Ведение единой клиентской базы для работы нескольких сайтов.
Настройки модуля | Форма настроек модуля Интеграция с Битрикс24 (Настройки > Настройки продукта > Настройки модулей > Интеграция с Битрикс24) предназначена для подключения портала Битрикс24 к сайту и разделения прав на доступ к модулю.

Смотрите также:

  • Клиенты (учебный курс "Администратор. Модули")
  • Коммуникации с клиентами (учебный курс "Администратор. Модули)
  • Каналы коммуникаций (учебный курс "Администратор. Модули")


Настройки модуля Интеграция с Битрикс24

Закладки

Форма настроек модуля Интеграция с Битрикс24 (Настройки > Настройки продукта > Настройки модулей > Интеграция с Битрикс24) предназначена для подключения портала Битрикс24 к сайту и разделения прав на доступ к модулю.

Подключение

На закладке расположена кнопка Подключить, с помощью которой осуществляется интеграция портала Битрикс24 и сайта на основе 1С Битрикс "Управление сайтом". После нажатия кнопки Вам будет предложено либо создать новый портал Битрикс24, либо подключить и подтвердить доступ к уже существующему порталу (для подключения необходимо обладать правами администратора на сайте и на портале). Подробнее процесс подключения описан в учебном курсе [image].

Доступ

Закладка позволяет настроить права на доступ к модулю для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Веб-аналитика:
  • [D] доступ закрыт - запрет на доступ;
  • [M] просмотр статистики без финансовых показателей - просмотр статистических показателей, кроме финансовых величин доходов и убытков;
  • [R] просмотр всей статистики - просмотр всех статистических показателей, включая финансовые;
  • [W] полный административный доступ - полный доступ к ресурсам модуля (просмотр статистических показателей, права на изменение настроек и редактирование).
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.

Смотрите также

  • Подключение Битрикс24 (учебный курс "Администратор. Модули")
  • Каналы коммуникаций (учебный курс "Администратор. Модули")


Коммуникации с клиентами

Вы можете подключить сайт на базе 1С-Битрикс: Управление сайтом к порталу Битрикс24, и тем самым получить доступ к цифровым каналам коммуникаций с клиентами. Модуль Коммуникации с клиентами решает следующие задачи:

  • Гибкая настройка необходимых каналов связи для каждой части сайта;
  • Настройка сценариев работы для мобильных устройств;
  • Информационная поддержка клиентов;
  • Полная интеграция с Битрикс24.CRM;
  • Динамическое управление потоком клиентов (от первого входа до повторных продаж);
  • Ведение единой клиентской базы для работы нескольких сайтов.

Общение с клиентами реализуется по следующим каналам (для получения подробной информации перейдите по ссылке):

  • Онлайн-чат [image] - чат для сопровождения клиента по сайту, поддержки, помощи в выборе или оформлении заказа;
  • Обратный звонок [image] - запрос обратного звонка для получения консультации;
  • CRM-форма [image] - форма для получения информации о клиенте и экспорта полученной информации в Битрикс24.CRM;
  • Открытые линии [image] - единый онлайн-чат, использующий цифровые каналы связи (Facebook*, VK, Telegram, Skype и др.);
  • Телефония [image] - интеграция с телефонией системы Битрикс24.

* деятельность организации запрещена в Российской Федерации.

Смотрите также

  • Коммуникации с клиентами (учебный курс "Администратор. Модули")
  • Подключение Битрикс24 (учебный курс "Администратор. Модули")


Сервисы

Модули раздела
Название | Описание
Бизнес-процессы | Предназначен для автоматизации бизнес-процессов организации, управления всеми этапами процесса и необходимыми для его исполнения действиями.
Блоги Модуль предоставляет следующие возможности:
  • создавать неограниченное число блогов;
  • управлять правами доступа к блогам;
  • настраивать иконки и смайлики для использования в сообщениях блога;
  • обрабатывать смайлики и теги при показе сообщений и комментариев;
  • создавать черновик сообщения;
  • использовать календарь сообщений;
  • импортировать блоги в RSS;
  • использовать механизм Trackback;
  • Tags (возможность группировки сообщений блога по произвольным темам);
  • создавать древовидные комментарии;
  • присоединять изображения к сообщениям.
Веб-мессенджер | Дополняет привычные способы общения - телефон и электронную почту, позволяя эффективно общаться и получать информацию прямо через браузер.
Веб-формы | Позволяет создавать произвольное количество веб-форм, а также осуществлять гибкое управление параметрами созданных форм. Основное назначение веб-форм - это организация обратной связи с посетителями сайта.
Видеоконференции (КП) | Предоставляет возможность проведения видеоконференцсвязи.
Внешние источники данных (КП) | Позволяет подключать различные внешние сервисы в корпоративный портал. Например можно выводить в Живую ленту портала, Рабочей группы, конкретного пользователя; а так же в RSS-ленту и т.п. информацию с внешних источников с помощью любого POST-запроса, RSS-ленты или используя XML-файл.
Интранет (КП) | Предназначен для управления задачами и поручениями, организации коллективных событий, резервирования переговорных и ресурсов, работы с электронными заявками.
Календарь событий | Дает возможность просматривать график грядущих и прошедших событий сотрудников.
Конструктор отчетов (КП) | Позволяет сотрудникам самим конструировать отчеты для разных объектов и в дальнейшем многократно их запускать.
Экстранет (КП) | Расширение для продукта «Битрикс24 в коробке», которое позволяет компании осуществлять конфиденциальную связь с поставщиками, дистрибуторами и другими внешними пользователями без доступа к внутрикорпоративной информации.
Контроллер | Предназначен для группового централизованного администрирования, обновления, мониторинга большого количества сайтов, расположенных как на этом же сервере, так и на удаленных серверах, доступных через Интернет.
Менеджер идей | Позволяет предложить свою идею для развития бизнеса компании, оценить идеи своих коллег. Каждая идея имеет свой рейтинг, который строится на основе мнения сотрудников компании.
Опросы, голосования | Позволяет проводить опросы и голосования, которые помогут вам узнать мнение пользователей сайта по различным вопросам.
Обучение | Предназначен для создания обучающих курсов и проведения тестов.
Подписка, рассылки Предназначен для создания рассылок почтовых сообщений. Почтовые рассылки отсылаются группам зарегистрированных подписчиков или пользователей сайта.

Примечание: В продуктах 1С-Битрикс, начиная с версии 15.0.1, появился новый модуль E-mail маркетинг c более продвинутыми функциями организации рассылок сайта.
Почта | Альтернативный подход к управлению почтовыми сообщениями (решение не исключает возможности чтения почтовых сообщений привычными средствами).
Рейтинги | Служит для вывода численных показателей, отражающих полезную активность человека, ценность контента для сообщества.
Смайлы | Единое место в системе для хранения смайлов, используемых разными модулями.
Социальная сеть Предоставляет следующие возможности:

  • создание персонального профайла пользователя с возможностью его редактирования;
  • настройка прав на доступ к содержимому личной страницы;
  • создание произвольного числа рабочих групп;
  • настройка прав на доступ к группе и содержимому ее страницы;
  • форумы, блоги, календари и фотогалереи сотрудников и рабочих групп;
  • классификация и поиск групп.
Социальные сервисы | Начиная с 10 версии, появилась возможность авторизации на сайтах, работающих под управлением «1С-Битрикс: Управление сайтом» и «Битрикс24 в коробке», с помощью социальных сетей ВКонтакте, Twitter, МойМир@Mail.Ru и других внешних сервисов авторизации. Благодаря этой новинке владельцы сайтов могут предоставить своим пользователям возможность авторизоваться под уже существующим аккаунтом социальной сети.
Стикеры | Функционал веб-стикеров позволяет создавать заметки прямо поверх сайта. Причем заметку можно привязать к какой-то области на странице, выделив ее курсором мыши, или к элементам страницы (меню, новостям, ссылкам и прочему). Также можно изменять цвет, форматировать текст и давать прямую ссылку другим пользователям на ваш стикер. При переходе по этой ссылке окно браузера прокрутится до нужной заметки.
Техподдержка | Позволяет организовать систему обращений посетителей к группе, ответственной за консультирование и техподдержку клиентов.
Учёт рабочего времени (КП) | Позволяет организовать контроль за использованием рабочего времени сотрудниками компании и учет поставленных в план и выполненных ими задач.
Форум Служит для создания и управления форумами сайта. Основные возможности модуля включают:

  • возможность самостоятельно строить и гибко модифицировать публичную часть (внешний вид) форума, опираясь на высокоуровневые функции и классы ядра форума;
  • создавать необходимое число форумов;
  • гибко регулировать права доступа клиентов на чтение и отправку сообщений в форум;
  • создавать модерируемые и постмодерируемые форумы;
  • назначать модераторами форума группы сотрудников;
  • устанавливать звания (статусы) посетителей в зависимости от количества баллов, присвоенных тому или иному посетителю другими посетителями или полученных им за количество сообщений;
  • управлять настройками форумов;
  • прочие возможности.
CRM (КП) | Система управления взаимодействием с клиентами (или CRM, сокр. от англ. Customer Relationship Management System) — система, предназначенная для повышения уровня продаж, оптимизации маркетинга и улучшения обслуживания клиентов. В CRM сохраняется информация о клиентах и история взаимоотношений с ними для последующего анализа результатов.


Бизнес-процессы. Описание модуля

Описание модуля

Модуль Бизнес-процессы предназначен для автоматизации бизнес-процессов организации, управления всеми этапами процесса и необходимыми для его исполнения действиями.

Модуль входит в состав редакции Энтерпрайз и Бизнес продукта "1С-Битрикс: Управление сайтом".

Примечание: ограничения распространяются только на новые процессы [image], которые работают с живой лентой (прежние Бизнес-процессы в CRM, списках (только для тарифа Компания), документах не меняются, для них нет ограничений).

О работе с модулем подробно можно узнать в статьях helpdesk.bitrix24.ru [image] и курсах Администратор. модули [image] и Администратор сервиса Битрикс24 (коробочная версия) [image]. Также доступен отдельный курс Бизнес-процессы [image], в котором рассматривается разработка бизнес-процессов [image].

Коротко:

  • В настройках нужного вам инфоблока в выпадающем списке Участвует в документообороте или бизнес процессах выбрать значение бизнес процессы. В результате на странице со списком элементов инфоблока появится кнопка, ведущая на страницу со списком шаблонов бизнес-процессов.
  • После этого выполняется создание шаблона бизнес-процесса с использованием специального конструктора.
  • Запуск бизнес-процесса осуществляется при создании и/или редактировании элемента инфоблока.

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Бизнес-процесс (комплексный компонент) | bizproc.wizards | Служит для создания полноценного публичного интерфейса для работы с бизнес-процессами организации.

Смотрите также

  • Настройка инфоблоков на работу с бизнес-процессами
  • Бизнес-процессы и новости
  • Настройка библиотек документов на работу с бизнес-процессами


Бизнес-процессы. Настройки модуля

Форма настроек модуля Бизнес-процессы (Настройки > Настройки продукта > Настройки модулей > Бизнес-процессы) предназначена для задания общесистемных параметров модуля.

Поле | Описание
Время хранения лога выполнения бизнес-процесса (дней) | Задается время хранения журнала выполнения бизнес-процесса в днях.
Не сохранять в лог события | Опция позволяет сократить объем данных, записываемых в лог.
Максимальное количество одновременно запущенных над документом процессов | Опция позволяет ограничить количество процессов, которые одновременно могут быть запущены для документа.
Включить режим совместимости для типа "Привязка к сотруднику" | Опция позволяет включить режим совместимости для старых шаблонов бизнес-процессов с новыми версиями модуля в случае возникновения проблем с типом данных "Привязка к сотруднику". Данную опцию рекомендуется включать только в случае возникновения проблем с типом данных "Привязка к сотруднику", в остальных случаях она должна быть отключена.
Использовать компрессию при хранении данных | Опция позволяет установить необходимость использования компрессии данных при работе с бизнес-процессам. Если выбрать вариант По умолчанию, то использование компрессии будет определяться возможностями системы.
Путь к списку зависших бизнес-процессов | Указывается каталог хранения экземпляров запущенных бизнес-процессов, которые зависли в процессе их исполнения.
Минимальное время ожидания для действий | Опция позволяет установить минимальное время ожидания для действий. Если в настройках действия в Визуальном конструкторе указать время меньшее, чем указано в этом параметре, то значение этого параметра будет использоваться как время ожидания.


Задания

Форма поиска

Форма позволяет выполнить поиск заданий, соответствующих указанным условиям.

Поле | Описание
Изменен | Поиск заданий по дате их изменений.
Название | Указывается название задания для его поиска.
ID пользователя | Поиск заданий по идентификатору исполнителя.

Чтобы отобрать задания по заданным критериям поиска, нажмите кнопку Найти. Для отображения всего списка заданий нажмите кнопку Отменить.

Список заданий

Поле | Описание
Действия Доступные действия:
  • Посмотреть задание - переход на страницу просмотра информации о задании.
ID | Идентификатор задания в системе.
Название | Название задания.
Описание | Описание выполняемых в задании действий.
Изменен | Дата и время последнего изменения задания.
Бизнес-процесс | Название бизнес-процесса, по которому выполняется задание.
Статус | Статус выполняемого задания.
Пользователь | Пользователь, которому назначено задание.

Смотрите также

  • Задания бизнес-процессов (учебный курс "Администратор. Модули")


Просмотр задания

Данная страница служит для просмотра информации о задании и его выполнения.

Контекстная панель

Кнопка | Описание
Вернуться | Переход на страницу со списком заданий.

Форма просмотра задания

Поле | Описание
Название задания | Название просматриваемого задания.
Описание задания | Описание действий, необходимых для выполнения задания. По ссылке Перейти к документу осуществляется переход на страницу редактирования документа (элемента информационного блока).
Комментарий | Произвольный комментарий к заданию.


Блоги. Описание модуля

Описание модуля

Модуль Блоги предоставляет следующие возможности:

  • создавать неограниченное число блогов;
  • управлять правами доступа к блогам;
  • настраивать иконки и смайлики для использования в сообщениях блога;
  • обрабатывать смайлики и теги при показе сообщений и комментариев;
  • создавать черновик сообщения;
  • использовать календарь сообщений;
  • импортировать блоги в RSS;
  • использовать механизм Trackback;
  • Tags (возможность группировки сообщений блога по произвольным темам);
  • создавать древовидные комментарии;
  • присоединять изображения к сообщениям.

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Блоги (комплексный компонент) | blog | Создает полноценный публичный интерфейс блога.
Сообщения блога | blog.blog | Выводит сообщения блога с возможностью их фильтрации по категории и дате.
Черновики сообщений блога | blog.blog.draft | Выводит неопубликованные сообщения текущего пользователя блога.
Редактирование блога | blog.blog.edit | Служит для изменения параметров и настройки блога.
Лучшие сообщения блога | blog.blog.favorite | Выводит список лучших сообщения блога на основе отметок владельца блога (при создании сообщений владелец блога указывает индекс сортировки сообщения).
Календарь | blog.calendar | Выводит календарь сообщений блога.
Теги блога | blog.category | Служит для редактирования тегов сообщений блога.
Комментируемые сообщения | blog.commented_posts | Выводит наиболее комментируемые сообщения блогов за заданный период.
Лента друзей | blog.friends | Выводит сообщения друзей пользователя блога.
Блоги группы | blog.group.blog | Выводит блоги группы.
Группы блогов | blog.groups | Выводит непустые группы блогов.
Информация о блоге | blog.info | Выводит информацию о блоге со списком тегов.
Меню блогов | blog.menu | Выводит меню блога.
Новые блоги | blog.new_blogs | Выводит новые блоги.
Новые комментарии | blog.new_comments | Выводит последние комментарии к сообщениям блогов.
Новые сообщения | blog.new_posts | Выводит последние сообщения блогов текущего сайта.
Последние сообщения всех блогов | blog.new_posts.list | Выводит последние сообщения блогов с постраничной навигацией.
Популярные блоги | blog.popular_blogs | Выводит популярные блоги.
Популярные сообщения | blog.popular_posts | Выводит наиболее просматриваемые сообщения блогов за заданный период.
Сообщение детально | blog.post | Выводит сообщение блога подробно.
Комментарии к сообщению | blog.post.comment | Выводит комментарии к сообщению блога с возможностью добавления нового комментария.
Редактирование сообщения | blog.post.edit | Служит для создания новых или редактирования существующих сообщения блога.
Trackback'и сообщения | blog.post.trackback | Выводит Trackback-адрес и Trackback'и к сообщению блога.
Получение Trackback'ов к сообщению | blog.post.trackback.get | Получает Trackback к сообщению блога.
[link=63218 ]RSS блога[/link] | blog.rss | Выводит RSS блогов в заданном формате.
RSS блогов по группам/сайтам | blog.rss.all | Выводит RSS блогов группы или сайта в заданном формате.
Ссылки на RSS блога | blog.rss.link | Выводит ссылки на RSS блога.
Поиск по блогам | blog.search | Выводит непустые группы блогов.
Профиль пользователя | blog.user | Позволяет просмотреть и изменить профиль пользователя.
Группы пользователей блога | blog.user.group | Служит для редактирования группы пользователей блога.
Настройка пользователей блога | blog.user.settings | Позволяет настраивать пользователей блога: добавлять их в друзья, удалять.
Настройка прав пользователя блога | blog.user.settings.edit | Позволяет настраивать привязку пользователя к группам блога.
Неопубликованные сообщения блога | blog.blog.moderation | Выводит сообщения блога, требующие модерации.
Получение данных в формате metaWeblog | blog.metaweblog | Осуществляет импорт в формате MetaWeblog.

Смотрите также

  • Настройки модуля блогов
  • Блоги (учебный курс "Администратор. Модули")
  • Блоги (учебный курс "Контент-менеджер")


Блоги. Настройки модуля

Закладки

Настройки модуля блогов

Форма настроек модуля Блоги (Настройки > Настройки продукта > Настройки модулей > Блоги) предназначена для задания общесистемных параметров модуля. Для удобства работы форма разделена на закладки, на каждой из которых выполняется настройка определённой группы параметров модуля.

Поле | Описание
Максимальный размер аватара (байт) | Указывается максимально допустимый размер (в байтах) аватара пользователя.
Максимальная ширина загружаемого изображения (пикселов) | Указывается максимальная ширина (в пикселах) изображения к сообщению.
Максимальная высота загружаемого изображения (пикселов) | Указывается максимальная высота (в пикселах) изображения к сообщению.
Максимальный размер загружаемого изображения (байт) | Указывается максимально допустимый размер (в байтах) загружаемого изображения.
Разрешить использование псевдонимов | При отмеченной опции будет разрешено использование псевдонимов.
Запретить изменение URL блога после регистрации | При отмеченной опции будет запрещено изменение URL блога (изменение названия блога, заданного латиницей) после регистрации.
Показывать IP в комментариях для владельцев блогов | При отмеченной опции будут отображены IP-адреса посетителей, оставивших комментарии.
Разрешить использование Trackback | При отмеченной опции будет разрешено использование Trackback механизма.
Разрешить вставку видео | При отмеченной опции в сообщения можно будет вставлять видео.
Добавлять к ссылкам rel='nofollow' и тег <noindex> | При отмеченной опции все ссылки в сообщениях и комментариях блога будут обрамляються тегом <noindex> и будет добавляться параметр rel='nofollow'.
Использовать автосохранение для сообщений | При отмеченной опции для новых сообщений блога будет включен режим автосохранения.
Проверять права для изображений | При отмеченной опции в случае попытки просмотреть картинку блога будет осуществлена проверка прав на просмотр сообщения/комментария, ее содержащего. Опция введена в контексте политики безопасности.
Использование CAPTCHA в комментариях (для неавторизованных пользователей) Указывается способ использования CAPTCHA для неавторизованных пользователей блога при добавлении комментариев:
  • Определяется пользователем;
  • Обязательно;
  • Отключено.
Отправлять пинг (http://www.weblogs.com) об изменениях в блоге | При отмеченной опции будут использоваться пинг сервисы.
Адреса для пинга (каждый адрес с новой строки) | Задается список сервисов для пинга. Каждый адрес указывается с новой строки.
Максимальные права на <право_доступа> Для каждого максимального права доступа:
  • сообщения для неавторизованных пользователей;
  • комментарии для неавторизованных пользователей;
  • сообщения для авторизованных пользователей;
  • комментарии для авторизованных пользователей;
  • сообщения для групп пользователей блога;
  • комментарии для групп пользователей блога.
задается одно из прав:
  • Запрещен;
  • Чтение;
  • Запись с премодерацией;
  • Запись;
  • Модерирование;
  • Администрирование.
Галерея смайлов блога | Задается галерея используемых смайлов.

Шаблоны путей

Поле | Описание
Шаблоны путей к публичной части блогов (по сайтам)
Шаблоны путей для сайта <название_сайта> Задается шаблон путей к публичной части блогов для компонентов 2.0 каждого сайта системы. Задаются следующие шаблоны путей:
  • Шаблон пути к блогу;
  • Шаблон пути к сообщению блога;
  • Шаблон пути к пользователю блога;
  • Шаблон пути к блогу группы (для социальных сетей);
  • Шаблон пути к сообщению блога группы (для социальных сетей);
Пути к публичной части блогов для компонентов 1.0 (по сайтам)
Шаблоны путей для сайта <название_сайта> | Задается шаблон путей к публичной части блогов для компонентов 1.0 каждого сайта системы.

Права на доступ

Закладка позволяет настроить права на доступ к модулю для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Блоги:
  • [D] чтение блогов - просмотр блогов в публичном разделе;
  • [N] создание блогов - создание блога в публичном разделе сайта;
  • [R] просмотр административной части - управление блогами в публичном разделе и разрешение просмотра в административной части без права модификаций;
  • [W] полный доступ - полный доступ к ресурсам модуля.


Список блогов

Фильтр

С помощью формы выполняется поиск блогов в соответствии с указанными условиями.

Параметр | Описание
Название* | Название блога. Поле присутствует, даже если фильтр свернут.
Активность | Поиск можно задать по активным, неактивным или всем блогам.
Путь | Путь к блогу для данного сайта.
Группа | Указывается группа, по которой будет проходить поиск, либо поиск будет выполнен по всем группам.
Владелец* | Имя владельца блога.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Для того чтобы отобрать блоги по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех блогов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Новый блог | Переход к форме создания нового блога.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из таблицы в MS Excel.

Список блогов

Поле | Описание
Колонка флажков | Поле для выбора блогов, к которым предполагается применить какое-либо правило или действие.
Действия Действия над блогом:
  • Изменить параметры блога - переход к форме редактирования блога;
  • Удалить блог - удаление блога.
ID | Идентификатор блога.
Название | Указывается имя пользователя блога.
Дата создания | Дата создания блога.
Дата последнего обновления | Дата последнего обновления блога.
Активность | Признак активности блога. Если блог неактивен, то он не может быть использован.
Владелец | Пользователь, который является владельцем блога.
Группа-владелец блога | Название группы-владельца блога.
Путь | Название блога латиницей, которое используется при указании пути к блогу.
Группа | Название группы, к которой привязан блог.
HTML | Разрешено ли в блоге использование визуального редактора и HTML.
Соц. сеть | Используется ли блог в рамках cоциальной сети.

Смотрите также

  • Блоги (учебный курс "Контент-менеджер")


Создание и редактирование блога

Закладки

Контекстная панель

Форма служит для создания нового или редактирования существующего блога. Каждый пользователь может завести только один блог.

Кнопка | Описание
Список блогов | Переход на страницу co списком блогов.
Новый блог | Переход к форме создания нового блога. Кнопка отображается при редактировании существующего блога.
Удалить блог | Удаление редактируемого блога. Кнопка отображается при редактировании существующего блога.

Параметры блога

Поле | Описание
ID | Уникальный идентификатор блога.
*Название | Название блога.
Описание | Поле для ввода описания к блогу.
*Название латинскими буквами | Название блога латинскими буквами. Допустимы латинские буквы, цифры, знаки тире и подчеркивания.
Активность | Признак активности блога.
Владелец блога | Указывается идентификатор пользователя, который является владельцем блога. Кнопка [...] позволяет выбрать пользователя из списка.
Группа-владелец блога | Если в редакцию продукта входит модуль Социальная сеть, то для блога рабочей группы указывается идентификатор данной рабочей группы.
*Группа блогов | Название группы, к которой относится блог.
Разрешить комментарии в блоге | Установка этого флага разрешает создавать комментарии к сообщениям.
Включена защита от роботов (CAPTCHA) | При включении этого флага будет использоваться технология CAPTCHA.
Включена выгрузка в RSS .92, RSS 2.0 и Atom .03 | Данная опция определяет возможность экспорта данных блога в форматы RSS .92, RSS 2.0 и Atom .03.
Отправлять уведомления на email | Отправка извещения о создании новых сообщений или комментариев на e-mail владельца блога.
Индексировать блог модулем поиска | При отмеченной опции блог будет индексироваться модулем поиска. Внимание: при включении индексации блога необходимо переиндекcировать модуль.
Блог используется в рамках cоциальной сети | При отмеченной опции блог будет использоваться в социальной сети. Опция доступна, если данный блог относится к используемой в рамках соцсети группе блогов.
Параметры текстового редактора
5 полей настройки редактора | Указание какие функции редактора будут доступны при написании комментариев к сообщениям. Для разрешения включения видео необходимое аналогичное разрешение в настройках модуля Блог.

* - Поля, обязательные для заполнения.

Право на доступ

На этой закладке настраиваются следующие права на доступ к блогу:

  • Права на сообщения;
  • Права на комментарии.

Каждое из этих прав настраивается для:

  • всех посетителей;
  • авторизованных посетителей;
  • друзей.

Дополнительные свойства

На данной закладке отображаются дополнительные свойства, созданные пользователем. Для добавления нового свойства служит ссылка Добавить пользовательское свойство.

Смотрите также

  • Блоги, создание блога (учебный курс "Контент-менеджер")


Группы блогов

Фильтр

На странице Группы блогов (Сервисы > Блоги > Группы блогов) представлена таблица, содержащая список групп блогов. Она служит для добавления новых групп, а также для перехода к редактированию существующих.

Параметр | Описание
Сайт | Поиск групп блогов по заданному сайту или по всем сайтам. Поле присутствует, даже если фильтр свернут.
Название | Поиск групп блогов, в которых встречается указанное название полностью или частично.

Чтобы отобрать группу по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех групп блогов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Новая группа | Переход к форме создания новой группы блогов.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из таблицы в MS Excel.

Список групп блогов

Поле | Описание
Колонка флажков | Выбор группы блогов, к которой предполагается применить какое-либо правило или действие.
Действия Действия над группой:
  • Изменить параметры группы - переход к форме редактирования группы блогов;
  • Удалить группу - удаление группы блогов.
ID | Идентификатор группы.
Название | Название группы.
Сайт | Привязка группы блогов к указанному сайту.

Смотрите также

  • Группы блогов (учебный курс "Контент-менеджер")


Комментарии

Фильтр

На странице Комментарии (Сервисы > Блоги > Комментарии) представлена таблица со списком комментариев. Она служит для просмотра всех имеющихся комментариев к сообщениям на сайте, а также их удаления или скрытия.

С помощью формы выполняется поиск комментариев в соответствии с указанными условиями.

Параметр | Описание
ID | Идентификатор комментария. Поле присутствует, даже если фильтр свернут.
Дата создания | Можно задать поиск по комментариям, опубликованным в течении какого-либо заданного промежутка времени.
Автор | Поиск по имени зарегистрированного на сайте пользователя, отправившего комментарий.
Имя автора | Поиск по имени, которое указал при отправке комментария, неавторизованный на сайте пользователь.
Email автора | Email автора комментария. Поиск проводится по неавторизованным на сайте пользователям.
Анонимный автор | Указание того, авторизован ли был на сайте автор комментария.
Текст комментария | Полный текст или часть комментария.
IP автора | IP-адреса компьютера, с которого был отправлен комментарий.
IP1 автора | Поиск комментариев, отправленных этим же пользователем, но с другого IP.
Опубликован | Отметка того, является ли комментарий уже опубликованным на сайте.
Блог | Название или ID блога, где был оставлен комментарий.
Сообщение | ID сообщения, к которому был написан комментарий.
Владелец блога | Хозяин блога.
Группа-владелец блога | Группа пользователей, имеющая полный доступ к блогу.
Блог активен | Поиск может быть как по активным и неактивным блогам, так и по обоим типам.
Группа блогов | Можно выбрать группу блогов, в которой нужно произвести поиск.
Сайт | Сайт,на котором будет выполняться поиск.

Для того чтобы отобрать блоги по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех блогов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из таблицы в MS Excel.

Список комментариев

Поле | Описание
Колонка флажков | Поле для выбора комментариев, к которым предполагается применить какое-либо действие.
Действия Действия над комментариями:
  • Скрыть - присвоение комментарию статуса "неопубликован";
  • Удалить - удаление комментария.
ID | Идентификатор комментария.
Опубликован | Статус комментария.
Дата создания | Дата создания комментария.
Автор | Автор комментария.
Комментарий | Текст комментария.
Сообщение | Сообщение, к которому был написан комментарий.
Блог | Идентификатор и имя блога, в котором был помещен комментарий.
IP | IP компьютера, с которого был отправлен комментарий. Нажав на Стоп-лист можно ограничить доступ этого посетителя на сайт

Смотрите также

  • Комментарии (учебный курс "Контент-менеджер")


Создание и редактирование группы блогов

Контекстная панель

Кнопка | Описание
Список групп | Переход на страницу со списком групп блогов.
Новая группа | Переход к форме создания новой группы. Кнопка отображается при редактировании существующей группы.
Удалить группу | Удаление редактируемой группы блогов. Кнопка отображается при редактировании существующей группы.

Форма редактирования - "Параметры группы блогов"

Поле | Описание
ID | Уникальный идентификатор блога. Отображается при редактировании существующей группы блогов и не редактируется.
*Название группы | Название группы блогов.
*Сайт группы | Сайт, на котором будут доступны блоги даннной группы.

* - Поля, обязательные для заполнения.

Смотрите также:

  • Группы блогов (учебный курс "Контент-менеджер")


Веб-мессенджер

Как инструмент номер один, Веб-мессенджер дополняет привычные способы общения - телефон и электронную почту, позволяя эффективно общаться и получать информацию прямо через браузер. Использование Веб-мессенджера отменяет необходимость установки в компании XMPP серверов и специальных Jabber клиентов. Реализован мессенджер с использованием всех инноваций современных браузеров (используется HTML5, local storage и т.д.).

Модуль Веб-мессенджер присутствует в продуктах «1C-Битрикс: Управление сайтом» и «Битрикс24 в коробке», но функционал модулей в этих продуктах немного отличается.

Смотрите также:

  • Что такое веб-мессенджер
  • Настройка веб-мессенджера


Веб-мессенджер. Настройки модуля

Описание модуля

Внимание:
  • Без настроенного модуля Push&Pull и сервера очередей не будут работать следующие функции: групповой чат, редактирование сообщений, передача файлов, телефония (внешние и внутренние звонки на портале);
  • Без модуля Телефония (voximplant) не будет работать телефония (внешние звонки с портала);
  • Опция Использовать для видеозвонков SFU сервер Voximplant требует установленный модуль Телефония (voximplant) и активную лицензию;
  • Без модуля Disk не будет работать передача файлов.

Внимание: Для улучшения быстродействия модуля Веб-мессенджер версии 17.0.4 и выше необходимо:
  • Обновить вашу БД MySQL до версии 5.6.
  • После этого в командной строке базы данных выполнить следующий запрос:
    CREATE fulltext index IXF_IM_MESS_1 on b_im_message

Если вы устанавливали продукт на сервер с уже установленной БД MySQL 5.6 и выше, то вам ничего делать не нужно.

Настройки

Форма настроек модуля Веб-мессенджер (Настройки > Настройки продукта > Настройки модулей > Веб-мессенджер) предназначена для задания параметров модуля.

Поле | Описание
Использовать для видеозвонков SFU сервер Voximplant Если опция включена, то медиа-поток звонка пойдет через сервера VoxImplant и будет разрешено подключение до 10 участников. Если не стоит - медиа-поток идет напрямую между участниками, разрешено до 4-х участников. По умолчанию не стоит.

Доступно только в "Битрикс24 в коробке"
Использовать свой TURN сервер видеозвонков При отмеченной опции указываются настройки собственного сервера видеозвонков.
По умолчанию:
  • Адрес сервера:turn.calls.bitrix24.com
  • Адрес сервера для Firefox:54.217.240.163
  • Логин:bitrix
  • Пароль:bitrix
Скрывать отсутствующих пользователей | При отмеченной опции отсутствующие пользователи по умолчанию будут скрыты в контакт-листе. Каждый пользователь может включать или выключать данную опцию в настройках Бизнес-чата [image] [image] [image] [image] в публичной части.
Скрывать группы пользователей | При отмеченной опции группы по умочланию будут скрыты в контакт-листе. Каждый пользователь может включать или выключать данную опцию в настройках Бизнес-чата [image] [image] [image] [image] в публичной части.
Загружать последние сообщения | При отмеченной опции по умочланию будут загружены последние сообщения в диалогах. Каждый пользователь может включать или выключать данную опцию в настройках Бизнес-чата [image] [image] [image] [image] в публичной части.
Загружать историю уведомлений | При отмеченной опции по умочланию будет загружена история уведомлений. Каждый пользователь может включиать или выключать данную опцию в настройках Бизнес-чата [image] [image] [image] [image] в публичной части.
Сочетание клавиш для отправки сообщения | Указывается сочетание клавиш для отправки сообщений: Enter или Ctrl + Enter по умолчанию.
Расположение панели мессенджера Указывается расположение панели мессенджера по умолчанию.

Примечание: В шаблоне Битрикс24 портала панель мессенджера скрыта и принудительно расположена справа по всей высоте экрана.
Принимать сообщения от Указывается, от кого разрешено получать сообщения по умолчанию.

Доступно только в "1С-Битрикс: Управление сайтом"
Принимать звонки от Указывается, от кого разрешено получать звонки по умолчанию.

Доступно только в "1С-Битрикс: Управление сайтом"
Приглашать в чат могут Указывается, от кого разрешено получать приглашение в чат по умолчанию.

Доступно только в "1С-Битрикс: Управление сайтом"
Отображать контакт при поиске для Указывается, для кого разрешено отображать свой контакт при поиске.

Доступно только в "1С-Битрикс: Управление сайтом"
При приглашении пользователя в чат, ему доступна история сообщений Указывается, как показывать историю сообщений группового чата при приглашении в него нового участника:
  • с момента входа - ранние сообщения участников группового чата приглашенному участнику будут не видны;
  • с первого сообщения - будут видны все сообщения с момента создания чата.
Включить цветовую схему для чатов и пользователей | При отмеченной опции будут включены Цветные чаты [image].
Включить открытые чаты | При отмеченной опции будут включены Открытые чаты [image], в том числе и Общий чат.
Включить предварительную загрузку всех пользователей портала для быстрого поиска Отключение опции рекомендуется для компаний с сотрудниками выше 300 человек. Это позволит снизить нагрузку на веб-клиент: при в отключенном состоянии будут подгружаться в мессенджер не все пользователи, а только те с которыми сотрудник переписывается или находит в поиске.

Доступно только в "Битрикс24 в коробке"
Включить автоматическое сообщение о новом сотруднике в общий чат При отмеченной опции в Общий чат будет приходить сообщение о принятии на работу нового сотрудника.

Доступно только в "Битрикс24 в коробке"
Включить автоматическое сообщение об увольнении сотрудника в общий чат При отмеченной опции в Общий чат будет приходить сообщение об увольнении сотрудника.

Доступно только в "Битрикс24 в коробке"
Настройки по сайтам или порталам
Формат отображения имени в списке контактов | Указывается формат отображения имени в списке контактов Бизнес-чата. Настройка доступна для разных сайтов.
Шаблон пути к странице пользователя Указывается шаблон пути к странице пользователя. По умолчанию: /club/user/#user_id#/.

Доступно только в "1С-Битрикс: Управление сайтом"


Веб-формы. Описание модуля

Описание модуля

Модуль Веб-формы позволяет создавать произвольное количество веб-форм, а также осуществлять гибкое управление параметрами созданных форм. Основное назначение веб-форм - это организация обратной связи с посетителями сайта.

О том, где может использоваться данный модуль смотрите в уроке Возможности модуля.

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Веб-форма (комплексный компонент) | form | Компонент, создавая физически только одну страницу, позволяет получить несколько страниц: заполнение веб-формы, со списком результатов, редактирование результата, просмотр результата и т.д.
Редактирование результата | form.result.edit | Служит для редактирования результатов заполнения веб-форм.
Список результатов | form.result.list | Предназначен для вывода списка результатов выбранной веб-формы.
Список своих результатов | form.result.list.my | Выводит список своих результатов по нескольким формам.
Заполнение веб-формы | form.result.new | Служит для вывода формы и добавления результата, т.е. для ее заполнения.
Просмотр результата | form.result.view | Служит для просмотра результата заполнения веб-формы.

Смотрите также

  • Создание вопросов веб-формы в упрощенном режиме
  • Как создать собственный шаблон веб-формы
  • Создание веб-формы в упрощенном режиме
  • Как включить расширенный режим редактирования веб-форм
  • Создание вопросов веб-формы в расширенном режиме
  • Создание статусов веб-формы
  • Создание полей веб-формы
  • Документация для разработчиков по модулю Веб-формы


Веб-формы. Настройки модуля

Закладки

Настройки

Форма настроек модуля Веб-формы (Настройки > Настройки продукта > Настройки модулей > Веб-формы) предназначена для задания параметров модуля.

Поле | Описание
Использовать HTML редактор (только для IE 5.0 или FireFox 1.0 и выше) | При отмеченной опции для редактирования свойств и вопросов формы будет использоваться визуальный HTML-редактор.
Использовать упрощённый режим редактирования форм | При отмеченной опции создание/редактирование веб-форм будет осуществлятся в упрощённом режиме редактирования (без использования статусов результатов веб-формы, полей и т.д.).
Максимальное кол-во записей выбираемых в SQL запросах | Указывается максимальное количество записей выбираемых в SQL запросах.
Количество результатов на одной странице | Указывается количество результатов веб-форм для показа на одной странице.
Право по умолчанию для вновь создаваемых веб-форм Задается право по умолчанию для групп пользователей на доступ ко всем вновь создаваемым веб-формам:
  • доступ закрыт - веб-форма и ее результаты полностью недоступны;
  • заполнение формы - посетитель может только заполнить и сохранить веб-форму;
  • работа со своим результатом в соответствии с его статусом - посетитель может работать только со своими результатами в соответствии с правами, заданными для каждого из статусов, в котором находится тот или иной результат веб-формы;
  • работа со всеми результатами в соответствии с их статусами - посетитель может работать со всеми результатами в соответствии с правами, заданными для каждого из статусов, в котором находится тот или иной результат веб-формы;
  • просмотр параметров формы - включает все вышеописанные права, а также возможность просмотра параметров веб-формы;
  • полный доступ - включает все вышеописанные права, а также права на изменение настроек формы.

Связь с CRM

Поле | Описание
[привязанные_порталы] | Для каждого привязанного портала указывается его название, путь к настройкам CRM портала и информация о соединении с порталом.
кнопка Добавить Кнопка служит для добавления новой связи. При ее нажатии открывается форма, в которой указывается:
  • название привязанного портала;
  • адрес сервера портала;
  • адрес страницы с компонентом интеграции относительного корневого каталога сервера (по умолчанию адрес уже задан);
  • логин и пароль сотрудника портала, который будет выполнять обработку лидов.

Доступ

Поле | Описание
По умолчанию | Управление уровнем доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Управление правом доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Веб-формы:
  • [D] доступ закрыт - доступ к меню и всем административным файлам модуля закрыт;
  • [R] доступ открыт - доступ к меню и административным файлам модуля открыт. Дальнейшие права доступа к формам регламентируются правами, заданными в каждой конкретной форме;
  • [W] полный доступ - полный доступ к ресурсам модуля, а также право на создание новых форм. В то же время, доступ к существующим формам регламентируется правами, заданными в каждой конкретной форме.


Список форм

Форма поиска

Страница Список форм (Сервисы > Веб-формы > Настройка форм) содержит список всех веб-форм и позволяет:

  • в форме наглядной таблицы просматривать параметры имеющихся форм;
  • создавать новые формы;
  • редактировать параметры формы;
  • удалять формы.

Форма поиска осуществляет поиск веб-форм, соответствующих указанным параметрам.

Поле | Описание
Заголовок* | Заголовок формы. Поле присутствует, даже если фильтр свернут.
ID* | Уникальный идентификатор
Сайты | Сайты, на которых используется форма.
Символьный идентификатор* | Символьный код формы (поле отображается для полного режима редактирования форм).
Описание* | Описание формы.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать веб-формы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех веб-форм нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Создать | Переход на страницу создания новой веб-формы.
Настроить | Переход к диалоговой форме настройки списка элементов.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список веб-форм

Поле | Описание
Колонка флажков | Выбор веб-форм, к которым предполагается применить какое-либо правило или действие.
Действия Доступные операции:
  • Изменить - редактирование формы;
  • Копировать- копирование;
  • Очистить - удаление всех результатов заполнения веб-формы;
  • Удалить - удаление веб-формы.
ID | Уникальный идентификатор веб-формы.
Сайты | Сайты, на которых используется веб-форма.
Сорт. | Относительный "вес", определяющий положение веб-формы в общем списке.
Символьный идентификатор Мнемонический идентификатор. Задается латинскими буквами, позволяет однозначно определить форму и вызвать ее из кода.

Поле отображается в полном режиме редактирования веб-форм.
Заголовок | Заголовок веб-формы.
Вопросы Ссылка для перехода к списку вопросов веб-формы. Ссылка [+] позволяет создать новой вопрос.
Поля Ссылка для перехода к списку полей веб-формы. Ссылка [+] позволяет добавить новое поле.

Поле отображается в полном режиме редактирования веб-форм.
Статусы Ссылка для перехода к списку статусов веб-формы. Ссылка [+] позволяет создать новый статус.

Поле отображается в полном режиме редактирования веб-форм.
Результаты | Ссылка для перехода к списку результатов веб-формы. Ссылка [+] позволяет создать новый результат веб-формы.


Создание и редактирование веб-формы

Закладки

Форма, расположенная на данной странице, предназначена для создания новых и изменения параметров уже существующих веб-форм.

В продукте предусмотрены два режима работы с веб-формами:

  • упрощённый режим- предусматривает процедуру создания и редактирования веб-форм без использования статусов для результатов веб-формы, полей и создания шаблонов для фильтрации и показа списка результатов формы;
  • расширенный режим - включает настройку всех параметров: создание полей, настройку результатов веб-формы, возможность использования кастомизированных шаблонов для фильтрации и показа списка результатов формы.

Выбор режима осуществляется на странице настроек модуля.

Внимание: при переключении в расширенный режим редактирования нежелательно переключаться обратно в упрощенный режим, поскольку данные, сохраненные в расширенном режиме, при переключении поменяют структуру.

В любом режиме есть две контекстных панели, разделенных названием формы. Контекстная панель формы используется для быстрого перехода к управлению параметрами, результатами или вопросами конкретной формы, а в случае расширенного режима - для перехода к списку полей и статусов формы. Контекстная панель формы отображается только при редактировании существующей формы. С помощью Основной контекстной панели осуществляется то или иное действие непосредственно с самой веб-формой.

Контекстная панель формы

Кнопка | Описание
Параметры формы | Настройка параметров формы.
Результаты | Переход на страницу со списком результатов формы. Кнопка отображается на странице редактирования уже существующей формы.
Вопросы | Переход на страницу со списком вопросов веб-формы. Кнопка отображается на странице редактирования уже существующей формы.
Поля | Переход на страницу со списком полей веб-формы. Кнопка отображается только в полном режиме редактирования веб-форм.
Статусы | Переход на страницу со статусами веб-формы. Кнопка отображается только в полном режиме редактирования веб-форм.

Основная контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком веб-форм. Кнопка отображается только на странице создания новой формы.
Создать | Переход на страницу создания новой веб-формы. Кнопка отображается на странице редактирования уже существующей формы.
Копировать | Копирование редактируемой веб-формы в новую. Кнопка отображается на странице редактирования уже существующей формы.
Очистить результаты | Удаление всех результатов веб-формы. Кнопка отображается на странице редактирования уже существующей формы.
Удалить веб-форму | Удаление редактируемой веб-формы. Кнопка отображается на странице редактирования уже существующей формы.

Свойства

Форма редактирования может быть открыта через панель управления. Также ее можно загрузить из публичной части в режиме Правка с помощью меню действий компонента Редактировать параметры веб-формы.

Поле | Описание
*Наименование | Название формы.
*Символьный идентификатор | Мнемонический идентификатор формы, вызывающий форму без использования ID в коде. Задается латинскими буквами. Удобен, например, при переносе базы данных. Поле отображается только в расширенном режиме редактирования.
Порядок сортировки | Относительный "вес", определяющий положение веб-формы в общем списке.
Меню результатов в административном разделе | Пункты меню в административном разделе сайта, ведущие на страницу с результатами формы. Названия пунктов меню указываются для всех языков интерфейса.
Сайты формы | Сайты, на которых используется веб-форма.
Отправлять результаты по email | Если вы хотите, чтобы каждый раз при заполнении веб-формы результаты заполнения отправлялись в виде письма на определённый адрес, то установите флаг в это поле. После сохранения параметров веб-формы автоматически будет сгенерирован почтовый шаблон, на основе которого будут отправляться сообщения. Для перехода к просмотру доступных шаблонов воспользуйтесь ссылкой Список шаблонов. Поле отображается только в упрощённом режиме редактирования веб-форм.
Подпись на кнопке, сохраняющей результаты формы | Надпись на кнопке, сохраняющей результаты формы. Например, Отправить или Сохранить.
Использовать CAPTCHA | Только при установленном параметре предусмотренная в форме CAPTCHA будет работать.

* - поля, обязательные для заполнения.

Описание

Поле | Описание
Изображение | Изображение, используемое для описания формы в публичном разделе сайта. Для выбора изображения служит кнопка Обзор.
Описание | Созданное описание будет выводиться при показе веб-формы в публичном разделе сайта.

Шаблон формы

При создании/редактировании веб-формы пользователю предоставлен выбор:

  • Использовать шаблон формы по умолчанию
  • Использовать свой шаблон формы

При выборе пункта Использовать свой шаблон формы возможно редактирование шаблона веб-формы с помощью визуального редактора.

Редактор дает следующие возможности:

  • редактирование шаблона оформления;
  • создание/редактирование структуры вопросов и ответов.

В центральной части находится схематичный вид шаблона редактируемой веб-формы, в котором поля, а также дополнительные элементы представлены в виде иконок. Вверху имеется Панель инструментов, аналогичная панели визуального HTML-редактора системы.

Кнопки, расположенные внизу окна редактора, позволяют скрывать и разворачивать панели Элементы формы и Свойства.

Если панель Элементы формы развернута, то она расположена в правой части редактора и содержит следующие разделы:

  • Новые поля формы служит для добавления в веб-форму новых элементов;
  • Существующие поля формы содержит уже настроенные вопросы веб-формы;
  • Дополнительные элементы формы содержит инструментарий для вставки в шаблон веб-формы дополнительных структурных элементов.

Аналогично, если панель Свойства развернута, то она расположена в нижней части редактора. В этой панели настраиваются параметры элементов, добавляемых в шаблон формы.

Область редактирования

Работа с областью редактирования шаблона осуществляется аналогично работе с визуальным HTML-редактором. Элементы, которые нужно вставить в шаблон веб-формы, перетаскиваются мышью из панели Элементы формы. После размещения компонента его параметры можно настроить в панели Свойства.

Панель "Элементы формы"

Новые поля формы

В разделе Новые поля формы содержатся компоненты, которые используются в качестве полей формы.

Поле | Описание
Строка | Вставка нового вопроса с ответом в виде поля типа text (поле для ввода однострочного текста длиной до 255 символов)
Текст | Вставка нового вопроса с ответом в виде поля типа textarea (поле для ввода многострочного неограниченного текста)
Группа переключателей | Вставка нового вопроса с ответами в виде полей типа radio (поле для выбора одного варианта из нескольких)
Флажок | Вставка нового вопроса с ответами в виде полей типа checkbox (поле для выбора нескольких вариантов из списка или поле-флаг)
Выпадающий спиок | Вставка нового вопроса с ответами в виде поля типа dropdown (выбор одного варианта из выпадающего списка)
Множественный список | Вставка нового вопроса с ответами в виде поля типа multiselect (поле для выбора одного или нескольких вариантов из списка)
Дата | Вставка нового вопроса с ответом в виде поля типа date (поле для ввода даты)
Изображение | Вставка нового вопроса с ответом в виде поля типа image (поле для прикрепления изображения к результату веб-формы)
Файл | Вставка нового вопроса с ответом в виде поля типа file (поле для прикрепления произвольного файла к результату веб-формы)
Адрес e-mail | Вставка нового вопроса с ответом в виде поля типа email (текстовое поле для ввода e-mail-адреса с дополнительной проверкой)
Адрес WWW | Вставка нового вопроса с ответом в виде поля типа url (текстовое поле для ввода интернет-адреса)
Пароль | Вставка нового вопроса с ответом в виде поля типа password (текстовое поле со скрытым вводом)

Существующие поля формы

Панель появляется только при редактировании уже созданной веб-формы. В ней перечислены уже созданные и настроенные вопросы веб-формы. В этом списке также отображаются неактивные вопросы с соответствующей пометкой. Они отображаются в виде: <Значок поля><Текст вопроса>. Например:

Дополнительные элементы формы

Дополнительные компоненты, используемые для оформления внешнего вида формы.

Иконка | Описание
Заголовок формы | Вывод содержимого поля Наименование закладки Свойства. Стиль выводимого текста задается в шаблоне средствами редактора.
Описание формы | Вывод содержимого поля Описание формы закладки Описание. Если описание создано с использованием визуального HTML редактора, то оно будет выведено без изменений. В противном случае, стиль форматирования текста можно задать в шаблоне средствами редактора.
Ошибки формы | Вывод отформатированных ошибок валидатора веб-формы или пустой строки в случае их отсутствия.
Ответ формы | Вывод ответа веб-формы или пустой строки в случае отсутствия ответа.
Изображение к форме | Вывод изображения, прикрепленного к веб-форме на закладке Описание.
Подпись поля формы | Вывод наименования вопроса. Выбор вопроса осуществляется в свойствах элемента.
Символ "Обязательно" | Вывод символа * - стандартной пометки того, что поле обязательно для заполнения. Примечание: при использовании элемента Подпись поля формы, если поле помечено как обязательное, то пометка будет выведена в публичной части автоматически.
Формат даты | Вывод формата даты: DD.MM.YYYY.
Изображение к полю | Вывод изображения к полю, указанное в форме редактирования вопроса.
Поля CAPTCHA | Вывод пары изображения и поля ввода для защиты от автоматического заполнения веб-формы.
Поле ввода CAPTCHA | Поля ввода для защиты от автоматического заполнения веб-формы.
Изображение CAPTCHA | Вывод изображения для защиты от автоматического заполнения веб-формы.
Кнопка Отправить | Вывод кнопки отправки результата веб-формы.
Кнопка Применить | Вывод кнопки сохранения результата веб-формы (и возврата к редактированию).
Кнопка Отменить | Вывод кнопки отмены изменений результата веб-формы.
Статус результата | Вывод статуса на странице просмотра результата заполнения формы. Доступ к странице просмотра результата определяется в настройках статусов веб-формы.
Изменение статуса | Вывод формы изменения статуса на странице редактирования результата веб-формы. Доступ к данной странице определяется в настройках статусов веб-формы.

Свойства элементов

При клике на любой добавленный в шаблон элемент, представленный иконкой, можно получить доступ к его параметрам в панели Свойства.

Набор настроек:

Параметр | Описание
Строковой идентификатор | Уникальный в рамках веб-формы идентификатор вопроса. Должен отличаться от строкового идентификатора веб-формы, выставляемого при расширенном режиме редактирования веб-формы. При добавлении нового элемента в шаблон его идентификатор по умолчанию будет new_field_N, где N - случайное число.
Текст вопроса Текст вопроса, который будет отображаться:
  1. при использовании элемента [image] Подпись поля формы;
  2. в таблице списка результатов веб-формы;
  3. в фильтре списка результатов веб-формы;
  4. при просмотре результата веб-формы;
  5. при выводе ошибок заполнения веб-формы.
Текст вопроса - HTML? | В тексте вопроса допускается собственное HTML-форматирование.
Обязателен? | Флаг обязательности заполнения вопроса.
Показать в HTML-таблице результатов? | Показывать ли колонку поля в таблице результатов веб-формы (в публичной части).
Показать в Excel-таблице результатов? | Показывать ли колонку поля в Excel-таблице результатов веб-формы.
Тип поля | Тип поля вопроса (не редактируется).
Ответы Параметры ответов на вопрос. Поле изменяется в зависимости от типа вопроса:
  • значение по умолчанию и длина поля для полей типа text, date, email, url, password, image, file;
  • число столбцов и число строк для полей типа textarea;
  • варианты ответов, порядок и флаг выбран по умолчанию для каждого варианта в случае полей типа dropdown, checkbox, radio, multiselect.

Для каждого элемента из раздела Дополнительные элементы формы есть свой набор настраиваемых свойств. Если элемент никаких настроек не имеет, это будет выведено в панели Свойства.

Параметр | Описание
Строковой идентификатор | Для элементов Подпись поля формы и Изображение поля формы предоставляется выбор соответствующего им поля формы в виде выпадающего списка строковых идентификаторов полей.
Стиль | Для многих элементов предоставляется выбор CSS-класса, который нужно присвоить элементу. Если нужного класса нет в списке, то его можно указать в текстовом поле под выпадающим списком стилей.
Расположение Для компонентов Изображение к форме и Изображение к полю можно задать такие параметры изображения, как:
  • расположение изображения относительно окружающего текста;
  • максимальная ширина и высота изображения;
  • увеличивать ли изображение в отдельном окне, если оно превышает максимальные размеры;
  • подпись для ссылки увеличения;
  • вертикальные и горизонтальные отступы от окружающего текста;
  • толщину рамки вокруг изображения.
Максимальная ширина
Максимальная высота
Увеличивать?
Вертикальный отступ
Горизонтальный отступ
Рамка
Подпись | Для элементов-кнопок можно указать подпись, которая будет изображена на кнопке.

Дополнительные замечания:

  • При желании можно отключить использование шаблона оформления, выбрав опцию Использовать шаблон формы по умолчанию над редактором. При этом редактор будет скрыт, и будет использоваться шаблон по умолчанию. Шаблон веб-формы будет сохранен вместе с изменениями структуры вопросов веб-формы.
  • Если в настройках веб-формы установлен флаг Использовать CAPTCHA, а в шаблоне веб-формы элементы для ввода CAPTCHA отсутствуют, то флаг автоматически снимется при сохранении веб-формы.
  • Вопрос, отсутствующий в шаблоне веб-формы, при сохранении будет помечен как неактивный. Это также выражается в том, что если добавить новый элемент в веб-форму, а потом удалить его, то он сохранится в виде неактивного вопроса. Исключение - если на веб-форме уже присутствует элемент с таким строковым идентификатором. В этом случае элемент, отсутствующий в шаблоне, будет удален.
  • При копировании веб-формы вопросы новой веб-формы будут иметь те же самые строковые идентификаторы, что и у исходной. Идентификатор самой веб-формы получит случайно сгенерированный постфикс.
  • При повторной вставке в шаблон веб-формы уже существующего вопроса (например, из панели Существующие поля формы или методом copy/paste) результатом будет создание связанной копии вопроса, все изменения которой будут отражаться и на изначальном элементе. Если Вы хотите продублировать элемент, создайте ещё один элемент того же типа с такими же параметрами (кроме, разумеется, строкового идентификатора) или воспользуйтесь инструментом копирования вопроса (в списке вопросов веб-формы).

Ограничения

Указание ограничений на добавление результатов.
Поле | Описание
Использовать ограничения | При отмеченной опции становятся активными нижеследующие поля и на добавление результатов будут использованы ограничения.
Максимальное количество результатов от пользователя | Задается максимальное количество результатов заполнения формы, получаемых от одного пользователя.
Минимальный промежуток времени между результатами | Указывается число единиц времени, определяющее минимальный интервал между результатами заполнения формы.
Использовать ограничения только для результатов в статусах | Используя Ctrl+правый клик мыши выбираются статусы данной веб-формы, для которых будут использованы ограничения.

Дополнительно

Отображается только в полном режиме создания веб-форм.

Позволяет настроить шаблоны, используемые при работе с веб-формой.

Поле | Описание
Почтовый шаблон | Указываются шаблоны, используемые для отправки результатов веб-формы.
Шаблон фильтра по таблице результатов в административной части | Путь к шаблону, используемому для фильтрации (поиска) результатов веб-формы в административном разделе.
Шаблон для таблицы результатов в административной части | Путь к шаблону, используемому для отображения таблицы результатов в Административном разделе.

Статистика

Служит для задания идентификаторов, с использованием которых событие заполнения веб-формы будет учитываться в модуле статистики.

Поле | Описание
Event1 | Идентификатор типа события event1.
Event2 | Идентификатор типа события event2.
Event3 | Дополнительный параметр для события.

CRM

Служит для настройка связей веб-формы с CRM портала.

Поле | Описание
CRM | В выпадающем списке выбирается портал, в CRM которого будут отсылаться результаты заполнения веб-формы. Когда портал выбран, то становятся доступными нижеописанные поля. Если в системе не создана ни одна связь с CRM, то в списке следует выбрать пункт настроить новый. Откроется форма создания связи.
Способ отсылки | При ручном режиме данные передаются в CRM менеджером после их обработки. При автоматическом режиме результаты заполнения сразу передаются в CRM..
Связанные поля
Указывается каким данным веб-формы (показаны справа) будет соответствовать какое-либо поле лида (показаны слева). Чтобы задать новое соответствие, служит кнопка Добавить.

Доступ

Служит для настройки прав групп пользователей на доступ к веб-форме.

Поле Описание
[Группа пользователей] Право группы пользователей на форму. Каждое последующее право включает в себя все предыдущие.
  • доступ закрыт - форма и ее результаты полностью недоступны;
  • заполнение формы - посетитель может только заполнить и сохранить форму;
  • работа со своим результатом в соответствии с его статусом - посетитель получает возможность работать только со своими результатами в соответствии с заданными для каждого из статусов правами;
  • работа со всеми результатами в соответствии с их статусами - посетитель получает возможность работать со всеми результатами в соответствии с заданными для каждого из статусов правами;
  • просмотр параметров формы - включает все вышеописанные права, а также возможность просмотра параметров веб-формы;
  • полный доступ - включает все вышеописанные права, а также права на изменение настроек формы.

Смотрите также

  • Создание и редактирование веб-формы (учебный курс "Контент-менеджер")


Список вопросов

Контекстная панель формы

На странице отображается список вопросов для выбранной веб-формы. Вопрос формы - совокупность непосредственно самого текста вопроса и полей ввода, предназначенных для ответа на него.

Кнопка | Описание
Параметры формы | Переход на страницу редактирования параметров веб-формы.
Результаты | Переход на страницу со списком результатов заполнения веб-формы.
Вопросы | Страница со списком вопросов веб-формы. Кнопка выделена, поскольку эта страница открыта.
Поля | Переход на страницу со списком полей веб-формы. Кнопка отображается только в режиме полного редактирования форм.
Статусы | Переход на страницу со списком статусов формы. Кнопка отображается только в режиме полного редактирования форм.

Форма поиска

Выполняется поиск вопросов веб-формы, соответствующих указанным параметрам.

Поле | Описание
Вопрос* | Текст вопроса (его часть). Поле присутствует, даже если фильтр свернут.
ID* | ID требуемого вопроса.
Активен | Флаг активности вопроса, который требуется отобразить.
Символьный идентификатор* | Идентификатор вопроса.
Комментарий* | Служебный комментарий (его часть).
Обязателен | Флаг обязательности ответа.
Включено в HTML-таблицу результатов | Флаг, указывающий, отображаются ли ответы на вопрос в HTML-таблице результатов.
Включено в таблицу результатов в Excel формате | Флаг, указывающий, отображаются ли ответы на вопрос в таблице результатов в Excel формате.
Включено в фильтр таблицы результатов | Флаг, указывающий наличие в таблице результатов полей, включенных в фильтр для поиска ответов на вопрос.
Логика между полями Тип логики, используемый при проведении выборки по значениям полей:
  • и: будут выведены все элементы, обладающие всеми указанными свойствами;
  • или: будут выведены все элементы, обладающие хотя бы одним из указанных свойств.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать вопросы веб-формы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех вопросов нажмите кнопку Отменить.

Основная контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания нового вопроса для выбранной веб-формы.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данные из отображаемой таблицы в MS Excel.

Список вопросов

Поле | Описание
Колонка флажков | Поле предназначено для выбора вопросов, к которым предполагается применить какое-либо правило или действие.
Действия Действия над вопросом:
  • Параметры вопроса - редактирование параметров вопроса;
  • Копировать - копирование вопроса;
  • Удалить - удаление вопроса.
ID | Идентификатор вопроса.
Акт. | Признак активности вопроса.
Сорт. | Относительный "вес", определяющий положение вопроса в общем списке.
Обяз. | Признак обязательности ответа на вопрос.
Символьный идентификатор Символьный код вопроса.

Поле отображается только в полном режиме редактирования веб-форм.
Вопрос | Текст вопроса.
Тип поля Тип поля для ввода ответа на вопрос.

Поле отображается только в упрощённом режиме редактирования веб-форм.
Комментарий | Служебный комментарий к вопросу.
Таб. Флаг, указывающий, отображаются ли ответы на вопрос в HTML-таблице результатов.

Поле отображается только в полном режиме редактирования веб-форм.
Excel Флаг, указывающий, отображаются ли ответы на вопрос в таблице результатов в Excel формате.

Поле отображается только в полном режиме редактирования веб-форм.


Добавление и редактирование результата

Контекстная панель формы

С помощью формы, представленной на данной странице, можно добавить или отредактировать результат заполнения веб-формы.

Кнопка | Описание
Параметры формы | Переход на страницу редактирования параметров веб-формы.
Результаты | Переход на страницу со списком результатов заполнения веб-формы. Кнопка выделена, поскольку открыта страница редактирования результата.
Вопросы | Переход на страницу со списком вопросов веб-формы.
Поля | Переход на страницу со списком полей веб-формы. Кнопка отображается только в режиме полного редактирования веб-форм.
Статусы | Переход на страницу со списком статусов формы. Кнопка отображается только в режиме полного редактирования веб-форм.

Основная контекстная панель

Кнопка | Описание
Добавить | Переход к добавлению нового результата формы.
Удалить результат | Удаление редактируемого результата.

Форма редактирования

Поле | Описание
Общая информация
ID | Идентификатор результата заполнения веб-формы.
Форма | Идентификатор, наименование и символьный идентификатор веб-формы, результат заполнения которой добавляется или редактируется.
Создатель | При добавлении результата указывается пользователь, который добавляет результат. Ссылка с именем пользователя служит для перехода к редактированию профайла данного пользователя.
Создан | Дата и время добавления результата. Данное поле отображается только при редактировании результата.
Изменен | Дата и время последнего изменения параметров результата заполнения формы. Данное поле отображается только при редактировании результата.
Посетитель | Идентификатор пользователя, добавившего результат, в модуле Веб-аналитика. Данное поле отображается только при редактировании результата.
Сессия | Идентификатор сессии пользователя, добавившего результат. Данное поле отображается только при редактировании результата.
Статус
Установить статус | Указывается статус, который должен быть установлен при добавлении результата. Данное поле отображается только при добавлении результата.
Текущий статус | Текущий статус редактируемого результата.
Изменить статус | Поле позволяет сменить статус редактируемого результата.
Поля результата
[название_поля] | Каждое поле веб-формы заполняется необходимыми данными.


Создание и редактирование вопроса

Контекстная панель формы

Для создания и изменения вопроса формы применяется страница одного типа. Большинство параметров вопросов и ответов можно настроить, воспользовавшись визуальным редактором шаблона оформления формы.

Кнопка | Описание
Параметры формы | Переход на страницу редактирования параметров веб-формы.
Результаты | Переход на страницу со списком результатов заполнения веб-формы.
Вопросы | Переход на страницу со списком вопросов веб-формы. Кнопка выделена, поскольку открыта страница редактирования вопроса.
Поля | Переход на страницу со списком полей веб-формы. Кнопка отображается только в режиме полного редактирования веб-форм.
Статусы | Переход на страницу со списком статусов веб-формы. Кнопка отображается только в режиме полного редактирования форм.

Основная контекстная панель

Основная контекстная панель отображается только при редактировании уже существующего вопроса.
Кнопка | Описание
Создать | Переход на страницу создания нового вопроса формы.
Копировать | Копирование текущего вопроса в новый.
Удалить вопрос | Удаление текущего вопроса.

Упрощённая форма редактирования

Закладка "Свойства"
Поле | Описание
Дата изменения | Дата последнего изменения вопроса. Поле отображается при редактировании существующего вопроса.
Активен | Флаг активности вопроса.
Порядок сортировки | Относительный "вес", определяющий положение вопроса в общем списке.
Изображение | Изображение, которое будет выведено рядом с вопросом.
Вопрос | Текст вопроса.
Поле ответа обязательно для заполнения | Флаг обязательности ответа на данный вопрос формы.
Тип поля для ответа Тип поля для ответа на данный вопрос:
  • text - однострочный текст;
  • textarea- многострочный текст;
  • multiselect - список вариантов с возможностью множественного выбора;
  • dropdown - список вариантов с возможностью одиночного выбора;
  • radio - набор radio кнопок (одиночный выбор);
  • checkbox - набор checkbox кнопок (множественный выбор);
  • image - поле для ввода изображения;
  • date - поля для ввода даты со встроенным календарем;
  • file - поле для добавления файла;
  • password - поле для ввода пароля;
  • email - поле для ввода электронного адреса;
  • url - поле для ввода адреса сайта;
  • hidden - скрытое поле.
Ответ Поле меняется в зависимости от выбранного типа ответа.
Для поля типа textarea указывается количество столбцов и строк.

Для полей типа radio, checkbox, dropdown, multiselect поле Ответ выглядит следующим образом:
Поле | Описание
Варианты ответа | Вариант ответа на вопрос.
Порядок | Относительный "вес", определяющий порядок следования вариантов ответа в списке.
По умолчанию | Вариант ответа, отмеченный в этом поле, по умолчанию будет использоваться в качестве ответа на вопрос.

Для поля типа hidden из выпадающего списка выбирается тип поля ответа, а для остальных полей задается размер поля ответа.

Закладка "Валидаторы" Добавление валидаторов для используемых полей ответов.
Поле | Описание
Доступные валидаторы для поля типа <тип_поля> | Из выпадающего списка для поля указанного типа выбирается один из доступных валидаторов. Для его назначения служит кнопка Добавить валидатор, расположенная рядом с полем.

Закладка "Комментарий"

Созданный служебный комментарий будет отображаться только в административном разделе.

Полная форма. Свойства

Поле | Описание
Дата изменения | Дата последнего изменения вопроса. Поле отображается при редактировании существующего вопроса.
Активен | Флаг активности вопроса.
Порядок сортировки | Относительный "вес", определяющий положение вопроса в общем списке.
* Символьный идентификатор | Символьный код вопроса. Задается символами латинского алфавита.
Обязателен | Признак обязательности ответа на данный вопрос.

* - Поля, обязательные для заполнения.

Полная форма. Вопрос

Поле | Описание
Изображение | Изображение, которое будет показываться рядом с вопросом.
Текст вопроса | Текст создаваемого вопроса.

Полная форма. Ответ

Форма позволяет создать поля, используемые для ввода ответа на вопрос, либо создать возможные варианты ответов на вопрос.
Поле | Описание
ID | Идентификатор поля для ответа.
Текст [ ANSWER_TEXT ] Текст ответа на вопрос.

Используется для полей типа dropdown, multiselect, radio, checkbox. Для остальных типов полей необходимо поставить пробел.
Значение [ ANSWER_VALUE ] | Дополнительный параметр, который может быть использован для идентификации конкретного ответа (например, в списках).
Тип поля Тип поля для ответа на данный вопрос:
  • text - однострочный текст;
  • textarea- многострочный текст;
  • multiselect - список вариантов с возможностью множественного выбора;
  • dropdown - список вариантов с возможностью одиночного выбора;
  • radio - набор radio кнопок (одиночный выбор);
  • checkbox - набор checkbox кнопок (множественный выбор);
  • image - поле для ввода изображения;
  • date - поля для ввода даты со встроенным календарем;
  • file - поле для добавления файла;
  • password - поле для ввода пароля;
  • email - поле для ввода электронного адреса;
  • url - поле для ввода адреса сайта
  • hidden - скрытое поле.
Ширина | Ширина полей типа text, textarea, image, date. Задается количеством столбцов.
Высота | Высота полей типа textarea, multiselect. Задается количеством строк.
Параметры Данное поле может использоваться для вывода стиля элемента ввода, а также для задания специальных идентификаторов:
  • SELECTED - при задании этого идентификатора поле ввода будет выделено; работает для полей следующих типов: multiselect, dropdown, radio.
  • CHECKED - при задании этого идентификатора поле ввода будет выделено; работает для полей следующих типов: checkbox.
  • NOT_ANSWER - идентификатор используется для пометки тех пунктов элементов управления, которые не являются вариантами ответа на вопрос. В том случае, если этот идентификатора задан и если ответ на вопрос обязателен, выбор посетителем данного ответа не будет считаться ответом на обязательный вопрос формы. Работает для типов полей: dropdown, radio, multiselect, checkbox.
  • NOW_DATE -выводит в поле типа date текущую дату.
  • NOW_TIME -выводит в поле типа date текущее время.
Сорт. | Относительный "вес" определяющий положение варианта ответа в общем списке.
Акт. | Признак активности поля. Для отображения в публичном разделе выбираются только активные варианты ответа.
Уд. | Чтобы удалить вариант ответа, установите флаг в это поле и нажмите кнопку Применить.
Для добавления дополнительных полей для ответа, нажмите на кнопку Добавить ответ.

Полная форма. Валидаторы

Добавление валидаторов для используемых полей ответов.
Поле | Описание
Доступные валидаторы для поля типа <тип_поля> | Выбирается один из доступных валидаторов. Для его назначения служит кнопка Добавить валидатор, расположенная рядом с полем.
Для добавления дополнительных валидаторов, нажмите на кнопку Добавить валидатор.

Полная форма. Результаты

Закладка служит для настройки параметров показа результатов ответа вопрос.
Поле | Описание
Показать в HTML-таблице результатов | Если отметить данный флаг, то ответы на данный вопрос будут отображены в HTML-таблице результатов формы.
Показать в Excel-таблице результатов | Если отметить данный флаг, то ответы на данный вопрос будут отображены в Excel-таблице результатов формы.
Заголовок столбца в таблице | Текст, который будет выводиться в таблице результатов в качестве заголовка столбца, содержащего ответы на данный вопрос.

Полная форма. Фильтр

Поле Описание
для вводимого значения Тип полей фильтра таблицы результатов для поиска ответов, вводимых пользователем в следующих типах полей: text, textarea.
Возможны следующие типы полей в фильтре:
  • однострочное текстовое поле;
  • числовой интервал;
  • интервал дат;
  • флаг существования.
Для выбора нескольких полей удерживайте клавишу Ctrl.

Примечание: Если в списке выбрано какое-либо значение, то оно будет отображаться в фильтре поиска на странице Результаты веб-формы.

для параметра ANSWER_TEXT Тип полей фильтра для поиска значений параметра ANSWER_TEXT в ответах посетителя.
Возможны следующие типы полей в фильтре:
  • однострочное текстовое поле;
  • числовой интервал;
  • выпадающий список из всех значений ANSWER_TEXT;
  • флаг существования.
Для выбора нескольких полей удерживайте клавишу Ctrl.

Примечание: Если в списке выбрано какое-либо значение, то оно будет отображаться в фильтре поиска на странице Результаты веб-формы и будет отмечено символом [...].

для параметра ANSWER_VALUE Тип полей фильтра для поиска значений параметра ANSWER_VALUE в ответах посетителя.
Возможны следующие типы полей в фильтре:
  • однострочное текстовое поле;
  • числовой интервал;
  • выпадающий список из всех значений ANSWER_VALUE;
  • флаг существования.
Для выбора нескольких полей удерживайте клавишу Ctrl.

Примечание: Если в списке выбрано какое-либо значение, то оно будет отображаться в фильтре поиска на странице Результаты веб-формы и будет отмечено символом (...).

Подпись к полю фильтра Текст, который будет выводиться рядом с выбранными полями фильтра по таблице результатов.

Примечание: Если поле пустое, то в качестве подписи к пользовательскому полю фильтра будет использоваться текст вопроса.

Полная форма. Комментарий

Созданный служебный комментарий будет отображаться только в административном разделе.

Смотрите также

  • Создание вопросов веб-формы (учебный курс "Контент-менеджер")


Создание и редактирование поля

Для создания и изменения поля формы применяется страница одного типа.

Контекстная панель формы

Кнопка | Описание
Параметры формы | Переход на страницу редактирования параметров веб-формы.
Результаты | Переход на страницу со списком результатов заполнения веб-формы.
Вопросы | Переход на страницу со списком вопросов веб-формы.
Поля | Переход на страницу со списком полей веб-формы. Кнопка выделена, поскольку открыта страница редактирования поля.
Статусы | Переход на страницу со списком статусов формы. Кнопка отображается только в режиме полного редактирования веб-форм.

Основная контекстная панель

Основная контекстная панель отображается только при редактировании уже существующего поля.
Кнопка | Описание
Добавить | Переход на страницу создания нового поля формы.
Копировать | Копирование текущего поля в новое.
Удалить поле | Удаление текущего поля.

Форма редактирования

Закладка Свойства
Поле | Описание
Дата изменения | Дата последнего изменения поля (отображается только на странице редактирования уже существующего поля).
Активен | Флаг активности поля.
Порядок сортировки | Порядок сортировки поля; используется при выводе данных в таблице результатов, а также при выводе в фильтре.
* Символьный идентификатор | Идентификатор поля; может состоять только из букв латинского алфавита.
Тип поля Используется для хранения данных в соответствующем формате, а также для выбора полей в фильтре:
  • текст - однострочное текстовое поле в фильтре;
  • число – числовой интервал в фильтре;
  • дата – интервал дат в фильтре.
Заголовок | Заголовок поля.

* - Поля, обязательные для заполнения.

Закладка Результаты
Закладка служит для настройки параметров показа значения поля.
Поле | Описание
Показать в HTML-таблице результатов | Если отметить данный флаг, то значения данного поля будут отображены в HTML-таблице результатов формы.
Показать в Excel-таблице результатов | Если отметить данный флаг, то значения данного поля будут отображены в Excel-таблице результатов формы.
Заголовок столбца в таблице | Текст, который будет выводиться в таблице результатов в качестве заголовка столбца, содержащего значения данного поля. Если поле не заполнено, в качестве заголовка выводится значение поля Заголовок из закладки Свойства, если и оно не заполнено, выводится значение обязательного поля Символьный идентификатор.

Закладка Фильтр
Форма служит для настройки полей в фильтре для поиска записей по значению данного поля.
Поле | Описание
Поля в фильтре Типы полей, по значениям которых будет осуществляться фильтрация элементов на странице со списком форм.
Возможны следующие типы полей:
  • текстовое поле;
  • числовой интервал;
  • интервал дат;
  • флаг существования.

Для выбора нескольких типов полей удерживайте клавишу Ctrl.
Подпись к полю фильтра | Текст, который будет выводиться в списке полей фильтра. Если поле не заполнено, в качестве заголовка выводится значение поля Заголовок из закладки Свойства, если и оно не заполнено, выводится значение обязательного поля Символьный идентификатор.

Закладка Комментарий
Форма позволяет создать служебный комментарий к полю.

Смотрите также

  • Создание полей веб-формы (учебный курс "Контент-менеджер")


Создание и редактирование статуса

Для создания и изменения статусов применяется страница одного типа. Переход к странице возможен только в полном режиме редактирования веб-форм.

Контекстная панель формы

Кнопка | Описание
Параметры формы | Переход на страницу редактирования параметров веб-формы.
Результаты | Переход на страницу со списком результатов заполнения веб-формы.
Вопросы | Переход на страницу со списком вопросов веб-формы.
Поля | Переход на страницу со списком полей веб-формы. Кнопка отображается только в режиме полного редактирования веб-форм.
Статусы | Переход на страницу со списком статусов формы. Кнопка выделена, поскольку открыта страница редактирования статуса.

Основная контекстная панель

Кнопка | Описание
Добавить | Переход на страницу создания нового статуса формы.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Закладка Свойства

Поле | Описание
Изменен | Дата и время последнего изменения настроек статуса.
Результатов в данном статусе | Количество результатов, имеющих данный статус.
Активен | Флаг активности статуса.
*Заголовок | Заголовок статуса.
Описание | Описание статуса.
Порядок сортировки | Порядок сортировки статуса (используется, в частности, при выводе выпадающего списка статусов).
Присваивать данный статус всем новым документам по умолчанию | Данный флаг позволяет присваивать редактируемый статус всем вновь создаваемым документам в случае, если статус не был явно указан.
CSS класс для отображения заголовка статуса | CSS класс для текста, которым будет выводиться заголовок статуса. Например, в таблице результатов или при просмотре, редактировании статуса при использовании шаблонов типа default.php.
Файл-обработчик смены данного статуса на какой-либо другой (либо удаление результата) | Адрес файла-обработчика, который будет запускаться при смене статуса.
Файл-обработчик смены какого-либо статуса на данный (либо добавление нового результата) | Адрес файла-обработчика, который будет запускаться при смене какого-либо статуса на данный. Подробнее об обработчиках смены статуса см. раздел Обработчики статусов.

* - Поля, обязательные для заполнения.

Закладка Уведомления

Настройка почтовых шаблонов для уведомления пользователей о смене статуса результата заполнения веб-формы.

Поле | Описание
Шаблон почтового уведомления при установке статуса | Шаблон, используемый для отправки почтового уведомления о смене статуса результата заполнения веб-формы. Создание нового шаблона выполняется по ссылке создать. Чтобы перейти к редактированию почтового шаблона, следует воспользоваться ссылкой с идентификатором данного шаблона. Для удаления шаблона служит ссылка удалить, а для перехода к списку всех почтовых шаблонов - ссылка список шаблонов.

Закладка Доступ

Настройка прав групп пользователей на доступ к результатам, находящимся в данном статусе.

Поле | Описание
Имеют право на перевод результатов в данный статус [MOVE] | Группы пользователей, которые смогут присвоить результату данный статус. Можно отдельно назначить данное право для создателя результата. Чтобы пользователи могли воспользоваться этим правом, у них должно быть право на редактирование результата. Для выбора нескольких групп удерживайте клавишу Ctrl.
Имеют право на просмотр результатов в данном статусе [VIEW] | Группы пользователей, члены которых смогут увидеть результат в данном статусе. Можно отдельно назначить данное право для создателя результата. Для выбора нескольких групп удерживайте клавишу Ctrl.
Имеют право на редактирование результатов в данном статусе [EDIT] | Группы пользователей, члены которых могут редактировать результаты в данном статусе. Можно отдельно назначить данное право для создателя результата. Для выбора нескольких групп удерживайте клавишу Ctrl.
Имеют право на удаление результатов в данном статусе [DELETE] | Группы пользователей, члены которых могут удалять результаты в данном статусе. Можно отдельно назначить данное право для создателя результата. Для выбора нескольких групп удерживайте клавишу Ctrl.

Смотрите также

  • Настройка статусов веб-формы (учебный курс "Контент-менеджер")


Список полей

Контекстная панель формы

На данной странице представлен список дополнительных полей веб-формы. Поле формы подразумевает хранение каких-либо данных, определяемых после сохранения заполненной формы (после сохранения результата).

Кнопка | Описание
Параметры формы | Переход на страницу редактирования параметров веб-формы.
Результаты | Переход на страницу со списком результатов заполнения веб-формы.
Вопросы | Переход на страницу со списком вопросов веб-формы.
Поля | Страница со списком полей веб-формы. Кнопка выделена, поскольку эта страница открыта.
Статусы | Переход на страницу со списком статусов формы.

Фильтр

Осуществляется поиск полей веб-формы, соответствующих указанным параметрам.

Наименование параметра | Описание
Заголовок* | Заголовок поля. Поле присутствует, даже если фильтр свернут.
ID* | ID поля.
Активен | Флаг активности поля.
Символьный идентификатор* | Идентификатор поля.
Комментарий* | Служебный комментарий.
Включено в HTML-таблицу результатов | Флаг, указывающий, отображаются ли значения полей в HTML-таблице результатов.
Включено в таблицу результатов в Excel формате | Флаг, указывающий, отображаются ли значения полей в Excel-таблице результатов.
Включено в фильтр таблицы результатов | Флаг, определяющий, участвуют ли значения поля в фильтре.
Логика между полями Определяется тип логики, используемой при проведении выборки по значениям полей фильтра:
  • и: будут выведены все элементы, обладающие всеми указанными свойствами;
  • или: будут выведены все элементы, обладающие хотя бы одним из указанных свойств.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать поля веб-формы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех полей нажмите кнопку Отменить.

Основная контекстная панель

Кнопка | Описание
Добавить | Создание нового поля.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список полей

Поле | Описание
Колонка флажков | Выбор полей, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия над полем:
  • Параметры вопроса - редактирование параметров поля;
  • Копировать - копирование поле в новое;
  • Удалить - удаление поля.
ID | Идентификатор поля.
Акт. | Признак активности поля. Если поле не активно, то оно будет не доступно для показа в таблице результатов и в фильтре по таблице результатов.
Сорт. | Относительный "вес", определяющий порядок вывода полей в списке.
Символьный идентификатор | Символьный код поля (задается символами латинского алфавита).
Заголовок | Заголовок поля.
Тип поля Тип поля:
  • текст - поле имеет текстовое значение;
  • число - поле имеет числовое значение;
  • дата - значением поля является дата.
Комментарий | Комментарий к значению поля.
Таб. | Флаг, определяющий, будет ли поле отображаться в HTML-таблице результатов.
Excel | Флаг, определяющий будет ли поле экспортироваться в таблицу результатов в формате Excel.


Список статусов

На странице представлен список статусов формы. Для каждого результата формы можно назначить определённый статус, например: принято к рассмотрению, опубликовано, отклонено и т.д. В настройках статуса вы можете указать различные права доступа для различных групп пользователей, а также отдельно для создателя результата. Просмотр данной страницы возможен только в полном режиме редактирования веб-форм.

Контекстная панель формы

Кнопка | Описание
Параметры формы | Переход на страницу редактирования параметров веб-формы.
Результаты | Переход на страницу со списком результатов заполнения веб-формы.
Вопросы | Переход на страницу со списком вопросов веб-формы.
Поля | Переход на страницу со списком полей веб-формы.
Статусы | Страница со списком статусов формы. Кнопка выделена, поскольку эта страница открыта.

Фильтр

Осуществляется поиск статусов веб-формы, соответствующих указанным параметрам.

Поле | Описание
Заголовок* | Заголовок статуса. Поле присутствует, даже если фильтр свернут.
ID* | ID статуса.
Активен | Флаг активности статуса.
Описание* | Описание статуса.
Результатов | Интервал, позволяющий отфильтровать статусы по количеству результатов.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать статусы веб-формы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех статусов нажмите кнопку Отменить.

Основная контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания нового статуса.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список статусов

Поле | Описание
Колонка флажков | Выбор статусов, к которым предполагается применить какое-либо правило или действие.
Действия Действия над статусом:
  • Изменить - редактирование параметров статуса;
  • Копировать - копирование статуса в новый;
  • Удалить - удаление статуса.
ID | Идентификатор статуса.
Изменен | Дата последнего редактирования параметров статуса.
Акт. | Признак активности статуса.
Сорт. | Относительный "вес", определяющий порядок вывода статусов в списке.
Умол. | Указывается, будет ли данный статус присваиваться всем вновь создаваемым результатам по умолчанию.
Заголовок | Заголовок статуса.
Описание | Описание статуса.
Результаты | Количество результатов в данном статусе. Ссылка с количеством результатов позволяет перейти к списку данных результатов.

Как создать/изменить статус

Для создания нового статуса служит кнопка Добавить, расположенная на Контекстной панели.

Для изменения статуса выберите пункт Изменить меню столбца Действия напротив соответствующего статуса.


Результаты веб-формы

Cтраница отображает результаты заполнения форм посетителями вашего сайта.

Контекстная панель

Кнопка | Описание
Параметры формы | Переход на страницу редактирования параметров веб-формы.
Результаты | Страница со списком результатов заполнения веб-формы. Кнопка выделена, поскольку эта страница открыта.
Вопросы | Переход на страницу со списком вопросов веб-формы.
Поля | Переход на страницу со списком полей веб-формы. Кнопка отображается только в режиме полного редактирования форм.
Статусы | Переход на страницу со списком статусов формы. Кнопка отображается только в режиме полного редактирования форм.

Фильтр

Поиск результатов заполнения веб-формы, соответствующих указанным параметрам.

Поле | Описание
ID* | ID результата. Поле присутствует, даже если фильтр свернут.
Дата создания (DD.MM.YYYY) | Дата создания результата.
Дата изменения (DD.MM.YYYY) | Дата изменения результата.
Зарегистрирован | Регистрировался ли посетитель, заполнявший форму на сайте.
Авторизован | Был ли посетитель авторизован по своим регистрационным данным в момент заполнения формы.
ID пользователя* | ID, логин, имя, фамилия посетителя заполнявшего форму.
ID посетителя* | ID посетителя в модуле статистики.
ID сессии* | ID сессии в модуле статистики.
Статус | Статус результата. Данное условие поиска доступно только в полном режиме редактирования веб-форм.
ID статуса | ID статуса результата. Данное условие поиска доступно только в полном режиме редактирования веб-форм.
Отправлено в CRM | Был ли результат заполнения веб-формы направлен в CRM в качестве нового лида.
[пользовательские_поля_фильтра]* | Ответы на вопросы формы.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать результаты веб-формы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех результатов нажмите кнопку Отменить.

Основная контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания нового результата.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список результатов

Поле | Описание
Колонка флажков | Поле предназначено для выбора результатов, к которым предполагается применить какое-либо правило или действие.
Действия Действия над результатом:
  • Изменить - редактирование результата;
  • Отправить в CRM - направить результат в CRM в качестве нового лида. Данное действие доступно только при настроенной связи CRM с текущей веб-формой;
  • Удалить - удаление результата.
ID | Идентификатор результата.
Статус | Статус, в котором находится результат. Данное поле отображается только в полном режиме редактирования форм.
Отправлено в CRM | Индикатор, показывающий отправлен ли результат заполнения веб-формы в CRM или нет. Данное поле доступно, если для веб-формы настроены связи с CRM.
Дата создания | Дата создания результата.
Изменено | Дата последнего изменения результата.
Создатель | Логин, имя, фамилия пользователя, создавшего либо изменившего результат (если посетитель не зарегистрирован, то выводится надпись не зарегистрирован).
Посетитель | ID посетителя в модуле статистики.
Сессия | ID сессии в модуле статистики.
[Вопросы формы] | Ответы на вопросы формы.
[Название поля] | Необходимые данные для поля веб-формы.

Редактирование результата

Отредактировать результат можно с помощью одного из шаблонов, в том числе и с помощью шаблона default.php, поставляемого вместе с дистрибутивом модуля. После редактирования будет обновлена дата изменения результата. Также вы можете сохранить выбранный шаблон в качестве шаблона по умолчанию для редактирования результатов данной формы.

Настройки, определяющие права групп пользователей на редактирование результатов устанавливаются в настройках каждой из веб-форм, а в случае работы в полном режиме также в настройках статусов.

Просмотр результата

Просмотреть данные результата можно с помощью одного из шаблонов, в том числе и с помощью шаблона default.php, поставляемого вместе с дистрибутивом модуля.

Настройки, определяющие права групп пользователей на просмотр результатов устанавливаются в настройках каждой из веб-форм, а в случае работы в полном режиме также в настройках статусов.


Примеры операций

  • Создание новой веб-формы (упрощенный режим)
  • Создание вопросов веб-формы (упрощенный режим)
  • Создание вопросов веб-формы (расширенный режим)
  • Создание полей веб-формы
  • Настройка статусов веб-формы


Видеоконференции (КП). Описание модуля

Модуль Видеоконференции предоставляет возможность проведения видеоконференцсвязи.

Примечание: модуль устарел и не поддерживается. Функционал видеосвязи выполняется модулем Вебмессенджер.

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Список видеоконференций | video | Ввыводит список доступных видеоконференций.
Видеозвонок пользователю | video.call | Служит для организации видеозвонка пользователю.
Подключение видеоконференции | video.conf | Подключает к видеоконференции.


Видеоконференции (КП). Настройки модуля

Закладки

Форма настроек модуля Видеоконференции (Настройки > Настройки продукта > Настройки модулей > Видеоконференции) предназначена для задания параметров модуля.

Настройки

Закладка предназначена для настройки общих параметров модуля.

Поле | Описание
Количество видеопереговорных | Указываются количество видеопереговорных.
Количество одновременных пользователей онлайн | Указываются количество одновременных пользователей онлайн.
Группы пользователей, которые могут совершать видеозвонки | Указываются группы пользователей, которые могут совершать видеозвонки.

ВидеоПорт

Поле | Описание
Адрес сервера | Указывается адрес вашего корпоративного видеосервера.
Порт сервера | Указывается порт вашего корпоративного видеосервера.
Секретное слово | Указывается ключ, заданный в VideoPort VCS Manager'е на закладке Приложения в поле Ключ для гостевых соединений.
Показывать главное окно видео | При отмеченной опции будет показано главное окно видео.
Показывать окно чата | При отмеченной опции будет показано окно чата.
Показывать окно участников конференции | При отмеченной опции будет показано окно участников конференции.
Показывать окно настроек | При отмеченной опции будет показано окно настроек конференции.
Показывать окно информации | При отмеченной опции будет показано окно информации конференции.
Показывать окно с изображением себя | При отмеченной опции будет показано окно с изображением себя.
Позволять приглашать пользователей | При отмеченной опции можно будет приглашать пользователей для участия в конференции.

Доступ

Закладка позволяет настроить права на доступ к модулю для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Видеоконференции:
  • [D] закрыт - запрет на доступ;
  • [R] просмотр всех данных модуля - разрешается только просмотр всех данных модуля;
  • [W] запись - полный доступ к ресурсам модуля.


Внешние источники данных (КП). Описание модуля

Модуль Внешние источники данных позволяет подключать различные внешние сервисы в корпоративный портал. Например можно выводить в Живую ленту портала, Рабочей группы, конкретного пользователя; а так же в RSS-ленту и т.п. информацию с внешних источников с помощью любого POST-запроса, RSS-ленты или используя XML-файл.

Модуль Внешние источники данных не имеет собственных настроек.

Смотрите также:

  • Публикация в Живую ленту


Публикация в Живую ленту

Страница Подключения к провайдерам данных для Живой ленты (Сервисы > Внешние источники данных > Публикация в Живую ленту) содержит информацию о существующих подключениях внешних источников, позволяет создавать новые подключени и управлять существующими. Информация о подключениях представлена в виде таблицы.

Контекстная панель

Кнопка | Описание
Добавить подключение | Переход к созданию нового подключения.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

Список подключений

Поле | Описание
Колонка флажков | Выбор форумов, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над подключениями:
  • Редактирование настроек подключения;
  • Активировать или деактивировать подключение;
  • Удаление подключение.
ID | Идентификатор подключения в системе.
Название | Произвольное название подключение.
Активность | Признак активности подключения.
Сортировка | Вес сортировки подключения; применяется при выводе списка подключений.
Сайт | Сайт(ы), к которым относится данное подключение.
Тип подключения | Тип подключения: POST-запрос, RSS-лента или Веб-сервис (XML).


Создание и редактирование подключения

Для создания и редактирования подключений применяется форма одного и того же вида. В зависимости от того, создаете вы новое подключение или редактируете существующее, некоторые поля могут присутствовать или отсутствовать на форме.

Контекстная панель

Кнопка | Описание
Список подключений | Ссылка для перехода на страницу со списком подключений.

POST-подключение

Поле | Описание
Настройка параметров подключения для публикации в Живую ленту
ID Идентификатор подключения.

Поле отображается только в режиме редактирования существующего вопроса.
Тип подключения | POST-запрос.
Активность | Признак активности подключения.
Сайт | Выбор сайта, для которого настраивается подключение.
*Название Произвольное название подключения.

Обратите внимание, это название будет непосредственно отображаться в Живой ленте, поэтому оно должно быть простым и понятным.

Сортировка | Вес сортировки подключения; применяется при выводе списка подключений.
Параметры события Живой ленты
*Добавлять событие для Указывается тип события:
  • рабочей группы - выбор рабочей группы, к которой привязывается событие;
  • страницы пользователя - выбрать сотрудника, на странице которого будет отображаться данные;
  • ленты новостей - выбрать информационный блок новостей;
  • внешнего источника данных - без привязки к какой-либо сущности портала;
Выберите рабочую группу Выбор рабочей группы из списка, для которой будет доступно событие.

Примечание: Опция доступна, только если выбран тип события - рабочей группы.

Выберите пользователя Указывается идентификатор пользователя в системе, либо с помощью кнопки [...] выбирается из списка пользователей в системе.

Примечание: Опция доступна, только если выбран тип события - страницы пользователя.

Лента новостей Выбор ленты новостей из списка доступных инфоблоков.

Примечание: Опция доступна, только если выбран тип события - ленты новостей.

Права на доступ к событию Выбор групп прав для доступа к событию: Все посетители, Авторизованные пользователи или Выбранные пользователи (можно указать идентификатор или выбрать из списка пользователей системы. По ссылке Добавить пользователя добавляются дополнительные пользователи).

Примечание: Опция доступна, только если выбран тип события - внешнего источника данных.

*Разрешить добавление комментариев к событию При выводе события в Живую ленту в ней будет доступен функционал комментариев к данному посту.

Примечание: Опция доступна, только если выбран тип события - внешнего источника данных.
Параметры подключения для передачи POST-запроса

В данной секции запроса указывается скрипт портала и параметры запроса, который должна сформировать внешняя по отношению к порталу система:

  • hash - хеш авторизации, чтобы портал разрешил импорт данных;
  • title - заголовок события для отображения в Живой ленте;
  • message - текст события для отображения в Живой ленте (может включать HTML-форматирование);
  • В параметре message передается HTML - при включенной опции текст события (параметр message) будет передавать в формате HTML;
  • text-message - текст события в виде простого текста (для уведомлений подписчиков по почте или jabber);
  • url - абсолютный путь события, для просмотра подробностей по этому событию, которые можно посмотреть вне портала.

RSS-подключение

Поле | Описание
Настройка параметров подключения для публикации в Живую ленту
ID Идентификатор подключения.

Поле отображается только в режиме редактирования существующего вопроса.
Тип подключения | RSS-лента.
Активность | Признак активности подключения.
Сайт | Выбор сайта, для которого настраивается подключение.
*Название Произвольное название подключения.

Обратите внимание, это название будет непосредственно отображаться в Живой ленте, поэтому оно должно быть простым и понятным.

Сортировка | Вес сортировки подключения; применяется при выводе списка подключений.
Параметры события Живой ленты
*Добавлять событие для Указывается тип события:
  • рабочей группы - выбор рабочей группы, к которой привязывается событие;
  • страницы пользователя - выбрать сотрудника, на странице которого будет отображаться данные;
  • ленты новостей - выбрать информационный блок новостей;
  • внешнего источника данных - без привязки к какой-либо сущности портала;
Выберите рабочую группу Выбор рабочей группы из списка, для которой будет доступно событие.

Примечание: Опция доступна, только если выбран тип события - рабочей группы.

Выберите пользователя Указывается идентификатор пользователя в системе, либо с помощью кнопки [...] выбирается из списка пользователей в системе.

Примечание: Опция доступна, только если выбран тип события - страницы пользователя.

Лента новостей Выбор ленты новостей из списка доступных инфоблоков.

Примечание: Опция доступна, только если выбран тип события - ленты новостей.

Права на доступ к событию Выбор групп прав для доступа к событию: Все посетители, Авторизованные пользователи или Выбранные пользователи (можно указать идентификатор или выбрать из списка пользователей системы. По ссылке Добавить пользователя добавляются дополнительные пользователи).

Примечание: Опция доступна, только если выбран тип события - внешнего источника данных.

*Разрешить добавление комментариев к событию При выводе события в Живую ленту в ней будет доступен функционал комментариев к данному посту.

Примечание: Опция доступна, только если выбран тип события - внешнего источника данных.

Параметры подключения к источнику данных
*URI | Указывается путь к источнику данных.
В элементе description передается HTML При включенной опции указывается, что в элементе description передаваемого через RSS сообщения используется HTML.

Примечание: В связи с изменениями, связанными с безопасностью, убедитесь, что в настройках схем публикации в живую ленту типа "RSS-лента" установлена активной опция В элементе description передается HTML там, где это необходимо.
Расписание автоматической публикации
*Время последней генерации выпуска (DD.MM.YYYY HH:MI:SS) | Выбирается время и дата последнего подключения.
Дни месяца (например 1,10-20,25) | Указывается числа месяца, когда производить подключение к внешним сервисам.
Дни недели | Указывается дни недели, когда производить подключение к внешним сервисам.
*Время (например 9:00,18:00) | Указывается время, когда производить подключение к внешним сервисам.

XML-подключение

Поле | Описание
Настройка параметров подключения для публикации в Живую ленту
ID Идентификатор подключения.

Поле отображается только в режиме редактирования существующего вопроса.
Тип подключения | XML.
Активность | Признак активности подключения.
Сайт | Выбор сайта, для которого настраивается подключение.
*Название Произвольное название подключения.

Обратите внимание, это название будет непосредственно отображаться в Живой ленте, поэтому оно должно быть простым и понятным.

Сортировка | Вес сортировки подключения; применяется при выводе списка подключений.
Параметры события Живой ленты
*Добавлять событие для Указывается тип события:
  • рабочей группы - выбор рабочей группы, к которой привязывается событие;
  • страницы пользователя - выбрать сотрудника, на странице которого будет отображаться данные;
  • ленты новостей - выбрать информационный блок новостей;
  • внешнего источника данных - без привязки к какой-либо сущности портала;
Выберите рабочую группу Выбор рабочей группы из списка, для которой будет доступно событие.

Примечание: Опция доступна, только если выбран тип события - рабочей группы.

Выберите пользователя Указывается идентификатор пользователя в системе, либо с помощью кнопки [...] выбирается из списка пользователей в системе.

Примечание: Опция доступна, только если выбран тип события - страницы пользователя.

Лента новостей Выбор ленты новостей из списка доступных инфоблоков.

Примечание: Опция доступна, только если выбран тип события - ленты новостей.

Права на доступ к событию Выбор групп прав для доступа к событию: Все посетители, Авторизованные пользователи или Выбранные пользователи (можно указать идентификатор или выбрать из списка пользователей системы. По ссылке Добавить пользователя добавляются дополнительные пользователи).

Примечание: Опция доступна, только если выбран тип события - внешнего источника данных.

*Разрешить добавление комментариев к событию При выводе события в Живую ленту в ней будет доступен функционал комментариев к данному посту.

Примечание: Опция доступна, только если выбран тип события - внешнего источника данных.
Параметры подключения к источнику данных
Стандартные схемы обмена | Выбирается один из источников данных, входящих в состав системы: нет, Статистика сайта, Статистика по заказам.
*URI Указывается путь к источнику данных.

Примечание: Поле доступно, только если выбрана опция Стандартные схемы обмена - нет.
Сервер Указывается сервер источника данных.

Примечание: Поле доступно, только если выбраны опции Стандартные схемы обмена: Статистика сайта и Статистика по заказам.
Метод веб-сервиса Указывается метод веб-сервиса.

Примечание: Поле доступно, только если выбрана опция Стандартные схемы обмена: нет.

Строка параметров для метода | Указывается строка параметров для метода веб-сервиса.
Логин | Указывается логин для подключения к веб-сервису.
Пароль | Указывается пароль для подключения к веб-сервису.
Расписание автоматической публикации
*Время последней генерации выпуска (DD.MM.YYYY HH:MI:SS) | Выбирается время и дата последнего подключения.
Дни месяца (например 1,10-20,25) | Указывается числа месяца, когда производить подключение к внешним сервисам.
Дни недели | Указывается дни недели, когда производить подключение к внешним сервисам.
*Время (например 9:00,18:00) | Указывается время, когда производить подключение к внешним сервисам.

* - поля, обязательные для заполнения.


Интранет (КП). Описание модуля

Описание модуля

Модуль Интранет предназначен для управления задачами и поручениями, организации коллективных событий, резервирования переговорных и ресурсов, работы с электронными заявками.

Модуль используется для выполнения простого и расширенного поиска по базе сотрудников, отображения кадровых изменений, происходящих в компании, автоматического построения графика отсутствия сотрудников, организации доски почета, мониторинга дней рождения сотрудников, создания календарей событий с возможностью взаимной интеграции, импорта пользователей из "1С:Зарплата и управление Персоналом".

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Интерфейс 1с 8.2 | intranet.1c82.interface | Позволяет подключаться к web-платформе 1С 8.2.
Расчетные листки сотрудников | payroll.1c | Позволяет подключаться к web-платформе "1С: ЗУП" и выводить зарплатные листки сотрудников компании.
Руководство подразделениями | intranet.structure.head.user | Выводит список подразделений, руководителем которых является сотрудник.
HR
Календарь отсутствий | intranet.absence.calendar | Выводит график отсутствий сотрудников в виде календаря.
Отсутствия пользователя | intranet.absence.user | Выводит график отсутствий конкретного пользователя.
Отсутствующие сотрудники | intranet.structure.informer.absent | Выводит краткий список отсутствующих сотрудников.
Доска почета | intranet.structure.honour | Выводит список почетных сотрудников компании.
Доска почета пользователя | intranet.structure.honour.user | Выводит историю присутствия пользователя на доске почета.
Кадровые изменения | intranet.structure.events | Выводит список последних кадровых перестановок в компании.
Новые сотрудники | intranet.structure.informer.new | Выводит краткий список новых сотрудников компании.
Дни рождения | intranet.structure.birthday.nearest | Выводит список ближайших именинников офиса, отдела или филиала компании.
Бронирование переговорных
Бронирование переговорных (комплексный компонент) | intranet.reserve_meeting | Выводит календарь занятости переговорных комнат, позволяет бронировать переговорные и управлять ими.
Меню | intranet.reserve_meeting.menu | Выводит меню комплексного компонента.
Переговорная | intranet.reserve_meeting.meeting | Служит для отображения переговорной.
Поиск переговорных | intranet.reserve_meeting.search | Служит для поиска переговорных.
Просмотр резервирования | intranet.reserve_meeting.view_item | Предназначен для просмотра резервирования переговорных.
Резервирование переговорной | ntranet.reserve_meeting.reserve | Служит для резервирования переговорной.
Создание переговорной | intranet.reserve_meeting.add | Служит для создания переговорной комнаты.
Список переговорных | intranet.reserve_meeting.list | Выводит список переговорных.
Оргструктура
Поиск сотрудника (комплексный компонент) | intranet.search | Выводит форму поиска и список найденных сотрудников корпоративного портала.
Структура компании (комплексный компонент) | intranet.structure | Выводит дерево структуры компании со списком сотрудников корпоративного портала.
Визуальная структура компании | intranet.structure.visual | Выводит визуальное представление древовидной структуры компании.
Список сотрудников | intranet.structure.list | Выводит список сотрудников, удовлетворяющих внешнему фильтру.
Форма поиска | intranet.structure.selector | Выводит форму фильтрации списка сотрудников.
Задачи 1.0
Меню | intranet.tasks.menu | Служит для показа меню.
Задачи | intranet.tasks | Служит для отображения задач.
Задачи (список) | intranet.tasks_list | Служит для отображения списка задач.
Изменение задачи | intranet.tasks.create | Служит для создания и изменения задач.
Изменение представления | intranet.tasks.create_view | Служит для создания и изменения представлений.
Список задач | intranet.tasks.view | Вспомогательный компонент, выводящий список задач. (Компонент служебный, не описывается.)
Календарь событий
Календарь событий | intranet.event.calendar | Служит для создания календаря событий.
Список событий календаря | intranet.event.list | Выводит список ближайших событий календаря.
Системные (не описываются)
Представления графика отсутствий | intranet.absence.calendar.view | Служебный компонент, шаблоны которого содержат скрипты обработки представлений графика отсутствий (закладки День/Неделя/Месяц).
Визитка сотрудника | intranet.system.person | Выводит персональные данные на странице Поиск сотрудников продукта "1С-Битрикс: Корпоративный портал".
Список задач | intranet.tasks.view | Служебный компонент, применяется в построении списка задач.

Смотрите также

  • Организация структуры компании
  • График отсутствий
  • Доска почета
  • Настройка календарей портала
  • Кадровые изменения сотрудников


Интранет (КП). Настройки модуля

Закладки

Форма настроек модуля Интранет (Настройки > Настройки продукта > Настройки модулей > Интранет) предназначена для задания общесистемных параметров модуля. Для удобства работы форма разделена на закладки, на каждой из которых выполняется настройка определённой группы параметров модуля.

Данные

Закладка служит для настрйки источников данных для компонентов модуля.

Поле | Описание
Общие настройки для всех сайтов
Инфоблоки оргструктуры
Тип инфоблока | Указывается тип информационного блока, содержащий оргструктуру компании.
Инфоблок структуры компании | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будет храниться структура компании.
Инфоблок доски почета | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будет храниться доска почета.
Инфоблок истории состояний | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будет храниться история состояний.
Инфоблоки вакансий
Тип инфоблока | Указывается тип информационного блока, содержащий вакансии.
Инфоблоки задач
Тип инфоблока | Указывается тип информационного блока, содержащий задачи.
Использовать задачи 2.0 | При отмеченной опции для новых задач будет использоваться функционал Задачи 2.0. Примечание: При активации этой опции старые задачи не будут сконвертированы в Задачи 2.0. Чтобы сконвертировать старые задачи в Задачи 2.0 необходимо воспользоваться мастером установки Задачи 2.0. Подробнее см. в уроке Установка и подключение модуля "Задачи 2.0" курса "Администрирование портала".
Другие настройки
Выключить добавление в живую ленту записи о принятии на работу нового сотрудника | При отмеченной опции запись о принятии на работу нового сотрудника в Живой ленте выводиться не будет.
Настройки для сайта <имя_сайта>
Инфоблок графика отсутствий | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будет храниться график отсутствий сотрудников.
Инфоблок вакансий | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будет храниться вакансии сотрудников.
Инфоблок задач | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будет храниться задачи сотрудников.

Импорт

Закладка предназначена для настройки параметров импорта пользователей из «1С: Зарплата и управление персоналом».

Поле | Описание
Базовые настройки
Сайт для привязки пользователей | Определяется сайт, к которому будут привязываться новые пользователи, созданные при импорте. Привязка может производиться либо к текущему сайту, либо к одному определённому сайту из имеющихся в системе.
Группы, пользователям которых разрешена загрузка | Указывается группа(-ы) пользователей, обладающие правом импорта пользователей из 1С:ЗУП на сайт.
Дополнительные настройки
Обновляемые свойства | Указываются свойства, которые будут обновлены при импорте пользователей из 1С:ЗУП.
E-mail по умолчанию | Указывается E-Mail, на который по умолчанию будут направляться информационные сообщения модуля Интранет. Например, сообщения об успешном импорте, ошибках и т.д.
Формировать уникальный e-mail | При отмеченной опции будет создаваться уникальный e-mail сотрудника.
Шаблон автоматического формирования логина | Указывается шаблон автоматического формирования логина.
Уведомление пользователей
E-mail-уведомление новым пользователям E-mail-уведомление будет отсылаться:
  • не отсылать - новые пользователи не будут получать уведомления;
  • только если указан e-mail - новым пользователям при условии если указан e-mail;
  • всем - всем новым пользователям.
Отсылать уведомления сразу | При отмеченной опции уведомления будут отсылатся сразу.
LDAP
XML-идентификатор свойства "Учетная запись AD" | Указывается XML-идентификатор свойства "Учетная запись AD" в том случае, если само свойство в 1С задано в набираемом свойстве.
Сервер LDAP | В выпадающем списке выбирается сервер, который будет использоваться при авторизации.
Настройки импорта в формате CommerceML 2
Проводить проверку целостности структуры | При отмеченной опции будет проводиться проверка целостности структуры.
Интервал одного шага в секундах (0 - выполнять загрузку за один шаг) | Указывается интервал одного шага в секундах при импорте каталога в систему. Если указать 0, то загрузка будет выполнена за один шаг.
Размер единовременно загружаемой части файла (в байтах) | Указывается размер единовременно загружаемой части файла (в байтах) - второе ограничение для пошаговой загрузки файла в систему.
Использовать сжатие zip, если доступно | При отмеченной опции данные сжимаются ZIP форматом (если доступно). Это позволяет заметно уменьшить размер XML файла(ов).
XML-идентификатор свойства "Электронная почта" | Указывается XML-идентификатор свойства "Электронная почта" в том случае, если само свойство в 1С задано в набираемом свойстве.
XML-идентификатор свойства "Логин" | Указывается XML-идентификатор свойства "Логин" в том случае, если само свойство в 1С задано в набираемом свойстве.
XML-идентификатор свойства "Пароль" | Указывается XML-идентификатор свойства "Пароль" в том случае, если само свойство в 1С задано в набираемом свойстве.
Настройки импорта в формате HR-XML
HRXML, значение атрибута SchemeName для ID физического лица | Указывается значение атрибута SchemeName для идентификатора физического лица.

Синхронизация

Закладка предназначена для настройки параметров синхронизации с Microsoft Outlook.

Поле | Описание
Синхронизировать изображения пользователей | При отмеченной опции изображения пользователей будут синхронизироваться.
Первый день недели | Указывается первый день недели.
Настройки часового пояса
В моем регионе осуществляется переход на летнее время и обратно | При отмеченной опции будет осуществляется переход на летнее время и обратно.
Переход на стандартное время Указывается вариант перехода на стандартное время для вашего региона.

Указав пункт другое->, можно описать свое условие перехода на летнее время на основе спецификации [MS-OUTSPS] 2.2.4.8 TransitionDate [image] [image].
Переход на летнее время Указывается вариант перехода на летнее время для вашего региона.

Указав пункт другое->, можно описать свое условие перехода на летнее время на основе спецификации [MS-OUTSPS] 2.2.4.8 TransitionDate [image] [image].
Локальное время сервера | В поле отображается Разница с GMT (например, +0200 (7200)), тип времени (Стандартное/летнее время) и Текущая дата (RFC 2822) (напрмер Mon, 30 Nov 2009 11:57:37 +0200).
Ссылки
Шаблон ссылки на <имя_сайта> Для каждого сайта системы на соответствующей закладке указываются шаблоны ссылок на:
  • профиль пользователя;
  • список задач пользователя;
  • задачу пользователя;
  • список задач группы;
  • задачу группы.

Поиск

Закладка предназначена для настройки параметров поиска файлов.

Поле | Описание
Индексация файлов внешними конверторами
Подробнее о настройке поиска документов см. курс Администратор "1С-Битрикс: Корпоративный портал"
Расширение | Указывается расширение файла для поиска.
Внешняя команда | Указывается внешняя команда конвертору для индексациий файлов.
Каталог программы | Указывается каталог, в котором содержится внешний конвертер для индексациий файлов.

Почта

Закладка предназначена для настройки параметров проверки внешних почтовых ящиков.

Поле | Описание
Разрешить подключение внешних почтовых ящиков | При отмеченной опции включается возможность проверки внешних почтовых ящиков. Подробнее см. Интеграция с почтой [image] .
Периодичность проверки в секундах | Указывается время периода проверки внешних почтовых ящиков в секундах.


Календарь событий

Модуль Календарь событий дает возможность просматривать график грядущих и прошедших событий сотрудников.

Модуль включает в себя следующие компоненты 2.0:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Календарь событий 2.0 | calendar.grid | Cлужит для создания календаря событий.
Список событий календаря 2.0 | calendar.events.list | Выводит список ближайших событий календаря.
* Просмотр события календаря (КП) | calendar.livefeed.view | Просмотр события календаря в Живой ленте социальной сети.
* Форма редактирования события (КП) | calendar.livefeed.edit | Компонент для отображения формы редактирования события в Живой ленте.
* - Компоненты используются в Живой ленте, автономная работа не предусмотрена.

Смотрите также:

  • Настройки модуля
  • Управление календарями (добавление календарей)
  • Управление событиями


Календарь событий. Настройки модуля

Форма настроек модуля Календарь событий (Настройки > Настройки продукта > Настройки модулей > Календарь событий) предназначена для задания общесистемных параметров модуля. Для удобства работы форма разделена на закладки, на каждой из которых выполняется настройка определённой группы параметров модуля.

Закладка Настройки

Поле | Описание
Параметры рабочего времени | Задаются параметры по умолчанию рабочего времени для компании.
Выходные дни недели | Указываются нерабочие для сотрудников компании дни.
Выходные и праздничные дни в году Указываются выходные и праздничные дни в году.

Формат представления:

12.06, 4.11, 12.12
Рабочие дни в году | При необходимости, аналогично выходным и праздничным дням, указываются рабочие дни в году.
Шаблон имени пользователя (КП) | Задается шаблон для имени пользователя.
По возможности проводить синхронизацию календаря через Webhook вместо агента (КП) | Система будет проводить синхронизацию с помощью технологии Webhook, если это возможно по настройкам сети.
Показывать логин пользователя (КП) | При отмеченной опции, на панели управления после имени и фамилии, будет указан логин сотрудника в системе.
Разрешить начальникам просматривать календари подчиненных (КП) | При отмеченной опции начальники подразделений смогут просматривать события всех календарей подчиненных вне зависимости от персональных настроек прав доступа.
Список типов календарей, которые могут быть добавлены в избранные (КП) | Отмечаются типы календарей, которые разрешается сотрудникам добавлять в список избранных.
Шаблоны ссылок (КП)
Общие для всех сайтов (КП) | При отмеченной опции заданные шаблоны ссылок будут применяться ко всем сайтам в системе.
Шаблоны ссылок (КП) Указываются шаблоны ссылок к следующим страницам:
  • профиля пользователя;
  • календаря пользователя;
  • просмотра рабочей группы;
  • просмотра календаря группы;
  • видеопереговорной;
  • переговорной;
  • Календаря компании;
  • Событий
  • типа "location"
  • типа "resource"
Параметры переговорных (КП)
Тип инфоблока бронирования переговорных, видеопереговорных (КП) | Выбирается тип инфоблока для бронирования видеопереговорных и переговорных.
Инфоблок бронирования переговорных (КП) | Выбирается инфоблок бронирования переговорных.
Инфоблок бронирования видеопереговорных (КП) | Выбирается инфоблок бронирования видеопереговорных.
Параметры комментариев для событий календаря
Форум для комментариев | Выбирается форум, который будет использован как комментарии к календарям.

Закладка Типы календарей

Закладка позволяет добавить новый тип календарей, удалить или изменить существующие, а также настроить права доступа к типам календарей для всех сотрудников.

Добавить новый тип - позволяет добавить новый тип календарей.

Изменить - позволяет изменить существующий тип календарей.

Удалить - позволяет удалить существующий тип календарей.

Добавить - позволяет добавить право доступа к типу календарей для сотрудника или группы сотрудников.

Поле Описание
Права доступа для всех календарей данного типа Указываются права доступа для групп сотрудников. Возможно назначение следующих прав доступа:
  • Доступ закрыт - запрет доступа к данному типу календарей;
  • Просмотр - разрешено только просматривать календари данного типа;
  • Редактирование событий и календарей - разрешено редактировать события и календари данного типа;
  • Полный доступ - разрешены любые действия с календарями данного типа.


Конструктор отчетов (КП). Описание модуля

Модуль Конструктор отчетов позволяет сотрудникам самим конструировать отчеты для разных объектов и в дальнейшем многократно их запускать.

Модуль включает в себя следующие компоненты 2.0, которые не имеют формы задания настроек:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Просмотр списка отчетов | report.list | Просмотр списка отчетов.
Просмотр отчета | report.view | Просмотр отчета.
Редактирование отчета | report.construct | Редактирование отчета.

Примечание: В фильтре по дате поддерживается PHP Date Relative Formats [image].

Смотрите также:

  • Как создать отчет
  • Конструктор отчетов (документация для разработчика)


Основные сведения

Описание модуля

Модуль Экстранет – расширение для продукта «Битрикс24 в коробке», которое позволяет компании осуществлять конфиденциальную связь с поставщиками, дистрибуторами и другими внешними пользователями без доступа к внутрикорпоративной информации.

Модуль входит в состав всех редакций продукта «Битрикс24 в коробке». Независимо от числа приобретенных лицензий для «Битрикс24 в коробке», количество внешних пользователей в модуле Экстранет не ограничивается.

Примечание: после установки модуля компоненты будут добавлены в соответствующие разделы списка компонентов визуального редактора:
  • Последние сообщения всех блогов экстранета (Общение -> Блоги);
  • Экстранет - создание группы (комплексный компонент) (Общение -> Социальная сеть);
  • Форма инициализации регистрации (Служебные -> Пользователь).

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Последние сообщения всех блогов экстранета | extranet.blog.new_posts.list | Выводит последние сообщения блогов сайта экстранета с постраничной навигацией.
Экстранет - создание группы (комплексный компонент) | extranet.group_create | Служит для создания группы экстранета
Форма инициализации регистрации | system.auth.initialize | Выводит форма инициализации регистрации, созданной в рамках социальной сети.

Смотрите также

  • Основные понятия о модуле Экстранет
  • Установка и настройка экстранета
  • Права доступа пользователей экстранета
  • Публичный сотрудник


Экстранет (КП). Настройки модуля

Форма настроек модуля Экстранет (Настройки > Настройки продукта > Настройки модулей > Экстранет) предназначена для задания общесистемных параметров модуля.

Закладка "Настройки"

Поле | Описание
Код сайта экстранета | Указывается сайт, который будет пониматься системой как сайт экстранета.
Символьный код пользовательского свойства признака публичности сотрудника | Указывается символьный код пользовательского свойства для признака публичности сотрудника. Код предварительно должен быть создан на странице Пользовательские поля.
Группа пользователей экстранет | Указывается группа пользователей экстранет. Можно использовать имеющиеся группы, но желательно использовать специальныую созданную группу пользователей.


Контроллер. Описание модуля

Описание модуля

Модуль Контроллер предназначен для группового централизованного администрирования, обновления, мониторинга большого количества сайтов, расположенных как на этом же сервере, так и на удаленных серверах, доступных через Интернет.

Модуль Контроллер:

  • предоставляет возможность по управлению любым сайтом (глобальное администрирование) или сразу группой сайтов;
  • хранит список всех локальных сайтов с их характеристиками и настройками;
  • осуществляет контроль над размерами каждого локального сайта, периодом активности и т.п.;
  • выполняет процедуру обновления продукта на сайтах клиентах;
  • содержит мастера и шаблоны для создания новых сайтов.

Помимо обновления, управления правами и параметрами на клиентских сайтах, контроллер может осуществлять копирование/удаление файлов на локальных сайтах, удаленно выполнять произвольные PHP-скрипты, быть сервером для единой авторизации и еще множество других операций.

Логически каждый сайт, подключенный к контроллеру, имеет следующий минимальный набор характеристик:

  • набор установленных модулей продукта (редакцию);
  • бюджет локального администратора и набор его прав доступа внутри данного сайта.

Права доступа локального администратора могут варьироваться от минимальных до максимальных, но не могут превышать полномочия самого администратора сайта-контроллера. Каждый локальный сайт может снабжаться индивидуальным мастером создания, запускаемым сразу после регистрации нового сайта на сайте-контроллере. Проходя по мастеру, локальный администратор настраивает свой сайт под решаемые задачи.

Доступ на локальные сайты администраторов возможно настроить двумя способами:

  • через контроллер;
  • напрямую.

При выполнении авторизации через контроллер список пользователей хранится на контроллере, где и осуществляется задание и проверка прав доступа для каждой группы пользователей. При этом доступ к локальному сайту осуществляется через изменяемый префикс.

При выполнении авторизации напрямую списки пользователей хранятся каждый на своем сайте, там же задается уровень прав доступа.

Разница способов доступа заключается в том, что при первом варианте локальный администратор может по своей авторизации получить доступ ко всем сайтам контроллера на правах, определенных администратором контроллера. При втором варианте локальный администратор может авторизоваться только на своем сайте и на другом сайте контроллера, если ему разрешен доступ локальным администратором другого сайта.

Внимание! Действие по публикации новостей требует на клиенте версию главного модуля 11.0.9.

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Список сайтов | controller.site.list | Выводит список сайтов, зарегистрированных в контроллере.
Системные компоненты. Не описываются.
Добавление сайта | controller.shared.add | Добавление сайта в контроллер .
Управление сайтом | controller.site.control | Управление добавленным сайтом.

Смотрите также

  • Как работать с Контроллером сайтов
  • Частые вопросы


Контроллер. Настройки модуля

Отправить отзыв по этому разделу
Сервисы>Контроллер>Контроллер. Настройки модуля

Контроллер::Контроллер. Настройки модуля

Закладки

Форма настроек модуля Контроллер (Настройки > Настройки продукта > Настройки модулей > Контроллер) предназначена для задания общесистемных параметров модуля. Для удобства работы форма разделена на закладки, на каждой из которых выполняется настройка определённой группы параметров модуля.

Настройки

Закладка предназначена для настройки общих параметров модуля.

Поле | Описание
Группа по умолчанию для присоединяющихся сайтов | Указывается название группы, к которой по умолчанию будут присоединяться сайты при их присоединении к контроллеру.
Интервал для автоматичекой установки групповых настроек на клиентские сайты, по умолчанию, минут (0 - не обновлять автоматически) | Задается интервал времени в минутах для автоматичекой установки групповых настроек на клиентские сайты по умолчанию. Если указано 0, то настройки клиентов не будут обновляться автоматически.
Путь к папке с общим ядром (относительно корня сайта-контроллера) | Для возможности обновления клиентов с общим файловым ядром продукта необходимо указать путь к папке с общим ядром. Данный параметр доступен в редакции Платформа аренды приложений продукта.
Включить показ дополнительного поля "Имя хоста" | При включении опции в форме создания/редактирования сайта будет доступно поле для задания альтернативного имени подключенного сайта.
Сколько дней хранить журнал авторизаций | Указание на срок хранения записей в журнале авторизаций. Значение 0 - записи не удаляться никогда.
Количество повторных попыток выполнения задач | Указывается число повторных попыток выполнения задач. Настройка доступна с версии модуля 20.100.0.
Интервал между повторными попытками выполнения задач (сек.) | Указывается интервал между повторными попытками выполнения задач в секундах. По умолчанию установлен интервал 600 сек.

Доступ

Закладка позволяет настроить права на доступ к модулю для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Контроллер:
  • [D] Нет доступа - запрет на доступ;
  • [L] Авторизация - разрешается выполнить вход на подчиненных сайтах;
  • [R] Чтение - разрешается только просмотр файлов и параметров модуля;
  • [T] Добавление - добавление новых сайтов, позволяет безопасно вводить имя-пароль на клиентских машинах при присоединении;
  • [V] Управление - управление сайтами, т.е. их добавление, обновление, отсоединение, административный вход на них, просмотр журнала работы. Нельзя удалять сайты и изменять групповые настройки;
  • [W] Полный доступ - полный доступ без каких-либо ограничений.

Смотрите также

  • Настройки модуля Контроллер [image] в курсе Администратор. Модули.


Управление подчиненными сайтами

Отправить отзыв по этому разделу
Сервисы>Контроллер>Управление подчиненными сайтами

Контроллер::Управление подчиненными сайтами

На странице Управление подчиненными сайтами (Сервисы > Контроллер > Сайты) представлен список сайтов, подключенных к сайту-контроллеру.

Фильтр

Фильтр используется для задания параметров отбора сайтов-клиентов, отображаемых в списке.

Поле | Описание
Название | Поиск сайта-клиента по названию. Поле присутствует, даже если фильтр свернут.
ID | Поиск клиента по идентификатору.
URL сайта | Поиск по адресу сайта-клиента.
Группа | Отбор клиентов, относящихся к указанной группе. Если выбрано значение любая, то будут отображены клиенты, относящиеся ко всем группам.
Уникальный код | Поиск клиента по уникальному коду.
Активен | Отображение только активных клиентов либо только неактивных клиентов, либо всех клиентов.
Отсоединенный | Отображение только присоединенных клиентов либо только отсоединенных клиентов, либо всех клиентов.
Период изменения | Поиск клиентов, настройки которых были изменены в указанный период.
Период создания | Поиск клиентов, которые были созданы в указанный период времени.
Активен с | Отбор клиентов, активность которых началась в заданный период времени.
Активен по | Отбор клиентов, активность которых закончилась в заданный период времени.
Контактное лицо | Отбор клиентов по ФИО контактного лица.
E-Mail адрес | Отбор клиетов по адресу электронной почты контактного лица.

Чтобы отфильтровать клиентов по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех клиентов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Служит для добавления нового клиента.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список сайтов

Колонка | Описание
Колонка флажков | Выбор клиентов, к которым предполагается применить действие.
Меню действий Доступные действия:
  • Редактировать - отредактировать параметры сайта;
  • Войти как Администратор - переход в публичный раздел сайта-клиента в качестве администратора. Виден только на подключенном сайте.
  • Обновить сайт - установка обновлений на сайт клиента. Виден только на подключенном сайте.
  • Обновить настройки - выполнение установки настроек на сайт клиента. Виден только на подключенном сайте.
  • Обновить счётчики - команда на обновление счётчиков на сайте клиента. Виден только на подключенном сайте.
  • Выполнить PHP - переход на страницу удаленного выполнения команды для данного сайта. Виден только на подключенном сайте.
  • Лог операций - переход на страницу журнала работы контроллера с установленным фильтром на данном клиенте.
  • Отсоединить - отключение клиента от контроллера. Виден только на подключенном сайте.
  • Удалить - удаление записи данного клиента.
Дата изменения | Дата и время проведения последнего изменения клиента.
Кем изменено | Логин, имя и фамилия пользователя, проводившего последнее изменение клиента.
Название | Название клиента.
URL сайта | Адрес сайта-клиента.
Контактное лицо | ФИО контактного лица сайта клиента.
E-Mail адрес | Адрес электронной почты контактного лица сайта клиента.
Группа | Группа, к которой относится клиент.
Отключен | Отметка о том, что клиент присоединен или отсоединен от контроллера.
Акт. | Признак активности клиента.
Активен с | Дата и время начала активности клиента.
Активен по | Дата и время окончания активности клиента.
Дата создания | Дата и время создания клиента.
Кем создана | Логин, имя и фамилия пользователя, который создал клиента.
Уникальный код | Уникальный код клиента.
Последнее обновление счетчиков | Дата и время последнего обновления счетчиков клиента.
Свободное место, Кб | Свободное дисковое пространство клиента (в КБ).
Кол-во сайтов | Количество сайтов клиента.
Пользователей | Количество пользователей на клиенте.
Последняя авторизация | Дата и время последней авторизации на клиенте.
Заметки | Произвольное описание клиента.
ID | Идентификатор клиента.

Смотрите также

  • Как подключить подчиненный сайт к контроллеру (учебный курс "Администратор. Модули")


Создание и редактирование сайта (клиента)

Отправить отзыв по этому разделу
Сервисы>Контроллер>Создание и редактирование сайта (клиента)

Контроллер::Создание и редактирование сайта (клиента)

Закладки

Форма, размещенная на данной странице, предназначена для регистрации новых клиентов и редактирования параметров существующих.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком клиентов.
История | Переход на страницу с историей изменений на клиенте. Кнопка отображается только при редактировании существующего клиента.
Добавить | Переход на страницу создания нового клиента. Кнопка отображается только при редактировании существующего клиента.
Отсоединить | Отключение клиента от контроллера. Кнопка отображается только при редактировании существующего неотсоединенного клиента.
Удалить | Удаление клиента. Примечание: если при удалении клиент не был отсоединен, то запись об этом клиенте из контроллера будет удалена, а сам сайт будет работать с теми настройками, которые были установлены контроллером. Если же перед удалением клиент был отсоединен, то на сайте будут возвращены настройки, установленные до подключения к контроллеру. Кнопка отображается только при редактировании существующего клиента.

Параметры сервера

Поле | Описание
ID | Идентификатор сайта-клиента. Поле отображается только при редактировании существующего клиента и изменению не подлежит.
Отсоединен от контроллера | Отметка о том, что клиент отсоединен от контроллера. Поле отображается только при редактировании существующей записи о клиенте, если клиент отключен, и изменению не подлежит.
Дата создания | Дата и время, а также логин, имя и фамилия пользователя, который зарегистрировал клиента. Поле отображается только при редактировании существующего клиента.
Последнее изменение | Дата и время, а также логин, имя и фамилия последнего пользователя, изменившего параметры клиента. Поле отображается только при редактировании существующего клиента.
*Название | Название клиента.
*Уникальный код | Уникальный код клиента, генерируемый автоматически.
*URL клиента | URL-адрес клиента.
Имя хоста | Поле для задания дополнительного названия, облегчает поиск нужного сайта в списке файлов. Доступно только при включённой соответствующей опции в настройках модуля.
*Группа | Указывается группа, к которой принадлежит клиент.
*Логин администратора подключаемого сервера | Логин администратора подключаемого сайта-клиента. Поле отображается только при регистрации нового клиента.
*Пароль администратора подключаемого сервера | Пароль администратора подключаемого сайта-клиента. Поле отображается только при регистрации нового клиента.
Доступность для посещения
Текущий статус | Текущий статус сайта клиента. Поле отображается только при редактировании существующего клиента и изменению не подлежит.
Активен (открыт для доступа посетителям) | Признак активности клиента. Чтобы сайт-клиент был открыт для доступа посетителям, необходимо отметить данную опцию.
Период активности | Указывается период, в течение которого активен клиент.
Дополнительная информация
Контактное лицо | Поле для указания ФИО представителя.
E-Mail адрес | Адрес электронной почты контактного лица.
Описание | Произвольное описание.

* - поля, обязательные для заполнения.

Счетчики

Поле | Описание
В последний раз счетчики были обновлены | Дата и время последнего обновления счетчиков. Ссылка обновить позволяет обновить данные, отображаемые в нижеследующих полях.
Свободное дисковое пространство (в Кб) | Свободное дисковое пространство клиента (в КБ).
Количество сайтов | Количество сайтов клиента.
Количество пользователей | Количество пользователей на клиенте.
Последняя авторизация | Дата и время последней авторизации на клиенте.

Дополнительные поля

На данной закладке отображаются созданные в системе дополнительные пользовательские свойства. К созданию нового пользовательского свойства можно перейти по ссылке Добавить пользовательское свойство.


Управление группами сайтов

Отправить отзыв по этому разделу
Сервисы>Контроллер>Управление группами сайтов

Контроллер::Управление группами сайтов

На странице Управление группами сайтов (Сервисы > Контроллер > Группы) представлена таблица, содержащая список групп сайтов-клиентов. Страница служит для добавления новых групп, а также для перехода к редактированию существующих.

Фильтр

Фильтр используется для задания параметров отбора групп сайтов, отображаемых в списке. Следующая таблица описывает поля фильтра.

Поле | Описание
Название | Поиск группы по названию. Поле присутствует, даже если фильтр свернут.
ID | Поиск группы по идентификатору.
Период изменения | Поиск группы по изменениям за указанный период.
Период создания | Отбор групп, которые были созданы в указанный период.

Чтобы отфильтровать группы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех групп нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Служит для добавления новой группы сайтов.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список групп

Колонка | Описание
Колонка флажков | Поле предназначено для выбора групп сайтов, к которым предполагается применить какое-либо действие.
Меню действий При нажатии на кнопку действий конкретной группы отображается меню, позволяющее:
  • Редактировать - отредактировать группу сайтов;
  • Копировать- создать новую группу, повторяющую настройки выбранной группы.
  • Удалить - удалить группу.
    • Примечание: удаление группы, к которой относится хотя бы один сайт, а также группы, используемой по умолчанию, невозможно.
Название | Название группы.
Дата изменения | Дата и время проведения последней модификации группы.
Кем изменено | Логин, имя и фамилия пользователя, проводившего последнее изменение группы.
Дата создания | Дата и время создания группы сайтов.
Кем создана | Логин, имя и фамилия пользователя, создавшего группу.
Описание | Произвольное описание группы сайтов.
Период обновления счетчиков | Период времени, через которое происходит обновление счетчика.
Обновлять счетчик св. места | Признак обновления счетчика свободного дискового пространства.
Обновлять счетчик сайтов | Признак обновления счетчика количества сайтов.
Обновлять счетчик пользователей | Признак обновления счетчика пользователей.
Обновлять счетчик последней авторизации | Признак обновления счетчика последней авторизации пользователя.
ID | Идентификатор группы.


Создание и редактирование группы сайтов

Отправить отзыв по этому разделу
Сервисы>Контроллер>Создание и редактирование группы сайтов

Контроллер::Создание и редактирование группы сайтов

Закладки

Контекстная панель

Кнопка | Описание
Вернуться к списку | Переход на страницу со списком групп сайтов.
Добавить новую группу | Переход на страницу создания новой группы. Кнопка отображается только при редактировании существующей группы.
Удалить текущую | Удаление группы. Кнопка отображается только при редактировании существующей группы. Примечание: удаление группы, к которой относится хотя бы один сайт, а также группы, используемой по умолчанию, невозможно.

Форма предназначена для создания новых и изменения параметров существующих групп сайтов. Для удобства работы форма разделена на несколько закладок. Каждая закладка содержит логически сгруппированный набор полей для управления параметрами группы.

Параметры

Поле | Описание
ID | Идентификатор группы. Поле отображается только при редактировании существующей группы и изменению не подлежит.
Дата создания | Дата и время, а также логин, имя и фамилия пользователя, создавшего группу. Поле отображается только при редактировании существующей группы.
Последнее изменение | Дата и время, а также логин, имя и фамилия последнего пользователя, изменившего параметры группы. Поле отображается только при редактировании существующей группы.
*Название | Название группы.
Описание | Произвольное описание группы.
Обновление настроек у сайтов данной группы
Период автоматического обновления установок на клиенте, минут (0 - не обновлять автоматически, пусто - использовать значение по умолчанию из настроек модуля) | Указывается интервал (в минутах), через который происходит автоматическое обновление всех настроек клиента. Если указано значение 0, то настройки автоматически обновляться не будут. Если поле оставлено пустым, то будет использовано значение по умолчанию, указанное в настройках модуля.
Обновить настройки у сайтов данной группы сразу после сохранения | При отмеченной опции настройки клиентов данной группы будут обновлены сразу после сохранения (будет выполнена задача Установить групповые настройки). Опция отображается только при редактировании существующей группы.

* - поля, обязательные для заполнения.

Модули

Поле | Описание
Установленные модули | При отмеченной опции станет доступным список модулей. На клиентах группы будут установлены только отмеченные в списке модули, а остальные - деинсталлированы. Если же опция не отмечена, то на клиентах будут установлены все модули. При отсоединении клиента от контроллера его деинсталлированные модули будут проинсталлированы.

Настройки модулей

На вкладке определяются настройки Главного модуля и модуля Управление структурой, которые должны быть установлены на клиентах данной группы. Для применения той или иной настройки на клиенте она должна быть отмечена флагом, в противном случае будет использована собственная настройка клиента.

Поле | Описание
Главный модуль
Автокеширование компонентов | Включение или отключение автокеширования на клиенте.
Режим вывода ошибок (error_reporting) Определяет, какие сообщения об ошибках в работе системы клиентов будут выводиться на экран (обычно используется для отладки):
  • Только ошибки - выводить сообщения только об ошибках;
  • Ошибки и предупреждения - выводить сообщения об ошибках, а также предупреждения о возможности возникновения ошибки;
  • Не выводить - не показывать сообщения об ошибках.
E-Mail адрес или список адресов через запятую на который будут дублироваться все исходящие сообщения | Все почтовые сообщения сайта-клиента будут дублироваться на указанныйв поле e-mail адрес (адреса).
Ограничение дискового пространства (Мб) | При необходимости можно задать ограничение (в Мб) на дисковое пространство.
Регистрация
Позволять ли пользователям регистрироваться самостоятельно | Определяет, могут ли посетители самостоятельно регистрироваться на сайте-клиенте.
Разрешить запоминание авторизации | Определяет, выводить ли флажок Запомнить меня на этом компьютере в форме авторизации.
Использовать CAPTCHA при регистрации | Использовать специальный текст для различия человека и программы при создании запроса на регистрацию в системе клиента.
Использовать Компоненты 2.0 для авторизации и регистрации | При отмеченной опции для авторизации и регистрации будут использованы Компоненты 2.0.
Префикс для авторизации на контроллере | Разрешение на использование и назначение префикса для авторизации.
Авторизовывать на этом сайте пользователей других сайтов контроллера | Переназначение настроек с пользовательских на настройки контролера. Задание разрешения или заперта на авторизацию.
Обновление
Имя сервера, содержащего обновления | Указывается имя сервера, с которого выполняется обновление клиента.
Адрес прокси для системы обновлений | Указывается адрес прокси-сервера, через который выполняется доступ к серверу обновлений.
Порт прокси для системы обновлений | Указывается адрес порта, по которому выполняется доступ к системе обновлений через прокси-сервер.
Имя пользователя прокси | Указывается имя пользователя для доступа к прокси-серверу.
Пароль прокси | Указывается пароль для доступа к прокси-серверу.
Усиленная проверка корректности установки обновлений | Флаг в этом поле позволяет выполнять проверку корректности установки обновлений. При копировании файлов из промежуточной папки /updates/ в папки модулей будет выполняться проверка контрольной суммы. Если полученная контрольная сумма не соответствует исходной, то выводится сообщение о некорректной установке обновлений.
Загружать только стабильные обновления | При отмеченной опции в системе обновлений будут загружаться только стабильные версии. При снятой опции - бета-версии.
Управление структурой
Доступные в виз. редакторе компоненты | Задается перечень компонентов, которые доступны в визуальном редакторе клиентов.

Права доступа

Поле | Описание
Отнимать полный доступ у Администраторов | При отмеченной опции группа Администраторы сайтов-клиентов будет лишена права полный доступ. Группе будут назначены права, указанные в нижеследующем поле.
Права доступа локальных групп на удаленных сайтах | 1. Указывается локальная группа (символьный идентификатор группы), права доступа для которой необходимо настроить. 2. Флагом отмечаются те модули, для которых необходимо настроить права данной группы. Примечание: если будет выбран уровень доступа, который не существует на клиенте, то будет создан. Если на клиенте уже существует уровень с таким же именем (например, уровень А), то он будет обновлен (будет уровень А*). Когда для данного модуля будет назначен другой уровень доступа (например, уровень В), то в список уровней доступа клиента будет возвращен уровень А, а уровень А* с клиента будет удален и добавлен уровень В.

Клик по ссылке Настроить права доступа для еще одной группы... добавляет поля для настройки прав доступа для еще одной локальной группы.

Счетчики

Поле | Описание
Пересчитывать счетчики каждые | Указывается период и единицы измерения периода времени (минут, часов, суток, недель, месяцев) для обновления счетчиков.
Счетчики
Размер свободного дискового пространства | При отмеченной опции будет подсчитываться размер свободного дискового пространства.
Количество сайтов | При отмеченной опции будет использоватся счетчик для подсчета количества сайтов.
Количество пользователей | При отмеченной опции будет использоватся счетчик для подсчета количества пользователей.
Дата последней авторизации | При отмеченной опции будет использоваться счетчик по дате последней авторизации.

Дополнительно

Поле | Описание
Произвольный PHP скрипт для выполнения при установке данной групповой политики | Указывается php-скрипт, который будет выполнен на клиентах группы при установке групповых настроек.
Произвольный PHP скрипт для выполнения при отмене данной групповой политики | Указывается php-скрипт, который будет выполнен на клинтах группы при отмене групповых настроек.

Доп. поля

На закладке имеется ссылка Добавить пользовательское свойство для добавления нового поля для раздела инфоблока. По ссылке осуществляется переход к форме создания нового поля.

Смотрите также

  • Как добавить группу сайтов


Задачи для выполнения на клиентах контроллера сайтов

Отправить отзыв по этому разделу
Сервисы>Контроллер>Задачи для выполнения на клиентах контроллера сайтов

Контроллер::Задачи для выполнения на клиентах контроллера сайтов

Список задач, выполняемых на клиентах контроллера. Могут быть выполнены следующие задачи:

  • установка групповых настроек;
  • обновление сайта;
  • обновление счетчика;
  • выполнение команды;
  • закрытие/открытие клиентов.

Фильтр

Фильтр используется для задания параметров отбора задач, отображаемых в списке.

Поле | Описание
Статус выполнения | Поиск задач по статусам их выполнения: Новая, Выполнена частично, Успешно выполнена или Ошибка выполнения. Возможен множественный выбор статусов. Поле присутствует, даже если фильтр свернут.
ID | Поиск задачи по идентификатору.
Клиент | Название клиента, на котором должны выполниться (выполнялись) задачи.
Операция | Поиск задачи по названию. Если выбрано значение любая, то будут отображены все задачи.
Период выполнения | Отбор задач, с указанным периодом их выполнения.
Период изменения | Отбор задач, с указанным периодом их изменения.
Период создания | Отбор задач, с указанным периодом их создания.

Чтобы отфильтровать задачи по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех задач нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Обновить список | Обновляет список задач.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список задач

Колонка | Описание
Колонка флажков | Выбор задач, к которым предполагается применить какое-либо действие.
Меню действий Доступные действия:
  • Повторить - повторить выполнение задачи.
  • Отменить - удалить задачу из списка.
Клиент | Название клиента, на котором выполнена задача.
Задача | Название задачи.
Состояние | Один из статусов выполнения задачи: Новая, Выполнена частично, Успешно выполнена или Ошибка выполнения.
Выполнено | Дата и время выполнения задачи.
Аргумент | Аргумент задачи. Например, для задачи Выполнить команду в качестве аргумента выступает php-скрипт.
Результат | Указывается результат выполнения задачи или описание ошибки выполнения задачи.
URL клиента | URL-адрес клиента.
Дата изменения | Дата и время изменения задачи.
Дата создания | Дата и время создания задачи.
ID | Идентификатор задачи.

Смотрите также

  • Задачи (учебный курс "Администратор. Модули")


Журнал работы контроллера сайтов

Отправить отзыв по этому разделу
Сервисы>Контроллер>Журнал работы контроллера сайтов

Контроллер::Журнал работы контроллера сайтов

Форма Журнал работы контроллера сайтов отображает все события, связанные с функционированием контроллера и его клиентов.

Фильтр

Фильтр используется для задания параметров отбора записей журнала, отображаемых в списке. Следующая таблица описывает поля фильтра.

Поле | Описание
Название | Название выполненной работы сайтом-контроллером . Данное поле отображается, даже если фильтр свернут.
Статус | Поиск можно задать по успешно выполненной работе или по работе, выполненной с ошибками, или по всем работам на контроллере.
Описание | Описание выполненной работы контроллером.
ID | Поиск по идентификатору записи журнала.
Клиент | Название клиента, на котором выполнялась работа.
ID клиента | Поиск записи работы контроллера по идентификатору контроллера.
Задача | Название задачи, выполняемой на клиентах контроллера.
ID задачи | Идентификатор задачи.
Период создания | Поиск записей журнала по периоду их создания.

Чтобы отфильтровать записи по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех записей нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список записей журнала

Колонка | Описание
Колонка флажков | Выбор записей, к которым предполагается применить какое-либо действие.
Меню действий Доступные действия:
  • Подробно - просмотр в отдельном окне детальной информации о выполнении задачи на клиенте.
  • Удалить - удалить запись журнала.
Дата добавления | Дата добавления записи в журнал (дата выполнения работы).
Название | Название выполненной работы сайтом-контроллером.
Клиент | Указывается название сайта-клиента и его идентификатор, для которого выполнялась работа.
Статус | Статус выполнения работы: успешно или с ошибками.
Задача | Идентификатор и название задачи, выполненной на клиенте.
Пользователь | Логин, имя и фамилия пользователя, выполнившего работу на контроллере.
Описание | Описание выполненной работы или произошедшей ошибки.
ID | Идентификатор записи журнала.

Смотрите также

  • Журнал и история (учебный курс "Администратор. Модули")


Удаленное выполнение команд

Отправить отзыв по этому разделу
Сервисы>Контроллер>Удаленное выполнение команд

Контроллер::Удаленное выполнение команд

Страница Удаленное выполнение команд (Сервисы > Контроллер > Удаленное выполнение команд) служит для задания php-скрипта, который будет выполнен на удаленном сервере.

Фильтр

Поле | Описание
Сайт | Выбирается сайт, на котором будет выполнен скрипт. При выборе значения "все" скрипт будет выполнен на всех сайтах указанной группы. Поле присутствует, даже если фильтр свернут.
Группа | Выбирается группа, на сайте (сайтах) которой должен быть выполнен скрипт.

Закладка "PHP скрипт"

Поле | Описание
[поле типа textarea] | Указывается произвольный php-скрипт, который будет выполнен на удаленном сервере.
Выполнить через планировщик задач | При отмеченной опции команда будет выполнена не сразу, а поставлена в очередь планировщиком задач.

Смотрите также:

  • Удаленное выполнение команд (учебный курс "Администратор. Модули")


Передача файлов

Отправить отзыв по этому разделу
Сервисы>Контроллер>Передача файлов

Контроллер::Передача файлов

Страница Передача файла (Сервисы > Контроллер > Передача файла) служит для передачи файлов на сайты.

Фильтр

Поле | Описание
Сайт | Выбирается сайт, на который будет передан файл. При выборе значения "все" передача будет выполнена на все сайты указанной группы. Поле не видно если фильтр свернут.
Группа | Выбирается группа, на сайт (сайты) которой должен быть передан файл.

Закладка "Файл"

Поле | Описание
Откуда | Указывается путь к файлу на контроллере, который необходимо переслать.
Куда | Для выбранного в фильтре сайта-клиента указывается директория, в которую должен быть отправлен файл.

Смотрите также:

  • Передача файла (учебный курс "Администратор. Модули")


Счетчики

Отправить отзыв по этому разделу
Сервисы>Контроллер>Счетчики

Контроллер::Счетчики

На странице Счетчики (Сервисы > Контроллер > Счетчики) представлен список счетчиков, заведенных в системе.

Счетчик - способ выполнения на удаленных сайтах определённого php-кода в заданный период времени. Параметры счетчика настраиваются на странице редактирования счетчика, параметры запуска - на странице групп сайтов.

Фильтр

Фильтр используется для задания параметров отбора сайтов-клиентов, отображаемых в списке.

Поле | Описание
Группа | Отбор счетчиков, относящихся к указанной группе. Если выбрано значение любая, то будут отображены счетчики, относящиеся ко всем группам.

Чтобы отфильтровать счетчики по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех клиентов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Служит для добавления нового счетчика.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список счётчиков

Колонка | Описание
Колонка флажков | Выбор клиентов, к которым предполагается применить действие.
Меню действий Доступные действия:
  • Редактировать - отредактировать параметры счётчика;
  • Удалить - удаление счётчика.
Название | Название счётчика.
Тип данных | В каком типе данных выводятся данные счетчика.
Формат | Выводятся ли данные в формате файла.
Команда | Код команды.


Создание счетчика

Отправить отзыв по этому разделу
Сервисы>Контроллер>Создание счетчика

Контроллер::Создание счетчика

Форма, размещенная на данной странице, предназначена для регистрации новых счетчиков и редактирования параметров существующих.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком счетчиков.
Новый | Переход на страницу регистрации нового счетчика. Кнопка отображается только при редактировании существующего счетчика.
Удалить | Удаление счетчика. Кнопка отображается только при редактировании существующего счетчика.

Закладка Счетчик

Поле | Описание
*Название | Название счетчика.
*Тип Тип счетчика. Влияет на форму вывода данных. Возможны типы:
  • Целое число. Выводит данные в формате целых чисел.
  • Число. Выводит данные в виде числа с десятичной дробью.
  • Строка. Выводит данные в формате строки.
  • Дата/время. Выводит данные в формате даты, времени в формате сайта.
Формат Позволяет выводить данные в формате размера файла (Например: Мб).

Поле работает только для типов Целое число и Число.
Группы Установка флажка для групп сайтов для которых должен применяться данный счетчик.

Подключение счетчика возможно и на закладке Счетчики на странице редактирования группы.
*Команда | Поле для ввода PHP-кода счетчика.

Закладка Группы

Поле | Описание
Группы | Установка флажка для групп сайтов для которых должен применяться данный счетчик. Подключение счетчика возможно и на закладке Счетчики на странице редактирования группы.

Закладка Команда

Поле | Описание
*Команда | Поле для ввода PHP-кода счетчика.

* - поля, обязательные для заполнения.

Примеры счетчиков

Подсчет пользователей экстранета

$counter = 0;
$rsUsers = CUser::GetList($o="ID", $b="asc", array("ACTIVE"=>"Y","=UF_DEPARTMENT"=>false), array("SELECT"=>array("ID")));
while($arUser = $rsUsers->Fetch())
  if($arUser["EXTERNAL_AUTH_ID"] !== "__controller")
    $counter++;
return $counter;

Выставление лимита в 5GB (Тип - число, формат - как размер файла)

$max_size = 5*1024*1024*1024;
COption::SetOptionString("main_size", "~max_size", $max_size);
return $max_size;

Объем файлов в облаке (Тип - число, формат - как размер файла)

$file_size = 0.0;
if(CModule::IncludeModule('clouds'))
{
  $rsBuckets = CCloudStorageBucket::GetList();
  while($arBucket = $rsBuckets->Fetch())
    $file_size += $arBucket["FILE_SIZE"];
}

COption::SetOptionString("main_size", "~cloud", $file_size);
$params = array("status" => "d", "time" => time());
COption::SetOptionString("main_size", "~cloud_params", serialize($params));

return $file_size;

Смотрите также

  • Счётчики (учебный курс "Администратор. Модули")


Авторизация

Отправить отзыв по этому разделу
Сервисы>Контроллер>Авторизация

Контроллер::Авторизация

Страница Авторизация (Сервисы > Контроллер > Авторизация) позволяет настроить авторизацию [image] пользователей на подчинённых сайтах, между подчинёнными сайтами и на контроллере.

Форма настройки авторизации позволяет настроить вход под единым логином:

  • с контроллера на подчинённый сайт;
  • с одного подчинённого сайта на другой;
  • с подчинённого сайта на контроллер.

Поля формы

Название | Описание
Разрешить авторизацию (конкретное название меняется в зависимости от авторизации) | Устанавливается разрешение на авторизацию между выбранными типами сайтов.
Соответствие групп | Задаётся соответствие группам на домашнем сайте группам на гостевом сайте. Добавление новых строк осуществляется по ссылке Добавить.

Смотрите также:

  • Авторизация (учебный курс "Администратор. Модули")


История изменений на клиенте

Отправить отзыв по этому разделу
Сервисы>Контроллер>История изменений на клиенте

Контроллер::История изменений на клиенте

На странице История сайта представлен список изменений, осуществленных на клиенте. Фиксируются изменения:

  • Группы сайта;
  • Активности (открытости для доступа посетителей) сайта;
  • Наименования сайта (NAME);
  • Активности управления сайтом (ACTIVE). Доступно с версии 20.100.0.

Фильтр

Фильтр используется для задания параметров отбора записей, отображаемых в списке.

Поле | Описание
ID | Поиск клиента по идентификатору. Поле присутствует, даже если фильтр свернут.
Изменённое поле Доступны два параметра фильтрации:
  • Группа сайта;
  • Активность сайта.

Чтобы отфильтровать записи по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех клиентов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Сайт | Возвращение к форме редактирования клиента.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список изменений

Колонка | Описание
Время | Время создания записи.
Изменённое поле | Какое поле было изменено.
Пользователь | Логин, имя и фамилия пользователя, проводившего последнее изменение клиента.
Начальное значение | Начальное значение поля.
Новое значение | Новое значение поля.
Примечание | Примечание по совершенному действию.

Смотрите также

  • Журнал и история сайта (учебный курс "Администратор. Модули")


Менеджер идей. Описание модуля

Сервис Есть идея? позволяет предложить свою идею для развития бизнеса компании, оценить идеи своих коллег. Каждая идея имеет свой рейтинг, который строится на основе мнения сотрудников компании.

Модуль включает в себя следующие компоненты 2.0:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Идеи | bitrix:idea | Комплексный компонент идей
Форма добавления идеи (popup) | bitrix:idea.popup | Форма добавлении идеи во всплывающем окне

Смотрите также:

  • Как пользоваться модулем "Менеджер идей" (учебный курс "Контент-менеджер")
  • Менеджер идей, создание и редактирование статусов (учебный курс "Администратор. Модули")


Опросы, голосования. Описание модуля

Модуль Опросы, голосования позволяет проводить опросы и голосования, которые помогут вам узнать мнение пользователей сайта по различным вопросам.

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Текущий опрос (комплексный компонент) | voting.current | Выводит форму опроса, а после ее заполнения отображает результаты опроса.
Форма опроса | voting.form | Выводит форму опроса.
Список опросов | voting.list | Выводит список опросов.
Результаты опроса | voting.result | Выводит результаты опроса в виде диаграммы.

Смотрите также:

  • Основные понятия
  • Как создать опрос
  • Документация для разработчиков по модулю Опросы, голосования


Опросы, голосования. Настройки модуля

Форма настроек модуля Опросы, голосования (Настройки > Настройки продукта > Настройки модулей > Опросы, голосования) предназначена для задания параметров модуля.

Закладка "Настройки"

Поле | Описание
Использовать HTML редактор | При отмеченной опции при редактировании описания опроса будет использоваться визуальный HTML-редактор.
Поддерживать старые шаблоны (default.php, bluebar.php) в форме редактирования вопросов | При отмеченной опции будут поддерживаться старые шаблоны в форме редактирования вопросов.

Закладка "Доступ"

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Опросы, голосования:
  • [D] закрыт - запрет на доступ;
  • [R] просмотр всех данных модуля - разрешается только просмотр всех данных модуля;
  • [W] запись - полный доступ к ресурсам модуля.


Группы опросов

На странице Группы опросов (Сервисы > Опросы > Группы опросов) представлен список имеющихся в системе групп опросов.

Фильтр

Задание параметров отбора групп опросов, которые отображаются в списке.
Поле | Описание
Заголовок* | Поиск групп опросов по их заголовку. Поле присутствует, даже если фильтр свернут.
ID | Задается идентификатор группы опросов, которую необходимо найти.
Сайты | Указываются сайты, группы опросов которых необходимо найти.
Активна | Поиск активных либо неактивных, либо всех групп.
Символьный идентификатор* | Поиск группы по символьному идентификатору.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы найти группы опросов по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех групп нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Создать | Создание новой группы опросов.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Таблица групп опросов

Поле | Описание
Колонка флажков | Выбор опросов для применения к ним действий при помощи вспомогательной формы Действия внизу таблицы.
Меню действий Доступные действия:
  • Изменить - отредактировать группу;
  • Удалить - удалить группу.
ID | Идентификатор группы опросов в базе.
Дата изм. | Дата изменения записи в базе.
Сайты | Сайты группы опросов.
Акт. | Флаг активности.
Скрыт. | Отмечается является ли группа скрытой или нет.
Сорт. | Порядок сортировки (может быть использован в публичной части при выводе списка групп опросов).
Символьный идентификатор | Символическое имя (используется в публичной части при выводе текущего опроса группы).
Заголовок | Заголовок группы опросов.
Опросов | Количество опросов в данной группе.

Действия над группами опросов

Вспомогательная форма Действия позволяет осуществить различные операции одновременно над несколькими группами. Чтобы применить то или иное действие к группам, следует пометить их галочками в левом столбце таблицы.

Предусмотрены следующие действия:

  • Активировать - переводит выбранные группы опросов в активный статус.
  • Деактивировать - переводит выбранные группы опросов в неактивный статус.


Создание и редактирование группы опросов

Контекстная панель

Кнопка | Описание
Список | Переход на страницу co списком групп опроса.
Создать | Создает новую группу опросов. Кнопка отображается только при редактировании существующей группы опросов.
Удалить | Удаляет текущую группу.
Опросы | Переход на страницу co списком вопросов текущей группы. Кнопка отображается только при редактировании существующей группы опросов.
Создать опрос | Переход к форме создания опроса в текущей группе. Кнопка отображается только при редактировании существующей группы опросов.

Закладка Свойства

Поле | Описание
Дата изменения | Дата изменения записи в базе данных.
Активна | Флаг активности группы опросов.
Разрешить только один текущий опрос в группе | При отмеченной опции в группе опросов может быть только один активный опрос.
Порядок сортировки | Порядок сортировки группы опросов при выводе ее в списке.
Сайты | Сайты, в которых данная группа опросов будет активна.
Символьный идентификатор* | Имя, идентифицирующее данную группу опросов в пределах всех групп опросов данного сайта; может содержать только латинские буквы.
Заголовок* | Заголовок группы опросов.

* - поля, обязательные для заполнения.

Закладка Доступ

Поле Описание
[группа_пользователей] Назначение различных прав доступа к группе опросов для разных групп пользователей:
  • закрыт - недоступны никакие действия;
  • смотреть результаты - позволено просматривать результаты;
  • принять участие - позволено голосовать в опросах и просматривать результаты;
  • изменить опрос - позволено голосовать и просматривать результаты, а также изменить опрос.


Создание и редактирование опроса

Контекстная панель

Кнопка | Описание
Список | Переход на страницу co списоком опросов.
Создать | Создание нового опроса.
Удалить | Удаление текущего опроса. Кнопка отображается только при редактировании существующего опроса.
Обнулить | Удаление всех результатов текущего опроса. Кнопка отображается только при редактировании существующего опроса.
Вопросы | Переход на страницу со списком вопросов текущего опроса. Кнопка отображается только при редактировании существующего опроса.
Создать вопрос | Переход к форме создания нового вопроса для текущего опроса. Кнопка отображается только при редактировании существующего опроса.

Закладка Свойства

Поле | Описание
Дата изменения Дата изменения записи в базе данных.

Поле отображается только при редактировании опроса.
Количество голосов Количество голосований по данному опросу.

Поле отображается только при редактировании опроса.
Активность | Флаг активности опроса.
Оповещать автора опроса о голосе Выбирается способ оповещения о каждом голосовании по данному опросу:
  • Да, с помощью сообщения;
  • Да, с помощью e-mail письма;
  • Нет, не оповещать.
Сортировка | Порядок сортировки опроса при выводе его в списке.
Группа | Группа к которой принадлежит опрос.
Название | Название опроса.
Дата (DD.MM.YYYY HH:MI:SS) | Указывается период, в течении которого опрос будет активным и доступным для голосования.
Путь | Прописывается url опроса относительно корня сайта.
Идентификаторы события
event1 | Идентификатор типа события - event1.
event2 | Идентификатор типа события - event2.
event3 | Дополнительный параметр события - event3.

Закладка Описание

Поле | Описание
Изображение | Вы можете загрузить со своего локального компьютера какое либо изображение в форматах *.bmp, *.jpg, *.jpeg, *.jpe, *.gif или *.png.
Описание Описание опроса в виде:
  • обычного текста (Text);
  • HTML с помощью встроенного в систему HTML - редактора. Доступно на системах с Internet Explorer 5.0, Firefox 1.0 и выше. Необходимо установить флаг Использовать HTML-редактор в настройках модуля Опросы, голосования.

Закладка Ограничения

Поле | Описание
Не голосовать дважды Ограничение пользователей, которые уже, вероятно, приняли участие в опросе.
  • <нет ограничений> - уникальность посетителей никак не отслеживается, каждый посетитель может голосовать по данному опросу неограниченное количество раз.
  • в одной сессии - посетитель не может дважды проголосовать по данному опросу в одной сессии (т.е. пока не перезапустит браузер либо пока не истечет сессия).
  • в одной сессии либо с одним cookie – каждому посетителю в момент голосования единожды выдается свой уникальный номер, который записывается в cookie посетителя; данная опция не позволяет посетителю голосовать дважды по данному опросу в одной сессии, либо с одним уникальным номером из cookie.
  • в одной сессии, либо с одним cookie, либо с одного IP – данная опция не позволит проголосовать посетителю дважды по данному опросу в одной сессии, либо с одним уникальным номером, либо с одного IP-адреса.
  • в одной сессии, либо с одним cookie, либо с одного IP, либо с одним ID пользователя – данная опция не позволит проголосовать посетителю дважды по данному опросу в одной сессии либо с одним уникальным номером, либо с одного IP-адреса, либо по одному ID авторизованного пользователя.
Запретить голосование
  • пользователям, зарегистрированным после даты начала опроса - при отмеченной опции будет запрет участия в опросе для пользователей, которые зарегистрировались после даты его начала.
Не голосовать дважды с одного IP в течение | Если в предыдущем вы выбрали не голосовать дважды в одной сессии, либо с одним cookie, либо с одного IP или не голосовать дважды в одной сессии, либо с одним cookie, либо с одного IP, либо с одним ID пользователя, следует учесть, что пользователи, находящиеся в локальной сети (LAN) какой-либо организации имеют как правило один внешний IP адрес, другими словами если какой – либо пользователь данной LAN уже проголосовал, то больше никто уже не сможет участвовать в данном опросе. Для разрешения такой ситуации вам необходимо задать интервал времени, в течение которого модуль опросов не даст голосовать дважды с одного IP-адреса.

Смотрите также

  • Создание опроса (учебный курс "Контент-менеджер")


Список вопросов

Страница Список вопросов предназначена для просмотра списка вопросов и осуществления различных операций над ними.

Фильтр

Задание параметров отбора вопросов, которые отображаются в списке.
Поле | Описание
Вопрос* | Поиск вопроса по его тексту. Поле присутствует, даже если фильтр свернут.
ID* | Задается идентификатор вопроса, который необходимо найти.
Активен | Поиск только активных либо только неактивных, либо всех вопросов.
Включен в диаграмму | Поиск вопроса по флагу включения в результирующую диаграмму.
Обязательное | Поиск вопроса, ответ на который обязателен для успешного завершения опроса.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы найти вопросы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех вопросов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Создать | Переход к созданию нового вопроса.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список вопросов

Поле | Описание
Колонка флажков | Поле позволяет выбрать вопросы для применения к ним действий при помощи вспомогательной формы Действия внизу таблицы.
Меню действий
  • Доступные действия:
    • Изменить - отредактировать вопрос;
    • Удалить - удалить вопрос.
    • ID | ID вопроса в базе.
    Изменено | Дата изменения записи в базе данных.
    Акт. | Флаг активности вопроса.
    Диагр. | Флаг, определяющий, включен ли вопрос в результирующую диаграмму.
    Обязательное | Указание того, является ли ответ на данный вопрос обязательным.
    Сорт. | Индекс сортировки (положение в списке) вопроса.
    Вопрос | Текст вопроса.

    Действия над вопросами

    Вспомогательная форма Действия позволяет осуществить различные операции одновременно над несколькими вопросами. Чтобы применить то или иное действие к вопросам, следует пометить их галочками в левом столбце таблицы.

    Предусмотрены следующие действия:

    • Активировать - переводит выбранные вопросы в активный статус.
    • Деактивировать - переводит выбранные вопросы в неактивный статус.


Создание и редактирование вопроса

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком вопросов текущего опроса.
Создать | Создание нового вопроса.
Удалить | Удаление текущего вопроса. Кнопка отображается только при редактировании существующего вопроса.

Закладка Вопрос

Поле | Описание
Группа | Группа опросов.
Опрос | Название опроса.
Дата изменения | Дата изменения записи в базе данных. Поле отображается только при редактировании вопроса.
Сколько раз ответили на данный вопрос | Количество ответов на данный вопрос. Поле отображается только при редактировании вопроса.
Активен | Флаг активности вопроса.
Порядок сортировки | Порядок сортировки (вес) вопроса. Чем меньше вес, тем выше в списке будет показан вопрос.
Включить в диаграмму результатов | Флаг включения вопроса в результирующую диаграмму.
Обязательный вопрос | Флаг пометки вопроса как обязательного к ответу.
Вид диаграммы | Указывается вид диаграммы, в виде которой будут представлены результаты ответов на вопрос.
Изображение | Изображение по тематике вопроса для загрузки с локального компьютера в форматах *.jpg, *.bmp, *.jpeg, *.jpe, *.gif или *.png.
Переключатель режима ввода текста | Задается режим ввода текста вопроса: Text, HTML или Визуальный редактор. В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть.

* - поля, обязательное для заполнения.

Закладка Ответы

На закладке задаются варианты ответов на вопрос.

Поле | Описание
ID | ID варианта ответа в базе.
Сообщение | Текстовое сообщение варианта ответа.
Тип поля Тип поля ответа:
  • radio – радио-кнопка, можно выбрать только один вариант ответа из группы ответов с таким типом поля.
  • checkbox – флаг, можно выбрать несколько вариантов ответов.
  • dropdown – элемент с выпадающим списком, можно выбрать только один вариант ответа; все элементы имеющие данные тип поля будут собраны в один выпадающий список.
  • multiselect – список, с возможностью множественного выбора; все элементы имеющие данный тип поля будут собраны в один список.
  • text – однострочное поле ввода, посетитель может заполнить его своим ответом.
  • textarea – многострочное поле ввода, посетитель может заполнить его своим ответом.
Ширина Для различных типов полей имеет различное назначение:
  • radio – не доступно для модификации.
  • checkbox – не доступно для модификации.
  • dropdown – не доступно для модификации.
  • multiselect – не доступно для модификации.
  • text – параметр size тега <input type=”text”>
  • textarea – параметр cols тега <textarea>
Высота Для различных типов полей имеет различное назначение:
  • radio – не доступно для модификации.
  • checkbox – не доступно для модификации.
  • dropdown – не доступно для модификации.
  • multiselect – параметр size тега <select multiple>
  • text – не доступно для модификации.
  • textarea – параметр rows тега <textarea>
Параметры | Дополнительные параметры элемента ввода: стиль, класс. Например, style="width:100%".
Сорт. | Порядок сортировки при выводе в форме опроса и в результирующей диаграмме.
Цвет | Цвет элемента диаграммы (для выбора нажмите на квадрат справа от поля).
Акт. | Флаг активности варианта ответа.
Уд. | Флаг при установке которого вариант ответа будет удален.

Примечание: если вы не хотите заполнять поле Сообщение, то поставьте пробел.

Смотрите также

  • Создание опроса (учебный курс "Контент-менеджер")


Посетители

На странице Посетители (Сервисы > Опросы > Посетители) представлена информация по посетителям сайта, участвовавшим в опросах.

Фильтр

Задание параметров отбора посетителей, которые отображаются в списке.

Поле | Описание
Имя, фамилия* | Поиск посетителей по идентификатору, логину, имени или фамилии пользователя.
ID* | Поиск посетителей по идентификатору пользователей в модуле Опросы.
Дата первого опроса (DD.MM.YYYY) | Интервал для даты, когда посетитель впервые принял участие в опросах.
Дата последнего опроса (DD.MM.YYYY) | Интервал для даты, когда посетитель голосовал последний раз.
ID посетителя в модуле статистики* | Поиск посетителей по идентификатору в модуле Статистика.
IP адрес* | Указывается IP-адрес, для поиска посетителей.
Число голосований | Поиск посетителей по интервалу количества голосований.
Опрос* | Опрос, в котором участвовали посетители.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы найти посетителей по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех посетителей нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список посетителей

Колонка | Описание
Колонка флажков | Выбор посетителей для применения к ним действий при помощи вспомогательной формы внизу таблицы.
Меню действий | Меню, позволяющее удалить запись о посетителе.
ID | Идентификатор посетителя в модуле Опросы.
Первый | Дата первого голосования посетителя.
Последний | Дата последнего голосования посетителя.
Посетитель | Идентификатор, логин, имя и фамилия авторизованного пользователя, а также идентификатор пользователя в модуле Статистика.
IP | IP-адрес, с которого голосовал пользователь.
Голосований | Количество голосований посетителя.


Голосования

На странице Голосования посетителей (Сервисы > Опросы > Голосования) представлена информация по голосованиям посетителей сайта и позволяет просматривать результаты каждого из голосований, устанавливать флаг валидности того или иного голосования. Если у голосования флаг валидности снят, то его результаты не учитываются при построении результирующей диаграммы опроса.

Фильтр

Задание параметров отбора голосований, которые отображаются в списке.

Поле | Описание
ID* | Поиск голосования по его идентификатору. Поле присутствует, даже если фильтр свернут.
ID посетителя* | Поиск голосований по идентификатору посетителя в модуле Опросы.
ID сессии* | Задается идентификатор сессии пользователя для поиска результатов голосований.
IP* | Маска для IP-адреса, с которого голосовал посетитель.
Дата (DD.MM.YYYY)* | Диапазон дат, за которые требуется отобрать голосования.
Опрос* | Идентификатор либо название опроса, результаты голосований которого необходимо найти.
Валидность | Значение флага валидности голосования.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы найти результаты голосований по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех результатов голосований нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Голосования посетителей

Поле | Описание
Колонка флажков | Выбор результатов голосований для применения к ним действий при помощи вспомогательной формы внизу таблицы.
Меню действий | Меню, позволяющее просмотреть либо удалить голосование посетителя.
ID | Идентификатор голосования в базе.
Посетитель | Идентификатор посетителя в модуле Опросы.
Сессия | Идентификатор сессии проголосовавшего посетителя.
IP | IP-адрес, с которого голосовал посетитель.
Дата | Дата и время голосования.
Опрос | Идентификатор и название опроса.
Валидность | Флаг валидности опроса.

Просмотр результата голосования

Просмотр результата голосования подразумевает отображение формы опроса с вариантами ответов, выбранными посетителем в момент голосования. Можно снять либо установить флаг валидности данного голосования.


Список опросов

Список опросов. В каждый опрос может входить один и более вопросов, каждый вопрос содержит в свою очередь варианты ответов разных типов.

Фильтр

Задание параметров отбора опросов, которые отображаются в списке.

Параметр | Описание
Заголовок* | Заголовок опроса. Поле присутствует, даже если фильтр свернут.
ID* | ID группы опросов в базе.
Индикатор | Красный – флаг активности опроса не установлен, либо текущая дата не попадает в интервал проведения опроса. Зеленый – флаг активности установлен и текущая дата попадает в интервал проведения опроса.
Дата начала | Интервал для поля Начало (дата начала проведения опроса).
Дата окончания | Интервал для поля Окончание (дата окончания опроса).
Группа опросов* | Группа, к которой принадлежит опрос.
Флаг активности установлен | Значение флага активности.
Число голосований | Интервал для количества голосований по тому или иному опросу.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Для инициализации фильтра необходимо нажать кнопку Найти. Для отображения всех опросов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Создать | Создание и установка параметров нового опроса.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список опросов

Поле | Описание
Колонка флажков | Выбор опросов для применения к ним действий при помощи вспомогательной формы Действия внизу таблицы.
Меню
действий 		Доступные действия:
  • Изменить - отредактировать запись;
  • Обнулить - удалить все результаты опроса;
  • Форма - посмотреть форму опроса;
  • Результаты - посмотреть результаты опроса;
  • Удалить - удалить запись.
ID | ID опроса в базе.
Инд. Индикатор опроса:
Красный - флаг активности опроса не установлен, либо текущая дата не попадает в интервал проведения опроса;
Зеленый - флаг активности установлен и текущая дата попадает в интервал проведения опроса.
    Начало | Дата начала проведения опроса.
    Окончание | Дата окончания проведения опроса.
    Группа | ID группы, к которой принадлежит опрос.
    Акт. | Флаг активности опроса.
    Сорт. | Порядок сортировки.
    Заголовок | Заголовок опроса.
    Вопросы | Количество вопросов; ссылка на добавление вопроса.
    Голосов. | Количество голосований по данному опросу, ссылка ведет на страницу голосований с предустановленным фильтром.

    Действия над опросами

    Вспомогательная форма Действия позволяет осуществить различные операции одновременно над несколькими опросами. Чтобы применить то или иное действие к опросам, следует пометить их галочками в левом столбце таблицы.

    Предусмотрены следующие действия:

    • Активировать - переводит выбранные опросы в активный статус.
    • Деактивировать - переводит выбранные опросы в неактивный статус.


Обучение. Описание модуля

Описание модуля

Модуль Обучение предназначен для создания обучающих курсов и проведения тестов.

Учебный курс обычно включает следующие элементы: главы, уроки, вопросы, тест для самопроверки и итоговый тест.

Модуль Обучение позволяет:

  • любой урок и/или главу размещать одновременно в разных курсах или главах;
  • создавать составные курсы, т.е. курс может быть включен в курс;
  • импортировать/экспортировать курсы;
  • просматривать результаты в журнале тестирования и список попыток тестирования пользователя;
  • автоматически определять результаты.

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Учебный курс (комплексный компонент) | learning.course | Осуществляет полноценный вывод учебного курса.
Все материалы курса | learning.course.contents | Выводит все материалы курса на одной странице.
Дерево курса | learning.course.tree | Выводит иерархию глав и уроков курса.
Детальный вывод курса | learning.course.detail | С помощью компонента производится детальный вывод курса.
Список курсов | learning.course.list | Выводит список курсов.
Поиск по курсам | learning.search | Выводит поиск по курсам, главам и урокам.
Журнал студента | learning.student.gradebook | Отображает результаты прохождения тестов.
Отчет по курсам | learning.student.certificates | Выводит список пройденных и непройденных курсов текущего пользователя.
Профиль студента | learning.student.profile | Отображает результаты прохождения тестов.
Резюме студента | learning.student.transcript | Отображает информацию о студенте и список полученных им сертификатов.
Контрольный тест | learning.test | Отображает контрольный тест курса.
Самопроверка | learning.test.self | Выводит тест для самопроверки.
Список тестов | learning.test.list | Выводит список активных тестов курса.
Детальный вывод главы | learning.chapter.detail | Производит детальный вывод главы курса.
Детальный вывод урока | learning.lesson.detail | Производит детальный вывод урока курса.

Смотрите также

  • Выполнение операций из публичного раздела (учебный курс "Контент-менеджер")
  • Выполнение операций из административного раздела (учебный курс "Администратор. Модули")
  • Документация для разработчиков по модулю Обучение


Обучение. Настройки модуля

Форма настроек модуля Обучение (Настройки > Настройки продукта > Настройки модулей > Обучение) предназначена для задания параметров модуля.

Закладка Настройки

Поле | Описание
Глобальные настройки модуля обучения
Использовать визуальный редактор | При отмеченной опции для создания/редактирования курсов, глав, уроков, вопросов и тестов будет использоваться визуальный HTML-редактор.
Количество курсов, выводимых в меню | Указывается количество курсов, выводимых в дереве-меню. Если количество курсов на сайте больше, чем указанное число, то для просмотра всего списка нужно воспользоваться пунктом меню Прочие.
Шаблоны путей к публичной части курсов (по сайтам)
[Шаблоны путей для сайта] | Указываются шаблоны путей к публичной части курсов для каждого сайта в системе: Шаблон пути к курсу, Шаблон пути к главе и Шаблон пути к уроку. Примечание: Если файлы публичной части модуля Обучение установлены не в стандартную директорию (learning), необходимо скопировать файл search.php из папки install/public/site/ru модуля в нужную, а также изменить шаблоны путей в настройках модуля.

Закладка Доступ

Поле | Описание
[пользователи и/или группа пользователей] Изменение настроек доступа для конкретного пользователя или группы. Возможно назначение следующих прав доступа к модулю Обучение:
  • Доступ закрыт - доступ к курсу запрещен;
  • Просмотр - разрешается только просмотр курсов;
  • Редактирование/удаление/создание - разрешается только редактирование/удаление/создание курсов и его элементов;
  • Привязывание/отвязывание в качестве потомка - разрешается только привязывание/отвязывание главы или урока в качестве потомка;
  • Привязывание/отвязывание в качестве родителя -разрешается только привязывание/отвязывание главы или урока в качестве родителя;
  • Привязывание/отвязывание - разрешается только привязывание/отвязывание главы или урока как в качестве потомка, так и в качестве родителя;
  • Редактирование/удаление/создание; привязывание/отвязывание в качестве потомка - разрешается редактирование/удаление/создание курсов и его элементов, а также привязывание/отвязывание главы или урока в качестве потомка;
  • Редактирование/удаление/создание; привязывание/отвязывание в качестве родителя -разрешается редактирование/удаление/создание курсов и его элементов, а также привязывание/отвязывание главы или урока в качестве родителя;
  • Редактирование/удаление/создание/привязывание/отвязывание - разрешается редактирование/удаление/создание курсов и его элементов, а также привязывание/отвязывание элементов как в качестве потомка, так и в качестве родителя;
  • Управление правами; редактирование/удаление/создание/привязывание/отвязывание - полный доступ к курсу;
Добавить | Ссылка, позволяющая добавить дополнительное право доступа для конкретного пользователя или группы пользователей.


Список курсов, глав и уроков

Управление учебными курсами, главами и уроками выполняется с помощью следующих страниц административного раздела:

  • список обучающих курсов Сервисы > Обучение > Курсы;
  • список всех имеющихся в системе курсов, глав и уроков Сервисы > Обучение > Список всех уроков;
  • список глав и уроков некоторого курса Сервисы > Обучение > Курсы > название_курса или главы Сервисы > Обучение > Курсы > название_курса > название_главы.

Поскольку все эти страницы имеют одинаковый внешний вид, то дадим единое описание для них.

Фильтр

Задание параметров отбора обучающих курсов, глав или уроков, отображаемых в списке.

Поле | Описание
Название | Отбор учебных курсов, глав или уроков по названию.
ID | Поиск учебного курса, главы или урока по его идентификатору.
Кто создал | Поиск курса, главы или урока по его создателю.
Активен | Отображение всех курсов/глав/уроков или только активных, или только неактивных.
Ключевые слова | Поиск глав и уроков по ключевым словам.
Тип элемента | Указывается по какому типу элемента модуля Обучение: курсу, главе или уроку выполнять поиск.

Чтобы отфильтровать обучающие курсы, главы или уроки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех курсов, глав или уроков нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Все уроки | Переход на страницу Сервисы > Обучение > Список всех уроков, которая содержит список всех имеющихся в системе курсов, глав и уроков. Данная кнопка доступна только при просмотре списка глав и уроков некоторого курса Сервисы > Обучение > название_курса.
На один уровень вверх | Переход в структуре курса на один уровень вверх. Данная кнопка доступна только при просмотре содержимого некоторой главы Сервисы > Обучение > название_курса > название_главы.
Добавить курс | Служит для создания нового учебного курса.
Добавить главу/урок | Служит для создания новой главы или урока.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список курсов, глав и уроков

Колонка | Описание
Колонка флажков | Выбор курсов/глав/уроков, к которым предполагается применить какое-либо действие.
Меню действий Допустимые действия:
  • Изменить - переход к редактированию курса, главы или урока;
  • Список вопросов - переход на страницу списка вопросов;
  • Расформировать - удаление непосредственно курса или главы, а все вложенные при этом курсы, главы и уроки останутся и будут доступны в разделе Сервисы > Обучение > Список всех уроков.
  • Удалить - удалить целиком курс/главу/урок.
Название | Название курса, главы или урока.
ID | Идентификатор курса, главы или урока.
Дата изм. | Дата и время последней модификации курса, главы или урока.
Акт. | Признак активности курса, главы или урока.
Сайты | Сайты, к которому принадлежит курс.
Сорт. | Вес сортировки курса/главы/урока; применяется при выводе в списке курса/главы/урока.
Вложенность | Глубина вложенности курса/главы. Для урока глубина вложенности равна 0.
Всего глав | Общее количество глав в курсе/главе. Символ "+" служит для перехода к созданию новой главы.
Всего уроков | Общее количество уроков в курсе/главе. Символ "+" служит для перехода к созданию нового урока.
Вопросов | Общее количество вопросов в курсе/главе/уроке. Символ "+" служит для перехода к созданию нового вопроса.
Тестов | Общее количество вопросов в курсе. Символ "+" служит для перехода к созданию нового теста.
Включен в | Указывается во что включен курс, глава или урок.
Включает в себя | Перечень курсов/глав/уроков, которые включены в курс/главу.
Символическое имя | Символическое имя курса, главы или урока.
Автор | Логин и имя пользователя, создавшего курс/главу/урок.


Создание и редактирование курса

Закладки

Для создания и редактирования учебного курса применяется форма одного и того же вида. В зависимости от того, создаете вы новый курс или редактируете существующий, некоторые поля могут присутствовать или отсутствовать на форме.

Контекстная панель

Кнопка | Описание
Список | Ссылка для перехода на страницу со списком учебных курсов.
Создать | Ссылка для перехода на страницу создания нового курса. Отображается только на странице редактирования уже существующего курса.
Удалить | Удаление курса, просматриваемого на данной странице. Команда доступна только на странице редактирования уже существующего курса.
Настроить | Настройка внешнего вида формы редактирования курса.

Курс

Настройка основных параметров.
Поле | Описание
ID Порядковый номер записи в модуле.

Поле отображается только в режиме редактирования существующего курса.
COURSE_ID Идентификатор обучающего курса.

Поле отображается только в режиме редактирования существующего курса.
Автор Логин и имя пользователя, создавшего курс.

Поле отображается только в режиме редактирования существующего курса.
Изменена Дата и время создания или изменения курса.

Поле отображается только в режиме редактирования существующего курса.
Запись активна | Признак активности курса. Если это поле отмечено, то курс и его содержимое доступно для показа в публичной части.
Период активности (DD.MM.YYYY) | Указывается период активности курса. Если какое-то из полей оставлено пустым, то граница периода считается неограниченной.
Символическое имя | Произвольное символическое имя курса.
*Сайты | Указываются сайты, на которых данный курс будет активным.
*Название | Название курса.
Индекс сортировки | Вес сортировки курса; применяется при выводе курса в списке.
Включить рейтинг Указывается включать ли вывод рейтинга в курсе:
  • по умолчанию (будет использоваться глобальная настройка рейтингов);
  • да;
  • нет.
Вид кнопок рейтинга Указывается тип кнопки рейтинга в курсе:
  • по умолчанию;
  • Мне нравится (текстовый);
  • Мне нравится (графический);
  • Нравится / Не нравится (текстовый);
  • Нравится / Не нравится (графический).

* - поля, обязательные для заполнения.

Анонс

Создание анонса курса
Поле | Описание
Переключатель режима ввода текста | Задается режим ввода текста краткого описания курса: Text, HTML или Визуальный редактор. В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть на сайте.
Изображение | Поле позволяет в краткое описание курса добавить изображение с помощью кнопки Добавить файл.

Подробно

Создание детального описания курса.
Поле | Описание
Переключатель режима ввода текста | Задается режим ввода текста детального описания курса: Text, HTML или Визуальный редактор. В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть на сайте.

Связи

На вкладке указывается в какой курс включен текущий курс, а также какие элементы привязаны к курсу.

Поле | Описание
Список родительских элементов
[курс] | Идентификатор и название курса, к которому привязан данный курс.
Добавить элемент | Ссылка, позволяющая выбрать курс, к которому необходимо привязать данный курс.
Список дочерних элементов
[глава] | Идентификатор и название главы (или урока), которая содержится в курсе.
Добавить элемент | Ссылка, позволяющая добавить главу или урок в курс.

Права доступа

Поле | Описание
[пользователи и/или группа пользователей] Изменение настроек доступа для конкретного пользователя или группы. Возможно назначение следующих прав доступа к курсу:
  • Доступ закрыт - доступ к курсу запрещен;
  • Просмотр - разрешается только просмотр курсов;
  • Редактирование/удаление/создание - разрешается только редактирование/удаление/создание курсов и его элементов;
  • Привязывание/отвязывание в качестве потомка - разрешается только привязывание/отвязывание главы или урока в качестве потомка;
  • Привязывание/отвязывание в качестве родителя -разрешается только привязывание/отвязывание главы или урока в качестве родителя;
  • Привязывание/отвязывание - разрешается только привязывание/отвязывание главы или урока как в качестве потомка, так и в качестве родителя;
  • Редактирование/удаление/создание; привязывание/отвязывание в качестве потомка - разрешается редактирование/удаление/создание курсов и его элементов, а также привязывание/отвязывание главы или урока в качестве потомка;
  • Редактирование/удаление/создание; привязывание/отвязывание в качестве родителя -разрешается редактирование/удаление/создание курсов и его элементов, а также привязывание/отвязывание главы или урока в качестве родителя;
  • Редактирование/удаление/создание/привязывание/отвязывание - разрешается редактирование/удаление/создание курсов и его элементов, а также привязывание/отвязывание элементов как в качестве потомка, так и в качестве родителя;
  • Управление правами; редактирование/удаление/создание/привязывание/отвязывание - полный доступ к курсу;
Добавить | Ссылка, позволяющая добавить дополнительное право доступа для конкретного пользователя или группы пользователей.

Примечание: для посетителей сайта проверяются только права на курс (если курс доступен посетителю на просмотр, то ему будут также доступны все главы и уроки этого курса, независимо от установленных на них прав).

Смотрите также

Смотрите также:

  • Создание курса (учебный курс "Администратор. Модули")


Создание и редактирование главы/урока

Закладки

Для создания и редактирования глав и уроков учебного курса применяется форма одного и того же вида, поскольку в системе используется следующий принцип: глава считается уроком, пока в нее не будет включен хотя бы один урок. В зависимости от того, создаете вы новый элемент курса или редактируете существующий, некоторые поля могут присутствовать или отсутствовать на форме.

Контекстная панель

Кнопка | Описание
Список | Ссылка для перехода на страницу со списком глав или уроков учебного курса.
Удалить | Удаление главы/урока, просматриваемого на данной странице. Кнопка доступна только на странице редактирования уже существующей главы/урока.
Настроить | Настройка внешнего вида формы редактирования главы/урока в курсе.

Параметры

Поле | Описание
ID | Идентификатор главы или урока. Поле отображается только в режиме редактирования существующей главы или урока.
Изменена | Дата и время создания или изменения главы/урока. Поле отображается только в режиме редактирования существующей главы/урока.
Автор | Логин и имя пользователя, создавшего главу или урок.
Запись активна | Установка статуса активности.
*Название | Название главы или урока.
Символическое имя | Мнемоническое имя главы или урока.
Ключевые слова | Ключевые слова главы или урока. Внимание! Эти ключевые слова предназначены для внутренного поиска в системе, а не для SEO.
Родительский раздел | Указывается родительский раздел, к которому привязана глава/урок.
Индекс сортировки | Вес сортировки главы/урока; применяется при выводе главы/урока в списке.
Не публиковать | Опция позволяет снять главу/урок с публикации в курсе.

* - поля, обязательные для заполнения.

Анонс

Поле | Описание
Переключатель режима ввода текста | Задается режим ввода текста описания главы/урока: Text, HTML или Визуальный редактор. В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть.
Изображение | Поле позволяет в краткое описание главы/урока добавить изображение с помощью кнопки Добавить файл.

Содержание

Поле | Описание
Источник содержимого урока | Выбирается источник для добавления содержимого главы/урока: текстовое поле или файл.
Переключатель режима ввода текста (если выбрано текстовое поле) | Задается режим ввода текста детального описания главы/урока: Text, HTML или Визуальный редактор. В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть.
Путь к файлу (если в качестве источника выбран файл) | Указывается путь к файлу с содержимым главы/урока. Файл должен быть в формате pdf, html, text, jpg или png.
Изображение | Поле позволяет в детальное описание главы/урока добавить изображение с помощью кнопки Добавить файл.

Связи

На вкладке указывается список дочерних и родительских элементов главы/урока, а также в какой курс включена текущая глава/урок.

Закладка доступна только в режиме редактирования существующей главы/урока.

Поле | Описание
Список родительских элементов
[курс/глава] | Идентификатор и название курса/главы, к которой привязана данная глава или урок.
Добавить элемент | Ссылка, позволяющая выбрать курс/главу, к которой необходимо привязать данную главу/урок.
Список дочерних элементов
[глава/урок] | Идентификатор и название главы/урока, который содержится в главе.
Добавить элемент | Ссылка, позволяющая добавить главу или урок в главу.

Права доступа

Закладка доступна только в режиме редактирования существующей главы/урока.

Поле | Описание
[пользователи и/или группа пользователей] Изменение настроек доступа для конкретного пользователя или группы. Возможно назначение следующих прав доступа к главе/уроку:
  • Доступ закрыт - доступ к главе/уроку запрещен;
  • Просмотр - разрешается только просмотр главы/урока;
  • Редактирование/удаление/создание - разрешается только редактирование/удаление/создание элементов курса;
  • Привязывание/отвязывание в качестве потомка - разрешается только привязывание/отвязывание главы или урока в качестве потомка;
  • Привязывание/отвязывание в качестве родителя -разрешается только привязывание/отвязывание главы или урока в качестве родителя;
  • Привязывание/отвязывание - разрешается только привязывание/отвязывание главы или урока как в качестве потомка, так и в качестве родителя;
  • Редактирование/удаление/создание; привязывание/отвязывание в качестве потомка - разрешается редактирование/удаление/создание элементов курса, а также привязывание/отвязывание главы или урока в качестве потомка;
  • Редактирование/удаление/создание; привязывание/отвязывание в качестве родителя -разрешается редактирование/удаление/создание элементов курса, а также привязывание/отвязывание главы или урока в качестве родителя;
  • Редактирование/удаление/создание/привязывание/отвязывание - разрешается редактирование/удаление/создание элементов курса, а также привязывание/отвязывание элементов как в качестве потомка, так и в качестве родителя;
  • Управление правами; редактирование/удаление/создание/привязывание/отвязывание - полный доступ к главе/уроку;
Добавить | Ссылка, позволяющая добавить дополнительное право доступа для конкретного пользователя или группы пользователей.

Примечание: для посетителей сайта проверяются только права на курс (если курс доступен посетителю на просмотр, то ему будут также доступны все главы и уроки этого курса, независимо от установленных на них прав).

Доп. поля

На данной закладке отображаются созданные в системе дополнительные пользовательские поля для глав и уроков модуля Обучение. К созданию нового пользовательского поля можно перейти по ссылке Добавить пользовательское поле.

Кнопки управления

Кнопка | Описание
Сохранить | Сохранение внесённых изменений. Возврат к списку глав или уроков курса.
Применить | Сохранение внесённых изменений. Продолжение редактирования параметров главы/урока.
Отменить | Отмена внесённых изменений. Возврат к списку глав или уроков курса.

Смотрите также

  • Создание глав и уроков


Вопросы тестов

Список вопросов для выбранного учебного курса (Сервисы > Обучение > Курсы > имя_курса > Вопросы).

Фильтр

Задание параметров отбора вопросов, отображаемых в списке.

Поле | Описание
Название* | Отбор вопросов по названию. Поле присутствует, даже если фильтр свернут.
Урок | Указывается урок, к которому относится вопрос, либо выбирается значение любой для отображения вопросов всех уроков.
Глава | Указывается глава, к которой относится вопрос, либо выбирается значение любая для отображения вопросов всех глав.
Для самопроверки | Отображение всех вопросов или только вопросов для самопроверки, или только вопросов не для самопроверки.
Активность | Отображение всех вопросов или только активных, или только неактивных.
Обязателен правильный ответ | Отображение всех ответов или только правильных, или только неправильных.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отфильтровать вопросы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех вопросов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить вопрос | Служит для перехода к форме создания нового вопроса.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список вопросов

Колонка | Описание
Колонка флажков | Выбор вопросов, к которым предполагается применить какое-либо действие.
Меню действий доступные действия:
  • Изменить - отредактировать вопрос;
  • Удалить - удалить вопрос.
ID | Идентификатор вопроса.
Акт. | Признак активности вопроса.
Дата изм. | Дата и время последней модификации вопроса.
Название | Текст самого вопроса.
Сорт. | Вес сортировки вопроса; применяется при выводе вопроса.
Самопров. | Принадлежность вопроса: для самопроверки или не для самопроверки.
Об. прав. | Обязателен правильный ответ.
Тип | Указывается тип вопроса: одиночный или множественный выбор вариантов ответа.
Балл | Указывается балл, начисляемый за правильный ответ.
Кол-во ответов (правильных/всего) | Указывается количество правильных из всех ответов. Ссылки на количествах ведут на страницы результатов теста с фильтром на соответствующие ответы.


Создание и редактирование вопроса

Закладки

Для создания и редактирования вопросов курса применяется форма одного и того же вида. В зависимости от того, создаете вы новый вопрос или редактируете существующий, некоторые поля могут присутствовать или отсутствовать на форме.

Контекстная панель

Кнопка | Описание
Список | Ссылка для перехода на страницу со списком вопросов.
Создать | Ссылка для перехода на страницу создания нового вопроса. Отображается только на странице редактирования уже существующего вопроса.
Удалить | Удаление вопроса, просматриваемого на данной странице. Команда доступна только на странице редактирования уже существующего вопроса.
Настроить | Настройка внешнего вида формы редактирования вопроса в курсе.

Вопрос

Поле | Описание
ID Идентификатор вопроса.

Поле отображается только в режиме редактирования существующего вопроса.
Изменена Дата и время создания или изменения вопроса.

Поле отображается только в режиме редактирования существующего вопроса.
Запись активна | Признак активности вопроса. Если это поле отмечено, то вопрос доступен для показа в публичной части.
Тип вопроса Выбор типа вопроса:
  • одиночный выбор - только один вариант ответа;
  • множественный выбор - возможен несколько вариантов ответа;
  • сортировка - необходимо расставить ответы в каком-либо порядке;
  • текстовый ответ - возможен только текстовый ответ, набираемый отвечающим на вопрос пользователем (поле для ввода текста появится на месте ответов).
Урок Урок, к которому относится вопрос.

Для выбора другого урока, к которому должен быть привязан вопрос, служит ссылка сменить. Откроется окно со списком глав и уроков курса: для выбора необходимого урока (или главы) кликнете по нему.
*Название | Текст самого вопроса.
Индекс сортировки | Вес сортировки вопроса; применяется при выводе вопроса.
Балл | Количество баллов, которые зачисляются пользователю в случае верного ответа на данный вопрос.
Для самопроверки Признак принадлежности вопроса: для самопроверки или нет.

Опция доступна, только если выбран тип вопроса - одиночный выбор, множественный выбор, сортировка.
Обязателен правильный ответ | При отмеченной опции если на данный вопрос не будет дан правильный ответ, то тест не будет сдан при любом набранном количестве баллов.
Сообщение при неправильном ответе | Указывается сообщение при неправильном ответе на вопрос во время прохождения теста. Сообщение будет выводится при включенной опции Показывать ошибки (Сервисы > Обучение > Курсы > имя_курса > Тесты) закладки "Настройки".
Уведомлять преподавателя об ответе При отмеченной опции преподавателю (пользователю, создавшему урок) отправляется письмо с ответом ученика.
Примечание: при необходимости можно добавить получателей, которым будет отправляться данное письмо. Оно отправляется по событию NEW_LEARNING_TEXT_ANSWER (Настройки > Настройки продукта > Почтовые события > Типы почтовых событий).

Опция доступна, только если выбран тип вопроса - текстовый ответ.
Заметка | Произвольный комментарий к вопросу, не видим для пользователя, отвечающего на вопрос.
Изображение | К тексту вопроса можно добавить изображение с помощью кнопки Добавить файл.

* - поля, обязательные для заполнения.

Ответы

Задание вариантов ответов на вопрос.

Поле | Описание
ID | Идентификатор вопроса. Это поле заполнено только в режиме редактирования вопроса.
Прав. | С помощью данного поля необходимо отметить один или несколько верных вариантов ответа в зависимости от типа вопроса.
Ответ | Текст ответа на вопрос.
Сорт. | Порядок вывода ответов в вопросе при выключенной опции Случайный порядок ответов в данном Тесте.
Удал. | Удаление вариантов ответа возможно только в режиме редактирования. Для этого необходимо отметить флаг тот вариант ответа, который вы хотите удалить.

Описание

Создание детального описания вопроса, которое может содержать как текст, так и изображения.

Поле | Описание
Переключатель режима ввода текста | Задается режим ввода текста вопроса: Text, HTML или Визуальный редактор. В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть.

Доп. поля

На данной закладке отображаются созданные в системе дополнительные пользовательские поля для вопросов модуля Обучение. К созданию нового пользовательского поля можно перейти по ссылке Добавить пользовательское поле.

Смотрите также

  • Создание вопросов (учебный курс "Администратор. Модули")


Тесты

На странице (Сервисы > Обучение > Курсы > имя_курса > Тесты) представлена информация в виде таблицы о тестах курса.

Фильтр

Фильтр используется для задания параметров отбора тестов, отображаемых в списке.

Поле | Описание
Название* | Отбор тестов с определённым названием.Поле присутствует, даже если фильтр свернут.
Активен | Отображение всех тестов или только активных, или только неактивных.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отфильтровать тесты по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех тестов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить тест | Служит для перехода к форме создания нового теста.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список тестов

Колонка | Описание
Колонка флажков | Выбор тестов, к которым предполагается применить какое-либо действие.
Меню действий Допустимые действия:
  • Изменить - отредактировать тест;
  • Удалить - удалить тест.
ID | Идентификатор теста.
Дата изм. | Дата и время последней модификации теста.
Название | Название теста.
Сорт. | Вес сортировки теста; применяется при выводе теста в списке.
Акт. | Признак активности теста.
Кол-во попыток (успешных/всего) | Указывается количество успешных из всех попыток. Ссылки на количествах ведут на страницы попыток с фильтром на соответствующие попытки.


Создание и редактирование теста

Закладки

Для создания и редактирования тестов курса применяется форма одного и того же вида. В зависимости от того, создаете вы новый тест или редактируете существующий, некоторые поля могут присутствовать или отсутствовать на форме.

Контекстная панель

Кнопка | Описание
Список | Ссылка для перехода на страницу со списком тестов.
Создать | Ссылка для перехода на страницу создания нового теста. Отображается только на странице редактирования уже существующего теста.
Удалить | Удаление просматриваемого теста. Команда доступна только на странице редактирования уже существующего теста.
Настроить | Настройка внешнего вида формы редактирования теста в курсе.

Тест

Поле | Описание
ID Идентификатор теста.

Поле отображается только в режиме редактирования существующего теста.
Изменена Дата и время создания или изменения теста.

Поле отображается только в режиме редактирования существующего теста.
Запись активна | Признак активности теста. Если это поле отмечено, то тест и его содержимое доступно для показа в публичной части.
*Название | Название теста.
Индекс сортировки | Вес сортировки теста; применяется при выводе теста в списке.
В тесте участвуют Количество вопросов, участвующих в тесте:
  • все вопросы курса;
  • либо все вопросы главы - выбирается нужная глава курса;
  • либо все вопросы урока - выбирается нужный урок из курса;
  • либо указанное количество вопросов со всего курса;
  • либо указанное количество вопросов из каждой главы;
  • или же указанное количество вопросов из каждого урока;
Включать вопросы для самопроверки | При отмеченной опции в тест будут включены вопросы для самопроверки.
Случайный порядок вопросов | Возможность вывода вопросов в случайном порядке.
Случайный порядок ответов | Возможность вывода вариантов ответов на вопрос в случайном порядке.
Количество попыток | Задается количество попыток прохождения теста. Если указано 0 или строка пуста, то количество попыток неограничено.
Минимальное время между попытками | Задается минимальное время в днях, часах, минутах между попытками прохождения теста. Если указано 0 или строка пуста, то паузы между попытками нет.
Ограничение времени | Задается количество минут для прохождения теста. Если указано 0 или строка пуста, то прохождение теста во времени не ограничено.
Автоматическая проверка результатов | Если данная опция отмечена, то результаты тестирования будут проверены автоматически.
Для прохождения теста необходимо правильно ответить на | Задается процент вопросов, на которые необходимо правильно ответить для прохождения теста.
Тип прохождения теста Выбирается один из трех возможных типов прохождения теста:
  • Запретить переход к следующему вопросу без ответа на текущий вопрос, пользователь не может изменять свои ответы.
  • Разрешить переход к следующему вопросу без ответа на текущий вопрос, пользователь не может изменять свои ответы.
  • Разрешить переход к следующему вопросу без ответа на текущий вопрос, пользователь может изменять свои ответы.
Запретить доступ к тесту без сдачи теста | Указывается тест, который необходимо сдать, а также указывается процент сдачи теста от общего количества баллов, чтобы перейти к сдаче текущего теста.
Для доступа к тесту необходимо правильно ответить на | Задается процент правильных ответов для прохождения предыдущего теста, чтобы иметь доступ к сдаче текущего теста.
Контроль неправильных ответов | При отмеченной опции тест будет досрочно прерван при критическом уровне ошибочных ответов на вопросы теста.
Показывать текущие результаты При отмеченной опции во время теста будут показываться текущие показатели:
  • показывать процент правильных ответов - количество правильных ответов в процентах;
  • показывать текущую оценку - оценка, формат которой настраивается на закладке "Оценки".
Показывать окончательные результаты При отмеченной опции по завершении будет выведены выбранные ниже результаты сдачи теста:
  • показывать количество правильных ответов
  • показывать количество набранных баллов
  • показывать итоговую оценку
  • показывать сообщение соответствующее оценке.
Показывать ошибки При отмеченной опции и неправильном ответе будет выведено уведомление, указанное в поле Сообщение при неправильном ответе (Сервисы > Обучение > Курсы > имя_курса > Вопросы) закладки "Вопрос", также будет выполнено действие (если выбрано в Тип прохождения теста - Разрешить переход к следующему вопросу без ответа на текущий вопрос, пользователь может изменять свои ответы):
  • переходить к следующему вопросу;
  • оставаться на предыдущем вопросе.

* - поля, обязательные для заполнения.

Описание

Поле | Описание
Переключатель режима ввода текста | Задается режим ввода текста описания теста: Text, HTML или Визуальный редактор. В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть на сайте.

Оценки

Поле | Описание
ID | Отображается идентификатор оценки. Присваивается автоматически при сохранении оценки.
Количество правильных ответов | Указывается количество правильных ответов для присвоения оценки.
Оценка | Задается оценка, соответствующая Количеству правильных ответов.
Сообщение | Задается сообщение, соответствующее Количеству правильных ответов.
Удалить | Выбор оценки для удаления.

Смотрите также

  • Тесты (учебный курс "Администратор. Модули")


Сертификация

На странице Сертификация (Сервисы > Обучение > Сертификация) представлена информация о пользователях, получивших сертификаты. Сертификат выдается пользователю после успешного тестирования. На страницу попадают только пользователи успешно прошедшие все тесты определенного учебного курса.

Фильтр

Задание параметров отбора сертификатов, отображаемых в списке.

Поле | Описание
Учащийся | Отбор сертификатов, выданных указанному учащемуся. Поле присутствует, даже если фильтр свернут.
ID | Идентификатор сертификата.
Курс | Выбирается курс, по которому выданы сертификаты. Если указано значение любой, то отображаются сертификаты по всем курсам.
Активен | Отображение всех сертификатов или только активных, или только неактивных.
Баллов | Указывается интервал количества баллов, которые заработали учащиеся. Если какое-то из полей оставлено пустым (или оба), то граница считается неограниченной.
Сертифицировался Online | Отображение всех сертификатов или только тех, которые получили пользователи Onine, либо только тех, которые получили пользователи Offline.

Чтобы отфильтровать сертификаты по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех сертификатов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список сертификатов

Колонка | Описание
Колонка флажков | Выбор сертификатов, к которым предполагается применить какое-либо действие.
Меню действий Доступные действия:
  • Удалить - удалить сертификат.
ID | Идентификатор сертификата.
Дата изм. | Дата и время получения сертификата.
Курс | Название курса, по которому получен данный сертификат.
Учащийся | Указывается идентификатор, логин, имя и фамилия пользователя.
Баллов | Количество заработанных баллов.
Макс. баллов | Максимальное количество баллов.
Акт. | Признак активности сертификата.
Сорт. Вес сортировки сертификата. Равен весу сортировка курса, за который получен данный сертификат.
Вес определяет положение сертификата в списке, чем меньше вес, тем выше в списке располагается сертификат.
Сертифицировался он-лайн | Отметка о том, что учащийся сертифицировался Online или нет.


Журнал результатов

На странице Результаты обучения (Сервисы > Обучение > Журнал) представлена информация о результатах обучения пользователей.

Фильтр

Задание параметров отбора результатов, отображаемых в списке.

Поле | Описание
Учащийся | Отбор результатов прохождения тестов указанного учащегося. Данное поле отображается, даже если фильтр свернут.
ID | Идентификатор результата.
Тест | Выбор теста, по которому имеются результаты о его прохождении. Если указано значение любой, то отображаются результаты по всем тестам.
Пройден | Отображение всех результатов или только результатов по успешному прохождению тестов, или только результатов по неудачно пройденным тестам.
Баллов | Указывается интервал количества баллов, которые заработали учащиеся в ходе прохождения тестирования. Если какое-то из полей оставлено пустым (или оба), то граница считается неограниченной.

Чтобы отфильтровать результаты по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех результатов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список результатов обучения

Колонка | Описание
Колонка флажков | Выбор результатов, к которым предполагается применить какое-либо действие.
Меню действий Доступные действия:
  • Удалить - удалить результат.
ID | Идентификатор результата.
Тест | Название теста, по которому получен данный результат.
Учащийся | Указывается идентификатор, логин, имя и фамилия пользователя.
Баллов | Количество баллов, которые заработал учащийся во время прохождения тестирования.
Макс. баллов | Максимальное количество баллов, которое можно заработать во время прохождения теста.
Попыток | Количество попыток прохождения теста.
Пройден | Указывается удачно пройден тест или нет.
Доп. попытки | Указывается количество дополнительных попыток сдачи теста.


Список попыток

На странице Список попыток (Сервисы > Обучение > Попытки) представлена информация о попытках прохождения учащимися тестирования.

Фильтр

Задание параметров отбора попыток, отображаемых в списке.

Поле | Описание
Учащийся | Отбор попыток прохождения тестов указанного учащегося. Поле присутствует, даже если фильтр свернут.
ID | Идентификатор попытки.
Тест | Выбор теста, по которому необходимо отобразить попытки о прохождении. Если указано значение любой, то отображаются попытки по всем тестам.
Дата начала | Указывается период начала тестирования. Если какое-то из полей оставлено пустым (или оба), то временная граница считается неограниченной.
Дата конца | Указывается период окончания тестирования. Если какое-то из полей оставлено пустым (или оба), то временная граница считается неограниченной.
Тест пройден | Отображение всех попыток или только успешных попыток, или только неудачных попыток.
Статус | Выбирается один или несколько статусов попытки прохождения тестирования.
Баллов | Указывается интервал количества баллов, которые заработали учащиеся в ходе прохождения тестирования. Если какое-то из полей оставлено пустым (или оба), то граница считается неограниченной.

Чтобы отфильтровать попытки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех попыток нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список попыток

Колонка | Описание
Колонка флажков | Выбор попыток, к которым предполагается применить какое-либо действие.
Меню действий Доступные действия:
  • Результаты - переход к форме с подробным описанием результатов прохождения теста этой попытки;
  • Удалить - удалить попытку.
ID | Идентификатор попытки.
Учащийся | Указывается идентификатор, логин, имя и фамилия пользователя.
Тест | Название теста, который учащийся пытается пройти или уже прошел.
Дата начала | Дата и время начала тестирования.
Дата конца | Дата и время окончания тестирования. Если тестирование ещё не закончено, то данное поле пусто.
Статус | Статус, в котором находится процесс тестирования.
Вопросов | Количество вопросов в тесте.
Тест пройден | Указывается удачно пройден тест или нет.
Баллов | Количество баллов, которые заработал учащийся во время прохождения тестирования.
Макс. баллов | Максимальное количество баллов, которое можно заработать во время прохождения теста.
Среднее время ответов | Среднее время затраченное пользователем на каждый ответ в тесте.


Результаты теста

Подробное описание результатов прохождения определённого теста определенным учащимся (на странице со списком попыток необходимо выбрать конкретную попытку прохождения теста определенным пользователем).

Фильтр

Фильтр используется для задания параметров отбора результатов попытки, отображаемых в списке. Следующая таблица описывает поля фильтра.

Поле | Описание
Вопрос | Отбор результатов с определённым текстом вопроса. Данное поле отображается, даже если фильтр свернут.
ID | Идентификатор результата ответа на вопрос.
Отвечен | Отображение всех результатов ответов на вопросы или только тех результатов, для которых был дан ответ на вопрос, либо только тех результатов, для которых не был дан ответ на вопрос.
Верно отвечен | Отображение всех результатов ответов на вопросы или только положительных результатов (ответ верен), или только отрицательных (ответ неверен).

Чтобы отфильтровать результаты ответов по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех результатов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорти данных из отображаемой таблицы в MS Excel.

Список результатов

Колонка | Описание
Колонка флажков | Выбор результатов, к которым предполагается применить какое-либо действие.
Меню действий Доступные действия:
  • Изменить - осуществляется переход на страницу редактирования результата;
  • Удалить - удалить результат.
ID | Идентификатор результата.
Вопрос | Текст вопроса.
Отвечен | Отметка о том, был ли дан ответ на вопрос.
Верно отвечен | Признак правильности ответа на вопрос.
Баллов | Количество баллов, заработанных при ответе на вопрос.
Ответ пользователя | Указывается какой ответ дал пользователь на вопрос.
Обязателен правильный ответ | Да, если вопрос имеет такой статус и Нет, если не имеет.


Редактирование результата

Переход на эту страницу выполняется при выборе команды Изменить в Меню действий результата теста.

Форма редактирования

Поле | Описание
Учащийся | Логин, имя и фамилия пользователя.
Отвечен | Опция определяет дан ответ на вопрос или нет.
Правильно отвечен | Опция определяет верный дан ответ на вопрос или нет.
Баллов | Количество баллов за ответ на вопрос.
Вопрос | Текст вопроса. Ссылка на редактирование вопроса.
Ответ | Ответ, предложенный учащимся на вопрос теста.


Учебные группы

На странице Список учебных групп (Сервисы > Обучение > Учебные группы) представлена информация об учебных группах.

Фильтр

Задание параметров отбора учебных групп, отображаемых в списке.

Поле | Описание
Название | Отбор учебных групп по названию.
ID | Поиск учебной группы по ее идентификатору.
Акт. | Отображение всех учебных групп или только активных, или только неактивных.
Символическое имя | Поиск группы по ее символическому имени.
Курс | Поиск учебных групп по курсу, для которого они были созданы.
ID курса | Поиск учебных групп по индентификатору курса, для которого они были созданы.
Сорт. | Отбор учебных групп по индексу сортировки.
Начало активности | Отбор учебных групп по периоду начала их активности.
Окончание активности | Отбор учебных групп по периоду окончания их активности.

Чтобы отфильтровать учебные группы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех учебных групп нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания новой учебной группы.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список учебных групп

Колонка | Описание
Колонка флажков | Выбор учебных групп, к которым предполагается применить какое-либо действие.
Меню действий Допустимые действия:
  • Изменить - переход к редактированию учебной группы;
  • Удалить - удаление учебной группы.
ID | Идентификатор учебной группы.
Акт. | Признак активности учебной группы.
Название | Название учебной группы.
Символическое имя | Символическое имя учебной группы.
Сорт. | Вес сортировки учебной группы; применяется при выводе в списке учебных групп.
Начало активности | Дата и время начала работы учебной группы. Именно с этого момента участникам учебной группы становятся доступны для изучения материалы курса.
Окончание активности | Дата и время окончания работы учебной группы. С этого момента становятся недоступными материалы учебного курса.
ID курса | Идентификатор курса, по которому проводится обучение учебной группы.
Курс | Название курса, по которому проводится обучение учебной группы.


Создание и редактирование учебной группы

Для создания и редактирования учебной группы применяется форма одного и того же вида. В зависимости от того, создаете вы новую группу или редактируете существующую, некоторые поля могут присутствовать или отсутствовать на форме.

Контекстная панель

Кнопка | Описание
Список | Ссылка для перехода на страницу со списком учебных групп.
Настроить | Настройка внешнего вида формы редактирования учебной группы.

Поля формы

Закладка Учебная группа

Поле | Описание
Название | Название учебной группы.
Символическое имя | Символическое имя учебной группы.
Курс | Учебный курс для обучения участников учебной группы.
Период активности | Начало и окончание активности учебной группы.
Запись активна | Признак активности учебной группы. Если опция отмечена, то в период активности группы ее участникам будут доступны для изучения материалы курса.
Индекс сортировки | Вес сортировки группы.
График открытия разделов*
Задержка перед открытием (в днях) | Для каждой главы/урока верхнего уровня указывается через сколько дней после начала активности группы она/он станет доступной/доступным.
Членство в группе
Состав учебной группы | Выбираются пользователи-участники учебной группы.

* - данная секция доступна только при редактировании учебной группы.

Закладка Доп. свойства

На данной закладке отображаются созданные в системе дополнительные пользовательские поля для учебных групп. К созданию нового пользовательского поля можно перейти по ссылке Добавить пользовательское поле.


Экспорт курса

Форма Экспорт курса (Сервисы > Обучение > Экспорт) служит для выгрузки имеющегося учебного курса.

Шаг 1. Закладка "Курс"

Поле | Описание
Курсы | Выбор курса, который необходимо выгрузить.

Для перехода к следующему шагу нажмите кнопку Далее >>.

Шаг 2. Закладка "Параметры экспорта"

Поле | Описание
Имя файла данных (относительно корня сайта) | Указывается имя файла данных относительно корня сайта. Сохраняемый файл должен быть следующего формата: <имя_файла>.tar.gz Если такой файл существует, то он будет перезаписан.

Для перехода к следующему шагу нажмите Начать выгрузку >>, а для возврата на первый шаг - кнопку << Назад.

Шаг 3. Закладка "Результат"

Выводится сообщение о завершении выгрузки и ссылка для скачивания архива курса.

Для повтора экспорта воспользуйтесь кнопкой << Вернуться на первый шаг, при нажатии на которую будет открыта вкладка Курс.

Смотрите также:

  • Экспорт\импорт курсов (учебный курс "Администратор. Модули")


Импорт курса

Форма Импорт курса (Сервисы > Обучение > Импорт) служит для загрузки учебного курса на сайт.

Вкладка "Файл данных " - 1 шаг

Поле | Описание
*Файл данных | С помощью кнопки Открыть в поле указывается имя и путь к загружаемому файлу данных.
*Сайт | Выбор сайтов, на которые необходимо загрузить учебный курс.
SCORM | Указывается, что импортируемый курс выполнен в стандарте SCORM (Sharable Content Object Reference Model), разработанном для систем дистанционного обучения.
* - поля, обязательные для заполнения.

Для загрузки курса нажмите кнопку Загрузить данные >> , после чего будет осуществлен переход на вкладку Результат.

Вкладка "Результат" - 2 шаг

Вывод сообщение о завершении импорта.

Для повтора импорта воспользуйтесь кнопкой << Назад, откроется вкладка Файл данных.

Смотрите также:

  • Экспорт\импорт курсов (учебный курс "Администратор. Модули")


Подписка, рассылки. Описание модуля

Описание модуля

Примечание: В продуктах 1С-Битрикс, начиная с версии 15.0.1, появился новый модуль E-mail маркетинг c более продвинутыми функциями организации рассылок сайта.

Модуль Подписка, рассылки предназначен для создания рассылок почтовых сообщений. Почтовые рассылки отсылаются группам зарегистрированных подписчиков или пользователей сайта. При помощи почтовых рассылок вы можете снабжать посетителей сайта информацией касательно деятельности вашей компании. Например, подписчики могут получать по электронной почте:

  • общие новости;
  • пресс-релизы вашей компании;
  • сообщения об обновлениях на сайте;
  • информацию о новых товарах и услугах;
  • анонсы публикаций;
  • другую информацию.

Термины

При работе с модулем рассылок используются следующие понятия:

  • Рассылки - тематические рубрики, на которые могут подписаться посетители сайта. Возможна одновременная подписка на несколько рассылок.
  • Подписчики - посетители сайта, подписавшиеся на рассылки. Подписчики могут быть как зарегистрированными пользователями, так и анонимными. Анонимными подписчиками признаются подписчики, не зарегистрированные на сайте.
  • Выпуски - почтовые сообщения, рассылаемые подписчикам. Выпуск может быть направлен:
    • подписчикам на определённые рассылки;
    • пользователям определённых групп прав;
    • на произвольные адреса.

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Список новостей | subscribe.news | Служит для выбора списка новостей из одного или нескольких информационных блоков для формирования рассылки.
Страница рассылок | subscribe.index | Служит для создания страницы со списком рассылок и формами управления подпиской.
Страница редактирования подписки | subscribe.edit | Служит для создания страницы с формами для добавления или редактирования адреса подписки.
Упрощенное редактирование подписки | subscribe.simple | Служит для управления подписками пользователей.
Форма подписки | subscribe.form | Служит для построения включаемой в дизайн сайта формы для подписки на рассылки.

Смотрите также

  • Как выполнить импорт адресов подписчиков?
  • Создание и управление автоматической рассылкой
  • Создание ручной рассылки
  • Организация подписки на рассылку
  • Документация для разработчиков по модулю Подписка, рассылки


Подписка, рассылки. Настройки модуля

Форма настроек модуля Подписка, рассылки (Настройки > Настройки продукта > Настройки модулей > Подписка, рассылки) предназначена для задания общесистемных параметров модуля.

Закладка Настройки

Поле | Описание
Разрешить анонимную подписку | При отмеченной опции посетителям сайта будет позволено подписываться на рассылки без предварительной регистрации на сайте.
Показывать ссылки на авторизацию при анонимной подписке | При отмеченной опции будут отображаться ссылки, позволяющие посетителям войти на сайт с использованием их регистрационных данных.
Публичный раздел, где находится страница редактирования подписки (макросы: #SITE_DIR#) | Указывается путь к папке (относительно корня сайта), в которой находится страница редактирования подписки. При задании пути допустимо использование макроса #SITE_DIR#.
Интервал в секундах для пошаговой рассылки в режиме "Персонально подписчику" (0 - рассылать за один шаг) | Указывается интервал отправки писем подписчикам (в секундах). Режим Персонально подписчику предполагает отправку индивидуальных сообщений каждому подписчику с адресом подписчика в поле Кому каждого такого письма. Если в поле указать 0, то отправка писем будет осуществляться за один шаг.
Максимальное количество адресов в поле BCC не в режиме "Персонально подписчику" (0 - отправить одно письмо) | Указывается максимальное количество адресов, которое может быть выведено в поле BCC в случае не использования режима Персонально подписчику. Если в поле указать 0, то одно письмо будет отправляться всем подписчикам.
Адрес отправителя по умолчанию Адрес отправителя, по умолчанию используемый во всех создаваемых сообщениях. С версии 20.700.0 Главного модуля (main) возможно использовать email с [dw]IDN[/dw][di]IDN (англ. Internationalized Domain Names — интернационализованные доменные имена) — это доменные имена, которые содержат символы национальных алфавитов, например, мойсайт.рф.

Подробнее [image]...[/di], включая кириллические домены.
Адрес получателя по умолчанию | Адрес получателя, по умолчанию используемый в поле Кому каждого создаваемого сообщения.
Кодировки сообщения в рассылку | Задается перечень допустимых таблиц кодов символов для создания сообщений.
Разрешить 8-битные символы в заголовке письма | При отмеченной опции в заголовке письма будут использоваться 8-битные символы расширенного ASCII (0-255). В противном случае, такие символы (обычно национальные, например, символы русского алфавита) будут выведены в кодировке Base-64.
Дополнительный параметр для передачи функции mail | Для более детальной настройки указывается дополнительный параметр для передачи функции mail.
Отправлять картинки в виде вложений в письмо | При отмеченной опции изображения будут отправлены как вложения в письмо. В противном случае в тело письма будут вставлены ссылки на картинки.
Через сколько дней удалять неподтвержденные подписки (0 - не удалять) | Указывается количество дней, по истечении которых неподтвержденные подписки будут удалены. Если в поле указать 0, то неподтвержденные подписки не будут удаляться.
Метод автоматической рассылки Указывается метод автоматической рассылки:
  • Агент - автоматическая рассылка осуществляется внутренними средствами системы;
  • Крон - используется при установке системы на сервер под управлением ОС Unix (предусматривает использование демона cron ОС Unix).
Количество писем для автоматической рассылки агентом за один запуск в режиме "Персонально подписчику" | Указывается количество писем выпуска (для которого задано свойство Отправлять письмо персонально каждому получателю), которые будут отправлены агентом автоматически за один запуск в режиме Персонально подписчику. Применяется для снижения нагрузки на сервер.
Метод автоматической генерации выпусков Указывается метод автоматической генерации выпусков:
  • Агент - автоматическая генерация выпусков осуществляется внутренними средствами системы;
  • Крон - используется при установке системы на сервер под управлением ОС Unix (предусматривает использование демона cron ОС Unix).
Интервал проверки необходимости генерации выпусков в секундах | Указывается интервал времени в секундах, по истечении которого будет проверяться необходимость генерации выпусков.
Максимальный размер вложений в мегабайтах (0 - без ограничений) | Указывается максимальный размер вложений в письма рассылок в мегабайтах (если указать 0, то без ограничений).

Закладка Доступ

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Подписка, рассылки:
  • [D] закрыт - запрет на доступ;
  • [R] просмотр всех данных модуля - разрешается только просмотр всех данных модуля;
  • [W] запись - полный доступ к ресурсам модуля.
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.


Список рассылок

На странице Список рассылок (Сервисы > Рассылки > Список рассылок) представлена информация об имеющихся в системе рассылках.

Фильтр

Используется для задания параметров отбора рассылок, которые отображаются в списке.

Поле | Описание
Найти | Поиск рассылок по наиболее часто используемым параметрам: идентификатору и названию рассылки. Данное поле отображается, даже если фильтр свернут.
ID | Идентификатор рассылки, под которым она зарегистрирован в базе данных.
Название | Поиск рассылок по названию.
Сайт | Сайт, на котором действуют требуемые рассылки.
Активность | Отбор рассылки, чей статус активен или неактивен, либо отображение как активных, так и неактивных рассылок.
Публикация | Поле позволяет найти либо только опубликованные, либо только неопубликованные рассылки, либо отобразить любые рассылки.
Автоматическая | Отбор автоматических либо неавтоматических рассылок, либо показ всех рассылок.
Символьный код | Поле позволяет найти рассылку по символьному коду.

Чтобы отфильтровать рассылки по заданным критериям нажмите кнопку Найти. Для отображения всех рассылок нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Служит для добавления новой рассылки.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список рассылок

Колонка | Описание
Колонка флажков | Поле выбора рассылок, к которым необходимо применить какое-либо правило или действие.
Меню действий | Отображение меню, позволяющее Изменить или Удалить рассылку.
ID | Идентификатор рассылки, под которым оно зарегистрировано в базе данных.
Название | Название рассылки, отображаемое посетителям.
Сайт | Сайт, к которому привязана рассылка.
Сорт. | Вес сортировки рассылки. Чем меньше это значение, тем выше в видимом списке располагается эта рассылка.
Акт. | Статус активности рассылки. Если рассылка активна, пользователи могут подписаться на нее.
Публ. | Является ли данная рассылка публичной. Т.е. разрешен или запрещён показ ссылки для подписки на данную рассылку в публичном разделе сайта.
Авт. | Признак автоматической генерации выпусков, относящихся к данной рассылке. Если значение поля - Да, то выпуски данной рассылки формируются автоматически по расписанию и на основании выбранного шаблона.
Генерация | Если рассылка является автоматической (поле Авт. имеет значение Да), то в этом поле выводится дата и время последней генерации выпусков данной рассылки. Если генерация выпусков не происходила, то в поле отображается дата и время, в которое рассылка стала автоматической и активной.
Символьный код | Символьный код рассылки


Создание и редактирование рассылки

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком рассылок.
Добавить | Переход к созданию новой рассылки. Отображается только при редактировании уже существующей рассылки.
Удалить | Удаление редактируемой рассылки. Отображается только при редактировании уже существующей рассылки.
Проверить | Переход на страницу проверки шаблона автоматической генерации выпусков. Просмотр сообщения рассылки выполняется в том виде, в котором оно будет получено подписчиками. Кнопка отображается только на странице редактирования автоматической рассылки.

Закладка Рассылка

Поле | Описание
Активна | Статус активности рассылки. Если рассылка активна, пользователи могут подписаться на нее.
Выводить в списке публичных рассылок | Разрешается или запрещается показ ссылки для подписки на данную рассылку в публичном разделе сайта.
Показывать рассылку на сайте | Сайт рассылки.
*Название | Название рассылки, отображаемое посетителям.
Сортировка | Вес сортировки списка рассылки. Чем больше это значение, тем выше в списке, показываемом посетителям, располагается эта рассылка.
Символьный код | Символьный код рассылки.
Описание для подписчиков (до 2000 симв.) | Описание рассылки, отображаемое посетителям сайта. Старайтесь создавать описание, краткое по объему и емкое по содержанию.
Автоматическая (выпуски формируются по расписанию и на основании шаблонов) | Создаваемая рассылка станет автоматической. Выпуски такой рассылки будут генерироваться автоматически на основании выбранного шаблона и отправляться подписчикам по заданному расписанию.

* - поле, обязательное для заполнения.

Закладка Автоматическая генерация

Вкладка доступна только при создании/редактировании автоматической рассылки.

Поле | Описание
Расписание
*Время последней генерации выпуска (DD.MM.YYYY HH:MI:SS) Дата и время последней генерации сообщений автоматической рассылки.
При создании новой автоматической рассылки в поле будет подставлена дата и время создания рассылки.
Значение поля используется для задания даты, начиная с которой сообщения автоматической рассылки будут генерироваться и рассылаться.
Дни месяца (например 1,10-20,25) | Список чисел месяца, по которым будет происходить автоматическая генерация выпусков рассылки. Возможно указание как отдельных дат через запятую (например: 1,8,10), так и диапазона дат (например: 19-25, 27-30).
Дни недели Дни недели для выпуска рассылки.

Примечание: Необходимо задать значение хотя бы одного из параметров: дней недели либо чисел месяца.
Если одновременно были заданы и дни недели, и числа месяца, то генерация выпусков будет происходить при календарном совпадении данных параметров. Например, если был выбран день недели Пт и задано число месяца 10, то генерация выпусков будет происходить в том случае, если десятое число месяца выпадает на пятницу.

*Время (например 9:00,18:00) | Время, когда будет автоматически генерироваться выпуск рассылки. Возможно указание списка значений (например: 8:00, 16:00, 24:00).
Шаблон для автоматической генерации выпусков
*Доступные шаблоны Выбор шаблонов из доступных, на основании которого будут автоматически генерироваться выпуски данной рассылки.
Если доступные шаблоны отсутствуют, то будет выведено сообщение: Не найдено ни одного шаблона для автоматической генерации выпусков.
Шаблоны для автоматической генерации выпусков могут быть созданы с использованием API функций продукта (см. класс CPostingTemplate [image]).

По умолчанию шаблоны для автоматической генерации выпусков лежат в директории /bitrix/php_interface/subscribe/templates. Для поддержки версионности при разработке сайта в ядре 14.0.1 была введена поддержка папки /local [image], что облегчает совместную разработку сайта.
С версии 16.5 модуля "Подписка, Рассылки" шаблоны для автоматической генерации выпусков можно хранить в папке /local/php_interface/subscribe/templates. Приоритет всегда у папки /local перед /bitrix, т.е если в/local/php_interface/subscribe/templates и/bitrix/php_interface/subscribe/templates будут находиться шаблоны с одинаковым названием, то шаблон будет выбираться из папки /local.

Поля письма
*От кого Адрес отправителя, который будет подставляться в поле От кого автоматически сгенерированных сообщений рассылки.
По умолчанию поле имеет значение, заданное на странице настроек модуля Рассылки.

* - поле, обязательное для заполнения.

Примечание: Отправка выпуска автоматической рассылки будет производиться только в том случае, если выпуск содержит данные, выбранные с использованием компонентов в динамическом шаблоне.
Если информация, необходимая для формирования выпуска за указанный период отсутствует, то рассылка производиться не будет.


Проверка шаблона рассылки

Переход на Страницу проверки шаблона осуществляется по кнопке Проверить, расположенной на контекстной панели страницы редактирования автоматической рассылки, либо через пункт меню действий Проверить шаблон на странице Список рассылок (Сервисы > Рассылки > Список рассылок).

На странице проверки шаблона можно осуществить просмотр сообщения, сформированного на основании выбранного шаблона, в том виде, в котором оно будет отправлено подписчикам рассылки.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком рассылок.
Добавить | Переход к созданию новой рассылки.
Редактировать | Переход к редактированию проверяемой рассылки.
Удалить | Удаление проверяемой рассылки.

Поля формы - закладка "Проверка"

Поле | Описание
Название рассылки | Название проверяемой рассылки.
Название шаблона | Название проверяемого шаблона для автоматической генерации выпусков.
Описание шаблона | Выводится описание шаблона.
Интервал времени
*С (DD.MM.YYYY HH:MI:SS) | Указывается нижняя граница периода, за который будет осуществляться проверка шаблона. Т.е. дата и время последней генерации сообщений рассылки на основе выбранного шаблона. Для новой автоматической рассылки по умолчанию подставляется дата и время ее создания.
*По (DD.MM.YYYY HH:MI:SS) | Указывается верхняя граница периода, за который будет осуществляться проверка шаблона. Т.е. дата и время предстоящей генерации сообщений рассылки на основе выбранного шаблона. Пример Если в настройках рассылки указана дата генерации сообщений - 1 числа каждого месяца, то для проверки вида сообщений рассылки, например, в августе данные поля будут заполнены следующим образом: - в поле начала действия шаблона будет указана дата предыдущего выпуска: 1 июля (01.07.2005); - в поле окончания действия шаблона будет указана дата предстоящего выпуска: 1 августа (01.08.2005).

* - поле, обязательное для заполнения.

Для проверки шаблона нужно нажать кнопку Проверить. Будет выведена таблица, содержащая информацию:

Массив входных параметров
[Показать\Скрыть параметры выпуска] | Ссылка, открывающая\скрывающая значения параметров шаблона, используемые для его идентификации в системе.
Тело письма
Сообщение в том виде, в котором оно будет получено подписчиками.
Параметры выпуска
[Показать\Скрыть параметры выпуска] | Ссылка, открывающая\скрывающая значения параметров выпуска данной рассылкие, заданные на странице создания/редактирования выпуска.


Список выпусков

Форма Список выпусков (Сервисы > Рассылки > Выпуски) предназначена для управления новостными сообщениями.

  • в форме наглядной таблицы просматривать имеющиеся сообщения;
  • создавать новостные сообщения (выпуски) с чистого листа и путём копирования существующих сообщений;
  • редактировать сообщения;
  • удалять сообщения;
  • отправлять сообщения рассылки подписчикам.

Фильтр

Фильтр используется для задания параметров отбора сообщений, отображаемых в списке. Следующая таблица описывает поля фильтра.

Поле | Описание
Найти Поиск выпусков сообщений по их основным параметрам: идентификатору, теме или статусу.

Поле присутствует, даже если фильтр свернут.
ID* | Идентификатор сообщения, под которым оно зарегистрировано в базе данных.
Дата изменения (DD.MM.YYYY) | Диапазон дат, в пределах которых искомые сообщения могли быть изменены.
Дата отправки (DD.MM.YYYY) | Диапазон дат, в пределах которых искомые сообщения могли быть отправлены.
Время автоматической отправки (DD.MM.YYYY) Выборка сообщений, отправляемых автоматически, по дате и времени их отправки.
Указываются Дата и время отправки сообщения, для которого в форме создания/редактирования было задано свойство Отправлять автоматически в указанное время.
Статус* Текущий статус сообщения в базе данных:
  • [S] Отправлено;
  • [P] В процессе;
  • [D] Черновик;
  • [E] Отправлено с ошибками;
  • [W] Остановлен.
Для фильтрации сообщений по значению статуса можно использовать текстовое поле, расположенное над списком статусов. Разрешается комбинировать значения статуса, например, "D|S" или "черновик|отправлено". Поле позволяет использовать язык запросов для создания сложных условий.
От кого* | Поле позволяет задать отправителей сообщений, сообщения от которых требуется найти. В качестве запроса можно использовать полный или частичный адрес e-mail. Возможно использование языка запросов для создания сложных условий.
Кому было отправлено* | Задания получателей сообщений для поиска сообщения. В качестве запроса можно использовать полный или частичный адрес e-mail. Поле Кому заполняется после частичной или полной отправки сообщения. Возможно использование языка запросов для создания сложных условий.
Тема* | Тема сообщений, которые требуется найти. Возможно использование языка запросов.
Тип сообщения | Позволяет отфильтровать только сообщения, созданные в HTML-формате либо в текстовом формате.
Сообщение* | Предназначено для задания слов, частей слов, фраз или частей фраз, которые могут содержаться в искомых сообщениях. Возможно использование языка запросов для создания сложных условий поиска.
Рассылки | Указываются рассылки для поиска выпусков, отправка которых осуществляется в рамках выбранных рассылок.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отфильтровать сообщения по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех сообщений нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Служит для добавления нового выпуска.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список сообщений

Таблица списка сообщений отображает выпуски рассылки, отбирая их согласно критериям, установленным в фильтре. Помимо этого, правая колонка таблицы списка (Действие) содержит ссылки-команды управления конкретным сообщением. При помощи этих команд сообщения могут быть отредактированы, отправлены и удалены.

Поля таблицы.

Колонка | Описание
Колонка флажков | Выбор сообщений для применения какого-либо правила или действия.
Меню действий
  • Отправить - отправка сообщения. Команда доступна для сообщений, находящихся в статусе Черновик;
  • Остановить - остановка отправки. Команда доступна для сообщений, находящихся в статусе В процессе;
  • Продолжить - возобновление отправки сообщения. Команда доступна для сообщений, находящихся в статусе Остановлен;
  • Изменить – редактирование сообщения. Команда не доступна для сообщений, находящихся в статусе В процессе;
  • Копировать – копирование данного сообщения в новое;
  • Удалить - удаление сообщения. Команда не доступна для сообщений, находящихся в статусе В процессе.
ID | Идентификатор сообщения, под которым оно зарегистрировано в базе данных.
Изменен | Дата и время модификации данного сообщения.
Тема | Тема сообщения.
Тип | Тип сообщения: текстовый или в формате HTML.
Статус Статус сообщения и информация о ходе его отправки.
  • [D] Черновик - сообщение может быть сохранено в данном статусе или переведено в него после остановки или завершения отправки (при этом будет очищена очередь отправки сообщения);
  • [P] В процессе - сообщение находится в процессе отправки;
  • [S] Отправлено - отправка сообщения прошла успешно;
  • [E] Отправлено с ошибками - во время отправки сообщения произошли ошибки;
  • [W] Остановлен - отправка сообщения была прервана.
Информация о ходе отправки представляется в виде шкалы, на которой цветами обозначено:
  • белый - количество ещё не отправленных сообщений;
  • зеленый - количество отправленных сообщений;
  • красный - количество сообщений, отправленных с ошибкой.
Отправлено | Дата и время отправки сообщения.
Отчет об отправке | Ссылка Посмотреть список адресов, ведущая на страницу списка адресов, на которые было отправлено сообщение.
От кого | Отправитель сообщения.
Кому | Получатель сообщения.

Как создать, отправить и найти
сообщение для рассылки

Для создания сообщения служит кнопка Добавить, открывающая форму добавления/редактирования сообщения.

Для отправки сообщения проще всего воспользоваться кнопкой Отправить формы добавления сообщения. Однако, после создания сообщения вы можете просто сохранить его в статусе Черновик, не отправляя. Отправить сообщение можно позднее, открыв меню нажатием на кнопку меню действий в таблице сообщений напротив соответствующего сообщения и выбрав пункт Отправить.

Для поиска конкретного сообщения, задайте его параметры в фильтре. Например, вы желаете найти сообщение, тема которого звучала так: Представляем новый ноутбук. Введите название в поле Тема фильтра и нажмите кнопку Найти. Таблица сообщений отобразит требуемое сообщение.

Диаграмма смены статусов сообщения

Логика смены статусов выпусков сообщений может быть описана с помощью следующей диаграммы:


Создание и редактирование выпуска

Закладки

Для создания и редактирования сообщений рассылки применяется форма одного типа. В зависимости от того, создаете вы новое сообщение или редактируете существующее, некоторые поля могут присутствовать или отсутствовать на форме.

С помощью формы редактирования сообщений можно:

  • создать новое или изменить существующее сообщение рассылки;
  • выбрать подписчиков для получения выпуска рассылки;
  • выбрать пользователей сайта для получения выпуска рассылки;
  • добавить дополнительные адреса получателей выпуска рассылки;
  • настроить параметры сообщения;
  • отправлять сообщения рассылки подписчикам.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком выпусков.
Добавить | Переход на страницу создания нового выпуска. Отображается только на странице редактирования уже существующего выпуска.
Копировать | Команда копирования выпуска доступна только на странице редактирования уже существующего выпуска.
Удалить данный выпуск | Удаление выпуска, просматриваемого на данной странице. Команда доступна только на странице редактирования уже существующего выпуска.

Выпуск

Поле | Описание
Информация о состоянии выпуска
Дата модификации Дата и время последнего редактирования сообщения.

Примечание: Данное поле отображается только в режиме редактирования существующего сообщения.
Дата отправки Дата и время отправки сообщения (если сообщение было отправлено).

Примечание: Данное поле отображается только в режиме редактирования существующего сообщения.
Отчет об отправке Список адресов, на которые сообщение было отправлено или не отправлено. Выводится, если такой список существует (при статусах Отправлено, Отправлено с ошибками, Остановлен).

Примечание: Данное поле отображается только в режиме редактирования существующего сообщения.
Текущий статус
  • черновик - выпуск может быть сохранен в данном статусе или переведен в него после остановки или завершения отправки (при этом будет очищена очередь отправки выпуска);
  • отправлено - отправка выпуска прошла успешно;
  • отправлено с ошибками - во время отправки выпуска произошли ошибки;
  • остановлен - отправка выпуска была прервана.
Перевести в статус Смена статуса сообщения. Например, чтобы отослать сообщение повторно, можно изменить его статус с Отправлено на Черновик и затем отправить.

Примечание: Данное поле отображается только в режиме редактирования существующего сообщения.
Поля письма
От кого | Информация об отправителе сообщения в виде, в котором его увидит пользователь. Если поле отправителя не будет заполнено, то адрес возьмется из настроек модуля Подписки, рассылки, либо из настроек Главного модуля.
Кому | Указывается адрес для контроля содержания рассылки. Если поле получателя не будет заполнено, то адрес возьмется из настроек модуля Подписки, рассылки, либо из настроек Главного модуля.
Тема | Тема сообщения. Обязательно для заполнения.
Переключатель режима ввода текста Задается режим ввода текста письма: Text, HTML или Визуальный редактор.

В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения с помощью HTML-тегов. Визуальный редактор позволяет редактировать контент так, как он непосредственно будет выглядеть в сообщении.

Получатели

Поле | Описание
Выбрать подписчиков на рассылки
Рассылки | Список существующих рассылок. Выбор рассылок для посылки сообщений.
Формат подписки Поле позволяет выборочно отправлять сообщения по формату получения.
(любой) - Отправить сообщение всем подписчикам.
Текст - Отправить сообщение тем подписчикам, которые выбрали простой текст в качестве формата подписки.
HTML - Отправить сообщение тем подписчикам, которые выбрали текст HTML в качестве формата подписки.
Выбрать пользователей сайта
Группы пользователей | Группы пользователей, для которых предназначено сообщение. Выбор группы из списка имеющихся.
Фильтр на выбранные адреса
Фильтр по E-Mail Ограничение получателей сообщения рассылки путём задания фильтра.

Для установки фильтра могут быть использованы специальные логические выражения [image].

.

Пример фильтра: %@bitrixsoft.ru
Посмотреть выбранные адреса получателей | Просмотр выбранных адресов получателей сообщения.
Дополнительные адреса получателей
Дополнительные адреса электронной почты, на которые будет отправлено данное сообщение.

Вложения

Поле | Описание
Список вложений | Поле содержит табличку с вложениями, состоящую из следубщих полей: Файл, Размер, байт и Удалить. Каждое вложение можно скачать, кликнув по ссылке с именем файла.
Загрузить вложения | С помощью кнопки Обзор... выберите файл для отправки получателям выпуска в виде вложений.

Параметры

Поле | Описание
Кодировка письма | Кодировка сообщения.
Отправлять письмо персонально каждому получателю (рекомендуется) | Если эта опция включена, каждое сообщение будет формироваться и отправляться каждому пользователю отдельно. Если опция выключена, одно сообщение будет отправлено сразу всем пользователям с указанием их адресов в поле Скрытая копия (BCC). Рекомендуется отправлять сообщения персонально, чтобы гарантировать их доставку подписчикам.
Отправлять автоматически в указанное время | Разрешается или запрещается автоматическая отправка сообщения в соответствии с указанными в поле Дата и время отправки параметрами.
Дата и время отправки (DD.MM.YYYY HH:MI:SS) | Дата и время отправки сообщения.


Подписчики

Форма Подписчики (Сервисы > Рассылки > Подписчики) предназначена для управления пользователями, подписанными на получение новостей. С помощью этой формы можно:

  • в форме наглядной таблицы просматривать данные подписчиков;
  • создавать новых подписчиков;
  • редактировать параметры подписчиков;
  • удалять подписчиков.

Фильтр

Фильтр используется для задания параметров отбора подписчиков, отображаемых в списке. Нижеследующая таблица описывает поля фильтра.

Поле | Описание
Найти Поиск подписчиков по их основным параметрам: адресу электронной почты, идентификатору или персональным данным пользователя.

Поле присутствует, даже если фильтр свернут.
ID* | Идентификатор подписчика, под которым он зарегистрирован в базе данных.
Дата добавления (DD.MM.YYYY) | Диапазон дат, в пределах которых искомые подписчики могли быть добавлены в базу данных.
Дата изменения (DD.MM.YYYY) | Диапазон дат, в пределах которых данные искомых подписчиков могли быть изменены.
E-Mail* | Адрес электронной почты подписчика, используемый для отсылки сообщений.
Анонимный Поле позволяет включать в отчет подписчиков:
  • да - анонимных (не зарегистрированных на сайте) подписчиков;
  • нет - зарегистрированных на сайте подписчиков;
  • все - всех подписчиков, как анонимных, так и зарегистрированных.
ID пользователя* Идентификатор пользователя, под которым он зарегистрирован на сайте.
Поле значимо лишь для зарегистрированных (не анонимных пользователей).
Подписчик* Персональные данные пользователя, по которым следует произвести отбор.
Поле значимо лишь для зарегистрированных (не анонимных пользователей).
Подтверждено Позволяет отобразить подписчиков:
  • да - подтвердивших свою подписку;
  • нет - не подтвердивших подписки;
  • все - всех подписчиков.
Активно Поле позволяет включать в отчет подписчиков, чей статус подписки:
  • да - активен (подписчик получает сообщения);
  • нет - не активен (подписчик не получает сообщения);
  • все - всех подписчиков.
Формат | Фильтрация подписчиков по желаемому формату получаемых сообщений.
Рассылка | Отображение подписчиков, которые подписаны на выбранные рассылки. Для выбора нескольких рассылок воспользуйтесь клавишей Ctrl при нажатии кнопки мыши.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отфильтровать сообщения по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех сообщений, нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Добавление нового подписчика.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список подписчиков

Фильтрация списка подписчиков согласно установленным критериям. Данные подписчика могут быть отредактированы и удалены.

Колонка | Описание
Колонка флажков | Выбор подписчиков, к которым предполагается применить какое-либо правило или действие.
Меню действий | Меню, позволяющее изменить или удалить подписчика.
ID | Идентификатор подписчика, под которым он зарегистрирован в базе данных.
Добавлено | Дата добавления данного подписчика в базу данных.
Адрес | Адрес электронной почты подписчика, используемый для отсылки сообщений.
Подписчик | Данные о подписчике: анонимный или его регистрационные данные.
Подтв. | Статус подтверждения подписки. Да - подписчик подтвердил желание получать сообщения подписанных рассылок, и нет - в противном случае.
Акт. | Статус активности подписки. Если подписка активна, то сообщения данному подписчику отсылаются.
Формат | Желаемый подписчиком формат сообщений.
Изменено | Дата изменения параметров подписки.
Время подтверждения | Дата создания подписки.
Код подтверждения | Код подтверждения подписки.

Как создать/изменить данные подписчика

Для создания подписчика служит кнопка Добавить, открывающая форму добавления/редактирования адреса.

Для изменения регистрационных данных подписчика дважды кликните на строке соответствующего подписчика.


Создание и редактирование подписчика

Для создания и изменения данных подписчика рассылок применяется форма одного типа. В зависимости от того, создаете вы новое сообщение или редактируете существующее, некоторые поля могут присутствовать или отсутствовать на форме.

С помощью формы можно:

  • создать новое или изменить существующее сообщение рассылки;
  • выбрать подписчиков для получения выпуска рассылки;
  • выбрать пользователей сайта для получения выпуска рассылки;
  • добавить дополнительные адреса получателей выпуска рассылки;
  • настроить параметры сообщения;
  • отправлять сообщения рассылки подписчикам.

Контекстная панель

Ссылка | Описание
Список | Ссылка на страницу со списком адресов подписчиков.
Добавить | Ссылка на страницу добавления нового подписчика. Примечание: Отображается только при переходе на страницу редактирования уже существующего подписчика.
Удалить | Удаление текущего подписчика. Примечание: Ссылка доступна только при переходе на страницу редактирования уже существующего подписчика.

Вкладка "Подписчик"

Поле | Описание
Дата добавления | Дата добавления данного подписчика в базу данных. Примечание: Данное поле отображается только в режиме редактирования данных существующего подписчика.
Дата модификации | Дата последнего изменения данных подписчика. Примечание: Данное поле отображается только в режиме редактирования данных существующего подписчика.
Подписка подтверждена | Флаг, определяющий, подтвердил подписчик желание получать сообщения или нет.
Код подтверждения подписки | Код подтверждения подписки, отправленный подписчику для подтверждения. Примечание: Данное поле отображается только в режиме редактирования данных существующего подписчика.
Дата генерации кода подтверждения | Дата и время генерации кода активации подписки. Примечание: Данное поле отображается только в режиме редактирования данных существующего подписчика.
Анонимный подписчик | Флаг, определяющий статус анонимности подписчика (анонимным признается подписчик, не зарегистрированный на сайте).
Пользователь (ID) | Идентификатор не анонимного пользователя, под которым он зарегистрирован на сайте.
Подписка активна | Статус активности подписки. Если подписка активна, то сообщения данному подписчику отсылаются.
E-Mail* | Адрес электронной почты подписчика, используемый для отсылки сообщений.
Выслать подписчику код подтверждения при изменении (добавлении) адреса | Если этот флаг установлен, то в случае добавления адреса или изменения адреса подписчика на новый адрес высылается код подтверждения подписки.
Отправить письмо на основе шаблона сайта | Поле служит для выбора шаблона сообщений, в соответствии с которым будет отослан код подтверждения.

* - поле, обязательное для заполнения.

Вкладка "Подписки"

Поле | Описание
Формат | Формат сообщений данного подписчика.
Рубрики подписки | Существующие рубрики рассылки, новостные сообщения которых отсылаются подписчику.


Импорт адресов

Форма (Сервисы > Рассылки > Импорт адресов) предназначена для добавления адресов рассылки сообщений из внешних источников (файлов) или из явно задаваемого списка адресов. С ее помощью можно добавить в систему большое количество адресов электронной почты (например, при смене системы управления сайтом на систему «1С-Битрикс: Управление сайтом»), не прибегая к ручному вводу адресов.

Для импорта адресов задайте источник адресов (внешний файл или список), установите описанные ниже параметры импорта и нажмите кнопку Импортировать адреса.

Поля формы

Поле | Описание
Импортировать из файла Путь к локальному файлу с адресами, из которого будет производиться импорт. Адреса в файле должны быть разделены запятой либо каждый новый адрес может находиться на новой строке:

user1@host.com,user2@host.com,user3@host.com
или
user1@host.com
user2@host.com
user3@host.com
Чтобы найти файл, из которого будет производиться импорт, нажмите кнопку Обзор...
Импортировать из списка | В этом поле можно явным образом задать адреса, скопировав их из текстового файла. Для явного задания адресов применяются те же правила, что и при импорте из файла.
Выслать код подтверждения подписки | При установке этого флага, на каждый из добавленных адресов будет выслан код подтверждения подписки.
Установить флаг подтверждения подписки | Установка этого флага приведет к тому, что подписка для каждого добавленного адреса будет автоматически подтверждена, даже если подписчик не подтвердил подписку явно.
Добавить подписчиков Подписчики рассылок могут быть добавлены как анонимные посетители или как зарегистрированные пользователи сайта.
  • Как анонимных посетителей - добавляемые подписчики не будут зарегистрированы на сайте; для них не будут созданы аккаунты.
  • Как пользователей (с созданием бюджета) - добавляемые подписчики регистрируются на сайте; для них создаются бюджеты (аккаунты) с возможностью привязки к группам пользователей.
Выслать регистрационную информацию пользователям Если этот флаг установлен, то после добавления адресов и регистрации каждого пользователя на его адрес высылаются регистрационные данные этого пользователя.

Примечание: Данный флаг доступен, только если подписчики добавляются как зарегистрированные пользователи.

Добавить пользователей в группы При регистрации каждого пользователя производится его добавление в заданные группы. Выберите группы, в которые следует добавить регистрируемых пользователей. Чтобы выбрать более одной группы, при их выборе удерживайте нажатой клавишу Ctrl.

Примечание: Данная опция доступна пользователю, у которого есть права доступа W (полный доступ) к Главному модулю, и только если подписчики добавляются как зарегистрированные пользователи.

Подписать на рассылки | При добавлении подписчиков есть возможность автоматически подписать их на одну или несколько существующих рассылок. Выберите те рассылки, на которые следует подписать добавляемых пользователей.
Формат | Формат сообщений, отсылаемых добавляемым подписчикам.
Отправить письма на основе шаблонов сайта | Сайт, шаблоны которого следует использовать для отправки сообщений подписчикам.

Смотрите также:

  • Импорт адресов (учебный курс "Контент-менеджер")


Типичные задачи

При решении задач по рассылке достаточно часто бывает необходимо настроить серверную утилиту cron. Описание способов настройки сторонних приложений не входит в задачи документации по "1С-Битрикс: Управление сайтом". О параметрах настройки этой утилиты можно узнать здесь [image], например.


Для чего нужны списки рассылки

Списки рассылки - средство группировки подписчиков по темам новостных сообщений.

Списки рассылки не содержат новостных сообщений или подписчиков. Списки рассылки служат удобным средством группировки подписчиков, получающих определённые новостные сообщения.

Например, Вы можете создать список рассылки "Новости компании" и предлагать посетителям подписаться на него. Подписчик, выбрав рассылку для подписки, тем самым устанавливает привязку своего адреса к этой рассылке. В дальнейшем, при создании новостного сообщения, Вы можете указать, что это сообщение должно отправляться по списку рассылки "Новости компании" - сообщение будет отослано тем подписчикам, которые подписаны на эту рассылку.


Как добавить подписчика

Для добавления нового подписчика вручную, сделайте следующее.

  1. Откройте форму Список подписчиков (Сервисы > Рассылки > Подписчики).
  2. Нажмите кнопку Добавить, расположенную на контекстной панели.
  3. Заполните форму данных о подписчике. Вы можете указать следующие данные:

    Подписка подтверждена
    Флаг, определяющий, подтвердил подписчик желание получать сообщения или нет. Вы можете принудительно установить этот флаг.

    Анонимный подписчик
    Флаг, определяющий статус анонимности подписчика (анонимным признается подписчик, не зарегистрированный на сайте).

    Подписка активна
    Установите этот флаг, иначе подписчик не сможет получать сообщения рассылок.

    E-Mail
    Адрес, на который будут отсылаться сообщения рассылок.

    Выслать подписчику код подтверждения при изменении (добавлении) адреса
    Если этот флаг установлен, то становится активным поле Отправить письмо на основе шаблона сайта, и подписчику будет выслан код подтверждения подписки на основе выбранного шаблона сайта.

  4. После заполнения формы, нажмите кнопку Сохранить или Применить.


Как импортировать список адресов подписчиков

Для добавления адресов подписчиков из внешнего файла вначале следует подготовить файл-источник данных.

Подготовка файла

Адреса в файле могут:

  • разделяться запятыми;
  • начинаться с новой строки.

Другими словами, файл может выглядеть следующим образом:

user1@host.com,user1@host.com,user1@host.com,user1@host.com

или

user1@host.com
user1@host.com
user1@host.com
user1@host.com

Импорт адресов

  1. Откройте форму Импорт адресов (Сервисы > Рассылки > Импорт адресов).
  2. Нажмите кнопку Обзор... и укажите файл, содержащий список адресов.
  3. Если требуется выслать код подтверждения подписки добавляемым подписчикам, установите флаг Выслать код подтверждения подписки.
  4. Если требуется автоматически подтвердить подписку всем добавляемым подписчикам, включите опцию Установить флаг подтверждения подписки.
  5. Если необходимо зарегистрировать добавляемых подписчиков на сайте и создать каждому из них персональный аккаунт, выберите опцию Как пользователей... в поле Добавить подписчиков.
  6. Если вы выбрали регистрацию добавляемых подписчиков как пользователей на сайте, то:
    • для отсылки регистрационной информации каждому из регистрируемых пользователей, включите опцию Выслать регистрационную информацию...;
    • выберите группы пользователей, к которым будут приписаны регистрируемые пользователи.
  7. Выберите рассылки, на которые по умолчанию будут подписаны пользователи.
  8. Выберите формат рассылки для отсылки сообщений регистрируемым пользователям.
  9. Нажмите кнопку Импортировать адреса.


Как создать список рассылки

Для создания новой рассылки проделайте следующее:
  1. Откройте форму Список рассылок (Сервисы > Рассылки > Список рассылок).
  2. Нажмите кнопку Добавить, с помощью которой будет открыта форма Добавление рассылки.
  3. Для активации рассылки должен быть установлен флаг Активна.
  4. Чтобы рассылка отображалась в списке доступных рассылок при подписке, необходимо отметить опцию Выводить в списке публичных рассылок.
  5. Выберите сайт, в котором будет доступна рассылка.
  6. Обязательный шаг
    Введите название рассылки. Это название будет показываться посетителям при подписке.
  7. Существует возможность установить вес сортировки для конкретной рассылки. Чем больше значение этого параметра, тем выше в списке доступных рассылок будет располагаться данная рассылка.
  8. Введите описание рассылки. Описание должно быть максимально информативным; на его основе посетитель будет принимать решение о подписке на данную рассылку.
  9. Если вы хотите создать автоматическую рассылку, то отметьте опцию Автоматическая, после чего становится активной закладка Автоматическая генерация.
  10. На этой закладке сделайте следующее:
    • Создайте расписание для генерации выпусков данной рассылки, обязательно заполнив поля Время последней генерации выпуска и Время.
    • Выберите шаблон генерации из предложенного списка. Если подходящий шаблон не был найден, то его необходимо создать.
    • Заполните обязательное поле письма От кого.
  11. Для сохранения рассылки нажмите кнопку Сохранить или Применить. (При нажатии кнопки Сохранить происходит возврат в форму Список рассылок).

    В форме Список рассылок для автоматической рассылки можно осуществить проверку шаблона с помощью пункта меню действий Проверить шаблон.


Как создать сообщение

Для создания нового сообщения проделайте следующее.
  1. Откройте форму Список выпусков (Сервисы > Рассылки > Выпуски).
  2. Нажмите кнопку Добавить, расположенную на контекстной панели.
  3. Заполните поля письма на вкладке Выпуск: От кого, Кому, Тема. Подписчики, получившие сообщение, увидят именно этот текст в соответствующих полях. На этой же вкладке введите текст сообщения. В текстовом режиме отсутствует возможность форматирования текста и вставки рисунков. Режим HTML позволяет использовать любое форматирование сообщения.
  4. Выберите получателей сообщения на вкладке Получатели. Существуют следующие опции выбора получателей сообщения:
    Подписчики рассылок
    Указать рассылки, на которые подписаны клиенты. При подписке на рассылки подписчик указывает, на какие рассылки он желает подписаться; таким образом, устанавливается привязка подписчика к определённой рассылке.
    Можно сузить диапазон подписчиков-получателей сообщения, выбрав определённый формат подписки; при отправке сообщения, оно будет доставляться только подписчикам, указавшим соответствующий формат подписки;
    Пользователи сайта
    Если требуется доставка сообщения определённым пользователям сайта, вы можете выбрать их в этом списке.
    Дополнительная фильтрация адресов
    Существует возможность сузить список получателей сообщения, установив фильтр на адреса электронной почты. Например, при необходимости вы можете отправить сообщение только подписчикам с определённого сервера. В качестве фильтра можно использовать полный или частичный адрес e-mail.
    Дополнительные адреса получателей
    Если требуется отправить сообщение получателям, не подписанным ни на одну из рассылок и не входящим ни в одну из групп пользователей (т.е. сторонним адресатам), укажите здесь адреса их электронной почты. В качестве разделителей адресов используйте запятую или перевод строки.
  5. С помощью вкладки Вложения вы можете загрузить вложения письма.
  6. Наконец, на вкладке Параметры выберите кодировку, в которой сообщение будет отправлено. Данное поле должно соответствовать кодировке, используемой в создаваемом сообщении (обычно Windows-1251 для сообщений, создаваемых в операционной системе Windows).
    Опцию Отправлять письмо персонально каждому получателю рекомендуется не отключать.
    При необходимости осуществления автоматической отправки сообщения поставьте флажок в соответствующем поле и укажите дату и время отправки.
  7. Для сохранения сообщения, нажмите кнопку Сохранить или Применить. (При нажатии кнопки Сохранить происходит возврат в форму Список выпусков.)

    Для немедленной отправки сообщения, нажмите кнопку Отправить.


Как отправить сообщение

Существует несколько способов отправки сообщений в зависимости от их статуса.

Создаваемое сообщение

Для немедленной отправки создаваемого сообщения в форме Добавление выпуска нажмите кнопку Отправить.

Статус "Черновик"

Если сообщение было сохранено в форме Добавление выпуска, но не отправлено, можно отправить его:

  • перейдя к редактированию сообщения, в форме Редактирование выпуска нажать на кнопку Отправить;
  • в таблице формы Список выпусков выбрать Отправить в меню действий соответствующего сообщения.

Статус "Отправлено"

Для повторной отправки сообщения следует вначале перевести его в статус Черновик.

  1. Откройте сообщения для редактирования, выбрав Изменить в меню действий соответствующего сообщения.
  2. В списке выбора Перевести в статус выберите статус Черновик.
  3. Нажмите кнопку Сохранить или Применить.
  4. По кнопке Сохранить вы вернетесь в форму Список выпусков, где нажмите Отправить в меню действий требуемого сообщения.
  5. Если вы нажали кнопку Применить, то нажмите на появившуюся кнопку Отправить.


Почта. Описание модуля

Процесс управления сайтом предполагает общение посредством электронной почты с рядом респондентов, так или иначе связанных с функционированием вашего веб-портала.

Вы можете, как и прежде, использовать ваше программное обеспечение для чтения электронной почты (E-mail клиент), например, The Bat, Outlook, Eudora или любой другой. Однако, система "1С-Битрикс: Управление сайтом" предлагает альтернативный подход к управлению вашими почтовыми сообщениями, причем предлагаемое решение не исключает возможности чтения почтовых сообщений привычными вам средствами.

Смотрите также:

  • Смотрите также Создание правила обработки писем
  • Настройка почты на Linux
  • Настройка почты на VMBitrix
  • Создание учетной записи почты


Почта. Настройки модуля

Закладки

Форма настроек модуля Почта (Настройки > Настройки продукта > Настройки модулей > Почта) предназначена для задания общесистемных параметров модуля.

Настройки

Поле | Описание
Сохранять исходный текст письма | При отмеченной опции система будет сохранять письма в базе данных, что позволяет прочитать их в любой момент времени после сеанса получения почты. Если опция не активна, то сообщения могут быть просмотрены только после их получения, при этом письма в базе сохраняться не будут.
Сохранять вложенные файлы | При отмеченной опции все файлы, вложенные в письма, будут сохраняться в файловой системе (в папке /upload/mail/attachment/). Изменить место хранения нельзя. Примечание: активация этого параметра может привести к существенному увеличению размеров занимаемого места на диске и архивной копии.
Таймаут соединения | Указывается максимальное количество времени (в минутах), в течение которого почтовая система ожидает ответа от почтового сервера.
Проверять сообщения на спам при получении почты | При отмеченной опции все входящие сообщения будут проверяться на предмет нежелательных рассылок (спам) во время получения почты.
Хранить журнал работы (дней) | Указывается количество дней, в течении которых будут сохранены записи почтового лога.

SMTP сервер

Поле | Описание
Командная строка запуска PHP | Задаются параметры запуска встроенного SMTP сервера из командной строки.
Состояние | Отображается текущее состояние SMTP сервера.

Для запуска SMTP сервера нажмите кнопку Запустить SMTP сервер, для остановки нажмите кнопку Остановить SMTP сервер .

Примечание: В операционных системах семейства Windows после запуска SMTP сервера откроется окно командной строки, закрытие которого приведет к остановке сервера.

Доступ

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Почта:
  • [D] закрыт - запрет на доступ;
  • [R] просмотр всех данных модуля - разрешается только просмотр всех данных модуля;
  • [W] запись - полный доступ к ресурсам модуля.


Почтовые ящики

Форма Почтовые ящики (Сервисы > Почта > Почтовые ящики) отображает созданные вами учетные записи электронной почты, используемые для доставки корреспонденции.

Фильтр

Используется для задания параметров отбора учетных записей электронной почты, отображаемых в списке.

Поле | Описание
Название* | Отбор учетных записей по названию. Поле присутствует, даже если фильтр свернут.
Тип | Отбор учетных записей по типу почтового сервера: POP3 или SMTP.
Адрес сервера* | Отбор учетных записей по адресу почтового сервера.
ID* | Идентификатор искомого почтового ящика.
Активность | Отображает все ящики, или только активные или не активные.
Сайт | Сайт, в котором искомый ящик активен.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отфильтровать почтовые ящики по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех почтовых ящиков нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Создание и установка параметров нового почтового ящика (пользовательского или системного).
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список ящиков

Колонка | Описание
Колонка флажков | Выбор ящиков, к которым предполагается применить какое-либо действие.
Меню действий
  • Правила - отображает правила, которые назначены этому ящику;
  • Добавить новое правило - добавляет новое правило для этого ящика;
  • Журнал - позволяет посмотреть журнал событий по данному ящику;
  • Письма - отображает все сообщения, пришедшие на этот ящик;
  • Изменить - редактирование параметров учетной записи;
  • Удалить - удаление учетной записи.
Примечание: для пользовательских почтовых ящиков доступны только два действия: Изменить и Удалить.
Название | Название ящика и ссылка на изменение его параметров.
Акт. | Признак активности почтового ящика.
Адрес сервера | Адрес почтового сервера.
Тип | Тип почтового сервера.
Сайт | Сайт, в котором данный ящик активен.
Дата изм. | Дата последнего изменения ящика.
ID | Идентификатор ящика в базе данных.


Создание и редактирование почтового ящика

Форма редактирования свойств почтового ящика служит для создания новых и редактирования уже созданных учетных записей электронной почты в системе, почтовые сообщения с которых будут приниматься. Для создания нового почтового ящика вам следует заполнить поля формы и нажать кнопку Сохранить.

Контекстная панель

Кнопка | Описание
Список почтовых ящиков | Позволяет вернуться к списку почтовых ящиков.
Добавить новый ящик | Создание нового почтового ящика, переход к форме создания ящика. Отображается только при редактировании.
Удалить данный ящик | Удаление данного ящика. Отображается только при редактировании.

Почтовый ящик (системный)

Поле | Описание
Код Код ящика, создаётся автоматически при создании.
Поле отображается при редактировании почтового ящика.
Сайт | Сайт, в котором данный ящик активен.
Активен | Признак активности почтового ящика. Если ящик не активен, он не будет применяться для чтения постовых сообщений.
*Название | Произвольное название учетной записи.
Описание | Произвольное описание почтового ящика.
Тип Выбирается тип почтового сервера:
  • Внешний POP3 сервер - прием сообщений будет происходить со внешнего POP3 сервера;
  • Внутренний SMTP сервер - прием сообщений будет происходить с внутреннего SMTP сервера.
Примечание: при выбранной опции внутренний SMTP сервер, для приема сообщений необходимо настроить DNS запись MX и запустить сервер скриптом /bitrix/modules/mail/smtpd.php.
*Почтовый сервер (POP3) / порт Адрес сервера, соединение с которым будет использоваться для получения сообщений.
Порт, к которому должно осуществляться подключение (обычно 110).
Использовать безопасное соединение (TLS) При отмеченной опции будет использоваться безопасное TLS соединение.
Примечание: для использования безопасного соединения в PHP должно быть установлено расширение OpenSSL.
Не проверять сертификат | Поле активно при отмеченной опции Использовать безопасное соединение (TLS).
*Имя входа | Имя учетной записи на вышеуказанном почтовом сервере, которому соответствует данный почтовый ящик.
*Пароль | Пароль входа на почтовый сервер для данного ящика.
Использовать безопасную (MD5) авторизацию | Вход на сервер с использованием средства шифрования паролей.
Удалять сообщения с сервера после получения Сообщения после получения и сохранения в системе будут удалены с почтового сервера. Так работает большинство почтовых программ.

Если вы хотите принимать сообщения ещё и при помощи вашей почтовой программы (напр., для архивации), не включайте эту опцию.
Проверять с периодом | Интервал времени, в минутах, для автоматической проверки новых сообщений на сервере. Для ручной проверки почты нужно установить 0 или оставить поле пустым.
*Адрес сервера / порт, звездочка (*) - все доступные адреса Адрес сервера, соединение с которым будет использоваться для получения сообщений и порт, к которому должно осуществляться подключение.
Если в поле Адрес сервера установлено "*", то будут использоваться все доступные адреса.
Доменные имена, обслуживаемые сервером (оставьте пустым, если нет ограничения по имени) | Указываются доменные имена, которые будут обслуживаться сервером. Для использования всех доступных доменных имен поле следует оставить пустым.
Пересылать сообщение получателю, если он принадлежит другому домену | При отмеченной опции сообщение будет автоматически пересылаться получателю, если он принадлежит другому домену.
Пересылать сообщение только при отправке авторизованными пользователями | При отмеченной опции пересылка сообщений будет происходить только при отправке авторизованными пользователями.
Добавить ящик и перейти к созданию правила
Шаблон создаваемого правила Выбирается шаблон создаваемого правила. Кнопка Добавить служит для добавления почтового ящика и перехода на страницу создания правила.

Поле присутствует только при добавлении нового ящика.
* - поля, обязательные для заполнения.

Дополнительные настройки

Поле | Описание
Максимальный размер пакета MySQL (MAX_ALLOWED_PACKET) | Отображается максимальный размер пакета MySQL. Вложения, превышающие этот размер будут удалены.
Максимальное количество сообщений принимаемых за одно соединение | Установка лимита на количество сообщений, принимаемых с сервера за один сеанс соединения. Если на сервере находится больше сообщений, чем предусмотрено данным параметром, оставшиеся сообщения будут приняты в ходе следующего подключения. Для неограниченного количества сообщений нужно установить 0 или оставить поле пустым.
Максимальный размер сообщения | Задается максимальный размер сообщения в килобайтах. Для неограниченного размера сообщений нужно установить 0 или оставить поле пустым.
Удалять с этого сервера письма старше | Указывается время хранения писем, после которого они будут удалены с этого сервера. Для неограниченного времени хранения сообщений нужно установить 0 или оставить поле пустым.
Кодировка, в которую конвертировать входящую почту | Задается кодировка, в которую будет конвертироваться входящая почта. Для использования той же кодировки, что и на сайте, оставьте это поле пустым.

Почтовый ящик (пользовательский)

Поле | Описание
Код | Код ящика, создаётся автоматически при создании. Поле отображается при редактировании почтового ящика.
Сайт | Сайт, в котором данный ящик активен.
Почтовый сервис | Выбирается один из созданных ранее почтовых сервисов [image] .
Активен | Признак активности почтового ящика. Если ящик не активен, он не будет применяться для чтения постовых сообщений.
*Название | Произвольное название учетной записи.
*Почтовый сервер (IMAP) / порт | Адрес сервера, соединение с которым будет использоваться для получения сообщений. Порт, к которому должно осуществляться подключение (обычно 993).
Использовать безопасное соединение (TLS) | При отмеченной опции письма будут шифроваться с помощью протокола TLS при пересылке между почтовыми серверами. Примечание: для использования безопасного соединения в PHP должно быть установлено расширение OpenSSL.
Не проверять сертификат | Поле активно при отмеченной опции Использовать безопасное соединение (TLS).
*Имя входа | Имя учетной записи на вышеуказанном почтовом сервере, которому соответствует данный почтовый ящик.
*Пароль | Пароль входа на почтовый сервер для данного ящика.
*Адрес веб-клиента | Указывается URL веб-клиента.
*Владелец | Выбирается один из пользователей сайта.
* - поля, обязательные для заполнения.

Смотрите также

  • Почтовые ящики (учебный курс "Администратор. Модули")


Правила

Форма Правила обработки почты (Сервисы > Почта > Правила) отображает созданные вами правила, которые могут быть применены к сообщениям.

Фильтр

Используется для задания параметров отбора правил, отображаемых в списке.

Поле | Описание
Название* | Отбор правил с определённым названием. Поле присутствует, даже если фильтр свернут.
ID* | Идентификатор искомого правила.
Почтовый ящик | Название почтового ящика, правила которого следует отобразить.
Активность | Отображает все правила, или только активные или не активные.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отфильтровать правила по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех сообщений нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить правило | Добавление нового правила обработки почты. В открывшемся меню выберите, какой тип правила следует добавить: ручная настройка, добавление сообщений в форумы соцсети, добавление сообщения в техподдержку, добавление события в CRM (для системы 1С-Битрикс: Корпоративный портал).
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список правил

Колонка | Описание
Колонка флажков | Выбор правил, к которым предполагается применить какое-либо действие.
Меню действий
  • Изменить - отредактировать правило;
  • Журнал - просмотреть журнал работы почтовой системы по этому правилу;
  • Удалить - удалить правило.
ID | Идентификатор правила.
Дата изм. | Дата и время последней модификации правила.
Название | Название правила и список действий, осуществляемых правилом.
Акт. | Признак активности правила.
Сорт. | Вес сортировки правила; применяется при выводе правила в списках.
Ящик. | Название почтового ящика, к которому применяется это правило.

Смотрите также

  • Правила


Создание и редактирование правила

Форма редактирования параметров правила предназначена для создания новых правил обработки почтовых сообщений и редактирования уже созданных. Для создания нового правила вам следует заполнить поля формы и нажать кнопку Сохранить.

Контекстная панель

Кнопка | Описание
Список правил | Переход на страницу со списком правил.
Добавить новое правило | Переход к форме создания нового правила. Кнопка отображается при редактировании существующего правила.
Удалить данное правило | Удаление данного ящика. Кнопка отображается при редактировании существующего правила.

Закладка Параметры

Поле | Описание
Код Код правила, под которым оно было сохранено.

Отображается при редактировании существующего правила.
Последнее изменение Дата и время последнего изменения правила.

Отображается при редактировании существующего правила.
Почтовый ящик | Почтовый ящик, к которому должно применяться это правило. Для создания нового почтового ящика, вы можете кликнуть ссылку Создать.
Активность Если этот флаг установлен, правило активно и может быть применено к сообщениям.
Если флаг не установлен, правило не применяется к сообщениям.

См. тж. поле Применять при событиях.
* Название | Любое осмысленное название данного правила.
Описание | Произвольное описание правила.
Сортировка | Вес сортировки правила; применяется при отображении правила в списке.
Применять при событиях Типы событий, при которых следует применять это правило:
  • При получении почты - если флаг установлен, правило будет применяться к каждому сообщению при получении почты с почтового ящика, для которого создано это правило. Если флаг сброшен, правило не будет автоматически применяться при получении почты;
  • При принудительном вызове правила - если флаг установлен, правило можно будет применить в ручном режиме.

* - поля, обязательные для заполнения.

Закладка Условия

Поле | Описание
Группы полей для задания условий | Задание условий предварительной фильтрации сообщений перед тем как к ним будет применено данное правило. Для получения подробной информации по полям группы см. примечания ниже.
Вероятность, что сообщение спам | Правило будет применяться только к сообщениям, параметр СПАМ коэф. которых удовлетворяет этому условию; т.е. больше или меньше уровня, задаваемого в процентах. Например, если выставить данное условие в "больше 90%", то правило будет применяться только к тем сообщениям, вероятность спама которых превышает 90%.
Размер сообщения | Правило будет применяться только к сообщениям, размер которых удовлетворяет этому условию.
Условие на PHP скрипте | Опциональный PHP скрипт, который исполняется во время определения возможности применения правила к сообщению. PHP скрипт должен определить допустимость применения правила к сообщению и вернуть значение true или false. Для получения подробной информации об этом поле см. примечания ниже.
Настройки добавления сообщения в техподдержку Эта группа настроек отображается только при создании правила с шаблоном "Добавление сообщения в техподдержку"
Определять по E-Mail ранее зарегистрированного пользователя | Если это условие установлено в да..., то при получении нового сообщения правило будет предпринимать попытки найти зарегистрированного пользователя с таким адресом в базе данных и привязать сообщение к нему. В противном случае, при получении писем с любых адресов сообщения в модуле техподдержки будут создаваться как анонимные.
Добавлять новое сообщение в уже открытое обращение | Условие определяет, сообщения с какого адреса могут быть добавлены в открытое обращение в техподдержку. При установке флага как скрытое... сообщение будет доступно только сотрудникам техподдержки.
Шаблоны темы для определения ответа на обращение | Регулярные выражения, применяемые для сортировки входящих сообщений. Поле предназначено для разработчиков; не рекомендуется изменять его значение без надобности.
Привязывать новое обращение к сайту | Указание на сайт, к которому будет привязано вновь создаваемое обращение.
Привязывать новое обращение к категории | Указание категории обращения, к которой будет привязано вновь создаваемое обращение.
Назначить новому обращению критичность | Позволяет указать критичность вновь создаваемого обращения.

Закладка Действия

Поле | Описание
Установить статус прочтенности | Позволяет отметить все сообщения, к которым будет применяться это правило, как прочитанные.
Установить пометку спам | Позволяет отметить все сообщения, к которым будет применяться это правило, как сообщения массовой рассылки.
Действие на PHP скрипте | Опциональный PHP скрипт, который исполняется во время применения правила к сообщению.
Удалить сообщение | Удаляет сообщения, к которым применяется правило.
Не обрабатывать другими правилами | Указывает, что после применения этого правила к конкретному сообщению, остальные правила не будут применены к нему, даже если сообщение удовлетворяет условиям правила.

Группы полей для задания условий

Первый выпадающий список группы содержит перечень текстовых свойств сообщения, которые являются источником информации для фильтра (операнд).

Второй выпадающий список содержит перечень компаративных операторов (операторов сравнения), определяющих тип операции сравнения, применяемой к тексту свойства, выбранного в первом списке при фильтрации. В качестве функционального оператора может быть выбран пункт Регулярное выражение. Синтаксис используемых регулярных выражений соответствует спецификации PCRE. Описание синтаксиса можно найти здесь: http://ru2.php.net/manual/en/reference.pcre.pattern.syntax.php [image].

Поле ввода текста предназначено для ввода образца текста, с которым производится сравнение текста свойства первого списка.

Пример

Для того чтобы правило применялось ко всем входящим сообщениям, в поле Тема которых присутствует слово "Заказ", установите следующие значения полей:

  • Операнд - Тема;
  • Оператор - Содержит;
  • Образец - Заказ.

Пример условия на PHP скрипте

Поставляемые возможности в большинстве случаев достаточны для задания условий отбора сообщений. Однако, если стандартные механизмы не позволяют реализовать требуемые условия отбора сообщений, предусмотрена возможность создания пользовательских программных условий отбора. Скрипт для отбора сообщений должен быть написан на языке PHP. Во время выполнения условного скрипта гарантируется валидность массива полей сообщения $arMessageFields.

Условный PHP-скрипт должен вернуть true, если условие выполняется и к сообщению может быть применено правило, или false в противном случае.

Пример

if ($arMessageFields["FIELD_PRIORITY"] > 3 || strpos($arMessageFields["FIELD_FROM"], "@bitrix") > 0)
   return true;
return false;


Журнал работы

Форма Журнал обработки почты (Сервисы > Почта > Журнал работы) отображает все события, связанные с функционированием модуля почты и получением сообщений:

  • запросы системы к почтовому серверу;
  • ответы почтового сервера;
  • применение правил и действий.

Фильтр

Используется для задания параметров отбора событий, отображаемых в журнале.

Поле | Описание
Письмо* | Поиск сообщений по их теме и краткому содержанию. Поле присутствует, даже если фильтр свернут.
Почтовый ящик | Название почтового ящика, события относительно которого следует отобразить.
Правило | Отбор всех сообщений, или только к которым было применено определённое правило.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отфильтровать сообщения по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех сообщений нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Журнал

Поле | Описание
Время | Время, в которое произошло описываемое событие.
Текст | Описание события. Запросы к серверу выделены зеленым цветом. Ответы от сервера выделены синим цветом. Описание ошибок отображается текстом красного цвета.
Ящик | Почтовый ящик, по отношению к которому произошло описываемое событие.
Правило (зависит от настроек фильтра) | Правило, примененное к сообщению.
Письмо (зависит от настроек фильтра) | Краткое содержание письма.

Смотрите также

  • Журнал работы


Письма

Форма Письма (Сервисы > Почта > Письма) отображает сообщения, полученные с существующих (добавленных вами) почтовых ящиков. Пользуясь этой формой, вы можете:

  • в форме наглядной таблицы просматривать информацию о полученных сообщениях;
  • полученные сообщения;
  • применять правила и действия к сообщениям (например, удалять сообщения, помечать сообщения как спам и пр.)

Фильтр

Используется для задания параметров отбора сообщений, отображаемых в списке.

Поле | Описание
Везде | Поиск сообщения по любому критерию. Данное поле отображается, даже если фильтр свернут.
ID | Идентификатор искомого сообщения.
Почтовый ящик | Название почтового ящика, где ищутся сообщения.
Помеченные как спам | Отбор всех сообщений, или только помеченных или не помеченных как спам.
Прочитанные сообщения | Отбор всех сообщений, или только прочитанных или не прочитанных.
От кого | Поиск по отправителю.
Кому | Поиск по получателю.
Тема | Поиск по теме письма.
Текст | Слова и фразы, которые могут содержаться в тексте (т.н. "теле") сообщения.

Чтобы отфильтровать сообщения по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех сообщений нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Получить почту | Команда получения почты с выбором почтового ящика
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из таблицы в MS Excel.

Поле Получить почту позволяет проверить наличие новых сообщений.

Список сообщений

Колонка | Описание
Колонка флажков | Выбор сообщений, к которым предполагается применить какое-либо правило или действие. Возможные правила и действия содержатся в области Обработка писем.
Тема | Тема полученного сообщения.
От кого | Отправитель сообщения. В качестве отправителя отображается имя отправителя, которое назначил себе сам отправитель.
Дата | Дата получения сообщения.
Ящик | Название почтового ящика, с которого получено данное сообщение.
Размер | Размер сообщения в байтах.
СПАМ коэф. | Относительный показатель принадлежности сообщения к спаму (сообщения массовой несанкционированной рассылки).
Влож. | Количество вложений в данном сообщении. Примечание: сообщения, отправленные в формате HTML, всегда имеют хотя бы одно вложение - само сообщение в формате HTML.

Как проверить наличие
новых сообщений

Чтобы проверить наличие новых сообщений в мини-форме Получить почту выберите интересующий вас ящик (или все ящики) и нажмите кнопку ОК.

В открывшейся промежуточной форме Получение новой почты отобразится статус проверки по каждому из ящиков и количество полученных сообщений.

Если при получении почты с какого-либо адреса возникли ошибки, статус проверки ящика будет включать ссылку Настройки почтового ящика. Перейдя по этой ссылке можно изменить свойства этого ящика (например, откорректировать пароль доступа).

Как удалить сообщения или применить
другие правила и действия к сообщениям

Для применения любого возможного действия или правила к сообщению или группе сообщений:

  1. Отметьте требуемые сообщения, обозначив их в Колонке флажков. Чтобы выделить все сообщения, поставьте флажок в заголовке таблицы.
  2. В мини-форме Обработка писем укажите, следует ли применять правило ко всем ли сообщениям или только к выделенным.
  3. Там же выберите требуемое действие, например, Удалить или Пометить как спам.
  4. Нажмите кнопку ОК.

Смотрите также

  • Письма (учебный курс "Администратор. Модули")


Просмотр сообщения

Форма просмотра сообщения служит для отображения текста и свойств выбранного сообщения. Ниже описываются поля формы.

Форма просмотра сообщения

Поле | Описание
Дата | Дата получения сообщения.
От кого | Отправитель сообщения.
Кому | Получатель сообщения.
Тема | Тема сообщения.
Прикрепленные файлы | Файлы, прикрепленные к сообщению (вложения).
Статус сообщения Мнемонический статус сообщения и индекс вероятности спама данного сообщения.
  • - у сообщения нет статуса;
  • - сообщение прочитано и не является спамом;
  • - сообщение прочитано и является спамом;
  • - сообщение не было прочитано, нет статуса;
  • - сообщение не было прочитано, не является спамом;
  • - сообщение не было прочитано, спам.
Обучить | Если вы хотите указать системе, как относиться к сообщениям, подобным тому, которое открыто в данный момент, выберите требуемое действие и нажмите кнопку Применить.
Применить ручные правила | Позволяет выбрать правила, которые обозначены как применяемые вручную, и применить их по сохранении изменений.
Удалить сообщение после обработки | Установка этого флага приведет к удалению после сохранения изменений.

Журнал обработки письма

Поле-список содержит правила и действия, которые были применены к сообщению. Поле несет исключительно информационную нагрузку.


Почтовые сервисы

Форма Почтовые сервисы (Сервисы > Почта > Почтовые сервисы) отображает сервисы электронной почты.

Фильтр

Используется для задания параметров отбора сервисов электронной почты, отображаемых в списке.

Поле | Описание
Название* | Отбор сервисов по названию.
Адрес сервера* | Отбор сервисов по адресу почтового сервера.
ID* | Идентификатор искомого почтового сервиса.
Активность | Отображает все сервисы, или только активные или не активные.
Сайт | Сайт, в котором искомый сервис активен.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отфильтровать почтовые сервисы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех почтовых сервисов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Создание и установка параметров нового почтового сервиса.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список сервисов

Колонка | Описание
Колонка флажков | Выбор сервисов, к которым предполагается применить какое-либо действие.
Меню действий
  • Изменить - редактирование параметров почтового сервиса;
  • Удалить - удаление почтового сервиса.
Название | Название сервиса.
Активность | Признак активности почтового сервиса.
Адрес сервера | Адрес почтового сервера.
Тип | Тип почтового сервера.
ID | Идентификатор сервиса в базе данных.


Создание и редактирование почтового сервиса

Форма редактирования свойств почтового сервиса служит для создания новых и редактирования уже созданных сервисов электронной почты. Для создания нового почтового сервиса вам следует заполнить поля формы и нажать кнопку Сохранить.

Контекстная панель

Кнопка | Описание
Список почтовых сервисов | Позволяет вернуться к списку почтовых сервисов.
Добавить новый сервис | Создание нового почтового сервиса, переход к форме создания сервиса. Отображается только при редактировании.
Удалить данный сервис | Удаление данного сервиса. Отображается только при редактировании.

Закладка Почтовый сервис

Поле | Описание
Код Код сервиса, создаётся автоматически при создании.
Поле отображается при редактировании почтового ящика.
Сайт | Сайт, в котором данный сервис активен.
Активен | Признак активности почтового сервиса.
Логотип | Выбирается файл с логотипом почтового сервиса.
*Название | Произвольное название почтового сервиса.
Тип При добавлении нового сервиса можно выбрать тип почтового сервера:
  • imap;
  • [dw]domain[/dw][di]Если при добавлении нового сервиса выбран тип почтового сервера domain, то в форме добавления появляются два новых поля: Доменное имя и Токен

    В эти поля вносятся данные, полученные у доменного регистратора. Уточняйте процедуру их получения у вашего регистратора. Например, о получении ПДД (Почта для домена)-токена Яндекс можно почитать здесь [image]. [/di]
Описание | Произвольное описание почтового ящика.
Почтовый сервер (IMAP) / порт Адрес сервера, соединение с которым будет использоваться для работы почты.
Порт, к которому должно осуществляться подключение.
Использовать безопасное соединение (TLS) Использование безопасного TLS соединения.
Примечание: для использования безопасного соединения в PHP должно быть установлено расширение OpenSSL.
Адрес веб-интерфейса | Указывается адрес веб-интерфейса.
Сортировка | Указывается индекс сортировки в общем списке сервисов.
* - поля, обязательные для заполнения.


Рейтинги

Вывод в публичной части функционала Рейтингов осуществляется компонентами, описанными в API документации:

Название | Имя в пространстве имен bitrix | Описание
Вывод результатов рейтинга | rating.result | Компонент предназначен для вывода результатов рейтинга. Компонент скрытый, его нельзя использовать через визуальный редактор.
Вывод рейтингового голосования | rating.vote | Компонент предназначен для вывода элементов рейтингового голосования и его текущих результатов. Компонент скрытый, его нельзя использовать через визуальный редактор.

Смотрите также:

  • Описание функционала рейтингов [image] в курсе Администратор.Базовый.


Список рейтингов

Страница Список рейтингов (Сервисы > Рейтинги > Список рейтингов) отображает обращения пользователей в службу техподдержки. С помощью этой страницы вы можете:

  • просмотреть созданные рейтинги;
  • пересчитать, редактировать и удалить рейтинги.

Фильтр

Форма фильтра используется для выбора рейтингов из списка в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Параметр | Описание
Название* | Поиск рейтингов по названию.
Активные Поле позволяет выбрать:
  • все рейтинги;
  • активные рейтинги;
  • неактивные рейтинги.
ID | Поле позволяет искать рейтинги по ID.
Оцениваемый объект* | Поле позволяет найти рейтинги по оцениваемому объекту.

* - для данных полей вы можете воспользоваться специальными логическими выражениями. Синтаксис выражений можно узнать, кликнув символ ? рядом с полем.

Контекстная панель

Кнопка | Описание
Новый рейтинг | Добавление нового рейтинга.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список рейтингов

Колонка | Описание
Колонка флажков | Выбор всех или только определённых рейтингов для применения к ним действий при помощи вспомогательной формы Действия внизу таблицы.
Меню действий При нажатии на кнопку конкретного рейтинга, отображается меню, позволяющее:
  • Изменить параметры рейтинга - отредактировать рейтинг;
  • Пересчитать рейтинг - обновить данные рейтинга;
  • Удалить рейтинг.
ID | Уникальный идентификатор рейтинга.
Название | Название рейтинга.
Создан | Дата и время создания рейтинга.
Модифицирован | Дата и время изменения (редактирования параметров) рейтинга.
Рассчитан | Дата и время последнего пересчета рейтинга.
Активен | Индикатор активности рейтинга: да или нет.
Состояние Рейтинг может находиться в одном из следующих состояний:
  • рассчитан;
  • выполняется обновление;
  • ожидает обновления.
Оцениваемый объект | Указан объект, который оценивается в данном рейтинге.

Действия над рейтингами

Вспомогательная форма Действия позволяет осуществить операции по редактированию и удалению одновременно нескольких рейтингов. Для того чтобы применить действие к рейтингам, следует пометить их галочками в левом столбце таблицы и нажать кнопку редактировать или удалить.

Предусмотрены следующие действия:

  • Редактировать - включает режим быстрого редактирования рейтингов в таблице без перехода к формам редактирования.
  • Удалить - позволяет удалить записи в таблице.


Создание/редактирование рейтинга

Данная форма - средство для редактирования и добавления рейтингов.

Контекстная панель

Кнопка | Описание
Список рейтингов | Переход на страницу со списком рейтингов.
Добавить | Переход на страницу с формой создания нового рейтинга. Кнопка отображается при редактировании уже существующего рейтинга.
Удалить | Удаление редактируемого рейтинга. Кнопка отображается при редактировании уже существующего рейтинга.

Форма редактирования

Поле | Описание
Активность | [Y|N] Флаг активности рейтинга. Активный рейтинг доступен для использования в публичной части сайта.
*Название | Название рейтинга.
*Оцениваемый объект Выберите объект, который будет оцениваться:
  • USER - пользователь, на данный момент доступен только этот объект.
  • FORUM_POST - объект в разработке.
  • BLOG_COMMENT - объект в разработке.
*Способ подсчёта Выберите способ подсчета рейтинга:
  • Сумма - рейтинг будет вычисляться как сумма всех параметров.
  • Среднее - рейтинг будет вычисляться как среднее арифметическое всех параметров.
Критерии рейтингования
Главный модуль
Голосование за пользователя [Y|N] [dw]Включите[/dw] [di] При включении данной опции станут доступны следующие поля:
Поле | Описание
Коэффициент | Поле доступно при отмеченной опции Голосование за пользователя. В данном поле устанавливается коэффициент, по которому будет выведена оценка голосования за пользователя. Итоговая оценка расчитывается по формуле: Total * K, где Total - итог голосования; K - коэффициент для итогов голосования, определяемый пользователем в данном поле.
Ограничивать по времени (дней) | Поле доступно при отмеченной опции Голосование за пользователя. В данном поле устанавливается ограничение по количеству дней для подсчета оценки. Если в ограничении указать "0", то подсчет будет производиться за всё время.
[/di] данную опцию, чтобы учитывать голосование за пользователя в текущем рейтинге.
Начальное значение рейтинга | [Y|N] [dw]Включите[/dw] [di] При включении данной опции станет доступно поле Коэффициент. В данном поле устанавливается коэффициент, который будет использоваться в оценке начального значения рейтинга. Оценка основывается на учете начального значения рейтинга (задается каждому пользователю отдельно в его настройках) и расчитывается по формуле: StartValue * K, где StartValue - начальное значение рейтинга; K - коэффициент, определяемый пользователем в данном поле. [/di] данную опцию, чтобы установить коэффициент для подсчета начального значения рейтинга.
Вкладка Форум
Голосование за темы пользователя на форумах [Y|N] [dw]Включите[/dw] [di] При включении данной опции станут доступны следующие поля:
Поле | Описание
Коэффициент | Поле доступно при отмеченной опции Голосование за темы пользователя на форумах. В данном поле устанавливается коэффициент, по которому будет выведена оценка голосования за темы пользователя на форумах. Итоговая оценка расчитывается по формуле: Total * K, где Total - итог голосования; K - коэффициент для итогов голосования, определяемый пользователем в данном поле. Если в ограничении указать "0", подсчет будет производиться за всё время.
Ограничивать по времени (дней): | Поле доступно при отмеченной опции Голосование за темы пользователя на форумах. Установите сколько дней действует возможность голосования за темы.
[/di] данную опцию, чтобы учитывать голосование за темы пользователя на форумах в текущем рейтинге.
Голосование за сообщения пользователя на форумах [Y|N] [dw]Включите[/dw] [di] При включении данной опции станут доступны следующие поля:
Поле | Описание
Коэффициент | Поле доступно при отмеченной опции Голосование за сообщения пользователя на форумах. В данном поле устанавливается коэффициент, по которому будет выведена оценка голосования за сообщения пользователя на форумах. Итоговая оценка расчитывается по формуле: Total * K, где Total - итог голосования; K - переходный коэффициент для итогов голосования, определяемый пользователем в данном поле. Если в ограничении указать "0", подсчет будет производиться за всё время.
Ограничивать по времени (дней): | Поле доступно при отмеченной опции Голосование за сообщения пользователя на форумах. Установите сколько дней действует возможность голосования за сообщения.
[/di]данную опцию, чтобы учитывать голосование за сообщения пользователя на форумах в текущем рейтинге.
Активность пользователя на форумах [Y|N][dw]Включите[/dw] [di] При включении данной опции станут доступны следующие поля:
Поле Описание
Коэф. для тем за текущий день (KT1) Оценка активности пользователя на форумах основывается на подсчёте количества тем и сообщений, созданных пользователем за текущий день, за последние семь дней и за последние тридцать дней по следующей формуле:
T1 * KT1 + T7 * KT7 + T30 * KT30 + Tall * KTall + P1 * KP1 + P7 * KP7 + P30 * KP30 + Pall * KPall
T1, T7, T30, Tall - количество тем, созданных за текущий день, за последние семь дней, за тридцать дней и за все время соответственно;

KT1, KT7, KT30, KTall - коэффициенты, определяемые пользователем для количества тем, созданных за текущий день, за последние семь, тридцать дней и за все время соответственно.

P1, P7, P30, Pall - количество сообщений, созданных за текущий день, за последние семь дней, за тридцать дней и за все время соответственно;

KP1, KP7, KP30, KPall - коэффициенты, определяемые пользователем для количества сообщений, созданных за текущий день, за последние семь дней, тридцать дней и за все время соответственно.
Коэф. для тем за последние 7 дней (KT7)
Коэф. для тем за последние 30 дней (KT30)
Коэф. для тем старше 30 дней (KTall)
Коэф. для сообщений за текущий день (KP1)
Коэф. для сообщений за последние 7 дней (KP7)
Коэф. для сообщений за последние 30 дней (KP30)
Коэф. для сообщений старше 30 дней (KPall)
[/di] данную опцию, чтобы учитывать активность пользователя на форумах в подсчете рейтинга. Только при отмеченной опции описанные ниже поля доступны.
Вкладка Блог
Голосование за сообщения пользователя в блогах [Y|N] [dw]Включите[/dw] [di] При включении данной опции станут доступны следующие поля:
Поле | Описание
Коэффициент | Поле доступно при отмеченной опции Голосование за сообщения пользователя в блогах. В данном поле устанавливается коэффициент, по которому будет выведена оценка голосования за сообщения пользователя в блогах. Итоговая оценка расчитывается по формуле: Total * K, где Total - итог голосования; K - коэффициент для итогов голосования, определяемый пользователем в данном поле. Если в ограничении указать "0", подсчет будет производиться за всё время.
Ограничивать по времени (дней): | Поле доступно при отмеченной опции Голосование за сообщения пользователя в блогах. Установите сколько дней действует возможность голосования за сообщения.
[/di] данную опцию, чтобы учитывать голосование за сообщения пользователя в блогах в текущем рейтинге.
Голосование за комментарии пользователя в блогах [Y|N] [dw]Включите[/dw] [di] При включении данной опции станут доступны следующие поля:
Поле | Описание
Коэффициент | Поле доступно при отмеченной опции Голосование за комментарии пользователя в блогах. В данном поле устанавливается коэффициент, по которому будет выведена оценка голосования за комментарии пользователя в блогах. Итоговая оценка расчитывается по формуле: Total * K, где Total - итог голосования; K - переходный коэффициент для итогов голосования, определяемый пользователем в данном поле. Если в ограничении указать "0", подсчет будет производиться за всё время.
Ограничивать по времени (дней): | Поле доступно при отмеченной опции Голосование за комментарии пользователя в блогах. Установите сколько дней действует возможность голосования за сообщения.
[/di] данную опцию, чтобы учитывать голосование за комментарии пользователя в блогах в текущем рейтинге.
Активность пользователя в блогах [Y|N] [dw]Включите[/dw] [di] При включении данной опции станут доступны следующие поля:
Поле Описание
Коэф. для сообщений за текущий день (KP1) Оценка основывается на подсчёте количества сообщений и комментариев, созданных пользователем за текущий день, за последние семь дней и за последние тридцать дней по следующей формуле:
P1 * KP1 + P7 * KP7 + P30 * KP30 + Pall * KPall + C1 * KC1 + C7 * KC7 + C30 * KC30 + Call * KCall
P1, P7, P30, Pall - количество сообщений, созданных за текущий день, за последние семь, тридцать дней и старше 30 дней соотвественно;

KP1, KP7, KP30, KPall - коэффициенты, определяемые пользователем для количества сообщений, созданных за текущий день, за последние семь, тридцать дней и старше 30 дней соотвественно.

C1, C7, C30, Call - количество комментариев, созданных за текущий день, за последние семь, тридцать дней и старше 30 дней соотвественно;

KC1, KC7, KC30, KCall - коэффициенты, определяемые пользователем для количества комментариев, созданных за текущий день, за последние семь, тридцать дней и старше 30 дней соотвественно.
Коэф. для сообщений за последние 7 дней (KP7)
Коэф. для сообщений за последние 30 дней (KP30)
Коэф. для сообщений старше 30 дней (KPall)
Коэф. для комментариев за текущий день (KC1)
Коэф. для комментариев за последние 7 дней (KC7)
Коэф. для комментариев за последние 30 дней (KC30)
Коэф. для комментариев старше 30 дней (KCall)
[/di] данную опцию, чтобы учитывать активность пользователя в блогах в подсчете рейтинга.
Вкладка Интранет
Добавочные голоса в зависимости от структуры компании [dw]Включите[/dw][di] При включении данной опции станет доступно поле Коэффициент.Вводится значение коэффициента, на который будет умножаться значение голоса пользователя.

Оценка основывается на данных рассчитанных правилом обработки "Структура компании" (правило учитывает начальное значения авторитета, которое задается каждому пользователю отдельно в его настройках).

Итоговая оценка рассчитывается по формуле: (SubordinateValue + StartValue) * K, где SubordinateValue - добавочные голоса; StartValue - начальное значение рейтинга; K - коэффициент увеличения значения в зависимости от структуры компании.

[/di] данную опцию, чтобы в рейтингах учитывался статус пользователя в зависимости от должности.
Результаты рейтинга
Рассчитывать место в рейтинге | Если данная опция установлена, то будут расчитаны места в рейтинге для всех участвующих в нем пользователей.
Использовать этот рейтинг для расчёта авторитета | Если данная опция установлена, то данный рейтинг будет использоваться для расчета авторитета пользователя.
Обнулить предыдущие результаты рейтинга после сохранения | Если данная опция установлена, то данный рейтинг будет обнуляться после каждого изменения его параметров. Опция видна только для редактируемого рейтинга.

* - поля, обязательные для заполнения.


Правила обработки

Страница Список правил (Сервисы > Рейтинги > Правила обработки) отображает все доступные правила обработки рейтингов. С помощью этой страницы вы можете:

  • просмотреть созданные правила обработки;
  • выполнить правило обработки, изменить его параметры или удалить.

Фильтр

Форма фильтра используется для выбора правил обработки из списка в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Параметр | Описание
Название* | Поиск правил обработки по названию.
Активность Поле позволяет выбрать:
  • все правила обработки;
  • активные правила;
  • неактивные правила.
ID | Поле позволяет искать правила обработки по ID.
Целевой объект* | Поле позволяет найти правила обработки по оцениваемому объекту.

* - для данных полей вы можете воспользоваться специальными логическими выражениями. Синтаксис выражений можно узнать, кликнув символ ? рядом с полем.

Контекстная панель

Кнопка | Описание
Новое правило | Добавление нового правила.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список правил

Колонка | Описание
Колонка флажков | Выбор всех или только определённых правил для применения к ним действий при помощи вспомогательной панели Действий внизу таблицы.
Меню действий При нажатии на кнопку конкретного рейтинга, отображается меню, позволяющее:
  • Изменить параметры - отредактировать правило;
  • Выполнить правило - применить данное правило;
  • Удалить - удалить правило обработки.
ID | Уникальный идентификатор правила обработки.
Название | Название правила.
Создан | Дата и время создания правила.
Модифицирован | Дата и время изменения (редактирования параметров) правила.
Применен | Дата и время последнего выполнения правила.
Активен | Индикатор активности правила: да или нет.
Целевой объект | Указан объект, к которому применяется данное правило.

Действия над правилами

Вспомогательная форма Действия позволяет осуществить операции по редактированию и удалению одновременно нескольких правил. Для того чтобы применить действие к правилам, следует пометить их галочками в левом столбце таблицы и нажать кнопку редактировать или удалить.

Предусмотрены следующие действия:

  • Редактировать - включает режим быстрого редактирования правил в таблице без перехода к форме редактирования.
  • Удалить - позволяет удалить записи в таблице.


Создание/редактирование правила обработки

Данная форма - средство для редактирования и добавления правил обработки целевого объекта на основании одного из рейтингов.

Контекстная панель

Кнопка | Описание
Список правил | Переход на страницу со списком правил.
Новое правило | Переход на страницу с формой создания нового правила обработки. Кнопка отображается при редактировании уже существующего правила.
Удалить | Удаление редактируемого правила. Кнопка отображается при редактировании уже существующего правила.

Форма редактирования

Поле | Описание
Активность | [Y|N] Флаг активности правила.
*Название | Название правила обработки.
Как активируется | Блок полей, которые задают условие выполнения правила.
*Условие | Условие, связанное со значением рейтинга пользователя. В зависимости от выбора меняются остальные поля.
Для условия Значение рейтинга. Условие связано со значением рейтинга пользователя.
Рейтинг | Выберите рейтинг из списка, к которому будет применяться правило.
Значение рейтинга Значение рейтинга устанавливается в двух полях:
  • Выбирается знак сравнения:
    • Больше или равно;
    • Меньше.
  • Устанавливается числовое значение, с которым будет сравниваться значение рейтинга. По умолчанию установлено значение 500.
Для условия Значение рейтинга (c ... по ...). Условие связано со значением рейтинга пользователя. Оно выполнится если значение рейтинга будет в указанном интервале.
Рейтинг | Выберите рейтинг из списка, к которому будет применяться правило.
Значение рейтинга | Устанавливается в двух полях: с какого и по какое значение.
Для условия Значение авторитета. Условие связано с количеством нормированных голосов за авторитет пользователя.
Кол-во нормированных голосов Устанавливается в двух полях:
  • Выбирается знак сравнения:
    • Больше или равно;
    • Меньше.
  • Устанавливается числовое значение, с которым будет сравниваться значение авторитета. По умолчанию установлено значение 1.
Для условия Значение авторитета (c ... по ...). Условие связано с количеством голосов за авторитет пользователя. Оно выполнится если кол-во нормированных голосов будет в указанном интервале.
Кол-во нормированных голосов | Устанавливается в двух полях: с какого и по какое значение.
Для условия Количество баллов за контент. Условие задает параметры когда один голос пользователя будет автоматически учтен в авторитете автора контента. То есть для голосования за пользователя не нужно заходить на его персональную страницу. Голосование за контент пользователя автоматически добавляет ему авторитет. Расчет авторитета пользователя происходит в соответствии с заданными ниже параметрами.

Для этого условия блок полей Что выполняет заменяется на блок Расчет баллов.

Учитываются голоса за последние | Авторитет будет рассчитываться за указанное число дней.
Сумма рассчитанных баллов не меньше | Устанавливается в двух полях: с какого и по какое значение.
Что выполняет | Блок полей, в которых устанавливается действие, которое будет выполнено в случае верности условия.
*Действие Это действие управляет участием пользователя в группе. Выберите нужное:
  • Добавление пользователя в группу;
  • Удаление пользователя из группы;
  • Обновление пользовательского свойства.
Для действий Добавление/удаление пользователя в группу. Условие связано с количеством голосов за авторитет пользователя. Оно выполнится если кол-во нормированных голосов будет в указанном в полях выше интервале.
Группа | При выполнении условия пользователь добавляется/удаляется в/из определенную в этом поле группу. Для выбора доступны все группы, созданные в системе.
Для действия Обновление пользовательского свойства. Действие обновляет значение пользовательского свойства.
Свойство | В выпадающем списке выберите свойство, которое обновиться.
Значение | Укажите значение, на которое должно обновиться свойство.
Расчет баллов | Блок полей, в которых задаются параметры для расчета баллов для условия Количество баллов за контент.
Голос за тему на форуме | Укажите значение для каждого из полей. С помощью этих значений вы можете отдавать предпочтения тому или иному виду контента в зависимости от направленности вашего проекта.
Голос за сообщение на форуме
Голос за сообщение в блогах
Голос за комментарий в блогах

* - поля, обязательные для заполнения.


Настройки рейтингов

Закладки

Данная форма - средство для редактирования настроек рейтингов.

Настройки рейтингов

Поле | Описание
Система расчета веса голоса Устанавливается система расчета веса голоса:
  • автоматическая - вес голоса будет рассчитываться автоматически по формулам [image].
  • настраиваемая - вес голоса будет рассчитываться по заданным параметрам.
Для расчета авторитета используется рейтинг | В выпадающем списке выберите один активных рейтингов, созданных в системе, для расчета авторитета.
Текущий размер сообщества (пользователей) | Числовой показатель, высчитывается при пересчете авторитета. В размер сообщества включаются пользователи, которые заходили на сайт не позднее 90 дней с момента расчета и имеют право голосовать (за рейтинг или авторитет).
Рассчитывать нормировочный коэффициент | Выбор ручного или автоматического расчета нормированного веса голоса (варианты выбора: Да, [dw]Нет[/dw][di]При выборе Нет становится доступной смена значения коэффициента Нормированный вес голоса. По умолчанию - 1000.[/di]).
Кол-во пользователей, за авторитет которых может голосовать пользователь в течение суток | Указывается количество пользователей.
Вес голоса за авторитет пользователя рассчитывается | Выберите, как будет рассчитываться вес голоса пользователя при голосовании за авторитет – по формуле (в зависимости от размера сообщества) или как один голос.
Кнопки голосования
Использовать оценку контента | Разрешение на вывод кнопок голосования в компонентах сайта. Централизованное включение и выключение голосования.
Тип оценки контента Выбор вариантов оценки:
  • Мне нравится. Оценка будет производится только в положительном плане. Данную оценку можно будет "забрать" обратно. При выборе этого чекбокса становятся доступными [dw]поля настройки текста кнопки.[/dw][di]
      Поля настройки текста кнопки:
    • Текст кнопки "Мне нравится" до голосования
    • Текст кнопки "Мне нравится" после голосования
    • Текст кнопки "Мне нравится" для гостей
    [/di]
  • Нравится / Не нравится. Оценка производится как в положительную сторону, так и в отрицательную. Данную оценку можно будет "забрать" обратно.
Вид кнопоки | Выберите, как будет отображаться инструмент для голосования. Виды кнопок меняются в зависимости от Типа оценки контента.
Поля настроек текстов кнопки | Доступны при выборе Типа оценки Мне нравится. Можно задать нужный текст для кнопок голосования.

Право на голосование

Поле | Описание
Пользователь может голосовать за свой контент | Указать может ли автор контента голосовать за собственный контент.
Кол-во дней отсутствия пользователя на сайте для учета в размере сообщества | Значение поля по умолчанию равно 90 дней. Вы можете его переопределить.
Автоматически включать пользователей в группу | [Y\N] Разрешает автоматическое включение новых пользователей в группу при регистрации.
Рейтинг
Группа, имеющая право голосовать за рейтинг | В данном поле указываются группы пользователей, которые могут голосовать за рейтинг контента. С помощью правил обработки вы можете настроить автоматическое включение пользователей в нужную группу по достижении определенного уровня авторитета.
Автоматически включать пользователей в группу | Указывается группа пользователей, в которую будут включаться/исключаться пользователи при достижения ими определенного уровня нормированных голосов. Значения диапазона голосов задаются в полях если кол-во нормированных голосов больше или равно и исключать если меньше.
Авторитет
Группа, имеющая право голосовать за авторитет | Здесь указываются группы пользователей, которые могут голосовать за авторитет пользователя. С помощью правил обработки вы можете настроить автоматическое включение пользователей в нужную группу по достижении определенного уровня авторитета.
Автоматически включать пользователей в группу | Указывается группа пользователей, в которую будут включаться/исключаться пользователи при достижения ими определенного уровня нормированных голосов. Значения диапазона голосов задаются в полях если кол-во нормированных голосов больше или равно и исключать если меньше.

Начальные значения

Поле | Описание
Начальный авторитет для нового пользователя | В данном поле укажите, какой начальный авторитет будет иметь пользователь после регистрации. По умолчанию, он будет получать 3 нормированных голоса, при стандартных настройках, это позволит ему сразу голосовать за рейтинг контента и за авторитет пользователя.
Установить всем пользователям начальный авторитет В данном поле вы можете выбрать начальный авторитет для всех пользователей. Эта опция создана для проектов, которые хотят запустить рейтинги на уже развитом сообществе. На основании этой настройки всем будет присвоен "Начальный авторитет":
  • равный начальному значению для новых пользователей - всем будут установлены значения, равные значению в поле "Начальный авторитет для нового пользователя" (задается в карточке пользователя [image]);
  • в зависимости от активности пользователя - всем будут установлены значения, равные активности на форумах;
  • начальное значение и активность пользователя - в качестве авторитета будет установлено Начальный авторитет + активность, т.е. первый + второй пункт;
  • не устанавливать - начальный авторитет не будет устанавливаться. Это значение настройки по умолчанию в системе.
Данные рейтингов
Удалить все данные системы рейтингования | Удаляет все голосования (за пост форума и т.д.) и сами результаты рейтинга — по сути это обнуление.


Отправить отзыв по этому разделу

Смайлы

Раздел Смайлы в ближайшее время станет единым местом в системе для хранения смайлов используемых разными модулями.

В дистрибутиве поставляется Стандартная галерея смайлов с Основным набором. Удалить Стандартную галерею и Основной набор невозможно. Редактировать состав Основного набора не рекомендуется. Разработчик оставляет за собой право в Основном наборе менять, удалять все что в нём есть.

См. также

  • Смайлы в курсе Администратор Базовый.
  • Галереи смайлов
  • Добавление и редактирование галереи
  • Наборы смайлов
  • Добавление/редактирование набора смайлов
  • Список смайлов
  • Добавление/редактирование смайла
  • Импорт архива смайлов


Галереи смайлов

Форма Галереи смайлов (Сервисы > Смайлы > Галереи и наборы) служит для просмотра имеющихся галерей смайликов и иконок и вызова формы созданий новых галерей. По умолчанию в дистрибутиве есть неудаляемая Стандартная галерея с Основным набором.

Контекстная панель

Кнопка | Описание
Новая галерея | Добавление новой галереи смайлов.
Настроить внешний вид списка Команды:
  • Настроить. Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
  • Excel. Экспорт данных из отображаемой таблицы в MS Excel.

Список галерей смайлов

Поле | Описание
Колонка флажков | Поле предназначено для выбора записей, к которым предполагается применить какое-либо правило или действие.
Действия Действия над записью:
  • Изменить - редактирование галереи;
  • Удалить - удаление галереи.
ID | Уникальный системный ID галереи.
Название | Название галереи. Отображается ссылкой с возможностью перехода к списку наборов в галерее.
Код галереи | Уникальный текстовый код галереи.
Сорт. | Вес сортировки. Определяет порядок вывода галереи в списке.
Смайлов | Суммарное число смайлов во всех наборах галереи.


Добавление и редактирование галереи

Форма служит для добавления/редактирования галереи смайлов.

Контекстная панель

Кнопка | Описание
Галереи смайлов | Возвращение к списку Галерей смайлов.
Добавить новую | Открытие формы создания галереи. (Доступно только при редактировании галереи.)
Удалить | Удаление редактируемой галереи. (Доступно только при редактировании галереи.)

Форма добавления/редактирования

Поле | Описание
Название галереи
Язык | Название галереи на определённом языке. Должны быть дано название как минимум для языка интерфейса административной части. В противном случае система присвоит набору название вида: Галерея*.
Дополнительные данные
Сортировка | Индекс сортировки, определяющий положение галереи в общем списке.
Код галереи | Осмысленное кодовое название галереи.
Смайлы из галереи | Отображение первых десяти смайлов.


Наборы смайлов

Форма Наборы смайлов (Сервисы > Смайлы > Галереи и наборы) служит для просмотра текущих наборов смайликов и иконок.

Контекстная панель

Кнопка | Описание
Галереи смайлов | Возвращение к списку Галерей смайлов.
Новый набор | Добавление нового набора смайлов.
Настроить внешний вид списка Команды:
  • Настроить. Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
  • Excel. Экспорт данных из отображаемой таблицы в MS Excel.

Список наборов смайликов

Поле | Описание
Колонка флажков | Поле предназначено для выбора записей, к которым предполагается применить какое-либо правило или действие.
Действия Действия над записью:
  • Изменить - редактирование набора;
  • Удалить - удаление набора.
ID | Уникальный системный ID набора.
Название | Название набора. Отображается ссылкой с возможностью перехода к редактированию параметров набора.
Код набора | Уникальный текстовый код набора.
Сорт. | Вес сортировки набора. Определяет порядок вывода наборов в списке.
Смайлов | Число смайлов в наборе. Отображается ссылкой с возможностью перехода к списку смайлов набора.


Добавление/редактирование набора смайлов

Форма служит для добавления/редактирования наборов смайлов.

Контекстная панель

Кнопка | Описание
Список наборов | Возвращение к списку Наборы смайлов.
Добавить новый | Открытие формы создания набора. (Доступно только при редактировании набора.)
Удалить | Удаление редактируемого набора. (Доступно только при редактировании набора.)

Форма добавления/редактирования

Поле | Описание
Название набора
Язык | Название набора на определённом языке. Должны быть дано название как минимум для языка интерфейса административной части. В противном случае система присвоит набору название вида: Набор*.
Дополнительные данные
Код набора | Осмысленное кодовое название набора.
Сортировка | Индекс сортировки, определяющий положение набора в общем списке.
Открыть импорт после создания | Установка флажка позволит перейти к форме загрузке архива смайлов. (Доступно только при создании набора)
Смайлы из набора | Отображение первых пяти смайлов из набора и ссылка для перехода к списку смайлов набора. (Доступно только при редактировании набора)


Список смайлов

Страница, на которой выводятся в общем списке все смайлы, зарегистрированные в наборах.

Контекстная панель

Кнопка | Описание
Список наборов | Возвращение к списку наборов.
Новый смайл | Создание нового смайла.
Импорт | Переход к импорту смайлов.
Настроить внешний вид списка Команды:
  • Настроить. Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
  • Excel. Экспорт данных из отображаемой таблицы в MS Excel.

Список смайликов

Название набора, к которому относится смайл.
Поле | Описание
Колонка флажков | Поле предназначено для выбора записей, к которым предполагается применить какое-либо правило или действие.
Действия Действия над записью:
  • Изменить - редактирование смайла;
  • Удалить - удаление смайла.
ID | Уникальный системный идентификатор смайлика.
Сорт. | Вес сортировки. Определяет порядок вывода смайла в списке.
Название | Название изображения, показываемое в публичной части.
Написание | Символьный эквивалент изображения.
Набор | Название набора, к которому относится смайл. Выводится в виде ссылки на список наборов.
Изображение | Само изображение смайла или иконки.
Тип | Тип изображения - смайл (выражение эмоции) или иконка (гештальт суждения).
Файл | Путь к файлу с изображением смайла.


Добавление/редактирование смайла

Форма предназначена для создания новых и редактирования уже существующих смайлов.

Контекстная панель

Кнопка | Описание
Список смайликов | Переход на страницу со списком смайликов.
Добавить новый | Открытие формы создания смайла. (Доступно только при редактировании смайла.)
Удалить | Удаление редактируемого смайла. (Доступно только при редактировании смайла.)

Форма редактирования

Поле | Описание
Тип смайлика | Укажите тип смайла: смайл или иконка.
Набор | В выпадающем списке укажите набор, к которому будет относится создаваемый смайл.
Написание | Системный код написания смайла. Можно перечислить несколько вариантов через пробел. Должно быть уникальным в рамках Галереи
Изображение | Отображение картинки смайла и указание пути до файла. (Доступно только при редактировании смайла.) Должно быть уникальным в рамках набора.
Новое изображение | Изображение смайла или иконки. Для загрузки изображения служит кнопка Добавить файл. При загрузке файла необходимо выбрать в каком разрешении создан файл.
Скрытый смайл | Установка флажка отключит изображение смайла в интерфейсе. Отправка файла станет возможной только по введению написания в тексте.
Сортировка | Вес сортировки смайлика. Определяет порядок вывода смайликов в списке.
Название смайла
Язык | Название смайла на определённом языке. Должны быть дано название как минимум для языка интерфейса административной части.
<


Импорт архива смайлов

Перед импортированием смайлов необходимо приготовить архив в формате ZIP без сжатия.

Поле | Описание
Набор | Выбор из выпадающего списка набора, к которому загружаются файлы.
Архив | Укажите путь к архиву на локальном компьютере.

Смотрите также:

  • Смайлы [image] в курсе Администратор Базовый


Социальная сеть. Описание модуля

Описание

Модуль Социальная сеть предоставляет следующие возможности:

  • создание персонального профайла пользователя с возможностью его редактирования;
  • настройка прав на доступ к содержимому личной страницы;
  • создание произвольного числа рабочих групп;
  • настройка прав на доступ к группе и содержимому ее страницы;
  • форумы, блоги, календари и фотогалереи сотрудников и рабочих групп;
  • классификация и поиск групп.

Компоненты

Модуль включает в себя следующие компоненты 2.0 продуктов «1C-Битрикс»:
Компоненты
Название | Имя в пространстве имен bitrix | Описание | Примечание
Социальная сеть (комплексный компонент) | socialnetwork | Создает полноценный публичный интерфейс социальной сети. |
Социальная сеть - группы (комплексный компонент) | socialnetwork_group | Служит для создания раздела рабочих групп социальной сети. |
Социальная сеть - пользователь (комплексный компонент) | socialnetwork_user | Служит для создания личного раздела пользователя социальной сети. |
Меню сообщений | socialnetwork.blog.menu | Выводит меню сообщений социальной сети. |
Список последних тем | socialnetwork.forum.topic.last | Выводит список последних тем форума пользователя или рабочей группы социальной сети. |
Тема (создание) | socialnetwork.forum.topic.new | Служит для сохранения новой темы форума социальной сети.. |
Тема (чтение) | socialnetwork.forum.topic.read | Выводит список сообщений темы форума социальной сети. |
Темы (список) | socialnetwork.forum.topic.list | Выводит список всех тем форума социальной сети. |
Уведомление о добавлении получателя | socialnetwork.blog.post_share.mail | Добавляет в почтовый шаблон соответствующее уведомление. |
Уведомление о записи или комментарии | socialnetwork.log.entry.mail | Добавляет в почтовый шаблон соответствующее уведомление. |
Уведомление о комментарии | socialnetwork.blog.post.comment.mail | Добавляет в почтовый шаблон соответствующее уведомление. |
Уведомление о сообщении | socialnetwork.blog.post.mail | Добавляет в почтовый шаблон соответствующее уведомление. |
Форма ввода пользователей | socialnetwork.user_search_input | Выводит форму, с помощью которой осуществляется ввод пользователей социальной сети. |
Форма создания сообщения | socialnetwork.forum.post_form | Выводит форму создания сообщения (или темы) форума социальной сети. |
Сообщения | socialnetwork.blog.blog | Выводит сообщения блога социальной сети с возможностью их фильтрации по категории и дате. |
Сообщения - модерация | socialnetwork.blog.moderation | Выводит сообщения, требующие модерации. |
Черновики сообщений | socialnetwork.blog.draft | Выводит черновики сообщений. |
Сообщение детально | socialnetwork.blog.post | Выводит подробно сообщение. |
Комментарии к сообщению | socialnetwork.blog.post.comment | Выводит комментарии к сообщению с возможностью добавления. |
Изменение профиля пользователя | socialnetwork.user_profile_edit | Позволяет изменить данные профиля пользователя социальной сети. |
Просмотр профиля пользователя | socialnetwork.user_profile | Позволяет просмотреть и изменить профиль пользователя социальной сети. |
Профиль группы | socialnetwork.group | Для просмотра и изменения профиля группы социальной сети. |
Top групп | socialnetwork.group_top | Показывает Top групп социальной сети. |
Бизнес-процессы | socialnetwork.bizproc | Выводит задания и историю по бизнес-процессам. |
Входящие сообщения | socialnetwork.messages_input | Показывает входящие сообщения социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Выход из группы | socialnetwork.user_leave_group | Позволяет выйти из группы социальной сети. |
Группы пользователя | socialnetwork.user_groups | Позволяет просмотреть и изменить группы пользователя социальной сети. |
Запрос пользователя на вступление в группу | socialnetwork.user_request_group | Позволяет пользователю отправить запрос на вступление в группу социальной сети. |
Запросы на вступление в группу (ex) | socialnetwork.group_requests.ex | Позволяет показать приглашения и запросы пользователя. |
Запросы на вступление в группу | socialnetwork.group_requests | Позволяет просмотреть и изменить запросы на вступление в группу социальной сети. | Устарел, рекомендуется socialnetwork.group_requests.ex
Запросы пользователю | socialnetwork.messages_requests | Показывает запросы пользователю социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Исходящие сообщения | socialnetwork.messages_output | Показывает исходящие сообщения социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Лог активности пользователя | socialnetwork.activity | Выводит лог активности пользователя социальной сети. | Устарел, рекомендуется socialnetwork.log.ex.
Лог изменений (ex) | socialnetwork.log.ex | Выводит запись вместе с комментариями. |
Лог изменений (entry) | socialnetwork.log.entry | Получает cписок комментариев к каждой из записей социальной сети. |
Меню профайла группы | socialnetwork.group_menu | Показывает меню профайла группы социальной сети. |
Меню профайла пользователя | socialnetwork.user_menu | Показывает меню профайла пользователя социальной сети. |
Меню сообщений пользователя | socialnetwork.messages_menu | Показывает меню сообщений пользователя социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Модераторы группы | socialnetwork.group_mods | Служит для просмотра и изменения модераторов группы социальной сети. | Устарел, рекомендуется socialnetwork.group_users.ex.
Настройка разрешений пользователя | socialnetwork.user_settings_edit | Позволяет настраивать разрешения пользователя (приватность) социальной сети. |
Настройка функционала | socialnetwork.features | Позволяет настраивать функционал пользователей и рабочих групп социальной сети. |
Обработка задания Бизнес-процесса | socialnetwork.bizproc_edit | Позволяет обработать задание бизнес-процесса. |
Переписка в виде чата | socialnetwork.messages_chat | Показывает переписку в виде чата социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Переписка с пользователем | socialnetwork.messages_users_messages | Показывает переписку с пользователем социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Переписка с пользователями | socialnetwork.messages_users | Показывает переписку с пользователями социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Подписка | socialnetwork.subscribe | Служит для настройки подписки социальной сети. | Устарел с версии 14.0 в связи с появлением Умного слежения в Живой ленте.
Поиск групп | socialnetwork.group_search | Создает страницу поиска рабочих групп. |
Поиск пользователей | socialnetwork.user_search | Позволяет искать пользователей социальной сети. |
Показ событий | socialnetwork.events | Показывает события: новое сообщение, запрос на добавление в список друзей и пр. социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Показ событий (ajax) | socialnetwork.events_dyn | Показывает события с помощью AJAX: новое сообщение, запрос на добавление в список друзей и пр. социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Пользователи группы | socialnetwork.group_users | Служит для просмотра и изменения пользователей группы социальной сети. | Устарел, рекомендуется socialnetwork.group_users.ex.
Пользователи группы (расширенный) | socialnetwork.group_users.ex | Служит для просмотра и изменения пользователей группы социальной сети. |
Друзья пользователя (расширенный) | socialnetwork.user_friends.ex | Служит для просмотра и изменения друзей пользователя группы социальной сети. |
Приглашение пользователей в группу | socialnetwork.group_request_search | Служит для приглашения пользователей в группу социальной сети. | Устарел, рекомендуется socialnetwork.group_create.ex
Приглашения на вступление в группу | socialnetwork.group_requests_out | Позволяет просмотреть и изменить приглашения на вступление в группу социальной сети. | Устарел, рекомендуется socialnetwork.group_requests.ex
Создание группы | socialnetwork.group_create | Позволяет создать новую (редактировать уже существующую) группу социальной сети. | Устарел, рекомендуется socialnetwork.group_create.ex
Создание группы в попап-диалоге | socialnetwork.group.iframe.popup | Позволяет создать новую группу в попап-диалоге. |
Создание группы в попап-диалоге (ex) | socialnetwork.group_create.ex | Позволяет создать новую группу в попап-диалоге. |
Список подписки пользователя | socialnetwork.subscribe_list | Позволяет показать список подписки пользователя социальной сети. | Устарел с версии 14.0 в связи с появлением Умного слежения в Живой ленте.
Удаление группы | socialnetwork.group_delete | Служит для удаления группы социальной сети. |
Форма отправки сообщения | socialnetwork.message_form | Позволяет отправить сообщение пользователю социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Форма приглашения пользователя вступить в группу | socialnetwork.group_request_user | Создает форму приглашения пользователю вступить в группу социальной сети. | Устарел, рекомендуется socialnetwork.group_create.ex.
Черный список группы | socialnetwork.group_ban | Служит для просмотра и изменения черного списка группы социальной сети. |
Редактирование сообщения | socialnetwork.blog.post.edit | Позволяет редактировать/создавать сообщения. |
RSS блогов | socialnetwork.blog.rss | Выводит RSS блогов группы или сайта в заданном формате. |
Используются только в БУС
Друзья пользователя | socialnetwork.user_friends | Позволяет просмотреть и изменить друзей пользователя социальной сети. | Не используется на КП. Устарел, рекомендуется socialnetwork.user_friends.ex
Дни рождения друзей | socialnetwork.user_birthday | Выводит ближайшие дни рождения друзей пользователя социальной сети. | Не используется на КП.
Добавление друга | socialnetwork.user_friends_add | Позволяет отправить запрос на добавление друга социальной сети. | Не используется на КП.
Удаление друга | socialnetwork.user_friends_delete | Позволяет удалить друга социальной сети. | Не используется на КП.
Черный список пользователя | socialnetwork.user_ban | Служит для просмотра и изменения черного списка пользователя социальной сети. | Не используется на КП.
Используются только на КП
Живая лента (мобильная, ex) | mobile.socialnetwork.log.ex | Отображает Живую ленту в формате для мобильных устройств. |
Живая лента (мобильная) | mobile.socialnetwork.log | Отображает Живую ленту в формате для мобильных устройств. |
Сообщение Живой ленты (мобильной) | mobile.socialnetwork.log.entry | Отображает сообщение Живой ленты в формате для мобильных устройств. |

Смотрите также

  • Документация для разработчиков по модулю Социальная сеть


Социальная сеть. Настройки модуля

Закладки

Форма настроек модуля Социальная сеть (Настройки > Настройки продукта > Настройки модулей > Социальная сеть) предназначена для задания общесистемных параметров модуля.

Настройки модуля социальной сети

Поле | Описание
Глобальные настройки модуля социальной сети
Следить за всеми сообщениями Живой ленты по умолчанию | При отмеченной опции в социальной сети каждое новое событие (комментарий, сообщение, загрузка файла, вступление в группу и т.п) будет "поднимать" данное событие наверх Живой ленты. Чтобы не следить за событием, пользователь сам решает следить или нет с помощью кнопки Больше не следить под сообщением Живой ленты. При отключенной опции, чтобы следить за событием, необходимо нажать кнопку Следить под нужным сообщением Живой ленты.
Разрешать адресовать "Всем" сообщения в Живой ленте | При отмеченной опции появляется возможность указать пользователей или группы пользователей, которым разрешено адресовать сообщения для всех пользователей портала.
Отображать адресацию "Всем" по умолчанию При отмеченной опции будет включена адресация "Всем" по умолчанию при создании сообщения.

Примечание: Опция появляется при включенной опции "Разрешать адресовать "Всем" сообщения в Живой ленте".

Отображать всех почтовых получателей При создании почтового сообщения из Живой ленты при выборе получателей эти получатели будут видны всем пользователям портала.

Примечание: Необходимо установка модуля Экстранет.

Отображать в Живой ленте по умолчанию только мои записи, записи моих групп и адресованные лично мне При отмеченной опции в социальной сети включается режим, при котором выбираются только записи, относящиеся к рабочим группам пользователя, а также его собственные или адресованные лично ему.

Режим включается/выключается как глобально, так и каждым пользователем в Живой ленте (пункт Только мои группы в меню Все сообщения).

Примечание: Опция доступна только для «1С-Битрикс: Управление сайтом».

Общие настройки по сайту (сайтам)
Разрешить функционал друзей | При отмеченной опции в социальной сети будет доступен функционал Друзья.
Разрешить функционал всплывающей информационной карточки | При отмеченной опции в социальной сети будет доступен функционал Информационная карточка - всплывающий тултип при наведении на пользователя с его основными данными.
Шаблон пути для темы групп Указывается шаблон пути к странице с темами рабочих групп.

Примечание: Опция доступна только для «Битрикс24 в коробке».

Шаблон пути для группы | Указывается шаблон пути к странице просмотра рабочих групп.
Путь к странице сообщений пользователя | Указывается путь к странице сообщений пользователя.
Свойства пользователя для показа во всплывающей информационной карточке Задаются свойства пользователя, которые будут отображаться во всплывающей информационной карточке.

Для выбора нескольких разделов необходимо удерживать клавишу Ctrl.
Доп. свойства пользователя для показа во всплывающей информационной карточке Задаются дополнительные свойства пользователя, которые будут отображаться во всплывающей информационной карточке.

Для выбора нескольких разделов необходимо удерживать клавишу Ctrl.
Выводить рейтинг во всплывающей информационной карточке | При отмеченной опции в всплывающей информационной карточке будет выводится рейтинг пользователя.
Использовать рейтинг | Задаются виды рейтинга, используемые для оценки пользователя.
Настройки для пользователей по сайту (сайтам)
Кто может смотреть моих друзей Указывается кто может смотреть моих друзей в социальной сети:
  • Только я;
  • Только друзья;
  • Только друзья и друзья друзей;
  • Авторизованные пользователи;
  • Все посетители.
Кто может смотреть мои группы Указывается кто может смотреть мои группы в социальной сети:
  • Только я;
  • Только друзья;
  • Только друзья и друзья друзей;
  • Авторизованные пользователи;
  • Все посетители.
Кто может смотреть мою страницу Указывается кто может смотреть мою страницу в социальной сети:
  • Только я;
  • Только друзья;
  • Только друзья и друзья друзей;
  • Авторизованные пользователи;
  • Все посетители.
Разрешить функционал форума для пользователей | При отмеченной опции в социальной сети будет доступен функционал форума для пользователей.
Разрешить функционал фотогалереи для пользователей | При отмеченной опции в социальной сети будет доступен функционал фотогалереи для пользователей.
Разрешить функционал поиска для пользователей | При отмеченной опции в социальной сети будет доступен функционал поиска для пользователей.
Разрешить функционал файлов для пользователей: При отмеченной опции в социальной сети будет доступен функционал файлов для пользователей.

Примечание: Опция доступна только для «Битрикс24 в коробке».

Разрешить функционал календаря для пользователей: При отмеченной опции в социальной сети будет доступен функционал календарей для пользователей.

Примечание: Опция доступна только для «Битрикс24 в коробке».

Разрешить функционал задач для пользователей: При отмеченной опции в социальной сети будет доступен функционал задач для пользователей.

Примечание: Опция доступна только для «Битрикс24 в коробке».

Задается уровень приватности пользователей по умолчанию:
  • Только я;
  • Только друзья;
  • Только друзья и друзья друзей;
  • Авторизованные пользователи;
  • Все посетители.
для каждой настройки следующего функционала:
Функционал Настройка
Форум Кто может управлять форумом;
Кто может создавать новые темы;
Кто может создавать сообщения;
Кто может просматривать форум.
Сообщения Кто может просматривать сообщения;
Кто может просматривать комментарии;
Кто может писать комментарии с премодерацией;
Кто может писать комментарии;
Фотогалерея Кто может изменять фотогалерею;
Кто может просматривать фотогалерею.
Поиск Кто может осуществлять поиск по контенту профиля пользователя.
Файлы Кто может просматривать файлы;
Кто может изменять свои файлы;
Кто может изменять все файлы.

Примечание: Данный функционал доступен только для «Битрикс24 в коробке».

Календарь Кто может изменять календарь;
Кто может просматривать календарь.

Примечание: Данный функционал доступен только для «Битрикс24 в коробке».

Задачи Кто может просматривать свои задачи;
Кто может просматривать все задачи;
Кто может создавать задачи;
Кто может изменять все задачи;
Кто может удалять все задачи;
Кто может изменять папки;
Кто может изменять общие представления.

Примечание: Данный функционал доступен только для «Битрикс24 в коробке».
Задается изображение по умолчанию для пользователей:
  • мужчина;
  • женщина;
  • пол не задан.
Настройки для групп по сайту (сайтам)
Разрешить функционал форума для групп | При отмеченной опции в социальной сети будет доступен функционал форума для групп.
Разрешить функционал сообщений для групп | При отмеченной опции в социальной сети будет доступен функционал блогов для групп.
Разрешить функционал фотогалереи для групп | При отмеченной опции в социальной сети будет доступен функционал фотогалереи для групп.
Разрешить функционал файлов для групп При отмеченной опции в социальной сети будет доступен функционал файлов для групп.

Примечание: Опция доступна только для «Битрикс24 в коробке».

Разрешить функционал календаря для групп При отмеченной опции в социальной сети будет доступен функционал календаря для групп.

Примечание: Опция доступна только для «Битрикс24 в коробке».

Разрешить функционал задач для групп При отмеченной опции в социальной сети будет доступен функционал задач для групп.

Примечание: Опция доступна только для «Битрикс24 в коробке».

Разрешить функционал поиска для групп | При отмеченной опции в социальной сети будет доступен функционал поиска для групп.
Разрешить работать с контентом архивных групп | При отмеченной опции в социальной сети будет разрешена работа с контентом архивных групп.
Задается уровень приватности групп по умолчанию:
  • Только владелец группы;
  • Владелец группы и модераторы группы;
  • Все члены группы;
  • Авторизованные пользователи;
  • Все посетители.
для каждой настройки следующего функционала:
Функционал Настройка
Форум Кто может управлять форумом;
Кто может создавать новые темы;
Кто может создавать сообщения;
Кто может просматривать форум.
Сообщения Кто может просматривать сообщения;
Кто может писать сообщения с премодерацией;
Кто может писать сообщения;
Кто может модерировать сообщения;
Кто может управлять сообщениями;
Кто может просматривать комментарии;
Кто может писать комментарии с премодерацией;
Кто может писать комментарии;
Кто может модерировать комментарии;
Кто может управлять комментариями.
Фотогалерея Кто может изменять фотогалерею;
Кто может просматривать фотогалерею.
Файлы Кто может просматривать файлы;
Кто может изменять свои файлы;
Кто может изменять все файлы.

Примечание: Данный функционал доступен только для «Битрикс24 в коробке».

Календарь Кто может изменять календарь;
Кто может просматривать календарь.

Примечание: Данный функционал доступен только для «Битрикс24 в коробке».

Задачи Кто может просматривать свои задачи;
Кто может просматривать все задачи;
Кто может создавать задачи;
Кто может изменять все задачи;
Кто может удалять все задачи;
Кто может изменять папки;
Кто может изменять общие представления.

Примечание: Данный функционал доступен только для «Битрикс24 в коробке».

Поиск Кто может осуществлять поиск по контенту профиля пользователя.
Включать по умолчанию в создаваемых группах, если функционал разрешен? При включенной опции в создаваемой группе данный функционал (Форум, Сообщения, Фотогалерея, Файлы, Календарь, Задачи, Поиск) по умолчанию будет включен.
Изображение по умолчанию Указывается изображение, которое будет использоваться в качестве иконки для группы по умолчанию.

Права на доступ

Закладка позволяет настроить права на доступ к модулю для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Социальная сеть:
  • [D] работа в публичной части без права создания групп - просмотр страниц социальной сети с возможностью редактирования своего профиля без права создания рабочих групп;
  • [K] работа в публичной части с правом создания групп - просмотр страниц социальной сети с возможностью редактирования своего профиля с правом создания рабочих групп;
  • [R] просмотр административной части - управление социальной сетью в публичном разделе и просмотр административной части без права модификаций;
  • [W] полный доступ - полный доступ к ресурсам модуля.
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.

Примечание: Уровни прав доступа модуля Работа в публичной части с правом создания групп и Полный доступ можно разделять по сайтам. Если в портале используется многодепартаментность или в сайт менеджере многосайтовость, то администратор соцсети одного сайта (департамента) сможет иметь полный доступ или право на создание групп в рамках соцсети этого сайта, а на другом сайте он будет иметь права в соответствии с настройками групп соцсети.


Темы групп

На странице Темы групп (Сервисы > Социальная сеть > Темы) представлена таблица со списком тем групп. Она служит для добавления новых тем групп, а также для перехода к управлению их параметрами.

Фильтр

С помощью формы выполняется поиск тем групп в соответствии с указанными условиями.

Параметр | Описание
Сайт* | Указывается сайт для поиска тем групп, либо поиск будет выполнен по всем сайтам. Поле присутствует, даже если фильтр свернут.
Название* | Указывается тема группы, по которой будет проходить поиск, либо поиск будет выполнен по всем темам.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Для того чтобы отобрать темы групп по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех тем групп нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Новая тема | Переход к форме создания новой темы.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из таблицы в MS Excel.

Список тем групп

Поле | Описание
Колонка флажков | Поле для выбора темы групп, к которым предполагается применить какое-либо правило или действие.
Действия Действия над темами:
  • Изменить параметры темы - переход к форме редактирования темы;
  • Удалить тему - удаление темы.
ID | Идентификатор темы.
Название | Имя темы групп.
Сайт | Имя сайта, к которому привязана тема.
Сорт. | Индекс сортировки темы.


Создание и редактирование темы групп

Контекстная панель

Кнопка | Описание
Список тем | Переход на страницу со списком тем групп.
Новая тема | Переход к форме создания новой темы. Кнопка отображается при редактировании существующей темы.
Удалить тему | Удаление редактируемой темы. Кнопка отображается при редактировании существующей темы.

Параметры темы групп

Поле | Описание
ID | Идентификатор темы. Отображается при редактировании существующей темы.
*Название темы | Название темы рабочих групп.
*Сайт темы | Сайт, на котором будут доступны группы даннной темы.
Сортировка | Индекс сортировки темы.

* - поля, обязательные для заполнения.

Смотрите также

  • Управление темами групп


Смайлы

На странице Смайлики социальной сети (Сервисы > Социальная сеть > Смайлы) представлена таблица, содержащая список смайликов. Она служит для добавления новых смайлов, а также для перехода к редактированию существующих.

Контекстная панель

Кнопка | Описание
Новый смайлик | Переход к форме создания нового смайлика.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из таблицы в MS Excel.

Список смайлов

Поле | Описание
Колонка флажков | Выбор смайлика, к которому предполагается применить какое-либо правило или действие.
Действия Действия над смайликами:
  • Изменить параметры смайлика - переход к форме редактирования смайлика;
  • Удалить смайлик - удаление смайлика.
Код | Уникальный код смайлика.
Сорт. | Относительный "вес", определяющий положение смайлика в списке. Чем меньше значение, тем выше в списке показывается смайлик.
Тип | Тип смайлика: смайлик или иконка.
Название | Название смайлика.
Написание | Написание смайлика.
Изображение | Изображение смайлика.


Создание и редактирование смайлика

Контекстная панель

Кнопка | Описание
Список смайликов | Переход на страницу, содержащую список смайлов.
Добавить новый смайлик | Переход к форме создания нового смайлика. Кнопка отображается при редактировании существующего смайлика.
Удалить смайлик | Удаление смайлика. Кнопка отображается при редактировании существующего смайлика.

Форма редактирования

Поле | Описание
Код Уникальный код смайлика.

Поле отображается только при редактировании существующей записи о клиенте и изменению не подлежит.
Сортировка | Указывается относительный "вес", определяющий положение смайлика в списке. Чем меньше значение, тем выше в списке показывается смайлик.
Тип смайлика Из выпадающего списка выбирается тип смайлика:
  • смайлик;
  • иконка.
Написание смайлика | Написание смайлика (изображение смайлика символами). Можно перечислить несколько вариантов через пробел.
Изображение смайлика | С помощью кнопки Обзор указывается изображение смайлика. Рекомендуемый размер смайликов: 16x16 пикселов, иконок: 15x15 пикселов.
Язык интерфейса
Название* | Для каждого языка задается название смайлика.

* - поля, обязательные для заполнения.

Смотрите также

  • Смайлы социальной сети (учебный курс "Администратор. Модули")


Социальные сервисы

Описание

Начиная с 10 версии, появилась возможность авторизации на сайтах, работающих под управлением «1С-Битрикс: Управление сайтом» и «Битрикс24 в коробке», с помощью социальных сетей ВКонтакте, Twitter, МойМир@Mail.Ru и других внешних сервисов авторизации. Благодаря этой новинке владельцы сайтов могут предоставить своим пользователям возможность авторизоваться под уже существующим аккаунтом социальной сети.

Нажмите на рисунок, чтобы увеличить

Пользователю не придется вводить свои данные, если он уже зарегистрирован в одном из сервисов: Яндекс, Livejournal, Mail.Ru, Google, Liveinternet, Blogger, Rambler. Просто выбирается один из этих сервисов при регистрации, и система запоминает нового пользователя на сайте со всеми его данными, скажем, Вконтакте:

Более того, эти данные аккаунта соцсети будут использованы в процессе покупки в интернет-магазинах.

Смотрите также

  • Социальные сервисы (учебный курс "Администратор. Модули")
  • Социальные сервисы (учебный курс "Администратор сервиса Битрикс24" (коробочная версия)).


Социальные сервисы. Настройки модуля

Форма настроек модуля Социальные сервисы (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы) предназначена для задания общесистемных параметров модуля для сервисов социальных сетей и систем авторизации.

Закладка Общие

Поле | Описание
Общие настройки для всех сайтов
Разрешить отправку активностей пользователей в социальные сети | Регулируется возможность отправки активности пользователя в социальные сети Twitter и Facebook*. Примечание: предварительно нужно настроить сервисы Twitter и Facebook*, а также пользователь должен связать свой аккаунт с аккаунтами данных соцсетей в Профиле пользователя в публичной части сайта. Опция доступна только в «Битрикс24 в коробке». * деятельность организации запрещена в Российской Федерации.
Транслировать твиты пользователей с хештегом в живую ленту | Указываются twitter-хештег, с которым будут транслироваться твиты пользователя в живую ленту. Примечание: предварительно нужно настроить сервис Twitter, а также пользователь должен связать свой аккаунт с twitter-аккаунтом в Профиле пользователя в публичной части сайта.
Внешние сервисы
Список сервисов | Указываются необходимые сервисы для авторизации на сайте.
Настройки <сервис>
Если данный сервис требует регистрации сайта в своей системе, то указываются в соответствующих полях уникальные идентификаторы и секретные ключи, которые необходимо предварительно получить. Как получить эти данные указано в ссылках под каждым сервисом.

Закладка <сайт>

Поле | Описание
Настройки для <сайта>
Применить индивидуальные настройки для этого сайта | При отмеченной опции для данного сайта будут применяться свои настройки авторизации с помощью социальных сервисов.
Внешние сервисы
Список сервисов | Указываются необходимые сервисы для авторизации на сайте.
Настройки <сервис>
Если данный сервис требует регистрации сайта в своей системе, то указываются в соответствующих полях уникальные идентификаторы и секретные ключи, которые необходимо предварительно получить. Как получить эти данные указано в ссылках под каждым сервисом.

Регистрация и авторизация

Поле | Описание
Регистрация новых пользователей | Показывается разрешено ли посетителям самостоятельно регистрироваться на сайте. За это отвечает опция Позволять ли пользователям регистрироваться самостоятельно? в настройках Главного модуля
Разрешить регистрацию новых пользователей через соцсети | При отмеченной опции разрешается регистрации новых пользователей на сайте через социальные сети. В противном случае можно будет только авторизовываться с помощью аккаунтов соцсетей, предварительно привязанных к профилю пользователя.
Группы пользователей, которым запрещена авторизация через соцсервисы | Указываются группы пользователей, которым запрещена авторизация через соцсервисы.
Группы пользователей, которым запрещена привязка соцсервисов | Указываются группы пользователей, которым запрещена привязка соцсервисов в своем профиле.

Шифрование токенов авторизации

Поле | Описание
Включить шифрование токенов авторизации | Функция включает хранение авторизационных токенов пользователей социальных сервисов в зашифрованном виде. После включения функции на закладке Шифрование будет отображен статус: Шифрование токенов авторизации активировано. Примечание: Действие необратимо. Отключить шифрование невозможно. Доступно с версии 19.0.100 модуля. На новых установках шифрование включено автоматически, что отобразит указанный выше статус.


Настройки стикеров

Функционал веб-стикеров позволяет создавать заметки прямо поверх сайта. Причем заметку можно привязать к какой-то области на странице, выделив ее курсором мыши, или к элементам страницы (меню, новостям, ссылкам и прочему). Также можно изменять цвет, форматировать текст и давать прямую ссылку другим пользователям на ваш стикер. При переходе по этой ссылке окно браузера прокрутится до нужной заметки.

Примечание: Подробнее про работу со стикерами смотрите в курсе Контент-менеджер.

Форма Права доступа для стикеров (Сервисы > Стикеры) предназначена для настройки прав доступа для стикеров. Для удобства работы форма разделена на закладки, на каждой из которых выполняется настройка определённой группы параметров.

Закладка Настройки

Закладка предназначена для настройки общих параметров стикеров.

Поле | Описание
Скрывать нижнюю панель с кнопками у стикеров | При отмеченной опции нижняя панель с кнопками будет автоматически скрываться.
Использовать комбинации горячих клавиш для добавления Веб-стикеров | При отмеченной опции для стикеров будут доступны комбинации горячих клавиш, которые будут также отображены рядом с пунктами меню кнопки Наклеить стикер панели управления.
Стартовые размеры стикера на странице (ширина х высота, в px) | Выбираются начальные размеры стикера, которые будут использованы при его создании.
Удалить все стикеры | Ссылка позволяет удалить все стикеры.

Закладка Доступ

Закладка позволяет настроить права на доступ к функционалу веб-стикеров для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право по умолчанию.
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа:
  • [D] Доступ закрыт - доступ к функционалу веб-стикеров закрыт;
  • [R] Просмотр стикеров - разрешается только просмотр веб-стикеров;
  • [W] Редактирование стикеров - разрешается создание и редактирование веб-стикеров.
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.

Примечание: для того чтобы пользователи могли работать с функционалом веб-стикеров, убедитесь что они принадлежат к группе, у которой есть доступ к модулю "Управление структурой", а также доступ на чтение для файлов в папке /bitrix/admin/.


Техподдержка. Описание модуля

Описание

Современный веб-портал, будь то информационный сайт или интернет-магазин, насыщен разнообразными функциями, сориентироваться в которых посетителю бывает порой непросто. Кроме того, многие производственные компании хотели бы иметь возможность оперативно отвечать на вопросы клиентов, тем самым поддерживая свою репутацию. Особенно это касается веб-порталов, ориентированных на консультирование клиентов в онлайновом режиме по вопросам функционирования программного обеспечения, технических устройств и т.п. Правильно организованный сайт должен обладать способностью быстро реагировать на возможные вопросы клиентов, относя вопросы в соответствии с их тематикой тем или иным сотрудникам, обеспечивающим бизнес-процессы сайта.

Модуль Техподдержка позволяет организовать на вашем сайте систему обращений посетителей к группе, ответственной за консультирование и техподдержку клиентов вашей компании.

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Мастер создания обращения | iblock.wizard | Формирует разделы мастера на основе секций инфоблока и вопросы на основе элементов инфоблока.
Техподдержка (комплексный компонент) | support.ticket | Создает полноценную систему техподдержки, с помощью которой можно просмотреть список обращений, добавить своё сообщение или написать новое обращение в техподдержку.
Создание нового, либо редактирование существующего обращения | support.ticket.edit | Предназначен для вывода формы редактирования существующего обращения либо создания нового.
Список обращений | support.ticket.list | Предназначен для вывода формы фильтра и списка обращений в техподдержку.
Техподдержка с мастером (комплексный компонент) | support.wizard | Служит для организации полноценного публичного интерфейса технической поддержки, создание обращения в котором выполняется с помощью специального мастера.

Смотрите также

  • Как сделать так, чтобы обращение в техподдержку создавалось из письма пользователя
  • Как ответить на обращение в техподдержку
  • Работа со справочниками техподдержки
  • Создание уровня техподдержки
  • Создание публичного интерфейса техподдержки на сайте
  • Добавление расписания работы техподдержки
  • Создание группы сотрудников техподдержки
  • Создание группы клиентов техподдержки


Техподдержка. Настройки модуля

Форма настроек модуля Техподдержка (Настройки > Настройки продукта > Настройки модулей > Техподдержка) предназначена для задания общесистемных параметров модуля.

Закладка Настройки

Поле | Описание
Каталог техподдержки (#SITE_DIR# - корневой каталог сайта) | Указывается путь к скриптам техподдержки в публичной части. При задании пути допустимо использование макроса #SITE_DIR#.
Страница редактирования обращения (относительно каталога техподдержки) | Указывается путь к странице редактирования обращения в техдержку в публичной части сайта относительно каталога техподдержки.
Макс. размер загружаемых файлов (Кб) | Указывается максимальный размер загружаемых файлов (в килобайтах) для пользователей не входящих в группу техподдержки.
Значение по умолчанию для флага "Сообщение скрыть, автора не оповещать" | При отмеченной опции при редактировании обращения флаг Сообщение скрывать, автора не оповещать будет установлен по умолчанию.
Ответственный по умолчанию для новых обращений При создании нового обращения не сотрудником техподдержки, ответственный может быть выбран в зависимости от категории, критичности или источника обращения (подобные зависимости настраиваются в справочнике техподдержки).

Если ответственный не был определён, то назначается ответственный по умолчанию, который в свою очередь выбирается в данном поле.
Значение по умолчанию для поля "Закрыть при отсутствии ответа через" | Если пользователь не выбрал иное количество дней, по истечении которых обращение будет автоматически закрыто, используется значение, указанное в данном поле.
Режим по умолчанию при просмотре обращения Указывается режим, в котором обращение будет открыто при просмотре:
  • не использовать режимы;
  • просмотр;
  • ответ.
Выводить данные в публичных компонентах по пользователям просматривавших обращение за последние | Указывается количество минут, по истечении которых не выводится информацию о пользователе просмотревшем обращение.
Как часто автоматически обновлять область "Сейчас в обращении" в административной части Каждое обращение содержит особую область, показывающую, какие пользователи в настоящее время просматривают или редактируют обращение. Очевидно, что обращение может быть открыто во время его просмотра другими пользователями.

Указывается время, через которое область с пользователями, просматривающими обращение, будет обновлена.
Количество сообщений на одной странице (для административной части) | Указывается количество сообщений обращения, отображаемых на одной странице в административной части.
Формат купона (# заменяется на случайный символ) | Указывается формат купона (например, SUP-COU-##########, где # заменяется на случайный символ. Например: SUP-COU-1111111111).
Уровень поддержки по умолчанию для купонов | Указывается уровень поддержки для купонов по умолчанию.
Уровень поддержки по умолчанию | Указывается уровень поддержки для обращений по умолчанию.
SLA и Категории | Выбирается способ настройки категорий обращений в соответствии с уровнями поддержки (SLA).
Источник для обращений, сформированных из электронной почты | Указывается источник для обращений, сформированных из электронной почты, например, E-mail.
Максимальное время одного шага в секундах | Указывается максимальный шаг переиндексации обращений для поиска.
Кэшировать расписание на дней назад ( максимальное время реакции + максимальное время закрытия обращения + 1 | Указывается на сколько дней назад кешировать расписание.
Кэшировать расписание на дней вперед ( максимальное время реакции + 1 ) | Указывается на сколько дней вперед кешировать расписание.
Перезапустить агентов | Ссылка перезапуска агентов.

Закладка Доступ

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Техподдержка:
  • [D] доступ закрыт - доступ к меню и административным файлам модуля закрыт, пользователь не может создавать обращения;
  • [R] клиент техподдержки - доступ к странице Обращения административного меню открыт, в административных и публичных файлах разрешено создание и редактирование своих обращений;
  • [T] сотрудник техподдержки - доступ ко всем пунктам меню и страницам модуля открыт, пользователь работает с теми обращениями, за которые он ответственен;
  • [V] демо-доступ - пользователь может только просматривать все обращения;
  • [W] администратор техподдержки - пользователь может редактировать справочник техподдержки и любое обращение.

Служебные процедуры

Поле | Описание
Интервал | Устанавливается интервал переиндексации в секундах.
Начать | Кнопка начала переиндексации обращений.


Рабочий стол

Рабочий стол (Сервисы > Техподдержка > Рабочий стол) содержит набор сводных отчетов по работе службы техподдержки. Сводные отчеты реализованы при помощи обзорных таблиц, отображающих количество назначенных, закрытых и открытых обращений:

  • по ответственным сотрудникам службы;
  • по критичности;
  • по текущему статусу;
  • по сложности;
  • по категории;
  • по источнику обращения;
  • по оценкам ответов на обращения;
  • по уровням поддержки.

Фильтр

Используется для задания параметров отбора элементов отчетов. С его помощью можно легко найти любое обращение за период времени, а также обращения, отнесенные к конкретному сотруднику.

Параметр | Описание
Период (DD.MM.YYYY) | Диапазон дат, запросы и ответы в службу техподдержки за которые следует показать. Вы можете выбрать либо количество дней от текущего дня, либо установить диапазон с помощью календарей. Поле присутствует, даже если фильтр свернут.
Сайты | Сайты, по которым требуется отобразить информацию.
Ответственный | При наличии прав администратора техподдержки вы можете отфильтровать отчет по любому сотруднику техподдержки; то есть, включить в отчет только обращения и ответы от конкретного сотрудника. Также вы можете задать для поиска имя сотрудника, полное или частичное. Для точного поиска по строке поиска, отметьте опцию точного поиска рядом с полем ввода. Можно использовать специальные логические выражения. Синтаксис выражений можно узнать, кликнув символ ? рядом с полем.

Чтобы отфильтровать отчеты по заданным критериям поиска, нажмите кнопку Найти. Для отображения полных отчетов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Показать сообщения | При включенной опции (да) отображается колонка Сообщения.

Сводные отчеты

Все отчеты показывают количество открытых и закрытых обращений. Открытые обращения ранжированы в соответствии с их источником:

- последний раз в обращение писал оппонент;
- последний раз в обращение писал сотрудник техподдержки;
- обращение закрыто.

Ответственный

Отчет показывает количество открытых и закрытых обращений, а также общее количество обращений, отнесенных к конкретному сотруднику службы техподдержки. Открытые обращения ранжированы в соответствии с источником последней записи в обращении - сотрудником техподдержки или оппонентом.

Ответственный |  |  |  | Открыто | Всего
[1] | [2] | [3] | [4] | [5] | [6]
  1. Сотрудник техподдержки, для которого отображается статистика обращений.
  2. Количество открытых обращений, в которые в последний раз писал клиент техподдержки.
  3. Количество открытых обращений, в которые в последний раз писал сотрудник техподдержки.
  4. Количество закрытых обращений.
  5. Количество открытых обращений, за которые ответственен данный сотрудник.
  6. Суммарное количество всех сообщений во всех обращениях, за которые ответственен данный сотрудник.

Критичность

Отчет показывает количество открытых и закрытых обращений, а также общее количество обращений по степени их критичности. Открытые обращения ранжированы в соответствии с их статусами.

Критичность |  |  |  | Открыто | Всего
[1] | [2] | [3] | [4] | [5] | [6]
  1. Уровень критичности обращения.
  2. Количество открытых обращений, имеющих данный уровень критичности, в которые в последний раз писал клиент техподдержки.
  3. Количество открытых обращений, имеющих данный уровень критичности, в которые в последний раз писал сотрудник техподдержки.
  4. Количество закрытых обращений, имеющих данный уровень критичности.
  5. Количество сообщений во всех открытых обращениях, имеющих данный уровень критичности.
  6. Суммарное количество всех сообщений во всех обращениях, имеющих данный уровень критичности.

Статус

Отчет показывает количество открытых и закрытых обращений, а также общее количество обращений в определённом статусе. Открытые обращения ранжированы в соответствии с источником последней записи в обращении - сотрудником техподдержки или оппонентом.

Статус |  |  |  | Открыто | Всего
[1] | [2] | [3] | [4] | [5] | [6]
  1. Статус обращения.
  2. Количество открытых обращений в данном статусе, в которые в последний раз писал клиент техподдержки.
  3. Количество открытых обращений в данном статусе, в которые в последний раз писал сотрудник техподдержки.
  4. Количество закрытых обращений в данном статусе.
  5. Количество сообщений во всех открытых обращениях в данном статусе.
  6. Суммарное количество всех сообщений во всех обращениях в данном статусе.

Уровень сложности

Отображается количество открытых и закрытых обращений, а также общее количество обращений определённого уровня сложности. Открытые обращения ранжированы в соответствии с источником последней записи в обращении - сотрудником техподдержки или оппонентом.

Сложность |  |  |  | Открыто | Всего
[1] | [2] | [3] | [4] | [5] | [6]
  1. Уровень сложности обращения.
  2. Количество открытых обращений данного уровня сложности, в которые в последний раз писал клиент техподдержки.
  3. Количество открытых обращений данного уровня сложности, в которые в последний раз писал сотрудник техподдержки.
  4. Количество закрытых обращений данного уровня сложности.
  5. Количество сообщений во всех открытых обращениях данного уровня сложности.
  6. Суммарное количество сообщений во всех обращениях данного уровня сложности.

Категория

Система технической поддержки позволяет поддерживать т.н. категории обращений, т.е. стандартные темы, к которым может быть отнесено то или иное сообщение, например: вопросы по доставке, вопросы по оплате и т.п.

Отчет показывает количество открытых и закрытых обращений, а также общее количество обращений, отнесенных к конкретной категории. Открытые обращения ранжированы в соответствии с источником последней записи в обращении - сотрудником техподдержки или оппонентом.

Категория |  |  |  | Открыто | Всего
[1] | [2] | [3] | [4] | [5] | [6]
  1. Категория обращения.
  2. Количество открытых обращений, находящихся в данной категории, в которые в последний раз писал клиент техподдержки.
  3. Количество открытых обращений, находящихся в данной категории, в которые в последний раз писал сотрудник техподдержки.
  4. Количество закрытых обращений, находящихся в данной категории.
  5. Количество сообщений во всех открытых обращениях, находящихся в данной категории.
  6. Суммарное количество всех сообщений во всех обращениях, находящихся в данной категории.

Источник

Источником обращения в службу техподдержки может быть любое средство связи: телефон, факс, электронная почта, интернет-пейджеры и т.п. Система техподдержки позволяет ранжировать обращения по их источникам.

Отчет показывает количество открытых и закрытых обращений, а также общее количество обращений, отнесенных к конкретному источнику обращения. Открытые обращения ранжированы в соответствии с источником последней записи в обращении - сотрудником техподдержки или оппонентом.

Источник |  |  |  | Открыто | Всего
[1] | [2] | [3] | [4] | [5] | [6]
  1. Источник обращения.
  2. Количество открытых обращений, поступивших с данного источника, в которые в последний раз писал клиент техподдержки.
  3. Количество открытых обращений, поступивших с данного источника, в которые в последний раз писал сотрудник техподдержки.
  4. Количество закрытых обращений, поступивших с данного источника.
  5. Количество сообщений во всех открытых обращениях, поступивших с данного источника.
  6. Суммарное количество всех сообщений во всех обращениях, поступивших с данного источника.

Оценка ответов

Отчет показывает количество открытых и закрытых обращений, а также общее количество обращений в соответствии с оценкой работы службы техподдержки. Открытые обращения ранжированы в соответствии с источником последней записи в обращении - сотрудником техподдержки или оппонентом.

Оценка ответов |  |  |  | Открыто | Всего
[1] | [2] | [3] | [4] | [5] | [6]
  1. Балл оценки ответов.
  2. Количество открытых обращений, имеющих данный балл оценки, в которые в последний раз писал клиент техподдержки.
  3. Количество открытых обращений, имеющих данный балл оценки, в которые в последний раз писал сотрудник техподдержки.
  4. Количество закрытых обращений, имеющих данный балл оценки.
  5. Количество сообщений во всех открытых обращениях, имеющих данный балл оценки.
  6. Суммарное количество всех сообщений во всех обращениях, имеющих данный балл оценки.

Уровни поддержки

Отображается количество открытых и закрытых обращений, а также общее количество обращений, отнесенных к конкретному уровню поддержки. Открытые обращения ранжированы в соответствии с источником последней записи в обращении - сотрудником техподдержки или оппонентом.

Ответственный |  |  |  | Открыто | Всего
[1] | [2] | [3] | [4] | [5] | [6]
  1. Название уровня техподдержки.
  2. Количество открытых обращений данного уровня техподдержки, в которые в последний раз писал клиент техподдержки.
  3. Количество открытых обращений данного уровня техподдержки, в которые в последний раз писал сотрудник техподдержки.
  4. Количество закрытых обращений данного уровня техподдержки.
  5. Количество сообщений во всех открытых обращениях данного уровня техподдержки.
  6. Суммарное количество всех сообщений во всех обращениях данного уровня техподдержки.


Обращения

Страница Обращения (Сервисы > Техподдержка > Обращения) отображает обращения пользователей в службу техподдержки. С помощью этой страницы вы можете:

  • просматривать обращения пользователей;
  • редактировать и удалять обращения;
  • изменять состояния обращений и их статусы.

Каждое обращение, помимо стандартных состояний и статусов, может быть идентифицировано как спам.

Фильтр

Форма фильтра используется для выбора из списка обращений в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Параметр | Описание
Найти | Поиск сообщений по наиболее типичным критериям, выбираемым в списке: ID обращения, текст сообщения, заголовок или автор.
ID обращения* | ID обращения в базе. Требуемые ID можно перечислять через запятую.
Сайты | Сайт, в котором было создано обращение.
Индикатор Вы можете выбрать один и более цвет индикаторов для фильтрации обращений:
  • - последний раз в обращение писал клиент техподдержки (вы ответственный);
  • - последний раз в обращение писал клиент техподдержки (вы не ответственный);
  • - последний раз в обращение писали вы;
  • - последний раз в обращение писал сотрудник техподдержки;
  • - обращение закрыто.
Закрыто/открыто Закрыто - обращение было закрыто;
Открыто - обращение не закрыто.
Отложенное обращение | Отображение только отложенных сообщений, неотложенных сообщений или всех.
Спам | Отображение только сообщения, которые могут быть расценены как спам, не спам или все.
Подозрительно на спам | То же, но для сообщений со статусом подозрительно на спам.
Создано (DD.MM.YYYY) | Интервал даты создания обращения.
Изменено (DD.MM.YYYY) | Интервал даты последнего изменения обращения.
Автор* | Автор обращений, которые требуется отобразить.
Кто изменил* | Сотрудник техподдержки, изменивший обращения, которые требуется отобразить.
Ответственный* | Сотрудник техподдержки ответственный за обращение.
Длительность решения проблемы (дни) | Интервал количества дней, прошедших с момента создания обращения до его закрытия.
Сообщений | Интервал количества сообщений в требуемых обращениях.
Время решения (мин.) | Интервал времени, прошедшего с момента создания обращения до его закрытия.
Просроченных сообщений | Интервал количества просроченных сообщений в требуемых обращениях.
Количество дней до авто-закрытия | Интервал количества дней, оставшихся до автоматического закрытия в требуемых обращениях.
Уровень поддержки | Уровень поддержки требуемых обращений.
Категория | Категория отображаемых обращений.
Критичность | Критичность отображаемых обращений.
Статус | Статус отображаемых обращений.
Уровень сложности | Уровень сложности требуемых обращений.
Оценка ответа | Оценка ответов, даваемая создателем отображаемых обращения.
Источник | Источник обращения. Если обращение было создано с помощью веб-формы, то имя источника – <web>.
Заголовок и Текст сообщения* | Маска для заголовка и текста отображаемых обращений.
Комментарий* | Маска для текста комментария отображаемых обращений.
Группа сотрудников техподдержки | Поиск обращений по выбранной группе сотрудников техподдержки.
Группа клиентов техподдержки | Поиск обращений по выбранной группе клиентов техподдержки.
Купон* | Указывается купон для поиска спецобращения.

* - для данных полей вы можете воспользоваться специальными логическими выражениями. Синтаксис выражений можно узнать, кликнув символ ? рядом с полем.

Контекстная панель

Кнопка | Описание
Добавить | Добавление нового обращения.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список обращений

Колонка | Описание
Колонка флажков | Выбор всех или только определённых сообщений для применения к ним действий при помощи вспомогательной формы Действия внизу таблицы.
Меню действий При нажатии на кнопку конкретного обращения, отображает меню, позволяющее:
  • Изменить - отредактировать обращение;
  • Закрыть - закрыть сообщение;
  • Открыть - открыть ранее закрытое обращение;
  • Снять отметку о спаме - снять отметку спам с обращения;
  • Отметить как подозрительное на спам - устанавливает состояние обращения подозрение на спам;
  • Отметить как спам - идентифицирует обращение как спам;
  • Отметить как спам и удалить -пометить сообщение как спам и удалить его;
  • Удалить - удалить сообщение.
ID | Идентификатор обращения. При клике на идентификаторе открывается форма правки обращения.
Индикатор Индикатор обращения:
  • - последний раз в обращение писал ваш оппонент (вы ответственный);
  • - последний раз в обращение писал оппонент (вы не ответственный);
  • - последний раз в обращение писали вы;
  • - последний раз в обращение писал сотрудник техподдержки;
  • - обращение закрыто.
Заголовок | Заголовок обращения.
Автор | Автор и время создания обращения.
Изменено | Время изменения и имя последнего пользователя, изменившего обращение.
Срочность ответа | Дата и время сообщения пользователя, от которого считается время реакции.
Дата ответа | Дата ответа на обращение.
Сбщ. | Количество сообщений в обращении.
Уровень | Уровень техподдержки обращения.
Категория | Категория, к которой относится обращение.
Критичность | Критичность обращения.
Сайт | Сайт, в котором было создано обращение.
Ответственный | Ответственный за обращение.
Статус | Статус, в котором находится обращение.
Сложность | Уровень сложности обращения.
Оценка | Оценка ответа на обращение.
Время решения | Время, затраченное на решение обращения.
Купон | Купон для спецобращения.
Крайний срок | Дата и время крайнего срока для решения обращения.

Действия над обращениями

Вспомогательная форма Действия позволяет осуществить различные операции одновременно над несколькими сообщениями. Для того чтобы применить то или иное действие к сообщениям, следует пометить их галочками в левом столбце таблицы.

Предусмотрены следующие действия:

  • Закрыть - закрывает обращение.
  • Закрыть и оповестить - закрывает обращение и оповещает об этом пользователей сайта, имеющих право доступа администратор техподдержки.
  • Открыть - переводит обращение в открытое состояние. Открытые обращения допускают создание новых сообщений.
  • Открыть и оповестить - переводит обращение в открытое состояние и оповещает об этом пользователей сайта, имеющих право доступа администратор техподдержки.
  • Снять отметку о спаме - снимает с обращения подозрение на спам.
  • Отметить как подозрительное на спам - устанавливает состояние обращения подозрение на спам.
  • Отметить как спам - идентифицирует обращение как спам.
  • Отметить как спам и удалить - идентифицирует обращение как спам и удаляет его.


Создание и редактирование обращения

Форма предназначена для явного создания обращения в службу техподдержки.

При создании нового обращения не сотрудником техподдержки, в зависимости от категории, критичности, либо источника, ответственный может быть назначен автоматически. Если ответственный не был определён, то в случае установки параметра Ответственный по умолчанию в настройках модуля будет назначен ответственный по умолчанию. После того как обращение будет добавлено в базу, ответственный получит извещение по электронной почте. Если ответственный не выбран, то извещение будет отослано на электронные адреса всех пользователей имеющих право администратор техподдержки.

Если обращение меняет ответственный, то об этом будет извещен автор обращения. Если, в свою очередь, обращение меняет автор, то об этом извещаются ответственный либо администраторы техподдержки. В случае, если назначается новый ответственный за обращение, то об этом будут извещены как автор обращения, так и новый ответственный. Автора обращения можно не оповещать, если снять флаг Сообщение скрыть, автора не оповещать.

Под изменением обращения понимается:

  • изменение категории, критичности, статуса обращения, а также оценки ответов;
  • назначение нового ответственного за обращение;
  • добавление нового сообщения;
  • закрытие, либо открытие обращения.

Контекстная панель

Кнопка | Описание
Список | Переход к списку всех обращений.
Создать | Создание нового обращения. Кнопка отображается при редактировании существующего обращения.
Закрыть | Закрытие текущего обращения. Кнопка отображается при редактировании существующего обращения.
Удалить | Удаление текущего обращения. Кнопка отображается при редактировании существующего обращения.
Спам Открывает меню с действиями:
  • Снять у обращения пометку о спаме;
  • Отметить обращение как подозрительное на спам;
  • Отметить обращение как спам;
  • Отметить обращение как спам и удалить.

Кнопка отображается при редактировании существующего обращения.

Закладка Обращение

Поле | Описание
Сайт | Сайт, на котором зарегистрировано обращение.
Автор | Источник (сайт, телефон и т.п.) и автор обращения.
Создано Время создания обращения; пользователь создавший обращение.

Поле отображается только в режиме редактирования существующего обращения.
Изменено Время последней модификации обращения; автор модификации.

Поле отображается только в режиме редактирования существующего обращения.
Дата авто-закрытия Дата автоматического закрытия обращения расчитывается с даты и времени последнего ответа сотрудника техподдержки. Обращение будет закрыто в установленную дату, если клиент больше не обратится с проблемой.

Поле отображается только в режиме редактирования существующего обращения.
Время решения Время решения расчитывается с момента открытия обращения и ответа на него сотрудником техподдержки.

Поле отображается только в режиме редактирования существующего обращения.
Дата ответа | Дата и время ответа на тикет
Магазин Отображается ссылка на историю заказов автора обращения при наличии установленного модуля Интернет-магазин.

Поле отображается только в режиме редактирования существующего обращения.
Закрыто Время закрытия обращения.

Поле отображается только в режиме редактирования существующего обращения.
Обсуждение

Секция отображается только в режиме редактирования существующего обращения.
  • # - порядковый номер сообщения. Определяет порядок, в соответствии с которым выводятся сообщения в дискуссии.
  • Время создания сообщения.
  • Автор сообщения.
  • [Создать обращение] – ссылка, позволяющая создать новое обращение из сообщений клиента.
  • [Цитировать] – ссылка, позволяющая вставлять цитаты.
  • [Оригинал] - ссылка, ведущая в модуль почты на оригинальный EMail (в случае если сообщение было создано из модуля почты).
  • [Изменить] – ссылка, позволяющая редактировать сообщение. Доступна только администраторам.
  • [Удалить] – ссылка, позволяющая удалить сообщение. Доступна только администраторам.
Изображение и тело сообщения
Режим | Режим работы с обращением.
Заголовок | Заголовок сообщения.
Сообщение скрыть, автора не оповещать При установке данного флага сообщение будет создано, как скрытое для автора обращения (если он не является сотрудником техподдержки). Помимо этого, не будет отослано почтовое сообщение автору обо всех изменениях, произведенных в данный момент; служба техподдержки уведомление получит.

Поле отображается только в режиме редактирования существующего обращения.
Не изменять статус обращения | В случае, если сообщение изменяется, установка этого флага позволяет избежать смены статуса обращения (например, с "последний раз в обращение писал оппонент" на "последний раз в обращение писали вы").
Источник / От кого | В данной группе полей сотрудник техподдержки может указать источник и автора сообщения. Если у сотрудника техподдержки есть право Чтение на главный модуль, то выбор пользователя можно осуществлять с использованием дополнительного окна (кнопка "..."). Помимо этого, при вводе ID пользователя рядом будет выводиться информация о пользователе (логин и имя).
Часто используемые ответы В выпадающем списке администратор либо ответственный может выбрать какой либо шаблон ответа.

Поле отображается только в режиме редактирования существующего обращения.
*Сообщение Поле для ввода нового сообщения.

Поле отображается только в режиме создания нового обращения.
Прикрепить файлы | Поле для прикрепления и отправки файлов нового сообщения (если требуется).
Статус обращения | Статус обращения.
Уровень сложности | Уровень сложности обращения.
Ответственный | Пользователь ответственный за обращение.
Критичность обращения | Критичность обращения.
Оценка ответов Уровень оценки ответов.

Поле отображается только в режиме редактирования существующего обращения.
Категория обращения | Категория обращения.
Уровень поддержки | Требуемый уровень техподдержки для этого сообщения.
Купон Указывается купон для этого обращения.

Поле отображается только в режиме создания нового обращения.
Время решения (мин.) Время решения обращения в мин.

Поле отображается только в режиме редактирования существующего обращения.
Отложенное обращение Определяет, возможно ли обращение отложить.

Поле отображается только в режиме редактирования существующего обращения.
Закрыть при отсутствии ответа через Количество дней, по истечении которых обращение будет автоматически закрыто.
Поле отображается только в режиме редактирования существующего обращения.
Закрыть обращение Флаг, позволяющий либо закрыть либо открыть обращение.

Поле отображается только в режиме редактирования существующего обращения.
Добавить пользовательское свойство Переход к добавлению пользовательского поля для формы создания/редактирования обращения.

Поле отображается только для администраторов системы.
Комментарий Поле для ввода комментария, видимого только пользователями входящими в группу техподдержки.

Поле отображается только в режиме редактирования существующего обращения.

* - поля, обязательные для заполнения.

При создании обращения или написании нового сообщения, если вы входите в группу техподдержки, то вы можете указать любого автора и любой источник обращения. По умолчанию, все операции будут проводиться от вашего имени. Источником по умолчанию является <web>.

Если вы администратор сайта либо ответственный за обращение, вам доступны для модификации только следующие поля:

  • Категория обращения;
  • Ответственный за обращение;
  • Статус обращения;
  • Закрыть обращение;
  • Комментарий.

Если вы являетесь создателем обращения, то вам доступны для модификации только следующие поля:

  • Критичность обращения;
  • Оценка ответов.

Закладка Редактирование параметров сообщения

Прямое редактирование сообщения доступно только администратору сайта либо администратору техподдержки. Переход к данной вкладке осуществляется с помощью ссылки Изменить, расположенной в секции обсуждения обращения.

Поле | Описание
Источник / От кого | Источник и автор данного сообщения.
Создано | Дата и время создания
Порядковый номер | Порядковый номер сообщения, в соответствии с которым выводятся сообщения в дискуссии. Поле отображается только в режиме редактирования существующего обращения.
Отметка о спаме | Позволяет отметить сообщение как спам или подозрительное на спам.
Не изменять статус обращения | Установка этого флажка позволяет не изменять статус обращения.
Скрытое | Установка этого флажка скрывает сообщение от автора.
Запись журнала изменений | Установка этого флажка приводит к записи изменений сообщения в лог-файл.
Сообщение клиента было просрочено | Указывает, что на сообщение клиента (напр., автора обращения) ответ не был дан вовремя.
Сообщение | Тело сообщения.
Прикрепить новые файлы | Поля предназначенные для замены, либо удаления изображения.
ID внешнего оригинала (email и т.п.) | Идентификатор источника сообщения, например, электронной почты.
Время решения (мин.) | Время решения обращения в минутах.
Дополнительное поле внешнего оригинала (заголовки email и т.п.) | Любая дополнительная информация о внешнем источнике.

Смотрите также

  • Работа с обращениями (учебный курс "Администратор. Модули")


Графики

Страница Графики (Сервисы > Техподдержка > Графики) отображает график нагрузки на техподдержку, а также диаграммы, иллюстрирующие качество работы службы техподдержки.

Фильтр

Форма фильтра используется для задания параметров отбора элементов для построения графиков. С его помощью можно сузить количество информации, отображаемых на графиках.

Параметр | Описание
Период (DD.MM.YYYY) | Обозначает, данные за какой период времени следует использовать для построения графиков. Для задания временного диапазона можно использовать либо список с количеством дней, либо поля-календари.
Сайты | Сайты, данные по которым будут отображаться на графиках.
Ответственный* Поле, позволяющее построить графики только для определённых сотрудников.

Использование этого поля требует прав прав администратора техподдержки.
Уровень поддержки | Уровень поддержки выводимых обращений.
Категория | Требуемая категория выводимых обращений.
Критичность | Критичность выводимых обращений.
Статус | Статус выводимых обращений.
Оценка ответа | Оценка ответа обращений, которые следует отобразить.
Источник | Источник требуемых обращений.
Что показать на графике Указать, какие из графиков показывать:
  • открытые обращения;
  • закрытые обращения;
  • все обращения;
  • сообщения;
  • просроченные сообщения.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отфильтровать элементов для построения графиков, нажмите кнопку Найти. Для отображения всех элниентов нажмите кнопку Отменить.

График нагрузки
на техподдержку

График отображает количество обращений и сообщений в системе техподдержки по дням. График отражает загрузку службы техподдержки на конкретную дату и может использоваться для принятия управленческих решений по функционированию службы техподдержки..

Пример графика

Диаграмма длительности
решения проблем

Круговая диаграмма наглядно показывает типичное количество времени (в днях), которое тратится на решение проблем службой техподдержки.

Пример диаграммы

Диаграмма количеств сообщений,
необходимых для решения проблемы

На данной диаграмме представлено процентное соотношение количеств сообщений в закрытых обращениях.

Пример диаграммы

Смотрите также

  • Графики (учебный курс "Администратор. Модули")


Уровни поддержки

Страница Уровни поддержки (Сервисы > Техподдержка > Уровни поддержки) служит для создания и настройки уровней техподдержки. Уровни используются для ранжирования и определения приоритетов тех или иных пользователей на получение техподдержки.

Фильтр

Форма фильтра используется для выбора из списка уровней в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Параметр | Описание
Название* | Поиск по названию уровня. Поле присутствует, даже если фильтр свернут.
ID* | Поиск по идентификатору уровня.
Сайт | Поиск уровней для определённого сайта.
Описание* | Поиск уровней по тексту описания.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать уровни техподдержки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех уровней нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Добавление нового уровня техподдержки.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список уровней техподдержки

Поле | Описание
Колонка флажков | Поле предназначено для выбора уровней техподдержки, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над уровнем техподдержки:
  • Изменить - переход к форме редактирования параметров уровня техподдержки;
  • Удалить - удаление уровня техподдержки.
ID | Идентификатор уровня в списке.
Приоритет | Приоритет уровня техподдержки.
Сайт | Сайт, на котором действует данный уровень.
Название | Название уровня техподдержки.
Описание | Описание уровня техподдержки.
Время реакции | Максимально возможное время реакции (ответа) на сообщения авторов обращений.
Группы пользователей | Группы пользователей, для которых действуют правила уровня техподдержки.
Ответственный | Ответственный по умолчанию за обращения этого уровня.
Расписание | Расписание техподдержки, применяемое для данного уровня.


Создание и редактирование уровня поддержки

Форма предназначена для создания нового или изменения параметров уже существующего уровня техподдержки.

Контекстная панель

Кнопка | Описание
Уровни техподдержки | Переход на страницу со списком уровней поддержки.
Новый уровень | Добавление нового уровня техподдержки. Кнопка отображается при редактировании существующего уровня техподдержки.
Удалить уровень | Удаление редактируемого уровня техподдержки.

Закладка Уровень техподдержки

Поле | Описание
Создано Дата и время создания уровня техподдержки.

Поле отображается при редактировании существующего уровня техподдержки.
Изменено Дата и время изменения уровня техподдержки.

Поле отображается при редактировании существующего уровня техподдержки.
*Название | Указывается название уровня техподдержки.
Сайт | Указывается сайт, на котором действует данный уровень техподдержки.
Приоритет | Задается приоритет уровня техподдержки.
Время реакции на сообщение клиента | Задается время реакции на сообщение клиента: либо в днях (дн.), либо в часах (ч.), либо в минутах (мин.).
За сколько до окончания времени реакции высылать напоминание по EMail | Указывается время (либо в днях (дн.), либо в часах (ч.), либо в минутах (мин.)) до окончании реакции на сообщение клиента, когда будут отправлено напоминание по EMail.
Ответственный по умолчанию | Указывается ответственный по умолчанию за обращения этого уровня.
Расписание | Выбирается одно из созданных в системе расписаний, по которому будет осуществляться техническая поддержка по данному уровню.
Считать крайний срок от Указывается момент, от которого следует отсчитывать время реакции на обращение:
  • Дата ответа клиента;
  • Дата создания обращения.
Описание | Указывается описание уровня техподдержки.

Закладки Группы, Доступ

Закладка Группы

На закладке указываются группы, пользователи которых могут создавать обращения с данным уровнем техподдержки.

Закладка Доступ

На закладке можно установить значения справочников, которые будут доступны при создании обращений с данным уровнем техподдержки.

Смотрите также

  • Уровни поддержки (SLA) (учебный курс "Администратор. Модули")


Группы

Страница Группы (Сервисы > Техподдержка > Группы) служит для управления группами пользователей техподдержки.

Группы созданы для облегчения коллективной работы с обращениями. Они могут быть клиентскими или сотрудников поддержки. Клиентские группы включают, как правило, пользователей от одного клиента компании. Группы техподдержки включают в себя, как правило, сотрудников одного отдела. Любого из членов группы можно отключить, при необходимости, от получения сообщений по группе.

Фильтр

Форма фильтра используется для выбора из списка групп пользователей техподдержки в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Параметр | Описание
Название* | Поиск групп по названию. Поле присутствует, даже если фильтр свернут.
ID | Поиск групп по их идентификатору.
Категории Поиск групп по типу:
  • (все) - будут отображены все группы (установлено как значение по умолчанию);
  • Сотрудники техподдержки - будут отображены только группы сотрудников техподдержки;
  • Клиенты техподдержки - будут отображены только группы клиентов техподдержки.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать групп пользователей техподдержки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех групп нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить группу | Переход к форме создания новой группы пользователей техподдержки.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список групп пользователей техподдержки

Поле | Описание
Колонка флажков | Поле предназначено для выбора групп пользователей техподдержки, к которым предполагается применить какое-либо правило или действие.
Меню действий Действия, которые можно произвести над группой:
  • Редактировать - переход к форме редактирования параметров группы пользователей техподдержки;
  • Удалить - удаление группы пользователей техподдержки.
ID | Идентификатор группы.
Название | Название группы. При клике по ссылки с названием группы открывается форма редактирования группы.
Сортировка | Индекс сортировки.
XML_ID | XML-идентификатор группы.
Группа сотрудников техподдержки | Признак того, что группа пользователей техподдержки относится к группе сотрудников техподдержки.

Смотрите также

  • Группы (учебный курс "Администратор. Модули")


Создание и редактирование группы

Форма предназначена для создания новой группы техподдержки или изменения параметров уже существующей группы.

Контекстная панель

Кнопка | Описание
Список групп | Переход на страницу со списком групп пользователей техподдержки.

Закладка Группа

Закладка предназначена для настройки основных параметров группы.

Поле | Описание
*Название группы | Указывается название группы пользователей техподдержки.
Сортировка | Задается индекс сортировки группы.
XML_ID | Указывается XML-идентификатор (набор произвольных чисел и латинских букв). Позволяет не привязываться к ID группы в имеющейся базе данных. В отличие от обычного идентификатора ID не меняется при переносе базы. Необходим для использования при разработке собственных скриптов.
Группа сотрудников поддержки | При отмеченной опции создаваемая группа будет относится к группе сотрудников техподдержки. Если опция не отмечена то создаваемая группа будет относится к клиентской группе.

* - поля, обязательные для заполнения.

Закладка Пользователи

На закладке производится набор пользователей в группу.

Поле | Описание
Пользователь | Идентификатор и логин пользователя, состоящего в группе.
Может видеть сообщения группы | При отмеченной опции пользователь сможет видеть сообщения, написанные другим пользователем этой группы.
Получает уведомления о новых обращениях в группе | При отмеченной опции пользователь будет получать уведомления о новых обращениях в группе.
Получает уведомления о обновлении обращений в группе | При отмеченной опции пользователь будет получать уведомления об обновлении обращений в группе.
Кнопка Добавить | Вызов всплывающего окна со списком пользователей для добавления их в группу.

Для удаления пользователя из группы достаточно удалить его ID из строки.

Смотрите также

  • Группы (учебный курс "Администратор. Модули")


Купоны спецобращений

На странице Купоны спецобращений (Сервисы > Техподдержка > Купоны спецобращений) представлена информация о купонах спецобращений. Обращения с купонами помещаются в начале списка обращений. Формат для генерации купонов задается в настройках модуля Техподдержка.

Фильтр

Форма фильтра используется для выбора из списка купонов в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Параметр | Описание
Купон | Поиск купона по его коду.
ID | Поиск купона по идентификатору.

Чтобы отобрать купоны по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех купонов нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить купон | Переход к форме создания нового купона.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список купонов

Поле | Описание
Колонка флажков | Выбор купонов для применения к ним каких-либо правил или действий.
Меню действий Действия, которые можно произвести над купоном:
  • Редактировать купон - переход к форме редактированию параметров купона;
  • Удалить - удаление купона;
  • Журнал использования - переход в журнал для просмотра информации об использовании данного купона.
ID | Идентификатор купона.
Купон | Сгенерированная последовательность символов, составляющая купон.
Количество использований | Количество, которое купон может быть использован еще раз.
Использован, раз | Количество использований купона.
Дата изменения | Время и дата изменения купона.
Дата создания | Время и дата создания купона.
Активность | Признак активности купона.
Активен с | Дата начала активности купона.
Активен по | Дата окончания активности купона.
ID создавшего пользователя | Личная информация создавшего купон пользователя.
Login создавшего пользователя
Имя создавшего пользователя
Фамилия создавшего пользователя
ID обновившего пользователя | Личная информация обновившего купон пользователя.
Login обновившего пользователя
Имя обновившего пользователя
Фамилия обновившего пользователя
ID уровня поддержки | Идентификатора уровня техподдержки, который применяется к обращению при использовании купона.
Уровень поддержки | Уровень техподдержки, который применяется к обращению при использовании купона.

Смотрите также

  • Спецобращения (учебный курс "Администратор. Модули")


Создание и редактирование купона

Форма предназначена для создания нового или редактирования параметров уже существующего купонов спецобращений.

Контекстная панель

Кнопка | Описание
Список купонов | Переход на страницу со списком купонов.

Закладка Купон

Поле | Описание
Купон | Сгенерированная последовательность символов, составляющая купон. Поле не редактируется и отображается только при редактировании существующего купона.
Купон активен с даты | Указывается дата начала активности купона.
Купон активен по дату | Указывается дата окончания активности купона.
Активность | При отмеченной опции купон будет активен в течение периода, заданного с помощью вышеуказанных полей.
Количество оставшихся использований | Указывается количество, которое купон может быть еще использован.
Уровень поддержки | С помощью выпадающего списка задается уровень техподдержки, к которому будет отнесено созданное с использованием купона обращение.

Смотрите также

  • Спецобращения (учебный курс "Администратор. Модули")


Журнал использования купонов

На странице Журнал использования купонов (Сервисы > Техподдержка > Журнал использования купонов) представлена информация об использовании купонов.

Фильтр

Форма фильтра используется для выбора записей журнала в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Параметр | Описание
Купон | Поиск записей об использовании купона по его коду. Поле присутствует, даже если фильтр свернут.
ID купона | Указывается идентификатор купона для поиска записей об его использовании.

Чтобы отобрать записи по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех записей нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Таблица использований купонов

Поле | Описание
Купон | Сгенерированная последовательность символов, составляющая купон.
Дата использования | Дата и время использования купона при создании обращения.
ID пользователя | Идентификатор пользователя, который использовал купон.
Логин | Логин пользователя, который использовал купон.
ID купона | Идентификатор купона.
Имя | Имя пользователя, который использовал купон.
Фамилия | Фамилия пользователя, который использовал купон.
ID сессии | Идентификатор сессии.
ID гостя | Идентификатор гостя.


Отправить отзыв по этому разделу

Справочники

  • Типы справочников техподдержки
  • Создание и редактирование записи справочника


Типы справочников техподдержки

Форма служит для отображения содержимого следующих типов справочников техподдержки:

  • Категории;
  • Критичности;
  • Статусы;
  • Оценки ответов;
  • Частые ответы;
  • Источники;
  • Сложность.

По умолчанию форма отображает справочник, выбранный в левой панели Административного раздела (категории, критичности и т.д.) путём автоматической установки поля Тип фильтра по конкретному справочнику.

Фильтр

Параметр | Описание
Найти | Это поле позволяет найти требуемые записи по наиболее типичным критериям, выбираемым в списке: заголовку и описанию. Данное поле отображается, даже если фильтр свернут.
ID* | Указывает на необходимость отображения конкретной записи в справочнике по ее идентификатору.
Сайты | Отображать записи справочника только для указанных сайтов.
Заголовок* | Заголовок записи справочника для отображения.
Описание* | Маска для текста описания.
Символьный код* | Символьный код типа справочника.
Ответственный* | Сотрудник техподдержки, ответственный за новые обращения, созданные в соответствующей категорией или с той или иной критичностью.
По умолчанию | Определяет, отображать ли только справочники по умолчанию, не по умолчанию или все.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отфильтровать записи по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех сообщений нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Добавление новой записи справочника. В открывшемся меню выберите, какой тип записи следует добавить: категорию, критичность, статус, оценку ответов, частый ответ, источник или сложность.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Записи справочника

Таблица отображает записи в выбранном для отображения справочнике. Для сортировки таблицы по тому или иному полю вы можете кликнуть по заголовку таблицы.

Поле | Описание
Колонка флажков | Выбор записей, к которым предполагается применить какое-либо действие.
Меню действий Нажатие на кнопку действий в строке записи справочника отображает меню, содержащее команды:
  • Изменить - отредактировать запись;
  • Удалить - удалить запись.
ID | ID записи справочника в базе.
Сорт. | Порядок сортировки при выводе.
Сайты | Сайты, на которых используется записи справочника.
Заголовок | Заголовок записи справочника.
Ответственный Ответственный за запись.

Данное поле отображается только для справочников типа Категории, Критичности, Источники.


Создание и редактирование записи справочника

Форма предназначена для создания и редактирования записей справочников техподдержки, а именно:

  • Категории;
  • Критичности;
  • Статусы;
  • Оценки ответов;
  • Частые ответы;
  • Источники;
  • Сложность.

Контекстная панель

Кнопка | Описание
Справочник | Открывает справочник для текущего типа записи.
Создать новую запись | Создает новую запись текущего типа в справочнике. Кнопка отображается только при редактировании существующей записи справочника.
Удалить запись | Удаляет открытую запись. Кнопка отображается только при редактировании существующей записи справочника.

Закладка Запись

Поле | Описание
Тип | Тип записи справочника.
Сайты | Указываются сайты, в которых должна быть показана данная запись.
Порядок сортировки | Порядок сортировки при выводе.
*Заголовок | Заголовок записи.
Символьный код | При использовании функции API CTicket::SetTicket есть возможность задавать в качестве параметра не ID типа записи справочника, а его символьные коды, что упрощает программирование. Данное поле может содержать именно этот символьный код.
Описание | Для типов категория, критичность, оценка, статус данное поле используется для всплывающей подсказки. Для типа часто используемые ответы это поле используется для ввода тела ответа.
При создании нового обращения на сайте, выбирать по умолчанию в выпадающем списке | Флаг позволяет выбрать по умолчанию данное значение в веб-форме при создании нового обращения. Для одного типа записей справочника и одного сайта может быть только одна запись, для которой этот флаг будет установленным. Поле доступно для модификации только для типов категория, критичность и источники.
Ответственный | Ответственный за обращение. Поле доступно для модификации только для типов категория, критичность и источники.

* - поле, обязательное для заполнения.

Закладка Статистика

Доступна только для типа категория.

Как регистрировать новые обращения в техподдержку в модуле статистики
event1 | Идентификатор event1 типа события для модуля Веб-аналитика.
event2 | Идентификатор event2 типа события для модуля Веб-аналитика.
event3 | Дополнительный параметр события для модуля Веб-аналитика.

Смотрите также

  • Справочники (учебный курс "Администратор. Модули")


Отправить отзыв по этому разделу

Расписания

  • Расписания
  • Создание и редактирование расписания
  • Исключения
  • Создание и редактирование исключения


Расписания

Страница Расписания (Сервисы > Техподдержка > Расписания > Расписания) служит для создания и настройки расписаний работы техподдержки. Расписания используются при настройке уровней техподдержки (SLA).

Фильтр

Форма фильтра используется для выбора из списка расписаний в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Параметр | Описание
Имя | Поиск по названию расписания. Поле допускает использование специальных логических выражений [image] .

Чтобы отобрать расписания по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех расписаний нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Добавление нового расписания.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список расписаний

Поле | Описание
Колонка флажков | Поле предназначено для выбора расписаний, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над расписанием:
  • Изменить - переход к форме редактирования параметров расписания;
  • Удалить - удаление расписания.
ID | Идентификатор расписания.
Название | Название расписания.
Описание | Описание расписания.


Создание и редактирование расписания

Форма предназначена для создания нового или изменения параметров уже существующего расписания.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком расписаний.
Удалить | Удаление редактируемого расписания.
Настройки | Переход к диалогу настройки внешнего вида формы создания/редактирования расписания.

Форма редактирования

Форма состоит из двух закладок, на которых задаются основные параметры расписания и режим работы техподдержки.

Закладка Расписание

Поле | Описание
*Имя | Указывается название расписания.
Описание | Произвольное описание расписания работы техподдержки.

* - поле обязательно для заполнения.

Закладка Часы

На данной закладке настраивается режим оказания технической поддержки по обращениям с тем уровнем поддержки (SLA), в настройках которого указано данное расписание. Расписание работы задается для каждого дня недели. Возможны следующие режимы работы техподдержки:

  • 24 часа - круглосуточный режим работы;
  • не работает;
  • часы работы (HH24:MI) - позволяет задать интервалы времени работы техподдержки (используется 24-х часовой формат). Ведется проверка корректности указанных дат.

    Кнопка Копировать служит для копирования текущего значения времени работы в нижнее поле.

Смотрите также

  • Расписания и исключения (учебный курс "Администратор. Модули")


Исключения

Страница Исключения (Сервисы > Техподдержка > Расписания > Исключения) служит для создания и настройки исключений в оказании технической поддержки по тому или иному уровню (SLA).

Фильтр

Форма фильтра используется для выбора из списка расписаний в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Параметр | Описание
Название | Поиск по названию исключения. Поле допускает использование специальных логических выражений [image] .
Действие | Отбор исключений по их действию.
Уровни поддержки | Поиск исключений, применяемых для определенных уровней поддержки.

Чтобы отобрать исключения по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех исключений нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Добавление нового исключения.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список исключений

Поле | Описание
Колонка флажков | Поле предназначено для выбора исключений, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над исключением:
  • Изменить - переход к форме редактирования параметров исключения;
  • Удалить - удаление исключения.
ID | Идентификатор исключения.
Название | Название исключения.
Действие | Действие, которое выполняется в исключении.
С | Дата и время, с которого начинает работать исключение.
По | Дата и время окончания действия исключения.
Уровни поддержки | Уровни поддержки (SLA), для которых выполняется исключение.


Создание и редактирование исключения

Форма предназначена для создания нового или редактирования параметров уже существующего исключения.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком исключений.
Удалить | Удаление редактируемого исключения.
Настройки | Переход к диалогу настройки внешнего вида формы создания/редактирования исключения.

Закладка Исключение

Поле | Описание
Имя | Название исключения.
Действие | Выбирается действие исключения: один из видов выходного или работы.
Действует С | Дата и время начала действия исключения.
По | Дата и время окончания действия исключения.
Действует для уровней поддержки | Указываются уровни поддержки, для которых действует данное исключение.
Описание | Произвольное описание исключения.

Смотрите также

  • Расписания и исключения (учебный курс "Администратор. Модули")


Учёт рабочего времени

Модуль позволяет организовать контроль за использованием рабочего времени сотрудниками компании и учет поставленных в план и выполненных ими задач.

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Отчеты по работе сотрудников | timeman.report.weekly | Вывод отчетов по работе сотрудников и руководителей. Компонент настроек не имеет.
Системные компоненты (не описываются)
Контроль времени | timeman | Ведет учет рабочего времени и учет поставленных в план и выполненных задач.

Смотрите также:

  • Как настроить учет рабочего времени


Настройка модуля

Закладки

Форма настроек модуля Учет рабочего времени (Настройки > Настройки продукта > Настройки модулей > Учет рабочего времени) предназначена для задания параметров модуля.

Рабочий день

Поле | Описание
Начало рабочего дня | Укажите время начала рабочего дня по умолчанию
Окончание рабочего дня | Укажите время окончания рабочего дня по умолчанию
Возобновление рабочего дня | Разрешено ли возобновлять рабочий день после его закрытия.
Максимальное время начала | Записи об открытии рабочего дня, сделанные после указанного времени, будут учтены как нарушение трудовой дисциплины. Значение можно переопределить в настройках подразделения или сотрудника.
Минимальное время окончания | Записи о закрытии рабочего дня, сделанные до указанного времени, будут учтены как нарушение трудовой дисциплины. Значение можно переопределить в настройках подразделения или сотрудника.
Минимальная продолжительность | Записи о закрытии рабочего дня, сделанные до выработки указанного времени, будут учтены как нарушение трудовой дисциплины. Значение можно переопределить в настройках подразделения или сотрудника.
Отчёт за день | Устанавливается требуется или нет обязательный ежедневный отчет. И выводить ли форму для составления отчета.
Допустимый промежуток изменения времени | Укажите в минутах на сколько сотрудник может изменить время начала или окончания рабочего дня, чтобы это не требовало подтверждения руководителем.

Доступ

Поле | Описание
Общие права доступа
Первый столбец | Название группы для которой задан уровень прав
Второй столбец | Выбор в выпадающем окне уровня прав. Для задания уровня прав для новой группы воспользуйтесь полями последней строки. Для добавления полей для новых групп воспользуйтесь ссылкой Добавить право доступа.
Субординация
Сотрудники могут редактировать текущий рабочий день | Разрешить или нет сотрудникам редактировать свой текущий день.
Управление рабочим днем и чтение отчетов | Задаются права тех кто может управлять рабочим днем и отчетами.
Изменение и подтверждение записей | Задание прав на изменение и подтверждение записей. При доступе в соответствии с субординацией нет возможности изменять или подтверждать свои записи о рабочих днях.

Рабочие отчеты

Поле | Описание
Форум для хранения комментариев к рабочим отчетам | Если для хранения комментариев создавался отдельный форум, то выпадающем списке выберите созданный. Если форум специально не создавался, то оставьте значение по умолчанию.
Пути к страницам | При смене дизайна со штатного на собственный можно изменить расположение страниц с отчётами. В этом случае нужно указать новые пути до страниц.


Форум. Описание модуля

Описание

Грамотно организованный веб-портал обычно позволяет своим посетителям общаться между собой, задавать вопросы, которые могут быть адресованы одновременно посетителям и администрации сайта. Основным средством подобной коммуникативности является форум, который может служить также дополнением к обычной службе техподдержки. Кроме того, форум - прекрасное средство привлечения дополнительных посетителей на сайт, поскольку поисковые машины обычно индексируют текстовое содержимое сообщений форума в дополнение к основному содержанию сайта.

Модуль Форум служит для создания и управления форумами сайта. Основные возможности модуля включают:

  • возможность самостоятельно строить и гибко модифицировать публичную часть (внешний вид) форума, опираясь на высокоуровневые функции и классы ядра форума;
  • создавать необходимое число форумов;
  • гибко регулировать права доступа клиентов на чтение и отправку сообщений в форум;
  • создавать модерируемые и постмодерируемые форумы;
  • назначать модераторами форума группы сотрудников;
  • устанавливать звания (статусы) посетителей в зависимости от количества баллов, присвоенных тому или иному посетителю другими посетителями или полученных им за количество сообщений;
  • управлять настройками форумов;
  • прочие возможности.

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Форум (комплексный компонент) | forum | Создает полноценный публичный интерфейс форума.
Помощь | forum.help | Выводит помощь по форуму.
[link=63182 ]Форумы (список)[/link] | forum.index | Выводит список всех форумов.
Шаблоны | forum.interface | Сборник js-библиотек служебных шаблонов.
[link=63161]Меню[/link] | forum.menu | Выводит меню форума.
Сообщения (проверка) | forum.message.approve | Выводит неодобренные сообщения форума.
Сообщения (перемещение) | forum.message.move | Служит для перемещения сообщений форума.
Письмо | forum.message.send | Выводит форму отправки письма (сообщения) пользователю.
PM (изменение) | forum.pm.edit | Служит для создания нового или редактирования существующего персонального сообщения.
PM (папки) | forum.pm.folder | Выводит список личных папок пользователя.
PM (список) | forum.pm.list | Выводит список личных сообщений пользователя из указанной папки.
PM (чтение) | forum.pm.read | Создает страницу детального просмотра персонального сообщения.
PM (поиск) | forum.pm.search | Выводит форму поиска пользователя.
Форма создания сообщения | forum.post_form | Выводит форму создания сообщения (или темы) форума.
RSS форума | forum.rss | Служит для экспорта RSS форума в указанном формате.
[link=63170 ]Правила[/link] | forum.rules | Служит для создания страницы с правилами форума.
Поиск | forum.search | Выводит форму поиска по форумам.
Статистика | forum.statistic | Выводит статистику по форуму.
Подписка | forum.subscribe.list | Выводит список подписок пользователя на сообщения и темы форумов.
Темы (новые) | forum.topic.active | Выводит список новых тем форума.
Темы (список внешний) | forum.topic.last | Выводит список тем (для использования вне форума).
Темы (список) | forum.topic.list | Выводит список всех тем форума.
Темы (перемещение) | forum.topic.move | Создает страницу перемещения тем форума.
Темы (создание) | forum.topic.new | Создание новой темы форума.
Темы (чтение) | forum.topic.read | Выводит список сообщений темы форума.
Темы (отзывы) | forum.topic.reviews | Выводит форму для создания отзыва к элементу инфоблока (например, новости, фотографии), а также весь список отзывов.
Темы (поиск) | forum.topic.search | Выводит форму поиска тем форума.
Пользователь (список пользователей) | forum.user.list | Выводит список пользователей форума.
Пользователь (сообщения) | forum.user.post | Выводит список сообщений, тем пользователя форума.
Пользователь (изменение профиля) | forum.user.profile.edit | Выводит форму редактирования профиля пользователя.
Пользователь (профиль) | forum.user.profile.view | Служит для просмотра профиля пользователя форума.

Смотрите также

  • Как создать комментарии к элементам сайта
  • Как назначить и организовать работу модератора форума?
  • Документация для разработчиков по модулю Форум
  • Настройки модуля Форум
  • Форумы
  • Управление темами и подписками
  • Звания и баллы


Форум. Настройки модуля

Закладки

Форма настроек модуля Форум (Настройки > Настройки продукта > Настройки модулей > Форум) предназначена для задания общесистемных параметров модуля.

Настройки

Поле | Описание
E-Mail для поля From писем с форума | Указывается адрес отправителя, подставляемый по умолчанию в поле FROM писем, отправляемых с форума. С версии 20.700.0 Главного модуля (main) возможно использовать email с [dw]IDN[/dw][di]IDN (англ. Internationalized Domain Names — интернационализованные доменные имена) — это доменные имена, которые содержат символы национальных алфавитов, например, мойсайт.рф. Подробнее [image] ...[/di], включая кириллические домены.
Включить бонусную систему | При отмеченной опции посетителям форума можно будет участвовать в голосовании для присвоения баллов авторам сообщений форума. Количество баллов, присвоенное посетителю форума, влияет на звание данного посетителя. Если данная опция выключена, то для оценки пользователей будет использоваться функционал Рейтинги.
Журналировать действия пользователей | При отмеченной опции (модерирование форума) будут журналироваться все действия по модерированию форума. При этом появится дополнительная опция изменение сообщения автором, которая позволяет заносить записи в журнал при изменении сообщений фрума автором.
Пользовательские настройки
Разрешить редактировать свои сообщения | При отмеченной опции автору будет разрешено редактировать свои сообщения форума.
Показывать имя пользователя (по-умолчанию для новых пользователей) | При отмеченной опции для новых пользователей форума будет показываться имя пользователя, а не логин.
Галерея смайлов форума | Выбирается, какая галерея смайлов будет использоваться в модуле Форум.
Добавлять к ссылкам rel='nofollow' | При отмеченной опции ко всем ссылкам в сообщениях форума будет добавлен параметр rel='nofollow'.
Открывать ссылки в новом окне (target='_blank') | При отмеченной опции все ссылки в сообщениях форума будут открываться в новом окне.
Использовать автосохранение | При отмеченной опции на форуме будет включен режим автосохранения [image] .
Максимальный размер аватара (байт) | Указывается максимальный размер файла аватара в байтах.
Максимальная ширина / высота аватара (пикселей) | Указывается максимально допустимые ширина и высота аватара в пикселях.
Максимальный размер загружаемых файлов (байт) | Указывается максимально допустимый размер файлов в байтах, разрешенных для загрузки на форум.
Настройки персональных сообщений
Версия | Указывается версия персональных сообщений. Версия 1.0 и 2.0 отличаются моделью взаимодействия «отправитель-получатель»: в версии 1.0 отправленное и полученное письмо - одна запись таблицы базы данных, в версии 2.0 - две разные сущности.
Размер ящика (сообщений) | Указывается размер ящика сообщений (количество сообщений, помещающихся в ящике).
Поиск
Количество документов, переиндексируемых за шаг | Задается количество документов, переиндексируемых за шаг поиска.
Названия статусов пользователей
Язык | Используемые в системе языки.
Поля статусов | Для всех созданных в системе языков задаются названия каждого статуса пользователей форума.

Доступ

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Форум:
  • [D] закрыт - запрет на доступ;
  • [R] просмотр всех данных модуля - разрешается только просмотр всех данных модуля;
  • [W] запись - полный доступ к ресурсам модуля.
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.

Фильтр нецензурных слов

Поле | Описание
Включить фильтр нецензурных слов | При отмеченной опции будет доступен для использования на форуме фильтр нецензурных слов, при этом станут активными следующие два поля: Действия с найденными словами и Замена.
Действия с найденными словами Указывается одно из действий, которое будет совершено с найденными нецензурными словами:
  • Ничего;
  • Удалить;
  • Заменить.
Замена | Если в качестве действия с найденными словами выбрано Заменить, то необходимо указать словосочетание или слово, на которое будет заменено нецензурное слово.
Языкозависимые параметры
Язык | Используемые в системе языки.
*Словарь слов и регулярных выражений | Для всех созданных в системе языков указываются словари нецензурных слов и регулярных выражений.
Словарь транслита | Для всех созданных в системе языков указываются словари транслита нецензурных слов.


Список форумов

Страница Список форумов (Сервисы > Форумы > Список форумов) содержит информацию о существующих форумах, позволяет создавать новые форумы и управлять существующими. Информация о форумах представлена в виде таблицы.

Фильтр

Форма фильтр + поиск используется для фильтрации списка форумов в соответствии с указанными условиями, а также для поиска по списку.

Поле | Описание
ID | Отбор форумов по идентификатору в системе.
Активный | Отбор форумов по признаку активности.
Сайт | Сайт, к которому относятся форумы.
Группа форумов | Группа, к которой относятся форумы.
Доступны для чтения | Отбор форумов по доступе группе пользователей (право доступа Чтение или выше)

Чтобы отобрать форумы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех форумов нажмите кнопку Сбросить.

Контекстная панель

Кнопка | Описание
Добавить форум | Переход к созданию нового форума.

Список форумов

Поле | Описание
Колонка флажков | Выбор форумов, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над форумом:
  • Изменить - переход к форме редактирования форума;
  • Удалить - удаление форума.
ID | Идентификатор форума в системе.
Название форума | Произвольное название форума.
Описание форума | Произвольное описание форума.
Группа Группа форумов, к которой относится данный форум.

Форум может быть и не привязан к какой-либо группе.
Сорт. | Вес сортировки форума; применяется при выводе списка форумов.
Акт. | Признак активности форума. Если форум неактивен, то он недоступен в публичной части.
Сайт | Сайт(ы), к которым относится данный форум.
Доступ | Отображает установленные права доступа для групп пользователей.
Модерируемый | Форум с модерацией сообщений или нет.
Индексируемый | Индексируется ли данный форум или нет.
Сортировка тем | По какому свойству темы происходит сортировка в данном форуме.
Направление сортировки тем | Направление сортировки в данном форуме: по убыванию или по возрастанию.
Тем | Количество тем на форуме.
Ответов | Количество ответов на форуме.
Неодобренных ответов | Количество неодобренных ответов.

Групповые действия

Действие | Описание
Редактировать | Отметьте нужные форумы в столбце флажков и нажмите Редактировать для редактирования параметров форума "на месте" без перехода к формам редактирования.
Удалить | Отметьте нужные форумы в столбце флажков и нажмите Удалить для удаления одного или нескольких форумов.
Очистить служебные данные | Выполнить очистку служебных данных форумов (кеш сообщений форума).


Создание и редактирование форума

Форма применяется как для создания новых, так и для редактирования существующих форумов.

Примечание: правами на создание новых форумов обладают только администраторы сайта.

Контекстная панель

Кнопка | Описание
Список форумов | Переход на страницу со списком форумов.
Создать новый форум | Переход к форме создания нового форума. Кнопка отображается при редактировании существующего форума.
Удалить форум | Удаление редактируемого форума.

Закладка Форум

Настройка общих параметров форума.

Поле | Описание
Активность | Признак активности форума. Неактивные форумы доступны только тем пользователям, которые имеют права на полный доступ к ним.
Группа форумов | Группа, к которой относится форум. Может быть не установлена (т.е. форум без группы).
*Сортировка | Относительный "вес", определяющий порядок показа форумов в рамках одной группы. Чем больше значение поля, тем ниже в списке будет расположен форум.
*Имя форума | Произвольное название форума.
Описание | Краткое описание форума. Описание будет показано в публичной части под названием форума.
Сайты, на которых доступен форум / Шаблон пути к сообщению на сайте
<Сайт> | Выбираются сайты, на которых будет доступен форум.
Шаблон пути к сообщению на сайте Шаблон пути к сообщениям форума для данного сайта. Это поле используется при отправке почтовых сообщений с форума и при индексировании сообщений форума в модуле поиска.

Пример шаблона:
/forum/index.php?

PAGE_NAME=read&FID=#FORUM_ID#&TID=#TOPIC_ID#&MID=#MESSAGE_ID##message#MESSAGE_ID#

Переменные #MESSAGE_ID#, #MID#, #TOPIC_ID#, #TID#, #TITLE_SEO#, #FORUM_ID#, #FID#, #PARAM1#, #PARAM2#, #SOCNET_GROUP_ID#, #OWNER_ID# при использовании шаблона автоматически заменяются на реальные код форума, код темы, код сообщения и т.д.

* - Поля, обязательные для заполнения.

Закладка Настройки

Поле | Описание
Индексация При отмеченной опции сообщения форума будут индексироваться модулем поиска.

Примечание: При изменении значения может потребоваться переиндексация форума

Модерация | Включение режима премодерирования: сообщения пользователей будут публиковаться на сайте только после проверки модератором (администратором сайта или другим пользователем с соответствующими правами).
Одинаковые сообщения в теме | При отмеченной опции запрещается писать два одинаковых сообщения в теме, независимо от очередности сообщений.
Сортировать по Сортировка "по умолчанию" тем в рамках одного форума в публичной части сайта. Выберите вариант сортировки сообщений, а также направление сортировки. Доступна сортировка по:
  • дате последнего сообщения;
  • тема сообщения;
  • количество ответов;
  • количество просмотров;
  • дата начала темы
  • автор темы;
Направление сортировки | Направление сортировки для выбранного режима сортировки.
Прикреплять первое сообщение темы | При отмеченной опции будет прикрепляться первое сообщение темы.
Позволить пользовательские подписи под сообщением | При отмеченной опции под сообщением будет автоматически отображаться подпись пользователя.
Позволить загрузку Разрешить загрузку присоединенных к сообщению файлов указанного типа. Возможные варианты значений:
  • нет - загрузка запрещена;
  • изображения - загрузка только изображений (gif, jpg, png, jpe, jpeg);
  • файлов с указанными расширениями - загрузка только файлов с расширениями из поля Допустимые расширения загружаемых файлов;
  • любых файлов - загрузка любых файлов. Не разрешайте без крайней необходимости загрузку выполнимых файлов и скриптов, так как это может позволить злоумышленникам полностью разрушить ваш сайт.
Допустимые расширения загружаемых файлов (для загрузки файлов с указанными расширениями, расширения разделять запятой) | Расширения файлов, разрешенных к загрузке на сайт (см. описание предыдущего поля).
Пользовательские настройки
Запросить E-Mail у гостя | Определяет, будет ли запрашиваться адрес почты у незарегистрированного пользователя при попытке добавления им сообщения.
Использовать CAPTCHA | Определяет, использовать ли защиту от автоматического заполнения. Используется только для неавторизованных пользователей
Регистрация новых сообщений в модуле статистики**
event1 | Идентификатор типа события - event1
event2 | Идентификатор типа события - event2
event3 | Дополнительный параметр события - event3
Настройки парсера
Смайлы | Разрешить использование смайликов в сообщении.
HTML-код | Разрешение или запрещение использования HTML-кода в тексте сообщения. Не рекомендуется разрешать использование произвольного HTML-кода на форуме без особой необходимости, так как это существенно снижает безопасность форума. При включенной опции работают BBCode.
Дополнительные настройки Дополнительные возможности настроек форума:
  • Позволить ссылки - Разрешить использование гиперссылок в сообщении (<a href=...>).
  • Позволить теги B, U, I, S - Разрешить выделение текста полужирным, подчеркиванием, курсивом или перечеркивание(<b> <u> <i> <s>).
  • Позволить изображения - Разрешить использование изображений в тексте сообщения. Изображения располагаются на сторонних сайтах и подключаются на форуме (<img src=...>).
  • Позволить видео - Разрешается использование видео в сообщениях форума.
  • Позволить списки - Разрешить создание списков (<ul><li>).
  • Позволить таблицы - Разрешить использование таблиц (<table>).
  • Позволить выравнивание - Разрешить использование выравнивания текста.
  • Позволить цитирование - Возможность цитировать сообщение другого пользователя ().
  • Позволить коды - Использование кодов в сообщении (<code>).
  • Позволить шрифты - Возможность изменения цвета текста и шрифт (<font color=...>).
  • Заменять символ перевода каретки на <br> - замена символа перевода каретки на <br> (Доступно только при отмеченной опции HTML-код).

** Секция служит для настройки идентификаторов, с использованием которых событие создания нового сообщения на форуме будет регистрироваться в модуле статистики.

Закладка Доступ

Предназначена для установки прав доступа к форуму для каждой из зарегистрированных на сайте групп пользователей. По умолчанию права имеют следующие значения.

Поле Описание
[Группа пользователей]

Уровень доступа к форуму для данной группы пользователей:

  • Нет доступа - запрет на доступ к форуму;
  • Чтение - доступ на чтения сообщений форума без права создания новых тем;
  • Ответ - доступ к обсуждению существующих тем без права создания новых тем;
  • Новая тема - доступ к обсуждению существующих тем, а также возможность создания новых тем;
  • Модерирование - возможность модерировать форум, т.е. производить те действия, которые не повлекут реальной потери данных. Например, модераторы могут скрыть или показать сообщение, но не могут отредактировать или удалить его. Члены группы с данным уровнем прав имеют возможность подписаться на получение копии всех сообщений форума по почте.
  • Редактирование - доступ к управлению чужими сообщениями на форуме;
  • Полный доступ - полный доступ к форуму, включая доступ к настройкам форума и прав доступа.

Примечание: Младшие права включаются в старшие (т.е. если группа имеет право на модерирование форума, то она тем более имеет право читать сообщения, отвечать на сообщения, создавать новые темы, но не имеет права на редактирование сообщений). При определении прав пользователя, который принадлежит к нескольким группам, берется максимальное из его прав.

Смотрите также

  • Форумы (учебный курс "Администратор. Модули")


Группы форумов

Страница Группы форумов (Сервисы > Форумы > Группы форумов) содержит список существующих групп форумов, а также позволяет перейти к созданию и изменению групп форумов.

Группы используются для группировки форумов в публичной части сайта. Например, можно объединить все форумы, имеющие отношение к различным вопросам по конкретному продукту, в одну группу: форум Лицензирование, форум Применение и пр. Возможно создание вложенных групп форумов.

Каждый форум может быть привязан к одной из групп форумов, либо может остаться без привязки.

Контекстная панель

Кнопка | Описание
Новая группа форумов | Переход к созданию новой группы форумов.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список групп форумов

Поле | Описание
Колонка флажков | Выбор групп, к которым предполагается применить какое-либо правило или действие.
Действия Действие над группой форумов:
  • Изменить параметры группы - редактирование группы форумов;
  • Удалить группу - удаление группы форумов. Удаление группы не влечет удаление форумов, относящихся к данной группе.
Код | Уникальный код группы форумов.
Название | Название группы, показываемое в публичной части.
Сорт. | Относительный "вес", определяющий положение группы в списке. Чем меньше значение, тем выше в списке показывается группа.


Создание и редактирование группы

Форма используется для создания и редактирования групп форумов, предназначенных для группировки форумов в публичной части сайта.

Контекстная панель

Кнопка | Описание
Список групп форумов | Переход на страницу со списком групп форумов.
Создать новую группу | Переход к форме создания новой группы форумов. Кнопка отображается при редактировании существующей группы.
Удалить группу | Удаление текущей группы форумов.

Форма редактирования

Поле | Описание
Код | Идентификатор группы форумов в системе. Поле отображается при редактировании группы форумов.
Сортировка | Относительный "вес", определяющий положение группы в списке. Чем меньше значение, тем выше в списке показывается группа.
Родительская группа | Выбор из выпадающего списка группы форумов, в составе которых данный форум будет вложен. Выбор многоточия означает верхний уровень вложенности.
[Язык]
*Название | Название группы, показываемое в публичной части. Название задается для каждого языка, используемого в системе.
Описание | Произвольное описание группы для каждого языка.

* - Поля, обязательные для заполнения.

Смотрите также

  • Группы форумов (учебный курс "Администратор. Модули")


Звания

Страница Звания (Сервисы > Форумы > Звания) содержит список созданных званий, а также позволяет перейти к созданию новых и изменению существующих званий.

Звания посетителей устанавливаются в зависимости от количества набранных баллов. Пользователь может получить баллы как за количество сообщений, созданных на форуме, так в результате голосования других посетителей форума.

Примечание: для использования данного функционала следует включить опцию Включить бонусную систему в глобальных настройках модуля форума. Если опция Включить бонусную систему неактивна, то звания будут устанавливаться на основе рейтингов.

Контекстная панель

Кнопка | Описание
Новое звание | Переход к форме создания нового звания.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список званий

Поле | Описание
Колонка флажков | Выбор званий, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над званием:
  • Изменить параметры звания - редактирование звания;
  • Удалить звание - удаление звания.
ID | Идентификатор звания в системе.
Название | Название звания, как оно отображается на форуме.
Необходимо баллов Количество баллов, требуемое для получения этого звания.

Примечание:Доступно при включенной опции Включить бонусную систему в настройках модуля Форум (Настройки > Настройки продукта > Настройки модулей > Форум).
Голосов Количество голосов, требуемое для получения этого звания.

Примечание:Доступно при включенной опции Включить бонусную систему в настройках модуля Форум (Настройки > Настройки продукта > Настройки модулей > Форум).

Необходимо нормированных голосов Количество нормированных голосов, требуемое для получения этого звания.

Примечание:Доступно при выключенной опции Включить бонусную систему в настройках модуля Форум (Настройки > Настройки продукта > Настройки модулей > Форум).


Создание и редактирование звания

Форма применяется как для создания новых, так и для редактирования существующих званий посетителей форума.

Контекстная панель

Кнопка | Описание
Список званий | Переход на страницу со списком званий.
Добавить новое звание | Переход к форме создания нового звания. Кнопка отображается при редактировании существующего звания.
Удалить звание | Удаление редактируемого звания.

Форма редактирования

Поле | Описание
ID | Идентификатор звания.
*Для получения звания необходимо баллов | Количество баллов, требуемое для получения этого звания.
Мнемонический код | Символьный код звания. Поле предназначено для использования разработчиками.
Имеет голосов | Количество голосов, которое отдает обладатель этого звания при каждом голосовании. Примечание: Доступно при включенной опции Включить бонусную систему в настройках модуля Форум (Настройки > Настройки продукта > Настройки модулей > Форум).
[Язык]
*Название | Название звания, как оно отображается на форуме. Название задается отдельно для каждого языка.

* - Поля, обязательные для заполнения.

Смотрите также

  • Звания и баллы (учебный курс "Администратор. Модули")


Баллы за сообщения

Форма Баллы за сообщения (Сервисы > Форумы > Баллы за сообщения) предназначена для управления количеством баллов, присваиваемых пользователю форума за каждое отправленное сообщение. При помощи этой формы можно легко настроить кумулятивную систему начисления баллов (т.е. количество баллов за одно сообщение будет увеличиваться в зависимости от общего числа отправленных сообщений).

Контекстная панель

Поле | Описание
Новая запись | Добавление новой записи с количеством баллов за сообщение.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список баллов за сообщение

Поле | Описание
Колонка флажков | Выбор записей, к которым предполагается применить какое-либо правило или действие.
Действия Действия над записью о количестве баллов за сообщение:
  • Изменить параметры - редактирование записи;
  • Удалить - удаление записи.
ID | Идентификатор записи в системе.
Необходимо сообщений Число сообщений, начиная с которого за каждое сообщение будет начисляться указанное в записи количество баллов.

Например, если значение поля равно 10, то начиная с десятого сообщения посетителю будет начисляться новое (указанное в данной записи) количество баллов за каждое сообщение.
Баллов за сообщение | Количество баллов, начисляемое за сообщение, при достижении указанного в предыдущем поле числа сообщений.


Создание и редактирование баллов за сообщение

Форма служит как для создания новых, так и для редактирования существующих записей с количеством баллов за сообщение.

Контекстная панель

Кнопка | Описание
Список записей | Переход на страницу со списком записей о количестве баллов, присваиваемых за сообщение.
Добавить новую запись | Переход к форме создания новой записи. Кнопка отображается при редактировании существующей записи.
Удалить запись | Удаление редактируемой записи.

Форма редактирования

Поле | Описание
ID | Идентификатор записи в системе. Отображается только при редактировании записи.
*Необходимо сообщений | Число сообщений, начиная с которого за каждое сообщение будет начисляться указанное в записи количество баллов.
Баллов за сообщение | Количество баллов, начисляемое за сообщение, при достижении указанного в предыдущем поле числа сообщений.

* - Поле, обязательное для заполнения.

Смотрите также

  • Звания и баллы (учебный курс "Администратор. Модули")


Смайлики форума (до v.15.5.2)

Внимание! Начиная с версии 15.5.2 в модуле Форум используются смайлы ядра системы.

Форма Смайлики форума (Сервисы > Форумы > Смайлики) служит для изменения набора доступных смайликов и иконок. После добавления смайлика или иконки нестандартного размера проверьте внешний вид публичной части форума - возможно, потребуется внести некоторые изменения.

Контекстная панель

Кнопка | Описание
Новый смайлик | Добавление нового смайлика.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список смайликов

Поле | Описание
Колонка флажков | Поле предназначено для выбора записей, к которым предполагается применить какое-либо правило или действие.
Действия Действия над записью:
  • Изменить параметры смайлика - редактирование смайлика;
  • Удалить смайлик - удаление смайлика.
Код | Уникальный системный код смайлика.
Название | Название изображения, показываемое в публичной части.
Сорт. | Вес сортировки смайлика. Определяет порядок вывода смайликов в списке.
Тип | Тип изображения - смайлик (выражение эмоции) или иконка (гештальт суждения).
Написание | Символьный эквивалент изображения.
Изображение | Само изображение смайлика или иконки.
Файл | Путь к файлу с изображением смайлика.


Создание и редактирование смайлика (до v.15.5.2)

Внимание! Начиная с версии 15.5.2 в модуле Форум используются смайлы ядра системы.

Форма предназначена для создания новых и редактирования уже существующих смайликов.

Контекстная панель

Кнопка | Описание
Список смайликов | Переход на страницу со списком смайликов.
Добавить новый смайлик | Добавление нового смайлика. Кнопка отображается при редактировании существующего смайлика.
Удалить смайлик | Удаление редактируемого смайлика.

Форма редактирования

Поле | Описание
Код | Уникальный системный код смайлика. Поле отображается при редактировании смайлика.
Сортировка | Вес сортировки смайлика. Определяет порядок вывода смайликов в списке.
Тип смайлика | Укажите тип смайлика: смайлик или иконка.
Написание смайлика | Символьный эквивалент изображения. Возможно перечисление нескольких вариантов через пробел.
Изображение смайлика | Изображение смайлика или иконки. Для загрузки изображения служит кнопка Обзор. Рекомендуемый размер смайликов: 16x16, иконок: 15x15.
[Язык]
*Название смайлика | Название изображения, показываемое в публичной части. Название указывается для каждого языка, используемого в системе.

* - Поля, обязательные для заполнения.


Управление темами

На странице Управление темами (Сервисы > Форумы > Управление темами) представлена информация о существующих темах форумов.

Форма поиска

Поиск тем в соответствии с указанными условиями.

Поле | Описание
Форум | Название форума, к которому относится тема. Поле присутствует, даже если фильтр свернут.
Название | Поиск темы по ее названию.
Описание | Поиск темы по описанию.
Модер. | Поле позволяет отобразить только одобреные либо только скрытые, либо все темы.
Сортировка | Поиск темы по типу сортировки.
Статус | Поле позволяет отобразить темы определенного статуса.
Создано | Параметр определяет диапазон дат, в пределах которых искомые темы могли быть созданы.
Последнее сообщение | Параметр определяет диапазон дат, в пределах которых было создано последнее сообщение темы.
ID автора темы | Поиск темы по идентификатору ее автора.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список тем

Поле | Описание
Колонка флажков | Выбор тем, к которым предполагается применить какое-либо правило или действие.
ID | Идентификатор темы.
Название | Название темы, отображаемое в публичной части.
Описание | Произвольное описание форума.
Статус | Статус, в котором находится тема.
Модер. | Указывается одобрена или скрыта созданная тема. Если форум не является премодерируемым, то все его темы всегда одобрены.
Сортировка | Указывается тип сортировки темы: важно или обычно.
Автор | Имя автора темы.
Создано | Дата и время создания темы.
Сообщения | Общее количество сообщений в данной темы форума.
Просмотров | Общее количество просмотров данной темы форума.
Форум | Форум, на котором создана тема.
Последнее сообщение | Дата и время последнего сообщения на форуме.

Смотрите также

  • Управление темами и подписками (учебный курс "Администратор. Модули")


Управление подпиской

На странице Управление подпиской пользователей(Сервисы > Форумы > Управление подпиской) представлена информация о пользователях, имеющих подписки на форумы.

Форма поиска

Форма фильтр + поиск используется для фильтрации списка пользователей, имеющих подписки, в соответствии с указанными условиями, а также для поиска по списку.

Поле | Описание
Логин | Логин пользователя.
Фамилия, имя, отчество | Отбор пользователей по фамилии, имени, отчеству.
E-Mail | E-Mail пользователя.
Дата начала подписки | Диапазон дат, в пределах которых подписки пользователей могли быть начаты.
Форум | Позволяет найти пользователей, подписки которых относятся к указанному форуму.
Вид подписки | Поиск пользователей, имеющих указанный вид подписки.

Чтобы отфильтровать список пользователей по заданным критериям поиска, нажмите кнопку Найти. Для отображения всего списка нажмите кнопку Сбросить.

Список пользователей, имеющих подписки

Поле | Описание
Колонка флажков | Выбор пользователей, имеющих подписки, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно применить к элементу списка:
  • Изменить - переход на форму подписок пользователя;
  • Удалить - удаление всех подписок пользователя.
ID | Идентификатор пользователя в системе.
E-Mail | E-Mail пользователя.
Логин | Логин пользователя.
Имя | Имя пользователя.
Фамилия | Фамилия пользователя.
Количество подписок | Количество подписок, которые имеет пользователь.

Групповые действия

Действие | Описание
Удалить | Отметьте нужные форумы в столбце флажков и нажмите Удалить для удаления одного или нескольких форумов.

Смотрите также

  • Управление темами и подписками (учебный курс "Администратор. Модули")


Подписки пользователя

На форме Подписки пользователя <логин_пользователя> представлена информация обо всех подписках этого пользователя.

Форма поиска

Поиск подписок пользователя в соответствии с указанными условиями.

Поле | Описание
Найти | Поиск подписки пользователя по их основным параметрам: форуму или теме. Это поле присутствует, даже если фильтр свернут.
Форум | Поиск подписки пользователя по названию форума, к которому относится подписка.
Дата начала подписки | Диапазон дат, в пределах которых искомые подписки могли быть начаты.
Вид подписки | Поле позволяет определить вид подписки.

Чтобы отфильтровать подписки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех подписок нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Список пользователей | Переход на страницу со списком пользователей, имеющих подписки на форумах.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список подписок пользователя

Поле | Описание
Колонка флажков | Выбор подписок, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно применить к элементу списка:
  • Удалить - удаление подписки пользователя.
FID | Идентификатор пользователя в модуле Форум.
ID | Идентификатор пользователя в системе.
Форум | Название форума, к которому относится подписка.
Тема | Название подписки и непосредственно темы форума.
Начало подписки | Дата и время начала подписки.
Последнее сообщение | Идентификатор последнего отправленного пользователем сообщения.


Модерирование форума

Модерирование форума выполняется из публичного раздела сайта. При просмотре сообщений форума для пользователей, обладающих правом на модерирование сообщений данного форума, рядом с каждым сообщением будет отображаться кнопка Показать/Скрыть. С помощью этой кнопки модератор может скрыть сообщение от других посетителей форума, либо сделать сообщение доступным для просмотра.

Примечание: Если форум является премодерируемым, то все вновь создаваемые сообщения данного форума являются скрытыми. Для того чтобы сообщения стали доступны посетителям форума, модератор форума (либо администратор сайта) должен разрешить показ данных сообщений.


Часто задаваемые вопросы

Вопросы

  • Как мне создать тему в форуме?
  • Могу ли я использовать HTML?
  • Как мне отформатировать текст сообщения, если HTML не разрешен?
  • Могу ли я вставлять картинки?
  • Что такое смайлики?
  • Зачем мне нужно регистрироваться?
  • Как мне изменить мои настройки?
  • Я хочу получать новые сообщения по почте!
    •

    Как мне создать тему в форуме?

    Щёлкните по соответствующей кнопке или ссылке в окне списка тем форума или конкретной темы. Вам, возможно, придётся зарегистрироваться, прежде чем отправить сообщение.

    Могу ли я использовать HTML?

    Зависит от того разрешено ли это администратором. Если разрешено его использовать, то, скорее всего, работать будут лишь несколько тегов. Это сделано для безопасности, чтобы запретить использование тегов, которые могут вызвать проблемы в работе сайта.

    Как мне отформатировать текст сообщения, если HTML не разрешен?

    Администратором может быть разрешено использование следующих тегов.
    Тег | Описание | Синонимы | Примечание
    <a href="ссылка"> Ссылка [URL]ссылка[/URL]
    [URL=ссылка]         		Должен всегда присутствовать соответствующий закрывающий тег </a>.
    <b>, <u>, <i> | Жирный, подчёркнутый текст или курсив соответственно | [b], [u], [i] | Должен всегда присутствовать соответствующий закрывающий тег </b>, </u>, </i>.
    <img src="адрес"> | Рисунок | [img]адрес[/img] | Адрес - полный путь к рисунку на любом публичном сайте.
    <ul>, <li> | Ненумерованные списки | [ul], [li] | Должен всегда присутствовать соответствующий закрывающий тег </ul>, </li>.
    <quote> | Специальный тег для выделения цитирования | [quote] | Должен всегда присутствовать соответствующий закрывающий тег </quote>.
    <code> | Специальный тег для выделения кода | [code] | Должен всегда присутствовать соответствующий закрывающий тег </code>.
    <font color=>, <font size=> | Изменение цвета и размера шрифта | [color=цвет], [size=размер] | Должен всегда присутствовать соответствующий закрывающий тег </font>.

    Могу ли я вставлять картинки?

    Вы можете вставлять картинки в сообщения, если это разрешено администратором. Вы должны указать ссылку на картинку, которая находится на общедоступном сервере, например: [img]http://www.1c-bitrix.ru/images/logo_bitrix.gif[/img] или <img src="http://www.1c-bitrix.ru/images/logo_bitrix.gif">.

    Что такое смайлики?

    Смайлики, или иконки эмоций - это маленькие картинки, которые могут быть использованы для выражения чувств, например :) значит радость, :( значит грусть. Полный список смайликов можно увидеть в форме создания сообщений. Только не перестарайтесь, используя их: они легко могут сделать сообщение нечитаемым, и модератор может отредактировать ваше сообщение, или вообще удалить его.

    Зачем мне нужно регистрироваться?

    Вы можете этого и не делать. Всё зависит от того, как администратор настроил форум: должны ли вы зарегистрироваться, чтобы размещать сообщения или нет.

    Как мне изменить мои настройки?

    Все ваши настройки хранятся в базе данных (если вы зарегистрированы). Чтобы изменить их, перейдите в раздел Профиль (ссылка на него находится вверху форума). Там вы можете изменить все свои настройки. Доступ в раздел Профиль возможен только после регистрации.

    Страница изменения профиля посетителя состоит из трех частей: изменение регистрационной информации, изменение личных данных и изменение профиля на форуме.

    • Раздел изменения регистрационной информации служит для изменения имени, фамилии, логина и пароля пользователя
    • Раздел изменения личных данных служит для указания профессии, номера ICQ, даты рождения, фотографии, места жительства и других личных данных
    • Раздел изменения профиля на форуме служит для изменения представления на форуме:
      • Показывать имя. В качестве имени автора сообщения используется его имя и фамилия, если они не пусты. В противном случае используется логин автора. Этот флаг запрещает использование имени и фамилии вне зависимости от их заполненности;
      • Пояснение - пояснение автора, оно будет выводиться под именем автора сообщения. В качестве пояснений запрещено использовать слова и выражения, содержащие слова админ, модератор, support и т.п. Нарушители будут удаляться с форума без предупреждения;
      • Подпись - автоматическая подпись под каждым сообщением этого пользователя. В подписи допустимо использовать любые разрешенные на данном форуме теги;
      • Аватар - изображение, показываемое под именем автора сообщения. Изображение должно быть размером не более 10 кб и разрешением не более 90x90 пикселов.

    Я хочу получать новые сообщения по почте!

    Вы можете подписаться как на получение новых сообщений со всего форума, так и на получение новых сообщений по конкретной теме. Для этого вы должны быть зарегистрированы на сервере. Если вы хотите подписаться на новые сообщения со всего форума, воспользуйтесь ссылкой Подписаться меню форума. Если вы хотите подписаться на новые сообщения конкретной темы, воспользуйтесь ссылкой Подписаться в правом верхнем углу темы.

    Существует третий вид подписки - только на новые темы (т.е. на первое сообщение каждой темы). Все три типа подписки доступны в меню форума. Управление подпиской также доступно из меню форума.

    Для управления подпиской перейдите по ссылке Изменить подписку, расположенной в вашем профиле.


Отправить отзыв по этому разделу

Фильтр нецензурных слов

  • Список словарей нецензурных слов/транслита
  • Создание/редактирование словаря
  • Словарь слов
  • Создание/редактирование записи словаря нецензурных слов
  • Словарь транслита
  • Создание/редактирование записи словаря транслита


Список словарей нецензурных слов/транслита

Отправить отзыв по этому разделу
Сервисы>Форум>Фильтр нецензурных слов>Список словарей нецензурных слов/транслита

Фильтр нецензурных слов::Список словарей нецензурных слов/транслита

Список словарей нецензурных слов

На странице Словарь нецензурных слов (Сервисы > Форумы > Фильтр нецензурных слов > Словарь нецензурных слов ) представлен список словарей нецензурных слов.

Фильтр

Поиск словарей слов в соответствии с указанными условиями.

Поле | Описание
Название | Поиск словарей по названию.

Чтобы отфильтровать словари по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех словарей нажмите кнопку Отменить.

Контекстная панель
Кнопка | Описание
Добавить | Добавление нового словаря.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список словарей нецензурных слов
Поле | Описание
Колонка флажков | Выбор словарей, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно применить к элементу списка:
  • Изменить - переход на форму редактирования словаря;
  • Удалить - удаление словаря.
ID | Идентификатор словаря.
Название | Название словаря.

Список словарей транслита

На странице Словарь транслита (Сервисы > Форумы > Фильтр нецензурных слов > Словарь транслита ) представлен список словарей транслита.

Фильтр

Поиск словарей слов в соответствии с указанными условиями.

Поле | Описание
Название | Поиск словарей по названию.

Чтобы отфильтровать словари по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех словарей нажмите кнопку Отменить.

Контекстная панель
Кнопка | Описание
Добавить | Добавление нового словаря.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список словарей транслита
Поле | Описание
Колонка флажков | Выбор словарей, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно применить к элементу списка:
  • Изменить - переход на форму редактирования словаря;
  • Удалить - удаление словаря.
ID | Идентификатор словаря.
Название | Название словаря.

Смотрите также

  • Фильтр нецензурных слов (учебный курс "Администратор. Модули")


Создание/редактирование словаря

Отправить отзыв по этому разделу
Сервисы>Форум>Фильтр нецензурных слов>Создание/редактирование словаря

Фильтр нецензурных слов::Создание/редактирование словаря

Форма применяется как для создания новых, так и для редактирования существующих словарей.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком словарей.

Закладка "Добавить словарь"

Поле | Описание
*Название | Указывается название словаря.
*Тип словаря Выбирается тип словаря:
  • Словарь транслитерации;
  • Словарь слов.

* - поля, обязательные для заполнения.

Смотрите также:

  • Фильтр нецензурных слов (учебный курс "Администратор. Модули")


Словарь слов

Отправить отзыв по этому разделу
Сервисы>Форум>Фильтр нецензурных слов>Словарь слов

Фильтр нецензурных слов::Словарь слов

На странице Словарь слов (Сервисы > Форумы > Фильтр нецензурных слов > Словарь нецензурных слов > [язык] Словарь слов) представлен список нецензурных слов, входящих в словарь [язык] Словарь слов. Данный словарь используется для фильтрации нецензурных слов в сообщениях форумов.

Форма поиска

Поиск нецензурных слов в соответствии с указанными условиями.

Поле | Описание
Найти | Поиск слов по наиболее типичным критериям, выбираемым в списке: слово, шаблон, замена, описание. Поле присутствует, даже если фильтр свернут.
Активен | Поиск слов по признаку активности.
Тип создания шаблона | Поиск слов по типу создания шаблона.

Контекстная панель

Кнопка | Описание
Добавить | Добавление нового слова в словарь.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список нецензурных слов

Поле | Описание
Колонка флажков | Выбор слов, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно применить к элементу списка:
  • Изменить - переход на форму редактирования слова;
  • Удалить - удаление записи в словаре.
ID | Идентификатор слова.
Активен | Признак активности.
Тип создания шаблона | Тип создания шаблона нецензурного слова.
Слово | Нецензурное слово или его часть (обычно используется корень слова).
Шаблон | Шаблон слова.
Замена Замена для нецензурного слова.

Примечание: Замена слова происходит в том случае, если в настройках модуля включен фильтр нецензурных слов и в качестве действий с найденными словами выбрано Заменить. Причем сначала проверяется, имеется ли собственная замена, если она есть, то будет использована. Если же собственной замены нет, то будет использоваться замена из настроек.
Описание | Описание слова, которое отображается только в административной части.

Смотрите также

  • Фильтр нецензурных слов (учебный курс "Администратор. Модули")


Создание/редактирование записи словаря нецензурных слов

Отправить отзыв по этому разделу
Сервисы>Форум>Фильтр нецензурных слов>Создание/редактирование записи словаря нецензурных слов

Фильтр нецензурных слов::Создание/редактирование записи словаря нецензурных слов

Форма используется для добавления в словарь новых и редактирования существующих нецензурных слов.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу словаря слов.
Добавить | Переход к форме создания нового слова. Кнопка отображается при редактировании существующего слова.
Удалить | Удаление слова. Кнопка отображается при редактировании существующего слова.

Форма редактирования

Поле | Описание
*Поиск Нецензурное слово или его часть с использованием символов:
^ - приставка;
% - суффиксы и окончания;
? - один символ;
* - любое количество словообразующих символов.
Активен | Признак активности.
Тип создания шаблона Указывается тип, на основе которого создаётся шаблон нецензурного слова. Можно выбрать один из трех вариантов:
  • Слово (без использования словаря транслита) - искаться и удаляться (заменяться) будет слово в точности с тем как оно введено в поле Поиск.
  • Транслит (с использованием словаря транслита) - искаться и удаляться (заменяться) будет слово в соответствии со словарем транслита.
  • Регулярное выражение - полное символьное выражение, которое использует система для анализа слова.
Замена Замена для нецензурного слова.

Примечание: Замена слова происходит в том случае, если в настройках модуля включен фильтр нецензурных слов и в качестве действий с найденными словами выбрано Заменить. Причем сначала проверяется, имеется ли собственная замена, если она есть, то будет использована. Если же собственной замены нет, то будет использоваться замена из настроек.

Описание | Произвольное описание для нецензурного слова, которое будет отображаться только в Административном разделе.

* - Поле, обязательное для заполнения.

Смотрите также

  • Фильтр нецензурных слов (учебный курс "Администратор. Модули")


Словарь транслита

Отправить отзыв по этому разделу
Сервисы>Форум>Фильтр нецензурных слов>Словарь транслита

Фильтр нецензурных слов::Словарь транслита

На странице Словарь транслита (Сервисы > Форумы > Фильтр нецензурных слов > Словарь транслита > [язык] Словарь транслита) представлена информация об аналоговом написании букв.

Форма поиска

Используя поле Найти данной формы вы можете выполнить поиск интересующей вас буквы или ее аналога.

Контекстная панель

Кнопка | Описание
Добавить | Служит для добавления новой записи.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Таблица элементов

Поле | Описание
Колонка флажков | Выбор записей, к которым предполагается применить какое-либо правило или действие.
ID | Идентификатор буквы.
Буква | Буква алфавита.
Аналог | Аналог буквы.

Смотрите также

  • Фильтр нецензурных слов (учебный курс "Администратор. Модули")


Создание/редактирование записи словаря транслита

Отправить отзыв по этому разделу
Сервисы>Форум>Фильтр нецензурных слов>Создание/редактирование записи словаря транслита

Фильтр нецензурных слов::Создание/редактирование записи словаря транслита

Форма используется для добавления новой записи в словарь транслита.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу Словарь транслита.

Форма редактирования

Поле | Описание
*Словарь | Словарь транслита, в который добавить новую запись.
*Буква | Написание новой буквы.
Замена | Содержимое этого поля будет заменять вышеуказанную букву.

* - Поля, обязательные для заполнения.

Смотрите также:

  • Фильтр нецензурных слов (учебный курс "Администратор. Модули")


CRM (КП). Описание модуля

Компоненты модуля

Описание модуля

Система управления взаимодействием с клиентами (или CRM, сокр. от англ. Customer Relationship Management System) — система, предназначенная для повышения уровня продаж, оптимизации маркетинга и улучшения обслуживания клиентов. В CRM сохраняется информация о клиентах и история взаимоотношений с ними для последующего анализа результатов.

Смотрите также:

  • Настройка интеграции магазина и портала Битрикс24

Действия

Название | Имя в пространстве имен bitrix | Описание
Дела (комплексный компонент) | crm.activity | Позволяет управлять списком дел.
Список задач | task.list | Выводит список задач
Список звонков/встреч | activity.calendar.list | Выводит список записей календаря.

Компании

Название | Имя в пространстве имен bitrix | Описание
Компании (комплексный компонент) | crm.company | Позволяет управлять списком компаний.
Список компаний | crm.company.list | Выводит список компаний.
Редактирование компании | crm.company.edit | Позволяет добавлять новую, или редактировать параметры имеющейся компании.
Просмотр компании | crm.company.show | Осуществляет вывод детального описания компании.
Панель инструментов | crm.company.menu | Позволяет настроить верхнее меню сущности.
Импорт компаний* | crm.company.menu | Позволяет импортировать список компаний.
* отмечены системные компоненты (не описываются)

Контакты

Название | Имя в пространстве имен bitrix | Описание
Контакты (комплексный компонент) | crm.contact | Позволяет управлять списком контактов.
Список контактов | crm.contact.list | Выводит список контактов.
Редактирование контакта | crm.contact.edit | позволяет добавлять новый, или редактировать параметры имеющегося контакта.
Просмотр контакта | crm.contact.show | Осуществляет вывод детального описания контакта.
Панель инструментов | crm.contact.menu | Позволяет настроить верхнее меню сущности.
Импорт контактов* | crm.contact.import | Предназначен для импорта списка контактов в формате CSV.
Веб сервис* | crm.contact.webservice | Предназначен для создания и экспорта контактов.
* отмечены системные компоненты (не описываются)

Лиды

Название | Имя в пространстве имен bitrix | Описание
Лиды (комплексный компонент) | crm.lead | Позволяет работать с лидами.
Трекер посетителей* | faceid.tracker | Выводит трекер посетителей и историю посещений.
Заполнение формы CRM-форм | crm.webform.fill | Отвечает за заполнение формы CRM-форм.
Список лидов | crm.lead.list | Выводит список лидов.
Редактирование лида | crm.lead.edit | Позволяет создать новый, либо редактировать существующий лид.
Просмотр лида | crm.lead.show | Осуществляет вывод детального описания лида.
Туллбар | crm.lead.menu | Позволяет настроить верхнее меню сущности.
Конвертация лида | crm.lead.convert | Позволяет конвертировать лид в контакт, компанию или сделку.
Импорт лидов* | crm.lead.import | Предназначен для импорта списка лидов в формате CSV.
Веб-сервис* | crm.lead.webservice | Сервис для создания лида.
Обработчик REST* | crm.lead.rest | Обработчик REST для создания лида.
* отмечены системные компоненты (не описываются)

Настройки

Название | Имя в пространстве имен bitrix | Описание
Настройки прав доступа | crm.config.perms | Позволяет выполнить настройку прав доступа к модулю CRM.
Настройка связей ролей | crm.config.perms.relation | Позволяет настроить связь ролей с группами сотрудников.
Редактирование роли | crm.config.perms.role.edit | Позволяет выполнить настройку прав доступа роли к сущностям CRM.
Настройки бизнес-процессов | crm.config.bp | Позволяет выполнить настройку бизнес-процессов в модуле CRM.
Список типов шаблонов бизнес-процессов | crm.config.bp.types | Выводит список типов шаблонов бизнес-процессов
Список бизнес-процессов | crm.config.bp.list | Выводит список бизнес-процессов модуля CRM.
Редактирование шаблона бизнес-процесса | crm.config.bp.edit | Позволяет отредактировать шаблон бизнес-процесса модуля CRM.
Настройки шаблонов реквизитов клиентов | crm.config.preset | Позволяет настроить шаблоны реквизитов клиентов модуля CRM.
Список неиспользуемых пользовательских полей | crm.config.preset.ufields | Выводит список пользовательских полей, которые не используются в шаблонах.
Список шаблонов реквизитов клиентов | crm.config.preset.list | Выводит список шаблонов реквизитов клиентов модуля CRM.
Настройки пользовательских полей | crm.config.fields | Позволяет выполнить настройку пользовательских полей в модуле CRM.
Список пользовательских полей | crm.config.fields.list | Выводит список пользовательских полей модуля CRM.
Список типов пользовательских полей | crm.config.fields.types | Выводит список типов пользовательских полей модуля CRM.
Настройка пользовательского поля | crm.config.fields.edit | Позволяет выполнить настройку пользовательского поля модуля CRM.
Связь с магазином (комплексный компонент) | crm.config.external_sale | Позволяет выполнить настройку интеграции CRM с интернет-магазином.
1С распознавание лиц* | faceid.1c | Идентифицирует клиентов из 1С по фотографии.
Настройка отправки писем* | crm.config.configs | Позволяет настроить отправку писем в модуле CRM.
Настройка Email-трекера* | crm.config.emailtracker | Позволяет настроить Email-трекер в модуле CRM.
Настройка Send&Save* | crm.config.sendsave | Настройка интеграции с Send&Save в модуле CRM.
Настройка интеграции с "1С:Предприятие" | crm.config.exch1c | Позволяет настроить интеграцию с "1С:Предприятие" в модуле CRM.
Настройка статусов* | crm.config.status | Позволяет выполнить настройку статусов модуля CRM.
Настройка трекера* | crm.config.tracker | Позволяет настроить трекер в модуле CRM.
* отмечены системные компоненты (не описываются)

Реквизиты

Название | Имя в пространстве имен bitrix | Описание
Список реквизитов | crm.requisite.list | Выводит список реквизитов компании.
Панель инструментов | crm.requisite.menu | Выводит панель инструментов.

Сделки

Название | Имя в пространстве имен bitrix | Описание
Сделки (комплексный компонент) | crm.deal | Позволяет работать со сделками.
Воронка продаж | crm.deal.funnel | Выводит количественное соотношение сделок на разных стадиях выполнения.
Список сделок | deal.list | Выводит список сделок.
Редактирование сделки | crm.deal.edit | Позволяет создать новую, либо редактировать существующую сделку.
Просмотр сделки | crm.deal.show | Осуществляет вывод детального описания сделки.
Панель инструментов | crm.deal.menu | Позволяет настроить верхнее меню сущности.
Импорт сделок* | crm.deal.import | Предназначен для импорта сделок в модуле CRM.
* отмечены системные компоненты (не описываются)

Счета

Название | Имя в пространстве имен bitrix | Описание
Счета (комплексный компонент) | crm.invoice | Позволяет работать со счетами в CRM.
Список счетов | crm.invoice.list | Выводит список счетов.
Редактирование счёта | crm.invoice.edit | Позволяет добавлять новый счёт, или редактировать параметры имеющегося.
Просмотр счёта | crm.invoice.show | Осуществляет вывод детального описания счёта.
Панель инструментов | crm.invoice.menu | Позволяет настроить контентное меню сущности.
Просмотр счёта в формате HTML/PDF* | crm.invoice.payment | Предназначен для просмотра счёта в формате HTML/PDF в модуле CRM.
* отмечены системные компоненты (не описываются)

Предложения

Название | Имя в пространстве имен bitrix | Описание
Предложения (комплексный компонент) | crm.quote | Позволяет работать с предложениями.
Список предложений | crm.quote.list | Выводит список предложений.
Редактирование предложения | crm.quote.edit | Позволяет добавлять новое, или редактировать параметры существующего предложения.
Просмотр предложения | crm.quote.show | Выводит детальное описание предложения.
Панель инструментов | crm.quote.menu | Позволяет настроить контентное меню сущности.
Просмотр счета в формате HTML/PDF* | crm.quote.payment | Позволяет просмотреть счет в формате HTML/PDF.
* отмечены системные компоненты (не описываются)

Товары

Название | Имя в пространстве имен bitrix | Описание
Товары | crm.product | Необходим для управления товарами сделок CRM.
Список товаров | crm.product.list | Используется для вывода списка товаров системы CRM.
Редактирование товара | crm.product.edit | Позволяет редактировать существующий, либо добавлять новый товар.
Просмотр товара | crm.product.show | Необходим для просмотра детального описания товара.
Список разделов | crm.product.section | Нужен для управления списком разделов выбранного каталога.
Туллбар | crm.product.menu | Позволяет настроить контентное меню для работы с каталогами и товарами.
Импорт товаров* | crm.product.import | Предназначен для импорта товаров в модуле CRM.
* отмечены системные компоненты (не описываются)

Другое

Название | Имя в пространстве имен bitrix | Описание
Отчеты (комплексный компонент) | crm.report | Необходим для составления отчетов по работе в CRM.
Просмотр событий | crm.event.view | Выводит список действий, произведенных над сущностями системы CRM.
Просмотр событий счета | crm.invoice.events | Выводит список действий, произведенных над счетами системы CRM.


CRM (КП). Настройки модуля

Отправить отзыв по этому разделу
Сервисы>CRM (КП)>CRM (КП). Настройки модуля

CRM (КП)::CRM (КП). Настройки модуля

Форма настроек модуля CRM (Настройки > Настройки продукта > Настройки модулей > CRM) предназначена для задания общесистемных параметров модуля.

Закладка Настройки

Поле | Описание
Сделка доступна для всех (по умолчанию) | [Y|N] При отмеченной опции создаваемая сделка по умолчанию будет открытой.
Вероятность сделки (по-умолчанию), % | Указывается вероятность заключения сделки в процентах.
Ответственный сделки (по умолчанию) | Нажмите Выбрать из структуры и выберите ответственного по умолчанию для добавляемых сделок.
Настройка прокси-сервера
Схема подключения к прокси | Указывается протокол, по которому будет осуществлено подключение.
Адрес прокси | Указывается адрес прокси-сервера.
Порт прокси | Указывается порт прокси-сервера.
Логин прокси | Указывается логин прокси-сервера.
Пароль прокси | Указывается пароль прокси-сервера.

Закладка Шаблоны пути

Поле | Описание
Шаблоны пути | Указываются адреса страниц в структуре портала.


Веб-аналитика. Описание модуля

Описание

Модуль Веб-аналитика позволяет накапливать и анализировать все основные показатели работы сайта, получать объективную численную статистику для анализа, вести детальный учет эффективности внешних посещений ресурса.

Модуль Веб-аналитика дает возможность:

  • вести учет хитов, хостов, сессий, посетителей сайта;
  • вести учет посетителей, добавивших сайт в «Избранное»;
  • регистрировать все ссылающиеся сайты;
  • фиксировать поисковые фразы внешних поисковых систем и встроенной системы поиска;
  • анализировать посещения разделов и документов сайта;
  • вести учет посетителей по дням с выделением постоянной аудитории сайта;
  • выполнять онлайн-мониторинг посетителей на сайте;
  • блокировать или перенаправлять посетителя, добавляя его в стоп-лист;
  • отслеживать все сессии одного посетителя между посещениями сайта;
  • просматривать всю историю движения посетителя по сайту;
  • регистрировать события, происходящие на сайте и за его пределами;
  • контролировать ход рекламной кампании и получать подробные отчеты;
  • вести учет страниц, индексируемых внешними поисковыми системами;
  • автоматически чистить базу данных статистики в соответствии с настройками модуля.

Примечание: Ссылки, отображаемые в модуле Веб-аналитика красным цветом означают, что запрашиваемая страница/раздел не существует (Ошибка 404).

Компоненты модуля

Модуль включает в себя следующие компоненты 2.0:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Таблица статистики | statistic.table | Выводит таблицу статистики по сайту, кроме того, настройки компонента позволяют отключить подсчет статистики для администраторов.

Смотрите также

  • Учет регистрации нового пользователя в статистике
  • Пример настройки событий
  • Как начать рекламную кампанию?
  • Общие рекомендации для оптимизации сайтов
  • Как начать работу с инструментами SEO?
  • Веб-аналитика (учебный курс)
  • Веб-аналитика (документация для разработчиков)


Веб-аналитика. Настройки модуля

Закладки

Форма настроек модуля Веб-аналитика (Настройки > Настройки продукта > Настройки модулей > Веб-аналитика) предназначена для задания общесистемных параметров модуля. Для удобства работы форма разделена на закладки, на каждой из которых выполняется настройка определённой группы параметров модуля.

Настройки

Поле | Описание
Когда отослать очередной статистический отчет по EMail (DD.MM.YYYY HH:MI:SS) | Данное поле содержит время отсылки очередного статистического отчета по электронной почте. В дальнейшем, отчет будет отсылаться ежедневно в это время. В случае, если поле оставлено пустым, отчет не будет отсылаться. Если сайт работает под управлением ОС Windows, данное поле по умолчанию не заполнено и отчет не отсылается. Это связано с довольно длительной отправкой письма в данной операционной системе. В противном случае, в данном поле содержится текущая дата, время - 9:00.
Интервал посетителей в online (сек.) | На странице Кто на сайте (Аналитика > Кто на сайте) Вы можете видеть сессии посетителей, проявивших активность за последние N секунд, которые задаются в этом поле.
Максимальное кол-во показываемых записей в таблицах | Страницы модуля Веб-аналитика отображают различные таблицы данных, которые представляют собой выборки из базы данных. Каждая выборка характеризуется, помимо прочего, количеством выбранных записей. Большее количество выбираемых записей требует большего количества ресурсов, необходимых серверу для обработки запроса и тем больше времени надо для отработки статистических страниц. Для ограничения количества выбираемых записей и ускорения генерации статистических отчетов (таблиц) введен этот параметр, позволяющий ограничить объемы выборок количеством выбираемых записей. При необходимости, можно снять данное ограничение, указав большую величину, например, 100 000 000 записей. Как правило, даже при очень большой загруженности сайта такие величины достигаются крайне редко.
Ширина графиков | Ширина графиков, отображаемых отчетами модуля (в пикселях).
Высота графиков | Высота графиков, отображаемых отчетами модуля (в пикселях).
Диаметр круговых диаграмм | Диаметр диаграмм, отображаемых отчетами модуля (в пикселях).
Размер TOP списка в сводной статистике | Количество элементов (рекламных кампаний, событий и т.д.), включаемых в отчеты на странице сводной статистики.
Размер TOP списка в детальном просмотре рекламной кампании | Количество элементов (точек входа и выхода, событий и т.д.), включаемых в отчеты на странице сводной статистики.
Использовать дополнительную обработку посетителей, не принимающих файлов cookie | В модуле сбора статистики предусмотрена схема работы с браузерами или любыми другими программами, не поддерживающими хранимых или сессионных cookies. Это достигается путём хранения сессионных данных в специальной таблице. При этом, идентификация посетителя производится по хэш-функции (md5) от ряда переменных окружения, характеризующих именно данного посетителя. Данный флаг позволяет включить или отключить такую дополнительную обработку.
Оптимизировать таблицы при очистке? | Автоматически оптимизирует таблицы MySQL при удалении устаревшей статистической информации (по полям Сколько дней хранить...).
Базовая валюта | Указывается валюта, в которой будут храниться все финансовые показатели.
Пересчитать все финансовые показатели | Если опция отмечена, то при сохранении настроек модуля все финансовые показатели будут пересчитаны в новой базовой валюте.
Ограничение активности Данная секция позволяет установить защиту от массовых скачиваний сайта специальными программами-грабберами. Если Вы не хотите, чтобы Ваш сайт был доступен для офлайнового просмотра, или Вы хотите просто ограничить доступ клиентов к сайту определённым количеством соединений, заполните поля этой формы соответствующими значениями.
[ редактировать шаблон ] | Кликнув ссылку редактировать шаблон, можно изменить PHP и HTML-код страницы, отправляемой клиенту при превышении лимита хитов.
Блокировать? | Если опция включена, излишне активные клиенты блокируются.
на время (сек.) | Период времени, в течение которого излишне активный клиент будет получать ошибку 503 (либо другую, устанавливаемую в шаблоне) на все запросы.
если в течение (сек.) | Период времени, в течение которого клиент не должен сделать большее количество хитов, чем указано в следующем поле.
сделано более N хитов | Максимальное количество хитов, которое клиент может сделать, не будучи заблокированным.
Сделать запись в журнал событий | Если опция отмечена, то при превышении лимита активности будет сделана запись в журнале событий. Ссылка журнал событий позволяет перейти к странице просмотра журнала событий.

Рекламные кампании

Поле | Описание
Использовать рекламную кампанию c referer1=NA, referer2=NA по умолчанию? | При установке данного флага все посетители, заходящие на сайт не по рекламной кампании и не совершающие возвратов по рекламным кампаниям, будут приписываться к рекламной кампании со следующими идентификаторами: referer1=NA, referer2=NA.
Автоматически создавать рекламные кампании при наличии параметров referer1, referer2 в URL'е | Если флаг установлен, и если параметры referer1, referer2 присутствуют в URL, но не найдено ни одной рекламной кампании с такими идентификаторами, создаётся новая кампания с этими параметрами.
Для автоматически создаваемых рекламных кампаний проверять, что referer1 и referer2 содержат только символы латинского алфавита, цифры и символы "_:;.,-" | Если опция отмечена, то при автоматическом создании рекламной кампании будет выполнятся проверка, чтобы referer1 и referer2 содержали только символы латинского алфавита, цифры и знак подчеркивания.
Учитывать события рекламных кампаний для поисковиков | При отмеченной опции события рекламных кампаний будут учитываться для поисковиков.
Синонимы referer1 | Данное поле позволяет назначить синонимы идентификаторам рекламных кампаний. По умолчанию синонимами referer1 являются r1 и referrer1.
Синонимы referer2 | То же для referer2.
Синонимы referer3 | То же для referer3.
Как показывать события в отчете рекламных кампаний по умолчанию | В отчете по рекламным кампаниям крайний столбец представляет информацию по событиям, сгенерированным посетителями, заходившими по данной рекламной кампании. Данный параметр позволяет видоизменять этот отчет.
Поддержка Openstat Данная секция позволяет настроить поддержку технологии Openstat, которая служит для точной идентификации переходов на сайт рекламодателя по каждому рекламному сообщению (текстовому объявлению, баннеру).
Обрабатывать Openstat | Отмеченная опция позволяет включить обработку ссылок Openstat. По ссылке Openstat Вы можете перейти на сайт http://openstat.ru [image] , посвященный данной технологии.
Шаблон формирования значения referer1 | Шаблон, по которому формируются значения referer1 из ссылки, совметимой с Openstat. В шаблоне можно использовать #service-name#, #campaign-id#, #ad-id#, #source-id#.
Шаблон формирования значения referer2 | Шаблон, по которому формируются значения referer2 из ссылки, совметимой с Openstat. В шаблоне можно использовать #service-name#, #campaign-id#, #ad-id#, #source-id#.

Страна и город

На закладке выполняется настройка параметров определения страны и города посетителя по IP адресу.

В таблице перечислены возможные источники определения города и страны, поддерживаемые модулем Веб-аналитика. С помощью колонки Будет использован выберите доступный и необходимый вам источник определения города и страны по IP-адресу.

Настройка данных

Поле | Описание
Посещаемость страниц и разделов
Сохранять статистику посещений разделов и файлов? | Флаг позволяет отключить либо включить сбор статистики посещений разделов и страниц сайта. Данная информация отображается в меню Посещаемость.
Собирать данные для отчета "Пути по сайту"? | Если опция включена, модуль Веб-аналитика регистрирует события и другую информацию, нужную для отображения отчета путей по сайту.
Максимальная длина путей по сайту для хранения | Максимальное количество переходов со страницы на страницу, которые будут сохраняться в пределах одного пути.
Важные параметры страницы | Параметры страницы (передаваемые в URL как ?param=value&param=value...), сохраняемые в статистике.
Индексные страницы разделов | Имена индексных страниц разделов, сохраняемых в статистике.
Поисковые системы
Маски для UserAgent'ов браузеров (используется для автодетекта поисковиков в качестве исключений) | В данном поле можно задать маски UserAgent’ов браузеров. Все браузеры, соответствующие данным маскам, будут исключены из рассмотрения в автодетекте (пункт меню Аналитика > Поисковики > Автодетект). В масках можно использовать спецсимволы % (ноль или более любых символов) и _ (один любой символ). Если вы задаете неточное совпадение маски, то необходимо обрамить ее с двух сторон спецсимволом %.
События
Кодировать дополнительный параметр #EVENT_GID# для событий | Данный флаг позволяет установить кодирование base64 для информативной части дополнительного параметра для событий.
Краткий идентификатор группы сайтов (для дополнительного параметра в ручной загрузке событий) (без точек и пробелов) | Краткий идентификатор группы сайтов используется в дополнительном параметре при ручной загрузке событий, происходящей за пределами сайта. Данный идентификатор был введен с целью дать возможность отличать дополнительные параметры внешних событий одного сайта от другого, при условии работы обоих сайтов на базе системы "1С-Битрикс: Управление сайтом".
Путь к дополнительным обработчикам при ручной загрузке событий | Путь к папке со скриптами (относительно корня сайта), которые могут быть использованы при загрузке событий для предварительной обработки CSV-файлов. Список имен файлов из этой папки включается в список поля Обработчик CSV файла формы загрузки событий.
Ссылающиеся сайты и поисковые фразы
Сохранять статистику ссылающихся сайтов и поисковых фраз? | Флаг позволяет отключить сбор статистики по заходам с внешних ссылающихся сайтов (в том числе и с поисковых систем). Данная информация отображается в меню Ссылающиеся сайты, Поисковые фразы.
Не очищать из ссылающихся доменов первые (TOP) | При очистке ссылающихся доменов можно указать первые по активности N доменов, которые не будут очищаться. Если вы укажете 0, все ссылающиеся домены будут очищаться по общему принципу: по дате последнего захода с этих доменов и в зависимости от количества дней, указанного в параметре Сколько дней хранить ссылающиеся домены на закладке Время хранения.
Хиты
Сохранять хиты? | Флаг позволяет отключить либо включить сохранение в базе адресов загружаемых страниц сайта. Данная информация отображается в меню Хиты посетителей (Аналитика > Посетители > Хиты)

Время хранения

Параметры закладки позволяют задать максимальное время хранения каждого события в днях. Каждый параметр имеет флаг "очистить", который позволяет удалить статистику по данному параметру. Очистка информации происходит по нажатии на кнопку Сохранить.

Поле | Описание
Посещаемость страниц и разделов
Сколько дней хранить историю посещений разделов и файлов | Посещаемость страниц и разделов сайта (количество хитов на страницу или раздел сайта) хранится в отдельной таблице, которая очищается по дате последнего хита по тому или иному разделу/странице в зависимости от количества дней, указанных в данном поле.
Сколько дней хранить динамику путей по сайту | По каждому пути на каждый день хранятся переходы в пределах конкретного пути. Эти данные хранятся в таблице, которая очищается по дате последнего перехода в зависимости от количества дней, указанных в данном поле.
Ссылающиеся сайты и поисковые фразы
Сколько дней хранить заходы с поисковыми фразами | Заход по поисковой фразе записывается в отдельную таблицу и характеризуется рядом параметров, в том числе датой захода, по которой данная таблице очищается в зависимости от количества дней, указанных в данном поле.
Сколько дней хранить заходы с ссылающихся страниц | Таблица заходов по ссылающимся сайтам очищается по полю дата захода в зависимости от количества дней, указанных в данном поле.
Сколько дней хранить ссылающиеся домены | В модуле Веб-аналитика помимо таблицы заходов с ссылающихся сайтов есть также таблица ссылающихся доменов. Такая схема, в частности, позволяет хранить данные по ссылающимся доменам значительно дольше, чем данные по заходам в силу меньшего размера таблицы. Но даже эта таблица должна периодически очищаться. Очистка происходит по дате последнего захода с того или иного домена в зависимости от количества дней, указанных в этом поле.
События
Сколько дней хранить каждое событие | В модуле Веб-аналитика существуют так называемые типы событий (Аналитика > События > Типы событий). Информация по всем событиям, происходящим на сайте и вне его пределов, хранится в таблице, которая очищается по дате того или иного события в зависимости от количества дней, указанных в данном поле.
Сколько дней хранить динамику типов событий | По каждому типу событий на каждый день хранится число произведенных событий того или иного типа. Эти данные хранятся в таблице, которая очищается по последней обсчитанной дате в зависимости от количества дней, указанных в данном поле.
Рекламные кампании
Сколько дней хранить историю посетителей рекламных кампаний | Система регистрирует факты захода каждого посетителя по рекламным кампаниям. Эти данные хранятся в специальной таблице, которая периодически очищается. Очистка таблицы осуществляется спустя определённое количество дней после последнего захода данного посетителя. Данное поле задает количество дней, иначе - период очистки таблицы после последнего захода.
Сколько дней хранить динамику рекламных кампаний | По каждой рекламной кампании ведется отдельная таблица, в которой хранятся данные по рекламной кампании за каждый день. Эта таблица очищается по последней посчитанной дате в зависимости от количества дней, указанных в данном поле.
Поисковые системы
Сколько дней хранить хиты поисковиков | Хитами поисковиков называются адреса проиндексированных страниц сайта. Все хиты поисковиков хранятся в отдельной таблице, которая очищается по дате последней индексации в зависимости от количества дней, указанных в данном параметре.
Сколько дней хранить динамику поисковиков | По каждому поисковику хранится количество проиндексированных страниц в тот или иной день. Таблица, хранящая эти данные, очищается по последней обсчитанной дате в зависимости от количества дней, указанных в этом поле.
Города и страны
Сколько дней хранить динамику по городам | По каждому городу хранится количество визитов из него и другая информация. Таблица, хранящая эти данные, очищается по последней дате в зависимости от количества дней, указанных в этом поле.
Сколько дней хранить динамику по странам | По каждой стране хранится количество визитов из нее и другая информация. Таблица, хранящая эти данные, очищается по последней дате в зависимости от количества дней, указанных в этом поле.
Посетители
Сколько дней хранить посетителей | Все посетители, заходящие на сайт, имеют собственные профили, которые хранятся в специальной таблице. Данные этой таблицы очищаются по дате последнего посещения сайта тем или иным посетителем в зависимости от количества дней, указанных в данном поле.
Сессии
Сколько дней хранить сессии | Сессии посетителей хранятся в отдельной таблице. Каждая сессия характеризуется рядом параметров, один из которых – дата последнего хита в данной сессии, по этому параметру таблица сессий очищается в зависимости от количества дней, указанных в данном поле.
Хиты
Сколько дней хранить хиты | Хиты (адреса загруженных страниц) хранятся в таблице, которая очищается по дате последнего хита в зависимости от количества дней, указанных в данном поле.

Исключения

На закладке могут быть заданы параметры, в соответствии с которыми определённые посетители могут быть исключены из статистики.

Поле | Описание
Исключения сбора статистики
Правила исключений Определяет порядок исключения требуемых посетителей:
  • учитывать всех без исключения - в базу данных статистики записываются данные по всем посетителям;
  • не учитывать пользователей из заданных групп - в базу данных статистики не включаются данные по посетителям, входящим в выбранные в следующем поле группы;
  • исключить пользователей с определённых IP адресов - не включаются данные по тем посетителям, чьи IP-адреса находятся в пределах диапазонов, указанных в поле Список диапазонов IP адресов...;
  • исключить пользователей из определённых групп пользователей, зашедших с определённых IP адресов - совмещение предыдущих двух условий.
Группы пользователей, для которых статистика НЕ собирается | Выберите группы пользователей, которые не будут учитываться при сборе статистики (т.е. по ним не будет вестись запись хитов, сессий, событий и прочих элементов статистической информации).
Список диапазонов IP адресов исключений (один диапазон на строке) Пользователи, чьи IP-адреса попадают в один из указанных диапазонов, не будут учитываться при сборе статистики. Необходимо вводить один диапазон на строке.

Примеры диапазонов:
  • 192.168.10.110-192.168.10.120;
  • 11.0.0.5-11.0.0.5 (обратите внимание - для задания одного адреса, введите диапазон, состоящий только из этого адреса).

Доступ

Закладка позволяет настроить права на доступ к модулю для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Веб-аналитика:
  • [D] доступ закрыт - запрет на доступ;
  • [M] просмотр статистики без финансовых показателей - просмотр статистических показателей, кроме финансовых величин доходов и убытков;
  • [R] просмотр всей статистики - просмотр всех статистических показателей, включая финансовые;
  • [W] полный административный доступ - полный доступ к ресурсам модуля (просмотр статистических показателей, права на изменение настроек и редактирование).
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.

Служебные процедуры

Закладка Очистка статистики

Форма позволяет очистить таблицы статистки. Исключение составляют таблица поисковиков (здесь будут сброшены только счетчики) и таблицы привязки IP-адресов к странам.

Закладка Оптимизация таблиц

Форма позволяет оптимизировать MySQL таблицы модуля Веб-аналитика для уменьшения их размера и увеличения производительности.

Смотрите также

  • Настройки модуля (учебный курс "Администратор. Модули")


Сводная статистика

Страница Сводная статистика (Аналитика > Сводная статистика) представляет обобщенную информацию по статистике сайта.

Фильтр

С помощью фильтра Вы можете получить данные за нужный период времени. После установки фильтра во всех таблицах, за исключением таблицы рекламных кампаний, будет выведен дополнительный столбец, в котором будут указаны данные за установленный период. В таблице рекламных кампаний будут отображены значения за установленный период.

Поле | Описание
Период (DD.MM.YYYY) | Эти поля фильтра позволяют выбрать период времени, за который следует отобразить статистику. Для задания временного диапазона можно использовать либо список с количеством дней, либо поля-календари. Данное поле отображается, даже если фильтр свернут.
Сайт | Выбор сайта, информацию по которому следует отобразить.

Чтобы отобразить данные с учётом фильтра, нажмите на кнопку Найти. Для отображения всех данных нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Графики посещаемости сайта | Открывает форму просмотра графиков посещаемости.

Посещаемость

Общая посещаемость | Сегодня | Вчера | Позавчера | Всего
Хитов | [1] | [2] | [3] | [4]
Хостов | [5] | [6] | [7] | [8]
Сессий | [9] | [10] | [11] | [12]
Событий | [13] | [14] | [15] | [16]
Посетителей
Всего | [17] | [18] | [19] | [20]
Новых | [21] | [22] | [23] |
Добавивших в избранное | [24] | [25] | [26] | [27]
Online | [28] |  |  |
  1. Количество хитов за текущий день.
  2. ... за вчерашний день.
  3. ... за позавчерашний день.
  4. Общее количество хитов за все время ведения статистики.
  5. Количество уникальных IP адресов посетителей (хостов) за текущий день.
  6. ... за вчерашний день.
  7. ... за позавчерашний день.
  8. Общее количество уникальных IP адресов за весь период ведения статистики.
  9. Количество заходов на сайт (сессий) за текущий день.
  10. ... за вчерашний день.
  11. ... за позавчерашний день.
  12. Общее количество заходов на сайт за весь период ведения статистики.
  13. Количество событий за текущий день.
  14. ... за вчерашний день.
  15. ... за позавчерашний день.
  16. Общее количество событий за весь период ведений статистики.
  17. Количество посетителей за текущий день.
  18. ... за вчерашний день.
  19. ... за позавчерашний день.
  20. Общее количество посетителей за весь период ведения статистики.
  21. Количество посетителей, пришедших на сайт впервые за текущий день.
  22. ... за вчерашний день.
  23. ... за позавчерашний день.
  24. Количество посетителей, добавивших сайт в избранное за текущий день.
  25. ... за вчерашний день.
  26. ... за позавчерашний день.
  27. ... за весь период ведения статистики.
  28. Количество посетителей, находящихся в текущий момент на сайте.

Рекламные кампании (переходы) (Top 10)

Посмотреть все рекламные кампании | Ссылка позволяет перейти на страницу Список кампаний для просмотра всего списка рекламных кампаний.
Рекламная кампания | Сегодня | Вчера | Позавчера | Всего
[1] | [2] | [3] | [4] | [5]
Всего | [6] | [7] | [8] | [9]
  1. Наименование рекламной кампании.
  2. Количество сессий на прямом заходе (количество переходов) за текущий день.
  3. ... за вчерашний день.
  4. ... за позавчерашний день.
  5. Общее количество сессий на прямом заходе за все время рекламной кампании.
  6. Сумма всех переходов по всем рекламным кампаниям за текущий день.
  7. ... за вчерашний день.
  8. ... за позавчерашний день.
  9. Общая сумма всех переходов по всем рекламным кампаниям за все время ведения статистики.

Типы событий (Top 10)

Этот отчет показывает количество произошедших событий за день. Каждое событие - суть переход по ссылке, содержащей параметры событий event1 и event2. Первая колонка отчета показывает имя события, представленное как event1 / event2. Например, если существует событие с event1=vote и event2=phones_poll, его имя будет показано как vote / phones_poll.

Посмотреть все типы событий | Ссылка позволяет перейти на страницу Список для просмотра списка типов событий.
Имя | Сегодня | Вчера | Позавчера | Всего
[1] | [2] | [3] | [4] | [5]
Всего | [6] | [7] | [8] | [9]
  1. Наименование типа события.
  2. Количество событий соответствующего типа за текущий день.
  3. ... за вчерашний день.
  4. ... за позавчерашний день.
  5. Общее количество событий данного типа.
  6. Сумма всех событий за текущий день.
  7. ... за вчерашний день.
  8. ... за позавчерашний день.
  9. Общая сумма всех событий за все время ведения статистики.

Ссылающиеся сайты (Top 10)

Посмотреть все ссылающиеся сайты | Ссылка позволяет перейти на страницу Переходы со списком всех ссылающихся сайтов.
Сайт | Сегодня | Вчера | Позавчера | Всего
[1] | [2] | [3] | [4] | [5]
Всего | [6] | [7] | [8] | [9]
  1. Ссылающийся сайт.
  2. Количество заходов с соответствующего сайта за текущий день.
  3. ... за вчерашний день.
  4. ... за позавчерашний день.
  5. Общее количество заходов с данного ссылающегося сайта за все время хранения данной статистики (время хранения настраивается в настройках модуля, параметр Сколько дней хранить ссылающиеся домены).
  6. Сумма всех переходов за текущий день.
  7. ... за вчерашний день.
  8. ... за позавчерашний день.
  9. Общая сумма всех переходов за все время ведения статистики.

Поисковые фразы (Top 10)

Посмотреть все поисковые фразы | Ссылка позволяет перейти на страницу Список переходов с полным списком поисковых фраз.
Фраза | Сегодня | Вчера | Позавчера | Всего
[1] | [2] | [3] | [4] | [5]
Всего | [6] | [7] | [8] | [9]
  1. Поисковая фраза, с которой посетитель зашел на сайт.
  2. Количество заходов с соответствующей поисковой фразой за текущий день.
  3. ... за вчерашний день.
  4. ... за позавчерашний день.
  5. Общее количество заходов с данной поисковой фразой за все время ведения статистики (время хранения настраивается в настройках модуля, параметр Сколько дней хранить заходы с поисковыми фразами).
  6. Сумма всех переходов с поисковыми фразами за текущий день.
  7. ... за вчерашний день.
  8. ... за позавчерашний день.
  9. Общая сумма всех переходов с поисковыми фразами за все время ведения статистики.

Индексация сайта (Top 10)

Посмотреть все поисковые системы | Ссылка позволяет перейти на страницу Список с полным списком поисковых систем.
Имя поисковика | Сегодня | Вчера | Позавчера | Всего
[1] | [2] | [3] | [4] | [5]
Всего | [6] | [7] | [8] | [9]
  1. Наименование поисковой системы (либо наименование системы, данные по которой собираются как по поисковикам).
  2. Количество индексаций за текущий день.
  3. ... за вчерашний день.
  4. ... за позавчерашний день.
  5. Общее количество индексаций за все время ведения статистики.
  6. Сумма всех индексаций по всем поисковикам за текущий день.
  7. ... за вчерашний день.
  8. ... за позавчерашний день.
  9. Общая сумма всех индексаций по всем поисковикам за все время ведения статистики.

Смотрите также

  • Сводная статистика (учебный курс "Продвижение сайта и Маркетинг")


Кто на сайте

На странице Кто на сайте (Аналитика > Кто на сайте) показана таблица сессий и посетителей, проявивших активность на сайте за последнее время.

Таблица автоматически обновляется через промежуток времени, задаваемый на странице. Для этого нужно выбрать одно из значений 20, 30, 60, 120 или 300, которые определяют время обновления в секундах. Для немедленного обновления списка нажмите на ссылку Обновить. Таймер в круглых скобках показывает количество секунд до следующего обновления.

Фильтр

Форма фильтра используется для выбора из списка записей в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Параметр | Описание
ID, логин, имя, фамилия* | Идентификатор, логин, имя или фамилия пользователя. Поле присутствует, даже если фильтр свернут.
ID сессии* | Маска идентификатора требуемых сессий.
ID посетителя* | Идентификатор посетителя сайта (не пользователя).
Зарегистрирован | Определяет, отображать сессии только зарегистрированных посетителей, только незарегистрированных или всех.
Впервые/вернулся | Флаг, позволяющий отфильтровать сессии посетителей, впервые посетивших сайт либо вернувшихся на сайт.
IP адрес* | Маска IP адреса искомых посетителей.
Страна* | Отбор сессии по стране посетителя (определяется по IP-адресу). В квадратных скобках можно ввести двухсимвольную аббревиатуру страны (напр., RU, BY, US).
Попал в стоп-лист | Фильтр сессий посетителей, которые были добавлены в стоп-лист.
ID записи стоп-листа* | Отбор сессий заблокированных пользователей по маске идентификатора записи в стоп-листе.
Хитов | Интервал для отбора сессий по количеству страниц (хитов), загруженных в течении сессии.
Пришел по рекламной кампании | Фильтр сессий посетителей, сделавших прямой заход, либо возврат по рекламной кампании.
ID рекламной кампании* | Маска ID рекламной кампании при поиске по предыдущему полю.
referer1 / referer2* | Идентификаторы рекламной кампании – referer1, referer2 (при поиске по полю Пришел по рекламной кампании).
referer3* | Дополнительный параметр при заходе по рекламной кампании – referer3 (при поиске по полю Пришел по рекламной кампании).
Возврат по рекламной кампании | Фильтр сессий посетителей или на прямом заходе по рекламной кампании, или на возврате (при поиске по полю Пришел по рекламной кампании).
Откуда впервые пришел* | Страница, с которой посетитель впервые пришел на сайт.
Последняя страница | Фильтр сессий посетителей по последней просмотренной странице и сайту. В выпадающем списке (ошибка 404) можно указать, отображать ли только запросы несуществующих страниц.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать записи по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех записей нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из таблицы в MS Excel.

Таблица сессий и посетителей

Поле | Описание
Действия Доступные действия над записью:
  • подробно - открывает отдельное окно с подробной информацией о посетителе;
  • стоп-лист - добавляет IP-адреса в стоп-лист.
Сессия | Идентификатор сессии.
Рекламная кампания | Если посетитель сделал прямой заход либо возврат по рекламной кампании, то в данном столбце выводятся: ID рекламной кампании, referer1 / referer2. Ссылка на ID кампании открывает список кампаний с фильтром, установленным на эту кампанию.
Хитов | Количество страниц (хитов), просмотренных в течении сессии. Ссылка на показателе открывает список хитов с фильтром, установленным на ID посетителя.
Время сессии | Длительность сессии.
Посетитель Если посетитель зарегистрирован, то отображаются данные в формате:
  • [ID пользователя] - ссылка открывает форму редактирования пользователя;
  • (логин) - Имя Фамилия;
  • [ID посетителя] - ссылка открывает список посетителей с фильтром по этому посетителю.
Если посетитель впервые на сайте - (впервые), иначе - (вернулся).
IP адрес | IP-адрес посетителя. Ссылка на значении открывает страницу поиска информации по адресу http://whois.domaintools.com/.
Страна | Страна посетителя (определяется по IP-адресу).
Регион | Регион посетителя (определяется по IP-адресу).
Город | Город посетителя (определяется по IP-адресу).
Последняя страница | Последняя страница, просмотренная посетителем.
Откуда впервые пришел | Страница, с которой посетитель впервые пришел на сайт.
Откуда сейчас пришел | Страница, с которой посетитель вернулся на сайт.

Смотрите также

  • Кто на сайте (учебный курс "Продвижение сайта и Маркетинг"


Посещаемость

Посещаемость - это раздел модуля Веб-аналитика, в котором регистрируются:

  • динамика посещаемости ресурса;
  • пройденные разделы и страницы;
  • длительность сессий;
  • посещаемость сайта по странам и др.

В этом разделе рассмотрены следующие вопросы:

  • Динамика посещаемости
  • Разделы и страницы. Точки входа и выхода
  • Пути по сайту
  • Внимательность посетителей
  • География по странам
  • География по городам

Смотрите также:

  • Посещаемость (учебный курс "Продвижение сайта и Маркетинг")


Динамика посещаемости

Страница Посещаемость (Аналитика > Посещаемость > Динамика) отображает динамику посещаемости сайта:

  • по датам;
  • по часам;
  • по дням недели;
  • по месяцам.

Эта форма показывает статистическую информацию по посещаемости сайта, включая хиты, хосты, сессии и события. Информация отображается в графической и табличной формах.

Фильтр

С помощью фильтра можно отобразить данные за интересующий период времени. После установки фильтра (по нажатию кнопки Построить) выбранная информация отображается на графике и находит отражение в таблице. Нажатие кнопки Отменить очищает график.

Поле | Описание
Период (DD.MM.YYYY) | Эти поля фильтра позволяют выбрать период времени, за который следует отобразить статистику. Для задания временного диапазона можно использовать либо список с количеством дней, либо поля-календари. Данное поле отображается, даже если фильтр свернут.
Сайт | Выбор сайта, информацию по которому следует отобразить.
Что показать на графиках | Набор опций, позволяющий выбрать, какой тип данных следует отображать на графике. Нажатие кнопки фильтра Отменить равносильно сбросу всех опций, т.е. очищает график.

Контекстная панель

Кнопка | Описание
Сгруппировано по... Нажатие этой кнопки открывает контекстное меню, в котором можно выбрать тип и плотность группировки отображаемой информации:
  • Группировать по датам;
  • Группировать по часам;
  • Группировать по дням недели;
  • Группировать по месяцам.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы (не график) в MS Excel.

График и таблица посещаемости сайта

График отображает данные, выбранные для его построения в фильтре.

Таблица посещаемости сайта

ID | Дата | День недели | Хитов | Хостов | Сессий | Событий | Посетителей | Новых
[1] | [2] | [3] | [4] | [5] | [6] | [7] | [8] | [9]
Выбрано: [10]
  1. ID записи в базе данных статистики.
  2. Дата, на которую показывается информация в строке.
  3. День недели (пн - вс).
  4. Количество хитов за соответствующий день.
  5. Количество уникальных хостов за этот день.
  6. Количество сессий за день.
  7. Количество событий, инициированных в соответствующий день.
  8. Общее количество посетителей сайта.
  9. Количество новых посетителей сайта.
  10. Количество выбранных из базы записей.

Смотрите также

  • Динамика посещаемости (учебный курс "Продвижение сайта и Маркетинг")


Разделы и страницы. Точки входа и выхода

В зависимости от того, какая страница выбрана в разделе Посещаемость, форма может показывать:

  • диаграммы и отчёты посещаемости разделов и страниц сайта;
  • диаграммы и отчёты точек входа на сайт и точек выхода.

Фильтр

Параметр | Описание
Период (DD.MM.YYYY) Период времени, за который следует отобразить диаграмму.

Данное поле отображается, даже если фильтр свернут.
Страница / раздел* Выражение, которое позволит отфильтровать показываемые разделы и файлы в диаграмме. Дополнительно можно указать:
  • сайт, страницы/разделы которого следует включить в диаграмму и отчёт;
  • метод отображения ошибочных запросов (ошибка 404): вместе с остальными страницами, только ошибочные запросы или все, кроме ошибочных запросов.
Что показать | Сущности, включаемые в диаграмму - только разделы сайта, только страницы сайта, либо все.
Рекламные кампании Позволяет отфильтровать данные отчета по одной или нескольким рекламным кампаниям.

Кнопка Добавить открывает окно со списком кампаний для выбора. Кнопка Удалить исключает выбранные кампании из списка.
Тип данных для рекламной кампании Тип данных для включения в отчет:
  • по суммарным значениям прямых заходов и возвратов;
  • на прямых заходах по рекламным кампаниям;
  • на возвратах.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы установить фильтр по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех данных нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы (не график) в формат MS Excel.

Диаграмма

Диаграмма выводится в виде объемной круговой диаграммы, справа от которой расположена легенда.

Для каждого сегмента диаграммы легенда показывает:

  • для отчета посещаемости - долю страницы или раздела в общем объеме просмотренных страниц. Для отчета по точкам входа/выхода - как часто та или иная страница/раздел были использованы в качестве точек входа или выхода;
  • ссылку (»), ведущую на соответствующую страницу или раздел;
  • ссылку на просмотр диаграммы посещаемости страницы/раздела, либо точек входа/выхода относительно этого раздела. Ссылка выполнена в виде (сокращенного) пути к странице/разделу;
  • количество хитов в соответствии с условиями фильтра.

Отчет о посещаемости разделов и страниц, точках входа и выхода

В зависимости от того, выбран для просмотра отчет Разделы и страницы или Точки входа (выхода), эта таблица показывает соответственно количество хитов или сессий выбранных страниц/разделов.

Меню действий | ID | Раздел/страница | Хитов/Сессий | Процент
[1] | [2] | [3] | [4] | [5]
Выбрано: [6]
  1. Кнопка, при нажатии на которую открывается контекстное меню, содержащее следующие команды:
    • График посещаемости данной страницы/раздела - открывает (в отдельном окне) страницу с соответствующим графиком (см. ниже).
    • Статистика переходов по ссылкам с данной страницы/раздела - просмотр отчета о переходах по ссылкам только с этой страницы.
  2. Порядковый номер записи.
  3. Ссылка или путь к странице/разделу.
  4. Количество уникальных хостов (для отчёта Разделы и страницы) или сессий (для отчёта Точки входа (выхода) за выбранный период.
  5. Процент посещений/переходов по данному пути.

Примечание: В таблице отчета ссылкой показаны путь к разделу, а путь к странице ссылкой не показывается. Страница - это единичный элемент сайта. Раздел - это папка сайта, в которой содержатся страницы и подпапки.

Если путь к странице обозначен красным цветом, то это означает, что за отчетный период зафиксирована 404-я ошибка при обращении к данной странице, но это вовсе не означает, что она и сейчас отдает 404-ю ошибку. Чтобы это выяснить, следует посмотреть список хитов для данной страницы.

Рассмотрим небольшой пример. Пусть в таблице отчета содержатся следующие данные:

site.ru/news/               100 хитов          /показан со ссылкой
site.ru/news/               80 хитов           /без ссылки, учитывается страница index.php
site.ru/news/main.php       5 хитов
site.ru/news/local.php      15 хитов

Таким образом, сумма хитов страниц – это число хитов раздела.

Смотрите также

  • Разделы и страницы. Точки входа и выхода (учебный курс "Продвижение сайта и Маркетинг")


Пути по сайту

Страница Пути по сайту (Аналитика > Посещаемость > Пути по сайту) в зависимости от того, какой пункт выбран в меню функций [image], может показывать диаграмму полных путей по сайту или их отрезков. Также можно отобразить диаграмму страниц, на которые уходили посетители с любого отрезка пути.

Фильтр

Поле | Описание
Период (DD.MM.YYYY) Период времени для построения диаграммы.

Данное поле отображается, даже если фильтр свернут.
Количество страниц в пути | Интервал для количества страниц в каждом из путей для диаграммы полных путей.
Первая страница пути* | Маска для любой страницы каждого из путей, попадающих в отчет. Данное поле фильтра нагляднее всего использовать в диаграмме полных путей.
Любая страница пути* | Маска для любой страницы каждого из путей, попадающих в отчет. Данное поле фильтра нагляднее всего использовать в диаграмме полных путей.
Последняя страница пути* | Маска для последней страницы каждого из путей, попадающих в отчет. Данное поле фильтра нагляднее всего использовать в диаграмме отрезков путей.
Рекламные кампании Позволяет отфильтровать данные отчета по одной или нескольким рекламным кампаниям.

Кнопка Добавить открывает окно со списком кампаний для выбора. Кнопка Удалить исключает выбранные кампании из списка.
Тип данных для рекламных кампаний Если Вы выбрали одну или несколько рекламных кампаний, по которым Вы хотите отфильтровать отчет, то у Вас есть возможность выбрать тип данных. Вы можете построить диаграмму:
  • по суммарным значениям прямых заходов и возвратов;
  • на прямых заходах по рекламным кампаниям;
  • на возвратах.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы установить фильтр по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех данных нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Начало путей | Нажатие этой кнопки открывает отчет, в котором перечислены все страницы и разделы, с которых посетители начинали навигацию по сайту (начало путей). Кнопка отображается после выбора отрезка пути в списке полных путей.
Полные пути / Отрезки путей | Выбор типа путей для отображения: только отрезки или полные пути.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Диаграмма путей и отрезков путей

Номер | Отрезок пути / Страница | Переходов | Процент
[номер пути] | [1] | [2] | [3]
Выбрано: [4] | Всего: [5] |
  1. Ссылка (»), ведущая на соответствующую страницу.
    Ссылка на имени страницы позволяет перейти на диаграмму для отрезка пути, заканчивающегося данной страницей.
    Ссылка, выделенная красным цветом означает, что запрашиваемая страница/раздел не существует (Ошибка 404).
  2. Абсолютное значение количества переходов.
  3. Процентное соотношение количества переходов.
  4. Количество путей, выбранных для отображения.
  5. Общее количество путей.

Смотрите также

  • Пути по сайту (учебный курс "Продвижение сайта и Маркетинг")


Внимательность

В зависимости от того, какой пункт выбран в меню функций [image], форма Внимательность посетителей (Аналитика > Посещаемость > Внимательность) показывает графики и диаграммы:
  • длительности сессий посетителей;
  • количества хитов в сессиях посетителей (активность посетителей).

Форма показывает график и круговую диаграмму параметров за выбранный период времени для выбранного сайта.

Фильтр

Параметр | Описание
Период (DD.MM.YYYY) | Период времени, для которого следует отобразить график и круговую диаграмму. Данное поле отображается, даже если фильтр свернут.
Сайт | Сайт, графики внимательности посетителей которого следует отобразить.

Чтобы активировать фильтр и построить графики, нажмите на кнопку Найти. Для отображения всех данных нажмите на кнопку Отменить.

Смотрите также:

  • Внимательность (учебный курс "Продвижение сайта и Маркетинг")


География по странам

В зависимости от того, какой пункт выбран в меню функций [image], форма География по странам (Аналитика > Посещаемость > География по странам) показывает графики и диаграммы:

  • сессий посетителей из различных стран в разрезе по дням;
  • новых посетителей;
  • хитов;
  • событий.

Форма показывает график и круговую диаграмму указанных сущностей за выбранный период времени, а также диаграмму за весь период ведения статистики.

Фильтр

Параметр | Описание
Период (DD.MM.YYYY) | Период времени, для которого следует отобразить график и круговую диаграмму. Данное поле отображается, даже если фильтр свернут.
Страна | Страны, которые следует отобразить на графиках. По умолчанию выбраны первые 20 стран в порядке убывания количества новых посетителей.

Чтобы активировать фильтр и построить графики, нажмите на кнопку Найти. Для отображения всех данных нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
[тип данных] | Нажатие этой кнопки открывает меню, в котором можно выбрать тип данных для отображения на графике и круговой диаграмме: сессии, новые посетители, хиты, события.

Примечание: При анализе диаграмм по сессиям за выбранный период времени и за весь период ведения статистики, оказывается, что количество сессий за весь период меньше, чем за указанный период времени. Дело в том, что в блоке "за весь период ведения статистики" отображается количество уникальных сессий, накопленных по каждой стране. В блоке "за выбранный период времени" отображается сумма сессий по дням.

Пример

День 1 - сессии A, B, C
День 2 - сессии A, C
Всего уникальных сессий (за весь период статистики): 3
Сумма сессий по дням (за выбранный период): 5

Для остальных показателей (новые посетители, хиты и события) происходит просто суммирование по дням, поэтому за некоторый период показатель меньше, чем за весь.

Смотрите также

  • География по городам и странам (учебный курс "Продвижение сайта и Маркетинг")


География по городам

В зависимости от того, какой пункт выбран в меню функций [image], форма География по городам (Аналитика > Посещаемость > География по городам) показывает графики и диаграммы:

  • сессий посетителей из различных городов некоторой страны в разрезе по дням;
  • новых посетителей;
  • хитов;
  • событий.

Форма показывает график и круговую диаграмму динамики посещаемости по городам за выбранный период времени, а также диаграмму за весь период ведения статистики.

Фильтр

Параметр | Описание
Период (DD.MM.YYYY) | Период времени, для которого следует отобразить график и круговую диаграмму. Данное поле отображается, даже если фильтр свернут.
Страна | Страна, статистику по городам которой следует отобразить на графиках.

Чтобы активировать фильтр и построить графики, нажмите на кнопку Найти. Для сброса значений фильтра нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
[тип данных] | Нажатие этой кнопки открывает меню, в котором можно выбрать тип данных для отображения на графике и круговой диаграмме: сессии, новые посетители, хиты, события.

Примечание: При анализе диаграмм по сессиям за выбранный период времени и за весь период ведения статистики, оказывается, что количество сессий за весь период меньше, чем за указанный период времени. Дело в том, что в блоке "за весь период ведения статистики" отображается количество уникальных сессий, накопленных по каждому городу. В блоке "за выбранный период времени" отображается сумма сессий по дням.

Пример

День 1 - сессии A, B, C
День 2 - сессии A, C
Всего уникальных сессий (за весь период статистики): 3
Сумма сессий по дням (за выбранный период): 5

Для остальных показателей (новые посетители, хиты и события) происходит просто суммирование по дням, поэтому за некоторый период показатель меньше, чем за весь.

Смотрите также

  • География по городам и странам (учебный курс "Продвижение сайта и Маркетинг")


Отправить отзыв по этому разделу

Рекламные кампании

  • Рекламные кампании. Список кампаний
  • Анализ рекламной кампании
  • Создание и редактирование рекламной кампании
  • Динамика рекламной кампании
  • Графики рекламной кампании
  • Сравнительный анализ рекламных кампаний


Рекламные кампании. Список кампаний

На странице Рекламные кампании (Аналитика > Рекламные кампании > Список кампаний) представлены обзорные данные по рекламным кампаниям.

Фильтр

Поле | Описание
Найти | Поле, позволяющее найти рекламные кампании по их основным параметрам: идентификатору, referer1 или referer2. Это поле присутствует, даже если фильтр свернут.
ID* | ID рекламных кампаний, которые требуется отобразить.
referer1 / referer2* | Идентификаторы рекламных кампаний, соответственно referer1 и referer2.
Длительность (дней) | Интервал для фильтрации по длительности рекламной кампании. Длительность - время, прошедшее с момента первого захода по рекламной кампании до последнего прямого захода либо возврата.
Сессий (всего) | Интервал для фильтрации по суммарному значению сессий (на прямом заходе либо возврате).
Посетителей (всего) | Интервал для фильтрации по суммарному значению посетителей (на прямом заходе либо возврате).
Период (DD.MM.YYYY) | Установка данного поля фильтра выводит дополнительный столбец в отчете по рекламным кампаниям, в котором содержатся данные за установленный период.
Внимательность | Интервал для фильтрации по значению внимательности (среднее значение количества хитов за одну сессию).
Посетителей за день | Интервал для фильтрации по количеству посетителей за день (среднее значение количества посетителей за один день).
Затраты | Интервал для фильтрации по полю рекламной кампании затраты. В данном поле может храниться денежная сумма, затраченная на рекламную кампанию.
Доходы | Интервал для фильтрации по полю доходы. Данное поле накапливает все денежные суммы по каждому событию, произошедшему в рамках рекламной кампании. Значение поля может быть изменено вручную.
Прибыль | Интервал для фильтрации по полю прибыль (разница между доходами и затратами на рекламную кампанию).
Рентабельность (ROI) | Интервал для рентабельности рекламной кампании, рассчитывается по формуле: (прибыль/затраты)*100%.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Контекстная панель

Кнопка | Описание
Добавить | Нажатие этой кнопки открывает форму создания новой рекламной кампании.
Группировка | Позволяет сгруппировать данные таблицы по одному из двух идентификаторов рекламной кампании - referer1 либо referer2, или отменить группировку.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Таблица рекламных кампаний

Поле | Описание
Колонка флажков | Поле предназначено для выбора кампаний, к которым предполагается применить какое-либо действие из панели действий, расположенной ниже таблицы кампаний.
Меню действий Нажатие на кнопку действий в строке конкретной кампании отображает меню, содержащее команды:
  • Анализ рекламной кампании - открывает форму, отображающую детальную информацию по динамике рекламной кампании: сводную статистику, графики, финансовые показатели, события и проч.;
  • Изменить - открывает форму редактирования рекламной кампании;
  • Сбросить - сбрасывает счетчики рекламной кампании: кол-во посетителей, внимательность, финансовые индикаторы;
  • Удалить - удаляет рекламную кампанию;
Следующие пункты меню присутствуют, если по данной рекламной кампании произошло по крайней мере одно событие (например, хит):
  • Разделы - открывает форму с отчетом и диаграммой посещаемости разделов и страниц посетителями, пришедшими по этой рекламной кампании;
  • Пути - открывает форму с отчетом и диаграммой путей, по которым прошли посетителями;
  • Динамика - отображает показатели динамики рекламной кампании по дням (сессии, посетители и т.п.);
  • Графики - открывает форму с графиками по рекламной кампании (посещения и события).
ID | ID рекламной кампании.
referer1 | Идентификатор рекламной кампании – referer1.
referer2 | Идентификатор рекламной кампании – referer2.
Начало | Время первого захода по рекламной кампании.
Окончание | Время последнего захода либо возврата по рекламной кампании.
Приоритет | Приоритет рекламной кампании. Это значение вводится при создании (или редактировании) кампании.
Зашли (сессий) сегодня | Кол-во сессий на прямом заходе (переходов) и возврате* за текущий день.
Зашли (сессий) всего | Суммарные значения количеств сессий на прямом заходе и на возврате.
Всего событий сегодня | Количество событий на прямом заходе и возврате за текущий день.
Всего событий | Количество событий за период (если он установлен в фильтре).

* - Возврат по рекламной кампании подразумевает ситуацию, когда посетитель делал непосредственный (прямой) заход по рекламной кампании и спустя некоторое время вернулся на сайт, при условии, что в этот промежуток времени он больше не делал прямых заходов по другим рекламным кампаниям.

Дополнительная информация: рекламные кампании

Под термином рекламная кампания подразумевается набор условий, выделяющих часть потока посетителей, приходящих на Ваш сайт. Все условия равносильны и могут быть следующих типов:

  • Наличие в ссылке, ведущей на Ваш сайт, одного или двух параметров – referer1, referer2.
    Пример подобной ссылки: http://www.1c-bitrix.ru/?referer1=vesti&referer2=news.
  • Поисковые системы, с которых могут заходить посетители.
  • Маски любых ссылающихся страниц.
  • Маски страниц Вашего сайта, на которые приходят посетители.

При определении рекламной кампании используется следующий алгоритм.

  1. Определяются те рекламные кампании, условия которых удовлетворяют параметрам посетителя.
  2. Среди выбранных рекламных кампаний берется кампания с наивысшим приоритетом (задается в настройках рекламной кампании). Если приоритеты одинаковы, то берется самая молодая рекламная кампания (с наибольшим ID).

Если посетитель пришел на сайт с параметрами referer1 и/или referer2, и с такими идентификаторами не было найдено ни одной рекламной кампании, то автоматически создаётся новая рекламная кампания с указанными referer1, referer2 в качестве идентификаторов.

Смотрите также

  • Рекламные кампании (учебный курс "Продвижение сайта и Маркетинг")


Анализ рекламной кампании

Вкладки таблицы отчетов

Эта форма показывает все данные, собранные системой статистики по выбранной для анализа рекламной кампании (или всем кампаниям). Форма анализа открывается на странице списка рекламных кампаний (Аналитика > Рекламные кампании > Список кампаний) путём нажатия на кнопку меню действий [image] и выбора пункта меню Анализ рекламной кампании.

Фильтр

Поле | Описание
Найти | Поле, позволяющее отобрать рекламную кампанию для анализа по ее основным параметрам: идентификатору, referer1 или referer2. Это поле присутствует, даже если фильтр свернут.
Дата (DD.MM.YYYY) | В этом поле можно выбрать период времени, за которые требуется вывести данные по рекламной кампании. Если период выбран, отчет вкладки Статистика содержит столбец Период.

Важно!
Нажатие кнопки Найти выводит информацию по рекламной кампании, выбранной путём заполнения поля Найти фильтра (т.е., по системному идентификатору или параметрам referer1 / referer2). Нажатие кнопки Отменить отменяет фильтрацию, т.е. выводит информацию сразу по всем рекламным кампаниям.

Поскольку система собирает и отображает очень большое количество статистической информации, она сгруппирована по категориям и размещена внутри листа свойств с закладками. Страницы свойств (вкладки) содержат соответствующую информацию.

Статистика

Эта вкладка содержит две таблицы: с количественными и относительными параметрами.

Таблица количественных параметров имеет такой формат:

 | Сегодня | Вчера | Позавчера | Период | Всего
Сессий |  |  |  |  |
Посетителей |  |  |  |  |
Новых посетителей |  |  |  |  |
Хостов |  |  |  |  |
Хитов |  |  |  |  |

Строки таблицы показывают значения параметров, указанных в левом столбце, для дня, обозначенного в шапке таблицы. Столбец Период включается в таблицу, если в фильтре установлен параметр Период. Последний столбец таблицы показывает общее количество событий по каждому параметру.

Ячейки столбцов (Сегодня, Вчера, Позавчера, Период, Всего) разделены на две. Первая ячейка содержит значение показателя на прямом заходе (прямых переходах). Вторая содержит значение показателя на возврате.

Возврат по рекламной кампании подразумевает ситуацию, когда посетитель делал непосредственный (прямой) заход по рекламной кампании и спустя некоторое время вернулся на сайт, при условии, что в этот промежуток времени он больше не делал прямых заходов по другим рекламным кампаниям.

Таблица относительных параметров:

Аналитические параметры
Посетителей за день | Среднее значение количества посетителей за день за все время ведения статистики.
Внимательность | Среднее значение количества хитов за сессию на прямом заходе и на возврате.
Активность | Среднее значение количества всех событий, совершенных на прямом заходе либо возврате к количеству посетителей пришедших по рекламной кампании (на прямом заходе).
Новых посетителей | Соотношение количества новых посетителей, впервые пришедших на сайт, к количеству всех посетителей пришедших по рекламной кампании.
Возвратилось | Процент посетителей, возвратившихся на сайт после первого захода по рекламной кампании.

Графики

Эта вкладка показывает два графика по выбранной рекламной кампании: график посещаемости и график событий в разрезе по дням. Ниже графиков выводится легенда, причем легенда графика событий содержит ссылки на форму просмотра типов событий.

Финансы (ROI)

Эта вкладка содержит две таблицы. В первой представлены данные о затратах, доходах и окупаемости рекламной кампании.

Параметр | Описание
Затраты | Денежные затраты на рекламную кампанию.
Доходы | Сумма по всем денежно-значимым событиям, произошедших в рамках рекламной кампании. Также доходы можно задать вручную в настройках кампании.
Прибыль | Разница между доходами и затратами.
Рентабельность (ROI) | Рентабельность рекламной кампании, рассчитывается по формуле: (прибыль / расходы) * 100%.
Цена за переход | Отношение затрат к суммарному количеству сессий на прямом заходе.
Цена за посетителя | Отношение затрат к суммарному количеству посетителей на прямом заходе.

Во второй таблице представлена информация о финансовых событиях рекламной кампании.

События

Эта вкладка содержит таблицу, в которой отражены произошедшие события.

Точки входа

Эта форма показывает диаграмму и отчёт точек входа на сайт по выбранной рекламной кампании.

Для каждого сегмента диаграммы, легенда показывает:

  • как часто та или иная страница/раздел были использованы в качестве точек входа;
  • ссылку », ведущую на соответствующую страницу или раздел;
  • ссылку на просмотр диаграммы точек входа относительно этого раздела;
  • количество хитов в виде ссылки на детальный отчет по хитам посетителей.

Список точек входа

Таблица показывает количество сессий по точкам входа (страницам/разделам).

Поле | Описание
Меню действий Нажатие на кнопку действий в строке конкретной точки входа отображает меню, содержащее команды:
  • График посещаемости данной страницы/раздела - открывает (в отдельном окне) страницу с соответствующим графиком.
  • Статистика переходов по ссылкам с данной страницы/раздела - просмотр отчета о перехода по ссылкам только с этой страницы.
ID | Порядковый номер записи.
Раздел/страница | Ссылка и путь к странице/разделу.
Сессий | Количество уникальных сессий за выбранный период для выбранной рекламной кампании.
Процент | Процент посещений или переходов с этой страницы/раздела.

Точки выхода

Отчет на этой вкладке построен аналогично отчету по точкам входа, но показывает информацию по страницам и разделам сайта, которыми завершался просмотр сайта посетителями, пришедшими по выбранной рекламной кампании.

Популярное

Эта вкладка также аналогична отчету по точкам входа, но показывает информацию по наиболее популярным страницам и разделам сайта, просмотренным посетителями, пришедшими по выбранной рекламной кампании. Однако, поскольку этот отчет предназначен для анализа просмотров страниц/разделов (т.е. хитов), он показывает количество хитов, а не сессий (в отличие от отчета по точкам входа).

Отрезки путей

Эта вкладка показывает диаграмму (в виде таблицы) отрезков путей по сайту. Также можно отобразить диаграмму страниц, на которые уходили посетители с любого отрезка пути.

Поле | Описание
Номер | Порядковый номер пути.
Отрезок пути / Страница | Ссылка, ведущая на соответствующую страницу, и набор последующих страниц пути либо отрезков пути. Ссылка на имени страницы позволяет перейти на диаграмму для отрезка пути, заканчивающегося данной страницей.
Переходов | Абсолютное значение количества переходов.
Процент | Процентное соотношение количества переходов.

Пути по сайту

Отчет на этой вкладке аналогичен отчету по отрезкам путей, но показывает информацию по страницам и разделам сайта, которыми завершался просмотр сайта посетителями, пришедшими по выбранной рекламной кампании.

Смотрите также

  • Рекламные кампании (учебный курс "Продвижение сайта и Маркетинг")


Создание и редактирование рекламной кампании

Эта форма предназначена для создания новых и правки существующих рекламных кампаний (РК). Подробнее о рекламных кампаниях можно прочитать в этом разделе.

Таблицы описывают поля, используемые при редактировании рекламной кампании.

Контекстная панель

Кнопка | Описание
Список | Открывает список всех рекламных кампаний.
Добавить | Создает новую рекламную кампанию. Отображается только при редактировании существующей рекламной кампании
Сбросить | Обнуляет все счетчики открытой рекламной кампании. Отображается только при редактировании существующей рекламной кампании.
Удалить | Удаляет текущую рекламную кампанию. Отображается только при редактировании существующей рекламной кампании.

Вкладка Свойства

Поле | Описание
Приоритет | Значение приоритета рекламной кампании. Чем выше значение, тем выше приоритет.
Идентификация рекламной кампании
referer1* | Значение идентификатора рекламной кампании referer1. Передается в URL.
referer2 | Значение идентификатора рекламной кампании referer2. Передается в URL.
Дополнительные условия РК работает (то есть, модуль статистики регистрирует ее события) при выполнении любого из этих условий или же без них.
Откуда пришли | Маски для ссылающихся страниц, разделенные новой строкой (в маске возможно использование символов: % - 0 или более любых символов и _ – один любой символ)
Поисковые системы | Поисковые системы, заходы с которых считаются заходами по данной рекламной кампании.
Куда пришли | Маски полных адресов для страниц сайта, заходы на которые следует регистрировать как заходы по рекламной кампании.

* - поля, обязательные для заполнения.

Вкладка Дополнительно

Поле | Описание
Финансы
Затраты | Денежная сумма, затраченная на рекламную кампанию. Выводится и хранится в базовой валюте модуля. При вводе суммы валюта может быть выбрана произвольно, при сохранении сумма будет сконвертирована в базовую валюту.
Доходы | Сумма денег по всем денежно-значимым событиям, произошедшим в рамках рекламной кампании. Данная сумма может быть также модифицирована вручную; принципы работы с валютой для данной суммы аналогичны затратам.
Дополнительные настройки
Как отображать события | Метод отображения событий по этой рекламной кампании в таблице рекламных кампаний.
Описание | Описание рекламной кампании.

Смотрите также

  • Рекламные кампании (учебный курс "Продвижение сайта и Маркетинг")


Динамика рекламной кампании

Описание

На данной странице отображаются следующие показатели динамики рекламной кампании (по дням):

  • количество сессий;
  • количество посетителей;
  • количество посетителей, добавивших сайт в избранное;
  • количество хостов (уникальных IP адресов);
  • количество хитов (загрузок страниц);
  • события (добавление посетителями сообщений, покупки в магазине и т.п.)

Форма может быть открыта путём выбора пункта Динамика меню действий списка рекламных кампаний:

или выбором ссылки Динамика рекламной кампании на вкладке Графики формы Анализ рекламной компании.

Фильтр

Поле | Описание
Период (DD.MM.YYYY) | Период времени, за который требуется вывести события.

Чтобы отобразить данные за выбранный период, нажмите на кнопку Найти. Для отображения всех данных нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Список рекламных кампаний | Нажатие этой кнопки открывает отчет со списком рекламных кампаний.
Графики рекламной кампании | Открывает форму с графиками рекламной кампании.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой формы в MS Excel.

Таблица показателей

Поле | Описание
Меню действий Нажатие на кнопку действий отображает меню, содержащее команду:
  • Список событий - открывает в отдельном окне страницу со списком событий, возникших в этот день.
Дата | Дата, на которую отображаются данные в этой строке.
Последующие поля: Сессий, Посетителей, Хостов, Хитов содержат собственно показатели динамики на данный день:
  • Сессий - количество заходов на сайт по рекламной кампании (сессия открывается в момент захода на сайт и закрывается при закрытии окна браузера. Также новая сессия открывается при авторизации пользователя, а при окончании авторизованного сеанса - закрывается).
  • Посетителей - количество уникальных посетителей.
  • Хостов - количество уникальных IP адресов.
  • Хитов - количество загрузок страниц.
Каждый из этих показателей имеет два значения: количество событий на прямом заходе (ПР) и на возврате (ВЗ).
Прямым заходом по рекламной кампании считается сессия, открытая в момент идентификации посетителя как посетителя по той или иной рекламной кампании.
Возвратом по рекламной кампании считается сессия, открытая посетителем после того, как он сделал прямой заход по данной рекламной кампании.

Кроме того, колонка Посетителей содержит количество новых посетителей (НВ).
Новым признается такой посетитель, от которого не был получен выдаваемый всем посетителям цифровой идентификатор. Считается, что такие посетители впервые приходят на сайт.
События | Количество событий на текущую дату на прямом заходе и на возврате по рекламной кампании. Ссылки на показателях ведут на просмотр списка событий (соответственно на прямом заходе и на возврате).

Смотрите также

  • Рекламные кампании (учебный курс "Продвижение сайта и Маркетинг")


Графики рекламной кампании

Описание

Эта форма отображает графики посещаемости и событий по данным, собираемых в рамках соответствующей рекламной кампании. Форма может быть открыта путём выбора пункта Графики меню действий списка рекламных кампаний:

или выбором ссылки Графики рекламной компании на вкладке Графики формы Анализ рекламной компании.

Фильтр

Поле | Описание
Период (DD.MM.YYYY) | Период времени, за который требуется вывести график. Это поле присутствует, даже если фильтр свернут.
События | События, которые требуется вывести на графике событий. Кнопка Добавить открывает окно со списком событий, в котором можно выбрать (установкой флажков и нажатием кнопки Выбрать) события для отображения. Кнопка Удалить исключает выбранные события из списка.

Для того чтобы отрисовать графики по заданным критериям, нажмите кнопку Найти. Для отображения всех данных без ограничений нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Список рекламных кампаний | Нажатие этой кнопки открывает отчет со списком рекламных кампаний.
Динамика рекламной кампании | Открывает отчет по динамике (кол-во хитов, сессий и т.п.) текущей рекламной кампании.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой формы в MS Excel.

На графике рекламной кампании можно вывести показатели по хитам, сессиям, посетителям, хостам и новым посетителям как на прямом заходе, так и на возврате, отметив соответствующие опции в форме Что показать на графиках ниже легенды графика.

Смотрите также

  • Рекламные кампании (учебный курс "Продвижение сайта и Маркетинг")


Сравнительный анализ рекламных кампаний

Форма Сравнительный анализ рекламных кампаний (Аналитика > Рекламные кампании > Сравнение кампаний) позволяет показать на одной координатной сетке графики нескольких рекламных кампаний, что позволит в наглядной форме сравнить их эффективность.

Фильтр

Поле | Описание
Период (DD.MM.YYYY) | Период времени, за который требуется вывести графики. Поле присутствует, даже если фильтр свернут.
ID рекламной кампании* | Маска идентификаторов искомых рекламных кампаний.
referer1* | Маска для поиска рекламных кампаний по referer1.
referer2* | Маска для поиска рекламных кампаний по referer2.
Рекламные кампании | Выберите в этом списке рекламные кампании, показатели которых требуется отобразить на графике. Для выбора нескольких кампаний удерживайте клавишу Ctrl. Кнопка Добавить открывает окно со списком кампаний, в котором можно выбрать (установкой флажков и нажатием кнопки Выбрать) кампании для отображения. Кнопка Удалить исключает выбранные кампании из списка.
ID события* | Маска идентификаторов для поиска событий рекламных кампаний.
event1* | Маска для поиска событий по event1.
event2* | Маска для поиска событий по event2.
Вы можете уточнить какие именно события вас интересуют | В этом списке можно выбрать события, которые требуется отобразить на графике. Для выбора нескольких событий, удерживайте клавишу Ctrl. Кнопка Добавить открывает окно со списком событий для выбора. Кнопка Удалить исключает выбранные события из списка.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобразить данные с учётом фильтра, нажмите на кнопку Найти. Для отображения всех данных нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Параметр для сравнения Нажатие этой кнопки открывает меню, в котором можно выбрать один из множества статистических параметров для построения графиков:
  • сессий в сумме на прямых заходах и возвратах;
  • сессий на прямых заходах;
  • сессий на возвратах;
  • посетителей в сумме на прямых заходах и возвратах;
  • посетителей на прямых заходах;
  • посетителей на возвратах;
  • новых посетителей;
  • хостов в сумме на прямых заходах и возвратах;
  • хостов на прямых заходах;
  • хостов на возвратах;
  • хитов в сумме на прямых заходах и возвратах;
  • хитов на прямых заходах;
  • хитов на возвратах;
  • событий в сумме на прямых заходах и возвратах;
  • событий на прямых заходах;
  • событий на возвратах.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

График и таблица показателей

В этой области выводятся график и таблица по выбранным показателям за установленный период.

Смотрите также

  • Рекламные кампании (учебный курс "Продвижение сайта и Маркетинг")


Отправить отзыв по этому разделу

События

  • Типы событий
  • События
  • Загрузка событий


События

На странице Список событий (Аналитика > События > События ) представлена информация по каждому событию, произошедшему как на сайте, так и вне сайта.

Фильтр

Параметр | Описание
Найти | Поле, позволяющее найти события по их основным параметрам: идентификатору рекламной кампании, event1 или event2. Это поле присутствует, даже если фильтр свернут.
ID* | ID события в базе.
ID типа события* | ID типа события в базе.
Наименование типа события* | Наименование типа события.
event1 / event2* | Идентификаторы типа события: event1 и event2 соответственно.
event3* | Дополнительный параметр события.
Дата (DD.MM.YYYY) | Интервал, за который требуется отобразить события.
ID сессии* | ID сессии, в рамках которой произошло событие.
ID посетителя* | ID посетителя, совершившего события.
Страна* | Страна посетителя сайта, инициировавшего событие. В квадратных скобках можно ввести двухсимвольную аббревиатуру страны (например, RU, BY, US).
ID рекламной кампании* | ID рекламной кампании, в рамках которой произошло событие.
На возврате по рекламной кампании | С помощью данного поля можно отфильтровать события, произошедшие на прямом заходе по рекламной кампании либо на возврате.
ID хита* | В данном поле можно задать ID хита, инициировавшего занесение в базу данных события.
Откуда пришли* | Сайт и страница, с которой пришли на ту страницу, где было инициировано требуемое событие.
Где произошло* | Сайт и страница, на которой было инициировано требуемое событие.
Куда перенаправили* | Поле позволяет отобрать события по странице, на которую перенаправляется посетитель после события.
Денежная сумма | Интервал для отбора событий по значению их денежной суммы.
Логика между полями Переключатель, определяющий механизм поиска записей.
  • И - выводятся события, удовлетворяющие всем критериям фильтра.
  • ИЛИ - выводятся события, удовлетворяющие хотя бы одному критерию.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы установить фильтр по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех событий нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Открывает форму для ручного создания нового события.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из таблицы в MS Excel.

События

Поле | Описание
Колонка флажков | Поле предназначено для выбора событий, к которым предполагается применить какое-либо действие из панели действий, расположенной ниже таблицы кампаний.
ID | Идентификатор события в базе.
Тип | Идентификатор типа события. Ссылка открывает список типов событий с фильтром, установленным на этот тип событий.
event1 | Параметр типа события - event1.
event2 | Параметр типа события - event2.
event3 | Параметр типа события - event3.
Дата | Дата возникновения событие.
Сессия | ID сессии, в течение которой произошло событие. Ссылка открывает список сессий с фильтром, установленным на эту сессию.
Посетитель | ID посетителя, инициировавшего событие. Ссылка открывает список посетителей с фильтром, установленным на этого посетителя.
Страна | Страна посетителя, инициировавшего событие.
Рекламная кампания | ID рекламной кампании, зайдя по которой, посетитель инициировал событие. Если ID выведен с символом *, посетитель инициировал событие на возврате по данной рекламной кампании, в противном случае - на прямом заходе. Ссылка открывает список кампаний с фильтром, установленным на эту кампанию.
Хит | ID хита, на котором произошло событие. Ссылка открывает список посетителей с фильтром, установленным на этого посетителя.
Сайт | Сайт, на котором произошло событие.
Откуда пришли | Сайт и страница, с которой пришли на ту страницу, где было инициировано требуемое событие.
Где произошло | Сайт и страница, на которой было инициировано требуемое событие.
Денежная сумма | Денежная сумма события, указывается либо в базовой валюте модуля, либо в валюте, выбранной в фильтре.

Смотрите также

  • События (учебный курс "Продвижение сайта и Маркетинг")


Загрузка событий

Форма Загрузка событий (Аналитика > События > Загрузка событий) предназначена для занесения в базу данных событий, произошедших вне сайта. Примерами таких событий могут служить оплата заказа, отмена заказа и т.п.

Закладка Загрузка из файла

Поле | Описание
CSV файл Указывается CSV файл со списком событий. Формат данных в файле должен иметь следующие поля:

"[1]","[2]","[3]","[4]","[5]","[6]","[7]"

  1. ID типа события.
  2. Дополнительный параметр (event3).
  3. Дата, заданная в формате даты для текущего сайта.
  4. Дополнительный параметр в формате:
    BITRIX_SM.сессия.посетитель.страна.рекламная_кампания.возврат.сайт
  5. Денежная сумма события.
  6. [пустое_поле] - поле заполнять не нужно, оно используется для совместимости CSV файлов с продуктом "1C-Битрикс: Управление сайтом" .
  7. Возврат денег (Y / N). Если эта опция установлена, сумма отнимается от доходов рекламной кампании. В противном случае, доход рекламной кампании увеличивается на эту сумму
Обработчик CSV файла | Выбирается обработчик CSV файла.
Предварительный просмотр При установленной опции будет доступен предварительный просмотр событий ,загружаемых из файла, перед загрузкой на сайт.

После нажатия кнопки Загрузить происходит чтение файла и занесение полей в таблицу, расположенную на закладке "Ручной ввод".

Загрузить только уникальные события | При установленной опции будет происходить проверка уникальности событий по комбинации всех загружаемых полей (кроме денежной суммы).
Шаг загрузки (сек.) | Задается длительность одного шага загрузки данных из CSV файла в секундах. При значении "0" загрузка данных выполняется за один шаг.

Пример содержания файла CSV:

10,"file1.exe","10.10.2007 12:30","BITRIX_SM.10.5.RU.6.Y","250"
11,"help_doc.chm","10.10.2007 12:30"
12,"www","10.10.2007 12:30","BITRIX_SM.11.4.US.8.N","233.45"
13,"1C-Битрикс: Корпоративный портал","10.10.2007 12:30","BITRIX_SM.11.4.US.8.N","233.45",,"Y"

Ручной ввод

Таблица служит для ручного ввода событий в базу данных.

# | ID типа события* | event3 | Дата | Доп. параметр | Денежная сумма | Возврат денег |
[1] | [2] [3] | [4] | [5] [6] | [7] | [8] | [9] | [10]
  1. Порядковый номер.
  2. ID типа события.
  3. Иконка, вызывающая форму для выбора типа события.
  4. Дополнительный параметр события – event3 (в нем может быть, например, сумма заказа).
  5. Дата события.
  6. Кнопка, открывающая календарь.
  7. Дополнительный параметр (формат описан выше).
  8. Денежная сумма события.
  9. Если эта опция установлена, сумма отнимается от доходов рекламной кампании. В противном случае, доход рекламной кампании увеличивается на эту сумму.
  10. Кнопка, копирующая текущую строку в следующую.

* - поле, обязательное для заполнения.

Автоматическая регистрация событий

Когда посетитель уходит, например, на оформление заказа, то в ссылку, ведущую на внешнюю платежную систему, должен быть добавлен специальный шаблон – #EVENT_GID#. Этот шаблон в дальнейшем будет автоматически заменен (в скрипте redirect.php) на составной идентификатор:

[код сайта].[ID сессии].[ID посетителя].[ID страны].[ID
 рекламной кампании].[Y – возврат по рекламной кампании; N – прямой заход].

Пример такой ссылки:

<a href="http://www.ritlabs.ru/redirect.php?event1=softkey_out&
 event2=thebat&event3=buy&
 goto=http://www.softkey.ru/catalog/basket.php?
 prodid=902&quantity=1&referer1=ritlabs_site&referer2=#EVENT_GID#">
Купить
</a>

В приведенной ссылке кодированные символы заменены для удобства чтения. Оригинал ссылки:

<a href="http://www.ritlabs.ru/redirect.php?event1=softkey_out&
 event2=thebat&event3=buy&
 goto=http%3A//www.softkey.ru/catalog/basket.php%3Fprodid%3D902%26quantity%3D1%26referer1%3Dritlabs_site%26referer2%3D%23EVENT_GID%23">
Купить
</a>

Для задания подобных ссылок предусмотрены специальные возможности во встроенном в систему HTML-редакторе.

Большинство платежных систем принимают такой специальный параметр и возвращают его в письме, оповещающем владельца товара о заказе (например, на www.softkey.ru таких идентификаторов два: referer1 и referer2). Когда к Вам поступает письмо, оповещающее о том, что заказ оформлен, Вы должны занести данное событие в статистику своего сайта.

Если Вы хотите автоматически заносить события, произошедшие вне Вашего сайта, то сделать это можно, загружая PHP-страницу, адрес которой формируется по следующей формуле:

http://[ВАШСАЙТ]/bitrix/admin/event_edit.php?

        USER_LOGIN=[ЛОГИН]&USER_PASSWORD=[ПАРОЛЬ]&lang=[САЙТ]&
        Login=Y&TYPE=AUTH&AUTH_FORM=Y&
        ARR[]=[N]&LOAD_[N]=Y&EVENT_ID_[N]=[ID типа]&EVENT3_[N]=[EVENT3]&
        DATE_ENTER_[N]=[ДАТА]&PARAM_[N]= [ПАРАМЕТР]]&MONEY_[N]=[ДЕНЕЖНАЯСУММА]&
        CHARGEBACK_[N]=[ФЛАГВОЗВРАТАДЕНЕГ]&
        ARR[]=[N+1]]&LOAD_[N+1]=Y&EVENT_ID_[N+1]=[ID типа]&EVENT3_[N+1]=[EVENT3]&
        DATE_ENTER_[N+1]=[ДАТА]&PARAM_[N+1]= [ПАРАМЕТР]&MONEY_[N+1]=[ДЕНЕЖНАЯСУММА]&
        CHARGEBACK_[N]=[ФЛАГВОЗВРАТАДЕНЕГ]&
...
        ARR[]=[M]&]&LOAD_[M]=Y&EVENT_ID_[M]=[ID типа]&EVENT3_[M]=[EVENT3]&
        DATE_ENTER_[M]=[ДАТА]&PARAM_[M]= [ПАРАМЕТР]&MONEY_[M]=[ДЕНЕЖНАЯСУММА]&
        CHARGEBACK_[N]=[ФЛАГВОЗВРАТАДЕНЕГ]

&check_unique=Y&save=Y

В данной формуле:

  • [ВАШСАЙТ] – адрес сайта;
  • [ЛОГИН] – логин пользователя, имеющего право Запись для модуля статистики;
  • [ПАРОЛЬ] – пароль вышеописанного пользователя;
  • [САЙТ] – сайт, в формате которого будет задана дата события (например, ru);
  • [N], [N+1] – порядковый номер загружаемого события;
  • [M] – количество загружаемых событий;
  • [IDтипа] – ID типа загружаемого события;
  • [EVENT3] – дополнительный параметр события;
  • [ДАТА] – дата события в формате заданного сайта;
  • [ПАРАМЕТР] – параметр в формате:
    [Код сайта].[ID сессии].[ID посетителя].[ID страны].[ID рекламной кампании].[Y – возврат по рекламной кампании; N – прямой заход];
  • [MONEY] – денежная сумма события;
  • [CHARGEBACK] – флаг возврата денег: Y – денежную сумму необходимо отнять от доходов рекламной кампании; N – денежную сумму необходимо прибавить к доходам компании (по умолчанию).
  • check_unique – для проверки уникальности загружаемых событий значение данного параметра должно быть Y, в противном случае уникальность проверяться не будет.

Пример адреса
http://www.1c-bitrix.ru/bitrix/admin/event_edit.php?
       USER_LOGIN=admin&USER_PASSWORD=123456&lang=ru&Login=Y&
       TYPE=AUTH&AUTH_FORM=Y&ARR[]=1&LOAD_1=Y&EVENT_ID_1=35&
       EVENT3_1=250&DATE_ENTER_1=10.01.2007&PARAM_1=BITRIX_SM.10345.676.US.3.Y&
       ARR[]=2&LOAD_2=Y&EVENT_ID_2=35&EVENT3_2=340&DATE_ENTER_2=11.01.2007&
       PARAM_2= BITRIX_SM.10400.700.RU.5.N&MONEY_2=970.35&check_unique=Y&save=Y

Внимание:
пример представлен не в кодированном виде. Для корректной работы страницы вам необходимо для значений параметров ссылки применять URL-кодирование (в PHP - функция urlencode()).


Отправить отзыв по этому разделу

Типы событий

  • Список
  • Создание и редактирование типа события
  • Динамика типа события по дням
  • Круговая диаграмма
  • Графики


Список

Описание

Форма Типы событий (Аналитика > События > Типы событий > Список) отображает список типов событий.

Тип события представляет собой заданное разработчиком сайта событие. Примерами типов событий могут служить:

  • уход на внешнюю платежную систему для оформления заказа;
  • событие, происходящее при нажатии ссылки купить и ведущей, например, на http://www.softkey.ru [image];
  • скачивание того или иного файла, происходящее при нажатии ссылки Скачать;
  • клик по баннеру, который показывается на Вашем сайте;
  • отсылка комментария на сайте;
  • переход в тот или иной раздел сайта.

Практически любое действие, происходящие на сайте, можно зафиксировать как событие в модуле статистики. Разработчики сайта могут получить подробное описание, как создавать события в разделе справочной системы (Для разработчиков > События).

Помимо событий, происходящих на Вашем сайте, Вы можете регистрировать события, происходящие вне сайта. К числу таких событий можно отнести события оплата заказа либо отмена заказа (см. Список событий).

Фильтр

Параметр | Описание
Найти | Поле, позволяющее найти события по их основным параметрам: идентификатору, event1 или event2. Это поле присутствует, даже если фильтр свернут.
ID* | ID типа события в базе.
event1* | Идентификатор типа события – event1.
event2* | Идентификатор типа события – event2.
Наименование* | Наименование типа события.
Описание* | Описание типа события.
Первое (DD.MM.YYYY) | Интервал для поля Первое (дата первого события данного типа).
Последнее (DD.MM.YYYY) | Интервал для поля Последнее (дата последнего события данного типа).
Период (DD.MM.YYYY) | Временной интервал, за который вы хотите вывести количество событий соответствующих типов.
Всего событий | Интервал для поля Всего (общее количество событий произошедших за время ведения статистики).
Денежная сумма | Интервал для фильтрации суммы денег по всем событиям того или иного типа за все время (столбец Всего).
Сколько дней хранить каждое событие | Фильтр по интервалу количества дней, отводимых для хранения искомых типы событий (в случае, если это количество задано, а не используется по умолчанию).
Сколько дней хранить динамику типа события | Фильтр по интервалу количества дней, отводимых для хранения динамики искомых типы событий (в случае, если это количество задано, а не используется по умолчанию).
Включить в отчет по рекламе | Позволяет выбрать типы событий с определённым значением флага Включить в отчет по рекламе.
Включить в круговую диаграмму и график по умолчанию | Позволяет выбрать типы событий с определённым значением флага Включить в круговую диаграмму и график по умолчанию.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы установить фильтр по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех типов событий нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Открывает форму создания нового типа событий.
Группировка | Выпадающий список, в котором можно выбрать метод группировки типов событий для отображения: без группировки, с группировкой по event1 или event2. Группировка видоизменяет таблицу типов, при этом каждая строка в таблице отображает данные по всем типам событий с одинаковыми event1 или event2.
Диаграмма | Открывает форму с круговой диаграммой типов событий.
Графики | Открывает форму с графиками типов событий.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из таблицы в формат MS Excel.

Типы событий

Поле | Описание
Колонка флажков Поле предназначено для выбора событий, к которым предполагается применить какое-либо действие из панели действий, расположенной ниже таблицы кампаний.

Эта колонка присутствует только в несгруппированной таблице.
Меню действий Нажатие на кнопку действий в строке конкретной кампании отображает меню, содержащее команды:
  • Изменить - открывает форму редактирования этого типа события;
  • Очистить - обнуляет всю статистику по данному типу события;
  • Удалить - удаляет тип события;
  • График - открывает форму График типов событий с фильтром, установленным на данный тип события;
  • Динамика - открывает форму Динамика типа события по дням с фильтром, установленным на данный тип события;
  • Кампании - открывает форму Сравнительный анализ рекламных кампаний с фильтром, установленным на данный тип события.
Эта колонка присутствует только в несгруппированной таблице.
ID Идентификатор типа события.

Эта колонка присутствует только в несгруппированной таблице.
Наименование Наименование типа события.

Эта колонка присутствует только в несгруппированной таблице.
event1 Идентификатор типа события – event1.

Эта колонка присутствует, если таблица не сгруппирована или сгруппирована по event1.
event2 Идентификатор типа события – event2.

Эта колонка присутствует, если таблица не сгруппирована или сгруппирована по event2.
Сегодня | Количество событий данного типа за текущий день.
Вчера | Количество событий данного типа за вчерашний день.
Позавчера | Количество событий данного типа за позавчерашний день.
Всего | Общее количество событий данного типа.
Первое | Дата первого события данного типа.
Последнее | Дата последнего события данного типа.


Создание и редактирование типа события

Эта форма применяется для создания и редактирования типов событий.

Контекстная панель

Кнопка | Описание
Список | Открывает список всех событий.
Добавить | Создание нового типа события. Отображается только при редактировании существующего типа события.
Очистить | Сброс типа события. Отображается только при редактировании существующего типа события.
Удалить | Удаление типа события. Отображается только при редактировании существующего типа события.

Форма настроек

Поле | Описание
event1* | Идентификатор типа события - event1. Идентификаторы типа события - два произвольных строковых значения, которые, в первую очередь, позволяют идентифицировать тип события в более читабельном виде, чем просто цифровой ID, а, во-вторых, позволяют группировать различные типы событий в соответствующем отчете.
event2* | Идентификатор типа события - event2.
Включить в отчет по рекламе | Флаг, позволяющий скрыть или отобразить события данного типа в отчете по рекламным кампаниям.
Включать в диаграмму и график по умолчанию | Флаг, позволяющий включать либо не включать данный тип события в круговую диаграмму и график типов событий по умолчанию.
Сколько дней хранить каждый экземпляр данного типа события | Срок хранения события данного типа. Если значение не задано, используется значение, указанное в настройках модуля (параметр Сколько дней хранить каждое событие).
Сколько дней хранить динамику типа события | Срок хранения динамики событий данного типа. Если значение не задано, используется значения в настройках модуля (параметр Сколько дней хранить динамику типов событий).
Порядок сортировки | Порядок сортировки данного типа события.
Наименование | Поле ввода, позволяющее ввести краткое наименование типа события (предпочтительно на английском языке)
Описание | Поле ввода, позволяющее ввести полное описание типа события (предпочтительно на английском языке)

* - поля, обязательные для заполнения.

Смотрите также

  • События (учебный курс "Продвижение сайта и Маркетинг")


Динамика типа события по дням

На данной форме представлена динамика событий заданного типа (количество) по дням. Фильтр позволяет задать интересующий Вас тип события и временной интервал для отображения.

Фильтр

Параметр | Описание
Тип события | Идентификатор типа события, динамику по которому следует отобразить. Кнопка Выбрать открывает окно со списком типов событий для выбора. Данное поле отображается, даже если фильтр свернут.
Период (DD.MM.YYYY) | Период времени, за который требуется вывести график.

Чтобы отобразить данные с учётом фильтра, нажмите на кнопку Найти. Для отображения всех данных нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
График | Открывает форму с графиком событий выбранного типа.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой формы в MS Excel.

Динамика типа события по дням

Поле | Описание
Дата | Дата, на которую приводятся данные.
Количество | Количество событий заданного типа за соответствующую дату.


Круговая диаграмма

Форма Круговая диаграмма типов событий (Аналитика > События > Типы событий > Круговая диаграмма) отображает круговую диаграмму, показывающую количество событий того или иного типа в общем объеме событий.

Фильтр

Поле | Описание
Период (DD.MM.YYYY) | Период времени, за который требуется вывести диаграмму. Данное поле отображается, даже если фильтр свернут.
Типы событий | В этом списке можно выбрать типы событий, которые требуется отобразить на диаграмме. Для выбора нескольких событий удерживайте клавишу Ctrl. Кнопка Добавить открывает окно со списком событий для выбора. Кнопка Удалить исключает выбранные события из списка.

Чтобы отобразить данные с учётом фильтра, нажмите на кнопку Найти. Для отображения всех данных нажмите на кнопку Отменить.

Легенда диаграммы типов событий

Справа от диаграммы находится ее легенда, содержащая важную информацию. Легенда позволяет не только идентифицировать сегменты диаграммы, но и открывать формы с дополнительной информацией.

  • Первое значение в скобках - количество событий данного типа событий. Кликнув эту ссылку, можно открыть список событий с фильтром, установленным на этот тип события и временной интервал, заданный в фильтре этой страницы (круговой диаграммы).
  • Второе значение в квадратных скобках - ID типа события. Ссылка ведет на список типов событий с фильтром, установленным на этот тип события.
  • Третье значение - Идентификаторы типа события event1 и event2. Ссылка ведет на форму с графиком событий этого типа.

Пример круговой диаграммы типов событий

© «Битрикс», 2001-2008, «1C-Битрикс», 2008-2022 1С-Битрикс: Управление сайтом


Графики

Форма График типов событий (Аналитика > События > Типы событий > Графики) отображает график, показывающий количество событий того или иного типа в разрезе по дням.

Фильтр

Параметр | Описание
Период (DD.MM.YYYY) | Период времени, за который требуется вывести график. Данное поле отображается, даже если фильтр свернут.
Типы событий | В этом списке можно выбрать типы событий, которые требуется отобразить на графике. Для выбора нескольких событий удерживайте клавишу Ctrl. Кнопка Добавить открывает окно со списком событий для выбора. Кнопка Удалить исключает выбранные события из списка.

Чтобы отобразить данные с учётом фильтра, нажмите на кнопку Найти. Для отображения всех данных нажмите на кнопку Отменить.

Контекстная панель

Кнопка Описание
[тип_графика] Открывает меню выбора типа графика:
  • Суммарный график - один график суммы значений всех показателей.
  • Отдельные графики - отдельные графики показателей.
[Показывать] Открывает меню выбора параметра, отображаемого на графике:
  • Денежные суммы - финансовые показатели событий (если они установлены).
  • Количество - количество событий.

Легенда графика типов событий

Внизу графика находится легенда, которая позволяет не только идентифицировать линии графика, но и открывать формы с дополнительной информацией.

  • Первое значение в квадратных скобках - ID типа события. Ссылка ведет на список типов событий с фильтром, установленным на этот тип события.
  • Третье значение - Идентификаторы типа события event1 и event2. Ссылка ведет на форму просмотра динамики событий этого типа; фильтр открываемой формы установлен на этот тип события и временной интервал, заданный в фильтре этой страницы.

Пример графика типов событий

© «Битрикс», 2001-2008, «1C-Битрикс», 2008-2022 1С-Битрикс: Управление сайтом


Отправить отзыв по этому разделу

Поисковики

  • Поисковые фразы. Переходы с поисковиков
  • Поисковые системы
  • Круговая диаграмма индексации сайта
  • График индексации сайта
  • Хиты поисковиков
  • Динамика посещений сайта поисковиком
  • Редактирование поисковика
  • Автодетект


Поисковые фразы. Переходы с поисковиков

Фильтр

Поле | Описание
Поисковая фраза* | Маска поисковых фраз, которые требуется отобразить. Это поле присутствует, даже если фильтр свернут.
ID* | ID записи в базе данных, содержащей информацию по поисковой фразе, с которой зашли на сайт.
Поисковая система* | Фильтр по ID и наименованию поисковой системы. Вы можете воспользоваться выпадающим списком всех поисковых систем, занесенных в базу данных.
Дата (DD.MM.YYYY) | Дата занесения в базу поисковой фразы.
Куда пришли* | Сайт и страница, на которую пришли с поисковой фразой (при внутреннем поиске - последняя страница, на которую перешли с результатов поиска). В выпадающем списке (ошибка 404) можно указать, отображать ли только запросы несуществующих страниц.
ID ссылающегося* | ID в таблице ссылающихся сайтов. В случае внешней поисковой системы - помимо выделения из поисковой фразы, система заносит ссылающуюся страницу в таблицу ссылающихся сайтов.
ID сессии* | ID сессии, в течение которой была занесена в базу поисковая фраза.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы установить фильтр по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех фраз нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из таблицы в MS Excel.

Cписок переходов

На странице Список переходов (Аналитика > Поисковики > Переходы с поисковиков > Список переходов) выводится информация на какую страницу/раздел сайта пришли посетители по поисковым фразам с поисковой системы.
Поле | Описание
ID | Идентификатор перехода по поисковой фразе.
Поисковая фраза | Поисковая фраза.
Поисковая система | Идентификатор и имя поисковой системы. Ссылка на идентификаторе открывает список поисковых систем с фильтром, установленным на эту систему. Ссылка на имени поисковой системы переключает данную форму в режим группировки по фразам именно этой поисковой системы.
Дата | Дата занесения поисковой фразы в базу.
Куда пришли | Мнемоническое имя сайта и адрес страницы из результатов поиска, на которую кликнул посетитель. Ссылка с именем сайта открывает форму настроек этого сайта. Ссылка на адресе страницы открывает ее для просмотра.
Ссыл. | Идентификатор записи в базе. Ссылка на идентификаторе записи открывает форму на cсылающиеся сайты с фильтром на этот идентификатор.
Сессия | Идентификатор сессии в базе. Ссылка на идентификаторе сессии открывает форму сессий посетителей с фильтром на этот идентификатор.

Cписок поисковых систем

На странице Список поисковых систем (Аналитика > Поисковики > Переходы с поисковиков > По поисковикам) выводится количество переходов с поисковых систем, среднее количество хитов посетителей с данной поисковой системы, а также графическое представление доли переходов с данной поисковой системы.
Поле | Описание
Номер | Порядковый номер записи.
Поисковая система | Идентификатор и имя поисковой системы. Ссылка на идентификаторе открывает список поисковых систем с фильтром, установленным на эту систему. Ссылка на имени поисковой системы переключает данную форму в режим группировки по фразам именно этой поисковой системы.
Количество | Количество переходов с данной поисковой системы; доля переходов с данной поисковой системы.
Хитов в среднем | Среднее количество хитов с данной поисковой системы.
График | Элемент диаграммы.

Cписок поисковых фраз

Форма Поисковые фразы (Аналитика > Поисковики > Список фраз) отображает информацию по поисковым фразам, по которым ваш сайт был найден в поисковой системе, а также фразы, которые были использованы при внутреннем поиске по сайту.

Поле | Описание
Номер | Порядковый номер фразы.
Поисковая фраза | Поисковая фраза. Ссылка на фразе добавляет ее в фильтр.
Количество | Количество использований данной поисковой фразы. Процентное соотношение количества запросов по поисковой фразе к общему количеству поисковых фраз в таблице.
График | Элемент диаграммы.

Смотрите также

  • Переходы с поисковиков, список фраз (учебный курс "Продвижение сайта и Маркетинг")


Поисковые системы

Форма, представленная на странице Поисковые системы (Аналитика > Поисковики > Индексация > Список), содержит информацию об индексации сайта различными поисковыми системами.

Фильтр

Поле | Описание
Наименование* | Отбор поисковой системы по ее названию. Это поле присутствует, даже если фильтр свернут.
ID* | Отбор поисковой системы по ID.
Активен | Отбор по значению флага активности.
Сохранять хиты | Если флаг установлен, отображаются только поисковики, чьи хиты записываются в таблицу хитов поисковиков.
Включать в круговую диаграмму индексации по умолчанию | Позволяет отобрать те поисковые системы, которые включаются в диаграмму индексации сайта, не включаются, или все.
Всего хитов | Отбор поисковых систем по количеству произведенных с них хитов.
Дата последнего хита (DD.MM.YYYY) | Отбор по дате последней индексации сайта поисковиком.
Период (DD.MM.YYYY) | Временной интервал, за который следует отобразить количество проиндексированных страниц.
UserAgent* | UserAgent искомых поисковых систем.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы установить фильтр по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех фраз нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Нажатие этой кнопки открывает форму добавления новой поисковой системы.
Диаграмма | Открывает форму с круговой диаграммой индексации сайта поисковыми системами.
Графики | Открывает форму с графиком индексации сайта поисковыми системами.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список поисковых систем

Поле | Описание
Колонка флажков | Поле предназначено для выбора поисковых систем, к которым предполагается применить какое-либо действие из панели действий, расположенной ниже таблицы.
Меню действий Нажатие на кнопку действий в строке конкретной поисковой системы отображает меню, содержащее команды:
  • График - открывает форму с графиком индексации сайта этой поисковой системой;
  • Динамика - открывает форму с отчетом о динамике индексации сайта этой поисковой системой (количество хитов за каждый день);
  • Изменить - редактирование параметров поисковой системы;
  • Удалить - удаляет поисковую систему.
ID | ID поисковой системы.
Наименование | Имя поисковой системы. Ссылка на имени открывает форму с графиком индексации сайта этой поисковой системой.
UserAgent | Строка UserAgent поисковой системы.
Сегодня | Количество индексаций этой поисковой системой за текущий день. | Ссылка на значении открывает форму с отчетом о динамике индексации сайта этой поисковой системой именно за этот день или период.
Вчера | Количество индексаций за вчерашний день.
Позавчера | Количество индексаций за позавчерашний день.
Всего | Общее количество индексаций страниц этой поисковой системой. Ссылка на значении открывает форму с отчетом о динамике индексации сайта этой поисковой системой за все время ведения статистики.
Последний хит | Дата последней индексации.

Смотрите также

  • Список поисковиков (учебный курс "Продвижение сайта и Маркетинг")


Круговая диаграмма индексации сайта

На странице Круговая диаграмма индексации сайта (Аналитика -> Поисковики -> Индексация -> Круговая диаграмма) отображается круговая диаграмма, иллюстрирующая долю каждой поисковой системы в общей индексации сайта.

Фильтр

Поле | Описание
Период (DD.MM.YYYY) | Временной интервал, за который необходимо представить диаграмму. Это поле присутствует, даже если фильтр свернут.
Поисковики | В этом списке можно выбрать поисковые системы, которые следует отобразить на диаграмме.

Чтобы построить диаграмму по заданным критериям поиска, нажмите на кнопку Найти.

Контекстная панель

Кнопка | Описание
Список | Нажатие этой кнопки открывает форму со списком всех поисковых систем.
Графики | Открывает форму с графиком индексации сайта поисковыми системами.

Легенда диаграммы

Внизу диаграммы находится ее легенда, содержащая важную информацию. Легенда позволяет не только идентифицировать сегменты диаграммы, но и открывать формы с дополнительной информацией.

  • Первое значение в скобках - количество хитов этой поисковой системы. Кликнув эту ссылку, можно открыть список хитов с фильтром, установленным на эту поисковую систему и временной интервал, заданный в фильтре этой страницы (круговой диаграммы).
  • Второе значение в квадратных скобках - ID поисковой системы. Ссылка ведет на список поисковых систем с фильтром, установленным на эту систему.
  • Третье значение - название поисковой системы. Ссылка ведет на форму с ее графиком.

Смотрите также

  • Круговая диаграмма (учебный курс "Продвижение сайта и Маркетинг")


График индексации сайта

На странице Графики индексации сайта (Аналитика > Поисковики > Индексация > Графики) отображаются графики, иллюстрирующие индексацию сайта поисковыми системами.

Фильтр

Поле | Описание
Период (DD.MM.YYYY) | Временной интервал, за который необходимо построить график. Это поле присутствует, даже если фильтр свернут.
Поисковики | В этом списке можно выбрать поисковые системы, которые следует отразить на графике. В выпадающем списке выберите метод построения графика: суммарный по всем указанным поисковым системам или по отдельности.

Чтобы построить график по заданным критериям поиска, нажмите на кнопку Найти.

Контекстная панель

Кнопка | Описание
Список | Нажатие этой кнопки открывает форму со списком всех поисковых систем.
Диаграмма | Открывает форму с диаграммой индексации сайта поисковыми системами.

Графики индексации

Легенда графика

Внизу графика находится легенда, аналогичная легенде круговой диаграммы.

Смотрите также:

  • Графики индексации (учебный курс "Продвижение сайта и Маркетинг")


Хиты поисковиков

На странице Хиты поисковиков (Аналитика > Поисковики > Индексация > Хиты поисковиков) представлены адреса страниц сайта, проиндексированные внешними поисковыми системами.

Фильтр

Поле | Описание
Поисковая система* | ID или наименование поисковой системы для отображения. Для выбора можно воспользоваться выпадающим списком со всеми поисковыми системами, занесенными в базу данных. Это поле присутствует, даже если фильтр свернут.
ID* | Поиск по маске ID записи в базе данных, содержащей адрес проиндексированной страницы.
Дата (DD.MM.YYYY): Период времени, за который требуется отобразить данные по индексации.
Страница* Поиск по маске адреса проиндексированной страницы.

В выпадающем списке (ошибка 404) можно указать, отображать ли только запросы несуществующих страниц.
UserAgent* | Отбор хитов поисковых систем по маске UserAgent (поле HTTP-заголовка UserAgent).
IP адрес* | Отбор хитов поисковых систем по маске значения поля IP адрес (поиск по IP адресу поисковых систем на момент индексации той или иной страницы).
Логика между полями Переключатель, определяющий механизм поиска записей:
  • И - выводятся события, удовлетворяющие всем критериям фильтра.
  • ИЛИ - выводятся события, удовлетворяющие хотя бы одному критерию.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы установить фильтр по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех хитов нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список хитов поисковиков

Поле | Описание
ID | ID проиндексированной страницы.
Дата | Дата и время индексации страницы.
Поисковик | Поисковая система. Ссылка на идентификаторе открывает список поисковых систем с фильтром, установленным на эту систему.
UserAgent | UserAgent поисковой системы.
IP адрес | IP адрес поисковой системы на момент индексации страницы. Ссылка Стоп-лист открывает форму для добавления в стоп-лист данного IP-адреса.
Страница | Адрес проиндексированной страницы. Ссылка на идентификаторе сайта открывает форму редактирования сайта.

Смотрите также

  • Хиты поисковиков (учебный курс "Продвижение сайта и Маркетинг")


Динамика посещений сайта поисковиком

Переход к форме Динамика индексации сайта поисковиком осуществляется со страницы со списком поисковых систем, используя меню действий поисковика:

В форме Динамика индексации сайта поисковиком представлена динамика по дням, выраженная в цифрах.

Фильтр

Поле | Описание
Поисковик | В этом списке можно выбрать поисковые системы, которые следует отобразить на диаграмме. Это поле присутствует, даже если фильтр свернут.
Период (DD.MM.YYYY) | Временной интервал, за который необходимо представить диаграмму.

Для того чтобы вывести таблицу по заданным критериям поиска, нажмите на кнопку Найти.

Контекстная панель

Кнопка | Описание
Список | Нажатие этой кнопки открывает форму со списком всех поисковых систем.
График | Открывает форму с графиком индексации сайта данной поисковой системой.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Динамика посещений сайта поисковиком

Поле | Описание
Дата | Количество проиндексированных страниц за соответствующую дату.
Хитов | Общее количество проиндексированных страниц. Ссылка на количестве проиндексированных страниц открывает список хитов поисковика с фильтром, установленным на эту систему.

Смотрите также

  • Динамика индексации (учебный курс "Продвижение сайта и Маркетинг")


Редактирование поисковика

Эта форма применяется для создания новых поисковиков и редактирования существующих. Форма может быть открыта путём нажатия кнопки Добавить контекстной панели списка поисковых систем, либо выбора пункта Изменить меню действий:

Контекстная панель

Кнопка | Описание
Список | Нажатие этой кнопки открывает форму со списком всех поисковых систем.
Добавить | Открывает текущую форму для добавления новой поисковой системы. Отображается только при редактировании существующего поисковика.
Удалить | Удаляет открытую для правки поисковую систему. Отображается только при редактировании существующего поисковика.

Вкладка Свойства

Поле | Описание
Активен | Флаг активности поисковой системы. Хиты активных поисковых систем распознаются и регистрируются в системе.
Проверять лимит активности | Если флаг не установлен, и в настройках модуля установлена проверка на превышение лимита активности клиентом, с данного поисковика снимаются все ограничения на превышение установленного лимита активности.
Сохранять хиты | Если флаг установлен, адреса проиндексированных страниц сохраняются в базе данных.
Включать в диаграмму и график индексации по умолчанию | Если флаг установлен, данные по этой поисковой системе включаются в круговую диаграмму индексации сайта.
Сколько дней хранить хиты | Количество дней для хранения адресов проиндексированных страниц. Если параметр не указан, используется значение, задаваемое в настройках модуля статистики (параметр Сколько дней хранить хиты поисковиков).
Сколько дней хранить динамику | Количество дней для хранения динамики индексации сайта. Если параметр не указан, используется значение, задаваемое в настройках модуля статистики (параметр Сколько дней хранить динамику поисковиков).
Наименование* | Наименование поисковой системы (например, Google).
UserAgent | UserAgent поисковой системы (например, Googlebot/).
Домены
Поле | Описание
Домен [%_] | Домен поисковой системы без www (например: google.com, google.com.ru, google.co.uk, search.yahoo.com и т.д.).
Переменные | Имя переменной, в которой передается искомая фраза.
Кодировка поисковой фразы | Кодировка фразы, по результатам поиска по которой поисковик вывел ссылку, ведущую на Ваш сайт.

* - поля, обязательные для заполнения.

Кнопка Сохранить позволяет сохранить свойства и выйти, кнопка Применить - сохранить и остаться в форме, а кнопка Отменить - выйти из формы без сохранения.

Переменные доменов

Переменные, в которых содержатся искомые фразы, определяются следующими правилами.

Например, при поиске на www.google.com слова bitrix поисковая система вернет результаты поиска на странице: http://www.google.ru/search?complete=1&hl=ru&source=hp&q=bitrix&aq=f&aqi=g10&aql=&oq=&gs_rfai=. В данном случае, искомое нами слово содержится в параметре q, поэтому для домена www.google.com мы устанавливаем переменную q. В дальнейшем эта переменная будет использована при выделении поисковых фраз.

Аналогично, для выделения поисковых фраз - при поиске в найденном. Например, мы ищем на Яндексе слово bitrix, а затем в найденном ищем слово download. Результаты поиска будут выданы на странице: http://yandex.ru/yandsearch?text=download&lr=22&holdreq=bitrix. Здесь поисковые фразы содержатся в параметрах holdreq и text. Указываем эти параметры через запятую, и в дальнейшем поисковые фразы будут выделяться в виде bitrix/download, т.е. через символ "/" и в соответствующем порядке.


Автодетект

Форма Автодетект неизвестных UserAgent'ов (Аналитика > Поисковики > Автодетект) предназначена для поиска в накопленных данных статистики новых для системы UserAgent’ов и определения их к классу браузеров или поисковиков.

Отнесение UserAgent’а к классу браузеров означает, что в дальнейшем данный UserAgent будет исключен из рассмотрения на странице Автодетект, и все посетители, заходящие на сайт с таким UserAgent’ом, будут регистироваться как и раньше, а именно - как обычные посетители: для них будет создан профиль, записаны сессии, хиты, зафиксированы переходы по рекламным кампаниям, события и т.д.

В случае, если UserAgent отнесен к классу поисковиков, все заходы на сайт с данным UserAgent’ом будут считаться заходами поискового робота с целью индексации содержимого сайта и, соответственно, будут зарегистрированы как поисковики: для них будут сохранены лишь адреса проиндексированных страниц.

Общие рекомендации по использованию

  1. Если вам неизвестен тот или иной UserAgent, то прежде, чем его классифицировать, лучше поискать этот UserAgent в какой-либо поисковой системе интернета.
  2. Обращайте внимание на длину и уникальность добавляемой маски для поисковика. В противном случае, маска может совпасть с каким-либо браузером, и все посетители, заходящие на сайт с данным браузером, будут обработаны как поисковики.
  3. Если в имени UserAgent'а встречается bot, robot, или crawler, то его с большой долей вероятности можно отнести к роботу поисковой системы (например: Googlebot, Gaisbot, GrigorBot, MetaTagRobot, metacrawler и т.д.).
  4. Если UserAgent является программой для скачивания, его лучше отнести к классу браузеров, т.к. в противном случае не будут фиксироваться события по скачиванию файлов.
  5. Если UserAgent является offline-браузером или какой-либо иной утилитой для получения web-содержимого, его лучше отнести к классу браузеров.
  6. Если UserAgent неизвестен и не определён, его лучше не относить ни к одному из классов.

Для добавления неизвестных UserAgent'ов в систему, воспользуйтесь одним из пунктов меню действий для требуемого UserAgent'а: Добавить как поисковик или Добавить как браузер.

Фильтр

Поле | Описание
UserAgent* | UserAgent посетителя сайта. Это поле присутствует, даже если фильтр свернут.
Искать за текущий день | Позволяет просмотреть данные за текущий день, за остальные дни или все.
Сессий | Отбор записей по интервалу количества сессий (количество заходов посетителей с тем или иным UserAgent’ом).

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы установить фильтр по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех данных нажмите на кнопку Отменить.

Список UserAgent’ов

Поле | Описание
Колонка флажков | Поле предназначено для выбора UserAgent’ов, к которым предполагается применить какое-либо действие из панели действий, расположенной ниже таблицы.
UserAgent | Неизвестный системе UserAgent.
Сессий | Количество заходов (сессий) с данным UserAgent’ом.
Добавляемая маска [%_] | Добавляемая маска в таблицу поисковиков либо браузеров; в маске допускается использование: % – 0 или более любых символов; _ – один любой символ.
Поисковик | Отнести UserAgent к классу поисковиков.
Браузер | Отнести UserAgent к классу браузеров.

Смотрите также

  • Автодетект (учебный курс "Продвижение сайта и Маркетинг")


Отправить отзыв по этому разделу

Ссылающиеся сайты

  • Сайты. Страницы. Переходы


Сайты. Страницы. Переходы

Переход на страницу Ссылающиеся сайты осуществляется таким образом: пункт меню Аналитика > Ссылающиеся сайты > Сайты (или Страницы или Переходы). Форма на странице отображает адреса страниц, с которых приходят на Ваш сайт, а также адреса страниц на Вашем сайте, куда осуществляется переход.

Фильтр

Параметр | Описание
ID* | Поиск по маске ID записи.
ID сессии* | Поиск по маске ID сессии, открывшейся в момент захода посетителя на сайт.
Откуда пришли* | Отбор результатов по маске страницы, ссылающейся на Ваш сайт.
Протокол | Позволяет отфильтровать результаты по имени протокола (напр., http).
Домен | Позволяет найти сайты и страницы, имеющие вхождение данной строки в имя домена.
Страница* | Поиск по маске ссылающейся страницы.
Куда пришли* | Поиск по маске страницы, на которую ссылается страница-источник. В выпадающем списке (ошибка 404) можно указать, отображать ли запросы несуществующих страниц.
Период | Временной интервал, за который следует отобразить переходы со ссылающейся страницы.
Логика между полями | Определяет, будут ли при поиске учитываться все критерии, или требуется совпадение по хотя бы одному критерию.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы установить фильтр по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех страниц нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Группировка | Открывает меню, в котором можно выбрать желаемый режим группировки результатов: по домену, по ссылке или без группировки. В зависимости от типа группировки, таблица отчета несколько изменяется.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из таблицы в формат MS Excel.

Таблица Переходы
(без группировки)

ID | Откуда пришли | Куда пришли | Дата | Сессия
[1] | [2] | [3] | [4] | [5]
Выбрано: [6]
  1. ID записи в базе.
  2. Ссылающаяся страница.
  3. Страница, на которую ссылается страница-источник.
  4. Дата захода посетителя со ссылающейся страницы.
  5. ID сессии, открывшейся в момент захода посетителя на сайт.
  6. Количество записей, выбранных из базы данных.

Таблица Сайты или Страницы
(группировка по домену или ссылке)

Номер | Откуда пришли | Количество | % | Хитов в среднем | График
[1] | [2] | [3] | [4] | [5] | [6]
 | Выбрано: [7]
  1. Порядковый номер записи.
  2. Доменное имя сайта.
  3. Абсолютное значение количества заходов со ссылающегося сайта.
  4. Процентное значение количества заходов со ссылающегося сайта.
  5. Среднее количество хитов посетителей, зашедших с того или иного сайта.
  6. Элемент диаграммы.
  7. Количество записей, выбранных из базы данных.

Смотрите также

  • Ссылающиеся сайты (учебный курс "Продвижение сайта и Маркетинг")


Отправить отзыв по этому разделу

Посетители

  • Список посетителей
  • Сессии посетителей
  • Хиты
  • Стоп-лист
  • Создание и редактирование записи стоп-листа


Список посетителей

На странице Посетители сайта (Аналитика > Посетители > Список посетителей) отображен список посетителей сайта.

Фильтр

Поле | Описание
ID, логин, имя, фамилия* Позволяет отобрать зарегистрированных посетителей по маске их логина, имени, фамилии или ID.

Данное поле отображается, даже если фильтр свернут.
ID посетителя* | Позволяет отобрать посетителей сайта (в т.ч. незарегистрированных) по маске их ID.
Зарегистрирован | Определяет, отображать ли зарегистрированных посетителей, незарегистрированных или всех.
UserAgent* | Данное поле позволяет отфильтровать посетителей по используемым ими браузерам.
IP адрес* | Отбор посетителей по IP адресу последнего входа.
Языки* | Отбор посетителей по языкам, установленным в браузере (для Internet Explorer: меню Tools > Internet Options > Languages).
Страна* | Отбор посетителей по стране. В квадратных скобках можно ввести двухсимвольную аббревиатуру страны (напр., RU, BY, US).
Регион | Позволяет отобрать посетителей сайта по региону.
Город | Позволяет отобрать посетителей сайта по городу. В квадратных скобках можно ввести код города.
Дата первого захода (DD.MM.YYYY) | Интервал для отбора посетителей по дате первого посещения.
Дата посещения (DD.MM.YYYY) | Интервал для отбора посетителей по датам посещений сайта (обрабатывается таблица сессий, поэтому искомые данные, возможно, будут уже очищены).
Дата последнего захода (DD.MM.YYYY) | Интервал для отбора посетителей по дате последнего посещения.
Страница* Позволяет найти посетителей по сайту и первым страницам первого входа и последним страницам последнего входа.

В выпадающем списке (ошибка 404) можно указать, отображать ли только запросы несуществующих страниц.
Пришел по рекламной кампании | Флаг, позволяющий отфильтровать посетителей, первый либо последний вход которых произошел по рекламной кампании.
ID рекламной кампании* | В этом поле можно через запятую указать ID рекламных кампаний для первого либо последнего входов.
referer1 / referer2* | Идентификаторы рекламной кампании первого либо последнего входов, соответственно, referer1 и referer2.
referer3* | Дополнительный параметр рекламной кампании первого либо последнего входов.
Событий | Интервал для количества событий, инициированных искомыми посетителями.
Сессий | Интервал для количества сессий (заходов на сайт), инициированных искомыми посетителями.
Хитов | Интервал для количества хитов, инициированных искомыми посетителями.
Логика между полями Переключатель, определяющий механизм поиска записей:
  • И - выводятся события, удовлетворяющие всем критериям фильтра;
  • ИЛИ - выводятся события, удовлетворяющие хотя бы одному критерию.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы установить фильтр по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех данных нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из таблицы в MS Excel.

Список посетителей

Поле | Описание
Меню действий Нажатие на кнопку действий в строке конкретной поисковой системы отображает меню, содержащее команды:
  • Подробно - открывает отдельное окно с детальной информацией по посетителю (см. ниже).
ID | ID посетителя. Если ID выделен красным, данный идентификатор является вашим.
Пользователь Данные зарегистрированного посетителя:
  • [ID пользователя] - ссылка открывает форму редактирования пользователя;
  • (логин) - логин посетителя;
  • Имя Фамилия - имя и фамилия посетителя.
Сессий | Количество сессий (заходов на сайт) посетителя. Если количество сессий равно 1, посетитель впервые зашел на сайт; в противном случае – посетитель относится к категории вернувшихся. Ссылка на показателе открывает список сессий с фильтром, установленным на ID этого посетителя (не пользователя).
Событий | Количество событий, инициированных посетителем. Ссылка на показателе открывает список событий с фильтром, установленным на ID этого посетителя.
Хитов | Количество хитов (загруженных страниц) посетителя. Ссылка на показателе открывает список хитов с фильтром, установленным на ID этого посетителя.
Первый заход | Время первого посещения сайта.
Последний заход | Время последнего посещения сайта.
Откуда пришел | Страница, с которой посетитель пришел на сайт.
Первая страница | Страница, на которую пришел посетитель в момент открытия сессии.
Последняя страница | Последняя страница, просмотренная в данной сессии.
Пришел по рекламной кампании | Рекламная компания, по которой посетитель сделал прямой заход, либо возврат.
Последняя рекламная комания | Последняя рекламная компания, по которой посетитель сделал прямой заход, либо возврат.
UserAgent | UserAgent посетителя сайта.
IP | IP-адрес посетителя. Ссылка на значении открывает страницу поиска информации по этому адресу http://whois.domaintools.com/ip [image].
Страна | Страна посетителя (определяется по IP-адресу).
Регион | Регион посетителя (определяется по IP-адресу).
Город | Город посетителя (определяется по IP-адресу).

Подробный просмотр данных посетителя

Этот отчет открывается в новом окне при выборе команды Подробно в меню действий какого-либо посетителя.

Поле | Описание
ID | ID посетителя в базе
Сессий | Количество сессий, открытых посетителем.
Событий | Количество событий, инициализированных посетителем.
Хитов | Количество просмотренных страниц.
Первый вход
Дата | Дата начала первой сессии посетителя.
ID сессии | ID первой сессии.
Хитов | Количество просмотренных страниц в первой сессии.
Время | Время первой сессии.
Откуда пришел | Ссылающаяся страница в момент открытия первой сессии.
Куда пришел | На какую страницу посетитель зашел в момент открытия первой сессии.
Рекламная кампания | Поле отображается в случае прямого захода по рекламной кампании. Если в первой сессии был прямой заход по рекламной кампании, то в данном поле отображаются данные рекламной кампании: [ID] referer1 / referer2 / referer3.
Последний вход
Дата | Дата начала последней сессии посетителя.
ID сессии | ID последней сессии.
Хитов | Количество просмотренных страниц в последней сессии.
Время | Время последней сессии.
Пользователь | Регистрационные данные пользователя в последней сессии. Поле отображается только для зарегистрированных пользователей.
Последняя | Последняя просмотренная страница.
IP (хост) | IP адрес посетителя и его хост.
Страна | Страна посетителя (определяется по IP посетителя).
UserAgent | UserAgent браузера посетителя.
Рекламная кампания | Последняя рекламная кампания, по которой посетитель сделал прямой вход.
Языки | Языки установленные в браузере посетителя.
Cookie | Содержимое файла cookie посетителя на его последнем хите.

Смотрите также

  • Список посетителей (учебный курс "Продвижение сайта и Маркетинг")


Сессии посетителей

Описание

Форма Сессий посетителей (Аналитика > Посетители > Сессии посетителей) отображает сессии посетителей сайта.

Моментом начала сессии в системе "1С-Битрикс: Управление сайтом" признается:

  • открытие сайта в окне браузера;
  • авторизация посетителя;
  • окончание авторизации посетителя (закрывается текущая сессия и сразу же открывается новая).

Моментом окончания сессии признается:

  • закрытие окна браузера;
  • окончание авторизации посетителя (закрывается текущая сессия).

Формально сессией можно считать один заход посетителя на сайт.

Фильтр

Поле | Описание
ID, логин, имя, фамилия* Позволяет отобрать зарегистрированных посетителей по их основным параметрам: ID, логин, имя или фамилия.

Данное поле отображается, даже если фильтр свернут.
ID сессии* | Маска идентификатора требуемых сессий.
Дата начала (DD.MM.YYYY) | Интервал для отбора сессий по дате начала сессии.
Дата окончания (DD.MM.YYYY) | Интервал для отбора сессий по дате окончания сессии.
ID посетителя* | Позволяет отобрать сессии по маске ID посетителей сайта.
Зарегистрирован | Определяет, отображать ли только сессии зарегистрированных посетителей, незарегистрированных или всех.
Впервые/вернулся | Флаг, позволяющий отфильтровать сессии посетителей, впервые посетивших сайт либо вернувшихся на сайт.
IP адрес* | Маска IP адреса искомых посетителей.
UserAgent* | Маска UserAgent’ов искомых посетителей.
Страна* | Позволяет отобрать сессии по стране посетителя. В квадратных скобках можно ввести двухсимвольную аббревиатуру страны (например, RU, BY, US).
Регион* | Позволяет отобрать хиты по региону посетителя.
Город* | Позволяет отобрать хиты по городу, в котором находится посетитель. В квадратных скобках можно ввести код города.
Попал в стоп-лист | Флаг, позволяющий отфильтровать сессии посетителей, которые были добавлены в стоп-лист.
ID записи стоп-листа | Позволяет отобрать сессии заблокированных пользователей по маске идентификатора записи в стоп-листе.
Хитов | Интервал для отбора сессий по количеству страниц (хитов), загруженных в течении сессии.
Событий | Интервал для отбора сессий по количеству событий, инициированных в течение сессии.
Пришел по рекламной кампании | Флаг, позволяющий отфильтровать сессии посетителей, сделавших прямой заход, либо возврат по рекламной кампании.
ID рекламной кампании* | Маска ID рекламной кампании при поиске по предыдущему полю.
referer1 / referer2* | Идентификаторы рекламной кампании – referer1, referer2 (при поиске по полю Пришел по рекламной кампании).
referer3* | Дополнительный параметр при заходе по рекламной кампании – referer3 (при поиске по полю Пришел по рекламной кампании).
Возврат по рекламной кампании | Флаг, позволяющий отфильтровать сессии посетителей или на прямом заходе по рекламной кампании, или на возврате (при поиске по полю Пришел по рекламной кампании).
Первая страница* Позволяет отфильтровать сессии посетителей по первой просмотренной странице и сайту.

В выпадающем списке (ошибка 404) можно указать, отображать ли только запросы несуществующих страниц.
Последняя страница* | То же, но для фильтрации по последним страницам сессий.
Логика между полями Переключатель, определяющий механизм поиска записей:
  • И - выводятся события, удовлетворяющие всем критериям фильтра;
  • ИЛИ - выводятся события, удовлетворяющие хотя бы одному критерию.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы установить фильтр по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех сессий нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Сессии посетителей

Поле | Описание
Меню действий Нажатие на кнопку действий в строке конкретной сессии отображает меню, содержащее команды:
  • Подробно - открывает отдельное окно с детальной информацией по сессии (см. ниже).
ID | ID сессии в базе (Ваша собственная сессия отмечена красным).
Посетитель Если посетитель зарегистрирован, данные в формате:
  • [ID пользователя] - ссылка открывает форму редактирования пользователя;
  • (логин) Имя Фамилия;
  • [ID посетителя] - ссылка открывает список посетителей с фильтром по этому посетителю.
Если посетитель впервые на сайте - (впервые), иначе - (вернулся).
Начало | Время начала сессии.
Конец | Время окончания сессии (время последнего хита).
Длительность | Длительность сессии.
IP адрес | IP адрес посетителя. Ссылка на значении открывает страницу поиска информации по этому адресу http://whois.domaintools.com/ip [image].
Хитов | Количество страниц (хитов), просмотренных в течении сессии. Ссылка на показателе открывает список хитов с фильтром, установленным на ID сессии.
Событий | Количество событий, инициированных в течении сессии. Ссылка на показателе открывает список событий с фильтром, установленным на ID сессии.
Рекламная кампания | В случае, если посетитель сделал прямой заход либо возврат по рекламной кампании, в данном столбце выводятся: ID рекламной кампании, referer1/referer2/referer3. Ссылка на ID кампании открывает список кампаний с фильтром, установленным на эту кампанию.
Первая страница | Страница, на которую пришел посетитель в момент открытия сессии.
Последняя страница | Последняя страница, просмотренная в данной сессии.
Страна | Страна посетителя (определяется по IP-адресу).
Регион | Регион посетителя (определяется по IP-адресу).
Город | Город посетителя (определяется по IP-адресу).
Выбрано | Количество сессий, выбранных из базы данных.

Подробный просмотр сессии

Поле | Описание
ID | ID сессии в базе.
Хитов | Количество просмотренных страниц.
Начало | Время начала сессии.
Конец | Время окончания сессии (время последнего хита).
Время | Длительность сессии.
Посетитель | Данные посетителя.
Первый IP-адрес | IP адрес посетителя при открытии сессии.
Последний IP-адрес | Последний IP адрес посетителя (на момент закрытия сессии).
Страна | Страна посетителя (определяется по IP-адресу).
Регион | Регион посетителя (определяется по IP-адресу).
Город | Город посетителя (определяется по IP-адресу).
Откуда пришел | Страница, откуда пришел посетитель в момент открытия сессии.
Первая страница | Страница, на которую пришел посетитель в момент открытия сессии.
Последняя страница | Последняя страница, просмотренная в данной сессии.
Рекламная кампания | Если был прямой заход либо возврат по рекламной кампании, то в данном поле отображены данные по рекламной кампании: [ID] referer1 / referer2 / referer3 (возврат - символ *).
UserAgent | UserAgent посетителя.

Смотрите также

  • Сессии посетителей (учебный курс "Продвижение сайта и Маркетинг")


Хиты

Форма Хиты посетителей (Аналитика > Посетители > Хиты) отображает хиты посетителей сайта. Под термином хит понимается одна загрузка страницы. Нажатие на ссылку на сайте и загрузка страницы приводит к генерации хита. Перезагрузка страницы или запрос к несуществующей странице (404 ошибка) также генерирует хит.

Фильтр

Поле | Описание
ID, логин, имя, фамилия* Позволяет отобрать хиты зарегистрированных посетителей по маске их строк логина, имени, фамилия или ID.

Данное поле отображается, даже если фильтр свернут.
ID хита | Маска идентификатора искомого хита.
ID сессии | Маска для отбора сессий, в течение которых пользователем были открыты страницы (сгенерированы хиты).
Дата | Интервал для отбора хитов по дате начала сессии.
ID посетителя* | Позволяет отобрать хиты по маске ID посетителей сайта.
Зарегистрирован | Определяет, отображать ли хиты зарегистрированных посетителей, незарегистрированных или всех.
Впервые/вернулся | Флаг, позволяющий отфильтровать хиты посетителей, впервые посетивших сайт либо вернувшихся на сайт.
IP адрес* | Маска IP-адреса посетителей, сгенерировавших искомые хиты.
Страна* | Позволяет отобрать хиты по стране посетителя. В квадратных скобках можно ввести двухсимвольную аббревиатуру страны (например, RU, BY, US).
Регион* | Позволяет отобрать хиты по региону посетителя.
Город* | Позволяет отобрать хиты по городу, в котором находится посетитель. В квадратных скобках можно ввести код города.
UserAgent* | Маска UserAgent’ов посетителей, сгенерировавших искомые хиты.
Cookie* | Маска для сопоставления с cookie посетителей (отбор хитов посетителей, которым были переданы определённые cookie).
Попал в стоп-лист | Флаг, позволяющий отфильтровать хиты посетителей, которые были добавлены в стоп-лист.
ID записи стоп-листа* | Позволяет отобрать хиты заблокированных пользователей по маске идентификатора записи в стоп-листе.
Страница* Позволяет отфильтровать хиты посетителей по имени страницы и сайту.

В выпадающем списке (ошибка 404) можно указать, отображать ли только запросы несуществующих страниц.
Логика между полями Переключатель, определяющий механизм поиска записей.
  • И - выводятся события, удовлетворяющие всем критериям фильтра.
  • ИЛИ - выводятся события, удовлетворяющие хотя бы одному критерию.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы установить фильтр по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех данных нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Хиты посетителей

Поле | Описание
Меню действий Нажатие на кнопку действий в строке конкретного хита отображает меню, содержащее команды:
  • Подробно - открывает отдельное окно с информацией по хиту.
ID | ID хита в базе (Ваш текущий хит отмечен красным).
Дата | Дата и время генерации хита (например, загрузки страницы).
Посетитель Если посетитель зарегистрирован, данные в формате:
  • [ID пользователя] - ссылка открывает форму редактирования пользователя;
  • (логин) Имя Фамилия.
Если посетитель впервые на сайте - (впервые), иначе - (вернулся).
IP адрес | IP адрес посетителя. Ссылка на значении открывает страницу поиска информации по этому адресу (http://whois.domaintools.com/ip [image]).
Страна | Страна посетителя (определяется по IP-адресу).
Город | Город, в котором находится посетитель (определяется по IP-адресу).
Страница | Страница хита.

Подробный просмотр информации о хите

Поле | Описание
ID | ID хита в базе.
Сессия | ID сессии в базе.
Дата | Время возникновения хита.
Откуда пришел | Ссылающаяся страница.
Куда пришел | Адрес страницы хита.
Посетитель | Регистрационные данные посетителя, ID посетителя.
IP адрес | IP-адрес посетителя в момент хита.
Страна | Страна посетителя.
Город | Город посетителя.
Регион | Регион посетителя.
UserAgent | UserAgent браузера посетителя.
Метод запроса | Метод HTTP-запроса: GET либо POST. Подробнее о методах запроса можно прочитать тут: Method Definitions [image] (или в переводе на русский [image] ).
Cookies | Содержимое файла cookie в момент хита.

Смотрите также

  • Хиты посетителей (учебный курс "Продвижение сайта и Маркетинг")


Стоп-лист

На странице Стоп-лист (Аналитика > Посетители > Стоп-лист) представлены параметры, используемые для ограничения доступа посетителей к содержимому сайта и перенаправлению на другие страницы.

Фильтр

Поле | Описание
ID* | Маска для отбора записей стоп-листа по идентификатору. Данное поле отображается, даже если фильтр свернут.
Сайт | Позволяет ограничить поиск записями стоп-листа только конкретных сайтов.
Дата начала (DD.MM.YYYY) | Время начала активности искомой записи стоп-листа.
Дата окончания (DD.MM.YYYY) | Время окончания активности искомой записи стоп-листа.
Активно | Позволяет выбрать или все записи, или только с установленным / снятым флагом Активно.
Добавить в статистику | Позволяет выбрать или все записи, или только с установленным / снятым флагом Добавить в статистику.
IP адрес* | IP адрес посетителя искомой записи стоп-листа.
UserAgent* | UserAgent посетителя.
Откуда* | Ссылающаяся страница (отбор записей по страницам, с которых приходили посетители, попавшие в стоп-лист).
Куда* | Отбор записей по страницам, на которые приходили посетители.
Перенаправить* | Поиск записей по маске страницы, на которую перенаправляется посетитель.
Сообщение* | Поиск записей по маске сообщения, отображаемого посетителю в стоп-листе.
Комментарий* | Комментарий администратора.
Логика между полями | Определяет, будут ли при поиске учитываться все критерии, или требуется совпадение по хотя бы одному критерию.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы установить фильтр по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех сессий нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Нажатие этой кнопки открывает форму добавления новой записи стоп-листа.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Стоп-лист

Поле | Описание
Поле флажков | Поле предназначено для выбора записей стоп-листа, к которым предполагается применить какое-либо действие из панели, расположенной ниже таблицы.
Меню действий Нажатие на кнопку действий в строке конкретной записи отображает меню, содержащее команды:
  • Изменить - редактирование параметров записи;
  • Удалить - удаляет запись стоп-листа.
ID | Идентификатор записи стоп-листа.
Статус активности Индикатор, сигнализирующий об активности записи:
  • - запись в данный момент активна;
  • - запись в данный момент не активна.
На активность записи влияют следующие поля:
  • время начала действия записи;
  • время окончания действия записи;
  • флаг активности записи.
Начало | Время начала действия записи.
Окончание | Время окончания действия записи.
Акт. | Флаг активности записи.
Сайт | Сайт, на котором активна данная запись стоп-листа.
IP адрес сети | IP-адрес посетителя.
Маска сети | Маска сети посетителя.
Откуда | Ссылающаяся страница (отбор записей по страницам, с которых приходили посетители, попавшие в стоп-лист).
Куда | Отбор записей по страницам, на которые приходили посетители.
Стат. | Если да - в статистике регистрируется факт попадания посетителя в стоп-лист.
UserAgent | UserAgent посетителя.
Выбрано | Количество записей, выбранных из базы данных.
Отмечено | Количество записей, отмеченных флажками.

Смотрите также

  • Стоп-лист (учебный курс "Продвижение сайта и Маркетинг")


Создание и редактирование записи стоп-листа

Форма Cоздание и редактирование записи стоп-листа предназначена для создания и редактирования параметров записей стоп-листа.

Контекстная панель

Кнопка | Описание
Стоп-лист | Переход на страницу со списком записей стоп-листа.
Создать | Нажатие этой кнопки создает новую запись стоп-листа. Отображается только при редактировании существующей записи стоп-листа.
Удалить | Удаляет открытую запись стоп-листа. Отображается только при редактировании существующей записи стоп-листа.

Закладка Параметры

Поле | Описание
Дата изменения | Дата изменения записи стоп-листа. Это поле не отображается при создании новой записи.
Активность записи
Флаг активности | Флаг, позволяющий сделать запись активной или неактивной.
Дата начала (DD.MM.YYYY HH:MI:SS) | Дата начала действия записи стоп-листа.
Дата окончания (DD.MM.YYYY HH:MI:SS) | Дата окончания действия записи стоп-листа.
По каким признакам фильтровать посетителей
Сайт | Сайт, для которого действует запись. | Актуальная фильтрация имеет место только при совпадении всех признаков с образцом (конъюнкция).
Маска сети | Маска сети посетителя (см. примечания ниже).
IP адрес | IP-адрес посетителя для сравнения.
UserAgent | UserAgent посетителя. Поле пуст служит для выделения посетителей без информации о UserAgent'е.
Откуда пришел | Страница, с которой приходят посетители.
Куда пришел | Страница, на которую приходят посетители.

Закладка Действия

Поле | Описание
Перенаправить по адресу (URL) | URL, по которому посетитель будет перенаправлен в случае его нахождения в стоп-листе.
Показать сообщение | Сообщение, которое будет показано посетителю, попавшему в стоп-лист.
В кодировке языка | Кодировка для показа сообщения.
Сохранить статистику | Если флаг установлен, факты попадания посетителя в стоп-лист регистрируются в базе данных статистики.

Закладка Комментарий

Произвольный комментарий, поясняющий причины создания данной записи стоп-листа.

После внесения изменений не забудьте нажать на кнопку Сохранить.

Замечания о масках подсетей

В терминологии сетей TCP/IP маской подсети или маской сети называется битовая маска, определяющая, какая часть IP-адреса узла сети относится к адресу сети, а какая — к адресу самого узла в этой сети. Например, узел с IP-адресом 12.34.56.78 и маской подсети 255.255.0.0 находится в сети 12.34.0.0.

Чтобы получить адрес сети, зная IP-адрес и маску подсети, необходимо применить к ним операцию поразрядной конъюнкции. Например, в случае более сложной маски:

IP-адрес:       00001100 00100010 00111000 1001110 (12.34.56.78)
Маска подсети:  11111111 11111111 11100000 0000000 (255.255.224.0)
--------------------------------------------------------------------
Адрес сети:     00001100 00100010 00100000 0000000 (12.34.32.0)

Запись стоп-листа содержит два поля: IP адрес сети и маска сети. Посетитель считается попадающим под ту или иную запись стоп-листа в случае, если при наложении маски сети на его IP-адрес мы получим IP адрес сети.

Пример 1. Стоит задача ограничить доступ всех посетителей, приходящих с IP = 206.191.49.66

  1. В этом случае нам необходимо задать:
    • IP адрес сети = 206.191.49.66
    • маска сети = 255.255.255.255
  2. В момент захода на сайт посетителя с IP = 206.191.49.66 будет произведена следующая операция конъюнкции:
    IP-адрес посетителя: 11010001 10111111 11000001 1000010 (206.191.49.66)
маска сети:          11111111 11111111 11111111 1111111 (255.255.225.255)
----------------------------------------------------------------------------
Результат:           11010001 10111111 11000001 1000010 (206.191.49.66)
    Если результат совпадает с IP адресом сети, то посетитель попадает под данную запись стоп-листа, что в данном случае и происходит. Таким образом, все посетители, заходящие на сайт с IP = 206.191.49.66, попадут под данную запись стоп-листа.

Пример 2. Стоит задача ограничить доступ всех посетителей, приходящих с подсети = 206.191.49.xxx (IP в интервале от 206.191.49.1 до 206.191.49.255)

  1. В этом случае нам необходимо задать:
    • IP адрес сети = 206.191.49.0
    • маска сети = 255.255.255.0
  2. В момент захода на сайт посетителя с IP = 206.191.49.76 будет произведена следующая операция конъюнкции:
    IP-адрес посетителя: 11010001 10111111 11000001 1001100 (206.191.49.76)
маска сети:          11111111 11111111 11111111 0000000 (255.255.225.0)
----------------------------------------------------------------------------
Результат:           11010001 10111111 11000001 0000000 (206.191.49.0)
    Если результат совпадает с IP адресом сети, то посетитель попадает под данную запись стоп-листа. Таким образом, все посетители, заходящие на сайт с IP в интервале от 206.191.49.1 до 206.191.49.255, попадут под данную запись стоп-листа.


Описание Marketplace

Marketplace - это раздел для обновления как самой системы, так и модулей и решений сторонних разработчиков, используемых на проектах. Кроме обновления сторонних модулей так же возможна их установка.

Каталог разработанных партнерами "1С-Битрикс" модулей и решений к системе Bitrix Framework позволяет максимально быстро интегрировать дополнительные возможности в систему. Он содержит как платные, так и бесплатные модули, загружаемые из Marketplace - от простых расширений, облегчающих работу сервисов сайта (например рассылка новостей), мастеров для новых решений, так и модулей со сложной интеграцией в другие системы (например платежные системы).

Раздел Marketplace позволяет:

  • устанавливать обновления системы Bitrix Framework;
  • просматривать сторонние модули, доступные для загрузки;
  • загружать и устанавливать сторонние модули;
  • просматривать список обновлений и загружать обновления.

Обратите внимание, что некоторые модули при деинсталляции предлагают сохранить (не удалять) накопленные ими данные. Если в дальнейшем вы планируете использовать эти данные, то при деинсталляции модуля следует отметить опцию Сохранить таблицы.


Каталог решений

На странице Marketplace (Marketplace > Каталог решений) можно просмотреть список доступных для загрузки и/или установленных модулей из Marketplace.

Фильтр

Фильтр используется для фильтрации модулей, доступных для загрузки из Marketplace.

Поле | Описание
Все | Отображает все имеющиеся модули в каталоге.
Платные | Оставляет в списке только платные модули.
Бесплатные | Оставляет в списке только бесплатные модули.
Акция! | В списке выводятся модули на которые действуют установленная разработчиками скидка.
Сортировать по рейтингу Позволяет выбрать сортировку отфильтрованных модулей по
  • рейтингу;
  • Дате добавления;
  • цене;
  • алфавиту.

Если вам известно название конкретного модуля, то можно использовать форму поиска. Поиск так же позволяет искать по автору модуля.

Кликом по названию или иконке модуля можно перейти к детальному просмотру модуля: описанию, отзывам пользователей, установке или покупке.

Смотрите также

  • Как установить решение с помощью штатного мастера после установки продукта
  • Как установить решение с помощью штатного мастера до установки продукта


Обновления решений

Cтраница Сторонние обновления (Marketplace > Обновления решений) предназначена для установки обновлений дополнительных модулей, разработанных партнерами "1С-Битрикс" и используемых в вашем проекте.

Контекстная панель

Кнопка | Описание
Проверить обновления | Проверка обновлений дополнительных модулей.
Изменить настройки | Переход к форме настройки Системы обновлений.

Закладка "Установка обновлений"

На данной закладке представлена информация об имеющихся рекомендуемых обновлениях сторонних модулей.

Закладка "Список обновлений"

На данной закладке в виде таблицы представлен список обновлений. Используя колонку флажков таблицы, вы можете выбрать необходимые обновления и установить их, нажав на кнопку Установить обновления.

Закладка "Активация купона"

В поле Введите купон вводится купон, полученный от разработчика стороннего модуля для активации вновь установленного модуля или продления действия уже установленного модуля.


Установленные решения

На странице Установленные решения представлены все обновления, установленные в системе, а так же информация по статусам и ошибкам установки.

Список установленных обновлений

Поле | Описание
Колонка действий Выбор действия над установленным решением. Доступно:
  • Обновить - система проверяет наличие обновлений модуля и переходит к странице установки обновлений.
  • Удалить - удаление модуля.
Название | Название и описание обновления.
Разработчик | Название (имя) разработчика модуля и ссылка на сайт разработчика.
Версия | Текущая версия установленного решения.
Дата обновления | Дата и время установки обновления.
Активен до | Срок активности (если такой установлен разработчиком решения).
Состояние | Статус произведенной установки обновления.


Система обновлений

Контекстная панель

Кнопка | Описание
Проверить обновления | Выполняется запрос к серверу обновлений на предмет наличия новых обновлений продукта.
Изменить настройки | Переход на страницу настроек главного модуля к настройкам системы обновлений.
Журнал обновлений | Просмотр журнала обновлений, который содержит информацию об установленных обновлениях, включая информацию по статусам и ошибкам установки обновлений.

Форма обновлений

Закладка "Установка обновлений"

На данной закладке представлена информация о регистрации продукта и об имеющихся рекомендуемых (обновления модулей) и опциональных обновлениях (языковые файлы интерфейса). Кроме того, если выпущено обновление самой системы обновлений, то перед началом работы необходимо установить это обновление.

Процесс загрузки обновлений системы отображается с помощью двух индикаторов выполнения (поля типа "Progress Bar").

Закладка "Список обновлений"

На данной закладке в виде таблице представлен список всех обновлений системы и языковых файлов. Используя колонку флажков таблицы, вы можете указать необходимые обновления для установки.

Активация купона

На этой закладке вводится купон для создания дополнительных сайтов на одном экземпляре.

Закладка "Дополнительно"

На данной закладке производится включение/отключение установки бета-версий, а также подписка на получение информации об обновлениях по почте.

Примечание! Не рекомендуется использовать включение бета-версий для работающих проектов. Бета-версии иногда содержат ошибки в коде, которые могут повлияют на работу вашего проекта негативным образом. Использовать ее можно для локальных установок с целью ознакомления с новым функционалом системы.

Смотрите также

  • Как настроить систему обновлений продукта
  • Как вручную проверить и установить обновления продукта
  • Что такое купоны и как их активировать
  • Основные ошибки при обновлении и способы их устранения


Настройки

Сущности раздела
Название | Описание
Избранное | Служит для быстрого перехода к заранее составленному списку страниц.
Управление пользователями | Позволяет создавать произвольное количество групп пользователей с разными правами доступа к ресурсам сайта.
Поиск | Осуществляет индексирование и поиск информации на сайте. Вся текстовая информация, которая попадает на сайт в виде статических HTML страниц или через модули (например, модуль Информационные блоки, модуль Форум и т.д.) автоматически индексируется. Поиск может осуществляться как по всей проиндексированной информации, так и по ее отдельным частям.
Проактивная защита | Является важным дополнением к стандартной политике безопасности продукта и существенно повышает уровень защиты веб-проекта.
DAV (КП) | Предназначен для обмена календарями и контактами с внешними системами.
Push and Pull | Позволяет организовать транспорт мгновенных нотификаций и сообщений клиентам.
REST API | Используется для разработки собственных приложений или интеграций для Битрикс.
Валюты | Необходим для работы модулей Торговый каталог и Интернет-магазин, позволяет управлять валютами и их курсами.
Веб-кластер | Это комбинация технологических решений, которые позволяют распределить один сайт на несколько серверов, решая тем самым несколько задач: обеспечение высокой доступности сайта; его масштабирование в условиях возрастающей нагрузки; балансирование нагрузки, трафика, данных между несколькими серверами.
Веб-сервисы | С помощью модуля Веб-сервисы можно организовать систему веб-сервисов и SOAP.
Коннекторы для внешних мессенджеров (КП) | Выполняет подключение каналов открытых линий.
Открытые линии (КП) | Позволяет организовать подключение различных внешних социальных сервисов для общения с помощью открытых линий.
Телефония | Предназначен для совершения входящих и исходящих звонков на вашем Битрикс24.
Облако 1С-Битрикс Раздел административной части Облако 1С-Битрикс содержит набор облачных сервисов и позволяет:
  • включить и настроить поддержку CDN;
  • включить и настроить инсектирование работоспособности сайта;
  • создавать и просматривать резервные копии, которые хранятся в облаке.
Облачные хранилища | Предназначен для подключения к проекту поддержки "облачных" хранилищ файлов.
AD/LDAP интеграция | Позволяет интегрировать продукт "1С-Битрикс: Управление сайтом" с корпоративными сетями, построенными с использованием Microsoft Windows Server 2000/2003/2008, Unix и Novell.
Перевод | Служит для удобства перевода файлов сообщений (заголовки таблиц, ссылки, текст кнопок и т.п.) на нескольких языков.
XMPP сервер (КП) | Предназначен для организации общения и учета присутствия сотрудников корпоративного портала, использующих Jabber-клиенты. Это можно делать только на выделенном сервере или на виртуальном выделенном сервере (VPS).
Настройки продукта (главный модуль) | Обеспечивает общее функционирование системы, взаимодействие всех модулей продукта и позволяет создавать, поддерживать и управлять неограниченным числом сайтов.
Инструменты
Монитор производительности | Предназначен для мониторинга параметров производительности сайта.
ЧатБоты (КП) | Модуль управляет чат-ботами Битрикс24. Установка модуля не происходит автоматически, так же необходимо будет осуществить настройку локальной сети для доступа к порталу из сети.
Компрессия | Осуществляет сжатие страниц для ускорения вывода содержания сайта пользователям. Модуль в несколько раз уменьшает объем передаваемых HTML-данных между сайтом и браузером клиента, что существенно увеличивает скорость работы как для посетителей, так и для администраторов сайта.


Избранное

Раздел административной части Избранное служит для быстрого перехода к заранее составленному списку страниц.

Смотрите также:

  • Избранное [image] (курс Контент-менеджер).


Список избранного

Описание

Управление избранными страницами осуществляется на странице Избранное (Настройки > Избранное) административного раздела сайта. Также на страницу со списком избранного можно перейти с помощью меню кнопки Избранное (Избранное > Организовать избранное...), расположенной на административной панели:

Список избранного предназначен для:

  • просмотра списка избранного;
  • редактирования избранных ссылок;
  • создания и удаления избранных ссылок.

Фильтр

Форма фильтра используется для выбора из списка избранного тех ссылок, которые соответствуют указанным условиям. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Найти | Позволяет найти избранные ссылки по основным параметрам: Заголовок, Ссылка и ID. Поле присутствует, даже если фильтр свернут.
Заголовок ссылки* | Поиск ссылок по заголовку.
URL ссылки* | Поиск избранного по URL ссылок.
ID* | Идентификатор ссылки избранного. Соответствует полю ID списка избранного.
Язык интерфейса Определяется, какому языку будут соответствовать избранные ссылки в результатах поиска:
  • (все) - будут отображаться избранные ссылки, соответствующие всем языкам системы;
  • далее в выпадающем списке перечислены все языки, установленные в системе, по каждому из которых можно осуществлять поиск.
Дата изменения (DD.MM.YYYY) | Позволяет отобрать избранные ссылки, параметры которых были изменены в течение интересующего вас периода. Кнопка Календарь служит для выбора даты изменения из календаря.
Кем изменено* | Позволяет отобрать избранные ссылки по пользователю, который изменил параметры избранного.
Кем создано* | Позволяет отобрать избранные ссылки по пользователю, который их создал.
Описание* | Позволяет отобрать избранные ссылки по их описанию.
Общая ссылка Определяется, какие ссылки будут отображаться в результатах поиска:
  • (все) - все ссылки (общие и необщие);
  • Да - общие для всех пользователей;
  • Нет - ссылки, не являющиеся общими для всех.
Принадлежит пользователю* | Позволяет отобрать избранные ссылки по пользователю, который является их владельцем.
Требуются права на модуль | Позволяет установить один из модулей системы, права на доступ к которому требуются для перехода по избранным ссылкам.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Для того чтобы отобрать избранные ссылки по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех ссылок нажмите на кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания новой избранной ссылки.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список групп пользователей

Поле | Описание
Колонка флажков | Поле предназначено для выбора избранных ссылок, к которым предполагается применить какое-либо правило или действие.
Действие Действия над избранной ссылкой:
  • Изменить - переход к форме редактирования избранной ссылки;
  • Удалить - удаление избранной ссылки.
Заголовок | Заголовок избранной ссылки. Представлен в виде ссылки на избранную страницу.
Ссылка | Ссылка на избранную страницу. По данной ссылке осуществляется переход к форме редактирования избранной ссылки.
Сорт. | Индекс сортировки, который определяет положение ссылки в общем списке.
Язык | Язык интерфейса, на котором будет доступна избранная ссылка.
Общая | Если ссылка является общей для всех пользователей, то в поле будет указано Да, если нет - Нет.
Владелец | ID, логин и имя пользователя, который является владельцем ссылки. ID представлено в виде ссылки на форму редактирования параметров пользователя.
Модуль | Модуль, права на доступ к которому необходимы, чтобы данная ссылка была доступна.
Изменено | Дата и время последнего изменения записи о ссылке.
Кем | ID, логин и имя пользователя, изменившего параметры избранной ссылки.
ID | Идентификатор избранной ссылки.


Создание и редактирование избранной ссылки

Форма создания/редактирования предназначена для настройки параметров существующей или вновь создаваемой избранной ссылки.

Чтобы пользователь имел право добавлять страницы административного раздела в избранное, он должен:

  • иметь доступ к административному разделу сайта;
  • иметь уровень доступа Изменение своего профайла в настройках Главного модуля.

Контекстная панель

Кнопка | Описание
Список избранного | Переход на страницу со списком избранного.
Добавить | Переход на страницу с формой создания новой ссылки. Кнопка отображается при редактировании существующей избранной ссылки.
Удалить | Удаление редактируемой ссылки. Кнопка отображается при редактировании существующей избранной ссылки.

Закладка Избранное

Поле | Описание
Изменено | Дата и время последнего изменения ссылки / ID, логин и имя пользователя, который внес изменения. Идентификатор представлен в виде ссылки на страницу с формой редактирования параметров пользователя. Поле отображается при редактировании существующей избранной ссылки.
Создано | Дата и время создания ссылки / ID, логин и имя пользователя, который создал ссылку. Идентификатор представлен в виде ссылки на страницу с формой редактирования параметров пользователя. Поле отображается при редактировании существующей избранной ссылки.
*Наименование | Наименование ссылки, которое будет отображаться в списке избранного.
*Ссылка | Путь к избранной странице.
Порядок сортировки | Относительный "вес" ссылки, определяющий положение ссылки в общем списке.
Доступна на языке интерфейса | Устанавливается, на каком языке интерфейса будет доступна создаваемая ссылка.
Комментарий | Произвольный комментарий к создаваемой ссылке.
Настройки администратора
Эта часть формы отображается при редактировании избранной ссылки администратором сайта.
Ссылка общая для всех пользователей | При [dw]отмеченной опции[/dw][di]Если опция отмечена, то доступно поле Доступна при наличии прав на модуль.Указывается один из модулей системы, при наличии прав доступа к которому ссылка будет доступна. Можно указать значение (не проверять). Если опция не отмечена, то доступно поле Принадлежит пользователю.С помощью кнопки [...] указывается пользователь системы, которому принадлежит избранная ссылка. По умолчанию поле содержит ID создателя ссылки.[/di] ссылка будет общей для всех пользователей, имеющих доступ к административном разделу.

* - поля, обязательные для заполнения.

Смотрите также

  • Избранное (учебный курс "Контент-менеджер")


Управление пользователями

Описание

Система "1С-Битрикс: Управление сайтом" позволяет создавать произвольное количество групп пользователей с разными правами доступа к ресурсам сайта. С помощью настройки прав доступа, вы можете:

  • управлять доступом пользователей к информации в публичном разделе сайта;
  • управлять доступом пользователей к "закрытым" разделам сайта. Например, закрытому форуму, партнёрскому разделу или любому другому разделу, требующему ограничения доступа;
  • разрешать пользователям изменять некоторые файлы и папки сайта, запретив при этом редактирование других файлов.

Система "1С-Битрикс: Управление сайтом" обладает широким спектром возможностей для организации совместного управления сайтом, что позволяет сократить время на его поддержку. С помощью настроек прав доступа можно организовать управление сайтом одновременно нескольким пользователям - администраторами сайта. Администраторы, в свою очередь, могут распределять определённые обязанности по управлению сайтом между другими сотрудниками компании, обладающими меньшими правами на доступ к ресурсам сайта.

Каждый зарегистрированный на сайте пользователь имеет персональные регистрационные данные: имя (логин) и пароль. Для того чтобы пользователь мог получить доступ к ресурсам сайта в соответствии с правами группы, к которой он относится, ему необходимо авторизоваться на сайте, т.е. указать свой логин и пароль в специальной форме авторизации.

Компоненты модуля

Название | Имя в пространстве имен bitrix | Описание
Параметры пользователя | main.profile | Позволяет вывести в публичную часть сайта информацию о пользователе.
Настраиваемая регистрация | main.register | Позволяет настроить форму регистрации на сайте.
Имя пользователя с тултипом | main.user.link | Выводит имя пользователя с всплывающей подсказкой (тултипом), который содержит информацию о пользователе социальной сети.
Форма авторизации | system.auth.form | Служит для вывода формы авторизации. Используется обычно в шаблоне дизайна сайта.
Форма подтверждения регистрации | system.auth.confirmation | Выводит форму подтверждения регистрации.
Запрос согласия пользователя | main.userconsent.request | Позволяет выполнить требования ФЗ-152.
Компонент для авторизации виджета Битрикс24.Онлайн-чат | b24connector.openline.info | Автоматически передаёт виджету контактные данные авторизованного клиента, позволяет настроить и дополнительно передаваемые данные.
Пароли приложений | main.app.passwords | Для управления паролями приложений.
Управление объединением профилей | socserv.auth.split | Объединяет профили пользователя (для социальных сетей).
Форма инициализации регистрации | system.auth.initialize | Выводит форму инициализации регистрации, созданной в рамках соцсети.
Форма отписки от писем | main.mail.unsubscribe | Служит для отписки от писем.

Смотрите также

  • Как управлять пользователями
  • Как импортировать пользователей


Список пользователей

Страница Список пользователей (Настройки > Пользователи > Список пользователей) содержит полный список пользователей сайта и позволяет:

  • добавлять новых пользователей сайта;
  • переходить к управлению параметрами и правами доступа пользователей;
  • удалять пользователей сайта.

Фильтр

Форма фильтр + поиск используется для фильтрации списка пользователей в соответствии с указанными условиями, а также для поиска по списку.

Параметр | Описание
ID | Идентификатор пользователя. Соответствует полю ID в списке пользователей.
Дата изменения | Позволяет отобрать пользователей, параметры которых были изменены в указанную дату или период времени.
Последняя авторизация | Позволяет осуществить поиск пользователей по дате (периоду времени) последней авторизации.
Активен | Определяется, какие пользователи будут участвовать в поиске: активные, неактивные или все (активные и неактивные).
Логин | Поле позволяет осуществить отбор пользователей по логину.
E-Mail | Служит для отбора пользователей по адресу электронной почты.
Фамилия, имя, отчество | Служит для отбора пользователей по имени.
Поля профиля | Позволяет осуществлять поиск пользователей по другим полям профиля: телефон, номер ICQ и пр.
Группы | Список групп, пользователей из которых можно отобрать. Доступен выбор нескольких групп.
Дата рождения | Служит для отбора пользователей по дате рождения.

Для того чтобы отобрать пользователей по заданным критериям поиска, нажмите на кнопку Найти. Для отображения всех групп нажмите на кнопку Сбросить.

Контекстная панель

Кнопка | Описание
Добавить пользователя | Переход к форме создания нового пользователя.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список пользователей

Поле | Описание
Колонка флажков | Поле предназначено для выбора пользователей, к которым предполагается применить какое-либо правило или действие.
Действие Действия над пользователями:
  • Изменить - переход к форме редактирования пользователя;
  • Добавить копию - создание копии пользователя;
  • Удалить - удаление пользователя;
  • Авторизоваться - быстрый вызов формы авторизации под данным пользователем. (Доступно для пользователей, имеющих в уровне доступа к Главному модулю операцию Изменение PHP-кода (edit_php).)
  • Выполнить выход - выполняется выход пользователя на всех устройствах.
Логин | Логин (имя входа) пользователя.
Активность Признак активности пользователя.

Примечание: блокировка администратора сайта невозможна.
E-mail | Адрес электронной почты пользователя.
ID | Идентификатор пользователя. Ссылка на профайл пользователя.
Остальные поля | С помощью кнопки [dw]Настройка списка[/dw][di] Нажмите на рисунок, чтобы увеличить [/di] настройте отображение остальных полей.

Групповые действия

Действие | Описание
Редактировать | Отметьте нужных пользователей в столбце флажков и нажмите Редактировать для редактирования параметров пользователей "на месте" без перехода к формам редактирования.
Удалить | Отметьте нужных пользователей в столбце флажков и нажмите Удалить для удаления одного или нескольких пользователей.
активировать | Вы можете активировать пользователей, которые на данный момент на активны без перехода к формам редактирования: отметьте неактивных пользователей в столбце флажков, установите действие активировать и нажмите Применить.
деактивировать | Вы можете деактивировать одного или нескольких пользователей, то есть не удаляя их, сделать их аккаунт неактивным. Это осуществляется без перехода к формам редактирования. Отметьте нужных пользователей в слолбце флажков, выберите действие деактивировать и нажмите Применить.
добавить в группу | Групповое действие, которое позволяет приписать к одной из заданных в системе групп произвольное число пользователей. Для этого отметьте нужных пользователей в колонке флажков, выберите действие добавить в группу, выберите нужную группу из списка и нажмите кнопку Применить.
удалить из группы | Групповое действие, которое позволяет исключить из группы произвольное число пользователей. Для этого отметьте нужных пользователей в колонке флажков, выберите действие удалить из группы, выберите нужную группу из списка и нажмите кнопку Применить.


Создание и редактирование пользователя

Закладки

На данной странице вы можете создать нового или изменить параметры существующего пользователя сайта.

Внимание! Часть полей настроек отображается только при отключенных настройках полей формы.

Все параметры пользователя сгруппированы по логическому принципу и размещены на соответствующих закладках формы.

Контекстная панель

Кнопка | Описание
Список пользователей | Переход на страницу со списком пользователей сайта.
Добавить | Переход на страницу с формой создания нового пользователя. Кнопка отображается при редактировании существующего пользователя.
Копировать | Копирование пользователя. Кнопка отображается при редактировании существующего пользователя.
Удалить | Удаление пользователя. Кнопка отображается при редактировании существующего пользователя.
Настроить | Переход к диалогу настройки внешнего вида формы редактирования.

Пользователь

Закладка служит для настройки общих параметров пользователя.

Поле | Описание
Дата обновления | Дату и время последнего изменения параметров пользователя. Поле отображается при редактировании существующего пользователя.
Последняя авторизация | Дата и время последней авторизации (входа в систему) данного пользователя. Поле отображается при редактировании существующего пользователя.
Активен | Признак активности пользователя. Для корпоративного портала Битрикс24 неактивность означает "Уволен".
Заблокирован | При установке флажка пользователь не может зайти на сайт (корпоративный портал).
Обращение | Указать какой слово использовать для обращения к пользователю. Обращение отображается в редактировании профиля, в просмотре профиля социальной сети, в формате имени в сайте и языке
Имя | Имя пользователя.
Фамилия | Фамилия пользователя.
Отчество | Отчество пользователя.
*E-Mail Адрес электронной почты пользователя, на который отсылаются все уведомления с сайта. Не допускается ввод адреса с комментарием и угловыми скобками в виде: "Имя фамилия" <mail@mail.ru>. Поле будет обязательным, если в настройках Главного модуля [dw]включена опция[/dw][di]Настройки > Настройки главного модуля > закладка Авторизация.

Подробнее...[/di] Email является обязательным полем.
*Логин (мин. 3 символа) | Логин пользователя, т.е. имя для входа в систему.
*Номер телефона для регистрации Номер телефона пользователя. Поле будет обязательным, если в настройках Главного модуля [dw]включена опция[/dw][di]Настройки > Настройки главного модуля > закладка Авторизация.

Подробнее...[/di] Номер телефона является обязательным. Возможно, но не рекомендуется, одновременное использование для регистрации номера телефона и e-mail.
Новый пароль | Поле, предназначенное для изменения текущего пароля пользователя. При изменении пароля требуется продублировать его в следующем поле. Пароль должен быть не менее 6 символов длиной.
Подтверждение нового пароля | Поле для подтверждения нового пароля пользователя. Содержимое этого поля должно в точности соответствовать содержимому предыдущего поля.
Требуется сменить пароль при следующем входе | При отмеченной опции пользователю потребуется сменить пароль при следующей попытке авторизации (будет выведена форма смены пароля). После смены пароля, опция в форме редактирования пользователя будет автоматически отключена. Параметр доступен с версии 21.400.0 главного модуля.
Тип авторизации Поле отображается, если пользователь зарегистрировался на сайте, используя источник внешней авторизации.

Это поле указывает точку проверки, посредством которой происходит авторизация пользователя.
Внешний код | Код, используемый, в основном, для внешней авторизации. Устанавливается системой.
Сайт по умолчанию для уведомлений | Сайт в системе, от имени и с использованием текстовых ресурсов которого будет производиться уведомление пользователя о каких-либо событиях.
Оповестить пользователя | Если флаг установлен, при нажатии кнопки Сохранить пользователю будет выслано сообщение об изменении его профайла.
Часовые пояса
Автоматически определять часовой пояс Для каждого пользователя можно указать настройки:
  • по умолчанию. Настройки автоопределения берутся из настроек главного модуля.
  • автоматически.
  • выбрать из списка. Выбор конкретной зоны. В этом случае становится активным поле ниже.
Настройки конкретного профиля имеют приоритет над настройками ядра.
Часовой пояс | Выбор часовой зоны.

* - поля, обязательные для заполнения.

Группы

На закладке определяется список групп, к которым привязан пользователь, а также период времени, на который осуществляется привязка.

Поле | Описание
Группа пользователей | Название группы, к которой может быть выполнена привязка пользователя.
Период активности Дата начала и конца периода, на который осуществляется привязка пользователя к группе. После окончания периода активности пользователь будет автоматически удален из данной группы.

Если пользователь привязывается к группе на неограниченный срок, то в этом поле указывается только дата начала периода активности.

Например, вы хотите предоставить новому пользователю право на доступ к закрытому форуму сайта сроком на 1 месяц. Для этого:
  • осуществите привязку данного пользователя к соответствующей группе, установив флажок в поле с названием группы (например, Закрытый форум);
  • затем, установите Период активности, по истечении которого пользователь будет удален из группы. В поле С задается дата начала (например, 25.08.2010), а в поле По - дата окончания (например, 25.09.2010) периода активности.

Безопасность

На закладке выводится информация о политике безопасности, применяемой к данной учётной записи. Изменить параметры нельзя. Если какой-то параметр политики безопасности перекрывается параметрами настроек одной из групп, в которой состоит пользователь, то будет выводится номер этой группы со ссылкой на её редактирование.

Личные данные

На закладке указывается личная информация пользователя.

Поле | Описание
Профессия | Личные данные пользователя.
WWW-страница
ICQ
Пол
Дата рождения (DD-MM-YYYY)
Фотография
Телефоны
Телефон | Контактная информация.
Факс
Мобильный
Пейджер
Скайп
Почтовый адрес
Страна | Почтовый адрес.
Область / край
Город
Почтовый индекс
Улица, дом
Почтовый ящик
Дополнительные заметки | Произвольный комментарий.

Работа

Закладка служит для указания информации о месте работы пользователя.

Поле | Описание
Наименование компании | Информация о месте работы пользователя
WWW-страница
Департамент / Отдел
Должность
Направления деятельности
Логотип компании
Телефоны
Телефон | Контактная информация.
Факс
Пейджер
Почтовый адрес
Страна | Почтовый адрес места работы пользователя.
Область / край
Город
Почтовый индекс
Улица, дом
Почтовый ящик
Дополнительные заметки | Произвольный комментарий.

Рейтинг

Закладка служит для определения начального значения рейтинга пользователя и авторитета. Также на этой вкладке вы можете посмотреть различные текущие значения параметров.

Поле | Описание
Закладка Рейтинг пользователя
Начальное значение | В данном поле можно установить начальное значение рейтинга, которое будет прибавляться к рассчитанному по критериям (голосование за пользователя, его темы и т.д.).
Текущее место | Каждому пользователю, который участвует в рейтинге, присваивается определенное место. Первая цифра - текущее занимаемое место, вторая - это смещение его относительно предыдущего. Зеленая стрелка означает, что пользователь поднялся вверх на n-мест. Красная - опустился вниз.
Текущее значение | Выводятся текущее и предыдущее значения рейтинга пользователя.
Предыдущее значение
Закладка Авторитет
Начальное значение | В данном поле можно установить начальное значение авторитета пользователя, которое будет прибавляться к рассчитанному по критериям (голосование за пользователя, его темы и т.д.).
Текущее место | Каждому пользователю, который участвует в рейтинге, присваивается определенное место. Первая цифра - текущее занимаемое место, вторая - это смещение его относительно предыдущего. Зеленая стрелка означает, что он поднялся вверх на n-мест. Красная - опустился вниз.
Текущее значение | Выводятся текущее и предыдущее значения авторитета пользователя.
Предыдущее значение
Кол-во нормированных голосов | Количество нормированных голосов в профиле показывается для информации администратору, чтобы он смог понять, почему какой-то пользователь не имеет права голосовать. Нормированный голос - это 1000 / Размер сообщества. Размер сообщество - это пользователи, которые имеют право голосовать и заходящие на сайт не позднее 90 дней (количество дней и "1000" можно задать на странице Настройки рейтингов)
Вес голоса для голосования за рейтинг | Выводится значение веса голоса для голосования за рейтинг.
Вес голоса для голосования за авторитет | Выводится значение веса голоса для голосования за авторитет.
Кол-во голосов для голосования за авторитет | Выводится количество голосов для голосования за авторитет.

Блог

Поле | Описание
Разрешено писать При отмеченной опции пользователю будет разрешено создавать сообщения (в т.ч. отвечать) в блогах.

Примечание: правом на создание своего блога обладает пользователь, который:
  • не ведет блог на данном сайте;
  • пользователь входит в группу, обладающую правами на создание блогов.
Псевдоним | Указывается псевдоним пользователя, он должен быть уникальным.
Пояснение | Короткое (2-3 слова) пояснение, отображаемое в блоге.
Интересы | Интересы пользователя.
Аватар | Картинка, отображаемая в блоге для пользователя. Максимально допустимый размер аватара указывается в настройках модуля Блоги.

Форум

На закладке задаются параметры профайла пользователя для форума.

Поле | Описание
Разрешено писать | При отмеченной опции пользователю будет разрешено создавать сообщения (в т.ч. отвечать) на форуме.
Не показывать в списке "Сейчас на форуме" | При отмеченной опции пользователь не будет отображаться в списке "Сейчас на форуме".
Включать свои сообщения в рассылку: | При отмеченной опции будет разрешено включение сообщений пользователя в рассылку для подписчиков темы.
Показывать имя | При отмеченной опции в форуме отображается имя пользователя.
Пояснение | Короткое (2-3 слова) пояснение, отображаемое в форуме.
Интересы | Интересы пользователя.
Подпись | Подпись пользователя для сообщений.
Аватар | Картинка, отображаемая в форуме для пользователя. Максимально допустимый размер аватара указывается в настройках модуля Форум.

Обучение

Поле | Описание
Разрешить публичный доступ к профайлу студента | При отмеченной опции все пользователи смогут просматривать информацию о данном пользователе.
Резюме | Резюме пользователя.
Идентификатор студента | Автоматически приписываемый пользователю уникальный идентификатор. Используется для ссылки на страницу с резюме пользователя.

Также на закладке присутствуют ссылки на Сертификаты и Журнал данного пользователя.

Двухэтапная авторизация

На закладке производится подключение устройства двухэтапной авторизации.

Примечание: До версии 20. 5.0 закладка была активна, если в модуле Проактивная защита включена поддержка двухэтапной авторизации (Настройки > Проактивная защита > Двухэтапная авторизация). С версии 20.5.0 закладка активна всегда. (Кроме версии Старт для которой этот функционал не доступе вообще.)

Примечание: Поля формы и элементы управления отличаются для включенного и отключенного механизма двухэтапной авторизации.

Поле | Описание
Включить | Включение механизма двухэтапной авторизации для пользователя.
Подключить (новый) брелок | Вызов формы подключения брелка в качестве устройства для двухэтапной авторизации.
Форма "Подключить брелок"
При инициализации или повторной синхронизации устройства с пользователем необходимо ввести Секретный ключ, поставляемый вместе с устройством, и заполнить два последовательно сгенерированных одноразовых пароля, полученных с устройства.
Поле | Описание
Секретный ключ (предоставляется индивидуально для каждого устройства) | Указывается секретный ключ, который предоставляется индивидуально с каждым устройством.
Первое значение пароля на устройстве (нажать и записать с экрана дисплея) | Указывается первое значение пароля, которое отобразится на экране дисплея после нажатия кнопки на устройстве.
Следующее значение пароля на устройстве (нажать еще раз и записать с экрана дисплея) | Указывается следующее значение пароля, которое отобразится на экране дисплея после повторного нажатия кнопки на устройстве.
Подключить (новый) телефон | Вызов формы подключения приложения на мобильном телефоне в качестве устройства для двухэтапной авторизации.
Форма "Подключить мобильный телефон"
При инициализации или повторной синхронизации мобильного приложения необходимо отсканировать QR-код или же ввести данные в приложение вручную и, в зависимости от выбранного алгоритма, заполнить поля данными, которые будут сгенерированы приложением.
Поле | Описание
Сканировать QR-код | Ссылка, позволяющая ввести нужные данный в мобильный телефон с помощью QR-кода. Для того, чтобы сканировать код, поднесите камеру мобильного телефона к монитору с картинкой и подождите, пока приложение сгенерирует требуемый код.
Ввести данные вручную | Ссылка, позволяющая переключиться в режим ручного ввода данных в мобильный телефон. При ручном вводе в мобильном приложении (в зависимости от версии) необходимо указать адрес сайта, ваш E-mail или логин, секретный код, который указан на картинке, и выбрать соответствующий тип алгоритма генерации пароля (по счетчику/по времени).
Код | Указывается первое значение пароля, которое отобразится в мобильном приложении.
Следующий код | Указывается следующее значение пароля, которое повторно необходимо сгенерировать в мобильном приложении. Поле доступно только в случае выбора алгоритма генерации пароля по счетчику.
Отключить Ссылка, позволяющая выключить для пользователя механизм двухэтапной авторизации на указанный период времени.

Доступно только при включенном механизме двухэтапной авторизации.
Резервные коды Ссылка, позволяющая перейти к форме резервные коды.

Доступно только при включенном механизме двухэтапной авторизации.
Синхронизировать Ссылка, позволяющая произвести синхронизацию приложения или аппаратного устройства, в случае, если код с брелка был введен не правильно несколько раз или же время мобильного приложения не совпадает со временем на сайте.
Доступно только при включенном механизме двухэтапной авторизации.

Для синхронизации устройства/приложения необходимо ввести Первое значение пароля на устройстве и Следующее значение пароля на устройстве в соответствующие поля.

Заметки

Поле | Описание
Заметки администратора | Произвольный комментарий администратора.

Дополнительные свойства

На данной закладке отображаются созданные в системе дополнительные пользовательские свойства. К созданию нового пользовательского свойства можно перейти по ссылке Добавить пользовательское свойство.


Группы пользователей

Управление группами пользователей осуществляется на странице Группы пользователей (Настройки > Пользователи > Группы пользователей), которая предназначена для:

  • просмотра групп пользователей;
  • редактирования групп пользователей;
  • создания и удаления групп пользователей.

Фильтр

Форма фильтра используется для выбора из списка групп пользователей в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Найти | Позволяет найти группы пользователей по их основным параметрам: названию или идентификатору. Поле присутствует, даже если фильтр свернут.
ID | Идентификатор группы пользователей. Соответствует полю ID списка групп.
Изменен | Позволяет отобрать группы пользователей, параметры которых были изменены в течение интересующего вас периода.
Активность | Определяется, какие группы пользователей будут отображаться в результатах поиска: активные, неактивные или все (активные и неактивные).
Название | Название отбираемых групп пользователей.
Описание | Позволяет осуществить отбор групп пользователей по их описанию.
Пользователей | Служит для отбора групп пользователей по количеству пользователей, относящимся к данным группам. Задается в виде числового диапазона.

Для того чтобы отобрать группы пользователей по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех групп нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить группу | Переход к форме создания новой группы пользователей.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список групп пользователей

Поле | Описание
Колонка флажков | Поле предназначено для выбора групп пользователей, к которым предполагается применить какое-либо правило или действие.
Действие Действия над группой пользователей:
  • Изменить - переход к форме редактирования параметров группы пользователей;
  • Добавить копию - создание копии группы пользователей;
  • Удалить - удаление группы пользователей.
Примечание: удаление групп Администраторы и Все пользователи (в том числе неавторизованные) невозможно.
ID | Идентификатор группы пользователей.
Дата изменения | Дата и время последней модификации группы.
Активность Признак активности группы. Если группа неактивна, все пользователи в составе группы полностью блокируются. Существуют две группы пользователей, блокировка которых невозможна: Администраторы и Все пользователи (в том числе неавторизованные).
  • Группа Администраторы всегда активна и предназначена для пользователей, осуществляющих администрирование сайта.
  • Группа Все пользователи (в том числе неавторизованные) виртуально содержит всех не авторизовавшихся посетителей сайта.
Сортировка | Относительный "вес" группы пользователей. Определяет порядок вывода групп в списке.
Название | Осмысленное название группы пользователей.
Описание | Описание группы пользователей.
Пользователей | Количество пользователей в группе.


Создание и редактирование группы пользователей

Закладки

Форма создания/редактирования группы пользователей предназначена для настройки параметров существующей или вновь создаваемой группы пользователей.

Контекстная панель

Кнопка | Описание
Список групп | Переход на страницу со списком групп пользователей.
Добавить группу | Переход на страницу с формой создания новой группы пользователей. Кнопка отображается при редактировании существующей группы пользователей.
Копировать группу | Копирование редактируемой группы пользователей. Кнопка отображается при редактировании существующей группы пользователей.. При копировании группы происходит копирование только общей информации по группе и кто туда входит. Чтобы настроить такие же доступы как для оригинальной группы нужно пройтись по модулям, файлам, возможно, инфоблокам и назначить права для новой группы.
Удалить группу | Удаление редактируемой группы пользователей. Кнопка отображается при редактировании существующей группы пользователей.

Форма настройки группы пользователей состоит из закладок, на каждой из которых выполняется определённый набор операций.

Параметры

На закладке выполняется настройка основных параметров группы пользователей.

Поле | Описание
Последнее обновление | Дата и время последнего изменения данной группы. Поле отображается при редактировании существующей группы пользователей.
Пользователей | Количество пользователей в данной группе. Поле отображается при редактировании существующей группы пользователей.
Активна | Признак активности группы. Если группа неактивна, все пользователи, относящиеся к данной группе, блокируются.
Порядок сортировки | Относительный "вес" группы пользователей. Определяет положение группы в списке.
*Наименование | Указывается произвольное и, в то же время, осмысленное имя группы. Например, Подписчики.
Символьный идентификатор | Символьный идентификатор группы. Задается латинскими буквами.
Описание | Произвольное описание группы.
Пользователи в группе
Форма служит для привязки уже зарегистрированных пользователей к текущей группе, а также для определения периода, на который пользователь привязывается к группе.
Поле | Описание
Пользователь | ID, логин и имя пользователя, привязываемого к текущей группе. ID пользователя представлен в виде ссылки для перехода к форме редактирования параметров пользователя.
Период активности (DD.MM.YYYY HH:MI:SS) | Дата и время начала и конца периода, на который осуществляется привязка пользователя к текущей группе. После окончания периода активности пользователь будет автоматически удален из данной группы. Если пользователь привязывается к группе на неограниченный срок, то в этом поле указывается только дата начала периода активности.

* - поля, обязательные для заполнения.

Безопасность

Поля данной закладки служат для настройки политики безопасности для текущей группы пользователей.

Поле | Описание
Предопределённые настройки уровня безопасности Механизм управление уровнем безопасности позволяет защитить сайт от XSS/CSS атак. В данном поле можно выбрать один из предусмотренных в системе уровней безопасности. Необходимые значения параметров безопасности будут автоматически подставлены в соответствующие поля. Доступны следующие предопределённые уровни безопасности:
  • Не переопределять - при выборе данного уровня ко всем группам пользователей будут применены предустановленные параметры безопасности:
    • для администраторов сайта будет применен повышенный уровень безопасности;
    • для остальных групп настройка уровня безопасности должна быть выполнена администратором сайта.
    Для того чтобы выполнить выборочное изменение значений параметров, снимите флаг Не переопределять рядом с нужными полями.
  • Низкий;
  • Обычный;
  • Повышенный.

Для пользователей, принадлежащих к нескольким группам, по каждому из пунктов политики безопасности будет действовать самое строгое правило из настроенных для этих групп.
Время жизни сессии (минут) | Длительность сессии в минутах. Применяется для исключения неправильной настройки времени жизни сессии в файле php.ini на хостинге.
Маска сети для привязки сессии | Включение данной защиты делает бесполезным перехват файла cookies с информацией о сессии. Данный тип защиты является важнейшим при защите от XSS/CSS атак. Опция защищает персональные данные, которые могли бы хранится в сессии пользователя.
Максимальное количество компьютеров, на которых может быть одновременно запомнена авторизация | Количество компьютеров, на которых разрешено одновременное запоминание авторизации пользователя. Для администраторов системы рекомендованное значение поля равно 1.
Маска сети для привязки сохраненной авторизации | Предотвращает возможность использования файла хэша, похищенного с компьютера пользователя, с целью проникновения на сайт. Рекомендуется использовать в сочетании с другими правилами по времени и числу авторизаций.
Срок хранения авторизации, запомненной на компьютере пользователя (минут) | Длительность запоминания авторизации пользователя в минутах.
Срок действия контрольного слова для восстановления пароля (минут) | Правило определяет время хранения контрольного слова для восстановления пароля и позволяет минимизировать риски взлома сайта через механизм восстановления при перехвате писем. Не рекомендуется использовать время более суток, для администраторов - не более нескольких часов.
Минимальная длина пароля | Правило определяет ограничение на минимальную длину пароля. Для пользователей рекомендуется 6 знаков, для администраторов не менее 8.
Пароль должен содержать латинские символы верхнего регистра (A-Z) | Правило определяет возможность использования латинских символов верхнего регистра (A-Z). Настоятельно рекомендуется для администраторов, а также рекомендуется для пользователей. Опция включена по умолчанию для группы Администраторы в коробочной версии Битрикс24.
Пароль должен содержать латинские символы нижнего регистра (a-z) | Правило определяет возможность использования латинских символов нижнего регистра (a-z). Настоятельно рекомендуется для администраторов, а также рекомендуется для пользователей. Опция включена по умолчанию для группы Администраторы в коробочной версии Битрикс24.
Пароль должен содержать цифры (0-9) | Правило определяет присутствие в пароле цифр (0-9). Настоятельно рекомендуется для администраторов, а также рекомендуется для пользователей. Опция включена по умолчанию для группы Администраторы в коробочной версии Битрикс24.
Пароль должен содержать знаки пунктуации (,.<>/?;:'"[]{}\|`~!@#$%^&*()-_+=) Правило определяет возможность использования следующих знаков пунктуации: ,, ., <, >, /, ?, ;, :, ', ", [, ], {, }, \, |, `, ~, !, @, #, $, %, ^, &, *, (, ), -, _, +, = .
Настоятельно рекомендуется для администраторов. Опция включена по умолчанию для группы Администраторы в коробочной версии Битрикс24..
Проверять пароль по базе слабых паролей | Включение функционала проверки пароля по базе слабых паролей.
Требовать смены пароля при несоответствии текущей политике | При установленной опции система будет требовать смены пароля, признанного слабым.
Требовать смены пароля через указанное количество дней Опция для использования OTP. Число дней, по прохождению которых система запросит смену пароля у пользователей группы. Значение "0" - не требовать смены вообще.

Внимание! Может потребоваться адаптировать кастомизированные шаблоны компонента system.auth.changepasswd.

Если администратор пропустил смену пароля и не может зайти в систему, воспользуйтесь этими [image] способами восстановления пароля.

Проверять на совпадение указанное количество последних паролей | Опция для использования OTP. Система будет проверять указанное число паролей на совпадение.
Количество попыток ввода пароля до показа CAPTCHA | Правило определяет количество попыток ввода пароля до показа CAPTCHA. Рекомендуется не более 3. Затрудняет попытки взлома пароля роботами через перебор. При установке значения 0 или галочки Не переопределять (т.е. 0 по умолчанию) CAPTCHA в форме авторизации не выводится, т.е. отключена.
Количество попыток ввода пароля до временной блокировки пользователя | Сколько попыток авторизации может сделать пользователь до того как система временно заблокирует его.
Период блокировки пользователя | Сколько минут длится временная блокировка пользователя, если он превысил число попыток авторизации в поле выше.

Доступ

На закладке выполняется настройка прав группы пользователей на доступ к модулям системы. Данная закладка не отображается для группы пользователей Администраторы.

Поле | Описание
[название модуля] | Модуль системы.
[уровень прав доступа] | Поле для установки прав группы пользователей на доступ к модулю. При выборе уровня доступа по умолчанию, данной группе пользователей присваивается стандартный уровень доступа, устанавливаемый в настройках главного модуля. Изменение доступа по умолчанию в настройках главного модуля приведет к автоматическому изменению прав доступа группы к модулям, для которых выбран уровень доступа по умолчанию.

Смотрите также

  • Группы пользователей (учебный курс "Администратор. Базовый")
  • Пример настроек закладки Безопасность группы пользователей


Уровни доступа

Управление уровнями доступа осуществляется на странице Уровни доступа ( Настройки > Пользователи > Уровни доступа).

На странице представлен список всех имеющихся уровней доступа: системных и созданных вами. Системные уровни доступа доступны только для просмотра, отредактировать и удалить их невозможно.

Фильтр

Форма фильтра используется для выбора из списка уровней доступа в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
ID | Поиск уровня доступа по идентификатору уровня доступа. Поле присутствует, даже если фильтр свернут.
Буква | Поиск уровня доступа по букве уровня доступа.
Модуль | Поле позволяет отобразить уровни доступак модулям Главный модуль, Торговый каталог, Управление структурой, Проактивная защита или Поисковая оптимизация.
Признак системности | Поле позволяет отобразить только системные уровни доступа либо только несистемные (созданные вами), либо все уровни доступа.
Привязка | Позволяет осуществить отбор уровней доступа, привязанных к модулю, либо к папкам и файлам, либо все уровни доступа.

Для того чтобы отобрать уровни доступа по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех уровней нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить уровень доступа | Переход к форме создания нового уровня доступа.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список уровней доступа

Поле | Описание
Колонка флажков | Поле предназначено для выбора уровней доступа, к которым предполагается применить какое-либо правило или действие.
Действие Действия над уровнями:
  • Посмотреть - переход к просмотру параметров уровня доступа. Данный пункт меню отображается только для системных уровней доступа. Просмотр системного уровня осуществляется на странице редактирования уровня.
  • Изменить - переход к форме редактирования уровня доступа. Данный пункт меню отображается только для несистемных уровней доступа.
  • Копировать - создание копии уровня доступа;
  • Удалить - удаление уровня доступа. Данный пункт меню отображается только для несистемных уровней доступа.
ID | Идентификатор уровня доступа.
Название | Название уровня доступа.
Буква | Буква уровня доступа.
Описание | Произвольное описание уровня.
Модуль | Модуль, к которому относится данный уровень доступа: Главный модуль, Торговый каталог, Управление структурой, Проактивная защита или Поисковая оптимизация.
Признак системности | Уровень доступа является системным или созданным пользователем.
Привязка | Указывается к чему привязан уровень: к модулю или файлам и папкам.

Смотрите также

  • Уровни доступа для стандартных групп пользователей (учебный курс "Администратор. Базовый")


Создание и редактирование уровня доступа

Закладки

Форма создания/редактирования уровня доступа предназначена для настройки параметров существующего или вновь создаваемого уровня доступа. Также данная форма используется для просмотра параметров системных уровней доступа.

Контекстная панель

Кнопка | Описание
Список уровней доступа | Переход на страницу со списком уровней доступа.
Добавить | Переход на страницу с формой создания нового уровня доступа. Кнопка отображается при редактировании существующего уровня доступа.
Копировать | Копирование редактируемого уровня доступа. Кнопка отображается при редактировании существующего уровня доступа.
Удалить | Удаление редактируемого уровня доступа. Кнопка отображается при редактировании существующего уровня доступа.

Параметры

На закладке выполняется настройка основных параметров уровня доступа.

Поле | Описание
*Название | Осмысленное название уровня доступа.
*Модуль | Указывается модуль, к которому относится уровень доступа.
Системный | Отметка о том, что уровень является системным или нет. Проставляется автоматически.
Привязка | Выбирается привязка уровня доступа к функционалу модуля. Список привязок различается и зависит от выбранного модуля.
Буква | Буква уровня доступа.
Описание | Произвольное описание уровня.

* - поля, обязательные для заполнения.

Включаемые операции

Закладка служит для настройки операций, которые возможно проводить, имея данный уровень доступа. Список операций меняется в зависимости от выбранного модуля и привязки на вкладке Параметры.

Поле | Описание
[название операции] | Для возможности выполнения операций при этом уровне доступа необходимо, чтобы они были отмечены флагами.


Импорт пользователей

Импортирование пользователей в систему осуществляется на странице Импорт пользователей (Настройки > Пользователи > Импорт пользователей).

В системе "1C-Битрикс: Управление сайтом" в качестве источника данных для импорта пользователей может использоваться:

  • CSV-файл;
  • Active Directory / LDAP.

Смотрите также:

  • Импорт пользователей (учебный курс "Администратор. Базовый")


Поиск. Описание модуля

Модуль Поиск осуществляет индексирование и поиск информации на сайте. Вся текстовая информация, которая попадает на сайт в виде статических HTML страниц или через модули (например, модуль Информационные блоки, модуль Форум и т.д.) автоматически индексируется. Поиск может осуществляться как по всей проиндексированной информации, так и по ее отдельным частям.

При формировании поискового запроса возможно использование языка запросов.

Язык запросов

Обычно запрос представляет из себя просто одно или несколько слов, например:

свежая рыба треска

По такому запросу находится информация, в которой встречаются все слова запроса.

Логические операторы позволяют строить более сложные запросы, например:

свежая рыба или пылесос

По такому запросу находится информация, в которой встречаются либо слова "свежая" и "рыба", либо слово "пылесос".

свежая рыба не скумбрия

По такому запросу находится информация, в которой встречаются слова "свежая" и "рыба" и не встречается слово "скумбрия". Вы можете использовать скобки для построения более сложных запросов.

Логические операторы

Оператор | Синонимы | Описание
И | And, &, + | Оператор логическое "и". Подразумевается, его можно опускать: запрос "свежая рыба" полностью эквивалентен запросу "свежая" и "рыба".
Или | Or, | | Оператор логическое "или" позволяет искать элементы, содержащие хотя бы один из операндов.
Не | Not, ~ | Оператор логическое "не" ограничивает поиск товарами, не содержащими слово, указанное после оператора.
( ) |  | Круглые скобки задают порядок действия логических операторов. При формировании строки запроса убедитесь, что для каждой открывающейся скобки есть парная закрывающаяся.
" " |  | Поиск точной фразы. Обычно используется для поиска цитат.

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Форма поиска | search.form | Служит для вывода формы поиска.
Поиск по заголовкам | search.title | Служит для вывода поля поиска по заголовкам с динамическими результатами.
Стандартная страница поиска | search.page | Служит для создания страницы поиска.
Поле ввода поискового запроса | search.suggest.input | Служит для вывода поля ввода поискового запроса с подсказкой.
Облако тегов | search.tags.cloud | Предназначен для вывода облака тегов.
Форма ввода тегов | search.tags.input | Предназначен для вывода формы ввода тегов.

Смотрите также

  • Управление правилами сортировки
  • Настройка морфологического поиска
  • Логические операторы поиска
  • Полезные советы по поиску
  • Документация для разработчиков по модулю Поиск


Поиск. Настройки модуля

Закладки

Форма настроек модуля Поиск (Настройки > Настройки продукта > Настройки модулей > Поиск) предназначена для задания параметров модуля.

Контекстная панель

Кнопка | Описание
Переиндексация сайта | Переход к форме, позволяющей пересоздать поисковый индекс сайта.
Google sitemap | Переход к форме создания карты сайта для передачи Google.

Индексация

Поле | Описание
Максимальный размер индексируемого документа в килобайтах | Проиндексированы будут только те документы, размер которых не превышает указанное число.
Маска включения | Файлы, которые соответствуют хотя бы одной из масок включения, будут проиндексированы поиском. Файлы, имена которых не соответствуют ни одной из указанных масок, поиском не индексируются. В качестве разделителя используется ";".
Маска исключения | Файлы, которые соответствуют хотя бы одной из масок исключения, не будут проиндексированы поиском. В качестве разделителя используется ";".
Код свойства страницы в котором хранятся теги | Указывается код свойства страницы, в котором хранятся теги.

Морфология

Поле | Описание
Использовать морфологию По умолчанию опция отмечена, то есть функция морфологического поиска активна.

Если эта опция активна, то при создании индекса (и, соответственно, при поиске) будут учтены все формы индексируемых слов. Например, при индексации слова телефон, база данных индекса будет учитывать различие в падежных окончаниях (телефона, телефону и т.д.), а также его множественное число (телефоны, телефонов, телефонам и т.д.). Соответственно, при поиске по запросу телефон будут найдены страницы, содержащие не только слово телефон, но и слова телефона, телефону, телефоны, телефонов, телефонам и т.д.
Морфологический поиск поддерживает работу со всеми языками, установленными в системе.
Отложить выполнение морфологического анализа (на агента) | При отмеченной опции морфологический анализ будет выполняться на агенте.
Максимальная длительность выполнения агента (секунд) | Указывается максимальное время выполнения агента.
Полнотекстовый поиск с помощью Указывается с помощью какой поисковой системы должен осуществляться поиск: Bitrix, Sphinx или Полнотекстовый поиск MySql.

Если выбрана система Sphinx, то необходимо настроить следующие параметры:
  • Строка подключения для управления индексом (протокол MySql) - задается адрес подключения к серверу Sphinx;
  • Идентификатор индекса - указывается название индекса для системы Sphinx.
Символы, по которым не производится разделение документа на слова (при морфологическом анализе) Символы, которые морфологический анализатор должен рассматривать как части слов. Указывать их следует друг за другом без каких-либо дополнительных знаков между ними: +#/-".

Алгоритм морфологического анализа разбивает предложения на слова, используя стандартные символы-разделители (пробел, точка, запятая и т.п.). В то же время, существуют символы, которые, не будучи буквами, все же являются частями слов (например, дефис в слове: ликеро-водочный).

Поиск

Поле | Описание
Максимальное количество документов в результатах поиска | Указывается максимальное количество документов для показа из всего результата поиска.
Использовать быстрый поиск (с ухудшенным ранжированием) | При отмеченной опции будет использоваться быстрый поиск (с ухудшенным ранжированием), при этом работа поиска ускоряется, но понижается качество поиска.
При ранжировании результатов учитывать расстояние между словами | При отмеченной опции будет включена поддержка учета расстояния между словами в поисковом индексе. Чем ближе друг к другу в тексте расположены искомые слова, тем выше будет материал в выдаче. Для включения этой настройки требуется переустановка модуля без сохранения таблиц с последующей полной переиндексацией.
При ранжировании результатов учитывать рейтинг | При отмеченной опции ранжирование результатов поиска будет происходить с учетом рейтинга контента. Для включения этой настройки требуется переустановка модуля без сохранения таблиц с последующей полной переиндексацией.
Сколько дней хранить поисковые запросы для подсказки | Указывается количество дней для хранения поисковых запросов, которые будут выводиться в подсказке.

Статистика

Поле | Описание
Собирать статистику по поисковым фразам | При отмеченной опции будет происходить сбор статистики по введенным поисковым фразам.
Сколько дней хранить статистику по поисковым фразам | Указывается количество дней, в течении которых будет храниться статистика по поисковым фразам.


Переиндексация

Перегенерация поискового индекса может потребоваться в самых различных ситуациях, например, после импорта товаров в каталог или после загрузки файлов по FTP. Пока индекс поиска не создан заново после подобных операций, новые страницы не будут выводиться в результатах поиска.

Форма Переиндексация (Настройки > Поиск > Переиндексация) позволяет пересоздать поисковый индекс, задав требуемые параметры и ограничения.

Закладка "Переиндексация"

Закладка предназначена для ручной переиндексации сайта.

Поле | Описание
Переиндексировать только измененные Если эта опция включена, при создании индекса будет обновляться/добавляться информация о модифицированных/созданных с момента последней индексации документах и страницах.
Если вы хотите переиндексировать сайт полностью, отключите эту опцию.
Шаг | Интервал между шагами индексации, в секундах. Если поле оставлено пустым или указано значение 0, то индексация будет совершена за один шаг. Такие значения, как правило, не используются, так как современные сайты имеют большие объёмы контента. Конкретное значение подбирается экспериментально, начинать советуем с шага в 5-10. Для большинства сайтов шаг 20 будет оптимальным.
Сайт | Сайт, документы которого требуется переиндексировать.
Модуль Список позволяет выбрать, какую информацию следует переиндексировать:
  • все;
  • Статические файлы;
  • [blog] Блоги;
  • [forum] Форум;
  • [iblock] Информационные блоки;
  • [intranet] Интранет;
  • [learning] Обучение;
  • [socialnetwork] Социальная сеть.

Примечание: Переиндексацию Социальной сети необходимо производить только из публичной части сайта с помощью соответствующей кнопки на панели инструментов (см. ниже). Опция [socialnetwork] Социальная сеть в данном случае не даст нужного эффекта.
Удалить поисковые фразы для подсказки | При отмеченной опции будут удалены все фразы, отображающиеся в виде интерактивных подсказок при поиске.

Для того чтобы начать переиндексацию, нажмите кнопку Переиндексировать. Для остановки переиндексации - кнопку Остановить, а для продолжения Продолжить.

Внимание! После выполнения переиндексации модуль Социальная сеть должен быть переиндексирован отдельно из публичного раздела.

Для этого:

  • Перейдите в разделы социальной сети (где установлены компоненты socialnetwork, socialnetwork_group, socialnetwork_user).
  • Нажмите кнопку Индексация на панели управления:

Смотрите также:

  • Индексация (учебный курс "Администратор. Базовый")


Google Sitemap

Google Sitemap - это простой инструмент управления доставкой информации о страницах сайта в базу данных Google, самой мощной и популярной поисковой системы. Применение Google Sitemap особенно важно для динамических сайтов, страницы которых генерируются автоматически, поскольку это гарантирует наличие информации о всех страницах сайта в базе данных Google. Файлы Google Sitemap по сути своей являются XML-файлами, однако создание их вручную крайне трудоемко и требует много времени. При помощи формы Создание Google Sitemap можно быстро создать карту сайта для передачи ее Google.

Форма cоздания Google Sitemap доступна на странице Создание Google Sitemap (Настройки > Поиск > Google Sitemap).

Закладка "Google Sitemap"

Поле | Описание
Сайт | Сайт, для которого требуется создать sitemap.
Шаг | Продолжительность каждого шага создания sitemap, указанная в секундах.
Максимальное количество документов для обработки на одном шаге | Укажите максимальное количество документов, которое будет обрабатываться на одном шаге.
Включать в Google Sitemap только темы форумов, но не сообщения | При отмеченной опции при создании в карту будут писаться только первые сообщения темы форума с датой модификации, равной последнему добавленному в тему сообщению.
Не включать в Google Sitemap комментарии к сообщениям блогов | Если опция отмечена, то при создании карты не будут включаться комментарии к сообщениям блога.
Использовать HTTPS | При отмеченной опции будет использоваться протокол HTTPS.

Для того чтобы начать генерацию карты сайта, нажмите кнопку Создать. Для остановки генерации служит кнопка Остановить, а для продолжения - Продолжить.

Внимание! При создании файлов Google Sitemap все файлы вида sitemap_*.xml, расположенные в корневой папке выбранного сайта, будут перезаписаны.

После создания карты сайта будет отображена страница, содержащая адрес sitemap для передачи Google, а также краткие инструкции.

Смотрите также:

  • Google Sitemap (учебный курс "Администратор. Базовый")


Правила сортировки результатов поиска

О правилах сортировки результатов поиска

После ввода пользователем строки поискового запроса и нажатия кнопки Поиск, система отбирает из поискового индекса страницы, соответствующие запросу. Перед отображением пользователю результаты поиска сортируются либо по релевантности (что обычно характеризуется плотностью ключевых слов на странице), либо по дате изменения (последнего обновления) страницы. Пользователь может выбрать режим сортировки на странице результатов поиска, нажав на одну из двух ссылок в конце списка найденных документов: Сортировать по релевантности или Сортировать по дате.

Вместе с тем очень часто требуется при выводе результатов поиска отдать предпочтение документам той или иной тематики. Например, может потребоваться "поднять" в результатах поиска товары, которые требуют скорейшего сбыта. Для достижения подобных целей служит специальный механизм, при помощи которого можно задать требуемый вес (ранг, page, rank) желаемым страницам. При отображении результатов поиска, страницы, соответствующие заданным правилам сортировки, будут отображены в самом начале списка, в соответствии с весами, указанными в правилах.

Фиксированный вес может быть присвоен:

  • статическим файлам (требует указания полного пути к таким файлам);
  • информационным блокам (дополнительно могут быть указаны: тип информационных блоков, информационный блок и элемент, которым следует отдать предпочтение);
  • форумам (могут быть указаны: форум, тема выбранного форума и сообщение).

Форма Список правил сортировки отображает все существующие правила сортировки, позволяет добавить новые правила, а также пересоздать существующий поисковый индекс. Перегенерация индекса требуется, если вы добавили, удалили или изменили какое-либо правило сортировки. Таким образом, назначение или изменение правил сортировки делится на два этапа:

  • первый этап: управление правилами сортировки - создание, правка или удаление правил;
  • второй этап: обновление поискового индекса для вступления новых правил в силу.

Фильтр

Фильтр используется для задания параметров отбора правил сортировки, отображаемых в списке. Нижеследующая таблица описывает поля фильтра.

Поле | Описание
Найти | Позволяет найти правила по их основным параметрам: идентификатору или сайту. Поле присутствует, даже если фильтр свернут.
ID | Системный идентификатор правила. Это поле обычно представляет интерес для разработчиков.
Сайт | Сайт, на котором действует искомое правило.
Модуль | Модуль, к элементам которого применимо искомое правило.
Параметр 1 | Параметр искомого правила. В зависимости от выбранного модуля, параметр может определять имя файла, тип информационного блока, форум и т.д.

Для того чтобы отобразить только требуемые правила, нажмите кнопку Найти. Для отображения всех сообщений нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания нового правила сортировки.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данныx из отображаемой таблицы в MS Excel.

Нажатием кнопки Сохранить можно применить изменения в полях Вес правил.

Список правил

Поле | Описание
Колонка флажков | Поле предназначено для выбора правил, к которым предполагается применить какое-либо правило или действие.
Меню
действий 		При нажатии на кнопку действий конкретного правила, отображается меню, позволяющее Изменить или Удалить правило.
ID | Системный идентификатор правила.
Сайт | Сайт, на котором действует данное правило.
Модуль | Модуль, к элементам которого применимо данное правило.
Параметр 1 Первый параметр правила. В зависимости от выбранного модуля, параметр может определять:
  • для Cтатических файлов - не используется;
  • для модуля Информационные блоки - тип информационного блока;
  • для модуля Блоги - не используется;
  • для модуля Форум - форум;
  • для модуля Социальная сеть - не используется.
Параметр 2 Второй параметр правила. Может определять:
  • для Статических файлов - не используется;
  • для модуля Информационные блоки - информационный блок;
  • для модуля Блоги - не используется;
  • для модуля Форум - тему форума;
  • для модуля Социальная сеть - не используется.
Параметр 3 Третий параметр правила. Может определять:
  • для Статических файлов - полный путь к файлу;
  • для модуля Информационные блоки - элемент информационного блока;
  • для модуля Блоги - блог, комментарий блога, сообщение блога, пользователь блога;
  • для модуля Форум - текст в сообщении темы форума;
  • для модуля Социальная сеть - группу соцсети, тему группы соцсети, тип инфоблока и инфоблок, для которых определен функционал соцсети (форумы, блоги, галереи групп и пользователей).
Вес | Вес (ранг) правила. Документы, соответствующие критериям правила, будут расположены в списке результатов поиска с соответствии с рангом сортировки. Чем больше значение веса, тем выше в списке будет отображен документ.

Обновление поискового индекса

Этот раздел формы содержит только кнопку Обновить. Обновление индекса поиска требуется, чтобы изменения (создание, правка или удаление правила сортировки) вступили в силу. Для обновления индекса, нажмите эту кнопку. Процесс обновления можно остановить с помощью кнопки Остановить, с помощью кнопки Продолжить его можно возобновить.

Смотрите также

  • Правила сортировки (учебный курс "Администратор. Базовый")


Создание и редактирование правила сортировки результатов поиска

Форма предназначена для создания нового или изменения существующего правила сортировки результатов поиска.

Примечание: применение правила предполагает изучение системой поиска строки запроса; нахождение документов, соответствующих запросу; поиск правил, соответствующих найденным документам; в случае нахождения подходящих правил - ранжирование результатов поиска в соответствии с весами сортировки, указанных в правилах.

Например, пользователь желает найти документы, соответствующие запросу "телефоны nokia", и существует правило:

"модуль Информационные блоки :: тип блока Каталог :: блок Телефоны Nokia :: сорт. 100"

После поиска система предпримет попытку найти подходящее запросу правило и обнаружит, что некоторые результаты поиска включают в себя элементы информационного блока Телефоны Nokia. Таким образом, к результатам поиска будет применено вышеуказанное правило, что повлечет за собой назначение веса сортировки 100 результатам из элементов информационного блока Телефоны Nokia.

Контекстная панель

Ссылка | Описание
Список | Переход на страницу со списком правил сортировки.
Добавить | Переход на страницу создания нового правила. Кнопка отображается при редактировании существующего правила.
Удалить | Удаление текущего правила. Кнопка отображается при редактировании существующего правила.

Закладка Правило

Поле | Описание
Сайт | Указывается сайт, в пределах которого должно действовать данное правило. Правило не будет применяться к результатам поиска на других сайтах.
Модуль Указывается модуль, к элементам которого применимо данное правило. Система позволяет определять правила, которые будут применены:
  • для Cтатических файлов - область действия правила ограничивается обязательно указываемым в поле Параметр 3 полным путём к требуемому файлу;
  • для модуля Информационные блоки - область действия правила может быть ограничена: определённым типом инфоблоков, определённым информационным блоком, а также элементом блока. Можно создать правило без ограничений по типам или элементам информационных блоков. В таком случае правило сортировки будет распространятся на все типы и элементы всех информационных блоков.
  • для модуля Блоги - область действия правила может быть ограничена: определённым блогом, комментарием блога, сообщением блога или пользователем блога.
  • для модуля Форум - область действия правила может быть ограничена: форумом, определённой темой форума, а также сообщением. Правило сортировки будет распространятся на все сообщения всех форумов, если не указаны ни один из трех параметров правила (форум, тема, сообщение).
  • для модуля Социальная сеть - область действия правила может быть ограничена: группой соцсети, темой группы соцсети, типом инфоблока и инфоблоком, для которых определен функционал соцсети (форумы, блоги, галереи групп и пользователей).
Параметр 1 Первый параметр правила. В зависимости от выбранного модуля, параметр может определять:
  • для Cтатических файлов - не используется;
  • для модуля Информационные блоки - тип информационного блока;
  • для модуля Блоги - не используется;
  • для модуля Форум - форум;
  • для модуля Социальная сеть - не используется.
Параметр 2 Второй параметр правила. Может определять:
  • для Статических файлов - не используется;
  • для модуля Информационные блоки - информационный блок;
  • для модуля Блоги - не используется;
  • для модуля Форум - тему форума;
  • для модуля Социальная сеть - не используется.
Параметр 3 Третий параметр правила. Может определять:
  • для Статических файлов - полный путь к файлу;
  • для модуля Информационные блоки - элемент информационного блока;
  • для модуля Блоги - блог, комментарий блога, сообщение блога, пользователь блога;
  • для модуля Форум - текст в сообщении темы форума;
  • для модуля Социальная сеть - группу соцсети, тему группы соцсети, тип инфоблока и инфоблок, для которых определен функционал соцсети (форумы, блоги, галереи групп и пользователей).
Вес | Указывается вес (ранг) правила. Документы, соответствующие критериям правила, будут расположены в списке результатов поиска с соответствии с рангом сортировки. Чем больше значение веса, тем выше в списке будет отображен документ.

Смотрите также

  • Правила сортировки (учебный курс "Администратор. Базовый")


Отправить отзыв по этому разделу

Статистика

  • Список переходов
  • Список фраз
  • Список тегов


Список переходов

Страница Список переходов (Настройки > Поиск > Статистика > Список переходов) предназначена для отображения статистики переходов по поисковым фразам, которые были использованы при поиске по сайту.

Фильтр

Фильтр используется для задания параметров отбора списка переходов. Следующая таблица описывает поля фильтра.

Поле | Описание
Поисковая фраза | Поисковые фразы, по которым были совершены переходы. Поле присутствует, даже если фильтр свернут.
Теги | Теги, по которым были совершены переходы.
ID | Идентификатор записи в базе данных, содержащей информацию о переходе по поисковой фразе.
Дата (DD.MM.YYYY) | Дата совершения перехода.
Сайт | Сайт, на который пришли с поисковой фразой.
Куда пришли | Страница, на которую пришли с поисковой фразой. В выпадающем списке (ошибка 404) можно указать, отображать ли только запросы несуществующих страниц.
ID сессии | Идентификатор сессии пользователя, совершившего переход.

Чтобы отфильтровать переходы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех переходов по поисковым фразам нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список переходов

Колонка | Описание
ID | Идентификатор поисковой фразы.
Сайт | Сайт, на котором производился переход при поиске.
Поисковая фраза | Фраза, по которой производился переход при поиске.
Теги | Теги, по которым производился переход при поиске.
Время | Время занесения записи в базу данных о произведении перехода.
Куда пришли | Адрес страницы, на которую перешел пользователь со страницы поиска. Ссылка с адресом позволяет перейти к просмотру страницы.
Найдено документов | Количество документов, найденных при поиске по фразе.
Глубина просмотра Результат поиска:
  • 0 - поиск по фразе был безуспешный;
  • 1 - поиск по фразе был успешный.
ID сессии | Идентификатор сессии пользователя, совершившего переход. Ссылка с идентификатором сессии позволяет перейти к списку сессий.

Смотрите также

  • Как просмотреть статистику по поиску


Список фраз

На странице Список фраз (Настройки > Поиск > Статистика > Список фраз) можно просмотреть список фраз, введенных посетителями при поиске на сайте.

Фильтр

Форма фильтра используется для фильтрации поисковых фраз пользователей в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым могут выбираться записи.

Поле | Описание
Поисковая фраза | Поисковые фразы, по которым были совершены переходы. Это поле присутствует, даже если фильтр свернут.
ID | Идентификатор записи в базе данных, содержащей информацию о переходе по поисковой фразе.
Дата (DD.MM.YYYY) | Дата занесения в базу поисковой фразы.
Сайт | Сайт, на который пришли с поисковой фразы.
Куда пришли | Cтраница, на которую пришли с поисковой фразой. В выпадающем списке (ошибка 404) можно указать, отображать ли только запросы несуществующих страниц.
ID сессии | Идентификатор сессии пользователя, совершившего переход.

Чтобы отфильтровать поисковые фразы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех поисковых фраз нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список поисковых фраз

Поле | Описание
Поисковая фраза | Поисковые фразы, по которым были совершены переходы.
Количество | Количество поисковых фраз, по которым были совершены переходы.


Список тегов

На странице Список тегов (Настройки > Поиск > Статистика > Список тегов) можно просмотреть список тегов, использованных посетителями при поиске на сайте.

Фильтр

Форма фильтра используется для фильтрации поисковых тегов в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым могут выбираться записи.

Поле | Описание
Теги | Теги, по которым были совершены переходы. Это поле присутствует, даже если фильтр свернут.
ID | Идентификатор записи в базе данных, содержащей информацию о переходе по тегу.
Дата (DD.MM.YYYY) | Дата перехода по тегам.
Сайт | Сайт, на который пришли по тегу.
Куда пришли | Страница, на которую пришли по тегу. В выпадающем списке (ошибка 404) можно указать, отображать ли только запросы несуществующих страниц.
ID сессии | Идентификатор сессии пользователя, совершившего переход.

Чтобы отфильтровать теги по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех тегов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список тегов

Поле | Описание
Теги | Теги, по которым были совершены переходы.
Количество | Количество тегов, по которым были совершены переходы.

Смотрите также

  • Статистика (учебный курс "Администратор. Базовый")


Проактивная защита. Описание модуля

Одной из первостепенных задач для владельцев веб-проектов является качественная и надежная защита от хакерских атак, взлома и кражи хранящейся на сайте информации.

Для этого в системе "1С-Битрикс: Управление сайтом" предусмотрен модуль Проактивная защита, с помощью которого реализуется целый комплекс защитных мероприятий для сайта и сторонних приложений. Уровень защиты, обеспечиваемый стандартной сборкой дистрибутива "1С-Битрикс: Управление сайтом", достаточно высок. Но во время реализации проектов на основе "1С-Битрикс: Управление сайтом" выполняется кастомизация компонентов, дописываются собственные инструменты, безопасность которых не всегда проверяется.

Модуль Проактивная защита является важным дополнением к стандартной политике безопасности продукта и существенно повышает уровень защиты веб-проекта.

Смотрите также:

  • Проактивная защита [image] (учебный курс "Администратор. Базовый").
  • Хранение сессий и смена идентификатора
  • Контроль целостности


Проактивная защита. Настройки модуля

Закладки

Форма настроек модуля Проактивная защита (Настройки > Настройки продукта > Настройки модулей > Проактивная защита) предназначена для задания общесистемных параметров модуля.

Настройки

Поле | Описание
Разрешать блокировать себя по IP (с показом предупреждения) | При отмеченной опции будет разрешено блокировать самого себя по IP адресу, при этом будет показано предупреждение.
Путь к файлу-флажку запрета блокировки по IP | Указывается путь к файлу-флажку, с помощью которого можно снять ограничение по IP-адресам. По умолчанию файл имеет имя следующего формата: ipcheck_disable_<случайный_набор_из_32_символов>.
Настройки журналирования
Секция позволяет указать, как и куда будет сохраняться информация о событиях, запись которых можно включить на административных страницах модуля (Настройки > Проактивная защита).
Формат сообщения Указывается формат записи данных о событии.

Доступные поля сообщения:
  • #AUDIT_TYPE# - Имя аудитора безопасности;
  • #SITE_ID# - ID текущего сайта;
  • #USER_INFO# - Информация о пользователе;
  • #URL# - Запрашиваемый url;
  • #VARIABLE_NAME# - Имя переменной, содержащей опасные данные;
  • #VARIABLE_VALUE# - Опасные данные;
  • #VARIABLE_VALUE_BASE64# - Опасные данные (base64-кодированные).
Формат информации о пользователе Указывается формат записи данных о пользователе, связанным с событием.

Доступные поля сообщения:
  • #REMOTE_ADDR# - IP-адрес;
  • #USER_AGENT# - User-Agent;
  • #USER_ID# - ID пользователя.
Заносить записи в журнал событий | При отмеченной опции информация о событиях будет заноситься в журнал событий.
Заносить записи в Syslog | При отмеченной опции информация о событиях будет заноситься в системный журнал: Syslog или же штатный журнал событий ОС Windows.
Тип журналирования (facility) | Задается тип журналирования (facility) [image] для записей о событиях.
Уровень оповещения | Задается уровень оповещения (priority) [image] для записей о событиях.
Заносить записи в файл | При отмеченной опции информация о событиях будут заноситься в файл.
Абсолютный путь к файлу | Задается абсолютный путь к файлу, в который будет производиться запись информации о событиях.

Доступ

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Проактивная защита:
  • [D] Доступ закрыт - запрет на доступ;
  • [F] Обход проактивного фильтра - для указанной группы пользователей будет осуществляться обход проактивного фильтра;
  • [S] Управление одноразовыми паролями - разрешается управлять одноразовыми паролями;
  • [T] Просмотр всех данных - разрешается только просмотр всех данных модуля;
  • [W] Полный административный доступ - полный доступ к ресурсам модуля.
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.


Сканер безопасности

Сканер безопасности - это инструмент, который позволяет выявить потенциальные ошибки и упущения, связанные с безопасностью сайта.

Примечание: Для того чтобы сканер имел возможность проводить статический анализ уязвимостей необходимо, чтобы в системе было установлено и включено PHP расширение tokenizer [image].

После нажатия кнопки Запустить сканирование система произведет поиск угроз безопасности и выдаст рекомендации по их устранению.

Смотрите также:

  • Сканер безопасности (учебный курс "Администратор. Базовый")


Панель безопасности

Уровни безопасности

Информация о текущем уровне безопасности представлена на странице Панель безопасности (Настройки > Проактивная защита > Панель безопасности). Для каждого уровня приведена соответствующая таблица параметров и их значений, а также указаны, в случае необходимости, рекомендации по изменению значений параметров.

Для всех уровней безопасности рекомендуется значение параметра Уровень безопасности группы администраторов выставлять повышенный.

Стандартный

Чтобы защита осуществлялась на стандартном уровне безопасности, необходимо настроить должным образом все параметры данного уровня.
Параметр | Значение
Проактивный фильтр (Web Application Firewall) | Включен
Исключения из проактивного фильтра | Нет
Журнал вторжений за последние 7 дней | 0
Контроль активности | Включен
Использовать CAPTCHA при регистрации | Да
Режим вывода ошибок (error_reporting) | Только ошибки или Не выводить
Показ ошибочных запросов базы данных | Выключен

Примечание: если стандартный уровень не настроен полностью, то защита сайта будет осуществляться на начальном уровне, но с учетом настроенных параметров на стандартном, высоком и повышенном уровнях.

Высокий

Чтобы защита осуществлялась на высоком уровне безопасности, сначала необходимо настроить стандартный уровень безопасности, а затем выполнить настройку параметров для высокого уровня.
Параметр | Значение
Журналирование событий главного модуля | Не все включены
Ограничение отображения страниц во фрейме | Включен
Защита административной части | Включена
Хранение сессий в базе данных | Включено
Смена идентификатора сессий | Включена
Защита редиректов от фишинга | Включена

Примечание: если некоторые параметры высокого уровня безопасности принимают несоответствующие значения, то защита сайта будет осуществляться на стандартном или начальном (если настроены не все параметры стандартного уровня) уровне, но с учетом настроенных параметров на стандартном, высоком и повышенном уровнях.

Повышенный

Чтобы защита осуществлялась на повышенном уровне безопасности, сначала необходимо настроить защиту на стандартном и высоком уровне, а затем выполнить настройку параметров повышенного уровня.
Параметр | Значение
Одноразовые пароли | Включены
Контроль целостности | Выполнен
Веб-антивирус | Включен
Действия при обнаружении вируса | Только оповещение
Исключения веб-антивируса | Нет
Журнал заражений за последние 7 дней | 0

Примечание: если хотя бы один параметр повышенного уровня безопасности принимает несоответствующее значение, то защита сайта будет осуществляться на том уровне, который настроен полностью, но при этом будут учтены настройки параметров всех уровней.


Проактивный фильтр

Закладки

Проактивный фильтр (Web Application Firewall) – это набор специализированных средств, которые выполняют фильтрацию трафика. Фильтр обеспечивает защиту от большинства известных атак на веб-приложения. В потоке внешних запросов пользователей проактивный фильтр распознает большинство опасных угроз и блокирует вторжения на сайт.

Проактивный фильтр

Включение или отключение проактивного фильтра выполняется на странице Проактивный фильтр (Настройки > Проактивная защита > Проактивный фильтр) с помощью кнопки Включить проактивную защиту (Отключить проактивную защиту).

Активная реакция

Форма позволяет настроить действия системы при попытке вторжения на сайт.

Поле | Описание
Активная реакция на вторжение Задается способ реакции системы на вторжение:
  • Сделать данные безопасными - опасные данные будут модифицированы, например, select будет заменен на sel ect, а <script> на <sc ript>;
  • Очистить опасные данные - опасные данные будут удалены;
  • Оставить опасные данные как есть - с опасными данными никаких действий выполняться не будет.
Добавить IP-адрес атакующего в стоп-лист При отмеченной опции пользователь будет заблокирован на некоторое количество минут.

Примечание: при такой настройке становится возможной атака, когда действия злоумышленника могут привести к блокировке посетителей сайта.
На сколько минут добавлять в стоп-лист | Период времени, на который будет заблокирован пользователь.
Занести попытку вторжения в журнал | При отмеченной опции попытка вторжения будет занесена в журнал событий.

Исключения

Форма позволяет настроить исключения из проактивного фильтра, т.е. проактивный фильтр не будет применяться на страницах, указанных на данной закладке.

Поле | Описание
Маски исключения (например: /bitrix/* или */news/*) | Указываются маски исключения для страниц и разделов выбранного сайта или для всех сайтов сразу.

Кнопки управления

Кнопка | Описание
Сохранить | Сохранение параметров.
Применить | Сохранение параметров. Продолжение редактирования.
Отменить | Отмена внесённых изменений. Возврат первоначальных значений параметров.

Смотрите также

  • Стандартный уровень защиты (учебный курс "Администратор. Модули")


Веб-антивирус

Закладки

Веб-антивирус - система противодействия заражениям сайтов. Веб-антивирус выявляет в html-коде потенциально опасные участки и "вырезает" подозрительные объекты из кода сайта, препятствуя проникновению вирусов на компьютер пользователя.

Примечание: веб-антивирус не является заменой обычного антивируса.

Веб-антивирус

Включение или отключение веб-антивируса выполняется на странице Веб-антивирус (Настройки > Проактивная защита > Веб-антивирус) с помощью кнопки Включить веб-антивирус (Выключить веб-антивирус).

Примечание: Для детектирования вирусов, внедренных до старта буферизации вывода, задайте параметр.

  • в php.ini:

    auto_prepend_file = <путь_до_папки_с_сайтом>/bitrix/modules/security/tools/start.php
  • или в файле .htaccess:
    php_value auto_prepend_file "<путь_до_папки_с_сайтом>/bitrix/modules/security/tools/start.php"

По умолчанию, для установки продукта с использованием пакета Битрикс: Веб-окружение <путь_до_папки_с_сайтом> = C:/Program Files/Bitrix Environment/www/

Параметры

Форма позволяет настроить параметры оповещения о заражении вирусом.

Поле | Описание
Действия при обнаружении вируса Указывается действие, которое будет выполняться при обнаружение вируса:
  • Вырезать из кода сайта - опасные данные будут вырезаны из кода сайта;
  • Только занести в журнал и оповестить администратора - запись об обнаружении вируса будет занесена в журнал событий, администратору будет послано оповещение по e-mail.
Интервал оповещения (минуты) | Задается интервал оповещения администратора сайта в минутах.

Исключения

Форма позволяет настроить исключения для веб-антивируса, т.е. веб-антивирус не будет применяться к блокам html, указанным на данной закладке.

Поле | Описание
Исключения | Указываются подстройки некоторых блоков html-кода, которые не будут распознаваться антивирусом как опасные данные.

Смотрите также

  • Повышенный уровень защиты (учебный курс "Администратор. Базовый")


Журнал вторжений

Журнал вторжений (Настройки > Проактивная защита > Журнал вторжений) предназначен для ведения логов событий, связанных с потенциальными угрозами для безопасности сайта. Период времени, в течение которого хранятся записи, определяется настройками Главного модуля.

Журнал вторжений - это, фактически, штатная настройка для Журнала событий. Срок хранения данных в Журнале определяется настройками Главного модуля.

Фильтр

Форма фильтра используется для выбора из списка вторжений в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым могут выбираться события.
Поле | Описание
Найти | Позволяет найти вторжения по их основным параметрам: названию или идентификатору. Это поле присутствует, даже если фильтр свернут.
ID | Идентификатор вторжения. Соответствует полю ID списка вторжений.
Время | Позволяет указать период (начало и окончание) времени для отбора событий.
Срочность | Определяется, события какой срочности будут участвовать в поиске: SECURITY или WARNING.
Событие* | Позволяет выполнить отбор событий по названию.
Источник* | Позволяет выполнить отбор событий по источнику.
Объект* | Позволяет выполнить отбор событий по объекту.
Сайт | Указывается сайт, для которого будет отображен список событий.
Пользователь | Задается имя пользователя, если событие было выполнено зарегистрированным пользователем, или идентификатор гостя для поиска событий (при наличии модуля Веб-аналитика).
Гость | Задается идентификатор гостя для отбора событий (при наличии модуля Веб-аналитика).
IP* | Служит для отбора событий по IP адресу.
User Agent* | Служит для отбора событий по User Agent.
URL* | Служит для отбора событий по адресу страницы.

* - для данных полей Вы можете воспользоваться [ds]специальными логическими выражениями[/ds][di]Облегчайте поиск информации вместе с логическими операторами. Система допускает использование пяти видов логических операторов. Давайте их рассмотрим.

Подробнее ... в курсе Администратор.Базовый.[/di].

Для того чтобы отобрать события по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех событий нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Журнал событий

Поле | Описание
ID | Идентификатор вторжения.
Время | Дата и время события.
Событие | Название произошедшего события.
Объект | Объект события.
IP | IP-адрес, с которого производилась атака. По ссылке стоп-лист можно добавить адрес в стоп-лист модуля Веб-аналитика.
URL | Адрес страницы, на которой выполнялось вторжение.
Пользователь | Имя пользователя, если событие было выполнено зарегистрированным пользователем, или идентификатор гостя (при наличии модуля Веб-аналитика).
Описание | Описание события.
Срочность | Срочность события (SECURITY или WARNING).
Источник | Источник события.
User Agent | Используемый User Agent.
Сайт | Сайт, на котором произошло событие.
Гость | Идентификатор гостя (при наличии модуля Веб-аналитика).


Двухэтапная авторизация

Закладки

Система одноразовых паролей [image] [image] дополняет стандартную систему авторизации и позволяет значительно усилить систему безопасности интернет-проекта. Для включения системы необходимо использовать аппаратное устройство (например, Aladdin eToken PASS [image]) или использовать соответствующее программное обеспечение [image]. Система одноразовых паролей рекомендуется к использованию администраторам сайтов для повышения уровня безопасности.

Двухэтапная авторизация

Включение или отключение механизма двухэтапной авторизации производится на странице Двухэтапная авторизация (Настройки > Проактивная защита > Двухэтапная авторизация) с помощью кнопки Включить/Выключить двухэтапную авторизацию.

Параметры

Форма позволяет настроить параметры механизма двухэтапной авторизации.
Поле | Описание
Размер окна проверки паролей Задается размер окна проверки паролей. Настройка актуальна только для алгоритма генерации паролей по счетчику.

Если на устройстве была нажата кнопка несколько раз (например, случайно), но не было выполнено ни одной удачной аутентификации, то при превышении числа нажатий значения, заданного в этом параметре, произойдет нарушение синхронизации счетчика генерации, и пользователь не сможет выполнить вход на сайт.
Алгоритм генерации паролей по умолчанию Выбирается алгоритм генерации паролей, который будет использоваться по умолчанию в системе:
  • по счетчику (HMAC-Based One-time Password [image], HOTP);
  • по времени (Time-based One-time Password [image], TOTP).
Разрешить запоминание одноразового пароля При отмеченной опции будет разрешено запоминание введенного одноразового пароля с помощью соответствующей опции в форме авторизации.

Примечание: Опция позволят сохранить одноразовый пароль во всех случаях, согласно настройкам политики безопасности (опции маска сети для привязки сохраненной авторизации и срок хранения авторизации, запомненной на компьютере пользователя) группы, в которую входит пользователь, кроме случая самостоятельного завершения сессии.
Разрешить использование резервных кодов | При отмеченной опции пользователю будет доступен функционал генерации резервных кодов авторизации, которые можно будет использовать для входа на сайт вместо одноразового пароля. Например, в случае утери устройства для двухэтапной авторизации, пользователь сможет самостоятельно авторизоваться на сайте только с помощью этих кодов.
Обязательность двухэтапной авторизации
Требовать двухэтапную авторизацию При отмеченной опции указанным пользователям через заданное время будет принудительно подключена двухэтапная авторизация. Отсчет времени начнется при первой авторизации пользователя после включения опции. Другими словами по истечении указанного времени доступ на сайт будет возможен только с использованием одноразового пароля.

В случае, если пользователь в указанный промежуток времени не подключил свое устройство для двухэтапной авторизации и не может зайти на сайт, администратор может на странице редактирования пользователя отключить для него двухэтапную авторизацию на необходимое время.
Количество дней для подключения | Указывается период, в течение которого пользователь должен подключить свое устройство для двухэтапной авторизации. Отсчет времени начнется при первой авторизации пользователя после включения опции требовать двухэтапную авторизацию.
Пользователи с обязательной двухэтапной авторизацией | Указываются пользователи, для которых будет принудительно подключена двухэтапная авторизация.

Смотрите также

  • Повышенный уровень защиты (учебный курс "Администратор. Базовый")


Контроль целостности

Контроль целостности файлов необходим для того, чтобы быстро выяснить, вносились ли изменения в файлы системы. В любой момент вы можете проверить целостность ядра, системных областей, публичной части продукта.

Предварительные операции

Закладка Контроль целостности скрипта

Форма позволяет настроить параметры защиты скрипта паролем.
Поле | Описание
Пароль* | Указывается пароль, который необходимо запомнить. Рекомендуется использовать пароль длиной не менее 10 символов, состоящий из латинских букв и цифр.
Пароль ещё раз* | Указывается пароль ещё раз.
Ключевое слово* | Указывается ключевое слово, которое необходимо запомнить. Это слово должно отличаться от пароля. Если при последующем запуске кодовое слово будет отличаться от указанного, то скрипт контроля файлов был изменен.

* - поля, обязательные для заполнения.

Примечание: при первом запуске скрипта будут отображены все поля формы. При последующих запусках будет отображено только поле Пароль.

Закладка Выбор действия

Форма позволяет выбрать действие: проверить файлы либо собрать информацию о файлах.
Поле | Описание
Проверить файлы | При отмеченной опции будет осуществлен переход к проверке целостности файлов системы.
Собрать информацию по файлам | При отмеченной опции будет осуществлен сбор информации по файлам для того, чтобы в дальнейшем выполнить проверку целостности системы.

Сбор информации

Закладка Сбор данных

Форма позволяет настроить параметры сбора данных.
Поле | Описание
Область сбора данных* | Указываются необходимые для обработки папки системы.
Расширения файлов* | Указываются расширения файлов, по которым должна быть собрана информация. Расширения файлов указываются через запятую без пробелов.
Пароль для шифрования* | Указывается пароль, который будет использоваться для шифрования и последующего дешифрования собранного верификационного файла.
Время выполнения шага (сек) | Задается время выполнения одного шага сбора данных в секундах.

* - поля, обязательные для заполнения.

Закладка Отчет

Форма позволяет просмотреть результат процесса сбора данных, по окончании которого в целях безопасности рекомендуется скачать файл с верификационными данными на локальный компьютер.

Проверка целостности системы

Закладка Выбор файла

Форма позволяет выбрать файл с верификационными данными для проверки целостности системы либо хранящийся в системе либо с локальном компьютера.
Поле | Описание
Выбор файла с верификационными данными | Указывается файл с верификационными данными, хранящийся в системе.
Загрузка файла с верификационными данными | Указывается путь к файлу с верификационными данными.

Закладка Проверка данных

Форма позволяет настроить параметры проверки целостности системы.
Поле | Описание
Пароль для дешифрования* | Указывается пароль, который был задан при создании файла с верификационными данными.
Время выполнения шага (сек) | Указывается время выполнения одного шага проверки (чем меньше время выполнения одного шага, тем больше нагрузка на сервер).

* - поля, обязательные для заполнения.

Закладка Отчет

Форма позволяет просмотреть результат проверки целостности системы.

Смотрите также

  • Повышенный уровень защиты (учебный курс Администратор. Базовый")


Защита административного раздела

Защита административной части сайта осуществляется с помощью ограничения доступа со всех, кроме указанных в настройках IP-адресов и диапазонов адресов.

Закладка Защита административной части

Включение или отключение защиты выполняется на странице Защита административной части (Настройки > Проактивная защита > Защита административного раздела) с помощью кнопки Включить защиту (Выключить защиту).

Поле | Описание
IP-адреса и диапазоны с которых разрешен доступ к административной части | Указываются IP-адреса и диапазоны адресов, с которых доступ к административной части будет разрешен. Например: 192.168.0.7 или 192.168.0.1-192.168.0.100

Смотрите также:

  • Сбросить защиту админки по IP
  • Высокий уровень защиты (учебный курс "Администратор. Базовый")


Защита сессий

Большинство атак на веб-приложения ставят целью получить данные об авторизованной сессии пользователя. Включение защиты сессий делает похищение авторизованной сессии неэффективным.

Модуль Проактивная защита позволяет выполнить защиту сессий с помощью следующих инструментов:

  • хранение данных сессий в таблице модуля;
  • смену идентификатора сессии раз в несколько минут (в зависимости от настройки).

Закладка Хранение в базе данных

Включение или отключение механизма хранения данных сессий пользователей в базе данных выполняется на странице Защита сессий (Настройки > Проактивная защита > Защита сессий) с помощью кнопки Включить хранение данных сессий в БД модуля (Отключить хранение данных сессий в БД модуля).

Закладка Смена идентификатора

Включение или отключение механизма смены идентификатора выполняется на закладке Смена идентификатора (Настройки > Проактивная защита > Защита административного раздела) с помощью кнопки Включить смену идентификатора (Отключить смену идентификатора).

Поле | Описание
Время жизни идентификатора, в секундах | Указывается время жизни идентификатора в секундах, т.е. промежуток времени, через который будет изменяться идентификатор сессий.

Смотрите также:

  • Высокий уровень защиты (учебный курс "Администратор. Базовый")


Защита редиректов

Описание

Фишинг (англ. phishing, от password — пароль и fishing — рыбная ловля, выуживание) — вид интернет-мошенничества, целью которого является получение доступа к конфиденциальным данным пользователей (например, логинам и паролям). Это достигается путем проведения массовых рассылок электронных писем от имени популярных брендов, например, от имени социальных сетей, банков, порталов. В письме часто содержится прямая ссылка на сайт, внешне не отличимая от настоящей.

Защита редиректов от фишинга осуществляется двумя методами:

  • во-первых, можно определить злонамеренный редирект по отсутствию заголовка http протокола - ссылающаяся страница.
  • во-вторых, можно подписать ссылки, генерируемые на сайте, цифровой подписью и проверять эту подпись при попытке редиректа.

Защита может заключаться в следующих вариантах действий:

  • показать пользователю предупреждение, что он будет перенаправлен на другой сайт и показать на какой именно.
  • принудительно перенаправить его на заведомо безопасный адрес. Например, главную страницу атакуемого сайта.

Закладка Защита редиректов

Включение или отключение защиты редиректов от фишинга выполняется на странице Защита редиректов от фишинга (Настройки > Проактивная защита > Защита редиректов) с помощью кнопки Включить защиту редиректов от фишинга (Выключить защиту редиректов от фишинга).

Закладка Параметры

Форма позволяет настроить параметры защиты редиректов.
Поле | Описание
Методы защиты от фишинга Указываются следующие методы защиты от фишинга:
  • Проверять наличие HTTP заголовка описывающего ссылающуюся страницу - при отмеченной опции будет проверяться наличие HTTP заголовка, описывающего страницу;
  • HTTP заголовок, описывающий ссылающуюся страницу, должен содержать текущий сайт - при отмеченной опции будет проверяться наличие в HTTP заголовке записи о текущем сайте, который описывает ссылающуюся страницу;
  • Добавлять цифровую подпись к перечисленным ниже URL - при отмеченной опции к адресам, перечисленным в поле Подписываемые URLs, будет добавляться цифровая подпись.

Примечание: Начиная с версии модуля 14.0.3, для страниц в публичной части сайта с сообщениями функционала "Защита редиректов от фишинга" и "Проактивный фильтр" добавлены теги noindex и nofollow.

Примечание: Начиная с версии модуля 20.0.0 cтраница защиты от редиректов отдает HTTP-статус 404 Not Found.

Подписываемые URLs | Указываются Системные и Пользовательские подписываемые URLs. Добавление полей ввода осуществляется с помощью кнопки Добавить.
Действия защиты от фишинга Задается одно из следующих действий защиты от фишинга:
  • Перенаправить на другой сайт с показом сообщения и задержкой - при отмеченной опции будет перенаправлен на другой сайт с показом соответствующего сообщения и выполнением задержки на несколько секунд. Текст сообщения задается в поле Сообщение, а период задержки пользователя – в поле Задержка.
  • Перенаправить на заданный URL - при отмеченной опци будет перенаправлен на заданный в поле URL адрес.
Занести попытку фишинга в журнал | При отмеченной опции попытка фишинга через редирект будет занесена в журнал событий.

Смотрите также

  • Высокий уровень защиты (учебный курс "Администратор. Базовый")


Защита от фреймов

На странице Защита от фреймов (Настройки > Проактивная защита > Защита от фреймов) можно включить/отключить ограничение работы во фрейме (<iframe>).

Ограничение отображения страниц сайта во фреймах сторонних доменов позволяет защитить ресурс от Clickjacking'a (подсовывание невидимого фрейма с целевого ресурса для получения клика от пользователя), Framesniffing'а и существенно снижает риск проведения Cross-site scripting атак.

Закладка "Защита от фреймов"

На этой вкладке можно включить/отключить ограничение работы страниц сайта во фрейме с помощью соответствующей кнопки.

Закладка "Исключения"

На этой закладке можно указать страницы, на которые не будет распространяться ограничение работы во фрейме.

Страницы можно указать по маскам (например: /bitrix/* или */news/*) как для конкретного сайта, так и для всех сразу.

Смотрите также:

  • Высокий уровень защиты (учебный курс "Администратор. Базовый")


Контроль активности

Контроль активности позволяет установить защиту от чрезмерно активных пользователей, программных роботов, некоторых категорий DDoS-атак, а также отсекать попытки подбора паролей перебором.

Примечание: контроль активности пользователей ведется на основе средств модуля Веб-аналитика и, следовательно, доступен только в тех редакция продукта, в которые входит этот модуль.

Закладка Контроль активности

Включение или отключение контроля активности выполняется на странице Контроль активности (Настройки > Проактивная защита > Контроль активности) с помощью кнопки Включить контроль активности (Выключить контроль активности).

Закладка Параметры

Форма позволяет задать параметры максимальной активности пользователей сайта.

Поле | Описание
Шаблон страницы, которая будет показана заблокированному пользователю | По ссылке редактировать шаблон будет отображена страница, шаблон которой можно изменить. Данная страница будет показана заблокированному пользователю.
Блокировать на время | Указывается период блокировки пользователя в секундах.
если в течение | Указывается период времени в секундах. Если пользователь за указанное количество секунд превысит количество запросов, указанное в поле сделано более, то он будет заблокирован.
сделано более | Указывается максимальное количество хитов. Если пользователь превысит количество запросов за количество секунд, указанных в поле если в течение, то он будет заблокирован.
Сделать запись в журнале событий | При отмеченной опции превышение лимита активности будет зафиксировано в журнале вторжений.

Смотрите также

  • Стандартный уровень защиты (учебный курс "Администратор. Базовый")


Стоп-лист

На странице Стоп-лист (Настройки > Проактивная защита > Стоп-лист) представлена информация о правилах блокировки доступа к вашему сайту или некоторым его разделам с определенных IP-адресов. Записи о блокировке доступа создаются либо вручную, либо автоматически.

Фильтр

Форма фильтра используется для фильтрации записей о блокировке в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым могут выбираться записи.
Поле | Описание
Найти | Позволяет найти записи о блокировке по их основным параметрам: названию, странице или IP. Это поле присутствует, даже если фильтр свернут.
Тип записи Определяется, какие записи будут отобраны:
  • все;
  • ручные;
  • автоматические.
Активность Определяется, какие записи о блокировке будут участвовать в поиске:
  • все;
  • да - активные;
  • нет - неактивные.
Административный раздел Определяется, какие записи о блокировке административного раздела участвовать в поиске:
  • все;
  • да - страницы административного раздела заблокированы;
  • нет - доступ к страницам административного раздела не заблокирован.
Сайт | Указывается сайт для поиска записей о блокировке доступа.
Название | Задается название записи о блокировке для поиска.
IP | Служит для отбора записей о заблокированных IP адресах.
Страница | Служит для поиска заблокированных адресов страниц.

Для того чтобы отобрать записи по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех записей нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания новой записи стоп-листа.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Стоп-лист

Поле | Описание
ID | Идентификатор записи стоп-листа.
Тип записи | Тип записи.
Активность | Активность записи стоп-листа.
Административный раздел | Статус блокировки административного раздела.
Сайт | Сайт, для которого создана запись.
Сортировка | Порядок сортировки записей в списке.
Название | Название записи.
Начало активности | Дата и время начала действия записи стоп-листа.
Окончание активности | Дата и время окончания действия записи стоп-листа.
Маски путей | Маски путей разделов и страниц, доступ к которым заблокирован.
Маски исключений | Маски путей разделов и страниц, доступ к которым разрешен.
IP-адреса | IP-адреса и диапазоны адресов, доступ с которых заблокирован.
IP-адреса исключений | IP-адреса и диапазоны адресов, доступ с которых разрешен.


Создание и редактирование правила стоп-листа

На данной странице можно создать новое или изменить параметры существующего правила блокировки доступа.

Контекстная панель

Кнопка | Описание
Список | Переход к списку правил блокировки.
Добавить | Переход на страницу с формой создания нового правила блокировки. Кнопка отображается при редактировании существующего правила.
Удалить | Удаление редактируемого правила блокировки.

Форма редактирования

Поле | Описание
Активность | При отмеченной опции запись будет активной.
Действует для страниц административного раздела | При отмеченной опции правило будет действовать для страниц административного раздела.
Действует для страниц публичной части сайта | Указывается сайт, для страниц публичной части которого будет действовать правило блокировки.
Сортировка | Порядок сортировки в списке правил. Чем меньше порядок сортировки, тем выше в списке будет показано правило.
Название | Название правила.
Начало активности | Дата и время начала активности правила.
Окончание активности | Дата и время окончания активности правила.
IP-адреса и диапазоны адресов, которые будут заблокированы | IP-адреса и диапазоны адресов, которые будут заблокированы. Например: 192.168.0.7 или 192.168.0.1-192.168.0.100. Каждый IP адрес добавляется с помощью нового поля, которое добавляется с помощью кнопки Добавить.
Исключения IP из заблокированных | IP-адреса и диапазоны адресов, доступ с которых будет разрешен.
Маски путей, доступ к которым будет заблокирован | Маски путей разделов и страниц, доступ к которым будет заблокирован. Например: /* или /bitrix/admin/*.
Исключения масок путей | Маски путей разделов и страниц, доступ к которым будет разрешен.

Смотрите также

  • Стоп-лист (учебный курс "Администратор. Базовый")


Хосты/домены

На странице Хосты/домены (Настройки > Проактивная защита > Хосты/домены) можно ограничить доступ или перенаправить на заданную страницу те запросы, у которых адрес в HTTP-заголовке Host не будет соответствовать разрешенным адресам.

Данный режим позволяет предотвратить подмену HTTP-заголовка Host и, соответственно, $_SERVER["HTTP_HOST"].

Закладка "Параметры"

Поле | Описание
Ограничивать | Опция позволяет включить режим ограничения для запросов с несоответствующими HTTP-заголовками Host.
Логировать | При отмеченной опции информация о запросах будет заноситься в журнал.
Активная реакция Задается режим реакции в ответ на запрос с несоответствующим заголовком:
  • Запрещать доступ - доступ к сайту будет ограничен;
  • Перенаправлять - будет произведено перенаправление на страницу, указанную ниже.
Адрес перенаправления | Указывается страница, на которую будет производиться перенаправление.
Список разрешенных хостов/доменов Указываются разрешенные хосты, с которыми будет производиться сравнение заголовков Host.

Допускается запись хостов через пробел и с новой строки.
Возможно использование символа *, например: *.site.com

Смотрите также:

  • Хосты/домены (учебный курс "Администратор. Базовый")


Отправить отзыв по этому разделу

DAV (КП)

Модуль DAV предназначен для обмена календарями и контактами с внешними системами.

  • DAV (КП). Настройки модуля


DAV (КП). Настройки модуля

Закладки

Форма настроек модуля DAV (Настройки > Настройки продукта > Настройки модулей > DAV) предназначена для задания общесистемных параметров для синхронизации календарей и контактов с внешними системами.

Закладка Exchange

Поле | Описание | Примечание
Включить синхронизацию календарей Exchange | При отмеченной опции будет включена синхронизация календарей с MS Exchange.
Включить синхронизацию контактов Exchange | При отмеченной опции будет включена синхронизация контактов с MS Exchange.
Включить синхронизацию задач Exchange | При отмеченной опции будет включена синхронизация задач с MS Exchange.
Включить запрос количества непрочитанных сообщений Exchange | При отмеченной опции будет отправляться запрос к MS Exchange на количество непрочитанных сообщений, которые будут выводиться в панели статусов публичной части портала.
Схема подключения к Exchange серверу | Выбирается протокол подключения к серверу MS Exchange: HTTP или HTTPS.
Адрес Exchange сервера | Указывается адрес для подключения с сервером MS Exchange.
Порт Exchange сервера | Указывается порт для подключения с сервером MS Exchange.
Имя пользователя для соединения с Exchange сервером | Указывается имя пользователя. | Модулю DAV нужен доступ к профилям всех пользователей Exchange, которые будут подключены к синхронизации. Роль пользователя Exchange, логин и пароль которого указываются в настройках модуля DAV, может включать в себя доступ только к тем объектам, которые предполагается синхронизировать. Например, держатель роли может обладать правами на календари, но не на контакты пользователей. Учетные записи пользователей не изменяются и не удаляются.
Пароль пользователя для соединения с Exchange сервером | Указывается пароль пользователя.
Шаблон почтового ящика Exchange сервера | Указывается шаблон почтового ящика в MS Exchange (Например: @test.com).
Использовать логин в качестве имени почтового ящика на Exchange сервере При отмеченной опции будет использоваться логин пользователя портала в качестве имени почтового ящика на сервере MS Exchange (Например: логин пользователя на портале - user, шаблон почтового ящика в MS Exchange - @test.com, то итоговый почтовый ящик пользователя будет user@test.com).

 Если опция отключена, то для правильной работы MS Exchange с пользователями необходимо:
  1. в форме редактирования профиля каждого пользователя в закладке Дополнительно включить пользовательское поле Почтовый ящик Exchange (код поля: UF_BXDAVEX_MAILBOX) с помощью кнопки Настроить (либо нажать кнопку Отменить действия настроек полей формы на время сессии);
  2. указать почтовый ящик пользователя в MS Exchange.

Внимание! при включении этой опции становится невозможным подключение E-mail трекера в CRM.
Путь к Outlook Web App | Указывается путь к Outlook Web App (OWA) - специальному приложению, которое позволяет работать в браузере с MS Exchange. После чего в панели статусов появится ссылка для перехода к OWA.

Закладка DAV

Поле | Описание
Включить синхронизацию календарей CalDAV | При отмеченной опции будет включена синхронизация между порталом и мобильными устройствами, используя протокол CalDAV (Например, для владельцев мобильных устройств по управлением Apple iOS).

Закладка Прокси

Поле Описание
Использовать прокси При отмеченной опции для работы DAV будет использоваться прокси-сервер. Для этого необходимо указать настройки подключения к прокси-серверу:
  • Схема подключения к прокси;
  • Адрес прокси;
  • Порт прокси;
  • Логин прокси;
  • Пароль прокси.

Смотрите также

  • Работа с модулем DAV


Модуль Push and Pull

Модуль позволяет организовать транспорт мгновенных нотификаций и сообщений клиентам.

При использовании продуктов Bitrix Framework на базе виртуальной машины BitrixVM либо BitrixEnvironment с v. 4.2, то необходимости в настройке модуля нет: всё работает "из коробки". Если проект используется не на штатных средствах установки Bitrix Framework, то необходимо настроить модуль самостоятельно.

Смотрите также:

  • Push and Pull (учебный курс "Администратор. Модули")


Push and Pull. Настройки модуля

При использовании продуктов Bitrix Framework на базе виртуальной машины BitrixVM v4.2 либо BitrixEnvironment, то необходимости в настройке модуля нет: всё работает "из коробки". О принципах работы модуля можно узнать из главы Push&Pull [image] учебного курса Администратор. Модули.

Поле | Описание
Состояние модуля | Индикация активности модуля.
Используют модули | Список модулей, использующих Push&Pull.
Отправлять PUSH уведомления на мобильные телефоны Включение отправки уведомлений на мобильные телефоны.
После включения опции становится активным окно для задания Максимального количества push-уведомлений в пакете при отправке.
Включить модуль для не авторизованных пользователей Сообщения будут доставляться пользователям, даже если они не авторизованы на сайте.

Опция неактивна для "Битрикс24 в коробке".
Использовать "Push server" Выбор типа сервера.
  • Не использовать - сервер не будет использоваться
  • Использовать облачный сервер. Сайт будет использовать [dw]облачный сервер Битрикса[/dw][di]1. Для выбора облачного сервера необходимо иметь активную лицензию.
    2. После выбора облачного сервера нужно указать в поле Зарегистрироваться на сервере нужный сервер и нажать Зарегистрироваться..[/di]. После выбора будет выведет адрес сервера в "облаке".
  • Использовать локальный сервер. Сайт будет использовать собственный, локальный, сервер. После выбора этой позиции нужно настроить поля, описанные ниже и помеченные: для локального сервера
На сервер установлена:
(для локального сервера) 		Указание на используемую виртуальную машину. Доступны значения:
  • Виртуальная машина 7.3 и новее (Bitrix Push server 2.0) - Рекомендуемая установка.
Указанные ниже версии объявлены устаревшими и скоро перестанут поддерживаться. Используйте Bitrix Push server 2.0 или подключите облачный сервер. Подробнее...
  • Виртуальная машина 7.1 - 7.2 (Bitrix Push server 1.0)
  • Виртуальная машина 4.4 и выше (nginx-push-stream-module 0.4.0) [dw]Внимание![/dw][di] 4.х - устаревшие версии Виртуальных машин. При их использовании недоступна установка числа отправленных команд, указание путей для веб-сокетов и некоторые другие опции. Рекомендуется обновить [image] [image] вашу виртуальную машину до версии не ниже 7.х.[/di]
  • Виртуальная машина 4.2 - 4.3 (nginx-push-stream-module 0.3.4) [dw]Внимание![/dw][di] 4.х - устаревшие версии Виртуальных машин. При их использовании недоступна установка числа отправленных команд, указание путей для веб-сокетов и некоторые другие опции. Рекомендуется обновить [image] [image] вашу виртуальную машину до версии не ниже 7.х.[/di]
Настройка адреса для публикации команд со стороны сервера
Путь для публикации команд
(для локального сервера) 		Укажите пути до папки с командами.
Код-подпись для взаимодействия с сервером
(для локального сервера) 		Ключ, которым подписываются сообщения, отправляемые на пуш-сервер. Рекомендуется для создания ключа использовать случайную строку длиной от 32 символов. Ключ указывается в настройках пуш-сервера:
<путь к пуш-серверу>/etc/push-server/push-server*.json:
"security": {
        "key": <ваш секретный ключ>
},

В виртуальной машине это поле создается автоматически при первом старте службы или при настройке/обновлении и прописывается в настройки сайта.
Секретный ключ можно получить в /etc/push-server/push-server-pub-*.json.
Настройка адреса для публикации команд со стороны клиента
Путь для публикации команд
(для локального сервера) 		Пути указываются отдельно по протоколам.
Настройка адреса чтения команд для браузеров
Путь для чтения команд
(для локального сервера) 		Пути указываются отдельно по протоколам. Рекомендуется использовать стандартный порт для HTTP или HTTPS. Используйте 8893 (HTTP) и 8894 (HTTPS) только для версии модуля nginx-push-stream-module 0.3.4
Настройка адреса чтения команд для браузеров с поддержкой Web Socket
Включить поддержку WebSocket
(для локального сервера) 		Включает использование Веб-сокетов. Активна только при использовании nginx-push-stream-module в версии 0.4.0
Путь для чтения команд через WebSocket (HTTP)
(для локального сервера) 		Пути указываются отдельно по протоколам.
Блокировка работы с модулем на определенных сайтах
Не использовать модуль на сайтах
(для локального сервера) 		Активно только при наличии нескольких активных сайтов в системе. Укажите на каких сайтах модуль не должен использоваться. С помощью клавиши Ctrl можно выбрать несколько сайтов.

Примечание. Домен при написании путей можно указать #DOMAIN#: такая нотация будет автоматически заменяться под нужный домен для многодоменных конфигураций. Пример: http://#DOMAIN#:8893/bitrix/sub/

Смотрите также:

  • Настройки модуля Push and Pull


Отправить отзыв по этому разделу

REST API

  • REST API. Настройки модуля


REST API. Настройки модуля

Форма настроек

Форма настроек модуля REST API (Настройки > Настройки продукта > Настройки модулей > REST API) предназначена для задания параметров модуля.

Закладка Настройки

Поле | Описание
Модуль mod_zip включен и настроен (требуется для экспорта) | При отмеченной опции для экспорта архива приложения будет использоваться модуль [dw]mod_zip[/dw][di]mod_zip - HTTP-модуль для NGINX, динамически собирающий ZIP-архивы. В простых конфигурациях mod_zip берет список файлов в локальной файловой системе и обслуживает их как один ZIP-архив. В более сложных настройках mod_zip может передавать файлы компонентов с вышестоящих серверов с помощью собственного прокси-кода NGINX. В отличие от многих сценариев создания ZIP, этот процесс никогда не занимает больше нескольких КБ ОЗУ, даже при сборке архивов, размер которых (потенциально) составляет сотни мегабайт. Подробнее... [/di].
Максимальный размер импортируемого файла (МБ) | Устанавливается ограничение на размер файла импорта.

Закладка Логирование

Поле | Описание
Активность логирования | Выполняется активация или отключение логирования.
Включить логирование | Устанавливается (выбирается из списка) время, на которое нужно включить лог использования RESTа.
Удалить собранные ранее данные | Выполняется удаление данных, собранных при предыдущем включении логирования.
Собрано данных | При нажатии на ссылку-число собранных данных можно просмотреть более подробный лог использования RESTа.
Настройки фильтрации
Идентификатор клиента (client_id) | Задаются параметры для выполнения импорта посредством REST. При большом объеме выгружаемых данных это значительно ускорит импорт. Подробное описание см. в документации по REST Как правильно выгружать большие объемы данных [image] .
Идентификатор пароля (password_id)
Область видимости (scope)
Метод (method)
Идентификатор пользователя (user_id)


Валюты. Описание модуля

Несомненно, в вашем интернет-магазине присутствуют товары зарубежного производства. Обычно цена на такие товары рассчитывается, исходя из закупочной цены, зачастую устанавливаемой в иностранной валюте. Однако законодательные правила требуют, чтобы расчёты по торговым операциям осуществлялись только во внутренней валюте государства (рублях). Для удобства обращения с такими товарами и ценами на них в системе предусмотрен модуль Валюты .

Модуль Валюты позволяет управлять валютами и их курсами. Модуль Валюты необходим для работы модулей Торговый каталог и Интернет-магазин.

Система позволяет гибко управлять валютами цены. Список валют определяется администратором сайта. Для каждой валюты могут быть установлены номиналы, курсы (с возможностью загрузки с сайта Центрального Банка РФ), формат вывода для каждого сайта.

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Таблица курсов валют | currency.rates | Служит для отображения таблицы курсов валют в соответствии с их форматом.

Смотрите также:

  • Показ курса валют на сайте
  • Как добавить валюту
  • Создание курса валют
  • Документация для разработчиков по модулю Валюты


Валюты. Настройки модуля

Отправить отзыв по этому разделу
Настройки>Валюты>Валюты. Настройки модуля

Валюты::Валюты. Настройки модуля

Форма настроек

Форма настроек модуля Валюты (Настройки > Настройки продукта > Настройки модулей > Валюты) предназначена для задания параметров модуля.

Форма позволяет установить базовую валюту и уровень доступа к модулю Валюты по умолчанию для всех групп пользователей сайта, а также дополнительно определить индивидуальный, отличный от заданного по умолчанию, уровень доступа для каждой группы пользователей в отдельности.

Закладка Основные настройки

Поле | Описание
Базовая валюта | Валюта, которая будет использоваться в качестве основы для расчетов других валют.

Закладка Доступ

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Валюты:
  • [D] закрыт - запрет на доступ;
  • [R] просмотр всех данных модуля - разрешается только просмотр всех данных модуля;
  • [W] запись - полный доступ к ресурсам модуля.

Служебные процедуры

Закладка Текущие базовые курсы

Кнопка | Описание
Пересчитать | Выполняется пересчет курсов валют по отношению к базовой.

Закладка Агенты

На закладке отображается информация о работе агента модуля.

Кнопка | Описание
Отключить агента/Активировать агента | Выполняется отключение или активация агента расчета курсов валют по отношению к базовой.


Список валют

Отправить отзыв по этому разделу
Настройки>Валюты>Список валют

Валюты::Список валют

Форма Валюты (Настройки > Валюты > Список валют) служит для управления валютами системы. Валюты в системе используются для работы интернет-магазина.

Важно! Помните, что магазин не может функционировать, если в системе не задана хотя бы одна валюта.

Контекстная панель

Кнопка | Описание
Добавить валюту | Переход к форме создания новой валюты.
Курсы валют | Переход к форме настройки курсов валют.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список валют

Поле | Описание
Колонка флажков | Поле предназначено для выбора валют, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия над валютой:
  • Изменить - переход к редактированию валюты.
  • Сделать базовой - использование валюты в качестве базовой. Пункт доступен только для небазовых валют.
  • Удалить- удаление валюты. Пункт доступен только для небазовых валют.
Валюта | Трехбуквенное обозначение валюты (например, RUB, EUR, USD).
Название | Полное название валюты.
Сорт. | Относительный "вес", влияющий на положение валюты в общем списке.
Номинал | Номинал, или количество валюты, для которого устанавливается обменный курс. Обычно равен номиналу, устанавливаемому ЦБ РФ. Для большинства валют номинал будет равен 1 (например, 30.5 RUB за 1 USD). У некоторых валют он будет отличен от 1 (например, 14.25 RUB за 1000 BYR).
Курс по умолчанию | Курс валюты, который будет использоваться при конвертации валют, если в форме "Курсы валют" другие курсы не заданы.
Базовая | Отметка о том, является ли валюта базовой.
Цифровой код | Трехзначный цифровой код валюты (см. международные обозначения валют).
Дата изменения | Дата и время изменения валюты.
Кем изменена | Имя пользователя, изменившего валюту.
Дата создания | Дата и время создания валюты.


Создание и редактирование валюты

Отправить отзыв по этому разделу
Настройки>Валюты>Создание и редактирование валюты

Валюты::Создание и редактирование валюты

Закладки

Данная форма служит для создания новой и изменения параметров созданной валюты.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком валют.
Создать | Переход к форме создания новой валюты.
Удалить | Удаление редактируемой валюты.

Валюта

Поле | Описание
*Валюта | Трёхбуквенный алфавитный (alfa-3) код валюты по международному стандарту ISO 4217 [image] [image] (например, RUB, EUR, USD).
Базовая | Отметка о том, является ли валюта базовой. Сделать валюту базовой можно из списка валют с помощью пункта меню действий Сделать базовой.
*Номинал | Номинал, или количество валюты, для которого устанавливается обменный курс. Обычно равен номиналу, устанавливаемому ЦБ РФ. Для большинства валют номинал будет равен 1 (например, 30.5 RUB за 1 USD). У некоторых валют он будет отличен от 1 (например, 14.25 RUB за 1000 BYR).
*Курс по умолчанию | Курс валюты, который будет использоваться при конвертации валюты, если в форме "Курсы валют" для данной валюты не задан другой курс. Для базовой валюты курс должен быть равен 1. Для остальных валют курс устанавливается относительно базовой валюты. Другими словами, при добавлении валюты поставьте напротив этой валюты сумму, которую дают за нее в базовой валюте. Например, установите курс для RUB в 1, тогда курс для USD может быть равен 30.5, а для EUR - 34.2. Подробнее о курсах валют смотрите раздел помощи Курсы валют. Валюта с курсом по умолчанию равным 1 должна быть только одна.
Цифровой код | Трёхзначный цифровой (number-3) код валюты по международному стандарту ISO 4217 [image] [image] (например 643 для RUB, 978 для EUR, 840 для USD).
Индекс сортировки | Относительный "вес", влияющий на положение валюты в общем списке.

* - Поля, обязательные для заполнения.

Языковые настройки

Поле | Описание
Настройки валют для языков системы (English, Russian и т.д.)
Название | Полное название валюты для данного языка.
Шаблон формата | Шаблон, по которому суммы в данной валюте будут выводиться на экран. При выборе шаблона вывода в нижеследующие поля будут подставлены значения по умолчанию. При необходимости вы можете изменить значения этих полей.
*Строка формата для вывода валюты | Формат для вывода суммы в данной валюте на экран. Все символы строки формата выводятся как есть, за исключением символа #. Символ # заменяется при выводе на реальную сумму (например, строка формата # руб за 1 шт. может быть выведена как 18 586,95 руб за 1 шт.). Формат вывода суммы зависит от описанных ниже полей.
Десятичная точка при выводе | Символ-разделитель целой и дробной части числа.
Разделитель тысяч при выводе | Символ-разделитель тысяч целой части числа. При выборе Другое значение можно указать свой вариант разделителя. Для разработчиков. Обратите внимание, что для обозначения символа-разделителя можно использовать шестнадцатеричное значение, например, xA0.
Количество десятичных знаков | Количество знаков в дробной части числа (например, количество копеек для RUB). Количество десятичных знаков дробной части цены влияет на отображение цен на сайте и в чеке. Все расчеты ведутся с параметрами округления, указанными в поле Точность округления при расчетах настроек модуля Интернет-магазин. Это может привести к визуальным ошибкам при конвертации валют и применении скидок. В качестве примера рассмотрим такую ситуацию. Стоимость товара 98,01 руб. Если задать количество десятичных знаков равным 0, цена будет показана как 98 руб. Однако стоимость 100 единиц в корзине будет показана как 9801 руб.
В публичной части не показывать незначащие нули в дробной части цены | При отмеченной опции в публичной части сайта не будут показаны не имеющие значения нули дробной части цены. Если у вас цена 12500,00 рублей - будет отображено 12500, если у вас 12500,50 - будет отображено 12500,50.

* - Поля, обязательные для заполнения.


Конфигуратор валюты

Отправить отзыв по этому разделу
Настройки>Валюты>Конфигуратор валюты

Валюты::Конфигуратор валюты

Закладки

Форма служит для создания новой валюты. В отличие от ручной формы создания валюты конфигуратор автоматически проставляет большую часть данных.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком валют.

Поиск и основные настройки

Поле | Описание
Поиск валюты | Поле для ввода названия валюты. При вводе в поле Выбор валюты ниже будут оставаться валюты, подходящие под условия поиска.
Выбор валюты | Список всех валют. Выбор валюты из списка автоматически заполняет неизменяемые поля в секции Основные настройки валюты и на закладке Языковые настрйоки.
Основные настройки валюты
*Курс обмена по умолчанию | Курс валюты, который будет использоваться при конвертации валюты, если в форме "Курсы валют" для данной валюты не задан другой курс. Для базовой валюты курс должен быть равен 1. Для остальных валют курс устанавливается относительно базовой валюты. При создании валюты нужно узнать её текущий курс по отношению к базовой и проставить в данном окне. Например, установите курс для RUB в 1, тогда курс для USD может быть равен 30.5, а для EUR - 34.2. Подробнее о курсах валют смотрите раздел помощи Курсы валют. Валюта с курсом по умолчанию равным 1 должна быть только одна.
Индекс сортировки | Относительный "вес", влияющий на положение валюты в общем списке.

* - Поля, обязательные для заполнения.

Языковые настройки

На закладке автоматически проставятся варианты настроек для каждого языка интерфейса, установленного в системе.

Поле | Описание
В публичной части не показывать незначащие нули в дробной части цены | Простановка флажка в опция убирает в публичной части показ незначащих нулей у дробной части цены. Если у вас цена 12500,00 рублей - будет отображено 12500, если у вас 12500,50 - будет отображено 12500,50

* - Поля, обязательные для заполнения.


Курсы валют

Отправить отзыв по этому разделу
Настройки>Валюты>Курсы валют

Валюты::Курсы валют

Форма Курсы валют (Настройки > Валюты > Курсы валют) служит для управления курсами валют. С помощью этой формы вы легко можете поддерживать список курсов валют на все интересующие вас даты. То есть, вы можете вести своего рода дневник курсов валют. Эта информация может пригодиться вам в дальнейшем, например, при обзоре заказов, сделанных в магазине за определённый период.

При конвертации валют на текущую дату система берет самый новый из курсов. Если курс не найден, то берется курс по умолчанию (из формы Валюты).

Фильтр

Поля формы служат для задания параметров поиска интересующих вас курсов валют.

Поле | Описание
Дата | Диапазон дат, курсы на которые следует показать. Вы можете выбрать либо количество дней от текущей даты, либо установить диапазон дат с помощью календарей. Данное поле отображается, даже если фильтр свернут.
Валюта | Определяет, выводить ли все курсы валют в списке или только курсы выбранной валюты.

Для того чтобы отобрать курсы валют по заданным критериям поиска, нажмите кнопку "Найти". Для отображения всех курсов нажмите кнопку "Отменить".

Контекстная панель

Кнопка | Описание
Создать курс валют | Переход к форме создания нового курса валюты.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список курсов валют

Поле | Описание
Колонка флажков | Поле предназначено для выбора курсов валют, к которым предполагается применить какое-либо правило или действие.
Действия Действия над курсом валюты:
  • Изменить- редактирование курса валюты;
  • Удалить- удаление курса валюты.
Валюта | Валюта, для которой установлен курс.
Дата | Дата, на которую установлен данный курс.
Номинал | Единица измерения валюты (см. Валюты)
Курс | Обменный курс данной валюты по отношению к базовой валюте.

Смотрите также

  • Курсы валют (учебный курс "Администратор. Бизнес")


Создание и редактирование курса валюты

Отправить отзыв по этому разделу
Настройки>Валюты>Создание и редактирование курса валюты

Валюты::Создание и редактирование курса валюты

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком курсов валют.
Создать | Переход к форме создания нового курса валюты. Кнопка отображается при редактировании существующего курса.
Удалить | Удаление редактируемого курса.

Форма редактирования

Поле | Описание
ID | Идентификатор курса валюты. Отображается только при редактировании курса.
*Дата | Дата, на которую устанавливается курс валюты.
*Валюта | Валюта, для которой установлен курс.
*Номинал | Единица измерения валюты (см. Валюты)
*Курс | Обменный курс данной валюты по отношению к базовой валюте. Кнопка Запросить позволяет запросить курс валюты на указанную дату с сайта Центрального банка РФ.

* - Поля, обязательные для заполнения.


Веб-кластер. Описание модуля

Описание

Модуль Веб-кластер - это комбинация технологических решений, которые позволяют распределить один сайт на несколько серверов, решая тем самым несколько задач: обеспечение высокой доступности сайта; его масштабирование в условиях возрастающей нагрузки; балансирование нагрузки, трафика, данных между несколькими серверами.

Модуль Веб-кластер позволяет выполнять:

  • Вертикальный шардинг (вынесение модулей на отдельные серверы MySQL);
  • Репликация MySQL и балансирование нагрузки между серверами;
  • Распределенный кеш данных (memcached);
  • Непрерывность сессий между веб-серверами (хранение сессий в базе данных);
  • Кластеризацию веб-сервера:
    • Синхронизация файлов;
    • Балансирование нагрузки между серверами.

Примечание: Работа Веб-кластера поддерживается на уровне самой платформы «1С-Битрикс».

Смотрите также

  • Практическая реализация веб-кластера на примере Amazon Web Services
  • Репликация
  • Шардинг
  • Memcached
  • Веб-кластер (учебный курс "Администратор. Базовый")


Веб-кластер. Настройки модуля

Отправить отзыв по этому разделу
Настройки>Веб-кластер>Веб-кластер. Настройки модуля

Веб-кластер::Веб-кластер. Настройки модуля

Форма настроек модуля Веб-кластер (Настройки > Настройки продукта > Настройки модулей > Веб-кластер) предназначена для задания общесистемных параметров модуля.

Закладка Настройки

Поле | Описание
Максимально возможное время отставания slave базы данных от master (сек.) | Указывается время отставания в секундах slave базы данных от master, при котором slave база данных будет автоматически отключена для снижения риска рассинхрониизации данных. Примечание: Отставание slave базы данных возможно при большом количестве обновлений основной (master) базы данных, недостаточно быстром соединении между master и slave базами данных, недостаточной производительности slave базы данных.


Шардинг

Отправить отзыв по этому разделу
Настройки>Веб-кластер>Шардинг

Веб-кластер::Шардинг

Описание

Страница Шардинг (Настройки > Веб-кластер > Шардинг) содержит информацию о существующих базах данных, позволяет добавлять новые базы и управлять текущими.

Вертикальный шардинг - разделение одной базы данных веб-приложения на две и более базы данных за счет выделения отдельных модулей, без изменения логики работы веб-приложения.

Горизонтальный шардинг - распределение однотипных данных веб-приложения (например, учетных записей) между отдельными базами данных.

Примечание: В продукте пока поддерживается только Вертикальный шардинг.

Таблицы с данными некоторых модулей можно вынести в отдельную базу данных, перераспределив нагрузку, создаваемую запросами между различными серверами. Для этого нажмите кнопку Добавить новую базу данных.

После добавления подключения данные модуля можно перенести двумя способами:

  • Первый способ доступен только для MySQL. Он заключается в том, чтобы в списке баз данных модулей в меню действий выбранной базы данных выполнить команду Начать использовать. Запустится мастер переноса данных.
  • Второй способ заключается в удалении модуля и последующей его установки. На первом шаге установки появится возможность указать базу данных для использования модулем. В этом случае таблицы модуля не будут перенесены.

На данный момент поддерживаются следующие модули:

  • Веб-аналитика;
  • Поиск.

Контекстная панель

Кнопка | Описание
Добавить новую базу данных | Добавление новой базы данных.
Обновить | Обновление списка.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

Таблица "Базы данных модулей"

Поле | Описание
ID | Идентификатор базы данных.
Состояние | Состояние и время работы базы данных.
Активность | Признак активности базы данных.
Статус | Текущий статус базы данных.
Название | Название базы данных.
Модули | Модули, осуществляющие работу с базой данных.
Описание | Описание базы данных.
Сервер | Адрес сервера базы данных.
База данных | Название базы данных, содержащей таблицы модулей.
Пользователь | Учетная запись MySQL, под которой веб-кластер работает с базой данных модулей.

Смотрите также

  • Шардинг (учебный курс "Администратор. Базовый")


Создание и редактирование подключения к базе данных

Отправить отзыв по этому разделу
Настройки>Веб-кластер>Создание и редактирование подключения к базе данных

Веб-кластер::Создание и редактирование подключения к базе данных

Закладки

Форма на странице позволяет создать или отредактировать подключение к базе данных.

Примечание: Данная страница доступна только для mssql и oracle версий.

Контекстная панель

Кнопка | Описание
Список | Перехода на страницу Шардинг.

Закладка Подключение

Редактирование подключения к базе данных

Поле | Описание
Активность | Признак активности подключения к базе.
Название | Задается название подключения к базе данных.
Строка подключения к базе данных | Указываются параметры подключения к базе данных: IP и порт машины с Базой данных.
База данных | Указывается база данных, к которой будет осуществляться подключение.
Пользователь | Указывается имя пользователя для подключения к базе.
Пароль | Указывается пароль для подключения к базе.
Описание | Указывается произвольное описание для подключения.


Репликация

Отправить отзыв по этому разделу
Настройки>Веб-кластер>Репликация

Веб-кластер::Репликация

Описание

Страница Репликация (Настройки > Веб-кластер > [Группа] > Репликация) содержит информацию о существующих резервных базах данных, позволяет добавлять новые резервные базы и управлять текущими.

Внимание! Страница Настройки > Веб-кластер > Репликация позволяет просматривать все базы данных для всех групп, но через нее добавить slave базу данных нельзя.

Запуск репликации начинается с копирования содержимого базы данных. На время копирования публичная часть сайта будет закрыта, а административная нет. Любые неучтенные модификации данных в период копирования могут в дальнейшем повлиять на правильность работы сайта.

Репликация базы данных - это процесс создания и поддержания в актуальном состоянии её копии.

Репликация позволяет:

  • перенести часть нагрузки с основной базы данных (master) на одну или несколько ее копий (slave);
  • использовать копии в качестве горячего резерва.

Для создания резервной базы данных нажмите кнопку Добавить slave базу данных и следуйте указаниям мастера. После создания базы в меню действий выполните команду Начать использовать.

Внимание! Для репликации необходимо использовать разные сервера с быстрым каналом связи между собой.

Запуск репликации начинается с копирования содержимого базы данных. На время копирования публичная часть сайта будет закрыта, а административная нет. Любые неучтенные модификации данных в период копирования могут в дальнейшем повлиять на правильность работы сайта.

Примечание: Страница репликации недоступна для mssql и oracle версий.

Контекстная панель

Кнопка | Описание
Добавить slave базу данных | Добавление резервной базы данных.
Обновить | Обновление списка баз данных модулей.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

Таблица "Slave базы данных"

Поле | Описание
ID | Идентификатор базы данных.
Состояние | Состояние и время работы базы данных.
Название | Название базы данных.
Отставание (сек) | Отставание slave базы данных при большом количестве обновлений основной (master) базы данных, недостаточно быстром соединении между master и slave базами данных или недостаточной производительности slave базы данных. Максимально возможное время отставания slave базы данных от master, при котором slave база данных будет автоматически отключена для снижения риска рассинхрониизации данных, можно задать в настройках модуля.
Статус | Текущий статус базы данных.
Использовать (%) | Рекомендуемая доля (вес) нагрузки на базу данных для использования встроенным в продукт балансировщиком SQL.
Описание | Описание базы данных.
Сервер | Адрес сервера.
База данных | Название базы данных, содержащей таблицы модулей.
Пользователь | Учетная запись MySQL, под которой веб-кластер работает с базой данных модулей.

Смотрите также

  • Репликация (учебный курс "Администратор. Базовый")


Memcached

Отправить отзыв по этому разделу
Настройки>Веб-кластер>Memcached

Веб-кластер::Memcached

Описание

Страница Memcached (Настройки > Веб-кластер > Memcached) содержит информацию о существующих серверах memcached, позволяет подключать новые memcached-серверы и управлять существующими.

Для снижения нагрузки по синхронизации файлов рекомендуем использовать memcached. Основная его функция - сохранение кеша не в файлах, а в оперативной памяти.

Использование нескольких memcached-серверов (распределенный кеш данных) позволяет повысить надежность системы за счет устойчивости подсистемы кешировния к выходу из строя отдельных компонентов, повышает эффективность за счет централизованного использования кеша веб-приложением и обладает неограниченной масштабируемостью за счет добавления новых memcached-серверов.

Примечание: Для работы потребуется php расширение memcache.

Контекстная панель

Кнопка | Описание
Добавить | Добавление сервера memcached.
Обновить | Обновление списка серверов memcached.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

Таблица "Memcached-серверы"

Поле | Описание
ID | Идентификатор сервера.
Состояние | Состояние и время работы сервера.
Статус | Текущий статус сервера.
Использовать (%) | Рекомендуемая доля (вес) хранимого в данном сервере кеша.
Сервер | Адрес сервера.

Смотрите также

  • Memcached (учебный курс "Администратор. Базовый")


Группы серверов

Отправить отзыв по этому разделу
Настройки>Веб-кластер>Группы серверов

Веб-кластер::Группы серверов

Страница Управление веб-кластером (Настройки > Веб-кластер > Группы серверов) содержит список групп серверов, входящих в состав веб-кластера.

Группы используются для объединения "узлов" в рамках гео-кластера.

Контекстная панель

Кнопка | Описание
Добавить группу | Добавление новой группы серверов.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

Таблица "Группы серверов"

Поле | Описание
ID | Идентификатор группы.
Название | Название группы.

Смотрите также:

  • Группы серверов (учебный курс "Администратор. Базовый")


Сессии

Отправить отзыв по этому разделу
Настройки>Веб-кластер>Сессии

Веб-кластер::Сессии

По умолчанию данные о сессиях пользователей хранятся в файловой системе сервера. При использовании одного единственного веб-сервера такой способ хранения сессий наиболее удобен. Основной его плюс - наиболее высокая производительность. Однако при работе с несколькими веб-серверами возможны ситуации, когда один запрос пользователя (например, непосредственно авторизация) попал на один сервер, а следующий или какие-либо другие запросы - на другие серверы, где посетитель еще не будет авторизован. Подобные ситуации будут вызывать целый ряд неудобств для посетителей сайта. Пользовательская сессия должна быть "прозрачной" для всех серверов веб-кластера. Для этого используется единое централизованное хранилище для данных сессий - база данных.

Закладка "Хранение в базе данных"

Включение или отключение механизма хранения данных сессий пользователей в базе данных выполняется на странице Сессии (Настройки > Веб-кластер > Сессии) с помощью кнопки Включить хранение данных сессий в БД модуля (Отключить хранение данных сессий в БД модуля).

Внимание! При переключении режима хранения сессий все пользователи потеряют авторизацию (данные сессий будут уничтожены).


Веб-сервера

Отправить отзыв по этому разделу
Настройки>Веб-кластер>Веб-сервера

Веб-кластер::Веб-сервера

Описание

Страница Веб-сервера (Настройки > Веб-кластер > Веб-сервера) содержит список существующих веб-серверов и основную информацию о них. Станица носит информационный характер.

Использование нескольких веб-серверов для работы сайта означает, что любой запрос любого посетителя сайта может попасть на любой из узлов кластера, что позволяют распределить один сайт на несколько серверов, решая тем самым несколько задач: обеспечение высокой доступности сайта; его масштабирование в условиях возрастающей нагрузки; балансирование нагрузки, трафика, данных между несколькими серверами.

Примечание: На каждом из серверов необходимо настроить страницу, на которой будет отображаться статистика веб-сервера Apache (с помощью модуля mod_status [image]).

Настройки для "1С-Битрикс: Веб-окружение" подробно рассмотрены в Руководстве по настройке Веб-кластера [image].

Контекстная панель

Кнопка | Описание
Добавить новый веб-сервер | Переход к форме добавления веб-сервера.
Обновить | Обновление списка серверов.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

Таблица "Веб-серверы"

Поле | Описание
Меню действий Действия, которые можно произвести над группой:
  • Изменить - переход к форме Редактирование веб-сервера;
  • Удалить - удаление веб-сервера из списка.
ID | Идентификатор сервера.
Состояние | Состояние и время работы сервера.
Статус | Текущий статус сервера.
Название | Название сервера.
Сервер | Адрес сервера.
URL статуса | Путь к служебной статусной странице веб-сервера apache относительно корня сайта (mod_status).
Описание | Описание сервера.

Смотрите также

  • Веб-сервера (учебный курс "Администратор. Базовый")


Создание и редактирование веб-сервера

Отправить отзыв по этому разделу
Настройки>Веб-кластер>Создание и редактирование веб-сервера

Веб-кластер::Создание и редактирование веб-сервера

Форма используется для добавления веб-сервера в общий список серверов в котором отображаются его основные параметры и статистика.

Примечание: На каждом из серверов необходимо настроить страницу, на которой будет отображаться статистика веб-сервера Apache (с помощью модуля mod_status [image]).

Настройки для "1С-Битрикс: Веб-окружение" подробно рассмотрены в Руководстве по настройке Веб-кластера [image].

Контекстная панель

Кнопка | Описание
Список | Перехода на страницу Веб-серверы.

Закладка Веб-сервер

Редактирование параметров веб-сервера

Поле | Описание
Название | Указывается название веб-сервера.
IP адрес сервера | Указывается IP адрес веб-сервера.
Порт сервера | Указывается порт веб-сервера.
URL статуса | Указывается путь к служебной статусной странице веб-сервера apache относительно корня сайта (mod_status).
Описание | Указывается описание веб-сервера.


Лицензирование

Отправить отзыв по этому разделу
Настройки>Веб-кластер>Лицензирование

Веб-кластер::Лицензирование

Страница Список лицензируемых серверов веб-кластера (Настройки > Веб-кластер > Лицензирование) содержит информацию о лицензируемых серверах веб-кластера.

Лицензируются только сервера в редакциях "Энтерпрайз по подписке". В обычном коробочном "Энтерпрайз" количество серверов не ограничено.


Веб-сервисы. Описание модуля

С помощью модуля Веб-сервисы можно организовать систему веб-сервисов и SOAP.

Модуль включает в себя следующие компоненты 2.0:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
SOAP&WSDL сервер | webservice.server | Реализует конечную точку (EndPoint) для сконфигурированного веб-сервиса на основе SOAP/WSDL.
Веб-сервисы модуля статистики | webservice.statistic | Веб-сервис, отдающий статистические данные по сайту, например, для гаджета статистики для боковой панели OC Windows Vista.
Проверка аутентификации | webservice.checkauth | Возвращает данные по пользователю, если он правильно авторизован. Компонент может рассматриваться как пример реализации веб-сервиса, содержащего методы проверки авторизации пользователя и получения информации по авторизованному пользователю. (Компонент не описывается.)

Смотрите также:

  • Создание Windows-приложения для добавления новостей на сайт
  • Документация для разработчиков по модулю Веб-сервисы


Диск (КП). Настройки модуля

Модуль Диск предназначен для организации работы с документами. Рекомендуется к использованию вместо устаревшего модуля Библиотека документов [image].


Диск (КП). Настройки модуля

Настройки модуля.

Поле | Описание
Включить работу с документами через внешние службы (Google Docs, MS Office Online и другие) | Опция разрешает просмотр документов через сторонние серверы. Необходима регистрация вна этих сервисах. При включении опции данные отправляются во внешние службы. Учтите это в плане политики безопасности.
Автоматически подключать Диск группы при вступлении пользователя в группу | Автоматическое подключение диска к пользователям нужно далеко не всегда. Предпочтительнее чтобы пользователи сами решали нужно им такое подключение или нет.
Разрешить редактировать документы, которые участвуют в обсуждениях, задачах, комментариях или других событиях, всем участникам, по умолчанию | Автоматическое разрешение на редактирование не рекомендуется использовать при строгих требованиях по политике безопасности. При включении опции в каждом отдельном событии можно вручную разрешить редактирование документов.
Индексировать документы | Документы будут доступны в поиске по названию.
Индексировать контент документов | Документы будут доступны в поиске по контенту. Ресурсозатратная опция.
Максимальный размер индексируемого документа (Мб) | Ограничение на размер индексируемых документов. Снижает нагрузку на сервер при индексировании.
Просматривать документы с помощью Выбор сервиса для просмотра документов.
  • Битрикс24 - работа с файлами через внутренний инструмент просмотра. Файлы форматов pdf, mp3, txt, php, css, html, некоторые видео в формате mp4 и mov, а также изображения всех форматов просматриваются локально. Для просмотра документов всех остальных форматов используется облачный конвертер файлов. При этом на сервере файлы не хранятся, а только проходят конвертацию. Кроме того, они отправляются без каких-либо пользовательских данных и информация, откуда они приходят, не сохраняется.
    Чтобы данные при просмотре файлов не отправлялись на облачный сервис - удалите модуль Конвертер файлов (transformer). Но в таком случае конвертация файлов тоже не будет работать.
  • Google Docs - документы просматриваются с помощью сервиса Google.Drive. Для этого нужно настроить сервис и авторизоваться в аккаунте Google. Все документы при этом временно загружаются на Google.Drive, который привязан к аккаунту, и просматриваются с помощью инструментов сервиса.
  • Office365 - обработка подобная Google Docs, но с использованием продуктов Microsoft.
  • Google Viewer - для просмотра генерируется публичная ссылка, с помощью которой просматривается документ. После завершения просмотра эта ссылка автоматически удаляется системой. Скорость работы данного инструмента полностью зависит от Google Viewer. Если файлы открываются медленно или не открываются вовсе - проблемы с доступностью на стороне Google.
Поддержка скачивания файлов архивом: Все файлы в сообщении, задаче и так далее могут быть скачены одним архивом. Требуется установка на сервер модуля mod_zip [image].
Разрешить квотирование хранилищ | Опция включает квотирование хранилищ. Настройка производится через API [image].
Разрешить использовать публичные ссылки | Разрешает использование ссылок на сторонние ресурсы.
Максимальное количество записей в истории документа | Ограничение лога истории. Снижение нагрузки на сервер.
Блокировка документов
Включить возможность блокировки документов | Включает возможность блокировать документы (в контекстном меню в списке файлов).


Конвертер файлов

Модуль предназначен для конвертации загруженных файлов для просмотра их пользователями и отображения в виде иконок в рамках файловой структуры.


Настройки модуля

Форма настроек модуля Конвертер файлов (Настройки > Настройки продукта > Настройки модулей > Конвертер файлов) предназначена для задания параметров подключения серверной части модуля.

Поле | Описание | Комментарий
Путь для добавления команд на конвертацию файлов | Указывается URL серверной части (модуль transformercontroller) |
Публичный адрес сайта | Укажите URL по которому портал доступен из сети. |
Режим отладки | Чекбокс включения режима отладки | Если включен, то данные о запросах и отправляемых командах будут писаться в файл /bitrix/modules/transformer.log
Время установления соединения с контроллером, секунды | Параметр установления соединения с серверной частью (модуль transformercontroller) на открытие сокета и установление соединения. |
Время ожидания ответа от контроллера, секунды | Параметр установления соединения с серверной частью (модуль transformercontroller) на ожидание ответа от неё. |


Коннекторы для внешних мессенджеров (КП)

С помощью модуля Коннекторы для внешних мессенджеров можно организовать подключение различных внешних социальных сервисов для общения с помощью открытых линий.


Коннекторы для внешних мессенджеров (КП). Настройки модуля

Форма настроек модуля Коннекторы для внешних мессенджеров (Настройки > Настройки продукта > Настройки модулей > Коннекторы для внешних мессенджеров) предназначена для задания параметров модуля.

Закладка Настройки коннекторов мессенджеров

Форма позволяет изменить публичный адрес для доступа к порталу, включить режим отладки и выбрать коннекторы.

Поле | Описание
Публичный адрес сайта | Адрес, по которому будет обращаться внешний сервис к вашему порталу для вывода сообщений в открытую линию. Как правило, совпадает с реальным адресом портала. После соответствующих настроек роутера локальной сети может не совпадать с публичным адресом, но эти меры - крайность, в случае строгих требований по безопасности.
Режим отладки | Включает логгирование работы модуля в файле /bitrix/modules/imconnector_error.log. Примечание: В файл пишется только лог ошибок, включать данную опцию имеет смысл только для отладки, лог трассировки сообщений в этот файл не пишется.
Список используемых коннекторов | Выбираются коннекторы, которые будут использоваться для каналов открытых линий. По умолчанию включены все коннекторы.


Открытые линии (КП)

С помощью модуля Открытые линии можно организовать подключение различных внешних социальных сервисов для общения с помощью открытых линий.


Открытые линии (КП). Настройки модуля

Форма настроек модуля Открытые линии (Настройки > Настройки продукта > Настройки модулей > Открытые линии) предназначена для задания параметров модуля.

Закладка Настройки

Форма позволяет изменить публичный адрес для доступа к порталу и включить режим отладки.

Поле | Описание
Публичный адрес сайта | Адрес, по которому будет обращаться внешний сервис к вашему порталу для вывода сообщений в открытую линию. Как правило, совпадает с реальным адресом портала. После соответствующих настроек роутера локальной сети может не совпадать с публичным адресом, но эти меры - крайность, в случае строгих требований по безопасности.
Режим отладки | Включает логгирование работы модуля в файле /bitrix/modules/imopenlines.log. Примечание: В файл пишется только лог ошибок, включать данную опцию имеет смысл только для отладки, лог трассировки сообщений в этот файл не пишется.


Распознавание лиц (КП)

Внимание! Модуль отключён с апреля 2022 года.

Модуль распознавание лиц для Битрикс24.


Настройки модуля Распознавание лиц (КП)

Внимание! Модуль отключён с апреля 2022 года.

Настройки модуля Распознавание лиц находятся по адресу Настройки > Настройки продукта > Настройки модулей > Распознавание лиц.

Поле | Описание | Примечание
Закладка Настройки
Публичный адрес сайта | Прописывается адрес портала | Устанавливается автоматически, можно поменять.
Режим отладки | Включает режим отладки. В этом режиме каждое обращение записывается в лог. При включённой опции появляется дополнительное поле Долгое ожидание ответа. | Лог-файл расположен по пути: /bitrix/modules/faceid.log.
Долгое ожидание ответа | Данную опцию необходимо активировать, если из-за настроек окружения вы не получаете ответа от сервера |
Закладка Баланс и списания
Если функционал подключён, то будет отображаться статистика использования распознаваний и остаток средств


Сервер конвертации файлов

Модуль для выполнения конвертации файлов.


Настройки модуля

Страница настроек модуля (Настройки > Настройки продукта > Настройки модулей > Сервер конвертации файлов) предназначена для задания параметров подключения к севреру очередей и настройки работы самих очередей.

Закладки:

Общие настройки

Поле | Описание | Комментарий
Режим отладки | Чекбокс включения режима отладки | Если включен, то данные о запросах и отправляемых командах будут писаться в файлах: /var/log/rabbitmq/ и /var/log/transformer/
Время установления соединения при проверке лицензии | Параметр установления соединения с сервером проверки лицензий. |
Время ожидания ответа при проверке лицензии | Параметр установления времени ожидания ответа сервера проверки лицензий. |
Адреса через запятую, с которых должны обрабатываться запросы на конвертацию |  | Оставьте пустым, если адрес не должен проверяться.

Настройки RabbitMQ

Поле | Описание | Комментарий
Логин | Параметры авторизации и подключения к серверу |
Пароль |  |
Адрес |  |
Порт |  |
Виртуальный хост |  |

Настройка очередей

На этой закладке вы можете изменить значения по умолчанию количество обработчиков.

Статус

Информационная закладка показывает статус работы сервера. При использовании BitrixVM настройка сервера производится автоматически и статусы меняются после запуска виртуальной машины.

Дополнительно

  • Настройка роли Transformer (учебный курс)


Служба сообщений

С помощью модуля Служба сообщений можно осуществлять маркетинговую рассылку посредством SMS-сообщений. Для этого необходимо установить сам модуль и подключить хотя бы одну служб отправки SMS:

  • Компания SMS.RU
  • [ds]SMS-ассистент[/ds][di]Cервис для СМС-рассылки в Республике Беларусь.

    Подробнее в курсе Администратор. Модули [image].[/di]
  • Компания Twilio.com
  • Компания sms.edna.ru

Смотрите также:

  • Служба сообщений (учебный курс "Администратор. Модули")
  • Служба сообщений (документация по REST)


Служба сообщений. Настройки модуля

Форма настроек (Настройки > Настройки продукта > Настройки модулей > Служба сообщений) предназначена для задания параметров модуля.

Поле | Описание
Сколько дней хранить сообщения | Количество дней, в течение которого будут сохраняться сообщения.
Сколько сообщений отправлять за один хит | Количество писем, отправляемых за один хит.
Службы отправки SMS Из списка выбирается и привязывается сервис SMS-рассылки:
  • Компания SMS.RU
  • [ds]SMS-ассистент[/ds][di]Cервис для СМС-рассылки в Республике Беларусь.

    Подробнее в курсе Администратор. Модули [image].[/di]
  • Компания Twilio.com
  • Компания sms.edna.ru
Дневные лимиты отправки SMS Устанавливаются [dw]ограничения[/dw][di] [image] [/di] на отправку сообщений по каждому из сервисов.

Примечание: Лимиты индивидуально устанавливаются провайдером. Укажите их значения, и Битрикс24 использует данные при создании sms рассылок.

Также можно настроить правило повторной рассылки при достижении лимита.


Телефония

Модуль Телефония (voximplant) позволяет совершать входящие и исходящие звонки на вашем Битрикс24.

Форма настроек (Настройки > Настройки продукта > Настройки модулей > Телефония) предназначена для задания параметров модуля.

Поле | Описание
Имя аккаунта | Информационное поле, выводит имя аккаунта, используемое в системе. Имя необходимо для настроек интеграции с офисной [image] и облачной [image] АТС через SIP-коннектор.
Баланс | Информационное поле, выводит величину баланса. Баланс выводится для зон RU в рублях, для DE - EUR, все остальные зоны - USD.
Публичный адрес сайта | Вводится публичный адрес портала.
Режим отладки | Установка флажка включает вывод логов работы телефонии в файле /modules/voximplant.log


Облако 1С-Битрикс

Раздел административной части Облако 1С-Битрикс содержит набор облачных сервисов и позволяет:

  • включить и настроить поддержку CDN;
  • включить и настроить инспектирование работоспособности сайта;
  • создавать и просматривать резервные копии, которые хранятся в облаке.

Смотрите также:

  • Облако 1С-Битрикс (учебный курс "Администратор. Базовый")
  • Настройка CDN


Облако 1С-Битрикс. Настройки модуля

Форма настроек модуля Облако 1С-Битрикс (Настройки > Настройки продукта > Настройки модулей > Облако 1С-Битрикс) предназначена для задания общесистемных параметров модуля.

Закладка Настройки

Поле | Описание
Интервал расчётов | Указывается период времени, который будет использован для расчета и отображения информации на странице Инспектор сайтов (Настройки > Облако 1С-Битрикс > Инспектор сайтов). Примечание: Период будет изменен не сразу из-за кеширования.


Ускорение сайта CDN

Закладки

Описание

Ускорение сайта CDN (Настройки > Облачные сервисы Битрикс > Ускорение сайта (CDN)) позволяет загружать весь статический контент вашего сайта (картинки, файлы стилей css, скрипты js) через сеть дистрибуции контента (Content Delivery Network или Content Distribution Network, CDN [image]). Тем самым значительная часть ресурсов сайта загружается посетителем с ближайшего к нему сервера. Это позволяет увеличить скорость загрузки страниц до нескольких раз.

Внимание! Для работы с CDN лицензия сайта должна быть активной, а сайт доступен из интернета.

Примечание: Источником данных о статическом контенте, который автоматически будет загружаться в CDN, будет являться HTML, возвращаемый сервером.

Ускорение

Поле | Описание
Включить ускорение сайта | Опция позволяет включить поддержку CDN.

После включения поддержки CDN ссылки на статические файлы сайта (картинки, файлы стилей css, скрипты js) будут заменены. Вместо локальных URL'ов будут использоваться служебные имена серверов сети CDN.

Что ускорять

Поле | Описание
Шаблон сайта (рекомендуется включить) | Опция позволяет включить поддержку CDN для файлов шаблона сайта.
Контент сайта | Опция позволяет включить поддержку CDN для контента сайта (папка upload).

Сайты

На этой закладке можно указать, для каких сайтов загружать ресурсы и делать замену ссылок. Например, при использовании многосайтовости.

Поле | Описание
Административный раздел | Позволяет загружать статические файлы административного раздела в сеть CDN.
[название_сайта] | Сайт, для которого будет производиться загрузка статических файлов в сеть CDN.

Дополнительно

Поле | Описание
url сайта с которого CDN будет брать ресурсы (css, js, изображения и т.п.) | Указывается альтернативный источник оригинальных файлов, откуда забирают контент узлы CDN. По умолчанию используется адрес основного сайта. Это может быть полезно, например, в случае использования разных доменов.
Сайт работает по https | Обязательно отметьте, если сайт использует этот протокол.

Смотрите также

  • Ускорение сайта CDN (учебный курс "Администратор. Базовый")


Резервные копии

На странице Резервные копии (Настройки > Облако 1С-Битрикс > Резервные копии) представлен список резервных копий, хранящихся в облаке "1С-Битрикс".

Хранение резервных копий предоставляется для всех лицензий на "1С-Битрикс: Управление сайтом" (кроме редакции "Первый сайт") и доступно для сайтов с активной коммерческой лицензией (технической поддержкой). Для каждой лицензии будут храниться три последние резервные копии. Более старые копии автоматически удаляются. При превышении выделенного для лицензии места в облаке может сохраняться меньшее количество резервных копий (вплоть до нуля, если размер одного бекапа превысит лимит).

Все резервные копии сайта сохраняются только зашифрованными тем паролем, который вы укажете при выполнении резервного копирования. Компания "1С-Битрикс" не имеет доступа к содержимому резервных копий. Если вы забудете пароль, то восстановление резервной копии станет невозможным.

Контекстная панель

Кнопка | Описание
Выполнить резервное копирование | Создание резервной копии продукта. Перед созданием резервной копии выполняется шифрование архива.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

Список резервных копий

Колонка | Описание
Имя файла | Имя файла резервной копи.
Размер файла | Размер файла резервной копии.


Инспектор сайтов

Описание

На странице Инспектор сайтов (Настройки > Облако 1С-Битрикс > Инспектор сайтов) расположен инструмент, который проверяет доступность и работоспособность сайта и сообщает обо всех неполадках E-mail или push-уведомления для мобильных устройств.

Примечание: Проверка осуществляется со стороны серверов компании "1С-Битрикс", поэтому сайт должен быть доступен "снаружи".

Инспектор сайта отслеживает 4 параметра, очень важных для работы любого веб-проекта, и особенно интернет-магазина:

  • раз в 5 минут проверяет доступность сайта из двух географических точек;
  • раз в день проверяет срок действия домена.
    Инспектор сайта напомнит за 30 дней о необходимости продлить домен. Повторяться напоминания будут раз в неделю, пока домен не будет продлен;
  • раз в день проверяет срок SSL-сертификата;
  • раз в день проверяет срок действия лицензионного ключа.
    Инспектор сайта напомнит за 30 дней об окончании срока активности обновлений и технической поддержки для вашей лицензии.

Контекстная панель

Кнопка | Описание
Добавить сайт для инспектирования | Добавление сайта и настройка параметров его инспектирования. Примечание: Для корректной работы сервиса для инспектируемого сайта должен быть указан домен на странице Редактирования сайта (Настройки продукта > Сайты > Список сайтов > требуемый_сайт) или в поле URL сайта настроек Главного модуля (Настройки > Настройки продукта > Настройки модулей > Главный модуль).
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

Результаты инспектирования

Колонка | Описание
Домен | Инспектируемый сайт.
Результаты инспектирования | Информация о результатах инспекции.

Смотрите также

  • Инспектор сайтов (курс "Администратор. Базовый")


Параметры инспектирования

На этой странице можно произвести настройку параметров инспектирования сайта.

Закладка Параметры инспектирования

Поле | Описание
Отслеживать работоспособность сайта | Опция позволяет включить проверку доступности сайта из двух географических точек. Проверка проводится раз в 5 минут из двух географических точек.
Отслеживать срок регистрации домена | Опция позволяет включить проверку срока действия домена. Инспектор сайта напомнит за 30 дней о необходимости продлить домен. Повторяться напоминания будут раз в неделю, пока домен не будет продлен.
Отслеживать срок истечения лицензии 1С-Битрикс | Опция позволяет включить проверку срока действия лицензионного ключа. Инспектор сайта напомнит за 30 дней об окончании срока активности обновлений и технической поддержки для вашей лицензии.
Инспектировать домен по https | Опция позволяет включить проверку поддержки сайтом протокола https.
Отслеживать срок действия SSL сертификата | Опция позволяет включить проверку срока действия SSL-сертификата.
e-mail для оповещений | Указывается почтовый адрес, на которой будут приходить оповещения, в случае, если какая-либо из указанных выше проверок не пройдет. Кнопка Добавить позволяет добавить дополнительные почтовые адреса.


Облачные хранилища. Описание модуля

Модуль Облачные хранилища позволяет подключить к проекту поддержку "облачных" хранилищ файлов.

Подробно прочитать о работе модуля можно в учебном курсе [image].

Примечание: Просмотр файлов и папок, находящихся в контейнере облачного хранилища, осуществляется на странице Облачные хранилища (Контент > Облачные хранилища).

Смотрите также:

  • Создание подключения
  • Перенос файлов в облако и обратно
  • Что можно сделать с файлами в облачном хранилище


Облачные хранилища

Отправить отзыв по этому разделу
Настройки>Облачные хранилища

Облачные хранилища::Облачные хранилища

Контекстная панель

Страница Облачные хранилища (Настройки > Облачные хранилища) содержит информацию о существующих облачных хранилищах, позволяет подключать новые контейнеры для хранения файлов и управлять текущими.

Кнопка | Описание
Добавить | Переход к форме создания нового подключения к облачному хранилищу.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

Список облачных хранилищ

Поле | Описание
Меню действий Доступные действия:
  • Изменить - переход к форме редактирования подключения к облачному хранилищу;
  • Переместить файлы в облачное хранилище - перенос файлов с локального хранилища (хостинг, на котором расположен проект) в облачное согласно установленным правилам (задается в форме редактирования подключения к облачному хранилищу);
  • Вернуть файлы из облачного хранилища - перенос файлов из облачного хранилища в локальное (хостинг, на котором расположен проект);
  • Деактивировать - перевод контейнера облачного хранилища в неактивное состояние. В этом случае данные будут доступны для чтения, но запись будет невозможна;
  • Удалить - удаление подключения к облачному хранилищу.
Сортировка | Индекс сортировки.
ID | Идентификатор контейнера.
Активность | Признак активности контейнера облачного хранилища.
Файлов | Количество файлов в контейнере.
Объем | Объем данных в контейнере облачного хранилища.
Режим | Режим работы контейнера (чтение/запись).
Сервис | Поставщик услуг облачного хранения.
Контейнер | Название контейнера, в котором хранятся файлы.


Создание/редактирование подключения к облачному хранилищу

Отправить отзыв по этому разделу
Настройки>Облачные хранилища>Создание/редактирование подключения к облачному хранилищу

Облачные хранилища::Создание/редактирование подключения к облачному хранилищу

Контекстная панель

Форма используется создания или изменения параметров подключения и использования облачного хранилища.

Кнопка | Описание
Список | Переход на страницу Облачные хранилища.

Закладка Подключение

Настройка параметров подключения и использования облачного хранилища.

Поле | Описание
ID | Идентификатор контейнера облачного хранилища файлов.
Активность | Признак активности контейнера облачного хранилища файлов. Если контейнер не активен, то старые данные будут читаться из него, а новые будут сохраняться на хостинге, на котором расположен проект.
Сортировка | Задается относительный "вес", влияющий на положение контейнера в списке.
Провайдер Выбирается поставщик услуг облачного хранения файлов:
  • Amazon Simple Storage Service;
  • Google Storage;
  • OpenStack Object Storage;
  • Rackspace Cloud Files;
  • Clodo.ru;
  • Selectel;
  • HotBox;
  • Yandex Object Storage;
  • S3 compatible storage – другие S3-совместимые хранилища.
Регион | Выбирается регион, в котором географически располагаются сервера (значения поля зависят от выбранного провайдера).
[дополнительные_поля_для_доступа_к_сервису] В зависимости от провайдера, в полях указываются параметры доступа к сервисам облачного хранения файлов. Например: Ключ доступа, Секретный ключ.

Примечание: Для некоторых провайдеров под полями расположена краткая инструкция по подключению.
Контейнер | Задается уникальное название контейнера. По умолчанию в поле уже указано название.
Только для чтения | При отмеченной опции контейнер будет использоваться в режиме чтения. Новые файлы будут сохраняться не в контейнере, а на хостинге с проектом.
Каноническое имя домена (CNAME) | Указывается каноническое имя домена.

Закладка Правила

Настройка правил для отбора файлов в облачное хранилище.

Поле | Описание
Список модулей | Список расширений | Список размеров |
[1] | [2] | [3] | [4]
Поле | Описание
[1] Список модулей | Указывается идентификатор модуля. Например: iblock, advertising. Если параметр не задан, то под действие правила подпадают файлы любых модулей.
[2] Список расширений | Указываются расширения файлов для хранения в облачном хранилище. Например: gif, png, jpeg, jpg. Если не задано, то под действие правила подпадают файлы с любым расширением. Список является нечувствительным к регистру.
[3] Список размеров | Задается размеров файлов. Допустимо использовать суффиксы, такие как: K, M или G. Так же возможно задавать диапазоны размеров. Например: 1K-1M, 2.3M-. Если параметр не задан, то под действие правила подпадают файлы любого размера.
[4] кнопка Х | Кнопка, позволяющая удалить правило.
Добавить новое правило | Ссылка, позволяющая добавить новое правило отбора файлов в облачное хранилище.

Смотрите также

  • Создание подключения (учебный курс Администратор.Базовый


AD/LDAP интеграция. Описание модуля

Описание

При интеграции сайта с информационной системой организации может возникнуть потребность в разграничении прав доступа сотрудников компании к ресурсам сайта и его управлению. Стандартным решением данной задачи является создание групп пользователей сайта с различным уровнем прав и добавление в эти группы сотрудников организации. В этом случае администратор может столкнуться с необходимостью дублирования уже существующих групп пользователей корпоративной сети в системе управления сайтом с последующим распределением сотрудников по этим группам, для наделения их соответствующими правами на доступ и управление сайтом. При этом, чтобы изменить уровень прав или добавить нового пользователя одновременно в корпоративной сети и в системе управления сайтом, будет необходимо выполнить настройку дважды: изменить/создать бюджет пользователя в корпоративной сети и выполнить ту же операцию в системе управления сайтом.

Модуль AD/LDAP интеграция позволяет интегрировать продукт "1С-Битрикс: Управление сайтом" с корпоративными сетями, построенными с использованием Microsoft Windows Server 2000/2003/2008, Unix и Novell.

С помощью модуля AD/LDAP интеграция, поставляемого компанией "1C-Битрикс" для продукта "1С-Битрикс: Управление сайтом", можно установить соответствие между группами пользователей корпоративной сети и группами пользователей системы управления сайтом, что позволит организовать централизованное управление всеми группами пользователей корпоративной информационной системы.

В разделе приводится описание, основные возможности и механизм работы модуля AD/LDAP интеграция системы "1С-Битрикс: Управление сайтом". Рассматривается механизм настройки модуля и задания соответствий групп пользователей сайта и корпоративной сети.

Подробнее прочитать о работе модуля можно из учебного курса [image].

Смотрите также

  • Регистрация сервера
  • Настройка NTLM авторизации со стороны продукта
  • Импорт пользователей из LDAP-directory


AD/LDAP интеграция. Настройки модуля

Закладки

Форма настроек модуля AD/LDAP интеграция (Настройки > Настройки продукта > Настройки модулей > AD/LDAP интеграция) предназначена для задания общесистемных параметров модуля.

Настройки

Закладка предназначена для настройки общих параметров модуля.

Поле | Описание
E-mail для пользователей, у которых он не указан | Задается e-mail для пользователей, не указавших его, например, no@email.
Использовать NTLM авторизацию | При отмеченной опции будет использоваться NTML авторизация. Для работы NTLM авторизации требуется выполнить настройку соответствующих модулей веб-сервера, а также задать домены для NTLM авторизации в настройках AD-серверов на портале.
Текущий логин пользователя NTLM авторизации (домен\логин) | Выводится автоматически определяемый текщий логин пользователя NTML авторизации.
Имя переменной PHP, в которой хранится логин пользователя NTLM (обычно REMOTE_USER) | Указывается название переменной PHP, в которой будет храниться логин пользователя, использующего NTML авторизацию.
Сервер домена по умолчанию | Указывается сервер домена, который будет использоваться по умолчанию для NTML авторизации.
Создавать новых пользователей при первой успешной авторизации | Указывается, создавать или нет новых пользователей при первой успешной авторизации. Работает и для NTML авторизации.
Проверять авторизацию на всех доступных ldap серверах, если в логине не указан префикс | При отмеченной опции будет производиться попытка авторизации на всех доступных ldap-серверах, если указан логин без префикса.
Создавать пользователя, если пользователь с таким логином уже существует | Указывается, будет ли создаваться второй пользователь, если при импорте обнаруживается пользователь с таким логином.
Переадресация Ntlm авторизации на порты 8890 8891
Включить переадресацию NTLM авторизации | При отмеченной опции будет включена переадресация NTLM авторизации на 8890 и 8891 порты.
Ограничить NTLM переадресацию следующей подсетью | Указывается подсеть, NTLM авторизацию пользователей которой, необходимо переадресовывать. Например: 192.168.1.0/24 или 192.168.1.0/255.255.255.0. Можно указать несколько диапазонов через точку с запятой (;). Если поле оставить пустым, тогда переадресация будет работать для всех пользователей.

Доступ

Закладка позволяет настроить права на доступ к модулю для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю AD/LDAP интеграция:
  • [D] закрыт - запрет на доступ;
  • [R] просмотр всех данных модуля - разрешается только просмотр всех данных модуля;
  • [W] запись - полный доступ к ресурсам модуля.
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.


Список серверов

Закладки

Страница AD/LDAP (Настройки > AD/LDAP) содержит информацию о существующих корпоративных серверах, позволяет создавать новые корпоративные серверы и управлять существующими.

Форма поиска

Поиск серверов в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Название | Поиск сервера по его названию. Поле присутствует, даже если фильтр свернут.
ID | Поиск сервера по его идентификатору.
Активный | Поиск можно задать по активным, неактивным или всем серверам.

Чтобы отобрать серверы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех серверов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания записи о новом сервере.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список серверов

Поле | Описание
Колонка флажков | Выбор серверов, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над сервером:
  • Изменить параметры сервера - переход к форме редактирования параметров сервера;
  • Удалить - удаление записи сервера.
ID | Идентификатор сервера в системе.
Дата изм. | Дата и время последнего изменения записи.
Название | Название сервера.
Акт. | Признак активности сервера. Если сервер неактивен, то он недоступен.
UTF-8 | Признак использования AD\LDAP сервером кодировки UTF-8.
Симв.код | Символьный (мнемонический) код сервера (префикс при авторизации).
Сервер | Адрес корпоративного сервера.
Синхронизировать | Признак использования периодической синхронизации сервера.
Период синхр-ции | Значение периода синхронизации в часах.
Последняя синхр-ция | Дата и время последней синхронизации сервера.


Создание и редактирование сервера

Закладки

Форма создания/редактирования сервера предназначена для настройки параметров существующего или вновь создаваемого сервера. Для удобства работы форма создания/редактирования сервера разделена на несколько закладок. На каждой закладке выполняется определённая группа действий по настройке сервера.

Каждая запись регламентирует доступ к одному корню дерева каталогов. Если сведения о группах пользователей корпоративной сети хранятся в базах данных нескольких серверов или в нескольких базах данных одного сервера, то следует создать несколько записей, регламентирующих доступ к ним.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком серверов.
Создать | Переход к форме создания нового сервера. Кнопка отображается при редактировании существующего сервера.
Удалить | Удаление редактируемого сервера. Кнопка отображается при редактировании существующего сервера.

Сервер

Закладка предназначена для настройки общих параметров сервера.

Поле | Описание
Код | Идентификатор сервера. Поле отображается при редактировании существующего сервера.
Последнее изменение | Дата и время последнего изменения записи. Поле отображается при редактировании существующего сервера.
Активен | При отмеченной опции сервер будет активным.
*Название | Указывается произвольное название сервера для обращения к нему в списке.
Описание | Произвольное описание сервера.
Домен для NTLM авторизации | Указывается в виде <домен\логин> (задается на латинице).
Текущий логин пользователя NTLM авторизации (домен\логин) | Указывается пользователь, если зашли авторизованными через NTLM.
*Сервер:порт | Указывается адрес корпоративного сервера с базой данных групп пользователей и порт, по которому к нему будет осуществляться обращение (389 порт является стандартным для обращения к LDAP-серверу).
Тип подключения | Выбор протокола: с шифрованием или без.
*Логин пользователя с правами доступа на чтение к дереву (в формате логин@домен или домен\логин) | Указывается логин для выполнения административного входа на сервер в виде логин@домен или <домен\логин> (задается на латинице).
*Пароль | Указывается пароль для выполнения административного входа на сервер.
Кнопка Проверить | Кнопка Проверить служит для проверки введенных выше данных и установления пробного соединения с сервером. Если проверка была выполнена успешно, то сервер вернет список доступных корней деревьев. Если же при проверке произошла ошибка, то вверху страницы будет выведена надпись красного цвета с указанием причины ошибки.
*Корень дерева (base DN) | Указывается корень дерева каталогов, в котором будет осуществляться поиск бюджетов авторизуемых пользователей (список доступных корней деревьев каталога появивится после успешной проверки).
Количество секунд для ожидания результатов поиска | Установка времени ожидания. По умолчанию стоят рекомендуемые параметры, изменения этих параметров должно быть осознанным. Что означают эти таймауты [image] .
Таймаут для синхронных вызовов API для OpenLDAP
Сетевой таймаут
Максимальное количество объектов, возвращаемых при одном поиске | Указывается максимальное количество записей, получаемых за один запрос. Примечание: Данное поле доступно только для php версии 5.4 и выше.

* - поля, обязательные для заполнения.

Настройка полей

Закладка предназначеня для настройки соответствий полей, выбираемых при импорте.

Поле | Описание
Параметры схемы сервера (AD \ LDAP)
В секции указываются значения параметров для схемы данных бюджетов пользователей, хранимых на сервере. Стандартные значения данных параметров как для LDAP, так и для AD сервера подставляются в поля формы автоматически. Выбор типа сервера осуществляется путём нажатия ссылки с соответствующим названием в заглавии раздела (AD \ LDAP). Если стандартные значения данных параметров были изменены на корпоративном сервере, то соответствующие изменения нужно внести в значения параметров в форме. В полях фильтров пользователей и групп допускается до 2048 символов.
Соответствие полей пользователя и атрибутов LDAP
В настройках LDAP-сервера указываються минимально необходимые поля, такие как Активность, Имя, Фамилия, E-Mail, т.е. поля которые необходимо постоянно переносить (синхронизировать из Active Directory). Если необходимо добавить поля, то воспользуйтесь ссылкой [добавить...], для удаления - ссылкой [удалить]. Остальные поля можно настроить при импорте в форме импорта пользователей в закладке Настройка полей.
Отделы и структура компании
Секция отображается если установлен модуль Intranet.
Импортировать структуру компании из AD | Опция позволяет импортировать структуру компании из AD при синхронизации данных пользователей корпоративной сети.
Подразделение, внутрь которого будет импортирована структура компании | Указывается подразделение, внутрь которого будет импортирована структура компании с AD-сервера. Если выбрать нет, то структура будет импортироваться в корень дерева подразделений.
Импортировать в структуру компании пользователей, у которых не указано подразделение | Опция позволяет импортировать пользователей, у которых не указано подразделение в Active Directory.
Назначать руководителей подразделений | Возможность отключить назначение руководителей подразделений автоматически.
Название подразделения по умолчанию (пустое значение соответствует корневому подразделению данного сервера) | Задается название подразделения к которому будут причислены пользователи, у которых не указано подразделение.

Группы

Закладка прежназначена для загрузки групп пользователей корпоративной сети и сайта в Таблицу соответствий и задание соответствий для этих групп.

Если список групп на сервере пуст, то необходимо нажать кнопку Обновить список групп, при этом будет выполнена проверка параметров, заданных на закладке Сервер. После обновления списка групп отобразится таблица соответствий групп пользователей корпоративной сети и сайта.

Поле | Описание
Группа на удаленном сервере | Указываются группы пользователей корпоративной сети.
Локальная группа | Указываются группы пользователей сайта, которые ставятся в соответствие группам пользователей корпоративной сети.
Удалить | Если напротив строки таблицы соответствий групп установлен флаг Удалить, то вся строка будет удалена.
Кнопка Еще | Служит для добавления пустых строк в таблицу соответствий групп пользователей.
Отмеченные ниже группы не участвуют в импорте пользователей | Выбор групп пользователей, не участвующих в импорте.

Синхронизация

Закладка предназначена для настройки параметров синхронизации сервера.

Поле | Описание
Последняя полная синхронизация была выполнена | Дата и время последней синхронизации сервера. Поле отображается при редактировании существующего сервера.
Создавать несуществующих пользователей | Опция позволяет синхронизировать только тех пользователей, которые уже есть, не добавляя новых.
Выполнять периодическую полную синхронизацию | При отмеченной опции будет выполняться периодическая полная синхронизации сервера.
Период, каждые | Указывается значение периода синхронизации в часах.
LDAP атрибут с датой изменения | Указывается LDAP атрибут с датой изменения для ведения лога изменений.

Смотрите также

  • Регистрация сервера (учебный курс "Администратор. Базовый")


Перевод. Описание модуля

Все сообщения (заголовки таблиц, ссылки, текст кнопок и т.п.), используемые в системе, хранятся в специальных файлах. Для удобства перевода данных файлов для нескольких языков в комплект поставки системы входит модуль Перевод.

В комплект поставки системы входит полный набор файлов для русского и английского языков.

В модуле Перевод используются следующие термины:

  • Языковой файл - файл, расположенный в каталоге с именем вида /lang/. Данный каталог может быть расположен в любом месте в дереве каталогов сайта. Идентификатор языка задается на странице Языки интерфейса единожды.

  • Языковое сообщение - группа фраз на разных языках, имеющая один смысл. У каждого языкового сообщения есть свой идентификатор.

Пример сообщения

Сущность | Значение
Текст на русском языке | Версия системы "1C-Битрикс: Управление сайтом"
Текст на английском языке | Bitrix Site Manager Version


Перевод. Настройки модуля

Закладки

Форма настроек модуля Перевод (Настройки > Настройки продукта > Настройки модулей > Перевод) предназначена для задания общесистемных параметров модуля.

Настройки

Поле | Описание
Ограничить области перевода | Указываются [dw]пути к папкам[/dw][di] [image] [/di] через запятую, с которыми разрешено работать через модуль. Это позволяет начинать просмотр файлов сразу из [dw]указанной папки[/dw][di] [image] [/di], а не от корня сайта, то есть без лишних переходов по папкам открывать просмотр в нужной папке.
Добавить на панель инструментов кнопку "Выводить языковые файлы" | При отмеченной опции на панель инструментов будет выведена кнопка Переводы. При выборе пункта меню Выводить языковые файлы кнопки Переводы внизу страницы сайта будут выведены адреса всех языковых файлов, используемых на данной странице.
Делать резервную копию редактируемых файлов | При отмеченной опции при изменении файла перевода будет создаваться его резервная копия.
Папка для резервных копии редактируемых файлов | Указывается папка, в которой будут храниться резервные копии редактируемых файлов.
Сортировать фразы в языковом файле при сохранении по кодам фраз | Поле предназначено для разработчиков. При отмеченной опции фразы в языковом файле сортируются при сохранении по [dw]кодам фраз[/dw][di]Языковое сообщение - группа фраз на разных языках, имеющая один смысл. Список сообщений в файле хранится в следующем виде: Подробнее в курсе Разработчик Bitrix Framework [image] .[/di].
Не выполнять сортировку фраз для языков | Выбираются языки, для которых не требуется выполнять сортировку фраз (для выбора нескольких языков необходимо зажать кнопку Ctrl). Функция работает совместно с Сортировать фразы в языковом файле при сохранении по кодам фраз.
Символ разделитель полей в экспортируемых CSV файлах | Выбор символа разделителя полей в файлах CSV при экспорте.
Папка для экспортируемых файлов | Указывается, куда будут складироваться собранные языковые пакеты (tar.gz).

Доступ

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право по умолчанию.
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Перевод:
  • [D] закрыт - запрет на доступ;
  • [R] просмотр всех данных модуля - разрешается только просмотр всех данных модуля;
  • [W] запись - полный доступ к ресурсам модуля.
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.


Просмотр файлов

На странице Перевод языковых файлов (Настройки > Локализация > Просмотр файлов) отображается структура каталогов, содержащих языковые файлы, в порядке расположения на диске. Для навигации по структуре каталогов можно пользоваться:

  • ссылками на именах каталогов;
  • полем Фильтр+поиск для фильтрации и поиска файлов.

Контекстная панель

Кнопка | Описание
Фильтр + поиск | В поле можно указывать как путь к нужному каталогу, так и различные настройки фильтра.
Список действий Выпадающий список со следующими действиями:
  • Показать общее количество фраз;
  • Показать общее количество языковых файлов;
  • Показать количество непереведенных фраз;
  • Показать количество файлов без переводов;
  • Скрыть папки без языковых файлов;
  • Показать ссылки на файлы без переводов.
Индексировать По нажатию кнопки выполняется обновление индекса фраз. Доступен выбор языков, для которых требуется выполнить операцию индексирования.
Процесс индексации занимает продолжительное время. Его можно остановить при помощи кнопки Остановить.
Кнопка экспорта/импорта По нажатию кнопки доступны два действия:
  • Выгрузить сообщения в CSV;
  • Импортировать сообщения из CSV.

Фильтр

Поле | Описание
Имя папки | Название папки
Имя файла | Название файла
[dw]Код фразы[/dw][di]Языковое сообщение - группа фраз на разных языках, имеющая один смысл. Список сообщений в файле хранится в следующем виде:

Подробнее в курсе Разработчик Bitrix Framework [image].[/di] 		Код фразы.
Как выполнять поиск кода фразы. Множественный выбор. Доступны варианты:
  • с учетом регистра
  • по точному соответствию
  • находится в начале
  • находится в конце
Найти фразы по списку кодов | Указываются фразы для поиска по списку кодов
Исключить фразы по списку кодов | Исключить фразы для поиска по списку кодов
Фраза | Указывается конкретная фраза
Язык | Выбирается язык из выпадающего списка
Как выполнять поиск фразы Множественный выбор. Доступны варианты:
  • с учетом регистра
  • по точному написанию слова
  • по точному соответствию фразе
  • находится в начале
  • находится в конце
Найти файлы по списку путей | Указывается список путей для поиска файлов
Исключить файлы из списка путей | Указывается список путей для исключения при поиске файлов

Список файлов

Поле | Описание
Колонка флажков | Поле предназначено для выбора разделов, к которым предполагается применить какое-либо правило или действие.
Действия Доступны следующие действия:
  • для папки:
    • Перейти к папке.
  • для файла:
    • Редактировать сообщения;
    • Показать PHP код;
    • Редактировать PHP.
Имя файла/папки | Название папки или файла.
Полный путь | Полный путь до папки или файла от корневого каталога.
Код фразы | Поле предназначено для разработчиков.
Языки | В списке показываются выбранные языки. При этом символом * отмечен текущий язык интерфейса.

Для каждой папки и файла выводится статистика переведенных и непереведенных языковых фраз. Количество непереведенных фраз для соответствующего языка отображается красным цветом, например:

Нажатие на ссылку на языковом файле приведет к открытию страницы для редактирования языкового файла.

Групповые действия

Действие | Описание
Экспортировать выделенные | Отмеченные файлы будут экспортированы в файл CSV.
Удалить фразы, которых нет на текущем языке | В выделенных каталогах удаляет фразы, которые нет на текущем языке.

Форма "Выгрузить
сообщения в CSV"

Поле | Описание
Обработка файлов Выберите способ выгрузки языковых файлов:
  • Выгрузить только непереведенные фразы - будут выгружены только непереведенные языковые файлы и сообщения.
  • Сконвертировать кодировку в UTF-8 - языковые файлы и сообщения будут сконвертированы в кодировку UTF-8.
  • Выберите языки для выгрузки - выбираются из списка нужные языки (для выбора нескольких языков зажмите клавишу Ctrl), либо вариант Все;
  • Выгрузить сообщения только для файлов и папок - В поле указываются полные пути файлов и папок, из которых нужно выгрузить сообщения.
Кнопка Экспортировать | Служит для запуска процесса экспорта языковых файлов.
Кнопка Остановить | Служит для остановки процесс экспорта (активна во время экспорта).

Форма "Импортировать
сообщения из CSV"

Поле | Описание
Файл CSV | С помощью кнопки Выберите файл укажите файл, из которого будет осуществляться импорт данных.
Укажите кодировку файла | Из выпадающего списка выберите нужную кодировку файла.
Укажите как добавлять фразы Выберите способ обработки языковых файлов:
  • добавлять только новые переводы - будут добавлены только новые языковые файлы и сообщения;
  • обновить только фразы, найденные в csv-файле - будут только обновлены существующие языковые файлы и сообщения;
  • добавлять новые переводы и обновить фразы, найденные в csv-файле - будут как добавлены новые языковые файлы и сообщения, так и обновлены существующие.
Индексировать загруженные фразы | Отметьте, если загруженные фразы необходимо сразу индексировать.
Кнопка Импортировать | Служит для запуска процесса импорта языковых файлов.
Кнопка Остановить | Служит для остановки процесса импорта языковых файлов.


Перевод сообщений

На странице Перевод сообщений (Настройки > Локализация > Просмотр файлов и открыт некоторый файл) показаны языковые сообщения для языков, загруженных в систему. Вы можете редактировать языковые сообщения для показанных языков, а также удалять сообщения, установив флаг удалить.

Контекстная панель

Кнопка | Описание
Путь к файлу | При нажатии на имя папки происходит переход к списку файлов языковых сообщений в этой папке.
Показать все сообщения | Отображать все сообщения.
Показать только непереведенные | Отображать только непереведенные сообщения.
Показать PHP код | Переход на страницу перевода с показом ее PHP-кода.
Редактировать PHP | Переход к редактированию PHP-кода страницы перевода.
Выгрузить сообщения в CSV | Выгрузка сообщений языкового файла в формате CSV.

Форма "Перевод сообщений"

Поле | Описание
Имя файла | Имя файла языковых сообщений.
Полный путь | Полный путь к файлу.
Всего сообщений | Количество языковых сообщений в файле.
Количество фраз | Общее количество сообщений для каждого языка, а также количество непереведенных (при наличии).
Список сообщений
ID | Идентификатор языкового сообщения.
Удалить | Чтобы удалить языковое сообщение, установите флаг в это поле и нажмите кнопку Применить.
[язык] Текст языкового сообщения для каждого языка.

В исходных строках сообщений возможно наличие шаблонов вида "#ID#", "#COUNT#". Если в оригинале подобные шаблоны присутствуют, в переводе их также необходимо сохранить. В момент использования данного сообщения шаблон будет заменен на конкретное значение.

Важно! Использование каких-либо PHP команд в языковых сообщениях запрещено. Однако, допустимо использование всех HTML-тегов.
Удалить сообщения Доступны на выбор два варианта:
  • Удалить все сообщения - будут удалены все сообщения в файле;
  • Удалить сообщения, перевод которых отсутствует для текущего языка - будут удалены только те сообщения, перевод у которых отсутствует для текущего языка (установленного в интерфейсе).
Для применения выбранного действия нажмите кнопку Применить.


Выгрузка и загрузка

Закладки

На странице Выгрузка и загрузка (Настройки > Локализация > Выгрузка и загрузка) осуществляется выгрузка и загрузка файлов локализации.

Сбор переводов

Поле | Описание
Выберите язык для сборки* | Выбирается язык локализации для выгрузки.
Введите дату сборки (YYYYMMDD)* | Указывается дата сборки в формате YYYYMMDD. Считается версией архива.
Сконвертировать в кодировку | Все языковые фразы в файлах локализации будут сконвертированы в национальную кодировку, указанную ниже.
Выберите кодировку | Указывается кодировка, в которую будут сконвертированы файлы локализации.
Упаковать файлы (tar.gz) | Все файлы локализации при выгрузке будут упакованы в архив .tar.gz.

Загрузка переводов

Поле | Описание
Выберите файл (tar.gz)* | Выбирается архив с локализацией для загрузки в систему (максимальный размер закачиваемого файла - 32 МБ).
Выберите язык для сборки (если язык отсутствует в списке, то сначала добавьте его)* | Выбирается язык сборки. Если в системе нет необходимого языка интерфейса, то с помощью ссылки добавьте осуществляется переход на страницу Добавление языка интерфейса.
Локализация в кодировке | Все языковые фразы локализации в архиве были подготовлены в национальной кодировке, указанной ниже.
Выберите кодировку | Выберите кодировку загружаемого файла.
Обновить локализацию в публичной части | Указывается, надо ли обновить локализацию в публичной части сайта.

* - Поля, обязательные для заполнения.


XMPP сервер (КП). Описание модуля

Модуль XMPP сервер предназначен для организации общения и учета присутствия сотрудников корпоративного портала, использующих Jabber-клиенты. Это можно делать только на выделенном сервере или на виртуальном выделенном сервере (VPS).

XMPP (англ. eXtensible Messaging and Presence Protocol — расширяемый протокол обмена сообщениями и информацией о присутствии, известный как Jabber) - это основанный на XML открытый, свободный для использования протокол для мгновенного обмена сообщениями и информацией о присутствии в режиме околореального времени. Протокол помимо передачи текстовых сообщений поддерживает передачу голоса и файлов по сети.

Смотрите также:

  • Настройка сервера
  • Управление сервером
  • Проблемы и решения


XMPP сервер (КП). Настройки модуля

Закладки

Настройки

Форма настроек модуля XMPP сервер (Настройки > Настройки продукта > Настройки модулей > XMPP сервер) предназначена для задания общесистемных параметров модуля.

Поле | Описание
Домен | Указывается домен вашего корпоративного портала.
Слушается | Задается IP адрес, который будет слушать XMPP сервер. Как правило, должно быть установлено значение 0.0.0.0
Язык | Указывается язык, в котором происходит обмен с XMPP сервером. В текущей версии должен быть en.
Путь к php Указывается путь к интерпретатору PHP. Например: C:\php\php.exe.

Примечание: для работы XMPP сервера необходима версия PHP не ниже 5.0.
Путь к XMPP серверу | Указывается путь к XMPP серверу. По умолчанию поле содержит ./bitrix/modules/xmpp/xmppd.php. Если размещение файлов сервера было изменено, то укажите новый путь.
Уровень логирования Задайте уровень логирования сервера:
  • 0 – максимально подробный уровень ведения лога;
  • 10 – минимально подробный уровень ведения лога.
При нормальной работе сервера достаточно вести лог с уровнем 5.
Запустить SSL | Укажите запускать SSL или нет при запуске XMPP сервера. При неустойчивой работе сервера SSL рекомендуется отключить.
Инфоблок для записи присутствия | Указывается инфоблок, в котором будет сохраняться история состояний (статусов) пользователя в формате календаря отсутствия. Название элемента инфоблока будет соответствовать статусу пользователя.
Формат отображения имени | Выбирается формат в котором будет отображаться имя пользователя.

Социальная сеть

На этой закладке можно указать пользователя от имени которого будет производиться рассылка системных сообщений. Например, рассылка новостей портала.
Поле | Описание
ID пользователя-отправителя для системных сообщений Выбирается тип пользователя, от которого будет производиться рассылка сообщений:
  • От имени пользователя Jabber;
  • От имени пользователя сайта.
В соответствии с выбранной опцией активным становится соответствующее поле, расположенное ниже.
Jabber ID отправителя для системных сообщений | Указывается Jabber идентификатор пользователя.
ID пользователя-отправителя для системных сообщений | Указывается идентификатор пользователя на сайте.

Доступ

Закладка позволяет настроить права на доступ к модулю для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю XMPP сервер:
  • [D] закрыт - запрет на доступ;
  • [R] просмотр всех данных модуля - разрешается только просмотр всех данных модуля;
  • [W] запись - полный доступ к ресурсам модуля.


Сервер XMPP

Закладка "XMPP сервер"

На странице XMPP сервер (Настройки > XMPP > Сервер XMPP) вы можете управлять XMPP сервером (запустить, запросить, остановить, очистить кеш) и просмотреть основную информацию о нем.

Поле | Описание
Сервер запущен | Отображается статус сервера: запущен (Да) или остановлен (Нет).
Пользователей на сайте | Отображается информация о количестве пользователей на сайте.
Соединений XMPP сервера | Отображается информация о количестве соединений XMPP сервера.


Настройки продукта (главный модуль). Описание

Главный модуль обеспечивает общее функционирование системы, взаимодействие всех модулей продукта и позволяет создавать, поддерживать и управлять неограниченным числом сайтов.

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Рабочий стол | desktop | Позволяет создать настраиваемый рабочий стол с использованием разнофункциональных гаджетов.
Форма обратной связи | main.feedback | Выводит форму для отправки сообщения с сайта на E-mail.
Элемент управления "Календарь" | main.calendar | Используется для ввода даты/времени.
Элемент управления "Часы" | main.clock | Служит для удобного ввода времени с использованием часов.
Элемент управления "Палитра" | main.colorpicker | Служит для удобного ввода таблицы выбора цвета.
Журнал изменений | event_list | Позволяет вывести историю изменений, произошедших на проекте.
Форма отписки от писем | main.mail.unsubscribe | Предоставляет возможность организовать централизованную отписку.
Включаемые области
Вставка включаемой области | main.include | Располагается в шаблоне дизайна сайта и определяет место расположения включаемых областей страниц и разделов.
Навигация
Выбор сайта | main.site.selector | Включен в шаблон дизайна сайта и служит для переключения между сайтами, созданными на базе данной копии продукта.
Меню | menu | Выводит меню указанного типа.
[link=63461 ]Навигационная цепочка[/link] | breadcrumb | Выводит навигационную цепочку в шаблоне.
Карта сайта
Карта сайта | main.map | Осуществляет отображение карты сайта.
Системные компоненты (не описываются)
Форма сообщения | main.post.form | Осуществляет вывод формы сообщения.

Смотрите также:

  • Основы администрирования
  • Документация для разработчиков по главному модулю


Настройки главного модуля

Форма Настройки модуля служит для управления глобальными настройками как сайта в целом, так и каждого модуля в отдельности. Для удобства работы форма разделена на закладки. Каждая закладка содержит логически сгруппированный набор полей, позволяющих выполнять определённые действия по настройке выбранного модуля.

Описание

Перейти к форме настройки модулей можно, нажав кнопку Настройки на административной панели, либо из административного меню: Настройки > Настройки продукта > Настройки модулей.

Глобальные настройки модулей системы зависят от характера этих модулей и описаны в соответствующих разделах помощи:

  • Блоги;
  • Библиотека документов;
  • Бизнес-процессы;
  • Валюты;
  • Веб-аналитика;
  • Веб-кластер;
  • Веб-мессенджер;
  • Веб-формы;
  • Видеоконференции;
  • Диск;
  • Документооборот;
  • Задачи;
  • Интернет-магазин;
  • Интранет;
  • Информационные блоки;
  • Календарь событий;
  • Контроллер;
  • Конвертер файлов;
  • Коннекторы для внешних мессенджеров;
  • Мастер магазина;
  • Монитор производительности;
  • Облако 1С-Битрикс;
  • Облачные хранилища;
  • Обучение;
  • Опросы, голосования;
  • Открытые линии;
  • Перевод;
  • Подписка, рассылки;
  • Поиск;
  • Поисковая оптимизация;
  • Почта;
  • Проактивная защита;
  • Реклама, баннеры;
  • Распознавание лиц;
  • Социальная сеть;
  • Сайты24;
  • Сервер конвертации файлов;
  • Служба сообщений;
  • Социальные сервисы;
  • Техподдержка;
  • Торговый каталог;
  • Управление структурой;
  • Универсальные списки;
  • Учёт рабочего времени;
  • Форум;
  • Фотогалерея 2.0;
  • Экстранет;
  • ЧатБоты;
  • AD/LDAP интеграция;
  • CRM;
  • DAV;
  • E-mail маркетинг;
  • Push&Pull;
  • REST API;
  • Wiki;
  • XMPP;

Следующие модули не имеют форм настроек:

  • Адреса и местоположения
  • А/B-тестирование
  • Внешние источники данных;
  • Веб-сервисы;
  • Генератор документов
  • Дизайнер бизнес-процессов;
  • Интеграция с Битрикс24
  • Менеджер идей;
  • Компрессия;
  • Конструктор отчётов;
  • Корзина удаленных сущностей
  • Конверсия
  • Машинное обучение
  • Мобильная платформа
  • Мобильное приложение
  • Планёрки и собрания.
  • Продажи в чате
  • Роботизация бизнеса
  • Управление масштабированием
  • Телефония
  • Highload-блоки
  • UI-библиотека

Далее приводится описание настроек Главного модуля.

Настройки

На данной вкладке выполняется настройка общих параметров Главного модуля.

Поле | Описание
Системные настройки
Язык по умолчанию для административной части | Определяет, какой язык используется для административной части по умолчанию.
Название сайта | Название, используемое для всех сайтов по умолчанию.
URL сайта (без http://) | Web-адрес, используемый по умолчанию в качестве адресов сайтов, работающих под управлением системы (вводится без http://). Например: www.mysite.com
Режим вывода ошибок (error_reporting) Определяет, какие сообщения об ошибках в работе системы будут выводиться на экран (обычно используется для отладки).
  • Только ошибки - выводить сообщения только об ошибках;
  • Ошибки и предупреждения- выводить сообщения об ошибках, а также предупреждения о возможности возникновения ошибки;
  • Не выводить- не показывать сообщения об ошибках.
Использовать горячие клавиши | Разрешение/запрет на использование горячих клавиш в продукте.
Галерея смайлов для парсера | Выбор набора смайлов, который будет использован парсером системы. Выбирается из загруженных наборов на странице Наборы смайлов.
Куки
Префикс для названия кук (без точек и пробелов) | Строка, добавляемая к имени cookie.
Использовать общие файлы cookies для всех доменов. Используется для модулей Статистика, Реклама, Опросы, Форумы и некоторых других модулей.

Установка флага в это поле также дает возможность организовать "сквозную" авторизацию на сайтах, работающих под управлением системы.
Устанавливать для кук авторизации атрибут secure (только для https) | Определяет, будет ли использоваться шифрация при сохранении идентификационной информация в файлах cookies.
Установка флага в это поле позволяет организовать "сквозную" авторизацию на всех сайтах, работающих под управлением системы. Т.е. авторизация пользователя в одном домене автоматически будет распространяться на все домены всех сайтов. Предварительно необходимо разрешить распространение файлов cookies на все домены.
Файлы
Ограничение дискового пространства (Мб) | При необходимости вы можете задать ограничение (в Мб) на дисковое пространство.
Папка по умолчанию для загрузки файлов | Папка, в которую будут попадать файлы (например, картинки) при загрузке на сайт. Путь к папке указывается относительно корня сайта.
Сохранять исходные имена загружаемых файлов Если опция отключена, то при загрузке файлов на сайт (например, изображений) оригинальные имена этих файлов сохранены не будут. Файлам будут автоматически присваиваться имена, состоящие из случайных символов.

Если же опция включена, то вместо переименования файлов создаётся подпапка с именем, состоящим из случайных символов; само же имя файла сохраняется. Это позволяет сохранять оригинальное осмысленное имя файла, что полезно, например, при скачивании файла посетителями.
Производить транслитерацию имени файла Если же опция включена, то при загрузке файла произойдёт автоматическая транслитерация имени файла, если исходный файл имеет название на кириллице.

Функция работает, если включена опция Сохранять исходные имена загружаемых файлов

Автоматически заменять невалидные символы в именах загружаемых файлов Если флаг Сохранять исходные имена загружаемых файлов включен, то при включении данной опции все небезопасные символы в именах файлов (нелатинские, цифры и некоторые другие) будут заменяться на произвольные латинские.
Если опция выключена, система не позволит сохранять файлы с небезопасными именами.
Данная возможность введена для обеспечения кроссплатформенной совместимости.
Контролировать загрузку дубликатов файлов | Включение контроля загрузки дубликатов. По умолчанию выключено, в новых дистрибутивах включено.
Максимальный размер файла для контроля дубликатов (Мб) | Установка ограничения на размер файла для контроля.
Качество JPG при масштабировании изображений (в процентах) | Задается уровень сжатия в процентах для *.JPG файлов при масштабировании.
Быстрая отдача файлов через Nginx Задаёт способ отдачи файлов: через Nginx или Apache.

Файл на скачивание с проверкой прав отдаётся с помощью метода CFile::ViewByUser. Если читать файл на php, то это занимает время на бекенде и существенно зависит от размера файла. При включенной опции метод после проверки прав выставляет заголовок X-Accel-Redirect и прекращает работу. Этот заголовок обрабатывается ngnix, который сам считывает указанный файл с диска, освобождая бекенд. При этом дополнительная настройка ngnix не требуется.

Изображения в профиле пользователя
Максимальная ширина в пикселях | Указание максимально возможной ширины изображения.
Максимальная высота в пикселях | Указание максимально возможной высоты изображения.
Максимальный размер файла в байтах | Указание максимально возможного размера файла.
Эти поля - не ресайз изображения, а проверка на заданные ограничения на загружаемый файл. В случае превышения ограничений файл не будет загружен, выведется соответсвующее уведомление.
Оптимизация CSS
Объединять CSS файлы | Все файлы стилей будут сведены в один файл для выдачи клиенту.
Объединять JS файлы | Все JS файлы будут сведены в один файл для выдачи клиенту.
Подключать минифицированные версии CSS и JS файлов | Минифицированная версия файлов имеет суффикс .min в названии: style.min.css и script.min.js. Это касается любых файлов, подключаемых через SetAdditionalCSS [image] и AddHeadScript [image]. Если время изменения исходного файла больше минифицированного, то подключится исходный.
Переместить весь Javascript в конец страницы | JS скрипты будут загружаться после загрузки кода всей страницы. Опция ускоряет загрузку страницы, но выполнение активных сценариев будет производиться после загрузки страницы.
Создавать сжатую копию объединенных CSS и JS файлов | Система создаст сжатый файл .gz и отдаст его клиенту. При установке флажка создается сжатый файл, для того чтобы nginx не сжимал файл js и css "на лету", а брал уже готовый файл.
Внешние сервисы перевода
Ключ сервиса Яндекс.Перевод Для автоматической генерации символьных кодов используется Яндекс.Перевод. Требуется зарегистрироваться на сайте API Яндекса [image], получить ключ и указать его в настройках модуля. Используемая версия API Яндекс.Перевода - 1.5.
Если ключ не указан, осуществляется транслитерация.
Часовые пояса
Локальное время сервера Информация о текущем времени сервера, на котором установлен сайт. Показывает, в каком поясе фактически работает сервер. Для корректной работы системы часовых поясов должна быть правильная комбинация времени и смещения от UTC (18:26:10 +0300). Из продукта время и пояс не настраиваются, они просто должны быть правильными. Если что-то не так, нужно настраивать ОС и/или PHP и БД.

Доступно для PHP 5.2.0 и выше

Разрешить использование часовых поясов Разрешение на использование часовых поясов,отличных от Локального времени сервера. При отключенной галочке запросы к БД будут немного короче.
При включённой опции станут активными [dw]дополнительные поля.[/dw][di]Список полей, активных при выборе опции Разрешить использование часовых поясов:
Поле | Описание
Часовой пояс сервера по умолчанию | Выбор часового пояса, который должен использоваться на сайте вместо Локального времени сервера. Поле указывает, в какой/из какого часового пояса будут конвертированы даты по умолчанию. Например, сайт стоит на разделяемом хостинге в США, фактически работает по чикагскому времени. Управлять системным временем на хостинге возможности нет. На сайте - форумы с преимущественно калининградскими посетителями. Необходимо выбрать зону Europe/Kaliningrad - и сообщения форума показываются по калининградскому времени для всех, даже для анонимов. Эта настройка может быть переопределена конкретным пользователем под себя.
По умолчанию автоматически определять часовой пояс по браузеру | Установить эту опцию, если не используются другие способы определения времени клиента. В этом случае время определяется по времени браузера клиента. Опция особенно полезна в корпоративном портале, где часовые пояса имеют большое значение.
[/di].
Сервис рекомендаций
Использовать сервис рекомендаций товаров | Включает использование сервиса BigData.
Карта сайта
Тип меню для нулевого уровня карты сайта | Название типа меню, пункты которого будут использоваться в качестве вершин карты сайта. Можно указать несколько типов меню через запятую, если предполагается использовать больше 2-х уровней вложенности.
Тип меню для остальных уровней карты сайта | Название типа меню, пункты которого будут использоваться в качестве ветвей карты сайта. Можно указать несколько типов меню через запятую, если предполагается использовать больше 2-х уровней вложенности.
Богатые ссылки
Включить богатые ссылки | При установке флажка ссылки в публичной части будут отображаться с выводом части информации с указанной страницы. (В Битрикс24 в коробке опция включена по умолчанию.)
Сохранять изображения локально | При включённой опции первом просмотре богатой ссылки загружается картинка и потом она достаётся из кеша. То есть повторные просмотры - производятся быстрее. Кроме того, некоторые сайты не любят, когда их контент напрямую вставляют в чужие страницы, и отдают access denied вместо изображения.
Редактор изображений
Разрешить редактирование изображений с внешних сайтов Параметр определяет можно ли открывать в редакторе изображения которые находятся на внешних ресурсах.
Изначально картинка редактируется на удаленном сервере, просто проксируется поток. Но это все потенциально небезопасно (см. политику CORS [image]). Поэтому пользователь может указать список доверенных ресурсов, с которых можно редактировать. По умолчанию редактировать можно только картинки с текущего хоста.
Список разрешенных сайтов | С помощью ссылки Добавить сайт указываются сайты (как правило это - CDN) с которых разрешено редактировать изображения.
Панель инструментов публичного раздела
Всегда показывать панель для пользователей | С помощью ссылки Добавить пользователей можно указать для каких групп пользователей, пользователей или структурных подразделений необходимо всегда отображать панель управления (независимо от имеющихся прав доступа).
Никогда не показывать панель для пользователей: С помощью ссылки Добавить пользователей можно указать для каких групп пользователей, пользователей или структурных подразделений не нужно отображать панель управления (независимо от имеющихся прав доступа).

Почта и СМС

Поле | Описание
Почта
E-Mail адрес или список адресов через запятую, на который будут дублироваться все исходящие сообщения | Все почтовые сообщения из системы почтовых событий сайта будут дублироваться на указанный e-mail адрес (адреса). В почтовых шаблонах адреса из этого поля выводятся по макросу #BCC#. Внимание! Не дублируются почтовые сообщения: из модуля Форум, уведомления Магазина.
Отправлять в письме идентификаторы почтового события и шаблона | При отмеченной опции в каждом письме будут присутствовать данные, уникально идентифицирующие это письмо.
Дублировать E-Mail адрес в заголовок | Адрес по умолчанию получателя сообщений с сайта. Значение данного поля используется, например, при формировании сообщений автоматической рассылки. Отметьте этот флаг, если письма с сайта приходят без поля TO.
E-Mail администратора сайта (отправитель по умолчанию) | По умолчанию в качестве e-mail адреса отправителя письма с сайта будет подставляться этот адрес. С версии 20.700.0 Главного модуля (main) возможно использовать email с [dw]IDN[/dw][di]IDN (англ. Internationalized Domain Names — интернационализованные доменные имена) — это доменные имена, которые содержат символы национальных алфавитов, например, мойсайт.рф. Подробнее [image] ...[/di], включая кириллические домены.
Конвертировать символы новой строки Unix формата в Windows формат при отправке email | Если опция включена, то переводы строк конвертируются из односимвольного формата UNIX в двухсимвольный Windows (CR+LF).
Конвертировать 8-битные символы в заголовке письма | Если символы с кодом выше 127 (т.е. 8-битные) в заголовках отправляемых с сайта писем отображаются некорректно, то включите эту опцию. В этом случае все подобные символы в заголовке будут переданы в кодировке Base64.
Отправлять картинки в виде вложений в письмо | Флажок, установленный в этом поле разрешит отправлять вложения в виде файла. Рекомендуется при использовании модуля Email-маркетинг.
Генерировать текстовую версию для html-писем | По умолчанию включено. При включённой опции автоматически создаётся текстовая версия [image] отправляемых писем.
Максимальный размер файлов вложения в байтах | Устанавливается ограничение на размер вложений в письмо. Значение 0 - вложения без ограничений.
Сколько дней хранить почтовые события | Количество дней, в течение которого будут сохраняться почтовые события [image] .
Сколько писем отправлять за один хит | Количество писем, отправляемых за один хит.
Дополнительный параметр для передачи функции mail | Указывается дополнительный параметр для передачи функции mail.
Протокол в ссылках письма (в относительные ссылки дописывается протокол и домен сайта, например, https) | Указывается протокол, который будет проставляться в относительные ссылки сообщения. Если протокол не указан, по умолчанию используется HTTP.
Отслеживать статус прочтения исходящих писем | Каждая из опций отключает выбранное отслеживание. Отключение глобальное, то есть трекинг не будет работать даже если включено отслеживание в каком-либо другом модуле. Реализовано с целью соблюдения законодательства разных стран.
Отслеживать переходы по ссылкам в исходящих письмах
Отправка СМС
Секция появляется при установленном и настроенном модуле Служба сообщений (messageservice)
Служба отправки СМС по умолчанию: | Одна из подключённых служб выбирается как служба по умолчанию.
Номер отправителя по умолчанию: | После выбора службы по умолчанию в этом поле автоматически появится список номеров из личного кабинета выбранной службы. Укажите один из них как номер отправителя.
Форматирование телефонных номеров
Страна по умолчанию | Выбор страны по правилам которой телефонный номер будет преобразован из местного формата в международный.

Авторизация

Поле | Описание
Настройки локальной системы авторизации
Разрешить запоминание авторизации | Определяет, выводить ли флажок "Запомнить меня на этом компьютере" в форме авторизации.
Разрешить авторизацию через внешние сервисы | При отмеченной опции для авторизации можно будет использовать внешние сервисы типа LiveID.
Разрешить аутентификацию по QR-коду | При отмеченной опции становится доступна аутентификация по QR-коду. Доступно с версии 21.800.0. Примечание: Опция работает только в коробочной версии Битрикс24 и требует наличия модуля Push&Pull и мобильного приложения Битрикс24.
Разрешить авторизацию HTTP Digest | В Windows 7/Office 2010 отказались от поддержки авторизации HTTP Basic без SSL, т.к. пароль передается в открытом виде. При этом поддерживается авторизация HTTP Digest, при которой пароль не передается в открытом виде, т.е. SSL не обязателен. С версии 10 такой тип авторизации поддерживается в библиотеке документов. Может применяться только для встроенной авторизации.
Страница регистрации (для системного компонента авторизации) | Указывается путь к странице авторизации.
Шаблон системных компонентов авторизации (system.auth.*) | Указание шаблона, который будет применяться в компонентах авторизации вместо штатного. (Пользователю недоступны настройки компонентов, они подключаются ядром.) Шаблон должен быть расположен в папке /local/templates/.default/components/bitrix/system.auth.authorize/_название вашего шаблона.
Использовать CAPTCHA при восстановлении пароля | При установке флажка при восстановлении пароля будет появляться поле для ввода CAPTCHA. Внимание! Может потребоваться доработка кастомизированных шаблонов компонентов system.auth.changepasswd и system.auth.forgotpasswd для показа CAPTCHA.
Безопасная авторизация
Передавать пароль в зашифрованном виде | Включение функции Безопасная авторизация [image] .
Ключ шифрования | Указывает на то, сгенерирован ли открытый ключ для использования функции. Если ключ не используется, то создать его можно по кнопке Сгенерировать ключ.
Регистрация новых пользователей
Позволять ли пользователям регистрироваться самостоятельно? | Определяет, могут ли посетители самостоятельно регистрироваться на сайте.
Использовать CAPTCHA при регистрации | При отмеченной опции будет использована технология CAPTCHA в процессе регистрации.
При регистрации добавлять в группу | Группа, в которую пользователь будет автоматически попадать при регистрации.
Регистрировать пользователей по номеру телефона: | Разрешение на регистрацию пользователя по номеру телефона. Номер телефона потребуется подтвердить через СМС. Настроить службы отправки СМС вы можете в настройках модуля Служба сообщений.
Номер телефона является обязательным: | Поле становится активным после включения опции, разрешающей регистрацию по телефону. Если опция не включена, поле "Номер телефона" при регистрации будет необязательным.
Регистрировать пользователей по email: | Разрешение на регистрацию пользователя по e-mail. После включения поля становятся активными три поля ниже.
E-mail является обязательным полем | Если [dw]флажок снят,[/dw][di]В этом случае поле Запрашивать подтверждение регистрации по E-mail будет неактивно[/di] то поле e-mail будет не обязательным при регистрации.
Запрашивать подтверждение регистрации по E-mail | При отмеченной опции пользователю будет отправлено письмо с подтверждением регистрации по E-mail, сформирванное на основе почтового шаблона. Отредактировать почтовый шаблон можно с помощью ссылки Почтовые шаблоны.
Проверять E-mail на уникальность при регистрации | Если опция отмечена, то при регистрации пользователя будет выполняться проверка адреса электронной почты на совпадение с уже имеющимися адресами в системе. Также уникальность E-mail будет проверяется и при обновлении пользователя. Уникальность Email проверяется только для внутренней регистрации. Внешние источники авторизации могут вовсе не отдавать e-mail, например odnoklassniki, twitter, vkontakte.
Сколько дней хранить пользователей с неподтвержденной регистрацией | Указывается количество дней, в течении которых будут храниться записи о пользователях с неподтвержденной регистрацией.
Настройка соглашений. | Переход к созданию нового соглашения о согласии пользователя по ссылке Создать новое соглашение. Далее следуют поля для выбора сайта и соглашения для него. Выбранное соглашение используется при регистрации пользователя.
Безопасность
Деактивировать давно не заходивших пользователей | Указывается число дней. Если в указанное значение пользователь не авторизовался на сайте, его аккаунт автоматически становится неактивным.
Защитить выход пользователя из системы от CSRF | Включение защиты выхода пользователя из системы от атаки CSRF (Cross-Site Request Forgery). Настройка доступна с версии 20.100.0 Главного модуля (main). Внимание!: Может потребоваться доработка кастомизированных шаблонов (ссылки на выход).
Контроль сессии
Продлевать сессию при активности посетителя в окне браузера | Под активностью понимается движение мышью, клик мышью, нажатие кнопки клавиатуры. Система отслеживает эти действия в окне браузера и автоматически продлевает сессию при их наличии.
Продлевать сессию только для авторизованных посетителей | Пункт позволяет продлевать сессию при активности посетителя в окне браузера только для авторизованных пользователей.
Показывать пользователям сообщение об окончании сессии | При отмеченной опции по истечении сессии пользователю будет выведено сообщение: В этом случае вам необходимо скопировать несохраненную информацию во избежание ее потери. Сообщение выводится и в публичной, и в административной части портала.

Журнал событий

На данной вкладке выполняется настройка параметров журнала событий.

Поле | Описание
Сколько дней хранить события | Указывается период времени (количество дней), в течении которого события будут храниться в журнале.
События для записи в журнал
Записывать [тип события] | Отметьте флажками события, которые должны фиксироваться в журнале.
Профиль пользователя
Сохранять историю изменения полей профиля пользователя | Включает логирование изменений профилей пользователей и делает активной страницу Настройки > Пользователи > История профилей.
Сколько дней хранить историю | Указывается период времени (количество дней), в течении которого будет храниться история изменений полей профиля пользователя. Примечание: Доступно с версии 20.5.200 Главного модуля (main).
Настройки системы авторизации на контроллере*
Префикс для авторизации на контроллере | Указывается префикс, который будет использоваться для авторизации пользователей контроллера на этом подчиненном сайте.
Авторизовывать на этом сайте пользователей других сайтов контроллера | При отмеченной опции пользователи других сайтов контроллера смогут авторизовываться на этом сайте, причем обязательно должна быть разрешена авторизация между подчиненными сайтами на контроллере и настроено соответствие групп.

* - данная секция доступна, если сайт подключен к контроллеру.

Система обновлений

Поле | Описание
Лицензионный ключ | Лицензионный ключ данной копии продукта.
Установка для разработки | Пометка того, что данный экземпляр используется для разработки и тестирования, закрытый от публичного доступа. Установки для разработки при обновлении учитываются отдельно от публичных установок.
Имя сервера, содержащего обновления | Имя сервера, с которого выполняется обновление продукта (должно быть равно www.bitrixsoft.com).
Адрес прокси для системы обновлений | Адрес прокси-сервера, через который выполняется доступ к серверу обновлений (используется, например, для корпоративных сетей).
Порт прокси для системы обновлений | Адрес порта, по которому выполняется доступ к системе обновлений через прокси-сервер.
Имя пользователя прокси | Имя пользователя для доступа к прокси-серверу.
Пароль прокси | Пароль для доступа к прокси-серверу.
Флаг в этом поле позволяет выполнять проверку корректности установки обновлений. При копировании файлов из промежуточной папки /updates/ в папки модулей будет выполняться проверка контрольной суммы. Если полученная контрольная сумма не соответствует исходной, то выводится сообщение о некорректной установке обновлений.
Включить безопасный режим | При включённой опции передается минимальный объем данных. Рекомендуется к использованию при небыстрых хостингах или при больших обновлениях.
Загружать только стабильные обновления | При отмеченной опции в системе обновлений будут загружаться только стабильные версии. При снятой опции - бета-версии.
Автоматически проверять наличие обновлений Указывается периодичность проверки наличия обновлений на сервере:
  • Не проверять;
  • Каждый день;
  • Раз в неделю;
  • Раз в месяц.
Если выбрать Каждый день, Раз в неделю или Раз в месяц, то система будет выводить в Центре уведомлений Панели управления [dw]соответствующее сообщение[/dw][di] [image] [/di].
Остановить автоматическую проверку при возникновении ошибок | При отмеченной опции при возникновении ошибок автоматическая проверка обновлений будет остановлена.
Не использовать архиватор | При отмеченной опции файлы с обновлениями архивироваться не будут. Опция влияет как на обновления самой системы, так и на обновления Marketplace.
Продолжительность шага пошаговой загрузки обновления (сек) | Система обновлений поддерживает пошаговую загрузку файлов обновления. Установите продолжительность шага загрузки в секундах.

Доступ

На закладке выполняется настройка прав доступа групп пользователей к управлению ресурсами Главного модуля.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к Главному модулю:
  • [D] Доступ закрыт - запрет на доступ;
  • [P] Изменение своего профайла - право на просмотр и изменение собственного профайла;
  • [R] Просмотр всех данных модуля - доступ к просмотру файлов модуля без права на изменение;
  • [T] Просмотр всех данных модуля и изменение своего профайла - доступ к просмотру файлов модуля с правом на изменение собственного профайла;
  • [V] Просмотр данных модуля и изменение заданных профайлов - доступ к просмотру файлов модуля с правом на изменение указанных профайлов;

    Примечание: при выборе этого права доступа необходимо указать Группы пользователей, профайлы которых можно изменять в одноименном поле снизу.

  • [W] Полный доступ - полный доступ к управлению модулем.

Публичная часть

Форма предназначена для ограничения доступа посетителей к сайту, например, на время выполнения технических работ.

Поле | Описание
Доступ к публичной части открыт/закрыт | Сообщение о текущем состоянии доступа к публичной части сайта.

С помощью кнопки Закрыть доступ пользователей/Открыть доступ для всех посетителям может быть разрешен или запрещён доступ к публичной части сайта.

Контроллер

Поле | Описание
URL контроллера | Адрес сайта, который является базовым для модуля Контроллер.
Дополнительные параметры
Логин администратора контроллера | Логин администратора контроллера.
Пароль | Пароль администратора контроллера.
Название текущего сайта | Название сайта.
URL сайта | URL подключаемого сайта.
Добавить этот сайт к контроллеру | Нажатие на кнопку добавляет сайт к контроллеру. Если не верно или не полностью заполнены данные, будет выведено соответствующее уведомление.
Настройки прокси (если требуется)
Поля для настройки доступа к серверу: Адрес, Порт, Логин и Пароль пользователя | Данные для доступа к прокси серверу.
Сохранить настройку прокси | Кнопка сохранения настроек.
Доступ к публичной части открыт/закрыт | Сообщение о текущем состоянии доступа к публичной части сайта.

Слабые пароли

Выбор базы данных для проверки паролей. Можно использовать штатную или собственную базу.

Поле | Описание
Использовать базу данных по умолчанию (один миллион паролей) | Выбор штатной базы паролей.
Использовать собственную базу данных слабых паролей | Выбор сторонней базы паролей.
Добавить файл | Кнопка для добавления собственного файла базы данных слабых паролей. Файл должен быть в формате txt. Каждый пароль должен быть в отдельной строке.

Дополнительно

  • Настройка главного модуля (учебный курс "Администратор. Базовый")


Модули

Форма Модули (Настройки > Настройки продукта > Модули) служит для инсталляции и деинсталляции модулей системы. Например, если не используется модуль Документооборот, то вы можете его деинсталлировать, чтобы он не занимал ресурсы компьютера и место в меню. Позднее вы сможете инсталлировать его вновь (дистрибутив модуля сохраняется в системе).

Поле | Описание
Название | Название модуля.
Версия | Текущая версия модуля.
Дата обновления | Дата последнего обновления модуля.
Статус Текущий статус модуля:
  • Установлен;
  • Не установлен.
Действия Доступные действия над модулем:
  • Удалить;
  • Установить.

Обратите внимание, что некоторые модули при деинсталляции предлагают сохранить (не удалять) накопленные ими данные. Если в дальнейшем вы планируете использовать эти данные, то при деинсталляции модуля следует отметить опцию Сохранить таблицы.

Примечание: некоторые модули поддерживают веб-кластеры и при установке имеют опцию выбора базы данных.


Автокеширование

Закладки

Кеширование компонентов

Использование технологии Автокеширования позволяет быстро подготовить сайт и компоненты проекта к работе в условиях стрессовых нагрузок или адаптировать сайт к работе на виртуальном хостинге. Методология разработки компонентов 2.0 включает обязательное требование поддержки технологии Автокеширования для разработчиков.

На странице Автокеширование (Настройки > Настройки продукта > Автокеширование) можно включить/отключить автокеширование на сайте с помощью кнопки Включить автокеширование/Выключить автокеширование.

Примечание: При включении режима автокеширования компонентов, компоненты с настройкой кеширования Авто + Управляемое будут переведены в режим работы с кешированием.

Суть автокеширования заключается в том, что все динамические компоненты, которые используются для создания веб-страниц, получили встроенную поддержку управления кешированием. Для использования новой технологии нетехническому специалисту достаточно включить автокеширование одной кнопкой на административной панели. При этом все компоненты, у которых был включен режим, автокеширования создадут кеши и полностью перейдут в режим работы без запросов к базе данных.

Обратите внимание: При использовании режима "Автокеширования", обновление информации, выводимой компонентами, происходит в соответствии с параметрами отдельных компонентов.

Для того чтобы обновить содержимое закешированных объектов на странице, вы можете:

  1. Перейти на нужную страницу и обновить ее содержимое, используя кнопку Сбросить кеш на панели инструментов:

    Кнопка "Сбросить кеш"

    Примечание 1: Когда сбрасываете кеш кнопкой Обновить кеш страницы, имейте в виду, что компонент может использовать привязку к группам для хранения кеша (опция Учитывать права доступа) и тогда кеш сбросится только у тех пользователей, которые входят в те же группы, что и вы. Это касается и администратора сайта.

    Опция "Учитывать права доступа"

    При установленной опции кеш будет разный для разных групп пользователей, в то время как при не установленной опции кеш будет общим.

    Пример: Незарегистрированные пользователи будут по-прежнему видеть не актуальную страницу после нажатия кнопки Обновить кеш страницы при установленной опции Учитывать права доступа.

    Примечание 2: Пункт меню Обновить кеш компонентов кнопки Сбросить кеш заставляет все компоненты, расположенные на странице, сбросить свой кеш. Кнопка (пункт) Обновить кеш страницы сбрасывает кеш всей страницы.

  2. В режиме Правки сайта использовать кнопки для очистки кеша в панели отдельных компонентов.

    Очистка кеша отдельных компонентов

  3. Использовать автоматический сброс кеша по истечении времени кеширования, для чего в настройках компонента выбрать режим кеширования Кешировать или Авто + Управляемое.

  4. Использовать автоматический сброс кеша при изменении данных, для чего в настройках компонента выбрать режим кеширования Авто + Управляемое. Подробнее про управляемый кеш см. ниже.

  5. Перейти к настройкам выбранных компонентов и перевести их в режим работы без кеширования.

    Настройки кеширования компонента

Компоненты с настройкой кеширования Авто + Управляемое автоматически обновляют кеш в течение заданного времени или при изменении данных.

Компоненты с настройкой кеширования Кешировать и временем кеширования больше нуля, всегда работают в режиме кеширования.

Компоненты с настройкой кеширования Не кешировать или временем кеширования равным нулю, всегда работают без кеширования.

Управляемый кеш

Для включения/отключения управляемого кеширования используйте кнопку Включить управляемый кеш/Выключить управляемый кеш (не рекомендуется).

Технология управляемого кеширования Сache Dependencies автоматически обновляет кеш компонентов при изменении данных. Если управляемое кеширование включено, вам не потребуется вручную обновлять кеш компонентов при изменении новостей или товаров, изменения сразу станут видны посетителям сайта.

Примечание: Не все компоненты могут поддерживать управляемое кеширование.

Примечание: Подсказка, расположенная ниже настроек кеширования в параметрах компонента отображает состояние текущих настроек ядра.

Ссылка Изменить настройки кеширования позволяет перейти на страницу Настройки кеширования в административном разделе сайта.

Примечание: Технология Сache Dependencies, как и весь продукт, может хранить кеш как в файлах, так и используя Memcached, APC, eAccelerator. Для этого достаточно изменить один из конфигурационных параметров [image].

HTML кеш

Внимание! С версии 16.0.14 данная закладка отсутствует. Вместо неё используется Композитный сайт.

Для включения/отключения HTML кеша используйте кнопку Включить HTML кеширование/Выключить HTML кеширование.

Поле | Описание
Маска включения | Укажите файлы и типы файлов, которые будут обрабатываться HTML кешем.
Маска исключения | Укажите файлы и типы файлов, которые не будут обрабатываться HTML кешем.
Дисковая квота (мегабайт) | Дисковая квота кеша (задается в мегабайтах).

Для сохранения настроек нажмите кнопку Сохранить настройки HTML кеша.

Для установки значений параметров равными значениям по умолчанию нажмите кнопку Установить настройки по умолчанию.

Внимание! Есть и ограничения в использовании. В частности, мы не советуем включать HTML кеш (или включать обдуманно по разделам) для редакций, которые содержат веб-аналитику и модуль рекламы.

Механизм HTML-кеширования лучше всего включить на какой-нибудь редко изменяющийся раздел с регулярным посещением анонимных посетителей, так как при включенном HTML-кешировании происходят следующие процессы:

  • механизмом HTML-кеша обрабатываются только страницы, не указанные в маске исключения и указанные в маске включения;
  • если на такие страницы заходит не авторизованный пользователь, то выполняется проверка существования файла кеша и если таковой найден, то выдается страница из кеша, не задействуя никакие модули продукта; например, не будет работать модуль статистики (не засчитаются хиты этого пользователя), модуль рекламы, главный и другие модули;
  • при этом если на момент включения кеша был установлен модуль компрессии, то страница будет отдаваться в сжатом виде;
  • если страница в кеше не найдена, то код исполняется в обычном режиме; когда страница полностью сформирована, ее копия сохраняется в HTML-кеш;

Очистка кеша:

  • если сохраняемый объем приводит к превышению дисковой квоты кеша, то кеш полностью очищается;
  • так же полная очистка кеша происходит при любом изменении данных в административной части системы;
  • если в публичной части сайта происходит POST данных (например, добавление комментария или голосование), то сбрасывается соответствующая часть кеша;

Из всего вышесказанного следует, что:

  • не ведется учет статистики;
  • модуль рекламы будет работать только в момент создания кеша (это не относится к внешней динамической рекламе (Begun и пр.));
  • необходимо обязательно задать дисковую квоту во избежание DoS-атаки по дисковому пространству;
  • после включения механизма HTML-кеширования необходимо проверить весь функционал раздела, к которому применен кеш (например, может не сработать публикация комментариев со старыми шаблонами блогов);

Очистка файлов кеша

Эта закладка используется для удаления файлов кеша, содержащих устаревшую или сбойную информацию.

Поле | Описание
Только устаревшие | Файлы, время жизни которых закончилось.
Все | Все файлы кеша.
Меню | Меню может быть закешировано, если происходят проверки доступа к различным пунктам меню, разделам. Данный пункт позволяет очистить этот кеш.
Весь управляемый | Все файлы раздела /bitrix/managed_cache/.
Все страницы HTML кеша | Удаление страниц HTML кеша.

Для удаления выбранных файлов нажмите кнопку Очистить.

После удаления файлов кеша выводимые данные будут обновлены до актуального состояния. Новые файлы кеша будут создаваться постепенно по мере обращений к страницам с закешированными областями.

Смотрите также

  • Настройки кеширования (учебный курс "Администратор. Базовый")
  • Автокеширование (учебный курс "Разработчик Bitrix Framework")


Список мастеров

Закладки

На странице Список мастеров (Настройки > Настройки продукта > Список мастеров) представлены все мастера, имеющиеся в системе. Мастер - это специализированный функционал, состоящий из нескольких шагов, за время выполнения которых происходит настройка системы для решения определённой задачи.

Контекстная панель

Кнопка | Описание
Загрузить мастер | Переход к форме импорта мастера.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список мастеров

Поле | Описание
Действие Действия над мастерами:
  • Установить - запуск мастера;
  • Скачать - скачивание мастера на локальный компьютер;
  • Удалить - удаление мастера.
ID | Полное имя мастера.
Название | Название мастера.
Описание | Краткое описание возможностей мастера.
Версия | Версия мастера.


Импорт мастера

С помощью формы Импорт мастера осуществляется загрузка мастера в систему.

Контекстная панель

Кнопка | Описание
Список мастеров | Переход на страницу со списком мастеров.

Закладка "Импорт мастера"

Поле | Описание
Файл с мастером для загрузки (*.gz) | С помощью кнопки Обзор... выбирается файл с мастером (формат *.gz) для загрузки.


Пользовательские поля

Закладки

На странице Пользовательские поля (Настройки > Настройки продукта > Пользовательские поля) можно добавлять новые поля, просматривать и изменять существующие, удалять ненужные пользовательские поля. Вывод значений пользовательских полей в публичной части производится с помощью API [image] продукта.

Форма поиска

Форма фильтра используется для выбора из списка пользовательских полей в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Параметр | Описание
Найти Позволяет найти пользовательские поля по их основным параметрам: идентификатору или объекту.

Это поле присутствует, даже если фильтр свернут.
ID | Поиск поля по идентификатору.
Объект | Поиск свойства по объекту, например, USER, USER_PROPERTY, BLOG_POST и т.д.
Название поля | Поиск поля по названию. Название начинается с UF_.
Тип данных Поиск поля по типу данных. Предлагается следующий набор типов данных:
  • Адрес;
  • Бронирование ресурсов;
  • Видео;
  • Да/Нет;
  • Дата;
  • Дата со временем;
  • Деньги;
  • Документ из библиотеки документов (Только для "Битрикс24 в коробке");
  • Опрос;
  • Письмо (email);
  • Привязка к разделам инф. блоков;
  • Привязка к сотруднику;
  • Привязка к справочникам CRM;
  • Привязка к элементам CRM;
  • Привязка к элементам highload-блоков;
  • Привязка к элементам инф. блоков;
  • Содержимое ссылки;
  • Список;
  • Ссылка;
  • Строка;
  • Файл;
  • Целое число;
  • Число;
  • Шаблон.
XML_ID | Поиск по внешнему идентификатору XML_ID.
Множ. | Поиск по признаку, является ли поле множественным, т.е. можно ли задать несколько значений одного поля.
Обяз. | Поиск по признаку, является ли поле обязательным для заполнения.
Фильтр Поиск по способу отображения поля в фильтре:
  • не показывать;
  • точное совпадение;
  • поиск по маске;
  • поиск по подстроке.
Показ. | Поиск по признаку, показывать ли данное поле в списке по месту применения.
Редакт. | Поиск по признаку, можно ли редактировать данное поле пользователем.
Поиск | Поиск по признаку, участвуют ли значения поля в поиске.

Чтобы отобрать пользовательские поля по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех пользовательских полей нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания нового пользовательского поля.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список пользовательских полей

Поле | Описание
Колонка флажков | Поле предназначено для выбора пользовательских полей, к которым предполагается применить какое-либо правило или действие.
Действия Доступные операции над пользовательским полем:
  • Изменить - переход к форме редактирования параметров пользовательского поля;
  • Удалить - удаление пользовательского поля.
ID | Уникальный идентификатор пользовательского поля.
Объект | Данное поле заполняется автоматически при переходе к созданию поля с места применения (например из формы редактирования пользователя, значение объекта - USER). Либо заполняется вручную при создании поля со страницы Пользовательские поля.
Название поля | Код поля. Можно задать только для нового поля. Начинается с UF_. Задается только латинскими буквами.
Тип данных Один из доступных типов данных:
  • Привязка к элементам highload-блоков;
  • Документ из библиотеки документов (Только для "Битрикс24 в коробке");
  • Число;
  • Да/Нет;
  • Видео;
  • Шаблон;
  • Список;
  • Строка;
  • Дата/Время;
  • Привязка к сотруднику;
  • Привязка к разделам инф. блоков;
  • Привязка к элементам инф. блоков;
  • Привязка к элементам CRM;
  • Привязка к справочникам CRM;
  • Файл;
  • Целое число.
XML_ID | Внешний XML идентификатор поля.
Сорт. | Индекс сортировки, определяющий положение поля в общем списке.
Множ. | Признак множественности поля.
Обяз. | Признак обязательности поля для заполнения.
Фильтр | Указывается способ отображения поля в фильтре.
Показ. | Параметр определяет показ поля в списке дополнительных полей той или иной формы.
Редакт. | Параметр определяет разрешать редактирование поля или нет.
Поиск | Признак участия значений поля в поиске в публичной части сайта.


Создание и редактирование пользовательского поля

Контекстная панель

Кнопка | Описание
Список | Переход к списку пользовательских полей.
Добавить | Переход к добавлению нового пользовательского поля. Кнопка отображается при редактировании существующего пользовательского поля.
Удалить | Удаление редактируемого пользовательского поля. Кнопка отображается при редактировании существующего пользовательского поля.

Форма редактирования

Форма предназначена для управления параметрами пользовательского поля.

number
Поле | Описание
ID | Уникальный идентификатор пользовательского поля. Присваивается после сохранения.
*Тип данных (можно задать только для нового поля) Выбирается один из возможных типов данных:
  • Привязка к элементам highload-блоков (Для коробочной версии Битрикс24);
  • Документ из библиотеки документов (Для коробочной версии Битрикс24);
  • Число;
  • Да/Нет;
  • Видео;
  • Деньги;
  • Шаблон;
  • Список;
  • Строка;
  • Дата со временем или Дата;
  • Привязка к сотруднику (Для коробочной версии Битрикс24);
  • Привязка к разделам или элементам инф. блоков;
  • Привязка к элементам CRM (Для коробочной версии Битрикс24);
  • Привязка к справочникам CRM (Для коробочной версии Битрикс24);
  • Файл;
  • Целое число;
  • Опрос;
  • Ссылка;
  • Адрес;
  • Бронирование ресурсов;
  • Версия файла (Диск) (Для коробочной версии Битрикс24);
  • Письмо;
  • Содержимое ссылки;
  • Файл (Диск) (Для коробочной версии Битрикс24).
    •
    Примечание: в зависимости от выбранного типа секция Дополнительные настройки поля будет иметь различный вид.
    *Объект Код объекта, к которому относится поле. [ds]Можно задать[/ds][di]Детальнее о Пользовательских полях, список объектов

    Подробнее ... [/di] только для нового поля.
    *Код поля (можно задать только для нового поля) | Код самого поля. Можно задать только для нового поля.
    XML_ID | Указывается идентификатор поля для работы с внешними источниками.
    Сортировка | Индекс сортировки, определяющий положение поля в общем списке.
    Множественное (можно задать только для нового поля) | При отмеченной опции значение поля будет множественным. Можно задать только для нового поля.
    Обязательное | При отмеченной опции поле будет обязательным для заполнения.
    Показывать в фильтре списка Указывается способ отображения поля в фильтре:
    • не показывать - поле не будет показано в фильтре;
    • точное совпадение - поле будет показано в фильтре. Для нахождения элемента требуется точное совпадение условию поиска;
    • поиск по маске - поле будет показано в фильтре. Для поиска элемента в списке по данному полю можно использовать маску;
    • поиск по подстроке - поле будет показано в фильтре. Для нахождения элемента выполнятся поиск по подстроке.
    Не показывать в списке | При отмеченной опции поле не будет отображаться в списке элементов в месте применения.
    Не разрешать редактирование пользователем | При отмеченной опции значение поля нельзя редактировать, только вычислять и устанавливать через API.
    Значения поля участвуют в поиске | При отмеченной опции значения поля будут участвовать в поиске в публичной части после переиндексации сайта.
    Дополнительные настройки поля (зависят от типа)
    Привязка к элементам highload-блоков
    Highload-блок | Задается highload-блок и поле для показа.
    Значение по умолчанию | Задаётся значение по умолчанию. Для множественного поля можно указать [dw]несколько значений[/dw][di] С версии 21.200.0 модуля Highload-блоки (highloadblock). [/di] по умолчанию.
    Внешний вид Указывается тип внешнего вида:
    • Список;
    • Флажки.
    Высота списка | Указывается высота списка.
    Документ из библиотеки документов (для коробочной версии Битрикс24)
    Инфоблок библиотеки документов | Указывается тип информационного блока и инфоблок из доступных в системе.
    Пользовательское свойство для сохранения настроек редактирования | Уникальный символьный код свойства.
    Число
    Точность (количество знаков после запятой) | Определяется точность числа - количество знаков после запятой.
    Значение по умолчанию | Можно определить значение по умолчанию.
    Размер поля ввода для отображения | Указывается размер поля, каким он будет отображен в форме, где используется данное поле. По умолчанию указано 20.
    Минимальне значение (0 - не проверять) | Можно установить минимальное допустимое значение. Если установлено 0, то не проверять.
    Максимальное значение (0 - не проверять) | Можно установить максимальное допустимое значение. Если установлено 0, то не проверять.
    Да/Нет
    Подписи для значений | Задание собственных название полей Да и Нет.
    Значение по умолчанию | Устанавливается, что будет значением по умолчанию, Да или Нет.
    Внешний вид Выбирается один из возможных внешних видов поля:
    • Флажок;
    • Радио кнопки;
    • Выпадающий список.
    Подпись флажка | Задание надписи для флажка. Действует при выборе Флажок в поле Внешний вид.
    Видео
    Общие настройки
    Размер буфера в секундах | Указывается сколько секунд воспроизведения ролика сохранять в буфере обмена, прежде чем начать проигрывать. Рекомендуется для медленного трафика.
    Расположение панели управления Указывается расположение панели управления плеера:
    • внизу (bottom) - снизу окна просмотра;
    • не показывать (none) - панель управления будет скрыта.
    Автоматически начать проигрывать | При отмеченной опции проигрывание медиафайла(ов) будет начато сразу после загрузки страницы.
    Уровень громкости в процентах от максимального | Указывается уровень громкости звука в процентах от максимального заданного в системе.
    Настройки Flash-плеера
    Скин | Выбирается скин Flash плеера. Стандартный скин Flash плеера доступен в любом случае.
    Дополнительные переменные Flashvars | Указываются дополнительные переменные для плеера.
    Режим окна (WMode) Указывается режим окна Flash плеера:
    • Обычный - медиафайл будет проигрываться на странице в собственном прямоугольном окне. Этот вариант дает наибольший выигрыш в скорости воспроизведения анимации;
    • Непрозрачный - медиафайл будет помещен на задний план страницы;
    • Прозрачный - фон страницы будет "проглядывать" через все прозрачные места медиафайла при проигрывании. Этот вариант может замедлить скорость воспроизведения анимации.
    Настройки WMV-плеера
    Цвет фона панели управления | Указывается код цвета для фона панели управления плеера.
    Цвет элементов управления | Указывается код цвета для элементов управления плеера.
    Цвет элементов управления при наведении указателя мыши | Указывается код цвета для элементов управления плеера при наведении указателя мыши.
    Цвет экрана | Указывается код цвета для экрана плеера.
    Дополнительные переменные Silverlight | Указываются дополнительные переменные для плеера.
    Режим окна Указывается режим окна WMW плеера:
    • Обычный - окно плеера будет убрано за HTML элементы страницы;
    • Прозрачный - окно плеера будет отображаться непосредственно в клиентской области обозревателя или внутри специально созданного окна.
    Деньги
    Значение по умолчанию | Устанавливается валюта, которая будет значением по умолчанию. Изначально стоит базовая валюта.
    Шаблон
    Шаблон вывода (#VALUE# - значение) | Указывается требуемый шаблон, например, <a href="callto:#VALUE#">#VALUE#</a>
    Значение по умолчанию | Можно определить значение по умолчанию.
    Размер поля ввода для отображения | Указывается размер поля ввода, каким он будет отображен в форме, где используется данное поле.
    Количество строчек поля ввода | Указывается количество строчек поля ввода.
    Минимальная длина строки (0 - не проверять) | Можно ограничить размер строки по минимальному значению. Если 0, то не ограничивать.
    Максимальная длина строки (0 - не проверять) | Можно ограничить ограничить размер строки по максимальному значению. Если 0, то не ограничивать.
    Регулярное выражение для проверки | Можно ввести регулярное выражение для ограничения вводимых значений поля. Регулярное выражение необходимо ограничить любыми удобными символами, например, /^T.+N$/ либо #^T.+N$#.
    Список
    Внешний вид Указывается тип внешнего вида:
    • Список;
    • Флажки,
    • [dw]Набираемый список[/dw][di]Диалог выбора сущностей. Выпадающий список с возможностью поиска по значениям. Актуален для больших списков. С версии main 20.500.[/di].
    Высота списка | Указывается высота списка.
    Подпись при отсутствии значения | Добавляется текст, который будет выводиться при отсутствии значений.
    Пункты списка задаются после сохранения изменений (кнопка Применить) на закладке Список.
    Строка
    Значение по умолчанию | Можно определить значение по умолчанию.
    Размер поля ввода для отображения | Указывается размер поля ввода, каким он будет отображен в форме, где используется данное поле.
    Количество строчек поля ввода | Указывается количество строчек поля ввода.
    Минимальная длина строки (0 - не проверять) | Можно ограничить размер строки по минимальному значению. Если 0, то не ограничивать.
    Максимальная длина строки (0 - не проверять) | Можно ограничить ограничить размер строки по максимальному значению. Если 0, то не ограничивать.
    Регулярное выражение для проверки | Можно ввести регулярное выражение для ограничения вводимых значений поля. Регулярное выражение необходимо ограничить любыми удобными символами, например, /^T.+N$/ либо #^T.+N$#.
    Дата со временем или Дата
    Значение по умолчанию Выбирается один из возможных вариантов:
    • нет - значения по умолчанию не будет;
    • текущее время - значением по умолчанию будет текущая дата на момент заполнения;
    • также значение по умолчанию может быть установлено вручную с использованием календаря. При выборе даты в типе Дата со временем возможна установка времени.
    Использовать секунды | Возможность задавать секунды при вводе времени.
    Использовать часовые пояса | Если установлена, то учитывается часовой пояс пользователя при выводе времени.
    Привязка к разделам (элементам) инф. блоков
    *Инфоблок Указывается тип информационного блока и инфоблок из доступных в системе.

    Для поля типа "Привязка к элементам инф. блоков" доступны только те инфоблоки, к которым установлено право доступа уровня "Добавление" и выше.

    Значение по умолчанию | Можно определить значение по умолчанию.
    Внешний вид Указывается тип внешнего вида:
    • Список;
    • Флажки.
    Высота списка | Указывается высота списка.
    Показывать только активные разделы (элементы) | [Y|N] При отмеченной опции будут выведены только активные разделы. Неактивные будут скрыты.
    Привязка к элементам CRM (для коробочной версии Битрикс24)
    Доступная сущность Выбираются сущности CRM: Лид, Контакт, Компания, Сделка, Заказы и Сущности смарт-процессов.
    Для разработчиков: формат хранения информации в поле типа "Привязка к элементам CRM":
    array("L_1", "D_2", "C_3", "CO_4", "O_5", "T80_6")

    где:

    • L - лид
    • D - сделка
    • C - контакт
    • CO - компания
    • O - заказ
    • T80 - hex от смарт процесса с id = 128
    • цифра - ID сущности
    Привязка к справочникам CRM (для коробочной версии Битрикс24)
    Доступная сущность | Выбираются сущности из списка.
    Файл
    Размер поля ввода для отображения | Указывается размер поля ввода, каким он будет отображен в форме, где используется данное поле. По умолчанию указано 20.
    Максимальные ширина и высота для отображения в списке | Указывается максимальная ширина и высота изображения для отображения в списке. Если размер изображения больше заданного, то изображение будет уменьшено (<img src="..." width="<w>" height="<h>">).
    Максимально допустимый размер для показа в списке (0 - не ограничивать) | Указывается максимально допустимый размер изображения для показа в списке. Если размер изображения больше указанного, то в списке будет выведена ссылка на изображение. Если указано 0, то не ограничивать.
    Максимально допустимый размер файла для загрузки (0 - не проверять) | Указывается максимально допустимый размер файла в байтах для загрузки. Если указано 0, то не проверять.
    Расширения | Указываются допустимые расширения файлов через запятую. Например: jpg,png,bmp.
    Открывать файл в новой вкладке | Файл откроется в новой вкладке.
    Целое число
    Значение по умолчанию | Можно определить значение по умолчанию.
    Размер поля ввода для отображения | Указывается размер поля ввода, каким он будет отображен в форме, где используется данное поле. По умолчанию указано 20.
    Минимальне значение (0 - не проверять) | Можно установить минимальное допустимое значение. Если установлено 0, то не проверять.
    Максимальное значение (0 - не проверять) | Можно установить максимальное допустимое значение. Если установлено 0, то не проверять.
    Опросы
    Группа опросов | Выбор группы опросов, ссылка перехода к созданию новой группы.
    Заголовок | Заголовок опроса.
    Символьный идентификатор | Символьный код (на латинице).
    Использовать CAPTCHA | Опция используется, если необходимо использовать CAPTCHA (для неавторизованных пользователей).
    Список групп - уровень прав | Отображается список всех групп пользователей в системе. Задаются права для доступа к опросам. По умолчанию все авторизованные могут участвовать в опросе, а неавторизованные - просматривать результаты.
    Оповещать автора опроса о голосе | Выбор уведомления автора и способ уведомления.
    Не голосовать дважды | Задание ограничений на головасание. с одним cookie - голосовать можно один раз в сессию, с одного IP голосовать можно только с разных IP, с одним ID пользователя - голосовать можно только раз для каждого пользователя.
    Запретить голосование пользователям, зарегистрированным после даты начала опроса | Флажок в этом поле разрешит голосование только для тех пользователей, которые зарегистрировались на сайте до начала опроса.
    Ссылка
    Открывать в новом окне | Открывать ссылку в новом или в текущем окне. По умолчанию - в новом.
    Значение по умолчанию | Значение, которое будет показываться до замены на нужную ссылку.
    Размер поля ввода для отображения | Размер окна для ввода ссылки в знаках.
    Минимальная длина строки | Ограничение на минимальную длину ссылки. Если число знаков в ссылке меньше значения этого пол, то ссылка добавлена не будет. Значение "0" - длина проверяться не будет.
    Максимальная длина строки | Ограничение на максимальную длину ссылки. Если число знаков в ссылке больше значения этого пол, то ссылка добавлена не будет. Значение "0" - длина проверяться не будет.
    Адрес
    Показывать карту | При установке флажка будет выведена карта для этого пользовательского поля.
    Бронирование ресурсов
    Выберите | Возможен выбор: Ресурса, Пользователей, Ресурсов и Пользователей. При выборе любой опции необходимо задать значения ресурсов и пользователей.
    Только дата без времени | Разрешает указывать только дату при бронировании ресурса.
    Добавить Услуги и длительность | При установке флажка появятся дополнительные окна для выбора Услуги и задания её длительности.
    Разрешить бронировать занятые ресурсы | Поле включает опцию Бронирования ресурсов.
    Языковые настройки
    Поле служит для задания языковых настроек пользовательского поля.
    Язык | Подпись в форме редактирования | Заголовок в списке | Подпись фильтра в списке | Сообщение об ошибке (не обязательное) | Помощь
[1] | [2] | [3] | [4] | [5] | [6]
    Поле | Описание
[1] Язык | Перечислены все языки, установленные в системе.
[2] Подпись в форме редактирования | Можно определить для каждого из установленных языков подпись поля в форме редактирования. Если поле пусто в форме редактирования будет выведен код поля.
[3] Заголовок в списке | Можно определить для каждого из установленных языков подпись поля в списке, т.е. в отчетной форме. Если поле пусто в списке поле будет представлено кодом (в случае, если настроено, что поле должно отображаться в списке).
[4] Подпись фильтра в списке | Можно определить для каждого из установленных языков подпись поля в фильтре, т.е. как поле будет отображено в форме поиска. Если поле пусто в фильтре поле будет представлено кодом (в случае, если настроено, что поле должно отображаться в фильтре).
[5] Сообщение об ошибке | Сообщение об ошибке, которое будет выводиться в форме, где применяется поле. Действует для типа данных Строка, например, при несоответствии введенного значения регулярному выражению, определённому для поля.
[6] Помощь | Поле для ввода сообщений помощи. Поле ведется внутри системы, но пока нигде не выводится. Вы можете вывести его самостоятельно там, где необходимо.

    * - поля, обязательные для заполнения.


CAPTCHA

Форма CAPTCHA (Настройки > Настройки продукта > CAPTCHA) предназначена для настройки защиты от автоматических регистраций.

Закладка "Параметры"

Поле | Описание
Профиль | Указывается один из вариантов построения CAPTCHA.
Прозрачность текста в процентах от 0 до 100 | Указывается прозрачность текста на изображениях CAPTCHA в процентах от 0 до 100.
Нижняя граница случайного цвета фона | Указывается нижняя граница случайного цвета фона.
Верхняя граница случайного цвета фона | Указывается верхняя граница случайного цвета фона.
Количество кругов | Указывается количество кругов, которые будут показаны на изображениях CAPTCHA.
Нижняя граница случайного цвета круга | Указывается нижняя граница случайного цвета круга.
Верхняя граница случайного цвета круга | Указывается верхняя граница случайного цвета круга.
Линии поверх текста | При отмеченной опции линии на изображениях CAPTCHA будут отображаться поверх текста
Количество линий | Указывается количество линий, наносимых на изображения CAPTCHA.
Нижняя граница случайного цвета линии | Указывается нижняя граница случайного цвета линии.
Верхняя граница случайного цвета линии | Указывается верхняя граница случайного цвета линии.
Отступ текста слева | Параметр определяет отступ для текста слева на изображениях CAPTCHA (в пикселях).
Размер шрифта | Параметр определяет размер шрифта текста, наносимых на изображения CAPTCHA.
Нижняя граница случайного цвета шрифта | Указывается нижняя граница случайного цвета шрифта.
Верхняя граница случайного цвета шрифта | Указывается верхняя граница случайного цвета шрифта.
Минимальный угол отклонения от вертикали | Указывается минимальный угол отклонения букв текста от вертикали.
Максимальный угол отклонения от вертикали | Указывается максимальный угол отклонения букв текста от вертикали.
Минимальное расстояние между началами символов (при отрицательном значении максимальное расстояние наложения символов) | Указывается минимальное расстояние между началами символов (при отрицательном значении максимальное расстояние наложения символов).
Максимальное расстояние между началами символов (при отрицательном значении минимальное расстояние наложения символов) | Указывается максимальное расстояние между началами символов (при отрицательном значении минимальное расстояние наложения символов).
Нелинейные искажения | При отмеченной опции изображения CAPTCHA будут нелинейно искажаться.
Цвет границы | Указывается цвет границы изображений CAPTCHA.
Используемые шрифты | Указываются шрифты, которые используются на изображениях CAPTCHA. Шритфы храняться в папке /bitrix/modules/main/fonts.
Допустимые символы (рекомендованный набор ABCDEFGHJKLMNPQRSTWXYZ23456789) | Указываются допустимые символы, отображаемые на изображениях CAPTCHA (рекомендованный набор ABCDEFGHJKLMNPQRSTWXYZ23456789).

Смотрите также:

  • CAPTCHA (учебный курс "Администратор. Базовый")


Агенты

Агенты - это технология, позволяющая запускать произвольные PHP-функции (агенты) с заданной периодичностью. В самом начале загрузки каждой страницы система автоматически проверяет, есть ли агент, который нуждается в запуске и в случае необходимости - исполняет его.

Список используемых в системе агентов приводится на странице Список агентов (Настройки > Настройки продукта > Агенты).

Фильтр

Форма фильтра используется для выбора из списка агентов в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Найти | Данное поле позволяет выполнить поиск агентов по наиболее часто используемым критериям: ID агента, Модуль, ID пользователя или Имя агента. Поле присутствует, даже если фильтр свернут.
ID агента | Идентификатор агента.
Модуль | Название модуля, к которому относится данный агент.
ID пользователя | Идентификатор пользователя, который запустил агент. Если необходимо отобразить только те агенты, которые запускаются системой, то в данном поле нужно указать Система.
Имя агента | Поиск агента по его имени (название функции).
Активность | Данное поле позволяет отобразить активные, неактивные или все агенты.
Дата последнего запуска (DD.MM.YYYY) | Поиск агентов по дате их последнего запуска.
Дата следующего запуска (DD.MM.YYYY) | Поиск агентов по дате их последующего запуска.
Периодичность Данное поле позволяет отобрать периодические, непериодические или все агенты.

Периодические агенты нужны чтобы выполнять операцию строго определенное число раз. Например, удаляем 10 файлов кеша раз в 10 секунд. Надо чтобы через минуту было удалено 60 файлов, тогда создается периодический агент.

Если необходимо чтобы агент удалял весь старый кеш разом, то он должен быть непериодическим.

Если с прошлого запуска периодического агента прошло времени больше, чем заданный период, то он будет отрабатывать такое число раз, которое он не отработал.

Пример: Есть два агента с периодом 1 минута периодический и нет. На сайт никто не заходил 10 минут: периодический агент отработает 10 раз, а непериодический - только один.

Для того чтобы отобразить агенты по заданным критериям поиска нажмите кнопку Найти. Для отображения всех агентов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить агента | Переход к форме создания нового агента.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список агентов

Поле | Описание
Колонка флажков | Поле предназначено для выбора агентов, к которым предполагается применить какое-либо правило или действие.
Действие Действия, которые можно произвести над агентом:
  • Изменить - переход к форме редактирования параметров агента;
  • Активировать - перевод агента в активное состояние;
  • Деактивировать - перевод агента в неактивное состояние;
  • Удалить - удаление агента.
ID | Идентификатор агента.
Модуль | Название модуля, к которому относится агент.
[ID] Логин | Система или ID, логин, имя пользователя, запустившего агент.
Сортировка | Относительный "вес" агента. Чем меньше указанное число, тем выше показан в списке агент.
Функция агента | Выполняемая PHP-функция агента.
Активность | Признак активности агента.
Последний запуск | Дата и время последнего запуска агента.
Следующий запуск | Дата и время следующего запуска агента.
Интервал | Интервал запуска агента, указанный в секундах.
Периодический | Признак периодичности агента.

Смотрите также

  • Агенты (учебный курс "Администратор. Базовый")


Создание и редактирование агента

На странице вы можете создать нового или изменить параметры существующего агента.

Контекстная панель

Кнопка | Описание
Список агентов | Переход на страницу со списком агентов.
Добавить | Переход на страницу с формой создания нового агента. Кнопка отображается при редактировании существующего агента.
Удалить агента | Удаление редактируемого агента. Кнопка отображается при редактировании существующего агента.

Закладка Агент

Поле | Описание
Дата последнего запуска | Дата и время последнего запуска агента. Поле отображается при редактировании существующего агента.
*Дата и время следующего запуска (DD.MM.YYYY HH:MI:SS) | Указывается дата и время следующего запуска агента.
Активен | При отмеченной опции агент будет активным. Если агент неактивен, то он не может быть запущен.
Модуль | Указывается название модуля, к которому относится агент. При отсутствии идентификатора модуля считается, что функция агента не принадлежит ни к одному из модулей.
*Функция агента | Задается полное название функции агента. Если функция-агент не принадлежит ни одному из модулей, то ее необходимо разместить в файле /bitrix/php_interface/init.php. Данный файл автоматически подключается в прологе.
ID пользователя | Задается идентификатор пользователя. Если пользователь не выбран, то владельцем агента является система.
Сортировка | Относительный "вес" агента. Чем меньше указанное число, тем выше в списке агентов будет показан данный агент.
Периодичность выполнения Доступны два значения:
  • через заданный интервал - при отмеченной опции агент будет вызываться первый раз в соответствии со значением поля Дата и время следующего запуска, время следующего запуска будет выставлено ровно через интервал, заданный в одноимённом поле ниже.
  • точно в указанное время - при отмеченной опции агент будет вызываться точно во время заданное в поле Дата и время следующего запуска.
Интервал (сек.) | Указывается интервал вызова агента в секундах.

* - поля, обязательные для заполнения.

Смотрите также

  • Пример создания агента (учебный курс "Разработчик Bitrix Framework")


Геолокация

На странице Список обработчиков геолокации (Настройки > Настройки продукта > Геолокация) представлены все обработчики геолокации, имеющиеся в системе.

Описание

Геолокация - получение сведений о местоположении клиента по его IP-адресу.

В системе доступно 3 обработчика геолокации: Расширение GeoIP , MaxMind и Sypex Geo. Для использования первого необходимо иметь установленную библиотеку C GeoIP версии 1.4.0 или выше. Использование сервиса MaxMind требует получения на сайте компании идентификатора пользователя и лицензионного ключа. Сервис Sypex Geo предоставляет 10000 запросов в месяц без регистрации, далее требуется также получение ключа.

Настройки использования обработчика геолокации просты: установите флаг активности и задайте сортировку. На текущий момент активные обработчики используются компонентом Оформление заказа: когда клиент впервые оформляет заказ, то система по IP-адресу определяет его местоположение (страну, город) и поставляет значения в соответствующие поля формы.

Список обработчиков геолокации

Поле | Описание
Действие Действия с обработчиками:
  • Редактировать - редактирование параметров обработчика;
  • Удалить - удаление обработчика.
Наименование | Название обработчика.
Описание | Описание обработчика.
Активность | Признак активности обработчика.
Установлен | Признак того, что обработчик установлен.
Сортировка | Относительный "вес" обработчика.
Языки | Языки, для которых используется обработчик.

Установка расширения GeoIP

Расширение GeoIP позволяет найти местоположение по IP-адресу. С помощью GeoIP можно получить такую информацию как город, государство, страна, долгота и широта.

На UNIX операционных системах установка производится через пакетные менеджеры:

    yum install php-pecl-geoip (cenos)

    brew install php55-geoip (macOS)

Либо загрузив расширение с официального сайта: https://pecl.php.net/package/geoip.

После установки модуля, необходимо загрузить платные базы данных.


Соглашения и список согласий

Форма Соглашения реализована в поддержку выполнения требований ФЗ-152.

Список созданных в системе агентов приводится на странице Соглашения (Настройки > Настройки продукта > Соглашения).

Фильтр

Форма фильтра используется для выбора из спискасоглашений в соответствии с указанными условиями. Поиск выполняется по полям:

Поле | Описание
Название | Поиск соглашения по названию.
Тип | Поиск по типу: собственное или стандартное
Дата создания | Поиск по дате создания.

Чтобы отобразить соглашения по заданным критериям поиска нажмите кнопку Найти. Для отображения всего списка нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания нового соглашения.

Список соглашений

Поле | Описание
Колонка флажков | Поле предназначено для выбора соглашений, к которым предполагается применить какое-либо действие.
Действие Действия, которые можно произвести над соглашением:
  • Открыть - переход к форме редактирования соглашения;
  • Полученные согласия - переход к списку полученных согласий;
  • Удалить - удаление соглашения.
Дата создания | Дата создания соглашения.
Название | Название соглашения. двойной клик открывает соглашение на редактирование.
Тип | Тип соглашения - стандартное или собственное.

Список согласий

На список согласий пользователь попадет по команде Полученные согласия в списке действий страницы Согласия.

Поле | Описание
ID | Идентификатор согласия
Дата | Дата получения согласия
Пользователь | Логин пользователя, давшего согласие с ссылкой на его профиль.
IP | IP адрес, с которого получено согласие.
Источник | Источником согласия могут быть сущности системы, в которых требуется получение согласия, например, заказ в магазине. Может отсутствовать значение.
Адрес | Путь до страницы, где было дано согласие. Может отсутствовать значение.

Смотрите также

  • Согласие на обработку персональных данных (учебный курс "Администратор. Базовый")
  • Согласие в собственных компонентах (учебный курс "Администратор. Базовый")


Создание соглашения

Форма создания или редактирования соглашения.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком соглашений.

Форма редактирования

Поле | Описание
Название | Название соглашения
Тип | Указывается тип: собственное соглашение или стандартное. От выбора типа зависит количество полей для заполнения. При выборе "Стандартное" справа появится ссылка для просмотра стандартного согласия.
Поля для собственного типа
Текст согласия | Указывается текст, с которым должен согласится пользователь.
Подпись галки согласия | Текст, который будет выведен на кнопке согласия.
При клике на ссылку открывать стороннюю ссылку или файл | Опция позволяет вывести на кнопке согласия указанную ссылку. Для вывода ссылки только у части текста, указанного в поле подпись галки согласия, необходимую часть нужно заключить в знаки процента: %текст%. Иначе весь текст будет отображен в виде ссылки.
Поля для стандартного типа
Источник данных | Источник данных - откуд будут браться данные для соглашения. Если выбран указывается вручную, то нужно заполнить вручную Название и Адрес регистрации компании. Если выбрано Реквизиты компании, то данные система подставит сама.
Указать свой вариант использования персональных данных | Если использование персональных данных отличается от типовых, то установка флажка сделает активным поле для ввода своего текста соглашения.
Информация передается третьим лицам | Если персональные данные передаются третьим лицам, то небходимо установить этот флажок и в появившемся поле указать куда передаются эти данные.
Email-адрес для жалоб | Указывается адрес куда могут обращаться пользователи для жалоб. Если не указан, то используется адрес системы по умолчанию.

Смотрите также

  • Согласие на обработку персональных данных (учебный курс "Администратор. Базовый")


Отправить отзыв по этому разделу

Сайты

  • Список сайтов
  • Создание и редактирование сайта
  • Шаблоны сайта
  • Создание и редактирование шаблона сайта
  • Импорт шаблона


Список сайтов

Добавление, изменение и удаление сайтов в системе выполняется на странице Список сайтов (Настройки > Настройки продукта > Сайты > Список сайтов).

Контекстная панель

Кнопка | Описание
Добавить сайт | Переход к форме создания нового сайта.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список сайтов

Поле | Описание
Колонка флажков | Поле предназначено для выбора сайтов, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над сайтом:
  • Изменить - переход к форме редактирования параметров сайта;
  • Копировать - копирование сайта;
  • Удалить- удаление сайта.
ID | Идентификатор сайта.
Акт. | Признак активности сайта. Если сайт неактивен, то он становится недоступным.
Сортировка Относительный вес, определяющий положение сайта в списке.

Если в системе второй сайт работает на [dw]поддомене[/dw][di] Пример:

site1.com - первый сайт

site2.site1.com - второй сайт (на поддомене первого сайта) [/di] домена первого сайта, то он в списке сайтов должен иметь [dw]наименьшее[/dw][di] [image] [/di] значение.

В противном случае (или при равенстве значений в поле Сортировка) система будет открывать первый сайт при обращении ко второму.

Для случаев, когда сайты находятся на [dw]разных доменах[/dw][di] Пример разных доменов:

site1.com

site2.com [/di] или [dw]разных поддоменах,[/dw][di] Пример разных поддоменов:

bus.site.com

b24.site.com [/di] сортировка может быть любой.

Название | Произвольное название сайта.
Папка Путь к папке сайта. Ядро системы позволяет использовать следующие типы URL для идентификации сайтов, работающих под управлением системы:
  • относительные (/ru/, /s2/) - для работы зеркал сайта на одном домене под управлением одной системы;
  • абсолютные корневые (www.site.ru) - для работы различных сайтов под управлением одной системы;
  • абсолютные (www.site.ru/s2/) - для работы разрозненных зеркал и/или сайтов под управлением одной системы.
Более подробная информация об организации многосайтовости содержится в курсе Многосайтовость [image].
По умолчанию | Сайт, загружаемый системой по умолчанию.

Смотрите также

  • Удаление сайтов (учебный курс "Администратор. Базовый")


Создание и редактирование сайта

Форма создания/редактирования сайта предназначена для настройки параметров существующего или вновь создаваемого сайта системы.

Контекстная панель

Кнопка | Описание
Список сайтов | Переход на страницу со списком сайтов.
Добавить сайт | Переход к форме создания нового сайта. Кнопка отображается при редактировании существующего сайта.
Копировать сайт | Копирование редактируемого сайта. Кнопка отображается при редактировании существующего сайта.
Удалить сайт | Удаление редактируемого сайта. Кнопка отображается при редактировании существующего сайта.

Закладка Параметры

Поле | Описание
*ID | Указывается идентификатор сайта в системе. Идентификатор состоит из двух букв латинского алфавита. Например, ru, en.
Активен | При отмеченной опции сайт будет активен. Если сайт неактивен, то он недоступен.
*Название | Указывается произвольное название сайта.
Параметры для определения сайта в публичном разделе
По умолчанию | При отмеченной опции сайт будет загружаться по умолчанию.
Доменное имя Задается доменное имя или список доменных имен (каждое с новой строки) сайта. С 11-ой версии поддерживается кириллические домены. Уровень домена может быть любым.

При определении сайта каждый элемент этого списка интерпретируется как корневой домен (например, значение site.com будет означать www.site.com, my.site.com и т.д.)

Заполнять поле рекомендуется только для организации многосайтовости на одном ядре [image].

*Папка сайта Указывается путь к папке сайта. Ядро системы позволяет использовать следующие типы URL для идентификации сайтов, работающих под управление системы:
  • относительные (/ru/, /s2/) - для работы зеркал сайта на одном домене под управлением одной системы;
  • абсолютные корневые (www.site.ru) - для работы различных сайтов под управлением одной системы;
  • абсолютные(www.site.ru/s2/) - для работы разрозненных зеркал и/или сайтов под управлением одной системы.
Примечание: папка должна существовать.
*Сортировка Задается относительный "вес", влияющий на положение сайта в списке.

Если в системе второй сайт работает на [dw]поддомене[/dw][di] Пример:

site1.com - первый сайт

site2.site1.com - второй сайт (на поддомене первого сайта) [/di] домена первого сайта, то он в списке сайтов должен иметь [dw]наименьшее[/dw][di] [image] [/di] значение.

В противном случае (или при равенстве значений в поле Сортировка) система будет открывать первый сайт при обращении ко второму.

Для случаев, когда сайты находятся на [dw]разных доменах[/dw][di] Пример разных доменов:

site1.com

site2.com [/di] или [dw]разных поддоменах,[/dw][di] Пример разных поддоменов:

bus.site.com

b24.site.com [/di] сортировка может быть любой.

Параметры
Название веб-сайта | Задается произвольное название сайта.
URL сервера (без http://) | Указывается URL сервера, на котором размещён сайт (без http://). Используется в почтовых сообщениях для идентификации отправителя (например, для автоматически сгенерированных сообщений).
E-Mail адрес по умолчанию Указывается адрес отправителя сообщений сайта. Подставляется в поле From. С версии 20.700.0 Главного модуля (main) добавлена возможность использовать email с [dw]IDN[/dw][di]IDN (англ. Internationalized Domain Names — интернационализованные доменные имена) — это доменные имена, которые содержат символы национальных алфавитов, например, мойсайт.рф.

Подробнее [image]...[/di], включая кириллические домены.
Путь к корневой папке веб-сервера для этого сайта (оставьте пустым, если все сайты работают на одном веб-сервере) Указывается путь к корневой папке веб-сервера для данного сайта. С помощью ссылки вставить текущий в данное поле может быть подставлен путь к текущей корневой папке сайта на сервере.

Если все сайты под управлением системы работают на одном веб-сервере, то данное поле следует оставить пустым.
Региональные настройки
*Язык | Указывается язык, используемый для представления информации на страницах сайта.
*Региональные настройки | Выбирается одна из ранее созданных Региональных настроек.
Далее следуют неактивные поля для просмотра значений выбранных Региональных настроек:
  • Формат даты
  • Формат даты и времени
  • Первый день недели
  • Формат имени
  • Кодировка
  • Направление текста
Для смены значений Региональных настроек воспользуйтесь ссылкой Изменить выбранные настройки.
Почтовые шаблоны
Создать почтовые шаблоны Данное поле позволяет создать шаблоны, на основе которых будут генерироваться почтовые сообщения сайта:
  • не создавать - почтовые шаблоны создаваться не будут;
  • привязать к имеющимся шаблонам сайта - для почтовых сообщений данного сайта буду использоваться почтовые шаблоны одного из уже существующих сайтов;
  • скопировать из шаблонов сайта - почтовые шаблоны данного сайта будут созданы на основе почтовых шаблонов уже существующего сайта.
Шаблон сайта
Поле служит для задания условий применения того или иного шаблона дизайна к страницам сайта. В форме создания сайта и в форме редактирования эти поля отличаются.
  • Форма создания сайта:
    Поле | Описание
    Запустить мастер установки решения | После создания сайта сразу запуститься мастер установки решения, позволяющий установить на созданный сайт то или иное решение от компании "1С-Битрикс" или партнеров (через Marketplace).
    Выбрать шаблон Появится [dw]форма выбора шаблона,[/dw][di]
    Поле | Описание
    Шаблон | Список доступных шаблонов сайта. Иконка позволяет просмотреть выбранный шаблон.
    Сорт. | Относительный "вес", влияющий на положение записи с условием применения шаблона в списке.
    Тип условия Тип условия, при выполнении которого шаблон будет применяться к страницам сайта:
    • Для папки или файла - страница или раздел, при отображении страниц которого будет использоваться данный шаблон;
    • Для групп пользователей - группы пользователей, для которых страницы сайта будут отображаться с использованием данного шаблона;
    • Период времени - дата или период времени, в течение которого страницы сайта будут отображаться с использованием данного шаблона;
    • Параметр в URL - параметр в URL страницы, при наличии которого к странице будет применен данный шаблон;
    • Выражение PHP - произвольное условие на языке PHP.
    Условие Условие, при котором шаблон будет применяться к страницам сайта.

    Примечание: для того чтобы выбранный шаблон дизайна применялся к страницам сайта по умолчанию, это поле нужно оставить пустым.
    [/di] форма выбора шаблона, аналогичная форме выбора шаблона в форме редактирования сайта. (См. ниже.)
    Заменить существующее решение при необходимости | Заменит имеющееся решение на новое. Активна только при выборе Запустить мастер установки решения.
  • Форма редактирования сайта:
    *Шаблон | Сорт. | Тип условия | Условие
    [1] | [2] | [3] | [4]
    Поле | Описание
    [1] *Шаблон | Список доступных шаблонов сайта. Иконка [img]643256[/img] позволяет просмотреть выбранный шаблон.
    [2] Сорт. | Относительный "вес", влияющий на положение записи с условием применения шаблона в списке.
    [3] Тип условия Тип условия, при выполнении которого шаблон будет применяться к страницам сайта:
    • Для папки или файла - страница или раздел, при отображении страниц которого будет использоваться данный шаблон;
    • Для групп пользователей - группы пользователей, для которых страницы сайта будут отображаться с использованием данного шаблона;
    • Период времени - дата или период времени, в течение которого страницы сайта будут отображаться с использованием данного шаблона;
    • Параметр в URL - параметр в URL страницы, при наличии которого к странице будет применен данный шаблон;
    • Выражение PHP - произвольное условие на языке PHP.
    [4] Условие Условие, при котором шаблон будет применяться к страницам сайта.

    Примечание: для того чтобы выбранный шаблон дизайна применялся к страницам сайта по умолчанию, это поле нужно оставить пустым.

* - поля, обязательные для заполнения.


Шаблоны сайта

Шаблон дизайна - это внешний вид сайта, в котором определяется расположение различных элементов на сайте, художественный стиль и способ отображения страниц. Включает в себя программный HTML-код, графические компоненты, таблицы стилей и дополнительные шаблоны для отображения контента.

Управление шаблонами осуществляется на странице Шаблоны сайта (Настройки > Настройки продукта > Сайты > Шаблоны сайтов). С ее помощью вы можете создавать новые, изменять и удалять существующие шаблоны дизайна сайта.

Контекстная панель

Кнопка | Описание
Добавить шаблон | Переход на страницу с формой создания нового шаблона сайта.
Загрузить шаблон | Переход к форме загрузки (импорта) шаблона сайта в систему.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список шаблонов

Поле | Описание
Колонка флажков | Поле предназначено для выбора шаблонов сайта, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над шаблоном:
  • Изменить - переход к форме редактирования шаблона дизайна сайта;
  • Копировать - копирование (дуплицирование) шаблона;
  • Скачать - сохранение шаблона;
  • Удалить - удаление шаблона.
ID | Идентификатор шаблона.
Название | Произвольное название шаблона.
Описание | Произвольное описание шаблона.
Скриншот | Отображается скриншот шаблона, если в закладке Дополнительные файлы форма создания/редактирования шаблона был загружен скриншот с именем screen.gif.
Порядок | Порядок следования шаблонов в списке.

Смотрите также

Смотрите также:

  • Шаблон сайта (учебный курс "Разработчик Bitrix Framework")


Создание и редактирование шаблона сайта

Закладки

Контекстная панель

Кнопка | Описание
Список шаблонов | Переход на страницу со списком шаблонов сайта.
Добавить | Переход к форме создания нового шаблона сайта. Кнопка отображается при редактировании существующего шаблона сайта.
Копировать | Копирование редактируемого шаблона сайта. Кнопка отображается при редактировании существующего шаблона сайта.
Удалить | Удаление редактируемого шаблона сайта. Кнопка отображается при редактировании существующего шаблона сайта.

Для удобства работы форма создания/редактирования шаблона разделена на несколько закладок. На каждой закладке выполняется определённая группа действий по настройке шаблона.

Шаблон

Поле | Описание
ID | Указывается идентификатор шаблона (символами латинского алфавита). При редактировании шаблона рядом с данным полем отображается ссылка на папку шаблона. Примечание: при создании новый шаблон будет автоматически сохранен в каталоге /bitrix/templates/ в папке с именем, соответствующим идентификатору шаблона.
Название | Задается произвольное название шаблона.
Описание | Задается произвольное описание шаблона.
Порядок | Значение этого поля задаёт порядок следования шаблона в общем списке шаблонов.
*Внешний вид шаблона сайта (рабочую область заменить #WORK_AREA#)
Поле служит для создания и редактирования кода шаблона. Разделитель #WORK_AREA# обозначает границу между верхней и нижней частью дизайна, т.е. место подключения рабочей области страницы. Примечание: опция Использовать визуальный редактор служит для подключения визуального режима редактирования шаблона. Опция доступна в версиях до 14.0, если в настройках Главного модуля отмечена опция Использовать визуальный редактор для редактирования шаблонов сайта.

* - поля, обязательные для заполнения.

Стили сайта

Файл стилей сайта (styles.css)
Поле служит для описания таблиц каскадных стилей (CSS), используемых на страницах сайта. Описание стилей хранится в файле styles.css в папке шаблона сайта.
Описание стилей
В данной части формы указываются названия стилей, как они будут отображаться в визуальном редакторе при редактировании страниц. Указанные здесь названия будут сохранены в файле .styles.php папки шаблона.
Поле | Описание
Имя стиля | Указывается название стиля. Название будет отображаться в визуальном редакторе.
Описание стиля | Указывается произвольное описание стиля.

Кнопка Еще... позволяет добавляет в форму еще одну пустую строку.

Стили шаблона

Файл стилей шаблона (template_styles.css)
Поле служит для описания таблиц каскадных стилей (CSS), используемых в шаблоне. Описание стилей хранится в файле template_styles.css в папке шаблона сайта.

Дополнительные файлы

Дополнительные файлы (включаемые области, картинки)
В поле указываются дополнительные файлы (картинки, шаблоны меню, шаблоны включаемых областей и др.), используемые для текущего шаблона сайта.
Следующие ссылки, расположенные под списком файлов, позволяют:
  • Добавить включаемый файл - перейти на страницу с формой создания нового включаемого файла;
  • Загрузить файл - перейти к загрузке произвольного файла в папку с шаблоном;
  • Управление структурой - перейти к управлению структурой папки с шаблоном.


Импорт шаблона

Форма Импорт шаблона предназначена для загрузки готовых шаблонов сайта в систему. Форма доступна по кнопке Загрузить шаблон, расположенной на контекстной панели страницы Шаблоны сайта.

Закладка "Импорт шаблона"

Поле | Описание
*Файл с шаблоном для загрузки (*.gz) | С помощью кнопки Обзор... укажите файл с шаблоном для загрузки. Обратите внимание, файлы шаблона должны быть в кодировке UTF-8.
Код шаблона | При загрузке по умолчанию шаблон будет распакован и помещен в папку с именем, соответствующим имени загружаемого файла. Например, если имя загружаемого файла template1.tar.gz, то шаблон будет автоматически помещен в папку /template1/, а самому шаблону будет присвоен идентификатор (ID) template1. Для того чтобы шаблону был присвоен другой идентификатор, а сам шаблон был размещён в папке с соответствующим именем, в данном поле указывается нужный код шаблона. Например, demo.
Привязать как шаблон по умолчанию к сайту | Указывается сайт, для которого загружаемый шаблон будет использоваться как шаблон по умолчанию.
Перейти после сохранения на страницу редактирования шаблона | При отмеченной опции после завершения загрузки шаблона будет открыта страница редактирования шаблона.

* - поля, обязательные для заполнения.


Отправить отзыв по этому разделу

Языковые параметры

  • Языки интерфейса
  • Создание и редактирование языка интерфейса
  • Региональные настройки
  • Создание и редактирование Региональной настройки


Языки интерфейса

Описание

Одной из важных особенностей продукта "1C-Битрикс: Управление сайтом" является поддержка произвольного количества языков. Система позволяет:

  • использовать многоязычный интерфейс в административном разделе;
  • создавать произвольное количество сайтов на различных языках в рамках одной системы (управление параметрами языков публичного раздела сайта выполняется отдельно для каждого сайта).

Управление языками административного интерфейса системы осуществляется на странице Языки интерфейса (Настройки > Настройки продукта > Языки интерфейса).

Список языков в форме определяет, на каких языках будет доступно отображение системных текстовых сообщений: информационных сообщений, сообщений об ошибках, заголовков таблиц, надписей на кнопках управления и т.д.

Выбор текущего языка административного раздела сайта осуществляется с помощью меню [image] на административной панели:

Дополнительно смотрите информацию в разделе Языки интерфейса [image] учебного курса Администратор. Базовый.

Контекстная панель

Кнопка | Описание
Добавить язык | Переход к форме создания записи о новом языке.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список языков

Поле | Описание
Колонка флажков | Поле предназначено для выбора языков, к которым предполагается применить какое-либо правило или действие.
Действия Операции с языком:
  • Изменить - переход к форме редактирования параметров языка;
  • Добавить копию - копирование (дуплицирование) языка;
  • Удалить - удаление языка.
ID | Идентификатор языка.
Акт. | Признак активности. Если язык не активен, то отображение сообщений на данном языке недоступно.
Сорт. | Относительный "вес", определяющий положение языка в списке.
Название | Произвольное название языка.
По умолчан. | Признак использования языка по умолчанию. При открытии сайта все языковые сообщения будут именно на этом языке.
*Региональные настройки | Выбирается одна из ранее созданных Региональных настроек.
Далее следуют неактивные поля для просмотра значений выбранных Региональных настроек:
  • Формат даты
  • Формат даты и времени
  • Первый день недели
  • Формат имени
  • Кодировка
  • Направление текста
Для смены значений Региональных настроек воспользуйтесь ссылкой Изменить выбранные настройки.

Смотрите также

  • Управление языками и Региональные настройки (учебный курс "Администратор. Базовый")


Создание и редактирование языка интерфейса

Форма создания/редактирования языка интерфейса предназначена для настройки параметров существующего или вновь создаваемого языка интерфейса.

Контекстная панель

Кнопка | Описание
Список языков | Переход на страницу со списком языков интерфейса.
Добавить язык | Переход к форме создания нового языка интерфейса. Кнопка отображается при редактировании существующего языка интерфейса.
Добавить копию | Копирование редактируемого языка интерфейса. Кнопка отображается при редактировании существующего языка интерфейса.
Удалить язык | Удаление редактируемого языка интерфейса. Кнопка отображается при редактировании существующего языка интерфейса.

Закладка Параметры

Поле | Описание
*ID | Указывается идентификатор языка интерфейса в системе (используется для загрузки соответствующих языковых файлов, поэтому должен совпадать с идентификатором языка в системе обновлений).
Активен | Признак активности языка интерфейса. Если язык неактивен, то отображение сообщений на данном языке недоступно.
*Название | Название языка интерфейса.
По умолчанию | При отмеченной опции все языковые сообщения интерфейса будут отображаться на этом языке.
*Сортировка | Относительный "вес", определяющий положение языка в списке языков интерфейса.
*Региональные настройки | Выбор ранее созданных региональных настроек, применяемых к данному языку. Ниже отображаются неактивные поля с выбранными настройками. Для смены значений полей используйте ссылку Изменить выбранные настройки

* - поля, обязательные для заполнения.


Региональные настройки

В продуктах Bitrix Framework можно задать понятие Региональная настройка. Региональная настройка - это набор параметров, которые могут быть различными у той или иной культуры. Например: Формат имени или Первый день недели.

Региональная настройка привязывается к определённому языку интерфейса и к сайту. Контент сайта будет отображаться в зависимости от этих настроек, при задании того или иного языка интерфейса.

Управление языками административного интерфейса системы осуществляется на странице Языки интерфейса (Настройки > Настройки продукта > Языковые параметры > Региональные настройки).

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания записи новой региональной настройки.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список Региональных настроек

Поле | Описание
Колонка флажков | Поле предназначено для выбора Настроек, к которым предполагается применить какое-либо правило или действие.
Действия Операции с Настройками:
  • Изменить - переход к форме редактирования Региональной настройки;
  • Добавить копию - копирование Региональной настройки;
  • Удалить - удаление Региональной настройки.
ID | Идентификатор Региональной настройки.
Символьный код | Двузначный код, обозначающий данную настройку
Название | Произвольное название Региональной настройки.
Формат даты | Выбранный формат даты.
Формат даты и времени | Выбранный формат даты и времени.
Формат имени | Выбранный формат имени.
Кодировка | Выбранный формат кодировки.
Начало недели | Выбранный формат недели.
Направление | Выбранный формат написания текста.


Создание и редактирование Региональной настройки

Форма создания/редактирования Региональной настройки предназначена для настройки параметров существующей или вновь создаваемой настройки.

Контекстная панель

Кнопка | Описание
Список | Переход на страницу со списком региональных настроек.
Добавить | Переход к форме создания нового настройки. Кнопка отображается при редактировании существующей настройки.
Добавить копию | Копирование редактируемой настройки. Кнопка отображается при редактировании существующей настройки.
Удалить | Удаление редактируемой настройки. Кнопка отображается при редактировании существующей настройки.

Закладка Параметры

Поле | Описание
ID | Отображается идентификатор Региональной настройки в системе (виден только при редактировании).
*Название | Название Региональной настройки.
*Формат даты (например: DD.MM.YYYY) | Указывается краткий формат показа даты в публичном и административном разделах сайта. Например, DD.MM.YYYY. Список основных форматов дат доступен на странице документации для разработчиков Формат даты и времени [image] .
*Формат даты и времени (например: DD.MM.YYYY HH:MI:SS) | Указывается полный формат показа даты и времени в публичном и административном разделах сайта. Например, DD.MM.YYYY HH:MI:SS.
Первый день недели | В выпадающем списке выберите день недели, который в данном регионе принят как первый.
*Формат имени | В выпадающем списке выберите формат отображения имени, принятый в данном регионе..
*Кодировка | Используемая кодировка для данного языка [image] .
Направление текста | Выберите направление текста, соответствующее данной культуре.
Символьный код | Двузначный код настройки.

* - поля, обязательные для заполнения.

Закладка Форматы вывода

Поле | Описание | Пример
Форматы даты
Дата в числовом формате | Число, месяц и год через слеш или точку | n/j/Y (7/24/2020 или 24.07.2020)
Число, месяц (сокращенный) и год | Указывается формат короткой даты. | j M Y (24 июл 2020)
Число, месяц и год | Указывается обычный формат даты. | j M Y (30 Января 2019)
Число и месяц | Указывается формат отображения числа и месяца. | j F (30 Января)
Число и месяц (сокращённый) | Упрощённый вариант числа и месяцев. | j F Y (30 Янв)
День недели (сокращённый), число и месяц | Упрощённый вариант числа. | D, j F (Пт, 24 июл)
День недели (сокращённый), число и месяц (сокращённый) | Упрощённый вариант числа и месяца. | D, j M (Пт, 24 июл)
День недели, число и месяц | Обычный вариант числа и месяца. | I, j F (Пятница, 24 июля)
День недели, число, месяц и год | Полная дата с днем недели | l, j F Y (Среда, 30 Января 2019)
Форматы времени
Время без секунд | Часы и минуты. Если необходимо к записи добавляется модификатор типа a | H:i (10:24)
Время с секундами | Часы, минуты, секунды. Если необходимо к записи добавляется модификатор типа a. | H:i:s (10:24:13)
Значение am | Обозначение времени «до полудня» при 12-часовом формате исчисления времени. | 10:24 am
Значение pm | Обозначение времени «после полудня» при 12-часовом формате исчисления времени. | 3:15 pm
Формат чисел
Разделитель тысяч | Указывается знак препинания, которым разделяют тысячные разряды в числе. | 2,345,678.12
Десятичный разделитель | Указывается знак препинания, которым разделяют целое число от десятых. | 5.25
Десятичных разрядов после разделителя | Указывается, сколько чисел отображать после десятичного разделителя. | При значении 3: 5.254

Модификаторы формата даты и времени

Поле | Описание | Пример
Y | Год. | 2019
F | Название месяца в родительном падеже. | Января
f | Название месяца в именительном падеже. | Январь
M | Сокращенное название месяца. | Янв
m | Номер месяца в двузначном формате. | 01
n | Номер месяца. | 1
[dw] l [/dw][di]Маленькая латинская буква L[/di] | Название дня недели. | Среда
D | Сокращенное название дня недели. | Ср
j | День. | 30
H | Часы для 24-часового формата. | 14:25
g | Часы для 12-часового формата. | 2:25
i | Минуты. | 14:25
s | Секунды. | 14:25:23
a | Отображение am/pm при 12-часовом формате исчисления времени. | g:i:s a 2:25:23 pm

Смотрите также

  • Управление языками и Региональные настройки (учебный курс "Администратор. Базовый")


Отправить отзыв по этому разделу

Почтовые и СМС события

  • Почтовые шаблоны
  • Создание и редактирование почтового шаблона
  • Шаблоны СМС-сообщений
  • Создание и редактирование шаблона смс сообщения
  • Типы событий
  • Создание и редактирование типа почтового события
  • Темы оформления
  • Создание и редактирование темы
  • Настройки SMTP
  • Создание и редактирование SMTP-подключения


Почтовые шаблоны

Описание

Страница Почтовые шаблоны (Настройки > Настройки продукта > Почтовые и СМС события > Почтовые шаблоны) служит для управления шаблонами почтовых сообщений. При возникновении на сайте события на отправку какого-либо письма, система ищет подходящий шаблон для такого письма. Если шаблон найден, то письмо отправляется в соответствии с этим шаблоном.

Шаблоны почтовых сообщений различаются по типам сообщений и сайтам, для которых шаблоны предназначены.

Каждый шаблон почтового сообщения может содержать два типа данных:

  • Неизменяемые данные (константы) - не изменяются от письма к письму по этому шаблону. Другими словами, все получатели письма получат эти данные в таком виде, в котором они занесены в шаблон письма. Примером неизменяемых данных является подпись внизу письма "С уважением, служба поддержки".
  • Изменяемые данные (параметры) - меняются от письма к письму в зависимости от разных условий. Другими словами, каждый получатель письма получит те данные, которые предназначены именно ему. Примером изменяемых данных является e-mail адрес получателя данного письма. Доступные для данного типа сообщения изменяемые данные перечислены в форме редактирования шаблона почтового сообщения в секции Доступные поля.

Фильтр

Форма фильтра используется для выбора из списка почтовых шаблонов в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Найти | Поле позволяет найти требуемые почтовые шаблоны по наиболее типичным критериям, выбираемым в списке: Тема, Отправитель, Получатель или Содержимое шаблона.
ID | Поиск по идентификатору шаблона.
Тип почтового события | Поиск шаблона по типу почтового события, к которому он относится.
Дата изменения (DD.MM.YYYY) | Поиск шаблона по интервалу дат последнего изменения почтового шаблона. Интервал указывается в формате DD.MM.YYYY.
Сайт | Поиск шаблона по cайту, на котором используется шаблон.
Активность | Поиск шаблона по активным, неактивным или всем шаблонам.
От кого | Поиск шаблона по адресу отправителя почтового сообщения.
Кому | Поиск шаблона по адресу получателя почтового сообщения.
Скрытая копия (BCC) | Поиск шаблона по адресу получателя скрытой копии сообщения.
Тема | Поиск шаблона по теме почтового сообщения.
Тип тела сообщения | Поиск шаблона по типу тела сообщения: text, html или по обоим типам.
Тело сообщения | Поиск шаблона по содержимому тела сообщения.

Контекстная панель

Кнопка | Описание
Добавить шаблон | Переход к форме создания нового почтового шаблона.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список почтовых шаблонов

Поле | Описание
Колонка флажков | Поле предназначено для выбора почтовых шаблонов, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над почтовым шаблоном:
  • Изменить - переход к форме редактирования параметров почтового шаблона;
  • Добавить копию - копирование почтового шаблона;
  • Удалить - удаление почтового шаблона.
ID | Идентификатор почтового шаблона.
Дата изм. | Дата и время последнего изменения шаблона.
Акт. | Признак активности почтового шаблона. Если шаблон не активен, то данный шаблон не будет использоваться для генерации почтовых сообщений.
Сайт | Идентификатор сайта, для отправки почтовых сообщений с которого используется данный шаблон.
Тип почтового события | Название типа почтового события, при возникновении которого будет сгенерировано почтовое сообщение на основе данного шаблона.
Тип почтового события | Код и название типа почтового события, при возникновении которого будет сгенерировано почтовое сообщение на основе данного шаблона.
Тема | Тема почтового сообщения. При генерации сообщения подставляется в поле Тема.
Отправитель | Адрес отправителя почтового сообщения.
Получатель | Адрес получателя почтового сообщения.
Скрытая копия (BCC) | Адрес получателя скрытой копии сообщения.
Тип тела сообщения | Формат тела сообщения: text или html.

Смотрите также

  • Работа с почтовыми шаблонами (учебный курс "Администратор. Модули")


Создание и редактирование почтового шаблона

Форма предназначена для создания нового или изменения уже существующего почтового шаблона.

Контекстная панель

Кнопка | Описание
Список шаблонов | Переход на страницу со списком шаблонов почтовых сообщений.
Тип события | Переход к форме редактирования соответствующего типа почтового события.
Добавить | Переход к форме создания нового почтового шаблона. Кнопка отображается при редактировании существующего почтового шаблона.
Копировать | Копирование редактируемого почтового шаблона. Кнопка отображается при редактировании существующего почтового шаблона.
Удалить | Удаление редактируемого почтового шаблона. Кнопка отображается при редактировании существующего почтового шаблона.

Закладка Параметры

Поле | Описание
Последнее обновление | Дата и время последнего изменения почтового шаблона. Поле отображается при редактировании существующего почтового шаблона.
Активен | При отмеченной опции почтовый шаблон будет активным. Если шаблон не активен, то данный шаблон не будет использоваться для генерации почтовых сообщений.
*Сайт | Указывается сайт (или сайты), для отправки почтовых сообщений с которого используется данный шаблон.
Язык | Указывается язык события. При создании письма выбираются почтовые шаблоны, соответствующие языку события, либо не имеющие установленного языка. При многоязычном сайте язык выбранного сайта и язык шаблона должны [dw]совпадать[/dw][di] [image] [/di].
Тип почтового события | Указывается тип почтового события (код и название типа почтового события), при возникновении которого будет сгенерировано почтовое сообщение на основе данного шаблона. Название шаблона - ссылка, которая позволяет перейти к редактированию типа события.
*От кого ** Указывается адрес отправителя почтового сообщения. С версии 20.700.0 Главного модуля (main) возможно использовать email с [dw]IDN[/dw][di]IDN (англ. Internationalized Domain Names — интернационализованные доменные имена) — это доменные имена, которые содержат символы национальных алфавитов, например, мойсайт.рф.

Подробнее [image]...[/di], включая кириллические домены.
*Кому** | Указывается адрес получателя почтового сообщения.
Ссылка показать дополнительные заголовки... При нажатии на ссылку становятся доступны следующие поля:
  • Копия - указывается адрес получателя копии сообщения.;
  • Скрытая копия - По умолчанию стоит макрос #BCC#. В этом случае выводятся адреса из поля E-Mail адрес или список адресов через запятую, на который будут дублироваться все исходящие сообщения настроек Главного модуля. При необходимости можно указать прямой адрес получателя скрытой копии сообщения;
  • Обратный адрес- указывается обратный адрес сообщения;
  • Ответ на сообщение - указывается ответ на сообщение сообщения;
  • Важность - задается важность сообщения;
  • [пользовательские_поля]- указываются значения дополнительных пользовательских полей.
Тема** | Указывается тема почтового сообщения.
Тип тела сообщения Указывается формат тела сообщения:
  • Текст - текстовый формат;
  • HTML - тело сообщения будет представлено в HTML формате.
  • Визуальный редактор - тело сообщения можно редактировать в визредакторе.
Тело сообщения**
Поле для создания информационной части (текста) сообщения.
Доступные поля
В данной секции представлены шаблоны переменных (изменяемых данных), которые могут быть подставлены в поля сообщения, отмеченные **.

Например, в поле От кого может быть подставлен шаблон #DEFAULT_EMAIL_FROM#. Это значит, что в качестве адреса отправителя сообщения будет подставляться e-mail адрес, указанный в настройках соответствующего сайта или Главного модуля.

* - поля, обязательные для заполнения.

** - значения данных полей могут быть заданы с помощью шаблонов, представленных в секции Доступные поля.

Закладка Вложения

Поле | Описание
Загрузить вложения | Указывается путь до файла, который должен служить вложением в сообщение.

Смотрите также

  • Работа с почтовыми шаблонами (учебный курс "Администратор. Модули")


Шаблоны СМС-сообщений

Описание

Страница Шаблоны СМС-сообщенй (Настройки > Настройки продукта > Почтовые и СМС события > Шаблоны СМС) служит для управления шаблонами смс сообщений. При возникновении на сайте события на отправку смс сообщения, система ищет подходящий шаблон. Если шаблон найден, то смс отправляется в соответствии с этим шаблоном.

Шаблоны смс сообщений различаются по типам событий, языкам и сайтам, для которых шаблоны предназначены. Каждый шаблон сообщения может содержать два типа данных:

  • Неизменяемые данные (константы) - не изменяются от сообщения к сообщению по этому шаблону. Другими словами, все получатели смс получат эти данные в таком виде, в котором они занесены в шаблон сообщения. Примером неизменяемых данных является сам текст сообщения.
  • Изменяемые данные (параметры) - меняются от письма к письму в зависимости от разных условий. Другими словами, каждый получатель письма получит те данные, которые предназначены именно ему. Примером изменяемых данных является название сайта от имени которого производится рассылка. Доступные для данного типа сообщения изменяемые данные перечислены в форме редактирования шаблона почтового сообщения в секции Доступные поля.

Фильтр

Поле | Описание
Найти | Поле позволяет найти требуемые шаблоны по наиболее типичным критериям, выбираемым в списке: Текст сообщения, Отправитель, Получатель.
ID | Поиск по идентификатору шаблона.
Название события | Поиск шаблона по событию, к которому он относится.
Сайт | Поиск шаблона по cайту, на котором используется шаблон.
Язык сообщения | Поиск шаблона по языку сообщения.
Активен | Поиск шаблона по активным, неактивным или всем шаблонам.
Телефон отправителя | Поиск шаблона по телефону отправителя.
Телефон получателя | Поиск шаблона по телефону получателя.
Шаблон сообщения | Поиск шаблона тексту или его части в шаблоне сообщения.

Контекстная панель

Кнопка | Описание
Добавить шаблон | Переход к форме создания нового шаблона сообщения.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список шаблонов сообщений

Поле | Описание
Колонка флажков | Поле предназначено для выбора почтовых шаблонов, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над почтовым шаблоном:
  • Изменить - переход к форме редактирования параметров шаблона смс сообщения;
  • Добавить копию - копирование шаблона;
  • Удалить - удаление шаблона.
ID | Идентификатор шаблона.
Название события | Название события.
Акт. | Признак активности шаблона. Если шаблон не активен, то он не используется для генерации смс сообщений.
Сайт | Идентификатор сайта, для отправки почтовых сообщений с которого используется шаблон.
Язык сообщения | Язык, используемый в сообщении.
Шаблон сообщения события | Текст шаблона сообщения.
Телефон отправителя | Телефон отправителя
Телефон получателя | Телефон получателя


Создание и редактирование шаблона смс сообщения

Форма предназначена для создания нового или изменения уже существующего шаблона смс сообщения.

Контекстная панель

Кнопка | Описание
Список шаблонов | Переход на страницу со списком шаблонов почтовых сообщений.
Добавить | Переход к форме создания нового почтового шаблона.***
Копировать | Копирование редактируемого почтового шаблона.***
Удалить | Удаление редактируемого почтового шаблона.***

Закладка Параметры

Поле | Описание
ID шаблона | Идентификатор шаблона. Поле отображается при редактировании существующего почтового шаблона.
*Название события | Название события.
Активен | При отмеченной опции почтовый шаблон будет активным. Если шаблон не активен, то данный шаблон не будет использоваться для генерации почтовых сообщений.
*Сайт | Указывается сайт (или сайты), для отправки сообщений с которого используется этот шаблон.
Язык | Указывается язык сообщения. При создании сообщения выбираются шаблоны, соответствующие языку события, либо не имеющие установленного языка. Для выбора доступны только языки, установленные в системе.
Тело сообщения**
*Телефон отправителя ** | Телефон отправителя смс сообщения.
*Телефон получателя ** | Телефон получателя смс сообщения.
Шаблон события | Текст сообщения.
Доступные поля
Список шаблонов переменных (изменяемых данных), которые могут быть подставлены в поля сообщения, отмеченные **. Например, в поле Телефон отправителя может быть использована переменная #DEFAULT_SENDER# . Это значит, что в качестве телефона отправителя сообщения будет подставляться телефон, указанный в настройках [dw]Главного модуля[/dw][di]Поле Номер отправителя по умолчанию на закладке Почта и СМС.[/di].

* - поля, обязательные для заполнения.

** - значения данных полей могут быть заданы с помощью шаблонов, представленных в секции Доступные поля.

*** - Кнопка отображается при редактировании существующего почтового шаблона.


Типы событий

На странице Типы почтовых и СМС событий (Настройки > Настройки продукта > Почтовые и СМС события > Типы событий) можно добавлять новые типы почтовых и СМС событий, просматривать и изменять существующие, удалять ненужные.

Каждый почтовый шаблон или шаблон СМС привязывается к определённому типу события. Тип определяет набор специальных полей (placeholder'ов, макросов), которые могут быть использованы в почтовом шаблоне. В момент создания почтового события (т.е. готового сообщения) эти поля будут инициализированы конкретными значениями.

Фильтр

Поле | Описание
Найти | Поле позволяет найти типы почтовых шаблонов по наиболее типичным критериям, выбираемым в списке: Тип события, Название типа и Описание типа.
ID типа события | Поиск типов событий по идентификатору.
ID шаблона | Поиск типов событий по идентификатору шаблона.

Чтобы отобрать типы событий по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех типов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить тип | Переход к форме создания нового типа события.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список типов почтовых событий

Поле | Описание
Колонка флажков | Поле предназначено для выбора типов событий, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над типом события:
  • Изменить - переход к форме редактирования параметров типа события;
  • Удалить - удаление типа почтового события.
ID | Идентификаторы типа события для каждого из языков, по которым тип определён.
Язык | Идентификаторы языков, для которых тип определён.
Тип | Кодовое название типа события (латинскими буквами без пробелов).
Название | Название типа события на текущем языке системы.
Описание | Описание типа события на текущем языке системы.
Шаблоны | Перечислены идентификаторы шаблонов, относящихся к данному типу события.
Вид события | Вид события: почтовое событие (Email) или СМС событие (SMS).

Смотрите также

  • Типы событий (учебный курс "Администратор. Модули")


Создание и редактирование типа почтового события

Форма предназначена для создания нового или изменения уже существующего типа почтового или СМС события.

Контекстная панель

Кнопка | Описание
Список типов | Переход на страницу со списком типов событий.
Добавить тип | Переход к форме создания нового типа события. Кнопка отображается при редактировании существующего типа события.
Удалить тип | Удаление редактируемого типа. Кнопка отображается при редактировании существующего типа сообытия.
Список шаблонов | Переход к списку шаблонов, привязанных к редактируемому типу. Кнопка отображается при наличии шаблонов, привязанных к типу.
Добавить шаблон | Переход к форме добавления шаблона.

Закладка Тип события

Поле | Описание
*Тип события | Указывается кодовое название типа почтового события (латинскими буквами без пробелов).
Вид события | Выбирается вид: почтовое событие или СМС-событие.
Для каждого из установленных в системе языков:
ID | Указывается идентификатор типа события для каждого из языков.
Сортировка | Задается индекс сортировки, определяющий положение типа события в общем списке.
Название | Указывается осмысленное название типа события.
Описание | Определяется набор специальных полей (placeholder'ов, макросов) которые могут быть использованы в почтовом шаблоне. Например, #ID# - идентификатор, #IBLOCK_ID# - идентификатор информационного блока.

* - поля, обязательные для заполнения.

Примечание: для создания нового типа события должно быть заполнено хотя бы одно языковое поле.

Закладка Шаблоны

Шаблоны
На данной закладке выводятся все почтовые или СМС шаблоны, привязанные к данному типу:
  • идентификатор шаблона, представленный в виде ссылки на форму редактирования данного шаблона;
  • название шаблона;
  • сайт (или сайты), для отправки почтовых или СМС сообщений с которого используется данный шаблон.


Темы оформления

Тема - это внешний вид сообщения, в котором определяется расположение различных элементов, художественный стиль и способ отображения текста сообщения. Включает в себя программный HTML-код, таблицы стилей и дополнительные шаблоны для отображения контента.

Контекстная панель

Кнопка | Описание
Добавить шаблон | Переход на страницу с формой создания новой темы.
Загрузить шаблон | Переход к форме загрузки (импорта) темы в систему.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список тем

Поле | Описание
Колонка флажков | Поле предназначено для выбора тем, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над темой:
  • Изменить - переход к форме редактирования темы;
  • Копировать - копирование (дуплицирование) темы;
  • Скачать - сохранение темы;
  • Удалить - удаление темы.
ID | Идентификатор темы.
Название | Произвольное название темы.
Описание | Произвольное описание темы.
Скриншот | Отображается скриншот темы, если в закладке Дополнительные файлы формы создания/редактирования был загружен скриншот с именем screen.gif.
Порядок | Порядок следования тем в списке.


Создание и редактирование темы

Закладки

Контекстная панель

Кнопка | Описание
Список шаблонов | Переход на страницу со списком тем почтовых сообщений.
Добавить | Переход к форме создания новой темы. Кнопка отображается при редактировании существующей темы.
Копировать | Копирование редактируемой темы. Кнопка отображается при редактировании существующей темы.
Удалить | Удаление редактируемой темы. Кнопка отображается при редактировании существующей темы.

Шаблон

Поле | Описание
ID Указывается идентификатор шаблона (символами латинского алфавита). При редактировании шаблона рядом с данным полем отображается ссылка на папку шаблона.

Примечание: при создании новый шаблон будет автоматически сохранен в каталоге /bitrix/templates/ в папке с именем, соответствующим идентификатору шаблона.
Название | Задается произвольное название шаблона.
Описание | Задается произвольное описание шаблона.
Порядок | Значение этого поля задаёт порядок следования шаблона в общем списке шаблонов.
Тип Выбор типа создаваемого шаблона.
  • Шаблон сайта - будет создан шаблон сайта.
  • Шаблон для почтовых писем - будет создан шаблон для писем.
*Внешний вид шаблона сайта (рабочую область заменить #WORK_AREA#)
Поле служит для создания и редактирования кода шаблона. Разделитель #WORK_AREA# обозначает границу между верхней и нижней частью дизайна, т.е. место подключения рабочей области страницы.

Примечание: опция Использовать визуальный редактор служит для подключения визуального режима редактирования шаблона. Опция доступна в версиях до 14.0, если в настройках Главного модуля отмечена опция Использовать визуальный редактор для редактирования шаблонов сайта

.

* - поля, обязательные для заполнения.

Стили сайта

Файл стилей сайта (styles.css)
Поле служит для описания таблиц каскадных стилей (CSS), используемых на страницах сайта. Описание стилей хранится в файле styles.css в папке шаблона сайта.
Описание стилей
В данной части формы указываются названия стилей, как они будут отображаться в визуальном редакторе при редактировании страниц. Указанные здесь названия будут сохранены в файле .styles.php папки шаблона.
Поле | Описание
Имя стиля | Указывается название стиля. Название будет отображаться в визуальном редакторе.
Описание стиля | Указывается произвольное описание стиля.

Кнопка Еще... позволяет добавляет в форму еще одну пустую строку.

Стили шаблона

Файл стилей шаблона (template_styles.css)
Поле служит для описания таблиц каскадных стилей (CSS), используемых в шаблоне. Описание стилей хранится в файле template_styles.css в папке шаблона сайта.

Дополнительные файлы

Дополнительные файлы (включаемые области, картинки)
В поле указываются дополнительные файлы (картинки, шаблоны меню, шаблоны включаемых областей и др.), используемые для текущего шаблона сайта.
Следующие ссылки, расположенные под списком файлов, позволяют:
  • Добавить включаемый файл - перейти на страницу с формой создания нового включаемого файла;
  • Загрузить файл - перейти к загрузке произвольного файла в папку с шаблоном;
  • Управление структурой - перейти к управлению структурой папки с шаблоном.

Смотрите также

  • Типы почтовых событий (учебный курс "Администратор. Модули")


Настройки SMTP

На странице Параметры SMTP-подключения (Настройки > Настройки продукта > Почтовые и СМС события > Настройки SMTP) можно добавлять новые SMTP-подключения, просматривать и изменять существующие, удалять ненужные.

Фильтр

Поле | Описание
Найти | Поле позволяет найти SMTP-подключения по наиболее типичным критериям, выбираемым в списке: Email отправителя, Имя.
ID | Поиск SMTP-подключения по идентификатору.
Email | Поиск SMTP-подключения по Email.
Имя отправителя | Поиск SMTP-подключения по имени отправителя.
Для всех пользователей | Поиск SMTP-подключения по признаку доступности SMTP-подключения для всех пользователей.

Чтобы отобрать SMTP-подключения по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех SMTP-подключений нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить SMTP-подключение | Переход к форме создания нового SMTP-подключения.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список SMTP-подключений

Поле | Описание
Колонка флажков | Поле предназначено для выбора SMTP-подключений, к которым предполагается применить какое-либо правило или действие.
Действия Действия, которые можно произвести над SMTP-подключением:
  • Изменить - переход к форме редактирования параметров SMTP-подключения;
  • Удалить - удаление SMTP-подключения.
ID | Идентификаторы SMTP-подключений.
Email | Email SMTP-подключений.
Имя отправителя | Имя отправителя SMTP-подключений.
Для всех пользователей | Признак доступности SMTP-подключения для всех пользователей.
Подтвержден | Подтверждено ли SMTP-подключение.

Смотрите также

  • Локальные настройки SMTP-сервера (учебный курс "Разработчик Bitrix Framework")


Создание и редактирование SMTP-подключения

Форма предназначена для создания нового или изменения уже существующего SMTP-подключения.

Контекстная панель

Кнопка | Описание
Список подключений SMTP | Переход на страницу со списком SMTP-подключений.
Добавить | Переход к форме создания нового SMTP-подключения. Кнопка отображается при редактировании существующего SMTP-подключения.
Копировать | Копирование редактируемого SMTP-подключения. Кнопка отображается при редактировании существующего SMTP-подключения.
Удалить | Удаление редактируемого SMTP-подключения. Кнопка отображается при редактировании существующего SMTP-подключения.

Закладка Параметры

Поле | Описание
*E-mail | Указывается email-адрес.
Имя отправителя | Прописывается имя отправителя.
Для всех пользователей | Опция определяет, смогут ли все пользователи видеть данного отправителя письма, использующего указанный SMTP-сервер.
Логин | Вводится логин SMTP-сервера.
Сервер | Указывается подключаемый почтовый сервер.
Порт | Указывается порт (в основном используются три значения: 25, 465, 587).
Пароль | Вводится пароль SMTP-сервера.

* - поля, обязательные для заполнения.

Смотрите также

  • Локальные настройки SMTP-сервера (учебный курс "Разработчик Bitrix Framework")


Отправить отзыв по этому разделу

Обработка адресов

  • Список правил обработки адресов
  • Создание и редактирование правила обработки адресов
  • Пересоздание правил обработки адресов


Список правил обработки адресов

Управление правилами преобразования адресов производится на странице Обработка адресов (Настройки > Настройки продукта > Обработка адресов).

Обработка адресов (UrlRewrite) применяется для того, чтобы скрипт мог отвечать не только по своему физическому, но и по любому другому указанному адресу. Например, можно задать такие настройки обработки адресов, что скрипт, лежащий в файле /fld/c.php и отвечающий по адресу /fld/c.php?id=15 будет отвечать также по адресу /catalog/15.php.

Адрес, по которому будет отвечать скрипт, не должен физически существовать на сервере. Если такой адрес физически существует, то будет вызван скрипт по этому адресу. Система обработки адресов запущена в этом случае не будет.

Фильтр

Форма фильтра используется для выбора из списка правил обработки в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Путь | Поиск правила по пути к файлу.
Сайт | Поиск правил для указанного сайта.
Условие | Поиск правил обработки адресов по условию применения.
Компонент | Поиск правил по полному имени компонента (пространство_имен:имя_компонента).

Для того чтобы отобрать правила по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех правил нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Новая запись | Переход к форме создания нового правила обработки адресов.
Пересоздание | Переход к странице Пересоздание правил обработки адресов.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в формат MS Excel.

Список правил

Поле | Описание
Колонка флажков | Поле предназначено для выбора правил, к которым предполагается применить какое-либо действие.
Действие Действия над правилами:
  • Изменить - переход к форме редактирования правила обработки адресов;
  • Удалить - удаление правила обработки адресов.
Условие | Условие, по которому правило будет применено.
Компонент | Компонент, для которого работает правило обработки адресов.
Файл | Указывается путь к файлу, который будет отображен в результате обработки адреса.
Правило | Правило вызова страницы, путь к которой указан в поле Файл.

Смотрите также

  • Примеры правил (учебный курс "Администратор. Базовый")


Создание и редактирование правила обработки адресов

На данной странице вы можете создать новое или изменить параметры существующего правила обработки адресов.

Контекстная панель

Кнопка | Описание
Список записей | Переход на страницу со списком правил обработки адресов.
Добавить | Переход на страницу с формой создания нового правила обработки адресов. Кнопка отображается при редактировании существующего правила обработки адресов.
Удалить | Удаление редактируемого правила обработки адресов. Кнопка отображается при редактировании существующего правила обработки адресов.

Закладка Параметры

Поле | Описание
*Условие | Задается условие, по которому будет работать правило обработки адресов.
Компонент | Указывается полное имя компонента (пространство_имен:имя_компонента), для которого будет работать правило.
Файл | Адрес страницы, которая должна быть показана с учетом правила.
Правило | Правило вызова страницы, путь к которой указан в поле Файл.

* - поля, обязательные для заполнения.

Смотрите также

  • Примеры правил (учебный курс "Администратор. Базовый")


Пересоздание правил обработки адресов

С помощью формы Пересоздание правил обработки адресов, представленной на данной странице, осуществляется пересоздание правил обработки адресов. Процесс пересоздания правил заключается в следующем: сначала удаляются все правила, созданные системой ранее, а затем создаются новые на основе используемых на сайте компонентов, поддерживающих ЧПУ. При этом правила, созданные пользователем вручную, удаляться и пересоздаваться не будут.

Закладка Пересоздание

Поле | Описание
Сайт | Указывается сайт, для которого будут созданы правила.
Максимальный размер документа | Устанавливается ограничение в килобайтах на размер обрабатываемых документов сайта.
Создать по шагам | При отмеченной опции процесс пересоздания правил будет выполняться по шагам, длительность шага задается в поле Шаг.
Шаг | Задается длительность выполнения шага создания правил в секундах.


Отправить отзыв по этому разделу

Интерфейс

  • Персональные настройки
  • Горячие клавиши
  • Создание и редактирование горячих клавиш


Персональные настройки

Управление оформлением административного раздела осуществляется на странице Настройка интерфейса пользователя (Настройки > Настройки продукта > Интерфейс > Персональные настройки).

Закладка Настройки

Поле | Описание
Персональные настройки
Разрешить контекстное меню в списках | При отмеченной опции будет отображено контекстное меню в списках (таблицах отчета).
Показывать контекстное меню по нажатию Если отмечена опция Разрешить контекстное меню в списках,то необходимо выбрать один из способов вызова меню:
  • по клику Правой кнопки мыши;
  • по клику Правой кнопки мыши + клавиша Ctrl.
Включить автосохранение форм | При отмеченной опции будет разрешена функция Автосохранения [image].
Панель инструментов
Переходить в режим правки сайта без перезагрузки страницы | При отмеченной опции система будет переходить в режим правки сайта без перезагрузки страницы. При этом нагрузка на сервер возрастает, т.е. ускорение работы достигается большей нагрузкой на сервер.
Отображать панель редактирования страницы | При отмеченной опции на каждой странице сайта в режиме правки будет доступна панель Изменить страницу в редакторе, используя которую можно редактировать текущую страницу из публичной части.
Меню "Пуск"
Производить предварительную загрузку меню | При отмеченной опции меню будет подгружаться предварительно в фоновом режиме.
Показывать всплывающие подсказки пунктов меню | При отмеченной опции будут отображаться всплывающие подсказки при наведении указателя мыши на пункты меню.
Количество часто используемых ссылок | Указывается количество ссылок на часто используемые страницы, список которых отображается в третьей секции меню Пуск.
Удалить все ссылки | По ссылке будет запущен Java-скрипт, который очистит список часто используемых ссылок.
Звуки
Проигрывать звуки | При отмеченной опции при начале работы системы будет проигрываться звук, указанный в поле Файл звука "Начало работы".
Файл звука "Начало работы" | Указывается путь до файла со звуком, который будет проигрываться.
Сообщения
Выводить сообщения При отмеченной опции будут выводиться сообщения:
  • О сроке окончания техподдержки;
  • О состоянии модуля проактивной защиты;
  • О состоянии модуля монитора производительности.
Общие настройки
Установить данные настройки по умолчанию для всех пользователей | При отмеченной опции данные настройки будут использоваться как настройки по умолчанию для всех зарегистрированных пользователей.

* - поля, обязательное для заполнения.

Закладка Удаление

Ссылка | Описание
Очистить все собственные настройки интерфейса | Для очистки всех собственных настроек интерфейса воспользуйтесь данной ссылкой.
Очистить все настройки по умолчанию | Для очистки всех настроек по умолчанию воспользуйтесь данной ссылкой.
Очистить персональные настройки всех пользователей | Для очистки персональных настроек всех пользователей воспользуйтесь данной ссылкой.


Горячие клавиши

На странице Горячие клавиши (Настройки > Настройки продукта > Горячие клавиши) выводится список заданных действий, для которых пользователь может задать горячие клавиши.

Форма поиска

Форма фильтра используется для выбора из списка горячих клавиш в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Параметр | Описание
Наименование | Позволяет найти горячие клавиши по их названию. Это поле присутствует, даже если фильтр свернут.
Наименование класса | Поиск по полю Наименование класса.
Выполняемый JS Код | Поиск по части кода, введенного в соответствующее поле.
Адрес (URL) | Поиск действий предназначенных для определённых страниц. Если надо найти горячие клавиши без ограничения по месту применения, то используйте выражение ~_.
Пользовательский код Предлагается следующий набор типов данных:
  • Да - выведутся все горячие клавиши с пользовательским кодом;
  • Нет - выведутся горячие клавиши с кодом, поставляемым в дистрибутиве.

Чтобы отобрать горячие клавиши по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех горячих клавиш нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить | Переход к форме создания нового действия для горячих клавиш.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список горячих клавиш

Поле | Описание
Действия Доступные операции над пользовательским полем:
  • Редактировать - переход к редактированию горячих клавиш;
Наименование класса | Указывается класс, который используется при вызове функционала горячих клавиш из кода PHP.
Наименование | Название под которым набор клавиш отображается для пользователя.
Комментарий | Комментарий к действию.
Адрес (URL) | Адрес страницы, раздела, к которому привязано действие.
Объект для привязки Title | Объект, который используется для вывода всплывающей подсказки.
Пользовательский | Пользовательский или системный набор горячих клавиш. Нередактируемое поле.
Идентификатор | Нередактируемый идентификатор, выдаваемый системой для горячих клавиш при их создании.
Выполняемый JS Код | Код, который должен будет выполниться по данному набору горячих клавиш.

Смотрите также

  • Как настроить "Горячие клавиши"


Создание и редактирование горячих клавиш

Контекстная панель

Кнопка | Описание
Список | Переход к списку Горячих клавиш.

Форма редактирования

Форма предназначена для создания и редактирования действий горячих клавиш.

Поле | Описание
*Наименование | Значение поля выводиться у пользователей в окне настроек горячих клавиш в качестве названия действия.
*Выполняемый JS Код | Вводится код, который должен будет выполниться по данному набору горячих клавиш.
Наименование класса | Указывается класс, который используется при вызове функционала горячих клавиш из кода PHP.
Комментарий | Произвольный текст, развёрнутые сведения о выполняемом действии.
Объект для привязки Title | Указывается объект, к которому будет привязана всплывающая подсказка (title). Объект - это, например, имя класса, или ID объекта, в свойства которого необходимо добавить данный атрибут.
Адрес (URL) где будет работать Если оставить поле пустым, то действие для привязки к горячим клавишам будет доступно везде, где есть Административная панель. Если необходимо что бы действие выполнялось на какой-то конкретной странице или в конкретном разделе, то их можно указать в данном поле, например:
http://127.0.0.1:84/bitrix/admin/hot_keys_list.php

* - поля, обязательные для заполнения.

Смотрите также

  • Горячие клавиши (учебный курс "Администратор. Базовый")


Композитный сайт

Раздел настроек и включения технологии Композитный сайт (Настройки > Настройки продукта > Композитный сайт). Перед включением необходимо настроить компоненты сайта на работу по этой технологии. О работе технологии и настройке компонентов смотрите учебный курс Технология Композитный сайт [image].

Технологию Композитный сайт можно использовать в двух режимах.


Отправить отзыв по этому разделу
Настройки>Композитный сайт>Настройки

Композитный сайт::Настройки

Закладки

Автокомпозит и Композит

Включение технологии производится либо в ручном, либо в автоматическом режиме. Активизация одного из режимов делает неактивной кнопку включения другого режима. Для смены режима надо сначала выключить ранее работавший режим. Перед включением любого из режимов необходимо очистить кеш компонентов.

Настройки

Голосование за композитный режим
Внимание! Раздел неактивен при включённом автоматическом режиме. В настройках каждого компонента, голосующего "за", появляются дополнительный раздел Композитный сайт, в котором, при необходимости можно изменить выбранные в указанных ниже полях значения.
Голосование шаблона компонента по умолчанию Вид голосования компонентов по умолчанию. Доступно два режима:
  • За - применяется при автоматическом режиме.
  • Против - Применяется при ручной адаптации компонентов для Композитного сайта
Содержимое компонента Становится активным при выборе режима голосования Против. Вид содержания компонента до получения ответа на ajax- запрос. Доступно два режима:
  • Динамическая область с заглушкой
  • Статическая область
Режим перезаписи кеша
Режим перезаписи кеша Задание способа перезаписи кеша. Доступно три варианта:
  • Стандартный режим с задержкой перезаписи - Стандартный режим, но происходит задержка перезаписи кеша на указанное время. Рекомендуется при переходе на режим Автокомпозит.
  • Стандартный режим. Делается фоновый ajax-запрос, который проверяет хеш от контента всей страницы и сравнивает его с хешем, который находится в кеше. Если они разные, то кеш перезаписывается.
  • Режим без фонового ajax-запроса - фактически прежнее HTML-кеширование [image] с указанием времени по истечении которого кеш будет перезаписан.
Настройки
Список доменных имен | Задаются доменные имена, для которых будет работать технология. Каждое доменное имя указывается в отдельной строке.
Маска включения | Указывается маска файлов, для которых будет применяться технология.
Маска исключения | Укажите файлы и типы файлов, которые не будут обрабатываться html кешем.
Игнорировать следующие параметры URL | Указание параметров URL, которые не будут восприниматься системой как отдельные УРЛ и, соответственно, для них не будут создаваться кеш. (Например: utm_source, fb_action_ids и др.)
Сохранять на диск только страницы без параметров | Отключает создание композитного кеша для вариативных страниц.
а также страницы содержащие только следующие параметры | Становится активной при установке чекбокса в пункте выше. Поле для указания параметров УРЛ, страницы с которыми будут сохраняться на диск.
Параметры URL, при которых не будет работать композитный режим | Указываются параметры URL при наличии которых для данной страницы не будет создаваться кеш.
Механизм хранения кеша
Хранить кеш в Выбор места хранения кеша в файлах или в memcached.
При выборе места хранения в файлах необходимо дополнительно указать дисковую квоту.
При выборе memcached появятся дополнительные поля Хост и Порт, в которых нужно указать параметры вашего сайта. Кнопка Проверить соединение проверяет возможность соединения.
Кластерный вариант memcached cluster использует настройки модуля Веб-кластер. Требуется наличие этого модуля.
Текущий размер кеша | Информационное поле. Помогает при определении оптимального значения Дисковой квоты.
Сбросить кеш | Ссылка для сброса кеша. Ведёт на страницу Очистка файлов кеша

Группы

На закладке выбираются группы для которых должна применяться технология.

Кнопка "Быстро с 1С-Битрикс"

Поле | Описание
Показать кнопку "Быстро с 1С-Битрикс" | Опция включает/отключает показ кнопки.
Вид кнопки | Выбор вида кнопки и белого фона.
Изменить цвет фона | Задание любого другого цвета фона.
Изменить цвет логотипа и надписи | Выбор варианта цвета логотипа и надписи.


Композитные страницы

Отправить отзыв по этому разделу
Настройки>Композитный сайт>Композитные страницы

Композитный сайт::Композитные страницы

Страница (Настройки > Настройки продукта > Композитный сайт > Страницы) выводит список файлов кеша, созданных по технологии Композитный сайт.

Форма поиска

Форма позволяет выполнить файлов кеша, соответствующих указанным параметрам.

Поле | Описание
ID | Идентификатор файла в системе.
ID кеша | Идентификатор кеша (Соответствует URL страницы).
Название страницы | Название страницы в рамках логической структуры сайта
Адрес страницы | URL страницы
Дата создания | Дата создания кеша
Дата изменения | Дата изменения кеша.
Дата просмотра | Дата последнего просмотра

Чтобы отобрать файлы кеша по заданным критериям поиска, нажмите кнопку Найти. Для отображения всего списка нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Очистить весь кеш | Переход к закладке Очистка файлов кеша страницы Автокеширования.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список кешированных страниц

Поле | Описание
Колонка флажков | Выбор информационных блоков, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия:
  • Удалить - удаление файла кеша. Рекомендуется не использовать: в системе реализована автоматическая очистка по LRU-алгоритму.
ID | Идентификатор файла в системе.
Страница | Название страницы и её URL, с названия страницы можно открыть саму страницу в новой вкладке.
ID кеша | Идентификатор кеша (Соответствует URL страницы).
Название страницы | Название страницы в рамках логической структуры сайта
Адрес страницы | URL страницы
Дата создания | Дата создания кеша
Дата изменения | Дата изменения кеша.
Дата просмотра | Дата последнего просмотра
Просмотров | Число просмотров файлов кеша как страницы.
Перезаписей | Число перезаписей кеша
Размер | Размер файла кеша
Хост | Адрес сайта.


Отладка

Отправить отзыв по этому разделу
Настройки>Композитный сайт>Отладка

Композитный сайт::Отладка

Страница Журнал отладки (Настройки > Настройки продукта > Композитный сайт > Отладка) выводит список ошибок создания файлов кеша, создаваемых по технологии Композитный сайт.

Включение отладки

Форма позволяет выбрать период, в течение которого будут фиксироваться ошибки в Журнале отладки, и включить/выключить саму отладку.

Форма поиска

Форма позволяет выполнить файлов кеша, соответствующих указанным параметрам.

Поле | Описание
ID | Идентификатор файла в системе.
Хост | Домен сайта
Название страницы | Название страницы в рамках логической структуры сайта
Адрес страницы | URL страницы
Дата создания | Дата создания кеша
Тип события | Тип ошибки
Ajax-запрос | Был ли сделан ajax-запрос
Пользователь | Пользователь, на которого не был создан файл кеша.

Чтобы отобрать ошибки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всего списка нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Очистить лог | Очистка списка ошибок
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Лог ошибок

Поле | Описание
Колонка флажков | Выбор информационных блоков, к которым предполагается применить какое-либо правило или действие.
Действия Доступные действия:
  • Удалить - удаление записи об ошибке.
ID | Идентификатор записи в системе.
Страница | Название страницы и её URL, при создании кеша которой возникла ошибка. С названия страницы можно открыть саму страницу в новой вкладке.
Дата создания | Дата создания кеша
Тип события | Тип события (ошибки), приведшего к добавлению записи.
Сообщение | Служебное сообщение для определённых типов ошибок, для которых возможна расширенная отладка.
Ajax-запрос | да/нет, был ли сделан ajax-запрос на странице
Название страницы | Название страницы в рамках логической структуры сайта
Адрес страницы | URL страницы
Пользователь | Логин пользователя, обращение которого вызвало ошибку
Хост | Адрес сайта.


Отправить отзыв по этому разделу

Инструменты

  • Резервное копирование
  • Диагностика
  • Журнал событий
  • Проверка системы
  • Монитор качества
  • SQL запрос
  • Командная PHP строка


Проверка системы

Страница Проверка системы (Настройки > Инструменты > Проверка системы) предназначена для всесторонней проверки соответствия параметров системы, на которой осуществляется функционирование "1C-Битрикс: Управление сайтом", минимальным и рекомендуемым требованиям продукта.

Форма содержит информацию, сгруппированную по закладкам для облегчения восприятия. Выделяются следующие закладки:

  • Тестирование конфигурации - предназначена для проведения комплексного тестирования конфигурации сервера. Операция может занять несколько минут. Ваша система должна соответствовать обязательным параметрам. Если какой-либо из этих параметров выделен красным цветом, то вам необходимо исправить его. В противном случае работоспособность сайта не гарантируется.
  • Проверка доступа к диску - cкрипты сайта должны иметь доступ на запись к файлам сайта. Это необходимо для работы модуля Управление структурой сайта, загрузки файлов, а так же для работы системы обновлений, которая обновляет ядро сайта до последней версии.

    Вы можете выбрать тип проверки:

    • Полная проверка;
    • Проверка папки для загрузки файлов;
    • Проверка ядра.

    Результаты проверки доступности дисков физической системы будут отображены ниже.

См. также

  • Проверка системы [image] в курсе Администратор. Базовый.


Монитор качества

Монитор качества - инструмент для проверки качества выполненного проекта перед сдачей его заказчику. Он позволяет решить задачу обеспечения прозрачного и гибкого процесса сдачи веб-проекта клиенту, повышая уровень гарантированного результата и снижая общие риски.

Включает в себя:

  • Структурированная методика управления качеством внедрения;
  • Система тестов для веб-разработчиков, набор рекомендаций для клиентов;
  • Состоит из 26 обязательных тестов и 39 необязательных;
  • Включает 12 автоматических проверок.

Сдача проекта осуществляется прохождением автоматических и ручных тестов Монитора качества.

Смотрите также:

  • Монитор качества


SQL запрос

Страница SQL запрос (Настройки > Инструменты > SQL запрос) предназначена для выполнения SQL запросов к базе данных. Возможно выполнение любых запросов на языке SQL. Вы можете выполнить несколько запросов в одном поле ввода. При этом обратите внимание, что информация будет выведена только по последнему запросу.

Примечание: система не устанавливает никаких ограничений на SQL запросы, поэтому будьте крайне внимательны при выполнении запросов типа UPDATE, DELETE, DROP и т.п.

Закладка "SQL запрос"

Поле | Описание
SQL запрос к базе данных | Указывается текст SQL запроса к базе данных.


Командная PHP строка

Страница Командная PHP-строка (Настройки > Инструменты > Командная PHP-строка) предназначена для задания PHP-скрипта, который будет выполнен на сервере.

Примечание: при написании неверного запроса к БД в командной строке выводится SQL-ошибка (с версии 11.0.9 ).

Закладка "PHP-строка"

Поле | Описание
Произвольный PHP-скрипт для выполнения на сервере | Указывается текст PHP-скрипта, который будет выполнен на сервере.


Отправить отзыв по этому разделу

Резервное копирование

  • Резервное копирование
  • Список резервных копий
  • Регулярное резервное копирование


Резервное копирование

Закладки

Описание

Для решения задач переноса сайта [image] на удаленный хостинг или восстановления старой версии проекта имеется специальный механизм резервного копирования [image], предоставляющий следующие возможности:

  • создание архивной версии файлов сайта (формат *.tar.gz);
  • исключение из архива папки, содержащей ядро продукта;
  • исключение из архива файлов, размер которых превышает некоторое заданное значение;
  • создание дампа базы данных (формат *.tar.gz);
  • исключение из дампа таблиц статистики и поискового индекса.

Выполнить перечисленные действия можно на странице Резервное копирование (Настройки > Инструменты > Резервное копирование).

Примечание: при обновлении продукта меняются файлы ядра и структура базы данных. Если версия ядра не будет соответствовать версии базы данных, сайт может оказаться неработоспособным.

Резервное копирование

Создание полной резервной копии с настройками процесса по умолчанию.

Поле | Описание
Облачное хранилище "1С-Битрикс" | Индикатор свободного места в облачном хранилище "1С-Битрикс". Поле неактивно, если не подключено облачное хранилище.
Размещение резервной копии | Выбор места для размещения резервной копии.
Сайт | Выбор сайта, если их в системе несколько. Появляется только при использовании многосайтовости на разных доменах [image] .

Параметры

Форма служит для ручного задания параметров резервного копирования.

Поле | Описание
Включить экспертные настройки создания резервной копии | При включении опции становятся доступными поля для настройки параметров. Включением опции пользователь подтверждает то, что он сознательно изменяет установки по умолчанию.
Содержимое резервной копии
Архивировать базу данных При отмеченной опции будет архивироваться база данных.

Примечание. До версии главного модуля 15.5.5 файл архива базы данных не мог превышать 2 Гб.

Исключить из базы данных | Поле позволяет исключить из архива таблиц статистики, журнала событий и поискового индекса. Для этого необходимо отметить соответствующие опции. Исключение поискового индекса уменьшит дамп базы данных, но потребует переиндексации после восстановления.
Архивировать ядро | При отмеченной опции будет создана резервная копия ядра продукта.
Архивировать публичную часть | При отмеченной опции будет архивироваться публичная часть сайта.
Исключить из архива файлы и директории по маске Указываются маски для файлов и директорий для исключения из архива.

Для маски исключения действуют следующие правила:
  • шаблон маски может содержать символы "*", которые соответствуют любому количеству любых символов в имени файла или папки;
  • если в начале стоит косая черта ("/" или "\"), путь считается от корня сайта;
  • в противном случае шаблон применяется к каждому файлу или папке;
Примеры шаблонов:
  • /content/photo - исключить целиком папку /content/photo;
  • .zip - исключить файлы с расширением *.zip;
  • .access.php - исключить все файлы *.access.php;
  • /files/download/*.zip - исключить файлы с расширением *.zip в директории /files/download;
  • /files/d*/*.ht* - исключить файлы из директорий, начинающихся на /files/d с расширениями, начинающимися на ht.
  • /bitrix/cache/, /bitrix/managed_cache/, /bitrix/stack_cache/ - исключает из архива папки с кешем.
  • /bitrix/backup/ - исключает из бекапа папку с бекапами, в противном случае каждый новый бекап будет содержать предыдущий бекап, что приводит к росту размера архива.
Исключить из архива файлы размером более | задание ограничения на размер файлов (в kb), включаемых в архив. (0 - без ограничения)
Пропускать символические ссылки на директории | При отмеченной опции в архив не будут добавляться символические ссылки, используемые в проекте.
Режим архивации
Шифровать данные резервной копии: Включение опции шифрования.
Проверить целостность архива после завершения | При отмеченной опции после создания архива он будет проверен на целостность.
Отключить компрессию архива (снижение нагрузки на процессор) | При установленной опции архив не будет сжат. Не рекомендуется к использованию. Если резервирование происходит только с включенной данной опцией, то хостинг рекомендуется поменять.
Длительность шага и Интервал | Указывается количество секунд для выполнения одного шага резервного копирования и интервал между шагами. При значении "0" архивация будет выполнена в один шаг. Длительность должна быть не более тайм-аута веб-сервера. Значения подбираются эмпирически под конкретный проект.
Максимальный размер несжатых данных в одной части архива (МБ) | Размер одной части архива, в несжатом состоянии. Рекомендуется оставить по умолчанию, так как при размере 100 Мб получается избежать некоторых ошибок при распаковке.


Список резервных копий

Список резервных копий

Список резервных копий размещается на отдельной странице Настройки > Инструменты > Резервное копирование > Список резервных копий

Контекстная панель

Кнопка | Описание
Создать резервную копию | Запуск процесса резервного копирования с переходом на страницу Создание резервной копии.
Автоматическое создание | Переход на страницу настроек автоматического резервного копирования.
Поле | Описание
Колонка флажков | Поле предназначено для выбора файлов архива, к которым предполагается применить какое-либо правило или действие.
Действие Действия над файлами архива (зависит от места размещения):
  • Скачать - скачивание файла на локальный компьютер (доступно при размещении локально или в стороннем облачном хранилище);
  • Получить ссылку для переноса - используется при восстановлении данных с помощью restore.php (доступно при размещении локально или в стороннем облачном хранилище);
  • Восстановить - восстановление архива (доступно при размещении локально или в облачном хранилище 1С-Битрикс);
  • Отправить в облако "имя_облака" - перенос файла в выбранное облачное хранилище (только для локального хранения);
  • Переименовать - смена имена файла (доступно при размещении локально или в стороннем облачном хранилище);
  • Удалить - удаление файла (доступно при размещении локально или в стороннем облачном хранилище).
Имя | Имя файла архива.
Размер архива | Размер файла, указанный в мегабайтах.
Размещение | Указание где размещён архив.
Изменен | Дата и время изменения файла.

С помощью ссылки Скачать, расположенной на данной странице после таблицы со списком резервных копий, вы можете скачать скрипт восстановления restore.php.

Примечание. Список резервных копий размещённых в облаке 1С-Битрикс отображается и в разделе Облако 1С-Битрикс.


Регулярное резервное копирование

Закладки

Форма служит для задания настроек автоматического резервного копирования.

Контекстная панель

Контекстная панель допускает переход к списку резервных копий на страницу Список резервных копий.

Регулярный запуск

На закладке производится включение/выключение процесса запуска. Если копирование производится в облако 1С-Битрикс, то будет необходимо введение пароля.

Параметры

Поле | Описание
Размещение резервной копии Опция выбора места для размещения резервной копии.
  • в папке сайта - копия будет размещена в структуре сайта. Доступно по умолчанию.
  • в облаке "1С-Битрикс" - копия будет размещена в облаке "1С-Битрикс" в рамках доступного места. Доступно при активной лицензии и установленном модуле Облако 1С-Битрикс.
  • _имя облака_ - копия будет размещена в подключенном стороннем облаке. Доступно при подключенном облачном хранилище.
Расписание
Метод запуска Выбор способа запуска создания резервной копии:
  • через облачный сервис "1С-Битрикс" - опция по умолчанию. Доступна при активной лицензии. Копия создаётся в заданное время согласно параметрам введённым ниже.
  • с агентами на cron - доступна в случае если системные агенты выполняются на cron (неважно, только непериодические или все).
  • через прямой запуск /bitrix/modules/main/tools/backup.php - копия создаётся по параметрам, заданным в указанном файле, запуск выполнения скрипта производится через панель хостинга.
Время создания резервной копии | Поле для указания времени создания копии.
Периодичность | Выбор периодичности создания копии.
Удаление старых копий
Удалять локальные резервные копии Выбор параметров удаления.
  • никогда не удалять - локальная копия никогда не будет удалена, даже если она перемещена в облако;
  • после успешной передачи в облако - локальная копия будет удалена сразу после перемещения в облако;
  • если прошло N дней с момента создания - локальная копия будет удалена через заданное число дней, даже если она не перемещена в облако;
  • если общее число копий больше N - будет удаляться самая старая копия, если общее число копий больше числа N;
  • если суммарный размер резервных копий больше N Гб - будет удаляться самая старая копия, если общий объем копий больше числа N.
Содержимое резервной копии
Архивировать базу данных | При отмеченной опции будет архивироваться база данных.
Исключить из базы данных | Поле позволяет исключить из архива таблиц статистики, журнала событий и поискового индекса. Для этого необходимо отметить соответствующие опции.
Архивировать ядро | При отмеченной опции будет создана резервная копия ядра продукта.
Архивировать публичную часть | При отмеченной опции будет архивироваться публичная часть сайта.
Исключить из архива файлы и директории по маске Указываются маски для файлов и директорий для исключения из архива.

Для маски исключения действуют следующие правила:
  • шаблон маски может содержать символы "*", которые соответствуют любому количеству любых символов в имени файла или папки;
  • если в начале стоит косая черта ("/" или "\"), путь считается от корня сайта;
  • в противном случае шаблон применяется к каждому файлу или папке;
Примеры шаблонов:
  • /content/photo - исключить целиком папку /content/photo;
  • .zip - исключить файлы с расширением *.zip;
  • .access.php - исключить все файлы *.access.php;
  • /files/download/*.zip - исключить файлы с расширением *.zip в директории /files/download;
  • /files/d*/*.ht* - исключить файлы из директорий, начинающихся на /files/d с расширениями, начинающимися на ht.
Исключить из архива файлы размером более | задание ограничения на размер файлов (в kb), включаемых в архив. (0 - без ограничения)
Пропускать символические ссылки на директории | При отмеченной опции в архив не будут добавляться символические ссылки, используемые в проекте.
Режим архивации
Шифровать данные резервной копии Отключение шифрования резервной копии.

Примечание. При размещении резервной копии в облачном хранилище "1С-Битрикс" отключить шифрование нельзя.

Проверить целостность архива после завершения | Проверка целостности созданного архива. Рекомендуется к использвоанию
Отключить компрессию архива (снижение нагрузки на процессор) | Позволяет уменьшить размер архива, но повышает нагрузку на процессор.
Длительность шага и Интервал | Указывается количество секунд для выполнения одного шага резервного копирования и интервал между шагами. При значении "0" архивация будет выполнена в один шаг. Длительность должна быть не более тайм-аута веб-сервера. Значения подбираются эмпирически под конкретный проект.
Максимальный размер несжатых данных в одной части архива (МБ) | Размер одной части архива, в несжатом состоянии. Рекомендуется оставить по умолчанию.

Смотрите также

  • Регулярное резервное копирование [image] в курсе Администоратор. Базовый.


Отправить отзыв по этому разделу

Диагностика

  • Настройки PHP
  • Проверка БД
  • Оптимизация БД


Настройки PHP

Страница Настройки PHP (Настройки > Инструменты > Настройки PHP) служит для отображения информации о текущих настройках PHP. Для получения информации используется функция phpinfo().


Проверка БД

Страница Проверка БД (Настройки > Инструменты > Проверка БД) служит для проверки и восстановления таблиц базы данных. Восстановление таблиц работает только для базы данных MySQL и таблиц типа MyISAM.

Внимание! Не открывайте эту страницу одновременно в нескольких копиях - это может повредить вашу базу данных. Операция может занять длительное время, если размер базы данных велик!

Кнопка Проверить / восстановить таблицы запускает процесс проверки таблиц базы данных. В результате проверки выводится таблица, состоящая из следующих полей:

Поле | Описание
Название таблицы | Название проверенной/восстановленной таблицы.
Количество записей | Количество записей в таблице.
Размер таблицы (байт) | Размер таблицы в байтах.
Результат проверки | Статус проверки. Сообщение зеленого цвета (OK). Сообщения красного цвета выводятся при неполадках с таблицей.
Результат восстановления | Сообщение выводится в случае, если таблицу пришлось восстанавливать и проверять. Также выводится сообщение об успешности этого действия.


Оптимизация БД

Страница Оптимизация БД (Настройки > Инструменты > Оптимизация БД) служит для оптимизации и анализа таблиц базы данных. Оптимизация баз данных повышает эффективность обработки запросов сервером базы данных. Процесс оптимизации баз работает только для базы данных MySQL и таблиц типа MyISAM.

Внимание! Не открывайте эту страницу одновременно в нескольких копиях - это может повредить вашу базу данных. Операция может занять длительное время. Желательно выполнять ее при наименьшей нагрузке на сайт.

Кнопка Оптимизировать запускает процесс оптимизации и анализа базы данных. После окончания процесса будет выведено соответствующее сообщение о завершении оптимизации. Если в процессе анализа баз данных будут найдены ошибки в таблицах, то система предложит их восстановить. Кнопка Приостановить позволяет сделать паузу, а кнопка Продолжить - продолжить процесс анализа и оптимизации баз данных.


Отправить отзыв по этому разделу

Журнал событий

  • Журнал событий
  • Оповещения журнала событий
  • Создание и редактирование оповещения


Журнал событий

Страница Журнал событий (Настройки > Инструменты > Журнал событий) предназначена для просмотра журнала события сайта.

Фильтр

Форма фильтра используется для выбора из журнала событий в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым может выполняться поиск.

Поле | Описание
Найти | Позволяет найти события по их основным параметрам: Событие, Пользователь, IP и UserAgent. Поле присутствует, даже если фильтр свернут.
ID | Поиск событий по идентификатору. Соответствует полю ID журнала событий.
Время | Позволяет указать период (начало и окончание) времени для отбора событий.
Срочность | Определяется, события какой срочности будут участвовать в поиске: SECURITY или WARNING.
Событие* | Позволяет выполнить отбор событий по названию.
Источник* | Позволяет выполнить отбор событий по источнику.
Объект* | Позволяет выполнить отбор событий по объекту.
Сайт | Указывается сайт, для которого будет отображен список событий.
Пользователь | Задается имя пользователя, если событие было выполнено зарегистрированным пользователем, или идентификатор гостя для поиска событий (при наличии модуля Веб-аналитика).
Гость | Задается идентификатор гостя для отбора событий (при наличии модуля Веб-аналитика).
IP* | Служит для отбора событий по IP адресу.
User Agent* | Служит для отбора событий по User Agent.
URL* | Служит для отбора событий по адресу страницы.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Для того чтобы отобразить события по заданным критериям поиска нажмите кнопку Найти. Для отображения всех событий нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Оповещения журнала событий | Переход к странице Оповещения журнала событий.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Журнал событий

Поле | Описание
ID | Идентификатор события.
Время | Дата и время события.
Срочность | Срочность события (SECURITY или WARNING).
Событие | Название произошедшего события.
Источник | Источник события.
Объект | Объект события.
IP | IP-адрес, с которого произошло событие. По ссылке [стоп-лист] можно добавить адрес в стоп-лист модуля Веб-аналитика.
User Agent | Используемый User Agent.
URL | Адрес страницы, на которой произошло событие.
Сайт | Сайт, на котором произошло событие.
Пользователь | Имя пользователя, если событие было выполнено зарегистрированным пользователем, или идентификатор гостя (при наличии модуля Веб-аналитика).
Описание | Описание события.
Гость | Идентификатор гостя (при наличии модуля Веб-аналитика).


Оповещения журнала событий

Страница Оповещения журнала событий (кнопка Оповещения журнала событий контекстной панели на странице Настройки > Инструменты > Журнал событий ) предназначена для просмотра списка оповещений журнала событий.

Функционал оповещений журнала событий доступен с версии 20.0.600 Главного модуля.

Контекстная панель

Кнопка | Описание
Добавить оповещение | Переход на страницу с формой создания нового оповещения.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Оповещения журнала событий

Поле | Описание
ID | Идентификатор оповещения.
Активность | Активность оповещения. Неактивные оповещения не срабатывают при наступлении события.
Название | Название оповещения.
Тип события | Тип события для срабатывания оповещения.
Объект | Объект оповещения.
Пользователь | Пользователь оповещения
Интервал | Интервал проверки наступления события в минутах.
Событий | Количество событий, после которого сработает оповещение.
Последняя проверка | Время последней проверки события.
IP-адрес | IP-адрес, при совершении события с которого сработает оповещение.
Браузер | Подстрока из заголовка User-Agent. Оповещение сработает при нахождении в User-Agent указанной подстроки.
Страница | Страница (URI), при совершении события на которой сработает оповещение.


Создание и редактирование оповещения

Закладки

Форма позволяет создавать и редактировать оповещения журнала событий.

Контекстная панель

Кнопка | Описание
Список оповещений | Переход на страницу со списком оповещений журнала событий.
* Добавить | Переход к форме создания нового оповещения.
* Копировать | При нажатии кнопки копируются настройки открытого оповещения и осуществляется переход к форме создания нового оповещения с использованием скопированных данных.
* Удалить | Удалить открытое оповещение.

* Кнопки отображаются только при редактировании существующего оповещения.

Условия срабатывания

Поле | Описание
ID | Идентификатор оповещения. Отображается только при редактировании существующего оповещения.
Дата последней проверки | Дата последней проверки наличия событий для оповещения. Отображается только при редактировании существующего оповещения.
Оповещение активно | Активность оповещения. Неактивные оповещения не срабатывают при наступлении события.
Название | Название оповещения.
На что реагировать
Тип события | Указывается тип события на которое будет срабатывать оповещение.
Объект | Объект события. Если объект указан в событии, то сработает оповещение.
Пользователь | ID пользователя, на действия которого сработает оповещение.
IP-адрес | IP-адрес. Оповещение сработает, если событие произошло с указанного IP-адреса.
Браузер | Указывается подстрока из заголовка User-Agent. Оповещение сработает при нахождении в User-Agent указанной подстроки.
Страница (URI) | URL страницы. Оповещение сработает, если событие произошло на указанной странице.
Условия
Интервал проверки, минут | Интервал проверки наличия событий в минутах.
Количество записей для срабатывания | Количество записей событий в журнале событий для срабатывания оповещения.

Действия

Поле Описание
Добавить новое действие При нажатии открывается форма создания действия:
Поле | Описание
Тип действия Два варианта отправки оповещения:
  • Отправить email
  • Отправить СМС
Получатель | В поле указывается email / номер телефона получателя оповещений.
Дополнительный текст | Дополнительный текст, который будет добавлен к оповещению.
Удалить | Удаление действия. Отображается только при редактировании существующего оповещения.

Доступно создание нескольких действий.


Монитор производительности. Описание модуля

Модуль Монитор производительности предназначен для мониторинга параметров производительности сайта.

О работе с модулем смотрите в учебном курсе [image].

Смотрите также:

  • Публичная часть модуля
  • Поиск "узких" мест сайта
  • Пример нахождения мелких ошибок в производительности
  • Запросы и методы
  • Пример настройки двухуровневой архитектуры


Монитор производительности. Настройки модуля

Закладки

Форма настроек модуля Монитор производительности (Настройки > Настройки продукта > Настройки модулей > Монитор производительности) предназначена для задания параметров модуля.

Настройки

Закладка предназначена для настройки параметров сбора информации и для управления монитором производительности.

Поле | Описание
Максимальная длина URL при отображении | Указывается максимальное количество символов для отображения URL'ов.
Вести журнал предупреждений PHP | При отмеченной опции ошибки PHP будут регистрироваться в журнале. Просмотреть журнал ошибок можно на странице Ошибки PHP.
Вести журнал кеширования | При отмеченной опции информация о файлах кеша будет сохраняться в журнале. Просмотреть журнал можно на странице Кеширование.
Записывать только операции с большими файлами кеша | При отмеченной опции в журнал будут записываться только операции с файлами кеша, размер которых больше, чем указано в поле Размер файла кеша больше которого считать его большим.
Размер файла кеша больше которого считать его большим | Задается размер файла кеша, по превышении которого он считается "большим".
Вести журнал SQL запросов | При отмеченной опции SQL запросы будут регистрироваться в журнале. Просмотреть журнал запросов можно на странице SQL запросы.
Сохранять стек вызова для SQL запросов | Включает отображение стека запроса на странице SQL запросы.
Записывать только медленные SQL запросы | Включает фильтры запросов по времени. При включенной опции максимальное время работы монитора может составлять 1 неделю (при выключенной опции максимальное время работы монитора составляет 1 час).
Время исполнения после которого считать запрос медленным | Задание продолжительности, по превышении которой запрос считается "медленным".
Активность монитора | В поле отображается текущий статус активности монитора производительности. Если монитор включен, то в поле будет отображен статус Работает, при этом ниже будет выведена информация: До окончания активности осталось: (часов:минут:секунд). Если монитор выключен, то в поле будет отображен статус Отключен.
Включить монитор [Отключить монитор] | Для включения монитора в поле Включить монитор укажите время, на которое монитор будет включен (например, на 1 минуту), и нажмите кнопку Применить или Сохранить. Для выключения монитора установите флаг в поле Отключить монитор и нажмите кнопку Применить или Сохранить.
Удалить собранные ранее данные | При отмеченной опции собранные ранее данные по производительности будут удалены. Опция доступна только при отключенном мониторе.

Генератор таблетов

Закладка предназначена для разработчиков [image]. На ней включается автоматическая генерация таблетов для ORM и настраиваются параметры генератора.

Поле | Описание
Разрешить генерацию таблетов для ORM | Включает автоматическую генерацию таблетов для ORM. Если разрешено, то на странице Настройки > Производительность > Таблицы в меню действий для таблицы станет доступен пункт ORM.
Параметры генератора
Использовать короткие алиасы классов | При включенной опции используются короткие алиасы классов. Пример: new Reference() вместо new Fields\Relations\Reference().
Описание параметров полей таблета через методы | При включенной опции параметры поля задаются через вывозы соответствующих методов.
Имена полей в карте | При включенной опции метод getMap таблета будет возвращаться массив, где индексами являются имена полей. При выключенной - нумерованный массив.

Доступ

Закладка позволяет настроить права на доступ к модулю для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Монитор производительности:
  • [D] доступ закрыт - запрет на доступ;
  • [R] просмотр всей статистики - доступ открыт только на просмотр статистики по производительности сайта;
  • [W] полный административный доступ - полный доступ к ресурсам модуля.
Добавить право доступа | Ссылка, позволяющая добавить дополнительное право доступа для группы пользователей.


Панель производительности

Закладки

Страница Панель производительности (Настройки > Производительность > Панель производительности) служит для выполнения тестирования производительности проекта и позволяет сравнить результаты с эталонной системой. Кроме того, даются рекомендации по настройке системы и приводится статистика самых нагруженных страниц.

Тестирование производительности

Для проведения тестирования производительности проекта служит кнопка Тестировать производительность. Тестирование будет выполняться в течение времени, указанного в поле рядом.

При выполнении тестирования будут проведены измерения активности пользователей сайта. По окончании указанного интервала на закладке Разработка будет выведена оценка производительности сайта.

Внимание! Замер производительности следует выполнять во время нагрузки, характерной для данного сайта, чтобы получить данные по фактическим посетителям. Если в момент замера на сайте посетителей нет, рекомендуем самостоятельно открывать страницы сайта во течение всего замера.

Примечание: Показатель производительности - есть величина, обратная времени исполнения ядра продукта (среднему на 10 измерений). Например, при Производительности = 40,32 можно сказать, что публичная страница сайта с пустым шаблоном (например, версия для печати), с пустой рабочей областью будет создаваться за 1/40,32 или 0,0248 сек. Если говорить проще, то сервер сгенерирует 40 (пустых, но с подключением ядра) страниц в секунду.

Конфигурация

На данной закладке осуществляется тест конфигурации системы с помощью кнопки Тестировать конфигурацию. В процессе тестирования конфигурации оценивается следующее:

  • общая оценка системы;
  • среднее время отклика (в секундах);
  • количество операций процессора с секунду (CPU);
  • файловая система (количество операций в секунду);
  • время, которое затрачивает почтовая система на отправку одного письма;
  • время старта сессии;
  • конфигурация PHP;
  • количество запросов в секунду на запись в базу данных;
  • количество запросов в секунду на чтение в базе данных;
  • количество запросов в секунду на изменение в базе данных.

После выполнения теста вы можете сравнить ваши показатели с показателями эталона. Результаты производительности для эталона получены на виртуальной машине VMBitrix.

Битрикс

На закладке представлена таблица со списком настроек системы "1С-Битрикс: Управление сайтом", которые непосредственно влияют на производительность, и приводятся необходимые рекомендации, чтобы настроить систему оптимальным образом.

Разработка

После того, как тест производительности выполнен, на данной закладке отображается статистика самых нагруженных страниц.

Масштабируемость

На данной закладке осуществляется тест производительности многопоточных и веб-кластерных систем с помощью кнопки Начать тестирование.

По ходу тестирования строится таблица с результатами, а так же графики.

Поле | Описание
Начальное количество одновременных соединений | Задается количество одновременных соединений, с которого начнется тест.
Конечное количество одновременных соединений | Задается количество одновременных соединений, с которым закончится тест.
С каким шагом увеличивать количество одновременных соединений | Указывается шаг, с которым будет увеличиваться количество одновременных соединений.
Сервер | Указывается сервер, который будет тестироваться в формате Сервер:Порт.
Страница (оставьте пустым для системного теста) | Указывается страница, к которой будет обращаться тест. При пустом поле обращение будет происходить к системной странице.
Максимальная продолжительность теста (минут) | Задается время теста в минутах.

Таблица с результатами тестов

Колонка | Описание
№ | Номер теста.
Соединений | Количество одновременных соединений к серверу.
Хитов | Общее количество хитов произведенных за тест.
Ошибок | В данном случае под ошибками понимается ответ сервера, отличающийся от 200 ОК.
Страниц в секунду | Количество страниц отданных тестируемым сервером за секунду. Соответствует красному графику Страниц в секунду.
Время генерации страницы | Время генерации страницы на тестируемом сервере. Соответствует красному графику Время генерации/получения страницы.
Время получения страницы | Время получения страницы от тестируемого сервера. Соответствует синему графику Время генерации/получения страницы.


Скорость сайта (БУС)

Скорость сайта - комплексный показатель комфортности работы с сайтом для посетителей.

Учитывает качество разработки сайта, качество хостинга и доступность сайта по сети. Рассчитывается для 1000 последних посетителей сайта. Скорость сайта фактически показывает, как быстро отобразился сайт для большинства из этих 1000 посетителей.

В отличие от большинства сервисов, замеряющих скорость загрузки сайта из внешних точек, скорость загрузки ресурса проверяется на хитах реальных пользователей.

Примечание: Инструмент Скорость сайта доступен после установки обновления main 14.9.0 и только для русских версий продуктов "1C-Битрикс: Управление сайтом".

Подробнее про инструмент можно посмотреть в соответствующем уроке [image] курса.


Страницы

На странице Страницы (Настройки > Производительность > Страницы) можно просмотреть отчет по нагружаемости страниц.

Фильтр

С помощью формы выполняется поиск страниц в соответствии с указанными условиями.

Параметр | Описание
Страница | Поиск можно задать по страницам. Поле присутствует, даже если фильтр свернут.
Адм. раздел | Поиск можно задать по страницам административного раздела или по страницам публичного раздела, или же по страницам всего сайта.
Количество | Поиск можно задать по количеству хитов по странице.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список страниц

Поле | Описание
Страница | Адрес посещаемой страницы относительно корня сайта.
Нагрузка | Нагрузка на страницу в процентом соотношении.
Количество | Количество хитов по странице.
Страница-время (сумма) | Время генерации страницы.
Страница-время (сред)
Страница-время (макс)
Страница-время (мин)
Компоненты (сред) | Среднее количество используемых компонентов.
Запросы (сред) | Среднее количество запросов к базе данных.
Файлы (макс) | Количество файлов, использующихся при обращении к странице.
Файлы (мин)
Файлы (сумма)
Файлы (сред)
Память (макс) | Количество памяти, используемое при обращении к странице.
Память (мин)
Память (сумма)
Память (сред)
Кеш (макс) | Значение кеша, используемое при обращении к странице.
Кеш (мин)
Кеш (сумма)
Кеш (сред)
Пролог-время (макс) | Время исполнения пролога при обращении к странице.
Пролог-время (мин)
Пролог-время (сумма)
Пролог-время (сред)
Агенты-время (макс) | Время исполнения агентов при обращении к странице.
Агенты-время (мин)
Агенты-время (сумма)
Агенты-время (сред)
Рабочая область-время (макс) | Время исполнения рабочей области при обращении к странице.
Рабочая область-время (мин)
Рабочая область-время (сумма)
Рабочая область-время (сред)
Эпилог-время (макс) | Время исполнения эпилога при обращении к странице.
Эпилог-время (мин)
Эпилог-время (сумма)
Эпилог-время (сред)
Почтовые события-время (макс) | Время исполнения почтовых событий при обращении к странице.
Почтовые события-время (мин)
Почтовые события-время (сумма)
Почтовые события-время (сред)
Компоненты (макс) | Количество памяти, используемое при обращении к странице.
Компоненты (мин)
Компоненты (сумма)
Компоненты-время (макс) | Количество компонентов, используемых при обращении к странице.
Компоненты-время (мин)
Компоненты-время (сумма)
Компоненты-время (сред)
Запросы (макс) | Количество запросов, совершенных при обращении к странице.
Запросы (мин)
Запросы (сумма)
Запросы-время (макс) | Время запросов, совершенных при обращении к странице.
Запросы-время (мин)
Запросы-время (сумма)
Запросы-время (сред)


Хиты

На странице Хиты (Настройки > Производительность > Хиты) можно просмотреть отчет по хитам.

Фильтр

Форма фильтра используется для фильтрации записей о хитах в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым могут выбираться записи.

Поле | Описание
Найти | Позволяет найти записи о хитах по их основным параметрам: имени сценария или идентификатору. Это поле присутствует, даже если фильтр свернут.
Имя сценария | Позволяет найти записи, указав адрес страницы, к которой осуществлялся запрос.
ID | Позволяет найти записи по идентификатору записи в таблице хитов.
Адм. раздел | Поиск можно задать по страницам административного раздела или по страницам публичного раздела, или же по страницам всего сайта.
HTTP метод | Можно задать поиск по методу GET или по всем HTTP методам.

Чтобы отфильтровать хиты по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех хитов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Хиты

Поле | Описание
Хит | Адрес страницы хита.
Страница-время | Время генерации запросов к странице.
Компоненты | Количество подключаемых компонентов.
Компоненты-время | Время, затраченное на подключение компонентов.
Запросы | Количество запросов к базе данных.
Запросы-время | Время исполнения запросов к базе данных.
ID | Идентификатор хита.
Время хита | Время, когда был совершен хит.
Адм. Раздел | Хит был совершен в административном разделе.
HTTP метод | Тип HTTP метода.
Имя сервера | Имя сервера.
Порт | Порт сервера.
Имя сценария | Адрес страницы, к которой осуществлялся запрос.
Файлов | Количество файлов, использующихся при хите.
Память | Количество памяти, используемое при хите.
Кеш | Объем кеша, используемый при хите.
Пролог-время | Время исполнения пролога при хите.
Агенты-время | Время исполнения агентов при хите.
Рабочая область-время | Время исполнения рабочей области при хите.
Эпилог-время | Время исполнения эпилога при хите.
Почтовые события-время | Время исполнения почтовых событий при хите.


Компоненты

На странице Компоненты (Настройки > Производительность > Компоненты) можно просмотреть отчет по используемым на страницах сайта компонентам или включаемым областям.

Фильтр

Форма фильтра используется для фильтрации записей о компонентах в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым могут выбираться записи.

Поле | Описание
Найти | Позволяет найти записи по основным параметрам: имени компонента или хиту. Это поле присутствует, даже если фильтр свернут.
Компонент | Позволяет найти запись по имени компонента или адреса файла включаемой области.
Хит | Позволяет найти компоненты, подключенные на странице, по идентификатору хита.
Страница | Позволяет найти запись по названию страницы.
Кеширование | Позволяет найти компоненты по типу их кеширования.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Компоненты

Поле | Описание
ID | Идентификатор записи в таблице.
Хит | Адрес страницы хита.
# | Порядковый номер компонента на странице.
Компонент | Имя компонента или адрес файла включаемой области.
Время | Время, затраченное на подключение.
Запросы | Количество выполненных запросов к базе данных.
Запросы-время | Время исполнения запросов к базе данных.
Кеширование | Тип кеширования компонента.


SQL запросы

На странице SQL запросы (Настройки > Производительность > SQL запросы) можно просмотреть отчет по запросам SQL.

Примечание: данная страница отображается, только если в настройках модуля Монитор производительности указана опция Вести журнал запросов.

Примечание: если в настройках модуля включена опция Сохранять стек вызова для SQL запросов, то при наведении указателя мыши виден стек запросов.

Фильтр

Форма фильтра используется для фильтрации записей в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым могут выбираться записи.

Поле | Описание
Найти | Позволяет найти записи о запросах по их основным параметрам: хиту или компоненту. Это поле присутствует, даже если фильтр свернут.
Хит | Позволяет найти запросы определенного хита.
Компонент | Осуществляется поиск запросов по имени определенного компонента или адреса файла включаемой области.

Чтобы отфильтровать запросы по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех запросов нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Запросы

Поле | Описание
Меню действий Доступные действия:
  • План исполнения - код запроса будет отображен в отдельном окне.
ID | Идентификатор запроса.
Хит | Идентификатор хита в модуле Монитор производительности.
# Порядковый номер запроса того или иного хита.
Время | Время выполнения запроса.
Модуль | Модуль, которым был выполнен запрос.
Компонент | Компонент, который выполнял запрос.
Запрос | Код запроса.
База данных кластера | База данных, для которой был выполнен запрос (актуально только при установленном модуле Веб-кластер).


Кеширование

На странице Монитор производительности: кеширование (Настройки > Производительность > Кеширование) можно просмотреть информацию о кеше и его файлах.

Фильтр

Поле | Описание
Найти | Позволяет найти записи о кеше по названию компонента или идентификатору хита.
Компонент | Позволяет найти записи по названию компонента.
Модуль | Позволяет найти записи по названию модуля.
Хит | Позволяет найти записи по идентификатору хита.
Экземпляр компонента | Позволяет найти записи по экземпляру компонента, который отработал на определенном хите (служебное поле, используется при переходе с других страниц модуля, например хиты).
Операция | Позволяет найти записи по типу операции с файлом кеша.
Тип | Позволяет найти записи по типу кеша (служебное поле; /bitrix/managed_cache/ - управляемый кеш, /bitrix/cache/ - неуправляемый).
Каталог | Позволяет найти записи по каталогу, в котором хранятся файлы кеша.
Файл | Позволяет найти записи по имении файла кеша.

Контекстная панель

Кнопка | Описание
Группировка Выбор режима отображения данных в таблице:
  • Без группировки - отображается вся информация о кеше, без каких-либо группировок;
  • Группировка по компонентам - информация о кеше сгруппирована по названию компонентов;
  • Группировка по типу - информация о кеше сгруппирована по типу кеша (управляемый / неуправляемый);
  • Группировка по каталогу - информация о кеше сгруппирована по каталогам, в которых хранятся файлы кеша;
  • Группировка по файлу - информация о кеше сгруппирована по файлам, в которых хранятся кеш.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.

Kеш

Поле | Описание
ID | Идентификатор записи о кеше.
Хит | Идентификатор хита.
Компонент | Название компонента, с которым связана запись о кеше.
Модуль | Название модуля, с которым связана запись о кеше.
Размер | Размер файла кеша в байтах.
Операция | Тип операции с файлом кеша.
Тип | Тип кеша.
Каталог | Каталог, в которых хранятся файлы кеша.
Файл | Название файла, в котором хранится кеш. Ссылка с названием позволяет перейти к просмотру содержимого этого файла.
Путь к файлу кеша | Путь к файлу кеша.


Таблицы

На странице Таблицы в базе данных (Настройки > Производительность > Таблицы) можно просмотреть таблицы базы данных.

При переходе по ссылке с именем таблицы в списке откроется страница, содержащая подробную информацию таблицы.


Анализ индексов

Страница для анализа индексов. Список запросов доступен после сбора статистики по медленным запросам. Детальнее смотрите в Курсе для хостеров [image].

Контекстная панель

Кнопка | Описание
Выполнить анализ собранных SQL запросов | Выполнение анализа и вывод списка запросов после тестирования конфигурации.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Список запросов

со списком запросов.
Поле | Описание
Действия Доступные действия:
  • Детальный анализ - переход к форме детального анализа;
  • План исполнения - вызов всплывающего окна с планом исполнения запроса.
Результат Цветовой индикатор результата анализа:
  • - индекс не создан
  • - индекс создан
Таблица | Имя таблицы в БД, к которой обращается запрос.
Колонки | Колонки таблицы в БД, к которым обращается запрос.
Количество запросов | Число запросов, выполненных за период тестирования. По клику на числе запросов происходит переход на страницу Настройки > Производительность > SQL запросы
Среднее время запроса | Среднее время запроса.
Общее время запроса | Общее время запроса.
Текст запроса | Собственно текст запроса.


Детальный анализ индекса

Закладки

Форма детального анализа запроса.

Контекстная панель

Кнопка | Описание
Список | Возврат к странице Список запросов.

Структура таблиц

Информация о структуре таблицы и её индексах.

Раздел | Описание
Запрос | Текст запроса.
Статистика таблицы | Название, размер и количество строк в таблице.
Структура таблицы | Структура таблицы и индекса.

Анализ запросов

Статистика селективности конкретных значений из запросов.

Колонка | Описание
Запрос | Текст запроса.
_имя колонки_ | Колонка таблицы, к которой обращается запрос и процент выборки данных.

Создание индекса

Создание, удаление и тестирование индекса.

Раздел | Описание
Запрос | Текст запроса.
План исполнения до создания индекса | Таблица с планом исполнения и средним временем запроса.
Индекс
  • Запрос на создание индекса (для использования в консоли);
  • Создать индекс - кнопка создания предлагаемого индекса;
  • Больше не предлагать создавать - отказ от создания, больше система не будет предлагать создание индекса по этому запросу.
После создания индекса появится кнопка Удалить индекс и раздел План исполнения после создания индекса.


Список индексов

Список созданных индексов

Контекстная панель

Кнопка | Описание
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.
Поле | Описание
Колонка действий Доступные действия:
  • Удалить индекс - удаление индекса.
Статус
  • - индекс создан
  • - индекс не будет создаваться
Таблица | Таблица к которой обращается запрос.
Колонка | Колонка таблицы к которой обращается запрос.
Индекс | Название индекса, либо уведомление Не предлагать создавать.


Настройки PHP

На странице Настройки PHP (Настройки > Производительность > PHP) отображается сводная таблица Параметры окружения с анализом параметров PHP.

С помощью ссылки Настройки PHP открывается страница с подробной информацией о PHP.


Сервер БД

На странице Сервер БД (Настройки > Производительность > Сервер БД) отображается сводная статистика производительности сервера базы данных.

Если значения показателей отличаются от рекомендованных, то их можно скорректировать с помощью инструментов Проверка БД и/или SQL запрос.


История замеров производительности

На странице История замеров производительности (Настройки > Производительность > История) можно просмотреть результаты прошлых замеров производительности.

В таблице отображается производительность системы с указанием даты замера.


Ошибки PHP

На странице Журнал ошибок PHP (Настройки > Производительность > Ошибки PHP (N)) можно просмотреть журнал регистрации ошибок PHP, где N - общее количество ошибок.

Примечание: Данная страница отображается, только если в настройках модуля Монитор производительности указана опция Вести журнал предупреждений PHP.

Фильтр

Форма фильтра используется для фильтрации записей журнала в соответствии с указанными условиями. Нижеследующая таблица описывает параметры, по которым могут выбираться записи.

Поле | Описание
Найти | Позволяет найти записи об ошибках по их основным параметрам. Это поле присутствует, даже если фильтр свернут.
Хит | Позволяет найти записи по идентификатору хита.
Класс ошибки | Позволяет осуществлять поиск в журнале по классу (типу) ошибок.
Файл | Позволяет осуществлять поиск в журнале по файлу, в котором произошла ошибка.
Текст | Позволяет осуществлять поиск в журнале по тексту ошибки.

Чтобы отфильтровать ошибки по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех ошибок нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Группировка Позволяет задать способ группировки записей об ошибках в журнале:
  • Группировка включена - журнал будет содержать поля: Класс ошибки, Файл, Строка, Текст, Количество;
  • Группировка выключена - журнал будет содержать поля: ID, Хит, Класс ошибки, Файл, Строка, Текст.
Настроить | Переход к диалогу настройки внешнего вида отчетной формы.
Excel | Экспорт данных из отображаемой таблицы в MS Excel.

Ошибки PHP

Поле | Описание
ID | Идентификатор записи об ошибке в журнале.
Хит | Идентификатор хита.
Класс ошибки | Класс (тип) ошибки.
Файл | Путь к файлу в системе, в котором произошла ошибка.
Строка | Номер строки в файле.
Текст | Текст ошибки.


Модуль Чат-ботов

Модуль управляет чат-ботами Битрикс24. Установка модуля не происходит автоматически, так же необходимо будет осуществить настройку локальной сети для доступа к порталу из сети. Подробнее в курсе Администратор сервиса Битрикс24 (коробочная версия) [image].


ЧатБоты (КП). Настройки модуля

Форма настроек модуля Чат-Боты (Настройки > Настройки продукта > Настройки модулей > Чат-боты Битрикс24) предназначена для задания параметров модуля.

Закладка Настройки

Форма позволяет изменить публичный адрес для доступа к порталу, включить или отключить какие-либо чат-боты.

Поле | Описание
Публичный адрес сайта | Адрес, по которому будет обращаться внешний сервис к вашему порталу для вывода сообщений чат-ботов. Как правило, совпадает с реальным адресом портала. После соответствующих настроек роутера локальной сети может не совпадать с публичным адресом, но эти меры - крайность, в случае строгих требований по безопасности.
Режим отладки | Включает логгирование работы модуля в файле /bitrix/modules/imbot.log.
Долгое ожидание ответа | Включение влияет на количество занятых worker-ов хостинга. Без активации этой опции сообщение чат-боту отправляется и worker освобождается. В случае активации опции worker будет занят до момента ответа чат-ботом (а это может занимать десятки секунд). Поэтому включать эту опцию нужно, только если не получилось корректно настроить окружение, и оно блокирует входящие запросы от marta.bitrix.info. Опция доступна после включения режима отладки.
Чат-боты | Опции включения штатных чат-ботов и чат-ботов из Маркетплейса Приложения 24. По умолчанию включён только штатный чат-бот Giphy (Картинки по запросу).


Компрессия

Внимание!
Начиная с версии 20.0.1300 Главного модуля модуль Компрессия удалён из продукта. Рекомендуется настроить сжатие контента в веб-сервере.

Модуль Компрессия осуществляет сжатие страниц для ускорения вывода содержания сайта пользователям. Модуль в несколько раз уменьшает объем передаваемых HTML-данных между сайтом и браузером клиента, что существенно увеличивает скорость работы как для посетителей, так и для администраторов сайта.

Модуль Компрессия не нуждается в каких-либо настройках. Эффективность работы модуля можно оценить, добавив в строке браузера параметр compress=Y. Например:

http://ourcompany.com/ru/partners/catalog.php?BID=10&compress=Y

При этом параметре внизу всех страниц будет выводиться таблица следующего вида:

Библиотека компрессии
Размер страницы | 101284
После сжатия | 14689
Коэффициент сжатия | 6.9

Примечание для разработчиков. Для оценки времени отгрузки страницы можно воспользоваться параметром show_page_exec_time=Y, при использовании которого в нижнем левом углу страницы отобразится время, затраченное на генерацию страницы (в отличие от времени, затраченного на передачу).

Примечание для разработчиков. На некоторых хостингах модуль компрессии может работать неадекватно из-за настроек сервера на хостинге. В этом случае рекомендуется либо отключить модуль в системе, либо установить в dbconn.php значение define("BX_COMPRESSION_DISABLED", true);.


Основные сведения

Структура главы Компоненты полностью повторяет логику панели компонентов визуального редактора. Сохранены все разделы, подразделы, названия и расположение каждого компонента. Разделы:

Контент

Название подраздела/компонента | Относится к модулям | Описание
Статьи и новости | Информационные блоки | Позволяет создать новостной раздел на сайте.
Фотогалерея | Информационные блоки | Позволяет получить полнофункциональную фотогалерею.
Фотогалерея 2.0 | Фотогалерея | Позволяет получить полнофункциональную фотогалерею с гибко настраиваемыми параметрами, в т.ч. многопользовательскую.
Каталог | Информационные блоки | Выводит полный каталог товаров.
Универсальные списки | Универсальные списки | Позволяет вести полнофункциональную работу с универсальными списками.
Google Maps | Управление структурой | Позволяет размещать на сайте карты, производить по ним поиск, создавать непосредственно на карте комментарии и задавать стартовую точку открытия карты.
Highload инфоблоки | Highload-блоки | Позволяет вести работу с хранилищами произвольных данных.
RSS | Информационные блоки | Позволяет вести работу с новостями другого сайта.
Wiki | Wiki | Для работы с базой знаний (Wiki).
Валюты | Валюты | Для работы с курсами валют.
Добавление элементов | Информационные блоки | Для работы с элементами инфоблока.
Инфоблоки | Информационные блоки | Для управления различными блоками однородной информации.
Календарь событий | Календарь событий | Для отображения календаря событий.
Карта сайта | Главный модуль | Для показа карты сайта.
Медиа | Информационные блоки Управление структурой | Для проигрывания медиафайлов различных форматов.
Яндекс.Карты | Управление структурой | Для отображения карты с сервиса Яндекс.Карты.
Обмен с 1С | Торговый каталог | Для обмена данными с 1С в формате CommerceML v2.
Социальные сервисы | Информационные блоки | Для публикации комментариев к товару и информации в соцсетях.

Сервисы

Название подраздела/компонента | Относится к модулям | Описание
Контроллер | Контроллер | Для администрирования локальных и удаленных сайтов.
Частые вопросы | Информационные блоки | Для вывода категорий и вопросов FAQ.
Email-маркетинг | Email-маркетинг | Для организации работы рассылок.
Веб-Сервис | Веб-сервис | Для организации системы веб-сервисов и SOAP.
Веб-формы | Веб-формы | Позволяет создавать и размещать в публичном разделе сайта различные формы для организации взаимодействия с посетителями.
Менеджер идей | Менеджер идей | Для организации сервиса идей.
Обучение | Обучение | Позволяет организовать систему дистанционного обучения.
Опросы, голосования | Опросы, голосования | Для организации обратной связи с посетителями сайта.
Рассылки | Рассылки | Для организации рассылки почтовых сообщений сайта.
Реклама | Реклама | Для организации рассылки почтовых сообщений сайта.
Техподдержка | Техподдержка | Для организации системы обращений пользователей в техподдержку.
Рабочий стол |  | Позволяет создать настраиваемый рабочий стол с использованием разнофункциональных гаджетов.

Общение

Название подраздела/компонента | Относится к модулям | Описание
Бизнес-процесс | Бизнес-процесс | Для работы с бизнес-процессами организации.
Блоги | Блоги | Для полнофункциональной работы с неограниченным числом блогов.
Социальная сеть | Социальная сеть | Для создания полнофункционального публичного интерфейса социальной сети.
Форум | Форум | Для организации полноценного публичного интерфейса форума.

Магазин

Название подраздела/компонента | Относится к модулям | Описание
Аффилиаты | Интернет-магазин | Для работы с аффилиатами.
Корзина | Интернет-магазин | Для работы с корзиной покупателя.
Процедура заказа | Интернет-магазин | Для построения процедуры оформления заказа.
Рекомендуемые товары | Торговый каталог | Выводит список товаров, рекомендуемых к покупке вместе выбранным товаром.
Список профилей текущего пользователя | Торговый каталог Интернет-магазин | Для работы с персональным разделом пользователя.
Экспорт заказов | Интернет-магазин | Для экспорта заказов в "1С:Предприятие".
Информация о товарах | Интернет-магазин Торговый каталог | Для организации работы с товарами.
Склады | Торговый каталог | Для работы со складами.

Служебные

Название подраздела/компонента | Относится к модулям | Описание
navigation | Главный модуль Информационные блоки | Для навигации между сайтами, по меню и т.д.
Безопасность | Проактивная защита | Для управления резервными кодами для двухэтапной авторизации.
Включаемые области | Главный модуль | Для расположения на страницах и в разделах включаемых областей.
Поиск | Поиск | Для размещения компонентов, которые осуществляют индексирование и поиск информации на сайте
Пользователь | Главный модуль Социальные сервисы Интеграция с Битрикс24 | Для полнофункциональной работы с пользователями.
Статистика | Веб-аналитика | Для размещения таблицы статистики.


CRM (КП)

Система управления взаимодействием с клиентами (или CRM, сокр. от англ. Customer Relationship Management System) — система, предназначенная для повышения уровня продаж, оптимизации маркетинга и улучшения обслуживания клиентов. В CRM сохраняется информация о клиентах и история взаимоотношений с ними для последующего анализа результатов.

Модуль относится только к "Битрикс24 в коробке" .

Настройки модуля описаны здесь.

Сущности модуля
Название | Имя в пространстве имен bitrix | Описание
Подразделы
Дела | crm.activity | Позволяет управлять списком дел, выводит списки задач и записей.
Компании | crm.company | Предназначен для создания и настройки компаний, а также управления их списком и др.
Контакты | crm.contact | Позволяет создавать и изменять контакты, управлять списками и экспортировать их.
Контакты | crm.contact | Позволяет создавать и изменять контакты, управлять списками и экспортировать их.
Лиды | crm.lead | Служит для работы с лидами.
Настройки | crm.config | Подраздел содержит компоненты настройки модуля CRM.
Предложения | crm.quote | Позволяет работать с предложениями: добавлять новые, редактировать, настраивать меню и др.
Редактирование группы пользователя* | crm.order.buyer | Предназначен для работы с группами пользователя.
Реквизиты | crm.requisite | Используется для вывода списка реквизитов компании.
Сделки | crm.deal | Содержит компоненты, отвечающие за настройку функционирования сделок.
Счета | crm.invoice | Позволяет работать со счетами в CRM.
Товары | crm.product | Используется для работы с товарами.
Форма оформления заказа* | crm.order.matcher.property.edit | Предназначен для настройки формы оформления заказа.
Компоненты
Отчеты (комплексный компонент) | crm.report | Необходим для составления отчетов по работе в CRM.
Просмотр событий | crm.event.view | Выводит список действий, произведенных над сущностями системы CRM.
Просмотр событий счета | crm.invoice.events | Выводит список действий, произведенных над счетами системы CRM.

* отмечены разделы только с системными компонентами (не описываются)


Просмотр событий

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Просмотр событий

CRM (КП)::Просмотр событий

Описание crm.event.view

Одностраничный компонент, выводит список действий, произведенных над сущностями системы CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Просмотр событий.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип сущности | ENTITY_TYPE | Указывается тип сущностей, список действий над которыми будет выводить компонент.
ID элемента сущности | ENTITY_ID | Указывается идентификатор элемента сущности.
Количество событий на странице | EVENT_COUNT | Выставляется число выводимых на одной странице событий.
Выводить заголовок сущности EVENT_ENTITY_LINK Указывается, требуется ли выводить в таблице название сущности, действие над которой приведено в списке. Возможны два варианта:
  • да;
  • нет.
Дополнительные настройки
Формат имени | NAME_TEMPLATE | Выбирается формат отображения имени.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.event.view",
    "",
    Array(
        "ENTITY_TYPE" => "LEAD",
        "ENTITY_ID" => "5",
        "EVENT_COUNT" => "20",
        "EVENT_ENTITY_LINK" => "N"
    )
);?>


Отчеты (комплексный компонент)

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Отчеты (комплексный компонент)

CRM (КП)::Отчеты (комплексный компонент)

Описание crm.report

Комплексный компонент, необходим для составления отчетов по работе в CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Отчеты.

Параметры

Поле | Параметр | Описание
Основные параметры
ID отчета | REPORT_ID | Указывается код, в котором передается идентификатор отчета.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта): SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - основная страница;
  • report - страница списка отчетов;
  • construct - страница редактирования отчета;
  • show - страница просмотра отчета;
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
  • report_id - имя переменной идентификатора отчета (указывается при выключенном режиме поддержки ЧПУ);
  • action - имя переменной идентификатора действия (указывается при выключенном режиме поддержки ЧПУ).
[/di] .

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.report",
    "",
    Array(
        "SEF_MODE" => "Y",
        "REPORT_ID" => $_REQUEST["report_id"],
        "SEF_FOLDER" => "/crm/reports/report/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "report" => "report/",
            "construct" => "construct/#report_id#/#action#/",
            "show" => "view/#report_id#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "report" => Array(),
            "construct" => Array(),
            "show" => Array(),
        )
    )
);?>


Просмотр событий счета

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Просмотр событий счета

CRM (КП)::Просмотр событий счета

Описание crm.invoice.events

Одностраничный компонент, выводит список действий, произведенных над счетами системы CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Просмотр событий счета.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип сущности | ENTITY_TYPE | Указывается тип сущностей, список действий над которыми будет выводить компонент. Доступно значение Счет.
ID элемента сущности | ENTITY_ID | Указывается идентификатор счета.
Количество событий на странице | EVENT_COUNT | Выставляется число выводимых на одной странице событий.
Дополнительные настройки
Формат имени | NAME_TEMPLATE | Выбирается формат отображения имени.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.invoice.events",
    "",
    Array(
        "ENTITY_TYPE" => "INVOICE",
        "ENTITY_ID" => "",
        "EVENT_COUNT" => "20",
        "NAME_TEMPLATE" => "#LAST_NAME#, #NAME# #SECOND_NAME#"
    )
);?>


Дела

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Дела (комплексный компонент) | crm.activity | Позволяет управлять списком дел.
Список задач | task.list | Выводит список задач
Список звонков/встреч | activity.calendar.list | Выводит список записей календаря.


Дела

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Дела

Дела::Дела

Описание crm.activity

Комплексный компонент, позволяет управлять списком дел.

В визуальном редакторе компонент расположен по пути CRM > Дела > Дела.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - основная страница;
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Дополнительные настройки
Формат имени | NAME_TEMPLATE | Выбирается формат отображения имени.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.activity",
    "",
    Array(
        "NAME_TEMPLATE" => "",
        "SEF_MODE" => "N"
    )
);?>


Список задач

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Дела>Список задач

Дела::Список задач

Описание crm.activity.task.list

Одностраничный компонент выводит список задач. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Дела > Список задач.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество задач на странице | ACTIVITY_TASK_COUNT | Число выводимых на одну страницу задач.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.activity.task.list",
    "",
    Array(
        "ACTIVITY_TASK_COUNT" => "20"
    )
);?>


Список звонков/встреч

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Дела>Список звонков/встреч

Дела::Список звонков/встреч

Описание crm.activity.calendar.list

Одностраничный компонент выводит список записей календаря. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Дела > Список звонков/встреч.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество звонков на странице | ACTIVITY_TASK_COUNT | Число выводимых на одну страницу записей календаря.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.activity.calendar.list",
    "",
    Array(
        "ACTIVITY_CALENDAR_COUNT" => "20"
    )
);?>


Компании

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Компании (комплексный компонент) | crm.company | Позволяет управлять списком компаний.
Список компаний | crm.company.list | Выводит список компаний.
Редактирование компании | crm.company.edit | Позволяет добавлять новую, или редактировать параметры имеющейся компании.
Просмотр компании | crm.company.show | Осуществляет вывод детального описания компании.
Панель инструментов | crm.company.menu | Позволяет настроить верхнее меню сущности.
Импорт компаний* | crm.company.menu | Позволяет импортировать список компаний.

* отмечены системные компоненты (не описываются)


Компании (комплексный компонент)

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Компании>Компании (комплексный компонент)

Компании::Компании (комплексный компонент)

Описание crm.company

Комплексный компонент позволяет управлять списком компаний. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Компании > Компании.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - основная страница;
  • list - страница списка контактов;
  • edit - страница редактирования контакта;
  • show - страница просмотра контакта;
  • import - страница импорта.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
company_id - имя переменной идентификатора компании (указывается при выключенном режиме поддержки ЧПУ).
[/di] .
Основные параметры
ID компании | ELEMENT_ID | Поле содержит код, в котором передается идентификатор компании.
Дополнительные настройки
Формат имени | NAME_TEMPLATE | Выбирается формат отображения имени.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.company",
    "",
    Array(
        "SEF_MODE" => "Y",
        "ELEMENT_ID" => $_REQUEST["company_id"],
        "NAME_TEMPLATE" => "",
        "SEF_FOLDER" => "/docs/a-new-section-1/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "list" => "list/",
            "edit" => "edit/#company_id#/",
            "show" => "show/#company_id#/",
            "import" => "import/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "report" => Array(),
            "construct" => Array(),
            "show" => Array(),
            "list" => Array(),
            "edit" => Array(),
            "import" => Array(),
        )
    )
);?>


Панель инструментов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Компании>Панель инструментов

Компании::Панель инструментов

Описание crm.company.menu

Одностраничный компонент, позволяет настроить контентное меню сущности.

В визуальном редакторе компонент расположен по пути CRM > Компании > Панель инструментов.

Параметры

Поле | Параметр | Описание
Основные параметры
ID компании | ELEMENT_ID | Поле содержит код, в котором передается идентификатор компании.
Вид отображения меню TYPE Выбирается функционал для представления в контентном меню. Возможны четыре варианта:
  • LIST - выводятся кнопки Список компаний, Добавить компанию;
  • SHOW - выводятся кнопки Список компаний, Добавить компанию;
  • EDIT - выводятся кнопки Список компаний, Добавить компанию.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.company.menu",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["company_id"],
        "TYPE" => "show"
    )
);?>


Просмотр компании

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Компании>Просмотр компании

Компании::Просмотр компании

Описание crm.company.show

Одностраничный компонент, осуществляющий вывод детального описания компании. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Компании > Просмотр компании.

Параметры

Поле | Параметр | Описание
Основные параметры
ID компании | ELEMENT_ID | Поле содержит код, в котором передается идентификатор компании.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.company.show",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["company_id"]
    )
);?>


Редактирование компании

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Компании>Редактирование компании

Компании::Редактирование компании

Описание crm.company.edit

Одностраничный компонент, позволяет добавлять новую, или редактировать параметры имеющейся компании. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Компании > Редактирование компании.

Параметры

Поле | Параметр | Описание
Основные параметры
ID компании | ELEMENT_ID | Поле содержит код, в котором передается идентификатор компании.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.company.edit",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["company_id"]
    )
);?>


Список компаний

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Компании>Список компаний

Компании::Список компаний

Описание crm.company.list

Одностраничный компонент выводит список компаний. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Компании > Список компаний.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество компаний на странице | COMPANY_COUNT | Число выводимых на одну страницу компаний.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.company.list",
    ".default",
    Array(
        "COMPANY_COUNT" => "20"
    )
);?>


Контакты

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Контакты (комплексный компонент) | crm.contact | Позволяет управлять списком контактов.
Список контактов | crm.contact.list | Выводит список контактов.
Редактирование контакта | crm.contact.edit | позволяет добавлять новый, или редактировать параметры имеющегося контакта.
Просмотр контакта | crm.contact.show | Осуществляет вывод детального описания контакта.
Панель инструментов | crm.contact.menu | Позволяет настроить верхнее меню сущности.
Импорт контактов* | crm.contact.import | Предназначен для импорта списка контактов в формате CSV.
Веб сервис* | crm.contact.webservice | Предназначен для создания и экспорта контактов.

* отмечены системные компоненты (не описываются)


Контакты (комплексный компонент)

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Контакты>Контакты (комплексный компонент)

Контакты::Контакты (комплексный компонент)

Описание crm.contact

Комплексный компонент позволяет управлять списком контактов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Контакты > Контакты.

Параметры

Поле | Параметр | Описание
Основные параметры
ID контакта | ELEMENT_ID | Поле содержит код, в котором передается идентификатор контакта.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить следующие параметры: [dw]SEF_FOLDER, SEF_URL_TEMPLATES.[/dw][di]
Каталог ЧПУ (относительно корня сайта): SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - основная страница;
  • list - страница списка контактов;
  • edit - страница редактирования контакта;
  • show - страница просмотра контакта;
  • service - страница Веб-сервиса;
  • import - страница импорта.
[/di]
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES. [/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
company_id - имя переменной идентификатора компании (указывается при выключенном режиме поддержки ЧПУ).
[/di]
Дополнительные настройки
Формат имени | NAME_TEMPLATE | Выбирается формат отображения имени.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.contact",
    "",
    Array(
        "SEF_MODE" => "Y",
        "ELEMENT_ID" => $_REQUEST["contact_id"],
        "NAME_TEMPLATE" => "",
        "SEF_FOLDER" => "/docs/a-new-section-1/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "list" => "list/",
            "edit" => "edit/#contact_id#/",
            "show" => "show/#contact_id#/",
            "service" => "service/",
            "import" => "import/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "report" => Array(),
            "construct" => Array(),
            "show" => Array(),
            "list" => Array(),
            "edit" => Array(),
            "import" => Array(),
            "service" => Array(),
        )
    )
);?>


Панель инструментов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Контакты>Панель инструментов

Контакты::Панель инструментов

Описание crm.contact.menu

Одностраничный компонент, позволяет настроить контентное меню сущности.

В визуальном редакторе компонент расположен по пути CRM > Контакты > Панель инструментов.

Параметры

Поле | Параметр | Описание
Основные параметры
ID контакта | ELEMENT_ID | Поле содержит код, в котором передается идентификатор контакта.
Вид отображения меню TYPE Выбирается функционал для представления в контентном меню. Возможны четыре варианта:
  • LIST - выводятся кнопки Добавить контакт, Импорт контактов, Экспорт контактов;
  • SHOW - выводятся кнопки Список контактов, Добавить контакт;
  • EDIT - выводятся кнопки Список контактов, Добавить контакт;
  • IMPORT - выводятся кнопки Список контактов, Добавить контакт.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.contact.menu",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["contact_id"],
        "TYPE" => "page"
    )
);?>


Просмотр контакта

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Контакты>Просмотр контакта

Контакты::Просмотр контакта

Описание crm.contact.show

Одностраничный компонент, осуществляющий вывод детального описания контакта. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Контакты > Просмотр контакта.

Параметры

Поле | Параметр | Описание
Основные параметры
ID контакта | ELEMENT_ID | Поле содержит код, в котором передается идентификатор контакта.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.contact.show",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["contact_id"]
    )
);?>


Редактирование контакта

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Контакты>Редактирование контакта

Контакты::Редактирование контакта

Описание crm.contact.edit

Одностраничный компонент, позволяет добавлять новый, или редактировать параметры имеющегося контакта. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Контакты > Редактирование контакта.

Параметры

Поле | Параметр | Описание
Основные параметры
ID контакта | ELEMENT_ID | Поле содержит код, в котором передается идентификатор контакта.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.contact.edit",
    ".default",
    Array(
        "ELEMENT_ID" => $_REQUEST["contact_id"]
    )
);?>


Список контактов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Контакты>Список контактов

Контакты::Список контактов

Описание crm.contact.lis

Одностраничный компонент выводит список контактов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Контакты > Список контактов.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество контактов на странице | CONTACT_COUNT | Число выводимых на одну страницу контактов.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.contact.list",
    ".default",
    Array(
        "CONTACT_COUNT" => "20"
    )
);?>


Лиды

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Лиды (комплексный компонент) | crm.lead | Позволяет работать с лидами.
Трекер посетителей* | faceid.tracker | Выводит трекер посетителей и историю посещений.
Заполнение формы CRM-форм | crm.webform.fill | Отвечает за заполнение формы CRM-форм.
Список лидов | crm.lead.list | Выводит список лидов.
Редактирование лида | crm.lead.edit | Позволяет создать новый, либо редактировать существующий лид.
Просмотр лида | crm.lead.show | Осуществляет вывод детального описания лида.
Туллбар | crm.lead.menu | Позволяет настроить верхнее меню сущности.
Конвертация лида | crm.lead.convert | Позволяет конвертировать лид в контакт, компанию или сделку.
Импорт лидов* | crm.lead.import | Предназначен для импорта списка лидов в формате CSV.
Веб-сервис* | crm.lead.webservice | Сервис для создания лида.
Обработчик REST* | crm.lead.rest | Обработчик REST для создания лида.

* отмечены системные компоненты (не описываются)


Заполнение формы CRM-форм

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Лиды>Заполнение формы CRM-форм

Лиды::Заполнение формы CRM-форм

Описание crm.webform.fill

Одностраничный компонент, отвечает за заполнение формы CRM-форм.

В визуальном редакторе компонент расположен по пути CRM > Лиды > Заполнение формы CRM-форм.

Параметры

Поле | Параметр | Описание
Основные параметры
Код формы | FORM_ID | Указывается уникальный идентификатор формы.
Символьный код формы | FORM_CODE | Прописывается мнемонический идентификатор. Задается латинскими буквами, позволяет однозначно определить форму и вызвать ее из кода.
Код безопасности | SECURITY_CODE | Вводится код для показа формы. Параметр берется из адреса страницы.
Путь к странице оплаты счета | PATH_TO_INVOICE_PAY | Указывается путь к странице оплаты счета от корня сайта. Если страница находится в текущей директории, то достаточно указать ее название.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.webform.fill",
    "",
    Array(
        "FORM_CODE" => "20",
        "FORM_ID" => "20",
        "PATH_TO_INVOICE_PAY" => "20",
        "SECURITY_CODE" => "20"
    )
);?>


Конвертация лида

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Лиды>Конвертация лида

Лиды::Конвертация лида

Описание crm.lead.convert

Одностраничный компонент, позволяет конвертировать лид в контакт, компанию и сделку. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Лиды > Конвертация лида.

Параметры

Поле | Параметр | Описание
Основные параметры
ID лида | ELEMENT_ID | Поле содержит код, в котором передается идентификатор лида.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.lead.convert",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["lead_id"]
    )
);?>


Лиды (комплексный компонент)

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Лиды>Лиды (комплексный компонент)

Лиды::Лиды (комплексный компонент)

Описание crm.lead

Комплексный компонент позволяет работать с лидами. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Лиды > Лиды.

Параметры

Поле | Параметр | Описание
Основные параметры
ID лида | ELEMENT_ID | Поле содержит код, в котором передается идентификатор лида.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта): SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - основная страница;
  • list - страница списка лидов;
  • edit - страница редактирования лида;
  • show - страница просмотра лида;
  • convert - страница конвертации лида;
  • import - страница импорта лидов.
  • service - страница Веб-сервиса;
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
lead_id - имя переменной идентификатора лида (указывается при выключенном режиме поддержки ЧПУ).
[/di] .
Дополнительные настройки
Формат имени | NAME_TEMPLATE | Выбирается формат отображения имени.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.lead",
    "",
    Array(
        "SEF_MODE" => "Y",
        "ELEMENT_ID" => $_REQUEST["lead_id"],
        "NAME_TEMPLATE" => "",
        "SEF_FOLDER" => "/docs/a-new-section-1/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "list" => "list/",
            "edit" => "edit/#lead_id#/",
            "show" => "show/#lead_id#/",
            "convert" => "convert/#lead_id#/",
            "import" => "import/",
            "service" => "service/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "report" => Array(),
            "construct" => Array(),
            "show" => Array(),
            "list" => Array(),
            "edit" => Array(),
            "import" => Array(),
            "service" => Array(),
            "convert" => Array(),
        )
    )
);?>


Просмотр лида

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Лиды>Просмотр лида

Лиды::Просмотр лида

Описание crm.lead.show

Одностраничный компонент, осуществляющий вывод детального описания лида. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Лиды > Просмотр лида.

Параметры

Поле | Параметр | Описание
Основные параметры
ID лида | ELEMENT_ID | Поле содержит код, в котором передается идентификатор лида.

Пример вызова

<?$
APPLICATION->IncludeComponent(
"bitrix:crm.lead.show",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["lead_id"]
    )
);?>


Редактирование лида

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Лиды>Редактирование лида

Лиды::Редактирование лида

Описание crm.lead.edit

Одностраничный компонент, позволяет добавлять новый, или редактировать параметры имеющегося лида. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Лиды > Редактирование лида.

Параметры

Поле | Параметр | Описание
Основные параметры
ID лида | ELEMENT_ID | Поле содержит код, в котором передается идентификатор лида.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.lead.edit",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["lead_id"]
    )
);?>


Список лидов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Лиды>Список лидов

Лиды::Список лидов

Описание crm.lead.list

Одностраничный компонент выводит список лидов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Лиды > Список лидов.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество лидов на странице | LEAD_COUNT | Число выводимых на одну страницу лидов.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.lead.list",
    "",
    Array(
        "LEAD_COUNT" => "20"
    )
);?>


Туллбар

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Лиды>Туллбар

Лиды::Туллбар

Описание crm.contact.menu

Одностраничный компонент, позволяет настроить контентное меню сущности.

В визуальном редакторе компонент расположен по пути CRM > Лиды > Туллбар.

Параметры

Поле | Параметр | Описание
Основные параметры
ID лида | ELEMENT_ID | Поле содержит код, в котором передается идентификатор лида.
Вид отображения меню TYPE Выбирается функционал для представления в контентном меню. Возможны пять вариантов:
  • LIST - выводятся кнопки Добавить лид, Импорт лидов, Экспорт лидов;
  • SHOW - выводятся кнопки Список лидов, Добавить лид;
  • EDIT - выводятся кнопки Список лидов, Добавить лид;
  • CONVERT - выводятся кнопки Список лидов, Добавить лид;
  • IMPORT - выводятся кнопки Список лидов, Добавить лид.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.contact.menu",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["lead_id"],
        "TYPE" => "page"
    )
);?>


Настройки

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Настройки прав доступа | crm.config.perms | Позволяет выполнить настройку прав доступа к модулю CRM.
Настройка связей ролей | crm.config.perms.relation | Позволяет настроить связь ролей с группами сотрудников.
Редактирование роли | crm.config.perms.role.edit | Позволяет выполнить настройку прав доступа роли к сущностям CRM.
Настройки бизнес-процессов | crm.config.bp | Позволяет выполнить настройку бизнес-процессов в модуле CRM.
Список типов шаблонов бизнес-процессов | crm.config.bp.types | Выводит список типов шаблонов бизнес-процессов
Список бизнес-процессов | crm.config.bp.list | Выводит список бизнес-процессов модуля CRM.
Редактирование шаблона бизнес-процесса | crm.config.bp.edit | Позволяет отредактировать шаблон бизнес-процесса модуля CRM.
Настройки шаблонов реквизитов клиентов | crm.config.preset | Позволяет настроить шаблоны реквизитов клиентов модуля CRM.
Список неиспользуемых пользовательских полей | crm.config.preset.ufields | Выводит список пользовательских полей, которые не используются в шаблонах.
Список шаблонов реквизитов клиентов | crm.config.preset.list | Выводит список шаблонов реквизитов клиентов модуля CRM.
Настройки пользовательских полей | crm.config.fields | Позволяет выполнить настройку пользовательских полей в модуле CRM.
Список пользовательских полей | crm.config.fields.list | Выводит список пользовательских полей модуля CRM.
Список типов пользовательских полей | crm.config.fields.types | Выводит список типов пользовательских полей модуля CRM.
Настройка пользовательского поля | crm.config.fields.edit | Позволяет выполнить настройку пользовательского поля модуля CRM.
Связь с магазином (комплексный компонент) | crm.config.external_sale | Позволяет выполнить настройку интеграции CRM с интернет-магазином.
1С распознавание лиц* | faceid.1c | Идентифицирует клиентов из 1С по фотографии.
Настройка отправки писем* | crm.config.configs | Позволяет настроить отправку писем в модуле CRM.
Настройка Email-трекера* | crm.config.emailtracker | Позволяет настроить Email-трекер в модуле CRM.
Настройка Send&Save* | crm.config.sendsave | Настройка интеграции с Send&Save в модуле CRM.
Настройка интеграции с "1С:Предприятие" | crm.config.exch1c | Позволяет настроить интеграцию с "1С:Предприятие" в модуле CRM.
Настройка статусов* | crm.config.status | Позволяет выполнить настройку статусов модуля CRM.
Настройка трекера* | crm.config.tracker | Позволяет настроить трекер в модуле CRM.

* отмечены системные компоненты (не описываются)


Настройка интеграции с "1С:Предприятие"

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Настройка интеграции с "1С:Предприятие"

Настройки::Настройка интеграции с "1С:Предприятие"

Описание crm.config.exch1c

Компонент позволяет выполнить настройку интеграции CRM с "1С:Предприятие" и содержит два шаблона: .default и free. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Настройка интеграции с "1С:Предприятие".

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта): SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - основная страница;
  • catalog/ - страница настройки обмена товарами с "1С:Предприятие";
  • invoice/ - страница настройки обмена счетами с "1С:Предприятие".
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Дополнительные настройки
Формат имени | NAME_TEMPLATE | Выбирается формат отображения имени.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.config.exch1c",
    ".default",
    Array(
        "SEF_MODE" => "Y",
        "NAME_TEMPLATE" => "#LAST_NAME# #NAME# #SECOND_NAME#",
        "SEF_FOLDER" => "/docs/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "catalog" => "catalog/",
            "invoice" => "invoice/"
        ),
        "VARIABLE_ALIASES" => Array(
            "PATH_TO_ROLE_EDIT" => Array(),
            "index" => Array(),
            "catalog" => Array(),
            "invoice" => Array(),
        )
    )
);?>


Настройка пользовательского поля

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Настройка пользовательского поля

Настройки::Настройка пользовательского поля

Описание crm.config.fields.edit

Одностраничный компонент, позволяет выполнить настройку пользовательского поля в модуле CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Настройка пользовательского поля.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Тип поля FIELS_ENTITY_ID Указывается тип дополнительного поля. Возможен выбор из трех вариантов:
  • Лид/контакт;
  • Компания;
  • Сделка.
Дополнительное поле | FIELS_FIELD_ID | Имя переменной, где будет храниться мнемоническое имя поля.
Шаблоны ссылок
URL списка типов | ENTITY_LIST_URL | Указывается страница со списком типов полей.
URL списка полей | FIELDS_LIST_URL | Указывается страница со списком полей.
URL редактирования поля | FIELD_EDIT_URL | Указывается страница редактирования поля.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.config.fields.edit",
    "",
    Array(
        "FIELS_ENTITY_ID" => "CRM_LEAD",
        "FIELS_FIELD_ID" => $_REQUEST["field_id"],
        "ENTITY_LIST_URL" => "field.php",
        "FIELDS_LIST_URL" => "field.list.php?entity_id=#entity_id#",
        "FIELD_EDIT_URL" => "field.edit.php?entity_id=#entity_id#&field_id=#field_id#"
    )
);?>


Настройка связей ролей

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Настройка связей ролей

Настройки::Настройка связей ролей

Описание crm.config.perms.relation

Одностраничный компонент, позволяет настроить связь ролей с группами сотрудников. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Настройка связей ролей.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
URL привязки ролей | PATH_TO_ENTITY_LIST | Указывается страница со списком ролей.
URL редактирования роли | PATH_TO_ROLE_EDIT | Указывается страница редактирования роли.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.config.perms.relation",
    "",
    Array(
        "PATH_TO_ENTITY_LIST" => "perms.php",
        "PATH_TO_ROLE_EDIT" => "role.edit.php?role_id=#role_id#"
    )
);?>


Настройки бизнес-процессов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Настройки бизнес-процессов

Настройки::Настройки бизнес-процессов

Описание crm.config.bp

Позволяет выполнить настройку бизнес-процессов в модуле CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Настройки бизнес-процессов.

Параметры

Поле Параметр Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта): SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • ENTITY_LIST_URL - страница списка типов;
  • BP_LIST_URL - страница списка шаблонов бизнес-процессов;
  • BP_EDIT_URL - страница редактирования шаблона.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
mode - имя переменной идентификатора режима (указывается при выключенном режиме поддержки ЧПУ). entity_id - имя переменной идентификатора типа (указывается при выключенном режиме поддержки ЧПУ). bp_id - имя переменной идентификатора шаблона бизнес-процесса(указывается при выключенном режиме поддержки ЧПУ).
[/di] .

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.config.bp",
    "",
    Array(
        "SEF_MODE" => "Y",
        "SEF_FOLDER" => "/docs/a-new-section-1/",
        "SEF_URL_TEMPLATES" => Array(
            "ENTITY_LIST_URL" => "",
            "BP_LIST_URL" => "#entity_id#/",
            "BP_EDIT_URL" => "#entity_id#/edit/#bp_id#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "BP_LIST_URL" => Array(),
            "BP_EDIT_URL" => Array(),
            "ENTITY_LIST_URL" => Array(),
        )
    )
);?>


Настройки пользовательских полей

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Настройки пользовательских полей

Настройки::Настройки пользовательских полей

Описание crm.config.fields

Позволяет выполнить настройку пользовательских полей в модуле CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Настройки пользовательских полей.

Параметры

Поле Параметр Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта): SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • ENTITY_LIST_URL - страница списка типов;
  • FIELDS_LIST_URL - страница списка полей;
  • FIELD_EDIT_URL - страница редактирования поля.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
mode - имя переменной идентификатора режима (указывается при выключенном режиме поддержки ЧПУ). entity_id - имя переменной идентификатора типа (указывается при выключенном режиме поддержки ЧПУ). field_id - имя переменной идентификатора поля(указывается при выключенном режиме поддержки ЧПУ).
[/di] .

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.config.fields",
    "",
    Array(
        "SEF_MODE" => "Y",
        "SEF_FOLDER" => "/crm/configs/sendsave/",
        "SEF_URL_TEMPLATES" => Array(
            "ENTITY_LIST_URL" => "",
            "FIELDS_LIST_URL" => "#entity_id#/",
            "FIELD_EDIT_URL" => "#entity_id#/edit/#field_id#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "list" => Array(),
            "edit" => Array(),
            "show" => Array(),
            "convert" => Array(),
            "import" => Array(),
            "service" => Array(),
            "FIELDS_LIST_URL" => Array(),
            "FIELD_EDIT_URL" => Array(),
            "ENTITY_LIST_URL" => Array(),
        )
    )
);?>


Настройки прав доступа (комплексный компонент)

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Настройки прав доступа (комплексный компонент)

Настройки::Настройки прав доступа (комплексный компонент)

Описание crm.config.perms

Комплексный компонент, позволяет выполнить настройку прав доступа к модулю CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Настройки прав доступа.

Параметры

Поле Параметр Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта): SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • PATH_TO_ENTITY_LIST - страница привязки ролей;
  • PATH_TO_ROLE_EDIT - страница редактирования роли.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
mode - имя переменной идентификатора режима (указывается при выключенном режиме поддержки ЧПУ). role_id - имя переменной идентификатора роли (указывается при выключенном режиме поддержки ЧПУ).
[/di]

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.config.perms",
    "",
    Array(
        "SEF_MODE" => "Y",
        "SEF_FOLDER" => "/crm/configs/sendsave/",
        "SEF_URL_TEMPLATES" => Array(
            "PATH_TO_ENTITY_LIST" => "",
            "PATH_TO_ROLE_EDIT" => "#role_id#/edit/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "list" => Array(),
            "edit" => Array(),
            "show" => Array(),
            "convert" => Array(),
            "import" => Array(),
            "service" => Array(),
            "FIELDS_LIST_URL" => Array(),
            "FIELD_EDIT_URL" => Array(),
            "ENTITY_LIST_URL" => Array(),
            "PATH_TO_ROLE_EDIT" => Array(),
            "PATH_TO_ENTITY_LIST" => Array(),
        )
    )
);?>


Настройки шаблонов реквизитов клиентов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Настройки шаблонов реквизитов клиентов

Настройки::Настройки шаблонов реквизитов клиентов

Описание crm.config.preset

Одностраничный компонент, позволяет настроить шаблоны реквизитов клиентов модуля CRM.. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Настройки шаблонов реквизитов клиентов.

Параметры

Поле Параметр Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта): SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • страница списка шаблонов реквизитов клиентов;
  • страница списка неиспользуемых пользовательских полей.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
  • mode - режим;
  • entity_type - идентификатор типа;
  • preset_id - идентификатор шаблона.
[/di] .

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.config.preset",
    "",
    Array(
        "SEF_MODE" => "N",
        "VARIABLE_ALIASES" => Array("entity_type"=>"entity_type","mode"=>"mode","preset_id"=>"preset_id")
    )
);?>


Редактирование роли

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Редактирование роли

Настройки::Редактирование роли

Описание crm.config.perms.role.edit

Одностраничный компонент, позволяет выполнить настройку прав доступа роли к сущностям CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Редактирование роли.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
URL привязки ролей | PATH_TO_ENTITY_LIST | Указывается страница со списком ролей.
URL редактирования роли | PATH_TO_ROLE_EDIT | Указывается страница редактирования роли.
Дополнительные настройки
Идентификатор роли | ROLE_ID | Указывается идентификатор роли.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.config.perms.role.edit",
    "",
    Array(
        "ROLE_ID" => $_REQUEST["role_id"],
        "PATH_TO_ENTITY_LIST" => "perms.php",
        "PATH_TO_ROLE_EDIT" => "role.edit.php?role_id=#role_id#"
    )
);?>

Описание параметров

© «Битрикс», 2001-2008, «1C-Битрикс», 2008-2022 1С-Битрикс: Управление сайтом


Редактирование шаблона бизнес-процесса

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Редактирование шаблона бизнес-процесса

Настройки::Редактирование шаблона бизнес-процесса

Описание crm.config.bp.edit

Одностраничный компонент, позволяет отредактировать шаблон бизнес-процесса модуля CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Редактирование шаблона бизнес-процесса.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
URL списка типов | ENTITY_LIST_URL | Указывается страница со списком типов шаблонов бизнес-процессов.
URL списка шаблонов | BP_LIST_URL | Указывается страница со списком шаблонов бизнес-процессов.
URL редактирования шаблона | BP_EDIT_URL | Указывается страница редактирования шаблона бизнес-процесса.
Дополнительные настройки
Тип шаблона | BP_ENTITY_ID | Указывается тип шаблона бизнес-процесса.
Идентификатор шаблона | BP_BP_ID | Указывается идентификатор шаблона.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.config.bp.edit",
    "",
    Array(
        "BP_ENTITY_ID" => $_REQUEST["entity_id"],
        "BP_BP_ID" => $_REQUEST["bp_id"],
        "ENTITY_LIST_URL" => "bp.php",
        "BP_LIST_URL" => "bp.list.php?entity_id=#entity_id#",
        "BP_EDIT_URL" => "bp.edit.php?entity_id=#entity_id#&bp_id=#bp_id#"
    )
);?>


Связь с магазином (комплексный компонент)

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Связь с магазином (комплексный компонент)

Настройки::Связь с магазином (комплексный компонент)

Описание crm.config.external_sale

Комплексный компонент, позволяет выполнить настройку интеграции CRM с интернет-магазином. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Связь с магазином.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта): SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - страница со списком интернет-магазинов;
  • edit - страница редактирования интеграции с интернет-магазином;
  • sync - страница запуска импорта из интернет-магазина.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.config.external_sale",
    "",
    Array(
        "SEF_MODE" => "Y",
        "AJAX_MODE" => "Y",
        "SEF_FOLDER" => "/docs/a-new-section-1/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "edit" => "edit-#id#.php",
            "sync" => "sync-#id#.php"
        ),
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y",
        "AJAX_OPTION_ADDITIONAL" => "",
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "edit" => Array(),
            "sync" => Array(),
        )
    )
);?>


Список бизнес-процессов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Список бизнес-процессов

Настройки::Список бизнес-процессов

Описание crm.config.bp.list

Одностраничный компонент, выводит список бизнес-процессов модуля CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Список бизнес-процессов.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
URL списка типов | ENTITY_LIST_URL | Указывается страница со списком типов шаблонов бизнес-процессов.
URL списка шаблонов | BP_LIST_URL | Указывается страница со списком шаблонов бизнес-процессов.
URL редактирования шаблона | BP_EDIT_URL | Указывается страница редактирования шаблона бизнес-процесса.
Дополнительные настройки
Тип шаблона | BP_ENTITY_ID | Указывается тип шаблона бизнес-процесса.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.config.bp.list",
    "",
    Array(
        "BP_ENTITY_ID" => $_REQUEST["entity_id"],
        "ENTITY_LIST_URL" => "bp.php",
        "BP_LIST_URL" => "bp.list.php?entity_id=#entity_id#",
        "BP_EDIT_URL" => "bp.edit.php?entity_id=#entity_id#&bp_id=#bp_id#"
    )
);?>


Список неиспользуемых пользовательских полей

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Список неиспользуемых пользовательских полей

Настройки::Список неиспользуемых пользовательских полей

Описание crm.config.preset.ufields

Одностраничный компонент, выводит список пользовательских полей, которые не используются в шаблонах. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Список неиспользуемых пользовательских полей.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
URL списка шаблонов | PRESENT_LIST_URL | Указывается страница со списком шаблонов.
URL списка неиспользуемых пользовательских полей | PRESENT_UFIELDS_URL | Указывается страница со списком неиспользуемых пользовательских полей.
Дополнительные настройки
Тип для шаблонов | ENTITY_TYPE_ID | Выбирается тип для шаблонов (по умолчанию тип Реквизиты).

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.config.preset.ufields",
    "",
    Array(
        "ENTITY_TYPE_ID" => "8",
        "PRESET_LIST_URL" => "list.php?entity_type=#entity_type#",
        "PRESET_UFIELDS_URL" => "ufields.php?entity_type=#entity_type#"
    )
);?>


Список пользовательских полей

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Список пользовательских полей

Настройки::Список пользовательских полей

Описание crm.config.fields.list

Одностраничный компонент, выводит список пользовательских полей модуля CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Список пользовательских полей.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Тип полей FIELS_ENTITY_ID Указывается тип дополнительных полей. Возможен выбор из трех вариантов:
  • Лид/контакт;
  • Компания;
  • Сделка.
Шаблоны ссылок
URL списка типов | ENTITY_LIST_URL | Указывается страница со списком типов полей.
URL списка полей | FIELDS_LIST_URL | Указывается страница со списком полей.
URL редактирования поля | FIELD_EDIT_URL | Указывается страница редактирования поля.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.config.fields.list",
    "",
    Array(
        "FIELS_ENTITY_ID" => "CRM_LEAD",
        "ENTITY_LIST_URL" => "field.php",
        "FIELDS_LIST_URL" => "field.list.php?entity_id=#entity_id#",
        "FIELD_EDIT_URL" => "field.edit.php?entity_id=#entity_id#&field_id=#field_id#"
    )
);?>


Список типов пользовательских полей

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Список типов пользовательских полей

Настройки::Список типов пользовательских полей

Описание crm.config.fields.types

Одностраничный компонент, выводит список типов пользовательских полей модуля CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Список типов пользовательских полей.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
URL списка полей | FIELDS_LIST_URL | Указывается страница со списком полей.
URL редактирования поля | FIELD_EDIT_URL | Указывается страница редактирования поля.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.config.fields.types",
    "",
    Array(
        "FIELDS_LIST_URL" => "field.list.php?entity_id=#entity_id#",
        "FIELD_EDIT_URL" => "field.edit.php?entity_id=#entity_id#&field_id=#field_id#"
    )
);?>


Список типов шаблонов бизнес-процессов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Список типов шаблонов бизнес-процессов

Настройки::Список типов шаблонов бизнес-процессов

Описание crm.config.bp.types

Одностраничный компонент, выводит список типов шаблонов бизнес-процессов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Список типов шаблонов бизнес-процессов.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
URL списка шаблонов | BP_LIST_URL | Указывается страница со списком шаблонов бизнес-процессов.
URL редактирования шаблона | BP_EDIT_URL | Указывается страница редактирования шаблона.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.config.bp.types",
    "",
    Array(
        "BP_LIST_URL" => "bp.list.php?entity_id=#entity_id#",
        "BP_EDIT_URL" => "bp.edit.php?entity_id=#entity_id#&bp_id=#bp_id#"
    )
);?>


Список шаблонов реквизитов клиентов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Настройки>Список шаблонов реквизитов клиентов

Настройки::Список шаблонов реквизитов клиентов

Описание crm.config.preset.list

Одностраничный компонент, выводит выводит список шаблонов реквизитов клиентов модуля CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Настройки > Список шаблонов реквизитов клиентов.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
URL списка шаблонов | PRESENT_LIST_URL | Указывается страница со списком шаблонов.
URL списка неиспользуемых пользовательских полей | PRESENT_UFIELDS_URL | Указывается страница со списком неиспользуемых пользовательских полей.
Дополнительные настройки
Тип для шаблонов | ENTITY_TYPE_ID | Выбирается тип для шаблонов (по умолчанию тип Реквизиты).

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.config.preset.list",
    "",
    Array(
        "ENTITY_TYPE_ID" => "8",
        "PRESET_LIST_URL" => "list.php?entity_type=#entity_type#",
        "PRESET_UFIELDS_URL" => "ufields.php?entity_type=#entity_type#"
    )
);?>


Предложения

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Предложения (комплексный компонент) | crm.quote | Позволяет работать с предложениями.
Список предложений | crm.quote.list | Выводит список предложений.
Редактирование предложения | crm.quote.edit | Позволяет добавлять новое, или редактировать параметры существующего предложения.
Просмотр предложения | crm.quote.show | Выводит детальное описание предложения.
Панель инструментов | crm.quote.menu | Позволяет настроить контентное меню сущности.
Просмотр счета в формате HTML/PDF* | crm.quote.payment | Позволяет просмотреть счет в формате HTML/PDF.

* отмечены системные компоненты (не описываются)


Предложения (комплексный компонент)

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Предложения>Предложения (комплексный компонент)

Предложения::Предложения (комплексный компонент)

Описание crm.quote

Комплексный компонент позволяет работать с предложениями. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Предложения > Предложения.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта): SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - основная страница;
  • list - страница списка предложений;
  • edit - страница редактирования предложения;
  • show - страница детального просмотра предложения;
  • import - страница импорта.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
quote_id - имя переменной идентификатора предложения (указывается при выключенном режиме поддержки ЧПУ).
[/di] .
Основные параметры
ID предложения | ELEMENT_ID | Поле содержит код, в котором передается идентификатор предложения.
Дополнительные настройки
Формат имени | NAME_TEMPLATE | Выбирается формат отображения имени.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.quote",
    "",
    Array(
        "SEF_MODE" => "Y",
        "ELEMENT_ID" => $_REQUEST["quote_id"],
        "NAME_TEMPLATE" => "#LAST_NAME#, #NAME_SHORT#",
        "SEF_FOLDER" => "/docs/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "list" => "list/",
            "edit" => "edit/#quote_id#/",
            "show" => "show/#quote_id#/",
            "import" => "import/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "list" => Array(),
            "edit" => Array(),
            "show" => Array(),
            "import" => Array(),
        )
    )
);?>


Список предложений

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Предложения>Список предложений

Предложения::Список предложений

Описание crm.quote.list

Одностраничный компонент выводит список предложений. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Предложения > Список предложений.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество предложений на странице | QUOTE_COUNT | Число выводимых на одну страницу предложений.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.quote.list",
    "",
    Array(
        "QUOTE_COUNT" => "20"
    )
);?>


Редактирование предложения

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Предложения>Редактирование предложения

Предложения::Редактирование предложения

Описание crm.quote.edit

Одностраничный компонент, позволяет добавлять новое, или редактировать параметры существующего предложения. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Предложения > Редактирование предложения.

Параметры

Поле | Параметр | Описание
Основные параметры
ID предложения | ELEMENT_ID | Поле содержит код, в котором передается идентификатор предложения.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.quote.edit",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["quote_id"]
    )
);?>


Просмотр предложения

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Предложения>Просмотр предложения

Предложения::Просмотр предложения

Описание crm.quote.show

Одностраничный компонент, осуществляющий вывод детального описания предложения. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Предложения > Просмотр предложения.

Параметры

Поле | Параметр | Описание
Основные параметры
ID предложения | ELEMENT_ID | Поле содержит код, в котором передается идентификатор предложения.

Пример вызова

<?$
APPLICATION->IncludeComponent(
"bitrix:crm.quote.show",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["quote_id"]
    )
);?>


Панель инструментов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Предложения>Панель инструментов

Предложения::Панель инструментов

Описание crm.quote.menu

Одностраничный компонент, позволяет настроить контентное меню сущности.

В визуальном редакторе компонент расположен по пути CRM > Предложения > Панель инструментов.

Параметры

Поле | Параметр | Описание
Основные параметры
ID предложения | ELEMENT_ID | Поле содержит код, в котором передается идентификатор предложения.
Вид отображения меню TYPE Выбирается функционал для представления в контентном меню. Возможны три варианта:
  • LIST;
  • SHOW;
  • EDIT.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.quote.menu",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["quote_id"],
        "TYPE" => "list"
    )
);?>


Реквизиты

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Список реквизитов | crm.requisite.list | Выводит список реквизитов компании.
Панель инструментов | crm.requisite.menu | Выводит панель инструментов.


Панель инструментов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Реквизиты>Панель инструментов

Реквизиты::Панель инструментов

Описание crm.requisite.menu

Компонент выводит панель инструментов.

В визуальном редакторе компонент находится в Компоненты > CRM > Реквизиты > Панель инструментов.

Параметры

Поле | Параметр | Описание
Основные параметры
ID реквизитов | ELEMENT_ID | Поле содержит код, в котором передается идентификатор реквизитов.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.requisite.menu",
    "",
Array(),
false
);?>


Список реквизитов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Реквизиты>Список реквизитов

Реквизиты::Список реквизитов

Описание crm.requisite.list

Компонент выводит список реквизитов компании.

В визуальном редакторе компонент находится в Компоненты > CRM > Реквизиты > Список реквизитов.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество реквизитов на странице | REQUISITE_COUNT | Указывается число реквизитов, отображаемых на одной странице.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.requisite.list",
    "",
Array()
);?>


Сделки

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Сделки (комплексный компонент) | crm.deal | Позволяет работать со сделками.
Воронка продаж | crm.deal.funnel | Выводит количественное соотношение сделок на разных стадиях выполнения.
Список сделок | deal.list | Выводит список сделок.
Редактирование сделки | crm.deal.edit | Позволяет создать новую, либо редактировать существующую сделку.
Просмотр сделки | crm.deal.show | Осуществляет вывод детального описания сделки.
Панель инструментов | crm.deal.menu | Позволяет настроить верхнее меню сущности.
Импорт сделок* | crm.deal.import | Предназначен для импорта сделок в модуле CRM.

* отмечены системные компоненты (не описываются)


Воронка продаж

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Сделки>Воронка продаж

Сделки::Воронка продаж

Описание crm.deal.funnel

Одностраничный компонент, выводит количественное соотношение сделок на разных стадиях выполнения. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Сделки > Воронка продаж.

Параметры

Поле | Параметр | Описание
Основные параметры
Отключить компенсацию стадий | DISABLE_COMPENSATION | При отмеченной опции каждая нижележащая стадия воронки продаж не будет включать в себя предыдущие.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.deal.funnel",
    "",
    Array(
        "DISABLE_COMPENSATION" => "Y"
    )

);?>


Панель инструментов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Сделки>Панель инструментов

Сделки::Панель инструментов

Описание crm.deal.menu

Одностраничный компонент, позволяет настроить контентное меню сущности.

В визуальном редакторе компонент расположен по пути CRM > Сделки > Панель инструментов.

Параметры

Поле | Параметр | Описание
Основные параметры
ID сделки | ELEMENT_ID | Поле содержит код, в котором передается идентификатор сделки.
Вид отображения меню TYPE Выбирается функционал для представления в контентном меню. Возможны три варианта:
  • LIST - выводятся кнопки Список сделок, Добавить сделку;
  • SHOW - выводятся кнопки Список сделок, Добавить сделку;
  • EDIT - выводятся кнопки Список сделок, Добавить сделку.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.deal.menu",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["deal_id"],
        "TYPE" => "page"
    )
);?>


Просмотр сделки

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Сделки>Просмотр сделки

Сделки::Просмотр сделки

Описание crm.deal.show

Одностраничный компонент, осуществляющий вывод детального описания сделки. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Сделки > Просмотр сделки.

Параметры

Поле | Параметр | Описание
Основные параметры
ID сделки | ELEMENT_ID | Поле содержит код, в котором передается идентификатор сделки.

Пример вызова

<?$
APPLICATION->IncludeComponent(
"bitrix:crm.deal.show",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["deal_id"]
    )
);?>


Редактирование сделки

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Сделки>Редактирование сделки

Сделки::Редактирование сделки

Описание crm.deal.edit

Одностраничный компонент, позволяет добавлять новую, или редактировать параметры существующей сделки. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Сделки > Редактирование сделки.

Параметры

Поле | Параметр | Описание
Основные параметры
ID сделки | ELEMENT_ID | Поле содержит код, в котором передается идентификатор сделки.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.deal.edit",
    ".default",
    Array(
        "ELEMENT_ID" => $_REQUEST["deal_id"]
    )
);?>


Сделки (комплексный компонент)

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Сделки>Сделки (комплексный компонент)

Сделки::Сделки (комплексный компонент)

Описание crm.deal

Комплексный компонент позволяет работать со сделками. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Сделки > Сделки.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта): SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - основная страница;
  • list - страница списка сделок;
  • funnel - страница воронки продаж;
  • edit - страница редактирования сделки;
  • show - страница детального просмотра сделки;
  • import - страница импорта.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
deal_id - имя переменной идентификатора сделки (указывается при выключенном режиме поддержки ЧПУ).
[/di] .
Основные параметры
ID сделки | ELEMENT_ID | Поле содержит код, в котором передается идентификатор сделки.
Дополнительные настройки
Формат имени | NAME_TEMPLATE | Выбирается формат отображения имени.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.deal",
    "",
    Array(
        "SEF_MODE" => "Y",
        "ELEMENT_ID" => $_REQUEST["deal_id"],
        "NAME_TEMPLATE" => "",
        "SEF_FOLDER" => "/docs/a-new-section-1/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "list" => "list/",
            "funnel" => "funnel/",
            "edit" => "edit/#deal_id#/",
            "show" => "show/#deal_id#/",
            "import" => "import/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "report" => Array(),
            "construct" => Array(),
            "show" => Array(),
            "list" => Array(),
            "edit" => Array(),
            "import" => Array(),
            "service" => Array(),
            "convert" => Array(),
            "BP_LIST_URL" => Array(),
            "BP_EDIT_URL" => Array(),
            "ENTITY_LIST_URL" => Array(),
            "FIELDS_LIST_URL" => Array(),
            "FIELD_EDIT_URL" => Array(),
            "PATH_TO_ROLE_EDIT" => Array(),
            "PATH_TO_ENTITY_LIST" => Array(),
            "sync" => Array(),
            "funnel" => Array(),
        )
    )
);?>


Список сделок

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Сделки>Список сделок

Сделки::Список сделок

Описание crm.deal.list

Одностраничный компонент выводит список сделок. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Сделки > Список сделок.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество сделок на странице | DEAL_COUNT | Число выводимых на одну страницу сделок.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.deal.list",
    "",
    Array(
        "DEAL_COUNT" => "20"
    )
);?>


Счета

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Счета (комплексный компонент) | crm.invoice | Позволяет работать со счетами в CRM.
Список счетов | crm.invoice.list | Выводит список счетов.
Редактирование счёта | crm.invoice.edit | Позволяет добавлять новый счёт, или редактировать параметры имеющегося.
Просмотр счёта | crm.invoice.show | Осуществляет вывод детального описания счёта.
Панель инструментов | crm.invoice.menu | Позволяет настроить контентное меню сущности.
Просмотр счёта в формате HTML/PDF* | crm.invoice.payment | Предназначен для просмотра счёта в формате HTML/PDF в модуле CRM.

* отмечены системные компоненты (не описываются)


Счета (комплексный компонент)

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Счета>Счета (комплексный компонент)

Счета::Счета (комплексный компонент)

Описание crm.invoice

Комплексный компонент, позволяет работать со счетами в CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Счета > Счета.

Параметры

Поле | Параметр | Описание
Основные параметры
ID счёта | ELEMENT_ID | Поле содержит код, в котором передается идентификатор счета.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта): SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - основная страница;
  • list - страница списка счетов;
  • edit - страница редактирования счёта;
  • show - страница просмотра счёта;
  • service - страница Веб-сервиса;
  • payment - страница оплаты счёта.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
invoice_id - имя переменной идентификатора счёта (указывается при выключенном режиме поддержки ЧПУ).
[/di] .
Дополнительные настройки
Формат имени | NAME_TEMPLATE | Выбирается формат отображения имени.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.invoice",
    "",
    Array(
        "SEF_MODE" => "Y",
        "ELEMENT_ID" => $_REQUEST["invoice_id"],
        "NAME_TEMPLATE" => "",
        "SEF_FOLDER" => "/crm/invoice/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "list" => "list/",
            "edit" => "edit/#invoice_id#/",
            "show" => "show/#invoice_id#/",
            "payment" => "payment/#invoice_id#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "list" => Array(),
            "edit" => Array(),
            "show" => Array(),
            "payment" => Array(),
        )
    )
);?>


Список счетов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Счета>Список счетов

Счета::Список счетов

Описание crm.invoice.list

Одностраничный компонент выводит список счетов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Счета > Список счетов.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество счетов на странице | DEAL_COUNT | Число выводимых на одну страницу счетов.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.invoice.list",
    "",
    Array(
        "DEAL_COUNT" => "20"
    )
);?>


Редактирование счёта

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Счета>Редактирование счёта

Счета::Редактирование счёта

Описание crm.invoice.edit

Одностраничный компонент, позволяет добавлять новый, или редактировать параметры имеющегося счёта. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Счета > Редактирование счёта.

Параметры

Поле | Параметр | Описание
Основные параметры
ID счёта | ELEMENT_ID | Поле содержит код, в котором передается идентификатор счёта.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.invoice.edit",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["invoice_id"]
    )
);?>


Просмотр счёта

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Счета>Просмотр счёта

Счета::Просмотр счёта

Описание crm.invoice.show

Одностраничный компонент, осуществляющий вывод детального описания счёта. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Счета > Просмотр счёта.

Параметры

Поле | Параметр | Описание
Основные параметры
ID счёта | ELEMENT_ID | Поле содержит код, в котором передается идентификатор счёта.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.invoice.show",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["invoice_id"]
    )
);?>


Панель инструментов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Счета>Панель инструментов

Счета::Панель инструментов

Описание crm.invoice.menu

Одностраничный компонент, позволяет настроить контентное меню сущности.

В визуальном редакторе компонент расположен по пути CRM > Счета > Панель инструментов.

Параметры

Поле | Параметр | Описание
Основные параметры
ID счёта | ELEMENT_ID | Поле содержит код, в котором передается идентификатор счёта.
Вид отображения меню TYPE Выбирается функционал для представления в контентном меню. Возможны три варианта:
  • LIST;
  • SHOW;
  • EDIT.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.invoice.menu",
    "",
    Array(
        "ELEMENT_ID" => $_REQUEST["invoice_id"],
        "TYPE" => "list"
    )
);?>


Товары

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Товары | crm.product | Необходим для управления товарами сделок CRM.
Список товаров | crm.product.list | Используется для вывода списка товаров системы CRM.
Редактирование товара | crm.product.edit | Позволяет редактировать существующий, либо добавлять новый товар.
Просмотр товара | crm.product.show | Необходим для просмотра детального описания товара.
Список разделов | crm.product.section | Нужен для управления списком разделов выбранного каталога.
Туллбар | crm.product.menu | Позволяет настроить контентное меню для работы с каталогами и товарами.
Импорт товаров* | crm.product.import | Предназначен для импорта товаров в модуле CRM.

* отмечены системные компоненты (не описываются)


Товары

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Товары>Товары

Товары::Товары

Описание crm.product

Компонент необходим для управления товарами сделок CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Товары > Товары.

Параметры

Поле | Параметр | Описание
Основные параметры
Торговый каталог | CATALOG_ID | Указывается каталог, товары которого будут показаны.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта): SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - основная страница;
  • product_list - страница списка товаров;
  • product_edit - страница редактирования товара;
  • product_show - страница просмотра товара;
  • section_list - страница списка разделов.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами:
  • product_id - имя переменной идентификатора товара(указывается при выключенном режиме поддержки ЧПУ);
  • section_id - имя переменной идентификатора раздела (указывается при выключенном режиме поддержки ЧПУ).
[/di] .

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.product",
    "",
    Array(
        "CATALOG_ID" => "34",
        "SEF_MODE" => "Y",
        "SEF_FOLDER" => "/docs/a-new-section-1/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "product_list" => "product_list/#section_id#/",
            "product_edit" => "product_edit/#product_id#/",
            "product_show" => "product_show/#product_id#/",
            "section_list" => "section_list/#section_id#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "product_list" => Array(),
            "product_edit" => Array(),
            "product_show" => Array(),
            "section_list" => Array(),
        )
    )
);?>


Список товаров

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Товары>Список товаров

Товары::Список товаров

Описание crm.product.list

Одностраничный компонент, необходим для вывода списка товаров системы CRM. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Товары > Список товаров.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество товаров на странице по умолчанию | PRODUCT_COUNT | Указывается максимальное число выводимых на одной странице товаров.
Торговый каталог | CATALOG_ID | Указывается каталог, товары которого будут показаны.
Раздел | SECTION_ID | При наличии таковой выбирается секция указанного торгового каталога.
Шаблон пути к странице списка товаров | PATH_TO_PRODUCT_LIST | Указывается путь к странице с перечнем товаров.
Шаблон пути к странице просмотра товара | PATH_TO_PRODUCT_SHOW | Указывается путь к странице детального просмотра товара.
Шаблон пути к странице редактирования товара | PATH_TO_PRODUCT_EDIT | Указывается путь к странице редактирования товара.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.product.list",
    "",
    Array(
        "PRODUCT_COUNT" => "20",
        "CATALOG_ID" => "33",
        "SECTION_ID" => "0",
        "PATH_TO_PRODUCT_LIST" => "?section_id=#section_id#",
        "PATH_TO_PRODUCT_SHOW" => "?product_id=#product_id#&show",
        "PATH_TO_PRODUCT_EDIT" => "?product_id=#product_id#&edit"
    )
);?>


Редактирование товара

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Товары>Редактирование товара

Товары::Редактирование товара

Описание crm.product.edit

Одностраничный компонент, необходим для редактирования существующего, либо добавления нового товара. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Товары > Редактирование товара.

Параметры

Поле | Параметр | Описание
Основные параметры
Торговый каталог | CATALOG_ID | Указывается каталог, товары которого будут показаны на странице.
Идентификатор товара | PRODUCT_ID | Указывается идентификатор товара.
Имя переменной идентификатора товара | PRODUCT_ID_PARAM | Указывается имя переменной, в которой будет содержаться идентификатор товара.
Шаблон пути к странице списка товаров | PATH_TO_PRODUCT_LIST | Указывается путь к странице с перечнем товаров выбранного каталога.
Шаблон пути к странице просмотра товара | PATH_TO_PRODUCT_SHOW | Указывается путь к странице детального просмотра товара.
Шаблон пути к странице редактирования товара | PATH_TO_PRODUCT_EDIT | Указывается путь к странице редактирования товара.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.product.edit",
    "",
    Array(
        "CATALOG_ID" => "33",
        "PRODUCT_ID" => "",
        "PRODUCT_ID_PARAM" => "product_id",
        "PATH_TO_PRODUCT_LIST" => "",
        "PATH_TO_PRODUCT_SHOW" => "?product_id=#product_id#&show",
        "PATH_TO_PRODUCT_EDIT" => "?product_id=#product_id#&edit"
    )
);?>


Просмотр товара

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Товары>Просмотр товара

Товары::Просмотр товара

Описание crm.product.show

Одностраничный компонент, необходим для просмотра детального описания товара. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Товары > Просмотр товара.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор товара | PRODUCT_ID | Указывается идентификатор товара.
Имя переменной идентификатора товара | PRODUCT_ID_PARAM | Указывается имя переменной, в которой будет содержаться идентификатор товара.
Шаблон пути к странице списка товаров | PATH_TO_PRODUCT_LIST | Указывается путь к странице с перечнем товаров выбранного каталога.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:crm.product.show",
    "",
    Array(
        "PRODUCT_ID" => "12",
        "PRODUCT_ID_PARAM" => "product_id",
        "PATH_TO_PRODUCT_LIST" => ""
    )
);?>


Список разделов

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Товары>Список разделов

Товары::Список разделов

Описание crm.product.section.list

Одностраничный компонент, необходим для управления списком разделов выбранного каталога. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Товары > Список разделов.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество разделов на странице по умолчанию | SECTION_COUNT | Максимальное число выводимых на одну страницу разделов.
Торговый каталог | CATALOG_ID | Указывается каталог, разделы которого будут показаны на странице.
Раздел | SECTION_ID | Указывается раздел, входящие разделы которого следует вывести. В случае, если оставить данный параметр неуказанным, то будут показаны разделы первого уровня.
Имя переменной идентификатора раздела | SECTION_ID_PARAM | Указывается имя переменной, в которой будет содержаться идентификатор раздела.
Шаблон пути к странице списка разделов | PATH_TO_SECTION_LIST | Указывается путь к странице с перечнем разделов выбранного каталога.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.product.section.list",
    "",
    Array(
        "SECTION_COUNT" => "20",
        "CATALOG_ID" => "33",
        "SECTION_ID" => "",
        "SECTION_ID_PARAM" => "section_id",
        "PATH_TO_SECTION_LIST" => "?section_id=#section_id#§ions"
    )
);?>


Туллбар

Отправить отзыв по этому разделу
Компоненты>CRM (КП)>Товары>Туллбар

Товары::Туллбар

Описание crm.product.menu

Одностраничный компонент, позволяет настроить контентное меню для работы с каталогами и товарами. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути CRM > Товары > Туллбар.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип | TYPE | Выбирается вид контентного меню. Виды характеризуются функционалом набора кнопок.
Идентификатор раздела | SECTION_ID | Указывается идентификатор раздела.
Идентификатор товара | PRODUCT_ID | Указывается идентификатор товара.
Шаблон пути к странице списка товаров | PATH_TO_PRODUCT_LIST | Указывается путь к странице с перечнем товаров выбранного раздела.
Шаблон пути к странице просмотра товара | PATH_TO_PRODUCT_SHOW | Указывается путь к странице детального просмотра товара.
Шаблон пути к странице редактирования товара | PATH_TO_PRODUCT_EDIT | Указывается путь к странице редактирования товара.
Шаблон пути к странице списка разделов | PATH_TO_SECTION_LIST | Указывается путь к странице списка разделов.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:crm.product.menu",
    "",
    Array(
        "TYPE" => "list",
        "SECTION_ID" => "",
        "PRODUCT_ID" => "",
        "PATH_TO_PRODUCT_LIST" => "?section_id=#section_id#",
        "PATH_TO_PRODUCT_SHOW" => "?product_id=#product_id#&show",
        "PATH_TO_PRODUCT_EDIT" => "?product_id=#product_id#&edit",
        "PATH_TO_SECTION_LIST" => "?section_id=#section_id#§ions"
    )
);?>


Корпоративный портал (КП)

Модуль предназначен для управления задачами и поручениями, организации коллективных событий, резервирования переговорных и ресурсов, работы с электронными заявками.

Модуль используется для выполнения простого и расширенного поиска по базе сотрудников, отображения кадровых изменений, происходящих в компании, автоматического построения графика отсутствия сотрудников, организации доски почета, мониторинга дней рождения сотрудников, создания календарей событий с возможностью взаимной интеграции, импорта пользователей из "1С:Зарплата и управление Персоналом".

Настройки модуля описаны здесь.

Модуль относится только к "Битрикс24 в коробке".

Модуль включает в себя следующие компоненты 2.0:
Сущности модуля
Название | Имя в пространстве имен bitrix | Описание
Подразделы
HR | intranet | Предназначен для контроля рабочего процесса сотрудников.
Бронирование переговорных | intranet.reserve_meeting | Служит для создания, поиска и бронирования переговорных.
Оргструктура | intranet.structure | Выводит в разных визуальных представлениях списки сотрудников в соответствии с заданным фильтром.
Собрания и планерки | meetings | Служит для управления собраниями.
Учет рабочего времени | faceid | Позволяет организовать контроль за использованием рабочего времени сотрудниками компании и учет поставленных в план и выполненных ими задач.
Компоненты
Руководство подразделениями | intranet.structure.head.user | Выводит список подразделений, руководителем которых является сотрудник.


Руководство подразделениями

Описание intranet.structure.head.user

Компонент выводит список подразделений, руководителем которых является сотрудник. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор пользователя | ID | Параметр содержит код, в котором передается идентификатор пользователя.
Шаблон ссылки на подразделение | DETAIL_URL | Указывается шаблон ссылки на подразделение компании.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.structure.head.user","",Array(
        "ID" => $USER->GetID(),
        "DETAIL_URL" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    ),
);?>


HR

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Календарь отсутствий | intranet.absence.calendar | Выводит график отсутствий сотрудников в виде календаря.
Отсутствия пользователя | intranet.absence.user | Выводит график отсутствий конкретного пользователя.
Отсутствующие сотрудники | intranet.structure.informer.absent | Выводит краткий список отсутствующих сотрудников.
Доска почета | intranet.structure.honour | Выводит список почетных сотрудников компании.
Доска почета пользователя | intranet.structure.honour.user | Выводит историю присутствия пользователя на доске почета.
Кадровые изменения | intranet.structure.events | Выводит список последних кадровых перестановок в компании.
Новые сотрудники | intranet.structure.informer.new | Выводит краткий список новых сотрудников компании.
Дни рождения | intranet.structure.birthday.nearest | Выводит список ближайших именинников офиса, отдела или филиала компании.


Календарь отсутствий

Описание intranet.absence.calendar

Компонент выводит график отсутствий сотрудников в виде календаря. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > HR.

Параметры

Поле | Параметр | Описание
Основные параметры
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Начальное представление VIEW_START Указывается закладка календаря графика отсутствий, которая будет открыта при обращении к графику:
  • день (day);
  • неделя (week);
  • месяц (month).
Отображаемые элементы управления FILTER_CONTROLS Указываются элементы, которые будут отображены на панели управления графиком отсутствий:
  • переход к дате (DATEPICKER);
  • типы отсутствий (TYPEFILTER);
  • только отсутствующие (SHOW_ALL);
  • подразделения (DEPARTMENT).
Первый день недели | FIRST_DAY | Указывается первый день недели.
Начало рабочего дня (час) | DAY_START | Указывается время (час) начала рабочего дня.
Конец рабочего дня (час) | DAY_FINISH | Указывается время (час) окончания рабочего дня.
Показывать нерабочее время в дневном представлении | DAY_SHOW_NONWORK | [Y|N] При отмеченной опции нерабочее время будет показано в дневном представлении.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты/времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.absence.calendar","",Array(
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "VIEW_START" => "month",
        "FILTER_CONTROLS" => Array("DATEPICKER", "TYPEFILTER", "DEPARTMENT"),
        "FIRST_DAY" => "1",
        "DAY_START" => "9",
        "DAY_FINISH" => "18",
        "DAY_SHOW_NONWORK" => "Y"
        "DATE_FORMAT" => "d.m.Y",
        "DATETIME_FORMAT" => "d.m.Y H:i:s"
    ),
);?>


Отсутствующие сотрудники

Описание intranet.structure.informer.absent

Компонент выводит краткий список отсутствующих сотрудников. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > HR.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество выводимых записей | NUM_USERS | Указывается количество выводимых записей.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается шаблон пути к странице подразделения компании.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение Y, то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты и времени, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Отдел/офис | DEPARTMENT | Указывается офис, филиал или отдел, краткий список отсутствующих сотрудников которого будет отображен.
Показывать год рождения SHOW_YEAR Поле определяет кому показываеть год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.structure.informer.absent","",Array(
        "NUM_USERS" => "10",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "DEPARTMENT" => "156",
        "PM_URL" => "/company/personal/messages/chat/#USER_ID#/",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_YEAR" => "Y",
        "AJAX_MODE" => "N",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    ),
);?>


Доска почета

Описание intranet.structure.honour

Компонент выводит список почетных сотрудников компании. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > HR.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество выводимых пользователей | NUM_USERS | Параметр определяет количество отображаемых на странице записей.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается шаблон пути к странице подразделения компании.
Страница структуры компании | STRUCTURE_PAGE | Указывается путь к странице структуры компании.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Имя фильтра страницы структуры компании | STRUCTURE_FILTER | Задается имя фильтра страницы структуры компании.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты без года | DATE_FORMAT_NO_YEAR | Указывается формат показа даты без года. В выпадающем списке перечислены все возможные варианты показа даты без года, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты и времени, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать год рождения SHOW_YEAR Поле определяет кому показываеть год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).
Страница видеозвонка | PATH_TO_VIDEO_CALL | Указывается путь к странице видеозвонка.
Пользовательские поля для вывода | USER_PROPERTY | Указываются поля пользователей, которые будут показаны в визитных карточках сотрудников.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.structure.honour","",Array(
        "STRUCTURE_PAGE" => "/company/structure.php",
        "PM_URL" => "/company/personal/messages/chat/#USER_ID#/",
        "STRUCTURE_FILTER" => "structure",
        "USER_PROPERTY" => array("UF_DEPARTMENT","PERSONAL_PHONE","PERSONAL_MOBILE","WORK_PHONE"),
        "NUM_USERS" => "50",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "PM_URL" => "/messages/chat/#USER_ID#/",
        "SHOW_LOGIN" => "Y",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_FORMAT_NO_YEAR" => "d.m",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_YEAR" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
        "PATH_TO_VIDEO_CALL" => "/company/personal/video/#USER_ID#/"
    )
);?>


Доска почета пользователя

Описание intranet.structure.honour.user

Компонент выводит историю присутствия пользователя на доске почета. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > HR.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор пользователя | ID | Указывается код, в котором передается идентификатор пользователя.
Количество выводимых записей | NUM_ENTRIES | Указывается количество отображаемых на странице записей.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.structure.honour.user","",Array(
        "ID" => $USER->GetID(),
        "NUM_ENTRIES" => "10",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    ),
);?>


Отсутствия пользователя

Описание intranet.absence.user

Компонент выводит график отсутствия конкретного пользователя.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > HR.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор пользователя | ID | Указывается ID пользователя.
Тип инфоблока с календарями сотрудников | CALENDAR_IBLOCK_TYPE | Выбирается один из существующих типов инфоблоков.
Инфоблок с календарями сотрудников | CALENDAR_IBLOCK_ID | Выбирается один из существующих инфоблоков.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:intranet.absence.user",
    "",
    Array(
        "CACHE_TIME" => "3600",
        "CACHE_TYPE" => "A",
        "CALENDAR_IBLOCK_ID" => "1",
        "CALENDAR_IBLOCK_TYPE" => "news",
        "ID" => $USER->GetID()
    ),
);?>


Кадровые изменения

Описание intranet.structure.events

Компонент выводит список последних кадровых перестановок в компании. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > HR.

Параметры

Поле | Параметр | Описание
Основные параметры
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается шаблон пути к странице подразделения компании.
Страница структуры компании | STRUCTURE_PAGE | Указывается путь к странице структуры компании.
Имя фильтра страницы структуры компании | STRUCTURE_FILTER | Задается имя фильтра страницы структуры компании.
Количество выводимых на странице записей | NUM_USERS | Параметр определяет количество отображаемых на одной странице записей. Все записи будут выведены с помощью постраничной навигации.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты без года | DATE_FORMAT_NO_YEAR | Указывается формат показа даты без года. В выпадающем списке перечислены все возможные варианты показа даты без года, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты и времени, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать год рождения SHOW_YEAR Поле определяет кому показываеть год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).
Страница видеозвонка | PATH_TO_VIDEO_CALL | Указывается путь к странице видеозвонка.
Отображать фильтр | SHOW_FILTER | [Y|N] При отмеченной опции будет отображаться панель выбора подразделения. Если опция не отмечена, то будет показан весь список кадровых изменений.
Подпись постраничной навигации | NAV_TITLE | Указывается подпись для постраничной навигации.
Выводить постраничную навигацию над списком | SHOW_NAV_TOP | [Y|N] При отмеченной опции постраничная навигация будет показываться над списком.
Выводить постраничную навигацию под списком | SHOW_NAV_BOTTOM | [Y|N] При отмеченной опции постраничная навигация будет показываться под списком.
Пользовательские поля для вывода | USER_PROPERTY | Указываются поля пользователей, которые будут показаны в визитных карточках при просмотре в виде списка.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.structure.events","",Array(
        "SHOW_FILTER" => "Y",
        "PM_URL" => "/messages/form/#USER_ID#/",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "STRUCTURE_PAGE" => "structure.php",
        "STRUCTURE_FILTER" => "structure",
        "NUM_USERS" => "10",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "NAV_TITLE" => "Сотрудники",
        "SHOW_NAV_TOP" => "Y",
        "SHOW_NAV_BOTTOM" => "Y",
        "USER_PROPERTY" => Array("PERSONAL_PHONE", "PERSONAL_MOBILE", "UF_DEPARTMENT"),
        "DATE_FORMAT" => "d.m.Y",
        "DATE_FORMAT_NO_YEAR" => "d.m",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_YEAR" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
        "PATH_TO_VIDEO_CALL" => "/company/personal/video/#USER_ID#/"
    ),
);?>


Новые сотрудники

Описание intranet.structure.informer.new

Компонент выводит краткий список новых сотрудников компании. Компонент является стандартным и входит в дистрибутив модуля.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество выводимых записей | NUM_USERS | Параметр определяет количество отображаемых на одной странице записей.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается шаблон пути к странице подразделения компании.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение Y, то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат показа даты | DATE_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты и времени, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Отдел/офис | DEPARTMENT | Указывается офис, филиал или отдел, краткий список новых сотрудников которого будет отображен.
Показывать год рождения SHOW_YEAR Поле определяет кому показываеть год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.structure.informer.new","",Array(
        "AJAX_MODE" => "Y",
        "NUM_USERS" => "10",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "DEPARTMENT" => "156",
        "PM_URL" => "/company/personal/messages/chat/#USER_ID#/",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_YEAR" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    ),
);?>


Дни рождения

Описание intranet.structure.birthday.nearest

Компонент выводит список ближайших именинников офиса, отдела или филиала компании. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > HR > Дни рождения.

Параметры

Поле | Параметр | Описание
Основные параметры
Страница структуры компании | STRUCTURE_PAGE | Указывается путь к странице структуры компании.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается шаблон пути к странице подразделения компании.
Имя фильтра страницы структуры компании | STRUCTURE_FILTER | Задается имя фильтра страницы структуры компании.
Количество выводимых пользователей | NUM_USERS | Параметр определяет количество отображаемых на странице записей.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение Y, то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты без года | DATE_FORMAT_NO_YEAR | Указывается формат показа даты без года. В выпадающем списке перечислены все возможные варианты показа даты без года, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты и времени, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Страница видеозвонка | PATH_TO_VIDEO_CALL | Указывается путь к странице видеозвонка.
Отображать фильтр | SHOW_FILTER | [Y|N] При отмеченной опции будет отображатся панель выбора подразделения. Если опция не отмечена, то будет показан весь список именниников.
Показывать год рождения SHOW_YEAR Поле определяет кому показываеть год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).
Пользовательские поля для вывода | USER_PROPERTY | Указываются поля пользователей, которые будут показаны в визитных карточках сотрудников.
Отдел/офис | DEPARTMENT | Указывается офис, филиал или отдел, список ближайших именинников которого будет отображен.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.structure.birthday.nearest","",Array(
        "SHOW_FILTER" => "Y",
        "AJAX_MODE" => "Y",
        "STRUCTURE_PAGE" => "structure.php",
        "PM_URL" => "/messages/form/#USER_ID#/",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "STRUCTURE_FILTER" => "structure",
        "NUM_USERS" => "10",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_FORMAT_NO_YEAR" => "d.m",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_YEAR" => "Y",
        "USER_PROPERTY" => Array("PERSONAL_PHONE", "PERSONAL_MOBILE", "UF_DEPARTMENT"),
        "DEPARTMENT" => "156",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "PATH_TO_VIDEO_CALL" => "/company/personal/video/#USER_ID#/"
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    ),
);?>


Бронирование переговорных

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Бронирование переговорных (комплексный компонент) | intranet.reserve_meeting | Выводит календарь занятости переговорных комнат, позволяет бронировать переговорные и управлять ими.
Меню | intranet.reserve_meeting.menu | Выводит меню комплексного компонента.
Переговорная | intranet.reserve_meeting.meeting | Служит для отображения переговорной.
Поиск переговорных | intranet.reserve_meeting.search | Служит для поиска переговорных.
Просмотр резервирования | intranet.reserve_meeting.view_item | Предназначен для просмотра резервирования переговорных.
Резервирование переговорной | ntranet.reserve_meeting.reserve | Служит для резервирования переговорной.
Создание переговорной | intranet.reserve_meeting.add | Служит для создания переговорной комнаты.
Список переговорных | intranet.reserve_meeting.list | Выводит список переговорных.


Бронирование переговорных (комплексный компонент)

Описание intranet.reserve_meeting

Комплексный компонент выводит календарь занятости переговорных комнат, позволяет бронировать переговорные и управлять ими. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Бронирование переговорных.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип информационного блока, используемого для резервирования переговорных
Инфоблок | IBLOCK_ID | Указывается инфоблок, используемый для хранения записей резервирования переговорных.
Группы пользователей, которые могут изменять переговорные | USERGROUPS_MODIFY | Указываются группы пользователей, которым разрешено создавать и изменять переговорные.
Группы пользователей, которые могут резервировать переговорные | USERGROUPS_RESERVE | Указываются группы пользователей, которые могут осуществлять резервирование переговорных комнат.
Группы пользователей, которые могут снимать резервирование переговорных | USERGROUPS_CLEAR | Указываются группы пользователей, которые смогут отменять бронирование переговорных
Выходные дни недели | WEEK_HOLIDAYS | Указываются выходные дни недели. Выбранные дни не будут отображаться в календаре переговорной, если в эти дни не зарезервированы переговорные.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включен режим поддержки ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить[dw] следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - главная страница резервирования переговорных;
  • meeting - страница с графиком переговорной;
  • modify_meeting - страница изменения переговорной;
  • view_item - страница просмотра резервирования переговорной;
  • reserve_meeting - страница резервирования переговорной;
  • search - страница поиска свободных переговорных.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Имена переменных VARIABLE_ALIASES Указываются имена переменных для управления страницами:
  • meeting_id - имя переменной для идентификатора переговорной;
  • item_id - имя переменной для идентификатора резервирования;
  • page - имя переменной для страницы.
[/di] VARIABLE_ALIASES.
Дополнительные настройки
Устанавливать навигационную цепочку | SET_NAVCHAIN | [Y|N] При отмеченной опции будет добавлен пункт с заголовком страницы в цепочку навигации.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Шаблон пути к странице пользователя | PATH_TO_USER | Указывается шаблон пути к странице пользователя.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается шаблон пути к странице подразделения компании.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты и времени, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать год рождения SHOW_YEAR Поле определяет кому показываеть год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Список переговорных.
Страница видеозвонка | PATH_TO_VIDEO_CALL | Указывается шаблон пути к видеозвонку.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.reserve_meeting","",Array(
        "SEF_MODE" => "Y",
        "IBLOCK_TYPE" => "events",
        "IBLOCK_ID" => "17",
        "SET_NAVCHAIN" => "Y",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "PATH_TO_USER" => "/company/personal/user/#USER_ID#/",
        "PM_URL" => "/company/personal/messages/chat/#USER_ID#/",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_YEAR" => "Y",
        "SET_TITLE" => "Y",
        "USERGROUPS_MODIFY" => array("1"),
        "USERGROUPS_RESERVE" => array("1"),
        "USERGROUPS_CLEAR" => array("1"),
        "WEEK_HOLIDAYS" => array("5", "6"),
        "PATH_TO_VIDEO_CALL" => "/company/personal/video/#USER_ID#/",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "meeting" => "meeting/#meeting_id#/",
            "modify_meeting" => "meeting/#meeting_id#/modify/",
            "view_item" => "meeting/#meeting_id#/view/#item_id#/",
            "reserve_meeting" => "meeting/#meeting_id#/reserve/#item_id#/",
            "search" => "search/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "meeting" => Array(),
            "modify_meeting" => Array(),
            "view_item" => Array(),
            "reserve_meeting" => Array(),
            "search" => Array(),
        )
    ),
);?>


Меню

Описание intranet.reserve_meeting.menu

Компонент выводит меню комплексного компонента. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Бронирование переговорных.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип информационного блока, используемого для резервирования переговорных.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, используемый для резервирования переговорных.
Код переговорной | MEETING_ID | Код, используемый для идентификации переговоной.
Код страницы | PAGE_ID | Код, используемый для идентификации страницы.
Группы пользователей, которые могут изменять переговорные | USERGROUPS_MODIFY | Указываются группы пользователей, которым разрешено создавать и изменять переговорные.
Группы пользователей, которые могут резервировать переговорные | USERGROUPS_RESERVE | Указываются группы пользователей, которые могут осуществлять резервирование переговорных комнат.
Шаблоны ссылок
Путь к графику переговорной | PATH_TO_MEETING | Указывается путь к странице с графиком переговорной от корня сайта.
Путь к главной странице резервирования переговорных | PATH_TO_MEETING_LIST | Указывается путь к странице со списком переговорных от корня сайта.
Путь к странице изменения переговорной | PATH_TO_MODIFY_MEETING | Указывается путь к странице изменения переговорной от корня сайта.
Путь к странице резервирования переговорных | PATH_TO_RESERVE_MEETING | Указывается путь к странице резервирования переговорной от корня сайта.
Путь к странице поиска переговорной | PATH_TO_SEARCH | Указывается путь к странице поиска переговорной от корня сайта.
Дополнительные настройки
Устанавливать навигационную цепочку | SET_NAVCHAIN | [Y|N] При отмеченной опции будет добавлен пункт с заголовком страницы в цепочку навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название переговорной.
Псевдонимы переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, используемой для идентификации страницы.
Имя переменной для идентификатора переговорной | MEETING_VAR | Указывается имя переменной, используемой для идентификации переговорной.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.reserve_meeting.menu","",Array(
        "IBLOCK_TYPE" => "events",
        "IBLOCK_ID" => "16",
        "PAGE_VAR" => "",
        "MEETING_VAR" => "",
        "MEETING_ID" => "44",
        "PAGE_ID" => "",
        "PATH_TO_MEETING" => "",
        "PATH_TO_MEETING_LIST" => "",
        "PATH_TO_MODIFY_MEETING" => "",
        "PATH_TO_RESERVE_MEETING" => "",
        "PATH_TO_SEARCH" => "",
        "SET_NAVCHAIN" => "Y",
        "SET_TITLE" => "Y",
        "USERGROUPS_MODIFY" => Array("1"),
        "USERGROUPS_RESERVE" => Array("1")
    ),
);?>


Переговорная

Описание intranet.reserve_meeting.meeting

Компонент служит для отображения переговорной. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Бронирование переговорных.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип информационного блока, используемого для резервирования переговорных.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, используемый для резервирования переговорных.
Код переговорной | MEETING_ID | Код, используемый для идентификации переговоной.
Группы пользователей, которые могут снимать резервирование переговорных | USERGROUPS_CLEAR | Указываются группы пользователей, которые смогут отменять события переговорных.
Выходные дни недели | WEEK_HOLIDAYS | Указываются выходные дни недели, которые не будут отображаться в графике переговорных.
Шаблоны ссылок
Путь к графику переговорной | PATH_TO_MEETING | Указывается путь к странице с графиком переговорной от корня сайта.
Путь к главной странице резервирования переговорных | PATH_TO_MEETING_LIST | Указывается путь к главной странице резервирования переговорных от корня сайта.
Путь к странице просмотра брони | PATH_TO_VIEW_ITEM | Указывается путь к странице просмотра брони от корня сайта.
Путь к странице резервирования переговорных | PATH_TO_RESERVE_MEETING | Указывается путь к странице резервирования переговорной от корня сайта.
Дополнительные настройки
Устанавливать навигационную цепочку | SET_NAVCHAIN | [Y|N] При отмеченной опции будет добавлен пункт с заголовком страницы в цепочку навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено График переговорной: <название_переговорной>.
Псевдонимы переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, используемой для идентификации страницы.
Имя переменной для идентификатора переговорной | MEETING_VAR | Указывается имя переменной, используемой для идентификации переговорной.
Имя переменной для идентификатора резервирования | ITEM_VAR | Указывается имя переменной, используемой для идентификации переговорной.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.reserve_meeting.meeting","",Array(
        "IBLOCK_TYPE" => "events",
        "IBLOCK_ID" => "16",
        "PAGE_VAR" => "",
        "MEETING_VAR" => "",
        "ITEM_VAR" => "",
        "MEETING_ID" => "44",
        "PATH_TO_MEETING" => "",
        "PATH_TO_MEETING_LIST" => "",
        "PATH_TO_VIEW_ITEM" => "",
        "PATH_TO_RESERVE_MEETING" => "",
        "SET_NAVCHAIN" => "Y",
        "SET_TITLE" => "Y",
        "USERGROUPS_CLEAR" => Array(),
        "WEEK_HOLIDAYS" => Array("5","6")
    )
);?>


Поиск переговорных

Описание intranet.reserve_meeting.search

Компонент служит для поиска переговорных. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Бронирование переговорных.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип информационного блока, используемого для резервирования переговорных.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, используемый для резервирования переговорных.
Шаблоны ссылок
Путь к графику переговорной | PATH_TO_MEETING | Указывается путь к странице с графиком переговорной от корня сайта.
Путь к странице резервирования переговорных | PATH_TO_RESERVE_MEETING | Указывается путь к странице резервирования переговорной от корня сайта.
Дополнительные настройки
Устанавливать навигационную цепочку | SET_NAVCHAIN | [Y|N] При отмеченной опции будет добавлен пункт с заголовком страницы в цепочку навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Поиск переговорных.
Псевдонимы переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, используемой для идентификации страницы.
Имя переменной для идентификатора переговорной | MEETING_VAR | Указывается имя переменной, используемой для идентификации переговорной.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.reserve_meeting.search","",Array(
        "IBLOCK_TYPE" => "events",
        "IBLOCK_ID" => "16",
        "PAGE_VAR" => "",
        "MEETING_VAR" => "",
        "PATH_TO_MEETING" => "",
        "PATH_TO_RESERVE_MEETING" => "",
        "SET_NAVCHAIN" => "Y",
        "SET_TITLE" => "Y"
    ),
);?>


Просмотр резервирования

Описание intranet.reserve_meeting.view_item

Комплексный компонент, позволяет управлять списком дел.

В визуальном редакторе компонент расположен по пути CRM > Дела > Дела.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип информационного блока, используемого для резервирования переговорных.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, используемый для резервирования переговорных.
Код переговорной | MEETING_ID | Код, используемый для идентификации переговоной.
Код резервирования | ITEM_ID | Код, используемый для резервирования переговорной.
Шаблоны ссылок
Путь к графику переговорной | PATH_TO_MEETING | Указывается путь к странице с графиком переговорной от корня сайта.
Путь к главной странице резервирования переговорных | PATH_TO_MEETING_LIST | Указывается путь к странице резервирования переговорных от корня сайта.
Дополнительные настройки
Устанавливать навигационную цепочку | SET_NAVCHAIN | [Y|N] При отмеченной опции будет добавлен пункт с заголовком страницы в цепочку навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Просмотр резервирования переговорной: <название_события>.
Псевдонимы переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, используемой для идентификации страницы.
Имя переменной для идентификатора переговорной | MEETING_VAR | Указывается имя переменной, используемой для идентификации переговорной.
Имя переменной для идентификатора бронирования | ITEM_VAR | Указывается имя переменной, используемой для идентификатора бронирования.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.reserve_meeting.view_item","",Array(
        "IBLOCK_TYPE" => "events",
        "IBLOCK_ID" => "16",
        "PAGE_VAR" => "",
        "MEETING_VAR" => "",
        "MEETING_ID" => "",
        "ITEM_VAR" => "",
        "ITEM_ID" => "",
        "PATH_TO_MEETING" => "",
        "PATH_TO_MEETING_LIST" => "",
        "SET_NAVCHAIN" => "Y",
        "SET_TITLE" => "Y"
    ),
);?>


Резервирование переговорной

Описание intranet.reserve_meeting.reserve

Компонент для резервирования переговорной. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Бронирование переговорных.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип информационного блока, используемого для резервирования переговорных.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, используемый для резервирования переговорных.
Код переговорной | MEETING_ID | Код, используемый для идентификации переговорной.
Код резервирования | ITEM_VAR | Код, используемый для резервирования переговорной.
Группы пользователей, которые могут резервировать переговорные | USERGROUPS_RESERVE | Указываются группы пользователей, которые могут осуществлять резервирование переговорных комнат.
Шаблоны ссылок
Путь к графику переговорной | PATH_TO_MEETING | Указывается путь к странице с графиком переговорной от корня сайта.
Путь к главной странице резервирования переговорных | PATH_TO_MEETING_LIST | Указывается путь к странице резервирования переговорных от корня сайта.
Дополнительные настройки
Устанавливать навигационную цепочку | SET_NAVCHAIN | [Y|N] При отмеченной опции будет добавлен пункт с заголовком страницы в цепочку навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Резервирование переговорной: <название_переговорной>.
Псевдонимы переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, используемой для идентификации страницы.
Имя переменной для идентификатора переговорной | MEETING_VAR | Указывается имя переменной, используемой для идентификации переговорной.
Имя переменной для идентификатора резервирования | ITEM_ID | Указывается имя переменной, используемой для идентификатора резервирования.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.reserve_meeting.reserve","",Array(
        "IBLOCK_TYPE" => "events",
        "IBLOCK_ID" => "16",
        "PAGE_VAR" => "",
        "MEETING_VAR" => "",
        "MEETING_ID" => "",
        "ITEM_VAR" => "",
        "ITEM_ID" => "",
        "PATH_TO_MEETING" => "",
        "PATH_TO_MEETING_LIST" => "",
        "SET_NAVCHAIN" => "Y",
        "SET_TITLE" => "Y",
        "USERGROUPS_RESERVE" => Array("1")
    ),
);?>


Создание переговорной

Описание intranet.reserve_meeting.add

Компонент служит для создания переговорной комнаты. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Бронирование переговорных.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип информационного блока, используемого для резервирования переговорных.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, используемый для резервирования переговорных.
Код переговорной | MEETING_ID | Код, используемый для идентификации переговоной.
Группы пользователей, которые могут изменять переговорные | USERGROUPS_MODIFY | Указываются группы пользователей, которым будет разрешено создавать и изменять переговорные.
Шаблоны ссылок
Путь к графику переговорной | PATH_TO_MEETING | Указывается путь к странице с графиком переговорной от корня сайта.
Путь к главной странице резервирования переговорных | PATH_TO_MEETING_LIST | Указывается путь к странице резервирования переговорных от корня сайта.
Дополнительные настройки
Устанавливать навигационную цепочку | SET_NAVCHAIN | [Y|N] При отмеченной опции будет добавлен пункт с заголовком страницы в цепочку навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Создание переговорной (при создании новой переговорной) или Изменение переговорной: <название_переговорной> (при редактировании параметров уже существующей переговорной).
Псевдонимы переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, используемой для идентификации страницы.
Имя переменной для идентификатора переговорной | MEETING_VAR | Указывается имя переменной, используемой для идентификации переговорной.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.reserve_meeting.add","",Array(
        "IBLOCK_TYPE" => "events",
        "IBLOCK_ID" => "16",
        "PAGE_VAR" => "",
        "MEETING_VAR" => "",
        "MEETING_ID" => "",
        "PATH_TO_MEETING" => "",
        "PATH_TO_MEETING_LIST" => "",
        "SET_NAVCHAIN" => "Y",
        "SET_TITLE" => "Y",
        "USERGROUPS_MODIFY" => Array("1")
    ),
);?>


Список переговорных

Описание intranet.reserve_meeting.list

Компонент выводит список переговорных. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Бронирование переговорных.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип информационного блока, используемого для резервирования переговорных.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, используемый для резервирования переговорных.
Группы пользователей, которые могут изменять переговорные | USERGROUPS_MODIFY | Указываются группы пользователей, которым будет разрешено создавать и изменять переговорные.
Группы пользователей, которые могут резервировать переговорные | USERGROUPS_RESERVE | Указываются группы пользователей, которые будут осуществлять резервирование переговорных комнат.
Шаблоны ссылок
Путь к графику переговорной | PATH_TO_MEETING | Указывается путь к странице с графиком переговорной от корня сайта.
Путь к главной странице резервирования переговорных | PATH_TO_MEETING_LIST | Указывается путь к странице со списком переговорных от корня сайта.
Путь к странице резервирования переговорных | PATH_TO_RESERVE_MEETING | Указывается путь к странице резервирования переговорной от корня сайта.
Путь к странице изменения переговорной | PATH_TO_MODIFY_MEETING | Указывается путь к странице изменения переговорной от корня сайта.
Дополнительные настройки
Устанавливать навигационную цепочку | SET_NAVCHAIN | [Y|N] При отмеченной опции будет добавлен пункт с заголовком страницы в цепочку навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Список переговорных.
Псевдонимы переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, используемой для идентификации страницы.
Имя переменной для идентификатора переговорной | MEETING_VAR | Указывается имя переменной, используемой для идентификации переговорной.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.reserve_meeting.list","",Array(
        "IBLOCK_TYPE" => "services",
        "IBLOCK_ID" => "25",
        "PAGE_VAR" => "",
        "MEETING_VAR" => "",
        "PATH_TO_MEETING" => "",
        "PATH_TO_MEETING_LIST" => "",
        "PATH_TO_RESERVE_MEETING" => "",
        "PATH_TO_MODIFY_MEETING" => "",
        "SET_NAVCHAIN" => "Y",
        "SET_TITLE" => "Y",
        "USERGROUPS_MODIFY" => Array("1"),
        "USERGROUPS_RESERVE" => Array("1")
    ),
);?>


Оргструктура

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Поиск сотрудника (комплексный компонент) | intranet.search | Выводит форму поиска и список найденных сотрудников корпоративного портала.
Структура компании (комплексный компонент) | intranet.structure | Выводит дерево структуры компании со списком сотрудников корпоративного портала.
Визуальная структура компании | intranet.structure.visual | Выводит визуальное представление древовидной структуры компании.
Список сотрудников | intranet.structure.list | Выводит список сотрудников, удовлетворяющих внешнему фильтру.
Форма поиска | intranet.structure.selector | Выводит форму фильтрации списка сотрудников.


Поиск сотрудника (комплексный компонент)

Описание intranet.search

Компонент выводит форму поиска и список найденных сотрудников корпоративного портала. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Оргструктура.

Параметры

Поле | Параметр | Описание
Основные параметры
Страница структуры компании | STRUCTURE_PAGE | Указывается путь к странице структуры компании.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается шаблон пути к странице подразделения компании.
Имя фильтра страницы структуры компании | STRUCTURE_FILTER | Указывается имя фильтра страницы структуры компании.
Выводить только синхронизируемых с 1С пользователей | FILTER_1C_USERS | [Y|N] При отмеченной опции будут выводиться только синхронизируемые с 1С пользователи.
Количество пользователей на страницу | USERS_PER_PAGE | Поле определяет количество пользователей, отображаемых на одной странице. Весь список будет отображен с помощью постраничной навигации.
Фильтр по подразделениям FILTER_SECTION_CURONLY Указывается тип фильтра по подразделениям:
  • прямой (Y);
  • рекурсивный (N).
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Выводить уведомление при пустом списке | SHOW_ERROR_ON_NULL | [Y|N] При отмеченной опции выводится уведомление при пустом списке.
Отображать фильтр по алфавиту на языках | ALPHABET_LANG | Задаются языки для показа фильтра по алфавиту.
Подпись постраничной навигации | NAV_TITLE | Поле содержит подпись для постраничной навигации.
Показывать постраничную навигацию над списком | SHOW_NAV_TOP | [Y|N] При отмеченной опции постраничная навигация будет показываться над списком.
Показывать постраничную навигацию под списком | SHOW_NAV_BOTTOM | [Y|N] При отмеченной опции постраничная навигация будет показываться под списком.
Показывать список при пустом фильтре | SHOW_UNFILTERED_LIST | [Y|N] При отмеченной опции будет выведен весь список сотрудников. Если опция не отмечена, то будет показана только форма поиска.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение Y, то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты без года | DATE_FORMAT_NO_YEAR | Указывается формат показа даты без года. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты и времени, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать год рождения SHOW_YEAR Поле определяет кому показываеть год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).
Страница видеозвонка | PATH_TO_VIDEO_CALL | Указывается шаблон пути к видеозвонку.
Показывать переключатель представления | USE_VIEW_SELECTOR | [Y|N] При отмеченной опции на странице поиска будет показываться переключатель вывода результатов.
Представление по умолчанию DEFAULT_VIEW Указывается способ вывода результатов поиска по умолчанию:
  • список (list);
  • таблица (table).
Шаблон для представления в виде списка LIST_VIEW Указывается способ для представления в виде списка:
  • простой список (list);
  • с группировкой по отделам (group).

Если параметр принимает значение group, то необходимо настроить следущий параметр: USER_PROPERTY_GROUP.
Шаблон для представления в виде таблицы TABLE_VIEW Указывается способ для представления в виде списка:
  • простой список (list);
  • с группировкой по отделам (group).

Если параметр принимает значение group, то необходимо настроить следущий параметр: USER_PROPERTY_GROUP.
Пользовательские поля для вывода в табличном представлении | USER_PROPERTY_TABLE | Указываются поля, которые должны быть отображены при выводе списка пользователей в табличном представлении.
Пользовательские поля для вывода в формате Excel | USER_PROPERTY_EXCEL | Указываются поля пользователей, которые должны быть выгружены при выполнении экспорта пользователей в MS Excel.
Пользовательские поля для вывода в представлении в виде списка | USER_PROPERTY_LIST | Указываются поля, которые должны быть отображены при выводе пользователей в виде простого списка.
Параметры фильтра
Имя фильтра (для внешних форм фильтрации) | FILTER_NAME | Указывается имя фильтра (для внешних форм фильтрации).
Выбор подразделения для фильтрации FILTER_DEPARTMENT_SINGLE Указывается способ выбора подразделения(ий) в форме поиска:
  • одинарный (Y) - в выпадающем списке можно выбрать только одно подразделение;
  • множественный (N) - поле позволяет выбирать несколько подразделений.
Запоминать фильтр в сессии | FILTER_SESSION | [Y|N] При отмеченной опции введеные значения в поля формы поиска будут запоминаться системой.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.search","",Array(
        "DEFAULT_VIEW" => "table",
        "LIST_VIEW" => "list",
        "USER_PROPERTY_TABLE" => Array("FULL_NAME", "EMAIL", "PERSONAL_PHONE", "WORK_POSITION", "UF_DEPARTMENT"),
        "USER_PROPERTY_EXCEL" => Array("FULL_NAME", "EMAIL", "PERSONAL_PHONE", "WORK_POSITION", "UF_DEPARTMENT"),
        "AJAX_MODE" => "Y",
        "STRUCTURE_PAGE" => "structure.php",
        "PM_URL" => "/messages/form/#USER_ID#/",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "STRUCTURE_FILTER" => "structure",
        "FILTER_1C_USERS" => "Y",
        "FILTER_NAME" => "users",
        "USERS_PER_PAGE" => "20",
        "FILTER_DEPARTMENT_SINGLE" => "N",
        "FILTER_SESSION" => "Y",
        "FILTER_SECTION_CURONLY" => "N",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "SHOW_ERROR_ON_NULL" => "Y",
        "ALPHABET_LANG" => array("ru"),
        "NAV_TITLE" => "Сотрудники",
        "SHOW_NAV_TOP" => "Y",
        "SHOW_NAV_BOTTOM" => "Y",
        "SHOW_UNFILTERED_LIST" => "Y",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_FORMAT_NO_YEAR" => "d.m",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_YEAR" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "PATH_TO_VIDEO_CALL" => "/company/personal/video/#USER_ID#/",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    ),
);?>


Структура компании (комплексный компонент)

Описание intranet.structure

Комплексный компонент выводит дерево структуры компании со списком сотрудников корпоративного портала. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Оргструктура.

Параметры

Поле | Параметр | Описание
Основные параметры
Страница поиска сотрудников | SEARCH_URL | Указывается путь к странице поиска сотрудников.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается шаблон пути к странице подразделения компании.
Количество пользователей на страницу | USERS_PER_PAGE | Поле определяет количество пользователей, отображаемых на одной странице. Весь список будет отображен с помощью постраничной навигации.
Фильтр по подразделениям FILTER_SECTION_CURONLY Указывается тип фильтра по подразделениям:
  • прямой (Y);
  • рекурсивный (N).
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Выводить уведомление при пустом списке | SHOW_ERROR_ON_NULL | [Y|N] При отмеченной опции выводится уведомление при пустом списке.
Подпись постраничной навигации | NAV_TITLE | Поле содержит подпись для постраничной навигации.
Показывать постраничную навигацию над списком | SHOW_NAV_TOP | [Y|N] При отмеченной опции постраничная навигация будет показываться над списком.
Показывать постраничную навигацию под списком | SHOW_NAV_BOTTOM | [Y|N] При отмеченной опции постраничная навигация будет показываться под списком.
Показывать список при пустом фильтре | SHOW_UNFILTERED_LIST | [Y|N] При отмеченной опции будет выведен весь список сотрудников. Если опция не отмечена, то будет показана только структура компании.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение Y, то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты без года | DATE_FORMAT_NO_YEAR | Указывается формат показа даты без года. В выпадающем списке перечислены все возможные варианты показа даты без года, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты и времени, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать год рождения SHOW_YEAR Поле определяет кому показываеть год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).
Выводить информацию о подразделении | SHOW_SECTION_INFO | [Y|N] При отмеченной опции будет выводится информация о подразделении.
Пользовательские поля для вывода | USER_PROPERTY | Указываются поля пользователей, которые будут показаны в визитных карточках при просмотре подразделения.
Параметры фильтра
Выводить только синхронизируемых с 1С пользователей | FILTER_1C_USERS | [Y|N] При отмеченной опции будут выводиться только синхронизируемые с 1С пользователи.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.structure","",Array(
        "SHOW_FROM_ROOT" => "N",
        "MAX_DEPTH" => "2",
        "MAX_DEPTH_FIRST" => "0",
        "COLUMNS" => "2",
        "COLUMNS_FIRST" => "2",
        "SHOW_SECTION_INFO" => "Y",
        "USER_PROPERTY" => Array("EMAIL", "PERSONAL_ICQ", "PERSONAL_PHONE", "PERSONAL_MOBILE", "UF_PHONE_INNER"),
        "AJAX_MODE" => "Y",
        "SEARCH_URL" => "search.php",
        "PM_URL" => "/messages/form/#USER_ID#/",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "FILTER_1C_USERS" => "Y",
        "FILTER_NAME" => "users",
        "USERS_PER_PAGE" => "10",
        "FILTER_SECTION_CURONLY" => "Y",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "SHOW_ERROR_ON_NULL" => "Y",
        "NAV_TITLE" => "Сотрудники",
        "SHOW_NAV_TOP" => "Y",
        "SHOW_NAV_BOTTOM" => "Y",
        "SHOW_UNFILTERED_LIST" => "N",
        "DATE_FORMAT" => "d-m-Y",
        "DATE_FORMAT_NO_YEAR" => "d.m",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_YEAR" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    ),
);?>


Визуальная структура компании

Описание intranet.structure.visual

Компонент выводит визуальное представление древовидной структуры компании. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Оргструктура > Визуальная структура компании.

Параметры

Поле | Параметр | Описание
Основные параметры
Страница структуры компании | DETAIL_URL | Указывается путь к странице структуры компании.
Страница профиля пользователя | PROFILE_URL | Указывается путь к странице с профиля пользователя.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет выводиться логин, если не указано имя в профиле пользователя.
Выводить всплывающие информационные карточки пользователей | USE_USER_LINK | [Y|N] При отмеченной опции будут выводиться всплывающие информационные карточки сотрудников компании.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.structure.visual","",Array(
        "DETAIL_URL" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "PROFILE_URL" => "/company/personal/user/#ID#/",
        "PM_URL" => "/company/personal/messages/chat/#ID#/",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "USE_USER_LINK" => "Y",
        "SHOW_LOGIN" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "PATH_TO_VIDEO_CALL" => "/company/personal/video/#USER_ID#/"
    ),
);?>


Список сотрудников

Описание intranet.structure.list

Компонент выводит список сотрудников, удовлетворяющих внешнему фильтру. Компонент содержит два шаблона: (.default) и (.list).Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Оргструктура.

Параметры

Поле | Параметр | Описание
Основные параметры
Выводить только синхронизируемых с 1С пользователей | FILTER_1C_USERS | [Y|N] При отмеченной опции будут выводиться только синхронизируемые с 1С пользователи.
Фильтр по подразделениям FILTER_SECTION_CURONLY Указывается тип фильтра по подразделениям:
  • прямой (Y);
  • рекурсивный (N).
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Выводить уведомление при пустом списке | SHOW_ERROR_ON_NULL | [Y|N] При отмеченной опции будет выводиться уведомление при пустом списке.
Количество пользователей на страницу | USERS_PER_PAGE | Поле определяет количество пользователей, отображаемых на одной странице. Весь список будет отображен с помощью постраничной навигации.
Подпись постраничной навигации | NAV_TITLE | Указывается подпись для постраничной навигации.
Показывать постраничную навигацию над списком | SHOW_NAV_TOP | [Y|N] При отмеченной опции постраничная навигация будет показываться над списком.
Показывать постраничную навигацию под списком | SHOW_NAV_BOTTOM | [Y|N] При отмеченной опции постраничная навигация будет показываться под списком.
Показывать список при пустом фильтре | SHOW_UNFILTERED_LIST | [Y|N] Если условия поиска не заданы, то при отмеченной опции будет выведен весь список сотрудников.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Вывести руководителя при фильтре по подразделению | SHOW_DEP_HEAD_ADDITIONAL | [Y/N] При отмеченной опции в фильтре по подразделению будет отображен руководитель подразделения.
Параметры для вывода в списке | USER_PROPERTY | Указываются поля пользователей, которые будут показаны в визитных карточках сотрудников.
Параметры для вывода в Excel | USER_PROPERTY_EXCEL | Указываются поля пользователей, которые должны быть выгружены при выполнении экспорта пользователей в MS Excel.
Страница отправки личного сообщения PM_URL Указывается путь к странице отправки личного сообщения.

Данное поле доступно только для шаблона .list.
Дополнительные поля для вывода USER_PROPERTY Указываются, какие поля будут выводиться в списке сотрудников, удовлетворяющих внешнему фильтру.

Данное поле доступно только для шаблона .list.
Параметры фильтра
Имя фильтра | FILTER_NAME | Указывается имя фильтра.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.structure.list","",Array(
        "USER_PROPERTY" => Array("FULL_NAME", "EMAIL", "PERSONAL_PHONE", "WORK_POSITION", "UF_DEPARTMENT"),
        "USER_PROPERTY_EXCEL" => Array("FULL_NAME", "EMAIL", "PERSONAL_PHONE", "WORK_POSITION", "UF_DEPARTMENT"),
        "FILTER_NAME" => "users",
        "FILTER_1C_USERS" => "Y",
        "FILTER_SECTION_CURONLY" => "N",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_ERROR_ON_NULL" => "Y",
        "USERS_PER_PAGE" => "10",
        "NAV_TITLE" => "Сотрудники",
        "SHOW_NAV_TOP" => "Y",
        "SHOW_NAV_BOTTOM" => "Y",
        "SHOW_UNFILTERED_LIST" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Форма поиска

Описание intranet.structure.selector

Компонент выводит форму фильтрации списка сотрудников. Компонент содержит шаблоны: (.default), (.alphabet), (.include_area), (online), (.sections). Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Оргструктура.

Параметры

Поле | Параметр | Описание
Основные параметры
Страница списка пользователей | LIST_URL | Указывается путь к странице со списком пользователей.
Параметры фильтра
Имя фильтра | FILTER_NAME | Указывается имя фильтра.
Выбор подразделения для фильтрации FILTER_DEPARTMENT_SINGLE Указывается способ выбора подразделения(ий) в форме поиска:
  • одинарный (Y) - в выпадающем списке можно выбрать только одно подразделение;
  • множественный (N) - поле позволяет выбирать несколько подразделений.
Запоминать фильтр в сессии | FILTER_SESSION | [Y|N] При отмеченной опции введенные значения в поля формы поиска будут запоминаться системой.
Дополнительно (данный список настроек доступен для шаблона .sections)
Количество колонок | COLUMNS | Указывается количество колонок в секции.
Количество колонок на первой странице | COLUMNS_FIRST | Указывается количество колонок на первой странице.
Максимальная глубина дерева (0 - все) | MAX_DEPTH | Указывается максимальная глубина дерева.
Максимальная глубина дерева на первой странице (0 - все) | MAX_DEPTH_FIRST | Указывается максимальная глубина дерева на первой странице.
Выводить информацию о подразделении | SHOW_SECTION_INFO | [Y|N] При отмеченной опции в результах поиска будет выводиться информация о подразделении.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.structure.selector","sections",Array(
        "COLUMNS" => "2",
        "COLUMNS_FIRST" => "2",
        "MAX_DEPTH" => "2",
        "MAX_DEPTH_FIRST" => "0",
        "SHOW_SECTION_INFO" => "Y",
        "LIST_URL" => "users_list.php",
        "FILTER_NAME" => "users",
        "FILTER_DEPARTMENT_SINGLE" => "Y",
        "FILTER_SESSION" => "Y"
    )
);?>


Собрания и планерки

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Собрания и планерки | meetings | Комплексный компонент для управления собраниями.


Собрания и планерки

Описание meetings

Комплексный компонент для управления собраниями.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Собрания и планерки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока переговорных | RESERVE_MEETING_IBLOCK_TYPE | Выбирается тип информационного блока, используемого для бронирования переговорных
Инфоблок переговорных | RESERVE_MEETING_IBLOCK_ID | Указывается инфоблок, используемый для хранения записей бронирования переговорных.
Тип инфоблока видеопереговорных | RESERVE_VMEETING_IBLOCK_TYPE | Выбирается тип информационного блока, используемого для бронирования видеопереговорных
Инфоблок видеопереговорных | RESERVE_VMEETING_IBLOCK_ID | Указывается инфоблок, используемый для хранения записей бронирования видеопереговорных.
Количество собраний на страницу | MEETING_COUNT | Устанавливается число записей о собраниях, отображаемых на одной странице.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включен режим поддержки ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить[dw] следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются шаблоны пути к следующим страницам:
  • list - страница списка собраний;
  • meeting - страница просмотра информации о собрании;
  • meeting_edit - страница редактирования информации о собрании;
  • meeting_copy - страница создания следующего собрания;
  • item - страница детальной информации о пункте повестки.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Имена переменных VARIABLE_ALIASES Указываются имена переменных для управления страницами:
  • action - имя переменной идентификатора действия
[/di] VARIABLE_ALIASES.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:meetings",
    "",
    Array(
        "MEETINGS_COUNT" => "20",
        "RESERVE_MEETING_IBLOCK_ID" => "1",
        "RESERVE_MEETING_IBLOCK_TYPE" => "news",
        "RESERVE_VMEETING_IBLOCK_ID" => "1",
        "RESERVE_VMEETING_IBLOCK_TYPE" => "news",
        "SEF_MODE" => "N",
        "VARIABLE_ALIASES" => Array("action"=>"action")
        )
    ),
);?>


Учет рабочего времени (КП)

Внимание! Функционал faceid отключён с апреля 2022 года.

Модуль позволяет организовать контроль за использованием рабочего времени сотрудниками компании и учет поставленных в план и выполненных ими задач.

Настройки модуля описаны здесь.

Модуль относится только к "Битрикс24 в коробке".

Системные компоненты модуля (не описываются)
Название | Имя в пространстве имен bitrix | Описание
Начало работы с Bitrix24Time | faceid.timeman.start | Включает Bitrix24Time и запускает индексацию фотографий сотрудников.
Фейс-трекер рабочего времени | faceid.timeman | Автоматизирует открытие и закрытие рабочего дня по фотографии пользователя.
Отчет по рабочему времени | timeman.report | Вывод отчета по рабочему времени для сотрудников и руководителей.
Отчеты по работе сотрудников | timeman.report.weekly | Вывод отчетов по работе сотрудников и руководителей.
Учет рабочего времени | timeman | Основной инструментарий учета рабочего времени.


Сайты 24

Подраздел предназначен для работы с сайтами и страницами, созданными с помощью модуля Сайты 24.

Внимание! Набор компонент модуля Сайты24 не рекомендуется использовать по отдельности, т. к. это связанный механизм, который в «1С-Битрикс: Управление сайтом» отображается только в Административном разделе.

Подраздел включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Добавление элементов
Управление (комплексный компонент) | landing.start | Комплексный компонент управления сайтами и страницами
Наполнение страницы | landing.landing_view | Компонент служит для наполнения страницы блоками и контентом.
Предпросмотр шаблона | landing.demo_preview | Компонент отвечает за предпросмотр шаблона страницы (первой страницы в случае сайта).
Публикация страницы | landing.pub | Компонент выводит опубликованную версию страницы.
Редактирование домена | landing.domain_edit | Компонент отвечает за редактирование домена.
Редактирование сайта | landing.site_edit | Компонент отвечает за редактирование настроек сайта.
Редактирование страницы | landing.landing_edit | Компонент отвечает за редактирование настроек страницы.
Создание сайта / страницы по шаблону | landing.demo | Компонент служит для создания сайта или страницы сайта по предустановленному шаблону.
Список доменов | landing.domains | Компонент выводит список доменов.
Список сайтов | landing.sites | Компонент выводит список сайтов.
Список страница | landing.landings | Компонент выводит список страниц сайта.
Фильтр | landing.filter | Блок фильтра сайтов или страниц с кнопкой действия.


Управление

Описание landing.start

Комплексный компонент управления сайтами и страницами.

В визуальном редакторе компонент расположен по пути Сайты 24 > Управление.

Компонент относится к модулю Сайты 24.

Параметры

Поле Параметр Описание Примечание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y/N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di] Настраиваемые параметры при включенном режиме поддержки ЧПУ:
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • Список сайтов - ;
  • Страница сайта (список лендингов) ;
  • Страница редактирования сайта ;
  • Страница редактирования лендинга ;
  • Страница просмотра/наполнения лендинга ;
  • Список доменов ;
  • Страница редактирования домена ;
[/di] SEF_FOLDER и SEF_URL_TEMPLATES.
Если режим ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами:
  • site_show - переменная ID сайта (просмотр);
  • site_edit - переменная ID сайта (редактирование);
  • landing_edit - переменная ID лендинга (редактирование);
  • landing_view - переменная ID лендинга (просмотр/наполнение);
  • domain_edit - переменная ID домена (редактирование);
  • domains - идентификатор страницы доменов;
  • sites - идентификатор страницы сайтов.
[/di]
Дополнительные настройки
Тип сайтов TYPE Выбирается тип сайта из списка:
  • Лендинг
  • Магазин
  • Проект
  • Предпросмотр

Пример вызова

IncludeComponent(
    "bitrix:landing.start",
    "",
    Array(
        "SEF_MODE" => "N",
        "TYPE" => "PAGE",
        "VARIABLE_ALIASES" => Array("domain_edit"=>"domain_edit","domains"=>"domains","landing_edit"=>"landing_edit","landing_view"=>"landing_view","site_edit"=>"site_edit","site_show"=>"site_show","sites"=>"sites")
    )
);?>


Наполнение страницы

Описание landing.landing_view

Компонент служит для наполнения страницы блоками и контентом. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сайты 24 > Наполнение страницы.

Компонент относится к модулю Сайты 24.

Параметры

Поле | Параметр | Описание | Примечание
Дополнительные настройки
Тип сайтов TYPE Выбирается тип сайта из списка:
  • Лендинг
  • Магазин
  • Проект
  • Предпросмотр
ID сайта | SITE_ID | Указывается идентификатор сайта.
ID лендинга | LANDING_ID | Указывается идентификатор лендинга (посадочной страницы).
Ссылка на страницу со списком сайтов | PAGE_URL_URL_SITES | Прописывается ссылка на страницу со списком всех сайтов.
Ссылка на страницу со списком всех лендингов сайта | PAGE_URL_LANDINGS | Прописывается ссылка на страницу со списком всех лендингов (посадочных страниц) сайта.
Ссылка на страницу редактирования лендинга | PAGE_URL_LANDING_EDIT | Прописывается ссылка на страницу редактирования лендинга.
Ссылка на страницу редактирования сайта | PAGE_URL_SITE_EDIT | Прописывается ссылка на страницу редактирования сайта.
Переменная с прочими параметрами для передачи конструктору | PARAMS | Системный параметр.

Пример вызова

IncludeComponent(
    "bitrix:landing.landing_view",
    "",
Array(),
false
);?>


Предпросмотр шаблона

Описание landing.demo_preview

Компонент служит для предпросмотра шаблона страницы (первой страницы в случае сайта). Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сайты 24 > Предпросмотр шаблона.

Компонент относится к модулю Сайты 24.

Параметры

Поле | Параметр | Описание | Примечание
Дополнительные настройки
Тип TYPE Выбирается тип сайта из списка:
  • Лендинг
  • Магазин
  • Проект
  • Предпросмотр
Идентификатор сайта | SITE_ID | Указывается идентификатор сайта.
Работать в режиме сайта насильно | SITE_WORK_MODE | [Y/N] При отмеченной опции список шаблонов будет работать в режиме Шаблоны для сайта, несмотря на переданный параметр SITE_ID.
Идентификатор шаблона | CODE | Указывается идентификатор шаблона сайта.

Пример вызова

IncludeComponent(
    "bitrix:landing.demo_preview",
    "",
    Array(
        "CODE" => "",
        "PAGE_URL_BACK" => "",
        "SITE_ID" => "",
        "SITE_WORK_MODE" => "N",
        "TYPE" => "PAGE"
    )
);?>


Публикация страницы

Описание landing.pub

Компонент служит для вывода опубликованной версии страницы. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сайты 24 > Публикация страницы.

Компонент относится к модулю Сайты 24.

Параметры

Поле | Параметр | Описание | Примечание
Дополнительные настройки
Идентификатор страницы | LID | Указывается идентификатор страницы. |
Доменное имя | HTTP_HOST | Прописывается доменное имя. |
Полный путь до сайта | PATH | Указывается абсолютный путь до сайта |

Пример вызова

IncludeComponent(
    "bitrix:landing.pub",
    "",
    Array(
        "HTTP_HOST" => "",
        "LID" => "",
        "PATH" => ""
    )
);?>


Редактирование домена

Описание landing.domain_edit

Компонент служит для редактирования домена. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сайты 24 > Редактирование домена.

Параметры

Поле | Параметр | Описание | Примечание
Дополнительные настройки
ID домена | DOMAIN_ID | Указывается идентификатор домена. |
Ссылка на страницу со списком доменов | PAGE_URL_DOMAINS | Прописывается ссылка на страницу со списком всех доменов. |

Пример вызова

IncludeComponent(
    "bitrix:landing.domain_edit",
    "",
    Array(
        "DOMAIN_ID" => "",
        "PAGE_URL_DOMAINS" => ""
    )
);?>


Редактирование сайта

Описание landing.site_edit

Компонент служит для редактирования настроек сайта. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сайты 24 > Редактирование сайта.

Компонент относится к модулю Сайты 24.

Параметры

Поле | Параметр | Описание | Примечание
Дополнительные настройки
Тип сайтов TYPE Выбирается тип сайта из списка:
  • Лендинг
  • Магазин
  • Проект
  • Предпросмотр
ID сайта | SITE_ID | Указывается идентификатор сайта.
Шаблон представления | TEMPLATE | Указывается шаблон представления формы настроек. Поддерживает: catalog (настройки каталога в случае интернет-магазина) и значение по умолчанию (без параметра).
Ссылка на страницу со списком сайтов | PAGE_URL_SITES | Прописывается ссылка на страницу со списком всех сайтов.
Ссылка на страницу просмотра / наполнения лендинга | PAGE_URL_LANDING_VIEW | Прописывается ссылка на страницу просмотра и наполнения лендинга (посадочной страницы).

Пример вызова

IncludeComponent(
    "bitrix:landing.site_edit",
    "",
    Array(
        "PAGE_URL_LANDING_VIEW" => "",
        "PAGE_URL_SITES" => "",
        "SITE_ID" => "",
        "TEMPLATE" => "",
        "TYPE" => "PAGE"
    )
);?>


Редактирование страницы

Описание landing.landing_edit

Компонент служит для редактирования настроек страницы. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сайты 24 > Редактирование страницы.

Компонент относится к модулю Сайты 24.

Параметры

Поле | Параметр | Описание | Примечание
Дополнительные настройки
ID сайта | SITE_ID | Указывается идентификатор сайта. |
ID лендинга | LANDING_ID | Указывается идентификатор лендинга (посадочной страницы). |
Ссылка на страницу со списком лендингов | PAGE_URL_LANDINGS | Прописывается ссылка на страницу со списком всех лендингов. |
Ссылка на страницу просмотра / наполнения лендинга | PAGE_URL_LANDING_VIEW | Указывается ссылка на страницу просмотра и наполнения лендинга. |

Пример вызова

IncludeComponent(
    "bitrix:landing.landing_edit",
    "",
    Array(
        "LANDING_ID" => "",
        "PAGE_URL_LANDINGS" => "",
        "PAGE_URL_LANDING_VIEW" => "",
        "SITE_ID" => ""
    )
);?>


Создание сайта / страницы по шаблону

Описание landing.demo

Компонент служит для создания сайта или страницы сайта по предустановленному шаблону. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сайты 24 > Создание сайта / страницы по шаблону.

Компонент относится к модулю Сайты 24.

Параметры

Поле | Параметр | Описание | Примечание
Дополнительные настройки
Тип TYPE Выбирается тип сайта из списка:
  • Лендинг
  • Магазин
  • Проект
  • Предпросмотр
Идентификатор сайта | SITE_ID | Указывается идентификатор сайта.
Работать в режиме сайта насильно | SITE_WORK_MODE | [Y/N] При отмеченной опции список шаблонов будет работать в режиме Шаблоны для сайта, несмотря на переданный параметр SITE_ID.
Ссылка на страницу со списком сайтов | PAGE_URL_SITES | Прописывается ссылка на страницу со списком всех сайтов.
Ссылка на страницу просмотра / наполнения лендинга | PAGE_URL_LANDING_VIEW | Прописывается ссылка на страницу просмотра и наполнения лендинга.

Пример вызова

IncludeComponent(
    "bitrix:landing.demo",
    "",
    Array(
        "PAGE_URL_LANDING_VIEW" => "",
        "PAGE_URL_SITES" => "",
        "SITE_ID" => "",
        "SITE_WORK_MODE" => "N",
        "TYPE" => "PAGE"
    )
);?>


Список доменов

Описание landing.domains

Компонент служит для вывода списка доменов. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сайты 24 > Список доменов.

Компонент относится к модулю Сайты 24.

Параметры

Поле | Параметр | Описание | Примечание
Дополнительные настройки
Ссылка на редактирование домена | PAGE_URL_EDIT | Указывается ссылка на редактирование домена. |

Пример вызова

IncludeComponent(
    "bitrix:landing.domains",
    "",
    Array(
        "PAGE_URL_DOMAIN_EDIT" => ""
    )
);?>


Список сайтов

Описание landing.sites

Компонент служит для вывода списка сайтов. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сайты 24 > Список сайтов.

Компонент относится к модулю Сайты 24.

Параметры

Поле | Параметр | Описание | Примечание
Дополнительные настройки
Тип сайтов TYPE Выбирается тип сайта из списка:
  • Лендинг
  • Магазин
  • Проект
  • Предпросмотр
Ссылка на сайт детально (список страниц) | PAGE_URL_SITE | Прописывается ссылка на страницу детального просмотра сайта (списка страниц).
Ссылка на редактирование сайта | PAGE_URL_SITE_EDIT | Указывается ссылка на страницу редактирования сайта.
Ссылка на редактирование страницы | PAGE_URL_LANDING_EDIT | Прописывается ссылка на страницу редактирования страницы.

Пример вызова

IncludeComponent(
    "bitrix:landing.sites",
    "",
    Array(
        "PAGE_URL_LANDING_EDIT" => "",
        "PAGE_URL_SITE" => "",
        "PAGE_URL_SITE_EDIT" => "",
        "TYPE" => "PAGE"
    )
);?>


Список страниц

Описание landing.landings

Компонент служит для выводит список страниц сайта. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сайты 24 > Список страница.

Компонент относится к модулю Сайты 24.

Параметры

Поле | Параметр | Описание | Примечание
Дополнительные настройки
Тип сайта TYPE Выбирается тип сайта из списка:
  • Лендинг
  • Магазин
  • Проект
  • Предпросмотр
ID сайта (обязательно) | SITE_ID | Указывается идентификатор сайта.
Ссылка на редактирование лендинга | PAGE_URL_LANDING_EDIT | Прописывается ссылка на страницу редактирования лендинга.
Ссылка на просмотр (наполнение) лендинга | PAGE_URL_LANDING_VIEW | Прописывается ссылка на страницу просмотра и наполнения лендинга.

Пример вызова

IncludeComponent(
    "bitrix:landing.landings",
    "",
    Array(
        "PAGE_URL_LANDING_EDIT" => "",
        "PAGE_URL_LANDING_VIEW" => "",
        "SITE_ID" => "",
        "TYPE" => "PAGE"
    )
);?>


Фильтр

Описание landing.filter

Блок фильтра сайтов или страниц с кнопкой действия. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сайты 24 > Фильтр.

Компонент относится к модулю Сайты 24.

Параметры

Поле | Параметр | Описание | Примечание
Дополнительные настройки
Тип фильтра | FILTER_TYPE | Абстрактный тип (любая символьная строка), позволяющая разграничивать по сессиям используемый фильтр. В системе применяется для разграничения фильтра между Магазинами и Сайтами в Битрикс24. |
Ссылка для иконки настроек | SETTING_LINK | Указывается ссылка на настройки (как правило, ссылка на настройки сайта). При передаче не пустого значения выведется иконка со ссылкой на настройки. |
Идентификатор сайта для создания папки | FOLDER_SITE_ID | Указывается идентификатор сайта для создания папки. Если параметр передан (идентификатор сайта), то выведется кнопка создания папки в указанном сайте. |
Массив кнопок | BUTTONS | Массив дополнительных пунктов для кнопки "Добавить". Системный параметр. |

Пример вызова

IncludeComponent(
    "bitrix:landing.filter",
    "",
    Array(
        "BUTTONS" => "",
        "FILTER_TYPE" => "",
        "FOLDER_SITE_ID" => "",
        "SETTING_LINK" => ""
    )
);?>


Контент

Подразделы
Название | Имя в пространстве имен bitrix | Описание
Агрегатор библиотек документов (КП) | webdav | Позволяет организовать коллективный доступ к офисным документам, хранящимся на сервере, с возможностью редактировать их, сохранять изменения, вести историю версий в системе документооборота, работать с файлами через проводник. Под опубликованными документами можно организовать обсуждение.
Задачи 2.0 (КП) | tasks | Предназначен для управления задачами на портале.
Статьи и новости | news | Служит для создания новостного раздела на сайте.
Фотогалерея | photo | Подраздел предназначен для размещения на сайте полнофункциональной фотогалереи.
Фотогалерея 2.0 | photogallery | Подраздел предназначен для организации полнофункциональной фотогалереи с гибко настраиваемыми параметрами, в т.ч. многопользовательской.
Каталог | catalog | Служит для организации и размещения на сайте полнофункционального каталога товаров.
Универсальные списки | lists | Позволяет организовать полнофункциональную работу с универсальными списками.
Google Maps | map.google | Компоненты позволяют размещать на сайте карты, производить по ним поиск, создавать непосредственно на карте комментарии и задавать стартовую точку открытия карты.
Highload инфоблоки | highloadblock | Служит для работы с произвольными наборами данных в условиях высоких нагрузок.
RSS | rss | Предназначен для работы с новостями другого сайта.
Wiki | wiki | Позволяет организовать коллективную работу над контентом страницы.
Валюты | currency | Позволяет управлять валютами и их курсами.
Добавление элементов | iblock.element.add | Предназначен для работы с элементами инфоблока.
Инфоблоки | iblock | Служит для управления и каталогизирования различных типов (блоков) однородной информации.
Календарь событий | calendar | Дает возможность просматривать график предстоящих и прошедших событий сотрудников.
Карта сайта | main.map | Осуществляет показ карты сайта.
Медиа |  | Служит для проигрывания медиафайлов различных форматов.
Яндекс.Карты | map.yandex | Компоненты позволяют размещать на сайте карты, производить по ним поиск, создавать на карте комментарии и задавать стартовую точку открытия карты.
Обмен с 1С |  | Предназначен для обмена данными с 1С в формате CommerceML v2.
Социальные сервисы |  | Предоставляет аутентификацию посетителей сайта на внешних сервисах авторизации


Агрегатор библиотек документов (КП)

Модуль Агрегатор библиотек документов позволяет организовать коллективный доступ к офисным документам, хранящимся на сервере, с возможностью редактировать их, сохранять изменения, вести историю версий в системе документооборота, работать с файлами через проводник. Под опубликованными документами можно организовать обсуждение.

Настройки модуля описаны здесь.

Модуль относится только к "Битрикс24 в коробке" .

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Агрегатор | webdav.aggregator | Служит для быстрой навигации по библиотекам документов.
Агрегатор для работы с мобильных устройств | mobile.webdav.aggregator | Служит для быстрой навигации по библиотекам документов портала, настроенного на работу с мобильных устройств.


Агрегатор

Описание webdav.aggregator
и mobile.webdav.aggregator

Компонент служит для быстрой навигации по библиотекам документов. Компонент является стандартным и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Контент > Агрегатор библиотек документов > Агрегатор.

Также в системе есть компонент Агрегатор для быстрой навигации по библиотекам документов корпоративного портала, настроенного на работу с мобильных устройств. Компонент является стандартным и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Контент > Агрегатор библиотек документов > Агрегатор и имеет идентичные обычному агрегатору опции настройки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Указывается тип информационного блока библиотеки документов.
Информационные блоки с документами | IBLOCK_OTHER_IDS | Для выбранного типа инфоблоков указывается идентификаторы инфоблоков, в котором хранятся документы.
Информационный блок документов рабочих групп | IBLOCK_GROUP_ID | Указывается идентификатор инфорблока документов рабочих групп.
Информационный блок документов пользователей | IBLOCK_USER_ID | Указывается идентификатор инфорблока документов пользователя.
Отображение имени NAME_TEMPLATE Параметр определяет отображение имени пользователя:
  • #NOBR##LAST_NAME# #NAME##/NOBR# - фамилия, имя (Петров Иван);
  • #NOBR##LAST_NAME# #NAME##/NOBR# #SECOND_NAME# - фамилия, имя, отчество. (Петров Иван Васильевич);
  • #NAME# #SECOND_NAME# #LAST_NAME# - имя, отчество, фамилия. (Иван Васильевич Петров);
  • #NOBR##NAME# #LAST_NAME##/NOBR# - имя, фамилия. (Иван Петров).

По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта).

Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • USER_FILE_PATH - страница документов пользователя (страница должна вести на существующий профиль пользователя и содержать #USER_ID#);
  • GROUP_FILE_PATH - страница документов рабочих групп (страница должна вести на существующий группу пользователей и содержать #GROUP_ID#);
  • USER_VIEW - страница пользователя (страница должна вести на существующий профиль пользователя и содержать #USER_ID#).
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова
webdav.aggregator

<?$APPLICATION->IncludeComponent("bitrix:webdav.aggregator","",Array(
        "SEF_MODE" => "Y",
        "IBLOCK_TYPE" => "library",
        "IBLOCK_OTHER_IDS" => array("18","19","22"),
        "IBLOCK_GROUP_ID" => "18",
        "IBLOCK_USER_ID" => "19",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "USER_FILE_PATH" => "company/personal/user/#USER_ID#/files/lib/#PATH#",
            "GROUP_FILE_PATH" => "workgroups/group/#GROUP_ID#/files/#PATH#",
            "USER_VIEW" => "/company/personal/user/#USER_ID#"
        ),
        "VARIABLE_ALIASES" => Array(
            "USER_FILE_PATH" => Array(),
            "GROUP_FILE_PATH" => Array(),
            "USER_VIEW" => Array(),
        )
    )
);?>

Пример вызова
mobile.webdav.aggregator

<?$APPLICATION->IncludeComponent(
    "bitrix:mobile.webdav.aggregator",
    "",
    Array(
        "CACHE_TIME" => "3600",
        "CACHE_TYPE" => "A",
        "IBLOCK_GROUP_ID" => "23",
        "IBLOCK_OTHER_IDS" => array("23"),
        "IBLOCK_TYPE" => "news",
        "IBLOCK_USER_ID" => "23",
        "NAME_TEMPLATE" => "",
        "SEF_MODE" => "N"
    )
);?>


Задачи 2.0 (КП)

Модуль Задачи предназначен для управления задачами на портале.

Настройки модуля описаны здесь.

Модуль относится только к "Битрикс24 в коробке".

Модуль включает в себя следующие компоненты:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Задача | tasks_task | Компонент для создания, просмотра и редактирования задачи.
Задачи | tasks.list | Компонент для отображения задач.
Изменение шаблона | tasks.template.edit | Компонент для создания и изменения шаблона задачи.
Просмотр задачи | tasks.task.detail | Компонент для отображения задачи.
Шаблоны | tasks.templates.list | Компонент для отображения шаблонов задач.
Тема (отзывы) | tasks.topic.reviews | Форма для создания отзыва к задаче, список отзывов.
Канбан задач | tasks.kanban | Компонент для отображения задач в формате виртуальной онлайн-доски для работы с проектами.
Системные компоненты (не описываются)
Отчет по эффективности | tasks.report | Компонент для отображения отчета эффективности сотрудников.
Выбор тегов к задаче | tasks.tags.selector | Компонент служит для выбора тегов к задаче.
Выбор задачи | tasks.task.selector | Компонент служит для выбора задач (в форме задачи для выбора родительской задачи). Также он используется в модуле Учет рабочего времени
Выбор сотрудников в задаче | tasks.user.selector | Компонент служит для выбора сотрудников в задаче.
Задачи (фильтр) | tasks.filter | Компонент служит для отображения фильтра в публичном интерфейсе. Устаревшая версия, сохранена для совместимости.
Задачи (фильтр v2) | tasks.filter.v2 | Компонент служит для отображения фильтра в публичном интерфейсе с поддержкой создания собственных настроек.

О работе с модулем смотрите в курсе Администратор сервиса Битрикс24 [image].


Задача

Описание tasks.task

Компонент для создания, просмотра и редактирования задачи.

В визуальном редакторе компонент расположен по пути: Контент > Задачи 2.0 > Задача.

Параметры

Существует параметр, не имеющий визуального отображения в форме настроек параметров компонента. С версии 20.6.0 (появление новых прав доступа) необходимо настраивать обязательный параметр компонента ACTION. Параметр может принимать значения edit или view в зависимости от того, на создание/редактирование или просмотр открывается задача.

Поле | Параметр | Описание
Основные параметры
Выбрать связанные сущности SUB_ENTITY_SELECT Указываются сущности, которые будут связаны с задачей:
  • Теги
  • Чек-лист
  • Напоминания
  • История изменений
  • Затраченное время
  • Шаблон повторения задачи
  • Зависимость в проекте
  • Связанные задачи
  • Данные планировщика задач
Выбрать дополнительные данные AUX_DATA_SELECT Выбираются дополнительные данные из списка:
  • Время работы компании
  • Пользовательские поля
  • Шаблоны задач
Источник данных
Идентификатор задачи | ID | Прописывается ID задачи.
Идентификатор группы | GROUP_ID | Указывается ID группы.
Идентификатор пользователя | USER_ID | Указывается ID пользователя.
Шаблоны ссылок
Путь к задачам пользователя | PATH_TO_USER_TASKS | Прописывается путь к списку задач пользователя.
Путь к списку задач | PATH_TO_GROUP_TASKS | Прописывается путь к списку задач.
Путь к задаче | PATH_TO_GROUP_TASKS_TASK | Указывается путь к задаче.
Путь к профилю пользователя | PATH_TO_USER_PROFILE | Указывается путь к профилю пользователя.
Путь к группе | PATH_TO_GROUP | Указывается путь к группе.
Дополнительные настройки
Включить цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции будет показана цепочка навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на каждой странице будет установлен заголовок <имя_пользователя>: Задачи или Мои задачи.
Включить рейтинг | SHOW_RATING | [Y|N] Включение функции отображения рейтинга.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).

Пример вызова

 <?$APPLICATION->IncludeComponent(
    "bitrix:tasks.task",
    "",
    Array(
        "AUX_DATA_SELECT" => array(),
        "GROUP_ID" => "",
        "ID" => "",
        "PATH_TO_GROUP" => "",
        "PATH_TO_GROUP_TASKS" => "",
        "PATH_TO_GROUP_TASKS_TASK" => "",
        "PATH_TO_USER_PROFILE" => "",
        "PATH_TO_USER_TASKS" => "",
        "RATING_TYPE" => "",
        "REDIRECT_ON_SUCCESS" => "Y",
        "SET_NAVCHAIN" => "Y",
        "SET_TITLE" => "Y",
        "SHOW_RATING" => "Y",
        "SUB_ENTITY_SELECT" => array(),
        "ACTION"=>"edit",
        "USER_ID" => ""
    )
);?>


Задачи

Описание tasks.list

Компонент выводит список задач сотрудника.

В визуальном редакторе компонент расположен по пути: Контент > Задачи 2.0 > Задачи.

Параметры

Поле | Параметр | Описание
Основные параметры
Свойства задачи | TASKS_FIELDS_SHOW | Указываются поля, которые должны быть отображены при показе задач.
Тип задач | TASK_TYPE | Указывается тип задач: Для группы (group) или Для пользователя (user).
Шаблоны ссылок
Путь к списку задач группы | PATH_TO_GROUP_TASKS | Указывается путь к списку задач группы.
Путь к задаче группы | PATH_TO_GROUP_TASKS_TASK | Указывается путь к задаче группы.
Путь к списку задач пользователя | PATH_TO_USER_TASKS | Указывается путь к списку задач пользователя.
Путь к задаче пользователя | PATH_TO_USER_TASKS_TASK | Указывается путь к задаче пользователя.
Дополнительные настройки
Включить цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции будет показана цепочка навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на каждой странице будет установлен заголовок <имя_пользователя>: Задачи или Мои задачи.
Количество записей на странице | ITEMS_COUNT | [Y|N] Параметр определяет количество задач отображаемых на одной странице. Остальные задачи будут выведены с помощью постраничной навигации.
Отображение имени | NAME_TEMPLATE | Выбор формата отображения фамилии и имени. Указывается шаблон для отображения ФИО пользователя. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Псевдонимы переменных
Имя переменной для кода задачи | TASK_VAR | Поле содержит имя переменной для кода задачи.
Имя переменной для кода пользователя | USER_VAR | Поле содержит имя переменной для кода пользователя.
Имя переменной для кода группы | GROUP_VAR | Поле содержит имя переменной для кода группы.
Имя переменной для кода действия | ACTION_VAR | Поле содержит имя переменной для кода действия.
Имя переменной для кода страницы | PAGE_VAR | Поле содержит имя переменной для кода страницы.

Пример вызова

 <?$APPLICATION->IncludeComponent(
    "bitrix:tasks.list",
    "",
    Array(
        "TASKS_FIELDS_SHOW" => array(),
        "TASK_TYPE" => "user",
        "TASK_VAR" => "task_var",
        "USER_VAR" => "user_var",
        "GROUP_VAR" => "group_var",
        "ACTION_VAR" => "action_var",
        "PAGE_VAR" => "page_var",
        "PATH_TO_GROUP_TASKS" => "/workgroups/group/#group_id#/tasks/",
        "PATH_TO_GROUP_TASKS_TASK" => "/workgroups/group/#group_id#/tasks/task/view/#task_id#/",
        "PATH_TO_USER_TASKS" => "/company/personal/user/#user_id#/tasks/",
        "PATH_TO_USER_TASKS_TASK" => "/company/personal/user/#user_id#/tasks/task/view/#task_id#/",
        "SET_NAVCHAIN" => "Y",
        "SET_TITLE" => "Y",
        "ITEMS_COUNT" => "20"
    )
);?>


Изменение шаблона

Описание tasks.template.edit

Компонент служит для создания и изменения шаблонов задач.

В визуальном редакторе компонент расположен по пути: Контент > Задачи 2.0 > Изменение задачи.

Параметры

Поле | Параметр | Описание
Основные параметры
Код | TASK_ID | Указывается код, в котором передается идентификатор задачи.
Код пользователя | USER_ID | Указывается код, в котором передается идентификатор пользователя.
Код группы | GROUP_ID | Указывается код, в котором передается идентификатор группы социальной сети.
Шаблоны ссылок
Путь к списку задач группы | PATH_TO_GROUP_TASKS | Указывается путь к списку задач группы.
Путь к задаче группы | PATH_TO_GROUP_TASKS_TASK | Указывается путь к задаче группы.
Путь к списку задач пользователя | PATH_TO_USER_TASKS | Указывается путь к списку задач пользователя.
Путь к задаче пользователя | PATH_TO_USER_TASKS_TASK | Указывается путь к задаче пользователя.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице будет установлен заголовок Задача №<номер_задачи> или Новая задача.
Псевдонимы переменных
Имя переменной для кода задачи | TASK_VAR | Поле содержит имя переменной для кода задачи.
Имя переменной для кода пользователя | USER_VAR | Поле содержит имя переменной для кода пользователя.
Имя переменной для кода группы | GROUP_VAR | Поле содержит имя переменной для кода группы.
Имя переменной для кода действия | ACTION_VAR | Поле содержит имя переменной для кода действия.
Имя переменной для кода страницы | PAGE_VAR | Поле содержит имя переменной для кода страницы.

Пример вызова

 <?$APPLICATION->IncludeComponent(
    "bitrix:tasks.template.edit",
    "",
    Array(
        "TASK_ID" => "$task_id",
        "USER_ID" => "$user_id",
        "GROUP_ID" => "$group_id",
        "TASK_VAR" => "task_var",
        "USER_VAR" => "user_var",
        "GROUP_VAR" => "group_var",
        "ACTION_VAR" => "action_var",
        "PAGE_VAR" => "page_var",
        "PATH_TO_GROUP_TASKS" => "/workgroups/group/#group_id#/tasks/",
        "PATH_TO_GROUP_TASKS_TASK" => "/workgroups/group/#group_id#/tasks/task/view/#task_id#/",
        "PATH_TO_USER_TASKS" => "/company/personal/user/#user_id#/tasks/",
        "PATH_TO_USER_TASKS_TASK" => "/company/personal/user/#user_id#/tasks/task/view/#task_id#/",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    ),
false
);?>


Просмотр задачи

Описание tasks.task.detail

Компонент служит для отображения задачи.

В визуальном редакторе компонент расположен по пути: Контент > Задачи 2.0 > Просмотр задачи.

Параметры

Поле | Параметр | Описание
Основные параметры
Свойства задачи | TASKS_FIELDS_SHOW | Указываются поля, которые должны быть отображены при показе задач.
Тип задач | TASK_TYPE | Указывается тип задач: Для группы (group) или Для пользователя (user).
Шаблоны ссылок
Путь к списку задач | PATH_TO_GROUP_TASKS | Указывается путь к списку задач.
Путь к задаче | PATH_TO_GROUP_TASKS_TASK | Указывается путь к задаче.
Путь к представлению | PATH_TO_GROUP_TASKS_VIEW | Указывается путь к представлению задачи.
Путь к странице пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается путь к странице пользователя.
Дополнительные настройки
Путь к папке со смайликами для форума относительно корня сайта | PATH_TO_FORUM_SMILE | Указывается путь к папке со смайлами. По умолчанию указано /bitrix/images/forum/smile/.
Выводить рейтинг | SHOW_RATING | [Y|N] При отмеченной опции будет включен функционал рейтинга.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).
Включить цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции будет показана цепочка навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на каждой странице будет установлен заголовок Задача №<номер_задачи>.
Количество записей на странице | ITEMS_COUNT | [Y|N] Параметр определяет количество задач отображаемых на одной странице. Остальные задачи будут выведены с помощью постраничной навигации.
Псевдонимы переменных
Имя переменной для кода задачи | TASK_VAR | Поле содержит имя переменной для кода задачи.
Имя переменной для кода пользователя | USER_VAR | Поле содержит имя переменной для кода пользователя.
Имя переменной для кода группы | GROUP_VAR | Поле содержит имя переменной для кода группы.
Имя переменной для кода действия | ACTION_VAR | Поле содержит имя переменной для кода действия.
Имя переменной для кода страницы | PAGE_VAR | Поле содержит имя переменной для кода страницы.

Пример вызова

 <?$APPLICATION->IncludeComponent(
    "bitrix:tasks.task.detail",
    "",
    Array(
        "TASKS_FIELDS_SHOW" => array(),
        "TASK_TYPE" => "group",
        "TASK_VAR" => "task_var",
        "USER_VAR" => "user_var",
        "GROUP_VAR" => "grouop_var",
        "ACTION_VAR" => "action_var",
        "PAGE_VAR" => "page_var",
        "PATH_TO_GROUP_TASKS" => "/workgroups/group/#group_id#/tasks/",
        "PATH_TO_GROUP_TASKS_TASK" => "/workgroups/group/#group_id#/tasks/task/view/#task_id#/",
        "PATH_TO_GROUP_TASKS_VIEW" => "",
        "PATH_TO_FORUM_SMILE" => "/bitrix/images/forum/smile/",
        "URL_TEMPLATES_PROFILE_VIEW" => "",
        "SHOW_RATING" => "",
        "RATING_TYPE" => "",
        "SET_NAVCHAIN" => "Y",
        "SET_TITLE" => "Y",
        "ITEMS_COUNT" => "20"
    )
);?>


Шаблоны

Описание tasks.templates.list

Компонент отображения шаблонов задач сотрудника.

В визуальном редакторе компонент расположен по пути: Контент > Задачи 2.0 > Шаблоны.

Параметры

Поле | Параметр | Описание
Основные параметры
Свойства задачи | TASKS_FIELDS_SHOW | Указываются поля, которые должны быть отображены при показе задач.
Тип задач | TASK_TYPE | Указывается тип задач: Для группы (group) или Для пользователя (user).
Шаблоны ссылок
Путь к списку задач группы | PATH_TO_GROUP_TASKS | Указывается путь к списку задач группы.
Путь к задаче группы | PATH_TO_GROUP_TASKS_TASK | Указывается путь к задаче группы.
Путь к списку задач пользователя | PATH_TO_USER_TASKS | Указывается путь к списку задач пользователя.
Путь к задаче пользователя | PATH_TO_USER_TASKS_TASK | Указывается путь к задаче пользователя.
Дополнительные настройки
Включить цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции будет показана цепочка навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на каждой странице будет установлен заголовок <имя_пользователя>: Задачи или Мои задачи.
Количество записей на странице | ITEMS_COUNT | [Y|N] Параметр определяет количество задач отображаемых на одной странице. Остальные задачи будут выведены с помощью постраничной навигации.
Псевдонимы переменных
Имя переменной для кода задачи | TASK_VAR | Поле содержит имя переменной для кода задачи.
Имя переменной для кода пользователя | USER_VAR | Поле содержит имя переменной для кода пользователя.
Имя переменной для кода группы | GROUP_VAR | Поле содержит имя переменной для кода группы.
Имя переменной для кода действия | ACTION_VAR | Поле содержит имя переменной для кода действия.
Имя переменной для кода страницы | PAGE_VAR | Поле содержит имя переменной для кода страницы.

Пример вызова

 <?$APPLICATION->IncludeComponent(
    "bitrix:tasks.templates.list",
    "",
    Array(
        "TASKS_FIELDS_SHOW" => array(),
        "TASK_TYPE" => "user",
        "TASK_VAR" => "task_var",
        "USER_VAR" => "user_var",
        "GROUP_VAR" => "grouop_var",
        "ACTION_VAR" => "action_var",
        "PAGE_VAR" => "page_var",
        "PATH_TO_GROUP_TASKS" => "/workgroups/group/#group_id#/tasks/",
        "PATH_TO_GROUP_TASKS_TASK" => "/workgroups/group/#group_id#/tasks/task/view/#task_id#/",
        "PATH_TO_USER_TASKS" => "/company/personal/user/#user_id#/tasks/",
        "PATH_TO_USER_TASKS_TASK" => "/company/personal/user/#user_id#/tasks/task/view/#task_id#/",
        "SET_NAVCHAIN" => "Y",
        "SET_TITLE" => "Y",
        "ITEMS_COUNT" => "20"
    )
);?>


Тема (отзывы)

Описание tasks.topic.reviews

Компонент служит для создания отзыва к задаче.

В визуальном редакторе компонент расположен по пути: Контент > Задачи 2.0 > Тема (отзывы).

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума для отзывов | FORUM_ID | Указывается идентификатор форума, в котором будут храниться отзывы пользователей.
ID элемента | TASK_ID | Указывается идентификатор задачи, отзывы к которому будут создаваться.
Начинать тему текстом элемента | POST_FIRST_MESSAGE | [Y|N] Если опция отмечена, то при переходе по ссылке Перейти к обсуждению на форуме первым сообщением форума будет ссылка на обсуждаемый элемент (форма представления первого сообщения определяется параметром POST_FIRST_MESSAGE_TEMPLATE).
Шаблон текста для первого сообщения темы | POST_FIRST_MESSAGE_TEMPLATE | Указывается шаблон текста для первого сообщения темы. По умолчанию поле содержит #IMAGE#[url=#LINK#]#TITLE#[/url]#BODY#.
Шаблоны ссылок
Страница чтения темы форума | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума.
Страница элемента инфоблока | URL_TEMPLATES_DETAIL | Указывается адрес страницы элемента инфоблока.
Страница пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Включить рейтинг | SHOW_RATING | [Y|N] При отмеченной опции будет включен функционал рейтинга.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Указывается количество сообщений, отображаемых на одной странице. Все сообщения будут выведены с помощью постраничной навигации.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Задается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/smile/.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления отзыва в публичной части.
Выводить сообщения в прямом порядке | PREORDER | [Y|N] При отмеченной опции сообщения будут отсортированы по дате создания по возрастанию.
Показать ссылку на форум | SHOW_LINK_TO_FORUM | [Y|N] При отмеченной опции на странице элемента будет отображена ссылка на форум обсуждения.
Максимальное количество файлов, прикрепленных к одному сообщению | FILES_COUNT | Задается количество файлов, которое может быть прикреплено к сообщению. Данный параметр работает только в том случае, если в настройках соответствующего форума разрешено прикреплять файлы к сообщениям.

Пример вызова

  <?$APPLICATION->IncludeComponent(
    "bitrix:tasks.topic.reviews",
    "",
    Array(
        "SHOW_LINK_TO_FORUM" => "Y",
        "FILES_COUNT" => "2",
        "FORUM_ID" => "1",
        "TASK_ID" => $_REQUEST["ID"],
        "POST_FIRST_MESSAGE" => "Y",
        "POST_FIRST_MESSAGE_TEMPLATE" => "#IMAGE#[url=#LINK#]#TITLE#[/url]#BODY#",
        "URL_TEMPLATES_READ" => "",
        "URL_TEMPLATES_DETAIL" => "",
        "URL_TEMPLATES_PROFILE_VIEW" => "",
        "SHOW_RATING" => "",
        "RATING_TYPE" => "",
        "MESSAGES_PER_PAGE" => "10",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "USE_CAPTCHA" => "Y",
        "PREORDER" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0"
    ),
false
);?>


Канбан задач

Описание tasks.kanban

Компонент для отображения задач

В визуальном редакторе компонент находится в Контент > Задачи 2.0 > Канбан задач.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
Путь к списку задач группы | PATH_TO_GROUP_TASKS | Прописывается путь к списку задач группы.
Путь к задаче группы | PATH_TO_GROUP_TASKS_TASK | Указывается путь к задаче группы.
Путь к списку задач пользователя | PATH_TO_USER_TASKS | Указывается путь к списку задач пользователя.
Путь к задаче пользователя | PATH_TO_USER_TASKS_TASK | Прописывается путь к задаче пользователя.
Путь к профилю пользователя | PATH_TO_USER_PROFILE | Указывается путь к профилю пользователя.
Дополнительные настройки
Персональный канбан | PERSONAL | [Y|N] Включение виртуальной онлайн-доски для работы с проектами.
Идентификатор пользователя | USER_ID | Указывается ID пользователя.
Идентификатор группы | GROUP_ID | Прописывается ID группы.
Идентификатор группы | GROUP_ID | Указывается ID группы.
Количество записей на странице | ITEMS_COUNT | Параметр определяет количество задач отображаемых на одной странице. Остальные задачи будут выведены с помощью постраничной навигации.
Отображение имени | NAME_TEMPLATE | Выбор формата отображения фамилии и имени. Указывается шаблон для отображения ФИО пользователя. По умолчанию - значение Формат сайта (т.е. используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Ширина превью | PREVIEW_WIDTH | Задается ширина канбана, отображаемого в предварительном просмотре.
Высота превью | PREVIEW_HEIGHT | Задается высота канбана, отображаемого в предварительном просмотре.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на каждой странице будет установлен заголовок <имя_пользователя>: Задачи или Мои задачи.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:tasks.kanban",
    "",
    Array(
        "GROUP_ID" => "",
        "ITEMS_COUNT" => "20",
        "NAME_TEMPLATE" => "",
        "PATH_TO_GROUP_TASKS" => "",
        "PATH_TO_GROUP_TASKS_TASK" => "",
        "PATH_TO_USER_PROFILE" => "",
        "PATH_TO_USER_TASKS" => "",
        "PATH_TO_USER_TASKS_TASK" => "",
        "PERSONAL" => "N",
        "PREVIEW_HEIGHT" => "150",
        "PREVIEW_WIDTH" => "200",
        "SET_TITLE" => "Y",
        "USER_ID" => ""
    )
);?>


Статьи и новости

Подраздел предназначен для создания новостного раздела на сайте и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Новости
Новости (комплексный компонент) | news | Позволяет создать новостной раздел на сайте.
Календарь | news.calendar | Служит для формирования и вывода календаря новостей или событий.
Новость детально | news.detail | Осуществляет вывод детального описания новости.
Все новости | news.index | Выводит новости из различных инфоблоков.
Лента | news.line | Осуществляет вывод списка элементов инфоблоков с датой и заголовком со ссылкой на страницу с подробной информацией.
Список новостей | news.list | Выводит список новостей из одного информационного блока.
Список новостей для почты | news.list.mail | Служит для выбора списка новостей из одного информационного блока для формирования рассылки.


Новости (комплексный компонент)

Комплексный компонент позволяет создать новостной раздел на сайте. Доступен просмотр детальной информации, списка элементов, настройка экспорта в rss, организация голосования за новости (или другие элементы инфоблоков), настройка отзывов, вывода материалов по темам, настройки ЧПУ и многое другое.

Описание news

Компонент содержит 3 шаблона: .default, web20 и flat. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Статьи и новости > Новости.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di] Настраиваемые параметры при включенном режиме поддержки ЧПУ:
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать. Все остальные настройки из этой секции дописываются к каталогу ЧПУ.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • news - страница общего списка;
  • section - страница раздела;
  • detail - страница детального просмотра;
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить [dw]следующие параметры:[/dw][di] Настраиваемые параметры при выключенном режиме поддержки ЧПУ:
Идентификатор раздела | SECTION_ID | Указывается идентификатор раздела.
Идентификатор новости | ELEMENT_ID | Указывается идентификатор новости.
[/di] SECTION_ID, ELEMENT_ID.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип инфо-блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока. Выбрав пункт (другое)->, можно указать вручную ID информационного блока.
Инфо-блок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
Количество новостей на странице | NEWS_COUNT | Указывается количество новостей, отображаемых на одной странице.
Разрешить поиск | USE_SEARCH | [Y|N] При отмеченной опции будет выведена форма поиска. Поиск будет осуществляться только в выводимой данным компонентом информации.
Настройки RSS
Разрешить RSS USE_RSS [Y|N] При отмеченной опции будет разрешен экспорт в RSS и [dw]доступны поля [/dw] [di]Доступные поля:
Количество новостей для экспорта | NUM_NEWS | Задается количество новостей для экспорта.
Количество дней для экспорта | NUM_DAYS | Указывается количество дней для экспорта новостей.
Экспортировать в диалект Яндекса | YANDEX | [Y|N] При отмеченной опции новости будут экспортироваться в диалект Яндекса.
[/di]для спецификации настроек RSS: NUM_NEWS, NUM_DAYS и YANDEX.
Настройки голосования
Разрешить голосование USE_RATING [Y|N] При отмеченной опции посетители смогут голосовать за новости, выставляя баллы, на странице с детальной информацией. При установленной опции становятся доступными [dw]следующие поля:[/dw] [di]Доступные поля:
Максимальный балл MAX_VOTE Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
[/di] MAX_VOTE и VOTE_NAMES.
Настройка материалов по теме
Выводить материалы по теме USE_CATEGORIES [Y|N] При отмеченной опции будут выводиться материалы по теме и станут доступны [dw]дополнительные поля:[/dw] [di]Доступные поля:
Инфоблоки CATEGORY_IBLOCK Указываются инфоблоки, из которых будет происходить выборка информации. В коде задается в виде массива:
array(0=>"33",1=>"29",2=>"8",),
Код свойства | CATEGORY_CODE | Указывается код свойства, в котором хранится привязка элемента к определенному разделу (например, THEMES).
Максимальное количество материалов из одного инфоблока | CATEGORY_ITEMS_COUNT | Указывается максимальное количество материалов (элементов), которое можно выбрать из одного инфоблока.
Стиль вывода материалов из инфоблока CATEGORY_THEME Выбирается один из двух стилей вывода:
  • в виде списка
  • предпросмотр картинок
[/di] Материалы в привязке к темам создаются следующим образом:
  • создается инфоблок (например, Темы), в котором определяются будущие темы материалов в виде разделов (разделы заполнять элементами не требуется);
  • в настройках инфоблока, элементы которого предполагается привязывать к созданным темам, определятся свойство типа Привязка к разделам и выбирается инфоблок, в котором разделы являются темами;
  • для каждого из элементов этого инфоблока задается свойство привязки к теме.
Настройки отзывов
Разрешить отзывы USE_REVIEW [Y|N] При отмеченной опции будет доступен [dw]функционал отзывов.[/dw][di] Функционал отзывов:
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Параметр определяет количество выводимых на одной странице сообщений.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления отзыва в публичной части.
Использовать AJAX в диалогах | REVIEW_AJAX_POST | [Y|N] При отмеченной опции будет разрешено использование AJAX.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Задается путь к папке со смайликами относительно корня сайта.
ID форума для отзывов | FORUM_ID | Указывается идентификатор форума, в котором будут храниться отзывы пользователей.
Страница чтения темы (пусто - получить из настроек форума) | URL_TEMPLATES_READ | Указывается относительный путь к странице чтения темы на форуме. Если поле пусто, путь к странице будет получен из настроек форума.
Показать ссылку на форум | SHOW_LINK_TO_FORUM | [Y|N] При отмеченной опции на странице новости будет отображена ссылка на форум обсуждения.
Начинать тему текстом элемента | POST_FIRST_MESSAGE | [Y|N] При отмеченной опции сообщение в отзыве будет начинаться с анонса новости.
[/di]
Настройки фильтра
Показывать фильтр USE_FILTER [Y|N] При отмеченной опции становятся доступными [dw]поля настройки фильтра.[/dw][di] Поля настройки фильтра:
Фильтр | FILTER_NAME | Указывается имя переменной, в которой передается массив параметров из фильтра. Служит для определения выходящих из фильтра элементов. Если поле оставлено пустым, то используется значение по умолчанию.
Поля FILTER_FIELD_CODE Указываются поля, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | FILTER_PROPERTY_CODE | Указываются свойства, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
[/di]
Источник данных
Поле для первой сортировки новостей SORT_BY1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FROM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для первой сортировки новостей SORT_ORDER1 Задается направление для первой сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки новостей SORT_BY2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для второй сортировки новостей SORT_ORDER2 Задается направление для второй сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы.
Настройки списка
Максимальная длина анонса для вывода (только для типа текст) | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода (только для типа текст). При превышении параметра остаток текста будет отсечен.
Формат показа даты | LIST_ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Поля LIST_FIELD_CODE Указываются поля, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | LIST_PROPERTY_CODE | Указываются свойства, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Скрывать ссылку, если нет детального описания | HIDE_LINK_WHEN_NO_DETAIL | [Y|N] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
Настройки детального просмотра
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции будет выводиться название элемента.
Установить ключевые слова страницы из свойства | META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
Установить описание страницы из свойства | META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
Установить заголовок окна браузера из свойства | BROWSER_TITLE | Среди всех свойств, определенных для данного инфоблока, выбирается то, которое будет выводиться в заголовоке окна браузера.
Устанавливать канонический URL DETAIL_SET_CANONICAL_URL [Y|N] При отмеченной опции страница новости будет помечена как каноническая (т.е. будет считаться основной для поисковых систем среди ее дублей).

Каноническая ссылка строится для основного раздела элемента, а если он не задан, то для раздела с наименьшим идентификатором.
Формат показа даты | DETAIL_ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Поля FIELD_CODE Указываются поля, которые будут отображены на странице детального просмотра. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице детального просмотра. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Настройки постраничной навигации детального просмотра
Название шаблона | DETAIL_PAGER_TEMPLATE | Указывается название шаблона постраничной навигации детального просмотра. При необходимости можно указать шаблон кодом в поле ниже.
Выводить над списком | DETAIL_DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы детального просмотра.
Выводить под списком | DETAIL_DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы детального просмотра.
Название категорий | DETAIL_PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Дополнительные настройки
Устанавливать в заголовках ответа время модификации страницы | SET_LAST_MODIFIED | [Y|N] При отмеченной опции http-ответ сервера будет содержать время последнего изменения страницы (заголовок Last-Modified [image]).
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия или заголовки (если заданы в настройках SEO) разделов.
Включать название элемента в цепочку навигации | ADD_ELEMENT_CHAIN | [Y|N] При отмеченной опции название или заголовок (если задан в настройках SEO) элемента будет добавлен в цепочку навигации.
Использовать дополнительное ограничение доступа USE_PERMISSIONS [Y|N] При [dw]отмеченной опции[/dw][di] Станет активным поле Группы пользователей, имеющие доступ к детальной информации.
Группы пользователей, имеющие доступ к детальной информации GROUP_PERMISSIONS Указываются группы пользователей, имеющие доступ к детальной информации.
[/di] будет ограничен доступ к детальной информации элементов инфоблока.
Строгая проверка раздела STRICT_SECTION_CHECK [Y|N] При отмеченной опции будет выполняться строгая проверка принадлежности элемента к разделу. Таким образом, если при просмотре элемента в адресной строке указать неверный раздел, то будет выдана 404-я ошибка.
Если опцию не отмечать, то нужный элемент будет показан в любом случае.
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будут выведены даты элементов.
Выводить изображение для анонса | DISPLAY_PICTURE | [Y|N] При отмеченной опции для элемента будут выведены изображения (анонс и детальная картинка), если они заданы. Если флаг снят, то никакое изображение показано не будет.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.
В качестве рейтинга показывать* DISPLAY_AS_RATING Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • Рейтинг (rating);
  • Среднее значение (vote_avg).
Количество тегов* | TAGS_CLOUD_ELEMENTS | Указывается количество тегов, отображаемых в облаке.
Период, в течение которого считать тег новым (дней)* | PERIOD_NEW_TAGS | Указывается период (количество дней), в течение которого тег считается новым.
Максимальный размер шрифта (px)* | FONT_MAX | Указывается максимальный размер шрифта отображения тегов (в пикселах).
Минимальный размер шрифта (px)* | FONT_MIN | Указывается минимальный размер шрифта отображения тегов (в пикселах).
Цвет более позднего тега (пример: "C0C0C0")* | COLOR_NEW | Указывается код цвета тегов, дата создания которых наиболее поздняя (пример: "C0C0C0").
Цвет более раннего тега (пример: "FEFEFE")* | COLOR_OLD | Указывается код цвета тегов, дата создания которых наиболее ранняя (пример: "FEFEFE").
Ширина облака тегов (пример: "100%" или "100px", "100pt", "100in")* | TAGS_CLOUD_WIDTH | Указывается ширина облака тегов (пример: "100%" или "100px", "100pt", "100in").
Отображать панель соц. закладок USE_SHARE Разрешает отображение панели закладок соцсетей при детальном просмотре новости.При выбранной опции становятся активными [dw]дополнительные поля.[/dw][di] Дополнительные поля:
Используемые соц. закладки и сети | SHARE_HANDLERS | Выбор сетей, которые будут отображаться в закладке соцсетей.
Логин для bit.ly | SHARE_SHORTEN_URL_LOGIN | Логин для сервиса сокращений.
Ключ для для bit.ly | SHARE_SHORTEN_URL_KEY | Пароль для сервиса сокращений.
[/di]
Не раскрывать панель соц. закладок по умолчанию | SHARE_HIDE | Если опция выбрана, то список соц сетей будет свёрнута под общим значком.
Шаблон компонента панели соц. закладок | SHARE_TEMPLATE | Указывается имя шаблона, если используется не системный шаблон.
Свойство с изображениями для слайдера** | SLIDER_PROPERTY | Указывается свойство, которые будет использовано для показа картинок в слайдере.
* - поля, доступные для шаблона web20.
** - поля, доступные для шаблона flat.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Настройка постраничной навигации
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда. По умолчанию выключено.
Название шаблона | PAGER_TEMPLATE | Указывается название шаблона постраничной навигации.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости. По умолчанию выключено.
Включить обработку ссылок PAGER_BASE_LINK_ENABLE [Y|N] При отмеченной опции доступна обработка ссылок для постраничной навигации. Станут активны [dw]дополнительные поля.[/dw][di] Дополнительные поля:
Url для построения ссылок (по умолчанию - автоматически) | PAGER_BASE_LINK | Задается адрес для построения ссылок. Если в параметре ничего не указывать, то адрес будет построен автоматически.
Имя массива с переменными для построения ссылок в постраничной навигации | PAGER_PARAMS_NAME | Задается имя переменной, в которой передается массив с переменными для построения ссылок компонентом постраничной навигации.
[/di]
Настройки 404 ошибки
Устанавливать статус 404 | SET_STATUS_404 | [Y|N] Опция служит для включения обработки ошибки 404 в компоненте.
Показ специальной страницы SHOW_404 [Y|N] При отмеченной опции будет показана [dw]специальная страница[/dw][di] Станет активным поле:
Страница для показа (по умолчанию /404.php) FILE_404 Задается адрес страницы, которая будет отображаться при возникновении ошибки 404.
[/di] в случае возникновения ошибки 404, в противном случае - будет отображено [dw]специальное сообщение.[/dw][di] Станет активным поле:
Сообщение для показа (по умолчанию из компонента) MESSAGE_404 Задается сообщение, которое будет показано в случае возникновения ошибки 404. Если ничего не указывать, то будет использоваться стандартное сообщение из компонента.
[/di]

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:news","",Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "SEF_MODE" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "news",
        "IBLOCK_ID" => "1",
        "NEWS_COUNT" => "20",
        "USE_SEARCH" => "Y",
        "USE_RSS" => "Y",
        "USE_RATING" => "Y",
        "USE_CATEGORIES" => "Y",
        "USE_REVIEW" => "Y",
        "USE_FILTER" => "Y",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "CHECK_DATES" => "Y",
        "PREVIEW_TRUNCATE_LEN" => "",
        "LIST_ACTIVE_DATE_FORMAT" => "d.m.Y",
        "LIST_FIELD_CODE" => Array(),
        "LIST_PROPERTY_CODE" => Array(),
        "HIDE_LINK_WHEN_NO_DETAIL" => "Y",
        "DISPLAY_NAME" => "Y",
        "META_KEYWORDS" => "-",
        "META_DESCRIPTION" => "-",
        "BROWSER_TITLE" => "-",
        "DETAIL_SET_CANONICAL_URL" => "Y",
        "DETAIL_ACTIVE_DATE_FORMAT" => "d.m.Y",
        "DETAIL_FIELD_CODE" => Array(),
        "DETAIL_PROPERTY_CODE" => Array(),
        "DETAIL_DISPLAY_TOP_PAGER" => "Y",
        "DETAIL_DISPLAY_BOTTOM_PAGER" => "Y",
        "DETAIL_PAGER_TITLE" => "Страница",
        "DETAIL_PAGER_TEMPLATE" => "",
        "DETAIL_PAGER_SHOW_ALL" => "Y",
        "STRICT_SECTION_CHECK" => "Y",
        "SET_TITLE" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "ADD_ELEMENT_CHAIN" => "N",
        "SET_LAST_MODIFIED" => "Y",
        "PAGER_BASE_LINK_ENABLE" => "Y",
        "SET_STATUS_404" => "Y",
        "SHOW_404" => "Y",
        "MESSAGE_404" => "",
        "PAGER_BASE_LINK" => "",
        "PAGER_PARAMS_NAME" => "arrPager",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => Array("1"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "CACHE_GROUPS" => "Y",
        "DISPLAY_TOP_PAGER" => "Y",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Новости",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_TEMPLATE" => "",
        "PAGER_DESC_NUMBERING" => "N",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "FILTER_NAME" => "",
        "FILTER_FIELD_CODE" => Array(),
        "FILTER_PROPERTY_CODE" => Array(),
        "NUM_NEWS" => "20",
        "NUM_DAYS" => "30",
        "YANDEX" => "Y",
        "MAX_VOTE" => "5",
        "VOTE_NAMES" => Array("0", "1", "2", "3", "4"),
        "CATEGORY_IBLOCK" => Array(),
        "CATEGORY_CODE" => "CATEGORY",
        "CATEGORY_ITEMS_COUNT" => "5",
        "MESSAGES_PER_PAGE" => "10",
        "USE_CAPTCHA" => "Y",
        "REVIEW_AJAX_POST" => "Y",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "FORUM_ID" => "1",
        "URL_TEMPLATES_READ" => "",
        "SHOW_LINK_TO_FORUM" => "Y",
        "POST_FIRST_MESSAGE" => "Y",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "detail" => "#ELEMENT_ID#/",
            "news" => "search/",
            "section" => "rss/",
        ),
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "VARIABLE_ALIASES" => Array(
            "detail" => Array(),
            "news" => Array(),
            "section" => Array(),
        ),
        "USE_SHARE" => "Y",
        "SHARE_HIDE" => "Y",
        "SHARE_TEMPLATE" => "",
        "SHARE_HANDLERS" => array("delicious", "lj", "twitter"),
        "SHARE_SHORTEN_URL_LOGIN" => "",
        "SHARE_SHORTEN_URL_KEY" => "",
        )
);?>


Список новостей

Одностраничный компонент выводит список новостей из одного информационного блока.

Описание news.list

Одностраничный компонент выводит список новостей из одного информационного блока (в качестве результата возвращает ID показанных элементов). Настройки позволяют кастомизировать вывод полей элементов в списке, управлять постраничной навигацией, выбирать формат даты, управлять настройками кеширования и т.д. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Статьи и новости > Список новостей.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
Количество новостей на странице | NEWS_COUNT | Указывается количество новостей, отображаемых на одной странице. По умолчанию - 20.
Источник данных
Поле для первой сортировки новостей SORT_BY1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FROM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для первой сортировки новостей.
Направление для первой сортировки новостей SORT_ORDER1 Задается направление для первой сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки новостей SORT_BY2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FROM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для второй сортировки новостей.
Направление для второй сортировки новостей SORT_ORDER2 Задается направление для второй сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Фильтр | FILTER_NAME | Указывается имя переменной, в которой передается массив параметров из фильтра. Служит для определения выходящих из фильтра элементов. Если поле оставлено пустым, то используется значение по умолчанию.
Поля FIELD_CODE Указываются поля, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы.
Шаблоны ссылок
URL страницы детального просмотра (по умолчанию - из настроек инфоблока) | DETAIL_URL | Задается адрес, ведущий на страницу с детальной информацией элемента раздела (по умолчанию - из настроек инфоблока).
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Дополнительные настройки
Максимальная длина анонса для вывода (только для типа текст) | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода (только для типа текст). При превышении параметра остаток текста будет отсечен.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Устанавливать заголовок окна браузера | SET_BROWSER_TITLE | [Y|N] При отмеченной опции будет установлен заголовок окна браузера по заданному SEO-шаблону META TITLE (см. закладку "SEO" в инфоблоке).
Устанавливать ключевые слова страницы | SET_META_KEYWORDS | [Y|N] При отмеченной опции будут установлены ключевые слова страницы по заданному SEO-шаблону META KEYWORDS (см. закладку "SEO" в инфоблоке).
Устанавливать описание страницы | SET_META_DESCRIPTION | [Y|N] При отмеченной опции будет установлено описание страницы по заданному SEO-шаблону META DESCRIPTION (см. закладку "SEO" в инфоблоке).
Устанавливать в заголовках ответа время модификации страницы | SET_LAST_MODIFIED | [Y|N] При отмеченной опции http-ответ сервера будет содержать время последнего изменения страницы (заголовок Last-Modified [image]).
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Скрывать ссылку, если нет детального описания | HIDE_LINK_WHEN_NO_DETAIL | [Y|N] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
ID раздела | PARENT_SECTION | Указывается числовой код раздела инфоблока, из которого будут выбраны новости. Поле может быть оставлено пустым, если указан Код раздела.
Код раздела | PARENT_SECTION_CODE | Указывается символьный код раздела инфоблока, из которого будут выбраны новости. Поле может быть оставлено пустым, если указан ID раздела.
Показывать элементы подразделов раздела | INCLUDE_SUBSECTIONS | [Y|N] При отмеченной опции будут отображены элементы подразделов раздела.
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будут выведены даты элементов.
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции для каждого элемента будет выведено его название.
Выводить изображение для анонса | DISPLAY_PICTURE | [Y|N] При отмеченной опции будут выведены изображения для элемента, если они заданы.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Настройки постраничной навигации
Шаблон постраничной навигации | PAGER_TEMPLATE | Указывается название шаблона постраничной навигации.
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда. По умолчанию выключено.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости. По умолчанию выключено.
Включить обработку ссылок PAGER_BASE_LINK_ENABLE [Y|N] При отмеченной опции доступна обработка ссылок для постраничной навигации. Становятся активными [dw]дополнительные поля.[/dw][di] Дополнительные поля:
Url для построения ссылок (по умолчанию - автоматически) | PAGER_BASE_LINK | Задается адрес для построения ссылок. Если в параметре ничего не указывать, то адрес будет построен автоматически.
Имя массива с переменными для построения ссылок в постраничной навигации | PAGER_PARAMS_NAME | Задается имя переменной, в которой передается массив с переменными для построения ссылок компонентом постраничной навигации.
[/di]
Настройки 404 ошибки
Устанавливать статус 404 | SET_STATUS_404 | [Y|N] Опция служит для включения обработки ошибки 404 в компоненте.
Показ специальной страницы SHOW_404 [Y|N] При отмеченной опции будет показана [dw]специальная страница[/dw][di] Станет активным поле:
Страница для показа (по умолчанию /404.php) FILE_404 Задается адрес страницы, которая будет отображаться при возникновении ошибки 404.
[/di] в случае возникновения ошибки 404, в противном случае - будет отображено [dw]специальное сообщение.[/dw][di] Станет активным поле:
Сообщение для показа (по умолчанию из компонента) MESSAGE_404 Задается сообщение, которое будет показано в случае возникновения ошибки 404. Если ничего не указывать, то будет использоваться стандартное сообщение из компонента.
[/di]

Внимание! При передаче символьного кода раздела (SECTION_CODE) выполняется дополнительная проверка на принадлежность раздела к инфоблоку, указанному в параметре IBLOCK_ID и активность с учетом вышележащих разделов. При передаче идентификатора раздела (SECTION_ID) такая проверка не производится.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:news.list","",Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "news",
        "IBLOCK_ID" => "3",
        "NEWS_COUNT" => "20",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "FILTER_NAME" => "",
        "FIELD_CODE" => Array("ID"),
        "PROPERTY_CODE" => Array("DESCRIPTION"),
        "CHECK_DATES" => "Y",
        "DETAIL_URL" => "",
        "PREVIEW_TRUNCATE_LEN" => "",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "SET_TITLE" => "Y",
        "SET_BROWSER_TITLE" => "Y",
        "SET_META_KEYWORDS" => "Y",
        "SET_META_DESCRIPTION" => "Y",
        "SET_LAST_MODIFIED" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "HIDE_LINK_WHEN_NO_DETAIL" => "Y",
        "PARENT_SECTION" => "",
        "PARENT_SECTION_CODE" => "",
        "INCLUDE_SUBSECTIONS" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "CACHE_GROUPS" => "Y",
        "DISPLAY_TOP_PAGER" => "Y",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Новости",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_TEMPLATE" => "",
        "PAGER_DESC_NUMBERING" => "Y",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "PAGER_BASE_LINK_ENABLE" => "Y",
        "SET_STATUS_404" => "Y",
        "SHOW_404" => "Y",
        "MESSAGE_404" => "",
        "PAGER_BASE_LINK" => "",
        "PAGER_PARAMS_NAME" => "arrPager",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "AJAX_OPTION_ADDITIONAL" => ""
    )
);?>


Новость детально

Одностраничный компонент, осуществляющий вывод детального описание новости. Компонент стандартный и входит в дистрибутив модуля.

Описание news.detail

В визуальном редакторе компонент расположен по пути: Контент > Статьи и новости > Новость детально.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
ID новости | ELEMENT_ID | Указывается числовой код, в котором передается идентификатор новости. Поле может быть оставлено пустым, если указан Код новости.
Код новости | ELEMENT_CODE | Указывается символьный код новости, из которого будут выбраны новости. Поле может быть оставлено пустым, если указан ID новости.
Источник данных
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы.
Поля FIELD_CODE Указываются поля, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl, либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl, либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Шаблоны ссылок
URL страницы просмотра списка элементов (по умолчанию - из настроек инфоблока) | IBLOCK_URL | Указывается адрес страницы просмотра списка элементов (по умолчанию - из настроек инфоблока).
URL страницы детального просмотра (по умолчанию - из настроек инфоблока) | DETAIL_URL | Указывается адрес страницы детального просмотра элемента (по умолчанию - из настроек инфоблока).
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлен заголовок элемента.
Устанавливать канонический URL SET_CANONICAL_URL [Y|N] При отмеченной опции страница новости будет помечена как каноническая (т.е. будет считаться основной для поисковых систем среди ее дублей).

Каноническая ссылка строится для основного раздела элемента, а если он не задан, то для раздела с наименьшим идентификатором.
Устанавливать заголовок окна браузера SET_BROWSER_TITLE [Y|N] При отмеченной опции будет установлен заголовок окна браузера по заданному SEO-шаблону META TITLE (см. закладку "SEO" в инфоблоке) или из [dw]свойства.[/dw][di] Становится активным поле:
Установить заголовок окна браузера из свойства BROWSER_TITLE Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится заголовок окна браузера.
[/di]
Устанавливать ключевые слова страницы SET_META_KEYWORDS [Y|N] При отмеченной опции будут установлены ключевые слова страницы по заданному SEO-шаблону META KEYWORDS (см. закладку "SEO" в инфоблоке) или из [dw]свойства.[/dw][di]Становится активным поле:
Установить ключевые слова страницы из свойства META_KEYWORDS Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
[/di]
Устанавливать описание страницы SET_META_DESCRIPTION [Y|N] При отмеченной опции будет установлено описание страницы по заданному SEO-шаблону META DESCRIPTION (см. закладку "SEO" в инфоблоке) или из [dw]свойства.[/dw][di] [di]Становится активным поле:
Установить описание страницы из свойства META_DESCRIPTION Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
[/di]
Устанавливать в заголовках ответа время модификации страницы | SET_LAST_MODIFIED | [Y|N] При отмеченной опции http-ответ сервера будет содержать время последнего изменения страницы (заголовок Last-Modified [image]).
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия или заголовки (если заданы в настройках SEO) разделов.
Включать название элемента в цепочку навигации | ADD_ELEMENT_CHAIN | [Y|N] При отмеченной опции название или заголовок (если задан в настройках SEO) элемента будет добавлен в цепочку навигации.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Использовать дополнительное ограничение доступа USE_PERMISSIONS [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. При [dw]отмеченной опции[/dw][di] Станет активным поле Группы пользователей, имеющие доступ к детальной информации.
Группы пользователей, имеющие доступ к детальной информации GROUP_PERMISSIONS Указываются группы пользователей, имеющие доступ к детальной информации.
[/di] будет ограничен доступ к детальной информации.
Строгая проверка раздела для показа элемента STRICT_SECTION_CHECK [Y|N] При отмеченной опции будет выполняться строгая проверка принадлежности элемента к разделу. Таким образом, если при просмотре элемента в адресной строке указать неверный раздел, то будет выдана 404-я ошибка.
Если опцию не отмечать, то нужный элемент будет показан в любом случае.
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будут выведены даты элементов.
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции для каждого элемента будет выведено его название.
Выводить детальное изображение | DISPLAY_PICTURE | [Y|N] При отмеченной опции будут выведены детальные изображения для элемента, если они заданы.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.
Отображать панель соц. закладок USE_SHARE [Y|N] При отмеченной опции на странице детального просмотра новости будет отображена [dw]панель социальных закладок.[/dw][di] Поля панели социальных закладок:
Не раскрывать панель соц. закладок по умолчанию* | SHARE_HIDE | [Y|N] При отмеченной опции список социальных сетей будет свернут под общим значком.
Шаблон компонента панели соц. закладок* | SHARE_TEMPLATE | Указывается имя шаблона, если используется несистемный шаблон.
Используемые соц. закладки и сети* | SHARE_HANDLERS | Задается перечень используемых соц. закладок и сетей.
Логин для bit.ly* | SHARE_SHORTEN_URL_LOGIN | Логин для сервиса сокращений.
Ключ для для bit.ly* | SHARE_SHORTEN_URL_KEY | Пароль для сервиса сокращений.
[/di]
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Настройки постраничной навигации
Шаблон постраничной навигации | PAGER_TEMPLATE | Указывается название шаблона постраничной навигации.
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции будет отображена ссылка для просмотра новости целиком, без использования постраничной навигации. По умолчанию выключено.
Включить обработку ссылок PAGER_BASE_LINK_ENABLE [Y|N] При отмеченной опции доступна обработка ссылок для постраничной навигации.Станут активны [dw]дополнительные поля.[/dw][di] Дополнительные поля:
Url для построения ссылок (по умолчанию - автоматически) | PAGER_BASE_LINK | Задается адрес для построения ссылок. Если в параметре ничего не указывать, то адрес будет построен автоматически.
Имя массива с переменными для построения ссылок в постраничной навигации | PAGER_PARAMS_NAME | Задается имя переменной, в которой передается массив с переменными для построения ссылок компонентом постраничной навигации.
[/di]
Настройки 404 ошибки
Устанавливать статус 404 | SET_STATUS_404 | [Y|N] Опция служит для включения обработки ошибки 404 в компоненте.
Показ специальной страницы SHOW_404 [Y|N] При отмеченной опции будет показана [dw]специальная страница[/dw][di] Станет активным поле:
Страница для показа (по умолчанию /404.php) FILE_404 Задается адрес страницы, которая будет отображаться при возникновении ошибки 404.
[/di] в случае возникновения ошибки 404, в противном случае - будет отображено [dw]специальное сообщение.[/dw][di] Станет активным поле:
Сообщение для показа (по умолчанию из компонента) MESSAGE_404 Задается сообщение, которое будет показано в случае возникновения ошибки 404. Если ничего не указывать, то будет использоваться стандартное сообщение из компонента.
[/di]

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:news.detail","",Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "USE_SHARE" => "Y",
        "SHARE_HIDE" => "N",
        "SHARE_TEMPLATE" => "",
        "SHARE_HANDLERS" => array("delicious"),
        "SHARE_SHORTEN_URL_LOGIN" => "",
        "SHARE_SHORTEN_URL_KEY" => "",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "news",
        "IBLOCK_ID" => "3",
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "ELEMENT_CODE" => "",
        "CHECK_DATES" => "Y",
        "FIELD_CODE" => Array("ID"),
        "PROPERTY_CODE" => Array("DESCRIPTION"),
        "IBLOCK_URL" => "news.php?ID=#IBLOCK_ID#\"",
        "DETAIL_URL" => "",
        "SET_TITLE" => "Y",
        "SET_CANONICAL_URL" => "Y",
        "SET_BROWSER_TITLE" => "Y",
        "BROWSER_TITLE" => "-",
        "SET_META_KEYWORDS" => "Y",
        "META_KEYWORDS" => "-",
        "SET_META_DESCRIPTION" => "Y",
        "META_DESCRIPTION" => "-",
        "SET_STATUS_404" => "Y",
        "SET_LAST_MODIFIED" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "ADD_ELEMENT_CHAIN" => "N",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => Array("1"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y",
        "DISPLAY_TOP_PAGER" => "Y",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Страница",
        "PAGER_TEMPLATE" => "",
        "PAGER_SHOW_ALL" => "Y",
        "PAGER_BASE_LINK_ENABLE" => "Y",
        "SHOW_404" => "Y",
        "MESSAGE_404" => "",
        "STRICT_SECTION_CHECK" => "Y",
        "PAGER_BASE_LINK" => "",
        "PAGER_PARAMS_NAME" => "arrPager",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Лента

Описание news.line

Одностраничный компонент, осуществляющий вывод списка элементов инфоблоков с датой и заголовком со ссылкой на страницу с подробной информацией. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Статьи и новости > Лента.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCKS | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
Количество новостей на странице | NEWS_COUNT | Указывается количество новостей, отображаемых на одной странице.
Источник данных
Поля FIELD_CODE Данные элемента, которые могут выводиться в ленте новостей. (Требуется кастомизация шаблона.)
  • ID – ID;
  • CODE – символьный код;
  • XML_ID – XML_ID;
  • NAME – название;
  • TAGS – теги;
  • SORT – сортировка;
  • PREVIEW_TEXT – текст анонса;
  • PREVIEW_PICTURE – картинка анонса;
  • DETAIL_TEXT – детальный текст;
  • DETAIL_PICTURE – детальная картинка.
  • DATE_ACTIVE_FROM – начало активности (дата);
  • ACTIVE_FROM – начало активности (время);
  • DATE_ACTIVE_TO – окончание активности (дата);
  • ACTIVE_TO – окончание активности (время);
  • SHOW_COUNTER – количество показов;
  • SHOW_COUNTER_START – дата первого показа;
  • IBLOCK_TYPE_ID – тип информаионного блока;
  • IBLOCK_ID – ID информационного блока;
  • IBLOCK_CODE – символьный код информационного блока;
  • IBLOCK_NAME – название информационного блока;
  • IBLOCK_EXTERNAL_ID – внешний код информационного блока;
  • DATE_CREATE – дата создания;
  • CREATED_BY – кем создан (ID);
  • CREATED_USER_NAME – дата изменения;
  • MODIFIED_BY – кем изменен (ID);
  • USER_NAME – кем изменен (имя).
Поле для первой сортировки новостей SORT_BY1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для первой сортировки новостей.
Направление для первой сортировки новостей SORT_ORDER1 Задается направление для первой сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки новостей SORT_BY2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для второй сортировки новостей.
Направление для второй сортировки новостей SORT_ORDER2 Задается направление для второй сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Задается адрес, ведущий на страницу с детальной информацией элемента раздела (по умолчанию - из настроек инфоблока).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:news.line","",Array(
        "IBLOCK_TYPE" => "news",
        "IBLOCKS" => Array("3"),
        "NEWS_COUNT" => "20",
        "FIELD_CODE" => Array("ID", "CODE"),
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "DETAIL_URL" => "news_detail.php?ID=#ELEMENT_ID#",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "300",
        "CACHE_GROUPS" => "Y"
    )
);?>


Список новостей для почты

Описание news.list.mail

Одностраничный компонент выводит список новостей для почты из одного информационного блока. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Статьи и новости > Список новостей для почты.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
Количество новостей на странице | NEWS_COUNT | Указывается количество новостей, отображаемых на одной странице.
Не отправлять выпуск, если недостаточно указанного количества новых элементов PREVENT_SEND_IF_NO_NEWS [Y|N] При отмеченной опции будут выбираться элементы, созданные с момента последней отправки периодического выпуска. Причем, если количество элементов меньше указанного в настройке NEWS_COUNT (Количество новостей на странице), то выпуск не будет отправлен. При выборе данной опции станет доступно [dw]дополнительное поле.[/dw][di] Дополнительное поле:
Код периодического выпуска рассылки SENDER_CHAIN_ID Указывается код периодического выпуска Email-маркетинга, у которого будет браться дата последней отправки для поиска новых элементов с этой даты. Обычно значение этой настройки остается по умолчанию.
[/di]
Источник данных
Поле для первой сортировки новостей SORT_BY1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для первой сортировки новостей.
Направление для первой сортировки новостей SORT_ORDER1 Задается направление для первой сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки новостей SORT_BY2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для второй сортировки новостей.
Направление для второй сортировки новостей SORT_ORDER2 Задается направление для второй сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Фильтр | FILTER_NAME | Указывается имя переменной, в которой передается массив параметров из фильтра. Служит для определения выходящих из фильтра элементов. Если поле оставлено пустым, то используется значение по умолчанию.
Поля FIELD_CODE Указываются поля, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы.
Шаблоны ссылок
URL страницы детального просмотра (по умолчанию - из настроек инфоблока) | DETAIL_URL | Задается адрес, ведущий на страницу с детальной информацией элемента раздела (по умолчанию - из настроек инфоблока).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кешировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Дополнительные настройки
Максимальная длина анонса для вывода (только для типа текст) | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода (только для типа текст). При превышении параметра остаток текста будет отсечен.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Скрывать ссылку, если нет детального описания | HIDE_LINK_WHEN_NO_DETAIL | [Y|N] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
ID раздела | PARENT_SECTION | Указывается числовой код раздела инфоблока, из которого будут выбраны новости. Поле может быть оставлено пустым, если указан Код раздела.
Код раздела | PARENT_SECTION_CODE | Указывается символьный код раздела инфоблока, из которого будут выбраны новости. Поле может быть оставлено пустым, если указан ID раздела.
Показывать элементы подразделов раздела | INCLUDE_SUBSECTIONS | [Y|N] При отмеченной опции будут отображены элементы подразделов раздела.
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будут выведены даты элементов.
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции для каждого элемента будет выведено его название.
Выводить изображение для анонса | DISPLAY_PICTURE | [Y|N] При отмеченной опции будут выведены изображения для элемента, если они заданы.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:news.list.mail",
    "",
    Array(
        "IBLOCK_TYPE" => "news",
        "IBLOCK_ID" => "3",
        "NEWS_COUNT" => "20",
        "PREVENT_SEND_IF_NO_NEWS" => "Y",
        "SENDER_CHAIN_ID" => "{#SENDER_CHAIN_ID#}",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "FILTER_NAME" => "",
        "FIELD_CODE" => array("",""),
        "PROPERTY_CODE" => array("",""),
        "CHECK_DATES" => "Y",
        "DETAIL_URL" => "/news/detail.php?ELEMENT_ID=#ELEMENT_ID#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_FILTER" => "N",
        "PREVIEW_TRUNCATE_LEN" => "",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "HIDE_LINK_WHEN_NO_DETAIL" => "Y",
        "PARENT_SECTION" => "",
        "PARENT_SECTION_CODE" => "",
        "INCLUDE_SUBSECTIONS" => "Y",
        "DISPLAY_DATE" => "Y",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y"
    )
);?>


Календарь

Описание news.calendar

Одностраничный компонент, который служит для формирования и вывода календаря новостей или событий. Настройки позволяют настраивать внешний вид календаря, указывать его тип, управлять шаблоном, кешированием и т.д. Компонент содержит два шаблона: .default и compact. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Статьи и новости > Календарь.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
Имя переменной для месяца | MONTH_VAR_NAME | Задается имя переменной, в которой передается номер месяца.
Имя переменной для года | YEAR_VAR_NAME | Задается имя переменной, в которой передается номер года.
Начало недели | WEEK_START | Указывается день начала отсчета недели.
Внешний вид
Показывать переход по годам | SHOW_YEAR | [Y|N] При отмеченной опции будет выведена ссылка на предыдущий год.
Показывать время новостей | SHOW_TIME | [Y|N] При отмеченной опции рядом с названием элемента будет выведено время начала активности, если оно определено для элемента.
Длина заголовка (0 - не ограничивать) | TITLE_LEN | Указывается длина заголовка новостей, выводимых в календаре (0 - не ограничивать).
Показывать текущий месяц и год | SHOW_CURRENT_DATE | [Y|N] При отмеченной опции будут выведены текущий месяц и год над календарем в правом углу.
Показывать выпадающий список месяцев | SHOW_MONTH_LIST | [Y|N] При отмеченной опции будет показан выпадающий список месяцев. В противном случае только ссылки на предыдущий и следующий месяцы.
Количество новостей в день (0 - не ограничивать) | NEWS_COUNT | Указывается количество новостей, отображаемых в одной ячейки календаря за один день (0 - не ограничивать). Если число отлично от нуля, то будут выбраны элементы с меньшим временем начала активности. Если время не определено, то элементы будут выбраны по индексу сортировки.
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Задается адрес, ведущий на страницу с содержимым элемента инфоблока в календаре.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Поле даты DATE_FIELD Указывается поле, по которому будет происходить сортировка новостей (событий) по датам:
  • DATE_ACTIVE_FROM - Дата активности с;
  • DATE_ACTIVE_TO - Дата активности по;
  • TIMESTAMP_X - Время последнего изменения;
  • DATE_CREATE - Дата создания.
Тип календаря TYPE Указывается тип календаря:
  • Новостной (NEWS) - освещает наступившие новости (события) (события текущего месяца будут выведены, даже если дата события еще не наступила);
  • Событийный (EVENTS) - освещает новости (события) ненаступившей даты.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет выведен текущий месяц и год.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:news.calendar","",Array(
        "AJAX_MODE" => "N",
        "IBLOCK_TYPE" => "news",
        "IBLOCK_ID" => "3",
        "MONTH_VAR_NAME" => "month",
        "YEAR_VAR_NAME" => "year",
        "WEEK_START" => "1",
        "DATE_FIELD" => "DATE_ACTIVE_FROM",
        "TYPE" => "EVENTS",
        "SHOW_YEAR" => "Y",
        "SHOW_TIME" => "Y",
        "TITLE_LEN" => "0",
        "SET_TITLE" => "Y",
        "SHOW_CURRENT_DATE" => "Y",
        "SHOW_MONTH_LIST" => "Y",
        "NEWS_COUNT" => "0",
        "DETAIL_URL" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "AJAX_OPTION_ADDITIONAL" => ""
    )
);?>


Все новости

Описание news.index

Одностраничный компонент, позволяющий вывести новости из различных инфоблоков. Ссылка на самом названии инфоблока переводит на страницу, где отображаются элементы только этого инфоблока. Ссылки на элементах переводят на страницу с детальной информацией по элементу. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Статьи и новости > Все новости.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационных блоков | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCKS | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
Количество новостей в каждом блоке | NEWS_COUNT | Указывается количество отображаемых новостей, выводимых из каждого инфоблока.
Источник данных
Поле для cортировки информационных блоков IBLOCK_SORT_BY Поле для сортировки информационных блоков:
  • Сортировка (SORT);
  • Название (NAME);
  • Идентификатор (ID).
Направление для cортировки информационных блоков IBLOCK_SORT_ORDER Задается направление для сортировки информационных блоков:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для первой сортировки новостей SORT_BY1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для первой сортировки новостей.
Направление для первой сортировки новостей SORT_ORDER1 Задается направление для первой сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки новостей SORT_BY2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для второй сортировки новостей.
Направление для второй сортировки новостей SORT_ORDER2 Задается направление для второй сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поля | FIELD_CODE | Указываются поля, которые будут отображены на странице.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице.
Имя массива со значениями фильтра для фильтрации элементов | FILTER_NAME | Задается имя переменной, в которой будет содержаться массив из фильтра для фильтрации элементов.
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | IBLOCK_URL | Задается адрес, ведущий на страницу с содержимым раздела.
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Задается адрес, ведущий на страницу с детальной информацией элемента раздела (по умолчанию - из настроек инфоблока).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:news.index","",Array(
        "IBLOCK_TYPE" => "news",
        "IBLOCKS" => Array("3"),
        "NEWS_COUNT" => "5",
        "IBLOCK_SORT_BY" => "SORT",
        "IBLOCK_SORT_ORDER" => "ASC",
        "SORT_BY1" => "ID",
        "SORT_ORDER1" => "ASC",
        "SORT_BY2" => "ID",
        "SORT_ORDER2" => "ASC",
        "FIELD_CODE" => Array(),
        "PROPERTY_CODE" => Array(),
        "FILTER_NAME" => "arrFilter",
        "IBLOCK_URL" => "news.php?ID=#IBLOCK_ID#",
        "DETAIL_URL" => "news_detail.php?ID=#ELEMENT_ID#",
        "ACTIVE_DATE_FORMAT" => "d-m-Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y"
    )
);?>


Фотогалерея

Подраздел предназначен для размещения на сайте полнофункциональной фотогалереи и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Фотогалерея
Фотогалерея (комплексный компонент) | photo | Позволяет получить полнофункциональную фотогалерею, создавая физически только одну страницу.
Фотография детально | photo.detail | Выводит детальную информацию по фотографии.
Случайное фото | photo.random | Служит для показа одной произвольной фотографии.
Фотографии раздела | photo.section | Выводит все фотографии из выбранного раздела.
Разделы с TOP'ом фотографий | photo.sections.top | Служит для вывода TOP'а фотографий, сгруппированных по разделам.


Фотогалерея (комплексный компонент)

Описание photo

Комплексный компонент Фотогалерея позволяет получить полнофункциональную фотогалерею, создавая физически только одну страницу. Настройки компонента дают возможность гибко управлять параметрами фотогалереи. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Фотогалерея > Фотогалерея.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока. После выбора инфоблока автоматически произойдёт перезагрузка формы для вывода списка инфоблоков выбранного типа. Если автоматическая перезагрузка не произошла, нажмите кнопку ОК.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока выбирается нужный информационный блок, фотографии из которого будут выводиться. Если вместо инфоблока будет выбрано другое, то в поле ниже необходимо указать идентификатор нужного инфоблока и нажать кнопку ОК.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di] Настраиваемые параметры при включенном режиме поддержки ЧПУ:
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • sections_top - страница списка разделов с TOP\'ом фотографий;
  • section - страница раздела фотогалереи;
  • detail - страница детального просмотра фотографии.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить [dw]следующие параметры:[/dw][di] Настраиваемые параметры при выключенном режиме поддержки ЧПУ:
Идентификатор раздела | SECTION_ID | Указывается идентификатор раздела.
Идентификатор элемента | ELEMENT_ID | Указывается идентификатор элемента.
[/di] SECTION_ID, ELEMENT_ID.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Фотогалерея.
Устанавливать в заголовках ответа время модификации страницы | SET_LAST_MODIFIED | [Y|N] При отмеченной опции http-ответ сервера будет содержать время последнего изменения страницы (заголовок Last-Modified [image]).
Использовать дополнительное ограничение доступа USE_PERMISSIONS [Y|N] При [dw]отмеченной опции[/dw][di] Станет активным поле Группы пользователей, имеющие доступ к детальной информации.
Группы пользователей, имеющие доступ к детальной информации GROUP_PERMISSIONS Указываются группы пользователей, имеющие доступ к детальной информации.
[/di] будет ограничен доступ к детальной информации элементов инфоблока.
Настройки голосования
Разрешить голосование USE_RATING [Y|N] При отмеченной опции посетители смогут голосовать за фотографии, выставляя баллы, на странице с детальной информацией. При установленной опции становятся доступными [dw]следующие поля:[/dw] [di]Доступные поля:
Максимальный балл MAX_VOTE Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
[/di] MAX_VOTE и VOTE_NAMES.
Настройки отзывов
Разрешить отзывы USE_REVIEW [Y|N] При отмеченной опции будет доступен [dw]функционал отзывов.[/dw][di] Функционал отзывов:
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Параметр определяет количество выводимых на одной странице сообщений отзывов.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления отзыва в публичной части.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Задается путь к папке со смайликами относительно корня сайта.
ID форума для отзывов | FORUM_ID | Указывается идентификатор форума, в котором будут храниться отзывы пользователей.
Страница чтения темы (пусто - получить из настроек форума) | URL_TEMPLATES_READ | Указывается относительный путь к странице чтения темы на форуме. Если поле пусто, путь к странице будет получен из настроек форума.
Показать ссылку на форум | SHOW_LINK_TO_FORUM | [Y|N] При отмеченной опции на странице фотографии будет отображена ссылка на форум обсуждения.
Начинать тему текстом элемента | POST_FIRST_MESSAGE | [Y|N] При отмеченной опции сообщение в отзыве будет начинаться с анонса фотографии.
[/di]
Настройки фильтра
Показывать фильтр USE_FILTER [Y|N] При отмеченной опции становятся доступными [dw]поля настройки фильтра.[/dw][di] Поля настройки фильтра:
Фильтр | FILTER_NAME | Указывается имя переменной, в которой передается массив параметров из фильтра. Служит для определения выходящих из фильтра элементов. Если поле оставлено пустым, то используется значение по умолчанию.
Поля FILTER_FIELD_CODE Указываются поля элементов инфоблока, по которым будет возможна фильтрация. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | FILTER_PROPERTY_CODE | Указываются свойства элементов инфоблока, по которым будет возможна фильтрация. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
[/di]
Настройки TOP'а
Максимальное количество выводимых разделов | SECTION_COUNT | Задается максимальное количество выводимых разделов.
Максимальное количество фотографий, выводимых в каждом разделе | TOP_ELEMENT_COUNT | Задается максимальное количество фотографий, выводимых в TOP’е элементов в каждом разделе.
Количество фотографий, выводимых в одной строке таблицы списка разделов | TOP_LINE_ELEMENT_COUNT | Указывается количество фотографий, выводимых в одной строке таблицы списка разделов.
По какому полю сортируем разделы SECTION_SORT_FIELD Указывается поле, по которому будет происходить сортировка разделов в TOP’е элементов:
  • SORT - по индексу сортировки;
  • TIMESTAMP_X - по дате изменения;
  • NAME - по названию;
  • ID - по идентификатору;
  • DEPTH_LEVEL - по уровню вложенности папки.
Можно указать код любого другого поля.
Порядок сортировки разделов SECTION_SORT_ORDER Задается порядок сортировки разделов:
  • ASC – По возрастанию;
  • DESC – По убыванию.
По какому полю сортируем фотографии TOP_ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка фотографий внутри каждого раздела:
  • SHOWS – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • ACTIVE_FROM – по дате активности с;
  • ACTIVE_TO – по дате активности по.
Порядок сортировки фотографий в разделе TOP_ELEMENT_SORT_ORDER Задается порядок сортировки фотографий в разделе:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поля TOP_FIELD_CODE Указываются поля, которые будут отображены на странице TOP'а элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | TOP_PROPERTY_CODE | Указываются свойства, которые будут отображены на странице TOP'а элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Настройки списка
Количество элементов на странице | SECTION_PAGE_ELEMENT_COUNT | Указывается количество элементов, выводимых на одной странице. Остальные элементы будут выведены с помощью постраничной навигации.
Количество фотографий, выводимых в одной строке таблицы раздела | SECTION_LINE_ELEMENT_COUNT | Указывается количество фотографий, выводимых в одной строке таблицы раздела.
По какому полю сортируем фотографии ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка фотографий внутри каждого раздела:
  • SHOWS – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • ACTIVE_FROM – по дате активности с;
  • ACTIVE_TO – по дате активности по.
Порядок сортировки фотографий в разделе ELEMENT_SORT_ORDER Задается порядок сортировки фотографий в разделе:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поля LIST_FIELD_CODE Указываются поля, которые будут отображены на странице детального просмотра. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | LIST_PROPERTY_CODE | Указываются свойства, которые будут отображены на странице детального просмотра. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Установить заголовок окна браузера из свойства | LIST_BROWSER_TITLE | Укажите свойство, которое будет использоваться в качестве заголовка окна браузера при просмотре списка фотографий.
Настройки детального просмотра
Установить ключевые слова страницы из свойства | META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
Установить описание страницы из свойства | META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
Установить заголовок окна браузера из свойства | BROWSER_TITLE | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится заголовок окна браузера.
Поля DETAIL_FIELD_CODE Указываются поля, которые будут отображены на странице детального просмотра. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | DETAIL_PROPERTY_CODE | Указываются свойства, которые будут отображены на странице детального просмотра. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Настройки постраничной навигации
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда, даже если все элементы помещаются на одной странице.
Название шаблона | PAGER_TEMPLATE | Указывается название шаблона постраничной навигации.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации в сегундах.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все фотографии.
Включить обработку ссылок PAGER_BASE_LINK_ENABLE [Y|N] При отмеченной опции доступна обработка ссылок для постраничной навигации. Станут активны [dw]дополнительные поля.[/dw][di] Дополнительные поля:
Url для построения ссылок (по умолчанию - автоматически) | PAGER_BASE_LINK | Задается адрес для построения ссылок. Если в параметре ничего не указывать, то адрес будет построен автоматически.
Имя массива с переменными для построения ссылок в постраничной навигации | PAGER_PARAMS_NAME | Задается имя переменной, в которой передается массив с переменными для построения ссылок компонентом постраничной навигации.
[/di]
Настройки 404 ошибки
Устанавливать статус 404 | SET_STATUS_404 | [Y|N] Опция служит для включения обработки ошибки 404 в компоненте.
Показ специальной страницы SHOW_404 [Y|N] При отмеченной опции будет показана [dw]специальная страница[/dw][di] Станет активным поле:
Страница для показа (по умолчанию /404.php) FILE_404 Задается адрес страницы, которая будет отображаться при возникновении ошибки 404.
[/di] специальная страница в случае возникновения ошибки 404, в противном случае - будет отображено [dw]специальное сообщение.[/dw][di] Станет активным поле:
Сообщение для показа (по умолчанию из компонента) MESSAGE_404 Задается сообщение, которое будет показано в случае возникновения ошибки 404. Если ничего не указывать, то будет использоваться стандартное сообщение из компонента.
[/di]

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photo","",Array(
        "AJAX_MODE" => "Y",
        "SEF_MODE" => "Y",
        "IBLOCK_TYPE" => "photos",
        "IBLOCK_ID" => "22",
        "USE_RATING" => "Y",
        "USE_REVIEW" => "Y",
        "USE_FILTER" => "Y",
        "SECTION_COUNT" => "20",
        "TOP_ELEMENT_COUNT" => "9",
        "TOP_LINE_ELEMENT_COUNT" => "3",
        "SECTION_SORT_FIELD" => "sort",
        "SECTION_SORT_ORDER" => "asc",
        "TOP_ELEMENT_SORT_FIELD" => "sort",
        "TOP_ELEMENT_SORT_ORDER" => "asc",
        "TOP_FIELD_CODE" => Array(),
        "TOP_PROPERTY_CODE" => Array(),
        "SECTION_PAGE_ELEMENT_COUNT" => "20",
        "SECTION_LINE_ELEMENT_COUNT" => "3",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_ORDER" => "asc",
        "LIST_FIELD_CODE" => Array(),
        "LIST_PROPERTY_CODE" => Array(),
        "LIST_BROWSER_TITLE" => "-",
        "META_KEYWORDS" => "-",
        "META_DESCRIPTION" => "-",
        "BROWSER_TITLE" => "-",
        "DETAIL_FIELD_CODE" => Array(),
        "DETAIL_PROPERTY_CODE" => Array(),
        "SET_TITLE" => "Y",
        "PAGER_BASE_LINK_ENABLE" => "Y",
        "SET_STATUS_404" => "Y",
        "SHOW_404" => "Y",
        "MESSAGE_404" => "",
        "PAGER_BASE_LINK" => "",
        "PAGER_PARAMS_NAME" => "arrPager",
        "SET_LAST_MODIFIED" => "Y",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => Array("1"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "CACHE_GROUPS" => "Y",
        "DISPLAY_TOP_PAGER" => "N",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Фотографии",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_TEMPLATE" => "",
        "PAGER_DESC_NUMBERING" => "N",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "FILTER_NAME" => "",
        "FILTER_FIELD_CODE" => Array(),
        "FILTER_PROPERTY_CODE" => Array(),
        "MAX_VOTE" => "5",
        "VOTE_NAMES" => Array("0", "1", "2", "3", "4"),
        "MESSAGES_PER_PAGE" => "10",
        "USE_CAPTCHA" => "Y",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "FORUM_ID" => "1",
        "URL_TEMPLATES_READ" => "",
        "SHOW_LINK_TO_FORUM" => "Y",
        "POST_FIRST_MESSAGE" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "AJAX_OPTION_ADDITIONAL" => "",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "sections_top" => "",
            "section" => "#SECTION_ID#/",
            "detail" => "#SECTION_ID#/#ELEMENT_ID#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "section" => Array(),
            "detail" => Array(),
            "sections_top" => Array(),
        )
    )
);?>


Разделы с TOP'ом фотографий

Описание photo.sections.top

Одностраничный компонент служит для вывода TOP'а фотографий, сгруппированных по разделам. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Фотогалерея > Разделы с TOP'ом фотографий.

Компонент относится к модулю Информационные блоки.

Параметры

Описание параметров

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, фотографии из которого будут выводиться.
Источник данных
Поля разделов SECTION_FIELDS Указываются поля раздела, которые будут отображены на странице TOP'а элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("ID","CODE",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив) ничего отображаться не будет.
Свойства раздела | SECTION_USER_FIELDS | Указываются свойства раздела, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, свойства не будут выведены.
По какому полю сортируем разделы SECTION_SORT_FIELD Указывается поле, по которому будет происходить сортировка разделов в TOP’е элементов:
  • SORT - по индексу сортировки;
  • TIMESTAMP_X - по дате изменения;
  • NAME - по названию;
  • ID - по идентификатору;
  • DEPTH_LEVEL - по уровню вложенности папки.
Можно указать код любого другого поля.
Порядок сортировки разделов SECTION_SORT_ORDER Задается порядок сортировки разделов:
  • ASC – По возрастанию;
  • DESC – По убыванию.
По какому полю сортируем фотографии ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка фотографий внутри каждого раздела:
  • SHOWS – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • ACTIVE_FROM – по дате активности с;
  • ACTIVE_TO – по дате активности по.
Порядок сортировки фотографий в разделе ELEMENT_SORT_ORDER Задается порядок сортировки фотографий в разделе:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Имя выходящего массива для фильтрации | FILTER_NAME | Задается имя переменной, в которой передается массив параметров из фильтра. Служит для определения выходящих из фильтра элементов. Поле может быть оставлено пустым, тогда используется значение по умолчанию.
Поля FIELD_CODE Указываются поля, которые будут отображены на странице TOP'а элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице TOP'а элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Внешний вид
Максимальное количество выводимых разделов | SECTION_COUNT | Задается максимальное количество выводимых разделов.
Максимальное количество фотографий, выводимых в каждом разделе | ELEMENT_COUNT | Задается максимальное количество фотографий, выводимых в TOP’е элементов в каждом разделе.
Количество фотографий, выводимых в одной строке таблицы | LINE_ELEMENT_COUNT | Указывается количество фотографий, выводимых в одной строке таблицы.
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается адрес страницы с содержимым раздела.
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается адрес страницы с содержимым элемента раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кешировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:photo.sections.top","",Array(
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => 9,
        "SECTION_FIELDS" => array("ID"),
        "SECTION_USER_FIELDS" => array(),
        "SECTION_SORT_FIELD" => "sort",
        "SECTION_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_ORDER" => "asc",
        "FILTER_NAME" => "arrFilter",
        "FIELD_CODE" => Array(),
        "PROPERTY_CODE" => Array(),
        "SECTION_URL" => "section.php?SECTION_ID=#SECTION_ID#",
        "DETAIL_URL" => "detail.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => 3600,
        "CACHE_FILTER" => "N",
        "CACHE_GROUPS" => "Y",
        "SECTION_COUNT" => "20",
        "ELEMENT_COUNT" => "9",
        "LINE_ELEMENT_COUNT" => "3"
    )
);?>


Фотографии раздела

Описание photo.section

Одностраничный компонент выводит все фотографии из выбранного раздела. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Фотогалерея > Фотографии раздела.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, фотографии из которого будут выводиться.
ID раздела | SECTION_ID | Указывается числовой код, в котором передается идентификатор раздела. Поле может быть оставлено пустым, если указан Код раздела.
Код раздела | SECTION_CODE | Указывается символьный код раздела, из которого будут выбраны фотографии. Поле может быть оставлено пустым, если указан ID раздела.
Источник данных
Свойства раздела | SECTION_USER_FIELDS | Указываются свойства раздела, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, свойства не будут выведены.
По какому полю сортируем фотографии ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка фотографий внутри каждого раздела:
  • SHOWS – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • ACTIVE_FROM – по дате активности с;
  • ACTIVE_TO – по дате активности по.
Порядок сортировки фотографий в разделе ELEMENT_SORT_ORDER Задается порядок сортировки фотографий в разделе:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Имя массива со значениями фильтра для фильтрации элементов | FILTER_NAME | Задается имя переменной, в которой передается массив параметров из фильтра для фильтрации элементов. Служит для определения выходящих из фильтра элементов. Поле может быть оставлено пустым, тогда используется значение по умолчанию.
Поля FIELD_CODE Указываются поля, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Внешний вид
Количество элементов на странице | PAGE_ELEMENT_COUNT | Указывается количество элементов, выводимых на одной странице. Остальные элементы будут выведены с помощью постраничной навигации.
Количество фотографий, выводимых в одной строке таблицы | LINE_ELEMENT_COUNT | Указывается количество фотографий, выводимых в одной строке таблицы.
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается адрес страницы с содержимым раздела.
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается адрес страницы с содержимым элемента раздела.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Установить ключевые слова страницы из свойства | META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
Установить описание страницы из свойства | META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
Установить заголовок окна браузера из свойства | BROWSER_TITLE | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится заголовок окна браузера.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя раздела.
Устанавливать в заголовках ответа время модификации страницы | SET_LAST_MODIFIED | [Y|N] При отмеченной опции http-ответ сервера будет содержать время последнего изменения страницы (заголовок Last-Modified [image]).
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Настройки постраничной навигации
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда, даже если все элементы помещаются на одной странице.
Название шаблона | PAGER_TEMPLATE | Указывается название шаблона постраничной навигации.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации в сегундах.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все фотографии раздела.
Включить обработку ссылок PAGER_BASE_LINK_ENABLE [Y|N] При отмеченной опции доступна обработка ссылок для постраничной навигации.Становятся активными [dw]дополнительные поля.[/dw][di] Дополнительные поля:
Url для построения ссылок (по умолчанию - автоматически) | PAGER_BASE_LINK | Задается адрес для построения ссылок. Если в параметре ничего не указывать, то адрес будет построен автоматически.
Имя массива с переменными для построения ссылок в постраничной навигации | PAGER_PARAMS_NAME | Задается имя переменной, в которой передается массив с переменными для построения ссылок компонентом постраничной навигации.
[/di]
Настройки 404 ошибки
Устанавливать статус 404 | SET_STATUS_404 | [Y|N] Опция служит для включения обработки ошибки 404 в компоненте.
Показ специальной страницы SHOW_404 [Y|N] При отмеченной опции будет показана [dw]специальная страница[/dw][di] Станет активным поле:
Страница для показа (по умолчанию /404.php) FILE_404 Задается адрес страницы, которая будет отображаться при возникновении ошибки 404.
[/di] в случае возникновения ошибки 404, в противном случае - будет отображено [dw]специальное сообщение.[/dw][di] Станет активным поле:
Сообщение для показа (по умолчанию из компонента) MESSAGE_404 Задается сообщение, которое будет показано в случае возникновения ошибки 404. Если ничего не указывать, то будет использоваться стандартное сообщение из компонента.
[/di]

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photo.section","",Array(
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "photos",
        "IBLOCK_ID" => "22",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "SECTION_CODE" => "",
        "SECTION_USER_FIELDS" => "",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_ORDER" => "asc",
        "FILTER_NAME" => "arrFilter",
        "FIELD_CODE" => Array(),
        "PROPERTY_CODE" => Array(),
        "SECTION_URL" => "",
        "DETAIL_URL" => "",
        "PAGE_ELEMENT_COUNT" => "20",
        "LINE_ELEMENT_COUNT" => "3",
        "META_KEYWORDS" => "-",
        "META_DESCRIPTION" => "-",
        "BROWSER_TITLE" => "-",
        "SET_TITLE" => "Y",
        "PAGER_BASE_LINK_ENABLE" => "Y",
        "SET_STATUS_404" => "Y",
        "SHOW_404" => "Y",
        "MESSAGE_404" => "",
        "PAGER_BASE_LINK" => "",
        "PAGER_PARAMS_NAME" => "arrPager",
        "SET_LAST_MODIFIED" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "CACHE_GROUPS" => "Y",
        "DISPLAY_TOP_PAGER" => "Y",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Фотографии",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_TEMPLATE" => "",
        "PAGER_DESC_NUMBERING" => "Y",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Фотография детально

Описание photo.detail

Одностраничный компонент выводит детальную информацию по фотографии. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Фотогалерея > Фотография детально.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфо-блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Инфо-блок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, фотографии из которого будут выводиться.
ID раздела | SECTION_ID | Указывается числовой код, в котором передается идентификатор раздела. Поле может быть оставлено пустым, если указан Код раздела.
ID элемента | ELEMENT_ID | Указывается числовой код, в котором передается идентификатор элемента. Поле может быть оставлено пустым, если указан Код элемента.
Код раздела | SECTION_CODE | Указывается символьный код раздела, из которого будут выбраны фотографии. Поле может быть оставлено пустым, если указан ID раздела.
Код элемента | ELEMENT_CODE | Указывается символьный код элемента, из которого будут выбраны фотографии. Поле может быть оставлено пустым, если указан ID элемента.
Источник данных
По какому полю отсортировать фотографии для ссылок "след." и "пред." ELEMENT_SORT_FIELD Указывается поле, по которому будут отсортированы фотографии для ссылок "следующая" и "предыдущая":
  • SHOWS – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • ACTIVE_FROM – по дате активности с;
  • ACTIVE_TO – по дате активности по.
В каком порядке отсортировать фотографии для ссылок "след." и "пред." ELEMENT_SORT_ORDER Задается порядок сортировки фотографий для ссылок "следующая" и "предыдущая":
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поля FIELD_CODE Указываются поля, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается адрес страницы с содержимым раздела.
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается адрес страницы с содержимым элемента раздела.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Установить ключевые слова страницы из свойства | META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
Установить описание страницы из свойства | META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
Установить заголовок окна браузера из свойства | BROWSER_TITLE | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится заголовок окна браузера.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название фотографии.
Устанавливать в заголовках ответа время модификации страницы | SET_LAST_MODIFIED | [Y|N] При отмеченной опции http-ответ сервера будет содержать время последнего изменения страницы (заголовок Last-Modified [image]).
Настройки 404 ошибки
Устанавливать статус 404 | SET_STATUS_404 | [Y|N] Опция служит для включения обработки ошибки 404 в компоненте.
Показ специальной страницы SHOW_404 [Y|N] При отмеченной опции будет показана [dw]специальная страница[/dw][di] Станет активным поле:
Страница для показа (по умолчанию /404.php) FILE_404 Задается адрес страницы, которая будет отображаться при возникновении ошибки 404.
[/di] в случае возникновения ошибки 404, в противном случае - будет отображено [dw]специальное сообщение.[/dw][di] Станет активным поле:
Сообщение для показа (по умолчанию из компонента) MESSAGE_404 Задается сообщение, которое будет показано в случае возникновения ошибки 404. Если ничего не указывать, то будет использоваться стандартное сообщение из компонента.
[/di]

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photo.detail","",Array(
        "AJAX_MODE" => "N",
        "IBLOCK_TYPE" => "photos",
        "IBLOCK_ID" => "22",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "SECTION_CODE" => "",
        "ELEMENT_CODE" => "",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_ORDER" => "asc",
        "FIELD_CODE" => Array(),
        "PROPERTY_CODE" => Array(),
        "SECTION_URL" => "",
        "DETAIL_URL" => "",
        "META_KEYWORDS" => "-",
        "META_DESCRIPTION" => "-",
        "BROWSER_TITLE" => "-",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "SHOW_404" => "Y",
        "MESSAGE_404" => "",
        "SET_LAST_MODIFIED" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    ),
);?>


Случайное фото

Одностраничный компонент cлужит для показа одной произвольной фотографии.

Описание photo.random

Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Фотогалерея > Случайное фото.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Инфо-блок | IBLOCKS | Для выбранного типа инфоблока указывается идентификатор информационного блока, фотографии из которого будут выводиться. Можно указать несколько инфоблоков.
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается адрес страницы с содержимым элемента раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
ID раздела | PARENT_SECTION | Указывается идентификатор раздела, из которого будут выбираться фотографии. Поле может быть пустым, тогда выбор фотографии производится из всех разделов указанных инфоблоков.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photo.random","",Array(
    "IBLOCK_TYPE" => "gallery",
    "IBLOCKS" => Array("-"),
    "PARENT_SECTION" => "",
    "DETAIL_URL" => "detail.php?SECTION_ID=#SECTION_ID#&ID=#ELEMENT_ID#",
    "CACHE_TYPE" => "A",
    "CACHE_TIME" => "180",
    "CACHE_GROUPS" => "Y"
    ),
);?>


Фотогалерея 2.0

Подраздел предназначен для организации полнофункциональной фотогалерии с гибко настраиваемыми параметрами, в т.ч. многопользовательской. Включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Фотогалерея 2.0 (комплексный компонент) | photogallery | Позволяет получить полнофункциональную фотогалерею, создавая физически только одну страницу.
Фотогалерея 2.0 (многопользовательская) (комплексный компонент) | photogallery_user | Позволяет получить полнофункциональную многопользовательскую фотогалерею, создавая физически только одну страницу.
Альбом | photogallery.section | Выводит полную информацию об одном альбоме.
Альбом (список) | photogallery.section.list | Выводит список альбомов с информацией о количестве фотографий, вложенных альбомов в каждом и ссылками на просмотр содержимого альбомов.
Панель | photogallery.user | Выводит информацию о галерее пользователя.
Фотогалерея (редактирование) | photogallery.gallery.edit | Выводит форму редактирования параметров фотогалереи пользователя.
Фотогалерея (список) | photogallery.gallery.list | Выводит список фотогалерей пользователя.
Фотогалерея (шаблоны) | photogallery.interface | Подключает библиотеку вспомогательных шаблонов. Компонент ничего не выводит.
Flash-слайдшоу (Не поддерживается с версии 15.0.0) | photogallery.imagerotator | Позволяет показывать фотографии в режиме слайдшоу
Альбом (редактирование обложки) | photogallery.section.edit.icon | Служит для редактирования обложки альбома.
Альбом (редактирование) | photogallery.section.edit | Позволяет отредактировать данные альбома: изменить название, дату создания, ввести описание, ограничить доступ к альбому по паролю.
Фото | photogallery.detail | Выводит детальную информацию по фотографии.
Фото (загрузка) | photogallery.upload | Служит для загрузки фотографии.
Фото (комментарии) | photogallery.detail.comment | Служит для создания комментариев к фотографии.
Фото (редактирование) | photogallery.detail.edit | Служит для редактирования свойств фотографии.
Фото (список) | photogallery.detail.list | Выводит список фотографий.
Список фото (со слайдером) | photogallery.detail.list.ex | Выводит список фотографий во всплывающем окне со слайдером и комментариями.


Фотогалерея 2.0 (комплексный компонент)

Комплексный компонент Фотогалерея 2.0 позволяет получить полнофункциональную фотогалерею, создавая физически только одну страницу. <

Описание photogallery

Комплексный компонент Фотогалерея 2.0 позволяет получить полнофункциональную фотогалерею, создавая физически только одну страницу.

Настройки компонента дают возможность гибко управлять параметрами фотогалереи:

  • организовать многопользовательскую фотогалерею;
  • создавать любое количество альбомов и загружать неограниченное количество фотографий;
  • ограничить максимальный размер загружаемого файла;
  • определять параметры фотографий при просмотре в различных режимах;
  • настраивать голосование, отзывы, теги и т.д.

Внимание! Компонент поддерживает два режима настройки: простой и расширенный. Расширенный предоставляет более обширные средства настройки.

Компонент стандартный и входит в дистрибутив модуля.

Компонент содержит два шаблона: .default и old.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры. Простой режим

Поле | Параметр | Описание
Основные параметры
Использовать простой режим настройки | USE_LIGHT_VIEW | [Y|N] При отмеченной опции будет использоваться простой режим настройки фотогалереи (значения остальных параметров будут по умолчанию).
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
Путь к профилю пользователя | PATH_TO_USER | Указывается шаблон пути к профилю пользователя.
Сортировать фотографии в альбоме перетаскиванием | DRAG_SORT | [Y|N] При отмеченной опции можно сортировать фотографии в альбоме перетаскиванием с помощью мыши.
Настройки отзывов
Разрешить отзывы USE_COMMENTS [Y|N] При отмеченной опции будет доступен функционал отзывов, станут активны [dw]дополнительные поля[/dw][di] Дополнительные поля:
Компонент комментариев COMMENTS_TYPE Указывается компонент, с помощью которого будут добавляться комментарии:
  • Блоги (blog);
  • Форум (forum).
Если указать Блоги, то необходимо настроить следующие параметры: BLOG_URL, PATH_TO_BLOG.

Если указать Форум, то необходимо настроить параметр FORUM_ID.
Блог для комментариев | BLOG_URL | Указывается блог, в котором будут храниться комментарии.
Путь к блогу | PATH_TO_BLOG | Указывается путь к главной странице блога.
ID форума для отзывов | FORUM_ID | Указывается один из созданных в системе форумов, который будет использован для комментариев.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО комментирующего пользователя. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
[/di]
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di] Настраиваемые параметры при включенном режиме поддержки ЧПУ:
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • Главная страница - главная страница фотогалереи;
  • Альбом - страница просмотра альбома;
  • Альбом (редактирование) - страница редактирования параметров альбома;
  • Альбом (редактирование обложки) - страница выбора обложки альбома;
  • Загрузка фото - страница загрузки фотографий;
  • Фото - страница просмотра фотографий;
  • Фото (редактирование) - страница редактирования параметров фотографии;
  • Фото (список) - страница со списком фотографий альбома;
  • Поиск - страница поиска.
[/di] SEF_FOLDER и SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить[dw]следующие параметры:[/dw][di] Настраиваемые параметры при выключенном режиме поддержки ЧПУ:
Идентификатор раздела | SECTION_ID | Указывается имя переменной, которой передается идентификатор раздела (альбома) фотогалереи.
Идентификатор элемента | ELEMENT_ID | Указывается имя переменной, которой передается идентификатор элемента (фотографии) фотогалереи.
Идентификатор страницы | PAGE_NAME | Указывается имя переменной, которой передается идентификатор страницы фотогалереи.
Идентификатор действия | ACTION | Указывается имя переменной, которой передается идентификатор действия фотогалереи.
[/di] SECTION_ID, ELEMENT_ID, PAGE_NAME и ACTION.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции будут установлены заголовки всех страниц в соответствии с их содержимым.
Показывать ссылки на главной странице SHOW_LINK_ON_MAIN_PAGE Указываются категории ссылок, которые будут отображены на главной старнице:
  • Новые (по дате добавления) (id);
  • Посещаемые (по количеству показов) (shows);
  • Лучшие (по количеству голосов) (rating);
  • Обсуждаемые (по количеству комментариев) (comments).
Настройки фотогалереи
Размер картинки фотоальбома (px) | ALBUM_PHOTO_SIZE | Указывается размер картинки фотоальбома в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Размер фотографии-анонса (px) | THUMBS_SIZE | Указывается размер картинки-анонса альбома в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Размер картинки в предпросмотре в списке альбомов (px) | SECTION_LIST_THUMBS_SIZE | Указывается размер картинки в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Обязательно ограничивать размер оригинала (px) (при значении 0 ограничение не происходит) | ORIGINAL_SIZE | Задается размер оригинала фотографии в пикселях. Фотография будет уменьшена до указанной величины. Если указано значение 0, то изменение размера не происходит. Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Отображать список альбомов в качестве рубрик со списком последних добавленых фотографий | PHOTO_LIST_MODE | [Y|N] При отмеченной опции в списке альбомов-рубрик будут отображаться последние добавленные фотографии.
Количество выводимых фотографий в списке альбомов | SHOWN_ITEMS_COUNT | Задается количество отображаемых последних фотографий в альбомах в режиме, включенном параметром PHOTO_LIST_MODE.
Настройки голосования
Разрешить голосование USE_RATING [Y|N] При отмеченной опции посетители смогут голосовать за фотографии, выставляя баллы, на странице с детальной информацией. При установленной опции становятся доступными [dw]следующие поля:[/dw][di] Доступные поля:
Максимальный балл MAX_VOTE Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
В качестве рейтинга показывать DISPLAY_AS_RATING Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • Рейтинг (rating) - высчитывается на основе формулы:

    Rating = (SUM(vote)+3.125*10) / (COUNT(*)+10), где:

    3.125 - это стартовый рейтинг. То есть изначально (при отсутствии голосов) рейтинг фотографии равен 3.125.

    10 - это константа, определяющая количество голосов, "утяжеляющих" первоначальное значение рейтинга (3.125). Это исключает случай, когда, например, трое проголосовавших человека могут вознести или опустить фотографию всего тремя голосами.

    При такой формуле расчета значение рейтинга получается более "плавное" и не так скачет при небольшом количестве голосующих. Чем больше голосов, тем больше рейтинг приближается к среднему арифметическому.

  • Среднее значение (vote_avg) - высчитывается как среднее арифметическое всех баллов к фотографии;
  • Рейтинг (главного модуля) (rating_main) - использование рейтинга главного модуля.

    Подробнее:

    - см. главу Рейтинги [image] [image];
    - в блоге Рейтинги: создание собственного критерия рейтингования [image] [image];
    - в блоге Саморегулируемое сообщество, построенное на двухфакторном рейтинге [image] [image].
Вид кнопок рейтинга RATING_MAIN_TYPE Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • по умолчанию;
  • Плюс / минус (standart);
  • Мне нравится (like).

Параметр доступен только если выбран Рейтинг (главного модуля) (rating_main).
[/di] MAX_VOTE и VOTE_NAMES.
Настройки тегов
Показывать теги SHOW_TAGS [Y|N] При отмеченной опции будет показано облако тегов фотогалереи. Станут активными [dw]дополнительные поля[/dw][di]
Количество тегов | TAGS_PAGE_ELEMENTS | Указывается количество тегов, отображаемых в облаке.
Максимальный размер шрифта (px) | TAGS_FONT_MAX | Указывается максимальный размер шрифта отображения тегов (в пикселах).
Минимальный размер шрифта (px) | TAGS_FONT_MIN | Указывается минимальный размер шрифта отображения тегов (в пикселах).
Цвет более позднего тега (пример: "C0C0C0") | TAGS_COLOR_NEW | Указывается код цвета тегов, дата создания которых наиболее поздняя (пример: "C0C0C0").
Цвет более раннего тега (пример: "FEFEFE") | TAGS_COLOR_OLD | Указывается код цвета тегов, дата создания которых наиболее ранняя (пример: "FEFEFE").
[/di]
Загрузка фото
Тип загрузчика PHOTO_UPLOADER_TYPE Указывается тип загрузчика фотографий в фотогалерею:
  • Одиночная загрузка через форму (form);
  • Множественный загрузчик (Java/ActiveX) (applet);
  • Множественный Flash-загрузчик (flash).
Параметр устарел с версии 15.0.0
Схема множественного загрузчика APPLET_LAYOUT Параметр определяет тип загрузчика в фотогалерии по умолчанию:
  • Стандартный шаблон (extended);
  • Упрощенный шаблон загрузчика (simple).
Выбор параметра доступен только при выборе параметра "Тип загрузчика" (PHOTO_UPLOADER_TYPE) равным "Множественный загрузчик (Java/ActiveX)" (applet).

Параметр устарел с версии 15.0.0
Максимальный размер загружаемого файла (не должен превышать 1024Mб) (Мб) | UPLOAD_MAX_FILE_SIZE | Указывается максимальный размер загружаемого файла в Мб (не должен превышать 1024Mб).
Наносить авторский знак USE_WATERMARK

Внимание! Функционал авторского знака устарел и не поддерживается с версии 14.5.0 Главного модуля (main).

[Y|N] При отмеченной опции при загрузке фотографий можно будет наносить авторский знак. Станут доступны [dw]поля настройки авторского знака.[/dw][di] Поля настройки авторского знака:
Правила нанесения авторского знака WATERMARK_RULES Указывается правило нанесения авторского знака:
  • На усмотрение пользователя (USER);
  • Обязательно наносить авторский знак (ALL).
Если выбрано значение Обязательно наносить авторский знак, то дополнительно необходимо настроить дополнительные параметры (приведены в таблице ниже).
Файл со шрифтом для авторского знака | PATH_TO_FONT | Указывается файл со шрифтом для создания авторского знака (будет использоваться также и при множественной загрузке). Шрифты предварительно загружаются в директорию \bitrix\modules\photogallery\fonts\. Поддерживаются TTF-, OTF- и PS-шрифты.
Минимальный размер фото для авторского знака (px) | WATERMARK_MIN_PICTURE_SIZE | Указывается минимальный размер фото, на которых будет нанесен авторский знак в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально. На фотографии меньшего размера знак добавлен не будет.

Дополнительные параметры, заполняемые при выборе правила Обязательно наносить авторский знак
(обратите внимание, что список параметров меняется в зависимости от типа авторского знака) :
Тип авторского знака WATERMARK_TYPE Указывается тип авторского знака:
  • Надпись (текст) (TEXT);
  • Картинка (PICTURE).
Если выбрано значение TEXT, то дополнительно необходимо настроить параметры: WATERMARK_TEXT, WATERMARK_COLOR и WATERMARK_SIZE.

Если выбрано значение PICTURE, то дополнительно необходимо настроить параметры: WATERMARK_FILE и WATERMARK_FILE_ORDER.
Текст надписи | WATERMARK_TEXT | Задается текст авторского знака.
Цвет надписи (без #, например, FF00EE) | WATERMARK_COLOR | Указывается шестнадцатеричный код цвета надписи без использования #.
Размер надписи (% от размера картинки) | WATERMARK_SIZE | Задается размер надписи авторского знака в процентном соотношении от размера фото.
Размещение авторского знака WATERMARK_POSITION Указывается область размещения авторского знака на фото:
  • Сверху слева (tl);
  • Сверху по центру (tc);
  • Сверху справа (tr);
  • Cлева (ml);
  • По центру (mc);
  • Cправа (mr);
  • Снизу cлева (bl);
  • Снизу по центру (bc);
  • Снизу cправа (br).
Физический полный путь к картинке | WATERMARK_FILE | Указывается полный путь к картинке для авторского знака относительно корня сайта.
Расположение картинки на фото WATERMARK_FILE_ORDER Указывается тип расположения картинки авторского знака на фото:
  • Без изменений (usual);
  • Растянуть (resize);
  • Замостить (repeat).
Прозрачность авторского знака | WATERMARK_TRANSPARENCY | Задается величина прозрачности авторского знака (в %).
[/di]

Параметры. Расширенный режим

Поле | Параметр | Описание
Основные параметры
Использовать простой режим настройки | USE_LIGHT_VIEW | [Y|N] При отсутствии отметки на данной опции будет использоваться расширенный режим настройки фотогалереи.
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
По какому полю сортируем альбомы SECTION_SORT_BY Указывается поле, по которому будет происходить сортировка альбомов:
  • ID - по идентификатору;
  • NAME - по названию;
  • SORT - по индексу сортировки;
  • ELEMENTS_CNT - по количесву фото в альбоме;
  • UF_DATE - по дате.
Порядок сортировки альбомов SECTION_SORT_ORD Задается порядок сортировки альбомов:
  • ASC – по возрастанию;
  • DESC – по убыванию.
По какому полю сортируем фото ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка фотографий:
  • SHOWS – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • RATING – по популярности;
  • COMMENTS – по комментариям.
Порядок сортировки фото в альбомах ELEMENT_SORT_ORDER Задается порядок сортировки фотографий в альбомах:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Путь к профилю пользователя | PATH_TO_USER | Указывается шаблон пути к профилю пользователя.
Сортировать фотографии в альбоме перетаскиванием | DRAG_SORT | [Y|N] При отмеченной опции можно сортировать фотографии в альбоме перетаскиванием с помощью мыши.
Настройки отзывов
Разрешить отзывы USE_COMMENTS [Y|N] При отмеченной опции будет доступен функционал отзывов. При расширенном режиме станут доступны [dw]дополнительные поля.[/dw][di] Дополнительные поля:
Компонент комментариев COMMENTS_TYPE Указывается компонент, с помощью которого будут добавляться комментарии:
  • Блоги (blog);
  • Форум (forum).
Если указать Блоги, то необходимо настроить следущие параметры: BLOG_URL, PATH_TO_BLOG.

Если указать Форум, то необходимо настроить следущие параметры: FORUM_ID, URL_TEMPLATES_READ, URL_TEMPLATES_PROFILE_VIEW, USE_CAPTCHA, SHOW_LINK_TO_FORUM, PREORDER.
ID форума для отзывов | FORUM_ID | Указывается один из созданных в системе форумов, который будет использован для комментариев.
Количество комментариев на странице | COMMENTS_COUNT | Указывается количество комментариев на странице.
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума.
Страница пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы профиля пользователя относительно корня сайта.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления комментария в публичной части.
Выводить сообщения в прямом порядке | PREORDER | [Y|N] При отмеченной опции собщения будут отсортированы по дате создания по возрастанию.
Начинать тему текстом элемента | POST_FIRST_MESSAGE | [Y|N] При отмеченной опции в обсуждении на форуме будет выведено первое сообщение отзыва.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО комментирующего пользователя. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
[/di]
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di] Настраиваемые параметры при включенном режиме поддержки ЧПУ:
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • Главная страница - главная страница фотогалереи;
  • Альбом - страница просмотра альбома;
  • Альбом (редактирование) - страница редактирования параметров альбома;
  • Альбом (редактирование обложки) - страница выбора обложки альбома;
  • Загрузка фото - страница загрузки фотографий;
  • Фото - страница просмотра фотографий;
  • Фото (редактирование) - страница редактирования параметров фотографии;
  • Фото (список) - страница со списком фотографий альбома;
  • Поиск - страница поиска.
[/di] SEF_FOLDER и SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить[dw]следующие параметры:[/dw][di] Настраиваемые параметры при выключенном режиме поддержки ЧПУ:
Идентификатор раздела | SECTION_ID | Указывается имя переменной, которой передается идентификатор раздела (альбома) фотогалереи.
Идентификатор элемента | ELEMENT_ID | Указывается имя переменной, которой передается идентификатор элемента (фотографии) фотогалереи.
Идентификатор страницы | PAGE_NAME | Указывается имя переменной, которой передается идентификатор страницы фотогалереи.
Идентификатор действия | ACTION | Указывается имя переменной, которой передается идентификатор действия фотогалереи.
[/di] SECTION_ID, ELEMENT_ID, PAGE_NAME и ACTION.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции будут установлены заголовки всех страниц в соответствии с их содержимым.
Показывать ссылки на главной странице SHOW_LINK_ON_MAIN_PAGE Указываются категории ссылок, которые будут отображены на главной старнице:
  • Новые (по дате добавления) (id);
  • Посещаемые (по количеству показов) (shows);
  • Лучшие (по количеству голосов) (rating);
  • Обсуждаемые (по количеству комментариев) (comments).
Формат вывода даты альбома | DATE_TIME_FORMAT_SECTION | Указывается формат показа даты и времени альбома. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат вывода даты фото | DATE_TIME_FORMAT_DETAIL | Указывается формат показа даты и времени фотографии. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Настройки постраничной навигации
Количество альбомов на странице | SECTION_PAGE_ELEMENTS | Указывается количество альбомов, отображаемых на одной странице. Остальные альбомы будут выведены с помощью постраничной навигации.
Количество фото на странице | ELEMENTS_PAGE_ELEMENTS | Указывается количество фотографий, отображаемых на одной странице. Остальные фотографии будут выведены с помощью постраничной навигации.
Шаблон для постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указываются название шаблона для постраничной навигации.
Настройки фотогалереи
Размер картинки фотоальбома (px) | ALBUM_PHOTO_SIZE | Указывается размер картинки фотоальбома в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Размер фотографии-анонса (px) | THUMBS_SIZE | Указывается размер картинки-анонса альбома в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Размер картинки в предпросмотре в списке альбомов (px) | SECTION_LIST_THUMBS_SIZE | Указывается размер картинки в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Качество фотографии-анонса (%) | JPEG_QUALITY1 | Указывается качество фотографии-анонса в процентах (100% - самое высокое качество).
Обязательно ограничивать размер оригинала (px) (при значении 0 ограничение не происходит) | ORIGINAL_SIZE | Задается размер оригинала фотографии в пикселях. Фотография будет уменьшена до указанной величины. Если указано значение 0, то изменение размера не происходит. Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Качество загружаемой фотографии (%) | JPEG_QUALITY | Указывается качество загружаемой фотографии в процентах (100% - самое высокое качество).
Дополнительные эскизы | ADDITIONAL_SIGHTS | Указываются типы для эскизов фотографий, которые должны быть показаны.
Отображать список альбомов в качестве рубрик со списком последних добавленых фотографий | PHOTO_LIST_MODE | [Y|N] При отмеченной опции в списке альбомов-рубрик будут отображаться последние добавленные фотографии.
Количество выводимых фотографий в списке альбомов | SHOWN_ITEMS_COUNT | Задается количество отображаемых последних фотографий в альбомах в режиме, включенном параметром PHOTO_LIST_MODE.
Отображать навигационную цепочку 'хлебные крошки' в рамках комплексного компонента | SHOW_NAVIGATION | [Y|N] При отмеченной опции на странице фотогалереи будет отображаться навигационная цепочка ('хлебные крошки').
Настройки голосования
Разрешить голосование USE_RATING [Y|N] При отмеченной опции посетители смогут голосовать за фотографии, выставляя баллы, на странице с детальной информацией. При установленной опции становятся доступными [dw]следующие поля:[/dw][di] Доступные поля:
Максимальный балл MAX_VOTE Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
В качестве рейтинга показывать DISPLAY_AS_RATING Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • Рейтинг (rating) - высчитывается на основе формулы:

    Rating = (SUM(vote)+3.125*10) / (COUNT(*)+10), где:

    3.125 - это стартовый рейтинг. То есть изначально (при отсутствии голосов) рейтинг фотографии равен 3.125.

    10 - это константа, определяющая количество голосов, "утяжеляющих" первоначальное значение рейтинга (3.125). Это исключает случай, когда, например, трое проголосовавших человека могут вознести или опустить фотографию всего тремя голосами.

    При такой формуле расчета значение рейтинга получается более "плавное" и не так скачет при небольшом количестве голосующих. Чем больше голосов, тем больше рейтинг приближается к среднему арифметическому.

  • Среднее значение (vote_avg) - высчитывается как среднее арифметическое всех баллов к фотографии;
  • Рейтинг (главного модуля) (rating_main) - использование рейтинга главного модуля.

    Подробнее:

    - см. главу Рейтинги [image] [image];
    - в блоге Рейтинги: создание собственного критерия рейтингования [image] [image];
    - в блоге Саморегулируемое сообщество, построенное на двухфакторном рейтинге [image] [image].
Вид кнопок рейтинга RATING_MAIN_TYPE Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • по умолчанию;
  • Плюс / минус (standart);
  • Мне нравится (like).

Параметр доступен только если выбран Рейтинг (главного модуля) (rating_main).
[/di] MAX_VOTE и VOTE_NAMES.
Настройки тегов
Показывать теги SHOW_TAGS [Y|N] При отмеченной опции будет показано облако тегов фотогалереи и станут доступны [dw]дополнительные поля.[/dw][di] Дополнительные поля:
Количество тегов | TAGS_PAGE_ELEMENTS | Указывается количество тегов, отображаемых в облаке.
Период выборки тегов (дней) | TAGS_PERIOD | Указывается количество дней, за которые происходит выборка тегов.
Сужать область поиска | TAGS_INHERIT | [Y|N] При отмеченной опции выбранные теги добавляются в фильтр поиска.
Максимальный размер шрифта (px) | TAGS_FONT_MAX | Указывается максимальный размер шрифта отображения тегов (в пикселах).
Минимальный размер шрифта (px) | TAGS_FONT_MIN | Указывается минимальный размер шрифта отображения тегов (в пикселах).
Цвет более позднего тега (пример: "C0C0C0") | TAGS_COLOR_NEW | Указывается код цвета тегов, дата создания которых наиболее поздняя (пример: "C0C0C0").
Цвет более раннего тега (пример: "FEFEFE") | TAGS_COLOR_OLD | Указывается код цвета тегов, дата создания которых наиболее ранняя (пример: "FEFEFE").
Показывать цепочку навигации | TAGS_SHOW_CHAIN | [Y|N] При отмеченной опции будет показана цепочка навигации. Параметр работает, если параметр TAGS_INHERIT принимает значение Y.
[/di]
Загрузка фото
Тип загрузчика PHOTO_UPLOADER_TYPE Указывается тип загрузчика фотографий в фотогалерею:
  • Одиночная загрузка через форму (form);
  • Множественный загрузчик (Java/ActiveX) (applet);
  • Множественный Flash-загрузчик (flash).
Параметр устарел с версии 15.0.0
Схема множественного загрузчика APPLET_LAYOUT Параметр определяет тип загрузчика в фотогалерии по умолчанию:
  • Стандартный шаблон (extended);
  • Упрощенный шаблон загрузчика (simple).
Выбор параметра доступен только при выборе параметра "Тип загрузчика" (PHOTO_UPLOADER_TYPE) равным "Множественный загрузчик (Java/ActiveX)" (applet).

Параметр устарел с версии 15.0.0
Максимальный размер загружаемого файла (не должен превышать 1024Mб) (Мб) | UPLOAD_MAX_FILE_SIZE | Указывается максимальный размер загружаемого файла в Мб (не должен превышать 1024Mб).
Наносить авторский знак USE_WATERMARK

Внимание! Функционал авторского знака устарел и не поддерживается с версии 14.5.0 Главного модуля (main).

[Y|N] При отмеченной опции при загрузке фотографий можно будет наносить авторский знак. Станут доступны [dw]поля настройки авторского знака.[/dw][di] Поля настройки авторского знака:
Правила нанесения авторского знака WATERMARK_RULES Указывается правило нанесения авторского знака:
  • На усмотрение пользователя (USER);
  • Обязательно наносить авторский знак (ALL).
Если выбрано значение Обязательно наносить авторский знак, то дополнительно необходимо настроить дополнительные параметры (приведены в таблице ниже).
Файл со шрифтом для авторского знака | PATH_TO_FONT | Указывается файл со шрифтом для создания авторского знака (будет использоваться также и при множественной загрузке). Шрифты предварительно загружаются в директорию \bitrix\modules\photogallery\fonts\. Поддерживаются TTF-, OTF- и PS-шрифты.
Минимальный размер фото для авторского знака (px) | WATERMARK_MIN_PICTURE_SIZE | Указывается минимальный размер фото, на которых будет нанесен авторский знак в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально. На фотографии меньшего размера знак добавлен не будет.

Дополнительные параметры, заполняемые при выборе правила Обязательно наносить авторский знак
(обратите внимание, что список параметров меняется в зависимости от типа авторского знака) :
Тип авторского знака WATERMARK_TYPE Указывается тип авторского знака:
  • Надпись (текст) (TEXT);
  • Картинка (PICTURE).
Если выбрано значение TEXT, то дополнительно необходимо настроить параметры: WATERMARK_TEXT, WATERMARK_COLOR и WATERMARK_SIZE.

Если выбрано значение PICTURE, то дополнительно необходимо настроить параметры: WATERMARK_FILE и WATERMARK_FILE_ORDER.
Текст надписи | WATERMARK_TEXT | Задается текст авторского знака.
Цвет надписи (без #, например, FF00EE) | WATERMARK_COLOR | Указывается шестнадцатеричный код цвета надписи без использования #.
Размер надписи (% от размера картинки) | WATERMARK_SIZE | Задается размер надписи авторского знака в процентном соотношении от размера фото.
Размещение авторского знака WATERMARK_POSITION Указывается область размещения авторского знака на фото:
  • Сверху слева (tl);
  • Сверху по центру (tc);
  • Сверху справа (tr);
  • Cлева (ml);
  • По центру (mc);
  • Cправа (mr);
  • Снизу cлева (bl);
  • Снизу по центру (bc);
  • Снизу cправа (br).
Физический полный путь к картинке | WATERMARK_FILE | Указывается полный путь к картинке для авторского знака относительно корня сайта.
Расположение картинки на фото WATERMARK_FILE_ORDER Указывается тип расположения картинки авторского знака на фото:
  • Без изменений (usual);
  • Растянуть (resize);
  • Замостить (repeat).
Прозрачность авторского знака | WATERMARK_TRANSPARENCY | Задается величина прозрачности авторского знака (в %).
[/di]

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photogallery","",Array(
        "SHOW_LINK_ON_MAIN_PAGE" => array("id","rating","comments","shows"),
        "USE_LIGHT_VIEW" => "Y",
        "SEF_MODE" => "Y",
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "10",
        "SECTION_SORT_BY" => "UF_DATE",
        "SECTION_SORT_ORD" => "DESC",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_ORDER" => "desc",
        "PATH_TO_USER" => "",
        "SECTION_PAGE_ELEMENTS" => "15",
        "ELEMENTS_PAGE_ELEMENTS" => "50",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "ALBUM_PHOTO_SIZE" => "120",
        "THUMBNAIL_SIZE" => "100",
        "JPEG_QUALITY1" => "100",
        "ORIGINAL_SIZE" => "1280",
        "JPEG_QUALITY" => "100",
        "ADDITIONAL_SIGHTS" => array(),
        "PHOTO_LIST_MODE" => "Y",
        "SHOWN_ITEMS_COUNT" => "6",
        "SHOW_NAVIGATION" => "N",
        "DATE_TIME_FORMAT_DETAIL" => "d.m.Y",
        "DATE_TIME_FORMAT_SECTION" => "d.m.Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_NOTES" => "",
        "USE_RATING" => "Y",
        "SHOW_TAGS" => "Y",
        "DRAG_SORT" => "Y",
        "UPLOADER_TYPE" => "applet",
        "APPLET_LAYOUT" => "extended",
        "UPLOAD_MAX_FILE_SIZE" => "1024",
        "USE_WATERMARK" => "Y",
        "WATERMARK_RULES" => "ALL",
        "WATERMARK_TYPE" => "PICTURE",
        "WATERMARK_FILE" => "",
        "WATERMARK_FILE_ORDER" => "usual",
        "WATERMARK_POSITION" => "mc",
        "WATERMARK_TRANSPARENCY" => "20",
        "PATH_TO_FONT" => "",
        "WATERMARK_MIN_PICTURE_SIZE" => "800",
        "MAX_VOTE" => "5",
        "VOTE_NAMES" => array("1","2","3","4","5"),
        "DISPLAY_AS_RATING" => "rating",
        "USE_COMMENTS" => "Y",
        "COMMENTS_TYPE" => "blog",
        "BLOG_URL" => "admin-blg",
        "COMMENTS_COUNT" => "10",
        "PATH_TO_BLOG" => "",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "TAGS_PAGE_ELEMENTS" => "150",
        "TAGS_PERIOD" => "",
        "TAGS_INHERIT" => "Y",
        "TAGS_FONT_MAX" => "30",
        "TAGS_FONT_MIN" => "10",
        "TAGS_COLOR_NEW" => "3E74E6",
        "TAGS_COLOR_OLD" => "C0C0C0",
        "TAGS_SHOW_CHAIN" => "Y",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "section" => "#SECTION_ID#/",
            "section_edit" => "#SECTION_ID#/action/#ACTION#/",
            "section_edit_icon" => "#SECTION_ID#/icon/action/#ACTION#/",
            "upload" => "#SECTION_ID#/action/upload/",
            "detail" => "#SECTION_ID#/#ELEMENT_ID#/",
            "detail_edit" => "#SECTION_ID#/#ELEMENT_ID#/action/#ACTION#/",
            "detail_list" => "list/",
            "search" => "search/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "section" => Array(),
            "section_edit" => Array(),
            "section_edit_icon" => Array(),
            "upload" => Array(),
            "detail" => Array(),
            "detail_edit" => Array(),
            "detail_list" => Array(),
            "search" => Array(),
        )
    ),
);?>


Фотогалерея 2.0 (многопользовательская) (комплексный компонент)

Комплексный компонент Фотогалерея 2.0 (многопользовательская) позволяет получить полнофункциональную многопользовательскую фотогалерею, создавая физически только одну страницу.

Описание photogallery_user

Параметры компонента позволяют произвести следующие настройки внешнего вида фотогалереи:

  • отображение облака тегов;
  • размеры картинок анонса (эскизов), детального просмотра фотографии, а также размеры картинки-анонса и картинки фотоальбома;
  • настройки голосования и отзывов;
  • и другие.

Внимание! Компонент поддерживает два режима настройки: простой и расширенный. Расширенный предоставляет более обширные средства настройки.

Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры. Простой режим

Поле | Параметр | Описание
Основные параметры
Использовать простой режим настройки | USE_LIGHT_VIEW | [Y|N] При отмеченной опции будет использоваться простой режим настройки фотогалереи (значения остальных параметров будут по умолчанию).
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
Группы пользователей, которым разрешено создавать галерею | GALLERY_GROUPS | Указываются группы пользователей, которым разрешено создавать галерею.
Включить премодерацию фото | MODERATION | [Y|N] При отмеченной опции будет использоваться механизм премодерации фото.
Путь к профилю пользователя | PATH_TO_USER | Указывается шаблон пути к профилю пользователя.
Отображать навигационную цепочку 'хлебные крошки' в рамках комплексного компонента | SHOW_NAVIGATION | [Y|N] При отмеченной опции на странице фотогалереи будет отображаться навигационная цепочка ('хлебные крошки')..
Анализировать параметры соц.сети | ANALIZE_SOCNET_PERMISSION | [Y|N] При отмеченной опции будет производится проверка прав доступа пользователя к модулю Социальная сеть.
Настройки фотогалереи
Размер картинки галереи (px) | GALLERY_AVATAR_SIZE | Указывается размер аватара владельца галереи в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Размер картинки-анонса фотоальбома (px) | ALBUM_PHOTO_THUMBS_SIZE | Указывается размер картинки-анонса фотоальбома в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Размер фотографии-анонса (px) | THUMBNAIL_SIZE | Указывается размер картинки-анонса альбома в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Размер картинки в предпросмотре в списке альбомов (px) | SECTION_LIST_THUMBS_SIZE | Указывается размер картинки в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Обязательно ограничивать размер оригинала (px) (при значении 0 ограничение не происходит) | ORIGINAL_SIZE | Задается размер оригинала фотографии в пикселях. Фотография будет уменьшена до указанной величины. Если указано значение 0, то изменение размера не происходит. Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di] Настраиваемые параметры при включенном режиме поддержки ЧПУ:
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - страница со списком альбомов;
  • galleries - страница со списком галерей;
  • gallery - страница с содержимым галереи;
  • gallery_edit - страница редактирования параметров галереи;
  • section - страница просмотра альбомов;
  • section_edit - страница редактирования параметров альбома;
  • section_edit_icon - страница выбора обложки альбома;
  • upload - страница загрузки фотографий;
  • detail - страница просмотра фотографий;
  • detail_edit - страница редактирования параметров фотографии;
  • detail_slide_show - страница слайд-шоу;
  • detail_list - страница со списком фотографий;
  • search - страница поиска;
  • tags - страница тегов.
[/di] SEF_FOLDER и SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить [dw]массив переменных[/dw][di] Настраиваемые параметры при выключенном режиме поддержки ЧПУ:
ID пользователя | USER_ID | Задается переменная, в которой будет передаваться идентификатор пользователя.
Код галереи | USER_ALIAS | Задается переменная, в которой будет передаваться символьный код галереи.
Идентификатор раздела | SECTION_ID | Задается переменная, в которой будет передаваться идентификатор раздела (альбома).
Идентификатор элемента | ELEMENT_ID | Задается переменная, в которой будет передаваться идентификатор элемента (фотографии).
Идентификатор страницы | PAGE_NAME | Задается переменная, в которой будет передаваться идентификатор страницы.
Идентификатор действия | ACTION | Задается переменная, в которой будет передаваться идентификатор действия.
[/di] VARIABLE_ALIASES, который включает в себя: USER_ID, USER_ALIAS, SECTION_ID, ELEMENT_ID, PAGE_NAME, ACTION.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Фотографии.
[Главная страница] Количество фото на главной странице | INDEX_PAGE_TOP_ELEMENTS_COUNT | Указывается количество фотографий, выводимых на главной странице фотогалереи.
[Главная страница] Показывать только опубликованные фото SHOW_ONLY_PUBLIC [Y|N] При отмеченной опции только на главной странице будут выводится только опубликованные фотографии.

Если опция отмечена, то необходимо настроить следущие параметры: PUBLIC_BY_DEFAULT и MODERATE.
Показывать секцию кнопок управления | SHOW_CONTROLS_BUTTONS | [Y|N] При отмеченной опции на Главной странице пользовательской галереи будут показываться кнопки управления (например Мои фото, Мои галереи, Загрузить фото). Параметр доступен только при использовании шаблона default.
Настройки голосования
Разрешить голосование USE_RATING [Y|N] При отмеченной опции посетители смогут голосовать за фотографии, выставляя баллы, на странице с детальной информацией. При установленной опции становятся доступными [dw]следующие поля.[/dw][di] Доступные поля:
Максимальный балл MAX_VOTE Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
В качестве рейтинга показывать DISPLAY_AS_RATING Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • Рейтинг (rating) - высчитывается на основе формулы:

    Rating = (SUM(vote)+3.125*10) / (COUNT(*)+10), где:

    3.125 - это стартовый рейтинг. То есть изначально (при отсутствии голосов) рейтинг фотографии равен 3.125.

    10 - это константа, определяющая количество голосов, "утяжеляющих" первоначальное значение рейтинга (3.125). Это исключает случай, когда, например, трое проголосовавших человека могут вознести или опустить фотографию всего тремя голосами.

    При такой формуле расчета значение рейтинга получается более "плавное" и не так скачет при небольшом количестве голосующих. Чем больше голосов, тем больше рейтинг приближается к среднему арифметическому.

  • Среднее значение (vote_avg) - высчитывается как среднее арифметическое всех баллов к фотографии;
  • Рейтинг (главного модуля) (rating_main) - использование рейтинга главного модуля.

    Подробнее:

    - см. главу Рейтинги [image] [image];
    - в блоге Рейтинги: создание собственного критерия рейтингования [image] [image];
    - в блоге Саморегулируемое сообщество, построенное на двухфакторном рейтинге [image] [image].
Вид кнопок рейтинга RATING_MAIN_TYPE Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • по умолчанию;
  • Плюс / минус (standart);
  • Мне нравится (like).

Параметр доступен только если выбран Рейтинг (главного модуля) (rating_main).
[/di]
Настройки тегов
Показывать теги SHOW_TAGS [Y|N] При отмеченной опции будет показано облако тегов фотогалереи. Станут активными [dw]дополнительные поля[/dw][di]
Максимальный размер шрифта (px) | TAGS_FONT_MAX | Указывается максимальный размер шрифта отображения тегов (в пикселах).
Минимальный размер шрифта (px) | TAGS_FONT_MIN | Указывается минимальный размер шрифта отображения тегов (в пикселах).
Цвет более позднего тега (пример: "C0C0C0") | TAGS_COLOR_NEW | Указывается код цвета тегов, дата создания которых наиболее поздняя (пример: "C0C0C0").
Цвет более раннего тега (пример: "FEFEFE") | TAGS_COLOR_OLD | Указывается код цвета тегов, дата создания которых наиболее ранняя (пример: "FEFEFE").
[/di]
Загрузка фото
Тип загрузчика PHOTO_UPLOADER_TYPE Указывается тип загрузчика фотографий в фотогалерею:
  • Одиночная загрузка через форму (form);
  • Множественный загрузчик (Java/ActiveX) (applet);
  • Множественный Flash-загрузчик (flash).
Параметр устарел с версии 15.0.0.
Схема множественного загрузчика APPLET_LAYOUT Параметр определяет тип загрузчика в фотогалерии по умолчанию:
  • Стандартный шаблон (extended);
  • Упрощенный шаблон загрузчика (simple).
Выбор параметра доступен только при выборе параметра "Тип загрузчика" (PHOTO_UPLOADER_TYPE) равным "Множественный загрузчик (Java/ActiveX)" (applet).

Параметр устарел с версии 15.0.0.
Максимальный размер загружаемого файла (не должен превышать 1024Mб) (Мб) | UPLOAD_MAX_FILE_SIZE | Указывается максимальный размер загружаемого файла в Мб (не должен превышать 1024Mб).
Наносить авторский знак USE_WATERMARK

Внимание! Функционал авторского знака устарел и не поддерживается с версии 14.5.0 Главного модуля (main).

[Y|N] При отмеченной опции при загрузке фотографий можно будет наносить авторский знак. Станут доступны [dw]поля настройки авторского знака.[/dw][di] Поля настройки авторского знака:
Правила нанесения авторского знака WATERMARK_RULES Указывается правило нанесения авторского знака:
  • На усмотрение пользователя (USER);
  • Обязательно наносить авторский знак (ALL).
Если выбрано значение ALL, то необходимо настроить дополнительные параметры (приведены в таблице ниже).
Файл со шрифтом для авторского знака | PATH_TO_FONT | Указывается файл со шрифтом для создания авторского знака (будет использоваться также и при множественной загрузке). Шрифты предварительно загружаются в директорию \bitrix\modules\photogallery\fonts\. Поддерживаются TTF-, OTF- и PS-шрифты.
Минимальный размер фото для авторского знака (px) | WATERMARK_MIN_PICTURE_SIZE | Указывается минимальный размер фото, на которых будет нанесен авторский знак в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально. На фотографии меньшего размера знак добавлен не будет.

Дополнительные параметры, заполняемые при выборе правила Обязательно наносить авторский знак
(обратите внимание, что список параметров меняется в зависимости от типа авторского знака) :
Тип авторского знака WATERMARK_TYPE Указывается тип авторского знака:
  • Надпись (текст) (TEXT);
  • Картинка (PICTURE).
Если выбрано значение TEXT, то дополнительно необходимо настроить параметры: WATERMARK_TEXT, WATERMARK_COLOR и WATERMARK_SIZE.

Если выбрано значение PICTURE, то дополнительно необходимо настроить параметры: WATERMARK_FILE и WATERMARK_FILE_ORDER.
Текст надписи | WATERMARK_TEXT | Задается текст авторского знака.
Цвет надписи (без #, например, FF00EE) | WATERMARK_COLOR | Указывается шестнадцатеричный код цвета надписи без использования #.
Размер надписи (% от размера картинки) | WATERMARK_SIZE | Задается размер надписи авторского знака в процентном соотношении от размера фото.
Размещение авторского знака WATERMARK_POSITION Указывается область размещения авторского знака на фото:
  • Сверху слева (tl);
  • Сверху по центру (tc);
  • Сверху справа (tr);
  • Cлева (ml);
  • По центру (mc);
  • Cправа (mr);
  • Снизу cлева (bl);
  • Снизу по центру (bc);
  • Снизу cправа (br).
Физический полный путь к картинке | WATERMARK_FILE | Указывается полный путь к картинке для авторского знака относительно корня сайта.
Расположение картинки на фото WATERMARK_FILE_ORDER Указывается тип расположения картинки авторского знака на фото:
  • Без изменений (usual);
  • Растянуть (resize);
  • Замостить (repeat).
Прозрачность авторского знака | WATERMARK_TRANSPARENCY | Задается величина прозрачности авторского знака (в %).
[/di]
Настройки отзывов
Разрешить отзывы USE_COMMENTS [Y|N] При отмеченной опции будет доступен функционал отзывов, станут активны [dw]дополнительные поля.[/dw][di] Дополнительные поля:
Компонент комментариев COMMENTS_TYPE Указывается компонент, с помощью которого будут добавляться комментарии:
  • Блоги (blog);
  • Форум (forum).
Если указать Блоги, то необходимо настроить параметр BLOG_URL.

Если указать Форум, то необходимо настроить параметр FORUM_ID.
Блог для комментариев | BLOG_URL | Указывается блог, в котором будут храниться комментарии.
ID форума для отзывов | FORUM_ID | Указывается один из созданных в системе форумов, который будет использован для комментариев.
[/di]

Параметры. Расширенный режим

Поле | Параметр | Описание
Настройки постраничной навигации
Количество альбомов на странице | SECTION_PAGE_ELEMENTS | Указывается количество альбомов, отображаемых на одной странице. Остальные альбомы будут выведены с помощью постраничной навигации.
Количество фото на странице | ELEMENTS_PAGE_ELEMENTS | Указывается количество фотографий, отображаемых на одной странице. Остальные фотографии будут выведены с помощью постраничной навигации.
Шаблон для постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указываются название шаблона для постраничной навигации.
Основные параметры
Использовать простой режим настройки | USE_LIGHT_VIEW | [Y|N] При отмеченной опции будет использоваться простой режим настройки фотогалереи (значения остальных параметров будут по умолчанию).
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
Группы пользователей, которым разрешено создавать галерею | GALLERY_GROUPS | Указываются группы пользователей, которым разрешено создавать галерею.
Разрешать создавать пользователям только одну галерею (группы пользователей, имеющие доступ на запись к инфоблоку, могут создавать неограниченное количество галерей) | ONLY_ONE_GALLERY | [Y|N] При отмеченной опции пользователям будет разрешено создать только одну галерею. Группы пользователей, имеющие доступ на запись к инфоблоку, могут создавать неограниченное количество галерей.
Включить премодерацию фото | MODERATION | [Y|N] При отмеченной опции будет использоваться механизм премодерации фото.
По какому полю сортируем альбомы SECTION_SORT_BY Указывается поле, по которому будет происходить сортировка альбомов:
  • ID - по идентификатору;
  • NAME - по названию;
  • SORT - по индексу сортировки;
  • ELEMENTS_CNT - по количесву фото в альбоме;
  • UF_DATE - по дате.
Порядок сортировки альбомов SECTION_SORT_ORD Задается порядок сортировки альбомов:
  • ASC – по возрастанию;
  • DESC – по убыванию.
По какому полю сортируем фото ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка фотографий:
  • SHOWS – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • RATING – по популярности;
  • COMMENTS – по комментариям.
  • rand – выведет элементы в произвольном порядке.
Порядок сортировки фото в альбомах ELEMENT_SORT_ORDER Задается порядок сортировки фотографий в альбомах:
  • ASC – по возрастанию;
  • DESC – по убыванию.
Путь к профилю пользователя | PATH_TO_USER | Указывается шаблон пути к профилю пользователя.
Отображать навигационную цепочку 'хлебные крошки' в рамках комплексного компонента | SHOW_NAVIGATION | [Y|N] При отмеченной опции на странице фотогалереи будет отображаться навигационная цепочка ('хлебные крошки')..
Анализировать параметры соц.сети | ANALIZE_SOCNET_PERMISSION | [Y|N] При отмеченной опции будет производится проверка прав доступа пользователя к модулю Социальная сеть.
Настройки фотогалереи
Размер картинки галереи (px) | GALLERY_AVATAR_SIZE | Указывается размер аватара владельца галереи в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Размер картинки-анонса фотоальбома (px) | ALBUM_PHOTO_THUMBS_SIZE | Указывается размер картинки-анонса фотоальбома в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Размер фотографии-анонса (px) | THUMBS_SIZE | Указывается размер картинки-анонса альбома в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Размер картинки в предпросмотре в списке альбомов (px) | SECTION_LIST_THUMBS_SIZE | Указывается размер картинки в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Обязательно ограничивать размер оригинала (px) (при значении 0 ограничение не происходит) | ORIGINAL_SIZE | Задается размер оригинала фотографии в пикселях. Фотография будет уменьшена до указанной величины. Если указано значение 0, то изменение размера не происходит. Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Качество фотографии-анонса (%) | JPEG_QUALITY1 | Указывается качество фотографии-анонса в процентах (100% - самое высокое качество).
Качество загружаемой фотографии (%) | JPEG_QUALITY | Указывается качество загружаемой фотографии в процентах (100% - самое высокое качество).
Дополнительные эскизы | ADDITIONAL_SIGHTS | Указываются типы для эскизов фотографий, которые должны быть показаны.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di] Настраиваемые параметры при включенном режиме поддержки ЧПУ:
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - страница со списком альбомов;
  • galleries - страница со списком галерей;
  • gallery - страница с содержимым галереи;
  • gallery_edit - страница редактирования параметров галереи;
  • section - страница просмотра альбомов;
  • section_edit - страница редактирования параметров альбома;
  • section_edit_icon - страница выбора обложки альбома;
  • upload - страница загрузки фотографий;
  • detail - страница просмотра фотографий;
  • detail_edit - страница редактирования параметров фотографии;
  • detail_slide_show - страница слайд-шоу;
  • detail_list - страница со списком фотографий;
  • search - страница поиска;
  • tags - страница тегов.
[/di] SEF_FOLDER и SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить [dw]массив переменных [/dw][di] Настраиваемые параметры при выключенном режиме поддержки ЧПУ:
ID пользователя | USER_ID | Задается переменная, в которой будет передаваться идентификатор пользователя.
Код галереи | USER_ALIAS | Задается переменная, в которой будет передаваться символьный код галереи.
Идентификатор раздела | SECTION_ID | Задается переменная, в которой будет передаваться идентификатор раздела (альбома).
Идентификатор элемента | ELEMENT_ID | Задается переменная, в которой будет передаваться идентификатор элемента (фотографии).
Идентификатор страницы | PAGE_NAME | Задается переменная, в которой будет передаваться идентификатор страницы.
Идентификатор действия | ACTION | Задается переменная, в которой будет передаваться идентификатор действия.
[/di] VARIABLE_ALIASES, который включает в себя: USER_ID, USER_ALIAS, SECTION_ID, ELEMENT_ID, PAGE_NAME, ACTION.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат вывода даты альбома | DATE_TIME_FORMAT_SECTION | Указывается формат показа даты и времени альбома. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат вывода даты фото | DATE_TIME_FORMAT_DETAIL | Указывается формат показа даты и времени фотографии. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Галерея.
[Главная страница] Количество фото на главной странице | INDEX_PAGE_TOP_ELEMENTS_COUNT | Указывается количество фотографий, выводимых на главной странице фотогалереи.
[Главная страница] Показывать только опубликованные фото SHOW_ONLY_PUBLIC [Y|N] При отмеченной опции только на главной странице будут выводится только опубликованные фотографии.

Если опция отмечена, то необходимо настроить следущие параметры: PUBLIC_BY_DEFAULT и MODERATE.
Показывать секцию кнопок управления | SHOW_CONTROLS_BUTTONS | [Y|N] При отмеченной опции на Главной странице пользовательской галереи будут показываться кнопки управления (например Мои фото, Мои галереи, Загрузить фото).
Настройки голосования
Разрешить голосование USE_RATING [Y|N] При отмеченной опции посетители смогут голосовать за фотографии, выставляя баллы, на странице с детальной информацией. При установленной опции становятся доступными [dw]следующие поля.[/dw][di] Доступные поля:
Максимальный балл MAX_VOTE Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
В качестве рейтинга показывать DISPLAY_AS_RATING Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • Рейтинг (rating) - высчитывается на основе формулы:

    Rating = (SUM(vote)+3.125*10) / (COUNT(*)+10), где:

    3.125 - это стартовый рейтинг. То есть изначально (при отсутствии голосов) рейтинг фотографии равен 3.125.

    10 - это константа, определяющая количество голосов, "утяжеляющих" первоначальное значение рейтинга (3.125). Это исключает случай, когда, например, трое проголосовавших человека могут вознести или опустить фотографию всего тремя голосами.

    При такой формуле расчета значение рейтинга получается более "плавное" и не так скачет при небольшом количестве голосующих. Чем больше голосов, тем больше рейтинг приближается к среднему арифметическому.

  • Среднее значение (vote_avg) - высчитывается как среднее арифметическое всех баллов к фотографии;
  • Рейтинг (главного модуля) (rating_main) - использование рейтинга главного модуля.

    Подробнее:

    - см. главу Рейтинги [image] [image];
    - в блоге Рейтинги: создание собственного критерия рейтингования [image] [image];
    - в блоге Саморегулируемое сообщество, построенное на двухфакторном рейтинге [image] [image].
Вид кнопок рейтинга RATING_MAIN_TYPE Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • по умолчанию;
  • Плюс / минус (standart);
  • Мне нравится (like).

Параметр доступен только если выбран Рейтинг (главного модуля) (rating_main).
[/di]
Настройки тегов
Показывать теги SHOW_TAGS [Y|N] При отмеченной опции будет показано [dw]облако тегов фотогалереи.[/dw][di] Облако тегов:
Количество тегов | TAGS_PAGE_ELEMENTS | Указывается количество тегов, отображаемых в облаке.
Период выборки тегов (дней) | TAGS_PERIOD | Указывается количество дней, за которые происходит выборка тегов.
Сужать область поиска | TAGS_INHERIT | [Y|N] При отмеченной опции выбранные теги добавляются в фильтр поиска.
Максимальный размер шрифта (px) | TAGS_FONT_MAX | Указывается максимальный размер шрифта отображения тегов (в пикселах).
Минимальный размер шрифта (px) | TAGS_FONT_MIN | Указывается минимальный размер шрифта отображения тегов (в пикселах).
Цвет более позднего тега (пример: "C0C0C0") | TAGS_COLOR_NEW | Указывается код цвета тегов, дата создания которых наиболее поздняя (пример: "C0C0C0").
Цвет более раннего тега (пример: "FEFEFE") | TAGS_COLOR_OLD | Указывается код цвета тегов, дата создания которых наиболее ранняя (пример: "FEFEFE").
Показывать цепочку навигации | TAGS_SHOW_CHAIN | [Y|N] При отмеченной опции будет показана цепочка навигации. Параметр работает, если параметр TAGS_INHERIT принимает значение Y.
[/di]
Загрузка фото
Тип загрузчика PHOTO_UPLOADER_TYPE Указывается тип загрузчика фотографий в фотогалерею:
  • Одиночная загрузка через форму (form);
  • Множественный загрузчик (Java/ActiveX) (applet);
  • Множественный Flash-загрузчик (flash).
Параметр устарел с версии 15.0.0.
Схема множественного загрузчика APPLET_LAYOUT Параметр определяет тип загрузчика в фотогалерии по умолчанию:
  • Стандартный шаблон (extended);
  • Упрощенный шаблон загрузчика (simple).
Выбор параметра доступен только при выборе параметра "Тип загрузчика" (PHOTO_UPLOADER_TYPE) равным "Множественный загрузчик (Java/ActiveX)" (applet).

Параметр устарел с версии 15.0.0.
Максимальный размер загружаемого файла (не должен превышать 1024Mб) (Мб) | UPLOAD_MAX_FILE_SIZE | Указывается максимальный размер загружаемого файла в Мб (не должен превышать 1024Mб).
Наносить авторский знак USE_WATERMARK

Внимание! Функционал авторского знака устарел и не поддерживается с версии 14.5.0 Главного модуля (main).

[Y|N] При отмеченной опции при загрузке фотографий можно будет наносить авторский знак.Станут доступны [dw]поля настройки авторского знака.[/dw][di] Поля настройки авторского знака:
Правила нанесения авторского знака WATERMARK_RULES Указывается правило нанесения авторского знака:
  • На усмотрение пользователя (USER);
  • Обязательно наносить авторский знак (ALL).
Если выбрано значение Обязательно наносить авторский знак, то необходимо настроить дополнительные параметры (приведены в таблице ниже).
Файл со шрифтом для авторского знака | PATH_TO_FONT | Указывается файл со шрифтом для создания авторского знака (будет использоваться также и при множественной загрузке). Шрифты предварительно загружаются в директорию \bitrix\modules\photogallery\fonts\. Поддерживаются TTF-, OTF- и PS-шрифты.
Минимальный размер фото для авторского знака (px) | WATERMARK_MIN_PICTURE_SIZE | Указывается минимальный размер фото, на которых будет нанесен авторский знак в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально. На фотографии меньшего размера знак добавлен не будет.

Дополнительные параметры, заполняемые при выборе правила Обязательно наносить авторский знак
(обратите внимание, что список параметров меняется в зависимости от типа авторского знака) :
Тип авторского знака WATERMARK_TYPE Указывается тип авторского знака:
  • Надпись (текст) (TEXT);
  • Картинка (PICTURE).
Если выбрано значение TEXT, то дополнительно необходимо настроить параметры: WATERMARK_TEXT, WATERMARK_COLOR и WATERMARK_SIZE.

Если выбрано значение PICTURE, то дополнительно необходимо настроить параметры: WATERMARK_FILE и WATERMARK_FILE_ORDER.
Текст надписи | WATERMARK_TEXT | Задается текст авторского знака.
Цвет надписи (без #, например, FF00EE) | WATERMARK_COLOR | Указывается шестнадцатеричный код цвета надписи без использования #.
Размер надписи (% от размера картинки) | WATERMARK_SIZE | Задается размер надписи авторского знака в процентном соотношении от размера фото.
Размещение авторского знака WATERMARK_POSITION Указывается область размещения авторского знака на фото:
  • Сверху слева (tl);
  • Сверху по центру (tc);
  • Сверху справа (tr);
  • Cлева (ml);
  • По центру (mc);
  • Cправа (mr);
  • Снизу cлева (bl);
  • Снизу по центру (bc);
  • Снизу cправа (br).
Физический полный путь к картинке | WATERMARK_FILE | Указывается полный путь к картинке для авторского знака относительно корня сайта.
Расположение картинки на фото WATERMARK_FILE_ORDER Указывается тип расположения картинки авторского знака на фото:
  • Без изменений (usual);
  • Растянуть (resize);
  • Замостить (repeat).
Прозрачность авторского знака | WATERMARK_TRANSPARENCY | Задается величина прозрачности авторского знака (в %).
[/di]
Настройки отзывов
Разрешить отзывы USE_COMMENTS [Y|N] При отмеченной опции будет доступен функционал отзывов.При расширенном режиме станут доступны [dw]дополнительные поля.[/dw][di] Дополнительные поля:
Компонент комментариев COMMENTS_TYPE Указывается компонент, с помощью которого будут добавляться комментарии:
  • Блоги (blog);
  • Форум (forum).
Если указать Блоги, то необходимо настроить следущие параметры: BLOG_URL, COMMENTS_COUNT, PATH_TO_USER, PATH_TO_BLOG.

Если указать Форум, то необходимо настроить следущие параметры: FORUM_ID, URL_TEMPLATES_READ, URL_TEMPLATES_PROFILE_VIEW, USE_CAPTCHA, SHOW_LINK_TO_FORUM, PREORDER.
Блог для комментариев | BLOG_URL | Указывается один из созданных в системе блогов, в котором будут храниться комментарии.
Количество комментариев на странице | COMMENTS_COUNT | Указывается количество комментариев, выводимых на одной странице. Остальные комментарии будут выведены с помощью постраничной навигации.
Путь к блогу | PATH_TO_BLOG | Задается путь к главной странице блога относительно корня сайта.
ID форума для отзывов | FORUM_ID | Указывается один из созданных в системе форумов, который будет использован для комментариев.
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума.
Страница пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы профиля пользователя относительно корня сайта.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления комментария в публичной части.
Показывать ссылку на форум | SHOW_LINK_TO_FORUM | [Y|N] При отмеченной опции на странице фотографии будет отображена ссылка на форум обсуждения.
Выводить сообщения в прямом порядке | PREORDER | [Y|N] При отмеченной опции собщения будут отсортированы по дате создания по возрастанию.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Начинать тему текстом элемента | POST_FIRST_MESSAGE | [Y|N] При отмеченной опции в обсуждении на форуме будет выведено первое сообщение отзыва.
[/di]

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photogallery_user","",Array(
        "INDEX_PAGE_TOP_ELEMENTS_COUNT" => "45",
        "SHOW_ONLY_PUBLIC" => "Y",
        "MODERATE" => "N",
        "SHOW_CONTROLS_BUTTONS" => "Y",
        "USE_LIGHT_VIEW" => "N",
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "11",
        "GALLERY_GROUPS" => array(),
        "ONLY_ONE_GALLERY" => "Y",
        "MODERATION" => "Y",
        "SECTION_SORT_BY" => "UF_DATE",
        "SECTION_SORT_ORD" => "DESC",
        "ELEMENT_SORT_FIELD" => "id",
        "ELEMENT_SORT_ORDER" => "desc",
        "PATH_TO_USER" => "",
        "SEF_MODE" => "Y",
        "SECTION_PAGE_ELEMENTS" => "15",
        "ELEMENTS_PAGE_ELEMENTS" => "50",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "DATE_TIME_FORMAT_SECTION" => "d.m.Y",
        "DATE_TIME_FORMAT_DETAIL" => "d.m.Y",
        "GALLERY_AVATAR_SIZE" => "50",
        "ALBUM_PHOTO_THUMBS_SIZE" => "120",
        "THUMBNAIL_SIZE" => "100",
        "ORIGINAL_SIZE" => "1280",
        "JPEG_QUALITY1" => "100",
        "JPEG_QUALITY" => "100",
        "ADDITIONAL_SIGHTS" => array(),
        "USE_RATING" => "Y",
        "SHOW_TAGS" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SHOW_NAVIGATION" => "Y",
        "UPLOADER_TYPE" => "applet",
        "APPLET_LAYOUT" => "extended",
        "UPLOAD_MAX_FILE_SIZE" => "1024",
        "USE_WATERMARK" => "Y",
        "WATERMARK_RULES" => "ALL",
        "WATERMARK_TYPE" => "PICTURE",
        "WATERMARK_FILE" => "",
        "WATERMARK_FILE_ORDER" => "usual",
        "WATERMARK_POSITION" => "mc",
        "WATERMARK_TRANSPARENCY" => "20",
        "PATH_TO_FONT" => "",
        "WATERMARK_MIN_PICTURE_SIZE" => "800",
        "MAX_VOTE" => "5",
        "VOTE_NAMES" => array("1", "2", "3", "4", "5"),
        "DISPLAY_AS_RATING" => "rating",
        "USE_COMMENTS" => "Y",
        "COMMENTS_TYPE" => "forum",
        "FORUM_ID" => "7",
        "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
        "URL_TEMPLATES_READ" => "",
        "URL_TEMPLATES_PROFILE_VIEW" => "",
        "USE_CAPTCHA" => "Y",
        "SHOW_LINK_TO_FORUM" => "Y",
        "PREORDER" => "Y",
        "POST_FIRST_MESSAGE" => "Y",
        "TAGS_PAGE_ELEMENTS" => "150",
        "TAGS_PERIOD" => "",
        "TAGS_INHERIT" => "Y",
        "TAGS_FONT_MAX" => "30",
        "TAGS_FONT_MIN" => "14",
        "TAGS_COLOR_NEW" => "486DAA",
        "TAGS_COLOR_OLD" => "486DAA",
        "TAGS_SHOW_CHAIN" => "Y",
        "ANALIZE_SOCNET_PERMISSION" => "Y",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "galleries" => "galleries/#USER_ID#/",
            "gallery" => "#USER_ALIAS#/",
            "gallery_edit" => "#USER_ALIAS#/action/#ACTION#/",
            "section" => "#USER_ALIAS#/#SECTION_ID#/",
            "section_edit" => "#USER_ALIAS#/#SECTION_ID#/action/#ACTION#/",
            "section_edit_icon" => "#USER_ALIAS#/#SECTION_ID#/icon/action/#ACTION#/",
            "upload" => "#USER_ALIAS#/#SECTION_ID#/action/upload/",
            "detail" => "#USER_ALIAS#/#SECTION_ID#/#ELEMENT_ID#/",
            "detail_edit" => "#USER_ALIAS#/#SECTION_ID#/#ELEMENT_ID#/action/#ACTION#/",
            "detail_slide_show" => "#USER_ALIAS#/#SECTION_ID#/#ELEMENT_ID#/slide_show/",
            "detail_list" => "list/",
            "search" => "search/",
            "tags" => "tags/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "galleries" => Array(),
            "gallery" => Array(),
            "gallery_edit" => Array(),
            "section" => Array(),
            "section_edit" => Array(),
            "section_edit_icon" => Array(),
            "upload" => Array(),
            "detail" => Array(),
            "detail_edit" => Array(),
            "detail_slide_show" => Array(),
            "detail_list" => Array(),
            "search" => Array(),
            "tags" => Array(),
        )
    ),
);?>


Альбом

Описание photogallery.section

Компонент выводит информацию об одном альбоме:

  • обложку альбома;
  • ссылку на редактирование свойств альбома;
  • ссылку на страницу редактирования обложки альбома;
  • ссылку на удаление альбома;
  • ссылки на список альбомов, на добавление альбома, на загрузку фотографий.
Вместе с данным компонентом на странице обычно используется компонент Фото (список), который выводит список фотографий данного альбома. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
ID раздела | SECTION_ID | Указывается числовой код, в котором передается идентификатор раздела. Поле может быть оставлено пустым, если указан Код раздела.
Код раздела | SECTION_CODE | Указывается символьный код раздела, из которого будут выбраны фотографии. Поле может быть оставлено пустым, если указан ID раздела.
Код фотогалереи | USER_ALIAS | Задается переменная, в которой будет передаваться символьный код галереи.
Режим работы фотогалереи BEHAVIOUR Указывается режим работы фотогалереи:
  • пустое поле - простой режим, т.е. один пользователь;
  • USER - многопользовательский режим.
Если параметр принимает значение USER, то необходимо настроить параметр GALLERY_URL и GALLERY_SIZE.
Шаблоны ссылок
Список разделов | SECTIONS_TOP_URL | Указывается адрес страницы со списком разделов (альбомов).
URL страницы с содержимым раздела | SECTION_URL | Указывается адрес страницы с содержимым раздела (альбома).
Альбом (редактирование) | SECTION_EDIT_URL | Указывается адрес страницы редактирования параметров альбома. Страница может быть создана с помощью компонента Альбом (редактирование).
Альбом (редактирование обложки) | SECTION_EDIT_ICON_URL | Указывается адрес страницы выбора обложки альбома. Страница может быть создана с помощью компонента Альбом (редактирование обложки).
Страница слайд-шоу | DETAIL_SLIDE_SHOW_URL | Указывается адрес страницы просмотра слайд-шоу.
Загрузка фото | UPLOAD_URL | Указывается адрес страницы загрузки фотографий. Страница может быть создана с помощью компонента Фото (загрузка).
Содержимое галереи | GALLERY_URL | Указывается адрес страницы просмотра содержимого галереи.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат вывода даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Размер альбома (px) | ALBUM_PHOTO_SIZE | Указывается размер картинки обложки фотоальбома в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Размер картинки-анонса альбома (px) | ALBUM_PHOTO_THUMBS_SIZE | Указывается размер картинки-анонса фотоальбома в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Возвращать массив данных альбома | RETURN_SECTION_INFO | [Y|N] При отмеченной опции компонент будет возвращать массив данных альбома.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] При отмеченной опции будет установлен статус 404, если не будут найдены элементы или раздел фотогалереи.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено <название_альбома>.
Размер фотогалереи | GALLERY_SIZE | Указывается размер галереи пользователя в Мб.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photogallery.section","",Array(
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "9",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "SECTION_CODE" => "",
        "USER_ALIAS" => "",
        "BEHAVIOUR" => "USER",
        "INDEX_URL" => "index.php",
        "SECTION_URL" => "section.php?SECTION_ID=#SECTION_ID#",
        "SECTION_EDIT_URL" => "section_edit.php?SECTION_ID=#SECTION_ID#",
        "SECTION_EDIT_ICON_URL" => "section_edit_icon.php?SECTION_ID=#SECTION_ID#",
        "DETAIL_SLIDE_SHOW_URL" => "slide_show.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "UPLOAD_URL" => "upload.php?SECTION_ID=#SECTION_ID#",
        "DATE_TIME_FORMAT" => "d.m.Y",
        "ALBUM_PHOTO_SIZE" => "150",
        "ALBUM_PHOTO_THUMBS_SIZE" => "70",
        "RETURN_SECTION_INFO" => "Y",
        "SET_STATUS_404" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SET_TITLE" => "Y"
    ),
);?>


Альбом (список)

Описание photogallery.section.list

Компонент выводит список альбомов с информацией о количестве фотографий, вложенных альбомов в каждом и ссылками на просмотр содержимого альбомов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, фотографии из которого будут выводиться.
ID раздела | SECTION_ID | Указывается числовой код, в котором передается идентификатор раздела. Поле может быть оставлено пустым, если указан Код раздела.
Код раздела | SECTION_CODE | Указывается символьный код раздела, из которого будут выбраны фотографии. Поле может быть оставлено пустым, если указан ID раздела.
Режим работы галереи BEHAVIOUR Указывается режим работы фотогалереи:
  • SIMPLE - простой, т.е. один пользователь;
  • USER - многопользовательский.
Если параметр принимает значение USER (многопользовательский), то необходимо настроить параметры USER_ALIAS, GALLERY_URL и GALLERY_SIZE.
Выводить список нескольких фотографий альбома вместо отображения обложки PHOTO_LIST_MODE [Y|N] При отмеченной опции вместо обложки будет выводиться список нескольких фотографий альбома.При выборе данной опции станут доступны [dw]дополнительные поля.[/dw][di] Дополнительные поля:
Количество выводимых фотографий в списке альбомов | SHOWN_ITEMS_COUNT | Задается количество фотографий, которое будет показано на странице списка альбомов.
Первое поле сортировки фото ELEMENT_SORT_FIELD Указывается первое поле, по которому будет происходить сортировка фотографий:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER Указывается порядок сортировки фотографий:
  • по возрастанию (asc);
  • по убыванию (desc).
Второе поле сортировки фото ELEMENT_SORT_FIELD1 Указывается второе поле, по которому будет происходить сортировка фотографий:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER1 Указывается порядок сортировки фотографий:
  • по возрастанию (asc);
  • по убыванию (desc).
Код фотогалереи | USER_ALIAS | Задается переменная, в которой будет передаваться символьный код фотогалереи.
[/di]
По какому полю сортируем разделы SORT_BY Указывается поле, по которому будет происходить сортировка альбомов:
  • ID – по идентификатору;
  • NAME – по названию;
  • SORT – по индексу сортировки;
  • ELEMENTS_CNT – по количеству элементов в альбоме;
  • UF_DATE – по дате.
Порядок сортировки разделов SORT_ORD Задается порядок сортировки фотографий в разделе:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Количество элементов на странице | PAGE_ELEMENTS | Указывается количество альбомов, выводимых на одной странице. Весь список альбомов будет выведен с помощью постраничной навигации.
Шаблоны ссылок
Главная страница | INDEX_URL | Указывается адрес страницы со списком разделов (альбомов).
URL страницы с содержимым раздела | SECTION_URL | Указывается адрес страницы с содержимым раздела (альбома).
Альбом (редактирование) | SECTION_EDIT_URL | Указывается адрес страницы редактирования параметров альбома. Страница может быть создана с помощью компонента Альбом (редактирование).
Альбом (редактирование обложки) | SECTION_EDIT_ICON_URL | Указывается адрес страницы выбора обложки альбома. Страница может быть создана с помощью компонента Альбом (редактирование обложки).
Страница загрузки фото | UPLOAD_URL | Указывается адрес страницы загрузки фотографий. Страница может быть создана с помощью компонента Фото (загрузка).
Содержимое галереи | GALLERY_URL | Указывается адрес страницы с содержимым галереи.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Размер альбома (px) | ALBUM_PHOTO_SIZE | Указывается размер картинки обложки фотоальбома в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Размер картинки-анонса альбома (px) | ALBUM_PHOTO_THUMBS_SIZE | Указывается размер картинки-анонса фотоальбома в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Шаблон для постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указываются название шаблона для постраничной навигации.
Формат вывода даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Альбомы.
Размер фотогалереи | GALLERY_SIZE | Указывается размер галереи пользователя в Мб.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photogallery.section.list","",Array(
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "9",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "SECTION_CODE" => "",
        "USER_ALIAS" => "",
        "BEHAVIOUR" => "",
        "PHOTO_LIST_MODE" => "Y",
        "SHOWN_ITEMS_COUNT" => "6",
        "ELEMENT_SORT_FIELD" => "SORT",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD1" => "",
        "ELEMENT_SORT_ORDER1" => "asc",
        "SORT_BY" => "UF_DATE",
        "SORT_ORD" => "ASC",
        "INDEX_URL" => "sections_top.php",
        "SECTION_URL" => "section.php?USER_ALIAS=#USER_ALIAS#&SECTION_ID=#SECTION_ID#",
        "SECTION_EDIT_URL" => "section_edit.php?USER_ALIAS=#USER_ALIAS#&SECTION_ID=#SECTION_ID#",
        "SECTION_EDIT_ICON_URL" => "section_edit_icon.php?USER_ALIAS=#USER_ALIAS#&SECTION_ID=#SECTION_ID#",
        "UPLOAD_URL" => "upload.php?USER_ALIAS=#USER_ALIAS#SECTION_ID=#SECTION_ID#",
        "ALBUM_PHOTO_SIZE" => "150",
        "ALBUM_PHOTO_THUMBS_SIZE" => "70",
        "PAGE_ELEMENTS" => "5",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "DATE_TIME_FORMAT" => "d.m.Y",
        "SET_STATUS_404" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "DISPLAY_PANEL" => "Y"
    )
);?>


Панель

Описание photogallery.user

Компонент выводит информацию о галерее пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
Код галереи | USER_ALIAS | Указывается символьный код галереи.
Шаблоны ссылок
Главная страница | INDEX_URL | Указывается адрес главной страницы галереи.
Просмотр содержимого галереи | GALLERY_URL | Указывается адрес страницы просмотра содержимого галереи.
Список галерей пользователя | GALLERIES_URL | Указывается адрес страницы со списоком галерей пользователя.
Редактирование галереи | GALLERY_EDIT_URL | Указывается адрес страницы редактирования галереи.
Загрузка фото | UPLOAD_URL | Указывается адрес страницы загрузки фотографий.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Разрешить зарегистрированным пользователям создавать только одну галерею | ONLY_ONE_GALLERY | [Y|N] При отмеченной опции зарегистрированным пользователям будет разрешено создать только одну галерею.
Группы пользователей, которым разрешено создавать галерею | GALLERY_GROUPS | Указываются группы пользователей, которым разрешено создавать галерею.
Размер галереи (Мб) | GALLERY_SIZE | Указываются размер галереи одного пользователя в Мб.
Размер аватара галереи (px) | GALLERY_AVATAR_SIZE | Указывается размер аватара владельца галереи в пикселях (px). Размер задается для одной сторона картинки, вторая будет высчитана пропорционально для загружаемого изображения.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:photogallery.user","",Array(
        "GALLERY_AVATAR_SIZE" => "50",
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "9",
        "USER_ALIAS" => $_REQUEST["USER_ALIAS"],
        "INDEX_URL" => "index.php",
        "GALLERY_URL" => "gallery.php&USER_ALIAS=#USER_ALIAS#",
        "GALLERIES_URL" => "galleries.php&USER_ID=#USER_ID#",
        "GALLERY_EDIT_URL" => "gallery_edit.php?USER_ALIAS=#USER_ALIAS#&ACTION=#ACTION#",
        "UPLOAD_URL" => "upload.php&USER_ALIAS=#USER_ALIAS#&SECTION_ID=#SECTION_ID#&ACTION=upload",
        "ONLY_ONE_GALLERY" => "Y",
        "GALLERY_GROUPS" => Array("1"),
        "GALLERY_SIZE" => "50",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Фотогалерея (редактирование)

Описание photogallery.gallery.edit

Компонент выводит форму редактирования параметров фотогалереи пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
Код галереи | USER_ALIAS | Указывается символьный код галереи.
Шаблоны ссылок
Главная страница | INDEX_URL | Указывается адрес главной страницы галереи.
Просмотр содержимого галереи | GALLERY_URL | Указывается адрес страницы просмотра содержимого галереи.
Список галерей пользователя | GALLERIES_URL | Указывается адрес страницы со списком галерей пользователя.
Редактирование галереи | GALLERY_EDIT_URL | Указывается адрес страницы редактирования галереи.
Дополнительные настройки
Разрешить зарегистрированным пользователям создавать только одну галерею | ONLY_ONE_GALLERY | [Y|N] При отмеченной опции зарегистрированным пользователям будет разрешено создать только одну галерею.
Группы пользователей, которым разрешено создавать галерею | GALLERY_GROUPS | Указываются группы пользователей, которым разрешено создавать галерею.
Размер галереи (Мб) | GALLERY_SIZE | Указываются размер галереи одного пользователя в Мб.
Размер аватара галереи (px) | GALLERY_AVATAR_SIZE | Указывается размер аватара владельца галереи в пикселях (px). Размер задается для одной сторона картинки, вторая будет высчитана пропорционально для загружаемого изображения.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:photogallery.gallery.edit","",Array(
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "9",
        "USER_ALIAS" => $_REQUEST["USER_ALIAS"],
        "INDEX_URL" => "index.php",
        "GALLERY_URL" => "gallery.php&USER_ALIAS=#USER_ALIAS#",
        "GALLERIES_URL" => "galleries.php&USER_ID=#USER_ID#",
        "GALLERY_EDIT_URL" => "gallery_edit.php?USER_ALIAS=#USER_ALIAS#&ACTION=#ACTION#",
        "ONLY_ONE_GALLERY" => "Y",
        "GALLERY_GROUPS" => Array(),
        "GALLERY_SIZE" => "50",
        "GALLERY_AVATAR_SIZE" => "50"
    )
);?>


Фотогалерея (список)

Описание photogallery.gallery.list

Компонент выводит список фотогалерей пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
ID пользователя | USER_ID | Указывается идентификатор пользователя для вывода список фотогалерей.
По какому полю сортируем разделы SORT_BY Указывается поле, по которому будет происходить сортировка альбомов:
  • ID – по идентификатору;
  • NAME – по названию;
  • SORT – по индексу сортировки;
  • UF_DATE – по дате.
Порядок сортировки разделов SORT_ORD Задается порядок сортировки фотографий в разделе:
  • ASC – по возрастанию;
  • DESC – по убыванию.
Шаблоны ссылок
Главная страница | INDEX_URL | Указывается адрес главной страницы галереи.
Просмотр содержимого галереи | GALLERY_URL | Указывается адрес страницы просмотра содержимого галереи.
Редактирование галереи | GALLERY_EDIT_URL | Указывается адрес страницы редактирования галереи.
Загрузка фото | UPLOAD_URL | Указывается адрес страницы загрузки фотографий. Страница может быть создана с помощью компонента Фото (загрузка).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Разрешить зарегистрированным пользователям создавать только одну галерею | ONLY_ONE_GALLERY | [Y|N] При отмеченной опции зарегистрированным пользователям будет разрешено создать только одну галерею.
Группы пользователей, которым разрешено создавать галерею | GALLERY_GROUPS | Указываются группы пользователей, которым разрешено создавать галерею.
Размер галереи (Мб) | GALLERY_SIZE | Указываются размер галереи одного пользователя в Мб.
Количество элементов на странице | PAGE_ELEMENTS | Указывается количество элементов, выводимых на одной странице. Остальные элементов будут выведены с помощью постраничной навигации.
Шаблон для постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указываются название шаблона для постраничной навигации.
Формат вывода даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Размер аватара галереи (px) | GALLERY_AVATAR_SIZE | Указывается размер аватара владельца галереи в пикселях (px). Размер задается для одной сторона картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] При отмеченной опции будет установлен статус 404, если не будут найдены элементы или раздел фотогалереи.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photogallery.gallery.list","",Array(
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "10",
        "USER_ID" => $_REQUEST["USER_ID"],
        "SORT_BY" => "ID",
        "SORT_ORD" => "ASC",
        "INDEX_URL" => "index.php",
        "GALLERY_URL" => "gallery.php?USER_ALIAS=#USER_ALIAS#",
        "GALLERY_EDIT_URL" => "gallery_edit.php?USER_ALIAS=#USER_ALIAS#&ACTION=#ACTION#",
        "UPLOAD_URL" => "upload.php?USER_ALIAS=#USER_ALIAS#&SECTION_ID=#SECTION_ID#&ACTION=upload",
        "ONLY_ONE_GALLERY" => "Y",
        "GALLERY_GROUPS" => array(),
        "GALLERY_SIZE" => "50",
        "PAGE_ELEMENTS" => "0",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "DATE_TIME_FORMAT" => "d.m.Y",
        "GALLERY_AVATAR_SIZE" => "",
        "SET_STATUS_404" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
    ),
);?>


Фотогалерея (шаблоны)

Компонент photogallery.interface подключает библиотеку вспомогательных шаблонов. Компонент ничего не выводит. Компонент содержит два шаблона: .default и bookmark. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.


Flash-слайдшоу

Описание photogallery.imagerotator

Компонент устарел и не поддерживается с версии 15.0.0. При попытке добавить компонент на страницу будет выведено сообщение: Плагин "Adobe Flash Player" больше не поддерживается.

Компонент циклически проигрывает фотографии из фотогалереи. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры

Поле | Параметр | Описание
Параметры отображения
Ширина | WIDTH | Указывается ширина прогрываемой фотографии в пикселах.
Высота | HEIGHT | Указывается высота прогрываемой фотографии в пикселах.
Время смены слайдов (сек.) | ROTATETIME | Указывается время задержки перед загрузкой следующей фотографии в секундах.
Цвет панели | BACKCOLOR | Указывается цвет панели навигации.
Цвет текста панели | FRONTCOLOR | Указывается цвет текста панели навигации.
Цвет текста панели при наведении | LIGHTCOLOR | Указывается цвет текста панели навигации при наведении.
Цвет экрана | SCREENCOLOR | Указывается цвет области проигрывания фотографий.
Логотип (отображается в верхнем правом углу) | __FD_PARAM_LOGO | Указывается путь к файлу логотипа, можно выбрать из структуры сайта либо через Медиабиблиотеку.
Не вписывать фотографию в отображаемые размеры | OVERSTRETCH | [Y|N] При отмеченной опции фотография будет автоматически вписываться в указанный выше размер.
Показывать панель навигации | SHOWNAVIGATION | [Y|N] При отмеченной опции будет показываться панель навигации.
Показывать кнопку полноэкранного режима | USEFULLSCREEN | [Y|N] При отмеченной опции на панели навигации будет показываться кнопка перехода в полноэкранный режим.
Эффекты при смене фото TRANSITION Указывается один из эффектов перехода к следующей фотографии.
  • random - случайно;
  • fade - угасание;
  • bgfade - угасание фона;
  • blocks - блоки;
  • bubbles - пузырьки;
  • circles - круги;
  • flash - вспышка;
  • fluids - жидкости;
  • lines - линии;
  • slowfade - медленное угасание.
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
ID раздела | SECTION_ID | Указывается шаблон идентификатора раздела.
Режим работы галереи | BEHAVIOUR | Указывается режим работы галереи - простой (SIMPLE) или многопользовательский (USER). Если выбран многопользовательский режим (USER), то необходимо настроить параметр USER_ALIAS.
Код галереи | USER_ALIAS | Указывается переменная, в которой будет передаваться символьный код галереи.
Первое поле сортировки фото ELEMENT_SORT_FIELD Указывается первое поле, по которому будет происходить сортировка фотографий:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER Задается порядок сортировки фото:
  • ASC – по возрастанию;
  • DESC – по убыванию.
Второе поле сортировки фото ELEMENT_SORT_FIELD1 Указывается второе поле, по которому будет происходить сортировка фотографий:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER1 Задается порядок сортировки фото:
  • ASC – по возрастанию;
  • DESC – по убыванию.
Шаблоны ссылок
Фото | DETAIL_URL | Указывается шаблон адреса к фотографии.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:photogallery.imagerotator","",Array(
        "WIDTH" => "800",
        "HEIGHT" => "600",
        "ROTATETIME" => "5",
        "BACKCOLOR" => "#000000",
        "FRONTCOLOR" => "#FFFFFF",
        "LIGHTCOLOR" => "#e8e8e8",
        "SCREENCOLOR" => "#FFFFFF",
        "LOGO" => "",
        "OVERSTRETCH" => "Y",
        "SHOWNAVIGATION" => "Y",
        "USEFULLSCREEN" => "Y",
        "TRANSITION" => "random",
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "10",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "BEHAVIOUR" => "USER",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600000",
        "CACHE_NOTES" => "",
        "USER_ALIAS" => $_REQUEST["USER_ALIAS"],
        "ELEMENT_SORT_FIELD" => "SHOW_COUNTER",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD1" => "TIMESTAMP_X",
        "ELEMENT_SORT_ORDER1" => "asc",
        "DETAIL_URL" => "detail.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "USE_PERMISSIONS" => "Y"
    )
);?>


Альбом (редактирование обложки)

Описание photogallery.section.edit.icon

Компонент служит для редактирования обложки альбома. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блока.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться. Можно указать несколько инфоблоков.
ID раздела | SECTION_ID | Указывается числовой код, в котором передается идентификатор раздела. Поле может быть оставлено пустым, если указан Код раздела.
Код раздела | SECTION_CODE | Указывается символьный код раздела, из которого будут выбраны альбомы. Поле может быть оставлено пустым, если указан ID раздела.
Код фотогалереи | USER_ALIAS | Указывается имя переменной, в которой передается код галереи.
Режим работы фотогалереи BEHAVIOUR Указывается режим работы фотогалереи:
  • пустое поле - простой режим, т.е. один пользователь;
  • USER - многопользовательский режим.
Если параметр принимает значение USER, то необходимо настроить параметр [dw]GALLERY_URL.[/dw][di] Данный параметр заполняется в пункте Шаблоны ссылок.
Содержимое галереи GALLERY_URL Указывается адрес страницы с содержимым галереи.
[/di]
Поле сортировки фото | ELEMENT_SORT_FIELD | Указывается поле, по которому будет выполнена сортировка фотографий.
Порядок сортировки фото ELEMENT_SORT_ORDER Указывается порядок сортировки фотографий:
  • ASC - по возрастанию;
  • DESC - по убыванию.
Размер альбома (px) | ALBUM_PHOTO_WIDTH | Указывается ширина обложки альбома в пикселах (px).
Размер картинки-анонса альбома (px) | ALBUM_PHOTO_THUMBS_WIDTH | Указывается ширина картинки-анонса альбома в пикселах (px).
Шаблоны ссылок
Главная страница | INDEX_URL | Указывается адрес главной страницы фотогалереи.
URL страницы с содержимым раздела | SECTION_URL | Указывается адрес страницы с содержимым раздела (альбома).
Содержимое галереи | GALLERY_URL | Указывается адрес страницы с содержимым галереи (параметр указывается при многопользовательском режиме работы).
Дополнительные настройки
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] При отмеченной опции будет установлен статус 404, если не будут найдены элементы или раздел фотогалереи.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено <название_альбома (выбор обложки)>.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photogallery.section.edit.icon","",Array(
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "10",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "SECTION_CODE" => "",
        "USER_ALIAS" => "",
        "BEHAVIOUR" => "USER",
        "ELEMENT_SORT_FIELD" => "ID",
        "ELEMENT_SORT_ORDER" => "ASC",
        "INDEX_URL" => "index.php",
        "SECTION_URL" => "section.php?SECTION_ID=#SECTION_ID#",
        "ALBUM_PHOTO_WIDTH" => "150",
        "ALBUM_PHOTO_THUMBS_WIDTH" => "70",
        "SET_STATUS_404" => "Y",
        "SET_TITLE" => "Y",
    ),
);?>


Альбом (редактирование)

Описание photogallery.section.edit

Компонент позволяет отредактировать данные альбома: изменить название, дату создания, ввести описание, ограничить доступ к альбому по паролю. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, фотографии из которого будут выводиться.
ID раздела | SECTION_ID | Указывается числовой код, в котором передается идентификатор раздела. Поле может быть оставлено пустым, если указан Код раздела.
Код раздела | SECTION_CODE | Указывается символьный код раздела, из которого будут выбраны альбомы. Поле может быть оставлено пустым, если указан ID раздела.
Код фотогалереи | USER_ALIAS | Указывается имя переменной, в которой передается код галереи.
Режим работы фотогалереи BEHAVIOUR Указывается режим работы фотогалереи:
  • пустое поле - простой режим, т.е. один пользователь;
  • USER - многопользовательский режим.
Если параметр принмает значение USER, то необходимо настроить параметр GALLERY_URL.
Действие | ACTION | Указывается имя переменной, в которой содержится действие. Например ={$_REQUEST["ACTION"]}.
Шаблоны ссылок
Главная страница | SECTIONS_TOP_URL | Указывается адрес страницы со списком разделов (альбомов).
URL страницы с содержимым раздела | SECTION_URL | Указывается адрес страницы с содержимым раздела (альбома).
Содержимое галереи | GALLERY_URL | Указывается адрес страницы с содержимым галереи.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат вывода даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название альбома.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:photogallery.section.edit","",Array(
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => 9,
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "SECTION_CODE" => "",
        "USER_ALIAS" => "",
        "BEHAVIOUR" => "USER",
        "ACTION" => $_REQUEST["ACTION"],
        "SECTIONS_TOP_URL" => "sections_top.php",
        "SECTION_URL" => "section.php?USER_ALIAS=#USER_ALIAS#&SECTION_ID=#SECTION_ID#",
        "DATE_TIME_FORMAT" => "d.m.Y",
        "SET_STATUS_404" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => 3600,
        "SET_TITLE" => "Y",
        "GALLERY_URL" => "gallery.php?USER_ALIAS=#USER_ALIAS#"
    ),
);?>


Список фото (со слайдером)

Описание photogallery.detail.list.ex

Компонент выводит список фотографий в всплывающем окне со слайдером и комментариями. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
Режим работы галереи BEHAVIOUR Указывается режим работы фотогалереи:
  • SIMPLE - обычный режим, т.е. один пользователь;
  • USER - многопользовательский режим.
Если параметр принимает значение USER, то необходимо настроить параметры [dw]USER_ALIAS[/dw][di]
Код галереи USER_ALIAS Указывается имя переменной, в которой передается код галереи. Например ={$_REQUEST["USER_ALIAS"]}.
[/di] , [dw] GALLERY_SIZE[/dw][di] Данный параметр заполняется в пункте Дополнительные настройки.
Размер галереи GALLERY_SIZE Задается размер галереи одного пользователя в Мб (параметр задается при выборе многопользовательского режима).
[/di] и [dw]GALLERY_URL.[/dw][di] Данный параметр заполняется в пункте Шаблоны ссылок.
Содержимое галереи GALLERY_URL Указывается адрес страницы просмотра содержимого галереи пользователя.
[/di]
ID раздела | SECTION_ID | В поле указывается код, в котором передается идентификатор раздела (альбома).
Дополнительные параметры выбора фото ELEMENT_LAST_TYPE Указываются дополнительные параметры выбора фото:
  • none - нет;
  • count - выбирать несколько последних фото (ID);
  • time - выбирать фото за последние несколько дней;
  • period - выбирать фото за период.
Если параметр принимает значение выбирать несколько последних фото (ID), то необходимо настроить параметр [dw]ELEMENTS_LAST_COUNT.[/dw][di]
Количество последних фото для выбора ELEMENTS_LAST_COUNT Указывается количество последних фото для выбора.
[/di]

Если параметр принимает значение выбирать фото за последние несколько дней, то необходимо настроить параметр [dw]ELEMENTS_LAST_TIME.[/dw][di]
Количество дней для выбора фото ELEMENTS_LAST_TIME Указывается количество дней для выбора фото.
[/di]

Если параметр принимает значение выбирать фото за период, то необходимо настроить [dw]параметры[/dw][di]
Начало периода (ввести дату в формате "DD.MM.YYYY HH:MI:SS") | ELEMENTS_LAST_TIME_FROM | Указывается дата начала периода для выбора фото в формате DD.MM.YYYY HH:MI:SS.
Конец периода (ввести дату в формате "DD.MM.YYYY HH:MI:SS") | ELEMENTS_LAST_TIME_TO | Указывается дата окончания периода для выбора фото в формате DD.MM.YYYY HH:MI:SS.
[/di] ELEMENTS_LAST_TIME_FROM и ELEMENTS_LAST_TIME_TO.
Первое поле сортировки фото ELEMENT_SORT_FIELD Указывается первое поле, по которому будет происходить сортировка фотографий:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER Указывается порядок сортировки фотографий:
  • по возрастанию (asc);
  • по убыванию (desc).
Второе поле сортировки фото ELEMENT_SORT_FIELD1 Указывается второе поле, по которому будет происходить сортировка фотографий:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER1 Указывается порядок сортировки фотографий:
  • по возрастанию (asc);
  • по убыванию (desc).
Свойства | PROPERTY_CODE | Выберите свойства фотографий, которые должны быть отображены.
Использовать обратную навигацию | USE_DESC_PAGE | [Y|N] При отмеченной опции будет использоваться обратная постраничная навигацию для списка фотографий.
Количество фото на странице | PAGE_ELEMENTS | Указывается количество фотографий, выводимых на одной странице. Остальные фотографий будут выведены с помощью постраничной навигации.
Название шаблона для постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указывается название шаблона для постраничной навигации.
Шаблоны ссылок
Содержимое галереи | GALLERY_URL | Указывается адрес страницы просмотра содержимого галереи пользователя (параметр задается при выборе многопользовательского режима).
Страница детального просмотра | DETAIL_URL | Указывается адрес страницы детального просмотра альбома.
Страница слайд-шоу | DETAIL_SLIDE_SHOW_URL | Указывается адрес страницы слайд-шоу.
Страница поиска | SEARCH_URL | Указывается адрес страницы поиска.
Путь к профилю пользователя | PATH_TO_USER | Указывается путь к странице профиля пользователя фотогалереи.
Настройки отзывов
Разрешить отзывы USE_COMMENTS [Y|N] При отмеченной опции будет доступен функционал отзывов, появятся [dw]дополнительные поля.[/dw][di] Дополнительные поля:
Компонент комментариев COMMENTS_TYPE Указывается компонент, с помощью которого будут добавляться комментарии:
  • Блоги (blog);
  • Форум (forum).
Если указать Блоги, то необходимо настроить следущие параметры: BLOG_URL, PATH_TO_BLOG.

Если указать Форум, то необходимо настроить следущие параметры: FORUM_ID, URL_TEMPLATES_READ, URL_TEMPLATES_PROFILE_VIEW, USE_CAPTCHA, SHOW_LINK_TO_FORUM, PREORDER.
Количество комментариев на странице | COMMENTS_COUNT | Указывается количество комментариев на странице.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Блог для комментариев | BLOG_URL | Указывается один из созданных в системе блогов, который будет использован для комментариев.
Путь к блогу | PATH_TO_BLOG | Указывается путь к месту расположения блога.
ID форума для отзывов | FORUM_ID | Указывается один из созданных в системе форумов, который будет использован для комментариев.
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума.
Страница пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы профиля пользователя относительно корня сайта.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления комментария в публичной части.
Выводить сообщения в прямом порядке | PREORDER | [Y|N] При отмеченной опции собщения будут отсортированы по дате создания по возрастанию.
Начинать тему текстом элемента | POST_FIRST_MESSAGE | [Y|N] При отмеченной опции в обсуждении на форуме будет выведено первое сообщение отзыва.
[/di]
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Список фотографий.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в парметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | Указываются группы пользователей, имеющие доступ к детальной информации.
Формат вывода даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] При отмеченной опции будет установлен статус 404, если не будут найдены элементы или раздел фотогалереи.
Дополнительные эскизы | ADDITIONAL_SIGHTS | Выбираются типы эскизов для просмотра фотографий.
Активный эскиз (один из множества дополнительных и основных эскизов) | PICTURES_SIGHT | Указывается тип эскиза, с которого начинается просмотр фотографий альбома.
Размер галереи | GALLERY_SIZE | Задается размер галереи одного пользователя в Мб (параметр задается при выборе многопользовательского режима).
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Размер фотографии-анонса (px) | THUMBNAIL_SIZE | Указывается размер фотографии-анонса в пикселях (px). Размер задается для одной стороны картинки, вторая сторона изображения будет высчитана пропорционально.
Показывать навигацию SHOW_PAGE_NAVIGATION Указывается место отображения навигации:
  • none - не показывать;
  • top - сверху;
  • bottom - снизу;
  • both - сверху и снизу.
Показывать голосования | SHOW_RATING | [Y|N] При отмеченной опции будут показаны голосования.
Показывать количество показов | SHOW_SHOWS | [Y|N] При отмеченной опции будет отображено количество показов.
Показывать количество комментариев | SHOW_COMMENTS | [Y|N] При отмеченной опции будет отображено количество комментариев.
Максимальный балл | MAX_VOTE | Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
В качестве рейтинга показывать DISPLAY_AS_RATING Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • Рейтинг (rating) - высчитывается на основе формулы:

    Rating = (SUM(vote)+3.125*10) / (COUNT(*)+10), где:

    3.125 - это стартовый рейтинг. То есть изначально (при отсутствии голосов) рейтинг фотографии равен 3.125.

    10 - это константа, определяющая количество голосов, "утяжеляющих" первоначальное значение рейтинга (3.125). Это исключает случай, когда, например, трое проголосовавших человека могут вознести или опустить фотографию всего тремя голосами.

    При такой формуле расчета значение рейтинга получается более "плавное" и не так скачет при небольшом количестве голосующих. Чем больше голосов, тем больше рейтинг приближается к среднему арифметическому.

  • Среднее значение (vote_avg) - высчитывается как среднее арифметическое всех баллов к фотографии;
  • Рейтинг (главного модуля) (rating_main) - использование рейтинга главного модуля.

    Подробнее:

    - см. главу Рейтинги [image];
    - в блоге Рейтинги: создание собственного критерия рейтингования [image];
    - в блоге Саморегулируемое сообщество, построенное на двухфакторном рейтинге [image].
Вид кнопок рейтинга (главного модуля) RATING_MAIN_TYPE Указывается одно из значений, которое должно быть показано, если выбран Рейтинг (главного модуля) (rating_main):
  • по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photogallery.detail.list.ex","",Array(
        "THUMBNAIL_SIZE" => "120",
        "SHOW_PAGE_NAVIGATION" => "none",
        "SHOW_RATING" => "Y",
        "SHOW_SHOWS" => "Y",
        "SHOW_COMMENTS" => "Y",
        "MAX_VOTE" => "5",
        "VOTE_NAMES" => array("1","2","3","4","5"),
        "DISPLAY_AS_RATING" => "rating",
        "RATING_MAIN_TYPE" => "",
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "10",
        "BEHAVIOUR" => "USER",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_NOTES" => "",
        "USER_ALIAS" => $_REQUEST["USER_ALIAS"],
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "ELEMENT_LAST_TYPE" => "period",
        "ELEMENTS_LAST_TIME_FROM" => "",
        "ELEMENTS_LAST_TIME_TO" => "",
        "ELEMENT_SORT_FIELD" => "SORT",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD1" => "SHOW_COUNTER",
        "ELEMENT_SORT_ORDER1" => "asc",
        "PROPERTY_CODE" => array(),
        "GALLERY_URL" => "gallery.php?USER_ALIAS=#USER_ALIAS#",
        "DETAIL_URL" => "detail.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "DETAIL_SLIDE_SHOW_URL" => "slide_show.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "SEARCH_URL" => "search.php",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => array(),
        "USE_DESC_PAGE" => "Y",
        "PAGE_ELEMENTS" => "50",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "DATE_TIME_FORMAT" => "d.m.Y",
        "SET_STATUS_404" => "Y",
        "ADDITIONAL_SIGHTS" => array(),
        "PICTURES_SIGHT" => "real",
        "GALLERY_SIZE" => "",
        "PATH_TO_USER" => "/company/personal/user/#USER_ID#",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y"
    ),
false
);?>


Фото

Описание photogallery.detail

Компонент выводит детальную информацию по фотографии. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
ID раздела | SECTION_ID | Указывается числовой код, в котором передается идентификатор раздела (альбома).
ID элемента | ELEMENT_ID | Указывается числовой код, в котором передается идентификатор элемента (фотографии).
Режим работы фотогалереи BEHAVIOUR Указывается режим работы фотогалереи:
  • SIMPLE - простой режим, т.е. один пользователь;
  • USER - многопользовательский режим.
Если параметр принимает значение USER, то необходимо настроить параметр [dw]USER_ALIAS[/dw][di]
Код галереи USER_ALIAS Указывается имя переменной, в которой передается код галереи.
[/di] и [dw]GALLERY_URL.[/dw][di] Данный параметр заполняется в поле Шаблоны ссылок.
Содержимое галереи GALLERY_URL Указывается адрес страницы просмотра содержимого галереи пользователя.
[/di]
Первое поле сортировки фото ELEMENT_SORT_FIELD Указывается первое поле, по которому будут сортироваться фотографии:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER Задается первый порядок сортировки фотографий в разделе:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Второе поле сортировки фото ELEMENT_SORT_FIELD1 Указывается второе поле, по которому будут сортироваться фотографии:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER1 Задается второй порядок сортировки фотографий в разделе:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Свойства | PROPERTY_CODE | Указываются свойства фотографий, которые должны быть отображены.
Шаблоны ссылок
Содержимое галереи | GALLERY_URL | Указывается адрес страницы просмотра содержимого галереи пользователя (параметр указывается при многопользовательском режиме работы).
Фото | DETAIL_URL | Указывается адрес страницы детального просмотра фотографии.
Фото (редактирование) | DETAIL_EDIT_URL | Указывается адрес страницы редактирования параметров фотографии.
Страница слайд-шоу | DETAIL_SLIDE_SHOW_URL | Указывается адрес страницы слайд-шоу содержимого галереи.
Страница поиска | SEARCH_URL | Указывается адрес страницы поиска.
Альбом | SECTION_URL | Указывается адрес страницы просмотра альбома.
Загрузка фото | UPLOAD_URL | Указывается адрес страницы загрузки фотографии.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено <название_альбома>.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в парметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | Указываются группы пользователей, имеющие доступ к детальной информации.
Формат вывода даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать теги | SHOW_TAGS | [Y|N] При отмеченной опции будет показано облако тегов.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] При отмеченной опции будет установлен статус 404, если не будут найдены элементы или раздел фотогалереи.
Размер детальной фотографии (px) | THUMBS_SIZE | Указывается размер детальной фотографии в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photogallery.detail","",Array(
        "THUMBS_SIZE" => "300",
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "10",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "BEHAVIOUR" => "USER",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "USER_ALIAS" => $_REQUEST["USER_ALIAS"],
        "ELEMENT_SORT_FIELD" => "SORT",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD1" => "NAME",
        "ELEMENT_SORT_ORDER1" => "desc",
        "PROPERTY_CODE" => array(),
        "GALLERY_URL" => "gallery.php?USER_ALIAS=#USER_ALIAS#",
        "DETAIL_URL" => "detail.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "DETAIL_EDIT_URL" => "detail_edit.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "DETAIL_SLIDE_SHOW_URL" => "slide_show.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "SEARCH_URL" => "search.php",
        "SECTION_URL" => "section.php?SECTION_ID=#SECTION_ID#",
        "UPLOAD_URL" => "upload.php?SECTION_ID=#SECTION_ID#&ACTION=upload",
        "USE_PERMISSIONS" => "N",
        "GROUP_PERMISSIONS" => array(),
        "DATE_TIME_FORMAT" => "d.m.Y",
        "SHOW_TAGS" => "Y",
        "SET_STATUS_404" => "Y"
    )
);?>


Фото (загрузка)

Описание photogallery.upload

Компонент служит для загрузки фотографии. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
ID раздела | SECTION_ID | Указывается числовой код, в котором передается идентификатор раздела.
Шаблоны ссылок
Индексная страница | INDEX_URL | Указывается адрес главной страницы галереи.
Страница просмотра альбома | SECTION_URL | Указывается адрес страницы просмотра содержимого альбома фотогалереи.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Загрузка фотографий.
Настройки фотогалереи
Тип загрузчика UPLOADER_TYPE Указывается тип загрузчика фотографий в фотогалерею:
  • Одиночная загрузка через форму (form);
  • Множественный загрузчик (Java/ActiveX) (applet);
  • Множественный Flash-загрузчик (flash).
Параметр устарел с версии 15.0.0.
Схема множественного загрузчика APPLET_LAYOUT Параметр определяет тип загрузчика в фотогалерии по умолчанию:
  • Стандартный шаблон (extended);
  • Упрощенный шаблон загрузчика (simple).
Выбор параметра доступен только при выборе параметра "Тип загрузчика" (UPLOADER_TYPE) равным "Множественный загрузчик (Java/ActiveX)" (applet).

Параметр устарел с версии 15.0.0.
Максимальный размер загружаемого файла (Мб) | UPLOAD_MAX_FILE_SIZE | Указывается максимальный размер загружаемого файла в Мб.
Пользовательские эскизы | ADDITIONAL_SIGHTS | Выбираются пользовательские эскизы из заданных в настройках модуля.
Обязательная премодерация фото | MODERATION | [Y|N] При отмеченной опции будет выполняться обязательная премодерация фото.
Размер картинки-анонса фотоальбома (px) | ALBUM_PHOTO_THUMBS_WIDTH | Указываются картинки-анонса для фотоальбома в пикселах.
Настройки авторского знака
Наносить авторский знак USE_WATERMARK

Внимание! Функционал авторского знака устарел и не поддерживается с версии 14.5.0 Главного модуля (main).

[Y|N] При отмеченной опции при загрузке фотографий можно будет наносить авторский знак.Станут доступны [dw]поля настройки авторского знака.[/dw][di] Поля настройки авторского знака:
Правила нанесения авторского знака WATERMARK_RULES Указывается правило нанесения авторского знака:
  • На усмотрение пользователя (USER);
  • Обязательно наносить авторский знак (ALL).
Если выбрано значение USER, то необходимо настроить следующие параметры: WATERMARK_TYPE, PATH_TO_FONT и WATERMARK_MIN_PICTURE_SIZE.

Если выбрано значение ALL, то необходимо настроить следующие параметры:
  • WATERMARK_TYPE, PATH_TO_FONT, WATERMARK_MIN_PICTURE_SIZE, WATERMARK_POSITION и WATERMARK_TRANSPARENCY;
  • и в зависимости от значения параметра WATERMARK_TYPE дополнительно настроить соответствующие поля.
Тип авторского знака WATERMARK_TYPE Указывается тип авторского знака:
  • На выбор: текст или картинка (BOTH) - доступно, если в параметре USE_WATERMARK выбрано значение USER;
  • Надпись (текст) (TEXT);
  • Картинка (PICTURE).
Если выбрано значение TEXT, а в параметре USE_WATERMARK было выбрано значение ALL, то дополнительно необходимо настроить параметры: WATERMARK_TEXT, WATERMARK_COLOR и WATERMARK_SIZE.

Если выбрано значение PICTURE, а в параметре USE_WATERMARK было выбрано значение ALL, то дополнительно необходимо настроить параметры: WATERMARK_FILE и WATERMARK_FILE_ORDER.
Файл со шрифтом для авторского знака | PATH_TO_FONT | Указывается путь к файлу со шрифтом для авторского знака.
Минимальный размер фото для авторского знака (px) | WATERMARK_MIN_PICTURE_SIZE | Указывается минимальный размер фото, на которых будет нанесен авторский знак в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения. На фотографии меньшего размера знак добавлен не будет.
Размещение авторского знака WATERMARK_POSITION Указывается область размещения авторского знака на фото:
  • Сверху слева (tl);
  • Сверху по центру (tc);
  • Сверху справа (tr);
  • Cлева (ml);
  • По центру (mc);
  • Cправа (mr);
  • Снизу cлева (bl);
  • Снизу по центру (bc);
  • Снизу cправа (br).
Прозрачность авторского знака | WATERMARK_TRANSPARENCY | Задается величина прозрачности авторского знака (в %).
Текст надписи | WATERMARK_TEXT | Задается текст авторского знака.
Цвет надписи (без #, например, FF00EE) | WATERMARK_COLOR | Указывается шестнадцатеричный код цвета надписи без использования #.
Размер надписи (% от размера картинки) | WATERMARK_SIZE | Задается размер надписи авторского знака в процентном соотношении от размера фото.
Физический полный путь к картинке | WATERMARK_FILE | Указывается полный путь к картинке для авторского знака.
Расположение картинки на фото | WATERMARK_FILE_ORDER | Указывается тип расположения картинки авторского знака на фото.
[/di]
Эскиз фотографии
Размер фотографии (px) | THUMBNAIL_SIZE | Указывается размер картинки-анонса альбома в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Качество загружаемой фотографии (%) | JPEG_QUALITY1 | Указывается качество фотографии-анонса в процентах (%).
Фотография
Обязательно ограничивать размер оригинала (px) (при значении 0 ограничение не происходит) | ORIGINAL_SIZE | Задается размер оригинала фотографии в пикселях. Фотография будет уменьшена до указанной величины. Если указано значение 0, то изменение размера не происходит. Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Давать возможность пользователю выбирать размер загружаемых фотографий P_SHOW_RESIZER Разрешать пользователю выбирать размер загружаемых фотографий.

Параметр устарел с версии 15.0.0.
Качество загружаемой фотографии (%) | JPEG_QUALITY | Указывается качество загружаемой фотографии в процентах (%).

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photogallery.upload","",Array(
        "SHOW_TAGS" => "Y",
        "USE_LIGHT_TEMPLATE" => "Y",
        "SHOW_WATERMARK" => "Y",
        "WATERMARK_COLORS" => array(),
        "IBLOCK_TYPE" => "photos",
        "IBLOCK_ID" => "23",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "INDEX_URL" => "index.php",
        "SECTION_URL" => "section.php?SECTION_ID=#SECTION_ID#",
        "UPLOAD_MAX_FILE_SIZE" => "7",
        "ADDITIONAL_SIGHTS" => array(),
        "MODERATION" => "Y",
        "WATERMARK_RULES" => "ALL",
        "WATERMARK_TYPE" => "PICTURE",
        "WATERMARK_FILE" => "",
        "WATERMARK_FILE_ORDER" => "usual",
        "WATERMARK_POSITION" => "mc",
        "WATERMARK_TRANSPARENCY" => "20",
        "PATH_TO_FONT" => "",
        "WATERMARK_MIN_PICTURE_SIZE" => "800",
        "ALBUM_PHOTO_THUMBS_WIDTH" => "120",
        "THUMBS_SIZE" => "250",
        "JPEG_QUALITY1" => "95",
        "PREVIEW_SIZE" => "600",
        "JPEG_QUALITY2" => "95",
        "ORIGINAL_SIZE" => "0",
        "JPEG_QUALITY" => "90",
        "SET_TITLE" => "Y"
    ),
);?>


Фото (комментарии)

Описание calendar.interface.grid

Компонент служит для создания комментариев к фотографии. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
ID элемента | ELEMENT_ID | В поле указывается код, в котором передается идентификатор элемента (фотографии).
Компонент комментариев COMMENTS_TYPE Указывается компонент, с помощью которого будут оставлены комментарии:
  • Блоги (blog);
  • Форум (forum).
Если указать Блоги, то необходимо настроить [dw]следующие параметры:[/dw][di]
Блог для комментариев | BLOG_URL | Указывается один из созданных в системе блогов, в котором будут храниться комментарии.
Путь к блогу | PATH_TO_BLOG | Задается путь к главной странице блога относительно корня сайта.
[/di] BLOG_URL, PATH_TO_USER, PATH_TO_BLOG.

Если указать Форум, то необходимо настроить [dw]следующие параметры:[/dw][di]
ID форума для отзывов | FORUM_ID | Указывается один из созданных в системе форумов, в котором будут храниться комментарии.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления комментария в публичной части.
Выводить сообщения в прямом порядке | PREORDER | [Y|N] При отмеченной опции собщения будут отсортированы по дате создания по возрастанию.
[/di] FORUM_ID, URL_TEMPLATES_READ, USE_CAPTCHA, PREORDER.
Количество комментариев на странице | COMMENTS_COUNT | Указывается количество комментариев, выводимых на одной странице. Остальные комментарии будут выведены с помощью постраничной навигации.
Путь к профилю пользователя | PATH_TO_USER | Указывается адрес страницы профиля пользователя относительно корня сайта.
Шаблоны ссылок
Страница детального просмотра | DETAIL_URL | Указывается адрес страницы детального просмотра фотографии.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photogallery.detail.comment","",Array(
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "9",
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "DETAIL_URL" => "detail.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "COMMENTS_TYPE" => "blog",
        "COMMENTS_COUNT" => "25",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "BLOG_URL" => "5-blog",
        "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
        "PATH_TO_USER" => "",
        "PATH_TO_BLOG" => ""
    ),
);?>


Фото (редактирование)

Описание photogallery.detail.edit

Компонент служит для редактирования свойств фотографии. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, фотографии из которого будут выводиться.
ID раздела | SECTION_ID | В поле указывается код, в котором передается идентификатор раздела (альбома).
ID элемента | ELEMENT_ID | В поле указывается код, в котором передается идентификатор элемента (фотографии).
Режим работы галереи BEHAVIOUR Указывается режим работы фотогалереи:
  • SIMPLE - обычный режим, т.е. один пользователь;
  • USER - многопользовательский режим.
Если параметр принмает значение USER, то необходимо настроить параметры [dw]GALLERY_URL[/dw][di] Данный параметр заполняется в пункте Шаблоны ссылок.
Содержимое галереи GALLERY_URL Указывается адрес страницы просмотра содержимого галереи пользователя.
[/di] и [dw]GALLERY_SIZE.[/dw][di] Данный параметр заполняется в пункте Дополнительные настройки.
Размер галереи GALLERY_SIZE Указывается размер галереи пользователя в Мб.
[/di]
Код галереи | USER_ALIAS | Указывается имя переменной, в которой передается код галереи. Например ={$_REQUEST["USER_ALIAS"]}.
Действие над фотографией | ACTION | Указывается имя переменной, в которой содержится действие. Например ={$_REQUEST["ACTION"]}.
Шаблоны ссылок
URL страницы с содержимым раздела | SECTION_URL | Указывается адрес страницы с содержимым раздела.
URL страницы с содержимым элемента раздела | DETAIL_URL | Указывается адрес страницы с содержимым элемента раздела.
Содержимое галереи | GALLERY_URL | Указывается адрес страницы просмотра содержимого галереи пользователя (параметр указывается при многопользовательском режиме работы).
Дополнительные настройки
Формат вывода даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название фотографии.
Размер галереи | GALLERY_SIZE | Указывается размер галереи пользователя в Мб (параметр указывается при многопользовательском режиме работы).
Показывать теги | SHOW_TAGS | [Y|N] При отмеченной опции будет показано облако тегов.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:photogallery.detail.edit","",Array(
        "SHOW_TAGS" => "Y",
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "9",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "BEHAVIOUR" => "USER",
        "USER_ALIAS" => $_REQUEST["USER_ALIAS"],
        "ACTION" => $_REQUEST["ACTION"],
        "SECTION_URL" => "section.php?SECTION_ID=#SECTION_ID#",
        "DETAIL_URL" => "detail.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "DATE_TIME_FORMAT" => "d.m.Y",
        "SET_STATUS_404" => "Y",
        "SET_TITLE" => "Y"
    )
);?>


Фото (список)

Описание photogallery.detail.list

Компонент выводит список фотографий. Компонент содержит шесть шаблонов: .default, simple, slider, slider_big, slider_fixed и slide_show. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Фотогалерея 2.0.

Компонент относится к модулю Фотогалерея.

Примечание: Компонент устарел и не рекомендуется к использованию. Используйте компонент Список фото (со слайдером).

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
Режим работы галереи BEHAVIOUR Указывается режим работы фотогалереи:
  • SIMPLE - обычный режим, т.е. один пользователь;
  • USER - многопользовательский режим.
Если параметр принимает значение USER, то необходимо настроить параметры [dw]USER_ALIAS[/dw][di]
Код галереи USER_ALIAS Указывается имя переменной, в которой передается код галереи. Например ={$_REQUEST["USER_ALIAS"]}.
[/di] , [dw]GALLERY_SIZE[/dw][di] Данный параметр заполняется в пункте Дополнительные настройки.
Размер галереи GALLERY_SIZE Задается размер галереи одного пользователя в Мб.
[/di] и [dw]GALLERY_URL.[/dw][di] Данный параметр заполняется в пункте Шаблоны ссылок.
Содержимое галереи GALLERY_URL Указывается адрес страницы просмотра содержимого галереи пользователя.
[/di]
ID раздела | SECTION_ID | В поле указывается код, в котором передается идентификатор раздела (альбома).
Дополнительные параметры выбора фото ELEMENT_LAST_TYPE Указываются дополнительные параметры выбора фото:
  • none - нет;
  • count - выбирать несколько последних фото (ID);
  • time - выбирать фото за последние несколько дней;
  • period - выбирать фото за период.
Если параметр принимает значение выбирать несколько последних фото (ID), то необходимо настроить параметр [dw]ELEMENTS_LAST_COUNT[/dw][di]
Количество последних фото для выбора ELEMENTS_LAST_COUNT Указывается количество последних фото для выбора.
[/di] .

Если параметр принимает значение выбирать фото за последние несколько дней, то необходимо настроить параметр [dw]ELEMENTS_LAST_TIME.[/dw][di]
Количество дней для выбора фото ELEMENTS_LAST_TIME Указывается количество дней для выбора фото.
[/di]

Если параметр принимает значение выбирать фото за период, то необходимо настроить [dw]параметры[/dw][di]
Начало периода (ввести дату в формате "DD.MM.YYYY HH:MI:SS") | ELEMENTS_LAST_TIME_FROM | Указывается дата начала периода для выбора фото в формате DD.MM.YYYY HH:MI:SS.
Конец периода (ввести дату в формате "DD.MM.YYYY HH:MI:SS") | ELEMENTS_LAST_TIME_TO | Указывается дата окончания периода для выбора фото в формате DD.MM.YYYY HH:MI:SS.
[/di] ELEMENTS_LAST_TIME_FROM и ELEMENTS_LAST_TIME_TO.
Первое поле сортировки фото ELEMENT_SORT_FIELD Указывается первое поле, по которому будет происходить сортировка фотографий:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER Указывается порядок сортировки фотографий:
  • по возрастанию (asc);
  • по убыванию (desc).
Второе поле сортировки фото ELEMENT_SORT_FIELD1 Указывается второе поле, по которому будет происходить сортировка фотографий:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER1 Указывается порядок сортировки фотографий:
  • по возрастанию (asc);
  • по убыванию (desc).
Свойства | PROPERTY_CODE | Выберите свойства фотографий, которые должны быть отображены.
Использовать обратную навигацию | USE_DESC_PAGE | [Y|N] При отмеченной опции будет использоваться обратная постраничная навигацию для списка фотографий.
Количество фото на странице | PAGE_ELEMENTS | Указывается количество фотографий, выводимых на одной странице. Остальные фотографий будут выведены с помощью постраничной навигации.
Название шаблона для постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указывается название шаблона для постраничной навигации.
Шаблоны ссылок
Содержимое галереи | GALLERY_URL | Указывается адрес страницы просмотра содержимого галереи пользователя (параметр указывается при многопользовательском режиме работы).
Страница детального просмотра | DETAIL_URL | Указывается адрес страницы детального просмотра альбома.
Страница слайд-шоу | DETAIL_SLIDE_SHOW_URL | Указывается адрес страницы слайд-шоу.
Страница поиска | SEARCH_URL | Указывается адрес страницы поиска.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Список фотографий.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в парметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | Указываются группы пользователей, имеющие доступ к детальной информации.
Формат вывода даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] При отмеченной опции будет установлен статус 404, если не будут найдены элементы или раздел фотогалереи.
Размер галереи | GALLERY_SIZE | Задается размер галереи одного пользователя в Мб (параметр указывается при многопользовательском режиме работы).
Дополнительные эскизы | ADDITIONAL_SIGHTS | Выбираются типы эскизов для просмотра фотографий.
Активный эскиз (один из множества дополнительных и основных эскизов) | PICTURES_SIGHT | Указывается тип эскиза, с которого начинается просмотр фотографий альбома.
Размер детальной фотографии (px) THUMBS_SIZE Указывается размер детальной фотографии в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Данное поле доступно только для шаблона default и simple.
Показывать навигацию SHOW_PAGE_NAVIGATION Задается способ показа навигации:
  • none - не показывать;
  • top - сверху;
  • bottom - снизу;
  • both - сверху и снизу.

Данное поле доступно только для шаблонов default, simple, slider и slider_fixed.
Показывать элементы управления SHOW_CONTROLS [Y|N] При отмеченной опции на странице будут отображены кнопки по управлению фотографиями.
Данное поле доступно только для шаблона default.
Показывать голосования SHOW_RATING [Y|N] При отмеченной опции будут показаны голосования.
Данное поле доступно только для шаблона default и simple.
Показывать количество показов SHOW_SHOWS [Y|N] При отмеченной опции будет отображено количество показов.
Данное поле доступно только для шаблона default и simple.
Показывать количество комментариев SHOW_COMMENTS [Y|N] При отмеченной опции будет отображено количество комментариев.
Данное поле доступно только для шаблона default и simple.
Максимальный балл MAX_VOTE Указывается максимально возможный балл, т.е. число возможных оценок.
Данное поле доступно только для шаблона default и simple.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
Данное поле доступно только для шаблонов default и simple.
В качестве рейтинга показывать DISPLAY_AS_RATING Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • Рейтинг (rating) - высчитывается на основе формулы:

    Rating = (SUM(vote)+3.125*10) / (COUNT(*)+10), где:

    3.125 - это стартовый рейтинг. То есть изначально (при отсутствии голосов) рейтинг фотографии равен 3.125.

    10 - это константа, определяющая количество голосов, "утяжеляющих" первоначальное значение рейтинга (3.125). Это исключает случай, когда, например, трое проголосовавших человека могут вознести или опустить фотографию всего тремя голосами.

    При такой формуле расчета значение рейтинга получается более "плавное" и не так скачет при небольшом количестве голосующих. Чем больше голосов, тем больше рейтинг приближается к среднему арифметическому.

  • Среднее значение (vote_avg) - высчитывается как среднее арифметическое всех баллов к фотографии;
  • Рейтинг (главного модуля) (rating_main) - использование рейтинга главного модуля.

    Подробнее:

    - см. главу Рейтинги [image];
    - в блоге Рейтинги: создание собственного критерия рейтингования [image];
    - в блоге Саморегулируемое сообщество, построенное на двухфакторном рейтинге [image].

Данное поле доступно только для шаблона default и simple.
Размер аватара галереи (используется при работе компонента в многопользовательском режиме, px) GALLERY_AVATAR_SIZE Указывается размер аватара галереи в пикселях (px)
Данное поле доступно только для шаблона simple.
Размер слайдера (количество фотографий) SLIDER_COUNT_CELL Указывается количество фотографий, отображаемых в слайдере.
Данное поле доступно только для шаблонов slider и slider_fixed.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:photogallery.detail.list","",Array(
        "THUMBS_SIZE" => "120",
        "SHOW_PAGE_NAVIGATION" => "bottom",
        "SHOW_CONTROLS" => "Y",
        "SHOW_RATING" => "Y",
        "SHOW_SHOWS" => "Y",
        "SHOW_COMMENTS" => "Y",
        "MAX_VOTE" => "5",
        "VOTE_NAMES" => array("1", "2", "3", "4", "5"),
        "DISPLAY_AS_RATING" => "rating",
        "IBLOCK_TYPE" => "gallery",
        "IBLOCK_ID" => "10",
        "BEHAVIOUR" => "USER",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "USER_ALIAS" => $_REQUEST["USER_ALIAS"],
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "ELEMENT_LAST_TYPE" => "count",
        "ELEMENTS_LAST_COUNT" => "30",
        "ELEMENT_SORT_FIELD" => "NAME",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD1" => "PROPERTY_RATING",
        "ELEMENT_SORT_ORDER1" => "desc",
        "PROPERTY_CODE" => array("vote_count", "rating", "vote_sum", "APPROVE_ELEMENT", "PUBLIC_ELEMENT"),
        "DETAIL_URL" => "detail.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "DETAIL_SLIDE_SHOW_URL" => "slide_show.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "SEARCH_URL" => "search.php",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => array("1"),
        "USE_DESC_PAGE" => "Y",
        "PAGE_ELEMENTS" => "50",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "DATE_TIME_FORMAT" => "d.m.Y",
        "SET_STATUS_404" => "Y",
        "ADDITIONAL_SIGHTS" => array(),
        "PICTURES_SIGHT" => array()
    ),
);?>


Каталог

Подраздел предназначен для организации и размещения на сайте полнофункционального каталога товаров. Включает следующие компоненты:

Обратите внимание! Несмотря на то, что компоненты каталога расположены в визуальном редакторе в подразделе Каталог, фактически они относятся к модулю Информационные блоки. В описании каждого компонента указано, к какому модулю он относится.

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Структура разделов | catalog.section.list | Выводит список разделов инфоблока с указанным количеством элементов в каждом разделе.
Элементы раздела | catalog.section | Выводит список элементов раздела с указанным набором свойств.
Каталог (комплексный компонент) | catalog | Осуществляет вывод полного каталога товаров из определенного инфоблока.
Поиск по каталогу | catalog.search | Выводит результаты поиска по элементам каталога с указанным набором свойств, цен и т.д.
Бренды | catalog.brandblock | Служит для отображения брендов на странице с детальной информацией о товаре.
Презентационный список | furniture.catalog.index | Выводит презентационный список элементов или разделов инфоблока.
Специальное предложение | furniture.catalog.random | Показывает одно специальное предложение.
Элемент каталога детально | catalog.element | Выводит детальную информацию по элементу каталога.
Список сравниваемых элементов каталога | catalog.compare.list | Выводит список сравниваемых элементов каталога в виде небольшой таблицы.
Таблица сравнения | catalog.compare.result | Выводит таблицу сравниваемых элементов каталога.
Умный фильтр | catalog.smart.filter | Подготавливает фильтр для выборки из инфоблока и выводит форму фильтра для фильтрации элементов.
Фильтр по элементам | catalog.filter | Выводит форму фильтра для фильтрации элементов информационых блоков.
Список информационных блоков заданного типа | catalog.main | Выводит список всех информационных блоков заданного типа.
Top элементов каталога | catalog.top | Выводит в таблице Top элементов из всех разделов в соответствии с заданной сортировкой (используется как правило на главной странице сайта).
Конструктор наборов | catalog.set.constructor | Служит для отображения заданного набора и конструктора составления собственного набора товаров.
Разделы с top'ом элементов | catalog.sections.top | Выводит Top элементов сгруппированных по разделам; элементы выводятся в таблице.
Список связанных элементов | catalog.link.list | Выводит список элементов, связанных с заданным.


Структура разделов

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Структура разделов

Каталог::Структура разделов

Компонент выводит список разделов инфоблока.

Описание catalog.section.list

Компонент стандартный, входит в дистрибутив модуля и содержит 4 шаблона: .default, old_version (шаблон .default до версии 14.0), tree и visual.

В визуальном редакторе компонент расположен по пути Контент > Каталог > Структура разделов.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание | Примечание
Основные параметры
Тип инфо-блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфо-блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор необходимого информационного блока.
ID раздела | SECTION_ID | Указывается код, в котором передается идентификатор раздела.
Код раздела | SECTION_CODE | Указывается код раздела.
Источник данных
Показывать количество элементов в разделе | COUNT_ELEMENTS | [Y|N] При отмеченной опции будет показано количество элементов в разделе.
Максимальная отображаемая глубина разделов | TOP_DEPTH | Параметр определяет максимальную глубину отображаемых разделов.
Поля разделов SECTION_FIELDS Указываются поля раздела, которые будут отображены на странице структуры разделов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
 Array("ID","CODE",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив) ничего отображаться не будет.
Свойства раздела | SECTION_USER_FIELDS | Указываются свойства раздела, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, свойства не будут выведены.
Имя массива со значениями фильтра разделов | FILTER_NAME | Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Внешний вид (для шаблона .default и visual)
Вид списка подразделов | VIEW_MODE | Определяется способ отображения списка подразделов: в виде списка (LINE), многоуровнего списка (LIST), текста (TEXT) или плитки (TILE).
Показывать название раздела | SHOW_PARENT_NAME | [Y|N] При отмеченной опции будет выводится название раздела (кроме раздела верхнего уровня).
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается путь к странице с содержимым раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции название или заголовок (если задан в настройках SEO) раздела будет включен в цепочку навигации.
Служебные параметры (не отображаются в настройках компонента)
Кастомная сортировка по произвольному числу параметров CUSTOM_SECTION_SORT Данный служебный параметр можно передать в вызове компонента. Тип параметра - массив. Структура массива соответствует ключу $arOrder метода CIBlockSection::GetList [image]. Доступно с версии модуля iblock 20.0.400.
Параметр не используется в штатных шаблонах комплексного компонента catalog.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:catalog.section.list","",
Array(
        "VIEW_MODE" => "TEXT",
        "SHOW_PARENT_NAME" => "Y",
        "IBLOCK_TYPE" => "",
        "IBLOCK_ID" => "",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "SECTION_CODE" => "",
        "SECTION_URL" => "",
        "COUNT_ELEMENTS" => "Y",
        "TOP_DEPTH" => "2",
        "SECTION_FIELDS" => "",
        "SECTION_USER_FIELDS" => "",
        "ADD_SECTIONS_CHAIN" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_NOTES" => "",
        "CACHE_GROUPS" => "Y"
    )
);?>


Элементы раздела

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Элементы раздела

Каталог::Элементы раздела

Компонент выводит список элементов раздела с указанным набором свойств.

Описание catalog.section

Компонент содержит пять шаблонов: .default, board, links, list и old_version_16 (шаблон .default до версии 17.0). Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Каталог > Элементы раздела.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание | Примечание
Основные параметры
Тип инфоблока IBLOCK_TYPE Указывается один из созданных в системе типов информационных блоков.
Инфоблок IBLOCK_ID Для выбранного типа инфоблоков указывается идентификатор информационного блока, из которого будет выводиться список элементов.
ID раздела | SECTION_ID | Указывается числовой код, в котором передается идентификатор раздела. Поле может быть оставлено пустым, если указан Код раздела. | При включенном режиме ЧПУ параметры настраиваются в секции Управление адресами страниц.
Код раздела | SECTION_CODE | Указывается символьный код раздела, из которого будут выбраны элементы. Поле может быть оставлено пустым, если указан ID раздела.
Источник данных
Свойства раздела SECTION_USER_FIELDS Указываются свойства раздела, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, свойства не будут выведены.
Имя массива со значениями фильтра для фильтрации элементов FILTER_NAME Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Показывать элементы подразделов раздела INCLUDE_SUBSECTIONS [Y|N] При отмеченной опции будут отображены элементы подразделов раздела.
Показывать все элементы, если не указан раздел SHOW_ALL_WO_SECTION [Y|N] При отмеченной будут отображены все элементы, если не указан раздел.

Если установить параметр в 'Y', то из ссылок на товары пропадает раздел, т.е. параметр DETAIL_URL перестаёт правильно работать. В этом случае установите скрытый параметр "BY_LINK"=> "Y".

Если установить параметр в 'N' и при отсутствии раздела будут показаны товары, не привязанные ни к одному разделу. Если при этом передать INCLUDE_SUBSECTIONS = Y - будет выполнена выборка по всему инфоблоку без ограничения по разделам.
Фильтр товаров CUSTOM_FILTER В данном поле настраиваются условия отбора товаров для показа. Выбор каждого условия осуществляется из выпадающего списка, доступного по ссылке Добавить условие. Для выбранного поля/свойства товара задается соответствие некоторому значению. Допускается создание нескольких условий и использование между ними как логики "И", так и логики "ИЛИ".

Недоступные товары HIDE_NOT_AVAILABLE Указывается способ отборажения недоступных для покупки товаров:
  • Y - не отображать;
  • L - отображать в конце;
  • N - отображать в общем списке.
Примечание: недоступные для покупки товары - это товары, для которых количество меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.

Недоступные торговые предложения HIDE_NOT_AVAILABLE_OFFERS Указывается способ отборажения недоступных для покупки торговых предложений:
  • Y - не отображать;
  • L - отображать только с возможностью подписки;
  • N - отображать все.
Настройки сортировки
По какому полю сортируем элементы ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • [dw]id – по идентификатору;[/dw][di]С версии 18.6.900 наследники класса \Bitrix\Iblock\Component\ElementList
    поддерживают сортировку по последовательности ID элементов.

    В параметры компонента передаётся:
    "ELEMENT_SORT_FIELD" => "ID",
    "ELEMENT_SORT_ORDER" => $arElements // массив ID в нужном порядке
    "FILTER_NAME" => "arrFilter"
     В фильтр компонента передаётся такой же массив:
    global $arrFilter;

$arrFilter = ['ID' => $arElements];
    [/di]
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)

Порядок сортировки элементов ELEMENT_SORT_ORDER Задается порядок сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.

Поле для второй сортировки элементов ELEMENT_SORT_FIELD2 Указывается поле, по которому будет происходить вторая сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)

Порядок второй сортировки элементов ELEMENT_SORT_ORDER2 Задается порядок второй сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.

По какому полю сортируем предложения товара OFFERS_SORT_FIELD Указывается поле, по которому сортируется весь список предложений товара.

См. примечание в конце страницы.
Данные параметры появляются при настройке компонента на инфоблок с поддержкой SKU.
Порядок сортировки предложений товара | OFFERS_SORT_ORDER | Выбирается как сортировать предложения товара: по возрастанию, или по убыванию.
Поле для второй сортировки предложений товара OFFERS_SORT_FIELD2 Указывается поле, по которому выполняется вторая сортировка списка предложений товара.

См. примечание в конце страницы.
Порядок второй сортировки предложений товара | OFFERS_SORT_ORDER2 | Выбирается направление второй сортировки предложений товара: по возрастанию, или по убыванию.
Внешний вид
Свойства PROPERTY_CODE Указываются свойства инфоблока, которые будут отображены при показе элементов в таблице. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.

Внимание! При включенной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di] эта настройка может быть скрыта. В этом случае показ свойств настраивается только в [dw]форме редактирования инфоблока [/dw][di] [image] [/di]. Подробнее о настройке свойств инфоблока в уроке [image] [image] [image].

Свойства товаров, отображаемые на мобильных устройствах PROPERTY_CODE_MOBILE Выбираются свойства инфоблока (перечень формируется из выбранных в параметре выше свойств), которые будут отображены в списке товаров при просмотре с мобильных устройств.
Поля предложений OFFERS_FIELD_CODE Выбираются поля предложений. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений OFFERS_PROPERTY_CODE Указываются свойства предложений. Можно добавлять свои. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.

Внимание! При включенной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di] эта настройка может быть скрыта. В этом случае показ свойств настраивается только в [dw]форме редактирования инфоблока [/dw][di] [image] [/di]. Подробнее о настройке свойств инфоблока в уроке [image] [image] [image].

Максимальное количество предложений для показа | OFFERS_LIMIT | Указывается максимальное для вывода на страницу число предложений (0 - все). | Параметр доступен, если опция Включить режим совместимости включена.
Установить фоновую картинку для шаблона из свойства BACKGROUND_IMAGE Указывается свойство, в котором хранится картинка для фона.

Свойство должно быть немножественным типа Файл.

Важно! В шаблоне сайта должна быть реализована поддержка этого функционала: в необходимом вам теге должно быть прописано:
<?=$APPLICATION->ShowProperty("backgroundImage")?>
Цветовая тема TEMPLATE_THEME Задается цветовая схема для отображения элементов раздела. По умолчанию используется синяя схема (blue).
Вариант отображения товаров PRODUCT_ROW_VARIANTS В правой части поля выберите блок с подходящим вам вариантом отображения одной строки товаров на странице и перетащите его в левую часть. Если строка товаров должна быть по персональной рекомендации, то предварительно отметьте опцию BigData и затем уже перетащите нужный блок. Аналогичным образом настройте остальные строки для формирования таблицы товаров.

Количество товаров на странице PAGE_ELEMENT_COUNT Отображается информация по количеству товаров на странице в соответствии с выбранным вариантом отображения товаров.
Количество товаров BigData на странице LINE_ELEMENT_COUNT Отображается информация по количеству товаров по персональной рекомендации, отображаемых на cтранице.
Выделять товары в списке ENLARGE_PRODUCT Выберите способ выделения товаров в списке:
  • по выбранному шаблону (строго) - товар будет выделятся строго по настроенному варианту отображения товаров;
  • по свойству, подгонять по шаблону (в этом случае возможно изменение сортировки элементов) - в списке будет выделяться тот товар, для которого заполнено указанное в параметре Выделять по выбранному свойству свойство.
Примечание: выделение товаров осуществляется в том случае, если для показа списка товаров выбран хотя бы один вариант вида:

Порядок отображения блоков товара PRODUCT_BLOCKS_ORDER Перетаскивая блоки, определите необходимый вам порядок следования блоков товара.

Показывать слайдер для товаров SHOW_SLIDER [Y|N] При отмеченной опции для товаров будет использоваться слайдер для показа изображений, станет доступно [dw]дополнительное поле[/dw][di]
Интервал смены слайдов, мс SLIDER_INTERVAL Указывается интервал смены слайдов в миллисекундах. Параметры настраиваются, если отмечена опция Показывать слайдер для товаров.
[/di] .
Показывать полосу прогресса SLIDER_PROGRESS [Y|N] При отмеченной опции будет отображаться полоса прогресса до начала показа следующего слайда.
Выделять по выбранному свойству | ENLARGE_PROP | Указывается то свойство товара, при наличии которого товар будет выделен в списке просмотренных (если позволяет вариант отображения товаров, см. поле Вариант отображения товаров). | Параметр доступен, если в параметре Выделять товары в списке указано значение по свойству (подгонять по шаблону).
Схема отображения PRODUCT_DISPLAY_MODE Задается режим отображения товаров: простой (N) или расширенный (Y). Параметр доступен для инфоблока с торговыми предложениями.
Дополнительная картинка основного товара ADD_PICT_PROP Задается свойство, в котором хранится дополнительная картинка для основного товара.
Свойство меток товара LABEL_PROP Указываются свойство, в котором хранится метка товара (например, новинка).
Свойства меток товара, отображаемые на мобильных устройствах LABEL_PROP_MOBILE Выбираются свойства меток (перечень формируется из выбранных в параметре выше свойств), которые будут отображены в списке товаров при просмотре с мобильных устройств.
Расположение меток товара LABEL_PROP_POSITION Выберите подходящее место для меток на карточке товара.
Дополнительные картинки предложения | OFFER_ADD_PICT_PROP | Задается свойство, в котором хранится дополнительная картинка для торгового предложения. Параметр доступен для инфоблока с торговыми предложениями.. | Данные настройки доступны, если в параметре Схема отображения выбрано значение расширенный.
Свойства для отбора предложений OFFER_TREE_PROPS Указываются свойства, по значениям которых будут группироваться торговые предложения. Параметр доступен для инфоблока с торговыми предложениями.

Внимание! При включенной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di] эта настройка может быть скрыта. В этом случае показ свойств настраивается только в [dw]форме редактирования инфоблока [/dw][di] [image] [/di]. Подробнее о настройке свойств инфоблока в уроке [image] [image] [image].

Разрешить оповещения для отсутствующих товаров PRODUCT_SUBSCRIPTION [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки.
Показывать процент скидки SHOW_DISCOUNT_PERCENT [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана, станет доступно [dw]дополнительное поле[/dw][di]
Расположение процента скидки "DISCOUNT_PERCENT_POSITION Выберите подходящее место для отображения процентной скидки на карточке товара.
[/di] .
Показывать старую цену SHOW_OLD_PRICE [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Показывать остаток товара SHOW_MAX_QUANTITY Укажите способ отображения остатка товара:
  • не показывать;
  • с отображением реального остатка - в этом случае необходимо настроить параметр [dw] Текст для остатка[/dw][di]
    Текст для остатка MESS_SHOW_MAX_QUANTITY Задается текст для отображения информации о наличии товара. Доступность данных параметров компонента определяется настройками параметра Показывать остаток товара.
    [/di];
  • с подменой остатка текстом - в этом случае необходимо настроить [dw]параметры[/dw][di]
    Текст для остатка | MESS_SHOW_MAX_QUANTITY | Задается текст для отображения информации о наличии товара.
    Значение, от которого происходит подмена | RELATIVE_QUANTITY_FACTOR | Указывается значение, меньше (больше) которого о количестве товара на складе будет отображаться выражение, что товара мало (много).
    Текст для значения больше | MESS_RELATIVE_QUANTITY_MANY | Задается текст, который будет отображаться при наличии товара в количестве большем, чем значение в параметре Значение, от которого происходит подмена.
    Текст для значения меньше | MESS_RELATIVE_QUANTITY_FEW | Задается текст, который будет отображаться при наличии товара в количестве меньшем, чем значение в параметре Значение, от которого происходит подмена..
    [/di] Текст для остатка, Значение, от которого происходит подмена, Текст для значения больше и Текст для значения меньше.
Показывать кнопку продолжения покупок во всплывающих окнах SHOW_CLOSE_POPUP [Y|N] При отмеченной опции будет отображаться кнопка Продолжить покупки во всплывающем окне, появляющемся после добавления товара в корзину.
Текст кнопки "Купить" MESS_BTN_BUY Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Добавить в корзину" MESS_BTN_ADD_TO_BASKET Задается текст, который должен быть отображен на кнопке добавления в корзину.
Текст кнопки "Уведомить о поступлении" MESS_BTN_SUBSCRIBE Задается текст, который должен быть отображен на кнопке уведомления о поступлении товара.
Текст кнопки "Подробнее" MESS_BTN_DETAIL Задается текст, который должен быть отображен на кнопке "Подробнее".
Сообщение об отсутствии товара MESS_NOT_AVAILABLE Указывается текст, который будет отображаться при отсутствии товара и невозможности его купить.
Настройки BigData
Тип рекомендации RCM_TYPE Выбирается один из типов рекомендаций:
  • personal - Персональные рекомендации;
  • bestsell - Самые продаваемые;
  • similar_sell - Продаваемые с этим товаром;
  • similar_view - Просматриваемые с этим товаром;
  • similar - Похожие товары;
  • any_similar - Продаваемые/Просматриваемые/Похожие товары;
  • any_personal - Самые продаваемые/Персональные;
  • any - Любая рекомендация.
Параметр ID продукта (для товарных рекомендаций) RCM_PROD_ID Для товарных рекомендаций (Продаваемые с этим товаром, Просматриваемые с этим товаром, Похожие товары, Продаваемые/Просматриваемые/Похожие товары, Самые продаваемые/Персональные и Любая рекомендация) необходимо обязательно передавать идентификатор товара.
Показывать товары из раздела SHOW_FROM_SECTION [Y|N] При отмеченной опции товары по персональной рекомендации будут показываться только из того раздела, на который настроен компонент. В противном случае - из всего инфоблока.
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела SECTION_URL Указывается путь к странице с детальным содержимым раздела.
URL, ведущий на страницу с содержимым элемента раздела DETAIL_URL Указывается путь к странице с детальным описанием элемента раздела.
Название переменной, в которой передается код группы SECTION_ID_VARIABLE Задается имя переменной, в которой будет передаваться идентификатор раздела.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции включается поддержка ЧПУ и становятся доступными [dw]поля настройки ЧПУ[/dw][di]
Правило для обработки | SEF_RULE | Указывается правило обработки вызова страницы. Для создания правила следует использовать шаблоны, доступные по кнопке [...]. |
ID раздела | SECTION_ID | Указывается ID раздела инфоблока. Можно не задавать, если указан Код раздела или Путь из символьных кодов раздела. | При отключенном режиме ЧПУ данные параметры настраиваются в секции Основные параметры.
Код раздела | SECTION_CODE | Указывается символьный код раздела инфоблока. Можно не задавать, если указан ID раздела инфоблока или Путь из символьных кодов раздела
Путь из символьных кодов раздела | SECTION_CODE_PATH | Задается путь из символьных кодов раздела инфоблока. Можно не задавать, если указан Код раздела или ID раздела инфоблока. |
[/di] .
Управление режимом AJAX
Включить режим AJAX AJAX_MODE [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента AJAX_OPTION_JUMP [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей AJAX_OPTION_STYLE [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера AJAX_OPTION_HISTORY [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.

Время кеширования (сек.) CACHE_TIME Время кеширования, указанное в секундах.
Учитывать права доступа CACHE_GROUPS [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Устанавливать заголовок страницы SET_TITLE [Y|N] При отмеченной опции в качестве заголовка страницы будет установлен заголовок раздела.
Устанавливать заголовок окна браузера SET_BROWSER_TITLE [Y|N] При отмеченной опции будет установлен заголовок окна браузера по заданному SEO-шаблону META TITLE (см. закладку "SEO" в инфоблоке) или из свойства (станет доступным [dw]дополнительное поле[/dw][di]
Установить заголовок окна браузера из свойства BROWSER_TITLE Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится заголовок окна браузера. Параметр доступен при отмеченной опции Устанавливать заголовок окна браузера.
[/di] ).
Устанавливать ключевые слова страницы SET_META_KEYWORDS [Y|N] При отмеченной опции будут установлены ключевые слова страницы по заданному SEO-шаблону META KEYWORDS (см. закладку "SEO" в инфоблоке) или из свойства (станет доступным [dw]дополнительное поле[/dw][di]
Установить ключевые слова страницы из свойства META_KEYWORDS Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова. Параметр доступен при отмеченной опции Устанавливать ключевые слова страницы.
[/di] ).
Устанавливать описание страницы SET_META_DESCRIPTION [Y|N] При отмеченной опции будет установлено описание страницы по заданному SEO-шаблону META DESCRIPTION (см. закладку "SEO" в инфоблоке) или из свойства (станет доступным [dw]дополнительное поле[/dw][di]
Установить описание страницы из свойства META_DESCRIPTION Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание. Параметр доступен при отмеченной опции Устанавливать описание страницы.
[/di]).
Устанавливать в заголовках ответа время модификации страницы SET_LAST_MODIFIED [Y|N] При отмеченной опции http-ответ сервера будет содержать время последнего изменения страницы (заголовок Last-Modified [image]).
Использовать основной раздел для показа элемента USE_MAIN_ELEMENT_SECTION [Y|N] Если опция отмечена, то при переходе на детальную страницу элемента в адресную строку браузера будет подставляться тот путь, который формируется при просмотре элемента через основной раздел, даже если элемент открыт через другой родительский его раздел.

Если опция не отмечена, про ссылка на детальную страницу элемента формируется с учетом того раздела, через который элемент открыт на просмотр.

Рассмотрим пример, когда опция в настройках отмечена. Допустим, что элемент с символьным кодом marketing привязан к двум разделам с кодами bisness и science соответственно, причем раздел с кодом bisness является основным. В результате, если пользователь пришел в раздел science и кликнул на элемент marketing, то в строке браузера вместо http://mysite.ru/catalog/science/marketing/ [image] будет отображено http://mysite.ru/catalog/bisness/marketing/ [image] .
Включать раздел в цепочку навигации ADD_SECTIONS_CHAIN [Y|N] При отмеченной опции название или заголовок (если задан в настройках SEO) раздела будет включен в строку навигации.
Кешировать при установленном фильтре CACHE_FILTER [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Настройки действий
Название переменной, в которой передается действие ACTION_VARIABLE Указывается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию ACTION. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки PRODUCT_ID_VARIABLE Задается имя переменной, в которой будет передаваться идентификатор товара для покупки.
Цены
Тип цены PRICE_CODE Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Использовать вывод цен с диапазонами USE_PRICE_COUNT [Y/N] При отмеченной опции будут отображаться цены всех типов на товары.
Выводить цены для количества SHOW_PRICE_COUNT Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену PRICE_VAT_INCLUDE [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах, станет доступным [dw]дополнительное поле[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты в которой будут отображаться цены.
[/di]. При выборе этой опции кеш компонента будет автоматически сбрасываться при изменении курсов валют тех товаров, что показываются компонентом. К примеру, если выбрана конвертация в рубли, а цены в инфоблоке сохранены в евро, то кеш сбросится при изменении курса евро или рубля. Изменения остальных валют на кеш не окажут влияния.
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя BASKET_URL Указывается путь к странице с корзиной покупателя.
Разрешить указание количества товара USE_PRODUCT_QUANTITY [Y|N] При отмеченной опции будет разрешен вывод количества товара, станет доступным [dw]дополнительное поле[/dw][di]
Название переменной, в которой передается количество товара PRODUCT_QUANTITY_VARIABLE Задается имя переменной, в которой будет передаваться количество товара.
[/di] .
Добавлять в корзину свойства товаров и предложений ADD_PROPERTIES_TO_BASKET [Y|N] При отмеченной опции становятся доступными [dw]настройки выбора свойств товаров и предложений[/dw][di]
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара. |
Разрешить добавлять в корзину товары, у которых заполнены не все характеристики | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет. |
Характеристики товара | PRODUCT_PROPERTIES | Указываются характеристики товара. |
Свойства предложений, добавляемые в корзину | OFFERS_CART_PROPERTIES | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использоать клавишу Ctrl. | Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
[/di] для передачи их в корзину и заказ.
Показывать кнопку добавления в корзину или покупки ADD_TO_BASKET_ACTION Выберите какая кнопка должна отображаться: кнопка покупки (BUY) или кнопка добавления в корзину (ADD).
Настройки аналитики
Отправлять данные электронной торговли в Google и Яндекс USE_ENHANCED_ECOMMERCE [Y|N] Включение опции. После включения станут доступны ещё [dw]два поля[/dw][di]
Имя контейнера данных | DATA_LAYER_NAME | Указываются свойства инфоблока, которые будут отображены в списке просмотренных товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Свойство брендов | BRAND_PROPERTY | Указывается свойство инфоблока, откуда система должна брать название бренда товара (производитель, марка, модель и т.п.).
[/di] . Требуется дополнительная настройка в Google Analytics Enhanced Ecommerce [image] и/или Яндекс.Метрике [image].

Примечание: Настройка Яндекс метрикой не сложна, и данные в ней отображаются довольно быстро (полчаса-час). У Google используется Google Tag Manager с плагином электронной коммерции, его нужно настроить и добавить на страницу в шаблоне. После настройки на "той" стороне, нужно настроить компоненты для работы с электронной коммерцией и включить эту поле настройки.

Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Указывается название шаблона постраничной навигации. Если поле пусто, то выбирается шаблон по умолчанию (.default).
Выводить над списком DISPLAY_TOP_PAGER [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы.
Выводить под списком DISPLAY_BOTTOM_PAGER [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы.
Название категорий PAGER_TITLE Задается название категорий, по которым происходит перемещение по элементам.
Выводить всегда PAGER_SHOW_ALWAYS [Y|N] При отмеченной опции постраничная навигация будет выводиться, даже если все элементы помещаются на одной странице.
Использовать обратную навигацию PAGER_DESC_NUMBERING [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации PAGER_DESC_NUMBERING_CACHE_TIME Задается время кеширования страниц в секундах для обратной навигации.
Показывать ссылку "Все" PAGER_SHOW_ALL [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все элементы раздела.
Включить обработку ссылок PAGER_BASE_LINK_ENABLE [Y|N] При отмеченной опции доступна обработка ссылок для постраничной навигации.
Показать кнопку ленивой загрузки Lazy Load LAZY_LOAD [Y|N] При отмеченной опции доступна кнопка [dw]"Показать еще"[/dw][di]
Текст кнопки "Показать ещё" MESS_BTN_LAZY_LOAD Указывается текст, который должен быть показан на кнопке "Показать ещё"/ Параметр доступен, если отмечена опция Показать кнопку ленивой загрузки Lazy Load.
[/di] .
Подгружать товары при прокрутке до конца LOAD_ON_SCROLL [Y|N] При отмеченной опции товары будет подгружаться на просмотр при прокрутке страницы до конца.
Настройки 404 ошибки
Устанавливать статус 404 SET_STATUS_404 [Y|N] Опция служит для включения обработки ошибки 404 в компоненте.
Показ специальной страницы SHOW_404 [Y|N] При отмеченной опции будет показана специальная страница [dw][/dw][di]
Страница для показа (по умолчанию /404.php) FILE_404 Задается адрес страницы, которая будет отображаться при возникновении ошибки 404. Параметр настраивается, если отмечена опция Показ специальной страницы.
[/di] в случае возникновения ошибки 404, в противном случае - будет отображено [dw]специальное сообщение[/dw][di]
Сообщение для показа (по умолчанию из компонента) MESSAGE_404 Задается сообщение, которое будет показано в случае возникновения ошибки 404. Если ничего не указывать, то будет использоваться стандартное сообщение из компонента. Параметр настраивается, если опция Показ специальной страницы не отмечена.
[/di] .
Специальные настройки
Включить режим совместимости COMPATIBLE_MODE [Y|N] При отмеченной опции будет включен режим совместимости, станет доступно [dw]дополнительное поле[/dw][di]
Не подключать js-библиотеки в компоненте DISABLE_INIT_JS_IN_COMPONENT [Y|N] При отмеченной опции js-библиотека popup не будет подключаться в самом компоненте. Если шаблон компонента основан на шаблоне решения "Интернет-магазин" версии 12.5, то использование этой опции приведет к ограничению функционала.
[/di] . Опцию необходимо отмечать при наличии старого кастомизированного шаблона компонента версии ниже 16.6.2 модуля Информационные блоки.
Служебные параметры (не отображаются в настройках компонента)
Кастомная сортировка по произвольному числу параметров CUSTOM_ELEMENT_SORT Данный служебный параметр можно передать в вызове компонента. Тип параметра - массив. Структура массива соответствует ключу $arOrder метода CIBlockElement::GetList [image]. Доступно с версии модуля iblock 20.0.400.
Параметр не используется в штатных шаблонах комплексного компонента catalog.

Примечание: если указаны поля сортировки, отличные от ID, и значения этих полей для торговых предложений разные, то для выбора первого для показа предложения будет выбрано то предложение, которое отсортировано первым.
Если же все значения совпадают, то будет показано то торговое предложение, у которого сортировка участвующих в выборе SKU значений свойств минимальна.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:catalog.section",
    "",
    Array(
        "ACTION_VARIABLE" => "action",
        "ADD_PICT_PROP" => "MORE_PHOTO",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "ADD_SECTIONS_CHAIN" => "N",
        "ADD_TO_BASKET_ACTION" => "ADD",
        "AJAX_MODE" => "N",
        "AJAX_OPTION_ADDITIONAL" => "",
        "AJAX_OPTION_HISTORY" => "N",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "BACKGROUND_IMAGE" => "UF_BACKGROUND_IMAGE",
        "BASKET_URL" => "/personal/basket.php",
        "BRAND_PROPERTY" => "BRAND_REF",
        "BROWSER_TITLE" => "-",
        "CACHE_FILTER" => "N",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "36000000",
        "CACHE_TYPE" => "A",
        "COMPATIBLE_MODE" => "Y",
        "CONVERT_CURRENCY" => "Y",
        "CURRENCY_ID" => "RUB",
        "CUSTOM_FILTER" => "",
        "DATA_LAYER_NAME" => "dataLayer",
        "DETAIL_URL" => "",
        "DISABLE_INIT_JS_IN_COMPONENT" => "N",
        "DISCOUNT_PERCENT_POSITION" => "bottom-right",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "DISPLAY_TOP_PAGER" => "N",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_FIELD2" => "id",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_ORDER2" => "desc",
        "ENLARGE_PRODUCT" => "PROP",
        "ENLARGE_PROP" => "NEWPRODUCT",
        "FILTER_NAME" => "arrFilter",
        "HIDE_NOT_AVAILABLE" => "N",
        "HIDE_NOT_AVAILABLE_OFFERS" => "N",
        "IBLOCK_ID" => "2",
        "IBLOCK_TYPE" => "catalog",
        "INCLUDE_SUBSECTIONS" => "Y",
        "LABEL_PROP" => array("NEWPRODUCT"),
        "LABEL_PROP_MOBILE" => array(),
        "LABEL_PROP_POSITION" => "top-left",
        "LAZY_LOAD" => "Y",
        "LINE_ELEMENT_COUNT" => "3",
        "LOAD_ON_SCROLL" => "N",
        "MESSAGE_404" => "",
        "MESS_BTN_ADD_TO_BASKET" => "В корзину",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_BTN_LAZY_LOAD" => "Показать ещё",
        "MESS_BTN_SUBSCRIBE" => "Подписаться",
        "MESS_NOT_AVAILABLE" => "Нет в наличии",
        "META_DESCRIPTION" => "-",
        "META_KEYWORDS" => "-",
        "OFFERS_CART_PROPERTIES" => array("ARTNUMBER","COLOR_REF","SIZES_SHOES","SIZES_CLOTHES"),
        "OFFERS_FIELD_CODE" => array("",""),
        "OFFERS_LIMIT" => "5",
        "OFFERS_PROPERTY_CODE" => array("COLOR_REF","SIZES_SHOES","SIZES_CLOTHES",""),
        "OFFERS_SORT_FIELD" => "sort",
        "OFFERS_SORT_FIELD2" => "id",
        "OFFERS_SORT_ORDER" => "asc",
        "OFFERS_SORT_ORDER2" => "desc",
        "OFFER_ADD_PICT_PROP" => "MORE_PHOTO",
        "OFFER_TREE_PROPS" => array("COLOR_REF","SIZES_SHOES","SIZES_CLOTHES"),
        "PAGER_BASE_LINK_ENABLE" => "N",
        "PAGER_DESC_NUMBERING" => "N",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "N",
        "PAGER_SHOW_ALWAYS" => "N",
        "PAGER_TEMPLATE" => ".default",
        "PAGER_TITLE" => "Товары",
        "PAGE_ELEMENT_COUNT" => "18",
        "PARTIAL_PRODUCT_PROPERTIES" => "N",
        "PRICE_CODE" => array("BASE"),
        "PRICE_VAT_INCLUDE" => "Y",
        "PRODUCT_BLOCKS_ORDER" => "price,props,sku,quantityLimit,quantity,buttons,compare",
        "PRODUCT_DISPLAY_MODE" => "Y",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_PROPERTIES" => array("NEWPRODUCT","MATERIAL"),
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PRODUCT_QUANTITY_VARIABLE" => "",
        "PRODUCT_ROW_VARIANTS" => "[{'VARIANT':'2','BIG_DATA':false},{'VARIANT':'2','BIG_DATA':false},{'VARIANT':'2','BIG_DATA':true}]",
        "PRODUCT_SUBSCRIPTION" => "Y",
        "PROPERTY_CODE" => array("NEWPRODUCT",""),
        "PROPERTY_CODE_MOBILE" => array(),
        "RCM_PROD_ID" => $_REQUEST["PRODUCT_ID"],
        "RCM_TYPE" => "personal",
        "SECTION_CODE" => "pants",
        "SECTION_ID" => "",
        "SECTION_ID_VARIABLE" => "SECTION_ID",
        "SECTION_URL" => "",
        "SECTION_USER_FIELDS" => array("",""),
        "SEF_MODE" => "N",
        "SET_BROWSER_TITLE" => "Y",
        "SET_LAST_MODIFIED" => "N",
        "SET_META_DESCRIPTION" => "Y",
        "SET_META_KEYWORDS" => "Y",
        "SET_STATUS_404" => "N",
        "SET_TITLE" => "Y",
        "SHOW_404" => "N",
        "SHOW_ALL_WO_SECTION" => "N",
        "SHOW_CLOSE_POPUP" => "N",
        "SHOW_DISCOUNT_PERCENT" => "Y",
        "SHOW_FROM_SECTION" => "N",
        "SHOW_MAX_QUANTITY" => "N",
        "SHOW_OLD_PRICE" => "N",
        "SHOW_PRICE_COUNT" => "1",
        "SHOW_SLIDER" => "Y",
        "SLIDER_INTERVAL" => "3000",
        "SLIDER_PROGRESS" => "N",
        "TEMPLATE_THEME" => "blue",
        "USE_ENHANCED_ECOMMERCE" => "Y",
        "USE_MAIN_ELEMENT_SECTION" => "N",
        "USE_PRICE_COUNT" => "N",
        "USE_PRODUCT_QUANTITY" => "N"
    )
);?>


Каталог (комплексный компонент)

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Каталог (комплексный компонент)

Каталог::Каталог (комплексный компонент)

Комплексный компонент осуществляет вывод полного каталога товаров из определенного инфоблока.

Описание catalog

Функциональность компонента объединяет возможности нескольких одностраничных компонентов: фильтра, компонента сравнения, вывода элементов раздела, топа элементов, связанных элементов и др. Расположив комплексный компонент на странице, можно получить полнофункциональный каталог. Компонент является стандартным и входит в дистрибутив модуля.

Внимание! Компонент не работает с инфоблоками, не имеющими структуры разделов. Если по логике проекта информация не должна иметь структурного деления, то необходимо создать один раздел верхнего уровня и уже в нём размещать элементы инфоблока.

В визуальном редакторе компонент расположен по пути Контент > Каталог > Каталог.

Компонент относится к модулю Информационные блоки.

Порядок секций в форме настройки компонента может меняться в зависимости от выбранного шаблона.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, из которого будет выводиться каталог товаров.
Источник данных
Недоступные товары HIDE_NOT_AVAILABLE Как отображать недоступные товары:
  • Отображать в общем списке
  • Отображать в конце
  • Не отображать
Недоступны товары, для которых количество меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Товар с торговыми предложениями считается доступным, если хоть одно предложение доступно.
Доступность товара не означает, что его можно купить. Для покупки должны быть цены тех типов, по которым клиент может покупать.
Недоступные торговые предложения HIDE_NOT_AVAILABLE_OFFERS Указывается способ отображения недоступных для покупки торговых предложений:
  • не отображать;
  • отображать только с возможностью подписки;
  • отображать все.
Внешний вид
Цветовая тема* | TEMPLATE_THEME | Задается цветовая схема для отображения элементов каталога. По умолчанию используется синяя схема (blue).
Дополнительная картинка основного товара | ADD_PICT_PROP | Указывается свойство, в котором хранится дополнительная картинка товара.
Свойство меток товара | LABEL_PROP | Указываются свойство, в котором хранится метка товара (например, новинка).
Свойство меток товара, отображаемые на мобильных устройствах | LABEL_PROP_MOBILE | Выбираются свойства, которые будут отображены в метках товара на мобильных устройствах. Для выбора доступны те свойства, которые были отмечены в параметре Свойство меток товара (LABEL_PROP).
Расположение меток товара | LABEL_PROP_POSITION | Указывается место расположения метки товара.
Схема отображения | PRODUCT_DISPLAY_MODE | Задается режим отображения товаров: простой (N) или расширенный (Y).
Дополнительные картинки предложения | OFFER_ADD_PICT_PROP | Задается свойство, в котором хранится дополнительная картинка для торгового предложения. Параметр доступен для инфоблока с торговыми предложениями.
Свойства для отбора предложений OFFER_TREE_PROPS Указываются свойства, по значениям которых будут группироваться торговые предложения. Параметр доступен для инфоблока с торговыми предложениями.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image] [image] [image] [image] [image] [image].
Показывать кнопку продолжения покупок во всплывающих окнах | COMMON_SHOW_CLOSE_POPUP | [Y|N] При отмеченной опции будет отображаться кнопка Продолжить покупки во всплывающем окне, появляющемся после добавления товара в корзину.
Разрешить оповещения для отсутствующих товаров | PRODUCT_SUBSCRIPTION | [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки.
Показывать процент скидки SHOW_DISCOUNT_PERCENT [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана, станет доступно [dw]дополнительное поле[/dw][di]
Расположение процента скидки "DISCOUNT_PERCENT_POSITION Выберите подходящее место для отображения процентной скидки на карточке товара.
[/di] .
Показывать старую цену | SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Показывать общее количество товара DETAIL_SHOW_MAX_QUANTITY [Y|N] Если включен количественный учет, то при установленной опции будет показано общее количество товара.

Примечание: Доступен только в шаблоне компонента .default_old.
Показывать остаток товара SHOW_MAX_QUANTITY Укажите способ отображения остатка товара:
  • не показывать;
  • с отображением реального остатка - в этом случае необходимо настроить параметр [dw] Текст для остатка[/dw][di]
    Текст для остатка MESS_SHOW_MAX_QUANTITY Задается текст для отображения информации о наличии товара. Доступность данных параметров компонента определяется настройками параметра Показывать остаток товара.
    [/di];
  • с подменой остатка текстом - в этом случае необходимо настроить [dw]параметры[/dw][di]
    Текст для остатка | MESS_SHOW_MAX_QUANTITY | Задается текст для отображения информации о наличии товара.
    Значение, от которого происходит подмена | RELATIVE_QUANTITY_FACTOR | Указывается значение, меньше (больше) которого о количестве товара на складе будет отображаться выражение, что товара мало (много).
    Текст для значения больше | MESS_RELATIVE_QUANTITY_MANY | Задается текст, который будет отображаться при наличии товара в количестве большем, чем значение в параметре Значение, от которого происходит подмена.
    Текст для значения меньше | MESS_RELATIVE_QUANTITY_FEW | Задается текст, который будет отображаться при наличии товара в количестве меньшем, чем значение в параметре Значение, от которого происходит подмена..
    [/di] Текст для остатка, Значение, от которого происходит подмена, Текст для значения больше и Текст для значения меньше.
Текст кнопки "Купить" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Добавить в корзину" | MESS_BTN_ADD_TO_BASKET | Задается текст, который должен быть отображен на кнопке добавления в корзину.
Текст кнопки "Сравнение" | MESS_BTN_COMPARE | Задается текст, который должен быть отображен на кнопке для сравнения товаров.
Текст кнопки "Подробнее" | MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Сообщение об отсутствии товара | MESS_NOT_AVAILABLE | Указывается текст, который будет отображаться при отсутствии товара и невозможности его купить.
Текст кнопки "Уведомить о поступлении" | MESS_BIN_SUBSCRIBE | Указывается текст, который будет отображаться в уведомлении о поступлении товара.
Показывать правый блок в списке товаров | SIDEBAR_SECTION_SHOW | [Y|N] При отмеченной опции на странице со списком товаров будет отображен блок с содержимым включаемой области, путь к которой указан в параметре ниже.
Показывать правый блок на детальной странице | SIDEBAR_DETAIL_SHOW | [Y|N] При отмеченной опции на детальной странице будет отображен блок с содержимым включаемой области, путь к которой указан в параметре ниже.
Путь к включаемой области для вывода информации в правом блоке | SIDEBAR_PATH | Указывается путь к файлу включаемой области.
* - поля недоступны для шаблона visual.
Согласие пользователя
Запрашивать согласие | USER_CONSENT | [Y|N] Установленный флажок включает механизм согласия пользователя в комментариях к товару.
Соглашение | USER_CONSENT_ID | Задается текст соглашения, которое отображается неавторизованному пользователю при создании комментария к товару.
Галка по умолчанию проставлена | USER_CONSENT_IS_CHECKED | Установка галочки автоматически устанавливает галочку в чекбоксе согласия пользователя. То есть согласие применяется одновременно с нажатием кнопки .
Загружать текст сразу | USER_CONSENT_IS_LOADED | Текст соглашения будет выводиться сразу. Если флажок не установлен, для просмотра текст нужно будет кликнуть по кнопке согласия.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить[dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • sections - страница со списком разделов;
  • section - страница с элементами раздела;
  • element - страница с детальной информацией;
  • compare - страница с таблицой сравнения.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Идентификатор раздела | SECTION_ID_VARIABLE | Задается имя переменной, в которой будет передаватся идентификатор раздела.
Идентификатор элемента | ELEMENT_ID | Задается имя переменной, в которой будет передаватся идентификатор элемента.
[/di] SECTION_ID, ELEMENT_ID.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленной опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кешировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Использовать основной раздел для показа элемента USE_MAIN_ELEMENT_SECTION [Y|N] Если опция отмечена, то при переходе на детальную страницу элемента в адресную строку браузера будет подставляться тот путь, который формируется при просмотре элемента через основной раздел, даже если элемент открыт через другой родительский его раздел.

Если опция не отмечена, про ссылка на детальную страницу элемента формируется с учетом того раздела, через который элемент открыт на просмотр.

Рассмотрим пример, когда опция в настройках отмечена. Допустим, что элемент с символьным кодом marketing привязан к двум разделам с кодами bisness и science соответственно, причем раздел с кодом bisness является основным. В результате, если пользователь пришел в раздел science и кликнул на элемент marketing, то в строке браузера вместо http://mysite.ru/catalog/science/marketing/ [image] будет отображено http://mysite.ru/catalog/bisness/marketing/ [image] .
Строгая проверка раздела для детального показа элемента DETAIL_STRICT_SECTION_CHECK [Y|N] При отмеченной опции будет выполняться строгая проверка принадлежности элемента к разделу. Таким образом, если при просмотре элемента в адресной строке указать неверный раздел, то будет выдана 404-я ошибка.
Если опцию не отмечать, то нужный элемент будет показан в любом случае.
Устанавливать в заголовках ответа время модификации страницы | SET_LAST_MODIFIED | [Y|N] При отмеченной опции http-ответ сервера будет содержать время последнего изменения страницы (заголовок Last-Modified [image]).
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет устанавливаться при переходе к разделам - имя раздела, к детальному просмотру элемента - имя элемента.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] Если опция отмечена и в инфоблоке созданы разделы, то при переходе по разделам их названия или заголовки (если выполнены настройки SEO) будут добавляться в цепочку навигации.
Включать название элемента в цепочку навигации | ADD_ELEMENT_CHAIN | [Y|N] При отмеченной опции название или заголовок (если задан в настройках SEO) элемента будет добавлен в цепочку навигации.
Показывать список лидеров продаж | USE_SALE_BESTSELLERS | [Y|N] При отмеченной опции будет показан блок лидеров продаж.
Настройки фильтра
Показывать фильтр USE_FILTER [Y|N] При отмеченной опции становятся доступными [dw]поля настройки фильтра[/dw][di]
Фильтр | FILTER_NAME | Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Вид отображения умного фильтра | FILTER_VIEW_MODE | Задается вид отображения умного фильтра: вертикальный (VERTICAL) или горизонтальный (HORIZONTAL).
Скрывать умный фильтр на мобильных устройствах | FILTER_HIDE_ON_MOBILE | [Y|N] При отмеченной опции умный фильтр скрывается на мобильных устройствах.
Мгновенная фильтрация при включенном AJAX | AJAX_OPTION_ADDITIONAL | [Y|N] При отмеченной опции включается мгновенная фильтрация при условии включенного режима AJAX.
[/di]. На странице разделов инфоблока отображается форма фильтра.
Настройки отзывов
В шаблоне .default компонента catalog версии модуля "Информационные блоки" выше 14.0.0 параметры этой секции работать не будут. В этом случае настройки отзывов следует проводить в секции Настройки детального просмотра. Но параметры присутствуют в компоненте из соображений совместимости с более ранними версиями, где они использовались.
Разрешить отзывы | USE_REVIEW | [Y|N] При отмеченной опции будет доступен функционал отзывов и становятся доступными параметры настройки отзывов.
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Параметр определяет количество выводимых на одной странице сообщений отзывов.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления отзыва в публичной части.
Использовать AJAX в диалогах | REVIEW_AJAX_POST | [Y|N] При отмеченной опции в диалогах будет использоваться технология AJAX.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Задается путь к папке со смайликами относительно корня сайта.
ID форума для отзывов | FORUM_ID | Указывается идентификатор форума, в котором будут храниться отзывы пользователей.
Страница чтения темы (пусто - получить из настроек форума) | URL_TEMPLATES_READ | Указывается относительный путь к странице чтения темы на форуме. Если поле пусто, путь к странице будет получен из настроек форума.
Показать ссылку на форум | SHOW_LINK_TO_FORUM | [Y|N] При отмеченной опции на странице фотографии будет отображена ссылка на форум обсуждения.
Начинать тему текстом элемента | POST_FIRST_MESSAGE | [Y|N] При отмеченной опции сообщение в отзыве будет начинаться с анонса фотографии.
Настройки действий
Название переменной, в которой передается действие | ACTION_VARIABLE | Задается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара.
Сравнение товаров
Разрешить сравнение товаров USE_COMPARE [Y|N] При отмеченной опции становятся доступными [dw]поля для настройки сравнения элементов[/dw][di]
Уникальное имя для списка сравнения | COMPARE_NAME | Задается имя переменной, в которой передается список сравниваемых элементов. По умолчанию CATALOG_COMPARE_LIST.
Поля COMPARE_FIELD_CODE Указываются поля товаров, по которым будет происходить сравнение в таблице сравнения. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания полей в строках (т.е. если задан пустой массив), будут выведены поля по умолчанию.
Свойства COMPARE_PROPERTY_CODE Указываются свойства, по которым товары будут сравниваться в таблице сравнения. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image] [image] [image] [image] [image] [image].
Поля предложений | COMPARE_OFFERS_FIELD_CODE | Указываются поля товаров, по которым будет происходить сравнение в таблице сравнения. При выборе пункта (не выбрано)-> будут выведены поля по умолчанию. Данное поле доступно для каталогов, имеющих торговые предложения.
Свойства предложений COMPARE_OFFERS_PROPERTY_CODE Указываются свойства, по которым товары будут сравниваться в таблице сравнения. При выборе пункта (не выбрано)-> свойства выведены не будут. Данное поле доступно для каталогов, имеющих торговые предложения.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image] [image] [image] [image] [image] [image].
По какому полю сортируем элементы COMPARE_ELEMENT_SORT_FIELD Выбирается поле, по которому будут отсортированы выбранные товары в таблице сравнения:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок сортировки элементов COMPARE_ELEMENT_SORT_ORDER Устанавливается направление сортировки товаров в таблице сравнения:
  • asc – По возрастанию;
  • desc – По убыванию.
Отображать список сравнения поверх страницы | COMPARE_POSITION_FIXED | [Y|N] При отмеченной опции специальный блок сравнения будет отображен поверх других элементов сайта. В противном случае детальная информация по сравнению товаров будет отображена на странице.
Положение на странице COMPARE_POSITION Задается положение блока сравнения товаров на странице: вверху слева, вверху справа, внизу слева или вверху справа.

Параметр доступен, если отмечена опция Отображать список сравнения поверх страницы.
[/di] и будет возможно сравнивать элементы каталога по кнопке Сравнить.
Цены
Тип цены | PRICE_CODE | Указывается какой из типов цен будет выведен в каталоге. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Использовать вывод цен с диапазонами | USE_PRICE_COUNT | [Y|N] При отмеченной опции будут отображаться цены всех типов на товары.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Отображать значение НДС | PRICE_VAT_SHOW_VALUE | [Y|N] При отмеченной опции цены будут показаны величины НДС.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах, станет доступным [dw]дополнительное поле[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты, в которой будут отображаться цены. Параметр доступен, если отмечена опция Показывать цены в одной валюте.
[/di] . При выборе этой опции кеш компонента будет автоматически сбрасываться при изменении курсов валют тех товаров, которые показываются компонентом. К примеру, если выбрана конвертация в рубли, а цены в информационном блоке сохранены в евро, то кеш сбросится при изменении курса евро или рубля. Изменения остальных валют на кеш не окажут влияния.
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Разрешить указание количества товара USE_PRODUCT_QUANTITY [Y|N] При отмеченной опции будет разрешен вывод количества товара, станет доступным [dw]дополнительное поле[/dw][di]
Название переменной, в которой передается количество товара PRODUCT_QUANTITY_VARIABLE Задается имя переменной, в которой будет передаваться количество товара.
[/di] .
Разрешить указание дробного количества товара | QUANTITY_FLOAT | [Y|N] При отмеченной опции в корзину можно будет добавлять дробное количество товара. Опция доступна, если отмечен параметр Разрешить указание количества товара, до версии модуля 14.0.0.
Добавлять в корзину свойства товаров и предложений ADD_PROPERTIES_TO_BASKET [Y|N] При отмеченной опции становятся доступными [dw]настройки выбора свойств товаров и предложений[/dw][di]
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить добавлять в корзину товары, у которых заполнены не все характеристики | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
Характеристики товара, добавляемые в корзину | PRODUCT_PROPERTIES | Указываются характеристики товара.
Свойства предложений, добавляемые в корзину | OFFERS_CART_PROPERTIES | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
[/di] для передачи их в корзину и заказ.
Одинаковые настройки показа кнопок добавления в корзину или покупки на всех страницах | USE_COMMON_SETTINGS_BASKET_POPUP | [Y|N] При отмеченной опции на всех страницах каталога будут использоваться одинаковые настройки отображения кнопок для добавления в корзину или покупки.
Показывать кнопку добавления в корзину или покупки COMMON_ADD_TO_BASKET_ACTION Выберите какая кнопка на страницах каталога должна отображаться: кнопка покупки (BUY) или кнопка добавления в корзину (ADD).

Параметр доступен, если отмечена опция Одинаковые настройки показа кнопок добавления в корзину или покупки на всех страницах.
Показывать кнопку добавления в корзину или покупки на странице с top'ом товаров TOP_ADD_TO_BASKET_ACTION Выберите какая кнопка должна отображаться на странице с top'ом товаров: кнопка покупки (BUY) или кнопка добавления в корзину (ADD).

Параметр доступен, если опция Одинаковые настройки показа кнопок добавления в корзину или покупки на всех страницах не отмечена.
Показывать кнопку добавления в корзину или покупки на странице списка товаров SECTION_ADD_TO_BASKET_ACTION Выберите какая кнопка должна отображаться на странице списка товаров: кнопка покупки (BUY) или кнопка добавления в корзину (ADD).

Параметр доступен, если опция Одинаковые настройки показа кнопок добавления в корзину или покупки на всех страницах не отмечена.
Показывать кнопки добавления в корзину и покупки на детальной странице товара DETAIL_ADD_TO_BASKET_ACTION Укажите какие кнопки должны отображаться на детальной странице товара: кнопка покупки (BUY) и/или кнопка добавления в корзину (ADD).

Параметр доступен, если опция Одинаковые настройки показа кнопок добавления в корзину или покупки на всех страницах не отмечена.
Выделять кнопки добавления в корзину и покупки на детальной странице товара DETAIL_ADD_TO_BASKET_ACTION_PRIMARY Укажите какие кнопки должны быть выделены на детальной странице товара. Для выбора доступны те кнопки, что указаны в поле Показывать кнопки добавления в корзину и покупки на детальной странице товара (DETAIL_ADD_TO_BASKET_ACTION).

Параметр доступен, если опция Одинаковые настройки показа кнопок добавления в корзину или покупки на всех страницах не отмечена.
Показывать на детальной странице цену за единицу товара DETAIL_SHOW_BASIS_PRICE [Y|N] При отмеченной опции на детальной странице товара будет указана цена за единицу товара.

Параметр доступен, если отмечена опция Разрешить указание количества товара.

Примечание: Доступен только в шаблоне компонента .default_old.
Настройки поиска
Количество результатов на странице | SEARCH_PAGE_RESULT_COUNT | Указывается количество результатов поиска, отображаемых на одной странице.
Искать без учета морфологии (при отсутствии результата поиска) | RESTART | [Y|N] При отмеченной опции с лучае отсутствия результата поиска будут выведены элементы, имеющие морфологические отклонения от поискового запроса.
Отключить обработку слов как логических операторов | NO_WORD_LOGIC | [Y|N] При снятой опции слова логических операторов ("И", "ИЛИ" и пр.) будут интерпретироваться только как лингвистическая часть поискового запроса.
Включить автоопределение раскладки клавиатуры | USE_LANGUAGE_GUESS | [Y|N] При отмеченной опции будет включено автоопределение раскладки клавиатуры.
Искать только в активных по дате документах | CHECK_DATES | [Y|N] При отмеченной опции поиск будет осуществляться только в активных по дате элементах.
Использовать сортировку результатов по релевантности | SEARCH_USE_SEARCH_RESULT_ORDER | [Y|N] При отмеченной опции результаты поиска будут отсортированы по релевантности.
Настройки TOP'а
Выводить топ элементов SHOW_TOP_ELEMENTS [Y|N] При отмеченной опции становятся доступными [dw]поля настроек TOP'а элементов[/dw][di]
Количество выводимых элементов TOP_ELEMENT_COUNT Указывается количество элементов, отображаемых на одной странице TOP’а. Все элементы списка будут выведены с помощью постраничной навигации.

Примечание: Доступен только в шаблоне компонента .default_old. В других шаблонах настройки задаются параметром Вариант отображения товаров.
Количество элементов, выводимых в одной строке таблицы TOP_LINE_ELEMENT_COUNT Указывается количество элементов TOP’а, выводимых в одной строке таблицы.

Примечание: Доступен только в шаблоне компонента .default_old. В других шаблонах настройки задаются параметром Вариант отображения товаров.
По какому полю сортируем товары в разделе TOP_ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка товаров внутри каждого раздела:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок сортировки товаров в разделе TOP_ELEMENT_SORT_ORDER Задается порядок сортировки товаров в разделе:
  • asc – По возрастанию;
  • desc – По убыванию.
Поле для второй сортировки товаров в разделе TOP_ELEMENT_SORT_FIELD2 Указывается поле, по которому будет происходить вторая сортировка товаров внутри каждого раздела:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок второй сортировки товаров в разделе TOP_ELEMENT_SORT_ORDER2 Задается порядок второй сортировки товаров в разделе:
  • asc – По возрастанию;
  • desc – По убыванию.
Свойства TOP_PROPERTY_CODE Указываются свойства инфоблока, которые будут отображены в TOP’е элементов. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image] [image] [image] [image] [image] [image].
Поля предложений | TOP_OFFERS_FIELD_CODE | Выбираются поля предложений. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений TOP_OFFERS_PROPERTY_CODE Указываются свойства предложений. Можно добавлять свои. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image] [image] [image] [image] [image] [image].
Показ элементов top'а | TOP_VIEW_MODE | Определяется способ отображения top'а элементов: баннер (BANNER), слайдер (SLIDER) или список (SECTION).
Порядок отображения блоков товара | TOP_PRODUCT_BLOCKS_ORDER | Перетаскивая блоки, определите необходимый вам порядок следования блоков.
Вариант отображения товаров TOP_PRODUCT_ROW_VARIANTS В правой части поля выберите блок с подходящим вам вариантом отображения одной строки товаров на странице и перетащите его в левую часть. Если строка товаров должна быть по персональной рекомендации, то предварительно отметьте опцию BigData и затем уже перетащите нужный блок. Аналогичным образом настройте остальные строки для формирования таблицы товаров.

Выделять товары в списке LIST_ENLARGE_PRODUCT Выберите способ выделения товаров в списке:
  • по выбранному шаблону (строго) - товар будет выделятся строго по настроенному варианту отображения товаров;
  • по свойству, подгонять по шаблону (в этом случае возможно изменение сортировки элементов) - в списке будет выделяться тот товар, для которого заполнено указанное в параметре Выделять по выбранному свойству свойство.
Примечание: выделение товаров осуществляется в том случае, если для показа списка товаров выбран хотя бы один вариант вида:

Выделять по выбранному свойству TOP_ENLARGE_PROP Указывается то свойство товара, при наличии которого товар будет выделен в списке просмотренных (если позволяет вариант отображения товаров, см. поле Вариант отображения товаров).
Параметр доступен, если в параметре Выделять товары в списке указано значение по свойству (подгонять по шаблону).
Показывать слайдер для товаров | TOP_SHOW_SLIDER | [Y|N] При установленной опции для товаров будет включен показ слайдов и станет доступно дополнительное поле.
Интервал смены слайдов, мс | TOP_SLIDER_INTERVAL | Указывается интервал смены слайдов в мс.
Показывать полосу прогресса | TOP_SLIDER_PROGRESS | Для указанного интервала будет отображаться полоса прогресса до следующего слайда.
[/di] и будет выведен TOP элементов инфоблока.
Настройки списка разделов
Показывать количество элементов в разделе | SECTION_COUNT_ELEMENTS | Указывается количество элементов в разделе.
Максимальная отображаемая глубина разделов | SECTION_TOP_DEPTH | Параметр определяет максимальную глубину отображаемых в структуре разделов.
Вид списка подразделов | SECTIONS_VIEW_MODE | Определяется способ отображения списка подразделов: в виде списка (LINE), текста (TEXT) или плитки (TILE).
Показывать название раздела | SECTIONS_SHOW_PARENT_NAME | [Y|N] При отмеченной опции будет выводится название раздела (кроме раздела верхнего уровня).
Не показывать названия подразделов | SECTIONS_HIDE_SECTION_NAME | Опция появляется, если для вида списка подразделов установлено Плитка. При выборе этой опции названия подразделов будут скрыты и показаны только картинки разделов.
Настройки списка
Количество элементов на странице PAGE_ELEMENT_COUNT Указывается количество элементов списка, отображаемых на одной странице. Все элементы списка будут выведены с помощью постраничной навигации.

Примечание: Доступен только в шаблоне компонента .default_old. В других шаблонах настройки задаются параметром Вариант отображения товаров.
Количество элементов, выводимых в одной строке таблицы LINE_ELEMENT_COUNT Указывается количество элементов списка, выводимых в одной строке таблицы. Все элементы списка будут выведены с помощью постраничной навигации.

Примечание: Доступен только в шаблоне компонента .default_old. В других шаблонах настройки задаются параметром Вариант отображения товаров.
По какому полю сортируем товары в разделе ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка товаров внутри каждого раздела:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок сортировки товаров в разделе ELEMENT_SORT_ORDER Задается порядок сортировки товаров в разделе:
  • asc – По возрастанию;
  • desc – По убыванию.
Поле для второй сортировки товаров в разделе ELEMENT_SORT_FIELD2 Указывается поле, по которому будет происходить вторая сортировка товаров внутри каждого раздела:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок второй сортировки товаров в разделе ELEMENT_SORT_ORDER2 Задается порядок второй сортировки товаров в разделе:
  • asc – По возрастанию;
  • desc – По убыванию.
Свойства LIST_PROPERTY_CODE Указываются свойства инфоблока, которые будут отображены в списке товаров внутри раздела. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image] [image] [image] [image] [image] [image].
Свойства товаров, отображаемые на мобильных устройствах | LIST_PROPERTY_CODE_MOBILE | Выбираются свойства товаров, которые будут отображены на мобильных устройствах.
Показывать элементы подразделов раздела | INCLUDE_SUBSECTIONS | [Y|N] При отмеченной опции будут отображены элементы подразделов раздела. Может иметь значение "A" (Active)
Установить ключевые слова страницы из свойства раздела | LIST_META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится ключевые слова страницы.
Установить описание страницы из свойства раздела | LIST_META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание страницы.
Установить заголовок окна браузера из свойства раздела | LIST_BROWSER_TITLE | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится заголовок окна браузера.
Установить фоновую картинку для шаблона из свойства SECTION_BACKGROUND_IMAGE Указывается свойство, в котором хранится картинка для фона для страницы списка.

Свойство должно быть немножественным типа Файл.

Важно! В шаблоне сайта должна быть реализована поддержка этого функционала: в необходимом вам теге должно быть прописано:
<?=$APPLICATION->ShowProperty("backgroundImage")?>
Поля предложений | LIST_OFFERS_FIELD_CODE | Выбираются поля предложений для списка. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений LIST_OFFERS_PROPERTY_CODE Указываются свойства предложений. Можно добавлять свои. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image] [image] [image] [image] [image] [image].
Порядок отображения блоков товара LIST_PRODUCT_BLOCKS_ORDER Перетаскивая блоки, определите необходимый вам порядок следования блоков товара.

Вариант отображения товаров LIST_PRODUCT_ROW_VARIANTS В правой части поля выберите блок с подходящим вам вариантом отображения одной строки товаров на странице и перетащите его в левую часть. Если строка товаров должна быть по персональной рекомендации, то предварительно отметьте опцию BigData и затем уже перетащите нужный блок. Аналогичным образом настройте остальные строки для формирования таблицы товаров.

Выделять товары в списке LIST_ENLARGE_PRODUCT Выберите способ выделения товаров в списке:
  • по выбранному шаблону (строго) - товар будет выделятся строго по настроенному варианту отображения товаров;
  • по свойству, подгонять по шаблону (в этом случае возможно изменение сортировки элементов) - в списке будет выделяться тот товар, для которого заполнено указанное в параметре Выделять по выбранному свойству свойство.
Примечание: выделение товаров осуществляется в том случае, если для показа списка товаров выбран хотя бы один вариант вида:

Выделять по выбранному свойству LIST_ENLARGE_PROP Указывается то свойство товара, при наличии которого товар будет выделен в списке просмотренных (если позволяет вариант отображения товаров, см. поле Вариант отображения товаров).
Параметр доступен, если в параметре Выделять товары в списке указано значение по свойству (подгонять по шаблону).
Показывать слайдер для товаров LIST_SHOW_SLIDER [Y|N] При установленной опции для товаров будет включен показ слайдов и станут доступны [dw]дополнительные поля[/dw][di]
Интервал смены слайдов, мс | LIST_SLIDER_INTERVAL | Указывается интервал смены слайдов в мс.
Показывать полосу прогресса | LIST_SLIDER_PROGRESS | Для указанного интервала будет отображаться полоса прогресса до следующего слайда.
[/di].
Настройки детального просмотра
Свойства DETAIL_PROPERTY_CODE Среди всех свойств, определенных для данного инфоблока, выбираются те, которые будут отображены при детальном просмотре элементов.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image] [image] [image] [image] [image] [image].
Установить ключевые слова страницы из свойства | DETAIL_META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова для страницы.
Установить описание страницы из свойства | DETAIL_META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится детальное описание страницы.
Установить заголовок окна браузера из свойства | DETAIL_BROWSER_TITLE | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится заголовок окна браузера.
Устанавливать канонический URL DETAIL_SET_CANONICAL_URL [Y|N] При отмеченной опции страница товара будет помечена как каноническая (т.е. будет считаться основной для поисковых систем среди ее дублей).

Каноническая ссылка строится для основного раздела элемента, а если он не задан, то для раздела с наименьшим идентификатором.
Название переменной, в которой передается код группы | SECTION_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор раздела.
Использовать код группы из переменной, если не задан раздел элемента | DETAIL_CHECK_SECTION_ID_VARIABLE | [Y|N] При отмеченной опции, если не задан раздел элемента, будет использоваться код раздела из значения переменной.
Установить фоновую картинку для шаблона из свойства DETAIL_BACKGROUND_IMAGE Указывается свойство, в котором хранится картинка для фона детальной страницы.

Свойство должно быть немножественным типа Файл.

Важно! В шаблоне сайта должна быть реализована поддержка этого функционала: в необходимом вам теге должно быть прописано:
<?=$APPLICATION->ShowProperty("backgroundImage")?>
Показывать деактивированные товары | SHOW_DEACTIVATED | [Y|N] При отмеченной опции компонент будет отображать также и неактивные товары.
Отображать описание для каждого торгового предложения SHOW_SKU_DESCRIPTION [Y|N] При отмеченной опции для каждого торгового предложения будет отображено своё описание для анонса и детальное описание в детальной карточке товара, если они заполнены. Если нет - отобразится описание для анонса и детальное описание самого товара.

Примечание: Параметр доступен с версии 20.5.0 модуля Информационные блоки.

Поля предложений | DETAIL_OFFERS_FIELD_CODE | Выбираются поля предложений. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений DETAIL_OFFERS_PROPERTY_CODE Указываются свойства предложений. Можно добавлять свои. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image] [image] [image] [image] [image] [image].
Свойства, отображаемые в блоке справа от картинки | DETAIL_MAIN_BLOCK_PROPERTY_CODE | Выберите свойства инфоблока, которые будут отображаться справа от картинки товара.
Свойства предложений, отображаемые в блоке справа от картинки | DETAIL_MAIN_BLOCK_OFFERS_PROPERTY_CODE | Выберите свойства предложений, которые будут отображаться справа от картинки товара.
Включить рейтинг товара DETAIL_USE_VOTE_RATING [Y|N] При установленной опции для товаров будет включен рейтинг, станет доступно [dw]дополнительное поле[/dw][di]
В качестве рейтинга показывать DETAIL_VOTE_DISPLAY_AS_RATING Указывается, что показывать в качестве рейтинга: рейтинг (rating) или среднее значение (vote_avg).
[/di].
Включить отзывы о товаре DETAIL_USE_COMMENTS [Y|N] При отмеченной опции доступен [dw]функционал отзывов о товаре[/dw][di]
Использовать комментарии | DETAIL_BLOG_USE | [Y|N] При отмеченной опции отзывы о товаре можно оставлять с помощью комментариев блога.
Название блога латинскими буквами | DETAIL_BLOG_URL | Указывается блог, в комментарии которого будут сохраняться отзывы о товаре.
Уведомление по электронной почте | DETAIL_BLOG_EMAIL_NOTIFY | [Y|N] При отмеченной опции уведомления об отзывах будут направлены по электронной почте.
Использовать ВКонтакте | DETAIL_VK_USE | [Y|N] При отмеченной опции отзывы о товаре можно будет оставлять с помощью плагина ВКонтакте. Параметр доступен, если отмечена опция Включить отзывы о товаре. Кроме того, при использовании Вконтакте для создания отзывов, становится доступным для настройки параметр DETAIL_VK_API_ID, в котором задается идентификатор приложения Вконтакте (API_ID).
Использовать Facebook* | DETAIL_FB_USE | [Y|N] При отмеченной опции отзывы о товаре можно будет оставлять с помощью плагина Facebook*. Параметр доступен, если отмечена опция Включить отзывы о товаре. Кроме того, при использовании Facebook* для создания отзывов, становится доступным для настройки параметр DETAIL_FB_APP_ID, в котором задается идентификатор приложения (APP_ID). * деятельность организации запрещена в Российской Федерации.
[/di].
Использовать компонент "Бренды" DETAIL_BRAND_USE [Y|N] При отмеченной опции будет доступен [dw]компонент брендов[/dw][di]
Таблица с брендами* DETAIL_BRAND_PROP_CODE Задается свойство типа "Справочник", в котором хранятся данные.
[/di] .
Выводить название элемента | DETAIL_DISPLAY_NAME | [Y|N] При отмеченной опции будет отображено название элемента на странице с детальной информацией.
Соотношение сторон изображения товара DETAIL_IMAGE_RESOLUTION Выберите из списка соотношение сторон изображения товара. Доступны варианты:
  • 16:9
  • 1:1
Порядок отображения блоков информации о товаре DETAIL_PRODUCT_INFO_BLOCK_ORDER Перетаскивая блоки, определите необходимый вам порядок следования блоков товара.

Порядок отображения блоков покупки товара | DETAIL_PRODUCT_PAY_BLOCK_ORDER | Перетаскивая блоки, определите необходимый вам порядок следования блоков покупки товара.
Показывать слайдер для товаров DETAIL_SHOW_SLIDER [Y|N] При отмеченной опции для товаров будет использоваться слайдер для показа изображений, станут доступны [dw]дополнительные поля[/dw][di]
Интервал смены слайдов, мс | DETAIL_SLIDER_INTERVAL | Указывается интервал смены слайдов в миллисекундах.
Показывать полосу прогресса | DETAIL_SLIDER_PROGRESS | [Y|N] При отмеченной опции будет отображаться полоса прогресса до начала показа следующего слайда.
[/di] .
Режим показа детальной картинки | DETAIL_DETAIL_PICTURE_MODE | Выберите режим показа детальной картинки элемента: обычный (IMG), всплывающее окно (POPUP) или лупа (MAGNIFIER).
Добавлять детальную картинку в слайдер | DETAIL_ADD_DETAIL_TO_SLIDER | [Y|N] При отмеченной опции детальная картинка будет отображаться в слайдере вместе с дополнительными изображениями для товара.
Показ описания для анонса на детальной странице | DETAIL_DISPLAY_PREVIEW_TEXT_MODE | Укажите каким образом должен быть выведен текст анонса на детальной странице элемента.
Название блока c расширенными ценами | MESS_PRICE_RANGES_TITLE | Указывается название блока с расширенными ценами.
Текст вкладки "Описание" | MESS_DESCRIPTION_TAB | Указывается заголовок вкладки с описанием товара.
Текст вкладки "Характеристики" | MESS_PROPERTIES_TAB | Указывается заголовок вкладки с характеристиками товара.
Текст вкладки "Комментарии" | MESS_COMMENTS_TAB | Указывается заголовок вкладки для комментариев к товару.
Показывать блок "Популярное в разделе" | DETAIL_SHOW_POPULAR | [Y|N] При отмеченной опции будет показан блок "Популярное в разделе".
Показывать блок "Просматривали" | DETAIL_SHOW_VIEWED | [Y|N] При отмеченной опции будет показан блок "Просматривали".
Настройки связанных элементов
Тип инфоблока, элементы которого связаны с текущим элементом | LINK_IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока, элементы которого связаны с текущим элементом.
ID инфоблока, элементы которого связаны с текущим элементом | LINK_IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, из которого будут выводиться список элементов, связаны с текущим элементом.
Свойство, в котором хранится связь | LINK_PROPERTY_SID | Свойство, по которому связаны элементы, выбирается из списка или указывается в виде кода в поле рядом.
URL на страницу, где будет показан список связанных элементов | LINK_ELEMENTS_URL | Указывается путь к странице, где будет показан список связанных элементов.
Настройки блока "С этим товаром покупают" (блок отображается только в шаблоне .default_old)
Показывать блок "С этим товаром покупают" USE_ALSO_BUY [Y|N] При отмеченной опции становятся доступными поля настройки блока, а в детальном описании товара будет выводиться блок "С этим товаром покупают".

Примечание: Для корректной работы данного функционала необходимо в глобальных настройках модуля Интернет-магазин определить статусы заказов, по товарам из которых будет формироваться список также продаваемых товаров (см. параметр Список статусов, при переводе заказа в которые, товары попадают в сбор).

Количество элементов для отображения | ALSO_BUY_ELEMENT_COUNT | Указывается количество товаров для отображения в блоке "С этим товаром покупают".
Минимальное количество покупок товара | ALSO_BUY_MIN_BUYES | Минимальное количество покупок товара, чтобы блок "С этим товаром покупают" мог быть отображен.
Настройки "Подарков"
Показывать блок "Подарки" в детальном просмотре | USE_GIFTS_DETAIL | [Y|N] При отмеченной опции на странице с детальной информацией о товаре будет отображаться блок с доступными подарками.
Показывать блок "Подарки" в списке | USE_GIFTS_SECTION | [Y|N] При отмеченной опции на странице со списком товаров раздела будет отображаться блок с доступными подарками. Причем должно быть выполнено особое условие [image].
Показывать блок "Товары к подарку" в детальном просмотре USE_GIFTS_MAIN_PR_SECTION_LIST [Y|N] При отмеченной опции будет отображаться блок с товарами, которые нужно купить для получения предложенного подарка.

Примечание. Товары в этом блоке отображаются только в том случае, если в настройках правила предоставления подарка [image] в Дополнительных условиях указано только одно условие (Товар = или Раздел =).

Количество элементов в блоке "Подарки" в строке в детальном просмотре | GIFTS_DETAIL_PAGE_ELEMENT_COUNT | Указывается количество элементов, отображаемых на одной странице блока с подарками при детальном просмотре товара.
Скрыть заголовок "Подарки" в детальном просмотре | GIFTS_DETAIL_HIDE_BLOCK_TITLE | [Y|N] При отмеченной опции на странице с детальной информацией о товаре заголовок блока подарков будет скрыт.
Текст заголовка "Подарки" в детальном просмотре | GIFTS_DETAIL_BLOCK_TITLE | Указывается текст заголовка блока с подарками на странице детального просмотра товара.
Текст метки "Подарка" в детальном просмотре | GIFTS_DETAIL_TEXT_LABEL_GIFT | Указывается текст метки, которая проставляется для подарка на странице детального просмотра товара.
Количество элементов в блоке "Подарки" строке в списке | GIFTS_SECTION_LIST_PAGE_ELEMENT_COUNT | Указывается количество элементов, отображаемых на одной странице блока с подарками при просмотре списка товаров раздела.
Скрыть заголовок "Подарки" в списке | GIFTS_SECTION_LIST_HIDE_BLOCK_TITLE | [Y|N] При отмеченной опции заголовок блока подарков будет скрыт на странице со списком товаров раздела .
Текст заголовка "Подарки" в списке | GIFTS_SECTION_LIST_BLOCK_TITLE | Указывается текст заголовка блока с подарками, отображаемый на странице со списком товаров раздела.
Текст метки "Подарка" в списке | GIFTS_SECTION_LIST_TEXT_LABEL_GIFT | Указывается текст метки, которая проставляется для подарка на странице со списком товаров раздела.
Показывать процент скидки | GIFTS_SHOW_DISCOUNT_PERCENT | [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана.
Показывать старую цену | GIFTS_SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Показывать название | GIFTS_SHOW_NAME | [Y|N] При отмеченной опции будет отображено название подарка.
Показывать изображение | GIFTS_SHOW_IMAGE | [Y|N] При отмеченной опции будет показано изображение подарка.
Текст кнопки "Выбрать" | GIFTS_MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Выбрать".
Количество элементов в блоке "Товары к подарку" в строке в детальном просмотре | GIFTS_MAIN_PRODUCT_DETAIL_PAGE_ELEMENT_COUNT | Указывается количество элементов на одной странице блока с товарами, которые нужно купить для получения предложенного подарка.
Скрыть заголовок "Товары к подарку" в детальном просмотре | GIFTS_MAIN_PRODUCT_DETAIL_HIDE_BLOCK_TITLE | [Y|N] При отмеченной опции заголовок блока товаров к подарку будет скрыт.
Текст заголовка "Товары к подарку | GIFTS_MAIN_PRODUCT_DETAIL_BLOCK_TITLE | Указывается заголовок для блока с товарами, которые нужно купить для получения предложенного подарка.
Настройки блока "Количество товара на складе"
Показывать блок "Количество товара на складе" USE_STORE [Y|N] При отмеченной опции становятся доступными [dw]поля настройки блока[/dw][di]
Склады | STORES | Выбираются склады, информация по которым должна быть показана. Для выбора нескольких значений следует воспользоваться клавишей Ctrl.
Показывать вместо точного количества информацию о достаточности | USE_MIN_AMOUNT | [Y|N] При отмеченной опции количество имеющегося на складе товара будет заменено на выражение "достаточно" или "мало".
Пользовательские поля | USER_FIELDS | Выбираются пользовательские поля складов для отображения. С помощью клавиши Ctrl можно выбрать несколько значений.
Поля | FIELDS | Выбираются поля складов для отображения. С помощью клавиши Ctrl можно выбрать несколько значений.
Значение, ниже которого выводится "мало" | MIN_AMOUNT | Указывается значение, меньше которого о количестве товара на складе будет отображаться выражение "мало". Если количество товара на складе больше, чем это значение, то на странице будет отображаться выражение "достаточно".
Отображать склад при отсутствие на нем товара | SHOW_EMPTY_STORE | [Y|N] При отмеченной опции склад будет отображен, даже если на нем нет товара.
Показывать общую информацию по складам | SHOW_GENERAL_STORE_INFORMATION | [Y|N] При отмеченной опции будет показана общая информация по складам.
Шаблон пути к каталогу STORE(относительно корня) | STORE_PATH | Указывается шаблон пути к детальной странице склада.
Заголовок блока | MAIN_TITLE | Указывается заголовок блока о количестве товара на складе.
[/di] , а в детальном описании товара будет выводиться блок с информацией о количестве товара на складе.
Настройка предложений (данный блок свойств появляется при настройке компонента на инфоблок с поддержкой SKU)
По какому полю сортируем предложения товара OFFERS_SORT_FIELD Указывается поле, по которому будет происходить сортировка предложений товара:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок сортировки предложений товара OFFERS_SORT_ORDER Задается порядок сортировки предложений товара:
  • asc – По возрастанию;
  • desc – По убыванию.
Поле для второй сортировки предложений товара OFFERS_SORT_FIELD2 Указывается поле, по которому будет происходить вторая сортировка предложений товара:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок второй сортировки предложений товара OFFERS_SORT_ORDER2 Задается порядок второй сортировки предложений товара:
  • asc – По возрастанию;
  • desc – По убыванию.
Персональные рекомендации
Показывать персональные рекомендации USE_BIG_DATA [Y|N] При отмеченной опции будет использоваться в каталоге сервис персонализации, станут доступны [dw]дополнительные поля[/dw][di]
Тип рекомендации BIG_DATA_RCM_TYPE Выбирается один из типов рекомендаций:
  • bestsell - Самые продаваемые;
  • personal - Персональные рекомендации;
  • similar_sell - Продаваемые с этим товаром;
  • similar_view - Просматриваемые с этим товаром;
  • similar - Похожие товары;
  • any_similar - Продаваемые/Просматриваемые/Похожие товары;
  • any_personal - Самые продаваемые/Персональные;
  • any - Любая рекомендация.
[/di] .
Настройки аналитики
Включить отправку данных в электронную торговлю USE_ENHANCED_ECOMMERCE [Y|N] Включение опции. После включения станут доступны ещё [dw]два поля[/dw][di]
Имя контейнера данных | DATA_LAYER_NAME | Указываются свойства инфоблока, которые будут отображены в списке просмотренных товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Свойство брендов | BRAND_PROPERTY | Указывается свойство инфоблока, откуда система должна брать название бренда товара (производитель, марка, модель и т.п.).
[/di] . Требуется дополнительная настройка в Google Analytics Enhanced Ecommerce [image] и/или Яндекс.Метрике [image].

Примечание: Настройка Яндекс метрикой не сложна, и данные в ней отображаются довольно быстро (полчаса-час). У Google используется Google Tag Manager с плагином электронной коммерции, его нужно настроить и добавить на страницу в шаблоне. После настройки на "той" стороне, нужно настроить компоненты для работы с электронной коммерцией и включить эту поле настройки.

Настройки постраничной навигации
Шаблон постраничной навигации | PAGER_TEMPLATE | Указывается название шаблона постраничной навигации. Если поле пусто, то выбирается шаблон по умолчанию (.default).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение по элементам.
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться, даже если все элементы помещаются на одной странице.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц в секундах для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все элементы каталога.
Включить обработку ссылок PAGER_BASE_LINK_ENABLE [Y|N] При отмеченной опции доступна [dw]обработка ссылок[/dw][di]
Url для построения ссылок (по умолчанию - автоматически) | PAGER_BASE_LINK | Задается адрес для построения ссылок. Если в параметре ничего не указывать, то адрес будет построен автоматически.
Имя массива с переменными для построения ссылок в постраничной навигации | PAGER_PARAMS_NAME | Задается имя переменной, в которой передается массив с переменными для построения ссылок компонентом постраничной навигации.
[/di] для постраничной навигации.
Показать кнопку ленивой загрузки Lazy Load LAZY_LOAD [Y|N] При отмеченной опции доступна кнопка [dw]"Показать еще"[/dw][di]
Текст кнопки "Показать ещё" MESS_BTN_LAZY_LOAD Указывается текст, который должен быть показан на кнопке "Показать ещё"/ Параметр доступен, если отмечена опция Показать кнопку ленивой загрузки Lazy Load.
[/di] .
Подгружать товары при прокрутке до конца | LOAD_ON_SCROLL | [Y|N] При отмеченной опции товары будет подгружаться на просмотр при прокрутке страницы до конца.
Настройки 404 ошибки
Устанавливать статус 404 | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Показ специальной страницы SHOW_404 [Y|N] При отмеченной опции будет показана [dw]специальная страница[/dw][di]
Страница для показа (по умолчанию /404.php) FILE_404 Задается адрес страницы, которая будет отображаться при возникновении ошибки 404.
[/di] в случае возникновения ошибки 404, в противном случае - будет отображено [dw]специальное сообщение[/dw][di]
Сообщение для показа (по умолчанию из компонента) MESSAGE_404 Задается сообщение, которое будет показано в случае возникновения ошибки 404. Если ничего не указывать, то будет использоваться стандартное сообщение из компонента.
[/di] .
Специальные настройки
Включить режим совместимости COMPATIBLE_MODE [Y|N] При отмеченной опции включается режим совместимости, становятся доступны [dw]дополнительные поля[/dw][di]
Не подключать js-библиотеки в компоненте | DISABLE_INIT_JS_IN_COMPONENT | [Y|N] При отмеченной опции js-библиотека popup не будет подключаться в самом компоненте. Если шаблон компонента основан на шаблоне решения "Интернет-магазин" версии 12.5, то использование этой опции приведет к ограничению функционала.
Включить сохранение информации о просмотре товара для старых шаблонов | "DETAIL_SET_VIEWED_IN_COMPONENT" => "N", | [Y|N] Необходимо включить эту опцию, если информация о просмотренных товарах не сохраняется (т.е. когда шаблон компонента не поддерживает функционал просмотренных товаров).
[/di] .
Использовать счетчик просмотров | USE_ELEMENT_COUNTER | [Y|N] При отмеченной опции включается счетчик просмотров элемента.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:catalog",
    "",
Array(
        "TEMPLATE_THEME" => "blue",
        "IBLOCK_TYPE" => "catalog",
        "IBLOCK_ID" => "2",
        "HIDE_NOT_AVAILABLE" => "N",
        "BASKET_URL" => "/personal/cart/",
        "ACTION_VARIABLE" => "action",
        "PRODUCT_ID_VARIABLE" => "id",
        "SECTION_ID_VARIABLE" => "SECTION_ID",
        "PRODUCT_QUANTITY_VARIABLE" => "quantity",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PARTIAL_PRODUCT_PROPERTIES" => "Y",
        "COMMON_SHOW_CLOSE_POPUP" => "N",
        "SEF_MODE" => "Y",
        "SEF_FOLDER" => "/catalog/",
         "AJAX_MODE" => "N",
        "AJAX_OPTION_ADDITIONAL" => "",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_FILTER" => "N",
        "CACHE_GROUPS" => "Y",
        "USE_MAIN_ELEMENT_SECTION" => "Y",
        "SET_LAST_MODIFIED" => "N",
        "SET_TITLE" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "ADD_ELEMENT_CHAIN" => "N",
        "USE_ELEMENT_COUNTER" => "Y",
        "USE_SALE_BESTSELLERS" => "Y",
        "COMPARE_POSITION_FIXED" => "Y",
        "COMPARE_POSITION" => "top left",
        "USE_FILTER" => "Y",
        "FILTER_NAME" => "",
        "FILTER_FIELD_CODE" => array(
            0 => "",
            1 => "",
        ),
        "FILTER_HIDE_ON_MOBILE" => "Y",
        "FILTER_PROPERTY_CODE" => array(
            0 => "",
            1 => "",
        ),
        "FILTER_PRICE_CODE" => array(
            0 => "BASE",
        ),
        "FILTER_OFFERS_FIELD_CODE" => array(
            0 => "PREVIEW_PICTURE",
            1 => "DETAIL_PICTURE",
            2 => "",
        ),
        "FILTER_OFFERS_PROPERTY_CODE" => array(
            0 => "",
            1 => "",
        ),
        "USE_COMMON_SETTINGS_BASKET_POPUP" => "N",
        "TOP_ADD_TO_BASKET_ACTION" => "ADD",
        "SECTION_ADD_TO_BASKET_ACTION" => "ADD",
        "DETAIL_ADD_TO_BASKET_ACTION" => array("BUY"),
        "DETAIL_SHOW_BASIS_PRICE" => "Y",
        "FILTER_VIEW_MODE" => "VERTICAL",
        "USE_REVIEW" => "Y",
        "MESSAGES_PER_PAGE" => "10",
        "USE_CAPTCHA" => "Y",
        "REVIEW_AJAX_POST" => "Y",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "FORUM_ID" => "1",
        "URL_TEMPLATES_READ" => "",
        "SHOW_LINK_TO_FORUM" => "Y",
        "POST_FIRST_MESSAGE" => "N",
        "USE_COMPARE" => "N",
        "PRICE_CODE" => array(
            0 => "BASE",
        ),
        "USE_PRICE_COUNT" => "N",
        "SHOW_PRICE_COUNT" => "1",
        "PRICE_VAT_INCLUDE" => "Y",
        "PRICE_VAT_SHOW_VALUE" => "N",
        "PRODUCT_PROPERTIES" => array(
        ),
        "USE_PRODUCT_QUANTITY" => "Y",
        "CONVERT_CURRENCY" => "Y",
        "CURRENCY_ID" => "RUB",
        "OFFERS_CART_PROPERTIES" => array(
            0 => "COLOR_REF",
            1 => "SIZES_SHOES",
            2 => "SIZES_CLOTHES",
        ),
        "SHOW_TOP_ELEMENTS" => "N",
        "SECTION_COUNT_ELEMENTS" => "N",
        "SECTION_TOP_DEPTH" => "1",
        "SECTIONS_VIEW_MODE" => "TEXT",
        "SECTIONS_SHOW_PARENT_NAME" => "Y",
        "PAGE_ELEMENT_COUNT" => "15",
        "LINE_ELEMENT_COUNT" => "3",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD2" => "id",
        "ELEMENT_SORT_ORDER2" => "desc",
        "LIST_PROPERTY_CODE" => array(
            0 => "NEWPRODUCT",
            1 => "SALELEADER",
            2 => "SPECIALOFFER",
            3 => "",
        ),
        "INCLUDE_SUBSECTIONS" => "Y",
        "LIST_META_KEYWORDS" => "UF_KEYWORDS",
        "LIST_META_DESCRIPTION" => "UF_META_DESCRIPTION",
        "LIST_BROWSER_TITLE" => "UF_BROWSER_TITLE",
        "LIST_OFFERS_FIELD_CODE" => array(
            0 => "NAME",
            1 => "PREVIEW_PICTURE",
            2 => "DETAIL_PICTURE",
            3 => "",
        ),
        "LIST_OFFERS_PROPERTY_CODE" => array(
            0 => "ARTNUMBER",
            1 => "COLOR_REF",
            2 => "SIZES_SHOES",
            3 => "SIZES_CLOTHES",
            4 => "MORE_PHOTO",
            5 => "",
        ),
        "LIST_OFFERS_LIMIT" => "0",
        "SECTION_BACKGROUND_IMAGE" => "-",
        "DETAIL_DETAIL_PICTURE_MODE" => "IMG",
        "DETAIL_ADD_DETAIL_TO_SLIDER" => "N",
        "DETAIL_DISPLAY_PREVIEW_TEXT_MODE" => "E",
        "DETAIL_PROPERTY_CODE" => array(
            0 => "NEWPRODUCT",
            1 => "MANUFACTURER",
            2 => "MATERIAL",
            3 => "",
        ),
        "DETAIL_META_KEYWORDS" => "KEYWORDS",
        "DETAIL_META_DESCRIPTION" => "META_DESCRIPTION",
        "DETAIL_BROWSER_TITLE" => "TITLE",
        "DETAIL_SET_CANONICAL_URL" => "N",
        "DETAIL_CHECK_SECTION_ID_VARIABLE" => "N",
        "SHOW_DEACTIVATED" => "N",
        "DETAIL_OFFERS_FIELD_CODE" => array(
            0 => "NAME",
            1 => "",
        ),
        "DETAIL_OFFERS_PROPERTY_CODE" => array(
            0 => "ARTNUMBER",
            1 => "COLOR_REF",
            2 => "SIZES_SHOES",
            3 => "SIZES_CLOTHES",
            4 => "MORE_PHOTO",
            5 => "",
        ),
        "DETAIL_BACKGROUND_IMAGE" => "-",
        "DETAIL_STRICT_SECTION_CHECK" => "Y",
        "LINK_IBLOCK_TYPE" => "",
        "LINK_IBLOCK_ID" => "",
        "LINK_PROPERTY_SID" => "",
        "LINK_ELEMENTS_URL" => "link.php?PARENT_ELEMENT_ID=#ELEMENT_ID#",
        "USE_ALSO_BUY" => "Y",
        "ALSO_BUY_ELEMENT_COUNT" => "3",
        "ALSO_BUY_MIN_BUYES" => "2",
        "DETAIL_SET_VIEWED_IN_COMPONENT" => "N",
        "DISABLE_INIT_JS_IN_COMPONENT" => "N",
        "USE_GIFTS_DETAIL" => "Y",
        "USE_GIFTS_MAIN_PR_SECTION_LIST" => "Y",
        "USE_GIFTS_SECTION" => "Y",
        "GIFTS_DETAIL_BLOCK_TITLE" => "Выберите один из подарков",
        "GIFTS_DETAIL_HIDE_BLOCK_TITLE" => "N",
        "GIFTS_DETAIL_PAGE_ELEMENT_COUNT" => "3",
        "GIFTS_DETAIL_TEXT_LABEL_GIFT" => "Подарок",
        "GIFTS_MAIN_PRODUCT_DETAIL_BLOCK_TITLE" => "Выберите один из товаров, чтобы получить подарок",
        "GIFTS_MAIN_PRODUCT_DETAIL_HIDE_BLOCK_TITLE" => "N",
        "GIFTS_MAIN_PRODUCT_DETAIL_PAGE_ELEMENT_COUNT" => "3",
        "GIFTS_MESS_BTN_BUY" => "Выбрать",
        "GIFTS_SECTION_LIST_BLOCK_TITLE" => "Подарки к товарам этого раздела",
        "GIFTS_SECTION_LIST_HIDE_BLOCK_TITLE" => "N",
        "GIFTS_SECTION_LIST_PAGE_ELEMENT_COUNT" => "3",
        "GIFTS_SECTION_LIST_TEXT_LABEL_GIFT" => "Подарок",
        "GIFTS_SHOW_DISCOUNT_PERCENT" => "Y",
        "GIFTS_SHOW_IMAGE" => "Y",
        "GIFTS_SHOW_NAME" => "Y",
        "GIFTS_SHOW_OLD_PRICE" => "Y",
        "USE_STORE" => "Y",
        "STORES" => array("1"),
        "USE_MIN_AMOUNT" => "N",
        "USER_FIELDS" => array(""),
        "FIELDS" => array("ADDRESS", "PHONE"),
        "SHOW_EMPTY_STORE" => "Y",
        "SHOW_GENERAL_STORE_INFORMATION" => "N",
        "STORE_PATH" => "/store/#store_id#",
        "MAIN_TITLE" => "Наличие на складах",
        "USE_BIG_DATA" => "Y",
        "BIG_DATA_RCM_TYPE" => "bestsell",
        "OFFERS_SORT_FIELD" => "sort",
        "OFFERS_SORT_ORDER" => "asc",
        "OFFERS_SORT_FIELD2" => "id",
        "OFFERS_SORT_ORDER2" => "desc",
        "PAGER_TEMPLATE" => "arrows",
        "DISPLAY_TOP_PAGER" => "N",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Товары",
        "PAGER_SHOW_ALWAYS" => "N",
        "PAGER_DESC_NUMBERING" => "N",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000000",
        "PAGER_SHOW_ALL" => "N",
        "PAGER_BASE_LINK_ENABLE" => "Y",
        "PAGER_BASE_LINK" => "",
        "PAGER_PARAMS_NAME" => "arrPager",
        "SET_STATUS_404" => "N",
        "SHOW_404" => "N",
        "MESSAGE_404" => "",
        "ADD_PICT_PROP" => "-",
        "LABEL_PROP" => "NEWPRODUCT",
        "PRODUCT_DISPLAY_MODE" => "Y",
        "OFFER_ADD_PICT_PROP" => "MORE_PHOTO",
        "OFFER_TREE_PROPS" => array(
            0 => "COLOR_REF",
            1 => "SIZES_SHOES",
            2 => "SIZES_CLOTHES",
            3 => "",
        ),
        "DETAIL_DISPLAY_NAME" => "Y",
        "DETAIL_ADD_DETAIL_TO_SLIDER" => "N",
        "SHOW_DISCOUNT_PERCENT" => "Y",
        "SHOW_OLD_PRICE" => "Y",
        "DETAIL_SHOW_MAX_QUANTITY" => "N",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_ADD_TO_BASKET" => "В корзину",
        "MESS_BTN_COMPARE" => "Сравнение",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_NOT_AVAILABLE" => "Нет в наличии",
        "TOP_VIEW_MODE" => "SECTION",
        "DETAIL_USE_VOTE_RATING" => "Y",
        "DETAIL_VOTE_DISPLAY_AS_RATING" => "rating",
        "DETAIL_USE_COMMENTS" => "Y",
        "DETAIL_BLOG_USE" => "Y",
        "DETAIL_VK_USE" => "N",
        "DETAIL_FB_USE" => "Y",
        "DETAIL_FB_APP_ID" => "",
        "DETAIL_BRAND_USE" => "N",
        "SIDEBAR_SECTION_SHOW" => "Y",
        "SIDEBAR_DETAIL_SHOW" => "N",
        "SIDEBAR_PATH" => "/examples/index_inc.php",
        "AJAX_OPTION_ADDITIONAL" => "",
        "SEF_URL_TEMPLATES" => array(
            "sections" => "",
            "section" => "#SECTION_CODE#/",
            "element" => "#SECTION_CODE#/#ELEMENT_CODE#/",
            "compare" => "compare/",
        )
        ),
        false
);?>


Поиск по каталогу

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Поиск по каталогу

Каталог::Поиск по каталогу

Описание catalog.search

Компонент выводит результаты поиска по элементам каталога с указанным набором свойств, цен и т.д.. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Каталог > Поиск по каталогу.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфо-блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфо-блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, по элементам которого будет произведен поиск.
Источник данных
По какому полю сортируем элементы ELEMENT_SORT_FIELD Выбирается свойство элементов, по которому следует произвести сортировку:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок сортировки элементов ELEMENT_SORT_ORDER Указывается порядок сортировки элементов:
  • по возрастанию;
  • по убыванию;
  • другое.
Поле для второй сортировки элементов ELEMENT_SORT_FIELD2 Выбирается свойство элементов, по которому будет выполняться вторая сортировка:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок второй сортировки элементов ELEMENT_SORT_ORDER2 Указывается порядок второй сортировки элементов:
  • по возрастанию;
  • по убыванию;
  • другое.
Недоступные товары HIDE_NOT_AVAILABLE Как отображать недоступные товары:
  • Отображать в общем списке
  • Отображать в конце
  • Не отображать
Недоступны товары, для которых количество меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Товар с торговыми предложениями считается доступным, если хоть одно предложение доступно.
Доступность товара не означает, что его можно купить. Для покупки должны быть цены тех типов, по которым клиент может покупать.
Недоступные торговые предложения HIDE_NOT_AVAILABLE_OFFERS Указывается способ отображения недоступных для покупки торговых предложений:
  • не отображать;
  • отображать только с возможностью подписки;
  • отображать все.
Не отображать товары, которых нет на складах | HIDE_NOT_AVAILABLE | [Y|N] При отмеченной опции будут скрыты товары, для которых общее доступное количество меньше либо равно нулю (не остатки по складам), включен количественный учет и не разрешена покупка при отсутствии товара.
Внешний вид
Количество элементов на странице | PAGE_ELEMENT_COUNT | Максимальное число показываемых на одной странице элементов.
Количество элементов выводимых в одной строке таблицы | LINE_ELEMENT_COUNT | Указывается число элементов, которые будут показаны в одной строке таблицы результатов поиска.
Свойства | PROPERTY_CODE | Указываются выводимые свойства товаров.
Поля предложений | OFFERS_FIELD_CODE | Выбираются поля предложений. Можно добавлять свои. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений | OFFERS_PROPERTY_CODE | Указываются свойства предложений. Можно добавлять свои. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
По какому полю сортируем предложения товара | OFFERS_SORT_FIELD | Указывается поле, по которому сортируется весь список предложений товара. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Порядок сортировки предложений товара | OFFERS_SORT_ORDER | Выбирается как сортировать предложения товара: по возрастанию, или по убыванию. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Поле для второй сортировки предложений товара | OFFERS_SORT_FIELD2 | Указывается поле, по которому выполняется вторая сортировка списка предложений товара. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Порядок второй сортировки предложений товара | OFFERS_SORT_ORDER2 | Выбирается порядок второй сортировки предложений товара: по возрастанию, или по убыванию. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Максимальное количество предложений для показа | OFFERS_LIMIT | Указывается максимально допустимое число показываемых торговых предложений (0 - все).
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается адрес страницы содержимого раздела.
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается адрес страницы содержимого элемента раздела.
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается адрес страницы корзины покупателя.
Название переменной, в которой передается действие | ACTION_VARIABLE | Указывается имя переменной, в которой передается действие. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Указывается имя переменной, в которой передается код товара для покупки.
Название переменной, в которой передается количество товара | PRODUCT_QUANTITY_VARIABLE | Указывается имя переменной, в которой передается количество товара.
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Указывается имя переменной, в которой передаются характеристики товара.
Название переменной, в которой передается код группы | SECTION_ID_VARIABLE | Указывается имя переменной, в которой передается код группы.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленной опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Выводить кнопку сравнения | DISPLAY_COMPARE | [Y|N] При отмеченной опции под каждым выводимым элементом будет ссылка Сравнить.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Использовать вывод цен с диапазонами | USE_PRICE_COUNT | [Y|N] При отмеченной опции будут отображаться цены всех типов на товары.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Характеристики товара | PRODUCT_PROPERTIES | Указываются характеристики товара.
Разрешить указание количества товара | USE_PRODUCT_QUANTITY | [Y|N] При установленной опции будет разрешено указание количества товара.
Показывать цены в одной валюте CONVERT_CURRENCY [Y|N] При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах, станет доступным [dw]дополнительное поле[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты в которой будут отображаться цены. Поле видно при отмеченной опции Показывать цены в одной валюте.
[/di]. При выборе этой опции кеш компонента будет автоматически сбрасываться при изменении курсов валют тех товаров, которые показываются компонентом. К примеру, если выбрана конвертация в рубли, а цены в информационном блоке сохранены в евро, то кеш сбросится при изменении курса евро или рубля. Изменения остальных валют на кеш не окажут влияния.
Свойства предложений, добавляемые в корзину | OFFERS_CART_PROPERTIES | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использоать клавишу Ctrl. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Поиск
Искать без учета морфологии (при отсутствии результата поиска) | RESTART | [Y|N] При отмеченной опции с лучае отсутствия результата поиска будут выведены элементы, имеющие морфологические отклонения от поискового запроса.
Отключить обработку слов как логических операторов | NO_WORD_LOGIC | [Y|N] При снятой опции слова логических операторов ("И", "ИЛИ" и пр.) будут интерпретироваться только как лингвистическая часть поискового запроса.
Включить автоопределение раскладки клавиатуры | USE_LANGUAGE_GUESS | [Y|N] При отмеченной опции будет включено автоопределение раскладки клавиатуры.
Искать только в активных по дате документах | CHECK_DATES | [Y|N] При отмеченной опции поиск будет осуществляться только в активных по дате элементах.
При ранжировании результата учитывать заголовки | USE_TITLE_RANK | [Y|N] При отмеченной опции элементы сайта, содержащие в заголовке поисковые слова, будут выведены в начале выдачи результатов.
Использовать сортировку результатов по релевантности | USE_SEARCH_RESULT_ORDER | [Y|N] При отмеченной опции результаты поиска будут выведены в порядке убывания релевантности.
Настройки постраничной навигации
Шаблон постраничной навигации | PAGER_TEMPLATE | Указывается название шаблона постраничной навигации.
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы поиска.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы поиска.
Название категорий | PAGER_TITLE | Указывается название заголовка постраничной навигации.
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции навигация будет отображаться всегда, даже если результаты поиска помещаются на одной странице.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц в секундах для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все элементы каталога..

Пример вызова

<?$APPLICATION->IncludeComponent (
"bitrix:catalog.search",
    "",
    Array(
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "catalog_tovar",
        "IBLOCK_ID" => "8",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD2" => "id",
        "ELEMENT_SORT_ORDER2" => "desc",
        "SECTION_URL" => "",
        "DETAIL_URL" => "",
        "BASKET_URL" => "/personal/basket.php",
        "ACTION_VARIABLE" => "action",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_QUANTITY_VARIABLE" => "quantity",
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "SECTION_ID_VARIABLE" => "SECTION_ID",
        "DISPLAY_COMPARE" => "Y",
        "PAGE_ELEMENT_COUNT" => "30",
        "LINE_ELEMENT_COUNT" => "3",
        "PROPERTY_CODE" => array(),
        "OFFERS_FIELD_CODE" => array(),
        "OFFERS_PROPERTY_CODE" => array(),
        "OFFERS_SORT_FIELD" => "sort",
        "OFFERS_SORT_ORDER" => "asc",
        "OFFERS_SORT_FIELD2" => "id",
        "OFFERS_SORT_ORDER2" => "desc",
        "OFFERS_LIMIT" => "5",
        "PRICE_CODE" => array("BASE"),
        "USE_PRICE_COUNT" => "Y",
        "SHOW_PRICE_COUNT" => "1",
        "PRICE_VAT_INCLUDE" => "Y",
        "USE_PRODUCT_QUANTITY" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "RESTART" => "Y",
        "NO_WORD_LOGIC" => "Y",
        "USE_LANGUAGE_GUESS" => "Y",
        "CHECK_DATES" => "Y",
        "DISPLAY_TOP_PAGER" => "Y",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Товары",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_TEMPLATE" => "",
        "PAGER_DESC_NUMBERING" => "Y",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "HIDE_NOT_AVAILABLE" => "N",
        "CONVERT_CURRENCY" => "Y",
        "CURRENCY_ID" => "RUB",
        "OFFERS_CART_PROPERTIES" => array(),
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y"
    )
);?>


Бренды

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Бренды

Каталог::Бренды

Описание catalog.brandblock

Компонент служит для отображения брендов (или некоторых других данных) на странице с детальной информацией о товаре. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Каталог > Бренды.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Идентификатор инфоблока | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор необходимого информационного блока.
Идентификатор элемента инфоблока | ELEMENT_ID | Указывается код, в котором передается идентификатор элемента. Поле может быть оставлено пустым, если указан Код элемента инфоблока.
Код элемента инфоблока | ELEMENT_CODE | Указывается код элемента. Поле может быть оставлено пустым, если указан Идентификатор элемента инфоблока.
Таблица брендов | PROP_CODE | Указываются свойства типа "Справочник", в которых хранятся данные.
Показывать бренды так же и деактивированных товаров | SHOW_DEACTIVATED | [Y|N] При отмеченной опции будут отображаться и те бренды, которые заданы для деактивированных товаров.
Выводить как список | SINGLE_COMPONENT | [Y|N] При отмеченной опции бренды будут выводится списком в одну строку.
Количество элементов на странице | ELEMENT_COUNT | Указывается количество выводимых брендов.
Внешний вид
Максимальная ширина изображения без описания (пикс) | WIDTH | Указывается максимальная ширина изображения, вставляемого в бренд без описания.
Максимальная высота изображения без описания (пикс) | HEIGHT | Указывается максимальная высота изображения, вставляемого в бренд без описания.
Максимальная ширина изображения с описанием (пикс) | WIDTH_SMALL | Указывается максимальная ширина изображения, вставляемого в бренд с описанием.
Максимальная высота изображения с описанием (пикс) | HEIGHT_SMALL | Указывается максимальная высота изображения, вставляемого в бренд с описанием.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:catalog.brandblock","",
Array(
        "IBLOCK_TYPE" => "books",
        "IBLOCK_ID" => "6",
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "ELEMENT_CODE" => "",
        "PROP_CODE" => "PUBLISH",
        "SHOW_DEACTIVATED" => "N",
        "SINGLE_COMPONENT" => "N",
        "ELEMENT_COUNT" => "6",
        "WIDTH" => "120",
        "HEIGHT" => "45",
        "WIDTH_SMALL" => "80",
        "HEIGHT_SMALL" => "40",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_GROUPS" => "Y"
    ),
false
);?>


Элемент каталога детально

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Элемент каталога детально

Каталог::Элемент каталога детально

Компонент выводит детальную информацию по элементу каталога.

Описание catalog.element

Компонент стандартный, входит в дистрибутив модуля и содержит три шаблона: .default, board и old_version_16 (шаблон .default до версии 17.0).

В визуальном редакторе компонент расположен по пути Контент > Каталог > Элемент каталога детально.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание | Примечание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор необходимого информационного блока.
ID элемента | ELEMENT_ID | Указывается код, в котором передается идентификатор элемента. | При включенном режиме ЧПУ параметры настраиваются в секции Управление адресами страниц.
Код элемента | ELEMENT_CODE | Указывается код элемента.
ID раздела | SECTION_ID | Указывается код, в котором передается идентификатор раздела.
Код раздела | SECTION_CODE | Указывается код раздела.
Источник данных
Показывать деактивированные товары | SHOW_DEACTIVATED | [Y|N] При отмеченной опции будут отображаться не только активные товары, но и неактивные.
Недоступные торговые предложения HIDE_NOT_AVAILABLE_OFFERS Указывается способ отборажения недоступных для покупки торговых предложений:
  • не отображать;
  • отображать только с возможностью подписки;
  • отображать все.
Внешний вид
Свойства PROPERTY_CODE Указываются свойства инфоблока, которые должны быть отражены на вкладке с характеристиками товара.

Внимание! При включенной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di] эта настройка может быть скрыта. В этом случае показ свойств настраивается только в [dw]форме редактирования инфоблока [/dw][di] [image] [/di]. Подробнее о настройке свойств инфоблока в уроке [image] [image] [image].

Поля предложений | OFFERS_FIELD_CODE | Выбираются поля предложений. С помощью клавиши Ctrl можно выбрать несколько значений. | Данные параметры появляются при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений OFFERS_PROPERTY_CODE Указываются свойства предложений, которые должны быть отражены на вкладке с характеристиками товара.

Внимание! При включенной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di] эта настройка может быть скрыта. В этом случае показ свойств настраивается только в [dw]форме редактирования инфоблока [/dw][di] [image] [/di]. Подробнее о настройке свойств инфоблока в уроке [image] [image] [image].

По какому полю сортируем предложения товара OFFERS_SORT_FIELD Указывается поле, по которому сортируется весь список предложений товара:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)

См. примечание в конце страницы.
Порядок сортировки предложений товара | OFFERS_SORT_ORDER | Выбирается как сортировать предложения товара: по возрастанию, или по убыванию.
Поле для второй сортировки предложений товара OFFERS_SORT_FIELD2 Указывается поле, по которому выполняется вторая сортировка списка предложений товара.:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)

См. примечание в конце страницы.
Порядок второй сортировки предложений товара | OFFERS_SORT_ORDER2 | Выбирается направление второй сортировки предложений товара: по возрастанию или по убыванию.
Максимальное количество предложений для показа | OFFERS_LIMIT | Указывается максимальное для вывода на страницу число предложений (0 - все). | Параметр доступен, если опция Включить режим совместимости включена.
Установить фоновую картинку для шаблона из свойства BACKGROUND_IMAGE Указывается свойство, в котором хранится картинка для фона.

Свойство должно быть немножественным типа Файл.

Важно! В шаблоне сайта должна быть реализована поддержка этого функционала: в необходимом вам теге должно быть прописано:
<?=$APPLICATION->ShowProperty("backgroundImage")?>
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения детальной информации элемента. По умолчанию используется синяя схема (blue).
Порядок отображения блоков информации о товаре | PRODUCT_INFO_BLOCK_ORDER | Перетаскивая блоки, определите необходимый вам порядок следования блоков с информацией о товаре.
Порядок отображения блоков покупки товара | PRODUCT_PAY_BLOCK_ORDER | Перетаскивая блоки, определите необходимый вам порядок следования блоков для покупки товара.
Свойства, отображаемые в блоке справа от картинки | MAIN_BLOCK_PROPERTY_CODE | Выберите свойства инфоблока, которые будут отображаться справа от картинки товара. Перечень списка формируется из свойств, указанных в параметре Свойства.
Свойства предложений, отображаемые в блоке справа от картинки | MAIN_BLOCK_OFFERS_PROPERTY_CODE | Выберите свойства предложений, которые будут отображаться справа от картинки товара. Перечень списка формируется из свойств, указанных в параметре Свойства предложений. | Параметр доступен для инфоблока с торговыми предложениями.
Дополнительная картинка основного товара | ADD_PICT_PROP | Задается свойство, в котором хранится дополнительная картинка для основного товара.
Свойство меток товара | LABEL_PROP | Указываются свойство, в котором хранится метка товара (например, новинка).
Свойства меток товара, отображаемые на мобильных устройствах | LABEL_PROP_MOBILE | Выбираются свойства меток (перечень формируется из выбранных в параметре выше свойств), которые будут отображены в списке товаров при просмотре с мобильных устройств.
Расположение меток товара | LABEL_PROP_POSITION | Выберите подходящее место для меток на карточке товара.
Дополнительные картинки предложения | OFFER_ADD_PICT_PROP | Задается свойство, в котором хранится дополнительная картинка для торгового предложения. | Параметры доступны для инфоблока с торговыми предложениями.
Свойства для отбора предложений OFFER_TREE_PROPS Указываются свойства, по значениям которых будут группироваться торговые предложения.

Внимание! При включенной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di] эта настройка может быть скрыта. В этом случае показ свойств настраивается только в [dw]форме редактирования инфоблока [/dw][di] [image] [/di]. Подробнее о настройке свойств инфоблока в уроке [image] [image] [image].

Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции будет отображено название элемента.
Показывать слайдер для товаров SHOW_SLIDER [Y|N] При отмеченной опции для товаров будет использоваться слайдер для показа изображений, станут доступны [dw]дополнительные поля[/dw][di]
Интервал смены слайдов, мс | SLIDER_INTERVAL | Указывается интервал смены слайдов в миллисекундах.
Показывать полосу прогресса | SLIDER_PROGRESS | [Y|N] При отмеченной опции будет отображаться полоса прогресса до начала показа следующего слайда.
[/di].
Режим показа детальной картинки | DETAIL_PICTURE_MODE | Выберите режим показа детальной картинки элемента: обычный, всплывающее окно или лупа.
Добавлять детальную картинку в слайдер | ADD_DETAIL_TO_SLIDER | [Y|N] При отмеченной опции детальная картинка будет отображаться в слайдере вместе с дополнительными изображениями для товара.
Показ описания для анонса | DISPLAY_PREVIEW_TEXT_MODE | Укажите каким образом должен быть выведен текст анонса на детальной странице элемента.
Разрешить оповещения для отсутствующих товаров | PRODUCT_SUBSCRIPTION | [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки.
Показывать процент скидки SHOW_DISCOUNT_PERCENT [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана.Станет доступно [dw]дополнительное поле[/dw][di]
Расположение процента скидки "DISCOUNT_PERCENT_POSITION Выберите подходящее место для отображения процентной скидки на карточке товара.
[/di].
Показывать старую цену | SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Показывать остаток товара SHOW_MAX_QUANTITY Укажите способ отображения остатка товара:
  • не показывать;
  • с отображением реального остатка - в этом случае необходимо настроить параметр [dw]Текст для остатка[/dw][di]
    Текст для остатка MESS_SHOW_MAX_QUANTITY Задается текст для отображения информации о наличии товара.
    [/di] ;
  • с подменой остатка текстом - в этом случае необходимо настроить [dw]параметры[/dw][di]
    Текст для остатка | MESS_SHOW_MAX_QUANTITY | Задается текст для отображения информации о наличии товара. | Доступность данных параметров компонента определяется настройками параметра Показывать остаток товара.
    Значение, от которого происходит подмена | RELATIVE_QUANTITY_FACTOR | Указывается значение, меньше (больше) которого о количестве товара на складе будет отображаться выражение, что товара мало (много).
    Текст для значения больше | MESS_RELATIVE_QUANTITY_MANY | Задается текст, который будет отображаться при наличии товара в количестве большем, чем значение в параметре Значение, от которого происходит подмена.
    Текст для значения меньше | MESS_RELATIVE_QUANTITY_FEW | Задается текст, который будет отображаться при наличии товара в количестве меньшем, чем значение в параметре Значение, от которого происходит подмена..
    [/di] Текст для остатка, Значение, от которого происходит подмена, Текст для значения больше и Текст для значения меньше.
Показывать кнопку продолжения покупок во всплывающих окнах | SHOW_CLOSE_POPUP | [Y|N] При отмеченной опции будет отображаться кнопка Продолжить покупки во всплывающем окне, появляющемся после добавления товара в корзину.
Текст кнопки "Купить" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Добавить в корзину" | MESS_BTN_ADD_TO_BASKET | Задается текст, который должен быть отображен на кнопке добавления в корзину.
Текст кнопки "Уведомить о поступлении" | MESS_BTN_SUBSCRIBE | Задается текст, который должен быть отображен на кнопке для оповещения о поступлении товара.
Текст кнопки "Сравнить" | MESS_BTN_COMPARE | Задается текст, который должен быть отображен на кнопке для сравнения товаров. | Поле доступно, если отмечена опция Разрешить сравнение товаров.
Сообщение об отсутствии товара | MESS_NOT_AVAILABLE | Указывается текст, который будет отображаться при отсутствии товара и невозможности его купить.
Включить рейтинг товара | USE_VOTE_RATING | [Y|N] При установленной опции для товаров будет включен рейтинг.
Включить отзывы о товаре USE_COMMENTS [Y|N] При отмеченной опции доступен [dw]функционал отзывов о товаре[/dw][di]
Использовать комментарии | BLOG_USE | [Y|N] При отмеченной опции отзывы о товаре можно оставлять с помощью комментариев блога.
Использовать Вконтакте | VK_USE | [Y|N] При отмеченной опции отзывы о товаре можно будет оставлять с помощью плагина Вконтакте. Кроме того, при использовании Вконтакте для создания отзывов, становится доступным для настройки параметр DETAIL_VK_API_ID, в котором задается идентификатор приложения Вконтакте (API_ID).
Использовать Facebook* | FB_USE | [Y|N] При отмеченной опции отзывы о товаре можно будет оставлять с помощью плагина Facebook*. Кроме того, при использовании Facebook* для создания отзывов, становится доступным для настройки параметр DETAIL_FB_APP_ID, в котором задается идентификатор приложения (APP_ID). * деятельность организации запрещена в Российской Федерации.
[/di] .
Использовать компонент "Бренды" BRAND_USE [Y|N] При отмеченной опции будет доступен компонент брендов, станет активным [dw]дополнительное поле[/dw][di]
Таблица с брендами BRAND_PROP_CODE Задается свойство типа "Справочник", в котором хранятся данные.
[/di]. 		Параметры доступны только при установленном модуле Highload-блоки.
Текст вкладки "Описание" | MESS_DESCRIPTION_TAB | Указывается заголовок вкладки с описанием товара.
Текст вкладки "Характеристики" | MESS_PROPERTIES_TAB | Указывается заголовок вкладки с характеристиками товара.
Текст вкладки "Комментарии" | MESS_COMMENTS_TAB | Указывается заголовок вкладки для комментариев к товару.
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается путь к странице с содержимым раздела.
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
Название переменной, в которой передается код группы | SECTION_ID_VARIABLE | Задается имя переменной, в которой будет передаваться код группы.
Использовать код группы из переменной, если не задан раздел элемента | CHECK_SECTION_ID_VARIABLE | [Y|N] При отмеченной опции будет использоваться в качестве идентификатора раздела значение переменной, заданной в параметре Название переменной, в которой передается код группы, если для раздела не задан ID или символьный код.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции включается поддержка ЧПУ и становятся доступными [dw]поля настройки ЧПУ[/dw][di]
Правило для обработки | SEF_RULE | Указывается правило обработки вызова страницы. Для создания правила следует использовать шаблоны, доступные по кнопке [...]. |
ID элемента | ELEMENT_ID | Указывается код, в котором передается идентификатор элемента. Можно не задавать, если указан Код элемента. | При отключенном режиме ЧПУ параметры настраиваются в секции Основные параметры.
Код элемента | ELEMENT_CODE | Указывается код элемента. Можно не задавать, если указан ID элемента.
ID раздела | SECTION_ID | Указывается ID раздела инфоблока. Можно не задавать, если указан Код раздела или Путь из символьных кодов раздела.
Код раздела | SECTION_CODE | Указывается символьный код раздела инфоблока. Можно не задавать, если указан ID раздела инфоблока или Путь из символьных кодов раздела.
Путь из символьных кодов раздела | SECTION_CODE_PATH | Задается путь из символьных кодов раздела инфоблока. Можно не задавать, если указан Код раздела или ID раздела инфоблока. |
[/di] .
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлен заголовок элемента.
Устанавливать канонический URL SET_CANONICAL_URL [Y|N] При отмеченной опции страница товара будет помечена как каноническая (т.е. будет считаться основной для поисковых систем среди ее дублей).

Каноническая ссылка строится для основного раздела элемента, а если он не задан, то для раздела с наименьшим идентификатором.
Устанавливать заголовок окна браузера SET_BROWSER_TITLE [Y|N] При отмеченной опции будет установлен заголовок окна браузера по заданному SEO-шаблону META TITLE (см. закладку "SEO" в инфоблоке) или из свойства (станет доступным [dw]дополнительное поле[/dw][di]
Установить заголовок окна браузера из свойства BROWSER_TITLE Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится заголовок окна браузера.
[/di]).
Устанавливать ключевые слова страницы SET_META_KEYWORDS [Y|N] При отмеченной опции будут установлены ключевые слова страницы по заданному SEO-шаблону META KEYWORDS (см. закладку "SEO" в инфоблоке) или из свойства (станет доступным [dw]дополнительное поле[/dw][di]
Установить ключевые слова страницы из свойства META_KEYWORDS Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
[/di]).
Устанавливать описание страницы SET_META_DESCRIPTION [Y|N] При отмеченной опции будет установлено описание страницы по заданному SEO-шаблону META DESCRIPTION (см. закладку "SEO" в инфоблоке) или из свойства (станет доступным [dw]дополнительное поле[/dw][di]
Установить описание страницы из свойства META_DESCRIPTION Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
[/di]).
Устанавливать в заголовках ответа время модификации страницы | SET_LAST_MODIFIED | [Y|N] При отмеченной опции http-ответ сервера будет содержать время последнего изменения страницы (заголовок Last-Modified [image]).
Использовать основной раздел для показа элемента USE_MAIN_ELEMENT_SECTION [Y|N] Если опция отмечена, то при переходе на детальную страницу элемента в адресную строку браузера будет подставляться тот путь, который формируется при просмотре элемента через основной раздел, даже если элемент открыт через другой родительский его раздел.

Если опция не отмечена, про ссылка на детальную страницу элемента формируется с учетом того раздела, через который элемент открыт на просмотр.

Рассмотрим пример, когда опция в настройках отмечена. Допустим, что элемент с символьным кодом marketing привязан к двум разделам с кодами bisness и science соответственно, причем раздел с кодом bisness является основным. В результате, если пользователь пришел в раздел science и кликнул на элемент marketing, то в строке браузера вместо http://mysite.ru/catalog/science/marketing/ будет отображено http://mysite.ru/catalog/bisness/marketing/.
Строгая проверка раздела для показа элемента STRICT_SECTION_CHECK [Y|N] При отмеченной опции будет выполняться строгая проверка принадлежности элемента к разделу. Таким образом, если при просмотре элемента в адресной строке указать неверный раздел, то будет выдана 404-я ошибка.
Если опцию не отмечать, то нужный элемент будет показан в любом случае.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции название или заголовок (если задан в настройках SEO) раздела будет включен в цепочку навигации.
Включать название элемента в цепочку навигации | ADD_ELEMENT_CHAIN | [Y|N] При отмеченной опции название или заголовок (если задан в настройках SEO) элемента будет включен в цепочку навигации.
Отображать описание для каждого торгового предложения SHOW_SKU_DESCRIPTION [Y|N] При отмеченной опции для каждого торгового предложения будет отображено своё описание для анонса и детальное описание в детальной карточке товара, если они заполнены. Если нет - отобразится описание для анонса и детальное описание самого товара.

Параметр доступен с версии 20.5.0 модуля Информационные блоки.
В качестве рейтинга показывать | VOTE_DISPLAY_AS_RATING | Указывается, что показывать в качестве рейтинга: рейтинг (rating) или среднее значение (vote_avg). | Параметр доступен, если отмечена опция Включить рейтинг товара.
Настройки действий
Название переменной, в которой передается действие | ACTION_VARIABLE | Задается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара.
Сравнение товаров
Разрешить сравнение товаров DISPLAY_COMPARE [Y|N] Если опция отмечена, то будет отображаться кнопка для сравнения товаров. Станут доступны [dw]дополнительные поля.[/dw][di]
Путь к странице сравнения | COMPARE_PATH | Путь к странице с компонентом сравнения товаров. Если значение параметра пустое, будет использована текущая страница.
Текст кнопки "Сравнить" | MESS_BIN_COMPARE | Вводится текст, который будет отображаться в кнопке.
[/di]
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Использовать вывод цен с диапазонами | USE_PRICE_COUNT | [Y/N] При отмеченной опции будут отображаться цены всех типов на товары.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Отображать значение НДС | PRICE_VAT_SHOW_VALUE | [Y|N] При отмеченной опции будет отображаться значение НДС.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах, станет активным [dw]дополнительное поле[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты в которой будут отображаться цены.
[/di] . При выборе этой опции кеш компонента будет автоматически сбрасываться при изменении курсов валют тех товаров, что показываются компонентом. К примеру, если выбрана конвертация в рубли, а цены в инфоблоке сохранены в евро, то кеш сбросится при изменении курса евро или рубля. Изменения остальных валют на кеш не окажут влияния.
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Разрешить указание количества товара USE_PRODUCT_QUANTITY [Y|N] При отмеченной опции будет разрешен вывод количества товара, станет доступным [dw]дополнительное поле[/dw][di]
Название переменной, в которой передается количество товара PRODUCT_QUANTITY_VARIABLE Задается имя переменной, в которой будет передаваться количество товара.
[/di].
Добавлять в корзину свойства товаров и предложений ADD_PROPERTIES_TO_BASKET [Y|N] При отмеченной опции становятся доступными [dw]настройки выбора свойств товаров и предложений[/dw][di]
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить добавлять в корзину товары, у которых заполнены не все характеристики | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
Характеристики товара | PRODUCT_PROPERTIES | Указываются характеристики товара.
[/di] для передачи их в корзину и заказ.
Свойства предложений, добавляемые в корзину | OFFERS_CART_PROPERTIES | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использоать клавишу Ctrl. | Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Показывать кнопки добавления в корзину и покупки | ADD_TO_BASKET_ACTION | Выберите какие кнопки должны отображаться: кнопка покупки (BUY) и/или кнопка добавления в корзину (ADD).
Выделять кнопки добавления в корзину и покупки | ADD_TO_BASKET_ACTION_PRIMARY | Выберите какие кнопки должны выделяться: кнопка покупки (BUY) и/или кнопка добавления в корзину (ADD).
Настройки связанных элементов
Тип инфоблока, элементы которого связаны с текущим элементом | LINK_IBLOCK_TYPE | Указывается тип инфоблока, элементы которого связаны с текущим элементом.
ID инфоблока, элементы которого связаны с текущим элементом | LINK_IBLOCK_ID | Указывается идентификатор инфоблока, элементы которого связаны с текущим элементом.
Свойство в котором хранится связь | LINK_PROPERTY_SID | Параметр определяет свойство, в котором хранится связь элементов инфоблоков.
URL на страницу где будут показан список связанных элементов | LINK_ELEMENTS_URL | Указывается адрес страницы, на которой будет показан список связанных элементов.
Настройки "Подарков"
Показывать блок "Подарки" в детальном просмотре USE_GIFTS_DETAIL [Y|N] При отмеченной опции будет отображаться блок с доступными подарками, станут активными [dw]поля настройки.[/dw][di]
Количество элементов в блоке "Подарки" в строке в детальном просмотре | GIFTS_DETAIL_PAGE_ELEMENT_COUNT | Указывается количество элементов, отображаемых на одной странице блока с подарками.
Скрыть заголовок "Подарки" в детальном просмотре | GIFTS_DETAIL_HIDE_BLOCK_TITLE | [Y|N] При отмеченной опции заголовок блока подарков будет скрыт.
Текст заголовка "Подарки" | GIFTS_DETAIL_BLOCK_TITLE | Указывается текст заголовка блока с подарками.
Текст метки "Подарка" в детальном просмотре | GIFTS_DETAIL_TEXT_LABEL_GIFT | Указывается текст метки, которая проставляется для подарка.
Показывать процент скидки | GIFTS_SHOW_DISCOUNT_PERCENT | [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана.
Показывать старую цену | GIFTS_SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Показывать название | GIFTS_SHOW_NAME | [Y|N] При отмеченной опции будет отображено название подарка.
Показывать изображение | GIFTS_SHOW_IMAGE | [Y|N] При отмеченной опции будет показано изображение подарка.
Текст кнопки "Выбрать" | GIFTS_MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Выбрать".
[/di] .
Показывать блок "Товары к подарку" в детальном просмотре USE_GIFTS_MAIN_PR_SECTION_LIST [Y|N] При отмеченной опции будет отображаться блок с товарами, которые нужно купить для получения предложенного подарка. Станут доступны [dw]поля настройки.[/dw][di]
Количество элементов в блоке "Товары к подарку" в строке в детальном просмотре | GIFTS_MAIN_PRODUCT_DETAIL_PAGE_ELEMENT_COUNT | Указывается количество элементов на одной странице блока с товарами, которые нужно купить для получения предложенного подарка.
Скрыть заголовок "Товары к подарку" в детальном просмотре | GIFTS_MAIN_PRODUCT_DETAIL_HIDE_BLOCK_TITLE | [Y|N] При отмеченной опции заголовок блока товаров к подарку будет скрыт.
Текст заголовка "Товары к подарку | GIFTS_MAIN_PRODUCT_DETAIL_BLOCK_TITLE | Указывается заголовок для блока с товарами, которые нужно купить для получения предложенного подарка.
[/di]
Настройки аналитики
Включить отправку данных в электронную торговлю USE_ENHANCED_ECOMMERCE [Y|N] Включение опции. После включения станут доступны ещё [dw]два поля[/dw][di]
Имя контейнера данных | DATA_LAYER_NAME | Указываются свойства инфоблока, которые будут отображены в списке просмотренных товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Свойство брендов | BRAND_PROPERTY | Указывается свойство инфоблока, откуда система должна брать название бренда товара (производитель, марка, модель и т.п.).
[/di]. Требуется дополнительная настройка в Google Analytics Enhanced Ecommerce [image] и/или Яндекс.Метрике [image].

Примечание: Настройка Яндекс метрикой не сложна, и данные в ней отображаются довольно быстро (полчаса-час). У Google используется Google Tag Manager с плагином электронной коммерции, его нужно настроить и добавить на страницу в шаблоне. После настройки на "той" стороне, нужно настроить компоненты для работы с электронной коммерцией и включить эту поле настройки.
Настройки 404 ошибки
Устанавливать статус 404 | SET_STATUS_404 | [Y|N] Опция служит для включения обработки ошибки 404 в компоненте.
Показ специальной страницы SHOW_404 [Y|N] При отмеченной опции будет показана [dw]специальная страница[/dw][di]
Страница для показа (по умолчанию /404.php) FILE_404 Задается адрес страницы, которая будет отображаться при возникновении ошибки 404.
[/di] в случае возникновения ошибки 404, в противном случае - будет отображено [dw]специальное сообщение[/dw][di]
Сообщение для показа (по умолчанию из компонента) MESSAGE_404 Задается сообщение, которое будет показано в случае возникновения ошибки 404. Если ничего не указывать, то будет использоваться стандартное сообщение из компонента.
[/di] .
Специальные настройки
Включить режим совместимости COMPATIBLE_MODE [Y|N] При отмеченной опции будет включен режим совместимости. Опцию необходимо отмечать при наличии старого кастомизированного шаблона компонента версии ниже 16.6.2 модуля Информационные блоки. Станут доступны [dw]дополнительные поля[/dw][di]
Не подключать js-библиотеки в компоненте | DISABLE_INIT_JS_IN_COMPONENT | [Y|N] При отмеченной опции js-библиотека popup не будет подключаться в самом компоненте. Если шаблон компонента основан на шаблоне решения "Интернет-магазин" версии 12.5, то использование этой опции приведет к ограничению функционала.
Включить сохранение информации о просмотре товара для старых шаблонов | SET_VIEWED_IN_COMPONENT | [Y|N] Необходимо включить эту опцию, если информация о просмотренных товарах не сохраняется (т.е. когда шаблон компонента не поддерживает функционал просмотренных товаров).
[/di].
Использовать счетчик просмотров | USE_ELEMENT_COUNTER | [Y|N] При отмеченной опции включается счетчик просмотров элемента.

Примечание: если указаны поля сортировки, отличные от ID, и значения этих полей для торговых предложений разные, то для выбора первого для показа предложения будет выбрано то предложение, которое отсортировано первым.
Если же все значения совпадают, то будет показано то торговое предложение, у которого сортировка участвующих в выборе SKU значений свойств минимальна.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:catalog.element",
    "",
    Array(
        "ACTION_VARIABLE" => "action",
        "ADD_DETAIL_TO_SLIDER" => "N",
        "ADD_ELEMENT_CHAIN" => "N",
        "ADD_PICT_PROP" => "-",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "ADD_TO_BASKET_ACTION" => array("BUY"),
        "ADD_TO_BASKET_ACTION_PRIMARY" => array("BUY"),
        "BACKGROUND_IMAGE" => "-",
        "BASKET_URL" => "/personal/basket.php",
        "BLOG_USE" => "N",
        "BRAND_PROPERTY" => "BRAND_REF",
        "BRAND_PROP_CODE" => array("BRAND_REF", ""),
        "BRAND_USE" => "N",
        "BROWSER_TITLE" => "-",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "36000000",
        "CACHE_TYPE" => "A",
        "CHECK_SECTION_ID_VARIABLE" => "N",
        "COMPARE_PATH" => "",
        "COMPATIBLE_MODE" => "Y",
        "CONVERT_CURRENCY" => "Y",
        "CURRENCY_ID" => "RUB",
        "DATA_LAYER_NAME" => "dataLayer",
        "DETAIL_PICTURE_MODE" => array("POPUP", "MAGNIFIER"),
        "DETAIL_URL" => "",
        "DISABLE_INIT_JS_IN_COMPONENT" => "N",
        "DISCOUNT_PERCENT_POSITION" => "bottom-right",
        "DISPLAY_COMPARE" => "N",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PREVIEW_TEXT_MODE" => "E",
        "ELEMENT_CODE" => "",
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "FB_USE" => "N",
        "FILE_404" => "",
        "GIFTS_DETAIL_BLOCK_TITLE" => "Выберите один из подарков",
        "GIFTS_DETAIL_HIDE_BLOCK_TITLE" => "N",
        "GIFTS_DETAIL_PAGE_ELEMENT_COUNT" => "3",
        "GIFTS_DETAIL_TEXT_LABEL_GIFT" => "Подарок",
        "GIFTS_MAIN_PRODUCT_DETAIL_BLOCK_TITLE" => "Выберите один из товаров, чтобы получить подарок",
        "GIFTS_MAIN_PRODUCT_DETAIL_HIDE_BLOCK_TITLE" => "N",
        "GIFTS_MAIN_PRODUCT_DETAIL_PAGE_ELEMENT_COUNT" => "3",
        "GIFTS_MESS_BTN_BUY" => "Выбрать",
        "GIFTS_SHOW_DISCOUNT_PERCENT" => "Y",
        "GIFTS_SHOW_IMAGE" => "Y",
        "GIFTS_SHOW_NAME" => "Y",
        "GIFTS_SHOW_OLD_PRICE" => "Y",
        "HIDE_NOT_AVAILABLE_OFFERS" => "N",
        "IBLOCK_ID" => "2",
        "IBLOCK_TYPE" => "catalog",
        "LABEL_PROP" => array("NEWPRODUCT"),
        "LABEL_PROP_MOBILE" => array(),
        "LABEL_PROP_POSITION" => "top-left",
        "LINK_ELEMENTS_URL" => "link.php?PARENT_ELEMENT_ID=#ELEMENT_ID#",
        "LINK_IBLOCK_ID" => "",
        "LINK_IBLOCK_TYPE" => "",
        "LINK_PROPERTY_SID" => "",
        "MAIN_BLOCK_OFFERS_PROPERTY_CODE" => array("COLOR_REF"),
        "MAIN_BLOCK_PROPERTY_CODE" => array("MATERIAL"),
        "MESSAGE_404" => "",
        "MESS_BTN_ADD_TO_BASKET" => "В корзину",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_COMPARE" => "Сравнить",
        "MESS_BTN_SUBSCRIBE" => "Подписаться",
        "MESS_COMMENTS_TAB" => "Комментарии",
        "MESS_DESCRIPTION_TAB" => "Описание",
        "MESS_NOT_AVAILABLE" => "Нет в наличии",
        "MESS_PROPERTIES_TAB" => "Характеристики",
        "MESS_RELATIVE_QUANTITY_FEW" => "мало",
        "MESS_RELATIVE_QUANTITY_MANY" => "много",
        "MESS_SHOW_MAX_QUANTITY" => "Наличие",
        "META_DESCRIPTION" => "-",
        "META_KEYWORDS" => "-",
        "OFFERS_CART_PROPERTIES" => array("ARTNUMBER", "COLOR_REF", "SIZES_SHOES", "SIZES_CLOTHES"),
        "OFFERS_FIELD_CODE" => array("", ""),
        "OFFERS_LIMIT" => "0",
        "OFFERS_PROPERTY_CODE" => array("COLOR_REF", "SIZES_SHOES", "SIZES_CLOTHES", ""),
        "OFFERS_SORT_FIELD" => "sort",
        "OFFERS_SORT_FIELD2" => "id",
        "OFFERS_SORT_ORDER" => "asc",
        "OFFERS_SORT_ORDER2" => "desc",
        "OFFER_ADD_PICT_PROP" => "MORE_PHOTO",
        "OFFER_TREE_PROPS" => array("COLOR_REF", "SIZES_SHOES", "SIZES_CLOTHES"),
        "PARTIAL_PRODUCT_PROPERTIES" => "Y",
        "PRICE_CODE" => array("BASE"),
        "PRICE_VAT_INCLUDE" => "Y",
        "PRICE_VAT_SHOW_VALUE" => "N",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_INFO_BLOCK_ORDER" => "sku,props",
        "PRODUCT_PAY_BLOCK_ORDER" => "rating,price,quantityLimit,quantity,buttons",
        "PRODUCT_PROPERTIES" => array("NEWPRODUCT", "SALELEADER", "MATERIAL"),
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PRODUCT_QUANTITY_VARIABLE" => "",
        "PRODUCT_SUBSCRIPTION" => "Y",
        "PROPERTY_CODE" => array("MANUFACTURER", "MATERIAL", ""),
        "RELATIVE_QUANTITY_FACTOR" => "5",
        "SECTION_CODE" => "",
        "SECTION_CODE_PATH" => "",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "SECTION_ID_VARIABLE" => "SECTION_ID",
        "SECTION_URL" => "",
        "SEF_MODE" => "N",
        "SEF_RULE" => "",
        "SET_BROWSER_TITLE" => "Y",
        "SET_CANONICAL_URL" => "N",
        "SET_LAST_MODIFIED" => "N",
        "SET_META_DESCRIPTION" => "Y",
        "SET_META_KEYWORDS" => "Y",
        "SET_STATUS_404" => "N",
        "SET_TITLE" => "Y",
        "SET_VIEWED_IN_COMPONENT" => "N",
        "SHOW_404" => "N",
        "SHOW_CLOSE_POPUP" => "N",
        "SHOW_DEACTIVATED" => "N",
        "SHOW_DISCOUNT_PERCENT" => "Y",
        "SHOW_MAX_QUANTITY" => "M",
        "SHOW_OLD_PRICE" => "N",
        "SHOW_PRICE_COUNT" => "1",
        "SHOW_SLIDER" => "Y",
        "SLIDER_INTERVAL" => "5000",
        "SLIDER_PROGRESS" => "N",
        "STRICT_SECTION_CHECK" => "N",
        "TEMPLATE_THEME" => "blue",
        "USE_COMMENTS" => "Y",
        "USE_ELEMENT_COUNTER" => "Y",
        "USE_ENHANCED_ECOMMERCE" => "Y",
        "USE_GIFTS_DETAIL" => "Y",
        "USE_GIFTS_MAIN_PR_SECTION_LIST" => "Y",
        "USE_MAIN_ELEMENT_SECTION" => "N",
        "USE_PRICE_COUNT" => "N",
        "USE_PRODUCT_QUANTITY" => "Y",
        "USE_VOTE_RATING" => "Y",
        "VK_USE" => "N",
        "VOTE_DISPLAY_AS_RATING" => "rating"
    )
);?>


Список сравниваемых элементов каталога

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Список сравниваемых элементов каталога

Каталог::Список сравниваемых элементов каталога

Описание catalog.compare.list

Компонент выводит список сравниваемых элементов каталога в виде небольшой таблицы. Он предоставляет возможность удаления элемента из списка и возможность сравнения элементов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Каталог > Список сравниваемых элементов каталога.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, элементы которого будут отфильтрованы.
Внешний вид
Отображать список сравнения поверх страницы | POSITION_FIXED | [Y|N] При отмеченной опции список сравнения будет отображен поверх страницы.
Положение на странице | POSITION | Выберите положение списка сравнения на странице: вверху слева, вверху справа, внизу слева или внизу справа.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Дополнительные настройки
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
URL страницы с таблицей сравнения | COMPARE_URL | Указывается путь к странице с таблицей сравнения элементов текущего инфоблока.
Уникальное имя для списка сравнения | NAME | Задается имя переменной, в которой передается список сравниваемых элементов. По умолчанию CATALOG_COMPARE_LIST.
Настройки действий
Название переменной, в которой передается действие | ACTION_VARIABLE | Задается имя переменной, в которой передается действие. Значение поля по умолчанию action. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:catalog.compare.list","",
Array(
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "books",
        "IBLOCK_ID" => "6",
        "POSITION_FIXED" => "Y",
        "POSITION" => "top left",
        "DETAIL_URL" => "",
        "COMPARE_URL" => "compare.php",
        "NAME" => "CATALOG_COMPARE_LIST",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "ACTION_VARIABLE" => "action",
        "PRODUCT_ID_VARIABLE" => "id"
    )
);?>


Таблица сравнения

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Таблица сравнения

Каталог::Таблица сравнения

Описание catalog.compare.result

Компонент выводит таблицу сравниваемых элементов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Каталог > Таблица сравнения.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Источник данных
Уникальное имя для списка сравнения | NAME | Задается имя переменной, в которой передается список сравниваемых элементов. По умолчанию CATALOG_COMPARE_LIST.
Тип инфо-блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфо-блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, элементы которого будут отфильтрованы.
Поля FIELD_CODE Указываются поля элементов (товаров), по которым будет происходить сравнение в таблице сравнения. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания полей в строках (т.е. если задан пустой массив), будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства инфоблока, которые будут отображены при показе в качестве полей фильтра. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках, свойства выведены не будут.
Поля предложений | OFFERS_FIELD_CODE | Выбираются поля предложений. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений | OFFERS_PROPERTY_CODE | Указываются свойства предложений. Можно добавлять свои. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
По какому полю сортируем элементы ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • CATALOG_AVAILABLE – по доступности к покупке.
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок сортировки элементов ELEMENT_SORT_ORDER Задается порядок сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.
Внешний вид
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения таблицы сравнения. По умолчанию используется синяя схема (blue).
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Дополнительные настройки
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
Название переменной, в которой передается код группы | SECTION_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор раздела.
Выводить список элементов инфоблока | DISPLAY_ELEMENT_SELECT_BOX | [Y|N] При отмеченной опции после таблицы будет добавлен список элементов текущего инфоблока, которые можно добавить в таблицу.
По какому полю сортируем список элементов ELEMENT_SORT_FIELD_BOX Указывается поле, по которому будет происходить сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • CATALOG_AVAILABLE – по доступности к покупке.
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок сортировки списка элементов ELEMENT_SORT_ORDER_BOX Задается порядок сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.
Поле для второй сортировки списка элементов ELEMENT_SORT_FIELD_BOX2 Указывается поле, по которому будет происходить сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • CATALOG_AVAILABLE – по доступности к покупке.
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок второй сортировки списка элементов ELEMENT_SORT_ORDER_BOX2 Задается порядок сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.
Не отображать недоступные товары | HIDE_NOT_AVAILABLE | [Y|N] При отмеченной опции будут скрыты товары, для которых общее количество на складах меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Настройки действий
Название переменной, в которой передается действие | ACTION_VARIABLE | Указывается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию ACTION. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара для покупки.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Использовать вывод цен с диапазонами | USE_PRICE_COUNT | [Y/N] При отмеченной опции будут отображаться цены всех типов на товары.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах; станет доступным [dw]дополнительное поле[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты, в которой будут отображаться цены.
[/di]. При выборе этой опции кеш компонента будет автоматически сбрасываться при изменении курсов валют тех товаров, что показываются компонентом. К примеру, если выбрана конвертация в рубли, а цены в инфоблоке сохранены в евро, то кеш сбросится при изменении курса евро или рубля. Изменения остальных валют на кеш не окажут влияния.
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.

Пример вызова

<?$APPLICATION->IncludeComponent (
"bitrix:catalog.compare.result",
    "",
    Array(
        "AJAX_MODE" => "Y",
        "NAME" => "CATALOG_COMPARE_LIST",
        "IBLOCK_TYPE" => "news",
        "IBLOCK_ID" => "2",
        "FIELD_CODE" => array(),
        "PROPERTY_CODE" => array(),
        "OFFERS_FIELD_CODE" => array(),
        "OFFERS_PROPERTY_CODE" => array(),
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_ORDER" => "asc",
        "DETAIL_URL" => "",
        "BASKET_URL" => "/personal/basket.php",
        "ACTION_VARIABLE" => "action",
        "PRODUCT_ID_VARIABLE" => "id",
        "SECTION_ID_VARIABLE" => "SECTION_ID",
        "PRICE_CODE" => array(),
        "USE_PRICE_COUNT" => "Y",
        "SHOW_PRICE_COUNT" => "1",
        "PRICE_VAT_INCLUDE" => "Y",
        "DISPLAY_ELEMENT_SELECT_BOX" => "Y",
        "ELEMENT_SORT_FIELD_BOX" => "name",
        "ELEMENT_SORT_ORDER_BOX" => "asc",
        "ELEMENT_SORT_FIELD_BOX2" => "id",
        "ELEMENT_SORT_ORDER_BOX2" => "desc",
        "HIDE_NOT_AVAILABLE" => "N",
        "AJAX_OPTION_SHADOW" => "Y",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y",
        "CONVERT_CURRENCY" => "Y",
        "CURRENCY_ID" => "RUB",
        "TEMPLATE_THEME" => "blue",
    )
);?>


Умный фильтр

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Умный фильтр

Каталог::Умный фильтр

Компонент подготавливает фильтр для выборки из инфоблока и выводит форму фильтра для фильтрации элементов.

Описание catalog.smart.filter

Компонент должен подключаться перед компонентом вывода элементов каталога, иначе список элементов фильтроваться не будет. Компонент стандартный, входит в дистрибутив модуля и содержит три шаблона: .default, visual_horizontal и visual_vertical. (Последние два шаблона не поддерживаются, остались для сохранения совместимости.)

В визуальном редакторе компонент расположен по пути Контент > Каталог > Умный фильтр.

Компонент относится к модулю Информационные блоки.

Внимание! В префильтре нельзя использовать вызов CIBlockElement::SubQuery [image].

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, элементы которого будут отфильтрованы.
ID раздела инфоблока SECTION_ID Указывается идентификатор раздела, фильтрация элементов которого должна выполняться. Можно не указывать, если задан Код раздела.

Примечание: при включенном режиме ЧПУ параметр настраивается в секции Управление адресами страниц.
Код раздела SECTION_CODE Указывается код раздела, фильтрация элементов которого должна выполняться. Можно не указывать, если задан ID раздела инфоблока.

Примечание: при включенном режиме ЧПУ параметр настраивается в секции Управление адресами страниц.
Имя входящего массива для дополнительной фильтрации элементов | PREFILTER_NAME | Задается имя переменной, в которую передается массив параметров из дополнительного фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Имя выходящего массива для фильтрации | FILTER_NAME | Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Не отображать недоступные товары | HIDE_NOT_AVAILABLE | [Y|N] При отмеченной опции будут скрыты товары, для которых общее количество на складах меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Внешний вид
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения фильтра. По умолчанию используется синяя схема (blue).
Вид отображения умного фильтра | FILTER_VIEW_MODE | Задается вид отображения умного фильтра: вертикальный (VERTICAL) или горизонтальный (HORIZONTAL).
Позиция для отображения всплывающего блока с информацией о фильтрации | POPUP_POSITION | Задается позиция отображения всплывающего блока: слева (left) или справа (right).
Показывать количество | DISPLAY_ELEMENT_COUNT | [Y|N] При отмеченной опции в всплывающем блоке будет показано количество отобранных элементов в соответствии с условиями фильтрации.
Управление адресами страниц
Включить поддержку ЧПУ | SEF_MODE | [Y|N] При отмеченной опции включается поддержка ЧПУ и становятся доступными поля настройки ЧПУ.
Правило для обработки SEF_RULE Указывается правило обработки вызова умного фильтра. Для создания правила следует использовать шаблоны, доступные по кнопке [...].

Например, компонент умного фильтра расположен на странице /examples/books/section.php, тогда правило может быть задано следующим образом:
/examples/books/#SECTION_ID#/filter/#SMART_FILTER_PATH#/apply/
где /filter/, /apply/ - выражения-ограничители, обязательно присутствующие в правиле (могут быть заменены на любые другие слова).
ID раздела инфоблока SECTION_ID Указывается ID раздела инфоблока. Можно не задавать, если указан Код раздела или Путь из символьных кодов раздела.

Примечание: при отключенном режиме ЧПУ параметр настраивается в секции Источник данных.
Код раздела SECTION_CODE Указывается символьный код раздела инфоблока. Можно не задавать, если указан ID раздела инфоблока или Путь из символьных кодов раздела.

Примечание: при отключенном режиме ЧПУ параметр настраивается в секции Источник данных.
Путь из символьных кодов раздела | SECTION_CODE_PATH | Задается путь из символьных кодов раздела инфоблока. Можно не задавать, если указан Код раздела или ID раздела инфоблока.
Блок ЧПУ умного фильтра | SMART_FILTER_PATH | Задается блок с параметрами фильтрации. По умолчанию подставляется значение ={$_REQUEST["SMART_FILTER_PATH"]}.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Сохранять установки фильтра в сессии пользователя | SAVE_IN_SESSION | [Y|N] При отмеченной опции установки фильтра будут сохраняться в сессии пользователя.
Имя массива с переменными для построения ссылок в постраничной навигации | PAGER_PARAMS_NAME | Задается имя переменной, в которой передается массив с переменными для построения ссылок компонентом постраничной навигации.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для фильтрации элементов.
Показывать цены в одной валюте CONVERT_CURRENCY [Y|N] При отмеченной опции цены в фильтре будут отображаться в одной валюте, даже если для товаров они будут заданы в разных валютах. Будет доступно для заполнения [dw]дополнительное поле.[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты, в которой будут отображаться цены.
[/di]

Примечание: конвертация цен в умном фильтре работает только при созданном фасетном индексе.
Поддержка Яндекс Островов (экспорт фильтра в XML)
Включить поддержку Яндекс Островов | XML_EXPORT | [Y|N] При отмеченной опции будет включена поддержка Яндекс Островов.
Заголовок | SECTION_TITLE | Указывается поле, которое будет использоваться в качестве заголовка раздела.
Описание | SECTION_DESCRIPTION | Задается поле, которое будет использоваться в качестве описания раздела.

Примечание: в компоненте имеется специальный параметр SHOW_ALL_WO_SECTION, принимающий значения Y|N. Если задано значение Y, то будут отображены все элементы инфоблока, если не указан раздел.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:catalog.smart.filter",
    ".default",
    array(
        "COMPONENT_TEMPLATE" => ".default",
        "IBLOCK_TYPE" => "books",
        "IBLOCK_ID" => "6",
        "SECTION_ID" => "10",
        "SECTION_CODE" => "",
        "FILTER_NAME" => "arrFilter",
        "HIDE_NOT_AVAILABLE" => "N",
        "TEMPLATE_THEME" => "blue",
        "FILTER_VIEW_MODE" => "horizontal",
        "DISPLAY_ELEMENT_COUNT" => "Y",
        "SEF_MODE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_GROUPS" => "Y",
        "SAVE_IN_SESSION" => "N",
        "INSTANT_RELOAD" => "Y",
        "PAGER_PARAMS_NAME" => "arrPager",
        "PRICE_CODE" => array(
            0 => "BASE",
        ),
        "CONVERT_CURRENCY" => "Y",
        "XML_EXPORT" => "N",
        "SECTION_TITLE" => "-",
        "SECTION_DESCRIPTION" => "-",
        "POPUP_POSITION" => "left",
        "SEF_RULE" => "/examples/books/#SECTION_ID#/filter/#SMART_FILTER_PATH#/apply/",
        "SECTION_CODE_PATH" => "",
        "SMART_FILTER_PATH" => $_REQUEST["SMART_FILTER_PATH"],
        "CURRENCY_ID" => "RUB"
    ),
    false
);?>

Смотрите также

  • Настройка отображения свойств в умном фильтре


Фильтр по элементам

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Фильтр по элементам

Каталог::Фильтр по элементам

Описание catalog.filter

Компонент выводит форму фильтра для фильтрации элементов информационых блоков. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Каталог > Фильтр по элементам.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфо-блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфо-блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, элементы которого будут отфильтрованы.
Имя выходящего массива для фильтрации | FILTER_NAME | Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Поля FIELD_CODE Указываются дополнительные поля элементов инфоблока, по которым будет возможна фильтрация. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания полей в строках (т.е. если задан пустой массив), будут выведены поля по умолчанию.
Свойства PROPERTY_CODE Указываются свойства инфоблока, которые будут отображены при показе в качестве полей фильтра. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках, свойства выведены не будут.

Значения свойств типа "Список" отображаются в фильтре в соответствии с настройками, заданными в форме редактирования самого свойства (поле "Внешний вид").
Поля предложений | OFFERS_FIELD_CODE | Выбираются поля предложений. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений | OFFERS_PROPERTY_CODE | Указываются свойства предложений. Можно добавлять свои. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Внешний вид
Высота списков множественного выбора | LIST_HEIGHT | Указывается высота множественных списков выбора, отображаемых в фильтре.
Ширина однострочных текстовых полей ввода | TEXT_WIDTH | Указывается ширина текстового поля ввода в форме фильтра.
Ширина полей ввода для числовых интервалов | NUMBER_WIDTH | Указывается ширина полей ввода для числовых интервалов в форме фильтра.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Сохранять установки фильтра в сессии пользователя | SAVE_IN_SESSION | [Y|N] При отмеченной опции установки фильтра будут сохраняться в сессии пользователя.
Имя массива с переменными для построения ссылок в постраничной навигации | PAGER_PARAMS_NAME | Задается имя переменной, в которой передается массив с переменными для построения ссылок компонентом постраничной навигации.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.

Пример вызова

<?$APPLICATION->IncludeComponent (
"bitrix:catalog.filter",
    "",
    Array(
        "IBLOCK_TYPE" => "news",
        "IBLOCK_ID" => "2",
        "FILTER_NAME" => "arrFilter",
        "FIELD_CODE" => array(),
        "PROPERTY_CODE" => array(),
        "OFFERS_FIELD_CODE" => array(),
        "OFFERS_PROPERTY_CODE" => array(),
        "PRICE_CODE" => array(),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_GROUPS" => "Y",
        "LIST_HEIGHT" => "5",
        "TEXT_WIDTH" => "20",
        "NUMBER_WIDTH" => "5",
        "SAVE_IN_SESSION" => "N",
        "PAGER_PARAMS_NAME" => "arrPager"
    ),
false
);?>


Список информационных блоков заданного типа

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Список информационных блоков заданного типа

Каталог::Список информационных блоков заданного типа

Компонент выводит список всех информационных блоков заданного типа. Компонент стандартный и входит в дистрибутив модуля.

Описание catalog.main

В визуальном редакторе компонент расположен по пути Контент > Каталог > Список информационных блоков заданного типа.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Шаблоны ссылок
URL, ведущий на страницу со списком секций | IBLOCK_URL | Указывается путь к странице со списком секций (разделов инфоблока).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:catalog.main","",Array(
        "IBLOCK_TYPE" => "books",
        "IBLOCK_URL" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y"
    ),
);?>


top элементов каталога

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>top элементов каталога

Каталог::top элементов каталога

Компонент выводит в таблице top элементов из всех разделов в соответствии с заданной сортировкой (используется как правило на главной странице сайта).

Описание catalog.top

Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Каталог > Top элементов каталога.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание | Примечание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, из которого будет выводиться top элементов сгруппированных по разделам.
Источник данных
Имя массива со значениями фильтра для фильтрации элементов | FILTER_NAME | Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Фильтр товаров CUSTOM_FILTER В данном поле настраиваются условия отбора товаров для показа. Выбор каждого условия осуществляется из выпадающего списка, доступного по ссылке Добавить условие. Для выбранного поля/свойства товара задается соответствие некоторому значению. Допускается создание нескольких условий и использование между ними как логики "И", так и логики "ИЛИ".

Недоступные товары HIDE_NOT_AVAILABLE Указывается способ отборажения недоступных для покупки товаров:
  • не отображать;
  • отображать в конце;
  • отображать в общем списке.
Примечание: недоступные для покупки товары - это товары, для которых количество меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Недоступные торговые предложения HIDE_NOT_AVAILABLE_OFFERS Указывается способ отборажения недоступных для покупки торговых предложений:
  • не отображать;
  • отображать только с возможностью подписки;
  • отображать все.
Настройки сортировки
По какому полю сортируем элементы ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок сортировки элементов ELEMENT_SORT_ORDER Задается порядок сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.
Поле для второй сортировки элементов ELEMENT_SORT_FIELD2 Указывается поле, по которому будет происходить вторая сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок второй сортировки элементов ELEMENT_SORT_ORDER2 Задается порядок второй сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.
По какому полю сортируем предложения товара OFFERS_SORT_FIELD Указывается поле, по которому сортируется весь список предложений товара.

См. примечание в конце страницы.
Данные параметры появляются при настройке компонента на инфоблок с поддержкой SKU.
Порядок сортировки предложений товара | OFFERS_SORT_ORDER | Выбирается как сортировать предложения товара: по возрастанию, или по убыванию.
Поле для второй сортировки предложений товара OFFERS_SORT_FIELD2 Указывается поле, по которому выполняется вторая сортировка списка предложений товара.

См. примечание в конце страницы.
Порядок второй сортировки предложений товара | OFFERS_SORT_ORDER2 | Выбирается направление второй сортировки предложений товара: по возрастанию, или по убыванию.
Внешний вид
Свойства PROPERTY_CODE Указываются свойства инфоблока, которые будут отображены при показе элементов в таблице. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.

Внимание! При включенной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di] эта настройка может быть скрыта. В этом случае показ свойств настраивается только в [dw]форме редактирования инфоблока [/dw][di] [image] [/di]. Подробнее о настройке свойств инфоблока в уроке [image] [image] [image].

Свойства товаров, отображаемые на мобильных устройствах | PROPERTY_CODE_MOBILE | Выбираются свойства инфоблока (перечень формируется из выбранных в параметре выше свойств), которые будут отображены в списке товаров при просмотре с мобильных устройств.
Поля предложений | OFFERS_FIELD_CODE | Выбираются поля предложений. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений OFFERS_PROPERTY_CODE Указываются свойства предложений. Можно добавлять свои. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.

Внимание! При включенной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di] эта настройка может быть скрыта. В этом случае показ свойств настраивается только в [dw]форме редактирования инфоблока [/dw][di] [image] [/di]. Подробнее о настройке свойств инфоблока в уроке [image] [image] [image].

Максимальное количество предложений для показа | OFFERS_LIMIT | Указывается максимальное для вывода на страницу число предложений (0 - все). | Параметр доступен, если опция Включить режим совместимости включена.
Показ элементов | VIEW_MODE | Определяется способ отображения элементов: баннер (BANNER), слайдер (SLIDER) или список (SECTION).
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения top'а элементов. По умолчанию используется синяя схема (blue).
Схема отображения | PRODUCT_DISPLAY_MODE | Задается режим отображения товаров: простой (N) или расширенный (Y). Параметр доступен для инфоблока с торговыми предложениями.
Дополнительная картинка основного товара | ADD_PICT_PROP | Задается свойство, в котором хранится дополнительная картинка для основного товара.
Свойство меток товара | LABEL_PROP | Указываются свойство, в котором хранится метка товара (например, новинка).
Свойства меток товара, отображаемые на мобильных устройствах | LABEL_PROP_MOBILE | Выбираются свойства меток (перечень формируется из выбранных в параметре выше свойств), которые будут отображены в списке товаров при просмотре с мобильных устройств.
Дополнительные картинки предложения | OFFER_ADD_PICT_PROP | Задается свойство, в котором хранится дополнительная картинка для торгового предложения. Параметр доступен для инфоблока с торговыми предложениями.. | Данные настройки доступны, если в параметре Схема отображения выбрано значение расширенный.
Свойства для отбора предложений OFFER_TREE_PROPS Указываются свойства, по значениям которых будут группироваться торговые предложения. Параметр доступен для инфоблока с торговыми предложениями.

Внимание! При включенной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di] эта настройка может быть скрыта. В этом случае показ свойств настраивается только в [dw]форме редактирования инфоблока [/dw][di] [image] [/di]. Подробнее о настройке свойств инфоблока в уроке [image] [image] [image].

Расположение меток товара | LABEL_PROP_POSITION | Выберите подходящее место для меток на карточке товара.
Показывать процент скидки | SHOW_DISCOUNT_PERCENT | [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана.
Показывать старую цену | SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Показывать остаток товара SHOW_MAX_QUANTITY Укажите способ отображения остатка товара:
  • не показывать;
  • с отображением реального остатка - в этом случае необходимо настроить параметр Текст для остатка;
  • с подменой остатка текстом - в этом случае необходимо настроить параметры Текст для остатка, Значение, от которого происходит подмена, Текст для значения больше и Текст для значения меньше.
Текст для остатка | MESS_SHOW_MAX_QUANTITY | Задается текст для отображения информации о наличии товара. | Доступность данных параметров компонента определяется настройками параметра Показывать остаток товара.
Значение, от которого происходит подмена | RELATIVE_QUANTITY_FACTOR | Указывается значение, меньше (больше) которого о количестве товара на складе будет отображаться выражение, что товара мало (много).
Текст для значения больше | MESS_RELATIVE_QUANTITY_MANY | Задается текст, который будет отображаться при наличии товара в количестве большем, чем значение в параметре Значение, от которого происходит подмена.
Текст для значения меньше | MESS_RELATIVE_QUANTITY_FEW | Задается текст, который будет отображаться при наличии товара в количестве меньшем, чем значение в параметре Значение, от которого происходит подмена..
Показывать кнопку продолжения покупок во всплывающих окнах | SHOW_CLOSE_POPUP | [Y|N] При отмеченной опции будет отображаться кнопка Продолжить покупки во всплывающем окне, появляющемся после добавления товара в корзину.
Разрешить оповещения для отсутствующих товаров | PRODUCT_SUBSCRIPTION | [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки. | Данные параметры доступны, если в параметре Показ элементов выбрано значение список.
Расположение процента скидки | "DISCOUNT_PERCENT_POSITION | Выберите подходящее место для отображения процентной скидки на карточке товара.
Вариант отображения товаров PRODUCT_ROW_VARIANTS В правой части поля выберите подходящий вам вариант отображения одной строки товаров на странице и перетащите его в левую часть. Аналогичным образом настройте остальные строки для формирования таблицы товаров.

Количество товаров на странице | ELEMENT_COUNT | Отображается информация по количеству товаров на странице в соответствии с выбранным вариантом отображения товаров.
Выделять товары в списке ENLARGE_PRODUCT Выберите способ выделения товаров в списке:
  • по выбранному шаблону (строго) - товар будет выделятся строго по настроенному варианту отображения товаров;
  • по свойству, подгонять по шаблону (в этом случае возможно изменение сортировки элементов) - в списке будет выделяться тот товар, для которого заполнено указанное в параметре Выделять по выбранному свойству свойство.
Примечание: выделение товаров осуществляется в том случае, если для показа списка товаров выбран хотя бы один вариант вида:

Выделять по выбранному свойству | ENLARGE_PROP | Указывается то свойство товара, при наличии которого товар будет выделен в списке просмотренных (если позволяет вариант отображения товаров, см. поле Вариант отображения товаров). Параметр доступен, если в параметре Выделять товары в списке указано значение по свойству (подгонять по шаблону).
Порядок отображения блоков товара PRODUCT_BLOCKS_ORDER Перетаскивая блоки, определите необходимый вам порядок следования блоков товара.

Показывать слайдер для товаров SHOW_SLIDER [Y|N] При отмеченной опции для товаров будет использоваться слайдер для показа изображений; станет доступным [dw]дополнительное окно[/dw][di]
Интервал смены слайдов, мс | SLIDER_INTERVAL | Указывается интервал смены слайдов в миллисекундах. Параметр настраивается, если отмечена опция Показывать слайдер для товаров.
Показывать полосу прогресса | SLIDER_PROGRESS | [Y|N] При отмеченной опции будет отображаться полоса прогресса до начала показа следующего слайда.
[/di]. 		Данные параметры доступны, если в параметре Показ элементов выбрано значение баннер или слайдер.
Время показа одного слайда, сек (0 - выключить автоматическую смену слайдов) | ROTATE_TIMER | Указывается время показа одного слайда (в сек.). Используется для автоматической прокрутки слайдов.
Показывать навигацию по слайдам | SHOW_PAGINATION | [Y|N] При отмеченной опции будет доступна навигация по слайдам.
Текст кнопки "Купить" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Добавить в корзину" | MESS_BTN_ADD_TO_BASKET | Задается текст, который должен быть отображен на кнопке добавления в корзину.
Текст кнопки "Сравнить" | MESS_BTN_COMPARE | Задается текст, который должен быть отображен на кнопке "Сравнить".
Текст кнопки "Подробнее" | MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Сообщение об отсутствии товара | MESS_NOT_AVAILABLE | Указывается текст, который будет отображаться при отсутствии товара и невозможности его купить.
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается путь к странице с детальным содержимым раздела.
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
Название переменной, в которой передается количество товара | PRODUCT_QUANTITY_VARIABLE | Задается имя переменной, в которой будет передаваться количество товара.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции включается поддержка ЧПУ и становятся доступными [dw]поля настройки ЧПУ.[/dw][di]
Правило для обработки SEF_RULE Указывается правило обработки вызова страницы. Для создания правила следует использовать шаблоны, доступные по кнопке [...].
[/di]
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Кешировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Включить режим совместимости | COMPATIBLE_MODE | [Y|N] При отмеченной опции будет включен режим совместимости. Опцию необходимо отмечать при наличии старого кастомизированного шаблона компонента версии ниже 16.6.2 модуля Информационные блоки.
Настройки действий
Название переменной, в которой передается действие | ACTION_VARIABLE | Задается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Использовать вывод цен с диапазонами | USE_PRICE_COUNT | [Y/N] При отмеченной опции будут отображаться цены всех типов на товары.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах; станет доступным [dw]дополнительное окно[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты в которой будут отображаться цены.
[/di]. При выборе этой опции кеш компонента будет автоматически сбрасываться при изменении курсов валют тех товаров, что показываются компонентом. К примеру, если выбрана конвертация в рубли, а цены в инфоблоке сохранены в евро, то кеш сбросится при изменении курса евро или рубля. Изменения остальных валют на кеш не окажут влияния.
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Разрешить указание количества товара | USE_PRODUCT_QUANTITY | [Y|N] При отмеченной опции будет разрешен вывод количества товара.
Добавлять в корзину свойства товаров и предложений ADD_PROPERTIES_TO_BASKET [Y|N] При отмеченной опции становятся доступными [dw]настройки выбора свойств товаров и предложений[/dw][di]
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить добавлять в корзину товары, у которых заполнены не все характеристики | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
Характеристики товара | PRODUCT_PROPERTIES | Указываются характеристики товара.
Свойства предложений, добавляемые в корзину | OFFERS_CART_PROPERTIES | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использоать клавишу Ctrl. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
[/di] для передачи их в корзину и заказ.
Показывать кнопку добавления в корзину или покупки | ADD_TO_BASKET_ACTION | Выберите какая кнопка должна отображаться: кнопка покупки (BUY) или кнопка добавления в корзину (ADD).
Сравнение товаров
Разрешить сравнение товаров DISPLAY_COMPARE [Y|N] Если опция отмечена, то будет отображаться кнопка для сравнения товаров, станет активным [dw]дополнительное окно[/dw][di]
Путь к странице сравнения COMPARE_PATH Путь к странице с компонентом сравнения товаров. Если значение параметра пустое, будет использована текущая страница.
[/di] .
Уникальное имя для списка сравнения | COMPARE_NAME | Задается имя переменной, в которой передается список сравниваемых элементов. По умолчанию CATALOG_COMPARE_LIST.
Настройки аналитики
Отправлять данные электронной торговли в Google и Яндекс USE_ENHANCED_ECOMMERCE [Y|N] Включение опции. После включения станут доступны ещё [dw]два поля[/dw][di]
Имя контейнера данных | DATA_LAYER_NAME | Указываются свойства инфоблока, которые будут отображены в списке просмотренных товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Свойство брендов | BRAND_PROPERTY | Указывается свойство инфоблока, откуда система должна брать название бренда товара (производитель, марка, модель и т.п.).
[/di] . Требуется дополнительная настройка в Google Analytics Enhanced Ecommerce [image] и/или Яндекс.Метрике [image].

Примечание: Настройка Яндекс метрикой не сложна, и данные в ней отображаются довольно быстро (полчаса-час). У Google используется Google Tag Manager с плагином электронной коммерции, его нужно настроить и добавить на страницу в шаблоне. После настройки на "той" стороне, нужно настроить компоненты для работы с электронной коммерцией и включить это поле настройки.

Служебные параметры (не отображаются в настройках компонента)
Кастомная сортировка по произвольному числу параметров CUSTOM_ELEMENT_SORT Данный служебный параметр можно передать в вызове компонента. Тип параметра - массив. Структура массива соответствует ключу $arOrder метода CIBlockElement::GetList [image]. Доступно с версии модуля iblock 20.0.400.
Параметр не используется в штатных шаблонах комплексного компонента catalog.

Примечание: если указаны поля сортировки, отличные от ID, и значения этих полей для торговых предложений разные, то для выбора первого для показа предложения будет выбрано то предложение, которое отсортировано первым.
Если же все значения совпадают, то будет показано то торговое предложение, у которого сортировка участвующих в выборе SKU значений свойств минимальна.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:catalog.top",
    "",
    Array(
        "ACTION_VARIABLE" => "action",
        "ADD_PICT_PROP" => "MORE_PHOTO",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "ADD_TO_BASKET_ACTION" => "ADD",
        "BASKET_URL" => "/personal/basket.php",
        "BRAND_PROPERTY" => "BRAND_REF",
        "CACHE_FILTER" => "N",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "36000000",
        "CACHE_TYPE" => "A",
        "COMPARE_NAME" => "CATALOG_COMPARE_LIST",
        "COMPARE_PATH" => "",
        "COMPATIBLE_MODE" => "N",
        "CONVERT_CURRENCY" => "Y",
        "CURRENCY_ID" => "RUB",
        "CUSTOM_FILTER" => "{\"CLASS_ID\":\"CondGroup\",\"DATA\":{\"All\":\"OR\",\"True\":\"True\"},\"CHILDREN\":{\"4\":{\"CLASS_ID\":\"CondIBSection\",\"DATA\":{\"logic\":\"Equal\",\"value\":1}},\"6\":{\"CLASS_ID\":\"CondIBProp:2:8\",\"DATA\":{\"logic\":\"Equal\",\"value\":3}}}}",
        "DATA_LAYER_NAME" => "dataLayer",
        "DETAIL_URL" => "",
        "DISCOUNT_PERCENT_POSITION" => "bottom-right",
        "DISPLAY_COMPARE" => "N",
        "ELEMENT_COUNT" => "9",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_FIELD2" => "id",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_ORDER2" => "desc",
        "ENLARGE_PRODUCT" => "STRICT",
        "FILTER_NAME" => "",
        "HIDE_NOT_AVAILABLE" => "L",
        "HIDE_NOT_AVAILABLE_OFFERS" => "L",
        "IBLOCK_ID" => "2",
        "IBLOCK_TYPE" => "catalog",
        "LABEL_PROP" => array("SALELEADER"),
        "LABEL_PROP_MOBILE" => array(),
        "LABEL_PROP_POSITION" => "top-left",
        "LINE_ELEMENT_COUNT" => "",
        "MESS_BTN_ADD_TO_BASKET" => "В корзину",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_COMPARE" => "Сравнить",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_NOT_AVAILABLE" => "Нет в наличии",
        "MESS_RELATIVE_QUANTITY_FEW" => "мало",
        "MESS_RELATIVE_QUANTITY_MANY" => "много",
        "MESS_SHOW_MAX_QUANTITY" => "Наличие",
        "OFFERS_CART_PROPERTIES" => array("COLOR_REF","SIZES_SHOES","SIZES_CLOTHES"),
        "OFFERS_FIELD_CODE" => array("",""),
        "OFFERS_LIMIT" => "5",
        "OFFERS_PROPERTY_CODE" => array("SIZES_SHOES","SIZES_CLOTHES","MORE_PHOTO",""),
        "OFFERS_SORT_FIELD" => "sort",
        "OFFERS_SORT_FIELD2" => "id",
        "OFFERS_SORT_ORDER" => "asc",
        "OFFERS_SORT_ORDER2" => "desc",
        "OFFER_ADD_PICT_PROP" => "MORE_PHOTO",
        "OFFER_TREE_PROPS" => array("COLOR_REF","SIZES_SHOES"),
        "PARTIAL_PRODUCT_PROPERTIES" => "N",
        "PRICE_CODE" => array("BASE"),
        "PRICE_VAT_INCLUDE" => "Y",
        "PRODUCT_BLOCKS_ORDER" => "price,props,sku,quantityLimit,quantity,buttons,compare",
        "PRODUCT_DISPLAY_MODE" => "Y",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_PROPERTIES" => array("NEWPRODUCT"),
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PRODUCT_QUANTITY_VARIABLE" => "",
        "PRODUCT_ROW_VARIANTS" => "[{'VARIANT':'2','BIG_DATA':false},{'VARIANT':'2','BIG_DATA':false},{'VARIANT':'2','BIG_DATA':false}]",
        "PRODUCT_SUBSCRIPTION" => "Y",
        "PROPERTY_CODE" => array("MANUFACTURER","MATERIAL",""),
        "PROPERTY_CODE_MOBILE" => array(),
        "RELATIVE_QUANTITY_FACTOR" => "5",
        "ROTATE_TIMER" => "30",
        "SECTION_URL" => "",
        "SEF_MODE" => "N",
        "SEF_RULE" => "",
        "SHOW_CLOSE_POPUP" => "N",
        "SHOW_DISCOUNT_PERCENT" => "Y",
        "SHOW_MAX_QUANTITY" => "M",
        "SHOW_OLD_PRICE" => "Y",
        "SHOW_PAGINATION" => "Y",
        "SHOW_PRICE_COUNT" => "1",
        "SHOW_SLIDER" => "Y",
        "SLIDER_INTERVAL" => "3000",
        "SLIDER_PROGRESS" => "N",
        "TEMPLATE_THEME" => "blue",
        "USE_ENHANCED_ECOMMERCE" => "Y",
        "USE_PRICE_COUNT" => "N",
        "USE_PRODUCT_QUANTITY" => "Y",
        "VIEW_MODE" => "SECTION"
    )
);?>


top элементов каталога по параметру (магазин) - не поддерживается с версии 12.5

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>top элементов каталога по параметру (магазин) - не поддерживается с версии 12.5

Каталог::top элементов каталога по параметру (магазин) - не поддерживается с версии 12.5

Описание store.catalog.top

Выводит в таблице top элементов из всех разделов в соответствии с заданной сортировкой (используется как правило на главной странице сайта). Компонент разработан специально для решения sitestore.

В визуальном редакторе компонент расположен по пути Решение: Магазин > Каталог > Top элементов каталога.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфо-блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфо-блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, из которого будет выводиться top элементов сгруппированных по разделам.
Источник данных
По какому полю сортируем элементы ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка элементов:
  • SHOWS – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • ACTIVE_FROM – по дате активности с;
  • ACTIVE_TO – по дате активности по.
Порядок сортировки элементов ELEMENT_SORT_ORDER Задается порядок сортировки элементов:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается путь к странице с детальным содержимым раздела.
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Название переменной, в которой передается действие | ACTION_VARIABLE | Указывается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию ACTION. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара для покупки.
Название переменной, в которой передается количество товара | PRODUCT_QUANTITY_VARIABLE | Указывается имя переменной, в которой будет передаваться количество товара.
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Указывается имя переменной, в которой будут передаваться характеристики товара.
Название переменной, в которой передается код группы | SECTION_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор раздела.
Дополнительные настройки
Выводить кнопку сравнения | DISPLAY_COMPARE | [Y|N] При отмеченной опции будет выведена кнопка Сравнить, с помощью которой элемент добавляется в список сравнения.
Внешний вид
Количество выводимых элементов | ELEMENT_COUNT | Указывается количество элементов, отображаемых на одной странице. Все элементы будут выведены с помощью постраничной навигации.
Количество элементов выводимых в одной строке таблицы | LINE_ELEMENT_COUNT | Указывается количество элементов выводимых в одной строке таблицы.
Свойства | PROPERTY_CODE | Указываются свойства инфоблока, которые будут отображены при показе элементов в таблице. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Необходимый для отображения флаг | FLAG_PROPERTY_CODE | Выбирается необходимый для отображения параметр каталога.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Использовать вывод цен с диапазонами | USE_PRICE_COUNT | [Y/N] При отмеченной опции будут отображаться цены всех типов на товары.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Характеристики товара | PRODUCT_PROPERTIES | Выбираются характеристики товара.
Разрешить указание количества товара | USE_PRODUCT_QUANTITY | [Y|N] При установленной опции будет разрешено указание количества товара.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:store.catalog.top",
    "",
    Array(
        "IBLOCK_TYPE_ID" => "xmlcatalog",
        "IBLOCK_ID" => array("8"),
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_ORDER" => "asc",
        "SECTION_URL" => "",
        "DETAIL_URL" => "",
        "BASKET_URL" => "/personal/basket.php",
        "ACTION_VARIABLE" => "action",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_QUANTITY_VARIABLE" => "quantity",
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "SECTION_ID_VARIABLE" => "SECTION_ID",
        "DISPLAY_COMPARE" => "Y",
        "ELEMENT_COUNT" => "9",
        "LINE_ELEMENT_COUNT" => "3",
        "PROPERTY_CODE" => array(),
        "PRICE_CODE" => array(),
        "USE_PRICE_COUNT" => "Y",
        "SHOW_PRICE_COUNT" => "1",
        "PRICE_VAT_INCLUDE" => "Y",
        "PRODUCT_PROPERTIES" => array(),
        "USE_PRODUCT_QUANTITY" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y"
    )
);?>


Конструктор наборов

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Конструктор наборов

Каталог::Конструктор наборов

Описание catalog.set.constructor

Компонент служит для отображения заданного набора и составления собственного набора товаров. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Каталог > Конструктор наборов.

Компонент относится к модулю Торговый каталог.

Компонент работает с одним инфоблоком (как и catalog [image]).

На текущий момент не работает с товаром, имеющим торговые предложения (как единым целым).

При передаче ID торгового предложения компонент будет искать набор для торгового предложения. Если не найдет - будет искать набор для головного товара.

На текущий момент компонент не показывает групповые скидки (на набор в целом) - только на отдельные элементы набора.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE_ID | Тип инфоблока (нужен только при настройке компонента в визуальном редакторе).
Инфоблок | IBLOCK_ID | ID инфоблока, которому принадлежит элемент (простой товар, комплект или торговое предложение).
ID элемента | ELEMENT_ID | Указывается код, в котором передается идентификатор элемента.
Внешний вид
Число элементов набора, готовых к добавлению в корзину BUNDLE_ITEMS_COUNT Сколько товаров из набора сразу добавятся в корзину при нажатии "Купить набор". По умолчанию 3 элемента.
Пример: если в наборе 6 товаров, а в этом поле установлено значение - 3, то из предложенных 6 три автоматически попадают в корзину, а три покупатель может добавить самостоятельно. В корзину автоматически попадают те товары из набора, чье значение Сортировки в списке ниже, чем у других товаров.
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения элементов каталога. По умолчанию используется синяя схема (blue).
Шаблоны ссылок
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа групп пользователей при кешировании.
Цены
Тип цены | PRICE_CODE | Перечень кодов (НЕ ID - так же, как у каталожных компонент) типов цен, среди которых будет вычисляться минимальная.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте CONVERT_CURRENCY [Y|N] При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах. Если флажок не установлен, цены товаров набора будут показаны в валюте товара-владельца. При выборе данной опции становится доступным [dw]дополнительное поле.[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты, в которой будут отображаться цены.

[/di]
Свойства предложений, добавляемые в корзину | OFFERS_CART_PROPERTIES | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использоать клавишу Ctrl. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU. То есть, имеет смысл только для ситуации, когда в набор входят торговые предложения из одного инфоблока. Может быть настроен в визуальном редакторе, только если в IBLOCK_ID указан инфоблок головного товара.

Пример вызова

<?$APPLICATION->IncludeComponent(
   "bitrix:catalog.set.constructor",
   "",
   Array(
      "BASKET_URL" => "/personal/basket.php",
      "BUNDLE_ITEMS_COUNT" => "3",
      "CACHE_GROUPS" => "Y",
      "CACHE_TIME" => "36000000",
      "CACHE_TYPE" => "A",
      "CONVERT_CURRENCY" => "Y",
      "CURRENCY_ID" => "RUB",
      "ELEMENT_ID" => "4",
      "IBLOCK_ID" => "2",
      "IBLOCK_TYPE_ID" => "catalog",
      "OFFERS_CART_PROPERTIES" => array("COLOR_REF", "SIZES_SHOES", "SIZES_CLOTHES"),
      "PRICE_CODE" => array("BASE", "FULL", "RETAIL"),
      "PRICE_VAT_INCLUDE" => "Y",
      "TEMPLATE_THEME" => "blue" // параметр из дефолтного шаблона, означает цветовую тему
   )
);?>


Разделы с top'ом элементов

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Разделы с top'ом элементов

Каталог::Разделы с top'ом элементов

Описание catalog.sections.top

Компонент выводит top элементов сгруппированных по разделам; элементы выводятся в таблице. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Каталог > Разделы с top'ом элементов.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, из которого будут выводиться список элементов.
Источник данных
Поля разделов SECTION_FIELDS Указываются поля раздела, которые будут отображены на странице структуры разделов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
 Array("ID","CODE",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив) ничего отображаться не будет.
Свойства раздела | SECTION_USER_FIELDS | Указываются свойства раздела, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, свойства не будут выведены.
По какому полю сортируем разделы SECTION_SORT_FIELD Указывается поле, по которому будет происходить сортировка разделов:
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • DEPTH_LEVEL – по уровню вложенности папки.
Порядок сортировки разделов SECTION_SORT_ORDER Задается порядок сортировки разделов:
  • ASC – По возрастанию;
  • DESC – По убыванию.
По какому полю сортируем элементы ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • CATALOG_AVAILABLE – доступность к покупке;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок сортировки элементов ELEMENT_SORT_ORDER Задается порядок сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.
Поле для второй сортировки элементов ELEMENT_SORT_FIELD2 Указывается поле, по которому будет происходить вторая сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • CATALOG_AVAILABLE – доступность к покупке;
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок второй сортировки элементов ELEMENT_SORT_ORDER2 Задается порядок второй сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.
Имя массива со значениями фильтра для фильтрации элементов | FILTER_NAME | Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Не отображать товары, которых нет на складах | HIDE_NOT_AVAILABLE | [Y|N] При отмеченной опции будут скрыты товары, для которых общее количество на складах меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Внешний вид
Максимальное количество выводимых разделов | SECTION_COUNT | Указывается максимальное количество разделов, отображаемых на странице.
Максимальное количество элементов, выводимых в каждом разделе | ELEMENT_COUNT | Указывается максимальное количество элементов выводимых в каждом разделе. Все элементы раздела будут выведены с помощью постраничной навигации.
Количество элементов, выводимых в одной строке таблицы | LINE_ELEMENT_COUNT | Указывается количество элементов выводимых в одной строке таблицы.
Свойства | PROPERTY_CODE | Указываются свойства инфоблока, которые будут отображены при показе элементов в таблице. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается путь к странице с детальным содержимым раздела.
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Название переменной, в которой передается действие | ACTION_VARIABLE | Указывается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию ACTION. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара для покупки.
Название переменной, в которой передается количество товара | PRODUCT_QUANTITY_VARIABLE | Задается имя переменной, в которой будет передаваться количество товара.
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Название переменной, в которой передается код группы | SECTION_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор группы.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кешировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Выводить кнопку сравнения | DISPLAY_COMPARE | [Y|N] При отмеченной опции будет выведена кнопка Сравнить, с помощью которой элемент добавляется в список сравнения.
Использовать основной раздел для показа элемента USE_MAIN_ELEMENT_SECTION [Y|N] Если опция отмечена, то при переходе на детальную страницу элемента в адресную строку браузера будет подставляться тот путь, который формируется при просмотре элемента через основной раздел, даже если элемент открыт через другой родительский его раздел.

Если опция не отмечена, про ссылка на детальную страницу элемента формируется с учетом того раздела, через который элемент открыт на просмотр.

Рассмотрим пример, когда опция в настройках отмечена. Допустим, что элемент с символьным кодом marketing привязан к двум разделам с кодами bisness и science соответственно, причем раздел с кодом bisness является основным. В результате, если пользователь пришел в раздел science и кликнул на элемент marketing, то в строке браузера вместо http://mysite.ru/catalog/science/marketing/ будет отображено http://mysite.ru/catalog/bisness/marketing/.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Использовать вывод цен с диапазонами | USE_PRICE_COUNT | [Y/N] При отмеченной опции будут отображаться цены всех типов на товары.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Характеристики товара | PRODUCT_PROPERTIES | Указываются характеристики товара.
Разрешить указание количества товара | USE_PRODUCT_QUANTITY | [Y|N] При отмеченной опции будет разрешен вывод количества товара.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах. При выборе этой опции кеш компонента будет автоматически сбрасываться при изменении курсов валют тех товаров, что показываются компонентом. К примеру, если выбрана конвертация в рубли, а цены в инфоблоке сохранены в евро, то кеш сбросится при изменении курса евро или рубля. Изменения остальных валют на кеш не окажут влияния. При выборе данной опции становится доступным [dw]дополнительное поле.[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты в которой будут отображаться цены.
[/di]
Разрешить указание дробного количества товара | QUANTITY_FLOAT | [Y|N] При отмеченной опции в корзину можно будет добавлять дробное количество товара. Опция доступна, если отмечен параметр Разрешить указание количества товара, до версии модуля 14.0.0.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:catalog.sections.top","",Array(
        "IBLOCK_TYPE" => "books",
        "IBLOCK_ID" => "6",
        "SECTION_FIELDS" => Array(""),
        "SECTION_USER_FIELDS" => Array(""),
        "SECTION_SORT_FIELD" => "sort",
        "SECTION_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD" => "active_from",
        "ELEMENT_SORT_ORDER" => "asc",
        "FILTER_NAME" => "arrFilter",
        "SECTION_URL" => "",
        "DETAIL_URL" => "",
        "BASKET_URL" => "/personal/basket.php",
        "ACTION_VARIABLE" => "action",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_QUANTITY_VARIABLE" =>  "quantity",
        "PRODUCT_PROPS_VARIABLE" =>  "prop",
        "SECTION_ID_VARIABLE" => "SECTION_ID",
        "DISPLAY_COMPARE" => "Y",
        "USE_MAIN_ELEMENT_SECTION" => "Y",
        "SECTION_COUNT" => "20",
        "ELEMENT_COUNT" => "9",
        "LINE_ELEMENT_COUNT" => "3",
        "PROPERTY_CODE" => Array("YEAR", "ISBN", "PAGES", "CML2_ARTICLE"),
        "PRICE_CODE" => Array("BASE"),
        "USE_PRICE_COUNT" => "Y",
        "SHOW_PRICE_COUNT" => "1",
        "PRICE_VAT_INCLUDE" => "Y",
        "PRODUCT_PROPERTIES" => array(),
        "USE_PRODUCT_QUANTITY" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "CACHE_GROUPS" => "Y",
        "HIDE_NOT_AVAILABLE" => "N",
        "QUANTITY_FLOAT" => "N",
        "CONVERT_CURRENCY" => "Y",
        "CURRENCY_ID" => "RUB",
    )
);?>


Список связанных элементов

Отправить отзыв по этому разделу
Компоненты>Контент>Каталог>Список связанных элементов

Каталог::Список связанных элементов

Описание catalog.link.list

Компонент выводит список элементов, связанных с заданным. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Каталог > Список связанных элементов.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфо-блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, из которого будут выводиться список элементов.
Свойство, в котором хранится связь | LINK_PROPERTY_SID | Свойство, по которому связаны элементы, выбирается из списка или указывается в виде кода в поле рядом.
ID элемента | ELEMENT_ID | Поле содержит код, в котором передается идентификатор элемента, для которого выводится список связанных элементов.
Источник данных
По какому полю сортируем элементы ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • CATALOG_AVAILABLE – по доступности к покупке.
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок сортировки элементов ELEMENT_SORT_ORDER Задается порядок сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.
Поле для второй сортировки элементов ELEMENT_SORT_FIELD2 Указывается поле, по которому будет происходить вторая сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • CATALOG_AVAILABLE – по доступности к покупке.
  • SCALED_PRICE_[ID] – по типу цен (вместо [ID] - идентификатор типа цены)
Порядок второй сортировки элементов ELEMENT_SORT_ORDER2 Задается порядок второй сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.
Имя массива со значениями фильтра для фильтрации элементов | FILTER_NAME | Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Недоступные товары HIDE_NOT_AVAILABLE Указывается способ отборажения недоступных для покупки товаров:
  • не отображать;
  • отображать в конце;
  • отображать в общем списке.
Примечание: недоступные для покупки товары - это товары, для которых количество меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Недоступные торговые предложения HIDE_NOT_AVAILABLE_OFFERS Указывается способ отборажения недоступных для покупки торговых предложений:
  • не отображать;
  • отображать только с возможностью подписки;
  • отображать все.
Внешний вид
Количество элементов на странице | PAGE_ELEMENT_COUNT | Указывается количество элементов, отображаемых на одной странице. Все элементы будут выведены с помощью постраничной навигации.
Свойства | PROPERTY_CODE | Указываются свойства инфоблока, которые будут отображены при показе элементов в таблице. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения списка связанных элементов. По умолчанию используется синяя схема (blue).
Схема отображения | PRODUCT_DISPLAY_MODE | Задается режим отображения товаров: простой (N) или расширенный (Y).
Дополнительная картинка основного товара | ADD_PICT_PROP | Задается свойство, в котором хранится дополнительная картинка для основного товара.
Свойство меток товара | LABEL_PROP | Указываются свойство, в котором хранится метка товара (например, новинка).
Показывать процент скидки | SHOW_DISCOUNT_PERCENT | [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана.
Показывать старую цену | SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Показывать кнопку продолжения покупок во всплывающих окнах | SHOW_CLOSE_POPUP | [Y|N] При отмеченной опции будет отображаться кнопка Продолжить покупки во всплывающем окне, появляющемся после добавления товара в корзину.
Текст кнопки "Купить" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Добавить в корзину" | MESS_BTN_ADD_TO_BASKET | Задается текст, который должен быть отображен на кнопке добавления в корзину.
Текст кнопки "Подробнее" | MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Сообщение об отсутствии товара | MESS_NOT_AVAILABLE | Указывается текст, который будет отображаться при отсутствии товара и невозможности его купить.
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается путь к странице с детальным содержимым раздела.
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Название переменной, в которой передается код группы | SECTION_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор раздела.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Кешировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название раздела связанного инфоблока.
Устанавливать в заголовках ответа время модификации страницы | SET_LAST_MODIFIED | [Y|N] При отмеченной опции http-ответ сервера будет содержать время последнего изменения страницы (заголовок Last-Modified [image]).
Показывать кнопку добавления в корзину или покупки | ADD_TO_BASKET_ACTION | Выберите какая кнопка должна отображаться: кнопка покупки (BUY) или кнопка добавления в корзину (ADD).
Настройки действий
Название переменной, в которой передается действие | ACTION_VARIABLE | Указывается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию ACTION. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара для покупки.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Использовать вывод цен с диапазонами | USE_PRICE_COUNT | [Y/N] При отмеченной опции будут отображаться цены всех типов на товары.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте CONVERT_CURRENCY [Y|N] При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах; станет активным [dw]дополнительное окно[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты, в которой будут отображаться цены..
[/di] . При выборе этой опции кэш компонента будет автоматически сбрасываться при изменении курсов валют тех товаров, которые показываются компонентом. К примеру, если выбрана конвертация в рубли, а цены в информационном блоке сохранены в евро, то кэш сбросится при изменении курса евро или рубля. Изменения остальных валют на кэш не окажут влияния.
Сравнение товаров
Разрешить сравнение товаров DISPLAY_COMPARE [Y|N] Если опция отмечена, то будет отображаться кнопка для сравнения товаров, станет доступно [dw]дополнительное поле[/dw][di]
Путь к странице сравнения COMPARE_PATH Путь к странице с компонентом сравнения товаров.
[/di] .
Настройки постраничной навигации
Шаблон постраничной навигации | PAGER_TEMPLATE | Указывается название шаблона постраничной навигации. Если поле пусто, то выбирается шаблон по умолчанию (.default).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение по элементам.
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться, даже если все элементы помещаются на одной странице.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц в секундах для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все элементы списка.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:catalog.link.list","",
Array(
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "catalog_tovar",
        "IBLOCK_ID" => "1",
        "LINK_PROPERTY_SID" => "",
        "ELEMENT_ID" => $_REQUEST["PARENT_ELEMENT_ID"],
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD2" => "id",
        "ELEMENT_SORT_ORDER2" => "desc",
        "FILTER_NAME" => "arrFilter",
        "SECTION_URL" => "",
        "DETAIL_URL" => "",
        "BASKET_URL" => "/personal/basket.php",
        "ACTION_VARIABLE" => "action",
        "PRODUCT_ID_VARIABLE" => "id",
        "SECTION_ID_VARIABLE" => "SECTION_ID",
        "SET_TITLE" => "Y",
        "PAGE_ELEMENT_COUNT" => "30",
        "PROPERTY_CODE" => array(),
        "PRICE_CODE" => array(),
        "USE_PRICE_COUNT" => "N",
        "SHOW_PRICE_COUNT" => "1",
        "PRICE_VAT_INCLUDE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "300",
        "CACHE_FILTER" => "Y",
        "CACHE_GROUPS" => "Y",
        "DISPLAY_TOP_PAGER" => "N",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Товары",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_TEMPLATE" => "",
        "PAGER_DESC_NUMBERING" => "N",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "HIDE_NOT_AVAILABLE" => "N",
        "CONVERT_CURRENCY" => "N",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "PRODUCT_DISPLAY_MODE" => "Y",
        "TEMPLATE_THEME" => "blue",
        "SHOW_DISCOUNT_PERCENT" => "N",
        "SHOW_OLD_PRICE" => "N",
        "SHOW_CLOSE_POPUP" => "N",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_ADD_TO_BASKET" => "В корзину",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_NOT_AVAILABLE" => "Нет в наличии",
        "DISPLAY_COMPARE" => "N",
        "ADD_PICT_PROP" => "-",
        "LABEL_PROP" => "-",
        "PRODUCT_DISPLAY_MODE" => "N",
        "SET_LAST_MODIFIED" => "Y",
        "ADD_TO_BASKET_ACTION" => "ADD"
    )
);?>


Универсальные списки

Подраздел предназначен для организации полнофункциональной работы с универсальными списками и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Универсальные списки | lists | Позволяет вести полнофункциональную работу с универсальными списками, создавая физически только одну страницу.
Списки | lists.lists | Выводит таблицу универсальных списков, доступных для просмотра и изменения.
Список | lists.list | Выводит разделы и элементы универсального списка с возможностью навигации и редактирования.
Разделы списка | lists.sections | Позволяет удалить и изменить разделы универсального списка.
Редактирование элемента | lists.element.edit | Выводит форму редактирования элемента списка.
Настройки списка | lists.list.edit | Показывает форму настроек универсального списка.
Поля списка | lists.fields | Показывает поля универсального списка и позволяет их редактировать.
Настройки поля списка | lists.field.edit | Показывает форму настройки поля универсального списка.
Навигационная цепочка | lists.element.navchain | Добавляет к выводу обычного компонента Навигационная цепочка (bitrix:breadcrumb) элемент списка.
Меню списков | lists.menu | Добавляет в меню социальной сети универсальные списки.
Скачивание файла | lists.file | Скачивает файлы, привязанные к элементам списка, с проверкой прав доступа.

Смотрите также:

  • Универсальные списки (учебный курс "Контент-менеджер")


Универсальные списки

Описание lists

Комплексный компонент позволяет вести полнофункциональную работу с универсальными списками, создавая физически только одну страницу. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Универсальные списки > Универсальные списки.

Компонент относится к модулю Универсальные списки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE_ID | Указывается тип информационных блоков, в котором будут храниться универсальные списки.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • lists - главная страница;
  • list - страница элементов и разделов;
  • list_sections - страница управления разделами;
  • list_edit - страница настроек списка;
  • list_fields - страница с полями списка;
  • list_field_edit - страница настроек полей списка.
  • element_id - страница редактирования элемента;
  • document_state_id - страница просмотра журнала бизнес-процесса;
  • element_id - страница запуска бизнес-процесса;
  • task_id - страница задачи бизнес-процесса.
[/di]: SEF_FOLDER и SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.

При выключенном режиме ЧПУ необходимо указать имена следующих переменных:
  • list_id - имя переменной для идентификатора списка;
  • field_id - имя переменной для идентификатора поля;
  • section_id - имя переменной для идентификатора раздела;
  • element_id - имя переменной для идентификатора элемента;
  • mode - имя переменной для идентификатора режима.
  • document_state_id - имя переменной для статуса бизнес-процесса;
  • task_id - имя переменной для задачи бизнес-процесса.
[/di].
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:lists","",Array(
        "SEF_MODE" => "Y",
        "IBLOCK_TYPE_ID" => "lists",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "lists" => "",
            "list" => "#list_id#/view/#section_id#/",
            "list_sections" => "#list_id#/edit/#section_id#/",
            "list_edit" => "#list_id#/edit/",
            "list_fields" => "#list_id#/fields/",
            "list_field_edit" => "#list_id#/field/#field_id#/",
            "list_element_edit" => "#list_id#/element/#section_id#/#element_id#/",
            "bizproc_log" => "#list_id#/bp_log/#document_state_id#/",
            "bizproc_workflow_start" => "#list_id#/bp_start/#element_id#/",
            "bizproc_task" => "#list_id#/bp_task/#section_id#/#element_id#/#task_id#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "lists" => Array(),
            "list" => Array(),
            "list_sections" => Array(),
            "list_edit" => Array(),
            "list_fields" => Array(),
            "list_field_edit" => Array(),
            "list_element_edit" => Array(),
            "bizproc_log" => Array(),
            "bizproc_workflow_start" => Array(),
            "bizproc_task" => Array(),

        )
    )
);?>

Смотрите также

  • Универсальные списки (учебный курс "Контент-менеджер")
  • Создание раздела списков и самих списков (учебный курс "Контент-менеджер")


Списки

Описание lists.lists

Компонент выводит таблицу универсальных списков, доступных для просмотра и изменения. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Универсальные списки > Списки.

Компонент относится к модулю Универсальные списки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE_ID | Указывается тип информационных блоков, в котором будут храниться универсальные списки.
Шаблоны ссылок
URL главной страницы списков | LISTS_URL | Указывается шаблон ссылки на главную страницу универсальных списков.
URL списка | LIST_URL | Указывается шаблон ссылки на универсальный список.
URL настройки списка | LIST_EDIT_URL | Указывается шаблон ссылки на страницу настроек универсального списка.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Количество списков в строке | LINE_ELEMENT_COUNT | Указывается количество универсальных списков, отображаемых в одной строке таблицы.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:lists.lists","",Array(
        "LINE_ELEMENT_COUNT" => "3",
        "IBLOCK_TYPE_ID" => "lists",
        "LISTS_URL" => "lists.lists.php",
        "LIST_URL" => "lists.list.php?list_id=#list_id#",
        "LIST_EDIT_URL" => "lists.list.edit.php?list_id=#list_id#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Список

Описание lists.list

Компонент выводит разделы и элементы универсального списка с возможностью навигации и редактирования. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Универсальные списки > Список.

Компонент относится к модулю Универсальные списки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE_ID | Указывается тип информационных блоков, в котором будут храниться универсальные списки.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока.
Раздел | SECTION_ID | Указывается код, в котором передается идентификатор раздела. По умолчанию указано ={$_REQUEST["section_id"]}.
Шаблоны ссылок
URL главной страницы списков | LISTS_URL | Указывается шаблон ссылки на главную страницу универсальных списков.
URL настройки списка | LIST_EDIT_URL | Указывается шаблон ссылки на страницу настроек универсального списка.
URL списка | LIST_URL | Указывается шаблон ссылки на универсальный список.
URL управления разделами | LIST_SECTIONS_URL | Указывается шаблон ссылки на страницу управления разделами универсального списка.
URL Редактирование элемента | LIST_EDIT_URL | Указывается шаблон ссылки на страницу редактирования элемента.
URL запуска бизнес-процесса | BIZPROC_WORKFLOW_START_URL | Указывается шаблон ссылки на страницу запуска бизнес-процесса.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:lists.list",
    "",
    Array(
        "IBLOCK_TYPE_ID" => "lists",
        "IBLOCK_ID" => $_REQUEST["list_id"],
        "SECTION_ID" => $_REQUEST["section_id"],
        "LISTS_URL" => "lists.lists.php",
        "LIST_EDIT_URL" => "lists.list.edit.php?list_id=#list_id#",
        "LIST_URL" => "lists.list.php?list_id=#list_id#§ion_id=#section_id#",
        "LIST_SECTIONS_URL" => "lists.sections.php?list_id=#list_id#§ion_id=#section_id#",
        "LIST_ELEMENT_URL" => "lists.element.edit.php?list_id=#list_id#§ion_id=#section_id#&element_id=#element_id#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "BIZPROC_WORKFLOW_START_URL" => "bizproc.workflow.start.php?element_id=#element_id#&list_id=#list_id#&workflow_template_id=#workflow_template_id#"
    )
);?>


Разделы списка

Описание lists.sections

Компонент позволяет удалить и изменить разделы универсального списка. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Универсальные списки > Разделы списка.

Компонент относится к модулю Универсальные списки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE_ID | Указывается тип информационных блоков, в котором будут храниться универсальные списки.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока.
Раздел | SECTION_ID | Указывается код, в котором передается идентификатор раздела. По умолчанию указано ={$_REQUEST["section_id"]}.
Шаблоны ссылок
URL главной страницы списков | LISTS_URL | Указывается шаблон ссылки на главную страницу универсальных списков.
URL настройки списка | LIST_EDIT_URL | Указывается шаблон ссылки на страницу настроек универсального списка.
URL списка | LIST_URL | Указывается шаблон ссылки на универсальный список.
URL управления разделами | LIST_SECTIONS_URL | Указывается шаблон ссылки на страницу управления разделами универсального списка.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:lists.sections","",Array(
        "IBLOCK_TYPE_ID" => "lists",
        "IBLOCK_ID" => "12",
        "SECTION_ID" => $_REQUEST["section_id"],
        "LISTS_URL" => "lists.lists.php",
        "LIST_EDIT_URL" => "lists.list.edit.php?list_id=#list_id#",
        "LIST_URL" => "lists.list.php?list_id=#list_id#§ion_id=#section_id#",
        "LIST_SECTIONS_URL" => "lists.sections.php?list_id=#list_id#§ion_id=#section_id#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>

Смотрите также

  • Создание раздела списков и самих списков (учебный курс "Контент-менеджер")


Редактирование элемента

Описание lists.element.edit

Компонент выводит форму редактирования элемента списка.

В визуальном редакторе компонент расположен по пути: Контент > Универсальные списки > Редактирование элемента.

Компонент относится к модулю Универсальные списки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE_ID | Указывается тип информационных блоков, в котором будут храниться универсальные списки.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока.
Раздел | SECTION_ID | Указывается код, в котором передается идентификатор раздела. По умолчанию указано ={$_REQUEST["section_id"]}.
Элемент | ELEMENT_ID | Указывается код, в котором передается идентификатор элемента. По умолчанию указано ={$_REQUEST["element_id"]}.
Шаблоны ссылок
URL главной страницы списков | LISTS_URL | Указывается шаблон ссылки на главную страницу универсальных списков.
URL раздела списка | LIST_URL | Указывается шаблон ссылки на страницу раздела списка.
URL элемента списка | LIST_ELEMENT_URL | Указывается шаблон ссылки на страницу элемента списка.
URL просмотра журнала бизнес-процесса | BIZPROC_LOG_URL | Указывается шаблон ссылки на страницу журнала бизнес-процессов.
BIZPROC_WORKFLOW_START_URL | LIST_URL | Указывается шаблон ссылки на страницу запуска бизнес-процесса.
URL задачи бизнес-процесса | BIZPROC_TASK_URL | Указывается шаблон ссылки на страницу задачи бизнес-процесса.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:lists.element.edit",
    "",
    Array(
        "IBLOCK_TYPE_ID" => "lists",
        "IBLOCK_ID" => $_REQUEST["list_id"],
        "SECTION_ID" => $_REQUEST["section_id"],
        "ELEMENT_ID" => $_REQUEST["element_id"],
        "LISTS_URL" => "lists.lists.php",
        "LIST_URL" => "lists.list.php?list_id=#list_id#§ion_id=#section_id#",
        "LIST_ELEMENT_URL" => "lists.element.edit.php?list_id=#list_id#§ion_id=#section_id#&element_id=#element_id#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "BIZPROC_LOG_URL" => "bizproc.log.php?ID=#document_state_id#",
        "BIZPROC_WORKFLOW_START_URL" => "bizproc.workflow.start.php?element_id=#element_id#&list_id=#list_id#",
        "BIZPROC_TASK_URL" => "bizproc.task.php?task_id=#task_id#"
    )
);?>


Настройки списка

Описание lists.list.edit

Компонент показывает форму настроек универсального списка. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Универсальные списки > Настройки списка.

Компонент относится к модулю Универсальные списки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE_ID | Указывается тип информационных блоков, в котором будут храниться универсальные списки.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока.
Шаблоны ссылок
URL главной страницы списков | LISTS_URL | Указывается шаблон ссылки на главную страницу универсальных списков.
URL списка | LIST_URL | Указывается шаблон ссылки на универсальный список.
URL настройки списка | LIST_EDIT_URL | Указывается шаблон ссылки на страницу настроек универсального списка.
URL настройки полей списка | LIST_FIELDS_URL | Указывается шаблон ссылки на страницу настроек полей универсального списка.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:lists.list.edit","",Array(
        "IBLOCK_TYPE_ID" => "lists",
        "IBLOCK_ID" => "12",
        "LISTS_URL" => "lists.lists.php",
        "LIST_URL" => "lists.list.php?list_id=#list_id#",
        "LIST_EDIT_URL" => "lists.list.edit.php?list_id=#list_id#",
        "LIST_FIELDS_URL" => "lists.fields.php?list_id=#list_id#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Поля списка

Описание lists.fields

Компонент показывает поля универсального списка и позволяет их редактировать. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Универсальные списки > Поля списка.

Компонент относится к модулю Универсальные списки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE_ID | Указывается тип информационных блоков, в котором будут храниться универсальные списки.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока.
Шаблоны ссылок
URL главной страницы списков | LISTS_URL | Указывается шаблон ссылки на главную страницу универсальных списков.
URL списка | LIST_URL | Указывается шаблон ссылки на универсальный список.
URL настройки списка | LIST_EDIT_URL | Указывается шаблон ссылки на страницу настроек универсального списка.
URL настройки полей списка | LIST_FIELDS_URL | Указывается шаблон ссылки на страницу настроек полей универсального списка.
URL настройки поля | LIST_FIELD_EDIT_URL | Указывается шаблон ссылки на страницу настройки поля универсального списка.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:lists.fields","",Array(
        "IBLOCK_TYPE_ID" => "lists",
        "IBLOCK_ID" => "12",
        "LISTS_URL" => "lists.lists.php",
        "LIST_URL" => "lists.list.php?list_id=#list_id#",
        "LIST_EDIT_URL" => "lists.list.edit.php?list_id=#list_id#",
        "LIST_FIELDS_URL" => "lists.fields.php?list_id=#list_id#",
        "LIST_FIELD_EDIT_URL" => "lists.field.edit.php?list_id=#list_id#&field_id=#field_id#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    ),
);?>


Настройки поля списка

Описание lists.field.edit

Компонент показывает форму настройки поля универсального списка. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Универсальные списки > Настройки поля списка.

Компонент относится к модулю Универсальные списки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE_ID | Указывается тип информационных блоков, в котором будут храниться универсальные списки.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока.
Поле | FIELD_ID | Указывается код, в котором передается идентификатор поля. По умолчанию указано ={$_REQUEST["field_id"]}.
Шаблоны ссылок
URL главной страницы списков | LISTS_URL | Указывается шаблон ссылки на главную страницу универсальных списков.
URL списка | LIST_URL | Указывается шаблон ссылки на универсальный список.
URL настройки списка | LIST_EDIT_URL | Указывается шаблон ссылки на страницу настроек универсального списка.
URL настройки полей списка | LIST_FIELDS_URL | Указывается шаблон ссылки на страницу настроек полей универсального списка.
URL настройки поля | LIST_FIELD_EDIT_URL | Указывается шаблон ссылки на страницу настройки поля универсального списка.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:lists.field.edit","",Array(
        "IBLOCK_TYPE_ID" => "lists",
        "IBLOCK_ID" => "12",
        "FIELD_ID" => $_REQUEST["field_id"],
        "LISTS_URL" => "lists.lists.php",
        "LIST_URL" => "lists.list.php?list_id=#list_id#",
        "LIST_EDIT_URL" => "lists.list.edit.php?list_id=#list_id#",
        "LIST_FIELDS_URL" => "lists.fields.php?list_id=#list_id#",
        "LIST_FIELD_EDIT_URL" => "lists.field.edit.php?list_id=#list_id#&field_id=#field_id#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Навигационная цепочка

Описание lists.element.navchain

Простой компонент добавляет к выводу обычного компонента Навигационная цепочка (bitrix:breadcrumb) элемент списка. Для работы компонента bitrix:lists.element.navchain в шаблон обязательно должен быть включен компонент bitrix:breadcrumb.

В визуальном редакторе компонент расположен по пути: Контент > Универсальные списки > Навигационная цепочка.

Компонент относится к модулю Универсальные списки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE_ID | Указывается тип информационных блоков, в котором будут храниться универсальные списки.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока.
Раздел | SECTION_ID | Указывается код, в котором передается идентификатор раздела. По умолчанию указано ={$_REQUEST["section_id"]}.
Элемент | ELEMENT_ID | Указывается код, в котором передается идентификатор элемента. По умолчанию указано ={$_REQUEST["element_id"]}.
Шаблоны ссылок
URL главной страницы списков | LISTS_URL | Указывается шаблон ссылки на главную страницу универсальных списков.
URL разделы списка | LIST_URL | Указывается шаблон ссылки на страницу разделов списка.
URL элемента списка | LIST_ELEMENT_URL | Указывается шаблон ссылки на страницу элемента списка.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Примечание: В данном компоненте невозможно использовать файлы result_modifier.php и component_epilog.php.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:lists.element.navchain",
    "",
    Array(
        "IBLOCK_TYPE_ID" => "lists",
        "IBLOCK_ID" => "12",
        "SECTION_ID" => $_REQUEST["section_id"],
        "ELEMENT_ID" => $_REQUEST["element_id"],
        "LISTS_URL" => "lists.lists.php",
        "LIST_URL" => "lists.list.php?list_id=#list_id#§ion_id=#section_id#",
        "LIST_ELEMENT_URL" => "lists.element.edit.php?list_id=#list_id#§ion_id=#section_id#&element_id=#element_id#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Меню списков

Описание lists.menu

Компонент добавляет в меню пункты, ведущие на страницы списков. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Универсальные списки > Меню списков.

Компонент относится к модулю Универсальные списки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE_ID | Указывается тип информационных блоков, откуда будет использоваться информация.
Шаблоны ссылок
Включить режим совместимости с поддержкой ЧПУ IS_SEF Установка флажка включает режим использвоания ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) | SEF_BASE_URL | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Основа ЧПУ URL списка | SEF_LIST_BASE_URL | Указывается основа для построения шаблона ссылок универсального списка.
URL списка | SEF_LIST_URL | Указывается шаблон ссылки на универсальный список.
[/di] SEF_BASE_URL, SEF_LIST_BASE_URL и SEF_LIST_URL.

Если режим поддержки ЧПУ выключен, то необходимо настроить [dw]следующие параметры:[/dw][di]
URL списка | LIST_URL | Указывается шаблон ссылки на универсальный список.
ID списка для подсветки пункта меню | LIST_ID | Указывается шаблон пункта меню для подсветки.
[/di] LIST_URL и LIST_ID.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

 <?$APPLICATION->IncludeComponent(
    "bitrix:lists.menu",
    "",
    Array(
        "IBLOCK_TYPE_ID" => "lists",
        "IS_SEF" => "N",
        "LIST_URL" => "lists.list.php?list_id=#list_id#",
        "LIST_ID" => $_REQUEST["list_id"],
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_NOTES" => ""
    )
); ?>


Скачивание файла

Описание lists.file

Компонент для скачивания файлов, привязанных к элементам списка с проверкой прав доступа. Компонент является стандартным, входит в дистрибутив модуля и содержит один шаблон .default.

Для скачивания файла нужно формировать ссылку, при переходе на которую будет вызываться этот компонент, в результате будет происходить скачивание файла.

В визуальном редакторе компонент расположен по пути: Контент > Универсальные списки > Скачивание файлов.

Компонент относится к модулю Универсальные списки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE_ID | Указывается тип информационных блоков, откуда будет использоваться информация.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока.
Раздел | SECTION_ID | Для выбранного инфоблока указывается идентификатор раздела.
Элемент | ELEMENT_ID | Указывается идентификатор элемента, к которому прикреплен файл.
Поле | FIELD_ID | Указывается идентификатор поля "Файл".
Файл | FILE_ID | Указывается идентификатор файла.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:lists.file", ".default", array(
    "IBLOCK_TYPE_ID" => COption::GetOptionString("lists", "socnet_iblock_type_id"),
    "IBLOCK_ID" => $arResult["VARIABLES"]["list_id"],
    "SECTION_ID" => $arResult["VARIABLES"]["section_id"],
    "ELEMENT_ID" => $arResult["VARIABLES"]["element_id"],
    "FIELD_ID" => $arResult["VARIABLES"]["field_id"],
    "FILE_ID" => $arResult["VARIABLES"]["file_id"],
    "SOCNET_GROUP_ID" => $arResult["VARIABLES"]["group_id"],
    ),
    $component
);?>


Google Maps

Компоненты Google Maps созданы на базе одноименного проекта компании Google. Для использования компонентов необходимо иметь ключ доступа.

Компоненты позволяют размещать на сайте карты, производить по ним поиск, создавать непосредственно на карте комментарии и задавать стартовую точку открытия карты.

Подраздел включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Google Maps
Google: поиск по адресу | map.google.search | Осуществляет отображение карты с сервиса Google Maps и предоставляет возможность поиска по адресу. Поддержка детального поиска (по улице и дому) осуществляется в соответствии с возможностями сервиса Google Maps.
Google: настраиваемая карта | map.google.view | Осуществляет отображение карты с сервиса Google Maps. Компонент позволяет выводить саму карту, задавать на ней стартовую позицию и добавлять на карту дополнительную информацию.


Инструкция получения ключа API Google

Для корректной работы компонентов с сервисами Google вам потребуется [dw]получить API ключи[/dw][di]Прочитать о том, как их получить можно здесь [image].[/di], а также настроить ряд библиотек.

В июне 2018 года Google запустил новый функционал Google Maps Platform [image], а c июля 2018 года вступил в силу новый тарифный план Google [image] с оплатой за использование API карт, маршрутов и мест (Maps, Routes or Places).

Процесс получения ключа вам поможет пройти специальный мастер:

  1. Войдите в свой аккаунт Google или же создайте новый;
  2. Перейдите по адресу https://cloud.google.com/maps-platform/ [image];
  3. Нажмите кнопку [dw]Get Started[/dw][di] [image] [/di].
  4. На верхней панели раскройте выпадающий список, кликните [dw]New project[/dw][di] [image] [/di], введите произвольное название и нажмите CREATE:

  5. Настройте свою систему оплаты за использование API. [dw]Создайте платежный аккаунт[/dw][di] [image] [/di].
    1. На первом шаге создания платежного аккаунта выберите страну, условия использования и нажмите [dw]Продолжить[/dw][di] [image] [/di].
    2. На втором шаге Google попросит ввести ваш номер телефона для верификации и пришлет на него код. [dw]Введите код[/dw][di] [image] [/di] в поле и нажмите VERIFY.
    3. Далее нужно будет внести данные [dw]банковской карточки[/dw][di] [image] [/di]. Google при этом [dw]проверит карточку[/dw][di]При проверке карточки Google выдает следующее уведомление:

      Доступ ко всем продуктам облачной платформы.
      Получите все необходимое для создания и запуска ваших приложений, веб-сайтов и служб, включая Firebase и API Карт Google. 300 долларов США бесплатно.
      Положите Google Cloud на работу с 300 долларами на счете, которые можно потратить в течение следующих 90 дней. Без автоматического списания после окончания бесплатного пробного периода.
      Мы просим вас указать кредитную карту, чтобы убедиться, что вы не робот. С вас не будет взиматься плата, если вы не перейдете на платную учетную запись вручную. [/di].

      Когда подключен платежный аккаунт, то на него ежемесячно начисляется бесплатно использование карт, маршрутов или мест на сумму в размере 200 долларов США. Это примерно до 28 000 запросов. Счет на оплату будет выставлен только после того, как использование Google Maps Platform превысит ежемесячный [dw]лимит в 200 долларов[/dw][di]У Google существуют разные кредиты. 200 долл/мес - это кредит для карт, маршрутов, мест. Вы можете использовать также кредит Google Cloud Platform (GCP) - 300 долл/3 мес. Он может покрывать как сервис Google Maps, так и другие облачные сервисы. Изучите документацию [image] Google Cloud для понимания, что покрывает каждый кредит.[/di].

  6. После подключения платежного аккаунта вы получите возможность выбрать и подключить [dw]необходимые сервисы[/dw][di] [image] [/di]: Google Maps JavaScript API, Google Maps Geocoding API, Google Maps Places API и другие. В дальнейшем, при необходимости, вы сможете подключать сервисы [dw]из библиотеки[/dw][di] [image] [/di].
    7. API-ключи могут понадобиться для подключения Google Images к Сайтам24

    Чтобы подключить возможность использовать в карточках Сайтов24 коллекцию картинок Google в библиотеке выберите и подключите сервис Custom Search API:

    В настройках модуля Сайты 24 (Настройки > Настройка Продукта > Настройки модулей > Сайты 24) укажите укажите ключ API для Google Images.

    После подключения можно будет выбирать в карточках картинки из коллекции Google:

  7. Выберите пункт меню API и сервисы -> Учетные данные и создайте их. При создании следует выбирать [dw]Ключ API[/dw][di] [image] [/di].
  8. Через несколько секунд [dw]ключ будет создан[/dw][di] [image] [/di].
  9. Перед его использованием примените ограничения для него. Минимально необходимые ограничения: протокол (HTTP) и источник перехода (ваш адрес портала в виде http://ваш_битрикс24.ru/ [image] *).

Теперь вы можете использовать этот ключ в [dw]настройках[/dw][di] Нажмите на рисунок, чтобы увеличить [/di] вашего портала.

API-ключи понадобятся для работы обновленного поля «Адрес»

Настройки модуля Адреса и местоположения описаны в курсе Администратор сервиса Битрикс24 (коробочная версия).

Чтобы в поле «Адрес» в реквизитах компаний автоматически выводились подсказки от Google или чтобы можно было указывать адрес непосредственно на карте:

понадобится 2 ключа:

  • Ключ с правами на Google Maps JavaScript API, Places API, Geocoding API для использования в браузере пользователя.
  • Ключ с правами на Google Places API, Geocoding API для использования на сервере.

Для первого ключа (использование в браузере) задайте ограничения по HTTP-источникам перехода, укажите источник перехода и допустимые API:

Для второго ключа (использование на сервере) задайте соответствующие ограничения по IP-адресам.

Ввести эти ключи нужно будет в настройках модуля:

Для просмотра уже созданных ключей перейдите по адресу https://console.developers.google.com/apis/credentials [image].


Google: настраиваемая карта

Описание map.google.view

Одностраничный компонент осуществляет отображение карты с сервиса Google Maps. Компонент позволяет выводить саму карту, задавать на ней стартовую позицию и добавлять на карту дополнительную информацию. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Google Maps > Google: настраиваемая карта.

Компонент относится к модулю Управление структурой.

Параметры

Поле | Параметр | Описание
Основные параметры
Ключ JavaScript API | API_KEY | Ключ можно получить по ссылке https://developers.google.com/maps/documentation/javascript/get-api-key.
Стартовый тип карты INIT_MAP_TYPE Указывается вид карты, который будет использоваться по умолчанию:
  • схема (MAP) - схематичная карта с именами улиц и объектов;
  • спутник (SATELLITE) - карта в виде фото со спутника;
  • гибрид (HYBRID) - карта в виде фото со спутника с наложенной на нее схемой основных дорог и объектов.
  • ландшафт (TERRAIN) - карта рельефа местности.
Данные выводимые на карте MAP_DATA По нажатию кнопки Изменить откроется окно Настройки карты, предназначенное для редактирования настроек карты:

Для смены стартовой позиции необходимо снять опцию зафиксировать, с помощью штатных инструментов масштабирования задать новое стартовое положение. После этого нужно вновь отметить опцию зафиксировать.

Для создания комментария на карте необходимо воспользоваться ссылкой Добавить точки. Двойным кликом на нужной точке на карте вызвать окно добавления текста комментария и ввести нужный текст. Число задаваемых точек не ограничено. После задания всех необходимых точек нужно завершить работу с помощью ссылки Закончить. Для удаления комментариев нужно навести указатель мыши на удаляемую запись и нажать на крестик, появившийся рядом с ней.

Для сохранения внесенных изменений нужно воспользоваться кнопкой Сохранить.
Ширина карты | MAP_WIDTH | Указывается ширина окна отображаемой карты в пикселях (px) или в процентах (%). Если параметр принмает значение AUTO, то ширина окна задается браузером, который будет растягивать его на все доступное место.
Высота карты | MAP_HEIGHT | Указывается высота окна отображаемой карты в пикселях (px) или в процентах (%).
Дополнительные настройки
Элементы управления CONTROLS Указываются необходимые элементы управления, которые будут отображены на карте:
  • Кнопки масштаба (SMALL_ZOOM_CONTROL) - кнопки Увеличить масштаб и Уменьшить масштаб для управления масштабированием;
  • Тип карты (TYPECONTROL) - кнопки Схема, Спутник или Гибрид для переключения типа карты;
  • Шкала масштаба (SCALELINE) - в левом нижнем углу будет отображена шкала масштаба, показывающая масштаб в футах/метрах/милях/километрах.
Настройки OPTIONS Задаются настройки для управление картой с помощью клавиатуры и мыши:
  • изменение масштаба колесом мыши (ENABLE_SCROLL_ZOOM) - позволяет изменять масштаб вращением колеса мыши;
  • изменение масштаба двойным щелчком мыши (ENABLE_DBLCLICK_ZOOM) - позволяет изменять масштаб карты двойным кликом мыши: левая кнопка - увеличение, правая кнопка - уменьшение;
  • перетаскивание карты (ENABLE_DRAGGING) - позволяет перетаскивать карту указателем мыши;
  • управление с клавиатуры (ENABLE_KEYBOARD) - позволяет управлять картой с помощью кнопок "+", "-", "стрелка вверх", "стрелка вниз", "стрелка влево", "стрелка вправо" на клавиатуре.
Идентификатор карты | MAP_ID | Указывается идентификатор карты. Задается произвольный код из цифр и букв латинского алфавита, который можно использовать при создании собственных клиентских сценариев.

Пример вызова

 <?$APPLICATION->IncludeComponent("bitrix:map.google.view","",Array(
        "API_KEY" => "",
        "INIT_MAP_TYPE" => "HYBRID",
        "MAP_DATA" => "a:4:{s:10:
            \"google_lat\";d:54.7078924801;s:10:
            \"google_lon\";d:20.5828726435;s:12:
            \"google_scale\";i:16;s:10:
            \"PLACEMARKS\";a:1:{i:0;a:3:{s:4:
            \"TEXT\";s:99:
            \"ООО \"1С-Битрикс\", г. Калининград, Московский проспект, 261.\";s:3:
            \"LON\";d:20.58321596625391;s:3:
            \"LAT\";d:54.70787388449525;}}}",
        "MAP_WIDTH" => "600",
        "MAP_HEIGHT" => "500",
        "CONTROLS" => array(
            "SMALL_ZOOM_CONTROL",
            "TYPECONTROL",
            "SCALELINE"
        ),
        "OPTIONS" => array(
            "ENABLE_SCROLL_ZOOM",
            "ENABLE_DBLCLICK_ZOOM",
            "ENABLE_DRAGGING",
            "ENABLE_KEYBOARD"
        ),
        "MAP_ID" => "gm_1"
    )
);?>


Google: поиск по адресу

Описание map.google.search

Одностраничный компонент осуществляет отображение карты с сервиса Google Maps и предоставляет возможность поиска по адресу. Поддержка детального поиска (по улице и дому) осуществляется в соответствии с возможностями сервиса Google Maps. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Google Maps > Google: поиск по адресу.

Компонент относится к модулю Управление структурой.

Параметры

Поле | Параметр | Описание
Основные параметры
Ключ JavaScript API | API_KEY | Ключ можно получить по ссылке https://developers.google.com/maps/documentation/javascript/get-api-key.
Стартовый тип карты INIT_MAP_TYPE Указывается вид карты, который будет использоваться по умолчанию:
  • схема (MAP) - схематичная карта с именами улиц и объектов;
  • спутник (SATELLITE) - карта в виде фото со спутника;
  • гибрид (HYBRID) - карта в виде фото со спутника с наложенной на нее схемой основных дорог и объектов;
  • ландшафт (TERRAIN) - карта рельефа местности со спутника с наложенной на нее схемой основных дорог и объектов.
Начальная позиция карты MAP_DATA По нажатию кнопки Изменить откроется окно Настройки карты, предназначенное для редактирования настроек карты:

Для поиска необходимого объекта/местоположения нужно использовать строку Найти на карте.

Для смены стартовой позиции необходимо снять опцию зафиксировать, с помощью штатных инструментов масштабирования задать новое стартовое положение. После этого нужно вновь отметить опцию зафиксировать.

Для сохранения внесенных изменений нужно воспользоватся кнопкой Сохранить.
Ширина карты | MAP_WIDTH | Указывается ширина окна отображаемой карты в пикселях (px) или в процентах (%). Если параметр принмает значение AUTO, то ширина окна задается браузером, который будет растягивать его на все доступное место.
Высота карты | MAP_HEIGHT | Указывается высота окна отображаемой карты в пикселях (px) или в процентах (%).
Дополнительные настройки
Элементы управления CONTROLS Указываются необходимые элементы управления, которые будут отображены на карте:
  • Кнопки масштаба (SMALL_ZOOM_CONTROL) - кнопки Увеличить масштаб и Уменьшить масштаб для управления масштабированием;
  • Тип карты (TYPECONTROL) - кнопки Схема, Спутник, Гибрид и Рельеф для переключения типа карты;
  • Шкала масштаба (SCALELINE) - в левом нижнем углу будет отображена шкала масштаба, показывающая масштаб в футах/метрах/милях/километрах.
Настройки OPTIONS Задаются настройки для управление картой с помощью клавиатуры и мыши:
  • изменение масштаба колесом мыши (ENABLE_SCROLL_ZOOM) - позволяет изменять масштаб вращением колеса мыши;
  • изменение масштаба двойным щелчком мыши (ENABLE_DBLCLICK_ZOOM) - позволяет изменять масштаб карты двойным кликом мыши: левая
  • перетаскивание карты (ENABLE_DRAGGING) - позволяет перетаскивать карту указателем мыши.
Идентификатор карты | MAP_ID | Указывается идентификатор карты. Задается произвольный код из цифр и букв латинского алфавита, который можно использовать при создании собственных клиентских сценариев.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:map.google.search",".default",Array(
        "INIT_MAP_TYPE" => "HYBRID",
        "MAP_DATA" => "a:3:{s:10:
            \"google_lat\";d:55.7383;s:10:
            \"google_lon\";d:37.5946;s:12:
            \"google_scale\";i:13;}",
        "MAP_WIDTH" => "600",
        "MAP_HEIGHT" => "500",
        "CONTROLS" => array(
            2=>"SMALL_ZOOM_CONTROL",
            4=>"TYPECONTROL",
            6=>"SCALELINE",
        ),
        "OPTIONS" => array(
            0=>"ENABLE_SCROLL_ZOOM",
            1=>"ENABLE_DBLCLICK_ZOOM",
            3=>"ENABLE_DRAGGING",
        ),
        "MAP_ID" => ""
    )
);?>


Highload инфоблоки

Подраздел предназначен для работы с произвольными наборами данных в условиях высоких нагрузок. Включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Запись детально | highloadblock.view | Выводит детальную информацию об одной записи заданного Highload-блока.
Список записей | highloadblock.list | Выводит список записей заданного Highload-блока.


Запись детально

Описание highloadblock.view

Одностраничный компонент, осуществляющий вывод детальной информации о записи Highload-блока. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Highload инфоблоки > Запись детально.

Компонент относится к модулю Highload-блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
ID инфоблока | BLOCK_ID | Указывается идентификатор одного из созданных в системе Highload-блоков.
ID записи | ROW_ID | Указывается идентификатор записи Highload-блока.
Путь к странице списка записей | LIST_URL | Путь к странице со списком всех записей Highload-блока.
Проверять права доступа | CHECK_PERMISSIONS | [Y|N] При отмеченной опции для текущего пользователя будет проверяться право доступа к Highload-блоку.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:highloadblock.view","",Array(
        "BLOCK_ID" => $_REQUEST['BLOCK_ID'],
        "CHECK_PERMISSIONS" => "Y",
        "ROW_ID" => $_REQUEST['ID'],
        "LIST_URL" => "list.php?IBLOCK_ID=#IBLOCK_ID#"
    )
);?>


Список записей

Описание highloadblock.list

Одностраничный компонент выводит список записей из одного Highload-блока. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Highload инфоблоки > Список записей.

Компонент относится к модулю Highload-блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
ID инфоблока | BLOCK_ID | Идентификатор Highload-блока, записи которого будут выводиться.
Путь к странице просмотра записи | DETAIL_URL | Задается адрес, ведущий на страницу с детальной информацией записи Highload-блока.
Разбить по страницам количеством | ROWS_PER_PAGE | Указывается количество записей Highload-блока, отображаемых на одной страницы.
Идентификатор страницы | PAGEN_ID | Идентификатор страницы для постраничной навигации.
Идентификатор фильтра | FILTER_NAME | Указывается идентификатор фильтра для передачи в компонент внешней фильтрации.
Поле сортировки | SORT_FIELD | Укажите поле, по которому компонент будет сортировать список.
Направление сортировки | SORT_ORDER | Укажите направление сортировки: по возрастанию или по убыванию.
Проверять права доступа | CHECK_PERMISSIONS | [Y|N] При отмеченной опции для текущего пользователя будет проверяться право доступа к Highload-блоку.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:highloadblock.list","",Array(
        "BLOCK_ID" => "1",
        "CHECK_PERMISSIONS" => "Y",
        "DETAIL_URL" => "detail.php?BLOCK_ID=#BLOCK_ID#&ROW_ID=#ID#",
        "FILTER_NAME" => "myfilter",
        "PAGEN_ID" => "page",
        "ROWS_PER_PAGE" => "5"
    )
);?>


RSS

Подраздел предназначен для работы с новостями другого сайта и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
RSS
RSS новости (экспорт) | rss.out | Предназначен для создания страницы, которая отдает выбранные новости вашего сайта в формате RSS.
RSS новости (импорт) | rss.show | Предназначен для импорта новостей с другого сайта.


RSS новости (импорт)

Компонент предназначен для импорта новостей с другого сайта.

Описание rss.show

Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > RSS > RSS новости (импорт).

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Адрес rss ленты | URL | Указывается адрес rss ленты сайта, с которого будет осуществляться импорт новостей.
Находятся ли новости вне канала (обычно нет) | OUT_CHANNEL | [Y|N] При отмеченной опции будет проверяться, находятся ли новости вне канала (обычно нет). Опцию необходимо отметить, если в составе rss-файла есть новости вне тега <channel>.
Количество новостей для показа (0 - не ограничивать) | NUM_NEWS | Параметр определяет количество новостей для показа (0 - не ограничивать).
Обработка содержимого rss канала PROCESS Параметр определяет способ вывода полученного сообщения:
  • без обработки - сообщение будет выведено в том виде, в котором получено;
  • преобразовать в текст - в сообщении будут удалены теги форматирования, оно будет выведено как текст;
  • экранировать html - сообщение будет выведено с сохранением тегов в виде текста.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:rss.show","",Array(
        "URL" => "http://www.1c-bitrix.ru/about/life/news/rss/",
        "OUT_CHANNEL" => "N",
        "PROCESS" => "NONE",
        "NUM_NEWS" => "10",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    ),
);?>


RSS новости (экспорт)

Компонент предназначен для создания страницы, которая отдает выбранные новости вашего сайта в формате RSS.

Описание rss.out

Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > RSS > RSS новости (экспорт).

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Информационный блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, информация из которого будет экспортироваться.
Раздел | SECTION_ID | Указывается числовой код, в котором передается идентификатор раздела. Поле может быть оставлено пустым, если указан Код раздела.
Код раздела | SECTION_CODE | Указывается символьный код раздела, из которого будут выбраны новости. Поле может быть оставлено пустым, если указан Раздел.
Количество новостей для экспорта | NUM_NEWS | Задается количество новостей для экспорта.
Количество дней для экспорта | NUM_DAYS | Указывается количество дней для экспорта новостей.
Источник данных
Поле для первой сортировки новостей SORT_BY1 Поле для первой сортировки новостей:
  • ID - по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FROM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X - по дате последнего изменения;
  • CREATED - по дате создания.
Направление для первой сортировки новостей SORT_ORDER1 Направление для первой сортировки новостей:
  • ASC – по возрастанию;
  • DECS – по убыванию.
Поле для второй сортировки новостей SORT_BY2 Поле для второй сортировки новостей:
  • ID - по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FROM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X - по дате последнего изменения;
  • CREATED - по дате создания.
Направление для второй сортировки новостей SORT_ORDER2 Направление для второй сортировки новостей:
  • ASC – по возрастанию;
  • DECS – по убыванию.
Фильтр | FILTER_NAME | Задается имя глобальной переменной для фильтрации новостей.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кешировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Параметры RSS
Время жизни (в минутах) | RSS_TTL | Указывается количество минут, на которые канал может кешироваться перед обновлением ресурса.
Экспортировать в диалект Яндекса | YANDEX | [Y|N] При отмеченной опции новости будут экспортироваться в диалект Яндекса.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:rss.out","",Array(
        "IBLOCK_TYPE" => "news",
        "IBLOCK_ID" => "3",
        "SECTION_ID" => "",
        "SECTION_CODE" => "",
        "NUM_NEWS" => "20",
        "NUM_DAYS" => "30",
        "RSS_TTL" => "60",
        "YANDEX" => "Y",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "FILTER_NAME" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y",
        "CACHE_FILTER" => "N"
    )
);?>


Wiki

Подраздел предназначен для коллективной работы над контентом страницы и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Комплексный Wiki компонент | wiki | Комплексный компонент позволяет вести полнофункциональную работу с Wiki.
Меню | wiki.menu | Выводит меню команд.
Страница | wiki.show | Выводит основную страницу Wiki.
Редактирование | wiki.edit | Выводит форму редактирования страницы.
Категории | wiki.categories | Выводит список категорий.
История | wiki.history | Выводит историю изменений страницы.
Обсуждения | wiki.discussion | Выводит обсуждение по статье.
Сравнение версий | wiki.history.diff | Выводит выводит тексты версий для сравнения.


Комплексный Wiki компонент

Описание wiki

Комплексный компонент позволяет вести полнофункциональную работу с Wiki, создавая физически только одну страницу. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Wiki > Wiki.

Компонент относится к модулю Wiki.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается тип информационных блоков, в котором будут храниться данные Wiki. Тип инфоблока создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Код информационного блока | IBLOCK_ID | Указывается информационный блок, в котором будут храниться данные Wiki. Инфоблок создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Имя Wiki-страницы | ELEMENT_NAME | Задается имя переменной в которой будет передаваться имя страницы. Должно совпадать с полем "Имя переменной для страницы".
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Указывается путь к странице пользователя. Используется в истории создании страницы для перехода на страницу профиля пользователя.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Для серверов на Windows каталог, указанный в этом поле, физически существовать не должен. Это связано с обработкой символа ":" в Windows.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - Шаблон пути к главной Wiki-странице;
  • post - Шаблон пути к Wiki-странице;
  • post_edit - Шаблон пути к странице редактирования Wiki-страницы;
  • categories - Шаблон пути к странице со списком категорий;
  • discussion - Шаблон пути к странице обсуждения;
  • history - Шаблон пути к странице истории изменений Wiki-страницы;
  • history_diff - Шаблон пути к странице сравнения версий Wiki-страницы;
  • search - Шаблон пути к странице поиска;
[/di] SEF_FOLDER и SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.

При выключенном режиме ЧПУ необходимо указать имена следующих переменных:
  • wiki_name - имя переменной для страницы;
  • oper - имя переменной для операции;
[/di] VARIABLE_ALIASES.
Дополнительные настройки
Название пункта меню для цепочки навигации | NAV_ITEM | В цепочку навигации будет включен пункт меню.
Устанавливать заголовок страницы | SET_TITLE | Название страницы будет установлено в качестве заголовка окна браузера.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | Странице будет установлен статус 404, если не найдена страница или раздел.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | В цепочку навигации будет включено название информационного блока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | Раздел Wiki будет включен в цепочку навигации.
Настройки обсуждения
Разрешить обсуждеие USE_REVIEW Дается разрешение на обсуждение статей Wiki. При включенной опции появляются [dw]дополнительные настройки.[/dw][di]
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Число сообщений форума, выводимое на одной странице.
USE_CAPTCHA | USE_CAPTCHA | Разрешает использование CAPTCHA при создании сообщений в форуме.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Если используется нестандартная папка со смайликами, укажите путь до нее.
ID форума для отзывов | FORUM_ID | Указать форум, который будет использован для обсуждения статей Wiki. Требуется предварительное создание форума.
Страница чтения темы (пусто - получить из настроек форума) | URL_TEMPLATES_READ | Указывается шаблон пути до темы форума с обсуждением статьи. Используется при выводе ссылки на обсуждение на странице статьи.
Показать ссылку на форум | SHOW_LINK_TO_FORUM | Разрешается показ ссылки на форум обсуждения статей.
Начинать тему текстом элемента | POST_FIRST_MESSAGE | Первое сообщение в форуме будет цитировать текст статьи.
[/di]

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:wiki",
    "",
    Array(
        "SEF_MODE" => "Y",
        "PATH_TO_USER" => "",
        "IBLOCK_TYPE" => "wiki",
        "IBLOCK_ID" => "",
        "ELEMENT_NAME" => $_REQUEST["title"],
        "USE_REVIEW" => "Y",
        "MESSAGES_PER_PAGE" => "10",
        "USE_CAPTCHA" => "Y",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "FORUM_ID" => "",
        "URL_TEMPLATES_READ" => "",
        "SHOW_LINK_TO_FORUM" => "N",
        "POST_FIRST_MESSAGE" => "N",
        "NAV_ITEM" => "",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "N",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "N",
        "ADD_SECTIONS_CHAIN" => "N",
        "SEF_FOLDER" => "/about/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "post" => "#wiki_name#/",
            "post_edit" => "#wiki_name#/edit/",
            "categories" => "categories/",
            "discussion" => "#wiki_name#/discussion/",
            "history" => "#wiki_name#/history/",
            "history_diff" => "#wiki_name#/history/diff/",
            "search" => "search/"
        ),
        "VARIABLE_ALIASES" => Array(
            "wiki_name" => "wiki_name",
            "oper" => "oper"

        )
    )
);?>


Меню

Описание wiki.menu

Компонент выводит меню команд. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Wiki > Меню.

Компонент относится к модулю Wiki.

Параметры

Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается тип информационных блоков, в котором будут храниться данные Wiki. Тип инфоблока создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Код информационного блока | IBLOCK_ID | Указывается информационный блок, в котором будут храниться данные Wiki. Инфоблок создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Имя Wiki-страницы | ELEMENT_NAME | Задается имя переменной в которой будет передаваться имя страницы. Должно совпадать с полем "Имя переменной для страницы".
Тип меню MENU_TYPE Параметр задает вид меню. Параметр принимает значения:
  • page - Обсуждение не выводится.
  • full - Обсуждение выводится.
Разрешить обсуждение | USE_REVIEW | Дается разрешение на обсуждение статей Wiki.
Шаблоны ссылок
Шаблон пути к Wiki-странице | PATH_TO_POST | Указывается путь к главной странице Wiki.
Шаблон пути к странице редактирования Wiki-страницы | PATH_TO_POST_EDIT | Указывается путь к странице редактирования страницы.
Шаблон пути к странице со списком категорий | PATH_TO_CATEGORIES | Указывается путь к странице со списком категорий.
Шаблон пути к странице обсуждения | PATH_TO_DISCUSSION | Указывается путь к странице форума обсуждения статьи.
Шаблон пути к странице поиска | PATH_TO_SEARCH | Указывается путь к странице поиска.
Шаблон пути к странице истории изменений Wiki-страницы | PATH_TO_HISTORY | Указывается путь к странице истории изменений страницы.
Шаблон пути к странице сравнения версий Wiki-страницы | PATH_TO_HISTORY_DIFF | Указывается путь к странице сравнения версий страницы.
Шаблон пути к странице пользователя | PATH_TO_USER | Указывается путь к странице пользователя. Используется в истории создании страницы для перехода на страницу профиля пользователя.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной в которой передается имя страницы
Имя переменной для операции | OPER_VAR | Указывается имя переменной, по которой определяется текущая операция на странице.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:wiki.menu",
    "",
    Array(
        "PATH_TO_POST" => "",
        "PATH_TO_POST_EDIT" => "",
        "PATH_TO_CATEGORIES" => "",
        "PATH_TO_DISCUSSION" => "",
        "PATH_TO_SEARCH" => "",
        "PATH_TO_HISTORY" => "",
        "PATH_TO_HISTORY_DIFF" => "",
        "PATH_TO_USER" => "",
        "PAGE_VAR" => "title",
        "OPER_VAR" => "oper",
        "IBLOCK_TYPE" => "wiki",
        "IBLOCK_ID" => "",
        "ELEMENT_NAME" => $_REQUEST["title"],
        "USE_REVIEW" => "Y",
        "MENU_TYPE" => "page"
    ),
false
);?>


Страница

Описание wiki.show

Компонент выводит основную страницу Wiki. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Wiki > Страница.

Компонент относится к модулю Wiki.

Параметры

Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается тип информационных блоков, в котором будут храниться данные Wiki. Тип инфоблока создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Код информационного блока | IBLOCK_ID | Указывается информационный блок, в котором будут храниться данные Wiki. Инфоблок создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Имя Wiki-страницы | ELEMENT_NAME | Задается имя переменной в которой будет передаваться имя страницы. Должно совпадать с полем "Имя переменной для страницы".
Шаблоны ссылок
Шаблон пути к Wiki-странице | PATH_TO_POST | Указывается путь к главной странице Wiki.
Шаблон пути к странице со списком категорий | PATH_TO_CATEGORIES | Указывается путь к странице со списком категорий.
Шаблон пути к странице обсуждения | PATH_TO_DISCUSSION | Указывается путь к странице форума обсуждения статьи.
Шаблон пути к странице поиска | PATH_TO_SEARCH | Указывается путь к странице поиска.
Шаблон пути к странице истории изменений Wiki-страницы | PATH_TO_HISTORY | Указывается путь к странице истории изменений страницы.
Шаблон пути к странице сравнения версий Wiki-страницы | PATH_TO_HISTORY_DIFF | Указывается путь к странице сравнения версий страницы.
Шаблон пути к странице пользователя | PATH_TO_USER | Указывается путь к странице пользователя. Используется в истории создании страницы для перехода на страницу профиля пользователя.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | Название страницы будет установлено в качестве заголовка окна браузера.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | Странице будет установлен статус 404, если не найдена страница или раздел.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | В цепочку навигации будет включено название информационного блока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | Раздел Wiki будет включен в цепочку навигации.
Имена переменных
Имя переменной для страницы | VARIABLE_ALIASES | Указывается имя переменной в которой передается имя страницы
Имя переменной для операции | VARIABLE_ALIASES | Указывается имя переменной, по которой определяется текущая операция на странице.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:wiki.show","",Array(
        "PATH_TO_POST_EDIT" => "",
        "PATH_TO_CATEGORIES" => "",
        "PATH_TO_DISCUSSION" => "",
        "PATH_TO_SEARCH" => "",
        "PATH_TO_HISTORY" => "",
        "PATH_TO_HISTORY_DIFF" => "",
        "PATH_TO_USER" => "",
        "PAGE_VAR" => "title",
        "OPER_VAR" => "oper",
        "IBLOCK_TYPE" => "wiki",
        "IBLOCK_ID" => "",
        "ELEMENT_NAME" => $_REQUEST["title"],
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_NOTES" => "",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "N",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "N",
        "ADD_SECTIONS_CHAIN" => "N"
    )
);?>


Редактирование

Описание wiki.edit

Компонент выводит форму редактирования страницы. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Wiki > Редактирование.

Компонент относится к модулю Wiki.

Параметры

Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается тип информационных блоков, в котором будут храниться данные Wiki. Тип инфоблока создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Код информационного блока | IBLOCK_ID | Указывается информационный блок, в котором будут храниться данные Wiki. Инфоблок создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Имя Wiki-страницы | ELEMENT_NAME | Задается имя переменной в которой будет передаваться имя страницы. Должно совпадать с полем "Имя переменной для страницы".
Шаблоны ссылок
Шаблон пути к Wiki-странице | PATH_TO_POST | Указывается путь к главной странице Wiki.
Шаблон пути к странице со списком категорий | PATH_TO_CATEGORIES | Указывается путь к странице со списком категорий.
Шаблон пути к странице обсуждения | PATH_TO_DISCUSSION | Указывается путь к странице форума обсуждения статьи.
Шаблон пути к странице истории изменений Wiki-страницы | PATH_TO_HISTORY | Указывается путь к странице истории изменений страницы.
Шаблон пути к странице сравнения версий Wiki-страницы | PATH_TO_HISTORY_DIFF | Указывается путь к странице сравнения версий страницы.
Шаблон пути к странице пользователя | PATH_TO_USER | Указывается путь к странице пользователя. Используется в истории создании страницы для перехода на страницу профиля пользователя.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | Название страницы будет установлено в качестве заголовка окна браузера.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | Странице будет установлен статус 404, если не найдена страница или раздел.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | В цепочку навигации будет включено название информационного блока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | Раздел Wiki будет включен в цепочку навигации.
Имена переменных
Имя переменной для страницы | VARIABLE_ALIASES | Указывается имя переменной в которой передается имя страницы
Имя переменной для операции | VARIABLE_ALIASES | Указывается имя переменной, по которой определяется текущая операция на странице.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:wiki.edit",
    "",
    Array(
        "PATH_TO_POST" => "",
        "PATH_TO_CATEGORIES" => "",
        "PATH_TO_DISCUSSION" => "",
        "PATH_TO_HISTORY" => "",
        "PATH_TO_HISTORY_DIFF" => "",
        "PATH_TO_USER" => "",
        "PAGE_VAR" => "title",
        "OPER_VAR" => "oper",
        "IBLOCK_TYPE" => "wiki",
        "IBLOCK_ID" => "",
        "ELEMENT_NAME" => $_REQUEST["title"],
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "N",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "N",
        "ADD_SECTIONS_CHAIN" => "N"
    )
);?>


Категории

Описание wiki.categories

Компонент выводит список категорий. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Wiki > Категории.

Компонент относится к модулю Wiki.

Параметры

Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается тип информационных блоков, в котором будут храниться данные Wiki. Тип инфоблока создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Код информационного блока | IBLOCK_ID | Указывается информационный блок, в котором будут храниться данные Wiki. Инфоблок создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Количество категорий на странице | CATEGORY_COUNT | Задается число категорий, которое будет выводится на странице. Если число категорий превысит указанное число, начнется постраничная навигация.
Шаблоны ссылок
Шаблон пути к Wiki-странице | PATH_TO_POST | Указывается путь к главной странице Wiki.
Дополнительные настройки
Имя переменной для страницы | VARIABLE_ALIASES | Указывается имя переменной в которой передается имя страницы
Имя переменной для операции | VARIABLE_ALIASES | Указывается имя переменной, по которой определяется текущая операция на странице.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:wiki.categories",
    "",
    Array(
        "PATH_TO_POST" => "",
        "PAGE_VAR" => "title",
        "OPER_VAR" => "oper",
        "IBLOCK_TYPE" => "wiki",
        "IBLOCK_ID" => "",
        "CATEGORY_COUNT" => "20"
    )
);?>


История

Описание wiki.history

Компонент выводит историю изменений страницы. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Wiki > История.

Компонент относится к модулю Wiki.

Параметры

Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается тип информационных блоков, в котором будут храниться данные Wiki. Тип инфоблока создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Код информационного блока | IBLOCK_ID | Указывается информационный блок, в котором будут храниться данные Wiki. Инфоблок создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Имя Wiki-страницы | ELEMENT_NAME | Задается имя переменной в которой будет передаваться имя страницы. Должно совпадать с полем "Имя переменной для страницы".
Количество версий на странице | HISTORY_COUNT | Задается число версий, которые будут выводиться на одной странице. Если число версий превышает указанное число, начнется постраничная навигация.
Шаблоны ссылок
Шаблон пути к Wiki-странице | PATH_TO_POST | Указывается путь к главной странице Wiki.
Шаблон пути к странице редактирования Wiki-страницы | PATH_TO_POST_EDIT | Указывается путь к странице редактирования Wiki-страницы.
Шаблон пути к странице со списком категорий | PATH_TO_CATEGORIES | Указывается путь к странице со списком категорий.
Шаблон пути к странице обсуждения | PATH_TO_DISCUSSION | Указывается путь к странице форума обсуждения статьи.
Шаблон пути к странице сравнения версий Wiki-страницы | PATH_TO_HISTORY_DIFF | Указывается путь к странице сравнения версий страницы.
Шаблон пути к странице пользователя | PATH_TO_USER | Указывается путь к странице пользователя. Используется в истории создании страницы для перехода на страницу профиля пользователя.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | Название страницы будет установлено в качестве заголовка окна браузера.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | Странице будет установлен статус 404, если не найдена страница или раздел.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | В цепочку навигации будет включено название информационного блока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | Раздел Wiki будет включен в цепочку навигации.
Имена переменных
Имя переменной для страницы | VARIABLE_ALIASES | Указывается имя переменной в которой передается имя страницы
Имя переменной для операции | VARIABLE_ALIASES | Указывается имя переменной, по которой определяется текущая операция на странице.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:wiki.history",
    "",
    Array(
        "PATH_TO_POST" => "",
        "PATH_TO_POST_EDIT" => "",
        "PATH_TO_CATEGORIES" => "",
        "PATH_TO_DISCUSSION" => "",
        "PATH_TO_HISTORY_DIFF" => "",
        "PATH_TO_USER" => "",
        "PAGE_VAR" => "title",
        "OPER_VAR" => "oper",
        "IBLOCK_TYPE" => "wiki",
        "IBLOCK_ID" => "",
        "ELEMENT_NAME" => $_REQUEST["title"],
        "HISTORY_COUNT" => "20",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_NOTES" => "",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "N",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "N",
        "ADD_SECTIONS_CHAIN" => "N"
    ),
false
);?>


Обсуждение

Описание wiki.discussion

Компонент выводит обсуждение по статье. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Wiki > Обсуждение.

Компонент относится к модулю Wiki.

Параметры

Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается тип информационных блоков, в котором будут храниться данные Wiki. Тип инфоблока создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Код информационного блока | IBLOCK_ID | Указывается информационный блок, в котором будут храниться данные Wiki. Инфоблок создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Имя Wiki-страницы | ELEMENT_NAME | Задается имя переменной в которой будет передаваться имя страницы. Должно совпадать с полем "Имя переменной для страницы".
Шаблоны ссылок
Шаблон пути к Wiki-странице | PATH_TO_POST | Указывается путь к главной странице Wiki.
Шаблон пути к странице редактирования Wiki-страницы | PATH_TO_POST_EDIT | Указывается путь к странице редактирования страницы.
Шаблон пути к странице истории изменений Wiki-страницы | PATH_TO_HISTORY | Указывается путь к странице истории изменений страницы.
Шаблон пути к странице сравнения версий Wiki-страницы | PATH_TO_HISTORY_DIFF | Указывается путь к странице сравнения версий страницы.
Шаблон пути к странице пользователя | PATH_TO_USER | Указывается путь к странице пользователя. Используется в истории создании страницы для перехода на страницу профиля пользователя.
Дополнительные настройки
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Число сообщений форума, выводимое на одной странице. Если число сообщений превышает указанное число, начинается постраничная навигация.
USE_CAPTCHA | USE_CAPTCHA | Разрешает использование CAPTCHA при создании сообщений в форуме.
ID форума для отзывов | FORUM_ID | Указать форум, который будет использован для обсуждения статей Wiki. Требуется предварительное создание форума.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Если используется нестандартная папка со смайликами, укажите путь до нее.
Страница чтения темы (пусто - получить из настроек форума) | URL_TEMPLATES_READ | Указывается шаблон пути до темы форума с обсуждением статьи. Используетс при выводе ссылки на обсуждение на странице статьи.
Показать ссылку на форум | SHOW_LINK_TO_FORUM | Указывается ссылка на форум для обсуждения.
Начинать тему текстом элемента | POST_FIRST_MESSAGE | Первое сообщение в форуме будет цитировать текст статьи.
Устанавливать заголовок страницы | SET_TITLE | Название страницы будет установлено в качестве заголовка окна браузера.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | Странице будет установлен статус 404, если не найдена страница или раздел.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | В цепочку навигации будет включено название информационного блока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | Раздел Wiki будет включен в цепочку навигации.
Имена переменных
Имя переменной для страницы | VARIABLE_ALIASES | Указывается имя переменной в которой передается имя страницы
Имя переменной для операции | VARIABLE_ALIASES | Указывается имя переменной, по которой определяется текущая операция на странице.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:wiki.discussion",
    "",
    Array(
        "PATH_TO_POST" => "",
        "PATH_TO_POST_EDIT" => "",
        "PATH_TO_HISTORY" => "",
        "PATH_TO_HISTORY_DIFF" => "",
        "PATH_TO_USER" => "",
        "PAGE_VAR" => "title",
        "OPER_VAR" => "oper",
        "IBLOCK_TYPE" => "wiki",
        "IBLOCK_ID" => "",
        "ELEMENT_NAME" => $_REQUEST["title"],
        "MESSAGES_PER_PAGE" => "10",
        "USE_CAPTCHA" => "Y",
        "FORUM_ID" => "",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "URL_TEMPLATES_READ" => "",
        "SHOW_LINK_TO_FORUM" => "N",
        "POST_FIRST_MESSAGE" => "N",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "N",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "N",
        "ADD_SECTIONS_CHAIN" => "N"
    ),
false
);?>


Сравнение версий

Описание wiki.history.diff

Компонент выводит тексты версий для сравнения. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Wiki > Сравнение версий.

Компонент относится к модулю Wiki.

Параметры

Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается тип информационных блоков, в котором будут храниться данные Wiki. Тип инфоблока создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Код информационного блока | IBLOCK_ID | Указывается информационный блок, в котором будут храниться данные Wiki. Инфоблок создается при инсталляции дистрибутива или установке модуля. Если не создан, то требуется создание вручную.
Имя Wiki-страницы | ELEMENT_NAME | Задается имя переменной в которой будет передаваться имя страницы. Должно совпадать с полем "Имя переменной для страницы".
Количество версий на странице | HISTORY_COUNT | Указывается число версий, выводимых на одной странице. Если число версий превышает указанное число, начнется постраничная навигация
Шаблоны ссылок
Шаблон пути к Wiki-странице | PATH_TO_POST | Указывается путь к главной странице Wiki.
Шаблон пути к странице редактирования Wiki-страницы | PATH_TO_POST_EDIT | Указывается путь к странице редактирования статьи.
Шаблон пути к странице со списком категорий | PATH_TO_CATEGORIES | Указывается путь к странице со списком категорий.
Шаблон пути к странице обсуждения | PATH_TO_DISCUSSION | Указывается путь к странице форума обсуждения статьи.
Шаблон пути к странице истории изменений Wiki-страницы | PATH_TO_HISTORY | Указывается путь к странице истории изменений страницы.
Шаблон пути к странице пользователя | PATH_TO_USER | Указывается путь к странице пользователя. Используется в истории создании страницы для перехода на страницу профиля пользователя.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | Название страницы будет установлено в качестве заголовка окна браузера.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | Странице будет установлен статус 404, если не найдена страница или раздел.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | В цепочку навигации будет включено название информационного блока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | Раздел Wiki будет включен в цепочку навигации.
Имена переменных
Имя переменной для страницы | VARIABLE_ALIASES | Указывается имя переменной в которой передается имя страницы
Имя переменной для операции | VARIABLE_ALIASES | Указывается имя переменной, по которой определяется текущая операция на странице.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:wiki.history.diff",
    "",
    Array(
        "PATH_TO_POST" => "",
        "PATH_TO_POST_EDIT" => "",
        "PATH_TO_CATEGORIES" => "",
        "PATH_TO_DISCUSSION" => "",
        "PATH_TO_HISTORY" => "",
        "PATH_TO_USER" => "",
        "PAGE_VAR" => "title",
        "OPER_VAR" => "oper",
        "IBLOCK_TYPE" => "wiki",
        "IBLOCK_ID" => "",
        "ELEMENT_NAME" => $_REQUEST["title"],
        "HISTORY_COUNT" => "20",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_NOTES" => "",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "N",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "N",
        "ADD_SECTIONS_CHAIN" => "N"
    ),
false
);?>


Валюты

Подраздел Валюты позволяет управлять валютами и их курсами. Он включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Таблица курсов валют | currency.rates | Служит для отображения таблицы курсов валют в соответствии с их форматом.


Таблица курсов валют

Отправить отзыв по этому разделу
Компоненты>Контент>Валюты>Таблица курсов валют

Валюты::Таблица курсов валют

Компонент служит для отображения таблицы курсов валют в соответствии с их форматом. Компонент стандартный и входит в дистрибутив модуля.

Описание currency.rates

В структуре визуального редактора компонент расположен по пути Контент > Валюты > Таблица курсов валют.

Компонент относится к модулю Валюты.

Параметры

Поле | Параметр | Описание
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Массив "исходных" валют для перевода | arrCURRENCY_FROM | Задаются валюты, курсы которых должны быть отображены.
Валюта, к которой приводятся "исходные" валюты | CURRENCY_BASE | Указывается валюта, по отношению к которой считаются курсы остальных валют (базовая валюта).
День, на который показывать курсы валют (в формате "Y-m-d") | RATE_DAY | Указывается день, на который будут показываться курсы валют (в формате "Y-m-d"). Если день не указан, то будет отображен текущий курс.
Показывать курс валют с ЦБ РФ | SHOW_CB | [Y|N] При отмеченной опции отдельной табличкой будет выведен курс ЦБ РФ.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:currency.rates","",Array(
        "arrCURRENCY_FROM" => Array("RUB", "USD", "EUR"),
        "CURRENCY_BASE" => "RUB",
        "RATE_DAY" => "",
        "SHOW_CB" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400"
    )
);?>


Добавление элементов

Подраздел предназначен для работы с элементами инфоблока и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Добавление элементов
Добавление элементов инфоблока (комплексный компонент) | iblock.element.add | Осуществляет вывод списка элементов указанного инфоблока, добавление/редактирование элементов и их удаление в зависимости от прав пользователя.
Форма добавления / редактирования | iblock.element.add.form | Осуществляет вывод формы создания (редактирования) элемента указанного информационного блока.
Список своих элементов | iblock.element.add.list | Осуществляет вывод списка доступных пользователю элементов указанного инфоблока, ссылок Добавить, Редактировать, Удалить.


Добавление элементов инфоблока (комплексный компонент)

Описание iblock.element.add

Комплексный компонент осуществляет вывод списка элементов указанного инфоблока, добавление/редактирование элементов и их удаление в зависимости от прав пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Добавление элементов > Добавление элементов инфоблока.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Параметры компонента
Количество элементов на странице | NAV_ON_PAGE | Задается количество элементов на одной странице. Все элементы будут выведены с помощью постраничной навигации.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления элемента.
Сообщение об успешном добавлении | USER_MESSAGE_ADD | Задается сообщение, которое выводится при успешном добавлении элемента.
Сообщение об успешном сохранении | USER_MESSAGE_EDIT | Задается сообщение, которое выводится при успешном сохранении элемента.
Размер полей ввода | DEFAULT_INPUT_SIZE | Указывается размер полей ввода в форме создания/редактирования элемента.
Использовать настройки инфоблока для обработки изображений | RESIZE_IMAGES | [Y|N] При отмеченной функции элементы, добавленные через публичную часть будут преобразовываться согласно настройкам инфоблока.
Источник данных
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается необходимый информационный блок.
Свойства инфоблока
Свойства, выводимые на редактирование | PROPERTY_CODES | Указываются поля и свойства инфоблока, которые выводятся в форме создания/редактирования элемента.
Свойства, обязательные для заполнения PROPERTY_CODES_REQUIRED Указываются обязательно заполняемые поля и свойства инфоблока в форме создания/редактирования элемента.

Примечание: указанные здесь поля и свойства должны быть обязательно указаны в параметре PROPERTY_CODES.
Параметры доступа
Группы пользователей, имеющие право на добавление/редактирование | GROUPS | Указываются группы пользователей, имеющие право на добавление/редактирование элементов инфоблока.
Редактирование возможно для статуса | STATUS | Указываются статусы, находясь в которых элементы будут доступны для редактирования и удаления.
Статус после сохранения | STATUS_NEW | Указывается статус, в который переводятся элементы при их создании/редактировании.
Разрешать редактирование | ALLOW_EDIT | [Y|N] При отмеченной опции будут выведены ссылки на редактирование доступных пользователю элементов.
Разрешать удаление | ALLOW_DELETE | [Y|N] При отмеченной опции будут выведены ссылки на удаление доступных пользователю элементов.
Привязка к пользователю ELEMENT_ASSOC Задается привязка к пользователю:
  • создателю (CREATED_BY) - привязка по создателю: пользователю будут показаны только созданные им элементы.
  • по свойству инфоблока --> (PROPERTY_ID) - привязка по свойству инфоблока. В этом случае доступен параметр ELEMENT_ASSOC_PROPERTY.
по свойству инфоблока --> | ELEMENT_ASSOC_PROPERTY | Указывается свойство, по которому выполняется привязка. Компонент поддерживает отображение свойств только типов: Строка, Число, Список, Файл, Дата/Время.
Ограничить кол-во элементов для одного пользователя | MAX_USER_ENTRIES | Указывается максимальное количество элементов, которые может добавить пользователь.
Ограничить кол-во рубрик, в которые можно добавлять элемент | MAX_LEVELS | Указывается максимальное количество разделов инфоблока, в которые пользователь может добавить один и тот же элемент.
Разрешить добавление только на последний уровень рубрикатора | LEVEL_LAST | [Y|N] При отмеченной опции пользователям разрешено добавлять элементы только в последний раздел дерева разделов инфоблока.
Максимальный размер загружаемых файлов, байт (0 - не ограничивать) | MAX_FILE_SIZE | Указывается максимальный размер загружаемых файлов. Если указано 0, то размер файлов не ограничен.
Использовать упрощенный визуальный редактор для редактирования текста анонса | PREVIEW_TEXT_USE_HTML_EDITOR | Разрешает использование упрощенного редактора вместо полного при добавлении и редактировании.
Использовать упрощенный визуальный редактор для редактирования подробного текста | DETAIL_TEXT_USE_HTML_EDITOR | Разрешает использование упрощенного редактора вместо полного при добавлении и редактировании.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
[/di] SEF_FOLDER.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Собственные названия полей
*поле_инфоблока* CUSTOM_TITLE_<поле_инфоблока> Задаются названия полей инфоблока для отображения пользователям. Вместо <поле_инфоблока> указывается следующее:
  • NAME - наименование;
  • TAGS - теги;
  • DATE_ACTIVE_FROM - дата начала;
  • DATE_ACTIVE_TO - дата завершения;
  • IBLOCK_SECTION - раздел инфоблока;
  • PREVIEW_TEXT - текст анонса;
  • PREVIEW_PICTURE - картинка анонса;
  • DETAIL_TEXT - подробный текст;
  • DETAIL_PICTURE - подробная картинка.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:iblock.element.add","",Array(
        "SEF_MODE" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "articles",
        "IBLOCK_ID" => "2",
        "PROPERTY_CODES" => Array("NAME", "TAGS", "DATE_ACTIVE_FROM", "DATE_ACTIVE_TO", "IBLOCK_SECTION", "PREVIEW_TEXT", "PREVIEW_PICTURE", "DETAIL_TEXT", "DETAIL_PICTURE", "1", "2", "3", "4", "5", "6", "7"),
        "PROPERTY_CODES_REQUIRED" => Array("NAME", "TAGS", "DATE_ACTIVE_FROM", "DATE_ACTIVE_TO", "IBLOCK_SECTION", "PREVIEW_TEXT", "PREVIEW_PICTURE", "DETAIL_TEXT", "DETAIL_PICTURE", "1", "2", "3", "4", "5", "6", "7"),
        "GROUPS" => Array("1", "2", "3", "4", "5", "6", "7", "8"),
        "STATUS" => Array("2", "3", "1"),
        "STATUS_NEW" => "2",
        "ALLOW_EDIT" => "Y",
        "ALLOW_DELETE" => "Y",
        "ELEMENT_ASSOC" => "CREATED_BY",
        "NAV_ON_PAGE" => "10",
        "MAX_USER_ENTRIES" => "100000",
        "MAX_LEVELS" => "100000",
        "LEVEL_LAST" => "Y",
        "USE_CAPTCHA" => "Y",
        "USER_MESSAGE_ADD" => "",
        "USER_MESSAGE_EDIT" => "",
        "DEFAULT_INPUT_SIZE" => "30",
        "RESIZE_IMAGES" => "N",
        "MAX_FILE_SIZE" => "0",
        "PREVIEW_TEXT_USE_HTML_EDITOR" => "N",
        "DETAIL_TEXT_USE_HTML_EDITOR" => "N",
        "CUSTOM_TITLE_NAME" => "",
        "CUSTOM_TITLE_TAGS" => "",
        "CUSTOM_TITLE_DATE_ACTIVE_FROM" => "",
        "CUSTOM_TITLE_DATE_ACTIVE_TO" => "",
        "CUSTOM_TITLE_IBLOCK_SECTION" => "",
        "CUSTOM_TITLE_PREVIEW_TEXT" => "",
        "CUSTOM_TITLE_PREVIEW_PICTURE" => "",
        "CUSTOM_TITLE_DETAIL_TEXT" => "",
        "CUSTOM_TITLE_DETAIL_PICTURE" => "",
        "SEF_FOLDER" => "/",
        "AJAX_OPTION_SHADOW" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "VARIABLE_ALIASES" => Array(
        )
    ),
);?>


Список своих элементов

Описание iblock.element.add.list

Компонент осуществляет вывод списка доступных пользователю элементов указанного инфоблока, ссылок Добавить, Редактировать, Удалить. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Добавление элементов >Список своих элементов.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Параметры компонента
Страница редактирования элемента | EDIT_URL | Указывается адрес страницы редактирования элемента.
Количество элементов на странице | NAV_ON_PAGE | Задается количество элементов на одной странице. Все элементы будут выведены с помощью постраничной навигации.
Ограничить кол-во элементов для одного пользователя | MAX_USER_ENTRIES | Задается максимальное количество элементов, которое может добавить пользователь.
Источник данных
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор необходимого информационного блока.
Параметры доступа
Группы пользователей, имеющие право на добавление/редактирование | GROUPS | Указываются группы пользователей, имеющие право на добавление/редактирование элементов инфоблока.
Редактирование возможно для статуса | STATUS | Указываются статусы, находясь в которых элементы будут отображаться пользователям.
Привязка к пользователю ELEMENT_ASSOC Задается привязка к пользователю:
  • никому (N) - нет привязки, элементы не показываются всем пользователям. В этом случае параметры ALLOW_EDIT и ALLOW_DELETE не доступны.
  • создателю (CREATED_BY) - привязка по создателю: пользователю будут показаны только созданные им элементы.
  • по свойству инфоблока --> (PROPERTY_ID) - привязка по свойству инфоблока. В этом случае доступен параметр ELEMENT_ASSOC_PROPERTY.
по свойству инфоблока --> | ELEMENT_ASSOC_PROPERTY | Указывается свойство, по которому выполняется привязка.
Разрешать редактирование | ALLOW_EDIT | [Y|N] При отмеченной опции будут выведены ссылки на редактирование доступных пользователю элементов.
Разрешать удаление | ALLOW_DELETE | [Y|N] При отмеченной опции будут выведены ссылки на удаление доступных пользователю элементов.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры: [/dw][di]
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
[/di] SEF_FOLDER.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:iblock.element.add.list","",Array(
        "SEF_MODE" => "Y",
        "IBLOCK_TYPE" => "articles",
        "IBLOCK_ID" => "2",
        "GROUPS" => Array("1", "2", "3", "4", "5", "6", "7", "8"),
        "STATUS" => Array("2", "3", "1"),
        "EDIT_URL" => "",
        "ELEMENT_ASSOC" => "PROPERTY_ID",
        "ELEMENT_ASSOC_PROPERTY" => "2",
        "ALLOW_EDIT" => "Y",
        "ALLOW_DELETE" => "Y",
        "NAV_ON_PAGE" => "10",
        "MAX_USER_ENTRIES" => "100000",
        "SEF_FOLDER" => "/",
        "VARIABLE_ALIASES" => Array(
        )
    )
);?>


Форма добавления / редактирования

Компонент осуществляет вывод формы создания (редактирования) элемента указанного информационного блока. Компонент стандартный и входит в дистрибутив модуля. В визуальном редакторе компонент расположен по пути: Контент > Добавление элементов > Форма добавления / редактирования. Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается информационный блок, элементы которого необходимо создавать (редактировать).
Параметры компонента
Статус после сохранения STATUS_NEW Значение поля зависит от того в каком режиме используется инфоблок:
  • Обычный: с какой активностью создаются элементы (активный/неактивный).
  • В режиме документооборота: указывается статус, в который переводятся элементы при их создании/редактировании.
  • В режиме бизнес-процессов: устанавливается статус снять с публикации.
Страница со списком своих элементов | LIST_URL | Задается адрес страницы со списком доступных пользователю элементов. После обновления данных редирект происходит именно на эту страницу.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления элемента.
Сообщение об успешном сохранении | USER_MESSAGE_EDIT | Задается сообщение, которое выводится при успешном сохранении элемента.
Сообщение об успешном добавлении | USER_MESSAGE_ADD | Задается сообщение, которое выводится при успешном добавлении элемента.
Размер полей ввода | DEFAULT_INPUT_SIZE | Указывается размер полей ввода в форме создания/редактирования элемента.
Использовать настройки инфоблока для обработки изображений | RESIZE_IMAGES | [Y|N] При отмеченной функции элементы, добавленные через публичную часть будут преобразовываться согласно настройкам инфоблока.
Свойства инфоблока
Свойства, выводимые на редактирование | PROPERTY_CODES | Указываются поля и свойства инфоблока, которые выводятся в форме создания/редактирования элемента.
Свойства, обязательные для заполнения PROPERTY_CODES_REQUIRED Указываются обязательно заполняемые поля и свойства инфоблока в форме создания/редактирования элемента.

Примечание: указанные здесь поля и свойства должны быть обязательно указаны в параметре PROPERTY_CODES.
Параметры доступа
Группы пользователей, имеющие право на добавление/редактирование | GROUPS | Указываются группы пользователей, имеющие право на добавление/редактирование элементов инфоблока.
Редактирование возможно для статуса STATUS Значение поля зависит от того в каком режиме используется инфоблок:
  • Обычный: в каком состоянии активности редактируются элементы (в любом - any или в неактивном - N).
  • В режиме документооборота: указываются статусы, находясь в которых элементы будут доступны для редактирования и удаления.
  • В режиме бизнес-процессов: бизнес-процессы аналогичны обычному инфоблоку.
Привязка к пользователю ELEMENT_ASSOC Задается привязка к пользователю:
  • создателю (CREATED_BY) - привязка по создателю: в дальнейшем пользователю будут показаны только созданные им элементы.
  • по свойству инфоблока --> (PROPERTY_ID) - привязка по свойству инфоблока. В этом случае доступен параметр ELEMENT_ASSOC_PROPERTY.
по свойству инфоблока --> | ELEMENT_ASSOC_PROPERTY | Указывается свойство, по которому выполняется привязка.
Ограничить кол-во элементов для одного пользователя | MAX_USER_ENTRIES | Указывается максимальное количество элементов, которые может добавить пользователь.
Ограничить кол-во рубрик, в которые можно добавлять элемент | MAX_LEVELS | Указывается максимальное количество разделов инфоблока, в которые пользователь может добавить один и тот же элемент.
Разрешить добавление только на последний уровень рубрикатора | LEVEL_LAST | [Y|N] При отмеченной опции пользователям разрешено добавлять элементы только в последний раздел дерева разделов инфоблока.
Максимальный размер загружаемых файлов, байт (0 - не ограничивать) | MAX_FILE_SIZE | Указывается максимальный размер загружаемых файлов. Если указано 0, то размер файлов не ограничен.
Использовать визуальный редактор для редактирования текста анонса | PREVIEW_TEXT_USE_HTML_EDITOR | [Y|N] При отмеченной опции будет использоваться визуальный редактор для редактирования текста анонса.
Использовать визуальный редактор для редактирования подробного текста | DETAIL_TEXT_USE_HTML_EDITOR | [Y|N] При отмеченной опции будет использоваться визуальный редактор для редактирования подробного текста.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
[/di] SEF_FOLDER.
Собственные названия полей
*поле_инфоблока* CUSTOM_TITLE_<поле_инфоблока> Задаются названия полей инфоблока для отображения пользователям. Вместо <поле_инфоблока> указывается следующее:
  • NAME - наименование;
  • TAGS - теги;
  • DATE_ACTIVE_FROM - дата начала;
  • DATE_ACTIVE_TO - дата завершения;
  • IBLOCK_SECTION - раздел инфоблока;
  • PREVIEW_TEXT - текст анонса;
  • PREVIEW_PICTURE - картинка анонса;
  • DETAIL_TEXT - подробный текст;
  • DETAIL_PICTURE - подробная картинка.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:iblock.element.add.form","",Array(
        "SEF_MODE" => "Y",
        "IBLOCK_TYPE" => "news",
        "IBLOCK_ID" => "1",
        "PROPERTY_CODES" => array("NAME","TAGS","DATE_ACTIVE_FROM","DATE_ACTIVE_TO","IBLOCK_SECTION","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT","DETAIL_PICTURE"),
        "PROPERTY_CODES_REQUIRED" => array("NAME","TAGS","DATE_ACTIVE_FROM","DATE_ACTIVE_TO","IBLOCK_SECTION","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT","DETAIL_PICTURE"),
        "GROUPS" => array("1"),
        "STATUS_NEW" => "2",
        "STATUS" => array("2"),
        "LIST_URL" => "",
        "ELEMENT_ASSOC" => "PROPERTY_ID",
        "ELEMENT_ASSOC_PROPERTY" => "",
        "MAX_USER_ENTRIES" => "100000",
        "MAX_LEVELS" => "100000",
        "LEVEL_LAST" => "Y",
        "USE_CAPTCHA" => "Y",
        "USER_MESSAGE_EDIT" => "",
        "USER_MESSAGE_ADD" => "",
        "DEFAULT_INPUT_SIZE" => "30",
        "RESIZE_IMAGES" => "Y",
        "MAX_FILE_SIZE" => "0",
        "PREVIEW_TEXT_USE_HTML_EDITOR" => "Y",
        "DETAIL_TEXT_USE_HTML_EDITOR" => "Y",
        "CUSTOM_TITLE_NAME" => "",
        "CUSTOM_TITLE_TAGS" => "",
        "CUSTOM_TITLE_DATE_ACTIVE_FROM" => "",
        "CUSTOM_TITLE_DATE_ACTIVE_TO" => "",
        "CUSTOM_TITLE_IBLOCK_SECTION" => "",
        "CUSTOM_TITLE_PREVIEW_TEXT" => "",
        "CUSTOM_TITLE_PREVIEW_PICTURE" => "",
        "CUSTOM_TITLE_DETAIL_TEXT" => "",
        "CUSTOM_TITLE_DETAIL_PICTURE" => "",
        "SEF_FOLDER" => "/",
        "VARIABLE_ALIASES" => Array(
        )
    )
);?>


Инфоблоки

Подраздел предназначен для управления и каталогизирования различных типов (блоков) однородной информации. Включает следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Голосование | iblock.vote | Реализует возможность голосования для пользователей.


Голосование

Описание iblock.vote

Компонент реализует возможность голосования для пользователей. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Инфоблоки > Голосование.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор необходимого информационного блока.
ID элемента | ELEMENT_ID | Указывается числовой код, в котором передается идентификатор элемента. Поле может быть оставлено пустым, если указан Код элемента.
Код элемента | ELEMENT_CODE | Указывается символьный код элемента. Поле может быть оставлено пустым, если указан ID элемента.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Максимальный балл | MAX_VOTE | Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
В качестве рейтинга показывать
(кроме шаблонов default, ajax_photo) 		DISPLAY_AS_RATING Выбирается что отображать в качестве рейтинга: сам рейтинг, либо среднее значение (сумма голосов поделённая на количество).
Настройки 404 ошибки
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Сообщение для показа (по умолчанию из компонента) | MESSAGE_404 | Задается сообщение, которое будет показано в случае возникновения ошибки 404. Если ничего не указывать, то будет использоваться стандартное сообщение из компонента.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:iblock.vote","",Array(
        "IBLOCK_TYPE" => "photos",
        "IBLOCK_ID" => "22",
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "ELEMENT_CODE" => $_REQUEST["code"],
        "MAX_VOTE" => "5",
        "VOTE_NAMES" => array("0","1","2","3","4"),
        "SET_STATUS_404" => "N",
        "MESSAGE_404" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Календарь событий

Подраздел дает возможность просматривать график предстоящих и прошедших событий сотрудников. Включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Интерфейс календарной сетки Интерфейс календарной сетки (КП) | calendar.interface.grid | Компонент позволяет показывать внешние сущности на календарной сетке. Требует использования API [image] модуля calendar.
Календарь событий 2.0 Календарь событий 2.0 (КП) | calendar.grid | Cлужит для создания календаря событий.
Список событий календаря 2.0 Список событий календаря 2.0 (КП) | calendar.events.list | Выводит список ближайших событий календаря.


Интерфейс календарной сетки

Отправить отзыв по этому разделу
Компоненты>Контент>Календарь событий>Интерфейс календарной сетки

Календарь событий::Интерфейс календарной сетки

Описание calendar.interface.grid

Компонент позволяет показывать внешние сущности на календарной сетке. Требует использования API [image] модуля calendar. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Календарь событий > Интерфейс календарной сетки.

Компонент относится к модулю Календарь событий.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип календаря | CALENDAR_TYPE | Указывается тип календаря событий.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:calendar.interface.grid",
    "",
    Array(
        "CALENDAR_TYPE" => "events"
    )
);?>


Интерфейс календарной сетки (КП)

Отправить отзыв по этому разделу
Компоненты>Контент>Календарь событий>Интерфейс календарной сетки (КП)

Календарь событий::Интерфейс календарной сетки (КП)

Описание calendar.interface.grid

Компонент позволяет показывать внешние сущности на календарной сетке. Требует использования API модуля calendar [image]. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Календарь событий > Интерфейс календарной сетки.

Компонент относится к модулю Календарь событий.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип календаря CALENDAR_TYPE Указывается тип календаря событий:
  • [company_calendar] Календарь компании;
  • [events] События;
  • [group] Календари групп;
  • [user] Календари пользователей.
Разрешить использовать избранные календари | ALLOW_SUPERPOSE | [Y|N] При отмеченной опции доступен функционал избранных календарей.
Использовать возможность бронирования переговорных / видеопереговорных | ALLOW_RES_MEETING | [Y|N] При отмеченной опции можно будет использовать возможность бронирования переговорных/видеопереговорных при создании событий.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:calendar.interface.grid",
    "",
    Array(
        "CALENDAR_TYPE" => "events"
    )
);?>


Календарь событий 2.0 (комплексный компонент)

Отправить отзыв по этому разделу
Компоненты>Контент>Календарь событий>Календарь событий 2.0 (комплексный компонент)

Календарь событий::Календарь событий 2.0 (комплексный компонент)

Описание calendar.grid

Компонент служит для отображения календаря событий. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Календарь событий > Календарь событий 2.0.

Компонент относится к модулю Календарь событий.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип календаря | CALENDAR_TYPE | Указывается тип календаря событий.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:calendar.grid",
    "",
    Array(
        "CALENDAR_TYPE" => "common"
    )
);?>


Календарь событий 2.0 (комплексный компонент) (КП)

Отправить отзыв по этому разделу
Компоненты>Контент>Календарь событий>Календарь событий 2.0 (комплексный компонент) (КП)

Календарь событий::Календарь событий 2.0 (комплексный компонент) (КП)

Описание calendar.grid

Компонент служит для отображения календаря событий. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Календарь событий > Календарь событий 2.0.

Компонент относится к модулю Календарь событий.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип календаря CALENDAR_TYPE Указывается тип календаря событий:
  • [company_calendar] Календарь компании;
  • [events] События;
  • [group] Календари групп;
  • [user] Календари пользователей.
Разрешить использовать избранные календари | ALLOW_SUPERPOSE | [Y|N] При отмеченной опции доступен функционал избранных календарей.
Использовать возможность бронирования переговорных / видеопереговорных | ALLOW_RES_MEETING | [Y|N] При отмеченной опции можно будет использовать возможность бронирования переговорных/видеопереговорных при создании событий.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:calendar.grid","",Array(
        "CALENDAR_TYPE" => "",
        "ALLOW_SUPERPOSE" => "Y",
        "ALLOW_RES_MEETING" => "Y"
    )
);?>


Список событий календаря 2.0

Отправить отзыв по этому разделу
Компоненты>Контент>Календарь событий>Список событий календаря 2.0

Календарь событий::Список событий календаря 2.0

Описание calendar.events.list

Компонент выводит список ближайших событий календаря. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Календарь событий > Список событий календаря 2.0.

Компонент относится к модулю Календарь событий.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип календаря | CALENDAR_TYPE | Указывается тип календаря событий.
Секция календаря | CALENDAR_SECTION_ID | Указывается секция календаря, события которой нужно вывести.
Дата инициализации | INIT_DATE | Если в параметре указана дата, то список ближайших событий будет выведен для заданной даты. В противном случае список ближайших событий календаря будет отображен для текущей даты.
Показывать ближайшие события за количество месяцев | FUTURE_MONTH_COUNT | Указывается количество месяцев, за которые будут отображены ближайшие события.
Адрес страницы для детального просмотра | DETAIL_URL | Указывается адрес страницы для детального просмотра события календаря.
Количество событий в списке | EVENTS_COUNT | Указывается количество событий, которые будут отображены в списке ближайших событий.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<$APPLICATION->IncludeComponent(
"bitrix:calendar.events.list",
    "",
    Array(
        "CALENDAR_TYPE" => "common",
        "INIT_DATE" => "--текущая дата--",
        "FUTURE_MONTH_COUNT" => "2",
        "DETAIL_URL" => "",
        "EVENTS_COUNT" => "5",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_NOTES" => ""
    )
);?>


Список событий календаря 2.0 (КП)

Отправить отзыв по этому разделу
Компоненты>Контент>Календарь событий>Список событий календаря 2.0 (КП)

Календарь событий::Список событий календаря 2.0 (КП)

Описание calendar.events.list

Компонент выводит список ближайших событий календаря. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Календарь событий > Список событий календаря 2.0.

Компонент относится к модулю Календарь событий.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип календаря CALENDAR_TYPE Указывается тип календаря событий:
  • Календарь компании;
  • События;
  • Календари групп;
  • Календари пользователей;
  • Бронирование преговорных;
  • Бронирование видео-переговорных.
Секция календаря | CALENDAR_SECTION_ID | Выбирается секция, события которой следует отобразить. Опция видна при выборе Календарь компании в опции Тип календаря.
Показывать события текущего пользователя | B_CUR_USER_LIST | [Y|N] При отмеченной опции будут показаны события календаря текущего пользователя.
Дата инициализации | INIT_DATE | Если в параметре указана дата, то список ближайших событий будет выведен для заданной даты. В противном случае список ближайших событий календаря будет отображен для текущей даты.
Показывать ближайшие события за количество месяцев | FUTURE_MONTH_COUNT | Указывается количество месяцев, за которые будут отображены ближайшие события.
Адрес страницы для детального просмотра | DETAIL_URL | Указывается адрес страницы для детального просмотра события календаря.
Количество событий в списке | EVENTS_COUNT | Указывается количество событий, которые будут отображены в списке ближайших событий.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<$APPLICATION->IncludeComponent(
"bitrix:calendar.events.list",
    "",
    Array(
        "CALENDAR_TYPE" => "calendar_company_s1",
        "CALENDAR_SECTION_ID" => "0",
        "B_CUR_USER_LIST" => "Y",
        "INIT_DATE" => "--текущая дата--",
        "FUTURE_MONTH_COUNT" => "2",
        "DETAIL_URL" => "",
        "EVENTS_COUNT" => "5",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_NOTES" => ""
    )
);?>


Описание подраздела

Подраздел предназначен для показа карты сайта и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Карта сайта
Карта сайта | main.map | Осуществляет отображение карты сайта.


Карта сайта

С помощью данного компонента осуществляется показ карты сайта.

Описание main.map

Компонент стандартный и входит в дистрибутив модуля. Карта строится на основе настроек Главного модуля, секция Карта сайта.

В визуальном редакторе компонент расположен по пути: Контент > Карта сайта > Карта сайта.

Компонент относится к Главному модулю.

Примечание: Если в настройках сайта (Настройки > Настройки продукта > Сайты > Список сайтов > _ имя сайта _) не совсем верно указана папка сайта (например, нет закрывающего слеша), то компонент не сможет создать карту сайта.

Параметры

Поле | Параметр | Описание
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка будет установлено Карта сайта.
Настройки компонента
Максимальный уровень вложенности (0 - без вложенности) | LEVEL | Параметр определяет максимальный уровень вложенности разделов при показе в карте сайта (0 - без вложенности). Если число в этом поле более чем 4, то рекомендуется еще раз продумать структуру сайта.
Количество колонок | COL_NUM | Указывается количество колонок карты сайта. Это число во многом зависит от дизайна сайта, используемого уровня вложенности, структуры сайта. Перенос пунктов карты по колонкам происходит на базе пунктов меню первого уровня. То есть, если один из пунктов меню имеет структуру намного более глубокую, чем другие пункты, то при выборе глубокого уровня вложенности на карте сайта вы можете получить длинную колонку этого пунтка и короткие колонки с другими пунктами.
Показывать описания | SHOW_DESCRIPTION | [Y|N] При отмеченной опции будут выведены описания разделов, если они заданы. Описания разделов информационных блоков не отображаются.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:main.map","",Array(
        "LEVEL" => "3",
        "COL_NUM" => "1",
        "SHOW_DESCRIPTION" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Медиа

Подраздел служит для проигрывания медиафайлов различных форматов. Включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Медиа
Видеотека | iblock.tv | Осуществляет вывод и поочередное проигрывание серии видеороликов в одном медиа проигрывателе.
Медиа проигрыватель | player | Осуществляет проигрывание медиафайлов различных форматов, поддерживает проигрывание плей-листов.
Проигрыватель videojs | videojs | Осуществляет проигрывание медиафайлов различных форматов, рекомендуется использование видео с Youtube или .mp4 видео..


Медиа проигрыватель

Одностраничный компонент осуществляет проигрывание медиафайлов различных форматов.

Описание player

Начиная с версии 17.0.2 модуля Управление структурой этот тип плеера рекомендуется заменить в настройках компонента на новый плеер videojs.

Поддерживает проигрывание плей-листов (см. список поддерживаемых форматов и плей-листов [image]), имеет большое количество настроек внешнего вида плеера. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Медиа > Медиа проигрыватель.

Компонент относится к модулю Информационные блоки.

Внимание! Компонент поддерживает два режима настройки: простой и расширенный. Расширенный предоставляет более обширные средства настройки.

Упрощенный режим

Поле | Параметр | Описание
Основные настройки
Тип плеера PLAYER_TYPE Указывается тип плеера:
  • Определить автоматически - если необходимо проигрывать файлы разных форматов;
  • video.js - поддерживает форматы FLV7 video, FLV8 video и другие форматы; начиная с версии 17.0.2 модуля Управление структурой, этот тип плеера рекомендуется выбирать в качестве плеера по умолчанию в настройках компонента. До версии 17.0.2 использовался компонент Проигрыватель HTML5 / Flash
  • HTML5 / Flash плеер - поддерживает форматы FLV7 video, FLV8 video и другие форматы.;
  • WMV Плеер (sound) - поддерживает форматы wmv, wma. Для работы WMV плеера необходимо установить Microsoft Silverlight.
Путь к списку воспроизведения | PATH | Указывается путь к файлу для проигрывания или к списку воспроизведения. Следует задавать полный путь к файлу от корня сайта. Также можно указать ссылку на видео с сайта YouTube.
Способ указания размеров SIZE_TYPE Указываются либо [dw]Абсолютные размеры[/dw][di] Станут доступны для заполнения следующие поля:
Ширина | WIDTH | Указывается ширина окна плеера в пикселях (px), вместе со списком воспроизведения, если проигрывается плей-лист.
Высота | HEIGHT | Указывается высота окна плеера в пикселях (px), вместе со списком воспроизведения, если проигрывается плей-лист.
[/di] плеера в пикселях (px), либо выбирается способ Вписать в контейнер (размеры плеера будут ограничиваться размерами контейнера).
Настройки воспроизведения
Автоматически начать проигрывать | AUTOSTART | [Y|N] При отмеченной опции проигрывание медиафайла(ов) будет начато сразу после загрузки страницы.
Настройки повторения REPEAT Указывается вариант повтора при проигрывании медиафайла(ов) или списка воспроизведения:
  • не повторять (none);
  • возпроизвести список один раз (list);
  • повторять файл/список постоянно (always);
  • повторять один файл в списке (single).
Уровень громкости в процентах от максимального | VOLUME | Указывается уровень громкости звука в процентах от максимального заданного в системе.
Дополнительные настройки
Начинать загрузку видео сразу | PRELOAD | При отмеченной опции загрузка видео будет происходить сразу после открытия плеера.
Показывать панель управления | SHOW_CONTROLS | [Y|N] При отмеченной опции будет отображаться панель управления плеером.
Скрыть плейлист | PLAYLIST_HIDE | [Y|N] При отмеченной опции плеер будет скрыт.
Размер списка воспроизведения в пикселях | PLAYLIST_SIZE | Задается размер (высота или ширина) списка воспроизведения в пикселях (px) в зависимости от его расположения.
Количество строк в списке воспроизведения | PLAYLIST_NUMBER | Задается необходимое количество строк в списке воспроизведения.
Расширенный режим настройки компонента | ADVANCED_MODE_SETTINGS | [Y|N] При отмеченной опции открывается полный набор настроек компонента. Опция предназначена для опытных пользователей. Позволяет расширенно настроить компонент. Если отключить эту опцию, то редакторы сайта смогут размещать медиафайлы в упрощенном режиме, но установленные расширенные настройки будут действовать.

Расширенный режим

Поле | Параметр | Описание
Основные настройки
Тип плеера PLAYER_TYPE Указывается тип плеера:
  • Определить автоматически (auto) - если необходимо проигрывать файлы разных форматов;
  • video.js - поддерживает форматы FLV7 video, FLV8 video и другие форматы; начиная с версии 17.0.2 модуля Управление структурой, этот тип плеера рекомендуется выбирать в качестве плеера по умолчанию в настройках компонента. До версии 17.0.2 использовался компонент Проигрыватель HTML5 / Flash
  • HTML5 / Flash плеер (flv) - HTML5 / Flash плеер;
  • WMV Плеер (wmv) - WMV плеер. Для работы WMV плеера необходимо установить Microsoft Silverlight.
Использовать список воспроизведения USE_PLAYLIST [Y|N] При отмеченной опции будет использоваться список воспроизведения, при этом необходимо настроить [dw]параметры:[/dw][di]
Путь к списку воспроизведения | PATH | Указывается путь к списку воспроизведения. Задается полный путь к файлу от корня сайта либо только имя файла, если он расположен в текущей директории. Также можно указать ссылку на видео с сайта YouTube.
Cписок воспроизведения | PLAYLIST_DIALOG | Параметр позволяет создать/отредактировать список воспроизведения.
Использовать список воспроизведения как альтернативные версии файла | USE_PLAYLIST_AS_SOURCES | При использовании этой опции html5-плеер пытается проиграть все ролики из списка по порядку и запускает первый, который ему удалось проиграть. (Стандартная логика множественных тегов <source> внутри <video>.)
[/di] Путь к списку воспроизведения (PATH), Список воспроизведения (PLAYLIST_DIALOG) и Использовать список воспроизведения как альтернативные версии файла (USE_PLAYLIST_AS_SOURCES)
Способ указания размеров SIZE_TYPE Указываются либо [dw]Абсолютные размеры[/dw][di] Станут доступны для заполнения следующие поля:
Ширина | WIDTH | Указывается ширина окна плеера в пикселях (px), вместе со списком воспроизведения, если проигрывается плей-лист.
Высота | HEIGHT | Указывается высота окна плеера в пикселях (px), вместе со списком воспроизведения, если проигрывается плей-лист.
[/di] плеера в пикселях (px), либо выбирается способ Вписать в контейнер (размеры плеера будут ограничиваться размерами контейнера).
Внешний вид, общие настройки для автоматически определяемого типа плеера и плеера Video.js
Путь к рисунку для предварительного просмотра PREVIEW Указывается путь к изображению, которое будет отображаться внутри плеера до начала воспроизведения. Можно использовать следующие варианты:
  • Ссылка на файл из структуры;
  • Картинка из медиатеки;
  • Публичная ссылка на файл на диске;
  • Ссылка на картинку в облаке (абсолютный путь с http:// или https://);
  • Ссылка на картинку на другом сайте (абсолютный путь с http:// или https://).
Показывать панель управления | SHOW_CONTROLS | При отмеченной опции будет отображаться панель управления плеером.
Скрыть плейлист | PLAYLIST_HIDE | При отмеченной опции плейлист будет скрыт.
Размер списка воспроизведения в пикселях | PLAYLIST_SIZE | Задается размер (высота или ширина) списка воспроизведения в пикселях (px) в зависимости от его расположения.
Количество строк в списке воспроизведения | PLAYLIST_NUMBER | Задается необходимое количество строк в списке воспроизведения.
Путь к папке со скинами | SKIN_PATH | Указывается путь к папке со скинами Flash плеера. Пользовательские скины должны храниться в директории, не затрагиваемой системой обновлений. Можно использовать javascript-файлы в папке скина.
Скин | SKIN | Указывается скин Flash плеера. Стандартный скин Flash плеера доступен в любом случае.
Внешний вид, общие настройки для плеера HTML5 / Flash
Путь к рисунку для предварительного просмотра PREVIEW Указывается путь к изображению, которое будет отображаться внутри плеера до начала воспроизведения. Можно использовать следующие варианты:
  • Ссылка на файл из структуры;
  • Картинка из медиатеки;
  • Публичная ссылка на файл на диске;
  • Ссылка на картинку в облаке (абсолютный путь с http:// или https://);
  • Ссылка на картинку на другом сайте (абсолютный путь с http:// или https://).
Путь к папке со скинами | SKIN_PATH | Указывается путь к папке со скинами Flash плеера. Пользовательские скины должны храниться в директории, не затрагиваемой системой обновлений. Можно использовать javascript-файлы в папке скина.
Скин | SKIN | Указывается скин Flash плеера. Стандартный скин Flash плеера доступен в любом случае.
Расположение панели управления CONTROLBAR Указывается расположение панели управления плеера:
  • внизу (bottom) - снизу окна просмотра;
  • поверх (over) - всплывает поверх окна просмотра;
  • не показывать (none) - панель управления будет скрыта.
Режим окна (WMode) WMODE Указывается режим окна Flash плеера:
  • Обычный (window) - медиафайл будет проигрываться на странице в собственном прямоугольном окне. Этот вариант дает наибольший выигрыш в скорости воспроизведения анимации;
  • Непрозрачный (opaque) - медиафайл будет помещен на задний план страницы;
  • Прозрачный (transparent) - фон страницы будет "проглядывать" через все прозрачные места медиафайла при проигрывании. Этот вариант может замедлить скорость воспроизведения анимации.
Расположение списка воспроизведения PLAYLIST Указывается расположение списка воспроизведения:
  • внизу - снизу окна просмотра;
  • справа - список воспроизведения будет показан в правой части окна плеера;
  • не показывать - панель управления будет скрыта.
Путь к изображению авторского знака | LOGO | Задается путь к рисунку, который будет использован как авторский знак в окне видео или аудио файла. Можно задать полный путь к файлу от корня сайта либо только имя файла, если он расположен в текущей директории.
Ссылка на изображении авторского знака | LOGO_LINK | Задается ссылка перехода при клике на изображении авторского знака.
Расположение авторского знака LOGO_POSITION Задается расположение авторского знака:
  • Не показывать (none);
  • Внизу слева (bottom-left);
  • Вверху слева (top-left);
  • Вверху справа (top-right);
  • Внизу справа (bottom-right).
Внешний вид, общие настройки для плеера WMV
Путь к рисунку для предварительного просмотра PREVIEW Указывается путь к изображению, которое будет отображаться внутри плеера до начала воспроизведения. Можно использовать следующие варианты:
  • Ссылка на файл из структуры;
  • Картинка из медиатеки;
  • Публичная ссылка на файл на диске;
  • Ссылка на картинку в облаке (абсолютный путь с http:// или https://);
  • Ссылка на картинку на другом сайте (абсолютный путь с http:// или https://).
Режим окна WMODE_WMV Указывается режим окна Wmv-плеера:
  • Обычный (window) - окно плеера будет убрано за HTML элементы страницы;
  • Прозрачный (windowless) - окно плеера будет отображаться непосредственно в клиентской области обозревателя или внутри специально созданного окна.
Показывать панель управления | SHOW_CONTROLS | [Y|N] При отмеченной опции будет отображаться панель управления плеером.
Формат списка воспроизведения PLAYLIST_TYPE Указывается формат списка воспроизведения:
  • ASX
  • ATOM
  • RSS
  • XSPF
Ширина картинки в списке воспроизведения | PLAYLIST_PREVIEW_WIDTH | Задается ширина картинки в списке воспроизведения в пикселях (px).
Высота картинки в списке воспроизведения | PLAYLIST_PREVIEW_HEIGHT | Задается высота картинки в списке воспроизведения в пикселях (px).
Расположение списка воспроизведения PLAYLIST Задается расположение списка воспроизведения:
  • Внизу (bottom) - список воспроизведения будет расположен снизу;
  • Справа (right) - список воспроизведения будет расположен справа.
Размер списка воспроизведения в пикселях | PLAYLIST_SIZE | Задается размер (высота или ширина) списка воспроизведения в пикселях (px) в зависимости от его расположения.
Показывать текущее время воспроизведения и оставшееся время | SHOW_DIGITS | [Y|N] При отмеченной опции будет показано текущее и оставшееся время воспроизведения ролика.
Цвет фона панели управления | CONTROLS_BGCOLOR | Указывается код цвета для фона панели управления плеера.
Цвет элементов управления | CONTROLS_COLOR | Указывается код цвета для элементов управления плеера.
Цвет элементов управления при наведении указателя мыши | CONTROLS_OVER_COLOR | Указывается код цвета для элементов управления плеера при наведении указателя мыши.
Цвет экрана | SCREEN_COLOR | Указывается код цвета для экрана плеера.
Настройки воспроизведения для автоматически определяемого типа плеера и плеера Video.js
Автоматически начать проигрывать | AUTOSTART | [Y|N] При отмеченной опции проигрывание медиафайла(ов) будет начато сразу после загрузки страницы.
Автоматически начинать проигрывать при появлении плеера на экране | AUTOSTART_ON_SCROLL | При отмеченной опции проигрывание медиафайла(ов) будет начато только после попадания плеера в поле зрения пользователя. Видео запускается автоматически только один раз. При автоматическом запуске звук выключается, включается только при первом взаимодействии с плеером.
Уровень громкости в процентах от максимального | VOLUME | Указывается уровень громкости звука в процентах от максимального заданного в системе.
Отключать звук при старте MUTE При отмеченной опции звук не будет воспроизводиться, включить его можно будет вручную в панели управления плеера.
При расширенном режиме настроек компонента.
Скорость воспроизведения PLAYBACK_RATE Указывается число от 1 до 3, которое будет множителем скорости воспроизведения видео. Не работает для flv-файлов.
При расширенном режиме настроек компонента.
Настройки воспроизведения для плеера HTML5 / Flash
Автоматически начать проигрывать | AUTOSTART | [Y|N] При отмеченной опции проигрывание медиафайла(ов) будет начато сразу после загрузки страницы.
Автоматически начинать проигрывать при появлении плеера на экране | AUTOSTART_ON_SCROLL | При отмеченной опции проигрывание медиафайла(ов) будет начато только после попадания плеера в поле зрения пользователя. Видео запускается автоматически только один раз. При автоматическом запуске звук выключается, включается только при первом взаимодействии с плеером.
Уровень громкости в процентах от максимального | VOLUME | Указывается уровень громкости звука в процентах от максимального заданного в системе.
Отключать звук при старте MUTE При отмеченной опции звук не будет воспроизводиться, включить его можно будет вручную в панели управления плеера.
При расширенном режиме настроек компонента.
Настройки повторения REPEAT Указывается вариант повтора при проигрывании медиафайла(ов) или списка воспроизведения:
  • не повторять (none);
  • возпроизвести список один раз (list);
  • повторять файл/список постоянно (always);
  • повторять один файл в списке (single).
Перемешать список воспроизведения | SHUFFLE | [Y|N] При отмеченной опции элементы списка воспроизведения будут проиграны в случайном порядке. Внешнее отображение списка изменено не будет.
Настройки воспроизведения для плеера WMV
Автоматически начать проигрывать | AUTOSTART | [Y|N] При отмеченной опции проигрывание медиафайла(ов) будет начато сразу после загрузки страницы.
Автоматически начинать проигрывать при появлении плеера на экране | AUTOSTART_ON_SCROLL | При отмеченной опции проигрывание медиафайла(ов) будет начато только после попадания плеера в поле зрения пользователя. Видео запускается автоматически только один раз. При автоматическом запуске звук выключается, включается только при первом взаимодействии с плеером.
Уровень громкости в процентах от максимального | VOLUME | Указывается уровень громкости звука в процентах от максимального заданного в системе.
Настройки повторения REPEAT Указывается вариант повтора при проигрывании медиафайла(ов) или списка воспроизведения:
  • не повторять (none);
  • возпроизвести список один раз (list);
  • повторять файл/список постоянно (always);
  • повторять один файл в списке (single).
Дополнительные настройки для автоматически определяемого типа плеера и плеера Video.js
Mime-type файла | TYPE | В поле можно в явном виде указать mime-type, если ссылка на php-скрипт, например.
Начинать загрузку видео сразу | PRELOAD | При отмеченной опции браузер начнет скачивать ролик сразу после загрузки страницы, еще до начала его воспроизведения.
Расширенный режим настройки компонента | ADVANCED_MODE_SETTINGS | [Y|N] При отмеченной опции открывается полный набор настроек компонента. Опция предназначена для опытных пользователей. Позволяет расширенно настроить компонент. Если отключить эту опцию, то редакторы сайта смогут размещать медиафайлы в упрощенном режиме, но установленные расширенные настройки будут действовать.
Идентификатор плеера | PLAYER_ID | Указывается идентификатор для плеера для дальнейшего обращения к объекту плеера из JavaScript.
Дополнительные настройки для плеера HTML5 / Flash
Mime-type файла | TYPE | В поле можно в явном виде указать mime-type, если ссылка на php-скрипт, например.
Расширенный режим настройки компонента | ADVANCED_MODE_SETTINGS | [Y|N] При отмеченной опции открывается полный набор настроек компонента. Опция предназначена для опытных пользователей. Позволяет расширенно настроить компонент. Если отключить эту опцию, то редакторы сайта смогут размещать медиафайлы в упрощенном режиме, но установленные расширенные настройки будут действовать.
Идентификатор плеера | PLAYER_ID | Указывается идентификатор для плеера для дальнейшего обращения к объекту плеера из JavaScript.
Список подключаемых плагинов PLUGINS Указываются подключаемые к flash-плееру плагины. При выборе данной опции становится активным [dw]дополнительное поле.[/dw][di]
Параметры плагина [название плагина] PLUGINS_[название плагина] Указываются дополнительные параметры подключаемых к flash-плееру плагинов.

Поле доступно, если в Списке подключаемых плагинов указан какой-либо плагин.
[/di]
Дополнительные переменные Flashvars | ADDITIONAL_FLASHVARS | Указываются дополнительные переменные для flash-плеера.
Начать проигрывать с элемента в списке | START_ITEM | Указывается номер элемента списка воспроизведения, с которого начать проигрывать. Элементы нумеруются с нуля.
Размер буфера в секундах | BUFFER_LENGTH | Указывается сколько секунд воспроизведения ролика сохранять в буфере обмена, прежде чем начать проигрывать. Рекомендуется для медленного трафика.
Разрешить проигрывание swf-файлов (не рекомендуется) | ALLOW_SWF | [Y|N] При отмеченной опции будет разрешено проигрывание файлов формата swf. Не рекомендуется использовать в силу высокой степени опасности XSS-атаки через подключаемый файл.
Дополнительные настройки для плеера WMV
Mime-type файла | TYPE | В поле можно в явном виде указать mime-type, если ссылка на php-скрипт, например.
Расширенный режим настройки компонента | ADVANCED_MODE_SETTINGS | [Y|N] При отмеченной опции открывается полный набор настроек компонента. Опция предназначена для опытных пользователей. Позволяет расширенно настроить компонент. Если отключить эту опцию, то редакторы сайта смогут размещать медиафайлы в упрощенном режиме, но установленные расширенные настройки будут действовать.
Идентификатор плеера | PLAYER_ID | Указывается идентификатор для плеера для дальнейшего обращения к объекту плеера из JavaScript.
Размер буфера в секундах | BUFFER_LENGTH | Указывается сколько секунд воспроизведения ролика сохранять в буфере обмена, прежде чем начать проигрывать. Рекомендуется для медленного трафика.
Ссылка для скачивания ролика | DOWNLOAD_LINK | Можно указать прямую ссылку для скачивание ролика с вашего сайта либо адрес страницы, на которую пользователь попадет при клике по экрану (если это настроено в параметре Действие при клике по экрану) или по стрелке в панели управления плеера. Переход по ссылке работает при проигрывании единичного файла.
Открывать ссылку в | DOWNLOAD_LINK_TARGET | Указывается в каком окне браузера открывать ссылку для скачивания: в текущем (_self) или в новом (_blank).
Дополнительные переменные Silverlight | ADDITIONAL_WMVVARS | Указываются дополнительные переменные для WMV плеера.

Создание/редактирование
списка воспроизведения

Если компонент Медиа проигрыватель настроен на работу со списками воспроизведения, то необходимо создать новый либо отредактировать существующий список воспроизведения.

Для создания списка воспроизведения необходимо указать в поле Путь к списку воспроизведения имя нового списка и нажать кнопку Изменить в поле Список воспроизведения. Откроется окно Создание списка воспроизведения:

Кнопка Добавить элемент служит для добавления элементов списка воспроизведения. По её нажатию нужно заполнить следующие поля:

Поле | Описание
Якорь | Инструмент для изменения положения пункта меню в общем порядке списка воспроизведения способом Drag & Drop.
Редактировать | Нажать для редактирования поля.
Название | Указывается название медиафайла, как оно будт отображаться в общем списке.
Автор | Указывается имя автора медиафайла.
Время | Указывается время проигрывания медиафайла в формате MM:SS.
Путь к файлу | Задается путь к медиафайлу.
Путь к рисунку | Указывается путь к рисунку для анонса.
Стрелки | Инструмент для пошагового изменения положения медиафайла в общем списке.
Удалить | Инструмент для удаления элемента списка воспроизведения.

Обязательным является заполнение полей Название и Путь к файлу.

Примечание: вывод в списке воспроизведения всей введенной в полях информации зависит от используемого скина плеера. Не все скины поддерживают вывод полного объема введенной информации.

После заполнения полей необходимо сохранить внесенные изменения.

Редактирование списка воспроизведения выполняется аналогичным образом.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:player","",Array(
    "PLAYER_TYPE" => "auto",
    "USE_PLAYLIST" => "Y",
    "PATH" => "playlist.xml",
    "PLAYLIST_DIALOG" => "",
    "PROVIDER" => "video",
    "STREAMER" => "",
    "WIDTH" => "400",
    "HEIGHT" => "400",
    "PREVIEW" => "",
    "FILE_TITLE" => "Вступление",
    "FILE_DURATION" => "305",
    "FILE_AUTHOR" => "Иван Иванов",
    "FILE_DATE" => "01.08.2010",
    "FILE_DESCRIPTION" => "Презентация продукта",
    "SKIN_PATH" => "/bitrix/components/bitrix/player/mediaplayer/skins",
    "SKIN" => "bitrix.swf",
    "CONTROLBAR" => "bottom",
    "WMODE" => "transparent",
    "PLAYLIST" => "right",
    "PLAYLIST_SIZE" => "180",
    "LOGO" => "/logo.png",
    "LOGO_LINK" => "http://ваш_сайт.com/",
    "LOGO_POSITION" => "bottom-left",
    "PLUGINS" => array("tweetit-1", "fbit-1"),
    "PLUGINS_TWEETIT-1" => "tweetit.link=",
    "PLUGINS_FBIT-1" => "fbit.link=",
    "ADDITIONAL_FLASHVARS" => "",
    "WMODE_WMV" => "window",
    "SHOW_CONTROLS" => "Y",
    "PLAYLIST_TYPE" => "xspf",
    "PLAYLIST_PREVIEW_WIDTH" => "64",
    "PLAYLIST_PREVIEW_HEIGHT" => "48",
    "SHOW_DIGITS" => "Y",
    "CONTROLS_BGCOLOR" => "FFFFFF",
    "CONTROLS_COLOR" => "000000",
    "CONTROLS_OVER_COLOR" => "000000",
    "SCREEN_COLOR" => "000000",
    "AUTOSTART" => "Y",
    "REPEAT" => "list",
    "VOLUME" => "90",
    "MUTE" => "N",
    "HIGH_QUALITY" => "Y",
    "SHUFFLE" => "N",
    "START_ITEM" => "1",
    "ADVANCED_MODE_SETTINGS" => "Y",
    "PLAYER_ID" => "",
    "BUFFER_LENGTH" => "10",
    "DOWNLOAD_LINK" => "http://ваш_сайт.com/video.flv",
    "DOWNLOAD_LINK_TARGET" => "_self",
    "ADDITIONAL_WMVVARS" => "",
    "ALLOW_SWF" => "Y",
      )
);?>

Смотрите также

  • Как работать с медиапроигрывателем
  • Как создать новый список воспроизведения


Видеотека

Одностраничный компонент осуществляет вывод и поочередное проигрывание серии видеороликов в одном Медиа проигрывателе. Компонент является стандартным и входит в дистрибутив модуля.

Описание iblock.tv

Примечание: при настройке компонента учтите, что часть полей последовательно появляется после выбора вышестоящих параметров.

В визуальном редакторе компонент расположен по пути: Контент > Медиа > Видеотека.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Общие настройки компонента
Тип информационного блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Информационный блок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, из которого будет выводиться ролики.
Разрешить проигрывание swf-файлов (не рекомендуется) | ALLOW_SWF | [Y|N] При отмеченной опции будет разрешено проигрывание файлов формата swf. Не рекомендуется использовать в силу высокой степени опасности XSS-атаки через подключаемый файл.
Свойство, в котором хранится путь к ролику | PATH_TO_FILE | Задается свойство инфоблока, в котором указывается путь к файлу ролика.
Свойство, в котором хранится длительность ролика | DURATION | Задается свойство инфоблока, в котором указывается длительность воспроизведения ролика.
Настройки плеера
Ширина области плеера | WIDTH | Указывается ширина области плеера в пикселях (px).
Высота области плеера | HEIGHT | Указывается высота области плеера в пикселях (px).
Логотип | LOGO | Указывается путь до файла с логотипом, накладываемым на ролик при просмотре.
Секция | SECTION_ID | Указывается раздел, ролики из которого будут отображены.
Статистика показов
Увеличить счетчик показов элемента | SHOW_COUNTER_EVENT | [Y|N] При отмеченной опции будет запущен счетчик показа каждого элемента (ролика).
Учитывать события в модуле статистики STAT_EVENT [Y|N] При отмеченной опции события будут учитываться в модуле Веб-аналитика. При выборе данной опции станут доступны [dw]дополнительные поля.[/dw][di]
event1 | STAT_EVENT1 | Указывается параметр типа события event1.
event2 | STAT_EVENT2 | Указывается параметр типа события event2.
[/di]
Настройки списка
Маленькое изображение по умолчанию | DEFAULT_SMALL_IMAGE | Указывается путь до маленького изображения ролика. Изображение будет показано в списке роликов.
Большое изображение по умолчанию | DEFAULT_BIG_IMAGE | Указывается путь до большого изображения ролика. Изображение будет показано на экране плеера перед началом просмотра видеоролика.
Поле для первой сортировки роликов SORT_BY1 Поле для первой сортировки роликов:
  • ID - по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FROM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X - по дате последнего изменения.
Направление для первой сортировки роликов SORT_ORDER1 Направление для первой сортировки роликов:
  • ASC – по возрастанию;
  • DECS – по убыванию.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:iblock.tv","",Array(
        "DEFAULT_SMALL_IMAGE" => "/bitrix/components/bitrix/iblock.tv/templates/.default/images/default_small.png",
        "DEFAULT_BIG_IMAGE" => "/bitrix/components/bitrix/iblock.tv/templates/.default/images/default_big.png",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "IBLOCK_TYPE" => "services",
        "IBLOCK_ID" => "4",
        "ALLOW_SWF" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y",
        "SHOW_COUNTER_EVENT" => "Y",
        "PATH_TO_FILE" => "15",
        "DURATION" => "16",
        "WIDTH" => "400",
        "HEIGHT" => "300",
        "LOGO" => "/bitrix/components/bitrix/iblock.tv/templates/.default/images/logo.png",
        "SECTION_ID" => "9",
        "ELEMENT_ID" => "16",
        "STAT_EVENT" => "Y",
        "STAT_EVENT1" => "player",
        "STAT_EVENT2" => "start_playing"
    )
);?>

Смотрите также

  • Как наполнить видеотеку


Проигрыватель videojs

Одностраничный компонент осуществляет проигрывание медиафайлов различных форматов, однако рекомендуется использование видео с Youtube или .mp4 видео.

Описание videojs

Начиная с версии 17.0.2 модуля Управление структурой, этот тип плеера рекомендуется выбирать в качестве плеера по умолчанию в настройках компонента. До версии 17.0.2 использовался компонент Проигрыватель HTML5 / Flash.

Внешний вид компонента и его поведение может быть изменено с помощью соответствующих настроек. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Медиа > Медиа проигрыватель (встроен в этот компонент).

Компонент относится к модулю Управление структурой.

Для настройки компонента используются следующие параметры.

Параметры

Поле | Описание
Основные настройки
Тип плеера Указывается тип плеера:
  • Определить автоматически - для wmv/wma файлов будет подключен WMV плеер, а для всех остальных файлов и ссылок - video.js. Так как новый плеер полностью перекрывает функционал старого HTML5 / Flash плеера, то при выборе этого плеера администратор увидит предупреждающее сообщение с просьбой перейти на новый плеер.;
  • HTML5 / Flash плеер - HTML5 / Flash плеер;
  • WMV Плеер - WMV плеер. Для работы WMV плеера необходимо установить Microsoft Silverlight.
Использовать список воспроизведения При отмеченной опции необходимо будет указать путь к файлу формата xml, в котором будет находиться плейлист. Формат плейлистов по сравнению с HTML5 / Flash плеером не изменился, однако были убраны поля Автор видео и Продолжительность ролика. Пример создания плейлиста - в конце статьи.
При расширенном режиме настроек компонента.
Путь к файлу Указывается путь к файлу для проигрывания. В качестве пути можно указать:
  • путь к файлу из структуры;
  • ролик из медиатеки;
  • ссылку на youtube (абсолютный путь c http:// или https://);
  • ссылку на vimeo.com (абсолютный путь c http:// или https://);
  • ссылку на потоковое видео формата m3u8/ts (абсолютный путь c http:// или https://);
  • публичную ссылку на файл на диске;
  • ссылку на файл в облаке (абсолютный путь c http:// или https://);
  • ссылку на файл на другом сайте (абсолютный путь c http:// или https://).
Способ указания размеров
  • Абсолютные размеры - необходимо ввести размеры блока в пикселях в поля Ширина и Высота. В эти размеры включены размеры плейлиста и кнопок управления плеером. Размеры по умолчанию - 400х300 пикселей;
  • Вписать в контейнер - размер тега video пример размеры родительского контейнера. Для адаптивного отображения компонента на различных устройствах рекомендуется использовать этот вариант;
  • Подстроиться под размеры видео - размер тега video будет соответствовать разрешению ролика. Эта опция недоступна при использовании плейлиста.
Внешний вид, общие настройки
Путь к рисунку для предварительного просмотра Указывается путь к изображению, которое будет отображаться внутри плеера до начала воспроизведения. Можно использовать следующие варианты:
  • Ссылка на файл из структуры;
  • Картинка из медиатеки;
  • Публичная ссылка на файл на диске;
  • Ссылка на картинку в облаке (абсолютный путь с http:// или https://);
  • Ссылка на картинку на другом сайте (абсолютный путь с http:// или https://).

При расширенном режиме настроек компонента.
Показывать панель управления При отмеченной опции будет отображаться панель управления плеером.
При расширенном режиме настроек компонента. При простом режиме опция находится в секции Дополнительные настройки
Путь к папке со скинами Указывается путь к папке со скинами. Если скин включает в себя не только файл стиля, но и дополнительные файлы (картинки), то необходимо, чтобы файл стилей и папка назывались одинаково.
При расширенном режиме настроек компонента.
Скин Если был правильно указан путь к папке с пользовательскими скинами, то в этом поле можно будет выбрать ваш скин.
При расширенном режиме настроек компонента.
Настройки воспроизведения
Автоматически начать проигрывать | При отмеченной опции проигрывание медиафайла(ов) будет начато сразу после загрузки страницы.
Автоматически начинать проигрывать при появлении плеера на экране | При отмеченной опции проигрывание медиафайла(ов) будет начато только после попадания плеера в поле зрения пользователя. Видео запускается автоматически только один раз. При автоматическом запуске звук выключается, включается только при первом взаимодействии с плеером.
Настройки повторения | Если вы используете плейлист - он будет зациклен по умолчанию. Если список воспроизведения не используется - можно включить или выключить повторение видео.
Уровень громкости в процентах от максимального | Указывается уровень громкости звука в процентах (от 0 до 100) от максимального заданного в системе.
Отключать звук при старте При отмеченной опции звук не будет воспроизводиться, включить его можно будет вручную в панели управления плеера.
При расширенном режиме настроек компонента.
Время начала воспроизведения Указывается место ролика в секундах, с которого должно начаться воспроизведение. Опция недоступна при работе с плейлистами, flv-файлами, роликами с vimeo и потоковым видео.
При расширенном режиме настроек компонента.
Скорость воспроизведения Указывается число от 1 до 3, которое будет множителем скорости воспроизведения видео. Не работает для flv-файлов.
При расширенном режиме настроек компонента.
Дополнительные настройки
Mime-type файла | В поле можно в явном виде указать mime-type, если ссылка на php-скрипт, например.
Начинать загрузку видео сразу | При отмеченной опции браузер начнет скачивать ролик сразу после загрузки страницы, еще до начала его воспроизведения.
Расширенный режим настройки компонента | Включает отображение дополнительных настроек, скрытых по умолчанию.
Идентификатор плеера | Указывается идентификатор для плеера для дальнейшего обращения к объекту плеера из JavaScript.

Примеры использования

Вставка видео заданных размеров на страницу:

  • В поле Путь к файлу вставляем ссылку на файл (рекомендуется использовать ссылку на youtube видео или ссылку на файл формата mp4);
  • Способ указания размеров - абсолютные размеры, указываем требуемую ширину и высоту в пикселях;
  • Остальные настройки можно оставить по умолчанию.

Вывод плейлиста с аудио-файлами:

  • Ставим галочку в поле Расширенный режим настройки компонента;
  • Ставим галочку в поле Использовать плейлист;
  • В поле Путь к файлу плейлиста вставляем расположение файла списка воспроизведения (например, /upload/audio.xml);
  • Нажимаем кнопку Создать плейлист, заполняем названия файлов и пути к ним;
  • Способ указания размеров - абсолютные размеры, указываем требуемую ширину и высоту в пикселях (например, 600 на 100 пикселей);
  • Размер списка воспроизведения - устанавливаем размер списка воспроизведения. К примеру, 300 пикселей;
  • Количество строк в списке отображения - указываем количество строк, которое будет отображаться в списке воспроизведения. К примеру, 5 строк.

Пример xml-файла для списка воспроизведения:

<?xml version="1.0" encoding="UTF-8"?>
<playlist version="1" xmlns="http://xspf.org/ns/0/">
<trackList>
   <track>
      <title>1 bunny local
      <location>/upload/SampleVideo_360x240_5mb.mp4
      <image>
  </track>
   <track>
      <title>2 bunny web
      <location>http://techslides.com/demos/sample-videos/small.mp4
      <image>/upload/pexels-photo-286142.jpeg
   </track>
</trackList>
</playlist>


Просмотр pdf-файлов

Описание pdf.viewer

Одностраничный компонент осуществляет вывод и просмотр файлов формата pdf на сайте. Компонент является стандартным и входит в дистрибутив модуля. В визуальном редакторе компонент расположен по пути: Контент > Медиа > Просмотр pdf-файлов.

Параметры

Поле | Параметр | Описание
Дополнительные параметры
Идентификатор просмотрщика | VIEWER_ID | Уникальный идентификатор компонента. Основной контейнер (dom-нода) будет иметь идентификатор outerContainer_#Идентификатор#. С его помощью производятся изменения в работе компонента, например: изменение стилей.
Путь к файлу | PATH | Указывается путь к файлу, который должен открыться.
Будет показан во фрейме | IFRAME | [Y/N]Если опция установлена, то перед выводом компонента будет очищен буфер страницы, а компонент вставит свои <html><head> теги так, как будто это отдельная страница. В этом режиме просмотрщик растягивается на всю ширину экрана.
Заголовок | TITLE | Если включен режим показа во фрейме, то в настройках можно указать заголовок окна. Если его не указать, то название по умолчанию Просмотр pdf файла.
Выводить кнопку печати | PRINT | [Y/N]Если включен режим показа во фрейме, то при установленной галочке будет выводиться кнопка для отправки файла на печать.
Высота | HEIGHT | Если не выбран режим показа во фрейме, то в этом поле указывается ширина просмотрщика (в пикселях).
Ширина | WIDTH | Если не выбран режим показа во фрейме, то в этом поле указывается высота просмотрщика (в пикселях).
Ссылка на страницу печати | PRINT_URL | Если не выбран режим показа во фрейме, то по умолчанию кнопка печати не выводится. Если в этом поле указать ссылку, то при клике на кнопку печати произойдёт переход на эту ссылку. Предполагается, что при переходе пользователь увидит страницу, где установлен этот же компонент, но в режиме фрейма, т.к. печать в этом компоненте не работает при выводе в теле страницы.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:pdf.viewer",
    "",
    Array(
        "HEIGHT" => "600",
        "IFRAME" => "N",
        "PATH" => "/upload/ISR6bMnaRq.pdf",
        "PRINT" => "N",
        "PRINT_URL" => "",
        "TITLE" => "",
        "VIEWER_ID" => "",
        "WIDTH" => "900"
    )
);?>


Яндекс.Карты

Компоненты Яндекс.Карты созданы в содружестве с компанией Яндекс на базе одноименного проекта компании. Для использования компонентов необходимо иметь ключ доступа, который получается в вашем кабинете разработчика компании Яндекс по адресу: http://developer.tech.yandex.ru [image].

Компоненты позволяют размещать на сайте карты, производить по ним поиск, создавать на карте комментарии и задавать стартовую точку открытия карты.

В работе компонента используется API сервиса Яндекс.карты. За описанием классов, функций и событий обратитесь к API-документации [image] Яндекса.

Подраздел включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Яндекс.Карты
Яндекс: поиск по адресу | map.yandex.search | Осуществляет отображение карты с сервиса Яндекс.Карты и предоставляет возможность поиска по адресу. Поддержка детального поиска (по улице и дому) осуществляется в соответствии с возможностями сервиса Яндекс.Карты.
Яндекс.Карты (системный компонент) | map.yandex.system | Осуществляет отображение карты с сервиса Яндекс.Карты.
Яндекс: настраиваемая карта | map.yandex.view | Осуществляет отображение карты с сервиса Яндекс.Карты. Компонент позволяет выводить саму карту, задавать на ней стартовую позицию и добавлять на карту дополнительную информацию.


Яндекс.Карты (системный компонент)

Описание map.yandex.system

Одностраничный компонент осуществляет отображение карты с сервиса Яндекс.Карты. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Управление структурой.

Параметры

Поле | Параметр | Описание
Основные параметры
Ключ доступа | KEY | Указывается ключ доступа, который получается у компании Яндекс. Без ключа карта работать не будет.
Стартовый тип карты INIT_MAP_TYPE Указывается вид карты, который будет использоваться по умолчанию:
  • схема (MAP) - схематичная карта с именами улиц и объектов;
  • спутник (SATELLITE) - карта в виде фото со спутника;
  • гибрид (HYBRID) - карта в виде фото со спутника с наложенной на нее схемой основных дорог и объектов.
Ширина карты | MAP_WIDTH | Указывается ширина окна отображаемой карты в пикселях (px) или в процентах (%). Если параметр принмает значение AUTO, то ширина окна задается браузером, который будет растягивать его на все доступное место.
Высота карты | MAP_HEIGHT | Указывается высота окна отображаемой карты в пикселях (px) или в процентах (%).
Дополнительные настройки
Элементы управления CONTROLS Указываются необходимые элементы управления, которые будут отображены на карте:
  • Панель инструментов (TOOLBAR) - кнопки Переместить карту, Увеличить и Измерить расстояние на карте;
  • Ползунок масштаба (ZOOM) - ползунок масштаба для управления масштабированием карты;
  • Кнопки масштаба (SMALLZOOM) - кнопки Увеличить масштаб и Уменьшить масштаб для управления масштабированием;
  • Мини-карта (MINIMAP) - включает отображение схематичной карты с крупным масштабом в левом нижнем углу карты;
  • Тип карты (TYPECONTROL) - кнопки Схема, Спутник или Гибрид для переключения стартового типа карты;
  • Шкала масштаба (SCALELINE) - в правом нижнем углу будет отображена шкала масштаба, показывающая масштаб относительно 1 см карты.
Настройки OPTIONS Задаются настройки для управление картой с помощью клавиатуры и мыши:
  • изменение масштаба колесом мыши (ENABLE_SCROLL_ZOOM) - позволяет изменять масштаб вращением колеса мыши;
  • изменение масштаба двойным щелчком мыши (ENABLE_DBLCLICK_ZOOM) - позволяет изменять масштаб карты двойным кликом мыши: левая кнопка - увеличение, правая кнопка - уменьшение;
  • перетаскивание карты (ENABLE_DRAGGING) - позволяет перетаскивать карту указателем мыши;
  • горячие клавиши (ENABLE_HOTKEYS) - позволяет управлять масштабом карты с помощью горячих клавиш.
Идентификатор карты | MAP_ID | Указывается идентификатор карты. Задается произвольный код из цифр и букв латинского алфавита, который можно использовать при создании собственных клиентских сценариев.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:map.yandex.system", ".default", array(
    "KEY" => "",
    "INIT_MAP_TYPE" => "SATELLITE",
    "MAP_WIDTH" => "800",
    "MAP_HEIGHT" => "500",
    "CONTROLS" => array(
        0 => "TOOLBAR",
        1 => "ZOOM",
        2 => "MINIMAP",
        3 => "TYPECONTROL",
        4 => "SCALELINE",
    ),
    "OPTIONS" => array(
        0 => "ENABLE_SCROLL_ZOOM",
        1 => "ENABLE_DBLCLICK_ZOOM",
        2 => "ENABLE_DRAGGING",
        3 => "ENABLE_HOTKEYS",
    ),
    "MAP_ID" => "testmap"
    )
);
?>


Яндекс: настраиваемая карта

Описание map.yandex.view

Одностраничный компонент осуществляет отображение карты с сервиса Яндекс.Карты. Компонент позволяет выводить саму карту, задавать на ней стартовую позицию и добавлять на карту дополнительную информацию. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Яндекс.Карты > Яндекс.Карты: настраиваемая карта.

Компонент относится к модулю Управление структурой.

Примечание. Компонент работает на API 2.0 Яндекса, использование протокола https необязательно.

Параметры

Поле | Параметр | Описание
Основные параметры
Стартовый тип карты INIT_MAP_TYPE Указывается вид карты, который будет использоваться по умолчанию:
  • схема (MAP) - схематичная карта с именами улиц и объектов;
  • спутник (SATELLITE) - карта в виде фото со спутника;
  • гибрид (HYBRID) - карта в виде фото со спутника с наложенной на нее схемой основных дорог и объектов.
  • народная карта (PUBLIC) - карта, составляемая пользователями Яндекса.
  • народный гибрид (PUBLIC_HYBRID) - карта в виде фото со спутника с наложенной на нее народной картой.
Данные выводимые на карте MAP_DATA По нажатию кнопки Изменить откроется окно Настройки карты, предназначенное для редактирования настроек карты:

Для смены стартовой позиции необходимо снять опцию зафиксировать, с помощью штатных инструментов масштабирования задать новое стартовое положение. После этого нужно вновь отметить опцию зафиксировать.

Для создания комментария на карте необходимо воспользоваться ссылкой Добавить точки. Двойным кликом на нужной точке на карте вызвать окно добавления текста комментария и ввести нужный текст. Число задаваемых точек не ограничено. После задания всех необходимых точек нужно завершить работу с помощью ссылки Закончить. Для удаления комментариев нужно навести указатель мыши на удаляемую запись и нажать на крестик, появившийся рядом с ней.

Для создания линии на карте необходимо воспользоваться ссылкой "Добавить линию". Двойным кликом на начальной точке линии начните процесс создания маршрута. Одиночными кликами проложите маршрут по карте. Завершите создание линии двойным кликом на последней точке. Появится диалог настроек линии. Введите название линии, выберите цвет, толщину линии и процент прозрачности. Закройте диалог и завершите создание линии с помощью ссылки Закончить добавление линий. Созданная линия появится в списке линий.
Для редактирования параметров (саму линию отредактировать нельзя) нажмите на названии линии, появится диалог для редактирования параметров.
Для удаления линии нужно навести указатель мыши на удаляемую запись и нажать на крестик, появившийся рядом с ней.

Для сохранения внесенных изменений нужно воспользоваться кнопкой Сохранить.
Ширина карты | MAP_WIDTH | Указывается ширина окна отображаемой карты в пикселях (px) или в процентах (%). Если параметр принимает значение AUTO, то ширина окна задается браузером, который будет растягивать его на все доступное место.
Высота карты | MAP_HEIGHT | Указывается высота окна отображаемой карты в пикселях (px) или в процентах (%).
Дополнительные настройки
Элементы управления CONTROLS Указываются необходимые элементы управления, которые будут отображены на карте:
  • Панель инструментов (TOOLBAR) - кнопки Переместить карту, Увеличить и Измерить расстояние на карте;
  • Ползунок масштаба (ZOOM) - ползунок масштаба для управления масштабированием карты;
  • Кнопки масштаба (SMALLZOOM) - кнопки Увеличить масштаб и Уменьшить масштаб для управления масштабированием;
  • Мини-карта (MINIMAP) - включает отображение схематичной карты с крупным масштабом в левом нижнем углу карты;
  • Тип карты (TYPECONTROL) - кнопки Схема, Спутник или Гибрид для переключения стартового типа карты;
  • Шкала масштаба (SCALELINE) - в правом нижнем углу будет отображена шкала масштаба, показывающая масштаб относительно 1 см карты.
  • Поиск по карте (SEARCH) - поле и кнопка для поиска по карте.
Настройки OPTIONS Задаются настройки для управление картой с помощью клавиатуры и мыши:
  • изменение масштаба колесом мыши (ENABLE_SCROLL_ZOOM) - позволяет изменять масштаб вращением колеса мыши;
  • изменение масштаба двойным щелчком мыши (ENABLE_DBLCLICK_ZOOM) - позволяет изменять масштаб карты двойным кликом мыши: левая кнопка - увеличение, правая кнопка - уменьшение;
  • изменение масштаба правой кнопкой мыши (ENABLE_RIGHT_MAGNIFIER) - позволяет с помощью щелчка правой кнопки мыши выделить и увеличить нужную область карты;
  • перетаскивание карты (ENABLE_DRAGGING) - позволяет перетаскивать карту указателем мыши;
Идентификатор карты | MAP_ID | Указывается идентификатор карты. Задается произвольный код из цифр и букв латинского алфавита, который можно использовать при создании собственных клиентских сценариев.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:map.yandex.view",".default",Array(
        "INIT_MAP_TYPE" => "HYBRID",
        "MAP_DATA" => "a:5:{s:10:
            \"yandex_lat\";d:54.707337846253914;s:10:
            \"yandex_lon\";d:20.578642461221364;s:12:
            \"yandex_scale\";i:16;s:10:
            \"PLACEMARKS\";a:1:{i:0;a:3:{s:3:
            \"LON\";d:20.5829274251;s:3:
            \"LAT\";d:54.7078476116;s:4:
            \"TEXT\";s:100:\"ООО \"1С-Битрикс\", г. Калининград, Московский проспект, 261.\";}}s:9:
            \"POLYLINES\";a:1:{i:0;a:3:{s:6:
            \"POINTS\";a:2:{i:0;a:2:{s:3:
            \"LAT\";d:54.707748780049165;s:3:
            \"LON\";d:20.577995674216798;}i:1;a:2:{s:3:
            \"LAT\";d:54.70704134712057;s:3:
            \"LON\";d:20.583708959423795;}}s:5:
            \"TITLE\";s:37:\"Московский проспект\";s:5:
            \"STYLE\";a:1:{s:9:
            \"lineStyle\";a:2:{s:11:
            \"strokeColor\";s:8:
            \"FFFF007F\";s:11:
            \"strokeWidth\";i:3;}}}}}",
        "MAP_WIDTH" => "600",
        "MAP_HEIGHT" => "500",
        "CONTROLS" => array(
            "TOOLBAR",
            "ZOOM",
            "SMALLZOOM",
            "MINIMAP",
            "TYPECONTROL",
            "SCALELINE"
        ),
        "OPTIONS" => array(
            "ENABLE_SCROLL_ZOOM",
            "ENABLE_DBLCLICK_ZOOM",
            "ENABLE_DRAGGING"
        ),
        "MAP_ID" => "yam_1"
    )
);?>


Яндекс: поиск по адресу

Описание map.yandex.search

Одностраничный компонент осуществляет отображение карты с сервиса Яндекс.Карты и предоставляет возможность поиска по адресу. Поддержка детального поиска (по улице и дому) осуществляется в соответствии с возможностями сервиса Яндекс.Карты. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Контент > Яндекс.Карты > Яндекс.Карты: поиск по адресу.

Компонент относится к модулю Управление структурой.

Параметры

Поле | Параметр | Описание
Основные параметры
Стартовый тип карты INIT_MAP_TYPE Указывается вид карты, который будет использоваться по умолчанию:
  • схема (MAP) - схематичная карта с именами улиц и объектов;
  • спутник (SATELLITE) - карта в виде фото со спутника;
  • гибрид (HYBRID) - карта в виде фото со спутника с наложенной на нее схемой основных дорог и объектов.
  • народная карта (PUBLIC) - карта, составляемая пользователями Яндекса.
  • народный гибрид (PUBLIC_HYBRID) - карта в виде фото со спутника с наложенной на нее народной картой.
Ширина карты | MAP_WIDTH | Указывается ширина окна отображаемой карты в пикселях (px) или в процентах (%). Если параметр принмает значение AUTO, то ширина окна задается браузером, который будет растягивать его на все доступное место.
Высота карты | MAP_HEIGHT | Указывается высота окна отображаемой карты в пикселях (px) или в процентах (%).
Начальная позиция карты MAP_DATA По нажатию кнопки Изменить откроется окно Настройки карты, предназначенное для редактирования настроек карты:

Для поиска необходимого объекта/местоположения нужно использовать строку Найти на карте.

Для смены стартовой позиции необходимо снять опцию зафиксировать, с помощью штатных инструментов масштабирования задать новое стартовое положение. После этого нужно вновь отметить опцию зафиксировать.

Для сохранения внесенных изменений нужно воспользоватся кнопкой Сохранить.
Дополнительные настройки
Элементы управления CONTROLS Указываются необходимые элементы управления, которые будут отображены на карте:
  • Панель инструментов (TOOLBAR) - кнопки Переместить карту, Увеличить и Измерить расстояние на карте;
  • Ползунок масштаба (ZOOM) - ползунок масштаба для управления масштабированием карты;
  • Кнопки масштаба (SMALLZOOM) - кнопки Увеличить масштаб и Уменьшить масштаб для управления масштабированием;
  • Мини-карта (MINIMAP) - включает отображение схематичной карты с крупным масштабом в левом нижнем углу карты;
  • Тип карты (TYPECONTROL) - кнопки Схема, Спутник или Гибрид для переключения стартового типа карты;
  • Шкала масштаба (SCALELINE) - в правом нижнем углу будет отображена шкала масштаба, показывающая масштаб относительно 1 см карты.
  • Поиск по карте (SEARCH) - поле и кнопка для поиска по карте.
Настройки OPTIONS Задаются настройки для управление картой с помощью клавиатуры и мыши:
  • изменение масштаба колесом мыши (ENABLE_SCROLL_ZOOM) - позволяет изменять масштаб вращением колеса мыши;
  • изменение масштаба двойным щелчком мыши (ENABLE_DBLCLICK_ZOOM) - позволяет изменять масштаб карты двойным кликом мыши: левая кнопка - увеличение, правая кнопка - уменьшение;
  • изменение масштаба правой кнопкой мыши (ENABLE_RIGHT_MAGNIFIER) - позволяет с помощью щелчка правой кнопки мыши выделить и увеличить нужную область карты;
  • перетаскивание карты (ENABLE_DRAGGING) - позволяет перетаскивать карту указателем мыши;
Идентификатор карты | MAP_ID | Указывается идентификатор карты. Задается произвольный код из цифр и букв латинского алфавита, который можно использовать при создании собственных клиентских сценариев.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:map.yandex.search",".default",array(
    "INIT_MAP_TYPE" => "MAP",
    "MAP_WIDTH" => "auto",
    "MAP_HEIGHT" => "500",
    "MAP_DATA" => "a:3:{s:10:
            \"yandex_lat\";d:54.704461192577305;s:10:
            \"yandex_lon\";d:20.51420630589147;s:12:
            \"yandex_scale\";i:13;}",
    "CONTROLS" => array(
        "TOOLBAR",
        "ZOOM",
        "MINIMAP",
        "TYPECONTROL",
        "SCALELINE"
    ),
    "OPTIONS" => array(
        "ENABLE_DBLCLICK_ZOOM",
        "ENABLE_DRAGGING"
    ),
    "MAP_ID" => "searchmap"
    )
);
?>


Обмен с 1С

Подраздел предназначен для обмена данными с 1С в формате CommerceML v2 и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Обмен с 1С
Импорт каталога из 1С | catalog.import.1c | Выполняет импорт данных из 1С в формате CommerceML v2.
Экспорт каталога в 1C | catalog.export.1c | Выполняет экспорт данных в 1С в формате CommerceML v2.


Импорт каталога из 1С

Описание catalog.import.1c

Компонент выполняет импорт данных из 1С в формате CommerceML v2. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Обмен с 1С > Импорт каталога из 1c.

Компонент относится к модулю Торговый каталог.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфо-блока IBLOCK_TYPE В выпадающем списке списке перечислены все уже созданные в системе типы инфоблоков. При выборе пункта Создать по необходимости в случае отсутствия необходимого типа инфоблока, будет создан новый.
Параметр играет роль только при первом импорте каталога (когда он создается). При последующих операциях импорта того же каталога этот параметр игнорируется.
Сайты, к которым привязывать инфоблоки при создании | SITE_LIST | Указывается сайт(ы), к которому будут привязываться новые инфоблоки, создаваемые при импорте. Привязка может производиться либо к текущему сайту, либо к одному определённому сайту из имеющихся в системе.
Интервал одного шага в секундах (0 - выполнять загрузку за один шаг) | INTERVAL | Указывается интервал одного шага в секундах при импорте каталога в систему. 0 - выполнять загрузку за один шаг.
Группы пользователей, которым разрешена загрузка | GROUP_PERMISSIONS | Указывается группа(-ы) пользователей, обладающие правом загрузки каталога на сайт.
Вести предложения в отдельном инфоблоке | USE_OFFERS | [Y|N] При отмеченной опции предложения будут загружены в отдельный инфоблок.
Цены только в инфоблоке предложений FORCE_OFFERS [Y|N] Данная опция имеет смысл, если некоторые товары выгружаются без характеристик:
  • если опция отмечена, то при выгрузке товаров из 1С, цены на товары будут храниться в торговых предложениях. Т.е для каждого товара будет создано 1 торговое предложение, в котором и будет храниться цена;
  • если опция не отмечена, то для выгруженных из 1С товаров торговые предложения создаваться не будут, цена будет храниться в самом товаре.
Для тех товаров, у которых есть характеристики, будут созданы торговые предложения в соответствии с количеством характеристик и цены будет храниться в этих торговых предложениях.

Хранение самих торговых предложений определяется опцией "Вести предложения в отдельном инфоблоке".
Импортировать с учетом типа инфоблока | USE_IBLOCK_TYPE_ID | [Y|N] При отмеченной опции данные будут импортированы с учетом типа инфоблока(ов).
Не импортировать корневой раздел инфоблока, если он единственный | SKIP_ROOT_SECTION | [Y|N] При отмеченной опции корневой раздел инфоблока импортироваться не будет, если он единственный.
Что делать с элементами, отсутствующими в файле импорта ELEMENT_ACTION Указывается действие с элементами, которые есть в системе, но отсутствуют в файле импорта:
  • N (ничего) - игнорировать, т.е. никаких действий не совершать;
  • A (деактивировать) - сделать такие элементы неактивными;
  • D (удалить) - удалить такие элементы.
Что делать с разделами, отсутствующими в файле импорта SECTION_ACTION Указывается действие с разделами, которые есть в системе, но отсутствуют в файле импорта:
  • N (ничего) - игнорировать, т.е. никаких действий не совершать;
  • A (деактивировать) - сделать такие разделы неактивными;
  • D (удалить) - удалить такие разделы.
Размер единовременно загружаемой части файла (в байтах) | FILE_SIZE_LIMIT | Указывается размер единовременно загружаемой части файла в байтах.
Использовать контрольные суммы элементов для оптимизации обновления каталога | USE_CRC | [Y|N] При отмеченной опции при выгрузке полного каталога изменению подвергнуться только изменившиеся элементы, что значительно снизит нагрузку на сервер и позволит процедуре обновления отработать значительно быстрее.
Использовать сжатие zip, если доступно | USE_ZIP | [Y|N] При отмеченной опции данные сжимаются ZIP форматом (если доступно). Это позволяет заметно уменьшить размер файлов.
Отключить проверку источника запроса | SKIP_SOURCE_CHECK | [Y|N] При отмеченной опции отключается проверка источника запроса.
Тегированный кеш инфоблока | IBLOCK_CACHE_MODE | Настройка управляет работой с тегированным кешем инфоблока при импорте.
Картинка анонса
Использовать настройки инфоблока для обработки изображений USE_IBLOCK_PICTURE_SETTINGS [Y|N] При отмеченной опции будут использоваться настройки инфоблока для обработки картинки анонса.При неотмеченной опции станут доступны [dw]дополнительные поля.[/dw][di]
Автоматически генерировать картинку анонса | GENERATE_PREVIEW | [Y|N] При отмеченной опции на основании фотографий, которые поступают из 1С, система будет самостоятельно генерировать картинку анонса (защита от поступления из 1С больших фотографий).
Максимально допустимая ширина картинки анонса | PREVIEW_WIDTH | При отмеченной опции Автоматически генерировать картинку анонса в данном поле определяется максимальная ширина картинки анонса в пикселях.
Максимально допустимая высота картинки анонса | PREVIEW_HEIGHT | При отмеченной опции Автоматически генерировать картинку анонса в данном поле определяется максимальная высота картинки анонса в пикселях.
Изменять детальную картинку | DETAIL_RESIZE | [Y|N] При отмеченной опции на основании фотографий, которые поступают из 1С, система будет самостоятельно изменять детальную картинку (защита от поступления из 1С больших фотографий).
Максимально допустимая ширина детальной картинки | DETAIL_WIDTH | При отмеченной опции Изменять детальную картинку в данном поле определяется максимальная ширина детальной картинки в пикселях.
Максимально допустимая высота детальной картинки | DETAIL_HEIGHT | При отмеченной опции Изменять детальную картинку в данном поле определяется максимальная высота детальной картинки в пикселях.
[/di]
Транслитерация символьного кода из названия
Транслитерировать при добавлении элемента или раздела TRANSLIT_ON_ADD [Y|N] При отмеченной опции при добавлении элемента или раздела будет происходить транслитерация символьного кода из его названия, станут доступны [dw]дополнительные поля.[/dw][di]
Максимальная длина результата транслитерации | TRANSLIT_MAX_LEN | Указывается максимальная длина символьного кода при транслетирации из названия в символах.
Приведение к регистру TRANSLIT_CHANGE_CASE Указывается к какому регистру будет приводиться результат при транслитерации символьного кода элемента или раздела:
  • <пусто> - сохранить (регистр не меняется);
  • L - к нижнему регистру;
  • U - к верхнему регистру.
Замена для символа пробела | TRANSLIT_REPLACE_SPACE | Указывается каким символом будет заменяться пробел при транслитерации символьного кода элемента или раздела из названия.
Замена для прочих символов | TRANSLIT_REPLACE_OTHER | Указывается каким символом будет заменяться прочие символы при транслитерации символьного кода элемента или раздела из названия.
Удалять лишние символы замены | TRANSLIT_DELETE_REPEAT_REPLACE | [Y|N] При отмеченной опции будут удаляться повторяющиеся символы при транслитерации символьного кода из названия.
[/di]
Транслитерировать при обновлении элемента или раздела TRANSLIT_ON_UPDATE [Y|N] При отмеченной опции при обновлении элемента или раздела будет происходить транслитерация символьного кода из его названия, станут доступны [dw]дополнительные поля.[/dw][di]
Максимальная длина результата транслитерации | TRANSLIT_MAX_LEN | Указывается максимальная длина символьного кода при транслетирации из названия в символах.
Приведение к регистру TRANSLIT_CHANGE_CASE Указывается к какому регистру будет приводиться результат при транслитерации символьного кода элемента или раздела:
  • <пусто> - сохранить (регистр не меняется);
  • L - к нижнему регистру;
  • U - к верхнему регистру.
Замена для символа пробела | TRANSLIT_REPLACE_SPACE | Указывается каким символом будет заменяться пробел при транслитерации символьного кода элемента или раздела из названия.
Замена для прочих символов | TRANSLIT_REPLACE_OTHER | Указывается каким символом будет заменяться прочие символы при транслитерации символьного кода элемента или раздела из названия.
Удалять лишние символы замены | TRANSLIT_DELETE_REPEAT_REPLACE | [Y|N] При отмеченной опции будут удаляться повторяющиеся символы при транслитерации символьного кода из названия.
[/di]

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:catalog.import.1c","",Array(
        "IBLOCK_TYPE" => "-",
        "SITE_LIST" => array(),
        "INTERVAL" => "30",
        "GROUP_PERMISSIONS" => array("1"),
        "IBLOCK_CACHE_MODE" => "N",
        "USE_OFFERS" => "N",
        "FORCE_OFFERS" => "N",
        "USE_IBLOCK_TYPE_ID" => "N",
        "SKIP_ROOT_SECTION" => "N",
        "ELEMENT_ACTION" => "D",
        "SECTION_ACTION" => "D",
        "FILE_SIZE_LIMIT" => "204800",
        "USE_CRC" => "Y",
        "USE_ZIP" => "Y",
        "USE_IBLOCK_PICTURE_SETTINGS" => "N",
        "GENERATE_PREVIEW" => "Y",
        "PREVIEW_WIDTH" => "100",
        "PREVIEW_HEIGHT" => "100",
        "DETAIL_RESIZE" => "Y",
        "DETAIL_WIDTH" => "300",
        "DETAIL_HEIGHT" => "300",
        "TRANSLIT_ON_ADD" => "Y",
        "TRANSLIT_ON_UPDATE" => "Y",
        "TRANSLIT_MAX_LEN" => "100",
        "TRANSLIT_CHANGE_CASE" => "L",
        "TRANSLIT_REPLACE_SPACE" => "_",
        "TRANSLIT_REPLACE_OTHER" => "_",
        "TRANSLIT_DELETE_REPEAT_REPLACE" => "Y"
    ),
false
);?>


Экспорт каталога в 1C

Описание catalog.export.1c

Компонент выполняет экспорт данных в 1С в формате CommerceML v2. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Обмен с 1С > Экспорт каталога в 1с.

Компонент относится к модулю Торговый каталог.

Параметры

Поле | Параметр | Описание
Основные параметры
Инфоблок каталога | IBLOCK_ID | Выбирается инфоблок для экспорта.
Интервал одного шага в секундах (0 - выполнять выгрузку за один шаг) | INTERVAL | Указывается интервал одного шага в секундах при экспорте каталога. 0 - выполнять выгрузку за один шаг.
Количество элементов выгружаемых за один шаг (0 - выполнять выгрузку за один шаг) | ELEMENTS_PER_STEP | Указывается число элементов, выгружаемых за один шаг. 0 - выполнять выгрузку за один шаг.
Группы пользователям которых разрешена выгрузка | GROUP_PERMISSIONS | Указывается группа(-ы), пользователей которые имеют права на выгрузку заказов в 1С.
Использовать сжатие zip, если доступно | USE_ZIP | [Y|N] При отмеченной опции данные сжимаются ZIP форматом (если доступно). Это позволяет заметно уменьшить размер файлов.

Пример вызова

<?$APPLICATION->IncludeComponent
"bitrix:catalog.export.1c",
    "",
    Array(
        "IBLOCK_ID" => "5",
        "INTERVAL" => "30",
        "ELEMENTS_PER_STEP" => "100",
        "GROUP_PERMISSIONS" => array(),
        "USE_ZIP" => "Y"
    )
);?>


Социальные сервисы

Подраздел предоставляет аутентификацию посетителей сайта на внешних сервисах авторизации и содержит следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Социальные сервисы
Комментарии к товарам | catalog.comments | Отображает форму добавления комментариев к товару.
Кнопки социальных сетей | catalog.socnets.buttons | Отображает кнопки социальных сетей.


Комментарии к товарам

Описание catalog.comments

Компонент служит для отображения формы добавления комментариев к товару и обычно размещается на странице с детальной информацией о товаре. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Социальные сервисы > Комментарии к товарам.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Идентификатор инфоблока | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор инфоблока, к товарам которого будут добавляться комментарии.
Идентификатор товара | ELEMENT_ID | Указывается код, в котором передается идентификатор товара. Поле может быть оставлено пустым, если указан Код товара.
Код товара | ELEMENT_CODE | Указывается код товара. Поле может быть оставлено пустым, если указан Идентификатор товара.
Путь к комментируемому товару | URL_TO_COMMENT | Путь к детальной странице товара.
Ширина | WIDTH | Ширина блока с комментариями к товарам.
Количество показываемых комментариев | COMMENTS_COUNT | Количество показываемых комментариев на странице (используется обратная постраничка).
Внешний вид
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения комментариев к товарам. По умолчанию используется синяя схема (blue).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Комментарии на сайте
Использовать комментарии BLOG_USE [Y|N] При отмеченной опции становится доступным [dw]функционал комментариев[/dw][di]
Надпись на вкладке | BLOG_TITLE | Надпись на вкладке с комментариями.
Название блога латинскими буквами | BLOG_URL | Задается код блога (латинскими символами), в котором будут храниться комментарии к товарам.
Путь к улыбкам | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта.
Уведомление по электронной почте | EMAIL_NOTIFY | [Y|N] При отмеченной опции будет отправляться уведомление по электронной почте в случая добавления к товару комментария.
Режим ajax | AJAX_POST | [Y|N] При отмеченной опции в комментариях будет использоваться технология AJAX.
Показывать администраторам ссылку на все комментарии пользователя | SHOW_SPAM | [Y|N] При отмеченной опции администратор будет видеть ссылку на страницу со всеми комментариями каждого пользователя.
Включить рейтинг | SHOW_RATING | [Y|N] При установленной опции для комментариев будет доступен функционал рейтинга.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопок рейтинга:
  • по умолчанию;
  • Мне нравится (текстовый);
  • Мне нравится (графический);
  • Нравится / Не нравится (текстовый);
  • Нравится / Не нравится (графический).

    • Значение По умолчанию берется из настроек рейтингов.
[/di] к товарам на основе блогов.
Комментарии в Facebook*
Использовать Facebook* FB_USE [Y|N] При отмеченной опции отзывы о товаре можно будет оставлять с помощью Facebook*, становятся активными [dw]дополнительные поля[/dw][di]
Надпись на вкладке | FB_TITLE | Надпись на вкладке с комментариями в Facebook*.
Идентификатор пользователя Facebook* - модератора сообщений | FB_USER_ADMIN_ID | Задается идентификатор (из аккаунта в Facebook*) пользователя, который будет модератором комментариев к товарам.
Идентификатор приложения Facebook* (app_id) | FB_APP_ID | Указывается идентификатор приложения Facebook*, который можно получить с помощью ссылки https://developers.facebook.com/setup.
Цветовая схема | FB_COLORSCHEME | Задается цветовая схема для отображения блока с комментариями в Facebook*: light - светлая или dark - темная.
Сортировка FB_ORDER_BY Задается сортировка комментариев:
  • social - социальная релевантность;
  • reverse_time - по времени создания обратный;
  • time - по времени создания.

* деятельность организации запрещена в Российской Федерации.

[/di]

* деятельность организации запрещена в Российской Федерации.

Комментарии В Контакте
Использовать Вконтакте VK_USE [Y|N] При отмеченной опции отзывы о товаре можно будет оставлять с помощью Вконтакте, станут доступны [dw]дополнительные поля[/dw][di]
Надпись на вкладке | VK_TITLE | Надпись на вкладке с комментариями ВКонтакте.
Идентификатор приложения (API ID) | VK_API_ID | Указывается идентификатор приложения Вконтакте, который можно получить с помощью ссылки http://vk.com/developers.php?o=-1&p=Comments.
[/di]. Компонент обращается к VKontakte только по протоколу https.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:catalog.comments","",
Array(
        "TEMPLATE_THEME" => "blue",
        "IBLOCK_TYPE" => "books",
        "IBLOCK_ID" => "6",
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "ELEMENT_CODE" => "",
        "URL_TO_COMMENT" => "/e-store/books/element.php?ELEMENT_ID=#ELEMENT_ID#",
        "WIDTH" => "500",
        "COMMENTS_COUNT" => "4",
        "BLOG_USE" => "Y",
        "FB_USE" => "N",
        "VK_USE" => "N",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "BLOG_TITLE" => "Комментарии",
        "BLOG_URL" => "catalog_comments",
        "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
        "EMAIL_NOTIFY" => "N",
        "AJAX_POST" => "N",
        "SHOW_SPAM" => "Y",
        "SHOW_RATING" => "Y",
        "RATING_TYPE" => "like_graphic",
        "FB_TITLE" => "Facebook",
        "FB_USER_ADMIN_ID" => "",
        "FB_APP_ID" => "",
        "FB_COLORSCHEME" => "dark",
        "FB_ORDER_BY" => "time",
        "VK_TITLE" => "Вконтакте",
        "VK_API_ID" => "API_ID"
    )
);?>


Кнопки социальных сетей

Описание catalog.socnets.buttons

Компонент служит для отображения кнопок социальных сетей и размещается на странице, информация которой может быть опубликована в социальных сервисах. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Социальные сервисы > Кнопки социальных сетей.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Адрес публикуемой страницы | URL_TO_LIKE | Задается адрес страницы, которая публикуется в социальном сервисе.
Заголовок публикации | TITLE | Заголовок публикации в социальном сервисе.
Текст публикации | DESCRIPTION | Описание публикации в сервисе.
Адрес изображения | IMAGE | Задается путь к изображению для публикации.
Настройки Facebook*
Включить использование Facebook* FB_USE [Y|N] При отмеченной опции будет доступна кнопка сервиса Facebook*.

* деятельность организации запрещена в Российской Федерации.

Настройки Twitter
Включить использование Twitter TW_USE [Y|N] При отмеченной опции будет отображаться кнопка сервиса Twitter, станут доступны [dw]дополнительные поля.[/dw][di]
С помощью (via) | TW_VIA | Указывается атрибут via - информация о владельце публикуемой страницы.
Отметить (hashtags) | TW_HASHTAGS | Указывается атрибут hashtags для публикации.
Рекомендовать (related) | TW_RELATED | Задается атрибут related для публикации.
[/di]
Настройки В Контакте
Включить использование ВКонтакте | VK_USE | [Y|N] При отмеченной опции будет отображаться кнопка сервиса ВКонтакте.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:catalog.socnets.buttons","",
Array(
        "URL_TO_LIKE" => "/examples/article.php",
        "TITLE" => "Моя статья",
        "DESCRIPTION" => "",
        "IMAGE" => "/upload/images/myarticle.png",
        "FB_USE" => "Y",
        "TW_USE" => "Y",
        "GP_USE" => "Y",
        "VK_USE" => "Y",
        "TW_VIA" => "",
        "TW_HASHTAGS" => "",
        "TW_RELATED" => ""
    )
);?>


Сервисы

Сущности
Название | Имя в пространстве имен bitrix | Описание
Подразделы
Видеоконференции (КП) | video | Предоставляет возможность проведения видеоконференцсвязи. Примечание: модуль устарел и не поддерживается. Функционал видеосвязи выполняется модулем Вебмессенджер..
Интранет | intranet | Предназначен для управления задачами и поручениями, организации коллективных событий, резервирования переговорных и ресурсов, работы с электронными заявками.
Экстранет (КП) | extranet | Модуль Экстранет – расширение для продукта «Битрикс24 в коробке», которое позволяет компании осуществлять конфиденциальную связь с поставщиками, дистрибуторами и другими внешними пользователями без доступа к внутрикорпоративной информации.
Контроллер | controller | Служит для централизованного управления любым количеством независимых веб-сайтов, созданных на платформе «1С-Битрикс: Управление сайтом».
Частые вопросы | support.faq | Предназначен для организации ЧаВо на сайте.
E-mail маркетинг | support.faq | Служит для организации работы рассылок.
Веб-Сервис | webservice | Позволяет организовать системы веб-сервисов и SOAP.
Веб-формы | form | Позволяет создавать произвольное количество веб-форм и управлять ими.
Менеджер идей | idea | Предоставляет возможность предложить свою идею для развития бизнеса компании, получить оценку и рейтинг.
Обучение | learning | Предназначен для создания обучающих курсов и проведения тестов.
Опросы, голосования | voting | Позволяет проводить опросы и голосования, которые помогут узнать мнение пользователей сайта по различным вопросам.
Рассылки | subscribe | Служит для создания рассылок почтовых сообщений.
Реклама |  | Предназначен для организации показа баннеров на сайте.
Техподдержка | support | Подраздел для организации системы обращений посетителей к группе техподдержки.
Компоненты
Рабочий стол | support | Компонент позволяет создать настраиваемый рабочий стол с использованием разнофункциональных гаджетов.


Рабочий стол

Описание desktop

Одностраничный компонент позволяет создать настраиваемый рабочий стол с использованием разнофункциональных гаджетов. В компоненте по умолчанию используется 6 гаджетов, которые инсталлируются с главным модулем системы. Разработчики могут создавать собственные гаджеты, компонент их увидит, если они размещены в папке /bitrix/gadgets.

В визуальном редакторе компонент расположен в разделе: Сервисы.

Компонент относится к Главному модулю.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор | ID | Символьный код стола. Столы с одинаковыми идентификаторами имеют одинаковые настройки.
Разрешить настраивать рабочий стол всем авторизованным пользователям | CAN_EDIT | [Y/N] Установленный флажок разрешает персональную настройку для авторизованных пользователей. В противном случае настраивать рабочий стол может только пользователь с правами на запись для страницы, на которой размещен компонент.
Количество столбцов | COLUMNS | Задается число столбцов Рабочего стола. После ввода числа нужно нажать кнопку OK, измениться число полей для задания ширины столбцов.
Размер столбца #N | COLUMN_WIDTH_0 | Поле для задания ширины конкретного столбца. Задается в пикселях или процентах.
Доступные гаджеты | GADGETS | С помощью кнопки CTRL выбираются гаджеты, которые будут отображаться на рабочем столе. Для выбранных гаджетов ниже появляются свои группы параметров для настройки.
Настройки гаджета "RSS лента"
Время кеширования | G_RSSREADER_CACHE_TIME | Срок в секундах на который кешируются полученные данные. При выборе "0" - данные не кешируются.
Показывать ссылку на подробную информацию | G_RSSREADER_SHOW_URL | [Y/N] Разрешает отображение ссылки на подробную информацию.
Предустановленные RSS ленты | G_RSSREADER_PREDEFINED_RSS | С каждой новой строки вводится отдельный URL RSS ленты. При изменении списка необходимо нажать кнопку [image] для сохранения изменений.
Настройки по умолчанию параметров пользователя для гаджета "RSS лента"
Название гаджета | GU_RSSREADER_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество новостей | GU_RSSREADER_CNT | Задается число отображаемых новостей. Если выставлено "0", будут отображаться все новости.
Ссылка на RSS ленту | GU_RSSREADER_RSS_URL | Выбор одной из предустановленных лент новостей, либо ввод URL любой другой ленты.
Настройки по умолчанию параметров пользователя для гаджета "Заметки"
Название гаджета | GU_HTML_AREA_TITLE_STD | Указать, какое название для гаджета будет видно пользователю.
Настройки по умолчанию параметров пользователя для гаджета "Избранные ссылки"
Название гаджета | GU_FAVORITES_TITLE_STD | Указать, какое название для гаджета будет видно пользователю.
Настройки гаджета "Пробки"
Время кеширования | G_PROBKI_CACHE_TIME | Срок в секундах на который кешируются полученные данные. При выборе "0" - данные не кешируются
Показывать ссылку на подробную информацию | G_PROBKI_SHOW_URL | [Y/N] Разрешает отображение ссылки на подробную информацию.
Настройки по умолчанию параметров пользователя для гаджета "Пробки"
Название гаджета | GU_PROBKI_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Город | GU_PROBKI_CITY | Выбор города, для которого нужно отображать пробки
Настройки гаджета "Прогноз погоды"
Время кеширования | G_WEATHER_SHOW_TIME | Срок в секундах на который кешируются полученные данные. При выборе "0" - данные не кешируются
Показывать ссылку на подробную информацию | G_WEATHER_SHOW_URL | [Y/N] Разрешает отображение ссылки на подробную информацию.
Настройки по умолчанию параметров пользователя для гаджета "Прогноз погоды"
Название гаджета | GU_WEATHER_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Страна | GU_WEATHER_COUNTRY | Выбор страны, для которой нужно отображать прогноз погоды.
Город | GU_WEATHER_CITY | Выбор города, для которого нужно отображать прогноз погоды.
Дополнительные настройки
Страница отправки личного сообщения | PM_URL | Страница, на которую будут отправляться сообщения пользователю.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Шаблон пути к странице подразделения.
Отображение имени NAME_TEMPLATE Шаблон отображения имени. Выбирается из выпадающего списка, либо вводится свой в дополнительном поле. В шаблоне допустимо использование:
  • #LAST_NAME# - фамилия (Петров);
  • #LAST_NAME_SHORT# - инициал фамилии (П.);
  • #NAME# - имя (Иван);
  • #NAME_SHORT# - инициал имени (И.);
  • #SECOND_NAME# - отчество (Васильевич);
  • #SECOND_NAME_SHORT# - инициал отчества (В.).

По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта).
Показывать логин, если не задано имя | SHOW_LOGIN | [Y/N] При установленной опции будет вводиться логин пользователя, если тот не указал в профиле имя и фамилию.
Формат показа даты и времени | DATE_TIME_FORMAT | Шаблон отображения даты и времени. Выбирается из выпадающего списка, либо вводится свой в дополнительном поле. (Для полей с указанием обоих параметров.) Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты | DATE_FORMAT | Шаблон отображения даты. Выбирается из выпадающего списка, либо вводится свой в дополнительном поле. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты без года | DATE_FORMAT_NO_YEAR | Шаблон отображения даты. Выбирается из выпадающего списка, либо вводится свой в дополнительном поле. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать год рождения | SHOW_YEAR | Выбрать кому будет отображаться год рождения.
Настройки гаджета "Видеоновости"
Тип информационного блока | G_VIDEO_IBLOCK_TYPE | Выбор типа информационного блока, из которого будут показываться видеоновости.
Информационный блок | G_VIDEO_IBLOCK_ID | Выбор информационного блока, из которого будут показываться видеоновости.
URL страницы со списком видеоновостей | G_VIDEO_LIST_URL | Адрес страницы на которой выводятся видеоновости.
Свойство, в котором хранится путь к ролику | G_VIDEO_PATH_TO_FILE | Указать свойство инфоблока, в котором храниться путь к файлу на сервере.
Свойство, в котором хранится длительность ролика | G_VIDEO_DURATION | Указать свойство инфоблока, в котором храниться описание длительности ролика.
Секция | G_VIDEO_SECTION_ID | Выбор секции инфоблока, из которо будут выводиться ролики для показа.
Элемент | G_VIDEO_ELEMENT_ID | Указать элемент, который будет отображаться в экране плеера при открытии.
Ширина области плеера | G_VIDEO_WIDTH | Задать ширину плеера
Высота области плеера | G_VIDEO_HEIGHT | Задать высоту плеера
Тип кеширования | G_VIDEO_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_VIDEO_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Видеоновости"
Название гаджета | GU_VIDEO_TITLE_STD | Указать, какое название для гаджета будет видно пользователю.
Настройки гаджета "Выскажи мнение"
Группа опросов | G_VOTE_CHANNEL_SID | Указывается группа опросов для выводв в гаджете.
Тип кеширования | G_VOTE_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_VOTE_CACHE_TIME | Задать время кеширования
URL страницы со списком опросов | G_VOTE_LIST_URL | Адрес страницы со списком опросов.
Настройки по умолчанию параметров пользователя для гаджета "Выскажи мнение"
Название гаджета | GU_VOTE_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Настройки по умолчанию параметров пользователя для гаджета "Гаджеты Google"
Название гаджета | GU_GOOGLE_GADGETS_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Настройки гаджета "Дни рождения"
Страница структуры компании | G_BIRTHDAY_STRUCTURE_PAGE | Адрес страницы портала со структурой компании.
Страница отправки личного сообщения | G_BIRTHDAY_PM_URL | Адрес страницы, на которой будет выводиться сообщение.
Показывать год рождения | G_BIRTHDAY_SHOW_YEAR | Выбрать кому будет отображаться год рождения.
Пользовательские поля для вывода | G_BIRTHDAY_USER_PROPERTY | Выбор из списка полей, которые будут отображаться у записи пользователя.
URL страницы со списком дней рождений | G_BIRTHDAY_LIST_URL | Адрес страницы со списком дней рождений.
Настройки по умолчанию параметров пользователя для гаджета "Дни рождения"
Название гаджета | GU_BIRTHDAY_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых пользователей | GU_BIRTHDAY_NUM_USERS | Сколько пользователей будет видно в списке гаджета.
Показывать для отдела/офиса | GU_BIRTHDAY_DEPARTMENT | Для какого подразделения выводить пользователей.
Настройки гаджета "Доска почета"
URL страницы с доской почета | G_HONOUR_LIST_URL | АДрес страницы, где отображается доска почета.
Настройки по умолчанию параметров пользователя для гаджета "Доска почета"
Название гаджета | GU_HONOUR_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых пользователей | GU_HONOUR_NUM_USERS | Сколько пользователей будет видно в списке гаджета.
Настройки гаджета "Живая лента"
Имя переменной для пользователя | G_UPDATES_USER_VAR | Переменная, в которой передается имя соответствующей сущности.
Имя переменной для группы | G_UPDATES_GROUP_VAR
Имя переменной для страницы | G_UPDATES_PAGE_VAR
Шаблон пути к странице пользователя | G_UPDATES_PATH_TO_USER | Шаблон пути к странице пользователя.
Шаблон пути к странице группы | G_UPDATES_PATH_TO_GROUP | Шаблон пути к странице группы.
URL страницы со списком обновлений | G_UPDATES_LIST_URL | Адрес страницы "Живая лента"
Настройки по умолчанию параметров пользователя для гаджета "Живая лента"
Название гаджета | GU_UPDATES_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество отображаемых записей | GU_UPDATES_LOG_CNT | Сколько записей будет выводиться гаджете.
Тип подписки | GU_UPDATES_ENTITY_TYPE | Выбор типа подписки.
Тип сообщения | GU_UPDATES_EVENT_ID | Выбор типов сообщений.
Настройки для гаджета "Информация"
Тип баннера | G_ADV_TYP | Указать тип баннера, который будет отображаться пользователю.
Настройки по умолчанию параметров пользователя для гаджета "Инфомация"
Название гаджета | GU_ADV_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Настройки гаджета "Мои задачи"
Имя переменной для кода страницы | G_TASKS_PAGE_VAR | Переменная, в которой передается имя соответствующей сущности.
Имя переменной для кода группы | G_TASKS_GROUP_VAR
Имя переменной для кода пользователя | G_TASKS_VIEW_VAR
Имя переменной для кода задачи | G_TASKS_TASK_VAR
Имя переменной для кода действия | G_TASKS_ACTION_VAR
Путь к списку задач группы | G_TASKS_PATH_TO_GROUP_TASKS | Путь к соответствующей странице.
Путь к задаче группы | G_TASKS_PATH_TO_GROUP_TASKS_TASK
Путь к списку задач пользователя | G_TASKS_PATH_TO_USER_TASKS
Путь к задаче пользователя | G_TASKS_PATH_TO_USER_TASKS_TASK
URL списка задач | G_TASKS_PATH_TO_TASK | Адрес страницы со списком задач
URL создания задачи | G_TASKS_PATH_TO_TASK_NEW | Адрес страницы с формой создания задачи.
Настройки по умолчанию параметров пользователя для гаджета "Мои задачи"
Название гаджета | GU_TASKS_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество записей на странице | GU_TASKS_ITEMS_COUNT | Сколько записей будет отображаться в гаджете.
Упорядочить по | GU_TASKS_ORDER_BY | Выбор сортировки для задач.
Показывать задачи | GU_TASKS_TYPE | Выбор типа задач.
Настройки гаджета "Мои сообщения"
Шаблон пути к странице пользователя | G_MESSAGES_PATH_TO_USER | Шаблон пути к соответствующим страницам
Шаблон пути к странице группы | G_MESSAGES_PATH_TO_GROUP
Шаблон пути к странице отправки сообщений | G_MESSAGES_PATH_TO_MESSAGE_FORM
Шаблон пути к странице ответа на сообщение | G_MESSAGES_PATH_TO_MESSAGE_FORM_MESS
Шаблон пути к странице чата | G_MESSAGES_PATH_TO_MESSAGES_CHAT
Путь к папке со смайликам относительно корня сайта | G_MESSAGES_PATH_TO_SMILE | Путь к папке со смайликам относительно корня сайта
Период опроса сервера | G_MESSAGES_AJAX_LONG_TIMEOUT | Указать время в секундах.
Имя переменной для сообщения | G_MESSAGES_MESSAGE_VAR | Переменная, в которой передается соответствующая сущность.
Имя переменной для страницы | G_MESSAGES_PAGE_VAR
Имя переменной для пользователя | G_MESSAGES_USER_VAR
Путь к входящим сообщениям | G_MESSAGES_INBOX_URL
Путь к отправленным сообщениям | G_MESSAGES_SENT_URL | Путь к странице с исходящими сообщениями.
Настройки по умолчанию параметров пользователя для гаджета "Мои сообщения"
Название гаджета | GU_MESSAGES_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Настройки гаджета "Мой календарь"
Тип инфоблока | G_CALENDAR_IBLOCK_TYPE | Выбор типа инфоблока, в котором размещаются календари.
Инфоблок | G_CALENDAR_IBLOCK_ID | Выбор инфоблока, в котором размещаются календари.
Адрес страницы для детального просмотра | G_CALENDAR_DETAIL_URL | Адрес страницы с персональным календарем.
Тип кеширования | G_CALENDAR_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_CALENDAR_CACHE_TIME | Задать время кеширования
Путь к персональному календарю | G_CALENDAR_CALENDAR_URL | Путь к персональному календарю
Настройки по умолчанию параметров пользователя для гаджета "Мой календарь"
Название гаджета | GU_CALENDAR_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество событий в списке | GU_CALENDAR_EVENTS_COUNT | Сколько событий будет выведено в гаджете.
Настройки гаджета "Мой профиль"
URL страницы Основное | G_PROFILE_PATH_TO_GENERAL | Указываются адреса соответствующих страниц.
URL страницы Изменение профиля | G_PROFILE_PATH_TO_PROFILE_EDIT
URL страницы Обновления | G_PROFILE_PATH_TO_LOG
URL страницы Мои подписки | G_PROFILE_PATH_TO_SUBSCR
URL страницы Мои сообщения | G_PROFILE_PATH_TO_MSG
URL страницы Мои группы | G_PROFILE_PATH_TO_GROUPS
URL страницы Создание группы | G_PROFILE_PATH_TO_GROUP_NEW
URL страницы Мои фотографии | G_PROFILE_PATH_TO_PHOTO
URL страницы Добавление фотографий | G_PROFILE_PATH_TO_PHOTO_NEW
URL страницы Форум | G_PROFILE_PATH_TO_FORUM
URL страницы Блог | G_PROFILE_PATH_TO_BLOG
URL страницы Добавления нового сообщения в блог | G_PROFILE_PATH_TO_BLOG_NEW
URL страницы Календарь | G_PROFILE_PATH_TO_CAL
URL страницы Задачи | G_PROFILE_PATH_TO_TASK
URL страницы Добавление задачи | G_PROFILE_PATH_TO_TASK_NEW
URL страницы Файлы | G_PROFILE_PATH_TO_LIB
Настройки по умолчанию параметров пользователя для гаджета "Мой профиль"
Название гаджета | GU_PROFILE_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Показать Основное | GU_PROFILE_SHOW_GENERAL | [Y\N] Выбор сущностей для отображения в гаджете.
Показать Группы | GU_PROFILE_SHOW_GROUPS
Показать Фото | GU_PROFILE_SHOW_PHOTO
Показать Форум | GU_PROFILE_SHOW_FORUM
Показать Календарь | GU_PROFILE_SHOW_CAL
Показать Блог | GU_PROFILE_SHOW_BLOG
Показать Задачи | GU_PROFILE_SHOW_TASK
Показать Файлы | GU_PROFILE_SHOW_LIB
Настройки гаджета "Найти сотрудника"
URL страницы со списком сотрудников компании | G_SEARCH_EMPLOYEE_LIST_URL | Адрес страницы "Сотрудники".
Настройки по умолчанию параметров пользователя для гаджета "Найти сотрудника"
Название гаджета | GU_SEARCH_EMPLOYEE_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Настройки гаджета "Наша жизнь"
Тип информационного блока (используется только для проверки) | G_LIFE_IBLOCK_TYPE | Выбор типа информационного блока.
Код информационного блока | G_LIFE_IBLOCK_ID | Выбор информационного блока.
Формат показа даты | G_LIFE_ACTIVE_DATE_FORMAT | Шаблон отображения даты. Выбирается из выпадающего списка, либо вводится свой в дополнительном поле.
URL страницы со списком новостей | G_LIFE_LIST_URL | Адрес соответствующей страницы
URL страницы с новостью подробно | G_LIFE_DETAIL_URL
Тип кеширования | G_LIFE_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_LIFE_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Наша жизнь"
Название гаджета | GU_LIFE_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество новостей на странице | GU_LIFE_NEWS_COUNT | Указать какое количество новостей выводить в гаджете.
Показывать дату | GU_LIFE_DISPLAY_DATE | [Y\N] Выбор сущностей для отображения в гаджете.
Показать картинку | GU_LIFE_DISPLAY_PICTURE
Показать текст анонса | GU_LIFE_DISPLAY_PREVIEW_TEXT
Настройки гаджета "Новое в блогах"
Шаблон пути к странице блога: G_BLOG_PATH_TO_BLOG Шаблон соответствующих страниц.
Шаблон пути к странице с сообщением блога | G_BLOG_PATH_TO_POST
Шаблон пути к странице с сообщением блога группы | G_BLOG_PATH_TO_GROUP_BLOG_POST
Шаблон пути к странице пользователя блога | G_BLOG_PATH_TO_USER
Тип кеширования | G_BLOG_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_BLOG_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Новое в блогах"
Название гаджета | GU_BLOG_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество результатов, выводимых на страницу | GU_BLOG_MESSAGE_COUNT | Указать какое количество новых сообщений выводить в гаджете.
Длина выводимого текста сообщения | GU_BLOG_MESSAGE_LENGTH | Указать какое количество знаков текста сообщения выводить в гаджете.
Формат показа даты и времени | GU_BLOG_DATE_TIME_FORMAT | Можно перезадать формат даты и времени для этого гаджета.
Настройки гаджета "Новое на форуме"
ID форума | G_FORUM_FID | Выбрать форум, новые сообщения которого будут выводиться в гаджете.
Поле для сортировки | G_FORUM_SORT_BY | По какому полю будут сортироваться сообщения.
Направление сортировки | G_FORUM_SORT_ORDER | Выбрать направление сортировки.
Страница чтения сообщения | G_FORUM_URL_TEMPLATES_MESSAGE | Адрес страницы.
Тип кеширования | G_FORUM_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_FORUM_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Новое на форуме"
Название гаджета | GU_FORUM_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество тем на одной странице | GU_FORUM_TOPICS_PER_PAGE | Указать какое количество новых сообщений выводить в гаджете.
Формат показа даты и времени | GU_FORUM_DATE_TIME_FORMAT | Можно перезадать формат даты и времени для этого гаджета.
Настройки гаджета "Новые сотрудники"
URL страницы с кадровыми перестановками | G_NEW_EMPLOYEES_LIST_URL | Адрес страницы.
Настройки по умолчанию параметров пользователя для гаджета "Новые сотрудники"
Название гаджета | GU_NEW_EMPLOYEES_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых записей | GU_NEW_EMPLOYEES_NUM_USERS | Указать какое количество новых сотрудников выводить в гаджете.
Показывать для отдела/офиса | GU_NEW_EMPLOYEES_DEPARTMENT | Указать для какого подразделения выводить данные.
Настройки гаджета "Общие документы"
Тип информационного блока (используется только для проверки) | G_SHARED_DOCS_IBLOCK_TYPE | Выбрать тип информационного блока где размещена информация.
Код информационного блока | G_SHARED_DOCS_IBLOCK_ID | Выбрать информационный блок где размещена информация.
URL страницы с библиотекой документов компании | G_SHARED_DOCS_LIST_URL | Адрес страницы.
URL страницы детального просмотра (по умолчанию - из настроек инфоблока) | G_SHARED_DOCS_DETAIL_URL | Адрес страницы.
Тип кеширования | G_SHARED_DOCS_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_SHARED_DOCS_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Общие документы"
Название гаджета | GU_SHARED_DOCS_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых документов | GU_SHARED_DOCS_DOCS_COUNT | Указать какое количество документов выводить в гаджете.
Показывать дату | GU_SHARED_DOCS_DISPLAY_DATE | [Y\N] Выбор сущностей для отображения в гаджете.
Показать картинку | GU_SHARED_DOCS_DISPLAY_PICTURE
Показать текст анонса | GU_SHARED_DOCS_DISPLAY_PREVIEW_TEXT
Настройки гаджета "Отсутствуют в офисе"
URL страницы со списком отсутсвий | G_ABSENT_LIST_URL | Адрес страницы.
Настройки по умолчанию параметров пользователя для гаджета "Отсутствуют в офисе"
Название гаджета | GU_ABSENT_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых записей | GU_ABSENT_NUM_USERS | Указать какое количество отсутсвий выводить в гаджете.
Показывать для отдела/офиса | GU_ABSENT_DEPARTMENT | Указать для какого подразделения выводить данные.
Настройки гаджета "Отчет 1С"
Тип кеширования | G_REPORT1C_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_REPORT1C_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Отсутствуют в офисе"
Название гаджета | GU_REPORT1C_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
URL сервера | GU_REPORT1C_R1_URL | Адрес сервера
Порт | GU_REPORT1C_R1_PORT | Порт сервера
Путь к веб-сервису | GU_REPORT1C_R1_PATH | Путь к веб-сервису
Имя пользователя | GU_REPORT1C_R1_LOGIN | Логин
Пароль | GU_REPORT1C_R1_PASSWORD | Пароль
Таймаут соединения, сек | GU_REPORT1C_R1_CONNTIMEOUT | Таймаут соединения
Кешировать ошибочные результаты | U_REPORT1C_R1_CACHE_ERR | Указать, кешировать или нет результаты, если они ошибочны.
Страница по-умолчанию | GU_REPORT1C_R1_INITIALREPORT | Какая страница будет открываться по умолчанию.
Настройки гаджета "Официальная информация"
Тип информационного блока (используется только для проверки) | G_OFFICIAL_IBLOCK_TYPE | Выбрать тип информационного блока где размещена информация.
Код информационного блока | G_OFFICIAL_IBLOCK_ID | Выбрать информационный блок где размещена информация.
URL страницы со списком официальной информации | G_OFFICIAL_LIST_URL | Адрес страницы.
URL страницы с подробно официальной информацией | G_OFFICIAL_DETAIL_URL | Адрес страницы.
Формат показа даты и времени | G_OFFICIAL_ACTIVE_DATE_FORMAT | Можно перезадать формат даты и времени для этого гаджета.
Тип кеширования | G_OFFICIAL_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_OFFICIAL_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Официальная информация"
Название гаджета | GU_OFFICIAL_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых документов | GU_OFFICIAL_NEWS_DOCS_COUNT | Указать какое количество документов выводить в гаджете.
Показать текст анонса | GU_OFFICIAL_DISPLAY_PREVIEW_TEXT | [Y\N] Вывод текста анонса в гаджете.
Настройки гаджета "Рабочие группы"
Имя переменной для группы | G_WORKGROUPS_GROUP_VAR | Переменная в которой передается имя группы.
Шаблон пути к странице группы | G_WORKGROUPS_PATH_TO_GROUP | Шаблон пути к странице.
Шаблон пути к странице поиска групп | G_WORKGROUPS_PATH_TO_GROUP_SEARCH | Шаблон пути к странице.
Время кеширования (сек.) | G_WORKGROUPS_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Рабочие группы"
Название гаджета | GU_WORKGROUPS_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Формат даты | GU_WORKGROUPS_DATE_TIME_FORMAT | Можно перезадать формат даты для гаджета.
Показывать изображение | GU_WORKGROUPS_DISPLAY_PICTURE | [Y\N] Выбор сущностей для отображения в гаджете.
Показать описание | GU_WORKGROUPS_DISPLAY_DESCRIPTION
Показать число участников | GU_WORKGROUPS_DISPLAY_NUMBER_OF_MEMBERS
Показать только мои | GU_WORKGROUPS_FILTER_MY
Настройки гаджета "События компании"
Тип информационного блока | G_COMPANY_CALENDAR_IBLOCK_TYPE | Выбрать тип информационного блока где размещена информация.
Информационный блок | G_COMPANY_CALENDAR_IBLOCK_ID | Выбрать информационный блок где размещена информация.
Адрес страницы для детального просмотра | G_COMPANY_CALENDAR_DETAIL_URL | Адрес страницы.
Тип кеширования | G_COMPANY_CALENDAR_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_COMPANY_CALENDAR_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "События компании"
Название гаджета | GU_COMPANY_CALENDAR_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество событий | GU_COMPANY_CALENDAR_EVENTS_COUNT | Указать какое количество событий выводить в гаджете.
Настройки по умолчанию параметров пользователя для гаджета "Список задач"
Название гаджета | GU_CRM_TASK_LIST_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Сущности в списке | GU_CRM_TASK_LIST_TASK_TYPE_LIST | Выбор сущностей, которые будут отображаться в гаджете.
Только мои | GU_CRM_TASK_LIST_ONLY_MY | [Y\N] Будут показаны только задачи созданные пользователем.
Сортировка | GU_CRM_TASK_LIST_SORT | Выбор параметра сортировки.
По | GU_CRM_TASK_LIST_SORT_BY | Выбор направления сортировки.
Количество событий | GU_CRM_TASK_LIST_TASK_COUNT | Указать какое количество событий выводить в гаджете.
Настройки по умолчанию параметров пользователя для гаджета "Список компаний"
Название гаджета | GU_CRM_COMPANY_LIST_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Тип компании | GU_CRM_COMPANY_LIST_TYPE_ID | Выбор типа компаний, которые будут отображаться в гаджете.
Только мои | GU_CRM_COMPANY_LIST_ONLY_MY | [Y\N] Будут показаны только компании пользователя.
Сортировка | GU_CRM_COMPANY_LIST_SORT | Выбор параметра сортировки.
По | GU_CRM_COMPANY_LIST_SORT_BY | Выбор направления сортировки.
Количество компаний | GU_CRM_COMPANY_LIST_COMPANY_COUNT | Указать какое количество компаний выводить в гаджете.
Настройки по умолчанию параметров пользователя для гаджета "Список контактов"
Название гаджета | GU_CRM_CONTACT_LIST_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Тип | GU_CRM_CONTACT_LIST_TYPE_ID | Выбор типов контактов, которые будут отображаться в гаджете.
Только мои | GU_CRM_CONTACT_LIST_ONLY_MY | [Y\N] Будут показаны только контакты созданные пользователем.
Сортировка | GU_CRM_CONTACT_LIST_SORT | Выбор параметра сортировки.
По | GU_CRM_TASK_CONTACT_SORT_BY | Выбор направления сортировки.
Количество контактов | GU_CRM_CONTACT_LIST_CONTACT_COUNT | Указать какое количество контактов выводить в гаджете.
Настройки по умолчанию параметров пользователя для гаджета "Список лидов"
Название гаджета | GU_CRM_LEAD_LIST_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Статус | GU_CRM_LEAD_LIST_STATUS_ID | Выбор статуса лида, в котором они будут отображаться в гаджете.
Только мои | GU_CRM_LEAD_LIST_ONLY_MY | [Y\N] Будут показаны только лиды созданные пользователем.
Сортировка | GU_CRM_LEAD_LIST_SORT | Выбор параметра сортировки.
По | GU_CRM_LEAD_LIST_SORT_BY | Выбор направления сортировки.
Количество лидов | GU_CRM_LEAD_LIST_LEAD_COUNT | Указать какое количество лидов выводить в гаджете.
Настройки по умолчанию параметров пользователя для гаджета "Список сделок"
Название гаджета | GU_CRM_DEAL_LIST_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Стадия | GU_CRM_DEAL_LIST_STAGE_ID | Выбор стадии сделок, которые будут отображаться в гаджете.
Только мои | GU_CRM_DEAL_LIST_ONLY_MY | [Y\N] Будут показаны только сделки созданные пользователем.
Сортировка | GU_CRM_DEAL_IST_SORT | Выбор параметра сортировки.
По | GU_CRM_TASK_DEAL_SORT_BY | Выбор направления сортировки.
Количество контактов | GU_CRM_DEAL_LIST_DEAL_COUNT | Указать какое количество сделок выводить в гаджете.
Настройки по умолчанию параметров пользователя для гаджета "Список событий"
Название гаджета | GU_CRM_EVENT_LIST_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Сущности в списке | GU_CRM_EVENT_LIST_EVENT_TYPE_LIST | Выбор сущности, событий которой будут отображаться в гаджете.
Количество событий | GU_CRM_EVENT_LIST_EVENT_COUNT | Указать какое количество событий выводить в гаджете.
Настройки гаджета "Фотогалерея компании"
Тип информационного блока | G_PHOTOS_IBLOCK_TYPE | Выбрать тип информационного блока где размещена информация.
Информационный блок | G_PHOTOS_IBLOCK_ID | Выбрать информационный блок где размещена информация.
URL страницы с фотогалереей компании | G_PHOTOS_LIST_URL | Адрес страницы.
Страница детального просмотра | G_PHOTOS_DETAIL_UR
Страница слайд-шоу | G_PHOTOS_DETAIL_SLIDE_SHOW_URL
Тип кеширования | G_PHOTOS_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_PHOTOS_CACHE_TIME | Задать время кеширования
Путь к профилю пользователя | G_PHOTOS_PATH_TO_USER | Адрес страницы.
Отображение имени | G_PHOTOS_NAME_TEMPLATE | Формат отображения имени.
Показывать логин, если не задано имя | G_PHOTOS_SHOW_LOGIN | [Y/N] При установленной опции будет отображаться логин пользователя, если в профиле не указаны имя и фамилия.
Настройки по умолчанию параметров пользователя для гаджета "Фотогалерея компании"
Название гаджета | GU_PHOTOS_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых фотографий | GU_PHOTOS_PAGE_ELEMENTS | Указать какое количество фотографий будет видно пользователю.
Дополнительно
Гаджеты, недоступные для удаления и настройки пользователями (должны быть настройках стола по умолчанию) | GADGETS_FIXED | Указать гаджеты, которые пользователи не смогут удалять при личной настройке Рабочего стола.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:desktop",
    "",
    Array(
        "ID" => "mainpage",
        "CAN_EDIT" => "N",
        "COLUMNS" => "3",
        "COLUMN_WIDTH_0" => "260px",
        "COLUMN_WIDTH_1" => "",
        "COLUMN_WIDTH_2" => "260px",
        "G_ADV_TYPE" => "INFO",
        "GADGETS" => Array("ALL"),
        "G_VIDEO_IBLOCK_TYPE" => "services",
        "G_VIDEO_IBLOCK_ID" => "10",
        "G_VIDEO_PATH_TO_FILE" => "19",
        "G_VIDEO_DURATION" => "20",
        "G_VIDEO_SECTION_ID" => "19",
        "G_VIDEO_ELEMENT_ID" => "47",
        "G_VIDEO_WIDTH" => "400",
        "G_VIDEO_HEIGHT" => "300",
        "G_VIDEO_CACHE_TYPE" => "A",
        "G_VIDEO_LIST_URL" => "/about/media.php",
        "G_VIDEO_CACHE_TIME" => "3600",
        "G_VOTE_CHANNEL_SID" => "COMPANY_s1",
        "G_VOTE_CACHE_TYPE" => "A",
        "G_VOTE_CACHE_TIME" => "3600",
        "G_VOTE_LIST_URL" => "/services/votes.php",
        "G_BIRTHDAY_STRUCTURE_PAGE" => "structure.php",
        "G_BIRTHDAY_PM_URL" => "/company/personal/messages/chat/#USER_ID#/",
        "G_BIRTHDAY_SHOW_YEAR" => "M",
        "G_BIRTHDAY_USER_PROPERTY" => Array("0"=>"PERSONAL_PHONE","1"=>"PERSONAL_MOBILE","2"=>"UF_DEPARTMENT","3"=>"",),
        "G_BIRTHDAY_LIST_URL" => "/company/birthdays.php",
        "G_LIFE_IBLOCK_TYPE" => "news",
        "G_LIFE_IBLOCK_ID" => "1",
        "G_LIFE_DETAIL_URL" => "/about/life.php?ID=#ELEMENT_ID#",
        "G_LIFE_CACHE_TYPE" => "A",
        "G_LIFE_CACHE_TIME" => "3600",
        "G_LIFE_LIST_URL" => "/about/life.php",
        "G_OFFICIAL_IBLOCK_TYPE" => "news",
        "G_OFFICIAL_IBLOCK_ID" => "2",
        "G_OFFICIAL_DETAIL_URL" => "/about/official.php?ID=#ELEMENT_ID#",
        "G_OFFICIAL_CACHE_TYPE" => "A",
        "G_OFFICIAL_CACHE_TIME" => "3600",
        "G_OFFICIAL_LIST_URL" => "/about/",
        "G_SHARED_DOCS_IBLOCK_TYPE" => "library",
        "G_SHARED_DOCS_IBLOCK_ID" => "22",
        "G_SHARED_DOCS_DETAIL_URL" => "/docs/shared/element/view/#ELEMENT_ID#/",
        "G_SHARED_DOCS_CACHE_TYPE" => "A",
        "G_SHARED_DOCS_CACHE_TIME" => "3600",
        "G_SHARED_DOCS_LIST_URL" => "/docs/",
        "G_COMPANY_CALENDAR_IBLOCK_TYPE" => "events",
        "G_COMPANY_CALENDAR_IBLOCK_ID" => "14",
        "G_COMPANY_CALENDAR_DETAIL_URL" => "/about/calendar.php",
        "G_COMPANY_CALENDAR_CACHE_TIME" => "3600000",
        "G_PHOTOS_IBLOCK_TYPE" => "photos",
        "G_PHOTOS_IBLOCK_ID" => "23",
        "G_PHOTOS_DETAIL_URL" => "/about/gallery/#SECTION_ID#/#ELEMENT_ID#/",
        "G_PHOTOS_DETAIL_SLIDE_SHOW_URL" => "/about/gallery/#SECTION_ID#/#ELEMENT_ID#/slide_show/",
        "G_PHOTOS_CACHE_TYPE" => "A",
        "G_PHOTOS_CACHE_TIME" => "3600000",
        "G_PHOTOS_LIST_URL" => "/about/gallery/",
        "G_WORKGROUPS_GROUP_VAR" => "group_id",
        "G_WORKGROUPS_PATH_TO_GROUP" => "/workgroups/group/#group_id#/",
        "G_WORKGROUPS_PATH_TO_GROUP_SEARCH" => "/workgroups/",
        "G_WORKGROUPS_CACHE_TIME" => "180",
        "G_BLOG_PATH_TO_BLOG" => "/company/personal/user/#user_id#/blog/",
        "G_BLOG_PATH_TO_POST" => "/company/personal/user/#user_id#/blog/#post_id#/",
        "G_BLOG_PATH_TO_GROUP_BLOG_POST" => "/workgroups/group/#group_id#/blog/#post_id#/",
        "G_BLOG_PATH_TO_USER" => "/company/personal/user/#user_id#/",
        "G_BLOG_CACHE_TYPE" => "A",
        "G_BLOG_CACHE_TIME" => "180",
        "G_FORUM_FID" => Array("1"),
        "G_FORUM_SORT_BY" => "LAST_POST_DATE",
        "G_FORUM_SORT_ORDER" => "DESC",
        "G_FORUM_URL_TEMPLATES_MESSAGE" => "/community/forum/messages/forum#FID#/topic#TID#/message#MID#/",
        "G_FORUM_CACHE_TYPE" => "A",
        "G_FORUM_CACHE_TIME" => "180",
        "G_TASKS_IBLOCK_ID" => "26",
        "G_TASKS_PATH_TO_GROUP_TASKS" => "/workgroups/group/#group_id#/tasks/",
        "G_TASKS_PATH_TO_GROUP_TASKS_TASK" => "/workgroups/group/#group_id#/tasks/task/#action#/#task_id#/",
        "G_TASKS_PATH_TO_USER_TASKS" => "/company/personal/user/#user_id#/tasks/",
        "G_TASKS_PATH_TO_USER_TASKS_TASK" => "/company/personal/user/#user_id#/tasks/task/#action#/#task_id#/",
        "G_CALENDAR_IBLOCK_TYPE" => "events",
        "G_CALENDAR_IBLOCK_ID" => "16",
        "G_CALENDAR_DETAIL_URL" => "/company/personal/user/#user_id#/calendar/",
        "G_CALENDAR_CACHE_TYPE" => "N",
        "G_CALENDAR_CACHE_TIME" => "3600000",
        "G_HONOUR_LIST_URL" => "/company/leaders.php",
        "G_NEW_EMPLOYEES_LIST_URL" => "/company/events.php"
    )
);?>


Видеоконференции (КП)

Модуль Видеоконференции предоставляет возможность проведения видеоконференцсвязи.

Примечание: модуль устарел и не поддерживается. Функционал видеосвязи выполняется модулем Вебмессенджер..

Настройки модуля описаны здесь.

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Список видеоконференций | video | Ввыводит список доступных видеоконференций.
Видеозвонок пользователю | video.call | Служит для организации видеозвонка пользователю.
Подключение видеоконференции | video.conf | Подключает к видеоконференции.


Видеозвонок пользователю

Описание video.call

Компонент служит для организации видеозвонка пользователю. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Сервисы > Видеоконференции.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока видеоконференций | IBLOCK_TYPE | Указывается тип информационного блока видеоконференций.
Инфоблок видеоконференций | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будут храниться видеоконференции.
ID пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя видеозвонка.
Шаблоны ссылок
Шаблон пути к видеозвонку | PATH_TO_VIDEO_CALL | Указывается шаблон пути к видеозвонку.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Видеоконференция.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:video.call","",Array(
        "IBLOCK_TYPE" => "events",
        "IBLOCK_ID" => "27",
        "USER_ID" => "",
        "PATH_TO_VIDEO_CALL" => "/services/video/detail.php?ID=#ID#",
        "SET_TITLE" => "Y"
    ),
);?>


Подключение видеоконференции

Описание video.conf

Компонент подключает к видеоконференции. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Сервисы > Видеоконференции.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока видеоконференций | IBLOCK_TYPE | Указывается тип информационного блока видеоконференций.
Инфоблок видеоконференций | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будут храниться видеоконференции.
ID видеоконференции | ID | Указывается код, в котором передается идентификатор видеоконференции. По умолчанию поле содержит $_REQUEST["ID"].
Шаблоны ссылок
Шаблон пути к видеоконференции | PATH_TO_VIDEO_CONF | Указывается шаблон пути к видеоконференции.
Шаблон пути к списку видеоконференций | PATH_TO_VIDEO_LIST | Указывается шаблон пути к списку видеоконференции.
Шаблон пути к странице пользователя | PATH_TO_USER | Указывается шаблон пути к странице пользователя видеоконференции.
Шаблон пути к чату с пользователем | PATH_TO_MESSAGES_CHAT | Указывается шаблон пути к чату с пользователем видеоконференции.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Видеоконференция.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:video.conf","",Array(
        "IBLOCK_TYPE" => "events",
        "IBLOCK_ID" => "27",
        "ID" => $_REQUEST["ID"],
        "PATH_TO_VIDEO_CONF" => "/services/video/detail.php?ID=#ID#",
        "PATH_TO_VIDEO_LIST" => "/services/video/",
        "PATH_TO_USER" => "/company/personal/user/#user_id#/",
        "PATH_TO_MESSAGES_CHAT" => "/company/personal/messages/chat/#user_id#/",
        "SET_TITLE" => "Y"
    ),
);?>


Список видеоконференций

Описание bitrix:video

Компонент выводит список доступных видеоконференций. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Сервисы > Видеоконференции.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока видеоконференций | IBLOCK_TYPE | Указывается тип информационного блока видеоконференций.
Инфоблок видеоконференций | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будут храниться видеоконференции.
Шаблоны ссылок
Шаблон пути к видеоконференции | PATH_TO_VIDEO_CONF | Указывается шаблон пути к видеоконференции.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Видеоконференции.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:video","",Array(
        "IBLOCK_TYPE" => "events",
        "IBLOCK_ID" => "27",
        "PATH_TO_VIDEO_CONF" => "/services/video/detail.php?ID=#ID#",
        "SET_TITLE" => "Y"
    ),
);?>


Интранет

Описание

Модуль Интранет предназначен для управления задачами и поручениями, организации коллективных событий, резервирования переговорных и ресурсов, работы с электронными заявками.

Модуль используется для выполнения простого и расширенного поиска по базе сотрудников, отображения кадровых изменений, происходящих в компании, автоматического построения графика отсутствия сотрудников, организации доски почета, мониторинга дней рождения сотрудников, создания календарей событий с возможностью взаимной интеграции, импорта пользователей из "1С:Зарплата и управление Персоналом".

Настройки модуля описаны здесь.

Модуль относится только к "Битрикс24 в коробке".

Компоненты

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Интерфейс 1с 8.2 | intranet.1c82.interface | Позволяет подключаться к web-платформе 1С 8.2.
Расчетные листки сотрудников | payroll.1c | Позволяет подключаться к web-платформе "1С: ЗУП" и выводить зарплатные листки сотрудников компании.
Руководство подразделениями | intranet.structure.head.user | Выводит список подразделений, руководителем которых является сотрудник.
HR
Календарь отсутствий | intranet.absence.calendar | Выводит график отсутствий сотрудников в виде календаря.
Отсутствия пользователя | intranet.absence.user | Выводит график отсутствий конкретного пользователя.
Отсутствующие сотрудники | intranet.structure.informer.absent | Выводит краткий список отсутствующих сотрудников.
Доска почета | intranet.structure.honour | Выводит список почетных сотрудников компании.
Доска почета пользователя | intranet.structure.honour.user | Выводит историю присутствия пользователя на доске почета.
Кадровые изменения | intranet.structure.events | Выводит список последних кадровых перестановок в компании.
Новые сотрудники | intranet.structure.informer.new | Выводит краткий список новых сотрудников компании.
Дни рождения | intranet.structure.birthday.nearest | Выводит список ближайших именинников офиса, отдела или филиала компании.
Бронирование переговорных
Бронирование переговорных (комплексный компонент) | intranet.reserve_meeting | Выводит календарь занятости переговорных комнат, позволяет бронировать переговорные и управлять ими.
Меню | intranet.reserve_meeting.menu | Выводит меню комплексного компонента.
Переговорная | intranet.reserve_meeting.meeting | Служит для отображения переговорной.
Поиск переговорных | intranet.reserve_meeting.search | Служит для поиска переговорных.
Просмотр резервирования | intranet.reserve_meeting.view_item | Предназначен для просмотра резервирования переговорных.
Резервирование переговорной | ntranet.reserve_meeting.reserve | Служит для резервирования переговорной.
Создание переговорной | intranet.reserve_meeting.add | Служит для создания переговорной комнаты.
Список переговорных | intranet.reserve_meeting.list | Выводит список переговорных.
Оргструктура
Поиск сотрудника (комплексный компонент) | intranet.search | Выводит форму поиска и список найденных сотрудников корпоративного портала.
Структура компании (комплексный компонент) | intranet.structure | Выводит дерево структуры компании со списком сотрудников корпоративного портала.
Визуальная структура компании | intranet.structure.visual | Выводит визуальное представление древовидной структуры компании.
Список сотрудников | intranet.structure.list | Выводит список сотрудников, удовлетворяющих внешнему фильтру.
Форма поиска | intranet.structure.selector | Выводит форму фильтрации списка сотрудников.
Импорт оргструктуры из 1С:ЗУП | intranet.users.import.1c | Позволяет подключаться к "1С:ЗУП" и производить импорт организационной структуры в формате CommerceML v2.
Импорт оргструктуры из 1С:ЗУП (hrxml) | intranet.users.import.1c.hrxml | Позволяет подключаться к "1С:ЗУП" и производить импорт организационной структуры в формате HR-XML.
Задачи 1.0
Меню | intranet.tasks.menu | Служит для показа меню.
Задачи | intranet.tasks | Служит для отображения задач.
Задачи (список) | intranet.tasks_list | Служит для отображения списка задач.
Изменение задачи | intranet.tasks.create | Служит для создания и изменения задач.
Изменение представления | intranet.tasks.create_view | Служит для создания и изменения представлений.
Список задач | intranet.tasks.view | Вспомогательный компонент, выводящий список задач. (Компонент служебный, не описывается.)
Календарь событий
Календарь событий | intranet.event.calendar | Служит для создания календаря событий.
Список событий календаря | intranet.event.list | Выводит список ближайших событий календаря.
Системные (не описываются)
Представления графика отсутствий | intranet.absence.calendar.view | Служебный компонент, шаблоны которого содержат скрипты обработки представлений графика отсутствий (закладки День/Неделя/Месяц).
Визитка сотрудника | intranet.system.person | Выводит персональные данные на странице Поиск сотрудников продукта "1С-Битрикс: Корпоративный портал".
Список задач | intranet.tasks.view | Служебный компонент, применяется в построении списка задач.


Расчетные листки сотрудников

Описание payroll.1c

Компонент позволяет подключаться к web-платформе "1С: ЗУП" и выводить зарплатные листки сотрудников компании. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Служебные > Расчетные листки сотрудников.

Параметры

Поле | Параметр | Описание
Основные параметры
Список организаций | ORG_LIST | Указывается организация, зарплатные листки сотрудников которой будут выводится. Обязательно нужно нажать на кнопку ОК. Форма перезагрузится и появится группа настроек Настройки для организации.
Таймаут соединения, сек | PR_TIMEOUT | Указывается таймаут соединения с web-платформой "1С: ЗУП" в секундах.
Пространство имен | PR_NAMESPACE | Указывается пространство имен для подключения к порталу.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто: действует при включенном кешировании в течение заданного времени;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Настройки для организации
URL веб-сервиса | PR_URL | Указывается адрес сервиса, полученный от администратора программы "1С: ЗУП". Настройки на стороне "1С: ЗУП" описаны тут [image].
Порт | PR_PORT | Указывается порт сервиса, полученный от администратора программы "1С: ЗУП".
Имя пользователя | PR_LOGIN | Указывается логин сервиса, полученный от администратора программы "1С: ЗУП".
Пароль | PR_PASSWORD | Указывается пароль сервиса, полученный от администратора программы "1С: ЗУП".

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:payroll.1c","",Array(
        "ORG_LIST" => array("Моя компания"),
        "PR_TIMEOUT" => "25",
        "PR_NAMESPACE" => "http://test_server.ru",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "PR_URL_0" => "http://test_server.ru/zupws/ws/zupws",
        "PR_PORT_0" => "80",
        "PR_LOGIN_0" => "demo",
        "PR_PASSWORD_0" => "demo"
    )
);?>


Интерфейс 1с 8.2

Описание intranet.1c82.interface

Компонент позволяет подключаться к web-платформе 1С 8.2. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Служебные > Отчеты по 1С.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
URL к 1C 8.2 | 1C_URL | Указывается путь для подключения интерфейса к web-платформе 1С 8.2.
Логин | LOGIN | Указывается логин для подключения интерфейса к web-платформе 1С 8.2.
Пароль | PASS | Указывается пароль для подключения интерфейса к web-платформе 1С 8.2.
Название | NAME | Указывается название, которое будет отображаться в заголовке страницы.
Открывать в отдельном окне | BLANK_MODE | [Y|N] При отмеченной опции работа с web-платформой 1С 8.2 будет происходить в отдельном окне.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено <название>, указанное в параметре NAME.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.1c82.interface","",Array(
        "1C_URL" => "http://site.ru/1c/",
        "LOGIN" => "Администратор",
        "PASS" => "123456",
        "NAME" => "Подключение к 1С 8.2",
        "BLANK_MODE" => "Y",
        "SET_TITLE" => "Y"
    )
);?>


Импорт оргструктуры из 1С:ЗУП

Описание intranet.users.import.1c

Компонент позволяет подключаться к "1С:ЗУП" и производить импорт организационной структуры в формате CommerceML v2. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Каталог > Импорт оргструктуры из 1С:ЗУП.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип инфоблока, в который будут импортироваться данные оргструктуры.
Инфоблок подразделений | DEPARTMENTS_IBLOCK_ID | Указывается инфоблок подразделений.
Инфоблок графика отсутствий | ABSENCE_IBLOCK_ID | Указывается инфоблок графика отсутствий.
Инфоблок кадровых перестановок | STATE_HISTORY_IBLOCK_ID | Указывается инфоблок кадровых перестановок.
Сайт для привязки пользователей | SITE_ID | Указывается идентификатор сайта, к которому будет привязка пользователей.
Проводить проверку целостности структуры | STRUCTURE_CHECK | [Y|N] При отмеченной опции будет проводиться проверка целостности структуры.
Интервал одного шага в секундах (0 - выполнять загрузку за один шаг) | INTERVAL | Указывается интервал одного шага при импорте в секундах.
Группы, пользователям которых разрешена загрузка | GROUP_PERMISSIONS | Указываются группы пользователей, которым разрешен импорт оргструктуры.
Размер единовременно загружаемой части файла (в байтах) | FILE_SIZE_LIMIT | Указывается размер в байтах единовременно загружаемой части файла.
Использовать сжатие zip, если доступно | USE_ZIP | [Y|N] При отмеченной опции включается сжатие zip.
E-mail по умолчанию | DEFAULT_EMAIL | Указывается e-mail по умолчанию.
Шаблон автоматического формирования логина | LOGIN_TEMPLATE | Указывается шаблон автоматического формирования логина.
Обновляемые свойства | UPDATE_PROPERTIES | Указываются свойства, которые будут обновляться при импорте оргструктуры.
Уведомление пользователей
E-mail-уведомление новым пользователям EMAIL_NOTIFY Выбор действия отсылки e-mail-уведомлений новым пользователям:
  • N - не отсылать;
  • E - только если указан e-mail;
  • Y - всем.
Отсылать уведомления сразу | EMAIL_NOTIFY_IMMEDIATELY | [Y|N] При отмеченной опции e-mail-уведомлений новым пользователям будут отправлять сразу при импорте данных.
Привязка к дополнительным свойствам XML
XML-идентификатор свойства "Электронная почта" | EMAIL_PROPERTY_XML_ID | Указывается XML-идентификатор свойства "Электронная почта".
XML-идентификатор свойства "Логин" | LOGIN_PROPERTY_XML_ID | Указывается XML-идентификатор свойства "Логин".
XML-идентификатор свойства "Пароль" | PASSWORD_PROPERTY_XML_ID | Указывается XML-идентификатор свойства "Пароль".
LDAP
XML-идентификатор свойства "Учетная запись AD" | LDAP_ID_PROPERTY_XML_ID | Указывается XML-идентификатор свойства "Учетная запись AD".
Сервер LDAP | LDAP_SERVER | Указывается сервер LDAP.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.users.import.1c","",
    Array(
        "IBLOCK_TYPE" => "structure",
        "DEPARTMENTS_IBLOCK_ID" => "5",
        "ABSENCE_IBLOCK_ID" => "3",
        "STATE_HISTORY_IBLOCK_ID" => "6",
        "SITE_ID" => "s1",
        "STRUCTURE_CHECK" => "Y",
        "INTERVAL" => "30",
        "GROUP_PERMISSIONS" => array("1"),
        "FILE_SIZE_LIMIT" => "204800",
        "USE_ZIP" => "Y",
        "DEFAULT_EMAIL" => "admin@myexample.com",
        "LOGIN_TEMPLATE" => "user_#",
        "EMAIL_NOTIFY" => "E",
        "EMAIL_NOTIFY_IMMEDIATELY" => "Y",
        "UPDATE_PROPERTIES" => array("NAME", "SECOND_NAME", "LAST_NAME", "PERSONAL_PROFESSION", "PERSONAL_WWW", "PERSONAL_BIRTHDAY", "PERSONAL_ICQ", "PERSONAL_GENDER", "PERSONAL_PHOTO", "PERSONAL_PHONE", "PERSONAL_FAX", "PERSONAL_MOBILE", "PERSONAL_PAGER", "PERSONAL_STREET", "PERSONAL_CITY", "PERSONAL_STATE", "PERSONAL_ZIP", "PERSONAL_COUNTRY", "WORK_POSITION", "WORK_PHONE", "UF_DEPARTMENT", "UF_PHONE_INNER", "UF_INN", "UF_DISTRICT", "UF_SKYPE", "UF_TWITTER", "UF_LINKEDIN", "UF_XING", "UF_WEB_SITES", "UF_SKILLS", "UF_INTERESTS", "UF_BXDAVEX_CALSYNC", "UF_PUBLIC", "UF_WORK_BINDING", "UF_TIMEMAN", "UF_TM_MAX_START", "UF_TM_MIN_FINISH", "UF_TM_MIN_DURATION", "UF_TM_REPORT_REQ", "UF_TM_REPORT_TPL", "UF_TM_FREE", "UF_TM_TIME", "UF_TM_DAY", "UF_TM_REPORT_DATE", "UF_REPORT_PERIOD", "UF_DELAY_TIME", "UF_LAST_REPORT_DATE", "UF_SETTING_DATE", "UF_TM_ALLOWED_DELTA"),
        "EMAIL_PROPERTY_XML_ID" => "",
        "LOGIN_PROPERTY_XML_ID" => "",
        "PASSWORD_PROPERTY_XML_ID" => "",
        "LDAP_ID_PROPERTY_XML_ID" => ""
    ),
false
);?>


Импорт оргструктуры из 1С:ЗУП (hrxml)

Описание intranet.users.import.1c.hrxml

Компонент позволяет подключаться к "1С:ЗУП" и производить импорт организационной структуры в формате HR-XML. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Каталог > Импорт оргструктуры из 1С:ЗУП.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип инфоблока, в который будут импортироваться данные оргструктуры.
Инфоблок подразделений | DEPARTMENTS_IBLOCK_ID | Указывается инфоблок подразделений.
Инфоблок графика отсутствий | ABSENCE_IBLOCK_ID | Указывается инфоблок графика отсутствий.
Инфоблок кадровых перестановок | STATE_HISTORY_IBLOCK_ID | Указывается инфоблок кадровых перестановок.
Сайт для привязки пользователей | SITE_ID | Указывается идентификатор сайта, к которому будет привязка пользователей.
Группы, пользователям которых разрешена загрузка | GROUP_PERMISSIONS | Указываются группы пользователей, которым разрешен импорт оргструктуры.
E-mail по умолчанию | DEFAULT_EMAIL | Указывается e-mail, на который по умолчанию будут направляться информационные сообщения. Например, сообщения об успешном импорте, ошибках и т.д.
Формировать уникальный e-mail | UNIQUE_EMAIL | [Y|N] При отмеченной опции будет формироваться уникальный e-mail
Шаблон автоматического формирования логина | LOGIN_TEMPLATE | Указывается шаблон автоматического формирования логина пользователей.
Обновляемые свойства | UPDATE_PROPERTIES | Указываются свойства, которые будут обновляться при импорте оргструктуры.
Уведомление пользователей
E-mail-уведомление новым пользователям EMAIL_NOTIFY Выбор действия отсылки e-mail-уведомлений новым пользователям:
  • N - не отсылать;
  • E - только если указан e-mail;
  • Y - всем.
Отсылать уведомления сразу | EMAIL_NOTIFY_IMMEDIATELY | [Y|N] При отмеченной опции e-mail-уведомлений новым пользователям будут отправлять сразу при импорте данных.
LDAP
XML-идентификатор свойства "Учетная запись AD" | LDAP_ID_PROPERTY_XML_ID | Указывается XML-идентификатор свойства "Учетная запись AD".
Сервер LDAP | LDAP_SERVER | Указывается сервер LDAP.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.users.import.1c.hrxml","",
    Array(
        "IBLOCK_TYPE" => "structure",
        "DEPARTMENTS_IBLOCK_ID" => "5",
        "ABSENCE_IBLOCK_ID" => "3",
        "STATE_HISTORY_IBLOCK_ID" => "6",
        "SITE_ID" => "s1",
        "GROUP_PERMISSIONS" => array("1"),
        "FILE_SIZE_LIMIT" => "204800",
        "USE_ZIP" => "Y",
        "DEFAULT_EMAIL" => "admin@myexample.com",
        "UNIQUE_EMAIL" => "Y",
        "LOGIN_TEMPLATE" => "user_#",
        "EMAIL_NOTIFY" => "E",
        "EMAIL_NOTIFY_IMMEDIATELY" => "Y",
        "UPDATE_PROPERTIES" => array("NAME", "SECOND_NAME", "LAST_NAME", "PERSONAL_PROFESSION", "PERSONAL_WWW", "PERSONAL_BIRTHDAY", "PERSONAL_ICQ", "PERSONAL_GENDER", "PERSONAL_PHOTO", "PERSONAL_PHONE", "PERSONAL_FAX", "PERSONAL_MOBILE", "PERSONAL_PAGER", "PERSONAL_STREET", "PERSONAL_CITY", "PERSONAL_STATE", "PERSONAL_ZIP", "PERSONAL_COUNTRY", "WORK_POSITION", "WORK_PHONE", "UF_DEPARTMENT", "UF_PHONE_INNER", "UF_INN", "UF_DISTRICT", "UF_SKYPE", "UF_TWITTER", "UF_LINKEDIN", "UF_XING", "UF_WEB_SITES", "UF_SKILLS", "UF_INTERESTS", "UF_BXDAVEX_CALSYNC", "UF_PUBLIC", "UF_WORK_BINDING", "UF_TIMEMAN", "UF_TM_MAX_START", "UF_TM_MIN_FINISH", "UF_TM_MIN_DURATION", "UF_TM_REPORT_REQ", "UF_TM_REPORT_TPL", "UF_TM_FREE", "UF_TM_TIME", "UF_TM_DAY", "UF_TM_REPORT_DATE", "UF_REPORT_PERIOD", "UF_DELAY_TIME", "UF_LAST_REPORT_DATE", "UF_SETTING_DATE", "UF_TM_ALLOWED_DELTA"),
        "LDAP_ID_PROPERTY_XML_ID" => ""
    ),
false
);?>


Задачи 1.0

В настоящее время существует более новая версия задач - Задачи 2.0, которая включает собственный модуль. Рекомендуется использовать именно их.


Меню

Описание intranet.tasks.menu

Компонент служит для показа меню. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Задачи.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Указывается тип информационного блока задач.
Информационый блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будут храниться задачи для пользователя или для группы.
Свойства задачи | TASKS_FIELDS_SHOW | Указываются поля, которые должны быть отображены при показе задач.
Тип задач | TASK_TYPE | Указывается тип задач: Для группы (group) или Для пользователя (user).
Код владельца | OWNER_ID | Поле содержит код владельца задачи.
Шаблоны ссылок
Путь к списку задач | PATH_TO_GROUP_TASKS | Указывается путь к списку задач.
Путь к задаче | PATH_TO_GROUP_TASKS_TASK | Указывается путь к задаче.
Путь к представлению | PATH_TO_GROUP_TASKS_VIEW | Указывается путь к представлению задачи.
Псевдонимы переменных
Имя переменной для кода задачи | TASK_VAR | Поле содержит имя переменной для кода задачи.
Имя переменной для кода пользователя | USER_VAR | Поле содержит имя переменной для кода пользователя.
Имя переменной для кода группы | GROUP_VAR | Поле содержит имя переменной для кода группы.
Имя переменной для кода представления | VIEW_VAR | Поле содержит имя переменной для кода представления.
Имя переменной для кода действия | ACTION_VAR | Поле содержит имя переменной для кода действия.
Имя переменной для кода страницы | PAGE_VAR | Поле содержит имя переменной для кода страницы.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.tasks.menu","",Array(
    "IBLOCK_TYPE" => "services",
    "IBLOCK_ID" => "25",
    "TASKS_FIELDS_SHOW" => "ID",
    "TASK_TYPE" => "user",
    "OWNER_ID" => $arResult["User"]["ID"],
    "TASK_VAR" => $arParams["TASK_VAR"],
    "USER_VAR" => $arParams["USER_VAR"],
    "GROUP_VAR" => $arParams["GROUP_VAR"],
    "VIEW_VAR" => $arParams["VIEW_VAR"],
    "ACTION_VAR" => $arParams["TASK_ACTION_VAR"],
    "PAGE_VAR" => $arParams["PAGE_VAR"],
    "PATH_TO_GROUP_TASKS" => $arParams["PATH_TO_GROUP_TASKS"],
    "PATH_TO_GROUP_TASKS_TASK" => $arParams["PATH_TO_GROUP_TASKS_TASK"],
    "PATH_TO_GROUP_TASKS_VIEW" => $arParams["PATH_TO_GROUP_TASKS_VIEW"],
    )
);?>


Задачи

Описание intranet.tasks

Компонент служит для отображения задач. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Задачи.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Указывается тип информационного блока задач.
Информационый блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будут храниться задачи для пользователя или для группы.
Свойства задачи | TASKS_FIELDS_SHOW | Указываются поля, которые должны быть отображены при показе задач.
Тип задач | TASK_TYPE | Указывается тип задач: Для группы (group) или Для пользователя (user).
Код владельца | OWNER_ID | Поле содержит код владельца задачи.
Шаблоны ссылок
Путь к списку задач | PATH_TO_GROUP_TASKS | Указывается путь к списку задач.
Путь к задаче | PATH_TO_GROUP_TASKS_TASK | Указывается путь к задаче.
Путь к представлению | PATH_TO_GROUP_TASKS_VIEW | Указывается путь к представлению задачи.
Дополнительные настройки
Включить цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочке навигации будут отображены переходы по страницам социальной сети.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на каждой странице будет установлен заголовок <имя_пользователя> : Задачи или <имя_группы> : Задачи.
Количество записей на странице | ITEMS_COUNT | Указывается количество представлений отображаемых на одной странице. Остальные представления будут выведены с помощью постраничной навигации.
Псевдонимы переменных
Имя переменной для кода задачи | TASK_VAR | Поле содержит имя переменной для кода задачи.
Имя переменной для кода пользователя | USER_VAR | Поле содержит имя переменной для кода пользователя.
Имя переменной для кода группы | GROUP_VAR | Поле содержит имя переменной для кода группы.
Имя переменной для кода представления | VIEW_VAR | Поле содержит имя переменной для кода представления.
Имя переменной для кода действия | ACTION_VAR | Поле содержит имя переменной для кода действия.
Имя переменной для кода страницы | PAGE_VAR | Поле содержит имя переменной для кода страницы.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.tasks","",Array(
    "IBLOCK_TYPE" => "services",
    "IBLOCK_ID" => "25",
    "TASKS_FIELDS_SHOW" => "ID",
    "TASK_TYPE" => "user",
    "OWNER_ID" => $arResult["User"]["ID"],
    "TASK_VAR" => $arParams["TASK_VAR"],
    "USER_VAR" => $arParams["USER_VAR"],
    "GROUP_VAR" => $arParams["GROUP_VAR"],
    "VIEW_VAR" => $arParams["VIEW_VAR"],
    "ACTION_VAR" => $arParams["TASK_ACTION_VAR"],
    "PAGE_VAR" => $arParams["PAGE_VAR"],
    "PATH_TO_GROUP_TASKS" => $arParams["PATH_TO_GROUP_TASKS"],
    "PATH_TO_GROUP_TASKS_TASK" => $arParams["PATH_TO_GROUP_TASKS_TASK"],
    "PATH_TO_GROUP_TASKS_VIEW" => $arParams["PATH_TO_GROUP_TASKS_VIEW"],
    "SET_NAVCHAIN" => "Y",
    "SET_TITLE" => "Y",
    "ITEMS_COUNT" => "20"
    )
);?>


Задачи (список)

Описание intranet.tasks_list

Компонент служит для отображения задач. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Задачи.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Указывается тип информационного блока задач.
Информационый блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будут храниться задачи для пользователя или для группы.
Свойства задачи | TASKS_FIELDS_SHOW | Указываются поля, которые должны быть отображены при показе задач.
Тип задач | TASK_TYPE | Указывается тип задач: Для группы (group) или Для пользователя (user).
Код владельца | OWNER_ID | Поле содержит код владельца задачи.
Шаблоны ссылок
Путь к списку задач группы | PATH_TO_GROUP_TASKS | Указывается путь к списку задач группы.
Путь к задаче группы | PATH_TO_GROUP_TASKS_TASK | Указывается путь к задаче группы.
Путь к списку задач пользователя | PATH_TO_USER_TASKS | Указывается путь к списку задач пользователя.
Путь к задаче пользователя | PATH_TO_USER_TASKS_TASK | Указывается путь к задаче пользователя.
Дополнительные настройки
Включить цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочке навигации будут отображены переходы по страницам социальной сети.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на каждой странице будет установлен заголовок <имя_пользователя> : Задачи или <имя_группы> : Задачи.
Количество записей на странице | ITEMS_COUNT | Параметр определяет количество задач отображаемых на одной странице. Остальные задачи будут выведены с помощью постраничной навигации.
Псевдонимы переменных
Имя переменной для кода задачи | TASK_VAR | Поле содержит имя переменной для кода задачи.
Имя переменной для кода пользователя | USER_VAR | Поле содержит имя переменной для кода пользователя.
Имя переменной для кода группы | GROUP_VAR | Поле содержит имя переменной для кода группы.
Имя переменной для кода представления | VIEW_VAR | Поле содержит имя переменной для кода представления.
Имя переменной для кода действия | ACTION_VAR | Поле содержит имя переменной для кода действия.
Имя переменной для кода страницы | PAGE_VAR | Поле содержит имя переменной для кода страницы.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.tasks_list",".default",Array(
    "IBLOCK_TYPE" => "services",
    "IBLOCK_ID" => "25",
    "TASKS_FIELDS_SHOW" => "ID",
    "TASK_TYPE" => "user",
    "OWNER_ID" => $arResult["User"]["ID"],
    "TASK_VAR" => $arParams["TASK_VAR"],
    "USER_VAR" => "",
    "GROUP_VAR" => $arParams["GROUP_VAR"],
    "VIEW_VAR" => $arParams["VIEW_VAR"],
    "ACTION_VAR" => $arParams["TASK_ACTION_VAR"],
    "PAGE_VAR" => $arParams["PAGE_VAR"],
    "PATH_TO_GROUP_TASKS" => $arParams["PATH_TO_GROUP_TASKS"],
    "PATH_TO_GROUP_TASKS_TASK" => $arParams["PATH_TO_GROUP_TASKS_TASK"],
    "PATH_TO_USER_TASKS" => $arParams["PATH_TO_USER_TASKS"],
    "PATH_TO_USER_TASKS_TASK" => $arParams["PATH_TO_USER_TASKS_TASK"],
    "SET_NAVCHAIN" => "Y",
    "SET_TITLE" => "Y",
    "ITEMS_COUNT" => "20"
    )
);?>


Изменение задачи

Описание intranet.tasks.create

Компонент служит для создания и изменения задач. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Задачи.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Указывается тип информационного блока задач.
Информационый блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будут храниться задачи для пользователя или для группы.
Свойства задачи | TASKS_FIELDS_SHOW | Указываются поля, которые должны быть отображены при показе задач.
Тип задач TASK_TYPE Указывается тип задач:
  • Для группы (group);
  • Для пользователя (user).
Код владельца | OWNER_ID | Поле содержит код владельца задачи.
Шаблоны ссылок
Путь к списку задач | PATH_TO_GROUP_TASKS | Указывается путь к списку задач.
Путь к задаче | PATH_TO_GROUP_TASKS_TASK | Указывается путь к задаче.
Путь к представлению | PATH_TO_GROUP_TASKS_VIEW | Указывается путь к представлению задачи.
Дополнительные настройки
Включить цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочке навигации будут отображены переходы по страницам социальной сети.
Устанавливать заголовок страницы SET_TITLE [Y|N] При отмеченной опции на каждой странице будет установлен заголовок:
  • <имя_пользователя> : Создание новой задачи или <имя_группы> : Создание новой задачи;
  • <имя_пользователя> : Изменение задачи или <имя_группы> : Изменение задачи.
Количество записей на странице | ITEMS_COUNT | Указывается количество представлений отображаемых на одной странице. Остальные представления будут выведены с помощью постраничной навигации.
Псевдонимы переменных
Имя переменной для кода задачи | TASK_VAR | Поле содержит имя переменной для кода задачи.
Имя переменной для кода пользователя | USER_VAR | Поле содержит имя переменной для кода пользователя.
Имя переменной для кода группы | GROUP_VAR | Поле содержит имя переменной для кода группы.
Имя переменной для кода представления | VIEW_VAR | Поле содержит имя переменной для кода представления.
Имя переменной для кода действия | ACTION_VAR | Поле содержит имя переменной для кода действия.
Имя переменной для кода страницы | PAGE_VAR | Поле содержит имя переменной для кода страницы.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.tasks.create",".default",Array(
    "IBLOCK_TYPE" => "services",
    "IBLOCK_ID" => "25",
    "TASKS_FIELDS_SHOW" => "ID",
    "TASK_TYPE" => "user",
    "OWNER_ID" => $arResult["User"]["ID"],
    "TASK_VAR" => $arParams["TASK_VAR"],
    "USER_VAR" => $arParams["USER_VAR"],
    "GROUP_VAR" => $arParams["GROUP_VAR"],
    "VIEW_VAR" => $arParams["VIEW_VAR"],
    "ACTION_VAR" => $arParams["TASK_ACTION_VAR"],
    "PAGE_VAR" => $arParams["PAGE_VAR"],
    "PATH_TO_GROUP_TASKS" => $arParams["PATH_TO_GROUP_TASKS"],
    "PATH_TO_GROUP_TASKS_TASK" => $arParams["PATH_TO_GROUP_TASKS_TASK"],
    "PATH_TO_GROUP_TASKS_VIEW" => $arParams["PATH_TO_GROUP_TASKS_VIEW"],
    "SET_NAVCHAIN" => "Y",
    "SET_TITLE" => "Y",
    "ITEMS_COUNT" => "20"
    )
);?>


Изменение представления

Описание intranet.tasks.create_view

Компонент служит для создания и изменения представлений. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Задачи.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Указывается тип информационного блока задач.
Информационый блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будут храниться задачи для пользователя или для группы.
Свойства задачи | TASKS_FIELDS_SHOW | Указываются поля, которые должны быть отображены при показе задач.
Тип задач TASK_TYPE Указывается тип задач:
  • Для группы (group);
  • Для пользователя (user).
Код владельца | OWNER_ID | Поле содержит код владельца задачи.
Шаблоны ссылок
Путь к списку задач | PATH_TO_GROUP_TASKS | Указывается путь к списку задач.
Путь к задаче | PATH_TO_GROUP_TASKS_TASK | Указывается путь к задаче.
Путь к представлению | PATH_TO_GROUP_TASKS_VIEW | Указывается путь к представлению задачи.
Дополнительные настройки
Включить цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочке навигации будут отображены переходы по страницам социальной сети.
Устанавливать заголовок страницы SET_TITLE [Y|N] При отмеченной опции на каждой странице будет установлен заголовок:
  • <имя_пользователя> : Создание нового представления или <имя_группы> : Создание нового представления;
  • <имя_пользователя> : Изменение представления или <имя_группы> : Изменение представления.
Количество записей на странице | ITEMS_COUNT | Указывается количество представлений отображаемых на одной странице. Остальные представления будут выведены с помощью постраничной навигации.
Псевдонимы переменных
Имя переменной для кода задачи | TASK_VAR | Поле содержит имя переменной для кода задачи.
Имя переменной для кода пользователя | USER_VAR | Поле содержит имя переменной для кода пользователя.
Имя переменной для кода группы | GROUP_VAR | Поле содержит имя переменной для кода группы.
Имя переменной для кода представления | VIEW_VAR | Поле содержит имя переменной для кода представления.
Имя переменной для кода действия | ACTION_VAR | Поле содержит имя переменной для кода действия.
Имя переменной для кода страницы | PAGE_VAR | Поле содержит имя переменной для кода страницы.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.tasks.create_view",".default",Array(
    "IBLOCK_TYPE" => "services",
    "IBLOCK_ID" => "25",
    "TASKS_FIELDS_SHOW" => "ID",
    "TASK_TYPE" => "user",
    "OWNER_ID" => $arResult["User"]["ID"],
    "TASK_VAR" => $arParams["TASK_VAR"],
    "USER_VAR" => $arParams["USER_VAR"],
    "GROUP_VAR" => $arParams["GROUP_VAR"],
    "VIEW_VAR" => $arParams["VIEW_VAR"],
    "ACTION_VAR" => $arParams["TASK_ACTION_VAR"],
    "PAGE_VAR" => $arParams["PAGE_VAR"],
    "PATH_TO_GROUP_TASKS" => $arParams["PATH_TO_GROUP_TASKS"],
    "PATH_TO_GROUP_TASKS_TASK" => $arParams["PATH_TO_GROUP_TASKS_TASK"],
    "PATH_TO_GROUP_TASKS_VIEW" => $arParams["PATH_TO_GROUP_TASKS_VIEW"],
    "SET_NAVCHAIN" => "Y",
    "SET_TITLE" => "Y",
    "ITEMS_COUNT" => "20"
    )
);?>


Отправить отзыв по этому разделу

Календарь событий

  • Календарь событий
  • Список событий календаря


Календарь событий

Описание intranet.event_calendar

Компонент служит для отображения календаря событий. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Календарь событий.

Внимание! Компонент устарел, рекомендуется использовать новый компонент Календарь событий 2.0.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип информационного блока календаря событий.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором хранятся события.
Разрешить использовать избранные календари | ALLOW_SUPERPOSE | [Y|N] При отмеченной опции доступен функционал избранных календарей.
Использовать возможность бронирования переговорных при создании событий | ALLOW_RES_MEETING | [Y|N] При отмеченной опции можно будет использовать возможность бронирования переговорных при создании событий.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:intranet.event_calendar","",Array(
        "IBLOCK_TYPE" => "events",
        "IBLOCK_ID" => "13",
        "ALLOW_SUPERPOSE" => "Y",
        "ALLOW_RES_MEETING" => "Y",
    )
);?>


Список событий календаря

Описание intranet.event_list

Компонент выводит список ближайших событий календаря. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Контент > Календарь событий.

Внимание! Компонент устарел, рекомендуется использовать новый компонент Список событий календаря 2.0.

Параметры

Поле | Параметр | Описание
Основные параметры
Показывать события текущего пользователя B_CUR_USER_LIST [Y|N] При отмеченной опции будут показаны события календаря текущего пользователя.

Если опция не отмечена (параметр принимает значение N), то необходимо настроить следущие параметры: IBLOCK_TYPE, IBLOCK_ID и IBLOCK_SECTION_ID.
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, события календарей которого будут выводиться.
ID секции инфоблока | IBLOCK_SECTION_ID | В поле указывается код, в котором передается идентификатор календаря (раздела инфоблока), события которого будут отображены.
Дата инициализации | INIT_DATE | Если в параметре указана дата, то список ближайших событий будет выведен для заданной даты. В противном случае список ближайших событий календаря будет отображен для текущей даты.
Показывать ближайшие события за количество месяцев | FUTURE_MONTH_COUNT | Указывается количество месяцев, за которые будут отображены ближайшие события.
Адрес страницы для детального просмотра | DETAIL_URL | Указывается адрес страницы для детального просмотра события календаря.
Количество событий в списке | EVENTS_COUNT | Указывается количество событий, которые будут отображены в списке ближайших событий.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:intranet.event_list","",Array(
        "B_CUR_USER_LIST" => "N",
        "IBLOCK_TYPE" => "events",
        "IBLOCK_ID" => "13",
        "IBLOCK_SECTION_ID" => "",
        "INIT_DATE" => "--текущая дата--",
        "FUTURE_MONTH_COUNT" => "2",
        "DETAIL_URL" => "",
        "EVENTS_COUNT" => "5",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Экстранет (КП)

Модуль Экстранет – расширение для продукта «Битрикс24 в коробке», которое позволяет компании осуществлять конфиденциальную связь с поставщиками, дистрибуторами и другими внешними пользователями без доступа к внутрикорпоративной информации.

Модуль входит в состав всех редакций продукта «Битрикс24 в коробке». Независимо от числа приобретенных лицензий для «Битрикс24 в коробке», количество внешних пользователей в модуле Экстранет не ограничивается.

Примечание: после установки модуля компоненты будут добавлены в соответствующие разделы списка компонентов визуального редактора:
  • Последние сообщения всех блогов экстранета (Общение -> Блоги);
  • Экстранет - создание группы (комплексный компонент) (Общение -> Социальная сеть);
  • Форма инициализации регистрации (Служебные -> Пользователь).

Настройки модуля описаны здесь.

Модуль включает в себя следующие компоненты 2.0:
Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Последние сообщения всех блогов экстранета | extranet.blog.new_posts.list | Выводит последние сообщения блогов сайта экстранета с постраничной навигацией.
Экстранет - создание группы (комплексный компонент) | extranet.group_create | Служит для создания группы экстранета
Форма инициализации регистрации | system.auth.initialize | Выводит форма инициализации регистрации, созданной в рамках социальной сети.


Последние сообщения всех блогов экстранета

Описание extranet.blog.new_posts.list

Компонент выводит последние сообщения блогов сайта экстранета с постраничной навигацией. Компонент является стандартным и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Последние сообщения всех блогов экстранета.

Параметры

Поле | Параметр | Описание
Источник данных
Группа блогов для отображения | GROUP_ID | Указывается группа блогов, последние сообщения которых будут отображены. Если не указано, то выборка производится по всем группам блогов сайта экстранета.
Внешний вид
Количество результатов, выводимых на страницу | MESSAGE_PER_PAGE | Указывается число последних сообщений блогов, отображаемых на одной странице. Все последние сообщения блогов будут выведены с помощью постраничной навигации.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается шаблон пути к главной странице блога.
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Указывается шаблон пути к странице детального просмотра сообщения блога.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается шаблон пути к странице профиля пользователя блога.
Шаблон пути к странице с сообщением блога группы | PATH_TO_GROUP_BLOG_POST | Указывается шаблон пути к странице с сообщением блога группы.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено .
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Шаблон пути к странице пользователя соцсети | PATH_TO_SONET_USER_PROFILE | Указывается шаблон пути к странице пользователя соцсети.
Шаблон пути к чату с пользователем | PATH_TO_MESSAGES_CHAT | Указывается шаблон пути к странице чата с пользователем.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается шаблон пути к странице подразделения компании.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:extranet.blog.new_posts.list","",Array(
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "PATH_TO_SONET_USER_PROFILE" => "/extranet/contacts/personal/user/#user_id#/",
        "PATH_TO_MESSAGES_CHAT" => "/extranet/contacts/personal/messages/chat/#user_id#/",
        "PATH_TO_VIDEO_CALL" => "/extranet/contacts/personal/video/#user_id#/",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "MESSAGE_PER_PAGE" => "6",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
        "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog&post_id=#post_id#",
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP_BLOG_POST" => "",
        "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
        "BLOG_VAR" => "blog",
        "POST_VAR" => "post_id",
        "USER_VAR" => "user_id",
        "PAGE_VAR" => "page",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "GROUP_ID" => "1",
        "NAV_TEMPLATE" => "",
        "SET_TITLE" => "Y"
    ),
);?>


Форма инициализации регистрации

Описание system.auth.initialize

Компонент выводит форму инициализации регистрации, созданную в рамках социальной сети. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Служебные > Пользователь > Форма инициализации регистрации.

Параметры

Поле | Параметр | Описание
Дополнительно
Название переменной, в которой передается ID пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя.
Название переменной, в которой передается контрольная строка | CHECKWORD | Параметр содержит код, в котором передается контрольная строка.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:system.auth.initialize","",Array(
        "USER_ID" => "user_id",
        "CHECKWORD" => "checkword"
    ),
);?>


Экстранет - создание группы (комплексный компонент)

Описание extranet.group_create

Комплексный компонент служит для создания группы экстранета. Компонент является стандартным и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Социальная сеть > Экстранет - создание группы.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить следущие параметры: SEF_FOLDER, SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить следущие параметры: VARIABLE_ALIASES.
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - путь к странице создания группы;
  • invite - путь к странице приглашения пользователей.
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.

При выключенном режиме ЧПУ необходимо указать имена следующих переменных:
  • user_id - имя переменной для идентификатора пользователя;
  • page - имя переменной для страницы;
  • group_id - имя переменной для идентификатора группы.
Дополнительные настройки
Страница группы | PATH_TO_GROUP | Указывается путь к странице группы экстранета.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:extranet.group_create","",Array(
        "SEF_MODE" => "Y",
        "PATH_TO_GROUP" => "",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "invite" => "#group_id#/invite/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "invite" => Array(),
        )
    )
);?>


Контроллер

Подраздел предназначен для централизованного управления любым количеством независимых веб-сайтов, созданных на платформе «1С-Битрикс: Управление сайтом». Включает в себя следующие компоненты:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Список сайтов | controller_site_list | Выводит список сайтов, зарегистрированных в контроллере.


Список сайтов

Отправить отзыв по этому разделу
Компоненты>Сервисы>Контроллер>Список сайтов

Контроллер::Список сайтов

Описание controller.site.list

Компонент выводит список сайтов, зарегистрированных в контроллере. Компонент стандартный и входит в дистрибутив модуля.

Примечание: список сайтов будет отображен только для пользователей, имеющих уровень доступа Авторизация на сайтах.

В визуальном редакторе компонент расположен по пути Сервисы > Контроллер > Список сайтов.

Компонент относится к модулю Контроллер.

Параметры

Поле | Параметр | Описание
Основные параметры
Заголовок | TITLE | Указывается текст заголовка списка сайтов.
Группы сайтов для отображения | GROUP | Указываются группы, для которых будет отображен список сайтов, зарегистрированных в контроллере.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:controller.site.list","",Array(
        "TITLE" => "Список сайтов",
        "GROUP" => "1",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    ),
);?>


Частые вопросы

Подраздел предназначен для организации ЧаВо на сайте и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Частые вопросы
FAQ | support.faq | Выводит FAQ категории и вопросы из инфоблока.
Вопрос FAQ | support.faq.element.detail | Выводит один вопрос FAQ из инфоблока конкретной категории.
Список вопросов FAQ из секции | support.faq.element.list | Выводит вопросы FAQ из инфоблока.
Список категорий FAQ | support.faq.section.list | Выводит список категорий FAQ из инфоблока.


FAQ (комплексный компонент)

Описание support.faq

Комплексный компонент выводит FAQ категории и вопросы из инфоблока. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Настройки компонента
Тип инфоблоков | IBLOCK_TYPE | Тип информационного блока FAQ.
Список инфоблоков | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будет храниться FAQ.
Список секций | SECTION | Указывается секция (категория FAQ), которая будет отображена на странице. Если ничего не указывать, то будет выведен весь список секций.
Показывать вложенные секции | EXPAND_LIST | [Y|N] При отмеченной секции будут показаны вложенные секции.
Настройки рейтингов
Включить рейтинг SHOW_RATING Указывается, будут ли использоваться рейтинги для оценки загруженных файлов.
  • по умолчанию;
  • да;
  • нет.

Значение по умолчанию берется из настроек рейтингов.

Вид кнопок рейтинга RATING_TYPE Указывается тип кнопок рейтинга:
  • по умолчанию;
  • Мне нравится (текстовый);
  • Мне нравится (графический);
  • Нравится / Не нравится (текстовый);
  • Нравится / Не нравится (графический).

Значение по умолчанию берется из настроек рейтингов.

Шаблон пути к странице пользователя | PATH_TO_USER | Указывается шаблон пути к странице пользователя.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При установленном флаге включается поддержка ЧПУ и становятся доступными [dw]поля настройки адресов ЧПУ.[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • faq - страница общего списка;
  • section - страница раздела;
  • detail - страница детального просмотра.
[/di]
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:support.faq","",Array(
        "IBLOCK_TYPE" => "services",
        "IBLOCK_ID" => "17",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y",
        "AJAX_MODE" => "N",
        "SEF_MODE" => "Y",
        "SECTION" => "-",
        "EXPAND_LIST" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "section" => "#SECTION_ID#/",
            "detail" => "#SECTION_ID#/#ELEMENT_ID#"
        ),
        "SHOW_RATING" => "Y",
        "RATING_TYPE" => "like_graphic",
        "PATH_TO_USER" => "",
        "VARIABLE_ALIASES" => Array(
            "section" => Array(),
            "detail" => Array(),
            "faq" => Array(),
        )
    )
);?>


Вопрос FAQ

Описание support.faq.element.detail

Компонент выводит один вопрос FAQ из инфоблока конкретной категории. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Настройки компонента
Тип инфоблоков | IBLOCK_TYPE | Тип информационного блока FAQ.
Список инфоблоков | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будет храниться FAQ.
ID Секции | SECTION_ID | Указывается идентификатор секции (категории FAQ), в которой хранятся вопросы FAQ.
ID Элемента | ELEMENT_ID | Указывается идентификатор элемента (вопроса FAQ).
Настройки рейтингов
Включить рейтинг SHOW_RATING Указывается, будут ли использоваться рейтинги для оценки загруженных файлов.
  • по умолчанию;
  • да;
  • нет.

Значение по умолчанию берется из настроек рейтингов.

Вид кнопок рейтинга RATING_TYPE Указывается тип кнопок рейтинга:
  • по умолчанию;
  • Мне нравится (текстовый);
  • Мне нравится (графический);
  • Нравится / Не нравится (текстовый);
  • Нравится / Не нравится (графический).

Значение по умолчанию берется из настроек рейтингов.

Шаблон пути к странице пользователя | PATH_TO_USER | Указывается шаблон пути к странице пользователя.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:support.faq.element.detail","",Array(
        "IBLOCK_TYPE" => "services",
        "IBLOCK_ID" => "17",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y",
        "AJAX_MODE" => "N",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "SHOW_RATING" => "Y",
        "RATING_TYPE" => "like",
        "PATH_TO_USER" => "",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Список вопросов FAQ

Описание support.faq.element.list

Компонент выводит вопросы FAQ из инфоблока. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Настройки компонента
Тип инфоблоков | IBLOCK_TYPE | Тип информационного блока FAQ.
Список инфоблоков | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будет храниться FAQ.
Настройки рейтингов
Включить рейтинг SHOW_RATING Указывается, будут ли использоваться рейтинги для оценки загруженных файлов.
  • по умолчанию;
  • да;
  • нет.

Значение по умолчанию берется из настроек рейтингов.

Вид кнопок рейтинга RATING_TYPE Указывается тип кнопок рейтинга:
  • по умолчанию;
  • Мне нравится (текстовый);
  • Мне нравится (графический);
  • Нравится / Не нравится (текстовый);
  • Нравится / Не нравится (графический).

Значение по умолчанию берется из настроек рейтингов.

Шаблон пути к странице пользователя | PATH_TO_USER | Указывается шаблон пути к странице пользователя.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:support.faq.element.list","",Array(
        "IBLOCK_TYPE" => "services",
        "IBLOCK_ID" => "17",
        "SHOW_RATING" => "Y",
        "RATING_TYPE" => "like",
        "PATH_TO_USER" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y",
        "AJAX_MODE" => "N",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Список категорий FAQ

Описание support.faq.section.list

Компонент выводит список категории FAQ из инфоблока. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Настройки компонента
Тип инфоблоков | IBLOCK_TYPE | Тип информационного блока FAQ.
Список инфоблоков | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будет храниться FAQ.
Список секций (по умолчанию - из корневой секции) | SECTION | Указывается секция (категория FAQ), которая будет отображена на странице. Если ничего не указывать, то будет выведен весь список секций.
Показывать вложенные секции | EXPAND_LIST | [Y|N] При отмеченной секции будут показаны вложенные секции.
URL страницы секции (по умолчанию - из настроек инфоблока) | SECTION_URL | Указывается адрес страницы секции FAQ.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:support.faq.section.list","",Array(
        "IBLOCK_TYPE" => "services",
        "IBLOCK_ID" => "17",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y",
        "AJAX_MODE" => "N",
        "SECTION" => "-",
        "EXPAND_LIST" => "Y",
        "SECTION_URL" => "faq_detail.php?SECTION_ID=#SECTION_ID#",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    ),
);?>


E-mail маркетинг

Подраздел предназначен для организации работы рассылок и содержит следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Форма подписки | sender.subscribe | Создает включаемую в дизайн сайта форму для подписки на рассылки.


Форма подписки

Компонент включается в дизайн сайта и служит формой для подписки на рассылки. Компонент стандартный и входит в дистрибутив модуля.

Описание sender.subscribe

В визуальном редакторе компонент расположен по пути Сервисы > Email-маркетинг > Форма подписки.

Компонент относится к модулю Email-маркетинг.

Параметры

Поле | Параметр | Описание
Основные параметры
Определять подписку текущего пользователя | USE_PERSONALIZATION | [Y|N] При включенной опции будут выделены только те рассылки, на которые подписан текущий пользователь. Иначе выбраны все рассылки.
Запрашивать подтверждение подписки по email | CONFIRMATION | [Y|N] При включенной опции подписчику отправляется письмо с ссылкой для подтверждения без авторизации. После перехода по ссылке подписчик будет подписан на выбранные подписки.
Скрыть список рассылок, и подписывать на все | HIDE_MAILINGS | [Y|N] При включенной опции будут выбраны все рассылки.
Источник данных
Показать скрытые рассылки для подписки | SHOW_HIDDEN | [Y|N] При включенной опции будут показываться подписки из скрытых рубрик, в настройках которых снята опция Вывод в публичной части для подписки.
Согласие пользователя
Запрашивать согласие | USER_CONSENT | [Y|N] Установленный флажок включает механизм согласия пользователя.
Соглашение | USER_CONSENT_ID | Задается текст соглашения, которое отображается пользователю при заказе.
Галка по умолчанию проставлена | USER_CONSENT_IS_CHECKED | Установка галочки автомаитчески устанавливает галочку в чекбоксе согласия пользователя. То есть согласие применяется одновременно с нажатием кнопки Оформить заказ.
Загружать текст сразу | USER_CONSENT_IS_LOADED | Текст соглашения будет выводиться сразу. Если флажок не установлен, для просмотра текст нужно будет кликнуть по кнопке согласия.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленной опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sender.subscribe","",Array(
        "COMPONENT_TEMPLATE" => ".default",
        "USE_PERSONALIZATION" => "Y",
        "CONFIRMATION" => "Y",
        "SHOW_HIDDEN" => "Y",
        "AJAX_MODE" => "Y",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SET_TITLE" => "Y"
    )
);?>


Веб-Сервис

Подраздел предназначен для организации системы веб-сервисов и SOAP и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
SOAP&WSDL сервер | webservice.server | Реализует конечную точку (EndPoint) для сконфигурированного веб-сервиса на основе SOAP/WSDL.
Веб-сервисы модуля статистики | webservice.statistic | Веб-сервис, отдающий статистические данные по сайту, например, для гаджета статистики для боковой панели OC Windows Vista.
Проверка аутентификации | webservice.checkauth | Возвращает данные по пользователю, если он правильно авторизован. Компонент может рассматриваться как пример реализации веб-сервиса, содержащего методы проверки авторизации пользователя и получения информации по авторизованному пользователю. (Компонент не описывается.)


SOAP&WSDL сервер

Описание webservice.server

Компонент реализует конечную точку (EndPoint) для сконфигурированного веб-сервиса на основе SOAP/WSDL. Компонент стандартный и входит в состав дистрибутива.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Веб-Сервис.

Компонент относится к модулю Веб-сервис.

Параметры

Поле | Параметр | Описание
Основные параметры
Название веб-сервиса | WEBSERVICE_NAME | Задаются имя используемого веб-сервиса.
Модуль веб-сервис | WEBSERVICE_MODULE | Указывается модуль, который будет подключен при вызове сервиса.
Конфигурирующий класс | WEBSERVICE_CLASS | Указывается собственно класс веб-сервиса.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:webservice.server","",Array(
        "WEBSERVICE_NAME" => "WebService EndPoint: Bitrix",
        "WEBSERVICE_MODULE" => "",
        "WEBSERVICE_CLASS" => "CGenericWSStub"
    ),
);?>


Веб-сервисы модуля статистики

Описание webservice.statistic

Веб-сервис, отдающий статистические данные по сайту, например, для гаджета статистики для боковой панели OC Windows Vista (/bitrix/components/bitrix/webservice.statistic/distr). Компонент стандартный и входит в состав дистрибутива.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Веб-Сервис.

Компонент относится к модулю Веб-сервис.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:webservice.statistic","",Array(
   ),
);?>


Проверка аутентификации

Описание webservice.checkauth

Компонент возвращает данные по пользователю, если он правильно авторизован.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Веб-Сервис.

Компонент относится к модулю Веб-сервис.

Компонент не имеет параметров для настройки.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:webservice.checkauth","",Array(
    )
);?>


Веб-формы

Подраздел позволяет создавать произвольное количество веб-форм и управлять ими. Включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Веб-форма (комплексный компонент) | form | Компонент, создавая физически только одну страницу, позволяет получить несколько страниц: заполнение веб-формы, со списком результатов, редактирование результата, просмотр результата и т.д.
Редактирование результата | form.result.edit | Служит для редактирования результатов заполнения веб-форм.
Список результатов | form.result.list | Предназначен для вывода списка результатов выбранной веб-формы.
Список своих результатов | form.result.list.my | Выводит список своих результатов по нескольким формам.
Заполнение веб-формы | form.result.new | Служит для вывода формы и добавления результата, т.е. для ее заполнения.
Просмотр результата | form.result.view | Служит для просмотра результата заполнения веб-формы.


Веб-форма (комплексный компонент)

Описание form

Комплексный компонент, создавая физически только одну страницу, позволяет получить несколько страниц: заполнение веб-формы, со списком результатов, редактирование результата, просмотр результата и т.д. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Веб-формы > Веб-форма.

Компонент относится к модулю Веб-формы.

Параметры

Поле | Параметр | Описание
Основные параметры
Начальная страница START_PAGE Указывается начальная страница:
  • new - страница добавления результата, т.е. будет представлена выбранная веб-форма для заполнения;
  • list - страница со списком результатов данной формы.
Показывать страницу со списком результатов | SHOW_LIST_PAGE | [Y|N] Если значение параметра START_PAGE равно new, то при отмеченной опции пользователь после заполнения результата будет переведен на страницу со списком результатов. Если же в качестве начальной страницы указано list, то вне зависимости от этой опции выведется страница результатов.
Показывать страницу редактирования результата SHOW_EDIT_PAGE [Y|N] При отмеченной опции на странице со списком результатов будет присутствовать ссылка Изменить на редактирование результата.

Примечание:количество записей на странице со списком результатов зависит от прав доступа пользователя, установленных в настройках формы и в настройках ее статуса.

Показывать страницу просмотра результата SHOW_VIEW_PAGE [Y|N] При отмеченной опции на странице со списком результатов будет присутствовать ссылка на просмотр результата.

Примечание: количество записей на странице со списком результатов зависит от прав доступа пользователя, установленных в настройках формы и в настройках ее статуса.
Страница с сообщением об успешной отправке | SUCCESS_URL | Указывается путь к странице с сообщением об успешной отправке результата формы. Используется при отправке результата пользователем без прав редактирования результата.
Источник данных
ID веб-формы | WEB_FORM_ID | Указывается идентификатор веб-формы.
ID результата | RESULT_ID | Указывается идентификатор результата заполнения формы. По умолчанию указано $_REQUEST["RESULT_ID"], но также может быть записан php-код, возвращающий RESULT_ID.
Внешний вид
Показать значение параметра ANSWER_VALUE | SHOW_ANSWER_VALUE | [Y|N] При отмеченной опции для показа будет выведено значение параметра ANSWER_VALUE вопроса веб-формы (выводится рядом со значением ответа).
Показать дополнительные поля веб-формы | SHOW_ADDITIONAL | [Y|N] При отмеченной опции будут выведены дополнительные поля формы при их наличии.
Показать текущий статус результата | SHOW_STATUS | [Y|N] При отмеченной опции статус текущего результата будет отображатся на странице со списком результатов.
Выводить на редактирование дополнительные поля | EDIT_ADDITIONAL | [Y|N] При отмеченной опции дополнительные поля будут выводиться на редактирование.
Выводить форму смены статуса | EDIT_STATUS | [Y|N] При отмеченной опции с учётом того, что значение параметра SHOW_STATUS равно Y, будет отображена форма смены статуса. Список доступных статусов в форме зависит от прав доступа, установленных для данной группы в настройках статусов формы.
Коды полей, которые нельзя показывать в фильтре NOT_SHOW_FILTER Указываются коды полей, которые нельзя показывать в фильтре. Можно исключить те поля веб-формы, которые не должны отображаться в фильтре на странице со списком результатов.

Примечание: чтобы поле отображалось в фильтре на странице со списком результатов, для данного вопроса должна быть заполнена закладка Фильтр в форме редактирования вопроса веб-формы в расширенном режиме.
Коды полей, которые нельзя показывать в таблице | NOT_SHOW_TABLE | Указываются коды полей, которые нельзя показывать в таблице. Можно исключить те поля веб-формы, которые не должны отображаться в таблице на странице со списком результатов веб-формы.
Игнорировать свой шаблон | IGNORE_CUSTOM_TEMPLATE | [Y|N] При отмеченной опции для отображения веб-формы будет использоваться шаблон формы по умолчанию, даже если создан свой шаблон.
Использовать расширенный вывод сообщений об ошибках | USE_EXTENDED_ERRORS | [Y|N] При отмеченной опции будет использован расширенный вывод сообщений об ошибках.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры: [/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • new - cтраница добавления результата;
  • list - cтраница списка результатов;
  • edit - cтраница редактирования результата;
  • view - cтраница просмотра результата.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]ACTION[/dw][di]
Имя переменной действия ACTION Указывается имя переменной действия.
[/di] .
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.
Дополнительные настройки
Название дополнительного пункта в навигационной цепочке | CHAIN_ITEM_TEXT | Указывается название дополнительного пункта в навигационной цепочке. Если оставить незаполненным, то в навигационную цепочку пункт не добавляется.
Ссылка на дополнительном пункте в навигационной цепочке | CHAIN_ITEM_LINK | Указывается ссылка, которая будет показана на дополнительном пункте меню в навигационной цепочке.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:form","",Array(
        "AJAX_MODE" => "N",
        "SEF_MODE" => "Y",
        "WEB_FORM_ID" => $_REQUEST["WEB_FORM_ID"],
        "RESULT_ID" => $_REQUEST["RESULT_ID"],
        "START_PAGE" => "new",
        "SHOW_LIST_PAGE" => "Y",
        "SHOW_EDIT_PAGE" => "Y",
        "SHOW_VIEW_PAGE" => "Y",
        "SUCCESS_URL" => "",
        "SHOW_ANSWER_VALUE" => "Y",
        "SHOW_ADDITIONAL" => "Y",
        "SHOW_STATUS" => "Y",
        "EDIT_ADDITIONAL" => "Y",
        "EDIT_STATUS" => "Y",
        "NOT_SHOW_FILTER" => Array(),
        "NOT_SHOW_TABLE" => Array(),
        "CHAIN_ITEM_TEXT" => "",
        "CHAIN_ITEM_LINK" => "",
        "IGNORE_CUSTOM_TEMPLATE" => "Y",
        "USE_EXTENDED_ERRORS" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "SEF_FOLDER" => "/communication/web-forms/",
        "SEF_URL_TEMPLATES" => Array(
            "new" => "#WEB_FORM_ID#/",
            "list" => "#WEB_FORM_ID#/list/",
            "edit" => "#WEB_FORM_ID#/edit/#RESULT_ID#/",
            "view" => "#WEB_FORM_ID#/view/#RESULT_ID#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "new" => Array(),
            "list" => Array(),
            "edit" => Array(),
            "view" => Array(),
        )
    )
);?>


Заполнение веб-формы

Описание form.result.new

Компонент служит для вывода формы и добавления результата, т.е. для ее заполнения. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Веб-формы > Заполнение веб-формы.

Компонент относится к модулю Веб-формы.

Параметры

Поле | Параметр | Описание
Источник данных
ID веб-формы WEB_FORM_ID Указывается идентификатор веб-формы.
Выбрав пункт (другое)->, можно задать внешний идентификатор веб-формы через $_REQUEST.
Внешний вид
Игнорировать свой шаблон | IGNORE_CUSTOM_TEMPLATE | [Y|N] При отмеченной опции для отображения веб-формы будет использоваться шаблон формы по умолчанию, даже если создан свой шаблон.
Использовать расширенный вывод сообщений об ошибках | USE_EXTENDED_ERRORS | [Y|N] При отмеченной опции будет использован расширенный вывод сообщений об ошибках.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить параметр [dw]SEF_FOLDER[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
[/di] .

Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.

При выключенном режиме ЧПУ необходимо указать имена следующих переменных:
  • WEB_FORM_ID - имя переменной, которой передается идентификатор веб-формы;
  • RESULT_ID - имя переменной, которой передается идентификатор результата заполнения формы.
[/di] .
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.
Параметры компонента
Страница со списком результатов | LIST_URL | Указывается адрес страницы со списком результатов.
Страница редактирования результата | EDIT_URL | Указывается адрес страницы редактирования результата.
Страница с сообщением об успешной отправке | SUCCESS_URL | Указывается путь к странице с сообщением об успешной отправке результата формы. Используется при отправке результата пользователем без прав редактирования результата.
Название дополнительного пункта в навигационной цепочке | CHAIN_ITEM_TEXT | Указывается название дополнительного пункта в навигационной цепочке. Если оставить незаполненным, то в навигационную цепочку пункт не добавляется.
Ссылка на дополнительном пункте в навигационной цепочке | CHAIN_ITEM_LINK | Указывается ссылка, которая будет показана на дополнительном пункте меню в навигационной цепочке.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:form.result.new","",Array(
        "SEF_MODE" => "Y",
        "WEB_FORM_ID" => "$_REQUEST["WEB_FORM_ID"]",
        "LIST_URL" => "result_list.php",
        "EDIT_URL" => "result_edit.php",
        "SUCCESS_URL" => "",
        "CHAIN_ITEM_TEXT" => "",
        "CHAIN_ITEM_LINK" => "",
        "IGNORE_CUSTOM_TEMPLATE" => "Y",
        "USE_EXTENDED_ERRORS" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SEF_FOLDER" => "/",
        "VARIABLE_ALIASES" => Array(
        )
    )
);?>


Просмотр результата

Описание form.result.view

Компонент служит для просмотра результата заполнения веб-формы. Обычно используется в сочетании с компонентом Список результатов. При самостоятельном использовании данного компонента необходимо явно указывать идентификатор результата, чтобы соответствующий результат веб-формы был выведен в публичном разделе. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Веб-формы > Просмотр результата.

Компонент относится к модулю Веб-формы.

Параметры

Поле | Параметр | Описание
Источник данных
ID результата | RESULT_ID | Указывается идентификатор результата.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • view - cтраница просмотра результата.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Параметры компонента
Показать дополнительные поля веб-формы | SHOW_ADDITIONAL | [Y|N] При отмеченной опции будут выведены дополнительные поля формы при их наличии.
Показать значение параметра ANSWER_VALUE | SHOW_ANSWER_VALUE | [Y|N] При отмеченной опции для показа будет выведено значение параметра ANSWER_VALUE вопроса веб-формы (выводится рядом со значением ответа).
Показать текущий статус результата | SHOW_STATUS | [Y|N] При отмеченной опции статуса текущего результата будет отображатся на странице со списком результатов.
Страница редактирования результата | EDIT_URL | Указывается адрес страницы редактирования результата.
Название дополнительного пункта в навигационной цепочке | CHAIN_ITEM_TEXT | Указывается название дополнительного пункта в навигационной цепочке. Если оставить незаполненным, то в навигационную цепочку пункт не добавляется.
Ссылка на дополнительном пункте в навигационной цепочке | CHAIN_ITEM_LINK | Указывается ссылка, которая будет показана на дополнительном пункте меню в навигационной цепочке.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:form.result.view","",Array(
        "SEF_MODE" => "Y",
        "RESULT_ID" => "$_REQUEST[\"RESULT_ID\"]",
        "SHOW_ADDITIONAL" => "Y",
        "SHOW_ANSWER_VALUE" => "Y",
        "SHOW_STATUS" => "Y",
        "EDIT_URL" => "result_edit.php",
        "CHAIN_ITEM_TEXT" => "",
        "CHAIN_ITEM_LINK" => "",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "view" => "#RESULT_ID#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "view" => Array(),
        )
    )
);?>


Редактирование результата

Компонент служит для редактирования результатов заполнения веб-форм.

Описание form.result.edit

При его использовании в сочетании с компонентом Список результатов значение поля RESULT_ID можно оставить по умолчанию. Если же компонент используется самостоятельно, то необходимо определить откуда компонент должен брать значение параметра RESULT_ID или задать его явно. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Веб-формы > Редактирование результата.

Компонент относится к модулю Веб-формы.

Настройки, определяющие права групп пользователей на редактирование результатов устанавливаются в настройках каждой из веб-форм, а в случае работы в расширенном режиме также в настройках статусов.

Параметры

Поле | Параметр | Описание
Источник данных
ID результата | RESULT_ID | Указывается идентификатор результата заполнения формы. По умолчанию указано $_REQUEST["RESULT_ID"], но также может быть записан php-код, возвращающий RESULT_ID.
Внешний вид
Игнорировать свой шаблон | IGNORE_CUSTOM_TEMPLATE | [Y|N] При отмеченной опции для отображения веб-формы будет использоваться шаблон формы по умолчанию, даже если создан свой шаблон.
Использовать расширенный вывод сообщений об ошибках | USE_EXTENDED_ERRORS | [Y|N] При отмеченной опции будет использован расширенный вывод сообщений об ошибках.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • edit - cтраница редактирование результата.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Параметры компонента
Выводить на редактирование дополнительные поля | EDIT_ADDITIONAL | [Y|N] При отмеченной опции будут выведены для редактирования дополнительные поля формы при их наличии.
Выводить форму смены статуса | EDIT_STATUS | [Y|N] При отмеченной опции будет выведена форма смены статуса текущего результата. Статусы будут доступны в соответствии с правами пользователя.
Страница со списком результатов | LIST_URL | Указывается адрес страницы со списком результатов.
Страница просмотра результата | VIEW_URL | Указывается адрес страницы просмотра результата.
Название дополнительного пункта в навигационной цепочке | CHAIN_ITEM_TEXT | Указывается название дополнительного пункта в навигационной цепочке. Если оставить незаполненным, то в навигационную цепочку пункт не добавляется.
Ссылка на дополнительном пункте в навигационной цепочке | CHAIN_ITEM_LINK | Указывается ссылка, которая будет показана на дополнительном пункте меню в навигационной цепочке.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:form.result.edit","",Array(
        "SEF_MODE" => "Y",
        "RESULT_ID" => "$_REQUEST[\"RESULT_ID\"]",
        "EDIT_ADDITIONAL" => "N",
        "EDIT_STATUS" => "Y",
        "LIST_URL" => "result_list.php",
        "VIEW_URL" => "result_view.php",
        "CHAIN_ITEM_TEXT" => "",
        "CHAIN_ITEM_LINK" => "",
        "IGNORE_CUSTOM_TEMPLATE" => "Y",
        "USE_EXTENDED_ERRORS" => "Y",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "edit" => "#RESULT_ID#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "view" => Array(),
            "edit" => Array(),
        )
    ),
);?>


Список результатов

Компонент предназначен для вывода списка результатов выбранной веб-формы.

Описание form.result.list

Количество записей на странице со списком результатов зависит от прав доступа пользователя, установленных в настройках формы и в настройках ее статуса. Настройки компонента позволяют переходить со страницы со списком результатов к заполнению веб-формы, подробному просмотру определённого результата, к изменению результата, также пользователь может удалить результат(ы), если имеет на это соответствующие права доступа. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Веб-формы > Список результатов.

Компонент относится к модулю Веб-формы.

Параметры

Поле | Параметр | Описание
Источник данных
ID веб-формы | WEB_FORM_ID | Указывается идентификатор веб-формы.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить параметр [dw]SEF_FOLDER[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
[/di] .
Параметры компонента
Страница просмотра результата | VIEW_URL | Указывается адрес страницы просмотра результата.
Страница редактирования результата | EDIT_URL | Указывается адрес страницы редактирования результата.
Страница добавления результата | NEW_URL | Указывается адрес страницы добавления результата (заполнения формы).
Показать дополнительные поля веб-формы | SHOW_ADDITIONAL | [Y|N] При отмеченной опции будут выведены дополнительные поля формы при их наличии.
Показать значение параметра ANSWER_VALUE | SHOW_ANSWER_VALUE | [Y|N] При отмеченной опции для показа будет выведено значение параметра ANSWER_VALUE вопроса веб-формы (выводится рядом со значением ответа).
Показать текущий статус результата | SHOW_STATUS | [Y|N] При отмеченной опции статус текущего результата будет отображатся на странице со списком результатов.
Коды полей, которые нельзя показывать в фильтре NOT_SHOW_FILTER Указываются коды полей, которые нельзя показывать в фильтре. Можно исключить те поля веб-формы, которые не должны отображаться в фильтре на странице со списком результатов.

Примечание: чтобы поле отображалось в фильтре на странице со списком результатов, для данного вопроса должна быть заполнена закладка Фильтр в форме редактирования вопроса веб-формы в расширенном режиме.
Коды полей, которые нельзя показывать в таблице | NOT_SHOW_TABLE | Указываются коды полей, которые нельзя показывать в таблице. Можно исключить те поля веб-формы, которые не должны отображаться в таблице на странице со списком результатов веб-формы.
Название дополнительного пункта в навигационной цепочке | CHAIN_ITEM_TEXT | Указывается название дополнительного пункта в навигационной цепочке. Если оставить незаполненным, то в навигационную цепочку пункт не добавляется.
Ссылка на дополнительном пункте в навигационной цепочке | CHAIN_ITEM_LINK | Указывается ссылка, которая будет показана на дополнительном пункте меню в навигационной цепочке.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:form.result.list","",Array(
        "SEF_MODE" => "Y",
        "WEB_FORM_ID" => "$_REQUEST[\"WEB_FORM_ID\"]",
        "VIEW_URL" => "result_view.php",
        "EDIT_URL" => "result_edit.php",
        "NEW_URL" => "result_new.php",
        "SHOW_ADDITIONAL" => "Y",
        "SHOW_ANSWER_VALUE" => "Y",
        "SHOW_STATUS" => "Y",
        "NOT_SHOW_FILTER" => "",
        "NOT_SHOW_TABLE" => "",
        "CHAIN_ITEM_TEXT" => "",
        "CHAIN_ITEM_LINK" => "",
        "SEF_FOLDER" => "/",
        "VARIABLE_ALIASES" => Array(
            "view" => Array(),
            "edit" => Array(),
        )
    ),
);?>


Список своих результатов

Описание form.result.list.my

Компонент выводит список своих результатов по нескольким формам. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Веб-формы > Список своих результатов.

Компонент относится к модулю Веб-формы.

Параметры

Поле | Параметр | Описание
Основные параметры
Формы (если не указано ни одной, то выборка будет по всем формам сайта) | FORMS | Указываются формы, по которым будет осуществлятся выборка для отображения результата. Если не указано ни одной, то выборка будет по всем формам сайта.
Дополнительные настройки
Количество результатов на одну форму | NUM_RESULTS | Указывается количество результатов на одну форму.
Страница со списком результатов | LIST_URL | Указывается адрес страницы со списком результатов.
Страница просмотра результата | VIEW_URL | Указывается адрес страницы просмотра результата.
Страница редактирования результата | EDIT_URL | Указывается адрес страницы редактирования результата.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:form.result.list.my","",Array(
        "FORMS" => Array(),
        "NUM_RESULTS" => "10",
        "LIST_URL" => "my_result_list.php?WEB_FORM_ID=#FORM_ID#",
        "VIEW_URL" => "my_result_view.php?WEB_FORM_ID=#FORM_ID#&RESULT_ID=#RESULT_ID#",
        "EDIT_URL" => "my_result_edit.php?WEB_FORM_ID=#FORM_ID#&RESULT_ID=#RESULT_ID#"
    )
);?>


Менеджер идей

Подраздел позволяет предложить свою идею для развития бизнеса компании, получить оценку и рейтинг. Включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Идеи | bitrix:idea | Комплексный компонент идей
Форма добавления идеи (popup) | bitrix:idea.popup | Форма добавлении идеи во всплывающем окне


Идеи

Комплексный компонент позволяет организовать сервис менеджера идей на портале.

Описание idea

Доступен просмотр списка идей, детальной информации, а также редактирование идеи.

В визуальном редакторе компонент расположен по пути: Общение > Менеджер идей > Идеи.

Компонент относится к модулю Менеджер идей.

Параметры

Поле | Параметр | Описание
Основные параметры
Блог | BLOG_URL | Выбирается блог для сервиса идея.
Инфоблок, в котором хранится структура категорий | IBLOCK_CATOGORIES | Выбирается инфоблок, в котором хранится структура категорий идей.
Группы пользователей, которые могут добавлять специальный ответ | POST_BIND_USER | Указывается группа пользователей, которая может модерировать сервис идей.
Статус по умолчанию для новой идеи | POST_BIND_STATUS_DEFAULT | Указывается статус, который будет автоматически присвоен новым идеям.
Внешний вид
Идей на странице | MESSAGE_COUNT | Указывается количество идей на странице. Остальные сообщения будут выведены с помощью постраничной навигации.
Комментариев к идее на странице | COMMENTS_COUNT | Указывается количество комментариев к идее на странице.
Использовать прямую постраничную навигацию для комментариев | USE_ASC_PAGING | [Y|N] При отмеченной опции список комментариев будет выводиться постранично с прямой навигацией.
Tегов в облаке тегов (0 - без ограничений) | TAGS_COUNT | Задается ограничение на количество отображаемых в облаке тегов.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Максимально допустимая ширина добавляемого в сообщение изображения (в пикселях).
Разрешить изменять размер визуального редактора | EDITOR_RESIZABLE | [Y|N] При отмеченной опции будет возможность менять размеры окна визуального редактора.
По умолчанию показывать невизуальный режим редактора | EDITOR_CODE_DEFAULT | [Y|N] При отмеченной опции визуальный режим редактора не будет использоваться по умолчанию.
Высота визуального редактора по умолчанию (пикселей) | EDITOR_DEFAULT_HEIGHT | Значение высоты визуального редактора при загрузке (в пикселях) в форме редактирования идеи.
Высота визуального редактора по умолчанию (пикселей) в комментариях | COMMENT_EDITOR_DEFAULT_HEIGHT | Значение высоты визуального редактора в форме комментариев при загрузке (в пикселях).
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ. Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Указывается путь к каталогу ЧПУ.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - главная страница идей
  • status_code - список идей со статусами 0го уровня
  • category_1 - общий список идей 1го уровня
  • category_1_status - список идей со статусами 1го уровня
  • category_2 - общий список идей 2го уровня
  • category_2_status - список идей со статусами 2го уровня
  • user_ideas - общий список идей пользователя
  • user_ideas_status - список идей пользователя со статусами
  • user - профайл пользователя
  • subscribe -Email подписки пользователя
  • edit - редактирование идеи:
  • post_id - идея детально:
  • post_rss - адрес комментариев к сообщению в RSS формате
  • rss - адрес блога в RSS формате
  • rss_status - адрес блога в RSS формате со статусом
  • rss_category - адрес блога в RSS формате с категорией
  • rss_category_status - адрес блога в RSS формате с категорией и статусом
  • rss_user_ideas - адрес блога в RSS формате к идеям пользователя
  • rss_user_ideas_status - адрес блога в RSS формате к идеям пользователя со статусом
  • rss_all - сообщения всех блогов в RSS формате
[/di] SEF_FOLDER и SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
[/di] .
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.
Время кэширования остальных страниц | CACHE_TIME_LONG | Указывается время кеширования страниц, начиная со второй.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта. По умолчанию задано /bitrix/images/blog/smile/.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название идеи.
Показывать навигацию (хлебные крошки) | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт с названием блога.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Разрешить вставку видео в комментарии | COMMENT_ALLOW_VIDEO | [Y|N] При отмеченной опции появится возможность вставки видеороликов в комментарий.
Запретить вставку ссылок в комментариях

NO_URL_IN_COMMENTS

Указывается, кому нельзя вставлять ссылки в комментарии (по умолчанию - Никому):

  • Никому;
  • Анонимным пользователям;
  • Всем.
Использовать символьный код сообщений как идентификатор | ALLOW_POST_CODE | [Y|N] При отмеченной опции транслитерация заголовка идеи будет использоваться как его идентификатор.
Использовать внешний сервис перевода для кода сообщений | USE_GOOGLE_CODE | [Y|N] При отмеченной опции для перевода символьного кода идей будет использоваться сервис перевода Bing. Параметр доступен при отмеченной опции Использовать символьный код сообщений как идентификатор.
Использовать рейтинги | SHOW_RATING | [Y|N] При отмеченной опции будут использоваться рейтинги для оценки идей и комментариев к ним.
Шаблон рейтингов | RATING_TEMPLATE | Выбирается шаблон визуального отображения рейтингов.
Отключить уведомления в живую ленту DISABLE_SONET_LOG [Y|N] Опция позволяет отключить вывод идей в живую ленту.

Опция доступна только в Битрикс24 в коробке.
Отключить почтовые уведомления | DISABLE_EMAIL | [Y|N] Опция позволяет отключить почтовые уведомления о новых комментариях.
Отключить RSS | DISABLE_RSS | [Y|N] Опция позволяет отключить RSS.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:idea",
    ".default",
    Array(
        "BLOG_URL" => "idea_s1",
        "IBLOCK_CATOGORIES" => "51",
        "POST_BIND_USER" => array(0=>"1",),
        "POST_BIND_STATUS_DEFAULT" => "15",
        "MESSAGE_COUNT" => "10",
        "COMMENTS_COUNT" => "10",
        "TAGS_COUNT" => "0",
        "DATE_TIME_FORMAT" => "d.m.y G:i",
        "NAV_TEMPLATE" => "",
        "IMAGE_MAX_WIDTH" => "770",
        "EDITOR_RESIZABLE" => "Y",
        "EDITOR_DEFAULT_HEIGHT" => "300",
        "EDITOR_CODE_DEFAULT" => "N",
        "COMMENT_EDITOR_DEFAULT_HEIGHT" => "200",
        "SEF_MODE" => "Y",
        "SEF_FOLDER" => "/services/idea/",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_TIME_LONG" => "604800",
        "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
        "SET_TITLE" => "Y",
        "SET_NAV_CHAIN" => "Y",
        "USE_ASC_PAGING" => "Y",
        "COMMENT_ALLOW_VIDEO" => "Y",
        "NO_URL_IN_COMMENTS" => "",
        "ALLOW_POST_CODE" => "Y",
        "USE_GOOGLE_CODE" => "Y",
        "SHOW_RATING" => "Y",
        "RATING_TEMPLATE" => "standart",
        "DISABLE_SONET_LOG" => "N",
        "DISABLE_EMAIL" => "N",
        "DISABLE_RSS" => "N",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "status_0" => "status/#status_code#/",
            "category_1" => "category/#category_1#/",
            "category_1_status" => "category/#category_1#/status/#status_code#/",
            "category_2" => "category/#category_1#/#category_2#/",
            "category_2_status" => "category/#category_1#/#category_2#/status/#status_code#/",
            "user_ideas" => "user_idea/#user_id#/",
            "user_ideas_status" => "user_idea/#user_id#/status/#status_code#/",
            "user" => "user/#user_id#/",
            "user_subscribe" => "user/#user_id#/subscribe/",
            "post_edit" => "edit/#post_id#/",
            "post" => "#post_id#/",
            "post_rss" => "#blog#/rss/#type#/#post_id#/",
            "rss" => "#blog#/rss/#type#",
            "rss_status" => "rss/#type#/status/#status_code#/",
            "rss_category" => "rss/#type#/category/#category#/",
            "rss_category_status" => "rss/#type#/category/#category#/status/#status_code#/",
            "rss_user_ideas" => "rss/#type#/user/#user_id#/idea/",
            "rss_user_ideas_status" => "rss/#type#/user/#user_id#/idea/status/#status_code#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "status_0" => Array(),
            "category_1" => Array(),
            "category_1_status" => Array(),
            "category_2" => Array(),
            "category_2_status" => Array(),
            "user_ideas" => Array(),
            "user_ideas_status" => Array(),
            "user" => Array(),
            "user_subscribe" => Array(),
            "post_edit" => Array(),
            "post" => Array(),
            "post_rss" => Array(),
            "rss" => Array(),
            "rss_status" => Array(),
            "rss_category" => Array(),
            "rss_category_status" => Array(),
            "rss_user_ideas" => Array(),
            "rss_user_ideas_status" => Array(),
        )
    )
);?>


Форма добавления идеи

Описание idea.popup

Компонент позволяет добавить в публичную часть сайта кнопку, которая открывает форму добавления идеи во всплывающем окне.

В визуальном редакторе компонент расположен по пути: Общение > Менеджер идей > Форма добавлении идеи (popup).

Компонент относится к модулю Менеджер идей.

Параметры

Поле | Параметр | Описание
Основные параметры
Блог | BLOG_URL | Выбирается блог для сервиса идея.
Инфоблок, в котором хранится структура категорий | IBLOCK_CATOGORIES | Выбирается инфоблок, в котором хранится структура категорий идей.
Путь к списку идей | PATH_IDEA_INDEX | Указывается путь к списку идей.
Путь к детальному описанию идеи | PATH_IDEA_POST | Указывается путь к детальному описанию идеи.
Путь к детальному описанию идеи | PATH_IDEA_POST | Указывается путь к детальному описанию идеи.
Цвет фона кнопки | BUTTON_COLOR | Задается цвет фона кнопки отзывов в публичной части сайта.
Статус по умолчанию для новой идеи | POST_BIND_STATUS_DEFAULT | Указывается статус, который будет автоматически присвоен новым идеям.
Шаблон формы авторизации | AUTH_TEMPLATE | Задается название шаблона для формы авторизации.
Страница забытого пароля | FORGOT_PASSWORD_URL | Указывается адрес страницы восстановления пароля.
Страница регистрации | REGISTER_URL | Указывается адрес страницы для регистрации нового пользователя.
Внешний вид
Количество категорий | CATOGORIES_CNT | Указывается количество идей, отображаемых в форме.
Количество идей в категории | MESSAGE | Указывается количество идей, отображаемых в категории.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.
Дополнительные настройки
Использовать рейтинги SHOW_RATING [Y|N] При отмеченной опции будут использоваться рейтинги для оценки идей и комментариев к ним, станет доступно [dw]дополнительное поле.[/dw][di]
Шаблон рейтингов RATING_TEMPLATE Выбирается шаблон визуального отображения рейтингов.
[/di]
Отключить уведомления в живую ленту DISABLE_SONET_LOG [Y|N] Опция позволяет отключить вывод идей в живую ленту.

Опция доступна только в Битрикс24 в коробке.
Отключить почтовые уведомления | DISABLE_EMAIL | [Y|N] Опция позволяет отключить почтовые уведомления о новых комментариях.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:idea.popup",
    "",
    Array(
        "BLOG_URL" => "idea_s1",
        "IBLOCK_CATOGORIES" => "23",
        "PATH_IDEA_INDEX" => "/services/idea/",
        "PATH_IDEA_POST" => "/services/idea/#post_id#/",
        "BUTTON_COLOR" => "#3EA822",
        "POST_BIND_STATUS_DEFAULT" => "1",
        "CATOGORIES_CNT" => "4",
        "LIST_MESSAGE_COUNT" => "8",
        "AUTH_TEMPLATE" => "",
        "FORGOT_PASSWORD_URL" => "",
        "REGISTER_URL" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SHOW_RATING" => "Y",
        "RATING_TEMPLATE" => "standart",
        "DISABLE_SONET_LOG" => "N",
        "DISABLE_EMAIL" => "N"
    )
);?>


Обучение

Подраздел предназначен для создания обучающих курсов и проведения тестов. Включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Учебный курс (комплексный компонент) | learning.course | Осуществляет полноценный вывод учебного курса.
Все материалы курса | learning.course.contents | Выводит все материалы курса на одной странице.
Дерево курса | learning.course.tree | Выводит иерархию глав и уроков курса.
Детальный вывод курса | learning.course.detail | С помощью компонента производится детальный вывод курса.
Список курсов | learning.course.list | Выводит список курсов.
Поиск по курсам | learning.search | Выводит поиск по курсам, главам и урокам.
Журнал студента | learning.student.gradebook | Отображает результаты прохождения тестов.
Отчет по курсам | learning.student.certificates | Выводит список пройденных и непройденных курсов текущего пользователя.
Профиль студента | learning.student.profile | Отображает результаты прохождения тестов.
Резюме студента | learning.student.transcript | Отображает информацию о студенте и список полученных им сертификатов.
Контрольный тест | learning.test | Отображает контрольный тест курса.
Самопроверка | learning.test.self | Выводит тест для самопроверки.
Список тестов | learning.test.list | Выводит список активных тестов курса.
Детальный вывод главы | learning.chapter.detail | Производит детальный вывод главы курса.
Детальный вывод урока | learning.lesson.detail | Производит детальный вывод урока курса.


Учебный курс (комплексный компонент)

Комплексный компонент осуществляет полноценный вывод учебного курса. Компонент стандартный и входит в дистрибутив модуля.

Описание learning.course

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор курса | COURSE_ID | Указывается идентификатор курса.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • course.detail - главная страница;
  • lesson.detail - страница урока;
  • chapter.detail - страница главы;
  • test.self - страница теста для самопроверки;
  • test - страница теста;
  • test.list - страница списка тестов;
  • course.contents - страница со всеми материалами курса;
  • gradebook - страница журнала.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.

При выключенном режиме ЧПУ необходимо указать имена следующих переменных:
  • COURSE_ID - идентификатор курса;
  • INDEX - идентификатор индексной страницы;
  • LESSON_ID - идентификатор урока;
  • CHAPTER_ID - идентификатор главы;
  • SELF_TEST_ID - идентификатор теста для самопроверки;
  • TEST_ID - идентификатор теста;
  • TYPE - идентификатор всех материалов курса;
  • TEST_LIST - идентификатор списка тестов;
  • GRADEBOOK - идентификатор журнала;
  • FOR_TEST_ID - идентификатор теста в журнале.
[/di] .
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Проверять право доступа | CHECK_PERMISSIONS | [Y|N] При отмеченной опции будет проверяться право на доступ к курсу.
URL, ведущий на страницу с профилем пользователя | PATH_TO_USER_PROFILE | Указывается шаблон пути со страницей профиля пользователя.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название курса.
Настройки теста
Количество вопросов в навигационной цепочке | PAGE_WINDOW | Указывается количество вопросов, отображаемых в навигационной цепочке.
Показывать счетчик ограничения времени SHOW_TIME_LIMIT [Y|N] При отмеченной опции будет отображаться счетчик времени.
Примечание: если в настройках теста ограничение по времени не установлено, то счетчик не будет отображаться в любом случае.
Идентификатор вопроса | PAGE_NUMBER_VARIABLE | Задается имя переменной для идентификатора вопроса теста.
Настройки списка тестов
Количество тестов на странице | TESTS_PER_PAGE | Указывается количество тестов, выводимых на одной странице. Остальные тесты будут выведены с помощью постраничной навигации.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:learning.course","",Array(
        "SEF_MODE" => "Y",
        "COURSE_ID" => "$_REQUEST[\"COURSE_ID\"]",
        "CHECK_PERMISSIONS" => "Y",
        "PAGE_WINDOW" => "10",
        "SHOW_TIME_LIMIT" => "Y",
        "PAGE_NUMBER_VARIABLE" => "PAGE",
        "TESTS_PER_PAGE" => "20",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "course.detail" => "course#COURSE_ID#/index",
            "lesson.detail" => "course#COURSE_ID#/lesson#LESSON_ID#/",
            "chapter.detail" => "course#COURSE_ID#/chapter#CHAPTER_ID#/",
            "test.self" => "course#COURSE_ID#/selftest#SELF_TEST_ID#/",
            "test" => "course#COURSE_ID#/test#TEST_ID#/",
            "test.list" => "course#COURSE_ID#/examination/",
            "course.contents" => "course#COURSE_ID#/contents/",
            "gradebook" => "course#COURSE_ID#/gradebook/"
        ),
        "VARIABLE_ALIASES" => Array(
            "course.detail" => Array(),
            "lesson.detail" => Array(),
            "chapter.detail" => Array(),
            "test.self" => Array(),
            "test" => Array(),
            "test.list" => Array(),
            "course.contents" => Array(),
            "gradebook" => Array(),
        )
    )
);?>


Все материалы курса

Описание learning.course.contents

Компонент выводит все материалы курса на одной странице. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор курса | COURSE_ID | Указывается идентификатор курса.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Проверять право доступа | CHECK_PERMISSIONS | [Y|N] При отмеченной опции будет проверяться право на доступ к курсу.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название курса.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:learning.course.contents","",Array(
        "COURSE_ID" => $_REQUEST["COURSE_ID"],
        "CHECK_PERMISSIONS" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    ),
);?>


Дерево курса

Описание learning.course.tree

Компонент выводит иерархию глав и уроков. В поставку продукта входят два шаблона компонента: шаблон по умолчанию в виде дерева и шаблон навигационной цепочки. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор курса | COURSE_ID | Указывается идентификатор курса.
Шаблоны ссылок
URL, ведущий на страницу с детальным просмотром курса | COURSE_DETAIL_TEMPLATE | Указывается путь к странице с детальным просмотром курса.
URL, ведущий на страницу с главой | CHAPTER_DETAIL_TEMPLATE | Указывается путь к странице с главой курса.
URL, ведущий на страницу с уроком | LESSON_DETAIL_TEMPLATE | Указывается путь к странице с уроком курса.
URL, ведущий на страницу с самотестированием | SELF_TEST_TEMPLATE | Указывается путь к странице с тестом для самопроверки.
URL, ведущий на страницу со списком тестов | TESTS_LIST_TEMPLATE | Указывается путь к странице со списком тестов.
URL, ведущий на страницу прохождения теста | TEST_DETAIL_TEMPLATE | Указывается путь к странице с прохождением теста.
Дополнительные настройки
Проверять право доступа | CHECK_PERMISSIONS | [Y|N] При отмеченной опции будет проверяться право на доступ к курсу.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название курса.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:learning.course.tree",".default",Array(
        "COURSE_ID" => $_REQUEST["COURSE_ID"],
        "COURSE_DETAIL_TEMPLATE" => "course/index.php?COURSE_ID=#COURSE_ID#",
        "CHAPTER_DETAIL_TEMPLATE" => "chapter.php?CHAPTER_ID=#CHAPTER_ID#",
        "LESSON_DETAIL_TEMPLATE" => "lesson.php?LESSON_ID=#LESSON_ID#",
        "SELF_TEST_TEMPLATE" => "self.php?LESSON_ID=#LESSON_ID#",
        "TESTS_LIST_TEMPLATE" => "course/test_list.php?COURSE_ID=#COURSE_ID#",
        "TEST_DETAIL_TEMPLATE" => "course/test.php?COURSE_ID=#COURSE_ID#&TEST_ID=#TEST_ID",
        "CHECK_PERMISSIONS" => "Y",
        "SET_TITLE" => "Y"
    ),
);?>


Детальный вывод курса

С помощью компонента производится детальный вывод курса. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Пример вызова компонента learning.course.detail

<?$APPLICATION->IncludeComponent("bitrix:learning.course.detail","",Array(
        "COURSE_ID" => $_REQUEST["COURSE_ID"],
        "CHECK_PERMISSIONS" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    ),
);?>

Секции настроек компонента:

  • Основные параметры
  • Настройки кеширования
  • Дополнительные настройки

    • Описание параметров

    Поле | Параметр | Описание
    Основные параметры
    Идентификатор курса | COURSE_ID | Указывается идентификатор курса.
    Настройки кеширования
    Тип кеширования CACHE_TYPE Тип кеширования:
    • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
    • Y - Кешировать: для кеширования необходимо определить время кеширования;
    • N - Не кешировать: кеширования нет в любом случае.
    Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
    Дополнительные настройки
    Проверять право доступа | CHECK_PERMISSIONS | [Y|N] При отмеченной опции будет проверяться право на доступ к курсу.
    Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название курса.


Список курсов

Описание learning.course.list

Компонент выводит список курсов. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
URL, ведущий на страницу с детальным просмотром курса | COURSE_DETAIL_TEMPLATE | Указывается путь к странице с детальным просмотром курса.
Дополнительные настройки
Поле для cортировки SORTBY Указывается способ сортироки курсов в списке:
  • ID – по идентификатору курса;
  • NAME – по названию;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Направление для cортировки SORTORDER Задается направление для cортировки:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Проверять право доступа | CHECK_PERMISSIONS | [Y|N] При отмеченной опции будет проверяться право на доступ к курсу.
Количество курсов на странице | COURSES_PER_PAGE | Указывается количество курсов, выводимых на одной странице. Остальные курсы будут выведены с помощью постраничной навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Список курсов.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:learning.course.list","",Array(
        "SORBY" => "SORT",
        "SORORDER" => "ASC",
        "COURSE_DETAIL_TEMPLATE" => "course/index.php?COURSE_ID=#COURSE_ID#&INDEX=Y",
        "CHECK_PERMISSIONS" => "Y",
        "COURSES_PER_PAGE" => "20",
        "SET_TITLE" => "Y"
    ),
);?>


Поиск по курсам

Описание learning.search

Компонент выводит поиск в курсах, главах и уроках. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Внешний вид
Количество результатов, выводимых на страницу | PAGE_RESULT_COUNT | Указывается количество результатов, выводимых на страницу при поиске.
Настройки постраничной навигации
Выводить над результатами | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы.
Выводить под результатами | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:learning.search","",Array(
        "PAGE_RESULT_COUNT" => "10",
        "DISPLAY_TOP_PAGER" => "Y",
        "DISPLAY_BOTTOM_PAGER" => "Y"
    ),
);?>


Журнал студента

Описание learning.student.gradebook

Компонент отображает результаты прохождения тестов. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
URL, ведущий на страницу прохождения теста | TEST_DETAIL_TEMPLATE | Указывается путь к странице прохождения теста.
URL, ведущий на страницу с детальным просмотром курса | COURSE_DETAIL_TEMPLATE | Указывается путь к странице с детальным просмотром курса.
Дополнительные настройки
Идентификатор теста | TEST_ID_VARIABLE | Указывается имя переменной, которой передается идентификатор теста.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Результаты тестирования.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:learning.student.gradebook","",Array(
        "TEST_DETAIL_TEMPLATE" => "course/index.php?COURSE_ID=#COURSE_ID#&TEST_ID=#TEST_ID#",
        "COURSE_DETAIL_TEMPLATE" => "course/index.php?COURSE_ID=#COURSE_ID#&INDEX=Y",
        "TEST_ID_VARIABLE" => "TEST_ID",
        "SET_TITLE" => "Y"
    ),
);?>


Отчет по курсам

Компонент выводит список пройденных и непройденных курсов текущего пользователя. Компонент является стандартным и входит в дистрибутив модуля.

Описание learning.student.certificates

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
URL, ведущий на страницу с детальным просмотром курса | COURSE_DETAIL_TEMPLATE | Указывается путь к странице с детальным просмотром курса.
URL, ведущий на страницу со списком тестов | TESTS_LIST_TEMPLATE | Указывается путь к странице со списком тестов.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Отчет по курсам.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:learning.student.certificates","",Array(
        "COURSE_DETAIL_TEMPLATE" => "course/index.php?COURSE_ID=#COURSE_ID#&INDEX=Y",
        "TESTS_LIST_TEMPLATE" => "course/index.php?COURSE_ID=#COURSE_ID#&TEST_LIST=Y",
        "SET_TITLE" => "Y"
    ),
);?>


Профиль студента

Описание learning.student.profile

Компонент отображает результаты прохождения тестов. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Основные параметры
URL, ведущий на страницу c результатами сертификации | TRANSCRIPT_DETAIL_TEMPLATE | Указывается путь к странице с результатами сертификации.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Анкета специалиста.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:learning.student.profile","",Array(
        "TRANSCRIPT_DETAIL_TEMPLATE" => "certification/?TRANSCRIPT_ID=#TRANSCRIPT_ID#",
        "SET_TITLE" => "Y"
    ),
);?>


Резюме студента

Описание learning.student.transcript

Компонент отображает информацию о студенте и список полученных им сертификатов. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор резюме (Transcript ID) | TRANSCRIPT_ID | Указывается идентификатор резюме студента.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя пользователя.
Формат имени | NAME_TEMPLATE | Из выпадающего списка выбирается один из форматов отображения имени.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:learning.student.transcript","",Array(
        "TRANSCRIPT_ID" => $_REQUEST["TRANSCRIPT_ID"],
        "SET_TITLE" => "Y",
        "NAME_TEMPLATE" => "#LAST_NAME# #NAME_SHORT# #SECOND_NAME_SHORT#"
    ),
);?>


Контрольный тест

Описание learning.test

Компонент отображает контрольный тест курса. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор курса | COURSE_ID | Указывается идентификатор курса.
Идентификатор теста | TEST_ID | Указывается идентификатор теста.
Шаблоны ссылок
URL, ведущий на страницу с результатами тестирования | GRADEBOOK_TEMPLATE | Указывается путь к странице с результатами тестирования (путь к журналу).
Дополнительные настройки
Идентификатор вопроса | PAGE_NUMBER_VARIABLE | Задается имя переменной для идентификатора вопроса теста.
Количество вопросов в навигационной цепочке | PAGE_WINDOW | Указывается количество вопросов, отображаемых в навигационной цепочке.
Показывать счетчик ограничения времени | SHOW_TIME_LIMIT | [Y|N] При отмеченной опции будет отображаться счетчик времени. Примечание: если в настройках теста ограничение по времени не установлено, то счетчик не будет отображаться в любом случае.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя пользователя.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:learning.test","",Array(
        "COURSE_ID" => $_REQUEST["COURSE_ID"],
        "TEST_ID" => $_REQUEST["TEST_ID"],
        "PAGE_NUMBER_VARIABLE" => "PAGE",
        "GRADEBOOK_TEMPLATE" => "../gradebook.php?TEST_ID=#TEST_ID#",
        "PAGE_WINDOW" => "10",
        "SHOW_TIME_LIMIT" => "Y",
        "SET_TITLE" => "Y"
    ),
);?>


Самопроверка

Описание learning.test.self

Компонент выводит тест для самопроверки. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор курса | COURSE_ID | Указывается идентификатор курса.
Идентификатор урока | LESSON_ID | Указывается идентификатор урока.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Проверять право доступа | CHECK_PERMISSIONS | [Y|N] При отмеченной опции будет проверяться право на доступ к курсу.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название урока.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:learning.test.self","",Array(
        "COURSE_ID" => $_REQUEST["COURSE_ID"],
        "LESSON_ID" => $_REQUEST["LESSON_ID"],
        "CHECK_PERMISSIONS" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    ),
);?>


Список тестов

Описание learning.test.list

Компонент выводит список активных тестов курса. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор курса | COURSE_ID | Указывается идентификатор курса.
Шаблоны ссылок
URL, ведущий на страницу прохождения теста | TEST_DETAIL_TEMPLATE | Указывается путь к странице с прохождением теста.
Дополнительные настройки
Проверять право доступа | CHECK_PERMISSIONS | [Y|N] При отмеченной опции будет проверяться право на доступ к курсу.
Количество тестов на странице | TESTS_PER_PAGE | Указывается количество тестов, выводимых на одной странице. Остальные тесты будут выведены с помощью постраничной навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Список тестов.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:learning.test.list","",Array(
        "COURSE_ID" => $_REQUEST["COURSE_ID"],
        "TEST_DETAIL_TEMPLATE" => "test.php?COURSE_ID=#COURSE_ID#&TEST_ID=#TEST_ID#",
        "CHECK_PERMISSIONS" => "Y",
        "TESTS_PER_PAGE" => "20",
        "SET_TITLE" => "Y"
    ),
);?>


Детальный вывод главы

Описание learning.chapter.detail

Компонент производит детальный вывод главы курса. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор курса | COURSE_ID | Указывается идентификатор курса.
Идентификатор главы | CHAPTER_ID | Указывается идентификатор главы.
Шаблоны ссылок
URL, ведущий на страницу с главой | CHAPTER_DETAIL_TEMPLATE | Указывается путь к странице с главой курса.
URL, ведущий на страницу с уроком | LESSON_DETAIL_TEMPLATE | Указывается путь к странице с уроком курса.
URL, ведущий на страницу с профилем пользователя | PATH_TO_USER_PROFILE | Указывается путь к странице профиля пользователя.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Проверять право доступа | CHECK_PERMISSIONS | [Y|N] При отмеченной опции будет проверяться право на доступ к главе курcа.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название главы.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:learning.chapter.detail","",Array(
        "COURSE_ID" => $_REQUEST["COURSE_ID"],
        "CHAPTER_ID" => $_REQUEST["CHAPTER_ID"],
        "CHAPTER_DETAIL_TEMPLATE" => "chapter.php?CHAPTER_ID=#CHAPTER_ID#",
        "LESSON_DETAIL_TEMPLATE" => "lesson.php?LESSON_ID=#LESSON_ID#",
        "PATH_TO_USER_PROFILE" => "",
        "CHECK_PERMISSIONS" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    ),
);?>


Детальный вывод урока

Описание learning.lesson.detail

Компонент производит детальный вывод урока курса. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Сервисы > Обучение.

Компонент относится к модулю Обучение.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор курса | COURSE_ID | Указывается идентификатор курса.
Идентификатор урока | LESSON_ID | Указывается идентификатор урока.
Шаблоны ссылок
URL, ведущий на страницу с самотестированием | SELF_TEST_TEMPLATE | Указывается путь к странице с тестом для самопроверки.
URL, ведущий на страницу с профилем пользователя | PATH_TO_USER_PROFILE | Указывается путь к странице профиля пользователя.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Проверять право доступа | CHECK_PERMISSIONS | [Y|N] При отмеченной опции будет проверяться право на доступ к уроку.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название урока.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:learning.lesson.detail","",Array(
        "COURSE_ID" => $_REQUEST["COURSE_ID"],
        "LESSON_ID" => $_REQUEST["LESSON_ID"],
        "SELF_TEST_TEMPLATE" => "self.php?COURSE_ID=#COURSE_ID#&LESSON_ID=#LESSON_ID#",
        "PATH_TO_USER_PROFILE" => "",
        "CHECK_PERMISSIONS" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    ),
);?>


Опросы, голосования

Подраздел позволяет проводить опросы и голосования, которые помогут узнать мнение пользователей сайта по различным вопросам. Включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Текущий опрос (комплексный компонент) | voting.current | Выводит форму опроса, а после ее заполнения отображает результаты опроса.
Форма опроса | voting.form | Выводит форму опроса.
Список опросов | voting.list | Выводит список опросов.
Результаты опроса | voting.result | Выводит результаты опроса в виде диаграммы.


Текущий опрос (комплексный компонент)

Компонент выводит форму опроса, а после ее заполнения отображает результаты опроса. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Опросы, голосования > Текущий опрос.

Компонент относится к модулю Опросы, голосования.

Пример вызова компонента voting.current

<?$APPLICATION->IncludeComponent(
    "bitrix:voting.current",
    "",
    Array(
        "CHANNEL_SID" => "ANKETA",
        "VOTE_ID" => "",
        "VOTE_ALL_RESULTS" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "AJAX_MODE" => "Y",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y"
    )
);?>

Секции настроек компонента:

  • Основные параметры
  • Управление режимом AJAX
  • Настройки кеширования

    • Описание параметров

    Поле | Параметр | Описание
    Основные параметры
    Группа опросов | CHANNEL_SID | Указывается символьный идентификатор группы, опрос которой должен быть выведен.
    ID опроса | VOTE_ID | Указывается идентификатор опроса, который должен быть опубликован.
    Показывать варианты ответов для полей типа Text и Textarea | VOTE_ALL_RESULTS | Опция предназначена для показа текстовых ответов в явном виде.
    Управление режимом AJAX
    Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
    Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
    Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
    Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
    Настройки кеширования
    Тип кеширования CACHE_TYPE Тип кеширования:
    • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
    • Y - Кешировать: для кеширования необходимо определить время кеширования;
    • N - Не кешировать: кеширования нет в любом случае.
    Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.


Результаты опроса

Компонент выводит результаты опроса в виде диаграммы. Диаграмма может быть представлена в трех видах: по умолчанию, гистограмма или круговая диаграмма. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Опросы, голосования > Результаты опроса.

Компонент относится к модулю Опросы, голосования.

Группа параметров Дополнительно отображается только в том случае, если параметр VOTE_ID задан явно и для этого опроса созданы вопросы.

Пример вызова компонента voting.result

<?$APPLICATION->IncludeComponent(
    "bitrix:voting.result",
    "",
    Array(
        "VOTE_ID" => "1",
        "VOTE_ALL_RESULTS" => "Y",
        "NEED_SORT" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "1200",
        "CACHE_NOTES" => "",
        "QUESTION_DIAGRAM_1" => "histogram",
        "QUESTION_DIAGRAM_2" => "histogram"
    )
);?>

Секции настроек компонента:

  • Основные параметры
  • Настройки кеширования

    • Описание параметров

    Поле | Параметр | Описание
    Основные параметры
    Идентификатор опроса | VOTE_ID | Указывается идентификатор опроса. Задается явно или с помощью кода.
    Показывать все результаты | VOTE_ALL_RESULTS | При отмеченной опции будут показаны все результаты.
    Сортировать по количеству ответов NEED_SORT Сортировка вариантов ответов по убыванию количества поданных голосов:
    • Y - Сортировать;
    • N - Не сортировать.
    Настройки кеширования
    Тип кеширования CACHE_TYPE Тип кеширования:
    • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
    • Y - Кешировать: для кеширования необходимо определить время кеширования;
    • N - Не кешировать: кеширования нет в любом случае.
    Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.
    Дополнительно
    Тип диаграммы для вопроса <название_вопроса> | QUESTION_DIAGRAM_N | Для созданного в опросе вопроса <название_вопроса> (N - идентификатор вопроса) указывается тип диаграммы: по умолчанию, гистограмма (histogram) или круговая диаграмма (circle).
    Тема шаблона THEMEN При установке шаблона компонента main_page (Встроенный шаблон) в данном поле выбирается цветовое оформление. Доступные темы:
    • бесцветная
    • зеленая
    • синяя


Список опросов

Компонент выводит список опросов. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Опросы, голосования > Список опросов.

Компонент относится к модулю Опросы, голосования.

Пример вызова компонента voting.list

<?$APPLICATION->IncludeComponent("bitrix:voting.list","",Array(
        "CHANNEL_SID" => "BOOKS_VOTE",
        "VOTE_FORM_TEMPLATE" => "vote_new.php?VOTE_ID=#VOTE_ID#",
        "VOTE_RESULT_TEMPLATE" => "vote_result.php?VOTE_ID=#VOTE_ID#"
    ),
);?>

Описание параметров

Поле | Параметр | Описание
Основные параметры
Группа опросов | CHANNEL_SID | Указываются группы, опросы которых будут выведены на странице.
Шаблоны ссылок
Страница для вывода пустой формы опроса | VOTE_FORM_TEMPLATE | Указывается адрес страницы для вывода пустой формы опроса.
Страница для вывода диаграмм результатов опроса | VOTE_RESULT_TEMPLATE | Указывается адрес страницы для вывода диаграмм результатов опроса.


Форма опроса

Компонент выводит форму опроса. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Опросы, голосования > Форма опроса.

Компонент относится к модулю Опросы, голосования.

Пример вызова компонента voting.form

<?$APPLICATION->IncludeComponent("bitrix:voting.form",".default",Array(
        "VOTE_ID" => "2",
        "VOTE_RESULT_TEMPLATE" => "vote_result.php?VOTE_ID=#VOTE_ID#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    ),
);?>

Описание параметров

Поле | Параметр | Описание
Основные параметры
Идентификатор опроса | VOTE_ID | Указывается идентификатор опроса. Задается явно или с помощью кода.
Шаблоны ссылок
Страница для вывода диаграмм результатов опроса | VOTE_RESULT_TEMPLATE | Указывается адрес страницы для вывода диаграмм результатов опроса.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.


Рассылки

Подраздел предназначен для создания рассылок почтовых сообщений и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Список новостей | subscribe.news | Служит для выбора списка новостей из одного или нескольких информационных блоков для формирования рассылки.
Страница рассылок | subscribe.index | Служит для создания страницы со списком рассылок и формами управления подпиской.
Страница редактирования подписки | subscribe.edit | Служит для создания страницы с формами для добавления или редактирования адреса подписки.
Упрощенное редактирование подписки | subscribe.simple | Служит для управления подписками пользователей.
Форма подписки | subscribe.form | Служит для построения включаемой в дизайн сайта формы для подписки на рассылки.


Список новостей

Описание subscribe.news

Компонент служит для выбора списка новостей из одного или нескольких информационных блоков для формирования рассылки. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сервисы > Рассылки > Список новостей.

Компонент относится к модулю Рассылки.

Параметры

Поле | Параметр | Описание
Дополнительно
Сайт | SITE_ID | Указывается идентификатор сайта, информационные блоки которого будут участвовать в формировании рассылки.
Тип информационного блока | IBLOCK_TYPE | Указывается тип информационного блока.
Код информационного блока | ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, список элементов которого будет участвовать в формировании рассылки. Если необходимы элементы всех инфоблоков выбранного типа, то укажите (все).
Поле для сортировки новостей | SORT_BY | Указывается поле, по которому будет выполнена сортировка новостей в списке: по дате начала активности (ACTIVE_FROM) или по индексу сортировки (SORT).
Направление сортировки новостей | SORT_ORDER | Указывается направление сортировки: по убыванию (DESC) или по возрастанию (ASC).

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:subscribe.news","",Array(
        "SITE_ID" => "s1",
        "IBLOCK_TYPE" => "paid",
        "ID" => "19",
        "SORT_BY" => "ACTIVE_FROM",
        "SORT_ORDER" => "DESC"
    ),
);?>


Страница рассылок

Описание subscribe.index

Компонент служит для создания страницы со списком рассылок и формами управления подпиской. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Сервисы > Рассылки > Страница рассылок.

Компонент относится к модулю Рассылки.

Параметры

Поле | Параметр | Описание
Источник данных
Показывать количество подписчиков | SHOW_COUNT | [Y|N] При отмеченной опции в публичной части будет выведено количество подписчиков на представленные рассылки.
Показать скрытые рубрики подписки | SHOW_HIDDEN | [Y|N] При отмеченной опции в списке рассылок будут выведены все активные рассылки вне зависимости от опции Выводить в списке публичных рассылок в настройках рассылки.
Шаблоны ссылок
Страница редактирования подписки (доступен макрос #SITE_DIR#) | PAGE | Указывается путь к странице редактирования подписки (доступен макрос #SITE_DIR#).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Рассылки.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:subscribe.index","",Array(
        "SHOW_COUNT" => "Y",
        "SHOW_HIDDEN" => "Y",
        "PAGE" => "#SITE_DIR#personal/subscribe/subscr_edit.php",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SET_TITLE" => "Y"
    )
);?>


Страница редактирования подписки

Описание subscribe.edit

Компонент служит для создания страницы с формами для добавления или редактирования адреса подписки. Если пользователь не авторизован на сайте, то в зависимости от настроек он сможет подписаться на рассылку, указав свой e-mail или перейти к редактированию параметров рассылки после ввода e-mail и кода подтверждения (пароля) подписки, который высылается на адрес электронной почты после оформления подписки. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сервисы > Рассылки > Страница редактирования подписки.

Компонент относится к модулю Рассылки.

Параметры

Поле | Параметр | Описание
Источник данных
Показать скрытые рубрики подписки | SHOW_HIDDEN | [Y|N] При отмеченной опции в списке рассылок будут выведены все активные рассылки вне зависимости от опции Выводить в списке публичных рассылок в настройках рассылки.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.
Дополнительные настройки
Разрешить анонимную подписку | ALLOW_ANONYMOUS | [Y|N] При отмеченной опции анонимные пользователи смогут подписываться на рассылку, лишь указав свой адрес электронной почты без необходимости регистрации на сайте. В случае неустановленной опции подписаться на рассылку анонимный пользователь не сможет. Только уже подписавшийся пользователь сможет редактировать параметры рассылки после ввода e-mail и кода подтверждения (пароль) подписки.
Показывать ссылки на авторизацию при анонимной подписке | SHOW_AUTH_LINKS | [Y|N] При отмеченной опции для анонимного пользователя при подписке на рассылку будут выведены формы для авторизации (если он зарегистрирован, то сможет авторизоваться) и форма для регистрации (пользователь сможет зарегистрироваться, если не имеет учетной записи на сайте).
Устанавливать заголовок страницы SET_TITLE [Y|N] При отмеченной опции заголовком страницы будет установлен:
  • Редактирование параметров подписки при редактировании подписки;
  • Добавление адреса подписки при создании подписки.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:subscribe.edit","",Array(
        "AJAX_MODE" => "N",
        "SHOW_HIDDEN" => "Y",
        "ALLOW_ANONYMOUS" => "Y",
        "SHOW_AUTH_LINKS" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SET_TITLE" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Упрощенное редактирование подписки

Описание subscribe.simple

Компонент служит для управления подписками пользователей. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сервисы > Рассылки > Упрощенное редактирование подписки.

Компонент относится к модулю Рассылки.

Параметры

Поле | Параметр | Описание
Источник данных
Показать скрытые рубрики подписки | SHOW_HIDDEN | [Y|N] При отмеченной опции в списке рассылок будут выведены все активные рассылки вне зависимости от опции Выводить в списке публичных рассылок в настройках рассылки.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Подписка.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:subscribe.simple","",Array(
        "AJAX_MODE" => "N",
        "SHOW_HIDDEN" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SET_TITLE" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    ),
);?>


Форма подписки

Описание subscribe.form

Компонент служит для построения включаемой в дизайн сайта формы для подписки на рассылки. Право на подписку имеют как зарегистрированные, так и анонимные пользователи (в случае наличия установленной опции в настройках модуля Подписка, рассылка). Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сервисы > Рассылки > Форма подписки.

Компонент относится к модулю Рассылки.

Параметры

Поле | Параметр | Описание
Основные параметры
Определять подписку текущего пользователя | USE_PERSONALIZATION | [Y|N] При отмеченной опции будут определяться имеющиеся подписки текущего пользователя.
Источник данных
Показать скрытые рубрики подписки | SHOW_HIDDEN | [Y|N] При отмеченной опции в списке рассылок будут выведены все активные рассылки вне зависимости от опции Выводить в списке публичных рассылок в настройках рассылки.
Шаблоны ссылок
Страница редактирования подписки (доступен макрос #SITE_DIR#) | PAGE | Указывается путь от корня сайта (#SITE_DIR#) к странице редактирования подписки.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:subscribe.form","",Array(
        "USE_PERSONALIZATION" => "Y",
        "PAGE" => "#SITE_DIR#personal/subscribe/subscr_edit.php",
        "SHOW_HIDDEN" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Реклама

Подраздел позволяет организовать показ баннеров на сайте и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Баннер | advertising.banner | Выводит баннер заданного типа.


Баннер

Описание advertising.banner

Компонент выводит баннер заданного типа. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Сервисы > Реклама > Баннер.

Компонент относится к модулю Реклама.

Внимание! Компонент не учитывает таргетинг по ключевым словам, для этого необходимо использовать функцию $APPLICATION->ShowBanner() (более подробную информацию по функции можно посмотреть на странице документации для разработчиков [image]).

Параметры

Поле | Параметр | Описание
Основные параметры
Тип баннера | TYPE | Указывается один из типов баннера, созданных в системе.
Добавлять в ссылки noindex/nofollow NOINDEX [Y|N] При отмеченной опции ссылка перехода по баннеру данного типа заключаются в тэг noindex, а самой ссылке присваивается атрибут nofollow. HTML-тэг noindex используются для исключения из ранжирования в Яндексе и Рамблере заключенного в него текста. Атрибут rel="nofollow" используется для исключения индексации ссылки. Например:
 <noindex><a href="/ссылка_перехода_по_баннеру"
rel="nofollow"><img src="/upload/banners/10d/banner_100x100.gif" /></a></noindex>
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:advertising.banner","",Array(
        "TYPE" => "BOTTOM",
        "CACHE_TYPE" => "A",
        "NOINDEX" => "Y",
        "CACHE_TIME" => "3600"
    )
);?>


Техподдержка

Подраздел для организации системы обращений посетителей к группе техподдержки. Включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Мастер создания обращения | iblock.wizard | Формирует разделы мастера на основе секций инфоблока и вопросы на основе элементов инфоблока.
Техподдержка (комплексный компонент) | support.ticket | Создает полноценную систему техподдержки, с помощью которой можно просмотреть список обращений, добавить своё сообщение или написать новое обращение в техподдержку.
Создание нового, либо редактирование существующего обращения | support.ticket.edit | Предназначен для вывода формы редактирования существующего обращения либо создания нового.
Список обращений | support.ticket.list | Предназначен для вывода формы фильтра и списка обращений в техподдержку.
Техподдержка с мастером (комплексный компонент) | support.wizard | Служит для организации полноценного публичного интерфейса технической поддержки, создание обращения в котором выполняется с помощью специального мастера.


Техподдержка (комплексный компонент)

Описание support.ticket

Комплексный компонент создает полноценную систему техподдержки, с помощью которой можно просмотреть список обращений, добавить своё сообщение или написать новое обращение в техподдержку. Компонент является стандартным и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Техподдержка > Техподдержка.

Компонент относится к модулю Техподдержка.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • ticket_list - страница списка обращений;
  • ticket_edit - страница редактирования обращения.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]ID[/dw][di]
Идентификатор обращения ID Указывается идентификатор обращения.
[/di] .
Дополнительные настройки
Количество обращений на одной странице | TICKETS_PER_PAGE | Указывается количество обращений, отображаемых на одной странице.
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Указывается количество сообщений, отображаемых на одной странице.
Максимальная длина неразрывной строки | MESSAGE_MAX_LENGTH | Задается максимальная длина фразы без пробелов или символов перевода строки.
Направление для сортировки сообщений в обращении MESSAGE_SORT_ORDER Указывается направление сортировки сообщений в обращении. Сообщения сортируются по времени добавления:
  • asc - по возрастанию;
  • desc - по убыванию.
Устанавливать заголовок страницы | SET_PAGE_TITLE | При выборе значения Да в качестве заголовка будет установлено Новое обращение. В противном случае (значение Нет) заголовок установлен не будет.
Показывать поле ввода купона | SHOW_COUPON_FIELD | [Y|N] При отмеченной опции будет показано поле ввода купона.
Показывать пользовательские поля | SET_SHOW_USER_FIELD | Выбираются пользовательские поля, которые должны быть показаны в форме создания/редактирования обращения.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:support.ticket","",Array(
        "SEF_MODE" => "Y",
        "TICKETS_PER_PAGE" => "50",
        "MESSAGES_PER_PAGE" => "20",
        "MESSAGE_MAX_LENGTH" => "70",
        "MESSAGE_SORT_ORDER" => "asc",
        "SET_PAGE_TITLE" => "Y",
        "SHOW_COUPON_FIELD" => "Y",
        "SEF_FOLDER" => "/",
        "SET_SHOW_USER_FIELD" => "array()",
        "SEF_URL_TEMPLATES" => Array(
            "ticket_list" => "index.php",
            "ticket_edit" => "#ID#.php"
        ),
        "VARIABLE_ALIASES" => Array(
            "ticket_list" => Array(),
            "ticket_edit" => Array(),
        )
    )
);?>


Техподдержка с мастером (комплексный компонент)

Описание support.wizard

Компонент служит для организации полноценного публичного интерфейса технической поддержки, создание обращения в котором выполняется с помощью специального мастера. Компонент является стандартным и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Техподдержка > Техподдержка с мастером.

Компонент относится к модулю Техподдержка.

Примечание: мастер представляет собой информационный блок, а вопросы мастера являются разделами и элементами этого инфоблока.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип информационного блока.
Информационный блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором хранится мастер техподдержки.
Свойство, в котором хранится тип вопроса | PROPERTY_FIELD_TYPE | Указывается свойство, в котором хранится тип вопроса.
Множественное свойство, в котором хранятся значения выпадающего списка | PROPERTY_FIELD_VALUES | Указывается множественное свойство, в котором хранятся значения выпадающего списка.
Управление адресами страниц
Идентификатор обращения | VARIABLE_ALIASES_ID | Указывается идентификатор обращения.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Дополнительные настройки
Добавлять разделы мастера в навигационную цепочку | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции разделы мастера техподдержки будут добавлены в навигационнную цепочку.
Количество обращений на одной странице | TICKETS_PER_PAGE | Указывается количество обращений, отображаемых на одной странице.
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Указывается количество сообщений, отображаемых на одной странице.
Максимальная длина неразрывной строки | MESSAGE_MAX_LENGTH | Задается максимальная длина фразы без пробелов или символов перевода строки.
Направление для сортировки сообщений в обращении MESSAGE_SORT_ORDER Указывается направление сортировки сообщений в обращении. Сообщения сортируются по времени добавления:
  • asc - по возрастанию;
  • desc - по убыванию.
Устанавливать заголовок страницы | SET_PAGE_TITLE | При выборе значения Да в качестве заголовка будет установлено Список обращений. В противном случае (значение Нет) заголовок установлен не будет.
Шаблон мастера | TEMPLATE_TYPE | Укажите тему внешнего вида мастера: Строгий (standard) или Изящный (.default).
Показать результат работы мастера | SHOW_RESULT | [Y|N] При отмеченной опции будет показан результат работы мастера.
Показывать поле ввода купона | SHOW_COUPON_FIELD | [Y|N] При отмеченной опции будет показано поле ввода купона.
Показывать пользовательские поля | SET_SHOW_USER_FIELD | Выбираются пользовательские поля, которые должны быть показаны в форме создания/редактирования обращения.
Привязка разделов мастера к категориям техподдержки
Включить привязки SECTIONS_TO_CATEGORIES [Y|N] При отмеченной опции будет включена привязка разделов мастера к категориям техподдержки, станет активным [dw]дополнительное поле.[/dw][di]
Список разделов для привязки SELECTED_SECTIONS Указывается список разделов мастера техподдержки для привязки.
[/di]

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:support.wizard","",Array(
        "IBLOCK_TYPE" => "services",
        "IBLOCK_ID" => "11",
        "PROPERTY_FIELD_TYPE" => "type",
        "PROPERTY_FIELD_VALUES" => "values",
        "AJAX_MODE" => "N",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "TICKETS_PER_PAGE" => "50",
        "MESSAGES_PER_PAGE" => "20",
        "MESSAGE_MAX_LENGTH" => "70",
        "MESSAGE_SORT_ORDER" => "asc",
        "SET_PAGE_TITLE" => "Y",
        "TEMPLATE_TYPE" => "standard",
        "SHOW_RESULT" => "Y",
        "SHOW_COUPON_FIELD" => "Y",
        "SECTIONS_TO_CATEGORIES" => "Y",
        "SELECTED_SECTIONS" => Array(),
        "SET_SHOW_USER_FIELD" => array(),
        "VARIABLE_ALIASES_ID" => "ID",
        "AJAX_OPTION_SHADOW" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Создание нового, либо редактирование существующего обращения

Описание support.ticket.edit

Компонент предназначен для вывода формы редактирования существующего обращения либо создания нового. С помощью этой формы ведется дискуссия по решению проблемы, обозначенной в обращении. Компонент является стандартным и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Техподдержка > Создание нового, либо редактирование существующего обращения.

Компонент относится к модулю Техподдержка.

Параметры

Поле | Параметр | Описание
Основные параметры
ID обращения | ID | Указывается идентификатор обращения.
Шаблоны ссылок
Страница списка обращений | TICKET_LIST_URL | Указывается адрес страницы списка обращений.
Дополнительные настройки
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Указывается количество сообщений, отображаемых на одной странице.
Максимальная длина неразрывной строки | MESSAGE_MAX_LENGTH | Задается максимальная длина фразы без пробелов или символов перевода строки.
Направление для сортировки сообщений в обращении MESSAGE_SORT_ORDER Указывается направление сортировки сообщений в обращении. Сообщения сортируются по времени добавления:
  • asc - по возрастанию;
  • desc - по убыванию.
Устанавливать заголовок страницы SET_PAGE_TITLE При выборе значения Да в качестве заголовка будет установлено:
  • Новое обращение - при создании нового обращения;
  • Редактирование обращения - при редактировании уже существующего обращения.
В противном случае (значение Нет) заголовок установлен не будет.
Показывать поле ввода купона | SHOW_COUPON_FIELD | [Y|N] При отмеченной опции будет показано поле ввода купона.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:support.ticket.edit","",Array(
        "ID" => "$_REQUEST[\"ID\"]",
        "TICKET_LIST_URL" => "ticket_list.php",
        "MESSAGES_PER_PAGE" => "20",
        "MESSAGE_MAX_LENGTH" => "70",
        "MESSAGE_SORT_ORDER" => "asc",
        "SET_PAGE_TITLE" => "Y",
        "SHOW_COUPON_FIELD" => "Y"
    )
);?>


Список обращений

Описание support.ticket.list

Компонент предназначен для вывода формы фильтра и списка обращений в техподдержку. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Техподдержка > Список обращений.

Компонент относится к модулю Техподдержка.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
Страница редактирования обращения | TICKET_EDIT_TEMPLATE | Указывается адрес страницы редактирования выбранного обращения.
Дополнительные настройки
Количество обращений на одной странице | MESSAGES_PER_PAGE | Указывается количество обращений, отображаемых на одной странице.
Устанавливать заголовок страницы | SET_PAGE_TITLE | При выборе значения Да в качестве заголовка будет установлено Список обращений. В противном случае (значение Нет) заголовок установлен не будет.
Показывать пользовательские поля | SET_SHOW_USER_FIELD | Выбираются пользовательские поля, которые должны быть показаны в форме создания/редактирования обращения.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:support.ticket.list","",Array(
        "TICKET_EDIT_TEMPLATE" => "ticket_edit.php?ID=#ID#",
        "TICKETS_PER_PAGE" => "50",
        "SET_PAGE_TITLE" => "Y",
        "SET_SHOW_USER_FIELD" => ""
    )
);?>


Мастер создания обращения

Описание iblock.wizard

Компонент формирует разделы мастера на основе секций инфоблока [image] и вопросы на основе элементов инфоблока. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Техподдержка > Мастер создания обращения.

Компонент относится к модулю Техподдержка.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип информационного блока.
Информационный блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором хранится мастер техподдержки.
Свойство, в котором хранится тип вопроса | PROPERTY_FIELD_TYPE | Указывается свойство, в котором хранится тип вопроса.
Множественное свойство, в котором хранятся значения выпадающего списка | PROPERTY_FIELD_VALUES | Указывается множественное свойство, в котором хранятся значения выпадающего списка.
Страница, с которой пришли на мастер (для кнопки "Назад", может быть пустое) | BACK_URL | Указывается адрес страницы, с которой пришли на мастер (для кнопки "Назад", поле может быть пустое).
Страница с формой редактирования сообщения | NEXT_URL | Указывается адрес страницы с формой редактирования сообщения.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.
Дополнительные настройки
Добавлять разделы мастера в навигационную цепочку | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции разделы мастера техподдержки будут добавлены в навигационнную цепочку.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:iblock.wizard","",Array(
        "AJAX_MODE" => "N",
        "IBLOCK_TYPE" => "services",
        "IBLOCK_ID" => "11",
        "PROPERTY_FIELD_TYPE" => "",
        "PROPERTY_FIELD_VALUES" => "",
        "BACK_URL" => "ticket_list.php",
        "NEXT_URL" => "ticket_edit.php",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    ),
);?>


Общение

Подразделы
Название | Имя в пространстве имен bitrix | Описание
Бизнес-процесс | bizproc | Cлужит для автоматизации бизнес-процессов организации.
Блоги | blog | Предоставляет возможность полнофункциональной работы с неограниченным числом блогов.
Социальная сеть | socialnetwork | Предназначен для создания полнофункционального публичного интерфейса социальной сети.
Форум | forum | Служит для создания и управления форумами сайта.


Бизнес-процесс

Подраздел служит для автоматизации бизнес-процессов организации и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Бизнес-процесс (комплексный компонент) | bizproc.wizards | Служит для создания полноценного публичного интерфейса для работы с бизнес-процессами организации.


Бизнес-процесс (комплексный компонент)

Комплексный компонент служит для создания полноценного публичного интерфейса для работы с бизнес-процессами организации, позволяет создавать и изменять произвольные бизнес-процессы с помощью визуальных средств. Компонент стандартный и входит в дистрибутив модуля.

Описание bizproc.wizards

В визуальном редакторе компонент расположен по пути: Общение > Бизнес-процесс > Бизнес-процесс.

Компонент относится к модулю Бизнес-процесс.

Примечание: создание новых шаблонов бизнес-процессов доступно только при наличии модуля Дизайнер бизнес-процессов [image], входящего в старшую редакцию продукта Бизнес-процессы.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков, в которых будут храниться бизнес-процессы. Каждый бизнес-процесс представляет собой инфоблок указаного типа.
Доступ
Административный доступ | ADMIN_ACCESS | Указываются группы пользователей, которые могут управлять (создавать, редактировать и удалять) бизнес-процессами в публичной части.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включен режим поддержки ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - страница со списком бизнес-процессов;
  • new - страница создания нового бизнес-процесса;
  • list - страница со списком запущенных бизнес-процессов;
  • start - страница запуска бизнес-процесса;
  • edit - страница редактирования бизнес-процесса;
  • task - страница задачи бизнес-процеса;
  • bp - страница редактирования бизнес-процесса;
  • setvar - страница настройки переменных бизнес-процесса;
  • log - страница истории бизнес-процесса.
Имена переменных | VARIABLE_ALIASES | Указываются имена переменных для управления страницами.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES и VARIABLE_ALIASES.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить затенение | AJAX_OPTION_SHADOW | [Y|N] Если параметр принимает значение "Y", то при выполнении AJAX-перехода будет затенена область, которая должна измениться.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции будет установлен заголовок страницы в соответствии с её содержимым.
Устанавливать цепочку навигации | SET_TITLE | [Y|N] При отмеченной опции переходы по страницам будут отображены в цепочке навигации.
Только один процесс | SKIP_BLOCK | [Y|N] При отмеченной опции будет выводиться только одним бизнес-процесс организации, а управление бизнес-процессами будет недоступно.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:bizproc.wizards","",Array(
        "SEF_MODE" => "Y",
        "SET_TITLE" => "Y",
        "SET_NAV_CHAIN" => "Y",
        "SKIP_BLOCK" => "N",
        "IBLOCK_TYPE" => "bizproc_iblockx",
        "ADMIN_ACCESS" => array("1"),
        "AJAX_MODE" => "Y",
        "SEF_FOLDER" => "/",
        "AJAX_OPTION_SHADOW" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "AJAX_OPTION_ADDITIONAL" => "",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "new" => "new.php",
            "list" => "#block_id#/",
            "start" => "#block_id#/start.php",
            "edit" => "#block_id#/edit.php",
            "task" => "#block_id#/task-#task_id#.php",
            "bp" => "#block_id#/bp.php",
            "setvar" => "#block_id#/setvar.php",
            "log" => "#block_id#/log-#bp_id#.php"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "new" => Array(),
            "list" => Array(),
            "start" => Array(),
            "edit" => Array(),
            "task" => Array(),
            "bp" => Array(),
            "setvar" => Array(),
            "log" => Array(),
        )
    ),
);?>


Блоги

Подраздел предоставляет возможность полнофункциональной работы с неограниченным числом блогов. Содержит компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Блоги (комплексный компонент) | blog | Создает полноценный публичный интерфейс блога.
Сообщения блога | blog.blog | Выводит сообщения блога с возможностью их фильтрации по категории и дате.
Черновики сообщений блога | blog.blog.draft | Выводит неопубликованные сообщения текущего пользователя блога.
Редактирование блога | blog.blog.edit | Служит для изменения параметров и настройки блога.
Лучшие сообщения блога | blog.blog.favorite | Выводит список лучших сообщения блога на основе отметок владельца блога (при создании сообщений владелец блога указывает индекс сортировки сообщения).
Календарь | blog.calendar | Выводит календарь сообщений блога.
Теги блога | blog.category | Служит для редактирования тегов сообщений блога.
Комментируемые сообщения | blog.commented_posts | Выводит наиболее комментируемые сообщения блогов за заданный период.
Лента друзей | blog.friends | Выводит сообщения друзей пользователя блога.
Блоги группы | blog.group.blog | Выводит блоги группы.
Группы блогов | blog.groups | Выводит непустые группы блогов.
Информация о блоге | blog.info | Выводит информацию о блоге со списком тегов.
Меню блогов | blog.menu | Выводит меню блога.
Новые блоги | blog.new_blogs | Выводит новые блоги.
Новые комментарии | blog.new_comments | Выводит последние комментарии к сообщениям блогов.
Новые сообщения | blog.new_posts | Выводит последние сообщения блогов текущего сайта.
Последние сообщения всех блогов | blog.new_posts.list | Выводит последние сообщения блогов с постраничной навигацией.
Популярные блоги | blog.popular_blogs | Выводит популярные блоги.
Популярные сообщения | blog.popular_posts | Выводит наиболее просматриваемые сообщения блогов за заданный период.
Сообщение детально | blog.post | Выводит сообщение блога подробно.
Комментарии к сообщению | blog.post.comment | Выводит комментарии к сообщению блога с возможностью добавления нового комментария.
Редактирование сообщения | blog.post.edit | Служит для создания новых или редактирования существующих сообщения блога.
Trackback'и сообщения | blog.post.trackback | Выводит Trackback-адрес и Trackback'и к сообщению блога.
Получение Trackback'ов к сообщению | blog.post.trackback.get | Получает Trackback к сообщению блога.
[link=63218 ]RSS блога[/link] | blog.rss | Выводит RSS блогов в заданном формате.
RSS блогов по группам/сайтам | blog.rss.all | Выводит RSS блогов группы или сайта в заданном формате.
Ссылки на RSS блога | blog.rss.link | Выводит ссылки на RSS блога.
Поиск по блогам | blog.search | Выводит непустые группы блогов.
Профиль пользователя | blog.user | Позволяет просмотреть и изменить профиль пользователя.
Группы пользователей блога | blog.user.group | Служит для редактирования группы пользователей блога.
Настройка пользователей блога | blog.user.settings | Позволяет настраивать пользователей блога: добавлять их в друзья, удалять.
Настройка прав пользователя блога | blog.user.settings.edit | Позволяет настраивать привязку пользователя к группам блога.
Неопубликованные сообщения блога | blog.blog.moderation | Выводит сообщения блога, требующие модерации.
Получение данных в формате metaWeblog | blog.metaweblog | Осуществляет импорт в формате MetaWeblog.
Комментарии к сообщению - плоский список | blog.post.comment.list | Dыводит комментарии к сообщениям блога в виде плоского списка.


Блоги (комплексный компонент)

Описание blog

Комплексный компонент создает полноценный публичный интерфейс блогов и осуществляет импорт сообщений из Microsoft Word и Microsoft Live Writer и других редакторов в формате MetaWeblog.

В поставку продукта входят шесть шаблонов компонента: .default, general_page, general_page_old_version, old_version, one_blog, one_blog_old_version и one_blog_with_main_page.

Для режима ЧПУ страница импорта - /blog/metaweblog.php, а если режим ЧПУ отключен, то - /blog/index.php?page=metaweblog.

Компонент является стандартным и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Блоги.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Внешний вид
Количество сообщений, выводимых на страницу | MESSAGE_COUNT | Указывается количество сообщений на странице. Остальные сообщения будут выведены с помощью постраничной навигации.
Количество дней для выбора популярных сообщений и блогов | PERIOD_DAYS | Указывается количество дней для выбора популярных сообщений и блогов, которые будут отображены в разделе Популярные.
Количество сообщений, выводимых на главной странице блогов | MESSAGE_COUNT_MAIN | Указывается количество сообщений, отображаемых на главной странице блогов.
Количество блогов, выводимых на главной странице блогов | BLOG_COUNT_MAIN | Указывается количество блогов, отображаемых на главной странице блогов.
Длина выводимых сообщений на главной странице блогов (символов) | MESSAGE_LENGTH | Задается длина выводимых сообщений на главной странице блогов в символах.
Количество блогов, выводимых на страницу | BLOG_COUNT | Указывается число блогов, отображаемых на одной странице. Остальные блоги будут выведены с помощью постраничной навигации.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Количество постоянно отображаемых смайлов | SMILES_COUNT | Указывается количество постоянно отображаемых смайлов на странице. По умолчанию значение равно 4.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Максимально допустимая ширина добавляемого в сообщение изображения (в пикселях).
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Максимально допустимая высота добавляемого в сообщение изображения (в пикселях).
Разрешить изменять размер визуального редактора | EDITOR_RESIZABLE | [Y|N] При отмеченной опции будет возможность менять размеры окна визуального редактора.
Высота визуального редактора по умолчанию (пикселей) | EDITOR_DEFAULT_HEIGHT | Значение высоты визуального редактора при загрузке (в пикселях).
По умолчанию показывать невизуальный режим редактора | EDITOR_CODE_DEFAULT | [Y|N] При отмеченной опции визуальный режим редактора не будет использоваться по умолчанию при создании сообщений.
Согласие пользователя
Запрашивать согласие | USER_CONSENT | [Y|N] Установленный флажок включает механизм согласия пользователя.
Соглашение | USER_CONSENT_ID | Задается текст соглашения, которое отображается пользователю при заказе.
Галка по умолчанию проставлена | USER_CONSENT_IS_CHECKED | Установка галочки автомаитчески устанавливает галочку в чекбоксе согласия пользователя. То есть согласие применяется одновременно с нажатием кнопки Оформить заказ.
Загружать текст сразу | USER_CONSENT_IS_LOADED | Текст соглашения будет выводиться сразу. Если флажок не установлен, для просмотра текст нужно будет кликнуть по кнопке согласия.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Если режим ЧПУ включен, то необходимо настроить [dw]следующие параметры[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Указывается путь к каталогу ЧПУ.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - главная страница блогов
  • group - страница блогов группы
  • blog - страница блога
  • user - страница профайла пользователя
  • user_friends - страница ленты друзей пользователя
  • search - страница поиска по блогам
  • user_settings - страница настройки пользователей
  • user_settings_edit - страница настройки прав доступа пользователей
  • group_edit - страница настройки групп пользователей блога
  • blog_edit - страница редактирования блога
  • category_edit - страница настройки тегов блога
  • post_edit - страница редактирования сообщения
  • draft - страница недописанных сообщений
  • moderation - страница премодерируемых сообщений
  • trackback - Trackback адрес сообщения
  • post - страница с сообщением, показанным детально
  • post_rss - адрес комментариев к сообщению в RSS формате
  • rss - адрес блога в RSS формате
  • rss_all - сообщения всех блогов в RSS формате
[/di]: SEF_FOLDER и SEF_URL_TEMPLATES.
Если режим ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
[/di].
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Время кеширования остальных страниц | CACHE_TIME_LONG | Указывается время кеширования страниц, начиная со второй.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта. По умолчанию задано /bitrix/images/blog/smile/.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Блоги.
Добавлять блог в цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт с названием блога.
Использование SEO SEO_USE Выбирается метод использования SEO:
  • не использовать;
  • отдельные поля для описания;
  • поля по умолчанию.
Показывать доп. свойства в профиле | USER_PROPERTY | Указываются дополнительные свойства, которые будут отображены в профиле пользователя блога.
Показывать свойства в блоге | BLOG_PROPERTY | Указываются пользовательские свойства блога, которые необходимо дополнительно отобразить.
Показывать пользовательские свойства блога в информации о блоге | BLOG_PROPERTY_LIST | Указываются дополнительные пользовательские свойства блога, которые необходимо отобразить в информации о блоге.
Показывать пользовательские свойства сообщения | POST_PROPERTY | Указываются пользовательские свойства сообщения, которые будут отображены при детальном просмотре сообщения.
Показывать пользовательские свойства сообщения в блоге | POST_PROPERTY_LIST | Указываются дополнительные пользовательские свойства сообщения в блоге, которые необходимо отобразить в блоге.
Показывать пользовательские свойства комментария | COMMENT_PROPERTY | Указываются пользовательские свойства комментария, которые необходимо отобразить в блоге.
Использовать прямую постраничную навигацию для комментариев | USE_ASC_PAGING | [Y|N] При отмеченной опции список комментариев будет выводиться постранично с прямой навигацией.
Включить рейтинг SHOW_RATING Указывается, будет ли будет использован функционал рейтингов:
  • да;
  • нет;
  • по умолчанию - значение берется из настроек рейтингов.

Примечание:

С версии 17.6.0 добавлена поддержка рейтингов с реакциями.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопок рейтинга:
  • по умолчанию;
  • Мне нравится (текстовый);
  • Мне нравится (графический);
  • Нравится / Не нравится (текстовый);
  • Нравится / Не нравится (графический).

    • Значение По умолчанию берется из настроек рейтингов.

Использовать символьный код сообщений как идентификатор ALLOW_POST_CODE

[Y|N] При отмеченной опции транслитерация заголовка сообщения будет использоваться как его идентификатор; станет доступно [dw]дополнительное поле[/dw][di]
Использовать внешний сервис для перевода кода сообщений USE_GOOGLE_CODE [Y|N] При отмеченной опции для перевода символьного кода сообщений будет использоваться сервис Google-переводчик.
[/di].
Дополнительно | Для шаблона old_version данная группа параметров не отображается.
Тема шаблона | THEME | Указывается цветовая тема, которая будет использоваться для интерфейса блогов. Данное поле доступно для шаблонов .default, general_page и one_blog.
Группа блогов для отображения | GROUP_ID | Указывается группа блогов, блоги которой будут отображены. Если не указано, то выборка производится по всем группам блогов. Данное поле доступно для шаблонов .default и general_page.
Показывать строку навигации по блогам | SHOW_NAVIGATION | [Y|N] При отмеченной опции будет отображаться навигация по блогам. Данное поле доступно для шаблона .default.
Название закладки с доп. свойствами | USER_PROPERTY_NAME | Указывается название закладки с дополнительными свойствами. Данное поле доступно для шаблонов .default, one_blog, one_blog_old_version и one_blog_with_main_page.
Период, в течение которого считать тег новым для облака тегов (дней) | PERIOD_NEW_TAGS | Указывается период (количество дней), в течение которого тег считается новым. Данное поле доступно для шаблона .default.
Период выборки тегов (дней) | PERIOD | Указывается период (количество дней), в течение которого осуществляется выборка тегов. Данное поле дотсупно для шаблона .default.
Плавное изменение цвета для облака тегов | COLOR_TYPE | [Y|N] При отмеченной опции переход между цветами тегов будет плавным. Данное поле доступно для шаблона .default.
Ширина облака тегов (пример: "100%" или "100px", "100pt", "100in") | WIDTH | Указывается ширина облака тегов (пример: "100%" или "100px", "100pt", "100in"). Данное поле доступно для шаблона .default.
Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя. Данное поле доступно для шаблонов .default и general_page.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество. Данное поле доступно для шаблонов .default, general_page, one_blog и one_blog_with_main_page.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя. Данное поле доступно для шаблонов .default, general_page, one_blog и one_blog_with_main_page.
Отображать панель соц. закладок USE_SHARE [Y|N] При отмеченной опции будет выведена панель соц. закладок на страницах со списком и на странице поста. Поле доступно в шаблонах: .default, general_page, one_blog, one_blog_with_main_page. При выборе данной опции станут доступны [dw]дополнительные поля[/dw][di]
Не раскрывать панель соц. закладок по умолчанию | SHARE_HIDE | [Y|N] При отмеченной опции панель со значками соц. сетей будет скрыта по умолчанию. При работе с сайтом пользователь сможет развернуть ее.
Шаблон компонента панели соц. закладок | SHARE_TEMPLATE | Если пусто, то будет использован шаблон по умолчанию. Можно создать свой шаблон.
Используемые соц. закладки и сети | SHARE_HANDLERS | [Y|N] В виде массива перечисляются соц.закладки и сети, которые требуется отобразить в выводимой панели. В виде кода пишется array("delicious","twitter","vk").
Логин для bit.ly | SHARE_SHORTEN_URL_LOGIN | Зарегистрируйтесь на ресурсе http://bit.ly/ [image] [image] и введите ваш логин оттуда.
Ключ для для bit.ly | SHARE_SHORTEN_URL_KEY | После регистрации на ресурсе http://bit.ly/ [image] [image] вы получите API Key. Его необходимо ввести в данном поле. После проведенных настроек ссылка на ваш сайт будет автоматически укорачиваться средствами bit.ly и примет такой вид http://bit.ly/aLj59v. Данная технология применена к twitter, где критична длина сообщения.
[/di].
Шаблон пути к странице пользователя соцсети | PATH_TO_SONET_USER_PROFILE | Указывается путь к странице пользователя соцсети. По умолчанию задано /club/user/#user_id#/. Данное поле доступно для шаблона .default, general_page и one_blog_with_main_page.
Шаблон пути к чату с пользователем | PATH_TO_MESSAGES_CHAT | Указывается путь к странице чата с пользователем. По умолчанию задано /club/messages/chat/#user_id#/. Данное поле доступно для шаблона .default, general_page и one_blog_with_main_page.
Разрешить перенос сообщений между блогами | ALLOW_POST_MOVE | [Y|N] При отмеченной опции будет разрешен перенос сообщений между блогами. Со включенной опцией вы сможете в режиме редактирования своего сообщения выбрать другой/другие блоги, где ваше сообщение будет также показано. Например, страница блога какой-либо группы или другого пользователя. Данное поле доступно для шаблона .default. При отмеченной опции необходимо определить значение шаблонов путей к различным страницам блога соц. сети. Поля описаны ниже.
Шаблон пути к странице сообщения блога пользователя в соц. сети | PATH_TO_USER_POST | Указывается шаблон пути к странице сообщения блога. Например, /company/personal/user/#user_id#/blog/#post_id#/, где /company/personal/ - берется из настроек компонента Социальная сеть - пользователь (bitrix:socialnetwork_user), поле Каталог ЧПУ (относительно корня сайта), user/#user_id#/blog/#post_id#/ - там же, поле Страница сообщения блога пользователя.
Шаблон пути к редактированию сообщения блога пользователя в соц. сети | PATH_TO_USER_POST_EDIT | Указывается шаблон пути к редактированию сообщения блога пользователя в соц. сети. Например, /company/personal/user/#user_id#/blog/edit/#post_id#/, где /company/personal/ - берется из настроек компонента Социальная сеть - пользователь (bitrix:socialnetwork_user), поле Каталог ЧПУ (относительно корня сайта), user/#user_id#/blog/edit/#post_id#/ - там же, поле Страница редактирования сообщения блога пользователя.
Шаблон пути к черновикам блога пользователя в соц. сети | PATH_TO_USER_DRAFT | Указывается шаблон пути к черновикам блога пользователя в соц. сети. Например, /company/personal/user/#user_id#/blog/draft/, где /company/personal/ - берется из настроек компонента Социальная сеть - пользователь (bitrix:socialnetwork_user), поле Каталог ЧПУ (относительно корня сайта), user/#user_id#/blog/draft/ - там же, поле Страница черновиков блога пользователя.
Шаблон пути к блогу пользователя в соц. сети | PATH_TO_USER_BLOG | Указывается шаблон пути к блогу пользователя в соц. сети. Например, /company/personal/user/#user_id#/blog/, где /company/personal/ - берется из настроек компонента Социальная сеть - пользователь (bitrix:socialnetwork_user), поле Каталог ЧПУ (относительно корня сайта), user/#user_id#/blog/ - там же, поле Страница блога пользователя.
Шаблон пути к странице сообщения блога группы в соц. сети | PATH_TO_GROUP_POST | Указывается шаблон пути к странице сообщения блога группы в соц. сети. Например, /workgroups/group/#group_id#/blog/#post_id#/, где /workgroups/ - берется из настроек компонента Социальная сеть - группы (bitrix:socialnetwork_group), поле Каталог ЧПУ (относительно корня сайта), group/#group_id#/blog/#post_id#/ - там же, поле Страница сообщения блога группы.
Шаблон пути к редактированию сообщения блога группы в соц. сети | PATH_TO_GROUP_POST_EDIT | Указывается шаблон пути к редактированию сообщения блога группы в соц. сети. Например, /workgroups/group/#group_id#/blog/edit/#post_id#/, где /workgroups/ - берется из настроек компонента Социальная сеть - группы (bitrix:socialnetwork_group), поле Каталог ЧПУ (относительно корня сайта), group/#group_id#/blog/edit/#post_id#/ - там же, поле Страница редактирования сообщения блога группы.
Шаблон пути к черновикам блога группы в соц. сети | PATH_TO_GROUP_DRAFT | Указывается шаблон пути к черновикам блога группы в соц. сети. Например, /workgroups/group/#group_id#/blog/draft/, где /workgroups/ - берется из настроек компонента Социальная сеть - группы (bitrix:socialnetwork_group), поле Каталог ЧПУ (относительно корня сайта), group/#group_id#/blog/draft/ - там же, поле Страница черновиков блога группы.
Шаблон пути к блогу группы в соц. сети | PATH_TO_GROUP_BLOG | Указывается шаблон пути к блогу группы в соц. сети. Например, /workgroups/group/#group_id#/blog/, где /workgroups/ - берется из настроек компонента Социальная сеть - группы (bitrix:socialnetwork_group), поле Каталог ЧПУ (относительно корня сайта), group/#group_id#/blog/ - там же, поле Страница блога группы.
Настройки комментариев
Количество комментариев к сообщению на странице | COMMENTS_COUNT | Указывается число комментариев к сообщению, выводимых на одной странице. Остальные комментарии будут выведены с помощью постраничной навигации.
Выводить комментарии плоским списком | COMMENTS_LIST_VIEW | При установке опции для вывода комментариев используется простой компонент blog.post.comment.list.
Не использовать тему для комментариев | NOT_USE_COMMENT_TITLE | [Y|N] При отмеченной опции не будет использоваться Тема для комментариев сообщения блога.
Использовать AJAX для постраничной навигации в комментариях AJAX_PAGINATION [Y|N] При отмеченной опции будут обработаны и возвращены в массиве arResult только комментарии для текущей страницы.

Внимание! при включении параметра может потребоваться внесение изменений в кастомный (не системый) шаблон.

Разрешить изменять размер визуального редактора в комментариях | COMMENT_EDITOR_RESIZABLE | [Y|N] При отмеченной опции будет доступна возможность регулировать размер визуального редактора при создании комментариев.
Высота визуального редактора по умолчанию (пикселей) в комментариях | COMMENT_EDITOR_DEFAULT_HEIGHT | Начальное значение высоты визуального редактора при написании комментария (пикселей).
По умолчанию показывать невизуальный режим редактора в комментариях | COMMENT_EDITOR_CODE_DEFAULT | [Y|N] При отмеченной опции визуальный режим редактора не будет использоваться по умолчанию при создании комментариев.
Разрешить вставку видео в комментарии | COMMENT_ALLOW_VIDEO | [Y|N] При отмеченной опции появится возможность вставки видеороликов в комментарий.
Разрешить загрузку изображений в комментариях COMMENT_ALLOW_IMAGE_UPLOAD Указывается, кому разрешено использовать в комментариях изображения (по умолчанию - Никому)
  • Всем;
  • Зарегистрированным пользователям;
  • Никому.
Показывать администраторам ссылку на все комментарии пользователя

SHOW_SPAM

[Y|N] При отмеченной опции администратор будет видеть ссылку на страницу со всеми комментариями данного пользователя.
Запретить вставку ссылок в комментариях

NO_URL_IN_COMMENTS

Указывается, кому нельзя вставлять ссылки в комментарии (по умолчанию - Никому)

  • Никому;
  • Анонимным пользователям;
  • Всем.
Минимальный авторитет, с которым пользователи могут вставлять ссылки в комментарии | NO_URL_IN_COMMENTS_AUTHORITY | Минимальное значение авторитета, при котором появляется возможность вставки ссылок в комментарии.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:blog",
    "",
    Array(
        "THEME" => "blue",
        "GROUP_ID" => array("1"),
        "SHOW_NAVIGATION" => "Y",
        "USER_PROPERTY_NAME" => "",
        "PERIOD_NEW_TAGS" => "",
        "PERIOD" => "",
        "COLOR_TYPE" => "Y",
        "WIDTH" => "100%",
        "SEO_USER" => "Y",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "USE_SHARE" => "Y",
        "SHARE_HIDE" => "Y",
        "SHARE_TEMPLATE" => "",
        "SHARE_HANDLERS" => array("delicious", "lj", "twitter"),
        "SHARE_SHORTEN_URL_LOGIN" => "",
        "SHARE_SHORTEN_URL_KEY" => "",
        "PATH_TO_SONET_USER_PROFILE" => "/club/user/#user_id#/",
        "PATH_TO_MESSAGES_CHAT" => "/club/messages/chat/#user_id#/",
        "ALLOW_POST_MOVE" => "Y",
        "PATH_TO_USER_POST" => "",
        "PATH_TO_USER_POST_EDIT" => "",
        "PATH_TO_USER_DRAFT" => "",
        "PATH_TO_USER_BLOG" => "",
        "PATH_TO_GROUP_POST" => "",
        "PATH_TO_GROUP_POST_EDIT" => "",
        "PATH_TO_GROUP_DRAFT" => "",
        "PATH_TO_GROUP_BLOG" => "",
        "SEF_MODE" => "Y",
        "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SET_TITLE" => "Y",
        "CACHE_TIME_LONG" => "604800",
        "SET_NAV_CHAIN" => "Y",
                "SEO_USE" => "N",
        "MESSAGE_COUNT" => "25",
        "PERIOD_DAYS" => "30",
        "MESSAGE_COUNT_MAIN" => "6",
        "BLOG_COUNT_MAIN" => "6",
        "COMMENTS_COUNT" => "25",
        "MESSAGE_LENGTH" => "100",
        "BLOG_COUNT" => "20",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "NAV_TEMPLATE" => "",
        "USER_PROPERTY" => array(),
        "BLOG_PROPERTY" => array(),
        "BLOG_PROPERTY_LIST" => array(),
        "POST_PROPERTY" => array(),
        "POST_PROPERTY_LIST" => array(),
        "COMMENT_PROPERTY" => array(),
        "USE_ASC_PAGING" => "N",
        "NOT_USE_COMMENT_TITLE" => "Y",
        "SMILES_COUNT" => "4",
        "IMAGE_MAX_WIDTH" => "800",
        "IMAGE_MAX_HEIGHT" => "800",
        "EDITOR_RESIZABLE" => "Y",
        "EDITOR_DEFAULT_HEIGHT" => "300",
        "EDITOR_CODE_DEFAULT" => "N",
        "AJAX_POST" => "Y",
        "COMMENT_EDITOR_RESIZABLE" => "Y",
        "COMMENT_EDITOR_DEFAULT_HEIGHT" => "200",
        "COMMENT_EDITOR_CODE_DEFAULT" => "Y",
        "COMMENT_ALLOW_VIDEO" => "Y",
        "COMMENT_ALLOW_IMAGE_UPLOAD" => "A",
        "SHOW_SPAM" => "Y",
        "NO_URL_IN_COMMENTS_AUTHORITY" => "",
        "ALLOW_POST_CODE" => "Y",
        "USE_GOOGLE_CODE" => "Y",
        "SEF_FOLDER" => "/e-store/xml_catalog/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "group" => "group/#group_id#/",
            "blog" => "#blog#/",
            "user" => "user/#user_id#/",
            "user_friends" => "friends/#user_id#/",
            "search" => "search.php",
            "user_settings" => "#blog#/user_settings.php",
            "user_settings_edit" => "#blog#/user_settings_edit.php?id=#user_id#",
            "group_edit" => "#blog#/group_edit.php",
            "blog_edit" => "#blog#/blog_edit.php",
            "category_edit" => "#blog#/category_edit.php",
            "post_edit" => "#blog#/post_edit.php?id=#post_id#",
            "draft" => "#blog#/draft.php",
            "moderation" => "#blog#/moderation.php",
            "trackback" => POST_FORM_ACTION_URI.'&blog=#blog#&id=#post_id#&page=trackback',
            "post" => "#blog#/#post_id#/",
            "post_rss" => "#blog#/rss/#type#/#post_id#",
            "rss" => "#blog#/rss/#type#",
            "rss_all" => "rss/#type#/#group_id#"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "group" => Array(),
            "blog" => Array(),
            "user" => Array(),
            "user_friends" => Array(),
            "search" => Array(),
            "user_settings" => Array(),
            "user_settings_edit" => Array(
                "user_id" => "id"
            ),
            "group_edit" => Array(),
            "blog_edit" => Array(),
            "category_edit" => Array(),
            "post_edit" => Array(
                "post_id" => "id"
            ),
            "draft" => Array(),
            "moderation" => Array(),
            "trackback" => Array(
                "blog" => "blog",
                "post_id" => "id"
            ),
            "post" => Array(),
            "post_rss" => Array(),
            "rss" => Array(),
            "rss_all" => Array(),
        )
    )
);?>


Меню блогов

Описание blog.menu

Компонент выводит меню блогов. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Меню блогов.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Путь блога | BLOG_UTL | Поле содержит код, в котором передается идентификатор блога.
Шаблоны ссылок
Шаблон пути к главной странице блога | PATH_TO_BLOG | Указывается путь к главной странице конкретного блога.
Шаблон пути к главной странице | PATH_TO_BLOG_INDEX | Указывается путь к главной странице.
Шаблон пути к недописанным сообщениям | PATH_TO_DRAFT | Указывается путь к недописанным сообщениям.
Шаблон пути к странице редактирования сообщения | PATH_TO_POST_EDIT | Указывается путь к странице редактирования сообщения блога.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице пользователя блога.
Шаблон пути к странице сообщений друзей пользователя | PATH_TO_USER_FRIENDS | Указывается путь к странице сообщений друзей пользователя.
Шаблон пути к настройкам доступа пользователей | PATH_TO_USER_SETTINGS | Указывается путь к странице редактирования списка друзей пользователя.
Шаблон пути к странице настройки групп пользователей | PATH_TO_GROUP_EDIT | Указывается путь к странице настройки групп пользователей блога.
Шаблон пути к настройкам блога | PATH_TO_BLOG_EDIT | Указывается путь к странице редактирования настроек блога.
Шаблон пути к настройкам тегов сообщений | PATH_TO_CATEGORY_EDIT | Указывается путь к странице настроек категорий сообщений блога.
Дополнительные настройки
Добавлять пункт в цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт с названием блога.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Задается имя переменной, которой передается ID блога.
Имя переменной для идентификатора сообщения | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.
Имя переменной для идентификатора пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.menu","",Array(
        "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
        "PATH_TO_BLOG_INDEX" => "blog.php",
        "PATH_TO_DRAFT" => "blog_b_draft.php?page=draft&blog=#blog#",
        "PATH_TO_POST_EDIT" => "blog_p_edit.php?page=post_edit&blog=#blog#&post_id=#post_id#",
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "PATH_TO_USER_FRIENDS" => "blog_friends.php?page=user_friend&user_id=#user_id#",
        "PATH_TO_USER_SETTINGS" => "blog_user_set.php?page=user_settings&blog=#blog#",
        "PATH_TO_GROUP_EDIT" => "blog_user_gr.php?page=group_edit&blog=#blog#",
        "PATH_TO_BLOG_EDIT" => "blog_b_edit.php?page=blog_edit&blog=#blog#",
        "PATH_TO_CATEGORY_EDIT" => "blog_category.php?page=category_edit&blog=#blog#",
        "BLOG_VAR" => "blog",
        "POST_VAR" => "post_id",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "BLOG_URL" => $blog,
        "SET_NAV_CHAIN" => "Y"
    ),
);?>


Комментируемые сообщения

Описание blog.commented_posts

Компонент выводит наиболее комментируемые сообщения блогов за заданный период. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Комментируемые сообщения.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Группа блогов для отображения | GROUP_ID | Указывается группа блогов, наиболее комментируемые сообщения которой будут отображены. Если не указано, то выборка производится по всем группам блогов. Выбрав пункт (другое)->, можно указать свою группу блогов.
Адрес блога для отображения | BLOG_URL | Указывается адрес блога, наиболее комментируемые сообщения которого будут отображены. Если не указано, то выборка производится по всем блогам.
Внешний вид
Количество выводимых сообщений | MESSAGE_COUNT | Указывается число комментируемых сообщений блогов, отображаемых на одной странице. Все сообщения блогов будут выведены с помощью постраничной навигации.
Количество дней для выбора популярных сообщений | PERIOD_DAYS | Указывается количество дней для выбора комментируемых сообщений, которые будут отображены.
Длина выводимого текста сообщения | MESSAGE_LENGTH | Задается длина выводимого текста сообщения.
Ширина картинки предпросмотра | PREVIEW_WIDTH | Указывается ширина картинки предпросмотра.
Высота картинки предпросмотра | PREVIEW_HEIGHT | Указывается ширина картинки предпросмотра.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога.
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Указывается путь к странице просмотра сообщения блога.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице профиля пользователя блога.
Шаблон пути к странице с сообщением блога группы | PATH_TO_GROUP_BLOG_POST | Указывается путь к странице с сообщением блога группы.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:blog.commented_posts","",Array(
        "SEO_USER" => "Y",
        "MESSAGE_COUNT" => "6",
        "PERIOD_DAYS" => "30",
        "MESSAGE_LENGTH" => "100",
        "PREVIEW_WIDTH" => "100",
        "PREVIEW_HEIGHT" => "100",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
        "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog&post_id=#post_id#",
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP_BLOG_POST" => "",
        "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
        "BLOG_VAR" => "blog",
        "POST_VAR" => "post_id",
        "USER_VAR" => "user_id",
        "PAGE_VAR" => "page",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "GROUP_ID" => "1",
        "BLOG_URL" => ""
    ),
);?>


Новые комментарии

Описание blog.new_comments

Компонент выводит последние комментарии к сообщениям блогов. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Новые комментарии.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Группа блогов для отображения | GROUP_ID | Указывается группа блогов, последние комментарии к сообщениям блогов которой будут отображены. Если не указано, то выборка производится по всем группам блогов.
Адрес блога для отображения | BLOG_URL | Указывается адрес блога, последние комментарии к сообщениям которого будут отображены. Если не указано, то выборка производится по всем блогам.
Внешний вид
Количество результатов, выводимых на страницу | COMMENT_COUNT | Указывается число последних комментариев к сообщениям блогов, отображаемых на одной странице. Все комментарии будут выведены с помощью постраничной навигации.
Длина выводимого текста сообщения | MESSAGE_LENGTH | Задается длина выводимого текста сообщения.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога.
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Указывается путь к странице просмотра сообщения блога.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице профиля пользователя блога.
Шаблон пути к странице с сообщением блога группы | PATH_TO_GROUP_BLOG_POST | Указывается путь к странице с сообщением блога группы.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.new_comments","",Array(
        "SEO_USER" => "Y",
        "COMMENT_COUNT" => "6",
        "MESSAGE_LENGTH" => "100",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
        "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog&post_id=#post_id#",
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP_BLOG_POST" => "",
        "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
        "BLOG_VAR" => "blog",
        "POST_VAR" => "post_id",
        "USER_VAR" => "user_id",
        "PAGE_VAR" => "page",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "GROUP_ID" => "1",
        "BLOG_URL" => ""
    ),
);?>


Новые сообщения

Компонент выводит последние сообщения блогов текущего сайта. Компонент стандартный и входит в дистрибутив модуля.

Описание blog.new_posts

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Новые сообщения.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Группа блогов для отображения | GROUP_ID | Указывается группа блогов, новые сообщения блогов которой будут отображены. Если не указано, то выборка производится по всем группам блогов. Выбрав пункт (другое)->, можно указать свою группу блогов.
Адрес блога для отображения | BLOG_URL | Указывается адрес блога, новые сообщения которого будут отображены. Если не указано, то выборка производится по всем блогам.
Внешний вид
Количество результатов, выводимых на страницу | MESSAGE_COUNT | Указывается число сообщений блогов, отображаемых на одной странице. Все последние сообщения блогов будут выведены с помощью постраничной навигации.
Длина выводимого текста сообщения | MESSAGE_LENGTH | Задается длина выводимого текста сообщения.
Ширина картинки предпросмотра | PREVIEW_WIDTH | Указывается ширина картинки предпросмотра.
Высота картинки предпросмотра | PREVIEW_HEIGHT | Указывается высота картинки предпросмотра.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога.
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Указывается путь к странице просмотра сообщения блога.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице профиля пользователя блога.
Шаблон пути к странице с сообщением блога группы | PATH_TO_GROUP_BLOG_POST | Указывается путь к странице с сообщением блога группы.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Используется в рамках социальной сети | USE_SOCNET | [Y|N] При отмеченной опции выбираются сообщения только из блогов социальной сети.
Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.new_posts","",Array(
        "SEO_USER" => "Y",
        "MESSAGE_COUNT" => "6",
        "MESSAGE_LENGTH" => "100",
        "PREVIEW_WIDTH" => "100",
        "PREVIEW_HEIGHT" => "100",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
        "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog&post_id=#post_id#",
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP_BLOG_POST" => "",
        "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
        "BLOG_VAR" => "blog",
        "POST_VAR" => "post_id",
        "USER_VAR" => "user_id",
        "PAGE_VAR" => "page",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "GROUP_ID" => "",
        "BLOG_URL" => ""
    )
);?>


Популярные сообщения

Описание blog.popular_posts

Компонент выводит наиболее просматриваемые сообщения блогов за заданный период. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Популярные сообщения.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Группа блогов для отображения | GROUP_ID | Указывается группа блогов, популярные сообщения блогов которой будут отображены. Если не указано, то выборка производится по всем группам блогов.
Адрес блога для отображения | BLOG_URL | Указывается адрес блога, популярные сообщения которого будут отображены. Если не указано, то выборка производится по всем блогам.
Внешний вид
Сортировать по SORT_BY1 Выбирается способ сортировки сообщений блога:
  • количество просмотров;
  • рейтинг сообщения;
  • количество голосов.
Количество результатов, выводимых на страницу | MESSAGE_COUNT | Указывается число сообщений блогов, отображаемых на одной странице. Все последние сообщения блогов будут выведены с помощью постраничной навигации.
Количество дней для выбора популярных сообщений | PERIOD_DAYS | Указывается количество дней для выбора популярных сообщений блогов, которые будут отображены.
Длина выводимого текста сообщения | MESSAGE_LENGTH | Задается длина выводимого текста сообщения.
Ширина картинки предпросмотра | PREVIEW_WIDTH | Указывается ширина картинки предпросмотра.
Высота картинки предпросмотра | PREVIEW_HEIGHT | Указывается ширина картинки предпросмотра.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога.
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Указывается путь к странице просмотра сообщения блога.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице профиля пользователя блога.
Шаблон пути к странице с сообщением блога группы | PATH_TO_GROUP_BLOG_POST | Указывается путь к странице с сообщением блога группы.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:blog.popular_posts",
    "",
    Array(
        "SEO_USER" => "Y",
        "SORT_BY1" => "RATING_TOTAL_VALUE",
        "MESSAGE_COUNT" => "6",
        "PERIOD_DAYS" => "30",
        "MESSAGE_LENGTH" => "100",
        "PREVIEW_WIDTH" => "100",
        "PREVIEW_HEIGHT" => "100",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PATH_TO_BLOG" => "",
        "PATH_TO_POST" => "",
        "PATH_TO_USER" => "",
        "PATH_TO_GROUP_BLOG_POST" => "",
        "PATH_TO_SMILE" => "",
        "BLOG_VAR" => "",
        "POST_VAR" => "",
        "USER_VAR" => "",
        "PAGE_VAR" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "GROUP_ID" => "",
        "BLOG_URL" => ""
    )
);?>


Последние сообщения всех блогов

Описание blog.new_posts.lis

Компонент выводит последние сообщения блогов с постраничной навигацией. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Последние сообщения всех блогов.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Группа блогов для отображения | GROUP_ID | Указывается группа блогов, последние сообщения блогов которой будут отображены. Если не указано, то выборка производится по всем группам блогов. Выбрав пункт (другое)->, можно указать свою группу блогов.
Адрес блога для отображения | BLOG_URL | Указывается адрес блога, последние сообщения которого будут отображены. Если не указано, то выборка производится по всем блогам.
Внешний вид
Количество результатов, выводимых на страницу | MESSAGE_PER_PAGE | Указывается число последних сообщений блогов, отображаемых на одной странице. Все последние сообщения блогов будут выведены с помощью постраничной навигации.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Указывается максимально допустимая ширина картинки, которую можно вставить в сообщение (в пикселах).
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Указывается максимально допустимая высота картинки, которую можно вставить в сообщение (в пикселах)..
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога. Например, blog_blog.php?page=blog&blog=#blog#.
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Указывается путь к странице просмотра сообщения блога. Например, blog_post.php?page=post&blog=#blog#&post_id=#post_id#.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице профиля пользователя блога. Например, blog_user.php?page=user&user_id=#user_id#.
Шаблон пути к странице с сообщением блога группы | PATH_TO_GROUP_BLOG_POST | Указывается путь к странице с сообщением блога группы.
Шаблон пути к странице блога c фильтром по тегу | PATH_TO_BLOG_CATEGORY | Указывается путь к странице блога с фильтром по тегу.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Последние сообщения блогов.
Показывать доп. свойства сообщения в блоге | POST_PROPERTY_LIST | Указываются пользовательские свойства сообщения, которые необходимо дополнительно отобразить в блоге социальной сети.
Включить рейтинг SHOW_RATING Указывается, будет ли будет использован функционал рейтингов:
  • да;
  • нет;
  • по умолчанию - значение берется из настроек рейтингов.

Примечание:

С версии 17.6.0 добавлена поддержка рейтингов с реакциями.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопок рейтинга:
  • по умолчанию;
  • Мне нравится (текстовый);
  • Мне нравится (графический);
  • Нравится / Не нравится (текстовый);
  • Нравится / Не нравится (графический).

Значение по умолчанию берется из настроек рейтингов.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:blog.new_posts.list",
    "",
    Array(
        "SEO_USER" => "Y",
        "MESSAGE_PER_PAGE" => "6",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PATH_TO_BLOG" => "",
        "PATH_TO_POST" => "",
        "PATH_TO_USER" => "",
        "PATH_TO_GROUP_BLOG_POST" => "",
        "PATH_TO_BLOG_CATEGORY" => "",
        "PATH_TO_SMILE" => "",
        "BLOG_VAR" => "",
        "POST_VAR" => "",
        "USER_VAR" => "",
        "PAGE_VAR" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "GROUP_ID" => "",
        "BLOG_URL" => "",
        "NAV_TEMPLATE" => "",
        "SET_TITLE" => "Y",
        "POST_PROPERTY_LIST" => array(),
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "IMAGE_MAX_WIDTH" => "600",
        "IMAGE_MAX_HEIGHT" => "600"
    )
);?>


Новые блоги

Описание blog.new_blogs

Компонент выводит новые блоги. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Новые блоги.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Группа блогов для отображения | GROUP_ID | Указывается группа блогов, новые блоги которой будут отображения. Если не указано, то выборка производится по всем группам блогов.
Внешний вид
Количество блогов | BLOG_COUNT | Указывается количество блогов, которое будут выведены на странице.
Показывать описание блога | SHOW_DESCRIPTION | [Y|N] При выборе значения Да (Y) будет выведено описание блога.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога.
Шаблон пути к странице с информацией о пользователе | PATH_TO_USER | Указывается путь к странице профиля пользователя блога.
Шаблон пути к странице с информацией о группе | PATH_TO_GROUP | Указывается путь к странице с информацией о группе блогов.
Шаблон пути к странице блога группы | PATH_TO_GROUP_BLOG | Указывается путь к странице блога группы.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Первое поле для сортировки SORT_BY1 Указывается поле, по которому будет происходить первая сортировка блогов:
  • DATE_CREATE - по дате создания;
  • ID - по идентификатору;
  • NAME – по названию;
  • LAST_POST_DATE - по дате последнего сообщения.
Выбрав пункт (другое)->, можно сформировать свой вариант первой сортировки блогов.
Направление сортировки SORT_ORDER1 Задается направление для первой сортировки:
  • ASC – по возрастанию;
  • DECS – по убыванию.
Второе поле для сортировки SORT_BY2 Указывается поле, по которому будет происходить вторая сортировка блогов:
  • DATE_CREATE - по дате создания;
  • ID - по идентификатору;
  • NAME – по названию;
  • LAST_POST_DATE - по дате последнего сообщения.
Выбрав пункт (другое)->, можно сформировать свой вариант второй сортировки блогов.
Направление сортировки SORT_ORDER2 Задается направление для второй сортировки:
  • ASC – по возрастанию;
  • DECS – по убыванию.
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.
Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.new_blogs","",Array(
        "SEO_USER" => "Y",
        "BLOG_COUNT" => "6",
        "SHOW_DESCRIPTION" => "Y",
        "SORT_BY1" => "DATE_CREATE",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "ID",
        "SORT_ORDER2" => "DESC",
        "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "blog_g_blog.php?page=group&group_id=#group_id#",
        "PATH_TO_GROUP_BLOG" => "",
        "BLOG_VAR" => "blog",
        "USER_VAR" => "user_id",
        "PAGE_VAR" => "page",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "GROUP_ID" => "1"
    )
);?>


Популярные блоги

Описание blog.popular_blogs

Компонент выводит популярные блоги. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Популярные блоги.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Группа блогов для отображения | GROUP_ID | Указывается группа блогов, популярные блоги которой будут отображения. Если не указано, то выборка производится по всем группам блогов. Выбрав пункт (другое)->, можно указать свою группу блогов.
Внешний вид
Количество блогов | BLOG_COUNT | Указывается блогов, которые будут выведены на странице.
Количество дней для выбора популярных сообщений блогов | PERIOD_DAYS | Указывается количество дней для выбора популярных сообщений блогов, которые будут выведены группы.
Показывать описание блога | SHOW_DESCRIPTION | [Y|N] При выборе значения Да (Y) будет выведено описание блога.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога.
Шаблон пути к странице с информацией о пользователе | PATH_TO_USER | Указывается путь к странице профиля пользователя блога.
Шаблон пути к странице с информацией о группе | PATH_TO_GROUP | Указывается путь к странице с информацией о группе блогов.
Шаблон пути к странице блога группы | PATH_TO_GROUP_BLOG | Указывается путь к странице блога группы.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Первое поле для сортировки SORT_BY1 Указывается поле, по которому будет происходить первая сортировка блогов:
  • DATE_CREATE - по дате создания;
  • ID - по идентификатору;
  • NAME – по названию;
  • LAST_POST_DATE - по дате последнего сообщения.
Направление сортировки SORT_ORDER1 Задается направление для первой сортировки:
  • ASC – по возрастанию;
  • DECS – по убыванию.
Второе поле для сортировки SORT_BY2 Указывается поле, по которому будет происходить вторая сортировка блогов:
  • DATE_CREATE - по дате создания;
  • ID - по идентификатору;
  • NAME – по названию;
  • LAST_POST_DATE - по дате последнего сообщения.
Направление сортировки SORT_ORDER2 Задается направление для второй сортировки:
  • ASC – по возрастанию;
  • DECS – по убыванию.
Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.popular_blogs","",Array(
        "SEO_USER" => "Y",
        "BLOG_COUNT" => "6",
        "PERIOD_DAYS" => "30",
        "SHOW_DESCRIPTION" => "Y",
        "SORT_BY1" => "NAME",
        "SORT_ORDER1" => "ASC",
        "SORT_BY2" => "ID",
        "SORT_ORDER2" => "ASC",
        "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "blog_g_blog.php?page=group&group_id=#group_id#",
        "PATH_TO_GROUP_BLOG" => "",
        "BLOG_VAR" => "blog",
        "USER_VAR" => "user_id",
        "PAGE_VAR" => "page",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "GROUP_ID" => "1"
    )
);?>


Группы блогов

Описание blog.groups

Компонент выводит непустые группы блогов. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Группы блогов.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Внешний вид
Количество выводимых групп | GROUPS_COUNT | Указывается число непустых групп, которые будут выведены на странице.
Количество столбцов | COLS_COUNT | Указывается количество столбцов, в которые будут выведены группы.
Шаблоны ссылок
Шаблон пути к странице группы блогов | PATH_TO_GROUP | Указывается путь к странице группы блогов.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Первое поле для сортировки SORT_BY1 Указывается поле, по которому будет происходить первая сортировка групп блогов:
  • ID - по идентификатору;
  • NAME – по названию.
Выбрав пункт (другое)->, можно сформировать свой вариант первой сортировки групп блогов.
Направление сортировки SORT_ORDER1 Задается направление для первой сортировки:
  • ASC – по возрастанию;
  • DECS – по убыванию.
Второе поле для сортировки SORT_BY2 Указывается поле, по которому будет происходить вторая сортировка групп блогов:
  • ID - по идентификатору;
  • NAME – по названию.
Выбрав пункт (другое)->, можно сформировать свой вариант второй сортировки групп блогов.
Направление сортировки SORT_ORDER2 Задается направление для второй сортировки:
  • ASC – по возрастанию;
  • DECS – по убыванию.
Имена переменных
Имя переменной для идентификатора группы блогов | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы блогов.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.groups","",Array(
        "GROUPS_COUNT" => "0",
        "COLS_COUNT" => "3",
        "SORT_BY1" => "NAME",
        "SORT_ORDER1" => "ASC",
        "SORT_BY2" => "ID",
        "SORT_ORDER2" => "ASC",
        "PATH_TO_GROUP" => "blog_g_blog.php?page=group&group_id=#group_id#",
        "GROUP_VAR" => "group_id",
        "PAGE_VAR" => "page",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400"
    ),
);?>


Поиск по блогам

Описание blog.search

Компонент выводит форму поиска и результаты поиска по блогам. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Поиск по блогам.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Внешний вид
Количество результатов, выводимых на страницу | PAGE_RESULT_COUNT | Указывается число результатов поиска, отображаемых на одной странице. Все результаты будут выведены с помощью постраничной навигации.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога.
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Указывается путь к странице просмотра сообщения блога.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице профиля пользователя блога.
Дополнительные настройки
Страница поиска | SEARCH_PAGE | Указывается путь к странице поиска.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Поиск по блогам.
Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.search","",Array(
        "SEO_USER" => "Y",
        "PAGE_RESULT_COUNT" => "25",
        "SEARCH_PAGE" => "blog_search.php",
        "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
        "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog&post_id=#post_id#",
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "BLOG_VAR" => "blog",
        "POST_VAR" => "post_id",
        "USER_VAR" => "user_id",
        "PAGE_VAR" => "page",
        "SET_TITLE" => "Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "NAV_TEMPLATE" => ""
    )
);?>


Лучшие сообщения блога

Описание blog.blog.favorite

Компонент выводит список лучших сообщения блога на основе отметок владельца блога (при создании сообщений владелец блога указывает индекс сортировки сообщения). Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Лучшие сообщения блога.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Путь блога | BLOG_URL | Указывается код, в котором передается идентификатор блога.
Внешний вид
Количество выводимых сообщений | MESSAGE_COUNT | Указывается число сообщений блогов, отображаемых на одной странице. Все сообщения будут выведены с помощью постраничной навигации.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Длина выводимого текста сообщения | MESSAGE_LENGTH | Задается длина выводимого текста сообщения.
Ширина картинки предпросмотра | PREVIEW_WIDTH | Указывается ширина картинки предпросмотра.
Высота картинки предпросмотра | PREVIEW_HEIGHT | Указывается ширина картинки предпросмотра.
Шаблоны ссылок
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Указывается путь к странице детального просмотра сообщения блога.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название блога.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.blog.favorite","",Array(
        "MESSAGE_COUNT" => "6",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog&post_id=#post_id#",
        "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
        "BLOG_VAR" => "blog",
        "POST_VAR" => "post_id",
        "PAGE_VAR" => "page",
        "BLOG_URL" => $blog,
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "7200",
        "SET_TITLE" => "Y",
        "MESSAGE_LENGTH" => "100",
        "PREVIEW_WIDTH" => "100",
        "PREVIEW_HEIGHT" => "100"
    )
);?>


Сообщения блога

Описание blog.blog

Компонент выводит сообщения блога с возможностью их фильтрации по категории и дате. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Сообщения блога.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Основные параметры
Год для фильтрации | YEAR | Указывается код, в котором передается год для фильтрации. По умолчанию поле содержит ={$year}.
Месяц для фильтрации | MONTH | Указывается код, в котором передается месяц фильтрации. По умолчанию поле содержит ={$month}.
День для фильтрации | DAY | Указывается код, в котором передается день для фильтрации. По умолчанию поле содержит ={$day}.
Идентификатор тега для фильтрации | CATEGORY_ID | Указывается код, в котором передается идентификатор тега для фильтрации. По умолчанию поле содержит ={$category}.
Источник данных
Путь блога | BLOG_URL | Указывается код, в котором передается идентификатор блога. По умолчанию поле содержит ={$blog}.
Имя массива со значениями фильтра для фильтрации сообщений | FILTER_NAME | Задается имя переменной, в которой передается массив параметров из фильтра. Служит для определения выходящих из фильтра элементов. Поле может быть оставлено пустым, тогда используется значение по умолчанию.
Внешний вид
Количество сообщений, выводимых на страницу | MESSAGE_COUNT | Указывается число сообщений блогов, отображаемых на одной странице. Все сообщения будут выведены с помощью постраничной навигации.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Указывается максимально допустимая ширина картинки, которую можно вставить в сообщение
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Указывается максимально допустимая высота картинки, которую можно вставить в сообщение
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога. Например, blog_blog.php?page=blog&blog=#blog#.
Шаблон пути к странице блога c фильтром по тегу | PATH_TO_BLOG_CATEGORY | Указывается путь к странице блога с фильтром по тегу. Например, blog_filter.php?page=blog&blog=#blog#&category=#category#.
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Указывается путь к странице детального просмотра сообщения блога. Например, blog_post.php?page=post&blog=#blog#&post_id=#post_id#.
Шаблон пути к странице редактирования сообщения блога | PATH_TO_POST_EDIT | Указывается путь к странице редактирования сообщения блога. Например, blog_p_edit.php?page=post_edit&blog=#blog#&post_id=#post_id#.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице профиля пользователя блога. Например, blog_user.php?page=user&user_id=#user_id#.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Время кеширования остальных страниц | CACHE_TIME_LONG | Указывается время кеширования страниц, начиная со второй.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Добавлять пункт в цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт с названием блога.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название блога.
Показывать доп. свойства сообщения в блоге | POST_PROPERTY_LIST | Указываются пользовательские свойства сообщения, которые необходимо дополнительно отобразить в блоге.
Включить рейтинг SHOW_RATING Указывается, будет ли будет использован функционал рейтингов:
  • да;
  • нет;
  • по умолчанию - значение берется из настроек рейтингов.

Примечание:

С версии 17.6.0 добавлена поддержка рейтингов с реакциями.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопок рейтинга:
  • по умолчанию;
  • Мне нравится (текстовый);
  • Мне нравится (графический);
  • Нравится / Не нравится (текстовый);
  • Нравится / Не нравится (графический).

    • Значение По умолчанию берется из настроек рейтингов.

Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, в которой передается идентификатор (ID) блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор (ID) сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор (ID) пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:blog.blog",
    "",
    Array(
        "SEO_USER" => "Y",
        "MESSAGE_COUNT" => "25",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PATH_TO_BLOG" => "",
        "PATH_TO_BLOG_CATEGORY" => "",
        "PATH_TO_POST" => "",
        "PATH_TO_POST_EDIT" => "",
        "PATH_TO_USER" => "",
        "PATH_TO_SMILE" => "",
        "BLOG_VAR" => "",
        "POST_VAR" => "",
        "USER_VAR" => "",
        "PAGE_VAR" => "",
        "BLOG_URL" => $blog,
        "YEAR" => $year,
        "MONTH" => $month,
        "DAY" => $day,
        "CATEGORY_ID" => $category,
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "7200",
        "CACHE_TIME_LONG" => "604600",
        "SET_NAV_CHAIN" => "Y",
        "SET_TITLE" => "Y",
        "FILTER_NAME" => "arFilter",
        "NAV_TEMPLATE" => "",
        "POST_PROPERTY_LIST" => array("UF_BLOG_POST_DOC"),
        "IMAGE_MAX_WIDTH" => "600",
        "IMAGE_MAX_HEIGHT" => "600"
    )
);?>


Информация о блоге

Описание blog.info

Компонент выводит информацию о блоге со списком тегов. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Информация о блоге.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор тега для фильтрации | CATEGORY_ID | Указывается код, в котором передается идентификатор категории для фильтрации.
Источник данных
Путь блога | BLOG_URL | Указывается код, в котором передается идентификатор блога.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога.
Шаблон пути к странице блога c фильтром по тегу | PATH_TO_BLOG_CATEGORY | Указывается путь к странице блога с фильтром по категории.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице профиля пользователя.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Какие свойства блога выводить | BLOG_PROPERTY_LIST | Указываются пользовательские свойства блога, которые необходимо дополнительно отобразить.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.
Дополнительно (данный список настроек доступен для шаблона .default)
Максимальный размер шрифта (px) | FONT_MAX | Указывается максимальный размер шрифта отображения тегов (в пикселах).
Минимальный размер шрифта (px) | FONT_MIN | Указывается минимальный размер шрифта отображения тегов (в пикселах).
Ширина облака тегов | WIDTH | Указывается ширина облака тегов (пример: "100%" или "100px", "100pt", "100in").

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:blog.info",
    ".default",
    Array(
        "FONT_MAX" => "50",
        "FONT_MIN" => "10",
        "WIDTH" => "100%",
        "PATH_TO_BLOG" => "",
        "PATH_TO_BLOG_CATEGORY" => "",
        "PATH_TO_USER" => "",
        "BLOG_VAR" => "",
        "USER_VAR" => "",
        "PAGE_VAR" => "",
        "BLOG_URL" => $blog,
        "CATEGORY_ID" => $category,
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "CACHE_NOTES" => "",
        "BLOG_PROPERTY_LIST" => array()
    )
);?>


Календарь

Описание blog.calendar

Компонент выводит календарь сообщений блога. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Календарь.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Основные параметры
Год для фильтрации | YEAR | Указывается код, в котором передается год для фильтрации.
Месяц для фильтрации | MONTH | Указывается код, в котором передается месяц фильтрации.
День для фильтрации | DAY | Указывается код, в котором передается день для фильтрации.
Источник данных
Путь блога | BLOG_URL | Указывается код, в котором передается идентификатор блога.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.calendar","",Array(
        "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
        "BLOG_VAR" => "blog",
        "PAGE_VAR" => "page",
        "BLOG_URL" => $blog,
        "YEAR" => $year,
        "MONTH" => $month,
        "DAY" => $day,
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400"
    )
);?>


Ссылки на RSS блога

Описание blog.rss.link

Компонент выводит ссылки на RSS. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Ссылки на RSS блога.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Основные параметры
Показывать ссылку на RSS .92 | RSS1 | [Y|N] При отмеченной опции будет показана ссылка на RSS .92.
Показывать ссылку на RSS 2.0 | RSS2 | [Y|N] При отмеченной опции будет показана ссылка на RSS 2.0.
Показывать ссылку на ATOM .3 | ATOM | [Y|N] При отмеченной опции будет показана ссылка на ATOM .3.
Показывать ссылки на RSS MODE Ссылки на RSS показывать для:
  • Блога (B);
  • Блогов сайта (S);
  • Блогов группы (G);
  • Комментариев к сообщению (С).
Источник данных
Путь блога | BLOG_URL | Указывается код, в котором передается идентификатор блога.
Идентификатор сообщения блога | POST_ID | Указывается код, в котором передается идентификатор сообщения блога.
Идентификатор группы блогов | GROUP_ID | Указывается код, в котором передается идентификатор группы блогов.
Шаблоны ссылок
Шаблон пути к странице RSS блога | PATH_TO_RSS | Указывается путь к странице RSS блога.
Шаблон пути к странице общего RSS блогов | PATH_TO_RSS_ALL | Указывается путь к странице общего RSS блога.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.
Имя переменной для идентификатора группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы блогов.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.rss.link","",Array(
        "PATH_TO_RSS" => "blog_rss.php?page=rss&blog=#blog#&type=#type#",
        "PATH_TO_RSS_ALL" => "blog_rss_all.php?page=rss_all&blog=#blog#&type=#type#",
        "BLOG_VAR" => "blog",
        "PAGE_VAR" => "page",
        "GROUP_VAR" => "group_id",
        "BLOG_URL" => $blog,
        "POST_ID" => $post_id,
        "GROUP_ID" => $group_id,
        "RSS1" => "Y",
        "RSS2" => "Y",
        "ATOM" => "Y",
        "MODE" => "S"
    )
);?>


Сообщение детально

Описание blog.post

Компонент выводит сообщение блога подробно. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Сообщение детально.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Путь блога | BLOG_URL | Указывается код, в котором передается идентификатор блога. По умолчанию поле содержит ={$blog}.
Идентификатор сообщения | ID | Указывается код, в котором передается идентификатор сообщения блога. По умолчанию поле содержит ={$id}.
Внешний вид
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Максимально допустимая ширина вставляемой в сообщение картинки.
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Максимально допустимая высота вставляемой в сообщение картинки.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается шаблон пути к главной странице блога. Например, blog_blog.php?page=blog&blog=#blog#.
Шаблон пути к странице блога c фильтром по тегу | PATH_TO_BLOG_CATEGORY | Указывается шаблон пути к странице блога с фильтром по категории. Например, blog_filter.php?page=blog&blog=#blog#&category=#category#.
Шаблон пути к странице редактирования сообщения блога | PATH_TO_POST_EDIT | Указывается шаблон пути к странице редактирования сообщения блога. Например, blog_p_edit.php?page=post_edit&blog=#blog#&post_id=#post_id#.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается шаблон пути к странице профиля пользователя блога. Например, blog_user.php?page=user&user_id=#user_id#.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Добавлять пункт в цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено название блога, к которому относится текущее сообщение.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название текущего сообщения.
Использование SEO SEO_USE Выбирается метод использования SEO для детальной страницы сообщения:
  • не использовать;
  • отдельные поля для описания;
  • поля по умолчанию.
Показывать доп. свойства сообщения | POST_PROPERTY | Указываются пользовательские свойства сообщения, которые необходимо дополнительно отобразить при детальном просмотре сообщения.
Включить рейтинг SHOW_RATING Указывается, будет ли будет использован функционал рейтингов:
  • да;
  • нет;
  • по умолчанию - значение берется из настроек рейтингов.

Примечание:

С версии 17.6.0 добавлена поддержка рейтингов с реакциями.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопок рейтинга:
  • по умолчанию;
  • Мне нравится (текстовый);
  • Мне нравится (графический);
  • Нравится / Не нравится (текстовый);
  • Нравится / Не нравится (графический).

    • Значение По умолчанию берется из настроек рейтингов.

Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:blog.post",
    "",
    Array(
        "SEO_USER" => "Y",
        "BLOG_URL" => $blog,
        "PATH_TO_BLOG" => "",
        "PATH_TO_BLOG_CATEGORY" => "",
        "PATH_TO_POST_EDIT" => "",
        "PATH_TO_USER" => "",
        "PATH_TO_SMILE" => "",
        "BLOG_VAR" => "",
        "POST_VAR" => "",
        "USER_VAR" => "",
        "PAGE_VAR" => "",
        "ID" => $id,
        "SET_NAV_CHAIN" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "POST_PROPERTY" => array(),
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "IMAGE_MAX_WIDTH" => "600",
        "IMAGE_MAX_HEIGHT" => "600"
    )
);?>


Trackback'и сообщения

Описание blog.post.trackback

Компонент выводит Trackback-адрес и Trackback'и к сообщению блога. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Trackback'и сообщения.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Путь блога | BLOG_URL | Указывается код, в котором передается идентификатор блога.
Идентификатор сообщения | ID | Указывается код, в котором передается идентификатор сообщения блога.
Внешний вид
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Шаблоны ссылок
Шаблон пути к trackback'у сообщения | PATH_TO_TRACKBACK | Указывается полный путь к главной странице trackback'а сообщения блога.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.post.trackback","",Array(
        "BLOG_URL" => $blog,
        "PATH_TO_TRACKBACK" => "/blog/blog_p_track_get.php?page=trackback&blog=#blog#&post_id=#post_id#",
        "BLOG_VAR" => "blog",
        "POST_VAR" => "post_id",
        "PAGE_VAR" => "page",
        "ID" => $id,
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s"
    ),
);?>


Комментарии к сообщению

Описание blog.post.comment

Компонент выводит комментарии к сообщению блога с возможностью добавления. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Комментарии к сообщению.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор сообщения | ID | Указывается код, в котором передается идентификатор сообщения блога.
Адрес блога | BLOG_URL | Указывается код, в котором передается идентификатор блога.
Внешний вид
Количество комментариев на странице | COMMENTS_COUNT | Указывается число комментариев, отображаемых на одной странице. Все комментарии будут выведены с помощью постраничной навигации.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Количество постоянно отображаемых смайлов | SMILES_COUNT | Указывается количество постоянно отображаемых смайлов в форме добавления комментария. Значение по умолчанию равно 4.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Максимально допустимая ширина добавляемого в комментарий изображения (в пикселях).
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Максимально допустимая высота добавляемого в комментарий изображения (в пикселях).
Разрешить изменять размер визуального редактора | EDITOR_RESIZABLE | [Y|N] При отмеченной опции будет возможность менять размеры окна визуального редактора.
Высота визуального редактора по умолчанию (в пикселях) | EDITOR_DEFAULT_HEIGHT | Значение высоты визуального редактора при загрузке (в пикселях).
По умолчанию показывать невизуальный режим редактора | EDITOR_CODE_DEFAULT | [Y|N] При отмеченной опции визуальный режим редактора не будет использоваться по умолчанию при создании сообщений.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога. Например: blog_blog.php?page=blog&blog=#blog#.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице профиля пользователя блога. Например: blog_user.php?page=user&user_id=#user_id#.
Согласие пользователя
Запрашивать согласие | USER_CONSENT | [Y|N] Установленный флажок включает механизм согласия пользователя.
Соглашение | USER_CONSENT_ID | Задается текст соглашения, которое отображается пользователю при заказе.
Галка по умолчанию проставлена | USER_CONSENT_IS_CHECKED | Установка галочки автомаитчески устанавливает галочку в чекбоксе согласия пользователя. То есть согласие применяется одновременно с нажатием кнопки Оформить заказ.
Загружать текст сразу | USER_CONSENT_IS_LOADED | Текст соглашения будет выводиться сразу. Если флажок не установлен, для просмотра текст нужно будет кликнуть по кнопке согласия.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Использовать AJAX для комментариев | AJAX_POST | [Y|N] При отмеченной опции технология AJAX будет применяться при отправке комментариев.
Упрощенный режим (без предварительного создания сообщения) | SIMPLE_COMMENT | [Y|N] При отмеченной опции будет использоваться упрощенный режим создания комментариев: комментарии можно создавать без сообщения (также используется в модуле Фотогалерея 2.0).
Использовать прямую постраничную навигацию | USE_ASC_PAGING | [Y|N] При отмеченной опции список комментариев будет выводиться постранично с прямой навигацией.
Включить рейтинг SHOW_RATING Указывается, будет ли будет использован функционал рейтингов:
  • да;
  • нет;
  • по умолчанию - значение берется из настроек рейтингов.

Примечание:

С версии 17.6.0 добавлена поддержка рейтингов с реакциями.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопок рейтинга:
  • по умолчанию;
  • Мне нравится (текстовый);
  • Мне нравится (графический);
  • Нравится / Не нравится (текстовый);
  • Нравится / Не нравится (графический).

    • Значение По умолчанию берется из настроек рейтингов.

Разрешить вставку видео | ALLOW_VIDEO | [Y|N] При отмеченной опции добавится возможность вставки видороликов в комментарии.
Показывать администраторам ссылку на все комментарии пользователя | SHOW_SPAM | [Y|N] При отмеченной опции администраторам будет доступна ссылка, по которой можно просмотреть все комментраии данного пользователя.
Запретить вставку ссылок NO_URL_IN_COMMENTS

Указывается, кому нельзя вставлять ссылки в комментарии (по умолчанию - Никому)

  • Никому;
  • Анонимным пользователям;
  • Всем.
Минимальный авторитет, с которым пользователи могут вставлять ссылки | NO_URL_IN_COMMENTS_AUTHORITY | Минимальное значение авторитета, при котором появляется возможность вставки ссылок в комментарии.
Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.
Имя переменной для идентификатора комментария | COMMENT_ID_VAR | Указывается имя переменной, которой передается идентификатор комментария блога.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:blog.post.comment",
    "",
    Array(
        "SEO_USER" => "Y",
        "ID" => $id,
        "BLOG_URL" => $blog,
        "PATH_TO_BLOG" => "",
        "PATH_TO_USER" => "",
        "PATH_TO_SMILE" => "",
        "BLOG_VAR" => "",
        "POST_VAR" => "",
        "USER_VAR" => "",
        "PAGE_VAR" => "",
        "COMMENT_ID_VAR" => "",
        "COMMENTS_COUNT" => "25",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "AJAX_POST" => "Y",
        "SIMPLE_COMMENT" => "Y",
        "USE_ASC_PAGING" => "Y",
        "SMILES_COUNT" => "4",
        "IMAGE_MAX_WIDTH" => "600",
        "IMAGE_MAX_HEIGHT" => "600",
        "EDITOR_RESIZABLE" => "Y",
        "EDITOR_DEFAULT_HEIGHT" => "200",
        "EDITOR_CODE_DEFAULT" => "N",
        "ALLOW_VIDEO" => "Y",
        "SHOW_SPAM" => "Y",
        "NO_URL_IN_COMMENTS_AUTHORITY" => ""
    )
);?>


Блоги группы

Описание blog.group.blog

Компонент выводит блоги группы. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Блоги группы.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | ID | Указывается код, в котором передается идентификатор группы блога.
Внешний вид
Количество блогов, выводимых на страницу | BLOG_COUNT | Указывается количество блогов, отображаемых на странице.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать блоги без сообщений | SHOW_BLOG_WITHOUT_POSTS | [Y|N] При отмеченной опции будут показаны блоги, которые не имеют сообщений.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога.
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Указывается путь к странице детального просмотра сообщения блога.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице профиля пользователя блога.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено <имя_группы> блогов.
Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.group.blog","",Array(
        "SEO_USER" => "Y",
        "BLOG_COUNT" => "20",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
        "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog#&post_id=#post_id#",
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "BLOG_VAR" => "blog",
        "POST_VAR" => "post_id",
        "USER_VAR" => "user_id",
        "PAGE_VAR" => "page",
        "ID" => $id,
        "SHOW_BLOG_WITHOUT_POSTS" => "Y",
        "NAV_TEMPLATE" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "SET_TITLE" => "Y"
    ),
);?>


Лента друзей

Описание blog.friends

Компонент выводит сообщения друзей пользователя блога. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Лента друзей.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | ID | Указывается код, в котором передается идентификатор пользователя блога. По умолчанию поле содержит ={$user_id}.
Внешний вид
Количество выводимых сообщений | MESSAGE_COUNT | Указывается количество сообщений, отображаемых на странице.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Максимально допустимая ширина выводимого изображения (в пикселях).
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Максимально допустимая высота выводимого изображения (в пикселях).
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога. Например, blog_blog.php?page=blog&blog=#blog#.
Шаблон пути к странице блога c фильтром по тегу | PATH_TO_BLOG_CATEGORY | Указывается путь к странице блога с фильтром по категории. Например, blog_filter.php?page=blog&blog=#blog#&category=#category#.
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Указывается путь к странице детального просмотра сообщения блога. Например, blog_post.php?page=post&blog=#blog#&post_id=#post_id#.
Шаблон пути к странице редактирования сообщения блога | PATH_TO_POST_EDIT | Указывается путь к странице редактирования сообщения блога. Например, blog_p_edit.php?page=post_edit&blog=#blog#&post_id=#post_id#.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице профиля пользователя блога. Например, blog_user.php?page=user&user_id=#user_id#.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Лента моих друзей.
Включить рейтинг SHOW_RATING Указывается, будет ли будет использован функционал рейтингов:
  • да;
  • нет;
  • по умолчанию - значение берется из настроек рейтингов.

Примечание:

С версии 17.6.0 добавлена поддержка рейтингов с реакциями.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопок рейтинга:
  • по умолчанию;
  • Мне нравится (текстовый);
  • Мне нравится (графический);
  • Нравится / Не нравится (текстовый);
  • Нравится / Не нравится (графический).

    • Значение По умолчанию берется из настроек рейтингов.

Запретить индексацию ссылки на профиль пользователя поисковыми ботами | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор (ID) блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор (ID) сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор (ID) пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:blog.friends",
    "",
    Array(
        "SEO_USER" => "Y",
        "MESSAGE_COUNT" => "25",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PATH_TO_BLOG" => "",
        "PATH_TO_BLOG_CATEGORY" => "",
        "PATH_TO_POST" => "",
        "PATH_TO_POST_EDIT" => "",
        "PATH_TO_USER" => "",
        "PATH_TO_SMILE" => "",
        "BLOG_VAR" => "",
        "POST_VAR" => "",
        "USER_VAR" => "",
        "PAGE_VAR" => "",
        "ID" => $user_id,
        "SET_TITLE" => "Y",
        "IMAGE_MAX_WIDTH" => "600",
        "IMAGE_MAX_HEIGHT" => "600"
    )
);?>


Профиль пользователя

Описание blog.user

Компонент позволяет просмотреть и изменить профиль пользователя. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Профиль пользователя.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | ID | Указывается код, в котором передается идентификатор пользователя блога.
Внешний вид
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Согласие пользователя
Запрашивать согласие | USER_CONSENT | [Y|N] Установленный флажок включает механизм согласия пользователя.
Соглашение | USER_CONSENT_ID | Задается текст соглашения, которое отображается пользователю при заказе.
Галка по умолчанию проставлена | USER_CONSENT_IS_CHECKED | Установка галочки автомаитчески устанавливает галочку в чекбоксе согласия пользователя. То есть согласие применяется одновременно с нажатием кнопки Оформить заказ.
Загружать текст сразу | USER_CONSENT_IS_LOADED | Текст соглашения будет выводиться сразу. Если флажок не установлен, для просмотра текст нужно будет кликнуть по кнопке согласия.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога.
Шаблон пути к странице пользователя | PATH_TO_USER | Указывается путь к странице пользователя блога.
Шаблон пути к странице редактирования пользователя | PATH_TO_USER_EDIT | Указывается путь к странице редактирования пользователя блога.
Шаблон пути к странице поиска | PATH_TO_SEARCH | Указывается путь к странице поиска.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Профиль пользователя "<имя_пользователя>".
Показывать доп. свойства | BLOG_PROPERTY | Указываются пользовательские свойства блога, которые необходимо дополнительно отобразить в блоге.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.user","",Array(
        "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "PATH_TO_USER_EDIT" => "blog_user_edit.php?page=user&user_id=#user_id#&mode=edit",
        "PATH_TO_SEARCH" => "blog_search.php",
        "BLOG_VAR" => "blog",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "ID" => $id,
        "SET_TITLE" => "Y",
        "USER_PROPERTY" => Array("UF_USER_CAR_DEMO"),
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s"
    ),
);?>


Редактирование сообщения

Описание blog.post.edit

Компонент позволяет создавать новые или редактировать существующие сообщения. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Редактирование сообщения.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Адрес блога | BLOG_URL | Указывается код, в котором передается идентификатор блога.
Идентификатор сообщения | ID | Указывается код, в котором передается идентификатор сообщения блога.
Внешний вид
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Количество постоянно отображаемых смайлов | SMILES_COUNT | Указывается количество постоянно отображаемых смайлов на странице. По умолчанию значение равно 4.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Максимально допустимая ширина добавляемого в сообщение изображения (в пикселях).
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Максимально допустимая высота добавляемого в сообщение изображения (в пикселях).
Разрешить изменять размер визуального редактора | EDITOR_RESIZABLE | [Y|N] При отмеченной опции будет возможность менять размеры окна визуального редактора.
Высота визуального редактора по умолчанию (пикселей) | EDITOR_DEFAULT_HEIGHT | Значение высоты визуального редактора при загрузке (в пикселях).
По умолчанию показывать невизуальный режим редактора | EDITOR_CODE_DEFAULT | [Y|N] При отмеченной опции визуальный режим редактора не будет использоваться по умолчанию при создании сообщений.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога. Например: blog_blog.php?page=blog&blog=#blog#.
Шаблон пути к странице сообщения блога | PATH_TO_POST | Указывается путь к странице сообщения блога. Например: blog_blog.php?page=post&blog=#blog#&post_id=#post_id#.
Шаблон пути к странице редактирования сообщения блога | PATH_TO_POST_EDIT | Указывается путь к странице редактирования сообщения блога. Например: blog_p_edit.php?page=post_edit&blog=#blog#&post_id=#post_id#.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице пользователя блога. Например: blog_user.php?page=user&user_id=#user_id#.
Шаблон пути к недописанным сообщениям | PATH_TO_DRAFT | Указывается путь к недописанным сообщениям блога.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Редактирование сообщения в блоге "<название_блога>".
Использовать отдельные поля для SEO описания | SEO_USE | [Y|N] При отмеченной опции для SEO-описания детальной страницы сообщения будут использоваться отдельные поля.
Показывать доп. свойства сообщения | POST_PROPERTY | Указываются пользовательские свойства сообщения, которые необходимо дополнительно отобразить при детальном просмотре сообщения.
Разрешить перенос сообщений между блогами | ALLOW_POST_MOVE | [Y|N] При отмеченной опции будет разрешен перенос сообщений между блогами. Со включенной опцией вы сможете в режиме редактирования своего сообщения выбрать другой/другие блоги, где ваше сообщение будет также показано. Например, страница блога какой-либо группы или другого пользователя. Данное поле доступно для шаблона .default. При отмеченной опции необходимо определить значение шаблонов путей к различным страницам блога соц. сети. Поля описаны ниже.
Использовать символьный код сообщений как идентификатор | ALLOW_POST_CODE | [Y|N] При отмеченной опции транслитерация заголовка сообщения будет использоваться как его идентификатор..
Шаблон пути к странице сообщения в блогах | PATH_TO_BLOG_POST | Указывается шаблон пути к странице сообщения блога. Например, /community/blogs/#blog#/#post_id#.php, где /community/blogs/ - каталог относительно корня сайта, в котором реализован функционал блогов, #blog#/#post_id#.php - непосредственно шаблон страницы сообщения в блогах.
Шаблон пути к редактированию сообщения в блогах | PATH_TO_BLOG_POST_EDIT | Указывается шаблон пути к редактированию сообщения в блогах. Например, /community/blogs/#blog#/post_edit.php?id=#post_id#, где /community/blogs/ - каталог относительно корня сайта, в котором реализован функционал блогов, #blog#/post_edit.php?id=#post_id# - непосредственно шаблон пути к редактированию сообщения в блогах.
Шаблон пути к черновикам в блогах | PATH_TO_BLOG_DRAFT | Указывается шаблон пути к редактированию сообщения в блогах. Например, /community/blogs/#blog#/draft.php, где /community/blogs/ - каталог относительно корня сайта, в котором реализован функционал блогов, #blog#/draft.php - непосредственно шаблон пути к черновикам в блогах.
Шаблон пути к блогу в блогах | PATH_TO_BLOG_BLOG | Указывается шаблон пути к редактированию сообщения в блогах. Например, /community/blogs/#blog#/, где /community/blogs/ - каталог относительно корня сайта, в котором реализован функционал блогов, #blog#/ - путь к странице блога.
Шаблон пути к странице сообщения блога пользователя в соц. сети | PATH_TO_USER_POST | Указывается шаблон пути к странице сообщения блога пользователя в соц. сети. Например, /company/personal/user/#user_id#/blog/#post_id#/, где /company/personal/ - берется из настроек компонента Социальная сеть - пользователь (bitrix:socialnetwork_user), поле Каталог ЧПУ (относительно корня сайта), user/#user_id#/blog/#post_id#/ - там же, поле Страница сообщения блога пользователя.
Шаблон пути к редактированию сообщения блога пользователя в соц. сети | PATH_TO_USER_POST_EDIT | Указывается шаблон пути к редактированию сообщения блога пользователя в соц. сети. Например, /company/personal/user/#user_id#/blog/edit/#post_id#/, где /company/personal/ - берется из настроек компонента Социальная сеть - пользователь (bitrix:socialnetwork_user), поле Каталог ЧПУ (относительно корня сайта), user/#user_id#/blog/edit/#post_id#/ - там же, поле Страница редактирования сообщения блога пользователя.
Шаблон пути к черновикам блога пользователя в соц. сети | PATH_TO_USER_DRAFT | Указывается шаблон пути к черновикам блога пользователя в соц. сети. Например, /company/personal/user/#user_id#/blog/draft/, где /company/personal/ - берется из настроек компонента Социальная сеть - пользователь (bitrix:socialnetwork_user), поле Каталог ЧПУ (относительно корня сайта), user/#user_id#/blog/draft/ - там же, поле Страница черновиков блога пользователя.
Шаблон пути к блогу пользователя в соц. сети | PATH_TO_USER_BLOG | Указывается шаблон пути к блогу пользователя в соц. сети. Например, /company/personal/user/#user_id#/blog/, где /company/personal/ - берется из настроек компонента Социальная сеть - пользователь (bitrix:socialnetwork_user), поле Каталог ЧПУ (относительно корня сайта), user/#user_id#/blog/ - там же, поле Страница блога пользователя.
Шаблон пути к странице сообщения блога группы в соц. сети | PATH_TO_GROUP_POST | Указывается шаблон пути к странице сообщения блога группы в соц. сети. Например, /workgroups/group/#group_id#/blog/#post_id#/, где /workgroups/ - берется из настроек компонента Социальная сеть - группы (bitrix:socialnetwork_group), поле Каталог ЧПУ (относительно корня сайта), group/#group_id#/blog/#post_id#/ - там же, поле Страница сообщения блога группы.
Шаблон пути к редактированию сообщения блога группы в соц. сети | PATH_TO_GROUP_POST_EDIT | Указывается шаблон пути к редактированию сообщения блога группы в соц. сети. Например, /workgroups/group/#group_id#/blog/edit/#post_id#/, где /workgroups/ - берется из настроек компонента Социальная сеть - группы (bitrix:socialnetwork_group), поле Каталог ЧПУ (относительно корня сайта), group/#group_id#/blog/edit/#post_id#/ - там же, поле Страница редактирования сообщения блога группы.
Шаблон пути к черновикам блога группы в соц. сети | PATH_TO_GROUP_DRAFT | Указывается шаблон пути к черновикам блога группы в соц. сети. Например, /workgroups/group/#group_id#/blog/draft/, где /workgroups/ - берется из настроек компонента Социальная сеть - группы (bitrix:socialnetwork_group), поле Каталог ЧПУ (относительно корня сайта), group/#group_id#/blog/draft/ - там же, поле Страница черновиков блога группы.
Шаблон пути к блогу группы в соц. сети | PATH_TO_GROUP_BLOG | Указывается шаблон пути к блогу группы в соц. сети. Например, /workgroups/group/#group_id#/blog/, где /workgroups/ - берется из настроек компонента Социальная сеть - группы (bitrix:socialnetwork_group), поле Каталог ЧПУ (относительно корня сайта), group/#group_id#/blog/ - там же, поле Страница блога группы.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:blog.post.edit",
    "",
    Array(
        "BLOG_URL" => $blog,
        "ID" => $id,
        "PATH_TO_BLOG" => "",
        "PATH_TO_POST" => "",
        "PATH_TO_POST_EDIT" => "",
        "PATH_TO_USER" => "",
        "PATH_TO_DRAFT" => "",
        "PATH_TO_SMILE" => "",
        "BLOG_VAR" => "",
        "POST_VAR" => "",
        "USER_VAR" => "",
        "PAGE_VAR" => "",
        "SET_TITLE" => "Y",
                "SEO_USE" => "Y",
        "POST_PROPERTY" => array("UF_BLOG_POST_DOC"),
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SMILES_COUNT" => "4",
        "ALLOW_POST_MOVE" => "Y",
        "IMAGE_MAX_WIDTH" => "600",
        "IMAGE_MAX_HEIGHT" => "600",
        "EDITOR_RESIZABLE" => "Y",
        "EDITOR_DEFAULT_HEIGHT" => "300",
        "EDITOR_CODE_DEFAULT" => "N",
        "ALLOW_POST_CODE" => "Y",
        "PATH_TO_BLOG_POST" => "",
        "PATH_TO_BLOG_POST_EDIT" => "",
        "PATH_TO_BLOG_DRAFT" => "",
        "PATH_TO_BLOG_BLOG" => "",
        "PATH_TO_USER_POST" => "",
        "PATH_TO_USER_POST_EDIT" => "",
        "PATH_TO_USER_DRAFT" => "",
        "PATH_TO_USER_BLOG" => "",
        "PATH_TO_GROUP_POST" => "",
        "PATH_TO_GROUP_POST_EDIT" => "",
        "PATH_TO_GROUP_DRAFT" => "",
        "PATH_TO_GROUP_BLOG" => ""
    )
);?>


Черновики сообщений блога

Описание blog.blog.draft

Компонент выводит неопубликованные сообщения текущего пользователя блога. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Черновики сообщений блога.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Путь блога | BLOG_URL | Указывается код, в котором передается идентификатор блога.
Внешний вид
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Максимально допустимая ширина добавляемого в сообщение изображения (в пикселях)..
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Максимально допустимая высота добавляемого в сообщение изображения (в пикселях).
Шаблоны ссылок
Шаблон пути к странице блога c фильтром по тегу | PATH_TO_BLOG_CATEGORY | Указывается шаблон пути к странице блога с фильтром по тегу.
Шаблон пути к странице редактирования сообщения блога | PATH_TO_POST_EDIT | Указывается шаблон пути к странице редактирования сообщения блога.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Добавлять пункт в цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт с названием блога.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Недописанные сообщения блога "<название_блога>".
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:blog.blog.draft",
    "",
    Array(
        "PATH_TO_BLOG_CATEGORY" => "",
        "PATH_TO_POST_EDIT" => "",
        "PATH_TO_SMILE" => "",
        "BLOG_VAR" => "",
        "POST_VAR" => "",
        "PAGE_VAR" => "",
        "BLOG_URL" => $blog,
        "SET_NAV_CHAIN" => "Y",
        "SET_TITLE" => "Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "IMAGE_MAX_WIDTH" => "600",
        "IMAGE_MAX_HEIGHT" => "600"
    )
);?>


Редактирование блога

Описание blog.blog.edit

Компонент позволяет изменить параметры и настройки блога. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Редактирование блога.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Путь блога | BLOG_URL | Указывается код, в котором передается идентификатор блога.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается шаблон пути к главной странице блога.
Шаблон пути к странице редактирования блога | PATH_TO_BLOG_EDIT | Указывается шаблон пути к странице редактирования блога.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Редактирование блога "<название_блога>".
Показывать доп. свойства в блоге | BLOG_PROPERTY | Указываются пользовательские свойства блога, которые необходимо дополнительно отобразить в блоге.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.blog.edit","",Array(
        "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
        "PATH_TO_BLOG_EDIT" => "blog_b_edit.php?page=blog_edit&blog=#blog#",
        "BLOG_VAR" => "blog",
        "PAGE_VAR" => "page",
        "BLOG_URL" => $blog,
        "SET_TITLE" => "Y",
        "BLOG_PROPERTY" => Array()
    ),
);?>


Группы пользователей блога

Описание blog.user.group

Компонент позволяет редактировать группы пользователей блога. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Группы пользователей блога.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Путь блога | BLOG_URL | Указывается код, в котором передается идентификатор блога.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Группы пользователей блога "<название_блога>".

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.user.group","",Array(
        "BLOG_URL" => $blog,
        "SET_TITLE" => "Y"
    ),
);?>


Теги блога

Описание blog.category

Компонент позволяет редактировать теги сообщений блога. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Теги блога.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Путь блога | BLOG_URL | Указывается код, в котором передается идентификатор блога.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Теги блога "<название_блога>".

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.category","",Array(
        "BLOG_URL" => $blog,
        "SET_TITLE" => "Y"
    )
);?>


Настройка пользователей блога

Описание blog.user.settings

Компонент позволяет настраивать пользователей блога: добавлять их в друзья, удалять. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Настройка пользователей блога.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Адрес блога | BLOG_URL | Указывается код, в котором передается идентификатор блога.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Указывается шаблон пути к странице профиля пользователя блога.
Шаблон пути к странице редактирования настроек пользователя | PATH_TO_USER_SETTINGS_EDIT | Указывается шаблон пути к странице редактирования настроек пользователя.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Пользователи блога "<название_блога>".
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.user.settings","",Array(
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "PATH_TO_USER_SETTINGS_EDIT" => "blog_u_set_edit.php?page=user_settings_edit&blog=#blog#&user_id=#user_id#",
        "BLOG_VAR" => "blog",
        "USER_VAR" => "user_id",
        "PAGE_VAR" => "page",
        "BLOG_URL" => "$blog",
        "SET_TITLE" => "Y"
    )
);?>


Настройка прав пользователя блога

Описание blog.user.settings.edit

Компонент позволяет настраивать привязку пользователя к группам блога. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Настройка прав пользователя блога.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Адрес блога | BLOG_URL | Указывается код, в котором передается идентификатор блога.
Идентификатор пользователя | ID | Указывается код, в котором передается идентификатор пользователя.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Указывается шаблон пути к странице профиля пользователя блога.
Шаблон пути к странице настроек пользователей | PATH_TO_USER_SETTINGS | Указывается шаблон пути к странице настроек пользователей.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Изменение прав пользователя блога "<название_блога>".
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.user.settings.edit","",Array(
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "PATH_TO_USER_SETTINGS" => "blog_user_set.php?page=user_settings&blog=#blog#&user_id=#user_id#",
        "BLOG_VAR" => "blog",
        "USER_VAR" => "user_id",
        "PAGE_VAR" => "page",
        "BLOG_URL" => $blog,
        "ID" => $user_id,
        "SET_TITLE" => "Y"
    )
);?>


RSS блога

Описание bitrix:blog.rss

Компонент выводит RSS блогов в заданном формате. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > RSS блога.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Путь блога | BLOG_URL | Поле содержит код, в котором передается идентификатор блога.
Идентификатор сообщения блога | POST_ID | Поле содержит код, в котором передается идентификатор сообщения блога.
Внешний вид
Количество сообщений | MESSAGE_COUNT | Указывается число сообщений блогов, данные из которых будут выгружены в соответствующем формате.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога.
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Указывается шаблон пути к странице просмотра сообщения блога.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается шаблон пути к странице профиля пользователя блога.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат RSS TYPE Указывается формат экспорта данных:
  • rss1 - формат RSS .92;
  • rss2 - формат RSS 2.0;
  • atom - формат Atom .03;
либо тип экспорта указывается с помощью кода.
Отдавать в RSS | MODE | Укажите данные, из которых будет формироваться RSS: сообщения (P) или комментарии (C) блога.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.rss","",Array(
        "MESSAGE_COUNT" => "10",
        "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
        "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog#&post_id=#post_id#",
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#iser_id#",
        "BLOG_VAR" => "blog",
        "POST_VAR" => "post_id",
        "USER_VAR" => "user_id",
        "PAGE_VAR" => "page",
        "BLOG_URL" =>$blog,
        "POST_ID" => $post_id,
        "TYPE" => "rss2",
        "MODE" => "P",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400"
    )
);?>


RSS блогов по группам/сайтам

Описание blog.rss.all

Компонент выводит RSS блогов группы или сайта в заданном формате. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > RSS блогов по группам/сайтам.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы блога | GROUP_ID | Указывается код, в котором передается идентификатор группы блогов.
Внешний вид
Количество сообщений | MESSAGE_COUNT | Указывается число сообщений блогов, данные из которых будут выгружены в соответствующем формате.
Шаблоны ссылок
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Указывается шаблон пути к странице просмотра сообщения блога.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается шаблон пути к странице профиля пользователя блога.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат RSS TYPE Указывается формат экспорта данных:
  • (другое)-> - можно сформировать свой тип экспорта с помощью кода;
  • rss1 - формат RSS .92;
  • rss2 - формат RSS 2.0;
  • atom - формат Atom .03;
либо тип экспорта указывается с помощью кода.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.rss.all","",Array(
        "MESSAGE_COUNT" => "10",
        "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog#&post_id=#post_id#",
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "BLOG_VAR" => "blog",
        "POST_VAR" => "post_id",
        "USER_VAR" => "user_id",
        "PAGE_VAR" => "page",
        "GROUP_ID" => "$group_id",
        "TYPE" => "rss2",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400"
    ),
);?>

Примечание: для корректного формирования XML, необходимо в шаблонах пути настройки компонента символ & заменять на & #38;:

"PATH_TO_POST" => "blog_post.php?page=post& #38;blog=#blog#&post_id=#post_id#",
"PATH_TO_USER" => "blog_user.php?page=user& #38;user_id=#user_id#",


Получение Trackback'ов к сообщению

Описание blog.post.trackback.get

Компонент получает Trackback к сообщению. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Получение Trackback'ов к сообщению.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Адрес блога | BLOG_URL | Параметр содержит код, в котором передается идентификатор блога.
Идентификатор сообщения | ID | Параметр содержит код, в котором передается идентификатор сообщения блога.
Шаблоны ссылок
Шаблон пути к сообщению | PATH_TO_POST | Задается шаблон пути к странице просмотра сообщения блога.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:blog.post.trackback.get","",Array(
        "BLOG_URL" => $blog,
        "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog#&post_id=#post_id#",
        "BLOG_VAR" => "blog",
        "POST_VAR" => "post_id",
        "PAGE_VAR" => "page",
        "ID" => $post_id
    )
);?>


Получение данных в формате metaWeblog

Данный компонент осуществляет импорт в формате MetaWeblog. Позволяет добавлять сообщения из Microsoft Word и Microsoft Live Writer на сайт в блоги пользователя и группы социальной сети.

Компонент настроек не имеет, его только необходимо разместить на удобной вам странице. Затем в настройках учетной записи Microsoft Word или Microsoft Live Writer необходимо задать адрес к данной странице и указать ваши параметры доступа к сайту.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Получение данных в формате metaWeblog.

Компонент относится к модулю Блоги.

По умолчанию компонент добавлен в комплексный компонент Блоги.


Комментарии к сообщению - плоский список

Описание blog.post.comment.list

Компонент позволяет выводить комментарии к сообщениям блога в виде плоского списка, вместо древовидного (компонент Комментарии к сообщению). Комопнент допускает возможность добавления комментария. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Комментарии к сообщению - плоский список. Относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор сообщения | ID | Указывается код, в котором передается идентификатор сообщения блога.
Адрес блога | BLOG_URL | Указывается код, в котором передается идентификатор блога
Внешний вид
Количество комментариев на странице | MESSAGE_COUNT | Указывается количество комментариев на странице. Остальные комментарии будут выведены с помощью постраничной навигации.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Количество постоянно отображаемых смайлов | SMILES_COUNT | Указывается количество постоянно отображаемых смайлов на странице. По умолчанию значение равно 4.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Максимально допустимая ширина добавляемого в сообщение изображения (в пикселях).
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Максимально допустимая высота добавляемого в сообщение изображения (в пикселях).
Разрешить изменять размер визуального редактора | EDITOR_RESIZABLE | [Y|N] При отмеченной опции будет возможность менять размеры окна визуального редактора.
Высота визуального редактора по умолчанию (пикселей) | EDITOR_DEFAULT_HEIGHT | Значение высоты визуального редактора при загрузке (в пикселях).
По умолчанию показывать невизуальный режим редактора | EDITOR_CODE_DEFAULT | [Y|N] При отмеченной опции визуальный режим редактора не будет использоваться по умолчанию при создании сообщений.
Согласие пользователя
Запрашивать согласие | USER_CONSENT | [Y|N] Установленный флажок включает механизм согласия пользователя.
Соглашение | USER_CONSENT_ID | Задается текст соглашения, которое отображается пользователю при заказе.
Галка по умолчанию проставлена | USER_CONSENT_IS_CHECKED | Установка галочки автомаитчески устанавливает галочку в чекбоксе согласия пользователя. То есть согласие применяется одновременно с нажатием кнопки Оформить заказ.
Загружать текст сразу | USER_CONSENT_IS_LOADED | Текст соглашения будет выводиться сразу. Если флажок не установлен, для просмотра текст нужно будет кликнуть по кнопке согласия.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Указывается путь к главной странице блога. Например: blog_blog.php?page=blog&blog=#blog#.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Указывается путь к странице профиля пользователя. Например: blog_user.php?page=user&user_id=#user_id#.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Упрощенный режим (без предварительного создания сообщения): SIMPLE_COMMENT [Y|N] В упрощенном режиме комментарии можно добавлять без сообщения (используется для модуля Фотогалерея 2.0).
Использовать прямую постраничную навигацию | USE_ASC_PAGING | [Y|N] При отмеченной опции список комментариев будет выводиться постранично с прямой навигацией.
Включить рейтинг SHOW_RATING Указывается, будет ли будет использован функционал рейтингов:
  • да;
  • нет;
  • по умолчанию - значение берется из настроек рейтингов.

Примечание:

С версии 17.6.0 добавлена поддержка рейтингов с реакциями.

Вид кнопок рейтинга RATING_TYPE Указывается тип кнопок рейтинга:
  • по умолчанию;
  • Мне нравится (текстовый);
  • Мне нравится (графический);
  • Нравится / Не нравится (текстовый);
  • Нравится / Не нравится (графический).

    • Значение По умолчанию берется из настроек рейтингов.

Разрешить вставку видео | ALLOW_VIDEO | [Y|N] При отмеченной опции в комментарии можно будет добавлять видео.
Разрешить загрузку изображений | ALLOW_IMAGE_UPLOAD | Указывается кто может загружать изображения в комментарии: Всем, Никому или только зарегистрированным пользователям.
Показывать администраторам ссылку на все комментарии пользователя | SHOW_SPAM | При включённой опции администратор может перейти сразу ко всем сообщениям пользователя.
Запретить вставку ссылок: NO_URL_IN_COMMENTS Указываются кому нельзя вставлять ссылки: Всем, незарегистрированным либо никому.
Минимальный авторитет, с которым пользователи могут вставлять ссылки: NO_URL_IN_COMMENTS_AUTHORITY Если вставка ссылок разрешена, то можно задать порог авторитета для пользователей с которого разрешается вставка ссылок.
Имена переменных
Имена переменных Указывается имена переменных для:
  • идентификатора блога (BLOG_VAR),
  • идентификатора сообщения блога (POST_VAR),
  • идентификатора пользователя блога (USER_VAR),
  • страницы (PAGE_VAR),
  • идентификатора комментария (COMMENT_ID_VAR),
в которых передаются эти сущности.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:blog.post.comment.list",
    "",
    Array(
        "ALLOW_IMAGE_UPLOAD" => "N",
        "ALLOW_VIDEO" => "N",
        "BLOG_URL" => $blog,
        "BLOG_VAR" => "",
        "CACHE_TIME" => "86400",
        "CACHE_TYPE" => "A",
        "COMMENTS_COUNT" => "25",
        "COMMENT_ID_VAR" => "",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "EDITOR_CODE_DEFAULT" => "N",
        "EDITOR_DEFAULT_HEIGHT" => "200",
        "EDITOR_RESIZABLE" => "Y",
        "ID" => $id,
        "IMAGE_MAX_HEIGHT" => "600",
        "IMAGE_MAX_WIDTH" => "600",
        "NO_URL_IN_COMMENTS" => "",
        "NO_URL_IN_COMMENTS_AUTHORITY" => "",
        "PAGE_VAR" => "",
        "PATH_TO_BLOG" => "",
        "PATH_TO_SMILE" => "",
        "PATH_TO_USER" => "",
        "POST_VAR" => "",
        "RATING_TYPE" => "",
        "SHOW_RATING" => "",
        "SHOW_SPAM" => "N",
        "SIMPLE_COMMENT" => "N",
        "SMILES_COUNT" => "4",
        "USER_CONSENT" => "N",
        "USER_CONSENT_ID" => "0",
        "USER_CONSENT_IS_CHECKED" => "Y",
        "USER_CONSENT_IS_LOADED" => "N",
        "USER_VAR" => "",
        "USE_ASC_PAGING" => "N"
    )
);?>


Неопубликованные сообщения блога

Описание blog.blog.moderation

Компонент выводит сообщения блога, требующие модерации. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Общение > Блоги > Неопубликованные сообщения блога.

Компонент относится к модулю Блоги.

Параметры

Поле | Параметр | Описание
Источник данных
Путь блога | BLOG_URL | Поле содержит код, в котором передается идентификатор блога.
Внешний вид
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Указывается максимально допустимая ширина картинки, которую можно вставить в сообщение
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Указывается максимально допустимая высота картинки, которую можно вставить в сообщение
Шаблоны ссылок
Шаблон пути к странице блога c фильтром по тегу | PATH_TO_BLOG_CATEGORY | Указывается путь к странице блога с фильтром по тегу. Например: blog_filter.php?page=blog&blog=#blog#&category=#category#.
Шаблон пути к странице редактирования сообщения блога | PATH_TO_POST_EDIT | Указывается путь к странице редактирования сообщения блога. Например: blog_p_edit.php?page=post_edit&blog=#blog#&post_id=#post_id#
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами.
Добавлять пункт в цепочку навигации | SET_NAV_CHAIN | При отмеченной опции в цепочку навигации будет добавлен пункт с названием блога.
Устанавливать заголовок страницы | SET_TITLE | При отмеченной опции в качестве заголовка страницы будет установлено Недописанные сообщения блога "название блога".
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:blog.blog.moderation",
    "",
Array(
        "PATH_TO_BLOG_CATEGORY" => "",
        "PATH_TO_POST_EDIT" => "",
        "PATH_TO_SMILE" => "",
        "BLOG_VAR" => "",
        "POST_VAR" => "",
        "PAGE_VAR" => "",
        "BLOG_URL" => $blog,
        "SET_NAV_CHAIN" => "Y",
        "SET_TITLE" => "Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "IMAGE_MAX_WIDTH" => "600",
        "IMAGE_MAX_HEIGHT" => "600"
    )
);?>


Социальная сеть

Подраздел предоставляет возможность создания полнофункционального публичного интерфейса социальной сети. Содержит компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание | Примечание
Социальная сеть (комплексный компонент) | socialnetwork | Создает полноценный публичный интерфейс социальной сети. |
Социальная сеть - группы (комплексный компонент) | socialnetwork_group | Служит для создания раздела рабочих групп социальной сети. |
Социальная сеть - пользователь (комплексный компонент) | socialnetwork_user | Служит для создания личного раздела пользователя социальной сети. |
Меню сообщений | socialnetwork.blog.menu | Выводит меню сообщений социальной сети. |
Список последних тем | socialnetwork.forum.topic.last | Выводит список последних тем форума пользователя или рабочей группы социальной сети. |
Тема (создание) | socialnetwork.forum.topic.new | Служит для сохранения новой темы форума социальной сети.. |
Тема (чтение) | socialnetwork.forum.topic.read | Выводит список сообщений темы форума социальной сети. |
Темы (список) | socialnetwork.forum.topic.list | Выводит список всех тем форума социальной сети. |
Уведомление о добавлении получателя | socialnetwork.blog.post_share.mail | Добавляет в почтовый шаблон соответствующее уведомление. |
Уведомление о записи или комментарии | socialnetwork.log.entry.mail | Добавляет в почтовый шаблон соответствующее уведомление. |
Уведомление о комментарии | socialnetwork.blog.post.comment.mail | Добавляет в почтовый шаблон соответствующее уведомление. |
Уведомление о сообщении | socialnetwork.blog.post.mail | Добавляет в почтовый шаблон соответствующее уведомление. |
Форма ввода пользователей | socialnetwork.user_search_input | Выводит форму, с помощью которой осуществляется ввод пользователей социальной сети. |
Форма создания сообщения | socialnetwork.forum.post_form | Выводит форму создания сообщения (или темы) форума социальной сети. |
Сообщения | socialnetwork.blog.blog | Выводит сообщения блога социальной сети с возможностью их фильтрации по категории и дате. |
Сообщения - модерация | socialnetwork.blog.moderation | Выводит сообщения, требующие модерации. |
Черновики сообщений | socialnetwork.blog.draft | Выводит черновики сообщений. |
Сообщение детально | socialnetwork.blog.post | Выводит подробно сообщение. |
Комментарии к сообщению | socialnetwork.blog.post.comment | Выводит комментарии к сообщению с возможностью добавления. |
Изменение профиля пользователя | socialnetwork.user_profile_edit | Позволяет изменить данные профиля пользователя социальной сети. |
Просмотр профиля пользователя | socialnetwork.user_profile | Позволяет просмотреть и изменить профиль пользователя социальной сети. |
Профиль группы | socialnetwork.group | Для просмотра и изменения профиля группы социальной сети. |
Top групп | socialnetwork.group_top | Показывает Top групп социальной сети. |
Бизнес-процессы | socialnetwork.bizproc | Выводит задания и историю по бизнес-процессам. |
Входящие сообщения | socialnetwork.messages_input | Показывает входящие сообщения социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Выход из группы | socialnetwork.user_leave_group | Позволяет выйти из группы социальной сети. |
Группы пользователя | socialnetwork.user_groups | Позволяет просмотреть и изменить группы пользователя социальной сети. |
Запрос пользователя на вступление в группу | socialnetwork.user_request_group | Позволяет пользователю отправить запрос на вступление в группу социальной сети. |
Запросы на вступление в группу (ex) | socialnetwork.group_requests.ex | Позволяет показать приглашения и запросы пользователя. |
Запросы на вступление в группу | socialnetwork.group_requests | Позволяет просмотреть и изменить запросы на вступление в группу социальной сети. | Устарел, рекомендуется socialnetwork.group_requests.ex
Запросы пользователю | socialnetwork.messages_requests | Показывает запросы пользователю социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Исходящие сообщения | socialnetwork.messages_output | Показывает исходящие сообщения социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Лог активности пользователя | socialnetwork.activity | Выводит лог активности пользователя социальной сети. | Устарел, рекомендуется socialnetwork.log.ex.
Лог изменений (ex) | socialnetwork.log.ex | Выводит запись вместе с комментариями. |
Лог изменений (entry) | socialnetwork.log.entry | Получает cписок комментариев к каждой из записей социальной сети. |
Меню профайла группы | socialnetwork.group_menu | Показывает меню профайла группы социальной сети. |
Меню профайла пользователя | socialnetwork.user_menu | Показывает меню профайла пользователя социальной сети. |
Меню сообщений пользователя | socialnetwork.messages_menu | Показывает меню сообщений пользователя социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Модераторы группы | socialnetwork.group_mods | Служит для просмотра и изменения модераторов группы социальной сети. | Устарел, рекомендуется socialnetwork.group_users.ex.
Настройка разрешений пользователя | socialnetwork.user_settings_edit | Позволяет настраивать разрешения пользователя (приватность) социальной сети. |
Настройка функционала | socialnetwork.features | Позволяет настраивать функционал пользователей и рабочих групп социальной сети. |
Обработка задания Бизнес-процесса | socialnetwork.bizproc_edit | Позволяет обработать задание бизнес-процесса. |
Переписка в виде чата | socialnetwork.messages_chat | Показывает переписку в виде чата социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Переписка с пользователем | socialnetwork.messages_users_messages | Показывает переписку с пользователем социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Переписка с пользователями | socialnetwork.messages_users | Показывает переписку с пользователями социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Подписка | socialnetwork.subscribe | Служит для настройки подписки социальной сети. | Устарел с версии 14.0 в связи с появлением Умного слежения в Живой ленте.
Поиск групп | socialnetwork.group_search | Создает страницу поиска рабочих групп. |
Поиск пользователей | socialnetwork.user_search | Позволяет искать пользователей социальной сети. |
Показ событий | socialnetwork.events | Показывает события: новое сообщение, запрос на добавление в список друзей и пр. социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Показ событий (ajax) | socialnetwork.events_dyn | Показывает события с помощью AJAX: новое сообщение, запрос на добавление в список друзей и пр. социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Пользователи группы | socialnetwork.group_users | Служит для просмотра и изменения пользователей группы социальной сети. | Устарел, рекомендуется socialnetwork.group_users.ex.
Пользователи группы (расширенный) | socialnetwork.group_users.ex | Служит для просмотра и изменения пользователей группы социальной сети. |
Друзья пользователя (расширенный) | socialnetwork.user_friends.ex | Служит для просмотра и изменения друзей пользователя группы. |
Приглашение пользователей в группу | socialnetwork.group_request_search | Служит для приглашения пользователей в группу социальной сети. | Устарел, рекомендуется socialnetwork.group_create.ex
Приглашения на вступление в группу | socialnetwork.group_requests_out | Позволяет просмотреть и изменить приглашения на вступление в группу социальной сети. | Устарел, рекомендуется socialnetwork.group_requests.ex
Создание группы | socialnetwork.group_create | Позволяет создать новую (редактировать уже существующую) группу социальной сети. | Устарел, рекомендуется socialnetwork.group_create.ex
Создание группы в попап-диалоге | socialnetwork.group.iframe.popup | Позволяет создать новую группу в попап-диалоге. | Устарел.
Создание группы в попап-диалоге (ex) | socialnetwork.group_create.ex | Позволяет создать новую группу в попап-диалоге. |
Список подписки пользователя | socialnetwork.subscribe_list | Позволяет показать список подписки пользователя социальной сети. | Устарел с версии 14.0 в связи с появлением Умного слежения в Живой ленте.
Удаление группы | socialnetwork.group_delete | Служит для удаления группы социальной сети. |
Форма отправки сообщения | socialnetwork.message_form | Позволяет отправить сообщение пользователю социальной сети. | Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).
Форма приглашения пользователя вступить в группу | socialnetwork.group_request_user | Создает форму приглашения пользователю вступить в группу социальной сети. | Устарел, рекомендуется socialnetwork.group_create.ex.
Черный список группы | socialnetwork.group_ban | Служит для просмотра и изменения черного списка группы социальной сети. |
Редактирование сообщения | socialnetwork.blog.post.edit | Позволяет редактировать/создавать сообщения. |
RSS блогов | socialnetwork.blog.rss | Выводит RSS блогов группы или сайта в заданном формате. |
Используются только в БУС
Друзья пользователя | socialnetwork.user_friends | Позволяет просмотреть и изменить друзей пользователя социальной сети. | Не используется на КП. Устарел, рекомендуется socialnetwork.user_friends.ex
Дни рождения друзей | socialnetwork.user_birthday | Выводит ближайшие дни рождения друзей пользователя социальной сети. | Не используется на КП.
Добавление друга | socialnetwork.user_friends_add | Позволяет отправить запрос на добавление друга социальной сети. | Не используется на КП.
Удаление друга | socialnetwork.user_friends_delete | Позволяет удалить друга социальной сети. | Не используется на КП.
Черный список пользователя | socialnetwork.user_ban | Служит для просмотра и изменения черного списка пользователя социальной сети. | Не используется на КП.
Используются только на КП
Живая лента (мобильная, ex) | mobile.socialnetwork.log.ex | Отображает Живую ленту в формате для мобильных устройств. |
Живая лента (мобильная) | mobile.socialnetwork.log | Отображает Живую ленту в формате для мобильных устройств. |
Сообщение Живой ленты (мобильной) | mobile.socialnetwork.log.entry | Отображает сообщение Живой ленты в формате для мобильных устройств. |


Социальная сеть (комплексный компонент)

Секции настроек компонента

Описание socialnetwork

Комплексный компонент социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Социальная сеть.

Внешний вид

Поле | Параметр | Описание
Количество элементов, выводимых на страницу | ITEM_DETAIL_COUNT | Параметр определяет количество элементов, отображаемых на одной странице. Все элементы будут выведены с помощью постраничной навигации.
Количество элементов, выводимых на главной странице профайла | ITEM_MAIN_COUNT | Параметр определяет количество элементов, отображаемых на главных страницах профайлов пользователя и рабочих групп социальной сети.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Разрешить владельцу изменять гаджеты на главной странице профиля и группы | CAN_OWNER_EDIT_DESKTOP | [Y|N] При отмеченной опции владелец группы может изменять гаджеты на главной странице профиля и группы.
Использовать ключевые слова для группы | GROUP_USE_KEYWORDS | [Y|N] При отмеченной опции появится возможность использовать ключевые слова для группы.
Тема меню | SM_THEME | Указывается тема шаблона меню.
Отображать меню соцсети в шаблоне сайта USE_MAIN_MENU [Y|N] При отмеченной опции меню социальной сети будет отображаться в меню, указанном в параметре [dw]Добавлять пункты к меню типа[/dw][di]
Добавлять пункты к меню типа MAIN_MENU_TYPE Указывается в какой тип меню шаблона сайта добавлять меню соцсети.
[/di] .

Примечание: данная опция будет работать только при включенном параметре Откладывать выполнение шаблона меню в компоненте Меню (bitrix:menu), название которого указано в параметре Добавлять пункты к меню типа.
Отображать панель соц. закладок | USE_SHARE | [Y|N] При отмеченной опции на странице будет отображаться панель соц. закладок.
Не раскрывать панель соц. закладок по умолчанию | SHARE_HIDE | [Y|N] При отмеченной опции по умолчанию панель соц. закладок будет свернута.
Шаблон компонента панели соц. закладок | SHARE_TEMPLATE | Указывается шаблон для отображения панели соц. закладок
Используемые соц. закладки и сети SHARE_HANDLERS Указываются соц. закладки и сети, которые будут доступны на странице:
  • Delicious
  • Facebook*
  • Livejournal
  • Мой мир@Mail.Ru
  • Twitter
  • ВКонтакте

* деятельность организации запрещена в Российской Федерации.
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.
Рейтинг | RATING_ID | Указывается какой будет использоваться рейтинг.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).

Шаблоны ссылок

Поле | Параметр | Описание
Внешний путь к странице поиска пользователей | PATH_TO_SEARCH_EXTERNAL | Указывается внешний путь к странице поиска пользователя социальной сети.

Управление адресами страниц

Поле Параметр Описание
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - главная страница социальной сети;
  • user - страница профиля пользователя;
  • user_friends - страница друзей пользователя;
  • user_friends_add - страница с формой добавления друга;
  • user_friends_delete - страница с формой удаления друга;
  • user_groups - страница списка рабочих групп, в которых участвует пользователь;
  • user_groups_add - страница создания рабочей группы;
  • group_create - страница с формой создания группы;
  • user_profile_edit - страница изменения профиля пользователя;
  • user_settings_edit - страница изменения персональных настроек приватности пользователя;
  • user_features - страница настроек функционалов пользователя;
  • search - страница поиска пользователей;
  • reindex - страница переиндексации социальной сети;
  • group_content_search - страница поиска контента группы;
  • user_content_search - страница поиска контента пользователя;
  • group - страница рабочей группы;
  • group_search - страница поиска групп;
  • group_search_subject - страница темы групп;
  • group_edit - страница изменения группы;
  • group_delete - страница с формой удаления группы;
  • group_request_search - страница с формой поиска пользователя для приглашения в группу;
  • user_request_group - страница с формой запроса пользователя на вступление в группу;
  • group_requests - страница с формой запросов на вступление в группу;
  • group_requests_out - страница с формой приглашений для вступления в группу;
  • group_mods - страница с формой модераторов группы;
  • group_users - страница с формой списка членов группы;
  • group_ban - страница черного списка группы;
  • user_leave_group - страница с формой выхождения из членов группы;
  • group_features - страница настроек функционала группы;
  • group_request_user - страница с формой приглашения пользователя вступить в группу;
  • group_request_group_search - страница с формой поиска групп для приглашения пользователя;
  • message_form - страница с формой отправки сообщения;
  • message_form_mess - страница ответа на сообщение;
  • user_ban - страница черного списка пользователя;
  • messages_chat - страница чата с пользователем;
  • messages_input - страница с формой входящих сообщений;
  • messages_input_user - страница с формой входящих сообщений с фильтром по пользователю;
  • messages_output - страница с формой исходящих сообщений;
  • messages_output_user - страница с формой исходящих сообщений с фильтром по пользователю;
  • messages_users - страница пользователей, с которыми ведется переписка;
  • messages_users_messages - страница переписки с пользователем;
  • log - страница лога обновлений;
  • subscribe - страница подписок пользователя;
  • user_subscribe - страница подписки на пользователя;
  • group_subscribe - страница подписки на группу;
  • user_photo - страница фотогалереи пользователя;
  • user_calendar - страница календарей пользователя;
  • user_files - страница файлов пользователя;
  • group_blog - страница блога группы;
  • group_photo - страница фотогалереи группы;
  • group_forum - страница форума рабочей группы;
  • group_calendar - страница календарей группы;
  • group_files - страница файлов группы;
  • user_blog - страница блога пользователя;
  • user_blog_post_edit - страница редактирования сообщения блога пользователя;
  • user_blog_rss - страница RSS блога пользователя;
  • user_blog_draft - страница черновиков блога пользователя;
  • user_blog_post - страница сообщения блога пользователя;
  • user_blog_moderation - страница модерации блога пользователя;
  • user_forum - страница форума пользователя;
  • user_forum_topic_edit - страница редактирования темы форума пользователя;
  • user_forum_topic - страница темы форума пользователя;
  • group_blog_post_edit - страница редактирования сообщений блога группы;
  • group_blog_rss - страница RSS блога группы;
  • group_blog_draft - страница черновиков блога группы;
  • group_blog_post - страница сообщений блога группы;
  • group_blog_moderation - страница модерации блога группы;
  • group_forum_topic_edit - страница редактирования темы форума группы;
  • group_forum_topic - страница просмотра темы форума группы;
  • bizproc - страница бизнес-процессов пользователя;
  • bizproc_edit - страница редактирования события бизнес-процесса пользователя;
  • video_call - страница с видеозвонком пользователю;
[/di] : SEF_FOLDER, SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.

При выключенном режиме ЧПУ необходимо указать имена следующих переменных:
  • user_id - имя переменной для идентификатора пользователя;
  • page - имя переменной для страницы;
  • group_id - имя переменной для идентификатора группы;
  • message_id - имя переменной для сообщения;
  • task_id - имя переменной для задачи;
  • view_id - имя переменной для представления;
  • action - имя переменной для действия.
[/di] .

Настройки кеширования

Поле | Параметр | Описание
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Время кэширования остальных страниц | CACHE_TIME_LONG | Указывается время кеширования страниц, начиная со второй.

Дополнительные настройки

Поле | Параметр | Описание
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта.
Путь к папке со смайликами для блогов относительно корня сайта | PATH_TO_BLOG_SMILE | Указывается путь к папке со смайлами для блогов относительно корня сайта.
Путь к папке со смайликами для форума относительно корня сайта | PATH_TO_FORUM_SMILE | Указывается путь к папке со смайлами для форума относительно корня сайта.
Путь к папке с иконками для форума относительно корня сайта | SONET_PATH_TO_FORUM_ICON | Указывается путь к папке с иконками для форума относительно корня сайта.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на каждой странице социальной сети будет установлен заголовок в соответствии с ее содержимым.
Добавлять социальную сеть в цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочке навигации будут отображены переходы по страницам социальной сети.
Учитывать подписку при показе обновлений на странице группы | LOG_SUBSCRIBE_ONLY | [Y|N] При отмеченной опции будет учитываться подписка при показе обновлений на странице рабочей группы.
Время жизни RSS лога обновлений группы (в минутах) | LOG_RSS_TTL | Указывается время жизни RSS лога обновлений рабочей группы в минутах.
Главные свойства пользователя | USER_FIELDS_MAIN | Указываются главные свойства, которые должны быть отображены в области основной информации о пользователе.
Главные доп. свойства пользователя | USER_PROPERTY_MAIN | Указываются дополнительные свойства, которые также должны быть отображены в области основной информации о пользователе.
Свойства пользователя для контакта | USER_FIELDS_CONTACT | Указываются свойства пользователя, которые должны быть отображены в области контактной информации.
Доп. свойства пользователя для контакта | USER_PROPERTY_CONTACT | Указываются дополнительные свойства пользователя, которые также должны быть отображены в области контактной информации.
Персональные свойства пользователя | USER_FIELDS_PERSONAL | Указываются свойства пользователя, которые должны быть отображены в области личной информации.
Персональные доп. свойства пользователя | USER_PROPERTY_PERSONAL | Указываются дополнительные свойства пользователя, которые также должны быть отображены в области личной информации.
Доп. свойства группы | GROUP_PROPERTY | Указываются дополнительные свойства группы, которые также должны быть отображены в области списка групп.
Использовать функционал черного списка в группах | GROUP_USE_BAN | [Y|N] При отмеченной опции будет использоваться функционал черного списка в рабочих группах.
Редактируемые свойства | EDITABLE_FIELDS | Указываются свойства, которые будут доступны пользователю для редактирования по ссылке Изменить профиль.
Показывать год рождения SHOW_YEAR Параметр определяет для каких сотрудников должен быть отображен год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).
Поля пользователя для простой формы поиска | USER_FIELDS_SEARCH_SIMPLE | Указываются свойства пользователя, которые должны быть отображены на простой форме поиска сотрудника.
Пользовательские свойства пользователя для простой формы поиска | USER_PROPERTIES_SEARCH_SIMPLE | Указываются дополнительные свойства пользователя, которые также должны быть отображены на простой форме поиска сотрудника.
Поля пользователя для расширенной формы поиска | USER_FIELDS_SEARCH_ADV | Указываются свойства пользователя, которые должны быть отображены на расширенной форме поиска сотрудника.
Пользовательские свойства пользователя для расширенной формы поиска | USER_PROPERTIES_SEARCH_ADV | Указываются дополнительные свойства пользователя, которые также должны быть отображены на расширенной форме поиска сотрудника.
Поля пользователя для вывода в списке | SONET_USER_FIELDS_LIST | Указываются поля пользователя, которые должны быть отображены при показе списка сотрудников.
Пользовательские свойства пользователя для вывода в списке | SONET_USER_PROPERTY_LIST | Указываются дополнительные свойства пользователя, которые также должны быть отображены при показе списка сотрудников.
Поля пользователя, по которым возможен поиск | SONET_USER_FIELDS_SEARCHABLE | Указываются поля пользователя, по которым будет осуществляться поиск сотрудников.
Пользовательские свойства пользователя, по которым возможен поиск | SONET_USER_PROPERTY_SEARCHABLE | Указываются дополнительные свойства пользователя, по которым также будет осуществляться поиск сотрудников.
Перенаправлять запрос на страницу приглашения пользователей после создания группы | ALLOW_GROUP_CREATE_REDIRECT_REQUEST | [Y|N] При отмеченной опции после создания группы будет открываться страница с формой приглашения пользователей вступить в эту группу.
Учитывать рейтинг в сортировке при выводе списка пользователей | ALLOW_RATING_SORT | [Y|N] При отмеченной опции при выводе списка пользователей будет учитываться их рейтинг.

Настройки блогов

Поле | Параметр | Описание
Группа блогов для блогов | BLOG_GROUP_ID | Указывается идентификатор группы блогов, в которой будут храниться блоги социальной сети.
Разрешить перенос сообщений между блогами ALLOW_POST_MOVE [Y|N] При отмеченной опции можно будет переносить сообщения между блогами; станут доступны [dw]дополнительные поля.[/dw][di]
Шаблон пути к странице сообщения в блогах | PATH_TO_BLOG_POST | Указывается путь к странице сообщения в блогах.
Шаблон пути к редактированию сообщения в блогах | PATH_TO_BLOG_POST_EDIT | Указывается путь к странице редактирования сообщения в блогах.
Шаблон пути к черновикам в блогах | PATH_TO_BLOG_DRAFT | Указывается путь к черновикам в блогах.
Шаблон пути к блогу в блогах | PATH_TO_BLOG_BLOG | Указывается путь к блогу в блогах.
[/di]
Максимальная ширина изображения | BLOG_IMAGE_MAX_WIDTH | Указывается максимальная ширина изображения в посте блога в пикселах.
Максимальная высота изображения | BLOG_IMAGE_MAX_HEIGHT | Указывается максимальная высота изображения в посте блога в пикселах.
Использовать AJAX для комментариев | BLOG_COMMENT_AJAX_POST | [Y|N] При отмеченной опции для публикации коментариев будет использоваться AJAX.
Разрешить вставку видео в комментарии | BLOG_COMMENT_ALLOW_VIDEO | [Y|N] При отмеченной опции в коментариях блога можно вставлять видео.
Показывать администраторам ссылку на все комментарии пользователя | BLOG_SHOW_SPAM | [Y|N] При отмеченной опции будет показыаться ссылка, ведущая на страницу со всеми постами пользователя.
Запретить вставку ссылок в комментариях | BLOG_NO_URL_IN_COMMENTS | Указывается кому запрещать постить ссылки в коментариях блога: Никому, Анонимным пользователям или Всем.
Минимальный авторитет, с которым пользователи могут вставлять ссылки в комментариях | BLOG_NO_URL_IN_COMMENTS_AUTHORITY | Указывается минимальный авторитет пользователя, который может вставлять ссылки в комментарии.
Использовать символьный код сообщений как идентификатор BLOG_ALLOW_POST_CODE [Y|N] При отмеченной опции URL поста блога будет создаваться с помощью транслитезации заголовка поста; станет доступным [dw]дополнительное поле[/dw][di]
Использовать внешний сервис для перевода кода сообщений BLOG_USE_GOOGLE_CODE [Y|N] При отмеченной опции URL поста будет создаваться с помощью заголовка, переведенного внешним переводчиком, данные которого указаны в группе опций Внешние сервисы перевода в Настройках главного модуля.
[/di].
Использовать внешний сервис для перевода кода сообщений | BLOG_USE_GOOGLE_CODE | [Y|N] При отмеченной опции URL поста будет создаваться с помощью заголовка, переведенного внешним переводчиком, данные которого указаны в группе опций Внешние сервисы перевода в Настройках главного модуля.
Использовать [CUT] для сообщений | BLOG_USE_CUT | [Y|N] При отмеченной опции в посте можно будет использовать тег [CUT]. После тега [CUT] текст в посте скрывается, вместо текста появляется ссылка Читать подробнее..., при переходе по которой открывается уже полное сообщение.

Настройки форума

Поле | Параметр | Описание
Форум | FORUM_ID | Указывается идентификатор форума, в котором будут храниться темы и сообщения пользователей и рабочих групп.
Темы | FORUM_THEME | Выбирается одна из восьми доступных тем оформления шаблона.
Разрешить опросы SHOW_VOTE [Y|N] При отмеченной опции будет выведен опрос; станут доступны [dw]дополнительные поля[/dw][di]
Группа опросов | VOTE_CHANNEL_ID | Указывается группа опросов, в которой будет создан опрос.
Группы пользователей, которые могут создавать опрос | VOTE_GROUP_ID | Задаются группы пользователей, которым разрешено создавать опросы на форуме.
Количество вопросов | VOTE_COUNT_QUESTIONS | Указывается максимально возможное количество вопросов в опросе.
Количество ответов | VOTE_COUNT_ANSWERS | Задается максимально возможное количество вариантов ответов на вопрос в опросе.
Шаблон для голосований | VOTE_TEMPLATE | Указывается шаблон для отображения опроса.
Не голосовать дважды VOTE_UNIQUE Указывается варианты запрета на повторное голосование в опросе:
  • 1 - в одной сессии;
  • 2 - с одним cookie;
  • 4 - с одного IP;
  • 8 - с одним ID пользователя.
Не голосовать дважды с одного IP в течение VOTE_UNIQUE_IP_DELAY Указывается период, в течение которого запрещается голосовать дважды с одного IP:
  • VOTE_UNIQUE_IP_DELAY_INPUT - указывается число;
  • VOTE_UNIQUE_IP_DELAY_SELECT - указывается:
    • S - секунд;
    • M - минут;
    • H - часов;
    • D - дней.
[/di]. Создание опроса доступно только при создании новой темы на форуме.
Использовать AJAX в диалогах | AJAX_POST | [Y|N] При отмеченной опции будет использоваться технология AJAX при добавлении, скрытии/показе и удалении сообщений на форуме.

Настройки фото

Поле | Параметр | Описание
Тип информационного блока (используется только для проверки)[Пользователь] | PHOTO_USER_IBLOCK_TYPE | Указывается тип информационного блока фотогалерей.
Код информационного блока[Пользователь] | PHOTO_USER_IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будут храниться фотогалереи пользователей.
Тип информационного блока (используется только для проверки)[Группа] | PHOTO_GROUP_IBLOCK_TYPE | Указывается тип информационного блока фотогалерей.
Код информационного блока[Группа] | PHOTO_GROUP_IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будут храниться фотогалереи рабочих групп.
Включить премодерацию фото | PHOTO_MODERATION | [Y|N] При отмеченной опции будет выполняться обязательная премодерация фото.
Количество альбомов на странице | PHOTO_SECTION_PAGE_ELEMENTS | Указывается количество альбомов, отображаемых на одной странице.
Количество фото на странице | PHOTO_ELEMENTS_PAGE_ELEMENTS | Задается количество фотографий, отображаемых на одной странице.
Размер картинки-анонса фотоальбома (px) | PHOTO_ALBUM_PHOTO_THUMBS_SIZE | Указывается размер картинки-анонса фотоальбома в пикселах (px).
Размер картинки фотоальбома (px) | PHOTO_ALBUM_PHOTO_SIZE | Указывается размер картинки фотоальбома в пикселах (px).
Размер фотографии-анонса (px) | PHOTO_THUMBS_SIZE | Указывается размер фотографии-анонса в пикселах (px). Задается одна сторона картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Обязательно ограничивать размер оригинала (px) (при значении 0 ограничение не происходит) | PHOTO_ORIGINAL_SIZE | Задается размер оригинала фотографии в пикселях. Фотография будет уменьшена до указанной величины. Если указано значение 0, то изменение размера не происходит. Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Минимальный размер фото для авторского знака (px) | PHOTO_WATERMARK_MIN_PICTURE_SIZE | Указывается минимальный размер (в пикселях) фото, на которых будет нанесен авторский знак. Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения. На фотографии меньшего размера знак добавлен не будет.
Файл со шрифтом (шрифт необходим для нанесения авторского знака при одиночной загрузке) | PHOTO_PATH_TO_FONT | Указывается файл со шрифтом для создания авторского знака. Шрифты предварительно загружаются в директорию \bitrix\modules\photogallery\fonts\. Поддерживаются TTF-, OTF- и PS-шрифты.
Показывать параметры авторского знака | PHOTO_SHOW_WATERMARK | [Y|N] При отмеченной опции будут показаны параметры авторского знака.
Правила нанесения авторского знака PHOTO_WATERMARK_RULES Выберите правило нанесения авторского знака: на усмотрение пользователя (USER) или обязательно наносить авторский знак (ALL).

Если выбрано значение ALL, то дополнительно необходимо настроить [dw]следующие параметры[/dw][di]
Тип авторского знака PHOTO_WATERMARK_TYPE Указывается тип авторского знака: картинка (PICTURE) или надпись (TEXT).

Если выбрано значение PICTURE, то дополнительно необходимо настроить параметры PHOTO_WATERMARK_FILE и PHOTO_WATERMARK_FILE_ORDER

Если выбрано значение TEXT, то дополнительно необходимо настроить параметры PHOTO_WATERMARK_TEXT, PHOTO_WATERMARK_COLOR и PHOTO_WATERMARK_SIZE.
Размещение авторского знака PHOTO_WATERMARK_POSITION Указывается размещение авторского знака на фото:
  • Без изменений (usual);
  • Растянуть (resize);
  • Замостить (repeat).
Прозрачность авторского знака | PHOTO_WATERMARK_TRANSPARENCY | Задается величина прозрачности авторского знака (в %).
Путь к картинке относительно корня сайта | PHOTO_WATERMARK_FILE | Указывается полный путь к картинке для авторского знака.
Расположение картинки на фото PHOTO_WATERMARK_FILE_ORDER Указывается тип расположения картинки авторского знака на фото:
  • Сверху слева (tl);
  • Сверху по центру (tc);
  • Сверху справа (tr);
  • Cлева (ml);
  • По центру (mc);
  • Cправа (mr);
  • Снизу cлева (bl);
  • Снизу по центру (bc);
  • Снизу cправа (br).
Текст надписи | PHOTO_WATERMARK_TEXT | Задается текст авторского знака.
Цвет надписи (без #, например, FF00EE) | PHOTO_WATERMARK_COLOR | Указывается шестнадцатеричный код цвета надписи без использования #.
Размер надписи (% от размера картинки) | PHOTO_WATERMARK_SIZE | Задается размер надписи авторского знака в процентном соотношении от размера фото.
[/di] : PHOTO_WATERMARK_TYPE, PHOTO_WATERMARK_POSITION и PHOTO_WATERMARK_TRANSPARENCY.
Максимальный размер загружаемого файла (не должен превышать 1024Mб) (Мб) | PHOTO_PHOTO_UPLOAD_MAX_FILESIZE | Параметр определяет максимальный размер загружаемых фотографий в Мб (не должен превышать 1024Mб).
Включить рейтинг (старый) PHOTO_USE_RATING [Y|N] При отмеченной опции можно проголосовать за ту или иную фотографию; станут доступны [dw]дополнительные поля[/dw][di]
Максимальный балл PHOTO_MAX_VOTE Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам PHOTO_VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
В качестве рейтинга показывать PHOTO_DISPLAY_AS_RATING Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • Рейтинг (rating);
  • Среднее значение (vote_avg).
[/di] .
Использовать комментарии PHOTO_USE_COMMENTS [Y|N] При отмеченной опции доступен [dw]функционал комментариев[/dw][di]
Компонент комментариев | PHOTO_COMMENTS_TYPE | Указывается какой из компонентов будет использоваться для вывода коментариев: blog (Блог) или forum (Форум).
ID форума | PHOTO_FORUM_ID | Указывается форум, в котором будут храниться комментарии пользователей.
Использовать CAPTCHA | PHOTO_USE_CAPTCHA | [Y|N] При отмеченной опции будет использоваться CAPTCHA при добавлении комментариев.
[/di] по фотографиям.
Количество фотографий для отображения в записи Живой ленты | LOG_PHOTO_COUNT | Указывается количество выводимых фотографий в одном посте Живой ленты.
Размер картинки-анонса фотоальбома для Живой ленты (px) | LOG_PHOTO_THUMBNAIL_SIZE | Указывается размер картинки-анонса фотоальбома для Живой ленты в пикселах. Задается одна сторона картинки, вторая будет высчитана пропорционально для загружаемого изображения.

Настройки поиска

Поле | Параметр | Описание
Сортировка результатов поиска по умолчанию SEARCH_DEFAULT_SORT Параметр определяет сортировку результатов поиска по умолчанию:
  • по релевантности (rank);
  • по дате (date).
Количество результатов поиска на странице | SEARCH_PAGE_RESULT_COUNT | Указывается количество результатов поиска на одной странице.
Количество тегов | SEARCH_TAGS_PAGE_ELEMENTS | Указывается количество тегов на одной странице.
Период выборки тегов (дней) | SEARCH_TAGS_PERIOD | Указывается количество дней для выборки тегов.
Максимальный размер шрифта (px) | SEARCH_TAGS_FONT_MAX | Указывается максимальный размер шрифта тегов в пикселях (px).
Минимальный размер шрифта (px) | SEARCH_TAGS_FONT_MIN | Указывается минимальный размер шрифта тегов в пикселях (px)
Цвет более позднего тега (пример: "C0C0C0") | SEARCH_TAGS_COLOR_NEW | Указывается цвет более позднего тега без #.
Цвет более раннего тега (пример: "FEFEFE") | SEARCH_TAGS_COLOR_OLD | Указывается цвет более раннего тега без #.
Имя дополнительного фильтра по функционалу | SEARCH_FILTER_NAME | Указывается имя дополнительного фильтра по функционалу.
Имя дополнительного фильтра по дате | SEARCH_FILTER_DATE_NAME | Указывается имя дополнительного фильтра по дате.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork","",Array(
        "ITEM_DETAIL_COUNT" => "32",
        "ITEM_MAIN_COUNT" => "6",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "NAME_TEMPLATE" => "",
        "PATH_TO_SEARCH_EXTERNAL" => "",
        "SEF_MODE" => "Y",
        "SEF_FOLDER" => "/club/",
        "AJAX_MODE" => "N",
        "AJAX_OPTION_SHADOW" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_TIME_LONG" => "604800",
        "PATH_TO_SMILE" => "/bitrix/images/socialnetwork/smile/",
        "PATH_TO_BLOG_SMILE" => "/bitrix/images/blog/smile/",
        "PATH_TO_FORUM_SMILE" => "/bitrix/images/forum/smile/",
        "SONET_PATH_TO_FORUM_ICON" => "/bitrix/images/forum/icon/",
        "SET_TITLE" => "Y",
        "SET_NAV_CHAIN" => "Y",
        "USER_FIELDS_MAIN" => array("LAST_LOGIN", "DATE_REGISTER", "PERSONAL_BIRTHDAY", "PERSONAL_GENDER"),
        "USER_PROPERTY_MAIN" => array("UF_USER_CAR_DEMO"),
        "USER_FIELDS_CONTACT" => array("EMAIL", "PERSONAL_WWW", "PERSONAL_ICQ", "PERSONAL_PHONE", "PERSONAL_FAX", "PERSONAL_MOBILE"),
        "USER_PROPERTY_CONTACT" => array(),
        "USER_FIELDS_PERSONAL" => array("PERSONAL_PROFESSION", "PERSONAL_NOTES"),
        "USER_PROPERTY_PERSONAL" => array(),
        "SET_NAVCHAIN" => "Y",
        "AJAX_LONG_TIMEOUT" => "60",
        "EDITABLE_FIELDS" => array("LOGIN", "NAME", "SECOND_NAME", "LAST_NAME", "EMAIL", "TIME_ZONE", "PASSWORD", "PERSONAL_BIRTHDAY", "PERSONAL_WWW", "PERSONAL_ICQ", "PERSONAL_GENDER", "PERSONAL_PHOTO", "PERSONAL_NOTES", "PERSONAL_PHONE", "PERSONAL_FAX", "PERSONAL_MOBILE", "PERSONAL_PAGER", "PERSONAL_COUNTRY", "PERSONAL_STATE", "PERSONAL_CITY", "PERSONAL_ZIP", "PERSONAL_STREET", "PERSONAL_MAILBOX", "FORUM_SHOW_NAME", "FORUM_DESCRIPTION", "FORUM_INTERESTS", "FORUM_SIGNATURE", "FORUM_AVATAR", "FORUM_HIDE_FROM_ONLINE", "FORUM_SUBSC_GET_MY_MESSAGE", "BLOG_ALIAS", "BLOG_DESCRIPTION", "BLOG_INTERESTS", "BLOG_AVATAR", "UF_USER_CAR_DEMO"),
        "SHOW_YEAR" => "Y",
        "USER_FIELDS_SEARCH_SIMPLE" => array("PERSONAL_CITY"),
        "USER_PROPERTIES_SEARCH_SIMPLE" => array("UF_USER_CAR_DEMO"),
        "USER_FIELDS_SEARCH_ADV" => array("PERSONAL_GENDER", "PERSONAL_COUNTRY", "PERSONAL_CITY"),
        "USER_PROPERTIES_SEARCH_ADV" => array("UF_USER_CAR_DEMO"),
        "SONET_USER_FIELDS_LIST" => array("PERSONAL_BIRTHDAY", "PERSONAL_GENDER", "PERSONAL_CITY"),
        "SONET_USER_PROPERTY_LIST" => array("UF_USER_CAR_DEMO"),
        "SONET_USER_FIELDS_SEARCHABLE" => array("LOGIN", "NAME", "SECOND_NAME", "LAST_NAME", "PERSONAL_BIRTHDAY", "PERSONAL_BIRTHDAY_YEAR", "PERSONAL_BIRTHDAY_DAY", "PERSONAL_PROFESSION", "PERSONAL_GENDER", "PERSONAL_COUNTRY", "PERSONAL_STATE", "PERSONAL_CITY", "PERSONAL_ZIP", "PERSONAL_STREET", "PERSONAL_MAILBOX", "WORK_COMPANY", "WORK_DEPARTMENT", "WORK_POSITION", "WORK_COUNTRY", "WORK_STATE", "WORK_CITY", "WORK_ZIP", "WORK_STREET", "WORK_MAILBOX"),
        "SONET_USER_PROPERTY_SEARCHABLE" => array("UF_USER_CAR_DEMO"),
        "SHOW_RATING" => "Y",
        "RATING_ID" => array("3"),
        "RATING_TYPE" => "like",
        "BLOG_GROUP_ID" => "1",
        "ALLOW_GROUP_CREATE_REDIRECT_REQUEST" => "Y",
        "FORUM_ID" => "8",
        "PHOTO_USER_IBLOCK_TYPE" => "gallery",
        "PHOTO_USER_IBLOCK_ID" => "11",
        "PHOTO_GROUP_IBLOCK_TYPE" => "car_gallery_demo",
        "PHOTO_GROUP_IBLOCK_ID" => "16",
        "PHOTO_UPLOAD_MAX_FILESIZE" => "2",
        "PHOTO_UPLOAD_MAX_FILE" => "4",
        "PHOTO_USE_RATING" => "Y",
        "PHOTO_USE_COMMENTS" => "Y",
        "PHOTO_FORUM_ID" => "7",
        "VARIABLE_ALIASES" => Array(),
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "user" => "user/#user_id#/",
            "user_friends" => "user/#user_id#/friends/",
            "user_friends_add" => "user/#user_id#/friends/add/",
            "user_friends_delete" => "user/#user_id#/friends/delete/",
            "user_groups" => "user/#user_id#/groups/",
            "user_groups_add" => "user/#user_id#/groups/add/",
            "group_create" => "user/#user_id#/groups/create/",
            "user_profile_edit" => "user/#user_id#/edit/",
            "user_settings_edit" => "user/#user_id#/settings/",
            "user_features" => "user/#user_id#/features/",
            "search" => "search/",
            "group" => "group/#group_id#/",
            "group_search" => "group/search/",
            "group_search_subject" => "group/search/#subject_id#/",
            "group_edit" => "group/#group_id#/edit/",
            "group_delete" => "group/#group_id#/delete/",
            "group_request_search" => "group/#group_id#/user_search/",
            "user_request_group" => "group/#group_id#/user_request/",
            "group_requests" => "group/#group_id#/requests/",
            "group_mods" => "group/#group_id#/moderators/",
            "group_users" => "group/#group_id#/users/",
            "group_ban" => "group/#group_id#/ban/",
            "user_leave_group" => "group/#group_id#/user_leave/",
            "group_features" => "group/#group_id#/features/",
            "group_request_user" => "group/#group_id#/user/#user_id#/request/",
            "group_request_group_search" => "group/#user_id#/group_search/",
            "message_form" => "messages/form/#user_id#/",
            "message_form_mess" => "messages/form/#user_id#/#message_id#/",
            "user_ban" => "messages/ban/",
            "messages_chat" => "messages/chat/#user_id#/",
            "messages_input" => "messages/input/",
            "messages_input_user" => "messages/input/#user_id#/",
            "messages_output" => "messages/output/",
            "messages_output_user" => "messages/output/#user_id#/",
            "messages_users" => "messages/",
            "messages_users_messages" => "messages/#user_id#/",
            "log" => "log/",
            "subscribe" => "subscribe/",
            "user_subscribe" => "user/#user_id#/subscribe/",
            "group_subscribe" => "group/#group_id#/subscribe/",
            "user_photo" => "user/#user_id#/photo/",
            "user_calendar" => "user/#user_id#/calendar/",
            "user_files" => "user/#user_id#/files/lib/#path#",
            "group_blog" => "group/#group_id#/blog/",
            "group_photo" => "group/#group_id#/photo/",
            "group_forum" => "group/#group_id#/forum/",
            "group_calendar" => "group/#group_id#/calendar/",
            "group_files" => "group/#group_id#/files/#path#",
            "user_blog" => "user/#user_id#/blog/",
            "user_blog_post_edit" => "user/#user_id#/blog/edit/#post_id#/",
            "user_blog_rss" => "user/#user_id#/blog/rss/#type#/",
            "user_blog_draft" => "user/#user_id#/blog/draft/",
            "user_blog_post" => "user/#user_id#/blog/#post_id#/",
            "user_forum" => "user/#user_id#/forum/",
            "user_forum_topic_edit" => "user/#user_id#/forum/edit/#topic_id#/",
            "user_forum_topic" => "user/#user_id#/forum/#topic_id#/",
            "group_blog_post_edit" => "group/#group_id#/blog/edit/#post_id#/",
            "group_blog_rss" => "group/#group_id#/blog/rss/#type#/",
            "group_blog_draft" => "group/#group_id#/blog/draft/",
            "group_blog_post" => "group/#group_id#/blog/#post_id#/",
            "group_forum_topic_edit" => "group/#group_id#/forum/edit/#topic_id#/",
            "group_forum_topic" => "group/#group_id#/forum/#topic_id#/"
        ),
        "SHOW_LOGIN" => "Y",
        "CAN_OWNER_EDIT_DESKTOP" => "Y",
        "LOG_AUTH" => "N",
        "GROUP_USE_KEYWORDS" => "Y",
        "SM_THEME" => "blue",
        "USE_MAIN_MENU" => "N",
        "SEF_URL_TEMPLATES" => Array(
            "reindex" => "reindex.php",
            "group_content_search" => "group/#group_id#/search/",
            "user_content_search" => "user/#user_id#/search/",
            "group_requests_out" => "group/#group_id#/requests_out/",
            "group_log" => "group/#group_id#/log/",
            "mail" => "mail/",
            "activity" => "user/#user_id#/activity/",
            "user_blog_moderation" => "user/#user_id#/blog/moderation/",
            "group_blog_moderation" => "group/#group_id#/blog/moderation/",
            "bizproc" => "bizproc/",
            "bizproc_edit" => "bizproc/#task_id#/",
            "video_call" => "video/#user_id#/"
        ),
        "LOG_SUBSCRIBE_ONLY" => "N",
        "LOG_RSS_TTL" => "60",
        "GROUP_PROPERTY" => array(),
        "GROUP_USE_BAN" => "Y",
        "PHOTO_APPLET_LAYOUT" => "extended",
        "LOG_THUMBNAIL_SIZE" => "",
        "LOG_COMMENT_THUMBNAIL_SIZE" => "",
        "ALLOW_RATING_SORT" => "N",
        "ALLOW_POST_MOVE" => "N",
        "BLOG_IMAGE_MAX_WIDTH" => "800",
        "BLOG_IMAGE_MAX_HEIGHT" => "800",
        "BLOG_COMMENT_AJAX_POST" => "N",
        "BLOG_COMMENT_ALLOW_VIDEO" => "N",
        "BLOG_COMMENT_ALLOW_IMAGE_UPLOAD" => "A",
        "BLOG_SHOW_SPAM" => "N",
        "BLOG_NO_URL_IN_COMMENTS" => "",
        "BLOG_NO_URL_IN_COMMENTS_AUTHORITY" => "",
        "BLOG_ALLOW_POST_CODE" => "Y",
        "BLOG_USE_GOOGLE_CODE" => "Y",
        "BLOG_USE_CUT" => "N",
        "FORUM_THEME" => "",
        "USER_FIELDS_FORUM" => array(),
        "SHOW_VOTE" => "N",
        "FORUM_AJAX_POST" => "N",
        "PHOTO_MODERATION" => "N",
        "PHOTO_SECTION_PAGE_ELEMENTS" => "15",
        "PHOTO_ELEMENTS_PAGE_ELEMENTS" => "50",
        "PHOTO_ALBUM_PHOTO_THUMBS_SIZE" => "120",
        "PHOTO_THUMBNAIL_SIZE" => "100",
        "PHOTO_ORIGINAL_SIZE" => "1280",
        "PHOTO_UPLOADER_TYPE" => "form",
        "PHOTO_WATERMARK_MIN_PICTURE_SIZE" => "400",
        "PHOTO_PATH_TO_FONT" => "",
        "PHOTO_SHOW_WATERMARK" => "Y",
        "PHOTO_WATERMARK_RULES" => "USER",
        "PHOTO_MAX_VOTE" => "5",
        "PHOTO_VOTE_NAMES" => array("1", "2", "3", "4", "5", ""),
        "PHOTO_DISPLAY_AS_RATING" => "rating",
        "PHOTO_COMMENTS_TYPE" => "blog",
        "PHOTO_USE_CAPTCHA" => "Y",
        "LOG_PHOTO_COUNT" => "6",
        "LOG_PHOTO_THUMBNAIL_SIZE" => "48",
        "SEARCH_DEFAULT_SORT" => "rank",
        "SEARCH_PAGE_RESULT_COUNT" => "10",
        "SEARCH_TAGS_PAGE_ELEMENTS" => "100",
        "SEARCH_TAGS_PERIOD" => "",
        "SEARCH_TAGS_FONT_MAX" => "50",
        "SEARCH_TAGS_FONT_MIN" => "10",
        "SEARCH_TAGS_COLOR_NEW" => "3E74E6",
        "SEARCH_TAGS_COLOR_OLD" => "C0C0C0",
        "SEARCH_FILTER_NAME" => "sonet_search_filter",
        "SEARCH_FILTER_DATE_NAME" => "sonet_search_filter_date",
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "user" => Array(),
            "user_friends" => Array(),
            "user_friends_add" => Array(),
            "user_friends_delete" => Array(),
            "user_groups" => Array(),
            "user_groups_add" => Array(),
            "group_create" => Array(),
            "user_profile_edit" => Array(),
            "user_settings_edit" => Array(),
            "user_features" => Array(),
            "search" => Array(),
            "group" => Array(),
            "group_search" => Array(),
            "group_search_subject" => Array(),
            "group_edit" => Array(),
            "group_delete" => Array(),
            "group_request_search" => Array(),
            "user_request_group" => Array(),
            "group_requests" => Array(),
            "group_mods" => Array(),
            "group_users" => Array(),
            "group_ban" => Array(),
            "user_leave_group" => Array(),
            "group_features" => Array(),
            "group_request_user" => Array(),
            "group_request_group_search" => Array(),
            "message_form" => Array(),
            "message_form_mess" => Array(),
            "user_ban" => Array(),
            "messages_chat" => Array(),
            "messages_input" => Array(),
            "messages_input_user" => Array(),
            "messages_output" => Array(),
            "messages_output_user" => Array(),
            "messages_users" => Array(),
            "messages_users_messages" => Array(),
            "log" => Array(),
            "subscribe" => Array(),
            "user_subscribe" => Array(),
            "group_subscribe" => Array(),
            "user_photo" => Array(),
            "user_calendar" => Array(),
            "user_files" => Array(),
            "group_blog" => Array(),
            "group_photo" => Array(),
            "group_forum" => Array(),
            "group_calendar" => Array(),
            "group_files" => Array(),
            "user_blog" => Array(),
            "user_blog_post_edit" => Array(),
            "user_blog_rss" => Array(),
            "user_blog_draft" => Array(),
            "user_blog_post" => Array(),
            "user_forum" => Array(),
            "user_forum_topic_edit" => Array(),
            "user_forum_topic" => Array(),
            "group_blog_post_edit" => Array(),
            "group_blog_rss" => Array(),
            "group_blog_draft" => Array(),
            "group_blog_post" => Array(),
            "group_forum_topic_edit" => Array(),
            "group_forum_topic" => Array(),
            "reindex" => Array(),
            "group_content_search" => Array(),
            "user_content_search" => Array(),
            "group_requests_out" => Array(),
            "group_log" => Array(),
            "mail" => Array(),
            "activity" => Array(),
            "user_blog_moderation" => Array(),
            "group_blog_moderation" => Array(),
            "bizproc" => Array(),
            "bizproc_edit" => Array(),
            "video_call" => Array(),
    )
);?>


Социальная сеть - группы (комплексный компонент)

Секции настроек компонента

Описание socialnetwork_group

Комплексный компонент служит для создания раздела рабочих групп портала. Настройки компонента обширны и позволяют управлять отображением тех или иных страниц в публичной части, внешним видом социальной сети и т.д. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Социальная сеть - группы.

Внешний вид

Поле | Параметр | Описание
Количество элементов, выводимых на страницу | ITEM_DETAIL_COUNT | Параметр определяет количество элементов, отображаемых на одной странице. Все элементы будут выведены с помощью постраничной навигации.
Количество элементов, выводимых на главной странице профайла | ITEM_MAIN_COUNT | Параметр определяет количество элементов, отображаемых на главной странице профайла группы.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Разрешить владельцу изменять гаджеты на главной странице группы | CAN_OWNER_EDIT_DESKTOP | [Y|N] При отмеченной опции владельцу группы будет разрешено изменять гаджеты на главной странице группы.
Тема меню | SM_THEME | Указывается тема оформления меню группы.
Отображать меню соцсети в шаблоне сайта USE_MAIN_MENU [Y|N] При отмеченной опции меню социальной сети будет отображаться в меню, указанном в параметре [dw]Добавлять пункты к меню типа[/dw][di]
Добавлять пункты к меню типа MAIN_MENU_TYPE Указывается в какой тип меню шаблона сайта добавлять меню соцсети.
[/di] .

Примечание: данная опция будет работать только при включенном параметре Откладывать выполнение шаблона меню в компоненте Меню (bitrix:menu), название которого указано в параметре Добавлять пункты к меню типа.
Отображать панель соц. закладок | USE_SHARE | [Y|N] При отмеченной опции будет отображаться панель закладок социальной сети.
Не раскрывать панель соц. закладок по умолчанию | SHARE_HIDE | [Y|N] При отмеченной опции по умолчанию панель соц. закладок будет свернута.
Шаблон компонента панели соц. закладок | SHARE_TEMPLATE | Указывается шаблон для отображения панели соц. закладок
Используемые соц. закладки и сети SHARE_HANDLERS Указываются соц. закладки и сети, которые будут доступны на странице:
  • Delicious
  • Facebook*
  • Livejournal
  • Мой мир@Mail.Ru
  • Twitter
  • ВКонтакте

* деятельность организации запрещена в Российской Федерации.
Логин для bit.ly | SHARE_SHORTEN_URL_LOGIN | Указывается логин для сервиса коротких ссылок bit.ly.
Ключ для bit.ly | SHARE_SHORTEN_URL_KEY | Указывается пароль для сервиса коротких ссылок bit.ly.
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.
Рейтинг | RATING_ID | Указывается какой будет использоваться рейтинг.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).

Шаблоны ссылок

Поле | Параметр | Описание
Шаблон пути к пользователю | PATH_TO_USER | Указывается путь к странице пользователя социальной сети.
Шаблон пути к управлению подписками | PATH_TO_SUBSCRIBE | Указывается путь к странице управления подписками социальной сети.
Форма создания группы | PATH_TO_GROUP_CREATE | Указывается путь к странице с формой создания рабочей группы социальной сети.
Внешний путь к странице поиска пользователей | PATH_TO_SEARCH_EXTERNAL | Указывается внешний путь к странице поиска пользователей социальной сети.
Шаблон пути к чату с пользователем | PATH_TO_MESSAGES_CHAT | Указывается путь к странице чата с пользователем социальной сети.
Шаблон пути к календарю пользователя | PATH_TO_USER_CALENDAR | Указывается путь к странице календаря пользователя социальной сети.
Шаблон пути к ответу на сообщение пользователя | PATH_TO_MESSAGE_FORM_MESS | Указывается путь к странице ответа на сообщение пользователя социальной сети.
Путь к логу обновлений пользователя | PATH_TO_USER_LOG | Указывается путь к странице лога обновлений пользователя социальной сети.
Страница списка шаблонов пользователя | PATH_TO_USER_TASKS_TEMPLATES | Указывается путь к странице списка шаблонов пользователя социальной сети.
Страница шаблона пользователя | PATH_TO_USER_TEMPLATES_TEMPLATE | Указывается путь к странице шаблона пользователя социальной сети.
Шаблон пути к списку заданий пользователя | PATH_TO_BIZPROC_TASK_LIST | Указывается путь к странице списка заданий пользователя социальной сети.
Шаблон пути к заданию пользователя | PATH_TO_BIZPROC_TASK | Указывается путь к странице задания пользователя социальной сети.

Управление адресами страниц

Поле Параметр Описание
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - главная страница рабочих групп социальной сети;
  • search - страница поиска пользователей;
  • group_reindex - страница переиндексации;
  • group_content_search - cтраница поиска контента группы;
  • group_subscribe - страница подписки на группу;
  • group - страница рабочей группы;
  • group_search - страница поиска групп;
  • group_search_subject - страница темы групп;
  • group_edit - страница изменения группы;
  • group_delete - страница с формой удаления группы;
  • group_request_search - страница с формой поиска пользователя для приглашения в группу;
  • group_request_user - страница с формой приглашения пользователя вступить в группу;
  • user_request_group - страница с формой запроса пользователя на вступление в группу;
  • group_requests - страница с формой запросов на вступление в группу;
  • group_requests_out - страница с формой приглашений для вступления в группу;
  • group_mods - страница с формой модераторов группы;
  • group_users - страница с формой списка членов группы;
  • group_ban - страница черного списка группы;
  • user_leave_group - страница с формой выхождения из членов группы;
  • group_features - страница настроек функционала группы;
  • group_photo - страница фотогалереи группы;
  • group_calendar - страница календарей группы;
  • group_files - страница файлов группы;
  • group_blog - страница блога группы;
  • group_blog_post_edit - страница редактирования сообщений блога группы;
  • group_blog_rss - страница RSS блога группы;
  • group_blog_draft - страница черновиков блога группы;
  • group_blog_post - сообщений блога группы;
  • group_blog_moderation - cтраница модерации блога группы;
  • group_forum - страница форума рабочей группы;
  • group_forum_topic_edit - страница редактирования темы форума группы;
  • group_forum_topic - страница просмотра темы форума группы.
[/di] : SEF_FOLDER, SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.

При выключенном режиме ЧПУ необходимо указать имена следующих переменных:
  • user_id - имя переменной для идентификатора пользователя;
  • page - имя переменной для страницы;
  • group_id - имя переменной для идентификатора группы;
  • message_id - имя переменной для сообщения.
[/di] .

Настройки кеширования

Поле | Параметр | Описание
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Время кэширования остальных страниц | CACHE_TIME_LONG | Указывается время кеширования страниц, начиная со второй.

Дополнительные настройки

Поле | Параметр | Описание
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта.
Путь к папке со смайликам для блогов относительно корня сайта | PATH_TO_BLOG_SMILE | Указывается путь к папке со смайлами для блогов относительно корня сайта.
Путь к папке со смайликам для форума относительно корня сайта | PATH_TO_FORUM_SMILE | Указывается путь к папке со смайлами для форума относительно корня сайта.
Путь к папке с иконками для форума относительно корня сайта | SONET_PATH_TO_FORUM_ICON | Указывается путь к папке с иконками относительно корня сайта.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на каждой странице будет установлен заголовок в соответствии с ее содержимым.
Добавлять социальную сеть в цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочке навигации будут отображены переходы по страницам социальной сети.
Учитывать подписку при показе обновлений на странице группы | LOG_SUBSCRIBE_ONLY | [Y|N] При отмеченной опции будет учитываться подписка при показе обновлений на странице рабочей группы.
Время жизни RSS лога обновлений группы (в минутах) | LOG_RSS_TTL | Указывается время жизни RSS лога обновлений рабочей группы в минутах.
Показывать год рождения SHOW_YEAR Поле определяет кому показываеть год рождения:
  • Y - всем;
  • M - только мужчинам;
  • N - никому.
Главные доп. свойства пользователя | USER_PROPERTY_MAIN | Указываются дополнительные свойства, которые должны быть отображены в области основной информации о пользователе.
Доп. свойства пользователя для контакта | USER_PROPERTY_CONTACT | Указываются дополнительные свойства пользователя, которые должны быть отображены в области контактной информации.
Персональные доп. свойства в пользователя | USER_PROPERTY_PERSONAL | Указываются дополнительные свойства пользователя, которые должны быть отображены в области личной информации.
Доп. свойства группы | GROUP_PROPERTY | Указываются дополнительные свойства группы, которые также должны быть отображены в области списка групп.
Использовать функционал черного списка в группах | GROUP_USE_BAN | [Y|N] При отмеченной опции будет использоваться функционал черного списка в рабочих группах.

Настройки блогов

Поле | Параметр | Описание
Группа блогов для блогов | BLOG_GROUP_ID | Указывается идентификатор группы блогов, в которой будут храниться блоги социальной сети.
Разрешить перенос сообщений между блогами ALLOW_POST_MOVE [Y|N] При отмеченной опции можно будет переносить сообщения между блогами; станут доступны [dw]дополнительные поля.[/dw][di]
Шаблон пути к странице сообщения в блогах | PATH_TO_BLOG_POST | Указывается путь к странице сообщения в блогах.
Шаблон пути к редактированию сообщения в блогах | PATH_TO_BLOG_POST_EDIT | Указывается путь к странице редактирования сообщения в блогах.
Шаблон пути к черновикам в блогах | PATH_TO_BLOG_DRAFT | Указывается путь к черновикам в блогах.
Шаблон пути к блогу в блогах | PATH_TO_BLOG_BLOG | Указывается путь к блогу в блогах.
[/di]
Шаблон пути к странице сообщения блога группы в соц. сети | PATH_TO_GROUP_POST | Указывается путь к странице сообщения блога группы.
Шаблон пути к редактированию сообщения блога группы в соц. сети | PATH_TO_GROUP_POST_EDIT | Указывается путь к странице редактирования сообщения блога группы.
Шаблон пути к черновикам блога группы в соц. сети | PATH_TO_GROUP_DRAFT | Указывается путь к черновикам блога группы.
Шаблон пути к блогу группы в соц. сети | PATH_TO_GROUP_BLOG | Указывается путь к блогу группы.
Максимальная ширина изображения | BLOG_IMAGE_MAX_WIDTH | Указывается максимальная ширина изображения в посте блога в пикселах.
Максимальная высота изображения | BLOG_IMAGE_MAX_HEIGHT | Указывается максимальная высота изображения в посте блога в пикселах.
Использовать AJAX для комментариев | BLOG_COMMENT_AJAX_POST | [Y|N] При отмеченной опции для публикации коментариев будет использоваться AJAX.
Разрешить вставку видео в комментарии | BLOG_COMMENT_ALLOW_VIDEO | [Y|N] При отмеченной опции в коментариях блога можно вставлять видео.
Разрешить загрузку изображений в комментариях BLOG_COMMENT_ALLOW_IMAGE_UPLOAD Указывается кому можно загружать изображения в коментарии к блогу:
  • А - всем;
  • R - зарегистрированным пользователям;
  • N - никому.
Показывать администраторам ссылку на все комментарии пользователя | BLOG_SHOW_SPAM | [Y|N] При отмеченной опции будет показыаться ссылка, ведущая на страницу со всеми постами пользователя.
Запретить вставку ссылок в комментариях | BLOG_NO_URL_IN_COMMENTS | Указывается кому запрещать постить ссылки в коментариях блога: Никому, Анонимным пользователям или Всем.
Минимальный авторитет, с которым пользователи могут вставлять ссылки в комментариях | BLOG_NO_URL_IN_COMMENTS_AUTHORITY | Указывается минимальный авторитет пользователя, который может вставлять ссылки в комментарии.
Использовать символьный код сообщений как идентификатор BLOG_ALLOW_POST_CODE [Y|N] При отмеченной опции URL поста блога будет создаваться с помощью транслитезации заголовка поста; станет доступным [dw]дополнительное поле[/dw][di]
Использовать внешний сервис для перевода кода сообщений BLOG_USE_GOOGLE_CODE [Y|N] При отмеченной опции URL поста будет создаваться с помощью заголовка, переведенного внешним переводчиком, данные которого указаны в группе опций Внешние сервисы перевода в Настройках главного модуля.
[/di].
Использовать переводчик Google для кода сообщений | BLOG_USE_GOOGLE_CODE | [Y|N] При отмеченной опции URL поста блога будет создаваться с помощью заголовка поста, переведенного переводчиком Google.

Настройки форума

Поле | Параметр | Описание
Форум | FORUM_ID | Указывается идентификатор форума, в котором будут храниться темы и сообщения форума рабочих групп.
Темы | FORUM_THEME | Выбирается одна из восьми доступных тем оформления шаблона.
Разрешить опросы SHOW_VOTE [Y|N] При отмеченной опции будет выведен опрос. Создание опроса доступно только при создании новой темы на форуме. При выборе данной опции станут доступны [dw]дополнительные поля.[/dw][di]
Группа опросов | VOTE_CHANNEL_ID | Указывается группа опросов, в которой будет создан опрос.
Группы пользователей, которые могут создавать опрос | VOTE_GROUP_ID | Задаются группы пользователей, которым разрешено создавать опросы на форуме.
Количество вопросов | VOTE_COUNT_QUESTIONS | Указывается максимально возможное количество вопросов в опросе.
Количество ответов | VOTE_COUNT_ANSWERS | Задается максимально возможное количество вариантов ответов на вопрос в опросе.
Шаблон для голосований | VOTE_TEMPLATE | Указывается шаблон для отображения опроса.
Не голосовать дважды VOTE_UNIQUE Указывается варианты запрета на повторное голосование в опросе:
  • 1 - в одной сессии;
  • 2 - с одним cookie;
  • 4 - с одного IP;
  • 8 - с одним ID пользователя.
Не голосовать дважды с одного IP в течение VOTE_UNIQUE_IP_DELAY Указывается период, в течение которого запрещается голосовать дважды с одного IP:
  • VOTE_UNIQUE_IP_DELAY_INPUT - указывается число;
  • VOTE_UNIQUE_IP_DELAY_SELECT - указывается:
    • S - секунд;
    • M - минут;
    • H - часов;
    • D - дней.
[/di]
Использовать AJAX в диалогах | AJAX_POST | [Y|N] При отмеченной опции будет использоваться технология AJAX при добавлении, скрытии/показе и удалении сообщений на форуме.

Настройки фото

Поле | Параметр | Описание
Тип информационного блока (используется только для проверки)[Группа] | PHOTO_GROUP_IBLOCK_TYPE | Указывается тип информационного блока фотогалерей рабочих групп.
Код информационного блока[Группа] | PHOTO_GROUP_IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будут храниться фотогалереи рабочих групп.
Включить премодерацию фото | PHOTO_MODERATION | [Y|N] При отмеченной опции будет выполняться обязательная премодерация фото.
Количество альбомов на странице | PHOTO_SECTION_PAGE_ELEMENTS | Указывается количество альбомов, отображаемых на одной странице.
Количество фото на странице | PHOTO_ELEMENTS_PAGE_ELEMENTS | Задается количество фотографий, отображаемых на одной странице.
Размер картинки-анонса фотоальбома (px) | PHOTO_ALBUM_PHOTO_THUMBS_SIZE | Указывается размер картинки-анонса фотоальбома в пикселах (px).
Размер картинки фотоальбома (px) | PHOTO_ALBUM_PHOTO_SIZE | Указывается размер картинки фотоальбома в пикселах (px).
Размер фотографии-анонса (px) | PHOTO_THUMBS_SIZE | Указывается размер фотографии-анонса в пикселах (px). Задается одна сторона картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Обязательно ограничивать размер оригинала (px, при значении 0 ограничение не происходит) | PHOTO_ORIGINAL_SIZE | Задается размер оригинала фотографии в пикселях. Фотография будет уменьшена до указанной величины. Если указано значение 0, то изменение размера не происходит. Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Минимальный размер фото для авторского знака (px) | PHOTO_WATERMARK_MIN_PICTURE_SIZE | Указывается минимальный размер (в пикселях) фото, на которых будет нанесен авторский знак. Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения. На фотографии меньшего размера знак добавлен не будет.
Файл со шрифтом (шрифт необходим для нанесения авторского знака при одиночной загрузке) | PHOTO_PATH_TO_FONT | Указывается файл со шрифтом для создания авторского знака. Шрифты предварительно загружаются в директорию \bitrix\modules\photogallery\fonts\. Поддерживаются TTF-, OTF- и PS-шрифты.
Показывать параметры авторского знака | PHOTO_SHOW_WATERMARK | [Y|N] При отмеченной опции будут показаны параметры авторского знака.
Правила нанесения авторского знака PHOTO_WATERMARK_RULES Выберите правило нанесения авторского знака: на усмотрение пользователя (USER) или обязательно наносить авторский знак (ALL).

Если выбрано значение ALL, то дополнительно необходимо настроить [dw]следующие параметры [/dw][di]
Тип авторского знака | PHOTO_WATERMARK_TYPE | Указывается тип авторского знака: картинка (PICTURE) или надпись (TEXT). Если выбрано значение PICTURE, то дополнительно необходимо настроить параметры PHOTO_WATERMARK_FILE и PHOTO_WATERMARK_FILE_ORDER Если выбрано значение TEXT, то дополнительно необходимо настроить параметры PHOTO_WATERMARK_TEXT, PHOTO_WATERMARK_COLOR и PHOTO_WATERMARK_SIZE.
Размещение авторского знака | PHOTO_WATERMARK_POSITION | Указывается размещение авторского знака на фото.
Прозрачность авторского знака | PHOTO_WATERMARK_TRANSPARENCY | Задается величина прозрачности авторского знака (в %).
Путь к картинке относительно корня сайта | PHOTO_WATERMARK_FILE | Указывается полный путь к картинке для авторского знака.
Расположение картинки на фото | PHOTO_WATERMARK_FILE_ORDER | Указывается тип расположения картинки авторского знака на фото.
Текст надписи | PHOTO_WATERMARK_TEXT | Задается текст авторского знака.
Цвет надписи (без #, например, FF00EE) | PHOTO_WATERMARK_COLOR | Указывается шестнадцатеричный код цвета надписи без использования #.
Размер надписи (% от размера картинки) | PHOTO_WATERMARK_SIZE | Задается размер надписи авторского знака в процентном соотношении от размера фото.
[/di] : PHOTO_WATERMARK_TYPE, PHOTO_WATERMARK_POSITION и PHOTO_WATERMARK_TRANSPARENCY.
Максимальный размер загружаемого файла (не должен превышать 1024Mб) (Мб) | PHOTO_PHOTO_UPLOAD_MAX_FILESIZE | Параметр определяет максимальный размер загружаемых фотографий в Мб (не должен превышать 1024Mб).
Включить рейтинг (старый) PHOTO_USE_RATING [Y|N] При отмеченной опции можно проголосовать за ту или иную фотографию; станут доступны [dw]дополнительные поля[/dw][di]
Максимальный балл PHOTO_MAX_VOTE Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам PHOTO_VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
В качестве рейтинга показывать PHOTO_DISPLAY_AS_RATING Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • rating - рейтинг;
  • vote_avg - среднее значение.
[/di].
Использовать комментарии PHOTO_USE_COMMENTS [Y|N] При отмеченной опции доступен [dw]функционал комментариев[/dw][di]
Компонент комментариев | PHOTO_COMMENTS_TYPE | Указывается какой из компонентов будет использоваться для вывода коментариев: blog (Блог) или forum (Форум).
ID форума | PHOTO_FORUM_ID | Указывается форум, в котором будут храниться комментарии пользователей.
Использовать CAPTCHA | PHOTO_USE_CAPTCHA | [Y|N] При отмеченной опции будет использоваться CAPTCHA при добавлении комментариев.
[/di] по фотографиям.
Количество фотографий для отображения в записи Живой ленты | LOG_PHOTO_COUNT | Указывается количество выводимых фотографий в одном посте Живой ленты.
Размер картинки-анонса фотоальбома для Живой ленты (px) | LOG_PHOTO_THUMBNAIL_SIZE | Указывается размер картинки-анонса фотоальбома для Живой ленты в пикселах. Задается одна сторона картинки, вторая будет высчитана пропорционально для загружаемого изображения.

Настройки поиска

Поле | Параметр | Описание
Сортировка результатов поиска по умолчанию SEARCH_DEFAULT_SORT Указывается порядок сортировки результатов поиска по умолчанию:
  • rank - по релевантности;
  • date - по дате.
Количество результатов поиска на странице | SEARCH_PAGE_RESULT_COUNT | Указывается количество результатов поиска выводимых на странице.
Отображать облако тегов на странице группы | SHOW_SEARCH_TAGS_CLOUD | [Y/N] При отмеченной опции будет включен вывод облака тегов на странице рабочей группы.
Количество тегов | SEARCH_TAGS_PAGE_ELEMENTS | Указывается количество тегов, отображаемых в облаке.
Период выборки тегов (дней) | SEARCH_TAGS_PERIOD | Параметр определяет период выборки тегов (дней).
Максимальный размер шрифта (px) | SEARCH_TAGS_FONT_MAX | Указывается максимальный размер шрифта отображения тегов (в пикселах).
Минимальный размер шрифта (px) | SEARCH_TAGS_FONT_MIN | Указывается минимальный размер шрифта отображения тегов (в пикселах).
Цвет более позднего тега (пример: "C0C0C0") | SEARCH_TAGS_COLOR_NEW | Указывается код цвета тегов, дата создания которых наиболее поздняя.
Цвет более раннего тега (пример: "FEFEFE") | SEARCH_TAGS_COLOR_OLD | Указывается код цвета тегов, дата создания которых наиболее ранняя.
Имя дополнительного фильтра по функционалу | SEARCH_FILTER_NAME | Задается имя дополнительного фильтра по функционалу.
Имя дополнительного фильтра по дате | SEARCH_FILTER_DATE_NAME | Задается имя дополнительного фильтра по дате.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork_group","",Array(
        "SEF_MODE" => "N",
        "PATH_TO_SMILE" => "/bitrix/images/socialnetwork/smile/",
        "PATH_TO_BLOG_SMILE" => "/bitrix/images/blog/smile/",
        "PATH_TO_FORUM_SMILE" => "/bitrix/images/forum/smile/",
        "SONET_PATH_TO_FORUM_ICON" => "/bitrix/images/forum/icon/",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_NOTES" => "",
        "SET_TITLE" => "Y",
        "CACHE_TIME_LONG" => "604800",
        "SET_NAV_CHAIN" => "Y",
        "LOG_SUBSCRIBE_ONLY" => "N",
        "LOG_RSS_TTL" => "60",
        "ITEM_DETAIL_COUNT" => "32",
        "ITEM_MAIN_COUNT" => "6",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_YEAR" => "Y",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "CAN_OWNER_EDIT_DESKTOP" => "Y",
        "USER_PROPERTY_MAIN" => array(),
        "USER_PROPERTY_CONTACT" => array(),
        "USER_PROPERTY_PERSONAL" => array(),
        "GROUP_PROPERTY" => array(),
        "GROUP_USE_BAN" => "Y",
        "PATH_TO_USER" => "",
        "PATH_TO_SUBSCRIBE" => "",
        "PATH_TO_GROUP_CREATE" => "",
        "PATH_TO_SEARCH_EXTERNAL" => "",
        "PATH_TO_MESSAGES_CHAT" => "/company/personal/messages/chat/#user_id#/",
        "PATH_TO_USER_CALENDAR" => "/company/personal/user/#user_id#/calendar/",
        "PATH_TO_MESSAGE_FORM_MESS" => "/company/personal/messages/form/#user_id#/#message_id#/",
        "PATH_TO_USER_LOG" => "/company/personal/log/",
        "PATH_TO_USER_TASKS_TEMPLATES" => "user/#user_id#/tasks/templates/",
        "PATH_TO_USER_TEMPLATES_TEMPLATE" => "user/#user_id#/tasks/templates/template/#action#/#template_id#/",
        "PATH_TO_BIZPROC_TASK_LIST" => "/company/personal/user/#user_id#/bizproc/",
        "PATH_TO_BIZPROC_TASK" => "/company/personal/user/#user_id#/bizproc/#id#/",
        "BLOG_GROUP_ID" => "1",
        "ALLOW_POST_MOVE" => "Y",
        "PATH_TO_BLOG_POST" => "",
        "PATH_TO_BLOG_POST_EDIT" => "",
        "PATH_TO_BLOG_DRAFT" => "",
        "PATH_TO_BLOG_BLOG" => "",
        "PATH_TO_USER_POST" => "",
        "PATH_TO_USER_POST_EDIT" => "",
        "PATH_TO_USER_DRAFT" => "",
        "PATH_TO_USER_BLOG" => "",
        "BLOG_IMAGE_MAX_WIDTH" => "800",
        "BLOG_IMAGE_MAX_HEIGHT" => "800",
        "BLOG_COMMENT_ALLOW_VIDEO" => "Y",
        "BLOG_SHOW_SPAM" => "Y",
        "BLOG_NO_URL_IN_COMMENTS" => "",
        "BLOG_NO_URL_IN_COMMENTS_AUTHORITY" => "",
        "BLOG_ALLOW_POST_CODE" => "Y",
        "BLOG_USE_GOOGLE_CODE" => "Y",
        "FORUM_ID" => "1",
        "FORUM_THEME" => "blue",
        "SHOW_VOTE" => "Y",
        "VOTE_CHANNEL_ID" => "2",
        "VOTE_GROUP_ID" => Array("2"),
        "VOTE_COUNT_QUESTIONS" => "10",
        "VOTE_COUNT_ANSWERS" => "20",
        "VOTE_TEMPLATE" => "light",
        "VOTE_UNIQUE" => array("1", "2", "4", "8"),
        "VOTE_UNIQUE_IP_DELAY" => "10 D",
        "PHOTO_GROUP_IBLOCK_TYPE" => "photos",
        "PHOTO_GROUP_IBLOCK_ID" => "8",
        "PHOTO_MODERATION" => "Y",
        "PHOTO_SECTION_PAGE_ELEMENTS" => "15",
        "PHOTO_ELEMENTS_PAGE_ELEMENTS" => "50",
        "PHOTO_ALBUM_PHOTO_THUMBS_SIZE" => "150",
        "PHOTO_ALBUM_PHOTO_SIZE" => "150",
        "PHOTO_THUMBS_SIZE" => "250",
        "PHOTO_ORIGINAL_SIZE" => "0",
        "PHOTO_WATERMARK_MIN_PICTURE_SIZE" => "200",
        "PHOTO_PATH_TO_FONT" => array(""),
        "PHOTO_SHOW_WATERMARK" => "Y",
        "PHOTO_WATERMARK_RULES" => "USER",
        "PHOTO_PHOTO_UPLOAD_MAX_FILESIZE" => "1024",
        "PHOTO_USE_RATING" => "Y",
        "PHOTO_MAX_VOTE" => "5",
        "PHOTO_VOTE_NAMES" => array("1","2","3","4","5"),
        "PHOTO_DISPLAY_AS_RATING" => "rating",
        "PHOTO_USE_COMMENTS" => "Y",
        "PHOTO_FORUM_ID" => "4",
        "PHOTO_USE_CAPTCHA" => "Y",
        "SEARCH_DEFAULT_SORT" => "rank",
        "SEARCH_PAGE_RESULT_COUNT" => "10",
        "SEARCH_TAGS_PAGE_ELEMENTS" => "100",
        "SEARCH_TAGS_PERIOD" => "",
        "SEARCH_TAGS_FONT_MAX" => "50",
        "SEARCH_TAGS_FONT_MIN" => "10",
        "SEARCH_TAGS_COLOR_NEW" => "3E74E6",
        "SEARCH_TAGS_COLOR_OLD" => "C0C0C0",
        "SEARCH_FILTER_NAME" => "sonet_search_filter",
        "SEARCH_FILTER_DATE_NAME" => "sonet_search_filter_date",
        "SM_THEME" => "grey",
        "USE_MAIN_MENU" => "Y",
        "MAIN_MENU_TYPE" => "left",
        "USE_SHARE" => "Y",
        "SHARE_HIDE" => "Y",
        "SHARE_TEMPLATE" => "",
        "SHARE_HANDLERS" => array("delicious","lj","twitter"),
        "SHARE_SHORTEN_URL_LOGIN" => "",
        "SHARE_SHORTEN_URL_KEY" => "",
        "SHOW_RATING" => "Y",
        "RATING_ID" => "1",
        "VARIABLE_ALIASES" => Array(
            "user_id" => "user_id",
            "page" => "page",
            "group_id" => "group_id",
            "message_id" => "message_id"
        )
    ),
false
);?>


Социальная сеть - пользователь (комплексный компонент)

Секции настроек компонента

Описание socialnetwork_user

Комплексный компонент служит для создания личного раздела пользователя сайта. Настройки компонента обширны и позволяют управлять отображением тех или иных страниц в публичной части, внешним видом социальной сети и т.д. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Социальная сеть - пользователь.

Внешний вид

Поле | Параметр | Описание
Количество элементов, выводимых на страницу | ITEM_DETAIL_COUNT | Параметр определяет количество элементов, отображаемых на одной странице. Все элементы будут выведены с помощью постраничной навигации.
Количество элементов, выводимых на главной странице профайла | ITEM_MAIN_COUNT | Параметр определяет количество элементов в списках на главной странице профайла пользователя.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Разрешить владельцу изменять гаджеты на главной странице профиля и группы | CAN_OWNER_EDIT_DESKTOP | [Y|N] При отмеченной опции владелец группы может изменять гаджеты на главной странице профиля и группы.
Тема меню | SM_THEME | Указывается тема шаблона меню.
Использовать ключевые слова для группы | GROUP_USE_KEYWORDS | [Y|N] При отмеченной опции включается возможность использовать ключевые слова для группы.
Размер изображения группы в списке | GROUP_THUMBNAIL_SIZE | Указывается размер изображения группы в списке.
Размер аватара в Живой ленте (сообщение) | LOG_THUMBNAIL_SIZE | Указывается размер аватара в Живой ленте (для сообщения).
Размер аватара в Живой ленте (комментарий) | LOG_COMMENT_THUMBNAIL_SIZE | Указывается размер аватара в Живой ленте (для комментария).
Использовать новый формат шаблона Живой ленты | LOG_NEW_TEMPLATE | [Y|N] При отмеченной опции будет использован новый формат шаблона Живой ленты.
Не требовать авторизацию для просмотра Живой ленты | LOG_AUTH | [Y|N] При отмеченной опции для просмотра Живой ленты не потребуется авторизация.
Отображать меню соцсети в шаблоне сайта USE_MAIN_MENU [Y|N] При отмеченной опции меню социальной сети будет отображаться в меню, указанном в параметре [dw]Добавлять пункты к меню типа[/dw][di]
Добавлять пункты к меню типа MAIN_MENU_TYPE Указывается в какой тип меню шаблона сайта добавлять меню соцсети.
[/di].

Примечание: данная опция будет работать только при включенном параметре Откладывать выполнение шаблона меню в компоненте Меню (bitrix:menu), название которого указано в параметре Добавлять пункты к меню типа.
Отображать панель соц. закладок | USE_SHARE | [Y|N] При отмеченной опции на странице будет отображаться панель соц. закладок.
Не раскрывать панель соц. закладок по умолчанию | SHARE_HIDE | [Y|N] При отмеченной опции по умолчанию панель соц. закладок будет свернута.
Шаблон компонента панели соц. закладок | SHARE_TEMPLATE | Указывается шаблон для отображения панели соц. закладок
Используемые соц. закладки и сети SHARE_HANDLERS Указываются соц. закладки и сети, которые будут доступны на странице:
  • Delicious
  • Facebook*
  • Livejournal
  • Мой мир@Mail.Ru
  • Twitter
  • ВКонтакте

* деятельность организации запрещена в Российской Федерации.
Логин для bit.ly | SHARE_SHORTEN_URL_LOGIN | Указывается логин для сервиса коротких ссылок bit.ly.
Ключ для bit.ly | SHARE_SHORTEN_URL_KEY | Указывается пароль для сервиса коротких ссылок bit.ly.
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.
Рейтинг | RATING_ID | Указывается какой будет использоваться рейтинг.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).

Шаблоны ссылок

Поле | Параметр | Описание
Шаблон пути к странице группы | PATH_TO_GROUP | Указывается путь к странице рабочей группы.
Страница подписки на обновления группы | PATH_TO_GROUP_SUBSCRIBE | Указывается путь к странице подписки на обновления группы.
Шаблон пути к странице поиска групп | PATH_TO_GROUP_SEARCH | Указывается путь к странице поиска рабочих групп.
Внешний путь к странице поиска пользователей | PATH_TO_SEARCH_EXTERNAL | Указывается путь к странице, на которой выполняется поиск сотрудников.
Шаблон пути к микроблогу группы | PATH_TO_GROUP_MICROBLOG | Указывается путь к странице микроблога группы.
Перенаправлять запрос на страницу приглашения пользователей после создания группы | ALLOW_GROUP_CREATE_REDIRECT_REQUEST | [Y|N] При отмеченной опции после создания группы будет открываться страница с формой приглашения пользователей вступить в эту группу.
Страница приглашения пользователей в группу | GROUP_CREATE_REDIRECT_REQUEST | Указывается путь к странице приглашения пользователей вступить в группу.

Управление адресами страниц

Поле Параметр Описание
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - главная страница социальной сети;
  • user_reindex - страница индексации социальной сети;
  • user_content_search - страница поиска контента пользователя;
  • user - страница профиля пользователя;
  • user_friends - страница друзей пользователя;
  • user_friends_add - страница с формой добавления друга;
  • user_friends_delete - страница с формой удаления друга;
  • user_groups - страница списка рабочих групп, в которых участвует пользователь;
  • user_groups_add - страница создания рабочей группы;
  • group_create - страница с формой создания группы;
  • user_profile_edit - страница изменения профиля пользователя;
  • user_settings_edit - страница изменения персональных настроек приватности пользователя;
  • user_features - страница настроек функционалов пользователя;
  • group_request_group_search - страница с формой поиска групп для приглашения пользователя;
  • group_request_user - страница с формой приглашения пользователя вступить в группу;
  • search - страница поиска пользователей;
  • message_form - страница с формой отправки сообщения;
  • message_form_mess - страница ответа на сообщение;
  • user_ban - страница черного списка пользователя;
  • messages_chat - страница чата с пользователем;
  • messages_input - страница с формой входящих сообщений;
  • messages_input_user - страница с формой входящих сообщений с фильтром по пользователю;
  • messages_output - страница с формой исходящих сообщений;
  • messages_output_user - страница с формой исходящих сообщений с фильтром по пользователю;
  • messages_users - страница пользователей, с которыми ведется переписка;
  • messages_users_messages - страница переписки с пользователем;
  • log - страница лога обновлений;
  • subscribe - страница подписок пользователя;
  • user_subscribe - страница подписки на пользователя;
  • user_photo - страница фотогалереи пользователя;
  • user_calendar - страница календарей пользователя;
  • user_files - страница файлов пользователя;
  • user_blog - страница блога пользователя;
  • user_blog_post_edit - страница редактирования сообщения блога пользователя;
  • user_blog_rss - страница RSS блога пользователя;
  • user_blog_draft - страница черновиков блога пользователя;
  • user_blog_post - страница сообщения блога пользователя;
  • user_blog_moderation - страница модерации блога пользователя;
  • user_forum - страница форума пользователя;
  • user_forum_topic_edit - страница редактирования темы форума пользователя;
  • user_forum_topic - страница темы форума пользователя;
  • bizproc - страница бизнес-процессов пользователя;
  • video_call - страница с видеозвонком пользователю.
[/di] : SEF_FOLDER, SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.

При выключенном режиме ЧПУ необходимо указать имена следующих переменных:
  • user_id - имя переменной для идентификатора пользователя;
  • page - имя переменной для страницы;
  • group_id - имя переменной для идентификатора группы;
  • message_id - имя переменной для сообщения;
  • task_id - имя переменной для задачи.
[/di] .

Настройки кеширования

Поле | Параметр | Описание
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Время кеширования остальных страниц | CACHE_TIME_LONG | Указывается время кеширования страниц, начиная со второй.

Дополнительные настройки

Поле | Параметр | Описание
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта.
Путь к папке со смайликами для блогов относительно корня сайта | PATH_TO_BLOG_SMILE | Указывается путь к папке со смайлами для блогов относительно корня сайта.
??? Путь к папке со смайликами для форума относительно корня сайта | PATH_TO_FORUM_SMILE | Указывается путь к папке со смайлами для форума относительно корня сайта.
??? Путь к папке с иконками для форума относительно корня сайта | SONET_PATH_TO_FORUM_ICON | Указывается путь к папке с иконками относительно корня сайта.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на каждой странице личного раздела пользователя будет отображен соответствующий заголовок.
Устанавливать цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочке навигации будут отображаться переходы по страницам социальной сети.
Не ограничивать набор полей профиля пользователя ALLOWALL_USER_PROFILE_FIELDS [Y|N] При включенной опции будет снято ограничение набора полей профиля пользователя и станут недоступны поля [dw]настройки свойств пользователя[/dw][di]Станут недоступны следующие поля:
  1. Главные свойства пользователя;
  2. Главные доп. свойства пользователя;
  3. Свойства пользователя для контакта;
  4. Доп. свойства пользователя для контакта;
  5. Персональные свойства пользователя;
  6. Персональные доп. свойства пользователя.
[/di].
Главные свойства пользователя* | USER_FIELDS_MAIN | Указываются главные свойства, которые должны быть отображены в области основной информации о пользователе.
Главные доп. свойства пользователя * | USER_PROPERTY_MAIN | Указываются дополнительные свойства, которые также должны быть отображены в области основной информации о пользователе.
Свойства пользователя для контакта * | USER_FIELDS_CONTACT | Указываются свойства пользователя, которые должны быть отображены в области контактной информации.
Доп. свойства пользователя для контакта * | USER_PROPERTY_CONTACT | Указываются дополнительные свойства пользователя, которые также должны быть отображены в области контактной информации.
Персональные свойства пользователя * | USER_FIELDS_PERSONAL | Указываются свойства пользователя, которые должны быть отображены в области личной информации.
Персональные доп. свойства пользователя * | USER_PROPERTY_PERSONAL | Указываются дополнительные свойства пользователя, которые также должны быть отображены в области личной информации.
Редактируемые свойства * | EDITABLE_FIELDS | Указываются свойства, которые будут доступны пользователю для редактирования по ссылке Изменить профиль.
Показывать год рождения SHOW_YEAR Параметр определяет для каких сотрудников должен быть отображен год рождения:
  • Y - для всех сотрудников;
  • M - только мужчинам;
  • N - никому.
Поля пользователя для простой формы поиска | USER_FIELDS_SEARCH_SIMPLE | Указываются свойства пользователя, которые должны быть отображены на простой форме поиска сотрудника.
Пользовательские свойства пользователя для простой формы поиска | USER_PROPERTIES_SEARCH_SIMPLE | Указываются дополнительные свойства пользователя, которые также должны быть отображены на простой форме поиска сотрудника.
Поля пользователя для расширенной формы поиска | USER_FIELDS_SEARCH_ADV | Указываются свойства пользователя, которые должны быть отображены на расширенной форме поиска сотрудника.
Пользовательские свойства пользователя для расширенной формы поиска | USER_PROPERTIES_SEARCH_ADV | Указываются дополнительные свойства пользователя, которые также должны быть отображены на расширенной форме поиска сотрудника.
Поля пользователя для вывода в списке | SONET_USER_FIELDS_LIST | Указываются поля пользователя, которые должны быть отображены при показе списка сотрудников.
Пользовательские свойства пользователя для вывода в списке | SONET_USER_PROPERTY_LIST | Указываются дополнительные свойства пользователя, которые также должны быть отображены при показе списка сотрудников.
Поля пользователя, по которым возможен поиск | SONET_USER_FIELDS_SEARCHABLE | Указываются поля пользователя, по которым будет осуществляться поиск сотрудников.
Пользовательские свойства пользователя, по которым возможен поиск | SONET_USER_PROPERTY_SEARCHABLE | Указываются дополнительные свойства пользователя, по которым также будет осуществляться поиск сотрудников.
Использовать AJAX в диалогах | FORUM_AJAX_POST | [Y|N] При отмеченной опции в диалогах будет использоваться технология AJAX.
Учитывать рейтинг в сортировке при выводе списка пользователей | ALLOW_RATING_SORT | [Y|N] При отмеченной опции при выводе списка пользователей будет учитываться их рейтинг.
* - эти поля компонента не будут видны вообще в настройках компонента после того, как администратор в первый раз сделает [dw]Настройку показа полей[/dw][di] [image] [/di] в общем виде карточки в профиле.

Настройки блогов

Поле | Параметр | Описание
Группа блогов для блогов | BLOG_GROUP_ID | Указывается идентификатор группы блогов, в которой будут храниться блоги социальной сети.
Разрешить перенос сообщений между блогами ALLOW_POST_MOVE [Y|N] При отмеченной опции можно будет переносить сообщения между блогами; станут доступны [dw]дополнительные поля.[/dw][di]
Шаблон пути к странице сообщения в блогах | PATH_TO_BLOG_POST | Указывается путь к странице сообщения в блогах.
Шаблон пути к редактированию сообщения в блогах | PATH_TO_BLOG_POST_EDIT | Указывается путь к странице редактирования сообщения в блогах.
Шаблон пути к черновикам в блогах | PATH_TO_BLOG_DRAFT | Указывается путь к черновикам в блогах.
Шаблон пути к блогу в блогах | PATH_TO_BLOG_BLOG | Указывается путь к блогу в блогах.
Шаблон пути к редактированию сообщения блога группы в соц. сети | PATH_TO_GROUP_POST_EDIT | Указывается путь к странице редактирования сообщения блога группы.
Шаблон пути к черновикам блога группы в соц. сети | PATH_TO_GROUP_DRAFT | Указывается путь к черновикам блога группы.
Шаблон пути к блогу группы в соц. сети | PATH_TO_GROUP_BLOG | Указывается путь к блогу группы.
[/di]
Шаблон пути к странице сообщения блога группы в соц. сети | PATH_TO_GROUP_POST | Указывается путь к странице сообщения блога группы.
Максимальная ширина изображения | BLOG_IMAGE_MAX_WIDTH | Указывается максимальная ширина изображения в посте блога в пикселях.
Максимальная высота изображения | BLOG_IMAGE_MAX_HEIGHT | Указывается максимальная высота изображения в посте блога в пикселях.
Использовать AJAX для комментариев | BLOG_COMMENT_AJAX_POST | [Y|N] При отмеченной опции для публикации комментариев будет использоваться AJAX.
Разрешить вставку видео в комментарии | BLOG_COMMENT_ALLOW_VIDEO | [Y|N] При отмеченной опции в комментариях блога можно вставлять видео.
Разрешить загрузку изображений в комментариях BLOG_COMMENT_ALLOW_IMAGE_UPLOAD Указывается кому можно загружать изображения в комментарии к блогу:
  • А - всем;
  • R - зарегистрированным пользователям;
  • N - никому.
Показывать администраторам ссылку на все комментарии пользователя | BLOG_SHOW_SPAM | [Y|N] При отмеченной опции будет показываться ссылка, ведущая на страницу со всеми постами пользователя.
Запретить вставку ссылок в комментариях | BLOG_NO_URL_IN_COMMENTS | Указывается кому запрещается постить ссылки в комментариях блога: Никому, Анонимным пользователям или Всем.
Минимальный авторитет, с которым пользователи могут вставлять ссылки в комментариях | BLOG_NO_URL_IN_COMMENTS_AUTHORITY | Указывается минимальный авторитет пользователя, который может вставлять ссылки в комментарии.
Использовать символьный код сообщений как идентификатор BLOG_ALLOW_POST_CODE [Y|N] При отмеченной опции URL поста блога будет создаваться с помощью транслитеризации заголовка поста; станет доступным [dw]дополнительное поле[/dw][di]
Использовать внешний сервис для перевода кода сообщений BLOG_USE_GOOGLE_CODE [Y|N] При отмеченной опции URL поста будет создаваться с помощью заголовка, переведенного внешним переводчиком, данные которого указаны в группе опций Внешние сервисы перевода в Настройках главного модуля.
[/di].
Использовать [CUT] для сообщений | BLOG_USE_CUT | [Y|N] При отмеченной опции в посте можно будет использовать тег [CUT]. После тега [CUT] текст в посте скрывается, вместо текста появляется ссылка Читать подробнее..., при переходе по которой открывается уже полное сообщение.

Настройки форума

Поле | Параметр | Описание
Форум | FORUM_ID | Указывается идентификатор форума, в котором будут храниться темы и сообщения пользователей социальной сети.
Темы | FORUM_THEME | Выбирается одна из восьми доступных тем оформления шаблона.
Разрешить опросы SHOW_VOTE [Y|N] При отмеченной опции будет выведен опрос. Создание опроса доступно только при создании новой темы на форуме. При выборе данной опции станут доступны [dw]дополнительные поля[/dw][di]
Группа опросов | VOTE_CHANNEL_ID | Указывается группа опросов, в которой будет создан опрос.
Группы пользователей, которые могут создавать опрос | VOTE_GROUP_ID | Задаются группы пользователей, которым разрешено создавать опросы на форуме.
Количество вопросов | VOTE_COUNT_QUESTIONS | Указывается максимально возможное количество вопросов в опросе.
Количество ответов | VOTE_COUNT_ANSWERS | Задается максимально возможное количество вариантов ответов на вопрос в опросе.
Шаблон для голосований | VOTE_TEMPLATE | Указывается шаблон для отображения опроса.
Не голосовать дважды VOTE_UNIQUE Указывается варианты запрета на повторное голосование в опросе:
  • 1 - в одной сессии;
  • 2 - с одним cookie;
  • 4 - с одного IP;
  • 8 - с одним ID пользователя.
Не голосовать дважды с одного IP в течение VOTE_UNIQUE_IP_DELAY Указывается период, в течение которого запрещается голосовать дважды с одного IP:
  • VOTE_UNIQUE_IP_DELAY_INPUT - указывается число;
  • VOTE_UNIQUE_IP_DELAY_SELECT - указывается:
    • S - секунд;
    • M - минут;
    • H - часов;
    • D - дней.
[/di] .
Использовать AJAX в диалогах | AJAX_POST | [Y|N] При отмеченной опции будет использоваться технология AJAX при добавлении, скрытии/показе и удалении сообщений на форуме.

Настройки фото

Поле | Параметр | Описание
Тип информационного блока (используется только для проверки) [Пользователь] | PHOTO_USER_IBLOCK_TYPE | Указывается тип информационного блока фотогалерей.
Код информационного блока [Пользователь] | PHOTO_USER_IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором будут храниться фотогалереи пользователей.
Включить премодерацию фото | PHOTO_MODERATION | [Y|N] При отмеченной опции будет выполняться обязательная премодерация фото.
Количество альбомов на странице | PHOTO_SECTION_PAGE_ELEMENTS | Указывается количество альбомов, отображаемых на одной странице.
Количество фото на странице | PHOTO_ELEMENTS_PAGE_ELEMENTS | Задается количество фотографий, отображаемых на одной странице.
Размер картинки-анонса фотоальбома (px) | PHOTO_ALBUM_PHOTO_THUMBS_SIZE | Указывается размер картинки-анонса фотоальбома в пикселях (px).
Размер картинки фотоальбома (px) | PHOTO_ALBUM_PHOTO_SIZE | Указывается размер картинки фотоальбома в пикселях (px).
Размер фотографии-анонса (px) | PHOTO_THUMBS_SIZE | Указывается размер фотографии-анонса в пикселях (px). Задается одна сторона картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Обязательно ограничивать размер оригинала (px) (при значении 0 ограничение не происходит) | PHOTO_ORIGINAL_SIZE | Задается размер оригинала фотографии в пикселях. Фотография будет уменьшена до указанной величины. Если указано значение 0, то изменение размера не происходит. Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Минимальный размер фото для авторского знака (px) | PHOTO_WATERMARK_MIN_PICTURE_SIZE | Указывается минимальный размер (в пикселях) фото, на которых будет нанесен авторский знак. Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения. На фотографии меньшего размера знак добавлен не будет.
Файл со шрифтом (шрифт необходим для нанесения авторского знака при одиночной загрузке) | PHOTO_PATH_TO_FONT | Указывается файл со шрифтом для создания авторского знака. Шрифты предварительно загружаются в директорию \bitrix\modules\photogallery\fonts\. Поддерживаются TTF-, OTF- и PS-шрифты.
Показывать параметры авторского знака | PHOTO_SHOW_WATERMARK | [Y|N] При отмеченной опции будут показаны параметры авторского знака.
Правила нанесения авторского знака PHOTO_WATERMARK_RULES Выберите правило нанесения авторского знака: на усмотрение пользователя (USER) или обязательно наносить авторский знак (ALL).

Если выбрано значение ALL, то дополнительно необходимо настроить [dw]следующие параметры[/dw][di]
Тип авторского знака PHOTO_WATERMARK_TYPE Указывается тип авторского знака: картинка (PICTURE) или надпись (TEXT).

Если выбрано значение PICTURE, то дополнительно необходимо настроить параметры PHOTO_WATERMARK_FILE и PHOTO_WATERMARK_FILE_ORDER

Если выбрано значение TEXT, то дополнительно необходимо настроить параметры PHOTO_WATERMARK_TEXT, PHOTO_WATERMARK_COLOR и PHOTO_WATERMARK_SIZE.
Размещение авторского знака PHOTO_WATERMARK_POSITION Указывается размещение авторского знака на фото:
  • Без изменений (usual);
  • Растянуть (resize);
  • Замостить (repeat).
Прозрачность авторского знака | PHOTO_WATERMARK_TRANSPARENCY | Задается величина прозрачности авторского знака (в %).
Путь к картинке относительно корня сайта | PHOTO_WATERMARK_FILE | Указывается полный путь к картинке для авторского знака.
Расположение картинки на фото PHOTO_WATERMARK_FILE_ORDER Указывается тип расположения картинки авторского знака на фото:
  • Сверху слева (tl);
  • Сверху по центру (tc);
  • Сверху справа (tr);
  • Cлева (ml);
  • По центру (mc);
  • Cправа (mr);
  • Снизу cлева (bl);
  • Снизу по центру (bc);
  • Снизу cправа (br).
Текст надписи | PHOTO_WATERMARK_TEXT | Задается текст авторского знака.
Цвет надписи (без #, например, FF00EE) | PHOTO_WATERMARK_COLOR | Указывается шестнадцатеричный код цвета надписи без использования #.
Размер надписи (% от размера картинки) | PHOTO_WATERMARK_SIZE | Задается размер надписи авторского знака в процентном соотношении от размера фото.
[/di] : PHOTO_WATERMARK_TYPE, PHOTO_WATERMARK_POSITION и PHOTO_WATERMARK_TRANSPARENCY.
Максимальный размер загружаемого файла (не должен превышать 1024Mб) (Мб) | PHOTO_PHOTO_UPLOAD_MAX_FILESIZE | Параметр определяет максимальный размер загружаемых фотографий в Мб (не должен превышать 1024Mб).
Включить рейтинг (старый) PHOTO_USE_RATING [Y|N] При отмеченной опции можно проголосовать за ту или иную фотографию; станут доступны [dw]дополнительные поля[/dw][di]
Максимальный балл PHOTO_MAX_VOTE Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам PHOTO_VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
В качестве рейтинга показывать PHOTO_DISPLAY_AS_RATING Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • Рейтинг (rating);
  • Среднее значение (vote_avg).
[/di].
Использовать комментарии PHOTO_USE_COMMENTS [Y|N] При отмеченной опции доступен [dw]функционал комментариев[/dw][di]
Компонент комментариев | PHOTO_COMMENTS_TYPE | Указывается какой из компонентов будет использоваться для вывода комментариев: blog (Блог) или forum (Форум).
ID форума | PHOTO_FORUM_ID | Указывается форум, в котором будут храниться комментарии пользователей.
Использовать CAPTCHA | PHOTO_USE_CAPTCHA | [Y|N] При отмеченной опции будет использоваться CAPTCHA при добавлении комментариев.
[/di] по фотографиям.
Шаблон пути к фотогалерее группы | PATH_TO_GROUP_PHOTO | Указывается путь к фотогалерее группы социальной сети.
Шаблон пути к альбому фотогалереи группы | PATH_TO_GROUP_PHOTO_SECTION | Указывается путь к альбому фотогалереи группы социальной сети.
Шаблон пути к элементу фотогалереи группы | PATH_TO_GROUP_PHOTO_ELEMENT | Указывается путь к элементу фотогалереи группы социальной сети.
Количество фотографий для отображения в записи Живой ленты | LOG_PHOTO_COUNT | Указывается количество выводимых фотографий в одном посте Живой ленты.
Размер картинки-анонса фотоальбома для Живой ленты (px) | LOG_PHOTO_THUMBNAIL_SIZE | Указывается размер картинки-анонса фотоальбома для Живой ленты в пикселях. Задается одна сторона картинки, вторая будет высчитана пропорционально для загружаемого изображения.

Настройки поиска

Поле | Параметр | Описание
Сортировка результатов поиска по умолчанию SEARCH_DEFAULT_SORT Параметр определяет сортировку результатов поиска по умолчанию:
  • по релевантности (rank);
  • по дате (date).
Количество результатов поиска на странице | SEARCH_PAGE_RESULT_COUNT | Указывается количество результатов поиска на одной странице.
Количество тегов | SEARCH_TAGS_PAGE_ELEMENTS | Указывается количество тегов на одной странице.
Период выборки тегов (дней) | SEARCH_TAGS_PERIOD | Указывается количество дней для выборки тегов.
Максимальный размер шрифта (px) | SEARCH_TAGS_FONT_MAX | Указывается максимальный размер шрифта тегов в пикселях (px).
Минимальный размер шрифта (px) | SEARCH_TAGS_FONT_MIN | Указывается минимальный размер шрифта тегов в пикселях (px)
Цвет более позднего тега (пример: "C0C0C0") | SEARCH_TAGS_COLOR_NEW | Указывается цвет более позднего тега без #.
Цвет более раннего тега (пример: "FEFEFE") | SEARCH_TAGS_COLOR_OLD | Указывается цвет более раннего тега без #.
Имя дополнительного фильтра по функционалу | SEARCH_FILTER_NAME | Указывается имя дополнительного фильтра по функционалу.
Имя дополнительного фильтра по дате | SEARCH_FILTER_DATE_NAME | Указывается имя дополнительного фильтра по дате.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork_user","",Array(
        "ALLOWALL_USER_PROFILE_FIELDS" => "N",
        "GROUP_THUMBNAIL_SIZE" => "50",
        "GROUP_USE_KEYWORDS" => "Y",
        "LOG_THUMBNAIL_SIZE" => "50",
        "LOG_COMMENT_THUMBNAIL_SIZE" => "30",
        "LOG_NEW_TEMPLATE" => "N",
        "SEF_MODE" => "N",
        "PATH_TO_SMILE" => "/bitrix/images/socialnetwork/smile/",
        "PATH_TO_BLOG_SMILE" => "/bitrix/images/blog/smile/",
        "PATH_TO_FORUM_SMILE" => "/bitrix/images/forum/smile/",
        "SONET_PATH_TO_FORUM_ICON" => "/bitrix/images/forum/icon/",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_NOTES" => "",
        "SET_TITLE" => "Y",
        "CACHE_TIME_LONG" => "604800",
        "SET_NAV_CHAIN" => "Y",
        "ITEM_DETAIL_COUNT" => "32",
        "ITEM_MAIN_COUNT" => "6",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "CAN_OWNER_EDIT_DESKTOP" => "Y",
        "USER_FIELDS_MAIN" => array(),
        "USER_PROPERTY_MAIN" => array(),
        "USER_FIELDS_CONTACT" => array(),
        "USER_PROPERTY_CONTACT" => array(),
        "USER_FIELDS_PERSONAL" => array(),
        "USER_PROPERTY_PERSONAL" => array(),
        "PATH_TO_GROUP" => "",
        "PATH_TO_GROUP_SUBSCRIBE" => "",
        "PATH_TO_GROUP_SEARCH" => "",
        "PATH_TO_SEARCH_EXTERNAL" => "",
        "EDITABLE_FIELDS" => array("LOGIN","NAME","SECOND_NAME","LAST_NAME","EMAIL","PERSONAL_BIRTHDAY","PERSONAL_WWW","PERSONAL_ICQ","PERSONAL_GENDER","PERSONAL_PHOTO","PERSONAL_PHONE","PERSONAL_FAX","PERSONAL_MOBILE","PERSONAL_PAGER","PERSONAL_COUNTRY","PERSONAL_STATE","PERSONAL_CITY","PERSONAL_ZIP","PERSONAL_STREET","PERSONAL_MAILBOX"),
        "SHOW_YEAR" => "Y",
        "USER_FIELDS_SEARCH_SIMPLE" => array("PERSONAL_GENDER","PERSONAL_CITY"),
        "USER_PROPERTIES_SEARCH_SIMPLE" => array(),
        "USER_FIELDS_SEARCH_ADV" => array("PERSONAL_GENDER","PERSONAL_COUNTRY","PERSONAL_CITY"),
        "USER_PROPERTIES_SEARCH_ADV" => array(),
        "SONET_USER_FIELDS_LIST" => array("PERSONAL_BIRTHDAY","PERSONAL_GENDER","PERSONAL_CITY"),
        "SONET_USER_PROPERTY_LIST" => array(),
        "SONET_USER_FIELDS_SEARCHABLE" => array("LOGIN","NAME","SECOND_NAME","LAST_NAME","PERSONAL_BIRTHDAY","PERSONAL_BIRTHDAY_YEAR","PERSONAL_BIRTHDAY_DAY","PERSONAL_PROFESSION","PERSONAL_GENDER","PERSONAL_COUNTRY","PERSONAL_STATE","PERSONAL_CITY","PERSONAL_ZIP","PERSONAL_STREET","PERSONAL_MAILBOX","WORK_COMPANY","WORK_DEPARTMENT","WORK_POSITION","WORK_COUNTRY","WORK_STATE","WORK_CITY","WORK_ZIP","WORK_STREET","WORK_MAILBOX"),
        "SONET_USER_PROPERTY_SEARCHABLE" => array(),
        "BLOG_GROUP_ID" => "1",
        "ALLOW_POST_MOVE" => "Y",
        "PATH_TO_BLOG_POST" => "",
        "PATH_TO_BLOG_POST_EDIT" => "",
        "PATH_TO_BLOG_DRAFT" => "",
        "PATH_TO_BLOG_BLOG" => "",
        "PATH_TO_GROUP_POST" => "",
        "PATH_TO_GROUP_POST_EDIT" => "",
        "PATH_TO_GROUP_DRAFT" => "",
        "PATH_TO_GROUP_BLOG" => "",
        "BLOG_IMAGE_MAX_WIDTH" => "800",
        "BLOG_IMAGE_MAX_HEIGHT" => "800",
        "BLOG_COMMENT_ALLOW_VIDEO" => "Y",
        "BLOG_SHOW_SPAM" => "Y",
        "BLOG_NO_URL_IN_COMMENTS" => "",
        "BLOG_NO_URL_IN_COMMENTS_AUTHORITY" => "",
        "BLOG_ALLOW_POST_CODE" => "Y",
        "BLOG_USE_GOOGLE_CODE" => "Y",
        "PATH_TO_GROUP_MICROBLOG" => "/workgroups/group/#group_id#/microblog/",
        "FORUM_AJAX_POST" => "N",
        "FORUM_ID" => "1",
        "FORUM_THEME" => "blue",
        "SHOW_VOTE" => "Y",
        "VOTE_CHANNEL_ID" => "2",
        "VOTE_GROUP_ID" => Array("2"),
        "VOTE_COUNT_QUESTIONS" => "10",
        "VOTE_COUNT_ANSWERS" => "20",
        "VOTE_TEMPLATE" => "light",
        "VOTE_UNIQUE" => array("1", "2", "4", "8"),
        "VOTE_UNIQUE_IP_DELAY" => "10 D",
        "PHOTO_USER_IBLOCK_TYPE" => "photos",
        "PHOTO_USER_IBLOCK_ID" => "8",
        "PHOTO_MODERATION" => "Y",
        "PHOTO_SECTION_PAGE_ELEMENTS" => "15",
        "PHOTO_ELEMENTS_PAGE_ELEMENTS" => "50",
        "PHOTO_ALBUM_PHOTO_THUMBS_SIZE" => "150",
        "PHOTO_ALBUM_PHOTO_SIZE" => "150",
        "PHOTO_THUMBS_SIZE" => "250",
        "PHOTO_ORIGINAL_SIZE" => "0",
        "PHOTO_WATERMARK_MIN_PICTURE_SIZE" => "200",
        "PHOTO_PATH_TO_FONT" => array(""),
        "PHOTO_SHOW_WATERMARK" => "Y",
        "PHOTO_WATERMARK_RULES" => "USER",
        "PHOTO_PHOTO_UPLOAD_MAX_FILESIZE" => "1024",
        "PHOTO_USE_RATING" => "Y",
        "PHOTO_MAX_VOTE" => "5",
        "PHOTO_VOTE_NAMES" => array("1","2","3","4","5"),
        "PHOTO_DISPLAY_AS_RATING" => "rating",
        "PHOTO_USE_COMMENTS" => "Y",
        "PHOTO_FORUM_ID" => "4",
        "PHOTO_USE_CAPTCHA" => "Y",
        "PATH_TO_GROUP_PHOTO" => "/workgroups/group/#group_id#/photo/",
        "PATH_TO_GROUP_PHOTO_SECTION" => "/workgroups/group/#group_id#/photo/album/#section_id#/",
        "PATH_TO_GROUP_PHOTO_ELEMENT" => "/workgroups/group/#group_id#/photo/#section_id#/#element_id#/",
        "LOG_PHOTO_COUNT" => "6",
        "LOG_PHOTO_THUMBNAIL_SIZE" => "48",
        "ALLOW_GROUP_CREATE_REDIRECT_REQUEST" => "Y",
        "GROUP_CREATE_REDIRECT_REQUEST" => "/workgroups/group/#group_id#/user_search/",
        "SEARCH_DEFAULT_SORT" => "rank",
        "SEARCH_PAGE_RESULT_COUNT" => "10",
        "SEARCH_TAGS_PAGE_ELEMENTS" => "100",
        "SEARCH_TAGS_PERIOD" => "",
        "SEARCH_TAGS_FONT_MAX" => "50",
        "SEARCH_TAGS_FONT_MIN" => "10",
        "SEARCH_TAGS_COLOR_NEW" => "3E74E6",
        "SEARCH_TAGS_COLOR_OLD" => "C0C0C0",
        "SEARCH_FILTER_NAME" => "sonet_search_filter",
        "SEARCH_FILTER_DATE_NAME" => "sonet_search_filter_date",
        "SM_THEME" => "grey",
        "USE_MAIN_MENU" => "Y",
        "MAIN_MENU_TYPE" => "left",
        "USE_SHARE" => "Y",
        "SHARE_HIDE" => "N",
        "SHARE_TEMPLATE" => "",
        "SHARE_HANDLERS" => array("delicious","lj","twitter"),
        "SHARE_SHORTEN_URL_LOGIN" => "",
        "SHARE_SHORTEN_URL_KEY" => "",
        "ALLOW_RATING_SORT" => "Y",
        "SHOW_RATING" => "Y",
        "RATING_ID" => array(),
        "RATING_TYPE" => "like",
        "VARIABLE_ALIASES" => Array(
            "user_id" => "user_id",
            "page" => "page",
            "group_id" => "group_id",
            "message_id" => "message_id",
            "task_id" => "task_id"
        )
    ),
false
);?>


Меню сообщений

Описание socialnetwork.blog.menu

Компонент выводит меню блогов социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Меню сообщений.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
Шаблон пути к главной странице сообщений | PATH_TO_BLOG | Указывается путь к главной странице блога.
Шаблон пути к недописанным сообщениям | PATH_TO_DRAFT | Указывается путь к недописанным сообщениям социальной сети.
Шаблон пути к странице редактирования сообщения | PATH_TO_POST_EDIT | Указывается путь к странице редактирования сообщения блога социальной сети.
Шаблон пути к странице пользователя | PATH_TO_USER | Указывается путь к странице пользователя блога социальной сети.
Дополнительные настройки
Добавлять пункт в цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт с названием блога.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога.
Имя переменной для идентификатора сообщения | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога.
Имя переменной для идентификатора пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.blog.menu","",Array(
    "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
    "PATH_TO_BLOG_INDEX" => "blog_s.php",
    "PATH_TO_DRAFT" => "blog_b_draft.php?page=draft&blog=#blog#",
    "PATH_TO_POST_EDIT" => "blog_p_edit.php?page=post_edit&blog=#blog#&post_id=#post_id#",
    "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
    "PATH_TO_USER_FRIENDS" => "blog_friends.php?page=user_friend&user_id=#user_id#",
    "PATH_TO_USER_SETTINGS" => "blog_user_set.php?page=user_settings&blog=#blog#",
    "PATH_TO_GROUP_EDIT" => "blog_user_gr.php?page=group_edit&blog=#blog#",
    "PATH_TO_BLOG_EDIT" => "blog_b_edit.php?page=blog_edit&blog=#blog#",
    "PATH_TO_CATEGORY_EDIT" => "blog_category.php?page=category_edit&blog=#blog#",
    "BLOG_VAR" => "blog",
    "POST_VAR" => "post_id",
    "PAGE_VAR" => "page",
    "USER_VAR" => "user_id",
    "BLOG_URL" => $blog,
    "SET_NAV_CHAIN" => "Y"
    ),
);?>


Список последних тем

Описание socialnetwork.forum.topic.last

Компонент выводит список последних тем форума пользователя или рабочей группы социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Список последних тем.

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума, с которого будут выводится темы. Возможен выбор нескольких форумов.
ID группы | SOCNET_GROUP_ID | Указывается идентификатор рабочей группы социальной сети.
ID пользователя | USER_ID | Указывается идентификатор пользователя социальной сети.
Поле для сортировки SORT_BY Задается параметр, по которому будет осуществляться сортировка. Доступны значения:
  • Заголовок (TITLE);
  • Автор (USER_START_NAME);
  • Ответы (POSTS);
  • Прочитано (VIEWS);
  • Последние сообщения (LAST_POST_DATE).
Направление сортировки SORT_ORDER Выбирается направление сортировки. Доступны значения:
  • По возрастанию (ASC);
  • По убыванию (DESC).
Шаблоны ссылок
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума.
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Указывается адрес страницы чтения сообщения форума.
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы профиля пользователя.
Дополнительные настройки
Количество тем на одной странице | TOPICS_COUNT | Указывается количество тем форума, отображаемых на одной странице.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.forum.topic.last","", Array(
        "FID" => "3",
        "SOCNET_GROUP_ID" => $_REQUEST["SOCNET_GROUP_ID"],
        "USER_ID" => $_REQUEST["USER_ID"],
        "SORT_BY" => "LAST_POST_DATE",
        "SORT_ORDER" => "DESC",
        "URL_TEMPLATES_READ" => "topic.php?TID=#TID#",
        "URL_TEMPLATES_MESSAGE" => "message.php?TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "TOPICS_COUNT" => "10"
    )
);?>


Тема (создание)

Описание socialnetwork.forum.topic.new

Компонент служит для сохранения новой темы форума социальной сети. Компонент стандартный и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Тема (создание).

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума социальной сети, в котором будут храниться темы и сообщения пользователей.
ID сообщения | MID | Указывается идентификатор сообщения форума социальной сети.
Действие над сообщением | MESSAGE_TYPE | Указывается имя переменной, в которой будет содержаться код действия над сообщением.
ID группы | SOCNET_GROUP_ID | Указывается идентификатор рабочей группы социальной сети.
ID пользователя | USER_ID | Указывается идентификатор пользователя социальной сети.
Шаблоны ссылок
Страница списка тем | URL_TEMPLATES_TOPIC_LIST | Указывается путь к странице со списком тем форума социальной сети.
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Указывается путь к странице чтения сообщения социальной сети.
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается путь к странице профиля пользователя социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/smile/.
Путь относительно корня сайта к папке с иконками к темам | PATH_TO_ICON | Указывается путь к папке с иконками к темам относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/icon/.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Использовать аякс | AJAX_TYPE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Новая тема.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.forum.topic.new","",Array(
    "SHOW_TAGS" => "Y",
    "FID" => "3",
    "MID" => $_REQUEST["MID"],
    "MESSAGE_TYPE" => $_REQUEST["MESSAGE_TYPE"],
    "SOCNET_GROUP_ID" => $_REQUEST["SOCNET_GROUP_ID"],
    "USER_ID" => $_REQUEST["USER_ID"],
    "URL_TEMPLATES_TOPIC_LIST" => "topic_list.php",
    "URL_TEMPLATES_MESSAGE" => "message.php?TID=#TID#&MID=#MID#",
    "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
    "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
    "PATH_TO_ICON" => "/bitrix/images/forum/icons/",
    "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
    "AJAX_TYPE" => "Y",
    "CACHE_TYPE" => "A",
    "CACHE_TIME" => "0",
    "SET_TITLE" => "Y"
    ),
);?>


Тема (чтение)

Описание socialnetwork.forum.topic.read

Компонент выводит список сообщений темы форума социальной сети. Компонент стандартный и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Тема (чтение).

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума, в котором хранятся темы и сообщения пользователей.
ID темы | TID | Указывается идентификатор темы, сообщения которой будут отображены.
ID сообщения | MID | Указывается идентификатор сообщения форума.
ID группы | SOCNET_GROUP_ID | Задается идентификатор рабочей группы социальной сети.
ID пользователя | USER_ID | Задается идентификатор пользователя социальной сети.
Шаблоны ссылок
Страница списка тем | URL_TEMPLATES_TOPIC_LIST | Указывается адрес страницы со списком тем форума социальной сети.
Страница чтения темы | URL_TEMPLATES_TOPIC | Указывается адрес страницы чтения темы форума социальной сети.
Страница создания новой темы | URL_TEMPLATES_TOPIC_EDIT | Указывается адрес страницы создания новой темы форума социальной сети.
Страница чтения темы (с ID сообщения) | URL_TEMPLATES_MESSAGE | Указывается адрес страницы чтения темы (с ID сообщения) форума социальной сети.
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Порядковый номер постраничной навигации | PAGEN | Параметр определяет порядковый номер постраничной навигации на странице.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указывается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Количество страниц в постраничной навигации | PAGE_NAVIGATION_WINDOW | Задается количество отображаемых в навигации ссылок на страницы. Если количество страниц превышает заданное число, то в навигацию будет добавлено многоточие.
Разрешать показывать все страницы форума | PAGE_NAVIGATION_SHOW_ALL | [Y|N] При отмеченной опции будут показаны все страницы форума.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/smile/.
Длина слова | WORD_LENGTH | Задается максимально допустимая длина словообразующих символов, следующих друг за другом. Если длина слова превысит указанное число, то символы слова будут разбавлены разрывами (при просмотре сообщений разрывы не отображаются).
Размер прикрепленного рисунка | IMAGE_SIZE | Указывается допустимый размер прикрепленного рисунка.
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Указывается количество сообщений, отображаемых на одной странице. Все сообщения будут выведены с помощью постраничной навигации.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Использовать аякс | AJAX_TYPE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название просматриваемой темы.
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.
Рейтинг | RATING_ID | Указывается какой будет использоваться рейтинг.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).
Показывать ссылку 'Имя' | SHOW_NAME_LINK | [Y|N] При отмеченной опции в сообщении отображается ссылка Имя. Клик по ссылке добавляет имя пользователя в текст ответа.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.forum.topic.read","",Array(
        "SHOW_NAME_LINK" => "Y",
        "FID" => "1",
        "TID" => $_REQUEST["TID"],
        "MID" => $_REQUEST["MID"],
        "SOCNET_GROUP_ID" => $_REQUEST["SOCNET_GROUP_ID"],
        "USER_ID" => $_REQUEST["USER_ID"],
        "URL_TEMPLATES_TOPIC_LIST" => "topic_list.php",
        "URL_TEMPLATES_TOPIC" => "topic.php?TID=#TID#",
        "URL_TEMPLATES_TOPIC_EDIT" => "topic_edit.php?TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_MESSAGE" => "message.php?TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "PAGEN" => "1",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "PAGE_NAVIGATION_WINDOW" => "11",
        "PAGE_NAVIGATION_SHOW_ALL" => "Y",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "WORD_LENGTH" => "50",
        "IMAGE_SIZE" => "500",
        "MESSAGES_PER_PAGE" => "10",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "AJAX_TYPE" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "CACHE_NOTES" => "",
        "SHOW_RATING" => "Y",
        "RATING_ID" => ""
         "RATING_TYPE" => "like",
    ),
false
);?>


Темы (список)

Описание socialnetwork.forum.topic.list

Компонент выводит список всех тем форума социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Темы (список).

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума, список тем и сообщений которого будут показаны.
Использовать обратную постраничку | USE_DESC_PAGE | [Y|N] При отмеченной опции для списка тем будет использоваться обратная постраничная навигация.
ID группы | SOCNET_GROUP_ID | Задается идентификатор рабочей группы социальной сети. По умолчанию поле содержит ={$_REQUEST["SOCNET_GROUP_ID"]}.
ID пользователя | USER_ID | Задается идентификатор пользователя. По умолчанию поле содержит ={$_REQUEST["USER_ID"]}.
Шаблоны ссылок
Страница списка тем | URL_TEMPLATES_TOPIC_LIST | Указывается путь к странице списка тем социальной сети.
Страница чтения темы | URL_TEMPLATES_TOPIC | Указывается путь к странице чтения темы социальной сети.
Страница создания новой темы | URL_TEMPLATES_TOPIC_EDIT | Указывается путь к странице создания новой темы социальной сети.
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Указывается путь к странице чтения сообщения социальной сети.
Страница профиля пользователя (группы) | URL_TEMPLATES_PROFILE_VIEW | Указывается путь к странице профиля пользователя (рабочей группы) социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
PAGEN | PAGEN | Параметр определяет порядковый номер постраничной навигации на странице.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указывается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Количество страниц в постраничной навигации | PAGE_NAVIGATION_WINDOW | Задается количество отображаемых в навигации ссылок на страницы. Если количество страниц превышает заданное число, то в навигацию будет добавлено многоточие.
Количество тем на одной странице | TOPICS_PER_PAGE | Указывается количество тем форума, отображаемых на одной странице. Все темы будут выведены с помощью постраничной навигации.
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Указывается количество сообщений, отображаемых на одной странице. Все сообщения будут выведены с помощью постраничной навигации.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Длина слова | WORD_LENGTH | Задается максимально допустимая длина словообразующих символов, следующих друг за другом. Если длина слова превысит указанное число, то символы слова будут разбавлены разрывами (при просмотре сообщений разрывы не отображаются).
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название форума, список тем которого просматривается.
Дополнительный маркер для новых сообщений | TMPLT_SHOW_ADDITIONAL_MARKER | Задается текст надписи, отображаемый рядом с темой, в которой есть непрочитанные вами сообщения.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.forum.topic.list","",Array(
        "TMPLT_SHOW_ADDITIONAL_MARKER" => "",
        "FID" => "3",
        "USE_DESC_PAGE" => "Y",
        "SOCNET_GROUP_ID" => $_REQUEST["SOCNET_GROUP_ID"],
        "USER_ID" => $_REQUEST["USER_ID"],
        "URL_TEMPLATES_TOPIC_LIST" => "topic_list.php",
        "URL_TEMPLATES_TOPIC" => "topic.php?TID=#TID#",
        "URL_TEMPLATES_TOPIC_EDIT" => "topic_edit.php?MID=#MID#&",
        "URL_TEMPLATES_MESSAGE" => "message.php?TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#"
        "PAGEN" => "1",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "PAGE_NAVIGATION_WINDOW" => "11",
        "TOPICS_PER_PAGE" => "10",
        "MESSAGES_PER_PAGE" => "10",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "WORD_LENGTH" => "50",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "SET_TITLE" => "Y"
    )
);?>


Уведомление о добавлении получателя

Описание socialnetwork.blog.post_share.mail

Компонент добавляет в почтовый шаблон уведомление о добавлении получателя.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Уведомление о добавлении получателя.

Параметры

Поле | Параметр | Описание
Email получателя | EMAIL_TO | Указывается email получателя сообщения.
ID получателя | RECIPIENT_ID | Указывается идентификатор пользователя-получателя сообщения (почтового пользователя).
ID сообщения | POST_ID | Указывается идентификатор сообщения блога.
ID комментария | COMMENT_ID | Указывается идентификатор комментария к сообщению блога.
URL сообщения | URL | Указывается URL сообщения блога в разделе сайта для почтовых пользователей (стандартно - в папке /pub/).

Пример вызова

<?EventMessageThemeCompiler::includeComponent(
    "bitrix:socialnetwork.blog.post_share.mail",
    "",
    Array(
        "EMAIL_TO" => "{#EMAIL_TO#}",
        "POST_ID" => "{#POST_ID#}",
        "RECIPIENT_ID" => "{#RECIPIENT_ID#}",
        "URL" => "{#URL#}"
    )
);?>


Уведомление о записи или комментарии

Описание socialnetwork.log.entry.mail

Компонент добавляет в почтовый шаблон уведомление о записи или комментарии.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Уведомление о записи или комментарии.

Параметры

Поле | Параметр | Описание
Email получателя | EMAIL_TO | Указывается email получателя сообщения.
ID получателя | RECIPIENT_ID | Указывается идентификатор пользователя-получателя сообщения (почтового пользователя).
ID записи ЖЛ | LOG_ENTRY_ID | Указывается идентификатор записи Живой ленты.
ID комментария | COMMENT_ID | Указывается идентификатор комментария к сообщению Живой ленты.
URL сообщения | URL | Указывается URL сообщения Живой ленты в разделе сайта для почтовых пользователей (стандартно - в папке /pub/).

Пример вызова

<?EventMessageThemeCompiler::includeComponent(
    "bitrix:socialnetwork.log.entry.mail",
    "",
    Array(
        "EMAIL_TO" => "{#EMAIL_TO#}",
        "LOG_ENTRY_ID" => "{#LOG_ENTRY_ID#}",
        "RECIPIENT_ID" => "{#RECIPIENT_ID#}",
        "URL" => "{#URL#}"
    )
);?>

Второй пример вызова

<?EventMessageThemeCompiler::includeComponent(
    "bitrix:socialnetwork.log.entry.mail",
    "",
    Array(
        "COMMENT_ID" => "{#COMMENT_ID#}",
        "EMAIL_TO" => "{#EMAIL_TO#}",
        "LOG_ENTRY_ID" => "{#LOG_ENTRY_ID#}",
        "RECIPIENT_ID" => "{#RECIPIENT_ID#}",
        "URL" => "{#URL#}"
    )
);?>


Уведомление о комментарии

Описание socialnetwork.blog.post.comment.mail

Компонент добавляет в почтовый шаблон уведомление о комментарии к посту в блоге или сообщению в Живой ленте.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Уведомление о комментарии.

Параметры

Поле | Параметр | Описание
Email получателя | EMAIL_TO | Указывается email получателя сообщения.
ID получателя | RECIPIENT_ID | Указывается идентификатор пользователя-получателя сообщения (почтового пользователя).
ID сообщения | POST_ID | Указывается идентификатор сообщения блога.
ID комментария | COMMENT_ID | Указывается идентификатор комментария к сообщению блога.
URL сообщения | URL | Указывается URL сообщения блога в разделе сайта для почтовых пользователей (стандартно - в папке /pub/).

Пример вызова

<?EventMessageThemeCompiler::includeComponent(
    "bitrix:socialnetwork.blog.post.comment.mail",
    "",
    Array(
        "COMMENT_ID" => "{#COMMENT_ID#}",
        "EMAIL_TO" => "{#EMAIL_TO#}",
        "POST_ID" => "{#POST_ID#}",
        "RECIPIENT_ID" => "{#RECIPIENT_ID#}",
        "URL" => "{#URL#}"
    )
);?>


Уведомление о сообщении

Описание socialnetwork.blog.post.mail

Компонент добавляет в почтовый шаблон уведомление о новом посте в блоге или сообщении в Живой ленте.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Уведомление о сообщении.

Параметры

Поле | Параметр | Описание
Email получателя | EMAIL_TO | Указывается email получателя сообщения.
ID получателя | RECIPIENT_ID | Указывается идентификатор пользователя-получателя сообщения (почтового пользователя).
ID сообщения | POST_ID | Указывается идентификатор сообщения блога.
URL сообщения | URL | Указывается URL сообщения блога в разделе сайта для почтовых пользователей (стандартно - в папке /pub/).

Пример вызова

<?EventMessageThemeCompiler::includeComponent(
    "bitrix:socialnetwork.blog.post.mail",
    "",
    Array(
        "EMAIL_TO" => "{#EMAIL_TO#}",
        "POST_ID" => "{#POST_ID#}",
        "RECIPIENT_ID" => "{#RECIPIENT_ID#}",
        "URL" => "{#URL#}"
    )
);?>


Форма ввода пользователей

Описание socialnetwork.user_search_input

Компонент предназначен для вывода формы, с помощью которой осуществляется ввод пользователей социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Форма ввода пользователей.

Параметры

Поле | Параметр | Описание
Дополнительно
Количество записей в выпадающем списке | PAGE_ELEMENTS | Указывается количество отображаемых записей в выпадающем списке-подсказке уже существующих пользователей.
Дополнительные свойства | TEXT | Указывается код дополнительного свойства.
Вставлять фрейм в шаблон компонента | TMPL_IFRAME | [Y|N] При отмеченной опции фрейм будет вставлен в шаблон компонента.
Основные параметры
Имя поля ввода | NAME | Задается название формы ввода пользователей.
Содержимое поля ввода | VALUE | Указывается содержимое формы ввода пользователей по умолчанию.
JavaScript функция | FUNCTION | Указывается имя функции, которой передается результат выбора пользователя.
Код экстранета (I/E/EA) EXTRANET Указывается код экстранета:
  • I - сотрудники компании;
  • EA - все внешние пользователи;
  • E - доступные внешние пользователи.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_search_input","",Array(
    "PAGE_ELEMENTS" => "10",
    "TEXT" => "",
    "TMPL_IFRAME" => "Y",
    "NAME" => "Пользователь",
    "VALUE" => "",
    "FUNCTION" => "",
    "EXTRANET" => "I"
    )
);?>


Форма создания сообщения

Описание socialnetwork.forum.post_form

Компонент выводит форму создания сообщения (или темы) форума социальной сети. Компонент стандартный и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Форма создания сообщения.

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума социальной сети, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["FID"]}.
ID темы | TID | Указывается идентификатор темы форума социальной сети, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["TID"]}.
ID сообщения | MID | Указывается идентификатор сообщения форума социальной сети, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["MID"]}.
ID вызывающего компонента | PAGE_NAME | Указывается идентификатор вызывающего компонента. Например, message.
Тип отображения формы редактирования (ответ, редактирование, новая тема) MESSAGE_TYPE Указывается тип отображения формы редактирования. Возможные варианты зачения параметра:
  • ответ - REPLY;
  • редактирование - EDIT;
  • новая тема - NEW.
Выбирать данные из формы | bVarsFromForm | [Y|N] При отмеченной опции будут выбираться данные из формы.
ID группы | SOCNET_GROUP_ID | Указывается идентификатор рабочей группы социальной сети, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["SOCNET_GROUP_ID"]}.
ID пользователя | USER_ID | Указывается идентификатор пользователя социальной сети, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["USER_ID"]}.
Шаблоны ссылок
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Задается путь к странице чтения сообщения форума социальной сети.
Страница списка тем | URL_TEMPLATES_LIST | Задается путь к странице списка тем форума социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Использовать AJAX | AJAX_TYPE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Показывать теги | SHOW_TAGS | [Y|N] При отмеченной опции будет выведена форма ввода тегов.
Максимальное количество файлов, прикрепленных к одному сообщению | FILES_COUNT | Задается количество файлов, которое может быть прикреплено к сообщению. Данный параметр работает только в том случае, если в настройках соответствующего форума разрешено прикреплять файлы к сообщениям.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.forum.post_form","",Array(
        "SHOW_TAGS" => "Y",
        "FILES_COUNT" => "2",
        "SMILES_COUNT" => "0",
        "FID" => $_REQUEST["FID"],
        "TID" => $_REQUEST["TID"],
        "MID" => $_REQUEST["MID"],
        "PAGE_NAME" => "message",
        "MESSAGE_TYPE" => $_REQUEST["MESSAGE_TYPE"],
        "bVarsFromForm" => "Y"],
        "SOCNET_GROUP_ID" => $_REQUEST["SOCNET_GROUP_ID"],
        "USER_ID" => $_REQUEST["USER_ID"],
        "URL_TEMPLATES_MESSAGE" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "PATH_TO_ICON" => "/bitrix/images/forum/icon/",
        "SMILE_TABLE_COLS" => "3",
        "AJAX_TYPE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0"
    ),
);?>


Сообщения

Описание socialnetwork.blog.blog

Компонент выводит сообщения блога социальной сети с возможностью их фильтрации по категории и дате. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Сообщения.

Параметры

Поле | Параметр | Описание
Основные параметры
Год для фильтрации | YEAR | Указывается код, в котором передается год для фильтрации.
Месяц для фильтрации | MONTH | Указывается код, в котором передается месяц фильтрации.
День для фильтрации | DAY | Указывается код, в котором передается день для фильтрации.
Идентификатор тега для фильтрации | CATEGORY_ID | Указывается код, в котором передается идентификатор тега для фильтрации.
Источник данных
Имя массива со значениями фильтра для фильтрации сообщений | FILTER_NAME | Задается имя переменной, в которой передается массив параметров из фильтра. Служит для определения выходящих из фильтра элементов. Поле может быть оставлено пустым, тогда используется значение по умолчанию.
Внешний вид
Количество сообщений, выводимых на страницу | MESSAGE_COUNT | Указывается количество сообщений блога, отоброжаемых в блоках на странице. Все сообщения будут выведены с помощью постраничной навигации.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Указывается максимальная ширина изображения в блоге в пикселах.
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Указывается максимальная высота изображения в блоге в пикселах.
Шаблоны ссылок
Шаблон пути к странице блога | PATH_TO_BLOG | Задается путь к главной странице конкретного блога социальной сети.
Шаблон пути к странице блога c фильтром по тегу | PATH_TO_BLOG_CATEGORY | Задается путь к главной странице блога социальной сети c фильтром по тегу.
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Задается путь к странице с сообщением блога социальной сети.
Шаблон пути к странице редактирования сообщения блога | PATH_TO_POST_EDIT | Задается путь к странице редактирования сообщения блога социальной сети.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Задается путь к странице пользователя блога социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Время кэширования остальных страниц | CACHE_TIME_LONG | Указывается время кеширования страниц, начиная со второй.
Дополнительные настройки
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Добавлять пункт в цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт с названием блога.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название сообщения блога социальной сети.
Показывать доп. свойства сообщения в блоге | POST_PROPERTY_LIST | Указываются пользовательские свойства сообщения, которые необходимо дополнительно отобразить в блоге социальной сети.
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).
Имена переменных
Имя переменной для идентификатора сообщения | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога социальной сети.
Имя переменной для идентификатора пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога социальной сети.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.blog.blog","",Array(
    "SEO_USER" => "Y",
    "MESSAGE_COUNT" => "25",
    "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
    "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
    "PATH_TO_BLOG_CATEGORY" => "blog_filter.php?page=blog&blog=#blog#&category=#category#",
    "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog#&post_id=#post_id#",
    "PATH_TO_POST_EDIT" => "blog_p_edit.php?page=post_edit&blog=#blog#&post_id=#post_id#",
    "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
    "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
    "BLOG_VAR" => "blog",
    "POST_VAR" => "post_id",
    "USER_VAR" => "user_id",
    "PAGE_VAR" => "page",
    "BLOG_URL" => $blog,
    "YEAR" => $year,
    "MONTH" => $month,
    "DAY" => $day,
    "CATEGORY_ID" => $category,
    "CACHE_TYPE" => "A",
    "CACHE_TIME" => "7200",
    "CACHE_TIME_LONG" => "604800",
    "SET_NAV_CHAIN" => "Y",
    "SET_TITLE" => "Y",
    "FILTER_NAME" => "arFilter",
    "NAV_TEMPLATE" => "",
    "SHOW_RATING" => "Y",
    "RATING_TYPE" => "standart",
    "IMAGE_MAX_WIDTH" => "600",
    "IMAGE_MAX_HEIGHT" => "600"
    "POST_PROPERTY_LIST" => Array()
    )
);?>


Сообщения - модерация

Описание socialnetwork.blog.moderation

Компонент выводит сообщения, требующие модерации. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Сообщения - модерация.

Параметры

Описание параметров

Поле | Параметр | Описание
Внешний вид
Количество сообщений, выводимых на страницу | MESSAGE_COUNT | Указывается количество сообщений, отоброжаемых в блоках на странице. Все сообщения будут выведены с помощью постраничной навигации.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Указывается максимальная ширина изображения, вставляемого в сообщение (в пикселах).
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Указывается максимальная высота изображения, вставляемого в сообщение (в пикселах).
Шаблоны ссылок
Шаблон пути к странице сообщений | PATH_TO_BLOG | Задается путь к главной странице конкретного сообщения социальной сети.
Шаблон пути к странице сообщения c фильтром по тегу | PATH_TO_BLOG_CATEGORY | Задается путь к главной странице сообщения социальной сети c фильтром по тегу.
Шаблон пути к странице с сообщением | PATH_TO_POST | Задается путь к странице с сообщением социальной сети.
Шаблон пути к странице редактирования сообщения | PATH_TO_POST_EDIT | Задается путь к странице редактирования сообщения блога социальной сети.
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Время кэширования остальных страниц | CACHE_TIME_LONG | Указывается время кеширования страниц, начиная со второй.
Дополнительные настройки
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Добавлять пункт в цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт с названием блога.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название сообщения в социальной сети.
Показывать доп. свойства сообщения | POST_PROPERTY_LIST | Указываются пользовательские свойства сообщения, которые необходимо дополнительно отобразить в социальной сети.
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).
Имена переменных
Имя переменной для идентификатора сообщения | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога социальной сети.
Имя переменной для идентификатора пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога социальной сети.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.blog.moderation","",Array(
    "SEO_USER" => "Y",
    "MESSAGE_COUNT" => "25",
    "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
    "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
    "PATH_TO_BLOG_CATEGORY" => "blog_filter.php?page=blog&blog=#blog#&category=#category#",
    "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog#&post_id=#post_id#",
    "PATH_TO_POST_EDIT" => "blog_p_edit.php?page=post_edit&blog=#blog#&post_id=#post_id#",
    "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
    "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
    "POST_VAR" => "post_id",
    "USER_VAR" => "user_id",
    "PAGE_VAR" => "page",
    "CACHE_TYPE" => "A",
    "CACHE_TIME" => "7200",
    "CACHE_TIME_LONG" => "604800",
    "SET_NAV_CHAIN" => "Y",
    "SET_TITLE" => "Y",
    "NAV_TEMPLATE" => "",
    "SHOW_RATING" => "Y",
    "POST_PROPERTY_LIST" => Array()
    "SHOW_RATING" => "",
    "RATING_TYPE" => "",
    "IMAGE_MAX_WIDTH" => "600",
    "IMAGE_MAX_HEIGHT" => "600"
    )
);?>


Черновики сообщений

Описание socialnetwork.blog.draft

Компонент выводит черновики сообщений. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Черновики сообщений.

Параметры

Поле | Параметр | Описание
Внешний вид
Количество сообщений, выводимых на страницу | MESSAGE_COUNT | Указывается количество сообщений, отоброжаемых в блоках на странице. Все сообщения будут выведены с помощью постраничной навигации.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Указывается максимальная ширина изображения, вставляемого в сообщение (в пикселах).
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Указывается максимальная высота изображения, вставляемого в сообщение (в пикселах).
Шаблоны ссылок
Шаблон пути к странице сообщений | PATH_TO_BLOG | Задается путь к главной странице конкретного сообщения социальной сети.
Шаблон пути к странице сообщения c фильтром по тегу | PATH_TO_BLOG_CATEGORY | Задается путь к главной странице сообщения социальной сети c фильтром по тегу.
Шаблон пути к странице с сообщением | PATH_TO_POST | Задается путь к странице с сообщением социальной сети.
Шаблон пути к странице редактирования сообщения | PATH_TO_POST_EDIT | Задается путь к странице редактирования сообщения блога социальной сети.
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Время кэширования остальных страниц | CACHE_TIME_LONG | Указывается время кеширования страниц, начиная со второй.
Дополнительные настройки
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Добавлять пункт в цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт с названием блога.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название сообщения в социальной сети.
Показывать доп. свойства сообщения | POST_PROPERTY_LIST | Указываются пользовательские свойства сообщения, которые необходимо дополнительно отобразить в социальной сети.
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).
Имена переменных
Имя переменной для идентификатора сообщения | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога социальной сети.
Имя переменной для идентификатора пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога социальной сети.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.blog.draft","",Array(
    "SEO_USER" => "Y",
    "MESSAGE_COUNT" => "25",
    "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
    "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
    "PATH_TO_BLOG_CATEGORY" => "blog_filter.php?page=blog&blog=#blog#&category=#category#",
    "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog#&post_id=#post_id#",
    "PATH_TO_POST_EDIT" => "blog_p_edit.php?page=post_edit&blog=#blog#&post_id=#post_id#",
    "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
    "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
    "POST_VAR" => "post_id",
    "USER_VAR" => "user_id",
    "PAGE_VAR" => "page",
    "CACHE_TYPE" => "A",
    "CACHE_TIME" => "7200",
    "CACHE_TIME_LONG" => "604800",
    "SET_NAV_CHAIN" => "Y",
    "SET_TITLE" => "Y",
    "NAV_TEMPLATE" => "",
    "SHOW_RATING" => "Y",
    "POST_PROPERTY_LIST" => Array()
    "SHOW_RATING" => "",
    "RATING_TYPE" => "",
    "IMAGE_MAX_WIDTH" => "600",
    "IMAGE_MAX_HEIGHT" => "600"
    )
);?>


Сообщение детально

Описание socialnetwork.blog.post

Компонент выводит подробно сообщение. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Сообщение детально.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор сообщения | ID | Параметр содержит код, в котором передается идентификатор сообщения.
Внешний вид
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Указывается максимальная ширина изображения, вставляемого в сообщение (в пикселах).
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Указывается максимальная высота изображения, вставляемого в сообщение (в пикселах).
Шаблоны ссылок
Шаблон пути к странице сообщений | PATH_TO_BLOG | Задается путь к главной странице конкретного сообщения социальной сети.
Шаблон пути к странице сообщения c фильтром по тегу | PATH_TO_BLOG_CATEGORY | Задается путь к главной странице сообщения социальной сети c фильтром по тегу.
Шаблон пути к странице редактирования сообщения | PATH_TO_POST_EDIT | Задается путь к странице редактирования сообщения блога социальной сети.
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице пользователя социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Добавлять пункт в цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт с названием блога.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название сообщения в социальной сети.
Показывать доп. свойства сообщения | POST_PROPERTY_LIST | Указываются пользовательские свойства сообщения, которые необходимо дополнительно отобразить в социальной сети.
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).
Имена переменных
Имя переменной для идентификатора сообщения | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения блога социальной сети.
Имя переменной для идентификатора пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя блога социальной сети.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница блога социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.blog.post","",Array(
    "ID" => $id,
    "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
    "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
    "PATH_TO_BLOG_CATEGORY" => "blog_filter.php?page=blog&blog=#blog#&category=#category#",
    "PATH_TO_POST_EDIT" => "blog_p_edit.php?page=post_edit&blog=#blog#&post_id=#post_id#",
    "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
    "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
    "POST_VAR" => "post_id",
    "USER_VAR" => "user_id",
    "PAGE_VAR" => "page",
    "CACHE_TYPE" => "A",
    "CACHE_TIME" => "7200",
    "SET_NAV_CHAIN" => "Y",
    "SET_TITLE" => "Y",
    "NAV_TEMPLATE" => "",
    "SHOW_RATING" => "Y",
    "POST_PROPERTY" => Array()
    "RATING_TYPE" => "",
    "IMAGE_MAX_WIDTH" => "600",
    "IMAGE_MAX_HEIGHT" => "600"
    )
);?>


Комментарии к сообщению

Описание socialnetwork.blog.post.comment

Компонент выводит комментарии к сообщению с возможностью добавления. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Комментарии к сообщению.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор сообщения | ID | Параметр содержит код, в котором передается идентификатор сообщения.
Внешний вид
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Указывается максимальная ширина изображения, вставляемого в сообщение (в пикселах).
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Указывается максимальная высота изображения, вставляемого в сообщение (в пикселах).
Шаблоны ссылок
Шаблон пути к странице сообщений | PATH_TO_BLOG | Задается путь к главной странице конкретного сообщения социальной сети.
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице пользователя социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).
Разрешить вставку видео | ALLOW_VIDEO | [Y|N] При отмеченной опции будет разрешена вставка видео в коментарий.
Разрешить загрузку изображений ALLOW_IMAGE_UPLOAD Указывается, кому разрешено использовать в комментариях изображения (по умолчанию - Никому):
  • A - Всем;
  • R - Зарегистрированным пользователям;
  • N - Никому.
Показывать администраторам ссылку на все комментарии пользователя | SHOW_SPAM | [Y|N] При отмеченной опции администратор будет видеть ссылку на страницу со всеми комментариями данного пользователя.
Запретить вставку ссылок NO_URL_IN_COMMENTS Указывается, кому запрещено вставлять в комментариях ссылки (по умолчанию - Никому):
  • - Никому;
  • А - Анонимным пользователям;
  • L - Всем.
Минимальный авторитет, с которым пользователи могут вставлять ссылки | NO_URL_IN_COMMENTS_AUTHORITY | Указывается минимальный авторитет пользователя, который может вставлять ссылки в комментарии.
Имена переменных
Имя переменной для идентификатора сообщения | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения социальной сети.
Имя переменной для идентификатора пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница сообщений социальной сети.
Имя переменной для идентификатора комментария | COMMENT_ID_VAR | Указывается имя переменной, которой передается идентификатор комментария.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.blog.post.comment","",Array(
    "ID" => $id,
    "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
    "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
    "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
    "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
    "POST_VAR" => "post_id",
    "USER_VAR" => "user_id",
    "COMMENT_ID_VAR" => "",
    "PAGE_VAR" => "page",
    "CACHE_TYPE" => "A",
    "CACHE_TIME" => "7200",
    "SHOW_RATING" => "Y",
    "RATING_TYPE" => "",
    "IMAGE_MAX_WIDTH" => "600",
    "IMAGE_MAX_HEIGHT" => "600"
    "ALLOW_VIDEO" => "Y",
    "ALLOW_IMAGE_UPLOAD" => "N",
    "SHOW_SPAM" => "Y",
    "NO_URL_IN_COMMENTS_AUTHORITY" => ""
    )
);?>


Изменение профиля пользователя

Описание socialnetwork.user_profile_edit

Компонент позволяет изменить данные профиля пользователя социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Изменение профиля пользователя.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Внешний вид
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице редактирования пользователя | PATH_TO_USER_EDIT | Задается путь к странице редактирования профиля пользователя социальной сети.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено Изменение профиля пользователя <пользователь>.
Редактируемые свойства | EDITABLE_FIELD | Указывается набор свойств, доступных для редактирования.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_profile_edit","",Array(
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_USER_EDIT" => "user_edit.php?page=user_edit&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "ID" => $user_id,
        "SET_TITLE" => "Y",
        "EDITABLE_FIELDS" => Array("UF_PHONE_INNER", "LOGIN", "NAME", "SECOND_NAME", "LAST_NAME", "EMAIL", "PERSONAL_PROFESSION"),
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s"
        "NAME_TEMPLATE" => "#NOBR##NAME# #LAST_NAME##/NOBR#",
        "SHOW_LOGIN" => "Y"
    )
);?>


Просмотр профиля пользователя

Описание socialnetwork.user_profile

Компонент позволяет просмотреть и изменить профиль пользователя социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Просмотр профиля пользователя.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Внешний вид
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице добавления в друзья | PATH_TO_USER_FRIENDS_ADD | Задается путь к странице добавления в друзья социальной сети.
Шаблон пути к странице отправки сообщений | PATH_TO_MESSAGE_FORM | Задается путь к странице отправки сообщений социальной сети.
Шаблон пути к странице чата | PATH_TO_MESSAGES_CHAT | Задается путь к странице чата социальной сети.
Шаблон пути к странице переписки с пользователем | PATH_TO_MESSAGES_USERS_MESSAGES | Задается путь к странице переписке с пользователем социальной сети.
Шаблон пути к странице удаления из друзей | PATH_TO_USER_FRIENDS_DELETE | Задается путь к странице удаления из друзей социальной сети.
Шаблон пути к странице друзей пользователя | PATH_TO_USER_FRIEND | Задается путь к странице друзей пользователя социальной сети.
Шаблон пути к странице поиска пользователей | PATH_TO_SEARCH | Задается путь к странице поиска пользователей социальной сети.
Шаблон пути к странице поиска групп | PATH_TO_GROUP_SEARCH | Задается путь к странице поиска групп социальной сети.
Шаблон пути к обновлениям | PATH_TO_LOG | Задается путь к странице обновлений социальной сети.
Шаблон пути к внутренней странице поиска пользователей | PATH_TO_SEARCH_INNER | Задается путь к внутренней странице поиска пользователей социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице изменения параметров группы | PATH_TO_GROUP_EDIT | Задается путь к странице изменения параметров группы социальной сети.
Шаблон пути к странице создания новой группы | PATH_TO_GROUP_CREATE | Задается путь к странице создания новой группы социальной сети.
Шаблон пути к странице групп пользователя | PATH_TO_USER_GROUPS | Задается путь к странице групп пользователя социальной сети.
Шаблон пути к странице редактирования пользователя | PATH_TO_USER_EDIT | Задается путь к странице редактирования пользователя социальной сети.
Шаблон пути к странице настройки функционала | PATH_TO_USER_FEATURES | Задается путь к странице настройки функционала пользователя социальной сети.
Шаблон пути к управлению подпиской | PATH_TO_USER_SUBSCRIBE | Задается путь к странице управлению подпиской социальной сети.
Шаблон пути к странице настройки пользователя | PATH_TO_USER_SETTINGS_EDIT | Задается путь к странице настройки пользователя социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт <пользователь>.
Сокращенная форма | SHORT_FORM | [Y|N] При отмеченной опции в профиле пользователя будет отображаться минимальное количество информации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <пользователь> : Профиль.
Главные свойства пользователя | USER_FIELDS_MAIN | Указываются главные свойства пользователя, которые будут выводиться в области основной информации о пользователе.
Главные доп. свойства пользователя | USER_PROPERTY_MAIN | Указываются главные дополнительные свойства пользователя, которые будут выводиться в области основной информации о пользователе.
Свойства пользователя для контакта | USER_FIELDS_CONTACT | Указываются свойства пользователя для контакта, которые будут выводиться в контактной информации.
Доп. свойства пользователя для контакта | USER_PROPERTY_CONTACT | Указываются дополнительные свойства пользователя для контакта, которые будут выводиться в контактной информации.
Персональные свойства пользователя | USER_FIELDS_PERSONAL | Указываются персональные свойства пользователя, которые будут выводиться в личной информации.
Персональные доп. свойства в пользователя | USER_PROPERTY_PERSONAL | Указываются персональные дополнительные свойства пользователя, которые будут выводиться в личной информации.
Количество записей в списке | ITEMS_COUNT | Параметр определяет количество записей в блоках (основная, контактная и личная информация), расположенных на странице.
Показывать год рождения SHOW_YEAR Параметр определяет для каких сотрудников должен быть отображен год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).
Поля пользователя, по которым возможен поиск | SONET_USER_FIELDS_SEARCHABLE | Указываются поля пользователя, по которым будет осуществляться поиск сотрудников.
Пользовательские свойства пользователя, по которым возможен поиск | SONET_USER_PROPERTY_SEARCHABLE | Указываются дополнительные свойства пользователя, по которым также будет осуществляться поиск сотрудников.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_profile",".default",Array(
        "SET_NAVCHAIN" => "Y",
        "SHORT_FORM" => "N",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_USER_FRIENDS_ADD" => "user_friends_add.php?page=user_friends_add&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM" => "message_form.php?page=message_form&user_id=#user_id#",
        "PATH_TO_MESSAGES_CHAT" => "messages_chat.php?page=messages_chat&user_id=#user_id#",
        "PATH_TO_MESSAGES_USERS_MESSAGES" => "messages_users_messages.php?page=messages_users_messages&user_id=#user_id#",
        "PATH_TO_USER_FRIENDS_DELETE" => "user_friends_delete.php?page=user_friends_delete&user_id=#user_id#",
        "PATH_TO_USER_FRIENDS" => "user_friends.php?page=user_friends&user_id=#user_id#",
        "PATH_TO_SEARCH" => "/company/index.php",
        "PATH_TO_GROUP_SEARCH" => "/community/workgroups/index.php",
        "PATH_TO_LOG" => "user_log.php?page=log&user_id=#user_id#",
        "PATH_TO_SEARCH_INNER" => "user_search.php",
        "PATH_TO_GROUP" => "/community/workgroups/group_view.php?page=group&group_id=#group_id#",
        "PATH_TO_GROUP_EDIT" => "/community/workgroups/group_edit.php?page=group_edit&group_id=#group_id#",
        "PATH_TO_GROUP_CREATE" => "group_add.php?page=create&user_id=#user_id#",
        "PATH_TO_USER_GROUPS" => "user_groups.php?page=user_groups&user_id=#user_id#",
        "PATH_TO_USER_EDIT" => "user_edit.php?page=user_edit&user_id=#user_id#",
        "PATH_TO_USER_FEATURES" => "user_features.php?page=user_features&user=#user_id#",
        "PATH_TO_USER_SUBSCRIBE" => "user_subscribe.php?page=subscribe&user_id=#user_id#",
        "PATH_TO_USER_SETTINGS_EDIT" => "user_settings.php?page=user_settings&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "ID" => $user_id,
        "SET_TITLE" => "Y",
        "USER_FIELDS_MAIN" => Array("LAST_LOGIN", "PERSONAL_PROFESSION", "WORK_POSITION"),
        "USER_PROPERTY_MAIN" => Array("UF_DEPARTMENT"),
        "USER_FIELDS_CONTACT" => Array("EMAIL", "PERSONAL_WWW", "PERSONAL_ICQ", "PERSONAL_PHONE", "PERSONAL_FAX", "PERSONAL_MOBILE", "PERSONAL_PAGER"),
        "USER_PROPERTY_CONTACT" => Array(),
        "USER_FIELDS_PERSONAL" => Array("PERSONAL_BIRTHDAY", "PERSONAL_GENDER"),
        "USER_PROPERTY_PERSONAL" => Array(),
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "ITEMS_COUNT" => "6",
        "SHOW_YEAR" => "Y",
        "SONET_USER_FIELDS_SEARCHABLE" => Array("NAME", "LAST_NAME", "PERSONAL_PROFESSION"),
        "SONET_USER_PROPERTY_SEARCHABLE" => Array("UF_DEPARTMENT")
    )
);?>


Профиль группы

Описание socialnetwork.group

Компонент служит для просмотра и изменения профиля группы социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Профиль группы.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Внешний вид
Количество записей в списках | ITEMS_COUNT | Указывается количество визиток, отоброжаемых в блоках на странице. Весь список визиток будет выведен с помощью ссылок.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице поиска пользователей | PATH_TO_SEARCH | Задается путь к странице поиска пользователей социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к черному списку группы | PATH_TO_GROUP_BAN | Задается путь к странице черного списка группы социальной сети.
Шаблон пути к странице руководства группы | PATH_TO_GROUP_MODS | Задается путь к странице модераторов группы социальной сети.
Шаблон пути к странице выхода из группы | PATH_TO_USER_LEAVE_GROUP | Задается путь к странице выхода из группы социальной сети.
Шаблон пути к странице членов группы | PATH_TO_GROUP_USERS | Задается путь к странице участников группы социальной сети.
Шаблон пути к странице изменения параметров группы | PATH_TO_GROUP_EDIT | Задается путь к странице изменения параметров группы социальной сети.
Шаблон пути к странице удаления группы | PATH_TO_GROUP_DELETE | Задается путь к странице удаления группы социальной сети.
Шаблон пути к странице создания новой группы | PATH_TO_GROUP_CREATE | Задается путь к странице создания новой группы социальной сети.
Шаблон пути к странице запроса к пользователю на вступление в группу | PATH_TO_GROUP_REQUEST_SEARCH | Задается путь к странице запроса к пользователю на вступление в группу социальной сети.
Шаблон пути к странице запроса к группе на вступление пользователя | PATH_TO_USER_REQUEST_GROUP | Задается путь к странице запроса к группе на вступление пользователя социальной сети.
Шаблон пути к странице запросов на вступление в группу | PATH_TO_GROUP_REQUESTS | Задается путь к странице запросов пользователей на вступление в группу социальной сети.
Шаблон пути к странице приглашений для вступления группу | PATH_TO_GROUP_REQUESTS_OUT | Задается путь к странице со списком отправленных пользователям приглашений для вступления группу.
Шаблон пути к странице настройки функционала | PATH_TO_GROUP_FEATURES | Задается путь к странице настройки функционала группы социальной сети.
Шаблон пути к управлению подпиской | PATH_TO_GROUP_SUBSCRIBE | Задается путь к странице управлению подпиской группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт <имя_группы>.
Сокращенная форма | SHORT_FORM | [Y|N] При отмеченной опции в профиле группы будет отображаться минимальное количество информации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <имя_группы> : Профиль.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group",".default",Array(
        "SET_NAVCHAIN" => "Y",
        "SHORT_FORM" => "N",
        "PATH_TO_USER" => "/community/socnet/index.php?page=user&user=#user_id#",
        "PATH_TO_SEARCH" => "/community/socnet/user_search.php",
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "PATH_TO_GROUP_BAN" => "group_ban.php?page=group_ban&group_id=#group_id#",
        "PATH_TO_GROUP_MODS" => "group_mods.php?page=group_mods&group_id=#group_id#",
        "PATH_TO_USER_LEAVE_GROUP" => "user_leave.php?page=user_leave_group&group_id=#group_id#",
        "PATH_TO_GROUP_USERS" => "group_users.php?page=group_users&group_id=#group_id#",
        "PATH_TO_GROUP_EDIT" => "group_edit.php?page=group_edit&group_id=#group_id#",
        "PATH_TO_GROUP_DELETE" => "group_delete.php?page=group_delete&group_id=#group_id#",
        "PATH_TO_GROUP_CREATE" => "/community/socnet/group_add.php?page=create&user=#user_id#",
        "PATH_TO_GROUP_REQUEST_SEARCH" => "group_invite.php?page=group_request_search&group_id=#group_id#",
        "PATH_TO_USER_REQUEST_GROUP" => "user_request.php?page=group_user_request&group_id=#group_id#&user_id=#user_id#",
        "PATH_TO_GROUP_REQUESTS" => "group_requests.php?page=group_requests&group_id=#group_id#",
        "PATH_TO_GROUP_REQUESTS_OUT" => "group_requests_out.php?page=group_requests_out&group_id=#group_id#",
        "PATH_TO_GROUP_FEATURES" => "group_features.php?page=group_features&group_id=#group_id#",
        "PATH_TO_GROUP_SUBSCRIBE" => "group_subscribe.php?page=group_subscribe&group_id=#group_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "GROUP_VAR" => "group_id",
        "GROUP_ID" => $group_id,
        "ITEMS_COUNT" => "6",
        "SET_TITLE" => "Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s"
    )
);?>


Top групп

Описание socialnetwork.group_top

Компонент позволяет показать Top групп социальной сети. Компонент содержит два шаблона: (.default) и (div). Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Top групп.

Параметры

Поле | Параметр | Описание
Внешний вид
Число записей на страницу | ITEMS_COUNT | Указывается количество рабочих групп в Top-списке, которые будут отоброжены.
Формат даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Шаблоны ссылок
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице поиска групп | PATH_TO_GROUP_SEARCH | Задается путь к странице поиска групп социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Показывать изображение | DISPLAY_IMAGE | [Y|N] При отмеченной опции в Top-списке будет показано изображение групп.
Показывать описание | DISPLAY_DESCRIPTION | [Y|N] При отмеченной опции в Top-списке будет показано описание группы.
Показывать число участников | DISPLAY_NUMBER_OF_MEMBERS | [Y|N] При отмеченной опции в Top-списке будет показано число участников группы.
Показывать тему | DISPLAY_SUBJECT | [Y|N] При отмеченной опции в Top-списке будет показана тема группы.
Показывать только мои | FILTER_MY | [Y|N] При отмеченной опции Top-список будет формироваться только из рабочих групп пользователя, просматривающего данную страницу.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, в которой передается страница социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, в которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group_top","",Array(
        "PAGE_VAR" => "page",
        "GROUP_VAR" => "group_id",
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "PATH_TO_GROUP_SEARCH" => "index.php",
        "ITEMS_COUNT" => "6",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "DISPLAY_IMAGE" => "Y",
        "DISPLAY_DESCRIPTION" => "Y",
        "DISPLAY_NUMBER_OF_MEMBERS" => "Y",
        "DISPLAY_SUBJECT" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Бизнес-процессы

Описание socialnetwork.bizproc

Компонент выводит задания и историю по бизнес-процессам. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Бизнес-процессы.

Параметры

Поле | Параметр | Описание
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для задания | TASK_VAR | Указывается имя переменной, которой передается идентификатор задания некоторого бизнес-процесса.
Шаблоны ссылок
Шаблон пути к обработке задания | PATH_TO_BIZPROC_EDIT | Задается путь к странице обработки задания бизнес-процесса.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочке навигации будет отображаться пункт Бизнес-процессы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено Бизнес-процессы.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.bizproc","",Array(
        "PAGE_VAR" => "page",
        "TASK_VAR" => "task_id",
        "PATH_TO_BIZPROC_EDIT" => "bizproc_task.php?task_id=#task_id#",
        "SET_NAV_CHAIN" => "Y",
        "SET_TITLE" => "Y"
    )
);?>


Входящие сообщения

Описание socialnetwork.messages_input

Компонент позволяет показать входящие сообщения социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: компонент устарел в связи с выходом модуля Веб-мессенджер (с версии 11.5).

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Входящие сообщения.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Внешний вид
Количество записей в списке | ITEMS_COUNT | Указывается количество входящих сообщений, отображаемых на одной странице. Все сообщения будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице отправки сообщений | PATH_TO_MESSAGE_FORM | Задается путь к странице отправки сообщений социальной сети.
Шаблон пути к странице ответа на сообщение | PATH_TO_MESSAGE_FORM_MESS | Задается путь к странице ответа на сообщение социальной сети.
Шаблон пути к входящим сообщениям | PATH_TO_MESSAGES_INPUT | Задается путь к странице входящих сообщений социальной сети.
Шаблон пути к входящим сообщениям с фильтром по пользователю | PATH_TO_MESSAGES_INPUT_USER | Задается путь к входящим сообщениям с фильтром по пользователю социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Входящие сообщения.
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Имена переменных
Имя переменной для сообщения | MESSAGE_VAR | Указывается имя переменной, которой передается идентификатор сообщения социальной сети.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.messages_input",".default",Array(
        "SET_NAV_CHAIN" => "Y",
        "MESSAGE_VAR" => "message_id",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM" => "message_form.php?page=message_form&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM_MESS" => "message_form.php?page=message_form&user_id=#user_id#&message_id=#message_id#",
        "PATH_TO_MESSAGES_INPUT" => "messages_input.php",
        "PATH_TO_MESSAGES_INPUT_USER" => "messages_input.php?page=messages_input&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "USER_ID" => $user_id,
        "PATH_TO_SMILE" => "/bitrix/images/socialnetwork/smile/",
        "ITEMS_COUNT" => "30"
    )
);?>


Выход из группы

Описание socialnetwork.user_leave_group

Компонент позволяет выйти из группы социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Выход из группы.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Группы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <имя_группы> : Выход из группы.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_leave_group","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "/community/socnet/index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "GROUP_VAR" => "group_id",
        "GROUP_ID" => $group_id,
        "SET_TITLE" => "Y"
    )
);?>


Группы пользователя

Описание socialnetwork.user_groups

Компонент позволяет просмотреть и изменить группы пользователя социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Группы пользователя.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Внешний вид
Количество записей в списке | ITEMS_COUNT | Указывается количество визиток групп, отображаемых на одной странице. Все визитки будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице создания группы | PATH_TO_GROUP_CREATE | Задается путь к странице создания новой группы социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к обновлениям | PATH_TO_LOG | Задается путь к странице обновлений социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Группы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено Группы.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_groups","",Array(
        "SET_NAVCHAIN" => "Y",
        "ITEMS_COUNT" => "30",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP_CREATE" => "group_add.php?page=create&user_id=#user_id#",
        "PATH_TO_GROUP" => "/community/workgroups/group_view.php?page=group&group_id=#group_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "PATH_TO_LOG" => "user_log.php?page=log&user_id=#user_id#",
        "GROUP_VAR" => "group_id",
        "USER_ID" => $user_id,
        "SET_TITLE" => "Y"
    )
);?>


Дни рождения друзей

Описание socialnetwork.user_birthday

Компонент выводит ближайшие дни рождения друзей пользователя социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: компонент не используется на КП.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Дни рождения друзей.

Параметры

Поле | Параметр | Описание
Внешний вид
Количество записей в списках | ITEMS_COUNT | Указывается количество записей о ближайших днях рождениях друзей пользователя, которые будут отображены.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Источник данных
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_birthday","",Array(
        "ITEMS_COUNT" => "30",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "USER_ID" => $id
    )
);?>


Добавление друга

Описание socialnetwork.user_friends_add

Компонент позволяет отправить запрос на добавление друга социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: компонент не используется на КП.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Добавление друга.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Добавление в список друзей.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <пользователь> : Добавление в список друзей.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Источник данных
Идентификатор пользователя | ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_friends_add","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "ID" => $user_id,
        "SET_TITLE" => "Y"
    )
);?>


Друзья пользователя

Описание socialnetwork.user_friends

Компонент позволяет просмотреть и изменить друзей пользователя социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: компонент не используется на КП.
Устарел, рекомендуется socialnetwork.user_friends.ex

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Друзья пользователя.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Внешний вид
Количество записей в списках | ITEMS_COUNT | Указывается количество визиток друзей пользователя, отображаемых на одной странице. Все визитки будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к обновлениям | PATH_TO_LOG | Задается путь к странице обновлений социальной сети.
Шаблон пути к странице добавления в друзья | PATH_TO_USER_FRIENDS_ADD | Задается путь к странице добавления в друзья социальной сети.
Шаблон пути к странице удаления из друзей | PATH_TO_USER_FRIENDS_DELETE | Задается путь к странице удаления из друзей социальной сети.
Шаблон пути к странице поиска пользователей | PATH_TO_SEARCH | Задается путь к странице поиска пользователей социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Друзья.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено Друзья.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_friends","",Array(
        "SET_NAVCHAIN" => "Y",
        "ITEMS_COUNT" => "30",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_LOG" => "user_subscribe.php?page=subscribe&user_id=#user_id#",
        "PATH_TO_USER_FRIENDS_ADD" => "user_friends_add.php?page=user_friends_add&user_id=#user_id#",
        "PATH_TO_USER_FRIENDS_DELETE" => "user_friends_delete.php?page=user_friends_delete&user_id=#user_id#",
        "PATH_TO_SEARCH" => "user_search.php",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "ID" => $user_id,
        "SET_TITLE" => "Y"
    )
);?>


Запрос пользователя на вступление в группу

Описание socialnetwork.user_request_group

Компонент позволяет пользователю отправить запрос на вступление в группу социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Запрос пользователя на вступление в группу.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице запросов на вступление в группу | PATH_TO_GROUP_REQUESTS | Задается путь к странице запросов на вступление в группу социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Запрос на присоединение к группе.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <имя_группы> : Запрос на присоединение к группе.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_request_group","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "/community/socnet/index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "PAGE_VAR" => "page",
        "GROUP_VAR" => "group_id",
        "USER_VAR" => "user_id",
        "GROUP_ID" => $group_id,
        "SET_TITLE" => "Y"
    )
);?>


Запросы на вступление в группу

Описание socialnetwork.group_requests

Компонент позволяет просмотреть и изменить запросы на вступление в группу социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Запросы на вступление в группу.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Внешний вид
Количество записей в списке | ITEMS_COUNT | Указывается количество запросов на вступление в группу, отображаемых на одной странице. Все запросы будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице запросов на вступление в группу | PATH_TO_GROUP_REQUESTS | Задается путь к странице запросов на вступление в группу социальной сети.
Шаблон пути к странице запроса к пользователю на вступление в группу | PATH_TO_GROUP_REQUEST_SEARCH | Задается путь к странице запроса к пользователю на вступление в группу социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Запросы на вступление в группу.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <имя_группы> : Запросы на вступление в группу.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group_requests",".default",Array(
        "GROUP_ID" => $group_id,
        "ITEMS_COUNT" => "30",
        "PATH_TO_USER" => "/community/socnet/index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "group_features.php?page=group_features&group_id=#group_id#",
        "PATH_TO_GROUP_REQUESTS" => "group_requests.php?page=group_requests&group_id=#group_id#",
        "PATH_TO_GROUP_REQUEST_SEARCH" => "group_invite.php?page=group_request_search&group_id=#group_id#",
        "SET_NAVCHAIN" => "Y",
        "SET_TITLE" => "Y",
        "PAGE_VAR" => "page",
        "GROUP_VAR" => "group_id",
        "USER_VAR" => "user_id"
    )
);?>


Запросы пользователю

Описание socialnetwork.messages_requests

Компонент позволяет показать запросы пользователю социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Запросы пользователю.

Параметры

Поле | Параметр | Описание
Внешний вид
Количество записей в списке | ITEMS_COUNT | Указывается количество запросов, отображаемых на одной странице. Все запросы будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице отправки сообщений | PATH_TO_MESSAGE_FORM | Задается путь к странице отправки сообщений социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Запросы пользователю.
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.messages_requests","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM" => "message_form.php?page=message_form&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "PATH_TO_SMILE" => "/bitrix/images/socialnetwork/smile/",
        "ITEMS_COUNT" => "30"
    )
);?>


Исходящие сообщения

Описание socialnetwork.messages_output

Компонент позволяет показать исходящие сообщения социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент расположен по пути Общение > Социальная сеть > Исходящие сообщения.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Внешний вид
Количество записей в списке | ITEMS_COUNT | Указывается количество исходящих сообщений, отоброжаемых на одной странице. Все сообщения будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице отправки сообщений | PATH_TO_MESSAGE_FORM | Задается путь к странице отправки сообщений социальной сети.
Шаблон пути к исходящим сообщениям | PATH_TO_MESSAGES_OUTPUT | Задается путь к исходящим сообщениям социальной сети.
Шаблон пути к исходящим сообщениям с фильтром по пользователю | PATH_TO_MESSAGES_OUTPUT_USER | Задается путь к исходящим сообщениям с фильтром по пользователю социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Исходящие сообщения.
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.messages_output","",Array(
        "SET_NAVCHAIN" => "Y",
        "ITEMS_COUNT" => "30",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM" => "message_form.php?page=message_form&user_id=#user_id#",
        "PATH_TO_MESSAGES_OUTPUT" => "messages_output.php",
        "PATH_TO_MESSAGES_OUTPUT_USER" => "messages_output.php?page=messages_output&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "USER_ID" => $user_id,
        "PATH_TO_SMILE" => "/bitrix/images/socialnetwork/smile/"
    )
);?>


Лог активности пользователя

Описание socialnetwork.activity

Компонент выводит лог активности пользователя социальной сети. Компонент содержит три шаблона: (.default), (main) и (short). Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Устарел, рекомендуется socialnetwork.log.ex.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Лог обновлений.
Источник данных
Количество дней лога | LOG_DATE_DAYS | Количество дней ведения лога изменений социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.activity","",Array(
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "GROUP_VAR" => "group_id",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "community/workgroups/group_view.php?page=group&group_id=#group_id#",
        "SET_NAVCHAIN" => "Y",
        "LOG_DATE_DAYS" => "7"
    )
);?>


Лог изменений (ex)

Описание socialnetwork.log.ex

Компонент получает список записей социальной сети для показа, а в его шаблоне подключаются компоненты bitrix:socialnetwork.log.entry и bitrix:socialnetwork.blog.post, получающие список комментариев к каждой из записей и отображающие запись вместе с комментариями. При этом реализовано кеширование на уровне каждой записи Живой ленты, вместо компонентного AJAX используется API, реализованное непосредственно в компоненте.
Компонент содержит шаблон: .default. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Количество дней лога | LOG_DATE_DAYS | Количество дней ведения лога изменений социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Лог обновлений.
Учитывать подписку | SUBSCRIBE_ONLY | [Y|N] При отмеченной опции будет отображаться лог изменений с учетом подписки, иначе - весь лог.
Количество отображаемых записей | LOG_CNT | Указывается количество записей в логе изменений.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.log.ex","",Array(
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "GROUP_VAR" => "group_id",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "community/workgroups/group_view.php?page=group&group_id=#group_id#",
        "SET_NAVCHAIN" => "Y",
        "SUBSCRIBE_ONLY" => "Y",
        "LOG_CNT" => "50",
        "LOG_DATE_DAYS" => "7"
        "USE_COMMENTS" => "Y"
    )
);?>


Лог изменений (entry)

Описание socialnetwork.log.entry

Компонент получает cписок комментариев к каждой из записей социальной сети.

Компонент относится к модулю Социальная сеть.

Компонент содержит шаблон: .default. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Количество дней лога | LOG_DATE_DAYS | Количество дней ведения лога изменений социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Лог обновлений.
Учитывать подписку | SUBSCRIBE_ONLY | [Y|N] При отмеченной опции будет отображаться лог изменений с учетом подписки, иначе - весь лог.
Количество отображаемых записей | LOG_CNT | Указывается количество записей в логе изменений.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.log.entry","",Array(
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "GROUP_VAR" => "group_id",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "community/workgroups/group_view.php?page=group&group_id=#group_id#",
        "SET_NAVCHAIN" => "Y",
        "SUBSCRIBE_ONLY" => "Y",
        "LOG_CNT" => "50",
        "LOG_DATE_DAYS" => "7",
        "USE_COMMENTS" => "Y"
    )
);?>


Меню профайла группы

Описание socialnetwork.group_menu

Компонент показывает меню профайла группы социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Шаблоны ссылок
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице руководства группы | PATH_TO_GROUP_MODS | Задается путь к странице модераторов группы социальной сети.
Шаблон пути к странице членов группы | PATH_TO_GROUP_USERS | Задается путь к странице членов группы социальной сети.
Шаблон пути к странице редактирования группы | PATH_TO_GROUP_EDIT | Задается путь к странице редактирования группы социальной сети.
Шаблон пути к странице приглашения пользователей в группу | PATH_TO_GROUP_REQUEST_SEARCH | Задается путь к странице приглашения пользователей в группу социальной сети.
Шаблон пути к странице черного списка пользователей | PATH_TO_GROUP_BAN | Задается путь к странице черного списка пользователей группы социальной сети.
Шаблон пути к странице запросов пользователей на вступление | PATH_TO_GROUP_REQUESTS | Задается путь к странице запросов пользователей на вступление в группу социальной сети.
Шаблон пути к странице блога группы | PATH_TO_GROUP_BLOG | Задается путь к странице блога группы социальной сети.
Шаблон пути к странице фото группы | PATH_TO_GROUP_PHOTO | Задается путь к странице фото группы социальной сети.
Шаблон пути к странице форума группы | PATH_TO_GROUP_FORUM | Задается путь к странице форума группы социальной сети.
Шаблон пути к странице календаря группы | PATH_TO_GROUP_CALENDAR | Задается путь к странице календаря группы социальной сети.
Шаблон пути к странице задач группы | PATH_TO_GROUP_TASK | Задается путь к странице задач группы социальной сети.
Шаблон пути к странице файлов группы | PATH_TO_GROUP_FILES | Задается путь к странице файлов группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group_menu",".default",Array(
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "PATH_TO_GROUP_MODS" => "group_mods.php?page=group_mods&group_id=#group_id#",
        "PATH_TO_GROUP_USERS" => "group_users.php?page=group_users&group_id=#group_id#",
        "PATH_TO_GROUP_EDIT" => "group_edit.php?page=group_edit&group_id=#group_id#",
        "PATH_TO_GROUP_REQUEST_SEARCH" => "group_invite.php?page=group_request_search&group_id=#group_id#",
        "PATH_TO_GROUP_BAN" => "group_ban.php?page=group_ban&group_id=#group_id#",
        "PATH_TO_GROUP_REQUESTS" => "group_requests.php?page=group_requests&group_id=#group_id#",
        "PATH_TO_GROUP_BLOG" => "group_blog.php?page=group_blog&group_id=#group_id#",
        "PATH_TO_GROUP_PHOTO" => "group_photo.php?page=group_photo&group_id=#group_id#",
        "PATH_TO_GROUP_FORUM" => "group_forum.php?page=group_forum&group_id=#group_id#",
        "PATH_TO_GROUP_CALENDAR" => "group_calendar.php?page=group_calendar&group_id=#group_id#",
        "PATH_TO_GROUP_TASK" => "group_task.php?page=group_task&group_id=#group_id#",
        "PATH_TO_GROUP_FILES" => "group_files.php?page=group_files&group_id=#group_id#",
        "PAGE_VAR" => "page",
        "GROUP_VAR" => "group_id",
        "GROUP_ID" => $group_id
    )
);?>


Меню профайла пользователя

Описание socialnetwork.user_menu

Компонент показывает меню профайла пользователя социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице добавления в друзья | PATH_TO_USER_FRIENDS_ADD | Задается путь к странице добавления в друзья социальной сети.
Шаблон пути к странице входящих сообщений | PATH_TO_MESSAGES_INPUT | Задается путь к странице входящих сообщений социальной сети.
Шаблон пути к странице отправки сообщений | PATH_TO_MESSAGE_FORM | Задается путь к странице отправки сообщений социальной сети.
Шаблон пути к странице удаления из друзей | PATH_TO_USER_FRIENDS_DELETE | Задается путь к странице удаления из друзей социальной сети.
Шаблон пути к странице друзей пользователя | PATH_TO_USER_FRIEND | Задается путь к странице друзей пользователя социальной сети.
Шаблон пути к странице поиска пользователей | PATH_TO_SEARCH | Задается путь к странице поиска пользователей социальной сети.
Шаблон пути к странице добавления групп | PATH_TO_USER_GROUPS_ADD | Задается путь к странице добавления групп социальной сети.
Шаблон пути к странице групп пользователя | PATH_TO_USER_GROUPS | Задается путь к странице групп пользователя социальной сети.
Шаблон пути к странице редактирования пользователя | PATH_TO_USER_EDIT | Задается путь к странице редактирования пользователя социальной сети.
Шаблон пути к странице блога пользователя | PATH_TO_USER_BLOG | Задается путь к странице блога пользователя социальной сети.
Шаблон пути к странице фото пользователя | PATH_TO_USER_PHOTO | Задается путь к странице фото пользователя социальной сети.
Шаблон пути к странице форума пользователя | PATH_TO_USER_FORUM | Задается путь к странице форума пользователя социальной сети.
Шаблон пути к странице календаря пользователя | PATH_TO_USER_CALENDAR | Задается путь к странице календаря пользователя социальной сети.
Шаблон пути к странице задач пользователя | PATH_TO_USER_TASKS | Задается путь к странице задач пользователя социальной сети.
Шаблон пути к странице файлов пользователя | PATH_TO_USER_FILES | Задается путь к странице файлов пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_menu",".default",Array(
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_USER_FRIENDS_ADD" => "user_friends_add.php?page=user_friends_add&user_id=#user_id#",
        "PATH_TO_MESSAGES_INPUT" => "messages_input.php?page=messages_input&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM" => "message_form.php?page=message_form&user_id=#user_id#",
        "PATH_TO_USER_FRIENDS_DELETE" => "user_friends_delete.php?page=user_friends_delete&user_id=#user_id#",
        "PATH_TO_USER_FRIENDS" => "user_friends.php?page=user_friends&user_id=#user_id#",
        "PATH_TO_SEARCH" => "user_search.php",
        "PATH_TO_USER_GROUPS_ADD" => "group_add.php?page=create&user=#user_id#",
        "PATH_TO_USER_GROUPS" => "user_groups.php?page=user_groups&user=#user_id#",
        "PATH_TO_USER_EDIT" => "user_edit.php?page=user_edit&user_id=#user_id#",
        "PATH_TO_USER_BLOG" => "user_blog.php?page=user_blog&user_id=#user_id#",
        "PATH_TO_USER_PHOTO" => "user_photo.php?page=user_photo&user_id=#user_id#",
        "PATH_TO_USER_FORUM" => "user_forum.php?page=user_forum&user_id=#user_id#",
        "PATH_TO_USER_CALENDAR" => "user_calendar.php?page=user_calendar&user_id=#user_id#",
        "PATH_TO_USER_TASKS" => "",
        "PATH_TO_USER_FILES" => "user_files.php?page=user_files&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "ID" => $user_id
    )
);?>


Меню сообщений пользователя

Описание socialnetwork.messages_menu

Компонент показывает меню сообщений пользователя социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор страницы | PAGE_ID | Параметр содержит код, в котором передается идентификатор страницы социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице переписки | PATH_TO_MESSAGES_USERS | Задается путь к странице переписки.
Шаблон пути к странице входящих сообщений | PATH_TO_MESSAGES_INPUT | Задается путь к странице входящих сообщений социальной сети.
Шаблон пути к странице исходящих сообщений | PATH_TO_MESSAGES_OUTPUT | Задается путь к странице исходящих сообщений социальной сети.
Шаблон пути к странице черного списка | PATH_TO_USER_BAN | Задается путь к странице черного списка социальной сети.
Шаблон пути к странице обновлений | PATH_TO_LOG | Задается путь к странице обновлений социальной сети.
Шаблон пути к странице подписки | PATH_TO_SUBSCRIBE | Задается путь к странице подписки социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.messages_menu",".default",Array(
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_MESSAGES_USERS" => "messages_users.php",
        "PATH_TO_MESSAGES_INPUT" => "messages_input.php",
        "PATH_TO_MESSAGES_OUTPUT" => "messages_output.php",
        "PATH_TO_USER_BAN" => "user_ban.php",
        "PATH_TO_LOG" => "user_log.php",
        "PATH_TO_SUBSCRIBE" => "user_subscribe.php",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "PAGE_ID" => $page
    )
);?>


Модераторы группы

Описание socialnetwork.group_mods

Компонент служит для просмотра и изменения модераторов группы социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Устарел, рекомендуется socialnetwork.group_users.ex.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Внешний вид
Количество записей в списке | ITEMS_COUNT | Указывается количество визитных карточек модераторов, отоброжаемых на одной странице. Все визитки будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице модераторов группы | PATH_TO_GROUP_MODS | Задается путь к странице модераторов группы социальной сети.
Шаблон пути к странице членов группы | PATH_TO_GROUP_USERS | Задается путь к странице участников группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Модераторы группы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <имя_группы> : Модераторы группы.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group_mods","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "/community/socnet/index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "PATH_TO_GROUP_MODS" => "group_mods.php?page=group_mods&group_id=#group_id#",
        "PATH_TO_GROUP_USERS" => "group_users.php?page=group_users&group_id=#group_id#",
        "PAGE_VAR" => "page",
        "GROUP_VAR" => "group_id",
        "USER_VAR" => "user_id",
        "ITEMS_COUNT" => "30",
        "GROUP_ID" => $group_id,
        "SET_TITLE" => "Y"
    )
);?>


Настройка разрешений пользователя

Описание socialnetwork.user_settings_edit

Компонент позволяет настраивать разрешения пользователя (приватность) социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Идентификатор страницы | PAGE_ID | Параметр содержит код, в котором передается идентификатор страницы социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Приватность пользователя.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено Приватность пользователя.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_settings_edit","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "USER_ID" => $user_id,
        "PAGE_ID" => $page,
        "SET_TITLE" => "Y"
    )
);?>


Настройка функционала

Описание socialnetwork.features

Компонент позволяет настраивать функционал пользователей и рабочих групп социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Идентификатор страницы | PAGE_ID | Параметр содержит код, в котором передается идентификатор страницы социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Настройки пользователя или Настройки группы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <пользователь> : Настройки пользователя или <имя_группы> : Настройки группы.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.features","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "index.php?page=user&user=#user_id#",
        "PATH_TO_GROUP" => "/community/workgroups/group_view.php?page=group&group_id=#group_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "GROUP_VAR" => "group_id",
        "GROUP_ID" => $group_id,
        "USER_ID" => $user_id,
        "PAGE_ID" => $page,
        "SET_TITLE" => "Y"
    )
);?>


Обработка задания Бизнес-процесса

Описание socialnetwork.bizproc_edit

Компонент позволяет обработать задание бизнес-процесса. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для задания | TASK_VAR | Указывается имя переменной, которой передается идентификатор задания некоторого бизнес-процесса.
Шаблоны ссылок
Шаблон пути к Бизнес-процессам | PATH_TO_BIZPROC | Задается путь к странице бизнес-процессов.
Источник данных
Идентификатор задания | TASK_ID | Параметр содержит код, в котором передается идентификатор задания некоторого бизнес-процесса.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочке навигации будет отображаться пункт Бизнес-процессы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено Обработка задания <номер_задания>.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.bizproc_edit","",Array(
        "PAGE_VAR" => "page",
        "TASK_VAR" => "task_id",
        "PATH_TO_BIZPROC" => "bizproc.php",
        "TASK_ID" => $task_id,
        "SET_NAV_CHAIN" => "Y",
        "SET_TITLE" => "Y"
    )
);?>


Переписка в виде чата

Описание socialnetwork.messages_chat

Компонент позволяет показать переписку в виде чата социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт <пользователь> : Обмен сообщениями.
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/>.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к истории сообщений пользователя | PATH_TO_MESSAGES_USERS_MESSAGES | Задается путь к странице с историей сообщений пользователя социальной сети.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Источник данных
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.messages_chat","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_MESSAGES_USERS_MESSAGES" => "messages_users_messages.php?page=messages_users_messages&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "USER_ID" => $user_id,
        "PATH_TO_SMILE" => "/bitrix/images/socialnetwork/smile/"
    )
);?>


Переписка с пользователем

Описание socialnetwork.messages_users_messages

Компонент позволяет показать переписку с пользователем социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Внешний вид
Число записей на странице | ITEMS_COUNT | Указывается количество сообщений, отоброжаемых на одной странице. Все сообщения будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице отправки сообщений | PATH_TO_MESSAGE_FORM | Задается путь к странице отправки сообщений социальной сети.
Шаблон пути к странице ответа на сообщение | PATH_TO_MESSAGE_FORM_MESS | Задается путь к странице ответа на сообщение социальной сети.
Шаблон пути к странице чата с пользователем | PATH_TO_MESSAGES_CHAT | Задается путь к странице чата с пользователем социальной сети.
Шаблон пути к странице переписки | PATH_TO_MESSAGES_USERS | Задается путь к странице переписки с пользователями социальной сети.
Шаблон пути к переписке с пользователем | PATH_TO_MESSAGES_USERS_MESSAGES | Задается путь к странице переписки с указанным пользователем социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Переписка.
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Имена переменных
Имя переменной для сообщения | MESSAGE_VAR | Указывается имя переменной, которой передается идентификатор сообщения социальной сети.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.messages_users_messages","",Array(
        "SET_NAVCHAIN" => "Y",
        "MESSAGE_VAR" => "message_id",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM" => "message_form.php?page=message_form&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM_MESS" => "message_form.php?page=message_form&user_id=#user_id#&message_id=#message_id#",
        "PATH_TO_MESSAGES_CHAT" => "messages_chat.php?page=messages_chat&user_id=#user_id#",
        "PATH_TO_MESSAGES_USERS" => "messages_users.php",
        "PATH_TO_MESSAGES_USERS_MESSAGES" => "messages_users_messages.php?page=messages_users_messages&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "USER_ID" => $user_id,
        "PATH_TO_SMILE" => "/bitrix/images/socialnetwork/smile/",
        "ITEMS_COUNT" => "20"
    )
);?>


Переписка с пользователями

Описание socialnetwork.messages_users

Компонент позволяет показать переписку с пользователями социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Внешний вид
Число записей на странице | ITEMS_COUNT | Указывается количество записей о переписках с пользователями, отоброжаемых на одной странице. Все записи будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице отправки сообщений | PATH_TO_MESSAGE_FORM | Задается путь к странице отправки сообщений социальной сети.
Шаблон пути к странице чата с пользователем | PATH_TO_MESSAGES_CHAT | Задается путь к странице чата с пользователем социальной сети.
Шаблон пути к странице переписки | PATH_TO_MESSAGES_USERS | Задается путь к странице переписки с пользователями социальной сети.
Шаблон пути к переписке с пользователем | PATH_TO_MESSAGES_USERS_MESSAGES | Задается путь к странице переписки с указанным пользователем социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Переписка с пользователями.
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.messages_users","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM" => "message_form.php?page=message_form&user_id=#user_id#",
        "PATH_TO_MESSAGES_CHAT" => "messages_chat.php?page=messages_chat&user_id=#user_id#",
        "PATH_TO_MESSAGES_CHAT" => "messages_users.php",
        "PATH_TO_MESSAGES_USERS_MESSAGES" => "messages_users_messages.php?page=messages_users_messages&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "USER_ID" => $user_id,
        "PATH_TO_SMILE" => "/bitrix/images/socialnetwork/smile/",
        "ITEMS_COUNT" => "20"
    )
);?>


Подписка

Описание socialnetwork.subscribe

Компонент служит для настройки подписки социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Устарел с версии 14.0 в связи с появлением Умного слежения в Живой ленте.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Идентификатор страницы | PAGE_ID | Параметр содержит код, в котором передается идентификатор страницы социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице подписок | PATH_TO_SUBSCRIBE | Задается путь к странице подписок социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Подписка.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <пользователь> : Подписка или <имя_группы> : Подписка.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.subscribe","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "/community/socnet/index.php?page=user&user_id=#user_id#",
        "PATH_TO_SUBSCRIBE" => "/community/socnet/user_subscribe.php?page=subscribe&user_id=#user_id#",
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "GROUP_VAR" => "group_id",
        "GROUP_ID" => $group_id,
        "USER_ID" => $user_id,
        "PAGE_ID" => $page,
        "SET_TITLE" => "Y"
    )
);?>


Поиск групп

Описание socialnetwork.group_search

Компонент служит для создания страницы поиска рабочих групп. С помощью компонента отображается форма фильтра и список групп, удовлетворяющих условиям поиска. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Код темы | SUBJECT_ID | Параметр содержит код, в котором передается код темы рабочих групп социальной сети.
Внешний вид
Число записей на страницу | ITEMS_COUNT | Указывается количество найденных групп, отоброжаемых на одной странице. Все группы будут выведены с помощью постраничной навигации.
Формат даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Шаблоны ссылок
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице поиска групп | PATH_TO_GROUP_SEARCH | Задается путь к странице поиска групп социальной сети.
Шаблон пути к странице создания группы | PATH_TO_GROUP_CREATE | Задается путь к странице создания группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Поиск групп.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено Поиск групп.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group_search",".default",Array(
    "SET_NAVCHAIN" => "Y",
    "PAGE_VAR" => "page",
    "USER_VAR" => "user_id",
    "SUBJECT_ID" => $subject_id,
    "GROUP_VAR" => "group_id",
    "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
    "PATH_TO_GROUP_SEARCH" => "index.php",
    "PATH_TO_GROUP_CREATE" => "/community/socnet/group_add.php?page=create&user_id=#user_id#",
    "ITEMS_COUNT" => "8",
    "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
    "SET_TITLE" => "Y"
    )
);?>


Поиск пользователей

Описание socialnetwork.user_search

Компонент позволяет искать пользователей социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Внешний вид
Число записей на страницу | ITEMS_COUNT | Указывается количество найденных пользователей, отоброжаемых на одной странице. Все найденные пользователи будут выведены с помощью постраничной навигации.
Формат даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице поиска пользователей | PATH_TO_SEARCH | Задается путь к странице поиска пользователей социальной сети.
Шаблон пути к внутренней странице поиска пользователей | PATH_TO_SEARCH_INNER | Задается путь к внутренней странице поиска пользователей социальной сети.
Шаблон пути к странице добавления в друзья | PATH_TO_USER_FRIENDS_ADD | Задается путь к странице добавления в друзья социальной сети.
Шаблон пути к странице отправки сообщений | PATH_TO_MESSAGE_FORM | Задается путь к странице отправки сообщений социальной сети.
Шаблон пути к странице чата | PATH_TO_MESSAGES_CHAT | Задается путь к странице чата социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Поиск пользователей.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено Поиск пользователей.
Выбирать пользователей без заданного фильтра | SHOW_USERS_WITHOUT_FILTER_SET | [Y|N] При отмеченной опции на странице будут отображен список пользователей.
Поля пользователя для простой формы поиска | USER_FIELDS_SEARCH_SIMPLE | Указываются свойства пользователя, которые должны быть отображены на простой форме поиска сотрудника.
Пользовательские свойства пользователя для простой формы поиска | USER_PROPERTIES_SEARCH_SIMPLE | Указываются дополнительные свойства пользователя, которые также должны быть отображены на простой форме поиска сотрудника.
Поля пользователя для расширенной формы поиска | USER_FIELDS_SEARCH_ADV | Указываются свойства пользователя, которые должны быть отображены на расширенной форме поиска сотрудника.
Пользовательские свойства пользователя для расширенной формы поиска | USER_PROPERTIES_SEARCH_ADV | Указываются дополнительные свойства пользователя, которые также должны быть отображены на расширенной форме поиска сотрудника.
Поля пользователя для вывода в списке | USER_FIELDS_LIST | Указываются поля пользователя, которые должны быть отображены при показе списка сотрудников.
Пользовательские свойства пользователя для вывода в списке | USER_PROPERTIES_LIST | Указываются дополнительные свойства пользователя, которые также должны быть отображены при показе списка сотрудников.
Поля пользователя, по которым возможен поиск | SONET_USER_FIELDS_SEARCHABLE | Указываются поля пользователя, по которым будет осуществляться поиск сотрудников.
Пользовательские свойства пользователя, по которым возможен поиск | SONET_USER_PROPERTY_SEARCHABLE | Указываются дополнительные свойства пользователя, по которым также будет осуществляться поиск сотрудников.
Показывать год рождения SHOW_YEAR Параметр определяет для каких сотрудников должен быть отображен год рождения:
  • Y - всем;
  • M - только мужчинам;
  • N - никому.
Учитывать рейтинг в сортировке | ALLOW_RATING_SORT | [Y|N] При отмеченной опции при выводе поискового запроса по пользователям будет учитываться их рейтинг.
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.
Рейтинг | RATING_ID | Указывается какой будет использоваться рейтинг.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_search","",Array(
        "SET_NAVCHAIN" => "Y",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_SEARCH" => "/company/index.php",
        "PATH_TO_SEARCH_INNER" => "user_search.php",
        "PATH_TO_USER_FRIENDS_ADD" => "user_friends_add.php?page=user_friends_add&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM" => "message_form.php?page=message_form&user_id=#user_id#",
        "PATH_TO_MESSAGES_CHAT" => "messages_chat.php?page=messages_chat&user_id=#user_id#",
        "ITEMS_COUNT" => "10",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SET_TITLE" => "Y",
        "USER_FIELDS_SEARCH_SIMPLE" => Array(),
        "SHOW_USERS_WITHOUT_FILTER_SET" => "N",
        "USER_PROPERTIES_SEARCH_SIMPLE" => Array("UF_DEPARTMENT"),
        "USER_FIELDS_SEARCH_ADV" => Array("EMAIL"),
        "USER_PROPERTIES_SEARCH_ADV" => Array("UF_DEPARTMENT"),
        "USER_FIELDS_LIST" => Array("NAME","SECOND_NAME","LAST_NAME","EMAIL"),
        "USER_PROPERTIES_LIST" => Array("UF_DEPARTMENT"),
        "SONET_USER_FIELDS_SEARCHABLE" => Array("NAME","SECOND_NAME","LAST_NAME","EMAIL"),
        "SONET_USER_PROPERTY_SEARCHABLE" => Array(),
        "SHOW_YEAR" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
        "SHOW_RATING" => "Y",
        "RATING_ID" => array(),
    )
);?>


Показ событий

Описание socialnetwork.events

Компонент позволяет показать события: новое сообщение, запрос на добавление в список друзей и пр. социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице отправки сообщений | PATH_TO_MESSAGE_FORM | Задается путь к странице отправки сообщений социальной сети.
Шаблон пути к странице ответа на сообщение | PATH_TO_MESSAGE_FORM_MESS | Задается путь к странице ответа на сообщение социальной сети.
Шаблон пути к странице чата | PATH_TO_MESSAGES_CHAT | Задается путь к странице чата социальной сети.
Дополнительные настройки
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для сообщения | MESSAGE_VAR | Указывается имя переменной, которой передается идентификатор сообщения социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.events","",Array(
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM" => "message_form.php?page=message_form&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM_MESS" => "message_form.php?page=message_form&user_id=#user_id#&message_id=#message_id#",
        "PATH_TO_MESSAGES_CHAT" => "messages_chat.php?page=messages_chat&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "MESSAGE_VAR" => "message_id",
        "USER_ID" => $user_id,
        "PATH_TO_SMILE" => "/bitrix/images/socialnetwork/smile/"
    )
);?>


Показ событий (ajax)

Описание socialnetwork.events_dyn

Компонент позволяет показать события с помощью AJAX: новое сообщение, запрос на добавление в список друзей и пр. социальной сети. В поставку продукта входят следующие шаблоны компонента: (.default) и (popup). Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Внешний вид
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени событий.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице отправки сообщений | PATH_TO_MESSAGE_FORM | Задается путь к странице отправки сообщений социальной сети.
Шаблон пути к странице ответа на сообщение | PATH_TO_MESSAGE_FORM_MESS | Задается путь к странице ответа на сообщение социальной сети.
Шаблон пути к странице чата | PATH_TO_MESSAGES_CHAT | Задается путь к странице чата социальной сети.
Дополнительные настройки
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Период опроса сервера | AJAX_LONG_TIMEOUT | Указывается время в секундах, через которое будет осуществляться опрос сервера на предмет наличия новых сообщений.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Блокировать повторный показ уведомления | POPUP | [Y|N] При отмеченной опции повторный показ уведомления производиться не будет.
Показывать год рождения | SHOW_YEAR | Указывается кому показывать день рождения: всем, только мужчинам или никому.
Имена переменных
Имя переменной для сообщения | MESSAGE_VAR | Указывается имя переменной, которой передается идентификатор сообщения социальной сети.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.events_dyn","",Array(
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "MESSAGE_VAR" => "message_id",
        "PATH_TO_GROUP" => "/community/workgroups/group_view.php?page=group&group_id=#group_id#",
        "PATH_TO_MESSAGE_FORM" => "message_form.php?page=message_form&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM_MESS" => "message_form.php?page=message_form&user_id=#user_id#&message_id=#message_id#",
        "PATH_TO_MESSAGES_CHAT" => "messages_chat.php?page=messages_chat&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "PATH_TO_SMILE" => "/bitrix/images/socialnetwork/smile/",
        "AJAX_LONG_TIMEOUT" => "60"
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME_SHORT# #SECOND_NAME_SHORT##/NOBR#",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_YEAR" => "Y",
        "SHOW_LOGIN" => "Y",
        "POPUP" => "N"
    )
);?>


Пользователи группы

Описание socialnetwork.group_users

Компонент позволяет просмотреть и изменить участников группы социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Устарел, рекомендуется socialnetwork.group_users.ex.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Внешний вид
Количество записей в списках | ITEMS_COUNT | Указывается количество визитных карточек участников группы, отображаемых на одной странице. Список всех участников группы будет выведен с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице модераторов группы | PATH_TO_GROUP_MODS | Задается путь к странице модераторов группы социальной сети.
Шаблон пути к странице членов группы | PATH_TO_GROUP_USERS | Задается путь к странице участников группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Участники группы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <имя_группы> : Участники группы.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group_users","",Array(
        "SET_NAVCHAIN" => "Y",
        "ITEMS_COUNT" => "30",
        "PATH_TO_USER" => "/community/socnet/index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "PATH_TO_GROUP_MODS" => "group_mods.php?page=group_mods&group_id=#group_id#",
        "PATH_TO_GROUP_USERS" => "group_users.php?page=group_users&group_id=#group_id#",
        "PAGE_VAR" => "page",
        "GROUP_VAR" => "group_id",
        "USER_VAR" => "user_id",
        "GROUP_ID" => $group_id,
        "SET_TITLE" => "Y"
    ),
);?>


Приглашение пользователей в группу

Описание socialnetwork.group_request_search

Компонент позволяет пригласить пользователей в группу социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Устарел, рекомендуется socialnetwork.group_create.ex.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Внешний вид
Количество записей в списках | ITEMS_COUNT | Указывается количество приглашение в группу, отображаемых на одной странице. Все приглашения будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице поиска пользователей | PATH_TO_SEARCH | Задается путь к странице поиска пользователей социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Приглашение в группу.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <имя_группы> : Приглашение в группу.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице поиска пользователей | PATH_TO_SEARCH | Задается путь к странице поиска пользователей социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group_request_search","",Array(
        "SET_NAVCHAIN" => "Y",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "GROUP_VAR" => "group_id",
        "ITEMS_COUNT" => "30",
        "PATH_TO_USER" => "/community/socnet/index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "PATH_TO_SEARCH" => "/community/socnet/user_search.php",
        "GROUP_ID" => $group_id,
        "SET_TITLE" => "Y"
    )
);?>


Друзья пользователя (расширенный)

Описание socialnetwork.user_friends.ex

Позволяет просмотреть и изменить друзей пользователя группы. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Общение > Социальная сеть > Друзья пользователя (расширенный).

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Внешний вид
Количество записей в списке | ITEMS_COUNT | Указывается количество найденных пользователей, отображаемых на одной странице. Все найденные пользователи будут выведены с помощью постраничной навигации.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Размер картинки пользователя (px) | THUMBNAIL_LIST_SIZE | Указывается максимальный размер фотографии в списке пользователей в пикселях.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице поиска пользователей | PATH_TO_SEARCH | Задается путь к странице поиска пользователей социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Поиск пользователей.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено Поиск пользователей.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_friends.ex","",Array(
        "SET_NAV_CHAIN" => "Y",
        "ITEMS_COUNT" => "10",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_SEARCH" => "",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "ID" => "$id",
        "SET_TITLE" => "Y",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "THUMBNAIL_LIST_SIZE" => "42"
    ),
false
);?>


Пользователи группы (расширенный)

Описание socialnetwork.group_users.ex

Позволяет просмотреть и изменить пользователей группы. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Внешний вид
Количество записей в списке | ITEMS_COUNT | Указывается количество найденных пользователей, отображаемых на одной странице. Все найденные пользователи будут выведены с помощью постраничной навигации.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Размер картинки пользователя (px) | THUMBNAIL_LIST_SIZE | Указывается максимальный размер фотографии в списке пользователей в пикселях.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице изменения параметров группы | PATH_TO_GROUP_EDIT | Задается путь к странице редактирования группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции на странице будет установлена цепочка навигации вида {Название группы} - Участники группы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено {Название группы} - Участники группы.
Использовать функционал черного списка в группах | GROUP_USE_BAN | [Y|N] При отмеченной опции будет использоваться функционал черного списка в рабочих группах.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group_users.ex","",Array(
        "SET_NAV_CHAIN" => "Y",
        "ITEMS_COUNT" => "20",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "ID" => "$id",
        "SET_TITLE" => "Y",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "THUMBNAIL_LIST_SIZE" => "42"
    ),
false
);?>


Приглашения на вступление в группу

Описание socialnetwork.group_requests_out

Компонент позволяет просмотреть и изменить приглашения на вступление в группу социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Устарел, рекомендуется socialnetwork.group_requests.ex.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Внешний вид
Количество записей в списках | ITEMS_COUNT | Указывается количество приглашений в группу, отображаемых на одной странице. Все приглашения будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице приглашения пользователю на вступление в группу | PATH_TO_GROUP_REQUEST_SEARCH | Задается путь к странице запроса к пользователю на вступление в группу социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Приглашения на вступление в группу.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <имя_группы> : Приглашения на вступление в группу.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group_requests_out","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "/community/socnet/index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "ITEMS_COUNT" => "30",
        "PATH_TO_GROUP_REQUEST_SEARCH" => "group_invite.php?page=group_request_search&group_id=#group_id#",
        "PAGE_VAR" => "page",
        "GROUP_VAR" => "group_id",
        "USER_VAR" => "user_id",
        "GROUP_ID" => $group_id,
        "SET_TITLE" => "Y"
    )
);?>


Создание группы

Описание socialnetwork.group_create

Компонент позволяет создать новую (редактировать уже существующую) группу социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Устарел, рекомендуется socialnetwork.group_create.ex.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице изменения параметров группы | PATH_TO_GROUP_EDIT | Задается путь к странице изменения параметров группы социальной сети.
Шаблон пути к странице создания новой группы | PATH_TO_GROUP_CREATE | Задается путь к странице создания новой группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации SET_NAVCHAIN [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт:
  • создание группы - Создание новой группы;
  • редактирование группы - Редактирование группы.
Устанавливать заголовок страницы SET_TITLE [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено:
  • создание группы - <имя_группы> : Создание группы;
  • редактирование группы - <имя_группы> : Редактирование группы.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group_create","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "/community/socnet/index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "PATH_TO_GROUP_EDIT" => "group_edit.php?page=group_edit&group_id=#group_id#",
        "PATH_TO_GROUP_CREATE" => "/community/socnet/group_add.php?page=create&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "GROUP_VAR" => "group_id",
        "GROUP_ID" => $group_id,
        "USER_ID" => $user_id,
        "SET_TITLE" => "Y"
    )
);?>


Создание группы в попап-диалоге

Описание socialnetwork.group.iframe.popup

Компонент выводит Создание группы в попап-диалоге позволяет создать новую группу в попап-диалоге. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

Компонент не имеет настроек.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Пример вызова

<?$APPLICATION->IncludeComponent("socialnetwork.group.iframe.popup","",Array(
    )
);?>


Создание группы в попап-диалоге (ex)

Описание socialnetwork.group_create.ex

Компонент выводит Создание группы в попап-диалоге позволяет создать новую группу в попап-диалоге. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

Компонент не имеет настроек.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Пример вызова

<?$APPLICATION->IncludeComponent("socialnetwork.group_create.ex","",Array(
    )
);?>


Список подписки пользователя

Описание socialnetwork.subscribe_list

Компонент позволяет показать список подписки пользователя социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Устарел с версии 14.0 в связи с появлением Умного слежения в Живой ленте.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Внешний вид
Число записей на странице | ITEMS_COUNT | Указывается количество подписок пользователя, отображаемых на одной странице. Все подписки будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице отправки сообщений | PATH_TO_MESSAGE_FORM | Задается путь к странице отправки сообщений социальной сети.
Шаблон пути к странице чата с пользователем | PATH_TO_MESSAGES_CHAT | Задается путь к странице чата с пользователем социальной сети.
Шаблон пути к странице переписки | PATH_TO_MESSAGES_USERS | Задается путь к странице переписки с пользователями социальной сети.
Шаблон пути к переписке с пользователем | PATH_TO_MESSAGES_USERS_MESSAGES | Задается путь к странице переписки с указанным пользователем социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Подписка.
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.subscribe_list","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_MESSAGE_FORM" => "message_form.php?page=message_form&user_id=#user_id#",
        "PATH_TO_MESSAGES_CHAT" => "messages_chat.php?page=messages_chat&user_id=#user_id#",
        "PATH_TO_MESSAGES_USERS" => "messages_users.php",
        "PATH_TO_MESSAGES_USERS_MESSAGES" => "messages_users_messages.php?page=messages_users_messages&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "USER_ID" => $user_id,
        "PATH_TO_SMILE" => "/bitrix/images/socialnetwork/smile/",
        "ITEMS_COUNT" => "10"
    )
);?>


Удаление группы

Описание socialnetwork.group_delete

Компонент служит для удаления группы социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Удаление группы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <имя_группы> : Удаление группы.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group_delete","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "/community/socnet/index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "GROUP_VAR" => "group_id",
        "GROUP_ID" => $group_id,
        "SET_TITLE" => "Y"
    )
);?>


Запросы на вступление в группу (ex)

Описание socialnetwork.group_requests.ex

Позволяет управлять приглашениями и запросами на вступление в группу. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Общение > Социальная сеть > Запросы на вступление в группу.

Параметры

Поле | Параметр | Описание
Количество записей в списке | ITEMS_COUNT | Указывается количество найденных пользователей, отображаемых на одной странице. Все найденные пользователи будут выведены с помощью постраничной навигации.
ID группы соцсети | GROUP_ID | Указывается идентификатор группы соцсети.
Путь к группе | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Устанавливать цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции на странице будет установлена цепочка навигации.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:socialnetwork.group_requests.ex",
    "",
    Array(
        "GROUP_ID" => $group_id,
        "GROUP_VAR" => "",
        "ITEMS_COUNT" => "30",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "PAGE_VAR" => "",
        "PATH_TO_GROUP" => "",
        "PATH_TO_GROUP_EDIT" => "",
        "PATH_TO_USER" => "",
        "SET_NAV_CHAIN" => "Y",
        "SET_TITLE" => "Y",
        "SHOW_LOGIN" => "Y",
        "THUMBNAIL_LIST_SIZE" => "30",
        "USER_VAR" => ""
    )
);?>


Удаление друга

Описание socialnetwork.user_friends_delete

Компонент позволяет удалить друга социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Компонент не используется на Корпоративном портале (КП).

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Удаление друга.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <пользователь> : Удаление друга.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_friends_delete","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "ID" => $user_id,
        "SET_TITLE" => "Y"
    )
);?>


Форма отправки сообщения

Описание socialnetwork.message_form

Компонент позволяет отправить сообщение пользователю социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Устарел с версии 11.5 в связи с выходом модуля Веб-мессенджер (IM).

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Код сообщения | MESSAGE_ID | Параметр содержит код, в котором передается идентификатор сообщения социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице входящих сообщений | PATH_TO_MESSAGES_INPUT | Задается путь к странице входящих сообщений социальной сети.
Шаблон пути к странице исходящих сообщений | PATH_TO_MESSAGES_OUTPUT | Задается путь к странице исходящих сообщений социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Приглашение вступить в группу.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <пользователь> : Приглашение вступить в группу.
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.message_form","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PATH_TO_MESSAGES_INPUT" => "messages_input.php?page=messages_input&user_id=#user_id#",
        "PATH_TO_MESSAGES_OUTPUT" => "messages_output.php?page=messages_output&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "USER_ID" => $user_id,
        "MESSAGE_ID" => $message_id,
        "SET_TITLE" => "Y",
        "PATH_TO_SMILE" => "/bitrix/images/socialnetwork/smile/"
    )
);?>


Форма приглашения пользователя вступить в группу

Описание socialnetwork.group_request_user

Компонент служит для создания формы, с помощью которой отправляется приглашение пользователю вступить в группу социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Устарел, рекомендуется socialnetwork.group_create.ex.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Приглашение вступить в группу.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <пользователь> : Приглашение вступить в группу.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group_request_user","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "/community/socnet/index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "GROUP_VAR" => "group_id",
        "USER_ID" => $user_id,
        "GROUP_ID" => $group_id,
        "SET_TITLE" => "Y"
    )
);?>


Черный список группы

Описание socialnetwork.group_ban

Компонент служит для просмотра и изменения черного списка группы социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы социальной сети.
Внешний вид
Количество записей в списках | ITEMS_COUNT | Указывается количество пользователей из черного списка группы, отображаемых на одной странице. Все пользователи, занесенные в черный список, будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Шаблон пути к странице модераторов группы | PATH_TO_GROUP_MODS | Задается путь к странице модераторов группы социальной сети.
Шаблон пути к странице членов группы | PATH_TO_GROUP_USERS | Задается путь к странице участников группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Черный список группы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено <имя_группы> : Черный список группы.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.group_ban","",Array(
        "SET_NAVCHAIN" => "Y",
        "PATH_TO_USER" => "/community/socnet/index.php?page=user&user_id=#user_id#",
        "PATH_TO_GROUP" => "group_view.php?page=group&group_id=#group_id#",
        "PATH_TO_GROUP_MODS" => "group_mods.php?page=group_mods&group_id=#group_id#",
        "PATH_TO_GROUP_USERS" => "group_users.php?page=group_users&group_id=#group_id#",
        "PAGE_VAR" => "page",
        "ITEMS_COUNT" => "30",
        "GROUP_VAR" => "group_id",
        "USER_VAR" => "user_id",
        "GROUP_ID" => $group_id,
        "SET_TITLE" => "Y"
    ),
);?>


Черный список пользователя

Описание socialnetwork.user_ban

Компонент позволяет просмотреть и изменить черный список пользователя социальной сети. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: Компонент не используется на Корпоративном портале (КП).

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Внешний вид
Количество записей в списках | ITEMS_COUNT | Указывается количество записей черного списка пользователя, отображаемых на одной странице. Все записи будут выведены с помощью постраничной навигации.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Черный список.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции на странице в качестве заголовка будет установлено Черный список.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.user_ban","",Array(
        "SET_NAVCHAIN" => "Y",
        "ITEMS_COUNT" => "30",
        "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
        "PAGE_VAR" => "page",
        "USER_VAR" => "user_id",
        "SET_TITLE" => "Y"
    )
);?>


Редактирование сообщения

Описание socialnetwork.blog.post.edit

Компонент позволяет редактировать/создавать сообщения. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор сообщения | ID | Параметр содержит код, в котором передается идентификатор сообщения.
Внешний вид
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Указывается максимальная ширина изображения, вставляемого в сообщение (в пикселах).
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Указывается максимальная высота изображения, вставляемого в сообщение (в пикселах).
Шаблоны ссылок
Шаблон пути к странице сообщений | PATH_TO_BLOG | Задается путь к главной странице конкретного сообщения социальной сети.
Шаблон пути к странице сообщения | PATH_TO_POST | Задается путь к странице сообщения.
Шаблон пути к странице редактирования сообщения | PATH_TO_POST_EDIT | Задается путь к странице редактирования сообщения блога социальной сети.
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице пользователя социальной сети.
Шаблон пути к недописанным сообщениям | PATH_TO_DRAFT | Задается путь к странице черновиков.
Дополнительные настройки
Путь к папке со смайликам относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/socialnetwork/smile/.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название сообщения в социальной сети.
Показывать доп. свойства сообщения | POST_PROPERTY | Указываются пользовательские свойства сообщения, которые необходимо дополнительно отобразить в социальной сети.
Использовать символьный код сообщений как идентификатор | ALLOW_POST_CODE | [Y|N] При отмеченной опции транслитерация заголовка сообщения будет использоваться как его идентификатор.
Имена переменных
Имя переменной для идентификатора сообщения | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения социальной сети.
Имя переменной для идентификатора пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница сообщений социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.blog.post.edit","",Array(
    "ID" => $id,
    "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
    "PATH_TO_BLOG" => "blog_blog.php?page=blog&blog=#blog#",
    "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog#&post_id=#post_id#",
     "PATH_TO_POST_EDIT" => "blog_p_edit.php?page=post_edit&blog=#blog#&post_id=#post_id#",
    "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
    "PATH_TO_DRAFT" => "",
    "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
    "POST_VAR" => "post_id",
    "USER_VAR" => "user_id",
    "PAGE_VAR" => "page",
    "IMAGE_MAX_WIDTH" => "600",
    "IMAGE_MAX_HEIGHT" => "600",
     "SET_TITLE" => "Y",
     "POST_PROPERTY" => Array(),
     "ALLOW_POST_CODE" => "Y",
    )
);?>


RSS блогов

Описание socialnetwork.blog.rss

Компонент выводит RSS блогов группы или сайта в заданном формате. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Социальная сеть.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор группы блога | GROUP_ID | Параметр содержит код, в котором передается идентификатор группы блога социальной сети.
Внешний вид
Количество сообщений | MESSAGE_COUNT | Указывается число сообщений блога, данные из которых будут выгружены в соответствующем формате.
Шаблоны ссылок
Шаблон пути к странице с сообщением блога | PATH_TO_POST | Задается путь к странице просмотра сообщения блога социальной сети.
Шаблон пути к странице пользователя блога | PATH_TO_USER | Задается путь к странице профиля пользователя блога социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат RSS TYPE Указывается формат экспорта данных:
  • rss1 - формат RSS .92;
  • rss2 - формат RSS 2.0;
  • atom - формат Atom .03;
Выбрав пункт (другое)->, можно указать формат с помощью кода.
Имена переменных
Имя переменной для идентификатора блога | BLOG_VAR | Указывается имя переменной, которой передается идентификатор блога социальной сети.
Имя переменной для идентификатора сообщения блога | POST_VAR | Указывается имя переменной, которой передается идентификатор сообщения социальной сети.
Имя переменной для идентификатора пользователя блога | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:socialnetwork.blog.rss","",Array(
        "MESSAGE_COUNT" => "10",
        "PATH_TO_POST" => "blog_post.php?page=post&blog=#blog#&post_id=#post_id#",
        "PATH_TO_USER" => "blog_user.php?page=user&user_id=#user_id#",
        "BLOG_VAR" => "blog",
        "POST_VAR" => "post_id",
        "USER_VAR" => "user_id",
        "PAGE_VAR" => "page",
        "GROUP_ID" => $group_id,
        "TYPE" => $type,
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400"
    )
);?>


Живая лента (мобильная, ex)

Описание mobile.socialnetwork.log.ex

Компонент отображает Живую ленту в формате для мобильных устройств. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Мобильное приложение [image].

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Количество дней лога | LOG_DATE_DAYS | Указывается количество дней ведения лога изменений социальной сети.
Внешний вид
Отображать комментарии с привязкой к событиям | USE_COMMENTS | [Y|N] При отмеченной опции комментарии будут отображаться с привязкой к событиям.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Лог обновлений.
Учитывать подписку | SUBSCRIBE_ONLY | [Y|N] При отмеченной опции будет отображаться лог изменений с учетом подписки, иначе - весь лог.
Количество отображаемых записей | LOG_CNT | Указывается количество записей в логе изменений.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница сообщений социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для идентификатора сообщения | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:mobile.socialnetwork.log.ex","",Array(
    "PATH_TO_POST" => "group_view.php?page=group&group_id=#group_id#",
    "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
    "GROUP_VAR" => "group_id",
    "USER_VAR" => "user_id",
    "PAGE_VAR" => "page",
    "SET_NAV_CHAIN" => "Y",
    "SUBSCRIBE_ONLY" => "Y",
    "LOG_CNT" => "0",
    "LOG_DATE_DAYS" => "7",
    "USE_COMMENTS" => "Y"
    ),
false
);?>


Живая лента (мобильная)

Описание mobile.socialnetwork.log

Компонент отображает Живую ленту в формате для мобильных устройств. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Мобильное приложение [image].

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Количество дней лога | LOG_DATE_DAYS | Указывается количество дней ведения лога изменений социальной сети.
Внешний вид
Отображать комментарии с привязкой к событиям | USE_COMMENTS | [Y|N] При отмеченной опции комментарии будут отображаться с привязкой к событиям.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Лог обновлений.
Учитывать подписку | SUBSCRIBE_ONLY | [Y|N] При отмеченной опции будет отображаться лог изменений с учетом подписки, иначе - весь лог.
Количество отображаемых записей | LOG_CNT | Указывается количество записей в логе изменений.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница сообщений социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для идентификатора сообщения | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:mobile.socialnetwork.log","",Array(
    "PATH_TO_POST" => "group_view.php?page=group&group_id=#group_id#",
    "PATH_TO_USER" => "index.php?page=user&user_id=#user_id#",
    "GROUP_VAR" => "group_id",
    "USER_VAR" => "user_id",
    "PAGE_VAR" => "page",
    "SET_NAV_CHAIN" => "Y",
    "SUBSCRIBE_ONLY" => "Y",
    "LOG_CNT" => "0",
    "LOG_DATE_DAYS" => "7",
    "USE_COMMENTS" => "Y"
    ),
false
);?>


Сообщение Живой ленты (мобильной)

Описание mobile.socialnetwork.log.entry

Отображает сообщение Живой ленты в формате для мобильных устройств. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Мобильное приложение [image].

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Компонент не имеет настроек.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:mobile.socialnetwork.log.entry","",Array(
    ),
false
);?>


Форум

Подраздел служит для создания и управления форумами сайта и включает в себя следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Форум (комплексный компонент) | forum | Создает полноценный публичный интерфейс форума.
Помощь | forum.help | Выводит помощь по форуму.
[link=63182 ]Форумы (список)[/link] | forum.index | Выводит список всех форумов.
Шаблоны | forum.interface | Сборник js-библиотек служебных шаблонов.
Сообщения (проверка) | forum.message.approve | Выводит неодобренные сообщения форума.
Сообщения (перемещение) | forum.message.move | Служит для перемещения сообщений форума.
Письмо | forum.message.send | Выводит форму отправки письма (сообщения) пользователю.
PM (изменение) | forum.pm.edit | Служит для создания нового или редактирования существующего персонального сообщения.
PM (папки) | forum.pm.folder | Выводит список личных папок пользователя.
PM (список) | forum.pm.list | Выводит список личных сообщений пользователя из указанной папки.
PM (чтение) | forum.pm.read | Создает страницу детального просмотра персонального сообщения.
PM (поиск) | forum.pm.search | Выводит форму поиска пользователя.
Форма создания сообщения | forum.post_form | Выводит форму создания сообщения (или темы) форума.
RSS форума | forum.rss | Служит для экспорта RSS форума в указанном формате.
[link=63170 ]Правила[/link] | forum.rules | Служит для создания страницы с правилами форума.
Поиск | forum.search | Выводит форму поиска по форумам.
Статистика | forum.statistic | Выводит статистику по форуму.
Подписка | forum.subscribe.list | Выводит список подписок пользователя на сообщения и темы форумов.
Темы (новые) | forum.topic.active | Выводит список новых тем форума.
Темы (список внешний) | forum.topic.last | Выводит список тем (для использования вне форума).
Темы (список) | forum.topic.list | Выводит список всех тем форума.
Темы (перемещение) | forum.topic.move | Создает страницу перемещения тем форума.
Темы (создание) | forum.topic.new | Создание новой темы форума.
Темы (чтение) | forum.topic.read | Выводит список сообщений темы форума.
Темы (отзывы) | forum.topic.reviews | Выводит форму для создания отзыва к элементу инфоблока (например, новости, фотографии), а также весь список отзывов.
Темы (поиск) | forum.topic.search | Выводит форму поиска тем форума.
Пользователь (список пользователей) | forum.user.list | Выводит список пользователей форума.
Пользователь (сообщения) | forum.user.post | Выводит список сообщений, тем пользователя форума.
Пользователь (изменение профиля) | forum.user.profile.edit | Выводит форму редактирования профиля пользователя.
Пользователь (профиль) | forum.user.profile.view | Служит для просмотра профиля пользователя форума.


Форум (комплексный компонент)

Описание forum

Комплексный компонент позволяет создать полноценный публичный интерфейс форума. Компонент стандартный и входит в дистрибутив модуля.

В компоненте используется неотключаемая обратная навигация. Поэтому число списка тем может не совпадать с числом установленным в поле Количество тем на одной странице.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Внимание! Компонент поддерживает два режима настройки: простой и расширенный. Расширенный предоставляет более обширные средства настройки.

Параметры. Простой режим

Поле | Параметр | Описание
Настройки шаблона
Темы | THEME | Выбор темы оформления шаблона.
Показывать теги | SHOW_TAGS | [Y|N] При отмеченной опции будут отображаться теги форума.
Показывать форму авторизации | SHOW_AUTH_FORM | [Y|N] Если опция отмечена, то отображаются ссылки "Войти" для неавторизованного пользователя и "Выйти" - для авторизованного.
Дополнительный маркер для новых сообщений | TMPLT_SHOW_ADDITIONAL_MARKER | Задается текст надписи, отображаемый рядом с темой, в которой есть непрочитанные вами сообщения.
Настройки поиска
Искать без учета морфологии (при отсутствии результата поиска) | RESTART | [Y|N] Если опция отмечена, то будет отключен морфологический поиск (морфологический поиск предполагает поиск по полному совпадению слова с запросом).
Отключить обработку слов как логических операторов | NO_WORD_LOGIC | [Y|N] При отмеченной опции слова (и, или, не) не будут использоваться как логические операторы.
Основные параметры
Использовать простой режим настройки | USE_LIGHT_VIEW | [Y|N] При отмеченной опции используется простой режим настройки компонента, а в противном случае - расширенный.
Показывать только выбранные форумы | FID | Указываются форумы, которые должны быть показаны.
Максимальное количество файлов, прикрепленных к одному сообщению | FILES_COUNT | Задается количество файлов, которое может быть прикреплено к сообщению. Данный параметр работает только в том случае, если в настройках соответствующего форума разрешено прикреплять файлы к сообщениям.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - страница списка форумов;
  • list - страница списка тем форума;
  • read - страница чтения темы форума;
  • message - страница чтения сообщения;
  • help - страница помощи по форумам;
  • rules - страница правил форумов;
  • message_appr - страница неодобренных сообщений;
  • message_move - страница переноса сообщений;
  • pm_list - страница личных сообщений;
  • pm_edit - страница создания (редактирования) личных сообщений;
  • pm_read - страница чтения персонального сообщения;
  • pm_search - страница поиска пользователей;
  • pm_folder - страница управления директориями личных сообщений;
  • rss - страница RSS;
  • search - страница поиска по форумам;
  • subscr_list - страница подписки;
  • active - страница новых тем форумов;
  • topic_move - страница переноса тем в форум;
  • topic_new - страница создания новой темы форума;
  • topic_search - страница поиска по форуму;
  • user_list - страница списка зарегистрированных пользователей форума;
  • profile - страница изменения профиля пользователя;
  • profile_view - страница просмотра профиля пользователя;
  • user_post - страница сообщений пользователей форума;
  • message_send - страница отправки письма.
[/di] : SEF_FOLDER, SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.

При выключенном режиме ЧПУ необходимо указать имена следующих переменных:
  • FID - идентификатор форума;
  • TID - идентификатор темы;
  • MID - идентификатор сообщения;
  • UID - идентификатор пользователя.
[/di].
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Время кеширования списка пользователей на форуме (сек.) | CACHE_TIME_USER_STAT | Время кеширования списка пользователей, указанное в секундах.
Время кеширования статистики (сек.) | CACHE_TIME_FOR_FORUM_STAT | Время кеширования статистики форума, указанное в секундах.
Дополнительные настройки
Количество форумов на одной странице | FORUMS_PER_PAGE | Указывается количество форумов, отображаемых на одной странице.
Количество тем на одной странице | TOPICS_PER_PAGE | Указывается количество тем, отображаемых на одной странице.
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Указывается количество сообщений, отображаемых на одной странице.
Размер рисунков в сообщении | IMAGE_SIZE | Задается сторона квадрата, в который с сохранением пропорций будет включено изображение. Указывается в пикселях.
Как показывать прикрепленные рисунки (под сообщением) ATTACH_MODE Задается форма отображения прикрепленных рисунков (под сообщением). Доступные формы:
  • [dw]Миниатюра[/dw][di] При выборе формы Миниатюра станет доступно дополнительное поле:
    Размер миниатюры рисунка (под сообщением, px) ATTACH_SIZE Задается сторона квадрата, в который с сохранением пропорций будет включено изображение. Указывается в пикселях.
    [/di]
  • Название
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Форумы.
Настройки RSS
Разрешить RSS | USE_RSS | [Y|N] При отмеченной опции становится возможным экспорт данных в формате RSS.
Количество элементов для экспорта | RSS_COUNT | Указывается количество элементов для экспорта в RSS-ленту.
Настройки опросов
Разрешить опросы SHOW_VOTE [Y|N] При отмеченной опции будет выведен опрос. Создание опроса доступно только при создании новой темы на форуме. При выборе данной опции станут доступны [dw]дополнительные поля.[/dw][di]
Группа опросов | VOTE_CHANNEL_ID | Указывается группа опросов, в которой будет создан опрос.
Группы пользователей, которые могут создавать опрос | VOTE_GROUP_ID | Задаются группы пользователей, которым разрешено создавать опросы на форуме.
Шаблон для голосований | VOTE_TEMPLATE | Указывается шаблон для отображения опроса.
Не голосовать дважды VOTE_UNIQUE Указывается варианты запрета на повторное голосование в опросе:
  • 1 - в одной сессии;
  • 2 - с одним cookie;
  • 4 - с одного IP;
  • 8 - с одним ID пользователя.
Не голосовать дважды с одного IP в течение VOTE_UNIQUE_IP_DELAY Указывается период, в течение которого запрещается голосовать дважды с одного IP:
  • VOTE_UNIQUE_IP_DELAY_INPUT - указывается число;
  • VOTE_UNIQUE_IP_DELAY_SELECT - указывается:
    • S - секунд;
    • M - минут;
    • H - часов;
    • D - дней.
[/di]
Настройки рейтинга
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.

Примечание:

С версии 17.5.4 добавлена поддержка рейтингов с реакциями.
Рейтинг | RATING_ID | Указывается какой будет использоваться рейтинг.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).

Параметры. Расширенный режим

Поле | Параметр | Описание
Настройки шаблона
Темы | THEME | Выбирается одна из восьми доступных тем оформления шаблона.
Показывать теги | SHOW_TAGS | [Y|N] При отмеченной опции будут отображаться теги форума.
Как показывать имя пользователя (seo) SEO_USER Выбор формы показа имени пользователя:
  • Скрытой от поисковых ботов ссылкой
  • Ссылкой
  • Текстом
Использовать внешний сервис для перевода названия темы (seo) | SEO_USE_AN_EXTERNAL_SERVICE | [Y|N] При отмеченной опции название темы будет переведено автоматически внешним сервером.
Показывать список пользователей | SHOW_FORUM_USERS | [Y|N] При отмеченной опции в меню форума будет показываться ссылка Пользователи, ведущая на страницу со списком пользователей системы.
Показывать ссылку "Подписка" в верхнем меню | SHOW_SUBSCRIBE_LINK | [Y|N] При отмеченной опции отображается ссылка "Подписка", ведущая на страницу управления подпиской на темы и сообщения.
Показывать форму авторизации | SHOW_AUTH_FORM | [Y|N] Если опция отмечена, то отображаются ссылки "Войти" для неавторизованного пользователя и "Выйти" - для авторизованного.
Показывать навигационную цепочку | SHOW_NAVIGATION | [Y|N] При отмеченной опции в навигационную цепочку включается название форума.
Показывать легенду | SHOW_LEGEND | [Y|N] Отображается легенда на страницах просмотра форума и списков форумов для иконок "новых сообщений" и статусов тем.
Показывать блоки статистики SHOW_STATISTIC_BLOCK [Y|N] При отмеченной опции в нижней части форума будут выводиться блоки:
  • STATISTIC - количество сообщений и тем;
  • BIRTHDAY - дни рождения пользователей;
  • USERS_ONLINE - пользователи онлайн.
Показывать форумы для быстрого доступа | SHOW_FORUMS | [Y|N] При установленной опции появится окно с выпадающим списком форумов сайта для быстрого перехода между форумами.
Всегда показывать первое сообщение темы (при отключенной опции будет использоваться значение из настроек форума) | SHOW_FIRST_POST | [Y|N] При перемещении по страницам темы всегда будет отображаться первое сообщение темы над сообщениями страницы.
Показывать колонку "Автор" в списке тем | SHOW_AUTHOR_COLUMN | [Y|N] Отображается колонка с именем автора темы. Имя автора темы под названием темы исчезает.
Дополнительный маркер для новых сообщений | TMPLT_SHOW_ADDITIONAL_MARKER | Задается текст надписи, отображаемый рядом с темой, в которой есть непрочитанные вами сообщения.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указывается шаблон, используемый для постраничной навигации. Разработчик может сам создать собственный шаблон и разместить его в папке www\bitrix\templates\.default\components\bitrix\system.pagenavigation\forum\.
Количество страниц в постраничной навигации | PAGE_NAVIGATION_WINDOW | Задается количество отображаемых в навигации ссылок на страницы. Если количество страниц превышает заданное число, то в навигацию будет добавлено многоточие.
Использовать AJAX в диалогах | AJAX_POST | [Y|N] При отмеченной опции будет использоваться технология AJAX при добавлении, скрытии/показе и удалении сообщений на форуме.
Длина фразы (если "0", то фраза не обрезается) WORD_WRAP_CUT Параметр предназначен для текста сообщения и только на индексной странице форума. Указывается действие со словом, длина которого превышает заявленную.
  • Разорвать (0) - в фразу будут вставлены разделительные символы, но при просмотре они не отобразятся;
  • Обрезать (23) - фраза будет обрезана до 23 символов.
  • другое - действие аналогичное команде Обрезать. При выборе этого значения в ставшем активном поле можно ввести число знаков, после которых произойдет обрезание фразы.
Длина слова | WORD_LENGTH | Задается максимально допустимая длина символов, следующих друг за другом. Если длина слова превысит указанное число, то символы слова будут разбавлены разрывами (при просмотре сообщений разрывы не отображаются).
Настройки поиска
Искать без учета морфологии (при отсутствии результата поиска) | RESTART | [Y|N] Если опция отмечена, то будет отключен морфологический поиск (морфологический поиск предполагает поиск по полному совпадению слова с запросом).
Отключить обработку слов как логических операторов | NO_WORD_LOGIC | [Y|N] При отмеченной опции слова (и, или, не) не будут использоваться как логические операторы.
Основные параметры
Использовать простой режим настройки | USE_LIGHT_VIEW | [Y|N] При отмеченной опции используется простой режим настройки компонента, а в противном случае - расширенный.
Показывать только выбранные форумы | FID | Указываются форумы, которые должны быть показаны.
Показывать пользовательские поля в профиле | USER_PROPERTY | Указываются дополнительные пользовательские свойства, которые будут отображены в профиле пользователя форума.
Показывать пользовательские поля сообщения | USER_FIELDS | Указываются пользовательские поля сообщения.
Путь к файлу, содержащему "Помощь по форуму" (при пустом поле ввода будет использовано значение по умолчанию) | HELP_CONTENT | Указывается путь к файлу, содержащему помощь по форуму (при пустом поле ввода будет использовано значение по умолчанию).
Путь к файлу, содержащему "Правила форума" (при пустом поле ввода будет использовано значение по умолчанию) | RULES_CONTENT | Указывается путь к файлу, содержащему правила форума (при пустом поле ввода будет использовано значение по умолчанию).
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - страница списка форумов;
  • list - страница списка тем форума;
  • read - страница чтения темы форума;
  • message - страница чтения сообщения;
  • help - страница помощи по форумам;
  • rules - страница правил форумов;
  • message_appr - страница неодобренных сообщений;
  • message_move - страница переноса сообщений;
  • pm_list - страница личных сообщений;
  • pm_edit - страница создания (редактирования) личных сообщений;
  • pm_read - страница чтения персонального сообщения;
  • pm_search - страница поиска пользователей;
  • pm_folder - страница управления директориями личных сообщений;
  • rss - страница RSS;
  • search - страница поиска по форумам;
  • subscr_list - страница подписки;
  • active - страница новых тем форумов;
  • topic_move - страница переноса тем в форум;
  • topic_new - страница создания новой темы форума;
  • topic_search - страница поиска по форуму;
  • user_list - страница списка зарегистрированных пользователей форума;
  • profile - страница изменения профиля пользователя;
  • profile_view - страница просмотра профиля пользователя;
  • user_post - страница сообщений пользователей форума;
  • message_send - страница отправки письма.
[/di] : SEF_FOLDER, SEF_URL_TEMPLATES.
Если режим поддержки ЧПУ выключен, то необходимо настроить параметр [dw]VARIABLE_ALIASES[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.

При выключенном режиме ЧПУ необходимо указать имена следующих переменных:
  • FID - идентификатор форума;
  • TID - идентификатор темы;
  • MID - идентификатор сообщения;
  • UID - идентификатор пользователя.
[/di]
Проверять корректность шаблонов пути | CHECK_CORRECT_PATH_TEMPLATES | [Y|N] При отмеченной опции выполняется проверка корректности путей, указанных в параметрах. При обнаружении ошибок происходит автоматическая замена используемого шаблон на шаблон по умолчанию.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Время кеширования списка пользователей на форуме (сек.) | CACHE_TIME_USER_STAT | Время кеширования списка пользователей, указанное в секундах.
Время кеширования статистики (сек.) | CACHE_TIME_FOR_FORUM_STAT | Время кеширования кеширования статистики форума, указанное в секундах.
Время кеширования RSS-ленты (сек.) | RSS_CACHE | Время кеширования ленты RSS, указанное в секундах.
Дополнительные настройки
Количество форумов на одной странице | FORUMS_PER_PAGE | Указывается количество форумов, отображаемых на одной странице.
Количество тем на одной странице | TOPICS_PER_PAGE | Указывается количество тем, отображаемых на одной странице.
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Указывается количество сообщений, отображаемых на одной странице.
Путь к форме авторизации | PATH_TO_AUTH_FORM | Задается путь к форме авторизации. Если не задан, то будет использовано значение по умолчанию (/auth.php).
Период для отображения статистики (сек.) | TIME_INTERVAL_FOR_USER_STAT | Указывается период времени в секундах, за который показывается статистика форума.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Размер рисунков в сообщении (px) | IMAGE_SIZE | Задается сторона квадрата, в который с сохранением пропорций будет включено изображение. Указывается в пикселях.
Как показывать прикрепленные рисунки (под сообщением) ATTACH_MODE Задается форма отображения прикрепленных рисунков (под сообщением). Доступные формы:
  • [dw]Миниатюра[/dw][di] При выборе формы Миниатюра станет доступно дополнительное поле:
    Размер миниатюры рисунка (под сообщением, px) ATTACH_SIZE Задается сторона квадрата, в который с сохранением пропорций будет включено изображение. Указывается в пикселях.
    [/di]
  • Название
По умолчанию показывать невизуальный режим редактора | EDITOR_CODE_DEFAULT | [Y|N] При отмеченной опции при создании или редактировании сообщения будет включен режим показа BB-кодов. (Пример: [B]сообщение[/B] вместо сообщение).
Могут отправлять письмо (e-mail) из профиля SEND_MAIL Указываются пользователи, которые могут отправлять письмо (e-mail) из профиля:
  • A - никто;
  • E - авторизованные пользователи;
  • U - все пользователи, а для неавторизованных пользователей выводить поле CAPTCHA;
  • Y - все пользователи.
Показывать навигацию (хлебные крошки) | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационной цепочке будет отражен переход на страницу списка тем форума.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Форумы.
Устанавливать мета-тег 'Description' из первого сообщения темы | SET_DESCRIPTION | [Y|N] При отмеченной опции в коде страницы будет дописываться мета-тег 'Description' с содержанием первого сообщения темы.
Устанавливать теги и описание темы в свойства страницы | SET_PAGE_PROPERTY | [Y|N] При отмеченной опции теги и описание темы будут установлена в качестве свойств страницы.
Показывать список пользователей | SHOW_FORUM_USERS | [Y|N] При отмеченной опции в меню форума будет показываться ссылка Пользователи, ведущая на страницу со списком пользователей системы.
Настройки администратора
Показывать администратору форумы других сайтов | SHOW_FORUM_ANOTHER_SITE | [Y|N] При отмеченной опции администратору будут показаны форумы других сайтов системы.
Настройки RSS
Разрешить RSS | USE_RSS | [Y|N] При отмеченной опции становится возможным экспорт данных в формате RSS и появляются дополнительные поля настройки RSS.
Использовать спецификации RSS_TYPE_RANGE Указываются форматы экспорта данных форума, которые необходимо отобразить:
  • RSS 0.92 (RSS1)
  • RSS 2.0 (RSS2)
  • Atom 0.3 (ATOM)
Количество элементов для экспорта | RSS_COUNT | Указывается количество элементов для экспорта.
Название ленты (при пустом поле ввода будет использовано значение по умолчанию) | RSS_TN_TITLE | Задается название ленты RSS (при пустом поле ввода будет использовано значение по умолчанию).
Описание ленты (при пустом поле ввода будет использовано значение по умолчанию) | RSS_TN_DESCRIPTION | Задается описание ленты RSS (при пустом поле ввода будет использовано значение по умолчанию).
Настройки опросов
Разрешить опросы SHOW_VOTE [Y|N] При отмеченной опции будет выведен опрос. Создание опроса доступно только при создании новой темы на форуме. При выборе данной опции станут доступны [dw]дополнительные поля.[/dw][di]
Группа опросов | VOTE_CHANNEL_ID | Указывается группа опросов, в которой будет создан опрос.
Группы пользователей, которые могут создавать опрос | VOTE_GROUP_ID | Задаются группы пользователей, которым разрешено создавать опросы на форуме.
Количество вопросов | VOTE_COUNT_QUESTIONS | Указывается максимально возможное количество вопросов в опросе.
Количество ответов | VOTE_COUNT_ANSWERS | Задается максимально возможное количество вариантов ответов на вопрос в опросе.
Шаблон для голосований | VOTE_TEMPLATE | Указывается шаблон для отображения опроса.
Не голосовать дважды VOTE_UNIQUE Указывается варианты запрета на повторное голосование в опросе:
  • 1 - в одной сессии;
  • 2 - с одним cookie;
  • 4 - с одного IP;
  • 8 - с одним ID пользователя.
Не голосовать дважды с одного IP в течение VOTE_UNIQUE_IP_DELAY Указывается период, в течение которого запрещается голосовать дважды с одного IP:
  • VOTE_UNIQUE_IP_DELAY_INPUT - указывается число;
  • VOTE_UNIQUE_IP_DELAY_SELECT - указывается:
    • S - секунд;
    • M - минут;
    • H - часов;
    • D - дней.
[/di]
Настройки рейтинга
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.

Примечание:

С версии 17.5.4 добавлена поддержка рейтингов с реакциями.
Рейтинг | RATING_ID | Указывается какой будет использоваться рейтинг.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).

Примечание: Если в группе Управление адресами страниц в полях Страница чтения темы форума (read) и Страница чтения сообщения (message), а также в Шаблоне пути к сообщению на сайте, изменить переменную символьного идентификатора темы #TID# (#TOPIC_ID#) на #TITLE_SEO#, то при изменении названия темы форума в адресной строке браузера будет отображаться уже новый вариант ссылки, при этом этот адрес будет индексироваться.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum","",Array(
        "THEME" => "green",
        "SHOW_TAGS" => "Y",
        "SHOW_AUTH_FORM" => "Y",
        "SHOW_NAVIGATION" => "Y",
        "SHOW_SUBSCRIBE_LINK" => "Y",
        "SHOW_LEGEND" => "Y",
        "SHOW_STATISTIC_BLOCK" => array("STATISTIC", "BIRTHDAY", "USERS_ONLINE"),
        "SHOW_NAME_LINK" => "Y",
        "SHOW_FORUMS" => "Y",
        "SHOW_FIRST_POST" => "Y",
        "SHOW_AUTHOR_COLUMN" => "Y",
        "TMPLT_SHOW_ADDITIONAL_MARKER" => "",
        "SMILES_COUNT" => "100",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "PATH_TO_ICON" => "/bitrix/images/forum/icon/",
        "PAGE_NAVIGATION_TEMPLATE" => "forum",
        "PAGE_NAVIGATION_WINDOW" => "5",
        "AJAX_POST" => "Y",
        "WORD_WRAP_CUT" => "23",
        "WORD_LENGTH" => "50",
        "SEO_USER" => "Y",
        "USE_LIGHT_VIEW" => "N",
        "SEF_MODE" => "Y",
        "CHECK_CORRECT_TEMPLATES" => "Y",
        "FID" => array("3", "4", "5"),
        "USER_PROPERTY" => array(),
        "FILES_COUNT" => "5",
        "HELP_CONTENT" => "",
        "RULES_CONTENT" => "",
        "FORUMS_PER_PAGE" => "20",
        "TOPICS_PER_PAGE" => "20",
        "MESSAGES_PER_PAGE" => "25",
        "PATH_TO_AUTH_FORM" => "",
        "TIME_INTERVAL_FOR_USER_STAT" => "10",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "IMAGE_SIZE" => "500",
        "EDITOR_CODE_DEFAULT" => "N",
        "SEND_MAIL" => "E",
        "SEND_ICQ" => "A",
        "SET_NAVIGATION" => "Y",
        "SET_TITLE" => "Y",
        "SET_DESCRIPTION" => "Y",
        "SET_PAGE_PROPERTY" => "Y",
        "SHOW_FORUM_USERS" => "Y",
        "USE_RSS" => "Y",
        "SHOW_FORUM_ANOTHER_SITE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_TIME_USER_STAT" => "60",
        "CACHE_TIME_FOR_FORUM_STAT" => "3600",
        "RSS_TYPE_RANGE" => array("RSS1", "RSS2", "ATOM"),
        "RSS_CACHE" => "1800",
        "RSS_COUNT" => "30",
        "RSS_TN_TITLE" => "",
        "RSS_TN_DESCRIPTION" => "",
        "SHOW_VOTE" => "Y",
        "VOTE_CHANNEL_ID" => "3",
        "VOTE_GROUP_ID" => array("1", "5"),
        "VOTE_COUNT_QUESTIONS" => "10",
        "VOTE_COUNT_ANSWERS" => "20",
        "VOTE_TEMPLATE" => "light",
        "VOTE_UNIQUE" => array("8"),
        "VOTE_UNIQUE_IP_DELAY" => "10 D",
        "SHOW_RATING" => "Y",
        "RATING_ID" => array("3", "4"),
        "RATING_TYPE" => "standart",
        "SEF_FOLDER" => "/communication/forum/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "list" => "forum#FID#/",
            "read" => "forum#FID#/topic#TID#/",
            "message" => "messages/forum#FID#/topic#TID#/message#MID#/",
            "help" => "help/",
            "rules" => "rules/",
            "message_appr" => "message/approve/forum#FID#/topic#TID#/",
            "message_move" => "message/move/forum#FID#/topic#TID#/message#MID#/",
            "pm_list" => "pm/forlder#FID#/",
            "pm_edit" => "pm/folder#FID#/message#MID#/user#UID#/#mode#/",
            "pm_read" => "pm/folder#FID#/message#MID#/",
            "pm_search" => "pm/search/",
            "pm_folder" => "pm/folders/",
            "rss" => "rss/#TYPE#/#MODE#/#IID#/",
            "search" => "search/",
            "subscr_list" => "subscribe/",
            "active" => "topic/new/",
            "topic_move" => "topic/move/forum#FID#/topic#TID#/",
            "topic_new" => "topic/add/forum#FID#/",
            "topic_search" => "topic/search/",
            "user_list" => "users/",
            "profile" => "user/#UID#/edit/",
            "profile_view" => "user/#UID#/",
            "user_post" => "user/#UID#/post/#mode#/",
            "message_send" => "user/#UID#/send/#TYPE#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "list" => Array(),
            "read" => Array(),
            "message" => Array(),
            "help" => Array(),
            "rules" => Array(),
            "message_appr" => Array(),
            "message_move" => Array(),
            "pm_list" => Array(),
            "pm_edit" => Array(),
            "pm_read" => Array(),
            "pm_search" => Array(),
            "pm_folder" => Array(),
            "rss" => Array(),
            "search" => Array(),
            "subscr_list" => Array(),
            "active" => Array(),
            "topic_move" => Array(),
            "topic_new" => Array(),
            "topic_search" => Array(),
            "user_list" => Array(),
            "profile" => Array(),
            "profile_view" => Array(),
            "user_post" => Array(),
            "message_send" => Array(),
        )
    )
);?>


Письмо

Описание forum.message.send

Компонент выводит форму отправки письма (сообщения) пользователю. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID пользователя | UID | Указывается код, в котором передается идентификатор пользователя форума. По умолчанию поле содержит $_REQUEST["UID"].
Могут отправлять письмо (e-mail) из профиля SEND_MAIL Указываются пользователи, которые могут отправлять письмо (e-mail) из профиля:
  • A - никто;
  • E - авторизованные пользователи;
  • U - все пользователи, а для неавторизованных пользователей выводить поле CAPTCHA;
  • Y - все пользователи.
Могут отправлять сообщение (icq) из профиля | SEND_ICQ | Указываются пользователи, которые могут отправлять сообщение (icq) из профиля.
Шаблоны ссылок
Страница профиля пользователя URL_TEMPLATES_PROFILE_VIEW Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#.
Такая страница может быть создана с помощью компонента Пользователь (профиль).
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Отправка письма.
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции будет добавлен пункт с заголовком страницы в цепочку навигации.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.message.send","",Array(
        "SET_TITLE" => "Y",
        "SET_NAVIGATION" => "Y",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "UID" => $_REQUEST["UID"],
        "SEND_MAIL" => "E",
        "SEND_ICQ" => "A"
    )
);?>


Подписка (список)

Описание forum.subscribe.list

Компонент выводит список подписок пользователя на сообщения и темы форумов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID пользователя | UID | Указывается идентификатор пользователя, подписки которого будут выведены. По умолчанию поле содержит ={$_REQUEST["UID"].
Шаблоны ссылок
Страница списка тем | URL_TEMPLATES_LIST | Указывается адрес страницы со списком тем форума. По умолчанию поле содержит list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Темы (список).
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#. Такая страница может быть создана с помощью компонента Тема (чтение).
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Указывается адрес страницы чтения сообщения форума. По умолчанию поле содержит message.php?FID=#FID#&TID=#TID#&MID=#MID#.
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Страница подписки | URL_TEMPLATES_SUBSCR_LIST | Указывается адрес страницы подписки. По умолчанию поле содержит subscr_list.php.
Дополнительные настройки
Количество тем на одной странице | TOPICS_PER_PAGE | Указывается количество тем, отображаемых на одной странице. Все темы будут выведены с помощью постраничной навигации.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Задается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Количество страниц в постраничной навигации | PAGE_NAVIGATION_WINDOW | Задается количество отображаемых в навигации ссылок на страницы. Если количество страниц превышает заданное число, то в навигацию будет добавлено многоточие.
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационной цепочке будет отражен переход на страницу списка подписки.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Список подписки на сообщения форума.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.subscribe.list","",Array(
        "UID" => $_REQUEST["UID"],
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_MESSAGE" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "URL_TEMPLATES_SUBSCR_LIST" => "subscr_list.php",
        "TOPICS_PER_PAGE" => "10",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "PAGE_NAVIGATION_WINDOW" => "11",
        "SET_NAVIGATION" => "Y",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y"
    )
);?>


Поиск

Описание forum.search

Компонент выводит форму поиска по форумам. Поиск производится по ключевым словам на всех форумах либо на определенном. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Источник данных
Искать без учета морфологии (при отсутствии результата поиска) | RESTART | [Y|N] Если опция отмечена, то будет отключен морфологический поиск (морфологический поиск предполагает поиск по полному совпадению слова с запросом).
Отключить обработку слов как логических операторов | NO_WORD_LOGIC | [Y|N] При отмеченной опции слова (и, или, не) не будут использоваться как логические операторы.
Шаблоны ссылок
Страница списка форумов | URL_TEMPLATES_INDEX | Указывается адрес страницы со списком форумов. По умолчанию поле содержит index.php.
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#.
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Указывается адрес страницы чтения сообщения форума. По умолчанию поле содержит message.php?FID=#FID#&TID=#TID#&MID=#MID#.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто: действует при включенном кешировании в течение заданного времени;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
ID форума | FID_RANGE | Указывается форумы, по которым будет осуществляться поиск.
Формат показа даты | DATE_FORMAT | Формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, вы можете сформировать свой вариант на основании php-функции date.
Количество тем на одной странице | TOPICS_PER_PAGE | Количество тем, отображаемых на одной странице. Для отображения всех тем используется постраничная навигация.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию, также в системе имеется шаблон orange.
Количество страниц в постраничной навигации | PAGE_NAVIGATION_WINDOW | Задается количество отображаемых в навигации ссылок на страницы. Если количество страниц превышает заданное число, то в навигацию будет добавлено многоточие.
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационной цепочке будет отражен переход на страницу поиска.
Устанавливать заголовок страницы | SET_TITLE | При отмеченной опции в качестве заголовка страницы будет установлено Поиск.

Пример вызова

<?APPLICATION->IncludeComponent("bitrix:forum.search","",Array(
        "URL_TEMPLATES_INDEX" => "index.php",
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_MESSAGE" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "FID_RANGE" => Array("3"),
        "DATE_FORMAT" => "d.m.Y H:i:s",
        "TOPICS_PER_PAGE" => "10",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "PAGE_NAVIGATION_WINDOW" => "11",
        "SET_NAVIGATION" => "Y",
        "DISPLAY_PANEL" => "N",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SET_TITLE" => "Y"
    )
);?>


Пользователь (изменение профиля)

Описание forum.user.profile.edit

Компонент выводит форму редактирования профиля пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID пользователя | UID | Указывается идентификатор пользователя, профиль которого будет изменяться. По умолчанию поле содержит ={$_REQUEST["UID"].
Шаблоны ссылок
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Показывать доп. свойства | USER_PROPERTY | Указываются дополнительные пользовательские свойства, которые будут отображены в публичной части в секции Дополнительно.
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационной цепочке будет отражен переход на страницу списка тем форума.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено <имя_пользователя> (изменение профиля).

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.user.profile.edit","",Array(
        "UID" => $_REQUEST["UID"],
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "USER_PROPERTY" => Array(),
        "SET_NAVIGATION" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => 0,
        "SET_TITLE" => "Y"
    )
);?>


Пользователь (профиль)

Описание forum.user.profile.view

Компонент служит для просмотра профиля пользователя форума. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID пользователя | UID | Указывается код, в котором передается идентификатор пользователя форума. По умолчанию поле содержит $_REQUEST["UID"].
Шаблоны ссылок
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#. Такая страница может быть создана с помощью компонента Тема (чтение).
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Указывается адрес страницы чтения сообщения форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#. Такая страница может быть создана с помощью компонента Тема (чтение).
Страница редактирования профиля | URL_TEMPLATES_PROFILE | Указывается адрес страницы редактирования профиля пользователя. По умолчанию поле содержит profile.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (изменение профиля).
Страница списка зарегистрированных пользователей форума | URL_TEMPLATES_USER_LIST | Указывается адрес страницы списка зарегистрированных пользователей форума. По умолчанию поле содержит user_list.php. Такая страница может быть создана с помощью компонента Пользователь (список пользователей).
Страница личных сообщений | URL_TEMPLATES_PM_LIST | Указывается адрес страницы личных сообщений. По умолчанию поле содержит pm_list.php. Такая страница может быть создана с помощью компонента PM (список).
Страница отправки сообщения | URL_TEMPLATES_MESSAGE_SEND | Указывается адрес страницы отправки сообщения. По умолчанию поле содержит message_send.php?TYPE=#TYPE#&UID=#UID#. Такая страница может быть создана с помощью компонента Письмо.
Страница создания (редактирования) личных сообщений | URL_TEMPLATES_PM_EDIT | Указывается адрес страницы создания (редактирования) персонального сообщения. По умолчанию поле содержит pm_edit.php.
Страница подписки | URL_TEMPLATES_PM_EDIT | Указывается адрес страницы просмотра подписок пользователя. По умолчанию поле содержит subscr_list.php.
Страница сообщений пользователя | URL_TEMPLATES_USER_POST | Указывается адрес страницы просмотра сообщений пользователя. По умолчанию поле содержит user_post.php?UID=#UID#&mode=#mode#. Такая страница может быть создана с помощью компонента Пользователь (сообщения).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
ID форума | FID_RANGE | Указываются форумы, из которых будут выбраны для отображения темы и сообщения пользователя.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Могут отправлять письмо (e-mail) из профиля SEND_MAIL Указываются пользователи, которые могут отправлять письмо (e-mail) из профиля:
  • A - никто;
  • E - авторизованные пользователи;
  • U - все пользователи, а для неавторизованных пользователей выводить поле CAPTCHA;
  • Y - все пользователи.
Могут видеть номер ICQ в профиле | SEND_ICQ | Указываются пользователи, которые могут видет номер ICQ в профиле.
Показывать доп. свойства | USER_PROPERTY | Указываются дополнительные пользовательские свойства, которые будут показаны на закладке с названием, заданным в параметре USER_PROPERTY_NAME.
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационной цепочке будет отражен переход на страницу профиля пользователя.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя пользователя.
Настройки рейтинга
Выводить рейтинг | SHOW_RATING | [Y|N] При отмеченной опции будет выведен рейтинг пользователя на форуме.
Рейтинг | RATING_ID | Указывается рейтинг из списка. У каждого рейтинга свои настройки посчета.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • standart - Плюс / Минус;
  • like - Мне нравится;

Внимание! С версии 17.5.4 добавлена поддержка рейтингов с реакциями.
Название закладки с доп. свойствами | USER_PROPERTY_NAME | Указывается название закладки с дополнительными свойствами.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.user.profile.view","",Array(
        "USER_PROPERTY_NAME" => "",
        "UID" => $_REQUEST["UID"],
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_MESSAGE" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_PROFILE" => "profile.php?UID=#UID#",
        "URL_TEMPLATES_USER_LIST" => "user_list.php",
        "URL_TEMPLATES_PM_LIST" => "pm_list.php",
        "URL_TEMPLATES_MESSAGE_SEND" => "message_send.php?TYPE=#TYPE#&UID=#UID#",
        "URL_TEMPLATES_PM_EDIT" => "pm_edit.php",
        "URL_TEMPLATES_SUBSCR_LIST" => "subscr_list.php",
        "URL_TEMPLATES_USER_POST" => "user_post.php?UID=#UID#&mode=#mode#",
        "FID_RANGE" => array(),
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SEND_MAIL" => "E",
        "SEND_ICQ" => "A",
        "USER_PROPERTY" => array(),
        "SET_NAVIGATION" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "CACHE_NOTES" => "",
        "SET_TITLE" => "Y",
        "SHOW_RATING" => "Y",
        "RATING_ID" => "",
        "RATING_TYPE" => "like"
    )
);?>


Пользователь (сообщения)

Описание forum.user.post

Компонент служит для вывода списка сообщений, тем пользователя форума. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID пользователя форума | UID | Параметр содержит код, в котором передается идентификатор пользователя. Значение по умолчанию: $_REQUEST["UID"].
Режим отображения MODE Указывается режим отображения сообщений пользователя:
  • all - все сообщения автора;
  • lt - участвовал в темах;
  • lta - автор тем.
Шаблоны ссылок
Страница списка тем | URL_TEMPLATES_LIST | Путь к странице со списком тем форума. По умолчанию поле содержит list.php?FID=#FID#.
Страница чтения темы | URL_TEMPLATES_READ | Путь к странице чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#.
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Путь к странице чтения сообщения форума. По умолчанию поле содержит message.php?FID=#FID#&TID=#TID#&MID=#MID#.
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Путь к странице просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#.
Страница пользователей форума | URL_TEMPLATES_USER_LIST | Путь к странице списка пользователей форума. По умолчанию поле содержит user_list.php.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
ID форума | FID_RANGE | Указываются форумы, из которых будут выбраны для отображения сообщения пользователя.
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Количество сообщений, отображаемых на одной странице. Все сообщения выводятся с помощью постраничной навигации.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Задается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Количество страниц в постраничной навигации | PAGE_NAVIGATION_WINDOW | Задается количество отображаемых в навигации ссылок на страницы. Если количество страниц превышает заданное число, то в навигацию будет добавлено многоточие.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/smile/.
Длина слова | WORD_LENGTH | Задается максимально допустимая длина словообразующих символов, следующих друг за другом. Если длина слова превысит указанное число, то символы слова будут разбавлены разрывами (при просмотре сообщений разрывы не отображаются).
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции будет добавлен пункт с логином пользователя в цепочку навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При установленной опции в качестве заголовка страницы будет установлено <логин_пользователя> (<режим_отображения>).

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.user.post","",Array(
        "PATH_TO_ICON" => "/bitrix/images/forum/icon/",
        "UID" => $_REQUEST["UID"],
        "mode" => "all",
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_MESSAGE" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "URL_TEMPLATES_USER_LIST" => "user_list.php",
        "FID_RANGE" => Array(3),
        "MESSAGES_PER_PAGE" => "3",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "PAGE_NAVIGATION_WINDOW" => "11",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "WORD_LENGTH" => "50",
        "SET_NAVIGATION" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0"
    )
);?>


Пользователь (список пользователей)

Описание forum.user.list

Компонент служит для вывода списка пользователей форумов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
Показывать статус пользователя | SHOW_USER_STATUS | [Y|N] При отмеченной опции будет показан статус (звание) пользователя.
Шаблоны ссылок
Страница отправки сообщения | URL_TEMPLATES_MESSAGE_SEND | Указывается адрес страницы отправки сообщения. По умолчанию поле содержит message_send.php?TYPE=#TYPE#&UID=#UID#. Такая страница может быть создана с помощью компонента Письмо.
Страница личных сообщений | URL_TEMPLATES_PM_EDIT | Указывается адрес страницы создания/редактирования персональных сообщений. По умолчанию поле содержит pm_edit.php?FID=#FID#&MID=#MID#&UID=#UID#&mode=#mode#. Такая страница может быть создана с помощью компонента PM (изменение).
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Страница сообщений пользователя | URL_TEMPLATES_USER_POST | Указывается адрес страницы просмотра сообщений пользователя. По умолчанию поле содержит user_post.php?UID=#UID#&mode=#mode#. Такая страница может быть создана с помощью компонента Пользователь (сообщения).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Количество пользователей на одной странице | USERS_PER_PAGE | Указывается количество пользователей, отображаемых на одной странице. Все пользователи будут выведены с помощью постраничной навигации.
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции будет добавлен пункт с заголовком страницы в цепочку навигации.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Задается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Пользователи.
Не индексировать ссылку на профиль | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.user.list","",Array(
        "SEO_USER" => "Y",
        "SHOW_USER_STATUS" => "Y",
        "URL_TEMPLATES_MESSAGE_SEND" => "message_send.php?TYPE=#TYPE#&UID=#UID#",
        "URL_TEMPLATES_PM_EDIT" => "pm_edit.php?FID=#FID#&MID=#MID#&UID=#UID#&mode=#mode#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "URL_TEMPLATES_USER_POST" => "user_post.php?UID=#UID#&mode=#mode#",
        "USERS_PER_PAGE" => "20",
        "SET_NAVIGATION" => "Y",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0"
    )
);?>


PM (изменение)

Описание forum.pm.edit

Компонент служит для создания нового или редактирования существующего персонального сообщения. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID сообщения | MID | Указывается код, в котором передается идентификатор сообщения. По умолчанию поле содержит $_REQUEST["MID"].
ID папки пользователя | FID | Указывается код, в котором передается идентификатор папки пользователя с личными сообщениями. По умолчанию поле содержит $_REQUEST["FID"].
ID пользователя | UID | Указывается код, в котором передается идентификатор пользователя. По умолчанию поле содержит $_REQUEST["UID"].
Тип сообщения MODE Указывается тип сообщения. Возможные варианты зачения параметра:
  • REPLY - ответ;
  • EDIT - редактирование;
  • NEW - новое сообщение.
Шаблоны ссылок
Страница списка персональных сообщений | URL_TEMPLATES_PM_LIST | Указывается адрес страницы со списком персональных сообщений. По умолчанию поле содержит pm_list.php?FID=#FID#. Такая страница может быть создана с помощью компонента PM (список).
Страница чтения персонального сообщения | URL_TEMPLATES_PM_READ | Указывается адрес страницы чтения персонального сообщения. По умолчанию поле содержит pm_read.php?MID=#MID#. Такая страница может быть создана с помощью компонента PM (чтение).
Страница редактирования (создания) персонального сообщения | URL_TEMPLATES_PM_EDIT | Указывается адрес страницы редактирования (создания) персонального сообщения. По умолчанию поле содержит pm_edit.php?MID=#MID#.
Страница поиска пользователя | URL_TEMPLATES_PM_SEARCH | Указывается адрес страницы поиска пользователя. По умолчанию поле содержит pm_search.php?MID=#MID#. Такая страница может быть создана с помощью компонента PM (поиск).
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/smile/.
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции будет добавлен пункт с заголовком страницы в цепочку навигации.
По умолчанию показывать невизуальный режим редактора | EDITOR_CODE_DEFAULT | [Y|N] При отмеченной опции при создании или редактировании сообщения будет включен режим показа BB-кодов. (Пример: [B]сообщение[/B] вместо сообщение).
Устанавливать заголовок страницы SET_TITLE [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено:
  • Новое при создании нового сообщения и при ответе на сообщение;
  • <тема_сообщения> (редактирование) при изменении сообщения.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.pm.edit","",Array(
        "MID" => $_REQUEST["MID"],
        "FID" => $_REQUEST["FID"],
        "UID" => $_REQUEST["UID"],
        "MODE" => $_REQUEST["MODE"],
        "URL_TEMPLATES_PM_LIST" => "pm_list.php?FID=#FID#",
        "URL_TEMPLATES_PM_READ" => "pm_read.php?MID=#MID#",
        "URL_TEMPLATES_PM_EDIT" => "pm_edit.php?MID=#MID#",
        "URL_TEMPLATES_PM_SEARCH" => "pm_search.php?MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "SET_NAVIGATION" => "Y",
        "EDITOR_CODE_DEFAULT" => "N",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "SET_TITLE" => "Y"
    )
);?>


PM (папки)

Описание forum.pm.folder

Компонент служит для вывода списка личных папок пользователя. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
Страница списка персональных сообщений | URL_TEMPLATES_PM_LIST | Указывается адрес страницы со списком персональных сообщений. По умолчанию поле содержит pm_list.php?FID=#FID#. Такая страница может быть создана с помощью компонента PM (список).
Страница чтения сообщения | URL_TEMPLATES_PM_READ | Указывается адрес страницы чтения персонального сообщения. По умолчанию поле содержит pm_read.php?MID=#MID#.
Страница создания (редактирования) личных сообщений | URL_TEMPLATES_PM_EDIT | Указывается адрес страницы создания (редактирования) персонального сообщения. По умолчанию поле содержит pm_edit.php?MID=#MID#.
Страница профиля | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Список папок.
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции будет добавлен пункт с заголовком страницы в цепочку навигации.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.pm.folder","",Array(
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => 0,
        "SET_NAVIGATION" => "Y",
        "URL_TEMPLATES_PM_LIST" => "pm_list.php?FID=#FID#",
        "URL_TEMPLATES_PM_READ" => "pm_read.php?MID=#MID#",
        "URL_TEMPLATES_PM_EDIT" => "pm_edit.php?MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#"
    )
);?>


PM (поиск)

Описание forum.pm.search

Компонент служит для вывода формы поиска пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Количество найденных пользователей на странице | PM_USER_PAGE | Указывается количество найденных пользователей, отображаемых на одной странице. Все найденные пользователи будут выведены с помощью постраничной навигации.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Задается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Количество страниц в постраничной навигации | PAGE_NAVIGATION_WINDOW | Задается количество отображаемых в навигации ссылок на страницы. Если количество страниц превышает заданное число, то в навигацию будет добавлено многоточие.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.pm.search","",Array(
        "PM_USER_PAGE" => 20,
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "PAGE_NAVIGATION_WINDOW" => "11"
    )
);?>


PM (список)

Описание forum.pm.list

Компонент выводит список личных сообщений пользователя из указанной папки. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID папки | FID | Указывается код, в котором передается идентификатор папки пользователя с личными сообщениями. По умолчанию поле содержит ={$_REQUEST["FID"]}.
Шаблоны ссылок
Страница списка персональных сообщений | URL_TEMPLATES_PM_LIST | Указывается адрес страницы со списком персональных сообщений. По умолчанию поле содержит pm_list.php?FID=#FID#.
Страница чтения персонального сообщения | URL_TEMPLATES_PM_READ | Указывается адрес страницы просмотра персонального сообщения. По умолчанию поле содержит pm_read.php?MID=#MID#. Такая страница может быть создана с помощью компонента PM (чтение).
Страница редактирования (создания) персонального сообщения | URL_TEMPLATES_PM_EDIT | Указывается адрес страницы редактирования (создания) персонального сообщения. По умолчанию поле содержит pm_edit.php?MID=#MID#&mode=#mode#. Такая страница может быть создана с помощью компонента PM (изменение).
Страница управления директориями личных сообщений | URL_TEMPLATES_PM_FOLDER | Указывается адрес страницы управления папками пользователя с личными сообщениями. По умолчанию поле содержит pm_folder.php. Такая страница может быть создана с помощью компонента PM (папки).
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Задается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Количество сообщений на странице | PM_PER_PAGE | Указывается количество персональных сообщений, отображаемых на одной странице. Все персональные сообщения будут выведены с помощью постраничной навигации.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационную цепочку будет добавлен пункт с заголовком страницы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название папки.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.pm.list","",Array(
        "FID" => $_REQUEST["FID"],
        "URL_TEMPLATES_PM_LIST" => "pm_list.php?FID=#FID#",
        "URL_TEMPLATES_PM_READ" => "pm_read.php?MID=#MID#",
        "URL_TEMPLATES_PM_EDIT" => "pm_edit.php?MID=#MID#&mode=#mode#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "URL_TEMPLATES_PM_FOLDER" => "pm_folder.php",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "PM_PER_PAGE" => "20",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SET_NAVIGATION" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "SET_TITLE" => "Y"
    ),
);?>


PM (чтение)

Описание forum.pm.read

Компонент служит для создания страницы детального просмотра персонального сообщения. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID папки | FID | Указывается код, в котором передается идентификатор папки пользователя с личными сообщениями. По умолчанию поле содержит $_REQUEST["FID"].
ID сообщения | MID | Указывается код, в котором передается идентификатор сообщения. По умолчанию поле содержит $_REQUEST["MID"].
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/smile/.
Шаблоны ссылок
Страница списка персональных сообщений | URL_TEMPLATES_PM_LIST | Указывается адрес страницы со списком персональных сообщений. По умолчанию поле содержит pm_list.php?FID=#FID#. Такая страница может быть создана с помощью компонента PM (список).
Страница чтения персонального сообщения | URL_TEMPLATES_PM_READ | Указывается адрес страницы просмотра персонального сообщения. По умолчанию поле содержит pm_read.php?MID=#MID#.
Страница редактирования (создания) персонального сообщения | URL_TEMPLATES_PM_EDIT | Указывается адрес страницы редактирования (создания) персонального сообщения. По умолчанию поле содержит pm_edit.php?MID=#MID#&mode=#mode#. Такая страница может быть создана с помощью компонента PM (изменение).
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено <тема_сообщения> (чтение).
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции будет добавлен пункт с заголовком страницы в цепочку навигации.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.pm.read","",Array(
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "SET_NAVIGATION" => "Y",
        "URL_TEMPLATES_PM_LIST" => "pm_list.php?FID=#FID#",
        "URL_TEMPLATES_PM_READ" => "pm_read.php?MID=#MID#",
        "URL_TEMPLATES_PM_EDIT" => "pm_edit.php?MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "FID" => $_REQUEST["FID"],
        "MID" => $_REQUEST["MID"],
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/"
    )
);?>


Помощь

Описание forum.help

Компонент выводит помощь по форуму. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
Путь к файлу, содержащему текст раздела (при пустом поле ввода будет использовано значение по умолчанию) | CONTENT | Указывается путь к файлу, содержащему текст раздела. Если значение параметра не указано, то будет использовано значение по умолчанию.
Шаблоны ссылок
Страница списка форумов | URL_TEMPLATES_INDEX | Указывается адрес страницы со списком форумов. По умолчанию поле содержит index.php. Такая страница может быть создана с помощью компонента Форумы (список).
Дополнительные настройки
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационной цепочке будет отражен переход на страницу помощи по форуму.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Помощь.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.help","",Array(
        "CONTENT" => "",
        "URL_TEMPLATES_INDEX" => "index.php",
        "SET_NAVIGATION" => "Y",
        "SET_TITLE" => "Y"
    )
);?>


Правила

Описание forum.rules

Компонент служит для создания страницы с правилами форума. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
Путь к файлу, содержащему текст раздела (при пустом поле ввода будет использовано значение по умолчанию) | CONTENT | Указывается путь к файлу, содержащему текст раздела. Если значение параметра не указано, то будет использовано значение по умолчанию.
Шаблоны ссылок
Страница списка форумов | URL_TEMPLATES_INDEX | Указывается адрес страницы со списком форумов. По умолчанию поле содержит index.php. Такая страница может быть создана с помощью компонента Форумы (список).
Дополнительные настройки
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационную цепочку будет добавлен пункт с заголовком страницы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Правила форума.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.rules","",Array(
        "CONTENT" => "",
        "URL_TEMPLATES_INDEX" => "index.php",
        "SET_NAVIGATION" => "Y",
        "SET_TITLE" => "Y"
    )
);?>


Сообщения (перемещение)

Описание forum.message.move

Компонент служит для перемещения сообщений форума. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["FID"]}.
ID темы | TID | Указывается идентификатор темы, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["TID"]}.
ID сообщения | MID | Указывается идентификатор сообщения, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["MID"]}.
Могут отправлять письмо (e-mail) из профиля SEND_MAIL Указываются пользователи, которые могут отправлять письмо (e-mail) из профиля:
  • A - никто;
  • E - авторизованные пользователи;
  • U - все пользователи, а для неавторизованных пользователей выводить поле CAPTCHA;
  • Y - все пользователи.
Шаблоны ссылок
Страница списка форумов | URL_TEMPLATES_INDEX | Указывается адрес страницы со списком форумов. По умолчанию поле содержит index.php. Такая страница может быть создана с помощью компонента Форумы (список).
Страница списка тем | URL_TEMPLATES_LIST | Указывается адрес страницы со списком тем форума. По умолчанию поле содержит list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Темы (список).
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#. Такая страница может быть создана с помощью компонента Тема (чтение).
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Страница поиска темы форума | URL_TEMPLATES_TOPIC_SEARCH | Указывается адрес страницы поиска темы форума. По умолчанию поле содержит topic_search.php. Такая страница может быть создана с помощью компонента Темы (поиск).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/smile/.
Путь относительно корня сайта к папке с иконками к темам | PATH_TO_ICON | Указывается путь к папке с иконками к темам относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/icon/.
Длина слова | WORD_LENGTH | Задается максимально допустимая длина словообразующих символов, следующих друг за другом. Если длина слова превысит указанное число, то символы слова будут разбавлены разрывами (при просмотре сообщений разрывы не отображаются).
Размер прикрепленного рисунка (px) | IMAGE_SIZE | Указывается размер прикрепляемых изображений.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационной цепочке будет отражен переход на страницу переноса сообщения.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Перенос сообщений.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.message.move","",Array(
        "SEND_MAIL" => "E",
        "FID" => $_REQUEST["FID"],
        "TID" => $_REQUEST["TID"],
        "MID" => $_REQUEST["MID"],
        "URL_TEMPLATES_INDEX" => "index.php",
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "URL_TEMPLATES_TOPIC_SEARCH" => "topic_search.php",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "PATH_TO_ICON" => "/bitrix/images/forum/icon/",
        "WORD_LENGTH" => "50",
        "IMAGE_SIZE" => "300",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SET_NAVIGATION" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0"
    ),
);?>


Сообщения (проверка)

Описание forum.message.approve

Компонент выводит неодобренные сообщения форума. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["FID"]}.
ID темы | TID | Указывается идентификатор темы, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["TID"]}.
Могут отправлять письмо (e-mail) из профиля SEND_MAIL Указываются пользователи, которые могут отправлять письмо (e-mail) из профиля:
  • A - никто;
  • E - авторизованные пользователи;
  • U - все пользователи, а для неавторизованных пользователей выводить поле CAPTCHA;
  • Y - все пользователи.
Шаблоны ссылок
Страница списка форумов | URL_TEMPLATES_INDEX | Указывается адрес страницы со списком форумов. По умолчанию поле содержит index.php. Такая страница может быть создана с помощью компонента Форумы (список).
Страница списка тем | URL_TEMPLATES_LIST | Указывается адрес страницы со списком тем форума. По умолчанию поле содержит list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Темы (список).
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#. Такая страница может быть создана с помощью компонента Тема (чтение).
Страница чтения темы (с ID сообщения) | URL_TEMPLATES_MESSAGE | Указывается адрес страницы для чтения сообщения темы. По умолчанию поле содержит message.php?FID=#FID#&TID=#TID#&MID=#MID#.
Страница скрытых сообщений | URL_TEMPLATES_MESSAGE_APPR | Указывается адрес страницы со списком скрытых сообщений темы форума. По умолчанию поле содержит message_appr.php?FID=#FID#&TID=#TID#.
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Страница личных сообщений | URL_TEMPLATES_PM_EDIT | Указывается адрес страницы личных сообщений. По умолчанию поле содержит pm_edit.php.
Страница отправки сообщения | URL_TEMPLATES_MESSAGE_SEND | Указывается адрес страницы отправки сообщения форума. По умолчанию поле содержит message_send.php?UID=#UID#.
Страница создания новой темы | URL_TEMPLATES_TOPIC_NEW | Указывается адрес страницы создания новой темы форума. По умолчанию поле содержит topic_new.php?FID=#FID#.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Количество сообщений на странице | MESSAGES_PER_PAGE | Указывается количество сообщений, отображаемых на одной странице. Все сообщения будут выведены с помощью постраничной навигации.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Задается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Количество страниц в постраничной навигации | PAGE_NAVIGATION_WINDOW | Задается количество отображаемых в навигации ссылок на страницы. Если количество страниц превышает заданное число, то в навигацию будет добавлено многоточие.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/smile/.
Длина слова | WORD_LENGTH | Задается максимально допустимая длина словообразующих символов, следующих друг за другом. Если длина слова превысит указанное число, то символы слова будут разбавлены разрывами (при просмотре сообщений разрывы не отображаются).
Размер прикрепленного рисунка (px) | IMAGE_SIZE | Указывается размер прикрепляемых изображений в пикселях.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационной цепочке будет отражен переход на страницу с неодобренными сообщениями.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Скрытые сообщения.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.message.approve","",Array(
        "SEND_MAIL" => "E",
        "FID" => $_REQUEST["FID"],
        "TID" => $_REQUEST["TID"],
        "URL_TEMPLATES_INDEX" => "index.php",
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_MESSAGE" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_MESSAGE_APPR" => "message_appr.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "URL_TEMPLATES_PM_EDIT" => "pm_edit.php",
        "URL_TEMPLATES_MESSAGE_SEND" => ""message_send.php?UID=#UID#",
        "URL_TEMPLATES_TOPIC_NEW" => "topic_new.php?FID=#FID#",
        "MESSAGES_PER_PAGE" => "10",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "PAGE_NAVIGATION_WINDOW" => "11",
        "SET_NAVIGATION" => "Y",
        "WORD_LENGTH" => "50",
        "IMAGE_SIZE" => "300",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SET_NAVIGATION" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0"
    )
);?>


Статистика

Описание forum.statistic

Компонент выводит статистику по форуму, информацию по посетителям. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["FID"]}.
ID темы | TID | Указывается идентификатор темы, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["TID"]}.
Период для отображения статистики (сек.) | PERIOD | Указывается период времени в секундах, за который показывается статистика форума.
Отображать в статистике SHOW Указываются данные, которые будут отображены в статистике:
  • STATISTIC - статистика форумов;
  • BIRTHDAY - именинники;
  • USERS_ONLINE - он-лайн пользователи.
Шаблоны ссылок
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Время кеширования списка пользователей на форуме | CACHE_TIME_USER_STAT | Указывается время кеширование информации о списке пользователей форума в секундах.
Дополнительные настройки
Длина слова | WORD_LENGTH | Задается максимально допустимая длина словообразующих символов, следующих друг за другом. Если длина слова превысит указанное число, то символы слова будут разбавлены разрывами (при просмотре сообщений разрывы не отображаются).
Не индексировать ссылку на профиль | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.statistic","",Array(
        "SEO_USER" => "Y",
        "FID" => $_REQUEST["FID"],
        "TID" => $_REQUEST["TID"],
        "PERIOD" => "600",
        "SHOW" => array("STATISTIC","BIRTHDAY","USERS_ONLINE"),
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "CACHE_TIME_USER_STAT" => "600",
        "WORD_LENGTH" => "50",
    )
);?>


Комментарии к инфоблоку

Описание forum.topic.reviews

Компонент выводит форму для создания отзыва к элементу инфоблока (например, новости, фотографии), а также весь список отзывов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума для отзывов | FORUM_ID | Указывается идентификатор форума, в котором будут храниться отзывы пользователей.
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, элементы которого будут выводиться.
ID элемента | ELEMENT_ID | Указывается идентификатор элемента инфоблока, отзывы к которому будут создаваться.
Шаблоны ссылок
Страница чтения темы форума | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#. Такая страница может быть создана с помощью компонента Тема (чтение).
Страница элемента инфоблока | URL_TEMPLATES_DETAIL | Указывается адрес страницы элемента инфоблока. Например, для фотографии поле может содержать photo_detail.php?ID=#ELEMENT_ID#.
Страница пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Указывается количество сообщений, отображаемых на одной странице. Все сообщения будут выведены с помощью постраничной навигации.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Задается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
По умолчанию показывать невизуальный режим редактора | EDITOR_CODE_DEFAULT | [Y|N] При отмеченной опции при создании или редактировании сообщения будет включен режим показа BB-кодов. (Пример: [B]сообщение[/B] вместо сообщение).
Показывать аватары пользователей | SHOW_AVATAR | [Y|N] При отмеченной опции при выводе отзыва будет показан аватар пользователя.
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.

Примечание:

С версии 17.5.4 добавлена поддержка рейтингов с реакциями.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).
Сворачивать форму добавления отзыва | SHOW_MINIMIZED | [Y|N] При отмеченной опции форма ввода отзыва будет свернута.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления отзыва в публичной части.
Выводить сообщения в прямом порядке | PREORDER | [Y|N] При отмеченной опции сообщения будут отсортированы по возрастанию.
Показать ссылку на форум | SHOW_LINK_TO_FORUM | [Y|N] При отмеченной опции на странице элемента будет отображена ссылка на форум обсуждения.
Максимальное количество файлов, прикрепленных к одному сообщению FILES_COUNT Задается количество файлов, которое может быть прикреплено к сообщению.

Примечание: Данный параметр работает только в том случае, если в настройках соответствующего форума разрешено прикреплять файлы к сообщениям.
Использовать AJAX в диалогах | AJAX_POST | [Y|N] При отмеченной опции будет использоваться технология AJAX при добавлении, скрытии/показе и удалении сообщений на форуме.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.topic.reviews","",Array(
        "SHOW_LINK_TO_FORUM" => "Y",
        "FILES_COUNT" => "2",
        "FORUM_ID" => "1",
        "IBLOCK_TYPE" => "photos",
        "IBLOCK_ID" => "22",
        "ELEMENT_ID" => "177",
        "AJAX_POST" => "N",
        "POST_FIRST_MESSAGE" => "Y",
        "POST_FIRST_MESSAGE_TEMPLATE" => "#IMAGE#[url=#LINK#]#TITLE#[/url]#BODY#",
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_DETAIL" => "photo_detail.php?ID=#ELEMENT_ID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "MESSAGES_PER_PAGE" => "10",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "EDITOR_CODE_DEFAULT" => "Y",
        "SHOW_AVATAR" => "Y",
        "SHOW_RATING" => "Y",
        "RATING_TYPE" => "like",
        "SHOW_MINIMIZED" => "Y",
        "USE_CAPTCHA" => "Y",
        "PREORDER" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0"
    )
);?>


Тема (создание)

Описание forum.topic.new

Компонент служит для сохранения новой темы форума. Он ничего не выводит. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["FID"]}.
ID темы | TID | Указывается идентификатор темы, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["TID"]}.
Действие над сообщением | MESSAGE_TYPE | Указывается переменная, в которой будет содержаться код действия над сообщением. По умолчанию поле содержит ={$_REQUEST["MESSAGE_TYPE"]}.
Шаблоны ссылок
Страница списка форумов | URL_TEMPLATES_INDEX | Указывается адрес страницы со списком форумов. По умолчанию поле содержит index.php. Такая страница может быть создана с помощью компонента Форумы (список).
Страница списка тем | URL_TEMPLATES_LIST | Указывается адрес страницы со списком тем форума. По умолчанию поле содержит list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Темы (список).
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#. Такая страница может быть создана с помощью компонента Тема (чтение).
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Указывается адрес страницы чтения сообщения форума. По умолчанию поле содержит message.php?FID=#FID#&TID=#TID#&MID=#MID#.
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/smile/.
Путь относительно корня сайта к папке с иконками к темам | PATH_TO_ICON | Указывается путь к папке с иконками к темам относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/icon/.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационную цепочку будет добавлен пункт с заголовком страницы.
Использовать аякс | AJAX_TYPE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Новая тема.
Показывать теги | SHOW_TAGS | [Y|N] При отмеченной опции будут показаны теги.
Настройки опросов
Показывать опросы SHOW_VOTE [Y|N] При отмеченной опции будет выведена форма создания опроса. Создание опроса доступно только при создании новой темы на форуме. При выборе данной опции станут активны [dw]дополнительные поля.[/dw][di]
Группа опросов | VOTE_CHANNEL_ID | Указывается группа опросов, в которой будет создан опрос.
Группа пользователей, которым разрешено создавать опросы | VOTE_GROUP_ID | Задаются группы пользователей, которым разрешено создавать опросы на форуме.
[/di]

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.topic.new","",Array(
        "SHOW_TAGS" => "Y",
        "FID" => $_REQUEST["FID"],
        "MID" => $_REQUEST["MID"],
        "MESSAGE_TYPE" => $_REQUEST["MESSAGE_TYPE"],
        "URL_TEMPLATES_INDEX" => "index.php",
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_MESSAGE" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "PATH_TO_ICON" => "/bitrix/images/forum/icons/",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SET_NAVIGATION" => "Y",
        "AJAX_TYPE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "SET_TITLE" => "Y",
        "SHOW_VOTE" => "Y",
        "VOTE_CHANNEL_ID" => "2",
        "VOTE_GROUP_ID" => ""
    )
);?>


Тема (чтение)

Описание forum.topic.read

Компонент выводит список сообщений темы форума. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["FID"]}.
ID темы | TID | Указывается идентификатор темы, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["TID"]}.
ID сообщения | MID | Указывается идентификатор сообщения, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["MID"]}.
Могут отправлять письмо (e-mail) из профиля SEND_MAIL Указываются пользователи, которые могут отправлять письмо (e-mail) из профиля:
  • A - никто;
  • E - авторизованные пользователи;
  • U - все пользователи, а для неавторизованных пользователей выводить поле CAPTCHA;
  • Y - все пользователи.
Шаблоны ссылок
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#.
Страница чтения темы (с ID сообщения) | URL_TEMPLATES_MESSAGE | Указывается адрес страницы со списком тем форума. По умолчанию поле содержит message.php?FID=#FID#&TID=#TID#&MID=#MID#.
Страница списка тем | URL_TEMPLATES_LIST | Указывается адрес страницы со списком тем форума. По умолчанию поле содержит list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Темы (список).
Страница переноса сообщений | URL_TEMPLATES_MESSAGE_MOVE | Указывается адрес страницы переноса сообщений форума. По умолчанию поле содержит message_move.php?FID=#FID#&TID=#TID#&MID_ARRAY=#MID_ARRAY#. Такая страница может быть создана с помощью компонента Сообщения (перемещение).
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Страница создания новой темы | URL_TEMPLATES_TOPIC_NEW | Указывается адрес страницы создания новой темы форума. По умолчанию поле содержит topic_new.php?FID=#FID#. Такая страница может быть создана с помощью компонента Тема (создание).
Страница подписки | URL_TEMPLATES_SUBSCR_LIST | Указывается адрес страницы подписки на форум. По умолчанию поле содержит subscr_list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Подписка (список).
Страница переноса тем | URL_TEMPLATES_TOPIC_MOVE | Указывается адрес страницы переноса темы форума. По умолчанию поле содержит topic_move.php?FID=#FID#&TID=#TID#. Такая страница может быть создана с помощью компонента Темы (перемещение).
Страница списка форумов | URL_TEMPLATES_INDEX | Указывается адрес страницы со списком форумов. По умолчанию поле содержит index.php. Такая страница может быть создана с помощью компонента Форумы (список).
Страница личных сообщений | URL_TEMPLATES_PM_EDIT | Указывается адрес страницы со списком форумов. По умолчанию поле содержит pm_edit.php. Такая страница может быть создана с помощью компонента PM (изменение).
Страница отправки сообщения | URL_TEMPLATES_MESSAGE_SEND | Указывается адрес страницы отправки сообщения. По умолчанию поле содержит message_send.php?UID=#UID#.
Страница RSS | URL_TEMPLATES_RSS | Указывается адрес страницы RSS форума. По умолчанию поле содержит rss.php?TYPE=#TYPE#&MODE=#MODE#&IID=#IID#.
Страница сообщений пользователя | URL_TEMPLATES_USER_POST | Указывается адрес страницы сообщений пользователя. По умолчанию поле содержит user_post.php?UID=#UID#&mode=#mode#.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Указывается количество сообщений, отображаемых на одной странице. Все сообщения будут выведены с помощью постраничной навигации.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Задается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Количество страниц в постраничной навигации | PAGE_NAVIGATION_WINDOW | Задается количество отображаемых в навигации ссылок на страницы. Если количество страниц превышает заданное число, то в навигацию будет добавлено многоточие.
Разрешать показывать все страницы форума | PAGE_NAVIGATION_SHOW_ALL | [Y|N] При отмеченной опции будут показаны все страницы форума.
Длина слова | WORD_LENGTH | Задается максимально допустимая длина словообразующих символов, следующих друг за другом. Если длина слова превысит указанное число, то символы слова будут разбавлены разрывами (при просмотре сообщений разрывы не отображаются).
Размер прикрепленного рисунка (px) | IMAGE_SIZE | Указывается допустимый размер прикрепленного рисунка в пикселах.
Показывать первое сообщение темы на каждой странице | SHOW_FIRST_POST | [Y|N] При отмеченной опции на каждой странице просмотра темы будет отображаться первое ее сообщение.
Показывать навигацию (хлебные крошки) | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационную цепочку будет добавлен пункт с заголовком страницы.
Использовать аякс | AJAX_TYPE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Устанавливать теги и описание темы в свойства страницы | SET_PAGE_PROPERTY | [Y|N] Разрешает установку тегов и описания темы, указанных при создании темы в качестве тегов и описания для страницы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название просматриваемой темы.
Как показывать прикрепленные рисунки (под сообщением) ATTACH_MODE Задается форма отображения прикрепленных рисунков (под сообщением). Доступные формы:
  • [dw]Миниатюра[/dw][di] При выборе формы Миниатюра станет доступно дополнительное поле:
    Размер миниатюры рисунка (под сообщением, px) ATTACH_SIZE Задается сторона квадрата, в который с сохранением пропорций будет включено изображение. Указывается в пикселях.
    [/di]
  • Название
Показывать RSS | SHOW_RSS | [Y|N] При отмеченной опции на странице будет отображаться ссылка на RSS.
Показывать ссылку «Имя» | SHOW_NAME_LINK | [Y|N] При отмеченной опции в форме сообщения будет показана ссылка «Имя» для вставки имени пользователя в создаваемое сообщение.
Не индексировать ссылку на профиль | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.
Показывать опросы | SHOW_VOTE | [Y|N] При отмеченной опции будет выведен опрос.
Шаблон для опросов | VOTE_TEMPLATE | Укажите шаблон для отображения опроса.
Настройки рейтинга
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • - по умолчанию;
  • Y - да;
  • N - нет.

Примечание:

С версии 17.5.4 добавлена поддержка рейтингов с реакциями.
Рейтинг | RATING_ID | Указывается какой будет использоваться рейтинг.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.topic.read","",Array(
        "SEND_MAIL" => "E",
        "SHOW_RSS" => "Y",
        "SHOW_NAME_LINK" => "Y",
        "SEO_USER" => "Y",
        "SHOW_VOTE" => "Y",
        "VOTE_TEMPLATE" => "light",
        "FID" => $_REQUEST["FID"],
        "TID" => $_REQUEST["TID"],
        "MID" => $_REQUEST["MID"],
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_MESSAGE" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "URL_TEMPLATES_MESSAGE_MOVE" => "message_move.php?FID=#FID#&TID=#TID#&MID_ARRAY=#MID_ARRAY#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "URL_TEMPLATES_TOPIC_NEW" => "topic_new.php?FID=#FID#",
        "URL_TEMPLATES_SUBSCR_LIST" => "subscr_list.php?FID=#FID#",
        "URL_TEMPLATES_TOPIC_MOVE" => "topic_move.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_INDEX" => "index.php",
        "URL_TEMPLATES_PM_EDIT" => "pm_edit.php",
        "URL_TEMPLATES_MESSAGE_SEND" => "message_send.php?UID=#UID#",
        "URL_TEMPLATES_RSS" => "rss.php?TYPE=#TYPE#&MODE=#MODE#&IID=#IID#",
        "URL_TEMPLATES_USER_POST" => "user_post.php?UID=#UID#&mode=#mode#",
        "PAGEN" => "1",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "MESSAGES_PER_PAGE" => "10",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "PAGE_NAVIGATION_WINDOW" => "11",
        "PAGE_NAVIGATION_SHOW_ALL" => "N",
        "WORD_LENGTH" => "50",
        "IMAGE_SIZE" => "300",
        "SHOW_FIRST_POST" => "N",
        "SET_NAVIGATION" => "Y",
        "AJAX_TYPE" => "Y",
        "SET_PAGE_PROPERTY" => "Y",
        "SET_TITLE" => "Y",
        "SHOW_RATING" => "Y",
        "RATING_ID" => "2",
        "RATING_TYPE" => "like",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0"
    )
);?>


Темы (новые)

Описание forum.topic.active

Компонент выводит список новых тем форума. Также компонент выводит форму для выбора форума, новые темы которого показывать. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["FID"]}.
Шаблоны ссылок
Страница списка форумов | URL_TEMPLATES_INDEX | Указывается адрес страницы со списком форумов. По умолчанию поле содержит index.php. Такая страница может быть создана с помощью компонента Форумы (список).
Страница списка тем | URL_TEMPLATES_LIST | Указывается адрес страницы со списком тем форума. По умолчанию поле содержит list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Темы (список).
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#. Такая страница может быть создана с помощью компонента Тема (чтение).
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Указывается адрес страницы чтения сообщения форума. По умолчанию поле содержит message.php?FID=#FID#&TID=#TID#&MID=#MID#.
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Порядковый номер постраничной навигации | PAGEN | Параметр определяет порядковый номер постраничной навигации на странице.
Количество тем на одной странице | TOPICS_PER_PAGE | Указывается количество тем форума, отображаемых на одной странице. Все темы будут выведены с помощью постраничной навигации.
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Указывается количество сообщений, отображаемых на одной странице. Все сообщения будут выведены с помощью постраничной навигации.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указывается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Количество страниц в постраничной навигации | PAGE_NAVIGATION_WINDOW | Задается количество отображаемых в навигации ссылок на страницы. Если количество страниц превышает заданное число, то в навигацию будет добавлено многоточие.
ID форума FID_RANGE Указываются форумы, для которых будут отображаться новые темы.

В публичном разделе сначала отображаются темы по указанным форумам, а затем накладывается условие FID (т.е. пользователь выбирает конкретный форум в фильтре).
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Длина слова | WORD_LENGTH | Задается максимально допустимая длина словообразующих символов, следующих друг за другом. Если длина слова превысит указанное число, то символы слова будут разбавлены разрывами (при просмотре сообщений разрывы не отображаются).
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационной цепочке будет отражен переход на страницу новых тем.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Новые темы.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.topic.active","",Array(
        "FID" => $_REQUEST["FID"],
        "URL_TEMPLATES_INDEX" => "index.php",
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_MESSAGE" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "PAGEN" => "1",
        "TOPICS_PER_PAGE" => "10",
        "MESSAGES_PER_PAGE" => "10",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "PAGE_NAVIGATION_WINDOW" => "11",
        "FID_RANGE" => Array(),
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "WORD_LENGTH" => "50",
        "SET_NAVIGATION" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "SET_TITLE" => "Y"
    )
);?>


Темы (перемещение)

Описание forum.topic.move

Компонент служит для создания страницы перемещения тем форума. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["FID"]}.
ID темы | TID | Указывается идентификатор темы, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["TID"]}.
Шаблоны ссылок
Страница списка форумов | URL_TEMPLATES_INDEX | Указывается адрес страницы со списком форумов. По умолчанию поле содержит index.php. Такая страница может быть создана с помощью компонента Форумы (список).
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#. Такая страница может быть создана с помощью компонента Тема (чтение).
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Указывается адрес страницы чтения сообщения форума. По умолчанию поле содержит message.php?FID=#FID#&TID=#TID#&MID=#MID#.
Страница списка тем | URL_TEMPLATES_LIST | Указывается адрес страницы со списком тем форума. По умолчанию поле содержит list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Темы (список).
Страница переноса тем | URL_TEMPLATES_TOPIC_MOVE | Указывается адрес страницы переноса темы форума. По умолчанию поле содержит topic_move.php?FID=#FID#&TID=#TID#.
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационную цепочку будет добавлен пункт с заголовком страницы.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Перенос темы в другой форум.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.topic.move","",Array(
        "FID" => $_REQUEST["FID"],
        "TID" => $_REQUEST["TID"],
        "URL_TEMPLATES_INDEX" => "index.php",
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_MESSAGE" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "URL_TEMPLATES_TOPIC_MOVE" => "topic_move.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "PATH_TO_ICON" => "/bitrix/images/forum/icon/",
        "SET_NAVIGATION" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0"
    )
);?>


Темы (поиск)

Описание forum.topic.search

Компонент выводит форму поиска тем форума. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
Страница поиска темы | URL_TEMPLATES_TOPIC_SEARCH | Указывается адрес страницы поиска темы форума. По умолчанию поле содержит topic_search.php. Такая страница может быть создана с помощью компонента Поиск.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Количество тем на одной странице | TOPICS_PER_PAGE | Указывается количество найденных тем на одной странице. Все темы будут выведены с помощью постраничной навигации.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указывается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Количество страниц в постраничной навигации | PAGE_NAVIGATION_WINDOW | Задается количество отображаемых в навигации ссылок на страницы. Если количество страниц превышает заданное число, то в навигацию будет добавлено многоточие.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.topic.search","",Array(
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "TOPICS_PER_PAGE" => "10",
        "URL_TEMPLATES_TOPIC_SEARCH" => "topic_search.php",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "PAGE_NAVIGATION_WINDOW" => "11"
    ),
);?>


Темы (список внешний)

Описание forum.topic.last

Компонент выводит список тем (для использования вне форума). Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Дополнительно
Показывать навигацию SHOW_NAV Указывается способ отображения постраничной навигации по темам:
  • сверху (TOP);
  • снизу (BOTTOM).
Если ничего не выбрано, то постраничная навигация выведена не будет.
Показывать колонки SHOW_COLUMNS Параметр служит для выбора полей, которые будут выведены для каждой темы в виде таблицы. В публичной части редактора поля выбираются, удерживая CTRL. В коде задаются в виде массива, например:

"SHOW_COLUMNS" => Array("USER_START_NAME","POSTS","LAST_POST_DATE"),
Показывать сортировку | SHOW_SORTING | [Y|N] При отмеченной опции в публичной части будет доступна сортировка тем.
Шаблон-разделитель для темы и форума | SEPARATE | Указывается шаблон-разделитель для темы и форума. Например, в форуме «#FORUM#».
Основные параметры
ID форума | FID | Указываются форумы, которые будут отображены в списке. Если не выбран ни один форум, то будут показаны все форумы.
Поле для сортировки SORT_BY Указывается порядок сортировки тем в списке:
  • по заголовку - Заголовок (TITLE);
  • по автору - Автор (USER_START_NAME);
  • по количеству ответов - Ответы (POSTS);
  • по количеству просмотров - Прочитано (VIEWS);
  • по дате последнего сообщения - Последнее сообщение (LAST_POST_DATE).
Направление сортировки SORT_ORDER Задается направление для сортировки тем:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Показывать вверху прикрепленные темы | SORT_BY_SORT_FIRST | [Y|N] При отмеченной опции прикрепленные темы будут показаны вверху списка.
Шаблоны ссылок
Страница списка форумов | URL_TEMPLATES_INDEX | Указывается адрес страницы со списком форумов. По умолчанию поле содержит index.php. Такая страница может быть создана с помощью компонента Форумы (список).
Страница списка тем | URL_TEMPLATES_LIST | Указывается адрес страницы со списком тем форума. По умолчанию поле содержит list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Темы (список).
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#. Такая страница может быть создана с помощью компонента Тема (чтение).
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Указывается адрес страницы чтения сообщения форума. По умолчанию поле содержит message.php?FID=#FID#&TID=#TID#&MID=#MID#. Такая страница может быть создана с помощью компонента PM (чтение).
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Количество тем на одной странице | TOPICS_PER_PAGE | Указывается количество тем форума, отображаемых на одной странице. Все темы будут выведены с помощью постраничной навигации.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать форумы других сайтов | SHOW_FORUM_ANOTHER_SITE | [Y|N] При отмеченной опции администратору будут показаны форумы других сайтов.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Список тем.
Настройки вывода первого сообщения темы
Сообщение темы SHOW_TOPIC_POST_MESSAGE Выбор сообщения, которое будет отображаться первым. Доступные опции:
  • не показывать
  • [dw]показывать первое сообщение темы[/dw][di] При выборе данной опции станут доступны дополнительные поля:
    Максимальная длина сообщения | TOPIC_POST_MESSAGE_LENGHT | Задается максимальное число символов, используемых для написания сообщения.
    Размер рисунков в тексте сообщения (px) | IMAGE_SIZE | Задается сторона квадрата, в который с сохранением пропорций будет включено изображение.
    Позволить HTML-код | ALLOW_HTML | При выборе данной опции в сообщения можно будет вставить код html .
    Позволить ссылки | ALLOW_ANCHOR | При выборе данной опции в сообщения можно будет вставить ссылки.
    Позволить изображения | ALLOW_IMG | Разрешить использование изображений в тексте сообщения. Изображения располагаются на сторонних сайтах и подключаются на форуме (<img src=...>)
    Позволить видео | ALLOW_VIDEO | При выборе данной опции к сообщениям можно будет прикреплять видео.
    Позволить списки | ALLOW_LIST | При выборе данной опции к сообщениям можно будет прикреплять видео.
    Позволить цитирование | ALLOW_QUOTE | Возможность цитировать сообщение другого пользователя ().
    Позволить коды | ALLOW_CODE | Возможность использования кодов в сообщении (<code>).
    Позволить выравнивание | ALLOW_ALIGN | Разрешить использование выравнивания текста.
    Позволить таблицы | ALLOW_TABLE | Разрешить использование таблиц (<table>).
    Позволить шрифты | ALLOW_FONT | Возможность изменения цвета текста и шрифт (<font color=...>).
    Позволить смайлы | ALLOW_SMILES | Возможность использования смайлов в сообщении.
    Заменять символ перевода каретки на <br> | ALLOW_NL2BR | замена символа перевода каретки на <br> (Доступно только при отмеченной опции HTML-код).
    [/di]
  • [dw]показывать последнее сообщение темы[/dw][di] При выборе данной опции станут доступны дополнительные поля:
    Максимальная длина сообщения | TOPIC_POST_MESSAGE_LENGHT | Задается максимальное число символов, используемых для написания сообщения.
    Размер рисунков в тексте сообщения (px) | IMAGE_SIZE | Задается сторона квадрата, в который с сохранением пропорций будет включено изображение.
    Позволить HTML-код | ALLOW_HTML | При выборе данной опции в сообщения можно будет вставить код html .
    Позволить ссылки | ALLOW_ANCHOR | При выборе данной опции в сообщения можно будет вставить ссылки.
    Позволить изображения | ALLOW_IMG | Разрешить использование изображений в тексте сообщения. Изображения располагаются на сторонних сайтах и подключаются на форуме (<img src=...>)
    Позволить видео | ALLOW_VIDEO | При выборе данной опции к сообщениям можно будет прикреплять видео.
    Позволить списки | ALLOW_LIST | При выборе данной опции к сообщениям можно будет прикреплять видео.
    Позволить цитирование | ALLOW_QUOTE | Возможность цитировать сообщение другого пользователя ().
    Позволить коды | ALLOW_CODE | Возможность использования кодов в сообщении (<code>).
    Позволить выравнивание | ALLOW_ALIGN | Разрешить использование выравнивания текста.
    Позволить таблицы | ALLOW_TABLE | Разрешить использование таблиц (<table>).
    Позволить шрифты | ALLOW_FONT | Возможность изменения цвета текста и шрифт (<font color=...>).
    Позволить смайлы | ALLOW_SMILES | Возможность использования смайлов в сообщении.
    Заменять символ перевода каретки на <br> | ALLOW_NL2BR | замена символа перевода каретки на <br> (Доступно только при отмеченной опции HTML-код).
    [/di]
Настройки постраничной навигации
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационной цепочке будет отражен переход на страницу списка тем форума.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигации будет выводиться, даже если все элементы помещаются на одной странице.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при постраничной навигации (например, тема, сообщение и др.)
Название шаблона | PAGER_TEMPLATE | Задается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.topic.last","",Array(
        "SHOW_NAV" => array("BOTTOM"),
        "SHOW_COLUMNS" => array("USER_START_NAME","POSTS","VIEWS","LAST_POST_DATE"),
        "SHOW_SORTING" => "Y",
        "SEPARATE" => "в форуме «#FORUM#»",
        "FID" => Array(),
        "SORT_BY" => "LAST_POST_DATE",
        "SORT_ORDER" => "DESC",
        "SORT_BY_SORT_FIRST" => "Y",
        "URL_TEMPLATES_INDEX" => "index.php",
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_MESSAGE" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "TOPICS_PER_PAGE" => "10",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_FORUM_ANOTHER_SITE" => "Y",
        "SET_NAVIGATION" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "SET_TITLE" => "Y",
        "PAGER_DESC_NUMBERING" => "Y",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_TITLE" => "Темы",
        "PAGER_TEMPLATE" => ""
    )
);?>


Темы (список)

Описание forum.topic.list

Компонент выводит список всех тем форума. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["FID"]}.
Использовать обратную постраничку | USE_DESC_PAGE | [Y|N] При отмеченной опции будет использоваться обратная постраничная навигация для списка тем.
Шаблоны ссылок
Страница списка форумов | URL_TEMPLATES_INDEX | Указывается адрес страницы со списком форумов. По умолчанию поле содержит index.php. Такая страница может быть создана с помощью компонента Форумы (список).
Страница просмотра форумов группы | URL_TEMPLATES_FORUMS | Указывается адрес страницы просмотра списка форумов группы форумов. По умолчанию поле содержит forums.php?GID=#GID#.
Страница списка тем | URL_TEMPLATES_LIST | Указывается адрес страницы со списком тем форума. По умолчанию поле содержит list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Темы (список).
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#. Такая страница может быть создана с помощью компонента Тема (чтение).
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Указывается адрес страницы чтения сообщения форума. По умолчанию поле содержит message.php?FID=#FID#&TID=#TID#&MID=#MID#.
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Страница списка скрытых сообщений | URL_TEMPLATES_MESSAGE_APPR | Указывается адрес страницы с неодобренными сообщениями форума. По умолчанию поле содержит message_appr.php?FID=#FID#. Такая страница может быть создана с помощью компонента Сообщения (проверка).
Страница создания новой темы | URL_TEMPLATES_TOPIC_NEW | Указывается адрес страницы создания новой темы. По умолчанию поле содержит topic_new.php?FID=#FID#. Такая страница может быть создана с помощью компонента Тема (создание).
Страница подписки | URL_TEMPLATES_SUBSCR_LIST | Указывается адрес страницы подписки на форум. По умолчанию поле содержит subscr_list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Подписка (список).
Страница переноса тем | URL_TEMPLATES_TOPIC_MOVE | Указывается адрес страницы переноса темы форума. По умолчанию поле содержит topic_move.php?FID=#FID#&TID=#TID#. Такая страница может быть создана с помощью компонента Темы (перемещение).
Страница RSS | URL_TEMPLATES_RSS | Указывается адрес страницы RSS форума. По умолчанию поле содержит rss.php?TYPE=#TYPE#&MODE=#MODE#&IID=#IID#.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Порядковый номер постраничной навигации | PAGEN | Параметр определяет порядковый номер постраничной навигации на странице.
Количество тем на одной странице | TOPICS_PER_PAGE | Указывается количество тем форума, отображаемых на одной странице. Все темы будут выведены с помощью постраничной навигации.
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Указывается количество сообщений, отображаемых на одной странице. Все сообщения будут выведены с помощью постраничной навигации.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указывается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Количество страниц в постраничной навигации | PAGE_NAVIGATION_WINDOW | Задается количество отображаемых в навигации ссылок на страницы. Если количество страниц превышает заданное число, то в навигацию будет добавлено многоточие.
Показывать навигацию | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационной цепочке будет отражен переход на страницу списка тем форума.
Длина слова | WORD_LENGTH | Задается максимально допустимая длина словообразующих символов, следующих друг за другом. Если длина слова превысит указанное число, то символы слова будут разбавлены разрывами (при просмотре сообщений разрывы не отображаются).
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название форума, список тем которого просматривается.
Дополнительный маркер для новых сообщений | TMPLT_SHOW_ADDITIONAL_MARKER | Задается текст надписи, отображаемый рядом с темой, в которой есть непрочитанные вами сообщения.
Показывать RSS | SHOW_RSS | [Y|N] При отмеченной опции на странице будет отображаться ссылка на RSS.
Не индексировать ссылку на профиль | SEO_USER | [Y|N] При отмеченной опции поисковые боты не смогут индексировать ссылки на профиль пользователя.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.topic.list","",Array(
        "TMPLT_SHOW_ADDITIONAL_MARKER" => "",
        "SHOW_RSS" => "Y",
        "SEO_USER" => "Y",
        "FID" => $_REQUEST["FID"],
        "USE_DESC_PAGE" => "Y",
        "URL_TEMPLATES_INDEX" => "index.php",
        "URL_TEMPLATES_FORUMS" => "forums.php?GID=#GID#",
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_MESSAGE" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "URL_TEMPLATES_MESSAGE_APPR" => "message_appr.php?FID=#FID#",
        "URL_TEMPLATES_TOPIC_NEW" => "topic_new.php?FID=#FID#",
        "URL_TEMPLATES_SUBSCR_LIST" => "subscr_list.php?FID=#FID#",
        "URL_TEMPLATES_TOPIC_MOVE" => "topic_move.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_RSS" => "rss.php?TYPE=#TYPE#&MODE=#MODE#&IID=#IID#",
        "PAGEN" => "1",
        "TOPICS_PER_PAGE" => "10",
        "MESSAGES_PER_PAGE" => "10",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "PAGE_NAVIGATION_WINDOW" => "11",
        "SET_NAVIGATION" => "Y",
        "WORD_LENGTH" => "50",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "SET_TITLE" => "Y"
    ),
);?>


Форма создания сообщения

Описание forum.post_form

Компонент выводит форму создания сообщения (или темы) форума. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
ID форума | FID | Указывается идентификатор форума, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["FID"]}.
ID темы | TID | Указывается идентификатор темы, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["TID"]}.
ID сообщения | MID | Указывается идентификатор сообщения, явно или в виде кода. По умолчанию поле содержит ={$_REQUEST["MID"]}.
ID вызывающего компонента | PAGE_NAME | Указывается идентификатор вызывающего компонента. Например, message.
Тип отображения формы редактирования (ответ, редактирование, новая тема) MESSAGE_TYPE Указывается тип отображения формы редактирования. Возможные варианты зачения параметра:
  • ответ - REPLY;
  • редактирование - EDIT;
  • новая тема - NEW.
По умолчанию показывать невизуальный режим редактора | EDITOR_CODE_DEFAULT | [Y|N] При отмеченной опции при создании или редактировании сообщения будет включен режим показа BB-кодов. (Пример: [B]сообщение[/B] вместо сообщение).
Шаблоны ссылок
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Указывается адрес страницы чтения сообщения форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#.
Страница списка тем | URL_TEMPLATES_LIST | Указывается адрес страницы со списком тем форума. По умолчанию поле содержит list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Темы (список).
Страница помощи по форумам | URL_TEMPLATES_HELP | Указывается адрес страницы помощи по форумам.
Страница правил форумов | URL_TEMPLATES_RULES | Указывается адрес страницы со списком правил форума.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайлами относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/smile/.
Путь относительно корня сайта к папке с иконками к темам | PATH_TO_ICON | Указывается путь к папке с иконками к темам относительно корня сайта. По умолчанию поле содержит /bitrix/images/forum/icon/.
Использовать аякс | AJAX_TYPE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Показывать теги | SHOW_TAGS | [Y|N] При отмеченной опции будет выведена форма ввода тегов.
Количество смайлов, которые буду показаны статически (при значении 0 количество смайлов будет высчитываться динамически) | SMILES_COUNT | Задается количество смайлов, которые будут всегда отображаться, а все смайлы будут доступны по кнопке Еще.
Настройки опросов
Показывать опросы | SHOW_VOTE | [Y|N] При отмеченной опции будет выведен опрос. Создание опроса доступно только при создании новой темы на форуме.
Группа опросов | VOTE_CHANNEL_ID | Указывается группа опросов, в которой будет создан опрос.
Группа пользователей, которым разрешено создавать опросы | VOTE_GROUP_ID | Задаются группы пользователей, которым разрешено создавать опросы на форуме.

Сообщение, выведенное, компонентом forum.post_form, не будет сохранено в компоненте forum.post_form, а только в forum.topic.new.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.post_form","",Array(
        "SHOW_TAGS" => "Y",
        "FILES_COUNT" => "5",
        "SMILES_COUNT" => "8",
        "VOTE_COUNT_QUESTIONS" => "10",
        "VOTE_COUNT_ANSWERS" => "20",
        "FID" => $_REQUEST["FID"],
        "TID" => $_REQUEST["TID"],
        "MID" => $_REQUEST["MID"],
        "PAGE_NAME" => "message",
        "MESSAGE_TYPE" => $_REQUEST["MESSAGE_TYPE"],
        "URL_TEMPLATES_MESSAGE" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "URL_TEMPLATES_HELP" => "help.php",
        "URL_TEMPLATES_RULES" => "rules.php",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "PATH_TO_ICON" => "/bitrix/images/forum/icon/",
        "AJAX_TYPE" => "Y",
        "EDITOR_CODE_DEFAULT" => "N",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0",
        "SHOW_VOTE" => "Y",
        "VOTE_CHANNEL_ID" => "2",
        "VOTE_GROUP_ID" => Array("1");
    ),
);?>


Форумы (список)

Описание forum.index

Компонент выводит список всех форумов. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Параметры

Поле | Параметр | Описание
Основные параметры
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
ID группы форумов | GID | Указывается идентификатор группы форумов. Может быть задан неявно с помощью кода ={$_REQUEST["GID"]}.
Шаблоны ссылок
Страница просмотра форумов группы | URL_TEMPLATES_FORUMS | Указывается адрес страницы просмотра списка форумов некоторой группы.
Страница списка тем | URL_TEMPLATES_LIST | Указывается адрес страницы со списком тем форума. По умолчанию поле содержит list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Темы (список).
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#.
Страница чтения сообщения | URL_TEMPLATES_MESSAGE | Указывается адрес страницы просмотра сообщения форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#.
Страница профиля пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Страница скрытых сообщений | URL_TEMPLATES_MESSAGE_APPR | Указывается адрес страницы с неодобренными сообщениями форума. По умолчанию поле содержит message_appr.php?FID=#FID#. Такая страница может быть создана с помощью компонента Сообщения (проверка).
Страница RSS | URL_TEMPLATES_RSS | Указывается адрес страницы RSS форума.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Количество форумов на одной странице | FORUMS_PER_PAGE | Указывается количество форумов, отображаемых на одной странице. Все форумы будут выведены с помощью постраничной навигации.
Название шаблона для вывода постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Задается название шаблона для вывода постраничной навигации. Если поле пусто, то используется шаблон по умолчанию.
Количество страниц в постраничной навигации | PAGE_NAVIGATION_WINDOW | Задается количество отображаемых в навигации ссылок на страницы. Если количество страниц превышает заданное число, то в навигацию будет добавлено многоточие.
Форум | FID | Указываются форумы, которые будут отображены в списке. Если не выбран ни один форум, то будут показаны все форумы.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Длина слова | WORD_LENGTH | Задается максимально допустимая длина словообразующих символов, следующих друг за другом. Если длина слова превысит указанное число, то символы слова будут разбавлены разрывами (при просмотре сообщений разрывы не отображаются).
Показывать навигацию (хлебные крошки) | SET_NAVIGATION | [Y|N] При отмеченной опции в навигационной цепочке будет отражен переход на страницу списка тем форума.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Форумы.
Дополнительный маркер для новых сообщений | TMPLT_SHOW_ADDITIONAL_MARKER | Задается текст надписи, отображаемый рядом с темой, в которой есть непрочитанные вами сообщения.
Показывать RSS | SHOW_RSS | [Y|N] При отмеченной опции на странице будет отображаться ссылка на RSS.
Настройки администратора
Отображать администратору выбранные форумы | SHOW_FORUMS_LIST | [Y|N] При отмеченной опции администратору будут показаны только те форумы, которые указаны в параметре FID.
Показывать администратору форумы других сайтов | SHOW_FORUM_ANOTHER_SITE | [Y|N] При отмеченной опции администратору будут показаны форумы других сайтов.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:forum.index","",Array(
        "TMPLT_SHOW_ADDITIONAL_MARKER" => "",
        "SHOW_RSS" => "Y",
        "URL_TEMPLATES_FORUMS" => "forums.php?GID=#GID#",
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "URL_TEMPLATES_READ" => "read.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_MESSAGE" => "read.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#",
        "URL_TEMPLATES_MESSAGE_APPR" => "message_appr.php?FID=#FID#&TID=#TID#",
        "URL_TEMPLATES_RSS" => "rss.php?TYPE=#TYPE#&MODE=#MODE#&IID=#IID#",
        "GID" => $_REQUEST["GID"],
        "FORUMS_PER_PAGE" => "10",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "PAGE_NAVIGATION_WINDOW" => "",
        "FID" => Array(),
        "DATE_FORMAT" => "d.m.Y",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "WORD_LENGTH" => "50",
        "SHOW_FORUMS_LIST" => "Y",
        "SHOW_FORUM_ANOTHER_SITE" => "Y",
        "SET_NAVIGATION" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "0"
    ),
);?>


Шаблоны

Компонент представляет собой сборник js-библиотек служебных шаблонов, которые часто используются в компонентах.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Например, с помощью одной из таких библиотек прорисовывается выпадающее меню со списком форумов:

<?$APPLICATION->IncludeComponent("bitrix:forum.interface","popup",
    array("DATA" => $arResult["popup"]["forums"]), $component,
    array("HIDE_ICONS" => "Y")
);?>


RSS форума

Описание bitrix:forum.rss

Компонент служит для экспорта RSS форума в указанном формате. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Форум.

Компонент относится к модулю Форум.

Компонент поддерживает два режима настройки: простой и расширенный. Расширенный предоставляет более обширные средства настройки.

Параметры

Поле | Параметр | Описание
Основные параметры
Формат RSS TYPE_RANGE Указываются форматы экспорта данных форума, которые необходимо отобразить:
  • RSS 0.92 (RSS1)
  • RSS 2.0 (RSS2)
  • Atom 0.3 (ATOM)
Разрешить RSS на форумах | FID_RANGE | Указываются форумы, для которых будет разрешен экспорт RSS в указанном формате.
ID | IID | Задается код, в котором передается идентификатор форума. Значение по умолчанию: $_REQUEST["IID"].
Вид компонента | MODE_TEMPLATE | В публичной части компонент будет представлен в виде RSS-ленты в указанном формате (rss).
Тип RSS | TYPE | Указывается диапазон поддерживаемых форматов RSS.
Шаблоны ссылок
Страница RSS | URL_TEMPLATES_RSS | Указывается адрес страницы RSS форума.
Страница списка тем | URL_TEMPLATES_LIST | Указывается адрес страницы со списком тем форума. По умолчанию поле содержит list.php?FID=#FID#. Такая страница может быть создана с помощью компонента Темы (список).
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума. По умолчанию поле содержит read.php?FID=#FID#&TID=#TID#&MID=#MID#. Такая страница может быть создана с помощью компонента Тема (чтение).
Страница профиля | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы просмотра профиля пользователя. По умолчанию поле содержит profile_view.php?UID=#UID#. Такая страница может быть создана с помощью компонента Пользователь (профиль).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Количество элементов для экспорта | COUNT | Указывается количество элементов для экспорта.
Размер рисунка для отображения на странице | MAX_FILE_SIZE | Указывается размер рисунка для отображения на странице в Мб.
Шаблон подписи для ленты RSS, если не задан ни один форум | TEMPLATES_TITLE_FORUMS | Подпись, которая будет выводиться, если не задан форум. При пустом поле ввода: #SITE_NAME# [форум] Вы можете использовать след. переменные: #FORUM_TITLE#, #FORUM_DESCRIPTION#, #TOPIC_TITLE#, #TOPIC_DESCRIPTION#, #SITE_NAME#, #SERVER_NAME#.
Шаблон подписи для ленты RSS, если задан форум | TEMPLATES_TITLE_FORUM | Подпись, которая будет выводиться, если задан форум. При пустом поле ввода: #SITE_NAME# [форум: #FORUM_TITLE#] Вы можете использовать след. переменные: #FORUM_TITLE#, #FORUM_DESCRIPTION#, #TOPIC_TITLE#, #TOPIC_DESCRIPTION#, #SITE_NAME#, #SERVER_NAME#.
Шаблон подписи для ленты RSS, если задана тема | TEMPLATES_TITLE_TOPIC | Подпись, которая будет выводиться, если задана тема форума для RSS. При пустом поле ввода: #SITE_NAME# [тема: #TOPIC_TITLE#] Вы можете использовать след. переменные: #FORUM_TITLE#, #FORUM_DESCRIPTION#, #TOPIC_TITLE#, #TOPIC_DESCRIPTION#, #SITE_NAME#, #SERVER_NAME#.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:forum.rss",
    "",
    Array(
        "TYPE_RANGE" => Array("RSS1", "RSS2", "ATOM"),
        "FID_RANGE" => Array("8"),
        "IID" => $_REQUEST["IID"],
        "MODE" => "link",
        "URL_TEMPLATES_RSS" => "rss.php?TYPE=#TYPE#&MODE=#MODE#&IID=#IID#",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "TYPE" => $_REQUEST["TYPE"],
        "COUNT" => "30",
        "MAX_FILE_SIZE" => "5",
        "TEMPLATES_TITLE_FORUMS" => "",
        "TEMPLATES_TITLE_FORUM" => "",
        "TEMPLATES_TITLE_TOPIC" => "",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "URL_TEMPLATES_LIST" => "list.php?FID=#FID#",
        "URL_TEMPLATES_READ" => "message.php?FID=#FID#&TID=#TID#&MID=#MID#",
        "URL_TEMPLATES_PROFILE_VIEW" => "profile_view.php?UID=#UID#"
    ),
false
);?>


Магазин

Подразделы
Название | Имя в пространстве имен bitrix | Описание
Аффилиаты | sale.affiliate |
Корзина | sale.basket | Предназначен для работы с корзинами товаров покупателя.
Процедура заказа | sale | Служит для построения процедуры оформления заказа.
Рекомендуемые товары | catalog.show.products | Подраздел содержит компоненты, которые выводят список товаров, рекомендуемых к покупке вместе выбранным товаром.
Список профилей текущего пользователя | sale.personal | Позволяет работать с персональным разделом пользователя.
Экспорт заказов | sale.export | Предназначен для экспорта заказов в "1С:Предприятие".
Информация о товарах | sale.export | Служит для организации работы с товарами.
Склады | catalog.store | Предназначен для работы со складами


Аффилиаты

Подраздел содержит следующие компоненты для работы с аффилиатами:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Аффилиатские планы | sale.affiliate.plans | Выводит список всех аффилиатских планов, определённых в системе.
Отчет аффилиата | sale.affiliate.account | Отображает движение денег на счете аффилиата.
Отчет по программе аффилиата | sale.affiliate.report | Отображает список проданных товаров от авторизованного аффилиата за установленный период времени.
Регистрация аффилиата | sale.affiliate.register | Служит для создания страницы регистрации аффилиата.
Технические инструкции аффилиата | sale.affiliate.instructions | Служит для вывода технических инструкций для аффилиата.


Аффилиатские планы

Одностраничный компонент выводит список всех аффилиатских планов, определённых в системе.

Описание sale.affiliate.plans

Компонент может использоваться на странице регистрации аффилиата для показа имеющихся планов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Аффилиаты > Аффилиатские планы.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Планы комиссий аффилиатов.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.affiliate.plans","",Array(
        "SET_TITLE" => "Y"
    ),
);?>


Отчет аффилиата

Одностраничный компонент отображает движение денег на счете аффилиата.

Описание sale.affiliate.account

Компонент стандартный и входит в дистрибутив модуля.

Если аффилиат авторизован на сайте, то ему будет показано движение денег на его счете за установленный период времени. Если авторизован пользователь, не являющийся аффилиатом, то компонент переведет его на страницу регистрации аффилиата, указанную в настройках компонента. Если пользователь не авторизован, то он будет перенаправлен на страницу регистрации аффилиата.

В визуальном редакторе компонент расположен по пути: Магазин > Аффилиаты > Отчет аффилиата.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Страница регистрации | REGISTER_PAGE | Указывается путь к странице регистрации аффилиата. Она может быть создана с помощью компонента Регистрация аффилиата. Если страница находится в текущей директории, то достаточно указать ее название.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Планы комиссий аффилиатов.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.affiliate.account","",Array(
        "REGISTER_PAGE" => "register.php",
        "SET_TITLE" => "Y"
    ),
);?>


Отчет по программе аффилиата

Одностраничный компонент, отображающий список проданных товаров от авторизованного аффилиата за установленный период времени.

Описание sale.affiliate.report

Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Аффилиаты > Отчет по программе аффилиата.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Страница регистрации | REGISTER_PAGE | Указывается путь к странице регистрации аффилиата. Она может быть создана с помощью компонента Регистрация аффилиата. Если страница находится в текущей директории, то достаточно указать ее название.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Отчет по программе.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.affiliate.report","",Array(
        "REGISTER_PAGE" => "register.php",
        "SET_TITLE" => "Y"
    ),
);?>


Регистрация аффилиата

Компонент является одностраничным и служит для создания страницы регистрации аффилиата.

Описание sale.affiliate.register

Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Аффилиаты > Регистрация аффилиата.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Путь к файлу с пользовательским соглашением | AGREEMENT_TEXT_FILE | Указывается путь к файлу с пользовательским соглашением.
Согласие пользователя
Запрашивать согласие | USER_CONSENT | [Y|N] Установленный флажок включает механизм согласия пользователя.
Соглашение | USER_CONSENT_ID | Задается текст соглашения, которое отображается пользователю при заказе.
Галка по умолчанию проставлена | USER_CONSENT_IS_CHECKED | Установка галочки автомаитчески устанавливает галочку в чекбоксе согласия пользователя. То есть согласие применяется одновременно с нажатием кнопки Оформить заказ.
Загружать текст сразу | USER_CONSENT_IS_LOADED | Текст соглашения будет выводиться сразу. Если флажок не установлен, для просмотра текст нужно будет кликнуть по кнопке согласия.
Дополнительные настройки
Страница для перехода после регистрации | REDIRECT_PAGE | Указывается путь к странице, на которую будет переведен пользователь после регистрации. Этот адрес не должен совпадать с адресом страницы, на которой расположен компонент. В противном случае будет зацикливание.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Регистрация аффилиата.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.affiliate.register",
    "",
    Array(
        "AGREEMENT_TEXT_FILE" => "",
        "REDIRECT_PAGE" => $_REQUEST["REDIRECT_PAGE"],
        "SET_TITLE" => "Y",
        "USER_CONSENT" => "Y",
        "USER_CONSENT_ID" => "1",
        "USER_CONSENT_IS_CHECKED" => "Y",
        "USER_CONSENT_IS_LOADED" => "N"
    )
);?>


Технические инструкции аффилиата

Компонент является одностраничным и служит для вывода технических инструкций для аффилиата.

Описание sale.affiliate.instructions

Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Аффилиаты > Технические инструкции аффилиата.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Страница регистрации | REGISTER_PAGE | Указывается путь к странице, которая будет предложена пользователю, если он не авторизован.
Путь для формирования ссылки на регистрацию аффилиата | AFF_REG_PAGE | Указывается путь для формирования ссылки на регистрацию аффилиата. Этот путь будет подставлен в текст инструкции для аффилиата. Сформированной ссылкой может воспользоваться пользователь, который захочет стать аффилиатом магазина.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Технические инструкции.
Основные параметры
Название сайта (если не указано, берется из настроек сайта) | SHOP_NAME | Указывается название сайта, которое будет подставлено в инструкцию аффилиата (если не указано, берется из настроек сайта).
Адрес сайта (без http://; если не указан, берется из настроек сайта) | SHOP_URL | Указывается адрес сайта, на котором организуется аффилиатство (без http://; если не указан, берется из настроек сайта).

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.affiliate.instructions","",Array(
        "REGISTER_PAGE" => "register.php",
        "SHOP_NAME" => "",
        "SHOP_URL" => "",
        "AFF_REG_PAGE" => "/affiliate/register.php",
        "SET_TITLE" => "Y"
    ),
);?>


Корзина

Подраздел предназначен для работы с корзинами товаров покупателя. Содержит следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Корзина | sale.basket.basket | Отображает список товаров, отправленных пользователем в корзину.
Ссылка на корзину | sale.basket.basket.line | В зависимости от настроек отображает ссылки на корзину пользователя и на его персональный раздел либо только на корзину.
Малая корзина для почты | sale.basket.basket.small.mail | Отображает для почты список товаров, находящихся в корзине пользователя.


Корзина

Одностраничный компонент отображает список товаров, отправленных пользователем в корзину.

Описание sale.basket.basket

Одностраничный компонент отображает список товаров, отправленных пользователем в корзину.Товары в корзине могут быть отложены и будут храниться, либо удалены из корзины, также пользователь может перейти к оформлению заказа. Компонент стандартный и входит в дистрибутив модуля.

С версии 18.1.0 модуля Интернет-магазин в составе шаблона .default доступна новая страница empty.php. Теперь при переходе в пустую корзину будет отображаться содержимое страницы empty.php вместо стандартной надписи "Корзина пуста". Кастомизируя шаблон, можно настроить собственное описание пустой корзины.

В визуальном редакторе компонент расположен по пути: Магазин > Корзина > Корзина.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Использовать механизм отложенной актуализации данных товаров с провайдером | DEFERRED_REFRESH | [Y|N] При выборе данной опции запрос актуализации данных о товаре (цены, наличие и др. из каталога) будет отправляться в фоновом режиме после отображения основной информации о товарах. Таким образом, получается выигрыш по времени для более быстрого отображения страницы.
Использовать динамическую подгрузку товаров | USE_DYNAMIC_SCROLL | [Y|N] При динамической подгрузке изначально отображаются первые 30 позиций в корзине, а последующие появляются при прокручивании страницы. Данная опция эффективна для магазинов с большими корзинами (с количеством позиций выше 30).
Отображать фильтр товаров | SHOW_FILTER | [Y|N] Опция отвечает за подключение фильтра, с помощью которого можно искать товары в корзине по наименованию, свойствам и другим параметрам товара. Данная опция эффективна для магазинов с большими корзинами.
Разрешить восстановление удалённых товаров | SHOW_RESTORE | [Y|N] Предоставляется возможность восстановить только что удаленный товар в корзине без перехода в каталог.
Внешний вид
Выводимые колонки | COLUMNS_LIST | Задаются поля, которые будут выведены в качестве названий колонок в таблице товаров, находящихся в корзине.
Колонки, отображаемые на мобильных устройствах | COLUMNS_LIST_MOBILE | Выбираются элементы корзины, которые будут отображаться в мобильной версии сайта.
Цветовая тема | TEMPLATE_THEME | Указывается цветовая тема для отображения списка товаров корзины.
Отображение блока с общей информацией по корзине TOTAL_BLOCK_DISPLAY Указывается один из двух способов отображения положение блока с с полем ввода номера купона, общей стоимостью заказа и кнопками его оформления.
Доступные способы отображения:
  • Над корзиной
  • Под корзиной
Режим отображения корзины | DISPLAY_MODE | Задается режим отображения корзины: «Расширенный» или «Компактный».
Отображать цену в отдельной колонке | PRICE_DISPLAY_MODE | [Y|N] Цена за 1 единицу товара будет отображаться в отдельной колонке.
Показывать процент скидки рядом с изображением SHOW_DISCOUNT_PERCENT [Y|N] Выводить рядом с изображением товара стикер с размером действующей скидки. Расположение стикера можно задать в [dw]дополнительном поле.[/dw][di]
Расположение процента скидки DISCOUNT_PERCENT_POSITION Задается место расположения стикера на изображении: по центру, справа, слева или внизу.
[/di]
Порядок отображения блоков товара | PRODUCT_BLOCKS_ORDER | Указывается порядок отображения блоков товара. Для изменения положение блока товара ухватите его в конструкторе левой кнопкой мыши и сместите вверх или вниз на нужную позицию.
Использовать анимацию цен | USE_PRICE_ANIMATION | [Y|N] Если опция включена, то при изменении количества товара в корзине цена по виду товара и общая стоимость заказа быстро «прокручиваются» до нужного значения (как на спидометре). Если опция отключена, суммы изменяются моментально без визуальных эффектов.
Свойства меток товара | LABEL_PROP | Указывается, какие метки товара (стикеры) будут отображаться на странице.
Дополнительные настройки
Страница оформления заказа | PATH_TO_ORDER | Задается путь к странице c процедурой оформления заказа. Если страница находится в текущей директории, то достаточно указать ее название.
Спрятать поле ввода купона | HIDE_COUPON | [Y|N] На странице с корзиной товаров станет скрытым поле для ввода купона на скидку .
Отображать значение НДС | PRICE_VAT_SHOW_VALUE | [Y|N] При отмеченной опции будет показано значение НДС для товара.
Использовать предавторизацию для оформления заказа (PayPal Express Checkout) | USE_PREPAYMENT | [Y|N] Станет доступной к использованию оптимизированная версия ExpressCheckout Shortcut, когда система Paypal автоматически отображает информацию клиента для выполнения заказа.
Использовать дробное значение количества | QUANTITY_FLOAT | [Y|N] Возможность использования дробного количества товара.
Автоматически рассчитывать количество товара кратное коэффициенту | CORRECT_RATIO | [Y|N] Будет выводиться количество товара, кратное заданному коэффициенту (опция удобна при оптовых продажах).
Автопересчет корзины | AUTO_CALCULATION | [Y|N] Корзина станет пересчитываться автоматически.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] В качестве заголовка страницы будет установлено Моя корзина.
Название переменной действия | ACTION_VARIABLE | Указывается имя переменной, в которой передается действие. Значение поля по умолчанию action. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Включить режим совместимости | COMPATIBLE_MODE | Включение режима совместимости старых шаблонов с новыми версиями модуля.
Путь к странице для продолжения покупок | EMPTY_BASKET_HINT_PATH | Относительно корня сайта указывается путь к странице, на которую должен перенаправляться пользователь для продолжения покупок.
Настройка торговых предложений
Свойства, влияющие на пересчет корзины | OFFERS_PROPS | Указываются свойства торговых предложений, которые должны отображаться в корзине и влияют на пересчет корзины.
Настройки изображений
Дополнительная картинка | ADDITIONAL_PICT_PROP_2 | Добавление в корзину изображения из дополнительной фотогалереи товара.
Дополнительная картинка (предложения) | ADDITIONAL_PICT_PROP_3 | Добавление в корзину изображения из торгового предложения.
Режим отображения изображений товаров BASKET_IMAGES_SCALING Определение размера основного фото товара. Доступные режимы:
  • Стандартный — маленькое фото
  • Адаптивный — фото среднего размера
  • Без сжатия — фото максимального размера
Настройки "Подарков"
Показывать блок "Подарки" | USE_GIFTS | [Y|N] При отмеченной опции будет отображаться блок с доступными подарками.
Вывод блока "Подарки" | GIFTS_PLACE | Выбирается способ отображения блока с подарками: над или под корзиной.
Текст заголовка "Подарки" | GIFTS_BLOCK_TITLE | Указывается текст заголовка блока с подарками.
Скрыть заголовок "Подарки" | GIFTS_HIDE_BLOCK_TITLE | [Y|N] При отмеченной опции заголовок блока подарков будет скрыт.
Текст метки "Подарка" | GIFTS_TEXT_LABEL_GIFT | Указывается текст метки, которая проставляется для подарка.
Название переменной, в которой передается количество товара | GIFTS_PRODUCT_QUANTITY_VARIABLE | Задается имя переменной, в которой будет передаваться количество товара.
Название переменной, в которой передаются характеристики товара | GIFTS_PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Показывать старую цену | GIFTS_SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Показывать процент скидки | GIFTS_SHOW_DISCOUNT_PERCENT | [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана.
Показывать название | GIFTS_SHOW_NAME | [Y|N] При отмеченной опции будет отображено название элемента.
Показывать изображение | GIFTS_SHOW_IMAGE | [Y|N] При отмеченной опции будет показано изображение элемента.
Текст кнопки "Выбрать" | GIFTS_MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Выбрать".
Текст кнопки "Подробнее" | GIFTS_MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Количество элементов на странице | GIFTS_PAGE_ELEMENT_COUNT | Указывается количество элементов, отображаемых на одной странице.
Показывать цены в одной валюте | GIFTS_CONVERT_CURRENCY | При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах.
Не отображать товары, которых нет на складах | HIDE_NOT_AVAILABLE | [Y|N] При отмеченной опции будут скрыты товары, для которых общее доступное количество меньше либо равно нулю (не остатки по складам), включен количественный учет и не разрешена покупка при отсутствии товара.
Настройки аналитики
Отправлять данные электронной торговли в Google и Яндекс USE_ENHANCED_ECOMMERCE [Y|N] Включение опции. После включения станут доступны ещё [dw]два поля[/dw][di]
Имя контейнера данных | DATA_LAYER_NAME | Указываются свойства инфоблока, которые будут отображены в списке просмотренных товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Свойство брендов | BRAND_PROPERTY | Указывается свойство инфоблока, откуда система должна брать название бренда товара (производитель, марка, модель и т.п.).
[/di]. Требуется дополнительная настройка в Google Analytics Enhanced Ecommerce [image] и/или Яндекс.Метрике [image].

Примечание: Настройка Яндекс метрикой не сложна, и данные в ней отображаются довольно быстро (полчаса-час). У Google используется Google Tag Manager с плагином электронной коммерции, его нужно настроить и добавить на страницу в шаблоне. После настройки на "той" стороне, нужно настроить компоненты для работы с электронной коммерцией и включить это поле настройки.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.basket.basket",
    "",
    Array(
        "ACTION_VARIABLE" => "action",
        "AUTO_CALCULATION" => "Y",
        "TEMPLATE_THEME" => "blue",
        "COLUMNS_LIST" => array("NAME","DISCOUNT","WEIGHT","DELETE","DELAY","TYPE","PRICE","QUANTITY"),
        "COMPONENT_TEMPLATE" => ".default",
        "GIFTS_BLOCK_TITLE" => "Выберите один из подарков",
        "GIFTS_CONVERT_CURRENCY" => "Y",
        "GIFTS_HIDE_BLOCK_TITLE" => "N",
        "GIFTS_HIDE_NOT_AVAILABLE" => "N",
        "GIFTS_MESS_BTN_BUY" => "Выбрать",
        "GIFTS_MESS_BTN_DETAIL" => "Подробнее",
        "GIFTS_PAGE_ELEMENT_COUNT" => "4",
        "GIFTS_PRODUCT_PROPS_VARIABLE" => "prop",
        "GIFTS_PRODUCT_QUANTITY_VARIABLE" => "",
        "GIFTS_SHOW_DISCOUNT_PERCENT" => "Y",
        "GIFTS_SHOW_IMAGE" => "Y",
        "GIFTS_SHOW_NAME" => "Y",
        "GIFTS_SHOW_OLD_PRICE" => "Y",
        "GIFTS_TEXT_LABEL_GIFT" => "Подарок",
        "GIFTS_PLACE" => "BOTTOM",
        "HIDE_COUPON" => "N",
        "OFFERS_PROPS" => array("SIZES_SHOES","SIZES_CLOTHES"),
        "PATH_TO_ORDER" => "/personal/order.php",
        "PRICE_VAT_SHOW_VALUE" => "N",
        "QUANTITY_FLOAT" => "N",
        "SET_TITLE" => "Y",
        "USE_GIFTS" => "Y",
        "USE_PREPAYMENT" => "N"
    )
);?>


Малая корзина для почты

Описание sale.basket.basket.small.mail

Одностраничный компонент отображает для почты список товаров, находящихся в корзине пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Корзина > Малая корзина для почты.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Внешний вид
Выводимые колонки | COLUMNS_LIST | Выбираются поля, которые будут выведены в списке товаров, находящихся в корзине.
Дополнительные настройки
Код пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя.
Страница корзины | PATH_TO_BASKET | Указывается путь к странице с корзиной. Если страница находится в текущей директории, то достаточно указать ее название. Такая страница может быть создана с помощью компонента Корзина.
Страница оформления заказа | PATH_TO_ORDER | Указывается путь к странице c процедурой оформления заказа. Если страница находится в текущей директории, то достаточно указать ее название. Такая страница может быть создана с помощью компонента Процедура оформления заказа.
Показывать отложенные товары | SHOW_DELAY | [Y|N] При отмеченной опции в корзине будут отображаться отложенные товары.
Показывать товары, недоступные для покупки | SHOW_NOTAVAIL | [Y|N] При отмеченной опции будут отображаться товары, недоступные для покупки.
Показывать товары, на которые подписан покупатель | SHOW_SUBSCRIBE | [Y|N] При отмеченной опции дополнительно будут показаны товары, на которые подписан покупатель.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.basket.basket.small.mail",
    "",
    Array(
        "COMPONENT_TEMPLATE" => ".default",
        "COLUMNS_LIST" => array("NAME","DISCOUNT_FORMATED","WEIGHT_FORMATED","PRICE_FORMATED","QUANTITY_FORMATED"),
        "USER_ID" => "{#USER_ID#}",
        "PATH_TO_BASKET" => "/personal/basket.php",
        "PATH_TO_ORDER" => "/personal/order.php",
        "SHOW_DELAY" => "Y",
        "SHOW_NOTAVAIL" => "Y",
        "SHOW_SUBSCRIBE" => "Y"
    )
);?>


Ссылка на корзину

Одностраничный компонент, который отображает специальный блок корзины с набором в зависимости от настроек самого компонента информации.

Описание sale.basket.basket.line

Компонент стандартный и входит в дистрибутив модуля. Поставляется с тремя шаблонами: .default_old, .default и bootstrap_v4.

В визуальном редакторе компонент расположен по пути: Магазин > Корзина > Ссылка на корзину.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Страница корзины | PATH_TO_BASKET | Указывается путь к странице с корзиной. Если страница находится в текущей директории, то достаточно указать ее название. Такая страница может быть создана с помощью компонента Корзина.
Страница оформления заказа | PATH_TO_ORDER | Указывается путь к странице оформления заказа. Если страница находится в текущей директории, то достаточно указать ее название.
Показывать количество товаров | SHOW_NUM_PRODUCTS | [Y|N] При отмеченной опции будет показано общее количество товара.
Показывать общую сумму по товару | SHOW_TOTAL_PRICE | [Y|N] При отмеченной опции будет выведена общая сумма по стоимости товаров, находящихся в корзине.
Выводить нулевые значения в пустой корзине | SHOW_EMPTY_VALUES | [Y|N] При отмеченной опции в пустой корзине будут выводится нулевые значения.
Персональный раздел
Отображать персональный раздел | SHOW_PERSONAL_LINK | [Y|N] При отмеченной опции будет выведена ссылка на персональный раздел.
Страница персонального раздела | PATH_TO_PERSONAL | Указывается путь к персональному разделу, где начальной страницей может быть список заказов, профили пользователя и т.д.
Авторизация
Добавить возможность авторизации SHOW_AUTHOR [Y|N] При отмеченной опции будет доступна ссылка для авторизации на сайте; станут активны [dw]дополнительные поля[/dw][di]
Страница регистрации | PATH_TO_REGISTER | Задается путь к странице регистрации на сайте.
Страница авторизации | PATH_TO_AUTHORIZE | Задается путь к странице авторизации.
Страница профиля | PATH_TO_PROFILE | Указывается путь к странице профиля покупателя.
[/di] .
Список товаров
Показывать список товаров SHOW_PRODUCTS [Y|N] При отмеченной опции в корзине будет выводится список добавленных товаров. Кроме того, становятся доступными [dw]дополнительные параметры[/dw][di]
Показывать отложенные товары | SHOW_DELAY | [Y|N] При отмеченной опции в корзине будут показаны отложенные товары.
Показывать товары, недоступные для покупки | SHOW_NOTAVAIL | [Y|N] При отмеченной опции в корзине будут показаны товары, недоступные в текущий момент для покупки.
Выводить картинку товара | SHOW_IMAGE | [Y|N] При отмеченной опции будет выводится изображение товара.
Выводить цену товара | SHOW_PRICE | [Y|N] При отмеченной опции для товара в корзине будет выведена цена.
Выводить подытог по строке | SHOW_SUMMARY | [Y|N] При отмеченной опции для каждой позиции в корзине будет выводится подытог.
[/di] для показа списка товаров.
Внешний вид
Отображать корзину поверх шаблона POSITION_FIXED [Y|N] При отмеченной опции специальный блок корзины будет отображен поверх других элементов сайта; станут активны [dw]дополнительные окна[/dw][di]
Положение по горизонтали | POSITION_HORIZONTAL | Выбирается положение блока корзины по горизонтали: справа или слева. Параметр доступен, если отмечена опция Отображать корзину поверх шаблона.
Положение по вертикали | POSITION_VERTICAL | Выбирается положение блока корзины по горизонтали: вверху или внизу. Параметр доступен, если отмечена опция Отображать корзину поверх шаблона.
[/di]. В противном случае детальная информация по содержимому корзины будет отображена на странице.
Дополнительные настройки
Не показывать на страницах корзины и оформления заказа | HIDE_ON_BASKET_PAGES | [Y|N] При отмеченной опции компонент на страницах корзины и оформления заказа будет скрыт. Рекомендуется оставлять данную опцию включенной во избежание снижения производительности на этих страницах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.basket.basket.line","",Array(
        "HIDE_ON_BASKET_PAGES" => "Y",
        "PATH_TO_BASKET" => SITE_DIR."personal/cart/",
        "PATH_TO_ORDER" => SITE_DIR."personal/order/make/",
        "PATH_TO_PERSONAL" => SITE_DIR."personal/",
        "PATH_TO_PROFILE" => SITE_DIR."personal/",
        "PATH_TO_REGISTER" => SITE_DIR."login/",
        "POSITION_FIXED" => "Y",
        "POSITION_HORIZONTAL" => "right",
        "POSITION_VERTICAL" => "top",
        "SHOW_AUTHOR" => "Y",
        "SHOW_DELAY" => "N",
        "SHOW_EMPTY_VALUES" => "Y",
        "SHOW_IMAGE" => "Y",
        "SHOW_NOTAVAIL" => "N",
        "SHOW_NUM_PRODUCTS" => "Y",
        "SHOW_PERSONAL_LINK" => "N",
        "SHOW_PRICE" => "Y",
        "SHOW_PRODUCTS" => "Y",
        "SHOW_SUMMARY" => "Y",
        "SHOW_TOTAL_PRICE" => "Y"
    )
);?>


Процедура заказа

Подраздел предназначен для построения процедуры оформления заказа. Содержит следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Калькулятор доставки (AJAX) | sale.ajax.delivery.calculator | Выводит динамический калькулятор доставки.
Оформление заказа | sale.order.ajax | Для оформления заказа на одной странице с использованием технологии AJAX.
[link=63308 ]Подключение обработчика результата платежной системы[/link] | sale.order.payment.receive | Подключает скрипт для получения результата от платежной системы.
Подключение платежной системы | sale.order.payment | Подключает платежную систему.
Привязка к местоположению: выпадающие списки | sale.location.selector.steps | Для выбора местоположения из выпадающего списка.
Привязка к местоположению: строка поиска | sale.location.selector.search | Для выбора местоположения с помощью ввода запроса в строку поиска.
Смена способа оплаты | sale.order.payment.change | Для смены платежной системы для оплаты заказа.


Смена способа оплаты

Описание sale.order.payment.change

Одностраничный компонент осуществляет смену платежной системы для оплаты заказа. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Процедура оформления заказа > Смена способа оплаты.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Страница подключения платежной системы | PATH_TO_PAYMENT | Указывается путь к странице подключения платежной системы.
Устанавливать заголовок страницы | SET_TITLE | При отмеченной опции будет устанавливаться заголовок страницы.
Исключить из списка платежных систем | ELIMINATED_PAY_SYSTEMS | Отмечаются платежные системы, которые необходимо исключить из списка.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.order.payment.change",
    "",
    Array(
        "ELIMINATED_PAY_SYSTEMS" => array("11","14"),
        "PATH_TO_PAYMENT" => "/personal/order/payment",
        "SET_TITLE" => "Y"
    )
);?>


Калькулятор доставки (AJAX)

Описание sale.ajax.delivery.calculator

Одностраничный компонент выводит динамический калькулятор доставки.

В визуальном редакторе компонент расположен по пути: Магазин > Процедура оформления заказа > Калькулятор доставки (AJAX) .

Компонент относится к модулю Интернет-магазин.

Компонент устарел с версии 14.0.0. Работает только со старыми доставками.

Пример вызова

...
<?$APPLICATION->IncludeComponent('bitrix:sale.ajax.delivery.calculator', '', array(
    "NO_AJAX" => $arParams["SHOW_AJAX_DELIVERY_LINK"] == 'S' ? 'Y' : 'N',
    "ORDER_WEIGHT" => $arResult["ORDER_WEIGHT"],
    "ORDER_PRICE" => $arResult["ORDER_PRICE"],
    "LOCATION_TO" => $arResult["DELIVERY_LOCATION"],
    "CURRENCY" => $arResult["BASE_LANG_CURRENCY"],
    "DELIVERY_ID" => 21    //21 - идентификатор службы доставки. Если служба доставки с профилями, то идентификатор конкретного профиля.
    ));
?>
...


Оформление заказа

Компонент служит для оформления заказа на одной странице с использованием технологии AJAX. Компонент является стандартным и входит в дистрибутив модуля.

Описание sale.order.ajax

Пользователь генерируется автоматически и незаметно для клиента. Клиент не получит уведомление о регистрации нового пользователя для него, если в настройках компонента не устанавливать галочку Отправлять пользователю письмо, что он зарегистрирован на сайте. Данный функционал будет работать при условии, что в Главном модуле включена самостоятельная регистрация и отключено подтверждение регистрации по E-mail.

Для регистрации пользователя используется E-mail, который берется из свойства заказа, у которого установлена галочка Использовать как E-Mail. После регистрации пользователь автоматически авторизуется на сайте.

В визуальном редакторе компонент расположен по пути: Магазин > Процедура оформления заказа > Оформление заказа.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Разрешить оплату с внутреннего счета | PAY_FROM_ACCOUNT | [Y|N] При отмеченной опции пользователю будет предложено оплатить заказ с внутреннего счета.
Разрешать оплату с внутреннего счета только в полном объеме | ONLY_FULL_PAY_FROM_ACCOUNT | [Y|N] При отмеченной опции пользователю будет предложено оплатить с внутреннего счета, при условии, что на этом счете есть достаточная сумма в базовой валюте сайта.
Оформлять заказ с автоматической регистрацией пользователя ALLOW_AUTO_REGISTER [Y|N] Если пользователь не зарегистрирован на сайте, то при отмеченной опции он будет автоматически зарегистрирован для оформления заказа. Если флаг с данной опции снят, то при оформлении заказа будет отображена форма регистрации и незарегистрированный пользователь должен будет зарегистрироваться самостоятельно.
Поле работает при условии, что в ядре включена самостоятельная регистрация и отключено подтверждение регистрации по E-mail.

Примечание: если в настройках Главного модуля отмечена хотя бы одна из опций Регистрировать пользователей по номеру телефона или Регистрировать пользователей по email, то при повторном оформлении заказа неавторизованным пользователем заказ будет привязан к уже существующей учётной записи на основании указанного телефонного номера или email. В противном случае ([dw]если ни одна из опций не отмечена[/dw][di] [image] [/di]) при повторном заказе будет создана новая учетная запись.
Разрешить оформлять заказ на существующего пользователя | ALLOW_APPEND_ORDER | [Y|N] Если пользователь с указанным e-mail уже существует, заказ прикрепится к этому пользователю (в настройках Главного модуля должен быть отмечен параметр Проверять email на уникальность при регистрации). При снятой опции будет выдана ошибка регистрации нового пользователя.
Отправлять пользователю письмо, что он зарегистрирован на сайте | SEND_NEW_USER_NOTIFY | [Y|N] При отмеченной опции пользователю будет отправлено письмо о том, что он зарегистрировался на сайте.
Когда рассчитывать доставки с внешними системами расчета DELIVERY_NO_AJAX Выбор момента когда происходит расчёт стоимости с внешними системами:
  • Не рассчитывать - для расчета оценочной стоимости необходимо будет нажать ссылку Рассчитать стоимость.
  • Рассчитать сразу - расчёт будет произведён при оформлении заказа.
  • Учитывать настройки доставки - расчёт будет произведён согласно установкам доставок. (Поле Рассчитывать стоимость сразу.)
Отображение доставок с ошибками расчета SHOW_NOT_CALCULATED_DELIVERIES Выбор отображения доставок с ошибками расчета:
  • Не показывать - не отобразятся в списке доступных доставок;
  • Показывать в конце - отобразятся в конце списка;
  • Показывать в общем списке - отобразятся в общем списке со всеми доставками.

Для сортировки доставок с внешним доступом к сервисам требуется включить параметр Рассчитывать сразу доставки с внешним доступом к сервисам
Проверять сессию при оформлении заказа | DELIVERY_NO_SESSION | [Y|N] При отмеченной опции при оформлении заказа будет произведена проверка текущей сессии пользователя на сайте.
Визуальный вид контрола выбора метоположений | TEMPLATE_LOCATION | Указывается внешний вид для выбора местоположения (строка поиска или пошаговый).
Определять местоположение покупателя по IP-адресу | SPOT_LOCATION_BY_GEOIP | [Y|N] При выборе опции подставляется местоположение покупателя, определённое по IP, в соответствующее поле.
Последовательность оформления | DELIVERY_TO_PAYSYSTEM | Выбирается последовательность выбора пользователем способа оплаты и доставки в форме оформления заказа.
Отображать значение НДС | SHOW_VAT_PRICE | [Y|N] При отмеченной опции будет показываться величина НДС.
Использовать предавторизацию для оформления заказа (PayPal Express Checkout) | USE_PREPAYMENT | При отмеченной опции для оформления заказа будет использована предавторизация.
Режим совместимости для предыдущего шаблона | COMPATIBLE_MODE | [Y|N] При использовании старого шаблона необходимо включить режим совместимости.
Автозаполнение оплаты и доставки по предыдущему заказу | USE_PRELOAD | [Y|N] При отмеченной опции при оформлении заказа будут использоваться данные из предыдущих заказов пользователя.
Разрешить использование профилей покупателей | ALLOW_USER_PROFILES | [Y|N] При отмеченной опции будет доступно использование профилей покупателей.
Внешний вид
Цветовая тема | TEMPLATE_THEME | Указывается цветовая тема, которая будет использоваться для интерфейса оформления заказа.
Отображать кнопку оформления заказа (для неавторизованных пользователей) | SHOW_ORDER_BUTTON | Выбирается вариант отображения кнопки оформления заказа для неавторизованных пользователей: всегда или только на последнем шаге.
Отображать дополнительную кнопку оформления заказа | SHOW_TOTAL_ORDER_BUTTON | [Y|N] При отмеченной опции будет отображаться дополнительная кнопка оформления заказа.
Отображать названия в списке платежных систем | SHOW_PAY_SYSTEM_LIST_NAMES | [Y|N] При отмеченной опции в списке будут отображаться названия платежных систем.
Отображать название в блоке информации по платежной системе | SHOW_PAY_SYSTEM_INFO_NAME | [Y|N] При отмеченной опции в блоке с информацией по платежной системе будет отображаться ее название.
Отображать названия в списке доставок | SHOW_DELIVERY_LIST_NAMES | [Y|N] При отмеченной опции в списке будут отображаться названия служб доставок.
Отображать название в блоке информации по доставке | SHOW_DELIVERY_INFO_NAME | [Y|N] При отмеченной опции в блоке с информацией по службе доставки будет отображаться ее название.
Показывать название родительской доставки | SHOW_DELIVERY_PARENT_NAMES | [Y|N] При отмеченной опции будет отображаться название родительской доставки.
Показывать изображения складов в окне выбора пункта выдачи | SHOW_STORES_IMAGES | [Y|N] При отмеченной опции будут показаны изображения складов в окне пункта выдачи.
Пропускать шаги, в которых один элемент для выбора | SKIP_USELESS_BLOCK | [Y|N] При отмеченной опции будет пропускаться тот блок, в котором только один вариант для выбора, и осуществляться переход к следующему после него.
Расположение списка товаров | BASKET_POSITION | Выбирается вариант отображения списка товаров: в начале или в конце.
Показывать заголовки колонок списка товаров | SHOW_BASKET_HEADERS | [Y|N] При отмеченной опции будут отображаться заголовки колонок списка товаров.
Дополнительные услуги, которые будут показаны в пройденном (свернутом) блоке | DELIVERY_FADE_EXTRA_SERVICES | [Y|N] При отмеченной опции выбранные покупателем дополнительные услуги будут отображаться в уже пройденном (свернутом) блоке.
Показывать ближайшие пункты самовывоза | SHOW_NEAREST_PICKUP | [Y|N] При отмеченной опции покупателю будут показаны ближайшие пункты самовывоза.
Количество доставок на странице | DELIVERIES_PER_PAGE | Задается количество доставок, отображаемых на одной странице.
Количество платежных систем на странице | PAY_SYSTEMS_PER_PAGE | Задается количество платежных систем, отображаемых на одной странице.
Количество пунктов самовывоза на странице | PICKUPS_PER_PAGE | Задается количество пунктов самовывоза, отображаемых на одной странице.
Показывать карту для доставок с самовывозом | SHOW_PICKUP_MAP | Опция, отвечающая за отображение карты с пунктами самовывоза.
Показывать карту в блоке свойств заказа | SHOW_MAP_IN_PROPS | При отмеченной опции в блоке свойств заказа (по умолчанию блок называется "Покупатель") будет отображаться карта, если покупатель выбрал одну из отмеченных в нижеследующем параметре доставок.
Показывать карту для выбранных служб доставки | SHOW_MAP_FOR_DELIVERIES | Выбираются доставки, для которых необходимо показывать карту. Параметр доступен, если отмечена опция Показывать карту в блоке свойств заказа.
Тип используемых карт | PICKUP_MAP_TYPE | Выбираются тип карт: Яндекс или Google.
Отображать поля ввода купонов SHOW_COUPONS [Y|N] При отмеченной опции станут доступны дополнительные [dw]настройки показа полей ввода купонов[/dw][di]
Поле | Параметр | Описание
Показывать поле ввода купонов в блоке списка товаров | SHOW_COUPONS_BASKET | [Y|N] При отмеченной опции в списке товаров будет отображаться поле ввода купонов.
Показывать поле ввода купонов в блоке доставки | SHOW_COUPONS_DELIVERY | [Y|N] При отмеченной опции в блоке доставки будет отображаться поле ввода купонов.
Показывать поле ввода купонов в блоке оплаты | SHOW_COUPONS_PAY_SYSTEM | [Y|N] При отмеченной опции в блоке оплаты будет отображаться поле ввода купонов.
[/di] в блоках формы.
Свойства заказа, которые будут показаны в пройденном (свернутом) блоке (название_типа_плательщика) | PROPS_FADE_LIST_N | Выбираются свойства, которые должны отображаться в свернутом блоке со свойствами заказа (по умолчанию блок называется "Покупатель").
Согласие пользователя
Запрашивать согласие | USER_CONSENT | [Y|N] Установленный флажок включает механизм согласия пользователя.
Соглашение | USER_CONSENT_ID | Задается текст соглашения, которое отображается пользователю при заказе.
Галка по умолчанию проставлена | USER_CONSENT_IS_CHECKED | Установка галочки автоматически устанавливает галочку в чекбоксе согласия пользователя. То есть согласие применяется одновременно с нажатием кнопки Оформить заказ.
Загружать текст сразу | USER_CONSENT_IS_LOADED | Текст соглашения будет выводиться сразу. Если флажок не установлен, для просмотра текст нужно будет кликнуть по кнопке согласия.
Дополнительные настройки
Название переменной, в которой передается действие | ACTION_VARIABLE | В данном поле указывается имя переменной, в которой передается действие: processOrder, showOrder и другие. Значение поля по умолчанию - action.
Путь к странице корзины | PATH_TO_BASKET | Указывается путь к странице с корзиной от корня сайта. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Корзина.
Путь к странице персонального раздела | PATH_TO_PERSONAL | Указывается путь к странице персонального раздела, например, к странице со списком заказов либо к пластиковым картам пользователя и т.д. Переход на страницу возможен по ссылке после оформления заказа.
Страница подключения платежной системы | PATH_TO_PAYMENT | Указывается путь к странице подключения платежной системы. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Подключение платежной системы.
Путь к странице авторизации | PATH_TO_AUTH | Указывается путь к странице авторизации пользователя от корня сайта.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Оформление заказа.
Оставаться на странице оформления заказа, если список товаров пуст | DISABLE_BASKET_REDIRECT | [Y|N] При отмеченной опции будет отображаться страница оформления заказа, даже если корзина пуста. В случае неотмеченной опции и пустой корзины будет выполняться переадресация на страницу с корзиной пользователя.
Использовать нормализацию номера телефона | USE_PHONE_NORMALIZATION | [Y|N] При отмеченной опции производится нормализация номера телефона (с +7 (999) 999-00-00 в 79999990000).
Выбранные колонки таблицы списка товаров | PRODUCT_COLUMNS_VISIBLE | Выбираются поля, которые будут выведены в качестве колонок в таблице товаров заказа.
Дополнительная картинка [название_каталога] | ADDITIONAL_PICT_PROP_идентификатор_каталога | Указывается свойство, в котором хранится дополнительная картинка товара.
Режим отображения изображений товаров | BASKET_IMAGES_SCALING | Выбирается режим отображения изображений товаров в списке: стандартный, адаптивный или без сжатия.
Режим отображения вспомогательных изображений | SERVICES_IMAGES_SCALING | Выбирается режим отображения вспомогательных изображений: стандартный, адаптивный или без сжатия.
Свойства товаров отображаемые в свернутом виде в списке товаров | PRODUCT_COLUMNS_HIDDEN | Выбираются свойства, которые будут выведены в свернутом виде в списке товаров.
Скрыть поле комментариев к заказу | HIDE_ORDER_DESCRIPTION | При отмеченной опции поле комментариев к заказу будет скрыто.
Настройки аналитики
Использовать цели счетчика Яндекс.Метрики USE_YM_GOALS [Y|N] При отмеченной опции доступны для использования цели счетчика Яндекс.Метрики. Станут доступны [dw]дополнительные поля.[/dw][di]
Номер счетчика Яндекс.Метрика | YM_GOALS_COUNTER | Код счетчика Яндекс.Метрики.
Идентификатор цели при инициализации компонента на странице | YM_GOALS_INITIALIZE | Указывается идентификатор цели при инициализации компонента на странице. Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Идентификатор цели при редактировании блока региона доставки | YM_GOALS_EDIT_REGION | Указывается идентификатор цели при редактировании блока региона доставки. Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Идентификатор цели при редактировании блока доставки | YM_GOALS_EDIT_DELIVERY | Задается идентификатор цели при редактировании блока доставки. Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Идентификатор цели при редактировании блока пунктов самовывоза | YM_GOALS_NEXT_PICKUP | Задается идентификатор цели при редактировании блока пунктов самовывоза. Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Идентификатор цели при редактировании блока оплаты | YM_GOALS_EDIT_PAY_SYSTEM | Указывается идентификатор цели при редактировании блока оплаты. Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Идентификатор цели при редактировании блока свойств заказа | YM_GOALS_EDIT_PROPERTIES | Задается идентификатор цели при редактировании блока свойств заказа. Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Идентификатор цели при редактировании блока списка товаров | YM_GOALS_EDIT_BASKET | Задается идентификатор цели при редактировании блока списка товаров. Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Идентификатор цели при переходе из блока региона доставки по кнопке "Далее" | YM_GOALS_NEXT_REGION | Указывается идентификатор цели при переходе из блока региона доставки по кнопке "Далее". Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Идентификатор цели при переходе из блока доставки по кнопке "Далее" | YM_GOALS_NEXT_DELIVERY | Указывается идентификатор цели при переходе из блока доставки по кнопке "Далее". Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Идентификатор цели при переходе из блока пунктов самовывоза по кнопке "Далее" | YM_GOALS_NEXT_PICKUP | Указывается идентификатор цели при переходе из блока пунктов самовывоза по кнопке "Далее". Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Идентификатор цели при переходе из блока оплаты по кнопке "Далее" | YM_GOALS_NEXT_PAY_SYSTEM | Задается идентификатор цели при переходе из блока оплаты по кнопке "Далее". Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Идентификатор цели при переходе из блока свойств заказа по кнопке "Далее" | YM_GOALS_NEXT_PROPERTIES | Задается идентификатор цели при переходе из блока свойств заказа по кнопке "Далее". Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Идентификатор цели при переходе из блока списка товаров по кнопке "Далее" | YM_GOALS_NEXT_BASKET | Задается идентификатор цели при переходе из блока списка товаров по кнопке "Далее". Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Идентификатор цели при оформлении заказа | YM_GOALS_SAVE_ORDER | Задается идентификатор цели при оформлении заказа. Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
[/di]

Важно! Счетчик Яндекс.Метрики должен быть подключен на странице.
Для этого необходимо выполнить регистрацию на Яндекс.Метрике, создать счетчик [image] и вставить его код на страницу. Яндекс.цели будут работать только с этим счетчиком.
Отправлять данные электронной торговли в Google и Яндекс USE_ENHANCED_ECOMMERCE [Y|N] Включает возможность отслеживать метрики добавления/удаления/покупки товаров. При выборе данной опции станут доступны [dw]дополнительные поля.[/dw][di]
Имя контейнера данных | DATA_LAYER_NAME | Задается идентификатор цели при оформлении заказа. Поле доступно при включенной опции Использовать цели счетчика Яндекс.Метрики.
Свойство, в котором указан бренд товара | BRAND_PROPERTY | Указывается свойство инфоблока, откуда система должна брать название бренда товара.
[/di]
Основные фразы
Заменить стандартные фразы на свои USE_CUSTOM_MAIN_MESSAGES [Y|N] При отмеченной опции становятся доступными [dw]параметры[/dw][di]
Название блока авторизации | MESS_AUTH_BLOCK_NAME | Задается название для блока авторизации.
Название блока регистрации | MESS_REG_BLOCK_NAME | Задается название блока для регистрации.
Название блока списка товаров | MESS_BASKET_BLOCK_NAME | Указывается название блока для списка товаров в заказе.
Название блока региона доставки | MESS_REGION_BLOCK_NAME | Задается название для блока указания региона доставки.
Название блока оплаты | MESS_PAYMENT_BLOCK_NAME | Задается название блока для выбора способа оплаты заказа.
Название блока доставки | MESS_DELIVERY_BLOCK_NAME | Указывается название блока с информацией о способе доставки.
Название блока свойств заказа | MESS_BUYER_BLOCK_NAME | Задается название блока с информацией о покупателе (поля блока берутся из свойств заказа).
Кнопка возврата к предыдущему блоку | MESS_BACK | Задается название кнопки для вовзрата к предыдущему блоку.
Кнопка перехода к следующему блоку | MESS_FURTHER | Задается название кнопки для перехода с следующему блоку.
Кнопка редактирования блока | MESS_EDIT | Задается название кнопки для изменения параметров в блоке.
Кнопка оформления заказа | MESS_ORDER | Указывается название кнопки для оформления заказа.
Заголовок для цены | MESS_PRICE | Указывается заголовок поля со стоимостью доставки.
Заголовок для срока доставки | MESS_PERIOD | Указывается заголовок для срока доставки.
Кнопка перехода к предыдущей странице | MESS_NAV_BACK | Задается название кнопки для возврата на предыдущую страницу.
Кнопка перехода к следующей странице | MESS_NAV_FORWARD | Задается название кнопки для перехода к следующей странице.
[/di] для замены стандартных основных фраз на свои собственные.
Дополнительные фразы
Заменить стандартные фразы на свои USE_CUSTOM_ADDITIONAL_MESSAGES [Y|N] При отмеченной опции становятся доступными [dw]параметры [/dw][di]
Текст для "бесплатно" | MESS_PRICE_FREE | Задается информационный текст, отображаемый для нулевых сумм.
Текст для "Экономия" | MESS_ECONOMY | Задается информационный текст, отображаемый для величины экономии денег покупателя.
Текст для перехода к блоку регистрации | MESS_REGISTRATION_REFERENCE | Задается информационный текст, отображаемый перед кнопкой "Зарегистрироваться" в блоке авторизации.
Справочная информация №1 блока "Авторизация" | MESS_AUTH_REFERENCE_1 | Задается текст для первого абзаца справочной информации в блоке авторизации.
Справочная информация №2 блока "Авторизация" | MESS_AUTH_REFERENCE_2 | Задается текст для второго абзаца справочной информации в блоке авторизации.
Справочная информация №3 блока "Авторизация" | MESS_AUTH_REFERENCE_3 | Задается текст для третьего абзаца справочной информации в блоке авторизации.
Кнопка дополнительных свойств товара | MESS_ADDITIONAL_PROPS | Указывается название кнопки для показа дополнительных свойств товара.
Заголовок поля ввода купона | MESS_USE_COUPON | Задается текст заголовка для поля ввода купонов.
Заголовок для примененных купонов | MESS_COUPON | Задается текст заголовка для поля примененных купонов.
Заголовок выбора типа плательщика | MESS_PERSON_TYPE | Указывается текст для заголовка поля с выбором типа плательщика.
Заголовок выбора профиля | MESS_SELECT_PROFILE | Указывается текст для заголовка поля с выбором профиля.
Справочная информация блока "Регион" | MESS_REGION_REFERENCE | Задается текст справочной информации, которая будет отображаться в блоке региона доставки.
Заголовок пунктов самовывоза | MESS_PICKUP_LIST | Указывается заголовок для списка всех пунктов самовывоза.
Заголовок ближайших пунктов самовывоза | MESS_NEAREST_PICKUP_LIST | Задается заголовок для списка ближайших пунктов самовывоза.
Кнопка выбора пункта самовывоза | MESS_SELECT_PICKUP | Указывается заголовок для кнопки выбора пункта самовывоза.
Информация о балансе внутреннего счета | MESS_INNER_PS_BALANCE | Задается заголовок для поля с информацией о состоянии внутреннего счета.
Заголовок комментариев к заказу | MESS_ORDER_DESC | Задается заголовок для поля с комментарием к заказу.
[/di] для замены стандартных дополнительных фраз на свои собственные.
Фразы уведомлений
Заменить стандартные фразы на свои USE_CUSTOM_ERROR_MESSAGES [Y|N] При отмеченной опции становятся доступными [dw]параметры[/dw][di]
Текст уведомления о корректной загрузке данных заказа | MESS_SUCCESS_PRELOAD_TEXT | Задается текст уведомления, которое отображается при корректной загрузке даныых заказа.
Текст уведомления о неудачной загрузке данных заказа | MESS_FAIL_PRELOAD_TEXT | Задается текст уведомления, которое отображается при неудачной загрузке даныых заказа.
Заголовок ошибки расчета доставки | MESS_DELIVERY_CALC_ERROR_TITLE | Указывается заголовок для ошибки, возникающей при расчете доставки.
Текст ошибки рассчета доставки | MESS_DELIVERY_CALC_ERROR_TEXT | Указывается текст ошибки, возникающей при расчете доставки.
Текст уведомления при статусе заказа, недоступном для оплаты | MESS_PAY_SYSTEM_PAYABLE_ERROR | Указывается текст ошибки, возникающей при недоступности оплаты.
[/di] для замены стандартных фраз уведомлений на свои собственные.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:sale.order.ajax",
    "",
    Array(
        "ADDITIONAL_PICT_PROP_8" => "-",
        "ALLOW_AUTO_REGISTER" => "N",
        "ALLOW_NEW_PROFILE" => "Y",
        "ALLOW_USER_PROFILES" => "Y",
        "BASKET_IMAGES_SCALING" => "standard",
        "BASKET_POSITION" => "after",
        "COMPATIBLE_MODE" => "Y",
        "DELIVERIES_PER_PAGE" => "8",
        "DELIVERY_FADE_EXTRA_SERVICES" => "Y",
        "DELIVERY_NO_AJAX" => "Y",
        "DELIVERY_NO_SESSION" => "Y",
        "DELIVERY_TO_PAYSYSTEM" => "d2p",
        "DISABLE_BASKET_REDIRECT" => "N",
        "MESS_DELIVERY_CALC_ERROR_TEXT" => "Вы можете продолжить оформление заказа, а чуть позже менеджер магазина
 свяжется с вами и уточнит информацию по доставке.",
        "MESS_DELIVERY_CALC_ERROR_TITLE" => "Не удалось рассчитать стоимость доставки.",
        "MESS_FAIL_PRELOAD_TEXT" => "Вы заказывали в нашем интернет-магазине, поэтому мы заполнили все данные автоматически.

Обратите внимание на развернутый блок с информацией о заказе. Здесь вы можете внести необходимые изменения или оставить
как есть и нажать кнопку \"#ORDER_BUTTON#\".",
        "MESS_SUCCESS_PRELOAD_TEXT" => "Вы заказывали в нашем интернет-магазине, поэтому мы заполнили все данные
автоматически. Если все заполнено верно, нажмите кнопку \"#ORDER_BUTTON#\".",
        "ONLY_FULL_PAY_FROM_ACCOUNT" => "N",
        "PATH_TO_AUTH" => "/auth/",
        "PATH_TO_BASKET" => "basket.php",
        "PATH_TO_PAYMENT" => "payment.php",
        "PATH_TO_PERSONAL" => "index.php",
        "PAY_FROM_ACCOUNT" => "Y",
        "PAY_SYSTEMS_PER_PAGE" => "8",
        "PICKUPS_PER_PAGE" => "5",
        "PRODUCT_COLUMNS_HIDDEN" => array("PROPERTY_MATERIAL"),
        "PRODUCT_COLUMNS_VISIBLE" => array("PREVIEW_PICTURE","PROPS"),
        "PROPS_FADE_LIST_1" => array("17","19"),
        "SEND_NEW_USER_NOTIFY" => "Y",
        "SERVICES_IMAGES_SCALING" => "standard",
        "SET_TITLE" => "Y",
        "SHOW_BASKET_HEADERS" => "N",
        "SHOW_COUPONS" => "Y",
        "SHOW_COUPONS_BASKET" => "Y",
        "SHOW_COUPONS_DELIVERY" => "Y",
        "SHOW_COUPONS_PAY_SYSTEM" => "Y",
        "SHOW_DELIVERY_INFO_NAME" => "Y",
        "SHOW_DELIVERY_LIST_NAMES" => "Y",
        "SHOW_DELIVERY_PARENT_NAMES" => "Y",
        "SHOW_MAP_IN_PROPS" => "N",
        "SHOW_NEAREST_PICKUP" => "N",
        "SHOW_NOT_CALCULATED_DELIVERIES" => "L",
        "SHOW_ORDER_BUTTON" => "final_step",
        "SHOW_PAY_SYSTEM_INFO_NAME" => "Y",
        "SHOW_PAY_SYSTEM_LIST_NAMES" => "Y",
        "SHOW_STORES_IMAGES" => "Y",
        "SHOW_TOTAL_ORDER_BUTTON" => "Y",
        "SHOW_VAT_PRICE" => "Y",
        "SKIP_USELESS_BLOCK" => "Y",
        "TEMPLATE_LOCATION" => "popup",
        "TEMPLATE_THEME" => "site",
        "USE_CUSTOM_ADDITIONAL_MESSAGES" => "N",
        "USE_CUSTOM_ERROR_MESSAGES" => "Y",
        "USE_CUSTOM_MAIN_MESSAGES" => "N",
        "USE_PREPAYMENT" => "N",
        "USE_YM_GOALS" => "N",
        "USER_CONSENT" => "Y",
        "USER_CONSENT_ID" => "1",
        "USER_CONSENT_IS_CHECKED" => "Y",
        "USER_CONSENT_IS_LOADED" => "N"
    )
);?>

Смотрите также

При завершении заказа выводится финальное сообщение. Если его нужно изменить, то отредактируйте шаблон компонента [image]. Эта фраза "зашита" в нём.


Подключение обработчика результата платежной системы

Одностраничный компонент осуществляет подключение скрипта для получения результата от платежной системы. Компонент стандартный и входит в дистрибутив модуля.

Описание sale.order.payment.receive

Одностраничный компонент осуществляет подключение скрипта для получения результата от платежной системы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Процедура оформления заказа > Подключение обработчика результата платежной системы.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Платежная система | PAY_SYSTEM_ID_NEW | Указывается платежная система (ее идентификатор), результат от которой должен быть получен.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.order.payment.receive","",Array(
        "PAY_SYSTEM_ID_NEW" => "4"
    ),
);?>


Подключение платежной системы

Описание sale.order.payment

Одностраничный компонент осуществляет подключение платежной системы. Компонент применяется в тех случаях, когда обработчик платежной системы должен открываться в новом окне.

В визуальном редакторе компонент расположен по пути: Магазин > Процедура оформления заказа > Подключение платежной системы.

Компонент относится к модулю Интернет-магазин.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.order.payment","",Array(
    )
);?>


Привязка к местоположению: выпадающие списки

Описание sale.location.selector.steps

Компонент выводит форму, в которой выбор местоположения осуществляется с помощью последовательного выбора вариантов из выпадающего списка. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Процедура оформления заказа > Привязка к местоположению: выпадающие списки.

Компонент относится к модулю Интернет-магазин.

Важно! Компонент используется только при работе с местоположениями версии 2.0.

Параметры

Поле | Параметр | Описание
Основные параметры
ID местоположения | ID | Идентификатор местоположения, которое должно быть отображено в форме. Можно не задавать, если задан Символьный код местоположения.
Символьный код местоположения | CODE | Символьный код местоположения, которое должно быть отображено в форме. Можно не задавать, если задан ID местоположения.
Имя поля ввода | INPUT_NAME | Задается название переменной для имени поля ввода.
Сохранять связь через | PROVIDE_LINK_BY | Указывается, что необходимо записать в форму ввода при выборе местоположения: идентификатор (id) или символьный код (code).
Источник данных
Отображать статичный ствол дерева | PRESELECT_TREE_TRUNK | [Y|N] Если у дерева местоположений есть цепочка, ведущая от корня и не имеющая разветвлений, то при отмеченной опции она будет отображена в селекторе как выбранная изначально.
Предварительно загружать последний выбранный уровень | PRECACHE_LAST_LEVEL | [Y|N] Если опция включена, то последний выбранный уровень будет пред-загружен при показе компонента. В противном случае, данные будут загружены при попытке открытия выпадающего списка.
Фильтровать по сайту | FILTER_BY_SITE | [Y|N] При отмеченной опции выбор местоположений осуществляется только среди тех, которые привязаны к сайту.
Отображать местоположения по умолчанию | SHOW_DEFAULT_LOCATIONS | [Y|N] При отмеченной опции вверху формы выбора местоположений будут отображены избранные местоположения.
Cайт | FILTER_SITE_ID | Указывается сайт, по местоположениям которого будет делаться выборка.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Идентификатор javascript-контрола | JSCONTROL_GLOBAL_ID | Системный параметр. Не описывается.
Javascript-функция обратного вызова | JS_CALLBACK | Системный параметр. Не описывается.
Не показывать ошибки, если они возникли при загрузке компонента | SUPPRESS_ERRORS | [Y|N] При отмеченной опции ошибки, возникающие при загрузке компонента, отображаться не будут.
Отключить поиск через ввод с клавиатуры и не показывать следующий уровень при выборе | DISABLE_KEYBOARD_INPUT | [Y|N] При отмеченной опции будет отключен поиск местоположений через ввод с клавиатуры не будет показываться следующий уровень при выборе.
Инициализировать компонент только при наступлении указанного javascript-события на объекте window.document | INITIALIZE_BY_GLOBAL_EVENT | Название javascript-события, при наступлении которого будет инициализироваться компонент.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.location.selector.steps",
    "",
    Array(
        "COMPONENT_TEMPLATE" => ".default",
        "ID" => "980",
        "CODE" => "",
        "INPUT_NAME" => "LOCATION",
        "PROVIDE_LINK_BY" => "id",
        "JSCONTROL_GLOBAL_ID" => "",
        "JS_CALLBACK" => "",
        "FILTER_BY_SITE" => "Y",
        "SHOW_DEFAULT_LOCATIONS" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "FILTER_SITE_ID" => "s1",
        "PRECACHE_LAST_LEVEL" => "N",
        "PRESELECT_TREE_TRUNK" => "N",
        "DISABLE_KEYBOARD_INPUT" => "N",
        "INITIALIZE_BY_GLOBAL_EVENT" => "",
        "SUPPRESS_ERRORS" => "N"
    )
);?>


Привязка к местоположению: строка поиска

Описание sale.location.selector.search

Компонент выводит форму, в которой выбор местоположения осуществляется с помощью ввода запроса в строку поиска. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Процедура оформления заказа > Привязка к местоположению: строка поиска.

Компонент относится к модулю Интернет-магазин.

Важно! Компонент используется только при работе с местоположениями версии 2.0.

Параметры

Поле | Параметр | Описание
Основные параметры
ID местоположения | ID | Идентификатор местоположения, которое должно быть отображено в форме. Можно не задавать, если задан Символьный код местоположения.
Символьный код местоположения | CODE | Символьный код местоположения, которое должно быть отображено в форме. Можно не задавать, если задан ID местоположения.
Имя поля ввода | INPUT_NAME | Задается название переменной для имени поля ввода.
Сохранять связь через | PROVIDE_LINK_BY | Указывается, что необходимо записать в форму ввода при выборе местоположения: идентификатор (id) или символьный код (code).
Источник данных
Фильтровать по сайту | FILTER_BY_SITE | [Y|N] При отмеченной опции поиск местоположений осуществляется только среди тех, которые привязаны к сайту.
Отображать местоположения по-умолчанию | SHOW_DEFAULT_LOCATIONS | [Y|N] При отмеченной опции вверху формы поиска будут отображены избранные местоположения.
Cайт | FILTER_SITE_ID | Указывается сайт, по местоположениям которого будет делаться выборка.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Идентификатор javascript-контрола | JSCONTROL_GLOBAL_ID | Системный параметр. Не описывается.
Javascript-функция обратного вызова | JS_CALLBACK | Системный параметр. Не описывается.
Не показывать ошибки, если они возникли при загрузке компонента | SUPPRESS_ERRORS | [Y|N] При отмеченной опции ошибки, возникающие при загрузке компонента, отображаться не будут.
Инициализировать компонент только при наступлении указанного javascript-события на объекте window.document | INITIALIZE_BY_GLOBAL_EVENT | Название javascript-события, при наступлении которого будет инициализироваться компонент.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.location.selector.search",
    "",
    Array(
        "COMPONENT_TEMPLATE" => ".default",
        "ID" => "980",
        "CODE" => "",
        "INPUT_NAME" => "LOCATION",
        "PROVIDE_LINK_BY" => "id",
        "JSCONTROL_GLOBAL_ID" => "",
        "JS_CALLBACK" => "",
        "FILTER_BY_SITE" => "Y",
        "SHOW_DEFAULT_LOCATIONS" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "FILTER_SITE_ID" => "s1",
        "INITIALIZE_BY_GLOBAL_EVENT" => "",
        "SUPPRESS_ERRORS" => "N"
    )
);?>


Рекомендуемые товары

Подраздел содержит компоненты, которые выводят список товаров, рекомендуемых к покупке вместе выбранным товаром.

Содержит следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Вывод товаров для почты | catalog.show.products.mail | Выводит список товаров для почты по заданным идентификаторам.


Вывод товаров для почты

Описание catalog.show.products.mail

Компонент выводит список товаров для почты по заданным идентификаторам. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Вывод товаров для почты > Вывод товаров для почты.

Компонент относится к модулю Торговый каталог.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Укажите id товаров через запятую | LIST_ITEM_ID | Указываются идентификаторы необходимых товаров.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:catalog.show.products.mail",
    "",
    Array(
        "LIST_ITEM_ID" => array("58")
    )
);?>


Список профилей текущего пользователя

Подраздел предназначен для работы с персональным разделом пользователя. Содержит следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Вывод полей заказа | sale.business.value.mail | Выводит список полей заказа по коду заказа.
Добавление средств на счет текущего пользователя | sale.account.pay | Позволяет добавить средства на внутренний счет текущего пользователя.
Заказы пользователя | sale.personal.order | Отображает список заказов текущего пользователя.
Накопительные программы | catalog.discsave.info | Отображает список накопительных программ.
Отмена заказа | sale.personal.order.cancel | Позволяет отменить заказ.
Отмена подписки | sale.personal.subscribe.cancel | Позволяет отменить подписку.
Персональный раздел пользователя | sale.personal.section | Организует персональный раздел пользователя.
Пластиковые карты | sale.personal.cc | Для управления пластиковыми картами текущего пользователя.
Подписки пользователя | sale.personal.subscribe | Для управления подписками текущего пользователя.
Подробная информация о заказе | sale.personal.order.detail | Выводит подробную информацию по заказу.
Подробная информация о заказе для почты | sale.personal.order.detail.mail | Выводит подробную информацию по заказу для почты.
Профили пользователя | sale.personal.profile | Для управления профилями текущего пользователя.
Редактирование пластиковых карт | sale.personal.cc.detail | Для редактирования пластиковых карт пользователя.
Редактирование профиля | sale.personal.profile.detail | Позволяет редактировать профиль пользователя.
Список заказов | sale.personal.order.list | Выводит фильтр и список заказов пользователя.
Список пластиковых карт текущего пользователя | sale.personal.cc.list | Выводит список пластиковых карт текущего пользователя.
Список подписок текущего пользователя | sale.personal.subscribe.list | Выводит список подписок текущего пользователя.
Список профилей текущего пользователя | sale.personal.profile.list | Выводит список профилей текущего пользователя.
Счета текущего пользователя | sale.personal.account | Отображает состояние внутреннего счета текущего пользователя в доступной валюте.


Вывод полей заказа

Описание sale.business.value.mail

Компонент выводит список полей заказа по коду заказа. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Персональный раздел > Вывод полей заказа.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Источник данных | PROVIDER | Указывается источник для вывода данных из заказа.
Группа полей | GROUP | В случае, если выбранный источник данных содержит несколько групп полей, то в параметре следует указать ту группу, данные из которой необходимо выводить.
Поля | FIELD | Задается перечень необходимых полей для вывода.
Дополнительные настройки
Код заказа | ORDER_ID | Указывается код заказа, список полей которого должен быть выведен.
Выводить название поля | DISPLAY_NAME | [Y|N] При отмеченной опции будет выводиться название поля.
Выводить пустые поля | DISPLAY_EMPTY | [Y|N] При отмеченной опции выбранные поля заказа будут выводиться даже в том случае, если они пусты.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.business.value.mail",
    "",
    Array(
        "DISPLAY_EMPTY" => "N",
        "DISPLAY_NAME" => "Y",
        "FIELD" => array("NAME","SECOND_NAME","EMAIL"),
        "GROUP" => "CLIENT",
        "ORDER_ID" => "{#ORDER_ID#}",
        "PROVIDER" => "USER"
    )
);?>


Добавление средств на счет текущего пользователя

Описание sale.account.pay

Одностраничный компонент позволяет добавить средства на внутренний счет текущего пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Добавление средств на счет текущего пользователя.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Включить обновленную версию компонента | REFRESHED_COMPONENT_MODE | [Y|N] При отмеченной опции будет использоваться обновленная версия компонента.
Дополнительные настройки (для старой версии компонента)
Путь к корзине | PATH_TO_BASKET | Указывается путь к странице с корзиной от корня сайта. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Корзина.
Путь к странице оплат | PATH_TO_PAYMENT | Указывается путь к странице оплат от корня сайта. Если страница находится в текущей директории, то достаточно указать ее название.
Валюта для отображения | SELL_CURRENCY | Из созданных в системе валют выбирается валюта, в которой будут отображаться денежные средства пользователя.
Выберите суммы для покупки | SELL_AMOUNT | Указывается набор сумм, который будет доступен для пополнения счета. Полный набор сумм задается на странице настроек модуля Интернет-магазин.
Перенаправлять пользователя на текущую страницу после добавления в корзину | REDIRECT_TO_CURRENT_PAGE | [Y|N] При отмеченной опции пользователь будет перенаправляться на данную страницу после добавление товара в корзину.
Имя переменной для покупки | VAR | Задается имя переменной, в которой будет передаваться сумма при зачислении на счет.
Callback-функция для разрешения доставки товара | CALLBACK_NAME | Задайте имя Callback-функции. По умолчанию используется PayUserAccountDeliveryOrderCallback. Свою функцию можно добавить в файл /bitrix/php_interface/init.php, при этом необходимо указать ее имя в параметрах компонента. Функция будет восприниматься как глобальная.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Пополнение счета.
Дополнительные настройки (для обновленной версии компонента)
Путь к корзине | PATH_TO_BASKET | Указывается путь к странице с корзиной от корня сайта. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Корзина.
Путь к странице оплат | PATH_TO_PAYMENT | Указывается путь к странице оплат от корня сайта. Если страница находится в текущей директории, то достаточно указать ее название.
Валюта для отображения | SELL_CURRENCY | Из созданных в системе валют выбирается валюта, в которой будут отображаться денежные средства пользователя.
Тип пользователя | PERSON_TYPE | Из созданных в системе типов плательщиков выбирается тот, для которого будет выполняться пополнение счета.
Исключить из списка платежных систем | ELIMINATED_PAY_SYSTEMS | Из созданных в системе платежных систем выбираются те, которые не должны быть доступны для пополнения счета.
Установка значения через заданную переменную | SELL_VALUES_FROM_VAR | [Y|N] При отмеченной опции значение суммы к оплате будет устанавливаться через переменную.
Сумма к оплате* | SELL_VAR_PRICE_VALUE | Указывается переменная, через которую будет передаваться сумма для зачисления на счет.
Показать сумму на странице* | SELL_SHOW_RESULT_SUM | [Y|N] При отмеченной опции сумма будет показана на странице.
Показывать значения фиксированных платежей | SELL_SHOW_FIXED_VALUES | [Y|N] При отмеченной опции будут отображаться значения фиксированных платежей.
Выберите суммы для покупки** | SELL_TOTAL | Задаются суммы фиксированных платежей.
Разрешить пользователю вводить сумму | SELL_USER_INPUT | [Y|N] При отмеченной опции пользователю будет доступно поле для ввода своей суммы платежа. Параметр недоступен, если отмечена опция Установка значения через заданную переменную.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Пополнение счета.

* - параметры доступны при отмеченной опции Установка значения через заданную переменную.

** - параметр доступен при отмеченной опции Показывать значения фиксированных платежей.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.account.pay",
    "",
    Array(
        "ELIMINATED_PAY_SYSTEMS" => array("2"),
        "PATH_TO_BASKET" => "/personal/cart",
        "PATH_TO_PAYMENT" => "/personal/order/payment",
        "PERSON_TYPE" => "1",
        "REFRESHED_COMPONENT_MODE" => "Y",
        "SELL_CURRENCY" => "RUB",
        "SELL_SHOW_FIXED_VALUES" => "Y",
        "SELL_TOTAL" => array("100","200","500","1000","5000",""),
        "SELL_USER_INPUT" => "Y",
        "SELL_VALUES_FROM_VAR" => "N",
        "SET_TITLE" => "Y"
    )
);?>


Заказы пользователя (комплексный компонент)

Комплексный компонент отображает список заказов текущего пользователя с ссылками для перехода к просмотру детальной информации, отмене заказа, к оформлению повторного заказа.

Описание sale.personal.order

Можно управлять адресами переходов по этим страницам с помощью настроек ЧПУ. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Заказы пользователя.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Не показывать свойства для типа плательщика <название_плательщика> | PROP_N | Для каждого типа плательщика <название_плательщика> (N - идентификатор типа плательщика) задается массив свойств, которые не должны быть отображены.
Внешний вид
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры[/dw][di]
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • list - страница со списком заказов;
  • detail - страница с подробной информацией о заказе;
  • cancel - страница отмены заказа.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
[/di]: SEF_FOLDER, SEF_URL_TEMPLATES.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Количество заказов на одной странице | ORDERS_PER_PAGE | Указывается количество заказов, отображаемых на одной странице. Все остальные заказы будут выведены с помощью постраничной навигации.
Страница подключения платежной системы | PATH_TO_PAYMENT | Указывается путь к странице подключения платежной системы. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Подключение платежной системы. Переход на эту страницу происходит по ссылке Повторить оплату на странице с детальной информацией по заказу.
Страница с корзиной | PATH_TO_BASKET | Указывается путь к странице с корзиной. Если страница находится в текущей директории, то достаточно указать ее название. Такая страница может быть создана с помощью компонента Корзина.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Мои заказы.
Сохранять установки фильтра в сессии пользователя | SAVE_IN_SESSION | [Y|N] При отмеченной опции установки фильтра будут сохранены в сессии пользователя.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Дополнительные свойства инфоблока | CUSTOM_SELECT_PROPS | Задаются коды свойств инфоблока, которые необходимо вывести при детальном просмотре заказа. Следует задавать для вывода только строковые и числовые типы свойств.
Перенести в историю заказы в статусах | HISTORIC_STATUSES | Указываются статусы, которые будут использоваться при фильтрации по истории. Если заказ находится в одном из выбранных статусов, то в списке всех заказов он показан не будет, а будет доступен в истории заказов.
Цвет статуса название_статуса | STATUS_COLOR_код_статуса | Указывается цвет, которым будет выделен статус заказа.
Цвет отменённых заказов | STATUS_COLOR_PSEUDO_CANCELLED | Указывается цвет, которым будет выделен статус отмененного заказа.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.personal.order","",Array(
        "STATUS_COLOR_N" => "green",
        "STATUS_COLOR_P" => "yellow",
        "STATUS_COLOR_F" => "gray",
        "STATUS_COLOR_PSEUDO_CANCELLED" => "red",
        "SEF_MODE" => "Y",
        "ORDERS_PER_PAGE" => 20,
        "PATH_TO_PAYMENT" => "payment.php",
        "PATH_TO_BASKET" => "basket.php",
        "SET_TITLE" => "Y",
        "SAVE_IN_SESSION" => "Y",
        "NAV_TEMPLATE" => "",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "PROP_1" => Array(),
        "PROP_2" => Array(),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y",
        "CUSTOM_SELECT_PROPS" => "",
        "HISTORIC_STATUSES" => "F",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "list" => "index.php",
            "detail" => "order_detail.php?ID=#ID#",
            "cancel" => "order_cancel.php?ID=#ID#"
        ),
        "VARIABLE_ALIASES" => Array(
            "list" => Array(),
            "detail" => Array(
                "ID" => "ID"
            ),
            "cancel" => Array(
                "ID" => "ID"
            ),
        )
    ),
);?>


Накопительные программы

Описание catalog.discsave.info

Одностраничный компонент, позволяет просмотреть список накопительных программ, распространяющихся на клиента Интернет-магазина.

Компонент стандартный и входит в дистрибутив модуля.

Компонент относится к модулю Торговый каталог.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Накопительные программы.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Показывать информацию о следующем уровне накоплений | SHOW_NEXT_LEVEL | [Y|N] При отмеченной опции будет показана информация о том, как увеличить скидку, если такая возможность имеется.
Сайт | SITE_ID | Выбирается сайт, на котором действуют накопительные скидки клиента, информацию по которым следует вывести к показу.
ID пользователя | USER_ID | Указывается ID пользователя, информацию по накопительным программам которого следует вывести к показу.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:catalog.discsave.info",
    "",
    Array(
        "SITE_ID" => "s1",
        "USER_ID" => "",
        "SHOW_NEXT_LEVEL" => "Y"
    )
);?>


Отмена заказа

Описание sale.personal.order.cancel

Одностраничный компонент позволяет отменить заказ. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Отмена заказа.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Страница со списком заказов | PATH_TO_LIST | Указывается путь к странице со списком заказов. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Список заказов.
Страница с подробной информацией о заказе | PATH_TO_DETAIL | Указывается путь к странице с детальной информацией о заказе. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Подробная информация о заказе. Необходимо передавать идентификатор заказа в качестве параметра.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Отмена заказа № <идентификатор_заказа>.
Идентификатор заказа | ID | Указывается код, результатом которого является получение идентификатора заказа. По умолчанию ={$ID}.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.personal.order.cancel","",Array(
        "PATH_TO_LIST" => "order_list.php",
        "PATH_TO_DETAIL" => "order_detail.php?ID=#ID#",
        "ID" => $ID,
        "SET_TITLE" => "Y"
    )
);?>


Отмена подписки

Описание sale.personal.subscribe.cancel

Одностраничный компонент позволяет отменить подписку. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Отмена подписки.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Страница со списком подписок | PATH_TO_LIST | Указывается путь к странице со списком подписок. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Список подписок текущего пользователя.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Отмена подписки № <идентификатор_подписки>.
Идентификатор подписки | ID | Указывается код, результатом которого является получение идентификатора подписки. По умолчанию ={$ID}.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:sale.personal.subscribe.cancel","",Array(
        "PATH_TO_LIST" => "subscribe_list.php",
        "ID" => $ID,
        "SET_TITLE" => "Y"
    ),
);?>


Персональный раздел пользователя

Комплексный компонент персонального раздела пользователя. Компонент стандартный и входит в дистрибутив модуля.

Описание sale.personal.section

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Персональный раздел пользователя.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Показать страницу персонального счета пользователя | SHOW_ACCOUNT_PAGE | [Y|N] При отмеченной опции будет доступна страница личного счета пользователя. Описание настроек страницы здесь.
Показать страницу заказов пользователя | SHOW_ORDER_PAGE | [Y|N] Опция позволяет просматривать страницу заказов пользователя. Описание настроек страницы здесь.
Показать страницу персональных данных пользователя | SHOW_PRIVATE_PAGE | [Y|N] Подключение страницы личных данных пользователя. Описание настроек страницы здесь
Показать страницу профилей пользователя | SHOW_PROFILE_PAGE | [Y|N] Вывод страницы для просмотра профилей пользователя. Описание настроек страницы здесь.
Показать страницу подписок | SHOW_SUBSCRIBE_PAGE | [Y|N] Отображение страницы подписок пользователя на товары.
Вывести ссылку на страницу контактов | SHOW_CONTACT_PAGE | [Y|N] При отмеченной опции станет доступна ссылка для перехода на страницу контактов магазина.
Вывести ссылку на корзину | SHOW_BASKET_PAGE | [Y|N] Будет отображаться ссылка для перехода в корзину.
Настройки дополнительных страниц раздела CUSTOM_PAGES Задаются настройки для добавления дополнительных страниц в персональный раздел пользователя.
  • Путь к дополнительной странице - адрес к дополнительной странице;
  • Название страницы - заголовок дополнительной страницы, отображаемый на индексной странице персонального раздела;
  • Имя класса FontAwesome - картинка (элемент CSS шрифта @font-awesome) для дополнительной страницы, отображаемая на индексной странице персонального раздела.
Шаблоны ссылок
Путь к странице оплат | PATH_TO_PAYMENT | Указывается путь к странице оплат по заказам.
Путь к странице контактных данных | PATH_TO_CONTACT | Задается путь к странице с контактными данными.
Путь к корзине | PATH_TO_BASKET | Указывается путь к корзине.
Путь к каталогу | PATH_TO_CATALOG | Указывается путь к каталогу товаров.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]дополнительные параметры[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • account - страница персонального счета пользователя;
  • index - главная страница персонального раздела;
  • order_cancel - страница отмены заказа;
  • order_detail - страница подробной информации о заказе;
  • orders - страница заказов пользователя;
  • private - страница персональных данных пользователя;
  • profile - страница списка профилей пользователя;
  • profile_detail - страница профиля пользователя;
  • subscribe - страница подписок.
[/di].
Страница персонального счета пользователя
Секция доступна, если отмечена опция Показать страницу персонального счета пользователя
Показать счет текущего пользователя | SHOW_ACCOUNT_COMPONENT | [Y|N] При отмеченной опции будет отображаться текущее состояние счета пользователя.
Разрешить добавление средств на счет текущего пользователя SHOW_ACCOUNT_PAY_COMPONENT [Y|N] При отмеченной опции пользователю будет доступно добавление средств на свой счет. Кроме того, становятся доступными для настройки [dw]дополнительные параметры[/dw][di]
Валюта для отображения | ACCOUNT_PAYMENT_SELL_CURRENCY | Из созданных в системе валют выбирается валюта, в которой будут отображаться денежные средства пользователя.
Тип пользователя | ACCOUNT_PAYMENT_PERSON_TYPE | Из созданных в системе типов плательщиков выбирается тот, для которого будет выполняться пополнение счета.
Исключить из списка платежных систем | ACCOUNT_PAYMENT_ELIMINATED_PAY_SYSTEMS | Из созданных в системе платежных систем выбираются те, которые не должны быть доступны для пополнения счета.
Показывать значения фиксированных платежей | ACCOUNT_PAYMENT_SELL_SHOW_FIXED_VALUES | [Y|N] При отмеченной опции будут отображаться значения фиксированных платежей.
Выберите суммы для покупки | ACCOUNT_PAYMENT_SELL_TOTAL | Задаются суммы фиксированных платежей. Параметр доступен при отмеченной опции Показывать значения фиксированных платежей.
[/di].
Разрешить пользователю вводить сумму | ACCOUNT_PAYMENT_SELL_USER_INPUT | [Y|N] При отмеченной опции пользователю будет доступно поле для ввода своей суммы платежа.
Страница заказов пользователя
Секция доступна, если отмечена опция Показать страницу заказов пользователя
Сохранять установки фильтра в сессии пользователя | SAVE_IN_SESSION | [Y|N] При отмеченной опции установки фильтра будут сохранены в сессии пользователя.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Дополнительные свойства инфоблока | CUSTOM_SELECT_PROPS | Задаются коды свойств инфоблока, которые необходимо вывести при детальном просмотре заказа. Следует задавать для вывода только строковые и числовые типы свойств.
Не показывать в информации о пользователе | ORDER_HIDE_USER_INFO | Выберите какие данные пользователя НЕ должны показываться на странице.
Не показывать свойства для типа плательщика <название_плательщика> | PROP_N | Для каждого типа плательщика <название_плательщика> (N - идентификатор типа плательщика) задается массив свойств, которые не должны быть отображены.
Перенести в историю заказы в статусах | ORDER_HISTORIC_STATUSES | Указываются статусы, которые будут использоваться при фильтрации по истории. Если заказ находится в одном из выбранных статусов, то в списке всех заказов он показан не будет, а будет доступен в истории заказов.
Запретить смену платежной системы у заказов в статусах | ORDER_RESTRICT_CHANGE_PAYSYSTEM | Указываются статусы, по достижении которых невозможно изменить платёжную систему.
Сортировка заказов | ORDER_DEFAULT_SORT | Выбор параметра по которому сортируются заказы.
Пересчитывать заказ после смены платежной системы | ORDER_REFRESH_PRICES | Разрешение на пересчёт заказа после смены платёжной системы
Разрешить оплату с внутреннего счета | ALLOW_INNER | Разрешение на оплату с внутреннего счёта
Разрешить оплату с внутреннего счета только в полном объеме | ONLY_INNER_FULL | Разрешение на оплату с внутреннего счёта при условии наличия на счёте полной суммы заказа.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Укажите имя шаблона для постраничной навигации.
Количество заказов на одной странице | ORDERS_PER_PAGE | Количество заказов на одной странице.
Страница профиля пользователя
Секция доступна, если отмечена опция Показать страницу профилей пользователя
Использовать расширенный выбор местоположения | USE_AJAX_LOCATIONS_PROFILE | [Y|N] При отмеченной опции будет использована расширенная форма выбора местоположений, которая может быть построена с помощью компонента AJAX-местоположения.
Получить список местоположений для устаревших версий шаблона | COMPATIBLE_LOCATION_MODE_PROFILE | [Y|N] При отмеченной опции получение списка местоположений будет осуществляться через CSaleLocation::GetList [image]. Опцию включать не рекомендуется, она оставлена для совместимости.
Страница персональных данных пользователя
Секция доступна, если отмечена опция Показать страницу персональных данных пользователя
Генерировать почтовое событие | SEND_INFO_PRIVATE | [Y|N] При отмеченной опции будет вызвано имеющееся почтовое событие и отправлено письмо пользователю.
Проверять права доступа | CHECK_RIGHTS_PRIVATE | [Y|N] При отмеченной опции будут проверяться права на редактирование профиля.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Количество заказов на одной странице | PER_PAGE | Указывается количество заказов, отображаемых на одной странице. Все остальные заказы будут выведены с помощью постраничной навигации.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции для страниц персонального раздела будут устанавливаться соответствующие заголовки.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.personal.section",
    "",
    Array(
        "ACCOUNT_PAYMENT_ELIMINATED_PAY_SYSTEMS" => array("0"),
        "ACCOUNT_PAYMENT_PERSON_TYPE" => "1",
        "ACCOUNT_PAYMENT_SELL_CURRENCY" => "RUB",
        "ACCOUNT_PAYMENT_SELL_SHOW_FIXED_VALUES" => "Y",
        "ACCOUNT_PAYMENT_SELL_TOTAL" => array("100", "200", "500", "1000", "5000", ""),
        "ACCOUNT_PAYMENT_SELL_USER_INPUT" => "Y",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "3600",
        "CACHE_TYPE" => "A",
        "CHECK_RIGHTS_PRIVATE" => "Y",
        "COMPATIBLE_LOCATION_MODE_PROFILE" => "N",
        "CUSTOM_PAGES" => "[]",
        "CUSTOM_SELECT_PROPS" => array(""),
        "NAV_TEMPLATE" => "",
        "ORDER_HISTORIC_STATUSES" => array("F"),
        "PATH_TO_BASKET" => "/personal/cart",
        "PATH_TO_CATALOG" => "/catalog/",
        "PATH_TO_CONTACT" => "/about/contacts",
        "PATH_TO_PAYMENT" => "/personal/order/payment",
        "PER_PAGE" => "20",
        "PROP_1" => array(),
        "PROP_2" => array(),
        "SAVE_IN_SESSION" => "Y",
        "SEF_FOLDER" => "/personal_section/",
        "SEF_MODE" => "Y",
        "SEF_URL_TEMPLATES" => Array(
            "account" => "account/",
            "index" => "index.php",
            "order_cancel" => "cancel/#ID#",
            "order_detail" => "orders/#ID#",
            "orders" => "orders/",
            "private" => "private/",
            "profile" => "profiles/",
            "profile_detail" => "profiles/#ID#",
            "subscribe" => "subscribe/"
        ),
        "SEND_INFO_PRIVATE" => "N",
        "SET_TITLE" => "Y",
        "SHOW_ACCOUNT_COMPONENT" => "Y",
        "SHOW_ACCOUNT_PAGE" => "Y",
        "SHOW_ACCOUNT_PAY_COMPONENT" => "Y",
        "SHOW_BASKET_PAGE" => "Y",
        "SHOW_CONTACT_PAGE" => "Y",
        "SHOW_ORDER_PAGE" => "Y",
        "SHOW_PRIVATE_PAGE" => "Y",
        "SHOW_PROFILE_PAGE" => "Y",
        "SHOW_SUBSCRIBE_PAGE" => "Y",
        "USE_AJAX_LOCATIONS_PROFILE" => "Y"
    )
);?>


Пластиковые карты пользователя (комплексный компонент)

Описание sale.personal.cc

Комплексный компонент используется для управления пластиковыми картами текущего пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Пластиковые карты пользователя.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры[/dw][di]
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • list - страница со списком карт;
  • detail - страница редактирования пластиковой карты.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
[/di]: SEF_FOLDER, SEF_URL_TEMPLATES.
Дополнительные настройки
Количество на одной странице | PER_PAGE | Указывается количество пластиковых карт, отображаемых на одной странице. Все остальные карты будут выведены с помощью постраничной навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Мои пластиковые карты.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.personal.cc","",Array(
        "SEF_MODE" => "Y",
        "PER_PAGE" => 20,
        "SET_TITLE" => "Y",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "list" => "index.php",
            "detail" => "detail.php?ID=#ID#"
        ),
        "VARIABLE_ALIASES" => Array(
            "list" => Array(),
            "detail" => Array(
                "ID" => "ID"
            ),
        )
    ),
);?>


Подписки пользователя (комплексный компонент)

Описание sale.personal.subscribe

Комплексный компонент используется для управления подписками текущего пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Подписки пользователя.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры[/dw][di]
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • list - страница со списком подписок;
  • cancel - страница отмены подписки.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
[/di]: SEF_FOLDER, SEF_URL_TEMPLATES.
Дополнительные настройки
Количество на одной странице | PER_PAGE | Указывается количество подписок, отображаемых на одной странице. Все остальные подписки будут выведены с помощью постраничной навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Регулярные платежи.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:sale.personal.subscribe","",Array(
        "SEF_MODE" => "Y",
        "PER_PAGE" => 20,
        "SET_TITLE" => "Y",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "list" => "subscribe_list.php",
            "cancel" => "subscribe_cancel.php?ID=#ID#"
        ),
        "VARIABLE_ALIASES" => Array(
            "list" => Array(),
            "detail" => Array(
                "ID" => "ID"
            ),
            "cancel" => Array(
                "ID" => "ID"
            ),
        )
    )
);?>


Подробная информация о заказе

Одностраничный компонент выводит подробную информацию по заказу. Компонент стандартный и входит в дистрибутив модуля.

Описание sale.personal.order.detail

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Подробная информация о заказе.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Не показывать свойства для типа плательщика <название_плательщика> | PROP_<N> | Для каждого типа плательщика <название_плательщика> (N - идентификатор типа плательщика) задается массив свойств, которые не должны быть отображены.
Внешний вид
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Ограничение по ширине для анонсного изображения, px | PICTURE_WIDTH | Указывается ширина (в пикселах) изображения товара при подробном просмотре заказа.
Ограничение по высоте для анонсного изображения, px | PICTURE_HEIGHT | Указывается высота (в пикселах) изображения товара при подробном просмотре заказа.
Тип масштабирования PICTURE_RESAMPLE_TYPE Из выпадающего списка выбирается тип масштабирования изображений:
  • С сохранением пропорций, улучшенная обработка;
  • С сохранением пропорций;
  • С обрезанием.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Страница со списком заказов | PATH_TO_LIST | Указывается путь к странице со списком заказов. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Список заказов.
Страница отмены заказа | PATH_TO_CANCEL | Указывается путь к странице отмены заказа. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Отмена заказа. Необходимо передавать идентификатор заказа в качестве параметра.
Страница повторения заказа | PATH_TO_COPY | Указывается путь к странице повтора заказа. Можно указать путь к странице, где происходит копирование заказа. Если указать путь к корзине, то заказ будет скопирован и можно будет начать оформление заказа.
Страница подключения платежной системы | PATH_TO_PAYMENT | Указывается путь к странице подключения платежной системы. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Подключение платежной системы.
Идентификатор заказа | ID | Указывается код, результатом которого является получение идентификатора заказа. По умолчанию ={$ID}.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Мой заказ № <идентификатор_заказа>.
Дополнительные свойства инфоблока | CUSTOM_SELECT_PROPS | Задаются коды свойств инфоблока, которые необходимо вывести при детальном просмотре заказа. Следует задавать для вывода только строковые и числовые типы свойств.
Запретить смену платежной системы у заказов в статусах | RESTRICT_CHANGE_PAYSYSTEM | Указываются статусы заказов по достижении которых нельзя сменить платёжную систему.
Пересчитывать заказ после смены платежной системы | ORDER_REFRESH_PRICES | Разрешение на пересчёт заказа после смены платёжной системы
Разрешить оплату с внутреннего счета | ALLOW_INNER | Разрешение на оплату с внутреннего счёта
Разрешить оплату с внутреннего счета только в полном объеме | ONLY_INNER_FULL | Разрешение на оплату с внутреннего счёта при условии наличия на счёте полной суммы заказа.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.personal.order.detail","",Array(
        "PATH_TO_LIST" => "order_list.php",
        "PATH_TO_CANCEL" => "order_cancel.php",
        "PATH_TO_PAYMENT" => "payment.php",
        "PATH_TO_COPY" => "",
        "ID" => $ID,
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y",
        "SET_TITLE" => "Y",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "PICTURE_WIDTH" => "110",
        "PICTURE_HEIGHT" => "110",
        "PICTURE_RESAMPLE_TYPE" => "1",
        "CUSTOM_SELECT_PROPS" => array(),
        "PROP_1" => Array(),
        "PROP_2" => Array()
    )
);?>


Подробная информация о заказе для почты

Описание sale.personal.order.detail.mail

Одностраничный компонент выводит подробную информацию по заказу для почты. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Подробная информация о заказе для почты.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор заказа | ID | Указывается идентификатор заказа или код, результатом которого является получение идентификатора заказа.
Показывать состав заказа | SHOW_ORDER_BASKET | [Y|N] При отмеченной опции будет отображено содержимое заказа.
Показывать общие данные заказа | SHOW_ORDER_BASE | [Y|N] При отмеченной опции будут отображены общие данные по заказу: статус заказа, на какую сумму, отменен или нет.
Показывать данные учетной записи | SHOW_ORDER_USER | [Y|N] При отмеченной опции будут отображены параметры учетной записи: имя, логин, e-mail.
Показывать параметры заказа | SHOW_ORDER_PARAMS | [Y|N] При отмеченной опции будет отображен блок "Параметры заказа".
Показывать личные данные | SHOW_ORDER_BUYER | [Y|N] При отмеченной опции будет отображен блок "Личные данные", содержащий информацию о покупателе.
Показывать данные для доставки | SHOW_ORDER_DELIVERY | [Y|N] При отмеченной опции будут показаны данные для доставки товара.
Показывать параметры доставки и оплаты | SHOW_ORDER_PAYMENT | [Y|N] При отмеченной опции будет отображена информация о платежной системе, службе доставки и оплачен ли заказ.
Показывать итоговую сумму | SHOW_ORDER_SUM | [Y|N] При отмеченной опции будет отображена итоговая сумма по заказу.
Выводимые колонки состава заказа | CUSTOM_SELECT_PROPS | Выбираются колонки, которые должны быть показаны в таблице содержимого заказа.
Не показывать свойства для типа плательщика <название_плательщика> | PROP_<N> | Для каждого типа плательщика <название_плательщика> (N - идентификатор типа плательщика) задается массив свойств, которые не должны быть отображены.
Внешний вид
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Ограничение по ширине для анонсного изображения, px | PICTURE_WIDTH | Указывается ширина (в пикселах) изображения товара при подробном просмотре заказа.
Ограничение по высоте для анонсного изображения, px | PICTURE_HEIGHT | Указывается высота (в пикселах) изображения товара при подробном просмотре заказа.
Тип масштабирования PICTURE_RESAMPLE_TYPE Из выпадающего списка выбирается тип масштабирования изображений:
  • С сохранением пропорций, улучшенная обработка;
  • С сохранением пропорций;
  • С обрезанием.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Страница со списком заказов | PATH_TO_LIST | Указывается путь к странице со списком заказов. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Список заказов.
Страница отмены заказа | PATH_TO_CANCEL | Указывается путь к странице отмены заказа. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Отмена заказа. Необходимо передавать идентификатор заказа в качестве параметра.
Страница подключения платежной системы | PATH_TO_PAYMENT | Указывается путь к странице подключения платежной системы. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Подключение платежной системы.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.personal.order.detail.mail",
    "",
    Array(
        "ID" => "{#ORDER_ID#}",
        "SHOW_ORDER_BASKET" => "Y",
        "SHOW_ORDER_BASE" => "Y",
        "SHOW_ORDER_USER" => "Y",
        "SHOW_ORDER_PARAMS" => "Y",
        "SHOW_ORDER_BUYER" => "Y",
        "SHOW_ORDER_DELIVERY" => "Y",
        "SHOW_ORDER_PAYMENT" => "Y",
        "SHOW_ORDER_SUM" => "Y",
        "CUSTOM_SELECT_PROPS" => array("NAME", "DISCOUNT_PRICE_PERCENT_FORMATED", "PRICE_FORMATED", "QUANTITY"),
        "PROP_1" => array(),
        "PROP_2" => array(),
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "PICTURE_WIDTH" => "110",
        "PICTURE_HEIGHT" => "110",
        "PICTURE_RESAMPLE_TYPE" => "1",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "PATH_TO_LIST" => "/personal/order/index.php",
        "PATH_TO_CANCEL" => "/personal/order/cancel.php?ORDER_ID=#ORDER_ID#",
        "PATH_TO_PAYMENT" => "/payment/payment.php"
    )
);?>


Профили пользователя (комплексный компонент)

Описание sale.personal.profile

Комплексный компонент служит для управления профилями текущего пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Профили пользователя.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры[/dw][di]
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • list - страница со списком профилей;
  • detail - страница с профилем подробно.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
[/di] : SEF_FOLDER, SEF_URL_TEMPLATES.
Дополнительные настройки
Количество на одной странице | PER_PAGE | Указывается количество профилей, отображаемых на одной странице. Все остальные профили будут выведены с помощью постраничной навигации.
Использовать расширенный выбор местоположения | USE_AJAX_LOCATIONS | [Y|N] При отмеченной опции будет использована расширенная форма выбора местоположений, которая может быть построена с помощью компонента AJAX-местоположения.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Профили.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.personal.profile","",Array(
        "SEF_MODE" => "Y",
        "PER_PAGE" => 20,
        "USE_AJAX_LOCATIONS" => "Y",
        "SET_TITLE" => "Y",
        "SEF_FOLDER" => "/",
        "SEF_URL_TEMPLATES" => Array(
            "list" => "profile_list.php",
            "detail" => "profile_detail.php?ID=#ID#"
        ),
        "VARIABLE_ALIASES" => Array(
            "list" => Array(),
            "detail" => Array(
                "ID" => "ID"
            ),
        )
    )
);?>


Редактирование пластиковых карт

Описание sale.personal.cc.detail

Компонент является одностраничным и служит для редактирования пластиковых карт пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Редактирование пластиковых карт.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Страница со списком пластиковых карт | PATH_TO_LIST | Указывается путь к странице со списком пластиковых карт. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Список пластиковых карт текущего пользователя.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Добавление новой карты.
Идентификатор пластиковой карты | ID | Указывается код, результатом которого является получение идентификатора пластиковой карты. По умолчанию ={$ID}.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.personal.cc.detail","",Array(
        "PATH_TO_LIST" => "credit_cards.php",
        "ID" => $ID,
        "SET_TITLE" => "Y"
    ),
);?>


Редактирование профиля

Описание sale.personal.profile.detail

Одностраничный компонент позволяет редактировать профиль пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Редактирование профиля.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Получить список местоположений для устаревших версий шаблона | COMPATIBLE_LOCATION_MODE | [Y|N] При отмеченной опции получение списка местоположений будет осуществляться через CSaleLocation::GetList [image] . Опцию включать не рекомендуется, она оставлена для совместимости.
Дополнительные настройки
Страница со списком профилей | PATH_TO_LIST | Указывается путь к странице со списком профилей. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Cписок профилей текущего пользователя.
Страница редактирования профиля | PATH_TO_DETAIL | Указывается путь к странице редактирования профиля. В качестве параметра необходимо указать идентификатор профиля. Если поле пусто, то пользователь после применения изменений останется на той же странице.
Использовать расширенный выбор местоположения | USE_AJAX_LOCATIONS | [Y|N] При отмеченной опции будет использована расширенная форма выбора местоположений, которая может быть построена с помощью компонента AJAX-местоположения.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Профиль № <идентификатор_пользователя>.
Идентификатор профиля | ID | Указывается код, результатом которого является получение идентификатора профиля пользователя. По умолчанию ={$ID}.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.personal.profile.detail","",Array(
        "COMPATIBLE_LOCATION_MODE" => "N",
        "PATH_TO_LIST" => "profile_list.php",
        "PATH_TO_DETAIL" => "profile_detail.php?ID=#ID#",
        "ID" => $ID,
        "USE_AJAX_LOCATIONS" => "Y",
        "SET_TITLE" => "Y"
    ),
);?>


Список заказов

Описание sale.personal.order.list

Одностраничный компонент выводит фильтр и список заказов пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Список заказов.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Внешний вид
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Страница c подробной информацией о заказе | PATH_TO_DETAIL | Указывается путь к странице с подробной информацией о заказе. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Подробная информация о заказе. Необходимо передавать идентификатор заказа в качестве параметра.
Страница повторения заказа | PATH_TO_COPY | Указывается путь к странице повтора заказа. Можно указать путь к странице, где происходит копирование заказа. Если указать путь к корзине, то заказ будет скопирован и можно будет начать оформление заказа.
Страница отмены заказа | PATH_TO_CANCEL | Указывается путь к странице, где можно отменить заказ. Страница может быть создана с помощью компонента Отмена заказа. Необходимо передавать идентификатор заказа в качестве параметра.
Страница подключения платежной системы | PATH_TO_PAYMENT | Указывается путь к странице оплат от корня сайта. Если страница находится в текущей директории, то достаточно указать ее название.
Страница корзины | PATH_TO_BASKET | Указывается путь к корзине пользователя. Страница может быть создана с помощью компонента Корзина.
Путь к каталогу | PATH_TO_CATALOG | Указывается путь к каталогу.
Количество заказов, выводимых на страницу | ORDERS_PER_PAGE | Указывается количество заказов, отображаемых на одной странице. Все остальные заказы будут выведены с помощью постраничной навигации.
Идентификатор заказа | ID | Указывается код, результатом которого является получение идентификатора заказа. По умолчанию ={$ID}.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Мои заказы.
Сохранять установки фильтра в сессии пользователя | SAVE_IN_SESSION | [Y|N] При отмеченной опции установки фильтра будут сохранены в сессии пользователя.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Перенести в историю заказы в статусах | HISTORIC_STATUSES | Указываются статусы, которые будут использоваться при фильтрации по истории. Если заказ находится в одном из выбранных статусов, то в списке всех заказов он показан не будет, а будет доступен в истории заказов.
Запретить смену платежной системы у заказов в статусах | RESTRICT_CHANGE_PAYSYSTEM | Указываются статусы заказов по достижении которых нельзя сменить платёжную систему.
Сортировка заказов | DEFAULT_SORT, | Указание по какому параметру производить сортировку заказов
Разрешить оплату с внутреннего счета | ALLOW_INNER | [Y\N] Разрешает оплату с внутреннего счёта пользователя.
Разрешить оплату с внутреннего счета только в полном объеме | ONLY_INNER_FULL | [Y\N] При установленном флажке оплата со счёта пользователя возможно только если суммы счёта хватает на полную оплату заказа.
Цвет статуса название_статуса | STATUS_COLOR_код_статуса | Указывается цвет, которым будет выделен текущий статус заказа.
Цвет отменённых заказов | STATUS_COLOR_PSEUDO_CANCELLED | Указывается цвет, которым будет выделен статус отмененного заказа.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.personal.order.list","",Array(
        "STATUS_COLOR_N" => "green",
        "STATUS_COLOR_P" => "yellow",
        "STATUS_COLOR_F" => "gray",
        "STATUS_COLOR_PSEUDO_CANCELLED" => "red",
        "PATH_TO_DETAIL" => "order_detail.php?ID=#ID#",
        "PATH_TO_COPY" => "basket.php",
        "PATH_TO_CANCEL" => "order_cancel.php?ID=#ID#",
        "PATH_TO_BASKET" => "basket.php",
        "PATH_TO_PAYMENT" => "payment.php",
        "ORDERS_PER_PAGE" => 20,
        "ID" => $ID,
        "SET_TITLE" => "Y",
        "SAVE_IN_SESSION" => "Y",
        "NAV_TEMPLATE" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y",
        "HISTORIC_STATUSES" => "F",
        "ACTIVE_DATE_FORMAT" => "d.m.Y"
    )
);?>


Список пластиковых карт текущего пользователя

Описание sale.personal.cc.list

Одностраничный компонент выводит список пластиковых карт текущего пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Список пластиковых карт текущего пользователя.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Страница с подробной информацией о пластиковой карте | PATH_TO_DETAIL | Указывается путь к странице с подробной информацией о карте. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Редактирование пластиковых карт.
Количество карт, выводимых на странице | PER_PAGE | Указывается количество карт, отображаемых на одной странице. Все остальные карты будут выведены с помощью постраничной навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Мои пластиковые карты.

Пример вызова

<$APPLICATION->IncludeComponent("bitrix:sale.personal.cc.list","",Array(
        "PATH_TO_DETAIL" => "card_detail.php",
        "PER_PAGE" => 20,
        "SET_TITLE" => "Y"
    ),
);?>


Список подписок текущего пользователя

Описание sale.personal.subscribe.list

Одностраничный компонент выводит список подписок текущего пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Список подписок текущего пользователя.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Страница отмены подписки | PATH_TO_CANCEL | Указывается путь к странице отмены подписки. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Отмена подписки. Необходимо передавать идентификатор подписки.
Количество подписок, выводимых на странице | PER_PAGE | Указывается количество подписок, отображаемых на одной странице. Все остальные подписки будут выведены с помощью постраничной навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Регулярные платежи.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.personal.subscribe.list","",Array(
        "PATH_TO_CANCEL" => "subscribe_cancel.php?ID=#ID#",
        "PER_PAGE" => 20,
        "SET_TITLE" => "Y"
    )
);?>


Список профилей текущего пользователя

Описание sale.personal.profile.list

Одностраничный компонент выводит список профилей текущего пользователя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Список профилей текущего пользователя.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Страница с подробной информацией о профиле | PATH_TO_DETAIL | Указывается путь к странице редактирования или просмотра профиля. Если страница находится в текущей директории, то достаточно указать ее название. Страница может быть создана с помощью компонента Редактирование профиля.
Количество профилей, выводимых на странице | PER_PAGE | Указывается количество профилей, отображаемых на одной странице. Все остальные профили будут выведены с помощью постраничной навигации.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Профили.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.personal.profile.list","",Array(
        "PATH_TO_DETAIL" => "profile_detail.php",
        "PER_PAGE" => 20,
        "SET_TITLE" => "Y"
    )
);?>


Счета текущего пользователя

Описание sale.personal.account

Одностраничный компонент отображает состояние внутреннего счета текущего пользователя в доступной валюте. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Персональный раздел > Счета текущего пользователя.

Компонент относится к модулю Интернет-магазин.

Ограничения для редакции "Малый бизнес": компонент не будет выводить покупателю информацию о его остатке на счете.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Мой пользовательский счет свободных средств.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.personal.account","",Array(
        "SET_TITLE" => "Y"
    )
);?>


Экспорт заказов

Подраздел предназначен для экспорта заказов в "1С:Предприятие" и содержит следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Экспорт заказов в "1С:Предприятие" | sale.export.1c | Экспортирует заказы в "1С:Предприятие" в формате CommerceML v2.


Экспорт заказов в "1С:Предприятие"

Описание sale.export.1c

Компонент служит для экспорта заказов в "1С:Предприятие" в формате CommerceML v2. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Экспорт заказов > Экспорт заказов в "1С:Предприятие".

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Сайт, заказы которого выгружать в "1С:Предприятие" | SITE_LIST | Указывается сайт(ы), заказы которого(ых) будут выгружены. Привязка может производиться либо к текущему сайту, либо к одному определённому сайту из имеющихся в системе.
Создавать новые заказы и контрагенты из 1С | IMPORT_NEW_ORDERS | Y|N] При отмеченной опции новые заказы и контрагенты из 1С будут добавляться на сайт при выполнении процедуры обмена заказами.
Сайт, на который добавлять новые заказы и контрагенты | SITE_NEW_ORDERS | Указываются сайты, на которые будут добавляться новые заказы и контрагенты.
Выгружать только оплаченные заказы | EXPORT_PAYED_ORDERS | [Y|N] При отмеченной опции будут выгружаться только оплаченные заказы.
Выгружать только заказы c разрешенной доставкой | EXPORT_ALLOW_DELIVERY_ORDERS | [Y|N] При отмеченной опции будут выгружаться только заказы c разрешенной доставкой.
Менять статусы заказов по информации из 1С | CHANGE_STATUS_FROM_1C | [Y|N] При отмеченной опции статусы заказов на сайте будут изменяться в соответствии с данными из 1С (т.е. изменяется статус заказа в 1С и после выполнения обмена данными статус заказа на сайте будет изменен на тот, который был задан в 1С).
Выгружать заказы начиная со статуса EXPORT_FINAL_ORDERS Указывается статус, начиная с которого будут выгружаться товары:
  • N - Принят;
  • F - Выполнен.
Заменять валюту при выгрузке в "1С:Предприятие" на | REPLACE_CURRENCY | При выгрузке валюта товаров будет заменена на указанную. Конвертация при этом не происходит.
Группы пользователей, которым разрешена выгрузка | GROUP_PERMISSIONS | Указывается группа(-ы), пользователи которых имеют права на выгрузку заказов в 1С.
Использовать сжатие zip, если доступно | USE_ZIP | [Y|N] При отмеченной опции данные сжимаются ZIP форматом (если доступно). Это позволяет заметно уменьшить размер файлов.
Интервал одного шага в секундах (0 - выполнять загрузку за один шаг) | INTERVAL | Указывается интервал одного шага в секундах при экспорте заказов в 1С. 0 - выполнять загрузку за один шаг.
Размер единовременно загружаемой части файла (в байтах) | FILE_SIZE_LIMIT | Указывается размер единовременно загружаемой части файла в байтах.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.export.1c","",Array(
        "SITE_LIST" => "s1",
        "IMPORT_NEW_ORDERS" => "N",
        "SITE_NEW_ORDERS" => "",
        "CHANGE_STATUS_FROM_1C" => "N",
        "EXPORT_PAYED_ORDERS" => "Y",
        "EXPORT_ALLOW_DELIVERY_ORDERS" => "Y",
        "EXPORT_FINAL_ORDERS" => "N",
        "REPLACE_CURRENCY" => "руб.",
        "GROUP_PERMISSIONS" => Array("1"),
        "USE_ZIP" => "Y",
        "INTERVAL" => "30",
        "FILE_SIZE_LIMIT" => "204800"
    )
);?>


Информация о товарах

Подраздел предназначен для организации работы с товарами и содержит следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Выбор товара для получения подарка | sale.gift.main.products | Отображает блок товаров, которые нужно купить для получения предложенного подарка
Подарки к товарам в корзине | sale.gift.basket | Отображает товары, которые будут предложены в качестве подарков к текущей корзине покупателя
Подарки к товарам в корзине (устаревший) | sale.gift.basket | Служит для отображения товаров, которые будут предложены в качестве подарков к текущей корзине покупателя
Подарки к товарам конкретного раздела | sale.products.gift.section | Отображает подарки к товарам заданного раздела
Подарки к выбранному товару | sale.gift.main.products | Отображает подарки к конкретному товару
Просмотренные товары | catalog.products.viewed | Выводит просмотренные пользователем товары с указанным набором свойств
Рекомендуемые товары | catalog.recommended.products | Для товара выводит список рекомендуемых к покупке вместе с ним товаров
Генерация купона на товар для почты | sale.discount.coupon.mail | Генерирует купон для правила корзины с соответствии с заданными параметрами
Персональные рекомендации для почты | sale.discount.coupon.mail | Выводит список рекомендованных товаров для почты
Самые продаваемые товары | sale.bestsellers | Выводит список самых продаваемых товаров
Сопутствующие заказу товары для почты | sale.bigdata.followup.mail | Выводит товары, сопутствующие ранее заказанным товарам
С этим товаром покупают | sale.recommended.products | Выводит товары, которые были куплены вместе с просматриваемым товаром, с учетом минимального количества покупок
Подписка на товары | catalog.product.subscribe | Отображает форму подписки на товар
Список товаров на которые вы подписаны | catalog.product.subscribe.list | Отображает список товаров, на которые подписан пользователь
Подарки к товарам конкретного раздела (устаревший) | sale.gift.section | Служит для отображения подарков к товарам заданного раздела
Персональные рекомендации (устаревший) | catalog.bigdata.products | Выводит рекомендованные сервисом 1C-Битрикс BigData товары с указанным набором свойств, ценами и другими его параметрами


Выбор товара для получения подарка

Описание sale.gift.main.products

Компонент служит для отображения блока товаров, которые нужно купить для получения предложенного подарка. Компонент стандартный и входит в дистрибутив модуля.

Примечание. Товары в этом блоке отображаются только в том случае, если в настройках правила предоставления подарка [image] в Дополнительных условиях указано только одно условие (Товар = или Раздел =).

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Выбор товара для получения подарка.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается инфоблок, из которого будет выводиться список товаров.
ID торгового предложения, по которому выводить товары, к которым торговое предложение является подарком | OFFER_ID | Указывается идентификатор торгового предложения, по которому выводить товары, к которым торговое предложение является подарком.
ID элемента, по которому выводить товары, к которым торговое предложение является подарком | ELEMENT_ID | Указывается идентификатор элемента, по которому выводить товары, к которым торговое предложение является подарком.
Источник данных
Свойства раздела | SECTION_USER_FIELDS | Указываются свойства раздела, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, свойства не будут выведены.
По какому полю сортируем элементы ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • CATALOG_AVAILABLE – доступность на складах.
Порядок сортировки элементов ELEMENT_SORT_ORDER Задается порядок сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.
Поле для второй сортировки элементов ELEMENT_SORT_FIELD2 Указывается поле, по которому будет происходить вторая сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • CATALOG_AVAILABLE – доступность на складах.
Порядок второй сортировки элементов ELEMENT_SORT_ORDER2 Задается порядок второй сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.
Имя массива со значениями фильтра для фильтрации элементов | FILTER_NAME | Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Показывать элементы подразделов раздела | INCLUDE_SUBSECTIONS | [Y|N] При отмеченной опции будут отображены элементы подразделов раздела.
Показывать все элементы, если не указан раздел | SHOW_ALL_WO_SECTION | [Y|N] При отмеченной будут отображены все элементы, если не указан раздел.
Не отображать товары, которых нет на складах | HIDE_NOT_AVAILABLE | [Y|N] При отмеченной опции будут скрыты товары, для которых общее доступное количество меньше либо равно нулю (не остатки по складам), включен количественный учет и не разрешена покупка при отсутствии товара.
Внешний вид
Количество элементов на странице | PAGE_ELEMENT_COUNT | Указывается количество элементов, отображаемых на одной странице. Все элементы будут выведены с помощью постраничной навигации.
Количество элементов выводимых в одной строке таблицы | LINE_ELEMENT_COUNT | Указывается количество элементов выводимых в одной строке таблицы.
Свойства | PROPERTY_CODE | Указываются свойства инфоблока, которые будут отображены при показе элементов в таблице. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Поля предложений | OFFERS_FIELD_CODE | Выбираются поля предложений. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений | OFFERS_PROPERTY_CODE | Указываются свойства предложений. Можно добавлять свои. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
По какому полю сортируем предложения товара | OFFERS_SORT_FIELD | Указывается поле, по которому сортируется весь список предложений товара. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Порядок сортировки предложений товара | OFFERS_SORT_ORDER | Выбирается как сортировать предложения товара: по возрастанию, или по убыванию. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Поле для второй сортировки предложений товара | OFFERS_SORT_FIELD2 | Указывается поле, по которому выполняется вторая сортировка списка предложений товара. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Порядок второй сортировки предложений товара | OFFERS_SORT_ORDER2 | Выбирается порядок второй сортировки предложения товара: по возрастанию, или по убыванию. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Максимальное количество предложений для показа | OFFERS_LIMIT | Выставляется максимальное для вывода на страницу число предложений (0 - все).
Установить фоновую картинку для шаблона из свойства BACKGROUND_IMAGE Указывается свойство, в котором хранится картинка для фона.

Свойство должно быть немножественным типа Файл.

Важно! В шаблоне сайта должна быть реализована поддержка этого функционала: в необходимом вам теге должно быть прописано:
<?=$APPLICATION->ShowProperty("backgroundImage")?>
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается путь к странице с детальным содержимым раздела.
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
Название переменной, в которой передается код группы | SECTION_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор раздела.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции включается поддержка ЧПУ и становятся доступными поля настройки ЧПУ; станут доступны [dw]дополнительные поля.[/dw][di]
Правило для обработки | SEF_RULE | Указывается правило обработки вызова страницы. Для создания правила следует использовать шаблоны, доступные по кнопке [...].
Путь из символьных кодов раздела | SECTION_CODE_PATH | Задается путь из символьных кодов раздела инфоблока.
[/di]
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлен заголовок раздела.
Устанавливать заголовок окна браузера SET_BROWSER_TITLE [Y|N] При отмеченной опции будет установлен заголовок окна браузера по заданному SEO-шаблону META TITLE (см. закладку "SEO" в инфоблоке) или из свойства (см. параметр [dw]"Установить заголовок окна браузера из свойства"[/dw][di]
Установить заголовок окна браузера из свойства BROWSER_TITLE Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится заголовок окна браузера.
[/di]).
Устанавливать ключевые слова страницы SET_META_KEYWORDS [Y|N] При отмеченной опции будут установлены ключевые слова страницы по заданному SEO-шаблону META KEYWORDS (см. закладку "SEO" в инфоблоке) или из свойства (см. параметр [dw]"Установить ключевые слова страницы из свойства"[/dw][di]
Установить ключевые слова страницы из свойства META_KEYWORDS Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
[/di]).
Устанавливать описание страницы SET_META_DESCRIPTION [Y|N] При отмеченной опции будет установлено описание страницы по заданному SEO-шаблону META DESCRIPTION (см. закладку "SEO" в инфоблоке) или из свойства (см. параметр [dw]"Установить описание страницы из свойства"[/dw][di]
Установить описание страницы из свойства META_DESCRIPTION Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
[/di]).
Устанавливать в заголовках ответа время модификации страницы | SET_LAST_MODIFIED | [Y|N] При отмеченной опции http-ответ сервера будет содержать время последнего изменения страницы (заголовок Last-Modified [image]).
Использовать основной раздел для показа элемента USE_MAIN_ELEMENT_SECTION [Y|N] Если опция отмечена, то при переходе на детальную страницу элемента в адресную строку браузера будет подставляться тот путь, который формируется при просмотре элемента через основной раздел, даже если элемент открыт через другой родительский его раздел.

Если опция не отмечена, про ссылка на детальную страницу элемента формируется с учетом того раздела, через который элемент открыт на просмотр.

Рассмотрим пример, когда опция в настройках отмечена. Допустим, что элемент с символьным кодом marketing привязан к двум разделам с кодами bisness и science соответственно, причем раздел с кодом bisness является основным. В результате, если пользователь пришел в раздел science и кликнул на элемент marketing, то в строке браузера вместо http://mysite.ru/catalog/science/marketing/ будет отображено http://mysite.ru/catalog/bisness/marketing/.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции название или заголовок (если задан в настройках SEO) раздела будет включен в строку навигации.
Кешировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Настройки действий
Название переменной, в которой передается действие | ACTION_VARIABLE | Задается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Использовать вывод цен с диапазонами | USE_PRICE_COUNT | [Y/N] При отмеченной опции будут отображаться цены всех типов на товары.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах; станет доступно [dw]дополнительное поле[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты в которой будут отображаться цены.
[/di]. При выборе этой опции кеш компонента будет автоматически сбрасываться при изменении курсов валют тех товаров, что показываются компонентом. К примеру, если выбрана конвертация в рубли, а цены в инфоблоке сохранены в евро, то кеш сбросится при изменении курса евро или рубля. Изменения остальных валют на кеш не окажут влияния.
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Разрешить указание количества товара USE_PRODUCT_QUANTITY [Y|N] При отмеченной опции будет разрешен вывод количества товара; нужно будет указать [dw]дополнительный параметр[/dw][di]
Название переменной, в которой передается количество товара PRODUCT_QUANTITY_VARIABLE Задается имя переменной, в которой будет передаваться количество товара.
[/di].
Добавлять в корзину свойства товаров и предложений ADD_PROPERTIES_TO_BASKET [Y|N] При отмеченной опции становятся доступными настройки выбора свойств товаров и предложений для передачи их в корзину и заказ; нужно будет указать [dw]дополнительные параметры[/dw][di]
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить добавлять в корзину товары, у которых заполнены не все характеристики | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
Характеристики товара | PRODUCT_PROPERTIES | Указываются характеристики товара.
Свойства предложений, добавляемые в корзину | OFFERS_CART_PROPERTIES | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использоать клавишу Ctrl. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
[/di].
Настройки постраничной навигации
Шаблон постраничной навигации | PAGER_TEMPLATE | Указывается название шаблона постраничной навигации. Если поле пусто, то выбирается шаблон по умолчанию (.default).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение по элементам.
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться, даже если все элементы помещаются на одной странице.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц в секундах для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все элементы раздела.
Включить обработку ссылок PAGER_BASE_LINK_ENABLE [Y|N] При отмеченной опции доступна обработка ссылок для постраничной навигации; станут доступны [dw]дополнительные поля[/dw][di]
Url для построения ссылок (по умолчанию - автоматически) | PAGER_BASE_LINK | Задается адрес для построения ссылок. Если в параметре ничего не указывать, то адрес будет построен автоматически.
Имя массива с переменными для построения ссылок в постраничной навигации | PAGER_PARAMS_NAME | Задается имя переменной, в которой передается массив с переменными для построения ссылок компонентом постраничной навигации.
[/di].
Настройки 404 ошибки
Устанавливать статус 404 | SET_STATUS_404 | [Y|N] Опция служит для включения обработки ошибки 404 в компоненте.
Показ специальной страницы SHOW_404 [Y|N] При отмеченной опции будет показана [dw]специальная страница[/dw][di]
Страница для показа (по умолчанию /404.php) FILE_404 Задается адрес страницы, которая будет отображаться при возникновении ошибки 404.
[/di] в случае возникновения ошибки 404, в противном случае - будет отображено [dw]специальное сообщение[/dw][di]
Сообщение для показа (по умолчанию из компонента) MESSAGE_404 Задается сообщение, которое будет показано в случае возникновения ошибки 404. Если ничего не указывать, то будет использоваться стандартное сообщение из компонента.
[/di] .
Специальные настройки
Не подключать js-библиотеки в компоненте | DISABLE_INIT_JS_IN_COMPONENT | [Y|N] При отмеченной опции js-библиотека popup не будет подключаться в самом компоненте. Если шаблон компонента основан на шаблоне решения "Интернет-магазин" версии 12.5, то использование этой опции приведет к ограничению функционала.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.gift.main.products",
    "",
    Array(
        "ACTION_VARIABLE" => "action",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "ADD_SECTIONS_CHAIN" => "N",
        "AJAX_MODE" => "N",
        "AJAX_OPTION_ADDITIONAL" => "",
        "AJAX_OPTION_HISTORY" => "N",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "BACKGROUND_IMAGE" => "-",
        "BASKET_URL" => "/personal/basket.php",
        "BROWSER_TITLE" => "-",
        "CACHE_FILTER" => "N",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "36000000",
        "CACHE_TYPE" => "A",
        "COMPONENT_TEMPLATE" => ".default",
        "CONVERT_CURRENCY" => "Y",
        "CURRENCY_ID" => "RUB",
        "DETAIL_URL" => "/example/#SECTION_ID#/#ELEMENT_ID#",
        "DISABLE_INIT_JS_IN_COMPONENT" => "N",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "DISPLAY_TOP_PAGER" => "N",
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_FIELD2" => "id",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_ORDER2" => "desc",
        "FILTER_NAME" => "arrFilter",
        "HIDE_NOT_AVAILABLE" => "N",
        "IBLOCK_ID" => "2",
        "IBLOCK_TYPE" => "catalog",
        "INCLUDE_SUBSECTIONS" => "Y",
        "LINE_ELEMENT_COUNT" => "3",
        "MESSAGE_404" => "",
        "META_DESCRIPTION" => "-",
        "META_KEYWORDS" => "-",
        "OFFERS_CART_PROPERTIES" => array("ARTNUMBER","COLOR_REF","SIZES_SHOES","SIZES_CLOTHES"),
        "OFFERS_FIELD_CODE" => array("",""),
        "OFFERS_LIMIT" => "5",
        "OFFERS_PROPERTY_CODE" => array("COLOR_REF","SIZES_SHOES","SIZES_CLOTHES",""),
        "OFFERS_SORT_FIELD" => "sort",
        "OFFERS_SORT_FIELD2" => "id",
        "OFFERS_SORT_ORDER" => "asc",
        "OFFERS_SORT_ORDER2" => "desc",
        "OFFER_ID" => $_REQUEST["OFFER_ID"],
        "PAGER_BASE_LINK_ENABLE" => "N",
        "PAGER_DESC_NUMBERING" => "N",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "N",
        "PAGER_SHOW_ALWAYS" => "N",
        "PAGER_TEMPLATE" => ".default",
        "PAGER_TITLE" => "Товары",
        "PAGE_ELEMENT_COUNT" => "30",
        "PARTIAL_PRODUCT_PROPERTIES" => "N",
        "PRICE_CODE" => array("BASE"),
        "PRICE_VAT_INCLUDE" => "Y",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_PROPERTIES" => array("MATERIAL"),
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PRODUCT_QUANTITY_VARIABLE" => "",
        "PROPERTY_CODE" => array("BRAND_REF","ARTNUMBER","MANUFACTURER","MATERIAL","COLOR",""),
        "SECTION_CODE_PATH" => "",
        "SECTION_ID_VARIABLE" => "SECTION_ID",
        "SECTION_URL" => "/example/#SECTION_ID#/",
        "SECTION_USER_FIELDS" => array("",""),
        "SEF_MODE" => "Y",
        "SEF_RULE" => "/example/#SECTION_ID#/",
        "SET_BROWSER_TITLE" => "Y",
        "SET_LAST_MODIFIED" => "N",
        "SET_META_DESCRIPTION" => "Y",
        "SET_META_KEYWORDS" => "Y",
        "SET_STATUS_404" => "N",
        "SET_TITLE" => "Y",
        "SHOW_404" => "N",
        "SHOW_ALL_WO_SECTION" => "N",
        "SHOW_PRICE_COUNT" => "1",
        "USE_MAIN_ELEMENT_SECTION" => "N",
        "USE_PRICE_COUNT" => "N",
        "USE_PRODUCT_QUANTITY" => "N"
    )
);?>


Подарки к товарам в корзине

Описание bitrix:sale.products.gift.basket

Компонент служит для отображения товаров, которые будут предложены в качестве подарков к текущей корзине покупателя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Подарки к товарам в корзине.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается инфоблок, из которого будет выводиться список товаров.
Источник данных
Показывать товары из раздела SHOW_FROM_SECTION [Y|N] При отмеченной опции просмотренные товары будут показываться из того раздела, который указан в [dw]следующих настройках[/dw][di]
ID раздела | SECTION_ID | Указывается идентификатор раздела, товары из которого должны быть показаны. Можно не указывать, если задан Код раздела.
Код раздела | SECTION_CODE | Указывается код раздела, товары из которого должны быть показаны. Можно не указывать, если задан ID раздела.
ID элемента, для которого будет выбран раздел | SECTION_ELEMENT_ID | Указывается идентификатор элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан Символьный код элемента, для которого будет выбран раздел.
Символьный код элемента, для которого будет выбран раздел | SECTION_ELEMENT_CODE | Указывается код элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан ID элемента, для которого будет выбран раздел.
Максимальная отображаемая глубина разделов | DEPTH | Параметр определяет максимальную глубину вложенности разделов, из которых будут показаны товары.
[/di] : ID раздела, Код раздела, ID элемента, для которого будет выбран раздел и Символьный код элемента, для которого будет выбран раздел. Если опция не отмечена, то данные настройки скрыты.
Недоступные товары HIDE_NOT_AVAILABLE Как отображать недоступные товары:
  • Отображать в общем списке
  • Отображать в конце
  • Не отображать
Недоступны товары, для которых количество меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Товар с торговыми предложениями считается доступным, если хоть одно предложение доступно.
Доступность товара не означает, что его можно купить. Для покупки должны быть цены тех типов, по которым клиент может покупать.
Недоступные торговые предложения HIDE_NOT_AVAILABLE_OFFERS Как отображать недоступные торговые предложения
  • Отображать только с возможностью подписки
  • Отображать все
  • Не отображать
Недоступны предложения, для которых количество меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Доступность предложения не означает, что его можно купить. Для покупки должны быть цены тех типов, по которым клиент может покупать.
Настройки сортировки
По какому полю сортируем элементы | ELEMENT_SORT_FIELD | Указывается поле, по которому будет происходить сортировка элементов текущего раздела.
Порядок сортировки элементов | ELEMENT_SORT_ORDER | В каком направлении будут отсортированы элементы, по возрастанию или по убыванию.
Поле для второй сортировки элементов | ELEMENT_SORT_FIELD2 | Указывается поле, по которому будет происходить вторичная сортировка элементов текущего раздела.
Порядок второй сортировки элементов | ELEMENT_SORT_ORDER2 | В каком направлении будут отсортированы элементы, по возрастанию или по убыванию во вторичной сортировке.
По какому полю сортируем предложения товара OFFERS_SORT_FIELD Указывается поле, по которому сортируется весь список предложений товара.

Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Порядок сортировки предложений товара OFFERS_SORT_ORDER Выбирается как сортировать предложения товара: по возрастанию, или по убыванию.

Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Поле для второй сортировки предложений товара OFFERS_SORT_FIELD2 Указывается поле, по которому выполняется вторая сортировка списка предложений товара.

Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Порядок второй сортировки предложений товара OFFERS_SORT_ORDER2 Выбирается направление второй сортировки предложений товара: по возрастанию, или по убыванию.

Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Внешний вид
Свойства товаров, отображаемые на мобильных устройствах | PROPERTY_CODE_MOBILE | Выбираются свойства инфоблока (перечень формируется из выбранных в параметре выше свойств), которые будут отображены в списке товаров при просмотре с мобильных устройств.
Поля предложений | OFFERS_FIELD_CODE | Выбираются поля предложений. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения элементов раздела. По умолчанию используется синяя схема (blue).
Вариант отображения товаров | PRODUCT_ROW_VARIANTS | В правой части поля выберите блок с подходящим вам вариантом отображения одной строки товаров на странице и перетащите его в левую часть.
Количество товаров на странице | PAGE_ELEMENT_COUNT | Отображается информация по количеству товаров на странице в соответствии с выбранным вариантом отображения товаров.
Выделять товары в списке ENLARGE_PRODUCT Выберите способ выделения товаров в списке:
  • по выбранному шаблону (строго) - товар будет выделятся строго по настроенному варианту отображения товаров;
  • по свойству, подгонять по шаблону (в этом случае возможно изменение сортировки элементов) - в списке будет выделяться тот товар, для которого заполнено указанное в параметре Выделять по выбранному свойству свойство.
Примечание: выделение товаров осуществляется в том случае, если для показа списка товаров выбран хотя бы один вариант вида:

Порядок отображения блоков товара PRODUCT_BLOCKS_ORDER Перетаскивая блоки, определите необходимый вам порядок следования блоков товара.

Схема отображения | PRODUCT_DISPLAY_MODE | Задается режим отображения товаров: простой (N) или расширенный (Y). Параметр доступен для инфоблока с торговыми предложениями.
Показывать слайдер для товаров SHOW_SLIDER [Y|N] При отмеченной опции для товаров будет использоваться слайдер для показа изображений, станет доступно [dw]дополнительное поле[/dw][di]
Интервал смены слайдов, мс SLIDER_INTERVAL Указывается интервал смены слайдов в миллисекундах. Параметры настраиваются, если отмечена опция Показывать слайдер для товаров.
[/di].
Показывать полосу прогресса | SLIDER_PROGRESS | [Y|N] При отмеченной опции будет отображаться полоса прогресса до начала показа следующего слайда.
Выделять по выбранному свойству ENLARGE_PROP Указывается то свойство товара, при наличии которого товар будет выделен в списке просмотренных (если позволяет вариант отображения товаров, см. поле Вариант отображения товаров).

Параметр доступен, если в параметре Выделять товары в списке указано значение по свойству (подгонять по шаблону).
Дополнительная картинка основного товара | ADD_PICT_PROP | Задается свойство, в котором хранится дополнительная картинка для основного товара.
Свойство меток товара | LABEL_PROP | Указываются свойство, в котором хранится метка товара (например, новинка).
Свойства меток товара, отображаемые на мобильных устройствах | LABEL_PROP_MOBILE | Выбираются свойства меток (перечень формируется из выбранных в параметре выше свойств), которые будут отображены в списке товаров при просмотре с мобильных устройств.
Расположение меток товара | LABEL_PROP_POSITION | Выберите подходящее место для меток на карточке товара.
Дополнительные картинки предложения | OFFER_ADD_PICT_PROP | Задается свойство, в котором хранится дополнительная картинка для торгового предложения. Параметр доступен для инфоблока с торговыми предложениями.
Разрешить оповещения для отсутствующих товаров | PRODUCT_SUBSCRIPTION | [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки.
Показывать процент скидки | SHOW_DISCOUNT_PERCENT | [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана.
Показывать старую цену | SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Показывать остаток товара SHOW_MAX_QUANTITY Укажите способ отображения остатка товара:
  • не показывать;
  • с отображением реального остатка - в этом случае необходимо настроить параметр [dw] Текст для остатка[/dw][di]
    Текст для остатка MESS_SHOW_MAX_QUANTITY Задается текст для отображения информации о наличии товара. Доступность данных параметров компонента определяется настройками параметра Показывать остаток товара.
    [/di];
  • с подменой остатка текстом - в этом случае необходимо настроить [dw]параметры[/dw][di]
    Текст для остатка | MESS_SHOW_MAX_QUANTITY | Задается текст для отображения информации о наличии товара.
    Значение, от которого происходит подмена | RELATIVE_QUANTITY_FACTOR | Указывается значение, меньше (больше) которого о количестве товара на складе будет отображаться выражение, что товара мало (много).
    Текст для значения больше | MESS_RELATIVE_QUANTITY_MANY | Задается текст, который будет отображаться при наличии товара в количестве большем, чем значение в параметре Значение, от которого происходит подмена.
    Текст для значения меньше | MESS_RELATIVE_QUANTITY_FEW | Задается текст, который будет отображаться при наличии товара в количестве меньшем, чем значение в параметре Значение, от которого происходит подмена..
    [/di] Текст для остатка, Значение, от которого происходит подмена, Текст для значения больше и Текст для значения меньше.
Показывать кнопку продолжения покупок во всплывающих окнах | SHOW_CLOSE_POPUP | [Y|N] При отмеченной опции будет отображаться кнопка Продолжить покупки во всплывающем окне, появляющемся после добавления товара в корзину.
Текст кнопки "Купить" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Добавить в корзину" | MESS_BTN_ADD_TO_BASKET | Задается текст, который должен быть отображен на кнопке добавления в корзину.
Текст кнопки "Уведомить о поступлении" | MESS_BTN_SUBSCRIBE | Задается текст, который должен быть отображен на кнопке уведомления о поступлении товара.
Текст кнопки "Подробнее" | MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Сообщение об отсутствии товара | MESS_NOT_AVAILABLE | Указывается текст, который будет отображаться при отсутствии товара и невозможности его купить.
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Настройки действий
Название переменной, в которой передается действие: ACTION_VARIABLE Указывается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Имя переменной, в которой будет передаваться ID товара.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара, кнопки В корзину и Купить показаны не будут.
Использовать вывод цен с диапазонами | SHOW_OLD_PRICE | При установленной опции для каждого товара выбираются все диапазоны цен, существующие у товара.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость. Если снята опция "Использовать вывод цен с диапазонами", т.е. для каждого товара выводится только одна цена, но в каталоге есть товары с расширенным управлением ценами (зависимость цены от количества), необходимо указать - для какого количества товара искать цену. На товары, чья цена не зависит от количества, эта опция не влияет.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах. При выборе данной опции станет активным [dw]дополнительное поле.[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты, в которой будут отображаться цены.
[/di]
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Разрешить указание количества товара | USE_PRODUCT_QUANTITY | [Y|N] При отмеченной опции будет разрешено указывать количества товара.
Добавлять в корзину свойства товаров и предложений ADD_PROPERTIES_TO_BASKET [Y|N] При отмеченной опции свойства товаров и предложений будут передаваться в корзину. Кроме того, становятся доступными для настройки [dw] следующие параметры:[/dw][di]
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить добавлять в корзину товары, у которых заполнены не все характеристики | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
[/di]Название переменной, в которой передаются характеристики товара и Разрешить добавлять в корзину товары, у которых заполнены не все характеристики.
Показывать кнопку добавления в корзину или покупки | ADD_TO_BASKET_ACTION | Выберите какая кнопка должна отображаться: кнопка покупки (BUY) или кнопка добавления в корзину (ADD).
Сравнение товаров
Разрешить сравнение товаров DISPLAY_COMPARE [Y|N] Включение функционала сравнения. После включения появляются дополнительные [dw]три поля.[/dw][di]
Путь к странице сравнения | COMPARE_PATH | Путь к странице с компонентом сравнения товаров. Если значение параметра пустое, будет использована текущая страница
Текст кнопки "Сравнить" | MESS_BTN_COMPARE | Замена текста по умолчанию для кнопки сравнения.
Уникальное имя для списка сравнения | COMPARE_NAME | Задается код для списка сравнения.
[/di]
Настройки аналитики
Отправлять данные электронной торговли в Google и Яндекс USE_ENHANCED_ECOMMERCE [Y|N] Включение опции. После включения станут доступны ещё [dw]два поля[/dw][di]
Имя контейнера данных | DATA_LAYER_NAME | Указываются свойства инфоблока, которые будут отображены в списке просмотренных товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Свойство брендов | BRAND_PROPERTY | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.
[/di]. Требуется дополнительная настройка в Google Analytics Enhanced Ecommerce и/или Яндекс.Метрике.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.products.gift.basket",
    "",
    Array(
        "ACTION_VARIABLE" => "action",
        "ADD_PICT_PROP" => "-",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "ADD_TO_BASKET_ACTION" => "ADD",
        "BASKET_URL" => "/personal/basket.php",
        "BRAND_PROPERTY" => "-",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "36000000",
        "CACHE_TYPE" => "A",
        "COMPARE_NAME" => "CATALOG_COMPARE_LIST",
        "COMPARE_PATH" => "",
        "CONVERT_CURRENCY" => "N",
        "DATA_LAYER_NAME" => "dataLayer",
        "DEPTH" => "2",
        "DETAIL_URL" => "",
        "DISPLAY_COMPARE" => "N",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_FIELD2" => "id",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_ORDER2" => "desc",
        "ENLARGE_PRODUCT" => "STRICT",
        "HIDE_NOT_AVAILABLE" => "N",
        "HIDE_NOT_AVAILABLE_OFFERS" => "N",
        "IBLOCK_ID" => "2",
        "IBLOCK_TYPE" => "catalog",
        "LABEL_PROP" => array("SPECIALOFFER"),
        "LABEL_PROP_MOBILE" => array(),
        "LABEL_PROP_POSITION" => "top-left",
        "MESS_BTN_ADD_TO_BASKET" => "В корзину",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_COMPARE" => "Сравнить",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_BTN_SUBSCRIBE" => "Подписаться",
        "MESS_NOT_AVAILABLE" => "Нет в наличии",
        "MESS_SHOW_MAX_QUANTITY" => "Наличие",
        "OFFERS_FIELD_CODE" => array("", ""),
        "OFFERS_SORT_FIELD" => "sort",
        "OFFERS_SORT_FIELD2" => "id",
        "OFFERS_SORT_ORDER" => "asc",
        "OFFERS_SORT_ORDER2" => "desc",
        "OFFER_ADD_PICT_PROP" => "MORE_PHOTO",
        "PAGE_ELEMENT_COUNT" => "4",
        "PARTIAL_PRODUCT_PROPERTIES" => "N",
        "PRICE_CODE" => array("BASE"),
        "PRICE_VAT_INCLUDE" => "Y",
        "PRODUCT_BLOCKS_ORDER" => "price,props,sku,quantityLimit,quantity,buttons",
        "PRODUCT_DISPLAY_MODE" => "Y",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PRODUCT_QUANTITY_VARIABLE" => "quantity",
        "PRODUCT_ROW_VARIANTS" => "[{'VARIANT':'3','BIG_DATA':false}]",
        "PRODUCT_SUBSCRIPTION" => "Y",
        "PROPERTY_CODE_MOBILE" => array("COLOR"),
        "SECTION_CODE" => "",
        "SECTION_ELEMENT_CODE" => "",
        "SECTION_ELEMENT_ID" => $GLOBALS["CATALOG_CURRENT_ELEMENT_ID"],
        "SECTION_ID" => $GLOBALS["CATALOG_CURRENT_SECTION_ID"],
        "SHOW_CLOSE_POPUP" => "N",
        "SHOW_DISCOUNT_PERCENT" => "N",
        "SHOW_FROM_SECTION" => "N",
        "SHOW_MAX_QUANTITY" => "N",
        "SHOW_OLD_PRICE" => "N",
        "SHOW_PRICE_COUNT" => "1",
        "SHOW_SLIDER" => "Y",
        "SLIDER_INTERVAL" => "3000",
        "SLIDER_PROGRESS" => "N",
        "TEMPLATE_THEME" => "blue",
        "USE_ENHANCED_ECOMMERCE" => "N",
        "USE_PRICE_COUNT" => "N",
        "USE_PRODUCT_QUANTITY" => "N"
    )
);?>


Подарки к товарам в корзине (устаревший)

Описание sale.gift.basket

Компонент служит для отображения товаров, которые будут предложены в качестве подарков к текущей корзине покупателя. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Подарки к товарам в корзине.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается инфоблок, из которого будет выводиться список товаров.
Источник данных
Показывать товары из раздела SHOW_FROM_SECTION [Y|N] При отмеченной опции просмотренные товары будут показываться из того раздела, который указан в [dw]следующих настройках[/dw][di]
ID раздела | SECTION_ID | Указывается идентификатор раздела, товары из которого должны быть показаны. Можно не указывать, если задан Код раздела.
Код раздела | SECTION_CODE | Указывается код раздела, товары из которого должны быть показаны. Можно не указывать, если задан ID раздела.
ID элемента, для которого будет выбран раздел | SECTION_ELEMENT_ID | Указывается идентификатор элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан Символьный код элемента, для которого будет выбран раздел.
Символьный код элемента, для которого будет выбран раздел | SECTION_ELEMENT_CODE | Указывается код элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан ID элемента, для которого будет выбран раздел.
Максимальная отображаемая глубина разделов | DEPTH | Параметр определяет максимальную глубину вложенности разделов, из которых будут показаны товары.
[/di] : ID раздела, Код раздела, ID элемента, для которого будет выбран раздел и Символьный код элемента, для которого будет выбран раздел. Если опция не отмечена, то данные настройки скрыты.
Не отображать товары, которых нет на складах | HIDE_NOT_AVAILABLE | [Y|N] При отмеченной опции будут скрыты товары, для которых общее доступное количество меньше либо равно нулю (не остатки по складам), включен количественный учет и не разрешена покупка при отсутствии товара.
Внешний вид
Показывать процент скидки | SHOW_DISCOUNT_PERCENT | [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана.
Разрешить оповещения для отсутствующих товаров | PRODUCT_SUBSCRIPTION | [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки.
Показывать название | SHOW_NAME | [Y|N] При отмеченной опции будет отображено название элемента.
Показывать изображение | SHOW_IMAGE | [Y|N] При отмеченной опции будет показано изображение элемента.
Текст кнопки "Выбрать" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Выбрать".
Текст кнопки "Подробнее" | MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Текст кнопки "Уведомить о поступлении" | MESS_BTN_SUBSCRIBE | Задается текст, который должен быть отображен на кнопке "Уведомить о поступлении".
Количество элементов на странице | PAGE_ELEMENT_COUNT | Указывается количество элементов, отображаемых на одной странице.
Количество элементов, выводимых в одной строке | LINE_ELEMENT_COUNT | Указывается количество элементов, выводимых в одной строке таблицы.
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения списка элементов. По умолчанию используется синяя схема (blue).
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Цены
Показывать старую цену | SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопка Купить показаны не будут.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах; станет доступным [dw]дополнительное поле[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты, в которой будут отображаться цены.
[/di].
Добавление в корзину
Текст заголовка "Подарки" | BLOCK_TITLE | Указывается текст заголовка блока с подарками.
Скрыть заголовок "Подарки" | HIDE_BLOCK_TITLE | [Y|N] При отмеченной опции заголовок блока подарков будет скрыт.
Текст метки "Подарка" | TEXT_LABEL_GIFT/b> | Указывается текст метки, которая проставляется для подарка.
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Название переменной, в которой передается действие | ACTION_VARIABLE | Задается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара.
Название переменной, в которой передается количество товара | PRODUCT_QUANTITY_VARIABLE | Задается имя переменной, в которой будет передаваться количество товара.
Добавлять в корзину свойства товаров и предложений ADD_PROPERTIES_TO_BASKET [Y|N] При отмеченной опции свойства товаров и предложений будут передаваться в корзину. Кроме того, становятся доступными для настройки [dw] следующие параметры:[/dw][di]
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить частично заполненные свойства | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
[/di]Название переменной, в которой передаются характеристики товара и Разрешить частично заполненные свойства.
Разрешить указание количества товара | USE_PRODUCT_QUANTITY | [Y|N] При отмеченной опции будет разрешено указывать количества товара.
Параметры вывода товаров из каталога <название_каталога>
Показывать товары каталога SHOW_PRODUCTS_<ID_каталога> [Y|N] При отмеченной опции товары из данного каталога, которые просмотрит пользователь, будут отображаться среди просмотренных товаров. Если опция не отмечена, то товары из данного каталога не будут отображаться среди просмотренных, даже если пользователь их просмотрит.

Если данная опция отмечена, то становятся доступными для настройки параметры отображения товаров каталога и соответствующих торговых предложений (при наличии).
Свойства для отображения | PROPERTY_CODE_<ID_каталога> | Указываются свойства инфоблока, которые будут отображены в списке просмотренных товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Свойства для добавления в корзину | CART_PROPERTIES_<ID_каталога> | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога> | Задается свойство, в котором хранится дополнительная картинка для товара.
Параметры вывода торговых предложений <название_каталога_предложений>
Секция доступна, если отмечена опция Показывать товары каталога
Свойства для отображения | PROPERTY_CODE_<ID_каталога_предложений> | Указываются свойства торговых предложений, которые должны быть отображены в списке.
Свойства для добавления в корзину | CART_PROPERTIES_<ID_каталога_предложений> | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога_предложений> | Задается свойство, в котором хранится дополнительная картинка торгового предложения.
Свойства для отбора предложений | OFFER_TREE_PROPS_<ID_каталога_предложений> | Указываются свойства, по значениям которых будут группироваться торговые предложения.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.gift.basket",
    "",
    Array(
        "ACTION_VARIABLE" => "action",
        "ADDITIONAL_PICT_PROP_2" => "MORE_PHOTO",
        "ADDITIONAL_PICT_PROP_3" => "MORE_PHOTO",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "BASKET_URL" => "/personal/basket.php",
        "BLOCK_TITLE" => "Выберите один из подарков",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "36000000",
        "CACHE_TYPE" => "A",
        "CART_PROPERTIES_2" => array("","CML2_MANUFACTURER",""),
        "CART_PROPERTIES_3" => array("COLOR_REF","SIZES_SHOES","SIZES_CLOTHES","CML2_MANUFACTURER",""),
        "COMPONENT_TEMPLATE" => ".default",
        "CONVERT_CURRENCY" => "N",
        "DEPTH" => "",
        "DETAIL_URL" => "/example/#SECTION_ID#/#ELEMENT_ID#/",
        "HIDE_BLOCK_TITLE" => "N",
        "HIDE_NOT_AVAILABLE" => "N",
        "IBLOCK_ID" => "2",
        "IBLOCK_TYPE" => "catalog",
        "LINE_ELEMENT_COUNT" => "3",
        "MESS_BTN_BUY" => "Выбрать",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_BTN_SUBSCRIBE" => "Подписаться",
        "OFFER_TREE_PROPS_3" => array("COLOR_REF","SIZES_SHOES","SIZES_CLOTHES"),
        "PAGE_ELEMENT_COUNT" => "5",
        "PARTIAL_PRODUCT_PROPERTIES" => "N",
        "PRICE_CODE" => array("BASE"),
        "PRICE_VAT_INCLUDE" => "Y",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PRODUCT_QUANTITY_VARIABLE" => "",
        "PRODUCT_SUBSCRIPTION" => "N",
        "PROPERTY_CODE_2" => array("","BRAND_REF","ARTNUMBER","MATERIAL","COLOR",""),
        "PROPERTY_CODE_3" => array("ARTNUMBER","COLOR_REF","SIZES_SHOES","SIZES_CLOTHES",""),
        "SECTION_CODE" => "",
        "SECTION_ELEMENT_CODE" => "",
        "SECTION_ELEMENT_ID" => "",
        "SECTION_ID" => "",
        "SHOW_DISCOUNT_PERCENT" => "Y",
        "SHOW_FROM_SECTION" => "N",
        "SHOW_IMAGE" => "Y",
        "SHOW_NAME" => "Y",
        "SHOW_OLD_PRICE" => "N",
        "SHOW_PRICE_COUNT" => "1",
        "SHOW_PRODUCTS_2" => "Y",
        "TEMPLATE_THEME" => "blue",
        "TEXT_LABEL_GIFT" => "Подарок",
        "USE_PRODUCT_QUANTITY" => "N"
    )
);?>


Подарки к товарам конкретного раздела

Описание sale.products.gift.section

Компонент служит для отображения подарков к товарам заданного раздела. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Подарки к товарам конкретного раздела.

С версии модуля sale 17.0.9 заменяет компонент sale.gift.section

Компонент наследуются от класса компонентов списка \Bitrix\Iblock\Component\ElementList.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается инфоблок, из которого будет выводиться список товаров.
Источник данных
Показывать товары из раздела SHOW_FROM_SECTION [Y|N] При отмеченной опции просмотренные товары будут показываться из того раздела, который указан в [dw]следующих настройках[/dw][di]
ID раздела | SECTION_ID | Указывается идентификатор раздела, товары из которого должны быть показаны. Можно не указывать, если задан Код раздела.
Код раздела | SECTION_CODE | Указывается код раздела, товары из которого должны быть показаны. Можно не указывать, если задан ID раздела.
ID элемента, для которого будет выбран раздел | SECTION_ELEMENT_ID | Указывается идентификатор элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан Символьный код элемента, для которого будет выбран раздел.
Символьный код элемента, для которого будет выбран раздел | SECTION_ELEMENT_CODE | Указывается код элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан ID элемента, для которого будет выбран раздел.
Максимальная отображаемая глубина разделов | DEPTH | Параметр определяет максимальную глубину вложенности разделов, из которых будут показаны товары.
[/di] : ID раздела, Код раздела, ID элемента, для которого будет выбран раздел и Символьный код элемента, для которого будет выбран раздел. Если опция не отмечена, то данные настройки скрыты.
Недоступные товары HIDE_NOT_AVAILABLE Как отображать недоступные товары:
  • Отображать в общем списке
  • Отображать в конце
  • Не отображать
Недоступны товары, для которых количество меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Товар с торговыми предложениями считается доступным, если хоть одно предложение доступно.
Доступность товара не означает, что его можно купить. Для покупки должны быть цены тех типов, по которым клиент может покупать.
Недоступные торговые предложения HIDE_NOT_AVAILABLE_OFFERS Как отображать недоступные торговые предложения
  • Отображать только с возможностью подписки
  • Отображать все
  • Не отображать
Недоступны предложения, для которых количество меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Доступность предложения не означает, что его можно купить. Для покупки должны быть цены тех типов, по которым клиент может покупать.
Настройки сортировки
По какому полю сортируем элементы | ELEMENT_SORT_FIELD | Указывается поле, по которому будет происходить сортировка элементов текущего раздела.
Порядок сортировки элементов | ELEMENT_SORT_ORDER | В каком направлении будут отсортированы элементы, по возрастанию или по убыванию.
Поле для второй сортировки элементов | ELEMENT_SORT_FIELD2 | Указывается поле, по которому будет происходить вторичная сортировка элементов текущего раздела.
Порядок второй сортировки элементов | ELEMENT_SORT_ORDER2 | В каком направлении будут отсортированы элементы, по возрастанию или по убыванию во вторичной сортировке.
Внешний вид
Количество элементов на странице: PAGE_ELEMENT_COUNT Значение поля определяет количество элементов на одной странице. Остальные элементы будут выведены с помощью постраничной навигации. Если заполнены поля секции Основные параметры, то выбор значений производится визуально с помощью [dw]drag&drop[/dw][di] [image] [/di]
Свойства PROPERTY_CODE Выбор свойств инфоблока для отображения при показе элементов. При выборе пункта (не выбрано) и без указания кодов свойств в строках ниже, свойства выведены не будут.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image].
Свойства товаров, отображаемые на мобильных устройствах | PROPERTY_CODE_MOBILE | Выбор свойств инфоблока для отображения при показе элементов в мобильной версии сайта.
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения списка элементов. По умолчанию используется синяя схема (blue).
Выделять товары в списке | ENLARGE_PRODUCT | По какому признаку выделяются товары: строго по шаблону, либо по признаку. Если выбрано По признаку, то необходимо указать признак в поле Выделять по выбранному свойству. Оба поля отображаются только если заданы параметры в секции Основные параметры
Порядок отображения блоков товара PRODUCT_BLOCKS_ORDER [dw]Визуальный выбор порядка отображения[/dw][di] [image] [/di] блоков товара.
Для некоторых блоков порядок может не соблюдаться в связи с особенностями шаблона. Блок товара может не отображаться если его функционал выключен или недоступен. Поле отображается только если заданы параметры в секции Основные параметры.
Показывать слайдер для товаров | SHOW_SLIDER | [Y|N] Товар будет отображён в слайдере. Поле отображается только если заданы параметры в секции Основные параметры.
Показывать полосу прогресса | SLIDER_PROGRESS | Скорость смены слайдов. Поле отображается только если заданы параметры в секции Основные параметры.
Дополнительная картинка основного товара | ADD_PICT_PROP | Свойство, откуда будут отображаться дополнительные картинки товара. Поле отображается только если заданы параметры в секции Основные параметры.
Свойства меток товара | LABEL_PROP | Выбрать метки, которые будут отображаться в товаре. После выбора укажите [dw]место расположения метки[/dw][di] [image] [/di] на фотографии. Поле отображается только если заданы параметры в секции Основные параметры.
Разрешить оповещения для отсутствующих товаров | PRODUCT_SUBSCRIPTION | [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки.
Показывать процент скидки SHOW_DISCOUNT_PERCENT [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана. Можно указать [dw]место расположения скидки[/dw][di]
Расположение процента скидки DISCOUNT_PERCENT_POSITION Задается место расположения стикера на изображении: по центру, справа, слева или внизу.
[/di].
Показывать старую цену | SHOW_OLD_PRICE | Опция отобразит старую, доскидочную цену.
Показывать остаток товара SHOW_MAX_QUANTITY Указывается количество товара доступных для продажи. Доступны значения:
  • Не показывать [N] - остаток не будет отображаться;
  • [dw]С отображением реального остатка[/dw][di]
    Текст для остатка MESS_SHOW_MAX_QUANTITY Возможность замены стандартного уведомления об остатке на свой текст.
    [/di] [Y] остаток будет выведен в виде числа;
  • [dw]С подменой остатка текстом[/dw][di]
    Текст для остатка | MESS_SHOW_MAX_QUANTITY | Возможность замены стандартного уведомления об остатке на свой текст.
    Значение, от которого происходит подмена | RELATIVE_QUANTITY_FACTOR | Количество товара с которого происходит замена текста о количестве. Сравнение происходит со значением, рассчитанным по формуле "Доступное количество"/"Коэффициент единицы измерения"
    Текст для значения больше | MESS_RELATIVE_QUANTITY_MANY | Текст выводится, если количество товара больше чем в поле Значение, от которого происходит подмена.
    Текст для значения меньше | MESS_RELATIVE_QUANTITY_FEW | Текст выводится, если количество товара меньше чем в поле Значение, от которого происходит подмена.
    [/di] [M] - остаток будет выведен текстом
В зависимости от выбранного значения появляются или скрываются дополнительные поля.
Показывать кнопку продолжения покупок во всплывающих окнах | SHOW_CLOSE_POPUP | Если опция отмечена, во всплывающих окнах будет показана кнопка "Продолжить покупки".
Текст кнопки "Купить" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Добавить в корзину" | MESS_BTN_ADD_TO_BASKET | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Подробнее" | MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Текст кнопки "Уведомить о поступлении" | MESS_BTN_SUBSCRIBE | Задается текст, который должен быть отображен на кнопке "Уведомить о поступлении".
Сообщение об отсутствии товара | MESS_NOT_AVAILABLE | Текст, который будет выведен при отсутствии товара.
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Композитный сайт
Голосование шаблона компонента по умолчанию | COMPOSITE_FRAME_MODE | Значения: Авто (актокомпозит), За, Против
Содержимое компонента | COMPOSITE_FRAME_TYPE | Что должен выводить компонент при включённом композитном режиме. Подробнее
Настройки действий
Название переменной, в которой передается действие: ACTION_VARIABLE Указывается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Имя переменной, в которой будет передаваться ID товара.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара, кнопки В корзину и Купить показаны не будут.
Использовать вывод цен с диапазонами | SHOW_OLD_PRICE | При установленной опции для каждого товара выбираются все диапазоны цен, существующие у товара.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость. Если снята опция "Использовать вывод цен с диапазонами", т.е. для каждого товара выводится только одна цена, но в каталоге есть товары с расширенным управлением ценами (зависимость цены от количества), необходимо указать - для какого количества товара искать цену. На товары, чья цена не зависит от количества, эта опция не влияет.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте | CONVERT_CURRENCY | При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах.
Валюта, в которую будут сконвертированы цены | CURRENCY_ID | Выбор валюты, в которой будут отображаться цены.
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Разрешить указание количества товара USE_PRODUCT_QUANTITY [Y|N] При отмеченной опции будет разрешено указывать количества товара; нужно заполнить [dw]дополнительное поле[/dw][di]
Название переменной, в которой передается количество товара PRODUCT_QUANTITY_VARIABLE Задается имя переменной, в которой будет передаваться количество товара.
[/di] .
Добавлять в корзину свойства товаров и предложений ADD_PROPERTIES_TO_BASKET [Y|N] При отмеченной опции свойства товаров и предложений будут передаваться в корзину и заказ. Свойства должны быть перечислены, если они влияют на выбор товара или включена возможность управлять свойствами в корзине (для торговых предложений), либо несут дополнительную информацию о товаре, которая необходима в заказе (например: клиент может сменить цвет в корзине, или цвет это другое торговое предложение и данное свойство показывает на этот выбор).
Кроме того, становятся доступными для настройки [dw]параметры [/dw][di]
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить добавлять в корзину товары, у которых заполнены не все характеристики | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
Характеристики товара | PRODUCT_PROPERTIES | Выводимые харакетристики товара.
[/di] Название переменной, в которой передаются характеристики товара и Разрешить добавлять в корзину товары, у которых заполнены не все характеристики.
Показывать кнопку добавления в корзину или покупки | BLOCK_TITLE | Выбор какую кнопку выводить.
Сравнение товаров
Разрешить сравнение товаров DISPLAY_COMPARE [Y|N] Включение функционала сравнения. После включения [dw]появляются дополнительные три поля.[/dw][di]
Путь к странице сравнения | COMPARE_PATH | Путь к странице с компонентом сравнения товаров. Если значение параметра пустое, будет использована текущая страница
Текст кнопки "Сравнить" | MESS_BTN_COMPARE | Замена текста по умолчанию для кнопки сравнения.
Уникальное имя для списка сравнения | COMPARE_NAME | Задается код для списка сравнения.
[/di]
Настройки аналитики
Отправлять данные электронной торговли в Google и Яндекс USE_ENHANCED_ECOMMERCE [Y|N] Включение опции. После включения станут доступны ещё [dw]два поля[/dw][di]
Имя контейнера данных | DATA_LAYER_NAME | Указываются свойства инфоблока, которые будут отображены в списке просмотренных товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Свойство брендов | BRAND_PROPERTY | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.
[/di]. Требуется дополнительная настройка в Google Analytics Enhanced Ecommerce [image] и/или Яндекс.Метрике [image].

Примечание: Настройка Яндекс метрикой не сложна, и данные в ней отображаются довольно быстро (полчаса-час). У Google используется Google Tag Manager с плагином электронной коммерции, его нужно настроить и добавить на страницу в шаблоне. После настройки на "той" стороне, нужно настроить компоненты для работы с электронной коммерцией и включить эту поле настройки.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.products.gift.section",
    "",
    Array(
        "ACTION_VARIABLE" => "action",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "ADD_TO_BASKET_ACTION" => "ADD",
        "BASKET_URL" => "/personal/basket.php",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "36000000",
        "CACHE_TYPE" => "A",
        "COMPOSITE_FRAME_MODE" => "A",
        "COMPOSITE_FRAME_TYPE" => "AUTO",
        "CONVERT_CURRENCY" => "N",
        "DEPTH" => "2",
        "DETAIL_URL" => "",
        "DISPLAY_COMPARE" => "N",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_FIELD2" => "id",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_ORDER2" => "desc",
        "HIDE_NOT_AVAILABLE" => "N",
        "HIDE_NOT_AVAILABLE_OFFERS" => "N",
        "IBLOCK_ID" => "",
        "IBLOCK_TYPE" => "news",
        "MESS_BTN_ADD_TO_BASKET" => "В корзину",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_BTN_SUBSCRIBE" => "Подписаться",
        "MESS_NOT_AVAILABLE" => "Нет в наличии",
        "MESS_SHOW_MAX_QUANTITY" => "Ещё можно купить!",
        "PAGE_ELEMENT_COUNT" => "4",
        "PARTIAL_PRODUCT_PROPERTIES" => "N",
        "PRICE_CODE" => array(),
        "PRICE_VAT_INCLUDE" => "Y",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_PROPERTIES" => array(),
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PRODUCT_QUANTITY_VARIABLE" => "quantity",
        "PRODUCT_SUBSCRIPTION" => "Y",
        "PROPERTY_CODE" => array("",""),
        "SECTION_CODE" => "",
        "SECTION_ELEMENT_CODE" => "",
        "SECTION_ELEMENT_ID" => $GLOBALS["CATALOG_CURRENT_ELEMENT_ID"],
        "SECTION_ID" => $GLOBALS["CATALOG_CURRENT_SECTION_ID"],
        "SHOW_CLOSE_POPUP" => "N",
        "SHOW_DISCOUNT_PERCENT" => "N",
        "SHOW_FROM_SECTION" => "N",
        "SHOW_MAX_QUANTITY" => "N",
        "SHOW_OLD_PRICE" => "N",
        "SHOW_PRICE_COUNT" => "1",
        "TEMPLATE_THEME" => "blue",
        "USE_ENHANCED_ECOMMERCE" => "N",
        "USE_PRICE_COUNT" => "N",
        "USE_PRODUCT_QUANTITY" => "N"
    )
);?>


Подарки к выбранному товару

Описание sale.products.gift

Компонент служит для отображения подарков к конкретному товару. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Подарки к выбранному товару.

С версии модуля sale 17.0.9 заменяет компонент sale.gift.product.

Компонент наследуются от класса компонентов списка \Bitrix\Iblock\Component\ElementList.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается инфоблок, из которого будет выводиться список товаров.
Источник данных
Показывать товары из раздела | SHOW_FROM_SECTION | [Y|N] При отмеченной опции просмотренные товары будут показываться из того раздела, который указан в нижеследующих настройках: ID раздела, Код раздела, ID элемента, для которого будет выбран раздел и Символьный код элемента, для которого будет выбран раздел. Если опция не отмечена, то данные настройки скрыты.
ID раздела | SECTION_ID | Указывается идентификатор раздела, товары из которого должны быть показаны. Можно не указывать, если задан Код раздела.
Код раздела | SECTION_CODE | Указывается код раздела, товары из которого должны быть показаны. Можно не указывать, если задан ID раздела.
ID элемента, для которого будет выбран раздел | SECTION_ELEMENT_ID | Указывается идентификатор элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан Символьный код элемента, для которого будет выбран раздел.
Символьный код элемента, для которого будет выбран раздел | SECTION_ELEMENT_CODE | Указывается код элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан ID элемента, для которого будет выбран раздел.
Максимальная отображаемая глубина разделов | DEPTH | Параметр определяет максимальную глубину вложенности разделов, из которых будут показаны товары.
Недоступные товары HIDE_NOT_AVAILABLE Как отображать недоступные товары:
  • Отображать в общем списке
  • Отображать в конце
  • Не отображать
Недоступны товары, для которых количество меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Товар с торговыми предложениями считается доступным, если хоть одно предложение доступно.
Доступность товара не означает, что его можно купить. Для покупки должны быть цены тех типов, по которым клиент может покупать.
Недоступные торговые предложения HIDE_NOT_AVAILABLE_OFFERS Как отображать недоступные торговые предложения
  • Отображать только с возможностью подписки
  • Отображать все
  • Не отображать
Недоступны предложения, для которых количество меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Доступность предложения не означает, что его можно купить. Для покупки должны быть цены тех типов, по которым клиент может покупать.
Настройки сортировки
По какому полю сортируем элементы | ELEMENT_SORT_FIELD | Указывается поле, по которому будет происходить сортировка элементов текущего раздела.
Порядок сортировки элементов | ELEMENT_SORT_ORDER | В каком направлении будут отсортированы элементы, по возрастанию или по убыванию.
Поле для второй сортировки элементов | ELEMENT_SORT_FIELD2 | Указывается поле, по которому будет происходить вторичная сортировка элементов текущего раздела.
Порядок второй сортировки элементов | ELEMENT_SORT_ORDER2 | В каком направлении будут отсортированы элементы, по возрастанию или по убыванию во вторичной сортировке.
Внешний вид
Количество элементов на странице: PAGE_ELEMENT_COUNT Значение поля определяет количество элементов на одной странице. Остальные элементы будут выведены с помощью постраничной навигации. Если заполнены поля секции Основные параметры, то выбор значений производится визуально с помощью [dw]drag&drop[/dw][di] [image] [/di]
Свойства PROPERTY_CODE Выбор свойств инфоблока для отображения при показе элементов. При выборе пункта (не выбрано) и без указания кодов свойств в строках ниже, свойства выведены не будут.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image].
Свойства товаров, отображаемые на мобильных устройствах | PROPERTY_CODE_MOBILE | Выбор свойств инфоблока для отображения при показе элементов в мобильной версии сайта.
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения списка элементов. По умолчанию используется синяя схема (blue).
Выделять товары в списке | ENLARGE_PRODUCT | По какому признаку выделяются товары: строго по шаблону, либо по признаку. Если выбрано По признаку, то необходимо указать признак в поле Выделять по выбранному свойству. Оба поля отображаются только если заданы параметры в секции Основные параметры
Порядок отображения блоков товара PRODUCT_BLOCKS_ORDER [dw]Визуальный выбор порядка отображения[/dw][di] [image] [/di] блоков товара.
Для некоторых блоков порядок может не соблюдаться в связи с особенностями шаблона. Блок товара может не отображаться если его функционал выключен или недоступен. Поле отображается только если заданы параметры в секции Основные параметры.
Показывать слайдер для товаров | SHOW_SLIDER | [Y|N] Товар будет отображён в слайдере. Поле отображается только если заданы параметры в секции Основные параметры.
Показывать полосу прогресса | SLIDER_PROGRESS | Скорость смены слайдов. Поле отображается только если заданы параметры в секции Основные параметры.
Дополнительная картинка основного товара | ADD_PICT_PROP | Свойство, откуда будут отображаться дополнительные картинки товара. Поле отображается только если заданы параметры в секции Основные параметры.
Свойства меток товара | LABEL_PROP | Выбрать метки, которые будут отображаться в товаре. После выбора укажите [dw]место расположения метки[/dw][di] [image] [/di] на фотографии. Поле отображается только если заданы параметры в секции Основные параметры.
Разрешить оповещения для отсутствующих товаров | PRODUCT_SUBSCRIPTION | [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки.
Показывать процент скидки SHOW_DISCOUNT_PERCENT [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана. Можно указать [dw]место расположения[/dw][di]
Расположение процента скидки DISCOUNT_PERCENT_POSITION Задается место расположения стикера на изображении: по центру, справа, слева или внизу.
[/di] скидки.
Показывать старую цену | SHOW_OLD_PRICE | Опция отобразит старую, доскидочную цену.
Показывать остаток товара SHOW_MAX_QUANTITY Указывается количество товара доступных для продажи. Доступны значения:
  • Не показывать [N] - остаток не будет отображаться;
  • [dw]С отображением реального остатка[/dw][di]
    Текст для остатка MESS_SHOW_MAX_QUANTITY Возможность замены стандартного уведомления об остатке на свой текст.
    [/di] [Y] остаток будет выведен в виде числа;
  • [dw]С подменой остатка текстом[/dw][di]
    Текст для остатка | MESS_SHOW_MAX_QUANTITY | Возможность замены стандартного уведомления об остатке на свой текст.
    Значение, от которого происходит подмена | RELATIVE_QUANTITY_FACTOR | Количество товара с которого происходит замена текста о количестве. Сравнение происходит со значением, рассчитанным по формуле "Доступное количество"/"Коэффициент единицы измерения"
    Текст для значения больше | MESS_RELATIVE_QUANTITY_MANY | Текст выводится, если количество товара больше чем в поле Значение, от которого происходит подмена.
    Текст для значения меньше | MESS_RELATIVE_QUANTITY_FEW | Текст выводится, если количество товара меньше чем в поле Значение, от которого происходит подмена.
    [/di] [M] - остаток будет выведен текстом
В зависимости от выбранного значения появляются или скрываются дополнительные поля.
Показывать кнопку продолжения покупок во всплывающих окнах | SHOW_CLOSE_POPUP | Если опция отмечена, во всплывающих окнах будет показана кнопка "Продолжить покупки".
Текст кнопки "Купить" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Добавить в корзину" | MESS_BTN_ADD_TO_BASKET | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Подробнее" | MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Текст кнопки "Уведомить о поступлении" | MESS_BTN_SUBSCRIBE | Задается текст, который должен быть отображен на кнопке "Уведомить о поступлении".
Сообщение об отсутствии товара | MESS_NOT_AVAILABLE | Текст, который будет выведен при отсутствии товара.
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Композитный сайт
Голосование шаблона компонента по умолчанию | COMPOSITE_FRAME_MODE | Значения: Авто (актокомпозит), За, Против
Содержимое компонента | COMPOSITE_FRAME_TYPE | Что должен выводить компонент при включённом композитном режиме. Подробнее
Настройки действий
Название переменной, в которой передается действие: ACTION_VARIABLE Указывается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Имя переменной, в которой будет передаваться ID товара.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара, кнопки В корзину и Купить показаны не будут.
Использовать вывод цен с диапазонами | SHOW_OLD_PRICE | При установленной опции для каждого товара выбираются все диапазоны цен, существующие у товара.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость. Если снята опция "Использовать вывод цен с диапазонами", т.е. для каждого товара выводится только одна цена, но в каталоге есть товары с расширенным управлением ценами (зависимость цены от количества), необходимо указать - для какого количества товара искать цену. На товары, чья цена не зависит от количества, эта опция не влияет.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах. При выборе данной опции станет активным [dw]дополнительное поле.[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты, в которой будут отображаться цены.
[/di]
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Разрешить указание количества товара USE_PRODUCT_QUANTITY [Y|N] При отмеченной опции будет разрешено указывать количества товара; нужно заполнить [dw]дополнительное поле[/dw][di]
Название переменной, в которой передается количество товара PRODUCT_QUANTITY_VARIABLE Задается имя переменной, в которой будет передаваться количество товара.
[/di].
Добавлять в корзину свойства товаров и предложений ADD_PROPERTIES_TO_BASKET [Y|N] При отмеченной опции свойства товаров и предложений будут передаваться в корзину и заказ. Свойства должны быть перечислены, если они влияют на выбор товара или включена возможность управлять свойствами в корзине (для торговых предложений), либо несут дополнительную информацию о товаре, которая необходима в заказе (например: клиент может сменить цвет в корзине, или цвет это другое торговое предложение и данное свойство показывает на этот выбор).
Кроме того, становятся доступными для настройки [dw]параметры[/dw][di]
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить добавлять в корзину товары, у которых заполнены не все характеристики | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
Характеристики товара | PRODUCT_PROPERTIES | Выводимые харакетристики товара.
[/di] Название переменной, в которой передаются характеристики товара и Разрешить добавлять в корзину товары, у которых заполнены не все характеристики.
Показывать кнопку добавления в корзину или покупки | BLOCK_TITLE | Выбор какую кнопку выводить.
Сравнение товаров
Разрешить сравнение товаров DISPLAY_COMPARE [Y|N] Включение функционала сравнения. После включения появляются дополнительные [dw]три поля.[/dw][di]
Путь к странице сравнения | COMPARE_PATH | Путь к странице с компонентом сравнения товаров. Если значение параметра пустое, будет использована текущая страница
Текст кнопки "Сравнить" | MESS_BTN_COMPARE | Замена текста по умолчанию для кнопки сравнения.
Уникальное имя для списка сравнения | COMPARE_NAME | Задается код для списка сравнения.
[/di]
Настройки аналитики
Отправлять данные электронной торговли в Google и Яндекс USE_ENHANCED_ECOMMERCE [Y|N] Включение опции. После включения станут доступны ещё [dw]два поля.[/dw][di]
Имя контейнера данных | DATA_LAYER_NAME | Указываются свойства инфоблока, которые будут отображены в списке просмотренных товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Свойство брендов | BRAND_PROPERTY | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.
[/di] Требуется дополнительная настройка в Google Analytics Enhanced Ecommerce и/или Яндекс.Метрике.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.products.gift",
    "",
    Array(
        "ACTION_VARIABLE" => "action",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "ADD_TO_BASKET_ACTION" => "ADD",
        "BASKET_URL" => "/personal/basket.php",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "36000000",
        "CACHE_TYPE" => "A",
        "COMPOSITE_FRAME_MODE" => "A",
        "COMPOSITE_FRAME_TYPE" => "AUTO",
        "CONVERT_CURRENCY" => "N",
        "DEPTH" => "2",
        "DETAIL_URL" => "",
        "DISPLAY_COMPARE" => "N",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_FIELD2" => "id",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_ORDER2" => "desc",
        "HIDE_NOT_AVAILABLE" => "N",
        "HIDE_NOT_AVAILABLE_OFFERS" => "N",
        "IBLOCK_ID" => "",
        "IBLOCK_TYPE" => "news",
        "MESS_BTN_ADD_TO_BASKET" => "В корзину",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_BTN_SUBSCRIBE" => "Подписаться",
        "MESS_NOT_AVAILABLE" => "Нет в наличии",
        "PAGE_ELEMENT_COUNT" => "4",
        "PARTIAL_PRODUCT_PROPERTIES" => "N",
        "PRICE_CODE" => array(),
        "PRICE_VAT_INCLUDE" => "Y",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_PROPERTIES" => array(),
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PRODUCT_QUANTITY_VARIABLE" => "quantity",
        "PRODUCT_SUBSCRIPTION" => "Y",
        "PROPERTY_CODE" => array("",""),
        "SECTION_CODE" => "",
        "SECTION_ELEMENT_CODE" => "",
        "SECTION_ELEMENT_ID" => $GLOBALS["CATALOG_CURRENT_ELEMENT_ID"],
        "SECTION_ID" => $GLOBALS["CATALOG_CURRENT_SECTION_ID"],
        "SHOW_CLOSE_POPUP" => "N",
        "SHOW_DISCOUNT_PERCENT" => "N",
        "SHOW_FROM_SECTION" => "N",
        "SHOW_MAX_QUANTITY" => "N",
        "SHOW_OLD_PRICE" => "N",
        "SHOW_PRICE_COUNT" => "1",
        "TEMPLATE_THEME" => "blue",
        "USE_ENHANCED_ECOMMERCE" => "N",
        "USE_PRICE_COUNT" => "N",
        "USE_PRODUCT_QUANTITY" => "N"
    )
);?>


Просмотренные товары

Описание catalog.products.viewed

Компонент выводит просмотренные пользователем товары с указанным набором свойств, цен и другими его параметрами. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Просмотренные товары.

Компонент относится к модулю Торговый каталог.

Параметры

Поле | Параметр | Описание
Источник данных
Показывать товары из | IBLOCK_MODE | Указывается как выбирать для отображения просмотренные товары: из одного инфоблока ("single") или из нескольких ("multi"). Если выбрано значение одного инфоблока, то необходимо настроить параметры инфоблока ниже.
Тип инфоблока* | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок* | IBLOCK_ID | Для выбранного типа инфоблоков указывается информационныйо блок, из которого будут выводиться просмотренные товары.
Показывать товары из раздела* SHOW_FROM_SECTION [Y|N] При отмеченной опции просмотренные товары будут показываться из того раздела, который указан в следующих [dw]настройках[/dw][di]
ID раздела | SECTION_ID | Указывается идентификатор раздела, товары из которого должны быть показаны. Можно не указывать, если задан Код раздела.
Код раздела | SECTION_CODE | Указывается код раздела, товары из которого должны быть показаны. Можно не указывать, если задан ID раздела.
ID элемента, для которого будет выбран раздел | SECTION_ELEMENT_ID | Указывается идентификатор элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан Символьный код элемента, для которого будет выбран раздел.
Символьный код элемента, для которого будет выбран раздел | SECTION_ELEMENT_CODE | Указывается код элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан ID элемента, для которого будет выбран раздел.
Максимальная отображаемая глубина разделов | DEPTH | Параметр определяет максимальную глубину вложенности разделов, из которых будут показаны товары.
[/di] : ID раздела, Код раздела, ID элемента, для которого будет выбран раздел и Символьный код элемента, для которого будет выбран раздел. Если опция не отмечена, то данные настройки скрыты.
Недоступные товары | HIDE_NOT_AVAILABLE | [Y|N] При отмеченной опции будут скрыты товары, для которых общее количество на складах меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара. Товар, имеющий торговое предложение, считается доступным, если есть хоть одно торговое предложение, доступное к покупке.
Недоступные торговые предложения HIDE_NOT_AVAILABLE_OFFERS Указывается способ отображения недоступных для покупки торговых предложений:
  • не отображать;
  • отображать только с возможностью подписки;
  • отображать все.
Внешний вид
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения списка элементов. По умолчанию используется синяя схема (blue).
Порядок отображения блоков товара PRODUCT_BLOCKS_ORDER Перетаскивая блоки, определите необходимый вам порядок следования блоков товара.

Вариант отображения товаров PRODUCT_ROW_VARIANTS В правой части поля выберите подходящий вам вариант отображения одной строки товаров на странице и перетащите его в левую часть. Аналогичным образом настройте остальные строки для формирования таблицы товаров.

Количество товаров на странице | PAGE_ELEMENT_COUNT | Отображается информация по количеству товаров на странице в соответствии с выбранным вариантом отображения товаров.
Выделять товары в списке ENLARGE_PRODUCT Выберите способ выделения товаров в списке:
  • по выбранному шаблону (строго) - товар будет выделятся строго по настроенному варианту отображения товаров;
  • по свойству, подгонять по шаблону (в этом случае возможно изменение сортировки элементов) - в списке будет выделяться тот товар, для которого заполнено указанное в параметре Выделять по выбранному свойству свойство.
Примечание: выделение товаров осуществляется в том случае, если для показа списка товаров выбран хотя бы один вариант вида:

Показывать слайдер для товаров SHOW_SLIDER [Y|N] При отмеченной опции для товаров будет использоваться слайдер для показа изображений, для которого нужно задать [dw]интервал смены слайдов[/dw][di]
Интервал смены слайдов, мс SLIDER_INTERVAL Указывается интервал смены слайдов в миллисекундах.
[/di].
Показывать полосу прогресса | SLIDER_PROGRESS | [Y|N] При отмеченной опции будет отображаться полоса прогресса до начала показа следующего слайда.
Расположение меток товара | LABEL_PROP_POSITION | Выберите подходящее место для меток на карточке товара.
Разрешить оповещения для отсутствующих товаров | PRODUCT_SUBSCRIPTION | [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки.
Показывать процент скидки SHOW_DISCOUNT_PERCENT [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана. Можно указать [dw]место расположения[/dw][di]
Расположение процента скидки "DISCOUNT_PERCENT_POSITION Выберите подходящее место для отображения процентной скидки на карточке товара.
[/di] скидки.
Показывать старую цену | SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Показывать остаток товара SHOW_MAX_QUANTITY Укажите способ отображения остатка товара:
  • не показывать;
  • [dw]с отображением реального остатка[/dw][di]
    Текст для остатка MESS_SHOW_MAX_QUANTITY Задается текст для отображения информации о наличии товара.
    [/di] - в этом случае необходимо настроить параметр Текст для остатка;
  • [dw]с подменой остатка текстом[/dw][di]
    Текст для остатка | MESS_SHOW_MAX_QUANTITY | Задается текст для отображения информации о наличии товара.
    Значение, от которого происходит подмена | RELATIVE_QUANTITY_FACTOR | Указывается значение, меньше (больше) которого о количестве товара на складе будет отображаться выражение, что товара мало (много).
    Текст для значения больше | MESS_RELATIVE_QUANTITY_MANY | Задается текст, который будет отображаться при наличии товара в количестве большем, чем значение в параметре Значение, от которого происходит подмена.
    Текст для значения меньше | MESS_RELATIVE_QUANTITY_FEW | Задается текст, который будет отображаться при наличии товара в количестве меньшем, чем значение в параметре Значение, от которого происходит подмена..
    [/di] - в этом случае необходимо настроить параметры Текст для остатка, Значение, от которого происходит подмена, Текст для значения больше и Текст для значения меньше.
Показывать кнопку продолжения покупок во всплывающих окнах | SHOW_CLOSE_POPUP | [Y|N] При отмеченной опции будет отображаться кнопка Продолжить покупки во всплывающем окне, появляющемся после добавления товара в корзину.
Текст кнопки "Купить" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Добавить в корзину" | MESS_BTN_ADD_TO_BASKET | Задается текст, который должен быть отображен на кнопке добавления в корзину.
Текст кнопки "Уведомить о поступлении" | MESS_BTN_SUBSCRIBE | Задается текст, который должен быть отображен на кнопке уведомления о поступлении товара.
Текст кнопки "Подробнее" | MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Сообщение об отсутствии товара | MESS_NOT_AVAILABLE | Указывается текст, который будет отображаться при отсутствии товара и невозможности его купить.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Настройки действий
Название переменной, в которой передается действие | ACTION_VARIABLE | Задается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action_cpv. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопка Купить показаны не будут.
Использовать вывод цен с диапазонами | USE_PRICE_COUNT | [Y/N] При отмеченной опции будут отображаться цены всех типов на товары.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах. При выборе данной опции станет активным [dw]дополнительное поле[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты, в которой будут отображаться цены.
[/di]
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Разрешить указание количества товара USE_PRODUCT_QUANTITY [Y|N] При отмеченной опции будет разрешено указывать количества товара; нужно заполнить [dw]дополнительное поле.[/dw][di]
Название переменной, в которой передается количество товара PRODUCT_QUANTITY_VARIABLE Задается имя переменной, в которой будет передаваться количество товара.
[/di]
Добавлять в корзину свойства товаров и предложений ADD_PROPERTIES_TO_BASKET [Y|N] При отмеченной опции свойства товаров и предложений будут передаваться в корзину. Кроме того, становятся доступными для настройки [dw]параметры[/dw][di]
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить добавлять в корзину товары, у которых заполнены не все характеристики | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
[/di] Название переменной, в которой передаются характеристики товара и Разрешить добавлять в корзину товары, у которых заполнены не все характеристики.
Показывать кнопку добавления в корзину или покупки | ADD_TO_BASKET_ACTION | Выберите какая кнопка должна отображаться: кнопка покупки (BUY) или кнопка добавления в корзину (ADD).
Сравнение товаров
Разрешить сравнение товаров DISPLAY_COMPARE [Y|N] Включение функционала сравнения. После включения появляются дополнительные [dw]три поля.[/dw][di]
Путь к странице сравнения | COMPARE_PATH | Путь к странице с компонентом сравнения товаров. Если значение параметра пустое, будет использована текущая страница
Текст кнопки "Сравнить" | MESS_BTN_COMPARE | Замена текста по умолчанию для кнопки сравнения.
Уникальное имя для списка сравнения | COMPARE_NAME | Задается код для списка сравнения.
[/di]
Параметры вывода товаров из каталога <название_каталога>
Показывать товары каталога SHOW_PRODUCTS_<ID_каталога> [Y|N] При отмеченной опции товары из данного каталога будут отображаться среди рекомендованных товаров. Если опция не отмечена, то товары из данного каталога не будут отображаться среди рекомендованных, даже если они указаны в карточке товара.

Если данная опция отмечена, то становятся доступными для настройки параметры отображения товаров каталога и соответствующих торговых предложений (при наличии).
Свойства для отображения PROPERTY_CODE_<ID_каталога> Указываются свойства инфоблока, которые будут отображены в списке рекомендованных товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image].
Свойства для добавления в корзину CART_PROPERTIES_<ID_каталога> Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image].
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога> | Задается свойство, в котором хранится дополнительная картинка для товара.
Свойство меток товара | LABEL_PROP_<ID_каталога> | Указываются свойство, в котором хранится метка товара (например, новинка).
Параметры вывода торговых предложений <название_каталога_предложений>
Секция доступна, если отмечена опция Показывать товары каталога
Свойства для отображения PROPERTY_CODE_<ID_каталога_предложений> Указываются свойства торговых предложений, которые должны быть отображены в списке.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image].
Свойства для добавления в корзину CART_PROPERTIES_<ID_каталога_предложений> Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image].
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога_предложений> | Задается свойство, в котором хранится дополнительная картинка торгового предложения.
Свойства для отбора предложений OFFER_TREE_PROPS_<ID_каталога_предложений> Указываются свойства, по значениям которых будут группироваться торговые предложения.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image].
Настройки аналитики
Отправлять данные электронной торговли в Google и Яндекс USE_ENHANCED_ECOMMERCE [Y|N] При отмеченной опции доступны для использования инструменты сервисов Google Analytics Enhanced Ecommerce и Яндекс.Метрики, следует заполнить [dw]Имя контейнера данных[/dw][di]
Имя контейнера данных DATA_LAYER_NAME Указывается название для контейнера данных.
[/di].

Важно! Требуются дополнительные настройки для использования сервисов.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:catalog.products.viewed",
    "",
    Array(
        "ACTION_VARIABLE" => "action_cpv",
        "ADDITIONAL_PICT_PROP_2" => "MORE_PHOTO",
        "ADDITIONAL_PICT_PROP_3" => "-",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "ADD_TO_BASKET_ACTION" => "BUY",
        "BASKET_URL" => "/personal/basket.php",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "3600",
        "CACHE_TYPE" => "A",
        "CART_PROPERTIES_2" => array("NEWPRODUCT","NEWPRODUCT,SALELEADER",""),
        "CART_PROPERTIES_3" => array("COLOR_REF","SIZES_SHOES",""),
        "CONVERT_CURRENCY" => "Y",
        "CURRENCY_ID" => "RUB",
        "DATA_LAYER_NAME" => "dataLayer",
        "DEPTH" => "",
        "DISCOUNT_PERCENT_POSITION" => "top-right",
        "ENLARGE_PRODUCT" => "STRICT",
        "ENLARGE_PROP_2" => "NEWPRODUCT",
        "HIDE_NOT_AVAILABLE" => "N",
        "HIDE_NOT_AVAILABLE_OFFERS" => "L",
        "IBLOCK_ID" => "2",
        "IBLOCK_MODE" => "single",
        "IBLOCK_TYPE" => "catalog",
        "LABEL_PROP_2" => array("NEWPRODUCT"),
        "LABEL_PROP_MOBILE_2" => array(),
        "LABEL_PROP_POSITION" => "top-left",
        "MESS_BTN_ADD_TO_BASKET" => "В корзину",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_BTN_SUBSCRIBE" => "Подписаться",
        "MESS_NOT_AVAILABLE" => "Нет в наличии",
        "MESS_RELATIVE_QUANTITY_FEW" => "мало",
        "MESS_RELATIVE_QUANTITY_MANY" => "много",
        "MESS_SHOW_MAX_QUANTITY" => "Наличие",
        "OFFER_TREE_PROPS_3" => array("COLOR_REF","SIZES_SHOES","SIZES_CLOTHES"),
        "PAGE_ELEMENT_COUNT" => "8",
        "PARTIAL_PRODUCT_PROPERTIES" => "N",
        "PRICE_CODE" => array("BASE"),
        "PRICE_VAT_INCLUDE" => "Y",
        "PRODUCT_BLOCKS_ORDER" => "price,props,quantityLimit,sku,quantity,buttons,compare",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PRODUCT_QUANTITY_VARIABLE" => "",
        "PRODUCT_ROW_VARIANTS" => "[{'VARIANT':'3','BIG_DATA':false},{'VARIANT':'3','BIG_DATA':false}]",
        "PRODUCT_SUBSCRIPTION" => "Y",
        "PROPERTY_CODE_2" => array("NEWPRODUCT","SALELEADER","SPECIALOFFER","MANUFACTURER","MATERIAL","COLOR","SALELEADER,SPECIALOFFER,MATERIAL,COLOR,KEYWORDS,BRAND_REF",""),
        "PROPERTY_CODE_3" => array("ARTNUMBER","COLOR_REF","SIZES_SHOES","SIZES_CLOTHES",""),
        "PROPERTY_CODE_MOBILE_2" => array(),
        "RELATIVE_QUANTITY_FACTOR" => "5",
        "SECTION_CODE" => "",
        "SECTION_ELEMENT_CODE" => "",
        "SECTION_ELEMENT_ID" => "",
        "SECTION_ID" => "",
        "SHOW_CLOSE_POPUP" => "N",
        "SHOW_DISCOUNT_PERCENT" => "Y",
        "SHOW_FROM_SECTION" => "N",
        "SHOW_MAX_QUANTITY" => "M",
        "SHOW_OLD_PRICE" => "Y",
        "SHOW_PRICE_COUNT" => "1",
        "SHOW_PRODUCTS_2" => "N",
        "SHOW_SLIDER" => "Y",
        "SLIDER_INTERVAL" => "3000",
        "SLIDER_PROGRESS" => "Y",
        "TEMPLATE_THEME" => "blue",
        "USE_ENHANCED_ECOMMERCE" => "N",
        "USE_PRICE_COUNT" => "N",
        "USE_PRODUCT_QUANTITY" => "Y"
    )
);?>


Рекомендуемые товары

Описание catalog.recommended.products

Компонент для товара выводит список рекомендуемых к покупке вместе с ним товаров. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Рекомендуемые товары.

Компонент относится к модулю Торговый каталог.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Выбирается один из созданных в системе типов инфоблоков.
Идентификатор инфоблока товара | IBLOCK_ID | Для выбранного типа инфоблоков задается необходимый инфоблок.
Идентификатор товара | ID | Задается числовой идентификатор товара. Можно не задавать, если указан Код товара.
Код товара | CODE | Указывается код товара. Можно не задавать, если указан Идентификатор товара.
Свойство привязки | PROPERTY_LINK | Указывается символьный код свойства элементов инфоблока, в котором хранится привязка к рекомендуемым товарам.
Свойство привязки для торговых предложений | OFFERS_PROPERTY_LINK | Задается символьный код свойства элементов инфоблока торговых предложений, в котором хранится привязка к рекомендуемым товарам.
По какому полю сортируем элементы ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • CATALOG_AVAILABLE – по доступности на складах.
Порядок сортировки элементов ELEMENT_SORT_ORDER Задается порядок сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.
Поле для второй сортировки элементов ELEMENT_SORT_FIELD2 Указывается поле, по которому будет происходить вторая сортировка элементов:
  • shows – по количеству просмотров в среднем;
  • sort – по индексу сортировки;
  • timestamp_x – по дате изменения;
  • name – по названию;
  • id – по идентификатору;
  • active_from – по дате активности с;
  • active_to – по дате активности по;
  • CATALOG_AVAILABLE – по доступности на складах.
Порядок второй сортировки элементов ELEMENT_SORT_ORDER2 Задается порядок второй сортировки элементов:
  • asc – По возрастанию;
  • desc – По убыванию.
Источник данных
Скрыть недоступные товары | HIDE_NOT_AVAILABLE | [Y|N] При отмеченной опции будут скрыты товары, для которых общее количество на складах меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Внешний вид
Показывать процент скидки | SHOW_DISCOUNT_PERCENT | [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана.
Разрешить оповещения для отсутствующих товаров | PRODUCT_SUBSCRIPTION | [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки.
Показывать название | SHOW_NAME | [Y|N] При отмеченной опции будет отображено название элемента.
Показывать изображение | SHOW_IMAGE | [Y|N] При отмеченной опции будет показано изображение элемента.
Текст кнопки "Купить" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Подробнее" | MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Сообщение об отсутствии товара | MESS_NOT_AVAILABLE | Указывается текст, который будет отображаться при отсутствии товара и невозможности его купить.
Текст кнопки "Уведомить о поступлении" | MESS_BTN_SUBSCRIBE | Задается текст, который должен быть отображен на кнопке "Уведомить о поступлении".
Количество элементов на странице | PAGE_ELEMENT_COUNT | Указывается количество элементов, отображаемых на одной странице.
Количество элементов, выводимых в одной строке LINE_ELEMENT_COUNT Указывается количество элементов, выводимых в одной строке таблицы.

Данный параметр недоступен для шаблона vertical.
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения списка элементов. По умолчанию используется синяя схема (blue).
Схема отображения | PRODUCT_DISPLAY_MODE | Задается режим отображения товаров: простой (N) или расширенный (Y). Параметр доступен для инфоблока с торговыми предложениями.
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Цены
Показывать старую цену | SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопка Купить показаны не будут.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах. При выборе данной опции станет доступно [dw]дополнительное поле.[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты, в которой будут отображаться цены.
[/di]
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Название переменной, в которой передается действие | ACTION_VARIABLE | Задается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара.
Название переменной, в которой передается количество товара | PRODUCT_QUANTITY_VARIABLE | Задается имя переменной, в которой будет передаваться количество товара.
Добавлять в корзину свойства товаров и предложений ADD_PROPERTIES_TO_BASKET [Y|N] При отмеченной опции свойства товаров и предложений будут передаваться в корзину. Кроме того, становятся доступными для настройки [dw]параметры[/dw][di]
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить частично заполненные свойства | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
[/di] Название переменной, в которой передаются характеристики товара и Разрешить частично заполненные свойства.
Разрешить указание количества товара | USE_PRODUCT_QUANTITY | [Y|N] При отмеченной опции будет разрешено указывать количества товара.
Параметры вывода товаров из каталога <название_каталога>
Показывать товары каталога SHOW_PRODUCTS_<ID_каталога> [Y|N] При отмеченной опции товары из данного каталога будут отображаться среди рекомендованных товаров. Если опция не отмечена, то товары из данного каталога не будут отображаться среди рекомендованных, даже если они указаны в карточке товара.

Если данная опция отмечена, то становятся доступными для настройки параметры отображения товаров каталога и соответствующих торговых предложений (при наличии).
Свойства для отображения PROPERTY_CODE_<ID_каталога> Указываются свойства инфоблока, которые будут отображены в списке рекомендованных товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image].
Свойства для добавления в корзину CART_PROPERTIES_<ID_каталога> Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image].
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога> | Задается свойство, в котором хранится дополнительная картинка для товара.
Свойство меток товара | LABEL_PROP_<ID_каталога> | Указываются свойство, в котором хранится метка товара (например, новинка).
Параметры вывода торговых предложений <название_каталога_предложений>
Секция доступна, если отмечена опция Показывать товары каталога
Свойства для отображения PROPERTY_CODE_<ID_каталога_предложений> Указываются свойства торговых предложений, которые должны быть отображены в списке.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image].
Свойства для добавления в корзину CART_PROPERTIES_<ID_каталога_предложений> Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image].
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога_предложений> | Задается свойство, в котором хранится дополнительная картинка торгового предложения.
Свойства для отбора предложений OFFER_TREE_PROPS_<ID_каталога_предложений> Указываются свойства, по значениям которых будут группироваться торговые предложения.

Обратите внимание, что данный параметр недоступен при отмеченной опции [dw]Использовать параметры свойств в компонентах и формах[/dw][di] [image] [/di]. Подробнее читайте в уроке [image] [image] [image] [image] [image].

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:catalog.recommended.products",
    "",
    Array(
        "IBLOCK_TYPE" => "books",
        "IBLOCK_ID" => "6",
        "ID" => "55",
        "CODE" => $_REQUEST["PRODUCT_CODE"],
        "PROPERTY_LINK" => "RECOMMEND",
        "OFFERS_PROPERTY_LINK" => "RECOMMEND",
        "HIDE_NOT_AVAILABLE" => "N",
        "SHOW_DISCOUNT_PERCENT" => "N",
        "PRODUCT_SUBSCRIPTION" => "N",
        "SHOW_NAME" => "Y",
        "SHOW_IMAGE" => "Y",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_NOT_AVAILABLE" => "Нет в наличии",
        "MESS_BTN_SUBSCRIBE" => "Подписаться",
        "PAGE_ELEMENT_COUNT" => "30",
        "LINE_ELEMENT_COUNT" => "3",
        "TEMPLATE_THEME" => "blue",
        "DETAIL_URL" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "SHOW_OLD_PRICE" => "N",
        "PRICE_CODE" => array(0=>"BASE",),
        "SHOW_PRICE_COUNT" => "1",
        "PRICE_VAT_INCLUDE" => "Y",
        "CONVERT_CURRENCY" => "Y",
        "CURRENCY_ID" => "RUB",
        "BASKET_URL" => "/personal/basket.php",
        "ACTION_VARIABLE" => "action",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_QUANTITY_VARIABLE" => "quantity",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PARTIAL_PRODUCT_PROPERTIES" => "N",
        "USE_PRODUCT_QUANTITY" => "Y",
        "SHOW_PRODUCTS_28" => "Y",
        "PROPERTY_CODE_28" => array("WIDTH", "LENGHT"),
        "CART_PROPERTIES_28" => array("SIZE"),
        "ADDITIONAL_PICT_PROP_28" => "MORE_PHOTO",
        "LABEL_PROP_28" => "SPECIALOFFER",
        "PROPERTY_CODE_29" => array("SIZE", "COLOR"),
        "CART_PROPERTIES_29" => array("SIZE"),
        "OFFER_TREE_PROPS_29" => array("SIZE")
    )
);?>


Генерация купона на товар для почты

Описание sale.discount.coupon.mail

Одностраничный компонент генерирует купон для правила корзины с соответствии с заданными параметрами. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Магазин > Информация о товарах > Генерация купона на товар для почты.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Скидка
Значение скидки | DISCOUNT_VALUE | Указывается величина скидки для правила работы с корзиной.
Тип скидки DISCOUNT_UNIT Выбирается тип скидки:
  • Perc - процент;
  • CurEach - на каждый товар;
  • CurAll - на сумму товаров.
Купон
Тип купона COUPON_TYPE Задается тип купона:
  • Order - на один заказ;
  • Basket - на одну позицию заказа.
Параметры
Поле правила скидки "XML_ID" | DISCOUNT_XML_ID | Указывается значение, которое будет подставлено в поле Внешний код правила работы с корзиной. По умолчанию в поле передается код выпуска рассылки.
Поле купона "Описание" | COUPON_DESCRIPTION | Указывается значение, которое будет подставлено в поле Комментарий купона правила работы с корзиной. По умолчанию в поле передается email получателя рассылки.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.discount.coupon.mail",
    "",
    Array(
        "DISCOUNT_VALUE" => "10",
        "DISCOUNT_UNIT" => "Perc",
        "COUPON_TYPE" => "Order",
        "DISCOUNT_XML_ID" => "{#SENDER_CHAIN_CODE#}",
        "COUPON_DESCRIPTION" => "{#EMAIL_TO#}"
    )
);?>


Персональные рекомендации (почта)

Описание sale.bigdata.personal.mail

Компонент выводит список рекомендованных товаров для почты. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Персональные рекомендации.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Код пользователя | USER_ID | Указывается идентификатор пользователя, рекомендованные товары для которого необходимо отобразить.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.bigdata.personal.mail",
    "",
    Array(
        "USER_ID" => "{#USER_ID#}"
    )
);?>


Самые продаваемые товары

Описание sale.bestsellers

Компонент выводит список самых продаваемых товаров, который формируется с учетом статусов заказов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Самые продаваемые товары.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Источник данных
Не отображать товары, которых нет на складах | HIDE_NOT_AVAILABLE | [Y|N] При отмеченной опции будут скрыты товары, для которых общее количество на складах меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Внешний вид
Показывать процент скидки | SHOW_DISCOUNT_PERCENT | [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана.
Разрешить оповещения для отсутствующих товаров | PRODUCT_SUBSCRIPTION | [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки.
Показывать название | SHOW_NAME | [Y|N] При отмеченной опции будет отображено название элемента.
Показывать изображение | SHOW_IMAGE | [Y|N] При отмеченной опции будет показано изображение элемента.
Текст кнопки "Купить" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Подробнее" | MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Сообщение об отсутствии товара | MESS_NOT_AVAILABLE | Указывается текст, который будет отображаться при отсутствии товара и невозможности его купить.
Текст кнопки "Уведомить о поступлении" | MESS_BTN_SUBSCRIBE | Задается текст, который должен быть отображен на кнопке "Уведомить о поступлении".
Количество элементов на странице | PAGE_ELEMENT_COUNT | Указывается количество элементов, отображаемых на одной странице.
Количество элементов, выводимых в одной строке LINE_ELEMENT_COUNT Указывается количество элементов, выводимых в одной строке таблицы.

Данный параметр недоступен для шаблона vertical.
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения списка элементов. По умолчанию используется синяя схема (blue).
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение Y, то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Сортировать отобранные товары по | BY | Указывается способ сортировки отобранных товаров по Объемам продаж (AMOUNT) или Количеству проданного товара (QUANTITY).
Период выборки (дней) | PERIOD | Указывается период выборки (количество дней) для построения списка самых продаваемых товаров.
Фильтр по статусам заказа | FILTER | Указываются статусы заказов, по товарам из которых будет формироваться список самых продаваемых товаров.
Выводить кнопку сравнения | DISPLAY_COMPARE | [Y|N] При отмеченной опции будет выведена кнопка Сравнить, с помощью которой элемент добавляется в список сравнения.
Цены
Показывать старую цену | SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопка Купить показаны не будут.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах. При выборе данной опции станет доступно [dw]дополнительное поле.[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты, в которой будут отображаться цены.
[/di]
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Название переменной, в которой передается действие | ACTION_VARIABLE | Задается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара.
Название переменной, в которой передается количество товара | PRODUCT_QUANTITY_VARIABLE | Задается имя переменной, в которой будет передаваться количество товара.
Добавлять в корзину свойства товаров и предложений ADD_PROPERTIES_TO_BASKET [Y|N] При отмеченной опции свойства товаров и предложений будут передаваться в корзину. Кроме того, становятся доступными для настройки [dw]параметры[/dw][di]
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить частично заполненные свойства | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
[/di] Название переменной, в которой передаются характеристики товара и Разрешить частично заполненные свойства.
Разрешить указание количества товара | USE_PRODUCT_QUANTITY | [Y|N] При отмеченной опции будет разрешено указывать количества товара.
Параметры вывода товаров из каталога <название_каталога>
Показывать товары каталога SHOW_PRODUCTS_<ID_каталога> [Y|N] При отмеченной опции товары из данного каталога будут отображаться в списке самых продаваемых товаров. Если опция не отмечена, то товары из данного каталога не будут отображаться в списке самых продаваемых, даже если они таковы являются.

Если данная опция отмечена, то становятся доступными для настройки параметры отображения товаров каталога и соответствующих торговых предложений (при наличии).
Свойства для отображения | PROPERTY_CODE_<ID_каталога> | Указываются свойства инфоблока, которые будут отображены в списке самых продаваемых товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Свойства для добавления в корзину | CART_PROPERTIES_<ID_каталога> | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога> | Задается свойство, в котором хранится дополнительная картинка для товара.
Свойство меток товара | LABEL_PROP_<ID_каталога> | Указываются свойство, в котором хранится метка товара (например, новинка).
Параметры вывода торговых предложений <название_каталога_предложений>
Секция доступна, если отмечена опция Показывать товары каталога
Свойства для отображения | PROPERTY_CODE_<ID_каталога_предложений> | Указываются свойства торговых предложений, которые должны быть отображены в списке.
Свойства для добавления в корзину | CART_PROPERTIES_<ID_каталога_предложений> | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога_предложений> | Задается свойство, в котором хранится дополнительная картинка торгового предложения.
Свойства для группировки | OFFER_TREE_PROPS_<ID_каталога_предложений> | Указываются свойства, по значениям которых будут группироваться торговые предложения.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.bestsellers","",
    Array(
        "LINE_ELEMENT_COUNT" => "3",
        "TEMPLATE_THEME" => "blue",
        "BY" => "AMOUNT",
        "PERIOD" => "0",
        "FILTER" => array("N", "P", "F"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "AJAX_MODE" => "N",
        "DETAIL_URL" => "",
        "BASKET_URL" => "/personal/basket.php",
        "ACTION_VARIABLE" => "action",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_QUANTITY_VARIABLE" => "quantity",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PARTIAL_PRODUCT_PROPERTIES" => "N",
        "DISPLAY_COMPARE" => "N",
        "SHOW_OLD_PRICE" => "N",
        "SHOW_DISCOUNT_PERCENT" => "N",
        "PRICE_CODE" => array("BASE"),
        "SHOW_PRICE_COUNT" => "1",
        "PRODUCT_SUBSCRIPTION" => "N",
        "PRICE_VAT_INCLUDE" => "Y",
        "USE_PRODUCT_QUANTITY" => "N",
        "SHOW_NAME" => "Y",
        "SHOW_IMAGE" => "Y",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_NOT_AVAILABLE" => "Нет в наличии",
        "MESS_BTN_SUBSCRIBE" => "Подписаться",
        "PAGE_ELEMENT_COUNT" => "30",
        "SHOW_PRODUCTS_3" => "Y",
        "PROPERTY_CODE_3" => array("MANUFACTURER", "MATERIAL"),
        "CART_PROPERTIES_3" => array("CORNER"),
        "ADDITIONAL_PICT_PROP_3" => "MORE_PHOTO",
        "LABEL_PROP_3" => "SPECIALOFFER",
        "PROPERTY_CODE_4" => array("COLOR"),
        "CART_PROPERTIES_4" => array(),
        "OFFER_TREE_PROPS_4" => array("-"),
        "HIDE_NOT_AVAILABLE" => "N",
        "CONVERT_CURRENCY" => "Y",
        "CURRENCY_ID" => "RUB",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Сопутствующие заказу товары

Описание sale.bigdata.followup.mail

Компонент выводит товары, сопутствующие ранее заказанным товарам. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Сопутствующие заказу товары.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Код заказа | ORDER_ID | Указывается идентификатор заказа с ранее заказанными товарами.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.bigdata.followup.mail",
    "",
    Array(
        "ORDER_ID" => "{#ORDER_ID#}"
    )
);?>


С этим товаром покупают

Описание sale.recommended.products

Компонент служит для отображения на странице с детальной информацией о товаре блока "С этим товаром покупают". По заданному ID товара он выводит все товары, которые были куплены вместе с ним с учетом минимального количества покупок. Компонент стандартный и входит в дистрибутив модуля.

Для корректного функционирования этого компонента необходимо в глобальных настройках модуля Интернет-магазин определить статусы заказов, по товарам из которых будет формироваться список также продаваемых товаров (см. параметр Список статусов, при переводе заказа в которые, товары попадают в сбор).

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > С этим товаром покупают.

Компонент относится к модулю Интернет-магазин.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Выбирается один из созданных в системе типов инфоблоков.
Идентификатор инфоблока товара | IBLOCK_ID | Для выбранного типа инфоблоков задается необходимый инфоблок.
Идентификатор товара | ID | Задается числовой идентификатор товара, для которого должен быть отображен блок "С этим товаром покупают". Можно не задавать, если указан Код товара.
Код товара | CODE | Указывается код товара, для которого должен быть отображен блок "С этим товаром покупают". Можно не задавать, если указан Идентификатор товара.
Минимальное количество покупок товара | MIN_BUYES | Минимальное количество покупок, чтобы блок мог быть отображен.
Источник данных
Не отображать товары, которых нет на складах | HIDE_NOT_AVAILABLE | [Y|N] При отмеченной опции будут скрыты товары, для которых общее количество на складах меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Внешний вид
Показывать процент скидки | SHOW_DISCOUNT_PERCENT | [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана.
Разрешить оповещения для отсутствующих товаров | PRODUCT_SUBSCRIPTION | [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки.
Показывать название | SHOW_NAME | [Y|N] При отмеченной опции будет отображено название элемента.
Показывать изображение | SHOW_IMAGE | [Y|N] При отмеченной опции будет показано изображение элемента.
Текст кнопки "Купить" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Подробнее" | MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Сообщение об отсутствии товара | MESS_NOT_AVAILABLE | Указывается текст, который будет отображаться при отсутствии товара и невозможности его купить.
Текст кнопки "Уведомить о поступлении" | MESS_BTN_SUBSCRIBE | Задается текст, который должен быть отображен на кнопке "Уведомить о поступлении".
Количество элементов на странице | PAGE_ELEMENT_COUNT | Указывается количество элементов, отображаемых на одной странице.
Количество элементов, выводимых в одной строке LINE_ELEMENT_COUNT Указывается количество элементов, выводимых в одной строке таблицы.

Данный параметр недоступен для шаблона vertical.
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения списка элементов. По умолчанию используется синяя схема (blue).
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Адрес страницы с детальной информацией о товаре.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Цены
Показывать старую цену | SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопка Купить показаны не будут.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте CONVERT_CURRENCY При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах. При выборе данной опции станет доступно [dw]дополнительное поле.[/dw][di]
Валюта, в которую будут сконвертированы цены CURRENCY_ID Выбор валюты, в которой будут отображаться цены.
[/di]
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Название переменной, в которой передается действие | ACTION_VARIABLE | Задается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара.
Название переменной, в которой передается количество товара | PRODUCT_QUANTITY_VARIABLE | Задается имя переменной, в которой будет передаваться количество товара.
Добавлять в корзину свойства товаров и предложений ADD_PROPERTIES_TO_BASKET [Y|N] При отмеченной опции свойства товаров и предложений будут передаваться в корзину. Кроме того, становятся доступными для настройки [dw]параметры[/dw][di]
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить частично заполненные свойства | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
[/di] Название переменной, в которой передаются характеристики товара и Разрешить частично заполненные свойства.
Разрешить указание количества товара | USE_PRODUCT_QUANTITY | [Y|N] При отмеченной опции будет разрешено указывать количества товара.
Параметры вывода товаров из каталога <название_каталога>
Показывать товары каталога SHOW_PRODUCTS_<ID_каталога> [Y|N] При отмеченной опции товары из данного каталога будут отображаться среди также продаваемых товаров. Если опция не отмечена, то товары из данного каталога не будут отображаться среди также продаваемых, даже если они таковы являются.

Если данная опция отмечена, то становятся доступными для настройки параметры отображения товаров каталога и соответствующих торговых предложений (при наличии).
Свойства для отображения | PROPERTY_CODE_<ID_каталога> | Указываются свойства инфоблока, которые будут отображены в списке также продаваемых товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Свойства для добавления в корзину | CART_PROPERTIES_<ID_каталога> | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога> | Задается свойство, в котором хранится дополнительная картинка для товара.
Свойство меток товара | LABEL_PROP_<ID_каталога> | Указываются свойство, в котором хранится метка товара (например, новинка).
Параметры вывода торговых предложений <название_каталога_предложений>
Секция доступна, если отмечена опция Показывать товары каталога
Свойства для отображения | PROPERTY_CODE_<ID_каталога_предложений> | Указываются свойства торговых предложений, которые должны быть отображены в списке.
Свойства для добавления в корзину | CART_PROPERTIES_<ID_каталога_предложений> | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога_предложений> | Задается свойство, в котором хранится дополнительная картинка торгового предложения.
Свойства для группировки | OFFER_TREE_PROPS_<ID_каталога_предложений> | Указываются свойства, по значениям которых будут группироваться торговые предложения.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:sale.recommended.products","",
Array(
        "IBLOCK_TYPE" => "catalog",
        "IBLOCK_ID" => "2",
        "ID" => $_REQUEST["PRODUCT_ID"],
        "CODE" => $_REQUEST["PRODUCT_CODE"],
        "MIN_BUYES" => "1",
        "HIDE_NOT_AVAILABLE" => "N",
        "SHOW_DISCOUNT_PERCENT" => "N",
        "PRODUCT_SUBSCRIPTION" => "N",
        "SHOW_NAME" => "Y",
        "SHOW_IMAGE" => "Y",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_NOT_AVAILABLE" => "Нет в наличии",
        "MESS_BTN_SUBSCRIBE" => "Подписаться",
        "PAGE_ELEMENT_COUNT" => "30",
        "LINE_ELEMENT_COUNT" => "3",
        "TEMPLATE_THEME" => "blue",
        "DETAIL_URL" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "86400",
        "SHOW_OLD_PRICE" => "N",
        "PRICE_CODE" => array("BASE"),
        "SHOW_PRICE_COUNT" => "1",
        "PRICE_VAT_INCLUDE" => "Y",
        "CONVERT_CURRENCY" => "N",
        "BASKET_URL" => "/personal/basket.php",
        "ACTION_VARIABLE" => "action",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_QUANTITY_VARIABLE" => "quantity",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PARTIAL_PRODUCT_PROPERTIES" => "N",
        "USE_PRODUCT_QUANTITY" => "Y",
        "SHOW_PRODUCTS_6" => "Y",
        "PROPERTY_CODE_6" => array("YEAR", "AUTHORS", ""),
        "CART_PROPERTIES_6" => array("AUTHORS", ""),
        "ADDITIONAL_PICT_PROP_6" => "MORE_PHOTO",
        "LABEL_PROP_6" => "NEW_BOOK",
        "PROPERTY_CODE_20" => array(""),
        "CART_PROPERTIES_20" => array(""),
        "ADDITIONAL_PICT_PROP_20" => "FILE",
        "OFFER_TREE_PROPS_20" => array()
    )
);?>


Подписка на товары

Описание catalog.product.subscribe

Компонент служит для отображения формы подписки на товар. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Подписка на товары.

Компонент относится к модулю Торговый каталог.

Параметры

Поле | Параметр | Описание
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
ID товара | PRODUCT_ID | Идентификатор товара, на который выполняется подписка.
ID кнопки подписки | BUTTON_ID | Идентификатор кнопки подписки.
CSS класс кнопки подписки | BUTTON_CLASS | CSS класс для кнопки подписки.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:catalog.product.subscribe",
    "",
    Array(
        "BUTTON_CLASS" => "",
        "BUTTON_ID" => "",
        "CACHE_TIME" => "3600",
        "CACHE_TYPE" => "A",
        "PRODUCT_ID" => "78"
    )
);?>


Список товаров на которые вы подписаны

Описание catalog.product.subscribe.list

Компонент служит для отображения списка товаров, на которые подписан пользователь. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Список товаров на которые вы подписаны.

Компонент относится к модулю Торговый каталог.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Количество элементов, выводимых в одной строке | LINE_ELEMENT_COUNT | Указывается количество элементов выводимых в одной строке на странице.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:catalog.product.subscribe.list",
    "",
    Array(
        "CACHE_TIME" => "3600",
        "CACHE_TYPE" => "A",
        "LINE_ELEMENT_COUNT" => "3"
    )
);?>


Подарки к товарам конкретного раздела (устаревший)

Описание sale.gift.section

Компонент служит для отображения подарков к товарам заданного раздела. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Подарки к товарам конкретного раздела.

С версии модуля sale 17.0.9 считается устаревшим. Используйте компонент sale.products.gift.section.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается инфоблок, из которого будет выводиться список товаров.
Источник данных
Показывать товары из раздела | SHOW_FROM_SECTION | [Y|N] При отмеченной опции просмотренные товары будут показываться из того раздела, который указан в нижеследующих настройках: ID раздела, Код раздела, ID элемента, для которого будет выбран раздел и Символьный код элемента, для которого будет выбран раздел. Если опция не отмечена, то данные настройки скрыты.
ID раздела | SECTION_ID | Указывается идентификатор раздела, товары из которого должны быть показаны. Можно не указывать, если задан Код раздела.
Код раздела | SECTION_CODE | Указывается код раздела, товары из которого должны быть показаны. Можно не указывать, если задан ID раздела.
ID элемента, для которого будет выбран раздел | SECTION_ELEMENT_ID | Указывается идентификатор элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан Символьный код элемента, для которого будет выбран раздел.
Символьный код элемента, для которого будет выбран раздел | SECTION_ELEMENT_CODE | Указывается код элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан ID элемента, для которого будет выбран раздел.
Максимальная отображаемая глубина разделов | DEPTH | Параметр определяет максимальную глубину вложенности разделов, из которых будут показаны товары.
Не отображать товары, которых нет на складах | HIDE_NOT_AVAILABLE | [Y|N] При отмеченной опции будут скрыты товары, для которых общее количество на складах меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Внешний вид
Показывать процент скидки | SHOW_DISCOUNT_PERCENT | [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана.
Разрешить оповещения для отсутствующих товаров | PRODUCT_SUBSCRIPTION | [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки.
Показывать название | SHOW_NAME | [Y|N] При отмеченной опции будет отображено название элемента.
Показывать изображение | SHOW_IMAGE | [Y|N] При отмеченной опции будет показано изображение элемента.
Текст кнопки "Купить" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Подробнее" | MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Текст кнопки "Уведомить о поступлении" | MESS_BTN_SUBSCRIBE | Задается текст, который должен быть отображен на кнопке "Уведомить о поступлении".
Количество элементов на странице | PAGE_ELEMENT_COUNT | Указывается количество элементов, отображаемых на одной странице.
Количество элементов, выводимых в одной строке | LINE_ELEMENT_COUNT | Указывается количество элементов, выводимых в одной строке таблицы.
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения списка элементов. По умолчанию используется синяя схема (blue).
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Цены
Показывать старую цену | SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопка Купить показаны не будут.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте | CONVERT_CURRENCY | При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах.
Валюта, в которую будут сконвертированы цены | CURRENCY_ID | Выбор валюты, в которой будут отображаться цены.
Добавление в корзину
Текст заголовка "Подарки" | BLOCK_TITLE | Указывается текст заголовка блока с подарками.
Скрыть заголовок "Подарки" | HIDE_BLOCK_TITLE | [Y|N] При отмеченной опции заголовок блока подарков будет скрыт.
Текст метки "Подарка" | TEXT_LABEL_GIFT/b> | Указывается текст метки, которая проставляется для подарка.
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Название переменной, в которой передается действие | ACTION_VARIABLE | Задается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара.
Название переменной, в которой передается количество товара | PRODUCT_QUANTITY_VARIABLE | Задается имя переменной, в которой будет передаваться количество товара.
Добавлять в корзину свойства товаров и предложений | ADD_PROPERTIES_TO_BASKET | [Y|N] При отмеченной опции свойства товаров и предложений будут передаваться в корзину. Кроме того, становятся доступными для настройки параметры Название переменной, в которой передаются характеристики товара и Разрешить частично заполненные свойства.
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить частично заполненные свойства | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
Разрешить указание количества товара | USE_PRODUCT_QUANTITY | [Y|N] При отмеченной опции будет разрешено указывать количества товара.
Параметры вывода товаров из каталога "<название_каталога>"
Показывать товары каталога SHOW_PRODUCTS_<ID_каталога> [Y|N] При отмеченной опции товары из данного каталога, которые просмотрит пользователь, будут отображаться среди просмотренных товаров. Если опция не отмечена, то товары из данного каталога не будут отображаться среди просмотренных, даже если пользователь их просмотрит.

Если данная опция отмечена, то становятся доступными для настройки параметры отображения товаров каталога и соответствующих торговых предложений (при наличии).
Свойства для отображения | PROPERTY_CODE_<ID_каталога> | Указываются свойства инфоблока, которые будут отображены в списке просмотренных товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Свойства для добавления в корзину | CART_PROPERTIES_<ID_каталога> | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога> | Задается свойство, в котором хранится дополнительная картинка для товара.
Параметры вывода торговых предложений "<название_каталога_предложений>"
Свойства для отображения | PROPERTY_CODE_<ID_каталога_предложений> | Указываются свойства торговых предложений, которые должны быть отображены в списке.
Свойства для добавления в корзину | CART_PROPERTIES_<ID_каталога_предложений> | Из списка выбираются свойства, которые можно добавить в корзину. Для выбора нескольких свойств нужно использовать клавишу Ctrl.
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога_предложений> | Задается свойство, в котором хранится дополнительная картинка торгового предложения.
Свойства для отбора предложений | OFFER_TREE_PROPS_<ID_каталога_предложений> | Указываются свойства, по значениям которых будут группироваться торговые предложения.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:sale.gift.section",
    "",
    Array(
        "ACTION_VARIABLE" => "action",
        "ADDITIONAL_PICT_PROP_2" => "MORE_PHOTO",
        "ADDITIONAL_PICT_PROP_3" => "MORE_PHOTO",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "BASKET_URL" => "/personal/basket.php",
        "BLOCK_TITLE" => "Подарки к товарам этого раздела",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "36000000",
        "CACHE_TYPE" => "A",
        "CART_PROPERTIES_2" => array("","CML2_MANUFACTURER",""),
        "CART_PROPERTIES_3" => array("COLOR_REF","SIZES_SHOES","SIZES_CLOTHES",""),
        "COMPONENT_TEMPLATE" => ".default",
        "CONVERT_CURRENCY" => "N",
        "DEPTH" => "",
        "DETAIL_URL" => "/example/#SECTION_ID#/#ELEMENT_ID#/",
        "HIDE_BLOCK_TITLE" => "N",
        "HIDE_NOT_AVAILABLE" => "N",
        "IBLOCK_ID" => "2",
        "IBLOCK_TYPE" => "catalog",
        "LINE_ELEMENT_COUNT" => "3",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_BTN_SUBSCRIBE" => "Подписаться",
        "OFFER_TREE_PROPS_3" => array("COLOR_REF","SIZES_SHOES","SIZES_CLOTHES"),
        "PAGE_ELEMENT_COUNT" => "5",
        "PARTIAL_PRODUCT_PROPERTIES" => "N",
        "PRICE_CODE" => array("BASE"),
        "PRICE_VAT_INCLUDE" => "Y",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PRODUCT_QUANTITY_VARIABLE" => "",
        "PRODUCT_SUBSCRIPTION" => "N",
        "PROPERTY_CODE_2" => array("BRAND_REF","ARTNUMBER","MATERIAL",""),
        "PROPERTY_CODE_3" => array("","COLOR_REF","SIZES_SHOES","SIZES_CLOTHES",""),
        "SECTION_CODE" => "dresses",
        "SECTION_ELEMENT_CODE" => "",
        "SECTION_ELEMENT_ID" => "",
        "SECTION_ID" => "",
        "SHOW_DISCOUNT_PERCENT" => "Y",
        "SHOW_FROM_SECTION" => "Y",
        "SHOW_IMAGE" => "Y",
        "SHOW_NAME" => "Y",
        "SHOW_OLD_PRICE" => "Y",
        "SHOW_PRICE_COUNT" => "1",
        "SHOW_PRODUCTS_2" => "Y",
        "TEMPLATE_THEME" => "blue",
        "TEXT_LABEL_GIFT" => "Подарок",
        "USE_PRODUCT_QUANTITY" => "N"
    )
);?>


Персональные рекомендации (устаревший)

Компонент выводит рекомендованные сервисом 1C-Битрикс BigData товары с указанным набором свойств, ценами и другими его параметрами. Компонент стандартный и входит в дистрибутив модуля.

Описание catalog.bigdata.products

В визуальном редакторе компонент расположен по пути Магазин > Информация о товарах > Персональные рекомендации.

Внимание! Компонент устарел с версии 17.0.5, не отображается в визуальном редакторе для добавления. Для показа персональных рекомендаций используйте комплексный компонент [comp include_catalog]Каталог[/comp] или простой компонент [comp include_catalog_section]Элементы раздела[/comp].

Подробнее о включении сервиса Персонализации читайте в уроке [image].

Параметры

Поле | Параметр | Описание
Основные параметры
Тип рекомендации RCM_TYPE Выбирается один из типов рекомендаций:
  • bestsell - Самые продаваемые;
  • personal - Персональные рекомендации;
  • similar_sell - Продаваемые с этим товаром;
  • similar_view - Просматриваемые с этим товаром;
  • similar - Похожие товары;
  • any_similar - Продаваемые/Просматриваемые/Похожие товары;
  • any_personal - Самые продаваемые/Персональные;
  • any - Любая рекомендация.
Параметр ID продукта (для товарных рекомендаций) | ID | Для товарных рекомендаций (Продаваемые с этим товаром, Просматриваемые с этим товаром, Похожие товары, Продаваемые/Просматриваемые/Похожие товары, Самые продаваемые/Персональные и Любая рекомендация) необходимо обязательно передавать идентификатор товара.
Тип инфоблока | IBLOCK_TYPE | Выбирается один из созданных в системе типов инфоблоков.
Инфоблок | IBLOCK_ID | Задается инфоблок, товары из которого должны быть показаны.
Источник данных
Показывать товары из раздела | SHOW_FROM_SECTION | [Y|N] При отмеченной опции товары по персональной рекомендации будут показываться из того раздела, который указан в нижеследующих настройках: ID раздела, Код раздела, ID элемента, для которого будет выбран раздел и Символьный код элемента, для которого будет выбран раздел. Если опция не отмечена, то данные настройки скрыты.
ID раздела | SECTION_ID | Указывается идентификатор раздела, товары из которого должны быть показаны. Можно не указывать, если задан Код раздела.
Код раздела | SECTION_CODE | Указывается код раздела, товары из которого должны быть показаны. Можно не указывать, если задан ID раздела.
ID элемента, для которого будет выбран раздел | SECTION_ELEMENT_ID | Указывается идентификатор элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан Символьный код элемента, для которого будет выбран раздел.
Символьный код элемента, для которого будет выбран раздел | SECTION_ELEMENT_CODE | Указывается код элемента, по которому будет выбран раздел для показа товаров. Можно не указывать, если задан ID элемента, для которого будет выбран раздел.
Максимальная отображаемая глубина разделов | DEPTH | Параметр определяет максимальную глубину вложенности разделов, из которых будут показаны товары.
Не отображать товары, которых нет на складах | HIDE_NOT_AVAILABLE | [Y|N] При отмеченной опции будут скрыты товары, для которых общее количество на складах меньше либо равно нулю, включен количественный учет и не разрешена покупка при отсутствии товара.
Внешний вид
Показывать процент скидки | SHOW_DISCOUNT_PERCENT | [Y|N] При отмеченной опции будет отображаться процентное значение скидки, если она задана.
Разрешить оповещения для отсутствующих товаров | PRODUCT_SUBSCRIPTION | [Y|N] При отмеченной опции клиент будет оповещаться, что интересующий его товар стал доступным для покупки.
Показывать название | SHOW_NAME | [Y|N] При отмеченной опции будет отображено название товара.
Показывать изображение | SHOW_IMAGE | [Y|N] При отмеченной опции будет показано изображение товара.
Текст кнопки "Купить" | MESS_BTN_BUY | Задается текст, который должен быть отображен на кнопке "Купить".
Текст кнопки "Подробнее" | MESS_BTN_DETAIL | Задается текст, который должен быть отображен на кнопке "Подробнее".
Текст кнопки "Уведомить о поступлении" | MESS_BTN_SUBSCRIBE | Задается текст, который должен быть отображен на кнопке "Уведомить о поступлении".
Количество элементов на странице | PAGE_ELEMENT_COUNT | Указывается количество товаров, отображаемых на одной странице.
Количество элементов, выводимых в одной строке | LINE_ELEMENT_COUNT | Указывается количество элементов, выводимых в одной строке таблицы.
Цветовая тема | TEMPLATE_THEME | Задается цветовая схема для отображения товаров. По умолчанию используется синяя схема (blue).
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Цены
Показывать старую цену | SHOW_OLD_PRICE | [Y|N] Если задана скидка на товар, то при отмеченной опции будет отображаться старая цена.
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопка Купить показаны не будут.
Выводить цены для количества | SHOW_PRICE_COUNT | Параметр определяет количество единиц товара, для которых выводить стоимость.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цены будут показаны с учетом НДС.
Показывать цены в одной валюте | CONVERT_CURRENCY | При установке флажка цены будут выводиться в одной валюте, даже если в каталоге они будут заданы в разных валютах.
Валюта, в которую будут сконвертированы цены | CURRENCY_ID | Выбор валюты, в которой будут отображаться цены.
Добавление в корзину
URL, ведущий на страницу с корзиной покупателя | BASKET_URL | Указывается путь к странице с корзиной покупателя.
Название переменной, в которой передается действие | ACTION_VARIABLE | Задается имя переменной, в которой передается действие: ADD_TO_COMPARE_LIST, ADD2BASKET и т.д. Значение поля по умолчанию action. Значение параметра должно быть уникальным среди всех используемых компонентов на одной странице.
Название переменной, в которой передается код товара для покупки | PRODUCT_ID_VARIABLE | Задается имя переменной, в которой будет передаваться идентификатор товара.
Название переменной, в которой передается количество товара | PRODUCT_QUANTITY_VARIABLE | Задается имя переменной, в которой будет передаваться количество товара.
Добавлять в корзину свойства товаров и предложений | ADD_PROPERTIES_TO_BASKET | [Y|N] При отмеченной опции свойства товаров и предложений будут передаваться в корзину. Кроме того, становятся доступными для настройки параметры Название переменной, в которой передаются характеристики товара и Разрешить частично заполненные свойства.
Название переменной, в которой передаются характеристики товара | PRODUCT_PROPS_VARIABLE | Задается имя переменной, в которой будет передаваться характеристики товара.
Разрешить частично заполненные свойства | PARTIAL_PRODUCT_PROPERTIES | [Y|N] При отмеченной опции в корзину будут добавляться и те товары, у которых заполнены не все характеристики. Если же опция не отмечена, то товар будет добавлен в корзину только при условии, что все характеристики, добавляемые в корзину, заполнены. На торговые предложения этот параметр не влияет.
Разрешить указание количества товара | USE_PRODUCT_QUANTITY | [Y|N] При отмеченной опции будет разрешено указывать количества товара.
Параметры вывода товаров из каталога "<название_каталога>"
Показывать товары каталога SHOW_PRODUCTS_<ID_каталога> [Y|N] При отмеченной опции в блоке рекомендаций будут отображаться товары из данного каталога, если они попали в персональные рекомендации для посетителя.

Если данная опция отмечена, то становятся доступными для настройки параметры отображения товаров каталога и соответствующих торговых предложений (при наличии).
Свойства для отображения | PROPERTY_CODE_<ID_каталога> | Указываются свойства товаров инфоблока, которые будут отображаться в списке товаров. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках ниже, свойства выведены не будут.
Свойства для добавления в корзину | CART_PROPERTIES_<ID_каталога> | Из списка выбираются свойства, которые будут отображаться для товаров в корзине. Для выбора нескольких свойств нужно использовать клавишу Ctrl.
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога> | Задается свойство, в котором хранится дополнительная картинка для товара.
Свойство меток товара | LABEL_PROP_<ID_каталога> | Указываются свойство, в котором хранится метка товара (например, новинка).
Параметры вывода торговых предложений "<название_каталога_предложений>"
Свойства для отображения | PROPERTY_CODE_<ID_каталога_предложений> | Указываются свойства торговых предложений, которые должны быть отображены в списке.
Свойства для добавления в корзину | CART_PROPERTIES_<ID_каталога_предложений> | Из списка выбираются свойства, которые будут отображаться для товарных позиций в корзине. Для выбора нескольких свойств нужно использовать клавишу Ctrl.
Дополнительная картинка | ADDITIONAL_PICT_PROP_<ID_каталога_предложений> | Задается свойство, в котором хранится дополнительная картинка торгового предложения.
Свойства для отбора предложений | OFFER_TREE_PROPS_<ID_каталога_предложений> | Указываются свойства, по значениям которых будут группироваться торговые предложения.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:catalog.bigdata.products",
    "",
    Array(
        "RCM_TYPE" => "any",
        "ID" => $_REQUEST["PRODUCT_ID"],
        "IBLOCK_TYPE" => "catalog",
        "IBLOCK_ID" => "2",
        "HIDE_NOT_AVAILABLE" => "N",
        "SHOW_DISCOUNT_PERCENT" => "Y",
        "PRODUCT_SUBSCRIPTION" => "N",
        "SHOW_NAME" => "Y",
        "SHOW_IMAGE" => "Y",
        "MESS_BTN_BUY" => "Купить",
        "MESS_BTN_DETAIL" => "Подробнее",
        "MESS_BTN_SUBSCRIBE" => "Подписаться",
        "PAGE_ELEMENT_COUNT" => "30",
        "LINE_ELEMENT_COUNT" => "3",
        "TEMPLATE_THEME" => "blue",
        "DETAIL_URL" => "/catalog/#SECTION_CODE#/#ELEMENT_CODE#/",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_GROUPS" => "Y",
        "SHOW_OLD_PRICE" => "N",
        "PRICE_CODE" => array("BASE"),
        "SHOW_PRICE_COUNT" => "1",
        "PRICE_VAT_INCLUDE" => "Y",
        "CONVERT_CURRENCY" => "Y",
        "BASKET_URL" => "/personal/cart/",
        "ACTION_VARIABLE" => "action",
        "PRODUCT_ID_VARIABLE" => "id",
        "ADD_PROPERTIES_TO_BASKET" => "Y",
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PARTIAL_PRODUCT_PROPERTIES" => "N",
        "USE_PRODUCT_QUANTITY" => "N",
        "SHOW_PRODUCTS_2" => "Y",
        "CURRENCY_ID" => "RUB",
        "PROPERTY_CODE_2" => array("NEWPRODUCT", "MANUFACTURER", "MATERIAL", "COLOR", ""),
        "CART_PROPERTIES_2" => array("NEWPRODUCT", ""),
        "ADDITIONAL_PICT_PROP_2" => "MORE_PHOTO",
        "LABEL_PROP_2" => "NEWPRODUCT",
        "PROPERTY_CODE_3" => array("COLOR_REF", "SIZES_SHOES", "SIZES_CLOTHES", ""),
        "CART_PROPERTIES_3" => array("COLOR_REF", "SIZES_SHOES", "SIZES_CLOTHES", ""),
        "ADDITIONAL_PICT_PROP_3" => "MORE_PHOTO",
        "OFFER_TREE_PROPS_3" => array("COLOR_REF", "SIZES_SHOES", "SIZES_CLOTHES"),
        "PRODUCT_QUANTITY_VARIABLE" => "quantity"
    )
);?>


Склады

Подраздел предназначен для работы со складами и содержит следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Склады | catalog.store | Осуществляет вывод полного списка складов.
Список складов | catalog.store.list | Осуществляет вывод списка складов с подробной информацией.
Информация о складе | catalog.store.detail | Осуществляет вывод подробной информации о складе.
Остатки по складам | catalog.store.amount | Выводит остатки выбранного товара по складам, на которых он имеется.


Склады (комплексный компонент)

Описание catalog.store

Комплексный компонент осуществляет вывод полного списка складов. Его функциональность объединяет возможности нескольких одностраничных компонентов, таких как Информация о складе, Список складов. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Склады > Склады.

Компонент относится к модулю Торговый каталог.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • liststores - страница со списком складов;
  • element - страница детального описания склада.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Отображать телефон | PHONE | При отмеченной опции будет выводиться телефон.
Отображать график работы | SCHEDULE | При отмеченной опции будет выводиться график работы.
Устанавливать заголовок страницы | SET_TITLE | При отмеченной опции будет выведен заголовок страницы, указанный в поле TITLE.
Заголовок страницы | TITLE | Указывается заголовок страницы.
Тип используемой карты MAP_TYPE Выбирается вид используемой карты:
  • Yandex;
  • Google.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:catalog.store",
    "",
    Array(
        "SEF_MODE" => "Y",
        "PHONE" => "Y",
        "SCHEDULE" => "Y",
        "SET_TITLE" => "Y",
        "TITLE" => "Список складов с подробной информацией",
        "MAP_TYPE" => "0",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SEF_FOLDER" => "/novyy-razdel/",
        "SEF_URL_TEMPLATES" => Array(
            "liststores" => "index.php",
            "element" => "#store_id#"
        ),
        "VARIABLE_ALIASES" => Array(
            "liststores" => Array(),
            "element" => Array(),
        )
    )
);?>


Список складов

Описание catalog.store.list

Одностраничный компонент осуществляет вывод списка складов с подробной информацией. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Склады > Список складов.

Компонент относится к модулю Торговый каталог.

Параметры

Поле | Параметр | Описание
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Отображать телефон | PHONE | При отмеченной опции будет выводиться телефон.
Отображать график работы | SCHEDULE | При отмеченной опции будет выводиться график работы.
Тип карты MAP_TYPE Выбирается вид используемой карты:
  • Yandex;
  • Google.
Устанавливать заголовок страницы | SET_TITLE | При отмеченной опции будет показан заголовок страницы.
Шаблон пути к каталогу STORE(относительно корня) | PATH_TO_ELEMENT | Указывается путь к странице к каталогу STORE.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:catalog.store.list",
    "",
    Array(
        "PHONE" => "Y",
        "SCHEDULE" => "Y",
        "PATH_TO_ELEMENT" => "store/#store_id#",
        "MAP_TYPE" => "0",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000"
    )
);?>


Информация о складе

Описание catalog.store.detail

Одностраничный компонент осуществляет вывод подробной информации о складе. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Магазин > Склады > Информация о складе.

Компонент относится к модулю Торговый каталог.

Параметры

Поле | Параметр | Описание
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
ID склада | STORE | Указывается ID склада.
Тип карты MAP_TYPE Выбирается вид используемой карты:
  • Yandex;
  • Google.
Устанавливать заголовок страницы | SET_TITLE | При отмеченной опции будет выведен заголовок страницы из названия и адреса склада.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:catalog.store.detail",
    "",
    Array(
        "STORE" => "1",
        "MAP_TYPE" => "0",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_NOTES" => "",
        "SET_TITLE" => "Y"
    )
);?>


Остатки по складам

Описание catalog.store.amount

Компонент выводит остатки выбранного товара по складам, на которых он имеется.

В визуальном редакторе компонент расположен по пути Магазин > Склады > Остатки по складам.

Компонент относится к модулю Торговый каталог.

Параметры

Поле | Параметр | Описание
Основные параметры
Склады | STORES | Выбираются склады, информация по которым должна быть показана. Для выбора нескольких значений следует воспользоваться клавишей Ctrl.
Товар | ELEMENT_ID | Идентификатор товара, остатки по складам которого должны быть отображены. Можно не указывать, если задан Код товара.
Код товара | ELEMENT_CODE | Символьный код товара, остатки по складам которого должны быть отображены. Можно не указывать, если задан идентификатор в поле Товар.
Торговое предложение | OFFER_ID | Идентификатор торгового предложения, остатки по складам которого должны быть отображены.
Шаблоны ссылок
URL на страницу, где будет показана детальная информация о складе | STORE_PATH | Адрес страницы с детальной информацией по складу.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Заголовок | MAIN_TITLE | Указывается заголовок блока о количестве товара на складе.
Склады
Свойства | USER_FIELDS | Выбираются пользовательские поля складов для отображения. С помощью клавиши Ctrl можно выбрать несколько значений.
Поля | FIELDS | Выбираются поля складов для отображения. С помощью клавиши Ctrl можно выбрать несколько значений.
Отображать склад при отсутствие на нем товара | SHOW_EMPTY_STORE | [Y|N] При отмеченной опции склад будет отображен, даже если на нем нет товара.
Показывать вместо точного количества информацию о достаточности USE_MIN_AMOUNT [Y|N] При отмеченной опции количество имеющегося на складе товара будет заменено на выражение "достаточно" или "мало". Кроме того, становится доступным для настройки параметр [dw]Минимальное достаточное количество товара на складе[/dw][di]
Минимальное достаточное количество товара на складе MIN_AMOUNT Указывается значение, меньше которого о количестве товара на складе будет отображаться выражение "мало". Если количество товара на складе больше, чем это значение, то на странице будет отображаться выражение "достаточно".
[/di] .
Показывать общую информацию по складам | SHOW_GENERAL_STORE_INFORMATION | [Y|N] При Y будет показана только общая информация по складам. При значении N дается информация по складам в отдельности (не общей суммой).

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:catalog.store.amount",
    "",
    Array(
        "STORES" => array(),
        "ELEMENT_ID" => "29",
        "ELEMENT_CODE" => "",
        "OFFER_ID" => "",
        "STORE_PATH" => "/store/store_detail.php",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000",
        "MAIN_TITLE" => "Наличие товара на складах",
        "USER_FIELDS" => array("",""),
        "FIELDS" => array("TITLE","ADDRESS","PHONE","SCHEDULE",""),
        "SHOW_EMPTY_STORE" => "Y",
        "USE_MIN_AMOUNT" => "Y",
        "SHOW_GENERAL_STORE_INFORMATION" => "N",
        "MIN_AMOUNT" => "0"
    )
);?>


Служебные

Внимание! Часть служебных компонентов невозможно настроить через публичный раздел. В этом случае их нужно настраивать редактируя код страницы как php-файл.

Сущности
Название | Имя в пространстве имен bitrix | Описание
Подразделы
Навигация |  | Объединяет компоненты разных модулей, служащие для навигации между сайтами, по меню и др.
Безопасность | security.user | Предназначен для управления резервными кодами для двухэтапной авторизации.
Включаемые области | main.include | Служит для расположения на страницах и в разделах включаемых областей.
Поиск | search | Используется для размещения следующих компонентов, которые осуществляют индексирование и поиск информации на сайте
Пользователь |  | Подраздел содержит компоненты для работы с профилями пользователей.
Статистика | statistic.table | Подраздел содержит компонент для вывода статистики по сайту.
Компоненты
Соц. закладки и сети | main.share | Выводит панель закладок со значками соц. сетей. Он позволяет быстро запустить окно соц. сети и оставить сообщение о вашей странице сайта, например, о новостях или сообщениях форума и т.д.
Упрощенный HTML-редактор | fileman.light_editor | Выводит упрощенный визуальный HTML-редактор.
Форма обратной связи | main.feedback | Выводит форму для отправки сообщения с сайта на E-mail.
Элемент управления "Календарь" | main.calendar | Используется для ввода даты/времени.
Элемент управления "Палитра" | main.colorpicker | Используется для ввода таблицы цвета.
Элемент управления "Часы" | main.clock | Служит для удобного ввода времени с использованием часов.
Журнал изменений | event_list | Позволяет вывести историю изменений, произошедших на проекте.


Соц. закладки и сети

Описание main.share

Компонент выводит панель закладок со значками соц. сетей. Он позволяет быстро запустить окно соц. сети и оставить сообщение о вашей странице сайта, например, о новостях или сообщениях форума и т.д. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к Главному модулю.

Параметры

Поле | Параметр | Описание
Дополнительно
Скрыть панель закладок по умолчанию | HIDE | [Y|N] При отмеченной опции панель со значками соц. сетей будет скрыта по умолчанию. При работе с сайтом пользователь сможет развернуть ее.
Используемые соц. закладки и сети | HANDLERS | В виде массива перечисляются соц.закладки и сети, которые требуется отобразить в выводимой панели.
URL страницы относительно корня сайта | PAGE_URL | На основании введенного URL будет сформирована ссылка, ведущая на вашу страницу. Ссылка отобразится по умолчанию в коротком сообщении в выбранной соц. сети.
Заголовок страницы | PAGE_TITLE | Введенный заголовок страницы будет использован при формировании сообщения пользователя, размещающего микроблог.
Логин для bit.ly | SHORTEN_URL_LOGIN | Зарегистрируйтесь на ресурсе http://bit.ly/ [image] [image] и введите ваш логин оттуда.
Ключ API для bit.ly | SHORTEN_URL_KEY | После регистрации на ресурсе http://bit.ly/ [image] [image] вы получите API Key. Его необходимо ввести в данном поле. После проведенных настроек ссылка на ваш сайт будет автоматически укорачиваться средствами bit.ly и примет такой вид http://bit.ly/aLj59v. Данная технология применена к twitter, где критична длина сообщения.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:main.share","",Array(
    "HIDE" => "N",
    "HANDLERS" => array
         ("delicious","twitter","vk"),
    "PAGE_URL" => "/examples/test.php",
    "PAGE_TITLE" => "Моя страница",
    "SHORTEN_URL_LOGIN" => "my_login",
    "SHORTEN_URL_KEY" => "K_edgd354df5454g5dg1b34a6cd1b10ffe05e30",
    )
);?>


Упрощенный HTML-редактор

Описание fileman.light_editor

Компонент выводит упрощенный визуальный HTML-редактор [image]. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Упрощенный HTML-редактор.

Компонент относится к модулю Управление структурой.

Параметры

Поле | Параметр | Описание
Основные настройки
Содержимое | CONTENT | Задается произвольный текст, который будет отображен в поле редактора.
Имя элемента управления | INPUT_NAME | Указывается имя текстового поля (добавляется в Содержимое). Необходимо для обработки сообщения при вводе.
ID элемента управления | INPUT_ID | Указывается идентификатор элемента управления. Если данные из текстового поля будут обрабатываться с помощью JavaScript, то сам элемент удобно "взять" зная это ID.
Ширина редактора | WIDTH | Указывается ширина окна редактора в пикселях (px) или в процентах (%).
Высота редактора | HEIGHT | Указывается высота окна редактора в пикселях (px).
Разрешить пользователю изменять высоту области редактирования | RESIZABLE | [Y|N] При отмеченной опции пользователю будет разрешено изменять высоту области редактирования.
Автоматическое увеличение области редактирования при наборе текста | AUTO_RESIZE | [Y|N] При отмеченной опции высота области редактирования будет автоматически увеличиваться по мере набора текста. Доступно только при отмеченной опции Разрешить пользователю изменять высоту области редактирования.
Настройки вставки видео
Разрешить вставку видео VIDEO_ALLOW_VIDEO [Y|N] При отмеченной опции будет разрешена вставка видео средствами упрощенного HTML-редактора. Станут доступны для заполнения [dw]дополнительные поля.[/dw][di]
Максимальная ширина видео | VIDEO_MAX_WIDTH | Указывается максимальная ширина окна для видео в пикселях (px).
Максимальная высота видео | VIDEO_MAX_HEIGHT | Указывается максимальная высота окна для видео в пикселях (px).
Размер буфера в секундах | VIDEO_BUFFER | Указывается размер буфера в секундах (т.е. промежуток времени ролика, который будет сохранен в буфер перед началом воспроизведения). Рекомендуется для медленного трафика.
Путь к изображению авторского знака | VIDEO_LOGO | Указывается путь к изображению авторского логотипа, который будет накладываться на видео.
Режим окна (WMode) (Только для Flash-плеера) VIDEO_WMODE Указывается режим окна только для Flash-плеера:
  • Обычный (window) - медиафайл будет проигрываться на странице в собственном прямоугольном окне. Этот вариант дает наибольший выигрыш в скорости воспроизведения анимации;
  • Непрозрачный (opaque) - медиафайл будет помещен на задний план страницы.
  • Прозрачный (transparent) - фон страницы будет "проглядывать" через все прозрачные места медиафайла при проигрывании. Этот вариант может замедлить скорость воспроизведения анимации.
Режим окна (windowless) (Только для Silverlight-плеера) | VIDEO_WINDOWLESS | [Y|N] При отмеченной опции только для Silverlight-плеера будет использоваться режима окна Прозрачный (windowless). Окно плеера будет отображаться непосредственно в клиентской области обозревателя или внутри специально созданного окна.
Путь к скину (Только для Flash-плеера) | VIDEO_SKIN | Указывается путь к скину только для Flash-плеера. Пользовательские скины должны храниться в директории, не затрагиваемой системой обновлений.
[/di]
Дополнительные настройки
Разрешить использование файлового диалога | USE_FILE_DIALOGS | [Y|N] При отмеченной опции будет разрешено использование файлового диалога системы (например, диалоги для указания путей загружаемых картинок или видеофайлов).
Служебный ID элемента управления | ID | Указывается служебный идентификатор элемента управления. Имеет значение при работе с API на JavaScript.
Имя Javascript-объекта | JS_OBJ_NAME | Указывается имя используемого JavaScript-объекта.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:fileman.light_editor","",Array(
    "CONTENT" => "",
    "INPUT_NAME" => "",
    "INPUT_ID" => "",
    "WIDTH" => "100%",
    "HEIGHT" => "300px",
    "RESIZABLE" => "Y",
    "AUTO_RESIZE" => "Y",
    "VIDEO_ALLOW_VIDEO" => "Y",
    "VIDEO_MAX_WIDTH" => "640",
    "VIDEO_MAX_HEIGHT" => "480",
    "VIDEO_BUFFER" => "20",
    "VIDEO_LOGO" => "",
    "VIDEO_WMODE" => "transparent",
    "VIDEO_WINDOWLESS" => "Y",
    "VIDEO_SKIN" => "/bitrix/components/bitrix/player/mediaplayer/skins/bitrix.swf",
    "USE_FILE_DIALOGS" => "Y",
    "ID" => "",
    "JS_OBJ_NAME" => ""
    )
);?>


Форма обратной связи

Описание main.feedback

Компонент выводит форму для отправки сообщения с сайта на E-mail. Компонент является стандартным и входит в дистрибутив модуля.

Для работы формы не требуется модуль Почта.

Компонент относится к Главному модулю.

Параметры

Поле | Параметр | Описание
Основные параметры
Использовать защиту от автоматических сообщений (CAPTCHA) для неавторизованных пользователей | USE_CAPTCHA | [Y|N] При отмеченной опции для неавторизованных пользователей будет использоваться CAPTCHA при создании сообщений.
Сообщение, выводимое пользователю после отправки | OK_TEXT | Задается текст сообщения, выводимый пользователю после отправки.
E-mail, на который будет отправлено письмо | EMAIL_TO | Задается E-mail, на который будет отправлено письмо (будет отображен в форме для отправки сообщений в поле Ваш E-mail).
Обязательные поля для заполнения | REQUIRED_FIELDS | Указываются поля формы, которые будут обязательными для заполнения.
Почтовые шаблоны для отправки письма | EVENT_MESSAGE_ID | Указывается почтовый шаблон, на основе которого будут отправляться письма.

Если компонент размещён на сайте, настроен, но сообщения не приходят, необходимо:

  • С помощью Проверки системы необходимо убедиться что почта уходит с сайта.
  • Убедиться, что есть активный почтовый шаблон FEEDBACK_FORM.
  • Убедиться, что в шаблоне проставлен валидный адрес в поле Кому.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:main.feedback","",Array(
        "USE_CAPTCHA" => "Y",
        "OK_TEXT" => "Спасибо, ваше сообщение принято.",
        "EMAIL_TO" => "my@email.com",
        "REQUIRED_FIELDS" => Array("NAME","EMAIL","MESSAGE"),
        "EVENT_MESSAGE_ID" => Array("5")
    )
);?>


Элемент управления "Календарь"

Описание main.calendar

Компонент используется для ввода даты/времени. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Элемент управления Календарь.

Компонент относится к Главному модулю.

Параметры

Поле | Параметр | Описание
Основные параметры
Показывать элемент управления SHOW_INPUT [Y|N] Параметр служит для выбора способа отображения календаря:
  • Y - показывать иконки календаря с полем ввода;
  • N - показывать только иконки календаря.
Имя формы | FORM_NAME | Указывается имя формы календаря.
Имя первого поля интервала | INPUT_NAME | Указывается название переменной первого поля временного интервала.
Имя второго поля интервала | INPUT_NAME_FINISH | Указывается название переменной второго поля временного интервала.
Значение первого поля интервала | INPUT_VALUE | Указывается значение по умолчанию первого поля временного интервала.
Значение второго поля интервала | INPUT_VALUE_FINISH | Указывается значение по умолчанию второго поля временного интервала.
Позволять вводить время | SHOW_TIME | [Y|N] При отмеченной опции пользователь имеет возможность указать не только дату, но и время.
Скрывать поле для ввода времени | HIDE_TIMEBAR | [Y|N] При отмеченной опции поле для ввода времени будет скрыто.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:main.calendar","",Array(
     "SHOW_INPUT" => "Y",
     "FORM_NAME" => "",
     "INPUT_NAME" => "date_fld",
     "INPUT_NAME_FINISH" => "date_fld_finish",
     "INPUT_VALUE" => "",
     "INPUT_VALUE_FINISH" => "",
     "SHOW_TIME" => "Y",
     "HIDE_TIMEBAR" => "Y"
    )
);?>


Элемент управления "Палитра"

Описание main.colorpicker

Компонент используется для ввода таблицы цвета. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Элемент управления "Палитра".

Компонент относится к Главному модулю.

Параметры

Поле | Параметр | Описание
Основные параметры
Показывать кнопку | SHOW_BUTTON | [Y|N] При отмеченной опции кнопки компонента будут отображены на странице.
Идентификатор | ID | Идентификатор компонента.
Название | NAME | Имя компонента, которое будет отображаться в публичной части.
Обработчик события выбора | ONSELECT | Обработчик, который будет использовать данный компонент.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:main.colorpicker","",Array(
        "SHOW_BUTTON" => "Y",
        "ID" => "123",
        "NAME" => "Выбор цвета",
        "ONSELECT" => ""
    ),
false
);?>


Элемент управления "Часы"

Описание main.clock

Компонент служит для удобного ввода времени с использованием часов. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Элемент управления "Часы".

Компонент относится к Главному модулю.

Параметры

Поле | Параметр | Описание
Основные параметры
ID поля ввода | INPUT_ID | Указывается идентификатор поля ввода, в которое вставится время. Если поле ввода при открытии содержит какое-то время, то оно будет отображаться на часах.
Имя поля ввода | INPUT_NAME | Указывается название поля ввода.
Всплывающая подсказка на поле ввода | INPUT_TITLE | Указывается всплывающая подсказка, которая отображается при наведении курсора мыши на поле ввода.
Стартовое время (HH:MM) | INIT_TIME | При необходимости указывается стартовое время в формате HH:MM, которое будет отображаться на часах. Если стартовое время не указано, то на часах будет отображатся текущее время, округленное с точностью до значения, указанного в параметре STEP.
Минимальный шаг для задания времени, в минутах | STEP | Указывается минимальный шаг для задания времени: 5, 15, 30 или 60 минут. Значение по умолчанию 5 минут.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:main.clock","",Array(
        "INPUT_ID" => "",
        "INPUT_NAME" => "Время",
        "INPUT_TITLE" => "Укажите необходимое время",
        "INIT_TIME" => "12:30",
        "STEP" => "0"
    )
);?>


Журнал изменений

Одностраничный компонент позволяет вывести историю изменений, произошедших на проекте.

Описание

В компоненте отображаются следующие действия:

  • пользователи (добавление, изменение, удаление);
  • страницы (изменение, добавление, удаление);
  • меню (изменение, создание, удаление);
  • файлы (изменение, добавление, удаление, перемещение, копирование, переименование);
  • разделы (добавление, изменение, удаление, перемещение, копирование, переименование);
  • инфоблоки (все события инфоблоков);
  • форумы общие и в рамках социальных сетей (сообщение: скрытие,показ, изменение, перенос, удаление; тема: показ, скрытие, прикрепление, открепление, открытие, закрытие, удаление, изменение).

В визуальном редакторе компонент расположен в разделе: Служебные.

Компонент относится к Главному модулю.

Настройки компонента

Поле | Параметр | Описание
Шаблоны ссылок
Шаблоны путей к странице пользователя | USER_PATH | Шаблон пути необходимо поменять, если он был изменен в рамках всего проекта.
Шаблоны путей к форуму | FORUM_PATH | Шаблон пути необходимо поменять, если он был изменен в рамках всего проекта.
Шаблоны путей к теме форума | FORUM_TOPIC_PATH | Шаблон пути необходимо поменять, если он был изменен в рамках всего проекта.
Шаблоны путей к сообщению форума | FORUM_MESSAGE_PATH | Шаблон пути необходимо поменять, если он был изменен в рамках всего проекта.
Дополнительные настройки
Количество отображаемых записей на странице | PAGE_NUM | Число записей на странице. При превышении указанного числа, включается постраничная навигация
Настройки фильтра
Элементы в фильтре | FILTER | Выбор сущностей, по которым возможна фильтрация данных.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:event_list",
    "",
    Array(
        "PAGE_NUM" => "10",
        "FILTER" => array("FORUM","USERS","PAGE_EDIT","MENU_EDIT"),
        "USER_PATH" => "company/personal/user/#user_id#/",
        "FORUM_PATH" => "community/forum/forum#FORUM_ID#/",
        "FORUM_TOPIC_PATH" => "community/forum/forum#FORUM_ID#/topic#TOPIC_ID#/",
        "FORUM_MESSAGE_PATH" => "community/forum/messages/forum#FORUM_ID#/topic#TOPIC_ID#/message#MESSAGE_ID#/#message#MESSAGE_ID#"
    )
);?>


Навигация

Подраздел объединяет компоненты разных модулей, служащие для навигации между сайтами, по меню и др. Включает в себя компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Навигация
Выбор сайта | main.site.selector | Включен в шаблон дизайна сайта и служит для переключения между сайтами, созданными на базе данной копии продукта.
Меню | menu | Выводит меню указанного типа.
Меню для мобильной платформы | mobileapp.menu | Служит для построения меню мобильного приложения административной части интернет-магазина.
[link=63461 ]Навигационная цепочка[/link] | breadcrumb | Выводит навигационную цепочку в шаблоне.
Пункты меню | menu.sections | Осуществляет дополнение созданного меню названиями разделов инфоблоков.


Выбор сайта

Описание

Компонент включен в шаблон дизайна сайта и служит для переключения между сайтами, созданными на базе данной копии продукта. Компонент определяет путь к корневым директориям сайтов, созданных в системе, и выводит ссылки с названиями сайтов в определенном в шаблоне дизайна сайта месте. При этом ссылка с названием текущего (просматриваемого в данный момент) сайта не подсвечивается, т.е. является неактивной. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Навигация > Выбор сайта.

Компонент относится к Главному модулю.

Параметры

Поле | Параметр | Описание
Источник данных
Список сайтов | SITE_LIST | Указываются сайты, ссылки на которые будут выведены данным компонентом в публичном разделе.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:main.site.selector","",Array(
        "SITE_LIST" => Array("*all*"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Меню

Компонент выводит меню указанного типа. Компонент является стандартным и входит в дистрибутив модуля.

Описание menu

В визуальном редакторе компонент расположен по пути: Служебные > Навигация > Меню.

Компонент относится к Главному модулю.

В поставку продукта входят следующие шаблоны компонента Меню (bitrix:menu):

  • Горизонтальное многоуровневое выпадающее меню (Яркий) (horizontal_multilevel);
  • Левое меню (Яркий) (left);
  • Вертикальное меню по умолчанию (Встроенный шаблон) (.default);
  • Голубое меню в виде закладок (Встроенный шаблон) (blue_tabs);
  • Серое меню в виде закладок (Встроенный шаблон) (grey_tabs);
  • Древовидное меню (Встроенный шаблон) (tree);
  • Вертикальное многоуровневое выпадающее меню (Встроенный шаблон) (vertical_multilevel).

Параметры

Поле | Параметр | Описание
Основные параметры
Тип меню для первого уровня | ROOT_MENU_TYPE | Указывается тип меню верхнего уровня, соответствующий данному меню.
Настройки кеширования
Тип кеширования MENU_CACHE_TYPE Тип кеширования:
  • A - Авто: автоматически обновляет кеш компонентов в течение заданного времени;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования | MENU_CACHE_TIME | Время кеширования в секундах.
Учитывать права доступа | MENU_CACHE_USE_GROUPS | При кешировании будут учитываться права доступа пользователя к тем или иным пунктам меню. Если меню построено без учета прав доступа, флажок лучше снять - размер кеша уменьшится.
Значимые переменные запроса | MENU_CACHE_GET_VARS | Если отображение меню зависит от параметров страницы, то при использовании кеширования необходимо указать параметры в этом поле. Параметры вводятся через запятую.
Дополнительные настройки
Уровень вложенности меню | MAX_LEVEL | В выпадающем списке выберите уровень вложенности. Доступно четыре уровня. Чем больше число, тем пункты более низких уровней будут отображены.
Тип меню для остальных уровней | CHILD_MENU_TYPE | Укажите тип меню для меню нижних уровней.
Подключать файлы с именами вида .тип_меню.menu_ext.php | USE_EXT | [Y|N] При отмеченной опции будет разрешено подключать файлы с именами вида .тип_меню.menu_ext.php.
Откладывать выполнение шаблона меню DELAY [Y|N] При отмеченной опции выполнение шаблона будет происходить после загрузки страницы. Очень удобен при включенном кешировании компонента, если нужно все же выполнять какие-то действия по модификации внешнего вида пунктов меню в зависимости от текущей страницы. Например, добавление пунктов меню в компонентах.
$GLOBALS['BX_MENU_CUSTOM']->AddItem('left', array(
'TEXT' => 'Моб. версия', 'LINK' => $APPLICATION->
GetCurPage(false) . '?mobile'))

Первый параметр - тип меню. Второй - массив, описывающий пункт меню [image].

Разрешить несколько активных пунктов одновременно | ALLOW_MULTI_SELECT | [Y|N] При отмеченной опции будет разрешено несколько активных пунктов меню одновременно.
Параметры для ручной настройки, в форме настройки компонента не видны
CACHE_SELECTED_ITEMS | Y\N. Определяет подмешивать или нет URL в кеш. По умолчанию меню кешируется отдельно для каждого раздела. Если на сайте много разделов, то размер кеша [image] меню может вызвать падение сайта из-за переполнения места на диске. Ограничение константы отключающей подмешивание URL в том, что во вложенном разделе может полностью быть переопределены пункты меню.
MENU_CACHE_USE_USERS | Y\N. Определяет подмешивать ли в кеш id пользователя.То есть делать ли его уникальным для каждого пользователя. Нужно когда оно отличается для каждого пользователя.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:menu",".default",Array(
        "ROOT_MENU_TYPE" => "top",
        "MAX_LEVEL" => "1",
        "CHILD_MENU_TYPE" => "top",
        "USE_EXT" => "Y",
        "DELAY" => "N",
        "ALLOW_MULTI_SELECT" => "Y",
        "MENU_CACHE_TYPE" => "N",
        "MENU_CACHE_TIME" => "3600",
        "MENU_CACHE_USE_GROUPS" => "Y",
        "MENU_CACHE_GET_VARS" => ""
    )
);?>

Смотрите также

  • Создание и работа с меню [image] в курсе Разработчик Bitrix Framework.


Меню для мобильной платформы

Описание mobileapp.menu

Компонент служит для построения меню мобильного приложения административной части интернет - магазина .

В визуальном редакторе компонент расположен по пути: Служебные > Навигация > Меню для мобильной платформы.

Компонент относится к модулю Мобильное приложение [image].

Параметры

Поле | Параметр | Описание
Путь к скриптам | SYNC_REQUEST_PATH | Указывается путь, где расположены административные скрипты
Путь к файлу меню | MENU_FILE_PATH | Указывается путь
Имя события | BUILD_MENU_EVENT_NAME | Наименование события формирования пунктов меню
Заголовок меню | MENU_TITLE | Указывается заголовок

Пример вызова

<?$APPLICATION->IncludeComponent(
'bitrix:mobileapp.menu',
'.default',
[
'SYNC_REQUEST_PATH' => '/bitrix/admin/mobile',
'MENU_FILE_PATH' => '/bitrix/admin/mobile/.mobile_menu.php',
'BUILD_MENU_EVENT_NAME' => 'OnBeforeAdminMobileMenuBuild',
'MENU_TITLE' => 'Администратор'
],
false,
Array('HIDE_ICONS' => 'Y'));
?>


Навигационная цепочка

Компонент выводит навигационную цепочку в шаблоне.

Описание breadcrumb

Настройки этого компонента позволяют регулировать уровень вложенности разделов (корень сайта - ноль), начиная с которого начнет выводиться навигационная цепочка. Также возможно переопределить путь, для которого цепочка будет построена и т.д. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Навигация > Навигационная цепочка.

Компонент относится к Главному модулю.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Номер пункта, начиная с которого будет построена навигационная цепочка | START_FROM | Указывается номер пункта, начиная с которого будет построена навигационная цепочка. В поле может быть задано числовое значение, определяющее уровень вложенности раздела на сайте. Например, 0 (ноль) означает, что построение навигационной цепочки начнется от корня сайта. Если 1, то с первого уровня текущего раздела и так далее.
Путь, для которого будет построена навигационная цепочка (по умолчанию, текущий путь) | PATH | Указывается путь, по которому будет построена навигационная цепочка. Если поле не заполнено совсем, то навигационная цепочка будет строиться для текущего пути.
Cайт (устанавливается в случае многосайтовой версии, когда DOCUMENT_ROOT у сайтов разный) | SITE_ID | Указывается сайт для построения навигационной цепочки. Параметр устанавливается в случае многосайтовой версии, когда DOCUMENT_ROOT у сайтов разный.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:breadcrumb","",Array(
        "START_FROM" => "0",
        "PATH" => "",
        "SITE_ID" => "s1"
    )
);?>


Пункты меню

Компонент осуществляет дополнение созданного меню названиями разделов инфоблоков. Компонент является стандартным и входит в дистрибутив модуля.

Описание menu.sections

В визуальном редакторе компонент расположен по пути: Служебные > Навигация > Пункты меню.

Компонент относится к модулю Информационные блоки.

Параметры

Поле | Параметр | Описание
Основные параметры
Включить режим совместимости с поддержкой ЧПУ IS_SEF [Y|N] При отмеченной опции включается режим поддержки ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) | SEF_BASE_URL | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Шаблон URL, ведущий на страницу с содержимым раздела | SECTION_PAGE_URL | Указывается шаблон пути, ведущий на страницу с содержимым раздела.
Шаблон URL, ведущий на страницу с элементом | DETAIL_PAGE_URL | Указывается шаблон пути, ведущий на страницу с элементом.
[/di] SEF_BASE_URL, SECTION_PAGE_URL, DETAIL_PAGE_URL.

Если режим поддержки ЧПУ выключен, то необходимо настроить [dw]следующие параметры:[/dw][di]
ID элемента для подсветки пункта меню | ID | Указывается идентификатор элемента для подсветки пункта меню.
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается шаблон пути, ведущий на страницу с содержимым раздела.
[/di] ID, SECTION_URL.
Тип информационного блока | IBLOCK_TYPE | Указывается идентификатор типа информационного блока.
Код информационного блока | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор (код) инфоблока, на основе которого будет строиться меню.
Источник данных
Сколько уровней вложенности выводить | DEPTH_LEVEL | Задается глубина вложений, согласно которой будет строиться меню.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:menu.sections","",Array(
        "IS_SEF" => "Y",
        "SEF_BASE_URL" => "/catalog/phone/",
        "SECTION_PAGE_URL" => "#SECTION_ID#/",
        "DETAIL_PAGE_URL" => "#SECTION_ID#/#ELEMENT_ID#",
        "IBLOCK_TYPE" => "news",
        "IBLOCK_ID" => "1",
        "DEPTH_LEVEL" => "1",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Безопасность

Подраздел предназначен для управления резервными кодами для двухэтапной авторизации. Включает в себя компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Подключение устройства OTP | security.user.otp.init | Выводит форму инициализации подключения нового устройства для двухэтапной авторизации.
Резервные коды OTP | security.user.recovery.codes | Выводит форму управления резервными кодами для двухэтапной авторизации.


Подключение устройства OTP

Описание security.user.otp.init

Компонент предназначен для вывода формы инициализации подключения нового устройства для двухэтапной авторизации.

В визуальном редакторе компонент находится в Компоненты > Служебные > Управление резервными кодами > Подключение устройства OTP.

Компонент относится к модулю Проактивная защита.

Примечание: Тип алгоритма генерации паролей, который будет использоваться компонентом для подключения нового устройства задается на странице настроек механизма двухэтапной авторизации (Настройки > Проактивная защита > Двухэтапная авторизация).

Параметры

Поле | Параметр | Описание
Путь для перенаправления после успешного подключения устройства | SUCCESSFUL_URL | Указывается адрес, по которому будет перенаправлен пользователь после успешного подключения устройства.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:security.user.otp.init",
    "",
    Array(
        "SUCCESSFUL_URL" => "/"
    )
);?>

Смотрите также

  • Компоненты
  • Глава Двухэтапная авторизация [image] в курсе «Администратор. Базовый».


Резервные коды OTP

Описание security.user.recovery.codes

Компонент предназначен для вывода формы управления резервными кодами для двухэтапной авторизации.

В визуальном редакторе компонент находится в Компоненты > Служебные > Управление резервными кодами > Резервные коды OTP.

Компонент относится к модулю Проактивная защита.

Компонент не имеет настраиваемых параметров.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:security.user.recovery.codes",
    "",
    Array(
    )
);?>

Смотрите также

  • Компоненты
  • Глава Двухэтапная авторизация [image] в курсе «Администратор. Базовый».


Включаемые области

Подраздел предназначен для расположения на страницах и в разделах включаемых областей. Включает в себя компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Вставка включаемой области | main.include | Определяет место расположения включаемых областей страниц и разделов.


Вставка включаемой области

Компонент располагается в шаблоне дизайна сайта и определяет место расположения включаемых областей страниц и разделов.

Описание main.include

Компонент может выводить содержимое произвольного файла (например, информацию об авторских правах, название компании и т.д.). Настройки компонента позволяют определить суффикс имени файла включаемой области, указать режим редактирования включаемой области по умолчанию, шаблон области по умолчанию. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Включаемые области > Вставка включаемой области.

Компонент относится к Главному модулю.

Параметры

Поле | Параметр | Описание
Параметры компонента
Показывать включаемую область AREA_FILE_SHOW Возможные значения:
  • sect: показывать для раздела, область будет являться включаемой для всего раздела;
  • page: показывать для страницы, область будет являться включаемой только для текущей страницы;
  • file: показывать информацию из файла. Если компонент расположить в шаблоне дизайна сайта, то информация из файла будет выводиться на всем сайте. Установка параметра доступна только пользователю с правами edit_php.
Путь к файлу области | PATH | Поле доступно, если выбрано Показывать включаемую область из файла. Задается полный путь от корня сайта к файлу с информацией, которую надо вывести в этой части сайта.
Суффикс имени файла включаемой области | AREA_FILE_SUFFIX | Поле предназначено для указания суффикса, который будет добавляться к именам файлов включаемых областей. Страницы с таким суффиксом будут восприниматься как включаемые области.
Рекурсивное подключение включаемых областей разделов | AREA_FILE_RECURSIVE | [Y|N] Настройка доступна при отмеченной области Показывать включаемую область (AREA_FILE_SHOW) в значение для раздела (sect). При отмеченной опции включаемые области разделов будут подключаться рекурсивно, т.е. если в папке более низкого уровня есть своя включаемая область, то она будет показана. Если же текущий раздел не имеет своей включаемой области, то рекурсивно до корня сайта будут проверяться все разделы до самого верхнего и будет выведена первая встретившаяся включаемая область.
Шаблон области по умолчанию | EDIT_TEMPLATE | Доступны все шаблоны страниц, созданные в системе. Они располагаются в разделе /bitrix/templates/.default/page_templates/. В данном поле можно указать любой другой файл в системе, указав полный путь к файлу-шаблону.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:main.include","",Array(
        "AREA_FILE_SHOW" => "sect",
        "AREA_FILE_SUFFIX" => "inc",
        "AREA_FILE_RECURSIVE" => "Y",
        "EDIT_TEMPLATE" => "standard.php"
    )
);?>


Поиск

Подраздел предназначен для размещения следующих компонентов, которые осуществляют индексирование и поиск информации на сайте:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Форма поиска | search.form | Служит для вывода формы поиска.
Поиск по заголовкам | search.title | Служит для вывода поля поиска по заголовкам с динамическими результатами.
Стандартная страница поиска | search.page | Служит для создания страницы поиска.
Поле ввода поискового запроса | search.suggest.input | Служит для вывода поля ввода поискового запроса с подсказкой.
Облако тегов | search.tags.cloud | Предназначен для вывода облака тегов.
Форма ввода тегов | search.tags.input | Предназначен для вывода формы ввода тегов.


Облако тегов

Описание search.tags.cloud

Компонент предназначен для вывода облака тегов - механизм поиска по тегам в статистических страницах, элементах информационных блоков, в блогах, форумах. Компонент имеет настройки различных шрифтов и цветов для тегов различной даты и различной популярности использования. Компонент является стандартным и входит в дистрибутив модуля.

Компонент относится к модулю Поиск.

Параметры

Поле | Параметр | Описание
Основные параметры
Сортировка тегов | SORT | Указывается тип сортировки тегов: по имени (NAME) или по популярности (CNT).
Количество тегов | PAGE_ELEMENTS | Параметр определяет количество выводимых тегов в облаке.
Период выборки тегов (дней) | PERIOD | Параметр определяет период выборки тегов (дней).
Путь к странице поиска (от корня сайта) | URL_SEARCH | Указывается путь к странице поиска (от корня сайта).
Сужать область поиска | TAGS_INHERIT | [Y|N] При отмеченной опции выбранные теги добавляются в фильтр поиска.
Источник данных
Искать только в активных по дате документах | CHECK_DATES | [Y|N] При отмеченной опции поиск будет осуществляться только в активных по дате документах.
Дополнительный фильтр | FILTER_NAME | Указывается название дополнительного фильтра (для разработчиков).
Ограничение области поиска arrFILTER Параметр служит для ограничение области поиска: статическими файлами (main), форумами (forum), одним из типов инфоблоков (iblock), определенных в системе, блогами (blog) или социальной сетью (socialnetwork). Можно также выбрать несколько из перечисленных источников информации либо выбрать пункт Не ограничивать.
Если выбрать:
  • [main] Cтатические файлы - то появляется для заполнения поле Путь к файлу начинается с любого из перечисленных, в котором можно указать путь к разделу или файлу, где будет осуществлен поиск, например, /about/. Если поле пусто, то поиск осуществляется во всех статических файлах системы.
  • [forum] Форумы - то ниже отображается поле со всеми форумами, созданными на сайте. Среди них можно выбрать один или несколько форумов либо выбрать вариант (все), тогда поиск будет осуществлен во всех форумах системы.
  • [iblock_<имя>] - один из типов инфоблоков (например, [iblock_news] Новости), то при нажатии кнопки ОК станут доступны все инфоблоки, созданные внутри выбранного типа. Среди них можно выбрать один или несколько инфоблоков либо выбрать вариант (все), тогда поиск будет осуществлен во всех инфоблоках этого типа.
  • [blog] Блоги - то при данном ограничении поиск будет осуществлен только во всех блогах системы;
  • [socialnetwork] Социальная сеть - то при данном ограничении поиск будет осуществлен только в рамках социальной сети;
  • [crm] CRM - то при данном ограничении поиск будет осуществлен только по CRM;
  • [disk] Файлы диска - то при данном ограничении поиск будет осуществлен только файлам диска.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.
Дополнительные настройки
Максимальный размер шрифта (px) | FONT_MAX | Указывается максимальный размер шрифта отображения тегов (в пикселах).
Минимальный размер шрифта (px) | FONT_MIN | Указывается минимальный размер шрифта отображения тегов (в пикселах).
Цвет более позднего тега (пример: "C0C0C0") | COLOR_NEW | Указывается код цвета тегов, дата создания которых наиболее поздняя (пример: "C0C0C0").
Цвет более раннего тега (пример: "FEFEFE") | COLOR_OLD | Указывается код цвета тегов, дата создания которых наиболее ранняя (пример: "FEFEFE").
Период, в течение которого считать тег новым (дней) | PERIOD_NEW_TAGS | Указывается период, в течение которого тег считается новым (дней).
Показывать цепочку навигации | SHOW_CHAIN | [Y|N] При отмеченной опции будет показана цепочка навигации. Параметр работает, если параметр TAGS_INHERIT принимает значение Y.
Плавное изменение цвета | COLOR_TYPE | [Y|N] При отмеченной опции переход между цветами COLOR_NEW и COLOR_OLD будет плавным.
Ширина облака тегов (пример: "100%" или "100px", "100pt", "100in") | WIDTH | Указывается ширина облака тегов (пример: "100%" или "100px", "100pt", "100in").

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:search.tags.cloud","",Array(
        "FONT_MAX" => "50",
        "FONT_MIN" => "10",
        "COLOR_NEW" => "3E74E6",
        "COLOR_OLD" => "C0C0C0",
        "PERIOD_NEW_TAGS" => "",
        "SHOW_CHAIN" => "Y",
        "COLOR_TYPE" => "Y",
        "WIDTH" => "100%",
        "SORT" => "NAME",
        "PAGE_ELEMENTS" => "150",
        "PERIOD" => "",
        "URL_SEARCH" => "/search/index.php",
        "TAGS_INHERIT" => "Y",
        "CHECK_DATES" => "Y",
        "FILTER_NAME"=> "",
        "arrFILTER" => Array("no"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Поиск по заголовкам

Описание search.title

Компонент служит для вывода поля поиска по заголовкам, которые динамически отображаются по группам в выпадающем списке. В поставку продукта входят три шаблона компонента: .default, catalog и visual.

Компонент относится к модулю Поиск.

Примечание: с версии 14.0.0 возможно размещение нескольких компонентов search.title на одной странице.

Параметры

Поле | Параметр | Описание
Основные параметры
Количество категорий поиска | NUM_CATEGORIES | Указывается количество категорий, которые будут выводиться в выпадающем списке.
Количество результатов в каждой категории | TOP_COUNT | Указывается количество выводимых результатов в каждой категории.
Сортировка результатов ORDER Задается направление для сортировки:
  • data - по дате;
  • rank - по релевантности.
Включить автоопределение раскладки клавиатуры | USE_LANGUAGE_GUESS | При отмеченной опции будет происходить автоматическое определение раскладки в которой набран поисковый запрос.
Искать только в активных по дате документах | CHECK_DATES | [Y|N] При отмеченной опции поиск будет осуществляться только в активных по дате элементах сайта.
Показывать категорию "прочее" | SHOW_OTHERS | [Y|N] При отмеченной опции в списке будет отображаться категория "прочее", в которую входит все остальное, кроме указанного в полях Ограничение области поиска.
Шаблоны ссылок
Страница выдачи результатов поиска (доступен макрос #SITE_DIR#) | PAGE | Указывается путь от корня сайта (макрос #SITE_DIR#) к странице, на которой будут выведены результаты поиска.
Дополнительные настройки
Показывать форму ввода поискового запроса | SHOW_INPUT | [Y|N] При отмеченной опции форма ввода поискового запроса будет отображаться на странице. Данная опция удобна, например, для отключения формы поиска без потери настроек.
ID строки ввода поискового запроса | INPUT_ID | Указывается идентификатор строки ввода поискового запроса.
ID контейнера, по ширине которого будут выводиться результаты | CONTAINER_ID | Указывается идентификатор контейнера, по ширине которого будут выводиться выпадающее меню с результатами поиска.
Тип цены* | PRICE_CODE | Указываются типы цен для отображаемых элементов.
Включать НДС в цену* | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции цена на товар будет отображаться с учетом НДС.
Максимальная длина анонса для вывода* | PREVIEW_TRUNCATE_LEN | Задается максимальная длина анонса для вывода, после которой текст анонса товара будет отсечен.
Показать картинку* | SHOW_PREVIEW | [Y|N] При отмеченной опции будет отображаться картинка товара, при этом необходимо настроить параметры PREVIEW_WIDTH и PREVIEW_HEIGHT.
Ширина картинки* | PREVIEW_WIDTH | Ширина картинки в пикселах.
Высота картинки* | PREVIEW_HEIGHT | Высота картинки в пикселах.
Показывать цены в одной валюте* | CONVERT_CURRENCY | [Y|N] При отмеченной опции цены на товары будут показаны в одной валюте, при этом необходимо настроить параметры CURRENCY_ID.
Валюта, в которую будут сконвертированы цены* | CURRENCY_ID | Указывается валюта, в которую будут сконвертированы цены.
* - параметры, доступные только при использовании шаблона catalog.
Категория [номер_категории]
Название категории | CATEGORY_<номер_категории>_TITLE | Указывается название категории, которое будет отображаться в выпадающем списке.
Ограничение области поиска CATEGORY_<номер_категории> Параметр служит для ограничения области поиска: статическими файлами (main), форумами (forum), одним из типов инфоблоков (iblock), определенных в системе, блогами (blog) или социальной сетью (socialnetwork). Можно также выбрать несколько из перечисленных источников информации либо выбрать пункт Не ограничивать.
Если выбрать:
  • [main] Статические файлы - то появляется для заполнения поле Путь к файлу начинается с любого из перечисленных, в котором можно указать путь к разделу или файлу, где будет осуществлен поиск, например, /about/. Если поле пусто, то поиск осуществляется во всех статических файлах системы.
  • [forum] Форумы - то ниже отображается поле со всеми форумами, созданными на сайте. Среди них можно выбрать один или несколько форумов либо выбрать вариант (все), тогда поиск будет осуществлен во всех форумах системы.
  • [iblock_<имя>] - один из типов инфоблоков (например, [iblock_news] Новости), то при нажатии кнопки ОК станут доступны все инфоблоки, созданные внутри выбранного типа. Среди них можно выбрать один или несколько инфоблоков либо выбрать вариант (все), тогда поиск будет осуществлен во всех инфоблоках этого типа.
  • [blog] Блоги - то при данном ограничении поиск будет осуществлен только во всех блогах системы;
  • [socialnetwork] Социальная сеть (группы) - то при данном ограничении поиск будет осуществлен только в рамках групп социальной сети;
  • [socialnetwork_user] Пользователь социальной сети - то при данном ограничении поиск будет осуществлен только среди пользователей социальной сети;
  • [crm] CRM - то при данном ограничении поиск будет осуществлен только по CRM;
  • [disk] Файлы диска - то при данном ограничении поиск будет осуществлен только файлам диска.

Внимание! Если компонент был добавлен в систему через обновления, то для его работы потребуется полная переиндексация. Подробнее про индексацию смотрите на странице Переиндексация.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:search.title","",Array(
        "SHOW_INPUT" => "Y",
        "INPUT_ID" => "title-search-input",
        "CONTAINER_ID" => "title-search",
        "PRICE_CODE" => array("BASE","RETAIL"),
        "PRICE_VAT_INCLUDE" => "Y",
        "PREVIEW_TRUNCATE_LEN" => "150",
        "SHOW_PREVIEW" => "Y",
        "PREVIEW_WIDTH" => "75",
        "PREVIEW_HEIGHT" => "75",
        "CONVERT_CURRENCY" => "Y",
        "CURRENCY_ID" => "RUB",
        "PAGE" => "#SITE_DIR#search/index.php",
        "NUM_CATEGORIES" => "3",
        "TOP_COUNT" => "10",
        "ORDER" => "date",
        "USE_LANGUAGE_GUESS" => "Y",
        "CHECK_DATES" => "Y",
        "SHOW_OTHERS" => "Y",
        "CATEGORY_0_TITLE" => "Новости",
        "CATEGORY_0" => array("iblock_news"),
        "CATEGORY_0_iblock_news" => array("all"),
        "CATEGORY_1_TITLE" => "Форумы",
        "CATEGORY_1" => array("forum"),
        "CATEGORY_1_forum" => array("all"),
        "CATEGORY_2_TITLE" => "Каталоги",
        "CATEGORY_2" => array("iblock_books"),
        "CATEGORY_2_iblock_books" => "all",
        "CATEGORY_OTHERS_TITLE" => "Прочее"
    )
);?>


Поле ввода поискового запроса

Описание search.suggest.input

Компонент служит для вывода поля ввода поискового запроса с подсказкой. Компонент стандартный и входит в дистрибутив модуля.

Компонент относится к модулю Поиск.

Параметры

Поле | Параметр | Описание
Основные параметры
Имя поля ввода | NAME | Указывается имя поля ввода.
Содержимое поля ввода | VALUE | Указывается текст, который будет отображаться в поле ввода по умолчанию.
Размер поля ввода | INPUT_SIZE | Задается ширина поля ввода в символах.
Размер выпадающего списка | DROPDOWN_SIZE | Задается количество пунктов, отображаемых в выпадающем списке.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:search.suggest.input","",Array(
        "NAME" => "search1",
        "VALUE" => "Поиск",
        "INPUT_SIZE" => "60",
        "DROPDOWN_SIZE" => "10"
    )
);?>


Стандартная страница поиска

Компонент служит для создания страницы поиска.

Описание search.page

Компонент можно использовать как самостоятельно для создания страницы поиска, так и в сочетании с компонентом Форма поиска. Вне зависимости от настроек поиск в системе осуществляется в соответствии с правами пользователя.
В поставку продукта входят пять шаблонов компонента:

  • по умолчанию (.default);
  • с упрощенным оформлением страницы поиска (clear);
  • с графическим отображением содержимого результата поиска (icons);
  • с интерактивными подсказками (suggest);
  • со встроенной поддержкой облака тегов (tags).

Компонент относится к модулю Поиск.

Параметры

Поле | Параметр | Описание
Источник данных
Искать без учета морфологии (при отсутствии результата поиска) | RESTART | [Y|N] При отмеченной опции сначала будет выполнен поиск с учетом морфологии. Если ничего не найдено, то будет запущен поиск без учета морфологии.
Отключить обработку слов как логических операторов | NO_WORD_LOGIC | [Y|N] При отмеченной опции слова (и, или, не) не будут использоваться как логические операторы.
Искать только в активных по дате документах | CHECK_DATES | [Y|N] При отмеченной опции поиск будет осуществляться только в активных по дате элементах сайта.
При ранжировании результата учитывать заголовки | USE_TITLE_RANK | [Y|N] По умолчанию выключена, т.к. создает дополнительную нагрузку. Если опция установлена, то при выводе результатов поиска будут учитываться заголовки новости/статьи/файла и т.п. (найденное будет отображаться сверху списка).
Сортировка по умолчанию | DEFAULT_SORT | Указывается порядок сортировки результатов поиска по умолчанию: по релевантности (rank) или по дате (date).
Дополнительный фильтр | FILTER_NAME | Задается имя переменной, в которой передается массив параметров из фильтра для фильтрации поискового индекса. Служит для определения выходящего из фильтра поискового индекса. Поле может быть оставлено пустым, тогда используется значение по умолчанию.
Ограничение области поиска arrFILTER Параметр служит для ограничение области поиска: статическими файлами (main), форумами (forum), одним из типов инфоблоков (iblock), определенных в системе, блогами (blog), социальной сетью (socialnetwork) или информацией о сотрудниках компании (intranet). Можно также выбрать несколько из перечисленных источников информации либо выбрать пункт Не ограничивать.
Если выбрать:
  • [main] Cтатические файлы - то появляется для заполнения поле Путь к файлу начинается с любого из перечисленных, в котором можно указать путь к разделу или файлу, где будет осуществлен поиск, например, /about/. Если поле пусто, то поиск осуществляется во всех статических файлах системы.
  • [forum] Форумы - то ниже отображается поле со всеми форумами, созданными на сайте. Среди них можно выбрать один или несколько форумов либо выбрать вариант (все), тогда поиск будет осуществлен во всех форумах системы.
  • [iblock_<имя>] - один из типов инфоблоков (например, [iblock_news] Новости), то при нажатии кнопки ОК станут доступны все инфоблоки, созданные внутри выбранного типа. Среди них можно выбрать один или несколько инфоблоков либо выбрать вариант (все), тогда поиск будет осуществлен во всех инфоблоках этого типа.
  • [blog] Блоги - то при данном ограничении поиск будет осуществлен только во всех блогах системы;
  • [socialnetwork] Социальная сеть - то при данном ограничении поиск будет осуществлен только в рамках социальной сети;
  • [intranet] Пользователи - то при данном ограничении поиск будет осуществлен только о сотрудниках компании;
  • [crm] CRM - то при данном ограничении поиск будет осуществлен только по CRM;
  • [disk] Файлы диска - то при данном ограничении поиск будет осуществлен только файлам диска.
Внешний вид
Показывать выпадающий список "Где искать" SHOW_WHERE [Y|N] При отмеченной опции в публичном разделе будет выведен [dw]выпадающий список[/dw][di]
Значения для выпадающего списка "Где искать" arrWHERE Указываются значения, которые должны быть включены в выпадающий список формы поиска "Где искать" (форум, блоги, инфоблоки и т.д.).
[/di] с вариантами ограничения поиска, указанными в параметре arrWHERE.
Показывать фильтр по датам | SHOW_WHEN | [Y|N] При отмеченной опции на странице поиска будет отображен дополнительный фильтр, позволяющий отсортировать результаты поиска по заданному интервалу времени.
Количество результатов на странице | PAGE_RESULT_COUNT | Параметр определяет количество результатов поиска, которое будет выведено на одной странице. Все результаты будут выведены с помощью постраничной навигации.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить затенение | AJAX_OPTION_SHADOW | [Y|N] Если параметр принимает значение "Y", то при выполнении AJAX-перехода будет затенена область, которая должна измениться.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.
Дополнительные настройки
Включить автоопределение раскладки клавиатуры | USE_LANGUAGE_GUESS | [Y|N] При отмеченной опции будет происходить автоматическое определение раскладки, в которой набран поисковый запрос.
Показывать подсказку с поисковыми фразами | USE_SUGGEST | [Y|N] При отмеченной опции в строке поиска будет отображаться интерактивная подсказка с введенными ранее поисковыми фразами.
Включить рейтинг SHOW_RATING Указывается включать ли вывод рейтинга:
  • пустое_значение - по умолчанию;
  • Y - да;
  • N - нет.

Данный параметр недоступен для шаблона icons.
Вид кнопок рейтинга RATING_TYPE Указывается тип кнопки рейтинга:
  • пустое_значение - по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).

Данный параметр недоступен для шаблона icons.
Шаблон пути к профилю пользователя PATH_TO_USER_PROFILE Указывается шаблон пути к профилю пользователя.

Данный параметр недоступен для шаблона icons.
Показывать теги документа SHOW_ITEM_TAGS [Y|N] При отмеченной опции для результатов поиска будут показаны теги документа.

Данное поле доступно только для шаблонов icons и clear.
Показывать дату изменения документа SHOW_ITEM_DATE_CHANGE [Y|N] При отмеченной опции для результатов поиска будет показана дата изменения документа.

Данное поле доступно только для шаблонов icons и clear.
Показывать сортировку SHOW_ORDER_BY [Y|N] При отмеченной опции будет доступна сортировка результатов поиска.

Данное поле доступно только для шаблонов icons и clear.
Показывать облако тегов SHOW_TAGS_CLOUD [Y|N] При отмеченной опции на странице поиска будет отображаться облако тегов. Кроме того, становятся доступными [dw]дополнительные поля[/dw][di]
Сужать область поиска* | TAGS_INHERIT | [Y|N] При отмеченной опции выбранные теги добавляются в фильтр поиска.
Сортировка тегов* | TAGS_SORT | Указывается тип сортировки тегов: по имени (NAME) или по популярности (CNT).
Количество тегов* | TAGS_PAGE_ELEMENTS | Параметр определяет количество выводимых тегов в облаке.
Период выборки тегов (дней)* | TAGS_PERIOD | Параметр определяет период выборки тегов (дней).
Путь к странице поиска (от корня сайта)* | TAGS_URL_SEARCH | Указывается путь к странице поиска (от корня сайта).
Максимальный размер шрифта (px)* | FONT_MAX | Указывается максимальный размер шрифта отображения тегов (в пикселах).
Минимальный размер шрифта (px)* | FONT_MIN | Указывается минимальный размер шрифта отображения тегов (в пикселах).
Цвет более позднего тега (пример: "C0C0C0")* | COLOR_NEW | Указывается код цвета тегов, дата создания которых наиболее поздняя (пример: "C0C0C0").
Цвет более раннего тега (пример: "FEFEFE")* | COLOR_OLD | Указывается код цвета тегов, дата создания которых наиболее ранняя (пример: "FEFEFE").
Период, в течение которого считать тег новым (дней)* | PERIOD_NEW_TAGS | Указывается период, в течение которого тег считается новым (дней).
Показывать цепочку навигации* | SHOW_CHAIN | [Y|N] При отмеченной опции будет показана цепочка навигации. Параметр работает, если параметр TAGS_INHERIT принимает значение Y.
Плавное изменение цвета* | COLOR_TYPE | [Y|N] При отмеченной опции переход между цветами COLOR_NEW и COLOR_OLD будет плавным.
Ширина облака тегов (пример: "100%" или "100px", "100pt", "100in")* | WIDTH | Указывается ширина облака тегов (пример: "100%" или "100px", "100pt", "100in").
[/di], отмеченные *.

Данное поле доступно только для шаблонов icons и clear.
Настройки постраничной навигации
Выводить над результатами | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы поиска.
Выводить под результатами | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы поиска.
Название результатов поиска | PAGER_TITLE | Указывается название заголовка постраничной навигации.
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции навигация будет отображаться всегда, даже если результаты поиска помещаются на одной странице.
Название шаблона | PAGER_TEMPLATE | Указывается название шаблона постраничной навигации.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:search.page","tags",Array(
        "TAGS_SORT" => "NAME",
        "TAGS_PAGE_ELEMENTS" => "150",
        "TAGS_PERIOD" => "30",
        "TAGS_URL_SEARCH" => "/search/index.php",
        "TAGS_INHERIT" => "Y",
        "FONT_MAX" => "50",
        "FONT_MIN" => "10",
        "COLOR_NEW" => "000000",
        "COLOR_OLD" => "C8C8C8",
        "PERIOD_NEW_TAGS" => "",
        "SHOW_CHAIN" => "Y",
        "COLOR_TYPE" => "Y",
        "WIDTH" => "100%",
        "USE_SUGGEST" => "Y",
        "SHOW_RATING" => "Y",
        "PATH_TO_USER_PROFILE" => "",
        "AJAX_MODE" => "N",
        "RESTART" => "Y",
        "NO_WORD_LOGIC" => "N",
        "USE_LANGUAGE_GUESS" => "Y",
        "CHECK_DATES" => "Y",
        "USE_TITLE_RANK" => "Y",
        "DEFAULT_SORT" => "rank",
        "FILTER_NAME" => "",
        "arrFILTER" => array("no"),
        "SHOW_WHERE" => "Y",
        "arrWHERE" => array(),
        "SHOW_WHEN" => "Y",
        "PAGE_RESULT_COUNT" => "50",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "DISPLAY_TOP_PAGER" => "Y",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Результаты поиска",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_TEMPLATE" => "",
        "AJAX_OPTION_SHADOW" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "AJAX_OPTION_ADDITIONAL" => ""
    )
);?>


Форма ввода тегов

Описание search.tags.input

Компонент предназначен для вывода формы ввода тегов. Компонент стандартный и входит в дистрибутив модуля.

Компонент относится к модулю Поиск.

Параметры

Поле | Параметр | Описание
Основные параметры
Имя поля ввода | NAME | Указывается название формы ввода тегов. По умолчанию указано TAG.
Содержимое поля ввода | VALUE | Указывается содержимое формы ввода тегов по умолчанию.
ID сайта | SITE_ID | Выбор портала (сайта), для которого предназначен вводимый тег.
Источник данных
Ограничение области поиска arrFILTER Параметр служит для ограничение области поиска: статическими файлами (main), либо форумами (forum), либо одним из типов инфоблоков (iblock), определенных в системе, либо блогами (blog). Можно также выбрать несколько из перечисленных источников информации либо выбрать пункт Не ограничивать. Если выбрать:
  • [main] Cтатические файлы - то появляется для заполнения поле Путь к файлу начинается с любого из перечисленных, в котором можно указать путь к разделу или файлу, где будет осуществлен поиск, например, /about/. Если поле пусто, то поиск осуществляется во всех статических файлах системы.
  • [forum] Форумы - то ниже отображается поле со всеми форумами (Форумы для поиска), созданными на портале. Среди них можно выбрать один или несколько форумов либо выбрать вариант (все), тогда поиск будет осуществлен во всех форумах портала.
  • [iblock_<имя>] - один из типов инфоблоков (например, [iblock_news] Новости), то при нажатии кнопки ОК станут доступны все инфоблоки, созданные внутри выбранного типа. Среди них можно выбрать один или несколько инфоблоков либо выбрать вариант (все), тогда поиск будет осуществлен во всех инфоблоках этого типа.
  • [blog] Блоги - то ниже отображается поле со всеми блогами (Блоги), созданными на портале. Среди них можно выбрать один или несколько блогов либо выбрать вариант (все), тогда поиск будет осуществлен во всех форумах системы.
Дополнительные настройки
Количество записей в выпадающем списке | PAGE_ELEMENTS | Параметр определяет количество записей в выпадающем списке уже существующих тегов.
Сортировать по популярности | SORT_BY_CNT | [Y|N] При отмеченной опции теги в списке будут отсортированы по популярности.
Дополнительные свойства | TEXT | Указывается код дополнительного свойства.
Вставлять фрейм в шаблон компонента | TMPL_IFRAME | [Y|N] При отмеченной области фрейм будет вставлен в шаблон компонента.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:search.tags.input","",Array(
        "PAGE_ELEMENTS" => "10",
        "SORT_BY_CNT" => "Y",
        "TEXT" => "",
        "TMPL_IFRAME" => "Y",
        "NAME" => "TAG",
        "VALUE" => "",
        "arrFILTER" => "no",
        "SITE_ID" => "ru"
        )
);?>


Форма поиска

Компонент служит для вывода формы поиска.

Описание search.form

В продукте форма поиска подключается в шаблоне дизайна и отображается на всех страницах портала. В строке ввода формы Поиск по порталу вводится поисковая фраза или слово и после нажатия кнопки Поиск пользователь перенаправляется на страницу Поиск (созданную с помощью компонента Стандартная страница поиска (bitrix:search.page)). Компонент стандартный и входит в дистрибутив модуля.

Компонент относится к модулю Поиск.

Параметры

Поле | Параметр | Описание
Дополнительно
Показывать подсказку с поисковыми фразами | USE_SUGGEST | [Y|N] При отмеченной опции в строке поиска будет отображаться интерактивная подсказка с введенными ранее поисковыми фразами.
Шаблоны ссылок
Страница выдачи результатов поиска (доступен макрос #SITE_DIR#) | PAGE | Указывается путь к странице поиска (доступен макрос #SITE_DIR#).

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:search.form","",Array(
        "USE_SUGGEST" => "N",
        "PAGE" => "#SITE_DIR#search/index.php"
    )
);?>


Пользователь

© «Битрикс», 2001-2008, «1C-Битрикс», 2008-2022 1С-Битрикс: Управление сайтом


Имя пользователя с тултипом

Описание main.user.link

Компонент выводит имя пользователя с всплывающей подсказкой (тултипом), который содержит информацию о пользователе социальной сети. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Пользователь > Имя пользователя с тултипом.

Параметры

Поле | Параметр | Описание
Основные параметры
Идентификатор пользователя | ID | Параметр содержит код, в котором передается идентификатор пользователя социальной сети.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Отображать личное фото в списке | USE_THUMBNAIL_LIST | [Y|N] При отмеченной опции личное фото будет отображено в списке пользователей.
Показывать поля пользователя | SHOW_FIELDS | Указываются пользовательские свойства, которые будут отображены в тултипе в публичной части.
Показывать доп. свойства | USER_PROPERTY | Указываются дополнительные пользовательские свойства, которые будут отображены в тултипе в публичной части.
Путь к странице пользователя | PATH_TO_SONET_USER_PROFILE | Задается путь к странице профиля пользователя социальной сети.
Внешний вид
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Шаблоны ссылок
Шаблон пути к странице пользователя | PROFILE_URL | Задается шаблон пути к странице профиля пользователя социальной сети.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Показывать год рождения SHOW_YEAR Поле определяет кому показываеть год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:main.user.link","",Array(
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "7200",
        "ID" => "",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "THUMBNAIL_LIST_SIZE" => "30",
        "THUMBNAIL_DETAIL_SIZE" => "100",
        "USE_THUMBNAIL_LIST" => "Y",
        "SHOW_FIELDS" => Array("PERSONAL_BIRTHDAY", "PERSONAL_ICQ", "PERSONAL_PHOTO", "PERSONAL_CITY", "WORK_COMPANY", "WORK_POSITION"),
        "USER_PROPERTY" => Array("UF_USER_CAR_DEMO"),
        "PATH_TO_SONET_USER_PROFILE" => "",
        "PROFILE_URL" => "",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_YEAR" => "Y"
    ),
);?>


Настраиваемая регистрация

Компонент позволяет настроить форму регистрации на сайте.

Описание main.register

Компонент позволяет:

  • установить, какие параметры будут предложены пользователю для заполнения, какие из них будут обязательны для заполнения;
  • настроить ЧПУ;
  • установить настройки кеширования;
  • регулировать дальнейшие переходы пользователя по страницам сайта после регистрации: по ссылке в параметре backurl или на страницу окончания регистрации и т.д.
Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Пользователь > Настраиваемая регистрация.

Параметры

Поле | Параметр | Описание
Основные параметры
Поля, которые показывать в форме SHOW_FIELDS Указываются поля [image], которые будут выведены в дополнение к стандартному набору в форме регистрации. Стандартными полями, обязательными для заполнения, являются:
  • Логин;
  • Пароль;
  • Подтверждение пароля;
  • Адрес E-mail.
Дополнительными полями являются: имя, фамилия, отчество, профессия и другие личные данные.
Поля, обязательные для заполнения | REQUIRED_FIELDS | Указываются обязательные для заполнения поля. Список допустимых значений такой же, что и в предыдущем пункте.
Дополнительные настройки
Автоматически авторизовать пользователей | AUTH | [Y|N] При отмеченной опции после регистрации пользователь будет автоматически авторизован на сайте. В противном случае после регистрации пользователю будет предоставлена к заполнению форма авторизации.
Отправлять пользователя по обратной ссылке, если она есть | USE_BACKURL | [Y|N] При отмеченной опции пользователь будет отправлен по обратной ссылке, если она есть. При наличии в адресной строке параметра backurl пользователь будет перенаправлен по указанной в этом параметре ссылке после заполнения формы регистрации.
Страница окончания регистрации SUCCESS_PAGE Указывается адрес страницы сайта, которая будет финальной страницей процедуры регистрации, и пользователь будет перенаправлен на нее в случае успешной регистрации. Если пользователь зарегистрирован и авторизован, то при переходе на страницу регистрации он попадет на страницу окончания регистрации.
Примечание: один из параметров (USE_BACKURL или SUCCESS_PAGE) лучше заполнить. Если отмечены оба параметра, то пользователь будет переведен по обратной ссылке.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Регистрация нового пользователя.
Показывать доп. свойства | USER_PROPERTY | Указываются дополнительные пользовательские свойства, если они заданы.
Название блока пользовательских свойств | USER_PROPERTY_NAME | Указывается название блока пользовательских свойств.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:main.register","",Array(
        "USER_PROPERTY_NAME" => "",
        "SEF_MODE" => "Y",
        "SHOW_FIELDS" => Array(),
        "REQUIRED_FIELDS" => Array(),
        "AUTH" => "Y",
        "USE_BACKURL" => "Y",
        "SUCCESS_PAGE" => "",
        "SET_TITLE" => "Y",
        "USER_PROPERTY" => Array(),
        "SEF_FOLDER" => "/",
        "VARIABLE_ALIASES" => Array()
    )
);?>


Параметры пользователя

Компонент позволяет вывести в публичную часть сайта информацию о пользователе.

Описание main.profile

Некоторые поля пользователь может отредактировать. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Пользователь > Параметры пользователя.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Профиль пользователя.
Показывать доп. свойства | USER_PROPERTY | Указываются дополнительные свойства, которые будут выведены на дополнительной закладке.
Генерировать почтовое событие | SEND_INFO | [Y|N] При отмеченной опции будет вызвано имеющееся почтовое событие и отправлено письмо пользователю.
Проверять права доступа | CHECK_RIGHTS | [Y|N] При отмеченной опции будут проверяться права на редактирование профиля.
Название закладки с доп. свойствами | USER_PROPERTY_NAME | Указывается название закладки для публичной части, на которой будут выведены дополнительные свойства.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:main.profile","",Array(
        "USER_PROPERTY_NAME" => "",
        "SET_TITLE" => "Y",
        "AJAX_MODE" => "N",
        "USER_PROPERTY" => Array(),
        "SEND_INFO" => "Y",
        "CHECK_RIGHTS" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Запрос согласия пользователя

Компонент позволяет выполнить требования ФЗ-152. Может использоваться как самостоятельно, так и включённым в другие компоненты.

Описание main.userconsent.request

Компонент стандартный и входит в дистрибутив модуля. В визуальном редакторе компонент расположен по пути: Служебные > Пользователь > Запрос согласия пользователя.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Соглашение | ID | Идентификатор используемого соглашения.
Галка согласия проставлена по умолчанию | IS_CHECKED | [Y\N] Установка флажка проставляет автоматически флажок согласия. То есть для отказа от использования данных пользователю нужно будет снять флажок.
Сохранять автоматически факт согласия | AUTO_SAVE | [Y\N] Согласие будет автоматически сохранено на странице ...
Загружать текст соглашения сразу: | IS_LOADED | [Y\N] Текст соглашения будет показан пользователю сразу.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:main.userconsent.request",
    "",
    Array(
        "AUTO_SAVE" => "Y",
        "COMPOSITE_FRAME_MODE" => "A",
        "COMPOSITE_FRAME_TYPE" => "AUTO",
        "ID" => "1",
        "IS_CHECKED" => "Y",
        "IS_LOADED" => "N"
    )
);?>


Компонент для авторизации виджета Битрикс24.Онлайн-чат

Описание b24connector.openline.info

Компонент автоматически передаёт виджету контактные данные авторизованного клиента, позволяет настроить и дополнительно передаваемые данные.

В визуальном редакторе компонент расположен по пути: Служебные > Пользователь.

Компонент относится к модулю Интеграция с Битрикс24.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Дополнительные данные | DATA | Любой текст, добавленный в это поле, транслируется в ОЛ.
Добавлять метку при отправке сообщения для Google Analytics | GA_MARK | Указывается метка Google Analytics. На странице с компонентом должна быть подключена Google Analytics [image] . Как только пользователь что-то напишет, то данная метка будет передана в аналитику для подсчета достижения цели (dataLayer, подробнее: Google Analytics [image] .)

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:b24connector.openline.info","", Array(
        "COMPOSITE_FRAME_MODE" => "A",
        "COMPOSITE_FRAME_TYPE" => "AUTO",
        "DATA" => "",
        "GA_MARK" => ""
    )
);?>


Пароли приложений

Описание main.app.passwords

Компонент служит для управления паролями приложений. Используется обычно в шаблоне дизайна сайта. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Пользователь > Пароли приложений.

Компонент не имеет настроек параметров.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:main.app.passwords","",Array(
     )
);?>


Управление объединением профилей

Описание socserv.auth.split

Компонент позволяет объединить профили пользователя (для социальных сетей). Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Пользователь .

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Показывать объединенные профили | SHOW_PROFILES | [Y|N] При отмеченной опции профиль будет отображаться как единый для всех соцсетей.
Разрешить удалять объединенные профили | ALLOW_DELETE | Разрешение на удаление объединённого профиля.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:socserv.auth.split",
    "",
    Array(
        "SHOW_PROFILES" => "Y",
        "ALLOW_DELETE" => "Y"
    ),
false
);?>


Форма авторизации

Компонент служит для вывода формы авторизации.

Описание system.auth.form

Используется обычно в шаблоне дизайна сайта. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Пользователь > Форма авторизации.

Параметры

Поле | Параметр | Описание
Дополнительно
Страница регистрации | REGISTER_URL | Указывается путь к странице регистрации пользователя.
Страница забытого пароля | FORGOT_PASSWORD_URL | Указывается путь к странице восстановления пароля.
Страница профиля | PROFILE_URL | Указывается путь к странице с параметрами пользователя.
Показывать ошибки | SHOW_ERRORS | [Y|N] При отмеченной опции будут отображаться ошибки, возникающие при авторизации в системе.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:system.auth.form","",Array(
     "REGISTER_URL" => "register.php",
     "FORGOT_PASSWORD_URL" => "",
     "PROFILE_URL" => "profile.php",
     "SHOW_ERRORS" => "Y"
     )
);?>

Механизм восстановления пароля

Если пользователь запросил восстановление пароля, то восстановление происходит по следующему механизму:

  1. Пользователь нажимает на Забыли Пароль? в форме авторизации.
  2. Генерируется случайная строка длиной 32 символа с учетом секрета, известного только серверу.
  3. Результат записывается в БД и отправляется на почту. Ссылка вида: http://site.ru/bitrix/admin/index.php?change_password=yes&lang=ru&USER_CHECKWORD=3farde09fay52547f11c68bf17d95760&USER_LOGIN=market, где:
    • http://site.ru/bitrix/admin/index.php - путь к страницы авторизации или смены пароля;
    • change_password=yes - действие смены пароля;
    • lang=ru идентификатор языка;
    • USER_CHECKWORD=3farde09fay52547f11c68bf17d95760 - контрольная строка для смены пароля 32 символа. В строке используются символы. доступные для md5: [0-9a-f].

      При смене пароля в запросе контрольной строки вводить только контрольную строку, без USER_CHECKWORD=!

    • &USER_LOGIN=market - указание для какого пользователя происходит смена пароля.
  4. При сравнении контрольной строки из формы с тем, что записано в БД, учитывается время истечения, указанное в групповой политике безопасности.

Примечание. В форме восстановления пароля рекомендуется использовать CAPTCHA - поле Использовать CAPTCHA при восстановлении пароля в настройках Главного модуля.


Форма инициализации регистрации

Описание system.auth.initialize

Компонент выводит форму инициализации регистрации, созданной в рамках соцсети. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Пользователь .

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Название переменной, в которой передается ID пользователя | USER_ID | Указывается название переменной для передачи ID пользователя. По умолчанию - user_id.
Название переменной, в которой передается контрольная строка | CHECKWORD | Указывается название переменной для передачи контрольной строки. По умолчанию - checkword.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "bitrix:system.auth.initialize",
    "",
    Array(
        "USER_ID" => "user_id",
        "CHECKWORD" => "checkword"
    ),
false
);?>


Форма отписки от писем

Описание main.mail.unsubscribe

Компонент служит для отписки от писем. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Пользователь > Форма отписки от писем.

Компонент не имеет настроек параметров.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:main.mail.unsubscribe","",Array(
     )
);?>


Форма подтверждения регистрации

Компонент выводит форму подтверждения регистрации.

Описание system.auth.confirmation

Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Пользователь > Форма подтверждения регистрации.

Параметры

Поле | Параметр | Описание
Дополнительно
Название переменной, в которой передается ID пользователя | USER_ID | Параметр содержит код, в котором передается идентификатор пользователя.
Название переменной, в которой передается код подтверждения | CONFIRM_CODE | Параметр содержит код, в котором передается код подтверждения.
Название переменной, в которой передается логин пользователя | LOGIN | Параметр содержит код, в котором передается логин пользователя.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:system.auth.confirmation","",Array(
        "USER_ID" => "confirm_user_id",
        "CONFIRM_CODE" => "confirm_code",
        "LOGIN" => "login"
    )
);?>


Статистика

Подраздел содержит компонент для вывода статистики по сайту:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Таблица статистики | statistic.table | Выводит таблицу статистики по сайту, кроме того, настройки компонента позволяют отключить подсчет статистики для администраторов.


Таблица статистики

Описание statistic.table

Компонент выводит таблицу статистики по сайту, кроме того, его настройки позволяют отключить подсчет статистики для администраторов. Обычно располагается в шаблоне дизайна сайта.

Компонент доступен только при наличии установленного модуля Веб-аналитика. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Статистика > Таблица статистики.

Параметры

Поле | Параметр | Описание
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Кэшировать для администраторов | CACHE_FOR_ADMIN | По умолчанию для пользователей группы Администраторы кеширование выключено и, как следствие, при отображении страницы выполняются запросы к БД. Можно снизить нагрузку на сайт включив эту опцию.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:statistic.table","",Array(
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => 20,
        "CACHE_FOR_ADMIN" => "N"
    )
);?>


Описание компонентов решений

Решения:

  • Корпоративный сайт услуг
  • Решения для 1С: Франчайзи
  • Решения для государственных организаций
    • Внутренний портал государственной организации
    • Официальный сайт государственной организации
  • Решения для здравоохранения
    • Портал органа управления здравоохранением
    • Сайт медицинской организации
  • Решения для образования
    • Внутренний портал учебного заведения
    • Сайт школы
  • Сайт конференции


Сайт услуг

Готовые решения реализованы для редакции не ниже 1С-Битрикс: Управление сайтом "Старт".

Примечание: В настоящее время данное решение недоступно.

Решение содержит следующие компоненты:

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Специальное предложение | furniture.catalog.random | Показывает одно специальное предложение.
Презентационный список | furniture.catalog.index | Выводит презентационный список элементов или разделов инфоблока.


Компоненты

Компоненты
Название | Имя в пространстве имен bitrix | Описание
Специальное предложение | furniture.catalog.random | Показывает одно специальное предложение.
Презентационный список | furniture.catalog.index | Выводит презентационный список элементов или разделов инфоблока.


Презентационный список

Отправить отзыв по этому разделу
Описание компонентов решений>Корпоративный сайт услуг>Компоненты>Презентационный список

Компоненты::Презентационный список

Описание furniture.catalog.index

Компонент выводит презентационный список элементов или разделов инфоблока. Компонент устанавливается в систему вместе с решением Корпоративный сайт услуг (bitrix.sitecorporate).

В визуальном редакторе компонент расположен по пути Контент > Каталог > Презентационный список.

Параметры

Поле | Параметр | Описание
Внешний вид
Тип инфо-блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфо-блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, из которого будут выводиться список элементов.
Показывать IBLOCK_BINDING Указывается, что показывать:
  • section - разделы;
  • element - элементы;
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:furniture.catalog.index","",Array(
        "IBLOCK_TYPE" => "books",
        "IBLOCK_ID" => "5",
        "IBLOCK_BINDING" => "element",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000",
        "CACHE_GROUPS" => "Y"
    )
);?>


Специальное предложение

Отправить отзыв по этому разделу
Описание компонентов решений>Корпоративный сайт услуг>Компоненты>Специальное предложение

Компоненты::Специальное предложение

Описание furniture.catalog.random

Компонент показывает одно специальное предложение. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Контент > Каталог > Специальное предложение.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Для выбранного типа инфоблока указывается идентификатор информационного блока, из которого будет выводиться специальное предложение.
Инфоблок | IBLOCKS | Для выбранного типа инфоблоков указывается идентификатор информационного блока, из которого будут выводиться список элементов.
Дополнительные настройки
ID раздела | PARENT_SECTION | Указывается идентификатор раздела, из которого будут выбираться фотографии. Поле может быть пустым, тогда выбор фотографии производится из всех разделов указанных инфоблоков.
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Указывается путь к странице с детальным описанием элемента раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:furniture.catalog.random","",Array(
        "IBLOCK_TYPE" => "books",
        "IBLOCKS" => array("6"),
        "PARENT_SECTION" => "",
        "DETAIL_URL" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "180",
        "CACHE_GROUPS" => "Y"
    ),
false
);?>


Решения для 1С: Франчайзи

Для продукта 1С-Битрикс: Управление сайтом решения 1С:Франчайзи [image] различаются по редакциям. Для редакции Старт реализована лицензия Сайт 1С:Франчайзи, для Бизнес - Интернет-магазин 1С:Франчайзи. Настройки модуля и компоненты идентичны для обеих лицензий.


Решния для 1С: Франчайзи. Настройки модуля

Закладки

Форма настроек модуля 1С-Битрикс: Модуль обмена электронными заказами с 1С (Настройки > Настройки продукта > Настройки модулей > 1С-Битрикс: Модуль обмена электронными заказами с 1С) предназначена для задания общесистемных параметров модуля.

Настройка решения производится на трех вкладках: Авторизация, Каталог и Заказы. Вкладки Каталог и Заказы становятся доступны после ввода кода реселлера.

Авторизация

Поле | Описание
Авторизация партнера
Логин | Логин, с которым вы зарегистрировались в партнерской системе 1С.
Пароль | Пароль, указанный при регистрации в партнерской системе 1С.
Код реселлера | Код реселлера партнер должен запросить по адресу esd@1c.ru после подписания договора.
PIN-код реселлера Касперского | PIN-код для обработки заказов на продукты Лаборатории Касперского. Можно оставить пустым, в этом случае заказы на данные продукты не будут обработаны.
RSA ключи
Открытый ключ RSA | Поле для вставки публичного ключа RSA.
Закрытый ключ RSA | Поле для вставки приватного ключа RSA.

Если у вас уже имеется пара ключей RSA (публичный и приватный) для работы с партнерской системой, вы можете вставить их в соответствующие поля. Если вы начинаете работу - необходимо сгенерировать ключи при помощи кнопки "Создать ключи". После этого необходимо отправить публичный ключ по адресу esd@1c.ru для привязки его к вашему аккаунту.

Ключи сохраняются в папке модуля с именами key.private и key.public соответственно. При попытке перезаписи существующих ключей будет выдано предупреждение.

Каталог

Поле | Описание
URL для синхронизации | Поле для указания базового адреса программного средства для обмена электронными заказами 1С. Значение по умолчанию - http://online.1c.ru/ personal/reseller/
Товарный каталог
Каталог | Выбор инфоблока-торгового каталога, в который будут импортироваться товары из каталога 1С. Выбор инфоблока влияет на параметры "Раздел", "Дополнительные изображения" и кнопку "Создать свойства".
Раздел | Выбор раздела инфоблока, в который будут импортироваться товары. При выборе значения "Корень инфоблока" данные будут импортироваться в корень выбранного инфоблока.
Дополнительные изображения | Выбор свойства инфоблока, в которое будут загружены дополнительные изображения (скриншоты) продукта. Свойство должно быть множественным и иметь тип "Файл". Если свойство не указано, дополнительные изображения загружены не будут.
Цена клиента | Выбор типа цены, в который будет записана рекомендуемая цена при импорте.
Цена закупки | Выбор типа цены, в который будет записана закупочная цена при импорте. Значение по умолчанию "Закупочная цена" означает, что данные будут записаны в соответствующее поле элемента торгового каталога.
Агент
Период обмена | Определяет период обмена (обновления) каталога в секундах. Минимальное значение 86400 (24 часа).
Дата первого запуска | Определяет дату первого запуска агента.
Записывать в журнал | Позволяет задать какие события попадают в системный журнал 1С-Битрикс: только ошибки или все события (ошибки и информация о выполнении агента).

Блок Принудительный обмен позволяет в ручном режиме немедленно произвести или полное обновление каталога с помощью кнопки "Полное (FULL)", или обновление только изменившихся и удаленных товарных позиций с помощью кнопки - "Только обновления (UPDATE)"

После нажатия кнопки появится всплывающее окно, в котором будет отображен прогресс и основная информация о процессе: количество добавленных, обновленных и удаленных элементов каталога и количество ошибок (если есть). Время работы будет зависеть от объема данных, скорости канала передачи данных и быстродействия сервера. Не закрывайте окно до полного завершения импорта.

Заказы

Поле | Описание
Статус заказа для отгрузки | Определяет статус заказа, при переводе в который будут автоматически запрошены ключи для продуктов, входящих в его состав. Ключи запрашиваются только для продуктов, загруженных из программного средства для обмена электронным заказами 1С.
Типы платильщиков | Список всех типов плательщиков в системе с возможностью выбрать один или несколько. Ключи на программные продукты будут автоматически запрашиваться только для выбранных типов плательщиков.
Записывать в журнал | Позволяет задать какие события попадают в системный журнал 1С-Битрикс: только ошибки или все события (ошибки и информация о запросе ключей).


Сайт 1С: Франчайзи

Сущности:

  • Настройки модуля
  • Компоненты


Сайт 1С: Франчайзи. Настройки модуля

Форма настроек модуля 1С-Битрикс: Сайт 1C-Франчайзи (Настройки > Настройки продукта > Настройки модулей > 1С-Битрикс: Сайт 1С-Франчайзи) предназначена для задания общесистемных параметров модуля.

Примечание: данные настройки могут задаваться при установке решения.

Закладка Настройки

Поле | Описание
Город расположения компании | Указывается город, в котором расположена компания.
Адрес компании | Указывается адрес (без города) расположения компании.
Код телефона компании | Указывается код телефона компании.
Телефон компании (без кода) | Указывается телефон компании (без кода).
ICQ для связи с клиентами | Указывается номер ICQ для связи с клиентами.
Skype для связи с клиентами | Указывается логин Skype для связи с клиентами.
E-mail для общей информации | Указывается электронный адрес для общей информации.
Инфоблок для импорта новостей с сайта 1с | Выбирается инфоблок указанного типа для импорта новостей с сайта 1с.
Раздел инфоблока для импорта новостей с сайта 1с | Для указанного инфоблока выбирается раздел для импорта новостей с сайта 1с.
Страница rss с новостями сайта 1с | Указывается путь к странице rss с новостями сайта 1с.


Компоненты

Модуль включает в себя следующие компоненты:

Компоненты модуля
Название | Имя в пространстве имен bitrix | Описание
Главная страница
Список новостей | news.list | Одностраничный компонент выводит список новостей из одного информационного блока (в качестве результата возвращает ID показанных элементов).
Баннер | advertising.banner | Компонент выводит баннер заданного типа.
Продукты - Продукты 1С
Каталог | catalog | Комплексный компонент осуществляет вывод полного каталога товаров из определенного инфоблока.
Продукты - Программы, книги, игры
Каталог | catalog | Комплексный компонент осуществляет вывод полного каталога товаров из определенного инфоблока.
Продукты - Продукты "1С-Битрикс"
Каталог | catalog | Комплексный компонент осуществляет вывод полного каталога товаров из определенного инфоблока.
Услуги - Наши услуги
Новости | news | Комплексный компонент позволяет создать новостной раздел на сайте.
Услуги - ИТС
Новости | news | Комплексный компонент позволяет создать новостной раздел на сайте.
Обучение - Расписание курсов
Каталог | catalog | Комплексный компонент осуществляет вывод полного каталога товаров из определенного инфоблока.
Обучение – Онлайн курсы
Учебный курс (комплексный компонент) | learning.course | Комплексный компонент осуществляет полноценный вывод учебного курса.
Список курсов | learning.course.list | Компонент выводит список курсов.
Дерево курса | learning.course.tree | Компонент выводит иерархию глав и уроков.
Поиск по курсам | learning.search | Компонент выводит поиск в курсах, главах и уроках.
Детальный вывод главы | learning.chapter.detail | Компонент производит детальный вывод главы курса.
Детальный вывод урока | learning.lesson.detail | Компонент производит детальный вывод урока курса.
Обучение – Преподаватели
Список новостей | news.list | Одностраничный компонент выводит список новостей из одного информационного блока (в качестве результата возвращает ID показанных элементов).
Наш опыт
Новости | news | Комплексный компонент позволяет создать новостной раздел на сайте.
О компании - Новости
Новости | news | Комплексный компонент позволяет создать новостной раздел на сайте.
О компании - Вакансии
Новости | news | Комплексный компонент позволяет создать новостной раздел на сайте.
Заполнение веб-формы | form.result.new | Компонент служит для вывода формы и добавления результата, т.е. для ее заполнения.
О компании - Фотогалерея
Фотогалерея (комплексный компонент) | photo | Позволяет получить полнофункциональную фотогалерею, создавая физически только одну страницу.
О компании – Специальные предложения
Новости | news | Комплексный компонент позволяет создать новостной раздел на сайте.
Корзина
Корзина | sale.basket.basket | Одностраничный компонент отображает список товаров, отправленных пользователем в корзину.
Оформление заказа
Оформление заказа | sale.order.ajax | Компонент служит для оформления заказа на одной странице с использованием технологии AJAX.
Личный кабинет
Параметры пользователя | main.profile | Компонент позволяет вывести в публичную часть сайта информацию о пользователе.
Список профилей текущего пользователя | sale.personal.profile.list | Одностраничный компонент выводит список профилей текущего пользователя.
Список заказов | sale.personal.order.list | Одностраничный компонент выводит фильтр и список заказов пользователя.
Отмена заказа | sale.personal.order.cancel | Одностраничный компонент позволяет отменить заказ. Компонент стандартный и входит в дистрибутив модуля.
Редактирование профиля | sale.personal.profile.detail | Одностраничный компонент позволяет редактировать профиль пользователя.
Подключение платежной системы | sale.order.payment | Одностраничный компонент осуществляет подключение платежной системы.
Подключение обработчика результата платежной системы | sale.order.payment.receive | Одностраничный компонент осуществляет подключение скрипта для получения результата от платежной системы.


Производственный календарь

Описание franchise.calendar

Компонент выводит календарь на год с отмеченными праздниками и выходными днями. Компонент разработан для решения Сайт 1С:Франчайзи. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Служебные.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCK_ID | Для выбранного типа инфоблока указывается информационный блок.
Тип календаря CALENDAR_TYPE Выбирается тип календаря:
  • На месяц;
  • На год.
Показывать заголовок месяца | SHOW_TITLE | [Y|N] При отмеченной опции будет выведен заголовок месяца.
Показывать в заголовке год | SHOW_YEAR | [Y|N] При отмеченной опции в заголовке будет показан год.
Не использовать автоматически перенос праздников, выпадающих на выходных | NO_CNAGE_DAY | [Y|N] При отмеченной опции не будет осуществляться автоматический перенос праздников, выпадающих на выходные дни.
Добавить ссылки на смену месяца | ADD_MONTH_CHANGE | [Y|N] При отмеченной опции будут добавлены ссылки на смену месяца.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<?$APPLICATION->IncludeComponent(
"franchise:franchise.calendar",
    "",
    Array(
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "news",
        "IBLOCK_ID" => "11",
        "CALENDAR_TYPE" => "month",
        "SHOW_TITLE" => "Y",
        "SHOW_YEAR" => "Y",
        "NO_CNAGE_DAY" => "Y",
        "ADD_MONTH_CHANGE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_GROUPS" => "Y",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y"
    )
);?>


Фильтр по элементам

Описание catalog.filter

Компонент выводит форму фильтра для фильтрации элементов информационых блоков. Компонент разработан для решения Сайт 1С:Франчайзи. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Компоненты > Контент > Каталог.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфо-блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфо-блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, элементы которого будут отфильтрованы.
Имя выходящего массива для фильтрации | FILTER_NAME | Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Поля FIELD_CODE Указываются дополнительные поля элементов инфоблока, по которым будет возможна фильтрация. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания полей в строках (т.е. если задан пустой массив), будут выведены поля по умолчанию.
Свойства PROPERTY_CODE Указываются свойства инфоблока, которые будут отображены при показе в качестве полей фильтра. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках, свойства выведены не будут.

Значения свойств типа "Список" отображаются в фильтре в соответствии с настройками, заданными в форме редактирования самого свойства (поле "Внешний вид").
Поля предложений | OFFERS_FIELD_CODE | Выбираются поля предложений. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений | OFFERS_PROPERTY_CODE | Указываются свойства предложений. Можно добавлять свои. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Внешний вид
Высота списков множественного выбора | LIST_HEIGHT | Указывается высота множественных списков выбора, отображаемых в фильтре.
Ширина однострочных текстовых полей ввода | TEXT_WIDTH | Указывается ширина текстового поля ввода в форме фильтра.
Ширина полей ввода для числовых интервалов | NUMBER_WIDTH | Указывается ширина полей ввода для числовых интервалов в форме фильтра.
Дополнительные настройки
Сохранять установки фильтра в сессии пользователя | SAVE_IN_SESSION | [Y|N] При отмеченной опции установки фильтра будут сохраняться в сессии пользователя.

Пример вызова

<?$APPLICATION->IncludeComponent (
"franchise:catalog.filter",
    "",
    Array(
        "IBLOCK_TYPE" => "news",
        "IBLOCK_ID" => "9",
        "FILTER_NAME" => "arrFilter",
        "FIELD_CODE" => array("ID","CODE"),
        "PROPERTY_CODE" => array("NEWS_wizard_tmp"),
        "PRICE_CODE" => array(),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_GROUPS" => "Y",
        "LIST_HEIGHT" => "5",
        "TEXT_WIDTH" => "20",
        "NUMBER_WIDTH" => "5",
        "SAVE_IN_SESSION" => "Y"
    )
);?>


Решения для государственных организаций

Решения:

  • Внутренний портал государственной организации
  • Официальный сайт государственной организации
  • Портал открытых данных


Портал открытых данных

Данное решение [image] – это комплексная информационная система для подготовки и публикации открытых данных о деятельности организации.

Создан на базе продукта «1С-Битрикс: Управление сайтом», содержит готовые разделы и сервисы как для контент-менеджеров, так и для посетителей сайта, что позволяет запустить проект в короткий срок и значительно сократить затраты на разработку по созданию внутренней системы подготовки данных.


Внутренний портал государственной организации

Данное решение реализовано в редакции 1С-Битрикс: Корпоративный портал "Бизнес-процессы".

Примечание: В настоящее время данное решение недоступно.


Внутренний портал государственной организации. Настройки модуля

Форма настроек модуля 1С-Битрикс: Портал государственной организации (Настройки > Настройки продукта > Настройки модулей > Портал государственной организации) предназначена для задания общесистемных параметров модуля.

Закладка Настройки

Поле | Описание
Инфоблоки планов
Тип инфоблока | Выбирается тип инфоблока планов.
Инфоблоки справочников
Инфоблоки справочников | Выбирается тип инфоблока справочников.
Инфоблок адресов | Выбирается инфоблок адресов.
Инфоблок категорий участников | Выбирается инфоблок категорий участников.
Инфоблок категорий событий | Выбирается инфоблок категорий событий.
Инфоблок руководителей | Выбирается инфоблок руководителей.
Генерация отчетов
Путь к гербу | Указывается шаблон пути к гербу.


Официальный сайт государственной организации

Данное решение [image] в базовом варианте реализовано в редакции 1С-Битрикс: Управление сайтом "Эксперт". В расширенном - в редакции "Веб-кластер".

Решение [image] можно приобрести на Marketplace.


Официальный сайт государственной организации. Настройки модуля

Закладки

Форма настроек модуля 1С-Битрикс: Сайт гос. организации (Настройки > Настройки продукта > Настройки модулей > 1С-Битрикс: Сайт гос. организации) предназначена для задания общесистемных параметров модуля. Для удобства работы форма разделена на закладки, на каждой из которых выполняется настройка определённой группы параметров модуля.

Настройки

Поле | Описание
Общие настройки
Анимация шапки (в базовом дизайне) Указываются параметры отображения анимации шапки:
  • выключена;
  • включена;
  • включена только на главной.
Название сайта | Заголовок сайта.
Статус сайта | Подпись под названием сайта.
Населенный пункт для поиска маршрута | Указывается населенный пункт для поиска маршрута.
Регион | Выбирается регион, которому принадлежит населенный пункт.
Статус новых обращений формы создания обращения Выбирается статус, который будет по умолчанию присваиваться новым обращениям:
  • На рассмотрении;
  • Обработано;
  • Отказано.
Форма создания нового обращения
Форма для обращений граждан Указывается форма для обращений граждан:
  • Новое обращение;
  • Новый запрос.
Вопрос Email формы для обращений Указывается вопрос Email формы для обращений:
  • E-Mail;
  • Ваш адрес (с индексом);
  • Как вас зовут (Имя Фамилия);
  • Прикрепить файл;
  • Текст обращения;
  • Тема обращения.
Регистрировать пользователя через форму создания обращения | При отмеченной опции регистрация пользователя будет осуществляться пользователя через форму создания обращения.
Форма запроса информации
Форма для запросов информации Выбирается форма для запросов информации:
  • Новое обращение;
  • Новый запрос.
Вопрос Email формы для запросов Указывается вопрос Email формы для запросов:
  • E-Mail;
  • Ваш адрес (с индексом);
  • Как вас зовут (Имя Фамилия);
  • Прикрепить файл;
  • Текст запроса;
  • Телефон;
  • Тема обращения.
Регистрировать пользователя через форму создания запросов | При отмеченной опции регистрация пользователя будет осуществляться пользователя через форму создания запроса.

Герб

На данной закладке можно выбрать герб, который будет отображаться на сайте.

Поле | Описание
Текущий герб | Здесь показан герб, который будет установлен на сайте после сохранения настроек модуля.
Гербы городов | Показаны гербы городов России. При нажатии левой кнопкой мыши по выбранному гербу он будет перенесен в раздел Текущий герб.
Гербы областей | Показаны гербы областей России. При нажатии левой кнопкой мыши по выбранному гербу он будет перенесен в раздел Текущий герб.
Пользовательские гербы | Показаны загруженные пользователем гербы. При нажатии левой кнопкой мыши по выбранному гербу он будет перенесен в раздел Текущий герб.
Загрузить герб | При нажатии на кнопку Добавить файл будет открыто окно выгрузки файла с компьютера или локальной сети. После сохранения настроек модуля выбранный файл будет добавлен в раздел Пользовательские гербы.

Объекты города/области

Поле | Описание
Объекты, туристические маршруты, события
Тип инфоблоков информации | Выбирается тип инфоблоков информации.
Объекты города/области
Инфоблок "Объекты города/области" | Выбирается инфоблок объектов города/области.
Свойство адреса | Указывается свойство инфоблока, из которого будет взят адрес.
Свойство LAT | Указывается свойство инфоблока, из которого будет взят LAT.
Свойство LNG | Указывается свойство инфоблока, из которого будет взят LNG.
Туристические маршруты
Инфоблок "Типы туристических маршрутов" | Указывается инфоблок типов туристических маршрутов.
Инфоблок "Туристические маршруты" | Указывается инфоблок туристических маршрутов.
Свойство адреса | Указывается свойство инфоблока, из которого будет взят адрес.
Свойство LAT | Указывается свойство инфоблока, из которого будет взят LAT.
Свойство LNG | Указывается свойство инфоблока, из которого будет взят LNG.
События
Инфоблок "События" | Указывается инфоблок событий.
Свойство адреса | Указывается свойство инфоблока, из которого будет взят адрес.
Свойство LAT | Указывается свойство инфоблока, из которого будет взят LAT.
Свойство LNG | Указывается свойство инфоблока, из которого будет взят LNG.


Компоненты

  • Визуальная структура компании
  • Интерактивная карта
  • Список сотрудников
  • Погода
  • Мобильная регистрация
  • Меню
  • Лог изменений
  • Рабочий стол
  • Мастер создания обращения (с регистрацией пользователя)
  • Список обращений
  • Вставка включаемой области


Визуальная структура компании

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для государственных организаций>Официальный сайт государственной организации>Компоненты>Визуальная структура компании

Компоненты::Визуальная структура компании

Описание gosportal:structure.visual

Компонент выводит визуальное представление древовидной структуры компании. Компонент разработан для решения Официальный сайт государственной организации. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен в разделе: Гос. сайт.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Указывается тип информационного блока (используется только для проверки).
Код информационного блока | IBLOCK_ID | Указывается код информационного блока.
Максимальная глубина выборки | MAX_DEPTH | Указывается максимальная глубина дерева.

Пример вызова

 IncludeComponent(
    "gosportal:structure.visual",
    "",
    Array(
        "IBLOCK_ID" => $_REQUEST["ID"],
        "IBLOCK_TYPE" => "news",
        "MAX_DEPTH" => "2"
    )
);?>
);?>


Интерактивная карта

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для государственных организаций>Официальный сайт государственной организации>Компоненты>Интерактивная карта

Компоненты::Интерактивная карта

Описание gosportal:map

Компонент выводит объекты на карте из одного информационного блока. Компонент разработан для решения Официальный сайт государственной организации. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен в разделе: Гос. сайт.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Указывается тип информационного блока (используется только для проверки).
Код информационного блока | IBLOCK_ID | Указывается код информационного блока.
Представление данных DATA_TYPE Выбранный тип данных влияет на их отображение на карте. Доступные типы:
  • Объекты
  • События
  • Маршруты
Максимальное количество элементов | ELEMENTS_COUNT | Выставляется максимальное для вывода на страницу число элементов.
Подсчитывать элементы при выборке разделов | SHOW_ELEMENTS_COUNT | При отмеченной опции будет подсчитано число элементов в выбранных разделах.
Источник данных
Поле для первой сортировки разделов SORT_SECTIONS_BY1 В списке перечислены поля, по которым может проводиться сортировка категорий:
  • ID
  • Название
  • Сортировка
  • Дата последнего изменения

Также можно выбрать пункт другое и задать в поле рядом код нужного поля.
Направление для первой сортировки разделов SORT_SECTIONS_ORDER1 Задаётся порядок сортировки:
  • По возрастанию
  • По убыванию
Поле для второй сортировки разделов SORT_SECTIONS_BY2 В списке перечислены поля, по которым может проводиться вторая сортировка категорий в случае совпадения значений полей первой сортировки:
  • ID
  • Название
  • Сортировка
  • Дата последнего изменения

Также можно выбрать пункт другое и задать в поле рядом код нужного поля.
Направление для второй сортировки разделов SORT_SECTIONS_ORDER2 Задаётся порядок сортировки:
  • По возрастанию
  • По убыванию
Поле для первой сортировки элементов SORT_BY1 В списке перечислены поля, по которым может проводиться сортировка объектов:
  • ID
  • Название
  • Дата начала активности
  • Сортировка
  • Дата последнего изменения

Также можно выбрать пункт другое и задать в поле рядом код нужного поля.
Направление для первой сортировки элементов SORT_ORDER1 Задаётся порядок сортировки:
  • По возрастанию
  • По убыванию
Поле для второй сортировки элементов SORT_BY2 В списке перечислены поля, по которым может проводиться вторая сортировка объектов в случае совпадения значений полей первой сортировки:
  • ID
  • Название
  • Дата начала активности
  • Сортировка
  • Дата последнего изменения

Также можно выбрать пункт другое и задать в поле рядом код нужного поля.
Направление для второй сортировки элементовв SORT_ORDER2 Задаётся порядок сортировки:
  • По возрастанию
  • По убыванию
Фильтр | FILTER_NAME | Задается имя переменной, в которой передается массив параметров из фильтра. Служит для определения выходящих из фильтра элементов. Поле может быть оставлено пустым, тогда используется значение по умолчанию.
Свойства разделов | SECTION_FIELDS | Выбираются свойства разделов. Можно добавлять свои.
Поля элементов | FIELD_CODE | В данном поле можно выбрать поля элементов инфоблока, по которым будет возможна фильтрация. Также можно добавить другие поля в виде символьного кода (в полях ниже).
Свойства элементов | PROPERTY_CODE | Перечислены свойства элементов инфоблока, среди которых можно выбрать те, по которым будет возможна фильтрация. Также можно добавить другие поля в виде символьного кода (в полях ниже).
Показывать только активные на данный момент элементы | CHECK_DATES | Опция служит для показа только активных элементов инфоблока.
Шаблоны ссылок
URL страницы детального просмотра (по умолчанию - из настроек инфоблока) | DETAIL_URL | Указывается шаблон ссылки на страницу детального просмотра. Например, news_detail.php?ID=#ELEMENT_ID#
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • Авто: действует при включенном кешировании в течение заданного времени;
  • Кешировать: для кеширования необходимо определить только время кеширования;
  • Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Поле служит для указания времени кеширования в секундах.
Кешировать при установленном фильтре | CACHE_FILTER | При установленной опции каждый результат, полученный из фильтра будет кешироваться. Имеет смысл отмечать, если многие пользователи используют одну и ту же выборку из фильтра.
Учитывать права доступа | CACHE_GROUPS | При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Максимальная длина анонса для вывода (только для типа текст) | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода (только для типа текст). При превышении параметра остаток текста будет отсечен.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт другое, можно сформировать свой вариант на основании php-функции date.
Устанавливать заголовок страницы | SET_TITLE | При установленной опции в качестве заголовка страницы будет установлено имя текущего инфоблока.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | Опция служит для включения обработки ошибки 404 в компоненте.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | При установленной опции в цепочку навигации будет добавлено имя инфоблока.
ID раздела | PARENT_SECTION | В данном поле можно указать ID "родительского" раздела, чтобы ограничить выборку элементов по нему.
Код раздела | PARENT_SECTION_CODE | В данном поле можно указать код "родительского" раздела, чтобы ограничить выборку элементов по нему.

Пример вызова

 IncludeComponent(
    "gosportal:map",
    "",
    Array(
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "CACHE_FILTER" => "N",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "36000000",
        "CACHE_TYPE" => "A",
        "CHECK_DATES" => "Y",
        "DATA_TYPE" => "objects",
        "DETAIL_URL" => "",
        "ELEMENTS_COUNT" => "500",
        "FIELD_CODE" => array("",""),
        "FILTER_NAME" => "",
        "IBLOCK_ID" => $_REQUEST["ID"],
        "IBLOCK_TYPE" => "-",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "PARENT_SECTION" => "",
        "PARENT_SECTION_CODE" => "",
        "PREVIEW_TRUNCATE_LEN" => "",
        "PROPERTY_CODE" => array("",""),
        "SECTION_FIELDS" => array("",""),
        "SET_STATUS_404" => "N",
        "SET_TITLE" => "Y",
        "SHOW_ELEMENTS_COUNT" => "N",
        "SORT_BY1" => "SORT",
        "SORT_BY2" => "NAME",
        "SORT_ORDER1" => "DESC",
        "SORT_ORDER2" => "ASC",
        "SORT_SECTIONS_BY1" => "NAME",
        "SORT_SECTIONS_BY2" => "SORT",
        "SORT_SECTIONS_ORDER1" => "DESC",
        "SORT_SECTIONS_ORDER2" => "ASC"
    )
);?>
);?>


Информеры

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для государственных организаций>Официальный сайт государственной организации>Компоненты>Информеры

Компоненты::Информеры

Описание gosportal:informers

Одностраничный компонент для показа информеров. Компонент разработан для решения Официальный сайт государственной организации. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен в разделе: Гос. сайт.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
Папка с информерами | FOLDER | Указывается шаблон пути к папке с информерами.

Пример вызова

<?$APPLICATION->IncludeComponent(
"gosportal:informers",
    "",
    Array(
        "FOLDER" => "#SERVER_NAME#"
    )
);?>


Лог изменений

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для государственных организаций>Официальный сайт государственной организации>Компоненты>Лог изменений

Компоненты::Лог изменений

Описание socialnetwork.log

Компонент выводит лог изменений. Компонент разработан для решения Официальный сайт государственной организации.

Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Источник данных
Количество дней лога | LOG_DATE_DAYS | Количество дней ведения лога изменений социальной сети.
Внешний вид
Отображать комментарии с привязкой к событиям | USE_COMMENTS | При отмеченной опции отображение комментариев будет идти с привязкой к событиям.
Шаблоны ссылок
Шаблон пути к странице пользователя | PATH_TO_USER | Задается путь к странице профиля пользователя социальной сети.
Шаблон пути к странице группы | PATH_TO_GROUP | Задается путь к странице группы социальной сети.
Дополнительные настройки
Устанавливать цепочку навигации | SET_NAVCHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт Лог обновлений.
Учитывать подписку | SUBSCRIBE_ONLY | [Y|N] При отмеченной опции будет отображаться лог изменений с учетом подписки, иначе - весь лог.
Количество отображаемых записей | LOG_CNT | Указывается количество записей в логе изменений.
Имена переменных
Имя переменной для страницы | PAGE_VAR | Указывается имя переменной, которой передается страница социальной сети.
Имя переменной для пользователя | USER_VAR | Указывается имя переменной, которой передается идентификатор пользователя социальной сети.
Имя переменной для группы | GROUP_VAR | Указывается имя переменной, которой передается идентификатор группы социальной сети.

Пример вызова

<?$APPLICATION->IncludeComponent(
"gosportal:socialnetwork.log",
    "",
    Array(
        "PAGE_VAR" => "",
        "USER_VAR" => "",
        "GROUP_VAR" => "",
        "PATH_TO_USER" => "",
        "PATH_TO_GROUP" => "",
        "SET_NAV_CHAIN" => "Y",
        "SUBSCRIBE_ONLY" => "Y",
        "LOG_CNT" => "0",
        "LOG_DATE_DAYS" => "7",
        "USE_COMMENTS" => "Y"
    )
);?>


Мастер создания обращения (с регистрацией пользователя)

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для государственных организаций>Официальный сайт государственной организации>Компоненты>Мастер создания обращения (с регистрацией пользователя)

Компоненты::Мастер создания обращения (с регистрацией пользователя)

Описание iblock.wizard

Компонент формирует разделы мастера на основе секций инфоблока и вопросы на основе элементов инфоблока. Компонент разработан для решения Официальный сайт государственной организации. Компонент стандартный и входит в дистрибутив модуля.

В структуре визуального редактора компонент расположен по пути Сервисы > Техподдержка.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается тип информационного блока.
Информационный блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор инфоблока, в котором хранится мастер техподдержки.
Свойство, в котором хранится тип вопроса | PROPERTY_FIELD_TYPE | Указывается свойство, в котором хранится тип вопроса.
Множественное свойство, в котором хранятся значения выпадающего списка | PROPERTY_FIELD_VALUES | Указывается множественное свойство, в котором хранятся значения выпадающего списка.
Свойство, в котором хранится признак обязательности | PROPERTY_FIELD_NEED | Указывается свойство, в котором хранится признак обязательности.
Страница, с которой пришли на мастер (для кнопки "Назад", может быть пустое) | BACK_URL | Указывается адрес страницы, с которой пришли на мастер (для кнопки "Назад", поле может быть пустое).
Страница с формой редактирования сообщения | NEXT_URL | Указывается адрес страницы с формой редактирования сообщения.
Дополнительные настройки
Добавлять разделы мастера в навигационную цепочку | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции разделы мастера техподдержки будут добавлены в навигационнную цепочку.
Регистрировать пользователей | REGISTER_USER | [Y|N] При отмеченной опции будет происходить регистрация пользователя, создающего обращение.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.

Пример вызова

<?$APPLICATION->IncludeComponent(
"gosportal:iblock.wizard",
    "",
    Array(
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "feedback",
        "IBLOCK_ID" => "7",
        "PROPERTY_FIELD_TYPE" => "type",
        "PROPERTY_FIELD_VALUES" => "values",
        "PROPERTY_FIELD_NEED" => "need",
        "BACK_URL" => "ticket_list.php",
        "NEXT_URL" => "ticket_edit.php",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "REGISTER_USER" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_NOTES" => "",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "N",
        "AJAX_OPTION_HISTORY" => "Y",
        "AJAX_OPTION_ADDITIONAL" => ""
    )
);?>


Меню

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для государственных организаций>Официальный сайт государственной организации>Компоненты>Меню

Компоненты::Меню

Описание gosportal:menu

Компонент выводит меню указанного типа с фиксированным верхним разделом.

Компонент разработан для решения Официальный сайт государственной организации. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен в разделе: Гос. сайт.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип меню для первого уровня | ROOT_MENU_TYPE | Указывается тип меню верхнего уровня, соответствующий данному меню.
Дополнительные настройки
Уровень вложенности меню | MAX_LEVEL | В выпадающем списке выберите уровень вложенности. Доступно четыре уровня. Чем больше число, тем пункты более низких уровней будут отображены.
Тип меню для остальных уровней | CHILD_MENU_TYPE | Укажите тип меню для меню нижних уровней.
Подключать файлы с именами вида .тип_меню.menu_ext.php | USE_EXT | [Y|N] При отмеченной опции будет разрешено подключать файлы с именами вида .тип_меню.menu_ext.php.
Откладывать выполнение шаблона меню DELAY [Y|N] При отмеченной опции выполнение шаблона будет происходить после загрузки страницы. Очень удобен при включенном кешировании компонента, если нужно все же выполнять какие-то действия по модификации внешнего вида пунктов меню в зависимости от текущей страницы. Например, добавление пунктов меню в компонентах.
$GLOBALS['BX_MENU_CUSTOM']->AddItem('left', array(

'TEXT' => 'Моб. версия', 'LINK' => $APPLICATION->

GetCurPage(false) . '?mobile'))

Первый параметр - тип меню. Второй - массив, описывающий пункт меню [image].

Разрешить несколько активных пунктов одновременно | ALLOW_MULTI_SELECT | [Y|N] При отмеченной опции будет разрешено несколько активных пунктов меню одновременно.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто: автоматически обновляет кеш компонентов в течение заданного времени;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования | MENU_CACHE_TIME | Время кеширования в секундах.
Учитывать права доступа | MENU_CACHE_USE_GROUPS | При кешировании будут учитываться права доступа пользователя к тем или иным пунктам меню. Если меню построено без учета прав доступа, флажок лучше снять - размер кеша уменьшится.
Значимые переменные запроса | MENU_CACHE_GET_VARS | Если отображение меню зависит от параметров страницы, то при использовании кеширования необходимо указать параметры в этом поле. Параметры вводятся через запятую.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "gosportal:menu",
    "left",
    Array(
        "ALLOW_MULTI_SELECT" => "N",
        "CHILD_MENU_TYPE" => "left",
        "DELAY" => "N",
        "MAX_LEVEL" => "1",
        "MENU_CACHE_GET_VARS" => array(""),
        "MENU_CACHE_TIME" => "3600",
        "MENU_CACHE_TYPE" => "N",
        "MENU_CACHE_USE_GROUPS" => "Y",
        "ROOT_MENU_TYPE" => "left",
        "USE_EXT" => "N"
    )
);?>

Смотрите также

Создание и работа с меню [image] в курсе Разработчик Bitrix Framework.


Мобильная регистрация

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для государственных организаций>Официальный сайт государственной организации>Компоненты>Мобильная регистрация

Компоненты::Мобильная регистрация

Описание mobile.register

Компонент позволят настроить форму регистрации нового пользователя.

Компонент разработан для решения Официальный сайт государственной организации. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Служебные > Пользователь.

Параметры

Поле | Параметр | Описание
Дополнительно
Название блока пользовательских свойств | USER_PROPERTY_NAME | Указывается название блока пользовательских свойств.
Основные параметры
Поля, которые показывать в форме | SHOW_FIELDS | Указываются поля, которые будут выведены в форме регистрации.
Поля, обязательные для заполнения | REQUIRED_FIELDS | Указываются обязательные для заполнения поля.
Дополнительные настройки
Автоматически авторизовать пользователей | AUTH | [Y|N] При отмеченной опции после регистрации пользователь будет автоматически авторизован на сайте. В противном случае после регистрации пользователю будет предоставлена к заполнению форма авторизации.
Отправлять пользователя по обратной ссылке, если она есть | USE_BACKURL | [Y|N] При отмеченной опции пользователь будет отправлен по обратной ссылке, если она есть. При наличии в адресной строке параметра backurl пользователь будет перенаправлен по указанной в этом параметре ссылке после заполнения формы регистрации.
Страница окончания регистрации | SUCCESS_PAGE | Указывается адрес страницы сайта, которая будет финальной страницей процедуры регистрации, и пользователь будет перенаправлен на нее в случае успешной регистрации. Если пользователь зарегистрирован и авторизован, то при переходе на страницу регистрации он попадет на страницу окончания регистрации. Примечание: один из параметров (USE_BACKURL или SUCCESS_PAGE) лучше заполнить. Если отмечены оба параметра, то пользователь будет переведен по обратной ссылке.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Регистрация нового пользователя.
Показывать доп. свойства | USER_PROPERTY | Указываются дополнительные пользовательские свойства, если они заданы.

Пример вызова

<?$APPLICATION->IncludeComponent(
"gosportal:mobile.register",
    "",
    Array(
        "USER_PROPERTY_NAME" => "",
        "SHOW_FIELDS" => array("NAME", "SECOND_NAME", "LAST_NAME"),
        "REQUIRED_FIELDS" => array("LAST_NAME"),
        "AUTH" => "Y",
        "USE_BACKURL" => "Y",
        "SUCCESS_PAGE" => "",
        "SET_TITLE" => "Y",
        "USER_PROPERTY" => array("UF_STRUCTURE")
    )
);?>


Погода

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для государственных организаций>Официальный сайт государственной организации>Компоненты>Погода

Компоненты::Погода

Описание weather

Компонент выводит погодные условия в выбранном населенном пункте.

Компонент разработан для решения Официальный сайт государственной организации и содержит следующие шаблоны: .default и .right. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен в разделе Служебные.

Параметры

Поле | Параметр | Описание
Основные параметры
Город | CITY | Выбирается город.
Показывать ссылку на подробную информацию | SHOW_URL | При отмеченной опции будет показана ссылка на интернет-страницу с детальным прогнозом погоды.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
"gosportal:weather",
    "",
    Array(
        "CITY" => "c11339",
        "SHOW_URL" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "300",
        "CACHE_NOTES" => ""
    )
);?>


Подключение содержимого информера

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для государственных организаций>Официальный сайт государственной организации>Компоненты>Подключение содержимого информера

Компоненты::Подключение содержимого информера

Описание gosportal:main.include

Компонент располагается в шаблоне дизайна сайта и определяет место расположения включаемых областей страниц и разделов. Настройки компонента позволяют определить суффикс имени файла включаемой области, указать шаблон области по умолчанию. Компонент разработан для решения Официальный сайт государственной организации. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен в разделе: Гос. сайт.

Параметры

Поле | Параметр | Описание
Параметры компонента
Показывать включаемую область AREA_FILE_SHOW Возможные значения:
  • sect: показывать для раздела, область будет являться включаемой для всего раздела;
  • page: показывать для страницы, область будет являться включаемой только для текущей страницы;
  • file: показывать информацию из файла. Если компонент расположить в шаблоне дизайна сайта, то информация из файла будет выводиться на всем сайте. Установка параметра доступна только пользователю с правами edit_php.
Суффикс имени файла включаемой области | AREA_FILE_SUFFIX | Поле предназначено для указания суффикса, который будет добавляться к именам файлов включаемых областей. Страницы с таким суффиксом будут восприниматься как включаемые области.
Шаблон области по умолчанию | EDIT_TEMPLATE | Доступны все шаблоны страниц, созданные в системе. Они располагаются в разделе /bitrix/templates/.default/page_templates/. В данном поле можно указать любой другой файл в системе, указав полный путь в файлу-шаблону.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "gosportal:main.include",
    "",
    Array(
        "AREA_FILE_SHOW" => "page",
        "AREA_FILE_SUFFIX" => "inc",
        "EDIT_TEMPLATE" => ""
    )
);?>


Рабочий стол

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для государственных организаций>Официальный сайт государственной организации>Компоненты>Рабочий стол

Компоненты::Рабочий стол

Описание desktop

Одностраничный компонент позволяет создать настраиваемый рабочий стол с использованием разнофункциональных гаджетов.

В визуальном редакторе компонент расположен в разделе: Сервисы.

Параметры

Поле | Параметр | Описание
Источник данных
Идентификатор | ID | Символьный код стола. Столы с одинаковыми идентификаторами имеют одинаковые настройки.
Разрешить настраивать рабочий стол всем авторизованным пользователям | CAN_EDIT | [Y/N] Установленный флажок разрешает персональную настройку для авторизованных пользователей. В противном случае настраивать рабочий стол может только пользователь с правами на запись для страницы, на которой размещен компонент.
Количество столбцов | COLUMNS | Задается число столбцов Рабочего стола. После ввода числа нужно нажать кнопку OK, измениться число полей для задания ширины столбцов.
Размер столбца #N | COLUMN_WIDTH_0 | Поле для задания ширины конкретного столбца. Задается в пикселях или процентах.
Доступные гаджеты | GADGETS | С помощью кнопки CTRL выбираются гаджеты, которые будут отображаться на рабочем столе. Для выбранных гаджетов ниже появляются свои группы параметров для настройки.
Настройки гаджета "RSS лента"
Время кеширования | G_RSSREADER_CACHE_TIME | Срок в секундах на который кешируются полученные данные. При выборе "0" - данные не кешируются.
Показывать ссылку на подробную информацию | G_RSSREADER_SHOW_URL | [Y/N] Разрешает отображение ссылки на подробную информацию.
Предустановленные RSS ленты | G_RSSREADER_PREDEFINED_RSS | С каждой новой строки вводится отдельный URL RSS ленты. При изменении списка необходимо нажать кнопку [image] для сохранения изменений.
Настройки по умолчанию параметров пользователя для гаджета "RSS лента"
Название гаджета | GU_RSSREADER_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество новостей | GU_RSSREADER_CNT | Задается число отображаемых новостей. Если выставлено "0", будут отображаться все новости.
Ссылка на RSS ленту | GU_RSSREADER_RSS_URL | Выбор одной из предустановленных лент новостей, либо ввод URL любой другой ленты.
Настройки гаджета "Видеоновости"
Тип информационного блока | G_VIDEO_IBLOCK_TYPE | Выбор типа информационного блока, из которого будут показываться видеоновости.
Информационный блок | G_VIDEO_IBLOCK_ID | Выбор информационного блока, из которого будут показываться видеоновости.
URL страницы со списком видеоновостей | G_VIDEO_LIST_URL | Адрес страницы на которой выводятся видеоновости.
Свойство, в котором хранится путь к ролику | G_VIDEO_PATH_TO_FILE | Указать свойство инфоблока, в котором храниться путь к файлу на сервере.
Свойство, в котором хранится длительность ролика | G_VIDEO_DURATION | Указать свойство инфоблока, в котором храниться описание длительности ролика.
Секция | G_VIDEO_SECTION_ID | Выбор секции инфоблока, из которо будут выводиться ролики для показа.
Элемент | G_VIDEO_ELEMENT_ID | Указать элемент, который будет отображаться в экране плеера при открытии.
Ширина области плеера | G_VIDEO_WIDTH | Задать ширину плеера
Высота области плеера | G_VIDEO_HEIGHT | Задать высоту плеера
Тип кеширования | G_VIDEO_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_VIDEO_CACHE_TIME | Задать время кеширования
Настройки гаджета "Выскажи мнение"
Группа опросов | G_VOTE_CHANNEL_SID | Указывается группа опросов для выводв в гаджете.
Тип кеширования | G_VOTE_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_VOTE_CACHE_TIME | Задать время кеширования
URL страницы со списком опросов | G_VOTE_LIST_URL | Адрес страницы со списком опросов.
Настройки по умолчанию параметров пользователя для гаджета "Выскажи мнение"
Название гаджета | GU_VOTE_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Настройки по умолчанию параметров пользователя для гаджета "Гаджеты Google"
Название гаджета | GU_GOOGLE_GADGETS_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Настройки гаджета "Дни рождения"
Страница структуры компании | G_BIRTHDAY_STRUCTURE_PAGE | Адрес страницы портала со структурой компании.
Страница отправки личного сообщения | G_BIRTHDAY_PM_URL | Адрес страницы, на которой будет выводиться сообщение.
Показывать год рождения | G_BIRTHDAY_SHOW_YEAR | Выбрать кому будет отображаться год рождения.
Пользовательские поля для вывода | G_BIRTHDAY_USER_PROPERTY | Выбор из списка полей, которые будут отображаться у записи пользователя.
URL страницы со списком дней рождений | G_BIRTHDAY_LIST_URL | Адрес страницы со списком дней рождений.
Настройки по умолчанию параметров пользователя для гаджета "Дни рождения"
Название гаджета | GU_BIRTHDAY_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых пользователей | GU_BIRTHDAY_NUM_USERS | Сколько пользователей будет видно в списке гаджета.
Показывать для отдела/офиса | GU_BIRTHDAY_DEPARTMENT | Для какого подразделения выводить пользователей.
Настройки гаджета "Доска почета"
URL страницы с доской почета | G_HONOUR_LIST_URL | АДрес страницы, где отображается доска почета.
Настройки по умолчанию параметров пользователя для гаджета "Доска почета"
Название гаджета | GU_HONOUR_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых пользователей | GU_HONOUR_NUM_USERS | Сколько пользователей будет видно в списке гаджета.
Настройки гаджета "Живая лента"
Имя переменной для пользователя | G_UPDATES_USER_VAR | Переменная, в которой передается имя соответствующей сущности.
Имя переменной для группы | G_UPDATES_GROUP_VAR
Имя переменной для страницы | G_UPDATES_PAGE_VAR
Шаблон пути к странице пользователя | G_UPDATES_PATH_TO_USER | Шаблон пути к странице пользователя.
Шаблон пути к странице группы | G_UPDATES_PATH_TO_GROUP | Шаблон пути к странице группы.
URL страницы со списком обновлений | G_UPDATES_LIST_URL | Адрес страницы "Живая лента"
Настройки по умолчанию параметров пользователя для гаджета "Живая лента"
Название гаджета | GU_UPDATES_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество отображаемых записей | GU_UPDATES_LOG_CNT | Сколько записей будет выводиться гаджете.
Тип подписки | GU_UPDATES_ENTITY_TYPE | Выбор типа подписки.
Тип сообщения | GU_UPDATES_EVENT_ID | ВЫбор типов сообщений.
Настройки по умолчанию параметров пользователя для гаджета "Заметки"
Название гаджета | GU_HTML_AREA_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Настройки по умолчанию параметров пользователя для гаджета "Избранные ссылки"
Название гаджета | GU_FAVORITES_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Настройки для гаджета "Информация"
Тип баннера | G_ADV_TYP | Указать тип баннера, который будет отображаться пользователю.
Настройки по умолчанию параметров пользователя для гаджета "Информация"
Название гаджета | GU_ADV_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Настройки гаджета "Мои задачи"
Имя переменной для кода страницы | G_TASKS_PAGE_VAR | Переменная, в которой передается имя соответствующей сущности.
Имя переменной для кода группы | G_TASKS_GROUP_VAR
Имя переменной для кода пользователя | G_TASKS_VIEW_VAR
Имя переменной для кода задачи | G_TASKS_TASK_VAR
Имя переменной для кода действия | G_TASKS_ACTION_VAR
Путь к списку задач группы | G_TASKS_PATH_TO_GROUP_TASKS | Путь к соответствующей странице.
Путь к задаче группы | G_TASKS_PATH_TO_GROUP_TASKS_TASK
Путь к списку задач пользователя | G_TASKS_PATH_TO_USER_TASKS
Путь к задаче пользователя | G_TASKS_PATH_TO_USER_TASKS_TASK
URL списка задач | G_TASKS_PATH_TO_TASK | Адрес страницы со списком задач
URL создания задачи | G_TASKS_PATH_TO_TASK_NEW | Адрес страницы с формой создания задачи.
Настройки по умолчанию параметров пользователя для гаджета "Мои задачи"
Название гаджета | GU_TASKS_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество записей на странице | GU_TASKS_ITEMS_COUNT | Сколько записей будет отображаться в гаджете.
Упорядочить по | GU_TASKS_ORDER_BY | Выбор сортировки для задач.
Показывать задачи | GU_TASKS_TYPE | Выбор типа задач.
Настройки гаджета "Мои сообщения"
Шаблон пути к странице пользователя | G_MESSAGES_PATH_TO_USER | Шаблон пути к соответствующим страницам
Шаблон пути к странице группы | G_MESSAGES_PATH_TO_GROUP
Шаблон пути к странице отправки сообщений | G_MESSAGES_PATH_TO_MESSAGE_FORM
Шаблон пути к странице ответа на сообщение | G_MESSAGES_PATH_TO_MESSAGE_FORM_MESS
Шаблон пути к странице чата | G_MESSAGES_PATH_TO_MESSAGES_CHAT
Путь к папке со смайликам относительно корня сайта | G_MESSAGES_PATH_TO_SMILE | Путь к папке со смайликам относительно корня сайта
Период опроса сервера | G_MESSAGES_AJAX_LONG_TIMEOUT | Указать время в секундах.
Имя переменной для сообщения | G_MESSAGES_MESSAGE_VAR | Переменная, в которой передается соответствующая сущность.
Имя переменной для страницы | G_MESSAGES_PAGE_VAR
Имя переменной для пользователя | G_MESSAGES_USER_VAR
Путь к входящим сообщениям | G_MESSAGES_INBOX_URL
Путь к отправленным сообщениям | G_MESSAGES_SENT_URL | Путь к странице с исходящими сообщениями.
Настройки по умолчанию параметров пользователя для гаджета "Мои сообщения"
Название гаджета | GU_MESSAGES_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Настройки гаджета "Мой календарь"
Тип инфоблока | G_CALENDAR_IBLOCK_TYPE | Выбор типа инфоблока, в котором размещаются календари.
Инфоблок | G_CALENDAR_IBLOCK_ID | Выбор инфоблока, в котором размещаются календари.
Адрес страницы для детального просмотра | G_CALENDAR_DETAIL_URL | Адрес страницы с персональным календарем.
Тип кеширования | G_CALENDAR_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_CALENDAR_CACHE_TIME | Задать время кеширования
Путь к персональному календарю | G_CALENDAR_CALENDAR_URL | Путь к персональному календарю
Настройки по умолчанию параметров пользователя для гаджета "Мой календарь"
Название гаджета | GU_CALENDAR_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество событий в списке | GU_CALENDAR_EVENTS_COUNT | Сколько событий будет выведено в гаджете.
Настройки гаджета "Мой профиль"
URL страницы Основное | G_PROFILE_PATH_TO_GENERAL | Указываются адреса соответствующих страниц.
URL страницы Изменение профиля | G_PROFILE_PATH_TO_PROFILE_EDIT
URL страницы Обновления | G_PROFILE_PATH_TO_LOG
URL страницы Мои подписки | G_PROFILE_PATH_TO_SUBSCR
URL страницы Мои сообщения | G_PROFILE_PATH_TO_MSG
URL страницы Мои группы | G_PROFILE_PATH_TO_GROUPS
URL страницы Создание группы | G_PROFILE_PATH_TO_GROUP_NEW
URL страницы Мои фотографии | G_PROFILE_PATH_TO_PHOTO
URL страницы Добавление фотографий | G_PROFILE_PATH_TO_PHOTO_NEW
URL страницы Форум | G_PROFILE_PATH_TO_FORUM
URL страницы Блог | G_PROFILE_PATH_TO_BLOG
URL страницы Добавления нового сообщения в блог | G_PROFILE_PATH_TO_BLOG_NEW
URL страницы Календарь | G_PROFILE_PATH_TO_CAL
URL страницы Задачи | G_PROFILE_PATH_TO_TASK
URL страницы Добавление задачи | G_PROFILE_PATH_TO_TASK_NEW
URL страницы Файлы | G_PROFILE_PATH_TO_LIB
Настройки по умолчанию параметров пользователя для гаджета "Мой профиль"
Название гаджета | GU_PROFILE_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Показать Основное | GU_PROFILE_SHOW_GENERAL | [Y\N] Выбор сущностей для отображения в гаджете.
Показать Группы | GU_PROFILE_SHOW_GROUPS
Показать Фото | GU_PROFILE_SHOW_PHOTO
Показать Форум | GU_PROFILE_SHOW_FORUM
Показать Календарь | GU_PROFILE_SHOW_CAL
Показать Блог | GU_PROFILE_SHOW_BLOG
Показать Задачи | GU_PROFILE_SHOW_TASK
Показать Файлы | GU_PROFILE_SHOW_LIB
Настройки гаджета "Найти сотрудника"
URL страницы со списком сотрудников компании | G_SEARCH_EMPLOYEE_LIST_URL | Адрес страницы "Сотрудники".
Настройки по умолчанию параметров пользователя для гаджета "Найти сотрудника"
Название гаджета | GU_SEARCH_EMPLOYEE_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Настройки гаджета "Наша жизнь"
Тип информационного блока (используется только для проверки) | G_LIFE_IBLOCK_TYPE | Выбор типа информационного блока.
Код информационного блока | G_LIFE_IBLOCK_ID | Выбор информационного блока.
Формат показа даты | G_LIFE_ACTIVE_DATE_FORMAT | Шаблон отображения даты. Выбирается из выпадающего списка, либо вводится свой в дополнительном поле.
URL страницы со списком новостей | G_LIFE_LIST_URL | Адрес соответствующей страницы
URL страницы с новостью подробно | G_LIFE_DETAIL_URL
Тип кеширования | G_LIFE_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_LIFE_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Наша жизнь"
Название гаджета | GU_LIFE_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество новостей на странице | GU_LIFE_NEWS_COUNT | Указать какое количество новостей выводить в гаджете.
Показывать дату | GU_LIFE_DISPLAY_DATE | [Y\N] Выбор сущностей для отображения в гаджете.
Показать картинку | GU_LIFE_DISPLAY_PICTURE
Показать текст анонса | GU_LIFE_DISPLAY_PREVIEW_TEXT
Настройки гаджета "Новое в блогах"
Шаблон пути к странице блога: | G_BLOG_PATH_TO_BLOG | Шаблон соответствующих страниц.
Шаблон пути к странице с сообщением блога | G_BLOG_PATH_TO_POST
Шаблон пути к странице с сообщением блога группы | G_BLOG_PATH_TO_GROUP_BLOG_POST
Шаблон пути к странице пользователя блога | G_BLOG_PATH_TO_USER
Тип кеширования | G_BLOG_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_BLOG_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Новое в блогах"
Название гаджета | GU_BLOG_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество результатов, выводимых на страницу | GU_BLOG_MESSAGE_COUNT | Указать какое количество новых сообщений выводить в гаджете.
Длина выводимого текста сообщения | GU_BLOG_MESSAGE_LENGTH | Указать какое количество знаков текста сообщения выводить в гаджете.
Формат показа даты и времени | GU_BLOG_DATE_TIME_FORMAT | Можно перезадать формат даты и времени для этого гаджета.
Настройки гаджета "Новое на форуме"
ID форума | G_FORUM_FID | Выбрать форум, новые сообщения которого будут выводиться в гаджете.
Поле для сортировки | G_FORUM_SORT_BY | По какому полю будут сортироваться сообщения.
Направление сортировки | G_FORUM_SORT_ORDER | Выбрать направление сортировки.
Страница чтения сообщения | G_FORUM_URL_TEMPLATES_MESSAGE | Адрес страницы.
Тип кеширования | G_FORUM_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_FORUM_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Новое на форуме"
Название гаджета | GU_FORUM_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество тем на одной странице | GU_FORUM_TOPICS_PER_PAGE | Указать какое количество новых сообщений выводить в гаджете.
Формат показа даты и времени | GU_FORUM_DATE_TIME_FORMAT | Можно перезадать формат даты и времени для этого гаджета.
Настройки гаджета "Новые сотрудники"
URL страницы с кадровыми перестановками | G_NEW_EMPLOYEES_LIST_URL | Адрес страницы.
Настройки по умолчанию параметров пользователя для гаджета "Новые сотрудники"
Название гаджета | GU_NEW_EMPLOYEES_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых записей | GU_NEW_EMPLOYEES_NUM_USERS | Указать какое количество новых сотрудников выводить в гаджете.
Показывать для отдела/офиса | GU_NEW_EMPLOYEES_DEPARTMENT | Указать для какого подразделения выводить данные.
Настройки гаджета "Общие документы"
Тип информационного блока (используется только для проверки) | G_SHARED_DOCS_IBLOCK_TYPE | Выбрать тип информационного блока где размещена информация.
Код информационного блока | G_SHARED_DOCS_IBLOCK_ID | Выбрать информационный блок где размещена информация.
URL страницы с библиотекой документов компании | G_SHARED_DOCS_LIST_URL | Адрес страницы.
URL страницы детального просмотра (по умолчанию - из настроек инфоблока) | G_SHARED_DOCS_DETAIL_URL | Адрес страницы.
Тип кеширования | G_SHARED_DOCS_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_SHARED_DOCS_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Общие документы"
Название гаджета | GU_SHARED_DOCS_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых документов | GU_SHARED_DOCS_DOCS_COUNT | Указать какое количество документов выводить в гаджете.
Показывать дату | GU_SHARED_DOCS_DISPLAY_DATE | [Y\N] Выбор сущностей для отображения в гаджете.
Показать картинку | GU_SHARED_DOCS_DISPLAY_PICTURE
Показать текст анонса | GU_SHARED_DOCS_DISPLAY_PREVIEW_TEXT
Настройки гаджета "Отсутствуют в офисе"
URL страницы со списком отсутсвий | G_ABSENT_LIST_URL | Адрес страницы.
Настройки по умолчанию параметров пользователя для гаджета "Отсутствуют в офисе"
Название гаджета | GU_ABSENT_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых записей | GU_ABSENT_NUM_USERS | Указать какое количество отсутсвий выводить в гаджете.
Показывать для отдела/офиса | GU_ABSENT_DEPARTMENT | Указать для какого подразделения выводить данные.
Настройки гаджета "Отчет 1С"
Тип кеширования | G_REPORT1C_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_REPORT1C_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Отсутствуют в офисе"
Название гаджета | GU_REPORT1C_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
URL сервера | GU_REPORT1C_R1_URL | Адрес сервера
Порт | GU_REPORT1C_R1_PORT | Порт сервера
Путь к веб-сервису | GU_REPORT1C_R1_PATH | Путь к веб-сервису
Имя пользователя | GU_REPORT1C_R1_LOGIN | Логин
Пароль | GU_REPORT1C_R1_PASSWORD | Пароль
Таймаут соединения, сек | GU_REPORT1C_R1_CONNTIMEOUT | Таймаут соединения
Кешировать ошибочные результаты | U_REPORT1C_R1_CACHE_ERR | Указать, кешировать или нет результаты, если они ошибочны.
Страница по-умолчанию | GU_REPORT1C_R1_INITIALREPORT | Какая страница будет открываться по умолчанию.
Настройки гаджета "Официальная информация"
Тип информационного блока (используется только для проверки) | G_OFFICIAL_IBLOCK_TYPE | Выбрать тип информационного блока где размещена информация.
Код информационного блока | G_OFFICIAL_IBLOCK_ID | Выбрать информационный блок где размещена информация.
URL страницы со списком официальной информации | G_OFFICIAL_LIST_URL | Адрес страницы.
URL страницы с подробно официальной информацией | G_OFFICIAL_DETAIL_URL | Адрес страницы.
Формат показа даты и времени | G_OFFICIAL_ACTIVE_DATE_FORMAT | Можно перезадать формат даты и времени для этого гаджета.
Тип кеширования | G_OFFICIAL_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_OFFICIAL_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Официальная информация"
Название гаджета | GU_OFFICIAL_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых документов | GU_OFFICIAL_NEWS_DOCS_COUNT | Указать какое количество документов выводить в гаджете.
Показать текст анонса | GU_OFFICIAL_DISPLAY_PREVIEW_TEXT | [Y\N] Вывод текста анонса в гаджете.
Настройки гаджета "Пробки"
Время кеширования | G_PROBKI_CACHE_TIME | Срок в секундах на который кешируются полученные данные. При выборе "0" - данные не кешируются
Показывать ссылку на подробную информацию | G_PROBKI_SHOW_URL | [Y/N] Разрешает отображение ссылки на подробную информацию.
Настройки по умолчанию параметров пользователя для гаджета "Пробки"
Название гаджета | GU_PROBKI_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Город | GU_PROBKI_CITY | Выбор города, для которого нужно отображать пробки
Настройки гаджета "Прогноз погоды"
Время кеширования | G_WEATHER_SHOW_TIME | Срок в секундах на который кешируются полученные данные. При выборе "0" - данные не кешируются
Показывать ссылку на подробную информацию | G_WEATHER_SHOW_URL | [Y/N] Разрешает отображение ссылки на подробную информацию.
Настройки по умолчанию параметров пользователя для гаджета "Прогноз погоды"
Название гаджета | GU_WEATHER_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Город | GU_WEATHER_CITY | Выбор города, для которого нужно отображать прогноз погоды.
Настройки гаджета "Рабочие группы"
Имя переменной для группы | G_WORKGROUPS_GROUP_VAR | Переменная в которой передается имя группы.
Шаблон пути к странице группы | G_WORKGROUPS_PATH_TO_GROUP | Шаблон пути к странице.
Шаблон пути к странице поиска групп | G_WORKGROUPS_PATH_TO_GROUP_SEARCH | Шаблон пути к странице.
Время кеширования (сек.) | G_WORKGROUPS_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "Рабочие группы"
Название гаджета | GU_WORKGROUPS_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Формат даты | GU_WORKGROUPS_DATE_TIME_FORMAT | Можно перезадать формат даты для гаджета.
Показывать изображение | GU_WORKGROUPS_DISPLAY_PICTURE | [Y\N] Выбор сущностей для отображения в гаджете.
Показать описание | GU_WORKGROUPS_DISPLAY_DESCRIPTION
Показать число участников | GU_WORKGROUPS_DISPLAY_NUMBER_OF_MEMBERS
Показать только мои | GU_WORKGROUPS_FILTER_MY
Настройки гаджета "События компании"
Тип информационного блока | G_COMPANY_CALENDAR_IBLOCK_TYPE | Выбрать тип информационного блока где размещена информация.
Информационный блок | G_COMPANY_CALENDAR_IBLOCK_ID | Выбрать информационный блок где размещена информация.
Адрес страницы для детального просмотра | G_COMPANY_CALENDAR_DETAIL_URL | Адрес страницы.
Тип кеширования | G_COMPANY_CALENDAR_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_COMPANY_CALENDAR_CACHE_TIME | Задать время кеширования
Настройки по умолчанию параметров пользователя для гаджета "События компании"
Название гаджета | GU_COMPANY_CALENDAR_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество событий | GU_COMPANY_CALENDAR_EVENTS_COUNT | Указать какое количество событий выводить в гаджете.
Настройки по умолчанию параметров пользователя для гаджета "Список задач"
Название гаджета | GU_CRM_TASK_LIST_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Сущности в списке | GU_CRM_TASK_LIST_TASK_TYPE_LIST | Выбор сущностей, которые будут отображаться в гаджете.
Только мои | GU_CRM_TASK_LIST_ONLY_MY | [Y\N] Будут показаны только задачи созданные пользователем.
Сортировка | GU_CRM_TASK_LIST_SORT | Выбор параметра сортировки.
По | GU_CRM_TASK_LIST_SORT_BY | Выбор направления сортировки.
Количество событий | GU_CRM_TASK_LIST_TASK_COUNT | Указать какое количество событий выводить в гаджете.
Настройки по умолчанию параметров пользователя для гаджета "Список компаний"
Название гаджета | GU_CRM_COMPANY_LIST_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Тип компании | GU_CRM_COMPANY_LIST_TYPE_ID | Выбор типа компаний, которые будут отображаться в гаджете.
Только мои | GU_CRM_COMPANY_LIST_ONLY_MY | [Y\N] Будут показаны только компании пользователя.
Сортировка | GU_CRM_COMPANY_LIST_SORT | Выбор параметра сортировки.
По | GU_CRM_COMPANY_LIST_SORT_BY | Выбор направления сортировки.
Количество компаний | GU_CRM_COMPANY_LIST_COMPANY_COUNT | Указать какое количество компаний выводить в гаджете.
Настройки по умолчанию параметров пользователя для гаджета "Список контактов"
Название гаджета | GU_CRM_CONTACT_LIST_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Тип | GU_CRM_CONTACT_LIST_TYPE_ID | Выбор типов контактов, которые будут отображаться в гаджете.
Только мои | GU_CRM_CONTACT_LIST_ONLY_MY | [Y\N] Будут показаны только контакты созданные пользователем.
Сортировка | GU_CRM_CONTACT_LIST_SORT | Выбор параметра сортировки.
По | GU_CRM_TASK_CONTACT_SORT_BY | Выбор направления сортировки.
Количество контактов | GU_CRM_CONTACT_LIST_CONTACT_COUNT | Указать какое количество контактов выводить в гаджете.
Настройки по умолчанию параметров пользователя для гаджета "Список лидов"
Название гаджета | GU_CRM_LEAD_LIST_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Статус | GU_CRM_LEAD_LIST_STATUS_ID | Выбор статуса лида, в котором они будут отображаться в гаджете.
Только мои | GU_CRM_LEAD_LIST_ONLY_MY | [Y\N] Будут показаны только лиды созданные пользователем.
Сортировка | GU_CRM_LEAD_LIST_SORT | Выбор параметра сортировки.
По | GU_CRM_LEAD_LIST_SORT_BY | Выбор направления сортировки.
Количество лидов | GU_CRM_LEAD_LIST_LEAD_COUNT | Указать какое количество лидов выводить в гаджете.
Настройки по умолчанию параметров пользователя для гаджета "Список сделок"
Название гаджета | GU_CRM_DEAL_LIST_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Стадия | GU_CRM_DEAL_LIST_STAGE_ID | Выбор стадии сделок, которые будут отображаться в гаджете.
Только мои | GU_CRM_DEAL_LIST_ONLY_MY | [Y\N] Будут показаны только сделки созданные пользователем.
Сортировка | GU_CRM_DEAL_IST_SORT | Выбор параметра сортировки.
По | GU_CRM_TASK_DEAL_SORT_BY | Выбор направления сортировки.
Количество контактов | GU_CRM_DEAL_LIST_DEAL_COUNT | Указать какое количество сделок выводить в гаджете.
Настройки по умолчанию параметров пользователя для гаджета "Список событий"
Название гаджета | GU_CRM_EVENT_LIST_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Сущности в списке | GU_CRM_EVENT_LIST_EVENT_TYPE_LIST | Выбор сущности, событий которой будут отображаться в гаджете.
Количество событий | GU_CRM_EVENT_LIST_EVENT_COUNT | Указать какое количество событий выводить в гаджете.
Настройки гаджета "Фотогалерея компании"
Тип информационного блока | G_PHOTOS_IBLOCK_TYPE | Выбрать тип информационного блока где размещена информация.
Информационный блок | G_PHOTOS_IBLOCK_ID | Выбрать информационный блок где размещена информация.
URL страницы с фотогалереей компании | G_PHOTOS_LIST_URL | Адрес страницы.
Страница детального просмотра | G_PHOTOS_DETAIL_UR
Страница слайд-шоу | G_PHOTOS_DETAIL_SLIDE_SHOW_URL
Тип кеширования | G_PHOTOS_CACHE_TYPE | Выбрать тип кеширования
Время кеширования (сек.) | G_PHOTOS_CACHE_TIME | Задать время кеширования
Путь к профилю пользователя | G_PHOTOS_PATH_TO_USER | Адрес страницы.
Отображение имени | G_PHOTOS_NAME_TEMPLATE | Формат отображения имени.
Показывать логин, если не задано имя | G_PHOTOS_SHOW_LOGIN | [Y/N] При установленной опции будет отображаться логин пользователя, если в профиле не указаны имя и фамилия.
Настройки по умолчанию параметров пользователя для гаджета "Фотогалерея компании"
Название гаджета | GU_PHOTOS_TITLE_STD | Указать какое название для гаджета будет видно пользователю.
Количество выводимых фотографий | GU_PHOTOS_PAGE_ELEMENTS | Указать какое количество фотографий будет видно пользователю.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "gosportal:desktop",
    "",
    Array(
        "ID" => "holder1",
        "CAN_EDIT" => "Y",
        "COLUMNS" => "3",
        "GADGETS" => array("ALL"),
        "GU_ADMIN_MARKETPALCE_TITLE_STD" => "",
        "G_RSSREADER_CACHE_TIME" => "3600",
        "G_RSSREADER_SHOW_URL" => "N",
        "G_RSSREADER_PREDEFINED_RSS" => "",
        "GU_RSSREADER_TITLE_STD" => "",
        "GU_RSSREADER_CNT" => "10",
        "GU_RSSREADER_RSS_URL" => "",
        "GU_SONET_GROUP_WIKI_TITLE_STD" => "",
        "GU_SONET_GROUP_WIKI_TEXT_LIMIT" => "500",
        "GU_BITRIX24_TITLE_STD" => "",
        "GU_SONET_USER_BIRTHDAY_TITLE_STD" => "",
        "G_SONET_BLOG_PATH_TO_BLOG" => "/company/personal/user/#user_id#/blog/",
        "G_SONET_BLOG_PATH_TO_POST" => "/company/personal/user/#user_id#/blog/#post_id#/",
        "G_SONET_BLOG_PATH_TO_GROUP_BLOG_POST" => "/workgroups/group/#group_id#/blog/#post_id#/",
        "G_SONET_BLOG_PATH_TO_USER" => "/company/personal/user/#user_id#/",
        "G_SONET_BLOG_CACHE_TYPE" => "A",
        "G_SONET_BLOG_CACHE_TIME" => "180",
        "GU_SONET_BLOG_TITLE_STD" => "",
        "GU_SONET_BLOG_MESSAGE_COUNT" => "6",
        "GU_SONET_BLOG_MESSAGE_LENGTH" => "100",
        "GU_SONET_BLOG_DATE_TIME_FORMAT" => "",
        "GU_PARTNERS_TITLE_STD" => "",
        "GU_PARTNERS_COUNT" => "5",
        "GU_PARTNERS_CAPTION" => "Важные ссылки",
        "G_VIDEO_LIST_URL" => "/about/media.php",
        "G_VIDEO_CACHE_TYPE" => "A",
        "G_VIDEO_CACHE_TIME" => "3600",
        "GU_VIDEO_TITLE_STD" => "",
        "GU_BIG_BANNER_TITLE_STD" => "",
        "GU_GOOGLE_GADGETS_TITLE_STD" => "",
        "GU_CITY_MENU_TITLE_STD" => "",
        "GU_SONET_USER_GROUPS_TITLE_STD" => "",
        "GU_SONET_USER_GROUPS_GROUPS_COUNT" => "10",
        "GU_DEMO_TITLE_STD" => "",
        "GU_SONET_USER_FRIENDS_TITLE_STD" => "",
        "GU_SONET_USER_ACTIVITY_TITLE_STD" => "",
        "GU_SONET_USER_ACTIVITY_LOG_DATE_DAYS" => "7",
        "GU_SONET_USER_ACTIVITY_LOG_CNT" => "7",
        "GU_UPDATES_ENTITY_TITLE_STD" => "",
        "GU_UPDATES_ENTITY_LOG_DATE_DAYS" => "7",
        "GU_UPDATES_ENTITY_LOG_CNT" => "7",
        "GU_CITIZEN_MENU_TITLE_STD" => "",
        "GU_HTML_AREA_TITLE_STD" => "",
        "GU_FAVORITES_TITLE_STD" => "",
        "GU_BITRIXCLOUD_MONITORING_TITLE_STD" => "",
        "GU_MESSAGETSLIST_TITLE_STD" => "",
        "GU_PROJECTSLIST_TITLE_STD" => "",
        "GU_SONET_GROUP_MODS_TITLE_STD" => "",
        "GU_ADMIN_CHECKLIST_TITLE_STD" => "",
        "GU_ADMIN_PERFMON_TITLE_STD" => "",
        "GU_NEWSLIST_TITLE_STD" => "",
        "GU_GOS_INFORMERS_TITLE_STD" => "",
        "GU_ADMIN_INFO_TITLE_STD" => "",
        "GU_SONET_GROUP_DESC_TITLE_STD" => "",
        "GU_SONET_USER_DESC_TITLE_STD" => "",
        "GU_VOTE_TITLE_STD" => "",
        "GU_OFFICIAL_MENU_TITLE_STD" => "",
        "G_HEAD_CACHE_TIME" => "3600",
        "G_HEAD_SHOW_URL" => "N",
        "GU_HEAD_TITLE_STD" => "",
        "GU_USER_MENU_TITLE_STD" => "",
        "GU_ADMIN_SECURITY_TITLE_STD" => "",
        "G_PROBKI_CACHE_TIME" => "3600",
        "G_PROBKI_SHOW_URL" => "N",
        "GU_PROBKI_TITLE_STD" => "",
        "GU_PROBKI_CITY" => "c213",
        "G_WEATHER_CACHE_TIME" => "3600",
        "G_WEATHER_SHOW_URL" => "N",
        "GU_WEATHER_TITLE_STD" => "",
        "GU_WEATHER_CITY" => "c22",
        "GU_EVENTSLIST_TITLE_STD" => "",
        "GU_ADMIN_STAT_TITLE_STD" => "",
        "GU_ADMIN_STAT_HIDE_GRAPH" => "N",
        "GU_ADMIN_STAT_GRAPH_PARAMS" => array("HOST","SESSION","EVENT","GUEST"),
        "GU_ADMIN_STAT_GRAPH_DAYS" => "30",
        "GU_ADMIN_STAT_GRAPH_WIDTH" => "400",
        "GU_ADMIN_STAT_GRAPH_HEIGHT" => "300",
        "GU_SONET_GROUP_TAGS_TITLE_STD" => "",
        "GU_SONET_USER_TAGS_TITLE_STD" => "",
        "GU_SONET_USER_LINKS_TITLE_STD" => "",
        "GU_SONET_GROUP_LINKS_TITLE_STD" => "",
        "GU_SONET_GROUP_USERS_TITLE_STD" => "",
        "GU_SONET_FORUM_TITLE_STD" => "",
        "GU_SONET_FORUM_TOPICS_COUNT" => "3",
        "GU_GALLERY_TITLE_STD" => "",
        "GU_ADMIN_IBLOCK_ELEMENTS_TITLE_STD" => "",
        "GU_ADMIN_IBLOCK_ELEMENTS_SORT_BY" => "ID",
        "GU_ADMIN_IBLOCK_ELEMENTS_SORT_ORDER" => "DESC",
        "GU_ADMIN_IBLOCK_ELEMENTS_TITLE_FIELD" => "NAME",
        "GU_ADMIN_IBLOCK_ELEMENTS_DATE_FIELD" => "DATE_ACTIVE_FROM",
        "GU_ADMIN_IBLOCK_ELEMENTS_PICTURE_FIELD" => "PREVIEW_PICTURE",
        "GU_ADMIN_IBLOCK_ELEMENTS_DESCRIPTION_FIELD" => "PREVIEW_TEXT",
        "GU_ADMIN_IBLOCK_ELEMENTS_DESCRIPTION_CUT" => "500",
        "GU_ADMIN_IBLOCK_ELEMENTS_ADDITIONAL_FIELDS" => array(),
        "GU_ADMIN_IBLOCK_ELEMENTS_THUMBNAIL_SIZE" => "100",
        "GU_ADMIN_IBLOCK_ELEMENTS_ITEMS_COUNT" => "10",
        "GU_GOS_SONET_USER_LINKS_TITLE_STD" => "",
        "GU_GOS_SONET_USER_LINKS_GOS_SITE_IMG" => "500"
    )
);?>


Список обращений граждан

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для государственных организаций>Официальный сайт государственной организации>Компоненты>Список обращений граждан

Компоненты::Список обращений граждан

Описание gosportal:support.ticket.list

Компонент предназначен для вывода формы фильтра и списка обращений в техподдержку. Компонент разработан для решения Официальный сайт государственной организации. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен в разделе: Гос. сайт.

Параметры

Поле | Параметр | Описание
Шаблоны ссылок
Страница редактирования обращения | TICKET_EDIT_TEMPLATE | Указывается адрес страницы редактирования выбранного обращения.
Дополнительные настройки
Количество обращений на одной странице | MESSAGES_PER_PAGE | Указывается количество обращений, отображаемых на одной странице.
Устанавливать заголовок страницы | SET_PAGE_TITLE | При выборе значения Да в качестве заголовка будет установлено Список обращений. В противном случае (значение Нет) заголовок установлен не будет. По умолчанию - Да.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "gosportal:support.ticket.list",
    "",
    Array(
        "SET_PAGE_TITLE" => "Y",
        "TICKETS_PER_PAGE" => "50",
        "TICKET_EDIT_TEMPLATE" => "ticket_edit.php?ID=#ID#"
    )
);?>


Список сотрудников

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для государственных организаций>Официальный сайт государственной организации>Компоненты>Список сотрудников

Компоненты::Список сотрудников

Описание structure.list

Компонент выводит список сотрудников, удовлетворяющих внешнему фильтру. Компонент разработан для решения Официальный сайт государственной организации. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Оргструктура.

Параметры

Поле | Параметр | Описание
Параметры фильтра
Имя фильтра | FILTER_NAME | Указывается имя фильтра.
Основные параметры
Выводить только синхронизируемых с 1С пользователей | FILTER_1C_USERS | [Y|N] При отмеченной опции будут выводиться только синхронизируемые с 1С пользователи.
Фильтр по подразделениям FILTER_SECTION_CURONLY Указывается тип фильтра по подразделениям:
  • прямой (Y);
  • рекурсивный (N).
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Выводить уведомление при пустом списке | SHOW_ERROR_ON_NULL | [Y|N] При отмеченной опции будет выводиться уведомление при пустом списке.
Количество пользователей на страницу | USERS_PER_PAGE | Поле определяет количество пользователей, отображаемых на одной странице. Весь список будет отображен с помощью постраничной навигации.
Подпись постраничной навигации | NAV_TITLE | Указывается подпись для постраничной навигации.
Показывать постраничную навигацию над списком | SHOW_NAV_TOP | [Y|N] При отмеченной опции постраничная навигация будет показываться над списком.
Показывать постраничную навигацию под списком | SHOW_NAV_BOTTOM | [Y|N] При отмеченной опции постраничная навигация будет показываться под списком.
Показывать список при пустом фильтре | SHOW_UNFILTERED_LIST | [Y|N] Если условия поиска не заданы, то при отмеченной опции будет выведен весь список сотрудников.
Страница детального просмотра | DETAIL_URL | Указывается путь к странице детального просмотра.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
"gosportal:structure.list",
    "",
    Array(
        "FILTER_NAME" => "users",
        "FILTER_1C_USERS" => "Y",
        "FILTER_SECTION_CURONLY" => "N",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_ERROR_ON_NULL" => "Y",
        "USERS_PER_PAGE" => "10",
        "NAV_TITLE" => "Сотрудники",
        "SHOW_NAV_TOP" => "Y",
        "SHOW_NAV_BOTTOM" => "Y",
        "SHOW_UNFILTERED_LIST" => "Y",
        "DETAIL_URL" => "/messages/form/#USER_ID#/",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Структура организации

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для государственных организаций>Официальный сайт государственной организации>Компоненты>Структура организации

Компоненты::Структура организации

Описание gosportal:gos_site.organiztion_structure

Компонент выводит визуальное представление структуры организации. Компонент разработан для решения Официальный сайт государственной организации. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен в разделе: Гос. сайт.

Параметры

Поле | Параметр | Описание
Дополнительно
Страница пользователя | EC_URL | Указывается шаблон пути к странице пользователя.
Дополнительные поля для вывода | USER_PROPERTY | С помощью клавиши Ctrl выберите дополнительные поля для вывода.
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будут выведены даты элементов.
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции для каждого элемента будет выведено его название.
Выводить изображение для анонса | DISPLAY_PICTURE | [Y|N] При отмеченной опции будут выведены изображения для элемента, если они заданы.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Указывается тип информационного блока (используется только для проверки).
Код информационного блока структуры | STRUCTURE_IBLOCK_ID | Указывается код информационного блока структуры.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленной опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".

Пример вызова

 IncludeComponent(
    "gosportal:gos_site.organiztion_structure",
    "",
    Array(
        "AJAX_MODE" => "N",
        "AJAX_OPTION_ADDITIONAL" => "",
        "AJAX_OPTION_HISTORY" => "N",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "DISPLAY_DATE" => "Y",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "EC_URL" => "#SITE_DIR#rukovodstvo/user/#USER_ID#/",
        "IBLOCK_TYPE" => "news",
        "STRUCTURE_IBLOCK_ID" => $_REQUEST["ID"],
        "USER_PROPERTY" => array("ID", "LOGIN")
    )
);?>
);?>


Решения для здравоохранения

Решения:

  • Портал органа управления здравоохранением
  • Сайт медицинской организации


Медицинский портал

В данном решении [image] реализованы: каталог и сайты подведомственных ЛПУ, онлайн-регистратура, личный кабинет пациента, сервис «обращение-ответ», интеграция с МИС, версия для инфоматов.

Для создания решения используется два продукта: «1С-Битрикс: Управление сайтом» [image] (система управления веб-проектами) и «1С-Битрикс: Сайт медицинской организации» [image] (готовое решение для создания медицинского сайта, которое содержит готовую структуру: разделы, сервисы (в составе продукта более 30 модулей) и демонстрационное наполнение.


Сайт медицинской организации

Данное решение [image] в базовом варианте реализовано в редакции 1С-Битрикс: Управление сайтом "Старт". В расширенном - в редакции "Эксперт".


Сайт медицинской организации. Настройки модуля

Закладки

Форма настроек модуля 1С-Битрикс: Сайт медицинской организации (Настройки > Настройки продукта > Настройки модулей > 1С-Битрикс: Сайт медицинской организации) предназначена для задания общесистемных параметров модуля. Для удобства работы форма разделена на закладки, на каждой из которых выполняется настройка определённой группы параметров модуля.

Настройки

Поле | Описание
Общие настройки
Включить обмен данными с МИС | Опция включает основной механизм интеграции с МИС. Установка опции открывает доступ к административному меню "Интеграция с МИС (Администрирование > Рабочий стол > Настройки > Интеграция c МИС), где можно как запустить процесс обмена данными через веб-сервис, так и сделать импорт/экспорт данных в ручном режиме, через файлы.
Папка выгрузки данных для МИС | Папка, куда будет выгружен архив с необходимыми данными при использовании экспорта в ручном режиме. Папка указывается относительно корневого раздела сайта.
Папка загрузки данных от МИС | Папка, откуда будут браться данные при использовании импорта в ручном режиме, если они не загружаются вручную. Папка указывается относительно корневого раздела сайта.
Папка мобильной версии | Папка публичной части мобильной версии, куда будет автоматически перенеправлен вызов при открытии сайта с телефона. Путь должен быть от корня сайта. Если путь пустой, то перенаправления не будет.
Папка мобильного приложения | Папка публичной части мобильного приложения. Внутри этой папки не сработает редирект на мобильную версию. Путь должен быть от корня сайта.
Не менять регистр символов | По умолчанию при импорте услуг и классификатора услуг регистр символов в названии переводится в нижний регистр с заглавной первой группой. Сохраняются только некоторые принятые сокращения. Например, "УЗИ МОЧЕВОГО ПУЗЫРЯ" будет преобразовано в "УЗИ мочевого пузыря". Если вам не нужно преобразование, включите эту опцию.
Использовть email в качестве логина при регистрации | Позволяет использовть email в качестве логина при регистрации.
Настройки работы с внешним веб-сервисом
Включить автоматический обмен данными с МИС | Опция включает автоматический обмен данными с МИС через веб-сервис. Пример: отправка информации о новых заявках на запись на прием.
Адрес wsdl файла веб-сервиса | Полный адрес wsdl файла веб-сервиса. Например, для веб-сервиса 1С:Поликлиники этот адрес может быть таким: http://127.0.0.1/1CBase/ws/MedML/?wsdl. 127.0.0.1 - адрес сервера, может быть так же доменным именем. 1CBase - параметр base в .vrd файле выгрузки веб-сервиса в 1С. (base="/1CBase"). ws - промежуточный тег, внутри которого в файле выгрузки находится точка доступа к веб-сервису. MedML - название точки доступа (<point name="MedML" alias="wsMedML.1cws"/>). ?wsdl - указание, что запрашивается именно wsdl файл. Для проверки адреса можно ввести его в браузере. Если адрес верный, то появится окно авторизации, а после ввода имени и пароля - текст wsdl файла (обычный xml документ).
Логин для веб-сервиса | Имя пользователя веб-сервиса. Заполняется, если на веб-сервисе используется авторизация.
Пароль для веб-сервиса | Заполняется, если на веб-сервисе используется авторизация.
Максимальное время ожидания ответа от сервиса (сек.) | Устанавливает максимальное время ожидания ответа от сервиса в секундах. Не может быть меньше 30 секунд. Если при импорте вы получаете ошибку вида "HTTP Error: socket read of headers timed out", попробуйте увеличить это значение.
Адрес сайта для асинхронной работы импорта (без http://) | Устанавливает адрес сайта, к которому будут делаться асинхронные обращения при запуске импорта данных. Это может быть как доменное имя вашего сайта, так и IP адрес. Если поле пустое, то асинхроные вызовы не используются.
Загружать талоны с периодичностью (сек.) | Устанавливает периодичность фоновой загрузки изменений по талонам с веб-сервиса в секундах. Если установлено 0, выключен автоматический обмен данными или не настроен адрес для асинхронных вызовов - обновления не загружаются. По умолчанию запрос обновлений выключен.
Загружать все обновления с периодичностью (мин.) | Устанавливает периодичность фоновой загрузки обновленных данных с веб-сервиса в минутах. Загружаются обновления следующих объектов: организации, подразлеления, сотрудники, услуги, расписания, прайс-листы. Если установлено 0, выключен автоматический обмен данными или не настроен адрес для асинхронных вызовов - обновления не загружаются. По умолчанию запрос обновлений выключен.
Метод обработки данных | Задает имя метода для обработки данных, переданных от сайта к МИС.
Параметр метода обработки данных | Задает название параметра, требуемого методом обработки данных, переданных от сайта к МИС.
Метод получения данных | Задает имя метода для получения данных от МИС.
Параметр метода получения данных | Задает название параметра, требуемого методом получения данных от МИС.
Настройки внутреннего веб-сервиса
Логин для веб-сервиса | Имя пользователя для подключения МИС к веб-сервису сайта. При включенном режиме обмена данными с МИС это поле должно быть заполнено.
Пароль для веб-сервиса | Изменене пароля для подключения МИС к веб-сервису сайта. Если вы ранее не устанавливали пароль, то при включенном обмене с МИС заполнение этого поля ОБЯЗАТЕЛЬНО. Пароль должен быть не менее 6 символов.

Электронная регистратура

Поле | Описание
Заблокировать запись на текущий день | При отмеченной опции запись клиентов на текущий день будет невозможна.
Автоматическое подтверждение записи | Автоматически подтверждает запись на прием (минуя статус "в обработке"). Опция работает если не настроен автоматический обмен талонами с МИС.
Хранить старые данные (в неделях) | Указывает сколько недель хранить старые данные расписания и талонов. Данные удаляются неделями. Например, если сейчас 19 число (вторник), то очищаться будут все данные старше 4 числа (понедельник) текущего месяца.
Почтовое событие уведомления о записи по талону | Код почтового события для уведомления пациента об успешной записи по талону.
Почтовое событие уведомления о записи на желаемое время | Код почтового события для уведомления пациента об успешной записи на желаемое время.

Работа с пациентами

Поле | Описание
Сервис обращений
Количество дней ответа на обращение, прежде чем оно будет просрочено | Указывается число дней ответа на обращение, по истечению которых обращение получит статус просроченного.
Тип инфоблока обращений пациентов | Выбирается тип инфоблока обращений пациентов.
Количество дней обращения модуля | Указывается количество дней обращения модуля.
Тип инфоблока обращений пациентов | Выбирается тип инфоблока обращений пациентов.
ID инфоблока обращений пациентов | Выбирается инфоблок обращений пациентов.
Свойство EMAIL пользователя | Выбирается свойство, содержащее email пользователя.
Свойство статуса обращения | Выбирается свойство, содержащее статус обращения.
Сервис обращений
Поля В полях прописывается текст уведомлений. Соответствующий текст будет отправлен пациенту в качестве комментария о причине отмены талона в автоматическом уведомлении при смене расписания. Если поле комментария пустое, то будет отправлен стандартный текст.

Поля:

  • Врач уходит в отпуск
  • Врач на больничном
  • Врач в командировке
  • Другие непредвиденные обстоятельства
Уведомления перед началом приема (пациенту)
Включить уведомления | При отмеченной опции пациент будет получать уведомления..
Уведомлять за (в минутах) | Прописывается число минут до начала приема.
Видеозвонки
Уведомлять за (в минутах) | Прописывается число минут до начала приема.
Почтовое событие напоминания перед видеозвонком | Указывается название почтового события [image] [image] напоминания перед видеозвонком.
Почтовое событие напоминания о начале видеозвонка | Указывается название почтового события [image] [image] напоминания о начале видеозвонка.
Настройки почтовой рассылки расписания на текущий день
Имя почтового события | Название почтового события, через которое производится рассылка.
Дата и время первого запуска автоматической рассылки | Автоматическая рассылка расписания на текущий день производится каждые 24 часа, начиная со времени первого запуска. Если поле пустое - автоматическая рассылка отключена.

Модуль карты

Поле | Описание
Включить автоматическое геокодирование | При отмеченной опции геокодирование будет проводиться автоматически.
Тип инфоблока МО_Организации | Выбирается тип инфоблока МО_Организации.
Инфоблок организаций | Выбирается тип инфоблока организаций, для которого далее выбираются Адрес, Широта и Долгота.
Инфоблок подразделений | Выбирается тип инфоблока подразделений, для которого далее выбираются Адрес, Широта и Долгота.

Доступ

Закладка позволяет настроить права на доступ к модулю Интернет-магазин для всех имеющихся в системе групп пользователей.

Поле | Описание
По умолчанию | Уровень доступа групп пользователей, для которых установлено право "по умолчанию".
[группа_пользователей] Изменение настроек доступа для конкретной группы. Возможно назначение следующих прав доступа к модулю Интернет-магазин:
  • [D] закрыт - запрет на доступ;
  • [P] Привязка к компании - доступ к обработке заказов, оплат, отгрузок, предназначенных для определённой компании;
  • [U] обработка заказов - доступ к обработке заказов, поступающих от покупателей;
  • [W] полный доступ - право на полный доступ к управлению модулем, в том числе на обработку заказов и управление правами доступа других групп пользователей.

Отладка

Закладка позволяет настроить права на доступ к модулю Интернет-магазин для всех имеющихся в системе групп пользователей.

Поле | Описание
Отладка обмена с МИС
Логирование запросов | При отмеченной опции будут сохраняться логи запросов. Все запросы сохраняются в папке /upload/medml/debug/: В папке INNER_SERVICE сохраняются xml файлы, приходящие на внутренний веб-сервис. В папке NUSOAP_MESSAGE_OUT сохраняются запросы к веб-сервису МИС. В папке NUSOAP_MESSAGE_IN сохраняются ответы веб-сервиса МИС. В папке SERVICE_ERRORS сохраняются ошибки обмена МИС.
Отладка электронной регистратуры
Сохранять данные о ходе записи пациентов | При отмеченной опции будут сохраняться данные о ходе записи пациентов. Вся информация сохраняется в /upload/medml/debug/reception/#ID врача#/#дата и время записи#/#ID услуги#.txt Предназначено в основном для определения сценариев двойной записи к одному врачу на одно и то же время.


Компоненты

  • Визуальная структура компании
  • Всплывающее облако
  • Запись на прием
  • Запись через инфомат
  • Заполнение карточки пациента
  • Информация о специалисте
  • Лента
  • Обновление CAPTCHA
  • Онлайн-консультации
  • Поиск сотрудника
  • Пользовательское соглашение
  • Просмотр результата
  • Разделы с top'ом элементов
  • Редактирование результата
  • Редактор пользовательских полей
  • Редактор расписаний
  • Сегодня работают
  • Сетка расписания
  • Специалисты
  • Список результатов
  • Список сотрудников
  • Структура компании
  • Структура разделов
  • Талоны пациента
  • Управление структурой организации
  • Управление талонами
  • Фильтр по элементам
  • Фильтр сервиса обращений
  • Форма добавления / редактирования обращения
  • Форма добавления / редактирования раздела
  • Форма добавления / редактирования элемента
  • Форма поиска


Визуальная структура компании

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Визуальная структура компании

Компоненты::Визуальная структура компании

Описание medsite.structure.visual

Компонент выводит визуальное представление древовидной структуры компании. Компонент разработан для решения Cайт медицинской организации. Компонент является стандартным и входит в дистрибутив модуля.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент находится в Мед.сайт > Оргструктура > Визуальная структура компании.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Указывается тип информационного блока (используется только для проверки).
Код информационного блока | IBLOCK_ID | Указывается код информационного блока.
Максимальная глубина выборки | MAX_DEPTH | Указывается максимальная глубина дерева.

Пример вызова

 IncludeComponent(
    "medsite:medsite.structure.visual",
    "",
    Array(
        "IBLOCK_ID" => $_REQUEST["ID"],
        "IBLOCK_TYPE" => "news",
        "MAX_DEPTH" => "2"
    )
);?>


Всплывающее облако

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Всплывающее облако

Компоненты::Всплывающее облако

Описание medsite:popup_message

Выводит всплывающее окно с информацией. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Разное > Всплывающее облако.

Параметры

Поле | Параметр | Описание
Основные параметры
Текст сообщения | TEXT | Прописывается текст, который будет выводиться во всплывающем облаке.
Ссылка | LINK | Прописывается ссылка, по которой будет происходить переход при клике на облако.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:popup_message",
    "",
    Array(
        "LINK" => "",
        "TEXT" => ""
    )
);?>


Запись на прием

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Запись на прием

Компоненты::Запись на прием

Описание medsite:record

Последний и актуальный компонент мастера записи на прием. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Запись на прием > Новый мастер записи.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока услуг | SERVICE_IBLOCK_TYPE | Тип инфоблока услуг.
Инфоблок услуг | IBLOCK_ID | ID инфоблока услуг.
Тип информационного блока организаций | ORG_IBLOCK_TYPE | Тип инфоблоков с данными об организациях.
Инфоблок списка организаций | ORG_IB_ID | ID инфоблока организаций.
Инфоблок специальностей | SPEC_IB_ID | ID инфоблока специальностей.
Инфоблок подразделений | DEPARTMENT_IB_ID | ID инфоблока подразделений.
Инфоблок врачебных участков | SECTOR_IB_ID | ID инфоблока врачебных участков.
Инфоблок кабинетов | PLACEMENT_IB_ID | ID инфоблока кабинетов.
С какого времени в понедельник открывать новую неделю (чч:мм) | NEW_WEEK_SHOW_TIME | Время начала показа записи на новую неделю в понедельник. Используется, если по организационным требованиям клиники необходимо открывать запись в определенное время (например, в 8:00). Если не заполнено – запись на новую неделю станет доступна сразу после полуночи.
Согласие пользователя
Запрашивать согласие | USER_CONSENT | [Y|N] Установленный флажок включает механизм согласия пользователя.
Соглашение | USER_CONSENT_ID | Задается текст соглашения, которое отображается пользователю при заказе.
Галка по умолчанию проставлена | USER_CONSENT_IS_CHECKED | Установка галочки автомаитчески устанавливает галочку в чекбоксе согласия пользователя. То есть согласие применяется одновременно с нажатием кнопки Оформить заказ.
Загружать текст сразу | USER_CONSENT_IS_LOADED | Текст соглашения будет выводиться сразу. Если флажок не установлен, для просмотра текст нужно будет кликнуть по кнопке согласия.
Дополнительные настройки
Показывать шаг выбора организации | ORG_STEP_SHOW | [Y|N] При отмеченной опции запись начнется с шага выбора организации.
Ссылка на страницу помощи по мастеру записи | WIZ_HELP_LINK | Ссылка на статическую информацию с инструкцией по записи на прием.
Количество отображаемых недель (кроме текущей) | WEEK_LEAF | Количество недель для вывода, кроме текущей недели.
Группы пользователей, имеющие право перезаписи талонов | GROUPS | Выбираются группы пользователей, имеющие право на перезапись талонов.
Группа врачей | EMPLOYES_GROUP | Группа пользователей, к которым будет осуществляться запись на прием.
Группа регистратуры | RECEPTION_GROUP | Группа сотрудников регистратуры.
Маска ввода номера телефона. Символ "9" значит место для цифры | PHONE_MASK | Маска телефона для проверки корректности ввода номера телефона на шаге ввода данных о пациенте.
Показать вкладку записи через специальность | SHOW_SPECIALITY_SELECTION | [Y|N] При отмеченной опции на этапе выбора специальности/врача/услуги будет отображаться вкладка выбора специальности.
Показать вкладку записи через услугу | SHOW_SERVICE_SELECTION | [Y|N] При отмеченной опции на этапе выбора специальности/врача/услуги будет отображаться вкладка выбора услуги.
Личная страница сотрудника | EMPLOYEE_PERSONAL_PAGE | Ссылка на личную страницу сотрудника.
Цены (только для БУС редакции «Бизнес»)
Тип цены | PRICE_CODE | Используемый для вывода тип цены.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции НДС будет включаться в выводимую цену.
Ссылка на корзину | BASKET_URL | Ссылка на раздел корзины.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:record",
    "",
    Array(
        "BASKET_URL" => "Y",
        "DEPARTMENTS_IB_ID" => $_REQUEST["ID"],
        "EMPLOYES_GROUP" => array(),
        "GROUPS" => array(),
        "IBLOCK_ID" => $_REQUEST["ID"],
        "NEW_WEEK_SHOW_TIME" => "08:00",
        "ORG_IBLOCK_TYPE" => "news",
        "ORG_IB_ID" => $_REQUEST["ID"],
        "ORG_STEP_SHOW" => "N",
        "PHONE_MASK" => "8 (999) 999-99-99",
        "PLACEMENT_IB_ID" => $_REQUEST["ID"],
        "PRICE_CODE" => array(),
        "PRICE_VAT_INCLUDE" => "Y",
        "RECEPTION_GROUP" => array(),
        "SECTOR_IB_ID" => $_REQUEST["ID"],
        "SERVICE_IBLOCK_TYPE" => "news",
        "SHOW_SERVICE_SELECTION" => "Y",
        "SHOW_SPECIALITY_SELECTION" => "Y",
        "SPEC_IB_ID" => $_REQUEST["ID"],
        "USER_CONSENT" => "N",
        "USER_CONSENT_ID" => "0",
        "USER_CONSENT_IS_CHECKED" => "Y",
        "USER_CONSENT_IS_LOADED" => "N",
        "WEEK_LEAF" => "2",
        "WIZ_HELP_LINK" => "record_wizard_help.php"
    )
);?>


Запись через инфомат

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Запись через инфомат

Компоненты::Запись через инфомат

Описание medsite:record.infomat.ajax

Компонент предназначен для организации записи на прием через информационные киоски. Он может быть использован только вместе со специально разработанным шаблоном дизайна сайта. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Запись на прием > Запись через инфомат.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока услуг | SERVICE_IBLOCK_TYPE | Тип инфоблока услуг.
Инфоблок услуг | IBLOCK_ID | ID инфоблока услуг.
Тип информационного блока организаций | ORG_IBLOCK_TYPE | Тип инфоблока организаций.
Инфоблок списка организаций | ORG_IB_ID | ID инфоблока организаций.
Адрес организации | ORG_ADDRESS | ID свойства с адресом организации.
Широта | ORG_LAT | ID свойства с широтой.
Долгота | ORG_LON | ID свойства с долготой.
Путь на транспорте к организации | ORG_TRANSPORT | ID свойства описания проезда на общественном транспорте.
Инфоблок специальностей | SPEC_IB_ID | ID инфоблока специальностей.
Инфоблок подразделений | DEPARTMENT_IB_ID | ID инфоблока подразделений.
Поля, обязательные для заполнения | REQUIRED_PROPERTIES | Массив кодов обязательных для заполнения свойств карточки пациента.
Дополнительные настройки
Показывать шаг выбора организации | ORG_STEP_SHOW | [Y|N] При отмеченной опции запись начнется с шага выбора организации.
Показать вкладку записи через специальность | SHOW_SPECIALITY_SELECTION | [Y|N] При отмеченной опции на этапе выбора специальности/врача/услуги будет отображаться вкладка выбора специальности.
Показать вкладку записи через услугу | SHOW_SERVICE_SELECTION | [Y|N] При отмеченной опции на этапе выбора специальности/врача/услуги будет отображаться вкладка выбора услуги.
Ссылка на главное меню инфомата | MAIN_PAGE_LINK | Ссылка возврата к главному меню инфомата.
Количество отображаемых недель (кроме текущей) | WEEK_LEAF | Количество недель для вывода расписания, кроме текущей недели.
Маска ввода номера телефона. Символ "9" значит место для цифры | PHONE_MASK | Маска телефона для проверки корректности ввода номера телефона на шаге ввода данных о пациенте.
Цены (только для БУС редакции «Бизнес»)
Тип цены | PRICE_CODE | Используемый для вывода тип цены.
Включать НДС в цену | PRICE_VAT_INCLUDE | [Y|N] При отмеченной опции НДС будет включаться в выводимую цену.
Ссылка на корзину | BASKET_URL | Ссылка на раздел корзины.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:record.infomat.ajax",
    "",
    Array(
        "BASKET_URL" => "Y",
        "DEPARTMENTS_IB_ID" => $_REQUEST["ID"],
        "IBLOCK_ID" => $_REQUEST["ID"],
        "MAIN_PAGE_LINK" => "/infomat/",
        "ORG_ADDRESS" => "",
        "ORG_IBLOCK_TYPE" => "news",
        "ORG_IB_ID" => $_REQUEST["ID"],
        "ORG_LAT" => "",
        "ORG_LON" => "",
        "ORG_STEP_SHOW" => "N",
        "ORG_TRANSPORT" => "",
        "PHONE_MASK" => "8 (999) 999-99-99",
        "PRICE_CODE" => array(),
        "PRICE_VAT_INCLUDE" => "Y",
        "REQUIRED_PROPERTIES" => array(),
        "SERVICE_IBLOCK_TYPE" => "news",
        "SHOW_SERVICE_SELECTION" => "Y",
        "SHOW_SPECIALITY_SELECTION" => "Y",
        "SPEC_IB_ID" => $_REQUEST["ID"],
        "WEEK_LEAF" => "2"
    )
);?>


Заполнение карточки пациента

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Заполнение карточки пациента

Компоненты::Заполнение карточки пациента

Описание medsite:record.userinfo.edit

Компонент для заполнения карточки клиента (используется с новым мастером записи на прием). Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Запись на прием > Заполнение карточки пациента.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCKS | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
Количество новостей на странице | NEWS_COUNT | Указывается количество новостей, отображаемых на одной странице.
Поле для первой сортировки новостей SORT_BY1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для первой сортировки новостей.
Направление для первой сортировки новостей SORT_ORDER1 Задается направление для первой сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки новостей SORT_BY2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для второй сортировки новостей.
Направление для второй сортировки новостей SORT_ORDER2 Задается направление для второй сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Фильтр | FILTER_NAME | Указывается имя фильтра.
Поля FIELD_CODE Данные элемента, которые могут выводиться в ленте новостей. (Требуется кастомизация шаблона.)
  • ID – ID;
  • CODE – символьный код;
  • XML_ID – XML_ID;
  • NAME – название;
  • TAGS – теги;
  • SORT – сортировка;
  • PREVIEW_TEXT – текст анонса;
  • PREVIEW_PICTURE – картинка анонса;
  • DETAIL_TEXT – детальный текст;
  • DETAIL_PICTURE – детальная картинка.
  • DATE_ACTIVE_FROM – начало активности (дата);
  • ACTIVE_FROM – начало активности (время);
  • DATE_ACTIVE_TO – окончание активности (дата);
  • ACTIVE_TO – окончание активности (время);
  • SHOW_COUNTER – количество показов;
  • SHOW_COUNTER_START – дата первого показа;
  • IBLOCK_TYPE_ID – тип информационного блока;
  • IBLOCK_ID – ID информационного блока;
  • IBLOCK_CODE – символьный код информационного блока;
  • IBLOCK_NAME – название информационного блока;
  • IBLOCK_EXTERNAL_ID – внешний код информационного блока;
  • DATE_CREATE – дата создания;
  • CREATED_BY – кем создан (ID);
  • CREATED_USER_NAME – дата изменения;
  • MODIFIED_BY – кем изменен (ID);
  • USER_NAME – кем изменен (имя).
Свойства | PROPERTY_CODE | Указывается код свойства пациента.
Показывать только активные на данный момент элементы | CHECK_DATES | [Y/N] При отмеченной опции будут показаны только активные элементы.
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Задается адрес, ведущий на страницу с детальной информацией элемента раздела (по умолчанию - из настроек инфоблока).
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленной опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение Y, то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Максимальная длина анонса для вывода (только для типа текст) | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода (только для типа текст). При превышении параметра остаток текста будет отсечен.
Формат показа даты | LIST_ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Устанавливать статус 404 | SET_STATUS_404 | [Y|N] Опция служит для включения обработки ошибки 404 в компоненте.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия или заголовки (если заданы в настройках SEO) разделов.
Скрывать ссылку, если нет детального описания | HIDE_LINK_WHEN_NO_DETAIL | [Y|N] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
ID раздела | PARENT_SECTION | Указывается числовой код раздела инфоблока, из которого будут выбраны новости. Поле может быть оставлено пустым, если указан Код раздела.
Код раздела | PARENT_SECTION_CODE | Указывается символьный код раздела инфоблока, из которого будут выбраны новости. Поле может быть оставлено пустым, если указан ID раздела.
Показывать элементы подразделов раздела | INCLUDE_SUBSECTIONS | [Y|N] При отмеченной опции будут отображены элементы подразделов раздела. Может иметь значение "A" (Active)
Группа регистратуры | RECEPTION_GROUP | Группа сотрудников регистратуры.
Настройки постраничной навигации
Шаблон постраничной навигации | PAGER_TEMPLATE | Указывается название шаблона постраничной навигации. Если поле пусто, то выбирается шаблон по умолчанию (.default).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение по элементам.
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться, даже если все элементы помещаются на одной странице.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц в секундах для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все элементы каталога.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:record.userinfo.edit",
    "",
    Array(
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "AJAX_MODE" => "N",
        "AJAX_OPTION_ADDITIONAL" => "",
        "AJAX_OPTION_HISTORY" => "N",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "CACHE_FILTER" => "N",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "36000000",
        "CACHE_TYPE" => "A",
        "CHECK_DATES" => "Y",
        "DETAIL_URL" => "",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "DISPLAY_TOP_PAGER" => "N",
        "FIELD_CODE" => array("", ""),
        "FILTER_NAME" => "",
        "HIDE_LINK_WHEN_NO_DETAIL" => "N",
        "IBLOCK_ID" => $_REQUEST["ID"],
        "IBLOCK_TYPE" => "news",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "INCLUDE_SUBSECTIONS" => "Y",
        "NEWS_COUNT" => "20",
        "PAGER_DESC_NUMBERING" => "N",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "N",
        "PAGER_SHOW_ALWAYS" => "N",
        "PAGER_TEMPLATE" => ".default",
        "PAGER_TITLE" => "Новости",
        "PARENT_SECTION" => "",
        "PARENT_SECTION_CODE" => "",
        "PREVIEW_TRUNCATE_LEN" => "",
        "PROPERTY_CODE" => array("", ""),
        "RECEPTION_GROUP" => array(),
        "SET_STATUS_404" => "N",
        "SET_TITLE" => "Y",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_BY2" => "SORT",
        "SORT_ORDER1" => "DESC",
        "SORT_ORDER2" => "ASC"
    )
);?>


Информация о специалисте

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Информация о специалисте

Компоненты::Информация о специалисте

Описание medsite:medsite.system.person

Компонент выводит информацию о специалисте клиники. Компонент разработан для решения Cайт медицинской организации. Компонент является стандартным и входит в дистрибутив модуля.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент находится в Мед.сайт > Оргструктура > Информация о специалисте.

Параметры

Название | Параметр | Описание
Основные настройки
Пользователь | USER | Параметр принимает ID, либо массив полей с данными о пользователе. В случае передачи ID будет сделан запрос к базе данных для получения информации о пользователе.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е. используется значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Тип информационного блока организаций | ORG_IBLOCK_TYPE | Тип инфоблоков с данными об организациях.
Инфоблок подразделений | DEPARTMENT_IB_ID | ID инфоблока подразделений.
Дополнительные настройки
Инфоблок услуг | IBLOCK_ID | ID инфоблока услуг.
Выбирать данные об организациях, в которых работает сотрудник | SHOW_COMPANIES | При отмеченной опции будет показаны данные об организациях, в которых работает указанный сотрудник.
Показать список услуг | SHOW_SERVICES | [Y|N] Показывает нужно ли выводить список услуг, оказываемых специалистом.
Ссылка на страницу с информацией о специалисте | USER_INFO_LINK | Ссылка на персональную страницу сотрудника, используется при выводе списка сотрудников.
Ссылка на расписание сотрудника | SCHEDULE_LINK | Ссылка на раздел записи на прием.
Вывести пользовательские свойства | USER_PROPERTY | Массив кодов выводимых свойств.
Шаблон заголовка страницы (если пустой - не устанавливается) | SET_TITLE_TEMPLATE | Устанавливается шаблон заголовка страницы.

Пример вызова

 IncludeComponent(
    "medsite:medsite.system.person",
    "",
    Array(
        "DEPARTMENTS_IB_ID" => $_REQUEST["ID"],
        "IBLOCK_ID" => $_REQUEST["ID"],
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "ORG_IBLOCK_TYPE" => "news",
        "SCHEDULE_LINK" => "",
        "SET_TITLE_TEMPLATE" => "",
        "SHOW_COMPANIES" => "N",
        "SHOW_SERVICES" => "N",
        "USER" => "",
        "USER_INFO_LINK" => "/employees/personal_info.php",
        "USER_PROPERTY" => array("FULL_NAME","EMAIL","PERSONAL_PHONE","WORK_POSITION")
    )
);?>


Лента

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Лента

Компоненты::Лента

Описание medsite:news.line

Одностраничный компонент, осуществляющий вывод списка статей и новостей с датой и заголовком со ссылкой на страницу с подробной информацией. Компонент является адаптацией стандартного компонента bitrix:news.line для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Разное > Лента.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCKS | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
Количество новостей на странице | NEWS_COUNT | Указывается количество новостей, отображаемых на одной странице.
Источник данных
Поля FIELD_CODE Данные элемента, которые могут выводиться в ленте новостей. (Требуется кастомизация шаблона.)
  • ID – ID;
  • CODE – символьный код;
  • XML_ID – XML_ID;
  • NAME – название;
  • TAGS – теги;
  • SORT – сортировка;
  • PREVIEW_TEXT – текст анонса;
  • PREVIEW_PICTURE – картинка анонса;
  • DETAIL_TEXT – детальный текст;
  • DETAIL_PICTURE – детальная картинка.
  • DATE_ACTIVE_FROM – начало активности (дата);
  • ACTIVE_FROM – начало активности (время);
  • DATE_ACTIVE_TO – окончание активности (дата);
  • ACTIVE_TO – окончание активности (время);
  • SHOW_COUNTER – количество показов;
  • SHOW_COUNTER_START – дата первого показа;
  • IBLOCK_TYPE_ID – тип информационного блока;
  • IBLOCK_ID – ID информационного блока;
  • IBLOCK_CODE – символьный код информационного блока;
  • IBLOCK_NAME – название информационного блока;
  • IBLOCK_EXTERNAL_ID – внешний код информационного блока;
  • DATE_CREATE – дата создания;
  • CREATED_BY – кем создан (ID);
  • CREATED_USER_NAME – дата изменения;
  • MODIFIED_BY – кем изменен (ID);
  • USER_NAME – кем изменен (имя).
Свойство ID пациента | PROPERTY_CODE | Указывается код свойства ID пациента
Поле для первой сортировки новостей SORT_BY1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для первой сортировки новостей.
Направление для первой сортировки новостей SORT_ORDER1 Задается направление для первой сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки новостей SORT_BY2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для второй сортировки новостей.
Направление для второй сортировки новостей SORT_ORDER2 Задается направление для второй сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Шаблоны ссылок
URL, ведущий на страницу с содержимым элемента раздела | DETAIL_URL | Задается адрес, ведущий на страницу с детальной информацией элемента раздела (по умолчанию - из настроек инфоблока).
Дополнительные настройки
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<?$APPLICATION->IncludeComponent(
"medsite:news.line",
    "",
    Array(
        "IBLOCK_TYPE" => "s1",
        "IBLOCKS" => array("4"),
        "NEWS_COUNT" => "20",
        "FIELD_CODE" => array(),
        "PROPERTY_CODE" => "",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "DETAIL_URL" => "",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "300",
        "CACHE_NOTES" => "",
        "CACHE_GROUPS" => "Y"
    )
);?>


Обновление CAPTCHA

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Обновление CAPTCHA

Компоненты::Обновление CAPTCHA

Описание medsite:captcha.reload

Компонент позволяет перегружать картинку CAPTCHA. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед. сайт > Разное > Обновление CAPTCHA.

Параметры

Поле | Параметр | Описание
Основные настройки
Использовать на всей странице (глобально) | USE_GLOBAL | [Y|N] При отмеченной опции компонент будет применяться ко всем формам на странице.
Имя формы с CAPTCHA | FORM_NAME | Указывается имя формы, к которой нужно применить компонент. Если установлен флаг "Использовать на всей странице", то этот параметр можно не заполнять.
Дополнительные настройки
Путь к картинке | IMAGE_DIALOG | Указывается путь к картинке с кнопкой вызова перезагрузки.
Путь к картинке | IMAGE_LOADING | Указывается путь к картинке анимации во время перезагрузки CAPTCHA.

Пример вызова

<?APPLICATION->IncludeComponent(
    "medsite:captcha.reload",
    "",
    Array(
        "COMPONENT_TEMPLATE" => ".default",
        "FORM_NAME" => array(""),
        "USE_GLOBAL" => "Y"
    )
);?>


Онлайн-консультации

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Онлайн-консультации

Компоненты::Онлайн-консультации

Описание medsite:videocall

Компонент является настройкой над стандартным компонентом bitrix: im.messenger. Компонент выводит панель уведомлений о записи на видеоконсультацию для авторизованных пользователей, а также осуществляет автоматическую привязку пациента и врача при начале приема для возможности видеозвонка. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации, установленного на редакцию БУС Бизнес. В визуальном редакторе компонент расположен по пути: Мед.сайт > Запись на прием > Онлайн-консультации.

Параметры у компонента отсутствуют.

Пример вызова

<?$APPLICATION->IncludeComponent(
"medsite:videocall",
 '',
array(
    ),
    false
);?>


Поиск сотрудника

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Поиск сотрудника

Компоненты::Поиск сотрудника

Описание medsite:medsite.search

Компонент выводит комплексную форму просмотра и поиска сотрудников. Компонент разработан для решения Сайт медицинской организации. Компонент является стандартным и входит в дистрибутив модуля.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент находится в Мед.сайт > Оргструктура > Поиск сотрудника.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Показывать пользователей из групп | GROUPS | С помощью клавиши Ctrl выбираются группы, пользователи из которых будут выводиться в результатах поиска.
Ссылка на страницу с информацией о специалисте | USER_INFO_LINK | Путь к странице с информацией о специалисте.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты без года | DATE_FORMAT_NO_YEAR | Указывается формат показа даты без года. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты и времени, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать год рождения SHOW_YEAR Поле определяет, кому показывать год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).
Представление по умолчанию DEFAULT_VIEW Указывается способ вывода результатов поиска по умолчанию:
  • список (list);
  • таблица (table).
Шаблон для представления в виде списка LIST_VIEW Указывается способ для представления в виде списка:
  • простой список (list);
  • с группировкой по отделам (group).

Если параметр принимает значение group, то необходимо настроить следущий параметр: USER_PROPERTY_GROUP.
Пользовательские поля для вывода в табличном представлении | USER_PROPERTY_TABLE | Указываются поля, которые должны быть отображены при выводе списка пользователей в табличном представлении.
Пользовательские поля для вывода в формате Excel | USER_PROPERTY_EXCEL | Указываются поля пользователей, которые должны быть выгружены при выполнении экспорта пользователей в MS Excel.
Сортировать пользователей по | USER_SORT | Выбирается поле для сортировки пользователей.
Тип сортировки SORT_TYPE Выбирается тип сортировки:
  • прямой;
  • обратный.
Пользовательские поля для вывода в представлении в виде списка | USER_PROPERTY_GROUP | С помощью клавиши Ctrl выбираются поля для вывода в виде списка.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленной опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение Y, то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Основные параметры
Тип инфоблока подразделений | IBLOCK_TYPE | Выбирается тип инфоблока подразделений.
Инфоблок подразделений | DEPARTMENT_BLOCK | Выбирается инфоблок подразделений.
Инфоблок специальностей | SPEC_IBLOCK_ID | Выбирается инфоблок специальностей.
Страница структуры компании | STRUCTURE_PAGE | Указывается путь к странице структуры компании.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается шаблон пути к странице подразделения компании.
Имя фильтра страницы структуры компании | STRUCTURE_FILTER | Указывается имя фильтра страницы структуры компании.
Выводить только синхронизируемых с 1С пользователей | FILTER_1C_USERS | [Y|N] При отмеченной опции будут выводиться только синхронизируемые с 1С пользователи.
Количество пользователей на страницу | USERS_PER_PAGE | Поле определяет количество пользователей, отображаемых на одной странице. Весь список будет отображен с помощью постраничной навигации.
Фильтр по подразделениям FILTER_SECTION_CURONLY Указывается тип фильтра по подразделениям:
  • прямой (Y);
  • рекурсивный (N).
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е. используется значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Выводить уведомление при пустом списке | SHOW_ERROR_ON_NULL | [Y|N] При отмеченной опции выводится уведомление при пустом списке.
Отображать фильтр по алфавиту на языках | ALPHABET_LANG | Задаются языки для показа фильтра по алфавиту.
Подпись постраничной навигации | NAV_TITLE | Поле содержит подпись для постраничной навигации.
Показывать постраничную навигацию над списком | SHOW_NAV_TOP | [Y|N] При отмеченной опции постраничная навигация будет показываться над списком.
Показывать постраничную навигацию под списком | SHOW_NAV_BOTTOM | [Y|N] При отмеченной опции постраничная навигация будет показываться под списком.
Показывать список при пустом фильтре | SHOW_UNFILTERED_LIST | [Y|N] При отмеченной опции будет выведен весь список сотрудников. Если опция не отмечена, то будет показана только форма поиска.
Параметры фильтра
Имя фильтра (для внешних форм фильтрации) | FILTER_NAME | Указывается имя фильтра (для внешних форм фильтрации).
Выбор подразделения для фильтрации FILTER_DEPARTMENT_SINGLE Указывается способ выбора подразделения(ий) в форме поиска:
  • одинарный (Y) - в выпадающем списке можно выбрать только одно подразделение;
  • множественный (N) - поле позволяет выбирать несколько подразделений.
Запоминать фильтр в сессии | FILTER_SESSION | [Y|N] При отмеченной опции значения, введенные в поля формы поиска, будут запоминаться системой.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:medsite.search",
    "",
    Array(
        "AJAX_MODE" => "N",
        "AJAX_OPTION_ADDITIONAL" => "",
        "AJAX_OPTION_HISTORY" => "N",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "ALPHABET_LANG" => array("ru",""),
        "CACHE_TIME" => "3600",
        "CACHE_TYPE" => "A",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_FORMAT_NO_YEAR" => "d.m",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "DEFAULT_VIEW" => "table",
        "DEPARTMENT_BLOCK" => "1",
        "FILTER_1C_USERS" => "N",
        "FILTER_DEPARTMENT_SINGLE" => "Y",
        "FILTER_NAME" => "users",
        "FILTER_SECTION_CURONLY" => "N",
        "FILTER_SESSION" => "Y",
        "GROUPS" => array(),
        "IBLOCK_TYPE" => "news",
        "LIST_VIEW" => "group",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "NAV_TITLE" => "Сотрудники",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&users_UF_DEPARTMENT=#ID#",
        "PM_URL" => "/company/personal/messages/chat/#USER_ID#/",
        "SHOW_ERROR_ON_NULL" => "Y",
        "SHOW_LOGIN" => "Y",
        "SHOW_NAV_BOTTOM" => "Y",
        "SHOW_NAV_TOP" => "Y",
        "SHOW_UNFILTERED_LIST" => "N",
        "SHOW_YEAR" => "Y",
        "SORT_TYPE" => "ASC",
        "SPEC_IBLOCK_ID" => "1",
        "STRUCTURE_FILTER" => "structure",
        "STRUCTURE_PAGE" => "structure.php",
        "USERS_PER_PAGE" => "20",
        "USER_INFO_LINK" => "/employees/personal_info.php",
        "USER_PROPERTY_EXCEL" => array("FULL_NAME","EMAIL","PERSONAL_PHONE","WORK_POSITION"),
        "USER_PROPERTY_GROUP" => array("EMAIL","PERSONAL_PHONE","PERSONAL_MOBILE","WORK_PHONE"),
        "USER_PROPERTY_TABLE" => array("FULL_NAME","EMAIL","PERSONAL_PHONE","WORK_POSITION"),
        "USER_SORT" => "WORK_POSITION"
    )
);?>


Пользовательское соглашение

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Пользовательское соглашение

Компоненты::Пользовательское соглашение

Описание medsite:userconsent.text

Выводит текст пользовательского соглашения об обработке персональных данных. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Разное > Пользовательское соглашение.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Соглашение | USER_CONSENT_ID | Выбирается текст соглашения, которое отображается пользователю при заказе.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:userconsent.text",
    "",
    Array(
        "ID" => "1"
    )
);?>


Просмотр результата

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Просмотр результата

Компоненты::Просмотр результата

Описание medsite:form.result.view

Компонент позволяет просмотреть результат заполнения веб-формы записи на госпитализацию. Компонент является модификацией стандартного компонента bitrix:form.result.view для решения Сайт медицинской организации. Компонент убран из модуля в следующих обновлениях после 5.0.4.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути Мед.сайт > Веб-формы > Просмотр результата.

Пример вызова

<?APPLICATION->IncludeComponent(
    "medsite:form.result.view",
    "",
    Array(
        "CHAIN_ITEM_LINK" => "",
        "CHAIN_ITEM_TEXT" => "",
        "EDIT_URL" => "result_edit.php",
        "RESULT_ID" => "5",
        "SEF_MODE" => "N",
        "SHOW_ADDITIONAL" => "N",
        "SHOW_ANSWER_VALUE" => "N",
        "SHOW_STATUS" => "Y"
    )
);?>


Разделы с top'ом элементов

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Разделы с top'ом элементов

Компоненты::Разделы с top'ом элементов

Описание medsite:medsite.catalog.sections.top

Компонент выводит top элементов, сгруппированных по разделам; элементы выводятся в таблице. Компонент является модификацией стандартного компонента bitrix:catalog.section.top для решения Сайт медицинской организации. Компонент убран из модуля в следующих обновлениях после 5.0.4.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути Мед.сайт > Разное > Разделы с top’ом элементов.

Пример вызова

<?APPLICATION->IncludeComponent(
    "medsite:medsite.catalog.sections.top",
    "",
    Array(
        "ACTION_VARIABLE" => "action",
        "BASKET_URL" => "/personal/basket.php",
        "CACHE_FILTER" => "N",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "3600",
        "CACHE_TYPE" => "A",
        "DETAIL_URL" => "",
        "DISPLAY_COMPARE" => "N",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_ORDER" => "asc",
        "FILTER_NAME" => "arrFilter",
        "IBLOCK_ID" => "10",
        "IBLOCK_TYPE" => "additional_info",
        "LINE_ELEMENT_COUNT" => "3",
        "PRICE_CODE" => array(),
        "PRICE_VAT_INCLUDE" => "Y",
        "PRODUCT_ID_VARIABLE" => "id",
        "PRODUCT_PROPERTIES" => array(),
        "PRODUCT_PROPS_VARIABLE" => "prop",
        "PRODUCT_QUANTITY_VARIABLE" => "quantity",
        "PROPERTY_CODE" => array("",""),
        "SECTION_ID_VARIABLE" => "SECTION_ID",
        "SECTION_SORT_FIELD" => "sort",
        "SECTION_SORT_ORDER" => "asc",
        "SECTION_URL" => "",
        "SHOW_PRICE_COUNT" => "1",
        "USE_PRICE_COUNT" => "N",
        "USE_PRODUCT_QUANTITY" => "N"
    )
);?>


Редактирование результата

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Редактирование результата

Компоненты::Редактирование результата

Описание medsite:form.result.edit

Компонент позволяет редактировать результат заполнения веб-формы записи на госпитализацию. Компонент является модификацией стандартного компонента bitrix:form.result.edit для решения Сайт медицинской организации. Компонент убран из модуля в следующих обновлениях после 5.0.4.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути Мед.сайт > Веб-формы > Редактирование результата.

Пример вызова

<?APPLICATION->IncludeComponent(
    "medsite:form.result.edit",
    "",
    Array(
        "CHAIN_ITEM_LINK" => "",
        "CHAIN_ITEM_TEXT" => "",
        "EDIT_ADDITIONAL" => "N",
        "EDIT_STATUS" => "Y",
        "IBLOCK_ID" => "9",
        "IBLOCK_TYPE" => "registry",
        "IGNORE_CUSTOM_TEMPLATE" => "N",
        "LIST_URL" => "result_list.php",
        "RESULT_ID" => $_REQUEST[RESULT_ID],
        "SEF_MODE" => "N",
        "USE_EXTENDED_ERRORS" => "N",
        "VIEW_URL" => "result_view.php"
    )
);?>


Редактор пользовательских полей

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Редактор пользовательских полей

Компоненты::Редактор пользовательских полей

Описание medsite:edit_user_fields

Компонент позволяет настроить список дополнительных полей, которые выводятся на шаге ввода данных о пациенте при записи на прием. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути Мед.сайт > Разное > Структура разделов.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:edit_user_fields",
    ".default",
    array(
        "COMPONENT_TEMPLATE" => ".default"
    ),
    false
);?>


Редактор расписаний

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Редактор расписаний

Компоненты::Редактор расписаний

Описание medsite:medsite.edit_calendar

Компонент предоставляет интерфейс редактирования расписания врачей. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути Мед. сайт > Запись на прием > Редактор расписаний.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Тип информационного блока услуг.
Код информационного блока услуг | IBLOCK_ID | ID информационного блока услуг.
Код информационного блока врачебных участков | SECT_IBLOCK_ID | ID информационного блока врачебных участков.
Код информационного блока помещений | BUILD_IBLOCK_ID | ID информационного блока помещений.
Код информационного блока организаций | ORGANIZTION_IBLOCK_ID | ID информационного блока организаций.
Код информационного блока структуры (подразделений) | STRUCTURE_IBLOCK_ID | ID информационного блока подразделений организаций.
Группы, которые могут просматривать/редактировать чужое расписание | EDIT_GROUPS | Устаревшее свойство, начиная с версии 5.0.3, будет удалено.
Выводить расписания для пользователей из групп | SHOW_FROM_GROUPS | Массив чисел. ID групп пользователей, расписание которых будет выводиться.
Дополнительные настройки
Начало рабочего дня | DAY_START | Начало рабочего дня в часах (например, 9).
Конец рабочего дня | DAY_END | Конец рабочего дня в часах (например, 19).
Шаг сетки календаря (в минутах, min 5) | WEB_STEP | Шаг сетки календаря в минутах. Минимальный шаг – 5 минут.
Показывать занятость времени | SHOW_BUSY | [Y|N] Если установлен – в периодах записи по талонам занятое время будет выделяться.

Пример вызова

<?APPLICATION->IncludeComponent(
    "medsite:medsite.edit_calendar",
    "",
    Array(
        "BUILD_IBLOCK_ID" => "6",
        "DAY_END" => "18",
        "DAY_START" => "9",
        "EDIT_GROUPS" => array("1","6"),
        "IBLOCK_ID" => "7",
        "IBLOCK_TYPE" => "medservices",
        "ORGANIZTION_IBLOCK_ID" => "3",
        "SECT_IBLOCK_ID" => "5",
        "SHOW_BUSY" => "N",
        "SHOW_FROM_GROUPS" => array("5"),
        "STRUCTURE_IBLOCK_ID" => "4",
        "WEB_STEP" => "60"
    )
);?>


Сегодня работают

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Сегодня работают

Компоненты::Сегодня работают

Описание medsite:working_today

Компонент показывает список сотрудников клиники, у которых есть расписание на сегодняшний день. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Оргструктура > Сегодня работают.

Параметры

Поле | Параметр | Описание
Основные настройки
Инфоблок подразделений/специализаций | SPEC_IB_ID | ID инфоблока подразделений.
Количество выводимых сотрудников | PERSON_COUNT | Число выводимых на странице сотрудников.
URL страницы сотрудника | PERSON_LINK | Ссылка на страницу с информацией о сотруднике.
Дополнительные настройки
Страница структуры организации | STRUCTURE_LINK | Ссылка на раздел списка сотрудников.
Имя фильтра страницы структуры компании | STRUCTURE_FILTER | Имя фильтра структуры в разделе списка сотрудников.
Выводить в случайном порядке | SHOW_IN_RANDOM_ORDER | [Y|N] При отмеченной опции пользователи будут выбираться и выводиться в случайном порядке.
Ссылка на расписание сотрудника | SCHEDULE_LINK | Ссылка на страницу расписания сотрудника.
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будет показана дата.
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции будет показано название элемента.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:working_today",
    "",
    Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "PERSON_COUNT" => "20",
        "PERSON_LINK" => "/employees/personal_info.php?empl=#id#",
        "SCHEDULE_LINK" => "",
        "SHOW_IN_RANDOM_ORDER" => "N",
        "SPEC_IB_ID" => $_REQUEST["ID"],
        "STRUCTURE_FILTER" => "structure",
        "STRUCTURE_LINK" => "/employees/structure.php"
    )
);?>


Сетка расписания

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Сетка расписания

Компоненты::Сетка расписания

Описание medsite:record.service.schedule

Компонент для формирования сетки расписания (используется с новым мастером записи на прием). Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Оргструктура > Сетка расписания.

Параметры

Поле | Параметр | Описание
Источник данных
Ссылка на расписание сотрудника | SCHEDULE_LINK | Ссылка на раздел записи на прием.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:record.service.schedule",
    "",
    Array(
        "SCHEDULE_LINK" => ""
    )
);?>


Специалисты

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Специалисты

Компоненты::Специалисты

Описание medsite:medsite.userview

Комплексный компонент, позволяет выводить информацию о специалистах клиники. Компонент разработан для решения Cайт медицинской организации. Компонент является стандартным и входит в дистрибутив модуля.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент находится в Мед.сайт > Оргструктура > Специалисты.

Параметры

Название | Параметр | Описание
Основные параметры
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е. используется значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать пользователей из групп | GROUPS | С помощью клавиши Ctrl выбираются группы, пользователи из которых будут показаны. По умолчанию - все.
Имя фильтра страницы структуры компании | STRUCTURE_FILTER | Имя фильтра страницы структуры компании.
Количество пользователей на страницу | USERS_PER_PAGE | Поле определяет количество пользователей, отображаемых на одной странице. Весь список будет отображен с помощью постраничной навигации.
Выводить уведомление при пустом списке | SHOW_ERROR_ON_NULL | [Y|N] При отмеченной опции в случае, если при фильтрации не было найдено ни одного сотрудника, будет показано текстовое уведомление об этом.
Показывать постраничную навигацию над списком | SHOW_NAV_TOP | [Y|N] При отмеченной опции постраничная навигация будет показываться над списком.
Показывать постраничную навигацию под списком | SHOW_NAV_BOTTOM | [Y|N] При отмеченной опции постраничная навигация будет показываться под списком.
Тип информационного блока организаций | ORG_IBLOCK_TYPE | Тип инфоблоков с данными об организации.
Инфоблок организаций | COMPANY_IB_ID | ID инфоблока организации.
Инфоблок подразделений | DEPARTMENT_IB_ID | ID инфоблока подразделений.
Инфоблок врачебных участков | SECTOR_IB_ID | ID инфоблока врачебных участков.
Инфоблок кабинетов | PLACEMENT_IB_ID | ID инфоблока кабинетов.
Тип инфоблока специальностей | SPEC_IBLOCK_TYPE | Тип инфоблока специальностей.
Инфоблок специальностей | SPEC_IBLOCK_ID | ID инфоблока специальностей.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
[/di] SEF_FOLDER.

Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Инфоблок услуг | IBLOCK_ID | ID инфоблока услуг.
Показать список услуг | SHOW_SERVICES | [Y|N] При отмеченной опции в информации о сотруднике будет выводиться список оказываемых им услуг.
Экранировать HTML код при выводе описания | ESCAPE_HTML | [Y|N] При отмеченной опции управляющие символы в описании (например, < > &) будут заменены на соответствующие им коды Unicode.
Показать поля пользователя | USER_FIELDS | Выбираются поля для отображения.
Показать свойства пользователя | USER_PROPERTY | Массив кодов выводимых свойств.
Ссылка на расписание сотрудника | SCHEDULE_LINK | Ссылка на раздел записи на прием.
Веб-форма для отзывов | REVIEW_FORM_ID | ID веб-формы отзывов о сотрудниках.
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты без года | DATE_FORMAT_NO_YEAR | Указывается формат показа даты без года. В выпадающем списке перечислены все возможные варианты показа даты без года, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты и времени, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Имя фильтра (для внешних форм фильтрации) | FILTER_NAME | Имя фильтра.
Сортировать пользователей по USER_SORT Поле для сортировки списка пользователей:
  • ID - по идентификатору;
  • NAME - по заголовку;
  • ACTIVE_FORM - по дате начала активности;
  • SORT - по индексу сортировки;
  • TIMESTAMP_X - по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для второй сортировки списка.
Тип сортировки SORT_TYPE Задается направление для второй сортировки новостей:
  • ASC - по возрастанию;
  • DESC - по убыванию.
Количество отображаемых недель (кроме текущей) | WEEK_LEAF | Количество недель для вывода, кроме текущей недели.
Количество отображаемых талонов до нажатия "Развернуть" (не меньше 3) | COLLAPSE_SCHEDULE_IF_MORE | Указывается число отображаемых талонов (остальные будут доступны при клике кнопки Развернуть).

Пример вызова

 IncludeComponent(
    "medsite:medsite.userview",
    "",
    Array(
        "CACHE_TIME" => "3600",
        "CACHE_TYPE" => "A",
        "COLLAPSE_SCHEDULE_IF_MORE" => "10",
        "COMPANY_IB_ID" => $_REQUEST["ID"],
        "DATE_FORMAT" => "d.m.Y",
        "DATE_FORMAT_NO_YEAR" => "d.m",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "DEPARTMENT_IB_ID" => $_REQUEST["ID"],
        "ESCAPE_HTML" => "Y",
        "FILTER_NAME" => "users",
        "GROUPS" => array(),
        "IBLOCK_ID" => $_REQUEST["ID"],
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "ORG_IBLOCK_TYPE" => "news",
        "PLACEMENT_IB_ID" => $_REQUEST["ID"],
        "REVIEW_FORM_ID" => "0",
        "SCHEDULE_LINK" => "",
        "SECTOR_IB_ID" => $_REQUEST["ID"],
        "SEF_MODE" => "N",
        "SHOW_ERROR_ON_NULL" => "Y",
        "SHOW_NAV_BOTTOM" => "Y",
        "SHOW_NAV_TOP" => "N",
        "SHOW_SERVICES" => "Y",
        "SORT_TYPE" => "ASC",
        "SPEC_IBLOCK_ID" => $_REQUEST["ID"],
        "SPEC_IBLOCK_TYPE" => "news",
        "STRUCTURE_FILTER" => "structure",
        "USERS_PER_PAGE" => "90",
        "USER_FIELDS" => array("EMAIL", "PERSONAL_PHONE", "WORK_POSITION", "WORK_NOTES"),
        "USER_PROPERTY" => array(),
        "USER_SORT" => "",
        "VARIABLE_ALIASES" => Array(
            "page" => "page",
            "user_id" => "user_id"
        ),
        "WEEK_LEAF" => "2"
    )
);?>


Список результатов

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Список результатов

Компоненты::Список результатов

Описание form.result.list

Компонент позволяет просматривать список результатов заполнения веб-формы записи на госпитализацию. Компонент является модификацией стандартного компонента bitrix:form.result.list для решения Сайт медицинской организации. Компонент убран из модуля в следующих обновлениях после 5.0.4.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути Мед.сайт > Веб-формы > Структура разделов.

Пример вызова

<?$APPLICATION->IncludeComponent("medsite:form.result.list",
    "",
    Array(
        "CHAIN_ITEM_LINK" => "",
        "CHAIN_ITEM_TEXT" => "",
        "EDIT_URL" => "result_edit.php",
        "IBLOCK_ID" => "9",
        "IBLOCK_TYPE" => "registry",
        "NEW_URL" => "result_new.php",
        "NOT_SHOW_FILTER" => array("",""),
        "NOT_SHOW_TABLE" => array("",""),
        "SEF_MODE" => "N",
        "SHOW_ADDITIONAL" => "N",
        "SHOW_ANSWER_VALUE" => "N",
        "SHOW_STATUS" => "Y",
        "VIEW_URL" => "result_view.php",
        "WEB_FORM_ID" => "1"
    )
);?>


Список сотрудников

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Список сотрудников

Компоненты::Список сотрудников

Описание medsite:medsite.structure.list

Компонент выводит список сотрудников, удовлетворяющих внешнему фильтру. Компонент содержит три шаблона: (.default), (.list) и (.structure_list). Компонент разработан для решения Сайт медицинской организации. Компонент является стандартным и входит в дистрибутив модуля.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент находится в Мед.сайт > Оргструктура > Список сотрудников.

Параметры

Поле | Параметр | Описание
Дополнительно
Параметры для вывода в списке | USER_PROPERTY | Указываются поля пользователей, которые будут показаны в визитных карточках сотрудников.
Параметры для вывода в Excel | USER_PROPERTY_EXCEL | Указываются поля пользователей, которые должны быть выгружены при выполнении экспорта пользователей в MS Excel.
Страница отправки личного сообщения PM_URL Указывается путь к странице отправки личного сообщения.

Данное поле доступно для шаблона .list и .structure_list.
Дополнительные поля для вывода USER_PROPERTY Указываются, какие поля будут выводиться в списке сотрудников, удовлетворяющих внешнему фильтру.

Данное поле доступно для шаблона .list и .structure_list.
Показывать пользователей из групп | GROUPS | С помощью клавиши Ctrl выбираются группы, пользователи из которых будут показаны. По умолчанию - все.
Параметры фильтра
Имя фильтра | FILTER_NAME | Указывается имя фильтра.
Основные параметры
Выводить только синхронизируемых с 1С пользователей | FILTER_1C_USERS | [Y|N] При отмеченной опции будут выводиться только синхронизируемые с 1С пользователи.
Фильтр по подразделениям FILTER_SECTION_CURONLY Указывается тип фильтра по подразделениям:
  • прямой (Y);
  • рекурсивный (N).
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е. используется значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Выводить уведомление при пустом списке | SHOW_ERROR_ON_NULL | [Y|N] При отмеченной опции будет выводиться уведомление при пустом списке.
Количество пользователей на страницу | USERS_PER_PAGE | Поле определяет количество пользователей, отображаемых на одной странице. Весь список будет отображен с помощью постраничной навигации.
Подпись постраничной навигации | NAV_TITLE | Указывается подпись для постраничной навигации.
Показывать постраничную навигацию над списком | SHOW_NAV_TOP | [Y|N] При отмеченной опции постраничная навигация будет показываться над списком.
Показывать постраничную навигацию под списком | SHOW_NAV_BOTTOM | [Y|N] При отмеченной опции постраничная навигация будет показываться под списком.
Показывать список при пустом фильтре | SHOW_UNFILTERED_LIST | [Y|N] Если условия поиска не заданы, то при отмеченной опции будет выведен весь список сотрудников.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
"medsite:medsite.structure.list",
    "",
    Array(
        "USER_PROPERTY" => array(),
        "USER_PROPERTY_EXCEL" => array(),
        "FILTER_NAME" => "users",
        "FILTER_1C_USERS" => "Y",
        "FILTER_SECTION_CURONLY" => "N",
        "GROUPS" => array(),
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_ERROR_ON_NULL" => "Y",
        "USERS_PER_PAGE" => "10",
        "NAV_TITLE" => "Сотрудники",
        "SHOW_NAV_TOP" => "Y",
        "SHOW_NAV_BOTTOM" => "Y",
        "SHOW_UNFILTERED_LIST" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_NOTES" => ""
    )
);?>


Структура компании

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Структура компании

Компоненты::Структура компании

Описание medsite:medsite.structure

Компонент выводит дерево структуры компании со списком сотрудников. Компонент разработан для решения Cайт медицинской организации. Компонент является стандартным и входит в дистрибутив модуля.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент находится в Мед.сайт > Оргструктура > Структура компании.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленной опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение Y, то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Основные параметры
Страница поиска сотрудников | SEARCH_URL | Указывается путь к странице поиска сотрудников.
Инфоблок расписаний | SHEDULES_BLOCK | Указывается шаблон пути к инфоблоку расписаний.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается шаблон пути к странице подразделения компании.
Количество пользователей на страницу | USERS_PER_PAGE | Поле определяет количество пользователей, отображаемых на одной странице. Весь список будет отображен с помощью постраничной навигации.
Фильтр по подразделениям FILTER_SECTION_CURONLY Указывается тип фильтра по подразделениям:
  • прямой (Y);
  • рекурсивный (N).
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е. используется значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Выводить уведомление при пустом списке | SHOW_ERROR_ON_NULL | [Y|N] При отмеченной опции выводится уведомление при пустом списке.
Подпись постраничной навигации | NAV_TITLE | Поле содержит подпись для постраничной навигации.
Показывать постраничную навигацию над списком | SHOW_NAV_TOP | [Y|N] При отмеченной опции постраничная навигация будет показываться над списком.
Показывать постраничную навигацию под списком | SHOW_NAV_BOTTOM | [Y|N] При отмеченной опции постраничная навигация будет показываться под списком.
Показывать список при пустом фильтре | SHOW_UNFILTERED_LIST | [Y|N] При отмеченной опции будет выведен весь список сотрудников. Если опция не отмечена, то будет показана только структура компании.
Параметры фильтра
Выводить только синхронизируемых с 1С пользователей | FILTER_1C_USERS | [Y|N] При отмеченной опции будут выводиться только синхронизируемые с 1С пользователи.
Имя фильтра (для внешних форм фильтрации) | FILTER_NAME | Указывается имя фильтра (для внешних форм фильтрации).
Дополнительные настройки
Ссылка на расписание сотрудника | SCHEDULE_LINK | Ссылка на раздел записи на прием.
Показывать пользователей из групп | GROUPS | С помощью клавиши Ctrl выбираются группы, пользователи из которых будут показаны. По умолчанию - все.
Формат показа даты и времени | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать год рождения SHOW_YEAR Поле определяет, кому показывать год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).
Всегда показывать структуру с корня | SHOW_FROM_ROOT | [Y|N] При отмеченной опции структура компании будет всегда отображаться с корня.
Максимальная глубина дерева (0 - все) | MAX_DEPTH | Указывается максимальная глубина дерева подразделений. Параметр доступен при выключенной опции SHOW_FROM_ROOT.
Максимальная глубина дерева на первой странице (0 - все) | MAX_DEPTH_FIRST | Указывается максимальная глубина дерева подразделений на первой странице.
Количество колонок | COLUMNS | Параметр определяет количество колонок (столбцов), в которых будет выведен список подразделений.
Количество колонок на первой странице | COLUMNS_FIRST | Параметр определяет количество колонок (столбцов) на первой странице, в которых будет выведен список подразделений.
Выводить информацию о подразделении | SHOW_SECTION_INFO | [Y|N] При отмеченной опции будет выводиться информация о подразделении.
Пользовательские поля для вывода | USER_PROPERTY | Указываются поля пользователей, которые будут показаны в визитных карточках при просмотре подразделения.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:medsite.structure",
    "",
    Array(
        "AJAX_MODE" => "N",
        "AJAX_OPTION_ADDITIONAL" => "",
        "AJAX_OPTION_HISTORY" => "N",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "CACHE_TIME" => "3600",
        "CACHE_TYPE" => "A",
        "COLUMNS" => "2",
        "COLUMNS_FIRST" => "2",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "FILTER_1C_USERS" => "Y",
        "FILTER_NAME" => "users",
        "FILTER_SECTION_CURONLY" => "N",
        "GROUPS" => array(),
        "MAX_DEPTH" => "2",
        "MAX_DEPTH_FIRST" => "0",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "NAV_TITLE" => "Сотрудники",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&users_UF_DEPARTMENT=#ID#",
        "PM_URL" => "/company/personal/messages/chat/#USER_ID#/",
        "SCHEDULE_LINK" => "",
        "SEARCH_URL" => "search.php",
        "SHOW_ERROR_ON_NULL" => "N",
        "SHOW_FROM_ROOT" => "N",
        "SHOW_LOGIN" => "Y",
        "SHOW_NAV_BOTTOM" => "Y",
        "SHOW_NAV_TOP" => "Y",
        "SHOW_SECTION_INFO" => "Y",
        "SHOW_UNFILTERED_LIST" => "N",
        "SHOW_YEAR" => "Y",
        "USERS_PER_PAGE" => "10",
        "USER_PROPERTY" => array("EMAIL", "PERSONAL_ICQ", "PERSONAL_PHONE", "PERSONAL_MOBILE")
    )
);?>


Структура разделов

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Структура разделов

Компоненты::Структура разделов

Описание medsite:catalog.section.list

Компонент выводит структуру разделов инфоблока с количеством элементов в каждом разделе. Компонент является модификацией стандартного компонента bitrix:catalog.section.list для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути Мед. сайт > Разное > Структура разделов.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор необходимого информационного блока.
ID раздела | SECTION_ID | Указывается код, в котором передается идентификатор раздела.
Код раздела | SECTION_CODE | Указывается код раздела.
Источник данных
Имя массива со значениями фильтра разделов | FILTER_NAME | Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Показывать количество элементов в разделе | COUNT_ELEMENTS | [Y|N] При отмеченной опции будет показано количество элементов в разделе.
Максимальная отображаемая глубина разделов | TOP_DEPTH | Параметр определяет максимальную глубину отображаемых разделов.
Поля разделов SECTION_FIELDS Указываются поля раздела, которые будут отображены на странице структуры разделов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
 Array("ID","CODE",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив) ничего отображаться не будет.
Свойства раздела | SECTION_USER_FIELDS | Указываются свойства раздела, которые будут отображены на странице. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, свойства не будут выведены.
Внешний вид (для шаблона .default и visual)
Вид списка подразделов | VIEW_MODE | Определяется способ отображения списка подразделов: в виде списка (LINE), многоуровнего списка (LIST), текста (TEXT) или плитки (TILE).
Показывать название раздела | SHOW_PARENT_NAME | [Y|N] При отмеченной опции будет выводится название раздела (кроме раздела верхнего уровня).
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается путь к странице с содержимым раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Дополнительные настройки
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции раздел будет включен в цепочку навигации.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:catalog.section.list",
    "",
    Array(
        "ADD_SECTIONS_CHAIN" => "Y",
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "36000000",
        "CACHE_TYPE" => "A",
        "COUNT_ELEMENTS" => "Y",
        "FILTER_NAME" => "arrFilter",
        "IBLOCK_ID" => "",
        "IBLOCK_TYPE" => "catalog",
        "SECTION_CODE" => "",
        "SECTION_FIELDS" => array("",""),
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "SECTION_URL" => "",
        "SECTION_USER_FIELDS" => array("",""),
        "SHOW_PARENT_NAME" => "Y",
        "TOP_DEPTH" => "2",
        "VIEW_MODE" => "LINE"
    )
);?>


Талоны пациента

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Талоны пациента

Компоненты::Талоны пациента

Описание medsite:talon

Компонент выводит список талонов для зарегистрированных пользователей. Для незарегистрированных он позволяет найти талон по номеру. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Запись на прием > Талоны пациента.

Параметры

Поле | Параметр | Описание
Основные параметры
Выводить дополнительные поля | SHOW_PROPERTIES | Массив ID полей карточки пациента, которые должны выводиться в талоне.
Поле для первой сортировки SORT_BY1 Поле для первой сортировки:
  • дата записи
  • время записи
Направление для первой сортировки SORT_ORDER1 Задается направление для первой сортировки:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки SORT_BY2 Поле для второй сортировки:
  • дата записи
  • время записи
Направление для второй сортировки SORT_ORDER2 Задается направление для второй сортировки:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Показать форму поиска | SHOW_SEARCH | [Y|N] При установленной опции пользователю будет доступна возможность фильтрации талонов.
Не выводить старые талоны (при фильтрации от текущей даты) | FILTER_OLD | [Y|N] При установленной опции пользователю старые талоны будут скрыты.
Ссылка на запись/каталог услуг | RECORD_URL | Ссылка, используемая в шаблоне в сообщении, которое показывается, если талонов нет, либо они не найдены при фильтрации.
Выводить на странице | SHOW_PER_PAGE | Число талонов, выводимых на одной странице.
Показать строку «Распечатано» | SHOW_PRINTED | [Y|N] При отмеченной опции у распечатанного талона появится соответствующая надпись.
Показать иконки управления талоном | SHOW_ICONS | [Y|N] При отмеченной опции будут показаны иконки с обозначениями возможных действий с талоном.
Ссылка на корзину | BASKET_URL | Ссылка на раздел корзины.
Ссылка на заказы | ORDER_URL | Ссылка на раздел заказов.
Настройки постраничной навигации
Шаблон постраничной навигации | PAGER_TEMPLATE | Указывается название шаблона постраничной навигации. Если поле пусто, то выбирается шаблон по умолчанию (.default).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение по элементам.
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться, даже если все элементы помещаются на одной странице.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц в секундах для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все элементы каталога.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:talon",
    "",
    Array(
        "BASKET_URL" => "/personal/cart/",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "DISPLAY_TOP_PAGER" => "N",
        "FILTER_OLD" => "Y",
        "ORDER_URL" => "/personal/orders/",
        "PAGER_DESC_NUMBERING" => "N",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "N",
        "PAGER_SHOW_ALWAYS" => "N",
        "PAGER_TEMPLATE" => ".default",
        "PAGER_TITLE" => "",
        "RECORD_URL" => "/services/",
        "SHOW_ICONS" => "Y",
        "SHOW_PER_PAGE" => "10",
        "SHOW_PRINTED" => "N",
        "SHOW_PROPERTIES" => array(),
        "SHOW_SEARCH" => "Y",
        "SORT_BY_1" => "TALON_DATE",
        "SORT_BY_2" => "TALON_DATE",
        "SORT_ORDER_1" => "DESC",
        "SORT_ORDER_2" => "DESC"
    )
);?>


Управление структурой организации

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Управление структурой организации

Компоненты::Управление структурой организации

Описание medsite:medsite.organiztion_structure

Компонент предназначен для редактирования организационной структуры сайта медицинской организации. Он выводит список пользователей (сотрудников) внутри структуры организаций и подразделений. Редактирование подразделений осуществляется в режиме правки. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути Мед. сайт > Оргструктура > Управление структурой компании.

Параметры

Поле | Параметр | Описание
Основные настройки
Тип информационного блока | IBLOCK_TYPE | Используется для проверки.
Код информационного блока организаций | ORGANIZTION_IBLOCK_ID | ID информационного блока организаций.
Код информационного блока структуры/подразделений | STRUCTURE_IBLOCK_ID | ID инфоблока подразделений внутри организаций.
Выводить пользователей из групп | SHOW_FROM_GROUPS | Массив ID групп пользователей, используемых для вывода.
Дополнительные настройки
Страница календаря записи на прием | PM_URL | Адрес страницы записи на прием к сотруднику.
Страница редактора расписания | EC_URL | Страница редактирования расписания для сотрудников.
Дополнительные поля для вывода | USER_PROPERTY | Массив дополнительных полей, выводимых в карточках сотрудников.

Пример вызова

<?APPLICATION->IncludeComponent(
"medsite:medsite.organiztion_structure",
    "",
    Array(
        "EC_URL" => "#SITE_DIR#for_staff/edit_calendar.php?empl=#USER_ID#",
        "IBLOCK_TYPE" => "structure",
        "ORGANIZTION_IBLOCK_ID" => "1",
        "PM_URL" => "#SITE_DIR#schedule/calendar.php?empl=#USER_ID#",
        "SHOW_FROM_GROUPS" => array(),
        "STRUCTURE_IBLOCK_ID" => "2",
        "USER_PROPERTY" => array("PERSONAL_PROFESSION")
    )
);?>


Управление талонами

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Управление талонами

Компоненты::Управление талонами

Описание medsite:talon_admin

Компонент предназначен для сотрудников регистратуры и позволяет управлять талонами записи на прием, созданными через сайт. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Запись на прием > Управление талонами.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Тип инфоблока (для проверки).
ID информационного блока врачебных участков | IBLOCK_ID | ID инфоблока врачебных участков.
Выводить дополнительные поля | SHOW_PROPERTIES | Массив ID полей карточки пациента для вывода.
Статус талона, который будет установлен после его воcстановления | STATUS_PROPERTY | Выбирается статус, который буден установлен после восстановления талона.
Выводить на странице | SHOW_PER_PAGE | Число талонов, выводимых на одной странице.
URL мастера записи на прием | RECORD_WIZARD_URL | Ссылка на раздел записи на прием.
Настройки постраничной навигации
Шаблон постраничной навигации | PAGER_TEMPLATE | Выбирается шаблон постраничной навигации.
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все талоны.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:talon_admin",
    "",
    Array(
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "DISPLAY_TOP_PAGER" => "N",
        "IBLOCK_ID" => $_REQUEST["ID"],
        "IBLOCK_TYPE" => "news",
        "PAGER_DESC_NUMBERING" => "N",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "N",
        "PAGER_SHOW_ALWAYS" => "N",
        "PAGER_TEMPLATE" => ".default",
        "PAGER_TITLE" => "",
        "RECORD_WIZARD_URL" => "/schedule/record_wizard.php",
        "SHOW_PER_PAGE" => "10",
        "SHOW_PROPERTIES" => array(),
        "STAUS_PROPERTY" => "0"
    )
);?>


Фильтр по элементам

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Фильтр по элементам

Компоненты::Фильтр по элементам

Описание medsite:catalog.filter

Компонент выводит форму фильтра для фильтрации элементов информационных блоков. Компонент является модификацией стандартного компонента bitrix:catalog.filter для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути Мед. сайт > Разное > Фильтр по элементам.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, элементы которого будут отфильтрованы.
Имя выходящего массива для фильтрации | FILTER_NAME | Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Поля FIELD_CODE Указываются дополнительные поля элементов инфоблока, по которым будет возможна фильтрация. Заполняется из публичной части редактора, удерживая клавишу Ctrl, либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания полей в строках (т.е. если задан пустой массив), будут выведены поля по умолчанию.
Свойства PROPERTY_CODE Указываются свойства инфоблока, которые будут отображены при показе в качестве полей фильтра. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках, свойства выведены не будут.

Значения свойств типа "Список" отображаются в фильтре в соответствии с настройками, заданными в форме редактирования самого свойства (поле "Внешний вид").
Поля предложений | OFFERS_FIELD_CODE | Выбираются поля предложений. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений | OFFERS_PROPERTY_CODE | Указываются свойства предложений. Можно добавлять свои. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Внешний вид
Высота списков множественного выбора | LIST_HEIGHT | Указывается высота множественных списков выбора, отображаемых в фильтре.
Ширина однострочных текстовых полей ввода | TEXT_WIDTH | Указывается ширина текстового поля ввода в форме фильтра.
Ширина полей ввода для числовых интервалов | NUMBER_WIDTH | Указывается ширина полей ввода для числовых интервалов в форме фильтра.
Дополнительные настройки
Сохранять установки фильтра в сессии пользователя | SAVE_IN_SESSION | [Y|N] При отмеченной опции установки фильтра будут сохраняться в сессии пользователя.
Всегда одно значение в списке выбора | SINGLE_SELECT | [Y|N] При отмеченной опции для выбора будет доступно только одно значение.

Пример вызова

<?APPLICATION->IncludeComponent (
    "medsite:catalog.filter",
    "",
    Array(
        "CACHE_GROUPS" => "Y",
        "CACHE_TIME" => "36000000",
        "CACHE_TYPE" => "A",
        "FIELD_CODE" => array("", ""),
        "FILTER_NAME" => "arrFilter",
        "IBLOCK_ID" => "",
        "IBLOCK_TYPE" => "",
        "LIST_HEIGHT" => "5",
        "NUMBER_WIDTH" => "5",
        "PRICE_CODE" => array(),
        "PROPERTY_CODE" => array("", ""),
        "SAVE_IN_SESSION" => "N",
        "SINGLE_SELECT" => "N",
        "TEXT_WIDTH" => "20"
    )
);?>


Фильтр сервиса обращений

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Фильтр сервиса обращений

Компоненты::Фильтр сервиса обращений

Описание medsite:catalog.filter.feedback

Компонент выводит форму фильтра для фильтрации элементов информационых блоков. Компонент является модификацией стандартного компонента bitrix:catalog.filter для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути Мед.сайт > Обращения > Фильтр сервиса обращений.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, элементы которого будут отфильтрованы.
Имя выходящего массива для фильтрации | FILTER_NAME | Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Поля FIELD_CODE Указываются дополнительные поля элементов инфоблока, по которым будет возможна фильтрация. Заполняется из публичной части редактора, удерживая клавишу Ctrl, либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания полей в строках (т.е. если задан пустой массив), будут выведены поля по умолчанию.
Свойства PROPERTY_CODE Указываются свойства инфоблока, которые будут отображены при показе в качестве полей фильтра. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках, свойства выведены не будут.

Значения свойств типа "Список" отображаются в фильтре в соответствии с настройками, заданными в форме редактирования самого свойства (поле "Внешний вид").
Поля предложений | OFFERS_FIELD_CODE | Выбираются поля предложений. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений | OFFERS_PROPERTY_CODE | Указываются свойства предложений. Можно добавлять свои. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Внешний вид
Высота списков множественного выбора | LIST_HEIGHT | Указывается высота множественных списков выбора, отображаемых в фильтре.
Ширина однострочных текстовых полей ввода | TEXT_WIDTH | Указывается ширина текстового поля ввода в форме фильтра.
Ширина полей ввода для числовых интервалов | NUMBER_WIDTH | Указывается ширина полей ввода для числовых интервалов в форме фильтра.
Дополнительные настройки
Сохранять установки фильтра в сессии пользователя | SAVE_IN_SESSION | [Y|N] При отмеченной опции установки фильтра будут сохраняться в сессии пользователя.

Пример вызова

<?$APPLICATION->IncludeComponent (
"medsite:catalog.filter.feedback",
    "",
    Array(
        "IBLOCK_TYPE" => "s1",
        "IBLOCK_ID" => "2",
        "FILTER_NAME" => "arrFilter",
        "FIELD_CODE" => array("ID"),
        "PROPERTY_CODE" => array("DOC_TYPE"),
        "PRICE_CODE" => array(),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_GROUPS" => "Y",
        "LIST_HEIGHT" => "5",
        "TEXT_WIDTH" => "20",
        "NUMBER_WIDTH" => "5",
        "SAVE_IN_SESSION" => "Y"
    )
);?>


Форма добавления / редактирования обращения

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Форма добавления / редактирования обращения

Компоненты::Форма добавления / редактирования обращения

Описание medsite:iblock.element.add.form.feedback

Осуществляет добавление/редактирование обращений. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Обращения > Форма добавления / редактирования обращения.

Параметры

Поле | Параметр | Описание
Параметры компонента
Статус после сохранения | STATUS_NEW | Указывается статус, в который переводятся элементы при их создании/редактировании.
Страница со списком своих элементов | LIST_URL | Указывается адрес страницы со списком элементов.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления элемента.
Сообщение об успешном добавлении | USER_MESSAGE_ADD | Задается сообщение, которое выводится при успешном добавлении элемента.
Сообщение об успешном сохранении | USER_MESSAGE_EDIT | Задается сообщение, которое выводится при успешном сохранении элемента.
Размер полей ввода | DEFAULT_INPUT_SIZE | Указывается размер полей ввода в форме создания/редактирования элемента.
Использовать настройки инфоблока для обработки изображений | RESIZE_IMAGES | [Y|N] При отмеченной функции элементы, добавленные через публичную часть будут преобразовываться согласно настройкам инфоблока.
Источник данных
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор необходимого информационного блока.
Свойства инфоблока
Свойства, выводимые на редактирование | PROPERTY_CODES | Указываются поля и свойства инфоблока, которые выводятся в форме создания/редактирования элемента.
Свойства, обязательные для заполнения | PROPERTY_CODES_REQUIRED | Указываются обязательно заполняемые поля и свойства инфоблока в форме создания/редактирования раздела.
Параметры доступа
Группы пользователей, имеющие право на добавление/редактирование | GROUPS | Указываются группы пользователей, имеющие право на добавление/редактирование элементов инфоблока.
Редактирование возможно для статуса | GROUPS | Указываются группы пользователей, имеющие право на добавление/редактирование элементов инфоблока.
Привязка к пользователю ELEMENT_ASSOC Задается привязка к пользователю:
  • создателю (CREATED_BY) - привязка по создателю: пользователю будут показаны только созданные им элементы.
  • по свойству инфоблока --> (PROPERTY_ID) - привязка по свойству инфоблока. В этом случае доступен параметр ELEMENT_ASSOC_PROPERTY.
Ограничить кол-во элементов для одного пользователя | MAX_USER_ENTRIES | Указывается максимальное количество элементов, которые может добавить пользователь.
Ограничить кол-во рубрик, в которые можно добавлять элемент | MAX_LEVELS | Указывается максимальное количество разделов инфоблока, в которые пользователь может добавить один и тот же элемент.
Разрешить добавление только на последний уровень рубрикатора | LEVEL_LAST | [Y|N] При отмеченной опции пользователям разрешено добавлять элементы только в последний раздел дерева разделов инфоблока.
Максимальный размер загружаемых файлов, байт (0 - не ограничивать) | MAX_FILE_SIZE | Указывается максимальный размер загружаемых файлов. Если указано 0, то размер файлов не ограничен.
Использовать визуальный редактор для редактирования текста анонса | PREVIEW_TEXT_USE_HTML_EDITOR | Разрешает использование редактора при добавлении и редактировании анонса.
Использовать визуальный редактор для редактирования подробного текста | DETAIL_TEXT_USE_HTML_EDITOR | Разрешает использование редактора при добавлении и редактировании подробного текста.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
[/di] SEF_FOLDER.
Собственные названия полей
*поле_инфоблока* CUSTOM_TITLE_<поле_инфоблока> Задаются названия полей инфоблока для отображения пользователям. Вместо <поле_инфоблока> указывается следующее:
  • NAME - наименование;
  • TAGS - теги;
  • DATE_ACTIVE_FROM - дата начала;
  • DATE_ACTIVE_TO - дата завершения;
  • IBLOCK_SECTION - раздел инфоблока;
  • PREVIEW_TEXT - текст анонса;
  • PREVIEW_PICTURE - картинка анонса;
  • DETAIL_TEXT - подробный текст;
  • DETAIL_PICTURE - подробная картинка.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:iblock.element.add.form.feedback",
    "",
    Array(
        "CUSTOM_TITLE_DATE_ACTIVE_FROM" => "",
        "CUSTOM_TITLE_DATE_ACTIVE_TO" => "",
        "CUSTOM_TITLE_DETAIL_PICTURE" => "",
        "CUSTOM_TITLE_DETAIL_TEXT" => "",
        "CUSTOM_TITLE_IBLOCK_SECTION" => "",
        "CUSTOM_TITLE_NAME" => "",
        "CUSTOM_TITLE_PREVIEW_PICTURE" => "",
        "CUSTOM_TITLE_PREVIEW_TEXT" => "",
        "CUSTOM_TITLE_TAGS" => "",
        "DEFAULT_INPUT_SIZE" => "30",
        "DETAIL_TEXT_USE_HTML_EDITOR" => "N",
        "ELEMENT_ASSOC" => "CREATED_BY",
        "GROUPS" => array(),
        "IBLOCK_ID" => "",
        "IBLOCK_TYPE" => "",
        "LEVEL_LAST" => "Y",
        "LIST_URL" => "",
        "MAX_FILE_SIZE" => "0",
        "MAX_LEVELS" => "100000",
        "MAX_USER_ENTRIES" => "100000",
        "PREVIEW_TEXT_USE_HTML_EDITOR" => "N",
        "PROPERTY_CODES" => array(),
        "PROPERTY_CODES_REQUIRED" => array(),
        "RESIZE_IMAGES" => "N",
        "SEF_MODE" => "N",
        "STATUS" => array(),
        "STATUS_NEW" => "1",
        "USER_MESSAGE_ADD" => "",
        "USER_MESSAGE_EDIT" => "",
        "USE_CAPTCHA" => "N"
    )
);?>


Форма добавления / редактирования раздела

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Форма добавления / редактирования раздела

Компоненты::Форма добавления / редактирования раздела

Описание medsite:iblock.section.add.form

Компонент осуществляет вывод списка разделов указанного инфоблока, добавление/редактирование разделов и их удаление в зависимости от прав пользователя. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Разное > Форма добавления / редактирования раздела.

Параметры

Поле | Параметр | Описание
Параметры компонента
Страница со списком разделов | LIST_URL | Указывается адрес страницы со списком разделов.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления элемента.
Сообщение об успешном добавлении | USER_MESSAGE_ADD | Задается сообщение, которое выводится при успешном добавлении элемента.
Сообщение об успешном сохранении | USER_MESSAGE_EDIT | Задается сообщение, которое выводится при успешном сохранении элемента.
Размер полей ввода | DEFAULT_INPUT_SIZE | Указывается размер полей ввода в форме создания/редактирования элемента.
Использовать настройки инфоблока для обработки изображений | RESIZE_IMAGES | [Y|N] При отмеченной функции элементы, добавленные через публичную часть будут преобразовываться согласно настройкам инфоблока.
Источник данных
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор необходимого информационного блока.
ID элемента | ID | Указывается код, в котором передается идентификатор элемента.
Свойства инфоблока
Свойства, выводимые на редактирование | PROPERTY_CODES | Указываются поля и свойства инфоблока, которые выводятся в форме создания/редактирования элемента.
Свойства, обязательные для заполнения | PROPERTY_CODES_REQUIRED | Указываются обязательно заполняемые поля и свойства инфоблока в форме создания/редактирования раздела.
Параметры доступа
Группы пользователей, имеющие право на добавление/редактирование | GROUPS | Указываются группы пользователей, имеющие право на добавление/редактирование элементов инфоблока.
Привязка к пользователю ELEMENT_ASSOC Задается привязка к пользователю:
  • создателю (CREATED_BY) - привязка по создателю: пользователю будут показаны только созданные им элементы.
  • по свойству инфоблока --> (PROPERTY_ID) - привязка по свойству инфоблока. В этом случае доступен параметр ELEMENT_ASSOC_PROPERTY.
Ограничить кол-во элементов для одного пользователя | MAX_USER_ENTRIES | Указывается максимальное количество элементов, которые может добавить пользователь.
Ограничить кол-во рубрик, в которые можно добавлять элемент | MAX_LEVELS | Указывается максимальное количество разделов инфоблока, в которые пользователь может добавить один и тот же элемент.
Разрешить добавление только на последний уровень рубрикатора | LEVEL_LAST | [Y|N] При отмеченной опции пользователям разрешено добавлять элементы только в последний раздел дерева разделов инфоблока.
Максимальный размер загружаемых файлов, байт (0 - не ограничивать) | MAX_FILE_SIZE | Указывается максимальный размер загружаемых файлов. Если указано 0, то размер файлов не ограничен.
Использовать визуальный редактор для редактирования текста анонса | PREVIEW_TEXT_USE_HTML_EDITOR | Разрешает использование редактора при добавлении и редактировании.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
[/di] SEF_FOLDER.
Собственные названия полей
*поле_инфоблока* CUSTOM_TITLE_<поле_инфоблока> Задаются названия полей инфоблока для отображения пользователям. Вместо <поле_инфоблока> указывается следующее:
  • NAME - наименование;
  • SORT - сортировка;
  • ACTIVE - активность;
  • IBLOCK_SECTION - раздел инфоблока;
  • DESCRIPTION - текст описания;
  • PICTURE - картинка;
  • DETAIL_PICTURE - подробная картинка.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:iblock.section.add.form",
    "",
    Array(
        "CUSTOM_TITLE_ACTIVE" => "",
        "CUSTOM_TITLE_DESCRIPTION" => "",
        "CUSTOM_TITLE_DETAIL_PICTURE" => "",
        "CUSTOM_TITLE_IBLOCK_SECTION_ID" => "",
        "CUSTOM_TITLE_NAME" => "",
        "CUSTOM_TITLE_PICTURE" => "",
        "CUSTOM_TITLE_SORT" => "",
        "DEFAULT_INPUT_SIZE" => "30",
        "ELEMENT_ASSOC" => "CREATED_BY",
        "GROUPS" => array(),
        "IBLOCK_ID" => "",
        "IBLOCK_TYPE" => "",
        "ID" => $_REQUEST["ID"],
        "LEVEL_LAST" => "Y",
        "LIST_URL" => "",
        "MAX_FILE_SIZE" => "0",
        "MAX_LEVELS" => "100000",
        "MAX_USER_ENTRIES" => "100000",
        "PREVIEW_TEXT_USE_HTML_EDITOR" => "N",
        "PROPERTY_CODES" => array(),
        "PROPERTY_CODES_REQUIRED" => array(),
        "RESIZE_IMAGES" => "N",
        "SEF_MODE" => "N",
        "USER_MESSAGE_ADD" => "",
        "USER_MESSAGE_EDIT" => "",
        "USE_CAPTCHA" => "N"
    )
);?>


Форма добавления / редактирования элемента

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Форма добавления / редактирования элемента

Компоненты::Форма добавления / редактирования элемента

Описание medsite:iblock.element.add.form

Компонент осуществляет вывод списка элементов указанного раздела инфоблока, добавление/редактирование элементов и их удаление в зависимости от прав пользователя. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Разное > Форма добавления / редактирования элемента.

Параметры

Поле | Параметр | Описание
Параметры компонента
Статус после сохранения | STATUS_NEW | Указывается статус, в который переводятся элементы при их создании/редактировании.
Страница со списком своих элементов | LIST_URL | Указывается адрес страницы со списком элементов.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления элемента.
Сообщение об успешном добавлении | USER_MESSAGE_ADD | Задается сообщение, которое выводится при успешном добавлении элемента.
Сообщение об успешном сохранении | USER_MESSAGE_EDIT | Задается сообщение, которое выводится при успешном сохранении элемента.
Размер полей ввода | DEFAULT_INPUT_SIZE | Указывается размер полей ввода в форме создания/редактирования элемента.
Использовать настройки инфоблока для обработки изображений | RESIZE_IMAGES | [Y|N] При отмеченной функции элементы, добавленные через публичную часть будут преобразовываться согласно настройкам инфоблока.
Источник данных
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор необходимого информационного блока.
ID элемента | ID | Указывается код, в котором передается идентификатор элемента.
Страница со списком элементов | LIST_URL_ALL | Указывается код, в котором передается идентификатор страницы со списком элементов.
Группа пользователей для списка | USER_GROUP | Выбираются группы пользователей, которые будут выводиться в списке.
Свойства инфоблока
Свойства, выводимые на редактирование | PROPERTY_CODES | Указываются поля и свойства инфоблока, которые выводятся в форме создания/редактирования элемента.
Свойства, обязательные для заполнения | PROPERTY_CODES_REQUIRED | Указываются обязательно заполняемые поля и свойства инфоблока в форме создания/редактирования раздела.
Параметры доступа
Группы пользователей, имеющие право на добавление/редактирование | GROUPS | Указываются группы пользователей, имеющие право на добавление/редактирование элементов инфоблока.
Редактирование возможно для статуса | GROUPS | Указываются группы пользователей, имеющие право на добавление/редактирование элементов инфоблока.
Привязка к пользователю ELEMENT_ASSOC Задается привязка к пользователю:
  • создателю (CREATED_BY) - привязка по создателю: пользователю будут показаны только созданные им элементы.
  • по свойству инфоблока --> (PROPERTY_ID) - привязка по свойству инфоблока. В этом случае доступен параметр ELEMENT_ASSOC_PROPERTY.
Ограничить кол-во элементов для одного пользователя | MAX_USER_ENTRIES | Указывается максимальное количество элементов, которые может добавить пользователь.
Ограничить кол-во рубрик, в которые можно добавлять элемент | MAX_LEVELS | Указывается максимальное количество разделов инфоблока, в которые пользователь может добавить один и тот же элемент.
Разрешить добавление только на последний уровень рубрикатора | LEVEL_LAST | [Y|N] При отмеченной опции пользователям разрешено добавлять элементы только в последний раздел дерева разделов инфоблока.
Максимальный размер загружаемых файлов, байт (0 - не ограничивать) | MAX_FILE_SIZE | Указывается максимальный размер загружаемых файлов. Если указано 0, то размер файлов не ограничен.
Использовать визуальный редактор для редактирования текста анонса | PREVIEW_TEXT_USE_HTML_EDITOR | Разрешает использование редактора при добавлении и редактировании.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
[/di] SEF_FOLDER.
Собственные названия полей
*поле_инфоблока* CUSTOM_TITLE_<поле_инфоблока> Задаются названия полей инфоблока для отображения пользователям. Вместо <поле_инфоблока> указывается следующее:
  • NAME - наименование;
  • SORT - сортировка;
  • ACTIVE - активность;
  • TAGS - теги;
  • DATE_ACTIVE_FROM - дата начала;
  • DATE_ACTIVE_TO - дата завершения;
  • IBLOCK_SECTION - раздел инфоблока;
  • PREVIEW_TEXT - текст анонса;
  • PREVIEW_PICTURE - картинка анонса;
  • DETAIL_TEXT - подробный текст;
  • DETAIL_PICTURE - подробная картинка.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "medsite:iblock.element.add.form",
    "",
    Array(
        "CUSTOM_TITLE_ACTIVE" => "",
        "CUSTOM_TITLE_DATE_ACTIVE_FROM" => "",
        "CUSTOM_TITLE_DATE_ACTIVE_TO" => "",
        "CUSTOM_TITLE_DETAIL_PICTURE" => "",
        "CUSTOM_TITLE_DETAIL_TEXT" => "",
        "CUSTOM_TITLE_IBLOCK_SECTION" => "",
        "CUSTOM_TITLE_NAME" => "",
        "CUSTOM_TITLE_PREVIEW_PICTURE" => "",
        "CUSTOM_TITLE_PREVIEW_TEXT" => "",
        "CUSTOM_TITLE_SORT" => "",
        "CUSTOM_TITLE_TAGS" => "",
        "DEFAULT_INPUT_SIZE" => "30",
        "DETAIL_TEXT_USE_HTML_EDITOR" => "N",
        "ELEMENT_ASSOC" => "CREATED_BY",
        "GROUPS" => array(),
        "IBLOCK_ID" => "",
        "IBLOCK_TYPE" => "",
        "ID" => $_REQUEST["ID"],
        "LEVEL_LAST" => "Y",
        "LIST_URL" => "",
        "LIST_URL_ALL" => $_REQUEST["SECTION_ID"],
        "MAX_FILE_SIZE" => "0",
        "MAX_LEVELS" => "100000",
        "MAX_USER_ENTRIES" => "100000",
        "PREVIEW_TEXT_USE_HTML_EDITOR" => "N",
        "PROPERTY_CODES" => array(),
        "PROPERTY_CODES_REQUIRED" => array(),
        "RESIZE_IMAGES" => "N",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "SEF_MODE" => "N",
        "STATUS" => array(),
        "STATUS_NEW" => "1",
        "USER_GROUP" => array(),
        "USER_MESSAGE_ADD" => "",
        "USER_MESSAGE_EDIT" => "",
        "USE_CAPTCHA" => "N"
    )
);?>


Форма поиска

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для здравоохранения>Сайт медицинской организации>Компоненты>Форма поиска

Компоненты::Форма поиска

Описание medsite:medsite.structure.selector

Компонент выводит форму фильтрации списка сотрудников. Компонент содержит шаблоны: (.default), (.alphabet), (.fio), (.include_area), (online), (.sections), (.section_filter). Компонент разработан для решения Сайт медицинской организации. Компонент является стандартным и входит в дистрибутив модуля.

Компонент доступен для базового варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент находится в Мед.сайт > Оргструктура > Форма поиска.

Параметры

Поле | Параметр | Описание
Дополнительно
Количество колонок | COLUMNS | Указывается количество колонок в секции. Параметр доступен только для шаблона .sections и .section_filter.
Количество колонок на первой странице | COLUMNS_FIRST | Указывается количество колонок на первой странице. Параметр доступен только для шаблона .sections и .section_filter.
Максимальная глубина дерева (0 - все) | MAX_DEPTH | Указывается максимальная глубина дерева. Параметр доступен только для шаблона .sections и .section_filter.
Максимальная глубина дерева на первой странице (0 - все) | MAX_DEPTH_FIRST | Указывается максимальная глубина дерева на первой странице. Параметр доступен только для шаблона .sections и .section_filter.
Выводить информацию о подразделении | SHOW_SECTION_INFO | [Y|N] При отмеченной опции в результатах поиска будет выводиться информация о подразделении. Параметр доступен только для шаблона .sections и .section_filter.
Основные параметры
Страница списка пользователей | LIST_URL | Указывается путь к странице со списком пользователей.
Параметры фильтра
Имя фильтра | FILTER_NAME | Указывается имя фильтра.
Выбор подразделения для фильтрации FILTER_DEPARTMENT_SINGLE Указывается способ выбора подразделения(ий) в форме поиска:
  • одинарный (Y) - в выпадающем списке можно выбрать только одно подразделение;
  • множественный (N) - поле позволяет выбирать несколько подразделений.
Запоминать фильтр в сессии | FILTER_SESSION | [Y|N] При отмеченной опции значения, введенные в поля формы поиска, будут запоминаться системой.

Пример вызова

<?$APPLICATION->IncludeComponent(
"medsite:medsite.structure.selector",
    ".default",
    Array(
        "LIST_URL" => "",
        "FILTER_NAME" => "users",
        "FILTER_DEPARTMENT_SINGLE" => "Y",
        "FILTER_SESSION" => "Y"
    )
);?>


Решения для образования

Решения:

  • Внутренний портал учебного заведения
  • Сайт учебного заведения
  • Сайт школы


Сайт учебного заведения

В данном решении [image] реализован дизайн, структура, созданы все готовые разделы: «О вузе», «Абитуриентам», «Студентам», «Выпускникам». Нет необходимости разрабатывать дизайн и структуру сайта, нужно только заполнить данные.

Для всех разделов сайта создан демо-контент, в состав решения также входит готовый адаптивный шаблон дизайна и несколько цветовых схем оформления.


Внутренний портал учебного заведения

Данное решение [image] в реализовано в редакции 1С-Битрикс: Корпоративный портал "Бизнес-процессы".


Внутренний портал учебного заведения. Настройки модуля

Форма настроек модуля 1С-Битрикс: Внутренний портал учебного заведения (Настройки > Настройки продукта > Настройки модулей > 1С-Битрикс: Внутренний портал учебного заведения) предназначена для задания общесистемных параметров модуля.

Поле | Описание
Инфоблоки внутреннего портала учебного заведения
Тип инфоблока структуры учебного заведения | Выбирается один из созданных в системе типов инфоблоков.
Инфоблок структуры учебного заведения | Для указанного типа инфоблоков выбирается инфоблок структуры учебного заведения.
ИД свойства с типом сущности (UF_TYPE) | Выбирается свойство инфоблока, в котором передается тип сущности.
ИД типа сущности Факультет | Выбирается идентификатор типа сущности Факультет.
ИД типа Кафедра | Выбирается идентификатор типа сущности Кафедра.
ИД типа сущности Специальность | Выбирается идентификатор типа сущности Специальность.
ИД типа сущности Учебная группа | Выбирается идентификатор типа сущности Учебная группа.
Инфоблок информационных сообщений | Для указанного типа инфоблоков выбирается инфоблок информационных сообщений.
ИД свойства Автор | Выбирается идентификатор cвойства Автор.
ИД типа свойства ФИО автора | Выбирается идентификатор типа cвойства ФИО автора.
Инфоблок тэгов информационных сообщений | Для указанного типа инфоблоков выбирается инфоблок тэгов информационных сообщений.
ИД элемента-тэга Оценка | Указывается идентификатор элемента-тэга Оценка.
Инфоблок статусов учебных групп | Для указанного типа инфоблоков выбирается инфоблок cтатусов учебных групп.
Инфоблок предметов | Для указанного типа инфоблоков выбирается инфоблок предметов.
ИД свойства Преподаватель | Выбирается идентификатор cвойства Преподаватель.
ИД свойства Рабочая группа предмета | Выбирается идентификатор cвойства Рабочая группа предмета.
Инфоблоки документов групп
Тип инфоблока документов | Выбирается один из созданных в системе типов инфоблоков.
Инфоблок библиотеки групп | Для указанного типа инфоблоков выбирается инфоблок библиотеки групп.
ИД свойства Оценка | Выбирается идентификатор cвойства Оценка.
ИД свойства Оценка в ведомости | Выбирается идентификатор cвойства Оценка в ведомости.
ИД значения Да свойства Оценка в ведомости | Выбирается идентификатор значения Да свойства Оценка в ведомости.
ИД свойства Уведомление отправлено | Выбирается идентификатор свойства Уведомление отправлено.
ИД значения Да свойства Уведомление отправлено | Выбирается идентификатор значения Да свойства Уведомление отправлено.
Инфоблок библиотеки групп экстранет | Для указанного типа инфоблоков выбирается инфоблок библиотеки групп экстранет.
ИД свойства Оценка | Выбирается идентификатор свойства Оценка.
ИД свойства Оценка в ведомости | Выбирается идентификатор свойства Оценка в ведомости.
ИД значения Да свойства Оценка в ведомости | Выбирается идентификатор значения Да свойства Оценка в ведомости.
ИД свойства Уведомление отправлено | Выбирается идентификатор свойства Уведомление отправлено.
ИД значения Да свойства Уведомление отправлено | Выбирается идентификатор значения Да свойства Уведомление отправлено.
Другие настройки
ИД значения активного статуса студента | Выбирается идентификатор значения активного статуса студента.
ИД темы рабочей группы предметов | Выбирается идентификатор темы рабочей группы предметов.
Группа пользователей Студенты | Выбирается группа пользователей Студенты.


Компоненты

  • Визуальная структура компании
  • Дни рождения
  • Меню
  • Поиск сотрудника
  • Предметы пользователя
  • Список сотрудников
  • Учебные группы пользователя
  • Фильтр по элементам
  • Форма поиска


Визуальная структура компании

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Внутренний портал учебного заведения>Компоненты>Визуальная структура компании

Компоненты::Визуальная структура компании

Описание intranet.structure.visual

Выводит всплывающее окно с информацией. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Разное > Всплывающее облако.

Параметры

Поле | Параметр | Описание
Основные параметры
Страница структуры компании | DETAIL_URL | Указывается путь к странице структуры учебного заведения.
Страница профиля пользователя | PROFILE_URL | Указывается путь к странице с профиля пользователя.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет выводиться логин, если не указано имя в профиле сотрудника.
Выводить всплывающие информационные карточки пользователей | USE_USER_LINK | [Y|N] При отмеченной опции будут выводиться всплывающие информационные карточки сотрудников.
Тип инфо-блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационных блоков.
Инфо-блок | IBLOCK_ID | Для выбранного типа инфоблока указывается инфоблок.
Разрешить настройку отображения состава групп | ALLOW_SET_USER_VIEW | [Y|N] При отмеченной опции будет разрешена настройка отображения состава групп.
Отображение состава групп DEFAULT_USER_VIEW Выбирается формат отображения состава групп по умолчанию:
  • Все;
  • Активный состав.
Путь к рабочей группе | PATH_TO_GROUP | Указывается шаблон ссылки на страницу рабочей группы.
Источник данных
Свойства разделов | SECTION_USER_FIELDS | С помощью клавиши Ctrl выбираются свойства разделов.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
"campus:intranet.structure.visual",
    "",
    Array(
        "DETAIL_URL" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "PROFILE_URL" => "/company/personal/user/#ID#/",
        "PM_URL" => "/company/personal/messages/chat/#ID#/",
        "NAME_TEMPLATE" => "#LAST_NAME#, #NAME# #SECOND_NAME#",
        "SHOW_LOGIN" => "Y",
        "USE_USER_LINK" => "Y",
        "IBLOCK_TYPE" => "structure",
        "IBLOCK_ID" => "5",
        "SECTION_USER_FIELDS" => array("UF_HEAD"),
        "ALLOW_SET_USER_VIEW" => "Y",
        "DEFAULT_USER_VIEW" => "all",
        "PATH_TO_GROUP" => "/workgroups/group/#GROUP_ID#/",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "2592000"
    )
);?>


Дни рождения

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Внутренний портал учебного заведения>Компоненты>Дни рождения

Компоненты::Дни рождения

Описание intranet.structure.birthday.nearest

Компонент выводит список ближайших именинников. Компонент доступен при использовании решения Внутренний портал учебного заведения и содержит следующие шаблоны: .default и include_area. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > HR.

Параметры

Поле | Параметр | Описание
Дополнительно
Отображать фильтр | SHOW_FILTER | [Y|N] При отмеченной опции будет отображатся панель выбора подразделения. Если опция не отмечена, то будет показан весь список именниников.
Показывать год рождения SHOW_YEAR Поле определяет кому показываеть год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).
Пользовательские поля для вывода | USER_PROPERTY | Указываются поля пользователей, которые будут показаны в визитных карточках сотрудников.
Отдел/офис | DEPARTMENT | Указывается офис, филиал или отдел, список ближайших именинников которого будет отображен.
Фильтрация на сайте экстранета EXTRANET_TYPE Выбирается фильтрация на сайте экстранета:
  • Контакты;
  • Сотрудники.
Группы пользователей | SHOW_GROUP_ID | C помощью клавиши Ctrl выбираются группы пользователей.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение Y, то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Основные параметры
Страница структуры компании | STRUCTURE_PAGE | Указывается путь к странице структуры компании.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается шаблон пути к странице подразделения компании.
Имя фильтра страницы структуры компании | STRUCTURE_FILTER | Задается имя фильтра страницы структуры компании.
Количество выводимых пользователей | NUM_USERS | Параметр определяет количество отображаемых на странице записей.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Дополнительные настройки
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты без года | DATE_FORMAT_NO_YEAR | Указывается формат показа даты без года. В выпадающем списке перечислены все возможные варианты показа даты без года, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты и времени, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
"campus:intranet.structure.birthday.nearest",
    "",
    Array(
        "SHOW_FILTER" => "Y",
        "AJAX_MODE" => "Y",
        "STRUCTURE_PAGE" => "structure.php",
        "PM_URL" => "/company/personal/messages/chat/#USER_ID#/",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "STRUCTURE_FILTER" => "structure",
        "NUM_USERS" => "10",
        "NAME_TEMPLATE" => "#LAST_NAME# #NAME# #SECOND_NAME#",
        "SHOW_LOGIN" => "Y",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_FORMAT_NO_YEAR" => "d.m",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_YEAR" => "Y",
        "USER_PROPERTY" => array("PERSONAL_PHOTO"),
        "DEPARTMENT" => "73",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SHOW_GROUP_ID" => array("5"),
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Меню

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Внутренний портал учебного заведения>Компоненты>Меню

Компоненты::Меню

Описание menu

Компонент выводит меню указанного типа. Компонент доступен при использовании решения Внутренний портал учебного заведения и содержит следующие шаблоны: Вертикальное меню по умолчанию, Вертикальное многоуровневое выпадающее меню.

Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Служебные > Навигация.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип меню для первого уровня | ROOT_MENU_TYPE | Указывается тип меню верхнего уровня, соответствующий данному меню.
Дополнительные настройки
Уровень вложенности меню | MAX_LEVEL | В выпадающем списке выберите уровень вложенности. Доступно четыре уровня. Чем больше число, тем пункты более низких уровней будут отображены. Только те шаблоны меню, которые являются многоуровневыми, принимают значения, отличные от 1.
Тип меню для остальных уровней | CHILD_MENU_TYPE | Укажите тип меню для меню нижних уровней.
Подключать файлы с именами вида .тип_меню.menu_ext.php | USE_EXT | [Y|N] При отмеченной опции будет разрешено подключать файлы с именами вида .тип_меню.menu_ext.php.
Откладывать выполнение шаблона меню DELAY [Y|N] При отмеченной опции выполнение шаблона будет происходить после загрузки страницы. Очень удобен при включенном кешировании компонента, если нужно все же выполнять какие-то действия по модификации внешнего вида пунктов меню в зависимости от текущей страницы. Например, добавление пунктов меню в компонентах.
$GLOBALS['BX_MENU_CUSTOM']->AddItem('left', array(

'TEXT' => 'Моб. версия', 'LINK' => $APPLICATION->

GetCurPage(false) . '?mobile'))

Первый параметр - тип меню. Второй - массив, описывающий пункт меню [image].

Разрешить несколько активных пунктов одновременно | ALLOW_MULTI_SELECT | [Y|N] При отмеченной опции будет разрешено несколько активных пунктов меню одновременно.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто: автоматически обновляет кеш компонентов в течение заданного времени;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования | MENU_CACHE_TIME | Время кеширования в секундах.
Учитывать права доступа | MENU_CACHE_USE_GROUPS | При кешировании будут учитываться права доступа пользователя к тем или иным пунктам меню. Если меню построено без учета прав доступа, флажок лучше снять - размер кеша уменьшится.
Значимые переменные запроса | MENU_CACHE_GET_VARS | Если отображение меню зависит от параметров страницы, то при использовании кеширования необходимо указать параметры в этом поле. Параметры вводятся через запятую.
Дополнительно
Путь к разделу меню | MENU_DIR | Указывается шаблон пути к разделу меню.

Пример вызова

<?$APPLICATION->IncludeComponent(
"campus:menu",
    "",
    Array(
        "ROOT_MENU_TYPE" => "left",
        "MAX_LEVEL" => "1",
        "CHILD_MENU_TYPE" => "left",
        "USE_EXT" => "Y",
        "DELAY" => "Y",
        "ALLOW_MULTI_SELECT" => "Y",
        "MENU_CACHE_TYPE" => "N",
        "MENU_CACHE_TIME" => "3600",
        "MENU_CACHE_USE_GROUPS" => "Y",
        "MENU_CACHE_GET_VARS" => array(),
        "MENU_DIR" => ""
    )
);?>


Поиск сотрудника

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Внутренний портал учебного заведения>Компоненты>Поиск сотрудника

Компоненты::Поиск сотрудника

Описание intranet.search

Комплексный компонент выводит комплексную форму поиска сотрудников. Компонент доступен при использовании решения Внутренний портал учебного заведения. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Оргструктура.

Параметры

Поле | Параметр | Описание
Дополнительно
Представление по умолчанию DEFAULT_VIEW Указывается способ вывода результатов поиска по умолчанию:
  • список (list);
  • таблица (table).
Шаблон для представления в виде списка LIST_VIEW Указывается способ для представления в виде списка:
  • простой список (list);
  • с группировкой по отделам (group).

Если параметр принимает значение group, то необходимо настроить следущий параметр: EXTRANET_TYPE.
Шаблон для представления в виде таблицы TABLE_VIEW Указывается способ для представления в виде списка:
  • простой список (list);
  • с группировкой по отделам (group).
Пользовательские поля для вывода в табличном представлении | USER_PROPERTY_TABLE | Указываются поля, которые должны быть отображены при выводе списка сотрудников в табличном представлении.
Пользовательские поля для вывода в формате Excel | USER_PROPERTY_EXCEL | Указываются поля, которые должны быть выгружены при выполнении экспорта сотрудников в MS Excel.
Пользовательские поля для вывода в представлении в виде списка | USER_PROPERTY_LIST | Указываются поля, которые должны быть отображены при выводе сотрудников в виде простого списка.
Фильтрация на сайте экстранета EXTRANET_TYPE Выбирается фильтрация на сайте экстранта:
  • Контакты;
  • Сотрудники.
Группы пользователей | SHOW_GROUP_ID | С помощью клавиши Ctrl выбираются группы пользователей.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При отмеченной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение Y, то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера Назад и Вперед.
Основные параметры
Страница структуры компании | STRUCTURE_PAGE | Указывается путь к странице структуры компании.
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается шаблон пути к странице подразделения компании.
Имя фильтра страницы структуры компании | STRUCTURE_FILTER | Указывается имя фильтра страницы структуры компании.
Выводить только синхронизируемых с 1С пользователей | FILTER_1C_USERS | [Y|N] При отмеченной опции будут выводиться только синхронизируемые с 1С пользователи.
Количество пользователей на страницу | USERS_PER_PAGE | Поле определяет количество пользователей, отображаемых на одной странице. Весь список будет отображен с помощью постраничной навигации.
Фильтр по подразделениям FILTER_SECTION_CURONLY Указывается тип фильтра по подразделениям:
  • прямой (Y);
  • рекурсивный (N).
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.
Выводить уведомление при пустом списке | SHOW_ERROR_ON_NULL | [Y|N] При отмеченной опции выводится уведомление при пустом списке.
Отображать фильтр по алфавиту на языках | ALPHABET_LANG | Задаются языки для показа фильтра по алфавиту.
Подпись постраничной навигации | NAV_TITLE | Поле содержит подпись для постраничной навигации.
Показывать постраничную навигацию над списком | SHOW_NAV_TOP | [Y|N] При отмеченной опции постраничная навигация будет показываться над списком.
Показывать постраничную навигацию под списком | SHOW_NAV_BOTTOM | [Y|N] При отмеченной опции постраничная навигация будет показываться под списком.
Показывать список при пустом фильтре | SHOW_UNFILTERED_LIST | [Y|N] При отмеченной опции будет выведен весь список сотрудников. Если опция не отмечена, то будет показана только форма поиска.
Параметры фильтра
Имя фильтра (для внешних форм фильтрации) | FILTER_NAME | Указывается имя фильтра (для внешних форм фильтрации).
Вложенность подразделений для поиска | FILTER_DEPARTMENT_DEPTH | Указывается вложенность подразделений для поиска.
Выбор подразделения для фильтрации FILTER_DEPARTMENT_SINGLE Указывается способ выбора подразделения(ий) в форме поиска:
  • одинарный (Y) - в выпадающем списке можно выбрать только одно подразделение;
  • множественный (N) - поле позволяет выбирать несколько подразделений.
Запоминать фильтр в сессии | FILTER_SESSION | [Y|N] При отмеченной опции введеные значения в поля формы поиска будут запоминаться системой.
Фильтр по должности | FILTER_POSITION | [Y|N] При отмеченной опции будет доступен фильтр по должности.
Дополнительные настройки
Формат показа даты | DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты без года | DATE_FORMAT_NO_YEAR | Указывается формат показа даты без года. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты и времени, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать год рождения SHOW_YEAR Поле определяет кому показываеть год рождения:
  • всем (Y);
  • только мужчинам (M);
  • никому (N).
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
"campus:intranet.search",
    "",
    Array(
        "DEFAULT_VIEW" => "list",
        "LIST_VIEW" => "group",
        "TABLE_VIEW" => ".default",
        "USER_PROPERTY_TABLE" => array("PERSONAL_PHOTO"),
        "USER_PROPERTY_EXCEL" => array("FULL_NAME"),
        "USER_PROPERTY_GROUP" => array("ID"),
        "AJAX_MODE" => "N",
        "STRUCTURE_PAGE" => "structure.php",
        "PM_URL" => "/company/personal/messages/chat/#USER_ID#/",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "STRUCTURE_FILTER" => "structure",
        "FILTER_1C_USERS" => "Y",
        "FILTER_NAME" => "users",
        "FILTER_DEPARTMENT_DEPTH" => "3",
        "USERS_PER_PAGE" => "20",
        "FILTER_DEPARTMENT_SINGLE" => "Y",
        "FILTER_SESSION" => "Y",
        "FILTER_POSITION" => "N",
        "FILTER_SECTION_CURONLY" => "N",
        "NAME_TEMPLATE" => "#LAST_NAME#, #NAME# #SECOND_NAME#",
        "SHOW_LOGIN" => "Y",
        "SHOW_ERROR_ON_NULL" => "Y",
        "ALPHABET_LANG" => array("ru","ru"),
        "NAV_TITLE" => "Сотрудники",
        "SHOW_NAV_TOP" => "Y",
        "SHOW_NAV_BOTTOM" => "Y",
        "SHOW_UNFILTERED_LIST" => "N",
        "DATE_FORMAT" => "d.m.Y",
        "DATE_FORMAT_NO_YEAR" => "d.m",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "SHOW_YEAR" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SHOW_GROUP_ID" => array("5"),
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Предметы пользователя

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Внутренний портал учебного заведения>Компоненты>Предметы пользователя

Компоненты::Предметы пользователя

Описание my_disciplines

Компонент позволяет просмотреть предметы, которые пользователь изучает или преподает. Компонент доступен при использовании решения Внутренний портал учебного заведения и содержит следующие шаблоны: .default и widget. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Основные параметры
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается путь к странице подразделения.
Страница видеозвонка | PATH_TO_VIDEO_CALL | Указывается путь к странице видеозвонка.
Количество отображаемых групп | GROUP_COUNT | Указывается число отображаемых групп.
Показывать ссылку "Все" | SHOW_LINK_ALL | [Y|N] При значении Y будет добавлена ссылка Все.
Показывать цепочку навигации | SHOW_NAV | [Y|N] При значении Y будет выведена цепочка навигации.
Устанавливать заголовок страницы | SET_PAGE_TITLE | [Y|N] При значении Y в качестве заголовка страницы будет установлено Мои предметы.
Поле для сортировки | SORT_BY1 | Указывается поле, по которому будет производиться сортировка.
Направление для сортировки | SORT_ORDER1 | Задается направление для сортировки.
Дополнительно
ИД пользователя | USER_ID | Указывается идентификатор пользователя.
URL страницы рабочей группы | WORKGROUP_URL | Указывается шаблон пути к странице рабочей группы.
URL страницы пользователя | USER_URL | Указывается шаблон пути к странице пользователя.
Только активные студенты | SHOW_ACTIVE | [Y|N] При отмеченной опции будет отображаться информация только по активным студентам.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "campus:my_disciplines",
    "",
    Array(
        "USER_ID" => "1",
        "WORKGROUP_URL" => "/workgroups/group/#GROUP_ID#/",
        "USER_URL" => "/company/personal/user/#USER_ID#/",
        "SHOW_ACTIVE" => "Y",
        "PM_URL" => "/company/personal/messages/chat/#USER_ID#/",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "PATH_TO_VIDEO_CALL" => "/company/personal/video/#USER_ID#/",
        "GROUP_COUNT" => "10",
        "SHOW_LINK_ALL" => "N",
        "SHOW_NAV" => "N",
        "SET_PAGE_TITLE" => "N",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC"
    )
);?>


Список сотрудников

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Внутренний портал учебного заведения>Компоненты>Список сотрудников

Компоненты::Список сотрудников

Описание intranet.structure.list

Компонент выводит список сотрудников, удовлетворяющих внешнему фильтру. Компонент доступен при использовании решения Внутренний портал учебного заведения и содержит два шаблона: .default и .list.Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Оргструктура.

Параметры

Поле | Параметр | Описание
Дополнительно
Параметры для вывода в списке | USER_PROPERTY | Указываются поля пользователей, которые будут показаны в визитных карточках сотрудников.
Параметры для вывода в Excel | USER_PROPERTY_EXCEL | Указываются поля пользователей, которые должны быть выгружены при выполнении экспорта сотрудников в MS Excel.
Страница отправки личного сообщения PM_URL Указывается путь к странице отправки личного сообщения.

Данное поле доступно только для шаблона .list.
Дополнительные поля для вывода USER_PROPERTY Указываются, какие поля будут выводиться в списке сотрудников, удовлетворяющих внешнему фильтру.

Данное поле доступно только для шаблона .list.
Параметры фильтра
Имя фильтра | FILTER_NAME | Указывается имя фильтра.
Основные параметры
Выводить только синхронизируемых с 1С пользователей | FILTER_1C_USERS | [Y|N] При отмеченной опции будут выводиться только синхронизируемые с 1С пользователи.
Фильтр по подразделениям FILTER_SECTION_CURONLY Указывается тип фильтра по подразделениям:
  • прямой (Y);
  • рекурсивный (N).
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Выводить уведомление при пустом списке | SHOW_ERROR_ON_NULL | [Y|N] При отмеченной опции будет выводиться уведомление при пустом списке.
Количество пользователей на страницу | USERS_PER_PAGE | Поле определяет количество пользователей, отображаемых на одной странице. Весь список будет отображен с помощью постраничной навигации.
Подпись постраничной навигации | NAV_TITLE | Указывается подпись для постраничной навигации.
Показывать постраничную навигацию над списком | SHOW_NAV_TOP | [Y|N] При отмеченной опции постраничная навигация будет показываться над списком.
Показывать постраничную навигацию под списком | SHOW_NAV_BOTTOM | [Y|N] При отмеченной опции постраничная навигация будет показываться под списком.
Показывать список при пустом фильтре | SHOW_UNFILTERED_LIST | [Y|N] Если условия поиска не заданы, то при отмеченной опции будет выведен весь список сотрудников.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
"campus:intranet.structure.list",
    "",
    Array(
        "USER_PROPERTY" => array("ID"),
        "USER_PROPERTY_EXCEL" => array("LOGIN"),
        "FILTER_NAME" => "users",
        "FILTER_1C_USERS" => "Y",
        "FILTER_SECTION_CURONLY" => "N",
        "NAME_TEMPLATE" => "#LAST_NAME#, #NAME# #SECOND_NAME#",
        "SHOW_ERROR_ON_NULL" => "Y",
        "USERS_PER_PAGE" => "10",
        "NAV_TITLE" => "Сотрудники",
        "SHOW_NAV_TOP" => "Y",
        "SHOW_NAV_BOTTOM" => "Y",
        "SHOW_UNFILTERED_LIST" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Учебные группы пользователя

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Внутренний портал учебного заведения>Компоненты>Учебные группы пользователя

Компоненты::Учебные группы пользователя

Описание my_edu_groups

Компонент позволяет просмотреть учебные группы, в которых пользователь состоит или преподает. Компонент доступен при использовании решения Внутренний портал учебного заведения и содержит следующие шаблоны: .default и widget. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Общение > Социальная сеть.

Параметры

Поле | Параметр | Описание
Основные параметры
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Шаблон пути к странице подразделения | PATH_TO_CONPANY_DEPARTMENT | Указывается путь к странице подразделения.
Страница видеозвонка | PATH_TO_VIDEO_CALL | Указывается путь к странице видеозвонка.
Путь к странице со списком учащихся в группе | PATH_TO_CONTACTS | Указывается шаблон пути к странице со списком учащихся в группе.
Количество отображаемых групп | GROUP_COUNT | Указывается число отображаемых групп.
Показывать ссылку "Все" | SHOW_LINK_ALL | [Y|N] При значении Y будет добавлена ссылка Все.
Показывать цепочку навигации | SHOW_NAV | [Y|N] При значении Y будет выведена цепочка навигации.
Устанавливать заголовок страницы | SET_PAGE_TITLE | [Y|N] При значении Y в качестве заголовка страницы будет установлено Мои учебные группы.
Дополнительно
ИД пользователя | USER_ID | Указывается идентификатор пользователя.
URL страницы рабочей группы | WORKGROUP_URL | Указывается шаблон пути к странице рабочей группы.
URL страницы пользователя | USER_URL | Указывается шаблон пути к странице пользователя.
Только активные студенты | SHOW_ACTIVE | [Y|N] При отмеченной опции будет отображаться информация только по активным студентам.

Пример вызова

<?$APPLICATION->IncludeComponent(
    "campus:my_edu_groups",
    "",
    Array(
        "USER_ID" => "473",
        "WORKGROUP_URL" => "/workgroups/group/#GROUP_ID#/",
        "USER_URL" => "/company/personal/user/#USER_ID#/",
        "SHOW_ACTIVE" => "Y",
        "PM_URL" => "/company/personal/messages/chat/#USER_ID#/",
        "PATH_TO_CONPANY_DEPARTMENT" => "/company/structure.php?set_filter_structure=Y&structure_UF_DEPARTMENT=#ID#",
        "PATH_TO_VIDEO_CALL" => "/company/personal/video/#USER_ID#/",
        "PATH_TO_CONTACTS" => "/extranet/contacts/",
        "GROUP_COUNT" => "10",
        "SHOW_LINK_ALL" => "N",
        "SHOW_NAV" => "N",
        "SET_PAGE_TITLE" => "N"
    )
);?>


Фильтр по элементам

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Внутренний портал учебного заведения>Компоненты>Фильтр по элементам

Компоненты::Фильтр по элементам

Описание catalog.filter

Компонент выводит форму фильтра для фильтрации элементов информационых блоков. Компонент доступен при использовании решения Внутренний портал учебного заведения. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути Компоненты > Контент > Каталог.

Параметры

Поле | Параметр | Описание
Источник данных
Тип инфо-блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфо-блок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, элементы которого будут отфильтрованы.
Имя выходящего массива для фильтрации | FILTER_NAME | Задается имя переменной, в которую передается массив параметров из фильтра. Если имя массива не указано, то будет использоваться значение по умолчанию.
Поля FIELD_CODE Указываются дополнительные поля элементов инфоблока, по которым будет возможна фильтрация. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания полей в строках (т.е. если задан пустой массив), будут выведены поля по умолчанию.
Свойства PROPERTY_CODE Указываются свойства инфоблока, которые будут отображены при показе в качестве полей фильтра. При выборе пункта (не выбрано)-> и без указания кодов свойств в строках, свойства выведены не будут.

Значения свойств типа "Список" отображаются в фильтре в соответствии с настройками, заданными в форме редактирования самого свойства (поле "Внешний вид").
Поля предложений | OFFERS_FIELD_CODE | Выбираются поля предложений. С помощью клавиши Ctrl можно выбрать несколько значений. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Свойства предложений | OFFERS_PROPERTY_CODE | Указываются свойства предложений. Можно добавлять свои. Данный параметр появляется при настройке компонента на инфоблок с поддержкой SKU.
Цены
Тип цены | PRICE_CODE | Указывается тип цены для выводимых элементов. Если не задан ни один из типов, то цена товара и кнопки Купить и В корзину показаны не будут.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Внешний вид
Высота списков множественного выбора | LIST_HEIGHT | Указывается высота множественных списков выбора, отображаемых в фильтре.
Ширина однострочных текстовых полей ввода | TEXT_WIDTH | Указывается ширина текстового поля ввода в форме фильтра.
Ширина полей ввода для числовых интервалов | NUMBER_WIDTH | Указывается ширина полей ввода для числовых интервалов в форме фильтра.
Дополнительные настройки
Сохранять установки фильтра в сессии пользователя | SAVE_IN_SESSION | [Y|N] При отмеченной опции установки фильтра будут сохраняться в сессии пользователя.

Пример вызова

<?$APPLICATION->IncludeComponent (
"campus:catalog.filter",
    "",
    Array(
        "IBLOCK_TYPE" => "news",
        "IBLOCK_ID" => "2",
        "FILTER_NAME" => "arrFilter",
        "FIELD_CODE" => array("ID"),
        "PROPERTY_CODE" => array("DOC_TYPE"),
        "PRICE_CODE" => array(),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_GROUPS" => "Y",
        "LIST_HEIGHT" => "5",
        "TEXT_WIDTH" => "20",
        "NUMBER_WIDTH" => "5",
        "SAVE_IN_SESSION" => "Y"
    )
);?>


Форма поиска

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Внутренний портал учебного заведения>Компоненты>Форма поиска

Компоненты::Форма поиска

Описание intranet.structure.selector

Компонент выводит форму фильтрации списка сотрудников. Компонент доступен при использовании решения Внутренний портал учебного заведения и содержит следующие шаблоны: .default, .alphabet, .include_area, online, .sections. Компонент является стандартным и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Корпоративный портал > Оргструктура.

Параметры

Поле | Параметр | Описание
Дополнительно (только для шаблона .sections)
Количество колонок | COLUMNS | Указывается количество колонок в секции.
Количество колонок на первой странице | COLUMNS_FIRST | Указывается количество колонок на первой странице.
Максимальная глубина дерева (0 - все) | MAX_DEPTH | Указывается максимальная глубина дерева.
Максимальная глубина дерева на первой странице (0 - все) | MAX_DEPTH_FIRST | Указывается максимальная глубина дерева на первой странице.
Выводить информацию о подразделении | SHOW_SECTION_INFO | [Y|N] При отмеченной опции в результах поиска будет выводиться информация о подразделении.
Основные параметры
Страница списка пользователей | LIST_URL | Указывается путь к странице со списком пользователей.
Параметры фильтра
Имя фильтра | FILTER_NAME | Указывается имя фильтра.
Выбор подразделения для фильтрации FILTER_DEPARTMENT_SINGLE Указывается способ выбора подразделения(ий) в форме поиска:
  • одинарный (Y) - в выпадающем списке можно выбрать только одно подразделение;
  • множественный (N) - поле позволяет выбирать несколько подразделений.
Запоминать фильтр в сессии | FILTER_SESSION | [Y|N] При отмеченной опции введенные значения в поля формы поиска будут запоминаться системой.
Вложенность подразделений для поиска | FILTER_DEPARTMENT_DEPTH | Указывается глубина вложенности подразделений для поиска.

Пример вызова

<?$APPLICATION->IncludeComponent(
"campus:intranet.structure.selector",
    "",
    Array(
        "LIST_URL" => "",
        "FILTER_NAME" => "users",
        "FILTER_DEPARTMENT_SINGLE" => "Y",
        "FILTER_SESSION" => "Y",
        "FILTER_DEPARTMENT_DEPTH" => "3"
    )
);?>


Сайт школы

Данное решение [image] в базовом варианте реализовано в редакции 1С-Битрикс: Управление сайтом "Старт". В расширенном - в редакции "Эксперт".


Модуль школьного расписания

Данный модуль доступен при использовании расширенного варианта решения Сайт школы.

Форма настроек Модуля школьного расписания (Настройки > Настройки продукта > Настройки модулей > 1С-Битрикс: Модуль школьного расписания) предназначена для задания общесистемных параметров модуля.

Поле | Описание
Настройки инфоблоков
Тип инфоблока | Выбирается тип инфоблока расписания.
Инфоблок предметов | Выбирается инфоблок предметов.
Инфоблок классов | Выбирается инфоблок классов.
Инфоблок кабинетов | Выбирается инфоблок кабинетов.
Дополнительные настройки
Группа учителей | Выбирается группа учителей.
Группа учащихся | Выбирается группа учащихся.
Типы оценок
Символьный код | Индивидуальный код типа оценки.
Полное название | Полное наименование типа оценки.
Короткое название | Сокращенное наименование типа оценки.
Значения оценок
Значение | Значение оценки.
Цвет | Цвет, соответствующий значению оценки.


Компоненты

  • Дневник ученика
  • Дневник ученика (для родителя)
  • Дневник ученика (для ученика)
  • Добавление ученика родителем
  • Журнал
  • Журнал учителя (комплексный компонент)
  • Коллектив
  • Список классов для учителя
  • Список классов и предметов учителя
  • Список учащихся
  • Список учащихся (комплексный компонент)
  • Список учеников одного родителя
  • Урок
  • Школьное расписание


Дневник ученика

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Дневник ученика

Компоненты::Дневник ученика

Описание school.student.diary

Одностраничный компонент для отображения дневника ученика. Компонент доступен при использовании расширенного варианта решения Сайт школы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Школа > Дневник ученика.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Скрывать ссылку, если нет детального описания | HIDE_LINK_WHEN_NO_DETAIL | [Y|N] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр..
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационных блоков.
Код информационного блока, в котором хранятся уроки | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок, в котором хранятся уроки.
ID ученика | USER_ID | Указывается идентификатор ученика.
Формат даты | ACTIVE_DATE_FORMAT | Выбирается формат даты.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Шаблоны ссылок
URL страницы детального просмотра | DETAIL_URL | Указывается путь к странице детального просмотра. По умолчанию - из настроек инфоблока.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:school.student.diary",
    "",
    Array(
        "IBLOCK_TYPE" => "library",
        "IBLOCK_ID" => "8",
        "USER_ID" => IntVal($_REQUEST["USER_ID"]),
        "DETAIL_URL" => "",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "HIDE_LINK_WHEN_NO_DETAIL" => "Y",
        "AJAX_MODE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y"
    )
);?>


Дневник ученика (для родителя)

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Дневник ученика (для родителя)

Компоненты::Дневник ученика (для родителя)

Описание school.diaries_parent

Комплексный компонент для отображения дневника. Компонент доступен при использовании расширенного варианта решения Сайт школы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Школа > Дневник ученика (для родителя).

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип инфо-блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Инфо-блок | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок.
Формат даты | ACTIVE_DATE_FORMAT | Выбирается формат даты.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • diary - страница дневника;
  • lesson - страница урока.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:school.diaries_parent",
    "",
    Array(
        "SEF_MODE" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "schedule",
        "IBLOCK_ID" => "12",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_GROUPS" => "Y",
        "SEF_FOLDER" => "/about/achievements/",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y",
        "SEF_URL_TEMPLATES" => Array(
            "diary" => "#USER_ID#/",
            "lesson" => "#USER_ID#/#ELEMENT_ID#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "log" => Array(),
            "lesson" => Array(),
            "classes" => Array(),
            "diary" => Array(),
        )
    )
);?>


Дневник ученика (для ученика)

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Дневник ученика (для ученика)

Компоненты::Дневник ученика (для ученика)

Описание school.diaries

Комплексный компонент для отображения дневника. Компонент доступен при использовании расширенного варианта решения Сайт школы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Школа > Дневник ученика (для ученика).

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип инфо-блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Инфо-блок | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок.
Формат даты | ACTIVE_DATE_FORMAT | Выбирается формат даты.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • lesson - страница урока.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:school.diaries",
    "",
    Array(
        "SEF_MODE" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "schedule",
        "IBLOCK_ID" => "12",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_GROUPS" => "Y",
        "SEF_FOLDER" => "/about/achievements/",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y",
        "SEF_URL_TEMPLATES" => Array(
            "lesson" => "#ELEMENT_ID#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "log" => Array(),
            "lesson" => Array(),
            "classes" => Array(),
        )
    )
);?>


Добавление ученика родителем

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Добавление ученика родителем

Компоненты::Добавление ученика родителем

Описание school.parent.students.add

Одностраничный компонент для добавления ученика родителем. Компонент доступен при использовании расширенного варианта решения Сайт школы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Школа.

Параметры

Поле | Параметр | Описание
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:school.parent.students.add",
    "",
    Array(
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_NOTES" => "",
        "CACHE_GROUPS" => "Y"
    )
);?>


Журнал

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Журнал

Компоненты::Журнал

Описание school.logs.detail

Одностраничный компонент для отображения журнала. Компонент доступен при использовании расширенного варианта решения Сайт школы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Школа > Журнал учителя.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока выбирается инфоблок.
Дополнительные настройки
Формат показа даты | ACTIVE_DATE_FORMAT | Выбирается формат показа даты.
ID класса | CLASS_ID | Указывается идентификатор класса.
ID предмета | SUBJECT_ID | Указывается идентификатор предмета.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Шаблоны ссылок
URL страницы урока | DETAIL_URL | Указывается путь к странице урока.

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:school.logs.detail",
    "",
    Array(
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "schedule",
        "IBLOCK_ID" => "12",
        "DETAIL_URL" => "/teachers/logs/#CLASS_ID#/#SUBJECT_ID#/#ELEMENT_ID#/",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "CLASS_ID" => intVal($_REQUEST["CLASS_ID"]),
        "SUBJECT_ID" => intVal($_REQUEST["SUBJECT_ID"]),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Журнал учителя (комплексный компонент)

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Журнал учителя (комплексный компонент)

Компоненты::Журнал учителя (комплексный компонент)

Описание school.logs

Комплексный компонент для отображения журналов. Компонент доступен при использовании расширенного варианта решения Сайт школы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Школа > Журнал учителя.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип инфо-блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Инфо-блок классов | CLASSES_IBLOCK_ID | Для выбранного типа инфоблока выбирается инфоблок классов.
Инфо-блок предметов | SUBJECTS_IBLOCK_ID | Для выбранного типа инфоблока выбирается инфоблок предметов.
Инфо-блок уроков | LESSONS_IBLOCK_ID | Для выбранного типа инфоблока выбирается инфоблок уроков.
ID класса | CLASS_ID | Указывается идентификатор класса.
ID предмета | SUBJECT_ID | Указывается идентификатор предмета.
ID урока | ELEMENT_ID | Указывается идентификатор урока.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • classes - страница списка классов и предметов;
  • log - страница журнала;
  • lesson - страница урока.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
Настройки журнала
Количество дней на странице | DAYS_COUNT | Указывается число дней, отображаемых на странице журнала.
Формат показа даты | ACTIVE_DATE_FORMAT | Выбирается формат показа даты.
Настройки урока
Формат показа даты | LESSON_DATE_FORMAT | Выбирается формат показа даты.

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:school.logs",
    "",
    Array(
        "SEF_MODE" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "schedule",
        "CLASSES_IBLOCK_ID" => "11",
        "SUBJECTS_IBLOCK_ID" => "10",
        "LESSONS_IBLOCK_ID" => "10",
        "CLASS_ID" => intVal($_REQUEST["CLASS_ID"]),
        "SUBJECT_ID" => intVal($_REQUEST["SUBJECT_ID"]),
        "ELEMENT_ID" => intVal($_REQUEST["ELEMENT_ID"]),
        "DAYS_COUNT" => "5",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "LESSON_DATE_FORMAT" => "d.m.Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "SEF_FOLDER" => "/about/achievements/",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y",
        "SEF_URL_TEMPLATES" => Array(
            "log" => "#CLASS_ID#/#SUBJECT_ID#/",
            "lesson" => "#CLASS_ID#/#SUBJECT_ID#/#ELEMENT_ID#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "log" => Array(),
            "lesson" => Array(),
        )
    )
);?>


Коллектив

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Коллектив

Компоненты::Коллектив

Описание staff.list

Одностраничный компонент для вывода списка сотрудников школы. Компонент доступен при использовании расширенного варианта решения Сайт школы и содержит два шаблона: staff и urban. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Контент > Новости.

Параметры

Поле | Параметр | Описание
Дополнительно
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будут выведены даты элементов.
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции будет выведено название элемента.
Выводить изображение для анонса | DISPLAY_PICTURE | [Y|N] При отмеченной опции для элемента будут выведены изображения (анонс и детальная картинка), если они заданы. Если флаг снят, то никакое изображение показано не будет.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационных блоков. Используется только для проверки.
Код информационного блока | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кешировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:staff.list",
    "staff",
    Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "IBLOCK_TYPE" => "school",
        "IBLOCK_ID" => $_REQUEST["ID"],
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_FILTER" => "Y",
        "CACHE_GROUPS" => "Y"
    )
);?>


Список классов для учителя

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Список классов для учителя

Компоненты::Список классов для учителя

Описание school.teacher.classes.list

Одностраничный компонент выводит список классов для учителя. Компонент доступен при использовании расширенного варианта решения Сайт школы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Школа > Список учащихся.

Параметры

Поле | Параметр | Описание
Дополнительно
Пользовательские поля для вывода | USER_PROPERTY | С помощью клавиши Ctrl выбираются поля для вывода.
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Инфоблок классов | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок классов.
URL страницы детального просмотра | DETAIL_URL | Указывается путь к странице детального просмотра (по умолчанию - из настроек инфоблока).
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:school.teacher.classes.list",
    "",
    Array(
        "IBLOCK_TYPE" => "events",
        "IBLOCK_ID" => "1",
        "DETAIL_URL" => "/teachers/lists_students/#CLASS_ID#/",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_NOTES" => "",
        "SET_TITLE" => "Y"
    )
);?>


Список классов и предметов учителя

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Список классов и предметов учителя

Компоненты::Список классов и предметов учителя

Описание school.logs.list

Одностраничный компонент для отображения списка классов и предметов учителя. Компонент доступен при использовании расширенного варианта решения Сайт школы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Школа > Журнал учителя.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Инфоблок классов | CLASSES_IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок классов.
Инфоблок предметов | SUBJECTS_IBLOCK_ID | Выбирается инфоблок предметов.
URL страницы детального просмотра | DETAIL_URL | Указывается путь к странице детального просмотра (по умолчанию - из настроек инфоблока).
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:school.logs.list",
    "",
    Array(
        "IBLOCK_TYPE" => "schedule",
        "CLASSES_IBLOCK_ID" => "11",
        "SUBJECTS_IBLOCK_ID" => "10",
        "DETAIL_URL" => "/teachers/logs/#CLASS_ID#/#SUBJECT_ID#/",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000"
    )
);?>


Список учащихся

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Список учащихся

Компоненты::Список учащихся

Описание school.students.list

Одностраничный компонент выводит список учащихся из информационного блока. Компонент содержит два шаблона: .default и print. Компонент доступен при использовании расширенного варианта решения Сайт школы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Школа > Список учащихся.

Параметры

Поле | Параметр | Описание
Дополнительно
Страница отправки личного сообщения | PM_URL | Указывается путь к странице отправки личного сообщения.
Дополнительные поля для вывода | USER_PROPERTY | С помощью клавиши Ctrl выбираются дополнительные поля для показа.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип инфоблока классов | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
ID инфоблока классов | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока.
Класс | CLASS_ID | Выбирается класс, учащиеся которого будут показаны.
Выводить только синхронизируемых с 1С пользователей | FILTER_1C_USERS | [Y|N] При отмеченной опции будут выводиться только синхронизируемые с 1С пользователи.
Фильтр по подразделениям FILTER_SECTION_CURONLY Указывается тип фильтра по подразделениям:
  • прямой (Y);
  • рекурсивный (N).
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Выводить уведомление при пустом списке | SHOW_ERROR_ON_NULL | [Y|N] При отмеченной опции выводится уведомление при пустом списке.
Количество пользователей на страницу | USERS_PER_PAGE | Указывается выводимое число пользователей на одной странице.
Подпись постраничной навигации | NAV_TITLE | Поле содержит подпись для постраничной навигации.
Показывать постраничную навигацию над списком | SHOW_NAV_TOP | [Y|N] При отмеченной опции постраничная навигация будет показываться над списком.
Показывать постраничную навигацию под списком | SHOW_NAV_BOTTOM | [Y|N] При отмеченной опции постраничная навигация будет показываться под списком.
Показывать список при пустом фильтре | SHOW_UNFILTERED_LIST | [Y|N] При отмеченной опции будет выведен весь список сотрудников. Если опция не отмечена, то будет показана только форма поиска.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Параметры фильтра
Имя фильтра | FILTER_NAME | Указывается имя фильтра.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:school.students.list",
    "",
    Array(
        "PM_URL" => "/personal/messages/form/#USER_ID#/",
        "USER_PROPERTY" => array("ID"),
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "schedule",
        "IBLOCK_ID" => "11",
        "CLASS_ID" => "269",
        "FILTER_NAME" => "users",
        "FILTER_1C_USERS" => "Y",
        "FILTER_SECTION_CURONLY" => "N",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_ERROR_ON_NULL" => "Y",
        "USERS_PER_PAGE" => "10",
        "NAV_TITLE" => "Сотрудники",
        "SHOW_NAV_TOP" => "Y",
        "SHOW_NAV_BOTTOM" => "Y",
        "SHOW_UNFILTERED_LIST" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SET_TITLE" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Список учащихся (комплексный компонент)

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Список учащихся (комплексный компонент)

Компоненты::Список учащихся (комплексный компонент)

Описание school.students

Комплексный компонент выводит список учащихся из информационного блока. Компонент доступен при использовании расширенного варианта решения Сайт школы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Школа > Список учащихся.

Параметры

Поле | Параметр | Описание
Дополнительно
Пользовательские поля для вывода | USER_PROPERTY | С помощью клавиши Ctrl выбираются поля для вывода.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип инфоблока классов | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока.
Идентификатор класса | CLASS_ID | Выбирается идентификатор класса, учащиеся которого будут показаны.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Устанавливать статус 404, если не найден класс | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • classes - страница списка классов;
  • students - страница списка учащихся в классе.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:school.students",
    "",
    Array(
        "USER_PROPERTY" => array(),
        "SEF_MODE" => "Y",
        "AJAX_MODE" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "IBLOCK_TYPE" => "schedule",
        "IBLOCK_ID" => "11",
        "CLASS_ID" => "272",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "SEF_FOLDER" => "/school_life/sports/",
        "SEF_URL_TEMPLATES" => Array(
            "classes" => "777",
            "students" => "#CLASS_ID#/"
        ),
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "VARIABLE_ALIASES" => Array(
            "students" => Array(),
            "classes" => Array(),
        )
    )
);?>


Список учеников одного родителя

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Список учеников одного родителя

Компоненты::Список учеников одного родителя

Описание school.parent.students

Одностраничный компонент для отображения списка учеников одного родителя. Компонент доступен при использовании расширенного варианта решения Сайт школы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Школа > Дневник ученика.

Параметры

Поле | Параметр | Описание
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Шаблоны ссылок
URL, ведущий на страницу с содержимым раздела | SECTION_URL | Указывается путь к странице с содержимым раздела.

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:school.parent.students",
    "",
    Array(
        "SECTION_URL" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "CACHE_NOTES" => "",
        "CACHE_GROUPS" => "Y"
    )
);?>


Урок

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Урок

Компоненты::Урок

Описание school.lesson

Одностраничный компонент для отображения урока. Компонент доступен при использовании расширенного варианта решения Сайт школы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Школа.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Инфоблок | IBLOCK_ID | Выбирается инфоблок указанного типа.
ID урока | ELEMENT_ID | Указывается идентификатор урока.
ID пользователя (ID ребенка) | USER_ID | Указывается идентификатор пользователя.
Тип пользователя USER_TYPE Выбирается тип пользователя:
  • Учитель;
  • Родитель;
  • Учащийся.
Формат показа даты | ACTIVE_DATE_FORMAT | Выбирается формат показа даты.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:school.lesson",
    "",
    Array(
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "schedule",
        "IBLOCK_ID" => "12",
        "ELEMENT_ID" => intVal($_REQUEST["ELEMENT_ID"]),
        "USER_ID" => intVal($_REQUEST["USER_ID"]),
        "USER_TYPE" => "TEACHER",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "36000000",
        "SET_TITLE" => "Y",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y"
    )
);?>


Школьное расписание

Отправить отзыв по этому разделу
...->Описание компонентов решений>Решения для образования>Сайт школы>Компоненты>Школьное расписание

Компоненты::Школьное расписание

Описание school.edit_calendar

Одностраничный компонент для вывода таблицы расписания уроков. Компонент доступен при использовании расширенного варианта решения Сайт школы. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Контент.

Параметры

Поле | Параметр | Описание
Основные параметры
Группа пользователей с возможностью редактировать расписание | EDIT_GROUP | С помощью клавиши Ctrl выбираются группы пользователей, которым будет разрешено редактировать расписание.
Дополнительные настройки
Количество уроков в дне | LESSON_COUNT | Указывается число уроков в одном дне.

Пример вызова

<?$APPLICATION->IncludeComponent(
"school:school.edit_calendar",
    "",
    Array(
        "EDIT_GROUP" => array("1"),
        "LESSON_COUNT" => "10"
    )
);?>


Сайт конференции

Данное решение [image] реализовано в редакции 1С-Битрикс: Управление сайтом "Старт".


Компоненты

  • Конференция
  • Программа
  • Докладчики
  • Новости
  • Регистрация
  • Партнеры
  • Отзывы
  • Фотогалерея 2.0
  • Медиа


Идеи

Отправить отзыв по этому разделу
Описание компонентов решений>Сайт конференции>Компоненты>Идеи

Компоненты::Идеи

Описание conf.idea

Комплексный компонент позволяет организовать сервис менеджера идей. Компонент доступен при использовании решения Сайт конференции.

В визуальном редакторе компонент расположен по пути: Компоненты > Общение > Менеджер идей.

Параметры

Поле | Параметр | Описание
Основные параметры
Блог | BLOG_URL | Выбирается блог для сервиса идей.
Инфоблок, в котором хранится структура категорий | IBLOCK_CATOGORIES | Выбирается инфоблок, в котором хранится структура категорий идей.
Группы пользователей, которые могут добавлять специальный ответ | POST_BIND_USER | Указывается группа пользователей, которая может модерировать сервис идей.
Статус по умолчанию для новой идеи | POST_BIND_STATUS_DEFAULT | Указывается статус, который будет автоматически присвоен новым идеям.
Внешний вид
Количество идей, выводимых на страницу | MESSAGE_COUNT | Указывается количество идей на странице. Остальные сообщения будут выведены с помощью постраничной навигации.
Количество комментариев к идее на странице | COMMENTS_COUNT | Указывается количество комментариев к идее на странице.
Количество выводимых тегов в облаке тегов (0 - без ограничений) | TAGS_COUNT | Задается ограничение на количество отображаемых в облаке тегов.
Формат показа даты и времени | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Имя шаблона для постраничной навигации | NAV_TEMPLATE | Указывается имя шаблона для постраничной навигации.
Количество постоянно отображаемых смайлов | SMILES_COUNT | Указывается количество постоянно отображаемых смайлов на странице.
Максимальная ширина изображения | IMAGE_MAX_WIDTH | Максимально допустимая ширина добавляемого в сообщение изображения (в пикселях).
Максимальная высота изображения | IMAGE_MAX_HEIGHT | Максимально допустимая высота добавляемого в сообщение изображения (в пикселях).
Разрешить изменять размер визуального редактора | EDITOR_RESIZABLE | [Y|N] При отмеченной опции будет возможность менять размеры окна визуального редактора в форме редактирования идеи.
Высота визуального редактора по умолчанию (пикселей) | EDITOR_DEFAULT_HEIGHT | Значение высоты визуального редактора при загрузке (в пикселях) в форме редактирования идеи.
По умолчанию показывать невизуальный режим редактора | EDITOR_CODE_DEFAULT | [Y|N] При отмеченной опции визуальный режим редактора не будет использоваться по умолчанию при редактировании идей.
Разрешить изменять размер визуального редактора в комментариях | COMMENT_EDITOR_RESIZABLE | [Y|N] При отмеченной опции будет возможность менять размеры окна визуального редактора в форме комментариев.
Высота визуального редактора по умолчанию (пикселей) в комментариях | COMMENT_EDITOR_DEFAULT_HEIGHT | Значение высоты визуального редактора в форме комментариев при загрузке (в пикселях).
По умолчанию показывать невизуальный режим редактора в комментариях | COMMENT_EDITOR_CODE_DEFAULT | [Y|N] При отмеченной опции визуальный режим редактора не будет использоваться по умолчанию при создании комментариев.
Управление адресами страниц
Включить поддержку ЧПУ | SEF_MODE | [Y|N] При отмеченной опции будет включена поддержка ЧПУ.
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Указывается путь к каталогу ЧПУ.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - главная страница идей
  • status_0 - список идей со статусами 0го уровня
  • category_1 - общий список идей 1го уровня
  • category_1_status - список идей со статусами 1го уровня
  • category_2 - общий список идей 2го уровня
  • category_2_status - список идей со статусами 2го уровня
  • user_ideas - общий список идей пользователя
  • user_ideas_status - список идей пользователя со статусами
  • user - страница профайла пользователя
  • user_subscribe - страница подписки на пользователя
  • post_edit - страница редактирования идеи
  • post - страница с идеей, показанной детально
  • post_rss - адрес комментариев к сообщению в RSS формате
  • rss - адрес блога в RSS формате
  • rss_status - адрес блога в RSS формате со статусом
  • rss_category - адрес блога в RSS формате с категорией
  • rss_category_status - адрес блога в RSS формате с категорией и статусом
  • rss_user_ideas - адрес блога в RSS формате к идеям пользователя
  • rss_user_ideas_status - адрес блога в RSS формате к идеям пользователя со статусом
  • rss_all - сообщения всех блогов в RSS формате
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
Настройки кеширования
Тип кеширования CACHE_TYPE Указывается тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах. По умолчанию поле содержит 3600 сек.
Время кэширования остальных страниц | CACHE_TIME_LONG | Указывается время кеширования страниц, начиная со второй.
Дополнительные настройки
Путь к папке со смайликами относительно корня сайта | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта. По умолчанию задано /bitrix/images/blog/smile/.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено название идеи.
Добавлять блог в цепочку навигации | SET_NAV_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлен пункт с названием блога.
Использовать прямую постраничную навигацию для комментариев | USE_ASC_PAGING | [Y|N] При отмеченной опции список комментариев будет выводиться постранично с прямой навигацией.
Разрешить вставку видео в комментарии | COMMENT_ALLOW_VIDEO | [Y|N] При отмеченной опции появится возможность вставки видеороликов в комментарий.
Запретить вставку ссылок в комментариях

NO_URL_IN_COMMENTS

Указывается, кому нельзя вставлять ссылки в комментарии (по умолчанию - Никому):

  • Никому;
  • Анонимным пользователям;
  • Всем.
Использовать символьный код сообщений как идентификатор | ALLOW_POST_CODE | [Y|N] При отмеченной опции транслитерация заголовка идеи будет использоваться как его идентификатор.
Использовать переводчик Bing для кода сообщений | USE_GOOGLE_CODE | [Y|N] При отмеченной опции для перевода символьного кода идей будет использоваться сервис перевода Bing. Параметр доступен при отмеченной опции Использовать символьный код сообщений как идентификатор.
Использовать рейтинги | SHOW_RATING | [Y|N] При отмеченной опции будут использоваться рейтинги для оценки идей и комментариев к ним.
Шаблон рейтингов | RATING_TEMPLATE | Выбирается шаблон визуального отображения рейтингов.
Отключить уведомления в живую ленту | DISABLE_SONET_LOG | [Y|N] Опция позволяет отключить вывод идей в живую ленту.
Отключить почтовые уведомления | DISABLE_EMAIL | [Y|N] Опция позволяет отключить почтовые уведомления о новых комментариях.
Отключить RSS | DISABLE_RSS | [Y|N] Опция позволяет отключить RSS.
Дополнительно
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО пользователя социальной сети. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
Показывать логин, если не задано имя | SHOW_LOGIN | [Y|N] При отмеченной опции будет отображен логин пользователя, если не задано имя.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.idea",
    "",
    Array(
        "SEF_MODE" => "Y",
        "BLOG_URL" => "conf_program_1",
        "IBLOCK_CATOGORIES" => "1",
        "POST_BIND_USER" => array(),
        "POST_BIND_STATUS_DEFAULT" => "1",
        "PATH_TO_SMILE" => "/bitrix/images/blog/smile/",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_NOTES" => "",
        "SET_TITLE" => "Y",
        "CACHE_TIME_LONG" => "604800",
        "SET_NAV_CHAIN" => "Y",
        "MESSAGE_COUNT" => "25",
        "COMMENTS_COUNT" => "25",
        "TAGS_COUNT" => "0",
        "DATE_TIME_FORMAT" => "d.m.Y H:i:s",
        "NAV_TEMPLATE" => "",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "SHOW_LOGIN" => "Y",
        "USE_ASC_PAGING" => "Y",
        "SMILES_COUNT" => "4",
        "IMAGE_MAX_WIDTH" => "800",
        "IMAGE_MAX_HEIGHT" => "800",
        "EDITOR_RESIZABLE" => "Y",
        "EDITOR_DEFAULT_HEIGHT" => "300",
        "EDITOR_CODE_DEFAULT" => "Y",
        "COMMENT_EDITOR_RESIZABLE" => "Y",
        "COMMENT_EDITOR_DEFAULT_HEIGHT" => "200",
        "COMMENT_EDITOR_CODE_DEFAULT" => "Y",
        "COMMENT_ALLOW_VIDEO" => "Y",
        "ALLOW_POST_CODE" => "Y",
        "USE_GOOGLE_CODE" => "Y",
        "SHOW_RATING" => "Y",
        "RATING_TEMPLATE" => "standart",
        "DISABLE_EMAIL" => "Y",
        "DISABLE_RSS" => "Y",
        "SEF_FOLDER" => "/conf2013/visitors/",
        "SEF_URL_TEMPLATES" => Array(
            "index" => "index.php",
            "status_0" => "status/#status_code#/",
            "category_1" => "category/#category_1#/",
            "category_1_status" => "category/#category_1#/status/#status_code#/",
            "category_2" => "category/#category_1#/#category_2#/",
            "category_2_status" => "category/#category_1#/#category_2#/status/#status_code#/",
            "user_ideas" => "user/#user_id#/idea/",
            "user_ideas_status" => "user/#user_id#/idea/status/#status_code#/",
            "user" => "user/#user_id#/",
            "user_subscribe" => "user/#user_id#/subscribe/",
            "post_edit" => "edit/#post_id#/",
            "post" => "#post_id#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "status_0" => Array(),
            "category_1" => Array(),
            "category_1_status" => Array(),
            "category_2" => Array(),
            "category_2_status" => Array(),
            "user_ideas" => Array(),
            "user_ideas_status" => Array(),
            "user" => Array(),
            "user_subscribe" => Array(),
            "post_edit" => Array(),
            "post" => Array(),
            "post_rss" => Array(),
            "rss" => Array(),
            "rss_status" => Array(),
            "rss_category" => Array(),
            "rss_category_status" => Array(),
            "rss_user_ideas" => Array(),
            "rss_user_ideas_status" => Array(),
        )
    )
);?>


Конференция

  • переадресация на текущую конференцию;
  • анонс конференции;
  • архив конференции.


Анонс конференции

Отправить отзыв по этому разделу
...->Описание компонентов решений>Сайт конференции>Компоненты>Конференция>Анонс конференции

Конференция::Анонс конференции

Описание conf.preview

Одностраничный компонент для отображения анонса этапа конференции. Компонент доступен при использовании решения Сайт конференции и содержит следующие шаблоны: .default, head_info_classic, head_info_dark, head_info_modern, head_info_social, print. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Конференция.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока. Используется только для проверки.
Код информационного блока | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок.
ID новости | ELEMENT_ID | Указывается числовой код, в котором передается идентификатор новости. Поле может быть оставлено пустым, если указан Код новости.
Код новости | ELEMENT_CODE | Указывается символьный код новости. Поле может быть оставлено пустым, если указан ID новости.
Дополнительные настройки
Установить ключевые слова страницы из свойства | META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
Установить описание страницы из свойства | META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | [Y|N] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего элемента.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в парметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | Указываются группы пользователей, имеющие доступ к детальной информации.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Шаблоны ссылок
URL страницы просмотра списка элементов | IBLOCK_URL | Указывается путь к странице просмотра списка элементов.
Источник данных
URL страницы просмотра списка элементов | IBLOCK_URL | Указывается путь к странице просмотра списка элементов.
Поля | FIELD_CODE | Указываются поля, которые будут отображены на странице. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Дополнительно
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будут выведены даты элементов.
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции для каждого элемента будет выведено его название.
Выводить детальное изображение | DISPLAY_PICTURE | [Y|N] При отмеченной опции будут выведены детальные изображения для элемента, если они заданы.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.preview",
    "",
    Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "",
        "ELEMENT_ID" => $_REQUEST["CONF_ID"],
        "ELEMENT_CODE" => "",
        "FIELD_CODE" => array("ID"),
        "PROPERTY_CODE" => array(),
        "IBLOCK_URL" => "",
        "META_KEYWORDS" => "-",
        "META_DESCRIPTION" => "-",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => array("2"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y"
    )
);?>


Архив конференции

Отправить отзыв по этому разделу
...->Описание компонентов решений>Сайт конференции>Компоненты>Конференция>Архив конференции

Конференция::Архив конференции

Описание conf.archive

Одностраничный компонент для отображения архива конференции. Компонент доступен при использовании решения Сайт конференции и содержит следующие шаблоны: .default, conf_archive_classic, conf_archive_dark, conf_archive_modern, main_left_classic, main_left_dark, main_left_modern и main_left_social. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Конференция.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Максимальная длина анонса для вывода | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода (только для типа текст). При превышении параметра остаток текста будет отсечен.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | [Y|N] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего элемента.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационных блоков. Используется только для проверки.
Код информационного блока | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок.
Количество новостей на странице | NEWS_COUNT | Указывается количество новостей, выводимых на одну страницу.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Шаблоны ссылок
URL страницы детального просмотра | DETAIL_URL | Указывается путь к странице детального просмотра. По умолчанию - из настроек инфоблока.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Выбирается шаблон постраничной навигации:
  • .default;
  • arrows;
  • arrows_adm;
  • js;
  • modern;
  • orange;
  • visual;
  • blog;
  • forum;
  • (другое).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости.
Источник данных
Фильтр | FILTER_NAME | Задается имя переменной, в которой передается массив параметров из фильтра.
Поля | FIELD_CODE | C помощью клавиши Ctrl выбираются поля элементов инфоблока, по которым будет возможна фильтрация.
Свойства | PROPERTY_CODE | C помощью клавиши Ctrl выбираются свойства элементов инфоблока, по которым будет возможна фильтрация..
Дополнительно
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будут выведены даты элементов.
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции для каждого элемента будет выведено его название.
Выводить детальное изображение | DISPLAY_PICTURE | [Y|N] При отмеченной опции будут выведены детальные изображения для элемента, если они заданы.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.archive",
    "",
    Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "5",
        "NEWS_COUNT" => "20",
        "FILTER_NAME" => "",
        "FIELD_CODE" => array("CODE"),
        "PROPERTY_CODE" => array("show_in_main"),
        "DETAIL_URL" => "",
        "PREVIEW_TRUNCATE_LEN" => "",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_NOTES" => "",
        "CACHE_FILTER" => "Y",
        "PAGER_TEMPLATE" => ".default",
        "DISPLAY_TOP_PAGER" => "Y",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Конференции",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_DESC_NUMBERING" => "Y",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y"
    )
);?>


Отправить отзыв по этому разделу

Программа

  • Доклады конференции
  • Зал детально
  • Мероприятие детально
  • Программа конференции
  • Секция конференции
  • Список докладов конференции
  • Список избранных докладов конференции


Доклады конференции

Описание conf.agenda.list

Одностраничный компонент служит для работы с докладами конференции. Компонент доступен при использовании решения Сайт конференции и содержит следующие шаблоны: .default, list. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Программа.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Временной шаг (мин) | TIME_STEP | Указывается число минут, составляющих шаг во временной сетке.
Устанавливать заголовок страницы | SET_TITLE | При отмеченной опции в качестве заголовка страницы будет установлено имя текущего инфоблока.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | При установленной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
ID раздела | PARENT_SECTION | Указывается идентификатор "родительского" раздела для ограничения выборки элементов по нему.
Код раздела | PARENT_SECTION_CODE | Указывается код раздела.
URL страницы избранных докладов | FAVORITE_PAGE_URL | Указывается путь к странице избранных докладов.
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационных блоков. Используется только для проверки.
Код информационного блока | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок докладов конференции.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Шаблоны ссылок
URL страницы детального просмотра | DETAIL_URL | Указывается шаблон ссылки на страницу детального просмотра. По умолчанию - из настроек инфоблока.
URL страницы секции | SECTION_DETAIL_URL | Указывается шаблон ссылки на страницу секции. По умолчанию - из настроек инфоблока.
URL страницы детального просмотра места проведения | DETAIL_ROOM_URL | Указывается шаблон ссылки на страницу детального просмотра места проведения. По умолчанию - из настроек инфоблока.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Настройки голосования
Разрешить голосование | VOTING | [Y|N] При отмеченной опции посетители смогут голосовать за доклад, выставляя баллы. При установленной опции становятся доступными следующие поля: MAX_VOTE и VOTE_NAMES.
Максимальный балл | MAX_VOTE | Указывается максимально возможный балл.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
Дополнительно
Выводить дату дня | DISPLAY_DAY_DATE | [Y|N] При отмеченной опции будет выводиться дата дня.
Выводить название дня | DISPLAY_DAY_NAME | [Y|N] При отмеченной опции будет выводиться наименование дня.
Выводить описание дня | DISPLAY_DAY_PREVIEW | [Y|N] При отмеченной опции будет выводиться описание дня конференции.
Выводить докладчиков | DISPLAY_SPEAKERS | [Y|N] При отмеченной опции будут выводиться докладчики.
Выводить ведущих | DISPLAY_LEADER | [Y|N] При отмеченной опции будут выводиться ведущие.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.agenda.list",
    "",
    Array(
        "DISPLAY_DAY_DATE" => "Y",
        "DISPLAY_DAY_NAME" => "Y",
        "DISPLAY_DAY_PREVIEW" => "Y",
        "DISPLAY_SPEAKERS" => "Y",
        "DISPLAY_LEADER" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "5",
        "DAY_SORT" => "ASC",
        "FILTER_NAME" => "",
        "FIELD_CODE" => array("ID"),
        "PROPERTY_CODE" => array("leaders_old"),
        "DETAIL_URL" => "",
        "SECTION_DETAIL_URL" => "",
        "DETAIL_ROOM_URL" => "",
        "TIME_STEP" => "10",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "PARENT_SECTION" => "",
        "PARENT_SECTION_CODE" => "",
        "FAVORITE_PAGE_URL" => "/conf2012/agenda/all_favorite/",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "VOTING" => "Y",
        "MAX_VOTE" => "4",
        "VOTE_NAMES" => array("2","3","4","5"),
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y"
    )
);?>


Зал детально

Описание conf.room.detail

Одностраничный компонент подробного показа зала. Компонент доступен при использовании решения Сайт конференции и содержит следующие шаблоны: .default и official. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Программа.

Параметры

Поле | Параметр | Описание
Дополнительно
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будет выводиться дата элемента.
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции будет показано название элемента.
Выводить детальное изображение | DISPLAY_PICTURE | [Y|N] При отмеченной опции будет выводиться детальное изображение.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выводиться текст анонса.
Дополнительные настройки
Установить ключевые слова страницы из свойства | META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
Установить описание страницы из свойства | META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
Установить заголовок окна браузера из свойства | BROWSER_TITLE | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится заголовок окна браузера.
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | [Y|N] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего инфоблока.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | При установленной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Формат показа даты | ACTIVE_DATE_FORMAT | Выбирается вариант показа даты. Выбрав пункт другое, можно сформировать свой вариант на основании php-функции date.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в парметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | Указываются группы пользователей, имеющие доступ к детальной информации.
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационных блоков. Используется только для проверки.
Код информационного блока | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок докладов конференции.
ID зала | ELEMENT_ID | Указывается идентификатор зала.
Код зала | ELEMENT_CODE | Указывается код зала.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Шаблоны ссылок
URL страницы просмотра списка элементов IBLOCK_URL Задается адрес страницы со списком элементов инфоблока. По умолчанию поле содержит
news.php?ID=#IBLOCK_ID#
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Источник данных
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные элементы инфоблока.
Поля | FIELD_CODE | Указываются поля, которые будут отображены на странице. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Выбирается шаблон постраничной навигации:
  • .default;
  • arrows;
  • arrows_adm;
  • js;
  • modern;
  • orange;
  • visual;
  • blog;
  • forum;
  • (другое).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.room.detail",
    "",
    Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "3",
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "ELEMENT_CODE" => "",
        "CHECK_DATES" => "Y",
        "FIELD_CODE" => array("CODE"),
        "PROPERTY_CODE" => array(),
        "IBLOCK_URL" => "",
        "META_KEYWORDS" => "-",
        "META_DESCRIPTION" => "-",
        "BROWSER_TITLE" => "NAME",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => array("3"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "PAGER_TEMPLATE" => ".default",
        "DISPLAY_TOP_PAGER" => "Y",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Страница",
        "PAGER_SHOW_ALL" => "Y",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y"
    )
);?>


Мероприятие детально

Описание conf.agenda.detail

Выводит всплывающее окно с информацией. Компонент разработан для решения Сайт медицинской организации. Компонент стандартный и входит в дистрибутив модуля.

Компонент доступен только для расширенного варианта решения 1С-Битрикс: Сайт медицинской организации. В визуальном редакторе компонент расположен по пути: Мед.сайт > Разное > Всплывающее облако.

Параметры

Поле | Параметр | Описание
Дополнительно
Выводить название | DISPLAY_NAME | [Y|N] При отмеченной опции будет выводиться название мероприятия.
Выводить детальное изображение | DISPLAY_PICTURE | [Y|N] При отмеченной опции будет показано детальное изображение.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выводиться текст анонса мероприятия.
Выводить дату дня | DISPLAY_DAY_DATE | [Y|N] При отмеченной опции будет выводиться дата дня мероприятия.
Выводить название дня | DISPLAY_DAY_NAME | [Y|N] При отмеченной опции будет выводиться название дня.
Выводить описание дня | DISPLAY_DAY_PREVIEW | [Y|N] При отмеченной опции будет выводиться описание дня.
Дополнительные настройки
Временной шаг (мин) | TIME_STEP | Указывается число минут, составляющих шаг на временной сетке.
Установить ключевые слова страницы из свойства | META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
Установить описание страницы из свойства | META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | [Y|N] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего инфоблока.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | При установленной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в парметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | Указываются группы пользователей, имеющие доступ к детальной информации.
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационных блоков. Используется только для проверки.
Код информационного блока | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок докладов конференции.
ID мероприятия | ELEMENT_ID | Указывается идентификатор мероприятия.
Код мероприятия | ELEMENT_CODE | Указывается код мероприятия.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Шаблоны ссылок
URL страницы программы IBLOCK_URL Задается адрес страницы со списком элементов инфоблока. По умолчанию поле содержит
news.php?ID=#IBLOCK_ID#
URL cтраницы секции | SECTION_DETAIL_URL | Указывается шаблон ссылки на страницу секции. По умолчанию - из настроек инфоблока.
URL страницы детального просмотра места проведения | DETAIL_ROOM_URL | Указывается шаблон ссылки на страницу детального просмотра места проведения. По умолчанию - из настроек инфоблока.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Источник данных
Поля | FIELD_CODE | Указываются поля, которые будут отображены на странице. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Настройки голосования
Разрешить голосование | VOTING | [Y|N] При отмеченной опции посетители смогут голосовать за доклад, выставляя баллы. При установленной опции становятся доступными следующие поля: MAX_VOTE и VOTE_NAMES.
Максимальный балл | MAX_VOTE | Указывается максимально возможный балл.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.agenda.detail",
    "",
    Array(
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "DISPLAY_DAY_DATE" => "Y",
        "DISPLAY_DAY_NAME" => "Y",
        "DISPLAY_DAY_PREVIEW" => "Y",
        "AJAX_MODE" => "N",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "5",
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "ELEMENT_CODE" => "",
        "FIELD_CODE" => array("ID"),
        "PROPERTY_CODE" => array("show_in_main"),
        "IBLOCK_URL" => "",
        "SECTION_DETAIL_URL" => "",
        "DETAIL_ROOM_URL" => "",
        "TIME_STEP" => "10",
        "META_KEYWORDS" => "vote_sum",
        "META_DESCRIPTION" => "take_rating",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => array("5"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "VOTING" => "Y",
        "MAX_VOTE" => "4",
        "VOTE_NAMES" => array("2","3","4","5"),
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Программа конференции

Описание conf.agenda

Комплексный компонент для вывода программы конференции. Компонент доступен при использовании решения Сайт конференции и содержит следующие шаблоны: .default, agenda_classic, agenda_dark, agenda_modern, agenda_social, agenda_table, list. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Программа.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип инфо-блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Инфо-блок | IBLOCK_ID | Для выбранного типа инфоблока выбирается инфоблок.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить следущие параметры: SEF_FOLDER, SEF_URL_TEMPLATES.
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • agenda - страница программы;
  • section - страница секции;
  • detail - страница детального просмотра;
  • room - страница детального просмотра места проведения.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
Дополнительно
Выводить дату дня | DISPLAY_DAY_DATE | [Y|N] При отмеченной опции будет выводиться дата дня конференции.
Выводить название дня | DISPLAY_DAY_NAME | [Y|N] При отмеченной опции будет выводиться наименование дня конференции.
Выводить описание дня | DISPLAY_DAY_PREVIEW | [Y|N] При отмеченной опции будет выводиться описание дня конференции.
Выводить докладчиков | DISPLAY_SPEAKERS | [Y|N] При отмеченной опции будут выводиться докладчики.
Выводить ведущих | DISPLAY_LEADER | [Y|N] При отмеченной опции будут выводиться ведущие.
Источник данных
Фильтр | FILTER_NAME | Задается имя переменной, в которой передается массив параметров из фильтра.
Дополнительные настройки
Временной шаг (мин) | TIME_STEP | Указывается число минут, составляющих шаг во временной сетке.
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | При отмеченной опции кнопки будут отображены в режиме редактирования сайта на административной панели и в наборе кнопок области редактирования компонента.
Устанавливать заголовок страницы | SET_TITLE | При отмеченной опции в качестве заголовка страницы будет установлено имя текущего инфоблока.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | При установленной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в параметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | С помощью клавиши Ctrl выбираются группы пользователей, имеющие доступ к детальной информации.
URL страницы избранных докладов | FAVORITE_PAGE_URL | Указывается путь к странице избранных докладов.
Настройки списка
Поля | DETAIL_FIELD_CODE | С помощью клавиши Ctrl выбираются поля, которые будут отображены на странице просмотра списка.
Свойства | LIST_PROPERTY_CODE | С помощью клавиши Ctrl выбираются свойства, которые будут отображены на странице просмотра списка.
Сортировка дней DAY_SORT Выбирается направление сортировки дней на странице просмотра списка:
  • По возрастанию;
  • По убыванию.
Настройки детального просмотра
Установить ключевые слова страницы из свойства | DETAIL_META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова для страницы.
Установить описание страницы из свойства | DETAIL_META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится детальное описание страницы.
Поля | DETAIL_FIELD_CODE | С помощью клавиши Ctrl выбираются поля, которые будут отображены на странице детального просмотра.
Свойства | DETAIL_PROPERTY_CODE | С помощью клавиши Ctrl выбираются свойства, которые будут отображены на странице детального просмотра.
Настройки голосования
Разрешить голосование | VOTING | [Y|N] При отмеченной опции посетители смогут голосовать за доклад, выставляя баллы. При установленной опции становятся доступными следующие поля: MAX_VOTE и VOTE_NAMES.
Максимальный балл | MAX_VOTE | Указывается максимально возможный балл.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.agenda",
    "",
    Array(
        "DISPLAY_DAY_DATE" => "Y",
        "DISPLAY_DAY_NAME" => "Y",
        "DISPLAY_DAY_PREVIEW" => "Y",
        "DISPLAY_SPEAKERS" => "Y",
        "DISPLAY_LEADER" => "Y",
        "SEF_MODE" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "5",
        "FILTER_NAME" => "",
        "LIST_FIELD_CODE" => array("USER_NAME"),
        "LIST_PROPERTY_CODE" => array("place", "LIKE"),
        "DAY_SORT" => "ASC",
        "META_KEYWORDS" => "-",
        "META_DESCRIPTION" => "-",
        "DETAIL_FIELD_CODE" => array("ID", "CODE", "DATE_ACTIVE_FROM", "ACTIVE_FROM"),
        "DETAIL_PROPERTY_CODE" => array("LIKE", "SHORT_NAME", "DATE"),
        "TIME_STEP" => "10",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => array("5"),
        "FAVORITE_PAGE_URL" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "VOTING" => "Y",
        "MAX_VOTE" => "4",
        "VOTE_NAMES" => array("2", "3", "4", "5"),
        "SEF_FOLDER" => "/conf2013/agenda/reports/",
        "SEF_URL_TEMPLATES" => Array(
            "section" => "section/#SECTION_ID#/",
            "detail" => "#ELEMENT_ID#/",
            "room" => "room/#ELEMENT_ID#/"
        ),
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y",
        "VARIABLE_ALIASES" => Array(
            "section" => Array(),
            "detail" => Array(),
            "room" => Array(),
        )
    )
);?>


Секция конференции

Описание conf.agenda.section

Одностраничный компонент служит для вывода секции конференции. Компонент доступен при использовании решения Сайт конференции. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Программа.

Параметры

Поле | Параметр | Описание
Дополнительно
Выводить дату дня | DISPLAY_DAY_DATE | [Y|N] При отмеченной опции будет выводиться дата дня.
Выводить название дня | DISPLAY_DAY_NAME | [Y|N] При отмеченной опции будет выводиться наименование дня.
Выводить описание дня | DISPLAY_DAY_PREVIEW | [Y|N] При отмеченной опции будет выводиться описание дня конференции.
Выводить докладчиков | DISPLAY_SPEAKERS | [Y|N] При отмеченной опции будут выводиться докладчики.
Выводить ведущих | DISPLAY_LEADER | [Y|N] При отмеченной опции будут выводиться ведущие.
Дополнительные настройки
Временной шаг (мин) | TIME_STEP | Указывается число минут, составляющих шаг на временной сетке.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего инфоблока.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | При установленной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
ID раздела | PARENT_SECTION | Указывается идентификатор "родительского" раздела для ограничения выборки элементов по нему.
Код раздела | PARENT_SECTION_CODE | Указывается код раздела.
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационных блоков. Используется только для проверки.
Код информационного блока | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок докладов конференции.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Шаблоны ссылок
URL страницы детального просмотра | DETAIL_URL | Указывается шаблон ссылки на страницу детального просмотра. По умолчанию - из настроек инфоблока.
URL программы | PROGRAM_URL | Указывается шаблон ссылки на страницу программы. По умолчанию - из настроек инфоблока.
URL страницы детального просмотра места проведения | DETAIL_ROOM_URL | Указывается шаблон ссылки на страницу детального просмотра места проведения. По умолчанию - из настроек инфоблока.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Источник данных
Сортировка дней DAY_SORT Задается направление сортировки дней:
  • По возрастанию;
  • По убыванию.
Фильтр | FILTER_NAME | Задается имя переменной, в которой передается массив параметров из фильтра.
Поля | FIELD_CODE | Указываются поля, которые будут отображены на странице. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Настройки голосования
Разрешить голосование | VOTING | [Y|N] При отмеченной опции посетители смогут голосовать за доклад, выставляя баллы. При установленной опции становятся доступными следующие поля: MAX_VOTE и VOTE_NAMES.
Максимальный балл | MAX_VOTE | Указывается максимально возможный балл.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.agenda.section",
    "",
    Array(
        "DISPLAY_DAY_DATE" => "Y",
        "DISPLAY_DAY_NAME" => "Y",
        "DISPLAY_DAY_PREVIEW" => "Y",
        "DISPLAY_SPEAKERS" => "Y",
        "DISPLAY_LEADER" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "1",
        "DAY_SORT" => "ASC",
        "FILTER_NAME" => "",
        "FIELD_CODE" => array("CODE"),
        "PROPERTY_CODE" => array("SHORT_NAME"),
        "DETAIL_URL" => "",
        "PROGRAM_URL" => "",
        "DETAIL_ROOM_URL" => "",
        "TIME_STEP" => "10",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "PARENT_SECTION" => "88",
        "PARENT_SECTION_CODE" => "14",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "VOTING" => "Y",
        "MAX_VOTE" => "4",
        "VOTE_NAMES" => array("2","3","4","5"),
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y"
    )
);?>


Список докладов конференции

Описание conf.reports.list

Одностраничный компонент служит для вывода списка докладов конференции. Компонент доступен при использовании решения Сайт конференции. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Программа.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | При отмеченной опции кнопки будут отображены в режиме редактирования сайта на административной панели и в наборе кнопок области редактирования компонента.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего инфоблока.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | При установленной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
ID раздела | PARENT_SECTION | Указывается идентификатор "родительского" раздела для ограничения выборки элементов по нему.
Код раздела | PARENT_SECTION_CODE | Указывается код раздела.
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационных блоков. Используется только для проверки.
Код информационного блока | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок докладов конференции.
Выводить только избранные доклады | DISPLAY_FAVORITS_ONLY | [Y|N] При отмеченной опции будут показываться только избранные доклады.
Количество докладов на странице | NEWS_COUNT | Указывается число выводимых на одной странице докладов.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Шаблоны ссылок
URL страницы детального просмотра | DETAIL_URL | Указывается шаблон ссылки на страницу детального просмотра. По умолчанию - из настроек инфоблока.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Источник данных
Фильтр | FILTER_NAME | Задается имя переменной, в которой передается массив параметров из фильтра.
Поля | FIELD_CODE | Указываются поля, которые будут отображены на странице. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Выбирается шаблон постраничной навигации:
  • .default;
  • arrows;
  • arrows_adm;
  • js;
  • modern;
  • orange;
  • visual;
  • blog;
  • forum;
  • (другое).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.reports.list",
    "",
    Array(
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "5",
        "DISPLAY_FAVORITS_ONLY" => "Y",
        "NEWS_COUNT" => "20",
        "FILTER_NAME" => "",
        "FIELD_CODE" => array("ID"),
        "PROPERTY_CODE" => array("show_in_main"),
        "DETAIL_URL" => "",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "PARENT_SECTION" => "12",
        "PARENT_SECTION_CODE" => "5dd",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "PAGER_TEMPLATE" => ".default",
        "DISPLAY_TOP_PAGER" => "Y",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Доклады",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_DESC_NUMBERING" => "Y",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y"
    )
);?>


Список избранных докладов конференции

Описание conf.reports.list.favorite

Одностраничный компонент служит для вывода списка избранных докладов. Компонент доступен при использовании решения Сайт конференции. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Программа.

Параметры

Поле | Параметр | Описание
Дополнительные настройки
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | При отмеченной опции кнопки будут отображены в режиме редактирования сайта на административной панели и в наборе кнопок области редактирования компонента.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего инфоблока.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | При установленной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
ID раздела | PARENT_SECTION | Указывается идентификатор "родительского" раздела для ограничения выборки элементов по нему.
Код раздела | PARENT_SECTION_CODE | Указывается код раздела.
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационных блоков. Используется только для проверки.
Код информационного блока | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок докладов конференции.
Количество докладов на странице | NEWS_COUNT | Указывается число выводимых на одной странице докладов.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Шаблоны ссылок
URL страницы детального просмотра | DETAIL_URL | Указывается шаблон ссылки на страницу детального просмотра. По умолчанию - из настроек инфоблока.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Настройки голосования
Разрешить голосование | VOTING | [Y|N] При отмеченной опции посетители смогут голосовать за доклад, выставляя баллы. При установленной опции становятся доступными следующие поля: MAX_VOTE и VOTE_NAMES.
Максимальный балл | MAX_VOTE | Указывается максимально возможный балл.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
Источник данных
Фильтр | FILTER_NAME | Задается имя переменной, в которой передается массив параметров из фильтра.
Поля | FIELD_CODE | Указываются поля, которые будут отображены на странице. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Выбирается шаблон постраничной навигации:
  • .default;
  • arrows;
  • arrows_adm;
  • js;
  • modern;
  • orange;
  • visual;
  • blog;
  • forum;
  • (другое).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.reports.list.favorite",
    "",
    Array(
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "5",
        "NEWS_COUNT" => "20",
        "FILTER_NAME" => "",
        "FIELD_CODE" => array("ID"),
        "PROPERTY_CODE" => array("leaders_old"),
        "DETAIL_URL" => "",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "PARENT_SECTION" => "",
        "PARENT_SECTION_CODE" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "VOTING" => "Y",
        "MAX_VOTE" => "4",
        "VOTE_NAMES" => array("2","3","4","5"),
        "PAGER_TEMPLATE" => ".default",
        "DISPLAY_TOP_PAGER" => "Y",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Доклады",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_DESC_NUMBERING" => "Y",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y"
    )
);?>


Отправить отзыв по этому разделу

Докладчики

  • Докладчик детально
  • Докладчики
  • Список докладчиков конференции


Докладчик детально

Описание conf.speakers.detail

Одностраничный компонент для подробного показа докладчика конференции. Компонент доступен при использовании решения Сайт конференции. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Докладчики.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Код информационного блока IBLOCK_ID Для указанного типа инфоблока выбирается инфоблок. При выборе пункта другое в поле рядом необходимо указать код инфоблока, например
={$_REQUEST["IBLOCK_ID"]}
Код информационного блока докладов | REPORT_IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок докладов.
ID докладчика | ELEMENT_ID | Указывается идентификатор докладчика.
Код докладчика | ELEMENT_CODE | Указывается код докладчика.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Выбирается шаблон постраничной навигации:
  • .default;
  • arrows;
  • arrows_adm;
  • js;
  • modern;
  • orange;
  • visual;
  • blog;
  • forum;
  • (другое).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Дополнительно
Выводить детальное изображение | DISPLAY_PICTURE | [Y|N] При отмеченной опции будет выведено детальное изображение.
Выводить E-mail | DISPLAY_EMAIL | [Y|N] При отмеченной опции будет выведен e-mail докладчика, если он задан.
Выводить телефон | DISPLAY_PHONE | [Y|N] При отмеченной опции будут выведен номер телефона докладчика, если он задан.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элемента, если он определен.
Источник данных
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы.
Поля | FIELD_CODE | С помощью клавиши Ctrl выбираются поля, которые будут отображены на странице детального просмотра.
Свойства | PROPERTY_CODE | С помощью клавиши Ctrl выбираются cвойства, которые будут отображены на странице детального просмотра.
Дополнительные настройки
Установить ключевые слова страницы из свойства | META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
Установить описание страницы из свойства | META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | [Y|N] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в параметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | С помощью клавиши Ctrl указываются группы пользователей, имеющие доступ к детальной информации.
Шаблоны ссылок
URL страницы просмотра списка элементов | IBLOCK_URL | Задается адрес страницы со списком элементов инфоблока.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.speakers.detail",
    "",
    Array(
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_EMAIL" => "Y",
        "DISPLAY_PHONE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "AJAX_MODE" => "N",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "4",
        "REPORT_IBLOCK_ID" => "5",
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "ELEMENT_CODE" => "",
        "CHECK_DATES" => "Y",
        "FIELD_CODE" => array("ID"),
        "PROPERTY_CODE" => array("position"),
        "IBLOCK_URL" => "",
        "META_KEYWORDS" => "company",
        "META_DESCRIPTION" => "user",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => array("3"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "PAGER_TEMPLATE" => ".default",
        "DISPLAY_TOP_PAGER" => "Y",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Страница",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Докладчики

Описание medsite:popup_message

Комплексный компонент для работы с докладчиками конференции. Компонент доступен при использовании решения Сайт конференции. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Докладчики.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип инфо-блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Инфо-блок | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок классов.
Инфо-блок докладов | REPORT_IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок докладов.
Количество элементов на странице | NEWS_COUNT | Указывается число элементов, выводимых на одну страницу.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • news - страница общего списка;
  • detail - страница детального просмотра.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
Настройки постраничной навигации детального просмотра
Выводить над списком | DETAIL_DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация при детальном просмотре будет выведена вверху страницы, над списком.
Выводить под списком | DETAIL_DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация при детальном просмотре будет выведена внизу страницы, под списком.
Название категорий | DETAIL_PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Название шаблона | DETAIL_PAGER_TEMPLATE | Указывается название шаблона.
Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Выбирается шаблон постраничной навигации:
  • .default;
  • arrows;
  • arrows_adm;
  • js;
  • modern;
  • orange;
  • visual;
  • blog;
  • forum;
  • (другое).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости.
Дополнительно
Выводить изображение для анонса | DISPLAY_PICTURE | [Y|N] При отмеченной опции будет выведено изображение для анонса.
Выводить E-mail | DISPLAY_EMAIL | [Y|N] При отмеченной опции будут выводиться e-mail докладчиков, если они заданы.
Выводить телефон | DISPLAY_PHONE | [Y|N] При отмеченной опции будут выведены номера телефонов докладчиков, если они заданы.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.
Настройки фильтра
Показывать фильтр | USE_FILTER | [Y|N] При отмеченной опции становятся доступными поля настройки фильтра. На странице разделов инфоблока отображается форма фильтра.
Фильтр | FILTER_NAME | Указывается имя переменной, в которой передается массив параметров из фильтра. Служит для определения выходящих из фильтра элементов. Если поле оставлено пустым, то используется значение по умолчанию.
Поля FILTER_FIELD_CODE Указываются поля, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | FILTER_PROPERTY_CODE | Указываются свойства, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Источник данных
Поле для первой сортировки новостей SORT_BY1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • NAME – по названию;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для первой сортировки новостей SORT_ORDER1 Задается направление для первой сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки новостей SORT_BY2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • NAME – по названию;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для второй сортировки новостей SORT_ORDER2 Задается направление для второй сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы.
Дополнительные настройки
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | [Y|N] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в парметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | Указываются группы пользователей, имеющие доступ к детальной информации.
Настройки списка
Максимальная длина анонса для вывода (только для типа текст) | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода (только для типа текст). При превышении параметра остаток текста будет отсечен.
Формат показа даты | LIST_ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Поля LIST_FIELD_CODE Указываются поля, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | LIST_PROPERTY_CODE | Указываются свойства, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Скрывать ссылку, если нет детального описания | HIDE_LINK_WHEN_NO_DETAIL | [Y|N] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
Настройки детального просмотра
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции будет выводиться название элемента.
Установить ключевые слова страницы из свойства | META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
Установить описание страницы из свойства | META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
Формат показа даты | DETAIL_ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Поля FIELD_CODE Указываются поля, которые будут отображены на странице детального просмотра. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице детального просмотра. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.speakers",
    "",
    Array(
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_EMAIL" => "Y",
        "DISPLAY_PHONE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "SEF_MODE" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "4",
        "REPORT_IBLOCK_ID" => "5",
        "NEWS_COUNT" => "20",
        "USE_FILTER" => "Y",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "CHECK_DATES" => "Y",
        "PREVIEW_TRUNCATE_LEN" => "",
        "LIST_ACTIVE_DATE_FORMAT" => "d.m.Y",
        "LIST_FIELD_CODE" => array("ID"),
        "LIST_PROPERTY_CODE" => array("company"),
        "HIDE_LINK_WHEN_NO_DETAIL" => "N",
        "DISPLAY_NAME" => "Y",
        "META_KEYWORDS" => "company",
        "META_DESCRIPTION" => "email",
        "DETAIL_ACTIVE_DATE_FORMAT" => "d.m.Y",
        "DETAIL_FIELD_CODE" => array("CODE"),
        "DETAIL_PROPERTY_CODE" => array("position"),
        "DETAIL_DISPLAY_TOP_PAGER" => "Y",
        "DETAIL_DISPLAY_BOTTOM_PAGER" => "Y",
        "DETAIL_PAGER_TITLE" => "Страница",
        "DETAIL_PAGER_TEMPLATE" => "",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => array("3"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "PAGER_TEMPLATE" => ".default",
        "DISPLAY_TOP_PAGER" => "Y",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Докладчики",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_DESC_NUMBERING" => "Y",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "FILTER_NAME" => "",
        "FILTER_FIELD_CODE" => array("ID"),
        "FILTER_PROPERTY_CODE" => array("company"),
        "SEF_FOLDER" => "/conf2013/visitors/speakers/",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y",
        "SEF_URL_TEMPLATES" => Array(
            "detail" => "#ELEMENT_ID#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "detail" => Array(),
        )
    )
);?>


Список докладчиков конференции

Описание conf.speakers.list

Одностраничный компонент для вывода списка докладчиков конференции. Компонент доступен при использовании решения Сайт конференции и содержит следующие шаблоны: .default, speakers_main_classic, speakers_main_dark, speakers_main_modern, speakers_main_social. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Докладчики.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Код информационного блока IBLOCK_ID Для указанного типа инфоблока выбирается инфоблок. При выборе пункта другое в поле рядом необходимо указать код инфоблока, например
={$_REQUEST["IBLOCK_ID"]}
Код информационного блока докладов | REPORT_IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок докладов.
Выводить только избранных докладчиков | DISPLAY_FAVORITS_ONLY | [Y|N] При отмеченной опции будут показаны только избранные докладчики.
Количество докладчиков на странице | SPEAKERS_COUNT | Указывается число докладчиков, выводимых на одну страницу.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Выбирается шаблон постраничной навигации:
  • .default;
  • arrows;
  • arrows_adm;
  • js;
  • modern;
  • orange;
  • visual;
  • blog;
  • forum;
  • (другое).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости.
Дополнительно
Выводить изображение для анонса | DISPLAY_PICTURE | [Y|N] При отмеченной опции будет выведено изображение для анонса.
Выводить E-mail | DISPLAY_EMAIL | [Y|N] При отмеченной опции будут выводиться e-mail докладчиков, если они заданы.
Выводить телефон | DISPLAY_PHONE | [Y|N] При отмеченной опции будут выведены номера телефонов докладчиков, если они заданы.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.
Источник данных
Поле для первой сортировки докладчиков SORT_BY1 Поле для первой сортировки докладчиков:
  • ID – по идентификатору;
  • NAME – по названию;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для первой сортировки докладчиков SORT_ORDER1 Задается направление для первой сортировки докладчиков:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки докладчиков SORT_BY2 Поле для второй сортировки докладчиков:
  • ID – по идентификатору;
  • NAME – по названию;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для второй сортировки докладчиков SORT_ORDER2 Задается направление для второй сортировки докладчиков:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Фильтр | FILTER_NAME | Указывается имя переменной, в которой передается массив параметров из фильтра.
Поля | FIELD_CODE | С помощью клавиши Ctrl выбираются поля инфоблока, по которым будет возможна фильтрация.
Свойства | PROPERTY_CODE | С помощью клавиши Ctrl выбираются cвойства элементов инфоблока, по которым будет возможна фильтрация.
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы.
Дополнительные настройки
Максимальная длина анонса для вывода (только для типа текст) | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода. При превышении параметра остаток текста будет отсечен.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | [Y|N] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Скрывать ссылку, если нет детального описания | HIDE_LINK_WHEN_NO_DETAIL | [Y|N] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
ID раздела | PARENT_SECTION | Указывается идентификатор "родительского" раздела для ограничения выборки элементов по нему.
Код раздела | PARENT_SECTION_CODE | Указывается код раздела.
Шаблоны ссылок
URL страницы детального просмотра | DETAIL_URL | Указывается шаблон ссылки на страницу детального просмотра.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.speakers.list",
    "",
    Array(
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_EMAIL" => "Y",
        "DISPLAY_PHONE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "4",
        "REPORT_IBLOCK_ID" => "5",
        "DISPLAY_FAVORITS_ONLY" => "N",
        "SPEAKERS_COUNT" => "20",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "FILTER_NAME" => "",
        "FIELD_CODE" => array("PREVIEW_TEXT"),
        "PROPERTY_CODE" => array("position"),
        "CHECK_DATES" => "Y",
        "DETAIL_URL" => "",
        "PREVIEW_TRUNCATE_LEN" => "",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "HIDE_LINK_WHEN_NO_DETAIL" => "Y",
        "PARENT_SECTION" => "",
        "PARENT_SECTION_CODE" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "PAGER_TEMPLATE" => ".default",
        "DISPLAY_TOP_PAGER" => "N",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Докладчики",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_DESC_NUMBERING" => "N",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "AJAX_OPTION_JUMP" => "Y",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "Y"
    )
);?>


Отправить отзыв по этому разделу

Новости

  • RSS новости конференции (экспорт)
  • Новости конференции
  • Список новостей конференции
  • Список фотографий конференции


RSS новости конференции (экспорт)

Описание conf.rss.out

Одностраничный компонент для экспорта новостей в формате RSS. Компонент доступен при использовании решения Сайт конференции. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Новости.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут экспортированы в rss.
Раздел | SECTION_ID | Указывается ID или символьный идентификатор раздела, новости из которого будут экспортированы в rss.
Код раздела | SECTION_CODE | Указывается код раздела, новости из которого будут экспортированы в rss.
Количество новостей для экспорта | NUM_NEWS | Указывается число экспортируемых в rss новостей.
Количество дней для экспорта | NUM_DAYS | Указывается, за какое число дней экспортировать новости.
Источник данных
Поле для первой сортировки новостей SORT_BY1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для первой сортировки новостей.
Направление для первой сортировки новостей SORT_ORDER1 Задается направление для первой сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки новостей SORT_BY2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для второй сортировки новостей.
Направление для второй сортировки новостей SORT_ORDER2 Задается направление для второй сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Параметры RSS
Время жизни (в минутах) | RSS_TTL | Указывается количество минут, на которые канал может кешироваться перед обновлением ресурса.
Экспортировать в диалект Яндекса | YANDEX | [Y|N] При отмеченной опции новости будут экспортироваться в диалект Яндекса.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.rss.out",
    "",
    Array(
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "6",
        "SECTION_ID" => "",
        "SECTION_CODE" => "",
        "NUM_NEWS" => "20",
        "NUM_DAYS" => "30",
        "RSS_TTL" => "60",
        "YANDEX" => "Y",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Новости конференции

Описание conf.news

Комплексный компонент позволяет создать новостной раздел на сайте. Компонент доступен при использовании решения Сайт конференции. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Новости.

Параметры

Поле | Параметр | Описание
Управление адресами страниц
Включить поддержку ЧПУ IS_SEF [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить следующие параметры: SEF_FOLDER, SEF_URL_TEMPLATES.

Если режим поддержки ЧПУ выключен, то необходимо настроить следующие параметры: SECTION_ID, ELEMENT_ID.
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать. Все остальные настройки из этой секции дописываются к каталогу ЧПУ.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • news - страница общего списка;
  • section - страница раздела;
  • detail - страница детального просмотра;
  • search - страница поиска;
  • rss - страница RSS;
  • rss_section - страница RSS для раздела.
Идентификатор раздела | SECTION_ID | Указывается идентификатор раздела.
Идентификатор новости | ELEMENT_ID | Указывается идентификатор новости.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип инфо-блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока. Выбрав пункт (другое)->, можно указать вручную ID информационного блока.
Инфо-блок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
Отображать новости прошедших этапов | NEWS_OLD | [Y|N] При отмеченной опции будут отображены новости прошедших этапов.
Количество новостей в этапе | NEWS_OLD_CNT | Указывается количество новостей, отображаемых в одном этапе.
Количество новостей на странице | NEWS_COUNT | Указывается количество новостей, отображаемых на одной странице.
Разрешить поиск | USE_SEARCH | [Y|N] При отмеченной опции будет выведена форма поиска. Поиск будет осуществляться только в выводимой данным компонентом информации.
Настройки RSS
Разрешить RSS | USE_RSS | [Y|N] При отмеченной опции будет разрешен экспорт в RSS и доступны поля для спецификации настроек RSS: NUM_NEWS, NUM_DAYS и YANDEX.
Количество новостей для экспорта | NUM_NEWS | Задается количество новостей для экспорта.
Количество дней для экспорта | NUM_DAYS | Указывается количество дней для экспорта новостей.
Экспортировать в диалект Яндекса | YANDEX | [Y|N] При отмеченной опции новости будут экспортироваться в диалект Яндекса.
Настройки голосования
Разрешить голосование | USE_RATING | [Y|N] При отмеченной опции посетители смогут голосовать за новости, выставляя баллы, на странице с детальной информацией. При установленной опции становятся доступными следующие поля: MAX_VOTE и VOTE_NAMES.
Максимальный балл | MAX_VOTE | Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
Настройка материалов по теме
Выводить материалы по теме USE_CATEGORIES [Y|N] При отмеченной опции будут выводиться материалы по теме. Материалы в привязке к темам создаются следующим образом:
  • создается инфоблок (например, Темы), в котором определяются будущие темы материалов в виде разделов (разделы заполнять элементами не требуется);
  • в настройках инфоблока, элементы которого предполагается привязывать к созданным темам, определятся свойство типа Привязка к разделам и выбирается инфоблок, в котором разделы являются темами;
  • для каждого из элементов этого инфоблока задается свойство привязки к теме.
Инфоблоки CATEGORY_IBLOCK Указываются инфоблоки, из которых будет происходить выборка информации. В коде задается в виде массива:
array(0=>"33",1=>"29",2=>"8",),
Код свойства | CATEGORY_CODE | Указывается код свойства, в котором хранится привязка элемента к определенному разделу (например, THEMES).
Максимальное количество материалов из одного инфоблока | CATEGORY_ITEMS_COUNT | Указывается максимальное количество материалов (элементов), которое можно выбрать из одного инфоблока.
Стиль вывода материалов из инфоблока CATEGORY_THEME_ Выбирается способ вывода материалов из инфоблока:
  • В виде списка;
  • Предпросмотр картинок.
Настройки отзывов
Разрешить отзывы | USE_REVIEW | [Y|N] При отмеченной опции будет доступен функционал отзывов.
Количество сообщений на одной странице | MESSAGES_PER_PAGE | Параметр определяет количество выводимых на одной странице сообщений.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления отзыва в публичной части.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Задается путь к папке со смайликами относительно корня сайта.
ID форума для отзывов | FORUM_ID | Указывается идентификатор форума, в котором будут храниться отзывы пользователей.
Страница чтения темы (пусто - получить из настроек форума) | URL_TEMPLATES_READ | Указывается относительный путь к странице чтения темы на форуме. Если поле пусто, путь к странице будет получен из настроек форума.
Показать ссылку на форум | SHOW_LINK_TO_FORUM | [Y|N] При отмеченной опции на странице новости будет отображена ссылка на форум обсуждения.
Начинать тему текстом элемента | POST_FIRST_MESSAGE | [Y|N] При отмеченной опции сообщение в отзыве будет начинаться с анонса новости.
Настройки фильтра
Показывать фильтр | USE_FILTER | [Y|N] При отмеченной опции становятся доступными поля настройки фильтра. На странице разделов инфоблока отображается форма фильтра.
Фильтр | FILTER_NAME | Указывается имя переменной, в которой передается массив параметров из фильтра. Служит для определения выходящих из фильтра элементов. Если поле оставлено пустым, то используется значение по умолчанию.
Поля FILTER_FIELD_CODE Указываются поля, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | FILTER_PROPERTY_CODE | Указываются свойства, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Источник данных
Поле для первой сортировки новостей SORT_BY1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для первой сортировки новостей SORT_ORDER1 Задается направление для первой сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки новостей SORT_BY2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для второй сортировки новостей SORT_ORDER2 Задается направление для второй сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы.
Настройки списка
Максимальная длина анонса для вывода (только для типа текст) | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода (только для типа текст). При превышении параметра остаток текста будет отсечен.
Формат показа даты | LIST_ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Поля LIST_FIELD_CODE Указываются поля, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | LIST_PROPERTY_CODE | Указываются свойства, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Скрывать ссылку, если нет детального описания | HIDE_LINK_WHEN_NO_DETAIL | [Y|N] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
Настройки детального просмотра
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции будет выводиться название элемента.
Установить ключевые слова страницы из свойства | META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
Установить описание страницы из свойства | META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
Формат показа даты | DETAIL_ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Поля FIELD_CODE Указываются поля, которые будут отображены на странице детального просмотра. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице детального просмотра. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Настройки постраничной навигации детального просмотра
Выводить над списком | DETAIL_DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы детального просмотра.
Выводить под списком | DETAIL_DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы детального просмотра.
Название категорий | DETAIL_PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Название шаблона | DETAIL_PAGER_TEMPLATE | Указывается название шаблона постраничной навигации детального просмотра.
Дополнительные настройки
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | [Y|N] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в парметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | Указываются группы пользователей, имеющие доступ к детальной информации.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Выбирается шаблон постраничной навигации:
  • .default;
  • arrows;
  • arrows_adm;
  • js;
  • modern;
  • orange;
  • visual;
  • blog;
  • forum;
  • (другое).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости.
Дополнительно
Выводить изображение для анонса | DISPLAY_PICTURE | [Y|N] При отмеченной опции будет выведено изображение для анонса.
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будет выводиться дата элемента.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.news",
    "",
    Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "SEF_MODE" => "Y",
        "AJAX_MODE" => "N",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "6",
        "NEWS_OLD" => "Y",
        "NEWS_OLD_CNT" => "5",
        "NEWS_COUNT" => "20",
        "USE_SEARCH" => "Y",
        "USE_RSS" => "Y",
        "USE_RATING" => "Y",
        "USE_CATEGORIES" => "Y",
        "USE_REVIEW" => "Y",
        "USE_FILTER" => "Y",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "CHECK_DATES" => "Y",
        "PREVIEW_TRUNCATE_LEN" => "",
        "LIST_ACTIVE_DATE_FORMAT" => "d.m.Y",
        "LIST_FIELD_CODE" => array("XML_ID"),
        "LIST_PROPERTY_CODE" => array(),
        "HIDE_LINK_WHEN_NO_DETAIL" => "Y",
        "DISPLAY_NAME" => "Y",
        "META_KEYWORDS" => "-",
        "META_DESCRIPTION" => "-",
        "DETAIL_ACTIVE_DATE_FORMAT" => "d.m.Y",
        "DETAIL_FIELD_CODE" => array("CODE"),
        "DETAIL_PROPERTY_CODE" => array(),
        "DETAIL_DISPLAY_TOP_PAGER" => "N",
        "DETAIL_DISPLAY_BOTTOM_PAGER" => "Y",
        "DETAIL_PAGER_TITLE" => "Страница",
        "DETAIL_PAGER_TEMPLATE" => "",
        "DISPLAY_PANEL" => "N",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => array("2"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "PAGER_TEMPLATE" => ".default",
        "DISPLAY_TOP_PAGER" => "N",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Новости",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_DESC_NUMBERING" => "Y",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "FILTER_NAME" => "",
        "FILTER_FIELD_CODE" => array("CODE"),
        "FILTER_PROPERTY_CODE" => array(),
        "NUM_NEWS" => "20",
        "NUM_DAYS" => "30",
        "YANDEX" => "N",
        "MAX_VOTE" => "5",
        "VOTE_NAMES" => array("1","2","3","4","5"),
        "CATEGORY_IBLOCK" => array(),
        "CATEGORY_CODE" => "CATEGORY",
        "CATEGORY_ITEMS_COUNT" => "5",
        "MESSAGES_PER_PAGE" => "10",
        "USE_CAPTCHA" => "Y",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "URL_TEMPLATES_READ" => "",
        "SHOW_LINK_TO_FORUM" => "Y",
        "POST_FIRST_MESSAGE" => "Y",
        "SEF_FOLDER" => "/conf2013/visitors/",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "SEF_URL_TEMPLATES" => Array(
            "section" => "#SECTION_ID#/",
            "detail" => "#SECTION_ID#/#ELEMENT_ID#/",
            "search" => "search/",
            "rss" => "rss/",
            "rss_section" => "#SECTION_ID#/rss/"
        ),
        "VARIABLE_ALIASES" => Array(
            "section" => Array(),
            "detail" => Array(),
            "search" => Array(),
            "rss" => Array(),
            "rss_section" => Array(),
        )
    )
);?>


Список новостей конференции

Описание conf.news.list

Одностраничный компонент выводит список новостей конференции из одного информационного блока. Компонент доступен при использовании решения Сайт конференции и содержит следующие шаблоны: .default, main_news_classic, main_news_dark, main_news_modern, main_news_social. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Новости.

Параметры

Поле | Параметр | Описание
Дополнительно
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будут выведены даты элементов.
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции для каждого элемента будет выведено его название.
Выводить изображение для анонса | DISPLAY_PICTURE | [Y|N] При отмеченной опции будут выведены изображения для элемента, если они заданы.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, новости из которого будут выводиться.
Отображать новости прошедших этапов | NEWS_OLD | [Y|N] При отмеченной опции будут показаны новости прошедших этапов.
Количество новостей в этапе | NEWS_OLD_CNT | Указывается число новостей в одном этапе.
Количество новостей на странице | NEWS_COUNT | Указывается количество новостей, отображаемых на одной странице.
Источник данных
Поле для первой сортировки новостей SORT_BY1 Поле для первой сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для первой сортировки новостей.
Направление для первой сортировки новостей SORT_ORDER1 Задается направление для первой сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки новостей SORT_BY2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для второй сортировки новостей.
Направление для второй сортировки новостей SORT_ORDER2 Задается направление для второй сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Фильтр | FILTER_NAME | Указывается имя переменной, в которой передается массив параметров из фильтра. Служит для определения выходящих из фильтра элементов. Если поле оставлено пустым, то используется значение по умолчанию.
Поля FIELD_CODE Указываются поля элементов инфоблока, по которым будет возможна фильтрация. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, по которым будет возможна фильтрация. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы.
Шаблоны ссылок
URL страницы детального просмотра (по умолчанию - из настроек инфоблока) | DETAIL_URL | Задается шаблон ссылки на страницу детального просмотра (по умолчанию - из настроек инфоблока).
Дополнительные настройки
Максимальная длина анонса для вывода (только для типа текст) | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода (только для типа текст). При превышении параметра остаток текста будет отсечен.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | При отмеченной опции кнопки будут отображены в режиме редактирования сайта на административной панели и в наборе кнопок области редактирования компонента.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Скрывать ссылку, если нет детального описания | HIDE_LINK_WHEN_NO_DETAIL | [Y|N] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
ID раздела | PARENT_SECTION | Указывается числовой код раздела инфоблока, из которого будут выбраны новости. Поле может быть оставлено пустым, если указан Код раздела.
Код раздела | PARENT_SECTION_CODE | Указывается символьный код раздела инфоблока, из которого будут выбраны новости. Поле может быть оставлено пустым, если указан ID раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Выбирается шаблон постраничной навигации:
  • .default;
  • arrows;
  • arrows_adm;
  • js;
  • modern;
  • orange;
  • visual;
  • blog;
  • forum;
  • (другое).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация по элементам будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация по элементам будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости.

Пример вызова

<?$APPLICATION->IncludeComponent("bitrix:news.list","",Array(
        "bitrix:conf.news.list",
    "",
    Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "AJAX_MODE" => "Y",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "6",
        "NEWS_OLD" => "Y",
        "NEWS_OLD_CNT" => "5",
        "NEWS_COUNT" => "20",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "FILTER_NAME" => "",
        "FIELD_CODE" => array("ID"),
        "PROPERTY_CODE" => array(),
        "CHECK_DATES" => "Y",
        "DETAIL_URL" => "",
        "PREVIEW_TRUNCATE_LEN" => "",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "HIDE_LINK_WHEN_NO_DETAIL" => "Y",
        "PARENT_SECTION" => "1d",
        "PARENT_SECTION_CODE" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "PAGER_TEMPLATE" => ".default",
        "DISPLAY_TOP_PAGER" => "N",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Новости",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_DESC_NUMBERING" => "Y",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Список фотографий конференции

Описание conf.photogallery.float

Одностраничный компонент выводит список фотографий конференции. Компонент доступен при использовании решения Сайт конференции. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Новости.

Параметры

Поле | Параметр | Описание
Дополнительно
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будут выведены даты элементов.
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции для каждого элемента будет выведено его название.
Выводить изображение для анонса | DISPLAY_PICTURE | [Y|N] При отмеченной опции будут выведены изображения для элемента, если они заданы.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип информационного блока (используется только для проверки) | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, фотографии из которого будут выводиться.
Источник данных
Поле для первой сортировки фотографий SORT_BY1 Поле для первой сортировки фотографий:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для первой сортировки новостей.
Направление для первой сортировки новостей SORT_ORDER1 Задается направление для первой сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки новостей SORT_BY2 Поле для второй сортировки новостей:
  • ID – по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FORM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, можно сформировать свой вариант поля для второй сортировки новостей.
Направление для второй сортировки новостей SORT_ORDER2 Задается направление для второй сортировки новостей:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Фильтр | FILTER_NAME | Указывается имя переменной, в которой передается массив параметров из фильтра. Служит для определения выходящих из фильтра элементов. Если поле оставлено пустым, то используется значение по умолчанию.
Поля FIELD_CODE Указываются поля элементов инфоблока, по которым будет возможна фильтрация. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, по которым будет возможна фильтрация. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы.
Шаблоны ссылок
URL страницы детального просмотра (по умолчанию - из настроек инфоблока) | DETAIL_URL | Задается шаблон ссылки на страницу детального просмотра (по умолчанию - из настроек инфоблока).
Дополнительные настройки
Максимальная длина анонса для вывода (только для типа текст) | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода (только для типа текст). При превышении параметра остаток текста будет отсечен.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | При отмеченной опции кнопки будут отображены в режиме редактирования сайта на административной панели и в наборе кнопок области редактирования компонента.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Скрывать ссылку, если нет детального описания | HIDE_LINK_WHEN_NO_DETAIL | [Y|N] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
ID раздела | PARENT_SECTION | Указывается числовой код раздела инфоблока, из которого будут выбраны фотографии. Поле может быть оставлено пустым, если указан Код раздела.
Код раздела | PARENT_SECTION_CODE | Указывается символьный код раздела инфоблока, из которого будут выбраны фотографии. Поле может быть оставлено пустым, если указан ID раздела.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Выбирается шаблон постраничной навигации:
  • .default;
  • arrows;
  • arrows_adm;
  • js;
  • modern;
  • orange;
  • visual;
  • blog;
  • forum;
  • (другое).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация по элементам будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация по элементам будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.photogallery.float",
    "",
    Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "AJAX_MODE" => "N",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "8",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "FILTER_NAME" => "",
        "FIELD_CODE" => array("ID"),
        "PROPERTY_CODE" => array("PUBLIC_ELEMENT"),
        "CHECK_DATES" => "Y",
        "DETAIL_URL" => "",
        "PREVIEW_TRUNCATE_LEN" => "",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "HIDE_LINK_WHEN_NO_DETAIL" => "Y",
        "PARENT_SECTION" => "",
        "PARENT_SECTION_CODE" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "N",
        "PAGER_TEMPLATE" => ".default",
        "DISPLAY_TOP_PAGER" => "N",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "фотогалерея",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_DESC_NUMBERING" => "Y",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Отправить отзыв по этому разделу

Регистрация

  • Регистрация пользователя


Регистрация пользователя

Описание conf.registration

Одностраничный компонент служит для регистрации участника конференции. Компонент доступен при использовании решения Сайт конференции и содержит следующие шаблоны: .default, registration_classic, registration_dark, registration_modern, registration_modern_en. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Регистрация.

Параметры

Поле | Параметр | Описание
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Источник данных
ID веб-формы | WEB_FORM_ID | Указывается идентификатор веб-формы для заполнения.
Ф.И.О. | FIO_LIST | Выбирается поле веб-формы, в котором будет содержаться фамилия\имя\отчество участника.
E-mail | EMAIL_LIST | Выбирается поле веб-формы, в котором будет содержаться электронный адрес участника.
Рассылка | SUBSCRIPTION_LIST | Выбирается рассылка.
Запрашивать у пользователя подтверждение подписки на рассылку | SUBSCRIPTION_LIST | [Y|N] При отмеченной опции у пользователя будет запрашиваться подтверждение подписки на рассылку.
Сообщение об успешном добавлении | MESSAGE_ADD_OK | Указывается сообщение, которое будет отображено в случае успешного добавления результатов заполнения веб-формы.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить параметр [dw]SEF_FOLDER[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
[/di] .

Если режим поддержки ЧПУ выключен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Имена переменных VARIABLE_ALIASES Имена переменных для управления страницами.
[/di]VARIABLE_ALIASES.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.registration",
    "",
    Array(
        "SEF_MODE" => "Y",
        "WEB_FORM_ID" => "1",
        "FIO_LIST" => "2",
        "EMAIL_LIST" => "3",
        "SUBSCRIPTION_LIST" => "3",
        "NOTIFY_USER" => "Y",
        "MESSAGE_ADD_OK" => "Success",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SEF_FOLDER" => "/conf2013/",
        "VARIABLE_ALIASES" => Array(
        )
    )
);?>


Отправить отзыв по этому разделу

Партнеры

  • Список партнеров конференции


Список партнеров конференции

Описание conf.partners.list

Одностраничный компонент для вывода списка партнеров конференции. Компонент доступен при использовании решения Сайт конференции и содержит следующие шаблоны: .default, logo_only, logo_only_classic, logo_only_dark, logo_inly_modern, logo_inly_social, logo_vertical, logo_vertical_classic, logo_vertical_dark, logo_vertical_modern. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Партнеры.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Код информационного блока IBLOCK_ID Для указанного типа инфоблока выбирается инфоблок. При выборе пункта другое в поле рядом необходимо указать код инфоблока, например
={$_REQUEST["IBLOCK_ID"]}
Этап конференции | CONF_STAGE | Выбирается этап конференции.
ID раздела | PARENT_SECTION | Выбирается идентификатор раздела, по которому будет ограничена выборка элементов.
Количество партнеров на странице | PARTNERS_COUNT | Указывается число партнеров, выводимых на одну страницу.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Дополнительно
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции будет показано название элемента.
Выводить изображение для анонса | DISPLAY_PICTURE | [Y|N] При отмеченной опции будет выведено изображение для анонса.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выведен текст анонса для элементов, если он определен.
Источник данных
Поле для первой сортировки партнеров SORT_BY1 Поле для первой сортировки партнеров:
  • ID – по идентификатору;
  • NAME – по названию;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для первой сортировки партнеров SORT_ORDER1 Задается направление для первой сортировки партнеров:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки партнеров SORT_BY2 Поле для второй сортировки партнеров:
  • ID – по идентификатору;
  • NAME – по названию;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для второй сортировки партнеров SORT_ORDER2 Задается направление для второй сортировки партнеров:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Фильтр | FILTER_NAME | Указывается имя переменной, в которой передается массив параметров из фильтра.
Поля | FIELD_CODE | С помощью клавиши Ctrl выбираются поля инфоблока, по которым будет возможна фильтрация.
Свойства | PROPERTY_CODE | С помощью клавиши Ctrl выбираются cвойства элементов инфоблока, по которым будет возможна фильтрация.
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы инфоблока.
Дополнительные настройки
Максимальная длина анонса для вывода (только для типа текст) | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода. При превышении параметра остаток текста будет отсечен.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | [Y|N] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Скрывать ссылку, если нет детального описания | HIDE_LINK_WHEN_NO_DETAIL | [Y|N] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
Шаблоны ссылок
URL страницы детального просмотра | DETAIL_URL | Указывается шаблон ссылки на страницу детального просмотра.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.partners.list",
    "",
    Array(
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "AJAX_MODE" => "N",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "7",
        "CONF_STAGE" => "10",
        "PARENT_SECTION" => "0",
        "PARTNERS_COUNT" => "20",
        "SORT_BY1" => "SORT",
        "SORT_ORDER1" => "ASC",
        "SORT_BY2" => "NAME",
        "SORT_ORDER2" => "ASC",
        "FILTER_NAME" => "",
        "FIELD_CODE" => array("ID","ID"),
        "PROPERTY_CODE" => array("PARTNER_ADDRESS","PARTNER_ADDRESS"),
        "CHECK_DATES" => "Y",
        "DETAIL_URL" => "",
        "PREVIEW_TRUNCATE_LEN" => "1000",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "HIDE_LINK_WHEN_NO_DETAIL" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Отправить отзыв по этому разделу

Отзывы

  • Отзыв детально
  • Отзывы о конференции
  • Список отзывов о конференции


Отзыв детально

Описание conf.interview.detail

Одностраничный компонент для подробного показа отзыва о конференции. Компонент доступен при использовании решения Сайт конференции и содержит следующие шаблоны: .default, official. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Отзывы.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Код информационного блока IBLOCK_ID Для указанного типа инфоблока выбирается инфоблок. При выборе пункта другое в поле рядом необходимо указать код инфоблока, например
={$_REQUEST["IBLOCK_ID"]}
ID новости | ELEMENT_ID | Указывается идентификатор новости.
Код новости | ELEMENT_CODE | Указывается код новости.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Выбирается шаблон постраничной навигации:
  • .default;
  • arrows;
  • arrows_adm;
  • js;
  • modern;
  • orange;
  • visual;
  • blog;
  • forum;
  • (другое).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости.
Дополнительно
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будет выводиться дата элемента.
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции будет показано название элемента.
Выводить детальное изображение | DISPLAY_PICTURE | [Y|N] При отмеченной опции будет выводиться детальное изображение.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выводиться текст анонса.
Источник данных
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы.
Поля | FIELD_CODE | С помощью клавиши Ctrl выбираются поля, которые будут отображены на странице детального просмотра.
Свойства | PROPERTY_CODE | С помощью клавиши Ctrl выбираются cвойства, которые будут отображены на странице детального просмотра.
Дополнительные настройки
Установить ключевые слова страницы из свойства | META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
Установить описание страницы из свойства | META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
Установить заголовок окна браузера из свойства | BROWSER_TITLE | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится заголовок окна браузера.
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | [Y|N] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в параметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | С помощью клавиши Ctrl указываются группы пользователей, имеющие доступ к детальной информации.
Шаблоны ссылок
URL страницы просмотра списка элементов | IBLOCK_URL | Задается адрес страницы со списком элементов инфоблока.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.interview.detail",
    "",
    Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "AJAX_MODE" => "N",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "10",
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "ELEMENT_CODE" => "",
        "CHECK_DATES" => "Y",
        "FIELD_CODE" => array("ID"),
        "PROPERTY_CODE" => array("company"),
        "IBLOCK_URL" => "",
        "META_KEYWORDS" => "company",
        "META_DESCRIPTION" => "company",
        "BROWSER_TITLE" => "NAME",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => array("3"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "PAGER_TEMPLATE" => ".default",
        "DISPLAY_TOP_PAGER" => "N",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Страница",
        "PAGER_SHOW_ALL" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Отзывы о конференции

Описание conf.interview

Комплексный компонент для работы с отзывами о конференции. Компонент доступен при использовании решения Сайт конференции. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Отзывы.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип инфо-блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Инфо-блок | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок.
Количество интервью на странице | NEWS_COUNT | Указывается максимальное число интервью, выводимых на одну страницу.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) SEF_FOLDER Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • news - страница общего списка;
  • detail - страница детального просмотра.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
Дополнительно
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будет выводиться дата элемента.
Выводить изображение для анонса | DISPLAY_PICTURE | [Y|N] При отмеченной опции будет выводиться изображение для анонса.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выводиться текст анонса.
Источник данных
Поле для первой сортировки SORT_BY1 Поле для первой сортировки отзывов:
  • ID – по идентификатору;
  • NAME – по названию;
  • ACTIVE_FROM - по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для первой сортировки SORT_ORDER1 Задается направление для первой сортировки отзывов:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки SORT_BY2 Поле для второй сортировки отзывов:
  • ID – по идентификатору;
  • NAME – по названию;
  • ACTIVE_FROM - по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для второй сортировки SORT_ORDER2 Задается направление для второй сортировки отзывов:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы инфоблока.
Дополнительные настройки
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | При отмеченной опции кнопки будут отображены в режиме редактирования сайта на административной панели и в наборе кнопок области редактирования компонента.
Устанавливать заголовок страницы | SET_TITLE | При отмеченной опции в качестве заголовка страницы будет установлено имя текущего инфоблока.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | При установленной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в параметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | С помощью клавиши Ctrl выбираются группы пользователей, имеющие доступ к детальной информации.
Настройки списка
Максимальная длина анонса для вывода (только для типа текст) | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода. При превышении параметра остаток текста будет отсечен.
Формат показа даты | LIST_ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Поля LIST_FIELD_CODE Указываются поля, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | LIST_PROPERTY_CODE | Указываются свойства, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Скрывать ссылку, если нет детального описания | HIDE_LINK_WHEN_NO_DETAIL | [Y|N] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
Настройки детального просмотра
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции будет выводиться название элемента.
Установить ключевые слова страницы из свойства | META_KEYWORDS | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержатся ключевые слова.
Установить описание страницы из свойства | META_DESCRIPTION | Среди всех свойств, определенных для данного инфоблока, выбирается то, в котором содержится описание.
Формат показа даты | DETAIL_ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Поля FIELD_CODE Указываются поля, которые будут отображены на странице детального просмотра. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | PROPERTY_CODE | Указываются свойства, которые будут отображены на странице детального просмотра. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.
Настройки постраничной навигации детального просмотра
Выводить над списком | DETAIL_DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация при детальном просмотре будет выведена вверху страницы, над списком.
Выводить под списком | DETAIL_DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация при детальном просмотре будет выведена внизу страницы, под списком.
Название категорий | DETAIL_PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Название шаблона | DETAIL_PAGER_TEMPLATE | Указывается название шаблона.
Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Выбирается шаблон постраничной навигации:
  • .default;
  • arrows;
  • arrows_adm;
  • js;
  • modern;
  • orange;
  • visual;
  • blog;
  • forum;
  • (другое).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости.
Настройки фильтра
Показывать фильтр | USE_FILTER | [Y|N] При отмеченной опции становятся доступными поля настройки фильтра. На странице разделов инфоблока отображается форма фильтра.
Фильтр | FILTER_NAME | Указывается имя переменной, в которой передается массив параметров из фильтра. Служит для определения выходящих из фильтра элементов. Если поле оставлено пустым, то используется значение по умолчанию.
Поля FILTER_FIELD_CODE Указываются поля, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив:
Array("NAME","PREVIEW_TEXT","PREVIEW_PICTURE","DETAIL_TEXT",""),
При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже (т.е. если задан пустой массив), на странице списка будут выведены поля по умолчанию.
Свойства | FILTER_PROPERTY_CODE | Указываются свойства, которые будут отображены на странице списка элементов. Заполняется из публичной части редактора, удерживая клавишу Ctrl либо в коде, указывая массив. При выборе пункта (не выбрано)-> и без указания вычисления полей в строках ниже, на странице детального просмотра свойства не будут выведены.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.interview",
    "",
    Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "SEF_MODE" => "Y",
        "AJAX_MODE" => "N",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "10",
        "NEWS_COUNT" => "20",
        "USE_FILTER" => "Y",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "CHECK_DATES" => "Y",
        "PREVIEW_TRUNCATE_LEN" => "",
        "LIST_ACTIVE_DATE_FORMAT" => "d.m.Y",
        "LIST_FIELD_CODE" => array("CODE"),
        "LIST_PROPERTY_CODE" => array("company"),
        "HIDE_LINK_WHEN_NO_DETAIL" => "N",
        "DISPLAY_NAME" => "Y",
        "META_KEYWORDS" => "company",
        "META_DESCRIPTION" => "company",
        "DETAIL_ACTIVE_DATE_FORMAT" => "d.m.Y",
        "DETAIL_FIELD_CODE" => array("ID"),
        "DETAIL_PROPERTY_CODE" => array("company"),
        "DETAIL_DISPLAY_TOP_PAGER" => "N",
        "DETAIL_DISPLAY_BOTTOM_PAGER" => "Y",
        "DETAIL_PAGER_TITLE" => "Страница",
        "DETAIL_PAGER_TEMPLATE" => "",
        "DISPLAY_PANEL" => "Y",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "Y",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => array("3"),
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "PAGER_TEMPLATE" => ".default",
        "DISPLAY_TOP_PAGER" => "N",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Интервью",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_DESC_NUMBERING" => "N",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "FILTER_NAME" => "",
        "FILTER_FIELD_CODE" => array("ID"),
        "FILTER_PROPERTY_CODE" => array("company"),
        "SEF_FOLDER" => "/conf2013/",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N",
        "SEF_URL_TEMPLATES" => Array(
            "detail" => "#ELEMENT_ID#/"
        ),
        "VARIABLE_ALIASES" => Array(
            "detail" => Array(),
        )
    )
);?>


Список отзывов о конференции

Описание conf.interview.list

Одностраничный компонент для вывода списка отзывов о конференции. Компонент доступен при использовании решения Сайт конференции. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Отзывы.

Параметры

Поле | Параметр | Описание
Управление режимом AJAX
Включить режим AJAX | AJAX_MODE | [Y|N] При установленной опции для компонента будет включен режим AJAX.
Включить прокрутку к началу компонента | AJAX_OPTION_JUMP | [Y|N] Если пользователь совершит AJAX-переход, то при установленой опции по окончании загрузки произойдет прокрутка к началу компонента.
Включить подгрузку стилей | AJAX_OPTION_STYLE | [Y|N] Если параметр принимает значение "Y", то при совершении AJAX-переходов будет происходить подгрузка и обработка списка стилей, вызванных компонентом.
Включить эмуляцию навигации браузера | AJAX_OPTION_HISTORY | [Y|N] Когда пользователь выполняет AJAX-переходы, то при включенной опции можно использовать кнопки браузера "Назад" и "Вперед".
Основные параметры
Тип информационного блока | IBLOCK_TYPE | Выбирается один из созданных в системе типов информационного блока.
Код информационного блока | IBLOCK_ID | Для указанного типа инфоблока выбирается инфоблок.
Количество интервью на странице | NEWS_COUNT | Указывается максимальное число интервью, выводимых на одну страницу.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Кэшировать при установленном фильтре | CACHE_FILTER | [Y|N] При отмеченной опции каждый результат, полученный из фильтра, будет кешироваться.
Дополнительно
Выводить дату элемента | DISPLAY_DATE | [Y|N] При отмеченной опции будет выводиться дата элемента.
Выводить название элемента | DISPLAY_NAME | [Y|N] При отмеченной опции будет выводиться название элемента.
Выводить изображение для анонса | DISPLAY_PICTURE | [Y|N] При отмеченной опции будет выводиться изображение для анонса.
Выводить текст анонса | DISPLAY_PREVIEW_TEXT | [Y|N] При отмеченной опции будет выводиться текст анонса.
Источник данных
Поле для первой сортировки SORT_BY1 Поле для первой сортировки отзывов:
  • ID – по идентификатору;
  • NAME – по названию;
  • ACTIVE_FROM - по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для первой сортировки SORT_ORDER1 Задается направление для первой сортировки отзывов:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Поле для второй сортировки SORT_BY2 Поле для второй сортировки отзывов:
  • ID – по идентификатору;
  • NAME – по названию;
  • ACTIVE_FROM - по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения.
Выбрав пункт (другое)->, в поле рядом можно указать код нужного поля.
Направление для второй сортировки SORT_ORDER2 Задается направление для второй сортировки отзывов:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Фильтр | FILTER_NAME | Указывается имя переменной, в которой передается массив параметров из фильтра.
Поля | FIELD_CODE | С помощью клавиши Ctrl выбираются поля инфоблока, по которым будет возможна фильтрация.
Свойства | PROPERTY_CODE | С помощью клавиши Ctrl выбираются cвойства элементов инфоблока, по которым будет возможна фильтрация.
Показывать только активные на данный момент элементы | CHECK_DATES | [Y|N] При отмеченной опции будут показаны только активные на данный момент элементы инфоблока.
Дополнительные настройки
Максимальная длина анонса для вывода (только для типа текст) | PREVIEW_TRUNCATE_LEN | Указывается максимальная длина анонса для вывода. При превышении параметра остаток текста будет отсечен.
Формат показа даты | ACTIVE_DATE_FORMAT | Указывается формат показа даты. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Добавлять в админ. панель кнопки для данного компонента | DISPLAY_PANEL | [Y|N] При отмеченной опции кнопки для данного компонента будут отображены на административной панели.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено имя текущего раздела.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Включать инфоблок в цепочку навигации | INCLUDE_IBLOCK_INTO_CHAIN | [Y|N] При отмеченной опции в цепочку навигации будет добавлено имя инфоблока.
Включать раздел в цепочку навигации | ADD_SECTIONS_CHAIN | [Y|N] При отмеченной опции при переходе по разделам ифоблока в цепочку навигации будут добавлены названия разделов.
Скрывать ссылку, если нет детального описания | HIDE_LINK_WHEN_NO_DETAIL | [Y|N] При отмеченной опции ссылки будут скрыты, если нет детальной информации или у пользователя нет прав на ее просмотр.
ID раздела | PARENT_SECTION | Указывается идентификатор "родительского" раздела для ограничения выборки элементов по нему.
Код раздела | PARENT_SECTION_CODE | Указывается код раздела.
Настройки постраничной навигации
Шаблон постраничной навигации PAGER_TEMPLATE Выбирается шаблон постраничной навигации:
  • .default;
  • arrows;
  • arrows_adm;
  • js;
  • modern;
  • orange;
  • visual;
  • blog;
  • forum;
  • (другое).
Выводить над списком | DISPLAY_TOP_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена вверху страницы, над списком.
Выводить под списком | DISPLAY_BOTTOM_PAGER | [Y|N] При отмеченной опции постраничная навигация будет выведена внизу страницы, под списком.
Название категорий | PAGER_TITLE | Задается название категорий, по которым происходит перемещение при детальном просмотре (например, страница, глава и др.).
Выводить всегда | PAGER_SHOW_ALWAYS | [Y|N] При отмеченной опции постраничная навигация будет выводиться всегда.
Использовать обратную навигацию | PAGER_DESC_NUMBERING | [Y|N] При отмеченной опции будет использоваться обратная навигация. Для обратной навигации в системе происходит обратный отсчет страниц (последняя страница считается первой). Таким образом, постоянно меняется лишь последняя страница при добавлении нового элемента. Это верно, если новые элементы попадают всегда вверх списка (отсортированы по дате начала активности по убыванию).
Время кеширования страниц для обратной навигации | PAGER_DESC_NUMBERING_CACHE_TIME | Задается время кеширования страниц для обратной навигации.
Показывать ссылку "Все" | PAGER_SHOW_ALL | [Y|N] При отмеченной опции в постраничную навигацию будет добавлена ссылка Все, с помощью которой можно отобразить все новости.
Шаблоны ссылок
URL страницы детального просмотра | DETAIL_URL | Указывается шаблон ссылки на страницу детального просмотра.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.interview.list",
    "",
    Array(
        "DISPLAY_DATE" => "Y",
        "DISPLAY_NAME" => "Y",
        "DISPLAY_PICTURE" => "Y",
        "DISPLAY_PREVIEW_TEXT" => "Y",
        "AJAX_MODE" => "N",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "10",
        "NEWS_COUNT" => "20",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "SORT_BY2" => "SORT",
        "SORT_ORDER2" => "ASC",
        "FILTER_NAME" => "",
        "FIELD_CODE" => array("ID"),
        "PROPERTY_CODE" => array("company"),
        "CHECK_DATES" => "Y",
        "DETAIL_URL" => "",
        "PREVIEW_TRUNCATE_LEN" => "",
        "ACTIVE_DATE_FORMAT" => "d.m.Y",
        "DISPLAY_PANEL" => "N",
        "SET_TITLE" => "Y",
        "SET_STATUS_404" => "N",
        "INCLUDE_IBLOCK_INTO_CHAIN" => "Y",
        "ADD_SECTIONS_CHAIN" => "Y",
        "HIDE_LINK_WHEN_NO_DETAIL" => "N",
        "PARENT_SECTION" => "",
        "PARENT_SECTION_CODE" => "",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_FILTER" => "Y",
        "PAGER_TEMPLATE" => ".default",
        "DISPLAY_TOP_PAGER" => "N",
        "DISPLAY_BOTTOM_PAGER" => "Y",
        "PAGER_TITLE" => "Интервью",
        "PAGER_SHOW_ALWAYS" => "Y",
        "PAGER_DESC_NUMBERING" => "N",
        "PAGER_DESC_NUMBERING_CACHE_TIME" => "36000",
        "PAGER_SHOW_ALL" => "Y",
        "AJAX_OPTION_JUMP" => "N",
        "AJAX_OPTION_STYLE" => "Y",
        "AJAX_OPTION_HISTORY" => "N"
    )
);?>


Отправить отзыв по этому разделу

Фотогалерея 2.0

  • Альбом
  • Альбом (список)
  • Фото
  • Фото (список)
  • Фотогалерея 2.0


Альбом

Описание conf.photogallery.section

Компонент выводит информацию об альбоме. Компонент доступен при использовании решения Сайт конференции. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Конференции > Фотогалерея 2.0.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
Этап конференции | PARENT_SECTION | Выбирается этап конференции.
Альбом | Указывается код, в котором передается идентификатор альбома.
Код фотогалереи | USER_ALIAS | Указывается код фотогалереи.
Режим работы фотогалереи BEHAVIOUR Указывается режим работы фотогалереи:
  • пустое поле - простой режим, т.е. один пользователь;
  • USER - многопользовательский режим.
Если параметр принимает значение USER, то необходимо настроить параметр GALLERY_URL и GALLERY_SIZE.
Шаблоны ссылок
Список разделов | SECTIONS_TOP_URL | Указывается адрес страницы со списком разделов (альбомов).
URL страницы с содержимым раздела | SECTION_URL | Указывается адрес страницы с содержимым раздела (альбома).
Альбом (редактирование) | SECTION_EDIT_URL | Указывается адрес страницы редактирования параметров альбома.
Альбом (редактирование обложки) | SECTION_EDIT_ICON_URL | Указывается адрес страницы выбора обложки альбома.
Страница слайд-шоу | DETAIL_SLIDE_SHOW_URL | Указывается адрес страницы просмотра слайд-шоу.
Загрузка фото | UPLOAD_URL | Указывается адрес страницы загрузки фотографий. [/link].
Содержимое галереи | GALLERY_URL | Указывается адрес страницы просмотра содержимого галереи. Параметр доступен при многопользовательском режиме работы фотогалереи.
Дополнительные настройки
Формат вывода даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Размер альбома (px) | ALBUM_PHOTO_SIZE | Указывается размер картинки обложки фотоальбома в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Размер картинки-анонса альбома (px) | ALBUM_PHOTO_THUMBS_SIZE | Указывается размер картинки-анонса фотоальбома в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Возвращать массив данных альбома | RETURN_SECTION_INFO | [Y|N] При отмеченной опции компонент будет возвращать массив данных альбома.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] При отмеченной опции будет установлен статус 404, если не будут найдены элементы или раздел фотогалереи.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено <название_альбома>.
Размер фотогалереи | GALLERY_SIZE | Указывается размер галереи пользователя в Мб. Параметр доступен при многопользовательском режиме работы фотогалереи.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.photogallery.section",
    "",
    Array(
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "8",
        "PARENT_SECTION" => "15",
        "USER_ALIAS" => "525",
        "BEHAVIOUR" => "",
        "INDEX_URL" => "index.php",
        "SECTION_URL" => "section.php?SECTION_ID=#SECTION_ID#",
        "SECTION_EDIT_URL" => "section_edit.php?SECTION_ID=#SECTION_ID#",
        "SECTION_EDIT_ICON_URL" => "section_edit_icon.php?SECTION_ID=#SECTION_ID#",
        "DETAIL_SLIDE_SHOW_URL" => "slide_show.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "UPLOAD_URL" => "upload.php?SECTION_ID=#SECTION_ID#",
        "DATE_TIME_FORMAT" => "d.m.Y",
        "ALBUM_PHOTO_SIZE" => "150",
        "ALBUM_PHOTO_THUMBS_SIZE" => "70",
        "RETURN_SECTION_INFO" => "Y",
        "SET_STATUS_404" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_NOTES" => "",
        "SET_TITLE" => "Y"
    )
);?>


Альбом (список)

Описание conf.photogallery.section.lis

Одностраничный компонент выводит список альбомов. Компонент доступен при использовании решения Сайт конференции и содержит следующие шаблоны: .default, .big, media_classic, media_dark, media_modern. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Конференции > Фотогалерея 2.0.

Параметры

Поле | Параметр | Описание
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, в котором хранятся фотографии.
Этап конференции | PARENT_SECTION | Выбирается этап конференции.
ID раздела | SECTION_ID | Указывается числовой код, в котором передается идентификатор раздела. Поле может быть оставлено пустым, если указан Код раздела.
Код раздела | SECTION_CODE | Указывается символьный код раздела, из которого будут выбраны фотографии. Поле может быть оставлено пустым, если указан ID раздела.
Режим работы галереи BEHAVIOUR Указывается режим работы фотогалереи:
  • SIMPLE - простой, т.е. один пользователь;
  • USER - многопользовательский.
Если параметр принимает значение USER (многопользовательский), то необходимо настроить параметры USER_ALIAS, GALLERY_URL и GALLERY_SIZE.
Выводить список нескольких фотографий альбома вместо отображения обложки | PHOTO_LIST_MODE | [Y|N] При отмеченной опции вместо обложки будет выводиться список нескольких фотографий альбома.
Количество выводимых фотографий в списке альбомов | SHOWN_ITEMS_COUNT | Задается количество фотографий, которое будет показано на странице списка альбомов.
Первое поле сортировки фото ELEMENT_SORT_FIELD Указывается первое поле, по которому будет происходить сортировка фотографий:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER Указывается порядок сортировки фотографий:
  • по возрастанию (asc);
  • по убыванию (desc).
Второе поле сортировки фото ELEMENT_SORT_FIELD1 Указывается второе поле, по которому будет происходить сортировка фотографий:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER1 Указывается порядок сортировки фотографий:
  • по возрастанию (asc);
  • по убыванию (desc).
По какому полю сортируем разделы SORT_BY Указывается поле, по которому будет происходить сортировка альбомов:
  • ID – по идентификатору;
  • NAME – по названию;
  • SORT – по индексу сортировки;
  • ELEMENTS_CNT – по количеству элементов в альбоме;
  • UF_DATE – по дате.
Порядок сортировки разделов SORT_ORD Задается порядок сортировки фотографий в разделе:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Количество элементов на странице | PAGE_ELEMENTS | Указывается количество альбомов, выводимых на одной странице. Весь список альбомов будет выведен с помощью постраничной навигации.
Шаблоны ссылок
Главная страница | INDEX_URL | Указывается адрес страницы со списком разделов (альбомов).
URL страницы с содержимым раздела | SECTION_URL | Указывается адрес страницы с содержимым раздела (альбома).
Альбом (редактирование) | SECTION_EDIT_URL | Указывается адрес страницы редактирования параметров альбома.
Альбом (редактирование обложки) | SECTION_EDIT_ICON_URL | Указывается адрес страницы выбора обложки альбома.
Страница загрузки фото | UPLOAD_URL | Указывается адрес страницы загрузки фотографий.
Дополнительные настройки
Размер альбома (px) | ALBUM_PHOTO_SIZE | Указывается размер картинки обложки фотоальбома в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Размер картинки-анонса альбома (px) | ALBUM_PHOTO_THUMBS_SIZE | Указывается размер картинки-анонса фотоальбома в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Шаблон для постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указываются название шаблона для постраничной навигации.
Формат вывода даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] Если система не находит в каталоге элемент или раздел, то при отмеченной опции вместо HTTP статуса 200 будет сообщаться HTTP статус 404.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Альбомы.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.

Пример вызова

<$APPLICATION->IncludeComponent(
"bitrix:conf.photogallery.section.list",
    "",
    Array(
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "8",
        "PARENT_SECTION" => "0",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "SECTION_CODE" => "",
        "BEHAVIOUR" => "SIMPLE",
        "PHOTO_LIST_MODE" => "Y",
        "SHOWN_ITEMS_COUNT" => "6",
        "ELEMENT_SORT_FIELD" => "SORT",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD1" => "TIMESTAMP_X",
        "ELEMENT_SORT_ORDER1" => "asc",
        "SORT_BY" => "UF_DATE",
        "SORT_ORD" => "ASC",
        "INDEX_URL" => "index.php",
        "SECTION_URL" => "section.php?SECTION_ID=#SECTION_ID#",
        "SECTION_EDIT_URL" => "section_edit.php?SECTION_ID=#SECTION_ID#",
        "SECTION_EDIT_ICON_URL" => "section_edit_icon.php?SECTION_ID=#SECTION_ID#",
        "UPLOAD_URL" => "upload.php?SECTION_ID=#SECTION_ID#",
        "ALBUM_PHOTO_SIZE" => "200",
        "ALBUM_PHOTO_THUMBS_SIZE" => "120",
        "PAGE_ELEMENTS" => "0",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "DATE_TIME_FORMAT" => "d.m.Y",
        "SET_STATUS_404" => "Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600"
    )
);?>


Фото

Описание conf.photogallery.detail

Компонент выводит детальную информацию по фотографии. Компонент доступен при использовании решения Сайт конференции. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Конференции > Фотогалерея 2.0.

Параметры

Поле | Параметр | Описание
Дополнительно
Размер детальной фотографии (px) | THUMBS_SIZE | Указывается размер детальной фотографии в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
ID раздела | SECTION_ID | Указывается числовой код, в котором передается идентификатор раздела (альбома).
ID элемента | ELEMENT_ID | Указывается числовой код, в котором передается идентификатор элемента (фотографии).
Режим работы фотогалереи BEHAVIOUR Указывается режим работы фотогалереи:
  • SIMPLE - простой режим, т.е. один пользователь;
  • USER - многопользовательский режим.
Если параметр принмает значение USER, то необходимо настроить параметр USER_ALIAS и GALLERY_URL.
Код галереи | USER_ALIAS | Указывается имя переменной, в которой передается код галереи.
Первое поле сортировки фото ELEMENT_SORT_FIELD Указывается первое поле, по которому будут сортироваться фотографии:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER Задается первый порядок сортировки фотографий в разделе:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Второе поле сортировки фото ELEMENT_SORT_FIELD1 Указывается второе поле, по которому будут сортироваться фотографии:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER1 Задается второй порядок сортировки фотографий в разделе:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Свойства | PROPERTY_CODE | Указываются свойства фотографий, которые должны быть отображены.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено <название_альбома>.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в парметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | Указываются группы пользователей, имеющие доступ к детальной информации.
Формат вывода даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Показывать теги | SHOW_TAGS | [Y|N] При отмеченной опции будет показано облако тегов.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] При отмеченной опции будет установлен статус 404, если не будут найдены элементы или раздел фотогалереи.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Шаблоны ссылок
Содержимое галереи | GALLERY_URL | Указывается адрес страницы просмотра содержимого галереи пользователя.
Фото | DETAIL_URL | Указывается адрес страницы детального просмотра фотографии.
Фото (редактирование) | DETAIL_EDIT_URL | Указывается адрес страницы редактирования параметров фотографии.
Страница слайд-шоу | DETAIL_SLIDE_SHOW_URL | Указывается адрес страницы слайд-шоу содержимого галереи.
Страница поиска | SEARCH_URL | Указывается адрес страницы поиска.
Альбом | SECTION_URL | Указывается адрес страницы просмотра альбома.
Загрузка фото | UPLOAD_URL | Указывается адрес страницы загрузки фотографии.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.photogallery.detail",
    "",
    Array(
        "THUMBNAIL_SIZE" => "300",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "8",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "ELEMENT_ID" => $_REQUEST["ELEMENT_ID"],
        "BEHAVIOUR" => "USER",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "USER_ALIAS" => $_REQUEST["USER_ALIAS"],
        "ELEMENT_SORT_FIELD" => "SORT",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD1" => "PROPERTY_RATING",
        "ELEMENT_SORT_ORDER1" => "asc",
        "PROPERTY_CODE" => array("APPROVE_ELEMENT"),
        "GALLERY_URL" => "gallery.php?USER_ALIAS=#USER_ALIAS#",
        "DETAIL_URL" => "detail.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "DETAIL_EDIT_URL" => "detail_edit.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "DETAIL_SLIDE_SHOW_URL" => "slide_show.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "SEARCH_URL" => "search.php",
        "SECTION_URL" => "section.php?SECTION_ID=#SECTION_ID#",
        "UPLOAD_URL" => "upload.php?SECTION_ID=#SECTION_ID#&ACTION=upload",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => array(),
        "DATE_TIME_FORMAT" => "d.m.Y",
        "SHOW_TAGS" => "Y",
        "SET_STATUS_404" => "Y"
    )
);?>


Фото (список)

Описание conf.photogallery.detail.list

Компонент выводит список фотографий. Компонент доступен при использовании решения Сайт конференции и содержит следующие шаблоны: .default, simple, slider, slider_big, slider_fixed, slide_show, table_clear, table_clear_classic, table_clear_dark, table_clear_modern. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Конференции > Фотогалерея 2.0.

Параметры

Поле | Параметр | Описание
Дополнительно
Размер детальной фотографии (px) THUMBS_SIZE Указывается размер детальной фотографии в пикселях (px). Размер задается для одной стороны картинки, вторая будет высчитана пропорционально для загружаемого изображения.
Данное поле доступно только для шаблонов default, table_clear, table_clear_classic, table_clear_dark, table_clear_modern и simple.
Показывать навигацию SHOW_PAGE_NAVIGATION Задается способ показа навигации:
  • none - не показывать;
  • top - сверху;
  • bottom - снизу;
  • both - сверху и снизу.

Данное поле доступно только для шаблонов default, simple, slider, slider_fixed, table_clear, table_clear_classic, table_clear_dark, table_clear_modern.
Показывать элементы управления SHOW_CONTROLS [Y|N] При отмеченной опции на странице будут отображены кнопки по управлению фотографиями.
Данное поле доступно только для шаблонов default, table_clear, table_clear_classic, table_clear_dark, table_clear_modern.
Показывать голосования SHOW_RATING [Y|N] При отмеченной опции будут показаны голосования.
Данное поле доступно только для шаблонов default, simple, table_clear, table_clear_classic, table_clear_dark, table_clear_modern.
Показывать количество показов SHOW_SHOWS [Y|N] При отмеченной опции будет отображено количество показов.
Данное поле доступно только для шаблона default, simple, table_clear, table_clear_classic, table_clear_dark, table_clear_modern.
Показывать количество комментариев SHOW_COMMENTS [Y|N] При отмеченной опции будет отображено количество комментариев.
Данное поле доступно только для шаблона default, simple, table_clear, table_clear_classic, table_clear_dark, table_clear_modern.
Размер аватара галереи (используется при работе компонента в многопользовательском режиме, px) GALLERY_AVATAR_SIZE Указывается размер аватара галереи в пикселях (px)
Данное поле доступно только для шаблона simple.
Показывать теги SHOW_TAGS [Y|N] При отмеченной опции будут показаны теги.
Данное поле доступно только для шаблона table_clear, table_clear_classic, table_clear_dark, table_clear_modern.
Максимальный балл MAX_VOTE Указывается максимально возможный балл, т.е. число возможных оценок.
Данное поле доступно только для шаблона default, simple, table_clear, table_clear_classic, table_clear_dark, table_clear_modern.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
Данное поле доступно только для шаблонов default, simple, table_clear, table_clear_classic, table_clear_dark, table_clear_modern.
В качестве рейтинга показывать DISPLAY_AS_RATING Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • Рейтинг (rating) - высчитывается на основе формулы:

    Rating = (SUM(vote)+3.125*10) / (COUNT(*)+10), где:

    3.125 - это стартовый рейтинг. То есть изначально (при отсутствии голосов) рейтинг фотографии равен 3.125.

    10 - это константа, определяющая количество голосов, "утяжеляющих" первоначальное значение рейтинга (3.125). Это исключает случай, когда, например, трое проголосовавших человека могут вознести или опустить фотографию всего тремя голосами.

    При такой формуле расчета значение рейтинга получается более "плавное" и не так скачет при небольшом количестве голосующих. Чем больше голосов, тем больше рейтинг приближается к среднему арифметическому.

  • Среднее значение (vote_avg) - высчитывается как среднее арифметическое всех баллов к фотографии;
  • Рейтинг (главного модуля) (rating_main) - использование рейтинга главного модуля.

    Подробнее:

    - см. главу Рейтинги [image];
    - в блоге Рейтинги: создание собственного критерия рейтингования [image];
    - в блоге Саморегулируемое сообщество, построенное на двухфакторном рейтинге [image].

Данное поле доступно только для шаблона default и simple.
Вид кнопок рейтинга (главного модуля) RATING_MAIN_TYPE Указывается одно из значений, которое должно быть показано, если выбран Рейтинг (главного модуля) (rating_main):
  • по умолчанию;
  • like - Мне нравится (текстовый);
  • like_graphic - Мне нравится (графический);
  • standart_text - Нравится / Не нравится (текстовый);
  • standart - Нравится / Не нравится (графический).

Данное поле доступно только для шаблонов .default, simple.
ID активного элемента ELEMENT_ID Указывается идентификатор активного элемента.
Данное поле доступно только для шаблонов slider, slider_fixed и slide_show.
Размер слайдера (количество фотографий) SLIDER_COUNT_CELL Указывается количество фотографий, отображаемых в слайдере.
Данное поле доступно только для шаблонов slider и slider_fixed.
Дополнительные эскизы | ADDITIONAL_SIGHTS | Выбираются типы для эскизов, в которых фотографии будут доступны для просмотра.
Активный эскиз (один из множества дополнительных и основных эскизов) | PICTURES_SIGHT | Указывается тип эскиза, с которого начинается просмотр фотографий альбома.
Основные параметры
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, фотографии из которого будут выводиться.
Режим работы галереи BEHAVIOUR Указывается режим работы фотогалереи:
  • SIMPLE - обычный режим, т.е. один пользователь;
  • USER - многопользовательский режим.
Если параметр принимает значение USER, то необходимо настроить параметры USER_ALIAS, GALLERY_SIZE и GALLERY_URL.
Код галереи | USER_ALIAS | Указывается имя переменной, в которой передается код галереи. Например ={$_REQUEST["USER_ALIAS"]}.
ID раздела | SECTION_ID | В поле указывается код, в котором передается идентификатор раздела (альбома).
Дополнительные параметры выбора фото ELEMENT_LAST_TYPE Указываются дополнительные параметры выбора фото:
  • none - нет;
  • count - выбирать несколько последних фото (ID);
  • time - выбирать фото за последние несколько дней;
  • period - выбирать фото за период.
Если параметр принмает значение count, то необходимо настроить параметр ELEMENTS_LAST_COUNT.

Если параметр принмает значение time, то необходимо настроить параметр ELEMENTS_LAST_TIME.

Если параметр принмает значение period, то необходимо настроить параметры ELEMENTS_LAST_TIME_FROM и ELEMENTS_LAST_TIME_TO.
Количество последних фото для выбора | ELEMENTS_LAST_COUNT | Указывается количество последних фото для выбора.
Количество дней для выбора фото | ELEMENTS_LAST_TIME | Указывается количество дней для выбора фото.
Начало периода (ввести дату в формате "DD.MM.YYYY HH:MI:SS") | ELEMENTS_LAST_TIME_FROM | Указывается дата начала периода для выбора фото в формате DD.MM.YYYY HH:MI:SS.
Конец периода (ввести дату в формате "DD.MM.YYYY HH:MI:SS") | ELEMENTS_LAST_TIME_TO | Указывается дата окончания периода для выбора фото в формате DD.MM.YYYY HH:MI:SS.
Первое поле сортировки фото ELEMENT_SORT_FIELD Указывается первое поле, по которому будет происходить сортировка фотографий:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER Указывается порядок сортировки фотографий:
  • по возрастанию (asc);
  • по убыванию (desc).
Второе поле сортировки фото ELEMENT_SORT_FIELD1 Указывается второе поле, по которому будет происходить сортировка фотографий:
  • SHOW_COUNTER – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • PROPERTY_RATING – по популярности;
  • PROPERTY_FORUM_MESSAGE_CNT – по количеству комментариев на форуме;
  • PROPERTY_BLOG_COMMENTS_CNT – по количеству комментариев в блоге.
Порядок сортировки фото ELEMENT_SORT_ORDER1 Указывается порядок сортировки фотографий:
  • по возрастанию (asc);
  • по убыванию (desc).
Свойства | PROPERTY_CODE | Выберите свойства фотографий, которые должны быть отображены.
Использовать обратную навигацию | USE_DESC_PAGE | [Y|N] При отмеченной опции будет использоваться обратная постраничная навигацию для списка фотографий.
Количество фото на странице | PAGE_ELEMENTS | Указывается количество фотографий, выводимых на одной странице. Остальные фотографий будут выведены с помощью постраничной навигации.
Название шаблона для постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указывается название шаблона для постраничной навигации.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Список фотографий.
Использовать дополнительное ограничение доступа | USE_PERMISSIONS | [Y|N] При отмеченной опции будет ограничен доступ к детальной информации элементов инфоблока. Группы пользователей, имеющие доступ к детальной информации, указываются в парметре GROUP_PERMISSIONS.
Группы пользователей, имеющие доступ к детальной информации | GROUP_PERMISSIONS | Указываются группы пользователей, имеющие доступ к детальной информации.
Формат вывода даты | DATE_TIME_FORMAT | Указывается формат показа даты и времени. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Устанавливать статус 404, если не найдены элемент или раздел | SET_STATUS_404 | [Y|N] При отмеченной опции будет установлен статус 404, если не будут найдены элементы или раздел фотогалереи.
Размер галереи | GALLERY_SIZE | Задается размер галереи одного пользователя в Мб.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Шаблоны ссылок
Содержимое галереи | GALLERY_URL | Указывается адрес страницы просмотра содержимого галереи пользователя.
Страница детального просмотра | DETAIL_URL | Указывается адрес страницы детального просмотра альбома.
Страница слайд-шоу | DETAIL_SLIDE_SHOW_URL | Указывается адрес страницы слайд-шоу.
Страница поиска | SEARCH_URL | Указывается адрес страницы поиска.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.photogallery.detail.list",
    "",
    Array(
        "THUMBNAIL_SIZE" => "120",
        "SHOW_PAGE_NAVIGATION" => "bottom",
        "SHOW_CONTROLS" => "Y",
        "SHOW_RATING" => "Y",
        "SHOW_SHOWS" => "Y",
        "SHOW_COMMENTS" => "Y",
        "MAX_VOTE" => "5",
        "VOTE_NAMES" => array("1", "2", "3", "4", "5"),
        "DISPLAY_AS_RATING" => "rating",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "8",
        "BEHAVIOUR" => "SIMPLE",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "SECTION_ID" => $_REQUEST["SECTION_ID"],
        "ELEMENT_LAST_TYPE" => "none",
        "ELEMENT_SORT_FIELD" => "SORT",
        "ELEMENT_SORT_ORDER" => "asc",
        "ELEMENT_SORT_FIELD1" => "SHOW_COUNTER",
        "ELEMENT_SORT_ORDER1" => "asc",
        "PROPERTY_CODE" => array("PUBLIC_ELEMENT", "PUBLIC_ELEMENT"),
        "DETAIL_URL" => "detail.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "DETAIL_SLIDE_SHOW_URL" => "slide_show.php?SECTION_ID=#SECTION_ID#&ELEMENT_ID=#ELEMENT_ID#",
        "SEARCH_URL" => "search.php",
        "USE_PERMISSIONS" => "Y",
        "GROUP_PERMISSIONS" => array("3"),
        "USE_DESC_PAGE" => "Y",
        "PAGE_ELEMENTS" => "50",
        "PAGE_NAVIGATION_TEMPLATE" => "",
        "DATE_TIME_FORMAT" => "d.m.Y",
        "SET_STATUS_404" => "Y",
        "ADDITIONAL_SIGHTS" => array(),
        "PICTURES_SIGHT" => "real"
    )
);?>


Фотогалерея 2.0

Описание conf.photogallery

Комплексный компонент позволяет получить полнофункциональную фотогалерею. Компонент доступен при использовании решения Сайт конференции и поддерживает два режима настройки: простой и расширенный. Компонент стандартный и входит в дистрибутив модуля.

В визуальном редакторе компонент находится в Компоненты > Конференции > Фотогалерея 2.0.

Внимание! Компонент поддерживает два режима настройки: простой и расширенный. Расширенный предоставляет более обширные средства настройки.

Параметры

Простой режим:

Поле | Параметр | Описание
Дополнительно
Показывать ссылки на главной странице SHOW_LINK_ON_MAIN_PAGE Указываются категории ссылок, которые будут отображены на главной старнице:
  • Новые (по дате добавления) (id);
  • Посещаемые (по количеству показов) (shows);
  • Лучшие (по количеству голосов) (rating);
  • Обсуждаемые (по количеству комментариев) (comments).
Основные параметры
Использовать простой режим настройки | USE_LIGHT_VIEW | [Y|N] При отмеченной опции будет использоваться простой режим настройки фотогалереи (значения остальных параметров будут по умолчанию).
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, в котором будут храниться фотографии.
Этап конференции | PARENT_SECTION | Выбирается этап конференции.
Путь к профилю пользователя | PATH_TO_USER | Указывается шаблон пути к странице пользователя.
Сортировать фотографии в альбоме перетаскиванием | DRAG_SORT | [Y|N] При отмеченной опции можно сортировать фотографии в альбоме перетаскиванием с помощью мыши.
Настройки отзывов
Разрешить отзывы USE_COMMENTS [Y|N] При отмеченной опции будет доступен функционал отзывов, станут активны [dw]дополнительные поля[/dw][di]
Компонент комментариев COMMENTS_TYPE Указывается модуль, с помощью которого будут добавляться комментарии:
  • Блоги (blog);
  • Форум (forum).
Если указать Блоги, то необходимо настроить следующие параметры: BLOG_URL, PATH_TO_BLOG.

Если указать Форум, то необходимо настроить параметр FORUM_ID.
ID форума для отзывов | FORUM_ID | Указывается один из созданных в системе форумов, который будет использован для комментариев.
Блог для комментариев | BLOG_URL | Указывается блог, в котором будут храниться комментарии.
Путь к блогу | PATH_TO_BLOG | Указывается путь к главной странице блога.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО комментирующего пользователя. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
[/di].
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - главная страница фотогалереи;
  • section - страница просмотра альбома;
  • section_edit - страница редактирования параметров альбома;
  • section_edit_icon - страница выбора обложки альбома;
  • upload - страница загрузки фотографий;
  • detail - страница просмотра фотографий;
  • detail_edit - страница редактирования параметров фотографии;
  • detail_list - страница со списком фотографий альбома;
  • search - страница поиска.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES и VARIABLE_ALIASES.

Если режим поддержки ЧПУ выключен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Идентификатор раздела | SECTION_ID | Указывается имя переменной, которой передается идентификатор раздела (альбома) фотогалереи.
Идентификатор элемента | ELEMENT_ID | Указывается имя переменной, которой передается идентификатор элемента (фотографии) фотогалереи.
Идентификатор страницы | PAGE_NAME | Указывается имя переменной, которой передается идентификатор страницы фотогалереи.
Идентификатор действия | ACTION | Указывается имя переменной, которой передается идентификатор действия фотогалереи.
[/di] SECTION_ID, ELEMENT_ID, PAGE_NAME и ACTION.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции будут установлены заголовки всех страниц в соответствии с их содержимым.
Настройки фотогалереи
Размер картинки фотоальбома (px) | ALBUM_PHOTO_SIZE | Указывается размер обложки фотоальбома в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Размер фотографии-анонса (px) | THUMBS_SIZE | Указывается размер картинки-анонса альбома в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Обязательно ограничивать размер оригинала (px) (при значении 0 ограничение не происходит) | ORIGINAL_SIZE | Задается размер оригинала фотографии в пикселях. Фотография будет уменьшена до указанной величины. Если указано значение 0, то изменение размера не происходит. Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Отображать список альбомов в качестве рубрик со списком последних добавленых фотографий | PHOTO_LIST_MODE | [Y|N] При отмеченной опции в списке альбомов-рубрик будут отображаться последние добавленные фотографии.
Количество выводимых фотографий в списке альбомов | SHOWN_ITEMS_COUNT | Задается количество отображаемых последних фотографий в альбомах в режиме, включенном параметром PHOTO_LIST_MODE.
Настройки голосования
Разрешить голосование USE_RATING [Y|N] При отмеченной опции посетители смогут голосовать за фотографии, выставляя баллы, на странице с детальной информацией. При установленной опции становятся доступными [dw]следующие поля:[/dw][di]
Максимальный балл MAX_VOTE Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
В качестве рейтинга показывать DISPLAY_AS_RATING Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • Рейтинг (rating) - высчитывается на основе формулы:

    Rating = (SUM(vote)+3.125*10) / (COUNT(*)+10), где:

    3.125 - это стартовый рейтинг. То есть изначально (при отсутствии голосов) рейтинг фотографии равен 3.125.

    10 - это константа, определяющая количество голосов, "утяжеляющих" первоначальное значение рейтинга (3.125). Это исключает случай, когда, например, трое проголосовавших человека могут вознести или опустить фотографию всего тремя голосами.

    При такой формуле расчета значение рейтинга получается более "плавное" и не так скачет при небольшом количестве голосующих. Чем больше голосов, тем больше рейтинг приближается к среднему арифметическому.

  • Среднее значение (vote_avg) - высчитывается как среднее арифметическое всех баллов к фотографии;
  • Рейтинг (главного модуля) (rating_main) - использование рейтинга главного модуля.

    Подробнее:

    - см. главу Рейтинги [image] [image];
    - в блоге Рейтинги: создание собственного критерия рейтингования [image] [image];
    - в блоге Саморегулируемое сообщество, построенное на двухфакторном рейтинге [image] [image].
Вид кнопок рейтинга RATING_MAIN_TYPE Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • по умолчанию;
  • Плюс / минус (standart);
  • Мне нравится (like).

Параметр доступен только если выбран Рейтинг (главного модуля) (rating_main).
[/di] MAX_VOTE и VOTE_NAMES.
Настройки тегов
Показывать теги SHOW_TAGS [Y|N] При отмеченной опции будет показано облако тегов фотогалереи. Станут активными [dw]дополнительные поля[/dw][di]
Количество тегов | TAGS_PAGE_ELEMENTS | Указывается количество тегов, отображаемых в облаке.
Максимальный размер шрифта (px) | TAGS_FONT_MAX | Указывается максимальный размер шрифта отображения тегов (в пикселах).
Минимальный размер шрифта (px) | TAGS_FONT_MIN | Указывается минимальный размер шрифта отображения тегов (в пикселах).
Цвет более позднего тега (пример: "C0C0C0") | TAGS_COLOR_NEW | Указывается код цвета тегов, дата создания которых наиболее поздняя (пример: "C0C0C0").
Цвет более раннего тега (пример: "FEFEFE") | TAGS_COLOR_OLD | Указывается код цвета тегов, дата создания которых наиболее ранняя (пример: "FEFEFE").
[/di].
Загрузка фото
Тип загрузчика PHOTO_UPLOADER_TYPE Указывается тип загрузчика фотографий в фотогалерею:
  • Одиночная загрузка через форму (form);
  • Множественный загрузчик (Java/ActiveX) (applet);
  • Множественный Flash-загрузчик (flash).
Схема множественного загрузчика APPLET_LAYOUT Параметр определяет тип загрузчика в фотогалерии по умолчанию:
  • Стандартный шаблон (extended);
  • Упрощенный шаблон загрузчика (simple).
Выбор параметра доступен только при выборе параметра "Тип загрузчика" (PHOTO_UPLOADER_TYPE) равным "Множественный загрузчик (Java/ActiveX)" (applet)
Максимальный размер загружаемого файла (не должен превышать 1024Mб) (Мб) | UPLOAD_MAX_FILE_SIZE | Указывается максимальный размер загружаемого фото в Мб (не должен превышать 1024Mб).
Наносить авторский знак USE_WATERMARK [Y|N] При отмеченной опции при загрузке фотографий можно будет наносить авторский знак. Станут доступны [dw]поля настройки авторского знака[/dw][di]
Правила нанесения авторского знака WATERMARK_RULES Указывается правило нанесения авторского знака:
  • На усмотрение пользователя (USER);
  • Обязательно наносить авторский знак (ALL).
Если выбрано значение ALL, то дополнительно необходимо настроить следующие параметры:
  • WATERMARK_POSITION и WATERMARK_TRANSPARENCY;
  • в зависимости от значения параметра WATERMARK_TYPE настроить соответствующие поля.
Размещение авторского знака WATERMARK_POSITION Указывается область размещения авторского знака на фото:
  • Сверху слева (tl);
  • Сверху по центру (tc);
  • Сверху справа (tr);
  • Cлева (ml);
  • По центру (mc);
  • Cправа (mr);
  • Снизу cлева (bl);
  • Снизу по центру (bc);
  • Снизу cправа (br).
Прозрачность авторского знака | WATERMARK_TRANSPARENCY | Задается величина прозрачности авторского знака (в %).
Тип авторского знака WATERMARK_TYPE Указывается тип авторского знака:
  • Надпись (текст) (TEXT);
  • Картинка (PICTURE).
Если выбрано значение TEXT, то дополнительно необходимо настроить параметры: WATERMARK_TEXT, WATERMARK_COLOR и WATERMARK_SIZE.

Если выбрано значение PICTURE, то дополнительно необходимо настроить параметры: WATERMARK_FILE и WATERMARK_FILE_ORDER.
Текст надписи | WATERMARK_TEXT | Задается текст авторского знака.
Цвет надписи (без #, например, FF00EE) | WATERMARK_COLOR | Указывается шестнадцатеричный код цвета надписи без использования #.
Размер надписи (% от размера картинки) | WATERMARK_SIZE | Задается размер надписи авторского знака в процентном соотношении от размера фото.
Физический полный путь к картинке | WATERMARK_FILE | Указывается полный путь к картинке для авторского знака относительно корня сайта.
Расположение картинки на фото WATERMARK_FILE_ORDER Указывается тип расположения картинки авторского знака на фото:
  • Без изменений (usual);
  • Растянуть (resize);
  • Замостить (repeat).
Файл со шрифтом для авторского знака | PATH_TO_FONT | Указывается файл со шрифтом для создания авторского знака (будет использоваться также и при множественной загрузке). Шрифты предварительно загружаются в директорию \bitrix\modules\photogallery\fonts\. Поддерживаются TTF-, OTF- и PS-шрифты.
Минимальный размер фото для авторского знака (px) | WATERMARK_MIN_PICTURE_SIZE | Указывается минимальный размер фото, на которых будет нанесен авторский знак в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально. На фотографии меньшего размера знак добавлен не будет.
[/di].

Расширенный режим:

Поле | Параметр | Описание
Дополнительно
Показывать ссылки на главной странице SHOW_LINK_ON_MAIN_PAGE Указываются категории ссылок, которые будут отображены на главной старнице:
  • Новые (по дате добавления) - (id);
  • Посещаемые (по количеству показов) - (shows);
  • Лучшие (по количеству голосов) - (rating);
  • Обсуждаемые (по количеству комментариев) - (comments).
Основные параметры
Использовать простой режим настройки | USE_LIGHT_VIEW | [Y|N] При отмеченной опции будет использоваться простой режим настройки фотогалереи (значения остальных параметров будут по умолчанию).
Тип инфоблока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационных блоков.
Инфоблок | IBLOCK_ID | Для выбранного типа инфоблоков указывается идентификатор информационного блока, в котором будут храниться фотографии.
Этап конференции | PARENT_SECTION | Выбирается этап конференции.
По какому полю сортируем альбомы SECTION_SORT_BY Указывается поле, по которому будет происходить сортировка альбомов:
  • ID - по идентификатору;
  • NAME - по названию;
  • SORT - по индексу сортировки;
  • ELEMENTS_CNT - по количесву фото в альбоме;
  • UF_DATE - по дате.
Порядок сортировки альбомов SECTION_SORT_ORD Задается порядок сортировки альбомов:
  • ASC – по возрастанию;
  • DESC – по убыванию.
По какому полю сортируем фото ELEMENT_SORT_FIELD Указывается поле, по которому будет происходить сортировка фотографий:
  • SHOWS – по количеству просмотров в среднем;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X – по дате последнего изменения;
  • NAME – по названию;
  • ID – по идентификатору;
  • RATING – по популярности;
  • COMMENTS – по комментариям.
Порядок сортировки фото в альбомах ELEMENT_SORT_ORDER Задается порядок сортировки фотографий в альбомах:
  • ASC – По возрастанию;
  • DESC – По убыванию.
Путь к профилю пользователя | PATH_TO_USER | Указывается шаблон пути к профилю пользователя.
Сортировать фотографии в альбоме перетаскиванием | DRAG_SORT | [Y|N] При отмеченной опции можно сортировать фотографии в альбоме перетаскиванием с помощью мыши.
Настройки отзывов
Разрешить отзывы USE_COMMENTS [Y|N] При отмеченной опции будет доступен функционал отзывов. При расширенном режиме станут доступны [dw]дополнительные поля[/dw][di]
Компонент комментариев COMMENTS_TYPE Указывается модуль, с помощью которого будут добавляться комментарии:
  • Блоги (blog);
  • Форум (forum).
Если указать Блоги, то необходимо настроить следущие параметры: BLOG_URL, PATH_TO_BLOG.

Если указать Форум, то необходимо настроить следущие параметры: FORUM_ID, URL_TEMPLATES_READ, URL_TEMPLATES_PROFILE_VIEW, USE_CAPTCHA, SHOW_LINK_TO_FORUM, PREORDER.
ID форума для отзывов | FORUM_ID | Указывается один из созданных в системе форумов, который будет использован для комментариев.
Блог для комментариев | BLOG_URL | Указывается блог, в котором будут храниться комментарии.
Путь к блогу | PATH_TO_BLOG | Указывается путь к главной странице блога.
Количество комментариев на странице | COMMENTS_COUNT | Указывается количество комментариев на странице.
Страница чтения темы | URL_TEMPLATES_READ | Указывается адрес страницы чтения темы форума.
Страница пользователя | URL_TEMPLATES_PROFILE_VIEW | Указывается адрес страницы профиля пользователя относительно корня сайта.
Путь относительно корня сайта к папке со смайлами | PATH_TO_SMILE | Указывается путь к папке со смайликами относительно корня сайта.
Использовать CAPTCHA | USE_CAPTCHA | [Y|N] При отмеченной опции будет выводиться изображение и поле ввода CAPTCHA в форме добавления комментария в публичной части.
Выводить сообщения в прямом порядке | PREORDER | [Y|N] При отмеченной опции собщения будут отсортированы по дате создания по возрастанию.
Начинать тему текстом элемента | POST_FIRST_MESSAGE | [Y|N] При отмеченной опции в обсуждении на форуме будет выведено первое сообщение отзыва.
Отображение имени | NAME_TEMPLATE | Указывается шаблон для отображения ФИО комментирующего пользователя. По умолчанию - значение Формат сайта (т.е используются значение Формат имени, указанное в закладке Параметры страницы Редактирование сайта). Указав пункт другое->, можно задать свой шаблон. Допустимы шаблоны: #NAME# - имя, #LAST_NAME# - фамилия, #SECOND_NAME# - отчество, #NAME_SHORT#, #LAST_NAME_SHORT#, #SECOND_NAME_SHORT# - сокращенные до одной буквы имя, фамилия и отчество.
[/di].
Управление адресами страниц
Включить поддержку ЧПУ SEF_MODE [Y|N] При отмеченной опции будет включена поддержка ЧПУ.

Если режим поддержки ЧПУ включен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Каталог ЧПУ (относительно корня сайта) | SEF_FOLDER | Каталог ЧПУ: путь до папки, с которой работает компонент. Этот путь может как совпадать с физическим путём, так и не совпадать.
Адреса страниц SEF_URL_TEMPLATES Указываются адреса следующих страниц:
  • index - главная страница фотогалереи;
  • section - страница просмотра альбома;
  • section_edit - страница редактирования параметров альбома;
  • section_edit_icon - страница выбора обложки альбома;
  • upload - страница загрузки фотографий;
  • detail - страница просмотра фотографий;
  • detail_edit - страница редактирования параметров фотографии;
  • detail_list - страница со списком фотографий альбома;
  • search - страница поиска.
Имена переменных | VARIABLE_ALIASES | Имена переменных для управления страницами.
[/di] SEF_FOLDER, SEF_URL_TEMPLATES и VARIABLE_ALIASES.

Если режим поддержки ЧПУ выключен, то необходимо настроить [dw]следующие параметры:[/dw][di]
Идентификатор раздела | SECTION_ID | Указывается имя переменной, которой передается идентификатор раздела (альбома) фотогалереи.
Идентификатор элемента | ELEMENT_ID | Указывается имя переменной, которой передается идентификатор элемента (фотографии) фотогалереи.
Идентификатор страницы | PAGE_NAME | Указывается имя переменной, которой передается идентификатор страницы фотогалереи.
Идентификатор действия | ACTION | Указывается имя переменной, которой передается идентификатор действия фотогалереи.
[/di] SECTION_ID, ELEMENT_ID, PAGE_NAME и ACTION.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Дополнительные настройки
Формат вывода даты альбома | DATE_TIME_FORMAT_SECTION | Указывается формат показа даты и времени альбома. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Формат вывода даты фото | DATE_TIME_FORMAT_DETAIL | Указывается формат показа даты и времени фотографии. В выпадающем списке перечислены все возможные варианты показа даты, формируемые внутри компонента. Выбрав пункт (другое)->, можно сформировать свой вариант на основании php-функции date.
Устанавливать заголовок страницы | SET_TITLE | [Y|N] При отмеченной опции в качестве заголовка страницы будет установлено Фотогалерея.
Настройки постраничной навигации
Количество альбомов на странице | SECTION_PAGE_ELEMENTS | Указывается количество альбомов на странице. Весь список альбомов будет выведен с помощью постраничной навигации.
Количество фото на странице | ELEMENTS_PAGE_ELEMENTS | Указывается количество фотографий на странице. Весь список фотографий будет выведен с помощью постраничной навигации.
Шаблон для постраничной навигации | PAGE_NAVIGATION_TEMPLATE | Указываются название шаблона для постраничной навигации.
Настройки фотогалереи
Размер картинки фотоальбома (px) | ALBUM_PHOTO_SIZE | Указывается размер картинки фотоальбома в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Размер фотографии-анонса (px) | THUMBS_SIZE | Указывается размер картинки-анонса альбома в пикселях (px). Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Качество фотографии-анонса (%) | JPEG_QUALITY1 | Указывается качество фотографии-анонса в процентах (100% - самое высокое качество).
Обязательно ограничивать размер оригинала (px) (при значении 0 ограничение не происходит) | ORIGINAL_SIZE | Задается размер оригинала фотографии в пикселях. Фотография будет уменьшена до указанной величины. Если указано значение 0, то изменение размера не происходит. Размер задается для большей стороны картинки, другая сторона загружаемого изображения будет высчитана пропорционально.
Качество загружаемой фотографии (%) | JPEG_QUALITY | Указывается качество загружаемой фотографии в процентах (100% - самое высокое качество).
Дополнительные эскизы | ADDITIONAL_SIGHTS | Указываются типы для эскизов фотографий, которые должны быть показаны.
Отображать список альбомов в качестве рубрик со списком последних добавленых фотографий | PHOTO_LIST_MODE | [Y|N] При отмеченной опции в списке альбомов-рубрик будут отображаться последние добавленные фотографии.
Количество выводимых фотографий в списке альбомов | SHOWN_ITEMS_COUNT | Задается количество отображаемых последних фотографий в альбомах в режиме, включенном параметром PHOTO_LIST_MODE.
Отображать навигационную цепочку 'хлебные крошки' в рамках комплексного компонента | SHOW_NAVIGATION | [Y|N] При отмеченной опции на странице фотогалереи будет отображаться навигационная цепочка ('хлебные крошки').
Настройки голосования
Разрешить голосование USE_RATING [Y|N] При отмеченной опции посетители смогут голосовать за фотографии, выставляя баллы, на странице с детальной информацией. При установленной опции становятся доступными [dw]следующие поля:[/dw][di]
Максимальный балл MAX_VOTE Указывается максимально возможный балл, т.е. число возможных оценок.
Подписи к баллам VOTE_NAMES Указываются подписи к каждому баллу. В коде вводится массив, в котором задаются подписи к баллам в таком виде:
"VOTE_NAMES" => Array("0","1","2","3","4","5"),
Если подписи заданы, то они будут выведены вместо оценок-цифр. Если массив не задан, то будут использованы значения по умолчанию.
В качестве рейтинга показывать DISPLAY_AS_RATING Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • Рейтинг (rating) - высчитывается на основе формулы:

    Rating = (SUM(vote)+3.125*10) / (COUNT(*)+10), где:

    3.125 - это стартовый рейтинг. То есть изначально (при отсутствии голосов) рейтинг фотографии равен 3.125.

    10 - это константа, определяющая количество голосов, "утяжеляющих" первоначальное значение рейтинга (3.125). Это исключает случай, когда, например, трое проголосовавших человека могут вознести или опустить фотографию всего тремя голосами.

    При такой формуле расчета значение рейтинга получается более "плавное" и не так скачет при небольшом количестве голосующих. Чем больше голосов, тем больше рейтинг приближается к среднему арифметическому.

  • Среднее значение (vote_avg) - высчитывается как среднее арифметическое всех баллов к фотографии;
  • Рейтинг (главного модуля) (rating_main) - использование рейтинга главного модуля.

    Подробнее:

    - см. главу Рейтинги [image] [image];
    - в блоге Рейтинги: создание собственного критерия рейтингования [image] [image];
    - в блоге Саморегулируемое сообщество, построенное на двухфакторном рейтинге [image] [image].
Вид кнопок рейтинга RATING_MAIN_TYPE Указывается одно из значений, которое должно быть показано в качестве рейтинга:
  • по умолчанию;
  • Плюс / минус (standart);
  • Мне нравится (like).

Параметр доступен только если выбран Рейтинг (главного модуля) (rating_main).
[/di] MAX_VOTE и VOTE_NAMES.
Настройки тегов
Показывать теги SHOW_TAGS [Y|N] При отмеченной опции будет показано облако тегов фотогалереи и станут доступны [dw]дополнительные поля[/dw][di]
Количество тегов | TAGS_PAGE_ELEMENTS | Указывается количество тегов, отображаемых в облаке.
Период выборки тегов (дней) | TAGS_PERIOD | Указывается количество дней, за которые происходит выборка тегов.
Сужать область поиска | TAGS_INHERIT | [Y|N] При отмеченной опции выбранные теги добавляются в фильтр поиска.
Максимальный размер шрифта (px) | TAGS_FONT_MAX | Указывается максимальный размер шрифта отображения тегов (в пикселах).
Минимальный размер шрифта (px) | TAGS_FONT_MIN | Указывается минимальный размер шрифта отображения тегов (в пикселах).
Цвет более позднего тега (пример: "C0C0C0") | TAGS_COLOR_NEW | Указывается код цвета тегов, дата создания которых наиболее поздняя (пример: "C0C0C0").
Цвет более раннего тега (пример: "FEFEFE") | TAGS_COLOR_OLD | Указывается код цвета тегов, дата создания которых наиболее ранняя (пример: "FEFEFE").
Показывать цепочку навигации | TAGS_SHOW_CHAIN | [Y|N] При отмеченной опции будет показана цепочка навигации. Параметр работает, если параметр TAGS_INHERIT принимает значение Y.
[/di].
Загрузка фото
Тип загрузчика PHOTO_UPLOADER_TYPE Указывается тип загрузчика фотографий в фотогалерею:
  • Одиночная загрузка через форму (form);
  • Множественный загрузчик (Java/ActiveX) (applet);
  • Множественный Flash-загрузчик (flash).
Схема множественного загрузчика APPLET_LAYOUT Параметр определяет тип загрузчика в фотогалерии по умолчанию:
  • Стандартный шаблон (extended);
  • Упрощенный шаблон загрузчика (simple).
Выбор параметра доступен только при выборе параметра "Тип загрузчика" (PHOTO_UPLOADER_TYPE) равным "Множественный загрузчик (Java/ActiveX)" (applet)
Максимальный размер загружаемого файла (не должен превышать 1024Mб) (Мб) | UPLOAD_MAX_FILE_SIZE | Указывается максимальный размер загружаемого файла в Мб (не должен превышать 1024Mб).
Наносить авторский знак USE_WATERMARK [Y|N] При отмеченной опции при загрузке фотографий можно будет наносить авторский знак. Станут доступны [dw]поля настройки авторского знака[/dw][di]
Правила нанесения авторского знака WATERMARK_RULES Указывается правило нанесения авторского знака:
  • На усмотрение пользователя (USER);
  • Обязательно наносить авторский знак (ALL).
Если выбрано значение ALL, то дополнительно необходимо настроить следующие параметры:
  • WATERMARK_POSITION и WATERMARK_TRANSPARENCY;
  • в зависимости от значения параметра WATERMARK_TYPE настроить соответствующие поля.
Размещение авторского знака WATERMARK_POSITION Указывается область размещения авторского знака на фото:
  • Сверху слева (tl);
  • Сверху по центру (tc);
  • Сверху справа (tr);
  • Cлева (ml);
  • По центру (mc);
  • Cправа (mr);
  • Снизу cлева (bl);
  • Снизу по центру (bc);
  • Снизу cправа (br).
Прозрачность авторского знака | WATERMARK_TRANSPARENCY | Задается величина прозрачности авторского знака (в %).
Тип авторского знака WATERMARK_TYPE Указывается тип авторского знака:
  • Надпись (текст) (TEXT);
  • Картинка (PICTURE).
Если выбрано значение TEXT, то дополнительно необходимо настроить параметры: WATERMARK_TEXT, WATERMARK_COLOR и WATERMARK_SIZE.

Если выбрано значение PICTURE, то дополнительно необходимо настроить параметры: WATERMARK_FILE и WATERMARK_FILE_ORDER.
Текст надписи | WATERMARK_TEXT | Задается текст авторского знака.
Цвет надписи (без #, например, FF00EE) | WATERMARK_COLOR | Указывается шестнадцатеричный код цвета надписи без использования #.
Размер надписи (% от размера картинки) | WATERMARK_SIZE | Задается размер надписи авторского знака в процентном соотношении от размера фото.
Физический полный путь к картинке | WATERMARK_FILE | Указывается полный путь к картинке для авторского знака относительно корня сайта.
Расположение картинки на фото WATERMARK_FILE_ORDER Указывается тип расположения картинки авторского знака на фото:
  • Без изменений (usual);
  • Растянуть (resize);
  • Замостить (repeat).
Файл со шрифтом для авторского знака | PATH_TO_FONT | Указывается полный путь к файлу шрифта для авторского знака относительно корня сайта.
Минимальный размер фото для авторского знака (px) | PATH_TO_FONT | Указывается минимальный размер фото в пикселях, меньше которого авторский знак наноситься не будет.
[/di].

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.photogallery",
    "",
    Array(
        "SHOW_LINK_ON_MAIN_PAGE" => array("id"),
        "USE_LIGHT_VIEW" => "Y",
        "SEF_MODE" => "Y",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "8",
        "PARENT_SECTION" => "0",
        "SECTION_SORT_BY" => "UF_DATE",
        "SECTION_SORT_ORD" => "DESC",
        "ELEMENT_SORT_FIELD" => "sort",
        "ELEMENT_SORT_ORDER" => "desc",
        "PATH_TO_USER" => "",
        "SECTION_PAGE_ELEMENTS" => "15",
        "ELEMENTS_PAGE_ELEMENTS" => "50",
        "ALBUM_PHOTO_SIZE" => "120",
        "THUMBNAIL_SIZE" => "100",
        "JPEG_QUALITY1" => "100",
        "ORIGINAL_SIZE" => "1280",
         "JPEG_QUALITY" => "100",
        "ADDITIONAL_SIGHTS" => array(),
        "PHOTO_LIST_MODE" => "Y",
        "SHOWN_ITEMS_COUNT" => "6",
        "SHOW_NAVIGATION" => "N",
        "DATE_TIME_FORMAT_DETAIL" => "d.m.Y",
        "DATE_TIME_FORMAT_SECTION" => "d.m.Y",
        "SET_TITLE" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
         "USE_RATING" => "Y",
        "SHOW_TAGS" => "Y",
        "DRAG_SORT" => "Y",
        "UPLOADER_TYPE" => "applet",
        "APPLET_LAYOUT" => "extended",
        "UPLOAD_MAX_FILE_SIZE" => "1024",
        "USE_WATERMARK" => "Y",
        "WATERMARK_RULES" => "USER",
        "PATH_TO_FONT" => "",
        "WATERMARK_MIN_PICTURE_SIZE" => "800",
        "MAX_VOTE" => "5",
        "VOTE_NAMES" => array("1","2","3","4","5"),
        "DISPLAY_AS_RATING" => "rating",
         "USE_COMMENTS" => "Y",
        "COMMENTS_TYPE" => "forum",
        "COMMENTS_COUNT" => "10",
        "PATH_TO_SMILE" => "/bitrix/images/forum/smile/",
        "USE_CAPTCHA" => "N",
        "PREORDER" => "N",
        "POST_FIRST_MESSAGE" => "N",
        "NAME_TEMPLATE" => "#NOBR##LAST_NAME# #NAME##/NOBR#",
        "TAGS_PAGE_ELEMENTS" => "150",
        "TAGS_INHERIT" => "Y",
        "TAGS_FONT_MAX" => "30",
        "TAGS_FONT_MIN" => "10",
        "TAGS_COLOR_NEW" => "3E74E6",
        "TAGS_COLOR_OLD" => "C0C0C0",
        "TAGS_SHOW_CHAIN" => "Y",
        "SEF_FOLDER" => "/conf2013/visitors/",
        "SEF_URL_TEMPLATES" => Array(
             "index" => "index.php",
            "section" => "#SECTION_ID#/",
            "section_edit" => "#SECTION_ID#/action/#ACTION#/",
            "section_edit_icon" => "#SECTION_ID#/icon/action/#ACTION#/",
            "upload" => "#SECTION_ID#/action/upload/",
            "detail" => "#SECTION_ID#/#ELEMENT_ID#/",
            "detail_edit" => "#SECTION_ID#/#ELEMENT_ID#/action/#ACTION#/",
            "detail_list" => "list/",
            "search" => "search/"
          ),
         "VARIABLE_ALIASES" => Array(
            "index" => Array(),
            "section" => Array(),
             "section_edit" => Array(),
            "section_edit_icon" => Array(),
            "upload" => Array(),
            "detail" => Array(),
            "detail_edit" => Array(),
            "detail_list" => Array(),
            "search" => Array(),
        )
    )
);?>


Отправить отзыв по этому разделу

Медиа

  • Видеотека


Видеотека

Отправить отзыв по этому разделу
...->Описание компонентов решений>Сайт конференции>Компоненты>Медиа>Видеотека

Медиа::Видеотека

Описание conf.iblock.tv

Одностраничный компонент осуществляет вывод видео с деревом роликов. Компонент доступен при использовании решения Сайт конференции и содержит следующие шаблоны: .default, round, section_list. Компонент является стандартным и входит в дистрибутив модуля.

Примечание: при настройке компонента учтите, что часть полей последовательно появляется после выбора вышестоящих параметров.

В визуальном редакторе компонент расположен по пути: Компоненты > Конференции > Медиа.

Параметры

Поле | Параметр | Описание
Настройки списка
Маленькое изображение по умолчанию | DEFAULT_SMALL_IMAGE | Указывается путь до маленького изображения ролика. Изображение будет показано в списке роликов.
Большое изображение по умолчанию | DEFAULT_BIG_IMAGE | Указывается путь до большого изображения ролика. Изображение будет показано на экране плеера перед началом просмотра видеоролика.
Поле для первой сортировки видео SORT_BY1 Поле для первой сортировки роликов:
  • ID - по идентификатору;
  • NAME – по заголовку;
  • ACTIVE_FROM – по дате начала активности;
  • SORT – по индексу сортировки;
  • TIMESTAMP_X - по дате последнего изменения.
Направление для первой сортировки видео SORT_ORDER1 Направление для первой сортировки роликов:
  • ASC – по возрастанию;
  • DECS – по убыванию.
Общие настройки компонента
Тип информационного блока | IBLOCK_TYPE | Указывается один из созданных в системе типов информационного блока.
Информационный блок | IBLOCK_ID | Для выбранного типа инфоблока указывается идентификатор информационного блока, из которого будет выводиться ролики.
Разрешить проигрывание swf-файлов (не рекомендуется) | ALLOW_SWF | [Y|N] При отмеченной опции будет разрешено проигрывание файлов формата swf. Не рекомендуется использовать в силу высокой степени опасности XSS-атаки через подключаемый файл.
Выводить элементы подразделов | SHOW_SUBSECTIONS | [Y|N] При отмеченной опции будут выводиться элементы подразделов.
Свойство, в котором хранится путь к ролику | PATH_TO_FILE | Задается свойство инфоблока, в котором указывается путь к файлу ролика.
Свойство, в котором хранится длительность ролика | DURATION | Задается свойство инфоблока, в котором указывается длительность воспроизведения ролика.
Настройки кеширования
Тип кеширования CACHE_TYPE Тип кеширования:
  • A - Авто + Управляемое: автоматически обновляет кеш компонентов в течение заданного времени или при изменении данных;
  • Y - Кешировать: для кеширования необходимо определить время кеширования;
  • N - Не кешировать: кеширования нет в любом случае.
Время кеширования (сек.) | CACHE_TIME | Время кеширования, указанное в секундах.
Учитывать права доступа | CACHE_GROUPS | [Y|N] При отмеченной опции будут учитываться права доступа при кешировании.
Статистика показов
Увеличить счетчик показов элемента | SHOW_COUNTER_EVENT | [Y|N] При отмеченной опции будет запущен счетчик показа каждого элемента (ролика).
Настройки плеера
Ширина области плеера | WIDTH | Указывается ширина области плеера в пикселях (px).
Высота области плеера | HEIGHT | Указывается высота области плеера в пикселях (px).
Логотип | LOGO | Указывается путь до файла с логотипом, накладываемым на ролик при просмотре.
Секция | SECTION_ID | Указывается раздел, ролики из которого будут отображены.
Элемент | ELEMENT_ID | Указывается элемент, который будет показан первым в окне медиа плеера.

Пример вызова

<?$APPLICATION->IncludeComponent(
"bitrix:conf.iblock.tv",
    "",
    Array(
        "DEFAULT_SMALL_IMAGE" => "/bitrix/components/bitrix/iblock.tv/templates/.default/images/default_small.png",
        "DEFAULT_BIG_IMAGE" => "/bitrix/components/bitrix/iblock.tv/templates/.default/images/default_big.png",
        "SORT_BY1" => "ACTIVE_FROM",
        "SORT_ORDER1" => "DESC",
        "IBLOCK_TYPE" => "s1_conference",
        "IBLOCK_ID" => "9",
        "ALLOW_SWF" => "Y",
        "SHOW_SUBSECTIONS" => "Y",
        "CACHE_TYPE" => "A",
        "CACHE_TIME" => "3600",
        "CACHE_GROUPS" => "Y",
        "SHOW_COUNTER_EVENT" => "Y",
        "PATH_TO_FILE" => "31",
        "DURATION" => "32",
        "WIDTH" => "400",
        "HEIGHT" => "300",
        "LOGO" => "/bitrix/components/bitrix/iblock.tv/templates/.default/images/logo.png",
        "SECTION_ID" => "18",
        "ELEMENT_ID" => "76"
    )
);?>


Отправить отзыв по этому разделу

Дополнительно

  • Местоположения 1.0


Местоположения 1.0

В данной главе описаны местоположения устаревшей схемы 1.0, которые доступны в более ранних версиях системы (версия модуля Интернет-магазин ниже, чем 14.10.1), либо в системе не осуществлялся переход на местоположения 2.0.


Группы местоположений

Страница Группы местоположений (Магазин > Настройки > Местоположения > Группы местоположений) служит для объединения местоположений в группы. Это облегчает работу с настройкой служб доставки. Вы можете создать группу местоположений и привязать к ней все службы доставки, которые осуществляют доставку в местоположения этой группы.

При появлении нового местоположения или изменения тарифов по какому-либо из существующих местоположений будет достаточно добавить или удалить это местоположение из группы местоположений. Изменять каждую из служб доставки, к которым имеет отношение это местоположение, не нужно.

Форма поиска

С помощью данной формы вы можете выполнить поиск групп местоположений в соответствии с указанными условиями.

Поле | Описание
Местоположение | Поиск групп по названию входящего в них местоположения.

Чтобы отобрать группы местоположений по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех групп местоположений нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Новая группа | Переход к форме создания новой группы местоположений.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список групп местоположений

Поле | Описание
Колонка флажков | Поле предназначено для выбора групп местоположений, к которым предполагается применить какое-либо правило или действие.
Действия Действия над группой местоположений:
  • Изменить параметры группы местоположений - редактирование группы местоположений;
  • Удалить местоположение - удаление группы местоположений. Удаление группы не влечет за собой удаление местоположений, входящих в эту группу.
ID | Идентификатор группы в системе.
Название | Название группы местоположений.
Сортировка | Относительный "вес", влияющий на положение группы в общем списке.


Создание и редактирование группы местоположений

Данная форма служит для задания свойств новой и редактирования параметров уже существующей группы местоположений.

Контекстная панель

Кнопка | Описание
Список групп местоположений | Переход на страницу со списком групп местоположений.
Добавить группу | Переход на страницу со списком групп местоположений. Кнопка отображается при редактировании существующей группы.
Удалить группу | Удаление редактируемой группы местоположений. Кнопка отображается при редактировании существующей группы.

Поля формы

Поле | Описание
ID | Уникальный идентификатор группы местоположений.
Сортировка | Относительный "вес", влияющий на положение данной группы местоположений в общем списке.
*Местоположения, входящие в группу | Выделите те местоположения, которые будут входить в данную группу. Для множественного выбора выделяйте местоположения с нажатой кнопкой Ctrl.
*Название | Название группы местоположений, для каждого языка, используемого в системе.

* - поля, обязательные для заполнения.

Смотрите также

  • Создание новой группы местоположений


Список местоположений

Страница Местоположения (Магазин > Настройки > Местоположения > Список местоположений) служит для настройки списка местоположений, из которого клиент магазина будет выбирать место для доставки заказа. Затем выбранное место будет использовано для вывода списка доступных служб доставки, расчёта стоимости доставки, а также в качестве части фактического адреса доставки.

Форма поиска

С помощью данной формы вы можете выполнить поиск местоположений в соответствии с указанными условиями.

Поле | Описание
Страна | Поиск местоположений по стране. Список стран представлен в виде поля со списком.
Страна* | Поле для задания условий поиска местоположений по странам.
Регион* | Поиск местоположений по региону.
Город* | Поиск местоположения по городу.

* - для данных полей вы можете воспользоваться специальными логическими выражениями [image].

Чтобы отобрать местоположения по заданным критериям поиска, нажмите кнопку Найти. Для отображения всех местоположений нажмите кнопку Отменить.

Контекстная панель

Кнопка | Описание
Добавить местоположение | Переход к форме создания нового местоположения.
Импорт местоположений | Переход на страницу импорта местоположений.
Настроить | Позволяет перейти к диалогу настройки внешнего вида отчетной формы.
Excel | Экспортирует данные из отображаемой таблицы в MS Excel.

Список местоположений

Поле | Описание
Колонка флажков | Поле предназначено для выбора местоположений, к которым предполагается применить какое-либо правило или действие.
Действия Действия над местоположением:
  • Изменить параметры местоположения - редактирование местоположения.
  • Удалить местоположение- удаление местоположения.
ID | Идентификатор местоположения.
Страна | Страна местоположения.
Регион | Регион местоположения.
Город | Город местоположения.
Сорт. | Относительный "вес" местоположения. Влияет на размещение местоположения в общем списке.


Создание и редактирование местоположения

Закладки

Данная форма служит для создания нового и управления параметрами уже существующего местоположения.

Контекстная панель

Кнопка | Описание
Список местоположений | Переход на страницу со списком местоположений.
Добавить | Переход к форме создания нового местоположения. Кнопка отображается при редактировании существующего местоположения.
Удалить | Удаление редактируемого местоположения.

Местоположение

Поле | Описание
ID | Уникальный идентификатор местоположения.
Сортировка | Относительный "вес" местоположения. Влияет на размещение местоположения в общем списке. Если для нескольких местоположений задано одинаковое значение данного поля, то сортировка производится по алфавиту.
Выводить по умолчанию | При отмеченной опции при оформлении заказа данное местоположение будет видимо без дополнительных операций.
Выберите страну
*Выберите страну | Выберите в этом поле страну для данного местоположения. Если необходимой страны в списке нет, то выберите пункт <Новая страна> и заполните форму Новая страна. Если страна выбрана из списка, то заполнять форму Новая страна не нужно.
Изменить текущую страну | Если в поле Страна выбрана одна из определённых стран, то, отметив данную опцию, можно изменить ее параметры: полные и краткие наименования.
Новая страна (в данной секции осуществляется добавление новой страны для создаваемого местоположения)
*Полное наименование | Укажите полное наименование страны для каждого языка, используемого в системе (например, Российская Федерация).
*Краткое наименование | Укажите краткое наименование страны для каждого языка, используемого в системе (например, России).
Регион/Штат/Провинция
*Выберите регион | Выберите в этом поле регион для данного местоположения. Если необходимого региона в списке нет, то выберите пункт <Новый регион> и заполните форму Новый регион, идентичную форме Новая страна. Если регион выбран из списка, то заполнять форму Новый регион не нужно.
Город
Без города | Отметьте данное поле, если вы хотите ввести только страну без города. Если вы вводите новую страну и не отмечаете это поле (т.е. вводите сразу страну и город), то создаются две записи местоположений: страна без города и страна с указанным городом. При заполнении списка местоположений убедитесь, что для каждой страны есть местоположение с этой страной без указания города - в этом случае клиенты при заказе смогут выбрать это местоположение и ввести город вручную, если пары страна - город не существует.
Полное наименование | Укажите полное наименование города для каждого языка, используемого в системе.
Краткое наименование | Укажите краткое наименование города для каждого языка, используемого в системе.

Индексы

Кнопка | Описание
Список индексов | С помощью кнопки Добавить можно добавить почтовые индексы для данного местоположения.

Смотрите также

  • Как создать новое местоположение для доставки заказа


Импорт местоположений

Страница Импорт местоположений (Магазин > Настройки > Местоположения > Импорт местоположений) предназначена для импорта местоположений. Для быстрой загрузки местоположений на сайт нужно воспользоваться мастером импорта местоположений.

Мастер импорта местоположений

Для удобства импорта местоположений в систему создан мастер загрузки местоположений. Для запуска мастера служит кнопка Запустить мастер импорта местоположений на закладке Импорт. На каждом шаге мастер предлагает к заполнению различные параметры: какие города загружать, удалять ли прежние данные и т.д. При работе с мастером импорта файлы местоположений загружать не требуется.

Также есть возможность загрузить местоположения из файла данных специального формата. Для этого необходимо воспользоваться флагом на втором шаге мастера загрузить из файла. При этом старые местоположения могут быть удалены автоматически с помощью флага Удалить прежние данные. Для загрузки местоположений из файла укажите путь к файлу с помощью кнопки Обзор.

Пример файла для загрузки местоположений

en
S,en,Russian Federation,ru,Россия
R,en,Sakha YAkutiya Resp,ru,Саха Якутия Респ
T,en,Moscow,ru,Москва
T,en,Kaliningrad,ru,Калининград
S,en,Ukraine,ru,Украина
T,en,Kiev,ru,Киев
S,en,Estonia,ru,Эстония

В первой строке указывается язык (в примере en - английский), названия на котором будут отображаться в административной части и использоваться для поиска при загрузке.

В остальных строках файла указываются загружаемые данные. Сначала указывается страна (строка начинается с S), потом регионы (строка начинается с R) все города этой страны (строки начинаются с T), потом следующая страна и т.д.

Каждая строка имеет следующий формат (в самом файле строка не должна разрываться):

<Указатель страна/регион/город (S/R/T)>,
<сайт (язык названия)>,<название для указанного перед этим сайта>,
<сайт (язык названия)>,<название для указанного перед этим сайта>...

Названия должны быть указаны для всех языков. Если какие-либо из языков не существуют, то они будут проигнорированы.

Если загружаемая страна уже присутствует в системе, то она не будет загружена повторно, а будет использована существующая запись. Города загружаются всегда, вне зависимости от присутствия подобных названий в системе.

Смотрите также

  • Как загрузить местоположения для функционирования служб доставки