Видеоматериалы к курсу "Администратор. Бизнес"
1 / 254

На данной странице представлены доступные для просмотра учебные видеоматериалы, которые помогут Вам быстро освоить курс Администратор. Бизнес. Видеоролики демонстрируют основные функциональные возможности продукта.

Название видеоролика | Размер файла, Мб | Длительность, мин:сек
Управление валютами | 7.83 | 2:10
Умный фильтр | 26.78 | 3:50
Количественный учет | 3.77 | 1:00
Резервирование | 8.39 | 2:00
Персональные рекомендации | 9.92 | 3:24
Единицы измерения | 8.03 | 1:53
Настройка цен | 7.29 | 1:41
Настройки подключения к 1С | 9.19 | 3:01
Интеграция с Яндекс.Маркет | 11.18 | 2:00
Продажи на Яндекс.Маркет | 9.37 | 2:46
SEO настройка каталога | 11.58 | 3:01

© «Битрикс», 2001-2008, «1C-Битрикс», 2008-2015 1С-Битрикс


Примеры решения типовых задач
2 / 254

Ссылки на страницы с описанием выполнения типовых задач, размещённых в разных местах учебного курса.

  • Создание скидки
  • Установка ставки НДС
  • Освобождение от налогов
  • Примеры правил работы с корзиной
  • Экспорт и импорт торговых каталогов
  • Настройка инфоблока на участие в торговых операциях
  • Типы товаров: простой товар, товар с торговыми предложениями, набор, комплект.
  • Осуществление подписки на контент
  • Печать документов
  • Генерация торговых предложений
  • Настройка зависимости свойств элементов от раздела каталога
  • Использование умного фильтра
  • Настройка программы "Покупка на Маркете"
  • Примеры настроек платежных систем
  • Складской учет товаров
  • Настройка статусов заказов
  • Пример организации продажи контента на сайте
  • Выгрузка товаров из 1С на сайт
  • Обмен заказами с 1С
  • Обмен в режиме реального времени
  • Выгрузка справочников из 1С
  • Комментарии к товарам на основе блогов
  • Техподдержка на сайте


Валюты
3 / 254

Вся работа по управлению валютами ведется в модуле Валюты.

Данный модуль позволяет:

  • управлять списком валют;
  • задавать формат представления цен в той или иной валюте;
  • устанавливать курсы валют (с возможностью загрузки с сайта Центрального Банка РФ).

Модуль Валюты необходим для работы модулей Торговый каталог, Интернет-магазин, а также может использоваться для отчетов в CRM.

Обычно в торговых каталогах присутствуют товары зарубежного производства. Как правило, цена на такие товары рассчитывается, исходя из закупочной цены, зачастую устанавливаемой в иностранной валюте. Однако по российскому законодательству расчеты по торговым операциям должны осуществлялись только во внутренней валюте государства (рублях). Для удобства обращения с такими товарами и ценами на них и предусмотрен модуль Валюты. И настроить работу этого модуля необходимо до того как вы займетесь собственно созданием каталога и интернет-магазина. Кроме этого, модуль необходим при работе с финансовыми параметрами в рекламных кампаниях и событиях в Веб-аналитике.

Цены на товар могут быть представлены в любой из доступных в системе валют (например, в долларах, евро, рублях). При составлении платежных документов с помощью механизмов модуля Валюты все цены будут конвертированы в базовую валюту (например, в рубли) по установленному курсу.

Настройка модуля

Настройка модуля Валюты производится на странице Настройки > Настройки продукта > Настройки модулей > Валюты.

В форме настроек есть лишь одна закладка Доступ. Настройка доступа проводится типовым для Bitrix Framework способом.

Примечание. Права доступа желательно ограничить и не давать большому числу пользователей. Лучше вообще оставить за одним администратором, так как обращение к модулю не требуется постоянно, а случайно изменить что-то можно. Так как изменения скажутся на работе каталога и интернет-магазина, то последствия могут быть серьезными.

Дополнительная информация

  • Пользовательская документация по модулю "Валюты"


Валюты
4 / 254

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Управление валютами

Управление списком валют осуществляется на странице Валюты (Настройки > Валюты > Список валют):

Одна (только одна!) из валют выбирается в качестве базовой (для этого следует выбрать пункт Сделать базовой в меню действий валюты). Курс остальных валют рассчитывается по отношению к базовой.

Базовая валюта – валюта, которая будет использоваться в качестве базы для расчетов других валют. Например, если в качестве базовой будет выбран рубль, то весь курс будет отображен относительно рубля. Базовой будет считаться та валюта, номинал которой равен ее курсу. В качестве базовой рекомендуется выбирать рубль. В этом случае отображение курса валют будет в привычном для всех виде: за 1 денежную единицу – столько-то рублей.

Добавление валюты

Если для работы вам требуются валюты, не представленные в системе, то их необходимо добавить.

Нажмите на кнопку Добавить валюту на контекстной панели. Откроется форма добавления валюты:

Заполните поля на закладке Валюта:

  • Валюта – международно признанное трехбуквенное обозначение валюты;
  • Номинал – сумма, которая принимается за единицу при расчете валюты. Как правило, равняется 1;
  • Курс по умолчанию – курс, который будет использоваться при конвертации валют, если в форме Курсы валют не заданы другие значения;
  • Цифровой код – международный трехзначный цифровой код валюты;
  • Индекс сортировки – приоритет данной валюты в общем списке валют.

На закладке Языковые настройки задаются настройки для разных языков интерфейсов системы: русского, английского и т.д. Поля у этих групп настроек одинаковые:

Примечание: дополнительные языковые представления валюты появляются в форме после добавления в систему дополнительного языка интерфейса.

Заполните поля для языковых вариантов:

  • Название – полное название валюты для данного языка;
  • Шаблон формата – способ вывода текста. При выборе того или иного шаблона вывода в остальные поля языкового оформления будут подставлены значения по умолчанию. При необходимости вы можете изменить значения этих полей;
  • Строка формата для вывода валюты – заполняется в виде «# текст». Вместо «#» выводится значение из поля Шаблон. Такое представление дает возможности индивидуализировать вывод сообщения о курсе;
  • Десятичная точка при выводе и Разделитель тысяч при выводе – способы разделения частей отображения валюты;
  • Количество десятичных знаков – количество знаков после запятой, которые нужно выводить при показе курса;
  • В публичной части не показывать незначащие нули в дробной части цены – в случае, если галочка выставлена, прежняя цена в 1637.00 будет показана как 1637.


Курсы валют
5 / 254

Для управления курсами валют служит страница Курсы валют (Настройки > Валюты > Курсы валют):

Здесь можно устанавливать курсы для валют, установленных в разделе Список валют.

При конвертации валют на текущую дату система берет самый новый из курсов. Если курс не найден, то берется курс по умолчанию (курс, заданный в настройках валюты).

Создание курса валют

Для создания курса валюты на текущую дату нажмите на кнопку Создать курс валют на контекстной панели. Откроется форма создания курса валют:

  • В поле Дата выберите дату, на которую нужно сохранить курс;
  • В поле Валюта в выпадающем окне выберите валюту, курс которой необходимо сохранить;
  • Нажмите кнопку Запросить. Система запросит курс валют на выбранную дату с нужного сайта (см. примечание ниже) и выведет значения в полях Номинал и Курс;

    Примечание: для получения курса валюты необходимо, чтобы краткий символьный идентификатор валюты был корректным (пример: если указать краткий символьный идентификатор валюты, допустим, UJD вместо USD, то получить курс автоматически не получится).

    Важно! Запрос курса валют может быть выполнен, если в системе в качестве базовой используется одна из следующих валют:
    • российский рубль - запрос выполняется с сайта Центрального банка РФ;
    • гривна - запрос с сайта Национального банка Украины;
    • белорусский рубль - запрос с сайта Национального банка Республики Беларусь.

  • Сохраните внесенные изменения. Откроется форма отчета со списком сохраненных курсов, в которой добавится новый сохраненный курс.


Информер курса валют
6 / 254

Работа модуля Валюты внешне не видна: к нему обращаются модули Торговый каталог и Интернет-магазин в своей работе. Но есть один внешне отображаемый компонент, который позволяет «увидеть» присутствие модуля на сайте. Это – информер курса валют.

Рассмотрим размещение информера курса валют на сайте.

Откройте нужную страницу в режиме визуального редактора и поместите на рабочую область компонент Таблица курсов валют (Контент > Валюты).

Вызовите панель Настройки параметров компонента:

  • В поле Массив "исходных" валют для перевода выберите валюты, данные которых должны отражаться на информере;
  • В поле Валюта, к которой приводятся "исходные" валюты укажите базовую валюту;
  • В поле День, на который показывать курсы валют укажите дату курса, с которого будут браться параметры;
  • Показывать курс валют с ЦБ РФ - отметьте данную опцию, если хотите указать курс ЦБ России.

Сохраните внесенные изменения и таблица отобразится на странице:

Дополнительная информация

  • Описание компонента (документация)


Пример работы с валютами
7 / 254

Допустим, имеется каталог продукции с товарными позициями. Цены, у которых представлены не только рублями, а так же долларами и фунтами стерлингов. Задача:

  • корректно отображать цены данных товарных позиций в листинге товаров;
  • для пользователей вывести информацию по курсам валют на сайте;
  • а при заказе данных товарных позиций конвертировать цену в рубли по курсу ЦБ РФ.

Для начала нужно создать нужные нам валюты, а также настроить шаблоны их отображения на сайте. В дистрибутиве "1С-Битрикс: Управление сайтом" по умолчанию уже настроена одна валюта: рубли. Она же и является базовой валютой.

Создайте валюты USD и GBP (фунты стерлингов).

Для примера приведем образец заполнения формы:

Должен получиться такой список:

Далее нам нужно настроить курсы данных валют. Переходим в раздел Курсы валют (Настройки > Валюты > Курсы валют). И создаём курсы для двух валют (USD и GBP) по отношению к базовой валюте RUB.

Теперь перейдя на карточку товара в каталоге товаров, можно указать цену в валютах которые мы создали, выбрав необходимое значение из выпадающего списка:

Создадим 3 товара в каталоге товаров с ценами в разных валютах. В итоге на странице каталога в публичной части, при переходе в раздел с созданными нами товарами, мы сможем наблюдать 3 товара с ценами в разных валютах:

Дополнительно, вне темы примера: Перед выводом товаров разместим компонент Таблица курсов валют (bitrix:currency.rates), таким образом, пользователь сможет видеть курсы, по которым будет произведена конвертация валют в рубли. В настройках компонента выберите из списка валюты, которые необходимо выводить, а также валюту по отношению к которой будет пересчитываться курс (в данном случае это RUB). Получили:

Теперь закажем эти книги и перейдём в корзину:

Цены книг автоматически перевелись в рубли по курсу, который мы установили. Это не сложно проверить: книга «Компьютерный андеграунд…» стоит 214,5 фунтов а курс мы установили 47,0519руб за фунт, в итоге получается 214,5*47,0519 = 10092,63255 руб., а так как в настройках валюты «RUB» установлен вывод только двух знаков после запятой то сумма округлилась до 10092,63 руб.


Торговый каталог
8 / 254

Модуль Торговый каталог используется в качестве надстройки к модулю Информационные блоки, позволяющей создавать каталоги товаров, управлять количеством товаров на складах.

Данная глава содержит подробное описание модуля, а также примеры настройки и использования функционала модуля.

Дополнительно можно посмотреть урок Наполнение каталога товарами в курсе Контент-менеджер.

Дополнительная информация

  • Пользовательская документация по модулю "Торговый каталог"
  • Фильтрация элементов инфоблока, не используя компонент фильтра


Функционал модуля
9 / 254

Модуль Торговый каталог является надстройкой к модулю Информационные блоки и позволяет:

  • создавать торговые каталоги товаров, услуг и всевозможного цифрового контента на базе информационных блоков;
  • управлять ценами, наценками, скидками и торговыми предложениями (SKU) на товары;
  • управлять и отслеживать поступление и списание товара со складов с помощью документов;
  • осуществлять продажу товаров, услуг и цифрового контента через интернет-магазин;
  • осуществлять продажу прав доступа к ресурсам сайта;
  • загружать и выгружать данные о товарах, заказах, продажах в форматах CommerceML, Froogle, Yandex и CSV (формат последнего можно настраивать при загрузке);
  • сохранять созданные профили экспорта и импорта элементов для повторного использования.
Важно! Торговый каталог создается путем соответствующей настройки Каталога товаров. Каталоги товаров формируются на основе информационных блоков, поэтому для использования модуля Торговый каталог необходимо наличие установленного в системе модуля Информационные блоки.

Элементы информационного блока, выбранного для использования в качестве Торгового каталога, становятся товарами. В форме редактирования элементов-товаров добавляется дополнительная секция Торговый каталог, позволяющая настроить:

Секция Торговый каталог

  • цену на товар;
  • ставку НДС;
  • складские характеристики товара;
  • посмотреть и изменить активные скидки без купонов, распространяющиеся на данный товар;
  • указать штрихкод товара.

Торговые предложения - SKU (stock keeping unit) - единица складской наличности. Фактически - это ассортиментная позиция (единица одной товарной группы, марки, сорта в одном типе упаковки одной размерности, емкости, цвета и т.д.). Это отличие, которое выделяет товар.

Включение функционала осуществляется путем указания инфоблока, который будет использоваться для хранения торговых предложений. Это можно сделать на закладке Каталоги страницы настроек модуля (Настройки > Настройки продукта > Настройки модулей > Торговый каталог):

То же самое можно сделать, выбрав на странице Контент > Информ. блоки > Типы информ. блоков нужный тип и инфоблок. На закладке Торговые предложения вкладки Торговый каталог укажите инфоблок торговых предложений:


Настройка инфоблока на работу в режиме торгового каталога
10 / 254

Чтобы нужный информационный блок работал в режиме торговых каталогов, необходимо отметить его флажком в поле Является торговым каталогом на странице настроек модуля Торговый каталог (Настройки > Настройки продукта > Настройки модулей > Торговый каталог):

Настройка на работу в режиме торгового каталога

Также есть второй способ настройки инфоблока на работу в качестве торгового каталога. В административном режиме зайдите в настройки нужного инфоблока и на закладке Торговый каталог выставьте галочку в поле Является торговым каталогом:

Сохраните внесенные изменения.

Внимание! В версии PHP 5.3.9 был добавлен параметр max_input_vars, значения по умолчанию которого не хватает для форм инфоблоков. Рекомендуемое значение этого параметра - не меньше 5000. Для установки этого значения необходимо обратиться к администратору хостинга.


Фасетный поиск в каталоге товаров
11 / 254

Начиная с версии 15.0.1 модуля Информационные блоки, добавлен фасетный (т.е. предопределенный) поиск по товарам торгового каталога. Система заранее формирует фасеты (всевозможные комбинации пересечения свойств товаров) и при выполнении поискового запроса сразу выдается результат - эти готовые фасеты. Механизм фасетного поиска встроен в информационные блоки и интегрирован с компонентом Умный фильтр. Кроме того, создание фасетных индексов значительно ускоряет не только поиск товаров, но и работу всего каталога в целом.

Фасетный индекс - это готовый поисковый набор товаров по некоторому значению свойства.

Чтобы иметь возможность использовать фасетный поиск по товарам магазина, в первую очередь в каталоге должно быть создано хотя бы одно отображаемое в умном фильтре свойство:

После чего необходимо создать фасетные индексы. Для этого служит специальная страница Фасетные индексы инфоблоков (Контент > Инфоблоки > Фасетные индексы):

С помощью пункта Создать в меню действий конкретного каталога или по кнопке Создать все, расположенной на контекстной панели, открывается форма запуска процесса создания индексов:

  • В поле Информационный блок указывается необходимый каталог товаров, для которого будут созданы индексы, либо указывается значение (все), чтобы создать индексы для всех каталогов системы.
  • В поле Шаг задается интервал одного шага создания индекса в секундах.

Запуск процесса создания индексов осуществляется по кнопке Начать.

Примечание: операция по созданию индексов может занять продолжительное время, если в каталоге сотни тысяч товаров. В этом случае индексацию рекомендуется выполнять в период минимальной нагрузки на сервер.

По окончании индексации будет выведено соответствующее сообщение:

Созданные фасетные индексы хранятся в базе данных, а в таблице для каталогов товаров в колонке Состояние отображается Работает:

При добавлении новых (редактировании существующих) товаров и разделов пересоздание индекса будет выполняться автоматически.

Примечания:
  • для каталога предложений фасетные индексы создаются при создании индексов для основного каталога.
  • при добавлении нового или удалении свойства из умного фильтра необходимо произвести повторное создание фасетного индекса.
  • при выгрузке товаров, например, из 1С индексы обновятся автоматически, если товары не создают новых свойств. Если выгружаются товары с новыми свойствами, то по окончании выгрузки индексы необходимо пересоздать.


Настройка отображения свойств в умном фильтре
12 / 254

Умный фильтр – это инструмент для отбора элементов каталога по заданным критериям, обладающий следующими особенностями:
  • анализируя все элементы раздела, он выстраивает на основании значений их свойств и цен унифицированное представление;
  • поддерживает торговые предложения;
  • умеет показать то количество элементов, которые будут выбраны при применении фильтра;
  • умеет показать пользователю, что некоторые комбинации значений не встречаются в каталоге.

В умном фильтре могут быть отображены свойства товаров и торговых предложений. Кроме того, начиная с версии 15.0.1 модуля Информационные блоки, для свойств доступна настройка их визуального представления и компонент Умный фильтр переведен на использование фасетного поиска.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Умный фильтр

Настройка внешнего вида для отображаемых в умном фильтре свойств (т.е. для свойств отмечена опция Показывать в умном фильтре) выполняется:

  • непосредственно в форме создания/редактирования конкретного свойства:

  • либо для нескольких свойств одновременно на закладке Свойства элементов формы настроек каталога или формы редактирования конкретного раздела каталога:

Независимо от выбранного варианта настройка визуального представления свойств осуществляется с помощью следующих двух параметров:

  • Вид в умном фильтре - в зависимости от типа свойства из списка выбирается один из подходящих видов отображения значений свойства в умном фильтре. Так, например, для типа свойства Справочник можно выполнить настройку следующим образом:

  • Показать развёрнутым - при отмеченной опции варианты значений свойства будут сразу показаны в фильтре в развернутом виде. Если опция не отмечена, то свойство будет показано в свернутом виде, развернуть которое можно будет при просмотре.

    Примечание: цены в умном фильтре всегда показаны в развернутом виде, но в случае необходимости пользователи могут их свернуть:

    Кроме того, дробная часть цены не будет показана в фильтре, если в настройках валюты запрещен показ десятичных знаков.

Таким образом, для каждого свойства в фильтре вы можете задать необходимый ему внешний вид.

Примечание: порядок свойств в умном фильтре определяется значениями сортировки:

Фасетный поиск в умном фильтре

В умный фильтр встроен фасетный поиск, поэтому, чтобы улучшить работу фильтра, следует создать для каталога фасетные индексы. В этом случае скорость работы фильтра не будет зависеть от размеров каталога, т.к. теперь фильтр не имеет линейной зависимости от количества товаров и свойств. В целом скорость фильтра улучшилась в 15 раз.

Примечание: рекомендуется сперва настроить все свойства в фильтре, а затем создавать индексы. Поскольку при добавлении/удалении свойства из умного фильтра необходимо заново пересоздавать фасетные индексы.


ЧПУ в умном фильтре
13 / 254

Поддержка ЧПУ в умный фильтр добавлена, начиная с версии 15.5.0 модуля Информационные блоки. До этой версии адресная строка при установленном фильтре имела следующий вид:

http://mysite.ru/e-store/books/business/?FILTER_P1_MIN=&FILTER_P1_MAX=&FILTER_19_1218211285=Y&FILTER_23_964515751=Y&set_filter=Показать

Теперь же можно выполнить настройки ЧПУ и адресная строка будет иметь удобный и читабельный вид:

http://mysite.ru/e-store/books/business/filter/year-is-2002/publisher-is-эксмо/apply/

Причем, если для каталога товаров используется комплексный компонент Каталог, то отдельных настроек для фильтра выполнять не нужно. Следует всего лишь настроить компонент на работу в режиме ЧПУ.

Если для публикации товаров используются простые компоненты, то настройки поддержки ЧПУ выполняются в необходимых простых компонентах, в том числе и в компоненте Умный фильтр:

Примечание: подробное описание параметров компонента приведено в документации по продукту.


Настройки товара и публикация каталога
14 / 254

Перейдем к настройке параметров товаров торгового каталога. В разделе Контент найдите инфоблок, работающий в режиме торгового каталога и зайдите в настройки его произвольного товара.

В секции Торговый каталог настроим следующие параметры товара:

  • Цены товара:

    • Базовая цена (BASE) товара, на основе которой будут вычислены остальные типы цен;
    • Закупочная цена - при включенном в настройках модуля торгового каталога складском учете данное поле заполняется автоматически при проведении документа как цена, по которой вы купили данный товар.

      Примечание: просмотр данного типа цены в карточке товара доступен для пользователей с правом доступа к модулю торгового каталога как Полный доступ, либо Управление складом.

    • Из списка определенных в системе валют Валюта базовой цены для представления цены товара;
    • Далее в форме отображены остальные типы цен, определенные в системе. В нашем примере это оптовая цена. Для нее можно выбрать определенный тип наценки, и тогда цена этого типа будет высчитана автоматически ([Цена]=[Базовая цена]+[Базовая цена]*[Наценка в процентах/100]):

    Примечание: чтобы задать стоимость товара для некоторого типа цены вручную (не используя имеющиеся наценки), в поле тип наценки нужно выбрать значение Не установлен. Тогда поля Сумма и Валюта будут открыты для ввода.

  • Для задания стоимости товара для разных типов цен в зависимости от дополнительных параметров (например, в зависимости от количества товаров) служит расширенный режим управления ценами. Для его активации необходимо установить флаг в поле Использовать расширенный режим управления ценами.

    Поля От и До служат для задания связи между количеством приобретаемых товаров и их стоимостью. Например, можно указать, что при приобретении от 1 до 3 единиц товара, товар будет продаваться по цене 8200 руб/шт, а при приобретении от 4 единиц товара (диапазон будет воспринят как от 4 включительно до бесконечности), стоимость товара будет равна 7500 руб/шт:

    Количество товара может быть задано как одним числом (можно заполнить только поле От или только поле До), так и в виде диапазона (указать оба поля);
  • О закладках Параметры и Склады можно узнать из урока Количественный учет. При включенном складском учете поля Доступное количество (закладка Параметры) и Количество товара (закладка Склады) будут недоступны для редактирования.
  • На закладке Скидки будет представлен список доступных скидок:

    Примечание: в карточке товара отображаются все скидки, затрагивающие данный товар: скидки, назначенные на сам товар, на конкретную секцию, к которой он принадлежит, на вышележащие секции и т.д.

    Список созданных купонов можно просмотреть на странице Купоны скидок.

  • На закладке Штрихкод можно указать штрихкод товара для его идентификации и быстрого поиска при организации складского учета:

    Штрихкоды функционируют только при складском учете, его можно ввести как вручную, так и с помощью USB-сканера: установите курсор мыши в поле Штрихкод, наведите сканер на штрихкод товара, и код окажется в поле.

    Если в случае данного товара каждый его экземпляр должен иметь индивидуальный штрихкод, то отметьте параметр Каждый экземпляр товара имеет собственный штрихкод, после чего поле для ввода исчезнет, а добавление штрихкода для такого товара осуществляется в форме создания документа Приход товара на склад:

    После нажатия кнопки Ввести штрих-коды появится форма ввода штрих-кодов, число полей в которой будет совпадать с количеством товара, которое вы указали в документе:

Публикация

Если публикация каталога осуществляется с помощью комплексного компонента Каталог (bitrix:catalog), то показ цен товаров определяется его настройками:

Дополнительная информация

  • Настройка параметров товара (документация)
  • Описание компонентов модуля (документация)


Типы товаров
15 / 254

Начиная с версии 14.0.0 в товарах торговых каталогов выделяются следующие типы: простой товар, товар с торговыми предложениями, набор, комплект.

Примечание: наборы и комплекты доступны в продукте, начиная с редакции Бизнес.

В списке элементов инфоблока, являющегося торговым каталогом, доступно две кнопки для добавления товаров вручную:

  • Добавить товар - служит для создания простого товара без торговых предложений и каких-либо возможностей.
  • Создать другие типы товаров - служит для добавления товаров других типов.

Рассмотрим подробно какие товары создаются с помощью кнопки Создать другие типы товаров:

  • Создать товар с торговыми предложениями - служит для добавления товара с торговыми предложениями. По сути самостоятельно этот товар не является товаром. Он содержит список торговых предложений, которые как раз и являются товарами (предложениями). По умолчанию в форме добавления такого товара недоступна закладка Торговый каталог, т.е для самого товара не задается никаких атрибутов: цены, остатков и т.д.

    Создание предложений выполняется на закладке Торговые предложения с помощью кнопок Добавить, Добавить предложение с набором или Генерировать торговые предложения. В форме торгового предложения задается цена и все необходимые параметры.

    Примечание: показ закладки Торговый каталог определяется соответствующей опцией настроек модуля.

  • Создать комплект - выбор данного действия служит для добавления товара, который должен продаваться комплектом из некоторых товаров.

    Комплект - это список товаров, составляющих необходимую комплектацию основного товара. Сам комплект не имеет физического остатка, его остаток зависит от товаров, которые входят в этот комплект. В комплект могут быть добавлены именно товары: торговые предложения и/или простые товары. Товар с торговыми предложениями добавить в него нельзя.

    Комплектующие товары к основному товару задаются на закладке Состав комплекта формы создания товара. Добавление товаров осуществляется с помощью диалога выбора товаров, который открывается по кнопке [...]. Специальных ограничений на количество входящих в комплект товаров нет. Например, некий системный блок продается только в комплекте с мышью, монитором и клавиатурой:

    Примечание: подробное описание полей закладки Состав комплекта представлено в документации по продукту.

  • Создать набор - служит для создания товара со списком рекомендованных к покупке с ним товаров.

    Набор - это список привязанных к основному товару товаров, которые магазин хочет порекомендовать к покупке. В набор могут быть добавлены именно товары: торговые предложения и/или простые товары. Товар с торговыми предложениями добавить в него нельзя.

    Создание набора выполняется на закладке Состав набора формы создания товара. Добавление товаров осуществляется с помощью диалога выбора товаров, который открывается по кнопке [...]. По умолчанию в публичной части отображается до трех рекомендованных товаров, но сам список может содержать любое разумное количество товаров, из которого можно выбрать замену для предложенного товара. Например, при покупке смартфона дополнительно рекомендуют купить чехол, карту памяти, защитную пленку на экран:

    Примечание: подробное описание полей закладки Состав набора представлено в документации по продукту.

Кроме того, обратите внимание, что при редактировании товара вы можете изменить тип товара на другой, который позволяет текущий тип, а также добавить набор:

Важно! Набор может быть добавлен к существующему товару любого типа.

При просмотре списка товаров также отображается информация по типам товарам в столбце Тип товара:


Торговые предложения
16 / 254

Торговые предложения - SKU (stock keeping unit) - единица складской наличности. Фактически - это ассортиментная позиция (единица одной товарной группы, марки, сорта в одном типе упаковки одной размерности, емкости, цвета и т.д.). Это отличие, которое выделяет товар.

Очень часто случается ситуация, когда цена товара зависит от его свойств. В этом случае удобно использовать встроенный в модуль Торговый каталог функционал торговых предложений.

Не используя функционал торговых предложений, нам нужно создавать карточки товара для каждой возможной вариации свойств товара. Но зачастую целесообразнее завести 1 карточку товара и добавить свои торговые предложения - модели, отличающиеся набором свойств. Большой плюс этого способа в том, что при переходе в карточку товара покупатель будет видеть зависимость цены товара от его свойств.


Добавление торговых предложений
17 / 254

Допустим, что нужно создать каталог Кровати, товары которого (кровати, каркасы кроватей) будут различаться по цветам и ширине. Для этого выполните следующие действия:

  • Для начала создайте инфоблок в режиме торгового каталога. Назовем этот инфоблок Кровати, он будет находится, например, в типе инфоблоков Каталоги.

    Внимание! Любой инфоблок может участвовать только в одной связке Товар - Торговое предложение.
  • Далее откройте закладку Торговый каталог в форме редактирования инфоблока Кровати и настройте этот инфоблок на работу с торговыми предложениями:

    1. выберите опцию Инфоблок имеет торговые предложения;
    2. отметьте в списке Инфоблок торговых предложений необходимый инфоблок или создайте новый. При создании нового инфоблока нужно указать название и выбрать тип инфоблока (или создать новый тип инфоблока);
    3. создайте необходимые свойства торговых предложений: в нашем случае - это Ширина и Цвет.

      Важно! Отбор торговых предложений может выполняться только по свойствам типа Список и Справочник.
  • Создайте карточку товара Каркас кровати в инфоблоке Кровати, заполните необходимую информацию о товаре: название, анонсовую и детальную информацию.
  • Перейдите на закладку Торговые предложения и нажмите кнопку Добавить элемент:

  • Укажите необходимые значения свойств, цену, количество и прочие параметры предложения:

    Примечание: форму создания элементов SKU можно настроить точно также как и обычную форму создания инфоблока. Кнопка доступна при добавлении/редактировании элементов SKU только через административный интерфейс.

  • Сохраните торговое предложение. Оно добавится в список предложений товара.
  • Аналогично добавляются другие торговые предложения к данному товару:

    Примечание: вы также можете настроить вид таблицы с перечнем предложений необходимым для вас образом. Например:

  • Сохраните товар.

В результате на детальной странице товара его свойства отображаются с учетом имеющихся предложений. Покупатель указывает необходимые ему параметры товара и совершает покупку по соответствующей цене:

Добавление торговых предложений товара в публичной части

Примечание: для добавления торговых предложений товара в публичной части, необходимо чтобы инфоблок каталога уже был настроен на работу с торговыми предложениями.

После настройки инфоблока каталога на работу с торговыми предложениями, необходимо в публичной части сайта:

  • С помощью кнопки Добавить товар или Изменить товар открыть карточку товара:

  • Заполнить необходимые данные товара и на закладке Торговые предложения, как было описано выше в административном интерфейсе, с помощью кнопки Добавить элемент создать торговые предложения для товара.


Генерация предложений
18 / 254

Добавление торговых предложений для товара очень трудоемкая и затратная по времени задача. Поэтому в систему, начиная с версии 14.0.0, был добавлен генератор торговых предложений. Рассмотрим на примере механизм его работы.

Допустим, что у нас имеется каталог Кровати, для которого настроен инфоблок торговых предложений Кровати (предложения) со следующими свойствами:

Добавим в каталог Кровати новый товар с торговыми предложениями. Для этого на странице со списком элементов раздела нажимаем кнопку Создать другие типы товаров и выбираем пункт Создать товар с торговыми предложениями. В открывшейся форме обязательно указываем название и сразу переходим на закладку Торговые предложения:

Нажимаем кнопку Генерировать торговые предложения. Открывается окно с генератором, в котором нужно заполнить основные данные для генерации.

  • В поле Название задается название торгового предложения вручную или с помощью шаблонов. Список доступных шаблонов разделен на два: свойства SKU и свойства родителя. Например, в нашем случае название задано с помощью названия основного товара (свойство родителя) и цвета (свойство предложений):

  • Поля Вес товара, Длина, Ширина, Высота - отвечают за вес и габаритные характеристики создаваемых товаров. Если они одинаковы для всех торговых предложений, то их можно заполнить во время генерации.
  • С помощью поля Ставка НДС определяется облагается ли товар НДС и, если облагается, то указывается конкретная ставка.
  • Опция НДС включён в цену позволяет для всех сгенерированных предложений включить НДС в их стоимость.
  • Поле Цена позволяет выбрать Тип цены, задать величину цены и валюту для каждого типа. Кнопка +Еще служит для добавления строк, чтобы можно было задать цены для всех необходимых вам типов.

Переходим к блоку выбора свойств, в соответствии с которыми будут генерироваться торговые предложения.

Важно! Для выбора доступны свойства инфоблока торговых предложений только типов Список и Справочник.

В нашем случае будут доступны свойства Цвет и Размер (см. список свойств инфоблока Кровати (предложения)):

Кнопка Добавить свойство служит для добавления некоторого свойства, которое доступно, но не отображается в форме. А для выбора всех доступных свойств служит кнопка Загрузить все. Если вы по ошибке добавили свойство, то вы сможете его убрать, нажав по крестику в заголовке свойства.

С помощью установки соответствующих флагов определяются те значения свойств, которые должны быть у генерируемых торговых предложений. Например, мы выберем только следующие цвета кроватей: Бук, Черный, Береза и Дуб, а размеры - 2-сп. и 1,5-сп.

Примечание: установка/снятие флага в верхней строке блока свойства позволяет установить/снять флаги для всех значений свойств сразу.

Свойства выбраны, переходим к блоку загрузки изображений. С помощью этого блока можно загрузить анонсовые, детальные изображения и необходимые файлы для всех свойств типа Файл:

Кнопка [ + ] добавляет новые поля, в которые должны быть загружены изображения. Переход к загрузке изображений для генерируемых торговых предложений осуществляется с помощью кнопки Прикрепить изображения.

Обратите внимание, что нажатие кнопки Прикрепить изображения блокирует выбор значений свойств и добавление полей, в которые должны быть загружены изображения.

Мы будем загружать детальные (поле Подробно) и дополнительные изображения (поле Картинки). Необходимые поля выбраны, нажимаем кнопку Прикрепить изображения.

Выбираем значения свойств и загружаем необходимые изображения. Например, в нашем случае изображения будут загружаться для всех размеров, но в зависимости от цвета:

После того, как все картинки загружены, нажимаем кнопку Генерировать, расположенную внизу формы. Торговые предложения сгенерированы в соответствии с нашими требованиями:

Генерация торговых предложений может выполняться не только для новых товаров, но и при добавлении необходимых предложений к существующему товару.

Примечание: если вы сгенерируете такие же предложения, которые уже были в товаре, то старые предложения будут перезаписаны на новые.

Важно! Для возможности одновременной загрузки большого количества картинок проверьте в настройках PHP параметр max_file_uploads и выставьте необходимое вам значение.

Ссылки по теме:

  • Как сэкономить на месте и ускорить выгрузку из 1С


Настройки для отображения торговых предложений
19 / 254

На примере настроек комплексного компонента Каталог рассмотрим, какие настройки обязательно должны быть выполнены, чтобы на сайте корректно отображались товары с торговыми предложениями.

  • В параметре Типы цен секции Цены должны быть отмечены используемые в каталоге товаров типы цен:

  • В секции Внешний вид в одноименном параметре необходимо выбрать свойства, по которым ведется отбор предложений:

    Важно! Отбор торговых предложений может выполняться только по свойствам типа Список и Справочник.

  • В секции Настройки детального просмотра в параметре Свойства предложений следует отметить свойства торговых предложений, которые должны отображаться при просмотре детальной информации о товаре. Причем, среди отмеченных свойств обязательно должны быть все те свойства, которые используются для отбора предложений (см. параметр выше):

  • В секции Добавление в корзину следует отметить опцию Разрешить указание количества товара, чтобы покупателям была доступна возможность изменять покупаемое количество товара:

  • В секции Настройки списка следует указать хотя бы одно свойство торговых предложений, чтобы в списке товаров раздела правильно отображалась анонсовая информация:

  • Аналогично, в секции Настройки TOP'а следует задать свойства торговых предложений, чтобы в TOP'е также правильно отображались данные по товарам:

Примечание: подробное описание параметров компонента приведено в документации по продукту.


Размещение в одном инфоблоке нескольких категорий товаров
20 / 254

Начиная с версии 12.0.0 система 1С-Битрикс: Управление сайтом позволяет в одном инфоблоке держать разнотипные товары с различными свойствами. Свойства привязываются к категориям товаров, каждая категория наследует свойства вышестоящей.

Настроим свойства для инфоблока, в котором будет два раздела: холодильники и молочные продукты. И в публичном разделе мы должны получить фильтр по товарам, где возможен поиск по свойствам текущего раздела каталога.

Создайте инфоблок (в нашем случае название инфоблока - Каталог с разнотипными разделами) и отметьте, что он является торговым каталогом.

Перейдите на страницу Магазин > Каталог товаров > имя_вашего_каталога > Свойства товаров и создайте необходимые свойства товаров:

Свойства Высота и Масса (грамм) предназначены для холодильников и молочных продуктов соответственно, а Производитель - общее, поэтому для него должна быть отмечена опция Показывать на странице редактирования элемента:

После этого данное свойство будет отображено в форме настроек самого торгового каталога:

Поставьте флажок Показать в умном фильтре.

Добавьте в каталог раздел Холодильники:

Для раздела Холодильники добавим свойство Высота:

Отметим, что по этому свойству возможна фильтрация товаров в умном фильтре:

Аналогично добавьте раздел Молочные продукты и сделайте для него доступным свойство Масса (грамм), также отметив опцию Показать в умном фильтре.

Настроим форму добавления товара так, чтобы показывались свойства текущего раздела. Для этого нажмите [image] в разделе Список товаров нашего торгового каталога и затем перейдите в настройки формы добавления:

Удаляем из формы свойства и их заголовок (Значения свойств).

После сохранения внесенных изменений при добавлении элемента, скажем, в раздел Холодильники, форма будет иметь следующий вид:

Примечание: при хранении свойств в отдельной таблице (инфоблоки 2.0) существует ограничение на количество свойств, при хранении свойств в общей таблице ограничений нет.


Количественный учет
21 / 254

Количественный учет - режим работы с товарами в интернет-магазине на базе 1С-Битрикс: Управление сайтом, позволяющий изменять количество товара как вручную, так и автоматически после оформления заказов покупателями.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Видео для урока
Количественный учет

Количественный учет может быть включен как для всех товаров сразу (в настройках модуля Торговый каталог), так и индивидуально для каждого товара (в форме его редактирования):

Если для товаров количественный учет отключен, то они всегда будут доступны к покупке.

Примечание: в данном уроке будем рассматривать только количественный учет при отключенном складском. Про складской учет читайте в одноименной главе.

При использовании количественного учета в форме редактирования товара в поле Доступное количество администратор интернет-магазина может задавать общее количество товара, имеющегося в наличии:

Примечание: поле Зарезервированное количество доступно в форме только при включенном механизме резервирования товаров.

Если на сайте включен механизм резервирования товаров, то количество товара будет уменьшаться в момент его резервирования. Причем правило резервирования товаров определяется параметром Когда резервировать товар настроек модуля Торговый каталог.

Если же механизм резервирования отключен, то количество товара будет уменьшаться в соответствии с настройкой параметра Количество товара уменьшается:

Кроме того, при включенном количественном учете с помощью одноименных опций можно управлять покупкой товара при его отсутствии, определять разрешена ли покупка или подписка при отсутствии товара (подробное их описание смотрите в документации по продукту).

Даже при выключенном складском учете вы можете настроить вывод информации по количеству имеющихся товаров. Для этого необходимо выполнить следующее:

  • В форме редактирования товара на закладке Склады укажите количество товара на каждом из ваших складов (склады должны быть предварительно созданы):

    Важно! Количество товара на складах носит исключительно информационный характер и не влияет на расчет остатков товара после заказов. Таким образом, изменять значения количества товара на складах необходимо вручную.

  • В настройках компонента Каталог (bitrix:catalog) отметьте опцию Показывать блок "Количество товара на складе" и настройте остальные параметры необходимым образом:

    Информация о количестве товара на складах будет отображаться при детальном просмотре товара:


Резервирование товаров
22 / 254

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Резервирование

В данном уроке рассмотрим схему работы механизма резервирования товаров. Для этого, в первую очередь, в настройках модуля Торговый каталог должна быть отмечена опция Включить резервирование:

И настроены следующие параметры резервирования:

  • Снятие резервов (через сколько дней) - указывается количество дней, через которое товар будет автоматически снят с резервов, если покупатель не выполнил никаких действий по заказу;
  • Товар резервируется - выбирается правило резервирования товара.

Примечание: при включенном складском учете механизм резервирования включается автоматически и отключить его нельзя.

Резервирование товара осуществляется только в том случае, если для него ведется количественный учет. Это определяется настройками параметра Включить количественный учет, которые можно изменить в форме редактирования товара:

Если параметр принимает значение по умолчанию, то использование количественного учета определяется глобальными настройками модуля Торговый каталог.

При включенном резервировании в карточке товара доступно поле Зарезервированное количество, в котором отображается зарезервированное количество этого товара:

Примечание: при включенном складском учете поле Зарезервированное количество будет недоступно для изменения:

Списание зарезервированного товара

Списание зарезервированного товара осуществляется при отгрузке заказа (в форме редактирования заказа необходимо отметить опцию Отгрузить заказ):

Примечание: если в настройках модуля Интернет-магазин отмечена опция Разрешать отгрузку при разрешении доставки, то списание зарезервированного товара будет осуществляться автоматически, как только будет разрешена доставка.

Чтобы убедиться, что товар списан, можно посмотреть произошли ли изменения в карточке товара:

Если же включен складской учет, то для успешного списания товара вручную вам необходимо корректно указать, сколько единиц товара с какого склада нужно вывезти, и правильно ввести штрихкод (если для товара он задан):

Обратите внимание, что автоматическое списание товара с уникальным штрихкодом при разрешении доставки невозможно, поскольку менеджер обязательно должен указать уникальный штрихкод товара.


Складской учет
23 / 254

Начиная с версии 12.5.0 модуля Торговый каталог, доступен функционал складского учета товаров.

Складской учет - режим работы с товарами в интернет-магазине на базе 1С Битрикс: Управление сайтом (кроме редакции Малый бизнес), позволяющий управлять складами, вести учет поступлений и списаний товара, реализовывать оборот товара на складах с помощью документов.

Включается данный функционал в настройках модуля Торговый каталог (Настройки > Настройки продукта > Настройки модулей > Торговый каталог):

Примечание: при установке решения Интернет-магазин (bitrix.eshop) складской учет можно включить в мастере установки.

При отключенном складском учете склады в системе остаются и, если для товаров включен количественный учет, при покупке товара имеющееся количество товара будет уменьшаться (поле Доступное количество вкладки Параметры карточки товара). Однако, если вам необходим автоматический расчет остатков товара на все случаи (обмен между складами, списание, поставка) с помощью документов и с учетом поставщиков товара, то рекомендуется использовать не только количественный, но и складской учет.

Важно! Складской учет можно включать, если для вашего сайта не настроена интеграция с внешними системами учета товаров (например, не настроена интеграция с 1С).

При первом включении складского учета, в случае несовпадения доступного товара и остатков по складам, вам будет выведено соответствующее сообщение. Синхронизация количества доступного товара с остатками на складах произойдет автоматически при проведении любого документа по данному товару.

Примечание: включение складского учета при отсутствии складов (или отсутствии активных складов) приведет к автоматическому созданию склада.

Управление складами выполняется на странице Магазин > Складской учет > Склады:

Подробное описание полей формы редактирования склада смотрите в документации по продукту.


Работа с документами
24 / 254

При включенном в настройках модуля торгового каталога функционале складского учета товарооборот в магазине осуществляется с помощью документов.

На странице административного режима Магазин > Складской учет > Документы вы можете создать следующие типы документов:

Оформим поступление женских платьев на склад. Для этого выберите тип создаваемого документа - Приход товара на склад, после чего откроется форма создания документа:

Заполните нужные поля, при необходимости создайте поставщика.

Выбор поступаемых на склад товаров осуществляется:

  • по ссылке найти по штрихкоду - введите в появившееся поле штрихкод и нажмите кнопку Найти. Найденный товар добавится в список поступаемых на склад товаров.
  • или по кнопке Найти в каталоге - откроется диалог выбора товаров:

    В форме выберите нужный каталог, найдите требуемый товар и нажмите для него Выбрать. Окно закроется, товар добавится в список поступаемых на склад товаров.

    Примечание: если поступающий на склад товар является товаром с торговыми предложениями, то каждое из торговых предложений нужно выбрать отдельно. Для этого нажмите Развернуть, чтобы увидеть их.

    Чтобы добавить в список другой товар, повторите вышеописанные действия.

Для поступаемых на склад товаров задайте их количество, закупочную цену и при необходимости измените склад:

Чтобы информация о поступлении товара вступила в силу, т.е. изменилось количество товара на складе, нажмите Провести. Чтобы просто сохранить документ как заготовку, нажмите Сохранить.

Примечание: проведенный документ нельзя уже будет отредактировать и удалить, но проведение можно отменить с помощью меню действий документа.

Все изменения, внесенные проведенным документом, можно наблюдать в карточке товара:

Поля Доступное количество (закладка Параметры) и Количество товара (закладка Склады) при включенном складском учете неактивны и изменяются только проведением документов.

Работа с остальными типами документов идентична рассмотренному выше.

Дополнительная информация

  • Документы (документация)
  • Поставщики (документация)


Диалог выбора товаров
25 / 254

Форма диалога выбора товаров в заказах, документах складского учета, скидках, правилах корзины, а также при редактировании состава наборов и комплектов имеет следующий вид:

Примечание: обновленная форма доступна:
  • для заказов, документов складского учета - с версии 15.0.1 модуля Торговый каталог;
  • для скидок - с версии 15.0.4 модуля Торговый каталог;
  • для правил корзины - с версии 14.11.0 модуля Интернет-магазин;
  • для наборов и комплектов - с версии 15.5.0 модуля Торговый каталог.

    С помощью кнопки (1) осуществляется выбор каталога, товары которого необходимо найти:

    Если же в настройках модуля Торговый каталог будет отмечена опция Показывать инфоблоки торговых предложений в форме выбора товара, то в выпадающем списке будут отображаться и каталоги предложений:

    По умолчанию (если не выполнены нижеописанные настройки) строка поиска (2) использует простой механизм отбора товаров через фильтр. Таким образом, по умолчанию поиск с помощью строки может выполняться только по названию товаров, а отбор по дополнительным параметрам возможен с помощью формы фильтра (3).

    Примечание: форма фильтра всегда доступна в диалоге выбора товаров независимо от настроек системы.

    Чтобы отбор товаров через строку поиска осуществлялся непосредственно модулем Поиск, выполните следующие настройки:

    • В настройках модуля Торговый каталог снимите галочку с опции Принудительно использовать фильтр для текстового поиска в форме выбора товара:

    • Включите индексацию товаров и разделов каталога (в форме редактирования инфоблока):

    • Переиндексируйте каталоги товаров (Настройки > Поиск > Переиндексация):

    Примечание: если хотя бы одна из настроек не выполнена, то будет использоваться простой механизм отбора товаров через фильтр.

    В результате поиск товаров будет осуществляться не только по названию, но и по их описанию, свойствам (если в настройках свойства разрешен поиск по его значениям).


Примеры
26 / 254

В главе приведены примеры работы с торговыми каталогами.


Товары из разных разделов каталога по одному единому URL
27 / 254

Иногда один и тот же товар в каталоге магазина может находиться в различных разделах и, соответственно, иметь различные адреса ссылок. Такая ситуация не очень хороша для SEO так как по разным адресам получается одинаковый контент.

Существует возможность, позволяющая задать единый адрес для всего каталога, по которому товар будет доступен из различных разделов.

Допустим, у нас есть один и тот же товар, привязанный к двум различным разделам:

http://shop6.my/catalog/dresses/dress-fashionista-on-a-walk/
http://shop6.my/catalog/pants/dress-fashionista-on-a-walk/

Внимание! В случае использования такой конфигурации символьный идентификатор товара должен быть уникальным в рамках сайта. При совпадении идентификаторов у двух различных товаров правильная работа не гарантируется.

На его примере этого товара и будем рассматривать настройку.

Комплексный компонент

В настройках компонента Каталог (bitrix:catalog) в секции Управление адресами страниц для опции Детальная информация необходимо указать

вместо значения по умолчанию

#SECTION_CODE#/#ELEMENT_CODE#/

собственное название ЧПУ для "общего" раздела

odezda/#ELEMENT_CODE#/

После чего, URL для данного товара будет один, несмотря на то, что сам товар находится в разных разделах со своими адресами:

http://shop6.my/catalog/odezda/dress-fashionista-on-a-walk/

Раздельные компоненты

В случае использования отдельных компонентов для списка элементов и детального просмотра также можно решить эту задачу.

Для этого понадобится:

  • Создать две отдельные страницы, например, в отдельном разделе /shop, и разместить на них компоненты:

    • section.php - Элементы раздела (bitrix:catalog.section);
    • detail.php - Элемент каталога детально (bitrix:catalog.element).

  • Создать правила обработки адресов (Настройки > Настройки продукта > Обработка адресов > Правила обработки):

    • для раздела
      • Условие - указывается регулярное выражение для выделения из URL символьного кода раздела каталога.
        #^/catalog/([\w\d\-]+)/(\\?(.*))?#
      • Файл - путь к странице, которая будет выводить собственно информацию о разделе. Страница может иметь произвольное место хранения и должна быть доступна для просмотра посетителям.
        /shop/section.php
      • Правило - ключ в $_REQUEST, в который будет передан полученный символьный код раздела каталога.
        section_code=$1

      Это правило будет использоваться для обработки ссылок вида http://ВАШ_САЙТ/catalog/odezda/СИМВОЛЬНЫЙ_КОД_РАЗДЕЛА_КАТАЛОГА/, где СИМВОЛЬНЫЙ_КОД_РАЗДЕЛА_КАТАЛОГА - уникальная (в пределах каталога) последовательность символов, заданных в поле Условие.
      В нашем примере символьный код должен состоять из символов латинского алфавита и цифр.

      Примечание: О том, как задается диапазон разрешенных символов, можно почитать в соответствующей документации по регулярным выражениям.

    • для элемента раздела
      • Условие - указывается регулярное выражение для выделения из URL символьного кода элемента каталога.
        #^/catalog/odezda/([\w\d\-]+)(\\?(.*))?#
      • Файл - путь к странице, которая будет выводить собственно информацию об элементе. Страница может иметь произвольное место хранения и должна быть доступна для просмотра посетителям.
        /shop/detail.php
      • Правило - ключ в $_REQUEST, в который будет передан полученный символьный код элемента каталога.
        code=$1

      Это правило будет использоваться аналогично предыдущему, но для элементов каталога.

    В итоге должно получиться следующее:

    Примечание: Первым будет обрабатываться более длинное правило, а именно для элемента каталога.

    Примечание: В случае если настройка производится на сайте, с уже существующим каталогом, то необходимо учитывать, чтобы созданные правила обработки адресов не пересекались с текущими правилами (например, правилами в случае использования комплексного компонента).

  • Настроить параметры компонента, ответственного за вывод списка элементов каталога (bitrix:catalog.section):
    • Код раздела
      ={$_REQUEST["section_code"]}
    • URL, ведущий на страницу с содержимым раздела
      /catalog/#SECTION_CODE#
    • URL, ведущий на страницу с содержимым элемента раздела
      /catalog/odezda/#ELEMENT_CODE#/

  • Настроить параметры компонента, ответственного за вывод детальной информации элемента каталога (bitrix:catalog.element):
    • Код элемента
      ={$_REQUEST["code"]}
    • URL, ведущий на страницу с содержимым раздела
      /catalog/
    • URL, ведущий на страницу с содержимым элемента раздела
      /catalog/odezda/#ELEMENT_CODE#
    • Название переменной, в которой передается код группы
      SECTION_ID

    • Внимание! Если значения параметров URL, ведущий на страницу с содержимым раздела и URL, ведущий на страницу с содержимым элемента раздела не продублировать в настройках инфоблока, то не будет корректно работать поиск, ссылки в корзине, заказе, просмотренных товарах, и далее.

В итоге при переходе к товару, который одновременно прикреплен к различным разделам, его URL будет один и тот же вид:

http://shop6.my/catalog/odezda/dress-fashionista-on-a-walk/

Ссылки по теме:

  • ЧПУ (Администратор. Базовый)


Комментарии к товарам на основе форума
28 / 254

Примечание: материалы данного урока следует использовать в том случае, если в комплексном компоненте Каталог не используется шаблон .default, доступный с версии 14.0.

Если у вас на сайте каталог товаров опубликован с помощью комплексного компонента Каталог (catalog), то вы легко можете настроить возможность добавления комментариев к товарам.

В первую очередь необходимо создать форум (например, Отзывы на книги), в котором будут храниться комментарии:

В настройках доступа к форуму для группы Все пользователи (в том числе неавторизованные) выставите право Новая тема, чтобы все пользователи могли добавлять комментарии к товарам.

Примечание: процесс создания форума подробно описан в уроке Форумы учебного курса Администратор. Модули.

После этого в публичном разделе сайта перейдите на страницу с каталогом товаром, включите режим правки и откройте форму параметров компонента. В группе параметров Настройки отзывов отметьте опцию Разрешить отзывы, станут доступными параметры настройки отзывов:

В параметре ID форума для отзывов укажите созданный форум для комментариев на товары (в нашем случае это Отзывы на книги).

Если данный форум с комментариями вы не планируете публиковать на самом форуме вашего сайта и хотите, чтобы обсуждение товара велось только на его детальной странице, то опцию Показать ссылку на форум отмечать не нужно.

Все остальные параметры для отзывов настройте необходимым для вас образом (подробное описание каждого параметра приведено в документации по продукту). Сохраните компонент.

В итоге, после проделанных действий, на странице детального просмотра пользователи теперь могут оставлять комментарии:

Премодерация комментариев

Чтобы иметь возможность модерирования комментариев к товарам, необходимо выполнить следующие действия:
  • Создать группу пользователей, ответственных за модерацию комментариев, и добавить в нее пользователей.
  • В настройках форума, который используется для комментариев к товарам, указать, что он является премодерируемым.
  • В некотором разделе сайта создать новую страницу и разместить на ней комплексный компонент Форум (forum).

    В настройках компонента в параметре Показывать только выбранные форумы укажите ваш форум с комментариями. Все остальные параметры настройте необходимым для вас образом (подробное описание каждого параметра компонента доступно в документации по продукту).
  • Настройте права доступа к странице, на которой размещен компонент форума следующим образом: для группы модераторов выставите Чтение, а для всех остальных групп - Доступ закрыт.


Пример подключения и использования умного фильтра
29 / 254

Допустим, что у нас имеется каталог Книги, который мы хотим опубликовать. Для его публикации мы будем использовать комплексный компонент Каталог (bitrix:catalog) в связке с компонентом Умный фильтр (bitrix:catalog.smart.filter). Поэтому предварительно следует настроить отображение необходимых свойств в умном фильтре. В нашем случае только Год выпуска и Автор(ы) будут отображаться в фильтре:

Создаем новую страницу и размещаем на ней компонент Каталог. В основных параметрах компонента указываем наш инфоблок Книги. В параметре Тип цены (секция Цены) выбираем Базовая цена. Чтобы легче было проверить работу фильтра, в настройках списка элементов отмечаем для отображения свойства Год выпуска и Автор(ы). Все остальные параметры настройте необходимым для вас образом (детальное описание каждого параметра компонента смотрите в документации по продукту).

Каталог книги опубликован. Если мы перейдем в некоторый раздел каталога, то увидим, что используется обычный встроенный в компонент фильтр. Заменим этот фильтр на умный фильтр.

Для этого со страницы просмотра некоторого раздела каталога выполняем копирование шаблона компонента Каталог: сразу применяем новый шаблон и переходим к его редактированию (файл /bitrix/templates/<шаблон_сайта>/components/bitrix/catalog/<шаблон_компонента>/section.php):

  • удаляем код вызова обычного фильтра:
    <?$APPLICATION->IncludeComponent(
    "bitrix:catalog.filter",
    "",
    Array(
        "IBLOCK_TYPE" => $arParams["IBLOCK_TYPE"],
        ...
        "CACHE_GROUPS" => $arParams["CACHE_GROUPS"],
    ),
    $component
);
?>
  • в самое начало файла добавляем следующий код для работы умного фильтра:
    <?
if (CModule::IncludeModule("iblock"))
{
    $arFilter = array(
        "ACTIVE" => "Y",
        "GLOBAL_ACTIVE" => "Y",
        "IBLOCK_ID" => $arParams["IBLOCK_ID"],
    );
    if(strlen($arResult["VARIABLES"]["SECTION_CODE"])>0)
    {
        $arFilter["=CODE"] = $arResult["VARIABLES"]["SECTION_CODE"];
    }
    elseif($arResult["VARIABLES"]["SECTION_ID"]>0)
    {
        $arFilter["ID"] = $arResult["VARIABLES"]["SECTION_ID"];
    }

    $obCache = new CPHPCache;
    if($obCache->InitCache(36000, serialize($arFilter), "/iblock/catalog"))
    {
        $arCurSection = $obCache->GetVars();
    }
    else
    {
        $arCurSection = array();
        $dbRes = CIBlockSection::GetList(array(), $arFilter, false, array("ID"));
        $dbRes = new CIBlockResult($dbRes);

        if(defined("BX_COMP_MANAGED_CACHE"))
        {
            global $CACHE_MANAGER;
            $CACHE_MANAGER->StartTagCache("/iblock/catalog");

            if ($arCurSection = $dbRes->GetNext())
            {
                $CACHE_MANAGER->RegisterTag("iblock_id_".$arParams["IBLOCK_ID"]);
            }
            $CACHE_MANAGER->EndTagCache();
        }
        else
        {
            if(!$arCurSection = $dbRes->GetNext())
                $arCurSection = array();
        }

        $obCache->EndDataCache($arCurSection);
    }
    ?>
    <?$APPLICATION->IncludeComponent(
        "bitrix:catalog.smart.filter",
        "",
        Array(
            "IBLOCK_TYPE" => $arParams["IBLOCK_TYPE"],
            "IBLOCK_ID" => $arParams["IBLOCK_ID"],
            "SECTION_ID" => $arCurSection["ID"],
            "FILTER_NAME" => "arrFilter",
            "PRICE_CODE" => $arParams["PRICE_CODE"],
            "CACHE_TYPE" => "A",
            "CACHE_TIME" => "36000000",
            "CACHE_NOTES" => "",
            "CACHE_GROUPS" => "Y",
            "SAVE_IN_SESSION" => "N"
        ),
        false
    );?>
<?
}
?>
    Обратите внимание, что в фильтре будут отображаться типы цен, выбранные при настройке компонента Каталог (см. параметр "PRICE_CODE). В нашем же случае будет отображаться только базовая цена (см. настройки компонента выше).
  • Сохраняем внесенные изменения.

В результате страница просмотра раздела каталога имеет следующий вид:

Фильтр отображается в соответствии с выбранными нами свойствами и типом цен.

Но такое расположение формы фильтра неудобно для поиска и просмотра списка книг. Поэтому в нашем примере вынесем форму фильтра во включаемую область страницы. Для этого необходимо выполнить следующие действия:

  • Скопируйте шаблон компонента Умный фильтр:

    В форме копирования шаблона отметьте опцию Применить новый шаблон компонента. В этом случае автоматически подставится название нового шаблона в коде вызова компонента в файле /bitrix/templates/<шаблон_сайта>/components/bitrix/catalog/<шаблон_компонента>/section.php (см. код выше).

    Важно! Если копирование компонента Умный фильтр выполняется вручную, то затем необходимо будет самостоятельно подставить название нового шаблона в коде вызова компонента фильтра в компоненте каталога:
    ...
<?$APPLICATION->IncludeComponent("bitrix:catalog.smart.filter", "<новый_шаблон>", Array(
    "IBLOCK_TYPE" => $arParams["IBLOCK_TYPE"],
    ...

    Кроме того, в форме копирования шаблона отметьте опцию Перейти к редактированию шаблона, чтобы сразу был осуществлен переход к редактированию шаблона компонента.
  • Добавьте следующий код в шаблон компонента Умный фильтр:
    <?$this->SetViewTarget("right_area");?>
    перед
    <form name="<?echo $arResult["FILTER_NAME"]."_form"?>"
...
    и в конце после
    ...
</form>"
    добавьте
    <?$this->EndViewTarget("right_area");?>
    И сохраните внесенные данные.
  • Перейдите к редактированию включаемой области страницы, на которой размещен компонент Каталог, и добавьте следующий код:
    <div class="sidebar pright">
   <?$APPLICATION->ShowViewContent("right_area")?>
</div>

В результате выполненных действий страница просмотра раздела каталога книг будет иметь вид:


Импорт данных
30 / 254

В 1С-Битрикс: Управление сайтом доступно три вида импорта данных:

  • Импорт из 1С;
  • Импорт из файла формата XML;
  • Импорт из файла формата CSV.

Примечание. Механизм выгрузки через XML – довольно сложный и используется для интеграции с существующими системами учета. В силу сложности темы, в «Примере» этот способ импорта рассматриваться не будет.


Импорт из 1С
31 / 254

Достаточно часто у заказчика база данных товаров расположена в программе 1С: Предприятие. Начиная с версии 8.1 в этой программе предусмотрен штатный механизм экспорта данных в 1С-Битрикс: Управление сайтом. Благодаря чему возможно использование существующей базы товаров для наполнения Интернет-магазина.

Настройка импорта со стороны 1С-Битрикс: Управление сайтом производится на странице Магазин > Настройки > Интеграция с 1С. Выполнение импорта осуществляется через интерфейс программы 1С: Предприятие. Детально процесс настройки и собственно импорта мы рассматривать не будем. Если вы решили экспортировать данные из 1С: Предприятие, то для информации воспользуйтесь соответствующей главой текущего курса.

Дадим несколько замечаний по поводу механизма импорта из 1С: Предприятие. Импорт из 1С не всегда применим в «чистом» виде: конфигурация может быть кастомизированой или структура номенклатуры в 1С: Предприятие такая, что совсем «не ложится» в 1С-Битрикс: Управление сайтом без существенных трудозатрат.

В этом случае первичное наполнение магазина лучше произвести другими способами, а затем провести комплекс организационных мер по наладке интеграции с учётной системой 1С: Предприятие уже работающего магазина.

Основное правило реорганизаций - все дополнительные детали в виде пакета картинок, дополнительных свойств номенклатурной позиции, делаются уже на стороне 1С-Битрикс: Управление сайтом. То есть из 1С: Предприятие необходимо получить как минимум: название, артикул, детальное описание, структуру каталога. По возможности изображение и цену с валютами.


Импорт из файла csv
32 / 254

Импорт из файла CSV – относительно удобный способ добавления товаров в каталог магазина.

Правда, механизм импорта может быть усложнен, если в каталоге есть привязки к другим инфоблокам. На стадии загрузки невозможно штатными средствами задать привязки элементов. Поэтому после загрузки элементов придется вручную проходить весь каталог и производить привязку элементов.

Опытные разработчики применяют следующий метод. Сначала в MS Excel создается специальный файл, в котором менеджер вручную задает привязки между элементами.

Пример строки файла:

ID элемента привязка к ИБ 1 привязка к ИБ 2 привязка к ИБ 3 И так далее…

После того как такой файл будет создан, он передается скрипту, который по наименованию ищет значения в связанных справочниках и для каждой записи выставляет ID связанного элемента из внешнего справочника.

А потом кастомным загрузчиком загружаются все CSV-файлы и восстанавливаются привязки. Этим загрузчиком также можно производить очистку данных (типографика), добавлять и генерировать служебные поля.

Подобное можно выполнить и в 1С-Битрикс: Управление сайтом, если вывести столбцы в списке элементов и переключиться в режим быстрого редактирования. Только в MS Excel это делается на порядок быстрее из-за того, что список выпадает прямо из ячейки, а не подгружается в новом окне как в 1С-Битрикс: Управление сайтом. Кроме того, неквалифицированному менеджеру привычнее работа в MS Excel.

Примечание: дополнительно, при загрузке данных следует озаботиться их типографикой. Обычно данные отформатированы так, что их лучше не показывать людям. Например, «» вместо "", лишние пробелы, знаки табуляции и прочее. Можно понадеяться что перед запуском материалы вычитают менеджеры со стороны заказчика, но обычно этого не происходит, а при импорте больших каталогов и вовсе очень дорого по ресурсам. Поэтому данные желательно типографить, чтобы они не портили верстку шаблонов и выглядели аккуратно. (http://www.typograf.ru/about/, http://www.artlebedev.ru/tools/typograf/about/).

Это можно уже делать и отдельными скриптами внутри БД – если использовать стандартный импорт и после него прогонять отдельные скрипты.


Файл csv
33 / 254

Прежде чем импортировать данные, нужно создать файл CSV, который будет применяться как источник для импорта. По умолчанию, в 1С-Битрикс: Управление сайтом для файлов импорта используется разделитель ;. Если вы в своем файле будете использовать иной разделитель, то при выполнении самого импорта не забудьте указать нужный.

Примечание: достаточно часто используется символ |, так как он никогда не встречается в названиях товаров.

Удобнее всего для создания файла использовать программу MS Excel. Можно использовать и другие, вплоть до простейшего Блокнота, но этот табличный редактор удобен и им привычно пользоваться обычным пользователям.

Откройте программу MS Excel.

Создайте новый файл под любым именем (в нашем случае пусть это будет: baza) и сохраните его с расширением csv.

Примечание: при сохранении файла в формате csv, в MS Excel 2007 нет формата разделителя ;. Excel предлагает сохранить только с разделителем ,. Соглашайтесь. На самом деле файл сохранится с нужным разделителем – точка с запятой. Почему так происходит – вопрос к разработчикам MS Excel.

В файле CSV обязательно должны присутствовать как минимум два параметра: уникальный идентификатор и название элемента. Название колонок с параметрами не обязательно должно совпадать с названиями параметров в системе. Главное, что бы они были понятны вам, и при задании условий импорта у вас не возникло затруднений в определении соответствий полей создаваемого вами сейчас файла CSV и полей формы импорта.

  • Создайте обязательные колонки. Пусть они называются ID и Название.
  • В колонку ID внесите произвольные цифровые индексы. Индексы должны быть уникальными для каждой строки.
  • В колонку Название внесите названия товаров так, как они должны будут отражаться в списке товаров.

Готов необходимый минимум параметров. При желании можно сохранить файл и импортировать его на сайт, технически операция импорта осуществится. Но это – технический минимум, нормальную торговлю на этих данных организовать невозможно. Значит, будем дополнять файл дальше.

Нам нужно, чтобы каждый товар попадал строго в нужную папку в рамках уже созданной структуры каталога. Для этого в процедуре импорта все предусмотрено. Нужно только создать колонки, которые будут объяснять, куда какому товару попадать. У нас крайне простая структура с одним уровнем вложенности. Значит, надо создать одну колонку с названиями папок в каталоге.

Создадим колонку для первого уровня и назовем ее Первый уровень.

Заполните колонку Первый уровень для всех элементов, согласно нашей структуре.

Важно! Названия, вводимые в эти колонки, должны точно совпадать с теми названиями, которые используются в каталоге. Если названия не будут совпадать, то система при импорте создаст разделы с новыми названиями и в них поместит импортируемые элементы.

В принципе можно структуру каталога заранее не создавать. При первом импорте будут созданы разделы нужного уровня вложенности с названиями, заданными в колонках файлах. Но при регулярном импорте важно указать точное название разделов для импорта элементов.

Примечание: в случае нескольких уровней вложенности, если будут указаны названия разделов нижнего уровня, но не указаны имена разделов верхнего уровня, то будут созданы папки верхнего уровня с именем Пустое название. Если у вас случайно произошла такая ошибка, то повторного импорта можно не производить. Просто перенесите добавленные элементы в нужную папку.

Теперь можно приступать к созданию колонок с данными о товаре.

Создайте колонки, соответствующие необходимым данным для импорта и заполните колонки данными.

Некоторые моменты:

  • Если в качестве описания используется текст, отформатированный html тегами, то необходимо в настройках модуля Торговый каталог, на закладке Экспорт / Импорт добавить в качестве используемой строку Тип детального описания. Если html-форматирование используется и для анонсового описания, то нужно добавить соответствующую строку и для анонсового описания. Соответственно в CSV файле должны быть добавлены колонки, указывающие на тип описания.
  • Добавление элемента в колонки со свойством типа Привязка к элементу не произведет автоматического привязывания элемента, если элементы еще не созданы (так как заполнить эту колонку можно только ID элементов, а они еще неизвестны). Привязку необходимо осуществить после экспорта, вручную. Однако, если элементы инфоблоков уже созданы, то можно в соответствующие колонки ввести код элемента.
  • При добавлении численных значений необходимо следить, чтобы разделитель десятичных знаков, используемый в 1С-Битрикс: Управление сайтом совпадал с разделителем, используемым в CSV файле. В системе 1С-Битрикс: Управление сайтом в качестве разделителя десятичных знаков используется точка.
  • Одновременно с указанием цены, в csv-файле обязательно необходимо предусмотреть колонку валюта, в которой будет указана используемая валюта. Без этого импорта не произойдет. Точнее – импорт элементов осуществится, но цены не будут добавлены.
  • Для загрузки данных для свойств с признаком множественности, необходимо повторить строку с товаром столько раз, сколько будет множественных полей. Например, в случае со свойством Технические характеристики, нам нужно заполнить три поля. Следовательно, в файле CSV получится по три строки на каждый товар. Если множественных свойств несколько, то число строк должно равняться числу параметров наибольшего свойства. Ячейки для параметров свойств с меньшим числом можно просто оставить пустыми. Все строки должны быть одинаковыми по содержанию, за исключением множественных полей, которые изменяются указанием новых данных для этого свойства. Подобная особенность импорта с помощью стандартного механизма приводит к распуханию файла, если количество множественных свойств много и они интенсивно используются. При импорте больших файлов следует использовать пошаговые операции.
  • Перед импортом необходимо загрузить картинки в систему. В файле CSV для них должны быть выделена свои отдельная колонка. Картинки могут быть расположены в любом месте в рамках файловой структуры, главное – указать при импорте правильный путь до них. Рекомендуется использовать папку /upload.


Импорт данных
34 / 254
  • Перейдем на страницу Магазин > Настройки > Импорт данных > Import CSV (new):

    Откроется трехшаговый мастер импорта:

  • С помощью кнопки Выбрать укажем путь до файла CSV (если файл до этого не был загружен в систему, то загрузите его).
  • В поле Информационный блок укажем в выпадающем списке тип инфоблока и выберем инфоблок (Бытовая техника).
  • Нажмите кнопку Далее. Откроется форма второго шага импорта:

Можно использовать как разные разделители, так и заданную ширину полей. По умолчанию в программе MS Excel используется разделитель точка с запятой. Не будем менять этих установок.

По умолчанию первая строка в файле должна определять названия колонок. Возможен и другой вариант, для этого предусмотрено поле Первая строка содержит имена полей. Но мы используем штатный вариант, другие варианты не рассматриваем, и потому ставим флажок в этом поле.

  • Нажмите кнопку Далее, система перейдет к третьему шагу импорта и откроется последний шаг настроек, в котором вам надо составить соответствие колонок в CSV-файле свойствам инфоблока:

    Примечание: В выпадающем списке формы отображаются только те поля, которые выбраны для импорта в настройках модуля.

    Это действие не должно вызвать у вас затруднений. Необходимо только следить за правильностью соответствий.
  • После задания соответствий переходим к Дополнительным настройкам:

    • В поле Путь к картинкам укажите путь до папки с картинками.
    • Использовать настройки инфоблока для обработки изображений - поставьте галочку, чтобы при импорте учитывались настройки изображений, заданные на закладке Поля страницы редактирования инфоблока.
    • Использовать настройки инфоблока для транслитерации символьных кодов - поставьте галочку, что при импорте учитывались параметры транслитерации, заданные на закладке Поля страницы редактирования инфоблока.
    • Язык для транслитерации - укажите язык транслитерации:

    • Если группе Товары, которых не было в файле выбрать не трогать, то товары и разделы добавленные ранее останутся без изменений. Если выбрать деактивировать, то станут неактивными все папки, которые были нами созданы ранее, но в которые не добавилось ни одного элемента, а так же деактивируются все ранее добавленные элементы. Если выбрать удалить, то папки, в которые не добавлено ни одного элемента и ранее добавленные элементы будут удалены. В нашем Примере мы выберем не трогать, так как структура разделов нами уже задана.
    • Поле Неактивные товары/группы, которые есть в файле оставляем как есть. Для информации – это функция для случаев, когда по каким-то причинам (например, отсутствие товара на складе) позицию товара деактивируют, а при последующем импорте ее надо опять включить.
    • Параметр Время выполнения шага сделан для больших файлов импорта. Большой – это несколько тысяч позиций. При таких файлах рекомендуется использовать шаг в 30-60 секунд. В нашем случае тестового файла CSV можно поставить 0 и весь импорт произойдет в один шаг.
  • Нажмите на кнопку Загрузить данные. Начнется процесс импорта. После его завершения система сообщит об успешном завершении операции (или о возникших ошибках).

Перейдите в публичную часть сайта и посмотрите результаты импорта.


Сохранение конфигурации импорта
35 / 254

Если импорт будет производиться регулярно, то есть смысл сохранить конфигурацию импорта для упрощения дальнейшей работы. В этом случае надо создать свою схему.

  • Перейдите на страницу Магазин > Настройки > Импорт данных. Откроется список имеющихся на данный момент схем импорта.
  • В контекстном меню выберите Добавить профиль и в выпавшем списке выберите тип профиля, на основе которого будет создан новый (в случае Примера – Import CSV (new)). Откроется первый шаг выполнения импорта.
  • Выполните первые два шага по импорту по аналогии с описанным ранее процессом. Третий шаг будет несколько отличаться.
  • После задания соответствий полей в файле полям в базе данных и проведения дополнительных настроек, перейдите к полю Название схемы импорта и заполните его:

  • Нажмите кнопку Сохранить. Новый профиль сохранится и появится в общем списке профилей импорта.

    • Теперь, при последующем импорте, не нужно будет заново заполнять все поля, достаточно только выбрать нужную схему.


Как сэкономить на месте и ускорить выгрузку из 1С
36 / 254

Рассмотрим пример: в каталоге есть товар, платье одного цвета и различных размеров.

Раньше, для каждого размера необходимо было загружать одинаковые картинки, причем различных размеров (картинка для превью, полноразмерная картинка и.т.д.).

В итоге, если таких товаров в каталоге много, то повторяющиеся картинки к ним на диске могут занимать достаточно много места. Также выгрузка из 1С таких товаров очень тяжелая из-за большого количества файлов и общего их размера.

По новой схеме работы картинку можно выгрузить в главный элемент торгового предложения, которая будет также отображаться и для связанных элементов. Это позволит сократить количество дублирующихся файлов, уменьшить объем занимаемого ими места на диске, ускорить выгрузку из 1С.

Пример такого варианта реализации можно посмотреть в штатном шаблоне готового решения интернет-магазин:
http://адрес_сайта/catalog/dresses/dress-spring-ease/.

Примечание: Эта особенность работает только с основными компонентами каталога.

Общий алгоритм работы поиска и отображения изображений:

  • Первым делом производится поиск картинки для анонса.
  • Если ее нет, то уже дальше продолжается поиск детальной картинки.
  • Далее идет поиск изображений в файловых свойствах.

  • Если в главном элементе торгового предложения нет изображений, то поиск производится по схеме, указанной выше, уже в связанных элементах. Другими словами, можно загрузить картинку в один связанный элемент товара, и она будет отображаться для всех элементов, включая главный.

Если же варианты торговых предложений отличаются, например, товар может быть разного цвета, то тогда необходимо загрузить различные картинки для различных торговых предложений.

Пример такого варианта реализации можно посмотреть в штатном шаблоне готового решения интернет-магазин:
http://адрес_сайта/catalog/pants/pants-flower-glade/.

Примечание: Если для товара созданы файловые свойства, в которых хранятся изображения, то в параметрах компонентов, выводящих в публичной части информацию по товарам, необходимо для параметров Дополнительная картинка основного товара и Дополнительные картинки предложений указать необходимые свойства с нужными изображениями:


Интернет-магазин
37 / 254

Для создания интернет-магазина предназначен модуль Интернет-магазин, позволяющий осуществлять продажу товаров и услуг с сайта. Интернет-магазин состоит из следующих функциональных элементов:

  • корзина товаров и услуг с возможностью добавления туда произвольных товаров и услуг;
  • процедура оформления заказа;
  • персональный раздел покупателя с возможностью просмотра сделанных заказов и настройкой профилей;
  • административный раздел для настройки параметров магазина и управления заказами клиентов.

Вся работа с Интернет-магазином в 1С-Битрикс: Управление сайтом в Административной части ведется в разделе Магазин. За исключением настроек модуля.

Внимание! Для корректного функционирования модуля Интернет-магазин необходимо наличие в системе установленного модуля Валюты, с помощью которого производится настройка валют. Магазин не сможет функционировать, если в системе не задана хотя бы одна валюта.

Дополнительная информация

  • Пользовательская документация по модулю "Интернет-магазин"


Настройка модуля
38 / 254

Настройка модуля осуществляется на странице Настройки > Настройки продукта > Настройки модулей > Интернет-магазин:

Детальные значения полей освещены в документации к продукту. Поясним базовые моменты настройки.

Форма настройки модуля состоит из закладок:

  • Настройка параметров модуля - основные параметры.
  • Параметры веса - параметры для систем доставки. При использовании нескольких магазинов в рамках одной системы можно задать для каждого магазина в отдельности. Можно использовать разные единицы веса (по умолчанию - кг).
  • Адрес магазина - указание местоположения магазина. В дистрибутиве уже загружены самые распространенные местоположения. Если вы не нашли своего местоположения, то его можно будет создать или загрузить на странице Магазин > Настройки магазина > Местоположения > Список местоположений. Кроме того, можно указать зону обслуживания интернет-магазина с помощью одноименного поля (в этом случае клиенту не нужно будет заполнять лишние поля при оформлении заказа). При использовании нескольких магазинов в рамках одной системы можно задать адрес для каждого магазина в отдельности.
  • Пластиковые карты - заполняется при работе магазина с пластиковыми картами. Рекомендуется проявить особую осторожность при использовании этого функционала, так как хранение данных о картах пользователя на сайте предъявляет высокие требования к обеспечению безопасности данных.

    Данная вкладка будет видна при отмеченном и сохраненном значении параметра Использовать пластиковые карты закладки Настройки.

  • Права на заказы - выбор групп, которые должны отвечать за обработку заказов. По умолчанию это - Администраторы Интернет-магазина. Не забудьте включить в эту группу тех пользователей, которые должны выполнять работу в магазине. Либо дать доступ к заказам тем группам, в которые уже включены эти люди. При использовании нескольких магазинов в рамках одной системы можно задать для каждого магазина в отдельности.
  • Доступ - типовой функционал настройки доступа к модулю.


Персонализация
39 / 254

1С-Битрикс BigData - облачный сервис для обработки больших объемов информации, автоматического выявления закономерностей, прогнозирования поведения пользователей. Выдача рекомендаций для интернет-магазинов и сайтов в режиме реального времени.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Персональные рекомендации

Облачный сервис персонализации 1С-Битрикс BigData, сохраняя полную анонимность данных, анализирует посетителей, зашедших на ваш сайт (их интересы, покупки, сходство с другими покупателями), и составляет для них персональные рекомендации. Выбор товаров для персональной рекомендации не зависит от внутреннего устройства групп пользователей на сайте.

Сервис работает индивидуально для каждого сайта, т.е. рекомендации показываются товарами того сайта, где запрашивается рекомендация. Передать данные сервису по продажам из сети офлайн магазинов невозможно.

Примечание: сервис встроен в продукт и доступен, начиная с версии 14.9.2 модуля Интернет-магазин и с версии 15.0.0 модулей Информационные блоки и Торговый каталог.

В административной части сайта содержится специальная страница сервиса (Магазин > Персонализация), на которой проверяется доступен ли сервис для использования и размещен ли компонент персонализации:

Таким образом, для подключения сервиса необходимо:

  • В настройках главного модуля отметить опцию Использовать сервис рекомендаций товаров:

  • Разместить на сайте и настроить компонент Персональные рекомендации (bitrix:catalog.bigdata.products). Его рекомендуется размещать на главной странице магазина, на странице со списком товаров, на странице с детальной информацией о товаре, на странице с корзиной или на странице оформления заказа.

    Компонент можно разместить не на одной странице, а на нескольких. Причем на разных страницах можно давать пользователям разные рекомендации (т.е. в настройках компонента для разных страниц задать разный тип рекомендаций).

Доступны следующие типы рекомендаций:

Пять типов являются базовыми, причем первые два типа не зависят от контекста и их можно размещать на любых страницах сайта:

  • Самые продаваемые – пользователю товары рекомендуются из top'а продаж.
  • Персональные рекомендации – рекомендации формируются на основе поведения пользователя на сайте.

Следующие три типа зависят от товара и могут быть установлены на детальной странице товара (в этом случае в настройках компонента должен быть задан идентификатор товара):

  • Продаваемые с этим товаром – анализируются товары, которые вместе с этим обычно покупают пользователи.
  • Просматриваемые с этим товаром – рекомендуются те товары, которые чаще всего просматривают пользователи до и после данного товара.
  • Похожие товары – смешанный анализ похожести на основе просмотров и покупок.

Также можно комбинировать вывод и показывать случайный тип рекомендации: Продаваемые/Просматриваемые/Похожие товары, Самые продаваемые/Персональные и Любая рекомендация.

Примечание: подробное описание параметров компонента представлено в документации по продукту.

Наличие размещенного на сайте компонента персонализации проверяется раз в сутки.

Примечание: начиная с версии 15.0.4 модуля Информационные блоки, показ персональных рекомендаций добавлен в шаблон по умолчанию компонента Каталог. По умолчанию показ включен.

Сервис персонализации работает по следующему принципу:

  • Собирается аналитика по всем товарам, которые пользователь просмотрел, положил в корзину, заказал.
  • На базе похожести уже выбранных пользователем товаров облачный сервис находит наиболее интересные для пользователя товары и предлагает их.
  • Если компонент персонализации расположен на детальной странице товара, то облачный сервис будет предлагать похожие на этот товар другие товары по настраиваемым признакам. Топ товаров на домене строится на базе статистики, собранной в облаке для данного домена.
  • Если для пользователя нет аналитики из облака, то персональные рекомендации не будут пустыми. Будут взяты данные из компонентов Просмотренные товары, Рекомендуемые товары и Самые продаваемые товары.

Примечание: сервис персонализации не сравнивает товары с разных сайтов. Кроме того, он оценивает поведение похожих пользователей на одном сайте, но не сами товары сайта.

Если данные персонализации закешированы, то поисковик видит их как часть страницы. Если же данные не закешированы, то они отобразятся ajax запросом.

Анализ рекомендаций

Отслеживание товаров, которые были куплены через облачный сервис персонализации, осуществляется на странице со списком заказов (Магазин > Заказы). На странице отображается используется ли облачный сервис персонализации, сколько было сделано заказов по персональным рекомендациям и какова их сумма:

Заказы и сами товары, купленные из блока персонализации, отмечаются специальным маркером.

Примечание: если же в заказе присутствуют товары, которые были куплены из блока персонализации и товары, купленные просто при просмотре товаров магазина, то проставляются маркеры и добавляется сумма продаж только для тех товаров, которые были куплены из блока персонализации.

Общая сумма по всем просматриваемым заказам доступна внизу страницы:

Пометка товаров, купленных по персонализации, также проставляется и при просмотре заказа:


Каталог товаров
40 / 254

Каталог товаров (Магазин > Каталог товаров) позволяет:

  • просмотреть/добавить/изменить товары/разделы каталогов интернет-магазина:

  • просмотреть/добавить/изменить свойства товаров:

  • просмотреть/добавить/изменить свойства торговых предложений:

  • редактировать настройки каталога:

    В настройках торгового каталога вы можете изменить его название, а также работать с общими для всех товаров свойствами и свойствами торговых предложений.


Заказы
41 / 254

После оформления в публичном разделе заказ отобразится на странице административного раздела Заказы (Магазин > Заказы):

Начиная с версии 12.5.4. модуля Интернет-магазин, доступен функционал генерации номера заказа по некоторому шаблону. По умолчанию шаблон не используется (см. настройки модуля) и номер заказа совпадает с идентификатором заказа. Подробная информация по шаблонам генерации номера представлена в документации по продукту.

В зависимости от настроек прав группы, к которой приписан пользователь, ему доступны разные возможности работы с заказами. Так, Администраторы имеют полный доступ к обработке заказов.

Права на заказы устанавливаются следующим образом. В настройках модуля Интернет-магазин на закладке Права на заказы для каждого сайта в отдельности выбираются группы пользователей, которые будут иметь доступ к заказам этого сайта:

На закладке Доступ устанавливается уровень доступа к формам модуля Интернет-магазин в административном разделе:

Доступ может быть:

  • [U] обработка заказов - группы пользователей с данным уровнем доступа смогут изменять параметры заказов, работать со счетами пользователей: изменять их, создавать новые. Всю остальную информацию Интернет-магазина они смогут только просматривать.
  • [W] полный доступ - дает неограниченный доступ ко всем составляющим магазина. Такой уровень прав рекомендуется оставлять только администратору сайта.
  • закрыт - доступ запрещен.

После этого вам следует установить доступ группы пользователей на необходимые параметры заказов. Это делается в форме редактирования статуса заказа.


Создание заказа из административной части
42 / 254

Как правило в Интернет-магазинах заказы создают пользователи из публичной части. В редких случаях администратору (менеджеру) магазина заказ приходиться создавать из административной части. Для этого в контекстной панели списка заказов есть команда Добавить заказ. По этой команде открывается форма создания заказа:

Остановимся на паре моментов заполнения данной формы.

Вы можете выбрать уже имеющегося в системе покупателя, кликнув по кнопке Существующий. Для существующего профиля вы можете выбрать уже имеющийся профиль либо создать новый:

Профиль покупателя нужен для того, чтобы каждый раз заново не вводить адрес доставки: при выборе уже созданного профиля поля адреса заполнятся автоматически.

Вы можете добавить нового покупателя, нажав кнопку [image]. Заполните все необходимые поля, покупатель будет добавлен в общий список.

Обратим внимание на секцию Состав заказа:

Вы можете добавить в заказ уже имеющийся товар, нажав на кнопку Добавить товар, либо добавить новый товар (кнопка Новый товар...), который после указания всех необходимых параметров останется в системе.

Примечание: кнопка Новый товар... доступна только в том случае, если в настройках модуля Интернет-магазин отмечена опция Разрешать добавлять новый товар в форме редактирования заказа.

Если у вас есть купоны на скидки на данный товар, то вы можете ввести их в поле Промо-код и нажать Пересчитать, после чего цена заказа будет обновлена с учетом скидок.

В новом магазине представлена секция Предложите покупателю. Вы можете добавить представленные там товары в существующий заказ либо создать новый с помощью соответствующих ссылок.

В случае затруднений с полями формы обратитесь к документации.

Списание зарезервированного товара

Если складской учет включен и вы отмечаете отгрузку товаров (галочка в параметре Отгрузить заказ), то для успешного списания товара вам вручную необходимо корректно указать, сколько единиц товара с какого склада нужно вывезти, и правильно ввести штрихкод (если для товара он задан):


Настройка представления товаров
43 / 254

Начиная с версии 14.0.0, доступна возможность настройки необходимых вам столбцов в таблице со списком товаров в форме редактирования заказа:

Настройка столбцов выполняется с помощью кнопки [image], расположенной в шапке таблицы над колонкой с доступными действиями. При нажатии на кнопку открывается форма следующего вида:

В списке доступных колонок отображаются все имеющиеся в системе свойства товаров и торговых предложений. Выберите необходимые вам свойства, добавьте их в список выбранных колонок и сохраните настройки. Все выбранные колонки отобразятся в таблице товаров:

Если требуется убрать какую-либо из отображаемых колонок, то необходимо выполнить следующие действия:

  • открыть форму настройки представления товаров;
  • выбрать требуемые колонки в списке выбранных колонок и перенести их в список доступных;
  • сохранить настройки формы.


Печать документов по заказу
44 / 254

Перейти к печати документов по заказу можно несколькими способами:

  • из меню действий заказа, выбрав пункт Печать документов:

  • в форме просмотра/редактирования заказа, нажав кнопку Печать заказа на контекстной панели:

В открывшейся форме содержится информация о товарах и о самом заказе (дата заказа, сайт заказа, его статус и т.д.):

В форме Печать документов представлены:
  • Общая информация о заказе: Номер заказа, Дата заказа, Сайт заказа, Статус.

    Примечание: цены на товары указаны уже с учетом скидки.
  • Cписок позиций заказа. Поле Включен в нем означает, что данная позиция будет включена в печатный документ. Некоторые шаблоны документов позволяют печатать данные не по всем, а по произвольной части товаров заказа, например, Счет-фактура, Бланк заказа, Накладная. С помощью данного поля можно указать, что в печатном документе должны присутствовать не все товарные позиции. Если шаблон не предусматривает печать только части заказа, то он отобразит все товарные позиции вне зависимости от установок на форме.

    Примечание: в таблице заказанных товаров поле Количество открыто для ввода. Оно служит для распечатывания документов по заказу для меньшего числа товаров, чем в заказе. Например, было заказано два телефона, а распечатать документ необходимо для одного из них. Тогда в поле количество ставят 1, среди шаблонов документов выбирают те, которые необходимы, и после нажатия кнопки Печать документ будет сформирован для указанного количества товаров.

  • Также в этой форме можно выбрать документы для печати. Для этого служит поле Шаблон документа. В этом поле выбираются документы, которые необходимо распечатать. Для множественного выбора выбирайте шаблоны, удерживая клавишу Ctrl.

Для того, чтобы приступить к печати документов, нажмите кнопку Печать. Все выбранные документы открываются в новых окнах. В некоторых документах перед печатью можно изменять какой-либо текст (например, в предустановленном документе Счет-фактура). Находясь в окне документа, нажимайте на клавишу Tab, а тексты, которые можно менять, будут подсвечиваться по очереди.

Примечание: внешний вид формы печати документов по заказу настраивается на странице Настройка печатных форм.

Файлы, содержащие Предустановленные шаблоны, находятся в каталоге /bitrix/modules/sale/reports/.

Если вас не устраивает какой-либо предустановленный шаблон, то вам следует скопировать файл этого шаблона из каталога предустановленных шаблонов в каталог пользовательских шаблонов (/bitrix/admin/reports/) и изменить его соответствующим образом. В каталог пользовательских шаблонов можно добавить любое количество произвольных шаблонов документов.

Дополнительная информация

  • Печать заказов (документация)


Управление маркетингом
45 / 254

В данной главе описан функционал скидок и правил работы с корзиной.

Общий алгоритм по применению скидок, правил корзины в магазине:
  1. Выбираются скидки на товар (с учетом введенных купонов). Сортируются в порядке убывания по полю Приоритет применимости. Внутри блока с одинаковым приоритетом сортировка идет по убыванию размера скидки. После каждой примененной скидки блок оставшихся пересортируется. Каждая из скидок проверяется на применимость к товару (условия, величина). Применяются друг за другом, пока не закончатся, либо пока не встретится флаг Прекратить дальнейшее применение скидок.
  2. Выбираются накопительные программы. Если их несколько, то выбирается наибольшая. В зависимости от настроек модуля Торговый каталог программы либо дополняют скидки на товар, либо выбирается большее значение (общее значение скидок на товар или накопительная), либо отбрасываются.
  3. Выбираются правила корзины (с учетом введенных купонов, начиная с версии 14.11.0 модуля Интернет-магазин). Сортируются по убыванию приоритета, внутри блока - по возрастанию сортировки. Применяются либо пока не закончатся, либо пока не встретится флаг Прекратить дальнейшее применение правил.


Скидки на товар
46 / 254

Скидка — величина, на которую снижается продажная цена товара, реализуемого покупателю.

Скидки могут применяться как к одному товару торгового каталога, так и ко всем товарам каталога или отдельного раздела. Скидки для товаров действуют и на их торговые предложения.

Управление скидками на товары осуществляется на странице Магазин > Управление маркетингом > Скидки на товар > Скидки на товар:

Примечание: о настройке таблицы списка читайте в курсе Администратор. Базовый.


Настройка скидки на товар
47 / 254

Рассмотрим форму настройки скидки на товары на примере создания, например, скидки 10% на раздел Пантолеты каталога Одежда, действующую в течении месяца. Для этого на контекстной панели страницы административного раздела Магазин > Управление маркетингом > Скидки на товар > Скидки на товар нажмите Новая скидка. Откроется форма создания (редактирования) скидки:

Заполните поля на закладке Скидка:

  • Опция Активность должна быть отмечена, чтобы скидка применялась к товарам каталога.
  • Укажите название скидки в одноименном поле, в нашем случае это Скидка 10% на пантолеты.
  • В поле Сайт выберите сайт интернет-магазина, для товаров которого создаете скидку.
  • Период активности выберите как Интервал и с помощью календаря сделайте этот интервал равным месяцу.

    Важно! Будьте внимательны при настройке дат интервала действия скидки. Если в календаре у вас отключена установка времени, то в соответствующем поле будет установлена только дата без времени:

    Например, если установлено, что скидка действует до 28.04.2015, то считается, что она действует до 28.04.2015 00:00:00. Таким образом, 28.04.2015 скидка действовать уже не будет.
  • В выпадающем списке Тип скидки можно выбрать одну из следующих форм задания скидки:
    • В процентах - скидка задается в процентах от стоимости товара (указывается в нашем примере);
    • Фиксированная сумма - можно указать определенную сумму скидки в валюте, определенной в поле Валюта скидки;
    • Установить цену на товар - можно указать фиксированную цену на товар после применения скидки в валюте, определенной в поле Валюта скидки.
  • В поле Величина скидки укажите величину скидки (в нашем примере это 10).
  • Поле Валюта скидки определяет, в какой валюте задана скидка (если она представлена в виде фиксированной суммы или цены), а также определяет валюту для Максимальной суммы скидки, если эта сумма задана. Поле Максимальная сумма скидки имеет смысл заполнять, если выбран тип скидки В процентах.

    Примечание: управление валютами, доступными для представления цен и скидок, осуществляется на страницах модуля Валюты (Настройки > Валюты).
  • Чем больше значение Приоритета применимости, тем раньше применится скидка. Помните о том, что приоритет применимости учитывается в рамках одного типа скидок (скидки на товары не будут скоординированы с правилами корзины).
  • Снимите галочку в поле Прекратить дальнейшее применение скидок, чтобы к товарам помимо данной скидки могли быть одновременно применены и другие (см. алгоритм применения).
  • Поле Краткое описание служит для задания краткого описания скидки. Размер описания не должен превышать 255 символов.

На закладке Условия задаются условия применения скидки. Укажем, что данная скидка может применяться только для раздела Пантолеты каталога Одежда. Для этого с помощью ссылки Добавить условие задайте соответствующие значения для поле Инфоблок и поле Раздел, соединив данные условия логическим И (все условия выполнены):

Примечание: вы можете добавить группу условий, которая будет обрабатываться как одна логическая единица, внутри которой также можно использовать логические операторы:

На закладке Ограничения можно указать группы пользователей, которые могут воспользоваться данной скидкой, и типы цен, на которые эта скидка распространяется:

Оставим данные параметры неуказанными, что позволит применять скидку всем группам пользователей для всех типов цен товаров.

Примечание: еще один пример создания скидки вы можете посмотреть в главе Пример создания интернет-магазина.

На закладке Купоны можно добавить купоны к скидке. Мы создаем скидку без купонов, поэтому опцию Создать купоны при сохранении параметров скидки оставляем неотмеченной:

Примечание: если для скидки нужно добавить купоны, то следует отметить опцию и указать тип и число купонов:

В результате скидка на товар будет показана в публичном разделе только в корзине после ввода купона.

Когда все параметры заданы, сохраните скидку. Она будет добавлена в общий список, а в публичном разделе созданная нами скидка будет отображаться сразу при просмотре товаров:

Дополнительная информация

  • Создание и редактирование скидки на товар (документация)


Купоны скидок на товары
48 / 254

Купон - разновидность скидки. Его отличие от скидки заключается в том, что он генерируется в любой момент и представляет собой уникальную последовательность символов. Правом на получение скидки по купону обладает покупатель, которому каким-либо образом был сообщен этот уникальный купон.

Список купонов на скидки расположен на странице Купоны на скидки (Магазин > Управление маркетингом > Скидки на товар > Купоны скидок на товар):

Примечание: о настройке таблицы списка читайте в курсе Администратор. Базовый.

Создадим, например, многоразовый купон на скидку, доступную при покупке платьев.

Примечание: купоны можно создавать также на закладке Купоны формы создания/редактирования скидки.

Нажмите [image] на странице Купоны на скидки и выберите нужную скидку в форме создания купона:

Выставьте флаг активности купона, сделайте его многоразовым, нажмите [image], чтобы сгенерировать код купона.

Примечание: купоны могут быть следующих видов:
  • Купон на одну позицию заказа - купон можно применить только к одному товару и только один раз. Если в заказе несколько товаров, то купон применяется к самому дорогому товару;
  • Купон на один заказ - купон можно применить один раз на один любой заказ;
  • Многоразовый купон - купон может применяться к заказам неограниченное количество раз.

Оставим дату применения купона пустой, чтобы его применение было возможно в любой момент.

После сохранения купон будет добавлен в общий список на странице Купоны на скидки.

В результате при вводе нашего сгенерированного купона в публичном разделе на странице корзины система автоматически выполнит пересчет и выведет новую цену только для тех товаров, для которых подходит скидка (в нашем скидка дается только на платья):

Важно! Для каждого товара может применяться неограниченное количество купонов скидок, но не более одного купона каждой скидки.

Дополнительная информация

  • Создание и редактирование купона (документация)


Правила работы с корзиной
49 / 254

Правила работы с корзиной представляют собой по сути скидки на заказ покупателя, удовлетворяющий определенным условиям. Вернее будет сказать что это не скидки, а наценки, поскольку в зависимости от выполняемого действия, стоимость заказа (или доставки) можно как уменьшить, так и увеличить. Данный инструмент позволяет задавать многовариативность условий применения скидок\наценок.

Правила работы с корзиной позволяют изменить стоимость доставки и/или стоимость товаров в корзине. Причем на комплекты правила действуют как на единую сущность (с версии 14.11.3 модуля Интернет-магазин).

Управление правилами работы с корзиной осуществляется на странице Магазин > Управление маркетингом > Правила работы с корзиной > Правила работы с корзиной:

Для правил работы с корзиной, как и для скидок на товар, могут создаваться купоны. Список всех имеющихся купонов для правил представлен на странице Магазин > Управление маркетингом > Правила работы с корзиной > Купоны правил корзины:

Примечание: купоны правил корзины доступны с версии 14.11.0 модуля Интернет-магазин.


Настройка правил работы с корзиной
50 / 254

Настройку правил работы с корзиной рассмотрим на примере добавления нового правила. Для этого на странице Магазин > Управление маркетингом > Правила работы с корзиной > Правила работы с корзиной нажмите на кнопку Добавить правило, откроется форма создания правила.

На закладке Общие параметры поля заполняются аналогично полям скидки на закладке Скидка (дополнительно см. алгоритм применения).

Рассмотрим закладку Действия и условия, именно на ней задаются условия применения скидки/наценки:

Правило может содержать в себе действие, позволяющее изменить стоимость товаров в корзине и/или стоимость доставки. Изменение стоимости товаров выполняется согласно заданным для этого действия условиям: так в нашем примере дается скидка 25% на товар из раздела Футболки, если он покупается в количестве большем или равном 2.

Дополнительные условия для применения правила задаются в одноименной секции. Например, с ее помощью можно задать условия изменения стоимости доставки:

В данном примере, если выбрана доставка курьером, то будет применяться скидка 50% на доставку и скидка 25% на футболки, если они покупаются в количестве большем 2. Если же будет выбран иной способ доставки, то скидка на футболки даваться не будет, поскольку в условиях задано, чтобы были выполнены все условия вместе.

На закладке Ограничения в обязательном порядке следует указать группы пользователей, на которые распространяется правило:

На закладке Купоны можно добавить купоны к правилу. Если необходимо, чтобы правило применялось для всех покупателей без купона, то опцию Создать купоны при сохранении правила оставляем неотмеченной:

Если правило корзины должно срабатывать по купону, то следует отметить опцию и указать тип купонов, их число и период действия:

Когда все параметры заданы, сохраните правило. Оно будет добавлено в общий список, а в публичном разделе на странице корзины или оформления заказа (если выбрано действие по изменению стоимости доставки) будет выполнен пересчет стоимости заказа в соответствии с заданными условиями.

Список ссылок по теме:

  • Примеры скидок на заказы


Купоны правил корзины
51 / 254

Примечание: купоны правил корзины доступны с версии 14.11.0 модуля Интернет-магазин.

Рассмотрим работу с купонами для правил на примере добавления нового купона со страницы Магазин > Управление маркетингом > Правила работы с корзиной > Купоны правил корзины.

Примечание: купоны правил можно также создавать на закладке Купоны формы создания/редактирования правила.

Для этого на странице Купоны правил корзины нажмите кнопку Добавить. Откроется форма создания (редактирования) купона на правило:

Заполните поля:

  • Отметьте флаг активности купона, чтобы он был доступен для применения.
  • В поле Правило корзины выберите нужное правило, на которое создается купон.
  • В поле Купон укажите код купона вручную или сгенерируйте по одноименной кнопке.
  • Выберите тип купона. Возможны следующие варианты:
    • на одну позицию заказа - купон можно применить только к одному товару и только один раз. Если в заказе несколько товаров, то купон применяется к самому дорогому товару;
    • на один заказ - купон можно применить один раз на один любой заказ;
    • многоразовый - купон может применяться к заказам неограниченное количество раз.
  • Если купон можно применять только в некоторый период времени, то задайте интервал использования в поле Период активности.

    Обратите внимание, что в купоне в первую очередь учитывается период активности самого правила.
  • Если купон должен принадлежать какому-то пользователю, то укажите данного пользователя в поле Владелец купона. В противном случае купон будет неименным.
  • В поле Максимальное число использований указывается ограничение по количеству использования для многоразового купона.
  • В поле Комментарий при необходимости можно задать произвольный комментарий для администратора.

Когда все параметры купона заданы, сохраните его. Он будет добавлен в общий список купонов для правил.

В результате при вводе купона в публичном разделе на странице корзины система автоматически выполнит пересчет и выведет новую цену только для тех товаров, для которых подходит правило (в нашем случае скидка дается на футболки, если их заказано более 2-х штук):

Важно! Для каждого заказа возможно применение неограниченного количества купонов правил корзины, но не более одного купона на каждое правило.


Накопительные скидки
52 / 254

Накопительная скидка - сумма, на которую снижается стоимость реализуемого покупателю товара, зависящая от общей суммы оформленных за определенный период покупок в данном магазине.

На странице административного раздела Магазин > Скидки > Накопительные скидки перечислены накопительные скидки, имеющиеся в системе:

Примечание: о настройке таблицы списка читайте в курсе Администратор. Базовый.

Механизм применения накопительных скидок можно выбрать в настройках модуля торгового каталога.

С примерами накопительных скидок вы можете ознакомиться в уроке Варианты накопительных программ.

Дополнительная информация

  • Накопительные скидки (документация)


Создание накопительной программы
53 / 254

Для добавления новой накопительной программы на контекстной панели страницы административного раздела Магазин > Скидки > Накопительные скидки нажмите Новая накопительная программа. Откроется форма создания накопительной программы:

Закладка "Накопительная программа"

Заполните следующие поля:

  • Активность - снимите галочку, если не хотите, чтобы данная накопительная программа применялась.
  • Название накопительной программы - введите любое название программы, дающее представление о случаях применения, величине и т.д. по желанию.
  • Сайт - выберите сайт, к ценам на товары которого может быть применена данная накопительная скидка.

Закладка "Скидки накопительной программы"

Заполните следующие поля:

  • Период для расчета скидок - укажите временной промежуток, за который следует произвести суммирование заказов для расчета скидки. Доступные значения:
    • За все время - суммируются все оплаченные заказы клиента, имеющиеся в базе.
    • При выборе значения За период появятся дополнительные поля, позволяющие указать дату/время начала и окончания этого периода:

    • При выборе значения За последние появится дополнительное поле Выбрать оплаченные заказы за последний(е):

      Укажите число дней\месяцев\лет до текущего момента, за которые следует произвести суммирование стоимости заказов для вычисления скидки.

  • Срок действия скидок - здесь указывается период времени, в течение которого можно использовать накопительную программу. Доступны следующие значения:
    • Бессрочно - без ограничений по времени.
    • При выборе значения Период, как и для поля Период для расчета скидок, появятся дополнительные поля, позволяющие указать дату/время начала и окончания этого периода.
    • При выборе значения Время с момента получения появится дополнительное поле Период действия скидок (с момента получения скидки):

      Укажите число дней\месяцев\лет с момента получения, в течении которых будет действовать скидка.

  • Валюта сумм оплаченных заказов - выберите валюту, в которой будут оплачиваться заказы и выдаваться скидка:

    Примечание: список валют настраивается на странице административного режима Настройки > Валюты > Список валют. Подробнее об этом читайте в разделе Валюты.

  • Сумма оплаченных заказов - в выбранной валюте введите сумму оплаченных заказов, при которой покупатель получит скидку.
  • Величина скидки - укажите скидку при накоплении заданной суммы стоимости заказов. Скидка может быть указана как в виде фиксированной суммы, так и в процентах от суммы заказа:

    Если вам не хватило полей для указания сумм и скидок для них, для добавления новых жмите кнопку [image].

Закладка "Ограничения"

На данной закладке в обязательном порядке следует указать группы пользователей, которые могут воспользоваться скидкой:

Мы отметили все группы.

Закладка "Дополнительно"

Здесь вы можете указать внешний код, используемый для связи накопительной программы с внешним источником данных, и изменить индекс сортировки, влияющий на расположение программы в общем списке (чем больше число, тем ниже по списку будет располагаться программа):

После того как все параметры накопительной программы будут указаны, нажмите Сохранить, и она отобразится в общем списке.


Варианты накопительных программ
54 / 254

Комбинации сроков суммирования и периодов действия дают различные варианты накопительных программ. Рассмотрим основные из них.

Бессрочные программы

Бессрочная накопительная программа

Скидка будет тем выше, чем больше покупок сделал клиент за все время. Данную скидку уже нельзя потерять, она будет активна всегда.

Для создания такой программы на вкладке Скидки накопительной программы формы создания накопительной скидки выберите следующие параметры:

Программа для поощрения старых клиентов

Предположим, нужно дать постоянную скидку 5% клиентам, которые сделали покупки до 01 сентября 2009 года на сумму не меньше 20 000 рублей. Для этого на вкладке Скидки накопительной программы формы создания накопительной скидки выберите следующие параметры:

Программа для стимуляции новых заказов

Допустим нужно учитывать только заказы с начала нынешнего года и скидка будет тем больше, чем больше покупок сделает клиент в дальнейшем. Для примера пусть это будет 5% от суммы заказов не меньшей 20 000 рублей. Для этого на вкладке Скидки накопительной программы формы создания накопительной скидки выберите следующие параметры:

Разовые накопительные программы

Премирующая скидка активным клиентам

Временная скидка дается активным клиентам, которые набрали определенную сумму заказов. В поле Период для расчета скидки выбирается За все время, в поле Срок действия скидок ставится определенный период.

Акция "Купи товаров в июне на определенную сумму и получи скидку на заказы в июле"

Для такой акции на вкладке Скидки накопительной программы формы создания накопительной скидки выберите следующие параметры:

Годовая накопительная программа

Данная программа стимулирует делать заказы в течение года.

Период для расчета скидок и срок действия полностью совпадают.

Частный случай такой программы показан на скриншоте ниже:

Премирующая программа с ограничением для активных за последнее время клиентов

Как пример это скидка на месяц клиентам, активно покупавшим последние полгода:

Программы без фиксированных дат

Такие программы действуют с момента получения скидки, т.е. когда будет набрана необходимая сумма оплаченных заказов.

Период для расчета можно брать как За все время, как За период (с указанием только даты начала), так и За последние.

Срок действия таких скидок - Время с момента получения, либо Период (возможно указание только даты окончания действия программы).

Программа без фиксированной даты, по которой дается скидка в 25% тем клиентам, кто в течение трех месяцев оформит заказов на 50 000 рублей:

Если клиент попадает под действие нескольких программ - выбирается максимальная. Если обычная скидка выше, чем скидка по накопительной программе, будет выбрана обычная.


Примеры скидок на заказы
55 / 254

На данной странице приведены примеры задания различных скидок, которые легко можно реализовать с помощью инструмента Правила работы с корзиной (условия применения скидки задаются на закладке Действия и условия).

  • Скидка 50% на доставку почтой России при покупке товаров на сумму от 5000 до 10 000 рублей
  • Скидка 3% на заказ, если оплата производится наличным расчетом
  • Скидка 40% на конфеты "Барбарис", если их больше 1 кг
  • Скидка 10% на сумму заказа от 5000 рублей
  • Скидка 15% в понедельник, вторник, среду - при оплате банковской картой и если сумма заказа от 3000 рублей
  • Скидка 50% на метлу при покупке двух и более лопат
  • Скидка 50% на метлу при покупке трех наименований вил\лопат в любом варианте состава
  • Скидка 25% на покупку двух и более товаров раздела Бытовая техника
  • Скидка 5% на желтые товары, если заказ по ним превысит 1000 рублей
  • Бесплатная доставка, если заказаны только определенные товары
  • Скидка 70% на банное полотенце, когда в корзине есть штора и коврик для ванной

Скидка 50% на доставку почтой России при покупке товаров на сумму от 5000 до 10 000 рублей:

Скидка 3% на заказ, если оплата производится наличным расчетом:

Скидка 40% на конфеты "Барбарис", если их больше 1 кг:

Скидка 10% на сумму заказа от 5000 рублей:

Скидка 15% в понедельник, вторник, среду - при оплате банковской картой и если сумма заказа от 3000 рублей:

Скидка 50% на метлу при покупке двух и более лопат:

Скидка 50% на метлу при покупке трех наименований вил\лопат в любом варианте состава (трое вил, ноль лопат; 1 вилы, четыре лопаты и т.п.):

Скидка 25% на покупку двух и более товаров раздела Бытовая техника:

Скидка 5% на желтые товары, если заказ по ним превысит 1000 рублей:

Предполагаем, что свойство товара Цвет - это SKU свойство (товар SKU с нужным цветом). Скидка будет применяться на все желтые товары в корзине, если суммарный заказ по желтым товарам превысит 1000 рублей.

Бесплатная доставка, если заказаны только определенные товары:

Скидка 100% должна действовать на доставку только определенных товаров, например, зеркал (круглого, овального и в полный рост). То есть, доставка будет бесплатной, если заказано одно или несколько из перечисленных зеркал. Если же в заказе наряду с зеркалами имеются и другие товары, то скидка срабатывать не будет.

Скидка 70% на банное полотенце, когда в корзине есть штора и коврик для ванной:


Пример суммирования скидок в магазине
56 / 254

В данном уроке рассмотрим на примере работу алгоритма по применению скидок. Допустим, что в нашем магазине:

  • созданы скидки на товары из разделов Нижнее белье и Пантолеты.

    Список скидок

    • Скидка на нижнее белье будет применяться по купону к товарам из раздела Нижнее белье и составляет 10%. Дальнейшее применение скидок не прекращается.
    • Скидка на пантолеты составляет 7% и применяется к товарам из раздела Пантолеты в указанный интервал. Дальнейшее применение скидок не прекращается.
  • имеется накопительная программа скидок.

    Параметры программы

  • созданы правила, изменяющие стоимость товаров в корзине.

    Список правил

    • Скидка в 3% будет применяться к стоимости заказа, если выбран наличный расчет. Дальнейшее применение правил не прекращается.
    • Скидка в 5% имеет больший приоритет и будет применяться к стоимости заказа в субботу и воскресенье. Дальнейшее применение правил прекращается.

Важно! Механизм одновременного применения скидок и накопительных программ определяется настройками модуля Торговый каталог.

Так в нашем магазине накопительные программы не будут действовать, если на товар имеется скидка:

Представим, что в выходной день в наш магазин пришел покупатель, имеющий купон на нижнее белье. В корзину он положил следующие товары:

Видим, что на товары покупатель получил разного рода скидки. Разберем, какие именно:

  • Первый товар куплен из раздела Пантолеты, поэтому он имеет скидку 7% (899 руб. - 0,07*899 руб.=836,07 руб).

  • На товар Нижнее белье Розовое Смущенье получена скидка 10% по введенному купону CP-WDVJW-FNSJBS8 (1199 руб. - 0,1*1199 руб. = 1079,1 руб.).
  • На третий товар Спортивный Костюм Нежная Теплота сработала скидка величиной 5% по накопительной программе, поскольку покупатель оплатил уже товаров на сумму больше, чем 20000 рублей (2330 руб. - 0,05*2330 руб. = 2213,5 руб.).

Обратите внимание, что скидка по накопительной программе не применилась к первому и второму товарам в соответствии с нашими настройками модуля Торговый каталог.

Когда покупатель переходит к оформлению заказа, то величины скидок изменяются:

Происходит это в связи с тем, что к стоимости товаров применились правила работы с корзиной. Рассмотрим подробнее, какое из правил или оба наших правила применились.

Покупатель выбрал наличный расчет, но делает покупку в выходной день. Следовательно, применилось только одно правило Скидка 5% на заказ в выходные, поскольку оно имеет более высокий приоритет применимости и после него больше никакие правила не применяются.

В нашем магазине правило применяется не к полной стоимости товара, а к стоимости, рассчитанной с учетом скидок на товар и скидок по накопительной программе:

Таким образом:

  • товар Пантолеты Кости на Пляже имеет стоимость: 836,07 руб. - 0,05*836,07 руб. = (899 - 0,07*899) руб. - 0,05*(899 - 0,07*899) руб. = 899 руб. - 0,1165*899 руб. = 794,27 руб., а суммарная величина скидки составила 11,65%;
  • товар Нижнее белье Розовое Смущенье имеет стоимость: 1079,1 руб. - 0,05*1079,1 руб. = (1199 - 0,1*1199) руб. - 0,05*(1199 - 0,1*1199) руб. = 1199 руб. - 0,145*1199 руб. = 1025,15 руб., а суммарная величина скидки составила 14,5%;
  • товар Спортивный Костюм Нежная Теплота имеет стоимость: 2213,5 руб. - 0,05*2213,5 руб. = (2330 - 0,05*2330) руб. - 0,05*(2330 - 0,05*2330) руб. = 2330 руб. - 0,0975*2330 руб.= 2102,83 руб., а суммарная величина скидки составила 9,75%.


Настройка магазина
57 / 254

Приведем перечень данных, которые необходимо последовательно ввести в магазине. Подробнее каждый из этапов будет рассмотрен далее.

  1. типы плательщиков;
  2. группы свойств заказов;
  3. свойства заказов;
  4. местоположения;
  5. необязательно: настройка групп местоположений (объединение местоположений в группы служит для облегчения работы с настройкой служб доставки);
  6. типы цен;
  7. службы доставки;
  8. настройка платежных систем;
  9. настройка статусов заказов; статусы заказа отражают этапы, через которые проходит заказ во время обработки. Они служат для информирования клиентов и сотрудников электронного магазина о текущем состоянии заказа;
  10. настройка печатных форм;
  11. необязательно: добавление наценок и скидок на заказ;
  12. необязательно: добавление налогов;
  13. необязательно: добавление единиц измерения;
  14. необязательно: настройка аффилиатства.

Часть данных (например, Типы плательщиков) можно использовать из дистрибутива, следует только изменить привязку. Часть данных нужно создавать заново.

Примечание: Про настройку интеграции магазина с 1С читайте в уроке Форма Интеграция с 1С главы Интеграция с 1С.

Дополнительная информация

  • Настройки интернет-магазина (документация)


Мастер магазина
58 / 254

Мастер магазина - инструмент помощи для владельца магазина в настройке и подготовке магазина к работе.

Стандартный функционал "1С-Битрикс: Управление сайтом" позволяет организовать работу интернет-магазина непосредственно "из коробки", то есть после установки сайта на хостинг. Но это не значит, что интернет-магазин не нужно настраивать. Для быстрой и в нужном порядке настройки магазина воспользуйтесь Мастером магазина (Магазин > Настройки > Мастер магазина).

Структура мастера

Мастер состоит из:

  • 1 - индикатор Общий прогресс - визуальное отслеживание общего уровня выполнения заданий.
  • 2 - название раздела Мастера.
  • 3 - индикатор выполнения заданий раздела.
  • 4 - блок заданий.
  • 5 - выполненное задание.
  • 6 - невыполненное задание.
  • 7 - развилка в пути выполнения заданий.
  • 8 - локальный индикатор выполнения для блока заданий.

Выполнение заданий по порядку обеспечит правильный порядок настройки магазина. В ситуациях, когда настройка предполагает разные варианты настройки в Мастере появляется развилка, позволяющая выбрать тот или иной путь. Например, будет магазин интегрирован с 1С: Предприятие или нет.

В Мастере все виды настроек разнесены по трём разделам:

  • Настройки интернет-магазина, без которых он не сможет работать - минимально необходимый уровень настроек, чтобы магазин вообще заработал.
  • Интернет-магазин открыт, обработка заказов, повседневная работа - настройка и оптимизация текущей деятельности по работе магазина.
  • Обслуживание интернет-магазина, следим за его здоровьем - настройка и контроль за техническим состоянием сайта и магазина.

Выполнение всех пунктов первого раздела - обязательно, второго - желательно. Третьего - по необходимости и с пониманием того, что делается. (Третий раздел - технический и требует соответствующих знаний в целом ряде настроек, лучше обратиться к партнёрам компании "1С-Битрикс: Управление сайтом".)

Выполнение заданий Мастера

Для выполнения заданий Мастера нужно просто кликнуть на нужный пункт. Это действие переместит вас на страницу настроек выбранного пункта Мастера:

В правом верхнем углу страницы будет выведено:

  • задание, что нужно сделать, чтобы произвести необходимые настройки,
  • кнопка вызова окна документации,
  • кнопка отметки о выполнении задания.

Окно Документация

Окно Документация предоставит минимально необходимую информацию для выполнения задания по настройке магазина. На некоторых страницах есть видео, описывающее процесс настройки. Для получения более детальной информации по теме в самом низу окна добавлены ссылки на необходимые страницы учебных курсов.

Примечание: Не забывайте оценивать окно Документации, это поможет компании "1С-Битрикс: Управление сайтом" сделать её лучше.

Техническая поддержка

Непосредственно из Мастера можно составить обращение в техподдержку 1С-Битрикс и партнёра, разрабатывавшего вам магазин. Эта возможность доступна в самом последнем блоке: Техническая поддержка вашего интернет бизнеса.

Разработчикам: Внести свои данные в этот раздел можно на странице настроек модуля Мастер магазина.


Типы плательщиков
59 / 254

В продукте есть возможность создавать свои и редактировать имеющиеся типы плательщиков (по умолчанию в системе созданы 2 типа плательщиков: физическое и юридическое лицо). В результате в публичном разделе сайта при оформлении заказа на первом шаге пользователю предлагается выбрать тип плательщика, к которому он себя относит:

Тип плательщика - способ разделить покупателей. Необходим в силу применения различных законодательных норм к покупателям разных видов.

К каждому типу плательщика привязаны собственные свойства для заполнения при заказе и собственные обработчики платежных систем. На основании выбора типа плательщика пользователю предоставляется соответствующий набор полей для заполнения свойств заказа и соответствующий набор интерфейсов платежных систем для оплаты заказа. Тип плательщика зависит от сайта. Для разных сайтов может быть создан свой набор типов плательщиков.

Внимание! К Типу плательщика привязываются Платежные системы и Свойства заказа. Если в работе магазина возможны Платежные системы или Свойства заказа, зависящие от Типа плательщика (например: резидент, не резидент), то необходимо создавать несколько Типов плательщиков.

Управление типами плательщиков осуществляется на странице Тип плательщика (Магазин > Настройки магазина > Типы плательщиков):

Для создания нового типа плательщиков служит кнопка Добавить тип, расположенная на контекстной панели. Переход к редактированию существующей записи осуществляется с помощью меню действий (пункт Изменить) либо с помощью двойного клика по соответствующей записи.

Форма создания (редактирования) типа плательщика имеет следующий вид:

После нажатия кнопки Сохранить созданный тип плательщика будет добавлен в общий список. Для каждого типа плательщика в этом списке указано определенное количество свойств – это свойства заказа, которые создаются в привязке к типу плательщика.

Примечание: Тип плательщика можно не создавать, а перепривязать существующие в дистрибутиве.


Группы свойств
60 / 254

Группа свойств - сущность для более удобного управления свойствами заказа.

Настройка групп свойств

Перед тем, как добавлять свойства, необходимо продумать Группы, в которые эти свойства будут объединены. Данная группировка применяется при построении формы для ввода значений свойств заказа в публичном разделе, что позволяет улучшить ее зрительное восприятие.

Показ группы свойств в форме заказа зависит от типа плательщика, выбранного покупателем, т.е. для каждого типа плательщика создается самостоятельный набор групп свойств. Например, для типа плательщика юридическое лицо создана группа свойств Данные компании, в этой группе заданы 4 свойства, которые и предлагаются для заполнения пользователю при оформлении заказа в публичном разделе:

Управление группами свойств осуществляется в административном разделе на странице Группы свойств (Магазин > Настройки магазина > Свойства заказа > Группы свойств):

Для создания новой группы свойств служит кнопка Новая группа, расположенная на контекстной панели. Переход к редактированию существующей записи осуществляется с помощью меню действий (пункт Изменить группу) либо с помощью двойного клика по соответствующей записи.

Форма создания (редактирования) группы свойств имеет следующий вид:

Теперь, когда группа создана, можно переходить к созданию ее свойств.


Свойства заказов
61 / 254

Свойства заказа - это значения заказа, которые должны быть указаны клиентом интернет-магазина при оформлении заказа. Они различаются по типам плательщиков: свойства заказов для физических и свойства для заказов юридических лиц.

Добавим в качестве примера свойство Местоположение для типа плательщика Физическое лицо. Для этого перейдите на страницу Магазин > Настройки магазина > Свойства заказа > Список свойств и нажмите кнопку Новое свойство, расположенную на контекстной панели. В выпадающем списке выберете тип плательщика Физическое лицо, т.е. свойства заказа задаются в привязке к типу плательщика:

Откроется форма добавления свойства заказа, состоящая из двух закладок: Свойства заказа и Привязка свойства.

Отметим некоторые особенности заполнения полей закладки Свойства заказа:

  • В поле Название задается название свойства, как оно будет показано клиенту магазина при оформлении заказа.
  • В поле Тип из выпадающего списка необходимо выбрать одно из значений:

  • Поле Обязательное определяет, обязательно ли поле к заполнению в публичном разделе.

    Обратите внимание, независимо от значения данного поля свойства с установленными флажками Использовать как... обязательны к заполнению в публичном разделе.

  • В поле Сортировка задается относительный "вес" свойства заказа. Используется при выводе данного свойства в общем списке свойств заказа в публичном разделе.
  • Установка опции Входит в профиль позволяет включить свойство в профиль пользователя.

    Профиль пользователя – это набор свойств, которые, будучи однажды введенными, запоминаются и предлагаются к использованию при последующих заказах. То есть, если клиент уже делал заказы в магазине, то ему необязательно будет при оформлении очередного заказа заполнять свойства, входящие в его профиль. Клиент сможет выбрать один из сохраненных профилей для автоматического заполнения свойств заказа.

    Клиент может редактировать свои профили в персональном разделе сайта.

  • В выпадающем списке Группа свойств можно выбрать одну из групп свойств данного типа плательщика. А по ссылке Группы свойств в новом окне откроется страница со всеми группами свойств, заданными в системе.
  • Использовать как местоположение - значение свойства будет использовано как местоположение покупателя для расчета стоимости доставки. Этот флажок можно отметить только у свойств типа LOCATION.

    Внимание! Введите по одному свойству с флагом Использовать как местоположение для каждого типа плательщика, иначе система обработки служб доставки работать не будет.

  • Использовать как местоположение для налогов – значение свойства будет использовано как местоположение покупателя для определения ставок налогов. Этот флажок можно отметить только у свойств типа LOCATION.

    Внимание! Введите по одному свойству с флагом Использовать как местоположение для налогов для каждого типа плательщика, иначе ставки налогов определены не будут.

Рассмотрим оставшиеся опции первой закладки формы редактирования свойства заказа:

  • Использовать как почтовый индекс – значение свойства будет использовано как почтовый индекс покупателя для расчета стоимости доставки.
  • Использовать как E-mail – значение свойства будет использовано как E-Mail при регистрации нового пользователя.
  • Использовать как название профиля – значение свойства будет использовано как название профиля пользователя.

    Если свойство с флагом Использовать как название профиля для данного типа плательщика введено не будет, то новые профили будут называться как Профиль <дата>. Названием профиля может стать, например, свойство Контактное лицо.

  • Использовать как имя плательщика – значением свойства будет являться имя плательщика, которое будет проставляться в платежных документах.

На закладке Привязка свойства настраивается связь свойства с необходимыми платежными системами и службами доставки:

Дополнительная информация

  • Свойства заказа (документация)


Местоположения
62 / 254

Местоположение - географическая единица, имеющая единые условия доставки заказа и определяющая часть полного адреса доставки.

В данной главе описана работа с местоположениями старой схемы, которые доступны в более ранних версиях системы (версия модуля Интернет-магазин ниже, чем 14.10.1), либо в системе не осуществлялся переход на местоположения 2.0.


Местоположения
63 / 254
  • Настройка местоположений
  • Загрузка местоположений

Особую роль при создании Служб доставки имеет указание Местоположений, в которые данная служба доставляет товары на указанных условиях.

Настройка местоположений

Страница Местоположения (Магазин > Местоположения > Список местоположений) служит для настройки списка местоположений, из которого клиент магазина будет выбирать место для доставки заказа. Затем выбранное место будет использовано при выводе списка доступных служб доставки, расчете стоимости доставки, а также в качестве части фактического адреса доставки.

Местоположением является сочетание Страна - Регион - Город. Кроме того, необходимо предусмотреть для каждой страны местоположение без указания региона и города, которое будет использоваться в тех случаях, когда подходящего сочетания Страна - Регион - Город для данного клиента нет.

Добавим новое местоположение. Закладка Местоположение состоит из трех частей:

  • В секции Страна указывается информация о стране на всех языках, определенных в системе.

    Если необходимо создать новую страну, то в выпадающем списке Выберите страну кликните пункт Новая страна и заполните полные и краткие наименования страны для всех языков системы.

    При редактировании существующей страны в секции Выберите страну отображается опция Изменить текущую страну, с помощью которой становятся доступными для изменения поля полных и кратких наименований.
  • в секции Регион/Штат/Провинция укажите Без региона, если вам нужно указать страну без него:

    Если же вы вводите новый регион, то необходимо заполнить полные и краткие наименования для всех языков, определенных в системе.

  • В секции Город отметьте опцию Без города, если вам необходимо ввести страну без города.

    Если же вы вводите новый город, то необходимо заполнить полные и краткие наименования для всех языков, определенных в системе.

На закладке Индексы можно добавить почтовые индексы для данного местоположения.

Загрузка местоположений

Заполнять вручную большое количество местоположений трудоемко, поэтому в системе предусмотрена возможность импорта местоположений на странице Импорт местоположений ( Магазин > Настройки магазина > Местоположения > Импорт местоположений).

Загрузку местоположений в систему можно выполнить одним из двух способов:

  1. Используя мастер импорта местоположений, который запускается с помощью расположенной на закладке Импорт кнопки Запустить мастер импорта местоположений. Последовательно за несколько шагов с помощью мастера производятся следующие действия:

    • На втором шаге выбирается загружаемый файл местоположений:

      При выборе файла Россия и СНГ можно отметить, загружать ли почтовые индексы или ZIP-коды. Также можно выбрать, синхронизировать ли загружаемые данные с имеющимися или удалить прежние данные.
    • На следующем шаге указывается длительность шага загрузки (по умолчанию 20 сек).
    • Затем производится загрузка требуемых файлов.
    • Далее происходит обработка загруженных данных. В конце выводится статистика базы данных местоположений и индексов.

    Примечание: кроме того, мастер импорта местоположений может быть запущен со страницы Список мастеров (Настройки > Настройки продукта > Список мастеров):

  2. С помощью импорта местоположений из файла (флаг Загрузить из файла второго шага формы импорта местоположений):

    С помощью кнопки Обзор вы можете выбрать необходимый файл на локальном компьютере. Старые местоположения могут быть удалены автоматически с помощью флага Удалить прежние данные.

    Обратите внимание! В этом случае местоположения будут удалены, даже если они фигурируют в адресах существующих заказов.

    Приведем пример файла для загрузки местоположений:

    en
S,en,Russian Federation,ru,Россия
T,en,Moscow,ru,Москва
T,en,Kaliningrad,ru,Калининград
S,en,Ukraine,ru,Украина
T,en,Kiev,ru,Киев
S,en,Estonia,ru,Эстония

    В первой строке указывается язык, например, en – английский, названия на котором будут отображаться в административной части.

    В остальных строках файла указываются загружаемые данные. Сначала указывается страна (строка начинается с "S"), потом все города этой страны (строки начинаются с "T"), потом следующая страна и т.д.

    Названия должны быть указаны для всех языков. Если какие-либо из языков не существуют в системе, то они будут проигнорированы.

    Если загружаемая страна уже присутствует в системе, то она не будет загружена повторно, а будет использована существующая запись. Города загружаются всегда, вне зависимости от присутствия подобных названий в системе. Краткое наименование заполнено в этом случае не будет.

Итак, в дальнейшем имеющиеся местоположения будут использоваться при настройке свойств заказа с типом Location и служб доставки.

Дополнительная информация

  • Местоположения (документация)


Группы местоположений
64 / 254

Настройка групп местоположений

Объединение в Группы местоположений служит для облегчения работы с настройкой служб доставки. Вы можете создать группу местоположений и привязать к ней все службы доставки, которые осуществляют доставку в местоположения этой группы.

Управление Группами местоположений осуществляется на странице Магазин > Настройки магазина > Местоположения > Группы местоположений.

При появлении нового местоположения или изменения тарифов по какому-либо из существующих местоположений будет достаточно добавить или удалить это местоположение из группы. Изменять каждую из служб доставки, к которым имеет отношение это местоположение, не нужно.

Создадим новую группу местоположений, включив в нее некоторые республики бывшего СССР:

После загрузки местоположений и создания групп местоположений (если это требуется) можно приступать к настройке служб доставки.


Переход на местоположения 2.0
65 / 254

Переход на местоположения 2.0 возможен, начиная с версии 14.10.1 модуля Интернет-магазин. Для этого в системе доступна специальная страница Переход на местоположения 2.0 (Магазин > Настройки > Местоположения > Переход на местоположения 2.0):

По кнопке Выполнить переход осуществляется конвертация старой схемы местоположений на новую. После конвертации магазин продолжит работать, используя старую базу местоположений, но уже по новой схеме.


Местоположения 2.0
66 / 254

Местоположение - географическая единица, имеющая единые условия доставки заказа и определяющая часть полного адреса доставки.

В данной главе описан функционал местоположений, доступных с версии 14.10.1 модуля Интернет-магазин.


Местоположения
67 / 254

Управление общим списком местоположений осуществляется на странице Настройки > Местоположения > Список местоположений:

Чтобы перейти к управлению дочерними местоположениями некоторого конкретного местоположения, следует дважды кликнуть по нему в таблице со списком местоположений или выбрать его в дереве местоположений:

Важно! Количество уровней вложенности местоположений не ограничено.

Форма создания (редактирования) местоположения имеет следующий вид:

Рассмотрим параметры, которые задаются на закладке Местоположение:

Примечание: подробное описание полей формы представлено в документации по продукту.

  • для местоположения обязательно указываются символьный код и тип местоположения (необходимый тип местоположения должен быть создан заранее);
  • если местоположение является дочерним по отношению к некоторому местоположению, то необходимо указать родительское местоположение;

    Примечание: интерфейс выбора родительского местоположения зависит от значения параметра Тип виджета местоположений в настройках модуля Интернет-магазин.
  • если магазин в своей работе использует геоданные, то необходимо указать широту и долготу местоположения;
  • название местоположения указывается на всех языках интерфейса.

На закладке Внешние данные указываются коды внешних сервисов (например, почтовый индекс и/или код Яндекс.Маркета) для данного местоположения:

Примечание: необходимые внешние сервисы должны быть созданы заранее.


Группы местоположений
68 / 254

Объединение местоположений в группы служит для облегчения работы с местоположениями сайта и с настройкой служб доставки. Вы можете создать группу местоположений и указать ее во всех службах доставки, которые осуществляют доставку в местоположения этой группы.

Управление Группами местоположений осуществляется на странице Магазин > Настройки магазина > Местоположения > Группы местоположений.

При появлении нового местоположения или изменения тарифов по какому-либо из существующих местоположений будет достаточно добавить или удалить это местоположение из группы. Изменять каждую из служб доставки, к которым имеет отношение это местоположение, не нужно.

Создадим новую группу местоположений, включив, например, в нее страны Балтии. В форме создания группы в первую очередь обязательно указываем символьный код и названия группы на всех языках интерфейса:

Затем в секции Выбор местоположений выбираем местоположения, которые должны быть включены в группу:

В группу будут входить только те местоположения, которые отображаются в разделе Выбранные местоположения. Поэтому, чтобы добавить местоположения в группу, в разделе Доступные местоположения следует найти требуемые местоположения с помощью строки поиска (1) или с помощью дерева местоположений (2), отметить их флагом (3) и нажать кнопку (4).

Примечание: соответственно для исключения местоположения из группы служит кнопка (5).

Когда все местоположения добавлены, сохраняем группу. Теперь группу можно использовать как при настройке местоположений для сайта, так и служб доставки.


Местоположения для сайтов
69 / 254

Новая схема местоположений позволяет загружать любые местоположения и выбирать среди них только те, с которыми будет работать конкретный сайт, что особенно удобно для многосайтовых систем.

Настройка списка местоположений для конкретного сайта выполняется на странице Настройки > Местоположения > Местоположения для сайтов.

В форме выбора местоположений для конкретного сайта указываем местоположения или группы местоположений, которые должны быть к нему привязаны:

  • находим требуемые местоположения с помощью строки поиска (1) или с помощью дерева местоположений (2);
  • отмечаем флагом группы (3) и/или найденные местоположения (4);
  • нажимаем кнопку (5).

В результате на сайте будут использоваться только те местоположения и/или группы, которые отображаются в разделе Выбранные местоположения (6). Соответственно, чтобы убрать местоположение из списка выбранных, нужно отметить его в списке (6) и нажать на кнопку (7).

Примечание: если для сайта не выбрано ни одно местоположение, то сайт будет работать со всеми загруженными в систему местоположениями.


Избранные местоположения
70 / 254

Для более удобного оформления заказов вы можете настраивать избранные местоположения, например, на основе наиболее часто используемых покупателями. Управление избранными местоположениями осуществляется на странице Магазин > Настройки > Местоположения > Избранные местоположения, где для каждого сайта системы формируется собственный список:

В форме выбора местоположений задаются местоположения, которые необходимо добавить в избранные. При этом обратите внимание, что интерфейс выбора местоположений зависит от значения параметра Тип виджета местоположений в настройках модуля Интернет-магазин:

Примечание: для упорядочивания местоположений при выводе используется соответствующий им индекс сортировки.

Таким образом, при оформлении заказа покупатель сможет быстро указывать необходимое ему местоположение, выбирая его из списка избранных:

В результате выбранное местоположение и индекс (если он задан для местоположения в системе) подставятся автоматически в одноименные поля.

Примечание: при работе с заказами в административном разделе сайта также доступны избранные местоположения:


Типы местоположений
71 / 254

Местоположения старой схемы позволяли использовать только структуру вида: Страна > Область > Регион > Город, а для местоположений 2.0 уровень вложенности не ограничен. Управление уровнями вложенности осуществляется путем настройки необходимых типов местоположений на странице Магазин > Настройки > Местоположения > Типы местоположений:

Примечание: необходимые типы местоположений создаются автоматически при конвертации базы местоположений на новую схему и при импорте местоположений с удаленного сервера в систему.

Создадим, например, тип местоположения Улица. В форме создания (редактирования) типа обязательно указываем символьный код, названия для всех языков интерфейса и задаем индекс сортировки для определения положения нового типа в списке:

В результате в систему можно добавлять местоположения нового типа:


Внешние сервисы
72 / 254

Управление внешними сервисами, необходимых для работы с кодами местоположений, осуществляется на странице Магазин > Настройки > Местоположения > Внешние сервисы:

При создании (редактировании) внешнего сервиса необходимо указать только его код:


Импорт местоположений
73 / 254

Загрузка местоположений в систему, а также очистка существующих выполняется на странице Настройки > Местоположения > Импорт местоположений.

На закладке Импорт местоположений осуществляется импорт местоположений в систему в соответствии с заданными параметрами:

  • Источник местоположений - выбирается источник загрузки местоположений: с удаленного сервера или из файла.

    При загрузке местоположений с сервера необходимо отметить нужные вам страны, области и/или регионы для загрузки.

    Примечание: для местоположений 2.0 на сервере хранится отдельная обновленная база, отличная от базы местоположений старой схемы. Причем серьезно расширена база для России (местоположения можно загружать вплоть до улиц).

    При загрузке местоположений из файла следует с помощью кнопки Добавить файл указать файл с данными, а также заранее вручную создать необходимые типы местоположений и внешние сервисы.
  • Почтовые индексы (ZIP-коды) - при отмеченной опции автоматически для местоположений будут заполнены почтовые индексы.

    Примечание: на данный момент индексы загружаются только для России (используется база данных ФИАС).
  • Коды Яндекс.Маркет - при отмеченной опции для местоположений будут заполнены коды Яндекс.Маркет, которые нужны при интеграции с Яндекс.Маркетом и расширяют возможности по доставке.
  • Загружать местоположения до - выбирается до какого типа местоположений (включительно) осуществлять загрузку данных.

    Примечание: загрузка до улиц возможна только для России.
  • Набор местоположений - выбирается набор местоположений, который нужно загрузить: стандартный (только крупные регионы и города) или расширенный (полный импорт с учетом мелким городов, сел и т.д.).
  • Не загружать округа - при отмеченной опции местоположения типа Округ не будут загружаться в систему. Таким образом, местоложения типа Область будут дочерними непосредственно для местоположений типа Страна.
  • Удалить все существующие местоположения - при отмеченной опции будут удалены все существующие местоположения в системе.

    Обратите внимание! В этом случае местоположения будут удалены, даже если они фигурируют в адресах существующих заказов.
  • Длина шага, секунды - указывается длина одного шага в секундах.
  • Поддерживать структурную целостность - при отмеченной опции будет поддерживаться структурная целостность местоположений. Таким образом, если некоторое местоположение А уже есть в системе, а затем импортируется более крупное по отношению к нему местоположение Б, то автоматически имеющееся местоположение А будет привязано к новому местоположению Б.

Запуск процесса импорта осуществляется по кнопке Начать импорт.

Важно! Загрузка местоположений - это достаточно длительный процесс, который в зависимости от количества загружаемых данных и мощности вашего хостинга может занять от нескольких минут до нескольких часов. Поэтому импорт данных рекомендуется выполнять в период минимальной нагрузки на сервер.

На закладке Очистить список местоположений выполняется очистка всех имеющихся в системе местоположений:

Важно! Не рекомендуется очищать местоположения на рабочем проекте. Будут удалены все местоположения, даже если они фигурируют в адресах существующих заказов.


Переиндексация поиска местоположений
74 / 254

Начиная с версии 14.11.9 модуля Интернет-магазин, для поиска местоположений при помощи строки ввода доступен новый алгоритм: поиск местоположения будет осуществляться по начальной части любого слова, которое входит в название местоположения:

В более ранних версиях модуля поиск осуществлялся только по начальной части всего названия местоположения (т.е. переставлять слова местами нельзя было):

Примечание: алгоритм поиска не используется, если выбор местоположений осуществляется при помощи выпадающих списков (см. значение параметра Тип виджета местоположений в настройках модуля Интернет-магазин).

Чтобы поиск работал по новому алгоритму, необходимо переиндексировать список местоположений. Создание индексов для местоположений выполняется на странице Магазин > Настройки > Местоположения > Переиндексация поиска:

В форме указывается для каких типов местоположений, а также по какому языку интерфейса должны быть созданы индексы. Кроме того, задается длина одного шага индексации. Запуск процесса создания индексов осуществляется по кнопке Начать переиндексацию.

Важно! Процесс переиндексации при наличии большой базы местоположений может занять продолжительное время в зависимости от настроек вашего сайта и мощности хостинга. Поэтому рекомендуется осуществлять запуск в период минимальной нагрузки на сервер.

При добавлении новых местоположений, а также при редактировании существующих имеющийся поисковый индекс утрачивает свою актуальность. Его необходимо будет пересоздать заново. В данной ситуации на странице просмотра списка местоположений будет отображаться соответствующая надпись:


Наценки
75 / 254
Наценки - заранее установленная величина в относительном выражении (например, в процентах), на которую уменьшается или увеличивается цена товара. Наценки применяются к базовой цене при расчете других типов цен товара (базовую цену сменить невозможно). Каждая цена будет считаться по формуле:

[Цена]=[Базовая цена]+[Базовая цена]*[Наценка в процентах/100]

Важно понимать, где применять в системе понятия Типов цен и Наценок:

  • Типы цен - для разных групп покупателей.
  • Наценки - для легкости смены цен на всех товарах.

В то же время наценка может быть представлена как положительной, так и отрицательной величиной.

Важно! При указании отрицательной наценки после знака минуса пробел ставить НЕ нужно.

Перейдите на страницу Магазин > Настройки > Наценки. Создадим следующие наценки:

  • Без скидки (Without discount) - величина данной наценки будет равна 0%:

  • Дилерская скидка (Dealer discount) - величина данной наценки будет равна -18,5%:

Важно! При указании дробного значения наценки разделитель зависит от используемой базы данных, при возникающих проблемах обратитесь к администратору базы данных.

Созданные наценки будут добавлены в общий список типов наценок на странице Наценки:

Возможно изменение параметров какой-либо наценки, которая появляется в форме редактирования. При открытии Наценки на редактирование после введения новой ставки наценки используйте чекбокс Пересчитать цены:

После сохранения новой величины наценки произойдёт автоматическое изменение цены для всех товаров, у которых применена эта наценка.

Если вы не применяете наценки (например, выводите сразу базовую цену или у вас типы цен прописаны вручную), то вам эта опция не потребуется.

По опыту работы партнеров, даже в самом простом случае рекомендуется делать базовый тип цен и тип цен "для продажи" и на последний ставить наценку 0%, которую всегда можно поменять и пересчитать цены с помощью одноимённой опции.


Покупки на Маркете
76 / 254

Начиная с версии 14.0.1 модуля Интернет-магазин, в продукте доступна настройка вашего магазина на участие в программе Покупка на Маркете. Таким образом, пользователи смогут заказывать ваши товары непосредственно на Яндекс.Маркете.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Интеграция с Яндекс.Маркет

В первую очередь необходимо стать участником программы.

Примечание: в настройках на Яндекс.Маркете в качестве URL API необходимо указать https://ваш_сайт/bitrix/services/ymarket/

После заключения договора с Яндексом можно приступать к настройкам внутри системы.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Продажи на Яндекс.Маркет

В административном разделе продукта перейдите на страницу Настройка "Покупка на маркете" (Магазин > Настройки > Покупки на Маркете). По умолчанию интеграция с Яндекс.Маркетом отключена:

Для включения нажмите кнопку Включить и на странице отобразятся настройки программы Покупка на Маркете. В соответствующих полях первой группы настроек укажите параметры, которые вы получите при подписании договора и регистрации приложения: идентификатор компании, токены для запросов Яндекса к магазину и от магазина к Яндексу, идентификатор приложения:

URL ресурса партнерского API Яндекс.Маркета - aдрес, на который магазин должен отправлять свои запросы к Яндекс.Маркету, уже задан и его оставьте без изменений.

Примечание: описание API запросов от магазина к Яндекс.Маркету доступно в руководстве разработчика Яндекс.Маркетa.

В поле Логин пользователя укажите логин, который вы использовали в сервисе Яндекс.Маркет при регистрации магазина. В поле Тип плательщика для заказов выберите необходимый вам тип плательщиков, который будет использоваться при оформлении заказов. Кроме того, в соответствующих полях выберите необходимый тип авторизации, задайте необходимый вам уровень журналирования событий работы программы и укажите (при наличии) идентификаторы пунктов самовывоза:

Примечание: все события работы программы Покупки на Маркете вы можете смотреть на странице Журнал событий (Настройки > Инструменты > Журнал событий).

Поскольку для работы программы ваш сервер должен быть доступен по протоколу HTTPS, то проверить эту возможность можно сразу в процессе выполнения настроек с помощью кнопки Проверить, расположенной в поле Проверка HTTPS.

В секции Способы оплаты укажите какие из платежных систем, доступных в вашем магазине, будут использоваться при предоплате через Яндекс, напрямую магазину, наличном расчете и оплате банковской картой при получении заказа:

Примечание: при использовании статуса UNPAID в качестве предоплаты через Яндекс должна использоваться платежная система Предоплата через Яндекс (новый обработчик Предоплата через Яндекс доступен с версии 14.5.9).

В секции Службы доставки определите какие из ваших служб будут использоваться и какой тип служб Яндекс.Маркета (курьерская доставка или самовывоз) им будет соответствовать:

В секции Статусы принимаемые от Яндекс-Маркета магазином укажите какие статусы Яндекс.Маркета будут использоваться и каким статусам магазина они будут соответствовать:

В секции Статусы отправляемые магазином в Яндекс-Маркет укажите какие статусы вашего магазина будут использоваться в Яндекс.Маркете и каким статусам Яндекс.Маркета они будут соответствовать:

В секции Настройка соответствия свойств заказа укажите какие свойства заказа соответствуют указанной информации, необходимой для создания заказов:

Не забудьте сохранить заданные настройки программы Покупка на Маркете.

Примечание: подробное описание каждого поля данной формы представлено в документации.

Важно! Для корректной интеграции с Яндекс.Маркетом необходимо, чтобы при тестировании конфигурации вашего сайта успешно выполнялся тест HTTP авторизация (Настройки > Инструменты > Проверка системы, закладка Тестирование конфигурации).

Ссылки по теме:

  • Статья о настройках и проведении тестирования через интерфейс Яндекс.Маркета


Типы цен
77 / 254
Типы цен - типы цен товара. Например, оптовая, розничная, цена за эксклюзивную покупку и т.д.

Кроме того, в системе применяется особый тип цены, используемый для формирования остальных типов цен - базовый тип. Она не обязательно должна быть равной закупочной или розничной, или оптовой, но может использоваться в качестве таковых.

Внимание! Базовая цена – основа для расчетов остальных цен. Этот тип должен присутствовать обязательно. (Либо один тип цен был отмечен как базовый.)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Настройка цен

Создадим тип цен, по которому будет выполняться продажа товара. Перейдите на страницу Магазин > Настройки > Типы цен.

Создадим розничный тип цен. Право на просмотр и покупку по ценам данного типа будет доступно всем посетителям сайта:

Созданный тип будет добавлен в общий список на странице Типы цен.

Дополнительная информация

  • Создание и редактирование типа цены (документация)


Службы доставки
78 / 254

Служба доставки - функционал, позволяющий обсчитать стоимость доставки заказа.

Службы доставки товаров позволяют:

  • указывать сроки доставки;
  • регламентировать вес заказа и его стоимость, при котором возможен выбор данной службы доставки;
  • указывать стоимость доставки и возможные для нее платежные системы;
  • определять положение имеющихся служб доставки в списке в публичном разделе сайта.

Существует два типа служб доставки: автоматизированные и настраиваемые. Разница в этих службах в том, что в автоматизированных службах доставки расчет стоимости доставки происходит не на вашем сайте, а на серверах этих служб, и вы не можете влиять на стоимость доставки. Единственное, что можно сделать - это осуществить наценку на стоимость доставки. Как правило, автоматизированные службы доставки - это внешние системы международной или междугородней доставки типа DHL или Почты России.

Службы доставки можно использовать из дистрибутива, просто задав привязку у штатных записей.

Список служб находится на страницах:

  • Настраиваемые: Магазин > Настройки магазина > Службы доставки > Настраиваемые
  • Автоматизированные: Магазин > Настройки магазина > Службы доставки > Автоматизированные

Создание и настройка настраиваемых служб доставки не должно вызвать затруднений, значения полей ясны из их названий. Служба может зависеть от общего веса и стоимости заказа и всегда зависит от списка местоположений.

Примечание: поля Местоположение и Группа местоположений для Настраиваемых служб доставки выделены полужирным шрифтом как обязательные для заполнения. Это значит, что нужно обязательно заполнить одно из них, а при необходимости можно выделить пункты в обоих полях.

Создание и настройка автоматизированных служб доставки возможно только при введенном адресе и местоположении магазина. О том, что данные не введены, будет выводиться соответствующее предупреждение:

Ссылка Изменить служит для перехода на закладку Адрес магазина формы настроек модуля, чтобы ввести необходимые данные.

Автоматизированные службы доставки представляют собой системные службы, которые созданы в ядре продукта. Ими можно пользоваться в неизменном виде. Если требуется внести изменения, необходимо скопировать нужную службу в каталог /bitrix/php_interface/include/sale_delivery/ и произвести модификацию там. Настройки каждой автоматизированной службы индивидуальны.

Для создания собственной службы доставки необходимо создать собственный обработчик и разместить его в папке /bitrix/php_interface/include/sale_delivery/***.php. После этого он станет доступен для настройки в общем списке.

Удостоверьтесь, что службы доставки покрывают все возможные варианты стоимостей заказов. Например, если вы указали, что данная служба доставки действует для заказов стоимостью более 500 рублей, то удостоверьтесь, что для тех же местоположений есть службы доставки, которые действуют для заказов стоимостью менее 500 рублей.

Также убедитесь, что созданы службы доставки для всех возможных местоположений.

Внимание! Для каждого типа плательщика должно быть введено по одному свойству заказа с флагом Использовать как местоположение, иначе система обработки служб доставки работать не будет. Такой флаг можно установить только у свойств типа Location.

Местоположение, указанное пользователем в этом свойстве при оформлении заказа, будет проверено на принадлежность местоположениям, отмеченным в службах доставки. Также будет проверено соответствие остальным категориям (вес, стоимость заказа и т.д.) и после этого будет выбрана определенная служба доставки. Если несколько служб удовлетворяют условиям, то они будут предложены пользователю на выбор.

Дополнительная информация

  • Службы доставки (документация)


Платежные системы
79 / 254

Платежные системы - способы оплаты за товары в интернет-магазине.

Под платежными системами понимаются любые способы оплаты заказа: как платежные системы, принимающие платежи online, так и банковские переводы. В системе может быть создано любое их количество. Управление платежными системами осуществляется на странице Платежные системы (Магазин > Настройки магазина > Платежные системы).

  • Создание платежной системы
  • Обработка платежных систем
  • Типичные обработчики
  • Результаты обработки
    •

    Создание платежной системы

    Рассмотрим особенности добавления платежной системы. Для этого перейдите к форме создания платежной системы с помощью кнопки Добавить платежную систему, расположенной на контекстной панели. Форма добавления платежной системы может быть заполнена так:

    На первой закладке заполняются общие параметры платежной системы. На закладке Типы плательщиков определяются параметры использования данной платежной системы каждым типом плательщика, определенным в системе (каждому типу плательщика соответствует закладка с его названием). Например, оплата через Сбербанк доступна для типа плательщика Физическое лицо:

    На закладке <тип_плательщика> определяется:
    • Отметка в поле Применяется для данного типа плательщика определяет, будет ли для этого типа плательщика работать данная платежная система или нет;
    • Название платежной системы, отображаемое в публичном разделе сайта для данного типа плательщика;
    • Выбирается Обработчик платежей, осуществляемых с помощью данной платежной системы (об обработчиках платежных систем речь пойдет ниже);
    • Флаг в поле Открывать в новом окне означает, что если по результатам работы обработчика платежей пользователю должен быть представлен какой-либо результат (например, платежный документ), то он будет выведен в отдельном окне веб-браузера;
    • В поле Кодировка укажите кодировку, в которой работает сайт платежной системы, например: UTF-8. Кодировка платежной системы указывается в документации, которую получается от службы поддержки выбранной системы вместе с параметрами доступа к ней. В случае с наличными (cash) в это поле можно ничего не вводить, так как обработчик работает на стороне вашего магазина.
    • Секция Свойства обработчика. Если выбранный вами обработчик платежной системы требует задания значений дополнительных свойств, то в секции будет выведен список этих свойств.
      • Чтобы скрыть список свойств, воспользуйтесь ссылкой Свернуть свойства обработчика.
      • Чтобы раскрыть список свойств, воспользуйтесь ссылкой Развернуть свойства обработчика.

    На закладке Службы доставки выбираются службы, при выборе которых будет доступна данная платежная системы при оформлении заказа:

    Обработка платежных систем

    Разные платежные системы предлагают различные интерфейсы для интеграции (взаимодействия). Зачастую эти интерфейсы отличаются кардинально: например, интеграция с системой Payflow Pro требует выполнения запросов к платежной системе при помощи устанавливаемого на сервер SDK (Software Development Kit), а интеграция со Сбербанком требует распечатки квитанции Сбербанка.

    Обработчик платежных систем - php-скрипт, осуществляющий интеграцию интернет-магазина с платежными системами.

    Эти файлы создаются индивидуально для каждой платежной системы и вызываются непосредственно после оформления заказа, а также при выборе клиентом функции повторения платежа в персональном разделе. Файлы-обработчики могут содержать скрипт, отображающий на экране необходимый платежный документ, или форму для отправки данных электронной платежной системе.

    Общая методика работы с файлами-обработчиками такова:

    • Скопируйте необходимые вам шаблоны файлов-обработчиков из папки /bitrix/modules/sale/payment/ в папку /bitrix/php_interface/include/sale_payment/;

      Обратите внимание, папка /bitrix/php_interface/include/sale_payment/ не единственно возможная директория для хранения персональных обработчиков платежных систем. Можно использовать любую другую директорию, для этого ее необходимо указать в настройках модуля Интернет-магазин в поле Путь к пользовательским файлам-обработчикам платежных систем.

    • Измените файлы в папке /bitrix/php_interface/include/sale_payment/ таким образом, чтобы они удовлетворяли вашим нуждам и соответствовали интерфейсу соответствующих платежных систем. Типичные изменения, которые необходимо произвести в этих файлах: изменение тестовых номеров и паролей к платежным системам на реальные номера и пароли, полученные при регистрации в соответствующей платежной системе; добавление изображения оттиска печати и подписей к счету; изменение внешнего вида формы в соответствии с дизайном сайта и т.п.;
    • Добавьте файлы-обработчики с интерфейсами других платежных систем, если они нужны.

    Типичные обработчики

    • Типичным обработчиком для платежной системы, которая не осуществляет on-line платежи, является вывод на экран счета (или квитанции), готового к печати на принтере. Примерами таких обработчиков являются счет или квитанция перевода через Сбербанк.

      Такой обработчик обычно представляет собой файл, который выводит необходимое для данного документа форматирование и вставляет в соответствующих местах данные заказа.

      Пример такого обработчика можно посмотреть в шаблонах платежных систем сбербанка (/bitrix/modules/sale/payment/sberbank/payment.php) или банковского перевода (/bitrix/modules/sale/payment/bill/payment.php).

    • Типичным обработчиком для платежной системы, которая осуществляет платежи on-line, является вывод на экран HTML-формы, которая отправляет данные платежной системе. Примерами таких платежных систем являются Assist, AuthorizeNet, Payflow, WorldPay.

      Вид, набор полей и прочие параметры HTML-формы полностью зависят от платежной системы. Конкретное описание формы, которая требуется данной платежной системе, следует искать в документации по этой платежной системе.

      Пример такого обработчика можно посмотреть в шаблонах платежных систем Assist (/bitrix/modules/sale/payment/assist/payment.php), Paypal (/bitrix/modules/sale/payment/paypal/payment.php) и т.д.

      Как правило платежные системы с online платежами предоставляют один из двух (иногда оба) типов интерфейса для интеграции:

      1. форма с параметрами заказа отправляется на сайт платежной системы, где покупатель заполняет дополнительные формы (например, вводит номер пластиковой карты) и производит фактическую оплату;
      2. все параметры заполняются на сайте и формируется запрос к платежной системе, в ответе на который она сообщает результат оплаты.

    Первый тип интерфейса является наиболее простым для интеграции. В обработчике достаточно создать HTML-форму, которая будет отправлять данные на сайт платежной системы, и добавить в форму необходимые платежной системе поля. Конкретные параметры необходимо смотреть в системе помощи по данной платежной системе. Пример такого обработчика можно посмотреть в шаблоне платежной системы Assist (/bitrix/modules/sale/payment/assist/payment.php).

    Второй тип является более сложным для интеграции, но зато он является более гибким в плане возможностей. Пример такого обработчика можно посмотреть в шаблоне платежной системы AuthorizeNet (/bitrix/modules/sale/payment/authorizenet/).

    Результаты обработки

    Возможность автоматического получения результата и параметров оплаты заказа у электронной платежной системы зависит от конкретной платежной системы. Возможно использование трёх способов получения ответа от платежной системы:

    • Если платежная система позволяет запросить статус обработки заказа, то возможно создание файла получения результата. Такую возможность предоставляет, например, платежная система assist. В файле получения результата (обработки результата) необходимо с помощью скрипта запросить платежную систему о статусе и параметрах заданного заказа, а потом сохранить полученную информацию. Файл получения результата будет вызываться на команду Получить формы Заказы административного раздела сайта.

      Примером файла получения результата может служить файл получения результата от платежной системы assist: /bitrix/modules/sale/payment/assist/result.php;

    • Если платежная система возвращает результат сразу в ответ на запрос обработки заказа, то соответствующий код должен содержаться в файле pre_payment.php. Примером такого алгоритма может служить файл-обработчик платежной системы Payflow Pro: /bitrix/modules/sale/payment/payflow_pro/pre_payment.php.
    • Штатный компонент Подключение обработчика результата платежной системы (sale.order.payment.receive). Достаточно разместить его на странице и выбрать нужную систему и плательщика. Для каждой отдельной системы, поддерживающей возврат результата, нужно создавать собственную страницу и настраивать собственный компонент.

    Дополнительная информация

    • Платежные системы (документация)


Пример настройки платежной системы Яндекс.Касса
80 / 254

В уроке рассматривается детальный пример настройки платежной системы Яндекс.Касса.

Примечание: до версии 14.11.8 модуля Интернет-магазин обработчик платежной системы Яндекс.Касса назывался Яндекс.Деньги.

Для приема платежей через систему Яндекс нужно заключить договор. Оставьте заявку на сайте Яндекс.Касса и в комментарии укажите, что у вас сайт на Bitrix Framework с версией протокола 3.0.

Примечание: начиная с версии протокола 3.0, компания Яндекс значительно упростила подключение для интернет-магазинов на основе 1С-Битрикс: Управление сайтом.

При подписании технической анкеты для Яндекса вам необходимо указать один параметр: shopPassword – пароль, который будет использоваться для подписи при обмене данных с Яндекс.

После заключения договора с Яндексом:

  • В административной части продукта в разделе Магазин > Настройки > Платежные системы создайте платежную систему.
  • При создании в качестве обработчика необходимо выбрать Яндекс.Касса 3.х (yandex_3x).
  • Задайте необходимые параметры обработчика:
    • Идентификатор магазина в ЦПП, Номер витрины магазина в ЦПП вы получите от Яндекса при заключении договора.
    • Пароль магазина (shopPassword) из вашей анкеты магазина для Яндекса.

Внимание! Ответ от Яндекса приходит по протоколу HTTPS. Проверка связи по этому протоколу осуществляется кнопкой Проверка HTTPS. Если сайт установлен на Битрикс: Веб-окружение, виртуальную машину BitrixVM, то всё будет работать "из коробки".

Если сайт установлен на другие сервера, то необходимо настроить работу по этому протоколу.

Пути до страниц с сообщением об успешной оплате или ошибке можно, при необходимости, изменить в настройках модуля Интернет-магазин:

Примечание: Оплата через Яндекс.Касса позволяет использовать разные типы оплаты:
  • Яндекс.Деньги;
  • Банковские карты;
  • Платежи через терминалы;
  • Мобильные платежи;
  • WebMoney (для использования данного платежного инструмента необходимо подписать дополнительное соглашение с Яндексом);
  • Альфа-Клик;
  • MasterPass;
  • Промсвязьбанк.

На данный момент невозможно использование разных типов оплаты в рамках одной платёжной системы. Если вам необходимо использовать разные типы оплаты, то необходимо для каждого из них создать собственную платежную систему.


Настройка платежной системы PayPal
81 / 254

Интеграция платежной системы PayPal с 1С-Битрикс: Управление сайтом доступна, начиная с версии 12.5.0 модуля Интернет-магазин.

Обратите внимание, что что платежи можно принимать только от физических лиц.


Настройка PayPal в продукте
82 / 254

Настройка платежной системы PayPal в вашем магазине зависит от способа работы с ней:

  • с использованием предавторизации (Express Checkout), т.е. возможность перехода в PayPal будет доступна уже на стадии корзины, а данные учетной записи PayPal будут автоматически занесены в поля оформления заказа (в этом случае необходимо выполнить активацию счета и автоматических уведомлений);
  • или без использования предавторизации, т.е. оплата с помощью PayPal производится уже после формирования заказа.

Когда способ работы с платежной системой выбран, можно приступать к ее настройке. Для этого откройте форму создания новой платежной системы или редактирования уже существующей:

Заполните поля формы необходимым для вас образом. При этом в качестве обработчика должно быть выбрано PayPal (paypal), а качестве кодировки - utf-8.

Настроим свойства обработчика:

  • Примечание: первые три свойства настраиваются, если платежная система будет использоваться с предавторизацией для оформления заказа (Express Checkout).

    В поля Имя пользователя, Пароль и Пароль для подписи подставьте значения, полученные при активации счета:

  • Укажите настройки параметров заказа:

  • В поле Адрес страницы для получения уведомлений задайте адрес к созданной вами странице, на которой должен быть размещен и настроен на Paypal компонент Подключение обработчика результата платежной системы (bitrix:sale.order.payment.receive).

  • В поле Путь к изображению для кнопки купить вы можете указать путь к другому изображению для кнопки, которая будет отображаться на странице оформления заказа при условии использования предавторизации (см. ниже). Кроме того, с помощью соответствующих полей можно задать названия для произвольных полей, необходимых клиентам:

  • В поле Email задайте email адрес вашего аккаунта PayPal, в поле Идентификатор - идентификатор, полученный от PayPal для Payment Data Transfer, а в поле Адрес возврата - адрес созданной вами страницы, на которую будет возвращаться покупатель после оплаты заказа.

  • Сохраните внесенные изменения.

Использование предавторизации (Express Checkout)

Чтобы в вашем интернет-магазине платежная система PayPal работала с использованием механизма предавторизации, помимо настроек обработчика платежной системы необходимо включить поддержку предавторизации (Express Checkout) в следующих компонентах:

  • Корзина (bitrix:sale.basket.basket):

  • и Одношаговое оформление заказа (bitrix:sale.order.ajax):

В результате после добавления товаров в корзину пользователю на странице корзины будет доступна кнопка Оформить заказ с PayPal:

При ее нажатии выполняется авторизация в PayPal и проверка наличия достаточных средств на счете. После чего пользователь будет возвращен на сайт магазина, где уже будут заполнены все нужные поля и выбрана по умолчанию платежная система PayPal. Пользователю остается только выбрать службу доставки и нажать Оформить заказ. Деньги будут списаны со счета, а заказ получит статус Оплачен.

Работа с платежной системой без предавторизации

Примечание: для корректной работы необходимо, чтобы в настройках обработчика был настроен параметр Адрес страницы для получения уведомлений, в настройках профиля на сайте Paypal должен быть включен механизм автовозврата и указан адрес к вашей странице возврата (см. поле Адрес возврата в настройках обработчика).

Если платежная система PayPal настроена без использования предавторизации (в компонентах sale.basket.basket и sale.order.ajax соответствующие опции не отмечены), то процесс оформления заказа и его оплата будет следующим:

  • Пользователь выбирает товары, добавляет их в корзину и переходит к оформлению заказа.
  • Из списка доступных методов оплаты выбирает PayPal, заполняет необходимым образом остальные поля и нажимает Оформить заказ. На странице, сообщающей о сформировании заказа, появляется кнопка PayPal:

  • Пользователь нажимает данную кнопку и попадает на страницу авторизации PayPal. Введя данные своего аккаунта, он может выполнить оплату заказа.


Активация счета PayPal
83 / 254
Примечание: в данном уроке описаны действия, которые должны быть обязательно выполнены при настройке платежной системы PayPal с использованием предавторизации (Express Checkout).

Для активации счета выполните следующие действия:

  • Войдите на сайт PayPal, используя данные вашего счета, и выберите пункт Дополнительные функции в меню Профиль:

  • В разделе Мои инструменты продаж найдите Доступ к интерфейсу API и нажмите Обновить:

  • Затем выберите Запросить учетные данные API:

    В открывшейся форме отметьте опцию Запросите подпись API и нажмите кнопку Подтвердить согласие и отправить:

  • Скопируйте появившиеся данные: Имя пользователя API, Пароль API и Подпись.

    И вставьте их в форме параметров платежной системы в административном разделе вашего сайта, работающего под управлением продукта 1С-Битрикс.

Активация автоматических уведомлений

Чтобы автоматически получать уведомления об оплате платежей через PayPal, необходимо выполнить следующие действия:

  • На сайте PayPal на странице Мой профиль выберите пункт Дополнительные функции в меню Профиль.
  • В открывшейся форме в разделе Мои инструменты продаж найдите Уведомления о мгновенных платежах и нажмите Обновить:

  • В появившемся окне в поле URL-адрес для уведомления введите адрес страницы сайта для получения уведомлений (см. адрес, заданный в настройках обработчика) и отметьте опцию Принимать IPN-сообщения:

  • Сохраните внесенные изменения.


Открытие корпоративного счета PayPal
84 / 254

Для открытия корпоративного счета PayPal выполните следующие действия:

  • Перейдите к регистрации на сайте PayPal.
  • Выберите страну регистрации вашего бизнеса и нажмите кнопку Открыть счет в разделе Корпоративный:

    Примечание: если вы являетесь физическим лицом и хотите принимать платежи в рамках своего собственного интернет-проекта, то вы можете использовать счет категории Личный.

  • В открывшейся форме заполните сведения о вашей компании и нажмите кнопку Продолжить.

  • Затем введите учетные данные для регистрации корпоративного счета PayPal:

  • Нажмите кнопку Войти и введите свои учетные данные в появившемся окне:

    Нажмите Вход.
  • Когда вход будет выполнен, нажмите кнопку Продолжить.

  • На следующем шаге необходимо предоставить информацию о вашей компании. Для этого с помощью каждой кнопки Начать заполните необходимые поля и загрузите документы. По завершении нажмите Подтвердить:

  • Теперь следует привязать к счету свою банковскую карту. Для этого служит ссылка Подключить и подтвердить мою дебетовую или кредитную карту, расположенная в секции Уведомления:

    В открывшемся окне следует заполнить все необходимые поля.
  • В заключение, с помощью ссылки Подтвердить адрес электронной почты, также расположенной в секции Уведомления, подтвердите свой адрес и введите пароль, полученный в сообщении от PayPal:


Настройка платежной системы ROBOKASSA
85 / 254

Обработчик платежной системы ROBOKASSA добавлен в Bitrix Framework, начиная с версии 11.0.5 модуля Интернет-магазин. Для подключения этой системы на вашем сайте необходимо выполнить следующие действия:

  • создать платежную систему, задав настройки обработчика ROBOKASSA;
  • создать результирующий файл, а также информационные страницы, на которые будет перенаправляться пользователь в случае успешного проведения платежа или отказа от проведения платежа;
  • задать настройки в личном кабинете на сайте robokassa.ru.

Создание платежной системы

В административной части продукта в разделе Магазин > Настройки > Платежные системы создайте платежную систему. В качестве обработчика выберите RoboKassa (roboxchange), вам станут доступными свойства обработчика.

Задайте логин и пароль магазина, а также второй пароль магазина, который будет использоваться интерфейсом оповещения о платеже:

Укажите настройки для заказа:

Поскольку ROBOKASSA позволяет принимать платежи с помощью большого количества сервисов (банковские карты, сервисы мобильной коммерции, электронные валюты и т.д. ), то, чтобы клиент не запутался в таком многообразии, в настройках обработчика платежной системы ROBOKASSA вы можете сразу выбрать конкретный способ организации приема платежей:

Создание результирующего файла и дополнительных страниц

Для работы платежной системы необходимо создать файл, например, result.php, который будет получать результат от платежной системы. Используя визуальный редактор, разместите компонент Подключение обработчика результата платежной системы (bitrix:sale.order.payment.receive) и обязательно выполните настройку его параметров:

  • в параметре Платежная система должна быть правильно указана система для оплаты платежей в ROBOKASSA;
  • в параметре Тип плательщика должен быть указан тип плательщика, для которого используется указанная платежная система.

Примечание: Страница для приема результатов платежа не должна содержать шаблон сайта, иначе не будет работать автоматическая оплата заказа. Должно быть подключение только ядра. Примерный код:
<?
require($_SERVER["DOCUMENT_ROOT"]."/bitrix/modules/main/include/prolog_before.php");

$APPLICATION->SetTitle("Прием информации об оплате");

$APPLICATION->IncludeComponent(
    "bitrix:sale.order.payment.receive",
    "",
    Array(
        "PAY_SYSTEM_ID" => "7",
        "PERSON_TYPE_ID" => "1"
    )
);

require($_SERVER["DOCUMENT_ROOT"]."/bitrix/modules/main/include/epilog_after.php");?>

Кроме того, необходимо создать еще две информационные страницы:

  • страницу, на которую будет переадресовываться пользователь в случае, когда оплата прошла успешно (например, payment_was_successful.php);
  • страницу, на которую будет переадресовываться пользователь в случае отказа проведения платежа ( например, payment_failed.php).

Настройки в личном кабинете на сайте robokassa.ru

Когда все настройки на сайте выполнены, можно приступать к указанию данных в личном кабинете для вашего магазина на сайте robokassa.ru:

  • В полях Пароль #1 и Пароль #2 должны быть указаны пароли, заданные вами на сайте магазина в настройках обработчика (см. выше).
  • В поле Result URL указывается путь к результирующему файлу на вашем сайте (в нашем случае путь к файлу result.php).
  • В поле Метод отсылки данных по Result URL укажите POST.
  • Success URL - в этом поле укажите адрес к странице на вашем сайте с информацией об успешном проведении платежа (в нашем случае путь к файлу payment_was_successful.php).
  • В поле Метод отсылки данных по Success URL укажите GET.
  • Fail URL - в этом поле укажите адрес к странице на вашем сайте с информацией об отказе проведения платежа (в нашем случае путь к файлу payment_failed.php).
  • В поле Метод отсылки данных по Fail URL укажите GET.


Настройка платежной системы QIWI Wallet
86 / 254

Обработчик платежной системы QIWI Wallet добавлен в Bitrix Framework, начиная с версии 10.0.1 модуля Интернет-магазин. Для подключения этой системы на вашем сайте необходимо выполнить следующие действия:

  • создать платежную систему;
  • создать результирующий файл, а также информационные страницы, на которые будет перенаправляться пользователь в случае успешного или неуспешного проведения платежа;
  • задать настройки на сайте Visa QIWI Wallet;
  • задать настройки обработчика QIWI Wallet.

Создание платежной системы

В административной части продукта перейдите на страницу Магазин > Настройки > Платежные системы и создайте новую платежную систему.

В качестве обработчика выберите Qiwi Wallet (qiwi) и сохраните платежную систему без выполнения настроек обработчика.

Важно! К настройкам обработчика вернемся позже, когда будет создан результирующий файл и выполнены настройки в личном кабинете.

Создание результирующего файла и дополнительных страниц

Для работы платежной системы необходимо создать файл, например, result.php, который будет получать результат от платежной системы. Используя визуальный редактор, разместите компонент Подключение обработчика результата платежной системы (bitrix:sale.order.payment.receive) и обязательно выполните настройку его параметров:

  • в параметре Платежная система должна быть правильно указана система для оплаты платежей в QIWI Wallet;
  • в параметре Тип плательщика должен быть указан тип плательщика, для которого используется указанная платежная система.

Кроме того, для удобного информирования клиентов можно подготовить следующие две страницы:

  • страницу, на которую будет переадресовываться пользователь в случае, когда оплата прошла успешно (например, qiwi_success.php);
  • страницу, на которую будет переадресовываться пользователь в случае неуспешной оплаты счета ( например, qiwi_failed.php).

Примечание: данные страницы создавать необязательно, например, в обоих случаях можно просто перенаправлять клиента на страницу со списком его заказов.

Настройки на сайте Visa QIWI Wallet

Войдите на сайт Visa QIWI Wallet, используя данные вашего аккаунта, и выполните настройки магазина:

  • Сгенерируйте и скопируйте аутентификационные данные (API ID и пароль API), их необходимо будет вставить в поля настроек обработчика.
  • Включите и настройте Pull (Rest) протокол (скопируйте при этом пароль оповещения). В поле URL для оповещения обязательно укажите адрес к странице получения результата от платежной системы.

Настройки обработчика QIWI Wallet

Выполните настройки свойств обработчика платежной системы QIWI Wallet следующим образом:

  • В поля Идентификатор магазина, Идентификатор API, Пароль API и Пароль оповещения подставьте значения, указанные в настройках на сайте Visa QIWI Wallet:

    Примечание: если пароль API не был скопирован при генерации идентификатора API, то следует перегенерировать идентификатор с помощью ссылки Сгенерировать новый ID и скопировать новый пароль.

    Аналогично, если пароль оповещения не был скопирован при настройке Pull (Rest) протокола, то его также можно сменить с помощью кнопки Сменить пароль оповещения.

  • Укажите настройки параметров заказов:

  • В поле Способ авторизации укажите значение OPEN, если пароль оповещения передается в открытом виде (в настройках на сайте Visa QIWI Wallet в разделе Настройки Pull (REST) протокола галочка Подпись снята) или SIMPLE в противном случае (используется простая подпись).

  • В нижеследующих параметрах укажите адреса страниц, на которые пользователь будет перенаправляться в случае успешной и неуспешной оплаты счета. Кроме того, определите автоматически ли оплачивать заказ при получении успешного статуса оплаты:

  • Сохраните внесенные данные.


Настройка платежной системы Assist
87 / 254

Для подключения платежной системы Assist на вашем сайте необходимо выполнить следующие действия:

  • создать платежную систему;
  • создать результирующий файл, а также информационные страницы, на которые будет перенаправляться пользователь в случае успешного или неуспешного проведения платежа;
  • задать настройки на сайте Assist;
  • задать настройки обработчика Assist.

Создание платежной системы

В административной части продукта перейдите на страницу Магазин > Настройки > Платежные системы и создайте новую платежную систему.

В качестве обработчика выберите Assist (assist) и сохраните платежную систему без выполнения настроек обработчика.

Важно! К настройкам обработчика вернемся позже, когда будет создан результирующий файл и выполнены настройки в личном кабинете.

Создание результирующего файла и дополнительных страниц

Для работы платежной системы необходимо создать файл, например, result.php, который будет получать результат от платежной системы. Используя визуальный редактор, разместите компонент Подключение обработчика результата платежной системы (bitrix:sale.order.payment.receive) и обязательно выполните настройку его параметров:

  • в параметре Платежная система должна быть правильно указана система для оплаты платежей в Assist;
  • в параметре Тип плательщика должен быть указан тип плательщика, для которого используется указанная платежная система.

Кроме того, для удобного информирования клиентов можно подготовить следующие две страницы:

  • страницу, на которую будет переадресовываться пользователь в случае, когда оплата прошла успешно (например, assist_success.php);
  • страницу, на которую будет переадресовываться пользователь в случае неуспешной оплаты счета ( например, assist_failed.php).

Примечание: данные страницы создавать необязательно, например, в обоих случаях можно просто перенаправлять клиента на страницу со списком его заказов.

Настройки на сайте Assist

Войдите на сайт Assist, используя данные вашего аккаунта, и выполните настройки отправки результатов платежей для вашего мерчанта (Настройки > Настройки мерчантов, закладка Настройка отправки результатов платежей):

  • Отметьте одноименные опции для отправки результатов оплат, отмен и подтверждений.
  • В поле URL для отправки результатов обязательно укажите адрес к странице получения результата от платежной системы.
  • Скопируйте секретное слово, его необходимо будет указать в настройках обработчика.

Настройки обработчика Assist

Выполните настройки свойств обработчика платежной системы Assist следующим образом:

  • В полях Логин и Пароль укажите логин и пароль вашего аккаунта для магазина на сайте Assist, а в полях Код магазина и Секретное слово подставьте значения, указанные в настройках мерчанта:

  • Укажите настройки параметров заказов:

  • В нижеследующих параметрах укажите адреса страниц, на которые пользователь будет перенаправляться в случае успешной и неуспешной оплаты счета:

  • Система Assist позволяет проводить платежи с помощью кредитных карт, а также систем YandexMoney, WebMoney Transfer и QIWI. Поэтому в настройках обработчика укажите какие из способов организации приема платежей будут доступны покупателям:

  • Кроме того, определите автоматически ли оплачивать заказ при получении успешного статуса оплаты:

  • Сохраните внесенные данные.


Статусы заказов
88 / 254

Статусы заказа - этапы, через которые проходит заказ во время обработки.

Они служат для информирования клиентов и сотрудников электронного магазина о текущем состоянии заказа. Вы можете создавать любое количество статусов заказа в зависимости от организации процесса обработки заказа. Например, Отложен, В обработке, Отгружен, В пути и т.д.

Управление статусами осуществляется на странице Статусы (Магазин > Настройки магазина > Статусы).

Примечание: существует два особых статуса заказа, удаление которых невозможно:
  • N - начальный статус (название по умолчанию - Принят), в который заказ устанавливается при создании;
  • F - финальный статус (название по умолчанию - Выполнен), в котором заказ считается выполненным (т.е. оплаченным и доставленным).

Форма редактирования статусов имеет вид:

Заполнение полей этой формы имеет следующие особенности:

  • Код - это уникальный код статуса. Задается в виде одной буквы латинского алфавита;
  • В поле Сортировка задается относительный вес статуса. Используется для определения положения данного статуса в общем списке статусов;
  • Отдельно для каждого языка, определенного в системе, задаются Название и Описание.
  • В секции Права на доступ выводятся те группы пользователей, которые имеют в настройках модуля Интернет-магазин уровень доступа Обработка заказов. Для них с помощью опций данной секции можно специфицировать возможности работы с заказами.

    В нашем примере правом на обработку заказов обладает группа Администраторы интернет-магазина. Эта группа выводится в форме редактирования статуса.

    Для этой группы при редактировании или создании нового статуса можно устанавливать права на изменение состояний заказа:
    • Флаг отмены;
    • Флаг доставки;
    • Флаг оплаты.

    Группы пользователей, для которых установлены эти флаги, имеют возможность изменять флаги соответственно отмены, доставки и оплаты в заказе. Это выполняется на странице детального просмотра заказа. Перейти к ней можно со страницы Заказы, выбрав пункт Просмотреть подробную информацию о заказе в меню действий:

    Примечание: флаги Изменение и Удаление в секции Правах на доступ формы Статус заказа означают, что при их наличии пользователям из данной группы будут доступны действия Изменить параметры заказа и Удалить заказ в меню действий выбранного заказа. (См. иллюстрацию выше.)

Итак, пусть заказ находится в статусе Принят. При работе с заказом, находящимся в определенном статусе, действуют настройки именно этого статуса.

В нашем примере все возможные опции в настройках статуса Принят установлены для группы Администраторы интернет-магазина. Для примера рассмотрим отмену заказа, которая выполняется в в верхней секции формы с помощью кнопки Отменить заказ:

При клике по этой кнопке появится дополнительное окно, в котором можно ввести причины отмены заказа.

Оплата заказа и разрешение доставки выполняется в секциях Оплата и Доставка с помощью кнопок Оплатить заказ и Разрешить доставку соответственно. При нажатии на кнопку открывается специальное окно, в котором вводится информация о документах оплаты (или доставки).

Впоследствии, если заказ был оплачен или разрешена была доставка, можно изменить флаг доставки или оплаты с помощью ссылки Изменить:

Можно изменить статус заказа с помощью поля Статус, по нажатии которой станет доступным выпадающий список, в котором можно выбрать требуемый статус и применить его к заказу.

Примечание: система Bitrix Framework позволяет создать и использовать собственную (кастомизированную) форму для просмотра заказов. Кастомизированная форма просмотра заказов создается аналогично форме создания/редактирования элементов информационных блоков. В поле Файл с пользовательской формой просмотра заказа формы настроек модуля Интернет-магазин указывается путь к файлу, содержащему пользовательскую форму.

Дополнительная информация

  • Создание и редактирование информационного статуса заказа (документация)


Налоги
89 / 254

Налоги - инструмент для вычисления налоговых отчислений в рамках заказа.

Если в системе установлены налоги, то они учитываются при определении стоимости заказа. Общие принципы работы с налогами в модуле Интернет-магазин таковы:

  • Налоги вводятся для каждого сайта независимо. Количество налогов не ограничено;
  • Ставки налогов могут зависеть от типа плательщика и его местоположения. Они задаются в процентном виде. Количество ставок налогов не ограничено. Ставки налогов могут быть включены в цену;
  • Некоторые покупатели могут иметь право не платить часть налогов. Для таких случаев необходимо настроить освобождения от налогов для групп пользователей, к которым принадлежат эти покупатели.
  • При расчёте стоимости товара налоги считаются перед скидками.

Работа с налогами

  • Налоги
  • Ставки налогов
  • Освобождение от налогов
    •

    Налоги

    Налоги настраиваются на странице управления налогами Список налогов (Магазин > Настройки магазина > Налоги > Список налогов). Каждый налог применяется к сайту, к которому он привязан. Форма создания/редактирования налога имеет следующий вид:

    В форме создания/редактирования налога указываются:

    • Сайт, на котором будет действовать данный налог;
    • Название налога;
    • Мнемонический код налога, который будет использоваться разработчиками (задается латинскими буквами);
    • произвольное Описание.

    Ставки налогов

    Ставки налогов настраиваются на странице управления ставками налогов Ставки налогов (Магазин > Настройки магазина > Налоги > Ставки налогов). На этой странице для налогов вводятся ставки в зависимости от местоположения покупателя и его типа плательщика (тип плательщика не обязателен).

    Форма создания/редактирования ставки налога имеет следующий вид:

    В форме создания/редактирования указываются:

    • Налог, для которого создается данная ставка;
    • Активность - только активные ставки участвуют при расчете стоимости заказа;
    • Тип плательщика, к которому применима данная ставка налога;
    • В поле Ставка задается величина ставки налога в процентах;
    • В поле Входит в цену определяется, включен ли налог в цену товара или нет. В случае если налог входит в цену, то освобождение от налога действовать не будет.
    • Порядок применения - ставки налога с одинаковым порядком применения складываются, с разными - образуют сложные проценты (проценты на проценты). Подробнее о расчете стоимости товара будет сказано ниже.
    • В поле Местоположения указываются местоположения, в которых будет применяться данная ставка налога.
    • В поле Группы местоположений выбирается группа(пы), в местоположениях которой будет применяться данная ставка налогов.
      • Примечание: необходимо обязательно указать значения хотя бы одного из полей: Местоположения либо Группы местоположений. Возможно указание значений обоих полей одновременно.

    Для расчета налогов для данного заказа будут выбираться все ставки налогов, удовлетворяющие следующим условиям:

    • Налог, к которому относится данная ставка, принадлежит тому сайту, на котором производится заказ.
    • Местоположение, указанное покупателем в свойстве, у которого стоит флажок Использовать как местоположение для налогов, должно входить в список местоположений, на которые действует данная ставка;
      • Примечание: для каждого типа плательщика должно быть введено по одному свойству с флагом Использовать как местоположение для налогов, иначе ставки налогов определены не будут. (Смотри урок Свойства заказа.)

      Местоположение, указанное пользователем в этом свойстве, будет проверено на принадлежность местоположениям, отмеченным в ставках налогов. После этого будут выбраны ставки налогов, которые будут применены к заказу.

    • Тип плательщика, установленный для данной ставки, совпадает с типом плательщика, выбранным покупателем при оформлении заказа, либо для данной ставки тип плательщика не установлен;
    • Данная ставка налога активна.

    Если страна представлена более чем одним местоположением и необходимо задать ставку налога, которая действует на всю страну, то рекомендуется создать группу местоположений, включающую все местоположения этой страны, и при вводе ставки налога указать эту группу местоположений.

    Если для данного заказа указано более одной ставки налогов, то порядок применения этих ставок следующий:

    • Ставки налогов применяются по порядку в соответствии со значениями в поле Порядок применения ставок налогов, начиная с наименьшего.
    • Ставка налога с данным порядком применения применяется к сумме, в которой уже учтены все налоги с меньшим порядком применения. Другими словами действуют сложные проценты (проценты на проценты).
    • Если ставки налогов имеют один и тот же порядок применения, то они складываются, т.е. они применяются к одной и той же сумме.

    Пример вычисления стоимости заказа

    Рассмотрим пример вычисления стоимости заказа. Пусть покупается товар стоимостью 25 рублей. Скидка при покупке на сумму более 20 рублей равна 2%. Пусть данному заказу соответствуют следующие ставки налогов:

    • Налог 1 со ставкой 18.5% и порядком применения 100;
    • Налог 2 со ставкой 2.7% и порядком применения 100;
    • Налог 3 со ставкой 3% и порядком применения 200.

    Налог 1 будет равен 4,63 рубля (25 * 0,185).

    Налог 2 будет равен 0,68 рубля (25 * 0,027).

    После применения Налога 1 и Налога 2 стоимость заказа будет равна 30,31 рубля (25 + 4,63 + 0,68).

    Налог 3 будет равен 0,91 рубля (30,31 * 0,03).

    После применения Налога 3 стоимость заказа будет равна 31,22 рубля (30,31 + 0,91).

    После применения скидки стоимость заказа будет составлять 30,6 рубля (31,22 - 31,22 * 0,02). Далее в эту стоимость должна быть включена стоимость доставки.

    В публичном разделе информация о взимаемых налогах выводятся в процессе оформления заказа.

    Освобождение от налогов

    Эта функциональная возможность применяется, если существуют покупатели, которые освобождены от уплаты части налогов.

    Создайте специальную группу пользователей, например, Освобожденные от налогов. Никаких прав в рамках системы предоставлять ей не надо, т.е. на закладке Доступ для всех полей оставьте значение по умолчанию.

    Далее перейдем на страницу Освобождение от налогов (Магазин > Настройки магазина > Налоги > Освобождение от налогов). На этой странице выведены все группы пользователей, определенные в системе. В меню действий созданной нами группы Освобожденные от налогов выберем пункт Изменить освобождение от налогов:

    В открывшейся форме укажем, какие налоги не должны взиматься с членов этой группы:

    Примечание: освобождение от налогов действовать не будет, если налог включен в цену.

    Дополнительная информация

    • Налоги (документация)


Ставки НДС
90 / 254

Если в системе установлены налоги, то они учитываются при определении стоимости заказа.

Налог на добавленную стоимость (НДС) — косвенный налог, форма изъятия в бюджет государства части добавленной стоимости, которая создаётся на всех стадиях процесса производства товаров, работ и услуг и вносится в бюджет по мере реализации.

Ставка НДС для товара

По умолчанию в Интернет-магазин уже включены Ставки НДС: 0% и 18%. Ставка НДС может быть разной в зависимости от товара. Создадим и применим новую Ставку НДС:

  • Перейдите на страницу Ставки НДС (Магазин > Настройки > Налоги > Ставки НДС).
  • Нажмите кнопку Добавить на контекстной панели. Откроется форма добавления новой ставки НДС:

    Добавление новой ставки НДС

  • Заполните поля формы:
    • Наименование – название ставки;
    • Ставка – величина ставки.
    • Акт. – опция активности ставки.
    • Сорт. – значение порядка сортировки.
  • Сохраните внесенные изменения.

Теперь, если вы перейдете к форме редактирования элемента (товара) Торгового каталога, то в поле Ставка НДС вы сможете выбрать нужную ставку НДС для товара:

Выбор ставки НДС

Ставка НДС для каталога товаров

Кроме индивидуальной для товара ставки НДС, можно установить ставку НДС для всего каталога:

  • Перейдите на страницу настройки модуля Торговый каталог (Настройки > Настройки продукта > Настройки модулей > Торговый каталог).
  • На закладке Каталоги в поле НДС установите необходимую ставку НДС для нужного каталога:

    Выбор ставки НДС для каталога

  • Сохраните внесенные изменения.

То же самое можно сделать на странице настроек непосредственно торгового каталога (Контент > Информационные блоки > Типы информационных блоков > Нужный тип > Необходимый инфоблок), на вкладке Торговый каталог.

Примечание: Если одновременно указана ставка НДС для товара и ставка для всего каталога, то для данного товара будет действовать только его персональная ставка НДС, а ставка НДС для всего каталога учитываться не будет.


Единицы измерения
91 / 254

Настройка единиц измерения для интернет-магазина подробно описана в видео-уроке:

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Единицы измерения

Дополнительная информация

  • Единицы измерения (документация)
  • Пример настройки единиц измерения при создании интернет-магазина


Печатные формы
92 / 254

Печатные формы - страница для настройки данных в документах по заказу, выводимых на печать.

В документах, выводимых на печать, необходимо указать множество данных от названия компании до реквизитов счета. Такая настройка выполняется на странице Настройка печатных форм Магазин > Настройки > Печатные формы.

Настройка выполняется простым заданием соответствий в двух колонках. Данные заполняются отдельно для магазина и для покупателя.

После заполнения и сохранения этих настроек при печати данных по заказу параметры полей будут заполняться системой в соответствии с этими настройками.


Экспорт и импорт данных
93 / 254

Модуль Торговый каталог позволяет выполнять экспорт и импорт данных информационных блоков, работающих в режиме торгового каталога (Магазин > Настройки).

Экспорт

Экспорт данных по умолчанию доступен в следующих форматах и профилях (Магазин > Настройки > Экспорт данных):

Примечание: профиль Газета Из рук в руки является примером предустановленного профиля, т.е. частично настроенного разработчиком. Для его использования пользователю необходимо задать оставшиеся настройки.

Примечание: описание формата представления данных для Яндекс.Маркет можно найти на сайте Yandex.

При обработке Яндекс.Маркетом созданных при экспорте файлов в формате Yandex Simple возможна ошибка дубликатов:

Ошибка: Найдено предложение-дубликат: http://www.mysite.ru/category/162/1078?r1=yandext&r2= (строка 72, столбец 9)
Ошибка: Предложение отклонено: http://www.mysite.ru/category/162/1078?r1=yandext&r2= (строка 72, столбец 9)
Ошибка: Найдено предложение-дубликат: http://www.mysite.ru/category/164/1086?r1=yandext&r2= (строка 88, столбец 9)
Ошибка: Предложение отклонено: http://www.mysite.ru/category/164/1086?r1=yandext&r2= (строка 88, столбец 9)

Подобная ошибка возникает, если для товаров задан диапазон цен, например:

  • При покупке 1ед. товара - цена 100р
  • При покупке от 2-х и выше - цена 50р

Диапазоны при экспорте превращаются в предложения с одинаковыми ссылками.

Импорт

Для импорта по умолчанию доступны следующие профили и форматы данных Магазин > Настройки > Импорт данных:

Import CSV(new) / Export CSV(new) - данный формат доступен при установленном в системе модуле Торговый каталог версии 4.0.5 и старше. Этот формат позволяет загружать и выгружать данные с учетом группировки цен товаров в зависимости от количества приобретаемых товаров, а также снимает ограничение с количества объединяемых таблиц, содержащих информацию о товарах. Кроме того, данный формат позволяет экспортировать и импортировать цены товара в валюте, указанной для каждой цены.

Параметры импорта или экспорта могут быть сохранены в виде профиля. При выполнении повторной операции с данными того же формата и тем же информационным блоком можно воспользоваться сохраненным профилем:

Сохранение профиля

Рассмотрим пример сохранения профиля экспорта.

В меню действий какого-либо формата экспорта\импорта выберите пункт Добавить профиль:

Укажите тип инфоблока и сам инфоблок на первом шаге:

Нажмите Далее и перейдите ко второму шагу:

Укажите следующие параметры экспорта/импорта:

  • символ разделителя полей;
  • при импорте укажите соответствие полей в файле полям и свойствам в базе, при экспорте - выберите поля и свойства базы и определите их порядок в файле;
  • укажите, следует ли выгружать файлы;
  • выберите имя и путь для сохраняемого файла;
  • укажите имя данной схемы настроек экспорта/импорта.

Примечание: поля Уникальный идентификатор и Названия являются минимально необходимыми для проведения импорта.

Если есть товары с одинаковым Названием, но разным Идентификатором, то система их за один не посчитает. И наоборот, два товара с разным Названием и одинаковым Идентификатором будут сочтены одним и тем же товаром.

Нажмите Сохранить и ваш профиль будет добавлен в общий список.

Кроме того, ссылки на часто используемые профили экспорта и импорта могут быть добавлены в административное меню:

При необходимости созданный пункт меню может быть удален выбором соответствующего пункта меню действий.

Дополнительная информация

  • Экспорт (документация)
  • Импорт (документация)


Аффилиаты
94 / 254

В Интернет-магазине реализована возможность управлять сетью аффилиатов. Для этого в административной части магазина имеется специальный раздел Аффилиаты (Магазин > Аффилиаты).

Аффилиат - вид партнера компании, который непосредственно не занимается продажей товара, а располагает у себя на сайте ссылку на Интернет-магазин компании, и пользователи его сайта, перешедшие по этой ссылке и купившие товар в магазине, считаются им привлеченными. Ему от таких продаж перечисляется определенный процент или фиксированная сумма, предусмотренная его планом.

В продукте есть также возможность реализовать пирамиду аффилиатов, т.е. многоуровневое аффилиатство. Суть его такова: если пользователь, привлеченный одним аффилиатом, также зарегистрировался как аффилиат, то привлекшему аффилиату, кроме своих процентов от продаж, будет также начисляться процент от дохода привлеченного аффилиата. Процесс подсчета доходов аффилиатов называется калькулирование, а процентные отношения между разными уровнями аффилиатов задаются на странице Пирамида.

Список всех транзакций, выполняемых по счетам аффилиатов, можно просмотреть на странице Транзакции.

Настройки работы с аффилиатами

Настройки работы с аффилиатами устанавливаются на странице настроек модуля Интернет-магазин (Настройки > Настройки продукта > Настройки модулей > Интернет-магазин)

Пользователю, который зарегистрировался на сайте как аффилиат, выдается ссылка, которую он размещает на своем сайте, и пользователи этого сайта, пришедшие в магазин по аффилиатской ссылке, считаются привлеченными этим аффилиатом. Для того чтобы знать, от какого именно аффилиата пришел покупатель, в настройках модуля Интернет-магазин в поле Название параметра, в котором приходит код аффилиата указывается название переменной, значением которой будет код аффилиата (в дистрибутиве это partner).

Дополнительная информация

  • "Бессмертный" аффилиат (блог)
  • Аффилиаты (документация)


Калькуляция аффилиата
95 / 254

Пользователю, который зарегистрировался в качестве аффилиата, будет предоставлена ссылка для размещения на своем сайте. В этой ссылке будет содержаться переменная (например, partner), указанная в настройках модуля Интернет-магазин, с определенным значением для идентификации пользователя, например, http://www.testsite.ru/index.php?partner=1, из которой будет известно, с сайта какого аффилиата пришел пользователь. Система считывает параметр partner, и, когда пользователь приобретет товар, это будет учтено для аффилиата с этим кодом.

Для калькуляции аффилиатов перейдите на страницу Калькуляция (Магазин > Аффилиаты > Калькуляция):

Эта форма служит для расширенной калькуляции. Обсудим особенности работы с ней. Рассмотрим случай, когда необходимо выполнить калькуляцию для всех аффилиатов. Тогда поле Аффилиаты не изменяется. Представленная форма позволяет:

  • Установить определенный Период калькуляции. Если не указана дата начала периода калькуляции, то калькуляция начнется с момента окончания предыдущей калькуляции. Если не указана дата окончания периода калькуляции, то калькуляция будет произведена по текущий момент.
  • Если установить Период для определения плана, то будут приниматься во внимание только те заказы, которые отгружены в этот период.
  • Можно установить одно из трех действий с начисленной суммой:
    • Начислить и выплатить переводом на внутренний счет пользователя - если у аффилиата еще нет внутреннего счета, то он будет автоматически создан, на этот счет будет начислена и выплачена сумма.
    • Начислить и пометить как выплаченую - при калькуляции аффилиатов с этой опцией будет произведён расчёт выплат и сумма будет помечена как выплаченная в графе Выплаченная сумма отчетной формы аффилиатов на страинце Магазин > Аффилиаты > Аффилиаты.
    • Если выбрать опцию Только начислить, то сумма будет отображаться только в графе Начисленная сумма на этой же странице.
  • Определение Пошаговая калькуляция с длиной шага может быть актуально при калькулировании большого количества аффилиатов, и тогда для увеличения надежности процесса можно задать шаг, например, 10 сек.

Чтобы выбрать аффилиатов, перейдите по ссылке списком аффилиатов формы. Таким образом вы перейдете на страницу Аффилиаты. Выберите нужных аффилиатов в отчетной форме и примените к ним одно из следующих действий:

  • Действие калькулировать аффилиата означает начислить сумму за заказы этого аффилиата за период со времени последней калькуляции по текущий момент. План аффилиата определяется по заказам за этот же период. То есть, если вы выполняете действие калькулировать аффилиата, то это будет выполнено в этой же форме. Если для данного аффилиата нет подходящего плана, например, от него куплено две книги, а планы действуют, начиная с трех книг, и в настройках этого аффилиата не установлена опция Фиксировать план, то будет выведена соответствующая ошибка и аффилиат будет деактивирован.

    То есть, необходимо создавать планы, предусматривающие все варианты. После калькуляции в соответствии с подходящим планом аффилиату будет начислена полагающаяся ему сумма.

  • Вы также можете калькулировать определенный набор аффилиатов расширенно. Выбрав действие калькулировать аффилиатов расширенно, вы будете возвращены в представленную форму калькуляции, в которой можно установить период калькуляции, а также период по заказам, за который определяется план аффилиата.
  • Рассмотрим оставшиеся возможные действия, которые могут быть выполнены над аффилиатами:
    • действие выплатить аффилиату начисленные суммы позволяет перевести начисленные суммы в выплаченые суммы.
    • действие выплатить аффилиату начисленные суммы на внутренний счет позволяет перевести начисленные суммы в выплаченые суммы с зачислением этих сумм на внутренний счет покупателя магазина (если внутренний счет пользователя не существует, то он будет создан).
    • действие обнулить выплаченные суммы(деньги переведены) используется при выплате наличных аффилиату.
    • действия активировать и деактивировать служат соответственно для установки и снятия флага активности с аффилиата. Неактивный аффилиат не участвует в работе системы, а лишь числится в списке аффилиатов.


Страница "Аффилиаты"
96 / 254

На странице Аффилиаты (Магазин > Аффилиаты > Аффилиаты) предусмотрены средства управления аффилиатами. Для создания нового аффилиата служит кнопка Добавить аффилиата, расположенная на контекстной панели. По нажатии на нее переходим к форме создания/редактирования аффилиата:

С помощью этой формы можно создавать нового и редактировать параметры существующего аффилиата:

  • Указывается Сайт, для которого создается отдельный набор аффилиатов.
  • Любой пользователь, зарегистрированный в системе, может стать аффилиатом. В поле Пользователь можно выбрать его из списка с помощью кнопки [...];
  • Если мы регистрируем аффилиата не первого уровня, то в поле Аффилиат, через которого зарегистрировался выбираем одного из имеющихся в системе аффилиатов.
  • В выпадающем списке План будут доступны все планы, созданные в системе для текущего сайта.

    Примечание: если вы хотите применить к редактируемому аффилиату не тот план, который подходит в действительности (план 5% с каждой продажи, т.к. в реальности с помощью аффилиата куплено 3 книги), а с более выгодными условиями (например, Книги 5 шт. – 6% при продаже от пяти книг), то нужный план необходимо выбрать в поле План, а также установить опцию Фиксировать план. Если эту опцию не установить, то вне зависимости от вашего выбора в поле План в процессе калькуляции этого аффилиата системой будет применен реальный план (5% с каждой продажи).
  • Опцию Активность необходимо выбрать, если вы хотите, чтобы данный аффилиат был активен.
  • Дата регистрации устанавливается с помощью кнопки
  • Поля Выплаченная сумма, Начисленная сумма и Дата последней калькуляции будут заполнены автоматически после калькуляции аффилиата.
  • Поля Сайт аффилиата и Описание аффилиата можно заполнять при желании.


Планы аффилиатов
97 / 254

В плане аффилиата фиксируется комиссия, которую он будет получать за привлечение клиентов и последующую продажу товаров. План может зависеть от количества проданных товаров либо от суммы продаж. Это определяется в настройках модуля Интернет-магазин в поле Планы аффилиатов делятся по:

  • количеству продаж;
  • сумме продаж.

В зависимости от этого форма редактирования плана аффилиата меняется. То есть вы можете создать сколько угодно планов, определяя в них поле, начиная с какой суммы или с какого количества будет действовать данный план. Отметим, что решение, по какому принципу делить планы аффилиатов, необходимо принять перед настройкой этой системы и уже не изменять впоследствии, иначе калькуляция будет происходить некорректно.

Управление планами аффилиатов осуществляется на странице Планы комиссий аффилиатов (Магазин > Аффилиаты > Планы). Перейдем на эту страницу и создадим новый план с помощью кнопки Добавить план, расположенной на контекстной панели. В случае если в настройках магазина установлено, что планы делятся по количеству продаж, то форма редактирования имеет вид:

Данная форма имеет следующие особенности:

  • ID и Дата последнего изменения добавляются автоматически после сохранения плана;
  • Сайт, для которого создается план;
  • Произвольное Название плана и Описание плана;
  • Опцию Активность необходимо установить, чтобы этот план действовал;
  • Комиссия аффилиата может быть задана в процентах либо в любой из валют, определенных в системе.

В случае если в настройках модуля Интернет-магазин в выпадающем списке выбран пункт Планы аффилиатов делятся по сумме продаж, то форма редактирования изменится: поле План действует при продаже не менее (шт.) поменяется на План действует при продаже на сумму не менее (в базовой валюте сайта).

Примечание: базовая валюта сайта определяется в настройках модуля Интернет-магазин на закладке Права на заказы.

На закладке Группы товаров можно указать группу, к товарам которой создаваемый план будет применяться на особых условиях. По кнопке Добавить появляются поля для заполнения:

Таким образом, аффилиат за продажу товаров, относящихся к указанной выше группе, будет получать особую комиссию, а за продажу товаров, не входящих в указанную группу, будет получать комиссию согласно общим настройкам плана, доступным на закладке План.

Для корректной работы с аффилиатами необходимо создать планы, учитывающие все возможные варианты, например:


Пирамида
98 / 254

Пирамида нужна для того, чтобы организовать многоуровневое аффилиатство. То есть, для того чтобы аффилиат мог зарабатывать не только на своих продажах, но и на продажах других аффилиатов, которых он привел на сайт.

Например, аффилиат C зарегистрировался на сайте через аффилиата B, а аффилиат B - через аффилиата A. Пусть комиссии пирамиды для 1 уровня - 10%, а для второго - 5%. Если аффилиат C получил за свои продажи 1000 руб., то аффилиат B получит дополнительно 100 руб. (1000 руб. * 10%), а аффилиат A получит дополнительно 50 руб. (1000 руб. * 5%).

Другими словами, если аффилиат Аня Телегина привела Андрея Андреева на сайт и Андрей тоже зарегистрировался как аффилиат, то Аня будет получать прибыль не только за свои продажи, но и за продажи Андрея. Сколько она будет получать за Андрея, настраивается в пирамиде в поле тарифа для 1 уровня. А то, что именно Аня привела Андрея, устанавливается в настройках аффилиата Андрея:

Создать новую пирамиду можно на странице Пирамиды (Магазин > Аффилиаты > Пирамида). Для перехода к форме создания/редактирования служит кнопка Добавить пирамиду, расположенная на контекстной панели:

В продукте реализован такой вариант пирамиды, когда аффилиат нулевого уровня получает доходы от приведенных им аффилиатов 1 уровня и т.д в процентах от прибыли этих аффилиатов. Возвращаясь к нашему примеру, Аня кроме своей прибыли будет получать еще и 4% (см. пирамиду) от прибыли Андрея.

Примечание: для каждого сайта может быть настроена только одна пирамида.

Если пирамида не заполнена или тарифы установлены в ноль, то аффилиаты будут получать прибыль только со своих продаж, т.е. многоуровневое аффилиатство использоваться не будет.


Покупатели
99 / 254
  • Список покупателей
  • Корзины
  • Счета

Список покупателей

На странице Список покупателей (Магазин > Покупатели > Список покупателей) перечислены покупатели интернет-магазина.

Вы можете просмотреть профиль покупателя либо создать на него заказ, выбрав соответствующий пункт в меню действий:

Подробно о форме просмотра профиля покупателя читайте в пользовательской документации.

Корзины

На странице Брошенные корзины пользователей администратор магазина видит корзины покупателей, в которых есть выбранный ими товар. Это может использоваться для оформления заказа по телефону, либо если покупатель по каким-либо причинам не может самостоятельно оформить заказ из товаров, которые он положил себе в корзину:

Подробно о фильтре и форме просмотра профиля покупателя читайте в пользовательской документации.

Счета

Счет покупателя - пополняемый "кошелек" пользователя в рамках магазина, с которого он может проводить расчеты с магазином по мере необходимости.

Наличие внутренних счетов пользователей позволяет сделать продажу товаров или контента с сайта более удобной. Суть работы с внутренними счетами заключается в следующем: пользователь сайта каким-либо доступным ему способом пересылает деньги фирме-владельцу сайта. Администратор сайта создает счет для этого пользователя или пополняет его той суммой, которая пришла.

Страница Внутренние счета пользователей (Магазин > Счета покупателей > Счета) содержит список внутренних счетов клиентов и отражает остаток средств на данных счетах. Создание нового счета осуществляется с помощью кнопки Добавить счет, расположенной на контекстной панели:

По нажатии на кнопку Добавить счет появляется форма создания/редактирования счета, которая имеет следующие особенности заполнения:

  • Поле Пользователь заполняется с помощью кнопки [image], по нажатии на которую появляется список всех пользователей системы, среди которых выбирается нужный.
  • Далее заполняется Сумма на счете в валюте счета.
  • В поле Заметки можно разместить произвольный комментарий к счету.
  • В поле Основание изменения суммы на счете указывается событие, в связи с которым изменяется сумма на счете.

После сохранения счет пользователя добавляется в список всех счетов пользователей сайта.

Важно! Пользователь в одной валюте может иметь только один счет.

Если появляется необходимость отредактировать счет (пополнить его новой суммой, например), то перейти к редактированию можно из меню действий, выбрав пункт Изменить параметры счета.

В момент выполнения оплаты за товар происходит автоматическая блокировка счета. После выполнения оплаты счет автоматически разблокируется. Возможна блокировка счета и с помощью API системы.

Для ручной разблокировки установите флаг в поле с названием счета и в списке действий выберите разблокировать. По нажатии кнопки Применить счет будет разблокирован:

Счета пользователей могут изменяться вручную, а могут автоматически, например, после оплаты заказа и т.д. Любое изменение счета в системе называется Транзакцией.


Транзакции
100 / 254

Транзакция - это любое изменение состояния счета, как списание со счета, так и пополнение.

Все транзакции по счетам учитываются на странице Транзакции (Магазин > Покупатели > Транзакции). Эта страница содержит список всех транзакций, выполняемых по счетам клиентов интернет-магазина, например, зачисление или списание денежных средств.

Транзакции выполняются в случае изменения внутренного счета пользователя: либо автоматическое пополнение счета, либо оплата заказа, либо ручное изменение счета. Список транзакций может пополняться как вручную по кнопке Добавить транзакцию контекстной панели, так и автоматически при перечислении денег клиентом, оплате заказа и т.д.

Форма создания транзакции имеет вид:


Продление подписки
101 / 254

На своем сайте вы можете организовать продажу любого контента (см. пример организации продажи контента на сайте). Доступ к контенту продается на определенный срок, по истечении которого в зависимости от настроек продаваемого контента продление будет проходить по-разному:

  • В случае, если в настройках продаваемого товара (подписки) на странице редактирования этого товара в разделе Торговый каталог (закладка Параметры) установлен Тип оплаты - Регулярная, заданы Длина периода и Единица времени периода и опция Продление без оформления заказа не установлена, т.е. форма имеет, например, такой вид:

    В этом случае по истечении срока подписки для ее продления будет автоматически сформирован новый заказ, будет произведена попытка оплатить его с внутреннего счета или с пластиковой карты пользователя, если на сайте имеются сведения о ней. Пользователю будет также выслано автоматически сгенерированное письмо по заданному шаблону, извещающее его о созданном заказе. И он сможет оплатить этот заказ тем же способом, что и в первый раз.
  • В случае, если в указанных параметрах установлена опция Продление без оформления заказа, то новый заказ не будет создаваться, а будет только произведена попытка оплатить подписку с внутреннего счета или по пластиковой карте пользователя. В случае неудачной попытки, продление произведено не будет, и для возобновления подписки пользователю необходимо осуществить покупку контента с сайта повторно.

Пользователь покупает подписку как обычный товар с той разницей, что в процедуре оформления заказа шаг Доставка должен быть пропущен (т.е. службы доставки не должны быть настроены):

По окончании процедуры оформления заказа он будет сформирован на странице Заказы. Когда заказ будет оплачен пользователем, администратор изменит статусы параметров заказа, с не оплачен на оплачен, и разрешит доставку. После этого новая запись появится на странице Продление подписки (Магазин > Покупатели > Продление):

На странице Продление подписки можно будет наблюдать за сроками подписок пользователей. Параметры продления подписки можно изменять вручную. Для этого служит форма редактирования параметров подписки, перейти к которой можно из меню действий по ссылке Изменить параметры продления или с помощью двойного клика по нужному элементу. Также можно добавлять продления подписки вручную с помощью кнопки Добавить запись контекстной панели.

Создадим новую подписку (подробнее об этом рассказано в примере организации продажи контента на сайте), в настройках которой указано, что продление выполняется без оформления заказа (см. выше). И после покупки пользователем этой подписки и ее автоматического продления форма редактирования продления подписки принимает вид:

Продление подписки для пользователя Даша отменено. Система продлевала подписку автоматически, списывая со счета пользователя определенные суммы за подписку. Когда денег на счету перестало хватать, продление подписки было автоматически отменено.

Дополнительная информация

  • Создание и редактирование продления подписки (документация)


Пластиковые карты
102 / 254

В системе предусмотрена возможность работы с пластиковыми картами клиентов. По умолчанию она отключена. Чтобы включить работу с пластиковыми картами, необходимо в настройках модуля Интернет-магазин отметить опцию Использовать пластиковые карты и сохранить настройки модуля:

Использование пластиковых карт может быть удобно в случае, если клиент подписывается на платную рассылку с автоматическим продлением, тогда по истечении срока использования для продления подписки с его пластиковой карты снимается определенная сумма. Разумеется, при подобной работе с пластиковыми картами необходимо максимально защищать доступ к ним посторонним лицам. Настройки безопасности работы с пластиковыми картами устанавливаются на странице настроек модуля Интернет-магазин на закладке Пластиковые карты:

  • Настройка безопасности работы с пластиковыми картами обеспечивается за счет создания уникального пароля и определения алгоритма шифрования номеров пластиковых карт. Красным цветом на форме выводится предупреждение о том, что не задан путь к файлу с паролем шифрования. Желательно, чтобы этот файл был создан и размещен вне корневого каталога сайта но так, чтобы он был доступен для чтения, например, /bitrix/modules/sale/install/data.php. В данном файле определите переменную $pwdString, значением которой должен стать пароль для шифрования номеров пластиковых карт.

    Примечание: рекомендуется использовать пароль, состоящий из букв и цифр, длиной не менее 20 символов.

    В продукте приводится пример файла с паролем (используется пустой пароль). Данный файл находится в каталоге /bitrix/modules/sale/install/data.php:

    <?
$pwdString = "";	// Please enter password as a value of this variable (at least 20 letters and digits is recommended)
?>
  • Выберите Алгоритм шифрования данных. Алгоритм RC4 не требует наличия каких-либо дополнительных модулей. Алгоритмы AES и 3DES требуют наличия PHP модуля Mcrypt.

    Примечание: алгоритмы шифрования не совместимы между собой. Поэтому нельзя выбирать другой алгоритм после начала реальной работы сайта (т.е. после появления в базе системы реальных номеров пластиковых карт).

Добавить данные о пластиковых картах в систему можно на странице Пластиковые карты (Магазин > Покупатели > Пластиковые карты). По нажатии кнопки Добавить карту, расположенной на контекстной панели, появится форма создания/редактирования следующего вида:

В данной форме редактирования определяется:

  • Пользователь, который выбирается из списка всех зарегистрированных пользователей с помощью кнопки [...].
  • Платежная система, через которую осуществляются платежи по данной пластиковой карте.
  • Тип карты и Валюта, которую можно снимать с карты.
  • Номер карты пользователя.
    • Примечание: вводимый вами номер карты будет проверен на достоверность алгоритмом, заданным для каждого типа карты (Visa, MasterCard и т.д.). То есть, номера каждого из типа карт не произвольные, а генерируются по определенному закону и если вводить произвольный набор цифр, то попытке сохранения карты будет выведено предупреждение:

  • В поле Валюта сумм указывается валюта введенных минимальной и максимальной сумм, которые можно снять с карты.


Отчеты
103 / 254

Инструмент Отчеты используется для анализа работы магазина.

Система позволяет получать статистику работы магазина в числовом и графическом виде. Эти возможности представлены в разделе Отчеты (Магазин > Отчеты). Статистика выводится по заказам и по товарам. Графики можно строить по количеству заказов и по деньгам.

Отчеты по заказам:

График по количеству:

Основной инструмент работы на этих страницах - это фильтр:

Фильтр имеет возможность:

  • Группировать выведенные заказы по временным интервалам;
  • Проводить выборку в зависимости от сайта;
  • Задавать интервал выборки.
  • Задавать показатели (для графиков).

Если у вас установлен модуль Конструктор отчетов, то у вас будет раздел Список отчетов, в котором вы можете создать типовые отчеты, нажав на кнопку Создать типовые отчеты:

В системе выводятся следующие типовые отчеты:

  • Брошенные корзины - отчет показывает список брошенных корзин магазина, упорядоченный по убыванию стоимости корзины. Отчет предназначен для менеджеров по работе с клиентами для получения списка клиентов, с которыми можно поработать.
  • Доходность по товарам - отчет показывает список товаров магазина, продажа которых принесла максимальный доход, за отчетный период.
  • Запасы товаров - отчет показывает, сколько какого товара и на какую сумму находится на складе. Отчет предназначен для анализа содержания склада и предназначен для менеджеров по управлению запасами.
  • Прайс-лист - отчет выводит список товаров с указанием цен;
  • Доходность по клиентам - по данному отчету можно оценить, какой товар и на какую сумму купил какой-либо пользователь;
  • Лучшие клиенты - отчет выводит список клиентов вашего магазина, упорядоченный по сумме доходов от покупок, которые они совершили, за отчетный промежуток времени. Отчет предназначен для менеджеров по работе с клиентами, для выделения лучших клиентов, дальнейшего их изучения и работы с ними.
  • Новые клиенты - отчет выводит информацию о количестве новых клиентов, зарегистрировавшихся в магазине, в разрезе дней, сколько заказов они сделали. Отчет предназначен для маркетологов для оценки динамики появления новых клиентов и активности новых клиентов.
  • Продажи - отчет выводит информацию по продажам, совершенным за отчетный период. Предназначен для владельцев магазинов, для оценки количества продаж, доходов и других характеристик выполненных заказов, сгруппированных по дням, неделям, месяцам, кварталам или годам.
  • Самые ожидаемые товары - отчет показывает товары, появление которых на складе ожидается наибольшим количеством клиентов магазина. Отчет предназначен для определения наиболее ценных товаров для поставки в магазин и предназначен для менеджеров по закупкам.
  • Самые просматриваемые товары - отчет показывает список товаров, которые просматривались пользователями чаще всего за отчетный период. Отчет предназначен для анализа товаров с точки зрения популярности у клиентов и конверсии просмотров товара в продажи.

Дополнительная информация

  • Отчеты (документация)


Конструктор отчетов
104 / 254

Универсальный конструктор отчетов - это отдельный модуль, который позволяет сотрудникам самим конструировать отчеты для разных объектов и в дальнейшем многократно их запускать. Отчеты изменяются в реальном времени, в зависимости от хода выполнения задач.

  • Просмотр отчетов
  • Создание нового отчета
    •

    Просмотр отчетов

    Список отчетов

    На странице Отчеты (Магазин > Отчеты > Список отчетов) представлен список всех имеющихся в системе отчетов по магазину:

    Примечание: при первом обращении к сервису отчетов система предлагает создать типовые отчеты:

    Используя меню действий, вы можете сформировать отчет, сделать его копию, отредактировать или удалить. Для просмотра отчета кликнете по ссылке с его названием.

    Примечание: перейти к просмотру отчета можно также из административного меню:

    Отчет

    Форма просмотра отчета состоит из:

    • Контекстной панели, которая позволяет вернуться к списку отчетов, сохранить отчет в виде файла .xls и перейти к редактированию настроек отчета.
    • Формы фильтра, которая служит для поиска удовлетворяющих некоторым условиям данных в отчете.
    • Таблицы с данными. Для сортировки данных отчета по какой-либо колонке достаточно кликнуть на её заголовок, после чего он изменит цвет фона. Под таблицей может быть расположена итоговая информация по всему отчету, которая подсчитывается только для численных данных.

    Создание нового отчета

    Отчет строится автоматически - достаточно его один раз создать и настроить.

    Для этого нажмите кнопку Добавить отчет на странице со списком отчетов. Появится форма для выбора базового набора полей в отчете:

    Выберите основу для построения отчета и нажмите кнопку Продолжить. Откроется форма следующего вида:

    При создании нового отчета необходимо ввести его название, выбрать магазин, для которого составляется отчет, и указать отчетный период (временной интервал, неделя, месяц и т.д.).

    Секция Колонки позволяет настроить колонки, отображаемые в отчете:

    • Опция Вычислить колонку позволяет отображать в отчете вычисленную величину, например, сумму или количество уникальных значений в колонке.

      Примечание: Вычисляемая величина зависит от конкретного типа данных.

    • Опция Группировать результаты по колонке позволяет группировать результаты отчета по данной колонке.

    • Опция Показывать итоги служит для отображения итогов по колонке.
    • Кнопки со стрелками позволяют изменить порядок следования колонок в итоговом отчете.
    • Для изменения названия колонки или же ее удаления используются соответствующие элементы управления, которые отображаются после её названия при наведении курсора.

      Примечание: Для численных типов данных доступна возможность выражать данные колонки в процентах с помощью элемента управления %:

    • Ссылка Добавить позволяет добавить в отчет новую колонку. За раз можно добавить сразу несколько колонок, отметив их в форме.
    • Опция Использовать выбор колонок с разными типами цен в отчёте позволяет только для сущности Товар динамически формировать набор колонок с разными типами цен прямо при просмотре отчета с помощью опции фильтра Выводить типы цен.

    Секция Фильтр позволяет настроить параметры фильтрации отчета:

    • Кнопки + и - позволяют добавить еще одно условие для фильтра или удалить текущее.

      При добавлении нескольких условий, над ними появится выпадающий список, который позволяет Ограничить результаты, выводимые в отчете по всем или любому из добавленных условий.

    • Кнопка И / Или позволяет построить дерево условий:

      На приведенном примере для построения отчета применится условие:
      (Статус = Выполнен и Изменил статус = Иван Петров) или (Статус = Выполнен и Разрешил отгрузку = Антон Филиппов).

      Примечание: Уровень вложенности условий искусственно ограничен 4-мя уровнями, чтобы не усложнять интерфейс.

    • Условия Фильтра зависят от базового набора полей, выбранного для построения отчета (см. выше). Например, если был выбран набор Покупатель, то поля фильтра могут быть такими:

    • Опция Изменять фильтр в отчете позволяет вывести отмеченные условия на панель фильтра и изменять их уже непосредственно при просмотре отчета.
    • С помощью соответствующей опции можно ограничить Максимальное количество элементов, выводимых в отчете.
    • С помощью соответствующей опции в отчете можно Выводить отрицательные значения красным.
    • Опция Использовать в мобильной версии делает отчет доступным для просмотра в списке отчетов в мобильном приложении.

    Конструктор имеет предварительный просмотр отчета - вы можете тут же поправить свой отчет и обновить предпросмотр.

    Опция Выводить диаграмму позволяет включить и настроить диаграммы и графики, которые будут выводиться прямо под отчетом.


Интеграция интернет-магазина с CRM
105 / 254

Установка связи между интернет-магазином и CRM позволит вашим менеджерам по продажам работать с заказами прямо из CRM корпоративного портала.

CRM-система (Customer Relationship Management) - система управления взаимоотношениями с клиентами. CRM служит для учета потенциальных и текущих клиентов, журналистов, партнеров и других «лидов». Полученные разными способами «лиды» загружаются в CRM-систему, после чего распределяются между сотрудниками, которые связываются с потенциальными клиентами и отмечают результат на портале.

Плюсы интеграции:

  • легко доступная к просмотру и редактированию полная информация по контактам и компаниям (телефоны, адреса, реквизиты, электронная почта, Skype и пр.);
  • наличие в CRM удобных инструментов ведения сделок;
  • возможность просмотра истории ведения сделки;
  • возможность производить анализ продаж благодаря наличию системы построения отчетов;
  • возможность выставления четкой системы прав на ведение сделок.

Примечание: подробнее о работе в CRM читайте в курсе Пользователь портала.


Минимальная настройка CommerceML
106 / 254

Интернет-магазин обменивается данными с CRM посредством протокола CommerceML. Возникает очень много ошибок, связанных с настройками его работы, поэтому рассмотрим некоторые рекомендации по их предотвращению.

CommerceML — единый стандарт обмена коммерческой информацией в формате XML.

Стандартом предусматривается использование схем XML, в частности для обмена:

  • каталогами товаров в системах управления каталогом;
  • коммерческими предложениями (заказами);
  • документами.

В интернет-магазине перейдите на страницу административного раздела Магазин > Настройки > Интеграция с 1С на закладку Профили обмена.

Сверьте ваши настройки с приведенными ниже.

Для физического лица

Технически обязательно только одно поле: Фамилия или Имя. В качестве типа для них можно использовать Параметр пользователя либо Свойство заказа.

Применительно к данным полям в использовании этих типов есть нюансы, которые можно использовать в организации работы магазина. Рассмотрим их:

  • При выборе типа Параметр пользователя все заказы будут добавляться в карточку этого пользователя в CRM, что бы ни указал пользователь в полях заказа при оформлении. То есть он может заказать товар для другого человека и указать этого человека в поле Контактное лицо, но в CRM товар всё равно отметится как заказ этого пользователя.
  • При выборе Свойство заказа, если данные в поле не будут совпадать, на каждый заказ будет создаваться свой пользователь. Допустим, в поле Контактное лицо указан Иванов И.И. - для него будет создан отдельный контакт в CRM. В следующем заказе указан Иванов И. - будет вновь создан новый контакт, хотя это может быть один и тот же человек. Но если в следующем заказе будет вновь указан Иванов И.И. - информация добавится в первый контакт, хотя люди могут быть разные.

Поля Название и Полное название рекомендуются к заполнению, но необязательны.

Все поля, связанные с адресом, в контакте CRM собраны в единое поле. В настройках модуля Интернет-магазин для таких полей рекомендуется использовать тип Свойство заказа, так легче отследить куда реально ушёл заказ.

Обязательно задавайте Полный адрес, если хотите, чтобы выгружались данные по адресу. Так же желательно заполнение полей Индекс, Страна, Город, Улица.

Технически не обязательно, но рекомендуется к использованию поле Контактный Email. Контактное лицо - не обязательно.

Для юридического лица

Для юридического лица обязательным является заполнение полей Название или Полное название. Однако уникальность компании проверяется по значению поля ИНН. Это значит, что система в первую очередь проверяет ИНН и добавит данные заказа именно в ту компанию, где совпадает ИНН, даже при другом значении поля Название.

И только при незаполненном поле ИНН система ищет по названию. Если название не совпало, то в CRM будет создана новая компания.

Поле КПП так же обязательно для заполнения.

Обязательно задавайте Полный адрес, если хотите, чтобы выгружались данные по адресу.

Адресные поля, как и в случае с физическим лицом, в CRM "склеиваются" в одно поле Адрес. Только таких "склеек" будет уже две: по юридическому и фактическому адресу. Поля Страна, Город и Улица рекомендуются к заполнению.

Все реквизиты компании так же соберутся в единое поле в карточке компании CRM.

В смысловом плане желательны к заполнению поля Контактный телефон и Контактный E-mail.

Примечание: Есть возможность настройки импорта произвольных реквизитов заказа из 1С. Для этого достаточно настроить поля в таблице Дополнительные параметры, расположенной ниже основной таблицы.


Настройка интеграции
107 / 254

Если у вас уже есть CRM от 1С-Битрикс, то вы можете сразу настроить интеграцию на специально для этого созданной странице административного режима Магазин > CRM:

Внимание! Если у вас нет CRM, то вы можете создать аккаунт в Битрикс24, нажав на этой же странице кнопку Получить CRM в Битрикс24 (бесплатно).

Нажмите кнопку Настроить интеграцию с CRM, возникнут поля формы настройки:

Для установки интеграции необходимо указать адрес корпоративного портала или Битрикс24, а также логин и пароль администратора CRM.

Вы можете уточнить тип протокола:

В процессе настройки интеграции автоматически создается специальный пользователь (с особыми правами), из-под которого CRM будет обращаться к интернет магазину. Однако вы можете сами ввести логин и пароль этого пользователя, сняв галочку в опции Автоматически создать пользователя и настроить права доступа (рекомендуется):

После того как вы ввели все необходимые данные, нажмите Настроить интеграцию, система проверит параметры синхронизации, страница перезагрузится, и в случае успешной интеграции вы увидите соответствующее сообщение:

Нажмите кнопку Настроить параметры и импортировать данные, и вы перейдете к интеграции со стороны CRM, где Мастер настройки автоматически возьмет все основные данные:

Нажмите Далее и вы перейдете к третьему шагу настройки:

Внимание! Если система выдает ошибку соединения, в поле Адрес интернет-магазина укажите его ip-адрес и не забудьте про порт.

Укажите параметры первичного импорта из интернет-магазина:

Внимание! Данные параметры будут применены для первого импорта, для регулярного импорта настройки будут производиться на пятом шаге Мастера.

  • Выбрать данные за последние (дней) - укажите промежуток времени, данные за который следует импортировать в CRM;
  • Вероятность сделок (%) - укажите вероятность успешного завершения сделок из первичного импорта;
  • Ответственный для новых сделок - нажмите выбрать и в структуре компании укажите сотрудника, который будет назначен ответственным за сделки, импортированные из магазина;
  • Сделки доступны для всех - оставьте галочку, если хотите, чтобы сделки по умолчанию были открытыми.

    Примечание: о том, как влияет, открыта сделка или нет, на доступ к ней, читайте в курсе Пользователь портала.

После того, как вы указали все настройки, жмите Далее, запустится первичный импорт, по окончании которого будет выведена статистика по первому импорту:

Примечание: если заказ в интернет-магазине был оформлен на физическое лицо, то в CRM автоматически будет создан контакт, если на юридическое - компания.

Нажмите Далее и вы перейдете к настройкам параметров регулярной синхронизации CRM с интернет-магазином:

Отметим те поля, которые еще не рассматривались выше:

  • Частота синхронизации - укажите в минутах промежуток между синхронизациями;
  • Направлять уведомления в группу - выберите группу, в которую будут приходить сообщения об импорте новых сделок.

Нажмите Далее, появится окно с информацией об успешной синхронизации:

Для окончания интеграции нажмите Завершить.

Вы можете посмотреть список интеграций и статистику по каждой из них на странице административной части Магазин > CRM:

Важно! Интеграция будет невозможна без наличия английского языка в административном интерфейсе интернет-магазина и CRM.

Это замечание не касается для CRM облачного Битрикс24


Примеры работы
108 / 254

В главе приводятся примеры решения задач, связанных с работой интернет-магазина.


Комментарии к товарам на основе блогов
109 / 254

В главе будет рассмотрено, как организовать и настроить работу с комментариями/отзывами для товаров интернет-магазина на основе блогов.

Ссылки по теме:

  • Блоги (курс Администратор. Модули)
  • Блоги (пользовательская документация)


Настройки
110 / 254
  • Создание блога
  • Настройка компонента

Создание блога

Для того чтобы в публичной части к товарам можно было оставлять комментарии, а в административной части, соответственно, работать с ними, необходимо создать отдельный блог для них (Сервисы > Блоги > Блоги).

Внимание! Для посетителей сайта в настройках блога обязательно должны быть установлены права на запись, чтоб они смогли оставлять комментарии.

В этом случае все зарегистрированные посетители смогут оставлять комментарии, которые сразу будут отображены на сайте.

Примечание: Подробнее про работу с блогами можно посмотреть в соответствующем уроке.

Настройка компонента

В стандартном шаблоне компонента Каталог (bitrix:catalog) существует возможность вывода в публичной части сайта формы для комментариев.

Для того чтобы форма комментариев выводилась и корректно работала, необходимо в форме настроек параметров компонента в секции Дополнительно отметить опции Включить отзывы о товаре, Использовать комментарии и указать название созданного блога соответствующем поле:

После чего в публичной части сайта станет доступна форма для комментариев/отзывов:


Работа с комментариями
111 / 254
  • Работа с комментариями
    • в публичной части сайта
    • в административной части сайта
  • Модерация комментариев

Просмотреть и отредактировать оставляемые в форме комментарии/отзывы можно как в публичной части сайта, так и в административном разделе.

Публичная часть

Для работы с комментариями в публичной части сайта необходимо перейти к желаемому товару и воспользоваться соответствующими ссылками под комментариями:

Назначение большинства ссылок понятно из названия, стоит лишь отметить, что ссылка Спам? позволяет перейти к административной части сайта, где можно ограничить доступ к сайту для посетителя, оставившего комментарий.

Административная часть

Для работы с комментариями в административной части необходимо перейти на страницу Комментарии (Сервисы > Блоги > Комментарии), на которой в списке будут отражены комментарии сразу ко всем блогам в системе:

Для того чтобы видеть все комментарии только для товаров магазина необходимо в фильтре указать идентификатор блога, в котором они и находятся:

Также, с помощью фильтра, можно указать другие параметры, по которым будут отображены комментарии в списке, например, дату создания:

С помощью пунктов меню действий списка можно Скрыть/Показать (комментарий не будет удален, но и не будет отображаться) или Удалить комментарий.
Пункты меню действий Скрыть/Показать обычно используются в случае, если для комментариев используется пермодерация.

Ссылка [стоп-лист] позволит ограничить доступ к сайту для посетителя, оставившего комментарий.

Ссылки в колонках ID и Комментарий позволяют перейти к комментарию в публичной части сайта для его просмотра или редактирования.

Модерация комментариев

Если необходимо, то для товаров можно использовать премодерацию комментариев, тогда они будут отображены на сайте только после проверки модератором.

Для этого в настройках блога необходимо установить право на запись с премодерацией:

В результате после того, как пользователь оставит комментарий, ему будет выведено сообщение, а сам комментарий отправится на премодерацию и не будет отображен на сайте:

В административной же части сайта такие комментарии будут отображаться с соответствующим статусом:

Примечание: Для того чтобы видеть только неопубликованные комментарии, можно воспользоваться соответствующим полем фильтра:

Модератор может публиковать/скрывать такие комментарии, как из административной, так и из публичной части сайта.

Примечание: Подробнее про модерацию можно посмотреть в уроке Модерация блогов.


Техподдержка на сайте
112 / 254

В примере будет рассказано, как с помощью возможностей "1C-Битрикс: Управление сайтом" организовать поддержку клиентов интернет-магазина, которая, например, невозможна или нецелесообразна по телефону. Такое решение, будет актуально для магазина, например, занимающегося продажей программного обеспечения.

  • Настройки
  • Работа с обращениями

Настройки

Для организации поддержки необходимо на сайте создать раздел/страницу и разместить на ней компонент Техподдержка (bitrix:support.ticket).

Это позволит посетителям сайта создавать обращения, а администратору работать с ними, и все прямо в публичной части сайта.

Внимание! При создании техподдержки на сайте необходимо для группы зарегистрированных пользователей (Настройки > Пользователи > Группы пользователей) для модуля Техподдержка дать право клиент техподдержки, иначе им будет недоступен интерфейс для работы с обращениями.

Работа с обращениями

Работа с обращениями, как клиентом, так и сотрудником поддержки (модератор/администратор сайта) выполняется прямо из публичного интерфейса. В списке отображаются все обращения и основная информация по ним:

Индикаторы в списке помогают визуально отличать, в каком статусе находится требуемое обращение.

С помощью фильтра можно найти требуемое обращение. При необходимости можно выбрать дополнительные параметры в фильтре, по которым можно производить поиск:

Работа с обращениями администратором производится с помощью формы, которая доступна по пункту меню Изменить списка обращений:

В верхней части формы отображается информация о пользователях, недавно просматривавших текущее обращение и информация о самом обращении. Ниже расположена сама переписка сотрудника поддержки и клиента:

Ниже располагается форма ответа, с помощью которой и происходит общение с клиентом. Помимо текста к сообщению можно прикреплять файлы.

Там же расположены элементы управления, касающиеся самого обращения. Можно указать, насколько критично обращение, оценить ответ или же закрыть обращение, если проблема решена.

Ссылки по теме:

  • Техподдержка (курс Администратор. Модули)
  • Техподдержка (пользовательская документация)


Пример организации продажи контента на сайте
113 / 254

Технология продажи контента основана на базовом принципе системы "1С-Битрикс: Управление сайтом" - разграничение прав доступа к ресурсам сайта. Для каждой группы пользователей сайта задается определенный набор прав, позволяющий членам этих групп получать доступ к той или иной информации на сайте. Посетитель, совершивший покупку какого-либо контента, добавляется в список пользователей сайта и привязывается к группе пользователей, обладающей правом доступа к платному контенту.

Таким образом, процесс продажи контента сводится к продаже прав доступа той или иной группы пользователей к содержимому сайта. Причем существует возможность продажи прав доступа как на определенный период (продажа абонемента), так и без ограничения сроков использования.

В общем случае, процесс организации продажи контента на сайте может быть описан следующей последовательностью операций:

  • создание группы пользователей, обладающей правами доступа к необходимым ресурсам сайта;
  • настройка возможностей продажи прав доступа этой группы;
  • создание и соответствующая настройка торгового каталога для продажи контента;
  • настройка Интернет-магазина;
  • размещение предлагаемых товаров (контента) в Публичном разделе сайта;
  • получение и обработка заказов покупателей.

В качестве примера рассмотрим организацию продажи подписки к подробному содержанию статей.


Создание группы пользователей
114 / 254

Продажа контента основана на распределении прав доступа, поэтому сначала необходимо создать группу, например с названием Подписчики, права которой будут продаваться. Механизм создания групп описан в курсе Администратор. Базовый.

Пользователям группы Подписчики будет предоставлен доступ только к информации в Публичном разделе сайта, поэтому значения полей в закладке Доступ формы создания группы следует оставить равными <по умолчанию>.

В настройках модуля Торговый каталог, на закладке Продажа прав отметьте группу Подписчики как группу, получение прав которой может продаваться:


Создание типа инфоблока и инфоблоков
115 / 254

Информация платного контента (статьи) и каталог предоставляемых услуг доступа (подписка на доступ к статьям) создаются на основе инфоблоков.

Создание типа инфоблока

Прежде чем создавать такие информационные блоки, необходимо создать новый тип инфоблоков (например, Платный контент).

Создание инфоблока для контента

Далее необходимо создать информационный блок, например Платные статьи. В этом информационном блоке будут храниться элементы (статьи), доступ к подробному содержанию которых будет платным.

Примечание: в полях формы создания инфоблока определяется раздел, в котором будут храниться страницы визуального просмотра (например, /e-store/paid/).

Добавление элементов контента

Наполните инфоблок статьями - контентом, который вы будете продавать. Создавать статьи можно из административной части, но в большинстве случаев созданием этих статей будет заниматься контент-менеджер, а не администратор. Поэтому будет рассмотрен вариант создания статей из публичной части.

Создание инфоблока для продажи контента

Чтобы предоставить посетителям возможность совершать покупку прав доступа к платным разделам вашего сайта, нужно:

  • создать каталог предоставляемых услуг доступа;
  • настроить каталог услуг на использование в качестве торгового каталога для продажи контента.

Создайте инфоблок типа Платный контент с названием Продажа подписки на доступ к платным статьям.

Настройте созданный информационный блок на работу в режиме торгового каталога с возможностью продажи контента, откройте страницу настроек модуля Торговый каталог (Настройки > Настройки продукта > Настройки модулей > Торговый каталог) на закладке Каталоги.

Установите флаги в поля Является торговым каталогом и Продажа контента, расположенные напротив инфоблока Продажа подписки на доступ к платным статьям.

Создание элементов инфоблока для продажи контента

Создание элементов инфоблока Продажа подписки на доступ к платным статьям лучше выполнить администратору, так как они не будут постоянно меняться и их будет совсем немного. Создавать их можно и из административной части. Основная сложность - это настройка цен. Приведем пример создания элемента этого инфоблока.

  • Откройте форму создания элемента этого инфоблока. Укажите название подписки (например, Подписка на 1 месяц), в группе параметров Торговый каталог укажите базовую цену, розничную, и выберите валюту базовой цены:

  • Включите режим расширенного управления ценами (поле Использовать расширенный режим управления ценами). Заполните поля закладки так, чтобы действовала скидка при подписке более чем на 6 месяцев:

    Аналогично установите цены для розничного типа цен.

  • Откройте закладку Параметры, в которой имеется секция Параметры подписки. Поля этой секции служат для задания параметров подписки на доступ к контенту сайта:

    • В поле Тип оплаты необходимо выбрать, какой тип оплаты будет использоваться:
      1. Одноразовая – означает, что товар приобретается покупателем один раз. В дальнейшем никаких движений по приобретенному товару не предусматривается.
      2. Регулярная (или подписка) – означает, что по истечении заданного периода времени покупателю будет выставлен новый счет на продление использования товара (в примере используется этот вариант).
      3. Пробный период – предусматривает приобретение пробной версии товара (например, пробного доступа). По истечении указанного периода покупателю будет выставлен счет на покупку полной версии товара.
    • В поле Длина периода оплаты указывается длительность периода времени, по истечении которого системой будет выставлен новый счет на приобретение товара. Значение поля задается для неодноразовых типов оплаты (регулярная и пробный период).
    • Единица времени периода оплаты – определяются единицы времени, используемые для задания продолжительности периода оплаты (месяц, сутки, час и т.д.).
    • В поле Пробная для (заполняется только для пробных) указывается полная версия товара. По истечении пробного периода пользователю будет предложено приобрести указанный товар (полную версию).
    • Продление без оформления заказа – если опция выбрана, то при продлении товара (пользования товаром) будет рассчитана сумма заказа, но сам заказ не будет сформирован в базе системы. Данная опция может быть полезна при проведении небольших регулярных списаний с внутреннего счета покупателя.
  • Перейдите на закладку Группы. Она служит для определения группы, к которой будет приписан пользователь, купивший подписку на платный контент. Если подписка на доступ к платному контенту осуществляется на определенный срок, то в поле Длительность приписывания нужно задать необходимый период. По истечении указанного периода пользователь будет удален из группы, обладающей доступом к контенту.

Повторяя операции по добавлению элемента в инфоблок, добавьте подписки на 6 и 12 месяцев. В итоге список элементов инфоблока Продажа подписки на доступ к платным статьям будет следующим:


Создание публичного интерфейса каталога
116 / 254

Размещение контента

Размещение информационного блока Платные статьи в Публичном разделе сайта осуществляется с помощью визуального редактора и компонентов модуля Информационные блоки.

Для вывода платных статей должны быть созданы следующие страницы:

  • со списком статей;
  • детального просмотра.

Создание страницы со списком статей

  • Создайте раздел /e-store/paid/ на сайте.
  • На индексной странице раздела разместите компонент Список новостей (Компоненты > Контент > Новости > Список новостей). Этот компонент выводит анонсы всех элементов инфоблока, которые используются для перехода на страницу детального просмотра независимо от прав пользователя.
  • В свойствах компонента укажите тип инфоблока Платный контент, код инфоблока Платные статьи, а также путь к странице детального просмотра detail.php:

Создание страницы детального просмотра новостей

На данной странице необходимо разместить компонент Новость детально, с помощью которого осуществляется детальный показ элемента инфоблока.

  • Создайте страницу detail.php в разделе /e-store/paid/.
  • В теле страницы разместите компонент Новость детально (Компоненты > Контент > Новости).
  • Настройте компонент:
    • В свойствах компонента укажите тип инфоблока Платный контент, код инфоблока Платные статьи, а также путь к странице со списком элементов (статей) index.php.
    • Отметьте опцию Устанавливать заголовок страницы. В этом случае в качестве заголовка страницы будет установлено название статьи.
  • Чтобы только Подписчики имели возможность детального просмотра элементов платного контента, необходимо провести следующие настройки компонента:
    • В группе Дополнительные настройки отметьте опцию Использовать дополнительное ограничение доступа. Появится список групп пользователей, которым можно назначить доступ к детальной информации.
    • В этом списке отметьте группу Подписчики:

Наполнение контентом

После создания публичного интерфейса контент-менеджер может приступать к наполнению сайта платным контентом через публичный интерфейс.

Рекомендуется настроить форму добавления статей для удобства работы контент-менеджера.

Если контент-менеджеров несколько и каждый из них отвечает за собственный раздел платного контента, настройте права доступа в расширенном режиме к нужным разделам.

Размещение каталога для покупки статей

Чтобы пользователи могли осуществить покупку подписки на доступ к платному контенту, необходимо настроить вывод каталога подписок в публичном разделе сайта. Например, можно опубликовать каталог во включаемой области раздела Платный контент (/e-store/paid/). Для этого:

  • Создайте файл sect_inc.php в разделе /e-store/paid/ по шаблону Включаемая область для раздела:

  • Разместите в файле компонент Элементы раздела (Компоненты > Контент > Каталог), который выводит элементы раздела каталога. В настройках компонента укажите тип инфоблока: Платный контент, инфоблок Продажа подписки на доступ к платным статьям. В группе параметров Цены укажите тип цены Розничная цена.
  • Чтобы после списка товаров отображалась ссылка на корзину, добавьте компонент Ссылка на корзину (bitrix:sale.basket.basket.line). С помощью этого компонента отображается информация о количестве товаров в корзине и ссылка на персональный раздел покупателя.

В результате выполненных действий индексная страница раздела Платный контент будет иметь следующий вид:

Пользователи группы Подписчики имеют право перейти к странице детального просмотра. Для остальных пользователей при попытке перейти к детальному просмотру будут выведены сообщение о запрете доступа и форма авторизации.


Создание персонального раздела
117 / 254

С помощью визуальных компонентов, расположенных в разделах Компоненты > Магазин > Персональный раздел и Компоненты > Магазин > Процедура оформления заказа, могут быть созданы страницы, на которых покупатель сможет просмотреть содержимое своей корзины, информацию о своих заказах, состоянии своего внутреннего счета, профилях, а также параметры очередного платежа по товарам.

Примечание: Примеры страниц для персонального раздела доступны в каталоге /bitrix/modules/sale/install/public/ дистрибутива продукта.

Переход на страницу просмотра содержимого корзины можно выполнить по ссылке на корзину или по кнопке Купить, расположенной рядом с товаром (подпиской). Именно с этой страницы вы можете приступить к процедуре оформления заказа (кнопка Оформить заказ).

Процедура оформления заказа

Чтобы посетитель имел возможность оформить заказ на выбранные товары, необходимо выполнить следующее:

  • Создайте новую страницу в необходимом вам разделе сайта.
  • В теле страницы разместите компонент Процедура оформления заказа (bitrix:sale.order.full).
  • Проведите настройку параметров компонента.
Внимание! Путь к созданной странице должен быть задан в настройках компонента Корзина (страница с содержимым корзины пользователя).

В результате выполненных действий в публичной части страница оформления заказа будет иметь следующий вид:


Настройка интернет-магазина
118 / 254

Процедуры продажи и оплаты контента, а также процедура обработки заказа выполняются с помощью средств модуля Интернет-магазин. Поэтому настройка параметров данных операций осуществляется на страницах модуля Интернет-магазин.

Примечание: Проведение настроек Интернет-магазина (типов плательщиков, платежных систем, пластиковых карт и т.д.) подробно описано выше. Здесь рассматривается только настройка прав на работу с заказами.

Права на работу с заказами

В рассматриваемом примере обработкой и управлением заказами будут заниматься сотрудники с правами Обработка заказов. Данный уровень прав позволяет им осуществлять обработку заказов, но запрещает доступ к управлению любыми настройками модуля Интернет-магазин.

Настройка групп на работу с заказами осуществляется на странице настроек модуля Интернет-магазин: Настройки > Настройки продукта > Настройки модулей > Интернет-магазин, на закладке Права на заказы:

Выберите группу пользователей, которая будет иметь доступ к управлению заказами сайта. Например, Администраторы интернет-магазина.

Примечание: пользователям этой группы должно быть предварительно поставлено право Обработка заказов на доступ к модулю Интернет-магазин:

Примечание: Если сайтов несколько, то для каждого сайта может быть выбрана своя группа пользователей, обладающая доступом к обработке заказов.

Статусы заказов

Информирование клиентов и сотрудников Интернет-магазина о текущем состоянии заказа осуществляется с помощью статусов заказа. В системе предусмотрено два вида статусов:

  • Статусы-состояния – предустановлены в системе и отражают текущее состояние заказа: Оплачен, Отменен, Разрешен к доставке.
  • Информационные статусы – отражают этапы, через которые проходит заказ во время обработки. Список всех информационных статусов представлен на странице Статусы заказов.

Управлять заказами будут сотрудники, относящиеся к группе Администраторы интернет-магазина, поэтому для них необходимо настроить права на доступ к различным статусам заказа. Настройка доступа выполняется на странице Статусы заказа: Магазин > Настройки > Статусы.

Для каждого статуса выполните следующие действия:

  • Откройте форму редактирования (пункт Изменить в Меню действий)
  • В группе параметров Права на доступ отметьте возможности, которыми должны обладать пользователи группы Администраторы интернет-магазина в данном статусе заказа:

После выполнения всех настроек пользователи группы Администраторы интернет-магазина смогут осуществлять управление заказами сайта, находящимися в любом статусе.


Интеграция с 1С
119 / 254

В главе рассматриваются вопросы интеграции продуктов 1С-Битрикс с продуктами компании 1С и способы диагностики при проблемах с интеграцией.

Примечание: В структуре сайтов компании 1С-Битрикс есть сайт, созданный специально для тех, кто занимается интеграцией наших продуктов с продуктами 1С. На этом сайте можно узнать об обновлениях функционала, планах развития и другую информацию.

Помните, что в "1С-Битрикс: Управление сайтом" и 1С некоторые сущности называются по разному:

  • контрагенты - это пользователи;
  • справочники - это highload инфоблоки;
  • номенклатура - это товары.

Примечание: в данной главе приведено описание интеграции с 1С:Управление торговлей ред. 10.3 и 11.1. Если вы используете 1С:Управление торговлей ред. 11.0, то описание интеграции смотрите в главе Дополнительно.

Список ссылок по теме:

  • Описание протокола выгрузки товарной номенклатуры
  • Описание протокола обмена заказами
  • Описание формата CommerceML
  • Форум Интеграция с 1С
  • Как сэкономить на месте и ускорить выгрузку из 1С
  • Как мы разрабатывали интеграцию интернет-магазина с 1С: Предприятие
  • Как мы разрабатывали интеграцию интернет-магазина с 1С: Предприятие. Часть 2
  • Настройка 1С для выгрузки в bitrix с товарными предложениями (блог)
  • Обобщение опыта работы с клиентами, заказывающими интеграцию с 1С (блог)
  • Расширяем функционал обмена заказами между 1С-Битрикс и 1С Предприятие УТ 11 (блог)
  • Пример XML-файла обмена данными (для старой версии модуля обмена) (форум)


Зависимость версий
120 / 254

Типовая конфигурация продукта 1С:Предприятие, ред. Управление торговлей имеет встроенные механизмы для обмена данными с сайтом, разработанном на платформе 1С-Битрикс: Управление сайтом. Улучшить возможности обмена можно с помощью установки дополнений.

Важно! Новый модуль обмена 4.х.х.x можно использовать только при выполнении следующих двух условий: 1С-Битрикс: Управление сайтом обновлен до версии 14.5 (или выше) и 1С:Управление торговлей версии 10.3 или 11.1.

В таблице представлены самые последние версии модулей обмена, которые можно установить в 1С, с учетом зависимости от версии 1С-Битрикс: Управление сайтом:

 | 1С:УТ 10.3.29.1 | 1С:УТ 11.1.2.31 | 1С:УТ 11.1.7.54 | 1С:УТ 11.1.9.61 | 1С:УТ 11.1.10.86
БУС версии ниже 14.5 | дополнение 10.3.26.4 | дополнение 3.1.2.31 | дополнение 3.1.2.31 | дополнение 3.1.2.31 | дополнение 3.1.2.31
БУС версии 14.5 и выше | модуль обмена 4.0.5.1 дополнение 10.3.26.4 | модуль обмена 4.0.5.1 дополнение 3.1.2.31 | модуль обмена 4.0.4.2 дополнение 3.1.2.31 | модуль обмена 4.0.5.2 дополнение 3.1.2.31 | модуль обмена 4.1.0.1 дополнение 3.1.2.31

Примечание: если у вас более ранние версии продуктов 1С:УТ и/или 1С-Битрикс: Управление сайтом и нет возможности обновится, то для обмена данными следует использовать старые дополнения или возможности типовой конфигурации 1С.

В этом случае часть имеющегося на текущий момент функционала по обмену данными будет вам недоступна.


Установка модуля обмена 4.х
121 / 254

В данном уроке рассмотрим порядок установки модуля обмена 4.x в 1С: Предприятие.

  • Установите скачанный дистрибутив модуля обмена согласно прилагаемой к нему инструкции (предварительно убедившись, что скачанная вами версия модуля соответствует версиям ваших продуктов).
  • Запустите систему 1С:Предприятие в режиме Конфигуратор.
  • Сделайте архивную копию информационной базы. Для этого в меню Администрирование выберите пункт Выгрузить информационную базу:

    Затем в открывшемся диалоге укажите имя файла, в который будут записаны данные.
  • Откройте конфигурацию (Конфигурация > Открыть конфигурацию).
  • Включите возможность изменения объектов конфигурации (Конфигурация > Поддержка > Настройка поддержки, в открывшемся окне нажмите кнопку Включить возможность изменения).
  • В окне Настройка правил поддержки выберите дважды Объект поставщика редактируется с сохранением поддержки и нажмите кнопку ОК:

  • Сохраните конфигурацию.
  • В редакции Управление торговлей версии 10.3 (для 1С:УТ версии 11.1 и 1С:УНФ этот шаг пропускается) необходимо установить для конфигурации режим совместимости Не использовать. Устанавливается режим совместимости в свойстве конфигурации(в дереве конфигурации нужно выбрать пункт Конфигурация, нажать на правую кнопку мыши и выбрать пункт Свойства - в самом конце свойств устанавливается режим совместимости. Режим совместимости необходимо снять из-за того, что используется функционал, который на старых версиях платформы 1С не поддерживается.

  • Вызовите режим Сравнить, объединить с конфигурацией из файла из меню Конфигурация. В этом режиме будут показаны только различающиеся объекты дополнения и используемой конфигурации, поэтому полностью идентичные объекты могут отсутствовать в окне сравнения-объединения. Также может отсутствовать флажок включения таких объектов в объединение.
  • В диалоге выбора указать файл конфигурации XXX.cf. По умолчанию он лежит по следующему адресу: C:\Users\...\AppData\Roaming\1C\1Cv82\tmplts\1С-Битрикс\ОбменССайтом\(конфигурация 1С).
  • Исключить из объединения все объекты конфигурации.
  • Нажмите кнопку Действия, затем Отметить по подсистемам файла. Установите флажок напротив пункта Битрикс и нажмите кнопку Установить:

  • Включите в объединение (установите флажок) подсистему Битрикс (для 1С:УТ версии 10.3: Конфигурация > Общие > Подсистемы > Битрикс, для 1С:УТ версии 11.1: Конфигурация > Общие > Подсистемы > Администрирование > Битрикс, для 1С:УНФ: Конфигурация > Общие > Подсистемы > НастройкаИАдминистрирование > Битрикс):

  • Выполните сравнение и объединение конфигураций (кнопка Выполнить).
  • Сохраните конфигурацию и обновите конфигурацию базы данных.
  • Рекомендуется запустить 1С с параметром ЗапуститьОбновлениеИнформационнойБазы для того, чтобы 1С заполнил все служебные данные в 1С. Запуск с параметром осуществите через командную строку или из конфигуратора.
    • чтобы запустить из командной строки, укажите следующие параметры:

      "<Адрес к 1cv8.exe>" ENTERPRISE (/F или /S в зависимости от типа базы) ""<Адрес к базе> " /N"<Логин>" /P"<Пароль>" /C ЗапуститьОбновлениеИнформационнойБазы
    • чтобы запустить из конфигуратора, откройте Сервис > Параметры. На вкладке Запуск 1С:Предприятия укажите параметр запуска:

    Из конфигуратора запустите: Отладка > Начало отладки. После обновления информационной базы 1С нужно очистить этот параметр запуска, чтобы он каждый раз не запускался.


Настройки со стороны "1С-Битрикс: Управление сайтом"
122 / 254

Чтобы иметь возможность осуществлять обмен данными с 1С:Предприятие, сначала необходимо со стороны 1С-Битрикс: Управление сайтом настроить на корректную работу модуль Интернет-магазин и сам интернет-магазин.

Подробно о том, как произвести эти настройки, читайте в разделе Настройка Интернет-магазина.

Важно! Установка и настройка модуля Интернет-магазин возможна только при наличии установленного модуля Валюты. Кроме того, в системе должна быть задана хотя бы одна валюта. Удаление модуля Валюты при наличии установленного модуля Интернет-магазин невозможно.

Дополнительная информация

  • Интеграция с 1С (документация)


Форма "Интеграция с 1С"
123 / 254

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
Настройки подключения к 1С

Настройка интеграции с 1С:Предприятие выполняется на странице Магазин > Настройки > Интеграция с 1С:

Параметры по умолчанию в данной форме будут приемлемы для большинства пользователей. Поясним некоторые настройки данной формы.

На закладке Каталог представлены настройки, которые используются при выгрузке каталога товаров из 1С на сайт.

  • Тип инфо-блока – указывается тип инфоблока, в который будут выгружаться товары из 1С.

    Примечание: товары из 1С могут быть выгружены в инфоблок другого типа, если на сайте уже имеется инфоблок, идентификатор которого совпадает с заданным идентификатором в файле импорта каталога.

    Чтобы импорт осуществлялся именно в указанный тип инфоблока, необходимо отметить опцию При выгрузке учитывать тип инфоблока (см. секцию Расширенные настройки).

  • Разрешить загрузку группам пользователей – задаются группы, пользователи которых смогут выполнить загрузку каталога на сайт.
  • Загружать торговые предложения (характеристики) в отдельный инфоблок – при отмеченной опции информация о самих товарах и предложения на товары (т.е. характеристики и цены) будут храниться в двух разных информационных блоках.

    Примечание: если у товаров нет предложений, то опцию отмечать не нужно. Если же товары имеют по несколько предложений, то опция должна быть отмечена обязательно, иначе предложения не будут выгружены.
  • Использовать контрольные суммы элементов для оптимизации обновления каталога – опция включает механизм, суть которого в том, что даже если на сайт выгружен полный каталог, будут модифицированы только изменившиеся элементы. Это позволяет значительно снизить нагрузку на сервер, а также значительно сокращает время выполнения процедуры обновления.
  • Цены только в инфоблоке предложений – данная опция имеет смысл, если некоторые ваши товары выгружаются без характеристик:
    • если опция отмечена, то при выгрузке товаров из 1С, цены на товары будут храниться в торговых предложениях. Т.е для каждого товара будет создано 1 торговое предложение, в котором и будет храниться цена;
    • если опция не отмечена, то для выгруженных из 1С товаров торговые предложения создаваться не будут, цена будет храниться в самом товаре.
    Для тех товаров, у которых есть характеристики, будут созданы торговые предложения в соответствии с количеством характеристик и цены будет храниться в этих торговых предложениях.

    Хранение самих торговых предложений определяется опцией Загружать торговые предложения (характеристики) в отдельный инфоблок.

  • Автоматически генерировать картинку анонса и Изменять детальную картинку – при отмеченных опциях в системе 1С-Битрикс на основании изображений, которые поступают из 1С, будет самостоятельно генерироваться картинка анонса и детальная картинка в соответствии с настройками максимальной ширины и высоты картинки. Это позволяет предотвратить поступление из 1С больших неподготовленных изображений.

Кроме того, необходимо создать бюджет пользователя, которому будет разрешено совершать обмен данными. Т.е. пользователь должен относится к одной из групп пользователей, выбранных в поле Разрешить загрузку группам пользователей настроек импорта каталога (и/или в поле Группы, пользователям которых разрешена выгрузка настроек выгрузки заказов).

Примечание: бюджет администратора сайта может использоваться для обмена данными только в том случае, если группа Администраторы отмечена в списке Разрешить загрузку группам пользователей и/или в списке Группы, пользователям которых разрешена выгрузка.

На закладке Экспорт каталога настраиваются параметры экспорта каталога товаров с сайта в 1С:Предприятие:

В поле Инфоблок каталога указывается инфоблок, товары из которого должны быть выгружены в 1С. Осуществлять выгрузку товаров смогут пользователи тех групп, которые отмечены в поле Разрешить выгрузку группам пользователей.

На закладке Заказы настраиваются параметры обмена заказами сайта и 1С:

С помощью параметров, расположенных на данной закладке, вы можете указать, откуда загружать заказы в 1С: с определенного сайта либо со всех. Поскольку 1С-Битрикс: Управление сайтом является многосайтовой системой, то вы можете создать несколько магазинов и обрабатывать все заказы в одной системе 1С. В тоже время возможно заказы различных сайтов выгружать в разные учетные системы.

Используя параметры Выгружать только оплаченные заказы, Выгружать только заказы с разрешенной доставкой и Выгружать заказы начиная со статуса, можно задать условия по заказам для выгрузки, т.е. выгружать заказы, удовлетворяющие заданным условиям.

Опция Менять статусы заказов по информации из 1С позволяет настроить автоматическую смену статусов заказов в соответствии с получаемой информацией из 1С при выполнении обмена данными.

Кроме того, в процессе выполнения обмена заказами можно загрузить на сайт новые заказы и контрагенты из 1С. Для этого следует отметить соответствующую опцию Создавать новые заказы и контрагенты из 1С и в поле Сайт, на который добавлять новые заказы и контрагенты указать сайт, на котором эти заказы и контрагенты будут созданы.

В поле Группы, пользователям которых разрешена выгрузка должны быть выбраны группы пользователей, которые будут обладать правом на выгрузку заказов в 1С.

Обмен заказами с 1С выполняется пошагово в соответствии с заданным интервалом одного шага и размером единовременно загружаемой части файла.

На закладке Профили обмена для каждого типа плательщика настраиваются поля экспорта заказов, которые будут переданы в 1С:

Пример настройки профилей обмена можно посмотреть в уроке Минимальная настройка CommerceML.

Более подробная информация по настройкам формы Интеграция с 1С представлена в документации по продукту.


Собственные настройки интеграции
124 / 254

Если вам необходимо выполнять обмен данными с одного продукта 1С-Битрикс: Управление сайтом, но с разными настройками обмена, то для этого следует создать собственные страницы с настройками импорта, экспорта каталога и обмена заказами.

Настройка параметров импорта каталога

  • Создайте новую страницу, например, с именем catalog_import.php и разместите на ней компонент Импорт каталога из 1С (bitrix:catalog.import.1c) (Контент > Каталог > Импорт каталога из 1С).
  • Настройте необходимым вам образом параметры компонента. Параметры компонента аналогичны параметрам формы Интеграция с 1С.
  • Настройте права доступа групп пользователей к данной странице.

    Для групп пользователей, которым разрешено выполнять импорт каталога, уровень доступа должен быть не ниже, чем Чтение. В целях безопасности для остальных групп пользователей доступ к странице необходимо закрыть.

В дальнейшем, когда будут выполняться настройки со стороны 1С:Предприятие, в профиле настройки выгрузки товаров из 1С необходимо будет указать путь к данной странице. Смотри урок Шаг 2.

Настройка параметров экспорта каталога с сайта

  • Создайте новую страницу, например, с именем catalog_export.php и разместите на ней компонент Экспорт каталога в 1с (bitrix:catalog.export.1c) (Контент > Каталог > Экспорт каталога в 1с).
  • Настройте необходимым вам образом параметры компонента. Параметры компонента аналогичны параметрам формы Интеграция с 1С.
  • Настройте права доступа групп пользователей к данной странице.

    Для групп пользователей, которым разрешено выполнять экспорт каталога, уровень доступа должен быть не ниже, чем Чтение. В целях безопасности для остальных групп пользователей доступ к странице необходимо закрыть.

В дальнейшем, когда будут выполняться настройки со стороны 1С:Предприятие, в мастере загрузки товаров необходимо будет указать путь к данной странице. Смотри урок Экспорт каталога с сайта в 1С.

Настройка параметров выгрузки заказов

  • Создайте новую страницу, например, с именем orders_export.php и разместите на ней компонент Экспорт заказов в "1С:Предприятие" (bitrix:sale.export.1c) (Магазин > Экспорт заказов > Экспорт заказов в "1С:Предприятие").
  • Настройте параметры необходимым для вас образом. Все параметры аналогичны параметрам обмена заказами формы Интеграция с 1С. Небольшое отличие - это отсутствие в компоненте параметров Префикс номера заказа при выгрузке и Статус, в который переводить заказ при получении отгрузки от "1С:Предприятие".
  • Настройте права доступа групп пользователей к данной странице.

    Для групп пользователей, которым разрешено выгружать заказы, уровень доступа должен быть не ниже, чем Чтение. В целях безопасности для остальных групп пользователей доступ к странице необходимо закрыть.

В дальнейшем, когда будут выполняться настройки со стороны 1С:Предприятие, в профиле настройки обмена заказами необходимо будет указать путь к данной странице. Смотри урок Шаг 2.


Интеграция с "1С:Управление торговлей" ред. 10.3
125 / 254

Начиная с версии продуктов 1С:Предприятие 8.1, редакция Управление торговлей (версия 10.3.2.4) и 1С-Битрикс: Управление сайтом версии 6.5 (редакции Малый бизнес, Бизнес) поставляются со встроенными процедурами взаимодействия.

Для реализации обмена данными с сайтом в 1С:Предприятие следует выполнить необходимые настройки обмена:

  • Если у вас обновлена редакция 1С, а также обновлен 1С-Битрикс: Управление сайтом до версии 14.5 или выше, то вы можете установить новый модуль обмена и иметь более расширенный функционал по обмену данными. В этом случае описание настроек смотрите в главе С модулем обмена.
  • Если у вас нет возможности обновить 1С и/или 1С-Битрикс: Управление сайтом, то для обмена данными следует использовать возможности типовой конфигурации 1С или имеющегося установленного дополнения. В этом случае описание настроек смотрите в главе Без модуля обмена.


С модулем обмена
126 / 254

В данной главе описаны возможности интеграции 1С:Предприятие, в которой установлен модуль обмена 4.0.х.х, и 1С-Битрикс: Управление сайтом, обновленного до версии 14.5.0 или выше.


Узлы обмена с сайтами
127 / 254

Настройки обмена с сайтами задаются в плане обмена Обмен с WEB-сайтом. Зайти в настройки можно следующим способом (Операции > Планы обмена > Обмен с WEB-сайтом):

Откроется список узлов обмена. В списке всегда есть предопределенный узел обмена, который нельзя использовать. Он с незаполненным наименованием.

При нажатии на кнопку Операции отобразится меню со следующими пунктами:

  • Выполнить обмен данными - будет выполнен обмен данными для выбранного в списке узла.
  • Открыть список изменений - для выбранного в списке узла обмена откроется форма, в которой можно просмотреть все зарегистрированные изменения узла, очистить или добавить новые изменения.
  • Редактировать коды Битрикс у объектов 1С - при нажатии на этот пункт меню откроется окно, в котором можно посмотреть и, при необходимости, отредактировать коды загруженных с сайта данных. Кроме того, для еще незагруженных элементов можно указать коды сайта, чтобы при загрузке данных модуль обмена не создавал новые объекты, а находил их по коду сайта.
  • Задать расписание для обмена в режиме реального времени - этот пункт меню активен только тогда, когда 1С работает в клиент-серверном варианте. При нажатии на этот пункт меню откроется окно настройки расписания регламентного задания, которое будет работать постоянно и принимать в режиме реального времени команды с сайта.
  • Загрузить номенклатуру с сайта - откроется мастер импорта каталога товаров с сайта.
  • Импорт настроек из справочника "Настройки обмена с WEB-сайтом" - произойдет импорт настроек обмена с сайтом из справочника Настройки обмена с WEB-сайтом. Использование данной возможности целесообразно в начале использования модуля обмена для переноса настроек. Поиск ведется по наименованию.
  • Установка соответствий платежных систем и касс - откроется регистр сведений, в котором можно загрузить с сайта платежные системы и установить соответствие с кассами, чтобы при автоматическом создании ПКО касса подставлялась в зависимости от платежной системы.
  • Открыть лог - откроется файл с логами обмена для выбранного узла за указанную дату..

Кнопка Запустить обмен в режиме реального времени служит для запуска режима, в котором сеанс 1С постоянно мониторит команду с сайта. В этом режиме сеанс 1С будет недоступен для работы. Для разблокировки необходимо нажать комбинацию клавиш Ctrl + Break. Кнопка активна только для файлового варианта работы 1С.

При нажатии на кнопку Перейти отобразится всплывающее меню, с помощью которого можно перейти в служебный регистр сведений Пакетный Обмен для CMS 1С-Битрикс В нем хранятся выгружаемые пакеты. Они хранятся до тех пор, пока сайт не загрузит их.

Форма создания/редактирования узла обмена имеет следующий вид:

Примечание: перечень параметров формы зависит от версии установленного модуля обмена.

Версионность параметров закладки "Основные"

Поле | С версии
Обмен товарами | 4.0.0.1
Обмен заказами | 4.0.0.1
Обмен пользовательскими справочниками | 4.0.0.1
Используется в режиме реального времени | 4.0.0.1
Режим обмена:
  • Полная выгрузка
  • Только изменения
4.0.0.1
Настройка версионности выгружаемых данных | 4.0.2.1
Тип обмена данными:
  • Выгружать на сайт
    • Адрес сайта
    • Пользователь
    • Пароль
  • Выгрузка в каталог
    • Каталог выгрузки
    • Файл загрузки заказов
4.0.0.1
Каталог лога | 4.0.0.1
Выгружать лог на сайт | 4.0.0.1
Хранить файлы обмена на сайте | 4.0.1.1
Число повторов при неудачно отправленных пакетах | 4.0.0.1
Тайм-аут между повторами неудачно отправленных пакетах | 4.0.0.1
Продолжить отправку неудачно закончившихся пакетов при следующем обмене | 4.0.0.1
Использовать периодический обмен данными | 4.0.0.1

На закладке Основные задаются базовые настройки параметров обмена. Наличие других закладок в форме зависит от выполненных основных настроек.

Заполните поле Наименование, поле Код заполнится автоматически.

Главные опции обмена:

  • Отмеченная опция Обмен товарами означает, что должны выгружаться товары и информация по ним. При этом появляется соответствующая закладка Обмен товарами.
  • При отмеченной опции Обмен заказами с сайта будут выгружаться заказы в 1С и из 1С загружаться на сайт. При установке флажка появляется соответствующая закладка Обмен заказами.
  • Установленный флажок Обмен пользовательскими справочниками означает, что должны выгружаться пользовательские справочники из 1С, при этом появляется соответствующая закладка Обмен польз. справочников.
  • Отмеченная опция Используется в режиме реального времени означает, что настройка обмена используется при обмене в реальном времени.

    Важно!
    1. Только для заказов может осуществляться обмен в режиме реального времени.
    2. Только в одной настройке может быть отмечена опция Используется в режиме реального времени.

В поле Режим обмена определяется как должен выполняться обмен данными:

  • если выбрана Полная выгрузка, тогда выгружаться из 1С будут все данные, удовлетворяющие заданным отборам. Если данных в базе много, то обмен может выполняться продолжительное время.
  • При отмеченной опции Только изменения будут выгружаться только те данные, которые изменились. В этом случае скорость обмена существенно повышается.

По кнопке Настройка версионности выгружаемых данных открывается специальное окно. Оно служит для выбора объектов, для которых необходимо указать, что их версия всегда новая (т.е. он всегда будет участвовать в обмене) вне зависимости от того, изменился ли объект в 1С или нет.

Поле Тип обмена данными:

  • При выборе опции Выгрузка на сайт данные будут выгружаться на сайт, настройки подключения к которому задаются в соответствующих полях:
    • Адрес сайта – адрес вашего сайта, содержащий путь до файла /bitrix/admin/1c_exchange.php (либо путь к странице с собственными настройками интеграции, см. урок Собственные настройки интеграции).
    • Пользователь – логин пользователя сайта под управлением 1С-Битрикс: Управление сайтом. Пользователь должен обладать правом на выполнение обмена данными, т.е. пользователь должен относиться к группе, указанной в настройках интеграции.
    • Пароль – пароль пользователя.
    При нажатии на кнопку Проверить, происходит проверка подключения к сайту.
  • Если отмечена опция Выгрузка в каталог, то данные будут выгружаться в каталог на диске. Каталог обмена и файл загрузки заказов задаются в соответствующих полях.

В поле Каталог лога задается каталог, в котором будет храниться лог-файл обмена. Логи хранятся в разрезе дня в подчиненной папке reports. Кроме того, с помощью одноименных опций можно определить выгружать ли логи на сайт и хранить ли файлы обмена на сайте.

В поле Группа для новых товаров указывается каталог, в котором будут храниться указанные в заказах с сайта товары, но отсутствующие в 1С (т.е. товар был создан на сайте и информации в 1С по нем нет).

Действия с неудачно отправленными пакетами:

  • В поле Число повторов при неудачно отправленных пакетах указывается количество попыток отправки пакета с данными, если пакет отправился неудачно.
  • В поле Таймаут между повторами неудачно отправленных пакетах задается количество секунд, которое должно пройти перед тем, как обмен снова отправит неудачно отправленный пакет данных.
  • Если отмечена опция Продолжить отправку неудачно отправленных пакетов при следующем обмене и имеются неудачно отправленные пакеты, то при следующем обмене сперва произойдет довыгрузка неотправленных пакетов, а затем непосредственно сам обмен.

Настройка автообмена:

Если отмечена опция Использовать периодический обмен данными то обмен будет выполняться по заданному расписанию. В зависимости от того, база 1С в файловом или клиент-серверном варианте, настройка автообмена отличается.

При установке флажка автоматически откроется форма настройки расписания обмена, в которой задается время начала и завершения обмена, дата начала и дата завершения, периодичность. Например, чтобы расписание выполнялось каждый день, в поле Повторять каждые должно стоять значение 1 день.

В дополнительных настройках указывается пользователь, который подставляется в данные (форма открывается по кнопке Дополнительные настройки расписания):

Примечание: если база 1С в файловом варианте, то необходимо указать пользователя, под которым будет выполняться автообмен, в настройках параметров учета (Операции > Константы, закладка Обмен данными):


Обмен товарами
128 / 254

Для выгрузки товаров из 1С на сайт в форме настроек обмена должна быть отмечена опция Обмен товарами и настроены основные настройки обмена. Затем следует перейти на закладку Обмен товарами и настроить параметры выгрузки. Для удобства содержимое закладки разделено на четыре вкладки:

  • Основные настройки
  • Отбор и сортировка
  • Настройка свойств товаров
  • Соответствие полей номенклатуры

После того, как вы выполните необходимые вам настройки и сохраните узел обмена, можно будет приступать непосредственно к выполнению выгрузки товаров на сайт.

Основные настройки

На данной вкладке указывается, какая информация о номенклатуре должна быть выгружена, в какой каталог должна быть загружена на сайт.

Примечание: перечень параметров формы зависит от версии установленного модуля обмена.

Версионность параметров закладки "Основные настройки"

Поле | С версии
Выгрузка справочных данных
Товары | 4.0.0.1
Количество товаров в пакете | 4.0.0.1
Свойства товаров | 4.0.0.1
Только используемые справочные значения свойств | 4.0.0.1
Картинки и файлы | 4.0.0.1
Предложения | 4.0.4.2
Выгружать номенклатуру как предложение, если у нее есть характеристики | 4.0.2.1
Выгружать штрихкоды | 4.0.0.1
Выгружать планируемую дату поступления товара | 4.0.2.1
кнопка Выполнить | 4.0.2.1*
* - до версии 4.0.2.1 вместо кнопки использовалась опция Принудительная полная выгрузка картинок и файлов.
Выгрузка справочных данных
Выгружать цены | 4.0.0.1
Выгружать остатки | 4.0.0.1
Выгружать предложения только с ценой | 4.0.2.1
Выгружать остатки по складам | 4.0.0.1
Прочие настройки
Классифицировать номенклатуру по ценовым группам | 4.0.0.1
Таблица каталогов | 4.0.0.1

Выгрузка справочных данных:

  • При отмеченной опции Товары будет выгружена информация о товарах. При этом с помощью поля Количество товаров в пакете задается сколько товаров должно быть в одном пакете с данными.
  • Если отмечена опция Свойства товаров, то будут выгружены свойства товаров. При этом, если отмечена опция Только используемые справочные значения свойств, то будут выгружены только те свойства, значения которых заданы хотя бы в 1 товаре.
  • При отмеченной опции Картинки и файлы будут выгружены картинки и файлы товаров, причем выгружаются только новые или измененные картинки и файлы.
  • При отмеченной опции Предложения будет выгружена информация о торговых предложениях.
  • При отмеченной опции Выгружать номенклатуру как предложение, если у нее есть характеристики номенклатура при наличии у нее характеристик будет выгружаться в торговое предложение.
  • Если установлен флаг Выгружать штрихкоды, тогда для товаров будут выгружены их штрихкоды. Если штрихкоды не используются, то лучше флаг этот не ставить, чтобы не замедлять работу выгрузки.
  • При отмеченной опции Выгружать планируемую дату поступления товара будет выгружаться дата поступления товара.
  • Кнопка Выполнить предназначена для обмена товарами с выполнением полной выгрузки картинок независимо от того, есть ли они на сайте. Полную выгрузку данных следует делать при первом обмене, а затем уже будет использоваться механизм версионности.

    Примечание: до версии 4.0.2.1 вместо кнопки Выполнить использовалась опция Принудительная полная выгрузка картинок и файлов.

Выгрузка регистровых данных:

  • Если отмечена опция Выгружать цены, то для выгружаемых товаров будут выгружены цены. Цены выгружаются только для тех типов цен, которые удовлетворяют условию.
  • Если отмечена опция Выгружать остатки, то для выгружаемых товаров будут выгружены остатки. Остатки выгружаются только по тем складам, которые удовлетворяют условию.
  • Если опция Выгружать предложения только с ценой отмечена, то будут выгружены только те торговые предложения, для которых задана цена. В противном случае - все.
  • При отмеченной опции Выгружать остатки по складам на сайте остатки будут вестись в разрезе складов.

Если отмечена опция Классифицировать номенклатуру по ценовым группам, то группами номенклатуры будут ценовые зоны.

Таблица каталогов:

Примечание: должно быть задано хотя бы одно соответствие групп номенклатуры каталогам на сайте.

  • В колонке Имя каталога задается название инфоблока на сайте.
  • В колонке Список групп указывается список групп товаров, которые должны быть выгружены в указанный инфоблок с учетом настроенных условий отбора на закладке Отбор и сортировка.
  • Колонка Дерево групп служит для указания пользовательского дерева групп для выгружаемых товаров каталога. Дерево групп можно сформировать только из тех товаров/групп, которые указаны в колонке Список групп. Если задано пользовательское дерево групп, то будут выгружены только относящиеся к нему товары. Таким образом, можно создавать свои группы товаров, которые будут выгружены на сайт, не изменяя иерархию товаров в 1С. Причем один и тот же товар можно указать сразу нескольким группам.

    Слева создается пользовательский каталог, который будет выгружен на сайт. Вложенность групп может быть различной. Сначала создается группа, потом ей назначается список товаров/групп.
  • В колонке GUID каталога задается код инфоблока.

Отбор и сортировка

На вкладке товаров Отбор и сортировка задаются условия отбора выгружаемых данных:

  • Номенклатура - отбор по самой номенклатуре или группе;
  • Тип цен - отбор по выгружаемым типам цен, и, соответственно, ценам товаров;
  • Остатки по складам - отбор по выгружаемым остаткам по складам. Остатки товара будут только по тем складам, которые удовлетворяют условию;
  • Остаток - отбор по выгружаемым остаткам товара. Если количества товара (по всем выгружаемым складам) будет меньше заданного количества, то товар не выгрузится;
  • Свойство номенклатуры - отбор по свойствам номенклатуры. Будут выгружены только те свойства, которые удовлетворяют условию отбора;
  • Категория номенклатуры - отбор номенклатуры по категориям товаров;
  • Основное изображение - отбор номенклатуры по основному изображению товара.

Настройка свойств товаров

На данной вкладке товаров можно указать, какие свойства товаров будут храниться в Highload-блоках, а какие влияют на цену.

Соответствие полей номенклатуры

С помощью данной вкладки можно настроить собственные соответствия полей номенклатуры, т.е. указать в какие поля xml-файла будут выгружаться те или иные данные:

Примечание: вкладка доступна, начиная с версии 4.0.2.1 модуля обмена.

Выполнение выгрузки товаров на сайт

Автоматическая выгрузка товаров осуществляется в соответствии с настройками автообмена. Для ручного запуска процесса выгрузки товаров необходимо:

  • в форме редактирования настройки обмена нажать кнопку Выполнить обмен:

  • либо в форме списка настроек обмена выбрать нужный узел и нажать пункт Выполнить обмен в меню кнопки Операции:

По окончании выгрузки результат можно просмотреть в административном разделе вашего сайта:


Обмен заказами
129 / 254

Для обмена заказами в форме настроек обмена должна быть отмечена опция Обмен заказами и выполнены основные настройки. Затем следует перейти на закладку Обмен заказами и настроить параметры обмена заказа необходимым для вас образом. Для удобства содержимое закладки Обмен заказами разделено на три вкладки:

  • Обмен заказами
  • Обмен контрагентами
  • Отбор и сортировка

После того, как вы выполните необходимые вам настройки и сохраните узел обмена, можно будет приступать непосредственно к выполнению обмена заказами.

Обмен заказами

На вкладке Обмен заказами указывается, как заказы должны выгружаться с сайта, с какими параметрами загружаться на сайт:

Примечание: перечень параметров зависит от версии установленного модуля обмена.

Версионность параметров закладки "Обмен заказами"

Поле | С версии
Выгрузка заказов из 1С
Выгружать все заказы | 4.0.0.1
Точка актуальности выгрузки | 4.0.0.1
Выгрузка отгрузок заказов | 4.0.0.1
Количество заказов в пакете | 4.0.0.1
Загрузка заказов в 1С
Не обновлять документы пришедшие с сайта | 4.0.0.1
Загрузка оплат вместе с заказами | 4.0.0.1
Загрузка отгрузок вместе с заказами | 4.0.0.1
Параметры создания документов
Подстановка в создаваемые документы:
  • Организация
  • Ответственный
  • Подразделение
  • Склад
  • 4.0.0.1
  • 4.0.0.1
  • 4.0.0.1
  • 4.0.4.2
Значение реквизитов из свойств:
  • Наименование свойства организация
  • Наименование свойства подразделение
  • Наименование свойства склад
  • Наименование свойства соглашение
4.0.4.2
Если контрагент физ. лицо:
  • Общий контрагент "физлицо"
  • Соглашение контрагента "физлицо"
4.0.0.1
Действия с документами, пришедшими с WEB-сайта
Заказы/Оплаты/Отгрузки:
  • Установка номера и даты
  • Режим записи
  • Действия с отменными
  • Соответствия статусов/Соответствия платежных систем и касс/Соответствия статусов отгрузок
4.0.0.1

Выгрузка заказов из 1С:

  • При отмеченной опции Выгружать все заказы будут выгружены все заказы, в том числе и те, которые не были созданы на сайте.
  • С помощью поля Точка актуальности выгрузки заказов указывается дата, начиная с которой и по текущий момент заказы будут выгружаться на сайт.
  • Если отмечена опция Выгрузка отгрузок заказов, то вместе с заказами будут выгружены их отгрузки.
  • В поле Количество заказов в пакете указывается, сколько заказов будет в одном пакете данных.

Загрузка заказов в 1С:

  • При отмеченной опции Загрузка оплат вместе с заказами для оплаченных заказов будет создан приходный кассовый ордер.
  • Если отмечена опция Загрузка отгрузок вместе с заказами, то модуль обмена будет загружать отгрузки, созданные или отредактированные на сайте.
  • Если отмечена опция Не обновлять документы пришедшие с сайта, то при повторной выгрузке документов с сайта документы в 1С не будут обновляться.

Параметры создания документов:

На вкладке Подстановка в создаваемые документы в соответствующих полях необходимо задать организацию, ответственного, подразделение и склад, которые будут подставляются в новые или отредактированные документы, пришедшие с сайта.

На вкладке Значение реквизитов из свойств задаются наименования свойств заказа на сайте, по которым будут искаться элементы в 1С.

Если на вкладке Если контрагент физ. лицо заполнены поля Общий контрагент "физлицо" и Соглашение контрагента "физлицо", то в новые заказы будет подставляться этот контрагент, когда у клиента с сайта стоит признак физическое лицо.

Действия с документами, пришедшими с WEB-сайта:

В данной секции задаются параметры записи и отмены документов.

Обмен контрагентами

На вкладке заказов Обмен контрагентами указываются настройки по выгрузке/загрузке контрагентов. Информация о контрагентах с сайта выгружается вместе с документами.

Примечание: перечень параметров зависит от версии установленного модуля обмена.

Версионность параметров закладки "Обмен контрагентами"

Поле | С версии
Выгрузка контрагентов из 1С
Контрагенты | 4.0.0.1
Количество контрагентов в пакете | 4.0.0.1
Загрузка контрагентов в 1С
Идентификация контрагентов | 4.0.0.1
Группа для новых контрагентов | 4.0.0.1
Не редактировать контрагентов пришедших с сайта | 4.0.5.1
Подставлять ФИО в полное наименование физ.лиц | 4.0.5.1
Соответствие адресов контрагентов
Юридическое лицо (таблица соответствий) | 4.0.1.1
Физическое лицо (таблица соответствий) | 4.0.1.1

Выгрузка контрагентов из 1С:

  • При установке флага Контрагенты, из 1С будут выгружены контрагенты, удовлетворяющие условию по указанным отборам на вкладке Отбор и сортировка.
  • В поле Количество контрагентов в пакете задается число контрагентов, которые будут выгружаться в одном пакете данных.

Загрузка контрагентов в 1С:

  • В поле Идентификация контрагентов указывается, как будут искаться контрагенты по базе, если контрагент не будет найден по уникальному идентификатору, или коду с сайта. Поиск контрагентов может быть или по наименованию, или по ИНН+КПП.
  • В поле Группа для новых контрагентов указывается группа контрагентов для новых контрагентов, созданных модулем обмена с этой настройкой обмена.
  • При отмеченной опции Не редактировать контрагентов пришедших с сайта информация о контрагентах обновляться в 1С не будет.
  • При отмеченной опции Подставлять ФИО в полное наименование физ.лиц полное наименование контрагента будет браться из полей XML-файла с фамилией, именем и отчеством.

Соответствие адресов контрагентов:

В данной секции настраивается соответствие адресов для новых контрагентов, которые загружаются в 1С. Соответствие задается для каждого типа лица с помощью таблицы:

  • В колонке Наименование поля в XML указывается название передаваемого в xml-файле поля с адресом.
  • В колонке Вид контактной информации выбирается поле адреса контрагента, в которое должны быть занесены данные.

Отбор и сортировка

На вкладке заказов Отбор и сортировка задаются условия отбора для выгружаемых заказов и контрагентов. Заказы, помимо точки актуальности, можно ограничить по организациям и подразделениям, а контрагенты - по контрагентам и категориям контрагентов.

Выполнение обмена заказами

Автоматический обмен заказами осуществляется в соответствии с настройками автообмена. Для ручного запуска процесса обмена необходимо:

  • в форме создания/редактирования настройки обмена нажать кнопку Выполнить обмен:

  • либо в форме списка настроек обмена выбрать нужный узел и нажать пункт Выполнить обмен в меню кнопки Операции:

Для просмотра выгруженных с сайта заказов в 1С следует воспользоваться пунктом меню Документы > Продажи > Заказы покупателей. Откроется форма со списком всех заказов, среди которых будут находиться и заказы с сайта:

Если в настройке обмена указано, чтобы заказы из 1С загружались на сайт, то для просмотра загруженных на сайт заказов следует перейти в административный раздел на страницу со списком заказов (Магазин > Заказы):

Просмотр выгруженных из 1С контрагентов (если настроена выгрузка) осуществляется на странице со списком пользователей (Настройки > Пользователи > Список пользователей):

Причем контрагенты, которые были заданы в загружаемых на сайт заказах, будут отображаться в списке покупателей (Магазин > Покупатели > Список покупателей):


Выгрузка польз. справочников из 1С
130 / 254

Начиная с версии 14.5.1 модуля Торговый каталог, в продукте доступен компонент catalog.import.hl. С его помощью осуществляется импорт справочников из 1С на сайт, причем каждый справочник будет загружен в отдельный Highload-блок. Вся процедура выполняется на стороне 1С.

Для выгрузки справочников из 1С в форме настроек обмена необходимо отметить опцию Обмен пользовательскими справочниками и выполнить основные настройки (в поле Адрес сайта укажите адрес вашего сайта, содержащий путь до файла /bitrix/admin/1c_exchange.php, именно в этом файле подключен необходимый компонент catalog.import.hl).

После чего перейдите на закладку Обмен польз. справочников. С помощью кнопки Добавить выберите те справочники из базы 1С, которые должны быть выгружены на сайт. При выборе строки с названием справочника в таблице ниже отобразятся все доступные его поля.

Чтобы необходимое поле справочника выгружалось, отметьте опцию Выгружаемо в соответствующей строке с названием поля.

Примечание: если значение поля является ссылкой, то для выгрузки наименования ссылочного элемента следует отметить опцию Выгружать как строка, иначе будет выгружен идентификатор данного поля.

Когда все настройки выполнены, нажмите кнопку Выполнить обмен. Начнется процесс импорта справочников на сайт. По его окончании в 1С будет отображено соответствующее сообщение.

Для проверки выполненных действий перейдите в административный раздел вашего сайта:


Загрузка каталога товаров с сайта в 1С
131 / 254

Для выгрузки каталога товаров с сайта в 1С: Предприятие требуется со стороны 1С-Битрикс: Управление сайтом только указать товары, которые должны быть выгружены (см. форму интеграции), а вся процедура выполняется со стороны 1С.

В 1С:Предприятие перейдите в настройки обмена с сайтами (Операции > Планы обмена > Обмен с WEB-сайтом) и кликнете по пункту Загрузить номенклатуру с сайта в меню кнопки Операции:

Откроется мастер импорта товаров с сайта:

  • В поле Адрес укажите адрес вашего сайта, содержащий путь до файла /bitrix/admin/1c_exchange.php (либо путь к странице с собственными настройками интеграции).
  • В поле Авторизация задайте логин и пароль пользователя из 1С-Битрикс: Управление сайтом, который обладает правом на выгрузку каталога с сайта (т.е. пользователь должен относится к группе, указанной в настройках интеграции).
  • В поле Дополнительно укажите интервал отправки запросов.

Нажмите кнопку Далее.

На следующем шаге задайте параметры загрузки товаров в 1С:

  • Укажите Вид номенклатуры загружаемых товаров, чаще всего это Товар.
  • В поле Базовая единица измерения укажите шт.
  • В поле Загружать товары в группу задайте группу, в которую товары должны быть загружены. Группу можно выбрать как среди существующих, так и создать новую.
  • Отметьте необходимые для вас опции загрузки товаров в 1С:
    • Создавать группы - в 1С попадет иерархия групп товаров, в которых будет сам товар;
    • Создавать свойства товаров - с сайта будут выгружены свойства товаров;
    • Создавать характеристики товаров - будут выгружены характеристики товаров;
    • Устанавливать цены - будут импортированы цены товаров и при необходимости типы цен.
    • Загружать картинки - вместе с товарами будут загружены картинки.

Нажмите кнопку Далее. Отобразится информация о процедуре импорта каталога товаров с сайта:

Нажмите кнопку Начать импорт. В процессе импорта, когда система получит данные с сайта, она запросит у вас разрешение на загрузку товаров. После того, как товары будут загружены в базу 1С, система запросит разрешение на загрузку изображений (если соответствующая опция была отмечена). По окончании процедуры импорта будет выведен протокол загрузки товаров:

Для проверки выполненных действий перейдите в Справочники > Номенклатура:


Обмен в режиме реального времени
132 / 254

Режим обмена заказами в реальном времени реализован таким образом, что в 1С постоянно висит один сеанс, который ждет сообщения с сайта. Если на сайте создали или отредактировали заказ, то в 1С посылается сигнал, чтобы 1С выполнила обмен заказами. Каждые 40 секунд (по умолчанию) соединение с сайтом обрывается и происходит новое соединение.

При авторизации на сайте к адресу сайта добавляется параметр ?type=listen. Параметр необходим, чтобы сайт «знал», что это соединение для режима реального времени.

Сайт может вернуть 2 кода состояния:

  • 200 - надо выполнить обмен. Признак того, на каком узле должен быть выполнен обмен, определяется настройками опции Используется в режиме реального времени (опция может быть отмечена только в одной настройке обмена):

  • 302 - нужно сделать переадресацию и снова посмотреть код состояния. Адрес переадресации берется из заголовка Location.

Механизм обмена в режиме реального времени зависит от варианта работы базы 1С:

  • Если база в файловом варианте работы, тогда активный сеанс 1С ждет сообщение с сайта. Для прекращения режима реального времени необходимо закрыть сеанс или разблокировать его, нажав на комбинацию клавиш Ctrl + Break.

    Запуск режима обмена заказами в реальном времени осуществляется с помощью одноименной кнопки:

  • Если база в клиент-серверном варианте, тогда фоновое задание ждет сообщения с сайта. Временной интервал, в котором работает режим реального времени, задается в расписании задания:

    В результате будет запущен режим обмена заказами в реальном времени с учетом заданного вами временного интервала.

Таким образом, все сделанные в интернет-магазине заказы в режиме реального времени попадают в 1С. Если параметры заказа были изменены в 1С либо в 1С были созданы новые заказы, то все изменения будут автоматически отражены и на сайте.


Прочие возможности модуля обмена
133 / 254


Просмотр и редактирование зарегистрированных изменений
134 / 254

Для просмотра зарегистрированных изменений необходимо перейти к списку узлов обмена (Операции > План обмена > Обмен с WEB-сайтом), выбрать необходимый вам узел и нажать на пункт Открыть список изменений в меню кнопки Операции.

Откроется окно с информацией о всех зарегистрированных изменениях узла обмена. Просматривать изменения можно вплоть до элементов, разворачивая их в дереве:

Кроме того, вы можете не только просматривать изменения, но и удалять их.


Редактирование кодов Битрикс у объектов 1С
135 / 254

Чтобы перейти к редактированию кодов Битрикс у объектов 1С, следует в форме со списком узлов обмена (Операции > План обмена > Обмен с WEB-сайтом) нажать кнопку Операции и выбрать пункт Редактировать коды битрикс у объектов 1С:

Откроется форма следующего вида:

В поле Тип объекта указывается тип объекта 1С, для которого нужно посмотреть/редактировать коды. Он может быть одним из следующих:

  • Справочники;
  • Документы;
  • Планы видов характеристик.

В поле Объект 1С указывается объект, коды элементов которого необходимо посмотреть/отредактировать. Список доступных объектов формируется в зависимости от указанного типа объекта 1С. Указать объекты 1С можно только те, которые могут хранить коды Битрикс.

При нажатии на кнопку Записать изменения измененные коды элементов будут перезаписаны в элементе 1С.


Режим логирования проводимых операций
136 / 254

В новом модуле обмена реализован механизм логирования. В лог записываются все ключевые данные по формированию, транспорту и обработке на сайте. Лог-файл хранится не только в каталоге, установленном в настройке обмена, но и может быть выгружен на сайт. На сайте он хранится в папке /upload/1c_catalog/Reports.

Лог-файл ведется в разрезе дня и для каждой настройки обмена он свой. После каждого обмена лог-файл дописывается. На сайте лог- файлы хранятся несколько дней, причем для уменьшения времени его передачи на сайт он архивируется.

Чтобы просмотреть лог-файл из 1С для некоторой настройки обмена, следует выбрать необходимую настройку и нажать пункт Открыть лог в меню кнопки Операции:

Затем в нужно указать дату, на которую требуется просмотреть лог-файл обмена:

В результате откроется лог-файл выполнения обмена данными в заданный день:


Установка соответствий платежных систем и касс
137 / 254

Чтобы перейти к установке соответствий платежных систем и касс, следует в форме со списком узлов обмена (Операции > План обмена > Обмен с WEB-сайтом) нажать кнопку Операции и выбрать пункт Установка соответствий платежных систем и касс:

Откроется форма следующего вида:

При нажатии на кнопку Загрузить платежные системы с сайта будут загружены данные о платежных системах в указанный узел обмена. В списке записей регистра сведений нужно указать, какая касса соответствует платежной системе. Именно по этой связке будет определяться, какая касса должна подставляться в ПКО на основании платежной системы.


Без модуля обмена
138 / 254

В данной главе описан механизм обмена данными между 1С:Предприятие и 1С-Битрикс: Управление сайтом, если нет возможности их обновить и установить в 1С модуль обмена 4.0.0.х.


Создание настройки обмена с WEB-сайтом
139 / 254

Для создания настройки обмена данными запустите мастер, выбрав пункт меню Сервисы > Обмен данными с WEB-сайтом > Настроить обмен данными с WEB-сайтом.


Шаг 1. Настройка обмена данными с WEB-сайтом
140 / 254

Нажмите на рисунок, чтобы увеличить

Отметьте опцию Создать новую настройку обмена с WEB-сайтом и нажмите кнопку Далее.


Шаг 2. Назначение выгрузки
141 / 254

Нажмите на рисунок, чтобы увеличить

  • Укажите данные для обмена:
    • установите флаг Выгрузка товаров, чтобы происходил экспорт товаров из 1С на сайт;
    • установите флаг Обмен заказами, чтобы заказы с сайта импортировались в 1С;
  • Отметьте опцию Выгрузка на сайт, чтобы данные из 1С выгружались на сайт. В этом случае укажите:
    • Адрес сайта – адрес вашего сайта, содержащий путь до файла /bitrix/admin/1c_exchange.php (либо путь к странице с собственными настройками интеграции, см. урок Собственные настройки интеграции).
    • Пользователь – логин пользователя сайта под управлением 1С-Битрикс: Управление сайтом. Пользователь должен обладать правом на выполнение обмена данными, т.е. пользователь должен относиться к группе, указанной в настройках интеграции.
    • Пароль – пароль пользователя.
    • Кнопка Проверить служит для выполнения проверки правильности указанных данных соединения с сайтом.
    • Если для соединения с сайтом необходимо использовать прокси-сервер, то отметьте опцию Использовать прокси-сервер и укажите параметры соединения.
  • Если отметить опцию Выгрузка в каталог, то выгрузка данных будет выполнена в указанный вами каталог.
  • Чтобы настроить формат величин данных обмена, нажмите кнопку Настроить форматы даты, времени и чисел…. Откроется форма настроек:

    Укажите нужный формат значений с помощью кнопки Изменить формат и нажмите кнопку OK.

  • Для перехода к следующему шагу нажмите кнопку Далее.


Шаг 3. Настройки выгрузки товаров на WEB-сайт
142 / 254

Нажмите на рисунок, чтобы увеличить

С помощью полей Имя каталога и Список групп номенклатуры укажите соответствия групп номенклатуры каталогам на сайте.

Внимание! Должно быть задано хотя бы одно соответствие групп номенклатуры каталогам на сайте.

Примечание: имя каталога соответствует имени информационного блока на сайте, в который будут выгружены товары.

Чтобы указать выгружаемую номенклатуру, выполните следующие действия:

  • Дважды кликните по необходимой строке таблицы соответствия либо вызовите контекстное меню и нажмите пункт Изменить:

  • Нажмите кнопку выбора номенклатуры […]:

  • В открывшемся окне нажмите кнопку Подбор, откроется форма выбора номенклатуры:

    Нажмите на рисунок, чтобы увеличить

  • Отметьте необходимые группы и позиции товаров и нажмите кнопку Выбрать.
  • В форме редактирования значений проверьте список значений для выгрузки и нажмите кнопку OK:

  • С помощью пункта контекстного меню Добавить укажите необходимое вам количество соответствий. Например, будет выполнена выгрузка товаров в 2 каталога сайта:

    Нажмите на рисунок, чтобы увеличить

  • Для перехода к следующему шагу нажмите кнопку Далее.


Шаг 4. Условия выгрузки товаров на сайт
143 / 254

Нажмите на рисунок, чтобы увеличить

Данный шаг мастера содержит дополнительные настройки выгрузки товаров на сайт:

  • Опции Выгружать картинки, Выгружать файлы, Выгружать все характеристики служит для экспорта изображений, файлов и других характеристик товара на сайт.

    Примечание: дополнительные изображения, файлы и характеристики сохраняются в дополнительных свойствах инфоблока.

  • Таблица отбора выгрузки товаров служит для задания условий отбора выгружаемых товаров по номенклатуре, типу цен и по имеющимся остаткам.
  • Специальное поле сортировки позволяет произвольным образом настроить порядок следования номенклатурных позиций, которые выгружаются на сайт, независимо от того, как эти позиции изначально сортируются в справочнике номенклатуры. Это может применяться для лучшего представления каталога на сайте.
  • Для перехода к следующему шагу нажмите кнопку Далее.


Шаг 5. Настройки обмена заказами с WEB-сайтом
144 / 254

Нажмите на рисунок, чтобы увеличить

Настройки обмена заказами включают:

  • Способ идентификации контрагентов – с сайта будут поступать заказы, в которых покупатели указывают свои имена и названия своих организаций. Можно выбрать способ идентификации по названию или по ИНН.
  • Параметры для подстановки в заказы с WEB-сайта – указываются параметры организации, которая осуществляет продажи в Интернет-магазине. Поскольку на сайте могут осуществлять продажи разные юридические лица, то в настройках каждого профайла обмена данными нужно указывать разные организации.
  • Параметры для создания новых элементов – задаются параметры, используемые при создании новых элементов.
  • Для перехода к следующему шагу нажмите кнопку Далее.


Шаг 6. Действия с поступившими с WEB-сайта документами
145 / 254

Нажмите на рисунок, чтобы увеличить

Выберите вариант установки даты:

  • По информации документа с сайта - дата документов не будет изменяться. Будет оставлена дата, которая установлена на сайте;
  • Устанавливать у документов текущую дату - дата документов будет изменена на текущую.

Укажите параметры проведения документов:

  • Только записывать документы;
  • Записывать и проводить документы.
Выберите действия с отмененными заказами:

  • Помечать на удаление;
  • Отменять проведение;
  • Ничего не делать;
  • Оформлять документ "Закрытие заказов покупателей".

Для перехода к следующему шагу нажмите кнопку Далее.


Шаг 7. Режим обмена данными с WEB-сайтом
146 / 254

Нажмите на рисунок, чтобы увеличить

  • Укажите режим обмена данными с сайтом: полная выгрузка данных или только измененных объектов с момента последнего обмена.
  • Задайте узел для обмена товарами и узел для обмена заказами.
  • Нажмите кнопку Далее.


Шаг 8. Периодический обмен данными
147 / 254

Нажмите на рисунок, чтобы увеличить

Если вам необходимо, чтобы обмен данными выполнялся периодически без непосредственного вызова процедуры обмена, то отметьте опцию Выполнять обмен данными периодически и укажите нужный период обмена.

При выборе произвольной настройки периода открывается окно, с помощью которого настраивается расписание обмена данными.

Для окончания работы с мастером нажмите кнопку Готово, для возврата на предыдущий шаг – кнопку Назад.


Шаг 9. Окончание работы мастера
148 / 254

После нажатия кнопки Готово выводится сообщение о том, что настройка обмена данными успешно сохранена, и отображается запрос на выполнение процедуры обмена:

На этом работа мастера окончена.


Редактирование настройки обмена с WEB-сайтом
149 / 254

Для изменения существующей настройки обмена данными с сайтом необходимо выполнить следующие действия:

  • Запустите мастер настройки обмена данными (Сервисы > Обмен данными с WEB-сайтом > Настроить обмен данными с WEB-сайтом).
  • На первом шаге мастера выберите Изменить существующую настройку обмена с WEB-сайтом и нажмите кнопку Далее.
  • Выберите настройку для редактирования и дважды кликните по ней:

  • Отредактируйте параметры настройки обмена данными:

    Если одна из опций Выгрузка товаров или Обмен заказами снята, то параметры и закладки, связанные с ними, становятся недоступными.

  • Для сохранения внесенных изменений нажмите кнопку OK или Записать.


Процедура обмена данными с WEB-сайтом
150 / 254

Обратите внимание! Запуск обмена данными производится только со стороны 1С. Со стороны сайта запустить обмен нельзя, это сделано в целях обеспечения безопасности.


Запуск и выполнение
151 / 254

Для выполнения процедуры обмена данными с сайтом проделайте следующие действия:

  • Выберите пункт меню Сервисы > Обмен данными с WEB-сайтом > Выполнить обмен данными с WEB-сайтом.
  • В открывшейся форме выберите необходимую настройку обмена данными и нажмите кнопку Выполнить обмен:

    Примечание: по кнопке [image] можно перейти к форме редактирования выбранной настройки обмена.

В процессе обмена данными вся необходимая информация отображается в специальном окне, расположенном снизу:

Нажмите на рисунок, чтобы увеличить

Импортированные на сайт каталоги товаров

После выгрузки товаров в 1С-Битрикс: Управление сайтом будут созданы соответствующие информационные блоки товаров.

Например, если осуществлялась выгрузка разных групп номенклатуры в разные каталоги, то в 1С-Битрикс: Управление сайтом будут созданы инфоблоки для каждого каталога.

Если в настройках импорта каталога на сайт была отмечена опция Выгружать предложения (характеристики) в отдельный инфоблок, то товары с их характеристиками будут выгружены в 2 разных инфоблока.

Поэтому первый инфоблок (например Основной каталог товаров) содержит только информацию о самих товарах, но не содержит цен и не является торговым каталогом. А второй каталог (Пакет предложений (Основной каталог товаров)) является каталогом предложений, связанных с товарами, содержит товары с разными характеристиками и цены.


Выгрузка каталогов в уже существующий инфоблок
152 / 254

Если данные из 1С выгрузились в отдельный инфоблок, выполните следующие действия.

В административном режиме перейдите на страницу Настройки > Настройки продукта > Настройки модулей > Информационные блоки и включите параметр Показывать код загрузки из внешних источников:

Теперь у вас в форме редактирования инфоблоков появится новое поле: Внешний код (оно же XML_ID).

Зайдите в форму редактирования созданного выгрузкой инфоблока и скопируйте значение поля Внешний код:

Теперь вставьте скопированный внешний код в одноименное поле ранее созданного инфоблока, в который нужно произвести выгрузку, новый инфоблок удаляете, или меняете/убираете значение поля Внешний код.

Запустите процедуру обмена данными, в результате которой данные будут выгружены в уже существующий инфоблок.

Важно! При обмене может учитываться тип инфоблока (опция При выгрузке учитывать тип инфоблока на странице Магазин > Настройки магазина > Интеграция с 1С). В таком случае вам нужно помимо внешнего кода поменять тип инфоблока.

При включенной опции При выгрузке учитывать тип инфоблока меняется внешний код инфоблока:
без опции: bd72d8f9-55bc-11d9-848a-00112f43529a
с опцией: cat-bd72d8f9-55bc-11d9-848a-00112f43529a, где cat - символьный код типа инфоблока.


Загруженные в 1С заказы
153 / 254

Для просмотра выгруженных заказов из 1С-Битрикс: Управление сайтом в 1С:Предприятие следует воспользоваться пунктом меню Документы > Продажи > Заказы покупателей:

Откроется форма со списком всех заказов, среди которых будут находиться заказы с сайта:

Нажмите на рисунок, чтобы увеличить

Всю информацию о заказе можно посмотреть в форме детального просмотра заказа:

Нажмите на рисунок, чтобы увеличить

Причем информация о доставке заказа отображается на закладке Услуги.


Монитор обмена данными
154 / 254

Форма Монитор обменов отображает данные о последнем обмене данными, о последних выполненных операциях по данному профайлу и т.д. На закладках формы представлены статистика обменов, история обменов и т.д. Перейти в данной форме можно через пункты меню: Сервис > Обмен данными с WEB-сайтом> Монитор обмена данными:


Публикация на сайте торгового каталога из 1С (до версии 14.0)
155 / 254

Публикация торгового каталога осуществляется с помощью комплексного компонента Каталог (bitrix:catalog).

Если вся информация о товарах выгружена в один информационный блок, то в настройках компонента необходимо указать необходимый тип инфоблоков и данный информационный блок. Остальные параметры настройте необходимым для вас образом. Подробная информация о параметрах компонента представлена в документации по продукту.

В качестве примера воспользуйтесь главой Настройка отображения каталога.


Публикация каталога с пакетом предложений
156 / 254

Если со стороны 1С-Битрикс: Управление сайтом в настройках импорта каталога была отмечена опция Выгружать предложения (характеристики) в отдельный инфоблок, то для публикации каталога товаров необходимо использовать компонент Каталог (Контент > Каталог > Каталог) с шаблоном offers:

При этом в группе параметров Основные параметры указывается тип инфоблоков, в который выполнялся импорт каталога, и информационный блок, который не является торговым каталогом, а содержит лишь информацию о товарах:

Информацию о предложениях на товар необходимо указать в группе параметров Настройки связанных элементов:

  • В качестве типа инфоблоков укажите тот же тип, что и в группе параметров Основные параметры.
  • Выберите инфоблок с каталогом предложений. Инфоблок имеет имя Пакет предложений (<имя_первого_инфоблока>), где <имя_первого_инфоблока> – это название информационного блока, в котором хранится информация о товарах.
  • В поле Свойство, в котором хранится связь укажите [CML2_LINK] Элемент каталога.

Все остальные параметры компонента настраиваются аналогичным образом как при публикации обычного торгового каталога.

В результате в публичной части сайта каталог товаров будет представлен следующим образом:

Причем на странице с детальной информацией о товарее отображаются все имеющиеся предложения на товар. Если один и тот же товар доступен в нескольких вариантах, т.е. к примеру, можно выбрать желаемый цвет, форму и т.п., то все эти предложения будут представлены в таблице, и пользователь сможет купить необходимый ему товар.


Интеграция с "1С:Управление торговлей" ред. 11.1
157 / 254

В данной главе описаны настройки для обмена данными со стороны 1С:Предприятие, ред. Управление торговлей 11.1. Описание настроек приведено с учетом того, что в 1С установлен новый модуль обмена 4.x.x.х (при этом обратите внимание на зависимость версий).

Примечание: если для обмена использовать встроенный в конфигурацию 1С механизм обмена или старое дополнение, то часть описанных в данной главе возможностей обмена будет недоступна.

Примечание: дополнительно вы можете ознакомиться с записью вебинара по интеграции с 1С:УТ.


Настройка параметров учета для обмена с сайтами
158 / 254
  • Если вы не используете модуль обмена 4.х.х.х, то необходимо вручную включить обмен с сайтами в 1С: Администрирование > Настройки синхронизации данных, опция Обмен данными с сайтами:

  • Включите использование дополнительных реквизитов и сведений (для нового модуля включается автоматически): Администрирование > Настройка параметров системы > Общие настройки, опция Дополнительные реквизиты и сведения:

  • Включите использование заказов клиентов: Администрирование > Настройка параметров системы > CRM и продажи, опция Заказы клиентов:

  • Создайте типовое соглашение для выгрузки цен (Маркетинг и планирование > Типовые соглашения с клиентами). Статус соглашения должен быть Действует, с пустым сегментом партнеров, с актуальным периодом действия, соответствующим видом цен и доступно внешним пользователям:


Узлы обмена с сайтами
159 / 254

Чтобы перейти к настройкам обмена с сайтами, следует открыть список узлов обмена (Администрирование > Подсистема Битрикс (или Битрикс) > Обмен с сайтами):

В списке всегда есть предопределенный узел обмена, который нельзя использовать. Он с незаполненным наименованием. Создание нового узла обмена выполняется с помощью кнопки Создать.

При нажатии на кнопку Синхронизация данных отобразится меню со следующими пунктами:

  • Выполнить обмен данными - будет выполнен обмен данными для выбранного в списке узла.
  • Показать зарегистрированные изменения - для выбранного в списке узла обмена откроется форма, в которой можно просмотреть все зарегистрированные изменения узла.
  • Информация о версии модуля обмена 1С-Битрикс - отобразится информация о номере версии используемого модуля обмена.
  • Открыть лог - откроется файл с логами обмена для выбранного узла за указанную дату.
  • Помощник импорта товара с сайта - откроется мастер импорта каталога товаров с сайта.

Кнопка Общие настройки включает в себя следующие действия:

  • Задать расписание для обмена в режиме реального времени - этот пункт меню активен только тогда, когда 1С работает в клиент-серверном варианте. При нажатии на этот пункт меню откроется окно настройки расписания регламентного задания, которое будет работать постоянно и принимать в режиме реального времени команды с сайта.
  • Импорт настроек обмена с сайтом из решения 1С - произойдет импорт настроек обмена с сайтом из решения 1С. Использование данной возможности целесообразно в начале использования модуля обмена для переноса настроек. Поиск ведется по наименованию.
  • Редактировать коды Битрикс у объектов 1С - откроется окно, на котором можно посмотреть и, при необходимости, отредактировать коды загруженных с сайта данных. Кроме того, для еще незагруженных элементов можно указать коды сайта, чтобы при загрузке данных модуль обмена не создавал новые объекты, а находил их по коду сайта.

Кнопка Запустить обмен в режиме реального времени служит для запуска режима, в котором сеанс 1С постоянно мониторит команду с сайта. В этом режиме сеанс 1С будет недоступен для работы. Для разблокировки необходимо нажать комбинацию клавиш Ctrl + Break. Кнопка активна только для файлового варианта работы 1С.

Форма создания/редактирования узла обмена имеет следующий вид:

Примечание: перечень параметров формы зависит от версии установленного модуля обмена.

Версионность параметров закладки "Основные настройки"

Поле | С версии
Режим обмена данными
Выгрузка товаров | 4.0.0.1
Обмен заказами | 4.0.0.1
Обмен пользовательскими справочниками | 4.0.0.1
Используется в режиме реального времени | 4.0.0.1
Контроль изменений
Полная выгрузка | 4.0.0.1
Выгружать только измененные объекты | 4.0.0.1
Настройка версионности выгружаемых данных | 4.0.4.2
Назначение
Выгружать на сайт:
  • Адрес сайта
  • Имя пользователя
  • Пароль
4.0.0.1
Выгружать в каталог на диске:
  • Каталог выгрузки
  • Файл загрузки заказов
4.0.0.1
Каталог лога
Каталог лога | 4.0.0.1
Выгружать лог на сайт | 4.0.0.1
Хранить файлы обмена на сайте | 4.0.1.1
Действия с неудачно отправленными пакетами
Число повторов при неудачно отправленных пакетах | 4.0.0.1
Тайм-аут между повторами неудачно отправленных пакетах | 4.0.0.1
Продолжить отправку неудачно закончившихся пакетов при следующем обмене | 4.0.0.1
Выполнять полную выгрузку принудительно | 4.1.0.1
Настройка автообмена
Использовать периодический обмен данными | 4.0.0.1

На закладке Основные настройки задаются базовые настройки параметров обмена. Наличие других закладок в форме зависит от выполненных основных настроек.

Наименование и Код заполнятся автоматически при сохранении настройки. Но вы можете задать их вручную при необходимости.

Режим обмена данными:

  • Отмеченная опция Выгрузка товаров означает, что должны выгружаться товары и информация по ним. При этом появляется соответствующая закладка Выгрузка товаров.
  • При отмеченной опции Обмен заказами с сайта будут выгружаться заказы в 1С и из 1С загружаться на сайт. При установке флажка появляется соответствующая закладка Обмен заказами.
  • Установленный флажок Обмен пользовательскими справочниками означает, что должны выгружаться пользовательские справочники из 1С, при этом появляется соответствующая закладка Обмен польз. справочников.
  • Отмеченная опция Используется в режиме реального времени означает, что настройка обмена используется при обмене в реальном времени.

    Важно!
    1. Только для заказов может осуществляться обмен в режиме реального времени.
    2. Только в одной настройке может быть отмечена опция Используется в режиме реального времени.

Контроль изменений:

  • Если выбрана Полная выгрузка, тогда выгружаться из 1С будут все данные, удовлетворяющие заданным отборам. Если данных в базе много, то обмен может выполняться продолжительное время.
  • При отмеченной опции Только изменения будут выгружаться только те данные, которые изменились. В этом случае скорость обмена существенно повышается.
  • По кнопке Настройка версионности выгружаемых данных открывается специальное окно:

    Оно служит для выбора объектов, для которых необходимо указать, что их версия всегда новая (т.е. он всегда будет участвовать в обмене) вне зависимости от того, изменился ли объект в 1С или нет.

Назначение:

  • При выборе опции Выгрузка на сайт данные будут выгружаться на сайт, настройки подключения к которому задаются в соответствующих полях:
    • Адрес сайта – адрес вашего сайта, содержащий путь до файла /bitrix/admin/1c_exchange.php (либо путь к странице с собственными настройками интеграции, см. урок Собственные настройки интеграции).
    • Пользователь – логин пользователя сайта под управлением 1С-Битрикс: Управление сайтом. Пользователь должен обладать правом на выполнение обмена данными, т.е. пользователь должен относиться к группе, указанной в настройках интеграции.
    • Пароль – пароль пользователя.
    При нажатии на кнопку Проверить, происходит проверка подключения к сайту.
  • Если отмечена опция Выгрузка в каталог на диск, то данные будут выгружаться в каталог на диске. Каталог обмена и файл загрузки заказов задаются в соответствующих полях.

В поле Каталог лога задается каталог, в котором будет храниться лог-файл обмена. Логи хранятся в разрезе дня в подчиненной папке reports. Кроме того, с помощью одноименных опций можно определить выгружать ли логи на сайт и хранить ли файлы обмена на сайте.

Действия с неудачно отправленными пакетами:

  • В поле Число повторов при неудачно отправленных пакетах указывается количество попыток отправки пакета с данными, если пакет отправился неудачно.
  • В поле Таймаут между повторами неудачно отправленных пакетах задается количество секунд, которое должно пройти перед тем, как обмен снова отправит неудачно отправленный пакет данных.
  • Если отмечена опция Продолжить отправку неудачно отправленных пакетов при следующем обмене и имеются неудачно отправленные пакеты, то при следующем обмене сперва произойдет довыгрузка неотправленных пакетов, а затем непосредственно сам обмен.
  • При отмеченной опции Выполнять полную выгрузку принудительно будет выполнена полная выгрузка данных.

Настройка автообмена:

Если отмечена опция Использовать периодический обмен данными то обмен будет выполняться по заданному расписанию. В зависимости от того, база 1С в файловом или клиент-серверном варианте, настройка автообмена отличается.

При установке флажка автоматически откроется форма настройки расписания обмена, в которой задается время начала и завершения обмена, дата начала и дата завершения, периодичность. Например, чтобы расписание выполнялось каждый день, в поле Повторять каждые должно стоять значение 1 день.

Примечание: в некоторых старых версиях редакции 11.1 могут потребоваться дополнительные настройки для автообмена:
  • Если база 1С в файловом варианте, то необходимо запустить специальный сеанс, обрабатывающий регламентные задания: Администрирование > Поддержка и обслуживание > Регламентные и фоновые задания > Команда Запустить отдельный сеанс.
  • Чтобы отдельный сеанс запускался автоматически для выполнения регламентных заданий при работе с базой данных, необходимо в настройках выполнения регламентных заданий (Администрирование > Поддержка и обслуживание > Регламентные и фоновые задания > Команда Настройка выполнения регламентных заданий) установить флажок Автоматически запускать отдельный сеанс для выполнения регламентных заданий.


Обмен данными
160 / 254

В данной главе детально рассматриваются настройки для тех данных, которые должны участвовать в обмене.


Выгрузка товаров
161 / 254

Для выгрузки товаров на сайт в форме настроек обмена должна быть отмечена опция Выгрузка товаров и настроены основные настройки. Затем следует перейти на закладку Выгрузка товаров и настроить параметры выгрузки:

Примечание: перечень параметров зависит от версии установленного модуля обмена.

Версионность параметров закладки "Выгрузка товаров"

Поле | С версии
Выгрузка справочных данных
Товары | 4.0.0.1
Настроить соответствия полей номенклатуры | 4.0.2.1
Картинки и файлы | 4.0.0.1
Свойства | 4.0.0.1
Настроить выгружаемые свойства | 4.0.0.1
Настройка свойств
Выгружать только используемые значения свойств | 4.0.0.1
Выгружать значения свойств в товары и предложения | 4.0.4.2
Предложения | 4.0.4.2
Настройка предложений
Выгружать штрихкоды | 4.0.0.1
Выгружать планируемую дату поступления товара | 4.0.2.1
Выгружать комплектующие | 4.1.0.1
Выгружать номенклатуру как предложение если у нее есть характеристики | 4.0.2.1
Выгружать характеристики только у которых есть остатки | 4.0.0.1
Выгружать предложения только с ценой | 4.0.2.1
Принудительное обновление данных (Принудительная полная выгрузка картинок и файлов) | 4.0.0.1
Выгрузка справочных данных
Выгружать цены | 4.0.0.1
Выгружать остатки | 4.0.0.1
Выгружать остатки по складам | 4.0.0.1
Выгружать остатки с учетом резерва | 4.0.0.1
Прочие настройки
Классифицировать по видам номенклатуры | 4.0.0.1
Количество товаров в пакете | 4.0.0.1
Таблица каталогов | 4.0.0.1

Выгрузка справочных данных:

  • При отмеченной опции Товары будет выгружена информация о товарах.

    Кнопка Настроить соответствия полей номенклатуры служит для настройки собственных соответствий полей номенклатуры. При ее нажатии открывается окно, в котором можно указать в какие поля xml-файла будут выгружаться те или иные данные:

  • При отмеченной опции Картинки и файлы будут выгружены картинки и файлы товаров, причем выгружаются только новые или измененные картинки и файлы. Опция доступна только при отмеченной опции Товары.
  • Если отмечена опция Свойства, то будут выгружены свойства товаров. В настройках ниже также будет доступен флаг Выгружать только используемые значения свойств, в противном случае - флаг Выгружать значения свойств в товары и предложения (см. ниже).

    Кнопка Настроить выгружаемые свойства служит для более детальной настройки выгружаемых свойств товаров. При ее нажатии открывается окно, в котором можно указать, какие свойства товаров должны храниться в Highload-блоках, какие влияют на цену, какие должны выгружаться в свойства предложений, а какие в свойства товаров:

    Примечание: свойство типа Файл всегда хранится в Highload-блоках.

Настройка свойств:

  • Если отмечена опция Выгружать только используемые значения свойств, то будут выгружены только те свойства, значения которых заданы хотя бы в 1 товаре. Опция доступна только при отмеченной опции Свойства (см. выше).
  • При отмеченной опции Выгружать значения свойств в товары и предложения значения свойств будут выгружены в товары и предложения. Опция доступна только, когда делается выгрузка без самих свойств, т.е. выше не отмечена опция Свойства.
  • При отмеченной опции Предложения будет выгружена информация о предложениях.

Настройка предложений:

  • Если установлен флаг Выгружать штрихкоды, тогда для товаров и их предложений будет выгружен их один штрихкод. Если штрихкоды не используются, то лучше флаг этот не ставить, чтобы не замедлять работу выгрузки.
  • При отмеченной опции Выгружать планируемую дату поступления товара будет выгружаться дата поступления товара.
  • Опция Выгружать комплектующие служит для выгрузки комплектов.

    Примечание: данный функционал находится в разработке.
  • При отмеченной опции Выгружать номенклатуру как предложение если у нее есть характеристики номенклатура при наличии у нее характеристик будет выгружаться в торговое предложение.
  • Отмеченная опция Выгружать характеристики только у которых есть остатки означает, что выгружены будут только те торговые предложения, количество которых больше нуля.
  • Если опция Выгружать предложения только с ценой отмечена, то будут выгружены только те торговые предложения, для которых задана цена. В противном случае - все.

Кнопка Принудительное обновление данных (до версии модуля 4.0.2.1 это была опция Принудительная полная выгрузка картинок и файлов) предназначена для выполнения процедуры выгрузки всех картинок независимо от того, есть ли они на сайте.
Полную выгрузку данных следует делать при первом обмене, а затем уже будет использоваться механизм версионности.

Выгрузка регистровых данных:

  • Если отмечена опция Выгружать цены, то для выгружаемых товаров будут выгружены цены. Цены выгружаются только для тех типов цен, которые удовлетворяют условию.
  • Если отмечена опция Выгружать остатки, то для выгружаемых товаров будут выгружены остатки. Остатки выгружаются только по тем складам, которые удовлетворяют условию.
  • При отмеченной опции Выгружать остатки по складам на сайте остатки будут вестись в разрезе складов.
  • При отмеченной опции Выгружать остатки с учетом резерва будут выгружаться с учетом резерва товара.

Опция Классифицировать номенклатуру по виду номенклатуры должна быть отмечена, если необходимо построить классификатор групп товаров по справочнику Виды номенклатуры. Иначе группы будут выгружаться из справочника Номенклатура.

С помощью поля Количество товаров в пакете задается сколько товаров должно быть в одном пакете с данными.

Таблица каталогов:

Примечание: должно быть задано хотя бы одно соответствие групп/видов номенклатуры каталогам на сайте.

  • В колонке Каталог задается название инфоблока на сайте.
  • В колонке Группы номенклатуры (или Виды номенклатуры, см. настройку опции Классифицировать номенклатуру по виду номенклатуры) настраивается фильтр выгрузки групп/видов номенклатуры. Например, нужно выгрузить на сайт каталог холодильников:

  • В колонке Идентификатор каталога задается идентификатор, по которому устанавливается связь выгружаемых данных с конкретным инфоблоком на сайте.
  • При нажатии на кнопку Настроить отбор появится окно, в котором можно указать параметры отбора выгружаемых данных:

    • Сегмент номенклатуры - отбор номенклатуры по сегментам номенклатуры;
    • Номенклатура - отбор по самой номенклатуре или группе;
    • Склад - отбор по выгружаемым складам. Остатки товара будут только по тем складам, которые удовлетворяют условию;
    • Свойство - отбор по свойствам номенклатуры. Будут выгружены только те свойства, которые удовлетворяют условию отбора;
    • Соглашение - отбор по выгружаемым соглашениям товаров, и, соответственно, ценам товаров. Соглашения выгружаются только типовые с признаком Доступно внешним пользователям и незаполненным реквизитом Сегмент партнеров;
    • Остаток - отбор по выгружаемым остаткам товаров.
  • При нажатии на кнопку Настроить дерево групп появляется окно, в котором можно задать произвольное пользовательское дерево групп товаров для выбранного инфоблока. Таким образом, можно создавать свои группы товаров, которые будут выгружены на сайт, не изменяя иерархию товаров в 1С. Причем один и тот же товар можно указать сразу нескольким группам.

    Слева создается пользовательский каталог, который будет выгружен на сайт. Вложенность групп может быть различной. Сначала создается группа, потом ей назначается список товаров/групп.

Выполнение выгрузки товаров на сайт

Автоматическая выгрузка товаров осуществляется в соответствии с настройками автообмена. Для ручного запуска процесса выгрузки товаров необходимо:

  • в форме создания/редактирования настройки обмена нажать кнопку Выполнить обмен данными:

  • либо в форме списка настроек обмена выбрать нужный узел и нажать пункт Выполнить обмен данными в меню кнопки Синхронизация данных:

По окончании выгрузки результат можно просмотреть в административном разделе вашего сайта:


Обмен заказами
162 / 254

Для обмена заказами в форме настроек обмена должна быть отмечена опция Обмен заказами и выполнены основные настройки. Затем следует перейти на закладку Обмен заказами и настроить параметры обмена заказа необходимым для вас образом. Для удобства содержимое закладки Обмен заказами разделено на три вкладки:

  • Обмен заказами
  • Обмен контрагентами
  • Отбор и сортировка

После того, как все настройки выполнены, можно сохранить настройку и выполнить обмен.

Выполнение обмена заказами

Автоматический обмен заказами осуществляется в соответствии с настройками автообмена. Для ручного запуска процесса обмена необходимо:

  • в форме создания/редактирования настройки обмена нажать кнопку Выполнить обмен данными:

  • либо в форме списка настроек обмена выбрать нужный узел и нажать пункт Выполнить обмен данными в меню кнопки Синхронизация данных:

Для просмотра выгруженных с сайта заказов в 1С следует воспользоваться пунктом меню Продажи > Заказы клиентов. Откроется форма со списком всех заказов, среди которых будут находиться и заказы с сайта:

Если в настройке обмена указано, чтобы заказы из 1С загружались на сайт, то для просмотра загруженных на сайт заказов следует перейти в административный раздел на страницу со списком заказов (Магазин > Заказы):

Просмотр выгруженных из 1С контрагентов (если настроена выгрузка) осуществляется на странице со списком пользователей (Настройки > Пользователи > Список пользователей):

Причем контрагенты, которые были заданы в загружаемых на сайт заказах, будут отображаться в списке покупателей (Магазин > Покупатели > Список покупателей):


Обмен заказами
163 / 254

На вкладке Обмен заказами указывается, как заказы должны выгружаться с сайта, с какими параметрами загружаться на сайт:

Версионность параметров закладки "Обмен заказами"

Поле | С версии | До версии
Выгрузка заказов из 1С
Выгружать все заказы | 4.0.0.1
Точка актуальности выгрузки | 4.0.0.1
Выгрузка отгрузок заказов | 4.0.0.1
Количество заказов в пакете | 4.0.0.1
Загрузка заказов в 1С
Не обновлять документы пришедшие с сайта | 4.0.0.1
Загрузка оплат вместе с заказами | 4.0.0.1
Загрузка отгрузок вместе с заказами | 4.0.0.1
кнопка Настроить загружаемые документы | 4.1.0.1
Загрузка товаров в 1С
Группа для новой номенклатуры | 4.0.0.1
Вид номенклатуры (товар) | 4.0.0.1
Вид номенклатуры (услуга) | 4.0.0.1
Дополнительные параметры документов | 4.1.0.1
Соответствия статусов заказов/Соответствия платежных систем и касс/Соответствия статусов отгрузок | 4.0.0.1
Параметры отмены заказов
  • Статус заказа "Отменен"
  • Причина отмены заказа
4.1.0.1
Если контрагент физ. лицо:
  • Общий контрагент "физлицо"
  • Соглашение контрагента "физлицо"
4.0.0.1
Параметры создания документов | 4.1.0.1
Действия с документами, пришедшими с WEB-сайта | 4.1.0.1

Выгрузка заказов из 1С:

  • При отмеченной опции Выгружать все заказы будут выгружены все заказы, в том числе и те, которые не были созданы на сайте.
  • С помощью поля Точка актуальности выгрузки заказов указывается дата, начиная с которой и по текущий момент заказы будут выгружаться на сайт.
  • Если отмечена опция Выгрузка отгрузок заказов, то вместе с заказами будут выгружены их отгрузки.
  • В поле Количество заказов в пакете указывается, сколько заказов будет в одном пакете данных.

Загрузка заказов в 1С:

  • При отмеченной опции Загрузка оплат вместе с заказами для оплаченных заказов будет создан приходный кассовый ордер.
  • Если отмечена опция Загрузка отгрузок вместе с заказами, то модуль обмена будет загружать отгрузки, созданные или отредактированные на сайте.
  • Если отмечена опция Не обновлять документы пришедшие с сайта, то при повторной выгрузке документов с сайта документы в 1С не будут обновляться.
  • По кнопке Настроить загружаемые документы открывается окно, в котором выполняется настройка соответствий загружаемых документов о заказах в 1С (всего доступно 3 вида документов):

    Чтобы настроить реквизиты для конкретного документа выберите его в списке и нажмите Настроить соответствия реквизитов. Отобразятся все доступные реквизиты для шапки документа, для которых можно указать какие поля откуда заполняются. Так, в соответствующих полях необходимо задать организацию, выбрать типовое соглашение, указать менеджера, подразделение и склад, которые будут подставляются в новые или отредактированные документы, пришедшие с сайта.

    Настройка соответствий табличной части документа выполняется аналогично: для выбранной табличной части следует нажать Настроить соответствия реквизитов и задать необходимые значения для реквизитов.

    Примечание: до версии модуля обмена 4.1.0.1 настройки для документов задавались с помощью следующих полей:

Загрузка товаров в 1С:

  • В поле Группа для новой номенклатуры можно указать группу, в которую будут помещаться товары и услуги, создаваемые при загрузке заказов с сайта.
  • В поле Вид номенклатуры (товар/услуга) задается вид номенклатуры, с которой будут записываться новые товары/услуги, загруженные с сайта.

Дополнительные параметры документов:

На вкладке Соответствия элементов задаются соответствия статусов сайта и 1С, а также для оплат задается соответствие платежных систем и касс. Для удобства статусы сайта и платежные системы можно загрузить непосредственно с сайта (кнопка Загрузить с сайта).

На вкладке Параметры отмены заказов задаются статус отмененного заказа и причина его отмены.

Если на вкладке Если контрагент физ. лицо заполнены поля Общий контрагент "физлицо" и Соглашение контрагента "физлицо", то в новые заказы будет подставляться этот контрагент, когда у клиента с сайта стоит признак физическое лицо.


Обмен контрагентами
164 / 254

На вкладке заказов Обмен контрагентами указываются настройки по выгрузке/загрузке контрагентов. Информация о контрагентах с сайта выгружается вместе с документами.

Примечание: перечень параметров зависит от версии установленного модуля обмена.

Версионность параметров закладки "Обмен контрагентами"

Поле | С версии
Выгрузка контрагентов из 1С
Синхронизация контрагентов | 4.0.0.1
Количество контрагентов в пакете | 4.0.0.1
Загрузка контрагентов в 1С
Способ идентификации контрагентов | 4.0.0.1
Группа для новых контрагентов | 4.0.0.1
Подставлять ФИО в полное наименование физ.лиц | 4.0.5.1
Не редактировать контрагентов пришедших с сайта | 4.0.2.1
Соответствие адресов контрагентов
Юридическое лицо (таблица соответствий) | 4.0.1.1
Физическое лицо (таблица соответствий) | 4.0.1.1

Выгрузка контрагентов из 1С:

  • При установке флага Синхронизация контрагентов, из 1С будут выгружены контрагенты, удовлетворяющие условию по указанным отборам на вкладке Отбор и сортировка.
  • В поле Количество контрагентов в пакете задается число контрагентов, которые будут выгружаться в одном пакете данных.

Загрузка контрагентов в 1С:

  • В поле Способ идентификации контрагентов указывается, как будут искаться контрагенты по базе или, если контрагент не будет найден, по уникальному идентификатору или коду с сайта. Поиск контрагентов может быть или по наименованию, или по ИНН+КПП.
  • В поле Группа для новых контрагентов указывается группа контрагентов для новых контрагентов, созданных модулем обмена с этой настройкой обмена.
  • При отмеченной опции Подставлять ФИО в полное наименование физ.лиц полное наименование контрагента будет браться из полей XML-файла с фамилией, именем и отчеством.
  • При отмеченной опции Не редактировать контрагентов пришедших с сайта информация о контрагентах обновляться в 1С не будет.

Соответствие адресов контрагентов:

В данной секции настраивается соответствие адресов для новых контрагентов, которые загружаются в 1С. Соответствие задается для каждого типа лица с помощью таблицы:

  • В колонке Наименование поля в XML указывается название передаваемого в xml-файле поля с адресом.
  • В колонке Тип выбирается сущность 1С (контрагент или партнер), в которую будут занесены данные.
  • В колонке Вид контактной информации выбирается поле адреса контрагента, в которое должны быть занесены данные.


Отбор и сортировка
165 / 254

На вкладке заказов Отбор и сортировка задаются условия отбора для выгружаемых заказов и контрагентов. Заказы, помимо точки актуальности, можно ограничить по заказам, организациям и подразделениям, а контрагенты - по контрагентам.

Версионность параметров закладки "Отбор и сортировка"

Поле | С версии
Отборы выгружаемых заказов
Таблица с условиями отбора | 4.0.0.1
Отборы выгружаемых контрагентов
Таблица с условиями отбора | 4.0.0.1


Выгрузка справочников из 1С
166 / 254

Начиная с версии 14.5.1 модуля Торговый каталог, в продукте доступен компонент catalog.import.hl. С его помощью осуществляется импорт справочников из 1С на сайт, причем каждый справочник будет загружен в отдельный Highload-блок. Вся процедура выполняется на стороне 1С.

В 1С:Предприятие перейдите в список узлов обмена с сайтами: Администрирование > Подсистема Битрикс (или Битрикс) > Обмен с сайтами. Выберите необходимый вам узел обмена (либо создайте новый). Откроется форма настроек узла:

На закладке Основные настройки задайте базовые настройки для выгрузки справочников из 1С:

  • Отметьте опцию Обмен пользовательскими справочниками. Станет доступной закладка Обмен польз. справочников.
  • Чтобы выгрузка выполнялась на сайт, отметьте опцию Выгружать на сайт и в поле Адрес сайта укажите адрес вашего сайта, содержащий путь до файла /bitrix/admin/1c_exchange.php (именно в этом файле подключен необходимый компонент catalog.import.hl).
  • Остальные параметры этой закладки настройте необходимым вам образом.

После чего перейдите на закладку Обмен польз. справочников. С помощью кнопки Добавить выберите те справочники из базы 1С, которые должны быть выгружены на сайт. При выборе строки с названием справочника в таблице ниже отобразятся все доступные его поля.

Чтобы необходимое поле справочника выгружалось, отметьте опцию Выгружено в соответствующей строке с названием поля.

Примечание: если значение поля является ссылкой, то для выгрузки наименования ссылочного элемента следует отметить опцию Выгружать как строка, иначе будет выгружен идентификатор данного поля.

Когда все настройки выполнены, нажмите кнопку Выполнить обмен данными. Начнется процесс импорта справочников на сайт. По его окончании в 1С будет отображено соответствующее сообщение.

Для проверки выполненных действий перейдите в административный раздел вашего сайта:


Загрузка каталога товаров с сайта в 1С
167 / 254

Начиная с версии продукта 12.5, доступна возможность экспорта каталога товаров с сайта в 1С: Предприятие. В 1С-Битрикс: Управление сайтом указываются только какие товары должны быть выгружены (см. форму интеграции), а сама процедура выполняется со стороны 1С.

В 1С:Предприятие перейдите в Администрирование и кликнете по пункту меню Обмен с сайтами. Откроется форма со списком узлов обмена с сайтами. Нажмите кнопку Синхронизация данных и выберите пункт Помощник импорта товаров с сайта под управлением CMS 1С-Битрикс:

Откроется мастер импорта товаров с сайта:

  • В поле Адрес укажите адрес вашего сайта, содержащий путь до файла /bitrix/admin/1c_exchange.php (либо путь к странице с собственными настройками интеграции).
  • В поле Авторизация задайте логин и пароль пользователя из 1С-Битрикс: Управление сайтом, который обладает правом на выгрузку каталога с сайта (т.е. пользователь должен относится к группе, указанной в настройках интеграции).

Нажмите кнопку Далее.

На следующем шаге задайте параметры импорта товаров в 1С:

  • Укажите Вид номенклатуры загружаемых товаров, чаще всего это Товар.
  • В поле Единица измерения укажите шт.
  • В поле Загружать товары в группу задайте группу, в которую товары должны быть загружены. Группу можно выбрать как среди существующих, так и создать новую.
  • Отметьте необходимые для вас опции загрузки товаров в 1С:
    • Создавать группы - в 1С попадет иерархия групп товаров, в которых будет сам товар;
    • Создавать свойства товаров - с сайта будут выгружены свойства товаров;
    • Создавать характеристики товаров - будут выгружены характеристики товаров;
    • Устанавливать цены - будут импортированы цены товаров и при необходимости типы цен.
    • Загружать картинки - вместе с товарами будут загружены картинки.

Нажмите кнопку Далее. Отобразится информация о процедуре импорта каталога товаров с сайта:

Нажмите кнопку Начать импорт. В процессе импорта, когда система получит данные с сайта, она запросит у вас разрешение на загрузку товаров. После того, как товары будут загружены в базу 1С, система запросит разрешение на загрузку изображений (если соответствующая опция была отмечена). По окончании процедуры импорта будет выведен протокол загрузки товаров:

Для проверки выполненных действий перейдите в Продажи > Номенклатура:


Обмен в режиме реального времени
168 / 254

Примечание: обмен заказами между 1С и сайтом в режиме реального времени доступен только при соблюдении следующих условий:
  1. модуль Интернет-магазин должен быть версии 14.5.0 или выше;
  2. в 1С должен быть установлен модуль обмена 4.0.х.х.

Режим обмена заказами в реальном времени реализован таким образом, что в 1С постоянно висит один сеанс, который ждет сообщения с сайта. Если на сайте создали или отредактировали заказ, то в 1С посылается сигнал, чтобы 1С выполнила обмен заказами. Каждые 40 секунд (по умолчанию) соединение с сайтом обрывается и происходит новое соединение.

При авторизации на сайте к адресу сайта добавляется параметр ?type=listen. Параметр необходим, чтобы сайт «знал», что это соединение для режима реального времени.

Сайт может вернуть 2 кода состояния:

  • 200 - надо выполнить обмен. Признак того, на каком узле должен быть выполнен обмен, определяется настройками опции Используется в режиме реального времени (опция может быть отмечена только в одной настройке обмена):

  • 302 - нужно сделать переадресацию и снова посмотреть код состояния. Адрес переадресации берется из заголовка Location.

Механизм обмена в режиме реального времени зависит от варианта работы базы 1С:

  • Если база в файловом варианте работы, тогда активный сеанс 1С ждет сообщение с сайта. Для прекращения режима реального времени необходимо закрыть сеанс или разблокировать его, нажав на комбинацию клавиш Ctrl + Break.

    Запуск режима обмена заказами в реальном времени осуществляется с помощью одноименной кнопки:

  • Если база в клиент-серверном варианте, тогда фоновое задание ждет сообщения с сайта. Временной интервал, в котором работает режим реального времени, задается в расписании задания:

    В результате будет запущен режим обмена заказами в реальном времени с учетом заданного вами временного интервала.

Таким образом, все сделанные в интернет-магазине заказы в режиме реального времени попадают в 1С. Если параметры заказа были изменены в 1С либо в 1С были созданы новые заказы, то все изменения будут автоматически отражены и на сайте.


Прочие возможности модуля обмена
169 / 254


Просмотр и редактирование зарегистрированных изменений
170 / 254

Для просмотра зарегистрированных изменений необходимо перейти к списку узлов обмена (Администрирование > Обмен с сайтами), выбрать необходимый вам узел и нажать на пункт Показать зарегистрированные изменения кнопки Синхронизация данных.

Откроется окно с информацией о всех зарегистрированных изменениях узла обмена. Просматривать изменения можно вплоть до элементов, разворачивая их в дереве:

Кроме того, вы можете не только просматривать изменения, но и удалять их.


Редактирование кодов Битрикс у объектов 1С
171 / 254

Чтобы перейти к редактированию кодов Битрикс у объектов 1С, следует в форме со списком узлов обмена (Администрирование > Обмен с сайтами) нажать кнопку Общие настройки и выбрать пункт Редактировать коды битрикс у объектов 1С:

Откроется форма следующего вида:

В поле Тип объекта указывается тип объекта 1С, для которого нужно посмотреть/редактировать коды. Он может быть одним из следующих:

  • Справочники;
  • Документы;
  • Планы видов характеристик.

В поле Объект 1С указывается объект, коды элементов которого необходимо посмотреть/отредактировать. Список доступных объектов формируется в зависимости от указанного типа объекта 1С. Указать объекты 1С можно только те, которые могут хранить коды Битрикс.

При нажатии на кнопку Записать изменения измененные коды элементов будут перезаписаны в элементе 1С.


Режим логирования проводимых операций
172 / 254

В новом модуле обмена реализован механизм логирования. В лог записываются все ключевые данные по формированию, транспорту и обработке на сайте. Лог-файл хранится не только в каталоге, установленном в настройке обмена, но и может быть выгружен на сайт. На сайте он хранится в папке /upload/1c_catalog/Reports.

Лог-файл ведется в разрезе дня и для каждой настройки обмена он свой. После каждого обмена лог-файл дописывается. На сайте лог- файлы хранятся несколько дней, причем для уменьшения времени его передачи на сайт он архивируется.

Чтобы просмотреть лог-файл из 1С для некоторой настройки обмена, следует выбрать необходимую настройку и нажать пункт Открыть лог в меню кнопки Синхронизация данных:

Затем в нужно указать дату, на которую требуется просмотреть лог-файл обмена:

В результате откроется лог-файл выполнения обмена данными в заданный день:


Интеграция с "1С:Управление небольшой фирмой"
173 / 254

В данной главе описаны для обмена данными настройки со стороны 1С:Управление небольшой фирмой. Описание настроек приведено с учетом того, что в 1С установлен модуль обмена.

Примечание: дополнительно вы можете ознакомиться с записью вебинара по интеграции с 1С:УНФ.


Узлы обмена с сайтами
174 / 254

Чтобы перейти к настройкам обмена с сайтами, следует открыть список узлов обмена (Настройки > Обмен с сайтами). В списке всегда есть предопределенный узел обмена, который нельзя использовать. Он с незаполненным наименованием.

При нажатии на кнопку Синхронизация данных отобразится всплывающее меню со следующими пунктами:

  • Выполнить обмен данными - будет выполнен обмен данными для выбранного в списке узла.
  • Показать зарегистрированные изменения - для выбранного в списке узла обмена откроется форма, в которой можно просмотреть все зарегистрированные изменения узла.
  • Информация о версии модуля обмена 1С-Битрикс - отобразится информация о номере версии используемого модуля обмена.
  • Открыть лог - откроется файл с логами обмена для выбранного узла за указанную дату.
  • Помощник импорта товара с сайта - откроется мастер импорта каталога товаров с сайта.

Кнопка Общие настройки включает в себя следующие действия:

  • Редактировать коды Битрикс у объектов 1С - откроется окно, на котором можно посмотреть и, при необходимости, отредактировать коды загруженных с сайта данных. Кроме того, для еще незагруженных элементов можно указать коды сайта, чтобы при загрузке данных модуль обмена не создавал новые объекты, а находил их по коду сайта.
  • Задать расписание для обмена в режиме реального времени - этот пункт меню активен только тогда, когда 1С работает в клиент-серверном варианте. При нажатии на этот пункт меню откроется окно настройки расписания регламентного задания, которое будет работать постоянно и принимать в режиме реального времени команды с сайта.

Кнопка Запустить обмен в режиме реального времени служит для запуска режима, в котором сеанс 1С постоянно мониторит команду с сайта. В этом режиме сеанс 1С будет недоступен для работы. Для разблокировки необходимо нажать комбинацию клавиш Ctrl + Break. Кнопка активна только для файлового варианта работы 1С.

Примечание: подробнее про механизм работы режима обмена в реальном времени смотрите в уроке Обмен в режиме реального времени (для 1С:УТ 11.1).

Форма создания/редактирования узла обмена имеет следующий вид:

Наименование и Код заполнятся автоматически при сохранении настройки. Но вы можете задать их вручную при необходимости.

На закладке Основные настройки задаются базовые настройки параметров обмена. Наличие других закладок в форме зависит от выполненных основных настроек.

Режим обмена данными:

  • Отмеченная опция Выгрузка товаров означает, что должны выгружаться товары и информация по ним. При этом появляется соответствующая закладка Выгрузка товаров.
  • При отмеченной опции Обмен заказами с сайта будут выгружаться заказы в 1С и из 1С загружаться на сайт. При установке флажка появляется соответствующая закладка Обмен документов.
  • Установленный флажок Обмен пользовательскими справочниками означает, что должны выгружаться пользовательские справочники из 1С, при этом появляется соответствующая закладка Обмен польз. справочников.
  • Отмеченная опция Используется в режиме реального времени означает, что настройка обмена используется при обмене в реальном времени.

    Важно!
    1. Только для заказов может осуществляться обмен в режиме реального времени.
    2. Только в одной настройке может быть отмечена опция Используется в режиме реального времени.

Контроль изменений:

  • Если выбрана Полная выгрузка, тогда выгружаться из 1С будут все данные, удовлетворяющие заданным отборам. Если данных в базе много, то обмен может выполняться продолжительное время.
  • При отмеченной опции Только изменения будут выгружаться только те данные, которые изменились. В этом случае скорость обмена существенно повышается.

Назначение:

  • При выборе опции Выгрузка на сайт данные будут выгружаться на сайт, настройки подключения к которому задаются в соответствующих полях:
    • Адрес сайта – адрес вашего сайта, содержащий путь до файла /bitrix/admin/1c_exchange.php (либо путь к странице с собственными настройками интеграции, см. урок Собственные настройки интеграции).
    • Пользователь – логин пользователя сайта под управлением 1С-Битрикс: Управление сайтом. Пользователь должен обладать правом на выполнение обмена данными, т.е. пользователь должен относиться к группе, указанной в настройках интеграции.
    • Пароль – пароль пользователя.
    При нажатии на кнопку Проверить соединение, происходит проверка подключения к сайту.
  • Если отмечена опция Выгружать в каталог на диске, то данные будут выгружаться в каталог на диске. Каталог обмена и файл загрузки заказов задаются в соответствующих полях.

В поле Каталог лога задается каталог, в котором будет храниться лог-файл обмена. Логи хранятся в разрезе дня в подчиненной папке reports. Кроме того, с помощью одноименных опций можно определить выгружать ли логи на сайт и хранить ли файлы обмена на сайте.

Действия с неудачно отправленными пакетами:

  • В поле Число повторов при неудачно отправленных пакетах указывается количество попыток отправки пакета с данными, если пакет отправился неудачно.
  • В поле Тайм-аут между повторами неудачно отправленных пакетах задается количество секунд, которое должно пройти перед тем, как обмен снова отправит неудачно отправленный пакет данных.
  • Если отмечена опция Продолжить отправку неудачно отправленных пакетов при следующем обмене и имеются неудачно отправленные пакеты, то при следующем обмене сперва произойдет довыгрузка неотправленных пакетов, а затем непосредственно сам обмен.
  • Если отмечена опция Выполнить полную выгрузку принудительно, то независимо от того, стоит ли полная выгрузка или изменения – будет произведена полная выгрузка. После удачного обмена с сайтом, признак снимается автоматически. При создании узла обмена – флаг автоматически установлен.

Настройка автообмена:

Если отмечена опция Использовать периодический обмен данными то обмен будет выполняться по заданному расписанию. В зависимости от того, база 1С в файловом или клиент-серверном варианте, настройка автообмена отличается.

При установке флажка автоматически откроется форма настройки расписания обмена, в которой задается время начала и завершения обмена, дата начала и дата завершения, периодичность.


Обмен данными
175 / 254

В данной главе детально рассматриваются настройки для тех данных, которые должны участвовать в обмене.


Выгрузка товаров
176 / 254

Для выгрузки товаров на сайт в форме настроек обмена должна быть отмечена опция Выгрузка товаров и настроены основные настройки. Затем следует перейти на закладку Выгрузка товаров и настроить параметры выгрузки:

Выгрузка справочных данных:

  • При отмеченной опции Товары будет выгружена информация о товарах.
  • Если отмечена опция Свойства товаров, то будут выгружены как сами свойства, так и заполненные свойства у товаров.
  • При отмеченной опции Картинки и файлы будут выгружены картинки и файлы товаров, причем выгружаются только новые или измененные картинки и файлы.
  • При отмеченной опции Предложения будут выгружены предложения товаров.
  • Если установлен флаг Выгружать штрихкоды, тогда для товаров и их предложений будет выгружен их один штрихкод. Если штрихкоды не используются, то лучше флаг этот не ставить, чтобы не замедлять работу выгрузки.
  • При отмеченной опции Выгружать планируемую дату поступления товара будет выгружаться дата поступления товара.
  • Кнопка Принудительное обновление данных предназначена для выполнения процедуры выгрузки всех картинок независимо от того, есть ли они на сайте.
    При переходе на новый модуль обмена рекомендуется выполнять эту операцию.

Тонкая настройка выгрузки данных:

  • При отмеченной опции Выгружать номенклатуру как предложение если у нее есть характеристики номенклатура при наличии у нее характеристик будет выгружаться в торговое предложение.
  • Отмеченная опция Выгружать характеристики только у которых есть остатки означает, что выгружены будут только те торговые предложения, количество которых больше нуля.
  • Если опция Выгружать предложения только с ценой отмечена, то будут выгружены только те торговые предложения, для которых задана цена. В противном случае - все.
  • Опция Выгружать только используемые значения свойств служит для дополнительного отбора по выгружаемым значениям свойств. При установленном флаге, если значение свойства в товарах не использовалось (вне зависимости от отбора), то такое значение не выгружается.

Выгрузка регистровых данных:

  • Если отмечена опция Выгружать цены, то для выгружаемых товаров будут выгружены цены. Цены выгружаются только для тех типов цен, которые удовлетворяют условию.
  • Если отмечена опция Выгружать остатки, то для выгружаемых товаров будут выгружены остатки. Остатки выгружаются только по тем складам, которые удовлетворяют условию.
  • При отмеченной опции Выгружать остатки по складам на сайте остатки будут вестись в разрезе складов.
  • При отмеченной опции Выгружать остатки с учетом резерва будут выгружаться с учетом резерва товара.

Опция Классифицировать номенклатуру по виду номенклатуры должна быть отмечена, если необходимо построить классификатор групп товаров по справочнику Виды номенклатуры. Иначе группы будут выгружаться из справочника Номенклатура.

С помощью поля Количество товаров в пакете задается сколько товаров должно быть в одном пакете с данными.

Таблица каталогов:

Примечание: должно быть задано хотя бы одно соответствие групп/видов номенклатуры каталогам на сайте.

  • В колонке Каталог задается название инфоблока на сайте.
  • В колонке Группы номенклатуры (или Виды номенклатуры, см. настройку опции Классифицировать номенклатуру по виду номенклатуры) настраивается фильтр выгрузки групп/видов номенклатуры.
  • В колонке Идентификатор каталога задается идентификатор, по которому устанавливается связь выгружаемых данных с конкретным инфоблоком на сайте.
  • При нажатии на кнопку Настроить отбор появится окно, в котором можно указать параметры отбора выгружаемых данных:

    • Номенклатура - отбор по самой номенклатуре или группе;
    • Склад - отбор по выгружаемым складам. Остатки товара будут только по тем складам, которые удовлетворяют условию;
    • Свойство - отбор по свойствам номенклатуры. Будут выгружены только те свойства, которые удовлетворяют условию отбора;
    • Остаток - отбор по остатку товаров. Будет выгружена только та номенклатура, остаток которой больше указанного количества по выгружаемым складам;
    • Вид цены - отбор по выгружаемым видам цен.
  • При нажатии на кнопку Настроить дерево групп появляется окно, в котором можно задать произвольное пользовательское дерево групп товаров для выбранного инфоблока. Таким образом, можно создавать свои группы товаров, которые будут выгружены на сайт, не изменяя иерархию товаров в 1С. Выгружены будут только те товары, которые указаны в дереве групп.

    Слева создается пользовательский каталог, который будет выгружен на сайт. Вложенность групп может быть различной. Сначала создается группа, потом ей назначается список товаров/групп. Созданное дерево групп может быть сохранено в файл или импортировано из файла.

На вкладке Настройка соответствий полей номенклатуры можно указать в какие поля xml-файла будут выгружаться те или иные данные:

Основные реквизиты постоянны. Ограничений на дополнительные реквизиты нет. Служебные поля xml-файла редактировать нельзя.

Значения наименований полей 1С могут быть как предопределенные (например Штрихкод, Наименование), так и произвольные. Произвольным полем 1С может быть кусок кода 1С, обращение к номенклатуре происходит через «Номенклатура.». Например, в поле XML наименование можно вставить выражение «Номенклатура.Артикул + « - » + СокрлЛП(Номенклатура.Наименование)», в результате чего уже на сайт попадет номенклатура с наименованием, склеенным с артикулом.

Использование произвольных полей 1С немного замедляет выгрузку данных из 1С.

На вкладке Настройка выгружаемых свойств можно указать, какие свойства товаров должны храниться в Highload-блоках, какие влияют на цену, какие должны выгружаться в свойства предложений, а какие в свойства товаров:

Примечание: свойство типа Файл всегда хранится в Highload-блоках.

Выполнение выгрузки товаров на сайт

Автоматическая выгрузка товаров осуществляется в соответствии с настройками автообмена. Для ручного запуска процесса выгрузки товаров необходимо:

  • в форме создания/редактирования настройки обмена нажать кнопку Выполнить обмен данными;
  • либо в форме списка настроек обмена выбрать нужный узел и нажать пункт Выполнить обмен данными в меню кнопки Синхронизация данных.

По окончании выгрузки результат можно просмотреть в административном разделе вашего сайта.


Обмен заказами
177 / 254

Для обмена заказами в форме настроек обмена должна быть отмечена опция Обмен заказами и выполнены основные настройки. Затем следует перейти на закладку Обмен заказами и настроить параметры обмена заказа необходимым для вас образом. Для удобства содержимое закладки Обмен заказами разделено на три вкладки:

  • Обмен документов
  • Обмен контрагентами
  • Отбор и сортировка

После того, как все настройки выполнены, можно сохранить настройку и выполнить обмен.

Выполнение обмена заказами

Автоматический обмен заказами осуществляется в соответствии с настройками автообмена. Для ручного запуска процесса обмена необходимо:

  • в форме создания/редактирования настройки обмена нажать кнопку Выполнить обмен данными;
  • либо в форме списка настроек обмена выбрать нужный узел и нажать пункт Выполнить обмен данными в меню кнопки Синхронизация данных.

Если в настройке обмена указано, чтобы заказы из 1С загружались на сайт, то для просмотра загруженных на сайт заказов следует перейти в административный раздел на страницу со списком заказов (Магазин > Заказы).

Просмотр выгруженных из 1С контрагентов (если настроена выгрузка) осуществляется на странице со списком пользователей (Настройки > Пользователи > Список пользователей). Причем контрагенты, которые были заданы в загружаемых на сайт заказах, будут отображаться в списке покупателей (Магазин > Покупатели > Список покупателей).


Обмен документов
178 / 254
На вкладке Обмен документов указывается, как заказы должны выгружаться с сайта, с какими параметрами загружаться на сайт:

Выгрузка заказов из 1С:

  • При отмеченной опции Выгружать все заказы будут выгружены все заказы, в том числе и те, которые не были созданы на сайте.
  • С помощью поля Точка актуальности выгрузки заказов указывается дата, начиная с которой и по текущий момент заказы будут выгружаться на сайт.
  • Если отмечена опция Выгрузка отгрузок заказов, то вместе с заказами будут выгружены их отгрузки.
  • В поле Количество заказов в пакете указывается, сколько заказов будет в одном пакете данных.

Загрузка заказов в 1С:

  • Если отмечена опция Не обновлять документы пришедшие с сайта, то при повторной выгрузке документов с сайта документы в 1С не будут обновляться.
  • При отмеченной опции Формирование оплаты, если заказ оплачен для оплаченных заказов будет создан приходный кассовый ордер.
  • Если отмечена опция Загрузка отгрузок вместе с заказами, то модуль обмена будет загружать отгрузки, созданные или отредактированные на сайте.
  • По кнопке Настроить соответствия полей загружаемых документов открывается окно, в котором настраивается заполнение реквизитов загружаемых документов. При создании узла обмена соответствия загружаемых полей заполняются по умолчанию.

    Левая верхняя таблица:

    В левой верхней таблице отображены все загружаемые документы. В этой таблице можно указать:

    • какая дата документа подставляется: дата на момент загрузки документа в 1С или же дата создания документа на сайте;
    • откуда берется номер документа: подставляется автоматически из 1С или приходит с сайта;
    • режим записи документа: записывать, проводить оперативно, проводить не оперативно;
    • действия с отмененными документами: помечать на удаление, отменять проведение, ничего не делать. Если на документ есть ссылки, то документ не будет отменен.

    Правая верхняя таблица:

    В правой верхней таблице отображаются все реквизиты указанного документа. Для того чтобы реквизиты документа отобразились в таблице, необходимо нажать на кнопку Настроить соответствия реквизитов, которая находится в верхней левой таблице.

    Тип данных заполнения реквизита может быть следующим:

    1. Из поля XML - если выбран этот тип, тогда значение будет найдено по алгоритму, указанному в колонке Значение. Как правило, алгоритмы реализованы на основании данных XML. При указании этого типа в колонке Значение появляется предопределенный список значений алгоритмов.
    2. Фиксированное значение - если выбран этот тип, тогда в реквизит документа будет подставляться указанное фиксированное значение. При указании этого типа данных тип значения фиксированного значения определяется автоматически.
    3. Из дополнительных свойств документа (по наименованию) - при указании этого типа значение реквизита будет искаться по следующему алгоритму:
      • Смотрится, есть ли свойство документа (задается в профилях обмена) с указанным наименованием, которое указывается в колонке Значение.
      • Если такое свойство есть и оно заполнено, то определяется тип реквизита документа. Если их несколько (составное), то - массив.
      • Перебираются все элементы объектов 1С указанного типа объекта (или нескольких). Первый найденный элемент с наименованием, указанным в свойстве заказа, будет подставлен в реквизит.
    4. Из дополнительных свойств (по идентификатору). Примерно то же самое, что и выше (см. по наименованию), но элемент ищется не по наименованию, а по уникальному идентификатору. Имеет смысл использовать в связке с highload-блоками, которые будут хранить значения выгруженных справочников.

    Левая нижняя таблица:

    В нижней левой части документа отображены все заполняемые табличные части указанного документа (добавление новых табличных частей пока отключено). В колонке Поле XML указывается наименование подчиненного элемента, из которого берутся данные. Если значение не заполнено, то будет создана всего одна строка.

    Правая нижняя таблица:

    В нижней правой части отображаются все реквизиты указанной табличной части документа. Для того чтобы реквизиты документа отобразились в таблице, необходимо нажать на кнопку Настроить соответствия реквизитов, которая находится в нижней левой таблице.

    Заполняются реквизиты так же, как и реквизиты документа, с единственным отличием, что у табличной части больше предопределенных алгоритмов.

Загрузка товаров в 1С:

  • В поле Группа для новой номенклатуры можно указать группу, в которую будут помещаться товары и услуги, создаваемые при загрузке заказов с сайта.

Соответствия статусов и оплат:

  • На вкладках задаются соответствия статусов заказов сайта с 1С и соответствия касс с платежными системами. В зависимости от пришедшего статуса с сайта в документе он будет подставлен по соответствию. Название соответствий и их идентификаторов можно загрузить с сайта, нажав на соответствующую кнопку.


Обмен контрагентами
179 / 254

На вкладке заказов Обмен контрагентами указываются настройки по выгрузке/загрузке контрагентов. Информация о контрагентах с сайта выгружается вместе с документами.

Выгрузка контрагентов из 1С:

  • При установке флага Синхронизация контрагентов, из 1С будут выгружены контрагенты, удовлетворяющие условию по указанным отборам на вкладке Отбор и сортировка.
  • В поле Количество контрагентов в пакете задается число контрагентов, которые будут выгружаться в одном пакете данных.

Загрузка контрагентов в 1С:

  • В поле Способ идентификации контрагентов указывается, как будут искаться контрагенты по базе, если контрагент не будет найден по уникальному идентификатору или коду с сайта. Поиск контрагентов может быть или по наименованию, или по ИНН.
  • В поле Группа для новых контрагентов указывается группа контрагентов для новых контрагентов, созданных модулем обмена с этой настройкой обмена.
  • При отмеченной опции Не редактировать контрагентов пришедших с сайта информация о контрагентах обновляться в 1С не будет.

Соответствие адресов контрагентов:

В табличных частях соответствий адресов контрагентов можно указать, какие виды контактной информации будут подставляться в адресах контрагентов в зависимости от поля XML-файла. Если указать одно и то же наименование поля в XML несколько раз, то контактная информация выгрузится для всех указанных видов контактной информации. Соответствия задаются как для юридических лиц, так и для физических.


Отбор и сортировка
180 / 254

На вкладке заказов Отбор и сортировка задаются условия отбора для выгружаемых заказов и контрагентов. Заказы, помимо точки актуальности, можно ограничить по заказам, организациям и подразделениям, а контрагенты - по контрагентам.


Выгрузка справочников из 1С
181 / 254

Для выгрузки справочников из 1С на сайт в форме настроек обмена должна быть отмечена опция Обмен пользовательскими справочниками и настроены основные настройки. Затем следует перейти на закладку Обмен польз. справочников и настроить параметры выгрузки.

В табличную часть Справочники можно добавить любой справочник базы 1С. При выборе строки в таблице значений, отобразятся все реквизиты справочника:

Чтобы необходимое поле справочника выгружалось, отметьте опцию Выгружено в соответствующей строке с названием поля.

Примечание: если значение поля является ссылкой, то для выгрузки наименования ссылочного элемента следует отметить опцию Выгружать как строка, иначе будет выгружен идентификатор данного поля.

Когда все настройки выполнены, нажмите кнопку Выполнить обмен данными. Начнется процесс импорта справочников на сайт. По его окончании в 1С будет отображено соответствующее сообщение.


Загрузка каталога товаров с сайта в 1С
182 / 254

В продукте доступна возможность экспорта каталога товаров с сайта в 1С: Предприятие. В 1С-Битрикс: Управление сайтом указываются только какие товары должны быть выгружены (см. форму интеграции), а сама процедура выполняется со стороны 1С.

В 1С:Предприятие перейдите в Настройки и кликнете по пунктуОбмен с сайтами. Откроется форма со списком узлов обмена с сайтами. Нажмите кнопку Синхронизация данных и выберите пункт Помощник импорта товаров с сайта под управлением CMS 1С-Битрикс. Откроется мастер импорта товаров с сайта:

  • В секции Адрес укажите адрес вашего сайта, содержащий путь до файла /bitrix/admin/1c_exchange.php (либо путь к странице с собственными настройками интеграции).
  • В секции Авторизация задайте логин и пароль пользователя из 1С-Битрикс: Управление сайтом, который обладает правом на выгрузку каталога с сайта (т.е. пользователь должен относится к группе, указанной в настройках интеграции).
  • В секции Дополнительно задайте интервал отправки запросов.

Нажмите кнопку Далее. На следующем шаге задайте параметры загрузки товаров в 1С:

  • В поле Единица измерения устанавливается та единица измерения, которая задана в настройках 1С.
  • В поле Загружать товары в группу задайте группу, в которую товары должны быть загружены. Группу можно выбрать как среди существующих, так и создать новую.
  • Отметьте необходимые для вас опции загрузки товаров в 1С:
    • Создавать группы - в 1С попадет иерархия групп товаров, в которых будет сам товар;
    • Создавать свойства (доп. сведения) товаров - с сайта будут выгружены свойства товаров;
    • Создавать характеристики товаров (SKU) - будут выгружены характеристики товаров;
    • Устанавливать цены - будут импортированы цены товаров и при необходимости типы цен.
    • Загружать картинки - вместе с товарами будут загружены картинки.

Нажмите кнопку Далее. Отобразится информация о процедуре импорта каталога товаров с сайта:

Нажмите кнопку Начать импорт. В процессе импорта, когда система получит данные с сайта, она запросит у вас разрешение на загрузку товаров. После того, как товары будут загружены в базу 1С, система запросит разрешение на загрузку изображений (если соответствующая опция была отмечена). По окончании процедуры импорта будет выведен протокол загрузки товаров.


Прочие возможности модуля обмена
183 / 254


Просмотр и редактирование зарегистрированных изменений
184 / 254

Для просмотра зарегистрированных изменений необходимо перейти к списку узлов обмена (Настройки > Обмен с сайтами), выбрать необходимый вам узел и нажать на пункт Показать зарегистрированные изменения кнопки Синхронизация данных.

Откроется окно с информацией о всех зарегистрированных изменениях узла обмена. Просматривать изменения можно вплоть до элементов, разворачивая их в дереве:

Кроме того, вы можете не только просматривать изменения, но и удалять их.


Редактирование кодов Битрикс у объектов 1С
185 / 254

Чтобы перейти к редактированию кодов Битрикс у объектов 1С, следует в форме со списком узлов обмена (Настройки > Обмен с сайтами) нажать кнопку Общие настройки и выбрать пункт Редактировать коды битрикс у объектов 1С. Откроется форма следующего вида:

В поле Тип объекта указывается тип объекта 1С, для которого нужно посмотреть/редактировать коды. Он может быть одним из следующих:

  • Справочники;
  • Документы;
  • Планы видов характеристик.

В поле Объект 1С указывается объект, коды элементов которого необходимо посмотреть/отредактировать. Список доступных объектов формируется в зависимости от указанного типа объекта 1С. Указать объекты 1С можно только те, которые могут хранить коды Битрикс.

При нажатии на кнопку Записать изменения измененные коды элементов будут перезаписаны в элементе 1С.


Настройки интеграции других продуктов 1С
186 / 254

Кроме описанных выше продуктов можно осуществить интеграцию и других продуктов 1С и их локализованных конфигураций.

Для интеграции 1С:Управление производственным предприятием и 1С:Комплексная автоматизация предприятий используйте описание настроек интеграции с "1С:Управление торговлей 10.3".


Скрипт для диагностики проблем интеграции с 1С
187 / 254

Скрипт поможет найти причины некоторых проблем, которые могут возникнуть при использовании функционала интеграции с 1С. Он работает только под аккаунтом администратора сайта.

Важно! Данный скрипт не может применяться для диагностики проблем с интеграцией, если используется новый модуль обмена 4.x.x.x.

Для работы нужно скопировать файл скрипта в корневую папку на сервер и запустить через браузер.

Важно! Не копируйте файл скрипта в каталог /upload, поскольку в целях безопасности из него запрещено выполнение скриптов.

Ссылка на скрипт в zip-архиве.

Возможности данного инструмента

  • Импорт файлов каталога и предложений, а также файлов структуры компании через стандартные компоненты продукта.
  • Получение информации о содержимом файлов импорта (количество товаров, групп и предложений).
  • Возможность пошаговой диагностики импорта каталога (начать импорт с любого шага).
  • Импорт файла заказов, который передался из 1С на сайт.
  • Просмотр информации о заказах, которые будут выгружены в 1С при следующей синхронизации.
  • Смена даты последнего обмена заказами.
  • Просмотр содержимого xml-файла заказов (в окне скрипта или в отдельном окне), который будет передан в 1C при следующей синхронизации.
  • Создание тестового типа инфоблоков, который будет автоматически установлен в настройках интеграции с 1С.
  • Поиск элементов по внешнему коду (по XML_ID).

Также в скрипте есть функциональная подчасть FileMan с такими возможностями:

  • Просмотр файловой структуры сайта.
  • Просмотр, загрузка, скачивание, правка, создание и удаление файлов.
  • Просмотр графических файлов.
  • Распаковка zip-архивов в текущую папку.

В этой главе будут рассмотрены основные возможности скрипта. При его использовании имейте в виду, что в нем присутствует "система" подсказок для кнопок, поэтому перед тем, как нажать, вы можете прочитать, что ожидать в итоге.

Примечание: вкладка WebDav предназначена для работы с библиотеками документов и в данной главе рассмотрена не будет.

Системные требования:

  • Скрипт верстался под Google Chrome, можно использовать Firefox. В Opera и IE запуск противопоказан.
  • Разрешение экрана желательно побольше, однако если не нужно редактировать, то подойдет любое.
  • Клавиатура, мышь.

Важно! Для версий продукта 14.5.0 и выше перед началом использования скрипта необходимо выполнить следующий код:
  • для обмена заказами:
    COption::SetOptionString("sale", "secure_1c_exchange", "N");
  • для обмена товарами:
    COption::SetOptionString("catalog", "DEFAULT_SKIP_SOURCE_CHECK", "Y" );

Примечание: разработанный ТП "1С-Битрикс" скрипт не является какой-то официальной разработкой, предназначен не для постоянного использования, а исключительно для диагностики проблем.


Импорт файлов каталога
188 / 254

Локальный импорт

В окне импорта файлов (выберите Локальный импорт на вкладке Импорт файлов) отображаются файлы, которые можно импортировать в продукт с использованием стандартных компонентов: файлы заказов, файлы каталога, файлы структуры компании. Скрипт считывает содержание папок 1c_catalog, 1c_exchange и 1c_intranet. Эти папки находятся в папке для загрузки файлов, создаются после проведения обмена с 1C. Если в папках есть файлы *.xml, они будут показаны в окне:

Для импорта содержимого файла дважды кликните по его имени в списке.

Если отметить опцию SkipMode, то возникнут еще два дополнительных поля:

В них вы можете указать внешний код или имя элемента, запись о котором вы хотите вывести из импортируемого файла в окно лога импорта:

Это может быть полезным при проблемах с импортом какого-либо конкретного элемента.

Внимание! Импорта как такового при отмеченной опции SkipMode не происходит.

Импортировать можно этим же скриптом, для этого поставьте галочку в одноименном поле. В этом режиме действует лог добавления и изменения элементов инфоблока (логи фиксируются в /import_element_log.txt).

В окне лога импорта будет отображаться ход процесса:

Если при импорте будут ошибки, они появятся в логе.

Фактически это имитация работы 1С, которая делает такие же запросы. В данном процессе отсутствует шаг сборки, передачи, распаковки и сохранения файла. Всё, что происходит после - идентично синхронизации с 1С. Хочется заметить, что в запросе передаётся параметр step, который позволяет идентифицировать шаг импорта для отладки. Например, в файле /bitrix/php_interface/dbconn.php можно вставить следующее:

$DBDebugToFile = false;
if (@$_REQUEST['step']==2)
    $DBDebugToFile = true;

В этом случае в корне сайта будет создаваться файл mysql_debug.sql, содержащий все запросы в базу данных, которые были осуществлены на шаге импорта текста файла во временную таблицу b_xml_tree.

Удаленный импорт

Также есть возможность импорта файлов на удалённом сервере. Выберите Удалённый импорт на вкладке Импорт файлов 1С.

Нужно ввести путь к скрипту обмена, название файла, логин, пароль и нажать начать.

При импорте отображаются заголовки ответа на каждый запрос, что сделано для удобства диагностики.

Создание типа инфоблока

Основное меню скрипта позволяет вам создать новый инфоблок для хранения выгружаемых данных. Для этого выберите пункт меню Создать тип инфоблока, появится окно создания нового типа инфоблоков:

Нажмите Создать, затем введите название нового инфоблока и снова кликните Создать. Если вы не снимали галочки с соответствующих опций при создании инфоблока, то с этих пор данные будут импортироваться в созданный вами инфоблок.

Временная таблица

Пункт основного меню Временная таблица необходим для контроля корректности импортируемых данных:

Перед импортом данные помещаются во временную таблицу, где можно проверить соответствие информации наименованию колонок, наличие данных и прочее.


Файлы заказов
189 / 254

Импорт файлов делается аналогично импорту товаров. При синхронизации продукт формирует файл заказов и передаёт в 1С. В файл попадают заказы с датой изменения старше даты последнего обмена. Чтобы продиагностировать этот момент, в скрипте есть инструменты для просмотра списка отдаваемых заказов, т.е. непосредственно просмотр файла, который будет отдан. Для просмотра списка заказов в основном меню выберите Выгрузка заказов:

Задайте параметры и нажмите Проверить. При необходимости укажите параметры авторизации:

После корректного входа в систему отобразится информация о заказах:

В случае наличия заказов в окне будут отображены ссылки на них.

Чтобы посмотреть непосредственно xml-файл заказов, в меню Заказы выберите XML-файл заказов или XML в отдельном окне:

Отметим, что при нажатии XML-файл заказов текст xml сохраняется в файле /upload/bx_orders.xml.


Импорт с любого шага
190 / 254

На импорт больших файлов зачастую уходит много времени, особенно когда требуется импорт файла во временную таблицу и импорт из временной таблицы. Скрипт позволяет пропустить некоторые шаги, которые были ранее уже сделаны и занимают достаточно долгое время.

Например, если ошибка возникает во время импорта элементов, то при диагностике будет удобно пропустить импорт во временную таблицу (т.к. она есть и уже заполнена), и начать сразу импорт из неё.

Имейте в виду, что не каждый шаг можно сделать без выполнения одного из предыдущих.

Для импорта с определенного шага, будучи на вкладке Импорт файлов 1С, кликните правой кнопкой мыши по имени файла в списке:

Выберите нужную операцию и нажмите на нее левой кнопкой мыши. В логе импорта будет отображен ход процесса.


FileMan и поиск
191 / 254

FileMan

FileMan содержит стандартные функции, но ввиду нестабильности работы не рекомендуется использовать функции редактирования и сохранения. FileMan позволяет просматривать файлы и папки, переходить в любую директорию из цепочки текущей директории, использовать фильтр для отображения.

Для каждого файла есть выпадающее меню со стандартными функциями. Открывается окно проводника кнопкой Fileman в основном меню, а также сочетанием клавиш Shift + ~:

Вы можете создавать, загружать и удалять файлы. Чтобы создать папку, поставьте галочку в опцию папку и нажмите Создать файл.

Поиск элементов

Поиск элементов по XML_ID (он же внешний код) осуществляется в окне Поиск:

Для поиска используется XML_ID, т.к. именно по нему идентифицируются элементы инфоблоков.


Типичные ошибки и проблемы
192 / 254
  • Обмен заказами завершен с ошибками
  • Не меняется статус заказа при выгрузке из 1С
  • Изменения товаров не зарегистрированы. Выгрузка товаров не произведена.
  • Как выгрузить каталоги из 1С в разные типы инфоблоков?
  • Не удалось найти вид номенклатуры
  • Поле объекта не обнаружено
  • Произошла ошибка на стороне сервера. Получен неизвестный статус импорта.
  • Произошла ошибка на стороне сервера. Файл не отправлен
  • Не работает авторизация при обмене данными с 1С
  • При выгрузке каталога из 1С не ставит галочку "уменьшать количество при заказе"
  • Возможные причины медленного импорта из 1С
  • Если структура каталога в 1С отличается от каталога на сайте?
  • Ошибка импорта метаданных
    •

    Проблема. При попытке обмена заказов в 1С выходит сообщение:

    Выгружено товаров: 1
    Выгружено картинок: 1
    Выгрузка товаров успешно завершена
    Не установлен реквизит "ГруппаДоступаККонтрагенту". Элемент не записан!
    Не установлен реквизит "РегионДоставки". Элемент не записан!
    Не установлен реквизит "Основная форма оплаты". Элемент не записан!
    {Обработка.ОбменССайтом(3468)}: Ошибка при вызове метода контекста (Записать): Операция не выполнена!
    Произошла ошибка: . По причине:

    Не удалось найти/создать контрагента.
    Не удалось обработать документы, загруженные с сервера.
    Обмен не выполнен.
    Не выгружен ни один заказ.
    Обмен заказами завершен с ошибками!!!

    Решение. Скорее всего, в используемой конфигурации предусмотрена обязательность заполнения указанных выше реквизитов для элемента справочника "Контрагенты".

    Проблема. Не меняется статус заказа при выгрузке из 1С

    В соответствие с логикой синхронизации 1С и "1С-Битрикс: Управление сайтом", статус заказа меняется, если из 1С передались дата оплаты либо дата отгрузки товара. Чтобы эти даты попали в XML-файл, который формируется 1С и передаётся на сайт, нужно сформировать и провести нужные документы.

    • В 1С УТ зарегистрировать оплату заказа можно путем ввода на основании заказа документов оплаты, таких как "Платежное поручение входящее" и "Приходный кассовый ордер".
    • Отгрузка, как правило, регистрируется вводом на основании заказа документа "Реализация товаров и услуг".
    • Если в регистре "Расчеты с контрагентами" остаток по заказу <= 0, заказ считается оплаченным.
    • Если в регистре "Заказы покупателей" остаток по заказу <= 0, заказ считается отгруженным. У конфигурации УПП принцип тот же.

    Статусы, в которые будут переводиться заказы при получении дат оплаты и отгрузки, устанавливаются в настройках модуля интернет-магазина: параметры При получении оплаты переводить заказ в статус и При получении разрешения доставки переводить заказ в статус соответственно.

    Проблема. 1С заполнена и настроена на обмен с "1С-Битрикс: Управление сайтом", который тоже настроен на интеграцию с 1С.
    При нажатии на кнопку Выполнить обмен сразу появляется сообщение в 1С: "Изменения товаров не зарегистрированы. Выгрузка товаров не произведена."

    Решение. Возможные ошибки:

    • Обычно появляется из-за некорректной настройки выгрузки товаров на вкладке "Выгрузка товаров". Стоит обратить внимание на то, что настраивается именно фильтр(!), а не выбираются поля для выгрузки. Если отмечается поле для фильтра, то значение этого поля в фильтре должно быть задано.
    • В 1С (Управление торговлей) обратите внимание в справочнике Номенклатура на реквизит вид номенклатуры. Должен быть обязательно признак товар (наименование товар и тип номенклатуры товар).
    • Если обмен осуществляется в режиме выгрузки изменений, а этих изменений с момента последнего обмена не зафиксировано, то возникает указанная ошибка. Стоит обратить внимание на следующие моменты:
      • Если осуществляется полная выгрузка каталога на сайт, то настройка фильтра необязательна (нужно снять выделение со всех отмеченных полей на вкладке "Выгрузка товаров").
      • "Изменения товара" никаким образом не относятся к сайту, т.е. удаление товаров на сайте или их редактирование не фиксируется в 1С. При обмене выгружаются изменения товаров, произведённые именно в 1С с момента последней выгрузки.

    Проблема. Как выгрузить каталоги из 1С в разные типы инфоблоков?

    Решение. Чтобы осуществить выгрузку в разные типы инфоблока, следует поместить несколько компонентов catalog.import.1c на разные страницы.

    Например, имеем две страницы: http://mysite.ru/1c_import_1.php и http://mysite.ru/1c_import_2.php. На обеих страницах настраиваем компонент catalog.import.1c - указываем в параметрах разные типы инфоблоков и устанавливаем флажок у опции Импортировать с учетом типа инфоблока.

    Затем при настройке импорта в 1с, для выгрузки в нужный тип инфоблока указываем разные файлы: http://mysite.ru/1c_import_1.php либо http://mysite.ru/1c_import_2.php.

    Пример файла:

    <?require($_SERVER["DOCUMENT_ROOT"]."/bitrix/header.php");
$APPLICATION->SetTitle("import1");
?>
<?$APPLICATION->IncludeComponent("bitrix:catalog.import.1c", "", Array(
        "IBLOCK_TYPE" => "books",
        "SITE_LIST" => array(),
        "INTERVAL" => "30",
        "GROUP_PERMISSIONS" => array(0 => "1"),
        "USE_OFFERS" => "N",
        "USE_IBLOCK_TYPE_ID" => "Y",
        "SKIP_ROOT_SECTION" => "N",
        "ELEMENT_ACTION" => "D",
        "SECTION_ACTION" => "D",
        "FILE_SIZE_LIMIT" => "204800",
        "USE_CRC" => "Y",
        "USE_ZIP" => "Y",
        "USE_IBLOCK_PICTURE_SETTINGS" => "N",
        "GENERATE_PREVIEW" => "Y",
        "PREVIEW_WIDTH" => "100",
        "PREVIEW_HEIGHT" => "100",
        "DETAIL_RESIZE" => "Y",
        "DETAIL_WIDTH" => "300",
        "DETAIL_HEIGHT" => "300",
        "TRANSLIT_ON_ADD" => "Y",
        "TRANSLIT_ON_UPDATE" => "Y",
        "TRANSLIT_MAX_LEN" => "100",
        "TRANSLIT_CHANGE_CASE" => "L",
        "TRANSLIT_REPLACE_SPACE" => "_",
        "TRANSLIT_REPLACE_OTHER" => "_",
        "TRANSLIT_DELETE_REPEAT_REPLACE" => "Y"
    ),
false
);?>
<?require($_SERVER["DOCUMENT_ROOT"]."/bitrix/footer.php");?>

    Проблема. Не удалось найти вид номенклатуры

    В процессе обмена 1С с сайтов возникает ошибка: Не удалось найти вид номенклатуры: Услуга Не удалось найти вид номенклатуры: Товар Не удалось найти/создать номенклатуру. Не удалось обработать документы, загруженные с сервера.

    Решение. Ошибка возникает, если в 1С нет типов номенклатуры Услуга и Товар. Эти типы номенклатуры критичны для процесса обмена данными с сайтом. Следует создать в 1С эти типы номенклатуры и только поле этого осуществлять обмен.

    Проблема. В процессе обмена возникает ошибка "Поле объекта не обнаружено".

    В процессе обмена заказами возникает ошибка: {Обработка.ОбменССайтом(3271)}: Поле объекта не обнаружено (Наименование) >> ОтобразитьСостояние("Идентификация контрагента: " + СтрокаДД.СтруктураДанныхКонтрагента.Наименование);

    Решение. Проверьте настройки интеграции с 1С, закладка Профили обмена: установлены ли соответствия для полей заказа. Обратите внимание на поля "Полное Наименование" и "Наименование". Эти поля критичны для 1С.

    Проблема. Произошла ошибка на стороне сервера. Получен неизвестный статус импорта.

    • Возникает ошибка следующего вида:

      Выгружено товаров: 679 Выгружено картинок: 469 Произошла ошибка на стороне сервера. Получен неизвестный статус импорта. Обмен не выполнен. Ответ сервера. Fatal error : Allowed memory size of 67108864 bytes exhausted (tried to allocate 102401 bytes) in /var/www/bitrix/modules/iblock/classes/general/cml2.php on line 483 Выгрузка товаров завершена с ошибками!

      Решение. Ошибка скорее всего связана с нехваткой ресурсов на масштабирование передаваемых на сервер изображений. Выходом из данной ситуации может служить отключение опции Выгружать картинки (вкладка Выгрузка товаров в настройке обмена в 1С).

      Также можно увеличить размер выделяемой памяти в настройках PHP (параметр memory_limit), для этого следует обратиться к хостинг-провайдеру.

    • Возникает ошибка следующего вида:

      Выгружено товаров: 46 Выгружено картинок: 0 Произошла ошибка на стороне сервера. Получен неизвестный статус импорта. Обмен не выполнен Ответ сервера: DB query error. Please try later. Выгрузка товаров завершена с ошибками!

      Решение. Ошибка может возникать в случае некорректной передачи файла на сервер. В процессе отправки файл может "обрезаться" и терять свою целостность, в итоге файл на сервер передаётся некорректным по содержанию.

      Причиной может служить прокси-сервер, через который осуществляется обмен. Попробуйте осуществить выгрузку не через прокси-сервер. Также попробуйте отключить опцию Использовать сжатие zip, если доступно в настройках Интеграции с 1С - возможно, на сервере не поддерживается zip-сжатие. Настройки интеграции с 1С.

    Проблема. Ошибка "Произошла ошибка на стороне сервера. Файл не отправлен"

    В процессе обмена возникает такого вида ошибка:
    Выгружено товаров: 3 Выгружено картинок: 0 Выгрузка товаров успешно завершена Выгружено заказов: 1 Произошла ошибка на стороне сервера. Файл не отправлен (C:\Documents and Settings\User\Local Settings\Temp\v8_5075_63.zip). Обмен не выполнен Ответ сервера: Файл для импорта пуст. Обмен заказами завершён с ошибками!

    Решение. Причины возникновения ошибки могут быть следующие:

    1. На компьютере, где установлена 1С, имеется файрволл или антивирус, препятствующий корректной передаче файла или блокирующий отправку файла на сервер.
    2. Некорректно работает функции расширения ZIP, вследствие чего из архива не распаковываются файлы. Для решения возникшей проблемы рекомендуется:
      • Установить последние стабильные версии обновлений модуля интернет-магазина.
      • На время обмена отключить на локальной машине все блокирующее ПО (антивирус, файрволлы и т.д.)
      • Отключить zip-сжатие в настройках интеграции с 1С.

    Проблема. Не работает авторизация при обмене данными с 1С

    Решение. Часто проблема возникает в результате работы php в режиме CGI. В этом режиме есть проблемы с передачей данных авторизации HTTP в php. Можно это проверить, посмотрев phpinfo() в разделе: Server API: CGI. Можно обойти проблему, но необходимо чтобы на сервере была включена обработка .htaccess и поддержка mod_rewrite. Выполните следующие действия:

    • В корне сайта в файл .htaccess добавьте строки:
          RewriteEngine on
    RewriteRule .* - [E=REMOTE_USER:%{HTTP:Authorization},L]
    • Закоментируйте следующие строки в файле bitrix/admin/.htaccess, которые отключают mod_rewrite:
          #<ifmodule mod_rewrite.c="">
    # RewriteEngine Off
    #</ifmodule>
    • В файл bitrix/php_interface/dbconn.php добавьте строки:
          $remote_user = $_SERVER["REMOTE_USER"]
    ? $_SERVER["REMOTE_USER"] : $_SERVER["REDIRECT_REMOTE_USER"];
    $strTmp = base64_decode(substr($remote_user,6));
    if ($strTmp)
        list($_SERVER['PHP_AUTH_USER'], $_SERVER['PHP_AUTH_PW']) = explode(':', $strTmp);

    Для проверки работоспособности HTTP-авторизации воспользуйтесь скриптом

    Внимание! Данный вариант обхода не всегда может решить проблему. Если при выполнении всех рекомендаций HTTP-авторизация не заработала, то следует обратиться к хостинг-провайдеру с этой проблемой.

    Проблема. При выгрузке каталога из 1С не ставит галочку "уменьшать количество при заказе"

    Решение. Чтобы исправить это, необходимо в файле init.php добавить код, который будет срабатывать при добавление продукта (через событие OnProductAdd):

    <?
AddEventHandler("sale", "OnProductAdd", "OnProductAdd");

    function OnProductAdd($ID,$Fields)
    {
  $res=Array("QUANTITY_TRACE"=>'Y);
   CCatalogProduct::Update($ID,$res);

}
?>

    Проблема: медленный импорт из 1С

    Возможные причины:

    Включённая индексация. Для ускорения можете в настройках инфоблока выключить индексацию элментов и разделов, а также свойств.

    Проактивная защита, которая меняет идентификатор сессии каждую минуту. В случае интеграции с 1С приложение 1С не подхватывает новый идентификатор и пытается получить переменные сессии со старым ID сессии. В сессии хранится шаг импорта, если не удаётся в сессии найти этот шаг, то считается, что шаг равен 1, т.е. импорт начинается сначала. Попробуйте отключить хранение сессий в базе и смену идентификатора сессии.

    Задача: Структура каталога на сайте должна отличаться от структуры в 1С.

    Варианты решения:

    Вариант 1. Делается отдельный классификатор - инфоблок и разделы. У разделов создаётся свойство привязка к разделам, и нужные "человеческие" разделы привязываются к разделам инфоблока с классификатором, который пришел из 1С. Можно сделать множественную привязку - будет проще свести в один раздел из кучи непонятных в 1С.

    Вариант 2: В 1С можно создать такой объект как прайс-лист и попробовать настроить обмен с сайтом, уже используя его как прокси. Т.е. Если в справочнике Номенклатура бардак и вообще куча всякого, что на сайте не должно показываться, то создаётся прайс-лист, и уже в нём создаются нужные секции. И специально обученный сотрудник добавляет в узлы прайс-листа ссылки на позиции из справочника номенклатура.

    Тогда на сайт будет уходить CML, структура которого берётся из прайс-листа, а не из номенклатурного справочника.

    Проблема: На этапе выгрузки свойств после построения таблиц выводится сообщение об ошибке:

      Выгружено товаров: 1 832
      Выгружено картинок: 0
      Выгружено предложений: 0
      Произошла ошибка на стороне сервера.
      Обмен не выполнен
      Ответ сервера:
      Ошибка импорта метаданных.

      Выгрузка товаров завершена с ошибками!!!

    Причина. Ошибка может возникать, если названия свойств начинаются с цифр. Первый знак в названии должен быть буквой.


Записи с вебинаров по интеграции с 1С
193 / 254

На данной странице представлены доступные для просмотра записи с вебинаров, которые помогут Вам освоить интеграцию с продуктами 1С.

Вебинар Рассматриваемые вопросы
Мастер-класс по интеграции с 1С:УТ от 3.03.15
  • обновление модуля обмена
  • исправление неправильно настроенных временных зон
  • настройка выгрузки товаров на сайт
  • загрузка документов (заказов) в 1С
Мастер-класс по интеграции с 1С:ЗУП и 1С:УТ от 5.12.14
  • для 1С:ЗУП:
    • установка модуля обмена
    • обновление конфигурации
    • экспорт кадровой информации
    • работа с расчетными листками
  • для 1С:УТ
    • разделение выгрузки товаров на 3 узла (выгрузка свойств, выгрузка товаров и предложений, выгрузка цен и остатков)
    • выгрузка пользовательских справочников
Мастер-класс по интеграции с 1С:УНФ от 14.10.14
  • установка модуля обмена
  • выгрузка товаров на сайт
  • обмен заказами


Пример создания интернет-магазина
194 / 254

Целью этого примера является разъяснение основных принципов создания интернет-магазина, а также объяснение некоторых частных моментов в процессе создания действующей модели магазина. В разделе рассмотрен простой вариант интернет-магазина.


Введение
195 / 254

Эта пошаговая инструкция позволяет:

  • Начинающим разработчикам понять основные шаги настройки интернет-магазина.
  • Опытным разработчикам, не создававшим ранее интернет-магазины, сэкономить время на изучение новой предметной области.
  • Заказчикам реализовать самостоятельно стандартный функционал онлайн-торговли, заложенный в 1С-Битрикс: Управление сайтом.
  • Создать «Check List» - контрольный список, по которому можно проверять выполнение необходимых действий по настройке интернет-магазина.

Пример создан на базе технического задания (ТЗ) для интернет-магазина.

Не будут рассматриваться следующие этапы работ, необходимые для создания реально функционирующего веб-проекта:

  • Оценка стоимости проекта.
  • Требования к системе в целом.
  • Дополнительные функциональные комплексы (ввод информации, интерактивные сервисы, сторонние программные комплексы и так далее).
  • Масштабируемость системы.
  • Требования к надежности.
  • Дизайн сайта.
  • Требования к информационной безопасности.
  • Виды и методы испытания системы.
  • Технология приемки-сдачи проекта.

Для создания интернет-магазина необходимо использование 1С-Битрикс: Управление сайтом в редакции не ниже Малого бизнеса (модуль Интернет-магазин также не входит в редакцию Веб-кластер.) Для изучения примера можно воспользоваться виртуальной лабораторией.

Не будут рассматриваться вопросы дизайна сайта. Все скриншоты, приведенные в разделе, соответствуют шаблону, входящему в состав дистрибутива 1С-Битрикс: Управление сайтом. Следовательно, все пути к файлам и папкам, указанные в «Примере», будут соответствовать настройкам по умолчанию.

Выполнение примера необходимо совершать под правами администратора системы. Для просмотра вносимых изменений в некоторых случаях потребуется пользователь с неадминистративными правами. Разработку рекомендуется производить с периодическими проверками на включение кеширования, чтобы избежать ошибок, связанных с неправильными стратегиями кеширования.

Стараясь максимально облегчить освоение работы Интернет-магазина, будут даваться ссылки на документацию во всех необходимых местах. Кроме того, для более успешного освоения опыта разработчиков будут приводиться ссылки с их блогов при рассказе определенных тем.


Типовой порядок работы
196 / 254

Типовой порядок работы над простым интернет-магазином

  • Сбор сведений и составление технического задания (ТЗ).
  • Выбор или создание дизайна в зависимости от требований заказчика, верстка дизайна.
  • Настройка модуля валют.
  • Первоначальная настройка интернет-магазина: типы цен, единицы измерения, типы плательщиков, местоположения, статусы заказов.
  • Создание товарного каталога, заполнение тестовыми товарами.
  • Применение дизайна для компонентов товарного каталога, корзины и оформления заказа.
  • Окончательная настройка интернет-магазина: платежные системы, службы доставки, скидки, права пользователей, склады.

Сбор сведений для составления ТЗ – этап особый. Его выполнение зависит во многом от опыта и умения понимать того, что хочет заказчик "на самом деле". Данное умение не относиться к техническим аспектам работы с 1С-Битрикс: Управление сайтом, поэтому этот этап опускается, считаем, что ТЗ уже есть.

Этапы работы с дизайном также опускаются, так как эта задача рассмотрена в учебном курсе Bitrix Framework.

Доработка функционала

При необходимости добавить в интернет-магазин функционал, отличающийся от базового функционала 1С-Битрикс: Управление сайтом, необходимо добавить этап доработки: программирование под потребности заказчика. Очень важно при этом взаимодействие с программистами 1C, если у заказчика – нестандартная конфигурация или дополнительные требования.

Необходимо заметить, что стандартный функционал редко удовлетворяет заказчика полностью. Часто требуется дополнительное программирование. В минимальном случае это – модернизация шаблона, при более серьезных потребностях – добавление кода с помощью API в файлы типа result_modifier.php. Это не недостаток Bitrix Framework. Создать универсальный, всех устраивающий продукт, настраиваемый только кликами мыши, нельзя. Большие возможности по модернизации кода – сильная сторона системы, однако, это требует от разработчиков сайтов умения грамотно программировать на PHP.

Программирование в рамках BitrixFramework лучше производить с учетом рекомендаций разработчиков. Перед программированием рекомендуем ознакомиться с общими технологиями и принципами работы системы.


Техническое задание (ТЗ)
197 / 254

Техническое задание (ТЗ) - текстовый документ, в котором оговариваются все технические, организационные, финансовые и иные параметры и ресурсы, которые должны быть выполнены и задействованы при реализации проекта.

Техническое задание – обязательный атрибут и первый шаг к созданию веб-проекта. Оно должно предусмотреть все аспекты создания сайта, в том числе и параметры интернет-магазина. ТЗ на интернет-магазин может существенно отличаться от приведенного ниже, все зависит от конкретных потребностей заказчика.

Примерная структура подсистемы управления интернет-магазином в рамках общего ТЗ на сайт:

  • Возможность для покупателей работы с собственными заказами.
  • Возможность работы администратора магазина с заказами и корзиной покупателя.
  • Импорт-экспорт товаров и заказов.
  • Управление системами доставки и оплаты.
  • Управление валютами.
  • Управление каталогом товара (категории, товары, прочее).
  • Задание товарам различных свойств в рамках одного каталога.
  • Управление складами и количеством товара на них.
  • Создание и управление системой скидок.
  • Вывод отзывов пользователей о товаре.
  • Интеграция с системами публикаций товара (google base и другие).
  • Интеграция с системой бухгалтерско-оперативного учета.

Весь этот функционал решается штатными средствами 1С-Битрикс: Управление сайтом.

Примечание: при обсуждении ТЗ на интернет-магазин необходимо получить от заказчика требования по всем параметрам системы. В противном случае, на этапе сдачи работ могут возникнуть ненужные проблемы.

Внимание! Необходимо обратить особое внимание на продумывание ролей, создание групп пользователей и разграничение прав. В рамках нашего примера эти моменты «размазаны» по главам, но продумывание этих административных моментов должно быть изначально централизованным и обговоренным с заказчиком.

Общее правило для пользователей со стороны заказчика должно быть таким: МИНИМАЛЬНО необходимый набор прав. К сожалению, достаточно часто разработчики просто передают аккаунт администратора системы заказчику или менеджеру магазина.

Детальное описание каждого из пунктов ТЗ будет приведено в соответствующих главах.


Настройка модуля валют
198 / 254

Перед началом создания интернет-магазина произведите настройку модуля Валюты. Об общих принципах работы с этим модулем читайте в соответствующей главе этого курса.

Валюта - один из самых внешне незаметных модулей. Действительно, отобразить его присутствие на сайте можно только одним единственным способом: выведя на страницу Информер курса валют. А если не выводить, то и его и вообще будет не заметно. Тем не менее, это довольно важный модуль. Без него интернет-магазин не будет работать.

Настроить работу модуля Валюты необходимо до того, как начнется создание каталога и настройка интернет-магазина.

  • Перейдите на страницу Настройки > Настройки продукта > Настройки модулей > Валюты. Откроется форма настроек, состоящая всего из одной закладки: Доступ.

    Доступ к этому модулю желательно ограничить и не давать большому числу пользователей. Лучше вообще оставить за одним администратором магазина, так как обращение к нему не требуется постоянно, а случайные изменения в модуле скажутся на работе интернет-магазина.

  • Задайте права доступа для групп пользователей, которые будут администрировать магазин и каталог.
  • Сохраните внесенные изменения.

Теперь можно приступать к работе с самим модулем.

Список валют

Перейдите на страницу Настройки > Валюты > Список валют. Откроется форма со списком всех имеющихся в системе валют. В дистрибутиве по умолчанию используются три валюты: рубль (как базовая), доллар и евро.

В качестве базовой валюты рекомендуется выбирать рубль. В этом случае отображение курса валют будет в привычном для всех виде: за 1 денежную единицу - столько-то рублей.

Курсы валют

Если ваш магазин будет каким-то образом взаимодействовать с валютами других государств, то вам необходимо создать нужные валюты и настроить курс валют.

Модуль валют настроен на работу с каталогом и интернет-магазином. Работа этого модуля, как уже говорилось, внешне не видна: к нему обращаются модули Торговый каталог и Интернет-магазин в своей работе.


Первоначальные настройки
199 / 254

В данной главе описаны настройки, без которых невозможно выполнить глобальные настройки модуля Интернет-магазин и заполнить каталог товарами.


Единицы измерения
200 / 254

Перед тем как добавлять товары, необходимо определиться в каких единицах измерения у вас будут доступны товары для покупки. Управление единицами измерения осуществляется на странице Магазин > Настройки > Единицы измерения:

Добавление новой единицы измерения выполняется из классификатора (кнопка Добавить из классификатора) или вручную (кнопка Добавить).

Для товаров нашего магазина необходимы единицы измерения погонный метр и квадратный метр. Добавим их из классификатора.

Погонный метр

В форме добавления выберите раздел и подраздел классификатора, затем отметьте нужную единицу и нажмите кнопку Добавить:

В результате новая единица измерения будет добавлена в общий список:

При добавлении единицы измерения вручную вам необходимо будет самостоятельно указать код единицы измерения в ОКЕИ, заполнить наименование и указать условные и кодовое обозначения (подробное описание полей смотрите в документации по продукту).

Квадратный метр

Добавление единицы измерения квадратный метр выполняется аналогично погонному метру.

Дополнительно сделаем квадратный метр единицей измерения, используемой по умолчанию для товаров нашего магазина. Для этого следует открыть форму ее редактирования, отметить опцию По умолчанию и сохранить внесенные изменения:


Настройка модуля Торговый каталог
201 / 254

Мы создаем простой интернет-магазин, в котором будет вестись только количественный учет товаров, а резервирование товаров и складской учет использоваться не будет, поэтому в форме настроек модуля Торговый каталог (Настройки > Настройки продукта > Настройки модулей > Торговый каталог) выполните следующие действия на закладке Настройки:

  • Отметьте опцию Включить количественный учет - количественный учет будет вестись для всех товаров. Также определите возможность покупки товара при его отсутствии, подписки на него.
  • Опции Включить складской учет и Включить резервирование оставьте неотмеченными (или снимите с них галочки).
  • В поле Количество товара уменьшается выберите условие уменьшения товара. В нашем случае количество товара будет уменьшаться сразу при оформлении заказа.
  • Все остальные значения параметров данной закладки можно оставить по умолчанию.

Настройки параметров, расположенных на остальных закладках, также можно оставить по умолчанию. В случае необходимости, к ним можно вернуться позже и донастроить соответствующим образом.

Сохраните внесенные изменения.

Примечание: подробное описание настроек модуля представлено в документации по продукту.


Статусы заказов
202 / 254

По умолчанию в системе имеются базовые статусы заказов, но чтобы их использовать, необходимо выполнить настройку прав доступа, т.е. определить пользователи каких групп смогут работать с заказами в том или ином статусе.

Кроме того, вполне вероятно, что вам будет недостаточно имеющихся статусов для работы вашего магазина. В этом случае необходимо создать недостающие статусы.

Настройка статусов

Важно! Работать с заказами могут только те группы пользователей, в настройках которых определен доступ к модулю Интернет-магазин как [U] Обработка заказов:

Помимо имеющейся группы Администраторы интернет-магазина, для работы с заказами создадим еще следующие группы пользователей: Менеджеры, Кладовщик и Бухгалтер и расставим необходимые права для каждого статуса:

  • Статус Принят получает любой заказ после того, как он будет оформлен в магазине. Поскольку с оформлением заказа работает только менеджер магазина, то именно он будет иметь основные права на этот статус. Однако, возможны ситуации, когда потребуется возврат товара из других статусов обратно в статус Принят. Например, клиент оплатил заказ и тут же передумал, попросил вернуть деньги, но от заказа не отказывается – обязуется оплатить позже. Бухгалтер должен вернуть заказ из статуса дальнейшей обработки в статус Принят. Таким образом, получается следующая картина прав на доступ статуса Принят:

  • Для статуса Отправлен (т.е. заказ оплачен и формируется к отправке) права могут быть настроены следующим образом:

  • Статус Выполнен – это финальный статус, устанавливается для заказа, который оплачен и доставлен. Пример прав на данный статус:

Создание статусов

Например, для нашего магазина необходим статус, когда заказ оплачен, обработан бухгалтерией, но в силу некоторых причин не может быть отгружен (скажем, товар поступает с интервалом в день-два и расходится в порядке очереди поступления заказа). Для таких случаев удобно иметь статус В очереди.

  • Перейдите на страницу Статусы (Магазин > Настройки > Статусы). Откроется список имеющихся статусов.
  • Нажмите кнопку Новый статус, расположенную на контекстной панели. Откроется форма создания статуса:

  • Заполните основные поля формы:
    • Введите произвольный буквенный код на латинице.
    • Укажите значение сортировки.
    • Введите название статуса для всех языковых интерфейсов.
    • Введите при необходимости описание статуса для всех языковых интерфейсов.
  • Перейдите к секции Права на доступ и выполните настройку прав. Для статуса В очереди права могут быть примерно такие:

    Важно! В секции Права на доступ отображаются только те группы пользователей, в настройках которых определен доступ к модулю Интернет-магазин как [U] Обработка заказов.
  • Сохраните внесенные изменения. Статус создастся и появится в общем списке.


Местоположения
203 / 254

Работа интернет-магазина невозможна без указания адреса магазина, который задается с помощью имеющихся в системе местоположений.

Управление местоположениями выполняется на странице Магазин > Настройки > Местоположения > Список местоположений. По умолчанию в системе уже загружены основные местоположения, но вы можете создать или загрузить недостающие вам местоположения:

Кроме того, для облегчения работы по настройке служб доставки, вы можете объединить в группы необходимые местоположения.


Типы плательщиков
204 / 254

Создание заказов в магазине невозможно, если в нем не созданы типы плательщиков. Для нашего магазина достаточно двух типов, которые по умолчанию уже имеются в системе: физическое и юридическое лицо.

Проверьте, чтобы типы плательщиков были активны и привязаны к вашему сайту интернет-магазина.

Примечание: в случае необходимости вы можете добавить нужные вам типы плательщиков.


Настройка цен
205 / 254

Для функционирования магазина необходимо установить цены, с которыми он будет работать. Если позволяет редакция продукта, то в каталоге и, соответственно, в интернет-магазине можно использовать несколько типов цен, но при этом один из типов цен является базовым.

Базовая цена – это цена, относительной которой рассчитываются все остальные цены системы.

В нашем магазине базовой ценой является Розничная цена, которая по умолчанию доступна в системе, причем покупать товары по этой цене могут все посетители сайта.

Создадим в нашем магазине тип Оптовая цена, по которой смогут покупать только оптовые покупатели. Кроме того, цена этого типа будет рассчитываться автоматически с учетом наценки -10%, которую тоже нужно создать, на базовую (розничную) цену.

Важно! При проведении операций в корзине система всегда выбирает наименьшую из доступных пользователю цен.


Создание типа цены
206 / 254

Управление типами цен осуществляется на странице Магазин > Настройки > Типы цен.

Создадим для нашего магазина новый тип цен Оптовая цена. Для этого с помощью кнопки Новый тип цен откройте форму создания и заполните ее поля:

  • Укажите код типа цены.
  • Для языков интерфейса введите названия типа цены.
  • В поле Группы пользователей, имеющие права на просмотр этого типа цены отметьте группу, пользователи которой смогут видеть оптовую цену на товар. В нашем случае, это группа Оптовые покупатели.
  • В поле Группы пользователей, имеющие права на покупку по этому типу цен также отметьте группу Оптовые покупатели, чтобы только оптовые покупатели могли покупать товары по оптовой цене.
  • Сохраните внесенные данные.

Новый тип создан. Теперь его можно использовать при указании цены на товар.


Создание наценки
207 / 254

Управление наценками осуществляется на странице Магазин > Настройки > Наценки.

Для нашего магазина создадим отрицательную наценку, которая впоследствии будет действовать для оптовых покупателей:

  • Нажмите на кнопку Новая наценка, расположенную на контекстной панели. Откроется форма создания новой наценки:

  • Введите название наценки (в нашем случае это -10% для оптовиков).
  • Задайте процентную ставку наценки.
  • Сохраните внесенные изменения.

Теперь новую наценку можно будет использовать при указании цены товара.


Налоги
208 / 254

Для товаров нашего магазина будут применяться только НДС. Управление ставками НДС осуществляется на странице Магазин > Настройки > Налоги > Ставки НДС:

Ставка НДС может быть разной в зависимости от товара. Создадим, например, ставку 10%. Для этого нажмите кнопку Добавить, расположенную на контекстной панели. Откроется форма добавления новой ставки НДС:

  • Введите наименование ставки НДС.
  • Укажите величину ставки – в нашем случае 10.
  • Задав сортировку и отметив флаг активности ставки, сохраните новую ставку НДС.

Теперь новая ставка НДС может быть применена к товарам магазина.

Примечание: если в вашем магазине необходимы другие налоги, отличные от НДС, то их создание выполняется на странице Список налогов (Магазин > Настройки магазина > Налоги > Список налогов), а создание их ставок – на странице Ставки налогов (Магазин > Настройки магазина > Налоги > Ставки налогов).


Настройка модуля Интернет-магазин
209 / 254

Перейдите на страницу Настройки > Настройки продукта > Настройки модулей > Интернет-магазин. Откроется форма настроек модуля Интернет-магазин.

В силу того, что наш магазин довольно прост, нам не потребуется настройка всех полей в формах. Поэтому мы упомянем только необходимые, а в остальных оставим значения по умолчанию.

На закладке Настройки обратите внимание на следующие параметры:

  • В поле E-Mail отдела продаж введите электронный адрес, на который будут получаться все сообщения, связанные с работой интернет-магазина.
  • Проверьте, чтобы была отмечена опция Фиксировать модуль Торгового каталога (catalog) в качестве каталога товаров.
  • В поле Валюта "по-умолчанию" укажите рубли.
  • С помощью следующих 4-х параметров: При получении оплаты переводить заказ в статус, При получении разрешения доставки переводить заказ в статус, Разрешать доставку при оплате заказа и Разрешать отгрузку при разрешении доставки настройте автоматический перевод заказов в необходимые статусы и разрешите установку флагов доставки/отгрузки заказов:

  • В поле Указать сайты, которые являются магазинами отметьте сайт, который является интернет-магазином.

На закладке Параметры веса настройте единицы веса (например, килограммы), которые будут использоваться в магазине. Настройка параметров веса необходима для корректного расчета стоимости доставки:

Перейдите на закладку Адрес магазина:

  • Введите в поле Индекс почтовый индекс отделения почты вашего магазина.
  • В поле Местоположение магазина в выпадающем списке выберите местоположение вашего магазина.
  • С помощью поля Зона обслуживания укажите какие страны, регионы и города будет обслуживать магазин. Наш интернет-магазин будет обслуживать все регионы России.

Перейдите на закладку Права на заказы. Здесь необходимо для сайта интернет-магазина указать группы, работающие с заказами:

  • В колонке Валюта выберите валюту интернет-магазина.
  • В колонке Группы, имеющие доступ к заказам сайта отметьте группы, которые должны отвечать за обработку заказов.

Откройте закладку Доступ, где в списке отображаются уже все группы, для которых в их форме редактирования был задан доступ к модулю Интернет-магазин. При необходимости настройте доступ к модулю для дополнительных групп.

Сохраните внесенные изменения.


Создание каталога товаров
210 / 254

Создание каталога товаров – один из самых трудоемких этапов при создании интернет-магазина в плане наполнения проекта реальным содержимым.


Техническое задание (ТЗ)
211 / 254

В качестве товаров для нашего примера возьмем напольные покрытия. В каталоге у нас будет несколько разделов, а товары будут использоваться следующих типов: простые товары и товары с торговыми предложениями. Поэтому в рамках примера используем следующее описание каталога в ТЗ сайта:

Простой товар - это объект, который имеет:

  • ID - уникальный идентификатор.
  • Название.
  • Статус активности (да/нет).
  • Символьный код.
  • Описание.
  • Meta keywords.
  • Meta description.
  • Название страницы (Page Title).
  • Изображение.
  • Артикул.
  • Признак новизны (да/нет).
  • Производителя.
  • Толщину (для товаров разделов Линолеум и Подложка).
  • Размер доски (для товаров разделов Ламинат и Паркетная доска).
  • Цену.
  • Количество.

Товар с торговыми предложениями - это объект, который имеет:

  • ID - уникальный идентификатор.
  • Название.
  • Статус активности (да/нет).
  • Символьный код.
  • Описание.
  • Meta keywords.
  • Meta description.
  • Название страницы (Page Title).
  • Изображение.
  • Артикул.
  • Признак новизны (да/нет).
  • Производителя.
  • Толщину (для товаров разделов Линолеум и Подложка).
  • Размер доски (для товаров разделов Ламинат и Паркетная доска).
  • Торговые предложения.

Торговое предложение - это объект, который имеет:

  • ID - уникальный идентификатор.
  • Название.
  • Статус активности (да/нет).
  • Привязку к основному товару.
  • Артикул.
  • Цвет.
  • Ширину.
  • Количество полос.
  • Цену.
  • Количество.
  • Изображение.

Категория (или субкатегория) - это объект, который имеет:

  • ID - уникальный идентификатор.
  • Наименование (Линолеум, Ламинат, Паркетная доска и Подложка).
  • Символьный код.
  • Описание.
  • Meta keywords.
  • Meta description.
  • Page Title.
  • Статус активности (да/нет).

Как правило, заказчик редко бывает в курсе терминологии, используемой в 1С-Битрикс: Управление сайтом, а также не всегда уверенно разбирается в функционале системы. Поэтому разработчик должен четко понимать, что заказчик имеет в виду под тем или иным пунктом ТЗ и какой пункт какими средствами CMS предстоит реализовать.

Примечание. Абсолютно справедливо и обратное: разработчик проекта не всегда может понимать, что имеет в виду заказчик.

В данном случае описание товаров и их свойств достаточно простое, создание каталога полностью решается штатными средствами системы.

Список ссылок по теме:

  • Информационная архитектура сайта


Создание типов инфоблоков
212 / 254

Анализ приведенного ТЗ показывает, что для создания каталога товаров нам потребуется 2 инфоблока: инфоблок товаров и инфоблок торговых предложений. Их можно хранить как в одном типе, так и в разных. Мы будем хранить в разных, т.е. создадим тип инфоблоков для каталога основных товаров (Каталоги) и отдельный тип для торговых предложений (Торговые предложения).

Примечание: при создании реального проекта желательно удалить все демо-данные: типы инфоблоков и сами инфоблоки (мнение опытного разработчика).

Перейдите в административную часть на страницу Контент > Инфоблоки > Типы инфоблоков. Откроется список типов информационных блоков, имеющихся в системе:

Сперва создадим тип инфоблока основных товаров – Каталоги. Для этого нажмите кнопку Добавить новый тип, расположенную на контекстной панели. Откроется форма создания нового типа инфоблока:

  • На закладке Основное укажите символьный код типа инфоблоков в поле Идентификатор (ID). Код - это произвольный набор латинских букв и символов, понятный администратору сайта. В нашем примере это будет catalog.

    Примечание: использование транслита в наименованиях может порождать огромное количество проблем при командной разработке, так как программисты транслитерируют термины по-разному. Лучше использовать английские названия - так любой разработчик может посмотреть в словаре значение этого термина, если он его не знает.

  • Флажок у поля Использовать древовидный классификатор элементов по разделам определяет, будет ли структура создаваемого типа инфоблока древовидной. Отказ от древовидной схемы требуется в крайне редких случаях.
  • Введите Название типа информационных блоков для русского языка и англоязычной версии.

    Важно! Даже если вы не планируете использование других языковых версий вашего сайта, вам все равно необходимо заполнить колонку Название для всех имеющихся языковых интерфейсов сайта.

  • Колонки Разделы и Элементы необязательны для заполнения. Но ввод в эти поля терминов позволяет сделать работу с каталогом более удобной, так как можно задать более соответствующие и понятные названия для будущих редакторов сайта.

Сохраните внесенные изменения. Форма закроется, система перейдет к списку имеющихся типов инфоблоков, среди которых отразится и вновь созданный тип инфоблока.

Аналогично создайте тип инфоблоков Торговые предложения с идентификатором, например, offers:


Создание инфоблоков
213 / 254

Необходимые типы инфоблоков (Каталоги и Торговые предложения) созданы, теперь можно приступать к созданию самих инфоблоков. Инфоблок товаров назовем Напольные покрытия, а инфоблок торговых предложений - Напольные покрытия (предложения).

Перейдите на страницу административной части Контент > Инфоблоки > Типы инфоблоков > Каталоги и нажмите Добавить инфоблок на контекстной панели. Откроется форма создания нового инфоблока:

На закладке Инфоблок выполните следующие настройки:

  • Задайте символьный код инфоблока (например, floor_covers).
  • Обязательно привяжите инфоблок к сайту магазина.
  • Укажите название инфоблока – Напольные покрытия.
  • Поля с публичными адресами страниц инфоблока пока пропустите. Задайте их, когда настроите компонент отображения инфоблока.
  • Отметьте опции Индексировать разделы для модуля поиска и Индексировать элементы для модуля поиска, чтобы инфоблок индексировался модулем поиска.
  • Остальные параметры оставьте по умолчанию.

Настройку SEO данных (закладка SEO ) на этапе создания инфоблока пропустим, к ней вернемся позже. Перейдем на закладку Поля, где зададим условия для ввода данных о товаре. Например, сделаем обязательным к заполнению поле Детальное описание и Символьный код, который по умолчанию будет транслитерироваться из названия элемента.

Внимание! Если используются компоненты добавления элементов инфоблока из публичной части (iblock.element.add и iblock.element.add.form), а также при импорте данных, то ограничения, заданные в этой закладке, не действуют.

Примечание: есть еще одна особенность при задании параметров в этой закладке. При установке параметра обязательности указанные поля должны обязательно присутствовать в файлах для импорта. При синхронизации с 1С может возникнуть ошибка, связанная с установленным для параметра свойством Обяз. Например, в инфоблоке стоит "Обяз" для значения Картинка для анонса, а в каталоге 1С такая картинка отсутствует. Элемент в этом случае загружен не будет, несмотря на сообщение об успешной синхронизации.

Закладку Свойства также пока пропустим, настройку свойств товаров выполним позже. Перейдем на закладку Поля разделов и для разделов сделаем обязательным к заполнению поле Символьный код:

На закладке Торговый каталог отметим, что созданный инфоблок является торговым каталогом и имеет торговые предложения:

В качестве инфоблока торговых предложений указываем новый инфоблок типа Торговые предложения с названием Напольные покрытия (предложения).

На закладке Доступ мы указываем полный доступ для администраторов, право на чтение для зарегистрированных пользователей и обычных посетителей, а администраторам интернет-магазина даем право на внесение изменений:

Сохраняем внесенные данные. В результате у нас создадутся 2 инфоблока:

Откроем форму редактирования инфоблока Напольные покрытия (предложения) и на закладке Доступ укажем такие же права доступа, как и для инфоблока товаров - Напольные покрытия (см. выше).


Создание свойств товаров
214 / 254

На странице Магазин > Каталог товаров > Напольные покрытия > Свойства товаров производится создание и настройка свойств элементов каталога. Именно здесь вы задаете параметры, описанные в ТЗ на элемент товара. Чтобы понять, какие свойства нам задавать в этой странице, вспомним само ТЗ и в скобках каждого пункта объясним, какими средствами системы мы будем его решать.

Цитата из ТЗ

Простой товар - это объект, который имеет:

  • ID - уникальный идентификатор (ID задается самой системой при создании элемента инфоблока и будет неизменен).
  • Название (штатное поле Название).
  • Статус активности (штатная функция Активность).
  • Символьный код (штатное поле Символьный код).
  • Описание (штатное поле Детальное описание).
  • Meta keywords (штатное поле Шаблон META DESCRIPTION).
  • Meta description (штатное поле Шаблон META KEYWORDS).
  • Page Title (штатная функция комплексного компонента Каталог).
  • Изображение (штатная функция Детальная картинка).
  • Артикул (создается отдельное свойство).
  • Признак новизны (создается отдельное свойство).
  • Производителя (создается отдельное свойство).
  • Толщину (создается отдельное свойство).
  • Размер доски (создается отдельное свойство).
  • Цену (штатная функция торгового каталога).
  • Количество (штатная функция торгового каталога).

Товар с торговыми предложениями - это объект, который имеет:

  • ID - уникальный идентификатор (ID задается самой системой при создании элемента инфоблока и будет неизменен).
  • Название (штатное поле Название).
  • Статус активности (штатная функция Активность).
  • Символьный код (штатное поле Символьный код).
  • Описание (штатное поле Детальное описание).
  • Meta keywords (штатное поле Шаблон META DESCRIPTION).
  • Meta description (штатное поле Шаблон META KEYWORDS).
  • Page Title (штатная функция комплексного компонента Каталог).
  • Изображение (штатная функция Детальная картинка).
  • Артикул (создается отдельное свойство).
  • Признак новизны (создается отдельное свойство).
  • Производителя (создается отдельное свойство).
  • Толщину (создается отдельное свойство).
  • Размер доски (создается отдельное свойство).
  • Торговые предложения (штатная функция торгового каталога).

Таким образом, нам необходимо создать следующие свойства:

  • Артикул
  • Новинка
  • Производитель
  • Толщина
  • Размер доски

Список свойств элементов будет выглядеть так, как показано на скриншоте:

Примечание: вы можете отредактировать порядок сортировки свойств необходимым для вас образом, чтобы изменить положение свойств между собой. На странице товара свойства будут выводиться в соответствии с заданной сортировкой.

Обязательно прочитайте ниже о настройках каждого свойства.

Свойство "Артикул"

Для добавления свойства нажмите кнопку Добавить свойство, расположенную на контекстной панели. В открывшейся форме укажите параметры свойства:

  • В поле Тип выберите Строка.
  • В поле Название введите название свойства – Артикул.
  • В поле Символьный код введите ARTNUMBER.

    Символьный код - мнемонический код свойства, используемый системой при работе с ним. Может состоять из латинских символов и цифр, но не должен начинаться с цифры.
  • Отметьте опцию Значения свойства участвуют в поиске, чтобы можно было выполнять поиск товаров по значениям данного свойства.
  • Отметьте опцию Выводить на странице списка элементов поле для фильтрации по этому свойству, чтобы можно было фильтровать список товаров по этому свойству.
  • Проверьте, чтобы опция Показывать на странице редактирования элемента была отмечена (если нет, то отметьте ее), поскольку свойство общее для всех типов товаров.
  • Остальные параметры оставьте без изменений.
  • Сохраните свойство.

Свойство "Новинка"

Данное свойство будет использоваться для пометки новых товаров в магазине. В форме создания свойства укажите его параметры следующим образом:

  • В поле Тип выберите Список.
  • В поле Название введите Новинка.
  • В поле Символьный код введите NEWPRODUCT.
  • Аналогично, как и для свойства Артикул, отметьте опции:
    • Значения свойства участвуют в поиске
    • Выводить на странице списка элементов поле для фильтрации по этому свойству
    • Показывать на странице редактирования элемента
  • В секции Значения списка добавьте значение да с XML_ID=Y:

    В настройках свойства значение по умолчанию не задаем, чтобы по умолчанию товар не считался новинкой.
  • Сохраните свойство.

Свойство "Производитель"

Свойство Производитель (код MANUFACTURER) создается аналогично свойству Артикул, но дополнительно в настройках необходимо отметить опцию Показывать в умном фильтре и задать внешний вид свойства в фильтре с помощью параметров Вид в умном фильтре и Показать развернутым. В нашем случае сделаем отображение свойства свернутым при входе на страницу, а при разворачивании значения будут показаны с помощью радиокнопок:

Свойство "Толщина"

Свойство Толщина (код DEPTH) - это свойство не для всех разделов, а только для разделов Линолеум и Подложка, поэтому в форме создания свойства опция Показывать на странице редактирования элемента должна быть не отмечена:

Все остальные настройки выполняем аналогично свойству Артикул.

Свойство "Размер доски"

Свойство Размер доски (код SIZE) - это свойство не для всех разделов, а только для разделов Ламинат и Паркет, поэтому его создаем аналогично свойству Толщина:


Создание свойств торговых предложений
215 / 254

На странице Магазин > Каталог товаров > Напольные покрытия > Свойства торговых предложений производится создание и настройка свойств торговых предложений. Именно здесь вы задаете параметры, описанные в ТЗ на торговое предложение:

Торговое предложение - это объект, который имеет:

  • ID – уникальный идентификатор (ID задается самой системой при создании предложения и будет неизменен).
  • Название (штатное поле Название).
  • Статус активности (штатная функция Активность).
  • Символьный код (штатное поле Символьный код).
  • Привязку к основному товару (свойство Элемент каталога типа Привязка к товарам создается автоматически при создании инфоблоков).
  • Изображение (штатная функция Детальная картинка).
  • Артикул (создается отдельное свойство).
  • Цвет (создается отдельное свойство).
  • Ширину (создается отдельное свойство).
  • Количество полос (создается отдельное свойство).
  • Цену (штатная функция торгового каталога).
  • Количество (штатная функция торгового каталога).

Таким образом, список свойств торговых предложений должен выглядеть так, как показано на скриншоте:

Примечание: свойство Элемент каталога (код CML2_LINK) создается автоматически при создании инфоблока торговых предложений.

Обязательно прочитайте ниже о настройках каждого свойства.

Свойство "Артикул"

Свойство Артикул для торговых предложений создаем аналогично свойству Артикул для товаров:

Свойство "Цвет"

В форме создания свойства укажите его параметры следующим образом:

  • В поле Тип выберите Справочник.
  • В поле Название введите Цвет.
  • В поле Символьный код введите COLOR.
  • Проверьте, чтобы опция Показывать на странице редактирования элемента была отмечена.
  • Отметьте опцию Показывать в умном фильтре.
  • В списке Вид в умном фильтре выберите Флажки с картинками.
  • Перейдите к секции Дополнительные настройки:

    • В поле Выберите справочник укажите Создать новый справочник, поскольку заранее мы не готовили highload-блок для использования в качестве справочника цветов.
    • В поле Название справочника введите название highload-блока, например, colorfloor.
    • С помощью полей таблицы создайте необходимое количество записей справочника.
  • Сохраните свойство.

Примечание: дополнительную информацию по работе со свойством типа Справочник смотрите в уроке.

Свойство "Ширина"

В форме создания свойства укажите его параметры следующим образом:

  • В поле Тип выберите Список.
  • В поле Название введите Ширина.
  • В поле Символьный код введите WIDTH.
  • Отметьте опции:
    • Значения свойства участвуют в поиске;
    • Выводить на странице списка элементов поле для фильтрации по этому свойству;
    • Показывать на странице редактирования элемента;
    • Показывать в умном фильтре.
  • В списке Вид в умном фильтре выберите Радиокнопки.
  • В секции Значения списка добавьте все необходимые значения для ширины:

  • Сохраните свойство.

Свойство "Количество полос"

Свойство Количество полос (код STRIP) создается аналогично свойству Ширина с единственным отличием, что в секции Значения списка задаются необходимые значения количества полос:


Создание разделов
216 / 254

Перед созданием элементов инфоблока желательно заранее создать саму структуру каталога. Структура может быть сколь угодно большой глубины вложенности, однако практика показывает, что более 4-го уровня редко кто опускается.

Примечание: если все же возникла необходимость в глубине вложенности более 4-х, то необходимо иметь в виду, что потребуется изменение файлов css и шаблонов меню, используемых для вывода структуры каталога в меню сайта. Подробнее об этом смотрите в разделе Меню в Bitrix Framework курса Разработчик Bitrix Framework.

Цитата из ТЗ:

Категория и субкатегория - это объект, который имеет:

  • ID - уникальный идентификатор (штатное поле системы);
  • Наименование (штатное поле Название).
  • Символьный код (штатное поле Символьный код).
  • Описание (штатное поле Детальное описание).
  • Meta description (штатное поле Шаблон META DESCRIPTION).
  • Meta keywords (штатное поле Шаблон META KEYWORDS).
  • Page title – вывод названия раздела в качестве названия страницы (штатное свойство системы).
  • Статус активности (штатная функция Активность).

Как видим из ТЗ, все свойства раздела реализуются штатными средствами. Приступим к созданию самих разделов: Линолеум, Ламинат, Паркетная доска и Подложка.

Перейдите на страницу Магазин > Каталог товаров > Напольные покрытия > Разделы. Создание разделов выполняется по кнопке Добавить раздел:

В форме создания для каждого раздела заполните поля на закладке Раздел: укажите название, символьный код (с учетом наших настроек инфоблока он транслитерируется из названия), введите описание:

На закладке SEO выполняется настройка SEO данных для раздела каталога, о которой читайте в следующем уроке. На закладке Дополнительно можно указать сортировку раздела.

Перейдите на закладку Свойства элементов. В соответствии с ТЗ при создании разделов Линолеум и Подложка добавьте в отображаемые свойства свойство Толщина и для него отметьте опцию Показывать в умном фильтре:

При создании разделов Ламинат и Паркет добавьте в отображаемые свойства свойство Размер доски и для него отметьте опцию Показывать в умном фильтре:

Примечание: для упрощения работы при создании/редактировании раздела можно выполнить настройку формы создания/редактирования раздела, т.е. настроить отображение полей формы раздела удобным для вас образом.

Теперь, чтобы свойства Толщина и Размер доски правильно показывались для разделов, необходимо выполнить следующее:

  • Со страницы Список товаров (Магазин > Каталог товаров > Напольные покрытия > Список товаров) открыть форму добавления простого товара (кнопка Создать товар).
  • Перейти к настройке внешнего вида формы и удалить свойства Толщина и Размер доски, а также их заголовок (Значения свойства):

  • Сохранить настройки формы.


Настройка SEO данных
217 / 254

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Учебное видео
SEO настройка каталога

Порядок настройки SEO данных в инфоблоке (торговом каталоге) зависит от специфики конкретного магазина. В нашем магазине представлен разнотипный товар, сгруппированный по соответствующим разделам, поэтому мы будем настраивать SEO данные для каждого раздела отдельно.

Перейдите на страницу со списком разделов (Магазин > Каталог товаров > Напольные покрытия > Разделы либо Контент > Каталоги > Напольные покрытия). Поочередно для каждого раздела выполните следующие действия:

  • Откройте форму редактирования раздела с помощью пункта Изменить в меню действий и перейдите на закладку SEO.
  • Сначала задайте настройки мета-данных непосредственно для самого раздела – секция Настройки для разделов:

    Например, для раздела Линолеум настроим шаблоны следующим образом:

    • Шаблон для мета-тега Заголовок окна браузера (META TITLE) зададим так: введем Каталог, затем с помощью кнопки [...] выберем шаблон Поля раздела > Название текущего раздела (подставится {=this.Name}) и допишем от магазина Напольные покрытия.
    • Шаблон для ключевых слов (META KEYWORDS) зададим, используя комбинации текста и шаблона {=this.Name}.
    • Для построения шаблона мета-описания (META DESCRIPTION) воспользуемся шаблоном Поля раздела > Название текущего раздела в нижнем регистре (подставится {=lower this.Name}).
    • Шаблон для заголовка раздела задавать не будем. У нас в качестве заголовка будет использоваться название раздела.
  • Перейдите к секции Настройки для элементов и задайте шаблоны мета-данных для элементов раздела.

    Например, для раздела Линолеум мета-данные товаров мы настроим точно также, как и для самого раздела:

  • Изображения для разделов не используются (см. ТЗ), поэтому секции Настройки для изображений разделов и Настройки для детальных картинок разделов пропустите.
  • Перейдите к настройкам мета-данных для картинок товаров (секции Настройки для картинок анонса элементов и Настройки для детальных картинок элементов) и настройте шаблоны тегов ALT и TITLE, а также шаблоны названий файлов.

    Для нашего магазина настройки в секциях будут одинаковыми и, например, для раздела Линолеум будут выполнены следующим образом:

  • Сохраните внесенные данные.

Таким образом, все мета-данные для разделов и товаров магазина будут формироваться по заданным шаблонам.

Смотрите также:

  • Настройка SEO информации (курс Контент-менеджер)
  • Настройка SEO данных в инфоблоке (курс Администратор. Базовый)
  • Обзор инструментов CMS 1С-Битрикс для поискового продвижение сайта (Статья в e-magnat)


Заполнение каталога товарами
218 / 254

Заполнение каталога товарами может быть выполнено несколькими способами (подробнее о способах смотрите в уроке Наполнение каталога товарами курса Контент-менеджер).

У нас нет ни подготовленного заранее файла для импорта данных, ни интеграции с 1С, поэтому мы будем добавлять товары вручную.

В нашем магазине будут использоваться только простые товары и товары с торговыми предложениями. Подробнее про создание товаров каждого типа смотрите в нижеследующих уроках.

Примечание: подробное описание типов товаров представлено в уроке Типы товаров.


Создание простого товара
219 / 254

Механизм добавления простых товаров в каталог рассмотрим на примере создания товара Подложка Синтетическая в разделе Подложка.

Примечание: действия будем выполнять из административного раздела сайта. О том, как добавить товар из публичного раздела смотрите здесь.

  • Перейдите на страницу Магазин > Каталог товаров > Напольные покрытия > Разделы > Подложка (либо на страницу Контент > Каталоги > Напольные покрытия > Подложка) и нажмите кнопку Создать товар.
  • На закладке Элемент укажите название товара, в нашем случае - Подложка Синтетическая. Символьный код подставится автоматически в соответствии с выполненными настройками инфоблока. Также на этой вкладке задайте необходимые значения свойств товара:

  • Для товаров нашего магазина анонсовые описания не используются, поэтому закладку Анонс пропустите и сразу перейдите на закладку Подробно, где загрузите картинку и введите детальное описание:

  • Закладки SEO и Разделы пропустите, поскольку настройки SEO были выполнены для всех элементов разделов, а создание товара выполняется сразу в нужном разделе.
  • Откройте закладку Торговый каталог и укажите цены на товар:

    • Выберите необходимую ставку НДС и определите включен ли НДС в цену;
    • Укажите себестоимость товара (поле Закупочная цена) и выберите валюту, в которой она задается.
    • Задайте базовую цену и ее валюту.
    • В поле Оптовая цена, которая используется для нашего магазина (см. настройку цен), укажите необходимую наценку и сумма посчитается автоматически.
  • Перейдите на вкладку Параметры, где выберите необходимую единицу измерения для товара и задайте его доступное к покупке количество:

  • Остальные параметры оставьте без изменений. Сохраните товар.

Товар Подложка Синтетическая создан. Аналогичным образом добавляются остальные простые товары в каталог.

Примечание: для упрощения работы при создании/редактировании товара можно выполнить настройку формы создания/редактирования товара, т.е. настроить отображение полей формы товара удобным для вас образом.


Создание товара с торговыми предложениями
220 / 254

Механизм добавления товаров с предложениями рассмотрим на примере создания товара Линолеум Абстракция в разделе Линолеум.

Примечание: действия будем выполнять из административного раздела сайта. О том, как добавить товар из публичного раздела смотрите здесь.

  • Перейдите на страницу Магазин > Каталог товаров > Напольные покрытия > Разделы > Линолеум (либо на страницу Контент > Каталоги > Напольные покрытия > Линолеум) и нажмите Создать товар с торговыми предложениями в меню кнопки Создать другие типы товаров.
  • На закладке Элемент укажите название товара (символьный код подставится автоматически) и задайте необходимые значения свойств товара:

  • На закладке Подробно загрузите картинку и введите детальное описание:

  • Закладки SEO и Разделы пропустите, поскольку настройки SEO были выполнены для всех элементов разделов, а создание товара выполняется сразу в нужном разделе.
  • Перейдите на закладку Торговые предложения. Торговые предложения для товара могут быть добавлены вручную или с помощью генератора. Рассмотрим оба варианта.

Генерация торговых предложений

Сгеренерируем для товара Линолеум Абстракция торговые предложения, например, из комбинаций 2-х вариантов цвета и 3-х вариантов ширины:

  • Нажмите кнопку Генерировать торговые предложения. Откроется окно для генерации предложений.
  • Укажите название для предложений. Для товаров нашего магазина название будет формироваться по шаблону, в котором задействованы название основного товара (свойство родителя), цвет и ширина (свойства предложений):

  • НДС у нас одинаков для всех предложений, поэтому укажите его ставку и определите включен ли НДС в цену.
  • Поле с настройкой цен пропустите, потому что цена на каждое предложение зависит от самого предложения. К настройке цен следует вернуться после генерации предложений.
  • Укажите свойства, в соответствии с которыми будут генерироваться торговые предложения:

  • Загрузите детальные изображения для генерируемых предложений:

  • Нажмите кнопку Генерировать. Торговые предложения сгенерируются в соответствии с нашими требованиями:

    В связи с тем, что при генерации были заданы не все параметры для предложений, нам в карточке каждого предложения следует указать значение свойства Артикул и на закладке Торговый каталог задать:
    • цены (розничную и, если необходимо, оптовую);
    • доступное количество;
    • единицу измерения отличную от используемой по умолчанию (напомним, что в нашем магазине по умолчанию используется квадратный метр - это подходит для товаров разделов Ламинат и Паркетная доска, но для товаров разделов Линолеум и Подложка должна быть задана единица измерения погонный метр).
    Теперь предложения добавлены должным образом.

Добавление торговых предложений вручную

Добавим к товару Линолеум Абстракция, например, предложение в цвете Дуб молочный шириной 2.5 м:

  • Нажмите кнопку Добавить элемент. Откроется форма добавления предложения (аналогичная форме добавления простого товара).
  • Укажите название предложения и заполните значения его свойств:

  • Загрузите детальную картинку на вкладке Подробно.
  • Перейдите на закладку Торговый каталог, где настройте цены на товар, укажите доступное к покупке количество и нужную единицу измерения.
  • Сохраните торговое предложение. Оно добавится в список предложений товара.

Таким образом, для товара Линолеум Абстракция мы создали следующие торговые предложения:

  • Нажмите кнопку Сохранить. Товар с торговыми предложениями добавится в каталог товаров.


Настройка отображения каталога
221 / 254

Для отображения каталога будем использовать комплексный компонент Каталог. Допустим, что у нас имеется ряд требований к отображению каталога на сайте. Перечислим их, указав в скобках какими средствами системы они решаются:

  • выводить названия для страниц каталога (параметр компонента Устанавливать заголовок страницы);
  • устанавливать ключевые слова, мета-описание для страниц каталога (в компоненте не должна быть настроена их установка из свойств как для списка товаров, так и для детального просмотра, чтобы данные брались из настроек SEO);
  • должен быть доступен фильтр для отбора интересующих товаров (параметры в секции компонента Настройки фильтра);
  • для оптовых покупателей должна показываться оптовая цена, а не розничная (параметры в секции компонента Цены);
  • свойство Артикул (товаров, а не предложений) должно показываться только на странице со списком товаров (свойство должно быть выбрано в поле Свойства для списка товаров, но не выбрано в настройках детального просмотра);
  • выбор необходимого торгового предложения должен быть доступен сразу при просмотре списка товаров (включить расширенную схему в параметрах компонента);
  • на странице товара должна быть возможность оставить отзыв о товаре (параметр компонента Включить отзывы о товаре);

Как видим, все задачи решаются штатными настройками компонента Каталог. Рассмотрим реализацию более детально. Для этого откроем параметры компонента Каталог и выполним их настройку:

Секция Основные параметры

  • Укажите тип инфоблоков Каталоги и инфоблок Напольные покрытия.

Секция Дополнительные настройки

  • Установите флажок в поле Устанавливать заголовок страницы. Теперь заголовок страницы будет браться из поля Название соответствующего странице элемента.
  • Установите флажок в поле Устанавливать статус 404 если не найдены элемент или раздел. В этом случае товарный каталог покажет не сообщение на пустой странице (элемент или раздел не найден), а перебросит пользователя на 404 страницу.

    Примечание: разработчик должен взять за правило: на проекте должны быть вменяемые тексты на страницах 404, 500 ошибок, а также сообщение о технических работах.

Секция Управление адресами страниц

  • Включите поддержку ЧПУ и настройте адреса страниц.

    Примечание: укажите адреса этих страниц в настройках инфоблока:

Секция Настройки фильтра

  • Отметьте опцию Показывать фильтр и в поле Тип цены выберите розничную цену, чтобы покупатели могли отбирать товары по цене. Остальные параметры группы оставьте по умолчанию. В фильтре будут отображаться те свойства товаров (и простых, и с предложениями), в настройках которых был задан показ в умном фильтре.

Секция Цены

  • Обязательно укажите типы цен: розничную и оптовую.

Секция Добавление в корзину

  • Правильно укажите адрес корзины и отметьте свойства, значения которых должны отображаться в корзине.

Секция Настройки списка

  • В поле Свойства выберите Артикул, Производитель, Толщина и Размер доски, а в поле Свойства предложений - Цвет, Ширина и Количество полос.
  • Поля Установить ключевые слова страницы из свойства раздела, Установить описание страницы из свойства раздела и Установить заголовок окна браузера из свойства раздела должны быть незаполненными, поскольку метаданные формируются в соответствии с SEO настройками.

Секция Настройки детального просмотра

  • В поле Свойства выберите Производитель, Толщина и Размер доски, а в поле Свойства предложений - Артикул, Цвет, Ширина и Количество полос.
  • Аналогично, как и для списка, поля Установить ключевые слова страницы из свойства раздела, Установить описание страницы из свойства раздела и Установить заголовок окна браузера из свойства раздела должны быть незаполненными.

Секция Дополнительно

  • В поле Схема отображения выберите расширенный.
  • В поле Свойства для отбора предложений отметьте Цвет, Ширина и Количество полос.
  • Отметьте опцию Включить отзывы о товаре. Станут доступными настройки отзывов: отметьте опцию Использовать комментарии и задайте название для блога латинскими буквами.


Настройки магазина
222 / 254

Помимо уже выполненных настроек, для работы магазина необходимо создать/настроить следующие группы данных:

  • Службы доставки;
  • Платежные системы;
  • Скидки;
  • Свойства заказа;
  • Внутренние счета для некоторых покупателей;
  • Заполнить печатные формы.


Создание скидки
223 / 254

Скидки в магазине могут быть реализованы несколькими способами. Это могут быть: скидки на товары, скидки на заказы (правила работы с корзиной), покупателям могут выдаваться купоны скидок, а также могут быть разработаны накопительные программы.

Список скидок зависит от стратегии магазина, маркетинговых акций и в процессе работы магазина будет постоянно пополняться/изменяться.

Рассмотрим пример создания скидки на товар. Допустим, что для нашего магазина необходима скидка 20% на любой из видов линолеума, если его остаток меньше или равен 5 погонным метрам:

  • Откройте страницу управления скидками на товары (Магазин > Управление маркетингом > Скидки на товар > Скидки на товар) и нажмите кнопку Новая скидка. Откроется форма создания новой скидки:

  • Укажите параметры скидки:
    • введите название Скидка на линолеум;
    • в списке сайтов выберите сайт магазина;
    • период активности укажите Без ограничений;
    • укажите величину скидки в процентах;
    • валюта скидки - RUB;
    • снимите галочку в поле Прекратить дальнейшее применение скидок, что позволит применять другие скидки параллельно с этой;
    • остальные параметры на данной закладке оставьте без изменения.
  • Перейдите на закладку Условия и установите применение скидки только к разделу Линолеум и при количестве товара на складе меньше или равно 5:

  • На закладке Ограничения можно задать запреты на применение скидки какими-либо группами пользователей или по отношению к каким-либо типам цен. Мы этого делать не будем.

    Примечание: кроме скидок есть еще и купоны. Скидка применяется ко всем товарам, указанным в закладке Ограничения, если не задано дополнительное ограничение в виде купона. Если такое ограничение задано, то скидка применяется к товарам, при заказе которых покупатель указал номер купона.

    В нашем случае ограничение в виде купона накладываться не будет.
  • Сохраните внесенные изменения. Скидка создастся и отобразится в общем списке.

Ссылки по теме:

  • Примеры скидок на заказы


Службы доставки
224 / 254

Существует два типа служб доставки: автоматизированные и настраиваемые. Разница в этих службах в том, что в автоматизированных службах доставки расчет стоимости доставки происходит не на вашем сайте, а на серверах этих служб, и вы не можете влиять на стоимость доставки. Единственное, что вы можете сделать - это осуществить наценку на стоимость доставки. Зато это можно сделать для каждого из интернет-магазинов в отдельности, если у вас их несколько.


Автоматизированные
225 / 254

Управление автоматизированными службами доставки выполняется на странице Магазин > Настройки > Службы доставки > Автоматизированные, где представлен список стандартных служб доставки. Чтобы начать использовать в магазине какую-либо из служб, ее необходимо сначала настроить.

Например, настроим службу доставки ПЭК, которая необходима в нашем магазине для доставки товаров в регионы России.

  • Откройте форму редактирования службы доставки ПЭК:

  • Если у вас несколько сайтов в системе, то установите флажок в поле Использовать индивидуальные настройки для различных сайтов и в поле Выберите сайт укажите ваш сайт интернет-магазина.
  • На вкладке Базовая конфигурация настройки оставьте по умолчанию. Если необходимо, то в поле Наценка на стоимость доставки укажите процент наценки.
  • Перейдите на закладку Настройки обмена:

  • Укажите имя пользователя и ключ для доступа к API, полученные при подписании договора с ПЭК. Затем заполните данные о своей организации и выберите форму оплаты.
  • На закладке Дополнительные услуги настройте услуги, которые ПЭК будет дополнительно оказывать:

  • Откройте закладку Автоперевозка:

    • Среди базовых настроек профиля службы отметьте опцию Активен, чтобы автоперевозка использовалась в качестве службы доставки грузов. Название оставьте по умолчанию. Если необходимо, то в поле Наценка на стоимость доставки укажите процент наценки на доставку автотранспортом. Задайте платежные системы, для которых будет использоваться данный профиль доставки.

      Примечание: если нужной платежной системы в списке нет, то ее следует создать, указав в настройках данную службу доставки.
    • Задайте ограничения на заказ, на отправку и размеры упаковочной коробки для расчета доставки автотранспортом:

  • Выполните необходимые настройки на закладке Авиаперевозка (поля аналогичны полям закладки Автоперевозка).
  • Сохраните внесенные изменения.

В случае необходимости дополнительно произведите настройку необходимых вам служб.


Настраиваемые
226 / 254

Настраиваемые службы доставки - это службы, стоимостью услуг которых вы можете управлять. Это, как правило, курьеры самого интернет-магазина или внешние по отношению к магазину службы внутригородской доставки.

Управление настраиваемыми службами доставки выполняется на странице Магазин > Настройки > Службы доставки > Настраиваемые. По умолчанию в системе уже есть примеры настраиваемых служб доставки, но они требуют настройки под конкретные нужды. Для нашего магазина потребуются служба доставки курьером и самовывоз. Их настройку (создание) рассмотрим на примере службы доставки курьером:

  • Откройте форму редактирования службы доставки (для создания/редактирования любой настраиваемой службы доставки используется одна и та же форма):

  • На закладке Служба доставки указывается название службы, сайт магазина, параметры доставки и местоположения.

    • Примечание: доставка может быть разной по стоимости в зависимости от веса заказа и его стоимости. Поля Вес и Стоимость заказа задают параметры для определения стоимости конкретной службы доставки. Так как параметры веса и стоимости заказа (а, следовательно, и стоимости доставки) могут быть разные, то служб доставки курьером может быть несколько. При создании магазина надо предусмотреть все возможные варианты по стоимости и весу заказа. Система при оформлении заказа автоматически выберет подходящую службу из имеющихся.

  • На закладке Платежные системы укажите платежные системы, которые можно будет использовать в случае выбора данной службы доставки при оформлении заказа. Если нужной платежной системы в списке нет, то ее следует создать, указав в настройках данную службу доставки.
  • Сохраните внесенные изменения.

Аналогичным образом создаются все настраиваемые службы доставки с необходимыми вам параметрами доставки.


Платежные системы
227 / 254

По умолчанию в системе уже создано несколько платежных систем для примера, но сразу использовать их нельзя. Поэтому необходимо заново создать платежные системы или выполнить настройку параметров уже имеющихся систем. При перенастройке системы на работающем магазине следует быть очень внимательным, иначе могут возникнуть проблемы с невыполненными заказами.

Управление платежными системами выполняется на странице Магазин > Настройки > Платежные системы. Рассмотрим настройку (создание) следующих платежных систем:

  • Оплата наличными
  • Оплата через банк

Оплата наличными

  • Откройте форму создания/редактирования платежной системы. На закладке Платежная система должно быть указано название платежной системы, отмечен флаг активности, задан индекс сортировки и, при необходимости, заполнено описание:

  • Перейдите на закладку Типы плательщиков, она содержит вложенные закладки для каждого созданного типа плательщиков на каждом сайте системы:

    Примечание: настройки платежной системы выполняются одинаково для всех типов плательщиков, поэтому мы рассмотрим только для типа плательщика Физическое лицо. В случае необходимости настройки для других типов выполните аналогично.

  • Убедитесь, что отмечена опция Применяется для данного типа плательщика.
  • Введите название системы для данного типа плательщика.
  • Выберите обработчик для платежной системы в выпадающем списке одноименного поля. В нашем случае – Наличный расчет (cash).

Интеграция Интернет-магазина с платежными системами осуществляется через обработчики платежных систем. Эти файлы создаются индивидуально для каждой платежной системы и вызываются непосредственно после оформления заказа, а также при выборе клиентом функции повторения платежа в персональном разделе. При необходимости выберите, где должен открываться обработчик: если он должен открываться в новом окне браузера, то установите флажок в поле Открывать в новом окне.

  • В поле Кодировка укажите кодировку, в которой работает сайт платежной системы, например: UTF-8.

    Примечание: кодировка платежной системы указывается в документации, которую вы получите от службы поддержки выбранной системы вместе с параметрами доступа к ней. В случае с наличными (cash) в это поле можно ничего не вводить, так как обработчик работает на стороне вашего магазина.

  • Повторите последние четыре действия для необходимых типов плательщиков нужных сайтов системы.
  • Перейдите на закладку Службы доставки и отметьте те службы доставки, для которых может использоваться наличный расчет:

    Примечание: в списке доступны только настроенные активные ваши службы доставки. При необходимости настройте нужную вам службу доставки.
  • Сохраните внесенные изменения. Платежная система для наличного расчета создана.

Оплата через банк

Создание платежной системы для оплаты через банк осуществляется аналогичным способом. Отличие только в выборе обработчика и его свойствах.

В дистрибутиве по умолчанию имеются все необходимые, на взгляд создателей 1С-Битрикс: Управление сайтом, обработчики, которые могут понадобиться владельцам магазинов. При создании платежной системы выберите нужный вам банк.

Если вы не нашли нужный вам обработчик, то его можно создать самостоятельно, пользуясь документацией.

Ссылки по теме:

  • Пример настройки платежной системы Яндекс.Деньги
  • Настройка платежной системы PayPal
  • Настройка платежной системы ROBOKASSA
  • Настройка платежной системы QIWI Wallet


Создание свойства заказа
228 / 254

Свойства заказа - это значения заказа, которые должны быть указаны клиентом интернет-магазина при оформлении заказа. Они различаются по типам плательщиков.

Свойства заказа можно собирать в группы для облегчения зрительного восприятия свойств.

Все имеющиеся группы можно увидеть на странице Магазин > Настройки > Свойства заказа > Группы свойств. Нажатием кнопки Новая группа, расположенной на контекстной панели, можно вызвать форму создания новой группы. Форма очень простая и ее заполнение не должно вызвать у вас трудностей.

По умолчанию в дистрибутиве предусмотрен минимально необходимый набор свойств заказа. Список всех имеющихся свойств заказа доступен на странице Магазин > Настройки > Свойства заказа > Список свойств:

Создадим свойство заказа Станция метро для типа плательщика Физическое лицо. Для этого нажмите на кнопку Новое свойство и в выпадающем списке выберите Физическое лицо. Откроется форма создания нового свойства:

Рассмотрим поля формы, которые необходимо заполнить:

  • В поле Название введите Станция метро.
  • В поле Мнемонический код укажите, например, METRO.
  • В поле Тип выберите MULTISELECT Список со множественным выбором.
  • Опцию Обязательное отмечать не будем, так как предполагается, что покупатели могут быть из городов, где нет метро.
  • Поле Значение по умолчанию лучше оставить пустым, поскольку невозможно сказать с какой станции будет большинство покупателей.
  • При необходимости выставьте значение Сортировка.
  • Поле Входит в профиль в данном случае лучше активировать.

    Активность этого поля означает, что однажды заполненное пользователем поле будет при последующих заказах автоматически принимать значение, выбранное им при первом заказе. Маловероятно, что пользователь будет менять место жительства так часто, что при каждом заказе ему надо будет заново выбирать станцию метро. А автоматически проставленная станция облегчит ему процесс заказа, значит повышается вероятность, что он вновь вернется к вам в магазин.

  • В поле Группа свойств выставьте Данные для доставки.

    Примечание: если вы создаете какое-то свойство и для него нет группы, то к созданию группы можно перейти по ссылке Группы свойств.

  • Поля Размер 1 и Размер 2 определяют размеры используемых полей. К их выбору надо подходить с учетом дизайна вашего сайта. Поэтому рекомендаций давать не будем, а просто укажем, что если значения в этих полях не заданы, то система будет использовать значения по умолчанию.
  • В поле Описание свойства введите комментарий к свойству.
  • Все нижележащие поля мы использовать не будем. К ним даны исчерпывающие комментарии на самой форме, чтобы вы при необходимости могли воспользовались ими.
  • Нажмите кнопку Применить, чтобы выполнить перезагрузку формы. В результате появится секция Значения списка. Продолжим заполнение полей, обязательными из которых являются только Код и Название:

    • Введите в поле Название имя станции метрополитена.
    • Введите Код для станции. Код может быть произвольным, но введен на латинице.
    • При необходимости укажите значение сортировки.
    • Повторите последние ействия для каждой станции метро. Для добавления полей воспользуйтесь кнопкой Еще.
  • Сохраните внесенные изменения. Форма закроется, система вернется к списку свойств.

Теперь при создании заказа будет отображаться новое свойство Станции метро.

При необходимости создайте аналогичное свойство для типа плательщика – Юридическое лицо.


Создание счета покупателя
229 / 254

Если компания (или частное лицо) постоянно покупает у вас какие-то товары, то есть смысл завести счет для такого постоянного покупателя. Это удобно покупателю, можно всегда быстро обратиться в магазин и приобрести нужный товар. Деньги в магазин могут поступать как угодно: наличными, перечислением. Их заносят на счет пользователя и оплата, при заказе товара, происходит автоматическим списанием суммы заказа со счета покупателя в магазине.

В ТЗ к сайту этот момент также не был оговорен. Мы можем реализовывать его по нашему усмотрению. Сделаем это в простейшем, штатном варианте.

С заведением пользователя в системе не происходит автоматического создания счета этого пользователя.

Примечание: но вместе с тем счет создается автоматически (если его не было) при денежных транзакциях (например, оплата заказа).

Создадим его вручную.

  • Перейдите на страницу Магазин > Покупатели > Счета. Откроется список счетов.
  • Нажмите на кнопку Добавить счет на контекстной панели. Откроется форма создания счета:

  • В строке Пользователь нажмите на кнопку [...]. Откроется окно для выбора пользователя.
  • Выберите в этом окне нужного пользователя.
  • В поле Сумма на счете введите переведенную вам авансом сумму. И выберите нужную валюту.
  • В полях Заметки и Основание для изменения суммы на счете введите информацию, сопровождающую счет: какие-то пояснения, замечания.
  • Сохраните внесенные изменения. Вновь созданный счет отобразится в общем списке.

Теперь можно создавать заказ с оплатой со счета.


Создание складов
230 / 254

Создадим склад для нашего интернет-магазина. Перейдите на страницу Магазин > Складской учет > Склады и нажмите кнопку Добавить. Откроется форма создания склада:

Заполните нужные поля и нажмите Сохранить.

Теперь вы можете указывать в форме редактирования товара (закладка Склады) его количество на данном складе:

Количество на складе будет отображаться при детальном просмотре товара, для этого в настройках комплексного компонента должно быть разрешено отображение количества товара на складе:

Важно! Количество товара на складах носит информационный характер и не влияет на расчет доступного к покупке количества товара.


Печатные формы
231 / 254

Для вывода на печать данных по заказу необходимо также настроить печатные формы. Для этого перейдите на страницу Печатные формы (Магазин > Настройки > Печатные формы):

Заполнение данных для "Печатных форм

Заполните поля для компании-продавца и для покупателя. Можно вводить как собственные данные, так назначить системе какие данные брать из заказов и свойств. Заполнение формы не должно вызвать трудностей.


Экспорт данных
232 / 254

Для экспорта товаров во внешние электронные каталоги типа Яндекс. Маркет предусмотрено два типа экспорта: Froogle и Yandex. Экспорт в Яндекс возможен двумя способами: просто экспорт и экспорт типа simple (упрощенный). Вы можете использовать любой из этих способов. Разница между ними заключается в том, что simple-режиме нет возможность выбрать отдельные разделы каталога, экспортируется весь выбранный инфоблок.

Примечание: если вы постоянно успешно производили выгрузку во внешний каталог через указанный механизм экспорта, а с какого-то момента начались ошибки, то прежде всего узнавайте, не изменились ли требования к файлу со стороны внешнего каталога. Проблемы в этом случае можно решить, обратившись в техподдержку.

У Яндекса есть несколько типов объектов товарного каталога. Это: vendor, model, book, artist и tour. 1С-Битрикс: Управление сайтом производит выгрузку в YML файл только общие для всех типов поля. А специализированные, вроде ISBN и автора для типа товаров книга, длительность для фильма и прочие, в текущей версии не выгружаются. На это стоит обратить внимание и включить в план работ кастомизацию выгрузки, например, если по этому материалу делается интернет-магазин для продажи книг. Заказчик обязательно попросит выгружать автора и ISBN и ещё ряд полей в Яндекс. Маркет (так же стоит это объяснить заказчику эту особенность CMS, что бы избежать обвинений в неполном экспорте данных в стандартной конфигурации).

Примечание: разработчик должен взять за правило - просматривать файлы выгрузок во время проведения работ по интеграции или экспорту данных. Так как скрипт может отработать верно, а формат или содержимое выгрузки могут не совпадать.


Частные случаи
233 / 254

При нестандартных запросах заказчика, прежде чем разрабатывать что-то самим, рекомендуем обратиться на форум компании 1С-Битрикс, либо на блоги сообщества разработчиков. Ниже приведены некоторые сообщения в блогах, которые могут помочь при разработке нестандартных проектов.

Внимание! Информация из блогов – это частное мнение автора сообщения, а не рекомендации создателей системы. Система обновляется, какие-то функции появляются в штатном функционале. Кроме этого обновления ядра системы могут привести к неработоспособности некоторых предлагаемых вариантов.

  • Изменение формы редактирования товара;
  • Аксессуары в интернет-магазине;
  • Включение НДС в новые товары по умолчанию;
  • Автоматический ежедневный импорт валют;
  • Обновление курса валют на сайте (вариант через агентов);
  • Автоматическое обновление курсов валют на сайте;
  • Автоматическое создание купона на скидку;
  • Гибкие цены для филиалов;
  • Как позволить оплатить с внутреннего счета только при определенной сумме на счете;
  • Модуль для интернет-магазинов;


Дополнительно
234 / 254


Интеграция с "1С:Управление торговлей" ред. 11.0
235 / 254

В данной главе представлено описание настроек интеграции для 1С:Управление торговлей в устаревшей редакции 11.0. Для данной редакции дополнения и модуль обмена не выпускается, поэтому обмен можно выполнить только с учетом имеющейся у вас конфигурации.


Концепция взаимодействия конфигурации «Управление торговлей 11» и «1С-Битрикс: Управление сайтом»
236 / 254

Торговая компания, которая ведет учет в конфигурации Управление Торговлей 11, может интегрировать в единую систему дополнительный канал продаж – интернет-магазин на базе 1С-Битрикс: Управление сайтом (далее БУС). При этом Управление торговлей 11 (далее УТ) будет выполнять функции бэк-офиса, обслуживая управление товарной номенклатурой, ценовой политикой, продажами компании в целом, а на веб-сайте будет работать фронт-офис, генерирующий заказы.

Данные о товарах и ценах поступают из УТ в БУС, а заказы из БУС в УТ. Заказ, поступивший в УТ, обрабатывается в соответствии с принятыми в торговой компании правилами. По заказам регистрируется отгрузка и оплата. Данные об изменениях в заказах могут быть выгружены назад на сайт. Такой двусторонний обмен происходит до тех пор, пока заказ не будет закрыт, отменен или полностью выполнен.

Возможны и другие варианты взаимодействия, когда из УТ выгружаются товары, а заказы обрабатываются прямо на сайте, без использования системы бэк-офиса.
Еще вариант, когда управление товарами происходит на сайте, а в УТ выгружаться только заказы для дальнейшей обработки.

Все взаимодействие двух систем происходит по открытым протоколам и стандартам:

  • TCP IP
  • HTTP, HTTPS
  • XML (Commerce ML 2.04)
  • Протокол выгрузки товарной номенклатуры
  • Протокол обмена заказами


Типовые сценарии работы пользователей
237 / 254

В описании сценариев используются следующие роли:

Продавец – торговая компания, у которой установлена программа Управление торговлей 11 и которая продает товары через сайт.

Покупатель – юридическое или физическое лицо, осуществляющее покупки через интернет с сайта продавца.


Сценарий 1. Выполняется Продавцом
238 / 254
  1. Продавец формирует каталог товаров.
  2. В зависимости от настроек обмена на сайт выгружается структура групп товаров справочника Номенклатура или структура групп справочника Виды номенклатуры.
  3. При формировании каталога товаров для сайта Продавец должен решить, в каком справочнике формировать структуру групп товаров сайта.
  4. При формировании каталога могут быть созданы произвольные дополнительные реквизиты и сведения элементов справочника Номенклатура, которые будут выгружены на сайт как свойства элемента инфоблока.
  5. Продавец формирует наименования и описания товаров. Присоединяет изображения и произвольные файлы к элементам справочника Номенклатура.
  6. Если по товарам ведется учет по упаковкам, то Продавец задает наборы упаковок, если нет – единицы измерения товаров.
  7. Продавец устанавливает ставки НДС для товаров.
  8. Продавец устанавливает цены на товары и определяет типовые соглашения, по которым будут выгружаться предложения. Типовые соглашения должны быть действующими, с незаполненным сегментом партнеров и со включенным флагом Доступно внешним пользователям.
  9. Продавец создает настройку обмена, устанавливает отборы для выгрузки на сайт и выгружает данные.


Сценарий 2. Выполняется Покупателем
239 / 254
  1. Покупатель заходит на сайт, находит нужные ему товары, услуги, видит цены на товары, варианты оплаты, действующие скидки на товары и услуги. На сайте может быть настроен показ остатков товаров или информации о доступности товаров.
  2. Выбранные товары помещаются в корзину.
  3. Далее Покупатель заполняет необходимую информацию для оплаты и доставки заказа и подтверждает заказ. Пока заказ не оплачен и не отгружен, Покупатель может изменить состав заказа или отменить его.
  4. Покупатель оплачивает и ожидает заказанные товары.


Сценарий 3. Выполняется Продавцом
240 / 254
  1. Продавец получает информацию о заказанных товарах или услугах, проверяет Заказ, полученный с сайта, проверяет корректность информации о контрагенте и партнере, выполняет согласование Заказа.
  2. В процессе согласования состав заказа может быть изменен.
  3. При отсутствии необходимых товаров на складе оформляется заказ поставщику.
  4. При невозможности поставить товары заказ отменяется.
  5. При поступлении оплаты от клиента регистрирует факт оплаты соответствующими документами. При поступлении товаров на склад компании и получении оплаты от клиента (в зависимости от установленного графика оплаты) переводит заказ в статус К отгрузке и оповещает клиента о готовности отгрузить заказ, отгружает товары и услуги клиенту.


Сценарий 4. Покупатель получает товары, заказанные на сайте
241 / 254
  1. Покупатель проверяет соответствие полученных товаров заказанным на сайте.
  2. При несоответствии потребительских свойств или качества заявленных на сайте товаров покупатель может отказаться от получения товаров. Возврат товаров на сайте никак не отражается.
  3. Оформляются соответствующие документы Продавцом в конфигурации Управление торговлей.


Сценарий 5. Обновление данных о каталоге товаров и услуг на сайте
242 / 254
  1. Продавец может произвольно менять данные каталога товаров в конфигурации Управление торговлей.
  2. В режиме автоматической полной выгрузки, при очередном сеансе обмена, все каталоги товаров выгрузятся на сайт.
  3. В режиме автоматической выгрузки изменений, при очередном сеансе обмена, все сделанные изменения выгрузятся на сайт.


Основные технические характеристики подсистемы обмена с сайтами
243 / 254
  • Обмен между УТ и сайтом осуществляется в формате CommerceML 2.05.
  • Обмен двунаправленный: выгрузка товаров на сайт, загрузка/выгрузка заказов с сайта.
  • Возможна выгрузка на сайт или в каталог на диске.
  • Возможна загрузка с сайта или из файла на диске.
  • Обмен с сайтом происходит по протоколу HTTP.
  • Запуск обмена может выполняться как интерактивно, так и по регламенту (автоматически).
  • Возможна как полная выгрузка, так и выгрузка только тех объектов, которые изменились.
  • Товары (номенклатура без характеристик) выгружаются как элемент CML Каталог, который включает в себя Классификатор.
  • Структура групп товаров строится по иерархии групп номенклатуры. Опционально может быть построена по справочнику Виды номенклатуры.
  • Характеристики, цены, остатки, скидки выгружаются, как элемент CML Пакет предложений.
  • С товарами могут быть выгружены присоединенные файлы и их описания. Файлы выгружаются отдельными файлами.
  • Товары могут выгружаться в один каталог и в несколько каталогов за один сеанс. Для каждого каталога может быть указан отбор по группам классификатора. Каждый каталог соответствует инфоблоку сайта. Для каждого инфоблока формируются отдельные Каталоги и Пакеты предложений в разных файлах xml.
  • Обмен заказами происходит в два этапа: сначала загрузка с сайта, затем выгрузка на сайт (или в каталог на диске).
  • По заказам, загруженным с сайта, формируется документ Заказ клиента.
  • При последующих сеансах обмена табличная часть документа обновляется в соответствии с информацией, полученной с сайта.
  • В ответном CML на сайт отправляется информация об оплате и отгрузке по заказам, ранее загруженным с сайта.
  • Контрагенты и номенклатура, полученные с сайта, идентифицируются в соответствующих справочниках. Объекты, которые не найдены, создаются.


Функциональность подсистемы
244 / 254
  • Выгрузка товаров на сайт или в каталог на диске в формате CML.
  • Установка отбора для выгружаемых товаров (номенклатура, соглашение, остатки по складам). Выгружаются цены по соглашениям. Т.е. для каждого товара вычисляются цены по всем действующим типовым соглашениям, у которых пустой сегмент партнеров и включен флаг Доступно внешним пользователям. При этом в xml в элементе ТипЦен будет передаваться соглашение. В отборе для выбора пользователю предлагаются только те соглашения, которые имеют смысл.
  • Выгрузка нескольких каталогов в одном сеансе обмена. Для каждого каталога может быть настроен индивидуальный набор выгружаемых групп, а также отбор выгружаемых товаров.
  • Загрузка заказов с сайта или из каталога на диске в формате CML.
  • Выгрузка данных по оплате и отгрузке по ранее загруженным заказам на сайт или в каталог на диске в формате CML.
  • Идентификация контрагентов в заказах, полученных с сайта по наименованию, ИНН+КПП.
  • Идентификация номенклатуры по уникальному идентификатору, по наименованию.
  • Управление режимом записи и проведения документов Заказ клиента (только запись, проведение, оперативное проведение).
  • Передача и хранение статусов и дополнительных реквизитов заказа с сайта.
  • Дополнительные реквизиты и статусы заказа с сайта загружаются в дополнительные сведения документа Заказ клиента.
  • В настройке обмена с сайтом можно указать соответствие статусов заказа на сайте статусам (состояниям) документа Заказ клиента. Если такое соответствие установлено, то при загрузке заказа с сайта будет выполняться попытка установки соответствующего состояния документа Заказ клиента.
  • Отмена Заказов клиента, отмененных на сайте. Отменяется заказ целиком. Частичная отмена не предусмотрена.
  • Хранение различных настроек обмена.
  • Хранение истории обмена с сайтом.
  • Вывод информации о результатах последнего сеанса обмена.
  • Интерактивный запуск обмена по настройке.
  • Автоматическое выполнение обмена по расписанию.
  • Полная выгрузка данных или частичная выгрузка только тех объектов, которые изменились с момента последнего успешного сеанса обмена. Регистрация изменений по узлам соответствующего плана обмена.
  • Сжатие передаваемых на сайт данных (zip).


Настройка параметров учета конфигурации «Управление торговлей 11» для обмена с сайтами
245 / 254
  • Включить использование обмена с сайтами в 1С: Управление торговлей 11: перейти Администрирование > Настройка параметров учета > Обмен данными, включить флажок Использовать обмен с сайтами:

  • Включить использование дополнительных реквизитов и сведений: перейти Администрирование > Настройка параметров учета > Общие настройки, включить флажок Использовать дополнительные реквизиты и сведения:

  • Включить использование заказов клиентов: перейти Администрирование > Настройка параметров учета > Оптовые продажи, включить флажок Использовать заказы клиентов:

  • Создать типовое соглашение для выгрузки цен: перейти Маркетинг > Типовые соглашения с клиентами. Создать новое соглашение или изменить существующее. При этом статус соглашение должен быть Действует, с пустым сегментом партнеров, с актуальным периодом действия, соответствующим видом цен и доступно внешним пользователям:

    Примечание: Тип цены для импортируемых товаров будет создан в соответствии с названием типового соглашения, поэтому имеет смысл назвать его, например, Цена инет-магазина или в подобном виде.


Создание узла обмена с сайтом
246 / 254
  • Перейти Администрирование - Обмен с сайтами. Нажмите кнопку Создать, откроется форма создания узла обмена с сайтом:

    • Примечание: для конфигурации Управление торговлей 10.3 нужно запустить помощник настройки обмена с WEB-сайтом Сервис > Обмен данными с WEB-сайтом > Настроить обмен данными с WEB-сайтом и затем выбрать Создать новую настройку обмена с WEB-сайтом.

  • Наименование и Код заполнятся автоматически при сохранении настройки. Но Вы можете задать их вручную при необходимости.
  • Установить Режим обмена данными для создаваемого узла: Выгрузка товаров, если планируется выгрузка товаров на сайт, и Обмен заказами, если планируется загрузка заказов с сайта.
  • Указать назначение обмена: Сайт или Каталог на диске. Для сайта указывается Адрес скрипта, обрабатывающего трафик обмена. Например, http://my_site.ru/bitrix/admin/1c_exchange.php.
  • Также необходимо указать Имя пользователя и Пароль. Для проверки соединения воспользуйтесь кнопкой Проверить соединение. Если все параметры заполнены корректно, будет выдано сообщение Соединение успешно установлено:

    В противном случае необходимо проверить правильность адреса и параметров доступа. Если проверка соединения не проходит, обмен работать не будет. Для назначения Каталог на диске указывается папка, в которую будут выгружаться файлы обмена. Для загрузки заказов указывается имя xml-файла с заказами.

  • Указать режим контроля изменений. В режиме Полная выгрузка выгружаются все товары и заказы, соответствующие условиям выгрузки. В режиме Выгружать только измененные объекты происходит автоматический контроль изменений, произошедших с момента последней удачной полной выгрузки. Все эти изменения выгружаются на сайт.
  • Настроить автоматический обмен, при необходимости. Для этого установить флажок Использовать периодический обмен данными. При этом автоматически откроется форма настройки расписания обмена. В расписании необходимо указать требуемое расписание обмена. Например так:

Настройте при необходимости выгрузку товаров и обмен заказами. О том как сделать это смотрите в следующем уроке.


Настройка выгрузки товаров
247 / 254
  • Перейти на закладку Выгрузка товаров (закладка доступна и видна, если включен флажок Выгрузка товаров на закладке Основные настройки):

  • Указать организацию – владельца каталога. Это та организация, от имени которой происходит выгрузка товарных предложений на сайт.
  • Указать коэффициент пересчета веса. По умолчанию = 1. Этот коэффициент используется для пересчета веса товаров из единиц, в которых указан вес в УТ, в единицы, в которых вес учитывается на сайте (например, пересчет веса товара из грамм в УТ в килограммы на сайте).
  • Установить флажок Выгружать файлы изображений, если планируется выгрузка картинок товаров на сайт.
  • Установить флажок Выгружать прочие файлы, если предполагается выгрузка произвольных файлов, присоединенных к номенклатуре, на сайт.
  • Установить флажок Классифицировать по видам номенклатуры, если необходимо построить классификатор групп товаров по справочнику Виды номенклатуры. Иначе группы будут выгружаться из справочника Номенклатура.
  • Настроить таблицу каталогов.

    Таблица каталогов содержит строки, соответствующие инфоблоку на сайте. В колонке Каталог задается имя каталога, в колонке Группы номенклатуры настраивается фильтр выгрузки групп. Причем состав выбираемых групп зависит от установки флажка Классифицировать по видам номенклатуры: если включена классификация по видам номенклатуры, то группы выбираются из справочника Виды номенклатуры, иначе – из справочника Номенклатура.

    Если группы не выбраны (указано Все), то выгружаются все группы. В колонке Идентификатор каталога задается идентификатор, по которому устанавливается связь выгружаемых данных с конкретным инфоблоком на сайте (для конфигурации Управление торговлей 10.3 колонка называется GUID каталога).

    Примечание: В версии 11 невозможно сохранение профиля без задания этих настроек.

    В версии 10 сохранение профиля возможно и обмен данными произойдет, но без указания соответствий всё выгрузится в "Основной каталог товаров". Поэтому считается, что указание соответствий обязательно и для УТ в версии 10.

  • Настроить отбор при необходимости: нажмите Настроить отбор, откроется форма настройки отборов для выбранного каталога. Отбор устанавливает ограничения по выгрузке товаров. Настройка отбора происходит стандартным для УТ образом:

  • Нажмите Завершить редактирование.
  • Сохраните настроенный узел обмена.


Настройка обмена заказами
248 / 254
  • Перейти на закладку Обмен заказами (закладка доступна и видна, если включен флажок Обмен заказами на закладке Основные настройки):

  • Настроить способ идентификации контрагентов. Это режим поиска контрагентов при загрузке заказов с сайта. Есть 2 варианта поиска: по Наименованию или по комбинации ИНН+КПП (одновременное их применение невозможно).
  • Указать вид номенклатуры Товар. С этим видом номенклатуры будут записываться новые товары, загруженные с сайта.
  • Указать вид номенклатуры Услуга. С этим видом номенклатуры будут записываться новые услуги, загруженные с сайта.
  • Указать единицу измерения для новой номенклатуры. Товары, которые будут создаваться при загрузке с сайта, будут записаны с этой единицей измерения.
  • Заполнить группу для новой номенклатуры, при необходимости. В эту группу будут помещаться товары и услуги, создаваемые при загрузке заказов с сайта.
  • Выберите созданное вами типовое соглашение, с которым будут создаваться документы Заказ клиента.
  • При необходимости можно указать организацию, от имени которой будут создаваться документы Заказ клиента.
  • При необходимости можно указать менеджера, от имени которого будут создаваться документы Заказ клиента.
  • На закладке Дополнительно можно настроить дополнительные параметры обмена заказами:

  • При необходимости установите режим записи и проведения документов Заказ клиента.
  • При необходимости настройте параметры отмены заказов. Если заказ отменен на сайте, соответствующая информация выгружается в УТ. Статус заказа Отменен - это значение статуса, получаемого с сайта. Обычно это значение равно Отменен. В поле Причина отмены заказа можно указать причину отмены, которая будет заполняться в соответствующем поле документа Заказ клиента.
  • При необходимости, нажав на кнопку Добавить, можно настроить соответствие статусов заказа на сайте статусам документа Заказ клиента в УТ. Если такие соответствия настроены, то при загрузке заказов будет происходить попытка установки соответствующего статуса документа Заказ клиента.
  • Сохранить настроенный узел обмена.


Изменение параметров существующих настроек (для конфигурации "Управление торговлей 10.3")
249 / 254

Для изменения параметров имеющихся настроек обмена данными с WEB-сайтом необходимо в меню выбрать Сервис > Обмен данными с WEB-сайтом > Выполнить обмен данными с WEB-сайтом:

На форме располагается список доступных настроек, по которым можно произвести обмен, краткая информация об обмене, а также дата последнего произведенного обмена:

В списке настроек присутствует пункт Настроить обмен данными для вызова формы помощника для добавления новой настройки обмена:

С помощью кнопки лупа откроем настройку для просмотра/изменения параметров обмена. На форме представлены настройки обмена, установленные ранее с помощью помощника. Варианты настроек на форме сгруппированы по режимам выгрузки (Выгрузка товаров, Обмен заказами). При установке флажка напротив необходимого режима появятся соответствующие вкладки:

Аналогичная форма настройки появится, если на форме помощника настройки выбрать пункт Изменить существующую настройку обмена с WEB-сайтом. После чего будет предложено выбрать настройку для изменения:


Выполнение обмена данными
250 / 254

Ручной запуск

Для ручного запуска обмена данными по настройке (узлу обмена) нажмите кнопку Выполнить обмен данными в форме узла или форме списка узлов. Будет запущен процесс обмена, по окончании которого будет выдано соответствующее сообщение.

Автоматический запуск

Для автоматического запуска обмена достаточно настроить расписание автоматического обмена данными и сохранить настройку узла обмена данными. Если на сервере 1С: Предприятия включено выполнение регламентных заданий, обмен будет происходить автоматически, по заданному расписанию. В файловом варианте работы Управления торговлей для выполнения автоматического обмена по расписанию должен быть запущен специальный сеанс, обрабатывающий регламентные задания:

Нажмите на рисунок, чтобы увеличить


Экспорт каталога с сайта в 1С
251 / 254

Начиная с версии продукта 12.5, доступна возможность экспорта каталога товаров с сайта в 1С: Предприятие. В 1С-Битрикс: Управление сайтом указываются только какие товары должны быть выгружены (см. форму интеграции), а сама процедура выполняется со стороны 1С.

В 1С:Предприятие перейдите в Администрирование и кликнете по последнему пункту Импорт товаров с сайта 1С-Битрикс. Откроется мастер импорта товаров с сайта:

  • В поле Адрес укажите адрес вашего сайта, содержащий путь до файла /bitrix/admin/1c_exchange.php (либо путь к странице с собственными настройками интеграции).
  • В поле Авторизация задайте логин и пароль пользователя из 1С-Битрикс: Управление сайтом, который обладает правом на выгрузку каталога с сайта (т.е. пользователь должен относится к группе, указанной в настройках интеграции).

Нажмите кнопку Далее.

На следующем шаге задайте параметры импорта товаров в 1С:

  • Укажите Вид номенклатуры загружаемых товаров, чаще всего это Товар.
  • В поле Единица измерения укажите шт.
  • В поле Загружать товары в группу задайте группу, в которую товары должны быть загружены. Группу можно выбрать как среди существующих, так и создать новую:

  • Отметьте необходимые для вас опции загрузки товаров в 1С: создавать ли подгруппы, свойства и характеристики товаров, устанавливать ли цены, загружать ли картинки.

Нажмите кнопку Далее. Отобразится информация о процедуре импорта каталога товаров с сайта:

Нажмите кнопку Начать импорт. В процессе импорта, когда система получит данные с сайта, она запросит у вас разрешение на загрузку товаров. После того, как товары будут загружены в базу 1С, система запросит разрешение на загрузку изображений. По окончании процедуры импорта будет выведен протокол загрузки товаров:

Для проверки выполненных действий перейдите в Продажи > Номенклатура:


Просмотр журнала обмена
252 / 254

Для анализа результатов обмена используется журнал регистрации 1С: Предприятия. Для просмотра событий выгрузки данных по узлу обмена необходимо выделить в списке нужный вам сеанс обмена и нажать кнопку События выгрузки данных. Для просмотра событий загрузки – События загрузки данных:

Примечание: для просмотра результатов обмена в конфигурации Управление торговлей 10.3 выберите в меню Сервис > Обмен данными с WEB-сайтом > Монитор обмена данными или на форме настройки обмена данными на командной панели, а также на форме списка настроек нажать на кнопку Монитор обменов.

В форме журнала регистрации для просмотра истории обмена открываются строки журнала, и анализируется содержащаяся в них информация:

Нажмите на рисунок, чтобы увеличить


Настройка контроля журнала регистрации
253 / 254

Для просмотра ошибок обмена можно использовать режим Контроль журнала регистрации (Администрирование > Сервис > Контроль журнала регистрации):

Для автоматической отправки email сообщений с отчетом по ошибкам обмена необходимо настроить расписание регламентного задания для формирования отчета по расписанию и указать email адреса получателей отчета. Также необходимо настроить системную учетную запись:


Просмотр и очистка регистрации объектов
254 / 254

Для просмотра и удаления объектов, зарегистрированных для выгрузки в очередном сеансе обмена в режиме выгрузки изменений, выделите нужный сеанс выгрузки и нажмите Показать зарегистрированные изменения:

Для просмотра объектов, зарегистрированных для выгрузки, откроется форма:

В форме отображаются группы (виды) объектов: Товары, Файлы и Заказы. Если нет ни одного зарегистрированного для обмена объекта, то группа не отображается.

Если необходимо отменить (удалить) регистрацию конкретного объекта, необходимо выбрать его и нажать кнопку [x]:


Администратор. Бизнес
0 / 254

Курс предназначен для администраторов сайтов, работающих на базе системы «1С-Битрикс: Управление сайтом». Изучение курса необходимо при работе с продуктом редакции «Малый бизнес» и выше при организации торговых операций через Интернет.

Расширенная версия интернет-магазина включает в себя следующий функционал, отсутствующий в базовой версии:

  • несколько видов цен;
  • остатки по складам/магазинам;
  • накопительные скидки;
  • аффилиатские программы;
  • возможность оплаты с внутреннего счета покупателя;
  • автоматическое списание с кредитных карт;
  • продажа электронного контента;
  • конструктор отчетов;
  • сервис Есть идея!;
  • поддержка покупателей;
  • социальная сеть;
  • веб-сервисы (интеграция магазина);
  • документооборот (утверждение материалов).

Этим курсом заканчивается линейка административных курсов по Bitrix Framework.

После изучения курса вам будет предложено пройти тесты на сертификацию. При успешной сдаче линейки тестов на странице Моё обучение можно просмотреть результат обучения и загрузить сертификат в формате PDF.

Для преподавания оффлайн

Если данный курс берётся в качестве основы для оффлайного преподавания, то рекомендуемая продолжительность: 2 дня (16 академических часов).

Скачать материалы курса в формате CHM. Файлы формата CHM обновляются ежемесячно, тем не менее, возможно некоторое отставание их от онлайновой версии курса.

Если не видно содержание файла CHM
Внимание! Если вы не видите содержимое файла формата .chm, то причина - настройки безопасности операционной системы: скачанные из интернета файлы находятся под наблюдением системы, которая ограничивает доступ к ним.

Чтобы отключить подобное отношение к файлу необходимо:

  • перейти в свойства файла на вкладку Общие. Внизу у Вас отобразится сообщение о том, что этот файл был заблокирован системой с целью защиты компьютера.

  • нажать кнопку Разблокировать.

Отсутствие кнопки Разблокировать возможно в двух случаях:

  1. Файл лежит не локально, а на сетевом ресурсе.
  2. Если файл лежит на локальном диске, но путь к нему содержит спецсимволы (# и прочие).