Справочная информация
1 / 694

Где получать информацию о функционале и способах работы

Научиться работать с продуктами компании «1С-Битрикс» не сложно, но потребуется внимание и определённая мера усидчивости. А поможет в этом различного вида справочная информация, ссылки на которую расположены на сайте компании в разделе Документация.

Справочная информация включает в себя:
  • Разные виды документации
  • Учебные курсы
  • Контекстная справка
  • Мастер магазина
  • Частые вопросы
  • Документация в файлах формата .chm

Документация

Нажмите на рисунок, чтобы увеличить

  • Онлайн документация для пользователей - описание интерфейса системы управления сайтом, ее основных модулей и наиболее типичных операций. Также в ней содержится полное описание прикладного программного интерфейса.
  • Онлайн документация для разработчиков по старому ядру, по ядру D7 и по Rest_API. Предназначена для технических специалистов со знанием PHP и HTML. В ней содержатся сведения о технологиях и основных принципах, заложенных в систему, описание классов и функций по всем продуктам.

Учебные курсы

Нажмите на рисунок, чтобы увеличить

Онлайн Курсы - это методические пособия по работе с продуктом, которые включают в себя описание и примеры работы с системой.

Контекстная справка

Нажмите на рисунок, чтобы увеличить

Контекстная справка выводит в Административной части системы информацию, относящуюся к открытому в данный момент разделу или странице. Доступна как в 1С-Битрикс: Управление сайтом , так и в коробочном Битрикс24 .

Мастер магазина

Мастер магазина - встроенная в административную часть система помощи с краткой информацией по конкретной задаче в рамках настройки и эксплуатации интернет-магазина с ссылками на более детальную информацию в конкретных учебных курсах.

FAQ

Частые вопросы - подборка решений наиболее часто встречающихся проблем при работе с продуктом в удобном представлении.

Документация в файлах формата .chm

Для изучения документации в оффлайн (при отсутствии интернета) созданы файлы в формате справки Windows. Они содержат копию онлайн документации, эти файлы обновляются реже, чем источник на сайте. По возможности рекомендуем использовать онлайн документацию.

Если не видно содержание файла CHM
Внимание! Если вы не видите содержимое файла формата .chm, то причина - настройки безопасности операционной системы: скачанные из интернета файлы находятся под наблюдением системы, которая ограничивает доступ к ним.

Чтобы отключить подобное отношение к файлу необходимо:

  • перейти в свойства файла на вкладку Общие. Внизу у Вас отобразится сообщение о том, что этот файл был заблокирован системой с целью защиты компьютера.

  • нажать кнопку Разблокировать.

Отсутствие кнопки Разблокировать возможно в двух случаях:

  1. Файл лежит не локально, а на сетевом ресурсе.
  2. Если файл лежит на локальном диске, но путь к нему содержит спецсимволы (# и прочие).

Файлы можно скачать с главной страницы учебного курса, либо с описания курса или документации на сайте компании.

Внимание! В файлах формата .chm нет возможности просматривать видеоролики и не работают всплывающие подсказки. Это ограничения формата. Поэтому рекомендуем пользоваться онлайн версией курсов.

Примечание: В дополнение к документации, информацию, касающуюся продуктов компании «1С-Битрикс», можно получить на сайте в разделе форум .

Для администраторов и разработчиков также рекомендуется познакомиться с опытом разработок сайтов на Bitrix Framework, который описывается в блогах разработчиков и в группах Социальной сети сайта компании 1С-Битрикс.

© «Битрикс», 2001-2008, «1C-Битрикс», 2008-2020 1С-Битрикс


Как отформатирован текст в курсе
2 / 694

Форматирование текста облегчает восприятие информации

Читать монотонный текст сложно. Форматирование - один из способов облегчить понимание смысла. Опишем правила форматирования, чтобы вам было легче ориентироваться.

Форматирование текста

Жирный шрифт используется для выделения важных в смысловом значении слов, терминов, фраз и предложений. То есть то, что особенно важно в контексте описываемого функционала:

  • Ключевое смысловое слово, фраза.
  • Термины, названия элементов интерфейса: кнопки, вкладки, поля, горячие клавиши, формат или название файла.
  • Название курса, глав курса, разделов и страниц сайтов. (Как правило, название глав или курсов даются ссылкой, но иногда это бывает излишним).
Примеры использования жирного шрифта
Пример названия курса или главы | Изучение курса позволяет освоить основные методы администрирования системы, а так же пополнить знания по темам, изученным в курсе Контент-менеджер.
Пример названий элементов интерфейса: | При этом у компонента Список новостей нужно настроить входные параметры так, чтобы он мог формировать ссылки на страницу детальной новости (с кодом новости). Для этого нужно в группе параметров Шаблоны ссылок в поле URL страницы детального просмотра задать путь к этой странице, а также название параметра, в котором будет передаваться код новости для показа.
Пример ключевой фразы, слова | При регистрации сервера обязательно укажите Домен для NTLM авторизации. Он должен полностью (включая регистр) совпадать с названием домена.

и Курсив и подчёркивание используются для выделения:

  • Названия продуктов компании 1С-Битрикс, других программ и технологических платформ.
  • Названия методов, классов, функций и событий, если нет их описания в API доке. (Если описание есть, то название метода или класса оформляется ссылкой на страницу документации.)
  • Пространство имён в новом ядре D7.
  • Ключевое слово, фраза, термин, если использование жирного шрифта не желательно по каким-то причинам.

Примеры использования курсива
Пример названия метода: | Усовершенствованные методы буферизации в шаблоне позволяют более не использовать CBitrixComponentTemplate::EndViewTarget() ввиду того, что конец шаблона вызывает завершение буферизации автоматически. (Если страница метода в документации есть, то будет так: Перед подключением компонента ко всем значениям параметров применяется функция htmlspecialcharsEx )
Пример названий продуктов и платформ: | Чтобы научиться эффективно работать в Bitrix Framework, нужно не сравнивать то, что вы знаете по другим системам, а стараться понять как то или иное реализуется в этой системе. В плане обучения «сравнительный» подход не работает. Просто отвлекитесь от старых знаний и изучите новую систему, используя только знания PHP и сайтостроения, а не сравнивая идеологии и технологии.
Пример пространства имён в D7: | При необходимости модуль может организовывать подпространства внутри своего пространства имен. Например, Bitrix\Main\IO, Bitrix\Forum\SomeName\SomeNameTwo.

Серый фон текста используется для выделения:

  • путей в рамках файловой системы.
  • атрибутов, тегов html, параметров функций, переменных, значения полей и настроек и листинга кода, который нет смысла помещать в стиль для листинга.
Примеры использования серого фона
Пример выделения путей в рамках файловой системы: | Результаты кеширования сохраняются в виде файлов в каталоге /bitrix/cache/.
Пример выделения атрибутов, тегов и так далее: | Если в компоненте написать код: $arParams = & $arSomeArray; то переменная $arParams будет отвязана от члена класса компонента и привязана к массиву $arSomeArray.

Синий курсив с > используется для подсветки путей в продукте. То есть пути выглядят так же как они оформлены в административном отделе системы.

Примеры использования синего курсива
Пример оформления путей в административном отделе системы: Файлы кеша можно удалить в административной части на закладке Очистка файлов кеша страницы Настройки > Настройки продукта > Автокеширование.

Синий шрифт используется для подсветки УРЛ без создания собственно ссылки - псевдо УРЛ.

Примеры использования синего шрифта
Пример псевдо УРЛ: При помощи access_token приложение совершает запросы к REST-сервису до его истечения.
https://имя_портала.bitrix24.ru/rest/user.current?auth=код_авторизации

Форматирование текста цветом используется в случаях, когда надо выделять информацию, относящуюся к разным сущностям в паралелльных процессах.

Примеры использования цветного шрифта
Цветной шрифт:
  • Настроить инфоблок на контроллере:

    ........

  • На подключенном сайте надо создать инфоблок с таким же значением внешнего кода, как и на контроллере. Кроме привязки к сайту, названия и внешнего кода необходимо настроить и права доступа к инфоблоку.

    ......

Всплывающие подсказки

Всплывающие подсказки обозначаются цветом шрифта и пунктирным подчёркиванием. Такие подсказки используются там, где:

  • Нужно пояснить какой-то термин.
    Пример: Как правило, все сайты имеют возможность авторизации из публичного раздела .
  • Дать наглядное представление о команде интерфейса.
    Пример: При включённом режиме Правки откройте на редактирование элемент инфоблока , например, новость.
  • Дать дополнительную, но не относящуюся напрямую к выполняемым работам, информацию.
    Пример: Этот инструмент создаст ссылку с одним единственным слешом после домена сайта .
  • Дать описание и ссылку на страницу компонента в пользовательской документации.
    Пример: Простую фотогалерею в публичном разделе выводит комплексный компонент Фотогалерея 2.0 .
Внимание! Всплывающие подсказки не работают в файлах формата CHM. Интернет на мобильных устройствах на сегодняшний день - не проблема, используйте эти файлы документации только в крайнем случае.

Форматирование абзацев текста

Форматирование целых абзацев текста используется для выделения какой-либо информации с целью указать направленность этой информации.

Определения каких-либо сущностей, явлений, терминов и так далее выводятся в абзацах такого вида:

Статическая информация – это информация, которая редко изменяется с течением времени. Например, рекламные тексты, история компании, контактная информация и т.п. Статическая информация создается, редактируется, дополняется и удаляется пользователями, обладающими правом на редактирование страниц сайта. Такое редактирование производится, как правило, в визуальном редакторе непосредственно в тексте самой страницы.

В Примечании размещается информация, поясняющая текст на странице, на которую стоит обратить внимание. Это могут быть примеры, расширенное объяснение, уточнение, ссылка на дополнительную информацию. Например:

Примечание. В ядре D7 настройки кеширования производятся в специальном файле

Предупреждения - это информация, имеющая критическое значение для работы того или иного функционала продукта. Например:

Важно! Если курс был деактивирован, то результаты тестов и сертификаты по этому курсу будут недоступны пользователям. Если курс был удален, то результаты тестов и сертификаты этого курса будут также удалены.

В особо важных случаях в этом виде форматирования может использоваться красный шрифт.

Спойлеры, скрывающие текст

В спойлерах размещается информация, которая имеет вторичное значение, но может быть полезна "для общего развития". Для открытия спойлера надо просто кликнуть на "+" в спойлере:

Задание окна для открытия ссылки при редактировании в режиме кода (для ознакомления)

В коде каждый из пунктов этого списка задается с помощью атрибута target тега <a>. Атрибут target может принимать соответственно следующие значения:

  • _blank;
  • _parent;
  • _self;
  • _top.

Чтобы избежать лишней прокрутки экрана, в спойлерах может быть размещена большая по объёму информация.

Видеоролики

Видеоролики располагаются в начале соответствующего урока. Или же вы можете следить за новыми роликами, которые выкладываются на нашем канале .


Основные сведения о системе
3 / 694
В главе опишем основные сведения о системе, дадим глоссарий терминов и схему работы продукта.


Модульная структура
4 / 694

Функционал в системе группируется помодульно

«1С-Битрикс: Управление сайтом» имеет модульную структуру.

Модуль - объёмная часть программного кода, отвечающая за определённый функционал на сайте. Каждый модуль отвечает за управление определенными элементами и параметрами портала: информационным наполнением и структурой, форумами, рекламой, рассылкой, распределением прав между группами пользователей, сбором статистики посещений, оценкой эффективности рекламных кампаний и так далее.

Возможности редакции (лицензии) продукта, что она может, а что - нет, определяется набором модулей. Проверить состав вашей редакции можно на странице Лицензии.

Модули системы, главным образом, работают независимо друг от друга. Но есть и зависимости, функционал одних модулей основан на возможностях других. Например:

  • Модуль Торговый каталог расширяет возможности модуля Информационные блоки и позволяет выполнять настройку цен товара в зависимости от различных условий, применять к товарам наценку и скидки и т.п.
  • Модуль Документооборот позволяет организовать последовательную коллективную работу с содержимым модулей Информационные блоки и Управление структурой.

Где в системе виден список модулей

Список используемых модулей выводится на странице Управление модулями (Настройки > Настройки продукта > Модули) в административном разделе системы:

Нажмите на рисунок, чтобы увеличить

Таблица содержит название и описание модулей, информацию о версии и дате последнего обновления, а также текущий статус в системе:

  • Установлен – модуль и его элементы доступны для использования .
  • Не установлен – модуль не доступен для использования в системе.

Функционал модулей в Административном разделе

Функционал установленных модулей виден в соответствующей секции административного меню системы.

Для некоторых модулей данные в меню загружаются динамически. Например:

  • для модуля Информационные блоки выполняется динамическая загрузка списка типов инфоблоков;
  • для модуля Веб-формы выполняется динамическая загрузка списка веб-форм;
  • для модуля Управления структурой выполняется динамическая загрузка файловой структуры.

В зависимости от прав на доступ к модулям системы не всем доступен тот или иной функционал модуля. Управление уровнем прав пользователей на доступ к модулям системы осуществляется отдельно для каждого модуля на странице его настроек.

Настройка модулей

Страница настроек модуля имеет различное число вкладок и полей, в зависимости от функционала модуля. Перейти к ней можно следующими способами:

  • с помощью административного меню: Настройки > Настройки продукта > Настройки модулей > имя_модуля;
  • с помощью кнопки Настройки Кнопка, расположенной на административной панели. По этой кнопке вы перейдете к настройкам модуля, страницы (формы) которого открыты в текущий момент в основной рабочей области.

Дополнительная информация

  • Документация по продукту


Глоссарий
5 / 694

Что есть что?

Каждая платформа имеет свои термины, используемые в работе. Чтобы без проблем ориентироваться в документации, учебных курсах, при общении с разработчиками желательно объяснять ваши трудности не «на пальцах», а на языке понятном специалистам. Ниже в помощь вам приведен глоссарий терминов системы и несколько общих терминов, активно используемых в системе.

  • Административная часть
  • Публичная часть
  • Режим Правка
  • Сайт
  • Шаблон сайта
  • Раздел сайта
  • Компоненты
  • Путь к компоненту
  • Включаемые области
  • Навигационная цепочка
  • Индексная страница (файл)
  • Пользователь
  • Группа пользователей
  • Почтовое событие
  • Тип почтового события
  • Почтовый шаблон
  • Путь относительно корня
  • Полный путь
  • Абсолютный путь
  • DocumentRoot
  • Система обновлений
  • Язык
  • Языковой файл
  • Многоязычный интерфейс
  • Локализация
  • Мета-тэг
  • Доменное имя (домен)
  • Хост
  • IP адрес
  • Сессия
  • Время в Unix-формате
  • Права в Unix системах
  • Пролог
  • Эпилог
  • Тело страницы
  • Шаблон страницы
  • Сабмит
  • HTML-безопасный вид
  • Связывание переменных
  • Дамп
  • cron (крон)
  • Буферизация
  • Постоянное соединение (persistent)
  • Accept-Language
  • Кастомизация
  • API
  • Экземпляр программы
  • Портал

Термин | Описание
Административная часть Раздел системы, содержащий интерфейс для управления модулями системы, структурой, содержанием, посетителями и другими составляющими сайта. Страницы, в которых подключен административный пролог и эпилог. Эти страницы:
  • не принадлежат ни одному сайту;
  • принадлежат какому-либо модулю;
  • имеют строго определённый административный интерфейс;
  • отображаются в выбранном языке интерфейса;
  • дополнительно проверяются по правам, задаваемым в настройках соответствующего модуля.
Публичная часть Раздел системы, доступный для отображения посетителям сайта.На страницах раздела подключается пролог и эпилог одного из шаблонов сайта. Эти страницы:
  • принадлежат какому либо сайту;
  • имеют интерфейс текущего шаблона сайта;
  • отображаются на языке текущего сайта.
Режим Правка | Режим, при котором текущая страница публичного раздела отображается в особом виде: выделены используемые компоненты, включаемые области, редактируемые области и т.д. Каждая такая область имеет набор кнопок для быстрого перехода к редактированию данного элемента страницы.
Сайт Совокупность параметров:
  • учетная запись в базе данных - создаётся в административном меню Сайты, включает в себя:
    • идентификатор - набор символов, идентифицирующий сайт;
    • доменное имя - одно или более доменное имя сайта;
    • папка сайта - путь к каталогу в котором будет храниться публичная часть сайта;
    • язык сайта;
    • формат даты и времени;
    • URL - протокол и доменное имя по умолчанию (например, http://www.site.ru);
    • DocumentRoot - если многосайтовость организована на разных доменах, то в данном параметре должен храниться путь в файловой системе сервера к корню сайта;
    • условия подключения шаблонов - каждый сайт может иметь один или более шаблонов для отображения скриптов своей публичной части, каждый такой шаблон может быть подключен по тому или иному условию;
  • публичная часть - совокупность страниц, лежащих в папке сайта и принадлежащих этому сайту;
  • настройки - каждый модуль может иметь ряд настроек, связанных с сайтом, например у модуля Информационные блоки эти настройки представляют из себя привязку информационного блока к тому или иному сайту, у модуля Техподдержка - привязку статуса, категории и т.п. к сайту.
Шаблон сайта Синонимы: дизайн сайта, скин сайта. Для показа одного сайта можно использовать несколько различных шаблонов. Шаблон сайта - это набор файлов в каталоге /bitrix/templates/ID_шаблона/, где ID_шаблона - поле ID в форме редактирования шаблона сайта. Структура каталога:
  • /components/ - каталог с компонентами, принадлежащими тому или иному модулю;
  • /lang/ - языковые файлы, принадлежащие как шаблону в целом, так и отдельным компонентам;
  • /images/ - каталог с изображениями шаблона;
  • /page_templates/ - каталог с шаблонами страниц и их описанием, хранящимся в файле .content.php;
  • /include_areas/ - каталог с файлами - содержимым включаемых областей;
  • header.php - пролог шаблона;
  • footer.php - эпилог шаблона;
  • styles.css - CSS стили, используемые на страницах сайта, когда используется шаблон;
  • template_styles.css - CSS стили, используемые в самом шаблоне;
  • .тип меню.menu_template.php - шаблон вывода меню соответствующего типа;
  • chain_template.php - шаблон по умолчанию для вывода навигационной цепочки;
  • а также ряд других вспомогательных произвольных файлов и папок, входящих в данный шаблон.
Раздел сайта | Каталог в файловой системе сервера. В Bitrix Framework структура сайта - это файловая структура сервера, поэтому страницы сайта - это файлы, а разделы сайта - соответственно каталоги.
Компонент | Часть какого-либо модуля, логически завершенный код, хранящийся в одном файле. Принимает ряд параметров, выполняет ряд действий и выводит результат этих действий (например, в виде HTML кода). Использование компонента - предпочтительный способ вывода информации как в публичной, так и в административной частях. Компонент подключается методом IncludeComponent Рабочая версия компонентов - 2.0. Использование компонентов 1.0 не рекомендуется, но их ещё можно встретить на сайтах, построенных на ранних версиях системы.
Путь к компоненту | Устаревшее. Используется в функции CMain::IncludeFile в качестве первого параметра и представляет из себя путь к основному файлу компонента 1.0.
Включаемые области | Это специально выделенная область на странице сайта, которую можно редактировать отдельно от основного содержания страницы. Реализуется с помощью специального компонента.
Навигационная цепочка | Это элемент дизайна, предназначенный для навигации по сайту. Выводится в визуальной части пролога и состоит из заголовков разделов сайта с соответствующими ссылками на них. Помимо заголовков разделов, добавляемых автоматически, вы также можете добавлять произвольные пункты в навигационную цепочку.
Индексная страница (файл) Это имя файла, который будет использован веб-сервером в случае, если запрашиваемый URL заканчивается на слэш и не содержит в себе имени файла. Порядок, в котором будут искаться индексные страницы для различных веб-серверов, задается по разному, например:
  • Apache - в файле httpd.conf, параметр DirectoryIndex;
  • IIS - в свойствах сайта, закладка Documents > Enable default content page;
К сожалению, в PHP значение данного параметра недоступно, поэтому для определения индексной страницы в коде необходимо пользоваться функцией GetDirIndex.
Пользователь Запись в базе данных с параметрами зарегистрированного пользователя, обязательные поля:
  • логин;
  • пароль;
  • E-Mail.
А также ряд дополнительных полей, содержащих личную информацию о пользователе, информацию по его работе, административные заметки.

Регистрационные данные (логин и пароль) в дальнейшем используются для авторизации в системе. Пользователь привязывается к определенной группе и получает право на доступ к ресурсам портала в соответствии с правами данной группы.

Группа пользователей | Совокупность пользователей, обладающих определенными правами на доступ и управление ресурсами (например, пользователи группы Модераторы обладают правом на чтение и редактирование сообщений форума). Управление группами пользователей осуществляется на странице Группы пользователей в административном разделе (Настройки > Пользователи > Группы пользователей).
Почтовое событие Это почтовое сообщение, имеющее свой тип и отправляемое по соответствующему почтовому шаблону. Почтовое событие инициализирует поля типа почтового события конкретными значениями. Порядок расположения этих полей в письме, а также текст письма, определяется почтовым шаблоном.
Для создания почтового события предназначен класс CEvent.
Почтовый шаблон Определяет текст почтового сообщения, а также порядок расположения полей (placeholder'ов), заданных в типе почтового события.
Почтовые шаблоны доступны в административном разделе на странице Почтовые шаблоны (Настройки > Настройки продукта > Почтовые события > Почтовые шаблоны).
Для манипуляции почтовыми шаблонами предназначен класс CEventMessage.
Тип почтового события Определяет набор специальных полей (placeholder'ов), которые могут быть использованы в почтовом шаблоне. В момент создания почтового события эти поля будут инициализированы конкретными значениями.
Типы почтовых событий доступны в административном разделе на странице Типы почтовых событий (Настройки > Настройки продукта > Почтовые события > Типы почтовых событий).
Для манипуляции типами почтовых событий предназначен класс CEventType.
Путь относительно корня | Путь к файлу, начинающийся от каталога, указанного в параметре DocumentRoot в настройках веб-сервера, заданный по правилам формирования URL-адресов. Пример:/ru/about/index.php
Полный путь | Включает в себя протокол, домен, порт и путь относительно корня к странице (каталогу). Пример: http://www.bitrixsoft.ru/ru/about/index.php
Абсолютный путь | Абсолютный путь к файлу включает в себя DocumentRoot и путь относительно корня.
DocumentRoot Путь к корню сайта в файловой системе сервера. Задается в настройках веб-сервера, например:
  • для Apache - в файле httpd.conf, параметр DocumentRoot;
  • для IIS - в свойствах сайта, закладка Home Directory > Local Path.
Система обновлений Технология SiteUpdate позволяет:
  • скачивать обновления продукта;
  • загружать новые модули и обновления для имеющихся модулей, расширяющие их функциональные возможности;
  • загружать языковые файлы и устанавливать новые языки;
  • выполнять регистрацию лицензий на дополнительные сайты.
В процессе обновления выполняется модификация только ядра продукта (файлы папок /bitrix/modules/, /bitrix/tools/, /bitrix/admin/ и /bitrix/components/bitrix/). Обновление не затрагивает публичную часть портала, полностью исключая возможность потери данных.

Обновление системы осуществляется в несколько шагов:

  • система обновлений автоматически запрашивает лицензионный ключ продукта;
  • затем выполняется проверка наличия доступных обновлений;
  • далее пользователю предлагается выбрать обновления для загрузки;
  • после этого происходит загрузка выбранных обновлений.
Язык Это учетная запись в базе данных, доступная для редактирования в административном меню на странице Языки интерфейса, со следующими полями:
  • Идентификатор;
  • Название;
  • Формат даты;
  • Формат времени;
  • Кодировка;
  • и т. д..
Как в публичной, так и административной частях, язык в первую очередь используется в работе с языковыми файлами.
В административной части язык определяет формат времени, даты, кодировку страниц (в публичной - данные параметры определяются настройками сайта).
Языковой файл Файл, хранящий переводы языковых фраз на тот или иной язык. Данный скрипт состоит из массива $MESS, ключи которого - идентификаторы языковых фраз, а значения - переводы на соответствующий язык. Для каждого языка существует свой набор языковых файлов, хранящихся как правило в каталогах /lang/.
Языковые файлы, как правило, используются в административных скриптах модулей и в компонентах.
Для работы с языковыми файлами предназначен модуль Перевод.
Многоязычный интерфейс Возможность реализуется за счет использования языковых файлов, хранящих перевод фраз на соответствующие языки для:
  • административного раздела;
  • сообщений об ошибках;
  • визуальных компонентов;
  • соответствующих областей в шаблоне портала;
  • и т.д.
В соответствии с текущим языком интерфейса выполняется подключение необходимых языковых файлов. В результате сообщения отображаются пользователю на выбранном им языке. Переключение между языками административного интерфейса осуществляется на административной панели.
Локализация | Подразумевает представление информации в переводе на соответствующих языке, кодировке и форматов представления данных (дата, время, денежные единицы, числа и т.д.).
Мета-тэг | Мета-тэг это - элемент HTML, задающий информацию о странице: кодировку страницы, ключевые слова, автора, краткое описание. Как правило, содержимое мета-тэгов используется в служебных целях, например, роботами поисковых систем, индексирующих сайт. Мета-тэг задается внутри тэга <head>.
Доменное имя (домен) | Одно из полей DNS таблицы (domain name service), содержащее в себе строго структурированное имя интернет сайта, заданное по определённым правилам. Основная задача DNS таблицы - это ассоциация доменных имен с IP адресами сайтов. Пример доменного имени: 1c-bitrix.ru
IP адрес | Это "имя" компьютера в сети, заданное по правилам протоколов TCP/IP. IP адрес состоит из четырех октетов, часть из которых идентифицирует подсеть, в которой находится компьютер, а часть - непосредственно этот компьютер в рамках соответствующей подсети. Пример IP адреса: 198.63.210.79.
Хост | В применении к функциям главного модуля, хост - это доменное имя или IP адрес для обращения к тому или иному сайту.
Сессия | Под термином понимается сессия PHP. Сессия может открываться в момент захода на сайт и закрывается при закрытии окна браузера. Также новая сессия открывается при авторизации пользователя, если закончить сеанс авторизации (разлогиниться) - сессия закрывается. Синонимом термина сессия можно считать один "заход на сайт".
Время в Unix-формате | Количество секунд, прошедшее с 1 января 1970 года, с точностью до микросекунды. На сегодняшний день, время в Unix-формате может фиксироваться только до 2038 года.
Права в Unix системах В Unix-подобных операционных системах поддерживаются три вида прав - чтение, запись и выполнение, которые присваиваются каждому файлу или директории. Права эти повторяются три раза: для владельца файла, для группы пользователей, и для всех остальных пользователей. Как правило, права указываются в числовом формате:
  • 4 - чтение;
  • 2 - запись;
  • 1 - выполнение.

Сумма этих чисел дает окончательный набор прав, например, 6 - это чтение и запись, но без выполнения, 7 - все права, 5 - чтение и выполнение.

Таким образом, например, право 764 будет означать: 7 - все права для владельца файла, 6 - чтение и запись для группы пользователей, к которой принадлежит владелец файла и 4 - чтение для всех остальных пользователей.

В PHP все права задаются в виде восьмеричных чисел, поэтому их надо задавать с обязательным указанием префикса - 0. Пример: 0755.

Пролог

В общем случае, под данным термином понимается верхняя левая часть страницы.

Для публичной части, пролог соответствующего шаблона сайта хранится в файле /bitrix/templates/ID шаблона сайта/header.php.

Для административной части - пролог хранится в файле /bitrix/modules/main/interface/prolog_main_admin.php.

В свою очередь пролог может быть разделен на служебную и визуальную части. В служебной части подключаются все необходимые классы, создаётся соединения с базой, создаются ряд служебных экземпляров объектов, таких как $USER, $APPLICATION и т.д. В визуальной части выводится верхняя левая часть страницы.

Если в публичной части необходимо подключить неразделенный пролог, то используем следующий код:

require($_SERVER["DOCUMENT_ROOT"]."/bitrix/header.php");

Если по тем или иным причинам необходимо разделить пролог на служебную (prolog_before.php) и визуальную (prolog_after.php) части, то используем следующий код:

require($_SERVER["DOCUMENT_ROOT"].
"/bitrix/modules/main/include/prolog_before.php");
...
require($_SERVER["DOCUMENT_ROOT"].
"/bitrix/modules/main/include/prolog_after.php");
Эпилог

В общем случае под данным термином понимается нижняя правая часть страницы.

Для публичной части, эпилог соответствующего шаблона сайта хранится в файле /bitrix/templates/ID шаблона сайта/footer.php.

Для административной части - эпилог хранится в файле /bitrix/modules/main/interface/epilog_main_admin.php.

В свою очередь эпилог может быть разделен на служебную и визуальную части. В служебной части производится ряд таких действий, как: отсылка почтовых сообщений, отработка обработчиков события OnAfterEpilog и др. В визуальной части выводится нижняя правая часть страницы.

Если в публичной части необходимо подключить неразделенный эпилог, то используем следующий код:

require($_SERVER["DOCUMENT_ROOT"]."/bitrix/footer.php");

Если по тем или иным причинам необходимо разделить эпилог на визуальную (epilog_before.php) и служебную (epilog_after.php) части, то используем следующие коды:

require($_SERVER["DOCUMENT_ROOT"].
"/bitrix/modules/main/include/epilog_before.php");
...
require($_SERVER["DOCUMENT_ROOT"].
"/bitrix/modules/main/include/epilog_after.php");

Примечание: Обратите внимание, что в случае пролога файл *_before.php это служебная часть, а в случае эпилога *_before.php это визуальная часть. Такое отличие возникает потому, что пролог перед телом страницы, а эпилог - после.

Тело страницы | Тело страницы это часть PHP/HTML кода, расположенного в скрипте между подключениями пролога и эпилога. Тело страницы не является частью шаблона сайта и представляет из себя индивидуальное содержимое публичной либо административной страницы.
Шаблон страницы Это файл, хранящийся в одном из каталогов:
  • /bitrix/templates/ID шаблона сайта/page_templates/
  • /bitrix/templates/.default/page_templates/
Данный файл представляет из себя заготовку публичной страницы. Как правило, используется при создании новой страницы в модуле Управление структурой. Для задания порядка сортировки шаблонов страниц используется файл .content.php находящийся в одном из вышеуказанных каталогов.
Сабмит | Отправка данных HTML формы на сервер.
HTML-безопасный вид Как правило данный термин применяют к тексту, в котором произведены следующие замены:
Исходное | Результат
< | &lt;
> | &gt;
" | &quot;
& | &amp;

Подобные замены позволяют выводить текст внутри HTML кода, не опасаясь, что он будет интерпретирован браузером как часть этого HTML кода.
Связывание переменных | В применении к SQL-запросам для Oracle версии, под данным термином подразумевается связывание имен переменных (либо полей таблицы) с их значениями. Как правило, подобная технология используется для полей типа BLOB, CLOB, LONG и т.п. предназначенных для хранения больших объемов данных.
Дамп В применении к базе данных это - выгрузка содержимого и, возможно, структуры таблиц в файл в определённом формате, для их возможной дальнейшей загрузки обратно в данную, либо любую другую БД. Для каждой базы данных существуют свои утилиты, позволяющие сделать дамп, например для MySQL утилита mysqldump позволяет выгрузить в формате обычных SQL запросов, для Oracle утилита exp позволяет выгрузить в своем внутреннем формате.
В применении к переменным, дамп подразумевает отображение структуры и содержимого переменной в текстовом виде.
cron (крон) | В Unix-подобных операционных системах утилита cron позволяет организовать запуск скриптов по четко указанному расписанию.
Буферизация | Режим, при котором весь исходящий поток данных из PHP скрипта (например, HTML код) запоминается предварительно в памяти и не отдается браузеру пользователя. Буферизацию в PHP можно включить с помощью функции ob_start. В дальнейшем её можно отключить, например с использованием функции ob_end_flush, при этом все накопленные данные будут отосланы браузеру. Режим позволяет произвольно манипулировать исходящим потоком данных, на этом принципе основана технология отложенных функций.
Постоянное соединение (persistent) | При создании соединения с базой, в памяти создаётся дескриптор данного соединения. Если соединение обычное, то после отработки скрипта этот дескриптор удаляется, если соединение постоянное, он остается и может быть использован другими процессами при необходимости. Достоинством постоянного соединения является то, что времени на его работу требуется меньше. Недостаток - количество открытых постоянных соединений ограничивается в настройках базы данных и при превышении этого лимита посетитель не сможет зайти на сайт пока не освободятся новые соединения.
Accept-Language | Набор языков, установленных в браузере посетителя сайта. К примеру, для MS Internet Explorer их можно выставить в меню Сервис > Свойства обозревателя > Общие > Языки. Для Mozilla Firefox: Меню > Настройки > Содержимое > Языки.
Кастомизация | Изменение логики работы компонента или шаблона компонента под частные задачи.
API (SDK) | Каждый модуль системы содержит набор высокоуровневых функций для выборки данных в публичном разделе сайта и набор классов с низкоуровневыми методами для более специализированной работы с данными модуля. Подробная информация по API каждого модуля представлена в документации для разработчиков.
Экземпляр программы | Копия какого-либо продукта «1C-Битрикс», включающая в себя исходный текст продукта и только одну копию структуры и таблиц базы данных, входящих в состав продукта, а также любую документацию по использованию продукта.
Портал | Один набор файлов, хранящихся в каталоге /bitrix/modules/, и одна копия базы. Портал включает в себя один или более сайтов. Синонимом данного термина может служить: «экземпляр продукта», «одна инсталляция системы», «одна копия системы».


Схема работы продукта
6 / 694

Визуальное представление работы продукта

Ознакомьтесь с общей схемой работы продукта.
Сайт 1 ... Сайт 3 ... Сайт N
Шаблон 1 Шаблон 2 Шаблон 3 ... Шаблон N
Многосайтовый диспетчер
Журналирование и статистика
Система авторизации и разграничения доступа
Битрикс Framework
Компоненты, написанные на API
Административный раздел Индивидуальная бизнес-логика Компоненты пользователей
API
Модули
Главный модуль | Управл. структурой | Интернет-магазин
Рекламные баннеры | Информ.блоки | Веб-формы
Документооборот | Торговый каталог | Почта и т.д.
Валюты | Статистика | Свои модули
Интерфейс к БД Интерфейс работы
c внешними источниками
Базы данных

MySQL 		XML, Excel, 1C ,
Платежные системы ,
Складские системы,
ERP и другие 		Дисковая подсистема


Таблица разделения прав администраторов
7 / 694

В "Битрикс24 в коробке" возможны две роли администраторов. В таблице показано разделение прав по администрированию каждым из администраторов. Компетенция Администраторов системы включает в себя все возможности Администратора портала и дополнительные возможности.

Примечание. Достаточно часто права Администратора КП расширяются от установленных по умолчанию. Администратор системы может использовать эту таблицу как ориентир в понимании какие права необходимо дать Администратору КП, для решения поставленных перед ним задач.

Таблица разделения прав
Функционал | Администратор КП | Администратор системы
Установка продукта | Весь комплекс функций по установке, первичной настройке, переносу системы.
Администрирование системы
Удаление демонстрационных данных | Через специальный мастер очистки данных.
Шаблон дизайна | Назначение шаблона. | Создание шаблона.
Страницы и разделы
  • изменение контента страниц;
  • настройка параметров компонентов;
  • просмотр статистики посещения страниц.
  • создание страниц и разделов;
  • изменение их свойств;
  • работа с меню;
  • работа со структурой портала;
  • управление правами доступа к страницам и разделам;
  • загрузка файлов;
Визуальный редактор
  • разрешение на использование редактора в некоторых модулях (Веб-формы, Опросы, Подписки, Wiki, Блоги, Документооборот).
  • общее подключение;
  • общая настройка;
  • ограничение списка доступных компонентов;
  • сокрытие исходного кода.
Управление интерфейсом
  • добавление языков интерфейса;
  • загрузка языковых файлов.
Работа с инфоблоками
  • редактирование настроек информационных блоков;
  • настройка форм инфоблоков.
  • импорт и экспорт данных в/из информационные блоки.
  • создание и управление типами информационных блоков и самими информационными блоками;
Управление пользователями
  • работа с пользователями.
  • задание условий регистрации новых пользователей;
  • создание и настройка групп пользователей;
  • импорт пользователей.
Управление доступом Управление доступом к некоторым модулям.
  • добавление уровня доступа
  • управление доступом к модулям;
  • управление доступом к файлам и папкам;
Работа с инструментами
  • работа с агентами;
  • операции по проверке сайта.
  • просмотр журнала событий;
  • оптимизация базы данных;
  • проверка базы данных;
  • работа с командной PHP-строкой;
  • выполнение SQL запросов к базе данных;
  • просмотр настроек PHP.
Прочие настройки | Настройка кеширования.
Настройка модулей
Главный модуль
Ядро продукта с технологией "SiteUpdate". 		Просмотр настроек. Настройка модуля.
AD/LDAP интеграция
Модуль для работы с Active Directory и LDAP.
  • настройка модуля;
  • регистрация сервера;
  • настройка NTLM авторизации.
CRM
Модуль дает возможность создания CRM
  • установка и удаление модуля;
  • настройка модуля.
DAV
Модуль поддержки доступа к объектам и коллекциям 		Настройка модуля.
Push and Pull
Модуль позволяет организовать транспорт мгновенных нотификаций и сообщений клиентам. 		Настройка параметров модуля.
Wiki
Модуль дает возможность ведения wiki-страниц на сайте. 		Настройка модуля.
XMPP сервер
Модуль позволяет использовать Jabber-клиенты для общения внутри корпоративного портала
  • настройка сервера
  • управление сервером;
Библиотека документов
  • создание файловых хранилищ;
  • создание библиотек документов;
  • проверка работы сервера WebDav.
Бизнес-процессы
Модуль для создания и работы с бизнес-процессами. 		Настройка инфоблоков на работу в режиме бизнес-процессов. Создание и настройка бизнес-процессов.
Блоги
Модуль дает возможность ведения блогов на сайте.
  • настройка модуля;
  • управление блогами.
 Создание публичного раздела.
Веб-аналитика
Модуль сбора и отображения статистики сайта. 		Модуль Веб-аналитика в "Битрикс24 в коробке" не используется. Модуль можно удалить для снижения нагрузки на систему.
Веб-кластер
Модуль поддержки веб-кластера. 		Модуль Веб-кластер в "Битрикс24 в коробке" не используется. Модуль можно удалить для снижения нагрузки на систему.
Веб-мессенджер
Модуль мгновенных сообщений и уведомлений. 		Настройка модуля.
Веб-сервисы
Модуль позволяющий организовать систему веб-сервисов и SOAP. 		Для создания собственных приложений изучите руководство Создание Windows-приложения на основе модуля Веб-сервисы Если модуль не используется, для снижения нагрузки его можно удалить.
Веб-формы
Модуль организует работу с произвольными веб-формами, позволяет хранить и фильтровать данные заполненных форм.
  • настройка модуля;
  • управление (создание, изменение) веб-формами в упрощенном и расширенном режимах.
  • создание шаблона веб-формы;
  • публикация веб-форм.
ВидеоПорт
Модуль предоставляет возможность использовать видеоконференции компании ВидеоПорт. 		Модуль настроек не имеет.
Видеоконференции
Модуль предоставляет возможность проведения видеоконференций. 		Настройка комплексных компонентов Социальной сети.
  • установка модуля;
  • настройка модуля Видеоконференции;
  • установка TrueConf Server.
Дизайнер бизнес-процессов
Модуль для проектирования, создания и изменения бизнес-процессов. 		Модуль настроек не имеет.
Документооборот
Модуль позволяющий организовать поэтапную обработку документов сайта.
  • настройка модуля;
  • создание статусов;
  • просмотр документов в статусах и истории;
  • задание документооборота для информационных блоков.
Задание прав доступа к файлам и папкам для групп пользователей, участвующих в документообороте.
Задачи
Модуль управления задачами 		Установка и настройка модуля.
Импорт данных из внешних источников.
Модуль содержит в себе инструменты для импорта данных в систему из внешних источников. 		Публикация в Живую ленту.
Интранет
Интранет - корпоративный портал.
  • настройка компонентов;
  • настройка инфоблоков;
  • добавление элементов.
  • создание публичного интерфейса;
  • создание новых информационных блоков для календарей;
  • настройка модуля.
Информационные блоки
Модуль работы с информационными блоками позволяет управлять и каталогизировать информацию различного характера - новости, вакансии, список продуктов.
  • редактирование настроек информационных блоков;
  • настройка форм инфоблоков.
  • импорт и экспорт данных в/из информационные блоки.
  • создание и управление типами информационных блоков и самими информационными блоками;
Календарь событий
Модуль для просмотра и управления календарями и событиями.
  • Установка модуля;
  • настройка модуля;
  • настройка типов календарей;
  • настройки доступа.
Компрессия
Модуль компрессирующий страницы сайта для ускорения их загрузки. 		Настройки модуля отсутствуют.
Контроллер
Удаленное управление сайтами 		Крайне редко используется в рамках "Битрикс24 в коробке". При необходимости использовать обратитесь к Пользовательской документации. Модуль можно удалить для снижения нагрузки на систему.
Конструктор отчетов
Создание и генерация отчетов 		Модуль настроек не имеет.
Менеджер идей
Модуль для создания сервиса идей.
  • настройка категорий менеджера идей;
  • настройка параметров компонента идей.
 Создание публичного интерфейса.
Монитор производительности
Модуль мониторинга параметров производительности сайта. 		Оценка настройки серверного оборудования и программного обеспечения.
Облако 1С-Битрикс
Модуль облачного резервного копирования. 		Создание резервных копий.
Облачные хранилища
Модуль поддержки облачных хранилищ файлов.
  • настройка модуля
  • просмотр и создание подключений к облачным хранилищам.
  • просмотр содержимого контейнеров облачных хранилищ.
Обучение
Модуль дистанционного обучения 		Редактирование, удаление, создание, привязывание и отвязывание курсов, глав и уроков. Весь функционал по работе с модулем.
Опросы, голосования
Модуль позволяющий организовать систему опросов и голосований посетителей сайта. 		Настройка модуля и управление опросами Размещение компонентов опросов в публичной части.
Перевод
Модуль перевода языковых файлов. 		Крайне редко используется в рамках "Битрикс24 в коробке". При необходимости использовать обратитесь к Пользовательской документации. Модуль можно удалить для снижения нагрузки на систему.
Планерки и собрания
Модуль для организации и проведения планерок и собраний. 		Модуль настроек не имеет.
Подписка, рассылки
Модуль для организации списков рассылки. 		Управление рассылками. Редактирование и создание шаблонов подписки.
Поиск
Поисковый модуль, осуществляющий индексирование и поиск на сайте.
  • Настройка информационных блоков для корректной работы модуля поиска.
  • разрешение на индексацию информационного блока.
  • настройка модуля;
  • работа с правилами сортировки;
  • настройки индексации;
  • просмотр статистики поиска;
Почта
Почтовый модуль, для получения почты, фильтрации писем и выполнения заданных действий.
  • настройка модуля;
  • создание учетных записей;
  • создание почтовых правил;
  • просмотр журнала работы;
  • управление полученными сообщениями.
Проактивная защита
Модуль проактивной защиты сайта. 		Настройка проактивной защиты, контроль за ее работой.
Реклама, баннеры
Модуль управления рекламой на сайте. 		Модуль Реклама в "Битрикс24 в коробке" практически не используется. При необходимости смотрите курс Администрирование. Модули. Модуль можно удалить для снижения нагрузки на систему.
Техподдержка
Модуль позволяющий организовать на сайте систему обращений посетителей к группе техподдержки. 		Просмотр своих обращений через административную часть. Все административные функции.

Часть административного функционала, связанная непосредственно с работой над обращениями, так же доступна пользователям группы Техподдержка.
Социальная сеть
Модуль дает возможность создания социальной сети на сайте. 		Все функции по управлению работой модуля. Создание страниц для размещения компонентов.
Социальные сервисы
Модуль для интеграции с внешними социальными сетями и сервисами. 		Настройка модуля.
Фотогалерея 2.0
Модуль позволяет организовать на сайте фотогалереи с массовой загрузкой изображений.
  • задание доступа к фотогалереям через задание прав доступа к инфоблокам фотогалерей;
  • настройка Социальной сети на использование фотогалерей;
 Размещение фотогалерей в публичном разделе.
Форум
Модуль для создания форумов. 		Управление форумами. Настройка модуля.
Экстранет
Модуль, поддерживающий работу сотрудников компании с внешними партнерами.
  • создание тем рабочих групп;
  • создание групп;
  • настройка гаджетов.
  • установка и настройка сайта экстранета;
  • настройка модуля;
  • управление доступом к сайту экстранета;
  • управление публичными сотрудниками.
Универсальные списки
Модуль для организации работы с различной информацией из публичной части сайта.
  • создание списков;
  • настройка списков.
 Установка и настройка модуля.
Управление структурой
Модуль для управления информационным наполнением и структурой сайта (ов), меню и правами доступа. 		Настройки параметров модуля, Визуального редактора, Медиабиблиотеки, Карт.
Учет рабочего времени
Модуль учета и контроля рабочего времени
  • настройка параметров Рабочего дня для всей компании;
  • настройка параметров субординации и редактирования рабочего дня.


Основы администрирования
8 / 694

Информация, приведенная в главе, позволяет понять основные принципы администрирования проекта, созданного на базе продукта «Битрикс24 в коробке».

Эту информацию полезно знать обоим Администраторам, не смотря на то, что большая часть функционала системы, описанная здесь, недоступна для Администратора КП.


Мастер очистки данных
9 / 694

Удаляем демо-данные

После изучения демоверсии Битрикс24 в коробке, перед наполнением данными рабочего проекта необходимо удалить демо-данные. Удалить их возможно вручную или специальным инструментом: Мастер очистки.

Использование мастера - предпочтительнее, так как он учитывает все взаимосвязи внутри продукта, которые бывает сложно учесть при ручном удалении демоданных. Однако, мастер удаляет все данные, в том числе и те, которые вы добавили во время изучения демоверсии. Если добавленная информация для вас не актуальна, то воспользуйтесь мастером. Если информация важна, то очищать демонстрационные данные придётся вручную.

Запуск мастера

Запуск мастера производится:

  • с помощью команды Мастер очистки на Панели управления;

  • через административный раздел на странице Настройки > Настройки продукта > Список мастеров. Найдите в списке Мастер очистки корпоративного портала (bitrix:portal_clear) и дважды кликните на него (либо выберите вариант Установить в меню действий).

На первом шаге система предупредит вас о том, какие данные будут удалены:

Нажмите на рисунок, чтобы увеличить

Если вас все устраивает, то нажмите кнопку Далее. На втором шаге система самостоятельно удалит все демо-данные.

Третий шаг - уведомление об окончании процесса, ссылка на учебный курс и ссылка возвращения на портал.

Внимание! В результате работы Мастера очистки в продукте останутся демо-данные в некоторых разделах, которые понадобится удалить вручную, и общая структура портала.

Следующая информация останется после очистки:

  • раздел Компания;
  • группы и папки групп на диске;
  • сообщения живой ленты;
  • товары и услуги (раздел CRM);
  • информация в разделе Сервисы ;
  • сегменты (раздел CRM-маркетинг);
  • все информационные блоки (в административном разделе).

Как очистить раздел Компания

Для удаления демо-информации из разделов Компания и Компания > О компании выполните следующие действия:

  1. Зайдите в административный раздел;
  2. Демо-данные хранятся в папках:
    • страница Компания - папка /about;
    • страница Компания > О компании - папка /about/company.

    Через структуру файлы и папки перейдите к нужной папке.

    Каждая страница раздела - это файл. Например, страница Миссия и стратегия это файл mission.php;

  3. Для всех файлов в папке: откройте файл в режиме Редактировать как HTML и удалите код PHP и остальные данные, если они есть;
  4. Теперь приступайте к наполнению страниц своими данными.

Примечание: если у Вас настроено отображение административной панели , то для удаления вывода демо-информации воспользуйтесь кнопкой Редактировать страницу. Затем удалите код PHP.

Дополнительно, при необходимости, удалите демо-изображения из папки /images/ru/company/about.


Административный раздел
10 / 694
Административный раздел на всех сайтах под управлением "1С-Битрикс: Управление сайтом" одинаковый. Изучив его один раз, Контент-менеджер сможет работать с любым сайтом.


Административный раздел
11 / 694

Изучите основные элементы интерфейса Административного раздела системы, с помощью которых выполняется полное управление содержанием и настройками сайта. Публичная часть у каждого сайта - своя. А вот Административный раздел на всех сайтах под управлением "1С-Битрикс: Управление сайтом" одинаковый. Изучив его один раз, Контент-менеджер сможет работать с любым сайтом.

Как попасть в Административный раздел

Для перехода в Административный раздел служит закладка [image], расположенная на Панели управления в Публичном разделе сайта.

Либо сразу авторизуйтесь в административной части системы: к адресу сайта допишите: /bitrix/ и нажмите кнопку Ввод.

Примечание: Для коробочной версии "Битрикс24" переход в административный раздел возможен только через дописывание /bitrix/ в адресе сайта.

Заключение

Административный раздел - часть "1С-Битрикс: Управление сайтом", где производится управление модулями системы, структурой сайта, его содержанием, посетителями и другими составляющими сайта. Недоступен для просмотра обычным посетителям сайта. Список возможностей Контент-менеджера в этом разделе зависит от того, какие права дал ему Администратор.


Логика интерфейса административного раздела
12 / 694

Как ориентироваться в административной части

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Текстовое содержание (нажмите на "плюсик")

Интерфейс административного раздела системы Bitrix Framework логически разграничен на области, обеспечивающие доступ к функциональным возможностям системы.

Интерфейс содержит следующие области:

  1. Административная панель ;
  2. Административное меню ;
  3. Меню функций ;
  4. Рабочая область .

Заключение

Интерфейс системы построен по иерархическому принципу: вышестоящие области интерфейса переключают зависимые области в тот или иной режим работы. Это позволяет скрыть ненужный в данный момент функционал системы и вынести на первый план требуемые функции. Такая организация интерфейса обеспечивает его наглядность и неперегруженность.


Административная панель управления
13 / 694

Команды общего назначения

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Текстовое содержание (нажмите на "плюсик")

Нажмите на рисунок, чтобы увеличить

Функционал панели:

Команды Панели управления
 | Переход в публичный раздел .
 | Переход в административный раздел .
 | Центр уведомлений
 | Открывает форму настроек активного модуля либо позволяет перейти к настройкам интерфейса административной части. Например, если открыт раздел Управление структурой, эта кнопка открывает форму настроек модуля Управление структурой.
 | Поиск в Панели управления по пунктам меню и настройкам модулей.
 | Переход к изменению профиля текущего пользователя в форме административного раздела. Ссылка Выйти завершает авторизованный сеанс в административном разделе.
 | Позволяет переключиться на другой (установленный в системе) язык административного интерфейса.
 | Кнопка вызывает окно настроек горячих клавиш и позволяет их настроить для удобства текущей работы.
 | Позволяет закрепить административную панель управления. Эта кнопка расположена на правом конце панели.
 | Открывает Контекстную справку.


Административное меню
14 / 694

Первый уровень иерархии: выбираем логический блок функционала

Весь большой и разнообразный функционал "1С-Битрикс: Управление сайтом" для удобства работы с ним разбит в Административном меню на логические блоки. В зависимости от того, установлены ли те или иные модули, состав административного меню может различаться: какие-то блоки могут отсутствовать. Например, в редакциях Старт, Стандарт будет отсутствовать блок Интернет-магазин.

Рабочий стол - инструмент для организации удобного управления работой сайта с помощью произвольно размещаемых гаджетов.

Контент содержит инструменты для управления информационными блоками, структурой сайта (т.е. папками и файлами), ресурсами медиабиблиотеки, а также настройки документооборота и управления документами.

Сайты инструменты создания и управления сайтами.

Маркетинг содержит маркетинговые инструменты для работы магазина, проведения рассылок, баннерной рекламы и так далее.

Магазин позволяет осуществить продажу товаров и услуг с сайта.

Клиенты служит для интеграций сайта с порталами Битрикс24 и организации каналов связи с ними.

Сервисы наиболее зависим от наличия в системе тех или иных модулей. Полный набор функций позволяет управлять опросами, веб-формами, рекламой, рассылками, техподдержкой, форумами и почтовой системой.

Аналитика полностью посвящен функциям сбора, обработки и отображения статистики по сайтам. Этот раздел присутствует, только если установлен модуль Веб-аналитика.

Marketplace позволяет обновлять систему, устанавливать и обновлять партнерские модули и решения.

Переход в Битрикс24 открывает Мастер установки Битрикс24. Позволяет перейти на продукт «1С-Битрикс24: Интернет-магазин+ CRM», объединяющий все возможности «1С-Битрикс: Управление сайтом» и Битрикс24.
Этот блок присутствует в «1С-Битрикс: Управление сайтом» с версии v20.0.0.

Настройки позволяет управлять пользователями, валютами интернет-магазина, шаблонами, а также настраивать прочие параметры сайта и системы.

Выбрав любой из этих блоков вы измените вид Меню функций.


Меню функций
15 / 694

Второй уровень иерархии: выбираем конкретный функционал

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Текстовое содержание (нажмите на "плюсик")

Содержимое Меню функций зависит от того, какой блок выбран в Административном меню . Например, выбрав Контент, вы получите такой вид панели:

Выбирая пункты дерева-меню, переходим непосредственно к тем функциям, которым они соответствуют. При этом Основная рабочая область будет отображать интерфейс для работы именно с этими функциями.

В случае необходимости Административное меню и Меню функций сворачиваются/разворачиваются с помощью соответствующих стрелок. Стрелки появляются при наведении указателя мыши к черте, разделяющей Меню функций и Рабочую область. С помощью кнопки , можно свернуть Меню функций, с помощью курсора придать ему нужную ширину.


Списки элементов
16 / 694
Что бы вы ни захотели посмотреть в административном разделе «1С-Битрикс: Управление сайтом»: баннеры, товары, новости и так далее, вы всё увидите в виде Списка элементов.


Списки элементов
17 / 694

Универсальный способ вывода списка любых элементов

Что бы вы ни захотели посмотреть в административном разделе «1С-Битрикс: Управление сайтом»: баннеры, товары, новости и так далее, вы всё увидите в виде Списка элементов. В них отображена вся информация об элементах. Например, выбрав пункт Баннеры в разделе Маркетинг, пользователь получает информацию об имеющихся в системе баннерах:

Нажмите на рисунок, чтобы увеличить

На странице со списком элементов обычно выводится фильтр, контекстная панель, сам список элементов и панель действий под списком. Далее рассмотрим составные части списка элементов.

Примечание: В настоящее время происходит переход на новый, более удобный и современный интерфейс. Часть разделов уже отображается в новом интерфейсе, поэтому в следующих уроках вы сможете ознакомиться с работой сразу в двух интерфейсах.

Нажмите на рисунок, чтобы увеличить


Фильтр (старый интерфейс)
18 / 694

Найти иголку в стоге сена

Найти нужный баннер, товар, новость или что-то ещё среди большого количества однотипных элементов поможет удобный настраиваемый фильтр.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Что есть в фильтре

Типичный фильтр выглядит так:

1 Область закладок. Здесь появляются сохранённые вами конфигурации фильтра. Пример создания закладки - ниже.
2 Кнопка сворачивания фильтра. Постоянно раскрытый фильтр не всегда нужен. Его можно свернуть для освобождения места на экране монитора.
3 Поля параметров поиска с кнопкой подсказки по условиям поиска.
4 Чекбокс включения точного поиска (есть не во всех фильтрах). При использовании этого поля фильтр будет искать только точное совпадение введённого значения.
5 Кнопка сохранения создаваемых закладок.
6 Включение дополнительных параметров поиска. По умолчанию фильтр открывается с единственным полем для поиска. При необходимости организовать сложный поиск просто добавьте нужные поля. Система запомнит это состояние фильтра для вас. И когда вы будете открывать страницу в следующий раз, эти поля уже будут в фильтре. если вы удалите и замените одни поля на другие, то система запомнит новый состав фильтра.

Сохраните часто используемую конфигурацию фильтра, пригодится

При постоянном использовании нескольких вариантов полей в фильтре, есть смысл их сохранить как закладки фильтра. Например, на странице Сервисы > Опросы > Список опросов необходимо часто выбирать все активные на данный момент опросы. В фильтре добавим поле Активность и удалим поле Название. С помощью кнопки [image] создадим новый фильтр:

Фильтр-закладку можно сделать доступным только для себя либо доступным для всех. Число закладок неограничено.

Активный фильтр меняет свой цвет. Если фильтр свёрнут, то меняет свой цвет действующая закладка:

Важно помнить

При поиске в поля можно вводить неполные параметры. Например, если ввести "справ", то поиск выберет все элементы, содержащие в названии эту часть слова: Справка, Справочная информация, Исправить дело и так далее.

Параметры, по которым фильтр может отображать данные, будут различными для разных форм. Различно и их число. По умолчанию показывается всегда одно поле: Имя (или аналог этого понятия).

Элементов в таблице бывает очень много и даже после фильтрации. Для удобства просмотра предусмотрена возможность вывода на странице разного количества элементов: от 20 по умолчанию до всех сразу. Выбор количества выводимых элементов, а также кнопки для перемещения по страницам списка, размещен между контекстной панелью и самой таблицей.

Заключение

Фильтр - инструмент для отбора информации, отображаемой в списках элементов. Указав критерии поиска в фильтре, можно найти и показать не все, а только требуемые данные.


Фильтр (новый интерфейс)
19 / 694

Облегчаем поиск

Найти среди большого количества однотипных элементов нужный товар, новость, баннер — да все, что угодно! — поможет удобный настраиваемый инструмент Фильтр+поиск.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Как выглядит этот инструмент

Визуально этот инструмент представляет собой строку поиска.

Нажмите на рисунок, чтобы увеличить

При клике по строке поиска раскрывается расширенный режим поиска с областью настройки фильтра. По умолчанию фильтр имеет одно поле поиска (поле "Название").

Настройка и сохранение фильтра

Однако вы можете добавить дополнительные параметры поиска. Выбирайте те параметры, по которым вам удобнее искать нужный элемент, с помощью кнопки Добавить поле. Система запомнит это состояние фильтра для вас. И когда вы будете открывать страницу в следующий раз, эти поля уже будут в фильтре. Если вы удалите и замените одни поля на другие, то система запомнит новый состав фильтра.

При постоянном использовании нескольких вариантов полей в фильтре есть смысл их сохранить как составные фильтры 1. После сохранения эти фильтры будут отображаться слева от полей настройки фильтра 2, а выбранный фильтр будет выводиться в поисковой строке 3.

У созданного фильтра всегда можно изменить параметры и состав полей, нажав на иконку шестеренки в нижнем левом углу. При этом дополнительно можно выполнить следующие действия:

  • назначить выбранный фильтр фильтром по умолчанию;
  • изменить название фильтра;
  • удалить фильтр.

Если вы хотите сохраненный фильтр сделать доступным для всех, то, в режиме редактирования фильтра, установите галочку в поле Для всех . При попытке сохранения фильтра, появится предупреждение , в котором требуется нажать Сохранить для всех.

Важно помнить

При поиске в поля можно вводить неполные параметры. Например, если ввести "справ", то поиск выберет все элементы, содержащие в названии эту часть слова: Справка, Справочная информация, Исправить дело и так далее.

Параметры, по которым фильтр может отображать данные, будут различными для разных форм. Различно и их число. По умолчанию показывается всегда одно поле: Название (или аналог этого понятия).

Элементов в таблице бывает очень много даже после фильтрации. Для удобства просмотра предусмотрена возможность вывода на странице разного количества элементов: от 5 по умолчанию до 500. Выбор количества выводимых элементов, а также кнопки для перемещения по страницам списка, расположены в нижнем правом углу.

Заключение

Фильтр - инструмент для отбора информации, отображаемой в списках элементов. Указав критерии поиска в фильтре, можно найти и показать не все, а только требуемые данные.


Список элементов (старый интерфейс)
20 / 694

Как устроен список элементов

Список элементов - основной способ представления информации в системе. Он используется везде: список баннеров, список элементов инфоблока, список страниц сайта и так далее. Вне зависимости от того, что список отображает он имеет общие составные части.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Структура списка элементов

Нажмите на рисунок, чтобы увеличить

1 - Контекстная панель. Состав панели может сильно различаться в зависимости от списка элементов.
2 - Колонка флажков. Позволяет выбрать элементы, над которыми нужно совершить какие-то действия.
3 - Меню действий. Список команд, которые можно выполнить над одним элементом.
4 - Собственно список элементов.
5 - Панель действий. Действия, которые можно совершить над выбранными в Колонке флажков элементами.
6 - Постраничная навигация.
7 - Окно выбора числа элементов на одной странице списка.

Как работать со Списком элементов

Список элементов позволяет не только просмотреть все или быстро найти нужный элемент. Он позволяет и выполнять некоторые другие действия: активировать/деактивировать элементы, переносить их в другие разделы, менять статус элемента в Документообороте и многое другое. Возможности действий зависят от того, список каких элементов в данный момент просматривается.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

В Меню действий отображается то, что можно совершить над одним элементом. Набор команд в этом меню так же зависит от самого списка элементов .

В Панели действий (при выполнении действий над выбранной и отмеченной группой элементов)доступны следующие действия:

  • Удаление.
  • Изменение наиболее важных и часто используемых свойств одновременно у всех выбранных элементов без переключения в форму редактирования. Рекомендуем пользоваться этими возможностями только для групповых операций небольших по объему параметров типа Сортировки или Названия. В крайнем случае – анонсов. Редактирование объемных текстов новостей или статей таким способом неудобно, лучше пользоваться формой редактирования.
  • Выполнение одного из возможных действий . Список действий различен для разных таблиц элементов.

Для группового выбора есть несколько дополнительных инструментов. Это флажок Для всех и заглавный флажок в Колонке флажков. Разница между ними в том, что первый отмечает вообще все элементы списка. А второй отмечает только элементы на открытой странице.

Как просмотреть все элементы информационного блока

По умолчанию в списке отображается иерархическая структура: сначала разделы, потом элементы. Если есть потребность просматривать все элементы единым списком вне зависимости от разделов, то в настройках модуля Информационные блоки надо снять флажок с поля Совместный просмотр разделов и элементов . Если у вас нет прав на это действие, обратитесь к администратору сайта.

Быстрое редактирование нескольких элементов

Отметьте элементы , которые нужно отредактировать, и на Панели групповых действий нажмите кнопку Быстрое редактирование , после чего станет возможно редактирование прямо на данной странице:

Внесите нужные изменения и сохраните их. Всё, дело сделано!

Пример быстрого редактирования группы элементов

Необходимо отредактировать список новостей из новостного инфоблока:

  • изменить порядок их вывода на странице,
  • поменять название
  • одну новость сделать неактивной на определенный промежуток времени
  • одну новость удалить

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».


Список элементов (новый интерфейс)
21 / 694

Список элементов и работа с ним

Весь контент, который вы загружаете на сайт, состоит из элементов. В зависимости от рода контента (это могут быть страницы сайта, элементы инфоблока, баннеры и т.д.) формируются разные списки, но для удобства устроены они все по одному принципу.

  • Структура списка элементов
  • Настройка отображаемых полей списка
  • Просмотр всех элементов информационного блока
  • Быстрое редактирование нескольких элементов

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Структура списка элементов

Нажмите на рисунок, чтобы увеличить

1 - Панель фильтра и поиска.
2 - Контекстная панель (т.е. панель действий, которые можно совершить со списком, например, добавить новый элемент или выгрузить список в Excel). Состав панели может сильно различаться в зависимости от списка элементов.
3 - Колонка флажков. Позволяет выбрать элементы, над которыми нужно совершить какие-то действия.
4 - Меню действий. Список команд , которые можно выполнить над одним элементом.
5 - Собственно список элементов.
6 - Постраничная навигация.
7 - Окно выбора числа элементов на одной странице списка.
8 - Панель групповых действий. Действия, которые можно совершить над выбранными в Колонке флажков элементами.

Настройка отображаемых полей списка

Чтобы выбрать среди всего многообразия полей те, которые нужны именно вам, нажмите на значок шестеренки над колонкой меню действий.

В открывшемся окне выберете нужные поля и нажмите Применить:

Нажмите на рисунок, чтобы увеличить

Чтобы быстро поменять расположение колонок на экране, перетяните их в требуемые места, ухватив левой кнопкой мыши.

Просмотр всех элементов информационного блока

По умолчанию в списке отображается иерархическая структура: сначала разделы, потом элементы.

Если есть потребность просматривать все элементы единым списком вне зависимости от разделов, то в настройках модуля Информационные блоки надо снять флажок с поля Совместный просмотр разделов и элементов . Если у вас нет прав на это действие, обратитесь к администратору сайта.

Быстрое редактирование нескольких элементов

Чтобы быстро отредактировать несколько элементов, отметьте их в колонке флажков и нажмите кнопку Редактировать.

После этого станут доступны для редактирования те поля, которые вы выбрали при настройке списка:

Нажмите на рисунок, чтобы увеличить


Настройка списка элементов (старый интерфейс)
22 / 694

Как сделать список элементов удобным для восприятия

Удобство работы со списком элементов - один из факторов быстрой и производительной работы контент-менеджера. Но каждый сайт - это свои информационные блоки со своими параметрами, свои опросы, свои группы баннеров и так далее. Создать удобный для всех случаев интерфейс списка элементов - невозможно. Поэтому в «1С-Битрикс: Управление сайтом» реализована возможность настройки списка элементов. Контент-менеджер может сделать видимым в списке только то, что ему нужно.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Способ настройки

Кнопка Настроить [image] вызывает диалог, в котором пользователь выбирает колонки для показа в таблице отчёта данной формы, а также задаёт некоторые параметры, применяемые по умолчанию:

Из Доступных колонок перенесите в Выбранные колонки нужные вам колонки. В Выбранных колонках удалите ненужные, а остальные разместите в удобном для вас порядке.

Примечание: Системная колонка ID не удаляется из таблицы, даже если вы удалите её из Выбранных колонок.

Для применения выбранных настроек нажмите кнопку Сохранить. Для возврата к настройкам списка по умолчанию нажмите Сбросить.

Важно запомнить!

Полностью удалять все параметры из поля Выбранные колонки - нельзя, должна оставаться хотя бы одна колонка.

Колонку флажков и Меню действий из Списка элементов удалить нельзя в принципе - это системные колонки.

По умолчанию настройки каждой таблицы сохраняются для текущего авторизованного пользователя. Установка флажка в поле Установить данные настройки по умолчанию для всех пользователей позволяет применить выбранные параметры формы для всех зарегистрированных пользователей, имеющих доступ к административному разделу.

Заключение

«1С-Битрикс: Управление сайтом» позволяет сделать работу Контент-менеджера удобной и производительной. Один из способов - настройка списка элементов, что позволяет держать перед глазами всегда только те данные, которые нужны.


Настройка списка элементов (новый интерфейс)
23 / 694

Настраиваем список элементов

Согласитесь, что при постоянной работе с однотипными файлами (в нашем случае - со списком элементов) хочется, чтобы все самые важные параметры были на виду, т.е. не приходилось открывать каждый элемент, а можно было все просмотреть в единой таблице. Это значительно экономит время и позволяет избегать рутинных действий.

В «1С-Битрикс: Управление сайтом» реализована возможность настройки списка элементов. То есть можно сделать видимым в списке только то, что нужно именно вам!

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Настройка списка элементов

Кнопка Настроить вызывает окно, в котором вы можете выбрать колонки для показа в таблице элементов данной формы:

Нажмите на рисунок, чтобы увеличить

Рабочие области окна настройки полей:

1 - Область быстрого выбора (можно сразу либо Выбрать все, либо Отменить все).
2 - Область выбора необходимых полей для вывода в таблице элементов.
3 - Область возврата к настройкам По умолчанию, а для администраторов также и область настройки отображения Для всех пользователей (т.е. выбранные администратором колонки будут отображаться не только у него, но и у всех пользователей, имеющих доступ к просмотру этих элементов).

Все, что нужно сделать для обеспечения себе более комфортной работы со списком элементов - выбрать нужные поля и нажать кнопку Применить! (соответственно, при нажатии кнопки Отменить все внесенные вами изменения удалятся).

Чтобы быстро поменять расположение колонок на экране, перетяните их в требуемые места, ухватив левой кнопкой мыши. При этом в настройках списка порядок тоже изменится.

Примечание: Вы также можете изменить названия выводимых колонок, кликнув по изображению пера справа от названия поля и нажав кнопку Сохранить после переименования.

Важно запомнить!

Полностью удалять все параметры нельзя, должна оставаться хотя бы одна колонка.

Колонку флажков и Меню действий из Списка элементов удалить нельзя в принципе - это системные колонки.

По умолчанию настройки каждой таблицы сохраняются для текущего авторизованного пользователя. Установка администратором флажка в поле Для всех позволяет применить выбранные параметры формы для всех зарегистрированных пользователей, имеющих доступ к административному разделу.

Заключение

«1С-Битрикс: Управление сайтом» позволяет сделать работу Контент-менеджера удобной и производительной. Один из способов - настройка списка элементов, что позволяет держать перед глазами всегда только те данные, которые нужны.


Основная рабочая область
24 / 694

Третий уровень: там где выполняются работы

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Текстовое содержание (нажмите на "плюсик")

Рабочая область - это место, где производится большинство операций по управлению сайтом:

  • просмотр элементов, составляющих контент сайта (например, информационных блоков , баннеров и т.п.);
  • добавление контента;
  • создание и удаление папок и файлов;
  • настройка меню и т.д.

Такие операции реализуются формами двух основных видов:

  • списки элементов - предназначены для просмотра элементов в форме таблиц, а также, в отдельных случаях (например, формы статистики) - в форме графиков и диаграмм;
  • формы редактирования - применяются для добавления и правки элементов, а также для задания настроек модулей и системы в целом.

Формы, отображаемые в рабочей области, хоть и разные, но имеют общие элементы. Ознакомьтесь с их функциями - это значительно облегчит дальнейшую работу с сайтом.

Для удобства текущего управления сайтом рекомендуется настроить Рабочий стол в Основной рабочей области.

Клик по пиктограмме [image], расположенной рядом с названием, добавляет ссылку на текущую страницу в Избранное команды Меню

Контекстная панель

Если форма позволяет производить какие-либо действия в отношении отображаемых элементов, то между фильтром и собственно списком на форме располагается контекстная панель, содержащая команды. Контекстные панели могут отображаться как в списках элементов, так и на формах редактирования. Например, список товаров на странице Одежда (Контент > Каталоги > Одежда) имеет такую контекстную панель:

Контекстная панель имеет кнопку [image], в которой содержатся дополнительные команды. Обязательно присутствуют команды:

  • Настроить выводит диалоговое окно, где пользователь выбирает колонки для отображения в списке и задаёт некоторые параметры, применяемые по умолчанию (поле и направление сортировки и т.п.).
  • Excel выполняет экспорт элементов из списка в файл Microsoft Excel.


Форма редактирования элемента
25 / 694

Что общего в разных формах редактирования: новости, заказы, баннеры...

Каждый элемент системы можно изменить: отредактировать новость, изменить описание товара, изменить SEO параметры страницы, создать скидку, настроить параметры модуля и так далее. Форма изменения появляется по команде Изменить . Несмотря на то, что формы различаются полями, объёмом изменяемой информации, можно выделить некоторые общие моменты для всех форм. Рассмотрим общие для всех форм редактирования моменты на примере формы изменения элемента Информационного блока :

Что есть на любой форме

1 - Контекстная панель. Её состав разный в зависимости от формы, но на любой панели есть кнопка возврата к списку элементов.

2 - Область закладок. Формы редактирования могут иметь большое число изменяемых свойств, поэтому схожие поля собраны в логические группы и выводятся в виде закладок. Обычно свойства сгруппированы так, что на первых страницах свойств (в порядке слева направо) помещаются наиболее часто используемые, а на последних - другие, дополнительные параметры. Доступен просмотр всех полей формы в одной закладке (или возврата в режим закладок) с помощью кнопки-треугольника в правой части области полей формы.

Несмотря на использование вкладок Область полей может быть большой и не помещаться на один экран. Для удобства сделайте постоянно видимыми Область закладок и Панель команд с помощью кнопки-гвоздика .

Внешний вид формы можно настроить для удобства работы: изменить состав и количество вкладок и полей. (Доступно не для всех форм редактирования.) Настройка формы и возвращение вида по умолчанию - по кнопке-шестерёнке .

3 - Область полей. Здесь и выводятся поля для редактирования. Названия полей, обязательных для заполнения, выделяются жирным шрифтом. Все формы работающие с контентом позволяют выбрать изображения для размещения однотипным способом .

4 - Панель команд.
Сохранить: внесённые изменения сохраняются, форма закрывается.
Применить: изменения сохраняются, форма остаётся открытой для дальнейшего редактирования.
Сохранить и добавить: изменения сохраняются, форма изменения закрывается и открывается новая форма для добавления элемента.

Заключение

Несмотря на обилие форм редактирования, у всех них есть общие области.

Формы редактирования настраиваются под конкретные условия работы.


Навигация и поиск
26 / 694

Как быстро попасть на нужную страницу

В Административном разделе предусмотрено несколько способов навигации и поиска. Традиционно навигация осуществляется с помощью пунктов Административного меню и Меню функций. Но есть и быстрый способ навигации - с помощью навигационной цепочки:

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

"Умный" поиск - быстрый поиск

На любой странице Административного раздела можно воспользоваться "умным" поиском, который при наборе слова уже начинает предлагать возможные варианты страниц, где встречается набираемое слово:

Поиск по файлам

В рамках файловой структуры есть механизм поиска файлов, размещающийся на контекстной панели в виде кнопки Поиск . Нажатие на эту кнопку открывает окно поиска:

Поиск ищет как по имени, так и по содержимому. Ограничения можно наложить следующие:

  • По папке или сайту;
  • Дате изменения;
  • Размеру файла;
  • Регистру.

Кнопка Подсчёт покажет общее число файлов, удовлетворяющих указанным условиям поиска.

С помощью поиска можно произвести замену слова или фразу в файле. Для этого воспользуйтесь закладкой Замена.


Рабочий стол
27 / 694
Рабочий стол - инструмент для организации удобного управления работой сайта с помощью произвольно размещаемых гаджетов. Система запоминает настройки Рабочего стола для каждого пользователя, то есть никто не изменит то, что вы настроили для себя.


Рабочий стол
28 / 694

Рабочий стол - организуй своё рабочее пространство

Рабочий стол - инструмент для организации удобного управления работой сайта с помощью произвольно размещаемых гаджетов. Система запоминает настройки Рабочего стола для каждого пользователя, то есть никто не изменит то, что вы настроили для себя.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».


Настройки Рабочего стола
29 / 694

Сделайте Рабочий стол вашим удобным рабочим местом

Удобная работа в Административной части при настроенном под потребности Контент-менеджера Рабочем столе - реальность. Достаточно только вывести на него нужные гаджеты и настроить внешний вид "под себя".

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Текстовое описание (нажмите на "плюсик")

Управление Рабочим столом выполняется с помощью кнопки:

Доступно:

  • Создать новый рабочий стол. Новые рабочие столы можно использовать для более удобной организации управления Административной частью.
  • Настроить рабочий стол: определение столбцов и их размеров.
  • Настроить все рабочие столы: изменение названий и положения столов, удаление столов.
  • Сбросить текущие настройки: вернуться к настройкам по умолчанию.


Гаджеты на рабочем столе
30 / 694

Гаджеты

Гаджеты в продуктах «1С-Битрикс: Управление сайтом» - это особые программные элементы, выполняющие функции уведомления и быстрого перехода к различным элементам управления и настройки системы и её элементов. С помощью гаджетов на Рабочем столе может быть представлена самая разнообразная информация.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Список гаджетов. (Нажмите на "плюсик".)
Список гаджетов
Название | Функционал
Группа Личное. Гаджеты для работы с персональными инструментами
Заметки
    Создание/изменение текстовых заметок.
Избранные ссылки
    Создание собственного мини-каталога ссылок.
Группа Внешние сервисы. Сервисы для получения информации из Интернета
RSS лента
    Вывод сообщений с внешнего источника.
Прогноз погоды
  • Прогноз погоды по выбранной местности.
  • Быстрый переход к сервису Яндекс.Погода.
Задачи и события | Гаджет для получения информации о задачах с портала Битрикс24
Группа Контент. Гаджеты раздела Контент.
Элементы инфоблока
  • Вывод списка элементов инфоблока согласно настройкам гаджета.
  • Быстрый переход к форме редактирования элемента.
Группа Магазин. Гаджеты раздела Магазин.
Заказы
  • Вывод списка элементов инфоблока согласно настройкам гаджета.
  • Быстрый переход к форме редактирования элемента.
Статистика по товарам | Вывод статистики по самым продаваемым и самым просматриваемым товарам.
Графики по продажам | Графики по доходу и по количеству.
Мобильное приложение | Работа с мобильным приложением.
Группа Веб-аналитика. Гаджеты раздела Веб-аналитика.
Статистика
  • Вывод статистики заказов и списка заказов.
  • Быстрый переход к соответствующим страницам раздела.
Группа Настройки. Гаджеты раздела Настройки Административной части
О системе | Информация о системе, обновлении, числе пользователей и другая.
Монитор производительности
  • Вывод текущей оценки производительности.
  • Быстрый переход к Панели производительности.
Монитор качества | Вывод оценок Монитора качества.
Проактивная защита
  • Вывод текущего уровня защиты.
  • Быстрый переход к Панели безопасности.
Marketplace | Переход к выбору решений из каталога.
Битрикс24 | Подключение Битрикс24
Авторизация Битрикс24 | Подключение единой авторизации всех порталов Битрикс24 и сайтов на "1С-Битрикс: Управление сайтом"
Инспектор сайтов | Переход к настройкам Инспектора. Текущая информация по Инспектору.
Скорость сайта | Измерение скорости открытия сайта для пользователей.

Примечание: В таблице описаны штатные гаджеты системы. Разработчики проектов на Bitrix Framework могут создать свои гаджеты и размещать их в системе.

Текстовое содержание видеоролика

Управление гаджетами

Для добавления служит кнопка Добавить гаджет. По ее нажатии открывается выпадающий список всех доступных гаджетов:

Выберите необходимый вам гаджет и он отобразится на рабочем столе в левой колонке сверху.

Перемещается гаджет наведением курсора мыши на его заголовок. Удерживая нажатой левую кнопку мыши, переместите гаджет в нужное место рабочего стола.

При нажатии на кнопку Настроить открывается форма настройки параметров. Состав полей формы зависит от конкретного гаджета. Минимальная настройка, доступная везде - это переименование. Поля настройки не сложны для понимания, вы сможете сами разобраться в их значениях, не будем на них останавливаться.

Пример параметров настройки:

Системой запоминаются все выполненные персональные настройки и расположение гаджетов.


Избранное
31 / 694

Избранное - ваше "любимые" ссылки

Избранное позволяет в один клик мыши перейти на нужную страницу сайта или в нужный раздел Административного интерфейса. Такой переход возможен как из Публичной , так и из Административной части . В Избранное можно добавить любую страницу как Публичного, так и Административного раздела, а также созданные вами фильтры.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Добавление в Избранное и его настройка

Добавить страницу в Избранное из Публичного раздела:

  • Откройте необходимую страницу.
  • Выполните на панели управления команду Меню > Избранное > Добавить в избранное. В Административном разделе откроется форма редактирования ссылки Избранного.
  • Заполните поля ссылки и сохраните изменения.

Добавить страницу в Избранное в Административном разделе:

  • с помощью специальной кнопки-звёздочки рядом с названием ;
  • перетаскиванием (drag&drop) страницы (или предустановленного фильтра) из Меню функций к правому краю экрана.

Редактирование Избранного производится на странице Административного раздела Настройки > Избранное (с публичной части на неё переходят по команде Закладка Сайты > Меню > Организовать избранное).

Нажмите на рисунок, чтобы увеличить

Важно запомнить!

  • При редактировании ссылки на странице Настройки > Избранное можно изменить название ссылки, но нельзя менять ее путь (поле Ссылка). При необходимости можно добавить комментарий в специальное поле.
  • Администратор может добавлять в список Избранного ссылки, которые видны всем.
  • Если ссылки в Меню добавляет сам пользователь, то они видны только ему.

Документация по теме:

  • Список избранного
  • Создание и редактирование избранной ссылки


Контекстная помощь
32 / 694

Ложка дорога к обеду

Обилие справочной информации «1С-Битрикс: Управление сайтом» иной раз создаёт проблему: где искать ответ на свой вопрос? Для облегчения поиска иголки в стоге сена создана Контекстная помощь, доступная только в Административном разделе системы. К ней обращаются нажатием на кнопку [image] в Административной панели. В Контекстной помощи отобразится вся информация по теме страницы, с которой она открывается. Если открываете со страницы Список баннеров, то выведется всё по работе с баннерами. Если открываете со страницы Заказы, то увидите всю информацию по заказам. И так далее.

Нажмите на рисунок, чтобы увеличить

Справка содержит следующие разделы (не все из них могут отображаться на каждой странице):

  • Почитайте готовые ответы - это список быстрых вопросов и ответов. Здесь собраны типовые вопросы и ответы, которые поступали в службу поддержки.
  • Учебный курс - список уроков из учебных курсов с детальным и подробным описанием функционала.
  • Советы пользователей - статьи партнёров 1С-Битрикса о работе с тем или иным функционалом.
  • Посмотрите Видеоролики - список видеороликов с общим рассказом о функционале и приёмах работы.
  • Пользовательская документация - список страниц из Пользовательской документации.
  • Быстрый поиск поиск по всем справочным материалам. Иногда с его помощью можно быстрее получить ответ.
  • Расскажите, что вы искали и не нашли - форма для отправки запроса на разъяснение тех или иных возможностей продукта.

Для администраторов в самом низу отображается ещё и форма для обращения в техподдержку компании "1С-Битрикс".

После клика по названию статьи, откроется сама статья. Есть несколько особенностей:

  1. Для изучения функционала бывает полезно одновременно с чтением повторять действия, описанные в статье. Чтобы сделать это воспользуйтесь ссылкой Открыть в новой вкладке . Статья откроется в новой вкладке, а на самом сайте вы сможете повторять действия, описанные в ней. Рекомендуется пользоваться этой опцией, так как функционал курсов имеет более широкие возможности, чем контекстная справка.
  2. Вы можете высказать своё отношение к статье с помощью специальных кнопок:

Заключение

Контекстная справка - информация о функционале, открываемая "по месту требования". То есть в разделе Информационные блоки откроется окно с информацией только о работе с инфоблоками, в разделе Медиабиблиотека - только о медиабиблиотеке.


Экспорт в MS Excel
33 / 694

Как получить данные из системы в формате MS Excel

Сохранить данные из «1С-Битрикс: Управление сайтом» на локальный компьютер - достаточно частая задача. Для такой операции используется формат MS Excel. Экспорт в него прост, выполняется в пару кликов прямо из Списка элементов. Используйте для этого кнопку Настроить . Если перед экспортом воспользоваться фильтром , то можно сохранить список только нужных вам элементов, а не всех подряд.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».


Проверьте себя
34 / 694

Ответьте на несколько вопросов по теме Административный раздел, которые помогут вам самим оценить свои знания. Это не тест, это просто проверка того, как вы поняли тему. Удачи!

Верно ли утверждение?

Оцените верность утверждения: Верно или Неверно. А потом в спойлере проверьте ваш выбор.

1 В Административном разделе можно скрыть ненужный в данный момент функционал системы и показать только требуемые функции.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
2 Внешний вид Административного раздела нельзя настроить.
Верно
Увы, вы ошиблись.Допускается сворачивание/разворачивание меню и придание им нужной ширины, настройка и создание любого количества Рабочих столов, использование самых разнообразных настраиваемых гаджетов. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
3 Для редактирования элемента списка нужно обязательно открывать форму редактирования.
Верно
Увы, вы ошиблись. Часть полей элемента можно редактировать прямо в списке. Советуем почитать тему ещё раз
Неверно
Аплодисменты, вы ответили правильно!
4 "1С-Битрикс: Управление сайтом" допускает групповое редактирование элементов списка.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
5 При настройке Внешнего вида списка элементов в списке обязательно должна оставаться хотя бы одна колонка.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
6 Любой пользователь может добавить в Избранное ссылку, которая будет видна всем.
Верно
Увы, вы ошиблись. Только Администратор может добавлять в список Избранного ссылки, которые видны всем. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
7 Экспорт данных из списка элементов невозможен.
Верно
Увы, вы ошиблись. Список элементов экспортируется в формат MS Excel. Предварительно отфильтровав список, можно получить в файле экспорта только нужные данные. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!


Информация на портале и работа с ней
35 / 694

Все действия по работе с информацией на сайте, которые делаются из Публичной части можно выполнять и в Административной части. Непосредственные действия по созданию, редактированию контента - типовые в обоих случаях. В этой главе рассказывается о различиях в выполнении работ по управлению содержимым сайта.

Замечание по Коротким ссылкам

Функционал Коротких ссылок имеет ограничение в использовании. Они могут не работать, если на главной странице сайта используется какой-либо комплексный компонент.


Шаблоны дизайна
36 / 694

Шаблоны и условия их применения

Страницы на сайте показываются в выбранном для них шаблоне дизайна.

Шаблон дизайна - программный код в котором определяется внешний вид сайта: расположение различных элементов на нём, художественный стиль и способ отображения страниц. Включает в себя программный html-код, графические элементы, таблицы стилей, дополнительные файлы для отображения контента. Может так же включать в себя шаблоны компонентов, шаблоны готовых страниц и сниппеты.

Число шаблонов дизайна на сайте ничем не ограничено. Для каждого шаблона определяется условие, при котором данный шаблон будет применяться к страницам сайта. Например, шаблон может быть применен:

  • ко всем страницам сайта в качестве шаблона по умолчанию;
  • к страницам отдельного раздела сайта;
  • к определенной странице сайта;
  • при отображении страниц для определенной группы пользователей;
  • при отображении версии страницы для печати;
  • в зависимости от программных условий ;
  • и т.п.

Нажмите на рисунок, чтобы увеличить

Настройка условий применения того или иного шаблона определяется отдельно для каждого сайта (в форме создания и редактирования сайта: Настройки > Настройки продукта > Сайты > Список сайтов).

Нажмите на рисунок, чтобы увеличить

Внимание! При настройке условий применения шаблонов обязательно указывайте индекс сортировки. Порядок применения шаблонов к сайту определяется в соответствии с указанной сортировкой. Если для страницы (раздела) может быть применено несколько шаблонов, то в итоге будет применен шаблон с меньшей сортировкой. Если индекс сортировки задан не будет, то может быть применен неверный шаблон.

Общее правило сортировки при назначении шаблонов подобно перевернутой воронке:

  • первыми должны идти условия частного характера;
  • потом условия выборки;
  • потом все остальное.

Документация по теме:

  • Простые примеры применения шаблонов в зависимости от различных условий (курс "Разработчик Bitrix Framework")
  • Создание и редактирование сайта (документация)
  • Шаблоны сайта (документация)


Создание и редактирование новых страниц и разделов
37 / 694

Работаем со структурой

Создание и редактирование страниц или разделов доступно как с Публичной , так и с Административной части.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Создание

Создание раздела и страницы в Административной части выполняется в рамках либо логической либо физической структуры. На контекстной панели воспользуйтесь кнопкой Добавить и выберите какой элемент будет добавлен:

Откроются формы для создания новой папки или файла. При создании файла откроется тот вид редактора, который задан в настройках модуля Управление структурой .

Для режимов правки файлов Редактировать как текст и Редактировать как PHP доступен режим редактирования кода с нумерацией строк и подсветкой синтаксиса .

При выборе режима Визуальный HTML редактор состав полей аналогичен составу в Публичном разделе, но разбит на закладки:

  • Закладка Редактирование. Выбирается шаблон страницы, указывается ее заголовок и название для файла , в котором данная страница будет сохранена. Ниже - собственно редактор:

    1 - панель инструментов визуального редактора.

    2 - панель переключения режимов редактирования.

    3 - рабочая область.

    4 - панели задач.

    5 - панель отображения свойств объектов.

  • На закладке Свойства указываются свойства страницы, например, значения тегов META: ключевые слова (keywords) и описание (description) страницы. Свойства, заданные в полях этой формы, будут использованы только для редактируемой страницы.
  • На закладке Меню добавите пункт в меню текущего раздела сайта (т.е. раздела, в котором создается страница), ссылающийся на созданную страницу.

Редактирование страниц и разделов

Чтобы перейти из Публичного раздела к редактированию текущей страницы (раздела) в Административном разделе, выберите в меню Изменить страницу пункт В панели управления .

В самом Административном разделе переход к редактированию страницы осуществляется из Менеджера файлов .

Документация по теме:

  • Создание новой папки (документация)
  • Создание и редактирование файла (документация)


Управление свойствами страниц и разделов
38 / 694

Задаём заголовок и другие свойства

Управление свойствами страницы в Административном разделе, независимо от выбранного редактора, осуществляется в форме редактирования страницы в таблице :

Управление свойствами раздела в Административном разделе производится с помощью пункта Свойства папки в контекстном меню папки, либо из контекстной панели, меню Дополнительно . Откроется окно настроек свойств каталога:

Если нужны новые типы свойств

По умолчанию в системе созданы два базовых типа свойств. Создание новых типов свойств выполняется на странице настроек модуля Управление структурой (Настройки > Настройки продукта > Настройки модулей > Управление структурой) в секции Настройки для сайтов:

Типы для каждого сайта

  • в поле Тип указывается символьный идентификатор создаваемого свойства. Он задаётся латинскими символами и служит для проверки или использования в коде продукта;
  • в поле Название задайте название свойства. Название отображается пользователям в форме настройки свойств страниц или разделов сайта.

Примечание: Типы свойств могут быть заданы отдельно для каждого сайта. Для этого:
  • Отметьте опцию Использовать индивидуальные настройки для каждого сайта ;
  • В списке Настройки для сайта выберите желаемый сайт;
  • Заполните поля Типы свойств.

Документация по теме:

  • Свойства папки


Управление правами доступа
39 / 694

Пускать "кого нужно"

Управлять правами доступа в «1С-Битрикс: Управление сайтом» возможно и с публичной и с административной части. В «Битрикс24 в коробке» права задаются только из административного раздела. Детальное описание управления правами на доступ к файлам и разделам дан ниже, в уроке Управление доступом к папкам и файлам . Здесь расскажем о способах перехода к форме задания прав.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Самый простой способ открыть форму настройки прав - воспользоваться контекстным меню для файла или папки . Правда это доступно только в рамках физической структуры.

Открыть форму настройки прав раздела в рамках логической или физической структуры сайта можно ещё одним способом, воспользоваться командой Свойства папки:

Задать права странице можно только в рамках физической структуры, как указано выше. Зато можно задавать права сразу нескольким файлам одновременно:

Документация по теме:

  • Задание прав с публичной части для «1С-Битрикс: Управление сайтом» (учебный курс "Контент-менеджер")
  • Права доступа


Загрузка и поиск файлов
40 / 694

Загрузка файлов

Для загрузки файлов перейдите с помощью Менеджера файлов в папку, в которую нужно загрузить файл и нажмите кнопку [image] на контекстной панели Менеджера файлов. Откроется сама форма загрузки файлов:

Нажмите на рисунок, чтобы увеличить

Число загружаемых файлов неограниченно.

Примечания:
  • По умолчанию в настройках системы установлено ограничение на размер загружаемого файла в 2 мегабайта. Если есть необходимость изменить это ограничение, то это можно сделать в файле php.ini в параметре upload_max_filesize.
  • Система поддерживает использование файлов с именами как на латинице, так и на кириллице, без ограничений по регистру. Недопустимо только использование спецсимволов: \ / ? * < > " '.

Поиск файлов

В рамках файловой структуры есть механизм поиска файлов, размещающийся на контекстной панели в виде кнопки Поиск . Откроется окно поиска:

Поиск ищет как по имени, так и по содержимому. Ограничения можно наложить следующие:

  • По папке или сайту
  • Дате изменения;
  • Размеру файла;
  • Регистру.

Кнопка Подсчёт покажет общее число файлов, удовлетворяющих указанным условиям поиска.

С помощью поиска можно произвести замену слова или фразу в файле. Для этого воспользуйтесь закладкой Замена.

Документация по теме:

  • Менеджер файлов
  • Загрузка нового файла


Расширенный режим настройки меню
41 / 694

Дополнительные возможности настроек

При ограничении доступа к разделу пользователю виден сам пункт, и это не всегда хорошо. Сокрытие пункта меню в зависимости от различных условий производится только в Административном разделе. Делается это и в рамках логической, и в рамках физической структуры. Ниже будет описан пример с ограничением доступа по пользователям (как самый частый вариант).

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Пример ограничения доступа к разделу с сокрытием пункта меню

В этом примере разберем ограничение по пользователям. Для такого ограничения доступа:

  • Перейдите в Административной части в раздел, в котором нам нужно скрыть нужный пункт меню.
  • Найдите в списке файлов файл нужного меню: Меню типа ****. В колонке действий выберите Редактировать меню . Откроется форма редактирования меню в упрощенном режиме. В упрощенном режиме с меню можно делать все то, что мы делали с меню в публичной части : создавать пункты, редактировать их, удалять и менять порядок.
  • Щелкните кнопкой мыши на пункте Расширенный режим на контекстной панели формы редактирования меню. Форма перейдет в расширенный режим:

    Примечание: Подробное описание полей формы можно посмотреть на странице пользовательской документации .

  • В поле Тип условия выберите Для групп пользователей. Форма перезагрузится, и откроются поля ограничения доступа по пользовательским группам.
  • Выберите группу пользователей. Ограничение доступа работает по разрешительному принципу. Иными словами, пункт меню будет виден для тех групп, которые выбраны в этом поле.

Примечание: Если скрыть только пункт меню, но не запретить доступ к разделу, то обычный пользователь сможет зайти в раздел, если он знает адрес раздела.

Документация по теме:

  • Редактирование меню


Пользователи и авторизация
42 / 694

За работу с пользователями (добавление и авторизация) отвечает Главный модуль системы. Пользователи добавляются с Публичного раздела самостоятельно, либо с Административного раздела вручную администратором или автоматически через разные виды импорта.

Авторизация в системе также возможна через модуль AD/LDAP .


Регистрация и разграничение прав
43 / 694

От чего зависят права пользователей

Каждый посетитель сайта относится к одной или нескольким группам пользователей сайта. Какой уровень прав есть у группы, такой же уровень прав есть и у пользователя. Если пользователь приписан к нескольким группам, то он обладает максимальным уровнем прав из доступных для него в рамках этих групп.

Примеры прав пользователя, состоящего в нескольких группах
  1. Предположим, что в системе зарегистрирован пользователь, приписанный к двум группам, например:
    • Редакторы сайта;
    • Партнеры.

    Пользователи группы Редакторы сайта обладают правом на редактирование страниц сайта, однако им запрещен доступ к страницам партнерского раздела.

    Пользователи группы Партнеры обладают правом на просмотр публичных страниц сайта, а также на доступ к закрытому партнерскому разделу.

    В результате пользователь, относящийся к этим двум группам, будет обладать следующими правами:

    • правом на редактирование всех страниц сайта, кроме страниц партнерского раздела;
    • правом на просмотр страниц партнерского раздела.

  2. Либо: в системе зарегистрирован пользователь, приписанный к двум группам, например:
    • Сотрудники;
    • Маркетинг и продажи.

    Пользователи группы Сотрудники обладают правом на просмотр страниц сайта, однако им запрещен доступ к некоторым страницам сайта (например, к разделу Документы - Маркетинг и продажи). По умолчанию, пользователи, не состоящие в этой группе, не будут иметь доступа к порталу.

    Пользователи группы Маркетинг и продажи обладают правом на доступ к соответствующему разделу на странице Документы.

    В результате пользователь, относящийся к этим двум группам, будет обладать следующими правами:

    • правом на доступ к порталу;
    • правом на доступ к документам Маркетинг и продажи.

Система разграничения прав доступа на сайтах "1С-Битрикс: Управление сайтом" - двухуровневая:

  • уровень 1: доступ к каталогам и файлам;
  • уровень 2: доступ к модулям системы и логическим операциям в модулях.

Управление этими уровнями прав выполняется отдельно друг от друга.

Регистрация пользователя в системе

При регистрации в системе пользователь получает личные регистрационные данные (логин и пароль) и приписывается к одной или нескольким группам.

Если в системе разрешена самостоятельная регистрация , то при регистрации пользователя ему создаётся учётная запись с добавлением в группу по умолчанию, указанную в настройках Главного модуля (Настройки > Настройки продукта > Настройки модулей > Главный модуль). В дальнейшем администратор может изменить приписку пользователя к группе.

После того, как пользователь авторизуется в системе, вверху страницы в публичном разделе сайта будет показана административная панель , содержащая набор команд для управления сайтом, если доступ к ней разрешен.

Набор кнопок, отображаемый пользователю, зависит от уровня прав доступа группы, к которой он относится. Например, для пользователей, обладающих правом только на чтение публичных страниц сайта, данная панель отображаться не будет. Полный набор кнопок отображается администратору сайта.

Документация по теме:

  • Типовые роли пользователей сайта
  • Управление пользователями
  • Уровни доступа
  • Настройки главного модуля
  • урок "Регистрация по номеру телефона"


Работа с учетными записями пользователей
44 / 694

Управление учетными записями

Управление учетными записями пользователей в системе выполняется на странице Список пользователей (Настройки > Пользователи > Список пользователей):

Нажмите на рисунок, чтобы увеличить

Для добавления нового пользователя служит кнопка Добавить пользователя, расположенная на контекстной панели.

Предупреждения для администраторов "Битрикс24 в коробке"
1. При первом выставлении счета в CRM создается фиктивный пользователь с именем anonymous_[набор символов]. Его удаление приведет к невозможности выставления счетов.

2. Пользователи могут быть лицензированными и активными. Лицензированные - это число пользователей, доступных по лицензии + число дополнительно приобретённых пользователей. Активные пользователи - это пользователи авторизованные на портале в данный момент.
Администратор может работать в административной части со всеми пользователями, но в публичную часть может войти активных пользователей числом не более, чем лицензируемых.

3. При работе Открытых линий для каждого внешнего клиента на портале создается пользователь типа экстранет. Обнаружив таких пользователей в списке пользователей , не пугайтесь, вас не взломали. Это системные пользователи.

4. С версии 15.5.0 при удалении пользователя включена проверка на его участие в шаблонах задач.

Удаление пользователя будет возможно только после его исключения из всех шаблонов.

Изменение учётной записи

Форма редактирование параметров пользователя вызывается с помощью двойного клика левой кнопкой мыши по записи пользователя, либо с помощью пункта Изменить в контекстном меню. С помощью команды Авторизоваться администратор может в один клик выйти из своего аккаунта и авторизоваться под выбранным аккаунтом .

Форма управления учетной записью пользователя имеет следующий вид:

Значения полей формы в большинстве случаев интуитивно понятны. Если возникнут вопросы, то подробное описание полей формы приводится в пользовательской документации продукта.

В больших проектах с несколькими администраторами есть смысл вести историю изменений учётных записей. Для этого используется опция Сохранять историю изменения полей профиля пользователя в настройках Главного модуля. Сами изменения отображаются на странице Настройки > Пользователи > История профилей.

Учётная запись администратора

Учетная запись администратора создаётся при установке системы автоматически с идентификатором 1. Пароль для этой записи должен быть не менее 6 символов. Этот пользователь обладает максимально возможным доступом к системе. В дальнейшем регистрационные данные администратора могут быть изменены, но саму запись удалить невозможно.

Если по каким-то причинам пароль к администраторскому аккаунту утерян, то восстановите его.


Группы пользователей
45 / 694
Внимание! Необходимо делать различия между понятиями группа пользователей и рабочая группа в рамках социальной сети. Группа в рамках социальной сети – это сотрудники, собранные для решения какой-либо задачи в рамках этой сети. При этом они могут принадлежать разным группам пользователей.

Управление группами пользователей в системе выполняется на странице Группы пользователей (Настройки > Пользователи > Группы пользователей):

Для добавления новой группы служит кнопка Добавить группу, расположенная на контекстной панели. Перейти к редактированию параметров группы можно с помощью двойного клика левой кнопкой мыши по соответствующей записи либо с помощью пункта Изменить в контекстном меню.

Примечание: Подробное описание формы создания и редактирования группы приведено в пользовательской документации продукта.

В системе существует две обязательные группы пользователей: Все пользователи и Администраторы:

  • по умолчанию к группе Все пользователи относятся все незарегистрированные посетители портала, обладающие правом только на просмотр публичных страниц сайта (кроме страниц закрытых разделов);
  • к группе Администраторы относятся администраторы портала, обладающие полным набором прав на доступ к управлению системой (в том числе, доступом к управлению правами других пользователей).
Параметры данных групп пользователей могут быть изменены (название, описание, уровень прав для группы Все пользователи), но сами группы не могут быть удалены из системы.

Внимание! Группа Сотрудники является обязательной группой, в нее должны входить все пользователи портала, чтобы иметь доступ и минимальные права для работы на портале. Для того чтобы повысить уровень прав пользователя (перевести в другую группу) необходимо включить его в состав двух групп: Сотрудники и требуемой группы.

Другими словами, смена прав для пользователя на портале выполняется путем добавления его в соответствующую группу, но без исключения из группы Сотрудники.

Приписка пользователей к той или иной группе выполняется в форме настройки параметров учетной записи пользователя на закладке Группы (Настройки > Пользователи > Список пользователей):

Примечание: С помощью полей Период активности можно указать период привязки пользователя к той или иной группе. По истечении указанного периода, пользователь будет отписан от соответствующей группы, однако бюджет пользователя сохраняется в системе.

Внимание! Необходимо помнить, что задание прав для групп производится не только в закладке Доступ при создании или редактировании группы. В каждом отдельном информационном блоке может быть задан свой уровень доступа для групп. Кроме того, можно через свойства страницы или раздела задать права доступа, отличные от тех, что заданы на закладке Доступ.

Подробную информацию об управлении доступом смотрите в курсе главе Управление доступом.


Типовые роли пользователей сайта
46 / 694

Рассмотрим типовые роли сотрудников, работающих с сайтом и описание того, какие минимальные настройки прав необходимы для каждой из этих ролей.

Роль Описание Как настроить
Младший контент-редактор Право на создание контента без возможности его публикации
  • право Чтение на папку bitrix/admin;
  • право доступа Изменение с ограничениями к инфоблоку контента (только при включенной опции в инфоблоке Расширенное управление правами);
  • полные права доступа к статусам документооборота Черновик и Готов.
Редактор каталога Права на редактирование каталога товаров
  • право Чтение на папку bitrix/admin;
  • право Изменение на нужный торговый каталог.
Главный редактор Все права контент-менеджера
  • право Чтение на папку bitrix/admin;
  • право Полный доступ на инфоблок контента;
  • максимальные права на все статусы документооборота.
Менеджер Право на просмотр заказов
  • право Чтение на папку bitrix/admin;
  • уровень доступа Обработка заказов к модулю Интернет-магазин;
  • пользователь должен быть включен в группы, имеющие доступ к заказам сайта (закладка Права на заказы в форме настроек модуля Интернет-магазин).
Старший менеджер Работа с заказами, отчетами и 1С
  • право Чтение на папку bitrix/admin;
  • уровень доступа Полный доступ к модулю Интернет-магазин;
  • пользователь должен быть включен в группы, которым разрешена выгрузка (закладки Экспорт каталога и Заказы на странице Магазин > Настройки > Интеграция с 1С).
Администратор контента Может администрировать инфоблоки и пользователей (кроме админов), не имеет прав менять глобальные настройки сайта, изменять папки и файлы.
  • Для таких пользователей должна быть создана отдельная группа, пользователь не должен входить в другие группы с более широкими правами;
  • Для группы установлено право Чтение на папку bitrix/admin, и право Запись на bitrix/admin/user_edit.php;
  • уровень доступа [V]Просмотр данных модуля и изменение заданных профилей к Главному модулю;
  • В настройках группы должно быть указаны группы чьи профили возможно редактировать;
  • В настройках нужных инфоблоков нужно задать право Полный доступ.
Директор Права главного редактора, работа с отчетами и управление ценами
  • право Чтение на папку bitrix/admin;
  • право Полный доступ на инфоблок контента;
  • максимальные права на все статусы документооборота;
  • уровень доступа Обработка заказов к модулю Интернет-магазин;
  • право доступа Редактирование цен к модулю Торговый каталог;
  • право доступа Изменение к нужному торговому каталогу.


Импорт пользователей
47 / 694

Пользователей на сайт можно добавлять не только по одному, но и целым списком. Импортировать пользователей можно:

  • из файла CSV
  • из Active Directory / LDAP


Страница импорта
48 / 694

Импорт пользователей

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Для добавления целого списка пользователей в систему служит специальная страница административного раздела Импорт пользователей.

Перейдите на страницу Импорт пользователей (Настройки > Пользователи > Импорт пользователей). Откроется форма импорта:

Нажмите на рисунок, чтобы увеличить

Выберите нужный источник данных и нажмите кнопку Далее.

Обратите внимание! Во время загрузки можно сохранить старую привязку пользователей к их группам либо указать, чтобы все пользователи привязались к какой-нибудь указанной группе портала. Выборочное изменение привязки пользователей из одного списка по разным группам невозможно.

Документация по теме:

  • Импорт пользователей


Импорт пользователей из CSV-файла
49 / 694

Импорт из файла

Для добавления целого списка пользователей в систему служит специальная страница административного раздела Импорт пользователей (Настройки > Пользователи > Импорт пользователей).

Нажмите на рисунок, чтобы увеличить

Важно! CSV-файл создаётся в кодировке сайта. Кодировку можно посмотреть в форме создания/редактирования сайта (Настройки > Настройки продукта > Сайты > Список сайтов).

Подготовка файла CSV

CSV-файл должен быть подготовлен заранее. Он должен иметь следующий формат:

заголовок
данные
данные
данные

Каждая строка файла — это одна строка таблицы. Заголовок может состоять из любого количества записей, расположенных в одной строке. Он указывает тип данных, содержащихся в разделе, который следует после заголовка. Значения в строках файлов (как заголовка, так и данных) разделяются разделительным символом (delimiter).

Пример заголовка данных пользователей
LAST_NAME;PERSONAL_PHOTO;NAME;SECOND_NAME;WORK_POSITION;EMAIL;PERSONAL_BIRTHDAY;PERSONAL_GENDER;WORK_PHONE;UF_1C_PHONE_INNER;PERSONAL_MOBILE;PERSONAL_ICQ;LOGIN;IBLOCK_SECTION_NAME_1;IBLOCK_SECTION_NAME_2;IBLOCK_SECTION_NAME_3;IBLOCK_SECTION_NAME_4

Данные в полях должны строго соответствовать порядку полей в заголовке. Вне зависимости от того, имеются ли данные для соответствующего поля, само поле должно быть указано.

Например, если заголовок файла имеет следующий вид:

LAST_NAME;PERSONAL_PHOTO;NAME;SECOND_NAME;WORK_POSITION;

а в какой-либо из строк нет данных для части полей, скажем, 2, 4 и 5, то строка с данными должна иметь вид:

Иванов;;Андрей;;

Поля, в которых нет данных, просто отмечены разделителем.

Перед форматированием CSV-файла учтите следующие аспекты:

  • Разделитель (delimiter) может быть любым: запятая (,), точка с запятой (;), пробел или табуляция. Нельзя вводить пробелы между значениями. Если в качестве разделителя выбран пробел, то необходимо следить за тем, чтобы не было двойных пробелов между значениями.
  • Если запятая является частью значения (например: свойства объекта перечислением через запятую), заключите значение в двойные кавычки "рыжий,красный,зеленый".
  • Если двойные кавычки являются частью значения, заключите значение в пару двойных кавычек. Например, "Иван" в CSV-файле должно выглядеть следующим образом: ""Иван"".
  • Пустые строки в CSV-файле не допускаются.
  • Регистр не учитывается в заголовках, строковых значениях, логине.
  • Пароли вводятся с учетом регистра.
  • Логические значения могут быть представлены следующим образом: Y — истина; N — ложь.
  • Данные, расположенные в строке данных после последнего распознанного значения в строке заголовка, игнорируются. Например, если в строке заголовка файла указано 10 значений, а в строке данных упоминается 12 значений, последние 2 будут отброшены.
  • Элементы данных, значения которых не указаны, обрабатываются как пустые строки.
  • Формат времени должен быть установлен в формате языка сайта. Например: MM/DD/YYYY HH:MI:SS (для английского языка), либо DD.MM.YYYY HH:MI:SS (для русского языка).

Экспорт пользователей из системы

Если вы хотите выгрузить пользователей, то выполните следующее:

  1. Перейдите на страницу Список пользователей (Настройки > Пользователи > Список пользователей).
  2. Нажмите на кнопку Excel, чтобы выгрузить данные из списка.
  3. После выгрузки адаптируйте файл под требования CSV-формата. В частности:
    • удалите итоговые строки внизу таблицы;
    • в заголовке замените названия значений на правильные латинские названия в соответствии с Таблицей типов данных, приведенной ниже;
    • проверьте правильность заполнения полей данными в соответствии с Таблицей типов данных, приведенной ниже. (Например, значения пола должны быть указаны M и F, а не М и Ж).
    4. Таблица типов данных

    В таблице приведены все типы данных и указан признак обязательно заполнения каждого поля.

    Значение | Тип данных | Обязательность | Комментарии
ACTIVE | boolean (логический) | Нет, по умолчанию - Да (истина) | Активен
LOGIN | string (строка) | Нет, по умолчанию автоматически генерируется | Логин (мин. 3 символа)
PASSWORD | string (строка) | Нет, по умолчанию автоматически генерируется | Пароль (мин. 6 символов). Если для группы пользователей в форме редактирования группы на закладке Безопасность изменён параметр Минимальная длина пароля, то возможно, что импорт будет производиться, ошибки система выдавать не будет, но пользователи добавляться не будут.
NAME | string (строка) | Да | Имя
LAST_NAME | string (строка) | Да | Фамилия
SECOND_NAME | string (строка) | Нет, по умолчанию не задано | Отчество
EMAIL | string (строка) | Нет, по умолчанию указан e-mail администратора | E-mail. Если поле не используется необходимо отключить опцию Проверять E-mail на уникальность при регистрации в настройках Главного модуля на закладке Авторизация.
DATE_REGISTER | date (дата) | Нет, по умолчанию текущая дата | Дата регистрации
LID | string (строка) | Нет | ID сайта по умолчанию для уведомлений
ADMIN_NOTES | string (строка) | Нет | Заметки администратора
EXTERNAL_AUTH_ID | string (строка) | Нет | Код источника внешней авторизации
XML_ID | string (строка) | Нет | ID пользователя для связи с внешними источниками (например, ID пользователя в какой-либо внешний базе)
Личные данные | Тип данных | Обязательность | Комментарии
PERSONAL_GENDER | string (строка) | Нет | Пол. M – муж.; F- жен.
PERSONAL_BIRTHDAY | date (дата) | Нет | В формате даты
PERSONAL_CITY | string (строка) | Нет | Город
PERSONAL_STATE | string (строка) | Нет | Область, район
PERSONAL_ZIP | string (строка) | Нет | Почтовый индекс
PERSONAL_WWW | string (строка) | Нет | Персональный сайт
PERSONAL_PROFESSION | string (строка) | Нет | Профессия
PERSONAL_NOTES | string (строка) | Нет | Персональные заметки
PERSONAL_ICQ | string (строка) | Нет | Номер ICQ
PERSONAL_PHONE | string (строка) | Нет | Домашний телефон
PERSONAL_PHOTO | string (строка) | Нет | Фото. Путь указывается относительно папки, указываемой в настройках импорта (поле Путь к картинкам относительно корня сайта), или относительно корня сайта, но при пустом значении поля Путь к картинкам относительно корня сайта
PERSONAL_FAX | string (строка) | Нет | Факс
PERSONAL_MOBILE | string (строка) | Нет | Мобильный номер
PERSONAL_PAGER | string (строка) | Нет | Пейджер
PERSONAL_STREET | string (строка) | Нет | Улица
PERSONAL_MAILBOX | string (строка) | Нет | Почтовый ящик
Работа | Тип данных | Обязательность | Комментарии
WORK_COMPANY | string (строка) | Нет | Название компании
WORK_DEPARTMENT | string (строка) | Нет | Название подразделения
WORK_POSITION | string (строка) | Нет | Должность
WORK_WWW | string (строка) | Нет | Рабочий сайт
WORK_PHONE | string (строка) | Нет | Телефон
WORK_FAX | string (строка) | Нет | Факс
WORK_PAGER | string (строка) | Нет | Пейджер
WORK_STREET | string (строка) | Нет | Улица
WORK_MAILBOX | string (строка) | Нет | Почтовый ящик
WORK_CITY | string (строка) | Нет | Город
WORK_STATE | string (строка) | Нет | Область, район
WORK_ZIP | string (строка) | Нет | Почтовый индекс
WORK_PROFILE | string (строка) | Нет | Направление деятельности компании
WORK_LOGO | string (строка) | Нет | Фото. Путь указывается относительно папки, указываемой в настройках импорта (поле Путь к картинкам относительно корня сайта), или относительно корня сайта, но при пустом значении поля Путь к картинкам относительно корня сайта
WORK_NOTES | string (строка) | Нет | Рабочие заметки
UF_* | string (строка) | Нет | Пользовательское свойство, созданное администратором. Свойство должно быть обязательно создано до импорта пользователей.
IBLOCK_SECTION_NAME_* | string (строка) | Нет | Привязка к инфоблоку. Доступно 5 уровней вложенности. В "1С-Битрикс: Корпоративный портал" позволяет сразу развести сотрудников по подразделениям. * обозначает уровень вложенности подразделения. (т.е. если подразделение верхнего уровня, то IBLOCK_SECTION_NAME_1, следующего IBLOCK_SECTION_NAME_2 и т.д.). В столбце значений указать название подразделения. На втором шаге импорта нужно указать Привязать пользователей к разделам информационного блока: Подразделения.

    Важно! Для импорта пользователей из CSV-файла минимально необходимое условие - это указание имени (NAME) и фамилии пользователя (LAST_NAME).

    Пример CSV-файла

    LAST_NAME,NAME,LOGIN,PASSWORD,EMAIL
Иванов,Василий,vivanov,Password1,vivanov@company.ru
Кузнецов,Владимир,vkuznetsov,Password2,vkuznetsov@company.ru
Романова,Ольга,oromanova,Password3,oromanova@company.ru
Синицына,Елена,esinitsyna,Password4,esinitsyna@company.ru
Тихомиров,Илья,itihomirov,Password5,itihomirov@company.ru
Басманов,Константин,kbasmanov,81QE1RO98M,kbasmanov@company.ru
Галкина,Екатерина,egalkina,D0O4IAYOX0,egalkina@company.ru
Королев,Михаил,mkorolev,CDUEND3SMX,mkorolev@company.ru
Матвеева,Ирина,imatveeva,GCH425XAM6,imatveeva@company.ru
Орлов,Кирилл,korlov,ZD3PZHP2E7,korlov@company.ru

    Чтобы гарантировать отсутствие ошибок в ходе импорта, проверьте, что данные в файле соответствуют формату, указанному в начале этой главы. Проверить правильность формата файлов можно, открыв CSV-файл в MS Excel, и просмотреть результат:

    • Проверьте заголовки данных.
    • Проверьте, что длина пароля для учетных записей, которые необходимо импортировать, составляет не менее 6 знаков.
    • Проверьте, что длина логина не менее 3 символов.

    После проверки CSV-файла можно приступать к импорту.

    Выполнение процедуры импорта

    В форме импорта пользователей в качестве источника данных выберите CSV-файл и нажмите кнопку Далее.

    Заполните поля второго шага импорта (закладка Параметры импорта):

    Настройка параметров импорта

    • Файл данных – укажите путь до CSV-файла.
    • Разделитель полей – укажите разделитель, который использовался в файле.
    • Привязать пользователей к группам – выберите группу (группы с помощью Ctrl), к которой нужно привязать пользователей из файла.
    • Путь к картинкам относительно корня сайта – путь к папке с картинками, относительно которой будут указаны пути значений PERSONAL_PHOTO и WORK_LOGO. Если поле пустое, то в значениях PERSONAL_PHOTO и WORK_LOGO необходимо указать полный путь относительно корня сайта.
    • Привязать пользователей к разделам информационного блока – выберите инфоблок, к которому будут привязаны пользователи, имеющие данные в значении IBLOCK_SECTION_NAME_*. Указать можно только один инфоблок. Если один и тот же пользователь должен быть привязан к разным инфоблокам, то привязку нужно осуществить впоследствии вручную.
    • Разрешить пользователям авторизовываться через LDAP-сервер – укажите имя сервера, через который будет проводиться авторизация. При необходимости можно перейти к созданию сервера сразу с этого шага по ссылке Создать.
    • Оповестить пользователя, если был указан e-mail - оповещать пользователей о регистрации на сайте с помощью выбранного шаблона, если в CSV-файле был указан e-mail.
    • Игнорировать пользователей, логин которых уже существует в системе - укажите эту опцию, чтоб при импорте не добавлялись пользователи с логинами, которые уже существуют в системе.

    Нажмите кнопку Далее. На следующем шаге выполняется автоматический импорт пользователей. После завершения импорта будет выведено сообщение о числе добавленных пользователей.

    Просмотр импортированных данных

    Для просмотра импортированных данных в административном разделе перейдите на страницу Список пользователей (Настройки > Пользователи > Список пользователей). Откроется таблица со всеми пользователями системы.

    Если импорт прошел неправильно, то необходимо удалить все записи, исправить CSV-файл и повторить описанные действия заново.


Импорт пользователей из LDAP-directory
50 / 694

Импорт пользователей из LDAP-directory

Для добавления целого списка пользователей в систему служит специальная страница административного раздела Импорт пользователей (Настройки > Пользователи > Импорт пользователей).

Для импорта пользователей из Active Directory / LDAP выполните следующее:

  1. На странице Импорт пользователей в качестве источника данных выберите Active Directory / LDAP и нажмите кнопку Далее.
  2. На втором шаге импорта (закладка Параметры импорта) в выпадающем списке выберите сервер , который будет использован для импорта.После выбора сервера в форме появятся импортируемые поля. Снимите флажки с дополнительных полей, которые не нужно импортировать.

    Настройка параметров импорта

  3. Нажмите кнопку Далее. Мастер перейдет к третьему шагу. Будет автоматически произведен импорт, система сообщит об его завершении и количестве добавленных записей.

    4. Примечание: Если пользователь заблокирован и существует на сайте, то его данные обновляются при импорте из AD/LDAP. Если пользователь неактивен и на сайте не существует, то он не импортируется на сайт.


Импорт из 1С: Зарплата и управление персоналом
51 / 694

Чтобы выполнить импорт пользователей из 1С: Зарплата и управление персоналом 8.1, необходимо выполнить настройки как со стороны продуктов «1С-Битрикс», так и со стороны 1С: Зарплата и управление персоналом 8.1.

Внимание! При импорте не отслеживается ситуация работы одного сотрудника на нескольких должностях. Поэтому при увольнении сотрудника с одной должности при остановке его на другой автоматически деактивируется учетная запись этого сотрудника на корпоративном портале, и сотрудник исчезает из телефонного справочника, из структуры компании, хотя он продолжает работать в компании и запись в 1С:ЗУП о том, что он работает на оставшейся должности, есть. (И даты увольнения на оставшейся должности у него не стоит, так как он продолжает работать).

Рекомендуется исключить пользователя из подразделения, но не увольнять сотрудника.

Настройка импорта в продуктах «1С-Битрикс»

На странице Импорт пользователей (Настройки > Пользователи > Импорт пользователей) в качестве источника данных выберите 1С: Зарплата и управление персоналом и нажмите кнопку Далее.

На втором шаге импорта (закладка Параметры импорта) создается пользователь и группа с правами на импорт пользователей из 1С. По умолчанию группа Импорт пользователей из 1С в продукте не предусмотрена и создается только в этом шаге.

Примечание: создание нового пользователя необходимо только в том случае, если импорт будет производиться другим сотрудником, а не администратором портала. Если процедура импорта возложена на администратора портала, то шаг можно пропустить.

Установите флажок в поле Создать пользователя, имеющего право на импорт из 1С: Зарплата и управление персоналом. Поля для создания пользователя станут активными.

Заполните поля в соответствии с требованиями.

Нажмите кнопку Далее. Пользователь и соответствующая группа будут созданы. Откроется последний шаг импорта.

Перейдите к настройке параметров импорта пользователей (страница Настройки > Настройки продукта > Настройки модулей > Интранет, закладка Импорт):

Настройка параметров импорта

Выполните настройку параметров:

  • Проводить проверку целостности cтруктуры – при установленном флаге система проверяет наличие дополнительных полей инфоблоков и пользовательских полей. В случае отсутствия, необходимые поля будут автоматически созданы.
  • Интервал одного шага в секундах - интервал выполнения одного шага импорта. Если указано 0, то загрузка выполняется за один шаг. Увеличение интервала приведет к более быстрой загрузке данных, но зачастую требует дополнительной настройки серверного программного обеспечения. Если вы не уверены в необходимости увеличения параметра, то оставьте значение по умолчанию.
  • Группы, пользователям которых разрешена загрузка – выберите группу (группы с помощью Ctrl) пользователей, обладающие правом загрузки пользователей в систему.
  • Размер единовременно загружаемой части файла (в байтах) – указывается размер в байтах - второе ограничение для пошаговой загрузки файла в систему.
  • Использовать сжатие zip, если доступно – при отмеченной опции данные сжимаются ZIP-форматом (если подключена библиотека php_zip). Это позволяет заметно уменьшить XML-файлы.
  • E-mail по умолчанию – адрес электронной почты, который будет установлен пользователям, если он отсутствует в карточке 1С (в виде контактного поля или набираемого свойства).
  • Шаблон автоматического формирования логина – шаблон, определяющий вид логина сотрудника, если он отсутствует в карточке 1С (в виде набираемого свойства). В шаблоне обязательно должен присутствовать символ #, который будет заменен на порядковый номер.
  • Обновляемые свойства – свойства, которые будут изменяться при обновлении данных. Свойства, которые разрешены для изменения сотрудниками рекомендуется исключать из обновлений. Также рекомендуется исключать Логин и Пароль. При добавлении новых сотрудников этот параметр игнорируется.
  • XML-идентификатор свойства "<название_свойства>" – указывается XML-идентификатор этого свойства в том случае, если само свойство в 1С задано в набираемом свойстве.
  • Сервер LDAP – в выпадающем списке выберите сервер, который будет использоваться при авторизации.

    • Примечание: параметры Сервер LDAP и XML-идентификатор свойства "Учетная запись AD" отобразятся в форме в том случае, если установлен и настроен модуль AD/LDAP интеграция.

Кроме того, при импорте пользователей из 1С выгружается не только список сотрудников, но также информация о структуре компании и вся кадровая информация о сотрудниках. Поэтому в «Битрикс24 в коробке» должны быть созданы тип инфоблоков (например, Оргструктура) и информационные блоки, в которых будут храниться импортированные данные. После чего они должны быть обязательно указаны в настройках модуля Интранет на закладке Данные:

Настройки модуля Интранет

Чтобы импорт пользователей и структуры компании был выполнен корректно, необходимо проверить настройки свойства UF_DEPARTMENT, с помощью которого осуществляется привязка пользователя к подразделению компании (настройка пользовательских свойств осуществляется на странице Настройки > Настройки продукта > Пользовательские поля):

Настройка пользовательского свойства

Настройка и проведение импорта из «1С: Зарплата и управление персоналом 8.1»

На компьютере с 1С: Зарплата и управление персоналом 8.1 запустите эту программу.

Примечание: компьютер с 1С: Зарплата и управление персоналом 8.1 должен иметь доступ к локальной сети и к корпоративному порталу.

Выполните команду Сервис > Обмен данными с WEB-сайтом > Настроить обмен данными с Web-сайтом. Откроется форма Настройка обмена данными с WEB сайтом:

Настройка обмена данными с WEB сайтом - Шаг 1

Выберите Создать новую настройку обмена с WEB-сайтом (если обмен данными уже настроен и необходимо отредактировать настройку, то выберите Изменить существующую настройку обмена с WEB-сайтом).

Нажмите кнопку Далее. Откроется второй шаг мастера:

Настройка обмена данными с WEB сайтом - Шаг 2

Заполните поля:

  • Отметьте опцию Выгрузка на сайт.
  • В поле Адрес сайта введите следующий адрес: http://<ваш_портал>/bitrix/admin/1c_intranet.php, где <ваш_портал> - это адрес вашего портала.
  • В поля Логин и Пароль введите данные пользователя, которого вы создавали в Битрикс24 в коробке на втором шаге импорта из 1С (HYPERLINK). Если специальный пользователь не был создан, то введите логин и пароль администратора портала.

    • Примечание: рекомендуется воспользоваться кнопкой Проверить перед дальнейшей настройкой, чтобы проверить правильность указанных данных и наличие соединения.

  • Если используется прокси-сервер, то установите флажок Использовать прокси-сервер, станут активными нижерасположенные поля, в которые нужно ввести данные для доступа к прокси-серверу.

Нажмите Далее. Откроется следующий шаг мастера:

Настройка обмена данными с WEB сайтом - Шаг 3

Если необходимо выгрузить всю структуру, то ничего отмечать не нужно. Для выгрузки только определенных подразделений (работников) нужно установить флаг в поле, выбрать тип сравнения и указать нужное значение.

Нажмите кнопку Далее.

Настройка обмена данными с WEB сайтом - Шаг 4

Укажите режим обмена данными:

  • Если необходимы все данные, то установите флажок Полная выгрузка данных.
  • Если необходимо только пополнить данные, то установите Выгружать только измененные объекты с момента последнего обмена.

Нажмите кнопку Далее. Откроется следующий шаг мастера. На этом шаге вы можете указать периодичность выполнения обмена данными. Если выгрузка пользователей предполагается одноразовой, то шаг пропустите.

Нажмите кнопку Готово. Откроется диалог с уведомлением о сохранении настроек и предложением провести обмен данными:

Настройка обмена данными с WEB сайтом - Шаг 5

Нажмите кнопку Да. Система проведет импорт пользователей в портал.

Функционал выгрузки сотрудников из справочника сотрудников для ЗУП 2.5

В ЗУП ред. 2.5 есть возможность одному и тому же физическому лицу назначить несколько сотрудников. Это имеет смысл, когда в одной организации один и тот же человек мог работать сразу в нескольких отделах:

До версии 1.5.5. модуля Общий модуль для релиза ЗУП 2.5 в этом случае выгружалось одно физическое лицо, но с кадровой информацией сразу о двух сотрудниках. Из за этого на КП выводилась некорректная информация о сотруднике. С версии 1.5.5. появилась возможность выгружать организационную структуру по сотрудникам, а не физическим лицам. В этом случае выгрузится два сотрудника, у каждого будет своя кадровая информация.

Для реализации этой возможности нужно включить опцию Выгружать орг структуру по сотрудникам:


Безопасная авторизация
52 / 694

Штатный инструмент безопасной авторизации

Пароли для большинства сайтов передаются в открытом виде, если не используется SSL . Отказ от использования SSL связан в большинстве случаев с административным фактором. Тем не менее проблему передачи паролей и логинов в открытом виде надо решать. Это можно сделать с помощью штатной функции Безопасная авторизация.

Безопасная авторизация - функция, обеспечивающая зашифрованную передачу пароля пользователя. Шифрование пароля не является заменой SSL. Безопасная авторизация защищает от перехвата пароля только при прослушивании трафика.

Если у злоумышленника есть возможность изменять трафик, то шифрование не поможет. При разработке функции исходили из того, что изменить трафик сложнее, чем прослушать его (тот же открытый WiFi). Более того, шифрование паролей не защищает от перехвата сессии, но у сессии есть свои механизмы защиты (привязка к IP, частое изменение кода сессии). В целом можно сказать, что уровень защиты повысился, но лучше использовать SSL.

Подключение

Подключается Безопасная авторизация в настройках главного модуля на закладке Авторизация:

Примечание: После установки флажка в чекбоксе перед генерацией ключа обязательно нажмите на кнопку Применить, сохраняющую настройки модуля. Без этого генерации ключа не произойдет.

По нажатию на Сгенерировать ключ происходит генерация ключа RSA .

Размер ключа зависит от библиотек, установленных на сервере. По умолчанию используется модуль PHP openssl, который создаёт 1024-битный ключ. Его и рекомендуется использовать. Если модуль не установлен, то возможно использование bcmath с генерацией 512-битного ключа. Если нет ни того, ни другого модуля, включить шифрование нельзя.

Генерация ключа выполняется один раз. Повторную генерацию производить необходимо, если есть подозрения в компрометации ключа.

Внимание! На браузерах клиентских компьютеров должно быть разрешено использование Javascript.

Алгоритм работы

  1. Вместе с формой авторизации клиенту передается открытый ключ.
  2. Перед отправкой формы авторизации, Javascript перехватывает отправку, зашифровывает пароль, с использованием открытого ключа, и отправляет на сервер.
  3. Сервер принимает шифротекст, расшифровывает его с использованием секретного ключа, и проводит аутентификацию пользователя.


Пример настройки прав пользователей
53 / 694

Распространенная ситуация: каждый из редакторов сайта должен отвечать за строго определенный его раздел или функционал. При этом редактор сайта не должен иметь возможность изменить что-либо в неподвластной ему части сайта.

Для решения данной задачи администратору сайта необходимо настроить права доступа соответствующим образом. Разберем это на примере (организация доступа к сайту по разделам).


Постановка задачи
54 / 694

Пусть у нас имеется сайт производственной компании, на котором помимо продажи продукции и списка оказываемых услуг выводится новостная лента фирмы, а также информация о ней в соответствующем разделе:

Нажмите на рисунок, чтобы увеличить

Постановка задачи

Распределение обязанностей:

  • администраторы интернет-магазина отвечают за размещение информации о продаваемой мебели и оказываемых услугах,
  • контент-менеджеры - за наполнение новостной ленты,
  • отдельный сотрудник - за статическую информацию о компании (история, вакансии и пр.),
  • просмотр информации о продукции, услугах и компании доступен всем посетителям,
  • Новостную ленту видят все посетители, но детальный просмотр новости доступен только подписчикам и администрации магазина.
  • Администраторы интернет-магазина могут добавлять, но не изменять или удалять новости.


Наполнение каталога товаров и услуг
55 / 694

Наполнение каталога товаров и услуг

Информация о продукции хранится в инфоблоке, из параметров компонента нам нужно узнать, в каком именно. Для этого, находясь на странице с перечнем наименований товаров, нажмите кнопку Изменить страницу .

В параметрах компонента Каталог посмотрите, из какого инфоблока берутся данные о продукции:

Нажмите на рисунок, чтобы увеличить

Теперь перейдите в административную часть сайта, на страницу настройки параметров инфоблока Контент > Информ. блоки > Типы информ. блоков > Товары и услуги > [s1]Продукция, закладка Доступ и выставьте права доступа указанным на скриншоте образом:

Выполните аналогичные действия для инфоблока услуг компании.


Наполнение новостной ленты
56 / 694

Для настройки управления новостной лентой предстоит настроить компонент и информационный блок.

Настройка компонента

В публичной части сайта перейдите в раздел Новости. Нажмите кнопку Изменить страницу и дважды щелкните по значку комплексного компонента Новости .

В открывшейся форме настроек комплексного компонента Новости перейдите к группе полей Дополнительные настройки:

Нажмите на рисунок, чтобы увеличить

Поставьте галочку в поле Использовать дополнительное ограничение доступа , после чего появится список Группы пользователей, имеющие доступ к детальной информации. Зажав клавишу Ctrl выделите в нем следующие группы:

  • Администраторы
  • Подписчики
  • Администраторы интернет-магазина
  • Контент-редакторы

Сохраните внесенные изменения.

Настройка информационного блока

Перейдите в административную часть и перейдите к закладке Доступ формы настроек инфоблока новостей. С помощью расширенного режима управления правами инфоблока надо задать право доступа для администраторов интернет-магазина Добавление:

Нажмите Сохранить для применения внесенных изменений.


Права на изменение статических страниц
57 / 694

Дать права на редактирование - означает выполнить последовательность действий по настройке различных параметров системы.

Права доступа на редактирование вообще

Дадим права доступа на редактирование информации о компании и контактах сотруднику с именем Даша, изначально не имеющей доступ к административному разделу сайта.

Перейдите в раздел Компания и нажмите Изменить раздел и выберите пункт меню Доступ к разделу .

В открывшемся окне измените право доступа для контент-редакторов на Чтение и нажмите Добавить право доступа.

В категории Пользователи поиском найдите сотрудника Дашу , кликните по ее имени левой кнопкой мыши и нажмите Выбрать, окно закроется, после чего укажите право доступа к разделу для Даши как Запись:

Произведите аналогичные действия для раздела Контакты и сохраните внесенные изменения.

Права на редактирование конкретных разделов.

Чтобы Даша могла воспользоваться своим правом записи для раздела Компания и Контакты, ей необходимо иметь право доступа на чтение к папке /bitrix/admin . Задать право доступа для папки можно для группы пользователей , поэтому перейдем на страницу административного раздела Настройки > Пользователи > Группы пользователей, и, нажав на кнопку контекстной панели Добавить группу, создадим группу Редакторы:

Заполните поля, отметьте галочкой пользователя Даша как участника данной группы и сохраните данную группу.

Затем в административном разделе пройдите на страницу Контент > Структура сайта > Файлы и папки > bitrix и выберите в меню действий папки admin пункт Права на доступ продукта . Для группы Редакторы должно быть установлено право Чтение.

Права на доступ к файловой структуре

Для редактирования страниц сайта необходимо иметь доступ к файловой структуре. Чтобы его задать для нашей созданной группы, в административном режиме перейдите на страницу Настройки > Настройки продукта > Настройки модулей > Управление структурой, закладка Доступ:

Для редакторов установите право доступа Редактирование файлов и папок и нажмите Сохранить.

Теперь пользователь Даша может редактировать страницы раздела Компания и Контакты как из административной, так и публичной части сайта.


Если пропадает авторизация пользователя
58 / 694

Если пропадает авторизация пользователя

Возможные причины проблемы:

  1. Лишние переносы строк (или иные символы) в скриптах конфигурации.

    Необходимо убедиться, что в коде файлов dbconn.php, init.php и after_connect.php, расположенных в папке bitrix/php_interface, не содержится переносов строк перед "<?" и после "?>".
  2. Файлы с сессиями продукта создаются, но PHP не хватает прав, чтобы к ним обратиться.

    Попробуйте в файле /bitrix/php_interface/dbconn.php закомментировать строку:

    //@umask(~BX_DIR_PERMISSIONS);
  3. Установлен лимит времени на бездействие пользователя, при превышении которого сессия удаляется.

    Вам необходимо в настройках группы пользователя на вкладке Безопасность увеличить значение Время жизни сессии (минут).
    Значение по умолчанию можно изменить в файле php.ini (Bitrix Environment\Apache2\zendserver\etc): параметр session.gc_maxlifetime.
  4. Значение параметра Маска сети для привязки сессии в настройках безопасности группы пользователей.

    Если оно равно, например, 255.255.255.255, то это означает, что при изменении IP пользователя авторизация будет сброшена.
  5. Значение параметра session.cookie_domain в файле php.ini на сервере.

    Если оно задано - убедитесь, что оно соответствует URL вашего сайта. Если значение параметра session.cookie_domain равно www.site.ru, а Вы обращаетесь к системе по URL site.ru, то в этом случае сессия не будет сохранена, и, соответственно, авторизация не сохранится.
    Для решения проблемы необходимо установить в настройках PHP корректное значение параметра session.cookie_domain.
  6. Неверно прописан домен в настройках главного модуля и для сайта отдельно.

    Проверьте значение поля URL сайта на странице административного режима Настройки > Настройки продукта > Настройки модулей > Главный модуль.
    Проверить значение поля URL сервера можно, открыв настройки нужного сайта на странице административного раздела Настройки > Настройки продукта > Сайты > Список сайтов.

    Примечание: также одной из причин может быть некорректное значение в параметрах сайта поля Путь к корневой папке веб-сервера для этого сайта, либо Доменное имя. Доменное имя можно сменить или удалить путем внесения изменений в файл /hosts.
  7. При переносе сайта не скопировался файл /.access.php.

    В данном файле хранятся права групп пользователей к сайту, и если данного файла нет, то для всех пользователей право доступа устанавливается как Запрещен.

    Проблема решается одним из способов:

    • вам надо на странице административного раздела Контент > Структура сайта > Файлы и папки в меню действий корневой папки сайта выбрать пункт Свойства папки и на вкладке Доступ установить для группы Все пользователи (в том числе неавторизованные) право Чтение;
    • в корневую папку сайта загрузить файл .access.php со следующим содержанием:
      <? $PERM["/"]["*"]="R"; ?>
  8. При многосайтовости вас выкидывает на форму авторизации при переходе по публичным страницам сайта.

    Проверьте содержимое файла .access.php на идентичность следующему коду:

    <?
$PERM["/"]["*"]="R";
?>

  9. Авторизация не учитывается на вашем домене.

    На закладке Авторизация страницы настроек главного модуля (Настройки > Настройки продукта > Настройки модулей > Главный модуль) поставьте галочку в поле Распространять авторизацию на все домены.
  10. Проблема в работе сервера (нужна поддержка сессий в php, должна быть указана папка сохранения сессий и права на запись в эту папку).

    Проверьте исправность работы сервера с сессиями с помощью данного скрипта и в случае наличия неполадок обратитесь к администратору сервера.

Примечание: если работа в административном режиме прерывается появляющейся формой авторизации, то чтобы дать себе возможность что-то поправить в настройках сайта, после авторизации не совершайте никаких действий порядка 10-30 секунд, и, возможно, форма авторизации не появится.


Регистрация по номеру телефона
59 / 694

Регистрация по номеру телефона

Начиная с версии 18.5.0, в "1С-Битрикс: Управление сайтом" появились возможность регистрироваться и восстанавливать пароль по СМС. Теперь при регистрации наравне с почтовым ящиком можно использовать и номер мобильного телефона.

Рассмотрим пошагово, как настроить этот полезный функционал:

  1. Сначала установите и настройте модуль Служба сообщений, привязав одну из служб сообщений.
  2. Далее укажите в настройках Главного модуля службу отправки СМС по умолчанию и выберите соответствующий номер отправителя (Настройки >Настройки продукта > Настройки модулей > Главный модуль (Почта и СМС)):

  3. И в завершении перейдите на вкладку Авторизация и разрешите регистрацию пользователей по номеру телефона, при необходимости сделав это поле обязательным (Настройки >Настройки продукта > Настройки модулей > Главный модуль (Авторизация)):

    Подробнее о настройке остальных полей (по желанию) можете прочитать в документации по продукту.

    Примечание: Не забудьте, что в России при сборе личных данных требуется обязательное согласие пользователя на обработку его персональных данных, поэтому настройте соглашение на обработку персональных данных (можете выбрать существующее соглашение или создать новое ).

Готово! Теперь регистрация пользователей будет осуществляться по номеру мобильного телефона.

Вид в публичном разделе
  1. Форма регистрации:

  2. Восстановление пароля:

Документация по теме:

  • Настройки главного модуля (закладка "Почта и СМС")
  • Настройки главного модуля (закладка "Авторизация")


Как восстановить пароль администратора
60 / 694

Как восстановить пароль администратора

Несомненно, администратор сайта должен обладать хорошей памятью. Особенно если сайтов много. И для каждого сайта свой пароль. И занимается администратор сайтами не одновременно, а периодически.

Но в какой-то момент может оказаться так, что один из паролей все-таки будет подзабыт. В такой ситуации можно восстановить пароль администратора одним из нижеперечисленных способов.

Способ первый

  1. Пароль восстанавливается для пользователя с ID=1 (т.к. это первый пользователь, зарегистрированный в системе, и в связи с этим обладающий правами администратора). Поэтому для начала вспомните, какой логин был у этого пользователя (по умолчанию устанавливается admin).
  2. Далее сохраните следующий скрипт в php-файл c любым именем:
    <?
require($_SERVER['DOCUMENT_ROOT']."/bitrix/header.php");
echo $USER->Update(1,array("PASSWORD"=>'Bitrix*123456'));
echo $USER->LAST_ERROR;
require($_SERVER['DOCUMENT_ROOT']."/bitrix/footer.php");
?>
  3. Закачайте созданный скрипт через FTP в корневой каталог сайта www/имя сайта/... и откройте его в браузере . После этого у пользователя с ID=1 (по умолчанию - администратор) установится пароль: Bitrix*123456
  4. Теперь авторизуйтесь на сайте под прежним логином (см. п. 1) и стандартным паролем (см. п. 3). В панели управления установите свой новый пароль.

Если доступ для неавторизованных пользователей закрыт, то перед процедурой восстановления пароля надо поправить файл .access.php в корне сайта, заменив:

$PERM["/"]["*"]="D";
на:
$PERM["/"]["*"]="R";

Внимание! Обязательно удалите залитый файл со скриптом после восстановления пароля, а также верните все внесенные изменения!

Способ второй

  1. Cохраните следующий скрипт в php-файл c любым именем:
    <?
require($_SERVER["DOCUMENT_ROOT"]."/bitrix/modules/main/include/prolog_before.php");

global $USER;
$USER->Authorize(1);

require($_SERVER["DOCUMENT_ROOT"]."/bitrix/modules/main/include/epilog_after.php");
?>
  2. Закачайте созданный скрипт через FTP в корневой каталог сайта www/имя сайта/... и откройте его в браузере.
  3. Зайдите на сайт (при этом ни логин, ни пароль не будут запрашиваться), и в административном разделе для своей учетной записи установите пароль.

Внимание! Обязательно удалите залитый файл со скриптом после восстановления пароля!

Дополнительно

Изучите дополнительно:

  • Как закрыть доступ к сайту другому администратору


Как создать форму авторизации (регистрации) на простых компонентах
61 / 694

В этом уроке разберем, как штатными способами без кастомизации компонентов и изменения шаблона сайта создать форму регистрации с нужными именно вам полями.

Суть работы заключается в размещении простых компонентов на четырех страницах:

  • /auth/index.php - существующая страница раздела /auth;

    • Создаваемые страницы:
  • /auth/registration.php - страница регистрации;
  • /auth/forget.php - страница забытого пароля (восстановления пароля);
  • /auth/personal.php - страница профиля (личных данных пользователя).

  1. Сначала нужно отключить запрос стандартной авторизации. Откроем страницу /auth/index.php (Контент > Структура сайта > Файлы и папки > auth) в режиме редактирования PHP.

    Удалим строку define("NEED_AUTH", true); (или можно её отключить, прописав в начале //):

  2. Далее нужно удалить всю имеющуюся информацию на странице авторизации (/auth/index.php) и разместить два компонента:
    • Форма авторизации (system.auth.form)
    • Форма подтверждения регистрации (system.auth.confirmation)

    В дополнительных настройках компонента Форма авторизации (system.auth.form) укажем адреса трех создаваемых страниц (регистрации, забытого пароля и профиля):

    Компонент Форма подтверждения регистрации (system.auth.confirmation) можно не настраивать.

  3. Теперь приступим, собственно, к созданию трех необходимых страниц и размещению на них соответствующих компонентов.
    • /auth/registration.php - страница регистрации;

      Разместим на этой странице компонент Настраиваемая регистрация (main.register). При желании можно в настройках этого компонента выбрать поля, которые должны отображаться в форме, а также обязательные для заполнения поля.

    • /auth/forget.php - страница забытого пароля (восстановления пароля);

      На этой странице нужно разместить системный компонент system.auth.forgotpasswd, но сделать это можно только не совсем привычным способом.

      Сначала разместим компонент Форма авторизации (system.auth.form).

      Теперь в административном разделе изменим эту страницу (Контент > Структура сайта > Файлы и папки > auth) в режиме редактирования PHP. Вместо system.auth.form пропишем system.auth.forgotpasswd в соответствующей строке. Должно получиться так:

      После этого на странице /auth/forget.php будет подключен компонент восстановления пароля.

    • /auth/personal.php - страница профиля (личных данных пользователя).

      Разместим на этой странице компонент Параметры пользователя (main.profile). В настройках этого компонента можно выбрать поля, которые будут отображаться в форме.

  4. Теперь в настройках Главного модуля (Настройки > Настройки продукта > Настройки модулей > Главный модуль) укажем Страницу регистрации (для системного компонента авторизации): /auth/registration.php

  5. Наконец, пропишем адреса созданных страниц в настройках компонента, выводящего ссылки на авторизацию и личный кабинет. В данном случае, это sale.basket.basket.line :

Готово! Форма регистрации и авторизации создана, и в настройках используемых компонентов можно выбрать те поля, которые нужны именно вам.

Документация по теме:

  • Как изменить стандартную форму авторизации (регистрации)? (способ с кастомизацией компонента и изменением шаблона сайта)
  • Компонент Форма авторизации (system.auth.form)
  • Компонент Форма подтверждения регистрации (system.auth.confirmation)
  • Компонент Настраиваемая регистрация (main.register)
  • Компонент Параметры пользователя (main.profile)
  • Компонент Ссылка на корзину (sale.basket.basket.line)


CAPTCHA
62 / 694

CAPTCHA (от англ. "Completely Automated Public Turing test to tell Computers and Humans Apart" - "полностью автоматизированный публичный тест Тьюринга для различия компьютеров и людей") - компьютерный тест, используемый для того, чтобы определить, кем является пользователь системы: человеком или компьютером. Основная идея теста: предложить пользователю такую задачу, которую с лёгкостью может решить человек, но которую несоизмеримо сложнее решить компьютеру. В основном это задачи на распознавание символов.

В этой главе вы узнаете, как оградить свой сайт от ботов , просто настроив CAPTCHA.


Настройка CAPTCHA
63 / 694

Внимание! Для работы CAPTCHA на сервере должна быть установлена библиотека FreeType library и Библиотека GD (функции imagecreatetruecolor и imagejpeg). Проверить их наличие можно на странице Проверка системы .

Настройка CAPTCHA

Форма Настройка CAPTCHA (Настройки > Настройки продукта > CAPTCHA) предназначена для настройки защиты от автоматических регистраций .

Нажмите на рисунок, чтобы увеличить

В поле Профиль можно выбрать уже готовые настройки или же можно вручную задать параметры отображения CAPTCHA в последующих полях .

CAPTCHA необходимо настраивать так, чтобы исключить, по возможности, автоматическое распознавание. Но необходимо искать компромисс между защитой от спама и неудобством для посетителей. Рекомендуемые параметры:

  • прозрачность текста в процентах - 40-50%,
  • угол отклонения от вертикали - от -30 до 30,
  • добавить нелинейные искажения,
  • шрифт лучше поменять на bitrix_captcha.ttf или какой-то другой не очень распространенный.

Чтобы при этом пользователи не сильно страдали, допустимые символы можно ограничить только цифрами.

Ниже даны примеры CAPTCHA, затрудняющие автоматическое распознавание:


Подключение CAPTCHA
64 / 694

После настройки основных параметров необходимо подключить CAPTCHA. Существует несколько вариантов подключения:

  • Подключение CAPTCHA в настройках модуля
  • Подключение CAPTCHA в параметрах компонента
  • Настройка показа CAPTCHA в формах
  • Подключение CAPTCHA в своих скриптах, модулях или компонентах

Подключение CAPTCHA в настройках модуля

В ряде модулей (Главный, Блоги, Wiki и других) CAPTCHA подключается прямо в настройках модуля. Например, опция Использовать CAPTCHA при регистрации в настройках Главного модуля позволяет включить использование CAPTCHA при регистрации новых пользователей:

Настройки главного модуля

Подключение CAPTCHA в параметрах компонента

CAPTCHA возможно подключить и для отдельных компонентов , например, Добавление элементов инфоблока (комплексный компонент), Каталог (комплексный компонент) и других. Рассмотрим пример использования CAPTCHA в компоненте Форма обратной связи, где опция Использовать защиту от автоматических сообщений (CAPTCHA) для неавторизованных пользователей позволяет включить CAPTCHA только для данного компонента:

Параметры компонента "Форма обратной связи"

Настройка показа CAPTCHA в формах

Использование CAPTCHA в формах создания/редактирования ограничивается в политике безопасности группы пользователей. Опция Количество попыток ввода пароля до показа CAPTCHA позволяет задать количество неправильных попыток ввода пароля, после которых будет в форме авторизации выводиться CAPTCHA для пользователя из соответствующей группы:

Внимание! Если в шаблоне компонента не предусмотрен вывод CAPTCHA, то возможна ситуация, когда система (при малом значении в поле Количество попыток ввода пароля до показа CAPTCHA) как бы "забывает" пароль пользователя не давая ему авторизоваться в системе. При этом при входе в административную часть (ваш_сайт/bitrix/admin/) авторизация осуществляется.

Это происходит потому, что при последовательном неправильном наборе пары логин/пароль и при малом значении в поле Количество попыток ввода пароля до показа CAPTCHA) система ждёт ввода верного кода CAPTCHA. А пользователь этого не делает, так как шаблон не предусматривает вывод CAPTCHA.

Подключение CAPTCHA в своих скриптах, модулях или компонентах

Для начала создайте саму CAPTCHA :

01      <?include_once($_SERVER["DOCUMENT_ROOT"]."/bitrix/modules/main/classes/general/captcha.php");
02	$cpt = new CCaptcha();
03	$captchaPass = COption::GetOptionString("main", "captcha_password", "");
04	if(strlen($captchaPass) <= 0)
05	{
06	    $captchaPass = randString(10);
07	    COption::SetOptionString("main", "captcha_password", $captchaPass);
08	}
09	$cpt->SetCodeCrypt($captchaPass);
10	?>

После этого выводите в нужном месте формы три элемента: скрытое поле со сгенерированным кодом, поле для ввода капчи пользователем и саму картинку.

<input name="captcha_code" value="<?=htmlspecialchars($cpt->GetCodeCrypt());?>" type="hidden">
<input id="captcha_word" name="captcha_word" type="text">
<img src="/bitrix/tools/captcha.php?captcha_code=<?=htmlspecialchars($cpt->GetCodeCrypt());?>">

В скрипте, на который сабмитится форма, добавьте проверку:

01      <?
02      if(!$APPLICATION->CaptchaCheckCode($_POST["captcha_word"], $_POST["captcha_code"]))
03	{
04	    // Неправильное значение
05	}
06	else
07	{
08	    // Правильное значение
09	}
10	?>

Документация по теме:

  • CAPTCHA


AD/LDAP интеграция
65 / 694

При проведении интеграции продуктов компании «1С-Битрикс» с информационной системой организации часто возниканет потребность в разграничении прав сотрудников компании на доступ к ресурсам корпоративного портала или сайта и его управлению. Стандартным решением данной задачи является создание нескольких групп пользователей Bitrix Framework с различным уровнем и распределение сотрудников по этим группам.

Модуль AD/LDAP интеграция позволяет исключить повторные операции и сократить затраты времени и труда на управление группами пользователей корпоративной информационной системы. С его помощью можно установить соответствие между группами пользователей корпоративной сети и группами пользователей Bitrix Framework, что позволяет организовать централизованное управление всеми группами пользователей корпоративной информационной системы.


Назначение и возможности модуля
66 / 694

Что может модуль LDAP

AD/LDAP модуль реализован с учетом особенностей работы протоколов LDAP и AD , один из которых должен быть установлен на корпоративном сервере.

В основе работы перечисленных протоколов лежит принцип хранения информации в виде записей, обладающих набором атрибутов и хранящихся в базе данных с древовидной иерархической структурой. Таким образом, при настройке на сервере локальной вычислительной сети LDAP или AD протокола информация о группах пользователей будет представляться в следующем виде:

Используя данную структуру хранения данных, модуль AD/LDAP позволяет настраивать соответствие групп пользователей корпоративной сети группам пользователей Bitrix Framework.

Модуль позволяет подключаться к нескольким AD. Обращение к AD серверу происходит при каждой авторизации пользователя, либо при импорте пользователей.

Таблица соответствий

Соответствие групп пользователей задается в специальной таблице соответствий в административном разделе Bitrix Framework. При этом возможно несовпадение имен групп пользователей Bitrix Framework с именами групп пользователей корпоративной сети. Например, группе пользователей корпоративной сети Techsupport, к которой относятся сотрудники технической поддержки корпоративной сети, может быть поставлена в соответствие группа пользователей Techsupport stuff, созданная в Bitrix Framework. В результате сотрудники службы технической поддержки корпоративной сети смогут выполнять обязанности сотрудников службы технической поддержки Bitrix Framework.

Группы пользователей внутри компании обладают правами на доступ к определенным ресурсам корпоративной сети, а сопоставленные им группы пользователей в Bitrix Framework обладают правами на доступ к ресурсам продукта «1С-Битрикс». Например, группа пользователей Techsupport наделена правами на доступ к почтовому серверу сети, а группа пользователей Bitrix Framework Techsupport stuff обладает правами на доступ к модулю Техническая поддержка.

В соответствии с приведенным выше примером, пользователь, относящийся к группе Techsupport корпоративной сети, при попытке авторизации в системе Bitrix Framework будет добавлен в группу пользователей Techsupport stuff системы Bitrix Framework. После чего в системе автоматически будет заведен аккаунт данного пользователя, на основе данных, хранящихся на корпоративном сервере.

Пользователь в нескольких группах

Допустима привязка пользователя к одной, двум или более группам. В системе могут быть настроены группы пользователей, для которых не установлено соответствие с группами пользователей в корпоративной сети. Принадлежность пользователей к такой группе задается вручную администратором системы. Все изменения аккаунта пользователя на корпоративном сервере будут автоматически учтены в аккаунте пользователя в системе Bitrix Framework во время его следующей авторизации. При этом изменения затронут пользователей только тех групп, для которых задано соответствие группам пользователей корпоративной сети.

Итак:

Модуль AD/LDAP позволяет:

  • интегрировать проекты, созданные на Bitrix Framework в корпоративную сеть;
  • Импортировать пользователей корпоративной сети в продукты Bitrix Framework;
  • настроить соответствие групп пользователей корпоративной сети и групп пользователей Bitrix Framework;
  • автоматически создавать аккаунт пользователя после его регистрации исходя из таблицы соответствий (данные для создания аккаунта запрашиваются из базы данных корпоративного сервера);
  • централизованно управлять изменениями аккаунтами пользователей системы через корпоративный сервер.

Модуль AD/LDAP интеграция так же позволяет использовать NTLM авторизацию . Чтобы ею воспользоваться, нужен веб-сервер IIS или Apache с модулем mod_ntlm или mod_auth_sspi.


Схема работы модуля
67 / 694

Как это работает

Общая схема работы модуля описывается следующей последовательностью действий:

  1. Пользователь проходит авторизацию в системе Bitrix Framework (вводится логин и пароль, используемые пользователем для авторизации в корпоративной сети);
  2. Система обращается к указанному в настройках AD/LDAP серверу и проверяет наличие пользователя с указанными данными (паролем и логином) в базе пользователей на корпоративном сервере:
    • если пользователя с такими данными в корпоративной сети не существует , то система запрещает вход;
    • если пользователь существует, то определяется группа пользователей корпоративной сети , к которой он относится, и сопоставленная ей группа пользователей Bitrix Framework (с помощью таблицы соответствий).
  3. Далее проверяется наличие аккаунта пользователя в системе:
    • если аккаунт не найден, то система получает данные о пользователе из базы данных корпоративного сервера и создает его аккаунт;
    • если аккаунт в системе уже был создан, т. е. пользователь уже авторизовался в Bitrix Framework, то система проверяет, были ли выполнены какие-либо изменения в профиле пользователя на корпоративном сервере. Если да, то соответствующие изменения выполняются и с профилем пользователя в Bitrix Framework.
  4. Пользователь получает разрешение на доступ к ресурсам Bitrix Framework и авторизуется. Права пользователя определяются в зависимости от настроек группы пользователей Bitrix Framework, к которой он был приписан.


Настройка модуля
68 / 694

Настройки

Перейдите на страницу Настройки модуля (Настройки > Настройки продукта > Настройки модулей > AD/LDAP интеграция).

Нажмите на рисунок, чтобы увеличить

Далее опишем поля, заполнение которых может вызвать затруднения.

  • Если используется NTLM авторизация, то установите флажок в поле Использовать NTLM авторизацию.

    Примечание: Для работы NTLM авторизации требуется выполнить настройку соответствующих модулей веб-сервера , а также задать домены для NTLM авторизации в настройках AD-серверов на сайте.

  • Если в силу каких-то причин для хранения логина пользователя вы используете другую переменную массива $_SERVER, то укажите эту переменную в поле Имя переменной PHP, в которой хранится логин пользователя NTLM. Учтите, что большинство модулей продукта используют именно переменную REMOTE_USER .
  • Если в локальной сети несколько LDAP-серверов, то в поле Сервер домена по умолчанию укажите тот, который используется для NTLM-авторизации.
  • Снятый флажок на опции Создавать новых пользователей при первой удачной авторизации при использовании протокола AD позволяет "зафиксировать" пользователей, имеющих доступ к сайту. Например, создается пять учетных записей, снимется флажок с опции и вход в систему имеют только указанные пять пользователей.
  • С помощью опции Создавать пользователя, если пользователь с таким логином уже существует указывается, будет ли создаваться второй пользователь, если при импорте обнаруживается пользователь с таким логином.
  • Также, при необходимости, настройте переадресацию NTLM авторизации на 8890 и 8891 порты.

Примечание: необходимо помнить, что компьютер, на котором размещен сервер Apache, должен быть включен в домен Windows.

Примечание: в некоторых случаях при работе с Internet Explorer старых версий возможны ситуации сбоя в работе продуктов "1С-Битрикс". Проблема выражается в сбое в работе кнопок в административной и публичных частях. Для решения этой проблемы добавьте в корневой файл .htaccess строку
SSPIPerRequestAuth On

Документация по теме:

  • Настройки модуля


Принадлежность пользователей к подразделениям на AD-сервере
69 / 694

Кто есть кто в иерархии компании

Необходимо специальным образом определить на AD-сервере принадлежность пользователей к подразделениям, иерархию подразделений компании, а также начальников подразделений. При импорте пользователей в продукты «1С-Битрикс», эта структура также может быть импортирована, при этом пользователям сразу назначаются нужные подразделения. Также, что более просто, можно задать одно фиксированное подразделение всем пользователям из AD.

Для задания структуры компании в AD используются всего 2 специальных атрибута пользователя :

  • department - символьное наименование подразделения, к которому относится данный пользователь.
  • manager - DN (Distinguished name, уникальный идентификатор в AD) пользователя, являющегося начальником данного.

На основании этой связи и строится иерархия компании:

  • Если начальник находится в другом подразделении, то это определяет связь между подразделениями: подразделение manager'а считается вышестоящим над данным. При этом текущий пользователь будет считаться начальником своего подразделения.
  • Если manager - в том же подразделении, то никаких дополнительных действий предпринято не будет, и это единственный способ явно указать, что пользователь сам не является начальником подразделения. Из чего можно сделать вывод, что для всех подчиненных в подразделении должен быть задан начальник из него же.
  • Если у пользователя не задано подразделение, но задан начальник, он считается принадлежащим тому же подразделению, что и начальник. Для начальника будут также действовать все те же правила и умолчания, так что такие "умолчательные" определения могут выстроиться в последовательную цепочку.
  • Если задано подразделение, но нет начальника - данное подразделение попадает в корень структуры компании, и пользователь сам будет его начальником.
  • Если же у пользователя нет ни подразделения, ни начальника, ему будет присвоено подразделение по умолчанию, задаваемое в настройках модуля.

Пример

Допустим, у нас существует следующая структура:

- Отдел 1
-- Начальник 1
-- Сотрудник 1
-- Отдел 2
   -- Начальник 2
   -- Сотрудник 2

Чтобы построилась такая иерархия, нужно чтобы у всех сотрудников корректно были заданы подразделения, в которых они работают (в атрибуте department), а также, чтобы у обоих сотрудников в поле manager был указан их непосредственный начальник (Начальник 1 и Начальник 2 соответственно). И самый важный момент, у Начальник 2 в атрибуте manager должен быть указан Начальник 1.


Регистрация сервера
70 / 694

Запись о сервере

Создание записи об AD/LDAP сервере выполняется в административном разделе Bitrix Framework, в которой указываются все необходимые сведения о сервере и соответствия групп пользователей.

Каждая запись регламентирует доступ к одному корню дерева каталогов. Если сведения о группах пользователей корпоративной сети хранятся в базах данных нескольких серверов или в нескольких базах данных одного сервера, то следует создать несколько записей, регламентирующих доступ к ним.

  1. Перейдите на страницу Active Directory/LDAP серверы (Настройки > AD/LDAP) и нажмите кнопку Добавить, расположенную на контекстной панели. Откроется форма создания новой записи.

  2. На закладке Сервер указываются сведения о корпоративном сервере и параметры доступа к базе данных групп пользователей, расположенной на нем. Опишем поля, заполнение которых может вызвать затруднения.

    Форма создания новой записи об AD/LDAP сервере

    • Домен для NTLM авторизации - используется для определения нужного AD/LDAP сервера при авторизации в виде домен\логин (задается на латинице), а также при автоматической NTLM авторизации (должно соответствовать домену организации, включая регистр).

      Такой вид будет указывать на конкретную запись, в соответствии с которой должен быть осуществлен поиск аккаунта пользователя на корпоративном сервере.

      Если имеется несколько LDAP-серверов, то использование этого поля становится необходимым, так как на разных серверах могут быть пользователи с одинаковым именем. В этом случае с помощью мнемонического имени будет определяться запись, указывающая на сервер и корень дерева каталогов, в котором следует искать аккаунт, используемый для его авторизации в Bitrix Framework.

      Если в настройках нескольких серверов указан один и тот же домен, то с версии 15.0 обращение происходит не к первому подходящему, а перебираются все подходящие сервера.

    • Сервер:порт - адрес и порт корпоративного сервера с базой данных групп пользователей (389 порт является стандартным для обращения к LDAP серверу).
    • Логин пользователя с правами доступа на чтение к дереву - укажите логин для выполнения административного входа на сервер в формате логин@домен или домен\логин.
    • Кнопка Проверить - для проверки введенных выше данных и установления пробного соединения с сервером. Если проверка произведена успешно , то сервер возвратит список доступных корней деревьев. Если же при проверке произошла ошибка, то вверху страницы будет выведена надпись красного цвета с указанием причины ошибки.
    • Корень дерева - укажите корень дерева каталогов, в котором будет осуществляться поиск бюджетов авторизуемых пользователей.
    • Максимальное количество объектов, возвращаемых при одном поиске - укажите максимальное количество записей , получаемых за один запрос.
  3. На закладке Настройка полей указываются значения параметров для схемы данных бюджетов пользователей, хранимых на сервере. Стандартные значения параметров как для LDAP, так и для AD сервера подставляются в поля формы автоматически. Выбор типа сервера осуществляется путем нажатия ссылки с соответствующим названием в заглавии раздела.

    Если вам необходимо добавить поля в группу Соответствие полей пользователя и атрибутов AD (LDAP) , то воспользуйтесь ссылкой [добавить…]. В настройках LDAP-сервера необходимо указывать минимально необходимые поля, такие как Активность, Имя, Фамилия, E-Mail адрес, т.е. поля которые необходимо постоянно переносить (синхронизировать из AD). Остальные поля можно настроить при импорте в форме импорта пользователей .

    Каждое из полей, добавленное в эту группу будет проверяться на изменения при синхронизации и, при несоответствии, изменяться на стороне продукта "1С-Битрикс". То есть, если пользователь изменил какое-либо поле в своем профиле, то при последующей синхронизации полю будет возвращено прежнее значение.

    Поэтому рекомендуется при первичном импорте пользователей добавить максимально возможное число полей, а после импорта, если используется периодическая синхронизация, удалить поля, которые не нуждаются в периодической проверке.

    Отделы и структура компании

    Эта секция отображается только при редактировании уже созданного подключения и если установлен модуль Intranet. Она позволяет настроить параметры импорта структуры компании в Bitrix Framework. Поясним некоторые поля.

    Значения параметров для LDAP сервера

    • Укажите Подразделение, внутрь которого будет импортирована структура компании с AD-сервера. Указание фиксированного места для импорта очень полезно, если в компании несколько филиалов, каждый со своим сервером. Тогда в структуре компании можно вручную создать подразделение для каждого филиала, и в настройках каждого сервера выбрать свое.

      Если выбрать нет, то структура будет импортироваться в корень дерева подразделений.

      Если при импорте имена подразделений в AD совпадут с существующими в системе - будут использованы существующие подразделения.

    • Используйте опцию Импортировать в структуру компании пользователей, у которых не указано подразделение для того, чтобы пользователи, у которых не указано подразделение в Active Directory, также импортировались в структуру Bitrix Framework. Импортироваться они будут в подразделение указанное в поле Название подразделения по умолчанию .
  4. На закладке Группы осуществляется загрузка групп пользователей корпоративной сети и Bitrix Framework в таблицу соответствий и задание соответствий этих групп.
    • Чтобы добавить названия групп пользователей в таблицу, нужно нажать кнопку Обновить список групп . После обновления списка групп пользователей в данном разделе отобразится таблица соответствий:

    Настройка соответствий групп

    • Соответствие задаётся выбором в поле Группа на удаленном сервере групп пользователей корпоративной сети и выбором соответсвующей группы пользователей Bitrix Framework в поле Локальная группа. Таким образом, в одной строке таблице будет размещена группа пользователей корпоративной сети и поставленная ей в соответствие группа пользователей Bitrix Framework.
    • Для удаления строки соответствия из таблицы, установите флажок в поле Удалить и нажать кнопку Применить.
    • В поле Отмеченные ниже группы не участвуют в импорте пользователей укажите группы, которые не должны участвовать в импорте, даже если они выбраны в качестве источника в колонке Группа на удаленном сервере.

      Если необходимо пользователей из одной и той же группы на сервере прописать в две разные локальные группы системы Bitrix Framework, то выберите эту группу в колонке Группа на удаленном сервере несколько раз и для каждой строки назначьте свои группы в колонке Локальная группа.

      Если в качестве Локальной группы в двух строках выбрана одна из имеющихся групп, а в Группах на удаленном севере – две разных, то в локальную группу добавятся только те пользователи, которые есть в обеих группах.

  5. Периодическая синхронизация баз настраивается на закладке Синхронизация:

    • Для активации полей настройки синхронизации поставьте флажок в поле Выполнять периодическую полную синхронизацию.
    • Значение в поле Период, каждые зависит от частоты, с которой изменяются профили сотрудников в вашей компании.
    • Введите атрибут LDAP атрибут с датой изменения для ведения лога изменений. (Или оставьте по умолчанию.)

      Для периодической синхронизации удобно использовать Агенты - технология, позволяющая запускать необходимые функции во время обычной жизни системы без использования каких-либо внешних программ. Подробней об использовании агентов смотрите в пользовательской документации продукта.

  6. После сохранения запись будет добавлена в список на странице Active Directory/LDAP серверы.

    Для изменения или удаления записи нужно выбрать соответствующий пункт в меню действий выбранной записи.

Документация по теме:

  • Создание и редактирование сервера


NTLM авторизация
71 / 694

NTLM авторизация позволяет входить на сайт/портал без ввода логина/пароля (используя данные авторизации Windows на AD сервере).


Настройка NTLM авторизации со стороны продукта
72 / 694

Пошаговая настройка

  1. Зарегистрируйте в системе AD/LDAP-сервер .
  2. При регистрации сервера обязательно укажите значение в поле Домен для NTLM авторизации . Он должен полностью (включая регистр) совпадать с названием домена.

  3. В настройках модуля отметьте опцию Использовать NTLM авторизацию . Если в силу каких-то причин для хранения логина пользователя вы используете другую, не REMOTE_USER, переменную массива $_SERVER, то в поле Имя переменной PHP, в которой хранится логин пользователя NTLM измените имя переменной на нужное. Помните при этом, что большинство модулей продукта используют именно переменную REMOTE_USER .

    Если в локальной сети несколько LDAP-серверов, то в поле Сервер домена по умолчанию выберите тот, который используется для NTML-авторизации. Даже если LDAP-сервер один, то все равно желательно указать значение этого поля, чтобы сотрудникам не требовалось вводить домен при первом входе в Bitrix Framework.

  4. Настройте на NTLM авторизацию на серверах Apache и IIS .
  5. Произведите настройку браузеров сотрудников .

Документация по теме:

  • Настройка NTLM-авторизации (учебный курс "Виртуальная машина BitrixVM")
  • BitrixVM3.1 с поддержкой NTLM авторизации (блог)
  • Новая версия BitrixEnv4 и BitrixVM4 (Настройка NTLM авторизации пользователей) (блог)
  • NTLM авторизация в нескольких базах данных одного сервера AD (форум)

    Внимание! Статья предполагает изменение файлов ядра, это может привести к нестабильной работе, а также потери права на техническую поддержку.


Настройка NTLM-авторизации для Apache
73 / 694

Поддержка NTLM-авторизации по умолчанию включена в дистрибутив продукта. Для этого рекомендуется использовать виртуальную машину VMBitrix, в ней настройка окружения для NTLM-авторизации выполняется через меню.

Если вы не используете рекомендуемый компанией "1С-Битрикс" пакет, то вам необходимо в настройках вашего окружения сделать следующее:

Для Centos 6

  1. Загрузите модуль mod_auth_sspi.
  2. Скопируйте его в папку c:\<путь_до_папки>\apache\modules\.
  3. В файле httpd.conf добавьте строку:
    LoadModule sspi_auth_module modules/mod_auth_sspi.so.
  4. В файле .htaccess добавьте следующие строки:
    AuthName "My Intranet"
AuthType SSPI
SSPIAuth On
SSPIPackage NTLM
SSPIDomain MYDOMAIN
SSPIPerRequestAuth On
SSPIAuthoritative On
SSPIOfferBasic On
Require valid-user

    При использовании стандартного пакета Битрикс: Веб-окружение указанные строчки в этом файле необходимо не создавать, а раскомментировать.

Для Centos 7

  1. Загрузите модуль auth_ntlm_winbind_module и установите его:

  LoadModule auth_ntlm_winbind_module modules/mod_auth_ntlm_winbind.so
  2. Для SSL обязательно добавьте:

  LoadModule ssl_module modules/mod_ssl.so
  # httpd 2.4
  LoadModule socache_shmcb_module modules/mod_socache_shmcb.so

Для всех видов установки

  1. В строке SSPIDomain MYDOMAIN файла .htaccess смените MYDOMAIN на имя вашего домена.
  2. Сохраните внесенные изменения.


Настройка NTLM-авторизации для IIS
74 / 694

Настройка авторизации при использовании IIS сервера производится аналогично настройкам на Linux . Подразумевается что, IIS при этом уже настроен на работу с PHP.

Для включения поддержки NTLM-авторизации для IIS выполните следующие действия:

  1. Откройте Диспетчер служб IIS;
  2. Перейдите к нужному сайту в левой части диспетчера;
  3. Выберите Проверка подлинности в основной области диспетчера служб IIS;
  4. В открывшимся списке включите опцию Проверка подлинности Windows.

Далее нужно настроить порты: 8890 (для http) или 8891 (для https) и 80 (для http) или 443 (https).

Документация по теме:

  • Windows Authentication (www.iis.net)


Настройка NTLM модуля Linux для Битрикс
75 / 694

Как настроить NTLM для Linux вне BitrixVM

Если вы не используете Виртуальную машину BitrixVM или Linux (BitrixEnv), то вам необходимо настроить ваше окружение для работы с модулем AD/LDAP "1С-Битрикс: Управление сайтом" или "Битрикс24 в коробке". Для этого вам нужно выполнить действия:

  1. Добавить хост в домен. (Описания не будет, если вы работаете на собственном окружении, вы знаете как это сделать.)
  2. Задать настройки сервера Apache под выбранный сайт.
  3. Произвести настройки NTLM модуля вашего окружения.
  4. Произвести настройки "1С-Битрикс: Управление сайтом".

Если хост уже находится в домене, и на нем находится несколько сайтов, то создайте настройки Apache сервера для сайтов, у которых не включена авторизация в домене.

Важно:
  1. Нельзя подключить разные сайты к разным доменам, так как хост единовременно находится только в одном домене.
  2. Если на сайте не установлен модуль LDAP, такой сайт нельзя авторизовать через NTLM.

Настройка NTLM авторизации

Для настройки NTLM необходимо задать в настройках вашего окружения следующую информацию:

Что нужно сделать
Netbios domain name (TEST) | Netbios имя домена (по стандарту не может быть больше 15 символов);
Full domain name (TEST.LOCAL) | FQDN имя для домена (будет использовано как realm в настройках kerberos);
Domain password server | FQDN имя или IP адрес сервера авторизации;
Domain admin user name | пользователь в AD, обладающий правами добавления машин в AD;
Domain admin user password | пароль пользователя;
Enter site name (default) | для какого сайта необходимо создать настройки у apache.

После того как все опции введены, запустите команду по настройке системы. Выполнение может занять некоторое время. После успешного завершения настроек должна появится информация о доменных настройках хоста.

Теперь переходите к настройкам NTLM со стороны "1С-Битрикс: Управление сайтом".


Настройка браузеров сотрудников
76 / 694

Internet Explorer

Для успешной NTLM авторизации нужно, чтобы веб-сервер находился в зоне Local Intranet.

Нажмите на рисунок, чтобы увеличить

Mozilla Firefox

Добавить веб-сервер к списку доверенных URI для автоматической NTLM-авторизации (через параметр network.automatic-ntlm-auth.trusted-uris на странице about:config)


Проблемы и решения
77 / 694

Частые проблемы и как их решить

  • После изменения профиля AD пользователя данные возвращаются в исходное значение
  • Для AD-пользователей не работает галка "Запомнить меня на этом компьютере"
  • Доступ к разделу Extranet без NTLM
  • Настройка авторизации на IIS

После изменения профиля AD пользователя данные возвращаются в исходное значение

Профиль пользователей, авторизующихся через Active Directory, при каждом входе синхронизируется с сервером AD, при этом все локально сделанные настройки перезаписываются данными, указанными на сервере. Изменить такое поведение можно:

  • либо установив для данного пользователя локальную авторизацию (для этого нужно вручную задать ему тот же пароль, что и в AD и изменить Тип авторизации на Внутренняя проверка на странице редактирования пользователя ). Тогда авторизация пользователя будет проходить не через AD, а локально;
  • либо внести изменения данных пользователя не на сайте, а в AD. Тогда на сайте они тоже автоматически изменятся при синхронизации с сервером;
  • либо уменьшить количество полей, по которым осуществляется синхронизация, в настройках AD сервера на сайте (Настройки > AD/LDAP, закладка Настройка полей ). В этом случае можно при импорта пользователей из AD/LDAP (Настройки > Пользователи > Импорт пользователей), например, указать нужные нам поля, а потом в настройках AD сервера на сайте удалить все поля. Тогда у пользователя будут первоначально заданы все необходимые данные, и впоследствии, он сможет менять их.

Для AD-пользователей не работает опция "Запомнить меня на этом компьютере"

Запомнить пароль невозможно, т.к. при авторизации AD-пользователей система обращается к указанному в настройках AD/LDAP серверу и проверяет наличие пользователя с указанными логином и паролем в базе пользователей на корпоративном сервере и дальше уже происходит авторизация (см. урок Схема работы модуля ).

Из соображений безопасности сайт не сохраняет у себя логин и пароль.

Доступ к разделу Extranet без NTLM

Чтобы корректно настроить доступ к папке extranet без авторизации через NTLM, необходимо:

  1. В файле /.htaccess добавить строки:
    AuthName "My Intranet"
AuthType SSPI
SSPIAuth On
SSPIPackage NTLM
SSPIDomain MYDOMAIN
SSPIPerRequestAuth On
SSPIAuthoritative On
SSPIOfferBasic On
Require valid-user
  2. В файлах /extranet/.htaccess и /bitrix/.htaccess добавить строку:
    Satisfy any
  3. В /bitrix/admin/.htaccess добавить:
    Satisfy all

В результате NTLM авторизация будет работать для всех папок в публичной части сайта, кроме extranet, а также в административной части сайта.

Настройка авторизации на IIS

Настройка авторизации при использовании IIS сервера производится аналогично настройкам на Linux . Подразумевается что, IIS при этом уже настроен на работу с PHP, разрешена доменная авторизация и на сайте настроены нужные порты: 8890 (для http) или 8891 (для https) и 80 (для http) или 443 (https).


Проверьте себя
78 / 694

Ответьте на несколько вопросов по теме Пользователи и авторизация, которые помогут вам самим оценить свои знания. Это не тест, это просто проверка того, как вы поняли тему. Удачи!

Верно ли утверждение?

Оцените верность утверждения: Верно или Неверно. А потом в спойлере проверьте ваш выбор.

1 Если пользователь приписан к нескольким группам, то он обладает минимальным уровнем прав из доступных для него в рамках этих групп.
Верно
Увы, вы ошиблись. Пользователь обладает максимальным уровнем прав из доступных для него групп. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
2 Сайты "1С-Битрикс: Управление сайтом" имеют двухуровневую систему разграничения прав доступа.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
3 Настройка прав доступа выполняется для всех модулей.
Верно
Увы, вы ошиблись. Часть модулей доступна только группе Администраторы. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
4 После установки системы обязательно нужно создать учетную запись Администратора.
Верно
Увы, вы ошиблись. Учетная запись администратора создаётся при установке системы автоматически с идентификатором 1. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
5 Пользователей на сайт можно добавлять не только по одному, но и импортировать целым списком.
Верно
Аплодисменты, вы ответили правильно! Импортировать можно из файла CSV и из Active Directory / LDAP.
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
6 Регистрация на сайте доступна только по электронной почте.
Верно
Увы, вы ошиблись. Начиная с версии 18.5.0 "1С-Битрикс: Управление сайтом" регистрация доступна и по мобильному телефону. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
7 Если пароль администратора утерян, то его можно восстановить.
Верно
Аплодисменты, вы ответили правильно! Существует два способа восстановления пароля администратора.
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
8 Параметры отображения CAPTCHA можно задать вручную.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
9 Модуль AD/LDAP позволяет настраивать соответствие групп пользователей корпоративной сети группам пользователей Bitrix Framework.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
10 Обращение к Active Directory серверу происходит только при импорте пользователей.
Верно
Увы, вы ошиблись. Обращение к AD серверу происходит ещё и при каждой авторизации пользователя. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
11 Авторизация на сайте/портале возможна без ввода логина/пароля.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. NTLM позволяет авторизоваться используя данные авторизации Windows на AD сервере. Советуем почитать тему ещё раз.


Практические задания
79 / 694

После изучения главы рекомендуем выполнить несколько практических заданий. Их можно выполнять на:

  1. тестовой лаборатории предоставленной компанией 1С-Битрикс
    2. либо
  2. на установленной на локальный компьютер пробной версии 1С-Битрикс: Управление сайтом

Первый вариант проще: Виртуальная лаборатория предполагает установку системы в упрощённом, в отличие от локальной версии 1С-Битрикс: Управление сайтом, варианте. При такой установке для получения идентичного изображения у пользователя и на скриншотах заданий выберите на шаге Решение для установки: Интернет-магазин . На остальных шагах менять установки по умолчанию не нужно.

Минус первого варианта в том, что сайт на виртуальной лаборатории "живёт" только 3 часа. Но для выполнения практических заданий в рамках главы этого вполне достаточно. После изучения следующей главы можно заново создать сайт.

Примечания:
  1. Настоятельно рекомендуем НЕ выполнять задания на работающем, "боевом" сайте.
  2. Если вы всё же пытаетесь выполнять задания на работающем сайте, где вы не являетесь администратором, то не все задания можно выполнить.

Практические задания состоят из вопроса, скриншота или видео с конечным результатом и объяснением как это получить в спойлере. Не торопитесь подглядывать в спойлер.

Практические задания

  1. Настройте доступ менеджеру к просмотру заказов магазина. Для этого:
    • Создайте новую группу пользователей Менеджеры;
    • Создайте нового пользователя и добавьте в созданную группу;
    • Выполните необходимые настройки доступа для группы, чтобы менеджер имел доступ к просмотру заказов . Также менеджеру должна быть доступна административная панель в публичном разделе.

    Решение
    Задание составлено по материалам уроков:
    • Работа с учетными записями пользователей.
    • Управление группами пользователей.
    • Типовые роли пользователей сайта.

    Результат:

    Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

  2. Импортируйте список пользователей с помощью CSV файла:
    • Пусть в списке импорта будут такие данные: логин, пароль, имя, фамилия, эл. почта, день рождения и пол;
    • Все импортируемые пользователи должны попасть в группу Зарегистрированные пользователи.

    Решение
    Задание составлено по материалам уроков:
    • Страница импорта.
    • Импорт пользователей из CSV-файла.

    Результат:

    Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

    Обратите внимание, что пароль в данных пользователя после импорта Вы не увидите. Но пользователь сможет авторизоваться с этим паролем.

  3. Настройте CAPTCHA с профилем Линии и рекомендуемыми параметрами из урока Настройка CAPTCHA:
    • прозрачность текста в процентах - 45%,
    • угол отклонения от вертикали - от -30 до 30,
    • добавить нелинейные искажения,
    • установить шрифт bitrix_captcha.ttf.

    Проверить результат можно на примере формы регистрации .

    Решение
    Задание составлено по материалам урока:
    • Настройка CAPTCHA.

    Результат:

    Сначала установим профиль Линии:

    Теперь выполним остальные настройки. При этом при внесении изменений профиль изменится на Пользовательский:

    Нажмите на рисунок, чтобы увеличить


Управление доступом
80 / 694

Управление доступом - одна из основных обязанностей администратора сайта. Как это можно сделать в "1С-Битрикс: Управление сайтом" читайте в этой главе.


Принципы управления доступом
81 / 694

Главные принципы управления доступом

Управление доступом в рамках системы подразумевает:

  • доступ к модулям,
  • доступ к элементам динамического контента,
  • доступ к файлам и папкам.

Доступ для конкретного пользователя осуществляется в рамках Группы пользователей.
То есть, чтобы пользователь получил определённые права, необходимо включить его в группу с нужным уровнем прав. Если пользователь входит в несколько групп, то его уровень доступа определяется суммой прав этих групп.

В таблице приведены права доступа по умолчанию к модулям системы для стандартных групп пользователей.

Внимание! При включении пользователя в новую группу для получения всего возможного уровня прав ему необходимо заново авторизоваться в системе.

Все пользователи, которым требуется вносить хоть какие-то изменения в Публичной части сайта, должны иметь доступ на чтение к папке /bitrix/admin.

Единую концепцию управления правами, подходящую для всех или большинства случаев, предложить крайне сложно: слишком велико разнообразие потребностей пользователей. Ниже перечислены общие моменты управления правами в большом проекте с большим числом пользователей:

  • В Wiki, в стороннем файле, на недоступной для обычных пользователей странице должны быть описаны регламенты доступа для групп и пользователей, подключённых через функционал расширенных прав.
  • Когда в рамках проекта принимается решение о том, что теперь конкретный пользователь или пользователи группы "такой-то" имеют право добавлять/изменять/удалять новости "такого-то" раздела, то эта информация добавляется в регламент. Важно: указывается срок жизни этого правила.
  • После обновления регламентов "вручную" или через бизнес-процессы ставится задача ИТ службе. Служба исполняет это решение централизовано (AD/LDAP) или в конкретном проекте.


Уровни доступа для стандартных групп пользователей
82 / 694

Следующие модули не включены в таблицу, так как настройка прав доступа для них не выполняется. По умолчанию полный доступ к настройкам этих модулей задан для группы Администраторы:

  • CRM
  • DAV
  • Push and Pull
  • Бизнес процессы
  • Веб-мессенджер
  • Веб-сервисы
  • Диск
  • Задачи
  • Интранет
  • Информационные блоки
  • Календарь событий
  • Коннекторы для внешних мессенджеров
  • Открытые линии
  • Поиск
  • Распознавание лиц
  • Служба сообщений
  • Социальные сервисы
  • Телефония
  • Универсальные списки
  • Фотогалерея 2.0
  • Чат-боты Битрикс24

Модуль, права доступа | Стандартные группы пользователей
 | Администраторы | Все пользователи (в том числе неавторизованные) | Пользователи, имеющие право голосовать за рейтинг | Пользователи, имеющие право голосовать за авторитет | Почтовые пользователи | Битрикс: Сотрудники | Битрикс: Администрация портала
Главный модуль Описание прав доступа | Полный доступ | Доступ закрыт |  |  | Изменение своего профиля |  | Просмотр данных модуля и изменение заданных профилей (для группы Битрикс: Сотрудники)
Wiki (wiki) Описание прав доступа | Полный доступ | Чтение страниц |  |  |  | Создание/изменение страниц | Удаление страниц и истории
Блоги (blog) Описание прав доступа | Полный доступ | Чтение блогов |  |  |  |  | Полный доступ
Валюты (currency) Описание прав доступа | Полный доступ | Закрыт
Интернет-магазин (sale) Описание прав доступа | Полный доступ | Доступ закрыт
Монитор производительности (perfmon) Описание прав доступа | Полный доступ | Доступ закрыт
Облако 1С-Битрикс (bitrixcloud) Настройки модуля | Полный доступ | Доступ закрыт
Облачные хранилища (clouds) Описание прав доступа | Полный доступ | Доступ закрыт
Опросы, голосования (vote) Описание прав доступа | Полный доступ | Закрыт
Перевод (translate) Описание прав доступа | Полный доступ | Закрыт
Подписка, рассылки (subscribe) Описание прав доступа | Полный доступ | Закрыт
Поисковая оптимизация (seo) Описание прав доступа | Полный доступ | Доступ закрыт
Почта (mail) Описание прав доступа | Полный доступ | Закрыт
Проактивная защита (security) Описание прав доступа | Полный доступ | Доступ закрыт
Социальная сеть (socialnetwork) Описание прав доступа | Полный доступ | Работа в публичной части |  |  |  |  | Полный доступ
Торговый каталог (catalog) Описание прав доступа | Полный доступ | Доступ закрыт
Управление структурой (fileman) Описание прав доступа | Полный доступ | Доступ закрыт |  |  |  |  | Редактирование файлов
Учет рабочего времени (timeman) Описание прав доступа | Полный доступ | В соответствии с настройками субординации: сотрудники могут управлять своим рабочим днем и читать отчеты; руководители могут управлять рабочим днем, отчетами, изменять и подтверждать записи подчиненного отдела и подотделов
Форум (forum) Описание прав доступа | Полный доступ | Закрыт |  |  |  |  | Запись


Уровни доступа
83 / 694

Разделять и управлять!

Система разграничения доступа позволяет гибко управлять правами пользователей. В системе введено понятие уровней доступа, которые состоят из набора разрешенных операций (например, права на создание файлов, управление пользователями и другие) и привязываются к модулям и группам пользователей.

Уровни доступа — определенный комплекс операций в системе, доступный для выполнения пользователем. Они предназначены для создания системы управления пользователями. Уровни доступа определяются администратором и могут быть как изменены, так и созданы. Обладают свойством "наследования", то есть если для текущего раздела/страницы явно не задан уровень прав, тогда устанавливается то право, которое задано для вышележащего раздела.

Примеры:

  • операция Управление пользователями только разрешенных групп позволяет не администраторам управлять пользователями из указанных групп
  • операция Ограниченная модификация файлов с PHP-кодом позволяет не администраторам настраивать параметры компонентов и редактировать файлы с PHP в визуальном режиме

Создание уровней доступа и управление ими

Управление уровнями доступа осуществляется в административном разделе на странице Уровни доступа (Настройки > Пользователи > Уровни доступа):

На данной странице представлен список всех имеющихся уровней доступа: системных и созданных пользователем. Системные уровни доступа доступны только для просмотра, отредактировать их невозможно. Созданные пользователем уровни доступа системными не являются, поэтому их всегда можно отредактировать либо удалить.

Создадим собственный уровень доступа с помощью кнопки контекстного меню Добавить уровень доступа.

Добавление уровня доступа

Отметим некоторые особенности данной формы:

  • поля Название и Модуль являются обязательными для заполнения;
  • в поле Привязка выбирается:
    • Модуль - в этом случае уровень доступа можно будет установить для указанного модуля;
    • либо Файл/Папка - в этом случае создаваемый уровень доступа будет возможно настроить для файлов или папок.

Также для создания нового уровня доступа можно воспользоваться пунктом контекстного меню элемента Копировать. При нажатии будет создана копия выбранного элемента и новый уровень доступа откроется на редактирование. При этом если был скопирован системный уровень доступа, то вновь созданный уровень будет уже пользовательским.

В зависимости от выбранного модуля и типа привязки отображаются свои возможные действия на закладке Включаемые операции .

После сохранения уровень доступа будет выведен в форме настроек Главного модуля (Настройки > Настройки продукта > Настройки модулей > Главный модуль), и в форме редактирования группы пользователей на закладке Доступ (Настройки > Пользователи > Группы пользователей).

Управление правами доступа пользователей осуществляется с помощью настройки прав групп , к которым относятся пользователи (в форме настройки параметров группы).

Документация по теме:

  • Создание и редактирование уровня доступа


Доступ к модулям
84 / 694

Управление правами доступа к модулям

Настройка прав доступа к модулям задаёт действия, которые может позволить себе пользователь определённой группы. Управление выполняется двумя способами:

  1. на закладке Доступ в форме настройки группы пользователей (Настройки > Пользователи > Группы пользователей):

    Форма настройки параметров группы пользователей

    В форме настраиваются права какой-либо группы пользователей на доступ ко всем модулям системы.

  2. в форме настройки модуля (Настройки > Настройки продукта > Настройки модулей >_нужный модуль_):

    Форма настройки модуля

    Значение По умолчанию определяет уровень доступа для всех групп. Если группе нужно установить значения отличное от По умолчанию, то выберите в левом столбце группу пользователей, а в правом - уровень доступа. Ссылка Добавить право доступа добавляет в список новые строки.

    Зачем нужно значение "По умолчанию"

    Каждый модуль имеет разные права доступа.
    Каждой группе можно задать разные права доступа
    Когда групп много, то установка прав - утомительное занятие. Поэтому сделано так:

    В настройках каждого модуля предусмотрено поле По умолчанию. В нём указывается то значение, которое должно быть по умолчанию для большинства групп. (Если вы создаёте группу, то в полях доступа для всех модулей будет стоять то самое - по умолчанию.)

    Например для главного модуля выбрано значение: Доступ закрыт. То есть для всех групп (кроме Админа), будет закрыт доступ к настройкам модуля.

    То есть массовое изменение прав доступа для групп производится в настройках модуля в поле По умолчанию. А когда нужно сменить доступ отдельной группы к модулю, то в настройках модуля выбирается группа и указывается новый доступ для неё.

    Примечание: Если вы дали группе доступ к модулю, но он по-прежнему недоступен для участников этой группы, то:
    • проверьте, установлен ли нужный уровень доступа в настройках группы - см. способ 1 (возможна такая ситуация: в настройках группы стоит доступ По умолчанию, а в настройках модуля этому значению соответствует уровень прав Доступ закрыт, и по правилам приоритета доступ участникам группы оказался закрыт);
    • участники группы должны заново авторизоваться (права не вступят в силу без повторной авторизации).

Отдельные модули позволяют осуществлять дополнительную настройку прав доступа к контенту (см. урок Доступ к элементам контента ).

Пример
Допустим, администратор сайта предполагает, что управление страницами некоторых разделов сайта будет поручено пользователям из группы Редакторы сайта. Для того чтобы редакторы сайта могли создавать и редактировать разделы и страницы сайта, для группы Редакторы сайта нужно установить право доступа к модулю Управление структурой равным Редактирование файлов и папок. Это позволит в дальнейшем определять папки и файлы, доступ к управлению которыми будет разрешен для пользователей данной группы, а также папки и файлы, доступ которым будет запрещен.

Кроме того, для модулей Реклама, баннеры и Техподдержка настройка прав доступа пользователей выполняется на уровне ролей.

Подробное описание ролей приводится в пользовательской документации продукта в разделах соответствующих модулей.


Доступ к элементам контента
85 / 694

Некоторые модули предусматривают дополнительную настройку прав доступа к контенту:

  • Модуль Инфоблоки
    • Простой режим
    • Расширенный режим
  • Модуль Веб-формы

Модуль Информационные блоки

Примечание. Уровень доступа групп пользователей к информационным блокам настраивается отдельно для каждого инфоблока. Более того, в Расширенном режиме доступна установка прав для каждого раздела или элемента по отдельности.

Настройка прав доступа выполняется в форме редактирования свойств инфоблока на закладке Доступ (Контент > Информ. блоки > Типы информ. блоков > <название_типа_инфоблока> <название_инфоблока>).

Нажмите на рисунок, чтобы увеличить

Простой режим

В простом режиме права доступа настраиваются для всего информационного блока в целом.

Например, чтобы пользователи группы Контент-редакторы имели право на создание и редактирование новостей инфоблока Новости компании, нужно в настройках инфоблока Новости компании установить для группы Контент-редакторы право доступа Изменение.

Если при попытке изменения доступа появляется сообщение "Внимание! Заданный уровень доступа переопределяется уровнем доступа по умолчанию", то это означает, что выставляемое право находится на более низком уровне иерархии, чем право доступа по умолчанию, и система не даст его установить.

Переопределение уровня доступа

В этом случае необходимо пересмотреть систему организации доступа. Например, по умолчанию выставить право Нет доступа и для нужных групп указать право Чтение.

Примечание: Если необходимо закрыть доступ к инфоблоку, проверьте уровень доступа группы Все пользователи, т.к. любые пользователи принадлежат к этой группе и пользуются ее правами.

Если доступ к инфоблоку для определенной группы закрыт, то пользователи из этой группы не увидят содержимое в публичной части.

Кроме того, закрытое содержимое не будет видно в поиске для этой группы пользователей.

Расширенный режим

После установки флажка в поле Расширенное управление правами нажмите кнопку Применить, и форма перезагрузится.

Теперь можно задать права для инфоблока по умолчанию. Эти права будут применяться до тех пор, пока в форме создания/редактирования конкретного раздела или элемента не будет указан другой уровень прав.

С помощью ссылки Добавить выберите нужную группу или конкретного пользователя, для которых хотите поменять права доступа и установите нужные права.

Для задания прав к конкретному разделу или элементу перейдите к форме редактирования элемента, на закладку Доступ .

Модуль Веб-формы

В модуле Веб-формы предусмотрено управление доступом к результатам заполнения веб-формы на уровне Статусов результатов (результатов заполнения веб-формы):

Для настройки прав доступа к статусам выполните следующее:
  • перейдите на страницу Список форм (Сервисы > Веб-формы > Настройка форм);

    • Примечание
    Использование статусов доступно только в расширенном режиме редактирования веб-форм. Для этого необходимо снять флажок в поле Использовать упрощенный режим редактирования форм формы настроек модуля Веб-формы (Настройки > Настройки продукта > Настройки модулей):

    Настройки модуля "Веб-формы"

  • Перейдите к редактированию параметров формы, дважды кликнув по строке с названием формы или выбрав пункт контекстного меню Изменить;
  • Перейдите к просмотру статусов формы, нажав кнопку Статусы на контекстной панели;
  • Перейдите к редактированию параметров статуса, дважды кликнув по строке с его названием или выбрав в пункте контекстного меню Изменить, затем выберите вкладку Доступ.

    • Для каждого статуса определяются группы пользователей, обладающие правом на работу с результатом веб-формы в данном статусе.

  • Пример организации прав доступа.


Права на файлы
86 / 694

Права на файлы

Дать универсальный ответ, какими должны быть права на файлы, нельзя, так как каждый хостинг настроен по-своему.

Результат должен быть таким: для пользователя, под которым запущен Apache, нужны права на чтение/запись на все файлы и папки, начиная от корня сайта. При этом на разделяемом хостинге другие пользователи на этой же машине не должны иметь права читать/изменять ваши файлы. Также желательно, чтобы файлы, закачанные по FTP, могли быть перезаписаны из скрипта.

Проблема в том, что у каждого хостинг-провайдера своя политика безопасности и свои настройки: одни ограничивают доступ к чужим файлам даже при праве доступа 777 , другие запускают процесс Apache под своим пользователем для каждого виртуального хоста, и т.д.

Поэтому вопрос необходимо решать с хостинг-провайдером.

Проблемы с неправильными правами и их решение

Unix/Linux - многопользовательская система, это значит, что в системе одновременно могут работать несколько пользователей в своих папках со своими файлами. Соответственно, разные пользователи имеют разные права на доступ к файлам и папкам.

Для загрузки файлов по FTP и работы с ними через веб-интерфейс используются разные программы (ftp клиент и веб-сервер), и для операционной системы это разные пользователи.

Для решения проблемы взаимной записи необходимо установить специальные права на файлы и папки (требуемые права зависят от того, под какими пользователями работают ftp клиент и веб-сервер, к каким группам принадлежат).

Внимание! На каждом хостинге эта настройка специфическая, подробности вы можете узнать у своего хостера.

Наиболее часто встречаемые проблемы, связанные с правами на файлы и папки:

  • При изменении файлов через FTP не удается сохранить изменения

    В этом случае необходимо пользователю веб-сервера разрешить запись в свои файлы для пользователя FTP. Это можно сделать через следующий скрипт:

    <?

function chmod_R($path, $perm)
{
   if (is_dir($path))
   {
      chmod($path."/".$file, $perm);
      $handle = opendir($path);
      if (!$handle)
      {
         echo "Error: ".$path;
         return;
      }

      while (false !== ($file = readdir($handle)))
      {
         if ($file == "." || $file == ".." || $file == '.htaccess')
            continue;

         chmod_R($path."/".$file, $perm);
      }
      closedir($handle);
      return true;
   }
   elseif(is_file($path))
   {
      $file_perm = $perm ^ 0111;
      return chmod($path, $file_perm);
   }
   return;
}

 $path = $_GET["path"];
 if (!trim($path))
 {
 ?>
    <form method=get>
       Путь от корня сайта: <input name=path value='<?=dirname($_SERVER['SCRIPT_NAME'])?>'><br>

       Права: <input name=perm value='0777'><br>
       <input type=submit value='OK'>
    </form>
 <?
 }
 else

 {
    $path = realpath($_SERVER["DOCUMENT_ROOT"] . "/" . $path);

    if (intval($_GET['perm']))
       $perm = octdec(intval($_GET['perm']));
    else
       $perm = 0777;

    if (chmod_R($path, $perm))
       echo "OK: ".$path;
 }
?>

    После запуска скрипт спросит путь к папке, в которой надо изменить права относительно корня сайта и сами права на папки. На файлы он автоматически сбросит атрибут "x" - исполнение. Если это не требуется, замените строку

    $file_perm = $perm ^ 0111;

    на

    $file_perm = $perm;
  • Файлы загружаются через ftp, но при попытке их изменения в продуктах Bitrix Framework появляется ошибка записи

    В этом случае необходимо пользователю ftp разрешить запись для пользователя веб-сервера, иными словами, выставить права.

    Сделать это можно по протоколу ssh, например, используя бесплатную программу PuTTY.

    Рассмотрим последовательность действий для изменения прав доступа:

    • подключитесь к своему сайту (о том, как это сделать, смотрите руководство к программе, с помощью которой вы подключаетесь)
    • перейдите в нужную директорию, используя команду cd:
      cd /path/to/dir
      Примечание: Путь /path/to/dir необходимо уточнить у хостера.
    • затем выполните команду chmod:
      chmod -R xxxx .

      где:
      -R - указывает, что необходимо изменить права на все папки и подпапки,
      xxxx - указывает требуемые атрибуты доступа (например, 0771),
      . - указание на текущую директорию.

      Подробнее про команду chmod можно посмотреть в Википедии и документации по PHP.

Примечание: Установка прав через клиент ftp с поддержкой рекурсивного изменения прав на папки не является хорошим вариантом. Потому что, например, для изменения прав на 100 файлов потребуется отправить специальную команду как минимум 100 раз (если есть подпапки - то ещё и для них). В дополнение к этому передаётся еще и множество служебной информации. В итоге эта операция может занять довольно продолжительное время даже при хорошем канале Интернет.

Обратите внимание:

  • чтобы избежать проблем с правами при установке продукта - лучше всего воспользоваться скриптом BitrixSetup. Он скачает и распакует дистрибутив с нашего сайта, при этом файлы будут принадлежать веб-серверу и проблем при работе не возникнет;
  • ftp и ssh сервисы в большинстве случаев позволяют авторизоваться под одним и тем же пользователем, значит можно закачать файл через ftp, а изменить права через ssh;
  • пользователь может изменить права только на свои файлы. Это значит, что если вы не можете изменить файл непосредственно в системе, то не стоит пытаться применять веб скрипт. Права необходимо изменять через ftp/ssh. И наоборот;
  • панель управления на хостинге чаще всего с целью безопасности работает под третьим пользователем, поэтому в борьбе с правами она скорее всего не поможет.

Установка прав на создаваемые Bitrix Framework файлы

Права, с которыми создаются файлы и папки, вы можете установить в файле /bitrix/php_interface/dbconn.php:

define("BX_FILE_PERMISSIONS", 0644);
define("BX_DIR_PERMISSIONS", 0755);


Управление доступом к папкам и файлам
87 / 694

Зачем это нужно

Система предусматривает возможность отключения просмотра физической структуры сайта в Административном разделе. Это может быть полезно по следующим соображениям:

  • если у какой-то группы пользователей есть такие права администрирования, которые в принципе могут привести к негативным последствиям в случае неграмотных действий;
  • если квалифицированный администратор сайта в отъезде, отпуске и т. д., то полезно скрыть физическую структуру, оберегая проект от непредвиденных случайностей;
  • чтобы контент-менеджеры не пребывали в недоумении, почему одни и те же страницы, разделы могут быть отображены дважды (в рамках физической и логической структуры): пусть работают только с логической структурой.

Как отключить просмотр физической структуры

Для отключения просмотра физической структуры на странице настроек модуля Управление структурой (Настройки > Настройки продукта > Настройки модулей > Управление структурой) установите флажок в поле Не отображать раздел "Файлы и папки" в меню "Структура сайта" .

Примечание: Если в файловом менеджере продукта не отображаются файлы и папки и без включения функции Не отображать раздел "Файлы и папки" в меню "Структура сайта", то это происходит:
  • либо в результате ошибки в настройках сайта (Настройки > Настройки продукта > Сайты > Список сайтов). Значение поля Путь к корневой папке веб-сервера для этого сайта не соответствует реальному пути к DOCUMENT_ROOT.
  • либо на корневую папку сайта (DOCUMENT_ROOT) установлены права недостаточные для чтение её содержимого. В данном случае надо установить на папку наиболее полные права.

Как настроить права доступа к управлению структурой

По команде Дополнительно > Показать права на доступ для > нужная группа отображается текущее право группы пользователей на доступ к папкам и файлам системы.

Настройка прав доступа к управлению структурой сайта выполняется в Менеджере файлов (Контент > Структура сайта). Для настройки прав:

  • Перейдите в раздел Файлы и папки (Контент > Структура сайта > Файлы и папки)
  • Отметьте нужные элементы в Колонке флажков;
  • Выберите действие Права на доступ продукта на панели групповых операций и нажать кнопку Применить:

    В форме настройки прав доступа укажите уровень доступа каждой группы пользователей к выбранным файлам и папкам.

Права, которые могут быть назначены Группам пользователей
  • Запрещен: доступ группы пользователей к каталогу или файлу будет закрыт;
  • Чтение: пользователи группы смогут просмотривать информацию файла или каталога в публичном разделе сайта;
  • Запись: пользователи смогут редактировать файлы;
  • Документооборот: пользователям разрешено создавать и редактировать файлы через модуль Документооборот;
  • Полный доступ: пользователи получают права не только на изменение каталогов или файлов, но и на управление правами доступа всех групп пользователей к ним;
  • Наследовать: для настраиваемых каталогов или файлов будут назначены те же права, что и для вышележащих каталогов.
Обратите внимание: Если установлено право доступа Наследовать […], то реальное право доступа определяется полем Все группы, для которых уровень доступа Наследовать. Иными словами, по умолчанию для всех групп установлено только право на чтение (кроме администратора сайта, который может все).

Для настройки прав доступа к текущей директории (например, к корневой папке) нужно воспользоваться кнопкой Свойства папки, расположенной на контекстной панели:

Права групп пользователей на доступ к директории сайта наследуются всеми вложенными папками и файлами. Иными словами, задав право, скажем, на чтение одной папки, задаются права на чтение для всех вложенных в неё папок.

Задание прав на примере группы Редакторы сайта
Предоставим группе пользователей Редакторы сайта право на управление разделом Контент (папка /content/). Для всех остальных разделов и файлов установим для данной группы право на просмотр (Чтение). Для этого:
  1. Установим право на доступ к корневому каталогу для группы Редакторы сайта равным Чтение;
  2. Для всех вложенных папок и файлов, кроме папки /content/ (раздел Контент), установим право доступа для группы Редакторы сайта равным Наследовать [чтение]:
  3. Установим для группы пользователей Редакторы сайта право доступа к папке /content/ (раздел Контент) равным Запись, а для всех вложенных файлов и папок каталога /content/ установим право доступа для группы Редакторы сайта равным Наследовать [запись].
В результате проделанных операций пользователи группы Редакторы сайта получат право на просмотр всех файлов сайта, а также право на создание и редактирование подразделов и файлов в разделе Контент (/content/).

Управление доступом к файлам и папкам так же возможно и из публичного раздела .

Чтобы пользователь мог редактировать те или иные страницы/разделы и на панели управления были соответствующие кнопки, для требуемой группы пользователей необходимо установить права на запись:

  • для нужных каталогов
  • или отдельных файлов

Внимание! Для изменений контента в Публичной части сайта пользователи необходим доступ на чтение к папке /bitrix/admin. Это папка, в которой расположен визуальный HTML-редактор. Без этого редактирование будет возможно только в текстовом режиме.

Нельзя закрыть доступ только к определенным папкам в разделе "Файлы и папки" (так, чтобы они не отображались для какой-либо группы пользователей). Чтобы группа пользователей могла работать только с конкретными папками, а остальные не видела, нужно закрывать доступ ко всему разделу "Файлы и папки" и открывать этой группе доступ к конкретным папкам, давая прямые ссылки на эти папки (группа пользователей сможет работать по прямым ссылкам, но файловой структуры не увидит).

Пример решения проблемы

Была правильно создана группа и к ней приписан пользователь. Группе назначены следующие права доступа к административным частям модулей:

  • Главный модуль - полный доступ;
  • Управление структурой - полный доступ.

Но в административной части сайта пользователи созданной группы не имеют доступа к страницам и при авторизации выдается сообщение об ошибке .

Решение: По умолчанию новые пользователи имеют только право чтения для всех папок сайта, кроме папки /bitrix/admin/. Следовательно, для получения доступа вам необходимо установить права на чтение папки /bitrix/admin/:

Важно запомнить!

  • Права групп пользователей на доступ к директории сайта могут быть унаследованы всеми вложенными папками и файлами
  • Все пользователи, которым требуется вносить хоть какие-то изменения в Публичной части сайта, должны иметь доступ на чтение к папке /bitrix/admin.

Документация по теме:

  • Права доступа


Дополнительная проверка прав доступа
88 / 694

Bitrix Framework позволяет использовать условия для отображения тех или иных элементов сайта, а также разграничения прав доступа к этим элементам для различных групп пользователей.

  • Настройка шаблона сайта
  • Настройка пунктов меню
  • Настройка доступа к элементам инфоблока
    •

    Настройка шаблона сайта

    Например, в зависимости от группы пользователей, к которой относится текущий пользователь, может показываться конкретный шаблон дизайна страниц сайта. Такое условие задается в форме редактирования сайта (Настройки > Настройки продукта > Сайты > Список сайтов):

    Или другой пример, проверка группы пользователей, к которой относится текущий пользователь по PHP выражению:

    !$GLOBALS['USER']->IsAuthorized() && (!isset($_SERVER['REMOTE_USER']) || strlen($_SERVER['REMOTE_USER']) <= 0)

    Также, в дистрибутиве «Битрикс24 в коробке» уже задан пустой шаблон, который отображается для неавторизованных пользователей.

    Настройка пунктов меню

    В зависимости от группы пользователей, к которой относится текущий пользователь, отображаются и пункты меню. Данный тип условий задается в расширенном режиме редактирования меню (подробно про настройку меню смотрите в уроке Расширенный режим настройки меню):

    Если скрыть только пункт меню, но не запретить доступ к разделу, то обычный пользователь сможет зайти в раздел, если он знает его адрес.

    Настройка доступа к элементам инфоблока

    Ряд компонентов системы допускает задание ограничений на доступ к контенту. Например, можно ограничить доступ к детальному просмотру новостей. Рассмотрим это на примере комплексного компонента Новости.

    Нажмите на рисунок, чтобы увеличить

    В группе параметров Дополнительные настройки при установке флажка в поле Использовать дополнительное ограничение доступа появляется дополнительное поле Группы пользователей, имеющие доступ к детальной информации. В этом поле выберите группы пользователей, которым должен быть обеспечен доступ к детальной информации.

    Для выбора нескольких групп используйте кнопку Ctrl. При использовании данного метода пользователь с недостаточным уровнем прав при просмотре с публичной стороны сайта увидит уведомление о том, что ему не разрешен показ этой информации.

    Документация по теме:

    • Права доступа
    • Список сайтов


Несколько примеров работы
89 / 694

Как сделать страницу, видимую для сотрудников, но не для пользователей

Это делается с помощью настройки прав доступа.

Мы уже умеем управлять правами доступа. А создать страницу может даже контент-менеджер.

Давайте совместим это. То есть сделаем страницу - например, будем там размещать приказы руководства - и дадим на неё права только сотрудникам, то есть администраторам и контент-менеджерам. Пункт перехода на страницу должен быть виден в основном меню сотрудникам и не виден пользователям, даже авторизованным.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Как быстро закрыть доступ к публичной части

Если возникла необходимость экстренного закрытия публичной части сайта, воспользуйтесь служебной процедурой на странице Настройки > Настройки продукта > Настройки модулей > Главный модуль:


Настройка доступа к инфоблокам
90 / 694

Настройка доступа

Регулирование доступа к инфоблоку - это ответственный этап его настройки. Неправильно заданные права могут привести к тому, что:

  • информацию увидят те пользователи, которым видеть ее не положено
    • либо возникнет обратная ситуация:
  • пользователям не будет доступна полагающаяся информация.

Права доступа задаются для каждого инфоблока отдельно в форме его редактирования на закладке Доступ. По умолчанию к новому инфоблоку полный доступ имеет только группа пользователей Администраторы, а для всех остальных групп доступ закрыт:

Нажмите на рисунок, чтобы увеличить

Настройка прав доступа в простом режиме

Простой режим настройки прав доступа к инфоблоку - это режим, когда опция Расширенное управление правами отключена, а в секции Доступ для групп пользователей перечислены все имеющиеся у вас в системе группы пользователей. Предоставление группе некоторого права доступа заключается в его выборе из выпадающего списка:

  • Так, контент-редакторам чаще всего предоставляется право Изменение , поскольку именно они вносят информацию в инфоблок.
  • Для всех пользователей обычно дают право Чтение . Исключение составляют случаи закрытой информации, тогда всем пользователям оставляют Нет доступа, а Чтение назначают отдельной группе, например, группе подписчиков.

Важно! При настройке прав доступа помните, что пользователи любых групп обязательно принадлежат и к группе Все пользователи. Поэтому право доступа группы Все пользователи не должно быть «выше» прав доступа всех остальных групп. В противном случае вы получите ошибку .

Когда вы хотите некоторой группе закрыть доступ, то следует закрыть доступ группе Все пользователи, требуемой группе проставить По умолчанию, а остальным необходимым группам проставить то право, которое было изначально у группы Все пользователи:

Нажмите на рисунок, чтобы увеличить

Настройка прав доступа в расширенном режиме

Расширенный режим позволяет настроить права доступа не только целиком ко всему инфоблоку, но и гибко задать права на отдельные его разделы и элементы.

Для включения расширенного режима отметьте опцию Расширенное управление правами и обязательно нажмите кнопку Применить. Именно после применения настроек режим становится доступным, а все ваши имеющиеся настройки прав сохраняются и просто конвертируются в расширенные:

По ссылке Добавить вы можете выбрать не только группу пользователей, но и группу социальной сети или непосредственно отдельных пользователей. Назначение прав выполняется обычным способом - выбором нужного уровня доступа из выпадающего списка . Установленные права будут распространяться на все разделы и элементы до тех пор, пока в разделе (или элементе) вы не зададите отличное право доступа (смотрите пример в уроке Определение прав доступа динамических страниц ).

Заключение

Настройка доступа может выполняться в двух режимах:

  • простом - права даются группам пользователей на весь инфоблок сразу.
  • расширенном - права могут предоставляться как на весь инфоблок, так и на отдельные его разделы и элементы для различных групп и отдельных пользователей.


Резервное копирование
91 / 694

В главе рассматривается механизм резервного копирования и способы хранения копий для любого коробочного продукта: "1С-Битрикс: Управление сайтом" и "Битрикс24 в коробке".

Внимание! Если у вас используется устаревшая версия программы (до 12.0), то воспользуйтесь этим документом.


Создание резервной копии
92 / 694

Выполняется резервное копирование на странице Резервное копирование (Настройки > Инструменты > Резервное копирование).

Обратите внимание! Механизм резервного копирования может быть использован только для базы данных MySQL.

Расписание резервирования и резервные копии в облаке "1С-Битрикс"
Нажмите на рисунок, чтобы увеличить

Форма создания резервной копии:

Нажмите на рисунок, чтобы увеличить

К вкладке Резервное копирование относятся важные примечания:

  1. Компания "1С-Битрикс" бесплатно предоставляет место в облаке для хранения трех резервных копий на каждую активную лицензию. Объём пространства в облаке зависит от лицензии. Доступ к резервным копиям осуществляется по лицензионному ключу и паролю. Без знания пароля никто, включая сотрудников "1С-Битрикс", не сможет получить доступ к вашим данным.
  2. Если выбрано несколько сайтов для помещения в архив, в корне архива будет лежать первый по списку сайт, а публичные части остальных сайтов будут помещены в папку /bitrix/backup/sites. При восстановлении нужно будет вручную скопировать их в нужные папки и создать символьные ссылки.

Особенности резервного копирования при многосайтовости на разных доменах

  1. Создавать резервные копии можно для любого сочетания существующих в системе файлов. Просто отметьте "птичками" в форме нужные сайты.
  2. База данных полностью копируется в архив. Даже тех сайтов, которые не были отмечены "птичками".
  3. Восстановление сайтов потребует дополнительных действий со стороны администратора:
    • Учтите, что из выбранных сайтов в состав архива полностью копируется только первый по сортировке в списке сайтов. Соответственно, при восстановлении в полностью работоспособном состоянии восстанавливается только этот сайт.
    • Публичная часть остальных сайтов сохраняется в архиве в папках вида /bitrix/backup/sites/_ID_сайта_. При распаковке архива появится предупреждение, что в нём содержится несколько публичных частей. После распаковки администратор должен будет вручную перенести папки сайтов в соответствующие папки на сервере.
    • Многосайтовость надо восстановить вручную (восстановить симлинки). Только после этого остальные сайты будут работоспособны.

Вкладка Параметры

Резервную копию можно сохранить как на локальный носитель, так и в облачное хранилище. В обоих случаях возможно изменение настроек этого процесса. Для этого перейдите на закладку Параметры и активируйте опцию Включить экспертные настройки создания резервной копии.

Внимание! Если вы не совсем ясно представляете суть настроек параметров, то рекомендуется не пользоваться этой опцией, а оставить настройки по умолчанию

Нажмите на рисунок, чтобы увеличить

К вкладке Параметры относятся важные примечания:

  3. Для маски исключения действуют следующие правила:

    • шаблон маски может содержать символы "*", которые соответствуют любому количеству любых символов в имени файла или папки;
    • если в начале стоит косая черта ("/" или "\"), путь считается от корня сайта;
    • в противном случае шаблон применяется к каждому файлу или папке;

    Примеры шаблонов:

    • /content/photo - исключить целиком папку /content/photo;
    • *.zip - исключить файлы с расширением "zip";
    • .access.php - исключить все файлы ".access.php";
    • /files/download/*.zip - исключить файлы с расширением "zip" в директории /files/download;
    • /files/d*/*.ht* - исключить файлы из директорий, начинающихся на "/files/d" с расширениями, начинающимися на "ht".
  4. При размещении резервной копии в облачном хранилище "1С-Битрикс" отключить шифрование нельзя.
  5. Системные ограничения php не позволяют делать размер одной части архива более 2 Гб. Не устанавливайте это значение больше 200 Мб т.к. это существенно увеличивает время архивации и распаковки, оптимальное значение: 100 Мб.

Подробнее о полях на вкладке Параметры
  • Величина поля Длительность шага зависит от параметров, установленных на хостинге (в php.ini). Если точное доступное значение шага неизвестно, то рекомендуются значения не более 30.
  • Если настроено несколько сайтов с разными путями к корневой папке веб-сервера, они сохраняются и восстанавливаются отдельно. При этом полный архив делается один раз. А затем, при архивации других сайтов, необходимо будет исключить ядро и базу данных через экспертные настройки. Если восстановление делается на другом сервере, символьные ссылки на папки /bitrix и /upload необходимо будет создать вручную.
  • Если копия будет сохраняться локально , то можно не использовать опцию шифрования данных резервной копии , это снизит нагрузку на сервер при создании архива.
  • Суть Проверки целостности архива после его завершения в том, что идет "виртуальная" распаковка без создания файлов. То есть это гарантирует, что сам по себе файл получился корректный. Полную гарантию целостности резервной копии можно дать после полного восстановления сайта.
Примечание: Подробное описание полей формы смотрите на странице пользовательской документации.

Подробнее про операцию переноса сайта с локальной машины на удаленный хостинг смотрите в уроке Перенос продукта.


Основные возможности
93 / 694

Как известно всем администраторам сайтов, бэкап должен быть всегда и много бэкапов не бывает. Кроме защиты данных от повреждения, резервное копирование необходимо также при переносе сайта на удаленный хостинг.

При работе с CMS Битрикс вы можете хранить резервные копии сайта :

  • у себя на локальном компьютере
  • в Облаке 1С-Битрикс
  • в стороннем облачном хранилище

Каждый из этих способов имеет свои достоинства и недостатки:

Например, хранение бэкапа на своем локальном компьютере может быть самым дешевым и доступным, но очень ограниченным по объему. К тому же, это не защищает от повреждения данных в результате простого отключения электричества во всем городе, не говоря уж о техногенных катастрофах, стихийных бедствиях и др. Снизить риски поможет дублирование на удаленную площадку - буквально физическое перемещение носителя с копией в другой город (страну, континент). Но это значительно снижает скорость восстановления данных при необходимости.

Хранение в Облаке 1С-Битрикс - это бесплатно, очень надежно, просто и быстро. Можно настроить регулярное автоматическое резервирование штатными методами системы. Недостаток - ограничение по объему в зависимости от тарифа. Но вы можете по потребности докупать место в облаке без смены тарифного плана.

Подключение сторонних облачных хранилищ также делается средствами и через интерфейс CMS Битрикс. Современные датацентры предлагают выгодные цены и большие объемы. Вы можете воспользоваться любыми "облаками", хранить там свои файлы и таким образом снижать нагрузку на ваши сервера. Но потребуется самостоятельно оформить "облачный" аккаунт у выбранного хостера и настроить его. Кроме того, место в облаке ограничено вашим тарифным планом.

Возможности резервного копирования:

  • создание архивной версии файлов сайта (формат tar.gz);
  • исключение из архива папки, содержащей ядро продукта;
  • исключение из архива файлов, размер которых превышает некоторое заданное значение;
  • создание дампа базы данных (формат tar.gz);
  • исключение из дампа таблиц статистики и поискового индекса;
  • автоматическое деление архивов на части когда размер несжатых данных превышает 1Гб;
  • архивирование данных в облачные хранилища.

Документация по теме:

  • Резервное копирование
  • Автоматическое создание резервной копии


Хранение и шифрование резервных копий
94 / 694

Где хранить бэкапы сайта - на локальном компьютере, в облаке 1С-Битрикс или в сторонних облачных хранилищах обычно решает администратор в соответствии с политикой компании. А CMS "1С-Битрикс" обеспечивает все эти возможности.

В списке резервных копий (Настройки > Инструменты > Резервное копирование > Список резервных копий) отмечено, является ли бэкап локальным или облачным. И действия, доступные в контекстом меню, также отличаются:

Нажмите на рисунок, чтобы увеличить

Локальный бэкап

Для сохранения на локальный носитель надо на закладке Резервное копирование выбрать опцию в папке сайта и нажать кнопку Резервное копирование. Архив создастся и сохранится. В имени файла будет содержаться дата создания.

Нажмите на рисунок, чтобы увеличить

В рамках файловой структуры сайта файлы копий хранятся в папке /bitrix/backup.

Облачный бэкап

Можно хранить резервную копию в любом стороннем облачном хранилище или в облачном хранилище, предоставляемом компанией "1С-Битрикс". В обоих случаях необходимы:

  • установленный модуль Облачные хранилища (clouds) ,
  • подключённое какое-либо хранилище,
  • доступный на сервере php модуль mcrypt (иначе отобразится соответствующая ошибка и будет недоступно шифрование).

Если используется копирование в облако "1С-Битрикс", то дополнительно необходимы:

  • активный коммерческий лицензионный ключ,
  • установленый модуль Облако 1С-Битрикс (bitrixcloud) .
Примечание: Хранение бэкапа в облаке "1С-Битрикс" не требует оплаченного и подключённого стороннего облачного хранилища. Однако объем хранимой информации ограничен:
  • «1С-Битрикс: Управление сайтом» - Старт: 1 Гб;
  • «1С-Битрикс: Управление сайтом» - Стандарт: 2 Гб;
  • «1С-Битрикс: Управление сайтом» - Малый бизнес: 4 Гб;
  • «1С-Битрикс: Управление сайтом» - Эксперт: 6 Гб;
  • «1С-Битрикс: Управление сайтом» - Бизнес: 10 Гб;
  • «Битрикс24 в коробке» - Корпоративный портал: 20 Гб;
  • «Битрикс24 в коробке» - Холдинг: 50 Гб.

В облаке "1С-Битрикс" будут храниться только 3 файла бэкапа, более ранние по времени будут удаляться автоматически. При нехватке места будет удалена самая ранняя копия (или все копии, если будет недостаточно места для сохранения новой).

В других облачных хранилищах число файлов бэкапа зависит от места, имеющегося в вашем распоряжении. Если места в облаке не хватит, то для сохранения последней копии удалятся все предыдущие. Если не хватит места для сохранения единственной копии, то будет выведено предупреждение.

Возможная ошибка: при создании резервной копии в облачное хранилище дополнительно создаётся и локальная копия. Ошибка возникает потому что файл не сразу отправляется в облако: сначала создается локально, потом идет проверка целостности, только после этого отправляется в облако. Если передача была успешна, локальный файл удаляется. Если возникла ошибка при передаче, то локальный файл остаётся.

Примечание: Облако "1С-Битрикс" доступно пользователям с активной лицензией. Если лицензия закончилась, то файл бэкапа будет доступен в облаке "1С-Битрикс" в течение двух недель. Но восстановить резервную копию из облака можно только при наличии активного лицензионного ключа.

Шифрование

При хранении резервной копии в любом облачном хранилище требуется гарантия безопасности данных. Делается это с помощью шифрования. Для шифрования бэкапа в настройках на закладке Параметры должна быть включена опция Шифровать данные резервной копии.

Примечание: при размещении резервной копии в облачном хранилище "1С-Битрикс" отключить шифрование нельзя.

Внимание! Пароль пользователя не хранится в системе Bitrix Framework или в компании "1С-Битрикс". При создании бэкапа на сервер компании "1С-Битрикс" передается только хеш пароля пользователя, который позволяет проверить корректность пароля, но не дает возможности распаковать архив.

Компания "1С-Битрикс" не может восстановить или поменять пароль! Будьте внимательны, без знания этого пароля восстановить бэкап не удастся! Восстановить сайт из бекапа при утере пароля техподдержка "1С-Битрикс" также не может.

Список резервных копий привязывается к лицензионному ключу (для многосайтовой установки облачное хранилище будет общее). Если даже произошла "утечка" ключа в чужие руки, то невозможно переполнить хранилище этого ключа: записывать резервные копии можно только с оригинальной установки (допускается еще одна копия для разработки). Повторный ввод ключа блокирует запись бэкапа.

Если шифрование включено, то перед началом создания резервной копии появится окно для ввода пароля . Рекомендуем, чтобы пароль содержал не менее 6 знаков и использовал спецсимволы.

Примечание: для каждой резервной копии можно задать свой отдельный пароль.

После задания пароля продолжится создание резервной копии.

Резервную копию из облака "1С-Битрикс" можно только восстановить.

Из стороннего облачного хранилища архив можно скачать на локальный носитель. Помните, что место в стороннем облаке также ограничено вашим тарифным планом.


Регулярное резервное копирование
95 / 694

Во многих случаях потеря или повреждение информации могут стоить очень дорого. Чтобы дополнительно обезопасить себя от возможных проблем с восстановлением данных, настройте регулярное резервное копирование. Так вы сможете быть уверены, что не забудете сделать бэкап и что информация в резервной копии будет актуальной.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

С версии 12.0 в Bitrix Framework возможно создание резервных копий в автоматическом режиме. Параметры автоматического резервного копирования задаются на странице Регулярное резервное копирование (Настройки > Инструменты > Резервное копирование > Регулярное резервное копирование).

Нажмите на рисунок, чтобы увеличить

Примечание: Детальное описание полей формы смотрите в документации.

Настройки автоматического бэкапа

На странице Регулярное резервное копирование можно:

  1. Включить или выключить регулярное копирование
  2. Указать, где размещать резервную копию - локально на сайте, либо в облаках: 1С-Битрикс или в стороннем облаке
  3. Задать расписание копирования
  4. Настроить порядок сохранения или удаления локальных копий
  5. Указать, какие части сайта исключать или включать в резервную копию (аналогично настройкам при ручном архивировании)
  6. Настроить режим архивации

    Примечание: при автоматическом создании резервной копии, в отличие от ручного создания, приходится хранить пароль пользователя в базе данных в зашифрованном виде. Для шифрования используется лицензионный ключ. То есть несанкционированный доступ к файлу архива возможен, если только злоумышленник получит полный доступ к вашему сайту. Даже если такое произойдёт, то удалить архив сайта с облака "1С-Битрикс" ему не удастся.

  7. Выбрать метод запуска резервного копирования. Доступен запуск:
    • через облачный сервис 1С-Битрикс
    • с агентами на cron. Нужно настроить выполнение агентов на cron, запуская каждую минуту /bitrix/modules/main/tools/cron_events.php. При этом автоматическое резервирование будет выключено.
    • через прямой запуск /bitrix/modules/main/tools/backup.php. Если по каким-то причинам на проекте не используются агенты , то необходимо настроить на определенное время запуск php скрипта /bitrix/modules/main/tools/backup.php через панель хостинга.

Как работает автоматическое резервное копирование в зависимости от метода запуска
  • Если выбрано копирование через облачный сервис, то для создания копии не нужно производить никаких дополнительных действий. Это самый простой вариант. Он рекомендуется для несложных проектов с малоопытными администраторами.

    После запуска процесса на странице Настройки > Облако 1С-Битрикс > Расписание резервирования появится ваше расписание, уникальный идентификатор которого передаётся облачному сервису. При наступлении указанного времени создания резервной копии сервис откроет специальную страницу на вашем сайте и передаст ей требуемые параметры, чтобы создать бэкап. Доступ к административной части не требуется и административный раздел может быть закрыт по IP.

    После выполнения копирования, на странице Настройки > Облако 1С-Битрикс > Резервные копии появится список всех создаваемых копий. Эти же копии отобразятся на странице Настройки > Инструменты > Резервное копирование > Список резервных копий. С этой страницы возможно их восстановление.

    Примечание: так как резервное копирование делается на серверах в облаке, на странице Настройки > Облако 1С-Битрикс > Расписание резервирования время создания бэкапа указывается по UTC.

  • Скрипт /bitrix/modules/main/tools/cron_events.php выполняется на cron'е каждую минуту. Сначала он проверяет отправку почты и выполняет системные агенты. Затем, если наступило установленное в настройках время, создаётся резервная копия. Создание копии задано не через агент сознательно: чтобы отправка почты и выполнение агентов могли выполняться независимо от создания резервной копии.

    Если произошла какая-то ошибка при автоматическом резервном копировании, то повторный запуск скрипта будет возможен только через сутки. А в течение этих суток создать бэкап можно только вручную. Это сделано для того, что бы на хостинге не возникало неприятных ситуаций из-за ошибок и зацикливания резервного копирования.

    В случае ошибки в системный журнал заносится соответствующее уведомление. На странице Настройки > Инструменты > Резервное копирование > Журнал резервного копирования расположен фильтр системного журнала, настроенный на вывод только записей по резервным копиям:

    Нажмите на рисунок, чтобы увеличить

Документация по теме:

  • Автоматическое резервное копирование в облако битрикс (блог)


Резервное копирование из командной строки
96 / 694

Возможно, вы предпочитаете использовать запуск из командной строки вместо штатных инструментов резервного копирования? Учтите, что перед выполнением бэкапа вам обязательно необходимо перейти в папку, где установлено «Битрикс: Веб-окружение», иначе не подключатся нужные модули php.

Пример для Windows

Если «Битрикс: Веб-окружение» размещено по пути c:\Bitrix\, то нужно перейти в папку:

cd c:\Bitrix\

И выполнить бэкап без БД:

"C:\Bitrix\apache2\zendserver\bin\php.exe" -c "C:\Bitrix\apache2\zendserver\etc\php.ini" -f "C:\Bitrix\www\bitrix\modules\main\tools\backup.php"


Восстановление сайта из резервной копии
97 / 694

Для восстановления сайта на странице Список резервных копий (Настройки > Инструменты > Резервное копирование > Список резервных копий) в меню действий выберите пункт Восстановить . Система запустит мастер восстановления из резервной копии.

  • Если архив был сохранен в облаке «1С-Битрикс», то будет предложено выбрать файл с архивом (необходимо ввести лицензионный ключ, если он не был введен ранее в системе) и пароль:

  • Если архив с резервной копией был сохранен локально, то после ввода пароля (если архив запаролен) начнется распаковка архива .
  • После завершения распаковки файлов необходимо будет указать настройки соединения с базой данных для восстановления сайта вместе с БД, или пропустить восстановление базы данных :

    Настройки подключения к MySQL по умолчанию берутся из /home/bitrix/www/bitrix/php_interface/dbconn.php.

    Можно указать собственные параметры подключения к MySQL - в этом случае необходимо еще выбрать опцию Создать базу данных, если не существует.

  • После успешного восстановления базы данных в целях безопасности необходимо Удалить локальную резервную копию и служебные скрипты, нажав на одноименную кнопку:

  • Восстановление завершено .

Примечание: О переносе сайта с одного сервера на другой можно прочитать в уроке Перенос продукта «1C-Битрикс» v.12.

Если вы не можете попасть в админку

Например, ваш сайт не отвечает или выдается сообщение

.

Такое может случиться, если во время работы мастера восстановления произошел сбой или вы самостоятельно пытались прервать его работу.

В этом случае в адресной строке браузера наберите http://ваш_сайт/restore.php. Если вы раньше не скачивали скрипт restore.php, то можете скачать свежую версию скрипта с сайта 1С-Битрикс.

После запуска скрипта запустится мастер восстановления.

Дальше действуйте, как описано в уроке о переносе продукта.


Проверьте себя
98 / 694

Ответьте на несколько вопросов по теме Резервное копирование, которые помогут вам самим оценить свои знания. Это не тест, это просто проверка того, как вы поняли тему. Удачи!

Верно ли утверждение?

Оцените верность утверждения: Верно или Неверно. А потом в спойлере проверьте ваш выбор.

1 При хранении в облаке 1С-Битрикс получить доступ к резервной копии без лицензионного ключа и пароля невозможно.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
2 При многосайтовости в работоспособном состоянии восстанавливаются все сайты.
Верно
Увы, вы ошиблись. Полностью восстановится только тот сайт, который был первым по сортировке в списке сайтов при создании резервной копии. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
3 Многосайтовость надо восстановить вручную. Только после этого остальные сайты будут работоспособны.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
4 Размер частей архива резервной копии не ограничен системой.
Верно
Увы, вы ошиблись. Системные ограничения php не позволяют делать размер одной части архива более 2 Гб, а оптимальным значением является 100 Мб. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
5 В CMS "1С-Битрикс" есть три возможности хранения резервной копии: на локальном компьютере, в облаке 1С-Битрикс или в сторонних облачных хранилищах.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
6 В рамках файловой структуры сайта файлы копий хранятся в папке /bitrix/backup.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
7 В облаке "1С-Битрикс" доступно хранение только одного бэкапа на каждую активную лицензию.
Верно
Увы, вы ошиблись. В облаке "1С-Битрикс" может храниться три файла бэкапа на активную лицензию. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
8 Системой предусмотрена возможность настройки автоматического создания резервной копии.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.


Работа с инфоблоками
99 / 694

Модуль Информационные блоки предназначен для управления различными блоками однородной информации. На базе информационных блоков можно реализовать каталоги товаров, блоки новостей, справочники и т.д.

Данная глава содержит подробное описание элементов модуля, а также примеры создания и настройки различных информационных блоков.

Дополнительная информация

  • Информационные блоки (документация)


Общий порядок работы с информационными блоками
100 / 694

Общий порядок работы с информационными блоками

Создание любого раздела сайта с использованием информационных блоков необходимо проводить в следующем порядке:

  1. Внимательное продумывание структуры инфоблоков.

    Примечание. На начальном этапе создания сайта еще можно будет переделать всю работу без особых временных потерь. Однако после импорта какой-нибудь большой базы данных при неудачно созданной структуре возможна ситуация, когда потребуется повторить весь импорт заново: инфоблоки не могут менять свой тип. И если вам нужно перенести данные из одного типа инфоблока в другой, то сделать это можно только экспортом данных и импортом их в новый инфоблок другого типа. Аналогично и с разделами и элементами.

  2. Создание нужного типа инфоблоков с настройкой параметров.
  3. Создание самих инфоблоков с настройкой параметров.
  4. Создание структуры внутри инфоблока.
  5. Создание элементов инфоблока
  6. Создание физической страницы (в случае использования комплексного компонента) или страниц (при использовании простых компонентов) и размещение на ней компонента (компонентов) с последующей настройкой свойств компонента.
  7. Кастомизация работы компонента под потребности ТЗ сайта.

Четвертый и пятый пункт, как правило, выполняют контент-менеджеры, если наполнение инфоблока производится вручную, а не импортом.

Одной из самых простых и распространенных схем структуры инфоблоков является обычная древовидная система типа:

Пример схемы структуры инфоблоков

В зависимости от целей проекта эту структуру можно реализовать разными способами. Например, через один тип инфоблока и несколько инфоблоков. В этом варианте типу товаров будет соответствовать инфоблок, группе товаров — раздел инфоблока, товару — элемент инфоблока. Более сложные схемы каталогизации можно реализовать, создавая разные типы инфоблока и разветвляя разделы инфоблока за счет вложенных подразделов.


Вложенные ЧПУ: формируем полные адреса
101 / 694

Вложенные ЧПУ: формируем полные адреса

Представьте, что инфоблок имеет многоуровневую структуру и некий элемент хранится в подразделе sectionC:

Нажмите на рисунок, чтобы увеличить

Несмотря на вложенность разделов, адрес в браузере при просмотре такого элемента будет иметь вид:

mysite.ru/catalog/sectionC/element/

Вам не подходит такой вариант? Формируйте абсолютные пути к элементам инфоблока вместе с инструментом вложенных ЧПУ:

mysite.ru/catalog/sectionA/sectionB/sectionC/element/

Примечание: поддержка вложенных ЧПУ доступна с версии 12.5 модуля Информационные блоки и реализована только для комплексных компонентов catalog, news и photo.

Как выполнить настройки?

  1. Откройте форму редактирования инфоблока, для элементов которого вы хотите настроить пути.
  2. В полях URL страницы раздела и URL страницы детального просмотра для настройки шаблонов путей используйте переменную SECTION_CODE_PATH:

    Нажмите на рисунок, чтобы увеличить
  3. Для всех разделов инфоблока укажите символьные коды .

    Примечание: настройте обязательность заполнения поля Символьный код и вы не будете забывать указывать код при создании новых разделов. Дополнительно можете включить автогенерацию кода из названия раздела путем транслитерации.
  4. Откройте настройки компонента, с помощью которого опубликована информация из инфоблока.
  5. Задайте шаблоны адресов с помощью символьных кодов раздела:

    Внимание! Использование слеша в конце адреса обязательно. Для системы адреса вида /catalog/section1/element1 и /catalog/section1/element1/ - это разные адреса.

Теперь просмотр ваших элементов будет выполняться по полным адресам.

Заключение

Абсолютные пути формируются с помощью переменной SECTION_CODE_PATH:

  1. укажите ее в форме редактирования инфоблока при настройке шаблонов путей;
  2. используйте эту переменную при настройке адресов страниц в компоненте.

Почитайте следующий урок и познакомьтесь, как выделить основную страницу элемента среди всех дублей.


Настройка SEO данных в инфоблоке
102 / 694

Настраиваем SEO

Настраивайте шаблоны метаданных для всего инфоблока или создавайте персональную настройку для конкретных разделов и элементов раздела. В видео показан пример настройки для инфоблока новостей.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Давайте еще посмотрим, как это сделать на примере инфоблока Одежда.

Настройки

Шаблоны метаданных для инфоблока (всех его разделов и элементов) настраиваются в форме редактирования инфоблока (Контент > Инфоблоки > Типы инфоблоков > _ваш_инфоблок_) на закладке SEO . В первых двух секциях настройки шаблонов мета-тегов TITLE, KEYWORDS, DESCRIPTION и заголовков страницы раздела/элемента. Для выбора шаблона служит кнопка [...] рядом с каждым полем:

Нажмите на рисунок, чтобы увеличить

Заполним настройки для разделов и для элементов:

В последующих секциях закладки SEO выполняются настройки шаблонов для тегов ALT, TITLE и имени файлов картинок анонса и детальных картинок разделов/элементов инфоблока.

Внимание! Настройки шаблона имени файлов работают только для тех файлов, которые загружены в систему после выполнения настроек. Для ранее загруженных файлов настройки не применяются.

Все ваши настройки SEO в инфоблоке видны в формах редактирования его разделов и элементов. Посмотрим, как это выглядит на примере раздела Платья инфоблока Одежда и увидим, что во всех шаблонах правильно подставилось название текущего раздела:

Если необходимо изменить какую-то из настроек, отметьте опцию Изменить для этого раздела и его подразделов или кликните мышью по полю (опция отметится автоматически). Теперь доступна кнопка [...] для выбора шаблона и ручной ввод. Обязательно отметьте при этом опцию Очистить кеш вычисленных значений . В этом случае кеш шаблонов очищается и все изменения сразу отобразятся.

Примечание Для отображения заголовка из параметра Заголовок раздела на странице раздела, отметьте опцию Устанавливать заголовок страницы в компоненте, который выводит данные инфоблока.

Теперь добавим новый элемент в наш инфоблок Одежда, раздел Платья. После заполнения необходимых полей формы, нажимаем кнопку Применить (или Сохранить). Данные нового элемента подставятся в шаблоны настроек SEO.

Фильтры-обработчики

Создавая шаблоны, при необходимости, используйте фильтры-обработчики вручную:

  • {=lower arg1 ... argN} - приведение к нижнему регистру;
  • {=upper arg1 ... argN} - приведение к верхнему регистру;
  • {=concat arg1 ... argN ", "} - сцепление строк через разделитель;
  • {=limit arg1 ... argN "<delimiter>" NN} - ограничение NN элементов по разделителю ;
  • {=translit arg1 ... argN} - транслитерация выбранных аргументов;
  • {=min arg1 ... argN} - выборка минимального числового значения;
  • {=max arg1 ... argN} - выборка максимального числового значения;
  • {=distinct arg1 ... argN} - уникальные (без дублей) значения.

Пример: у нас указано {=lower this.Name}. А мы хотим привести к верхнему регистру. Заменим вручную lower на upper. Результат применения сразу отобразится под полем ввода:

Как выглядит исходный код страницы после настроек SEO

Если просмотреть исходный код страницы раздела Платья, то мы увидим в нем все заданные в настройках метатеги:

<head>
...
<meta name="keywords" content="Платья, купить Платья, приобрести Платья, Платья в различных цветах, Платья от дистрибьютора">
<meta name="description" content="В магазине Одежда+ собраны уникальные Платья, представленный официальным дистрибьютором в России">
...
<title>Уникальные Платья от магазина Одежда+</title>
...
</head>

Документация по теме:

  • Создание и редактирование информационного блока. Закладка SEO;
  • Создание и редактирование раздела инфоблока. Закладка SEO;
  • Создание и редактирование элемента инфоблока. Закладка SEO;
  • Настройка SEO информации в главе Разделы и элементы курса Контент-менеджер.


Редактор изображений в элементах инфоблока
103 / 694

Редактор изображений в элементах инфоблока

Делайте информацию в инфоблоках привлекательной, загружайте большое количество фотографий. При этом не нужно устанавливать специальное программное обеспечение, в инфоблоки встроен собственный редактор изображений.

Примечание: инструмент загрузки и обработки изображений доступен с версии 15.5.1. Его можно использовать для картинок анонса , детальных картинок элемента, для фотографий, загружаемых в свойство типа Файл и для изображений раздела.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Как пользоваться редактором?

  1. Откройте форму редактирования элемента (раздела).
  2. Перетащите в область картинок изображения с локального компьютера.
    Хотите загрузить из других источников? Используйте кнопку [image].
  3. Дважды кликните по добавленному изображению либо нажмите на "карандашик" под изображением. Откроется окно редактора:

    Нажмите на рисунок, чтобы увеличить

    Примечание: для добавляемых изображений редактор откроется автоматически, если предварительно в меню кнопки [image] отметить пункт Использовать кадрирование .
  4. Придайте подходящий вид изображению, отображаемому в рабочей области 1. При этом:
    • Инструменты панели 3 используйте для поворота, отражения, обрезки изображения , а также при переводе изображения в черно-белый вид и добавлении подписи.
    • Сохраняйте настройки выполняемой вами обрезки по кнопке 5, чтобы применять их в дальнейшем.
    • Обрезайте изображение по вашим настройкам: в панели 4 выберите пресет и нажмите кнопку [image]. В рабочей области 1 сразу отобразится рамка обрезки нужного размера.

      Старые пресеты редактируйте по кнопке [image] панели 4.
    • Изменяйте размеры изображения в абсолютном 6 или процентом соотношении 7.
    • Не бойтесь ошибиться. Любое действие отменяется по кнопке 8.
    Если вы загрузили несколько изображений в область, то не закрывайте редактор. Переключайтесь между обрабатываемыми изображениями с помощью панели 2.
  5. Сохраните выполненные настройки.

Заключение

Вы узнали, как пользоваться встроенным инструментом загрузки и обработки изображений. Попробуйте инструмент в работе, добавьте изображения в элементы инфоблока на вашем сайте.


Экспорт/импорт данных
104 / 694
Экономьте свое время вместе с инструментами импорта и экспорта. Импорт предназначен для пополнения инфоблоков данными из внешнего источника, а экспорт - для выгрузки и использования информации на другом проекте. Импорт и экспорт - самый оптимальные способы работы с большими объемами данных.


Формат CSV
105 / 694

Переносите информацию вместе с широко используемым форматом CSV. Создавайте и редактируйте csv-файлы самостоятельно. С помощью MS Excel это под силу даже обычному пользователю. Почитайте уроки главы и вы научитесь выгружать и загружать данные формата CSV.


Экспорт данных
106 / 694

Экспорт данных

Нужно выгрузить информацию из инфоблока в файл формата CSV? Используйте встроенный инструмент и вы выгрузите данные всего за 4 простых шага.

Важно! Если инфоблок содержит товары, то используйте другой инструмент экспорта: Магазин > Настройки > Экспорт данных. Подробнее в курсе Администратор. Бизнес.

Выгрузка данных из инфоблока

Шаг 1. Откройте страницу Выгрузка информационного блока (Контент > Инфоблоки > Экспорт > CSV):

Нажмите на рисунок, чтобы увеличить

Шаг 2. В выпадающих списках выберите сначала тип, а затем и сам инфоблок, данные из которого экспортируете. Нажмите Далее.

Примечание: уровень глубины вложенности выгружаемых разделов определяется настройками модуля Информационные блоки.

Шаг 3. Задайте параметры экспорта:

  • Выберите разделитель полей и определите первую строку файла.
  • Отметьте поля для выгрузки .
  • Задайте путь к файлу , в который выполняется экспорт.

Шаг 4. Нажмите кнопку Начать выгрузку. Начинается экспорт инфоблока, и в форме отображается ход процесса выгрузки. По окончании выводится соответствующее сообщение . Скачайте файл и используйте его для своих целей.

Кто может выполнять экспорт?

С версии 15.0.6 модуля Информационные блоки выгружать данные могут те пользователи, которым разрешена операция Экспорт инфоблока . По умолчанию такая операция входит только в уровень доступа Полный доступ.

Создавайте собственные уровни доступа, чтобы пользователи не имели полного доступа, но могли экспортировать инфоблок.

Примечание: для создания уровней доступа необходимо обладать правами администратора. Если такой возможности нет, то обратитесь за помощью к администратору сайта.

Заключение

Итак, вы познакомились, как выгрузить данные из инфоблока в CSV-файл, а также узнали, кто может это делать. В следующем уроке Вы узнаете, как готовить данные для загрузки в инфоблок.

Документация по теме:

  • Экспорт в формате CSV


Как подготовить CSV-файл для загрузки данных
107 / 694

Как подготовить CSV-файл для загрузки данных

Когда наполняете сайт данными через инструмент импорта, то вас, несомненно, волнует вопрос успешности загрузки данных. Избегайте ошибок и траты времени впустую, подготавливайте csv-файл правильно. Рассмотрим основные вопросы подготовки файла с данными.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

В какой программе создавать файл?

Используйте MS Excel. Вы, конечно, можете пользоваться и другими, вплоть до простого текстового редактора Блокнот, но привычный табличный редактор более удобен. Создайте в MS Excel новый файл, заполните таблицу данными (подробнее остановимся ниже) и сохраните его с расширением csv.

Пример итогового файла .csv

Название;Название раздела;Название подраздела;Фото;Анонс;Детальное описание
Чемпионы мира сыграли с детьми;Новости спорта;Футбол;child.jpg;Команда профессиональных футболистов провела дружеский матч с дворовыми командами города.;Это было сюрпризом для ребят. Участники сборной подъехали к полю, где играли ребята, и предложили сыграть дружеский матч.
Проведены первые тренировки;Новости спорта;Хоккей;hockey.jpg;Долгожданное открытие секции по хоккею;Всего за неделю был полностью оборудован каток для проведения игр, а также организованы раздевалки и зоны питания.
Новое кино - о любви и литературе;Новости кино;Русское кино;girl.jpg;По мотивам нашумевшего романа.;Деликатно и вместе с тем чувственно описаны события прошедшего столетия.
Результаты ожидаемой кинопремии;Новости кино;Зарубежное кино;cinema.jpg;Победители кинопремии поделились эмоциями.;Кто-то из них даже не ожидал, что именно он получит премию.

По умолчанию в «1С-Битрикс:Управление сайтом» для файлов импорта используется разделитель «;» (точка с запятой). Если вы в своем файле используете иной, то при выполнении импорта не забудьте указать в настройках нужный.

Примечания:
1) Если при сохранении файла в csv-формате в MS Excel нет формата разделителя «;», то выберите разделитель «,». На самом же деле файл все равно сохранится с нужным разделителем – точка с запятой.
2) Сохранять файл нужно в кодировке вашего сайта – эту информацию можно уточнить у администратора сайта или посмотреть в региональных настройках.

Технический минимум полей для csv-файла

В файле CSV должно присутствовать хотя бы одно из двух полей (по этим полям элементы сопоставляются с базой данных):

  • Название элемента (так элемент будет отображаться в каталоге);
  • уникальный идентификатор элемента XML_ID.

Рассмотрим случаи, когда и какое из полей должно быть обязательно:

  • Если Вы только вносите изменения в уже существующие на сайте элементы, то можно указывать только XML_ID (т.к. в первую очередь база данных сверяется именно по XML_ID);
  • Если Вы создаете новый элемент, то Вам достаточно указать название элемента, а XML_ID будет добавлен автоматически при импорте.

Создание структуры каталога и распределение элементов

Часто при импорте необходимо, чтобы элементы попадали строго в нужные разделы уже созданного каталога. В этом случае в файле создайте колонки, которые будут объяснять системе, куда какой элемент распределять. Рассмотрим крайне простую структуру с двумя уровнями вложенности.

  1. Создайте колонку для первого уровня и назовите ее, например, Название раздела.
  2. Создайте колонку для второго уровня, например, Название подраздела.
  3. Заполните колонки Название раздела и Название подраздела для всех элементов, согласно вашей структуре.

    Примечания:
    • Названия, вводимые в эти колонки, должны точно совпадать с теми названиями, которые используются в каталоге. Если названия не будут совпадать, то система при импорте создаст разделы с новыми названиями и в них поместит импортируемые элементы.
    • Структуру каталога можно заранее не создавать. При первом импорте будут созданы разделы нужного уровня вложенности с названиями, заданными в колонках файлах. Но при регулярном импорте важно указать точное название разделов для импорта элементов.
    • Если будут указаны названия разделов нижнего уровня, но не указаны имена разделов верхнего уровня, то будут созданы папки верхнего уровня с именем «Пустое название». Если у вас случайно произошла такая ошибка, то повторного импорта можно не производить. Просто перенесите добавленные элементы в нужную папку.
    • Уровень глубины вложенности разделов для импорта определяется настройками модуля Информационные блоки.
  4. Создайте колонки, соответствующие необходимым данным для импорта.
  5. Заполните колонки данными.

Некоторые моменты

  • Название колонок с параметрами не обязательно должно совпадать с названиями параметров в системе. Главное, чтобы они были понятны пользователю, выполняющему импорт, и при задании условий импорта у него не возникло затруднений в определении соответствий полей создаваемого файла CSV и полей формы импорта.
  • Добавление элемента в колонки со свойством типа Привязка к элементу не произведет автоматического привязывания элемента, если элементы еще не созданы (так как заполнить эту колонку можно только ID элементов, а они еще неизвестны). Привязку необходимо осуществить после импорта вручную, как это делается при ручном добавлении. Однако если элементы инфоблоков уже созданы, то можно в соответствующие колонки ввести код элемента.
  • При добавлении численных значений необходимо следить, чтобы разделитель десятичных знаков, используемый в «1С-Битрикс:Управление сайтом», совпадал с разделителем, используемым в csv-файле. В системе «1С-Битрикс:Управление сайтом» в качестве разделителя десятичных знаков используется точка.
  • Если для элемента отсутствует значение для некоторого типа данных, то нужно просто поставить второй знак разделителя .
  • Для загрузки данных для свойств с признаком множественности необходимо повторить строку с элементом столько раз, сколько будет значений множественного поля.
    Например, множественное поле имеет три значения . Следовательно, в csv-файле получится по три строки элемента на каждое значение поля. (Если множественных свойств несколько, то число строк должно равняться числу параметров наибольшего свойства. Ячейки для параметров свойств с меньшим числом можно просто оставить пустыми) Все строки должны быть одинаковыми по содержанию, за исключением множественных полей, которые изменяются указанием новых данных для этого свойства. Подобная особенность импорта с помощью стандартного механизма приводит к распуханию файла, если количество множественных свойств велико и они интенсивно используются. При импорте больших файлов следует использовать пошаговые операции.
  • Проверьте настройки инфоблока (Контент > Инфоблоки > Типы инфоблоков > [ваш тип инфоблока]/[ваш инфоблок]), в который Вы хотите загрузить файл: если во вкладках Поля или Поля разделов какие-либо поля отмечены как обязательные, то эти колонки должны быть обязательно и в загружаемом csv-файле.

Изображения для элементов

Перед импортом загрузите изображения в систему. В csv-файле для них должны быть выделена своя отдельная колонка. Картинки могут быть расположены в любом месте в рамках файловой структуры, главное – указать при импорте правильный путь до них. Рекомендуется использовать папку /upload.

Заключение

Вы ознакомились с важными моментами создания csv-файла. Почитайте следующий урок и приступайте к процедуре импорта.


Импорт данных
108 / 694

Импорт данных

Наполняете инфоблок данными? Сберегите свое время и силы. Подготовьте CSV-файл с данными, а встроенный инструмент импорта быстро загрузит все данные в инфоблок.

Важно! Если инфоблок содержит товары, то используйте другой инструмент импорта: Магазин > Настройки > Импорт данных. Подробнее в курсе Администратор. Бизнес.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Загрузка данных в инфоблок

  1. Откройте страницу Загрузка информационного блока (Контент > Инфоблоки > Импорт > CSV):

    Нажмите на рисунок, чтобы увеличить
  2. Задайте параметры:
    • Файл данных - с помощью кнопки Открыть... выберите файл в CSV-формате с сервера или загрузите с локального компьютера.
    • Информационный блок - в выпадающих списках выберите сначала тип, а затем и сам инфоблок, данные в который импортируете.

    Примечание: уровень глубины вложенности загружаемых разделов определяется настройками модуля Информационные блоки.

    Нажмите Далее.
  3. Укажите формат вашего файла с данными. Нажмите Далее.
  4. Задайте соответствия между полями в файле и полями информационного блока, в который выполняется загрузка.

    Важно! Обязательно должно быть выбрано хотя бы одно из полей Уникальный идентификатор (B_IBLOCK_ELEMENT.XML_ID) или Название (B_IBLOCK_ELEMENT.NAME). Эти поля используются для сопоставления записей в файле записям в базе данных.

    Также проверьте настройки инфоблока (Контент > Инфоблоки > Типы инфоблоков > [ваш тип инфоблока]/[ваш инфоблок]), в который Вы хотите загрузить файл: если во вкладках Поля или Поля разделов какие-либо поля отмечены как обязательные, то эти колонки должны быть обязательно и в загружаемом csv-файле.

    О дополнительных настройках читайте в документации.

  5. Нажмите кнопку Загрузить данные. Начинается импорт инфоблока, и в форме отображается ход процесса загрузки. По окончании выводится соответствующее сообщение .

    Перейдите к списку элементов инфоблока и проверьте результат загрузки данных.

Примечание: при импорте больших объёмов данных рекомендуется отключать индексацию созданных элементов модулем Поиск. Это существенно увеличит скорость создания элементов. Если в инфоблоке больше 100 тысяч записей, то производительность уже серьезно начинает зависеть от аппаратных возможностей сервера и настроек программного обеспечения (MySQL в первую очередь).

Заключение

Итак, вы познакомились с загрузкой данных в инфоблок из CSV-файла. Почитайте материалы следующей главы и узнайте, как правильно выгружать и загружать данные в формате XML.

Документация по теме:

  • Импорт в формате CSV


Формат XML
109 / 694
Знакомы с форматом XML? Используйте знания для оптимизации своей работы. Выгружайте и загружайте информацию в инфоблоки за три простых шага. Уроки главы помогут вам в этом.


Экспорт данных
110 / 694

Экспорт данных

Выгружайте данные из инфоблока в формате XML. Встроенный инструмент позволяет переносить не только содержимое инфоблоков, но и все свойства (в том числе и пользовательские свойства разделов) и изображения. Экспорт в XML-файл совершается всего за 3 шага.

Выгрузка данных из инфоблока

Шаг 1. Откройте страницу Экспорт XML (Контент > Информационные блоки > Экспорт > XML):

Нажмите на рисунок, чтобы увеличить

Шаг 2. Задайте параметры экспорта:

  • Файл для выгрузки – укажите путь относительно корня сайта к файлу и сам XML-файл, в который будет выгружена информация из инфоблока. Для файла достаточно задать только его имя, а инфоблок выгрузится по указанному пути в файл <имя_файла>.xml.
  • Информационный блок – выберите информационный блок для экспорта.
  • Длительность шага в секундах – укажите количество секунд выполнения шага экспорта. Если указано 0, то экспорт инфоблока будет осуществлен за один шаг. Учтите, что слишком маленький шаг может существенно нагрузить систему, если элементов очень много, а большой шаг - удлинить процесс экспорта.
  • Разделы – задайте условия выгрузки разделов.
  • Элементы – определите условия выгрузки элементов.

Примечание: экспорт инфоблока в XML не имеет ограничений на вложенность.

Шаг 3. Нажмите кнопку Экспортировать. Начинается экспорт инфоблока, над формой отображается ход процесса выгрузки. По окончании выводится соответствующее сообщение .

Итак, xml-файл с данными доступен для скачивания по указанному в параметре Файл для выгрузки пути. Изображения и файлы инфоблока выгружаются в папку с названием <имя_файла>_files (она размещается внутри той же папки, где и файл экспорта).

Таблица соответствия CommerсML и инфоблоков

В таблице ниже приведены соответствия тегов CommerсML и стандартных полей инфоблоков\(свойств элементов) демо-данных.

Значение | Тип данных | Обязательность | Множественное | Наименование
CML2_ACTIVE | boolean (логический) | Нет | Нет | Активность
CML2_CODE | string (строка) | Нет | Нет | Символьный код
CML2_SORT | Число | Нет. По умолчанию автоматически генерируется | Нет | Сортировка
CML2_ACTIVE_FROM | Дата\Время | Нет. По умолчанию - не задано | Нет | Начало активности
CML2_ACTIVE_TO | Дата\Время | Нет. Можно задать продолжительность активности (дней) | Нет | Окончание активности
CML2_PREVIEW_TEXT | HTML/Текст | Нет | Нет | Анонс
CML2_DETAIL_TEXT | HTML/Текст | Нет | Нет | Описание
CML2_PREVIEW_PICTURE | Идентификатор файла | Нет | Нет | Картинка для анонса
BLOG_POST_ID | Число | Нет | Нет | ID блога
REAL_PICTURE | Файл | Нет | Нет | Оригинал
DESCRIPTION | Строка | Нет | Нет | Описание
SOURCE | Строка | Нет | Нет | Источник
KEYWORDS | Строка | Нет | Нет | Ключевые слова
THEMES | Привязка к разделам | Нет | Да | Темы
BROWSER_TITLE | Строка | Нет | Нет | Заголовок окна браузера
AUTHOR | Строка | Нет | Нет | Автор
FORUM_TOPIC_ID | Число | Нет | Нет | Идентификатор темы форума
FORUM_MESSAGE_CNT | Число | Нет | Нет | Количество комментариев
vote_count | Число | Нет | Нет | Количество голосов
vote_sum | Число | Нет | Нет | Сумма голосов
rating | Число | Нет | Нет | Рейтинг
URL | Строка | Нет | Нет | Адрес сайта
EMAIL | Строка | Нет | Нет | Ваш e-mail
USER_ID | Привязка к пользователю | Нет | Нет | Владелец ресурса
PHONE | Строка | Нет | Нет | Телефон
FILE | Привязка к файлу (на сервере) | Нет | Нет | Файл
DURATION | Строка | Нет | Нет | Длительность
type | Список | Нет | Нет | Тип поля
values | Строка | Нет | Да | Значения
BIRTHDATE | Дата\Время | Нет | Нет | Год рождения
YEAR | Строка | Нет | Нет | Год выпуска
ISBN | Строка | Нет | Нет | ISBN
PAGES | Строка | Нет | Нет | Число страниц
PUBLISHER | Строка | Нет | Нет | Издатель
CML2_BAR_CODE | Строка | Нет | Нет | Штрихкод
CML2_ARTICLE | Строка | Нет | Нет | Артикул
CML2_ATTRIBUTES | Строка | Нет | Да | Характеристики
CML2_TRAITS | Строка | Нет | Да | Реквизиты
CML2_BASE_UNIT | Строка | Нет | Нет | Базовая единица
CML2_TAXES | Строка | Нет | Да | Ставки налогов
MORE_PHOTO | Файл | Нет | Да | Картинки
FORUM_TOPIC_ID | Число | Нет | Нет | ID темы форума
FORUM_MESSAGE_CNT | Число | Нет | Нет | Количество комментариев
BOOK | Привязка к элементам | Нет | Нет | Рецензия на книгу
PERSON | Строка | Нет | Нет | Руководитель

Пример файла xml (инфоблок "Новости" демо-данных)

<?xml version="1.0" encoding="UTF-8"?>
<КоммерческаяИнформация ВерсияСхемы="2.021" ДатаФормирования="2019-09-17T14:31:35">
    <Классификатор>
        <Ид>clothes_news_s1</Ид>
        <Наименование>Новости</Наименование>
        <Свойства>
            <Свойство>
                <Ид>CML2_ACTIVE</Ид>
                <Наименование>БитриксАктивность</Наименование>
                <Множественное>false</Множественное>
            </Свойство>
            <Свойство>
                <Ид>CML2_CODE</Ид>
                <Наименование>Символьный код</Наименование>
                <Множественное>false</Множественное>
            </Свойство>
            <Свойство>
                <Ид>CML2_SORT</Ид>
                <Наименование>Сортировка</Наименование>
                <Множественное>false</Множественное>
            </Свойство>
            <Свойство>
                <Ид>CML2_ACTIVE_FROM</Ид>
                <Наименование>Начало активности</Наименование>
                <Множественное>false</Множественное>
            </Свойство>
            <Свойство>
                <Ид>CML2_ACTIVE_TO</Ид>
                <Наименование>Окончание активности</Наименование>
                <Множественное>false</Множественное>
            </Свойство>
            <Свойство>
                <Ид>CML2_PREVIEW_TEXT</Ид>
                <Наименование>Анонс</Наименование>
                <Множественное>false</Множественное>
            </Свойство>
            <Свойство>
                <Ид>CML2_DETAIL_TEXT</Ид>
                <Наименование>Описание</Наименование>
                <Множественное>false</Множественное>
            </Свойство>
            <Свойство>
                <Ид>CML2_PREVIEW_PICTURE</Ид>
                <Наименование>Картинка анонса</Наименование>
                <Множественное>false</Множественное>
            </Свойство>
            <Свойство>
                <Ид>240</Ид>
                <Наименование>Картинки новостей</Наименование>
                <Множественное>true</Множественное>
                <БитриксСортировка>500</БитриксСортировка>
                <БитриксКод>PICS_NEWS</БитриксКод>
                <БитриксТипСвойства>F</БитриксТипСвойства>
                <БитриксСтрок>1</БитриксСтрок>
                <БитриксКолонок>30</БитриксКолонок>
                <БитриксТипСписка>L</БитриксТипСписка>
                <БитриксТипыФайлов>jpg, gif, bmp, png, jpeg</БитриксТипыФайлов>
                <БитриксКоличествоПолей>5</БитриксКоличествоПолей>
                <БитриксСвязанныйИнфоблок></БитриксСвязанныйИнфоблок>
                <БитриксОписаниеРазрешено>false</БитриксОписаниеРазрешено>
                <БитриксПоискРазрешен>false</БитриксПоискРазрешен>
                <БитриксФильтрРазрешен>false</БитриксФильтрРазрешен>
                <БитриксРасширениеТипа></БитриксРасширениеТипа>
                <БитриксОбязательное>false</БитриксОбязательное>
                <БитриксЗначениеПоУмолчанию>s:0:"";</БитриксЗначениеПоУмолчанию>
                <Сериализовано>1</Сериализовано>
            </Свойство>
        </Свойства>
        <СвойстваЭлементов>
            <Свойство>
                <Ид>240</Ид>
                <УмныйФильтр>false</УмныйФильтр>
                <ТипОтображения></ТипОтображения>
                <ПоказатьРазвёрнутым>false</ПоказатьРазвёрнутым>
                <Подсказка></Подсказка>
            </Свойство>
        </СвойстваЭлементов>
        <Группы>
        </Группы>
    </Классификатор>
    <Каталог>
        <Ид>clothes_news_s1</Ид>
        <ИдКлассификатора>clothes_news_s1</ИдКлассификатора>
        <Наименование>Новости</Наименование>
        <БитриксКод>news</БитриксКод>
        <БитриксСортировка>500</БитриксСортировка>
        <БитриксURLСписок>#SITE_DIR#/news/</БитриксURLСписок>
        <БитриксURLДеталь>#SITE_DIR#/news/#ELEMENT_CODE#/</БитриксURLДеталь>
        <БитриксURLРаздел></БитриксURLРаздел>
        <БитриксURLКанонический></БитриксURLКанонический>
        <БитриксКартинка></БитриксКартинка>
        <БитриксИндексироватьЭлементы>true</БитриксИндексироватьЭлементы>
        <БитриксИндексироватьРазделы>false</БитриксИндексироватьРазделы>
        <БитриксДокументооборот>false</БитриксДокументооборот>
        <БитриксПодписи>
            <БитриксПодпись>
                <Ид>ELEMENT_NAME</Ид>
                <Значение>Новость</Значение>
            </БитриксПодпись>
            <БитриксПодпись>
                <Ид>ELEMENTS_NAME</Ид>
                <Значение>Новости</Значение>
            </БитриксПодпись>
            <БитриксПодпись>
                <Ид>ELEMENT_ADD</Ид>
                <Значение>Добавить новость</Значение>
            </БитриксПодпись>
            <БитриксПодпись>
                <Ид>ELEMENT_EDIT</Ид>
                <Значение>Изменить новость</Значение>
            </БитриксПодпись>
            <БитриксПодпись>
                <Ид>ELEMENT_DELETE</Ид>
                <Значение>Удалить новость</Значение>
            </БитриксПодпись>
            <БитриксПодпись>
                <Ид>SECTION_NAME</Ид>
                <Значение>Раздел</Значение>
            </БитриксПодпись>
            <БитриксПодпись>
                <Ид>SECTIONS_NAME</Ид>
                <Значение>Разделы</Значение>
            </БитриксПодпись>
            <БитриксПодпись>
                <Ид>SECTION_ADD</Ид>
                <Значение>Добавить раздел</Значение>
            </БитриксПодпись>
            <БитриксПодпись>
                <Ид>SECTION_EDIT</Ид>
                <Значение>Изменить раздел</Значение>
            </БитриксПодпись>
            <БитриксПодпись>
                <Ид>SECTION_DELETE</Ид>
                <Значение>Удалить раздел</Значение>
            </БитриксПодпись>
        </БитриксПодписи>
        <Товары>
            <Товар>
                <Ид>1</Ид>
                <Наименование>Форум производителей одежды в России</Наименование>
                <БитриксТеги></БитриксТеги>
                <Группы>
                </Группы>
                <Картинка>news_files/iblock/2f3/2f3e6f7f62c65af3cb2e311311892a93.jpg</Картинка>
                <ЗначенияСвойств>
                    <ЗначенияСвойства>
                        <Ид>CML2_ACTIVE</Ид>
                        <Значение>true</Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_CODE</Ид>
                        <Значение>forum_of_producers_of_clothes_in_russia</Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_SORT</Ид>
                        <Значение>500</Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_ACTIVE_FROM</Ид>
                        <Значение></Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_ACTIVE_TO</Ид>
                        <Значение></Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_PREVIEW_TEXT</Ид>
                        <Значение>С 20 по 23 февраля состоится <strong>Форум производителей одежды в России</strong> &ndash; важнейшее мероприятии отрасли в этом году.</Значение>
                        <Тип>html</Тип>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_DETAIL_TEXT</Ид>
                        <Значение><p>С 20 по 23 февраля этого года состоится <strong>Форум производителей одежды в России</strong> &ndash; важнейшее мероприятии отрасли в текущем году. В экспозиции принимают участие свыше 160 компаний из <em>Беларуси, Австрии, Латвии, Литвы, России, Польши </em>и<em> Украины</em>. В составе форума состоится пять выставок:&quot;Московский Фэшн Салон&quot;, &quot;Технологии в Одежде&quot;, &quot;Офис Комфорт&quot;, &quot;Повседневная одежда&quot; и &quot;Детская одежда&quot;. Экспозиция будет строиться по принципу двух тематических секторов:<em> одежда</em> и <em>материалы для ее производства</em>.
                    <br />
                    </p>

                    <p>В секторе готовой одежды будут представлены:</p>

                    <ul>
                    <li>одежда для дома;</li>

                    <li>одежда для детей и молодежи;</li>

                    <li>аксессуары в одежде;</li>

                    <li>одежда для спорта и отдыха;</li>

                    <li>одежда для офиса.</li>
                    </ul>

                    <p>В секторе материалов для производства одежды будут демонстрироваться новинки рынка одежной фурнитуры, материалов, тканей, элементов и аксессуаров для производства одежды.
                    <br />
                    </p>

                    <p>Помимо расширенной экспозиции пяти тематических выставок &quot;Экспофорум&quot; подготовил разнообразную деловую программу форума производителей Одежды. В рамках выставки состоятся семинары и мастер-классы. И поистине масштабным в этом году обещает стать республиканский конкурс форума &quot;<strong>Народное признание</strong>&quot;. В этом году он выходит за рамки выставки и становится республиканским смотром образцов одежды.   </p>

                    <p><strong>Форум производителей Одежды</strong> предоставляет специалистам возможность познакомиться с тенденциями моды, провести переговоры, получить практические предложения рынка, увидеть перспективы развития и новые конкурентные преимущества. Впервые для участников конкурса будет подготовлен маркетинговый отчет по результатам опроса посетителей выставок <strong>Форума производителей Одежды</strong>.
                    <br />
                    </p>

                    <p><em>Прием заявок на участие в конкурсе осуществляется до 12 января этого года.</em></p>

                    <ul> </ul>
 </Значение>
                        <Тип>html</Тип>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_PREVIEW_PICTURE</Ид>
                        <Значение>news_files/iblock/9cb/9cb4477b7b086001cba0a24be9d1ad8a.jpg</Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>240</Ид>
                        <Значение></Значение>
                    </ЗначенияСвойства>
                </ЗначенияСвойств>
            </Товар>
            <Товар>
                <Ид>8</Ид>
                <Наименование>Международная выставка одежды Salon De Fashion</Наименование>
                <БитриксТеги></БитриксТеги>
                <Группы>
                </Группы>
                <Картинка></Картинка>
                <ЗначенияСвойств>
                    <ЗначенияСвойства>
                        <Ид>CML2_ACTIVE</Ид>
                        <Значение>true</Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_CODE</Ид>
                        <Значение>exhibition_salon_de_fashion</Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_SORT</Ид>
                        <Значение>500</Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_ACTIVE_FROM</Ид>
                        <Значение></Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_ACTIVE_TO</Ид>
                        <Значение></Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_PREVIEW_TEXT</Ид>
                        <Значение>В следующем году состоится выставка одежды - Salon De Fashion, которая обещает быть еще более расширенной и интересной.</Значение>
                        <Тип>html</Тип>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_DETAIL_TEXT</Ид>
                        <Значение>В следующем  году выставка Salon De Fashion обещает быть еще более расширенной и интересной. На выставке Salon De Fashion будут представлены все типы одежды для офиса и дома от платьев и шорт до VIP-аксессуаров, включая оборудование для производства и детской одежды.
                    <div>
                    <br />
                    </div>

                    <div>Заявки на участие подали более чем 1 500 компаний со всего мира. Предполагается, что за время проведения выставки ее посетят более 300 000 тысяч человек. Экспозиция выставки разместится на общей площади 149 871 кв.м. В следующем году эта поистине грандиозная выставка будет проводиться уже в 14-й раз.</div>
                </Значение>
                        <Тип>html</Тип>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_PREVIEW_PICTURE</Ид>
                        <Значение>news_files/iblock/093/093e2024f3fac9f2fd918d3a48eb7ee8.jpg</Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>240</Ид>
                        <Значение>news_files/iblock/724/724fe965bd20759d515fb9037b0f23bf.jpg</Значение>
                        <ЗначениеСвойства>
                            <Значение>news_files/iblock/724/724fe965bd20759d515fb9037b0f23bf.jpg</Значение>
                            <Описание></Описание>
                        </ЗначениеСвойства>
                        <Значение>news_files/iblock/e2f/e2fe8b9ff65f860c2c129a5be68f0707.jpg</Значение>
                        <ЗначениеСвойства>
                            <Значение>news_files/iblock/e2f/e2fe8b9ff65f860c2c129a5be68f0707.jpg</Значение>
                            <Описание></Описание>
                        </ЗначениеСвойства>
                        <Значение>news_files/iblock/20b/20b92dc30a248caa61f40f0eb4fc2eec.jpg</Значение>
                        <ЗначениеСвойства>
                            <Значение>news_files/iblock/20b/20b92dc30a248caa61f40f0eb4fc2eec.jpg</Значение>
                            <Описание></Описание>
                        </ЗначениеСвойства>
                    </ЗначенияСвойства>
                </ЗначенияСвойств>
            </Товар>
            <Товар>
                <Ид>9</Ид>
                <Наименование>Новое веяние в одежде - получено прочное водостойкое соединение</Наименование>
                <БитриксТеги></БитриксТеги>
                <Группы>
                </Группы>
                <Картинка>news_files/iblock/d2d/d2d919405b231070995cf88eb671ea68.jpg</Картинка>
                <ЗначенияСвойств>
                    <ЗначенияСвойства>
                        <Ид>CML2_ACTIVE</Ид>
                        <Значение>true</Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_CODE</Ид>
                        <Значение>waterproof_connection</Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_SORT</Ид>
                        <Значение>500</Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_ACTIVE_FROM</Ид>
                        <Значение></Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_ACTIVE_TO</Ид>
                        <Значение></Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_PREVIEW_TEXT</Ид>
                        <Значение>Получено новое прочное водостойкое клеевое соединение.Изобретение относится к области получения и применения клеящих составов, используемых в обработке тканей, кожи и других материалов. Данная клеевая композиция предназначена только для горячего прессования и имеет в своем составе многокомпонентный очень гибкий отвердитель. Который даст возможность делать новые виды аппликаций и соединения тканей и различных типов материалов.</Значение>
                        <Тип>html</Тип>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_DETAIL_TEXT</Ид>
                        <Значение><b>Авторы изобретения</b>: Разиньков Егор Михайлович и Зайцева Анна Анатольевна
                    <br />
                    Патент Российской Федерации RU2277566
                    <br />

                    <h3>Описание изобретения</h3>

                    <p>Изобретение относится к области получения и применения клеящих составов, используемых в производстве одежды и аксессуаров. Данная клеевая композиция предназначена только для горячего прессования и имеет в своем составе многокомпонентный гибкий отвердитель. Прототипом клеевой композиции является клей, состоящий из карбамидоформальдегидной смолы, сополимера акрилонитрила с N-винилкапролактамом и отвердитель. В качестве отвердителя применяют хлористый аммоний либо акриловую кислоту. </p>

                    <p>Изобретение решает задачу по получению прочного и водостойкого клеевого соединения. Это достигается тем, что клеевая композиция, включающая синтетическую смолу и отвердитель, согласно изобретению, дополнительно содержит модификатор, причем в качестве синтетической смолы клеевая композиция включает карбамидомеламиноформальдегидную смолу с отвердителем 2542, в качестве модификатора - карбамидоформальдегидную смолу, а в качестве отвердителя - 10%-ный раствор щавелевой кислоты при следующем соотношении компонентов, мас.ч.: </p>

                    <table cellspacing="0">
                    <tbody>
                    <tr> <td>Карбамидомеламиноформальдегидная смола</td><td>64,5-79,2</td> </tr>

                    <tr> <td>10%-ный Раствор щавелевой кислоты</td><td>4,4-20,5</td> </tr>

                    <tr> <td> Отвердитель для карбамидомеламиноформальдегидной </td><td>0,6-2,0</td> </tr>

                    <tr> <td> смолы 2542</td><td>13,0-15,8</td> </tr>
                    </tbody>
                    </table>
</Значение>
                        <Тип>html</Тип>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>CML2_PREVIEW_PICTURE</Ид>
                        <Значение>news_files/iblock/bc8/bc8a6974a75616f2f085cc5b913e0650.jpg</Значение>
                    </ЗначенияСвойства>
                    <ЗначенияСвойства>
                        <Ид>240</Ид>
                        <Значение></Значение>
                    </ЗначенияСвойства>
                </ЗначенияСвойств>
            </Товар>
        </Товары>
    </Каталог>
</КоммерческаяИнформация>

Кто может выполнять экспорт?

С версии 15.0.6 модуля Информационные блоки выгружать данные могут те пользователи, которым разрешена операция Экспорт инфоблока . По умолчанию такая операция входит только в уровень доступа Полный доступ.

Создавайте собственные уровни доступа, чтобы пользователи не имели полного доступа, но могли экспортировать инфоблок.

Примечание: для создания уровней доступа необходимо обладать правами администратора. Если такой возможности нет, то обратитесь за помощью к администратору сайта.

Заключение

Итак, вы познакомились, как выгрузить данные из инфоблока в XML-файл, а также узнали, кто может это делать. Почитайте следующий урок и узнайте, как загружать в инфоблок данные в XML формате.

Документация по теме:

  • Экспорт в формате XML
  • Описание структуры файлов XML


Импорт данных
111 / 694

Импорт данных

Представьте, что у вас есть XML-файл, данные из которого следует занести в инфоблок. Экономьте время с инструментом импорта и загружайте данные за 3 простых шага.

Шаг 1. Откройте страницу Импорт XML (Контент > Инфоблоки > Импорт > XML):

Нажмите на рисунок, чтобы увеличить

Шаг 2. Задайте параметры импорта:

  • Файл для загрузки – с помощью кнопки Открыть... выберите файл в формате XML с сервера или загрузите с локального компьютера.

    • Важно! Чтобы в загруженном инфоблоке корректно отображались изображения, необходимо загружать файл xml в ту же папку, в которую загружена папка с картинками инфоблока. Это связано с тем, что в файле xml путь до картинок прописывается не от корня сайта, а от импортируемой папки с изображениями, т.е. папка и файл xml должны быть на одном уровне.

  • Тип информационного блока – выберите тип, к которому должен относиться загружаемый инфоблок.
  • Сайты, к которым будет привязан информационный блок (если будет создаваться новый) – отметьте сайт, к которому привязан инфоблок.

    Примечание: если загружаемый инфоблок уже существует в системе, то независимо от выбранного типа инфоблока и сайтов, он заново загружен не будет. Имеющиеся элементы будут обновлены, новые - добавлены, а над теми элементами, которые отсутствуют в файле, будет выполнено заданное действие в параметре Действия над элементами, которых нет в файле. Пользователь, запустивший импорт, будет отмечен как изменивший обновленный элемент.

    Если же такого инфоблока в системе нет, то он будет создан в указанном типе, привязан к выбранным сайтам и его содержимое будет загружено.

    При импорте больших объемов данных рекомендуется отключить индексацию созданных элементов модулем Поиск. Это существенно увеличит скорость создания элементов.
  • Действия над элементами, которых нет в файле – выберите действие над элементами инфоблока. Оно будет выполняться над имеющимися элементами в инфоблоке, но при этом отсутствующими в файле загрузки.
  • Длительность шага в секундах – укажите количество секунд выполнения шага импорта. Если указано 0, то импорт инфоблока будет осуществлен за один шаг.
  • Использовать настройки инфоблока для обработки изображений – отметьте опцию, чтобы добавленные изображения преобразовывались согласно настройкам инфоблока.

Шаг 3. Нажмите кнопку Импортировать. Начинается импорт инфоблока, над формой отображается ход процесса выгрузки. По окончании выводится соответствующее сообщение .

Перейдите к списку элементов инфоблока и проверьте результат загрузки данных.

Примечание: если при импорте списочных свойств значения отсутствуют в метаданных, но есть у элементов, то они не удаляются. Если свойство Символьный код в исходном файле пустое, то система заполняет его транслитом из названия (если в закладке Поля формы настройки инфоблока для поля Символьный код было указано Транслитерировать из названия при добавлении элемента).

Заключение

Итак, вы узнали, как загружать данные в инфоблока из XML-файла. Почитайте материалы следующей главы и ознакомьтесь с обменом данными в формате RSS.

Документация по теме:

  • Импорт в формате XML
  • Описание структуры файлов XML


Формат RSS
112 / 694
RSS-формат является устаревшим на данный момент и редко используемым. Однако, в случае необходимости, вы можете им пользоваться. Материалы главы помогут вам с настройками.


Экспорт в RSS
113 / 694

Экспорт в RSS

Новости, товары и т.д. вы можете экспортировать в другие системы. Выполните несколько простых действий:

  1. В настройках типа инфоблоков отметьте опцию Использовать экспорт в RSS .
  2. В настройках модуля Информационные блоки (Настройки > Настройки продукта > Настройки модулей > Информационные блоки) укажите путь к директории , в которую выполняется экспорт данных.
  3. Настройте компонент на экспорт данных.

    Можно использовать простой компонент RSS новости (экспорт). В его настройках укажите информационный блок, количество дней для экспорта и другие параметры. Результат экспорта будет аналогичен приведенному ниже примеру.

Пример настройки компонента для RSS-экспорта

Рассмотрим экспорт данных в формате RSS из информационного блока (например, новости), используя настройки комплексного компонента Новости :

  1. Создайте страницу и разместите на ней комплексный компонент Новости.
  2. Настройте все необходимые параметры: источник данных, настройки RSS и другие:

    Примечание: предварительно убедитесь, что в настройках типа инфоблоков разрешен экспорт данных в формате RSS.

В результате созданная страница имеет вид:

Переход по ссылке rss открывает страницу со списком элементов в формате RSS.

Заключение

Вы познакомились с настройкой экспорта данных со своего сайта в формате RSS. Почитайте следующий урок и вы узнаете, как на своем сайте показать принятые в формате RSS данные.


Отображение данных из RSS
114 / 694

Отображение данных из RSS

Нужно опубликовать на сайте данные, полученные в формате RSS? Используйте компонент RSS новости (импорт) :

  1. Разместите компонент RSS новости (импорт) на странице.
  2. Настройте его параметры . Обязательно укажите Адрес ленты rss сайта, с которого производится импорт.

В итоге страница имеет следующий вид:

Заключение

Для публикации полученной в формате RSS информации разместите и настройте компонент RSS новости (импорт).


Визуальный редактор
115 / 694

В этой главе Вы ознакомитесь с правилами и возможностями работы в визуальном HTML-редакторе, который позволяет управлять информационным содержанием страницы и редактировать его в режиме реального времени.


Подключение редактора
116 / 694

Где будет доступен редактор

Большим преимуществом редактора является возможность работать с визуальными компонентами: размещать их на странице и настраивать их параметры, определяющие внешний вид динамически меняющейся информации.

Визуальный редактор является штатным функционалом и не требует дополнительной установки.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Подключение редактора

Чтобы редактором страниц по умолчанию был визуальный HTML-редактор, необходимо его выбрать в настройках модуля Управление структурой.

Внимание! Все пользователи, которым необходимо вносить хоть какие-нибудь изменения в Публичной части сайта должны иметь доступ на чтение к папке /bitrix/admin. Это папка, в которой расположен визуальный HTML-редактор. Без этого редактирование будет возможно только в текстовом режиме.

Визуальный редактор в модулях системы

Подключение визуального редактора в модуле Управление структурой дает общее разрешение на его использование. Но для разных модулей использование визуального редактора можно настроить по отдельности в настройках модулей . Это можно сделать у большинства модулей, например:

  • Информационные блоки;
  • Веб-формы;
  • Обучение;
  • Опросы, голосования;
  • Подписка, рассылки
  • и другие.


Настройка визуального редактора
117 / 694

Настройка визуального редактора

Системные настройки визуального редактора производятся в настройках модуля Управление структурой (Настройки > Настройки продукта > Настройки модулей > Управление структурой) на закладке Визуальный редактор.

Нажмите на рисунок, чтобы увеличить

Первой опцией в настройках визуального редактора является выбор самого редактора. Вы можете пользоваться новой версией редактора, либо вернуться к старой (до версии 9.5) . Здесь и далее мы будем иметь в виду и описывать новую версию. С работой в старой версии Вы можете ознакомиться в курсе Интерфейс до версии 9.5.

Визуальный редактор предоставляет возможность проверки орфографии введенного текста только с помощью pSpell (проверка производится в браузере, при условии если pSpell установлен на сервере).

Для того, чтобы визуальный редактор мог использовать это расширение, его надо подключить. Для этого нужно зайти в Настройки > Настройки модулей > Управление структурой > Визуальный редактор.

Документация по теме:

  • Настройки визуального редактора


Настройки отображения компонентов
118 / 694

Определяем компоненты с которыми можно работать

По умолчанию пользователю предоставляется полный список компонентов , которые он может размещать на редактируемой странице. Эту возможность администратор сайта может ограничить. Для этого:

  • Перейдите на страницу настроек модуля Управление структурой (Настройки > Настройки продукта > Настройки модулей > Управление структурой).
  • Заполните поле Разрешенные компоненты.

Ограничение работает так: если в поле нет ни одного компонента, то разрешены все. Если в поле добавлен хотя бы один компонент, то будет разрешен только он (все остальные запрещены). Иными словами, для запрета доступа к единственному компоненту в это поле нужно внести все компоненты, которые разрешены. При добавлении компонентов можно использовать маски вида: news.*. Все компоненты, попадающие под эту маску, будут разрешены к использованию. Каждое название компонента или регулярное выражение вводится с новой строки.

Для пользователей этот запрет внешне будет проявляться в том, что в визуальном редакторе при вызове панели Компоненты будут видны только разрешенные компоненты.

Поле работает только с системными компонентами, то есть компонентами из пространства имен bitrix. Если Ваш компонент размещен не в папке www\bitrix\components\... (в структуре папок на веб-сервере), то он будет проигнорирован.

После ввода разрешенных компонентов для всех пользователей (в том числе и для администратора сайта) при редактировании страниц и сохранении изменений все неразрешенные компоненты будут удалены со страницы.

В самом же визуальном редакторе в списке компонентов будут присутствовать только лишь разрешенные компоненты.


Сниппеты в визуальном редакторе
119 / 694

Где лежат сниппеты

Работа со сниппетами подробно рассмотрена в уроке Внешний вид редактора курса Контент-менеджер. Физически сниппеты хранятся в папке /snippets/ соответствующего шаблона либо в шаблоне по умолчанию (.default). Так как сниппеты - это фрагменты HTML-кода, то они используют стили CSS того шаблона, для которого они созданы. Папка шаблона обычно содержит:

  • Файл .content.php - перечисление всех созданных сниппетов в данном шаблоне. И для каждого из сниппетов хранится заголовок (title) и описание (description).
    <?if(!defined("B_PROLOG_INCLUDED") || B_PROLOG_INCLUDED!==true)die();?>
    <?
    $SNIPPETS = Array();
    $SNIPPETS["snippet0001.snp"] = Array("title"=>"Таблица", "description"=>"");
    ?>
  • Файл .htaccess - настройки прав доступа к сниппетам;
  • Коды самих сниппетов (файлы *.snp). Они могут храниться в подгруппах.
  • Изображение для сниппета, хранится в подкаталоге /snippets/images/ и далее директория, дублирующая расположение самого сниппета. Имя изображения совпадает с именем сниппета. Например, сниппет расположен в папке /test1/table.snp. Тогда изображение к нему будет располагаться в папке /images/test1/table.png (или другое расширение изображения).

Видеопример использования сниппетов

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Пример использования сниппетов: создание спойлера

Довольно часто на сайтах используют спойлеры. Спойлер несложно создать с помощью стандартного инструмента html – тега <details>.

Но текстовым наполнением сайта обычно занимается контент-менеджер, которому нужна кнопка для быстрого добавления таких спойлеров. Выход прост – создайте сниппет!

Пример html-кода вставки спойлера

<table>
  <tr><td><details>
  <summary>Подробнее</summary>
  Скрытый текст
  </details></td></tr>
</table>

Теперь контент-менеджер сможет легко добавлять спойлеры в визуальном редакторе.


Работа с визуальным редактором
120 / 694

Работа с визуальным редактором

Работать с визуальным редактором можно и в публичном разделе , и в административном.

Для того, чтобы перейти к редактированию страницы в Административном разделе, нужно выбрать соответствующую команду в Публичном разделе или в Административном разделе.

При редактировании страницы в Административном разделе появится специальное меню для работы с существующей страницей, а также сам визуальный редактор :

Нажмите на рисунок, чтобы увеличить


Работа с php-скриптом
121 / 694

Работа с php-скриптом

Примечание: Правом на работу с произвольным php-скриптом обладает только пользователь с правами администратора сайта.

В HTML-редакторе можно разместить произвольный php-скрипт следующим способом: перейдя в режим редактирования исходного кода (или смешанный режим) и написав требуемый код. Тогда в режиме визуального редактирования (или в соответствующем поле смешанного режима ) появится тот же ярлык [image], содержание php-кода которого можно будет редактировать в режиме работы с исходным кодом и в области Свойства:

Внимание! Есть некоторые тонкости при прерывании html-кода php-скриптом.

Например, можно писать так:
 <a href="<? echo 'www.oursite.ru';?>" title="Посетите сайт">OurSite</a>
Аналогично, и с рисунками (тег img).

Перечислим атрибуты, которые обрабатываются для ссылок, рисунков и аудио:
для тега <a> атрибуты: href, title, class, style
для тега <img> атрибуты: src, alt, class, style
для тега <audio> атрибуты: src, autoplay, control, loop, preload
Т.е. вместо этих атрибутов можно вставлять <? ...... ?>

Код таблицы тоже можно прерывать php-скриптом:
 <table >
  <? ........ ?>
  <tr>
  <? ........ ?>
  <td>
  </td>
  <? ........ ?>
  </tr>
  <? ........ ?>
 </table>

Важно то, что визуальный редактор не показывает php-код в начале и в конце страницы. Например, строки в начале кода главной страницы не будут показаны при редактировании этой страницы с помощью визуального редактора:

<?
require($_SERVER["DOCUMENT_ROOT"]."/bitrix/header.php");
$APPLICATION->SetPageProperty("title", "Демонстрационная версия продукта «1С-Битрикс: Управление сайтом 6.0»");
$APPLICATION->SetPageProperty("NOT_SHOW_NAV_CHAIN", "Y");
$APPLICATION->SetTitle("Новости интернет-магазина");
?>

Код, вызывающий файл footer.php, тоже не будет показан в HTML-редакторе:

<?require($_SERVER["DOCUMENT_ROOT"]."/bitrix/footer.php");?>


Работа с Инструментами
122 / 694

Чтобы вы могли проверить ваш сайт на соответствие техническим требованиям «1С-Битрикс: Управление сайтом» в административном меню имеется набор специальных инструментов. Они служат для обнаружения проблем в работе сайта и помогают избежать появления ошибок в дальнейшем.


Раздел Инструменты
123 / 694

Чтобы вы могли проверить ваш сайт на соответствие техническим требованиям «1С-Битрикс: Управление сайтом» в административном меню имеется набор специальных инструментов. Они служат для обнаружения проблем в работе сайта и помогают избежать появления ошибок в дальнейшем.

Средства для выполнения PHP-кода, SQL запросов к базе данных, оптимизации БД и т.п. также расположены в разделе Настройки > Инструменты.

В этой главе содержится описание возможностей данных инструментов и способов их использования.

Документация по теме:

  • Инструменты (документация)


Проверка системы
124 / 694

Форма Проверка системы (Настройки > Инструменты > Проверка системы) предназначена для всесторонней проверки соответствия параметров системы, на которой осуществляется функционирование проекта, минимальным и рекомендуемым техническим требованиям продукта.

Примечание:
  1. Не осуществляется проверка структуры базы для Oracle и MS SQL.
  2. Проверка не осуществляется в модулях, в которых присутствует точка в имени: в модулях Marketplace.
  3. Тест ничего не знает об архитектуре сети и он пытается протестировать систему на основе той информации, что есть. Соответственно, при проверке на локальной установке могут возникать ошибки, связанные с необходимостью внешнего сканирования, например, ошибка сокетов.

Закладка Тестирование конфигурации

Здесь проводится комплексное тестирование конфигурации сервера. В том числе проверяются параметры, некритичные для нормального функционирования, но которые желательно установить в рекомендуемые значения.

Каждый тест сопровождается подробной информацией, которую можно прочитать по кнопке [image] в строке теста. Откроется окно с подробными комментариями .

Закладка Проверка доступа

Здесь выполняется проверка доступности дисков физической системы не только на чтение, но и на запись. Это необходимо для управления структурой сайта, загрузки файлов, а также для работы системы обновлений, которая обновляет ядро сайта до последней версии. Проверку можно осуществлять по трем критериям:

  • Полная проверка – анализируются на доступ все файлы системы.
  • Проверка папки для загрузки файлов – проверяется доступность на чтение и на запись папки для загрузки файлов.
  • Проверка ядра – анализу на доступ подвергаются системные файлы.

Результатом проверки может быть либо системное сообщение об успешном окончании, либо отображение файлов, недоступных на чтение или на запись.

Закладка Техподдержка

С помощью этой мини-формы можно быстро и оперативно связаться со службой технической поддержки компании "1С-Битрикс". Для этого нужно заполнить требуемые поля формы , подробно описав суть проблемы.

Многие проблемы можно решить быстрее, если к письму будет присоединена информация о системе, поэтому настоятельно рекомендуется провести тесты на закладке Тестирование конфигурации и оставлять опцию Отправить журнал тестирования конфигурации включенной.

Другие возможности проверки системы

  • Проверка сайта без авторизации

    • Инструмент представляет возможность протестировать конфигурацию, даже если не работает авторизация или сайт не открывается из за нарушения сжатия (на экране отображаются крякозябры). Для этого достаточно создать пустой файл site_checker_debug в папке /bitrix. После этого откройте страницу http://you_site.ru/bitrix/admin/site_checker.php

    Внимание! После решения проблемы обязательно удалите файл site_checker_debug и убедитесь, что проверка сайта без авторизации недоступна. Если открыть проверку сайта с авторизацией - файл site_checker_debug удаляется автоматически.
  • Исправление ошибок базы данных

    • Выполняется, если при тестировании конфигурации в структуре базы данных будут найдены ошибки:

    За первоисточник берётся кодировка соединения с базой. В большинстве случаев она правильная, т.к. иначе вся информация на сайте просто будет нечитаема.

    Кодировка базы - это важный параметр, но не влияющий непосредственно на отображение данных. Новые таблицы (после обновления или переустановки модулей) будут создаваться в этой кодировке. Т.е. проблемы появляются в будущем.

    Система позволяет автоматически исправить неправильные сравнения базы данных, таблиц и полей. Смена кодировки не производится, так как это меняет сами данные и в случае сбоя может привести к их потере. Несмотря на это, перед началом исправления настоятельно рекомендуется сделать полную резервную копию базы данных.


Проверка КП
125 / 694

В рамках страницы Проверка системы для Корпоративного портала есть отдельный инструмент: Работа портала. Страница предназначена не столько для админов, сколько для руководителей организаций, которые в любой момент могут проверить как работает корпоративный портал и принять административные меры для исправления ошибок.

Этот инструмент проверяет работу модулей, ответственных за бизнес-функции корпоративного портала. В системе реализована ежесуточная проверка работы этих модулей. Если такая проверка выявила какие-то проблемы, то для сотрудников имеющих администраторский доступ будет появляться такое уведомление:

При нажатии на Проверить и исправить пользователь перейдёт на страницу Проверка системы и автоматически запуститься тест проверки. По результатам проверки будет выведен реестр результатов:

При клике указателем мыши на знак вопроса в строке ошибки выводится подробное описание ошибки:

Информация выводится в терминах, достаточных для понимания руководителю без технического образования.


Монитор качества
126 / 694

Проверка сайта перед сдачей

Страница Монитор качества предназначена для проверки качества выполненного проекта перед сдачей его заказчику.На ней содержится встроенный набор автоматизированных и ручных тестов для проверки качества интеграции дизайна и разработки, внешнего программного окружения, безопасности, производительности, настроек хостинга, целостности ядра системы и другие.Благодаря контролю качества проекта веб-разработчик получает возможность провести доскональную проверку сайта перед сдачей, а клиент – уверенность в качестве сборки проекта.

Нажмите на рисунок, чтобы увеличить

Контроль качества проводится перед запуском сайта и выполняется разработчиком. Поэтому эта процедура подробно описана в курсе "Разработчик Bitrix Framework" в главе Монитор качества .

Документация по теме:

  • Контроль качества внедрений
  • Монитор качества


SQL запрос и Командная PHP строка
127 / 694

SQL запрос

Форма SQL запрос (Настройки > Инструменты > SQL запрос) предназначена для выполнения SQL запросов к базе данных. Возможно выполнение любых запросов на языке SQL.

Важно! Система не устанавливает никаких ограничений на SQL запросы, поэтому будьте крайне внимательны при выполнении запросов типа UPDATE, DELETE, DROP и т.п.

Командная PHP-строка

Форма Командная PHP-строка (Настройки > Инструменты > Командная PHP-строка) предназначена для исполнения некоторого кода, вызывающего функции API Битрикса без создания новых страниц на сайте. Доступно несколько закладок для выполнения разного кода одновременно.


Настройки PHP
128 / 694

Проверяем настройки PHP

Страница Настройки PHP (Настройки > Инструменты > Диагностика > Настройки PHP) служит для отображения информации о текущих настройках PHP. Для получения информации используется функция phpinfo().


Проверка и оптимизация БД
129 / 694

Проверка БД

На странице Проверка / восстановление таблиц (Настройки > Инструменты > Диагностика > Проверка БД) вы можете проверить и восстановить таблицы базы данных. Использование скрипта проверки и восстановления позволит оперативно восстановить работу сайта.

Внимание! Восстановление таблиц работает только для базы данных MySQL и таблиц типа MyISAM.

Внимание! Не открывайте эту страницу одновременно в нескольких копиях - это может повредить вашу базу данных. Операция может занять длительное время, если размер базы данных велик!

Отчет о проверке базы данных

Примечание: Если повреждены таблицы статистики и нет возможности перейти в административный раздел, то сбор статистики может быть временно отключен с помощью параметра ?no_keep_statistic_LICENSE-KEY=Y. В параметре указывается лицензионный ключ сайта.

Существует возможность использования скрипта проверки и восстановления базы данных без перехода в административный раздел.

Для этого при обращении к странице восстановления необходимо указать два параметра: имя (login) и пароль (password) на доступ к базе данных. Например: http://www.mysite.ru/bitrix/admin/repair_db.php?login=DB_Login&amp; password=DB_Password.

По умолчанию значения данных параметров хранятся в файле /bitrix/php_interface/dbconn.php.

Иногда возникает ситуация, когда сайт перестает отвечать и посетителям отображается пустая страница. В этом случае откройте файл /bitrix/php_interface/dbconn.php, который содержит параметры соединения с базой данных, и установите значение параметра $DBDebug = true;

В результате будет получен код ошибки, содержащий, как правило, названия поврежденных таблиц базы данных. Если целостность таблиц действительно нарушена, воспользуйтесь скриптом восстановления.

Оптимизация

На странице Оптимизация БД (Настройки > Инструменты > Диагностика > Оптимизация БД) вы можете оптимизировать и проанализировать таблицы базы данных. Это повысит эффективность обработки запросов сервером базы данных.

Внимание! Не открывайте эту страницу одновременно в нескольких копиях - это может повредить вашу базу данных. Операция может занять длительное время. Желательно выполнять ее при наименьшей нагрузке на сайт.

После нажатия кнопки Оптимизировать процесс запустится, за его ходом можно будет наблюдать по индикатору:

По завершении оптимизации на странице появится сообщение об этом .


Журнал событий
130 / 694
Просматривайте события на сайте и настраивайте оповещения о событиях с помощью инструмента Журнал событий.


Журнал событий
131 / 694

Отслеживаем что происходит на сайте

На странице Журнал событий (Настройки > Инструменты > Журнал событий) вы можете просмотреть события сайта.

Нажмите на рисунок, чтобы увеличить

Примечание: Детальное описание значений полей журнала событий смотрите на странице пользовательской документации.

Вы можете самостоятельно определить события, которые нужно записывать в журнал. Это можно сделать:

  • в настройках главного модуля на закладке Журнал событий (Настройки > Настройки продукта > Настройки модулей > Главный модуль),

    Примечание: Обратите внимание на поле Сколько дней хранить события . По умолчанию установлен срок хранения 7 дней. По истечении этого срока события из журнала будут удалены.

  • в настройках модуля Инфоблоки (Настройки > Настройки продукта > Настройки модулей > Информационные блоки),
  • в настройках модуля Форум (Настройки > Настройки продукта > Настройки модулей > Форум),
  • в настройках модуля Облачные хранилища (Настройки > Настройки продукта > Настройки модулей > Облачные хранилища),
  • в настройках модуля Управление структурой (Настройки > Настройки продукта > Настройки модулей > Управление структурой),
  • в настройках Информационного блока (Контент > Инфоблоки > Типы инфоблоков > конкретный инфоблок),

Примечание: Ряд модулей, например Контроллер, Проактивная защита, Техподдержка и другие ведут собственные журналы.

Ссылка [стоп-лист] в таблице Журнала событий ведет на страницу Аналитика > Посетители > Стоп-лист . Там вы сможете добавить в список тех пользователей, которым запрещено выполнять те или иные действия на сайте. Например, создавать или изменять страницы сайта или выполнять SQL-запросы.

Также доступна возможность настройки оповещений о наступлении событий на сайте. О работе с оповещениями описано в следующем уроке.

Документация по теме:

  • Как добавить свой элемент в журнал событий (блог)


Оповещения журнала событий
132 / 694

Оперативно следим за событиями на сайте

Не упустите важные события на Вашем сайте. Получайте сообщения на email или мобильный телефон, настроив оповещения журнала событий.

Примечание: Функционал оповещений журнала событий доступен с версии 20.0.600 Главного модуля (main).

Настройки оповещений

Для открытия списка оповещений перейдите на страницу Журнал событий (Настройки > Инструменты > Журнал событий) и нажмите на кнопку Оповещения журнала событий .

Нажмите на рисунок, чтобы увеличить

Откроется список созданных оповещений. Для создания оповещения воспользуйтесь кнопкой Добавить оповещение.

В открывшейся форме имеются две вкладки:

  1. Условия, при которых отправлять оповещения :
    • Укажите название оповещения и выберите активность;
    • В разделе На что реагировать обязательно выберите из выпадающего списка тип события.
      При необходимости укажите более узкие условия срабатывания оповещения (объект, пользователь, IP-адрес, браузер, страница).
    • В разделе Условия установите интервал проверки наличия событий в минутах и количество записей в журнале событий для срабатывания оповещения.
  2. Действия для оповещения : укажите каким способом и куда отправлять оповещения.

Примечание: Детальное описание значений полей смотрите в пользовательской документации:
  • Оповещения журнала событий;
  • Форма создания и редактирования оповещения.

Примечание: Для отправки оповещений по СМС настройте службы отправки СМС .

Шаблоны оповещений

Для каждого способа отправки оповещения есть свой предустановленный шаблон:

  • Почтовый шаблон (Настройки > Настройки продукта > Почтовые и СМС события > Почтовые шаблоны): [EVENT_LOG_NOTIFICATION] Оповещение журнала событий;
  • Шаблон СМС-сообщений (Настройки > Настройки продукта > Почтовые и СМС события > Шаблоны СМС): Оповещение журнала событий [SMS_EVENT_LOG_NOTIFICATION].

При необходимости внесите свои изменения в шаблоны.

Дополнительно

  • Журнал событий;
  • Служба сообщений (курс Администратор. Модули);
  • Работа с почтовыми шаблонами (курс Администратор. Модули).


Безопасность сайта
133 / 694
В обязанности администратора напрямую входит решение проблем, связанных с безопасной эксплуатацией сайтов. В этой главе мы расскажем, как обеспечить и контролировать безопасный доступ пользователей к сайту.


Обеспечение безопасности
134 / 694

Безопасность сайта - ваша забота, а мы поможем

В значительной мере безопасность проекта закладывается при его создании . Тем не менее от администратора зависит:

  • Использование надежных паролей для пользователей, имеющих доступ в административную часть.
  • Обеспечение надежного хранения админских паролей, паролей доступа по FTP. (Предпочтительно использование SFTP/SCP)
  • Обеспечение доступа на сайт по SSL.
  • Грамотная работа с модулем Проактивная защита .
  • Грамотное использование штатных систем безопасности Bitrix Framework.
  • Грамотное использование разделения прав доступа пользователей .
Внимание! Статистика Техподдержки Bitrix Framework показывает что основная проблема со взломами сайтов - это вирусы на административных компьютерах. Можно порекомендовать использовать регулярно обновляемые антивирусы, регулярно обновлять компоненты системы (браузер, флеш, Java, саму систему и прочее).

Дополнительно

  • Безопасная авторизация
  • Как восстановить пароль администратора
  • Организация разделения прав доступа между контент-менеджерами

Документация по теме:

  • Проактивная защита
  • Эксплуатация уязвимостей (блог)
  • Эксплуатация уязвимости – противостоим модулем «Проактивная Защита» 1С-Битрикс (блог)
  • Безопасность сайта: поиск троянов (блог)


Настройка HTTPS-соединения
135 / 694

Как перевести сайт на протокол HTTPS

Перевод сайта на работу по протоколу https обеспечивает защиту от атак, основанных на прослушивании сетевого соединения. Действия по такому переводу не сложны, но требуют определённых знаний. В административном разделе "1С-Битрикс: Управление сайтом" создана специальная страница с указанием последовательности работ по настройке HTTPS соединения. Поясним каждый из пунктов этого списка.

Нажмите на рисунок, чтобы увеличить

Внимание! Для выполнения работ администратор должен иметь полный доступ к проекту.

Подготовить сайт к переходу на HTTPS

  • Изменить ссылки, используемые в проекте, с абсолютных на относительные: в каждом файле проекта поменять ссылки вида http://_ваш_сайт/bitrix/admin/*** на /bitrix/admin/*** (убрать указание на протокол и домен).
  • Проверить и изменить ссылки для контента (видео, картинки), загружаемого со сторонних ресурсов, протокол, по которому проект запрашивает контент.

    Пункт лёгкий для исполнения, если используются стандартные компоненты "1С-Битрикс: Управление сайтом": штатные компоненты работают по умолчанию "как надо". Если используются кастомизированные компоненты, то проверьте , что этот пункт в них выполняется.

    Сложнее ситуация, если используется решение от партнёров "1С-Битрикс". В этом случае нужно либо обратиться к разработчику решения для внесения таких правок, либо произвести эти правки самостоятельно.

    Определить наличие неверных указаний протокола можно с помощью консоли. При открытии страниц сайта будут отображены неверные ссылки:

  • Изменить подключение внешних скриптов с абсолютных на относительные. Внешние скрипты: различные счётчики, виджеты "Обратный звонок" и подобные, обращение к сторонним библиотекам, шрифтам и так далее.

    Если используются внешние скрипты, то нужна уверенность, что они работают корректно. Если это счётчики Google или Yandex или скрипты иного "серьёзного" проекта, то тут, как правило, всё работает правильно. Если разработчик стороннего скрипта недостаточно профессионален, то такие ошибки так же отслеживаются в консоли. Самостоятельное исправление невозможно, нужно либо обратиться к разработчику внешнего скрипта с просьбой исправить его работу, либо поискать другой внешний скрипт, решающий ваши задачи и работающий корректно по протоколу HTTPS.

Установить SSL-сертификат

  • Выбрать и получить сертификат. Простая процедура, просто выберите поставщика, оплатите и получите.
  • Установить полученный сертификат на хостинг.

    Операция требует определённой квалификации. Если она у вас есть - то пояснять вам нечего и незачем вам читать эту страницу. Если квалификации нет, то обратитесь к хостеру: его администраторы установят сертификат.

    Если используется BitrixVM, то как установить сертификат описано в уроке Добавление ssl-сертификатов в BitrixVM .

    Если сертификат из нескольких файлов
    Некоторые поставщики сертификатов выдают три файла и несколько промежуточных сертификатов. В этом случае сделайте следующее (на примере поставщика Comodo):

    Все полученные файлы (private.key, vash_domen.crt и промежуточный сертификаты) скопируйте под правами root по ssh на вашу BitrixVM в папку /etc/nginx/ssl/1. (Папку надо предварительно создать.)

    Объедините ваш сертификат домена и промежуточный сертификат в один файл формата pem. Важно соблюсти обратную последовательность: сначала должен быть сертификат для домена, затем промежуточные сертификаты №2, №1 и корневой сертификат. Сделайте это через любой текстовый редактор или через командную строку сервера.

    cd /etc/nginx/ssl/1/
cat vash_domen.crt COMODORSADomainValidationSecureServerCA.crt COMODORSAAddTrustCA.crt AddTrustExternalCARoot.crt > cert.pem

    Полученный файл cert.pem скопируйте в папку /nginx/ssl/, заменив старый файл. Пропишите в конфигурационном файле NGINX путь к публичному ключу - /etc/nginx/bx/conf/ssl.conf:

    ssl_certificate /etc/nginx/ssl/cert.pem;
ssl_certificate_key /etc/nginx/ssl/private.key;

    Перезагрузите NGINX:

    [root@1 conf]# service nginx restart
Stopping nginx:                                            [  OK  ]
Starting nginx:                                            [  OK  ]

  • Проверить доступность сайта через HTTPS-протокол. В консоли не должно быть красных строк.

Выполнить важные изменения на сайте

  • В файле robots.txt в директиве Host исправить протокол с http на https.
  • Установить 301 редирект с HTTP на HTTPS.

    301 редирект на HTTPS задаётся в файле .htaccess. Это файл занимает много места в памяти, поэтому через год редиректы рекомендуется удалить. За этот год произойдёт полная переиндексация сайта в поисковых системах.

    Примеры установки редиректа:

    RewriteEngine on
RewriteCond %{HTTPS} !=on
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
    RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
    RewriteEngine On
RewriteCond %{HTTPS} off
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    RewriteCond %{ENV:HTTPS} !on
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    RewriteCond %{HTTP:X-HTTPS} !1
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
    RewriteEngine On
RewriteCond %{HTTP:SSL} !1
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [QSA,L,R=301]

    Если предложенные варианты не работают, то обратитесь к хостеру. Нужно понять как на хостинге различается https/http трафик. В некоторых реализациях тип протокола определяется только по какому-то дополнительному элементу, например, в NGINX добавляется специальный заголовок.

    Если используется BitrixVM, то достаточно отключить http в меню виртуальной машины. (Выполняется после подключения ssl-сертификатов в BitrixVM.)

    Внимание! Отключение протокола HTTP - обязательная опция, оставлять его нельзя.

  • Изменить ссылки в файле sitemap.xml. Аналогично с файлами проекта изменяются ссылки в файле sitemap.xml. Либо пересоздать этот файл с выбором настройки HTTPS в поле Адрес карты сайта.

    • Примечание: В списке выше указаны основные моменты настройки системы на работу по протоколу HTTPS. Кроме них нужно дополнительно произвести настройки функционала, если этот функционал используется:
    • Если используется CDN, то поставить флажок в поле Сайт работает по https в настройках сервиса Ускорение сайта CDN.
    • Установить флажок в поле Использовать в выгрузке протокол https в выгрузке Yandex. (Рабочий стол > Магазин > Настройки > Экспорт данных).
    • В настройках модуля E-mail маркетинг надо включить https для ссылок в письмах.
    • Указать пути в настройках модуля Push and Pull (Настройки > Настройки продукта > Настройки модулей > Push and Pull).
    • Отключить HTTP в Глобальных действиях Панели управления масштабированием.
    • Изменить настройки URL сайта в форме редактирования сайта , если ваш сайт подключён к Контролеру другого сайта.
      • В случае коробочной версии Битрикс24 к ним добавляются:
    • Установка протокола https в поле Публичный адрес сайта на страницах:
      • Настройки > Настройки продукта > Настройки модулей > Коннекторы для внешних мессенджеров
      • Настройки > Настройки продукта > Настройки модулей > Открытые линии
      • Настройки > Настройки продукта > Настройки модулей > Распознавание лиц
      • Настройки > Настройки продукта > Настройки модулей > Телефония
      • Настройки > Настройки продукта > Настройки модулей > Чат-боты Битрикс24

Оповестить поисковики об изменениях

Важный этап, требующий особой аккуратности в работе. В случае ошибки можно потерять все позиции в поисковых выдачах.

  • Добавить HTTPS-версию сайта в панель для вебмастеров Яндекс Вебмастера и Google Search Console.

    При этом старый сайт удалять не рекомендуется до тех пор, пока ИКС не "переедет" на новый сайт. Теоретически, после того как это произойдёт, можно старый сайт удалить, но рекомендуется оставить его не менее чем на год. В Google сайт лучше не удалять совсем.

  • Изменить адрес в панели Яндекс Вебмастера и Google Search Console.

    Проверка выполнения этого пункта заключается в том, что в строке поиска нужно ввести запрос, по которому будет точно выдан ваш сайт, и проверить какой адрес указал поисковик. Протокол должен быть https. Если это есть, то значит настройка вашего сайта на https успешно завершена.


Контроль за изменениями в системе
136 / 694

Следим за изменениями

Одной из задач обеспечения безопасности в работе сайта является мониторинг изменений в системе. Для осуществления такого мониторинга можно использовать несколько инструментов.

Журнал событий

Журнал событий описан выше , вы с ним, вероятно, уже знакомы. Настраивается он на одноименной закладке Главного модуля.

Журнал изменений

Специальный компонент Журнал изменений , который выводит список изменений:

  • пользователи (добавление);
  • страницы (изменение, добавление, удаление);
  • меню (изменение, создание, удаление);
  • файлы (изменение, добавление, удаление, перемещение, копирование, переименование);
  • разделы (добавление, изменение, удаление, перемещение, копирование, переименование);
  • инфоблоки (добавление, изменение, удаление элементов и разделов);
  • форумы общие и в рамках социальных сетей (сообщение: скрытие,показ, изменение, перенос, удаление; тема: показ, скрытие, прикрепление, открепление, открытие, закрытие, удаление, изменение).

Для использования компонента создайте отдельную страницу на сайте с доступом к ней для нужной группы пользователей. Разместите на ней указанный компонент и настройте его.

Для контроля за изменениями в инфоблоках необходимо настроить параметры журнала событий для конкретного инфоблока в его настройках.

В чём разница?

Журнал изменений и Журнал событий в чем-то перекликаются. Отличие их в том, что Журнал изменений более подходит для мониторинга изменений контента, а Журнал событий - для мониторинга изменений настройки системы.


Пример настроек закладки Безопасность группы пользователей
137 / 694

Настраиваем оптимальное время жизни авторизации

Одна из задач, которую приходится решать администратору - это сочетание безопасности работы сайта и удобства работы пользователя. Например, снять с пользователя необходимость частой авторизации.

Неопытный администратор долгую авторизацию пользователя пытается решить через параметр Время жизни сессии , что не правильно. Долгая жизнь сессии (более 20-30 минут) у множества пользователей неизбежно приведёт к замедлению работы сайта из-за увеличения количества сессий на активных сайтах.

Гораздо лучше для этого использовать сочетание параметров закладки Безопасность (Настройки > Пользователи > Группы пользователей > {группа_пользователей}).

Прежде всего устанавливаем маску для Маски сети для привязки сессии. Этот параметр можно задать достаточно строго, так как за короткий период жизни сессии пользователь вряд ли сменит провайдера.

Для долгой авторизации можно использовать настройку трёх параметров:

  • Поле Максимальное количество компьютеров, на которых может быть одновременно запомнена авторизация не должно быть большим. Для сотрудников, работающих только в организации, естественно, это - 1. Для тех, кто может входить на сайт с разных компьютеров (рабочий, домашний, мобильные устройства) - число должно быть определено конкретно. Если в одной и той же группе есть пользователи с существенно разным числом компьютеров, то есть смысл подумать о создании новых групп пользователей. (Если руководством проекта задаются строгие требования к безопасности.)
  • Для пользователей, работающих с разных мест имеет значение поле Маска сети для привязки сохраненной авторизации. Оно позволяет сохранять авторизацию используя разных провайдеров. Чем меньше провайдеров используется, тем строже может быть маска. Если постоянно используется один и тот же, то рекомендуется маска 255.255.255.0. Если провайдеров может быть несколько, то маску нужно расширить, скажем, 255.255.0.0. Выбор вместо 0 промежуточных значений (что позволяет повысить безопасность) зависит от конкретных условий работы вашей сети.
  • Значение поля Срок хранения авторизации, запомненной на компьютере пользователя не рекомендуется больше одной недели.

Пример настройки для группы пользователей, работающих в течение рабочей недели на работе и дома с нескольких компьютеров может быть таким:


Как закрыть доступ к сайту другому администратору
138 / 694

Как закрыть доступ к сайту другому администратору

Иногда бывают такие ситуации, когда необходимо "вчерашнему" администратору сайта закрыть доступ к этому сайту (например, при смене подрядчика, создавшего и сопровождавщего Ваш сайт). Как же это сделать, ведь у него, как у администратора, есть все "адреса/пароли/явки"?

Чтобы подрядчик не смог восстановить свой доступ (см. урок Как восстановить пароль администратора), выполните три действия:

  1. Сначала найдите Пользователя с ID=1 (Настройки > Пользователи > Список пользователей) и смените E-mail и пароль:

    Примечание: Пользователь с ID=1 по умолчанию является администратором. Конечно, можно лишить его этих прав, сняв соответствующую галку. Однако мы настоятельно рекомендуем этого не делать, так как Вы сами потом не сможете восстановить пароль администратора, если возникнет такая необходимость.

  2. Смените пароль доступа по FTP, чтобы подрядчик не смог зайти на Ваш сервер.
  3. Проверьте у всех остальных пользователей (Настройки > Пользователи > Список пользователей) наличие полных прав на Главный модуль (есть хоть и маленькая, но все-таки вероятность того, что подрядчик создал своего тестового пользователя и дал ему права администратора).


Проактивная защита
139 / 694

В этой главе рассматриваются основные операции по настройке модуля Проактивная защита, который является важным дополнением к стандартной политике безопасности продукта и существенно повышает уровень защиты веб-проекта.


Предотвращаем вторжения
140 / 694

Проактивная защита: предотвращаем вторжения

Защита от хакерских атак, взлома и кражи хранящейся на сайте информации — важная задача для любого действующего проекта, даже если он не имеет доступа к сети Интернет.

Хакерские атаки - это использование некоторых неочевидных возможностей приложений для совершения нетипичных действий, возможность выполнения которых не учитывалась явно разработчиком веб-приложения.

Рассмотрим основные операции по настройке модуля Проактивная защита, который является важным дополнением к стандартной политике безопасности продукта и существенно повышает уровень защиты веб-проекта.

Проактивная защита – это комплекс технических и организационных мер, которые объединены общей концепцией безопасности и позволяют значительно расширить понятие защищенности и реакции веб-приложений на угрозы.

Все настройки параметров Проактивной защиты, в том числе и страница просмотра текущего уровня безопасности Панель безопасности, расположены в разделе Настройки > Проактивная защита.

Главная цель модуля Проактивная защита — уберечь сайт от возможных ошибок при доработке проекта сторонними разработчиками. Этот модуль реализует целый комплекс защитных мероприятий для сайта и сторонних приложений.

Понятие проактивной защиты веб-проекта объединяет в себе следующее:

  • надежную аутентификацию пользователя с использованием одноразовых паролей;
  • технологию защиты сессии пользователя;
  • проактивный фильтр защиты от атак;
  • контроль целостности системы;
  • защиту от фишинга;
  • защиту от DDoS;
  • веб-антивирус;
  • шифрование данных.

Не секрет, что любая включенная функция — дополнительная нагрузка на сервер. Поэтому работа с модулем Проактивная защита — это вечный поиск компромисса между защитой от потенциальной опасности и реальной загруженностью сервера.

Документация по теме:

  • Пользовательская документация по модулю "Проактивная защита"


Немного теории: уязвимости
141 / 694

Немного теории: уязвимости

Уязвимости сайта - недостатки в системе, позволяющие злоумышленнику навредить работе сайта или похитить персональные данные пользователей.

Соответственно, уязвимости можно разделить на два основных типа:

  • атаки непосредственно на систему;
  • атаки на клиентов веб-приложений.

Атаки непосредственно на систему

Это атаки, осуществляемые на систему непосредственно, без всякого участия "сторонних" программ.

  • SQL-инъекция. Один из самых частых и действенных способов атаки, связанный с недостаточной фильтрацией данных, используемых в SQL-запросах. Эта критическая уязвимость приводит к тому, что злоумышленник может выполнить произвольные SQL-запросы к базе данных. В рамках "философии программирования" в Bitrix Framework запрещено обращаться непосредственно к базе. Но разработчики сайтов иногда отходят от этого принципа.
  • Внедрение в имя файла. Уязвимость связана с использованием в качестве части имени файла недостаточно фильтруемого значения, принятого от пользователя. Нападающий может изменить имя файла таким образом, чтобы включить и выполнить на уязвимом сайте произвольный PHP-файл.
  • Выполнение системных команд. Уязвимость связана с недостаточной фильтрацией данных. С помощью инъекции в класс системных функций можно выполнить произвольные команды на целевом сервере в контексте пользователя, от которого работает php.
    Примеры опасных команд такого рода: system, passthru, exec, и.т.д.
  • Подбор реквизитов доступа. Нападающий может подобрать простые пароли.
  • Логические ошибки в коде. Данный тип ошибок особенно тяжело диагностируется и имеет наибольшее разнообразие. Логическая ошибка в коде возникает, когда при некоторых ситуациях код работает не так, как предполагается.

Атаки на клиентов веб-приложения

Это атаки на веб-систему, которые проходят через других пользователей веб-приложения. Например, через администраторов форума.

  • Межсайтовый скриптинг. Уязвимость возникает тогда, когда данные, принятые от пользователя, выводятся в браузер без надлежащей фильтрации. Уязвимость может быть использована для изменения вида HTML-страниц уязвимого сайта в контексте браузера целевого пользователя, похищения cookie данных браузера целевого пользователя с последующим внедрением в его сессию под его учетной записью.
  • Межсайтовая подделка запроса. Если каким-либо образом заставить браузер пользователя сделать запрос к уязвимому серверу, браузер сделает этот запрос с текущими cookie данного пользователя.
  • Социальная инженерия. Злоумышленник может представиться администратором сайта и попросить пароль у пользователя, или изменить пароль на какой-то заданный, или узнать "любимое блюдо" и т. п.
  • Фишинг. Создается подставной веб-сайт, который повторяет дизайн целевого сайта и имеет похожий URL. Например, lc-bitrix.ru (здесь первый символ — "эль", а не "один"), на него заманивается пользователь в надежде, что он введет свои логин и пароль, которые будут доступны злоумышленникам. Уязвимость может быть использована совместно с XSS и CSRF.


Немного теории: уровни Проактивной защиты
142 / 694

Немного теории: уровни Проактивной защиты

Любой веб-проект на базе Bitrix Framework обязательно имеет начальный уровень защиты. Повысить этот уровень можно с помощью модуля Проактивная защита, настроив один из следующих уровней безопасности:

  • Стандартный;
  • Высокий;
  • Повышенный.

Причем для уровней справедливо понятие «вложенности»: чтобы настроить защиту сайта на высоком уровне, необходимо сначала настроить стандартный уровень защиты, а затем настроить все параметры высокого уровня. Соответственно, чтобы настроить защиту на повышенном уровне, необходимо настроить высокий уровень защиты, а затем настроить параметры повышенного уровня.

Информация о текущем уровне безопасности сайта представлена на странице Панель безопасности (Настройки > Проактивная защита > Панель безопасности).

Ниже для каждого уровня приведена соответствующая таблица параметров и их значений, а также указаны рекомендации по изменению значений параметров (т.е. если для какого-то параметра установлено несоответствующее значение, то в поле Рекомендации будет отображено необходимое для выполнения действие).


Настройки модуля Проактивная защита
143 / 694

Настройки модуля

Модуль Проактивная защита настраивается в Административной части на странице Настройки > Настройки продукта > Настройки модулей > Проактивная защита

Нажмите на рисунок, чтобы увеличить

На вкладке Настройки предлагается настроить параметры блокировки по IP-адресу и журналирования событий в системе.

Укажите путь к файлу-флагу, с помощью которого можно снять установленные ограничения IP-адресов в поле Путь к файлу-флажку.

В нижней части формы расположены подсказки по заполнению параметров журналирования. Укажите формат, в котором будет вестись журналирование, путь к файлу журнала, а также при необходимости - параметры системного журналирования.

На закладке Доступ распределяются права доступа к модулю для групп пользователей.

Документация по теме:

  • Настройки модуля


Сканер безопасности
144 / 694

Как работать с нашим собственным инструментом Сканер безопасности рассказывается в этой главе.


Что может сканер безопасности
145 / 694

Сканер безопасности

Сканер безопасности - это инструмент, который позволяет выявить потенциальные ошибки и упущения, связанные с безопасностью сайта.

  • Чтобы сканер имел возможность проводить статический анализ уязвимостей, необходимо установить и включить в системе PHP расширение Tokenizer.
  • При статическом анализе уязвимостей сканер может "подвисать" на проверке больших скриптов (больше 100 Кб). Рекомендуется убирать такие скрипты на время проверки сканером или разбивать скрипты на части.

На текущий момент сканер может следующее:

  • Выполнять внутреннее сканирование окружения проекта (к примеру, безопасно ли хранятся файлы сессий);
  • Выполнять проверку настроек сайта (к примеру, включен ли WAF, установлен ли пароль к базе данных и т. д.);
  • Выполнять поиск потенциальных уязвимостей в коде проекта с помощью статического анализа;
  • Запускать внешнее сканирование.

    Примечание: Внешнее сканирование будет запущено, если сайт доступен снаружи (например, расположен на хостинге, а не на локальной машине) и в опции URL сайта (без http://) настроек главного модуля указан правильный адрес.

Минимальные системные требования по сканеру безопасности:

  • Статический анализ уязвимостей - наличие расширения tokenizer (см. выше), max_execution_time не менее 20 секунд, memory_limit не менее 256Мб;
  • Проверка прав доступа к файлам - max_execution_time не менее 20 секунд.

После нажатия кнопки Запустить сканирование система произведет поиск угроз безопасности и выдаст рекомендации по их устранению.

Примечание: Для некоторых сообщений сканера доступны подробные описания обнаруженной проблемы в секции Детали.

Документация по теме:

  • Сканер безопасности - верный друг и помощник (блог)
  • Сканер безопасности


Трактовка результатов сканера безопасности
146 / 694

Трактовка результатов сканера безопасности

Сканер разделен на две части - локальную и внешнюю. Внешнее сканирование позволяет произвести проверку сайта "снаружи". Локальная - отвечает за проверки, которые невозможно/нецелесообразно выполнить “снаружи”, например, настройки сайта или исполнение php/python/perl/etc скриптов в директории хранения загружаемых файлов гораздо эффективнее проверять именно изнутри.

  • локальное сканирование
  • внешнее сканирование

Локальное сканирование

Настройки окружения

Директория хранения файлов сессий доступна для всех системных пользователей

Сообщение об этой угрозе можно увидеть, когда директория хранения файловых сессий PHP (session.save_path (phpinfo), по умолчанию /tmp) доступна для всех (other), например:

         $ stat -c 'Perms: %A' /tmp Perms: drwxrwxrwt

Если вы не используете хранение сессий в БД и пользуетесь shared-хостингом, то в большинстве случаев ваш "сосед" сможет получить полный доступ к вашему сайту, модифицировав сессионные данные. Это хороший повод задать ему вопрос и потребовать внести правки в конфигурацию, таким образом, дабы сессионные файлы каждого пользователя были отделены друг от друга, и на эти директории были установлены корректные файловые права. Пользователям выделенных серверов это менее критично, но все же рекомендовано.

Если настройка производится самостоятельно, то необходимо создать другую папку (можно даже внутри /tmp, в большинстве случаев) и выставить на неё корректные файловые права, затем указать её в настройках php. Настраивая этот параметр, учтите что у вас есть все шансы загубить авторизацию на сайте или же отключить garbage collector сессионых файлов. Посему - лучше обратитесь к специалисту или в ТП хостинга.

Предположительно в директории хранения сессий находятся сессии других проектов

Подобное сообщение можно встретить, если несколько сайтов используют одну директорию для хранения сессий. Очень часто это можно встретить при использовании выделенных серверов, когда есть N сайтов и все они хранят свои сессии где-нибудь в /tmp/php_sess. Начиная с версии модуля main 12.5.0 это стало не столь критично, но, тем не менее, стоит это исправить, указав собственную директорию хранения сессий для каждого сайта.

Чем это опасно? При такой конфигурации сессии получаются "сквозные", т.е., допустим, есть сайт A и сайт B:
a) Мы регистрируемся на сайте B, получаем идентификатор пользователя 7;
b) Теперь зайдя на сайт A с идентификатором сессии от сайта B, мы окажемся авторизованными под пользователем с идентификатором 7, но сайта A (а что если пользователь с идентификатором 7 на сайте A администратор?).

php/python/perl/etc скрипты исполняются в директории хранения загружаемых файлов

Используя API Битрикс, пользователь сайта не может загрузить .php, .py, .psp, .pl и т.д. файлы без наличия необходимых прав. Но, к сожалению, как в пользовательском коде, так и в коде разработчиков "Маркетплейс" все еще встречается "кастомная" загрузка файлов, которая может позволить загрузить файлы с потенциально опасными расширениями. Именно поэтому лучше исключить эту возможность, корректно сконфигурировав ваш веб-сервер.

.htaccess файлы обрабатываются Apache в директории хранения загружаемых файлов

Аналогично предыдущему, только вектор атаки через загрузку файлов направлен на загрузку .htaccess файлов с "кастомными" конфигурациями. Например, такой:

         <Files ~ "^\.ht"> Order allow,deny Allow from all </Files> AddHandler zend-enabler-script .htaccess <IfModule mod_mime.c> AddType application/x-httpd-php .htaccess </IfModule> #<?php assert($_GET[0]); ?>
Необходимо найти все текущие правила:
         $ find ./upload -type f -name '.htaccess' -print -exec cat {} \; ./upload/support/not_image/.htaccess Deny from all ./upload/.htaccess <IfModule mod_mime.c> RemoveHandler php .php3 .php4 .php5 .php6 .phtml .pl .asp .aspx .cgi .dll .exe .ico .shtm .shtml .fcg .fcgi .fpl .asmx .pht .py .psp AddType text/plain php .php3 .php4 .php5 .php6 .phtml .pl .asp .aspx .cgi .dll .exe .ico .shtm .shtml .fcg .fcgi .fpl .asmx .pht .py .psp </IfModule> <IfModule mod_php5.c> php_flag engine off </IfModule>
Перенести их в конфигурацию виртуального хоста вашего сайта и добавить AllowOverride None для директории загружаемых файлов, например, так:
         <Directory /home/bitrix/www/upload/support/not_image> AllowOverride none Order allow,deny Deny from all </Directory> <Directory /home/bitrix/www/upload> AllowOverride none AddType text/plain php .php3 .php4 .php5 .php6 .phtml .pl .asp .aspx .cgi .dll .exe .ico .shtm .shtml .fcg .fcgi .fpl .asmx .pht .py .psp php_value engine off </Directory>

Apache Content Negotiation разрешен в директории хранения загружаемых файлов

Суть проблемы заключается в том, что в конфигурации Apache по умолчанию можно встретить такую строку:

         AddHandler type-map .var
Это означает, что если в директории загружаемых файлов у вас будет лежать файл с именем test.var.gif и содержимым:
         GIF89: any Content-language: ru Content-type: text/html; Body:----------ru-- <img src=x onerror=prompt(/XSS/)> ----------ru--
(вполне валидная картинка, по мнению PHP), то при запросе этого файла нам будет отдано тело с типом text/html, что логично, т.к. обработчики в Apache вызываются до определения типа:
         $ http -v http://bus-win.my/upload/test.var.gif GET /upload/test.var.gif HTTP/1.1 Accept: */* Accept-Encoding: gzip, deflate, compress Host: bus-win.my User-Agent: HTTPie/0.7.2 HTTP/1.1 200 OK Accept-Ranges: bytes Content-Language: ru Content-Length: 34 Content-Type: text/html Date: Sun, 27 Oct 2013 09:57:40 GMT Server: Apache/2.4.3 (Unix) OpenSSL/1.0.1c PHP/5.4.7 <img src=x onerror=prompt(/XSS/)>
А не как мы ожидали image/gif, что, разумеется, приводит к возможности XSS нападения.

Эта возможность придает гибкости Apache для обработки мультиязычной статики, но безопасности вашего сайта только вредит.

Настройки PHP

Разрешено чтение файлов по URL (URL wrappers)

Чтобы оградить разработчика от "сюрпризов" и повысить безопасность сайта - allow_url_fopen должен быть Off.

Cookies доступны из JavaScript

Имеется в виду, что при установке cookie ваш сайт не передает дополнительный флаг httpOnly для HTTP-заголовка Set-Cookie, который указывает на запрет чтения/записи данных Cookie посредством JavaScript, отсюда и название. XSS атаки наиболее распространены, и получить пользовательские cookies это самый простой их вектор (сейчас все чаще XSS нападение используется для CSRF атак). Поэтому необходимо использовать любую возможность для уменьшения рисков. Флаг httpOnly рекомендуется указывать как минимум для ID сессии, для этого достаточно в настройках PHP указать:

         session.cookie_httponly = On

Ссылки по теме:

  • httpOnly (owasp.org);
  • Директива PHP session.cookie_httponly.

Не установлен дополнительный источник энтропии при создании идентификатора сессии

Отсутствие дополнительной энтропии может использоваться для предугадывания случайных чисел. Необходимо в настройках php указать:

         session.entropy_file = /dev/urandom
         session.entropy_length = 128"

Включено использование тегов в стиле ASP
Многие разработчики не догадываются о существовании подобной опции, а как следствие могут не учесть её в различных проверках. Необходимо в настройках php указать:
         asp_tags = Off

Cookies - не единственное хранилище идентификатора сессии
Хранение идентификатора сессии не только в Cookies может служить источником атак разного типа. Необходимо в настройках php указать:
         session.use_only_cookies = On

Включен вывод ошибок
Вывод ошибок предназначен для разработки и тестовых стендов, он не должен использоваться на конечном ресурсе. Необходимо в настройках php указать:
         display_errors = Off

Настройки сайта

Ограничен список потенциально опасных расширений исполняемых файлов

Так как администратор сайта вправе изменять этот список по своему усмотрению, он может устаревать со временем (когда мы решаем добавить какое-либо расширение в список опасных, к примеру, как было с var). Сканер безопасности сообщит, если в кастомизированном списке содержатся не все необходимые расширения.

Проактивный фильтр выключен

Выключенный проактивный фильтр не сможет отразить попытки нападения на ресурс.

Защита редиректов выключена

Редирект на произвольный сторонний ресурс может служить подспорьем для множества атак, защита редиректов исключает эту возможность (при использовании стандартного API).

Уровень безопасности административной группы не является повышенным

Пониженный уровень безопасности административной группы может значительно помочь злоумышленнику.

Включена отладка SQL запросов (\$DBDebug в значении true)

Отладка SQL запросов может раскрыть важную информацию о ресурсе. Рекомендуется установить значение переменной \$DBDebug в false.

Ошибки, связанные с паролями. Рекомендуется усложнить пароли согласно указаниям сканера.
  • Пароль к базе данных пустой
  • Символы пароля к БД в одном регистре
  • Пароль к БД не содержит чисел
  • Пароль к БД не содержит спецсимволов(знаков препинания)
  • Длина пароля к БД меньше 8 символов

Пользователи

Эти проверки появились только с версии модуля 14.0.3. Основная их цель - проверить, все ли привилегированные пользователи используют MFA, у всех ли установлен пароль достаточной сложности и так далее.

У некоторых пользователей административной группы установлен слабый пароль

Сканер безопасности берет список пользователей из административной группы и пытается подобрать пароль к ним методом перебора по словарю. В случае успеха будет выведен список пользователей, которым необходимо установить более сложный пароль. Зачастую слабый пароль у пользователей административной группы оказывается вследствие того, что изначально они небыли администраторами, т.е. административный доступ предоставляется ранее зарегистрированному пользователю, чьи политики безопасности не требовали стойкого пароля.

Выключена двухэтапная авторизация

Двухэтапная авторизация призвана значительно повысить безопасность сайта от фишинг-атак. Её использование крайне рекомендовано для привилегированных пользователей.

Не все администраторы сайта используют OTP

То же самое, что и в предыдущем пункте. Необходимо оповестить администраторов сайта о необходимости использования OTP.

Внешнее сканирование

Доступен листинг директорий

Включенный Directory AutoIndex встречается повсеместно и сулит как минимум неконтролируемым доступом к загруженным пользовательским файлам. Для nginx необходимо убрать директиву autoindex, она выглядит примерно так:

         location / { autoindex on; ...}
Для Apache это Options +Indexes в конфигурационном файле:
         <Directory /home/bitrix/www> Options +Indexes </Directory>

Открыт доступ к важным сервисам

Всегда помните - все сервисы, необходимые только сайту, не должны быть видны "наружу". Случаи неконтролируемого доступа к критически важным сервисам (например, memcached) - совсем не редкость. Это важный момент, т.к. доступ к memcached, где ваш сайт хранит свой кеш - это, по сути, полный контроль над ним. Если вы пользуетесь shared-хостингом - это отличный повод для "беседы" с ним. Если у вас не кластерная архитектура проекта, то правильнее всего использовать unix-сокет, когда у вас memcached используется для кластера - корректные настройки firewall + SASL.

Инъекция PHP-CGI параметров из строки запроса

Есть уязвимость в PHP: CVE-2012-1823. Она позволяет как читать файлы вашего сайта (/some_script.php?-s), так и в большинстве случаев исполнять произвольный php-код в контексте вашего сайта.
Рекомендуется незамедлительно обновить версию PHP, либо не использовать php-cgi вовсе.

Неправильно сконфигурирована связка Nginx + php-fpm

К сожалению, в интернете все еще достаточно много ужасных "How To" по настройке связки nginx + php-fpm, в которых ни слова не сказано о том, что php-fpm с конфигурацией по умолчанию и location в nginx примерно следующего содержания:

         location ~* \.php$ { fastcgi_pass backend; ...}
позволит злоумышленнику интерпретировать любой файл как php-скрипт.

К примеру, обратившись к аватару пользователя таким образом: /upload/main/f6f/photo.jpg/some.php, злоумышленник выполнит php-код, содержащийся в аватаре (например в EXIF или конце PNG).

Наиболее распространенными вариантами решения является либо указание в php.ini (если это удовлетворяет требованиям вашего проекта):

         cgi.fix_pathinfo=0
либо корректно сконфигурировать nginx, учитывая особенности вашего проекта.

Открыт доступ к служебным "статус" страницам

Так называемые статус-страницы позволяют злоумышленнику получить дополнительную информацию о вашем сайте, которая им столь нужна. Не стоит их радовать, ограничив доступ к ним (а лучше отключив/закрыв авторизацией, т.к. доверять localhost так же не стоит).

Наиболее распространенные:

  • Apache mod_status (например: http://apache.org/server-status);
  • PHP-FPM Status Page - pm.status-path.

Найдены временные файлы

При редактировании файлов на сервере по SSH или при использовании DCVS могут создаваться временные копии текущих файлов, в которых может содержаться важная информация (например, все еще актуальные данные о подключении к БД).

Внешнее сканирование отобразит вам список всех таких файлов, которые необходимо удалить и понять причину их появления. Так же, возможно, стоит ограничить доступ к таким файлам на уровне веб-сервера.

Найдены опасные файлы

Так же достаточно часто встречаются сайты, на которых остались какие-то файлы после отладки, установки и т.д.
Например: bitrixsetup.php, bx_1c_import.php, restore.php, log.txt и т.д.

Внешнее сканирование сообщит вам список найденных файлов, которые в обязательном порядке необходимо удалить.

Доступны настройки PhpMyAdmin

Еще одна частая проблема - доступны настройки PhpMyAdmin (папочка setup в новых версиях). Они как минимум позволяют прочесть текущую конфигурацию PhpMyAdmin и, вдобавок, в них постоянно находятся новые уязвимости. Внешнее сканирование сообщит, "куда нужно смотреть".

Публичный доступ к файлам контроля версий

Как ни странно - публичный доступ к служебным каталогам DCVS все еще достаточно актуальное явление. Зачастую это крайне опасно для вашего сайта - необходимо в срочном порядке закрыть доступ к таким каталогам (.git, .hg, .bzr и т.д.) и к файлам игнорирования (.gitignore, .hgignore и т.д.). В идеале необходимо пользоваться экспортом в вашей DCVS. Разумеется, внешнее сканирование сообщит, "куда нужно смотреть".

Разрешено отображение сайта во фрейме с произвольного домена

Эта ошибка по своей сути ничто иное как, проверка включена ли у вас защита от фреймов. Суть защиты заключается в запрете отображения целевого сайта во фрейме со стороннего сайта или запрете работы во фреймах вовсе. Это рекомендованная настройка нужна для предотвращения целого класса client-side атак (например, таких как Clickjacking, Framesniffing и т.п.).

Проверяемый сайт отвечает на хост по умолчанию

Это, пожалуй, одна из самых распространенных ошибок конфигурации для выделенных серверов. Суть проблемы заключается в том, что сайт отвечает на любой Host в заголовке запроса, вследствие чего, например, если $_SERVER["HTTP_HOST"] попадет в кеш компонента, то получаем классический content spoofing.

Проверить очень легко, запрашиваем наш сайт с правильным хостом:

         $ http -v head some.info HEAD / HTTP/1.1 Accept: */* Accept-Encoding: gzip, deflate, compress Host: some.info User-Agent: HTTPie/0.6.0 HTTP/1.1 200 OK Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0 Connection: keep-alive Content-Encoding: gzip Content-Type: text/html; charset=windows-1251 Date: Fri, 25 Oct 2013 06:57:31 GMT Expires: Thu, 19 Nov 1981 08:52:00 GMT P3P: policyref="/bitrix/p3p.xml", CP="NON DSP COR CUR ADM DEV PSA PSD OUR UNR BUS UNI COM NAV INT DEM STA" Pragma: no-cache Server: nginx/1.2.6 Set-Cookie: PHPSESSID=vp93uc1j3avoibvfkusn5p6gc5; path=/; HttpOnly X-Frame-Options: SAMEORIGIN X-Powered-CMS: Bitrix Site Manager (a0b80388d20et47833773cf8f6b7c738)
А теперь с произвольным:
         $ http -v head some.info 'Host: batman.inc' HEAD / HTTP/1.1 Accept: */* Accept-Encoding: gzip, deflate, compress Host: batman.inc User-Agent: HTTPie/0.6.0 HTTP/1.1 200 OK Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0 Connection: keep-alive Content-Encoding: gzip Content-Type: text/html; charset=windows-1251 Date: Fri, 25 Oct 2013 06:57:35 GMT Expires: Thu, 19 Nov 1981 08:52:00 GMT P3P: policyref="/bitrix/p3p.xml", CP="NON DSP COR CUR ADM DEV PSA PSD OUR UNR BUS UNI COM NAV INT DEM STA" Pragma: no-cache Server: nginx/1.2.6 Set-Cookie: PHPSESSID=55up92i9r2sorg24j78lud9li2; path=/; HttpOnly X-Frame-Options: SAMEORIGIN X-Powered-CMS: Bitrix Site Manager (a0b80388d20et47833773cf8f6b7c738)
Если мы видим одинаковый контент отданный для правильного и произвольного хоста - у нас неправильно сконфигурирован веб-сервер. Для решения этой угрозы, например, в nginx достаточно добавить сервер по умолчанию с перенаправлением на основной домен, например, такой (domain.com замените на ваш домен):
         server { listen 80 default_server; access_log /var/log/nginx/default.host.access.log main; return 301 $scheme://domain.com$request_uri; }
Перед этим не забудьте убедиться, что больше нет явно указанных серверов по умолчанию (с директивой default_server).

Подробнее можно посмотреть в документации nginx.

Найден phpinfo()

С завидным постоянством на сайтах можно увидеть файлы x.php, pi.php, phpinfo.php и т.д. с выводом phpinfo().
Эти файлы не должны быть доступны.

Внешнее сканирование укажет список таких файлов, которые необходимо удалить и впредь использовать встроенную в страницу административного интерфейса ссылку (Настройки > Производительность > PHP, ссылка Настройки PHP) с выводом phpinfo().

Включен Automatic MIME Type Detection для Internet Explorer

По умолчанию в Internet Explorer включен mime-сниффинг (MIME Type Detection in Windows Internet Explorer, Internet Explorer 8 Security Part VI: Beta 2 Update), что никак не идет на пользу безопасности пользователей вашего сайта. В двух словах, если в заголовке ответа Content-Type сказано text/plain, application/octet-stream, он отсутствует либо пуст - Internet Explorer сам решает какой тип у контента, основываясь на его содержимом (начиная с Internet Explorer 8 этим поведением можно управлять при помощи заголовка X-Content-Type-Options).

Самый простой пример эксплуатации этого - загрузка файла без расширения. Допустим, у нас есть скрипт позволяющий загружать только картинки, но сохраняющий их без расширения...

  • Загружаем через него файл test.gif с содержимым:
                 GIF89 <html> <script> prompt('XSS on ' + document.domain); </script> </html>
  • Т.к. это вполне "валидная" картинка с позиции PHP, она благополучно попадет на сервер, но сохранится без расширения (по условиям примера). Допустим, будет доступна по адресу: http://192.168.1.185:8080/upload/test.
  • Для начала проверяем, как его обработает Internet Explorer 10 с включенным mime-сниффингом:
                 $ http head http://192.168.1.185:8080/upload/test HTTP/1.1 200 OK Accept-Ranges: bytes Connection: keep-alive Content-Length: 80 Content-Type: application/octet-stream Date: Sun, 27 Oct 2013 12:14:45 GMT ETag: "526d026b-50" Last-Modified: Sun, 27 Oct 2013 12:09:15 GMT Server: nginx/1.4.3
    Т.к. тип отдаваемого контента application/octet-stream (по умолчанию, регулируется директивой default_type), Internet Explorer включает mime-сниффинг, и мы видим, что наша "картинка" была обработана как html-код:

  • А теперь с заголовком X-Content-Type-Options: nosniff.

    В nginx это можно сделать через add_header:

                 add_header X-Content-Type-Options nosniff;
    Проверяем:
                 $ http head http://192.168.1.185:8080/upload/test HTTP/1.1 200 OK Accept-Ranges: bytes Connection: keep-alive Content-Length: 80 Content-Type: application/octet-stream Date: Sun, 27 Oct 2013 12:18:21 GMT ETag: "526d026b-50" Last-Modified: Sun, 27 Oct 2013 12:09:15 GMT Server: nginx/1.4.3 X-Content-Type-Options: nosniff
    И видим, что Internet Explorer теперь предлагает нам сохранить этот файл:

Документация по теме:

  • Трактовка результатов сканера безопасности (блог)


Стандартный уровень
147 / 694

Стандартный уровень

Чтобы защита веб-проекта осуществлялась на стандартном уровне безопасности, необходимо настроить должным образом все параметры данного уровня:

* для быстрого перехода к описанию настройки нужного Вам параметра кликните по одной из ссылок ниже:

  • 1 , 2 Проактивный фильтр и исключения из него;
  • 3 Ведение журнала вторжений;
  • 4 Контроль активности;
  • 5 Уровень безопасности группы администраторов;
  • 6 Использовать CAPTCHA при регистрации;
  • 7 Режим вывода ошибок (error_reporting);
  • 8 Показ ошибочных запросов базы данных.

Внимание: если стандартный уровень не настроен полностью, то защита сайта будет осуществляться на начальном уровне, но с учетом настроенных параметров на стандартном, высоком и повышенном уровнях.

1 , 2 Проактивный фильтр и исключения из него

Включение или отключение проактивного фильтра выполняется на странице Проактивный фильтр (Настройки > Проактивная защита > Проактивный фильтр) с помощью кнопки Включить проактивную защиту (или Выключить проактивную защиту).

На закладке Активная реакция настраиваются действия системы при попытке вторжения на сайт:

Выберите необходимый вам способ реакции на вторжение:
  • Сделать данные безопасными – опасные данные будут модифицированы, например, select будет заменен на sel ect.
  • Очистить опасные данные – введенные опасные данные будут удалены.
  • Оставить опасные данные как есть – с опасными данными никаких действий выполняться не будет.

Чтобы заблокировать пользователя на некоторое количество минут, отметьте опцию Добавить IP-адрес атакующего в стоп-лист. При этом период времени блокировки задается в поле На сколько минут добавлять в стоп-лист.

Примечание: при добавлении IP-адреса атакующего в стоп-лист становится возможной атака, когда действия злоумышленника могут привести к блокировке посетителей сайта.

Для фиксирования попыток атаки отметьте опцию Занести попытку вторжения в журнал.

Обратите внимание, что некоторые действия пользователей, не представляющие угрозы, тоже могут выглядеть подозрительно и вызывать ложное срабатывание фильтра.

При необходимости могут быть заданы исключения из проактивного фильтра (закладка Исключения), т.е. проактивный фильтр не будет применяться на страницах, указанных на данной закладке.

Примечание: Чтобы защита сайта осуществлялась на стандартном уровне, проактивный фильтр должен быть включен и не должно быть задано ни одного исключения.

Однако при необходимости можно добавить определенные страницы или конкретных пользователей в правило исключения

Исключение для конкретных страниц
  • Перейдите на вкладку Исключения страницы Настройки > Проактивная защита > Проактивный фильтр.
  • В поле Маски исключения внесите нужные вам страницы. С помощью кнопки Добавить можно увеличить число полей для исключений.

Исключение для конкретных пользователей

При необходимости можно настроить проактивный фильтр так, чтобы он не срабатывал на любых страницах, но для определенных групп пользователей. Эта настройка осуществляется на странице настроек параметров самого модуля Проактивная защита:

  • Перейдите на вкладку Доступ страницы Настройки > Настройки продукта > Настройки модулей > Проактивная защита.
  • Для нужных групп пользователей выберите уровень доступа: [F] Обход проактивного фильтра.

Примечание: проактивный фильтр не работает для тех групп пользователей, для которых в правах доступа к модулю Проактивная защита разрешена операция Обход проактивного фильтра. Определяется настройками уровня доступа (Настройки > Пользователи > Уровни доступа) к модулю проактивной защиты.

Примечание: Начиная с версии модуля 14.0.3, для страниц в публичной части сайта с сообщениями функционала "Защита редиректов от фишинга" и "Проактивный фильтр" добавлены теги noindex и nofollow.

3 Журнал вторжений

Журнал вторжений (Настройки > Проактивная защита > Журнал вторжений) предназначен для ведения логов событий, связанных с потенциальными угрозами безопасности сайта. Период времени, в течение которого хранятся записи, определяется настройками Главного модуля на закладке Журнал событий.

Информация о событии, которая фиксируется в журнале
  • дата и время события;
  • название произошедшего события;
  • объект события;
  • IP-адрес, с которого производилась атака. По ссылке [стоп-лист] можно добавить адрес в стоп-лист модуля Веб-аналитика.
  • URL страницы, на которой выполнялось вторжение;
  • имя пользователя, если событие было выполнено зарегистрированным пользователем или идентификатор гостя (при наличии модуля Веб-аналитика);
  • описание события;
  • срочность (SECURITY или WARNING);
  • источник события;
  • используемый User Agent;
  • сайт, на котором произошло событие.

В журнале фиксируются события следующих типов:

  • Со стороны модуля Веб-аналитика: превышение лимита активности.
  • Со стороны модуля Проактивная защита: попытки внедрения SQL и PHP, попытки атак через XSS, попытки заражения вирусами и фишинга через редирект.
  • Со стороны модуля Форум: операции над темами и сообщениями форумов.
  • Со стороны Главного модуля: успешный вход и выход из системы, запрос на смену и смена пароля пользователя, ошибки входа и входа при сохраненной авторизации, регистрация нового пользователя, ошибка регистрации и удаление пользователя.

Подробное описание всех полей списка смотрите на странице пользовательской документации .

4 Контроль активности

Контроль активности пользователей ведется на основе средств модуля Веб-аналитика и, следовательно, доступен только в тех редакциях продукта, в которые входит этот модуль. Контроль активности позволяет установить защиту от чрезмерно активных пользователей, программных роботов, некоторых категорий DDoS-атак, а также отсекать попытки подбора паролей перебором.

Включение или отключение контроля активности выполняется на странице Контроль активности (Настройки > Проактивная защита > Контроль активности) с помощью кнопки Включить контроль активности (или Выключить контроль активности).

На закладке Параметры задаются параметры максимальной активности пользователей вашего сайта.

Таким образом, если пользователь превысит количество запросов за указанное количество секунд, то он будет заблокирован на заданное время. При этом ему будет отображена специальная страница, шаблон которой можно отредактировать по ссылке редактировать шаблон. Для фиксирования превышения лимита активности в журнале вторжений необходимо отметить опцию Сделать запись в журнале событий.

Примечание: Контроль активности связан с работой модуля Веб-аналитика. Поэтому его настройку можно также произвести на странице настроек модуля (Настройки > Настройки продукта > Настройки модулей > Веб-аналитика, закладка Настройки, секция Ограничение активности).

5 Уровень безопасности группы администраторов

Чтобы защита веб-проекта осуществлялась на стандартном уровне, необходимо задать повышенный уровень безопасности для группы администраторов. По умолчанию данный параметр уже настроен. Если по каким-либо причинам уровень безопасности группы администраторов отличен от повышенного, то необходимо выполнить следующее:

  • На странице Панель безопасности нажмите ссылку Включить повышенный для опции Уровень безопасности группы администраторов. Откроется форма редактирования группы на закладке Безопасность (Настройки > Пользователи > Группы пользователей).
  • В поле Предопределенные настройки уровня безопасности укажите повышенный уровень.
  • Сохраните внесенные изменения.

6 Использовать CAPTCHA при регистрации

Необходимым условием для защиты сайта на стандартном уровне является использование CAPTCHA при регистрации новых пользователей. Данная опция включается в настройках главного модуля на закладке Авторизация.

Настройка внешнего вида CAPTCHA выполняется на странице CAPTCHA (Настройки > Настройки продукта > CAPTCHA).

7 Режим вывода ошибок

Наряду с параметром Использовать CAPTCHA при регистрации, необходимо настроить еще один параметр главного модуля – Режим вывода ошибок (error_reporting), чтобы защита сайта осуществлялась на стандартном уровне безопасности.

  • Перейдите на страницу настроек Главного модуля (Настройки > Настройки продукта > Настройки модулей > Главный модуль).
  • В поле Режим вывода ошибок (error_reporting) укажите Только ошибки или Не выводить.

    • Примечание: если выбрать режим Ошибки и предупреждения, то будет установлен начальный уровень безопасности.

  • Сохраните внесенные изменения.

8 Показ ошибочных запросов базы данных

Для осуществления защиты веб-проекта на стандартном уровне показ ошибочных данных должен быть выключен, т.е. переменная $DBDebug должна принимать значение code. Таким образом, в случае ошибки при создании соединения с базой или выполнения запроса полный текст ошибки будет отображаться только администраторам сайта. Если же переменная принимает значение true, то полный текст ошибки будет отображаться всем пользователям сайта.

Изменение значения переменной $DBDebug выполняется в файле /bitrix/php_interface/dbconn.php.

Документация по теме:

  • Проактивный фильтр
  • Контроль активности


Высокий уровень
148 / 694

Высокий уровень

Чтобы защита веб-проекта осуществлялась на высоком уровне безопасности, сначала необходимо настроить стандартный уровень безопасности, а затем выполнить настройку параметров для высокого уровня:

Высокий уровень безопасности

* для быстрого перехода к описанию настройки нужного Вам параметра кликните по одной из ссылок ниже:

  • 1 Журналирование событий главного модуля;
  • 2 Защита административной части;
  • 3 Хранение сессий в базе данных;
  • 4 Смена идентификатора сессий;
  • 5 Защита редиректов от фишинга.
  • 6 Защита от фреймов.

Внимание: если некоторые параметры высокого уровня безопасности принимают несоответствующие значения, то защита сайта будет осуществляться на стандартном или начальном (если настроены не все параметры стандартного уровня) уровне, но с учетом настроенных параметров на стандартном, высоком и повышенном уровнях.

1 Журналирование событий главного модуля

Параметр Журналирование событий главного модуля подразумевает целый ряд настроек Главного модуля (Настройки > Настройки продукта > Настройки модулей > Главный модуль):

Чтобы защита сайта велась на высоком уровне, должны быть отмечены все опции секции События для записи в журнал . Даже если не будет отмечена только одна опция, то считается, что параметр Журналирование событий главного модуля принимает несоответствующее значение, и защита сайта будет осуществляться на стандартном (или начальном) уровне безопасности.

2 Защита административной части

Защита административной части сайта осуществляется с помощью ограничения доступа со всех, кроме указанных в настройках IP-адресов. Включение или отключение защиты выполняется на странице Защита административного раздела (Настройки > Проактивная защита > Защита административного раздела) с помощью кнопки Включить защиту (или Выключить защиту).

Внимание: перед включением защиты административной части необходимо внести в список IP-адреса и диапазоны, с которых разрешен доступ к административной части свой IP-адрес и дополнительные адреса (или диапазоны), с которых разрешен доступ.

Снять уже установленное ограничение по IP-адресам можно посредством создания специального файла, путь к которому задается в настройках модуля Проактивная защита. По умолчанию файл имеет имя следующего формата: ipcheck_disable_<случайный_набор_из_32_символов>.

3 , 4 Хранение сессий и смена идентификатора

Сессия пользователя – это ключевой объект атаки на веб-сайт с целью похищения сессии авторизованного пользователя и в особенности администратора. В базовой поставке продукта защита сессий настраивается в политике безопасности каждой группы пользователей с помощью параметров:

  • Время жизни сессии (минут);
  • Маска сети для привязки сессии.

Но такие строгие настройки не всегда получается ввести, например в силу того, что пользователи могут работать с разных IP-адресов. Модуль Проактивная защита позволяет выполнить защиту сессий с помощью следующих инструментов:

  • хранение сессий в базе данных модуля безопасности;
  • смена идентификатора сессий через указанное время.

Включение (или отключение) механизма хранения данных сессий пользователей в базе данных выполняется на странице Защита сессий (Настройки > Проактивная защита > Защита сессий) с помощью кнопки Включить хранение данных сессий в БД модуля (или Отключить хранение данных сессий в БД модуля).

Хранение данных сессий в таблице модуля Проактивная защита позволяет избежать чтения этих данных через скрипты других виртуальных серверов, исключив ошибки конфигурирования виртуального хостинга, ошибки настройки прав доступа во временных каталогах и ряд других проблем настройки операционной среды. Кроме того, это разгружает файловую систему, перенося нагрузку на сервер базы данных.

Внимание! При переключении режима хранения сессий все пользователи потеряют авторизацию (данные сессий будут уничтожены).

Примечание: допустимо хранение сессий в memcached .

Настройка механизма смены идентификатора сессий выполняется на закладке Смена идентификатора формы настройки защиты сессий.

Чтобы выполнялась смена идентификатора, необходимо:

  • указать Время жизни идентификатора, в секундах, т.е. через какой промежуток времени будет изменяться идентификатор сессий;
  • нажать кнопку Включить смену идентификатора.

Смена идентификатора создает дополнительную нагрузку на сервер, но позволяет сделать похищение авторизованной сессии неэффективным.

Примечание: Хранение сессий также рекомендуется при конфигурации с несколькими веб-серверами веб-кластера .

5 Защита редиректов от фишинга

Фишинг основан на незнании пользователями основ сетевой безопасности. Они воспринимают просьбы от якобы используемого ими сервиса сообщить свои учетные данные, пароль и др. как вполне легальные.

Такая мера получения несанкционированного доступа характерна для проектов с большой посещаемостью и большим числом пользователей, когда есть вероятность, что в общей «толпе» окажется достаточное количество некомпетентных пользователей.

Включение или отключение защиты редиректов от фишинга выполняется на странице Защита редиректов (Настройки > Проактивная защита > Защита редиректов) с помощью кнопки Включить защиту редиректов от фишинга (или Выключить защиту редиректов от фишинга).

Параметры защиты от фишинга настраиваются на закладке Параметры:

Защита редиректов от фишинга может осуществляться:

  • Проверкой наличия HTTP-заголовка, описывающего страницу;
  • Проверкой наличия в HTTP-заголовке записи о текущем сайте, который описывает ссылающуюся страницу;
  • Добавлением цифровой подписи к ссылкам, генерируемым на сайте.

При включенной защите все системные ссылки обязательно подписываются дополнительным параметром индивидуальным для сайта и для этого перехода. Кроме того, можно защитить пользовательские ссылки перенаправлений, добавив их в поле Подписываемые URLs в секции Пользовательские (добавление полей ввода осуществляется с помощью кнопки Добавить).

Защита редиректов может выражаться одним из следующих действий:

  • Перенаправлением на другой сайт с показом соответствующего сообщения и выполнением задержки на несколько секунд.

    Текст сообщения задается с помощью поля Сообщение, а период задержки пользователя – в поле Задержка.
или
  • Перенаправлением на заведомо безопасный адрес, например, на главную страницу сайта.

    В этом случае необходимо задать адрес страницы сайта с помощью поля URL.

Примечание: Начиная с версии модуля 14.0.3, для страниц в публичной части сайта с сообщениями функционала "Защита редиректов от фишинга" и "Проактивный фильтр" добавлены теги noindex и nofollow.

Для фиксирования попыток фишинга через редирект необходимо отметить опцию Занести попытку фишинга в журнал.

6 Защита от фреймов

Ограничение отображения страниц сайта во фреймах сторонних доменов позволяет защитить ресурс от Clickjacking'a (подсовывание невидимого фрейма с целевого ресурса для получения клика от пользователя), Framesniffing'а и существенно снижает риск проведения Cross-site scripting атак.

Включение или отключение ограничения отображения страниц сайта во фреймах на сторонних доменах осуществляется на странице Защита от фреймов (Настройки > Проактивная защита > Защита от фреймов), закладка Защита от фреймов.

На закладке Исключения можно указать страницы, для которых настройки ограничения применяться не будут.

Страницы можно указать по маскам (например: /bitrix/* или */news/*) как для всех сайтов, так и для конкретного.

Документация по теме:

  • Защита административного раздела
  • Защита сессий
  • Защита редиректов
  • Защита от фреймов


Повышенный уровень
149 / 694

Повышенный уровень

Чтобы защита веб-проекта осуществлялась на повышенном уровне безопасности, сначала необходимо настроить защиту на стандартном и высоком уровне, а затем настроить параметры повышенного уровня:

Повышенный уровень безопасности

* для быстрого перехода к описанию настройки нужного Вам параметра кликните по одной из ссылок ниже:

  • 1 Двухэтапная авторизация;
  • 2 Контроль целостности;
  • 3 , 4 , 5 , 6 Веб-антивирус.

Внимание: если хотя бы один параметр повышенного уровня безопасности принимает несоответствующее значение, то защита сайта будет осуществляться на том уровне, который настроен полностью, но при этом будут учтены настройки параметров всех уровней.

1 Двухэтапная авторизация

Двухэтапная авторизация позволяет дополнить стандартную систему авторизации и позволяет значительно усилить систему безопасности сайта.

При каждой авторизации пользователь должен дополнительно, помимо логина и пароля ввести секретный код со специального устройства или мобильного приложения, который каждый раз имеет новое значение. Такой подход исключает возможность несанкционированного доступа, в случае, например, кражи основного пароля.

Подробнее про механизм двухэтапной авторизации можно посмотреть в соответствующей главе .

2 Контроль целостности

Форма, расположенная на странице Контроль целостности (Настройки > Проактивная защита > Контроль целостности), служит для выполнения проверки целостность ядра, системных областей, публичной части продукта.

Для защиты веб-проекта на повышенном уровне безопасности необходимо регулярно (примерно раз в неделю) выполнять проверку целостности системы. Кроме того, проверку целостности следует выполнять перед установкой обновлений системы, а после установки обновлений необходимо собрать новую информацию по файлам.

Примечание: некоторые обновления модуля могут потребовать переподписания скрипта контроля.

Первый запуск проверки целостности
  • Введите и запомните пароль, состоящий из латинских букв и цифр, длиной не менее 10 символов.
  • Подтвердите его в поле Пароль еще раз.
  • Задайте Ключевое слово, отличное от пароля, и запомните его.

  • Нажмите кнопку Далее.

Если вы не ошиблись при подтверждении пароля, то отобразится сообщение об успешном подписании скрипта.

Теперь можно приступать к сбору информации по файлам, чтобы в дальнейшем выполнить проверку целостности системы.

Сбор информации по файлам
  • На закладке Выбор действия отметьте опцию Собрать информацию по файлам:

  • Нажмите кнопку Далее. Откроется форма сбора данных.

  • Задайте параметры для сбора информации:
    • Область сбора данных – отметьте необходимые для обработки папки системы.
    • Расширения файлов – укажите расширения файлов, по которым должна быть собрана информация. Расширения файлов указываются через запятую без пробелов. По умолчанию информация собирается для файлов с расширениями php, js, htaccess.
    • Пароль для шифрования – введите и запомните пароль, который будет использоваться для шифрования и последующего дешифрования собранного верификационного файла.
    • Время выполнения шага – укажите количество секунд для выполнения одного шага сбора данных.
  • Нажмите кнопку Далее. Начнется процесс сбора данных, по окончании которого в целях безопасности рекомендуется скачать файл с данными на локальный компьютер.

Файл с верификационными данными собран, теперь можно выполнить проверку целостности системы.

Проверка целостности системы

При любом (кроме первого) запуске проверки целостности системы сначала проверяется сам скрипт контроля на наличие в нем изменений.

  • Введите пароль, которым вы подписали скрипт контроля, и нажмите кнопку Далее.

В сообщении о результатах проверки скрипт должен указать кодовое слово, которое вы ввели в момент подписания.

Примечание: если вы не увидели своего кодового слова в сообщении о результатах проверки, то скрипт контроля целостности файлов скомпрометирован (т.е. он был изменен и его результатам доверять нельзя). В этом случае необходимо заменить скрипт контроля целостности системы (например, можно сделать откат до более ранней версии модуля).

  • На закладке Выбор действия отметьте опцию Проверить файлы.

  • Нажмите кнопку Далее. Откроется форма выбора файла с верификационными данными.

  • Выберите один из лог-файлов, хранящихся в системе, либо загрузите лог-файл с вашего компьютера с помощью кнопки Обзор. Откроется форма проверки данных.

  • В поле Пароль для дешифрования укажите пароль, который вы задавали при создании файла с верификационными данными.
  • Укажите время выполнения одного шага проверки (чем меньше время выполнения одного шага, тем больше нагрузка на сервер).
  • Нажмите кнопку Далее. Начнется процесс проверки целостности системы, по окончании которого будет выведен отчет:

3 , 4 , 5 , 6 Веб-антивирус

Веб-антивирус - система противодействия заражениям сайтов. Веб-антивирус выявляет в html-коде потенциально опасные участки и "вырезает" подозрительные объекты из кода сайта, тем самым препятствуя проникновению вирусов на компьютер пользователя.

Внимание! веб-антивирус не является заменой обычного антивируса.

Включение или отключение веб-антивируса выполняется на странице Веб-антивирус (Настройки > Проактивная защита > Веб-антивирус) с помощью кнопки Включить веб-антивирус (или Выключить веб-антивирус).

По умолчанию веб-антивирус всегда включен. Отключая его, Вы снижаете контроль за безопасностью своего сайта. Несмотря на ограничения доступа из Всемирной сети, корпоративный проект можно инфицировать.

С целью уменьшения нагрузки на сервер веб-антивирус не проводит автоматически проверку с заданной периодичностью, а проверяет код непосредственно в момент его отдачи браузеру. Вирус будет обнаружен именно в этот момент, а уведомления об обнаруженном вирусе администратор сайта будет получать в интервале, заданном в настройках веб-антивируса. Прежде всего настройте периодичность оповещения и параметры реакции антивируса на обнаруженный подозрительный код.

Перейдите на страницу Настройки > Проактивная защита > Веб-антивирус, на вкладку Параметры. Откроется форма настройки параметров реагирования на угрозы.

В поле Интервал оповещения (минуты) можно изменить периодичность уведомления администратора при обнаружении модулем вируса. Значение можно оставить по умолчанию.

Вне зависимости от выбранного режима работы (только Оповестить или Вырезать) пользователь не получает сообщения. Но в первом случае система выдает посетителю сайта вместе с кодом запрошенной страницы код подозрительного объекта (и компьютер сотрудника тоже может заразиться вирусом). Во втором случае подозрительный код вырезается из отдаваемой пользователю страницы. В любом случае администратор получает уведомление (на почту и в Журнал вторжений).

Примечание: Строго говоря, вирус не присутствует на сайте. На сайте есть ссылка на связку скриптов и вирус, которыми заражаются посетители проекта. Заражение может реализоваться двумя способами:
  • Первый: на каком-либо сайте выставляется ссылка на вирус. Задача вируса — заразить посетителей. Если этот сайт посещает некоторый человек с устаревшим браузером, то связка скриптов (эксплоитов) "пробивает" браузер и заражает ПК посетителя. Компьютер посетителя пополняет армию ботов в какой-нибудь зомби-сети.
  • Второй: на этот сайт заходит не просто посетитель, а администратор другого сайта и тоже заражается. В этом случае вирус не просто пополняет зараженным компьютером армию ботов, а находит на компьютере сохраненные пароли от серверов, обслуживаемых этим администратором. Пароли передаются автору вируса, который заходит на сайты с помощью похищенных паролей и добавляет на них ссылки на свой вирус.

С полем Действия при обнаружении вируса нужно быть внимательными. Проблема заключается в том, что любая система может допускать ложные срабатывания. Количество ложных срабатываний веб-антивируса минимально, но, к сожалению, они все же встречаются. Иными словами, если вы выберете параметр Вырезать из кода сайта, то в случае ошибки можете нанести ущерб самим себе.

Как отличить ошибку от ложного срабатывания?

Работа веб-антивируса основана на эвристическом анализе потенциально опасных блоков в HTML-коде. В целом распознавание "вирусных" и легитимных блоков может быть сложной задачей даже для человека, а не только для программы.

Ключевое отличие блоков, действительно содержащих ссылки на вирусы, от ложных срабатываний — это то, что ошибочно принятые за вирус блоки были явно добавлены вашим программистом. Кто добавил "вирусные" блоки и откуда они взялись, вы не знаете.

Если вы уверены, что блок, на который срабатывает веб-антивирус, легитимный и не содержит ссылки на загрузку вирусов, то данное срабатывание антивируса является ложным. В этом случае вам необходимо взять некоторую строку из этого блока (достаточно длинную и достаточно уникальную) и добавить ее в исключения веб-антивируса на одноименной вкладке страницы Веб-антивирус. В результате антивирус перестанет срабатывать на любые обрабатываемые им блоки, содержащие указанную строку.

Маска исключений должна быть достаточно уникальной, но при этом покрывать все блоки данного типа (если они генерируются динамически). Вероятность того, что при добавлении достаточно длинной строки (содержащей, например, имена нормальных переменных или функций из корректного блока) случайно будет разрешен вирус, невелика.

Если срабатывание антивируса не ложное, то все будет намного сложнее. Удалить обнаруженный код — дело несложное. Нужно понять, как он оказался на вашем сайте. Почти со стопроцентной уверенностью можно утверждать, что "вирусный" блок был помещен злоумышленником с помощью пароля, похищенного через компьютер какого-либо сотрудника, имеющего доступ на сервер через FTP (SSH, SFTP и т. п.). Этот компьютер заражен вирусом, укравшим пароль от сервера.

При обнаружении вируса на сайте
  • необходимо проверить все компьютеры людей, имеющих доступ к сайту (в том числе к Панели администрирования), с помощью персонального антивирусного программного обеспечения;
  • после того как все такие компьютеры были вылечены, нужно сменить все пароли от вашего сервера всем пользователям;
  • только после этого можно вычищать весь сторонний код на сервере. При вычищении кода обратите внимание на сроки обнаружения заражения и сроки создания резервной копии (бэкапа) сайта. Если по каким-то причинам резервное копирование делалось после даты заражения, бэкапом пользоваться нельзя.

Для отслеживания изменившихся файлов рекомендуется использовать инструмент Контроль целостности. Если же вы не используете данный инструмент, то в общем случае поиск всех изменений, оставленных хакером, может быть таким:

  • поиск по всем файлам на сервере, содержащем строки из блока, на который сработал веб-антивирус;
  • поиск и ручная проверка всех недавно изменившихся файлов;
  • анализ логов HTTP-сервера.

При этом остается надеяться, что хакер оказался не слишком хитрым, ограничился внедрением JavaScript со ссылками на вирус и не оставил за собой скрытых бэкдоров (что, в общем-то, бывает достаточно редко).

Примечание: для детектирования вирусов, внедренных до старта буферизации вывода, необходимо задать
  • либо в php.ini:
    • auto_prepend_file = /www/bitrix/modules/security/tools/start.php
  • или в файле .htaccess:
    • php_value auto_prepend_file "/www/bitrix/modules/security/tools/start.php"

Документация по теме:

  • Веб-антивирус
  • Двухэтапная авторизация
  • Контроль целостности


Двухэтапная авторизация
150 / 694

В этой главе рассказывается, как значительно усилить систему безопасности продуктов «1С-Битрикс» с помощью механизма двухэтапной авторизации и системы одноразовых паролей.


Система одноразовых паролей
151 / 694

Система одноразовых паролей дополняет стандартную систему авторизации и позволяет значительно усилить систему безопасности продуктов «1С-Битрикс».

Одноразовый пароль (англ. one time password, OTP) — это пароль, действительный только для одного сеанса аутентификации. Действие одноразового пароля также может быть ограничено определенным промежутком времени. Преимущество одноразового пароля по сравнению со статическим в том, что пароль невозможно использовать повторно. Таким образом, злоумышленник, перехвативший данные из успешной сессии аутентификации, не может использовать скопированный пароль для получения доступа к защищаемой информационной системе.

При каждой авторизации пользователь получает новый секретный код, что исключает возможность его получения злоумышленниками. При включении системы OTP в продукте «1C-Битрикс» можно авторизоваться только с использованием дополнительного одноразового пароля.

В продуктах «1C-Битрикс» поддерживаются два алгоритма генерации одноразовых паролей:

  • по счетчику ( HMAC-Based One-time Password, HOTP ) - код будет доступен до тех пор, пока пользователь не запросит новый;
  • по времени ( Time-based One-time Password, TOTP ) - код будет доступен в течение 30 секунд с момента его получения, после чего он автоматически обновится.

Внимание! Все коды доступа являются одноразовыми, повторное их использование для авторизации невозможно.

Краткое описание технологии

Для расчета значения OTP принимаются два входных параметра - секретный ключ (начальное значение для генератора) и текущее значение счетчика (количество необходимых циклов генерации или текущее время, в зависимости от выбранного алгоритма). Начальное значение хранится как в самом устройстве, так и на сайте после инициализации устройства.

В случае использования алгоритма по счетчику (HOTP), счетчик в устройстве увеличивается при каждой генерации OTP, на сервере - при каждой удачной аутентификации по OTP.
В случае использования алгоритма по времени (TOTP), счетчик в устройстве не хранится, на сервере лишь корректируется возможное небольшое смещение времени устройства при каждой удачной аутентификации по OTP.

Партия устройств OTP поставляется с зашифрованным файлом, содержащим начальные значения (секретные ключи) для всех устройств партии, связанного с серийным номером устройства (печатается на корпусе устройства).

В случае нарушения синхронизации счетчика генерации в устройстве и на сервере, её можно легко восстановить - привести значение на сервере в соответствие значению, хранящемуся в устройстве. Для этого администратор системы или сам пользователь (при наличии соответствующих разрешений) должен сгенерировать два последовательных значения одноразовых паролей (OTP) и ввести их в форму на сайте.

Примечание:

Количество действующих кодов авторизации по счетчику после предыдущей успешной авторизации ограничивается параметром Размер окна проверки паролей.

Количество действующих кодов авторизации по времени ограничивается временным интервалом 1 минута в обе стороны (по 2 кода, которые действительны 30 секунд).

Документация по теме:

  • Двухэтапная авторизация (ОТР) (курс "Пользователь сервиса Битрикс24")
  • Одноразовый_пароль (Wikipedia)
  • HMAC-Based One-Time Password Algorithm (Wikipedia)
  • Time-based One-time Password Algorithm (Wikipedia)


Включение и общие настройки механизма двухэтапной авторизации
152 / 694

Включение механизма двухэтапной авторизации

Включение/отключение механизма двухэтапной авторизации на сайте производится на странице Двухэтапная авторизация (Настройки > Проактивная защита > Двухэтапная авторизация).

Настройки механизма двухэтапной авторизации

На закладке Параметры (Настройки > Проактивная защита > Двухэтапная авторизация) можно настроить параметры механизма двухэтапной авторизации:

Подробное описание значений полей
  • Размер окна проверки паролей - задается размер окна проверки паролей, если используется алгоритм генерации паролей по счетчику ( мобильное приложение или аппаратное устройство OTP ).

    Если на устройстве была нажата кнопка несколько раз (например, случайно), но не было выполнено ни одной удачной аутентификации, то при превышении числа нажатий значения, заданного в этом параметре, произойдет нарушение синхронизации счетчика генерации, и пользователь не сможет выполнить вход на сайт.
  • Алгоритм генерации паролей по умолчанию - выбирается алгоритм генерации паролей, который будет использоваться в системе по умолчанию:
    • по счетчику - HOTP (RFC4226);
    • по времени - TOTP (RFC6238).
  • Разрешить запоминание одноразового пароля - опция позволяет разрешить запоминание введенного одноразового пароля с помощью соответствующей опции в форме авторизации, что позволит в следующий раз его уже не запрашивать.

    Примечание: Опция позволят сохранить одноразовый пароль во всех случаях, согласно настройкам политики безопасности группы, в которую входит пользователь, кроме случая самостоятельного завершения сессии.

  • Разрешить использование резервных кодов - опция разрешает использование функционала генерации резервных кодов авторизации, которые можно будет использовать для входа на сайт вместо одноразового пароля.

    Например, в случае утери устройства для двухэтапной авторизации, пользователь сможет самостоятельно авторизоваться на сайте только с помощью этих кодов.

  • Требовать двухэтапную авторизацию - опция позволяет указанным ниже пользователям через заданное время принудительно включить двухэтапную авторизацию.

    В редакциях Стандарт и Малый бизнес есть возможность включить двухэтапную авторизацию, но нет модуля Социальная сеть, где по умолчанию выводятся публичные инструменты подключения пользователями этой авторизации. В этом случае нужно добавить в публичную часть страницу с размещённым на ней компонентом Подключение устройства OTP (bitrix:security.user.otp.init).

  • Количество дней для подключения - указывается период, в течение которого пользователь должен подключить свое устройство для двухэтапной авторизации. Отсчет времени начнется при первой авторизации пользователя после включения опции требовать двухэтапную авторизацию.

    По истечении указанного времени доступ на сайт будет возможен только с использованием одноразового пароля. Если в этом поле выбрано "0", то система будет требовать OTP уже при следующей авторизации пользователя.

  • Пользователи с обязательной двухэтапной авторизацией - указываются пользователи, для которых будет принудительно подключена двухэтапная авторизация.

После включения механизма на сайте необходимо, чтобы пользователи произвели подключение своих устройств двухэтапной авторизации.

Внимание! В случае если пользователь в указанный промежуток времени не подключил свое устройство для двухэтапной авторизации и не может зайти на сайт, администратор может на странице редактирования пользователя отключить для него двухэтапную авторизацию на необходимое время.

Если не получается зайти на портал

При жалобах пользователей на невозможность войти на портал при подключённой двухэтапной авторизации нужно сделать следующее:

  • При алгоритме по времени пользователь должен проверить расхождение времени на его устройстве и на сервере сайта (портала).
  • При алгоритме по счётчику администратору нужно повторно подключить телефон пользователя как аппаратное устройство.

Документация по теме:

  • Пример настроек закладки Безопасность группы пользователей (курс Администратор. Базовый)


Подключение устройств
153 / 694

Как подключить аппаратное устройство OTP или мобильное приложение, рассказывается в этой главе.


Какие устройства можно подключить
154 / 694

После включения механизма двухэтапной авторизации всем пользователям нужно подключить одно из устройств OTP:

  • Мобильное приложение - пользователь самостоятельно подключается в публичной части сайта (продукты Битрикс 24).

    Также мобильное приложение можно подключить и в административной части сайта, обладая соответствующими правами.
  • Аппаратное устройство - подключение производится только через административную часть сайта (администратором или пользователем, обладающим соответствующими правами).

Внимание! Одновременно можно использовать лишь одно средство (мобильное приложение/аппаратное устройство) для двухэтапной авторизации. При подключении нового устройства авторизоваться с помощью старого будет уже невозможно.


Мобильное приложение
155 / 694

Мобильное приложение

Наиболее простой и удобный способ авторизации на сайте, использующем двухэтапную авторизацию - авторизация с использованием мобильного приложения.

Чтобы использовать такой способ, нужно установить на мобильный телефон специальное приложение, а затем подключить его на сайте, заполнив специальную форму. После этого при каждой авторизации, помимо логина и пароля, необходимо будет ввести еще и код, который сгенерирует приложение.

Рекомендуется использовать мобильное приложение Bitrix24 OTP:

Его можно скачать по следующим ссылкам:

Подробнее про работу с приложением можно посмотреть в уроке Мобильное приложение Bitrix24 OTP.

Также для двухэтапной авторизации можно использовать и другие приложения.

Внимание! Перед подключением двухэтапной авторизации проверьте правильность установленного времени и часового пояса в вашем мобильном устройстве.

Подключение приложения в административной части сайта

Подключить приложение можно и в публичной, и в административной части сайта.

Подробнее про подключение приложения в публичной части сайта смотрите в уроке Мобильное приложение Bitrix24 OTP.

Для подключения мобильного приложения в административной части перейдите на страницу редактирования пользователя (Настройки > Пользователи > Список пользователей), вкладка Двухэтапная авторизация:

Примечание: Вкладка отображается только если в системе включено использование механизма двухэтапной авторизации.

  1. С помощью кнопки Подключить телефон выберите алгоритм генерации паролей, который будет использоваться для двухэтапной авторизации сайта и поддерживаться приложением:
    • По счетчику (HOTP);
    • По времени (TOTP).
  2. В открывшейся форме отсканируйте с помощью приложения QR-код
    • При использовании алгоритма по счетчику получите первый код и введите его в первое поле.
      Затем сгенерируйте второй код и введите его во второе поле.
    • При использовании алгоритма по времени получите код и введите его в единственное поле.

    В случае отсутствия возможности отсканировать QR-код воспользуйтесь ссылкой Ввести данные вручную

    • Адрес сайта вида www.site.ru;
    • E-mail, с которым был зарегистрирован пользователь на сайте;
    • Секретный ключ, который указан на картинке (можно не обращать внимания на пробелы);
    • Тип ключа.
  3. Сохраните внесенные изменения.

После чего подключение будет завершено, а форма на вкладке Двухэтапная авторизация примет следующий вид:

Описание возможных действий
  • Отключить - позволяет отключить двухэтапную авторизацию бессрочно или же на определенное количество дней.
  • Резервные коды - позволяет перейти к форме работы с резервными кодами.
  • Синхронизировать - позволяет перейти к форме синхронизации устройств.
  • Подключить новый брелок/телефон - позволяет произвести подключение нового устройства двухэтапной авторизации.

Резервные коды доступны, если на странице настроек двухэтапной авторизации отмечена соответствующая опция.

Внимание! Одновременно можно использовать лишь одно средство (мобильное приложение/аппаратное устройство) для двухэтапной авторизации. При подключении нового устройства авторизоваться с помощью старого будет уже невозможно.


Аппаратное устройство
156 / 694

Аппаратное устройство

Помимо мобильного приложения, для двухэтапной авторизации можно использовать и аппаратные устройства, например, USB-токен JaCarta WebPass .

Для подключения брелка необходимо перейти на страницу редактирования пользователя (Настройки > Пользователи > Список пользователей), вкладка Двухэтапная авторизация:

  1. С помощью кнопки Подключить брелок выберите алгоритм генерации паролей, который будет использоваться для двухэтапной авторизации сайта в соответствии с документацией к брелку:
    • По счетчику (HOTP);
    • По времени (TOTP).
  2. В открывшейся форме заполните следующие поля:
    • Секретный ключ - секретный ключ, который поставляется вместе с устройством.
    • Первое значение пароля на устройстве - вводится код, который необходимо сгенерировать с помощью брелка.
    • Следующее значение пароля на устройстве - вводится следующий по счету код, сгенерированный брелком.
  3. Сохраните внесенные изменения.

После чего подключение будет завершено, а форма на вкладке Двухэтапная авторизация примет следующий вид:

Описание возможных действий
  • Отключить - позволяет отключить двухэтапную авторизацию бессрочно или же на определенное количество дней.
  • Резервные коды - позволяет перейти к форме работы с резервными кодами.
  • Синхронизировать - позволяет перейти к форме синхронизации устройств.
  • Подключить новый брелок/телефон - позволяет произвести подключение нового устройства двухэтапной авторизации.

Резервные коды доступны, если на странице настроек двухэтапной авторизации отмечена соответствующая опция.

Внимание! Одновременно можно использовать лишь одно средство (мобильное приложение/аппаратное устройство) для двухэтапной авторизации. При подключении нового устройства авторизоваться с помощью старого будет уже невозможно.


Резервные коды
157 / 694

Резервные коды

Функционал резервных кодов используется для доступа на сайт в тех случаях, когда нет возможности использовать устройство двухэтапной авторизации. Например, при утере брелка или телефона с приложением.

Примечание: Доступность функционала резервных кодов зависит от настроек двухэтапной авторизации.

Администратор сайта может получить список резервных кодов с помощью ссылки Резервные коды на странице редактирования пользователя (Настройки > Пользователи > Список пользователей), вкладка Двухэтапная авторизация:

Действительны только коды, созданные последними.

Также, в случае, когда пользователь не может воспользоваться своим устройством для входа на сайт, можно просто на время отключить двухэтапную авторизацию для него.

Примечание: В публичной части сайта получение Резервных кодов пользователем можно сделать с помощью создания администратором сайта страницы и размещения на ней компонента Резервные коды OTP (bitrix:security.user.recovery.codes).


Синхронизация
158 / 694

Синхронизация

Синхронизация необходима для случаев, когда на устройстве генерации одноразовых паролей по счетчику была произведена генерация паролей несколько раз (например, случайно нажата кнопка на аппаратном устройстве), но не было выполнено ни одной удачной аутентификации. Тогда, в случае превышения числа нажатий значения, заданного в параметре Размер окна проверки паролей, произойдет нарушение синхронизации счетчика генерации, и пользователь не сможет выполнить вход на сайт.

В этом случае необходимо выполнить повторную синхронизацию пользователя с устройством – привести значение на сервере в соответствие значению, хранящемуся в устройстве. Для этого администратор системы или сам пользователь (при наличии соответствующих разрешений) должен сгенерировать два последовательных значения одноразовых паролей и ввести их в форму редактирования параметров пользователя.

Примечание: Чтобы избежать нарушений синхронизации, можно увеличить значение параметра Размер окна проверки паролей.

Количество действующих кодов авторизации по счетчику после предыдущей успешной авторизации ограничивается параметром Размер окна проверки паролей.

Количество действующих кодов авторизации по времени ограничивается временным интервалом 1 минута в обе стороны (по 2 кода, которые действительны 30 секунд).


Компоненты
159 / 694

Компоненты

В редакциях Стандарт и Малый бизнес есть модуль Проактивная защита, но нет модуля Социальная сеть, который выводит форму подключения пользователями двухэтапной авторизации. Администратор должен создать публичные страницы для размещения компонентов подключения и резервных кодов.

Примечание: Доступ к информации, выводимой компонентами в публичной части сайта, имеют только авторизованные пользователи.

Вывод страницы подключения двухфакторной авторизации с помощью компонента

Для вывода формы подключения нового устройства двухэтапной авторизации в публичной части используется компонент Подключение устройства OTP . Использование этого компонента удобно если пользователь захочет подключить свое устройство, но у него нет доступа в административный раздел.

Для вывода формы необходимо:
  • Создать страницу, на которой разместится инструкция по подключению;
  • С помощью визуального редактора добавить компонент Подключение устройства OTP;
  • Сделать удобную для пользователей ссылку на эту страницу;
  • Теперь на этой странице пользователи смогут подключить двухфакторную авторизацию, следуя инструкции.

Пример создания такой страницы

Рассмотрим пример добавления страницы подключения двухфакторной авторизации в Интернет магазине в личном кабинете пользователя:

  • Создадим новую страницу с названием Двухфакторная авторизация;
  • В визуальном редакторе добавим компонент Подключение устройства OTP:

    Нажмите на рисунок, чтобы увеличить

  • Добавим в меню личного кабинета пользователя пункт Двухфакторная авторизация со ссылкой на созданную страницу;
  • Теперь пользователь сможет подключить себе двухфакторную авторизацию:

    Нажмите на рисунок, чтобы увеличить

Для вывода формы управления резервными кодами в публичной части используется компонент Резервные коды OTP.

Дополнительно

  • Подключение пользователем двухэтапной авторизации
  • компонент Социальная сеть - пользовательская документация
  • компонент Подключение устройства OTP - пользовательская документация
  • компонент Резервные коды OTP - пользовательская документация


Стоп-лист
160 / 694

Стоп-лист

Модуль Проактивная защита имеет собственный Стоп-лист (Настройки > Проактивная защита > Стоп-лист), отличный от стоп-листа модуля Веб-аналитика.

На странице Стоп-лист представлена информация о правилах блокировки доступа определенных IP-адресов к Вашему сайту или некоторым его разделам.

Список заблокированных IP-адресов создается либо вручную, либо автоматически.

Автоматическое создание Стоп-листа

Правило добавления в Стоп-лист создается автоматически в следующих случаях:

  • при включении механизма защиты административной части сайта;
  • при срабатывании проактивного фильтра на вторжении (если в качестве активной реакции на вторжение выбрано Добавить IP-адрес атакующего в стоп-лист на <количество> минут).

Создание вручную Стоп-листа

Чтобы создать правило блокировки вручную (например, на основе анализа журнала вторжений), выполните следующее:

  1. Нажмите на кнопку Добавить, расположенную на контекстной панели страницы стоп-листа проактивной защиты. Откроется форма создания (редактирования) правила блокировки доступа к сайту:

    2. Создание правила блокировки доступа

  2. Заполните поля формы необходимым Вам образом.

    Вы можете заблокировать доступ как к административной, так и к публичной части сайта, указав при этом IP-адреса или диапазоны адресов, которые будут заблокированы. Вы можете заблокировать доступ не ко всему сайту, а только к некоторым его разделам и страницам, для этого необходимо задать маски путей, доступ к которым необходимо заблокировать. Исключения в правиле задаются как по IP-адресам, так и по маскам путей.

    Примечание: каждый IP-адрес или маска пути задается в отдельном поле, которое добавляется по кнопке Добавить.

    Диапазон IP-адресов указывается с помощью дефиса, например, 192.168.0.1-192.168.0.100.
  3. Сохраните внесенные данные.

В результате пользователю, для IP-адреса которого имеется правило блокировки доступа, при попытке зайти на сайт будет выдана ошибка HTTP 403 – доступ запрещен.

Документация по теме:

  • Стоп-лист
  • Создание и редактирование правила стоп-листа


Хосты/домены
161 / 694

Хосты/домены: ограничение доступа и перенаправление запросов

На странице Хосты/домены (Настройки > Проактивная защита > Хосты/домены) можно ограничить доступ или перенаправить на заданную страницу те запросы, у которых адрес в HTTP-заголовке Host не будет соответствовать разрешенным адресам.

Данный режим позволяет предотвратить подмену HTTP-заголовка Host и, соответственно, $_SERVER["HTTP_HOST"].

Доступны следующие настройки:

  • Ограничивать - включение режима ограничения для "не правильных" запросов;
  • Логировать - запись в журнал информации о запросах, которые имеют не соответствующие заголовки;
  • Активная реакция - выбор режима ответной реакции на запросы с несоответствующими заголовками:
    • Запрещать доступ - доступ к сайту будет ограничен;
    • Перенаправлять - будет произведено перенаправление на страницу, указанную ниже.
  • Адрес перенаправления - указывается страница, на которую будет производиться перенаправление;
  • Список разрешенных хостов/доменов - Указываются разрешенные хосты, с которыми будет производиться сравнение заголовков Host.

    Примечание: Допускается запись хостов через пробел и с новой строки.
    Возможно использование символа *, например: *.site.com.

    При использовании многосайтовости на разных доменах в этом списке обязательно должен быть указан домен второго сайта во избежание 403 ошибки.

Документация по теме:

  • Хосты/домены


Защита от DDoS
162 / 694

Защита от DDoS

DDoS (или DDos-атака) - (от англ. Denial of Service — отказ в обслуживании) атака злоумышленниками на вычислительную систему с целью доведения ее до отказа, вследствие которого доступ легальных пользователей системы к ее ресурсам будет затруднен или запрещен.

Примечание: Защита от DDoS недоступна в ограниченной лицензии .

Защита от DDoS предоставляется компанией 1С-Битрикс совместно с компанией Qrator. Для того, чтобы поставить сайт под защиту необходимо заполнить форму на странице Настройки > Защита от DDoS. После того, как форма будет заполнена, заявка на защиту от DDoS будет направлена в компанию Qrator, а на указанный в форме E-mail будет прислано письмо с дальнейшими указаниями по настройке.

Бесплатная защита в течение 10 дней на протяжении года предоставляется при активной лицензии "1С-Битрикс:Управление сайтом". Причем предоставляемые 10 дней включают в себя и процедуру подключения, и непосредственно саму защиту. При продлении лицензии будут предоставлены новые 10 дней.

Внимание! Предоставляемые 10 дней включают в себя непрерывную защиту, приостановить действие которой будет нельзя.

Примечание: если под управлением системы находятся сразу несколько сайтов, то можно поставить под защиту один из сайтов отдельно. Однако этого делать крайне не рекомендуется, потому что в таком случае велика вероятность обхода защиты. Поэтому лучше ставить под защиту систему целиком.


Проверьте себя
163 / 694

Ответьте на несколько вопросов по теме Безопасность сайта, которые помогут вам самим оценить свои знания. Это не тест, это просто проверка того, как вы поняли тему. Удачи!

Верно ли утверждение?

Оцените верность утверждения: Верно или Неверно. А потом в спойлере проверьте ваш выбор.

1 Для защиты от атак, основанных на прослушивании сетевого соединения, нужно перевести сайт на работу по протоколу https.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
2 Первым шагом при переходе на HTTPS является установка SSL-сертификата.
Верно
Увы, вы ошиблись. Перед переходим на HTTPS необходимо подготовить сайт, изменив все ссылки с абсолютных на относительные. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
3 Журнал изменений более подходит для мониторинга изменений контента, а Журнал событий - для мониторинга изменений настройки системы.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
4 Для каждой группы пользователей можно настроить свои параметры безопасности.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Параметры безопасности можно настроить с учётом специфики работы различных групп пользователей. Советуем почитать тему ещё раз.
5 Единственный способ борьбы с автоматической регистрацией ботов - CAPTCHA.
Верно
Увы, вы ошиблись. Есть много способов борьбы с автоматической регистрацией (использование CAPTCHA - только один из способов). Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
6 Один администратор сайта не может закрыть доступ другому администратору.
Верно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
7 Проактивная защита является существенным дополнением к стандартной политике безопасности продукта. Поэтому одноименный модуль включен во все редакции продукта «1С-Битрикс: Управления сайтом» (кроме Старта).
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
8 Чтобы настроить защиту на Повышенном уровне, достаточно настроить стандартный уровень защиты, а затем настроить параметры повышенного уровня.
Верно
Увы, вы ошиблись. Для уровней защиты справедливо понятие "вложенности": чтобы настроить Повышенный уровень, нужно настроить сначала стандартный уровень защиты, потом высокий уровень, а уже в финале - параметры повышенного уровня. Советуем почитать тему ещё раз.
Неверно
Аплодисменты, вы ответили правильно!
9 Инструмент Сканер безопасности позволяет провести не только локальное сканирование, но и внешнее.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
10 При включенном механизме двухэтапной авторизации можно использовать либо специальное аппаратное устройство генерации кодов, либо мобильное приложение Bitrix OTP.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
11 Если пользователь потерял устройство двухэтапной авторизации, то администратор сайта может либо выдать пользователю Резервные коды, либо временно отключить двухэтапную авторизацию конкретно для этого пользователя.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Советуем почитать тему ещё раз.
12 В модуле Проактивная защита можно автоматически или вручную создать правило блокировки определенных IP-адресов.
Верно
Аплодисменты, вы ответили правильно!
Неверно
Увы, вы ошиблись. Это можно сделать на странице Стоп-лист. Советуем почитать тему ещё раз.


Практические задания
164 / 694

После изучения главы рекомендуем выполнить несколько практических заданий. Их можно выполнять на:

  1. тестовой лаборатории, предоставленной компанией 1С-Битрикс
    2. либо
  2. на установленной на локальный компьютер пробной версии 1С-Битрикс: Управление сайтом

Первый вариант проще: Виртуальная лаборатория предполагает установку системы в упрощённом, в отличие от локальной версии 1С-Битрикс: Управление сайтом, варианте. При такой установке для получения идентичного изображения у пользователя и на скриншотах заданий выберите на шаге Решение для установки: Интернет-магазин . На остальных шагах менять установки по умолчанию не нужно.

Минус первого варианта в том, что сайт на виртуальной лаборатории "живёт" только 3 часа. Но для выполнения практических заданий в рамках главы этого вполне достаточно. После изучения следующей главы можно заново создать сайт.

Примечания:
  1. Настоятельно рекомендуем НЕ выполнять задания на работающем, "боевом" сайте.
  2. Если вы всё же пытаетесь выполнять задания на работающем сайте, где вы не являетесь администратором, то не все задания можно выполнить.

Практические задания состоят из вопроса, скриншота или видео с конечным результатом и объяснением как это получить в спойлере. Не торопитесь подглядывать в спойлер.

Практические задания

  1. Включите Проактивную защиту и настройте Проактивный фильтр согласно следующим требованиям:
    • опасные данные должны быть модифицированы;
    • IP-адрес атакующего необходимо занести в стоп-лист на 4 часа, а попытку вторжения - в журнал;
    • для группы Администраторов интернет-магазина нужно сделать исключение (обход фильтра).

    Решение
    Задание составлено по материалам уроков:
    • Стандартный уровень
    • Стоп-лист

    Результат:

    Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

  2. Включите Защиту административного раздела (не забудьте добавьте в исключения свой IP-адрес).

    Решение
    Задание составлено по материалам уроков:
    • Высокий уровень

    Результат:

    Нажмите на рисунок, чтобы увеличить

    Внимание: Помните, что перед включением защиты административной части необходимо внести в список IP-адреса и диапазоны, с которых разрешен доступ к административной части свой IP-адрес и дополнительные адреса (или диапазоны), с которых разрешен доступ.

  3. Включите механизм двухэтапной авторизации и настройте её согласно следующим требованиям:
    • алгоритм генерации паролей - по времени;
    • запрещено запоминание одноразового пароля;
    • разрешено использование резервных кодов;
    • двухэтапная авторизация обязательна для группы контент-редакторов сайта;

    Решение
    Задание составлено по материалам уроков:
    • Повышенный уровень
    • Включение и общие настройки механизма двухэтапной авторизации

    Результат:
    1. Включаем механизм двухэтапной авторизации (Настройки > Проактивная защита > Двухэтапная авторизация):

    2. На вкладке Параметры указываем нужные настройки:

  4. * После настройки механизма двухэтапной авторизации настройте свою учётную запись, скачав мобильное приложение для генерации кодов (например, бесплатное приложение BitrixOTP)

    Решение
    Задание составлено по материалам уроков:
    • Мобильное приложение

    Результат:
    1. Подключим телефон на странице редактирования своего профиля (Настройки > Пользователи > Список пользователей), вкладка Двухэтапная авторизация:

    2. В открывшейся форме продолжаем подключение согласно инструкции: скачаем и настроим приложение (например, считав QR-код), введём код подтверждения:


Управление интерфейсом
165 / 694

Администратор сайта работает со всем богатым функционалом продукта "1С-Битрикс: Управление сайтом" из Административного раздела . Мы постарались сделать интерфейс административного раздела удобным, понятным, логичным. А кроме того, у вас есть возможность настроить и сам интерфейс так, как удобно вам. В этой главе мы расскажем о способах настройки административного интерфейса, поддержки работы с многоязычным интерфейсом в административном разделе, а также о создании проектов на различных языках.

Внимание! Перед клиентами коробочной версии Битрикс24 часто возникает задача переключения языка меню, без дублирования контента. Штатно это реализовать нельзя, нужна доработка как настроек портала, так и файлов меню.


Пользовательские настройки
166 / 694

Настройка под себя

Bitrix Framework позволяет настраивать и запоминать настройки интерфейса для каждого зарегистрированного пользователя, имеющего доступ в административный раздел.

Примечание: Дополнительную информацию по настройке интерфейса форм смотрите в следующих уроках:
  • Настройка формы редактирования элемента
  • Настройка формы отчета (Списки элементов)
  • Настройки форм инфоблоков

На многих страницах административного раздела на контекстной панели расположена кнопка Настроить [image]. При нажатии на неё вызывается диалог Настройка списка:

Система сохранит произведенные настройки для конкретного пользователя. Каждый раз этот список для этого пользователя будет открываться в заданном виде. Пользователь может настроить каждый из списков в административной части "под себя".


Административные настройки
167 / 694

Как задать Административные (то есть общие для всех) настройки интерфейса системы.


Административные настройки
168 / 694

Административный уровень настроек по умолчанию задается:

  • в общем случае на странице Настройка интерфейса пользователя (Настройки > Настройки продукта > Интерфейс > Персональные настройки);
  • в частном случае для каждой формы в диалоге Настройка списка каждой конкретной формы.

В свою очередь административные настройки имеют два уровня:

  • первый уровень - тот, который идёт с поставкой системы (системный уровень настроек по умолчанию);
  • второй уровень - тот, который может задать администратор (административный уровень настроек по умолчанию).

Административные настройки по умолчанию для каждой формы выполняются таким же образом, как и пользовательская настройка, но с установкой флажка Установить данные настройки по умолчанию для всех пользователей.

Для задания общего административного уровня настроек по умолчанию откройте страницу Настройка интерфейса пользователя (Настройки > Настройки продукта > Интерфейс > Персональные настройки):

Описание закладки Настройки

Закладка Настройки позволяет задать настройки интерфейса пользователя, используя следующие разделы:

  • Раздел Персональные настройки позволяет:
    • разрешить/запретить контекстное меню в списках (таблицах отчетов);
    • задать способ отображения контекстного меню: по клику Правой кнопки мыши или по клику Правой кнопки мыши + клавиша Ctrl.
    • Включить или выключить автосохранение форм.
  • Раздел Панель инструментов позволяет настроить внешний вид Панели инструментов.
  • Раздел Меню "Пуск" позволяет:
    • разрешить/запретить предварительную подгрузку пунктов меню в фоновом режиме;
    • разрешить/запретить отображение всплывающих подсказок при наведении указателя мыши на пункты меню;
    • определить количество часто используемых ссылок, которое будет выведено в Меню под Избранным:

  • Раздел Звуки позволяет разрешить/запретить проигрывание звуков и указать звук, который будет проигрываться при начале работы системы.
  • В разделе Сообщения можно указать, какие сообщения будут выводиться: о сроке окончания техподдержки, о состоянии модулей Проактивная защита и Монитор производительности.
  • Раздел Общие настройки позволяет назначить указанные настройки, которые будут использоваться как настройки по умолчанию для всех зарегистрированных пользователей, имеющих доступ в административный раздел.

Ссылки на закладке Удаление позволяют:

  • Очистить все собственные настройки интерфейса - удалить все настройки, установленные со снятой опцией Установить данные настройки по умолчанию для всех пользователей и установить заново все настройки административного уровня "по умолчанию";
  • Очистить все настройки по умолчанию - установить все настройки на системном уровне по умолчанию;
  • Очистить персональные настройки всех пользователей - установить все настройки на административном уровне по умолчанию.


Горячие клавиши
169 / 694

Работу в "1С-Битрикс: Управление сайтом" можно сделать более эффективной и быстрой, если пользоваться не только мышью, но и применять «горячие клавиши» - специальные комбинации клавиш, призванные упростить и ускорить работу. Зачастую это гораздо удобнее.

Как создать и изменить горячие клавиши в публичном разделе рассказывается в отдельном уроке. Управление горячими клавишами в административном разделе производится на странице Настройки > Настройки продукта > Интерфейс > Горячие клавиши.

Чтобы добавить своё действие, нажмите кнопку Добавить на контекстной панели. После этого заполните форму создания для горячих клавиш:

Необходимо заполнить как минимум два поля:

  • Наименование - выводится у пользователей в окне настроек горячих клавиш;
  • Выполняемый JavaScript код - код, вызывающий нужное действие.

Примечание: Описание других полей смотрите в документации .

Пустое поле Адрес (URL), где будет работать означает, что действие для привязки к горячим клавишам будет доступно везде, где есть административная панель. Если необходимо, чтобы действие выполнялось на какой-то конкретной странице, или в конкретном разделе, то их нужно указать в данном поле, например:

http://127.0.0.1:84/bitrix/admin/hot_keys_list.php или /bitrix/admin/.

По умолчанию горячие клавиши можно назначать на действия, выполняемые через основные кнопки публичной части Эрмитажа и Административной панели.

Примечание: Допускается назначение одинакового комплекта горячих клавиш на действия на разных страницах.

Пример

Можно назначить по горячей клавише переход в наиболее часто используемый раздел. Код JavaScript для открытия страницы Настройки > Настройки продукта > Интерфейс > Горячие клавиши Административного раздела будет выглядеть так:

location.href='/bitrix/admin/hot_keys_list.php';

Документация по теме:

  • Горячие клавиши
  • Создание и редактирование горячих клавиш


Поведение мыши по умолчанию
170 / 694

Клавишами мыши в административном интерфейсе можно выполнить:
  • левый клик на кнопке меню действий или правый клик на строке таблицы отчета - вывод меню действий:

    или

  • Ctrl + правая кнопка - выводит стандартное меню браузера:

  • двойной клик на строке таблицы отчета - открывает сущность, отображаемую в строке, для редактирования;
  • Shift + двойной клик на строке таблицы отчета - открывает сущность для редактирования в новом окне.


Добавление пункта меню в административный раздел
171 / 694

Нужен пункт меню в админке

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Есть два варианта:

1) Дополнительные пункты меню могут быть созданы через раздел управления Избранное (Настройки > Избранное). В этом разделе кликните по кнопке Добавить и укажите название пунктов меню и ссылки на нужные страницы:

Добавленные страницы появятся как отдельные пункты меню в разделе Избранное в публичной части сайта:

2) Пользователь может настраивать административное меню так же, как и меню в публичном разделе. Т.е. для каждого модуля к стандартным пунктам меню можно добавить свои пункты и целые разделы. Для этого:

  • Через интерфейс управления структурой сайта перейти в папку /bitrix/admin/ (Контент > Структура сайта > Файлы и папки > bitrix > admin).
  • С помощью меню Добавить создайте меню типа [left] Левое меню.
  • При редактировании меню ввести название раздела и необходимые пункты меню:

  • Создание раздела меню

    Для создания раздела меню нужно перейти в расширенный режим , ввести название пункта (например, Мои Отчеты) и в секции Параметры ввести новые параметры, например:

    SEPARATOR = Y // указывает, что этот пункт должен быть оформлен как раздел;

SECTION_ID = MyReports // определяет символьный код своего раздела меню, например "my_menu"

SORT = 200000 // это глобальный индекс сортировки для показа данного пункта в общем меню;

    Нажмите на рисунок, чтобы увеличить

    Пример:

    Для редактирования кода элемента меню используется кнопка Редактировать как файл на контекстной панели

    <?
// добавим свой раздел меню "МоиОтчеты"
$aMenuLinks = Array(
    Array(
        "МоиОтчеты",
        "",
        Array(),
        Array(
          "SECTION_ID"=>"MyReports",
          "SEPARATOR" => "Y",
          "SORT" => 200000
        ),
        ""
    )
);
?>

    В результате новый раздел добавится в меню .

    •

  • Создание пункта меню

    Для создания обычного пункта меню нужно задать его название, ссылку, а также указать в поле Параметры мнемоническое имя того раздела меню, где будет показан пункт. Например, вставим свой пункт Импорт техники в раздел Инфоблоки:

    Если надо вставить пункт в свой подраздел, поле SECTION_ID не указывается.

    Сортировка пунктов внутри подраздела будет выполняться в соответствии со значениями индекса сортировки для каждого пункта.

    Пример:

    Для редактирования кода элемента меню используется кнопка Редактировать как файл на контекстной панели

    <?
// добавим свой пункт меню "Импорт техники" в раздел "Информ. блоки" (iblock)
$aMenuLinks = Array(
    Array(
        "Импорт техники",
        "/bitrix/admin/equipment_import.php?lang=ru",
        Array(),
        Array(
            "ALT" => "Импорт техники из dbf файлов",
            "SECTION_ID" => "iblock",
            "SORT" => "100"
        )
    )
);
?>

    В результате новый раздел добавится в меню .

Примечание: Подробную информацию про меню можно посмотреть на странице документации для разработчиков Административное меню.


Языки интерфейса
172 / 694

Bitrix Framework поддерживает работу с многоязычным интерфейсом в административном разделе сайта. В административной части это позволяет выводить служебные сообщения (например, сообщения об ошибках), отображать сообщения форм и таблиц на различных языках.

Примечание: Русский, английский и немецкие языки не ставятся через систему обновлений. Для использования их в административной части необходимо установить соответствующие дистрибутивы.

Система помощи также отображается в зависимости от текущего языка административного раздела. Таким образом, при нажатии на кнопку Помощь административной панели будет открыта соответствующая страница онлайн документации . В настоящее время система помощи поставляется на русском и английском языках.

Языки административного интерфейса также используются для определения, на каком языке будут выводиться текстовые сообщения визуальных компонентов , а также служебные сообщения системы в публичном разделе каждого сайта. То есть для определения основного языка сайта.

Язык указывается для каждого сайта на странице настроек (Настройки > Настройки продукта > Сайты > Список сайтов):

Как реализуется многоязычный интерфейс административного раздела?

Для каждого модуля системы создается набор специальных языковых файлов. Они хранятся в папках с названиями соответствующих языков. В файлах содержатся переводы фраз, используемых в интерфейсе, на эти языки.

Нажмите на рисунок, чтобы увеличить

По умолчанию в системе используются русский и английский языки. Выбор текущего языка административного раздела сайта осуществляется на административной панели.

Важно! Количество языков, используемых в системе, не зависит от количества сайтов, работающих под управлением системы.

Список языков интерфейса, доступных для штатной установки в продуктах «1С-Битрикс: Управление сайтом» и коробочной версии «Битрикс24»:

  • украинский
  • испанский (Латинская Америка)
  • португальский (Бразилия)
  • французский (Канада)
  • польский
  • литовский


Управление языками
173 / 694

Языки

Управление языками интерфейса системы выполняется на странице Языки интерфейса (Настройки > Настройки продукта > Языковые параметры > Языки интерфейса). В списке отображены языки, доступные для выбора в качестве языка административного интерфейса. На выбранном языке будут отображаться системные сообщения: информационные сообщения, сообщения об ошибках, заголовки таблиц, надписи на кнопках управления и т.д.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Пример добавления языка в систему

Рассмотрим добавление в систему нового языка на примере испанского (для Латинской Америки). Для этого:

  1. Создадим учетную запись языка (кнопка Добавить язык на контекстной панели страницы Языки интерфейса).

    Значения полей ясны из названий, если возникло непонимание, обратитесь к пользовательской документации . Одно обязательное пояснение:

    ID - символьный идентификатор языка используется для загрузки соответствующих языковых файлов, поэтому он должен совпадать с идентификатором языка в системе обновлений. Например, языковые файлы для испанского (для Латинской Америки) языка доступны на сервере обновлений с идентификатором la. Поэтому при создании испанского языка используйте в поле ID – la.

    Список идентификаторов языков
    Язык& | Идентификатор | Кодировка
    Russian | ru | iso-8859-5, windows-1251, koi8-r
    English | en | iso-8859-1, windows-1252
    Afrikaans | af | iso-8859-1, windows-1252
    Albanian | sq | iso-8859-1, windows-1250
    Arabic | ar | iso-8859-6, windows-1256
    Basque | eu | iso-8859-1, windows-1252
    Bulgarian | bg | iso-8859-5, windows-1251
    Belorussian | be | iso-8859-5, windows-1251
    Catalan | ca | iso-8859-15, windows-1252
    Croatian | hr | iso-8859-2, windows-1250
    Czech | cs | iso-8859-2, windows-1250
    Danish | da | iso-8859-1, windows-1252
    Dutch | nl | iso-8859-1, windows-1252
    Esperanto | eo | iso-8859-3
    Estonian | et | iso-8859-15, windows-1257
    Faroese | fo | iso-8859-1, windows-1252
    Finnish | fi | iso-8859-1, windows-1252
    French | fr | iso-8859-1, windows-1252
    Galician | gl | iso-8859-1, windows-1252
    German | de | iso-8859-1, windows-1252
    Greek | el | iso-8859-7
    Hebrew | iw | iso-8859-8
    Hungarian | hu | iso-8859-2, windows-1250
    Icelandic | is | iso-8859-1, windows-1252
    Irish | ga | iso-8859-1, windows-1252
    Italian | it | iso-8859-1, windows-1252
    Japanese | ja | shift_jis, iso-2022-jp, euc-jp
    Korean | ko | euc-kr
    Latvian | lv | iso-8859-13, windows-1257
    Lithuanian | lt | iso-8859-13, windows-1257
    Macedonian | mk | iso-8859-5, windows-1251
    Maltese | mt | iso-8859-3
    Norwegian | no | iso-8859-1, windows-1252
    Polish | pl | iso-8859-2, windows-1250
    Portuguese | pt | iso-8859-1, windows-1252
    Portuguese (бразильский) | br | iso-8859-1, windows-1252
    Romanian | ro | iso-8859-2, windows-1250
    Scottish | gd | iso-8859-1, windows-1252
    Serbian cyrillic | sr | iso-8859-5, windows-1251
    Serbian latin | sr | iso-8859-2, windows-1250
    Slovak | sk | iso-8859-2, windows-1250
    Slovenian | sl | iso-8859-2, windows-1250
    Spanish | la | iso-8859-1, windows-1252
    Swedish | sv | iso-8859-1, windows-1252
    Turkish | tr | iso-8859-9, windows-1254
    Ukrainian | ua | windows-1251, koi8-u

  2. После сохранения запись нового языка будет добавлена в общий список на странице Языки интерфейса .
  3. Также в кнопке для переключения языков на административной панели появится выбор добавленного языка:

  4. Далее выполните загрузку языковых файлов для созданного языка.

Список языков интерфейса, доступных для штатной установки в продуктах «1С-Битрикс: Управление сайтом» и коробочной версии «Битрикс24»:

  • украинский
  • испанский (Латинская Америка)
  • португальский (Бразилия)
  • французский (Канада)
  • польский
  • литовский

Документация по теме:

  • Языки интерфейса


Региональные настройки
174 / 694

У каждой страны свои предпочтения

Региональная настройка - набор параметров, которые имеют разные значения в зависимости от культурных особенностей той или иной местности. Например: формат даты и времени, формат имени, первый день недели и другие.

Создание региональных настроек выполняется на странице Региональные настройки (Настройки > Настройки продукта > Языковые параметры > Региональные настройки).

При добавлении/редактировании региональных настроек видим две закладки:

  1. Параметры - здесь задаем основные настройки

    2. Нажмите на рисунок, чтобы увеличить

  2. Форматы вывода - расширенные форматы региональных настроек. Позволяют настроить отображение различных типов даты и времени, а также формат вывода чисел.

Значения полей описаны в документации . После создания региональной настройки её используют при создании языка интерфейса и при создании сайта .

Информация о форматах даты и таблиц кодов, используемых для представления символов языка в публичном разделе сайта, приводится в документации продукта. В полях Формат даты и Формат даты и времени укажите системе, как отображать эти параметры.

Внимание! Установка Формата даты и Формата даты и времени должна соответствовать параметрам даты и времени, используемым в настройке компонентов и при кастомизации. При несовпадении форматов данные будут отображаться с ошибками.

Кодировка языка также определяет кодировку вводимого контента (содержимого) модулей. Например, для русского языка используется кодировка Windows-1251 .

Примечание: Если в системе используется кодировка UTF-8, то используемые в системе языки также представляются в кодировке UTF-8.


Загрузка языковых файлов
175 / 694

Многоязычный интерфейс административного раздела реализуется за счет использования языковых файлов. Загрузка и обновление языковых файлов для новых и/или уже используемых в системе языков выполняется через Систему обновлений (Marketplace > Обновления платформы):

При переходе на закладку Список обновлений будет отображено:

  • список обновлений языковых файлов для уже используемых языков (секция Рекомендуемые обновления таблицы);
  • список языковых файлов для неустановленных в системе языков (секция Опциональные обновления таблицы). Данные языковые файлы также могут быть загружены и сохранены в системе. При создании учетных записей для соответствующих языков эти файлы будут установлены автоматически.

Для выполнения загрузки следует отметить требуемые языковые файлы с помощью флажков и нажать кнопку Установить обновления.

Пример загрузки языковых файлов

Рассмотрим загрузку языковых файлов для, например, испанского языка. Для этого:

  1. Создайте в системе испанский язык.
  2. Перейдите на страницу Система обновлений (Marketplace > Обновления платформы).
  3. На закладке Список обновлений открывшейся странице отметьте языковые файлы для испанского языка, которые будут загружены в систему:

    Нажмите на рисунок, чтобы увеличить

  4. Для загрузки выбранных файлов служит кнопка Установить обновления.


Управление языковыми сообщениями
176 / 694

Чтобы многоязычный интерфейс работал правильно, нужно где-то хранить весь текст, который используется в административном разделе. Он хранится в виде отдельных текстовых сообщений в языковых файлах соответствующих языков. Языковые файлы размещаются в папках тех модулей и шаблонов, для которых используются эти текстовые сообщения.

Модуль Перевод предоставляет удобный интерфейс для поиска и перевода языковых сообщений.


Mодуль Перевод
177 / 694

Правим файлы для многоязычного интерфейса

Чтобы многоязычный интерфейс работал правильно, требуется где-то хранить весь текст, который используется в административном разделе. Он хранится в виде отдельных текстовых сообщений в языковых файлах соответствующих языков. Языковые файлы размещаются в папках тех модулей и шаблонов, для которых используются эти текстовые сообщения.

Перевод языковых файлов возможен:

  • вручную, путем редактирования соответствующих файлов;
  • с помощью модуля Перевод.

Модуль Перевод предоставляет удобный интерфейс для поиска и перевода языковых сообщений и позволяет:

  • просмотреть распределение языковых фраз по файлам системы;
  • определить количество непереведенных фраз для каждого файла;
  • перейти к переводу необходимых текстовых сообщений;

Примечание: с версии 19.0.0 модуля translate доступен функционал:
  • Подсчёт недостающих и лишних фраз и языковых файлов;
  • Поиск фраз по уже существующим переводам;
  • Экспорт в CSV как полного списка фраз, так и результата поиска.

Настройки модуля

Настройки модуля выполняются на странице Настройки > Настройки продукта > Настройки модулей > Перевод :

Нажмите на рисунок, чтобы увеличить

Описание всех настроек приводится в документации.

Удаление модуля

В случае необходимости удаления модуля это можно сделать на странице Настройки > Настройки продукта > Модули. При этом можно сохранить данные модуля (например, настройки, индекс, примеры фраз с полным переводом) в таблицах базы данных:

Дополнительно

  • Настройки модуля Перевод;
  • Языковые файлы в курсе Разработчик Bitrix Framework.


Поиск языковых файлов
178 / 694

Индексация

Все языковые сообщения распределены по разным файлам. Чтобы поиск этих сообщений работал корректно, необходимо выполнить индексацию фраз. Кроме того, индексация позволяет подсчитать число фраз без перевода, найти лишние, найти примеры фраз с полным переводом или с неправильным переводом.

Индексация выполняется по кнопке Индексировать:

Выполнение этой операции может занять продолжительное время. Чтобы сократить это время, можно выбрать только нужные языки .

Как найти языковые файлы

Для просмотра распределения языковых сообщений по файлам перейдите на страницу Перевод языковых файлов (Настройки > Локализация > Просмотр файлов):

Нажмите на рисунок, чтобы увеличить

Для поиска конкретных фраз или каталогов используйте фильтр + поиск .

А с помощью кнопки со списком действий укажите режим отображения: показывать общее количество фраз/языковых файлов или только без перевода.

Цифры синего и красного цвета показывают разницу в количестве языковых фраз от текущего языка интерфейса:

  • красный цвет - фраз перевода меньше, чем на текущем языке;
  • синий цвет - фраз перевода больше , чем на текущем языке.

Поиск файлов для перевода на конкретной странице

Для поиска файлов перевода на конкретной странице воспользуйтесь удобным инструментом, который позволяет перейти к форме выполнения перевода языковых сообщений непосредственно со страницы, на которой эти сообщения используются (как в публичной, так и административной части сайта).

Для этого требуется включить в настройках модуля Перевод функцию Добавить на панель инструментов кнопку "Выводить языковые файлы". Тогда на панели инструментов станет доступна кнопка Перевод .

Второй способ включения
Второй вариант - добавить в адресную строку браузера параметр show_lang_files=Y. Результат аналогичен нажатию кнопки Выводить языковые файлы, т.е. файлы отобразятся на всех страницах.

Для выключения функции измените параметр в адресной строке на show_lang_files=N.

При включенном выводе языковых файлов в низу страниц Вы увидите список в виде ссылок. При нажатии на ссылку открывается страница редактирования языковых сообщений в выбранном файле.

Нажмите на рисунок, чтобы увеличить

Также внизу списка отображается поле, позволяющее выполнять поиск языковых фраз в файлах по точному совпадению.

Пример поиска фраз по совпадению

Например: найдем языковое сообщение Ваша корзина пуста, используемое на странице просмотра корзины пользователем. Для этого введем в поле для поиска Корзина и нажмем кнопку OK. В результате получим список файлов, содержащих эту фразу. Ссылка с текстом фразы позволяет перейти непосредственно к редактированию текста сообщения.

Нажмите на рисунок, чтобы увеличить

Дополнительно

  • Просмотр файлов;
  • Языковые файлы в курсе Разработчик Bitrix Framework.


Перевод фраз
179 / 694

Перевод фразы

Откройте файл для редактирования языковых фраз одним из следующих способов:

  • Откройте файл по его полному пути: через поиск или перейдя по папкам каталога;
  • В общем списке файлов выберите действие Показать ссылки на файлы без переводов при помощи кнопки выбора действий. Тогда в списке отобразятся ссылки на файлы , по которым доступен переход.
  • Из списка языковых файлов на странице .

В файле отображаются языковые сообщения . Найдите фразу и введите перевод сообщения для нужного языка:

Удаление фраз

Для удаления сообщений доступны варианты:

Нажмите на рисунок, чтобы увеличить

  • Удалить - отметьте вручную, какие фразы следует удалить;
  • Удалить все сообщения - отмечает все языковые фразы для удаления;
  • Удалить сообщения, перевод которых отсутствует для текущего языка - будут отмечены только те фразы, у которых отсутствует перевод для текущего языка.

Отмеченные фразы удалятся после нажатия кнопки Сохранить.

Дополнительно

  • Перевод сообщений;
  • Языковые файлы в курсе Разработчик Bitrix Framework.


Импорт и экспорт
180 / 694

Импорт и экспорт языковых файлов

Частый случай - необходимость перевода большого количества фраз на какой-либо язык. Модуль Перевод позволяет легко выгружать и загружать языковые файлы в формате CSV.

Выполняйте выгрузку как всех файлов, так и отдельных. А также всех фраз или только без перевода.

Экспорт

Экспорт файла выполняется на странице Перевод языковых файлов (Настройки > Локализация > Просмотр файлов) с помощью кнопки Выгрузить сообщения в CSV .

Откроется форма настройки:

Для выгрузки языковых сообщений из конкретных папок или файлов требуется указать пути к ним в поле Выгрузить сообщения только для файлов и папок.

Второй способ экспорта конкретных папок или файлов - из списка. Отметьте их в списке и на панели действий выберите действие Экспортировать выделенные .

Функция экспорта языковых сообщений также доступна в форме просмотра конкретного файла.

Примечание: с версии 19.0.0 модуля translate доступна возможность экспорта в CSV как полного списка фраз, так и результата поиска .

Импорт

В экспортированный файл CSV внесите необходимые переводы для языковых фраз. После переходите к импорту нажатием кнопки Импортировать сообщения из CSV на странице просмотра файлов.

В открывшейся форме выберите файл для загрузки, кодировку и каким образом добавлять фразы.

По окончании импорта, в языковых файлах отобразятся изменения в соответствии с содержимым файла и настройками импорта.

Полная локализация

Сбор всех языковых файлов локализации выполняется на странице Выгрузка и загрузка (Настройки > Локализация > Выгрузка и загрузка):

  1. На вкладке Сбор переводов выполняется экспорт для выбранного языка. Рекомендуется выполнять выгрузку в формате архива .tar.gz;
  2. На вкладке Загрузка переводов выполните загрузку файла локализации . Предварительно создайте язык , для которого хотите загрузить локализацию, если его нет в списке.

Примечание: Подробнее о реализации механизма локализации, загрузке и выгрузке файлов локализации см. курс Разработчик Bitrix Framework .

Дополнительно

  • Документация:
    • Просмотр файлов;
    • Перевод сообщений;
    • Выгрузка и загрузка;
  • Загрузка и выгрузка локализации в курсе Разработчик Bitrix Framework.


Настройка вида страницы ошибки 404
181 / 694

Если страницы не существует

При запросе пользователем страницы, отсутствующей на сервере, последний автоматически генерирует страницу с надписью, подобной этой:

Нажмите на рисунок, чтобы увеличить

Причин появления такой страницы может быть несколько:

  • некорректная ссылка на сайте;
  • неправильно введенный пользователем адрес;
  • документ, на который ведет ссылка, был удален.

Можно сделать так, чтобы в таких случаях пользователь видел не техническую страницу, а заранее вами заготовленную. Для этого в корневом разделе сайта (Контент > Структура сайта > Файлы и папки) найдите файл 404.php . В меню действий файла выберите Редактировать как php.

Содержимое файла 404.php
В штатной установке 1С-Битрикс: Управление сайтом файл 404.php содержит следующий код:

<?
// подключение файла обработки адресов urlrewrite.php
include_once($_SERVER['DOCUMENT_ROOT'].'/bitrix/modules/main/include/urlrewrite.php');

// установка HTTP статуса 404
CHTTP::SetStatus("404 Not Found");
@define("ERROR_404","Y");
// скрывает боковую панель на странице
define("HIDE_SIDEBAR", true);

// подключение header.php
require($_SERVER["DOCUMENT_ROOT"]."/bitrix/header.php");

// установка заголовка страницы
$APPLICATION->SetTitle("Страница не найдена");?>

<! -- начало содержимого страницы 404.php -->
    <div class="bx-404-container">
        <div class="bx-404-block"><img src="<?=SITE_DIR?>images/404.png" alt=""></div>
        <div class="bx-404-text-block">Неправильно набран адрес, <br>или такой страницы на сайте больше не существует.</div>
        <div class="">Вернитесь на <a href="<?=SITE_DIR?>">главную</a> или воспользуйтесь картой сайта.</div>
    </div>
    <div class="map-columns row">
        <div class="col-sm-10 col-sm-offset-1">
            <div class="bx-maps-title">Карта сайта:</div>
        </div>
    </div>

    <div class="col-sm-offset-2 col-sm-4">
        <div class="bx-map-title"><i class="fa fa-leanpub"></i> Каталог</div>

    </div>

    <div class="col-sm-offset-1 col-sm-4">
        <div class="bx-map-title"><i class="fa fa-info-circle"></i> О магазине</div>
        // подключение компонента Карта сайта
        <?
        $APPLICATION->IncludeComponent(
            "bitrix:main.map",
            ".default",
            array(
                "CACHE_TYPE" => "A",
                "CACHE_TIME" => "36000000",
                "SET_TITLE" => "N",
                "LEVEL" => "3",
                "COL_NUM" => "2",
                "SHOW_DESCRIPTION" => "Y",
                "COMPONENT_TEMPLATE" => ".default"
            ),
            false
        );?>
    </div>
<! -- окончание содержимого страницы 404.php -->

<! --  подключение файла footer.php -->
<?require($_SERVER["DOCUMENT_ROOT"]."/bitrix/footer.php");?>

Внесите необходимые изменения в его содержимое и сохраните их. После этого при возникновении ошибки 404 отобразится созданная вами страница (в примере ниже удалён компонент Карта сайта, добавлен текст и настроен размер и цвет шрифта):

Частые вопросы
При настройке отображения 404 страницы возникают следующие вопросы:
  1. Вопрос: На сайте создан инфоблок и информация в публичном разделе выводится с помощью компонентов. Настроен ЧПУ.
    Если раздел или элемент удалены, то вместо 404 ошибки на странице выведено сообщение Раздел не найден или Элемент не найден. Как сделать вывод 404 ошибки?

    Решение: в настройках компонента в разделе Настройки 404 ошибки отметить опции:
    • Устанавливать статус 404;
    • Показ специальной страницы .

    В результате, если при обращении к странице система не найдет элемент или раздел инфоблока, то при отмеченных опциях, вместо HTTP статуса 200, веб-сервер сообщит HTTP статус 404 и покажет специальную страницу 404.php.

  2. Вопрос: Сайт работает на сервере nginx и переадресация на 404.php не работает.

    Если используется сервер nginx, то в конфигурации сервера пропишите строку error_page 404 /404.php;.


Рейтинги
182 / 694

В общем случае система устроена так, что все основные расчеты происходят автоматически по внутренним механизмам. По умолчанию также активен всего лишь один главный рейтинг в системе - Авторитет...


Что такое рейтинги
183 / 694

Как определить кто авторитетнее на сайте

В общем случае система устроена так, что все основные расчеты происходят автоматически по внутренним механизмам. По умолчанию также активен всего лишь один главный рейтинг в системе - Авторитет.

Авторитет – численный показатель признания пользователя сообществом, влияет на значимость голоса человека, когда он голосует за контент. Авторитет также служит основным механизмом регулирования сообщества через доступность тех или иных функций (в зависимости от авторитета можно настроить право публикации сообщений, комментировать, и так далее).

Рейтинг – численный показатель, отражающий полезную активность человека, ценность контента для сообщества.

Общая схема работы системы рейтингов, настроенной по умолчанию

Каждый новый пользователь имеет уже заранее указанный в настройках начальный авторитет , который можно при желании изменить .

Таким образом, он сразу после регистрации может участвовать в активной жизни сообщества. По умолчанию, пользователь будет получать 3 нормированных голоса, при стандартных настройках, что позволит ему сразу голосовать за рейтинг контента и соответственно авторитет пользователя.

Примечание: Для отдельных пользователей можно вручную указать иное, чем по умолчанию, начальное значение авторитета на закладке Рейтинг страницы настроек пользователя (Настройки > Пользователи > Список пользователей). Там же отображаются текущие значения параметров, связанные с рейтингом пользователя.

Нормированный вес голоса - это минимальный вес одного голоса в системе, в зависимости от размеров сообщества. Значение авторитета напрямую зависит от нормированного веса голоса.

Общее количество голосов пользователя рассчитывается по формуле: Авторитет / вес одного нормированного голоса.

Нормировка от размера сообщества позволяет утверждать, что если в сообществе в 500 человек у вас авторитет равен 100, и в сообществе на 500 000 человек у вас авторитет равен 100, это означает признание вас 10% сообщества.

Размер сообщества – это число пользователей, которые заходили на сайт не позднее 90 дней с момента расчета рейтинга и имеют право голосовать.

При голосовании (нажатии мне нравится) пользователь отдает за контент автора количество голосов, равное результату деления авторитета пользователя на значение нормированного голоса.

Пользователи не могут напрямую голосовать за авторитет. Это возможно лишь косвенно, согласно правилу обработки голосов Автоматическое голосование за авторитет пользователя (Сервисы > Рейтинги > Правила обработки). По этому правилу на основе суммы голосов, оставленных за контент пользователя, происходит изменение его авторитета.

Правило настроено так: один голос пользователя автоматически учитывается в авторитете автора контента, если в течение 90 дней за его контент проголосуют на 10 баллов в сумме. В секции Расчет баллов формы редактирования правила можно настроить, сколько балов будет учитываться для разных типов голосования за контент автора.

Примечание: Для рейтинга (не авторитета) можно произвести настройки (Сервисы > Рейтинги > Список рейтингов секция Критерии рейтингования) так, что пользователи могут голосовать как за контент, так и напрямую за сам рейтинг.

Таким образом, по умолчанию, авторитет пользователя строится на основе правила автоматического голосования. Рейтинг же учитывает голоса за контент, его тип и.т.д.

Документация по теме:

  • Пользовательская документация по модулю "Рейтинги"
  • Саморегулируемое сообщество построенное на двухфакторном рейтинге (блог)
  • Рейтинги: создание собственного критерия рейтингования (блог)


Расчёт и особенности рейтингов
184 / 694

Расчет рейтингов

Рейтинги рассчитываются автоматически каждый час с помощью соответствующих агентов, но если необходимо посмотреть изменение рейтинга после каких-либо его изменений, то можно пересчитать рейтинг вручную .

Примечание: Если какой-то критерий на момент запуска пересчета рейтингов не подсчитывался, то данные будут взяты из его последнего расчета.

Внимание! После изменения общих настроек рейтингов потребуется пересчет всех рейтингов.

Особенности рейтингов

  • Для некоторых компонентов необходимо в параметрах включить поддержку рейтингов с помощью соответствующей опции, чтобы в публичной части сайта отображались кнопки оценки контента. Там же можно выбрать их оформление для конкретного компонента. Значение По умолчанию берется из настроек рейтингов.
  • Рейтинг контента влияет на поиск. Чем больше рейтинг - тем выше в поисковой выдаче будет расположен контент. Такой режим поведения включается на странице настроек модуля Поиск с помощью опции При ранжировании результатов учитывать рейтинг.

Различия системы рейтингов в продуктах «Битрикс24 в коробке» и «1С-Битрикс: Управление сайтом»

  • В корпоративном портале система авторитета строится на основе субординации. Так количество голосов, отдаваемое сотрудником при голосовании за контент, зависит от его положения в иерархии компании. Голос начальника будет состоять из суммы голосов подчиненных и его собственного. Расчет добавочных голосов за авторитет по структуре компании осуществляется с помощью соответствующего правила обработки (Сервисы > Рейтинги > Правила обработки).

    Поддержка субординации (для авторитета включена по умолчанию) настраивается на вкладке Интранет формы редактирования рейтинга (Сервисы > Рейтинги > Список рейтингов).

  • В подсказке с проголосовавшими сотрудниками за контент (при наведении курсора на символ ★) в корпоративном портале список сначала строится по субординации, а если авторитет одинаков (например, равноценные начальники или обычные сотрудники), то уже по принципу "чей контент больше нравится, тот и выше". В БУС же список строится только по принципу "чей контент больше нравится, тот и выше".
  • В мастере настройки корпоративного портала, например при установке, можно сразу включить рейтинги и настроить внешний вид публичных элементов оценки контента.


Примеры работы
185 / 694

Примеры из жизни

Пара примеров работы с рейтингами на основе модуля Форум.

  • Настройка званий на форуме
  • Перемещение пользователя в группу в зависимости от рейтингов на примере форума

Настройка званий на форуме

Настроим систему рейтингов так, чтоб пользователь на форуме получал звание в зависимости от количества нормированных голосов у него.

  • Для начала необходимо отключить опцию Включить бонусную систему в настройках модуля Форум (Настройки > Настройки продукта > Настройки модулей > Форум), это позволит использовать на форуме Рейтинги вместо собственной системы подсчета баллов.

    Примечание: Для форумов используется только Авторитет.

  • На странице Звания (Сервисы > Форумы > Звания) необходимо создать звания , которые будут выдаваться пользователям, в зависимости от количества нормированных голосов у пользователя.

Перемещение пользователя в группу в зависимости от рейтингов на примере форума

  • Создадим 2 группы пользователей (Настройки > Пользователи > Список пользователей): Группа 1 и Группа 2.

    Пользователи 1-й группы смогут лишь отвечать на сообщения в форуме, но не смогут создавать новые темы, пользователи же 2-й группы будут иметь доступ к обсуждению существующих тем, а также возможность создания новых тем.

  • Настроим доступ к желаемому форуму для созданных ранее групп на странице Список форумов (Сервисы > Форумы > Список форумов, закладка Доступ) следующим образом :

    • Группа 1: Ответ;
    • Группа 2: Новая тема.

  • Создадим новые правила обработки (Сервисы > Рейтинги > Правила обработки):

    • Добавление в Группу 1;
    • Удаление из Группы 1;
    • Добавление в Группу 2.

    В качестве Условия выберем Значение авторитета. В поле Кол-во нормированных голосов для разных правил укажем:

    • Добавление в Группу 1 - Больше или равно 0. Тогда все пользователи форума автоматически будут добавлены в эту группу для того, чтобы они смогли отвечать в чужих темах;
    • Удаление из Группы 1 - Больше или равно 10;
    • Добавление в Группу 2 - Больше или равно 10. Перевод пользователей в группу, чтоб они смогли создавать собственные темы на форуме.

После произведенных настроек пользователи, в зависимости от их авторитета, будут переводиться в соответствующие группы и получать определенные права на форуме.


Смайлы и агенты
186 / 694

В главе приведено описание настроек функционала, не попавшего по классификации в другие разделы.


Смайлы
187 / 694

Системные и дополнительные смайлы

Раздел Смайлы (Сервисы > Смайлы) - системный раздел для смайлов, используемых модулями системы.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Для работы со смайлами используются понятия Галереи смайлов и Набор смайлов. Число Галерей и Наборов не ограничено. Каждая из Галерей может быть использована в любом из модулей . Выбор осуществляется в настройках модуля. Настройки Главного модуля являются настройками по умолчанию для остальных модулей.

Галереи

В дистрибутиве по умолчанию присутствует Стандартная галерея с Основным набором. Они неудаляемые, но при необходимости можно удалить из них все смайлы . Каждая Галерея может содержать в себе несколько наборов. Пользователь может использовать любой из имеющихся наборов, переключившись на нужный:

Один и тот же смайл может быть использован только в одной галерее.

Примечание: "Смайлом" для системы является не конкретная картинка или ID, а её написание. Соответственно, вы не можете использовать одно и то же написание в разных наборах в рамках одной галереи, для этого вам понадобится создать отдельную галерею.

Создание галереи

Для создания Галереи достаточно заполнить поля формы . Число галерей не ограничено. Кликнув на созданную галерею, можно перейти на страницу с созданием наборов.

Наборы

Для создания набора достаточно заполнить поля формы с указанием Галереи к которой они относятся и произвести импорт архива смайлов.

Для импорта необходимо заранее подготовить архив в формате ZIP. В простейшем виде архив может представлять из себя набор картинок, лежаших в корне архива. Но при использовании архива в таком виде импорт будет произведен по списку файлов с использованием меток в названии файла (если они есть). Варианты меток: "smile_" - смайл, "icon_" - иконка, "_hr" - высокое разрешение .

Например, при импорте в набор с кодом test файла smile_green_hr.png будет интерпретирован как "Смайл в высоком разрешении", а код вставки в редактор будет :test/green:.

В результате потребуется дальнейшее редактирование каждого смайла в отдельности. Нужно будет отредактировать поля Название и Написание, которые будут добавлены в виде неудобном для использования:

Чтобы избежать этого в архиве необходимо предусмотреть служебные файлы в формате csv . Служебных файлов должно быть как минимум два:

  • install.csv - данные для загрузки;
  • install_lang_**.csv - языковой файл, где ** - код языка , например, ru для русского.

Поля в файлах

Все поля в обоих файлах являются обязательными. Более того, порядок следования полей строго регламентирован и не может быть нарушен.

Поля файла install.csv

Название | Описание и значения
TYPE | Тип: смайл (S) или иконка (I). По умолчанию S.
CLICKABLE | Служебное значение (Y|N). По умолчанию Y.
SORT | Значение сортировки, определяет расположение смайла в общем списке. Чем меньше число, тем выше расположение смайла. По умолчанию ставится 300.
IMAGE | Имя файла в архиве.
IMAGE_WIDTH | Ширина картинки в пикселях.
IMAGE_HEIGHT | Высота картинки в пикселях.
IMAGE_DEFINITION Разрешение изображения:
  • Стандартное разрешение (SD)
  • Высокое разрешение (HD)
  • Сверхвысокое разрешение (UHD)
HIDDEN | Скрытое изображение, то есть вывод производится только по использованию написания (Y|N). По умолчанию N.
IMAGE_LANG | Мнемоническое название на английском языке для связки в языковом файле.
TYPING | Образцы написания смайла. Возможно несколько описаний, которые должны вводиться через пробел.

Поля файла install_lang_**.csv

Поле | Описание и значение
Мнемоническое название | Значение поля IMAGE_LANG из файла install.csv.
Название | Название смайла на подгружаемом языке.

Так же доступно ручное добавление смайлов, в ходе которого его необходимо привязать к тому или иному набору. При ручной загрузке невозможно загрузить смайл в разрешении Ultra HD.

Документация по теме:

  • АПИ для работы со смайлами
  • Пользовательская документация по смайлам


Агенты
188 / 694

Работаем с агентами

Агенты - это технология , позволяющая запускать произвольные PHP функции (агенты) с заданной периодичностью. В самом начале загрузки каждой страницы система автоматически проверяет, есть ли агент, который нуждается в запуске и в случае необходимости - исполняет его.

Внимание! Временная точность запуска агентов напрямую зависит от равномерности и плотности посещаемости сайта. Если вам необходимо организовать запуск каких либо PHP функций в абсолютно точно заданное время, то необходимо воспользоваться стандартной утилитой cron , предоставляемой большинством хостингов.

Кроме того, если агенты выполняются на обычных хитах, то, при большой нагрузке на агенты, посетитель вынужден ждать долгую загрузку страницы, пока все агенты исполнятся.

Список используемых в системе агентов приводится на странице Список агентов (Настройки > Настройки продукта > Агенты):

Для создания нового агента служит кнопка Добавить агента, расположенная на контекстной панели.

Примечание: Подробное описание полей формы смотрите на странице пользовательской документации .

Документация по теме:

  • Агенты
  • Выполнение всех агентов на cron


Настройка поиска документов
189 / 694

По умолчанию в продукте поддерживается поиск документов MS Office 2007. Для поиска всех документов необходимо выполнить ряд настроек, описанных в этой главе.


Добавление новых форматов
190 / 694

Если по умолчанию нет нужного формата

По умолчанию в «Битрикс24 в коробке» используется поиск по стандартным документам MS Office. Для организации поиска по документам иных форматов дополните список форматов с подключением необходимых программ для обработки файлов.

  • Загрузите необходимые программы для перевода текстовой информации из этих документов в режим plain text.
  • Установите на компьютер с «Битрикс24 в коробке» эти программы и в административном разделе откройте страницу настроек модуля Интранет (Настройки > Настройки продукта > Настройки модулей > Интранет). Перейдите на закладку Поиск .
  • В пустой строке в колонке Расширение укажите нужный формат, например, odt.
  • В колонке Внешняя команда введите команду в формате: <имя_программы> <имя_файла>. Например, внешняя команда для программы Otf2txt перевода документа в формате .ODT (OpenOffice) в формат .TXT имеет такой вид: odt2txt --encoding=UTF-8 #FILE_NAME#:

  • В колонке Каталог программы укажите путь до каталога с установленной программой и сохраните внесенные изменения.
  • Кроме того, чтобы выполнялся поиск по новому формату, необходимо на странице настроек модуля Поиск (Настройки > Настройки продукта > Настройки модулей > Поиск) добавить *.odt в поле Маска включения .
Примечание: При работе с файлами PDF возможна некорректная индексация части русскоязычных файлов. В этом случае замените пакет XPDF от компании The Poppler Developers (входящую в дистрибутив) на пакет Poppler-Utils от компании Glyph and Cog.


Поиск документов MS Office более ранних версий
191 / 694

Поиск документов, созданных в MS Office версий ранее 2007 (форматы doc, xls и ppt), возможен при подключении Catdoc – специального пакета программ для конвертации документов в формат plain text.

Если используется виртуальная машина VMBitrix , то поиск работает "из коробки". Если используется другое окружение, то удостоверьтесь в том, что Catdoc установлен.


Проверка установки Catdoc
192 / 694

Установлен ли пакет Catdoc

Проверить наличие пакета Catdoc можно следующим образом:

Проверка в Windows

Выполните команду Пуск > Выполнить. В открывшемся окне введите cmd. Нажмите ОК. Откроется окно командной строки.

  • Введите команду CD <полный_путь_до папки_окружения>\catdoc и нажмите ввод. Затем введите env.exe HOME=. catdoc.exe -v.
  • Если вы проверяете наличие пакета Catdoc на компьютере, то введите предполагаемый <полный_путь_до_папки_пакета>\catdoc.exe -v.

Нажмите ввод. Система должна выдать сообщение типа:

Usage:
catdoc [-vu8btawxlV] [-m number] [-s charset] [-d charset] [ -f format] files

Если сообщение будет следующим:

"C:\..." не является внутренней или внешней командой, исполняемой программой или пакетным файлом.

то либо неверен указанный путь, либо Catdoc не установлен.

Примечание: путь до пакета должен быть прописан настройках модуля Интранет в закладке Поиск (Настройки > Настройки продукта > Настройки модулей > Интранет).

Проверка в *NIX

Выполните

which catdoc
/usr/bin/catdoc

Если пакет установлен, то отобразится исполняемый файл.


Установка пакета Catdoc
193 / 694

Если по каким-то причинам пакет программ Catdoc не установлен, то:

Установка в Windows

  • Откройте в браузере сайт http://www.cygwin.com/ и загрузите файл setup.exe программы Cygwin.
  • Запустите установку программы и следуйте инструкциям Мастера установки.
  • На шаге выбора пакетов для установки откройте группу пакетов Text и отметьте для установки пакет Catdoc:

    Выбор пакетов для установки

  • В административном разделе "Битрикс24 в коробке" откройте страницу настроек модуля Интранет (Настройки > Настройки продукта > Настройки модулей > Интранет) и перейдите на закладку Поиск. Измените пути до файлов *.exe согласно их расположению, выбранному при установке Cygwin:

Установка в UNIX

Выполните команду:

yum install catdoc


Администратор КП
194 / 694

Администратору портала доступна настройка функционала не требующая высокого уровня квалификации.

Пользователям с правами Администратора портала недоступно управление следующими модулями:

  • Техподдержка;
  • Учет рабочего времени;
  • CRM;
  • Почта;
  • XMPP;
  • Задачи;
  • Поиск;
  • Диски;
  • Библиотека документов;
  • DAV;
  • AD/LDAP;
  • Видеоконференции;
  • Монитор производительности;
  • Проактивная защита;
  • Экстранет.


Настройка главной страницы
195 / 694

Главная страница портала настраивается администратором корпоративного портала под потребности всей компании. Фактически ее содержательная часть задается руководством.

Внимание! Описываемый функционал работает только в устаревшем и нераспространяемом шаблоне "Лайт". В шаблоне Битрикс24 отсутствует функционал гаджетов.

Технология настройки главной страницы аналогична настройке страницы Мой портал, описанной в курсе Пользователь портала. В этом уроке оговорим вопросы, касающиеся администрирования Главной страницы.

Настроив Главную страницу (число, размещение и параметры гаджетов), сохраните настройки с помощью кнопки Сохранить как настройки по умолчанию. Для сброса настроек используйте кнопку Сбросить текущие настройки.

Примечание: Для сотрудников, входящих в группу Администраторы изменения вступят в силу только в том случае если они ничего не меняли на Рабочем столе. В том случае если они что-либо меняли на нем (меняли местами гаджеты или добавляли новые), общие настройки уже не работают. Чтобы у этих сотрудников также отобразились нужные настройки, им нужно нажать на кнопку Сбросить текущие настройки.

Если информационная политика компании позволяет, то администратор может разрешить каждому авторизованному пользователю настраивать Главную страницу "под себя". Такое разрешение выдается в настройках компонента Рабочий стол (bitrix:desktop).

Так же в настройках компонента можно задать некоторые параметры внешнего вида Рабочего стола, без редактирования шаблона компонента: число и размер столбцов, в которых будут размещаться гаджеты.

Администратор имеет возможность ограничить набор используемых пользователями гаджетов для настройки и настроить каждый из гаджетов:


Wiki
196 / 694

Настройка модуля

База знаний (Wiki) - чаще всего информационный раздел сайта, структуру и содержимое которого пользователи могут сообща изменять с помощью инструментов, предоставляемых самим сайтом.
Детальное описание способов работы и примеры работы есть в курсе Контент-менеджер.

Для настройки модуля Wiki перейдите на страницу Настройки > Настройка Продукта > Настройки модулей > Wiki:

На закладке Настройки можно запретить использование визуального редактора при создании или редактировании статей, а также указать максимальные ширину и высоту изображений, которые получатся при ресайзе загружаемых картинок.

На закладке Социальная сеть, если планируется использование Wiki в рамках Социальной сети, нужно указать инфоблок для Wiki групп, а так же ID форума, который будет использоваться для комментариев статей Wiki в группах.

На закладке Доступ настраиваются права работы групп пользователей со страницами Wiki.

Внимание! При самостоятельной установке модуля Wiki опционально можно создавать/не создавать инфоблок для него. Отказываться от создания инфоблока не рекомендуется, так как компонент Wiki не будет работать корректно с созданным вне модуля инфоблоком. Работа с инфоблоком для wiki должна производиться только через компонент или API модуля.

Пользовательские списки статей/категорий

Кроме штатных категорий, администратор может создавать произвольные выборки страниц, пополняемый автоматически. Это не совсем категории, так как они подразумевают динамическое добавление и удаление страниц по ряду параметров.

Эти списки создаются с помощью кода, размещённого в файле init.php :

//Можно код разместить, например в файле /bitrix/php_interface/init.php

/*
* Функция, которая будет вызываться по событию при генерации списка категорий
* @param &obj $categories - объект, списка категорий
* @param str $sPathTemplate - путь для создания ссылки на категорию
* @return bool true.
*/
function _testOnCategoryListCreateEvent(&$categories, $sPathTemplate)
{
    $catParams = new CWikiCategoryParams; // создаем объект - набор параметров категории

    $catParams->sName = "Страницы созданные пользователем test"; // название категории
    $catParams->sTitle = "Тайтл категории cтраницы созданные пользователем тест"; // всплывающая подскака

    /*здесь вычисляем количество страниц попадающих в нашу категорию*/

    $catParams->iItemsCount = 333; // к примеру их оказалось 333
    $catParams->bIsRed = 'N'; // помечать ли категорию красным цветом, если не создана для нее страница
    $catParams->createLinkFromTemplate($sPathTemplate); // создаем ссылку на категорию
    $categories->addItem($catParams); // добавляем категорию в список категорий

    return true;
}

//обрабатываем событие создания списка категорий
AddEventHandler("wiki", "OnCategoryListCreate", "_testOnCategoryListCreateEvent");

/*
* Функция, которая будет вызываться по событию при генерации списка страниц категории
* @param &obj $categoryName - Наименование категории
* @param str $iBlockId - id iblock-а, в котором хранятся страницы вики
* @return dbResult
*/
function _testOnCategoryPagesListCreateEvent($categoryName, $iBlockId)
{
    // проверяем, наша ли категория создает список страниц
    if($categoryName != "Category:Страницы измененные сегодня")
        return false;

    //Подготавливаем данные для выборки нужных нам страниц вики

    $arPagesFilter = array(
            'IBLOCK_ID' => $iBlockId,
            'CHECK_PERMISSIONS' => 'N',
            'ACTIVE' => 'Y',
            'CREATED_USER_ID' => 478 // Показываем страницы созданные пользователем с id 478
            );

    $arSort = array('XML_ID' => 'ASC');    // Указываем сортировку

    $arPagesFilter['INCLUDE_SUBSECTIONS'] = 'Y'; // Включаем подкатегории

    // Учитываем, что вики может быть просто вики, а может быть для групп
    if (CWikiSocnet::IsSocNet())
        $arPagesFilter['SECTION_ID'] = CWikiSocnet::$iCatId;
    else
        $arPagesFilter['SECTION_ID'] = 0;

    return CIBlockElement::GetList($arSort, $arPagesFilter, false, false, Array());
}

//обрабатываем событие создания списка страниц в категории
AddEventHandler("wiki", "OnCategoryPagesListCreate", "_testOnCategoryPagesListCreateEvent");

Документация по теме:

  • Компоненты модуля "Wiki" (документация)
  • Способы работы и примеры


Библиотека документов
197 / 694

Внимание! Модуль Библиотека документов устарел. С версии КП 15.0 мы рекомендуем использовать модуль Битрикс24.Диск.

Средства системы коробочного Битрикс24 позволяют организовать специальный раздел коллективного доступа и работы над документами. Раздел может состоять из нескольких подразделов (библиотек), права доступа к которым могут быть различными для отдельных групп пользователей, рабочих групп.


Файловое хранилище
198 / 694

Внимание! Модуль Библиотека документов устарел. С версии КП 15.0 мы рекомендуем использовать модуль Битрикс24.Диск.

Функционал модуля Библиотека документов позволяет организовать на портале файловое хранилище, т.е. к порталу может быть подключена некоторая физическая папка с имеющимися в ней файлами и документами.

Чем файловое хранилище отличается от библиотеки документов

Файловое хранилище позволяет подключить существующий архив документации, получив готовый Web-интерфейс доступа к архиву.

Библиотека документов на инфоблоках обладает очень широким функционалом. Например: комментирование документов, разграничение доступа для отдельных отделов, рабочих групп и даже отдельных пользователей к папкам и даже к отдельным документам, история версий при изменении документов (можно просмотреть, откатиться на любую из предыдущих версий), возможность использовать гибкий и очень мощный функционал бизнес-процессов. И многое другое. Разумеется, с дополнительным функционалом библиотека менее производительна.

Подключение физической папки к порталу и организация интерфейса для работы с ней выполняется с помощью комплексного компонента Библиотека (bitrix:webdav).

Внимание! Начиная с версии КП 15.0 компоненты модуля Библиотека документов отключены. Мы рекомендуем использовать REST-методы, доступные при работе с Диском.

При размещении компонента на странице в его настройках следует в качестве источника данных указать Физическая папка на диске и задать относительно корня сайта путь к необходимой папке:

Также следует поставить галочку в опции Включить поддержку ЧПУ, а в поле Каталог ЧПУ (относительно корня сайта) необходимо ввести путь к папке с публичным интерфейсом относительно корня сайта.

В результате к порталу будет подключена указанная папка и все ее содержимое будет доступно в рамках библиотеки документов портала:

Работа с файлами и подпапками данной папки возможна как с помощью средств портала, так и традиционными средствами операционной системы.

Примечание: в библиотеке документов на основе физической папки отсутствует документооборот/бизнес-процессы, а также недоступен просмотр и изменение некоторых свойств файла.


Календарь событий
199 / 694

Для работы с модулем Календарь событий необходимо обладать правами администратора системы.


Веб-формы
200 / 694

Модуль Веб-формы позволяет создавать и размещать в публичном разделе сайта различные формы, служащие для организации взаимодействия с посетителями сайта. Это могут быть, например, формы для создания запроса к службе поддержки компании, отправки заявки на участие в семинаре, для сбора информации на вакансии и т.п.

В процессе управления веб-формами пользователь работает со следующими элементами модуля Веб-формы:

  • Веб-форма – формы, размещаемые на страницах Bitrix Framework;
  • Вопрос – совокупность самого текста вопроса и полей ввода, предназначенных для ответа на него;
  • Результат – результат заполнения веб-формы (ответы на вопросы);
  • Поле - подразумевает хранение каких-либо данных, определяемых (вычисляемых) после сохранения заполненной формы (после сохранения результата);
  • Статусы - для каждого результата формы можно назначить определенный статус, например, принято к рассмотрению, опубликовано, отклонено и т.д. В настройках статуса можно указать различные права доступа к результату для различных групп пользователей, а также отдельно для создателя результата.

Набор элементов, с которыми работает пользователь, зависит от выбранного режима редактирования веб-форм. Доступны следующие режимы редактирования веб-форм:

  • упрощенный;
  • расширенный.

Модуль Веб-формы позволяет создавать произвольное количество веб-форм, а также осуществлять гибкое управление параметрами созданных форм.


Настройки модуля
201 / 694

Настройки модуля

Настройка модуля Веб-формы осуществляется на странице Настройки > Настройки продукта > Настройки модулей > Веб-формы:

Нажмите на рисунок, чтобы увеличить

Поясним некоторые опции вкладки Настройки:

  • Использовать упрощенный режим редактирования форм - включение/выключение расширенного режима работы с веб-формами. После выключения упрощённого режима возврат к нему не рекомендуется: возможно искажение данных.
  • Максимальное кол-во записей выбираемых в SQL запросах - число записей, которое будет разрешено выбирать за один запрос SQL (устаревший параметр);
  • Право по умолчанию для вновь создаваемых веб-форм - определяются возможные действия для пользователя с создаваемой формой.

На вкладке Связь с CRM модуль Веб-формы можно интегрировать с CRM корпоративного портала , после чего любую веб-форму можно настроить так, что результаты ее заполнения будут отправляться в качестве полей нового лида в CRM.

Чтобы добавить новое соединение нажмите кнопку Добавить, после чего появится окно привязки CRM :

Поясним некоторые поля:

  • Сервер CRM - адрес вашего корпоративного портала или Битрикс24.
  • Путь - адрес страницы с компонентом интеграции относительного корневого каталога сервера (он уже по умолчанию должен присутствовать в поле и вводить его не надо).

На вкладке Доступ указывается уровень доступа к настройкам форм и результатам заполнения.

Чтобы добавить право доступа для какой-либо группы пользователей, нажмите ссылку Добавить право доступа. В противном случае ко всем группам пользователей, кроме администраторов, будет применено право доступа По умолчанию.

Документация по теме:

  • Настройки модуля


Упрощенный режим
202 / 694

Если нет сложных потребностей

Упрощенный режим предназначен для решения простых задач, например, создания формы обратной связи. В этом режиме не используются поля и статусы веб-форм .

Работа в упрощённом режиме возможна, если в настройках модуля Веб-формы установлен флаг Использовать упрощённый режим редактирования форм . Если вы работали в упрощённом режиме, а потом переключились в расширенный режим, то нежелательно возвращаться обратно в упрощенный режим. Данные, сохраненные в расширенном режиме, при переключении могут поменять структуру и сделать работу веб-формы неверной.

Видео-пример создания веб-формы в упрощенном режиме

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Создание веб-формы

  1. С помощью кнопки Создать , расположенной на контекстной панели страницы Список форм (Сервисы > Веб-формы > Настройка форм) откройте форму создания:

    Нажмите на рисунок, чтобы увеличить

    Заполните поля веб-формы. Значение полей понятно из их названия, если возникли вопросы, обратитесь к документации. Здесь поясним некоторые нюансы.

    • Если на закладке Свойства не будет заполнено поле Пункты меню в административном разделе, то пункт с названием веб-формы не добавится в меню Сервисы > Веб-формы > Результаты.
    • Если нужно получать результаты заполнении формы на какой-то e-mail, установите флажок в поле Отправлять результаты по email. Будет автоматически сгенерирован почтовый шаблон. Ссылка список шаблонов позволяет открыть список созданных шаблонов и отредактировать их необходимым образом.
    • Создайте шаблон веб-формы на закладке Шаблон формы.

      Примечание: закладка Шаблон формы доступна для сотрудников группы Администраторы.

    • Установите на закладке Ограничения ограничения на добавление результатов, это сделает результаты опроса более точными.
    • Закладка Статистика служит для задания идентификаторов для учёта события заполнения веб-формы в модуле Статистики. Это позволит анализировать динамику заполнения веб-форм, а также получать информацию о посетителях, заполнивших формы.

      • На закладке CRM (после сохранения формы) свяжите веб-форму с CRM корпоративного портала.

  2. После сохранения веб-форма будет добавлена в список на странице Список форм.

Создание вопросов

Самый простой способ создать вопрос - с помощью ссылки + , расположенной в столбце Вопросы. Откроется форма создания (редактирования) вопроса:

Заполнение полей не должно вызвать сложностей, если они возникли, обратитесь к документации. Поясним несколько неявных моментов.

  • Тип поля для ответа на данный вопрос определяет вид вопроса при показе формы посетителю. В зависимости от выбранного типа поля укажите дополнительные параметры в поле Ответ (на иллюстрации указана длина поля в знаках для ответа на вопрос).
  • На закладке Валидаторы можете назначить имеющиеся валидаторы для выбранного типа поля.
  • Для сохранения вопроса нажмите кнопку Сохранить.

Например, для формы Анкета посетителя сайта могут быть созданы следующие вопросы:

Дополнительная информация

  • Создание и редактирование веб-формы (документация)


Расширенный режим
203 / 694
Расширенный режим работы с веб-формами, помимо управления вопросами и результатами веб-форм, позволяет настраивать статусы результатов и создавать вычисляемые поля веб-форм.


Особенности режима
204 / 694

Используем все возможности

Для работы в расширенном режиме в настройках модуля Веб-формы необходимо снять флаг с поля Использовать упрощённый режим редактирования форм . Если вы работали в упрощённом режиме, а потом переключились в расширенный режим, то нежелательно возвращаться обратно в упрощенный режим. Данные, сохраненные в расширенном режиме, при переключении могут поменять структуру и сделать работу веб-формы неверной.

Что такое Поля и Статусы

Поля формы выводят промежуточные либо окончательные результаты вычислений, получаемых на основе того что вводилось посетителем в поля для ответов. Значения полей веб-формы вычисляются программным скриптом, заданным в коде визуального компонента. Пример использования приведен в документации.

Дополнительная обработка данных программным скриптом в полях требуется редко. Если не уверены, что справитесь сами, обратитесь к администратору сайта.

Статусы - для каждой формы создаются несколько статусов, например: Принято к рассмотрению, Опубликовано, Отклонено и так далее. В настройках статуса можно указать различные права доступа к результату для различных групп пользователей, а также отдельно для создателя результата.

Примечание: при работе с веб-формами в расширенном режиме для каждой веб-формы обязательно должен быть создан и настроен хотя бы один статус.


Создание и редактирование веб-формы
205 / 694

Видео-пример создания веб-формы в расширенном режиме

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Создаём форму в расширенном режиме

Создание веб-формы в расширенном режиме идентично работе в упрощенном режиме, но есть дополнительные параметры. Появляются:

  • поле для создания символьного идентификатора формы на закладке Свойства.
  • поле указывающее для каких статусов действуют ограничения на закладке Ограничения.
  • дополнительные уровни доступа сотрудников к веб-форме и результатам ее заполнения.

    Примечание: помните что настройки доступа к модулю Веб-формы по приоритету перекрывают таковые для каждой отдельной формы. То есть, если какой-то группе посетителей закрыт доступ к модулю совсем, то они не будут видеть веб-форму, даже если в самой форме будут установлены максимальные поля доступа.

  • Появляется вкладка Дополнительно, на которой могут быть выбраны или созданы шаблоны для фильтра по таблице результатов в административной части, а также для самой таблицы результатов:

    Примечание: ссылка Создать отображается только в режиме редактирования веб-формы. Поэтому для генерации почтового шаблона нужно сохранить создаваемую веб-форму с помощью кнопки Применить. Для каждой веб-формы может быть создано неограниченное число почтовых шаблонов.

Документация по теме:

  • Создание и редактирование веб-формы


Создание вопросов веб-формы
206 / 694

Создаём вопросы для веб-формы

Самый простой способ создать вопрос - открыть форму создания с помощью ссылки [+] , расположенной в столбце Вопросы, откроется форма создания вопроса:

Нажмите на рисунок, чтобы увеличить

Форма создания вопроса в расширенном режиме отличается от формы в упрощенном . Увеличилось число вкладок, поменялись расположения полей. Опишем только существенные отличия от упрощённой формы, подробное описание полей формы есть в документации.

Текст вопроса переехал на закладку Вопрос . При создании вопроса можно использовать визуальный HTML-редактор, а также загрузить изображение.

На закладке Ответ выберите Тип поля для ответа на данный вопрос и зависимости от выбранного типа поля укажите необходимые параметры в поле Текст:

Примечание: если в поле Текст не нужно вводить данные (для некоторых типов полей, например - файл, текст, это не нужно), то поставьте пробел.

На закладке Результаты настраиваются параметры показа результатов ответа на вопрос, а на закладке Фильтр - типы полей фильтра для различных параметров.

Для сохранения вопроса нажмите кнопку Сохранить.

Документация по теме:

  • Создание и редактирование вопроса


Настройка статусов веб-формы
207 / 694

Статусы

Статусы - для каждой формы создаются несколько статусов, например: Принято к рассмотрению, Опубликовано, Отклонено и так далее. В настройках статуса можно указать различные права доступа к результату для различных групп пользователей, а также отдельно для создателя результата.

Статусы нужны для того, чтобы реализовать сложные схемы работы с веб-формами, когда нужно не просто получить ответы на вопросы от посетителей сайта, но и обработать их: занести в CRM, составить списки по выборочным данным и так далее.

Создание статусов

Для создания статусов веб-формы кликните либо на Статусы на специальной панели в режиме редактирования нужной веб-формы, либо перейдите по ссылке [+] , расположенной в столбце Статусы на странице со списком форм. Откроется окно создания статуса:

Нажмите на рисунок, чтобы увеличить

На закладке Свойства три последние поля формы - для "тонкой" настройки, которой занимаются разработчики при кастомизации работы веб-форм. Вам нужно их заполнить, если только вы точно понимаете что делаете. Есть особенность поля Присваивать данный статус всем новым документам по умолчанию на этой же закладке. Оно может быть установлено только у одного статуса для данной веб-формы.

Настройка закладки Уведомления описана в уроке Настройка уведомлений.

Обязательно нужно задать права доступа на статус. Смотрите небольшой пример ниже.

Пример создания статусов

Создадим для результатов нашей формы два статуса:

  • В очереди, присваиваемый автоматически всем результатам после заполнения анкеты. Посетителю, создавшему анкету, дана возможность отредактировать анкету, пока она находится в этом статусе.
  • Принято, устанавливается вручную контент-менеджером после того как анкета была рассмотрена и добавлена в банк данных. В данном статусе анкета уже не может быть отредактирована пользователем, отправившим её. Право переводить анкету в статус Принято будет предоставлено пользователям группы Редакторы сайта .

Документация по теме:

  • Список статусов
  • Создание и редактирование статуса


Создание полей веб-формы
208 / 694

Как создать поле

Поле формы используется для хранения каких-либо данных, введённых после сохранения заполненной формы (после сохранения результата). Простейший пример: комментарий к ответу пользователя.

Самый простой способ создать поле - нажать на [+] , расположенный в столбце Поля нужной формы. Откроется форма следующего вида:

Нажмите на рисунок, чтобы увеличить

Значения полей понятны из их названия, в крайнем случае обратитесь к документации. Поясним моменты, которые не очевидны.

На закладке Результаты выберите в какой форме должны выводиться результаты: в HTML-таблице и/или в Excel-таблице. Поля фильтра будут выбраны в соответствии с заданным на закладке Свойства типом поля:

  • типу text соответствует однострочное текстовое поле фильтра;
  • типу integer соответствует интервал чисел;
  • типу date интервал дат.

Примечание:

В однострочном текстовом поле фильтра у вас есть возможность использовать логические выражения, в синтаксис которых входят:

  • & - это логическое И
  • | - это логическое ИЛИ
  • ~ - это логическое отрицание
  • () - это круглые скобки

На закладке Фильтр указываются типы полей для проведения выборки в таблице результатов по значениям данного поля, а в поле Подпись к полю фильтра задается надпись данного поля для фильтра.

Сохраните поле с помощью кнопки Сохранить или Применить.

Документация по теме:

  • Список полей
  • Создание и редактирование поля
  • Результаты веб-формы


Настройка интеграции веб-формы и CRM
209 / 694

Обмен данными с CRM

С версии 11.5 "1С-Битрикс: Управление сайтом" любая веб-форма передаёт данные в CRM корпоративного портала в качестве нового лида. Поля созданной веб-формы сопоставляются с полями CRM, и когда клиент заполнит веб-форму на сайте, эти данные отправляются на портал.

Рассмотрим на примере, как это можно сделать.

На странице Сервисы > Веб-формы > Настройка форм откройте нужную форму для редактирования либо создайте новую , нажав Создать на контекстной панели.

В открывшейся форме перейдите на закладку CRM:

Откройте выпадающий список поля CRM, где сейчас стоит нет. В выпадающем списке будут перечислены уже имеющиеся привязки к серверам CRM, выберите нужный портал. Если привязанных порталов нет, то создайте связь, выбрав пункт меню настроить новый.

Настройка привязки новой CRM

  • Название – произвольное название портала;
  • Сервер CRM – адрес портала;
  • Путь – адрес страницы с компонентом интеграции относительного корневого каталога сервера (по умолчанию адрес уже задан, и его менять не нужно);
  • Логин, Пароль – логин и пароль сотрудника портала, который будет выполнять обработку лидов.

После того, как привязанная CRM выбрана, закладка примет следующий вид:

  • Выберите Способ отсылки: при ручном режиме данные передаются в CRM менеджером после их обработки. При автоматическом режиме результаты заполнения сразу передаются в CRM.
  • В секции Связанные поля укажите, каким данным веб-формы (показаны справа) будет соответствовать какое-либо поле лида (показаны слева). Чтобы задать новое соответствие, нажмите кнопку Добавить.

    Внимание!

    Если не видны поля CRM, сохраните форму настройки и откройте ее снова.

    Для корректной передачи данных в CRM, к полю Название лида обязательно должно быть привязано какое-либо из полей веб-формы.

Если в веб-форме нет данных, подходящих нужному полю лида, выберите пункт Создать новый вопрос . Сохраните настройки веб-формы по кнопке Применить и вопрос создастся автоматически.

Примечание. Если в веб-форме используется шаблон формы по умолчанию, то созданный вопрос автоматически отобразится в форме. Если используется свой шаблон, то откройте шаблон на редактирование и в разделе Существующие поля формы добавьте вопрос в шаблон формы .

Передача данных в CRM

Допустим, что посетитель заполнил вашу веб-форму. Если в настройках был указан ручной способ отсылки, то на странице с результатами заполнения формы сотрудник, ответственный за их обработку, сможет отправить их в CRM, выбрав соответствующий пункт контекстного меню:

Если данные переданы успешно, выведется сообщение о добавлении лида . Результаты заполнения веб-формы можно отправить в CRM неограниченное количество раз, лиды в таком случае будут отличаться только значением ID.

Если в настройках указана автоматическая передача, то соответствующие лиды сразу появятся в CRM:

Примечание: в случае автоматической отсылки повторная отправка лида осуществляется уже вручную.

Документация по теме:

  • Настройки связи с CRM


Настройка шаблонов уведомлений
210 / 694

Уведомить об изменениях

Опрос по веб-форме может длиться долго, а то и постоянно. Для удобства работы, чтобы контент-менеджер не бегал на страницу результатов опроса каждый час, лучше организовать уведомления по электронной почте . Уведомления присылаются как при ответе посетителя на вопросы формы, так и на изменения статусов ответа, если это настроено.

Параметры сообщения по электронной почте настраиваются с помощью почтовых шаблонов, которые создаются, меняются и удаляются. В упрощённом режиме отсылается только одно сообщение, на заполнение формы. В расширенном режиме сообщений может быть несколько: на создание сообщения и на смену статусов.

Создание шаблонов

Шаблон сообщения о заполнении формы посетителем сайта создаётся автоматически при сохранении веб-формы.

Шаблон сообщения об изменении статуса в расширенном режиме автоматически не создаётся, так как не для всех статусов может понадобиться автоматическое уведомление. Для его создания нажмите создать на закладке Дополнительно. Шаблон сообщения на смену статусов создаётся аналогично описанному ниже.

Настройка почтового шаблона

Для настройки шаблона просто кликните по его номеру в нужной вам форме (самой формы или статуса формы). В открывшейся форме много полей, но минимально необходимые: От кого, Кому, Тема и Сообщение. При редактировании шаблона можно использовать простой текст, а можно использовать код из списка доступных полей внизу формы шаблона. Этот код подставит автоматически нужное текстовое значение.

Нажмите на рисунок, чтобы увеличить

В полях От кого и Кому введите электронные адреса, которые будут использоваться при отправке почты. Если необходимо указать несколько e-mail для доставки, то введите их через запятую.

Если в шаблоне не указать e-mail отправителя, то автоматически подставится тот, который задан в настройках Главного модуля (Настройки > Настройки продукта > Настройки модулей > Главный модуль).

Измените, если нужно, текст сообщения и тему письма и всё, шаблон готов!


Динамика заполнения веб-форм
211 / 694

Как отследить динамику ответов?

Если стоит задача отследить насколько активно посетители заполняют вашу форму, то это делается с помощью модуля Веб-аналитика. Этот модуль позволяет анализировать динамику заполнения веб-форм, а также получать информацию о посетителях, заполнивших формы. Регистрация веб-формы в модуле выполняется с помощью типов событий , назначаемых каждой веб-форме на закладке Статистика:


Почта
212 / 694

У администратора КП есть возможность частичного управления модулем Почта. Так же администратор может подключить к Битрикс24 собственную корпоративную почту через протокол IMAP. Возможно и подключение собственного почтового домена и управление через корпоративный портал почтовыми ящиками. Управление осуществляется методами, аналогичными управлению ящиками в облачной версии Битрикс24.


Работа с почтовыми шаблонами
213 / 694

Почтовые шаблоны расположены на странице Настройки > Настройки продукта > Почтовые и СМС события > Почтовые шаблоны. Чтобы отредактировать почтовый шаблон, выберите пункт Изменить в меню действий нужного шаблона:

Откроется форма редактирования почтового шаблона. Суть большинства параметров ясна их названия, опишем только некоторые:

  • От кого - указывается электронный адрес, который будет указываться как e-mail отправителя письма.
  • Кому - указываются адреса тех, кому будут отправлены письма.

    Примечание: Если в поля От кого и Кому не проставлены конкретные адреса электронной почты, то подставляются адреса по умолчанию. Система сначала подставляет адрес из настроек сайта, к которому привязан шаблон, и затем, если такой адрес не обнаружен, из настроек Главного модуля. Поскольку адрес по умолчанию в обоих случаях один, то он будет подставлен в оба поля.

  • Скрытая копия - о факте отправки письма на электронные адреса, указанные в данном поле, не будут знать ни главный адресат, ни получатели, указанные в поле Копия. Кроме того, адресаты, указанные в поле Скрытая копия, также не будут видеть друг друга в получателях письма.
  • Важность - нажмите на стрелочку и укажите степень важности отсылаемого уведомления.
  • Тема - укажите тему письма. Удобно использовать для рассылок определённой тематики. Тема должна быть предварительно создана.

Само сообщение представлено на вкладке Тело сообщения. При редактировании сообщения можно выбрать более удобный для вас в данной форме формат представления сообщения: Текст, HTML или Визуальный редактор.

Доступные значения полей для параметров и тела сообщения можно брать ниже в виде макросов:

Кроме макросов, в почтовых шаблонах можно указать php-код (с версии главного модуля 15.0.7). К примеру:

Добрый день!
Ваш логин: #LOGIN#
Текущая дата: <?=date('d.m.Y')?>

Примечание: в доступных полях, при указании что параметр устанавливается в настройках, зачастую имеются в виду настройки главного модуля.

Добавление шаблона

Нажав кнопку Добавить шаблон на контекстной панели вы откроете форму добавления, кторая фактически идентична форме редактирования шаблона, за исключением того, что вам нужно выбрать тип ранее созданного почтового события, к которому будет привязан шаблон:

Чтобы увидеть все поля формы, нажмите показать дополнительные заголовки....

Визуальный редактор

В визуальном редакторе почтового шаблона допустимо использование компонентов . Но нужно учитывать, что:

  • Подключение компонентов выполняется методом EventMessageThemeCompiler::includeComponent() вместо метода CMain::IncludeComponent , хотя передаваемые аргументы нового метода аналогичны аргументам IncludeComponent.
  • В визуальном редакторе при редактировании почтового шаблона отображаются только почтовые компоненты у которых в файле описания (.description.php) указан тип "TYPE" => "mail". Например:
    <?if (!defined("B_PROLOG_INCLUDED") || B_PROLOG_INCLUDED!==true) die();
$arComponentDescription = array(
    "NAME" => GetMessage("SBBS_DEFAULT_TEMPLATE_NAME"),
    "TYPE" => "mail",
    "DESCRIPTION" => GetMessage("SBBS_DEFAULT_TEMPLATE_DESCRIPTION"),
    "ICON" => "/images/sale_basket.gif",
    "PATH" => array(
        "ID" => "e-store",
        "CHILD" => array(
            "ID" => "sale_basket",
            "NAME" => GetMessage("SBBS_NAME")
        )
    ),
);
?>

    Без этого компонент можно будет подключить только вручную вставив код вызова.

  • Подключенный в почтовом шаблоне компонент может выполняться на хите (отправка письма на хите), соответственно компонент не должен использовать:
    • глобальный объект USER , так как в нём содержатся данные о том кто сделал хит, а не о том, кому отправляется письмо;
    • константы SITE_ID , LANGUAGE_ID , SITE_TEMPLATE_ID .

      Вместо них нужно использовать вызовы методов:
      $this->getSiteId() - сайт, указанный в почтовом событии,
      $this->getLanguageId() - язык сайта, указанного в почтовом событии,
      $this->getSiteTemplateId() - шаблон сайта, указанного в почтовом событии.

    Внимание! При отправке письма по шаблону, будет выполнен код компонента. Языковые файлы в компоненте будут подключены для того языка, который указан в настройках сайта указанного в почтовом событии. Для письма используется та кодировка, которая указана в настройках сайта, код которого передан в событии.

    Таким образом, если на сайте используется многосайтовость с разными языками, то на хите по русскому сайту, может быть отправлено письмо для другого языка.

Темы сообщения

Тема сообщения - это шаблон оформления сообщения. Создаётся из списка тем со страницы Настройки > Настройки продукта > Почтовые и СМС события > Темы оформления. Технология создания темы аналогична созданию шаблона сайта и имеет аналогичную форму. Технически тема оформления - это шаблон сайта в папке /bitrix/templates. При создании именно темы для почтовых сообщений нужно выбрать значение Шаблон для почтовых писем в поле Тип. В этом случае в файле описания (.description.php) будет указан тип "TYPE" => "mail":

<?$arTemplate = array(
    "NAME" => "Тестовая тема оформления",
    "DESCRIPTION" => "Тестовая тема оформления",
    "SORT" => "",
    "TYPE" => "mail",
);
?>

Стили, указанные в файлах стилей будут вставлены в письмо (inline) в том месте, где будет вызов <?=$this->showStyles()?>

Темы оформления, так же как и шаблоны сайта, могут содержать php-код.

Поиск шаблона почтового компонента выполняется по стандартному алгоритму. Если у почтового шаблона, где подключается компонент, проставлена тема оформления, то папка темы оформления используется в качестве текущего шаблона сайта при поиске шаблона компонента.

Документация по теме:

  • Почтовые шаблоны
  • Создание и редактирование почтового шаблона


Типы почтовых событий
214 / 694

Типы почтовых событий описаны на странице Настройки > Настройки продукта > Почтовые события > Типы почтовых событий:

Для редактирования типа почтовых событий выберите пункт Изменить в меню действий. Чтобы добавить новый тип нажмите кнопку Добавить тип на контекстной панели, откроется форма создания:

Введите название создаваемого типа. Поставьте галочки напротив заголовков тех языковых описаний, на которых хотите представить свой новый тип, и заполните поля Сортировка, Название и Описание. В поле Описание введите доступные поля (макросы вида #SOMETHING#,), которые должны использоваться при написании тела сообщения почтового шаблона, который будет принадлежать создаваемому вами типу.

Примечание: Сами же макросы заменяются на вывод значения из массива по ключу названия макроса. Допустим, добавлено событие с массивом полей:
array(
    'ORDER_ID' => 123,
    'ORDER_PAID' => 'Y',
    'BUYER_NAME' => 'Андрей'
)

В почтовом шаблоне можно будет использовать эти поля, указывая макросы:

#ORDER_ID#
#ORDER_PAID#
#BUYER_NAME#

Начиная с версии главного модуля 15.0.7, где разрешается использование PHP в почтовых шаблонах, то же самое можно указать и так:

<=$arParams['ORDER_ID']>
<$arParams['ORDER_PAID']>
<=$arParams['BUYER_NAME']>

Таким образом, в теле почтового шаблона массив переданных полей доступен через переменную $arParams.

Особенности использования тега xml
Текст xml выдаст ошибку:
<?xml version="1.1" encoding="UTF-8" ?>
<tag1>a</tag1>
<tag2>b</tag2>

Дело в том, что тег xml интерпретируется php не как текст. Поэтому, нужно выводить тег xml так:

<?echo '<'.'?'.'xml version="1.1" encoding="UTF-8" ?'.'>'?>

Нажмите Сохранить, после чего новый тип добавится в общий список и его можно будет указывать при создании почтовых шаблонов.

Примечание: подробнее о почтовых шаблонах смотрите в уроке Работа с почтовыми шаблонами .

При редактировании типа почтовых событий появится закладка Шаблоны, на которой видны шаблоны почтовых событий, привязанные к данному типу. Для только что созданного нами типа данная вкладка будет пустой.

Документация по теме:

  • Типы почтовых событий
  • Создание и редактирование типа почтового события


Бизнес-процессы
215 / 694

Сам модуль Бизнес-процессы настроек не имеет, однако, для корректной его работы необходимо произвести настройки прав доступа для пользователей и настройки инфоблоков.

Примечание: Настройка и создание бизнес-процессов организации описаны в главе Бизнес-процессы раздела Администратор системы.

Примечание: Подробнее про работу с бизнес-процессами в публичной части смотрите в курсе Пользователь корпоративного портала, глава Бизнес-процессы.


Настройка библиотек документов на работу с бизнес-процессами
216 / 694
Настройка библиотек документов на работу с бизнес-процессами

Для настройки инфоблоков, используемых для организации библиотек документов (инфоблоки типа Документы), на работу с бизнес-процессами необходимо выполнить следующие действия:

  1. Настройка инфоблоков
  2. Настройка прав доступа

Настройка инфоблоков

Чтобы документы и файлы определенного инфоблока работали в режиме Бизнес-процессов необходимо произвести настройки этого инфоблока в административном разделе. Это может сделать администратор системы либо пользователи с правами доступа к модулю Бизнес-процессы не ниже Полного доступа.

Примечание: Один и тот же информационный блок не может работать и в режиме Документооборота и в режиме Бизнес-процессов.
  • Для настройки инфоблока перейдите на страницу настройки свойств инфоблока (Контент > Информ. блоки > Типы информ. блоков > [Нужный_тип_инфоблока] > [Нужный_инфоблок] ).
  • На закладке Инфоблок в поле Участвует в документообороте или бизнес процессах выберите Бизнес-процессы.

    • Инфоблок участвует в бизнес процессах

  • Нажмите кнопку Применить для внесения изменений.

Теперь выбранный инфоблок будет участвовать в Бизнес-процессах.

Примечание: включить участие инфоблока в документообороте можно и из публичного раздела.

Настройка прав доступа

Для работы с бизнес-процессами к модулю должен быть подключен не только инфоблок. Необходимо дать нужные права для групп пользователей.

  • Перейдите на закладку Доступ настраиваемого инфоблока и назначьте для соответствующих групп уровень доступа не ниже Бизнес-процессы.

    • Инфоблок участвует в бизнес процессах

    Внимание! Уровень доступа Бизнес-процессы позволяет указанным группам пользователей только лишь участвовать в бизнес-процессах. Для того чтобы пользователи смогли сами запускать бизнес-процессы, необходимо выставить более высокий уровень прав доступа для инфоблока, например Изменение.
  • Нажмите кнопку Применить для внесения изменений.

Примечание: Работа с бизнес процессами библиотеки документов рассмотрена в курсе Пользователь портала в уроке Бизнес-процессы документов


Настройка инфоблоков на работу с бизнес-процессами
217 / 694

Настраиваем работу инфоблока с бизнес-процессами

Для настройки работы бизнес-процессов с инфоблоками необходимо выполнить ряд действий.

Настройка инфоблоков

Для участия инфоблока в Бизнес-процессах:

  • Перейдем на страницу настройки свойств инфоблока (Контент > Информ. блоки > Типы информ. блоков > [Нужный_тип_инфоблока]).
  • На закладке Инфоблок в поле Участвует в документообороте или бизнес процессах выбираем Бизнес-процессы .

Настройка прав доступа

Для работы с бизнес-процессами необходимо дать права для групп пользователей. Перейдем на закладку Доступ настраиваемого инфоблока и назначим для соответствующих групп уровень доступа не ниже Бизнес-процессы .

Внимание! Уровень доступа Бизнес-процессы позволяет указанным группам пользователей только участвовать в бизнес-процессах. Для того чтобы пользователи смогли сами запускать бизнес-процессы, необходимо выставить более высокий уровень прав доступа для инфоблока, например Изменение.

Настройка автозапуска бизнес-процесса при создании/изменении элемента инфоблока

Модуль Бизнес-процессы позволяет автоматически запускать выбранные бизнес-процессы при создании/изменении элемента инфоблока.

  • Перейдем на закладку Шаблоны бизнес-процессов настраиваемого инфоблока.
  • В строке с названием нужного бизнес-процесса установим флаг в поле Автозапуск: Создание и Изменение .

    • Примечание: Если у вас установлена старшая редакция продукта (модуль Дизайнер бизнес-процессов), то вы имеете возможность редактировать шаблоны типовых бизнес-процессов и создавать собственные, поэтому вам названия шаблонов типовых процессов отображаются в виде ссылок и доступна ссылка Список шаблонов бизнес-процессов.

Для запуска бизнес-процесса вручную используйте пункт меню действий Запустить бизнес-процесс желаемого элемента инфоблока.

Настройка формы создания/изменения элемента инфоблока

При создании/изменении элемента инфоблока пользователь указывает не только название и другие параметры, относящиеся к контенту, но и все параметры запускаемого бизнес-процесса. Для этого настроим саму форму редактирования элемента инфоблока. Перейдем на страницу со списком элементов инфоблока, а затем к форме редактирования некоторого элемента. По умолчанию закладка Бизнес процессы, на которой производится управление бизнес-процессами, отключена. Для её включения есть два способа :

  1. Выбираем команду Отменить настройки формы и все доступные закладки появятся перед вами. Этот способ не удобен тем, что из всего, что появится, требуется только одна закладка, остальные мешаются;
  2. Выберите команду Настройки. Откроется окно Настройка формы редактирования. В секции Доступные вкладки выберите Бизнес-процессы и нажмите кнопку [image], чтобы в форме создания/редактирования элемента была доступна вкладка Бизнес-процессы с соответствующими полями.

Теперь, например, в форме добавления новости в публичной части сайта будет доступна вкладка Бизнес-процессы .


Журнал выполнения бизнес-процесса
218 / 694

Узнаем подробности в журнале

При разработке и использовании уже готовых процессов бывает необходимо узнать подробности выполнения того или иного процесса / действия. Для этого в системе предусмотрен журнал выполнения бизнес-процессов (лог).

Административная часть сайта

Для просмотра журнала выполнения бизнес-процесса перейдем в режим редактирования элемента инфоблока (документа, для которого запущен бизнес-процесс) на вкладку Бизнес-процессы и затем используем ссылку в поле Текущий статус. Откроется форма с Историей выполнения бизнес-процесса .

Для просмотра более подробной информации используем ссылку Расширенный режим .

Идентификатор действия в расширенном режиме
В расширенном режиме в скобках отображается идентификатор конкретного действия. Посмотрите или задайте его непосредственно при создании/редактировании шаблона бизнес-процесса в форме Настройка параметров действия с помощью ссылки [Ид].

В поле допустимо вводить только символ подчеркивания (_), буквы латинского алфавита или цифры.

Публичная часть

Скриншоты публичной части даны на примере шаблона "Битрикс24 в коробке". Функционал аналогичен, даже если на вашем реальном сайте внешний вид отличается.

Для просмотра текущего статуса созданного вами процесса откроем вкладку Процесс выполнения страницы Мои процессы. Вы увидите сам статус, в котором находится процесс, а также пользователя, ответственного за его выполнение на каждом шагу развития процесса.

Полноценный лог можно найти при просмотре детальной информации о процессе. Можно проследить полный жизненный цикл бизнес-процесса, кем и когда были приняты соответствующие решения и что стало их результатом. По нажатию правой кнопкой мыши по шапке таблицы лога откроется меню , в котором настраивается лог, в том числе, выбираются колонки, которые в нем отобразятся.


Блоги
219 / 694

Блог - это сетевой журнал (дневник), позволяющий вести тематические записи в хронологическом порядке. В блоге автор может свободно выражать свои мысли по тем или иным вопросам, высказывать свое мнение о происходящих событиях и т.п.

Модуль Блоги в рамках социальной сети является функционалом Сообщения, который дает возможность вести общение как на персональных страницах сотрудников, так и в группах.

Нажмите на рисунок, чтобы увеличить

Сотрудник может не только добавлять новые сообщения, но и получать комментарии посетителей относительно этих сообщений. Данный функционал позволяет автору предлагать посетителям различные темы для обсуждения, организовывать обмен мнениями по поводу мыслей, высказанных в сообщениях и т.п.

Возможности модуля:

  • создавать неограниченное число сообщений;
  • управлять правами сотрудников на доступ к сообщениям;
  • настраивать иконки и смайлики для использования в сообщениях;
  • обрабатывать смайлики и теги при показе сообщений и комментариев;
  • использовать Trackback механизм;
  • группировать сообщения по произвольным темам (tags);
  • присоединять изображения, видео и файлы к сообщениям.
Примечание. Trackback — это механизм уведомления сайта A (на нем может находиться, например, некая «родительская» статья) о существовании некоторого другого сайта B (например, с «дочерней» статьей или некоторым комментарием).


Настройки модуля
220 / 694

Настройки модуля Блоги

Глобальные параметры блогов определяются на странице настроек модуля Блоги (Настройки > Настройки продукта > Настройки модулей > Блоги).

Закладка Настройки модуля блогов позволяет определить:

  • максимально допустимые размеры аватара пользователя и прикрепляемого к сообщению изображения;
  • возможность использования псевдонимов, Trackback'а, CAPTCHA и пр.;
  • права на сообщения, комментарии, изображения (при неотмеченной опции Проверять права для изображений пользователь сможет просмотреть картинку из сообщения\комментария блогов по ссылке на нее, даже если для него стоит запрет на просмотр самого сообщения\комментария);
  • добавлять к ссылкам rel='nofollow' и тег <noindex> - при отмеченной опции ссылки исключаются из индексации и ранжирования в Яндексе и Рамблере;

Шаблоны путей к публичной части блогов настраиваются на соответствующей закладке в зависимости от используемых визуальных компонентов:

Документация по теме:

  • Настройки модуля


Настройка прав
221 / 694

Настройка прав

Права доступа к группам блогов, блогам и комментариям блогов настраиваются на закладке Права на доступ на странице административного раздела Настройки > Настройки продукта > Настройки модулей > Блоги. Если необходимо, чтобы у какого-либо пользователя было право не только чтения, но и создания блога, то необходимо причислить его к группе , для которой должно быть задано соответствующее право:

Каждый владелец блога может самостоятельно настраивать права доступа для него, но администратор может задать максимальную глубину такой настройки, выставив соответствующие параметры в Настройках модуля блогов:

То есть если Администратор укажет в настройках модуля "Максимальные права на сообщения для групп пользователей блога" уровня Запись, то Контент-менеджер уже не сможет дать группам пользователей блога (и стандартным группам, и Открытым группам) права Модерирование и Администрирование.

Настройка прав доступа к сообщениям и комментариям блога выполняется также при создании или редактировании блога или сообщения блога.

Документация по теме:

  • Настройки модуля


Группы блогов
222 / 694

Группа блогов - это, по сути, тематика, к которой относится блог. Например, Туризм, Интернет, Досуг, Софт и т.д. Каждый создаваемый в системе блог привязывается к определенной группе.

Создание и редактирование группы блогов

Создание и изменение групп выполняется на странице Группы блогов (Сервисы > Блоги > Группы блогов):

Для создания новой группы служит кнопка Новая группа, расположенная на контекстной панели.

Форма создания (редактирования) группы блогов состоит всего из двух пунктов:

  • Название группы - указывается название создаваемой группы;
  • Сайт группы - указывается сайт, на котором будут доступны блоги, относящиеся к данной группе. Таким образом, создается привязка группы блогов к определенному сайту, и в дальнейшем каждый новый блог будет связан с ним.

Важно! Привязка блога к одной из групп является обязательной и выполняется в форме создания/редактирования блога.

Чтобы перейти к редактированию уже существующей группы, выберите пункт контекстного меню Изменить параметры группы, для удаления - Удалить группу.

Форма редактирования группы блогов аналогична форме создания.

Документация по теме:

  • Группы блогов
  • Создание и редактирование группы блогов


Блоги
223 / 694

В предыдущем уроке мы разобрали, как создавать группу блогов. В этом уроке рассмотрим, как создавать сами блоги.

Видео-пример создания и редактирования блога

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Создание и редактирование блога

Создание и редактирование блогов осуществляется на странице Блоги (Сервисы > Блоги > Блоги):

Для создания нового блога служит кнопка Новый блог, расположенная на контекстной панели.

Форма создания/редактирования блога имеет следующий вид:

  1. Параметры блога:

    Владелец блога - выбирается пользователь, который будет вести блог и модерировать его.

    Включена выгрузка в RSS .92, RSS 2.0 и Atom .03 - данная опция определяет возможность экспорта данных блога в форматы RSS .92, RSS 2.0 и Atom .03. Если флаг установлен, то на страницах блога будут отображаться кнопки для экспорта данных в соответствующие форматы.

    Значения остальных параметров понятны интуитивно.

    Примечание: при включении индексации блога не забудьте переиндекcировать модуль.

    При создании можно ограничить возможности текстового редактора для тех, кто комментирует сообщения. Это выполняется в секции Параметры текстового редактора .

  2. Права на доступ:

    Настройка прав на доступ к блогу выполняется на закладке Права на доступ формы создания/редактирования блога:

    Примечание: по умолчанию в блоге присутствуют две группы пользователей: Все пользователи и Авторизованные пользователи. Дополнительно блогер может создать в своем дневнике другие группы, например, Друзья, Посетители и т.д. Это выполняется с помощью функционала публичного раздела. Настройка прав всех групп пользователей возможна как из административного раздела, так и из публичного раздела.
  3. Доп. поля:

    На закладке Доп. поля можно добавить и настроить Пользовательское поле .

Редактирование и удаление блога

Чтобы отредактировать или удалить существующий блог, воспользуйтесь соответствующими пунктами меню действий.

Форма редактирования блога аналогична форме создания.

Документация по теме:

  • Список блогов
  • Создание и редактирование блога


Комментарии
224 / 694

Управление комментариями

Управление комментариями к записям блогов осуществляется на странице Комментарии (Сервисы > Блоги > Комментарии):

Нажмите на рисунок, чтобы увеличить

Чтобы удалить или скрыть комментарий, воспользуйтесь соответствующими пунктами меню действий.

Документация по теме:

  • Комментарии


Документооборот
225 / 694

Модуль Документооборот системы «Битрикс24 в коробке» используется для организации цепочки движения документа от момента создания до момента публикации с обязательным ведением истории изменении и сохранением копий документов на каждом из этапов.

Администратор портала обладает всеми необходимыми правами для работы со статическими и динамическими страницами через модуль Документооборота и с самим модулем, но чтобы настроить документооборот на работу со статическими страницами нужна будет помощь Администратора системы (обеспечить доступ нужным пользователям к статическим страницам).


Статусы, создание и настройка
226 / 694

Список статусов

Статус - это то, что обозначает определенный этап в работе с документом. Статусы так же ограничивают доступ к документу для пользователей.

Управление статусами выполняется на странице Статусы (Контент > Документооборот > Статусы):

Нажмите на рисунок, чтобы увеличить

Примечание: статус с ID=1 является конечным в цепочке документооборота (на рисунке это статус Опубликован). Он зарезервирован и не удаляется, но название статуса изменяется. При достижении документом этого статуса все изменения, выполненные в документе, вступают в силу, документ публикуется.

Создание статуса

Нажмите на [image] на странице списка Статусов, откроется форма создания статуса:

Настройка прав групп пользователей

Введите название и настройте права доступа к документам в этом статусе. Если необходимо уведомлять пользователей о достижении статуса, установите флажок в поле Оповестить всех, кто имеет право....

Количество возможных статусов не ограничено.


Настройка модуля
227 / 694

Настраиваем модуль

Управление настройками модуля выполняется на странице настройки модуля Документооборот (Настройки > Настройки продукта > Настройки модулей > Документооборот).

Нажмите на рисунок, чтобы увеличить

На закладке Настройки суть полей ясна из названия, в крайнем случае обратитесь к пользовательской документации . Но одно поле поясним. Это поле Группа администраторов документооборота. Для нормальной работы документооборота нужно создавать, изменять статусы. Делается это, если у пользователя есть полный доступ к модулю Документооборот. Давать права полного доступа сотрудникам, работающим с документами нецелесообразно. Поэтому есть такое поле, в котором указывается какая группа пользователей будут администраторами.

На закладке Доступ настраиваются уровни прав доступа к модулю для групп пользователей сайта.

Для пользователей, которые должны работать с документами, установите право - Участие в документообороте, для тех кто контролирует работу можно установить право Просмотр без права модификации.


Документооборот в структуре файлов
228 / 694

Как настроить документооборот для файлов и папок

Настройка документооборота на последовательную работу над страницами сайта включает в себя шаги:

  1. Настройка прав модуля Документооборот,
  2. Настройка прав модуля Управление структурой,
  3. Настройки в менеджере файлов для папок, участвующих в документообороте
  4. Создание и настройка необходимых статусов для документов.

Настройка прав модуля Документооборот

В модуле Документооборот для той группы пользователей, кто будет работать с документами установите право Участие в документообороте:

Настройка прав доступа к модулю Документооборот

Внимание для администраторов Битрикс24 в коробке! Этот пункт недоступен для пользователя корпоративного портала с правами Администрация портала, эту операцию должен выполнять пользователь с правами Администратор системы.

Настройка прав модуля Управление структурой

В модуле Управление структурой для той группы пользователей, кто будет работать с документами установите право Редактирование файлов и папок:

Настройка прав доступа к модулю Управление структурой

Настройки в менеджере файлов для папок, участвующих в документообороте

В Менеджере файлов для папок и файлов, с которыми будет работать пользователь, для этой же группы установите право доступа Документооборот:

Настройка прав доступа к папкам и файлам

Пользователи группы, предназначенной для документооборота, должны иметь право доступа на чтение к папке /bitrix/admin.

Документация по теме:

  • Создание и редактирование документа
  • Документы


Документооборот при работе с инфоблоками
229 / 694

Как настроить документооборот для Информационных блоков

Настройка документооборота на последовательную работу над информационными блоками включает в себя шаги:

  1. Настройка прав модуля Управление структурой.
  2. Настройки разделов, участвующих в документообороте.
  3. Настройки информационных блоков, участвующих в документообороте, может выполняться Контент-менеджером, если ему даны такие права.
  4. Создание и настройка необходимых статусов для документов.

Внимание! В случае с инфоблоками нет необходимости давать права на модуль Документооборот.

Видео-пример настройки прав для документооборота в инфоблоках

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Настройка прав модуля Управление структурой

В модуле Управление структурой для той группы пользователей, которая будет работать с документами, установить право Редактирование файлов и папок:

Настройка прав доступа к модулю Управление структурой

Настройки в менеджере файлов для папок, участвующих в документообороте

В Менеджере файлов для папок и файлов, где будет размещаться информационный блок, для этой же группы установите право доступа Документооборот:

Настройка прав доступа к папкам и файлам

Пользователи группы, предназначенной для документооборота, должны иметь право доступа на чтение к папке /bitrix/admin.


Интранет
230 / 694

Работа модуля Интранет основана на модуле Информационные блоки. Компоненты этого модуля используются для:

  • выполнения поиска сотрудников;
  • отображения кадровых изменений, происходящих в компании;
  • построения графика отсутствующих сотрудников;
  • организации доски почета;
  • вывода списка ближайших именинников;
  • создания календарей событий;
  • импорта пользователей из «1С:Зарплата и Управление Персоналом».
Примечание: Настройки модуля выполняет Администратор системы.


Структура компании
231 / 694

Примечание: Если во время установки продукта была отмечена опция Установить демонстрационный пример структуры компании, то будет загружен демонстрационный пример структуры компании и пользователей, т.е. в инфоблок Подразделения будут добавлены разделы и подразделы, а результат можно будет просмотреть на странице Структура компании. В противном случае, инфоблок и страница будут пустыми.

Для организации структуры должен быть создан тип инфоблока, например Оргструктура, и инфоблок Подразделения, в котором будет храниться структура компании.

Создание структуры компании может быть выполнено одним из способов:

  • автоматически при импорте пользователей в систему (при этом Тип инфоблока и Инфоблок, в который будет загружена структура компании при импорте пользователей, указываются в настройках модуля Интранет):

    Параметры импорта пользователей

    При выполнении импорта пользователей из AD/LDAP необходимо настроить параметры импорта структуры с сервера:

    Примечание: Подробнее про настройки импорта пользователей из AD/LDAP смотрите в уроке Регистрация сервера главы AD/LDAP.

  • вручную посредством добавления разделов и подразделов в созданный инфоблок.

Для добавления филиалов, подразделений, отделов перейдите на страницу Подразделения (Контент > Оргструктура > Подразделения). Нажмите на кнопку Добавить подразделения, расположенную на контекстной панели. Откроется форма создания подразделения (раздела):

Обязательно заполните поле Название подразделения.

Примечание: если создается запись о филиале компании, то в поле Вышестоящее подразделение выберите Верхний уровень, а если создаются подразделения и отделы – выберите филиал, к которому они принадлежат.

Сохраните внесенные изменения. Например, созданная структура может иметь следующий вид:

Для добавления сотрудника в созданное подразделение/отдел перейдите на страницу Список пользователей (Настройки > Пользователи > Список пользователей). Создайте или найдите пользователя в списке. Откройте форму создания (редактирования) пользователя и перейдите на закладку Пользователь. В поле Подразделения укажите, к какому подразделению (филиалу, отделу) принадлежит пользователь, выбрав соответствующее значение в поле:

Добавление сотрудника в созданное подразделение/отдел

Публикация структуры

Для отображения структуры компании в публичном разделе служит компонент Структура компании (bitrix:intranet.structure).

Примечание: Внешний вид и работа с компонентом в публичной части рассмотрена в курсе Пользователь корпоративного портала, урок Структура компании.

Создание визуальной структуры компании

Просмотр структуры компании также возможен с помощью визуального представления. Для этого следует создать новую страницу и разместить на ней компонент Визуальная структура компании (bitrix:intranet.structure.visual).

Примечание: Внешний вид и работа с компонентом в публичной части рассмотрена в курсе Пользователь корпоративного портала, урок Визуальная структура.


График отсутствий
232 / 694

Для представления информации об отсутствующих сотрудниках должен быть создан тип инфоблока, например Оргструктура, и инфоблок График отсутствий, в котором будут храниться записи об отсутствии сотрудников по той или иной причине.

Группы пользователей портала, которые могут создавать/изменять записи, определяются в настройках доступа инфоблока:

Настройка прав доступа к инфоблоку График отсутствий

В данном случае создавать/изменять записи об отсутствующих сотрудниках могут пользователи группы Отдел кадров, а полный доступ к инфоблоку имеют Администраторы и Администрация портала.

Создание записи

Для добавления записи об отсутствии сотрудника перейдите на страницу График отсутствий (Контент > Оргструктура > График отсутствий) и нажмите кнопку Добавить отсутствие, расположенную на контекстной панели. Откроется форма создания новой записи:

Создание записи об отсутствии сотрудника

  • В поле Выберите отсутствующего сотрудника укажите сотрудника, который отсутствует.
  • Выберите Тип отсутствия. Каждому типу соответствует свой цвет на графике.
  • Обязательно заполните поле Причина отсутствия. Введенный текст будет отображен на графике в качестве названия отсутствия сотрудника.
  • Укажите Период отсутствия (поля Начало и Окончание) отсутствия сотрудника.

Сохраните внесенные данные с помощью кнопки Сохранить.

Просмотр в публичном разделе

Для отображения графика отсутствий компании в публичном разделе служит компонент Календарь отсутствий (bitrix:intranet.absence.calendar).

Примечание: Дополнительную информацию о графике отсутствий смотрите в курсе Пользователь корпоративного портала, урок График отсутствий.


Доска почета
233 / 694

Для представления информации о сотрудниках должен быть создан тип инфоблока, например Оргструктура, и инфоблок Доска почета, в котором будут храниться записи о сотрудниках, помещенных на доску почета по той или иной причине.

Чтобы информация о помещенных на доску почета сотрудниках отображалась на портале корректно, следует созданный инфоблок указать в настройках модуля Интранет в поле Инфоблок доски почета:

Настройки модуля Интранет

Группы пользователей портала, которые могут создавать/изменять записи, определяются в настройках доступа инфоблока:

Настройка прав доступа к инфоблоку

В данном случае создавать/изменять записи могут пользователи группы Отдел кадров, а полный доступ к инфоблоку имеют Администраторы и Администрация портала.

Занесение сотрудника на доску почета

Для занесения сотрудника на доску почета в административном разделе перейдите на страницу Доска почета (Контент > Оргструктура > Доска почета) и нажмите кнопку Добавить на доску почета, расположенную на контекстной панели. Откроется форма создания новой записи:

Создание записи о размещении сотрудника на доске почета

  • В поле Выберите сотрудника на доску почета укажите сотрудника, который будет помещен на доску почета.
  • С помощью поля За какие заслуги помещен на доску укажите заслугу, за которую сотрудник помещен на доску почета.
  • Укажите Период нахождения на доске почета (поля Начало и Окончание).
  • Укажите Краткое описание заслуги. Указанный текст будет выведен в качестве заголовка визитки сотрудника на странице просмотра сотрудников, помещенных на доску почета.

Сохраните внесенные изменения с помощью кнопки Сохранить.

Просмотр в публичном разделе

Список отмеченных сотрудников выводится с помощью компонента Доска почета (bitrix:intranet.structure.honour).

Примечание: Подробнее про работу с компонентом в публичной части сайта смотрите в курсе Пользователь корпоративного портала, урок Доска почета.


Обучение
234 / 694

Модуль Обучение позволяет организовать систему дистанционного обучения. Весь функционал модуля доступен Администратору КП. Публикация курсов осуществляется Администратором системы.

Основные понятия

Курс - организованная и логически завершенная последовательность страниц, содержащих информацию о некоторой предметной области.

Средства модуля позволяют при необходимости создавать составные курсы, т.е. материалы одного курса могут быть включены в другой курс (подробнее об этом читайте в уроке Курсы).

Чаще всего по итогам курса проводится тестирование, призванное проверить уровень знаний обучающихся (пользователей, прошедших курс).

Стандартный курс включает следующие элементы:

  • Главы – тематические (смысловые) разделы и подразделы курса. Каждая глава может включать неограниченное количество дочерних элементов: подразделов и уроков, а также относится к нескольким родителям: главам или курсам;
  • Уроки – информационное наполнение курса. Урок может входить в состав одной или нескольких глав или курсов. Каждый урок представляет собой отдельную страницу.
  • В обучающем курсе могут быть заданы вопросы, часть которых может быть использована в тесте для самопроверки. Тест для самопроверки позволяет пользователю оценить степень усвоения материалов урока.
  • По итогам курса вопросы, созданные для отдельных уроков (глав или непосредственно курса), могут быть объединены в проверочный тест (тесты) для оценки освоения пользователями материалов курса. При этом вопросы, участвовавшие в тестах для самопроверки, могут быть исключены из итогового теста.

    Информация обо всех попытках тестирования пользователей хранится в справочнике Список попыток. Записи справочника отражают успешность предпринятых попыток прохождения теста, количество набранных баллов и т.д.

    Данные о результатах тестирования пользователей хранятся в журнале Результаты обучения. Результат – это запись с количеством баллов, набранных пользователем при прохождении теста. Результат определяется по итогам самой успешной из предпринятых пользователем попыток прохождения теста.

    Если результаты тестирования определяются автоматически, то для каждого результата выводится сообщение, сигнализирующее, является ли тест пройденным или нет.

Курсы, созданные с использованием модуля Обучение, могут быть экспортированы во внешний файл для последующей загрузки на другие сайты, работающие на базе системы "Битрикс24 в коробке" или "1С-Битрикс: Управление сайтом". Операции экспорта и импорта выполняются с помощью специальных механизмов модуля Обучение.


Экспорт\импорт курсов
235 / 694

Используя средства системы, можно выполнить экспорт и/или импорт учебного курса в формате .tar.gz. Причем, если для курса созданы вопросы и итоговые тесты, то они также экспортируются (импортируются). Это очень удобно при перемещении курсов с сайта на сайт (например, со старого сайта нужно перенести обучающий курс на новый сайт).

Экспорт курса

Экспорт курса выполняется с помощью специальной формы, расположенной на странице Выгрузка курса (Сервисы > Обучение > Экспорт).

С помощью выпадающего списка выберите учебный курс, который необходимо выгрузить, и нажмите кнопку Далее. Откроется следующий шаг процедуры экспорта.

Укажите имя файла данных курса и нажмите кнопку Начать выгрузку.

Система выполнит выгрузку курса и выведет сообщение о завершении экспорта.

Теперь вы можете, например, загрузить курс с локальной установки продукта на ваш Bitrix Framework.

Примечание: При экспорте курса происходит изменение имен файлов картинок, загруженных в систему, в папку /upload. К существующим именам и в названии самой картинки, и в уроке (в коде вызова этой картинки) добавляется префикс из пяти случайных знаков и разделитель. Пример измененного имени файла: 6or1P.bitrix_blog.png. Это не влияет на правильность отображения картинки в уроке.

Импорт курса в систему

Процедура импорта курса также выполняется в несколько шагов с помощью формы, расположенной на странице Загрузка курса (Сервисы > Обучение > Импорт).

С помощью кнопки Открыть укажите имя и путь к загружаемому файлу данных. В поле Сайты отметьте те сайты, к которым должен быть привязан загружаемый курс. Если импортируется курс в формате SCORM , установите флажок в соответствующем поле. Нажмите кнопку Загрузить данные. Система выполнит загрузку курса и выведет соответствующее сообщение.

Примечание: На данный момент поддержка формата SCORM реализована не полностью. В текущей версии после импорта работает только просмотр курсов с публичной части. Мы планируем дальнейшую реализацию формата, но полноценной работы с курсами в формате SCORM как с курсами, созданными вручную, не будет, это связано с особенностями формата.

Документация по теме:

  • Экспорт курса
  • Импорт курса


Результаты обучения
236 / 694

Результаты обучения можно оценить с помощью соответствующих страниц в разделе Обучение Сервисы > Обучение:

  • Попытки прохождения тестов
  • Результат прохождения теста
  • Сертификаты
  • Пример работы со статистикой

Попытки прохождения тестов

По итогам курса пользователям можно предложить пройти один или несколько тестов для проверки полученных знаний. Попытки прохождения тестов фиксируются на странице Попытки (Сервисы > Обучение > Попытки):

Результат прохождения теста

Результат прохождения теста (по итогам наиболее результативной попытки) отражается на странице Журнал (Сервисы > Обучение > Журнал):

Если тест проверяется не автоматически, то в журнале выводится только количество набранных баллов.

Если включен Контроль неправильных ответов, то прохождение теста завершится при первом же неверном ответе.

В параметрах теста можно задать число попыток прохождения. С помощью поля Дополнительные попытки добавляются попытки конкретному пользователю в конкретном тесте:

  1. С помощью фильтра найдите нужного учащегося и тест;
  2. Поставьте флажок в первой колонке и в панели действий выберите команду Редактировать. Все поля, в которых допустимо редактирование данных, станут активными.
  3. Добавьте нужное число попыток в поле Дополнительные попытки и сохраните изменения.

    4.

    Сертификаты

    Список обучаемых, успешно сдавших тесты, со всеми возможными статистическими данными размещается на странице Сертификация (Сервисы > Обучение > Сертификация):

    С сертификатами можно выполнить следующие действия:

    • активировать/деактивировать
    • изменить данные
    • удалить

    Пример работы со статистикой

    Допустим, мы хотим понять, какой материал хуже всего усвоен тем или иным учащимся.

    Выполним следующие несложные действия:

    1. На странице Список попыток с помощью фильтра находим результаты нужного пользователя и нужного теста:

    2. В отдельных вкладках браузера открываем результаты прохождения каждого теста. Результаты открываются по клику на ссылку в колонке Вопросов.
    3. В каждой открывшейся вкладке сортируем вопросы кликом по колонке Верно отвечен, таким образом, чтобы наверху оказались неверно отвеченные вопросы.
    4. Сравниваем результаты и ищем закономерности:

      5. Важно! Если курс был деактивирован, то результаты тестов и сертификаты по этому курсу будут недоступны пользователям. Если курс был удален, то результаты тестов и сертификаты этого курса будут также удалены.

      Документация по теме:

      • Результаты теста
      • Редактирование результата
      • Попытки
      • Журнал
      • Сертификация


Учебные группы
237 / 694

Начиная с версии 14.0.0 модуля Обучение доступен функционал учебных групп, позволяющий контролировать процесс обучения. Теперь в системе не нужно создавать группы пользователей, которые имели бы доступ к тем курсам, по которым проводится отдельное обучение. Для таких курсов создается учебная группа, в которой указываются время ее работы, доступность материалов в процессе изучения курса и список обучающихся пользователей.

Важно! Если участник учебной группы входит в некоторую группу пользователей, которая обладает правом на курс не ниже Просмотр, то ему всегда будет доступен весь этот курс независимо от настроек учебной группы.

Создание учебной группы

Допустим, что курс, по которому будет проводиться отдельное обучение, уже создан и недоступен для обычных пользователей (иначе весь смысл учебной группы теряется). Теперь можно приступить к созданию и настройке учебной группы.

Перейдите на страницу Список учебных групп (Сервисы > Обучение > Учебные группы) и нажмите кнопку Добавить. Откроется форма следующего вида:

  • Обязательно в соответствующих полях укажите название учебной группы и выберите учебный курс, по которому будет проходить обучение.
  • В поле Период активности задайте временной интервал, в течение которого будет доступен курс для изучения, а также отметьте опцию Запись активна, чтобы обучение могло осуществляться.
  • В поле Состав учебной группы укажите пользователей, которые будут проходить обучение в рамках данной группы.

На закладке Доп. поля можно заполнить имеющиеся пользовательские поля для рабочих групп или перейти к добавлению новых.

Примечание: подробное описание каждого поля представлено в документации по продукту.

Нажмите кнопку Применить, чтобы получить доступ к настройкам графика открытия разделов курса и продолжить редактирование учебной группы. Если вам не требуется настройка графика или вы хотите сделать это позднее, то нажмите Сохранить.

Настройка графика открытия разделов курса выполняется для всех глав/уроков верхнего уровня:

Для каждой главы (урока) указывается, через сколько дней после начала обучения она станет доступной. После того, как график составлен, не забудьте сохранить настройки учебной группы.

В результате до наступления начала обучения курс будет недоступен для пользователей, а затем откроется в соответствии с настройками графика.


Создание и редактирование курсов
238 / 694

Управление курсами осуществляется с помощью команд на странице Список курсов (Сервисы > Обучение):

Все операции по созданию и редактированию курсов можно выполнять как из публичного раздела при включенном режиме Правка, так и из административного раздела. При работе из публичного раздела будет доступно такое меню:

Формы создания курсов, уроков, тестов и вопросов идентичны для публичной и административной частей. В главе будет рассмотрена работа в административной части.

Примечание: в форме создания вопроса, вызванной из публичной части, нельзя сменить тип вопроса.

Советы:
  • При редактировании в публичном разделе при включенном режиме Правка любую форму можно открыть двойным быстрым кликом по странице.
  • Рекомендуется настроить формы редактирования глав и уроков (по аналогии с механизмом настройки форм инфоблоков), удалив не нужные поля и закладки, и изменив расположение оставшихся полей в нужном порядке.


Курсы
239 / 694

Создание курса

Управление учебными курсами осуществляется на странице со списком обучающих курсов (Сервисы > Обучение > Курсы):

Для добавления нового курса служит кнопка Добавить курс, расположенная на контекстной панели. Переход к редактированию существующей записи осуществляется с помощью меню действий (пункт Изменить).

Форма создания/редактирования курса состоит из нескольких закладок:

  1. На закладке Курс задаются основные параметры учебного курса.

    А также настроить рейтинг на страницах курса (опции Включить рейтинг и Вид кнопок рейтинга).

    Важно! Если курс был деактивирован, то результаты тестов и сертификаты по этому курсу будут недоступны пользователям. Если курс был удален, то результаты тестов и сертификаты этого курса будут также удалены.

  2. На закладке Анонс задается описание для анонса курса, которое отображается на странице со списком курсов.
  3. Подробное описание курса, которое отображается на странице детального просмотра курса, задается на закладке Подробно.
  4. На закладке Права доступа выполняется настройка прав доступа пользователей и групп пользователей к курсу (подробную информацию об уровнях прав доступа смотрите в документации по продукту).

    На закладке перечисляются пользователи и группы пользователей, для которых настроены права доступа к модулю Обучение. Эти записи отредактировать невозможно, поскольку права доступа на модуль перекрывают права доступа на курс. Таким образом, если пользователям и группам пользователей уже установлены права на модуль Обучение, то они обладают этими же правами доступа и на все курсы системы.

    Настройка прав доступа к курсу некоторым другим пользователям и группам пользователей выполняется с помощью ссылки Добавить. По ее нажатию открывается окно выбора пользователей и групп.

    Выберите пользователей или группы, для которых настраиваются права доступа, и задайте для них нужный уровень прав.

    Примечание: обычно при создании курса доступ к нему предоставляется только для тех групп, пользователи которых осуществляют создание. После того, как курс готов, его делают доступным для всех необходимых групп пользователей.
  5. Дополнительные поля для курса настраиваются на закладке Доп. поля. Здесь можно задать иконку для курса, добавить файлы к материалам курса, указать, за сколько дней предупреждать о закрытии курса и прекращать тестирование и т.д.

  6. В форме редактирования курса доступна еще одна закладка - Связи:

    На данной закладке указываются все взаимосвязи курса: какие главы (уроки) или, может быть, целый курс содержится в текущем курсе, а также включен ли этот курс в какой-нибудь другой курс/главу.

    Примечание: курсы, главы и уроки могут быть как родительскими, так и дочерними элементами по отношению друг к другу.

    По ссылке Добавить элемент, расположенной в списке родительских элементов, с помощью специального окна выбирается курс, к которому необходимо привязать текущий курс. По одноименной ссылке, но расположенной в списке дочерних элементов, привязываются к курсу как любые главы и уроки из других курсов, так и целиком некоторый курс.

    7. Документация по теме:

    • Список курсов, глав и уроков
    • Создание и редактирование курса


Главы и уроки
240 / 694

Начиная с 12-ой версии продукта, курсы, главы и уроки могут быть как родительскими, так и дочерними элементами по отношению друг к другу, т.е. доступна возможность привязки курсов, глав и уроков к любым уже имеющимся в системе главам и курсам.

При этом один и тот же урок может быть привязан к нескольким главам разных курсов. Это очень удобно, когда у Вас есть несколько курсов на схожие тематики. Можно создать один урок с общей для всех курсов информацией и привязать его сразу ко всем этим курсам. Как пример - урок "Как отформатирован текст в курсе", который прикреплен ко всем обучающим курсам «1С-Битрикс». И когда Вы правите этот урок в одном из курсов, то текст правится сразу во всех курсах, к которым он прикреплен.

Когда создается новая глава, она считается просто уроком. И только тогда, когда в нее будет добавлен хотя бы один урок, она становится полноценной главой. Аналогично, если некоторый урок А сделать вложенным в урок Б, то урок Б становится главой. Если же из главы удалить единственный урок, то она превращается в урок.

Создание глав и уроков

Прежде чем приступить к созданию главы (или урока), необходимо перейти в тот раздел курса, где она (он) должна находиться:

  • если в верхнем уровне курса, то перейдите на страницу Сервис > Обучение > Курсы;
  • если в некоторой главе курса, то перейдите на страницу Сервис > Обучение > Курсы > название_главы.

Примечание: в продукте доступна возможность создания свободных глав и уроков, т.е. не привязанных ни к одному курсу или главе. Создание свободных глав/уроков выполняется со страницы Список всех уроков (Сервис > Обучение > Список всех уроков) с помощью кнопки Добавить главу/урок. Привязка к курсу или главе может быть выполнена позже с помощью настройки связей.

Перейти к созданию главы или урока курса можно с помощью кнопки Добавить главу/урок, расположенной на контекстной панели, либо с помощью ссылки [+], расположенной в столбце Всего глав (или Всего уроков):

Примечание: ссылка [+] встречается не только в списке глав/уроков. Она встречается и в других списках системы. Означает она то, что с ее помощью можно создать еще один элемент той или иной сущности. В нашем случае эта ссылка позволяет перейти к созданию подраздела или урока для выбранной главы.

В форме создания главы/урока указываются:

  • основные параметры главы или урока, среди которых обязательно задается название главы или урока (как оно будет отображаться в меню курса в административном и публичном разделах);
  • краткое описание и детальное содержание главы/урока на закладках Анонс и Содержание соответственно;
  • дополнительные поля для глав и уроков курса на закладке Доп. поля.
Внимание! При установке галочки "Не публиковать" данная глава/урок не будет отображаться в списке уроков курса при настройке тестов и к ней невозможно будет привязать тест. Нужно сначала задать такую привязку и лишь затем снимать отметку "Не публиковать".

Примечание: полное описание формы создания и редактирования главы/урока представлено в документации по продукту.

После сохранения урок (или будущая глава) будет добавлен в общий список глав и уроков соответствующего уровня:

Процесс создания урока на этом полностью завершен. Для создания полноценной главы необходимо повторить описанный выше процесс по созданию урока внутри создаваемой главы либо в форме редактирования главы добавить ей дочерние элементы.

Переход к редактированию существующей главы/урока осуществляется с помощью меню действий (пункт Изменить). В форме редактирования главы/урока дополнительно доступны 2 закладки: Связи и Права доступа. Сначала рассмотрим подробно закладку Связи:

В списке родительских элементов указываются курсы/главы, к которым принадлежит редактируемая глава/урок, а в списке дочерних - главы и уроки, включенные в текущую главу (урок).

Чтобы привязать редактируемую главу/урок к другим курсам/главам или, наоборот, включить в главу имеющиеся в системе главы и уроки, выполните следующие действия:

  1. Нажмите на соответствующую ссылку Добавить элемент. Откроется окно со списком всех имеющихся в системе курсов, глав и уроков.
  2. Выберите необходимый курс, главу или урок с помощью меню действий (пункт Выбрать) или двойного клика по соответствующей записи.

    3. Созданная связь отобразится в форме редактирования главы/урока.

    Статус "Не публиковать" устанавливается для каждого родительского курса отдельно.

    Внимание! Один и тот же урок нельзя сделать дочерним несколько раз в рамках одного курса.

    Чтобы отвязать главу/урок от какого-нибудь родителя или открепить некоторые вложенные элементы, удалите соответственно запись о родительском или дочернем элементе по кнопке x, расположенной рядом с названием элемента.

    На закладке Права доступа для главы или урока можно выполнить отдельную настройку прав доступа пользователей и групп пользователей.

    На закладке перечислены пользователи и группы пользователей, для которых настроены права доступа к модулю Обучение. Эти записи отредактировать невозможно, поскольку права доступа на модуль перекрывают права доступа на курс, главы и уроки. Таким образом, если пользователям и группам пользователей уже установлены права на модуль Обучение, то они обладают этими же правами доступа и на все курсы системы, главы и уроки.

    Кроме того, права на курс (главы) перекрывают права на вложенные главы и уроки. Например, если пользователям и группам заданы некоторые права на курс (главы), а на вложенные главы и/или уроки установлены меньшие права, то этим пользователям и группам вложенные главы и уроки будут доступны в соответствии с правами на курс (вышележащие главы). Если же на некоторые главы (уроки) заданы большие права, чем на курс (главу), то конечные права на главы (уроки) суммируются.

    Настройка прав доступа к главе (уроку) дополнительным пользователям и группам пользователей выполняется с помощью ссылки Добавить. По ее нажатию открывается окно, в котором выбираются необходимые пользователи и/или группы, а затем для них указываются нужные права доступа.

    Документация по теме:

    • Список курсов, глав и уроков
    • Создание и редактирование главы/урока


Тесты
241 / 694

Создание тестов

Тесты для оценки знаний пользователей создаются на основе вопросов, задаваемых к урокам курса. Главное отличие итоговых тестов в том, что вся информация об их прохождении строго фиксируется (количество попыток, число набранных баллов и т.д.).

Тест для самопроверки служит (как это уже понятно из названия) для проверки обучающимся того, как он усвоил материал. Это не итоговая проверка знаний, а промежуточная, без сбора информации о прохождении конкретных пользователей. Тест для самопроверки генерируется автоматически из созданных вопросов, если у них при создании было отмечено поле Для самопроверки.

По этой ссылке откроется вопрос для самопроверки:

Параметры итогового теста для оценки знаний пользователей, прошедших курс обучения, задаются в форме создания теста.

Работа с тестами

Управление тестами курса осуществляется на странице Тесты (Сервисы > Обучение > Курсы > название_курса > Тесты):

Для создания нового теста служит кнопка Добавить тест, расположенная на контекстной панели. В открывшейся форме необходимо задать параметры теста. Параметры сгруппированы по назначению:

  1. Добавление вопросов в тест выполняется на основе параметров, указанных в поле В тесте участвуют. Уроки и подуроки могут быть выбраны из списка, только если они активны и в их параметрах не отмечена опция "Не публиковать".
  2. По умолчанию вопросы, участвующие в тесте для самопроверки, не включаются в проверочный тест. Чтобы включить данные вопросы в тест, нужно отметить соответствующую опцию.
  3. Настройки теста позволяют определить порядок вывода вопросов и ответов на них.
  4. Возможно ограничение количества попыток и времени, предоставляемых пользователю на одну попытку и между попытками.
  5. Чтобы проверка результатов теста выполнялась автоматически (т.е. для того чтобы в журнале выводилось сообщение, является ли тест пройденным или нет), нужно отметить соответствующую опцию и ввести процент вопросов, на которые необходимо ответить правильно для успешного прохождения теста. Проценты вводятся в целых числах.
  6. Настройки прохождения теста задаются в поле Тип прохождения теста.
  7. Дополнительные условия теста могут задать порядок прохождения теста в группе тестов учебного курса и другие условия.

Примечание: подробное описание формы создания и редактирования теста представлено в документации по продукту.

Документация по теме:

  • Тесты
  • Создание и редактирование теста


Вопросы
242 / 694

Создание вопросов

В обучающем курсе есть возможность создать вопросы для двух типов тестов:

  • тест для самопроверки
  • итоговый тест

Вопросы создаются как самостоятельные объекты, которые можно включать в тот или иной тест.

Вопросы по материалам курса могут быть привязаны непосредственно к курсу (т.е. созданы в самом верхнем уровне), к главам или урокам курса. Вопросы для самопроверки логичнее создавать для урока, чтобы сперва изучить материал, а затем пройти тест для самопроверки.

Перейти к созданию вопроса можно следующими способами:

  • с помощью ссылки "+", расположенной в столбце Вопросов на странице со списком уроков/глав/курсов (Сервисы > Обучение > Курсы> Название курса):

  • с помощью кнопки Добавить вопрос, расположенной на странице со списком всех вопросов определенного урока/главы/курса (Сервисы > Обучение > Курсы> Название курса > Вопросы):

Если вы осуществляете переход к созданию вопроса с помощью кнопки Добавить вопрос, то следует сразу выбрать тип вопроса:

  • одиночный выбор - в списке предложенных вариантов ответов может быть выбран только один ответ;
  • множественный выбор - в списке предложенных вариантов ответов может быть выбрано несколько ответов.
  • сортировка - в списке предложенных вариантов ответов необходимо расставить ответы в нужном порядке;
  • текстовый ответ - выводится текстовое поле для самостоятельного ответа обучаемым.

    Примечание: для вопросов данного типа доступна возможность отправки письма с ответом преподавателю (т.е. автору) урока. Причем вы можете внести изменения в почтовый шаблон и добавить получателей, которым будет отправляться данное письмо. Оно отправляется по событию NEW_LEARNING_TEXT_ANSWER (Настройки > Настройки продукта > Почтовые события > Типы почтовых событий).

В остальных случаях необходимый тип вопроса указывается в момент создания вопроса с помощью специальной формы создания (редактирования) вопроса. На закладке Вопрос данной формы указывается текст самого вопроса:

Если вам требуется изменить привязку вопроса к уроку, то в поле Урок нажмите ссылку сменить. Откроется окно выбора главы/урока, к которому вопрос должен быть привязан.

Для включения вопроса в тест для самопроверки (данный тест будет доступен пользователям после изучения материалов урока, указанного в поле Урок) отметьте поле Для самопроверки.

Если на вопрос обязательно нужен правильный ответ, то выберите соответствующую опцию Обязателен правильный ответ.

Также при неправильном ответе можно выводить сообщение, которое указывается в поле Сообщение при неправильном ответе.

К вопросу можно добавить изображение с помощью кнопки Добавить файл.

На закладке Ответы указываются варианты ответов на вопрос.

Примечание: Если необходимо добавить больше четырех ответов, то следует нажать кнопку Добавить ответ для добавления поля ответа.

В поле Сорт. указываются порядок отображения ответов в вопросе (сортировка будет учитываться, если в тесте, в котором содержится данный вопрос, отключена опция Случайный порядок ответов).

Важно! Не забудьте отметить правильный вариант (варианты) ответа на вопрос.

Для удаления ответа необходимо нажать кнопку [image] рядом с соответствующей записью.

На закладке Описание можно более подробно описать вопрос, а на закладке Доп. поля заполнить имеющиеся пользовательские поля для вопросов или перейти к добавлению новых полей.

После сохранения вопрос будет добавлен в общий список вопросов урока/главы/курса:

Документация по теме:

  • Вопросы
  • Создание и редактирование вопроса


Опросы, голосования
243 / 694

Модуль Опросы, голосования предназначен для организации на портале различных опросов и голосований. Использование инструментов модуля позволяет создавать группы опросов, ограничивать доступ сотрудников к голосованиям (например, запрещать одному и тому же сотруднику голосовать дважды в рамках одного опроса), управлять показом результатов голосований и т.п.

Использование механизма разграничения прав доступа дает возможность управлять доступом сотрудников к участию в тех или иных опросах и голосованиях, а также к просмотру данных о ходе голосований и их результатов.

Управление параметрами опросов и голосований позволяет:

  • ограничивать период проведения опросов;
  • предлагать посетителям на выбор несколько вариантов ответов на вопрос;
  • предоставлять сотрудникам возможность вводить собственные ответы на вопросы;
  • управлять видом результирующих графиков и диаграмм;
  • и т.д.

Для создания опросов достаточно прав группы Администрация портала. Для публикации опроса в публичном разделе нужно быть администратором системы.

В рамках Битрикс24 опрос существует как сам по себе, в виде модуля Опросы и как часть возможностей чего-либо, например, Живой ленты. (В рамках облачных редакций Опрос - это только часть функционала другой сущности.)

Различие этих двух видов опросов:

  • Как самостоятельный функционал Опрос доступен только в коробочной версии Битрикс24. И действует он в рамках срока активности, заданного при создании опроса.
  • Как часть функционала Живой ленты опрос доступен в обоих версиях (коробочной и облачной), и его можно остановить из самой Живой ленты:

    • © «Битрикс», 2001-2008, «1C-Битрикс», 2008-2020 1С-Битрикс


Подписка, рассылки
244 / 694

Возможности модуля Подписка, рассылки позволяют решать любые задачи, связанные с организацией рассылки почтовых сообщений с портала. Рассылка сообщений дает возможность информировать пользователей о достижениях компании, новых направлениях в ее деятельности, предоставляемых услугах, планируемых акциях и т.д.

Могут быть созданы два вида рассылок:

  • публичные – сотрудникам предоставляется возможность самостоятельно оформлять подписку на интересующие их рубрики, а также изменять параметры уже оформленной подписки.

    Подписка может быть оформлена как зарегистрированными, так и незарегистрированными (анонимными) пользователями.

  • закрытые – подписка пользователей на закрытые рассылки выполняется Администратором КП либо Администратором системы.

Система поддерживает два режима отправки выпусков рассылок:

  • ручной – при создании выпуска определяется, на какие рассылки будет отправлено сообщение подписчикам.
  • автоматический – генерация и рассылка сообщений выполняется автоматически по заданному шаблону и расписанию (в указанные дни и время суток).


Рассылки
245 / 694

Что такое рассылки, выпуски и подписчики?

Рассылки - это тематические рубрики, на которые могут подписаться посетители Bitrix Framework. Возможна одновременная подписка на несколько рассылок.

Подписчики - посетители Bitrix Framework, подписавшиеся на рассылки. Подписчики могут быть как зарегистрированными пользователями, так и анонимными. Анонимными подписчиками признаются подписчики, не зарегистрированные в Bitrix Framework.

Выпуски - почтовые сообщения, рассылаемые подписчикам. Выпуск может быть направлен:
  • Подписчикам на определённые рассылки;
  • Пользователям определённых групп прав;
  • На произвольные адреса.

Управление рассылками осуществляется на странице Список рассылок (Сервисы > Рассылки > Список рассылок):

Нажмите на рисунок, чтобы увеличить

Новая рассылка создаётся по кнопке Добавить. Редактируется рассылка с помощью команд меню действий либо с помощью двойного клика по соответствующей записи.

Какие бывают рассылки

Рассылки различаются по следующим критериям: доступности и способу отправки.

Доступность:

  • публичные – пользователи самостоятельно оформляют подписку на интересующие их рубрики, а также изменяют параметры уже оформленных подписок. Подписка может быть оформлена как зарегистрированным, так и анонимным пользователем.
  • закрытые – подписка пользователей на закрытые рассылки выполняется администратором.

Способ отправки:

  • ручной – при создании выпуска определяется на какие рассылки будет отправлено сообщение подписчикам.
  • автоматический – генерация и рассылка сообщений выполняется автоматически по заданному шаблону и расписанию (в указанные дни и время суток).

Документация по теме:

  • Список рассылок
  • Создание и редактирование рассылки
  • Проверка шаблона рассылки
  • Настройки модуля


Импорт адресов
246 / 694

Как загрузить имеющуюся базу подписчиков

Если у вас уже есть база подписчиков, то её можно загрузить на сайт с помощью несложного импорта, не прибегая к ручному вводу адресов. Для этого перейдите на страницу Импорт адресов (Сервисы > Рассылки > Импорт адресов), заполните поля формы и дайте команду на импорт.

Нажмите на рисунок, чтобы увеличить

Отметим некоторые особенности этой формы:

  • Импорт адресов рассылки делается как с помощью файла с адресами, так и вручную из списка.
  • Можно выслать код подтверждения или автоматически подтвердить подписку, если она была не подтверждена подписчиком.
  • Подписчики рассылок могут быть добавлены как анонимные посетители или как зарегистрированные пользователи сайта (заводится аккаунт каждому пользователю).
  • Новым подписчикам можно высылать регистрационную информацию и автоматически заносить в группы на сайте .
  • Также есть возможность автоматически подписать на рассылку из списка и выбрать формат отображения.

Примечание: Подробное описание всех параметров формы см. в компонентне Импорт адресов .

Документация по теме:

  • Импорт адресов


Автоматическая рассылка
247 / 694

В главе описывается порядок создания автоматической рассылки и приводится пример.


Как создать автоматическую рассылку
248 / 694

Видео-пример создания рассылки (ручной и автоматической)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Как создать автоматическую рассылку

Чтобы генерация и отправка выпусков выполнялись в автоматическом режиме, при создании рассылки в форме создания рассылки нужно установить флаг в поле Автоматическая . После этого станет доступна закладка Автоматическая генерация, на которой указывается следующее:

  • Расписание, по которому будут выполняться генерация и отправка сообщений рассылки.

    • Внимание! Необходимо задать значение хотя бы одного из параметров: дней недели либо чисел месяца. Если одновременно были заданы и дни недели, и числа месяца, то генерация выпусков будет происходить при календарном совпадении данных параметров. Например, если был выбран день недели Пт. и задано число месяца 10, то генерация выпусков будет происходить в том случае, если десятое число месяца выпадает на пятницу.

  • Шаблон, на основе которого будут генерироваться выпуски (сообщения) рассылки. В шаблоне рассылки определяется:
    • внешний вид сообщений;
    • информация, размещаемая в сообщении.
  • Адрес, который будет подставляться в поле От кого отправляемых сообщений. Если адрес не будет указан, то будет использоваться адрес, указанный в настройках модуля Подписка, рассылки . Если в настройках модуля Подписка, рассылки поле От кого не заполнено, то подставляется адрес, указанный в настройках Главного модуля.


Просмотр выпуска
249 / 694

Как просмотреть выпуск автоматической рассылки

После сохранения параметров рассылки рекомендуем проверить вид выпуска, в котором он будет отправлен подписчикам. Откройте рассылку на редактирование и воспользуйтесь кнопкой Проверить . Эта кнопка откроет страницу с параметрами шаблона. Если параметры верны, то можно приступать к проверке внешнего вида. Этому служит зелёная кнопка Проверить.

Если проверка прошла, то вы увидите форму, где:

  1. входные параметры шаблона;
  2. сообщение в том виде, в котором оно будет отправлено подписчикам;

    Примечание: если в сообщении содержатся динамические данные (например, выборка новостей), то в сообщении будет размещена выборка данных за промежуток времени между датами последней и последующей генерации сообщения. При этом в настройках инфоблока, используемого в рассылке, поле Начало активности должно иметь значение по умолчанию Текущие дата и время.

  3. параметры выпуска.
  4. Добавить выпуск - c помощью этой кнопки сообщение, сгенерированное на основе выбранного шаблона, может быть сохранено в списке выпусков, а затем отправлено вручную.

Если проверка не пройдена, то отобразится сообщение с указанием ошибок:

Вернуться к форме настройки созданной рассылки можно с помощью кнопки Редактировать .

Создание и редактирование шаблонов рассылки может выполнять только Администратор.


Ручная рассылка
250 / 694

В общих чертах процесс управления «ручной» рассылкой почтовых сообщений может быть описан следующей последовательностью действий:

  • создание тематической рассылки;
  • организация подписки на созданную рассылку;
  • создание почтовых сообщений рассылки;
  • отправка почтовых сообщений.


Организация подписки на рассылку
251 / 694

Как подписываются на рассылки?

Оформление подписки на рассылку делается:

  • самостоятельно пользователем, если рассылка публичная;
  • администратором (если рассылка является закрытой, то есть недоступной из публичного раздела).

Подписаться самостоятельно

Чтобы пользователь мог оформлять подписку самостоятельно, в шаблоне сайта или на нужных страницах сайта должен быть размещен компонент Форма подписки (sender.subscribe). После того, как подписчик укажет в нём свой почтовый адрес и подтвердит своё желание получать сообщения, он сможет выбрать список рассылок, которые ему интересны, на странице Подписка профиля пользователя (Профиль > Подписка) в публичной части.

По умолчанию на этой странице отображаются активные рассылки, для которых было отмечено поле Выводить в списке публичных рассылок . При желании можно вывести и скрытые рассылки. Для этого нужно в настройках используемого компонента отметить опцию Показать скрытые рассылки для подписки.

После оформления подписки для пользователя-подписчика создается учетная запись в модуле Подписка, рассылки на странице Сервисы > Рассылки > Подписчики:

Нажмите на рисунок, чтобы увеличить .

Эта запись содержит данные подписчика , а также информацию о выбранных пользователем рассылках. При необходимости администратор может изменить бюджет подписчика (например, отписать его от какой-либо рассылки или подтвердить подписку вручную).

Подписка пользователя администратором

Администратор добавляет в систему подписчика с помощью кнопки Добавить на контекстной панели страницы Список подписчиков (Сервисы -> Рассылки -> Подписчики). Открывается форма добавления подписчика:

На закладке Подписчик вводятся данные о подписчике:

    1 - Чтобы подписчик мог получать выпуски рассылок, Администратор должен подтвердить подписку в поле Подписка подтверждена.

    2 - Если подписчик является анонимным, то достаточно указать адрес в поле E-mail на который будет выполняться рассылка выпусков;

    3 - Если подписчик является зарегистрированным пользователем, то его ID вводится либо прямо в поле Пользователь, либо выбирается с помощью кнопки [image] из структуры сайта.

На закладке Подписки выбираются рассылки , на которые подписывается пользователь, а также формат отправляемых сообщений.

Документация по теме:

  • Подписчики
  • Создание и редактирование подписчика


Управление выпусками ручной рассылки
252 / 694

Выпуск - это почтовое сообщение, отправляемое подписчикам на те или иные рассылки.

Каждая рассылка может разослать бесконечное число выпусков. Создав рассылку вы создали, образно говоря, телеканал, передачами в котором служат выпуски. Создание выпусков выполняется для ручных рассылок. Выпуски для автоматических рассылок генерируются системой по заданному расписанию на основе выбранного шаблона.

Видео-пример создания выпуска ручной рассылки

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Создание выпуска

Управление выпусками осуществляется на странице Список выпусков (Сервисы > Рассылки > Выпуски):

Нажмите на рисунок, чтобы увеличить

По клику на кнопке Добавить откроется форма создания выпуска, состоящая из нескольких закладок. Заполните эти закладки

  • Закладка Выпуск служит для создания самого информационного сообщения.

    Нажмите на рисунок, чтобы увеличить

    Для правильной отправки сообщения необходимо заполнить поля с адресами отправителя и получателя сообщения по умолчанию, а также темой сообщения. Если поля отправителя и получателя не будут заполнены, то они возьмутся из настроек модуля Подписки, рассылки либо из настроек Главного модуля.

  • На закладке Получатели выбираются получатели выпуска:
    • подписчики рассылок;
    • пользователи определенных групп;
    • дополнительные получатели. это поле для ситуации когда надо создать рассылку для незарегистрированных пользователей (например, новостей сайта). Просто введите в него нужные адреса.

    Примечание: с помощью фильтра можно наложить условия на адреса, по которым будет разослано сообщение. Например: %@bitrixsoft.ru.

  • На закладке Вложения выбираются файлы для отправки получателям выпуска в виде вложений.
  • На закладке Параметры указываются параметры отправляемого сообщения.

    Чтобы в поле Кому отправляемого сообщения указывался адрес отдельного получателя сообщения, следует выбрать опцию Отправлять письмо персонально каждому получателю.

    Примечание: система также позволяет отправить выпуск автоматически. Для этого нужно:
    • установить флаг в поле Отправить автоматически в указанное время;
    • затем указать дату и время, в которое будет отправлен выпуск;
    • подтвердить отправку сообщения с помощью кнопки Отправить.

Созданный выпуск может быть:

  • сохранен в статусе Черновик с помощью кнопки Сохранить или Применить;
  • отправлен непосредственно после создания с помощью кнопки Отправить.


Социальная сеть
253 / 694

Модуль Социальные сети предназначен для формирования сообществ на корпоративном портале, организации совместной работы сотрудников (рабочие группы, обсуждения, блоги, календари, фотогалереи, общие файлы), укрепления связей внутри сообществ, обмена мгновенными сообщениями внутри портала по типу популярной ICQ.

В рамках Социальной сети Администратор КП не может только создавать страницы для размещения на них компонентов модуля.

Примечание: При создании публичного интерфейса социальной сети можно использовать два отдельных компонента Социальная сеть - пользователь (bitrix:socialnetwork_user) и Социальная сеть - группы (bitrix:socialnetwork_group).


Настройки модуля
254 / 694

Управления общими настройками модуля выполняется на странице Настройки > Настройки продукта > Настройки модулей > Социальная сеть:

На закладке Настройки модуля социальной сети содержатся глобальные настройки модуля:

  • Следить за всеми сообщениями Живой ленты по умолчанию - при отмеченной опции в социальной сети каждое новое событие (комментарий, сообщение и т.п) будет "поднимать" данное событие наверх Живой ленты. Пользователь сам решает следить или нет с помощью кнопки Больше не следить под сообщением Живой ленты. При отключенной опции, чтобы следить за событием, необходимо нажать кнопку Следить под нужным сообщением Живой ленты.
  • Разрешать адресовать "Всем" сообщения в Живой ленте - при отмеченной опции появляется возможность указать пользователей или группы пользователей, которым разрешено адресовать сообщения для всех пользователей портала.
  • Отображать адресацию "Всем" по умолчанию - при отмеченной опции будет включена адресация Всем по умолчанию при создании сообщения. Опция появляется при включенной опции Разрешать адресовать "Всем" сообщения в Живой ленте.
  • Отображать в Живой ленте по умолчанию только мои записи, записи моих групп и адресованные лично мне - опция включает режим, при котором выбираются только записи, события, относящиеся к рабочим группам пользователя, а также его собственные или адресованные лично ему.

    Примечание: Эта опция доступна только в продукте «1С-Битрикс: Управление сайтом».

    Режим включается/выключается как глобально, так и каждым пользователем в Живой ленте (пункт Только мои группы в меню Все сообщения).

Параметры, настраиваемые для каждого сайта в отдельности
  • Для включения функционала Друзья установите флаг в поле Разрешить функционал друзей.
  • С помощью полей Шаблон пути для темы групп и Шаблон пути для группы задаются шаблоны адресов для тем групп и групп.
  • В поле Путь к странице сообщений пользователя указывается адрес страницы к просмотру переписки с пользователями.
  • В поле Свойства пользователя для показа во всплывающей информационной карточке выбираются свойства пользователя, которые должны быть отображены во всплывающей карточке.
  • Дополнительные свойства пользователя, которые должны быть показаны во всплывающей информационной карточке, указываются соответственно в поле Доп. свойства пользователя для показа во всплывающей информационной карточке.
  • С помощью опций Выводить рейтинг во всплывающей информационной карточке и Использовать рейтинг включаются использование рейтингов в карточках пользователя и указываются их виды.
  • С помощью секции Настройки для пользователей вы можете запретить или разрешить использование того или иного функционала на личных страницах пользователей путем установки или снятия флагов в соответствующих полях, а также для каждого функционала задать настройки по умолчанию.
  • Настройка секции Настройки для групп аналогична настройке секции Настройки для пользователей и дополнительно определяет возможность работы с контентом архивных рабочих групп.

Закладка Права на доступ предназначена для настройки прав на доступ групп пользователей к модулю. Возможно назначение следующих прав:

  • [D] Работа в публичной части без права создания групп – пользователям разрешается просмотр страниц социальной сети с возможностью редактирования своего профиля. (По умолчанию стоит у всех групп.)
  • [K] Работа в публичной части с правом создания групп – пользователям разрешается просмотр страниц социальной сети с возможностью редактирования своего профиля и создания рабочих групп.
  • [R] Просмотр административной части – управление элементами социальной сети из публичной части и разрешение просмотра в административном разделе без права модификации.
  • [W] Полный доступ – полный доступ к ресурсам модуля.

Примечание: Управлять определенным функционалом можно как для всех сайтов сразу, так и для конкретных сайтов путем установки флагов в соответствующие поля.

Примечание: Подробнее о настройках модуля Социальная сеть см. Пользовательскую документацию по продукту.

Документация по теме:

  • Настройки модуля


Управление темами групп
255 / 694

В модуле Социальная сеть введено понятие темы групп.

Тема групп – это совокупность рабочих групп, обладающих некоторой общей тематикой, признаком.

Таким образом, чтобы иметь возможность создать рабочую группу, необходимо сначала создать в системе темы групп. Управлять темами групп могут только те пользователи, которые имеют полный доступ к модулю.

Важно! Создание, редактирование и удаление тем рабочих групп осуществляется только в административном разделе.

Создание новой темы

Чтобы создать новую тему групп в административном разделе, перейдите на страницу Сервисы > Социальная сеть > Темы и нажмите кнопку Новая тема на контекстной панели.

Примечание: В корпоративном портале также перейти на страницу тем групп можно, нажав в публичном интерфейсе кнопку [image], предварительно необходимо перейти в режим администратора.

Откроется форма создания новой темы:

Укажите Название темы, выберите Сайт темы, на котором будут доступны рабочие группы данной темы, и задайте индекс сортировки в поле Сортировка. Сохраните внесенные изменения, созданная тема добавится в список тем групп.

Создание новой рабочей группы

Теперь можно создать новую рабочую группу, привязанную к данной теме.

Рабочие группы создаются из публичного интерфейса. В административном разделе они выводятся в списке на странице Группы (Сервисы > Социальная сеть > Группы). В этом списке возможно только удаление группы:

Примечание: в «Битрикс24 в коробке» меню раздела Рабочие группы является динамическим и хранится в файле /workgroups/.left.menu_ext.php. В коде должны быть правильно определены шаблоны путей к теме групп и к группе:

$strGroupSubjectLinkTemplate = COption::GetOptionString("socialnetwork", "subject_path_template", "/workgroups/group/search/#subject_id#/", SITE_ID);
$strGroupLinkTemplate = COption::GetOptionString("socialnetwork", "group_path_template", "/workgroups/group/#group_id#/", SITE_ID);

Документация по теме:

  • Создание и редактирование темы групп


Личная страница сотрудника
256 / 694

Личная страница сотрудника создается с помощью комплексного компонента Социальная сеть - пользователь (bitrix:socialnetwork_user). Компонент позволяет, создавая физически одну страницу, организовать полноценную социальную сеть сотрудников.

Обширные настройки компонента дают возможность:

  • гибко управлять отображаемыми данными пользователей;
  • настраивать ЧПУ и AJAX;
  • управлять функционалом личной фотогалереи, блога, календарей, задач и файлов.

Создайте новую страницу и разместите на ней компонент Социальная сеть - Пользователь (bitrix:socialnetwork_user):

Далее проведите настройку параметров компонента:

  • Настройте параметры по управлению адресами страниц в режиме ЧПУ или без использования ЧПУ (группа свойств Управление адресами страниц).
  • В полях группы свойств Дополнительные настройки отметьте те свойства пользователей, которые должны быть отображены в различных секциях личной страницы или отметьте опцию Не ограничивать набор полей профиля пользователя :

  • Выберите группу блогов, в которой будут храниться блоги пользователей, а также другие настройки блогов:

  • В полях группы свойств Шаблоны ссылок обязательно укажите шаблоны путей к страницам рабочей группы:

    Главную страницу группы необходимо создать с помощью компонента Социальная сеть – группы.
  • В группе свойств Настройки форума укажите форум, в котором будут храниться личные темы и сообщения сотрудников, выберите цветовую тему оформления форума, а также, если необходимо, включите поддержку опросов:

  • Далее в соответствующих группах свойств выполните настройку остальных функционалов социальной сети: Календарь, Задачи, Файлы и Фото.

    Для каждого функционала укажите необходимый тип инфоблока и инфоблок, в котором будут храниться соответственно личные календари событий, задачи, файлы и фотографии сотрудников.

    Например, группа свойств Настройки фото может быть настроена следующим образом:

Примечание: детальное описание каждого параметра компонента приведено в документации по продукту.

После того, как все параметры компонента настроены необходимым для вас образом, сохраните страницу. В результате в публичной части она будет иметь следующий вид:

Вся информация представлена с помощью специальных блоков, управление которыми аналогично настройке персонального рабочего стола. Кнопки Добавить гаджет и Сбросить текущие настройки доступны всем сотрудникам портала. Если пользователь имеет полный доступ к социальной сети, то ему становится доступной кнопка Сохранить как настройки по умолчанию. Данная кнопка позволяет настроить внешний вид по умолчанию для личных страниц пользователей.

На личной странице сотрудника представлена служебная, контактная и личная информация.

Каждый сотрудник может управлять своими данными и настройками доступа к имеющимся функционалам с помощью ссылок Изменить профиль и Изменить настройки соответственно. Ссылка Изменить приватность позволяет настроить уровни доступа к функционалу личной страницы.

Примечание: Если в блоке Управление на закладке Основное нет ссылки Изменить профиль, то необходимо дать права [P] Изменение своего профайла в опции Главный модуль, на закладке Доступ группы (Настройки > Пользователи > Группы пользователей > [группа_пользователей]), в которую входит данный сотрудник.

Ссылка Подписка предназначена для просмотра подписки на обновления групп и сотрудников. Просмотр обновлений групп и сотрудников осуществляется по ссылке Обновления.

Если сотрудник относится к группе пользователей, обладающей правом Работа в публичной части с правом создания групп, то сотрудник может создавать рабочие группы, приглашать в нее других сотрудников.

В зависимости от разрешенных функционалов портала сотрудник сможет размещать фотографии, создавать темы на форуме и сообщения в блоге, управлять персональным календарем, задачами и файловым хранилищем.

Примечание: подробная информация по использованию личной страницы представлена на helpdesk.bitrix24.ru.


Страница рабочей группы
257 / 694

Страница рабочей группы сотрудников создается с помощью комплексного компонента Социальная сеть - группы (bitrix:socialnetwork_group). Компонент позволяет, создавая физически одну страницу, организовать полноценную социальную сеть рабочих групп сотрудников.

Обширные настройки компонента дают возможность:

  • гибко управлять отображаемыми данными групп;
  • управлять функционалом группы: календарем событий, задачами, форумом, блогом, файлами, фотографиями и ее участниками.

Создайте новую страницу, разместите на ней компонент и проведите настройку параметров компонента:

Примечание: настройка основных параметров данного компонента производится аналогично настройке параметров компонента Социальная сеть - пользователь (bitrix:socialnetwork_user) (см. урок Личная страница сотрудника), а настройка параметров поиска информации в рабочей группе выполняется в секции Настройки поиска:

В результате страница детального просмотра группы будет иметь следующий вид:

Вся информация представлена с помощью специальных блоков, управление которыми аналогично настройке персонального рабочего стола. Кнопки Добавить гаджет и Сбросить текущие настройки доступны всем участникам группы. Если пользователь имеет полный доступ к социальной сети, то ему становится доступной кнопка Сохранить как настройки по умолчанию. Данная кнопка позволяет настроить внешний вид по умолчанию для страниц рабочих групп.

Модератор группы, а также администратор портала могут выполнять все операции над группой с помощью ссылок, расположенных под картинкой группы. Участникам группы и сотрудникам компании могут быть доступны лишь некоторые ссылки в соответствии с их правами доступа.

Если необходимо написать текстовое сообщение участникам группы, то следует воспользоваться ссылкой Написать сообщение.

Ссылка Редактировать группу позволяет перейти к странице редактирования параметров группы. Для управления функционалом группы используйте ссылку Изменить настройки. Для удаления группы воспользуйтесь ссылкой Удалить группу.

С помощью ссылки Редактировать модераторов можно управлять составом модераторов. Для управления участниками группы предназначена ссылка Редактировать состав.

Блокировать провинившихся сотрудников рабочей группы можно с помощью ссылки Черный список. Приглашение новых сотрудников в группу осуществляется с помощью ссылки Пригласить в группу.

Ссылка Проверить запросы на вступление в группу позволяет просмотреть сотрудников, желающих вступить в группу, а ссылка Приглашения в группу служит для просмотра отправленных пользователям приглашений на вступление в данную группу. Оформить подписку на обновления можно с помощью ссылки Подписаться.

Примечание: дополнительная информация по рабочим группам представлена на helpdesk.bitrix24.ru.


Смайлы социальной сети
258 / 694

Добавление и редактирование смайлов, доступных для использования в сообщениях социальной сети, осуществляется на странице Смайлики социальной сети (Сервисы > Социальная сеть > Смайлы):

Для добавления нового смайлика служит кнопка Новый смайлик. Для того чтобы отредактировать уже существующий смайлик, воспользуйтесь соответствующим пунктом меню действий.

Форма создания (редактирования) смайлика имеет следующий вид:

Документация по теме:

  • Смайлы
  • Создание и редактирование смайлика


Фотогалерея
259 / 694

Модуль Фотогалерея 2.0 - это современный и удобный инструмент для создания и управления галереями и фотоальбомами сотрудников, рабочих групп и компании в целом. Средства модуля позволяют выполнять массовую загрузку фотографий, проводить голосование, вести обсуждение.


Основные понятия
260 / 694

Работа модуля Фотогалерея 2.0 основана на модуле Информационные блоки. Альбомы и фотографии галерей сотрудников хранятся как разделы и элементы инфоблока.

Таким образом, в системе необходимо создать тип инфоблока, например Фотогалерея, а для всех видов фотогалерей портала - соответствующие инфоблоки. Например:

  • Фотогалерея – для хранения альбомов и фотографий компании. Разделами инфоблока являются альбомы, а элементами – фотографии.
  • Фотогалерея групп – для хранения альбомов и фотографий рабочих групп. Разделами инфоблока являются галереи рабочих групп, подразделами – альбомы групп, а элементами – фотографии.
  • Фотогалерея пользователей – для хранения альбомов и фотографий сотрудников портала. Разделами инфоблока являются персональные галереи пользователей, подразделами – альбомы пользователей, а элементами – фотографии.

Примечание: При наличии установленного модуля Экстранет в списке будут присутствовать еще 2 инфоблока: Фотогалерея групп - экстранет и Фотогалерея пользователей - экстранет.

В результате, созданная структура будет иметь следующий вид:

Доступ к фотогалерее определяется в настройках доступа выбранного инфоблока:

Настройка прав доступа к инфоблоку


Фотогалерея в социальной сети
261 / 694

Настройки в Социальной сети

Для использования фотогалерей в Социальной сети сайта активируйте этот функционал в настройка модуля Социальная сеть на странице Настройки > Настройки продукта > Настройки модулей > Социальная сеть в секциях:

  1. Настройки для пользователей:

    Настройка прав доступа к функционалу

  2. Настройки для групп:

    Настройка прав доступа к функционалу

Далее в этих же секциях задайте права по умолчанию для фотогалерей.

Если сайтов несколько, то управление фотогалереями выполняется отдельно для каждого сайта.

Документация по теме:

  • Настройки модуля "Социальная сеть"


Форум
262 / 694
Грамотно организованный веб-проект обычно позволяет своим посетителям общаться между собой, задавать вопросы, которые могут быть адресованы одновременно посетителям и администрации сайта. Основным средством подобной коммуникации является форум, который может служить также дополнением к обычной службе техподдержки. Кроме того, форум - прекрасное средство привлечения дополнительных посетителей на сайт, поскольку поисковые машины обычно индексируют текстовое содержимое сообщений форума в дополнение к основному содержанию сайта.

Модуль Форум служит для создания и управления форумами сайта. Основные возможности модуля включают:

  • создавать необходимое число форумов;
  • возможность самостоятельно строить и гибко модифицировать публичную часть (внешний вид) форума;
  • регулировать права доступа клиентов на чтение и отправку сообщений в форум;
  • создавать модерируемые и постмодерируемые форумы;
  • назначать модераторами форума группы сотрудников;
  • устанавливать звания (статусы) посетителей в зависимости от количества баллов, присвоенных тому или иному посетителю другими посетителями или полученных им за количество сообщений;
  • управлять настройками форумов и прочее.

В данной главе рассматриваются основные операции по настройке и работе с форумами.


Группы форумов
263 / 694

Группировка форумов

Если на сайте много форумов, то может возникнуть сложность в работе с ними: пойди, найди нужный. Для решения этой проблемы можно сгруппировать форумы по какому-то общему для них признаку.

Группа форумов – это совокупность форумов, обладающих общим признаком, тематикой.

Просмотр уже созданных групп форумов, их редактирование и создание новых выполняется на странице Группы форумов (Сервисы > Форумы > Группы форумов).

Нажмите на рисунок, чтобы увеличить

Создание группы форумов

Для создания группы форумов используйте кнопку Новая группа форумов расположеную на контекстной панели. Для редактирования уже созданной группы выберите соответствующий пункт меню действий.

Форма создания (редактирования) группы форумов очень простая и значение полей ясно из их названия. Поясним только пару из них:

  • Сортировка – индекс сортировки, который определяет положение группы в списке. Чем меньше значение сортировки, тем выше в списке будет отображаться группа форумов.
  • Родительская группа – указывается группа, в которую будет вложена данная группа форумов. Выбор многоточия означает верхний уровень вложенности.

Документация по теме:

  • Группы форумов
  • Создание и редактирование группы


Форумы: создание и управление
264 / 694

Управление форумами

Управление форумами осуществляется, как правило, в Административном разделе. Создание новых форумов возможно только в административном разделе. Список всех форумов размещается на странице Список форумов (Сервисы > Форумы > Список форумов):

Нажмите на рисунок, чтобы увеличить

Создание форума

Для создания нового форума используется кнопка Новый форум, расположенная на контекстной панели. Откроется форма создания форума. Поясним поля формы, значение которых может не совсем понятно из названия или имеет особенности.

  1. на закладке Форум :
    • Активность - при отмеченной опции форум будет включен. Если форум неактивен, то он доступен только пользователям с правами на полный доступ к ним.
    • Сайты, на которых доступен форум (Шаблон пути к сообщению на сайте) - укажите сайт(ы), на которых доступен форум и шаблон пути к сообщению.
  2. на закладке Настройки :
    • Индексация - установленный флажок разрешает индексировать поиском сообщения форума;
    • Модерация - при отмеченной опции сообщения пользователей будут публиковаться на сайте только после проверки модератором;
    • Одинаковые сообщения в теме - запрет создания двух одинаковых сообщений в теме;
    • Сортировать по и Направление сортировки - выберите вариант сортировки сообщений, а также направление сортировки;
    • Позволить загрузку - разрешить загрузку присоединенных к сообщению файлов указанного типа;
    • Допустимые расширения загружаемых файлов - расширения файлов, разрешенных к загрузке;
    • Пользовательские настройки - при отмеченных опциях для незарегистрированных пользователей будет запрошен e-mail при добавлении сообщения и будет использована CAPTCHA;
    • Регистрация новых сообщений в модуле статистики - здесь настраиваются идентификаторы, с использованием которых создание нового сообщения на форуме будет регистрироваться в модуле Веб-аналитика;
    • Настройки парсера - указываются дополнительные настройки форума: ссылки, изображения, видео, теги, HTML-код, смайлики и т.д.

  3. на закладке Доступ определите права доступа к форуму для групп пользователей:
    • Нет доступа - запрет на доступ к форуму.
    • Чтение - доступ на чтение сообщений форума без права создания новых тем.
    • Ответ - доступ к обсуждению тем без права создания новых тем.
    • Новая тема - доступ к обсуждению и созданию тем.
    • Модерирование - доступ к модерации форума. Например, модераторы могут скрыть или показать сообщение, но не могут отредактировать или удалить его. Члены группы с этим уровнем прав имеют возможность подписаться на получение копии всех сообщений форума по почте.
    • Редактирование - доступ к управлению чужими сообщениями на форуме.
    • Полный доступ - полный доступ к форуму, включая доступ к настройкам форума и прав доступа.

Чтобы отредактировать форум воспользуйтесь пунктом контекстного меню Изменить , откроется форма, аналогичная форме создания.

Корректировка шаблонного текста

Частая задача администратора - корректировка шаблонного текста страниц Помощь по форуму и Правила форума. Простой вариант решения этой задачи:

В свойствах комплексного компонента bitrix:forum в группе параметров Основные настройки убираем флажок в поле Использовать простой режим настройки. Появляются поля Путь к файлу, содержащему "Правила форума" и Путь к файлу, содержащему "Помощь по форуму". Создаем файл с правилами, выкладываем в нужное место, прописываем путь к файлу в этих полях.

Примечание: Подробнее о значении полей формы создания/редактирования см. в пользовательской документации .

Документация по теме:

  • Список форумов
  • Создание и редактирование форума


Управление темами и подписками
265 / 694

Управление темами форумов

Темы форумов создаются только в публичном разделе. В панели управления можно только менять название тем, но не создавать их.

Информация о темах форумов представлена на странице Управление темами (Сервисы > Форумы > Управление темами):

Нажмите на рисунок, чтобы увеличить

Используя панель Действия, можно быстро отредактировать или удалить отмеченные записи, а также переместить выбранные темы в указанный форум. Для этого выполните следующее:

  • В колонке флажков отметьте темы, которые хотите перенести.
  • В списке действий выберите Переместить.
  • С помощью выпадающего списка укажите форум, куда будут перенесены темы.
  • Нажмите кнопку Применить.

Управление подписками пользователей

Список пользователей с подпиской на форумы представлен на странице Управление подпиской (Сервисы > Форумы > Управление подпиской):

Для просмотра подписок некоторого пользователя используйте меню действий (пункт Изменить ) либо двойной клик по соответствующей записи.

Документация по теме:

  • Управление темами
  • Управление подпиской


Звания и баллы
266 / 694

На любом форуме есть проблема оценки сообщений пользователя и его квалификации. В "1С-Битрикс: Управление сайтом" для этого используются стандартные механизмы: баллы и звания.

Баллы за сообщения

Баллы присваиваются пользователю форума за каждое отправленное сообщение. При этом можно легко настроить кумулятивную систему начисления баллов, т.е. количество баллов за одно сообщение будет увеличиваться согласно числу отправленных сообщений.

Настройка количества баллов за сообщение происходит на странице Баллы за сообщения (Сервисы > Форумы > Баллы за сообщения):

Нажмите на рисунок, чтобы увеличить

Для создания новой записи используется кнопка Новая запись, расположенная на контекстной панели. В форме создания (редактирования) записи о количестве баллов за сообщение заполните поля:

  • Необходимо сообщений - число сообщений, начиная с которого за каждое сообщение будет начисляться указанное в записи количество баллов.
  • Баллов за сообщение – количество баллов, начисляемое за сообщение, при достижении указанного в предыдущем поле числа сообщений.

Внимание! Пересчет баллов пользователей при изменении записи автоматически не происходит. Пересчет баллов каждого пользователя произойдет при написании очередного сообщения, при голосовании за него и т.п.

Звания

Звания посетителей форума устанавливаются согласно количеству набранных баллов. Пользователь получает баллы как за количество сообщений, созданных на форуме, так и в результате голосования других посетителей форума.

Примечание: Для получения звания за количество сообщений на форуме включите опцию Включить бонусную систему в настройках модуля Форум. Если эта опция неактивна, то звания будут устанавливаться на основе рейтингов.

Для настройки званий используйте страницу Звания (Сервисы > Форумы > Звания):

Нажмите на рисунок, чтобы увеличить

Для создания новой записи нажмите кнопку Новое звание, расположенную на контекстной панели. Откроется форма создания (редактирования) звания. Заполнение формы не должно вызвать у вас проблем, она полностью понятна.

Документация по теме:

  • Звания
  • Создание и редактирование звания
  • Баллы за сообщения
  • Создание и редактирование баллов за сообщение


Фильтр нецензурных слов
267 / 694

Следим за грубостями

Фильтр нецензурных слов используется для работы с нецензурными словами в сообщениях форумов. В дистрибутиве уже поставляются заполненные словари, вы можете дополнить их или отредактировать.

Для использования на форуме фильтра нецензурных слов включите данную возможность в настройках модуля Форум, при этом укажите, какое действие будет выполняться с найденными словами, и задайте языкозависимые параметры.

На странице Словарь нецензурных слов (Сервисы > Форумы > Фильтр нецензурных слов > Словарь нецензурных слов) представлен список словарей с нецензурными словами:

Нажмите на рисунок, чтобы увеличить

Добавление словаря, слов и букв транслита

Это требуется редко, но если потребовалось, то для добавления нового словаря воспользуйтесь кнопкой Добавить, расположенной на контекстной панели страницы. В открывшейся форме укажите Название и Тип словаря .

Для добавления нецензурных слов в словарь используется страница Словарь слов (Сервисы > Форумы > Фильтр нецензурных слов > Словарь нецензурных слов > <имя_словаря>). В открывшейся форме добавьте корень слова с символами изменяемых частей слова и выберите тип шаблона . Необязательно, но можно добавить слово или фразу, которые заменят добавляемое слово в тексте.

Для добавления информации об аналоговом написании букв в словарь транслита используется страница Словарь транслита (Сервисы > Форумы > Фильтр нецензурных слов > Словарь транслита > <имя_словаря>). Создание записи словаря Транслита не представляет сложности.

Документация по теме:

  • Список словарей нецензурных слов/транслита
  • Создание/редактирование словаря
  • Словарь слов
  • Создание/редактирование записи словаря нецензурных слов
  • Словарь транслита
  • Создание/редактирование записи словаря транслита


Экстранет
268 / 694

Экстранет - расширение корпоративного портала, которое позволяет компании осуществлять конфиденциальную связь с поставщиками, дистрибьюторами и другими внешними пользователями без доступа их к внутрикорпоративной информации. Это специально созданная веб-территория, используемая сотрудниками компании для эффективного сотрудничества с уполномоченными пользователями других компаний.

Модуль входит в состав редакций Корпоративный портал и Холдинг продукта «Битрикс24 в коробке». Количество внешних пользователей в модуле Экстранет не ограничивается и не зависит от лицензии, приобретенной на пользователей корпоративного портала.

Модуль Экстранет решает задачи ограниченного доступа сторонних и внутренних пользователей для совместного решения производственных задач. Технически функционал модуля реализован как еще один сайт в рамках продукта «Битрикс24 в коробке », доступ к которому ограничен (см. урок Установка модуля и настройка сайта экстранета).

Функционал модуля Экстранет является, по сути, надстройкой над функционалом модулей Социальная сеть и Интранет, обеспечивающей специфические права на доступ к контенту и функционалу корпоративного портала.

Ограничения на доступ имеют как сотрудники компании, так и внешние пользователи. Если пользователь не является сотрудником, то после авторизации он будет перенаправлен на сайт экстранета. Для сотрудников, не входящих в группу Пользователи экстранета, возможность просмотра сайта экстранета отключена (см. урок Права доступа пользователей экстранета).

Функционал сайта экстранета немного отличается от функционала сайта корпоративного портала. Основным инструментом работы в рамках экстранета является рабочая группа. Кроме того, в рамках экстранета введено понятие Публичный сотрудник, а для рабочего стола доступны дополнительные гаджеты.

Администратор портала будет иметь доступ к экстранету в случае, если он еще входит как минимум в группу Пользователи экстранета. Для администрирования модуля Экстранет автоматически создается новая группа пользователей Администраторы сайта экстранета. Все действия в этой главе описаны в плане возможностей этой группы.

Рабочие группы

Основным инструментом работы на сайте экстранета является рабочая группа. Рабочая группа в рамках экстранета обладает практически тем же функционалом, что и рабочая группа корпоративного портала, но имеет ряд отличий:

  • рабочую группу экстранета видят только ее участники;
  • изменен порядок подтверждения вступления в рабочую группу в силу того, что приглашаемый внешний пользователь не является сотрудником и у него нет доступа к корпоративному порталу.

Рабочие группы экстранета, как и группы портала, привязываются к темам. Поэтому в системе должны быть созданы необходимые темы рабочих групп экстранета. Информацию по созданию тем рабочих групп смотрите в уроке Управление темами групп.

Создание самих рабочих групп в Экстранете аналогично созданию обычных рабочих групп, только необходимо включение опции Группа доступна в экстранете.


Гаджеты экстранета
269 / 694

Как и на портале, рабочий стол на сайте экстранета организуется с помощью гаджетов, но при этом часть гаджетов портала недоступна на сайте экстранета. Список доступных на рабочем столе гаджетов определяется настройками компонента Рабочий стол (bitrix:desktop):

Специально для модуля Экстранет создан гаджет Контакты. С его помощью отображается два списка контактов для пользователя:

  • список пользователей его рабочих групп;
  • список доступных контактов, т.е. список публичных сотрудников экстранета.

Примечание: подробное описание процедуры добавления и управления гаджетами, а также описание по созданию собственных гаджетов смотрите в уроке Настройка главной страницы.

Примечание: Начиная с версии 11.5 сотрудники компании работают с группами Экстранета не переходя на собственно сайт Экстранета. То есть сайт Экстранета видят только внешние приглашённые участники.


Универсальные списки
270 / 694

Иногда функционала информационных блоков не хватает для работы с необходимой информацией. В этом случае на помощь приходит модуль 1С-Битрикс Универсальные списки.

Универсальные списки - инструмент для удобного хранения и работы с любой структурированной информацией.

Возможности Универсальных списков

Модуль может:

  • Сконструировать произвольные хранилища информационных объектов;
  • Предоставить доступ к функционалу из публичной части сайта;
  • Создать произвольную иерархию хранения объектов;
  • Фильтровать и сортировать данные, настраивать колонки и поля карточки элемента и списков элемента, выполнять групповое редактирование, управлять правами доступа и другое.

Универсальные списки используются в следующих сценариях:

  • FAQ (часто задаваемые вопросы);
  • Cправочники и базы знаний;
  • Cписки контрагентов;
  • Cтруктурированные архивы;
  • Библиотеки и файловые хранилища;

Основная функция Администратора КП в работе с Универсальными списками заключается в создании списков, настройке их параметров и доступа.

«Битрикс24 в коробке» позволяет работать со списками как с публичной, так и с административной части. Интерфейс и принципы работы со списками в обеих случаях одинаковый. Администратору портала рекомендуется работать с публичной части, страница Списки (Сервисы > Списки).


Создание списка
271 / 694

Для создания списка воспользуйтесь кнопкой [image] на контекстной панели страницы Списки. Откроется форма создания нового списка:

Примечание: Доступна возможность копирования уже существующего списка. Для копирования нужно перейти в настройки нужного списка, и воспользоваться командой Копировать список. Новый список будет иметь название старого с добавлением: (Копия).

Заполните поля закладок формы создания списка:

Закладка Настройки

  • Название списка - обязательное поле, введите название списка, как список должен быть виден для сотрудников компании.
  • Сортировка - введите число, определяющее порядок создаваемого списка в общем порядке всех списков. Чем выше число, тем ниже в общем порядке будет создаваемый список.
  • Картинка с помощью кнопки Обзор можно задать картинку, соответствующую списку. Картинка автоматически будет изменена в размере под дизайн сайта без искажения пропорций сторон. Если не будет использована собственная картинка, то будет установлена картинка по умолчанию из дистрибутива программы.
  • Включить поддержку бизнес-процессов - если в работе создаваемого списка планируется использование стандартных или собственных бизнес-процессов, то установка этого флажка необходима.

Закладка Подписи

На закладке можно задать название элементов и разделов создаваемого списка, чтобы облегчить сотрудникам работу. Например, если создается список Поставщики, то логично будет заменить слово элемент на поставщик, а слово раздел, на группа поставщиков, и так далее.

Закладка Доступ

Внимание! Если группа пользователей не будет обладать соответствующими правами на доступ к списку, то они не увидят соответственно и сам список на странице Списки.

Закладка Доступ позволяет настроить права доступа к элементам и разделам списка по умолчанию. Эти права потом можно перезадать в настройках доступа к каждому конкретному разделу или элементу.

С помощью ссылки Добавить выберите нужную группу или конкретного пользователя, для которых хотите поменять права доступа и установите нужные права.

  • Нет доступа - создаваемый список даже не будет виден.
  • Чтение - даёт возможность только просматривать список.
  • Просмотр в панели - просмотр элементов списка в административной части. (Доступно в Битрикс24 в коробке.)
  • Добавление - можно просматривать список и добавлять в него элементы.
  • Добавление в панели - добавление элементов списка в административной части. (Доступно в Битрикс24 в коробке.)
  • Изменение - доступен не только просмотр и добавление элементов в список, но и изменение состава списка.
  • Изменение с ограничениями - допускается не только изменять список, но и запускать бизнес-процессы по элементам списка.
  • Полный доступ - устанавливается полный уровень прав доступа к списку.

Итог: Для того чтобы пользователи смогли просматривать список, достаточно указать право на чтение в настройках списка . Таким образом, задавая права на доступ можно ограничить доступ на чтение/изменение различных списков для разных групп пользователей.

Нажмите Сохранить, список создастся и можно переходить к его настройкам.


Зарплата и отпуск
272 / 694

Сервис Зарплата и отпуск работает только с "1С: ЗУП". Для настройки сервиса необходимо произвести настройки на стороне "1С" и на стороне «Битрикс24 в коробке».

Настройки на стороне «Битрикс24 в коробке»

Для настройки сервиса Зарплата и отпуск необходимо настроить компонент Расчетные листки сотрудников (bitrix:payroll.1c), размещенный на странице Сервисы > Зарплата и отпуск.

Детальное описание полей дано в пользовательской документации по «Битрикс24 в коробке». Минимально достаточная настройка заключается в следующем:

  • В поле Список организации создайте новую организацию, если их несколько. Если организация одна, то можно просто переименовать имеющуюся по умолчанию. Обязательно нажмите на кнопку ОК. Форма перезагрузится.
  • В группе полей Настройки для организации *** заполните поля:
    • URL веб-сервиса - адрес сервиса, полученный от администратора программы "1С: ЗУП";
    • Порт - порт сервиса, полученный от администратора программы "1С: ЗУП";
    • Логин и Пароль пользователя 1С, от имени которого будет производиться доступ к программе "1С: ЗУП".
  • Сохраните внесенные изменения.

Настройки на стороне "1С:ЗУП", ред. 2.5

УРЛ веб-сервиса указывается при публикации из "1С". Подробно публикация вэб-сервисов описана в документации к 1С. Кратко о необходимых действиях (нужен доступ в Конфигуратор и административные права):

  • Откройте пункт меню Администрирование > Публикация на веб-сервере:

    После этого получится УРЛ такого вида: http://test_server/zupws/ws/zupws
  • Доступ к вэб-сервису осуществляется от любого пользователя, у которого включена роль Веб-сервис 1С Битрикс. То есть в "1С" для работы необходимо создать такого пользователя, задать ему пароль и включить эту роль.

    В Конфигураторе:

    В режиме Предприятия:

Настройки на стороне "1С:ЗУП", ред. 3.0

Примечание: подробное описание настроек со стороны 1С:ЗУП, ред. 3.0 представлено в соответствующей главе курса.


Отчеты 1С
273 / 694

Это специальный модуль, который позволяет выгружать любые печатные формы документов и отчеты из 1С в Живую ленту Битрикс24.

Порядок подключения и настройки

  1. Скачайте и установите модуль «1С+Битрикс24» по ссылке
  2. Перезапустите 1С. После этого в разделе администрирования появится пункт с настройкой модуля (в зависимости от конфигураций 1С может немного отличаться местоположение )
  3. Свяжите 1С с вашим Битрикс24. Для этого перейдите на страницу Настройки подключения Битрикс24:

  4. В вашем Битрикс24 скопируйте ключ

  5. Введите скопированный в Битрикс24 ключ на стороне 1С.

О других возможностях интеграции 1С и Битрикс24 вы можете прочитать:

  • Face-карт для 1С.
  • 1С-трекер.
  • Интеграция с 1С.
  • Раздел Синхронизация с Битрикс24.
  • 1С:Бэкофис - установка для коробочной Битрикс24 аналогична облачной версии, за исключением пары моментов:
    • Требуется настройка Push-сервера. Push-сервер уже настроен в виртуальной машине BitrixVM , либо настройте его на стороннем окружении . Взаимодействие между 1С и Битрикс24 происходит через Push&Pull, поэтому со стороны 1С всегда должно быть соединение, которое подключено к Push серверу, чтобы постоянно проверять от него сообщения.
    • Возможны проблемы при использовании самоподписанного сертификата SSL. Если сертификат самоподписанный, то сначала необходимо добавить его в исключения браузера при прямом подключении к веб-версии 1С и только после этого заходить через Битрикс24. Иначе браузер выдаст ошибку по сертификату.


Администратор системы
274 / 694

Администратор системы имеет доступ к любой функции системы. В главе описаны возможности недоступные Администратору КП.

Администратору системы необходимо помнить, что при обновлении системы и добавлении новых модулей не происходит автоматической установки модулей. Новые модули необходимо самостоятельно установить (Настройки > Настройки продукта > Модули) и, в ряде случаев, заново пройти Мастер установки портала (Настройки > Настройки продукта > Список мастеров)

Внимание! Часть описанных в этой главе действий имеет смысл только в случае, если отдельные модули не были установлены при установке «Битрикс24 в коробке». Такая ситуация возможна, если происходит переход с низшей редакции на высшую, либо, если ваша установка продукта долго не обновлялась.

Перед выполнением действий по установке и настройке убедитесь в том, что:

  • необходимый вам модуль действительно отсутствует в системе;
  • страницы, использующие компоненты этого модуля не созданы;
  • компоненты на этих страницах не настроены.
  • инфоблоки для данного модуля не созданы.


CRM
275 / 694

Об установке модуля CRM смотрите в уроке Установка и удаление модуля.

В административном разделе можно настроить параметры сделок по-умолчанию, прокси-сервера и изменить адреса страниц в структуре портала для компонентов CRM (Настройки > Настройки продукта > Настройки модулей > CRM):

Примечание: сотрудник, заданный как ответственный для сделок по-умолчанию, будет таковым для сделок, импортированных из интернет-магазинов, в настройках интеграции которых не задан ответственный для сделок.

Администратор системы может менять настройки CRM и управлять правами доступа, давая их отдельным сотрудникам, либо группам сотрудников. Подробнее об этом читайте на helpdesk.bitrix24.ru.

Дополнительная информация

  • CRM (документация)


Установка и удаление модуля CRM
276 / 694

Установка модуля CRM

Если модуль CRM по каким-либо причинам отсутствует на вашем портале, то установите его на странице административного раздела Настройки > Настройки продукта > Модули.

На главной области страницы откроется таблица с перечисленными модулями корпоративного портала, нажмите Установить напротив модуля CRM:

Откроется страница с настройками установки модуля. При отмеченной опции Скопировать публичные файлы и шаблон для сайта система при установке модуля будет копировать необходимые файлы модуля CRM заново, если при этом какие-либо файлы уже имеются, то они не будут перезаписываться, а останутся неизменными.

Если вы хотите чтобы при копировании имеющиеся файлы заменялись новыми, то поставьте галочку в опции Переписывать существующие файлы.

Примечание: отмеченная опция Переписывать существующие файлы удалит при переустановке модуля CRM все ранее имеющиеся страницы, но оставит неизменными внесенные данные (контакты, компании, лиды, сделки).

После того, как все параметры настроены, нажмите кнопку Установить модуль.

Если установка прошла успешно, то на появившейся странице вы будете оповещены об этом соответствующим сообщением.

Нажмите кнопку Вернуться в список чтобы перейти на страницу административного раздела со списком модулей.

Удаление модуля CRM

Перейдите на страницу административного раздела со списком модулей. Найдите в таблице строку модуля CRM и нажмите кнопку Удалить. Появится запрос подтверждения на удаление с настройками процесса удаления. Снимите галочку у опции Сохранить таблицы если не хотите сохранять имеющиеся в системе CRM данные, такие как списки контактов, компаний, лидов и сделок.

Для удаления модуля нажмите кнопку Удалить модуль.

Если удаление прошло успешно, то на появившейся странице вы будете оповещены об этом соответствующим сообщением.

Нажмите кнопку Вернуться в список чтобы перейти на страницу административного раздела со списком модулей.


DAV
277 / 694

С помощью протоколов DAV (WebDAV, CalDAV, CardDav) осуществляется двунаправленная интеграция календарей, задач, интеграция контактов на портале с MS Exchange, а также с другими внешними системами.

WebDAV (Web-based Distributed Authoring and Versioning) - защищенный сетевой протокол высокого уровня, работающий поверх HTTP для доступа к объектам и коллекциям.

CalDAV (Calendaring Extensions to WebDAV) – интернет стандарт, позволяющий клиентам получать доступ к общей информации на удаленном сервере для планирования работы. Работает поверх WebDAV, использует формат iCalendar.

CardDav - протокол для работы c адресной книгой.

Дополнительная информация

  • DAV (документация)


Настройка модуля DAV
278 / 694

Для настройки протоколов DAV перейдите на страницу настроек модуля (Настройки > Настройки продукта > Настройки модулей > DAV ). На открывшейся странице настроек параметров модуля заполните следующие поля формы:

  • На закладке Exchange указываются настройки соединения с Exchange сервером:

    Нажмите на рисунок, чтобы увеличить

    • Включить синхронизацию календарей, контактов и задач Exchange с помощью соответствующих опций.
    • Включить запрос количества непрочитанных сообщений Exchange - если эта опция включена, то будет отправляться запрос к MS Exchange на предмет непрочитанных сообщений, оповещение о которых будут выводиться в панели статусов публичной части портала.
    • Схема подключения к Exchange серверу - позволяет выбрать протокол подключения к серверу Exchange: HTTP или HTTPS.
    • Адрес Exchange сервера - указывается адрес Exchange сервера.
    • Порт Exchange сервера - указывается порт Exchange сервера.
    • Имя пользователя для соединения с Exchange сервером - указывается имя пользователя.
    • Пароль пользователя для соединения с Exchange сервером - указывается пароль пользователя c правами управления учетными записями в MS Exchange.
    • Шаблон почтового ящика Exchange сервера - указывается шаблон почтового ящика в MS Exchange (Например: @test.local).
    • Использовать логин в качестве имени почтового ящика на Exchange сервере - при отмеченной опции будет использоваться логин пользователя портала в качестве имени почтового ящика на сервере MS Exchange (Например: логин пользователя на портале - user, шаблон почтового ящика в MS Exchange - @test.local, то итоговый почтовый ящик в MS Exchange пользователя будет user@test.local).

      Внимание! Если опция Использовать логин в качестве имени почтового ящика на Exchange сервере отключена

      Внимание! Если опция Использовать логин в качестве имени почтового ящика на Exchange сервере отключена, то для правильной работы MS Exchange с пользователями необходимо:
      1. В форме редактирования профиля каждого пользователя в закладке Дополнительно с помощью кнопки Настроить на контекстной панели вызвать диалоговое окно для настройки формы отчета данной формы:

        и включить пользовательское поле Почтовый ящик Exchange (код поля: UF_BXDAVEX_MAILBOX). После чего нажать кнопку Сохранить.
        Либо нажать кнопку Отменить действия настроек полей формы на время сессии.
      2. В закладке Дополнительно указать e-mail в появившемся поле Почтовый ящик Exchange для каждого пользователя:

      3. Нажать кнопку Сохранить.

      Эти действия необходимо провести с профилем каждого сотрудника!

      Примечание: при включении этой опции становится невозможным подключение E-mail трекера в CRM.

      Таким образом, например в разделе Календарь появится иконка MS Exchange:

      Нажмите на рисунок, чтобы увеличить

      Если у вас отсутствует такая иконка вообще, то соединение c Exchange невозможно либо неправильно настроено.

    • Включение синхронизации календарей между порталом и внешними системами включается на закладке DAV. Используется протокол CalDAV. После включения опции в Календаре пользователя станет доступной кнопка подключения Google календаря.

      Примечание: О работе с календарями и мобильными устройствами см. главу Календарь курса Пользователь корпоративного портала.

    • Настройки для работы модуля DAV с помощью прокси-сервера указываются на закладке Прокси, где указываются параметры для подключения.


Что такое Highload-блоки
279 / 694

Экономят время и деньги для сайтов с высокой посещаемостью

Модуль позволяет создавать списки для хранения произвольных данных (новости, вакансии и другое). Каждый список хранится в отдельной таблице базы данных (БД) и использует собственные индексы.

Это быстрые справочники, без поддержки иерархии, с ограниченной поддержкой свойств. Они могут обращаться к БД и работать с большими объёмами данных.

В поставку модуля включено два компонента, отображающих информацию из Highload-блоков: Запись детально (bitrix:highloadblock.view) и Список записей (bitrix:highloadblock.list).

Кроме того, с появлением модуля Highload-блоки для элементов модуля Информационные блоки доступен новый тип свойства Справочник, где в качестве справочника используется некоторый Highload-блок.

В каких случаях удобно использовать Highload-блоки:

  • очень большой объем данных и нагрузки, с которым не могут справиться инфоблоки ;
  • если нужна некая структура для хранения служебных данных, которая не будет редактироваться контент-менеджерами;

Документация по теме:

  • Архитектура модуля Highload-блоки
  • Импорт справочников из 1С


Push and Pull
280 / 694

Push-уведомления – это небольшие всплывающие окна, которые появляются на экране мобильного телефона или обычного компьютера и сообщают о важных событиях и обновлениях. То есть инициатором уведомлений являются сайты, на которые подписан пользователь. Противоположностью Push-технологии является технология Pull, где информация запрашивается самим пользователем.


Что делает Push and Pull
281 / 694

Модуль Push and Pull обеспечивает отправку мгновенных команд.

Так как этот функционал организован в виде отдельного модуля, то любой другой модуль (в том числе и модули сторонних разработчиков) может, используя API, отправлять мгновенные нотификации и сообщения клиентам.

Работа этого модуля требуется для полной функциональности:

  • Мобильного приложения - задачи, события в календаре, мгновенные сообщения и т.д. обновляются/добавляются мгновенно без обновления страницы.
  • Голосований и опросов - обновление результатов голосования в режиме online.
  • Блогов - мгновенное обновление счетчика лайков у сообщений и комментариев
  • Веб-мессенджера - мгновенные сообщения в личной и групповой переписке без необходимости ждать опроса сервера, уведомление о том, что сообщение прочитано и пишется ответ, возможность совершать звонки и видеозвонки.

Примечание: Если при просмотре ленты у пользователя вместо правильного текста появляются нечитаемые символы, то скорее всего, в браузере жестко указана какая-либо кодировка. Необходимо указать автоматический выбор кодировки (Вид > Кодировка > Авто).


Как работает Push-сервер
282 / 694

 Когда пользователь входит на сайт, его браузер, настольное или мобильное приложение устанавливают и держат постоянное соединение с Push-сервером.

Обычно это делается с помощью WebSocket , который используют 95% современных браузеров. А если технология WebSocket не поддерживается браузером, то используется Long Polling — постоянный долгий опрос. Это ajax-запрос , который в течение 40 секунд ждет ответа от сервера. В случае получения ответа или при наступлении таймаута, запрос повторяется.

Для "1С-Битрикс: Управление сайтом" разработан собственный Push-сервер:

Схема работы Push-сервера

  • Пользователь пишет какое-то сообщение на портале.
  • Сообщение поступает на NGINX-сервер . Он обрабатывает и держит множество TCP и HTTPS-соединений, занимается балансировкой нагрузки и выполняет другие важные функции, такие как кеширование HTTP и использование в качестве обратного прокси.
  • Сообщение отправляется в PHP-часть бэкенда, там оно сохраняется, а потом транслируется в Push-сервер.
  • Push-сервер состоит из восьми процессов приложения Node.js - 6 процессов обслуживают входящие соединения, 2 процесса отвечают за публикацию сообщений.
  • Все восемь процессов Node.js-приложения имеют постоянное соединение с Redis . В Redis сохраняются все сообщения, статистика по каналам и состояние онлайна.
  • В самом сообщении содержатся все атрибуты данных, то есть автор, адресат и т.д. Один из двух процессов, отвечающих за публикацию сообщений, принимает это сообщение, обрабатывает его и публикует в Redis.
  • Redis записывает сообщение и оповещает другие шесть процессов о том, что поступило новое сообщение и его можно разослать подписчикам.
  • Для работы с WebSocket используется open-source модуль Node.js под названием ws.
  • Для безопасной работы с push-сервером каждый пользователь получает уникальный идентификатор канала при подсоединении. Это случайная строка из 32 символов и добавленная к ней специальная подпись, уникальная для этого конкретного идентификатора канала. Сами каналы регулярно меняются, как и их идентификаторы.
  • Сам канал хранится на сервере 24 часа, но запись в него осуществляется не более 12 часов. Остальное время хранения необходимо для того, чтобы пользователь смог получить ранее отправленные сообщения. Ведь если вечером ноутбук "уснул" с одним идентификатором канала, то утром он "проснется" с ним же и обратится на сервер. После отправки сообщений сервер закрывает старый канал и создает для этого пользователя новый.

Варианты работы Push-сервера «1С-Битрикс»

Для работы "1С-Битрикс: Управление сайтом" и "Битрикс24 в коробке" рекомендуется использовать виртуальную машину BitrixVM , где всё уже настроено. Если по каким-то причинам использование BitrixVM невозможно, то в используемом окружении необходимо настроить push-сервер.

Скачать исходные файлы Push-сервера из нашей виртуальной машины можно по адресу: /opt/push-server/.

Настройки хранятся в файле config/config.json .

Один из примеров настройки и запуска Push-сервера на стороннем окружении приведен в уроке.

Документация по теме:

  • Настройки модуля (документация)
  • Зачем настраивать модуль Push&Pull (блог)
  • Работа с модулем для разработчиков
  • API модуля
  • Push-уведомления в курсе «BitrixMobile - создание кроссплатформенных мобильных приложений»
  • О новом push-сервере «1С-Битрикс»
  • Новый real-time сервер push-уведомлений. Использование Node.js
  • Работа с модулем "Push & Pull"


Push and Pull - настройка модуля
283 / 694

Настройка Push and Pull

Сложность настройки модуля Push and Pull зависит от выбора типа сервера. Опишем настройки по возрастанию сложности. Все настройки осуществляются на странице Настройки > Настройки продукта > Настройки модулей > Push and Pull.

Облачный Push сервер

Для включения облачного сервера достаточно в поле Использовать "Push server" выбрать облачный тип сервера, затем указать нужный сервер и зарегистрироваться:

Использование актуальной виртуальной машины

Если ваш Битрикс установлен на виртуальной машине BitrixVM версии 7.1 и выше , то у вас так же нет необходимости настраивать модуль Push and Pull. В виртуальной машине установлен Push-сервер по умолчанию. Он настроен, сконфигурирован и работает "из коробки".

Если, всё же необходимо произвести некоторые изменения, то это делается на странице Настройки > Настройки продукта > Настройки модулей > Push and Pull:

Нажмите на рисунок, чтобы увеличить

  • Укажите секретный код для подписи сообщения. Это 32-хзначный произвольный код, который указывается в настройках пуш-сервера:
    <путь к пуш-серверу>./push-server/config/config.json:
"security": {
        "key": <ваш секретный ключ>
    Примечание: В виртуальной машине BitrixVM это поле создается автоматически при первом старте службы или при настройке/обновлении и прописывается в настройки сайта.
  • При необходимости перенастройте шаблоны путей. Домен в адресе для чтения сообщений можно указать #DOMAIN#: такая нотация будет автоматически заменяться под нужный домен для многодоменных конфигураций. Пример: http://#DOMAIN#:8893/bitrix/sub/.
  • Если в системе несколько активных сайтов, то есть возможность выбрать, на каких сайтах модуль не будет работать.

Если у вас устаревшая версия Виртуальной машины

Для устаревших виртуальных машин используйте информацию из спойлеров.

Работа модуля Push and Pull Битрикса на виртуальной машине до версии 5.0.

На серверной стороне поддержка мгновенных сообщений осуществляется модулем NGINX: nginx-push-stream-module. Данный модуль обеспечивает поддержку long-polling соединений с клиентами и доставку опубликованных им сообщений.

Примечание: Bitrix Framework и без модуля nginx-push-stream-module обеспечивает достаточно высокую скорость передачи сообщений: 60 секунд интервал, при наличии сообщений интервал между соединениями уменьшается до 10 секунд.

При открытии страницы клиент ajax-запросом, подключается к своему каналу на одном из портов NGINX: 8893 (http) или 8894 (https). (В случае использования виртуальной машины BitrixVM. При использовании собственной конфигурации сервера администратор волен использовать любые удобные ему порты.) С данного порта NGINX перенаправляет пользователя на внутренний сервер очередей (доступный только по 127.0.0.1:8895), где проверятся наличие канала пользователя и новых сообщений. В случае если в канале нет сообщений, сервер не отдает ответ, а держит соединение в течение 40 сек.

Если в течение этого времени в канал пользователя придет новое сообщение, то сервер отправит его клиенту и закроет соединение. В случае если в канал пользователя не будет новых сообщений в течение 40 секунд, то сервер разорвет соединение и отправит ему заголовок: 304 Not Modified.

После получения ответа сервера и закрытия соединения клиент выполнит повторное подключение к каналу с новой датой последнего изменения.

Сообщения в канал пользователя публикуются посредством вызова соответствующих методов API модуля Push and Pull.

Для работы с мгновенными сообщениями рекомендуем использовать протокол https.

Примечание: Большое значение имеет правильная синхронизация времени сервера с глобальными серверами.

Настройка модуля

При использовании продуктов Bitrix Framework на базе виртуальной машины BitrixVM с v. 5.0 необходимости в настройке модуля нет: всё работает "из коробки". Если проект используется не на штатных средствах установки Bitrix Framework, то необходимо произвести дополнительные настройки.

Примечание: Приведённые ниже образцы настроек даны для примера. Настройку под конкретный проект, при отказе от использования рекомендуемых BitrixVM или BitrixEnvironment, администратор должен произвести самостоятельно.

Внимание! Работа модуля Push and Pull поддерживается только до версии 0.5 nginx-push-stream-module. Более свежие версии не поддерживаются, так как для работы Push and Pull разрабатывается специальное решение от "1С-Битрикс".

  • Соберите NGINX с поддержкой модуля nginx-push-stream-module;

    В качестве примеров можно использовать файлы из нашей виртуальной машины:

    • /etc/nginx/bx/site_enabled/push.conf - настройки push and pull для публикации сообщений, а так же для работы мобильных;
    • /etc/nginx/bx/conf/im_subscrider.conf - настройки для получения сообщений (они подключаются к сайту непосредственно);
    • /etc/nginx/bx/conf/im_settings.conf - количество каналов, объём памяти и т.п..

Настройка nginx-push-stream-module в версии 0.4.0 (рекомендуется к использованию)
  • Общие настройки (файл /etc/nginx/bx/conf/im_settings.conf):
    # Common settings for nginx-push-stream-module
push_stream_shared_memory_size 256M;
push_stream_max_messages_stored_per_channel 1000;
push_stream_max_channel_id_length 32;
push_stream_max_number_of_channels 200000;
push_stream_message_ttl 86400;
  • Настроить отдельные виртуальные сервера NGINX на портах 8893, 8894, 8895 (/etc/nginx/bx/site_enabled/push.conf):
    # поддержка мобильных платформ, для http запросов
server {
    # nginx-push-stream-module server for push & pull

listen 8893;
server_name _;

# Include error handlers
include bx/conf/errors.conf;

# Include im subscrider handlers
include bx/conf/im_subscrider.conf;

location ^~ / { deny all; }
}
# поддержка мобильных платформ, для https запросов
# SSL enabled server for reading personal channels
server {
    listen 8894;
server_name _;
    include bx/conf/ssl.conf;

# Include error handlers
include bx/conf/errors.conf;

# Include im subscrider handlers
include bx/conf/im_subscrider.conf;

location ^~ / { deny all; }
}
# для публикации сообщений
# Server to push messages to user channels
server {
    listen 127.0.0.1:8895;
server_name _;

location ^~ /bitrix/pub/ {
    push_stream_publisher admin;
    push_stream_channels_path $arg_CHANNEL_ID;
    push_stream_store_messages on;
    allow 127.0.0.0/8;
deny all;
}

location ^~ / { deny all; }

# Include error handlers
include bx/conf/errors.conf;
}

    Для получения сообщений через запрос на стандартный порт (80 для http, 443 для https) в дефолтный файл /etc/nginx/bx/conf/im_subscrider.conf добавлено:

    # Include im subscrider handlers
include bx/conf/im_subscrider.conf;

    Этот файл содержит:

    # Location for long-polling connections
location ^~ /bitrix/sub {

# we don't use callback and droppped it (XSS)
if ( $arg_callback ) {
    return 400;
}

    push_stream_subscriber            long-polling;
    push_stream_allowed_origins "*";
    push_stream_channels_path        $arg_CHANNEL_ID;
    push_stream_last_received_message_tag    $arg_tag;
    if ($arg_time) {
        push_stream_last_received_message_time "$arg_time";
    }
    push_stream_longpolling_connection_ttl    40;
    push_stream_authorized_channels_only    on;
    push_stream_message_template '#!NGINXNMS!#{"id":~id~,"channel":"~channel~","tag":"~tag~","time":"~time~","eventid":"~event-id~","text":~text~}#!NGINXNME!#';
}

# Location for websocet connections
location ^~ /bitrix/subws/ {
    push_stream_subscriber websocket;
    push_stream_channels_path        $arg_CHANNEL_ID;
    push_stream_websocket_allow_publish    off;
    push_stream_ping_message_interval    40s;
    push_stream_authorized_channels_only     on;
    push_stream_last_received_message_tag    "$arg_tag";
    push_stream_last_received_message_time    "$arg_time";
    push_stream_message_template '#!NGINXNMS!#{"id":~id~,"channel":"~channel~","tag":"~tag~","time":"~time~","eventid":"~event-id~","text":~text~}#!NGINXNME!#';
}

Настройка nginx-push-stream-module в версии 0.3.4
  • Общие настройки:
    # Common settings for nginx-push-stream-module

push_stream_shared_memory_size			256M;
push_stream_max_messages_stored_per_channel	1000;
push_stream_max_channel_id_length		32;
push_stream_max_number_of_channels		100000;
push_stream_shared_memory_cleanup_objects_ttl	60;
push_stream_message_ttl				86400;
  • Настройки сервера мгновенных сообщений
        # Nonsecure server for reading personal channels. Use secure server instead.
    server {
        # nginx-push-stream-module server for push & pull

        listen	8893;
        include	bx/node_host.conf;

        # Include error handlers
        include	bx/conf/errors.conf;

        # Location for long-polling connections
        location ^~ /bitrix/sub {
            push_stream_subscriber			long-polling;
            set $push_stream_channels_path		$arg_CHANNEL_ID;
            push_stream_last_received_message_tag	$arg_tag;
            push_stream_longpolling_connection_ttl	40;
            push_stream_authorized_channels_only	on;
            push_stream_content_type		"text/html; charset=utf-8";
            push_stream_message_template "#!NGINXNMS!#{
                            \"id\":~id~,\"tag\":\"~tag~\",\"time\":\"~time~\",\"text\":~text~}#!NGINXNME!#";
        }

        # Location for websocet connections
        location ^~ /bitrix/subws/ {
            push_stream_websocket;
            set $push_stream_channels_path		$arg_CHANNEL_ID;
            push_stream_websocket_allow_publish	off;
            push_stream_ping_message_interval	40s;
            push_stream_authorized_channels_only on;
            push_stream_message_template		"#!NGINXNMS!#{
                            \"id\":~id~,\"tag\":\"~tag~\",\"time\":\"~time~\",\"text\":~text~}#!NGINXNME!#";
        }

        location ^~ / 			{ deny all; }
    }

    # SSL enabled server for reading personal channels
    server {
        listen	8894;
        include	bx/node_host.conf;
        include	bx/conf/ssl.conf;

        # Include error handlers
        include	bx/conf/errors.conf;

        add_header "Access-Control-Allow-Origin" "*";
        add_header "Access-Control-Allow-Headers" "if-modified-since, origin, if-none-match";

        # Location for long-polling connections
        location ^~ /bitrix/sub {
            push_stream_subscriber			long-polling;
            set $push_stream_channels_path		$arg_CHANNEL_ID;
            push_stream_last_received_message_tag	$arg_tag;
            push_stream_longpolling_connection_ttl	40;
            push_stream_authorized_channels_only	on;
            push_stream_content_type		"text/html; charset=utf-8";
            push_stream_message_template		"#!NGINXNMS!#{
                            \"id\":~id~,\"tag\":\"~tag~\",\"time\":\"~time~\",\"text\":~text~}#!NGINXNME!#";
        }

        # Location for web socket connections
        location ^~ /bitrix/subws/ {
            push_stream_websocket;
            set $push_stream_channels_path		$arg_CHANNEL_ID;
            push_stream_websocket_allow_publish	off;
            push_stream_ping_message_interval	40s;
            push_stream_authorized_channels_only	on;
            push_stream_message_template		"#!NGINXNMS!#{
                             \"id\":~id~,\"tag\":\"~tag~\",\"time\":\"~time~\",\"text\":~text~}#!NGINXNME!#";
        }

        location ^~ / 			{ deny all; }
    }

    # Server to push messages to user channels
    server {
        listen 127.0.0.1:8895;
        include	bx/node_host.conf;

        location ^~ /bitrix/pub/ {
            push_stream_publisher			admin;
            set $push_stream_channel_id		$arg_CHANNEL_ID;
            push_stream_store_messages		on;
            push_stream_keepalive			off;
            allow					127.0.0.0/8;
            deny					all;
        }

        location ^~ /	{ deny all; }

        # Include error handlers
        include	bx/conf/errors.conf;
    }
  • Включите в настройках продукта на странице Настройки > Настройки продукта > Настройки модулей > Push and Pull опцию На сервере установлен модуль nginx-push-stream-module:

    Также необходимо выбрать версию используемой вами машины. Рекомендуется использовать Виртуальную машину в версии 4.4 и выше, так как в ней используется более совершенная версия модуля nginx-push-stream-module 0.4.0, позволяющая использовать технологию Веб-сокетов и отправление команд.

  • При необходимости перенастройте шаблоны путей. Если используется Виртуальная машина, либо настройка nginx-push-stream-module производилась по аналогии с BitrixEnvironment, то изменения путей не требуется.

    • Внимание! Если у вас появляется ошибка вида:
    XMLHttpRequest cannot load
http://example.com:8893/bitrix/sub/?CHANNEL_ID=<уникальный_адрес_канала>&tag=1&rnd=1380619831146.
Origin http://example.com is not allowed by Access-Control-Allow-Origin.
    значит, вы используете версию модуля nginx push stream module до 0.3.4.

    Необходимо либо обновить версию модуля, либо закомментировать строки:

    add_header "Access-Control-Allow-Origin" "*";
add_header "Access-Control-Allow-Headers" "if-modified-since, origin, if-none-match";

    Как использовать модуль, подробно рассказано в курсе Разработчик Bitrix Framework в главе Push and Pull .

    Документация по теме:

    • Настройки модуля (документация)
    • Зачем настраивать модуль Push&Pull (блог)
    • Работа с модулем для разработчиков
    • API модуля
    • Push-уведомления в курсе «BitrixMobile - создание кроссплатформенных мобильных приложений»


Настройка и запуск push сервера на стороннем окружении
284 / 694

Для работы "1С-Битрикс: Управление сайтом" и "Битрикс24 в коробке" рекомендуется использовать BitrixVM , где всё уже настроено. Если по каким-то причинам использование BitrixVM невозможно, то в используемом окружении необходимо настроить push-сервер. Примеры приведены для CentOs.

Настройка push-сервера

  1. Подключите подключенный репозиторий bitrix-env:
    cat /etc/yum.repos.d/bitrix.repo
[bitrix]
name=$OS $releasever - $basearch
failovermethod=priority
baseurl=http://repos.1c-bitrix.ru/yum/el/$releasever/$basearch
enabled=1
gpgcheck=1
gpgkey=http://repos.1c-bitrix.ru/yum/RPM-GPG-KEY-BitrixEnv

    Примечание: В случае Centos 6 необходим подключенный nodejs репозиторий
    curl --silent --location https://rpm.nodesource.com/setup_6.x | bash - >/dev/null 2>&1

  2. Установите пакеты.

    Примечание: На текущий момент существует проблема с Cenos 7.3, нужно установить вручную пакет http-parser:
    rpm -Uvh https://kojipkgs.fedoraproject.org//packages/http-parser/2.7.1/3.el7/x86_64/http-parser-2.7.1-3.el7.x86_64.rpm
    Затем
     yum -y install nodejs push-server

Настройка Redis сервера

  1. Измените группу у пользователя Redis. В случае Bitrix окружения это - группа bitrix, в остальных случаях группа соответствует группе с правами которой работает apache или php-fpm сервис.
    usermod -g bitrix redis
  2. Измените конфигурационный файл для redis сервиса:
     cat /etc/redis.conf
# Ansible managed
unixsocket /tmp/redis.sock
pidfile /var/run/redis_6379.pid
logfile /var/log/redis/redis.log
dir /var/lib/redis

bind 127.0.0.1
protected-mode yes
port 6379
tcp-backlog 511
unixsocketperm 770
timeout 0
tcp-keepalive 300
daemonize yes
supervised no
loglevel notice
databases 16
save 86400 1
save 7200 10
save 3600 10000
stop-writes-on-bgsave-error no
rdbcompression yes
rdbchecksum yes
dbfilename dump.rdb
slave-serve-stale-data yes
slave-read-only yes
repl-diskless-sync no
repl-diskless-sync-delay 5
repl-disable-tcp-nodelay no
slave-priority 100
appendonly no
appendfilename "appendonly.aof"
appendfsync everysec
no-appendfsync-on-rewrite no
auto-aof-rewrite-percentage 100
auto-aof-rewrite-min-size 64mb
aof-load-truncated yes
lua-time-limit 5000
slowlog-log-slower-than 10000
slowlog-max-len 128
latency-monitor-threshold 0
notify-keyspace-events ""
hash-max-ziplist-entries 512
hash-max-ziplist-value 64
list-max-ziplist-size -2
list-compress-depth 0
set-max-intset-entries 512
zset-max-ziplist-entries 128
zset-max-ziplist-value 64
hll-sparse-max-bytes 3000
activerehashing yes
client-output-buffer-limit normal 0 0 0
client-output-buffer-limit slave 256mb 64mb 60
client-output-buffer-limit pubsub 32mb 8mb 60
hz 10
aof-rewrite-incremental-fsync yes
maxmemory 459mb
maxmemory-policy allkeys-lru

    Значение maxmemory зависит от сервера, где устанавливается push-server. В случае BitrixVM, например, этот параметр равен 1/4 от установленной памяти.

    Примечание: В случае Centos 7 меняем настройки службы Redis:
    cat /etc/systemd/system/redis.service.d/custom.conf
[Service]
Group=bitrix
    Если не используется окружение Bitrix, выставляем значение группы в нужное вам.

  3. Перезапустите сервис Redis и включите для него автоматический запуск.

    Команда для Centos 7:

     systemctl enable redis && systemctl restart redis

    Команда для Centos 6:

     chkconfig redis on && /etc/init.d/redis restart

Конфигурация Push-server

  1. Измените файл настроек /etc/sysconfig/push-server-multi, добавив опцию WS_HOST - IP адрес хоста , на котором запускается сервис. Если необходимо измените настройки, которые отвечают за количество процессов nodejs, обрабатывающих запрос на получение и публикацию сообщений:
    ID_SUB=5              # max ID for sub service
ID_PUB=1              # max ID for pub service
  2. Создайте конфигурационные файлы для запускаемых процессов. Одновременно в конфиге будет создан ключ SECURITY_KEY:

    /etc/init.d/push-server-multi reset

    Данный процесс создаст конфигурационные файлы в каталоге:

    ls -al /etc/push-server/push-server-*
-rw-r--r-- 1 bitrix root   685 Aug 25 14:52 /etc/push-server/push-server-pub-9010.json
-rw-r--r-- 1 bitrix root   685 Aug 25 14:52 /etc/push-server/push-server-pub-9011.json
-rw-r--r-- 1 bitrix root   635 Aug 25 14:52 /etc/push-server/push-server-sub-8010.json
-rw-r--r-- 1 bitrix root   635 Aug 25 14:52 /etc/push-server/push-server-sub-8011.json
-rw-r--r-- 1 bitrix root   635 Aug 25 14:52 /etc/push-server/push-server-sub-8012.json
-rw-r--r-- 1 bitrix root   635 Aug 25 14:52 /etc/push-server/push-server-sub-8013.json
-rw-r--r-- 1 bitrix root   635 Aug 25 14:52 /etc/push-server/push-server-sub-8014.json
-rw-r--r-- 1 bitrix root   635 Aug 25 14:52 /etc/push-server/push-server-sub-8015.json

    Количество файлов зависит от опций, указанных выше.

  3. Запустите процессы.

    Команда для Centos 7:

    systemctl enable push-server && systemctl start push-server

    Команда для Centos 6:

    chkconfig push-server-multi on && /etc/init.d/push-server-multi start

Конфигурация NGINX

  1. Настройте upstream серверов для push-server:
    #/etc/nginx/bx/settings/rtc-im_settings.conf

log_format simple '$time_local $status $request';
# if connection ti not set
map $http_upgrade $connection_upgrade {
  default upgrade;
  '' 'close';
}

map $http_upgrade  $replace_upgrade {
  default $http_upgrade;
  ''      "websocket";
}

# sub services
upstream nodejs_sub {
  ip_hash;
  keepalive 1024;
  server vm04.ksh.bx:8010;
  server vm04.ksh.bx:8011;
  server vm04.ksh.bx:8012;
  server vm04.ksh.bx:8013;
  server vm04.ksh.bx:8014;
  server vm04.ksh.bx:8015;
}

# pub services
upstream nodejs_pub {
  ip_hash;
  keepalive 1024;
  server vm04.ksh.bx:9010;
  server vm04.ksh.bx:9011;
}

    В качестве имени сервера укажите имя или IP адрес сервера, на котором стоит push-server.

  2. Конфигурационный файл виртуальных серверов:
    # /etc/nginx/bx/site_enabled/rtc-server.conf

server {
    listen 8895 default_server;
    server_name _;

    # access_log  /var/log/nginx/access.log  main buffer=64k;
    # access_log  /dev/shm/access.log simple;
    # error_log  /var/log/nginx/error.log  warn;
    access_log off;

    add_header "X-Content-Type-Options" "nosniff";

    location /server-stat {
        access_log off;
        proxy_pass http://nodejs_pub;
    }

    location  /nginx_status {
        stub_status on;
    }

    location /bitrix/pub/ {
        # IM doesn't wait
        proxy_ignore_client_abort on;
        proxy_pass http://nodejs_pub;
    }

        include bx/conf/im_subscrider.conf;

    location / {
        deny all;
    }
}

server {
    listen 8893;
    listen 8894 default_server ssl;

    access_log off;
    add_header Access-Control-Allow-Origin *;

    server_name _;

    # ssl settings
    include bx/conf/ssl.conf;

    # Include error handlers
    include bx/conf/errors.conf;

    # Include im subscrider handlers
    include bx/conf/im_subscrider.conf;

    location ^~ /           { deny all; }
}

    Примечание: Доступ на сервер, обслуживающий /pub нужно открыть только для web-серверов, которые будут выполнять публикацию. Если все настройки находятся на одном хосте, то лучше всего использовать 127.0.0.1 адрес для этого сервера.

  3. В конфигурационом файле bx/conf/im_subscrider.conf содержаться настройки для публичных точек входа /bitrix/subws, /bitrix/sub и /bitrix/rest. Если предполагается их использование напрямую на сайте, а не отдельным виртуальным сервером, данный файл нужно подключить напрямую в конфиг сайта.
    # cat /etc/nginx/bx/conf/im_subscrider.conf
# Ansible managed
location ~* ^/bitrix/subws/ {
    access_log off;
   proxy_pass http://nodejs_sub;
   # http://blog.martinfjordvald.com/2013/02/websockets-in-nginx/
   # 12h+0.5
   proxy_max_temp_file_size 0;
   proxy_read_timeout  43800;
   proxy_http_version 1.1;
   proxy_set_header Upgrade $replace_upgrade;
   proxy_set_header Connection $connection_upgrade;
}

location ~* ^/bitrix/sub/ {
   access_log off;
   rewrite ^/bitrix/sub/(.*)$ /bitrix/subws/$1 break;
   proxy_pass http://nodejs_sub;
   proxy_max_temp_file_size 0;
   proxy_read_timeout  43800;
}

location ~* ^/bitrix/rest/ {
   access_log off;
   proxy_pass http://nodejs_pub;
   proxy_max_temp_file_size 0;
   proxy_read_timeout  43800;
}
  4. Подключите конфиги:
    # /etc/nginx/nginx.conf
include /etc/nginx/bx/site_enabled/rtc-server.conf;
include /etc/nginx/bx/settings/rtc-im_settings.conf;
  5. В случае виртуальной машины необходимо удалить конфигурацию старого сервера (push-stream-module) /etc/nginx/bx/conf/im_subscrider.conf и /etc/nginx/bx/site_enabled/push.conf.
  6. Перезапустите NGINX сервер.

Настройка сайта

В конфигурационный файл bitrix/.settings.php добавляем настройки вида:

'pull' => Array(
    'value' =>  array(
        'path_to_listener' => 'http://#DOMAIN#/bitrix/sub/',
        'path_to_listener_secure' => 'https://#DOMAIN#/bitrix/sub/',
        'path_to_modern_listener' => 'http://#DOMAIN#/bitrix/sub/',
        'path_to_modern_listener_secure' => 'https://#DOMAIN#/bitrix/sub/',
        'path_to_mobile_listener' => 'http://#DOMAIN#:8893/bitrix/sub/',
        'path_to_mobile_listener_secure' => 'https://#DOMAIN#:8894/bitrix/sub/',
        'path_to_websocket' => 'ws://#DOMAIN#/bitrix/subws/',
        'path_to_websocket_secure' => 'wss://#DOMAIN#/bitrix/subws/',
        'path_to_publish' => 'http://vm04.ksh.bx:8895/bitrix/pub/',
        'nginx_version' => '3',
        'nginx_command_per_hit' => '100',
        'nginx' => 'Y',
        'nginx_headers' => 'N',
        'push' => 'Y',
        'websocket' => 'Y',
        'signature_key' => 'ANzCW8X3ui4GokEqAh8fwinrSBnWj3dU1V0O3knHlwc224vBdIA8Yg1PhPU1G3tQaTcnorGO9skoWPbLiDV5eqnVcH2RgbKCP65yAHjiFfP4RJh60W9sxqISkcQxWQ0U',
        'signature_algo' => 'sha1',
        'guest' => 'N',
    ),
),

В качестве signature_key указываем настройки из /etc/sysconfig/push-server-multi.

grep SECURITY_KEY /etc/sysconfig/push-server-multi
SECURITY_KEY=ANzCW8X3ui4GokEqAh8fwinrSBnWj3dU1V0O3knHlwc224vBdIA8Yg1PhPU1G3tQaTcnorGO9skoWPbLiDV5eqnVcH2RgbKCP65yAHjiFfP4RJh60W9sxqISkcQxWQ0U


XMPP сервер
285 / 694
Модуль XMPP сервер предназначен для организации общения и учета присутствия сотрудников корпоративного портала, использующих Jabber-клиенты. Это можно делать только на выделенном сервере или на виртуальном выделенном сервере (VPS).

XMPP (англ. eXtensible Messaging and Presence Protocol — расширяемый протокол обмена сообщениями и информацией о присутствии, известный как Jabber) - это основанный на XML открытый, свободный для использования протокол для мгновенного обмена сообщениями и информацией о присутствии в режиме околореального времени. Протокол помимо передачи текстовых сообщений поддерживает передачу голоса и файлов по сети.

Примечание: Не во всех реализациях корпоративного портала используется модуль XMPP. Если вы отказываетесь от его использования, то учтите, что в функциях модуля Социальная сеть заложена обработка событий модулем XMPP на добавление сообщений. В этом случае при отправке сообщений в корпоративный портал (через Социальную Сеть) проходит очень много времени между посылкой сообщений и его отображением в окне переписки (например, секунд 10 висит "загрузка").

Самый простой способ решения проблемы в этой ситуации - удалить модуль XMPP на странице Модули (Настройки > Настройки продукта > Модули).

Дополнительная информация

  • XMPP сервер (пользовательская документация)


Настройка сервера
286 / 694
  • Закладка "Настройки"
  • Закладка "Социальная сеть"
  • Закладка "Доступ"
    •

    Для настройки сервера перейдите на страницу настроек модуля XMPP сервер (Настройки > Настройки продукта > Настройки модулей > XMPP сервер). На открывшейся странице настроек параметров модуля заполните следующие поля формы:

    Закладка "Настройки"

    • Домен – укажите домен вашего корпоративного портала;
    • Слушается - задайте IP-адрес, который будет слушать XMPP сервер.

      Примечание: Как правило, должно быть установлено значение 0.0.0.0.

    • Язык - укажите язык, в котором будет происходить обмен с XMPP сервером. В текущей версии должен быть указано en.
    • Путь к php - укажите путь к интерпретатору PHP. Например: C:\php\php.exe.

      • Путь к файлу может быть указан двумя способами:

      • прямой от корня файловой системы (в этом случае путь к файлу должен быть взять в кавычки, если в названия папок присутствует пробел);
      • в виде ../apache/php.exe -c ../apache/php.ini, если «Битрикс24 в коробке» установлен на "Битрикс Веб-окружение".

      Примечание: Для работы XMPP сервера необходима версия PHP не ниже 5.0.

    • Уровень логирования - задайте уровень логирования сервера:
      • 0 – максимально подробный уровень ведения лога;
      • 10 – минимально подробный уровень ведения лога.

      При нормальной работе сервера достаточно вести лог с уровнем 5.

    • Запустить SSL - укажите запускать SSL или нет при запуске XMPP сервера. При неустойчивой работе сервера SSL рекомендуется отключить.
    • Инфоблок для записи присутствия - Укажите инфоблок, в котором будет сохраняться история состояний (статусов) пользователя. Название элемента инфоблока будет соответствовать статусу пользователя, а запись в колонке Кем создана будет соответствовать имени сотрудника.

    Закладка "Социальная сеть"

    • В поле ID пользователя-отправителя для системных сообщений укажите пользователя, от имени которого будет производиться рассылка системных сообщений:

      • От имени пользователя Jabber - в данном случае поле Jabber ID отправителя для системных сообщений необходимо указать в идентификатор пользователя, от имени которого будет происходить рассылка сообщений. Например admin@mycompany.test.
      • От имени пользователя сайта - в данном случае в поле ID пользователя-отправителя для системных сообщений необходимо указать идентификатор пользователя на портале, от имени которого будет происходить рассылка сообщений.

    Закладка "Доступ"

    • При необходимости настройте права доступа к модулю.

    Сохраните внесенные изменения с помощью кнопки Применить.


Управление сервером
287 / 694

Для управлением XMPP сервером перейдите на страницу Сервер XMPP (Настройки > XMPP > Сервер XMPP). Откроется страница управления сервером:

Для запуска сервера нажмите на кнопку Запустить сервер. После запуска сервера на странице отобразится число пользователей на портале и число соединений XMPP сервера:

Для обновления данных нажмите кнопку Опросить сервер, для остановки сервера - Остановить сервер, для очистки кеша сервера - Очистить кеш.

Примечание: Посмотреть логи XMPP сервера можно по следующему пути: /bitrix/modules/xmppd.log


Клиент для XMPP
288 / 694

XMPP сервер работает с большинством менеджеров мгновенных сообщений, поддерживающих протокол XMPP.

Тем не менее, рекомендуется использовать сборку менеджера мгновенных сообщений Miranda, которую можно загрузить с сервера компании 1С-Битрикс.

Данная сборка прошла тестирование под конкретную реализацию XMPP сервера, и имеет возможности работы с группами «Битрикс24 в коробке».

Примечание: рекомендуем использовать штатный бизнес-чат Битрикс24 (подробнее о настройках чата на helpdesk ).


Проблемы и решения
289 / 694

Автозапуск сервера XMPP

Чтобы запустить XMPP вызывайте интерпретатор PHP (путь к нему можно посмотреть в из настройках модуля XMPP) с параметром полного пути к файлу xmppd.php.

Пример:

c:\php\php.exe c:\www\bitrix\modules\xmpp\xmppd.php

Соответствующую команду следует добавить в автозагрузку вашей системы.

Примечание: В продукте «1C-Битрикс: Виртуальная машина» уже реализован автозапуск сервера XMPP, причем в случае его остановки он будет перезапущен автоматически.

Нестабильная работа в режиме SSL

Проблема с нестабильной работой в режиме SSL относится не столько к работе XMPP-сервера, сколько к работе PHP в данном режиме.

Проблему можно решить, используя дополнительное ПО, например, stunnel. Эта программа работает на той же машине, что и xmpp сервер, держит соединение с клиентами по ssl и транслирует все запросы на порт 5222 без шифрования.

XMPP на разделяемом хостинге

Запуск сервера должен осуществляться на выделенном сервере или виртуальной машине (VPS).

Разделяемый хостинг не подходит, т.к. XMPP сервер - это фактически скрипт php, который исполняется неограниченно долгое время. Политика разделения ресурсов разделяемого хостинга не может позволить такое решение.

Кроме того, сервер должен монопольно занимать порт сервера 5222 для открытого доступа, это противоречит безопасности на разделяемом хостинге.


Библиотека документов
290 / 694
Внимание! Модуль Библиотека документов устарел. Оставлен в продукте для совместимости версий. Рекомендуется использовать модуль Диск

Средства системы коробочного Битрикс24 позволяют организовать специальный раздел коллективного доступа и работы над документами. Раздел может состоять из нескольких подразделов (библиотек), права доступа к которым могут быть различными для отдельных групп пользователей, рабочих групп.

Для нормальной работы системы поиска по содержимому документов, созданных в MS Office версий ранее 2007 (форматы doc, xls и ppt), необходимо произвести соответствующие настройки.

Внимание! На данный момент модуль Библиотека документов работает некорректно на веб-серверах под управлением IIS 7.x. Архитектура таких веб-серверов в базовом варианте не позволяет организовать работу PHP-скриптов по протоколу WebDav: сервер перехватывает все запросы и они не доходят до системы «Битрикс24 в коробке».


Настройка модуля
291 / 694

Глобальные параметры библиотеки документов определяются на странице настроек модуля Библиотека документов (Настройки > Настройки продукта > Настройки модулей > Библиотека документов):

Здесь можно указать следующие параметры:

  • Расширения документов для включения пункта меню "Редактировать в MS Office" - если загруженный в библиотеку документов файл будет иметь одно из указанных здесь расширений, то можно будет редактировать его каким-либо офисным редактором, выбрав соответствующий пункт в меню действий данного файла.
  • Скрывать системные файлы (начинающиеся с ".") - оставьте здесь галочку, если хотите чтобы не отображались системные файлы вида: .hgrc, .DS_Store.
  • Журналировать действия пользователей - отметьте данную опцию, если хотите чтобы информация об изменении документов вносилась в системный журнал событий.

    Примечание: при отмеченной опции журналироваться будут только события библиотеки документов на инфоблоках. К примеру, изменения файлов библиотеки документов на диске отмечаться не будут.

  • Интеграция с модулем соц. сети - снимите галочку, если хотите чтобы работа с библиотекой документов не отображалась в Социальной сети (к примеру, уведомления в Живой ленте о добавлении/изменении файлов в библиотеке документов).
  • Включить работу с документами через внешние службы (Google Docs, MS Office Web Apps и другие) - оставьте здесь галочку, если хотите чтобы работа с документами компании могла осуществляться через внешние сервисы.

    Примечание: Для правильной работы данного функционала необходимо предварительно настроить работу с документами через внешние службы Google Docs и MS Office Web Apps .

  • Разрешать работу с документами через внешние службы индивидуально в настройках библиотек групп и пользователей - оставьте здесь галочку, если разрешаете работу с личными документами и документами рабочих групп через Google Docs. В этом случае сотрудник портала (владелец группы) самостоятельно включает/отключает работу с документами через Google Docs в настройках личной библиотеки (библиотеки рабочей группы).
  • Автоматически подключать Диск группы при вступлении пользователя в группу - следует снять галочку, если вы не хотите, чтобы Диск группы подключался к диску сотрудника, в нее вступающего.

    Примечание: при снятии галочки подключенные Диски групп отключены не будут.

  • Путь для публичных ссылок - укажите путь, по которому будет формироваться адрес публичной ссылки документа.

Типы файлов

В типах файлов указываются параметры, необходимые для последующего поиска файлов по библиотеке документов на инфоблоках.

Указываются название типа документов и расширения, которые позволяют отнести файл к данному типу. Вы можете изменять названия и расширения, для этого щелкните по нужному полю левой кнопкой мыши:

Чтобы добавить какой-либо тип файлов, нажмите Добавить тип файлов, появятся пустые поля для ввода названия типа и расширений файлов:

Чтобы удалить какой-либо тип файлов, отметьте его галочкой в поле Удалить и нажмите Сохранить.

Указываемые типы файлов нужны для параметра Тип документа при использовании фильтра в публичном разделе:

Закладка "История документов"

На закладке История документов можно настроить параметры настройки истории документов:

  • Максимальное количество записей в истории документа - здесь можно указать максимально хранимое количество записей в истории изменений документа, вносимых сотрудниками.

    Примечание: если документ участвует в документообороте, то данный параметр настраивается в опциях модуля Документооборот.

  • Использовать склейку истории изменений документа - при выставленной галочке, в случае многократного изменения документа в течении периода времени, указанного в параметре История изменений документа склеивается в течении, секунд, сохраняться в истории документа будет первоначальная и предпоследняя версии экземпляров документа(последней версией считается сам документ).

    Внимание! "Склейка" не происходит и в историю добавляется новый экземпляр, если текущее время больше, чем дата последней версии документа + значение параметра.

  • История изменений документа склеивается в течении, секунд - выставляется количество секунд, в течении которого происходит "склейка" экземпляров в истории документа.


Создание библиотек документов
292 / 694
  • Создание библиотеки в административном разделе
  • Создание библиотеки средствами портала
  • Настройка библиотеки документов

Создание библиотеки в административном разделе

С помощью средств модулей Библиотека документов и Информационные блоки в продукте реализована возможность работы с библиотекой документов компании.

Для организации библиотеки должен быть создан тип инфоблока, например Документы, а для всех видов библиотек портала - соответствующие инфоблоки.

Например:

  • инфоблок Библиотека групп для файлов рабочих групп (закладка Файлы на странице рабочей группы);
  • инфоблок Библиотека пользователей для организаций персональных файловых хранилищ (закладка Файлы на личной странице);
  • инфоблок Документы для руководства для файлов руководящего состава;
  • инфоблок Маркетинг и продажи для хранения документов отдела маркетинга;
  • инфоблок Общие документы для коллективной библиотеки документов групп пользователей.

Примечание: при создании инфоблока особое внимание уделите закладке Доступ, на которой задаются права доступа групп пользователей к инфоблоку (в данном случае, к инфоблоку Общие документы):

Например, изменять документы общей библиотеки могут только пользователи группы Руководство и Сотрудники, полный доступ имеют группы Администраторы и Администрация портала, а для остальных пользователей доступен только просмотр документов.

В публичной части портала закрытые для просмотра пользователю библиотеки будут не видны.

Внешнее представление и управление библиотеками документов в публичном разделе можно осуществить с помощью комплексного компонента Библиотека (bitrix:webdav). Разместите компонент на странице, в настройках в качестве источника выберите Информационный блок и укажите тип инфоблоков и инфоблок, в котором будут храниться файлы (например, Документы и Общие документы соответственно).

Создание библиотеки средствами портала

Когда создан публичный интерфейс работы с документами, то всю работу по добавлению новых библиотек документов удобно выполнять с помощью средств публичного раздела портала. В главном меню перейдите в раздел с документами:

На корпоративном портале по способу доступа изначально есть три вида документов:

  • общие документы (доступные всем);
  • документы рабочих групп (доступные участникам групп);
  • личные документы (доступные одному человеку).

Можно создать библиотеку документов с доступом для любых выбранных вами людей.

Нажмите ссылку Добавить библиотеку, откроется окно мастера:

  • Укажите заголовок раздела, он будет отображаться как пункт меню раздела Документы на портале. Если вы не хотите, чтобы заголовок раздела был виден как пункт меню, снимите галочку в опции добавить пункт меню.
  • Если отключена генерация имени папки из названия раздела, то введите самостоятельно латинскими буквами имя папки для создания публичного интерфейса библиотеки. В этой папке будет создана индексная страница с размещенным на ней компонентом Библиотека (bitrix:webdav).

    Если необходимо отредактировать индексную страницу, то отметьте соответствующую опцию.
  • Если вы хотите ограничить доступ к создаваемому разделу для каких-либо групп сотрудников, отметьте галочкой опцию Ограничить доступ к разделу, и в открывшемся списке выберите группы, которым разрешен доступ (чтобы выбрать несколько групп, удерживайте нажатой клавишу Ctrl):

    Ссылка Настроить группы редакторов по умолчанию служит, чтобы перейти к настройкам модуля Управление структурой и указать каким группам сотрудников при создании файлов и папок автоматически устанавливать полный к ним доступ.

Нажмите кнопку Далее. Если вы не снимали галочку в опции Добавить пункт меню, то отобразится форма настройки отображения пункта меню:

Здесь вы можете изменить имя нового пункта, а также выбрать в каком меню его отображать и каким по очереди.

Нажмите Далее и вы попадете в форму настройки библиотеки документов:

Измените в случае необходимости имя библиотеки, выберите тип инфоблока и укажите, создавать новый, или использовать существующий инфоблок для хранения данных.

Примечание: если в качестве источника данных выбрать Физическая папка на диске, то некоторые поля будут убраны.

Здесь же вы можете настроить права доступа к библиотеке для групп сотрудников:

  • Чтение - разрешается просмотр документов библиотеки.
  • Бизнес-процессы - разрешается запускать бизнес-процессы с документами библиотеки.
  • Запись - разрешается загружать документы.

Нажмите кнопку Далее, чтобы указать свойства раздела, а для создания библиотеки нажмите Готово.

Настройка библиотеки документов

Со страницы библиотеки документов можно перейти к ее настройкам, нажав на контекстной панели кнопку Еще и выбрав пункт Настройки:

Откроется форма, на которой вы можете задать права доступа к инфоблоку, его участие в документообороте и бизнес-процессах, а также добавить пользовательские поля:

Пользовательские поля поддерживаются в общей библиотеке и библиотеках групп, но не в персональных хранилищах, и необходимы для указания каких-либо свойств или параметров загружаемых файлов.

Рассмотрим пример добавления пользовательского поля, в котором будет указываться актуальность загружаемого документа для партнерского отдела.

Нажмите ссылку Добавить пользовательское поле, откроется форма добавления:

Заполните поля в соответствии со скриншотом:

  • в поле Тип данных выберите Да/Нет;
  • введите код поля (UF_YES_NO);
  • сделайте создаваемое поле необязательным для заполнения;
  • запретите его редактирование пользователями.

    Примечание: если вы в дальнейшем измените данный параметр пользовательского поля, то изменение коснется всех загруженных ранее документов.

    Примечание: при разрешенном редактировании его можно произвести на закладке свойств документа, выбрав Свойства и описание в меню действий документа:

  • для возможности поиска по значениям создаваемого вами поля отметьте галочкой опцию Значения поля участвуют в поиске;
  • в качестве внешнего вида выберите Радио кнопки;
  • в языковых настройках введите то, как будет подписано данное поле при загрузке документа. В нашем случае это Актуально для партнерского отдела.

Об остальных полях формы вы можете прочитать в пользовательской документации.

Нажмите Сохранить и поле будет добавлено в общий список, расположенный на странице административного раздела Настройки > Настройки продукта > Пользовательские поля.

Теперь при загрузке каких-либо файлов в библиотеку документов на данном инфоблоке, ваше пользовательское поле будет доступно для заполнения:

Указанное значение будет отображаться в форме свойств документа (пункт Свойства и описание в меню действий документа).


Выставление прав доступа
293 / 694

Рассмотрим как можно настроить параметры доступа к библиотекам документов в зависимости от используемого источника данных:

  • Физическая папка на диске
  • Информационный блок

Физическая папка на диске

Для библиотек документов, использующих в качестве источника данных физическую папку на диске, права доступа к файлам можно настроить при создании библиотеки. Если при создании библиотеки права доступа заданы не были, то наследуются заданные по умолчанию: для группы Сотрудники - Чтение, для группы Администрация портала - Полный доступ, для всех остальных - Доступ закрыт.

Чтобы перенастроить права доступа для библиотеки документов, берущей данные с папки на диске, нажмите Доступ:

В открывшемся окне укажите необходимые права доступа:

  • Доступ закрыт - запрет на любые действия.
  • Полный доступ - разрешены все возможные действия.
  • Запись - данное право идентично полному доступу.
  • Чтение - разрешен только просмотр.
  • Документооборот - в библиотеке документов на основе физической папки отсутствует документооборот/бизнес-процессы, поэтому данное право даст возможность только чтения.

Права доступа обладают свойством "наследования", т.е. если для текущего раздела/страницы явно не задан уровень прав, то устанавливается то право, которое задано для вышележащего раздела.

Информационный блок

Настройки прав доступа непосредственно к библиотеке документов задается в настройках соответствующего информационного блока. Переход к настройкам осуществляется со страницы библиотеки по кнопке контекстной панели Еще, выбрав пункт Настройки:

Откроется форма настройки прав доступа к инфоблоку и участия его в документообороте и бизнес-процессах:

Если опция Расширенное управление правами не отмечена, то выполняется простая настройка прав доступа к библиотеке для групп пользователей, созданных в системе. Ссылка Добавить группу служит для добавления полей, с помощью которых можно выбрать группу пользователей и назначить ей некоторое право доступа.

Если опция Расширенное управление правами отмечена, то форма имеет несколько другой вид:

В этом случае общая настройка прав доступа ко всей библиотеке может быть выполнена для:

  • групп пользователей системы;
  • некоторых отдельных пользователей системы;
  • некоторых сотрудников компании или сотрудников некоторого всего отдела;
  • групп социальной сети или некоторых их участников.

Ссылка Добавить служит для перехода к окну выбора категорий пользователей, для которых необходимо настроить права доступа к библиотеке документов:

Выберите тех, для кого следует настроить права, и задайте им необходимые уровни прав доступа к библиотеке (о том, как работать с данной формой, вы можете прочитать в уроке Права доступа).

Кроме того, расширенный режим управления правами позволяет настроить отдельные права доступа на некоторые папки и документы библиотеки.

Внимание! Информация ниже актуальна только для расширенного режима настройки прав инфоблоков.

По умолчанию доступ к папкам и файлам библиотеки документов определяется настройками инфоблока. Чтобы задать отдельные права доступа к конкретной папке (файлу аналогично), в ее меню действий выберите Права доступа:

В открывшейся форме указаны текущие права доступа:

Примечание: Права доступа, которые наследуются от библиотеки изменить невозможно.

С помощью ссылки Добавить выберите необходимые категории пользователей и назначьте им необходимые уровни прав доступа. На папку (файл) возможно назначение следующих прав доступа:

  • Нет доступа - доступ к папке (файлу) запрещен.
  • Добавление - можно загружать документы, но при этом нельзя будет их просматривать.
  • Чтение - разрешен только просмотр папки и документов.
  • Изменение - идентично полному доступу, но нельзя управлять правами доступа.
  • Изменение с ограничениями - можно редактировать и удалять файлы, разделы изменять запрещено.
  • Полный доступ - полный доступ к папке (файлу).

Важно! Помните о том, что приоритет доступа имеет разрешающую направленность. К примеру, если в настройках инфоблока доступ к библиотеке документов для сотрудника запрещен, а для папки в составе этого инфоблока - разрешен, то сотрудник сможет с ней работать. В обратном случае (для инфоблока - разрешен, для папки-запрещен) - сотрудник все равно будет иметь к ней доступ в соответствии с выставленным правом доступа.


Автоматическая настройка компьютеров в корпоративной сети для работы с webdav
294 / 694

Автоматическая настройка компьютеров в корпоративной сети для работы с webdav

Как Вы уже знаете, в коробочной версии сервиса «1С-Битрикс24» есть полезнейший сервис, позволяющий организовать специальный раздел коллективного доступа и работы над документами - Библиотека документов (webdav).

Однако если в корпоративной сети много компьютеров, которые нужно настроить на работу с этим модулем, то системный администратор потратит слишком много времени, настраивая ПК вручную.

В этом уроке Вы узнаете, как сделать автоматическую настройку этих компьютеров.

  1. Скачайте файл с расширением *.reg, как описано здесь, и переименуйте его в BAuthFix.reg.

  2. Воспользуйтесь стандартным способом распространения файлов с расширением *.reg через групповые политики:

    В редакторе реестра (REGEDIT.EXE) внесите изменения в режиме /s silent :

    • Создайте новый объект групповой политики (adm-файл) и свяжите его с требуемой группой компьютеров, которые настроены для всех административных пользователей в домене (в том числе свой);
    • Откройте созданный объект (Конфигурация пользователя > Конфигурация Windows > Сценарии (вход/выход из системы));
    • В узле Вход в систему выполните настройки таким образом, чтобы Regedit.exe вызывал файл BAuthFix.reg в автоматическом режиме (с помощью переключателя /s);

    • Кликните Показать файлы (Show Files) и поместите BAuthFix.reg в SYSVOL.

    Эта групповая политика будет реплицироваться в рамках домена.

При входе с любого ПК этого домена служба "Веб-клиент" будет запускаться в автоматическом режиме.


Ошибки, возникающие при работе с библиотекой в ОС Windows
295 / 694
  • Ограничения ОС Windows
  • Таблица сравнений клиентских WebDAV-приложений
  • Запуск службы Веб-клиент
  • Разрешение авторизации без https
    • Изменение параметров с помощью файлов *.reg
    • Изменение параметров с помощью Редактора реестра
  • Увеличение максимального размера загружаемых файлов

Ограничения ОС Windows

В Windows XP всегда необходимо указывать номер порта, даже в том случае, если используется 80 порт (http://servername:80/).

В Windows Vista запрещена базовая авторизация (Basic Authorization), необходимо внести изменения в реестр.

В Windows 7 запрещена базовая авторизация (Basic Authorization), необходимо внести изменения в реестр. Компонент веб-папок не работает по защищенному протоколу. Для работы с библиотекой из Windows 7 по протоколу HTTPS необходимо использовать путь вида: \\<ваш_сервер>@SSL\DavWWWRoot\docs\shared вместо http://<ваш_сервер>/docs/shared/.

Если требуется указание порта, то он указывается таким образом: @SSL:443\.

В Windows 2008 Server не установлена служба Веб-клиент (WebClient). Необходимо установить Дополнения (Features) след. образом:

  • Перейдите на Start > Administrative Tools > Server Manager > Features;
  • Справа сверху нажмите на Add Features;
  • Выберите Desktop Experience, установите.

Так же необходимо внести изменения в реестр.

Внимание! Прежде, чем подключать библиотеку документов, убедитесь, что запущена служба Веб-клиент (WebClient).

Таблица сравнений клиентских WebDAV-приложений

Примечание: При использовании WebDAV-клиента для управления библиотекой в случае документооборота или бизнес-процессов, есть некоторые ограничения:
  • нельзя запустить бизнес-процесс для документа;
  • нельзя загружать, изменять документы, если на автозапуске находятся бизнес-процессы с обязательными параметрами автозапуска без значений по-умолчанию;
  • нельзя проследить историю документа.

WebDAV-клиент | Авторизация базовая (Basic) | Авторизация Windows (IWA) | SSL | Порт | Установлен в ОС
Веб-папка, Windows XP | + | + | + | все | +
Веб-папка, Vista SP1 | + | + | + | все | +
Веб-папка, Windows 7 | + | + | + | все | +
Веб-папка, Windows 2003/2000 | + | + | + | все | -
Веб-папка, Windows Server 2008 | + | + | + | все | -
Сетевой диск, Windows XP | + | + | + | все | +
Сетевой диск, Vista SP1 | + | + | + | все | +
Сетевой диск, Windows 7 | - | + | - | 80 | +
Сетевой диск, Windows 2003/2000 | - | + | - | 80 | +
MS Office 2007/2003/XP | + | + | + | все | -
MS Office 2010 | + | + | только | все | -
MAC OS X | + | - | + | все | +

При подключении папок из раздела Документы могут возникать ошибки, связанные с настройкой ОС Windows. За работу службы Веб-клиент в операционной системе отвечает специальный системный параметр. По умолчанию в ОС Windows XP он включен, а в Windows Vista - настроен на работу по защищенному протоколу HTTPS. Возможны ситуации, когда и в Windows XP это параметр будет не соответствовать значениям по умолчанию.

В этих случаях кнопка Сетевая папка, а также возможность подключиться к диску или редактировать документы при помощи офисного редактора будет невозможным. Чтобы исправить ошибки с этим связанные необходимо проверить и выполнить несколько настроек.

Запуск службы Веб-клиент

Для этого перейдите: Пуск > Панель управления > Администрирование > Службы. Откроется диалог Службы:

Найдите в общем списке служб строку Веб-клиент. В колонке Состояние должно стоять Работает.

Если служба не запущена (отсутствует надпись Работает в колонке Состояние), то кликнете на строке со службой правой кнопкой мыши, вызовите контекстное меню. В этом меню выполните команду Пуск. Служба запуститься.

Чтобы служба запускалась в дальнейшем при старте операционной системы, кликнете на строке со службой, вызовите контекстное меню. В контекстном меню выполните команду Свойства. Откроется диалог свойств службы Веб-клиент:

В выпадающем списке Тип запуска выберите Авто. Сохраните внесенные изменения.

Теперь служба будет запускаться автоматически при запуске операционной системы. Можно приступать непосредственно к подключению папки.

Разрешение авторизации без https

Для решения этой проблемы необходимо изменить параметр Basic authentication в реестре ОС. Сделать это можно двумя способами: с помощью Редактора реестра или с помощью специальных скриптов в дистрибутиве продукта «Битрикс24 в коробке».

Изменение параметров с помощью файлов *.reg

Способ рекомендуется для обычных пользователей.

Откройте новое окно браузера Internet Explorer. Введите в адресной строке браузера:

  • - для ОС Windows XP: http://<ваш_портал>/bitrix/webdav/xp.reg.
  • - для ОС Windows Vista: http://<ваш_портал>/bitrix/webdav/vista.reg.

Запустится окно загрузки и запуска файла:

Нажмите кнопку Запустить. Начнется загрузка файла. После ее завершения откроется диалог Редактора реестра с предупреждением о недостоверности источника:

Примечание: при использовании других браузеров загрузка файла на локальный компьютер произойдет, но автоматически не запустится Редактор реестра. Необходимо вручную запустить загруженный файл.

Нажмите кнопку Да. Изменения будут внесены в реестр, появится соответствующее сообщение об изменении реестра. Перегрузите компьютер.

Изменение параметров с помощью Редактора реестра

Этот способ рекомендуется только для системных администраторов, понимающих особенности работы с реестром.

Выполните команду: Пуск > Выполнить. Откроется окно Запуск программы:

В поле Открыть введите regedit и нажмите кнопку ОК. Откроется редактор реестра:

Нажмите на рисунок, чтобы увеличить

Для Windows XP необходимо найти параметр:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters]
"UseBasicAuth"=dword:00000001

Если параметр отличается от указанного в листинге, то выставьте его равным 1.

Для Windows Vista и Windows 7 нужно найти параметр:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters]
"BasicAuthLevel"=dword:00000002

Если параметр отличается от указанного в листинге, то выставьте его равным 2.

Примечание:

При переходе на новую версию MS Office 2010 Prof возможны ошибки при синхронизации с Outlook 2010. В результате ошибки выводится сообщение: Задача 'SharePoint' сообщила об ошибке (0x80070005) : 'Отсутствуют разрешения на просмотр этого списка SharePoint. Обратитесь к администратору сайта SharePoint. HTTP 401.'

Причина в том, что Outlook 2010 не поддерживает простую авторизацию. Для авторизации требуется либо использовать ntlm (авторизация на AD-сервере), либо необходмо работать с сервером через SSL (https). При https варианте, начиная с Windows 7, потребуется также иметь действующий ssl-сертификат (сгенерированный самостоятельно работать не будет).

Решение: добавить в реестре по пути:

HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet

ключ

"BasicAuthLevel"=dword:00000002

Перезапустите службу Веб-клиент.

Увеличение максимального размера загружаемых файлов

Максимальный размер загружаемого файла - это минимальные значения переменных PHP (upload_max_filesize и post_max_size) и параметры настройки компонентов.

Если вы хотите увеличить квоту, которая превышает рекомендуемые значения, то внесите следующие изменения php.ini:

upload_max_filesize = желаемое_значение;
post_max_size = превышает_размер_upload_max_filesize;

Если вы арендуете площадку (виртуальный хостинг), то внесите изменения в файл .htaccess:

php_value upload_max_filesize желаемое_значение
php_value post_max_size превышает_размер_upload_max_filesize

Возможно, вам придется обратиться к хостеру с просьбой увеличить минимальные значения переменных PHP (upload_max_filesize и post_max_size).

После того, как будут увеличены квоты PHP, следует внести изменения в настройки компонентов.


Бизнес-процессы
296 / 694

Сам модуль Бизнес-процессы настроек не имеет, однако, для корректной его работы необходимо произвести настройки прав доступа для пользователей и настройки инфоблоков.

Права на бизнес-процесс

При создании бизнес-процесса при выборе пользователей в настройках действий в форме Вставка значений выводятся только те пользователи, которые имеют соответствующий уровень доступа к типу документа, для которых создаётся бизнес-процесс.

Например, если в настройках информационного блока для определённой группы пользователей будет выставлен уровень прав Чтение, то они не будут иметь доступа к работе с бизнес-процессами инфоблока, хотя могут просматривать его элементы.

Примечание: Настройки библиотеки документов и прочих инфоблоков для работы с бизнес-процессами описаны в главе Бизнес-процессы раздела Администратор КП.

Примечание: Подробнее про работу с бизнес-процессами в публичной части смотрите в курсе Пользователь корпоративного портала, глава Бизнес-процессы.

Примечание: Если проектируемый процесс будет иметь сложную структуру, то лучше использовать Бизнес-процесс со статусами.

Ссылки по теме:
  • Модуль Бизнес-процессов (Блог)
  • Бизнес-процессы (пользовательская документация)


Общая информация
297 / 694

Что такое Бизнес-процессы

Бизнес-процесс - это процесс обработки документа, для которого задана одна точка входа и несколько точек выхода и последовательность действий (шагов, этапов, функций), совершаемых в заданном порядке и в определенных условиях.

Другими словами Бизнес-процесс – последовательность действий, направленных на получение заданного результата.

В системе все бизнес-процессы работают с так называемыми документами (файл, элемент инфоблока, элемент CRM) и их версиями. Для каждого документа (инфоблок, списки и т.п.) существуют свои шаблоны бизнес-процессов. Поддерживаемые типы документов:

  • Элементы инфоблоков в административной части
  • Элементы универсального списка
  • Файлы из библиотеки документов («Битрикс24 в коробке»)
  • Элементы CRM («Битрикс24 в коробке»)
  • "Виртуальный документ" (для бизнес-процессов организаций, реализуемых с помощью компонента Бизнес-процесс (комплексный компонент) в публичной части сайта)

Где можно найти Бизнес-процессы

В продуктах компании 1С-Битрикс бизнес-процессы можно найти в следующих местах:

  • Инфоблоки в административной части сайта («1С-Битрикс: Управление сайтом» и «Битрикс24 в коробке»)
  • Универсальные списки («Битрикс24 в коробке», Сервисы > Списки)
  • Библиотека документов («Битрикс24 в коробке», Документы)
  • CRM («Битрикс24 в коробке»)

Права на бизнес-процесс

В большинстве случаев для корректной работы модуля Бизнес-процессы необходимо произвести настройки прав доступа для пользователей и настройки инфоблоков.

При создании бизнес-процесса при выборе пользователей в настройках действий в форме Вставка значений выводятся только те пользователи, которые имеют соответствующий уровень доступа к типу документа, для которых создаётся бизнес-процесс.

Например, если в настройках информационного блока для определённой группы пользователей будет выставлен уровень прав Чтение, то они не будут иметь доступа к работе с бизнес-процессами инфоблока, хотя могут просматривать его элементы.

Видео

Видеозаписи с вебинаров по Битрикс24, в которых рассказывается о том, что такое бизнес-процессы, как с ними работать, а также рассмотрены примеры их использования.

Примечание: В данных роликах рассмотрен функционал в рамках сервиса Битрикс24, но общие сведения и принципы переносимы и на остальные продукты, в которых используются бизнес-процессы.

Функционал может меняться со временем выхода новых версий и отличаться от показанного в ролике.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Вебинар Роботы и бизнес-процессы. RPA с точки зрения разработчика. Техноволна 1 от 06 апреля 2020.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Документация по теме:

  • Пользовательская документация по модулю "Бизнес-процессы"
  • Модуль Бизнес-процессов (блог)


Типы бизнес-процессов
298 / 694

При помощи модуля Бизнес-процессы могут быть описаны два типа бизнес-процессов: последовательный и со статусами.


Последовательный бизнес-процесс
299 / 694

Шаг за шагом

Последовательный бизнес-процесс — действия выполняются одно за другим от точки входа до точки выхода.

Последовательный бизнес-процесс представляет собой бизнес-процесс как набор шагов, которые следует выполнять по порядку до тех пор, пока они все не завершатся. Он похож на обычную блок-схему, описывающую алгоритм решения задачи.

Последовательный бизнес-процесс начинает работу, выполняя находящееся в нем первое дочернее действие, и продолжается до тех пор, пока не выполнит все остальные дочерние действия.


Бизнес-процесс со статусами
300 / 694

Если нужно настроить произвольные действия и состояния

Бизнес-процесс со статусами (так же известный как машина состояний или автомат на состояниях) — начала и конца не имеет, в процессе работы происходит переход из одного состояния в другое.

Бизнес-процесс со статусами представляет собой набор состояний, переходов и действий. Одно состояние обозначается как начальное состояние. В процессе выполнения процесс переходит из одного состояния в другое, основываясь на событиях.

При переходе бизнес-процесса в любой из статусов выполняется последовательный подпроцесс для инициализации этого статуса. После чего бизнес-процесс становится в ожидание одного из определенных в данном статусе событий. Список возможных событий и их названия могут быть получены для отображения в пользовательском интерфейсе. На каждое событие может быть получен список групп пользователей, которые имеют право отправлять данное событие.

При возникновении события выполняется последовательный подпроцесс, соответствующий принятому событию (связанный с ним).

Среди действий подпроцесса может быть действие по установке нового статуса. В этом случае бизнес-процесс переводится в новый статус. Если такого действия нет, то текущий статус считается конечным и бизнес-процесс завершается.

Если для данного статуса определен последовательный подпроцесс для финализации этого статуса, то он выполняется непосредственно перед выходом из данного статуса (перед переходом в другой статус).

Документация по теме:

  • Создание шаблона бизнес-процесса со статусами
  • Пример использования бизнес-процесса со статусами для организации обработки и доработки документа


Выбор типа бизнес-процесса
301 / 694

Практически любая возникающая задача может быть решена как с помощью последовательного бизнес-процесса, так и с помощью бизнес-процесса со статусами. Выбор не оптимального типа бизнес-процесса для конкретной задачи существенно усложнит шаблон бизнес-процесса.

Тип последовательный бизнес-процесс выбирается в том случае, если просто необходимо выполнить определенную последовательность действий.

Тип бизнес-процесс со статусами выбирается в том случае, если бизнес-процесс (документ) может находиться в разных состояниях, переходы между которыми осуществляются по определенным правилам. При этом появляется возможность автоматически контролировать права на доступ к документу в разных состояниях и на выполнение переходов между состояниями. Для каждого состояния может быть задан набор событий, при возникновении которых выполняются соответствующие подпроцессы.


Типовые бизнес-процессы
302 / 694
Типовые бизнес-процессы - образцы часто используемых процессов, которые включены в состав продуктов «1C-Битрикс», содержащих модуль Бизнес-процессы.


Список типовых бизнес-процессов
303 / 694

Какие процессы часто используются

Типовые бизнес-процессы - образцы часто используемых процессов, которые включены в состав продуктов «1C-Битрикс», содержащих модуль Бизнес-процессы.

Типовые бизнес-процессы включены в состав младших редакций как неизменяемые процессы. Они настраиваются на работу с нужными сотрудниками, но схема прохождения документа остается неизменной. Изменение шаблонов типовых бизнес-процессов, а также создание собственных шаблонов возможно только при наличии модуля Дизайнер бизнес-процессов , который доступен только в старших редакциях .

Типовые бизнес-процессы для документов

  • Двухэтапное утверждение (последовательный процесс)
    Нажмите на рисунок, чтобы увеличить
Рекомендуется для ситуаций утверждения документа с предварительной экспертной оценкой. В рамках процесса на первом этапе документ утверждается экспертом. Если документ им не утвержден, то он возвращается на доработку. Если утвержден, то документ передается для принятия решения группой сотрудников простым большинством голосов. Если документ не принят на втором этапе голосования, то он возвращается автору на доработку и повторяется процесс утверждения.
  • Экспертная оценка (последовательный процесс)
    Нажмите на рисунок, чтобы увеличить
Рекомендуется для ситуаций, когда для принятия решения по документу лицу, принимающему решение, требуется экспертная оценка по документу. В рамках процесса назначается экспертная группа, каждый участник которой высказывает свое мнение по документу. Мнения передаются лицу, принимающему решение, который утверждает или нет документ.
  • Ознакомление с документом (последовательный процесс)
    Нажмите на рисунок, чтобы увеличить
Предназначен для ситуаций, когда группу сотрудников требуется ознакомить с каким-то документом. В рамках процесса задается группа работников, которая должна быть поставлена в известность. Дается право оставлять комментарии.
  • Простое утверждение/голосование (последовательный процесс)
    Нажмите на рисунок, чтобы увеличить
Рекомендуется для ситуаций, когда требуется принятие решения простым большинством голосов. В его рамках включают в список голосующих нужных сотрудников, дают возможность комментировать свое решение голосовавшим. По окончании голосования всем участникам сообщается принятое решение.
  • Утверждение документа со статусами (бизнес-процесс со статусами)
    Нажмите на рисунок, чтобы увеличить
Прохождение документом цепочки утверждения со статусами.
  • Утверждение по первому голосу (последовательный процесс)
    Нажмите на рисунок, чтобы увеличить
Рекомендуется для ситуаций, когда достаточно одного экспертного мнения из некоторого сообщества. В рамках этого процесса задается список сотрудников, имеющих право принять решение c уведомлением о начавшемся процессе. Процесс считается завершенным по первому отозвавшемуся сотруднику.

Универсальный бизнес-процесс оплаты счетов (только для коробочной версии Битрикс24)

Запускается в рамках Универсального списка Счета на странице Счета (Сотрудники > Списки > Счета). Бизнес-процесс реализован с учетом новых прав доступа и интегрирован с задачами. Он "проводит" счет по этапам утверждения от сотрудника до директора, и только затем счет уходит в бухгалтерию на оплату.

Настроим бизнес-процесс перед началом работы:

  • Дадим права доступа к списку (выполняет администратор);
  • Настроим параметры шаблона;
  • Создадим разделы.

Бизнес-процесс построен так:

  • "Автор" создает элемент списка Счет (заполняет все поля);
  • Сообщение о новом счете (о необходимости утвердить счет) уходит "Начальнику подразделения" (через Обмен сообщениями или почтой);
  • После утверждения "Начальником подразделения" счет идет на утверждение "Директору по маркетингу";
  • Потом счет утверждает "Генеральный директор" или "Директор по развитию компании";
  • Счет переводится в статус "К оплате";
  • Сообщение об оплате получает "Бухгалтер подразделения". После оплаты он меняет статус на "Оплачен";
  • Автору уходит сообщение о необходимости собрать документы;
  • После того, как документы собраны (отданы в бухгалтерию), автор меняет статус на "Документы собраны";
  • "Бухгалтер подразделения" подтверждает это;
  • Бизнес-процесс закрывается.

Типовые бизнес-процессы организации

Бизнес-процессы организации предназначены для автоматизации деятельности организации. По умолчанию создано и представлено пять типовых бизнес-процессов:

  1. Выдача наличных
  2. Исходящие документы
  3. Счет на оплату
  4. Заявление на отпуск
  5. Заявление на командировку

Администратор изменяет и копирует бизнес-процессы. А в редакции продукта Компания - создает собственные.


Создание шаблонов типовых бизнес-процессов
304 / 694

Как создать шаблон

Типовые шаблоны бизнес-процессов создаются автоматически при установке продуктов «1C-Битрикс». Посмотрим, каким образом создать их, если по каким-либо причинам типовые процессы не были созданы при установке.

Действия по созданию шаблонов

  • Универсальные списки (публичная часть сайта)
    • перейти к желаемому списку на соответствующей странице Списки (Сервисы > Списки);
    • перейти к списку шаблонов бизнес-процессов с помощью кнопки Бизнес-процессы , расположенной на странице просмотра списка;
    • воспользоваться соответствующей ссылкой для создания шаблонов бизнес-процессов.

  • Общий диск
    • перейти на страницу Общий диск (Диск > Общий диск);
    • перейти к списку шаблонов бизнес-процессов с помощью пункта Бизнес процессы в меню настроек;
      Примечание: Если в меню настроек нет пункта Бизнес-процессы, то нужно включить поддержку бизнес-процессов для библиотеки, выбрав пункт Настройка бизнес-процессов, и в открывшейся форме включив опцию Активировать бизнес-процессы .
    • воспользоваться соответствующей ссылкой для создания шаблонов бизнес-процессов.

  • Инфоблоки (административная часть сайта)
    • перейти на страницу редактирования инфоблока (Контент > Инфоблоки > Типы инфоблоков > [требуемый_инфоблок]);
    • включить поддержку бизнес-процессов установив для опции Участвует в документообороте или бизнес процессах значение бизнес процессы ;
    • на закладке Шаблоны бизнес-процессов отобразятся типовые шаблоны.
      • Примечание: Перейти к списку шаблонов возможно непосредственно из самого инфоблока с помощью кнопки Шаблоны бизнес-процессов (если данный инфоблок участвует в бизнес-процессах).

  • CRM (публичная часть сайта, «Битрикс24 в коробке»)
    • перейти на страницу настроек бизнес-процессов в CRM (CRM > Настройки > Роботы и бизнес-процессы > Бизнес-процессы);
    • перейти на страницу со списком шаблонов бизнес-процессов для требуемой сущности с помощью соответствующей ссылки ;
    • воспользоваться соответствующей ссылкой для создания шаблонов бизнес-процессов.

  • Бизнес процессы организаций (публичная часть сайта, «Битрикс24 в коробке»)

    Типовые шаблоны устанавливаются автоматически с установкой модуля Бизнес-процессы.

Удаление шаблонов типовых бизнес-процессов

Для удаления шаблона бизнес-процесса используйте пункт меню действий Удалить .

Важно: удалить шаблон незавершенного бизнес-процесса нельзя.


Типовые бизнес-процессы для коробочной версии «Битрикс24»
305 / 694

В данной главе будут рассмотрены штатные бизнес процессы, которые присутствуют только в коробочной версии "Битрикс24".


Бизнес-процессы документов
306 / 694

Запускаем бизнес-процесс документов

Давайте посмотрим как настроить автозапуск и запуск вручную для бизнес-процессов документов в коробочной версии Битрикс24.

Важно! Для работы с бизнес-процессами на портале у пользователя должен быть определенный уровень доступа. Если вы не можете работать с бизнес-процессами на портале, обратитесь к Администратору портала.

Настройка автозапуска для бизнес-процессов документов

Настройка выполняется на странице Бизнес-процессы (меню настроек в разделе Диск > Общий диск):

  • открываем список бизнес-процессов;
  • на странице Шаблоны бизнес-процессов в меню действий выбираем способ автоматического запуска бизнес-процесса - Запускать при создании или Запускать при изменении;
  • статус запуска бизнес-процесса отобразится в колонке Автозапуск .

    Примечание: Например, в нашем случае при загрузке документов автоматически запуститься бизнес-процесс Утверждение документа со статусами. Когда сотрудник загружает файл в данный раздел документов, то он должен указать все необходимые параметры запуска бизнес-процесса.

Запуск бизнес-процессов вручную

Чтобы запустить вручную бизнес-процесс для некоторого документа:

  • В меню действий документа выберите пункт Бизнес-процессы, а затем в предложенном списке найдите необходимый бизнес-процесс (например, Ознакомление с документом);
  • Укажите необходимые параметры запуска бизнес-процесса и нажмите кнопку Запустить .

Бизнес-процесс запустится и начнет выполняться в соответствии со своим шаблоном и произведенными настройками.

Бизнес-процессы сотрудника

Каждому сотруднику отображается список запущенных им бизнес-процессов с помощью анимированных иконок в колонке Название после названия файла в списке документов. Если вы участвуете в бизнес-процессе, то рядом с анимированной иконкой увидите восклицательный знак .

Выполнение назначенных заданий по бизнес-процессу осуществляется на закладке Бизнес-процессы личной страницы.


Бизнес-процессы организации
307 / 694

Запускаем бизнес-процесс документов

Бизнес процессы организации предназначены для автоматизации деятельности организации. По умолчанию создано и представлено пять типовых бизнес-процессов :

  1. Выдача наличных
  2. Исходящие документы
  3. Счет на оплату
  4. Заявление на отпуск
  5. Заявление на командировку

Администратору доступно изменение и копирование бизнес процессов. А в редакции продукта Компания - создание собственных . Работа с бизнес-процессами осуществляется через пункт меню Бизнес-процессы .

Выполнение заданий бизнес-процессов

Видео: Работа с бизнес-процессами организации (содержание может отличаться от текущей версии продукта)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Как только появятся процессы, требующие внимания, их количество будет отражено рядом с пунктом меню Бизнес-процессы. Выполнение назначенных заданий по бизнес-процессам организации осуществляется на закладке Задания бизнес-процессов (Бизнес-процессы> Задания бизнес-процессов). На закладке видим информацию о бизнес-процессе, вывод которой настраивается, если щелкнуть правой кнопкой мыши по шапке таблицы. Также приведено описание действий , которые необходимо сделать.

Варианты получения подробной информации о каждом действии:

  • Выберите соответствующую команду в меню действий.
  • Кликните правой кнопкой мыши по строке действия и выберите Подробнее.
  • Дважды кликните левой кнопкой мыши по строке действия.

Воспользуйтесь фильтром процессов для поиска необходимых процессов в списке. Руководитель подразделения сможет найти процессы, выполняемые его подчиненными, и делегировать их.

Процессы в ленте

На странице Процессы в ленте (Бизнес-процессы> Процессы в ленте) пользователь просматривает и запускает бизнес-процессы, к которым у него есть доступ. Также в этом разделе администратор указывает , какие из этих процессов доступны для вызова прямо из Живой ленты .

Вызов бизнес-процессов из вкладки Мои процессы

Вызов бизнес-процессов на исполнение возможен и через закладку Бизнес-процессы> Мои процессы. Эта страница хранит все процессы, которые вызывались вами, включая историю их исполнения и полную информацию о них.

Расположение вкладки Мои процессы в старых версиях коробочного Битрикс24

После нажатия на кнопку Запустить процесс предлагается заполнить поля с входными параметрами вашего процесса. Однако настройки параметров работы (Кто утверждает, Кто оплачивает и т.п.) должны быть предварительно проведены, иначе бизнес-процесс не начнет свое выполнение.

Все активные

На странице Все активные (Бизнес-процессы> Все активные) отображен список активных запущенных процессов. На этой странице отслеживаем выполнение запущенных процессов, контролируем зависшие. Обычный пользователь видит список процессов запущенных только им самим. Администратору портала видны все процессы запущенные на портале, которые он удалит в случае зависания.

1 выберите модули, для которых были запущены процессы. Также доступен выбор зависших процессов.

2 используйте фильтр для поиска определенных задач.

3 настройте отображение колонок списка, кликнув правой кнопкой по шапке таблицы.

4 с помощью меню действий перейдите к документу (для администратора доступно удаление).


Бизнес-процессы организации
308 / 694


Настройки для бизнес-процессов организации
309 / 694

В публичной части портала бизнес-процессы могут быть запущены не только для документов, списков или CRM, но и для любых внутренних процессов организации: оформления командировок, отпусков, утверждения счетов и т.п. По умолчанию для пользователей создано и представлено два типовых бизнес-процесса организации: Оформление командировки и Оформление отпуска.

Внимание: Администратор системы может добавлять собственные процессы только при наличии модуля Дизайнер бизнес процессов.

Для настройки и создания публичного интерфейса бизнес-процессов организации:

  • В системе должен быть создан тип информационных блоков (например, Бизнес-процессы), инфоблоками которого будут бизнес-процессы организации:

  • После того как создан необходимый тип инфоблоков, следует создать новую страницу, разместить на ней комплексный компонент Бизнес-процесс (bitrix:bizproc.wizards) и в его настройках указать созданный тип инфоблоков.

    Данный компонент создает полноценный публичный интерфейс для работы с бизнес-процессами организации, позволяет создавать и изменять произвольные бизнес-процессы с помощью визуальных средств.

  • В итоге в публичной части портала появится страница с бизнес-процессами организации.

Примечание: Работа с бизнес процессами организации рассмотрена в курсе Пользователь портала в уроке Бизнес-процессы организации


Создание и редактирование бизнес-процесса организации
310 / 694

Для создания нового бизнес-процесса организации необходимо:

Нажать на кнопку Создать новый:

Обратите внимание, что данная кнопка доступна только при наличии прав доступа к типу информационных блоков, содержащему бизнес-процесс, по умолчанию кнопка доступна только Администратору системы.

Откроется форма создания нового бизнес-процесса:

  • Вкладка Настройки содержит основные настройки процесса

    • Название процесса - название нового бизнес-процесса организации.
    • Описание процесса - произвольное описание.
    • Сортировка - индекс сортировки бизнес-процесса, определяющий его положение в общем списке. Чем меньше меньше, тем выше в списке он будет располагаться.
    • Картинка - изображение для бизнес-процесса.

  • Вкладка Подписи содержит подписи к элементам и разделам процесса. Вы можете настраивать их для своего удобства и сделать их более подходящими содержанию вашего процесса.

  • Во вкладке Управление правами доступа к элементам и разделам процесса вы можете назначить права для работы с процессом как для целых отделов и групп, так и персонально для отдельных пользователей.

Заполните все поля необходимым для вас образом и нажмите кнопку Сохранить. После сохранения ваш процесс отразится в общем списке процессов.

После того, как бизнес-процесс создан, можно его изменят и редактировать, щелкнув по нему в списке всех процессов.

В появившемся меню можно выделить следующие вкладки:

  • Добавить элемент - запустить экземпляр данного процесса. По сути это действие идентично вызову бизнес-процесса из вкладки Мои процессы.
  • Управление разделами - создание разделов для группировка элементов
  • Бизнес-процессы создание/редактирование шаблона бизнес-процесса с помощью Дизайнера
  • Настройки процесса - открыть меню настроек бизнес-процесса
  • Экспорт в Excel - экспорт списка элементов в Excel


Задания бизнес-процессов
311 / 694

Посмотрим интерфейс заданий бизнес-процессов на примере Битрикс24.

Администратор, помимо списка своих заданий бизнес-процессов, имеет доступ к списку заданий остальных пользователей:

  • в публичной части сайта;

  • в административной части сайта на странице Задания (Сервисы > Бизнес-процессы > Задания).

С помощью этой страницы администратор просматривает и выполняет задания за других пользователей. Например, выполняет срочное задание за сотрудника, ушедшего в отпуск.

Примечание: Задания бизнес-процессов автоматически удаляются при удалении документа, для которого они были запущены.

Документация по теме:

  • Задания
  • Просмотр задания


Дизайнер бизнес-процессов
312 / 694
Модуль Дизайнер бизнес-процессов, входящий в старшие редакции продуктов "1С-Битрикс", предназначен для проектирования, создания и изменения бизнес-процессов.


Дизайнер бизнес-процессов
313 / 694

Проектируем бизнес-процесс

Модуль Дизайнер бизнес-процессов, входящий в старшие редакции продуктов "1С-Битрикс", предназначен для проектирования, создания и изменения бизнес-процессов.

Механизм проектирования бизнес-процессов реализован за счет визуального программирования по технологии drag&drop , понятной и известной любому пользователю компьютера. Шаблон бизнес-процессов создается в особом визуальном конструкторе , который позволяет пользователю, не владеющему программированием, задать нужный порядок бизнес-процесса, отобразить его специфичные потребности с помощью простых графических схем.

Создание бизнес-процессов - это программирование, хоть и без написания кода (в большинстве случаев). Помимо знания предметной области, в которой проектируется шаблон, и знания реального процесса, требуется постановка задачи, алгоритмирование и тестирование. Для этого требуются определенные навыки и базовая подготовка.

Созданный шаблон бизнес-процесса выполняется автоматически или вручную, в зависимости от настроек. Одновременно работают несколько экземпляров бизнес-процесса, и система занимается управлением выполнения этих экземпляров, сохраняя и восстанавливая их состояние по требованию. Ведется лог каждого экземпляра бизнес-процесса для дальнейшего анализа работы схемы и корректировки ее под новые условия.

Примечание: Если проектируемый процесс имеет сложную структуру, то лучше использовать Бизнес-процесс со статусами.


Визуальный конструктор
314 / 694

Как открыть визуальный конструктор

Визуальный конструктор - инструмент, входящий в состав модуля Дизайнер бизнес-процессов, который позволяет создавать и редактировать шаблоны бизнес-процессов.

Административная часть

В административной части есть два способа открытия списка шаблонов бизнес-процессов. Рекомендуемый нами (более удобный) способ вызова визуального конструктора: перейдите к желаемому инфоблоку и нажмите на контекстной панели кнопку Шаблоны бизнес-процессов.

Нажмите на рисунок, чтобы увеличить

После чего используйте меню кнопки Создать шаблон на контекстной панели или команду меню действий Изменить .

Второй способ
Перейти к странице Шаблоны бизнес-процессов также возможно со страницы настройки свойств инфоблока , используя ссылку Список шаблонов бизнес-процессов.

Нажмите на рисунок, чтобы увеличить

Публичная часть

Переход к визуальному конструктору отличается для разных типов документов . Обычно это кнопка или пункт меню с подписью Бизнес-процессы. Например, для универсальных списков это выглядит так:

Далее воспользуйтесь кнопками создания бизнес-процессов или отредактируйте существующий с помощью кнопки Изменить в меню действий.


Из чего состоит визуальный конструктор
315 / 694

Внешний вид визуального конструктора

Визуальный конструктор состоит из четырех областей. Его вид будет отличаться в зависимости от того, какой процесс редактируется.

Внешний вид визуального конструктора

1. Контекстная панель

Контекстная панель визуального конструктора состоит из набора кнопок:

  • Параметры шаблона - позволяет задать/изменить основные параметры и параметры запуска бизнес-процесса;
  • Список шаблонов - переход к списку шаблонов бизнес-процессов;
  • Создать шаблон <тип_бизнес-процесса> - позволяет перейти к созданию одного из типов бизнес-процессов;
  • Экспорт - экспорт текущего шаблона бизнес-процесса;
  • Импорт - импорт шаблона бизнес-процесса взамен текущего.

2. Основная рабочая область

Внешний вид основной рабочей области зависит от типа БП: последовательный бизнес процесс или бизнес-процесс со статусами .

Создание и редактирование шаблона бизнес-процесса, т.е. добавление некоторых действий, осуществляется простым перетягиванием действия на основную рабочую область конструктора в нужном месте шаблона бизнес-процесса. Или воспользуйтесь меню, которое доступно при нажатии на треугольник .

Для копирования действий перетащите уже существующее действие, зажав клавишу Ctrl. Для удаления действия служит кнопка X, а для выполнения детальной настройки размещенного в шаблоне действия - кнопка X. Некоторые действия сворачиваются для экономии места на экране .

3. Панель действий конструктора

Панель действий визуального конструктора содержит набор действий , из которых и производится конструирование шаблона.

Создание своих групп действий в панели действий

Сгруппируйте действия в собственные группы. Для этого внесите изменения в конфигурационный файл .description.php, находящийся в папке конкретного действия (\bitrix\activities\bitrix\).

'CATEGORY' => array(
        'ID' => 'document',
        "OWN_ID" => 'crm',     // идентификатор новой создаваемой группы действий
        "OWN_NAME" => 'CRM',     // название группы, которое будет отображаться в дизайнере
    ),

В итоге получим следующие группировки действий.

4. Кнопки управления

Если осуществляется создание/редактирование шаблона последовательного бизнес-процесса, то отображаются кнопки: Сохранить, Применить и Отменить.

Если же выполняется создание/редактирование шаблона бизнес-процесса со статусами, то отображается только кнопка Вернуться к настройке статусов, которая служит для перехода к схеме шаблона, где и выполняется сохранение/отмена внесенных изменений в статусы и их действия.

Примечание: Если шаблон был изменен, но не сохранен, то при попытке покинуть страницу появится предупреждение о возможной потере несохраненных данных, с возможностью сохранить изменения.

Заключение

Мы узнали, где запустить Визуальный конструктор и как проектировать в нем шаблоны бизнес-процессов. Инструмент, с помощью технологии drag&drop, позволяет наглядно и удобно создавать и редактировать шаблоны бизнес-процессов.


Форма "Вставка значения"
316 / 694

При работе с бизнес-процессом в параметрах действий, параметрах шаблона и настройках статуса есть возможность указывать как собственный текст, заданный вручную, так и использовать различные переменные, поля документа и прочие данные, которые не задаются вручную. Для этого используется специальная форма Вставка значения.


Форма "Вставка значения"
317 / 694

Заполняем поля с помощью формы "Вставка значения"

При работе с бизнес-процессом в параметрах действий, параметрах шаблона и настройках статуса есть возможность указывать как собственный текст (заданный вручную), так и использовать различные переменные (поля документа и прочие данные, которые не задаются вручную). Для этого используется специальная форма Вставка значения.

Нажмите на рисунок, чтобы увеличить

Разделы

  • Параметры шаблона - вставка параметров шаблона. Задаются для конкретного шаблона в форме, доступной по кнопке Параметры шаблона на контекстной панели визуального конструктора бизнес-процесса. Значение параметра - то, что введет пользователь в соответствующих полях при запуске бизнес-процесса.
  • Переменные - вставка пользовательских переменных, которые могут изменяться по ходу выполнения бизнес-процесса. Пример: дополнительное числовое поле, заполняемое пользователем в процессе выполнения бизнес-процесса.
  • Константы - вставка заранее заданных констант, которые остаются неизменными в процессе исполнения бизнес-процесса. Их значение задается в параметрах шаблона и пользователь, не имеющий доступа к изменению процессов, не может менять их значение.
  • Поля документа - вставка значения какого-либо поля документа, участвующего в бизнес-процессе. Например: Дата создания или Кем создан.
  • Дополнительные результаты - вставка результатов выполнения некоторых действий. Не все действия предоставляют дополнительные результаты. В списке отображаются сразу все доступные результаты для всех действий, добавленных в текущий процесс, если они их поддерживают.
  • Пользователи - вставка пользователя или группы пользователей, которые будут причастны к выполнению бизнес-процесса. Есть возможность выбрать несколько пользователей/групп пользователей. Для этого в качестве разделителя используется символ ;.
  • Категории пользователей - позволяет подробно указать пользователей, которые будут причастны к выполнению бизнес-процесса. В том числе можно выбрать Отдел или Группу соцсети.
Примечание: Возможна вставка как отдельных групп пользователей, так и целых отделов и групп социальной сети . Для этого в настройках прав доступа к элементам и разделам процесса указываем группы, которые вы хотите чтобы отображались в форме . Любая помещенная в эту вкладку группа вне зависимости от указанного уровня доступа будет отображаться в списке.
Дополнительные значения (недоступны напрямую из формы)

Следующие значения недоступны напрямую из формы, но могут быть внесены вручную при проектировании шаблона бизнес-процесса:

  • {=Workflow:ID} - идентификатор бизнес-процесса;
  • {=User:ID} - идентификатор текущего пользователя в формате user_[номер_пользователя_в_системе];
  • {=Template:TargetUser} - параметр, в котором содержится идентификатор пользователя, запустившего бизнес-процесс в формате user_[номер_пользователя_в_системе];
  • {=System:Now} - текущая дата со временем на сервере;
  • {=System:NowLocal} - текущая дата со временем у клиента (учитывается часовой пояс);
  • {=System:Date} - текущая дата без времени;
  • {=Document:DETAIL_PAGE_URL} - позволяет получить ссылку на страницу детального просмотра документа, при условии, что в настройках инфоблока корректно заполнен URL страницы детального просмотра.

Использование некоторых значений полей контактов/компаний (для облачной версии Битрикс24)

В рамках бизнес-процессов для сделок в CRM воспользуйтесь некоторыми значениями из полей контакта или компании, которые связаны с этой сделкой.

Значения для Контактов:

  • {=Document:CONTACT_ID} - ID контакта;
  • {=Document:CONTACT_TYPE_ID} - ID типа контакта;
  • {=Document:CONTACT_NAME} - имя контакта;
  • {=Document:CONTACT_SECOND_NAME} - фамилия контакта;
  • {=Document:CONTACT_LAST_NAME} - отчетство контакта;
  • {=Document:CONTACT_FULL_NAME} - ФИО контакта;
  • {=Document:CONTACT_ADDRESS} - фактический адрес контакта.

Значения для Компаний:

  • {=Document:COMPANY_ID} - ID компании;
  • {=Document:COMPANY_TITLE} - Название компании;
  • {=Document:COMPANY_INDUSTRY} - ID сферы деятельности;
  • {=Document:COMPANY_REVENUE} - годовой оборот;
  • {=Document:COMPANY_CURRENCY_ID} - ID валюты;
  • {=Document:COMPANY_TYPE} - ID типа компании;
  • {=Document:COMPANY_ADDRESS} - фактический адрес компании;
  • {=Document:COMPANY_BANKING_DETAILS} - банковские реквизиты.

Заключение

Мы узнали, как с помощью формы Вставка значение добавлять различные переменные в параметры действий, параметры шаблона и настройки статуса. В следующем уроке посмотрим, как модифицировать эти данные.


Модификация типов данных
318 / 694

Модифицируем данные

Указанные нами параметры, переменные шаблона или поля документа возможно модифицировать. Для этого существуют специальные модификаторы, которые преобразуют данные.

Для параметров и переменных шаблона, а так же полей документа используется модификатор _printable, преобразующий значения в понятную пользователю строку.

Возьмем переменную типа пользователь. Результат, если значение переменной равно Автор:

{=Variable:user}                          author
{=Variable:user_printable}                Автор

Если для поля документа или параметра доступен такой вариант отображения, то он представлен в форме Вставка значения. Если же печатная форма не предусмотрена, запросите вывод печатной формы от любого значения (переменная, дополнительный результат и т.п.). Кроме того, доступно преобразовывать не только в печатную форму, но и менять тип данных .

Таблица преобразования типов данных

Начальный/конечный | bool (Да/Нет) | date (Дата) | datetime (Дата/Время) | double (Число) | int (Целое число) | file (Файл) | select (Список) | string (Строка) | text (Текст) | user (Пользователь)
bool (Да/Нет) | --- | x | x | 1 или 0 | 1 или 0 | х | х | Y или N | Y или N | x
date (Дата) | x | --- | по формату | timeslamp | timeslamp | x | x | по формату | по формату | x
datetime (Дата/Время) | x | по формату | --- | timeslamp | timeslamp | x | x | по формату | по формату | x
double (Число) | 0==N !0==Y | из timeslamp | из timeslamp | --- | (int) | x | x | (string) | (string) | user_<ID>
int (Целое число) | 0==N !0==Y | из timeslamp | из timeslamp | (float) | --- | x | x | (string) | (string) | user_<ID>
file (Файл) | x | x | x | x | x | --- | x | x | x | x
select (Список) | Y или N | x | x | (float) | (int) | x | --- | (string) | (string) | user_<ID> group_<CODE> <ID>
string (Строка) | Y или N | strtotime | strtotime | (float) | (int) | x | x | --- | (string) | user_<ID> group_<CODE> <ID>
text (Текст) | Y или N | strtotime | strtotime | (float) | (int) | x | x | (string) | --- | user_<ID> group_<CODE> <ID>
user (Пользователь) | x | x | x | ID | ID | x | x | (string) | (string) | ---

Примечание: все выражения в тексте автоматически преобразуются к строке, при отсутствии дополнительных идентификаторов.

Примечание: при преобразовании типа Список в Строку или Текст берутся значения списка, при преобразовании Списка в Список - ключи списка. Для получения значения ключа списка используйте конвертирование, например: {=Variable:Select > select}.

Для данных типа Пользователь есть возможность преобразования в формат friendly. В таком случае выводится только имя и фамилия пользователя, без его ID и логина.

Пример: {=Document:CREATED_BY} > User_1

{=Document:CREATED_BY > printable} > Иван Иванов [1]

{=Document:CREATED_BY > friendly} > Иван Иванов

Важно! Для версий модуля до 15.6.0 преобразование типов данных, в том числе и запрос печатной формы для значений, не имеющих таковой, возможно с помощью переменных и действия PHP-код.

Примечание: Для вставки одного и того же значения в разные действия шаблона не обязательно всегда пользоваться формой Вставка значения. Достаточно скопировать текст, вставленный с помощью этой формы, и использовать его дальше.

Решение некоторых проблем (для коробочной версии)

Если для документа было создано дополнительное поле и оно по каким-либо причинам не отображается в форме Вставка значения, то необходимо перейти к настройкам инфоблока в административной части сайта (Контент > Инфоблоки > Типы инфоблоков > [требуемый_инфоблок], закладка Свойства), и в параметрах свойств этого поля отметить опцию Выводить на странице списка элементов поле для фильтрации по этому свойству:.

Если этого не сделать, то будет невозможно использовать это свойство в бизнес-процессах.


Вычисление значений выражений в параметрах действий
319 / 694

Вычисляем выражения

В системе имеется возможность вычислять значения выражений в параметрах действий. Для этого ставим знак = в поле перед операциями.

Пример: =6^2 + {=Document:PROPERTY_NUM}/2 или =if({Document:ID}=5, "текст1", "текст2").

В каждом поле доступно использовать сразу несколько разных вычислений. Если Вы хотите не только произвести вычисление, но и вывести дополнительные данные (значение переменных, текст), то используйте оператор конкатенации (&), а текст напишите в кавычках (").

Пример : ="Ответ:" & (1+3) или ="Автор: " & {=Document:CREATED_BY} & ", " & "Конечный срок: " & Dateadd({=Document:DATE_CREATE}, "1d")

Примечание: С версии 15.6.0 вычисляемые значения можно просто размещать в тексте, поместив вычисление в конструкцию {{=...}}. Например: Вам необходимо оформить документы до {{=DateAdd({=Document:CREATED}, '5d')}}.

Примечание: Синтаксис символьных операторов аналогичен синтаксису соответствующих php-функций.


Примеры работы с выражениями
320 / 694

Посмотрим примеры работы с выражениями

Давайте, для лучшего понимания, посмотрим несколько примеров использования вычисления значений выражений .

Использование переменных в ссылках

В полях действий, поддерживающих тег [url], доступно использование собственных переменных для создания ссылок.
    [url=http://{=Variable:Domain}/{=Variable:Path}]название ссылки[/url]
где: {=Variable:Domain} и {=Variable:Path} - переменные, содержащие адрес сервера и требуемый путь.

Создание прямой ссылки на страницу с заданием

Используйте ссылку, например, для отправки пользователю сообщения о необходимости выполнить задание в рамках бизнес-процесса.

    Ссылка на страницу с заданием: [url=http://[адрес_портала]/company/personal/bizproc/{=Workflow:ID}/]ссылка на страницу просмотра документа[/url]

Создание ссылки на страницу детального просмотра документа

Используйтесь ссылку, например, для отправки пользователю сообщения из которого он перейдет непосредственно к просмотру документа.

    Ссылка на страницу детального просмотра документа: [url]{=Document:DETAIL_PAGE_URL}[/url]

Примечание: Выражение {=Document:DETAIL_PAGE_URL} формирует нужную ссылку при условии, что в настройках инфоблока корректно заполнен URL страницы детального просмотра.

Создание прямой ссылки к файлу на сервере

Такой сценарий понадобится, если нужно отправить, например, ссылку на скачивание файла клиенту (т.е. кому-то извне).

Допустим, в документе имеется поле Файл. Для получения внутренней ссылки используем: вставка значения Поля документа > Файл (имя).

Ссылка на файл  - {=Document:PROPERTY_FILE_PRINTABLE}

Такая ссылка потребует авторизации на портале. Получить публичную ссылку можно с помощью модификатора src, который нужно указать вручную таким образом:

// удалим _PRINTABLE и добавим модификатор >src и bb-code [url].
Ссылка на файл - [url={=Document:PROPERTY_FILE>src}]link[/url]

Внимание! Использование такого модификатора на коробочных версиях может быть небезопасно. Например, если данный файл загружает пользователь: он может загрузить HTML и по такой ссылке откроется в браузере страница вашего сайта, в которой пользователем может быть написан вредоносный код. Но возможно обойти использованием CDN (как в облачной версии Битрикс24) или настройкой вашего сервера (правила .htaccess и т.п., запрещающие выполнение html/php файлов в папке из папки /upload/).

Проверка корректности времени

Выражение используется для полей документа, переменных или параметров шаблона.

    =if(and((intval(substr({=Template:Parameter1}, 0, 2)) >= 0), (intval(substr({=Template:Parameter1}, 0, 2)) < 25), (substr({=Template:Parameter1}, 2, 1) = ":"), (intval(substr({=Template:Parameter1}, 3, 2)) >= 0), (intval(substr({=Template:Parameter1}, 3, 2)) < 60)), {=Template:Parameter1}, "время указано неправильно")

Если в параметре {=Template:Parameter1} передается время (в 24 часовом формате ЧЧ:ММ, например 21:45), то возвращается его значение. Иначе вернется время указано неправильно.


Функции калькулятора выражений
321 / 694

Функции для вычислений

При вычислении значений выражений в параметрах действий вы можете использовать следующие функции и операторы:

Функции

Функция Описание
explode Функция разбивает строку с помощью разделителя. Полезна, когда нужно разбить строку и присвоить части как значение множественной переменной. Аналог explode в PHP.
Возвращает массив строк, полученных разбиением строки str с использованием delimiter в качестве разделителя.
explode(
   delimiter,
   str)
Параметры:
  • delimiter - разделитель;
  • str - строка для разделения.
Implode Объединяет множественные значения в строку. Полезна, когда нужно вывести в текст значения множественных переменных нестандартным разделителем (стандартный - просто запятая). Аналог implode в PHP.
Возвращает строку, содержащую строковое представление всех элементов массива в указанном порядке, со значением glue между каждым элементом.
Implode(
   glue,
   pieces
)
Параметры:
  • glue - по умолчанию равен пустой строке;
  • pieces - массив объединяемых строк.
toUserDate Функция приводит любое время к времени сотрудника (с учетом его часового пояса).
toUserDate(
   user,
   date=now
)
Параметры
  • user - пользователь, к чьему времени необходимо привести время БП;
  • date - начальная дата, по умолчанию - текущее время.
GetUserDateOffset Функция возвращает значение смещения часовой зоны пользователя в секундах (относительно серверного времени).
GetUserDateOffset(
   user
)
Параметры:
  • user - пользователь, относительно чьего времени нужно значение.

Операторы

Доступны следующие операторы:

Оператор | Описание
+ Сложение.
- Вычитание.
* Умножение.
/ Деление.
= Равно.
<> Не равно.
< Меньше.
> Больше.
<= Меньше или равно.
>= Больше или равно.
() Порядок действий.
& Оператор конкатенации, который возвращает строку, представляющую собой соединение левого и правого аргумента.
^ Возведение в степень.
% Вычисление процентов.
true | Правда.
false | Ложь.
and | Логический оператор И.
or логический оператор ИЛИ.

Пример: =if(or({=Variable:aaa}>2, {=Variable:bbb}<10), "yes", "no")
not | Отрицание.
min | Наименьшее значение.
abs | Вычисление модуля.
date | Для корректного форматирования даты . Работает аналогично функции Date в PHP.
dateadd Добавляет заданное количество дней, месяцев, лет, часов, минут и секунд к указанной дате.

Синтаксис: =dateadd([начальная_дата], [что_добавлять]);

Варианты написания и примеры
y, year, years, m, month, months, d, day, days, h, hour, hours, i, min, minute, minutes, s, second, seconds.
При написании можно использовать верхний или нижний регистр.
Примеры: =Dateadd({=Document:DATE_CREATE}, "-2d"), =Dateadd({=Document:DATE_CREATE}, "2 days 3 minutes").

В случае, если необходимое для добавления количество единиц времени содержится в поле, переменной и т.п., то необходимо использовать оператор конкатенации &.

Например: =DateAdd({=Document:DATE_CREATE}, {=Variable:WHAT2ADD} & "y 10h")
datediff Позволяет вычислить разницу между двумя датами.

Синтаксис:
=datediff([первая дата], [вторая дата], [как выводить разницу]);

Разницу можно выводить в разных единицах, в зависимости от решаемых вами задач.

Примеры:
=datediff({=Variable:Variable1}, {=Variable:Variable2},'%m month, %d days')
if Условие.

Синтаксис:
=if([условие], [результат_в_случае_выполнения_условия], [результат_в_случае_не_выполнения_условия]);

Пример:
=if ({=Variable:Variable1_printable}>0, "да", "нет")

При сравнении значений переменных также возможно сравнивать переменные с разным типом данных. Однако сравниваемые переменные должны соответствовать таблице преобразования типов.
intval Возвращает целое значение переменной;

Пример:
=intval("234j4hv5jhv43v53jk4vt5hj4") вернет 234.
substr Возвращает подстроку определенной длины, начиная с указанного символа. Данная функция аналогична существующей substr в php.

Синтаксис:
substr([входная строка], [с какого символа исходной строки начнется возвращаемая статья], [какой длины будет строка])

Имейте ввиду, что строка начинает с символа под номером 0. Например, в строке 'abcdef', в позиции 0 находится символ 'a', в позиции 2 - символ 'c', и т.д.

Пример:
{{=substr("0123456789", 3, 4)}} вернет 3456.

Внимание! Если синтаксис выражения будет неправильным, то оно отобразится как текст.
merge Позволяет объединять массивы.

Синтаксис:
= merge({=массив_1}, {=массив_2});

Пример:
= merge({=Document:FILES}, {=Variable:file}).

AddWorkDays Функция добавляет N рабочих дней к указанной дате.

Синтаксис:
=addworkdays([дата, к которой будут добавляться дни], [количество добавляемых рабочих дней]).

Примеры:

  • {{=addworkdays('07.03.2016', 1)}} - результат: 09.03.2016 00:00:00, т.к. в настройках сайта 8 марта - выходной.
  • {{=addworkdays('05.02.2016 16:14:00', 1)}} - результат: т.к. 05.02.2016 - пятница, то результат: 08.02.2016 16:14:00 - понедельник.
isWorkDay Проверяет, является ли дата рабочим днем (по Календарю).

Синтаксис:
=if(isWorkDay([проверяемая дата]), [сообщение, если дата является рабочим днем], [сообщение, если не является]).

Пример:
{{=if(isWorkDay({=Template:Parameter1}), 'Да', 'Нет')}} - в параметре содержится дата 28.04.2016. Результат - Да, т.к. это рабочий день.
isWorkTime Аналогична функции isWorkDay, но для типов данных Дата/Время.

Синтаксис:
=if(isWorkDay([проверяемая дата со временем]), [сообщение, если дата со временем является попадает на рабочее время], [сообщение, если не попадает]).

Пример:
{{=if(isWorkTime({=Template:Parameter1}), 'Да', 'Нет')}} - в параметре содержится дата со временем 27.04.2016 15:00:00. Результат - Да, т.к. это рабочее время.
WorkDateAdd Добавляет заданное количество рабочих дней, часов и минут к указанной дате.

Синтаксис:
=WorkDateAdd([начальная_дата], [что_добавлять]).

Варианты написания и примеры
Варианты написания: d, day, days, h, hour, hours, i, min, minute, minutes. Допустимо написание как в верхнем, так и в нижнем регистре.

Пример:
=WorkDateAdd({=Template:Parameter1}, "2d") - в параметре содержится дата 28.04.2016. Результат - 02.05.2016 09:00:00, т.к. 30.04 и 1.05 - это выходные дни, то они будут пропущены. 09:00:00 - начало рабочего дня. Список выходных дней и начало рабочего дня настраивается в Настройках портала.


Примеры работы с датами
322 / 694

Работаем с датами в бизнес-процессах

В уроке рассмотрим возможности работы с датами в бизнес-процессах:

  • Перевод даты на русский язык
  • Относительный формат даты
  • Добавление N дней из параметра
    •

    Результаты выведем с помощью действия Сообщение соц.сети .

    Перевод даты на русский язык

    Для вывода даты используется функция date . В примере используем параметр F - полное наименование месяца. Список всех параметров функции смотрите в документации по PHP.

    Текущий месяц - {{=date('F',{=System:Date})}}

    В результате получим уведомление вида Текущий месяц - April.

    Для получения названия месяца на русском языке понадобится создать Список соответствия для названий месяцев. Введем переменную бизнес-процесса типа Список:

    В вариантах значений в квадратных скобках укажем ключ - номер месяца, а после - значение (название месяца на русском языке).

    Вернемся к шаблону бизнес-процесса и перед сообщением соц.сети добавим действие Изменение переменных в котором укажем функцию {{=date('n')}}, где n - порядковый номер месяца без ведущего нуля (из документации по PHP).

    В действии Уведомление соц. сети поменяем текст сообщения на вывод нашей переменной Variable1:

    Текущий месяц - {=Variable:Variable1 > printable}

    Результат:

    Таким же образом можно выводить дни недели и др. подобные даты.

    Относительный формат даты

    Задание: необходимо вывести дату - пятница следующей недели. Сделать это можно с помощью работы функции strtotime и относительных форматов PHP.

    Создадим новую переменную Дата и снова воспользуемся действием Изменение переменных, как в примере выше. Укажем значение ='next week friday':

    А в тексте сообщения соц. сети выведем переменную Дата.

    Следующая пятница - {=Variable:Variable2 > printable}

    Результат

    Добавление N дней из параметра

    Сначала посмотрим на простой пример: прибавим к текущей дате точное количество дней.

    Для этого понадобится функция dateadd:

    Текущая дата + 2 дня: {{=dateadd({=System:Date}, '2d')}} // прибавим 2 дня к текущей дате

    Теперь посмотрим, как правильно добавлять количество дней, которое хранится в параметре БП:

    Текущая дата + N дней: {{=dateadd({=System:Date}, {=Template:Parameter1} & 'd')}} // прибавим дни из параметра к текущей дате

    Важно! Для правильного указания количества дней из параметра применен оператор конкатенации, который возвращает строку, представляющую собой соединение левого и правого аргумента.

    Результат (при запуске БП для параметра указано значение 10):

    Дополнительно

    • Функции калькулятора выражений.


Вычисляем числовые значения с записью в поля документа
323 / 694

Пример вычисления числовых значений

Рассмотрим небольшой пример работы с полями документа и вычислением их значений . Для простоты воспользуемся функционалом списков (Сервисы > Списки). Описанные ниже действия применимы и к другим типам документов, например, CRM. За основу примера возьмем сообщение с форума:

"Доброго времени суток, может кто сталкивался с такой задачей, нужно чтоб во время оформления сделки высчитывалась чистая прибыль, т.е. от заложенной суммы сделки вычитался налог усн (6%), вычитались затраты на подряд (если они есть) и все это потом записывалось в отчет менеджера по проведенной сделке."

Порядок действий

  • Создадим новый список, а в нем набор полей типа число :

    • Сумма;
    • Затраты на подряд ;
    • Налог (6%). Считается автоматически;
    • Итоговая сумма. Считается автоматически.
  • Создадим шаблон последовательного бизнес-процесса и настроим его на запуск при добавлении нового элемента.
  • Добавим и настроим первое действие Изменение документа , которое вычислит налог от общей суммы :

    Поле: Налог (6%). Считается автоматически,

    Значение: ={=Document:PROPERTY_s}*0.06,

    где {=Document:PROPERTY_s} является значением поля Сумма.

  • Добавим и настроим второе действие Изменение документа, которое вычислит итоговую сумму с учетом всех вычетов:

    Поле: Итоговая сумма. Считается автоматически,

    Значение: ={=Document:PROPERTY_s}-{=Document:PROPERTY_contract}-{=Document:PROPERTY_tax},

    где

    {=Document:PROPERTY_s} - значение поля Сумма,
    {=Document:PROPERTY_contract} - значение поля Затраты на подряд,
    {=Document:PROPERTY_tax} - значение поля Налог (6%). Считается автоматически.

Дополнительно

Шаблон для ознакомления : Скачать


Шаблоны бизнес-процессов
324 / 694
Шаблон бизнес-процесса представляет собой последовательность шагов (действий) от начального к конечному, которые будут выполняться один за другим. Необходимо таким образом и в таком порядке составить шаги (действия), чтобы реализовать нужный нам алгоритм и получить необходимый результат.


Примечание для библиотеки документов
325 / 694

Создание и редактирование шаблонов бизнес-процессов выполняется в административном разделе для всех инфоблоков, кроме используемых в рамках Библиотеки документов и Бизнес-процессов организаций.

Создание/редактирование шаблонов бизнес-процессов, используемых в рамках модуля Библиотека документов, следует выполнять только с помощью публичного интерфейса, поскольку в нем ведется работа с документами портала. Все созданные шаблоны бизнес-процессов в рамках этого модуля с помощью административного интерфейса не будут доступны в публичном разделе, работа с ними может быть осуществлена только в административном разделе.


Настройка параметров шаблона
326 / 694

Настроим параметры шаблона

Шаблон БП представляет собой последовательность шагов (действий) от начального к конечному, которые выполняются один за другим. Необходимо таким образом и в таком порядке составить шаги (действия), чтобы реализовать нужный нам алгоритм и получить необходимый результат.

Шаблоны бизнес-процессов используются для быстрой и эффективной настройки формы бизнес-процесса согласно потребностям сотрудника. При создании бизнес-процесса на основе шаблона происходит не только изменение внешнего вида бизнес-процесса, но и заполнение его некоторыми начальными параметрами.

Создание шаблона

Процесс проектирования шаблона бизнес-процесса разделим на два этапа:
  • первый - это задание основных параметров шаблона ;
  • второй - конструирование шаблона, по которому будет выполняться бизнес-процесс.

Посмотрим первый этап. Форма настройки параметров шаблона бизнес-процесса разделена на несколько закладок, с помощью которых задаются параметры запуска и настройки бизнес-процесса.

Внимание! В бизнес-процессах отсутствует возможность использования параметров, переменных и констант родительского процесса дочерними БП.

Основное

На закладке Основное указываются название шаблона бизнес-процесса, его описание и определяются параметры автоматического запуска. Бизнес-процесс имеет два варианта автоматического запуска: при создании и/или при изменении элемента. Если оба флага сняты, то бизнес-процесс возможно запустить только вручную.

Параметры

Параметры используются для явного указания каких-либо значений во время исполнения бизнес-процесса. Значения параметров задаются непосредственно перед запуском бизнес-процесса в специальных полях. Для создания параметра нажимаем ссылку Добавить параметр на закладке Параметры и заполняем поля :

  • Идентификатор - символьный идентификатор параметра;
  • Описание - произвольное описание параметра;
  • Тип - с помощью выпадающего списка указывается тип данных параметра запуска;
  • Обязательный - если опция отмечена, то обязательно указываем значение данного параметра для запуска бизнес-процесса;
  • Множественный - при отмеченной опции может быть задано несколько значений параметра;
  • Значение по умолчанию - в зависимости от выбранного типа данных указывается значение параметра, используемое по умолчанию.

    Примечание: для некоторых типов данных значение по умолчанию можем указать с помощью кнопки [...], по нажатии которой открывается форма Вставка значения .

После создания параметр отобразится в общем списке .

Переменные

Переменные используются для временного хранения данных, необходимых для выполняемого процесса. Значения переменных хранятся до тех пор, пока выполняется бизнес-процесс. После его завершения они все стираются .

Константы / Глобальные константы

Константы нужны для хранения информации, значение которой не должно меняться во время исполнения данного процесса. Их значение настраиваем до запуска бизнес-процесса. Константы добавляются по ссылке Добавить константу на соответствующей закладке. При этом откроется вкладка создания константы. В поле Значение константы указываем, какое значение имеет константа в процессе исполнения бизнес-процесса.

Глобальные константы попадают сразу во все процессы. Создаются аналогично Константам.

Доступ

На закладке Доступ для пользователей задаются начальные права, которые устанавливаются для документа при его запуске. Причем права доступа задаются как явно, так и с помощью переменных.

Особенности назначения прав в системе
Если для документа используется упрощенная (старая) версия прав, то они устанавливаются жестко извне (настройки доступа к инфоблокам/спискам/и т.д.). Единственный вариант, позволяющий устанавливать права прямо из бизнес-процесса - это установка для документа права бизнес-процессы извне (права на сам документ). В этом случае с помощью закладки Доступ или действия Установка прав можно менять права по ходу выполнения процесса.

Если используются расширенные права доступа, то из бизнес-процесса можно только добавлять новые права на документ, которые будут оставаться у документа даже после выполнения процесса. Переопределить права, которые были установлены извне, внутри бизнес-процесса нельзя.

Заключение

Мы посмотрели первый этап процесса проектирования шаблона бизнес-процесса. Заполнили все закладки, с помощью которых задаются параметры запуска и настройки бизнес-процесса. В следующих уроках разберем второй этап - конструирование шаблона, по которому работает бизнес-процесс.


Создание шаблона последовательного бизнес-процесса
327 / 694

Создадим шаблон последовательного бизнес-процесса

Посмотрим видеоролик о создании шаблона последовательного бизнес-процесса . Узнаем как использовать визуальный конструктор и настраивать параметры действий.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Текстовое содержание видео

При проектировании шаблона последовательного бизнес-процесса после настройки и сохранения его параметров сразу становится доступным визуальный конструктор для конструирования шаблона.

Конструирование шаблона выполняется путем добавления в рабочую область необходимых действий с последующей настройкой их параметров.

Настройка параметров каждого действия осуществляется в специальной форме, открываемой с помощью кнопки [image], причем набор параметров зависит от конкретного действия.

Заполните необходимые поля. Для упрощения процедуры заполнения полей служит кнопка [image], при нажатии которой открывается зависящая от типа поля форма Вставка значения .

Для выбора значения откройте нужную группу, затем выберите необходимое значение и нажмите кнопку Вставить (либо дважды кликнете по выбранному значению). Для вставки нескольких значений необходимо повторно вызвать форму выбора значения. Значение или его код будут подставлены в настраиваемое поле (На иллюстрации выше такой код выделен красной рамочкой).

По окончании настройки параметров действия, сохраните его. Система вернется к созданию (редактированию) шаблона бизнес-процесса.

Когда в шаблон будут добавлены и настроены все необходимые действия, не забудьте сохранить его. Шаблон отобразится в списке всех шаблонов бизнес-процессов.


Создание шаблона бизнес-процесса со статусами
328 / 694

Создаем шаблон бизнес-процесса со статусами

Посмотрим видеоролики о создании шаблона бизнес-процесса со статусами . Мы создадим статусы документа, настроим действия внутри каждого из них, а также сделаем связи между ними.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Текстовое содержание видео

При проектировании шаблона бизнес-процесса со статусами, после настройки и сохранения его параметров осуществляется переход к конструированию непосредственно самого шаблона в 3 этапа:

  1. Создание необходимых статусов;
  2. Настройка действий внутри каждого статуса и создание связей между статусами;
  3. Настройка прав доступа для статуса.

Создание статусов

Создание статусов выполняется на главной странице построения шаблона бизнес-процесса:

  • Нажмите кнопку Добавить статус для создания нового статуса.

    Важно! Бизнес-процесс всегда начинается с первого созданного статуса. Изменить статус, с которого начинается процесс, в последующем невозможно.

  • В форме создания статуса указывается его название и права доступа к документу (элементу бизнес-процесса).
  • Сохраните статус.

Аналогичным образом добавляются все необходимые статусы .

Настройка действий внутри каждого статуса и создание связей между статусами

После того, как все статусы созданы, следует настроить операции и действия (подпроцессы), которые выполняются в каждом статусе, а также создать связи между статусами.

Для каждого статуса настраивается :

  • Команда , позволяет пользователю вручную запускать подпроцесс. Внешний вид элемента управления, с помощью которого пользователем запускается команда, зависит от места запуска бизнес-процесса и типа документа. Команду используем, например, для определения того, как должен исполняться бизнес-процесс. Или как подпроцесс, который выполняется только при определенных условиях.
  • Выполнение через заданное время - позволяет отложить выполнение подпроцесса на заданное в обработчике время.
  • Обработчик входа в данный статус - отдельный последовательный бизнес-процесс. Всегда выполняется автоматически при входе в данный статус.
  • Обработчик выхода из данного статуса - отдельный последовательный бизнес-процесс. Всегда выполняется автоматически при выходе из данного статуса.

Настройка прав доступа для статуса

По умолчанию бизнес-процесс использует права документа, но в каждом статусе возможно дополнительно указать права, которые будут добавлены к правам документа именно в этом статусе. Рассмотрим пример настройки прав для документа и определенного статуса на основе списков

В настройках списка укажем следующие права доступа: Сотрудники = добавление; Автор = чтение. После такой настройки прав сотрудник сможет добавлять элементы списка и просматривать только свои, но он не сможет видеть текущий статус бизнес-процесса на соответствующей вкладке при детальном просмотре элемента списка.

Примечание: Смысл в том, что права на список и права у бизнес-процесса - это разные права. И по правилам списков (инфоблоков) они "не знают" такой тип пользователя как Автор (это понятие только для бизнес-процессов).

В настройках прав требуемого статуса укажем, что право на чтение имеет Автор. В этом случае права из бизнес-процесса добавятся к правам на список, и произойдет сопоставление понятия Автор с конкретным пользователем и его правами в списке. После такой настройки пользователь сможет просматривать статус бизнес-процесса, когда тот будет находиться в требуемом статусе.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Содержание видеоролика может отличаться от текущей версии продукта. Более актуальная информация содержится в тексте урока.

Общая схема работы

При входе в статус первым всегда выполняется Обработчик входа в данный статус, если он задан. После выполнения всех внутренних действий статуса бизнес-процесс переходит в режим ожидания. Для дальнейшего продолжения процесса можно воспользоваться подпроцессами Выполнение через заданное время и Команда.

Примечание: если в Обработчике входа в данный статус уже добавлен переход к другому статусу прерывающий выполнение текущего, то после него сразу будет выполняться Обработчик выхода из данного статуса. Подпроцессы Выполнение через заданное время и Команда будут в таком случае пропущены.

Если статус не является конечным, то переход от одного статуса к другому (создание связей) с помощью действия Установить статус , которое должно располагаться внутри подпроцесса, предполагающего такой переход. При выходе из статуса автоматически будет выполнен подпроцесс Обработчик выхода из данного статуса, если он создан.

Небольшой пример настройки статуса

Рассмотрим добавление команды для статуса Черновик:

  • В выпадающем меню для данного статуса выберите пункт Команда. Откроется форма настройки основных параметров команды.
  • Укажите название команды и пользователей, которые могут выполнить данную команду. Если документ должен сменить статус после выполнения команды, то выберите необходимый статус с помощью выпадающего списка. Список статусов формируется из статусов бизнес-процесса.
  • Сохраните параметры команды.

В результате будет создано действие в статусе и связь между статусами.

Поскольку команда - это собственный последовательный бизнес-процесс, то процесс необходимо создать :

  • Кликнете по названию команды. Откроется визуальный конструктор . В конструкторе уже содержится действие Установить статус, так как в ходе выполнения команды происходит смена статуса бизнес-процесса. В схему команды добавьте необходимые вам действия и выполните их настройку. Для возврата на главную страницу создания шаблона бизнес-процесса со статусами служит кнопка Вернуться к настройке статусов.
  • Для настройки действий в каждом статусе повторите описанные выше шаги. Результат:

  • По окончании выполнения необходимых настроек не забудьте сохранить шаблон с помощью кнопки Сохранить, доступной на главной странице со статусами бизнес-процесса.


Пример использования параметров шаблона
329 / 694

Посмотрим, как использовать параметры шаблона

Предположим, мы хотим, чтобы при запуске бизнес-процесса пользователь имел возможность явно указывать сотрудника, которому адресовано почтовое сообщение, отсылаемое в ходе выполнения процесса. Рассмотрим как это реализовать на примере штатного бизнес-процесса Ознакомление с документом.

Настройки

  • В форме Параметры шаблона на закладке Параметры создан параметр Ознакомить типа Пользователь.
  • В действии Почтовое сообщение созданный параметр указан в поле Получатель (с помощью формы Вставка значения , группа Параметры шаблона).

В результате при запуске бизнес процесса у пользователя запрашиваются дополнительные параметры:


Пример: организация обработки и доработки документа
330 / 694

Используем бизнес-процесс со статусами

Рассмотрим пример : бизнес-процесс позволяет утверждать документ в цикле, запрашивать нужную информацию в случае доработки, а также отображает автору и проверяющему комментарии, которые они оставляют при выполнении заданий.

Начальные действия:

  • Создадим 3 статуса: Рассмотрение документа, Доработка, Утвержден.
  • В каждом добавим подпроцесс Вход в статус .

Cтатус Рассмотрение документа

  • Перейдем в статус и добавим действие Утверждение документа . В параметрах действия заполним все обязательные поля . Поле Описание задания пока оставим пустым, мы к нему вернемся позже.
  • Добавим действия Установить статус в каждую ветку утверждения документа, после чего произведем их настройку для статусов Утвержден и Доработка.

Получится такой процесс : в случае если проверяющий сотрудник утвердит документ, то бизнес процесс перейдет в статус Утвержден, иначе - в статус Доработка.

Статус Доработка

  • Перейдем в статус и добавим действие Запрос дополнительной информации . В Поле Описание задания, используя форму Вставка значения , добавим комментарий , который будет оставлен проверяющим после выполнения действия Утверждение документа (Утверждение документа > Комментарий, группа Дополнительные результаты).
  • Вернемся в статус Рассмотрение документа к настройке действия Утверждение документа. В поле Описание задания, используя форму Вставка значения, добавим комментарий, который оставит автор после выполнения действия Запрос дополнительной информации.
  • Добавим действие Установить статус и произведем его настройку для статуса Рассмотрение.

В результате в этом статусе мы получим от автора нужные исправления/комментарии и отправим документ на повторное утверждение.

Статус Утвержден

В этом статусе, например, добавляем действие для оповещения автора о результатах утверждения документа.

В итоге, после всех настроек, наш бизнес процесс со статусами выглядит так:

Дополнительно

Шаблон для ознакомления: Скачать


Экспорт и импорт
331 / 694

Если нужно перенести шаблон

Процесс переноса шаблона с одного проекта на другой достаточно простой. Для этого необходимо воспользоваться кнопками на контекстной панели дизайнера бизнес-процессов .

Перед этим в проекте, куда импортируется шаблон, необходимо создать такие же типы документов (инфоблок/список/и т.д.) как и в проекте, откуда экспортируется шаблон.

Внимание! Нельзя экспортировать шаблон процесса с одним типом документа в процесс с другим. Пример: экспортировать шаблон из CRM в Списки.

Особенности импорта шаблона бизнес-процесса списков
В связи с особенностью работы модуля списков импорт шаблона бизнес-процесса проводят с некоторыми условиями.

Наиболее простой вариант - это изначально создать и настроить список, поля и шаблон бизнес-процесса:

  • Создать пользовательские поля в исходном списке не через интерфейс списков, а прямо через интерфейс конструктора бизнес-процессов;
  • После экспорта шаблона из исходного списка в новый обязательно проверить все действия, где используются пользовательские поля.

Если же пользовательские поля исходного списка были уже ранее созданы через публичный интерфейс самих списков, то импорт нужно проводить по следующей схеме:

  • Создать и настроить новый список также как и исходный;
  • Создать и настроить через публичный интерфейс модуля списков такие же поля, как и в исходном списке;
  • Задать для пользовательских полей и их значений (например, для полей типа список) такие же идентификаторы, как и в исходном списке через административную часть сайта;
  • Импортировать шаблон бизнес-процесса;
  • Обязательно проверить получившийся после импорта шаблон, особенно те действия, где используются пользовательские поля.

При несоблюдении указанных условий шаблон и пользовательские поля могут некорректно импортироваться.


Действия
332 / 694

Последовательный бизнес-процесс строится из набора действий. Каждое действие выполняет определенную функцию и имеет собственные параметры.


Общие моменты
333 / 694

Что общего у большинства действий

Последовательный бизнес-процесс строится из набора действий . Каждое действие выполняет определенную функцию и имеет собственные параметры.

Настройка параметров действия

Настройка параметров действия производится в соответствующей форме, которая вызывается с помощью двойного клика по тексту заголовка действия или с помощью кнопки [image] расположенной на нем.

Общие моменты для большинства действий

  • Поле Заголовок - позволяет задать заголовок действия, который будет отображен в визуальном конструкторе.
  • [Ид] - ссылка, позволяющая просмотреть/изменить уникальный идентификатор действия . Например, его можно использовать при просмотре истории выполнения бизнес-процесса в административной части сайта.
  • Поля выбора пользователей/групп. Пользователя/группу можно выбрать из списка или задать непосредственно вручную. Для этого нужно указать в поле идентификатор в квадратных скобках для пользователя, например [1] или без скобок - для группы пользователей.
  • Поля Описание задания позволяют использовать следующие теги bb-code: [img], [url], [b], [i], [s], [u]. Тег [url] можно использовать и в уведомлениях, например, в поле Текст сообщения действия Сообщение соц.сети .
  • В любых действиях, где есть возможность множественного выбора полей или условий, доступен выбор только из одной сущности. Например, в действии Цикл выход из цикла можно организовать либо по сочетанию группы полей, либо по сочетанию группы условий.

Документация по теме:

  • Создание собственных действий


Обработка документа
334 / 694

В группе собраны действия, связанные с этапами обработки документа.


Публикация на подключенных сайтах
335 / 694

Действие Публикация на подключенных сайтах позволяет опубликовать элемент инфоблока на подключенных сайтах.

Описание Параметров

Тип выбора сайтов - указывается, на каких сайтах будет опубликован элемент инфоблока

  • Все сайты;
  • Сайты принадлежащие определенным группам;
  • Выбранные сайты из одной группы.

Синхронизировать элементы:

  • немедленно - элементы будут синхронизированы немедленно;
  • используя задачи - синхронизация будет происходить с использованием задач .

Важно! С версии 15.5.0 Дизайнера бизнес-процессов данное действие включено только для модуля Инфоблоки.


Создание элемента списка
336 / 694

Действие позволяет создать элемент указанного списка.

Описание параметров

Тип документа - выбор инфоблока создаваемого элемента. В зависимости от выбранного типа будет предложено заполнить необходимые поля.


Запуск бизнес-процесса
337 / 694

Действие выполняет другой шаблон бизнес-процесса.

Параметры

ID документа - идентификатор документа, который запускает бизнес-процесс.

Для запуска бизнес-процесса над элементами CRM синтаксис будет другой:
  1. если процесс для Компании, то COMPANY_{=Document: ID} - запустит БП для этой же компании, LEAD_{=Document: LEAD_ID} - запустит бизнес-процесс для связанного лида;
  2. если процесс для Контакта, то CONTACT_{=Document: ID} - запустит БП для этого же контакта, LEAD_{=Document: LEAD_ID} - запустит бизнес-процесс для связанного лида;
  3. если процесс для Сделки, то DEAL_{=Document: ID} - запустит БП для этой же сделки, LEAD_{=Document: LEAD_ID} - запустит БП для связанного лида, CONTACT_{=Document: CONTACT_ID} - запустит БП для связанного контакта, COMPANY_{=Document: COMPANY_ID} - запустит бизнес-процесс для связанной компании;
  4. если процесс для Лида, то LEAD_{=Document: ID} - запустит бизнес-процесс для этого же лида.

Сущность - какой элемент запускает бизнес-процесс.

Тип документа

Шаблон - шаблон запускаемого бизнес-процесса.

Ожидать завершения бизнес-процесса - бизнес-процесс будет ожидать выполнения запущенного действия и только потом продолжит свое исполнение.


Создание нового документа
338 / 694

Действие позволяет создать новый документ с заданными параметрами.

Описание Параметров

В зависимости от типа документа, поля могут отличаться.

Например, для бизнес-процесса в инфоблоках в качестве документа будет создан новый элемент инфоблока. Соответственно поля в форме настройки параметров действия будут аналогичны полям в форме создания элемента инфоблока для конкретного типа инфоблоков.


Удаление документа
339 / 694

Действие удаляет документ, запустивший бизнес-процесс.


Блокировка документа
340 / 694

Действие блокирует документ, чтобы другие процессы не смогли произвести в него запись. Таким образом сохраняется целостность данных - несколько бизнес-процессов не смогут одновременно изменить документ и сохранить его.

Блокировка продлится до завершения текущего бизнес-процесса либо пока не выполнится действие Разблокировка

Важно! С версии 15.5.0 Дизайнера бизнес-процессов данное действие исключено для модуля Диск.


Публикация документа
341 / 694

Действие переводит документ в статус опубликован.

Актуально в коробочной версии для бизнес-процессов, запущенных на инфоблоках.


Сохранение истории документа
342 / 694

Действие позволяет создать слепок документа с внесенными на момент запуска действия изменениями. Доступно автоматическое задание названия копии с настройками параметров.

Описание Параметров

Название записи в историю - указывается название версии документа, под которым он будет сохранен в истории. Это позволит отличить его от других версий.

Оставьте поле пустым для того, чтобы название бралось из документа.

Важно! С версии 15.5.0 Дизайнера бизнес-процессов данное действие исключено для модуля Диск.


Изменение документа
343 / 694

Действие изменяет указанные поля документа.

Выберите поле документа, которое вы хотите изменить, и введите новое значение. Чтобы изменить несколько полей нажмите Добавить условие.

Ссылка Добавить поле создает новое поле в документе.

Пример: Для документов типа инфоблоки это приведет к созданию дополнительных полей элемента инфоблока .


Разблокировка документа
344 / 694

Действие разблокирует документ для других бизнес-процессов.

Примечание: Если не разблокировать документ, то он будет недоступен для других действий бизнес-процесса.

Важно! С версии 15.5.0 Дизайнера бизнес-процессов данное действие исключено для модуля Диск.


Снятие документа с публикации
345 / 694

Действие снимает документ с публикации.

Противоположно действию Публикация документа .


Задания
346 / 694

В группе содержатся действия, создающие задания бизнес-процессов для пользователей.


Утверждение документа
347 / 694

Действие позволяет произвести утверждение документа , для которого запущен бизнес-процесс. В зависимости от результата (утвержден документ или нет) возможны 2 варианта развития дальнейших действий.

Описание Параметров

Утверждают сотрудники - указываются пользователи, которые должны утвердить документ.

Тип утверждения:
  • Все сотрудники - утвердить должны все пользователи указанные выше;
  • Любой сотрудник - утвердить должен любой из пользователей, указанных выше;
  • Голосование сотрудников - утверждение производится методом голосования среди указанных выше пользователей.
    дополнительные поля
    Для варианта Голосование сотрудников доступны поля Более скольки процентов голосов необходимо для принятия решения и Ожидать, чтобы проголосовали все указанные сотрудники.
    Последнее поле можно использовать для автоматизации передавая в него значения Y или N. Если выбран вариант да, то действие будет ожидать, пока не проголосуют все указанные выше сотрудники. Если выбран вариант нет, то действие будет ожидать, пока не наберется указанный процент голосов.

Название задания - задается название, которое будет отображаться в интерфейсе для пользователей.

Описание задания - указывается описание или пояснения к заданию. Содержимое данного поля будет отображаться в интерфейсе для пользователей. Рекомендуется в этом поле указывать полную информацию о действии, которое необходимо выполнить пользователю. Это поможет избежать путаницы в случае нескольких однотипных действий.

Устанавливать текст статуса - позволяет изменить текст статуса документа на произвольный. Это может, например, позволить отслеживать на каком этапе сейчас находится бизнес-процесс.

Текст статуса - задается текст статуса.

Модификаторы
Можно использовать следующие модификаторы в тексте статуса: #PERCENT# - процент, #VOTED# - ознакомлено человек, #TOTAL# - всего должно быть ознакомлено, #APPROVERS# - список утвердивших, #REJECTERS# - список отклонивших.

Текст кнопки подтверждения в задании и Текст кнопки отказа в задании позволяют задать собственный текст для соответствующих кнопок.

Показывать поле ввода комментария - опция позволяет разрешить пользователям оставлять собственные комментарии к назначенному заданию. Например, какие-либо замечания касаемо утверждаемого документа. Содержимое поля можно получить после выполнения действия с помощью соответствующей опции в форме Вставка значения - Дополнительные результаты (см. ниже).

Обязательность комментария - опция позволяет назначить добавление комментария при выполнении действия обязательным. Можно включить обязательность комментария только для утверждения или отклонения документа.

Метка для поля комментария - подпись для поля с комментарием.

Период утверждения - Можно задать период, за время которого, если документ не будет утвержден либо отклонен, то документ будет автоматически отвергнут. Пустое значение или 0 - отсутствие периода.

Ограничить доступ - делает текст задания видимым только для исполнителя задания и не показывает его в живой ленте. Это очень полезная опция, если нужно, например, передать исполнителю конфиденциальную информацию: пароли, пин-коды и т.п.

Примечание: При выполнении задания по утверждению несколькими сотрудниками в публичной части история изменения документа, включая комментарии других утверждающих, будет отображена в зависимости от прав на документ.

Например
Eсли в Списке для определенной группы пользователей задать право только на добавление, то историю изменения (и комментарии соответственно), пользователь этой группы при выполнении задания не увидит:

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • Комментарий;
  • Сколько проголосовало;
  • Сколько должно проголосовать;
  • Процент проголосовавших;
  • Процент утвердивших;
  • Процент отклонивших;
  • Количество утвердивших;
  • Количество отклонивших;
  • Последний голосовавший;
  • Утвердили пользователи;
  • Утвердили пользователи (текст) - получение списка пользователей;
  • Отклонили пользователи;
  • Отклонили пользователи (текст)- получение списка пользователей;
  • Автоматическое отклонение - поле будет содержать 1, если документ был автоматически отклонен (см. Период утверждения).


Запрос доп.информации (с отклонением)
348 / 694

Действие создаст задание, в ходе которого, у пользователя (или пользователей) запрашивается дополнительная информация, необходимая для выполнения бизнес-процесса. В отличие от стандартного действия Запрос дополнительной информации , пользователь имеет возможность отклонить ввод информации.

Описание Параметров

Заполняют сотрудники - указываются пользователи, один из которых ( первый , кто приступит к его выполнению) должен указать дополнительную информацию.

Название задания - задается название, которое отобразится в интерфейсе для пользователей.

Описание задания - указывается описание или пояснения к заданию. Содержимое данного поля отобразится в интерфейсе для пользователей. Рекомендуется в этом поле указывать полную информацию о действии, которое необходимо выполнить пользователю. Это поможет избежать путаницы в случае нескольких однотипных действий.

Текст кнопки в задании - позволяет задать собственный текст для кнопки, соответствующей вводу информации.

Текст кнопки отклонения в задании - позволяет задать собственный текст для кнопки, соответствующей отклонению ввода информации.

Тип отклонения - указывается принцип, по которому будет проводиться отклонение ввода информации:

  1. Все сотрудники - запрос информации будет проводиться, пока все указанные сотрудники его не отклонят;
  2. Любой сотрудник - при первом же отклонении каким-либо сотрудником, другие сотрудники запросы не получают.

Показывать поле ввода комментария - опция позволяет разрешить пользователям оставлять собственные комментарии к назначенному заданию. Например, какие-либо примечания касаемо задания. Содержимое поля можно получить после выполнения действия с помощью соответствующей опции в форме Вставка значения - Дополнительные результаты (см. ниже).

Обязательность комментария - опция позволяет назначить добавление комментария при выполнении действия обязательным.

Метка для поля комментария - подпись для поля с комментарием.

Устанавливать текст статуса - позволяет изменить текст статуса документа на произвольный. Это может, например, позволить отслеживать на каком этапе сейчас находится бизнес-процесс.

Текст статуса - задается текст статуса.

Период ожидания информации: По окончании периода задание будет автоматически завершено. Пустое значение или 0 - отсутствие периода. - позволяет установить время, в течение которого действие будет ожидать выполнения.

Ограничить доступ - делает текст задания видимым только для исполнителя задания и не показывает его в живой ленте. Это очень полезная опция, если нужно, например, передать исполнителю конфиденциальную информацию: пароли, пин-коды и т.п.

Раздел Поля позволяет добавить собственные поля, которые будет необходимо заполнить пользователям в ходе выполнения задания. Содержимое полей после выполнения действия можно получить в форме Вставка значения - Переменные.

Переменные

В этом разделе можно получить содержимое дополнительных полей, созданных в разделе Поля.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон:

  • Комментарий.
  • Автоматическое завершение.
  • Пользователь, предоставивший информацию.


Запрос дополнительной информации
349 / 694

Действие создает задание, в ходе которого у пользователя будет запрошена дополнительная информация необходимая для выполнения бизнес-процесса.

Описание Параметров

Заполняют сотрудники - указываются пользователи, один из которых ( первый кто приступит к его выполнению) должен указать дополнительную информацию.

Название задания - задается название, которое будет отображаться в интерфейсе для пользователей.

Описание задания - указывается описание или пояснения к заданию. Содержимое данного поля будет отображаться в интерфейсе для пользователей. Рекомендуется в этом поле указывать полную информацию о действии, которое необходимо выполнить пользователю. Это поможет избежать путаницу в случае нескольких однотипных действий.

Текст кнопки в задании - позволяют задать собственный текст для соответствующей кнопки.

Показывать поле ввода комментария - опция позволяет разрешить пользователям оставлять собственные комментарии к назначенному заданию. Например, какие-либо примечания касаемо задания. Содержимое поля можно получить после выполнения действия с помощью соответствующей опции в форме Вставка значения - Дополнительные результаты (см. ниже).

Обязательность комментария - опция позволяет назначить добавление комментария при выполнении действия обязательным.

Метка для поля комментария - подпись для поля с комментарием.

Устанавливать текст статуса - позволяет изменить текст статуса документа на произвольный. Это может, например, позволить отслеживать на каком этапе сейчас находится бизнес-процесс.

Текст статуса - задается текст статуса.

Период ожидания информации: По окончании периода задание будет автоматически завершено. Пустое значение или 0 - отсутствие периода. - позволяет установить время, в течение которого действие будет ожидать выполнения.

Ограничить доступ - делает текст задания видимым только для исполнителя задания и не показывает его в живой ленте. Это очень полезная опция, если нужно, например, передать исполнителю конфиденциальную информацию: пароли, пин-коды и т.п.

Раздел Поля позволяет добавить собственные поля, которые будет необходимо заполнить пользователям в ходе выполнения задания.

Содержимое полей после выполнения действия можно получить в форме Вставка значения - Переменные.

Переменные

В этом разделе можно получить содержимое дополнительных полей, созданных в разделе Поля.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон:

  • Комментарий.
  • Автоматическое завершение.
  • Пользователь, предоставивший информацию.
  • Измененные поля.


Ознакомление с документом
350 / 694

Действие позволяет создать для выбранных пользователей задание по ознакомлению с документом и возможностью оставить отзыв на него. В ходе выполнения задания ведется вычисление процента ознакомившихся.

Описание Параметров

Ознакомить пользователей - указываются пользователи, которые должны ознакомиться с документом.

Название задания - задается название, которое будет отображаться в интерфейсе для пользователей.

Описание задания - указывается описание или пояснения к заданию. Содержимое данного поля будет отображаться в интерфейсе для пользователей. Рекомендуется в этом поле указывать полную информацию о действии, которое необходимо выполнить пользователю. Это поможет избежать путаницу в случае нескольких однотипных действий.

Должны ознакомиться:

  • Все сотрудники - задача не будет выполнена пока с документом не ознакомятся все пользователи, указанные выше;
  • Любой сотрудник - с документом должен ознакомиться любой из пользователей, указанных выше.

Устанавливать текст статуса - позволяет изменить текст статуса документа на произвольный. Это может, например, позволить отслеживать на каком этапе сейчас находится бизнес-процесс.

Текст статуса - задается текст статуса.

Модификаторы
Можно использовать следующие модификаторы в тексте статуса: #PERCENT# - процент, #REVIEWED# - ознакомлено человек, #TOTAL# - всего должно быть ознакомлено, #REVIEWERS# - кто ознакомлен.

Текст кнопки в задании - позволяют задать собственный текст для соответствующей кнопки.

Показывать поле ввода комментария - опция позволяет разрешить пользователям оставлять собственные комментарии к назначенному заданию. Например, какие-либо примечания касаемо задания. Содержимое поля можно получить после выполнения действия с помощью соответствующей опции в форме Вставка значения - Дополнительные результаты (см. ниже).

Обязательность комментария - опция позволяет назначить добавление комментария при выполнении действия обязательным.

Метка для поля комментария - подпись для поля с комментарием.

Период ознакомления - можно задать период, если до окончания которого пользователи не будут ознакомлены с документом, то задание по ознакомлению будет автоматически завершено. Пустое значение или 0 - отсутствие периода.

Ограничить доступ - делает текст задания видимым только для исполнителя задания и не показывает его в живой ленте. Это очень полезная опция, если нужно, например, передать исполнителю конфиденциальную информацию: пароли, пин-коды и т.п.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно следующее:

  • Комментарий;
  • Сколько ознакомлено;
  • Сколько должно быть ознакомлено;
  • Автоматическое ознакомление - поле будет содержать 1, если задание по ознакомлению было автоматически завершено (см. Период ознакомления);
  • Последний ознакомившийся - ID последнего пользователя ознакомившегося с документом.


Конструкции
351 / 694

В группе собраны управляющие конструкции.


Команда
352 / 694

Действие, выполнение которого зависит от пользователей . Для них будет создан соответствующий элемент управления.

Команду можно использовать и отдельно, но тогда нужно будет оповестить пользователя, например, с помощью сообщения соц. сети , что ему необходимо выполнить эту команду. Тип и вид элемента управления зависит от документа и места, где был запущен бизнес-процесс.

Описание Параметров

Выполнить команду могут - позволяет ограничить круг пользователей, которым будет доступна эта команда.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон:

  • Пользователь, отправивший команду.

Пример использования действия

В данном примере, после выполнения блока действий, бизнес процесс остановится и будет ждать, пока пользователь с помощью команды не решит, по какой ветке будут развиваться события.


Условие
353 / 694

Конструкция позволяет направить бизнес-процесс по разным сценариям в зависимости от заданных условий.

Проверка условий начинается слева направо. Если условие выполняется, то действия, расположенные в ветке под ним, будут исполнены. Если же какое-либо условие не выполняется, то будет произведен переход к условию, расположенному правее и так до тех пор, пока какое-либо условие не будет выполнено.

Тип условия - PHP код

В качестве условия указывается код . В случае если указанный PHP код вернет значение true, то будет выполнена ветка действий условия, если возвратится false, то будет произведен переход к следующему условию.

Внимание! Для этого типа условия можно использовать только PHP-код. Параметры типа {=Variable:Variable2_printable} не поддерживаются. Также результатом выполнения кода в условии должно быть логическое выражение (true или false).

Тип условия - Поле документа

Ветка действий условия будет выполнена, если совпадут параметры, связанные с полями документа.

Тип условия - Значение переменной

Ветка действий условия будет выполнена , если совпадут параметры, связанные с переменными бизнес-процесса.

Тип условия - Истина

Ветка действий будет выполнена сразу. Это условие выполняется всегда.

Тип условия - Было изменено

Если бизнес-процесс запускается при изменении документа, то есть возможность определять внутри него измененные поля. Ветка условий будет выполняться , если в поле были внесены какие-то изменения.

Как настроить этот тип условия (для разработчика)
Для того, чтобы можно было использовать данный тип условия, нужна реализация на стороне модуля, который работает с процессом. При старте процесса необходимо передавать массив изменившихся полей через параметр CBPDocument::PARAM_MODIFIED_DOCUMENT_FIELDS:
CBPDocument::StartWorkflow(
   $arDocumentState["TEMPLATE_ID"],
   BizProcDocument::getDocumentComplexId($arParams["IBLOCK_TYPE_ID"], $arResult["ELEMENT_ID"]),
   array_merge($arBizProcParametersValues[$arDocumentState["TEMPLATE_ID"]], array(
      CBPDocument::PARAM_TAGRET_USER => "user_".intval($GLOBALS["USER"]->GetID()),
      CBPDocument::PARAM_MODIFIED_DOCUMENT_FIELDS => $modifiedFields
   )),
   $arErrorsTmp
);

А для того, чтобы новое условие появилось в редакторе для настройки, необходимо реализовать в документе его поддержку:

public static function isFeatureEnabled($documentType, $feature)
{
   return in_array($feature, array(\CBPDocumentService::FEATURE_MARK_MODIFIED_FIELDS));
}

Внимание! Если ни одно из условий не выполнится, то, бизнес-процесс продолжит выполнять действия расположенные под конструкцией Условие. Другими словами он ее "перескочит".

Объединение условий

Для типов условия Поле документа и Значение переменной возможно объединять условия по правилу И / ИЛИ. При выборе И ветка условий будет исполняться при выполнении обоих условий, а при ИЛИ - любое из указанных.


Параллельное ожидание действия
354 / 694

Конструкция позволяющая направить бизнес-процесс по разным сценариям в зависимости от того, какое из событий наступит раньше.

Для выбора ветки действий в этой конструкции первыми должны быть обязательно использованы действия Команда или Пауза .Другими словами, какое из этих действий в разных ветках произойдет раньше, то нижележащая цепочка того и будет выполнена.

Действие Пауза позволяет продолжить выполнение бизнес-процесса через определенное время в случае, если ни одна из команд не будет выполнена. Иначе бизнес-процесс просто остановится и будет ожидать выполнения какой-либо команды внутри конструкции.


Параллельное выполнение
355 / 694

Конструкция, позволяющая выполнять параллельные сценарии бизнес-процесса.

Если какая-либо из веток внутри конструкции не будет выполнена, то бизнес-процесс остановится и будет ожидать ее исполнения. Пример использования: параллельное ознакомление с документом разных групп пользователей.


Установить статус
356 / 694

Действие позволяет перевести бизнес-процесс в другой статус , которое доступно только для бизнес-процессов со статусами.

В действии также доступна опция Прервать выполнение текущего статуса, которая позволяет немедленно перейти к новому статусу, не дожидаясь полной отработки предыдущего.


Итератор
357 / 694

Действие позволяет организовать обработку множественной переменной. С помощью него можно создать цикл действий, которые будут выполняться с очередным её значением.

В настройках действия укажите переменную , с которой вы планируете работать.

После этого можно легко организовать выполнение целого ряда однотипных действий со всеми значениями множественной переменной. Например, у вас имеется переменная с типом Пользователь, представляющая собой список сотрудников. И вы хотите создать последовательно каждому из них задачу. Укажите в настройках Итератора переменную со списком, а в сам цикл добавьте действие Задача.

Обратите внимание! Для того, чтобы каждый раз в цикле использовать очередное значение переменной, нужно использовать пункт Значение из Дополнительных результатов Итератора.


Цикл
358 / 694

Конструкция выполняет свои поддействия до тех пор, пока выполняется заданное условие.

Другими словами цикл работает пока условие истино (true), иначе (false) происходит выход из цикла.

Тип условия - PHP код

В качестве условия указывается код .

В случае если указанный PHP код вернет значение true, то цикл продолжит работу, если возвратится false, то будет произведен выход из цикла.

Тип условия - Поле документа

Цикл будет продолжать свою работу, пока совпадают параметры, связанные с полями документа.

Тип условия - Значение переменной

Цикл будет продолжать свою работу, пока совпадают параметры , связанные с переменными бизнес-процесса.

Тип условия - Истина

В этом случае цикл будет выполняться всегда

Внимание! Для облачной версии Битрикс24 количество итераций цикла ограничено 1000.

Дополнительно

Пример использования цикла для утверждения документа


Уведомления
359 / 694

В группе собраны все виды уведомления о событии.


График отсутствия
360 / 694

Действие позволяет добавить событие в график отсутствия.

Внимание! Действие относится к продукту Корпоративный портал и работает только там.

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.

Пользователь - указывается пользователь, для которого будет занесено событие в график отсутствия.


Информационный звонок
361 / 694

Действие позволяет совершить информационный звонок на указанный номер.

Внимание! Действие работает только при работающей телефонии.

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.

Номер абонента - указывается конкретный номер или строковое поле в документе, в котором указан номер телефона.

Ожидать результата - Приостановить или нет действие Бизнес-процесса пока не будет завершено выполнение информационного звонка.


Календарь
362 / 694

Действие позволяет добавить событие в календарь.

Примечание: Данное действие устарело и используется только со старой версией календарей, которые не используют модуль Календарь событий. Для текущей версии календаря следует использовать действие Событие календаря .

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.

Пользователь - указывается пользователь, для которого будет создано событие в календаре.


Событие календаря
363 / 694

Действие позволяет добавить событие в календарь (используется для модуля Календарь событий).

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.

Тип календаря (не обязательное) - задается тип календаря, в котором будет создано событие .

Доступные типы календарей можно посмотреть в настройках модуля (Настройки > Настройки продукта > Настройки модулей > Календарь событий, закладка "Типы календарей").

ID владельца календаря (не обязательное) - указывается идентификатор владельца календаря. В случае создания события в календаре группы указывается ее идентификатор (см. пример ниже).

Примечание: Данное поле актуально, только если Тип календаря не равен user.

Пользователь - указывается пользователь, для которого будет создано событие в календаре.

Пример:
Для создания события в группе (которая, например, имеет адрес http://site_domen/workgroups/group/5/), помимо основных полей, необходимо заполнить поля следующим образом:
  • Тип календаря (не обязательно): group
  • ID владельца календаря (не обязательно): 5

Внимание! Получить значение поля ID секции календаря (не обязательно) можно из базы данных, из исходного кода страницы или из анализа AJAX запроса. Поэтому данное поле лучше заполнять программисту.


Уведомление пользователя
364 / 694

Действие позволяет отправлять сообщения на сайт /XMPP/e-mail .

Описание Параметров

Текст уведомления для сайта - задается текст сообщения, который будет отображаться в качестве уведомления на сайте, если пользователь не использует XMPP.
Для текста доступно форматирование BBCode ([b], [i], [s], [u], [url]).

Текст уведомления для email/jabber - задается текст сообщения для e-mail/XMPP, который будет отправлен, если пользователь не авторизован на сайте. Текст сообщения можно задать как отличный от текста уведомления для сайта, так и такой же, оставив для этого поле пустым.

Тип уведомления - позволяет указать от кого придет сообщение: от конкретного человека или же это будет системное сообщение.


Почтовое сообщение
365 / 694

Действие позволяет отослать уведомление о событии на e-mail, указанный в настройках действия.

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.

Тип сообщения - указывается, как будет отправлено сообщение: в виде текста или с использованием html.

Кодировка - Задается кодировка отправляемого сообщения.

Способ отправки - выбирается способ отправки сообщения:

  • Прямая отправка - сообщение будет отправлено сразу ;
  • Отправка через систему сообщений - сообщение будет отправлено через встроенную почтовую систему. Отправка может произойти не сразу .

Сайт шаблона сообщения - указывается сайт шаблона сообщения для отправки его через встроенную почтовую систему. На разных сайтах могут быть разные шаблоны почтовых сообщений .

Вложение - позволяет добавить к письму документы, хранящиеся в полях, параметрах либо переменных типа Файл или Файл (Диск).

Разделитель почтовых адресов - указывается символ, которым можно разделить почтовые адреса получателей при групповой рассылке.


Установить текст статуса
366 / 694

Действие позволяет изменить текст статуса документа, что облегчает отслеживание состояния документа в общем списке бизнес-процессов во время выполнения бизнес-процесса. Также в большинстве случаев статус можно посмотреть, перейдя к детальному просмотру документа, для которого запущен бизнес-процесс.

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.


Сообщение соц.сети
367 / 694

Действие, которое позволяет отправить уведомление о событии указанному пользователю/группе пользователей через модуль социальной сети.

Если пользователь не активен в течение 10 минут, то сообщение будет отправлено на почту.

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.


Контроль
368 / 694

Действие позволяет отправить уведомление руководителю ответственного за сущность менеджера.

Примечание: данное действие доступно для Сделок и Лидов в бизнес-процессах в CRM.

Параметры действия

Текст сообщения - текст уведомления, отправляемого руководителю.

Отправить руководителю - выбирать ли непосредственного начальника ответственного менеджера, согласно структуре компании.

Дополнительные получатели - дополнительные пользователи, которым будет отправлено уведомление. Если руководителем не является непосредственный начальник, то здесь указывается кому нужно отправить уведомление.


Задача
369 / 694

Действие позволяет создать задачу .

Описание Параметров

Настройка параметров действия аналогична созданию новой задачи в публичной части сайта .

Остановить процесс на время выполнения задачи - при отмеченной опции бизнес-процесс будет остановлен до тех пор, пока созданная задача не перейдет в статус Завершена.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно:

  • ID задачи;
  • Дата завершения задачи;
  • Пользователь, закрывший задачу.


Сообщение в живую ленту
370 / 694

Действие позволяет отправлять сообщения в Живую ленту указанному пользователю или группе пользователей.

Описание параметров

Автор - от чьего имени будет размещена запись в Живой ленте.

Внимание! Если вдруг в этом поле окажется несколько авторов, то автором записи будет тот, кто указан в поле первым.

Получатели - пользователи, группы пользователей или отделы, в чьих живых лентах будет размещена создаваемая запись.

Тема сообщения - с какой темой будет размещено сообщение.

Текст сообщения - содержание сообщения. Для сообщения поддерживается работа с BB-кодами.

Целевой сайт - в Живой ленте какого сайта публиковать данное сообщение.


Диск
371 / 694

В группе собраны действия для работы с объектами диска.


Детально об объекте Диска
372 / 694

Действие позволяет получить детальную информацию об объекте. Полученная информация используется в качестве дополнительных результатов для других действий.

Описание параметров

Исходный объект - файл или папка на диске, информацию о которых необходимо получить.

Папка или файл Диска - можно указать дополнительные данные для действия, например ID ранее созданной папки.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно:

  • Тип объекта;
  • Название;
  • Размер в байтах;
  • Размер (форматированное);
  • URL для просмотра;
  • URL для загрузки.


Загрузить в Диск
373 / 694

Действие загружает файл в хранилище Диска.

Описание параметров

Куда загрузить - куда именно нужно загрузить файл. Возможны следующие варианты:

  • Диск пользователя - в этом случае так же указывается и пользователь, в диск которого будет загружаться файл;
  • Диск группы соцсети - файл будет загружен в диск указанной группы;
  • Общий диск - файл будет загружаться в выбранный общий диск;
  • Папка диска - файл будет загружен в папку на Диске.

Файл для загрузки - необходимо указать сам загружаемый файл;

Загружать от имени - от чьего имени будет загружен файл на диск.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно:

  • ID файлов Диска;
  • URL для просмотра;
  • URL для загрузки.


Удалить объект Диска
374 / 694

Действие удаляет объект Диска.

Описание параметров

Исходный объект - файл или папка, которые должны быть удалены;

Папка или файл Диска - можно указать дополнительные данные для действия, например ID ранее созданной папки;

Удалять от имени - от чьего имени будет удален файл.


Копировать/Переместить в Диске
375 / 694

Действие позволяет копировать элементы или перемещать их в Диске.

Описание параметров

Исходный объект - файл или папка, которые будут скопированы;

Папка или файл Диска - можно указать дополнительные данные для действия, например ID созданной ранее папки;

Тип операции - какая операция будет производиться: Перемещение или Копирование.

Куда - куда будет произведено копирование/перемещение. Возможны следующие варианты:

  • Диск пользователя - в этом случае так же указывается и пользователь в, диск которого будет загружаться файл;
  • Диск группы соцсети - файл будет загружен в диск указанной группы;
  • Общий диск - файл будет загружаться в выбранный общий диск;
  • Папка диска - необходимо указать папку, в которую будет загружен файл.

Выполнять от имени - от чьего имени будет выполняться операция.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно:

  • ID объектов Диска;
  • URL для просмотра;
  • URL для загрузки.


Загрузить новую версию в Диск
376 / 694

Загружает новую версию документа на Диск.

Описание параметров

Файл Диска - файл на диске, который будет обновлен;

Файл для загрузки - новая версия обновляемого файла на диске;

Загружать от имени - от чьего имени будет произведено обновление.


Создать папку в Диске
377 / 694

Действие создает папку в Диске.

Описание параметров

Где создать - где будет создана папка. Возможны следующие варианты:

  • Диск пользователя - в этом случае также указывается и пользователь, в диск которого будет загружаться файл;
  • Диск группы соцсети - файл будет загружен в диск указанной группы;
  • Общий диск - файл будет загружаться в выбранный общий диск;
  • Папка диска - необходимо указать папку, в которую будет загружен файл.

Название папки - как будет называться созданная папка;

Создатель папки - от чьего имени будет создана папка.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно:

  • ID папки Диска;
  • URL папки.


CRM
378 / 694
В группе собраны действия для работы с CRM.


Создание новой компании
379 / 694

Действие аналогично действиям в публичной части CRM по созданию новой компании.

Примечание: если при создании элемента появляются неописанные поля, то это заведенные на портале пользовательские поля .


Создание нового контакта
380 / 694

Действие аналогично действиям в публичной части CRM по созданию нового контакта .

Примечание: если при создании элемента появляются неописанные поля, то это заведенные на портале пользовательские поля


Реклама Яндекс
381 / 694

Добавляет email и телефонные номера в рекламный сегмент Яндекс.Аудитории.

Важно! Роботы рекламы не настраиваются через дизайнер бизнес-процессов. Они настраиваются отдельно в CRM в разделе Автоматизация .


Сменить ответственного
382 / 694

Действие позволяет сменить ответственного за сущность, на которой был запущен бизнес-процесс.

Параметры действия

Новый ответственный - указывается новый ответственный за сущность.


Создать на основании
383 / 694

Действие позволяет создать новую сделку на основании лида .

Параметры действия

Создать на основании - выбирается тип сущности, который будет создан на основании лида (пока что доступно только создание сделки).

Направление сделки - указывается направление создаваемой сделки.


Выбор данных crm
384 / 694

Действие позволяет получить значения полей некоторой сущности. Выбранные поля будут доступны в форме Вставки значения во вкладке Дополнительные результаты.

Параметры действия

ID сущности - уникальный идентификатор.

Тип сущности - для каких типов записей (Контакты, Лиды, Сделки, Компании) будет осуществляться выборка полей.

Выберите поля - укажите, какие из полей будут выбраны.

Версия для печати - укажите эту опцию, если вы хотите получить значения полей в форме, понятной человеку.


Задание
385 / 694

Действие создает дело для ответственного менеджера.

Параметры действия

Тема - название создаваемого дела.

Описание - подробная информация о содержании дела.

Ответственный - менеджер, отвечающий за создаваемое дело.

Важное дело - указать для дела повышенную важность. Важные дела в списке дел помечаются значком [image].

Автоматически завершать дело при переходе в другой статус - при выборе данной опции дело будет считаться завершенным, как только статус Лида/Сделки изменится.


Ожидание статуса лида
386 / 694

Действие приостанавливает выполнение бизнес-процесса, пока не будет достигнут указанный статус лида.

Описание параметров

ID лида - идентификатор лида.

Статус - укажите статус, по достижении которого процесс продолжит свое выполнение.


Отправить SMS
387 / 694

Действие позволяет отправить SMS клиенту.

Параметры действия

Текст сообщения - что будет отправлено клиенту.

Провайдер - с помощью какого провайдера нужно отправить сообщение. Провайдера необходимо установить через Маркетплейс.


Реклама Вконтакте
388 / 694

Добавляет e-mail и телефонные номера в рекламную аудиторию Вконтакте.

Важно! Роботы рекламы не настраиваются через дизайнер бизнес-процессов. Они настраиваются отдельно в CRM в разделе Автоматизация .


Реклама Google AdWords
389 / 694

Добавляет e-mail и телефонные номера в рекламную аудиторию Google AdWords.

Важно! Роботы рекламы не настраиваются через дизайнер бизнес-процессов. Они настраиваются отдельно в CRM в разделе Автоматизация .


Реклама Facebook
390 / 694

Добавляет e-mail и телефонные номера в рекламную аудиторию Facebook.

Важно! Роботы рекламы не настраиваются через дизайнер бизнес-процессов. Они настраиваются отдельно в CRM в разделе Автоматизация .


Отправить письмо
391 / 694

Действие позволяет отправить письмо клиенту.

Параметры действия

Тема - тема письма.

Текст письма - текст письма.


Запланировать звонок
392 / 694

Действие позволяет запланировать звонок клиенту.

Описание параметров

Тема - название события.

Дата начала - дата и время начала звонка.

Дата завершения - дата и время завершения звонка.

Описание - детальное описание назначения звонка.

Напомнить за - количество единиц времени, за которое будет выслано уведомление.

Интервал напоминания - выбор единиц времени.

Ответственный - сотрудник, ответственный за звонок клиенту.

Важное дело - указать высокую важность события.


Запланировать встречу
393 / 694

Действие позволяет запланировать встречу с клиентом.

Описание параметров

Тема встречи - название события.

Дата начала - дата и время начала встречи.

Дата завершения - дата и время завершения встречи.

Описание - детальное описание создаваемой встречи.

Место - место проведения встречи.

Напомнить за - количество единиц времени, за которое будет выслано уведомление.

Интервал напоминания - выбор единиц времени.

Ответственный - сотрудник, ответственный за встречу с клиентом.

Важное дело - указать высокую важность события.


Создание новой сделки
394 / 694

Действие аналогично действиям в публичной части CRM по созданию новой сделки .

Примечание: если при создании элемента появляются неописанные поля, то это заведенные на портале пользовательские поля .


Сменить статус
395 / 694

Действие позволяет сменить статус лида или сделки и немедленно прервать исполнение процесса.

Параметры действия

Изменить на статус - какой статус для записи нужно установить.


Создание нового лида
396 / 694

Действие аналогично действиям в публичной части CRM по созданию нового лида .

Примечание: если при создании элемента появляются неописанные поля, то это заведенные на портале пользовательские поля .


Запись события в crm
397 / 694

Действие позволяет создать запись события в CRM .

Действие выполняется только в контексте бизнес-процессов, работающих в CRM.


Ожидание стадии сделки
398 / 694

Действие приостанавливает выполнение бизнес-процесса пока не будет достигнута указанная стадия сделки.

Описание параметров

ID сделки - ID сделки. Для удобства можно использовать Форму вставки значения.

Стадия - нужно указать стадию, по достижении которой процесс продолжит свое выполнение.

Действие выполняется только в контексте бизнес-процессов, работающих в CRM.


Прочее
399 / 694

В группе собраны все остальные команды.


PHP код
400 / 694

Действие позволяет выполнить произвольный PHP код .

Внимание! Данное действие доступно только для коробочной версии «Битрикс24».

Описание Параметров

Смысл большинства полей ясен из их названия, поэтому их описание будет пропущено.

Примеры использования

Примечание: Код нужно указывать без открывающих и закрывающих тегов (<?, ?>).

Важно! Не рекомендуется использовать в теле кода выражения типа {=...}. Они могут содержать параметры, которые может изменить любой пользователь портала, даже не имеющий необходимых прав.
Например, вместо конструкции {=Variable:COMPANY_NAME} лучше использовать $root->GetVariable('COMPANY_NAME').

1. Установка значения переменной

$this->SetVariable('Variable1', 12345);

где:

Variable1 - идентификатор переменной, которой будет присвоено значение (число 12345).

2. Запись нескольких пользователей в переменную типа "Пользователь"

$this->SetVariable("user", array("user_1", "user_2"));

где:

array("user_1", "user_2") - массив пользователей в формате user_[идентификатор_пользователя_в_системе].

3. Использование php-кода и значений полей/переменных для получения названия элемента инфоблока

$arFilter = Array("IBLOCK_ID" => {=Variable:Variable1_printable}, "ID" => {=Document:PROPERTY_1});
$dc = CIBlockElement::GetList(array(), $arFilter, array("NAME"));
$br = $dc->Fetch();
$Pbrr = $br["NAME"];
$this -> SetVariable('Variable2', $Pbrr);

где:

{=Variable:Variable1_printable} - значение переменной, в которой содержится идентификатор инфоблока;
{=Document:PROPERTY_1} - поле документа, содержащее идентификатор элемента инфоблока;
Variable2 - идентификатор переменной, которой будет присвоено вычисленное название элемента инфоблока.

4. Преобразование формата поля документа и дальнейшее его использование

Рассмотрим пример преобразования поля документа Пользователь в понятную форму для того, чтобы использовать его при отправке сообщения:

  1. В шаблоне бизнес процесса следует создать переменную для хранения преобразованного значения поля документа;
  2. Укажем в действии PHP-код приблизительно следующее:
    $rsUser = CUser::GetByID({=Document:PROPERTY_USER});
$arUser = $rsUser->Fetch();
$this->SetVariable('#Имя_переменной#', $arUser[NAME].' '.$arUser[SECOND_NAME].' '.$arUser[LAST_NAME]);
  3. После чего в блоке, используемом для уведомления, необходимо уже использовать вывод данной переменной вместо поля документа.

Документация по теме:

  • Произвольный PHP код в бизнес-процессе
  • Добавление информации в инфоблок из бизнес-процесса


Пауза в выполнении
401 / 694

Действие позволяет отложить выполнение следующего действия на заданное время.

Описание Параметров

Режим:

  • Промежуток - указывается промежуток времени, через который продолжится выполнение бизнес-процесса;
  • Время - указывается конкретное время возобновления бизнес-процесса.

Примечание: Если в режиме Время, на момент выполнения действия, указанная дата имеет место в прошлом (например был указан прошлый год, а действие начало выполняться в текущем), то будет произведен автоматический переход к следующему за "паузой в выполнении" действию. Другими словами процесс "перескочит" через него.


Блок действий
402 / 694

Блок действий предназначен для группировки набора действий в один блок, который можно свернуть для экономии места.

Обратите внимание на это действие. Оно позволяет существенно сэкономить трудозатраты на типовых блоках действий при создании шаблона бизнес-процесса. Однажды созданный и настроенный блок действий можно сохранить в группе Мои действия и многократно использовать.


Выбор сотрудника
403 / 694

Действие позволяет в автоматическом режиме выбрать сотрудника для дальнейшего использования его в процессе.

Описание Параметров

Тип:

  • случайный - выбор обычного сотрудника случайным образом;
  • начальник - выбор начальника для указанного сотрудника.

Из пользователей - указываются пользователи или группы, из которых будет выбран один сотрудник.

Для пользователя - указывается пользователь, для которого будет выбран начальник.

Уровень начальника (чем больше, тем выше уровень) - выбирается уровень начальника для указанного пользователя.

Резервные пользователи - Указываются пользователи, которые будут выбраны в случае невозможности выбора из основных пользователей, указанных выше. Например, если указанная в поле Из пользователей группа не содержит сотрудников, то будет выбран кто-то из резервных пользователей.

Пропускать отсутствующих - позволяет автоматически пропускать отсутствующих сотрудников, например, если они в отпуске.

Пропускать с завершенным рабочим днем - позволяет автоматически пропускать сотрудников, завершивших рабочий день.

Подробнее про ситуацию с отсутствующим сотрудником/начальником

Если невозможно выбрать основного начальника (например, в случае отпуска) и опция Пропускать отсутствующих равна Да, то действие автоматически продолжит выбирать начальника, но уже более высокого уровня. Если будет недоступен и начальник самого верхнего уровня, то выбор будет производиться уже из сотрудников, указанных в поле Резервные пользователи.

Если опция Пропускать отсутствующих равна Нет, то действие завершится и, независимо от отсутствия, будет выбран начальник соответствующего уровня.

Если все начальники будут недоступны или у сотрудника нет начальника, то действие вернет пустое значение.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно:

  • Выбранный сотрудник.


Создание группы
404 / 694

Действие позволяет создать рабочую группу.

Описание параметров

Название группы - необходимо указать название создаваемой группы.

Владелец группы - необходимо выбрать пользователя, который будет владельцем группы. Важно то, что у группы может быть только один Владелец.

Участники группы - необходимо выбрать участников группы. Можно выбрать как отдельных пользователей, так отделы и членов другой рабочей группы.


WebHook
405 / 694

Действие позволяет добавить WebHook . Действие не возвращает никаких данных, оно только отправляет запрос.

Параметры действия

Хендлер - URL, который нужно использовать при отправке данных из Битрикс24.


Запись в отчет
406 / 694

Действие позволяет добавлять в отчет и лог, соответственно, произвольные записи. Запись в отчет удобно использовать, например, во время отладки бизнес-процесса, сохраняя в отчет данные на нужном этапе.

Описание Параметров

Загрузить отчет для доступа из бизнес-процесса - позволяет получить содержимое всего отчета в рамках бизнес-процесса для дальнейших действий (например, отправить по почте) используя форму Вставка значения (секция Дополнительные результаты). В противном случае данные отчета нельзя будет получить в рамках бизнес-процесса и просмотреть возможно будет только в логе.

Опцию Загрузить отчет для доступа из бизнес-процесса логично использовать на этапе завершения бизнес-процесса для формирования конечного отчета без лишних запросов к базе.

Результаты выполнения действия

Результаты выполнения этого действия можно получить с помощью формы Вставка значения - Дополнительные результаты, в которой они будут доступны сразу после добавления действия в шаблон.

Доступно:

  • Отчет.

В секции Дополнительные результаты на каждую запись в отчет будет создана своя переменная. Если для действия была отмечена опция Загрузить отчет для доступа из бизнес-процесса, то с её помощью можно будет получить отчет, который уже был сформирован на этапе этого действия. Отчет каждого последующего действия будет включать отчет предыдущих действий. Если опция не была отмечена, то переменная будет пустой.


Изменение переменных
407 / 694

Действие позволяет изменить значения переменных, заданных в настройках шаблона.

Описание Параметров

В выпадающих списках выбираются переменные и устанавливаются для них необходимые значения.


Установка прав
408 / 694

Действие позволяет устанавливать права на доступ к документу.

Описание Параметров

Право на операцию "..." имеют - установка прав документа для указанных пользователей/групп пользователей.

Перезаписать - позволяет не добавлять права, а производить их замену. В данном случае производится работа только с правами, которые устанавливаются внутри бизнес-процесса.

Особенности назначения прав в системе
Если для документа используется упрощенная (старая) версия прав, то они устанавливаются жестко извне (настройки доступа к инфоблокам/спискам/и.т.д.). Единственный вариант, позволяющий устанавливать права прямо из бизнес-процесса - это установка для документа права бизнес-процессы извне (права на сам документ). В этом случае с помощью закладки Доступ или действия Установка прав можно менять права по ходу выполнения процесса.

Если используются расширенные права доступа, то из бизнес-процесса можно только добавлять новые права на документ, которые будут оставаться у документа даже после выполнения процесса. Переопределить права, которые были установлены извне, внутри бизнес-процесса нельзя.

Важно! С версии 15.5.0 Дизайнера бизнес-процессов данное действие исключено для модулей Диск и CRM.


Прерывание процесса
409 / 694

Действие позволяет прекратить выполнение бизнес-процесса.

Важно! Продолжить выполнение процесса с того места, где он был прерван нельзя. Для выполнения всех последующий после прерывания операций придется запускать бизнес-процесс заново.

Описание параметров:

Текст статуса - устанавливает текст статуса действия.


Мои действия
410 / 694

Мои действия позволяют сохранять настроенные действия/конструкции и использовать их повторно.

Также этот блок удобно использовать для копирования действий внутри шаблона бизнес-процесса. Достаточно перетянуть в него нужные действия. После их можно будет многократно использовать, перетянув обратно в рабочую область дизайнера бизнес-процессов.

Действия, добавленные в этот блок, сохраняются вместе с шаблоном и могут потом повторно использоваться при последующем редактировании.

Документация по теме:

  • Создание собственных действий


Примеры работы с действиями
411 / 694
Давайте посмотрим примеры использования действий в бизнес-процессах.


Пример использования цикла для утверждения документа
412 / 694

Используем цикл для процесса утверждения документа

Рассмотрим такой пример: документ проходит процедуру утверждения до тех пор, пока начальство не исправит его и не одобрит. Если документ не утвержден, то запрашивается дополнительная информация и он вновь направляется на утверждение.

Пример упрощен, и описание касается только работы конструкции Цикл . В примере используем тип условия - Поле документа.

Порядок действий:

  • Первым делом добавим действие Изменение документа . C помощью ссылки Добавить поле создадим дополнительное поле типа список с названием Результат утверждения. Укажем 2 варианта значений поля с новой строки: на рассмотрении и утвержден. По значениям этого поля будет принято решение - выходить из цикла или нет.

    Теперь выберем созданное поле Результат утверждения и установим для него значение на рассмотрении .

  • Добавим действие Цикл. В параметрах укажем : тип условия - поле документа; условие - равно; значение - на рассмотрении.
  • В цикле добавим действие Утверждение документа :
    • В ветку Да добавляем действие Изменение документа. В параметрах поля Результат утверждения выбираем значение утвержден. Этим мы заставим процесс больше не входить в цикл.
    • После этого действия, если требуется, ставим дополнительные действия .
    • В ветку Нет добавляем действие Запрос дополнительной информации . Оно используется, например, для указания информации о правках старой версии документа или каких-либо замечаний, связанных с повторным рассмотрением документа.
    • Добавляем действие Изменение документа. В поле Результат утверждения выбираем значение на рассмотрении. Этим мы заставим процесс повторно войти в цикл. Также в этом действии мы обновим значения полей документа на значения, полученные из предыдущего действия, т.е. отправим на рассмотрение уже измененный документ.
    • При необходимости укажем в этой ветке дополнительные действия.
  • После конструкции Цикл установим действие, которое оповестит нас о том, что цикл завершил свою работу. В качестве оповещения выберем действие Установить текст статуса или Почтовое сообщение .

Итоговая схема шаблона бизнес-процесса с Циклом:


Пример работы с переменными и дополнительными результатами действий
413 / 694

Когда нужна дополнительная информация

Рассмотрим пример создания простого шаблона последовательного бизнес-процесса , в котором у пользователя запрашивается дополнительная информация, и затем она используется для записи в отчет и установку статуса документа.

Порядок действий:

  • Добавим действие Запрос дополнительной информации .
  • Перейдем к форме настройки параметров действия. Заполним обязательные поля и добавим новые с помощью cсылки Добавить поле:
    • Дата начала (тип Дата/Время);
    • Количество (тип Число);
    • Согласовано (тип Список).

    В рамках этого действия мы создаем поля , которые отобразятся пользователю. Заполняя эти поля, пользователь задает нужные значения переменных. Для внесения изменений в поля заходим в параметры действия или пользуемся кнопкой Параметры шаблона на контекстной панели дизайнера бизнес-процессов.

  • Добавим действие Запись в отчет . Вызовем окно настроек действия и, используя форму Вставка значений, вставим в поле Текст наши переменные (группа Переменные) и комментарии (группа Дополнительные параметры).
  • Добавим действие Установить текст статуса и укажем текст .
  • Запустим бизнес-процесс на исполнение и введем требуемые данные .
  • Во вкладке Мои процессы отображается статус завершенного бизнес-процесса.
  • Перейдем к просмотру журнала исполнения процесса , там отображена запись, содержащая значения переменных.

Получили такой шаблон:


Пример использования действия "Выбор сотрудника"
414 / 694

Пример: начальник в отпуске

Рассмотрим небольшой пример использования действия Выбор сотрудника . Используем его для выбора начальника, который утверждает документ. Если начальник находится в отпуске, то выбирается вышестоящий начальник и так далее. Когда действие, таким образом, дойдет до генерального директора, или начальник не выбран вообще (в случае отсутствия всего начальства), то назначается заместитель начальника.

Порядок действий

  • Создадим новый шаблон, а в нем 2 переменные типа Пользователь:
    • переменная Начальник, которая меняется по ходу процесса;
    • переменная Заместитель, которая практически постоянна, и меняется вручную в случае ухода в отпуск заместителя. Укажем для нее сотрудника по умолчанию, который утвердит документ в случае отсутствия начальства.
  • Первым добавим действие Выбор сотрудника. В параметрах укажем , что производим выбор непосредственного начальника для Автора с пропуском отсутствующих.
  • Добавим действие Изменение переменной . В параметрах укажем , что значение переменной Начальник равно сотруднику, который был выбран действием Выбор сотрудника (форма Вставка значения - Дополнительные результаты - Выбор сотрудника - Выбранный сотрудник).
  • Добавим конструкцию Условие и создадим в ней 3 ветви. Нумерация условий в действии такая же, как и порядок их выполнения действием: слева направо.
    1. В первой ветке определим условие, при котором, в случае выбора генерального директора, ответственным назначается заместитель. Для этого в самом условии укажем генерального директора , а после добавим действие Изменение переменной. В нем укажем , что значение переменной Начальник равно значению переменной Заместитель.
    2. Во второй ветке определим условие, при котором заместитель утверждает документ, в случае отсутствия всего начальства. Для этого в самом условии укажем , что значение переменной Начальник должно быть пустым . Теперь добавим действие Изменение переменной, которое настраивается аналогично предыдущей ветке. После, например для заместителя, добавим уведомление о том, что все начальство отсутствует.
    3. В последней ветке условия мы не меняем сотрудников, в результате у нас значение переменной Начальник останется равно результату работы действия Выбор сотрудника.

В результате шаблон выглядит так:


Ручной переход по действиям процесса с помощью "Ознакомления с документом"
415 / 694
В ряде случаев полезно включить в шаблон ручной переход от задания к заданию (например, в целях обучения пользователей работе с созданным бизнес-процессом). С помощью действия Ознакомление с документом , создадим обязательный шаг переключения бизнес-процесса вручную к следующему исполнителю.

Как это выглядит в публичной части

В публичной части это будет выглядеть так:

Маленький минус использования этого действия в том, что ссылку Перейти к документу удалить нельзя.


Пример использования действия "Утверждение документа"
416 / 694

Утверждаем документ

Действие Утверждение документа удобно использовать для автоматизации процесса распределения работ. Например, у нас есть задача: необходимо уведомить нескольких сотрудников о наличии работы, которую нужно выполнить. Работа назначается первому сотруднику, который возьмется за ее выполнение. Как только кто-то один берет на себя эту работу, другим она уже не предлагается. В случае, если никто не согласился, процесс повторяется.

Порядок действий:

  • В данном шаблоне используем Цикл . Голосование повторится до тех пор, пока кто-либо из сотрудников не возьмет на себя работу.
  • Остановимся на настройках действия Утверждение документа подробнее :
    • В поле Утверждают сотрудники укажем тех сотрудников, которым высылается уведомление.
    • Тип утверждения - выберем Голосование сотрудников .
    • Более скольки процентов голосов необходимо для принятия решения - в данном поле укажем 0. Как только любой пользователь из указанных утвердит документ, а в нашем случае согласится взять на себя работу, то голосование прекратится.
    • Ожидать, чтобы проголосовали все указанные сотрудники - укажем Да, таким образом, цикл голосования повториться только после того, как все проголосуют.
  • После того, как сотрудник утвердил документ, ему поставлена Задача. Сотрудника, утвердившего документ, возможно указать используя Дополнительные результаты предыдущего действия с помощью формы Вставка значения.
  • Действие Изменение переменной используется только для того, чтобы контролировать выход из цикла.

Шаблон полученного процесса:


Распространенные ошибки при работе с бизнес-процессами
417 / 694

Постараемся не делать ошибок

Бизнес процессы - важнейший инструмент, который позволяет автоматизировать рабочие процессы компании. Однако их использование требует определенного навыка и осторожности. В противном случае бизнес-процессы создадут значительную нагрузку на проект.

На каждом физическом сервере в Битрикс24 одновременно работает несколько порталов. Аномальная нагрузка от одного из них негативно влияет на остальные. Одна из причин - бизнес-процессы . В связи с этим, рекомендуется проверить и скорректировать свои бизнес-процессы. При выявлении аномальной нагрузки создаваемой бизнес-процессами, портал блокируется согласно пункту 8.1 лицензионного соглашения .

Распространенные ошибки

Рассмотрим наиболее распространенные ошибки при проектирование бизнес-процессов, которые увеличивают нагрузку на портал:

  1. Изменения различных полей документа несколькими действиями — достаточно частая ошибка . Конечно, не запрещено изменять каждое поле документа отдельным действием, однако это значительно увеличивает количество выполняемых запросов при работе бизнес-процесса. Рекомендуется изменять все необходимые поля документа в рамках одного действия .

  2. Зацикливание — тщательно проверяйте отсутствие зацикливания бизнес-процессов, особенно, если используются паузы . Если запустить бизнес-процесс на создание документа с ошибкой в условии выхода из цикла, постепенно накопится большое количество экземпляров бизнес-процесса, запущенных для разных документов. Еще более опасный вариант, когда это случается для бизнес-процессов на изменение документа. В этом случае быстро накапливается большое количество работающих экземпляров бизнес-процесса даже на небольшом количестве документов.

    В некоторых случаях лучше предусмотреть отдельное условие прекращения выполнения циклов. Оно обеспечит выход из него, даже если основное условие по каким-либо причинам не было выполнено за разумное время/циклы. Например условие: бизнес-процесс прекращается после того как время обработки лида становится больше 1000 минут, несмотря на то, что статус лида еще не изменился на нужный. Это позволяет останавливать бизнес-процесс, если он не был обработан в рамках разумного времени (например, по причине увольнения ответственного).

  3. Использование проверки статуса в цикле с паузой — бывает, что вместо действия Ожидание стадии сделки используется цикл с паузой . В этом случае при запуске процесса на создание документа, накапливается большое число запущенных экземпляров шаблона бизнес-процесса, для разных документов. При постоянном частом подъеме из паузы они создают нагрузку и в определенный момент могут привести к неработоспособности проекта. Правильнее в данном случае использовать действие Ожидание стадии сделки . В этом случае бизнес-процесс проснется только во время смены статуса документа на нужный и не будет создавать нагрузку все остальное время.

  4. Некорректное использование пауз и заданий — ошибка случается часто для бизнес-процессов, которые запускаются при изменении документа .

    Использование таких действий может нарушить идеологию и целостность бизнес-процесса. Пока бизнес-процесс ожидает их исполнения, исходный документ может быть снова изменен. Поэтому бизнес-процессы, запускаемые на изменение, должны отрабатывать без каких-либо ожиданий и пауз и прекращать свое существование. Если же в бизнес-процессе, запускаемом на изменение, есть паузы, ожидание действий, запрос информации, то смело говорим, что бизнес-процесс работает неправильно.

  5. Ошибки при работе с Параллельным ожидания действия – очень часто возникают сложности при работе с этой конструкцией . При ее использовании процесс выполняется по той ветке, которая следует за первой выполненной Командой . Но если ни одна из команд не выполнена, то и процесс зависнет и исполняться дальше не будет. Чтобы такого не происходило, всегда стоит добавлять ветку, содержащую Паузу в выполнении . Таким образом, бизнес-процесс продолжит свое исполнение по истечению указанного в нем времени, даже если ни одна из команд не будет выполнена.

    6. © «Битрикс», 2001-2008, «1C-Битрикс», 2008-2020 1С-Битрикс


Каталог примеров
418 / 694

В главе приведены примеры использования бизнес-процессов.

Посмотреть примеры работ с отдельными действиями можно в разделе Примеры работы с действиями.

Внимание! Обязательно производите сверку и настройку под себя импортируемых шаблонов бизнес-процессов.


Пример создания бизнес-процесса
419 / 694

Рассмотрим процедуру создания БП на примере алгоритма согласования подотчетных денег. С использованием компонента Бизнес-процесс. Создание БП с использованием других механизмов будет частично выглядеть иначе. Пусть в нашей условной организации согласование подотчетных денег осуществляется следующим образом:

  1. Составляется заявка на выдачу подотчетных денег;
  2. Заявка согласуется с руководителем (или несколькими руководителями). Пусть согласование производится по очереди с двумя заранее известными руководителями;
  3. Оформление заявки в бухгалтерии;
  4. Выдача денег;
  5. Предоставление отчета;
  6. Проверка отчета в бухгалтерии.

Пусть при этом подать заявление на подотчетные деньги может любой сотрудник, а видеть все заявления может только руководство.


Создание нового бизнес-процесса
420 / 694

Для создания нового БП нажмите на кнопку Новый бизнес-процесс на странице Бизнес-процессы > Процессы в ленте:

И заполните форму создания нового БП:

После сохранения БП автоматически запускается редактор БП и открывается окно основных настроек БП.

В основных параметрах БП на закладке Параметры с помощью команды Добавить параметр задайте входящие параметры БП: подотчетное лицо, сумма, цель и описание подотчетных денег. Эти параметры должно будет заполнить подотчетное лицо при оформлении заявки (т.е. при запуске экземпляра БП). Приведем ключевые значения полей формы, остальные поля заполните по собственным потребностям:

  • Подотчетное лицо: идентификатор – TargetUser, тип – Привязка к сотруднику.

    Примечание: Создание этого параметра с таким идентификатором нужно для одной единственной цели: правильного отображения имени пользователя создавшего заявку. Технически БП будет работать и без этого параметра.
    В отличие от других параметров использование другого типа идентификатора невозможно, параметр не будет выполнять своей роли.

  • Сумма: идентификатор – Summ, тип – Число, обязательный.
  • Цель: идентификатор – Purpose, тип – Список, обязательный, заполнить поле Варианты значений (закупка материалов, представительские расходы и так далее).
  • Описание: идентификатор – Purpose_text, тип – Текст.

В итоге имеем:

Зададим на закладке Доступ права на доступ к БП (Для выбора групп пользователей можно воспользоваться кнопкой [image] рядом с полем ввода):

  • любой сотрудник может запустить экземпляр БП (т.е. подать заявление на подотчетные деньги), а так же может видеть свои заявки (группа Автор);
  • администраторы могут видеть все экземпляры БП и могут управлять ими (группа Администраторы);
  • руководство может видеть все экземпляры БП (группа Руководство).

После сохранения основных параметров запуска можно начинать создание шаблона БП.


Создание шаблона бизнес-процесса. Часть1.
421 / 694

Шаблон БП представляет собой последовательность шагов (действий) от начального к конечному, которые будут выполняться один за другим. Необходимо таким образом и в таком порядке составить шаги (действия), чтобы реализовать нужный нам алгоритм и получить необходимый результат.

Примечание: В данном типе документа, который используется компонентом "Бизнес-процесс", для каждого документа существует только один БП. Поэтому далее будем считать конкретный запущенный на выполнение экземпляр БП и документ эквивалентными терминами (за исключением того, что по завершении БП уничтожается, а документ сохраняется для истории).

  • Сохраните в документе входящие параметры БП: сумму, цель и описание назначения подотчетных денег. Это необходимо для того, чтобы иметь возможность посмотреть и обработать эти параметры даже после завершения БП.

    Для сохранения параметров разместите в шаблоне БП действие Изменение документа (раздел Обработка документа). Это действие позволяет сохранить любую информацию в полях документа таким образом, что к ней всегда можно будет обратиться. Кроме того, это действие позволяет создавать для документа дополнительные поля.

  • Настройте параметры действия (кнопка [image] в правом верхнем углу действия):
    • Измените название документа, которое выводится в списке документов. Допустим необходимо, чтобы документ назывался по шаблону: Подотчетное лицо, цель, сумма подотчетных денег. (Например: Иван Иванов, закупка оборудования, 3800).

      Для этого в окне настройки параметров действия выберите в выпадающем списке поле Название элемента и в качестве значения укажем строку {=Template:TargetUser_printable}, {=Template:Purpose}, {=Template:Summ}. Значения в фигурных скобках - это ссылки на значения входящих параметров БП. Они имеют вид {=Template:КодВходящегоПараметра}.

      Для вставки таких значений проще всего воспользоваться кнопкой рядом с полем ввода. В открывшемся диалоге на закладке Параметры шаблона можно выбрать любой входящий параметр БП.

      Примечание: Обратите внимание, что для входящих параметров, содержащих коды пользователей, их реальные значения можно получить строкой {=Template:КодПараметра} (например, user_1), а их печатные значения - строкой {=Template:КодПараметра_printable} (например, Иван Иванов [1]).

    • Сохраните сразу в документ все входящие параметры БП. Для этого добавьте новое поле (ссылка Добавить условие). Выберите Текст для предпросмотра и в качестве значения укажите ссылку на входящий параметр БП Описание, т.е. строку {=Template:Purpose_text}. Для вставки этой строки нажмите на кнопку [image] рядом с полем ввода и в открывшемся диалоге на закладке Параметры шаблона выберите Описание.
    • Для сохранения параметра Сумма создайте новое поле (так как стандартного поля нет). Используйте ссылку Добавить поле и введите параметры нового поля. Задайте в качестве значения поля Сумма ссылку на входящий параметр БП Сумма, т.е. строку {=Template:Summ}.

  • Сохраните параметры действия Изменение документа.
  • Нажмите на кнопку Применить редактора БП. Теперь в случае возникновения каких-либо проблем не придется начинать конструировать БП с самого начала.

Вторым шагом выполнения БП задайте установку начального статуса БП. Этот статус выводится в списке документов и служит для указания, на каком этапе согласования подотчетных денег мы находимся.

  • Установите статус с помощью действия Установить текст статуса из раздела Уведомления.

  • Откройте диалог настройки параметров действия Установить текст статуса и укажите в качестве текста статуса значение Согласование.


Создание шаблона бизнес-процесса. Часть 2.
422 / 694

Далее согласно алгоритму БП необходимо последовательно согласовать документ у двух руководителей.

  • Для организации согласования перенесите действие Утверждение документа (раздел Обработка документа) под действие Установить текст статуса.
  • Откройте диалог настройки параметров действия и заполните необходимые поля:
    • в поле Заголовок запишете значение: Утверждение начальником отдела;
    • в поле Утверждают сотрудники выберите с помощью кнопки [image] пользователя или группу пользователей, которые первыми утверждают документ (например, группы Администраторы и Руководство);
    • в поле Тип утверждения выберите значение Любой сотрудник (любой сотрудник из указанных может утвердить документ);
    • в поле Название задания введите строку Согласование подотчетных денег для {=Template:TargetUser_printable}, {=Template:Purpose} (значения в фигурных скобках могут быть выбраны с помощью кнопки [image]);
    • в поле Описание задания введите текст:
      Необходимо согласовать подотчетные деньги
Сотрудник: {=Template:TargetUser_printable}
Сумма: {=Template:Summ}
Цель: {=Template:Purpose}
Описание:
{=Template:Purpose_text};
    • в поле Устанавливать текст статуса - значение Да;
    • в поле Текст статуса измените значение на: этап 1;
    • в поле Период утверждения введите значение 5 и выберите в выпадающем списке значение дней (в этом случае если в течение 5 дней документ не будет согласован, то он будет автоматически отвергнут).

  • Сохраните внесенные изменения.

В момент обработки реальной заявки, когда конкретный экземпляр БП дойдет до шага Утверждение начальником отдела, будет сделано следующее:

  • пользователям, указанным в действии Утверждение начальником отдела, будет выставлено задание утвердить или отклонить заявку;
  • данный экземпляр БП будет поставлен в ожидание (приостановлен), пока кто-либо из указанных пользователей не выполнит задание (утвердит или отклонит заявку);
  • после выполнения задания исполнение экземпляра БП будет продолжено в соответствии с алгоритмом БП.

В случае, если первый этап согласования не будет пройден (т.е. документ будет отвергнут), выполнение БП пойдет по ветке, обозначенной словом Нет.

  • Разместите в этой ветке действие Сообщение соц.сети с сообщением для подотчетного лица об отклонении.
    • При заполнении поля Отправитель сообщения нажмите на кнопку [image] рядом с полем ввода и на закладке Дополнительные результаты открывшегося диалогового окна выберем подпункт Последний голосовавший пункта Утверждение начальником отдела. Таким образом сообщение будет отправлено от имени того пользователя, который отклонил согласование подотчетных денег.
    • В качестве получателя сообщения укажите подотчетное лицо, т.е. значение {=Template:TargetUser}.

  • Установите в этой ветке текущий статус БП с помощью действия Установить текст статуса в значение Отклонено.

  • Нажмите на кнопку Применить редактора БП. Теперь в случае возникновения каких-либо проблем нам не придется начинать конструировать БП с самого начала.

Если первый этап согласования будет успешно пройден, выполнение БП пойдет по ветке, обозначенной словом Да.

  • Разместите в этой ветке действие Утверждение документа для второго этапа согласования.
  • Настройте параметры действия аналогично первому этапу согласования с учетом того, что это – второй этап. В частности утверждать может уже другая группа пользователей или конкретный пользователь, скажем Главный бухгалтер.
  • В ветке Нет второго этапа согласования разместите действие Сообщение соц.сети с сообщением для подотчетного лица об отклонении. Кроме того установим в этой ветке текущий статус БП с помощью действия Установить текст статуса в значение Отклонено.

Если выполнение БП пойдет по ветке Да второго этапа согласования, то это означает, что подотчетные деньги согласованы у обоих руководителей. В этом случае можно оформлять их в бухгалтерии.


Создание шаблона бизнес-процесса. Часть 3.
423 / 694

Обработка заявки в бухгалтерии.

  • Разместим в ветке Да второго этапа согласования действие Сообщение соц.сети с сообщением для подотчетного лица об согласовании подотчетных денег.
  • Установите текущий статус БП с помощью действия Установить текст статуса в значение Согласовано.

Далее согласно алгоритму нашего БП необходимо оформить заявку в бухгалтерии.

  • Добавьте действие Ознакомление с документом из раздела Задания.
  • Откройте свойства действия Ознакомление с документом и заполните необходимые поля:
    • в поле Заголовок запишите значение Оформление в бухгалтерии;
    • в поле Ознакомить пользователей выберите с помощью кнопки [image] пользователя или группу пользователей, которые являются бухгалтерами (например, группы Администраторы и Бухгалтерия);
    • в поле Название задания введите строку: Оформление подотчетных денег для {=Template:TargetUser_printable}, {=Template:Purpose};
    • в поле Описание задания введите текст:
      Необходимо оформить согласованные подотчетные деньги

Сотрудник: {=Template:TargetUser_printable}
Сумма: {=Template:Summ}
Цель: {=Template:Purpose}

Описание:
{=Template:Purpose_text}
    • в поле Должны ознакомится выберите значение Любой сотрудник;
    • в поле Устанавливать текст статуса выберите значение Нет;
    • в поле Текст кнопки в задании введите значение Подотчетные деньги оформлены;
    • в поле Период утверждения значение оставьте незаполненным (т.е. БП будет дожидаться ознакомления бесконечно долго).
  • Установите текущий статус БП в значение Деньги даны в подотчет (действие Установить текст статуса).
  • Нажмите на кнопку Применить редактора БП. Теперь в случае возникновения каких-либо проблем нам не придется начинать конструировать БП с самого начала.

Далее, согласно алгоритму нашего БП, необходимо запросить отчет у подотчетного лица.

  • Используйте действие Запрос дополнительной информации (раздел Обработка документа).
  • Откройте параметры действия и заполните необходимые поля:
    • в поле Заголовок запишите значение Отчет подотчетного лица;
    • в поле Заполняют сотрудники выберите с помощью кнопки [image] подотчетное лицо из входящих параметров БП ({=Template:TargetUser});
    • в поле Название задания введите строку Отчет по подотчетным деньгам, {=Template:Purpose};
    • в поле Описание задания введите текст:
      Необходимо отчитаться по подотчетным деньгам
Сумма: {=Template:Summ}
Цель: {=Template:Purpose}
Описание:
{=Template:Purpose_text}.
    • Затем с помощью ссылки Добавить поле.. необходимо добавить поле, в которое подотчетное лицо введет отчет об использовании денег.

  • Сохраните внесенные изменения.

Следующим шагом сохраним отчет подотчетного лица в документе.

  • Воспользуйтесь действием Изменение документа.
  • В окне настройки параметров действия выберите в выпадающем списке поле Текст для просмотра и в качестве значения укажите строку {=Variable:report}. Значение в фигурных скобках - это ссылка на переменную БП, которая устанавливается действием Отчет подотчетного лица.
  • Сохраните внесенные изменения.
  • Установите текущий статус БП в значение Отчет (действие Установить текст статуса).

Далее обеспечим возможность бухгалтерии ознакомиться с отчетом подотчетного лица.

  • Добавьте действие Ознакомление с документом.
  • Откройте свойства действия Ознакомление с документом и заполните необходимые поля:
    • в поле Заголовок запишем значение Оформление в бухгалтерии;
    • в поле Ознакомить пользователей выберем с помощью кнопки [image] пользователя или группу пользователей, которые являются бухгалтерами (например, группы Администраторы и Бухгалтерия);
    • в поле Название задания введем строку Отчет подотчетного лица {=Template:TargetUser_printable}, {=Template:Purpose};
    • в поле Описание задания введем текст:
      "Отчет по подотчетным деньгам

Сотрудник: {=Template:TargetUser_printable}
Сумма: {=Template:Summ}
Цель: {=Template:Purpose}

Описание:
{=Template:Purpose_text}

Отчет:
{=Document:DETAIL_TEXT}";
    • в поле Должны ознакомиться выберем значение Любой сотрудник;
    • в поле Устанавливать текст статуса выберем значение Нет;
    • в поле Текст кнопки в задании введем значение Оформлено;
    • в поле Период утверждения значение оставим незаполненным.
  • Установите текущий статус БП в значение Завершено.

Получили готовый шаблон БП


Проверка работы
424 / 694

При создании элемента бизнес-процесса нам нужно будет настроить его параметры.

Обратите внимание, что параметр Подотчетное лицо не показывается. Параметр с кодом TargetUser устанавливается автоматически в значение, равное коду текущего пользователя.

После заполнения параметров и отправки формы будет запущен новый экземпляр БП (документ).

Примечание: Если по этому новому экземпляру БП для сотрудника, создавшего БП, сразу есть задание (т.е. он является одним из тех, кто осуществляет согласование на первом этапе), то он будет автоматически переправлен на страницу этого задания.

Далее экземпляр БП будет выполняться в соответствии с созданным БП:

  • будут выставляться задания указанным пользователям;
  • меняться статусы согласования подотчетных денег.

Конечным состоянием нашего экземпляра БП, которого он достигнет после выполнения определенного числа шагов, будет либо статус Отклонено (в случае отклонения заявки на одном из этапов согласования), либо статус Завершено (в случае одобрения заявки на обоих этапах согласования).

В случае изменения БП это изменение будет воздействовать только на вновь созданные экземпляры БП.


Пример динамического назначения прав на документ
425 / 694

Динамическое изменение прав

Рассмотрим пример динамического изменения прав на документ по мере выполнения бизнес-процесса на базе списков (Сервисы > Списки).

Поначалу, конкретный пользователь будет иметь один уровень прав, который задается на весь список. При создании нового элемента списка будет запущен бизнес-процесс. В ходе выполнения бизнес-процесса права на элемент для пользователя будут поэтапно изменяться.

Особенности назначения прав в системе
Если для документа используется упрощенная (старая) версия прав, то они устанавливаются жестко извне (настройки доступа к инфоблокам/спискам/и т.д.). Единственный вариант, позволяющий устанавливать права прямо из бизнес-процесса - это установка для документа права бизнес-процессы извне (права на сам документ). В этом случае с помощью закладки Доступ или действия Установка прав можно менять права по ходу выполнения процесса.

Если используются расширенные права доступа, то из бизнес-процесса можно только добавлять новые права на документ, которые будут оставаться у документа даже после выполнения процесса. Переопределить права, которые были установлены извне, внутри бизнес-процесса нельзя.

Создадим простой пример бизнес-процесса:

  • По умолчанию, укажем в настройках списка для определенной группы пользователей, в которую входит необходимый нам сотрудник, право на Добавление ;
  • Создадим простой последовательный шаблон бизнес-процесса (в списке выбираем Действия > Настроить бизнес-процессы), который будет запускаться при создании элемента списка.

    • Добавим действие Утверждение документа . В поле Утверждают сотрудники укажем нашего пользователя . Это действие носит демонстрационный характер и позволит управлять сценарием выполнения бизнес-процесса.
    • В ветку положительного утверждения документа добавим действие Установка прав . Отметим в нем опцию Перезаписать и укажем нужного пользователя для операции Право на операцию "Чтение" имеют .

      После выполнения данного действия пользователь будет наделен правом на просмотр созданного им, и ранее недоступного, элемента списка.

    • Добавим еще одно действие Утверждение документа. Назначение и настройки будут полностью аналогичны первому.
    • В ветку положительного утверждения документа добавим действие Установка прав. Отметим опцию Перезаписать и укажем нужного пользователя для операции Право на операцию "Полный доступ" имеют .

      Таким образом, пользователь теперь имеет право на изменение созданного им, и ранее доступного только на чтение, элемента списка.

В результате получится такая схема:

Как работает наш бизнес процесс

Требуемый пользователь создает элемент списка, который не будет для него сразу отображаться:

После будет создано первое задание бизнес-процесса по утверждению документа:

В случае утверждения, пользователь получит права на чтение. В списке появится элемент и соответствующие элементы управления для него:

После этого будет создано второе задание бизнес-процесса по утверждению документа. Форма выглядит аналогично первой. В случае утверждения, пользователь получит права на изменение, о чем будет свидетельствовать появление соответствующих элементов управления:

Примечание: Если в первый раз отклонить утверждение, то пользователь не будет обладать правом на чтение и не сможет увидеть в списке созданный им элемент. Запрос на утверждение придет во второй раз. Если утверждение выполнено, то пользователь сразу сможет читать и изменять документ, так как он будет обладать правом полный доступ.

Документация по теме:

  • Действие "Установка прав"
  • Действие "Утверждение документа"


Использование пользователя в бизнес-процессе
426 / 694

Выбираем пользователя

Рассмотрим пример на основе списков (Сервисы > Списки):

  • При создании нового элемента списка мы указываем пользователя в соответствующем поле. Этот пользователь будет использован в бизнес-процессе.
  • После запуска бизнес-процесса пользователь из этого поля будет передан в переменную. Затем от его имени будет отправлено уведомление автору .

Для этого:

  • Создадим в списке новое поле Пользователи типа привязка к пользователю. Поле множественное не отмечаем;
  • Создадим простой последовательный шаблон бизнес-процесса, который будет запускаться при создании элемента списка.
    • В параметрах шаблона создадим не множественную переменную с названием Пользователи (v_user) типа Привязка к сотруднику;
    • Добавим действие Изменение переменных , в котором передадим значение поля элемента списка Пользователи в переменную Пользователи (v_user);
    • Добавим действие Уведомление пользователя , в котором в качестве получателя сообщения укажем Автора, а в качестве отправителя - пользователя из переменной Пользователи (v_user) {=Variable:v_user}.

В результате получится такой простой шаблон:


Утверждение документа с учетом времени
427 / 694

Пример: утверждение документа

Рассмотрим простой пример, когда на утверждение документа отводится определенное время. Если документ не утвержден за указанное время (например, 10 минут с момента создания), то после выполнения задания пользователю будет выслано соответствующее уведомление.

Важно! Бизнес процесс выполняется на хитах , поэтому для точности выполнения процесса по времени на портале обязательно должны быть хиты.

Пример посмотрим на базе списков (Сервисы > Списки) для одного единственного пользователя:

  • Создадим простой последовательный шаблон бизнес-процесса (в списке выбираем Действия > Настроить бизнес-процессы), который будет запускаться при создании элемента списка;
  • В Параметрах шаблона создадим первую переменную с названием Окно утверждения (идентификатор укажем date) типа число. В поле Значение по умолчанию укажем количество минут (в нашем случае 10) на утверждение документа;
  • Там же создадим вторую переменную Вычисленная дата (название идентификатора c_date) типа Дата/Время. В эту переменную будет сохранена крайняя дата/время, относительно даты создания документа. После этого срока считается, что утверждение документа выполнено не вовремя;
  • Добавим первое действие Изменение переменных , в котором для переменной Вычисленная дата произведем расчет крайней даты/времени по формуле :
    =dateadd({=Document:DATE_CREATE}, {=Variable:date_printable} & "minutes")

    Подробнее про dateadd

    К Дате создания документа ({=Document:DATE_CREATE}) будет прибавлено требуемое количество минут ("minutes") из переменной Окно утверждения ({=Variable:date_printable}) .

  • Следующим добавим действие Утверждение документа . В поле Утверждают сотрудники укажем Автор ;
  • После утверждения документа добавим конструкцию Условие :

    • Левую ветку условия мы настроим так, чтобы значение переменной Вычисленная дата было больше чем {=System:Now};

      • Подробнее про {=System:Now}

      Где {=System:Now} - текущая дата на момент выполнения данного условия.

      В этом случае мы будем сравнивать дату/время, которая была рассчитана на момент утверждения документа (Вычисленная дата), с датой/временем, которое наступит после утверждения документа ({=System:Now}) и будет считаться текущим на момент выполнения конструкции Условие.

      Соответственно, ветка условия будет выполняться, если Вычисленная дата будет больше чем текущая дата/время (на момент после утверждения документа).

    • Правую ветку условия мы настроим так, чтобы в поле Тип условия было указано значение Истина , т.е. ветка условий будет выполняться всегда ;
    • После условия в правой ветке идет действие Уведомление пользователя. Оно будет оповещать Автора о том, что он не уложился с утверждением документа в срок.

    Ветки условия выполняются слева направо, поэтому в первую очередь будет проверено, что утверждение уложилось в указанные временные рамки, в остальных же случаях (Истина) утверждение будет считаться не уложившимся.

В результате получится такая схема шаблона:

Документация по теме:

  • Форма "Вставка значения"
  • Вычисление значений выражений в параметрах действий


Пример использования бизнес-процессов и списков
428 / 694

В данном уроке будет рассмотрен пример создания сервиса сбора и размещения заявок на закупку согласно ТЗ на корпоративном портале.


Техническое задание
429 / 694

Постановка технического задания

ТЗ по размещению заявок на закупку на корпоративном портале.

  1. Общие требования к функционалу:
    1. Требуется создать область для размещения, обработки и хранения заявок на закупку. Заявка на закупку представляет собой карточку, состоящую из набора именованных полей определенного типа. Заявка на закупку также может содержать неограниченное количество файлов (а может и не содержать ни одного).
    2. Любой пользователь (входящий в определенную группу доступа) может создать заявку на закупку. Данный пользователь в дальнейшем рассматривается как автор заявки.
    3. В дальнейшем, никакой программной обработки заявок не производится.
  2. Требования к работе с данными:
    1. Заявка состоит из следующих полей (символом ‘*’ отмечены поля, обязательные к заполнению):
      1. Тип закупки* (выбор из списка: «менее 100.000 руб», «100.000 руб и более»)
      2. Предмет закупки* (строка)
      3. Стоимость, руб (целое число)
      4. Обоснование* (многострочное поле)
      5. Выбранный поставщик* (строка)
      6. Потенциальные поставщики* (многострочное поле)
      7. Статус закупки* (выбор из списка: «на согласовании», «одобрена», «отклонена»).
      8. Инициатор* (автор заявки)
        Желательно, чтобы это поле заполнялось автоматически при вводе заявки.
      9. Непосредственный руководитель* (выбор из списка пользователей)
        Желательно, чтобы это поле заполнялось автоматически при вводе заявки.
      10. Бюджетный контролер* (выбор из списка пользователей)
        Желательно, чтобы выбор производился из ограниченного списка пользователей
      11. Юрист* (выбор из списка пользователей)
        Желательно, чтобы выбор производился из ограниченного списка пользователей
      12. Главный бухгалтер* (выбор из списка пользователей)
        Желательно, чтобы это поле заполнялось автоматически при вводе заявки.
      13. Финансовый директор* (выбор из списка пользователей)
        Желательно, чтобы это поле заполнялось автоматически при вводе заявки.
    2. Пользователи должны иметь возможность редактировать свои (и, в отдельных случаях, чужие) заявки. При этом в системе должны сохраняться: дата и время создания, дата и время изменения, автор и автор последнего изменения.
    3. Любой пользователь (п 1.2) должен иметь доступ к списку заявок, автором которых он является. Доступ к списку заявок, созданных другими пользователями, должен быть предоставлен только пользователям – членам определенной группы (как на чтение, так и на редактирование). Допускается разделение доступа на уровне интерфейса
    4. Область просмотра заявок должна представлять собой таблицу. Колонки таблицы соответствуют полям заявки.
      1. В рамках области просмотра должны быть представлены следующие поля (в указанном порядке)
        • Дата создания
        • Тип закупки
        • Предмет закупки
        • Стоимость, руб
        • Инициатор
        • Выбранный поставщик
      2. В таблице должна быть представлена группировка/сортировка по статусу закупки.
      3. Интерфейс должен предоставлять фильтрацию по значению полей заявок (как минимум: выбор значения фильтра из списка возможных значений), по любому полю, если его тип отличен от «многострочный текст».
      4. Дополнительные требования (желательно). Пользователь с правами конфигуратора системы должен иметь возможность (не прибегая к средствами разработки PHP):
        • Создавать другие представления данных, подходящие под описание п. 2.4, с произвольным набором полей, сортировок, группировок, фильтров.
        • Проводить массовые операции с заявками (например – удаление всех заявок, отвечающих критериям определенного фильтра).
        • Создавать новые типы закупки и настраивать доступность полей в зависимости от типа.
        • Редактировать состав полей заявки.
  3. Прочие требования:
    1. Необходимо предусмотреть функционал оповещений – пользователи, входящие в определенную группу, должны получать оповещения о внесении любых изменений в какую-либо заявку. Оповещение должно содержать значения всех полей заявки.
    2. В качестве групп пользователей, упомянутых в данных требованиях, должна быть возможность использовать ранее созданные группы портала (которые используются для предоставления доступа к другим ресурсам).


Подготовка списка и его настройка
430 / 694

Подготавливаем и настраиваем список

Согласно условиям ТЗ наиболее подходящим под нашу задачу будет функционал Универсальные списки .

Подготовка списка и его настройка

В нашем примере мы будем работать со списками продукта «Битрикс24 в коробке» (Сервисы > Списки).

Нажмите на рисунок, чтобы увеличить

  • Создадим новый список с поддержкой бизнес-процессов и произведем настройку подписей . Разделы мы использовать не будем, поэтому оставляем их как есть.
  • Добавим поля согласно ТЗ: во вкладке Действия выбираем Настроить поля . В открывшемся окне - [image]. Не забудем отметить нужные поля, как обязательные к заполнению.

Примеры настройки поля типа список
Поле Тип закупки.

Поле Статус закупки.

В обязательных полях, которые будут заполняться автоматически, установим в поле Значение по умолчанию текст-пояснение .

Примечание: Такими полями будут Инициатор, Непосредственный руководитель, Главный бухгалтер, Финансовый директор.

Пример настройки поля с автоматическим значением по умолчанию, равному дате и времени создания заявки

По ТЗ не требуется выбор пользователей системы, поэтому укажем требуемых сотрудников текстом с использованием поля типа Cписок :

Примечание: Такими полями будут Бюджетный контролер, Юрист.

Результат создания нами полей, согласно ТЗ, мы увидим в виде списка .

Теперь форма создания новой заявки будет иметь вид:


Настройка внешнего вида и доступа для списка
431 / 694

Настраиваем список

Теперь настроим внешний вид отображения области просмотра заявок в соответствии с техническим заданием, а также установим права доступа к списку.

Настройка внешнего вида списка и фильтра

  • С помощью кнопки [image] настроим внешний вид списка заявок в соответствии с требованиями ТЗ ;
  • В нашем примере интерфейс должен предоставлять фильтрацию по значению полей заявок. При помощи кнопки [image] настроим фильтр и отметим Для всех , чтобы наши настройки отображались для всех пользователей.

Настройка прав доступа к списку

Перейдем опять к настройке списка на закладку Доступ и укажем права доступа следующим образом:

  • Bitrix24: Все сотрудники отдела с подотделами - Добавление
  • Автор - Изменение
  • Ответственный сотрудник - Изменение


Создание бизнес-процессов
432 / 694

Создаем бизнес-процессы

Для работы с заявками мы создадим 2 шаблона последовательных бизнес-процессов (Бизнес-процессы > Процессы в ленте, кнопка Создать новый). Один будет запускаться при создании заявки, а второй - при ее изменении.

БП для создания заявки на закупку

Произведем настройку параметров шаблона:

  • На вкладке Основное укажем название и отметим опцию автоматически запускать при добавлении ;
  • На вкладке Переменные создадим новые обязательные переменные типа Привязка к сотруднику (Главный бухгалтер, Финансовый директор, Проверяющий ). Эти сотрудники в ходе процесса будут автоматически подставляться в карточку заявок;
  • Также создадим еще пару переменных типа Привязка к сотруднику для дальнейшей автоматизации, но без указания обязательности и значения по умолчанию: Инициатор, Непосредственный руководитель.

Перейдем к непосредственному созданию шаблона бизнес-процесса:

  • В основную область конструктора бизнес-процессов добавим действие Выбор сотрудника для вычисления начальника для автора, чтоб в будущем записать его имя в заявку автоматически.
  • Добавим действие Изменение документа, которое будет записывать нужные поля в карточке заявки. Заполним форму .
    • Статус закупки - указываем на согласовании. Это поможет избежать ошибки, если сотрудник при заполнении заявки укажет иной статус.
    • Инициатор - с помощью формы Вставка значения в секции Пользователи выберем Автор.
    • Непосредственный руководитель - с помощью формы Вставка значения в секции Дополнительные результаты выберем результат Выбранный сотрудник действия Выбор начальника.
    • Для полей Главный бухгалтер и Финансовый директор с помощью формы Вставка значения укажем соответствующие им переменные.
  • Добавим действие Сообщение соц.сети , которое будет отправлять уведомление сотруднику, ответственному за сервис заявок о том, что создана новая заявка. Также в сообщении будут указаны значения всех полей заявки.

В итоге получим такую схему шаблона бизнес-процесса:

БП для изменения заявки на закупку

Сначала настроим параметры шаблона:

  • На вкладке Основное укажем название и отметим опцию автоматически запускать при изменении ;
  • На вкладке Переменные создадим новую обязательную переменную типа Привязка к сотруднику, в которой явно зададим Проверяющего (сотрудника ответственного за сервис заявок).

Теперь перейдем к созданию шаблона бизнес-процесса:

  • В основную область конструктора бизнес-процессов добавим действие Сообщение соц.сети, которое отправит уведомление сотруднику, ответственному за заявки, о том, что заявка изменена. Также в сообщении будут указаны новые значения всех полей заявки;
  • Добавим конструкцию Условие и создадим 3 ветки условия: Одобрена, На согласовании, Отклонена. Это позволит отправлять автору разные сообщения о статусе его заявки;
  • Настроим условие Одобрена . Для этого в поле Поле документа укажем, что условие будет выполняться, если статус закупки будет равен одобрена;
  • Аналогичным образом настроим условия для остальных вариантов статуса закупки;

    • Добавим действие Сообщение соц.сети в ветки условий Одобрена и Отклонена. Тем самом мы будем оповещать автора о том, что заявка на закупку после ее изменения перешла в эти статусы.

  • Настроим действие Сообщение соц.сети для ветки условия Одобрена;
  • Аналогично настроим действие и для ветки условия Отклонена, изменив лишь часть текста сообщения.

В итоге наша схема шаблона бизнес-процесса выглядит так:


Пример бизнес-процесса со статусами по созданию счета для клиента в CRM
433 / 694
Рассмотрим пример бизнес-процесса со статусами по созданию счета для клиента в CRM согласно ТЗ.


Техническое задание
434 / 694

Постановка технического задания

Рассмотрим пример бизнес-процесса со статусами по созданию счета для клиента в CRM согласно ТЗ.

ТЗ по созданию счета для клиента на корпоративном портале:

  1. Менеджер по продажам начинает бизнес-процесс и заполняет поля:

    • Название сделки,
    • Менеджер по продажам,
    • Менеджер по закупкам,
    • Клиент (название),
    • Сумма сделки,
    • Адрес доставки.

  2. Менеджер по закупкам продолжает процесс и заполняет поля:

    • Поставщик (название),
    • Поставщик (контактное лицо),
    • Сумма закупки,
    • Срок поставки от поставщика,
    • Вес отправления,
    • Объем отправления,
    • Адрес отгрузки,
    • Счет от поставщика, опционально (номер и вложение),
    • Договор от поставщика, опционально (номер и вложение).

  3. Менеджер по продажам изучает ответ от менеджера по закупкам.

    Выставление срока поставки для клиента. Сверяются сроки поставки, если срок поставки до клиента равен или > срок поставки до поставщика +5 дней, процесс продолжается, иначе открывается поле комментирования сроков поставки, комментарии обязателен. Заполняются следующие поля:

    • Срок поставки до клиента.

  4. Юрист изучает договор вложенный менеджером по закупке (в случае его наличия) и создает договор для клиента. Заполняются следующие поля:

    • Договор для клиента (номер и вложение),
    • Договор от поставщика, опционально (номер и вложение).

  5. Процесс переходит менеджеру по продажам, согласование договора. Заполняются следующие поля:

    • Договор для клиента (номер и вложение).

  6. Процесс переходит менеджеру по закупкам, согласование договора. Заполняются следующие поля:

    • Договор для клиента (номер и вложение).

  7. Процесс переходит в бухгалтерию — создание и прикрепление счета для клиента. Заполняются следующие поля:

    • Счет для клиента (номер и вложение).

  8. Процесс переходит помощнику руководителя, который должен иметь возможность получить для печати всех документов сделки.

    После печати обязательно добавление сканов договора и счета для клиента с подписью и печатью, после этого сканы сохраняются, процесс возвращается менеджеру по продажам вместе со сканами счетов и договора.

    • Счет для клиента (номер и вложение),
    • Договор для клиента (номер и вложение).

Шаблон для ознакомления: Скачать


Настройки CRM
435 / 694

Как настроить CRM

Сначала произведем настройки в самой CRM.

Создание и настройка пользовательских полей

В качестве основы будем использовать такую сущность CRM, как Сделка. Поэтому первым делом мы создадим и настроим пользовательские поля для карточки сделки согласно ТЗ (CRM > Настройки > Настройки форм и отчетов > Пользовательские поля > Сделка > Список полей).

Настроенные пользовательские поля CRM

В форме будет всего 2 обязательных поля: Название и Адрес доставки. Остальные поля буду заполнены автоматически, а также при выполнении заданий разными участниками процесса.

Настройка прав доступа

Укажем, кто будет иметь доступ к бизнес-процессам (менеджеры, юрист, бухгалтер и остальные, согласно ТЗ) на странице Права доступа (CRM > Настройки > Права > Права доступа)

В нашем примере используем группу Моя компания: Сотрудники. Это позволит выбирать любого сотрудника при создании нового шаблона бизнес-процесса.

Внимание! В описании и шаблоне-примере для всех сотрудников в процессе задан по умолчанию сотрудник с идентификатором 1. Это позволит сразу ознакомиться со всем процессом, не создавая и не настраивая других пользователей.

Настройка формы создания сделки

Перейдем к форме создания новой сделки (CRM > Сделки) и произведем ее настройку согласно ТЗ.

Результат настройки формы

В итоге получим следующий вид:


Создание бизнес-процесса
436 / 694

Создаем бизнес-процесс

Создадим новый шаблон бизнес-процесса со статусами для сделки (CRM > Настройки > Роботы и бизнес-процессы > Бизнес-процессы) и настроим его параметры.

Начальные настройки

  • Укажем в параметрах шаблона, что процесс будет автоматически запускаться при добавлении новой сделки.
  • Создадим новые переменные типа Привязка к пользователю :
    • Менеджер по продажам (*),
    • Менеджер по закупкам (*),
    • Юрист (*),
    • Бухгалтер (*),
    • Логист (*),
    • Помощник руководителя (*).

    Для всех по умолчанию укажем требуемых сотрудников (в нашем случае это пользователь с идентификатором 1).

  • Создадим переменную Адрес портала (*) типа Строка и укажем для нее значение по умолчанию, равное адресу портала .

В результате получим список переменных . Остальные переменные будут созданы по мере необходимости .

Статусы шаблона

Начальный статус

Подпроцесс первого статуса начинается с Блока действий, который используется для группировки однотипных действий:

  • проверки, указаны ли требуемые сотрудники в форме Сделка,
  • автоматической записи пользователей в пустые поля из переменных Менеджер по продажам (*), и.т.д.
Таким образом он позволяет автоматизировать заполнение формы

Этап 1 - Менеджер по продажам

Этап проходит по алгоритму:
  1. Проверяется заполнение требуемых от менеджера по продажам полей:
    • Если поле окажется пустым, то значение специальной переменной Флаг "Поля пусты" будет изменено на Да. Переходим к п. 2 алгоритма.
    • Если поля окажутся заполнены, то значение переменной Флаг "Поля пусты" будет сброшено на Нет и процесс перейдет на следующий этап.
  2. Сначала значение переменной Флаг "Поля пусты" будет сброшено на Нет, а затем Менеджеру по продажам будет выставлено задание, в котором от него потребуется заполнить эти поля. После чего будет произведен переход на начало этапа (п. 1).

Этап 2 - Менеджер по закупкам

На этом этапе менеджеру будет выставляться задание по заполнению требуемых полей (согласно ТЗ). Для этого используется действие Запрос дополнительной информации и дополнительные поля (переменные) в этом действии. Значения этих переменных будут сохранены в поля Сделки.

Менеджер по продажам будет уведомлен через модуль Веб-Мессенджер о том, что поля заполнены. В сообщении будут указаны значения этих полей, ссылки на Поставщика и приложенные файлы.

Рассмотрим эти ссылки поподробнее

  • Для автоматического формирования ссылки на карточку просмотра сделки будет использоваться следующее выражение

    [url]{=Variable:domain_printable}/crm/deal/show/{=Document:ID}/[/url]

    где {=Variable:domain_printable} будет являться значением переменной Адрес портала (*), которая была ранее задана при создании шаблона бизнес-процесса, а {=Document:ID} - Идентификатор сделки, который входит в стандартный набор полей сделки.

  • Для автоматического формирования ссылки на карточку просмотра поставщика будет использоваться следующее выражение

    [url]{=Variable:domain_printable}/crm/company/show/{=Document:UF_CRM_1369312906}/[/url]

    где {=Document:UF_CRM_1369312906} будет являться значением поля Поставщик (название).

  • Для автоматического формирования ссылки на файл из поля сделки Счет от поставщика будет использоваться следующее выражение

    [url]{=Variable:domain_printable}/bitrix/components/bitrix/crm.deal.show/show_file.php?ownerId={=Document:ID}&fieldName=UF_CRM_1369315496&fileId={=Document:UF_CRM_1369315496}/[/url]

    где {=Document:UF_CRM_1369315496} будет являться значением поля Счет от поставщика (файл). Также идентификатор этого поля используется для параметра &fieldName=UF_CRM_1369315496 ссылки.

Этап 3 - Менеджер по продажам

Действия аналогичны действиям предыдущего этапа, с той разницей, что задается другой сотрудник и поля для заполнения.

Этап 3а - Комментарий относительно сроков доставки

На этом этапе сверяются сроки поставки. Если срок поставки до клиента равен или больше срока поставки до поставщика +5 дней, то процесс продолжается, иначе менеджеру по продажам выставляется задание (Ознакомление с документом), в котором он должен будет оставить комментарий по поводу сроков поставки. После чего его комментарий будет записан в сделку.

Проверка осуществляется следующим образом

Если значение поля документа Срок поставки до клиента не меньше чем вычисленное выражение =Dateadd({=Document:UF_CRM_1369314998}, "5d") (где {=Document:UF_CRM_1369314998} - поле сделки Срок поставки от поставщика), то никаких действий выполняться не будет. Во всех остальных случаях менеджеру по продажам будет выставлено задание.

Этап 4 - Этап 8

Действия аналогичны действиям 3-го этапа, с той разницей, что задается другой сотрудник и поля для заполнения.


Добавление информации в инфоблок из бизнес-процесса
437 / 694

Как добавить информацию из Бизнес-процесса

Рассмотрим пример, в котором значения из пользовательских полей списка с помощью бизнес-процесса будут записываться в пользовательские свойства инфоблока.

После заполнения полей списка Название, Строка и Файл (несколько файлов) и последующего сохранения, необходимо создать новый элемент в нужном инфоблоке. В пользовательские свойства этого элемента вносятся значения, указанных выше, полей списка. Название этого элемента будет соответствовать названию создаваемого элемента списка.

  • Для начала создадим в списке дополнительные поля:

    Значения из этих полей с помощью бизнес-процесса будут записываться в пользовательские свойства инфоблока.

    Для поля Идентификатор инфоблока зададим значение по умолчанию , чтоб каждый раз не заполнять его при создании нового элемента списка. В примере это будет инфоблок с идентификатором =1. Это поле создано лишь для наглядности .

  • Перейдем к инфоблоку. На странице настроек инфоблока, закладка Свойства (Контент > Инфоблоки > Типы инфоблоков > требуемый_инфоблок), создадим новые пользовательские свойства, в которые у нас и будут записываться значения из полей списка.

Перейдем к самому бизнес-процессу. Создадим шаблон последовательного бизнес-процесса.

  • Создадим 2 переменные , которые будут использоваться в отладочных целях:

    • ELEMENT_ID - переменная бизнес процесса, в которую будет записан ИД созданного элемента инфоблока в случае удачи,
    • ERROR - переменная бизнес процесса, в которую будет записан текст ошибки в случае неудачи создания элемента инфоблока.

  • Возьмем код из примера АПИ-вызова CIBlockElement::Add

    Исходный код

    <?
$el = new CIBlockElement;

$PROP = array();
$PROP[12] = "Белый";  // свойству с кодом 12 присваиваем значение "Белый"
$PROP[3] = 38;        // свойству с кодом 3 присваиваем значение 38

$arLoadProductArray = Array(
  "MODIFIED_BY"    => $USER->GetID(), // элемент изменен текущим пользователем
  "IBLOCK_SECTION_ID" => false,          // элемент лежит в корне раздела
  "IBLOCK_ID"      => 18,
  "PROPERTY_VALUES"=> $PROP,
  "NAME"           => "Элемент",
  "ACTIVE"         => "Y",            // активен
  "PREVIEW_TEXT"   => "текст для списка элементов",
  "DETAIL_TEXT"    => "текст для детального просмотра",
  "DETAIL_PICTURE" => CFile::MakeFileArray($_SERVER["DOCUMENT_ROOT"]."/image.gif")
  );

if($PRODUCT_ID = $el->Add($arLoadProductArray))
  echo "New ID: ".$PRODUCT_ID;
else
  echo "Error: ".$el->LAST_ERROR;
?>

    и модифицируем его:

    <?
CModule::IncludeModule("iblock"); //подключаем модуль инфоблоков

$el = new CIBlockElement;

$PROP = array();
$PROP[IB_CUSTOM_PROPERTY] = {=Document:PROPERTY_117};
// задаем для свойства инфоблока "IB_CUSTOM_PROPERTY" типа "строка" значение из поля документа "PROPERTY_117"

$files = explode(', ',"{=Document:PROPERTY_118}");
foreach($files as $key=>$value)
 {
  $PROP[IB_FILE_PROPERTY]['n'.$key]=array('VALUE'=> CFile::MakeFileArray($value), 'DESCRIPTION' => '');
 }
// задаем для свойства инфоблока "IB_FILE_PROPERTY" типа "файл" (множественное) значение из поля документа "PROPERTY_118"

$arLoadProductArray = Array(
  "IBLOCK_ID" = >{=Document:PROPERTY_119},
// задаем  Идентификатор инфоблока, в котором будет создан элемент, из поля документа "PROPERTY_119" типа "строка"
  "NAME" => {=Document:NAME},
// задаем Название создаваемого элемента инфоблока из поля документа "Название"
 "PROPERTY_VALUES"	=> $PROP,
);

$ELEMENT_ID = $el->Add($arLoadProductArray);

if($ELEMENT_ID > 0)
 $this->SetVariable('ELEMENT_ID', $ELEMENT_ID);
// задаем для переменной бизнес-процесса "ELEMENT_ID" значение, содержащее номер созданного элемента инфоблока, в случае, если он будет создан
else
 $this->SetVariable('ERROR', $el->LAST_ERROR);
// задаем для переменной бизнес-процесса "ERROR" значение, содержащее текст ошибки, в случае, если  элемент инфоблока не будет создан
?>

    Этот код будет, с помощью АПИ-методов, создавать новый элемент инфоблока, в котором пользовательские свойства IB_CUSTOM_PROPERTY, IB_FILE_PROPERTY, а также название элемента инфоблока будут содержать значения пользовательских полей PROPERTY_117, PROPERTY_118, PROPERTY_119 и значение поля название элемента списка.

    После чего добавим в шаблон действие PHP-код, в котором укажем наш измененный код.

  • Добавим в шаблон действие Запись в отчет, в котором укажем следующий текст:
    {=Variable:ELEMENT_ID_printable}, {=Variable:ERROR_printable}

    Этим самым мы запишем в отчет по выполнению бизнес-процесса значение отладочных переменных для анализа в случае ошибок.

Документация по теме:

  • Действие "PHP код"
  • АПИ-метод "CIBlockElement::Add"
  • Произвольный PHP код в бизнес-процессе


Пример бизнес-процесса для подачи заявки на отпуск
438 / 694

В данном уроке рассмотрен пример создания сервиса по работе с заявками на отпуск, который основан на базе Универсальных списков.

Краткий алгоритм работы

После того как сотрудник заполнит данные заявки, она автоматически направляется на утверждение его начальнику.

Если начальником является директор компании, то заявка утверждается или отклоняется им. Если же начальником не является директор компании, то сначала заявка будет утверждаться непосредственным начальником сотрудника, а затем и директором компании.

В процессе утверждения бухгалтеру, директору и начальнику высылаются оповещения с указанием информации касательно заявки на отпуск (используются данные из полей самой заявки).

После утверждения/отклонения заявки для соответствующей переменной устанавливается/не устанавливается нужное значение, на основе которого потом будут произведены действия по оповещению требуемых сотрудников, установке соответствующих статусов для заявки и записи в график отсутствия.

Примечание: Процесс подразумевает, что в компании используется структура с несколькими уровнями начальства и одним главным директором.

Шаблон для ознакомления: Скачать

Настройка списка

Необходимо создать следующие поля списка:

  • Номер - типа Счетчик;
  • С - типа Дата/Время (обязательное);
  • По - типа Дата/Время (обязательное);
  • Тип отпуска - типа Список (обязательное), со значениями: Очередной, За свой счет, Учебный;
  • Доп.инф. - типа Название (обязательное). Данное поле создано потому, что тип Название обязательный и удалить его невозможно.

    Значение по умолчанию: нет.

Используемые переменные

  • Автор (applicant) типа Пользователь - используется для указания автора заявки на отпуск;

    Значение по умолчанию: Автор.
  • Начальник (deptchief) типа Пользователь - используется для хранения начальника, который будет выбран для автора в ходе выполнения бизнес-процесса;
  • Директор (ceo) типа Пользователь - используется для указания директора компании;

    Значение по умолчанию: указывается_соответствующий_сотрудник_компании.
  • Бухгалтер (accountant) типа Пользователь - используется для указания бухгалтера компании;

    Значение по умолчанию: указывается_соответствующий_сотрудник_компании.
  • Утверждено? (approved) типа Да/Нет - используется в качестве флага, отображающего статус заявки. На его основе производится выбор дальних действий над заявкой после ее утверждения;

    Значение по умолчанию: Нет.
  • Кем отклонено (rejectedby) типа Пользователь - используется для хранения пользователя, отклонившего заявку на отпуск;
  • Ссылка (link) типа Строка - используется формирования ссылки для перехода к просмотру заявки на отпуск. Эта ссылка будет использоваться в тексте оповещения сотрудников, участвующих в процессе.

    Значение по умолчанию: http://адрес_портала/company/personal/bizproc/.

Настройка шаблона

  • Необходимо проставить свои поля (взамен тех, что будут после импорта шаблона) во всех действиях шаблона (через форму Вставка значения);

    Также замену полей необходимо произвести и в тексте сообщений:

  • Необходимо задать для переменных Директор, Бухгалтер и Ссылка свои Значения по умолчанию.

Общая схема работы бизнес-процесса

  • Первым делом идет действие по выбору начальника для автора.

    В случае если непосредственный начальник отсутствует, то будет выбран вышестоящий начальник, для этого в параметрах действия для опции пропускать отсутствующих выбрано значение да.

  • Следующее действие (Роли) производит запись в переменные следующих пользователей:
    • Автор - сотрудник, который создал заявку на отпуск. Указывается с помощью выражения {=Document:CREATED_BY};
    • Начальник - сотрудник, который был выбран предыдущим действием (выбор начальника). Указывается с помощью формы Вставка значения (Дополнительные результаты - Выбор начальника - Выбранный начальник).

  • Далее следует действие по установке прав. В нем для основных сотрудников разрешается доступ на чтение к заявке на отпуск.

  • Следующим идет условие (Выбранный начальник?), по которому, в зависимости от того, какой именно начальник был выбран (действие выбор начальника), будут выполняться различные ветви последовательности действий.

    • Выполнение первой ветки условия происходит, если значение переменной Начальник равно значению переменной Директор.

      Далее Бухгалтеру и Директору будут отправлены уведомления, после чего заявка будет отправлена на рассмотрение Директору.

      В случае одобрения заявки значение переменной Утверждено? будет установлено на да.

      В противном случае в качестве значения переменной Кем отклонено будет установлен сотрудник, отклонивший заявку - Директор.

    • Если условие 1-й ветки не будет выполнено, то тогда будет произведен переход к проверке условия 2-й ветки. Ее выполнение происходит, если значение переменной Начальник равно сотруднику, который был выбран действием выбор начальника.

      Таким образом, происходит проверка, что переменная Начальник не пуста и не равна Директору.

      Далее Начальнику будут отправлены уведомления, после чего заявка будет отправлена ему на рассмотрение.

      В случае отклонения в качестве значения переменной Кем отклонено будет установлен сотрудник, отклонивший заявку - Начальник.

      В случае одобрения заявки будет выполнено последующее ее согласование с директором, аналогично 1-й ветки условия.

    • 3-я ветка условия будет выполняться в последнюю очередь, при условии, что переменная Начальник будет пуста.

      В этом случае Бухгалтеру и Директору будут отправлены уведомления, после чего заявка будет отправлена на рассмотрение Директору.

  • Следующей конструкцией будет опять условие.

    В этот раз выбор ветки с действиями будет производиться в зависимости от значения переменной Утверждено?, которое по умолчанию равно нет, но может быть изменено на да в ходе выполнения предыдущего условия.

    • В случае если значение переменной Утверждено? равно да, то тогда Бухгалтеру, Начальнику и Автору будут отправлены сообщения, оповещающие о том, что заявка на отпуск была одобрена.

      Затем заявка будет опубликована в списке заявок со статусом "одобрена".

      После в график отсутствия будет занесена соответствующая запись и установлен соответствующий статус для заявки, на чем и завершится процесс.

    • В случае если значение переменной Утверждено? равно нет, то тогда Начальнику и Автору будут отправлены сообщения, оповещающие о том, что заявка на отпуск была отклонена.

      После чего будет установлен соответствующий статус для заявки, на чем и завершится процесс.


Примеры использования бизнес-процессов совместно с другим функционалом системы (ссылки)
439 / 694

Ссылки на статьи в других курсах, где описываются примеры совместного использования бизнес-процессов и другого функционала системы.

  • Использование бизнес-процессов в разделе KPI для отдела организации курса Пользователь КП.
  • Сценарий для работы службы техподдержки из курса Администратор сервиса Битрикс24 (коробочная версия).

    Клиенты заполняют форму на сайте, в которой указывают свои данные и выбирают причину обращения. Данная информация, путем настроенной интеграции, передается в CRM в виде лида, к которому автоматически привязывается задача под ответственность соответствующего задаче специалиста.

  • Автоматизация исполнения проекта.

    Использование бизнес-процессов для работы над проектом после закрытия сделки.

  • Сценарий автоматизации контроля оказания услуг.


Веб-кластер
440 / 694

Модуль Веб-кластер - это комбинация технологических решений, которые позволяют распределить один сайт на несколько серверов, решая тем самым несколько задач:

  • обеспечение высокой доступности сайта;
  • его масштабирование в условиях возрастающей нагрузки;
  • балансирование нагрузки, трафика, данных между несколькими серверами.


Что может Веб-кластер
441 / 694

Цели и задачи

Модуль Веб-кластер - это комбинация технологических решений, которые позволяют распределить один сайт на несколько серверов, решая тем самым несколько задач:

  • обеспечение высокой доступности сайта;
  • его масштабирование в условиях возрастающей нагрузки;
  • балансирование нагрузки, трафика, данных между несколькими серверами.

Работа Веб-кластера поддерживается на уровне самой платформы «1С-Битрикс», поэтому вносить какие-либо изменения в код существующих и новых проектов не потребуется. Для настройки веб-кластера может потребоваться начальная квалификация в области системного администрирования.

Модуль Веб-кластер позволяет использовать:

  • Вертикальный шардинг (вынесение отдельных частей базы данных (модулей) на отдельные серверы MySQL, например, "Поиск" и "Веб-аналитика");
  • Репликацию MySQL и балансирование нагрузки между серверами;
  • Распределенный кеш данных (memcached);
  • Непрерывность сессий между веб-серверами (хранение сессий в базе данных);
  • Кластеризацию веб-сервера:
    • Синхронизация файлов;
    • Балансирование нагрузки между серверами.

Внимание! Если серверы СУБД кластера расположены в разных дата-центрах, необходимо настроить на них единую временную зону.

Модуль "Веб-кластер" решает несколько очень важных практических бизнес-задач.

  • Масштабирование веб-проекта, повышение производительности;
  • Резервирование всех узлов системы, обеспечение отказоустойчивости и непрерывной доступности;
  • Real-time backup;
  • Снижение стоимости трафика, простая система CDN;

Масштабирование веб-проекта, повышение производительности

Рост популярности и посещаемости веб проекта требует увеличения ресурсов (CPU, памяти, дискового пространства). До определенного порога задача решается просто. С виртуального хостинга сайт переносится на VPS, затем - на свой выделенный сервер, затем - на более мощный сервер. При этом каждый новый перенос сайта на новые ресурсы сопровождается временной недоступностью сайта в период переезда. Но рано или поздно ресурсов оказывается недостаточно.

"1С-Битрикс: Веб-кластер" гибко, в реальном времени, масштабирует именно те ресурсы (база данных или веб-сервер), которые востребованы в настоящий момент. Просто добавляя/отключая новые машины по мере необходимости.

Ключевые особенности технологии:

  • каждая машина ("нода") в кластере может быть разной сущности: виртуальный хост, VPS, выделенный сервер, инстанс в "облаке" (например, Amazon EC2);
  • ноды могут быть распределены любым удобным образом - вплоть до нахождения в разных датацентрах;
  • добавление нод различной мощности в среднем дает пропорциональный прирост производительности.

Пример: если ваш сайт работает на выделенном сервере с одним процессором Intel Quad Core, 4 Гб RAM и в пиках посещаемости может обрабатывать до 40 запросов в секунду, то добавление второго такого же сервера в веб-кластер повышает производительность примерно на 90-95% и позволяет обрабатывать в пиках до 77 запросов в секунду.

Подобный подход позволяет последовательно по мере необходимости наращивать ресурсы для проекта.

Резервирование всех узлов системы, обеспечение отказоустойчивости и непрерывной доступности

Выход из строя оборудования или авария в датацентре может привести к многочасовой недоступности сайта. А это чревато последствиями:

  • потерянные заказы (в случае интернет-магазине);
  • впустую потраченные деньги на рекламу;
  • потеря репутации;
  • потеря позиций в выдаче поисковых систем в случае переиндексации поисковым роботом в момент недоступности сайта.

Кластеризация всех составляющих сайта (веб-сервер и база данных) с помощью "1С-Битрикс: Веб-кластер" минимизирует время простоя системы. В зависимости от того, как именно реализована балансировка нагрузки между нодами кластера, время недоступности сайта может составить 5-15 минут, а в отдельных случаях и вовсе может быть сведено к нулю.

Как это работает: при аварии на отдельных нодах вышедшие из строя узлы кластера помечаются неактивными (OFFLINE), а нагрузка на систему автоматически распределяется между оставшимися узлами.

В пиках нагрузки может пропорционально возрасти время отдачи страниц сайта посетителям, но работоспособность не будет нарушена. В штатном же режиме работы при наличии достаточного резерва производительности клиенты вообще не заметят каких-либо изменений.

После устранения причин аварии вновь вводятся в работу вышедшие из строя ноды, тем самым распределив нагрузку между большим числом серверов.

Real-time backup

Крайне важный аспект создания резервных копий – частота их обновлений. Если бэкапы создаются не очень часто, например, раз в неделю (а для больших проектов, это, к сожалению, не редкость), то в случае аварии есть риск потерять все изменения (код разработчиков, данные самого сайта, пользовательские данные) вплоть до семи дней.

"1С-Битрикс: Веб-кластер" подключает одну из нод в качестве бэкап-сервера. Это может быть не очень дорогой сервер или, например, VPS. В настройках веб-кластера отмечается, что данная нода используется только для бэкапа, и она не участвует в распределении нагрузки от посещений сайта. При этом данные сайта (и файлы, и база данных) дублируются в реальном времени. В случае аварии будут восстановлены актуальные данные на момент сбоя. Для максимально быстрого восстановления обращения к сайту могут быть переключены непосредственно на резервный бэкап-сервер.

Снижение стоимости трафика, простая система CDN

Перед владельцами сайтов с "тяжелым" контентом (аудио, видео, фото) стоит серьезная задача: минимизировать стоимость трафика проекта в сочетании с обеспечением высокой скорости доступа для всех посетителей независимо от территориального распределения.

Ноды веб-кластера размещают в разных датацентрах (например, три сервера: в США, в Европе и в России). Дополнительные инструменты (например, базы GeoIP) автоматически определяют регион посетителя сайта и перенаправляют его запрос на соответствующую ноду кластера. (Подобный механизм, регулирующий загрузку контента в зависимости от географического положения клиента, называется CDN - Content Delivery Network).

Документация по теме:

  • Пользовательская документация по модулю "Веб-кластер"
  • Веб кластер: выносим таблицы своего модуля в отдельную базу данных (Блог)
  • Веб-кластер в "облаке" Scalaxy за 1 час (Блог)


Настройки модуля и группы серверов
442 / 694

Настройки - проще некуда

Форма настроек модуля имеет единственную настройку:

Максимально возможное время отставания slave базы данных от master (сек.) - время отставания slave базы данных от master, после которого она будет автоматически отключена для снижения риска рассинхрониизации данных.

Отставание slave базы данных возможно при большом количестве обновлений основной (master) базы данных, недостаточно быстром соединении между master и slave базами данных, недостаточной производительности slave базы данных.

Примечание: Время отставания базы данных отображается в таблице на странице Репликация .

Группирование серверов

Группы - сущность созданная только для удобства работы. Они используются для объединения "узлов" в рамках гео-кластера. Это позволяет расположить в различных географически расположенных дата-центрах собственные: Cервера баз данных, Memcached-сервера, Веб-сервера.

Создание групп происходит на странице Настройки > Веб-кластер > Группы серверов. Создание группы - это просто задать ей название.

Важно! Для каждого веб-сервера одной группы в файле dbconn.php должна быть определена переменная BX_CLUSTER_GROUP, значение которой соответствует идентификатору группы. Например: define("BX_CLUSTER_GROUP", 1).

Название второй группы может быть "Группа #2", но в переменной BX_CLUSTER_GROUP необходимо указать реальный (автоинкрементный) идентификатор этой группы, который можно посмотреть на странице со списком групп серверов (Настройки > Веб-кластер > Группы серверов).

Файл dbconn.php не должен синхронизироваться между группами.

Документация по теме:

  • Настройки модуля


Репликация
443 / 694

Репликация базы данных - это процесс создания и поддержания в актуальном состоянии её копии.

Репликация позволяет:

  • перенести часть нагрузки с основной базы данных (master) на одну или несколько ее копий (slave);
  • использовать копии в качестве горячего резерва.
  • использовать несколько географически разнесенных основных баз данных (master-master репликация).


Master-Slave репликация
444 / 694

Настройка и подключение резервной базы данных для снятия нагрузки с основной БД

Подключение к сайту дополнительных серверов баз данных позволяет снизить нагрузку на основную базу данных. В этом случае чтение данных происходит из дополнительных (slave) баз данных, а запись - в основную.

Подключение

Подключение и настройка дополнительных (slave) баз данных осуществляется на странице Slave базы данных (Настройки > Веб-кластер > Группа #1 > Репликация).

Внимание! При использовании нескольких веб-серверов в файле \bitrix\php_interface\dbconn.php на всех серверах обязательно должен быть указан адрес подключения к главной базе данных (master). Желательно указывать прямой IP-адрес или быть уверенным, что для каждого веб-сервера будет происходить соединение именно с сервером главной базы данных в случае обращения не по IP-адресу. Использование адреса вида localhost при такой конфигурации запрещено.

Для репликации необходимо использовать разные серверы с быстрым каналом связи между собой.

В настройках модуля Веб-кластер можно указать время отставания slave базы данных от master, после которого она будет автоматически отключена для снижения риска рассинхрониизации данных.

Примечание: Для работы репликации учетные записи основного и резервных master/slave-серверов должны иметь, кроме стандартных, также привилегии: SUPER, REPLICATION CLIENT, REPLICATION SLAVE.

Учетные записи
Их три, но для простоты администрирования рекомендуется объединить в одну.
  1. Учетная запись для работы приложения с базой данных (БД) для всех нод кластера (определяемая в dbconn.php).
    GRANT SELECT,LOCK TABLES,CREATE TEMPORARY TABLES,INSERT,UPDATE,DELETE,CREATE,DROP,ALTER,INDEX, REPLICATION CLIENT, RELOAD ON bitrixcluster.* TO 'bitrixcluster'@'%' IDENTIFIED BY '123456';

    REPLICATION CLIENT - для отображения статистики мастера.

    RELOAD- используется в master-БД во время переноса таблиц в slave-БД для "FLUSH TABLES WITH READ LOCK".

    Под этой же учетной записью (именно логин/пароль) при добавлении slave-базы через административный интерфейс система пытается запустить потоки слейва (CHANGE MASTER TO #логин/пароль учетной записи в master-БД#), поэтому ей также нужны привилегии: REPLICATION SLAVE.

  2. Учетная запись для управления slave-нодами из административного интерфейса веб-кластера. Создается в каждой slave-БД и указывается при подключении слейва в административном интерфейсе веб-кластера.

    GRANT REPLICATION CLIENT on *.* TO 'bitrixcluster_slave'@'%' IDENTIFIED BY '123456'; - нужна для отображения статистики слейва в административном интерфейсе.

    GRANT SUPER on *.* TO 'bitrixcluster_slave'@'%'; - нужна для отображения запуска/остановки слейва и изменения параметров репликации из административного интерфейса слейвов веб-кластера.

    GRANT SELECT,LOCK TABLES,CREATE TEMPORARY TABLES,INSERT,UPDATE,DELETE,CREATE,DROP,ALTER,INDEX ON bitrixcluster.* TO 'bitrixcluster_slave'@'%' IDENTIFIED BY '123456'; - нужна для первоначального экспорта в БД слейва данных из БД мастера.

  3. Учетная запись для загрузки бинлогов в slave-БД с master-БД (для собственно организации процесса репликации). Создается на master-БД для каждого подключения slave-БД (можно использовать одну учетную запись для всех слейвов).

    GRANT REPLICATION SLAVE on *.* TO 'bitrixcluster_replica'@'%';

  • Нажмите кнопку Добавить slave базу данных. После чего откроется окно мастера добавления новой slave базы данных.
  • В первом окне будут выведены рекомендации по настройке системы , критичные для работы. Обязательно исправьте их, пока проверка не покажет, что всё в порядке .
  • Пройдите все шаги мастера .

После прохождения мастера база появится в списке, но будет не задействована:

Мастер добавления новой slave базы данных

В списке slave баз данных в меню действий выполните команду Начать использовать и следуйте рекомендациям мастера.

Внимание! Запуск репликации начинается с копирования содержимого базы данных. На время копирования публичная часть сайта будет закрыта , а административная нет. Любые неучтенные модификации данных в период копирования могут в дальнейшем повлиять на правильность работы сайта.

После успешного подключения slave-сервера баз данных отображается его статус .

Настройка параметров базы данных

При необходимости измените настройки подключения базы. Для этого дважды кликните по желаемой базе в списке или воспользуйтесь пунктом меню действий Изменить. Откроется форма Настройка параметров главной базы/slave базы данных:

Настройка параметров slave базы данных

Значение в поле Процент распределения нагрузки (0..100) указывается для каждой базы в отдельности. Эта опция перераспределяет большую часть нагрузки на более быстрые и мощные серверы в составе кластера.

Примечание: Для главной базы существует отдельная опция, которая позволяет Минимизировать нагрузку на нее.

Особенности обращений к master базе

Если на хите в системе происходит запись в master базу, то последующие операции чтения (запросы) данных будут тоже происходить из master базы, а не slave.

Это связано с особенностью кластерной архитектуры: только так можно быть уверенным в том, что при запросе этих данных они будут актуальны, т.к. синхронизация со слейвами всегда имеет определенное отставание (данных там просто может еще и не быть).

Примечание для разработчиков: Собственные запросы на запись в системе (пример - веб аналитика) обрамлены специальными методами класса CDatabase: StartUsingMasterOnly и StopUsingMasterOnly. Которые соответственно начинают и заканчивают использование только мастер базы.

Вы можете обернуть свои АПИ вызовы на запись такими конструкциями, но должны быть уверены, что дальше по коду не будет чтения этих данных из базы.

Дополнительно

  • Урок Настройка репликации MySQL, аварийное переключение slave->master - пример тонкой настройки реплицации.


Резервная копия
445 / 694

Настройка базы данных для использования в качестве резервной копии

В данном случае slave база данных будет использоваться только для создания копии основной базы данных. В отличие от случая, описанного выше, операций чтения из нее происходить не будет.

Для перевода базы в этот режим в форме Настройка параметров slave базы данных отметьте опцию Для резервного копирования:

Настройка параметров slave базы данных


Master-master репликация
446 / 694

Настройка master-master репликации

Настройка master-master репликации аналогична настройке master-slave репликации за исключением некоторых моментов.

Для настройки master-master репликации выполните следующее:

  1. Создайте группу на странице Управление веб-кластером (Настройки > Веб-кластер > Группы серверов)

    2. Примечание: У каждого веб-сервера одной группы в файле dbconn.php должна быть определена константа BX_CLUSTER_GROUP, значение которой соответствует идентификатору группы. Например: define("BX_CLUSTER_GROUP", 1).

    Файл dbconn.php не должен синхронизироваться между группами.

  2. На странице Репликация (Настройки > Веб-кластер > [_название_группы_] > Репликация) запустите Мастер добавления новой master-slave базы данных с помощью кнопки Добавить master-slave базу данных контекстной панели.
  3. Пройдите все шаги мастера. Если необходимо, произведите настройки, в соответствии с рекомендациями.

    Примечание: Для таблиц InnoDB необходимо также указать параметр binlog_format=mixed в секции [mysqld] файла my.cnf.

    Иначе будет возникать ошибка:
    Binary logging not possible. Message: Transaction level 'READ-COMMITTED' in InnoDB is not safe for binlog mode 'STATEMENT'

    После прохождения мастера база появится в списке, но будет не задействована.
  4. В списке баз данных в меню действий выполните команду Начать использовать и следуйте рекомендациям мастера.

После успешного подключения в списке будет отображен статус базы

Особенности работы с управляемым кэшем при master-master репликации

Если добавить во вторую группу веб-кластера второй мастер-сервер, то сброс кэша (ядра, управляемый и.т.д.) на обеих нодах не будет работать, если в обе группы не добавить memcached-серверы.


Memcached
447 / 694

Кеш в оперативной памяти

memcached сервер - сервер, позволяющий сохранять кеш не в файлах, а в оперативной памяти. memcached можно использовать и для хранения сессий.

Использование нескольких memcached-серверов:

  • повышает надежность системы за счет устойчивости подсистемы кеширования к выходу из строя отдельных компонентов,
  • повышает эффективность за счет централизованного использования кеша веб-приложением,
  • обладает неограниченной масштабируемостью за счет добавления новых memcached-серверов.

Если произошёл отказ всех memcached-серверов, то подсистема кеширования снова начинает использовать файловый кеш .

Внимание! Для работы потребуется php расширение memcache.

Некоторые версии расширения memcache имеют ошибку, приводящую к значительному снижению производительности при наличии более одного подключения. С помощью панели производительности получите оценку производительности до добавления подключения и после. При наличии значительной разницы попробуйте установить другую версию расширения memcache.

Если используется несколько memcache-серверов, нужно установить значение переменной memcache.hash_strategy string в consistent (по умолчанию это выключено!). Такое значение нужно для следующего: если один из мемкэшей сломается, начнется ресурсоемкая операция перетасовки ключей между мемкэшами, замедляющая работу веб-кластера. А если установить в consistent - проблем практически не будет.

Примечание: «1С-Битрикс: Веб-окружение» для Linux уже содержит сервер memcached. Для его запуска необходимо выполнить команды:
chkconfig memcached on
service memcached start

Подключение серверов memcached

Сервера подключают на странице Подключения к memcached (Настройки > Веб-кластер > [_название_группы_] > Memcached):

  • Нажмите кнопку Добавить на контекстной панели и в форме Настройка параметров подключения к серверу memcached укажите адрес и порт сервера.

    Примечание: Если подключаемые к кластеру memcached серверы разной мощности или с разным объемом оперативной памяти, то желательно соответственно настроить коэффициент их использования через настройку параметра Процент распределения нагрузки (0..100).

    • После подключения сервер по умолчанию не будет активным.

  • Для запуска его в работу в меню действий выберите пункт Начать использовать .

Теперь сервер используется вместо файлового кеша:

Примечание: Настройки подключения серверов memcached хранятся в файле \bitrix\modules\cluster\memcache.php. Соответственно любые изменения настроек подключения будут автоматически применены на остальные ноды кластера при настроенной файловой синхронизации в кластере.

Рекомендации по настройке

При настройке подсистемы кластерного кеширования обратите внимание на параметр: get_hits: #count# (#hitrate#%) где, #hitrate# - показывает эффективность кеширования. Это значение надо довести как можно ближе к 100%.

Экспериментально отрегулируйте эффективность, постепенно увеличивая объем памяти, выделяемой серверу memcached (limit_maxbytes). Начините с объема памяти в 128MB и увеличивайте с шагом в 32MB, пока #hitrate# перестанет заметно увеличиваться.

Также рекомендуется периодически анализировать и использование кеша приложением (параметр using_bytes).

За счет использования в сервере memcached алгоритма LRU в кеше будут храниться только наиболее актуальные данные, а редко используемые - вытесняться. Это не позволит объему кеша безгранично разрастаться в размерах, что приводило не только к неэффективному использованию ресурсов системы, но и отрицательно сказывалось на скорости работы с кешем за счет роста его объема. В результате кеш веб-кластера будет автоматически поддерживаться в максимально эффективном состоянии: как по скорости доступа, так и по использованию ресурсов.

Примечание: Константа BX_CLUSTER_GROUP должна быть установлена в файле dbconn.php. В противном случае не будет работать Композитный сайт .

Дополнительно

  • Практический пример: урок Кластеризация кеша (memcached);
  • Статья Технологии кластеризации 1С-Битрикс - эффективное кэширование в memcached.


Веб-сервера
448 / 694

Распределяем нагрузку на веб-сервера

На странице Веб-сервера (Настройки > Веб-кластер > [_название_группы_] > Веб-сервера) показаны статусы активности и текущей нагрузки веб-серверов. Страница носит информационный характер.

Для добавления веб-сервера в список:

  • Нажмите на контекстной панели кнопку Добавить новый веб-сервер;
  • Заполните поля формы:

    Редактирование параметров веб-сервера

Примечание: Настройки для "1С-Битрикс: Веб-окружение" (Linux) подробно рассмотрены в уроке Кластеризация веб-сервера

Документация по теме:

  • Веб-сервера
  • Создание и редактирование веб-сервера


Шардинг
449 / 694

Выносим работу отдельных модулей на сторонний сервер

Шардинг позволяет перераспределить нагрузку, создаваемую запросами между различными серверами, за счёт выноса данных некоторых модулей в отдельную базу данных.

Вертикальный шардинг - разделение одной базы данных веб-приложения на две и более базы данных за счет выделения отдельных модулей, без изменения логики работы веб-приложения. (Таблицы разносятся по серверам.)

Горизонтальный шардинг - распределение однотипных данных веб-приложения (например, учетных записей) между отдельными базами данных. (Таблица делится на части и части разносятся по серверам.)

В "1С-Битрикс: Управление сайтом" и "Битрикс24 в коробке" поддерживается только Вертикальный шардинг и перенос данных модулей Веб-аналитика и Поиск

Настройка шардинга

Добавление новой БД делается на странице Вертикальный шардинг (базы данных модулей) (Настройки > Веб-Кластер > Шардинг). Для вынесения таблицы с данными модуля в отдельную базу:

  • Нажмите на контекстной панели кнопку Добавить новую базу данных . После чего откроется окно мастера добавления новой базы данных модулей.
  • Пройдите все шаги мастера. Если необходимо, произведите настройки, в соответствии с рекомендациями. Вы должны получить полностью "зелёный" список .
  • Укажите параметры подключения БД и исправьте, при необходимости, параметры до получения "зелёного" списка.

    • После чего база появится в списке, но будет не задействована.

Перенос данных

Теперь перенесём данные модуля в добавленную базу данных. Это можно выполнить двумя способами:

  • Первый способ доступен только для MySQL: в списке баз данных модулей в меню действий выбранной базы данных выполнить команду Начать использовать . Запустится мастер переноса данных. В нем выберите модуль, который будет перенесен .

    Внимание! Любые модификации данных в модуле на период копирования сохранены не будут.

  • Второй способ: удалите модуль и установите его заново. На первом шаге установки укажите базу данных для использования модулем. В этом случае таблицы модуля не будут перенесены.

    Выбор базы данных для установки модуля

После переноса таблиц модуля в подключенную базу данных список будет иметь следующий вид:

Примечание: Для mssql и oracle версий вместо мастера будет отображена форма Редактирование подключения к базе данных.


Хранение сессий в базе данных
450 / 694

Если несколько веб-серверов

По умолчанию данные о сессиях пользователей хранятся в файловой системе сервера. Информация об этом есть на странице Хранение сессий в базе данных (Настройки > Веб-кластер > Сессии)

Хранение сессий в базе данных

Если веб-сервер единственный, то такой способ хранения сессий наиболее удобен. Основной его плюс - наиболее высокая производительность. Как показывают различные нагрузочные тесты, скорость генерации страниц сайта при хранении сессий в базе снижается на 3-5%.

Если веб-серверов несколько, то возможно что один запрос пользователя (например, непосредственно авторизация) попадёт на один сервер, а следующий или какие-либо другие запросы - на другие серверы, где посетитель еще не будет авторизован. Подобные ситуации доставят целый ряд неудобств для посетителей сайта. Также, в случае хранения сессий в файлах будет некорректно вестись статистика посетителей.

Пользовательская сессия должна быть "прозрачной" для всех серверов веб-кластера. Поэтому рекомендуется включить хранение сессий в базе данных. Включение механизма хранения данных сессий пользователей в базе данных выполняется с помощью кнопки Включить хранение данных сессий в БД модуля.

Внимание! При переключении режима хранения сессий все пользователи потеряют авторизацию (данные сессий будут уничтожены).

Примечание: Для снижения нагрузки на базу данных и обеспечения "прозрачности сессии", можно сессии в базе не хранить, а вместо этого настроить и использовать в nginx модуль ip_hash.


Безопасность
451 / 694

Как защитить веб-кластер

Веб-кластер использует дополнительные сервисы (централизованное кэширование, синхронизация) и запускается, как правило, на группе машин. Рассмотрим особенности обеспечения информационной безопасности веб-кластера.

Балансирование нагрузки и защита от DDoS-атак

Рекомендуется открыть для публичного доступа 80 порт балансировщика нагрузки, ограничив внешний доступ к http портам машин (нод) веб-кластера. Это надежно защитит ноды, спрятанные за балансировщиком, от перегрузки (например, возникшей при проведении рекламной интернет-кампании), а также существенно снизит эффективность DDoS-атак.

Кластеризованный кэш

Необходимо закрыть от публичного доступа серверы memcached (tcp порт 11211), открыв доступ к ним с нод веб-кластера. Одно из решений - сконфигурировать файервол.

Сервис синхронизации контента нод кластера

Если для синхронизации контента используется утилита csync2, необходимо закрыть ее сервисы от публичного доступа (tcp порт 30865), открыв доступ к ним с нод веб-кластера.

Пример настройки файервола

Для ноды веб-кластера:

  • 22 (tcp; ssh) - открыт для подсети администратора;
  • 80 (tcp; http) - открыт для подсети веб-кластера;
  • 443 (tcp; https) - открыт для подсети веб-кластера;
  • 3306 (tcp; mysql) - открыт для подсети веб-кластера;
  • 11211 (tcp; memcached) - открыт для подсети веб-кластера;
  • 30865 (tcp; csync2) - открыт для подсети веб-кластера.

Для балансировщика нагрузки:

  • 80 (tcp; http) - открыт для всех;
  • 443 (tcp; https) - открыт для всех.


Локальный кеш в кластере
452 / 694

Ускоряем работу с кешем

Использование подключения через unix soket к локальным memcache серверам, ускоряет работу проекта. Ядро обеспечивает валидность кеша на всех нодах, удаляя помеченные ключи кеша на них. Такой режим работы кластера очень хорошо себя зарекомендовал в различных нагрузочных тестах и реальной эксплуатации, обеспечивая прирост порядка 30% за счет более быстрой работы с кешем.

Настройка режима работы с локальным кешем

Предположим, есть две ноды на которых настроены роли веб сервера, мемкеша и БД. В этом случае необходимо выполнить следующие шаги:

  1. Настроить memcache на использование веб сокета и модуль Веб-кластер на работу с мемкешем через сокет.
    • Для настройки memcache на работу с сокетом выполните команду:
      cat /etc/sysconfig/memcached
# Ansible managed: /etc/ansible/roles/memcached/templates/sysconfig-memcached.j2 modified on 2015-01-30 19:00:16 by root on bx24.perf
# memcached settings
PORT="11211"
USER="memcached"
MAXCONN="4096"
CACHESIZE="512"
OPTIONS="-t 8 -s /tmp/memcached.sock -a 0777"
    • Для настройки модуля Веб-кластер на работу с мемкешем через сокет указать порт 0 и урл unix:///tmp/memcached.sock
  2. В модуле кластера добавить нужное количество групп.
  3. На каждом сервере определить константы указывающие ID группы, а также включающий режим чтения слэйвов из любой группы.
    <?
define('BX_CLUSTER_GROUP', 1);
define('BX_CLUSTER_SLAVE_USE_ANY_GROUP', true);
?>
  4. Перенести слэйв сервера в административную часть БУС, по нужным группам. Для переноса слэйв серверов в нужную группу необходимо, отредактировать соответствующие записи в таблице b_cluster_dbnode, установив нужное значение в поле GROUP_ID.
  5. Для переноса серверов memcached в нужную группу, необходимо установить нужное значение ключа GROUP_ID в файле /bitrix/modules/cluster/memcache.php.

После этого сервера начнут работать с локальным кешем через сокет, что значительно быстрее чем работа с удаленными серверами по tcp.


Варианты конфигурации веб-кластера для решения практических задач
453 / 694

Выберите подходящий вариант

Прежде всего, необходимо внимательно проанализировать (спрогнозировать) характер нагрузки на веб-приложение. Для сбора и анализа данных рекомендуется проактивно использовать известные инструменты мониторинга, такие как munin, zabbix, apache server-status, и т.п.

Ниже перечислены варианты конфигурации веб-кластера для различных типов нагрузки.

Высокая нагрузка на процессоры, невысокая/средняя нагрузка на СУБД, контент меняется редко

Необходимо снизить нагрузку на процессоры - подключаем к веб-кластеру ноду(ы). Ноды заводим под балансировщик нагрузки. В результате нагрузка на процессоры распараллеливается между нодами.

Рекомендуется также на каждой ноде запустить сервер memcached - это позволит еще больше снизить нагрузку на процессоры за счет того, что кэш будет создаваться один раз на одной из нод веб-кластера, а использоваться остальными нодами.

Для синхронизации контента подойдет csync2, nfs/cifs-сервер на одной из нод веб-кластера.

Высокая растущая нагрузка на СУБД

Для разгрузки СУБД необходимо организовать master-slave репликацию. Чем больше будет добавлено slave-нод, тем сильнее снизится нагрузка на основную master базу данных. Если slave-ноды разной мощности, рекомендуется адекватно распределить между ними нагрузку с помощью параметра Процент распределения нагрузки (0..100).

В результате нагрузка на СУБД распределится между master и slave нодами веб-кластера. При дальнейшем увеличении нагрузки на СУБД рекомендуется:
  1. Оптимизировать master и slave-ноды. Т.к. master-сервер будет использоваться преимущественно для записи, его нужно, путем настройки параметров, оптимизировать для записи, а slave-ноды - оптимизировать для чтения.
  2. Добавлять slave-ноды.

Большой объем кэша, кэш часто перестраивается, контент меняется часто, изменений много

Необходимо настроить эффективную работу с кэшем. Для этого запускаем на каждой ноде сервер memcached, выделяем каждому по несколько GB памяти (в зависимости от требований приложения).

Для синхронизации контента рекомендуется использовать выделенный nfs/cifs-сервер, либо ocfs/gfs или аналоги.


Блоги
454 / 694

Блоги необходимы для ознакомления с сообщениями и комментариями сотрудников.

Настройку и управление блогами может выполнить администратор портала.


Валюты
455 / 694
Вся работа по управлению валютами ведется в модуле Валюты. Этот модуль необходим для работы модулей Торговый каталог, Интернет-магазин, используется для отчетов в CRM, необходим при работе с финансовыми параметрами в рекламных кампаниях и событиях в Веб-аналитике.


Настройки модуля Валюты
456 / 694

Что может модуль Валюты

Вся работа по управлению валютами ведется в модуле Валюты. Этот модуль необходим для работы модулей Торговый каталог, Интернет-магазин, используется для отчетов в CRM, необходим при работе с финансовыми параметрами в рекламных кампаниях и событиях в Веб-аналитике. Он позволяет:

  • управлять списком валют;
  • задавать формат представления цен в той или иной валюте ;
  • устанавливать курсы валют (с возможностью загрузки курса с сайта Центрального Банка РФ).

Настройка модуля

Нажмите на рисунок, чтобы увеличить

Настройка модуля Валюты производится на странице Настройки > Настройки продукта > Настройки модулей > Валюты. Форма позволяет установить базовую валюту и уровень доступа к модулю. Настройка доступа проводится типовым для Bitrix Framework способом .

Примечание: права доступа желательно ограничить и не давать большому числу пользователей. Лучше вообще оставить за одним администратором, так как обращение к модулю не требуется постоянно, а случайно изменить что-то можно. Так как изменения скажутся на работе каталога и интернет-магазина, то последствия могут быть серьезными.

Кроме того, на странице настроек модуля выполняются служебные процедуры по пересчету текущих курсов валют по отношению к базовой.

Документация по теме:

  • Настройки модуля


Валюты
457 / 694
Глава о том, как создать валюты, управлять списком валют и выбрать базовую валюту. Курс остальных валют рассчитывается по отношению к базовой.


Валюты: создание и управление
458 / 694

Видеоурок по управлению валютами

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Управление списком валют осуществляется на странице Валюты (Настройки > Валюты > Список валют):

Нажмите на рисунок, чтобы увеличить

Одна (только одна!) из валют выбирается в качестве базовой (для этого следует выбрать пункт Сделать базовой в меню действий валюты). Курс остальных валют рассчитывается по отношению к базовой.

Базовая валюта – валюта, которая будет использоваться в качестве базы для расчетов других валют. Например, если в качестве базовой будет выбран рубль, то весь курс будет отображен относительно рубля. Базовой будет считаться та валюта, номинал которой равен ее курсу. В качестве базовой рекомендуется выбирать рубль. В этом случае отображение курса валют будет в привычном для всех виде: за 1 денежную единицу – столько-то рублей.

Простое добавление валюты

Если для работы вам требуются валюты, не представленные в системе, то их необходимо добавить.

Нажмите на кнопку Добавить валюту на контекстной панели. Откроется форма добавления валюты:

Заполните поля на закладке Валюта:

  • Валюта – международно признанное трехбуквенное обозначение валюты;
  • Номинал – сумма, которая принимается за единицу при расчете валюты. Как правило, равняется 1;
  • Курс по умолчанию – курс, который будет использоваться при конвертации валют, если в форме Курсы валют не заданы другие значения;
  • Цифровой код – международный трехзначный цифровой код валюты;
  • Индекс сортировки – приоритет данной валюты в общем списке валют.

На закладке Языковые настройки задаются настройки для разных языков интерфейсов системы: русского, английского и т.д. Поля у этих групп настроек одинаковые:

Примечание: дополнительные языковые представления валюты появляются в форме после добавления в систему дополнительного языка интерфейса.

Заполните поля для языковых вариантов:

  • Название – полное название валюты для данного языка;
  • Шаблон формата – способ вывода текста. При выборе того или иного шаблона вывода в остальные поля языкового оформления будут подставлены значения по умолчанию. При необходимости вы можете изменить значения этих полей;
  • Строка формата для вывода валюты – заполняется в виде «# текст». Вместо «#» выводится значение из поля Шаблон. Такое представление дает возможности индивидуализировать вывод сообщения о курсе;
  • Десятичная точка при выводе и Разделитель тысяч при выводе – способы разделения частей отображения валюты;
  • Количество десятичных знаков – количество знаков в дробной части числа (указывается в зависимости от количества копеек в используемой валютной единице). Количество десятичных знаков дробной части цены влияет на отображение цен на сайте и в чеке. Все расчеты ведутся с параметрами округления, указанными в поле Точность округления при расчетах настроек модуля Интернет-магазин;
  • В публичной части не показывать незначащие нули в дробной части цены – в случае, если галочка выставлена, прежняя цена в 1637.00 будет показана как 1637.


Создание валют через классификатор
459 / 694

Создание валют через классификатор

Создать валюту можно через Классификатор валют. Это намного удобнее, чем ручное добавление, так как создание валюты сводится всего к нескольким кликам. При создании валюты надо указывать цифровой и символьные коды в соответствии с ISO 4217, а значит надо искать ссылку на этот стандарт, искать в стандарте данные по создаваемой валюте. Это долго. Классификатор валют сделает эту работу за вас.

Для создания валюты воспользуйтесь кнопкой Добавить из классификатора на странице Списки валют, откроется форма создания:

В поле Поиск валюты начните набирать название нужной вам валюты и классификатор в окне ниже будет выводить названия.

После выбора нужной валюты классификатор сам подставит все нужные значения и в Основных настройках валюты и в Языковых настройках. Вам останется только узнать курс создаваемой валюты по отношению к базовой и ввести этот курс в поле Курс обмена (по умолч.) и нажать на Сохранить.


Курсы валют: создание курса
460 / 694

Курсы валют

Для управления курсами валют служит страница Курсы валют (Настройки > Валюты > Курсы валют). Можно устанавливать курсы для валют, установленных в разделе Список валют.

При конвертации валют на текущую дату система берет самый новый из курсов. Если курс не найден, то берется курс по умолчанию (курс, заданный в настройках валюты).

Создание курса валют

Для создания курса валюты на текущую дату нажмите на кнопку Создать курс валют на контекстной панели. Откроется форма создания курса валют:

  1. В поле Дата выберите дату, на которую нужно сохранить курс;
  2. В поле Валюта в выпадающем окне выберите валюту, курс которой необходимо сохранить;
  3. Нажмите кнопку Запросить. Система запросит курс валют на выбранную дату с нужного сайта (см. примечание ниже) и выведет значения в полях Номинал и Курс;

    Примечание: для получения курса валюты необходимо, чтобы краткий символьный идентификатор валюты был корректным (пример: если указать краткий символьный идентификатор валюты, допустим, UJD вместо USD, то получить курс автоматически не получится).

    Важно! Запрос курса валют может быть выполнен, если в системе в качестве базовой используется одна из следующих валют:
    • российский рубль - запрос выполняется с сайта Центрального банка РФ;
    • гривна - запрос с сайта Национального банка Украины;
    • белорусский рубль - запрос с сайта Национального банка Республики Беларусь.

  4. Сохраните внесенные изменения. Откроется форма отчета со списком сохраненных курсов, в которой добавится новый сохраненный курс.

Документация по теме:

  • Курсы валют


Информер курса валют
461 / 694

Информер курса валют

Работа модуля Валюты внешне не видна: к нему обращаются модули Торговый каталог и Интернет-магазин в своей работе. Но есть один внешне отображаемый компонент, который позволяет «увидеть» присутствие модуля на сайте. Это – информер курса валют.

Рассмотрим размещение информера курса валют на сайте.

Откройте нужную страницу в режиме визуального редактора и поместите на рабочую область компонент Таблица курсов валют (Контент > Валюты). Вызовите окно настроек параметров компонента:

  • В поле Массив "исходных" валют для перевода выберите валюты, данные которых должны отражаться на информере;
  • В поле Валюта, к которой приводятся "исходные" валюты укажите базовую валюту;
  • В поле День, на который показывать курсы валют укажите дату курса, с которого будут браться параметры;
  • Показывать курс валют с ЦБ РФ - отметьте данную опцию, если хотите указать курс ЦБ России.

Сохраните внесенные изменения и таблица отобразится на странице:

Документация по теме:

  • Описание компонента


Пример работы с валютами
462 / 694

Пример работы с валютами

Пусть имеется каталог продукции с товарными позициями, у которых цены представлены не только рублями, но и долларами и фунтами стерлингов. Перед нами поставлена следующая задача:

  • корректно отображать цены данных товарных позиций в списке товаров;
  • для пользователей вывести информацию по курсам валют на сайте;
  • а при заказе данных товарных позиций конвертировать цену в рубли по курсу ЦБ РФ.

Для начала нужно создать требуемые валюты, а также настроить шаблоны их отображения на сайте. В дистрибутиве «1С-Битрикс: Управление сайтом» по умолчанию уже настроена одна валюта: рубли. Она же и является базовой валютой.

Создайте валюты USD и GBP (фунты стерлингов). Для примера приведем образец заполнения формы . Должен получиться такой список:

Далее нам нужно настроить курсы данных валют. Переходим в раздел Курсы валют (Настройки > Валюты > Курсы валют). И создаем курсы для двух валют (USD и GBP) по отношению к базовой валюте RUB.

Теперь перейдя на карточку товара в каталоге товаров, можно указать цену в валютах которые мы создали, выбрав необходимое значение из выпадающего списка:

Создадим 3 товара в каталоге товаров с ценами в разных валютах. В итоге на странице каталога в публичной части, при переходе в раздел с созданными нами товарами, мы сможем наблюдать 3 товара с ценами в разных валютах:

Дополнительно, вне темы примера: Перед выводом товаров разместим компонент Таблица курсов валют (bitrix:currency.rates), таким образом, пользователь сможет видеть курсы, по которым будет произведена конвертация валют в рубли. В настройках компонента выберите из списка валюты, которые необходимо выводить, а также валюту по отношению к которой будет пересчитываться курс (в данном случае это RUB).

Теперь закажем эти платья и перейдём в корзину:

Нажмите на рисунок, чтобы увеличить

Цены платьев автоматически перевелись в рубли по курсу, который мы установили.


Как изменить валюту в публичной части магазина
463 / 694

Как изменить валюту в публичной части магазина

Допустим, на нашем сайте базовая валюта - рубли. Однако в публичной части нужно выводить цены в другой валюте (например, в польских злотых). Рассмотрим подробно по шагам, как это сделать:

  1. Сначала добавим нужную валюту (Настройки > Валюты > Список валют) одним из двух способов:
    • либо облегченным способом с помощью классификатора валют;
    • либо обычным способом.
  2. Далее в настройках модуля Интернет-магазин (Настройки > Настройки продукта > Настройки модулей > Интернет-магазин) во вкладке Права на заказы выберем нужную валюту (валюту оплаты товара):

    Примечание: Выполненные на этом шаге настройки подтягиваются в компоненты Корзина и Оформление заказа (т.е. в корзине пользователя и при оформлении заказа стоимость всех товаров будет уже отображаться в новой валюте, и оплаты будут произведены в этой же валюте).
  3. И, наконец, выведем цены каталога в новой валюте. Для этого в настройках компонента Каталог отметим опцию Показывать цены в одной валюте, указав нужную валюту:

Готово! Теперь и в каталоге , и в корзине , и при оформлении заказа клиент будет видеть стоимость в новой валюте, а в административном разделе цены товаров останутся в прежней валюте.


Веб-мессенджер
464 / 694

Для настройки модуля Веб-мессенджер перейдите на страницу Настройки > Настройки продукта > Настройки модулей > Веб-мессенджер

Настройки модуля Веб-мессенджер

На закладке Настройки задаются глобальные настройки параметров модуля, которые определяют:

  • сервер видеозвонков;
  • отображение истории, контактов, сообщений по умолчанию;
  • расположение панели мессенджера;
  • настройки приватности (для «1С-Битрикс: Управление сайтом»);
  • указанию для каждого сайта шаблона пути к странице пользователя для правильной работы модуля с профилем пользователя и добавлению в друзья (для «1С-Битрикс: Управление сайтом»);
  • указание формата отображения имени в списке контактов.

Внимание: Для улучшения быстродействия модуля Веб-мессенджер версии 17.0.4 и выше необходимо:
  • Обновить вашу БД MySQL до версии 5.6.
  • После этого в командной строке базы данных выполнить следующий запрос:
    CREATE fulltext index IXF_IM_MESS_1 on b_im_message

Если вы устанавливали продукт на сервер с уже установленной БД MySQL 5.6 и выше, то вам ничего делать не нужно.

Примечание: подробное описание каждого параметра приведено в пользовательской документации по модулю Веб-мессенджер.

Документация по теме:

  • Настройка модуля Push and Pull
  • Телефония
  • Настройки модуля (документация)


Веб-формы
465 / 694

Модуль Веб-формы позволяет создавать и размещать в публичном разделе портала различные формы, служащие для организации взаимодействия с сотрудниками. Это могут быть, например, формы для оформления подписки, отправки заявки на участие в семинаре и т.п. Подробно смотрите в уроке Возможности модуля.

Созданием шаблонов веб-форм и их публикацией должен заниматься администратор системы. Администратор портала может добавлять веб-формы и управлять ими.

Примеры использования модуля:

  • Система "Вопрос-ответ" на базе веб-форм


Создание шаблона веб-формы
466 / 694

Делаем свой шаблон

Если не нравится как отображается ваш шаблон в стандартном варианте , перейдите на закладку Шаблон формы в режиме редактирования веб-формы и создайте свой шаблон, выбрав пункт Использовать свой шаблон формы .

Если форма и вопросы к ней уже созданы, то вопросы сразу отобразятся в визуальном редакторе в панели Элементы формы . Если вопросы не созданы, то их можно создавать прямо в процессе создания шаблона. Создание вопросов при создании шаблона - не самый удобный способ, к тому же в этом случае доступен не весь функционал вопросов, в частности нельзя задать валидаторы. Поэтому рекомендуем вопросы создать заранее.

Видео-пример создания шаблона веб-формы

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Создание шаблона и вопросов

Создадим шаблон и вопросы формы. Для этого в рабочей области разместим элементы из разделов Дополнительные элементы формы и Новые поля формы панели Элементы формы и определим их свойства. Суть элементов ясна из их названия и дополнительных пояснений не требует.

Разместите наверху поля элемент Заголовок формы, а внизу - Кнопка Отправить.

Примечание: если при создании веб-формы ставили флажок Использовать CAPTCHA, то обязательно разместите элемент CAPTCHA. Иначе при сохранении формы флаг Использовать CAPTCHA пропадёт.

Создадим вопрос с множественным выбором. В разделе Новые поля формы найдите элемент Флажок и перенесите его на поле формы. А в разделе Дополнительные элементы формы найдите элемент Подпись поля формы и поместите его перед Флажком.

Нажмите на рисунок, чтобы увеличить

Кликните на элементе Флажок, откроется панель Свойства:

Заполните поля. Обязательно заполните Строковой идентификатор, Текст вопроса и Ответы.

Кликните на элементе Подпись поля формы, откроется панель Свойства. В форме укажите Строковой идентификатор, который только что указали для элемента флажок.

Создайте по аналогии все остальные вопросы формы, разместите их нужным образом на странице, добавьте картинки, измените шрифты и используйте другие возможности визуального редактора , тогда веб-форма в публичном разделе станет такой как вам хочется её видеть. Например, такой:

Как разместить сообщение об ошибке (не заполнены поля)
Для того, чтобы пользователь видел, что поле является обязательным к исполнению, воспользуйтесь элементом Символ "Обязательное поле". Для вывода сообщения о том, что не все обязательные поля использованы используйте элемент Ошибки формы:

Такой результат получим в публичной части при нажатии кнопки Отправить:

Дополнительно

  • Пример для упрощенного режима: анкета регистрации - практический пример создания веб-формы с собственным шаблоном.


Публикация веб-формы
467 / 694

Выводим веб-форму на сайт

Публикация веб-форм выполняется с использованием визуальных компонентов модуля Веб-формы, традиционным для сайтов на CMS "1С-Битрикс: Управление сайтом" способом и, затем, настраивается на нужную веб-форму.

Рассмотрим пример публикации веб-формы Анкета посетителя сайта, например, в разделе Веб-формы. Посетитель может редактировать результаты своих ответов, а также создадим страницу со списком всех результатов веб-формы.

Пример ниже реализуем на основе простых компонентов, а не комплексного. Это сложнее, но вы поймёте разницу между ними .

Видео-пример публикации веб-формы на сайте (два способа: комплексным компонентом и простыми компонентами)

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Создание раздела в структуре сайта

Для удобства работы посетителей сайта с веб-формами создадим раздел, где разместим все необходимые страницы. Создайте раздел Анкета, разместите его в нижнем меню. Создайте страницы в разделе:

  • Главная страница раздела (имя файла - index.php), на ней размещается сама анкета (Страница создаётся вместе с созданием раздела, отдельно создавать не надо.);
  • Список ответов (имя файла - result_list.php) - здесь будет выводится список всех результатов опроса;
  • Исправить ответ (имя файла - result_edit.php) - страница для редактирования ответов;
  • Ответ (имя файла - result_view.php) - страница где отображается чей-то конкретный ответ.

Примечание: Лучше прописывать у создаваемых страниц именно те имена файлов, которые указаны в примере, т. к. это облегчит дальнейшую настройку размещаемых компонентов (в параметрах компонентов по умолчанию указаны такие названия).

Еще рекомендуем создать страницу с сообщением об успешной отправке для того, чтобы посетители с ограниченными правами (только право заполнения формы) после, собственно, заполнения веб-формы могли удостовериться, что все сделали правильно. Здесь имя файла можно задать любое. Скопируйте часть URL созданной страницы от конца домена и заканчивая расширением файла php (понадобится в следующем действии).

Размещение и настройка компонентов

  • Главная страница раздела выводит сам опрос.

    Откройте на редактирование главную страницу раздела и разместите на ней компонент Заполнение веб-формы (bitrix:form.result.new).

    В параметре Страница с сообщениями об успешной отправке укажите скопированную ранее часть URL созданной страницы.

    Примечание: Если после всех настроек ссылка не работает, попробуйте вручную указать в конце части URL параметр ?WEB_FORM_ID=#FORM_ID#.

    Укажите, какую веб-форму надо выводить на этой странице, остальные параметры компонента оставьте без изменений:

  • Список ответов - на ней можно увидеть список всех ответивших на анкету.

    Откройте страницу на редактирование и разместите на ней компонент Список результатов (bitrix:form.result.list). В настройках, кроме выбора веб-формы нужно ещё исправить адрес в поле Страница добавления результата (группа параметров Параметры компонента) с того что есть на index.php

  • Страница Ответ - для детального просмотра ответов выбранного посетителя.

    Откройте страницу на редактирование и разместите на ней компонент Просмотр результата (bitrix:form.result.view). Компонент настраивать не надо, он работает по умолчанию как надо.

  • Исправить ответ - страница, где посетитель может подправить свой ответ.

    Откройте на редактирование страницу и разместите на ней компонент Редактирование результата (bitrix:form.result.edit). Компонент настраивать не надо, он работает по умолчанию как надо.

Что мы увидим в результате? (нажмите на +, чтобы просмотреть)

Главная страница раздела с формой опроса:

Страница Список ответов:

Нажмите на рисунок, чтобы увеличить

Страница Ответ:

Страница Исправить ответ:

Настройка ЧПУ в компонентах веб-форм
Если Вы хотите использовать ЧПУ для веб-форм, то в настройках компонентов потребуется отметить опцию Включить поддержку ЧПУ в разделе Управление адресами страниц .

В качестве Каталога ЧПУ (относительно корня сайта) укажите раздел. В нашем примере это /anketa/.

Теперь переходим к настройке остальных страниц:

Внимание! Все пути к страницам при включенном ЧПУ указываются без раздела (каталога ЧПУ).

  • Для комплексного компонента Веб-форма в разделе Управление адресами страниц при необходимости измените настройки отображения адресов страниц или оставьте их по умолчанию. А в разделе Основные параметры укажите в поле Страница с сообщением об успешной отправке путь к странице без /anketa/.
  • Для простых компонентов потребуется выполнить настройки в разделе Параметры компонента. Укажите все пути к страницам без /anketa/.

Дополнительная информация

  • Описание компонентов модуля (документация)


Внешние источники данных
468 / 694

Модуль Импорт данных из внешних источников (xdimport) позволяет информировать сотрудников компании через Живую ленту портала информацией и событиями, которые происходят вне портала.

Примечание: Модуль Импорт данных из внешних источников (xdimport) доступен в «Битрикс24 в коробке», начиная с версии 11.

Дополнительная информация

  • Внешние источники данных (документация)


Публикация в Живую ленту
469 / 694

Примечание: В скриншотах на странице приведены демонстрационные данные.

Настройки модуля расположены в административной части портала в разделе Сервисы (Сервисы > Внешние источники данных > Публикация в Живую ленту). Всего с порталом может работать неограниченное количество внешних источников.

Подключаемый вебсервис должен возвращать данные в нужных полях. На текущий момент поддерживается 3 способа (протокола) импорта данных:

  • POST - прием информации порталом по протоколу HTTP в виде запроса методом POST;
  • RSS - импорт из внешнего RSS-источника;
  • Веб-сервис (XML) - импорт на базе сервисно-ориентированной модели (SOA) или веб-сервисов.

Интерфейс настройки для режима POST

Для настройки соединения необходимо заполнить данные:

  • В поле Название указать название внешнего источника данных.

    Обратите внимание, это название будет непосредственно отображаться в Живой ленте, поэтому оно должно быть простым и понятным.

  • В параметре Добавлять событие для указать тип события:
    • рабочей группы - выбор рабочей группы, к которой привязывается событие;
    • страницы пользователя - выбрать сотрудника, на странице которого будет отображаться данные;
    • ленты новостей - выбрать информационный блок новостей;
    • внешнего источника данных - без привязки к какой-либо сущности портала;
    • рабочие отчеты - выбрать сотрудника, рабочий отчет которого будет выводиться;
    • рабочее время - выбрать сотрудника, рабочее время которого будет выводиться.

    В зависимости от выбора события необходимо выбрать сущность и само событие для POST-запроса.

    Примечание: Для типа внешний источник данных доступ можно поставить принудительно: либо всем сотрудникам, либо только авторизованным, либо выбранным сотрудникам. Также можно выбрать опцию Разрешить комментарии для возможности обсуждения.

  • В секции Параметры подключения для передачи POST-запроса указывается скрипт портала и параметры POST-запроса, который должна сформировать внешняя по отношению к порталу система:
    • hash - хеш авторизации, чтобы портал разрешил импорт данных;
    • title - заголовок события для отображения в Живой ленте;
    • message - текст события для отображения в Живой ленте (может включать HTML-форматирование);
    • text-message - текст события в виде простого текста (для уведомлений подписчиков по почте или jabber);
    • url - абсолютный путь события, для просмотра подробностей по этому событию, которые можно посмотреть вне портала.

Интерфейс настройки для RSS

  • Секция настроек Параметры события Живой ленты аналогична секции для настройки POST-запроса.
  • В поле URI указывается путь источника RSS-ленты.

    Примечание: В связи с изменениями, связанными с безопасностью, убедитесь, что в настройках схем публикации в живую ленту типа "RSS-лента" установлена активной опция В элементе description передается HTML там, где это необходимо.

  • В секции настроек Расписание автоматической публикации задается расписание импорта данных с внешнего источника.

Интерфейс настройки для Веб-сервисов (XML)

В отличие от RSS, здесь указываются все необходимые параметры для обращения к веб-сервису, опубликованному на внешнем источнике данных: URL, Метод, строку параметров запроса и параметры авторизации:

Также есть два стандартных импорта - статистики и заказов с сайта под управлением «1C-Битрикс», где необходимо указать сервер и данные доступа к нему:


Примеры работы модуля
470 / 694

В главе показаны примеры настройки импорта информации в Живую ленту Корпоративного портала из внешних источников для различных протоколов.


Выгрузка данных из 1С:УТ
471 / 694

Для «1С:Управление торговлей» был создан специальный модуль, который, используя режим POST-запросов, выгружать в Живую ленту различные отчеты.

Модуль поставляется в виде дополнения для «1С:Управление торговлей», которое устанавливается в режиме сравнения и объединения конфигураций (инструкция по установке открывается после распаковки архива).

После установки модуля появится интерфейс для настройки выгрузки данных на корпоративный портал, также можно создать неограниченное количество выгрузок со следующими настройками:

На вкладке Основные настройки необходимо определить параметры интеграции: в первую очередь указать параметры POST-запроса, которые 1С будет отправлять корпоративному порталу: URL, hash и заголовок события. Поля Имя пользователя и Пароль можно использовать для проверки установки соединения с порталом.

Учитывая, что в режиме POST-запросов корпоративный портал выступает пассивным потребителем информации, в 1С можно настроить автоматическую выгрузку данных в указанное время:

На вкладке Настройки отчета выбирается один из представленных на выбор отчетов:

После выбора отчета появится интерфейс его настройки, где можно указать, параметры выборки данных:

Нажатием кнопки Сформировать можно посмотреть результат произведенных настроек - то, что будет впоследствии выгружаться в Живую ленту.

Настройка окончена, теперь можно приступать к выгрузке данных.

Для ручного запуска обмена данными по настройке (узлу обмена) нажимаем кнопку Выгрузить данные в «Живую ленту» КП в форме узла или форме списка узлов. Будет запущен процесс обмена, по окончании которого будет выдано соответствующее сообщение:

Если настроена автоматическая выгрузка по расписанию, то 1С самостоятельно будет формировать данные и отправлять их Корпоративному порталу. Если на сервере «1С:Предприятия» включено выполнение регламентных заданий, обмен будет происходить автоматически по заданному расписанию. В файловом варианте работы для выполнения автоматического обмена по расписанию, должен быть запущен специальный сеанс, обрабатывающий регламентные задания:

После выполнения обмена, в живой ленте корпоративного портала появляется сообщение примерно следующего вида:

Также в настройках импорта на Корпоративном портале можно управлять доступом к этой информации. Так, отчет по продажам можно вывести, например, в рабочую группу Продажи. В итоге отчеты в Живой ленте увидят только те, кто имеет право их просматривать.

В 1С доступен Журнал обмена, в котором фиксируются результаты всех выгрузок.

Можно посмотреть историю обмена, удачные и неудачные попытки выгрузки и зафиксированные ошибки, например, отсутствие соединения с порталом. Эта информация поможет разобраться в причинах, если в нужное время отчет не появился на портале:

Примечание: Для быстрого просмотра протокола обмена по строке журнала достаточно навести указатель мыши на поле Комментарий.


Импорт из RSS-ленты
472 / 694

Для демонстрации воспользуемся RSS-лентой новостей сайта «1C-Битрикс».

В данном случае необходимо указать URL RSS-источника и настроить расписание для импорта событий:

В итоге в Живой ленте мы увидим новости компании «1C-Битрикс»:


Импорт из веб-сервиса
473 / 694

Для демонстрации воспользуемся стандартным веб-сервисом «1C-Битрикс», который предоставляет данные статистики по сайту.

Примечание: На стороне сайта должен быть инсталлирован модуль Веб-сервисы.

В поле Стандартные схемы обмена необходимо выбрать из списка Статистика сайта, указать URL и параметры авторизации, а также выбрать расписание получения отчета.

В живой ленте в назначенное время будет отображаться статистика сайта:


Диск
474 / 694

Работа с Диском

Рассмотрим такие часто встречающиеся задачи и их решения.

  • Корректное добавление нового хранилища
  • Переименование диска с использованием API
  • Удаление диска из базы и из файловой системы
  • Удаление дисков групп, отключение и подключение их пользователям
    •

    Как корректно добавить новое хранилище с пошаговым мастером, что обозначают параметры этого мастера

    Для добавления нового хранилища перейдите с правами администратора системы на страницу https://ваш_портал/docs/index.php:

    Если нужно подключить имеющийся сетевой диск, то воспользуйтесь ссылкой Подключить сетевой диск. В открывшемся окне скопируйте адрес для подключения и подключите диск штатным для ОС Windows способом. (Если забыли, то воспользуйтесь ссылкой Как подключить библиотеку как сетевой диск) во всплывшем окне.

    Если требуется создать новое хранилище, то нажмите ссылку Добавить хранилище, откроется окно мастера:

    Пройдите шаги этого мастера. Все окна в шагах достаточно информативны без документации, однако, если возникли проблемы, обратитесь к описанию создания библиотеки в Библиотеке документов. Мастер полностью аналогичен, за исключением работы с инфоблоком на третьем шаге: модуль Диск не работает с инфоблоками.

    Как переименовать диск (отображаемое имя) с использованием API

    Хранилища пользователей "слушают" события переименования пользователей и после этого переименовываются сами. Если есть потребность сделать это через API, то сделайте это так:

    <?php
\Bitrix\Main\Loader::includeModule('disk');
$storageId = 100; //id хранилища Диска, которые вы желаете переименовать. См. таблицу b_disk_storage
$newName = 'Tomorrow'; //новое, желаемое имя
$errors = null;

$storage = \Bitrix\Disk\Storage::loadById($storageId);
if($storage)
{
    if(!$storage->rename($newName))
    {
        $errors = $storage->getErrors();
    }
}

    Как удалить диск из базы и из файловой системы

    Если удалить группу или пользователя, то удалится и её/его диск. Удаление с помощью API реализуется так:

    <?php
\Bitrix\Main\Loader::includeModule('disk');
$userId = 1; //id пользователя, от имени которого будет совершаться удаление
$storageId = 100; //id хранилища Диска, которые вы желаете переименовать. См. таблицу b_disk_storage
$errors = null;

$storage = \Bitrix\Disk\Storage::loadById($storageId);
if($storage)
{
    if(!$storage->delete($userId))
    {
        $errors = $storage->getErrors();
    }
}

    Как удалять диски групп, отключать и подключать их пользователям

    Не каждый пользователь подключает к себе диск при вступлении в группу, а производственная необходимость требует такого действия. Администратору доступно с помощью API управление процессами подключения дисков для всех пользователей.

    Как удалять диски групп?
    <?php
\Bitrix\Main\Loader::includeModule('disk');
$userId = 1; //id пользователя, от имени которого будет совершаться удаление
$groupId = 345; //id группы соц.сети, хранилище которой нужно удалить
$errors = null;

$storage = \Bitrix\Disk\Driver::getInstance()->getStorageByGroupId($groupId);
if($storage)
{
    if(!$storage->delete($userId))
    {
        $errors = $storage->getErrors();
    }
}

    Как подключить пользователю 444 диск группы с ID 345

    <?php
\Bitrix\Main\Loader::includeModule('disk');
$groupId = 345; //id группы соц.сети
$toUserId = 444; //id пользователя, к которому нужно подключить хранилище группы
$errors = null;

$groupStorage = \Bitrix\Disk\Driver::getInstance()->getStorageByGroupId($groupId);
if($groupStorage)
{
    $errorCollection = new Bitrix\Disk\Internals\Error\ErrorCollection;
    if(!\Bitrix\Disk\Sharing::connectGroupToSelfUserStorage($toUserId, $groupStorage, $errorCollection))
    {
        $errors = $errorCollection->toArray();
    }
}

    Как отключить у пользователя 444 диск группы с ID 345

    <?php
\Bitrix\Main\Loader::includeModule('disk');
$userId = 1; //id пользователя, от имени которого будет совершаться удаление
$groupId = 345; //id группы соц.сети
$toUserId = 444; //id пользователя, у которому нужно отключить хранилище группы
$errors = null;

$groupStorage = \Bitrix\Disk\Driver::getInstance()->getStorageByGroupId($groupId);
if($groupStorage)
{
    $errorCollection = new Bitrix\Disk\Internals\Error\ErrorCollection;
    $sharing = \Bitrix\Disk\Sharing::load(array(
        '=TO_ENTITY' => \Bitrix\Disk\Sharing::CODE_USER . $toUserId,
        'REAL_OBJECT_ID' => $groupStorage->getRootObjectId(),
        'REAL_STORAGE_ID' => $groupStorage->getId(),
        'TYPE' => \Bitrix\Disk\Internals\SharingTable::TYPE_TO_USER,
    ));

    if($sharing)
    {
        if(!$sharing->delete($userId))
        {
            $errors = $sharing->getErrors();
        }
    }
}

    Внимание! Публичные ссылки недоступны, если публичная часть сайта закрыта.

    О хранении файлов в диске. Немного теории.

    Все файлы регистрируются в ядре Битрикса, точнее в таблице БД. Сам контент файлов лежит в облаке или локально.

    Модуль Диск оперирует записями в этой таблице. Реально он не знает где лежат файлы. Модуль даст команду на загрузку или скачивание файла, но весь механизм работы принадлежит Главному модулю.

    Единственный нюанс - при работе с Дескотопным приложением. В целях оптимизации работы с большими файлами в приложении работает несколько иной механизм. Файл частями по 5 Мб загружается в облако напрямую с приложения используя API модуля Облачное хранилище.

    Файл в подключенных облаках хранятся по своим именам, созданным по правилам подключённого облака. Как правило - это череда бессмысленных букв и цифр. Напрямую с облака скачать нереально, долгий процесс подбора имён.

    В рамках простой бизнес-логики: загрузить через корпоративный портал, происходит проверка прав доступа на уровне ядра системы: наличие места для данного типа пользователя (платный, бесплатный), может ли собственно этот пользователь грузить файлы вообще, может ли он загрузить файл в конкретную папку и так далее.

    В модуле Диск предусмотрена защита от CSRF атак.

    Напрямую загрузить/скачать файл используя REST API тоже не получится, так как нужны access token, которые хранятся на сервере Битиркса.

    Проблемы возможны в случае, если используется стороннее приложение и его разработчик ошибся: любой пользователь приложения получил администраторские права.

    В случае "Битрикс24 коробке" ошибка, также, возможна в случае ошибок администрирования прав.

    Документация по теме:

    • REST-методы, доступные при работе с Диском


Настройка работы с документами через внешние службы
475 / 694

Настройка работы с документами через Google Docs

Для функционала работы с документами через Google Docs нужно:

  • авторизоваться в Google и выполнить Настройки Google в модуле Социальные сервисы.
  • перейти в меню Библиотека и найти опцию Google Drive API либо быстрым поиском, либо из списка Популярных API.
  • включить Google Drive API и Gmail API c помощью кнопки Включить.
  • активировать опцию Включить работу с документами через внешние службы (Google Docs, MS Office Online и другие) в настройках модуля Диск (Настройки > Настройки продукта > Настройки модулей > Диск).

Решение проблем верификации в Google

В этом курсе описывается коробочная версия портала Битрикс24 . Одним из её преимуществ является возможность установки на выбранном вами сервере хостера или в локальной сети. Но Google Docs - онлайн сервис (облачный сервис, SaaS). Он доступен из глобальной сети, поэтому его политика безопасности постоянно корректируется и ужесточается. В связи с этим, при настройке внешней авторизации вы можете получить запрос на верификацию вашего приложения (портала Битрикс24).

Есть два варианта решения этой ситуации:

  • Вариант 1. Вы можете не проходить процедуру верификации. Тогда вам придется каждый раз переходить по ссылке Дополнительные настройки и давать разрешение на доступ.
  • Вариант 2. Верифицировать ваше приложение. Для этого нужно:
    • заполнить форму на вкладке Окно запроса доступа OAuth. В форме нужно указать данные вашего приложения (портала Битрикс24) - название, логотип, адрес техподдержки.
    • Обязательно указать Области действия для API Google.

    • В список используемых скоупов рекомендуется включать:

      - https://www.googleapis.com/auth/userinfo.email и https://www.googleapis.com/auth/userinfo.profile - используются для базовой авторизации и привязки аккаунта Google к аккаунту Битрикс24

      - https://www.googleapis.com/auth/calendar - используется для интеграции календаря в Битрикс24 с Google Calendar

      - https://www.googleapis.com/auth/drive - используется для загрузки файлов Google Drive в Битрикс24 и для редактирования документов из Битрикс24 в Google Docs.

      - https://mail.google.com/ и email - используются для работы веб-интерфейса почты внутри Битрикс24.

    • Даже если вы не используете что-то из перечисленного у себя в коробочном портале, лучше указать все возможности, чтобы не проходить верификацию повторно. Если у вас есть какие-то свои дополнения на основе Google API к функционалу коробки, их тоже нужно здесь указать и описать.
    • После заполнения формы нужно подождать ответа от техподдержки Google. Обычно это 2-3 рабочих дня. Техподдержка Google может прислать вам инструкции о том, что вам необходимо изменить или настроить на сайте, чтобы использовать ваше OAuth-приложение.

      Пример инструкции от техподдержки Google

      Dear Developer,

      Thank you for submitting an OAuth App Verification request.

      It appears that your homepage URL https://mysite.ru/ is a login screen, which restricts public access to your app's information and intent. Google requires that your homepage accurately represents your app’s identity to users. If your app requires a log in, we recommend that you place the limited access sign-in procedure on a separate web page.

      If your app is meant to be available to the public, please make sure that your app’s homepage URL features content associated with your brand, accurately represents your true identity, and clearly describes the functionality of your app.

      If you need to update the homepage URL linked to your OAuth Consent Screen, you can do the following:

      Sign-in to Google Cloud Console

      Select the project ID: my_site_ru

      Go to Credentials on OAuth consent screen

      Enter the homepage URL

      Click Submit

      If your app is meant to be internal, please let us know by replying to this email. We will then close your case so that you are able to update your project from public to internal.

      To update your project fr om public to internal:

      Sign-in to Google Cloud Console

      Select the project ID: my_site_ru

      Go to Credentials on OAuth consent screen

      Go to Application Type

      Select Internal

      Click Save

      In addition, you will need to associate your project with your organization:

      If you have not already done so, create an Organization by following the Quickstart Using Organizations instructions.

      Migrate the project into the organization you created as shown in Migrating Existing Projects into the Organization.

      Once you have associated your project with your organization, you and the project users in your organization can use the app to directly access OAuth scopes. No verification will be required.

      Please reply to this email once you have made the appropriate updates to your site and/or your OAuth Consent Screen so that we may continue with the verification process. Note that any new email sent to api-oauth-dev-verification@google.com will not be received by our team.

      You can find more information in the OAuth Application Verification FAQ. If you have additional questions, please respond to this email.

    • В случае, если техподдержка Google начнет настоятельно требовать перейти со скоупа https://mail.google.com/ на https://www.googleapis.com/auth/gmail.readonly, можно ответить, что такой возможности нет, поскольку веб-интерфейс работает по протоколу IMAP, для которого требуется токен со скоупом https://mail.google.com/.
    • После подтверждения все заработает, но в будущем может потребоваться повторное подтверждение, если Google будет менять настройки приложения, или если Битрикс будет выпускать новые возможности интеграции с Google. Потому данные заполнения формы лучше сохранить, чтобы не сочинять их потом заново.

Настройка работы с документами через MS Office Online

  • Авторизоваться или завести рабочую учетную запись Office365 (xxxx@xxxx.onmicrosoft.com) с подпиской Office365 для Бизнеса.
  • Выполнить Настройки Office365 в модуле Социальные сервисы.
  • Активировать опцию Включить работу с документами через внешние службы (Google Docs, MS Office Online и другие) в настройках модуля Диск (Настройки > Настройки продукта > Настройки модулей > Диск).

Если вы всё ещё используете модуль Библиотека документов

Опция Включить работу с документами через внешние службы (Google Docs, MS Office Web Apps и другие) находится в настройках модуля Библиотека документов (Настройки > Настройки продукта > Настройки модулей > Библиотека документов).


Задачи
476 / 694

При установке «Битрикс24 в коробке» с нового дистрибутива модуль устанавливается автоматически. В корпоративных порталах установленных ранее этот модуль отсутствует.

  • Установка и подключение модуля (для порталов со старой версией задач)
  • Оповещения о задачах в живой ленте
  • Синхронизация задач с Exchange
  • Настройка Помощи
    •

    Установка и подключение модуля (для порталов со старой версией задач)

    Чтобы установить модуль и начать использовать новые задачи вместо старых выполните следующее:
    • Установите обновление Модуль Задачи (Настройки > Обновления);
    • Затем установите модуль Задачи, который появится в списке модулей (Настройки > Настройки продукта > Модули) после обновлений:

      Установка модуля "Задачи"

    • Во время установки модуля будет предложена конвертация старых задач. Это позволит перенести и подключить все старые задачи в новый модуль Задачи, так как старые и новые задачи не совместимы:

      После чего на экране будет отображено общее количество сконвертированных задач

      Количество сконвертированных задач

      а на странице Задачи будет новый интерфейс

      Нажмите на рисунок, чтобы увеличить

    Примечание: Переключиться обратно на старые задачи и интерфейс можно, отключив опцию Использовать задачи 2.0 в настройках модуля Интранет (Настройки > Настройки продукта > Настройки модулей > Интранет):

    Настройки модуля "Интранет"

    Но тогда, задачи, созданные в новом интерфейсе, будут недоступны для старого и наоборот.

    Если при установке модуля вы по ошибке не произвели конвертацию старых задач, то:

    • Отключите Задачи 2.0 в настройках модуля Интранет (Настройки > Настройки продукта > Настройки модулей > Интранет):

      Настройки модуля "Интранет"

    • Удалите модуль Задачи и затем установите его заново

      Установка модуля "Задачи"

    Если уже были созданы новые задачи с помощью модуля Задачи, но необходимо добавить старые, то выполните аналогичные действия, но на шаге удаления модуля сохраните данные в таблицах базы данных:

    Удаление модуля "Задачи"

    Оповещения о задачах в живой ленте

    Начиная с 11 версии модуля поддерживается "добавление" задач в живую ленту. Для корректной работы необходимо указать Форум для комментариев в настройках модуля Задачи:

    После чего в живой ленте будут отображаться история изменения задач и комментарии к ним:

    Примечание: В живой ленте будут отображаться только те задачи, к которым у сотрудника есть доступ.

    Синхронизация задач с Exchange

    Для соединения задач и их синхронизации с Exchange сервером необходимо произвести настройки модуля DAV (Настройки > Настройки продукта > Настройки модулей > DAV)

    настройки модуля "DAV"

    Настройка помощи

    При смене шаблона портала с "Лайт" на "Битрикс24" (либо собственный) подсказки к задачам, вызываемые по кнопке Помощь не соответствуют тому, что видит пользователь на своём мониторе. Это несоответствие создают затруднения в использовании задач у неопытных пользователей. Для замены картинок в подсказках сделайте следующее:

    В папке bitrix/modules/tasks/install/public/js/tasks/css/images есть файл task-legend-sprite.gif. Создайте под этим же именем новый файл с новыми картинками подсказок, соответствующими вашему дизайну. Замените им старый файл.

    Примечание: Важно, что бы размеры составных частей и их число точно соответствовало начальному. Если эти параметры не соответствуют исходным, то необходимо отредактировать настройки css в файле bitrix/modules/tasks/install/public/js/tasks/css/tasks.css.

    Ссылки по теме:
    • Задачи (Курс "Пользователь корпоративного портала")
    • Настройки модуля "Задачи" (Пользовательская документация)
    • Автоматическая смена ответственного в задачах (Блог)


Добавление пользовательских полей для задач
477 / 694

Система позволяет добавить собственные поля для задач.

Рассмотрим пример создания поля, в котором сотрудник сможет самостоятельно указывать процент выполнения задачи.

Создадим новое пользовательское поле на странице Пользовательские поля (Настройки > Настройки продукта > Пользовательские поля):

  • в поле Тип данных выберем число;
  • в поле Объект укажем TASKS_TASK;
  • зададим уникальный Код поля, который будет начинаться с UF_, например UF_TASKS_F_1;

    • Примечание: Можно создать множество собственных полей. Для этого необходимо указать разные коды полей, но поле объект для задач всегда должно содержать значение TASKS_TASK.

  • укажем подписи для поля в блоке Языковые настройки.

Теперь при создании и просмотре задачи пользователю будет доступно соответствующее поле:


Интранет
478 / 694

Работа модуля Интранет основана на модуле Информационные блоки. Компоненты этого модуля используются для:

  • выполнения поиска сотрудников;
  • отображения кадровых изменений, происходящих в компании;
  • построения графика отсутствующих сотрудников;
  • организации доски почета;
  • вывода списка ближайших именинников;
  • создания календарей событий;
  • импорта пользователей из «1С:Зарплата и Управление Персоналом».

Внимание! В дистрибутиве уже созданы все необходимые информационные блоки. Необходимость создания новых возникает если только создаются новые типы календарей.

Примечание: параметры настроек модуля описаны в Пользовательской документации.


Календари
479 / 694

В продукте реализована возможность ведения календарей событий нескольких видов. Для этого создайте тип инфоблока, например Календарь, а для всех видов календарей портала создайте соответствующие инфоблоки. Например:

  • для отображения занятости помещений, в которых проводятся переговоры и встречи, создайте инфоблок Бронирование переговорных;
  • для проведения видеоконференций создайте инфоблок Бронирование видео-переговорных.

Разделами инфоблока Бронирование переговорных являются переговорные комнаты, а элементами - брони переговорных. Аналогично разделами инфоблока Бронирование видео-переговорных являются видеопереговорные.

Примечание: Для отображения событий компании, рабочих групп, персональных календарей сотрудников необходимо воспользоваться специальным модулем Календарь событий.

Создание публичного интерфейса

Для размещения любого из видов календарей в публичном разделе, а также для создания интерфейса резервирования переговорных с помощью календаря служит компонент Календарь событий 2.0 (bitrix:calendar.grid).

Примечание: отображение календарей сотрудников и рабочих групп также выполняется с помощью данного компонента, но он вызывается комплексным компонентом Социальная сеть - пользователь (bitrix:socialnetwork_user) и Социальная сеть - группы (bitrix:socialnetwork_group) соответственно, в настройках параметров которых указываются необходимые календари сотрудников и рабочих групп.

Примечание: Подробнее про работу с компонентом в публичной части сайта смотрите в курсе Пользователь корпоративного портала, глава Календарь.

Для создания интерфейса табличного режима резервирования переговорных служит комплексный компонент Бронирование переговорных (bitrix:intranet.reserve_meeting).

Примечание: подробное описание интерфейса резервирования переговорных приведено в курсе Пользователь корпоративного портала, урок Резервирование переговорных.

При этом обратите внимание, что при наличии необходимых прав доступа, будут доступны дополнительные действия по управлению и резервированию переговорных.

Настройки синхронизации с Microsoft Outlook

Для обеспечения синхронизации календарей портала с MS Outlook необходимо произвести настройку параметров модуля Интранет (Настройки > Настройки продукта > Настройки модулей > Интранет, заклада Синхронизация).

Настройте следующие параметры необходимым для вас образом:

  • Синхронизировать изображения пользователей - при отмеченной опции изображения пользователей будут синхронизироваться.
  • Первый день недели - указывается первый день недели.
  • Если в вашем часовом поясе осуществляется переход на летнее время и обратно, то в секции Настройки часового пояса отметьте опцию В моем регионе осуществляется переход на летнее время и обратно и настройте параметры Переход на стандартное время и Переход на летнее время. В поле Серверное время отображается разница с GMT, тип времени и текущая дата.
  • в секции Ссылки для каждого сайта указываются шаблоны ссылок на:
    • профиль пользователя;
    • список задач пользователя;
    • задачу пользователя;
    • список задач группы;
    • задачу группы.

Примечание: выполнение процедуры экспорта календарей в MS Outlook подробно рассмотрено в курсе Пользователь корпоративного портала, урок Экспорт календарей.


Кадровые изменения
480 / 694

Для представления информации об изменениях, произошедших в карьере сотрудников, необходимо создать тип инфоблока, например Оргструктура, и инфоблок История состояний, в котором будут храниться записи о кадровых изменениях сотрудников.

Чтобы информация о карьерном изменении отображалась на портале корректно, следует созданный инфоблок указать в настройках модуля Интранет в поле Инфоблок истории состояний:

Настройки модуля Интранет

Группы пользователей портала, которые могут создавать/изменять записи, определяются в настройках доступа инфоблока:

Настройка прав доступа к инфоблоку

По умолчанию только администраторы системы могут управлять кадровыми изменениями сотрудников.

Создание записи

Для добавления записи о кадровой перестановке сотрудника перейдите на станицу История состояний (Контент > Оргструктура > История состояний). Нажмите кнопку Добавить запись, расположенную на контекстной панели. Откроется форма создания новой записи:

Создание записи о кадровом изменении

  • В поле Выберите сотрудника, к которому относится изменение и заполните поле Дата изменения.
  • Обязательно заполните поле Информация о кадровом изменении, например, Переведен, Принят и т.д.
  • В поле Краткое описание изменения укажите краткую информацию о записи.
  • Сохраните внесенные данные с помощью кнопки Сохранить.

Публикация кадровых изменений

Для отображения кадровых изменений компании в публичном разделе служит компонент Кадровые изменения (bitrix:intranet.structure.events).

Примечание: Подробнее про работу с компонентом в публичной части сайта смотрите в курсе Пользователь корпоративного портала, урок Кадровые изменения.

Примечание: Администратору системы доступны следующие кнопки управления, расположенные на странице в публичной части:
  • Добавить запись - добавить запись о кадровой перестановке в публичном разделе;
  • Управление - перейти к управлению записями о кадровых перестановках в административном разделе.


Календарь событий
481 / 694

Модуль Календарь событий позволяет просматривать прошедшие и запланированные события, отмеченные в различных календарях. Также он дает возможность управления событиями и их экспорта.

Дополнительная информация

  • Календарь событий (документация)


Настройки модуля календарей
482 / 694

В форме настроек Календаря событий (Настройки > Настройки продукта > Настройки модулей > Календарь событий) задаются общесистемные параметры модуля.

Нажмите на рисунок, чтобы увеличить

Закладка "Настройки"

Здесь задаются параметры, большинство которых понятны из названия полей.

Ниже подробно рассказано о параметрах, которые могут вызвать трудности:

  • По возможности проводить синхронизацию календаря через Webhook вместо агента - система будет проводить синхронизацию с помощью технологии Webhook, если это возможно по настройкам сети.

    Подробнее о настройке синхронизации через вебхуки
    Бывает удобно, чтобы календарь Гугл синхронизировался с календарем на портале по Push-технологии, то есть не через постоянно включенный агент, а только тогда, когда произошли какие-то изменения. Для этого в Гугле нужно разрешить веб-хуку отправлять уведомления на ваши внешние домены. Чтобы добавить домен в Google:
    • Необходимо зайти в Google Search Console под авторизацией того пользователя, к которому привязан сервис Битрикс24 и кому принадлежат учётные данные (client_id, client_secret) и добавить свой портал в консоль вебмастера:

    • Далее следует подтвердить право собственности на домен, как описано в окне:

    • Зарегистрировать свой домен в консоли API и сервисов Google:

    • В административной части вашего портала в настройках модуля "Календарь событий" включить чекбокс:

    Обратите внимание! Ваш портал должен обязательно работать по протоколу https.
  • Показывать логин пользователя - при отмеченной опции, на панели управления после имени и фамилии, будет указан логин сотрудника в системе.
  • Разрешить начальникам просматривать календари подчиненных - при отмеченной опции начальники подразделений смогут просматривать события всех календарей подчиненных вне зависимости от персональных настроек прав доступа.

    • Шаблоны ссылок

    Указываются шаблоны ссылок к страницам профиля пользователя, календаря пользователя, просмотра рабочей группы и др.

  • Общие для всех сайтов - при отмеченной опции заданные шаблоны ссылок будут применяться ко всем сайтам в системе.

    • Параметры переговорных

    Здесь задаются тип инфоблока и сам инфоблок для бронирования видеопереговорных и переговорных.

    Параметры комментариев для событий календаря

    Выбирается форум, который будет использован как комментарии к календарям.

Закладка "Типы календарей"

Закладка позволяет добавить новый тип календарей, удалить или изменить существующие, а также настроить права доступа к типам календарей для всех сотрудников.

Как заполнять поля - понятно из названия полей. Если всё-таки возникнут трудности, обратитесь к пользовательской документации.

Дополнительная информация

  • Календарь событий. Настройки модуля (документация)


Установка модуля и конвертация календарей
483 / 694

Модуль автоматически устанавливается при новой установке дистрибутива «Битрикс24 в коробке», либо будет загружен при установке обновлений для модуля Интранет 11.0.3 и выше.

После установки обновлений, в публичной части, на странице Компания > Календарь событий для администраторов будет выводиться сообщение о возможности установки нового модуля:

Нажав на ссылку установки модуля вы попадете на страницу Настройки > Настройки продукта > Модули. Найдите в списке модуль Календарь событий и нажмите кнопку Установить. После успешной установки модуля необходимо провести конвертацию данных.

Примечание: если вы случайно покинете страницу с предложением переконвертации данных, то попасть на нее снова можно будет либо переустановив модуль, либо перейдя по ссылке: /bitrix/admin/calendar_convert.php.

Для начала конвертации нужно проанализировать публичные файлы сайта:

Примечание: анализ является пошаговым и может занять длительное время, если структура портала является обширной.

После анализа публичных файлов будут выведены параметры, считанные из компонентов в публичных файлах:

Обратите внимание на следующие моменты:

  • Типы календарей конвертируются из инфоблоков. В стандартной поставке: Календари пользователей, Календари групп, Календарь компании.
  • Не рекомендуется конвертировать инфоблок, используемый для бронирования переговорных (этот функционал в текущей версии продукта продолжит использовать модуль Интранет).
  • Шаблоны ссылок - извлекаются из публичных файлов, поэтому если на корпоративном портале присутствуют "нерабочие" страницы с некорректными путями - шаблоны ссылок могут быть ошибочными.
  • При многопортальности используются разные ссылки к разным типам календарей, поэтому потребуется указать их заново после конвертации.
  • Все настройки можно будет изменить в настройках модуля и после конвертации.

Внимание! В процессе конвертации, и переходе к работе на новый модуль, список избранных календарей пользователей не конвертируется. Также потребуется заново подключить календари exchange и Google.

Процесс конвертации идет автоматически, в пошаговом режиме, и если конвертация произошла хорошо, вы увидите лог, и предложение перейти в настройки модуля.

Примечание: если что-то пошло не так, то вы всегда можете вернуться на предыдущую версию функционала, и при желании повторить конвертацию.

Для возврата на прежнюю версию интерфейсов в командной строке PHP выполните:

COption::SetOptionString("intranet", "calendar_2", "N");

Для повторного запуска конвертации удалите модуль Календарь событий без сохранения таблиц, и установите его заново.

Перейдите к настройкам модуля, где вы можете изменить настройки, установленные при конвертации, разделять шаблоны путей для разных сайтов.

На закладке Типы календарей вы можете управлять типами календарей, и настраивать общий доступ пользователей к ним.

После установки модуля на вашем корпоративном портале появятся новые интерфейсы календарей событий.


Настройки календаря
484 / 694

Чтобы настроить календарь, нажмите "шестеренку":

Здесь частично дублируются настройки модуля, которые мы делали в административной части. То есть можно установить выходные и праздничные дни недели и года, время начала и окончания рабочего дня. Здесь же настраивается отображение задач и событий:

В секции Права доступа настраиваются уровни доступа к календарю для различных категорий пользователей

Начальник может смотреть календари подчиненных вне зависимости от выставляемых подчиненными прав доступа.

Примечание: подробнее о редактировании календарей смотрите на странице Поддержка24.

Ошибка ErrorFolderNotFound
При синхронизации календарей пользователей с MS Exchange может возникать ошибка: ErrorFolderNotFound. Причина ошибки - в настройке прав доступа пользователей к MS Exchange.

Для установки нужного уровня прав в power shell выполните:

Get-MailboxDatabase -identity “[mailbox database name]” | Add-ADPermission -user [username] -AccessRights GenericAll

Где mailbox database name - результат выполнения команды:

Get-MailboxDatabase | ft Identity


Настройка синхронизации Календарей с Google.Calendar
485 / 694

Google

Для синхронизации Календарей портала с Google.Calendar нужно:

  • авторизоваться в Google и выполнить Настройки Google в модуле Социальные сервисы.
  • перейти в меню Библиотека и найти опции Calendar API и СalDAV API либо быстрым поиском, либо из списка Популярных API.
  • включить Calendar API и СalDAV API c помощью кнопки Включить


Коннекторы для внешних мессенджеров
486 / 694

С помощью модуля Коннекторы для внешних мессенджеров можно организовать подключение различных внешних социальных сервисов для общения с помощью открытых линий.

Открытые линии - способ коммуникации с клиентами компании, посетителями сайта, с помощью которого собираются сообщения из разных каналов (мессенджеры, соцсети) в Битрикс24, распределяются по правилам очереди между сотрудниками и незаметно сохраняются в CRM.

Список подключаемых коннекторов к открытым линиям довольно обширен:

  • Онлайн-чат
  • Битрикс24.Network
  • Telegram
  • Вконтакте
  • Facebook: Сообщения
  • Facebook: Комментарии
  • Microsoft Bot Framework, позволяющий включить следующие каналы в Открытые линии: Skype, Slack, Kik, GroupMe, Twilio, Web Chat, E-mail, Telegram, Facebook Messenger, Direct Line.


Настройка модуля
487 / 694

Общие серверные настройки

  1. Полный доступ из вне к http://адрес сайта/pub/imconnector/, к корню и всем файлам и поддиректориям.
  2. Действующий лицензионный ключ.
  3. Доступ со стороны портала ко всем внешним адресам, в частности к соцсетям Facebook, Вконтакте и т.п. по http и https.
  4. Настройка параметра Nginx: nginx proxy_ignore_client_abort on. Эту настройку необходимо включать для конкретного location.
  5. Для работы коннектора Онлайн-чат:
    • для location /online/(/?)([^/]*) разрешить X-Frame-Options SAMEORIGIN (открывать эту страницу как фрейм из любого сайта или только того, где будет расположен фрейм). Такие настройки могут быть в Nginx и в модуле Проактивная защита в разделе Защита от фреймов (Настройки > Проактивная защита > Защита от фреймов);
  6. Для работы коннектора Битрикс24.Нетворк:
    • установленный и настроенный модуль Чат-боты Битрикс24 (imbot);
    • доступ без авторизации к странице /pub/imbot.php;
    • если возникают проблемы с прохождением сообщений даже при таких настройках, необходимо включить опцию Долгое ожидания ответа в опциях модуля Чат-боты Битрикс24.

Настройка модуля Коннекторы для внешних мессенджеров (Настройки > Настройки продукта > Настройки модулей > Коннекторы для внешних мессенджеров) проста:

  • Публичный адрес сайта - нужно убедиться, что после установки был верно определен адрес портала. Он должен быть указан вместе с адресом портала и протоколом. Закрывающий слэш не обязателен.
  • Включить режим отладки - эта опция включает лог ошибок работы коннекторов в файл /bitrix/modules/imconnector_error.log.

    Примечание: В файл пишется только лог ошибок, включать данную опцию имеет смысл только для отладки, лог трассировки сообщений в этот файл не пишется.

  • Список используемых коннекторов - здесь выбираются коннекторы (каналы), доступные к подключению.

Внимание! Если не удается подключить каналы и происходит ошибка, то нужно в первую очередь в настройках модуля проверить верность указания доменного имени с протоколом и убедиться, что данный адрес доступен из интернета.


Добавление собственного типа коннекторов
488 / 694

Регистрация обработчика

Обработчик события OnImConnectorBuildList модуля imconnector регистрируется либо в init.php, либо при установке модуля.

Пример обработчика:

\Bitrix\Main\EventManager::getInstance()->addEventHandler("imconnector", "OnImConnectorBuildList", Array("MyClass", "OnImConnectorBuildListHandler"));

class MyClass
{
  function OnImConnectorBuildListHandler()
  {
     return array(
        //ID коннектора
        'ID' => 'baseconnector',
        //Имя коннектора
        'NAME' => 'Базовый коннектор',
        //Описание иконки
        'ICON' => array(
           'DATA_IMAGE' => 'data:image/svg+xml;charset=US-ASCII,%3Csvg%20version%3D%221.1%22%20id%3D%22Layer_1%22%20xmlns%3D%22http%3A//www.w3.org/2000/svg%22%20x%3D%220px%22%20y%3D%220px%22%0A%09%20viewBox%3D%220%200%2070%2071%22%20style%3D%22enable-background%3Anew%200%200%2070%2071%3B%22%20xml%3Aspace%3D%22preserve%22%3E%0A%3Cpath%20fill%3D%22%230C99BA%22%20class%3D%22st0%22%20d%3D%22M34.7%2C64c-11.6%2C0-22-7.1-26.3-17.8C4%2C35.4%2C6.4%2C23%2C14.5%2C14.7c8.1-8.2%2C20.4-10.7%2C31-6.2%0A%09c12.5%2C5.4%2C19.6%2C18.8%2C17%2C32.2C60%2C54%2C48.3%2C63.8%2C34.7%2C64L34.7%2C64z%20M27.8%2C29c0.8-0.9%2C0.8-2.3%2C0-3.2l-1-1.2h19.3c1-0.1%2C1.7-0.9%2C1.7-1.8%0A%09v-0.9c0-1-0.7-1.8-1.7-1.8H26.8l1.1-1.2c0.8-0.9%2C0.8-2.3%2C0-3.2c-0.4-0.4-0.9-0.7-1.5-0.7s-1.1%2C0.2-1.5%2C0.7l-4.6%2C5.1%0A%09c-0.8%2C0.9-0.8%2C2.3%2C0%2C3.2l4.6%2C5.1c0.4%2C0.4%2C0.9%2C0.7%2C1.5%2C0.7C26.9%2C29.6%2C27.4%2C29.4%2C27.8%2C29L27.8%2C29z%20M44%2C41c-0.5-0.6-1.3-0.8-2-0.6%0A%09c-0.7%2C0.2-1.3%2C0.9-1.5%2C1.6c-0.2%2C0.8%2C0%2C1.6%2C0.5%2C2.2l1%2C1.2H22.8c-1%2C0.1-1.7%2C0.9-1.7%2C1.8v0.9c0%2C1%2C0.7%2C1.8%2C1.7%2C1.8h19.3l-1%2C1.2%0A%09c-0.5%2C0.6-0.7%2C1.4-0.5%2C2.2c0.2%2C0.8%2C0.7%2C1.4%2C1.5%2C1.6c0.7%2C0.2%2C1.5%2C0%2C2-0.6l4.6-5.1c0.8-0.9%2C0.8-2.3%2C0-3.2L44%2C41z%20M23.5%2C32.8%0A%09c-1%2C0.1-1.7%2C0.9-1.7%2C1.8v0.9c0%2C1%2C0.7%2C1.8%2C1.7%2C1.8h23.4c1-0.1%2C1.7-0.9%2C1.7-1.8v-0.9c0-1-0.7-1.8-1.7-1.9L23.5%2C32.8L23.5%2C32.8z%22/%3E%0A%3C/svg%3E%0A',
           'COLOR' => '#1900ff',
           //Возможно
           'SIZE' => '90%',
           'POSITION' => 'center'
        ),
        'ICON_DISABLED' => array(
           'DATA_IMAGE' => 'data:image/svg+xml;charset=US-ASCII,%3Csvg%20version%3D%221.1%22%20id%3D%22Layer_1%22%20xmlns%3D%22http%3A//www.w3.org/2000/svg%22%20x%3D%220px%22%20y%3D%220px%22%0A%09%20viewBox%3D%220%200%2070%2071%22%20style%3D%22enable-background%3Anew%200%200%2070%2071%3B%22%20xml%3Aspace%3D%22preserve%22%3E%0A%3Cpath%20fill%3D%22%235c6470%22%20class%3D%22st0%22%20d%3D%22M34.7%2C64c-11.6%2C0-22-7.1-26.3-17.8C4%2C35.4%2C6.4%2C23%2C14.5%2C14.7c8.1-8.2%2C20.4-10.7%2C31-6.2%0A%09c12.5%2C5.4%2C19.6%2C18.8%2C17%2C32.2C60%2C54%2C48.3%2C63.8%2C34.7%2C64L34.7%2C64z%20M27.8%2C29c0.8-0.9%2C0.8-2.3%2C0-3.2l-1-1.2h19.3c1-0.1%2C1.7-0.9%2C1.7-1.8%0A%09v-0.9c0-1-0.7-1.8-1.7-1.8H26.8l1.1-1.2c0.8-0.9%2C0.8-2.3%2C0-3.2c-0.4-0.4-0.9-0.7-1.5-0.7s-1.1%2C0.2-1.5%2C0.7l-4.6%2C5.1%0A%09c-0.8%2C0.9-0.8%2C2.3%2C0%2C3.2l4.6%2C5.1c0.4%2C0.4%2C0.9%2C0.7%2C1.5%2C0.7C26.9%2C29.6%2C27.4%2C29.4%2C27.8%2C29L27.8%2C29z%20M44%2C41c-0.5-0.6-1.3-0.8-2-0.6%0A%09c-0.7%2C0.2-1.3%2C0.9-1.5%2C1.6c-0.2%2C0.8%2C0%2C1.6%2C0.5%2C2.2l1%2C1.2H22.8c-1%2C0.1-1.7%2C0.9-1.7%2C1.8v0.9c0%2C1%2C0.7%2C1.8%2C1.7%2C1.8h19.3l-1%2C1.2%0A%09c-0.5%2C0.6-0.7%2C1.4-0.5%2C2.2c0.2%2C0.8%2C0.7%2C1.4%2C1.5%2C1.6c0.7%2C0.2%2C1.5%2C0%2C2-0.6l4.6-5.1c0.8-0.9%2C0.8-2.3%2C0-3.2L44%2C41z%20M23.5%2C32.8%0A%09c-1%2C0.1-1.7%2C0.9-1.7%2C1.8v0.9c0%2C1%2C0.7%2C1.8%2C1.7%2C1.8h23.4c1-0.1%2C1.7-0.9%2C1.7-1.8v-0.9c0-1-0.7-1.8-1.7-1.9L23.5%2C32.8L23.5%2C32.8z%22/%3E%0A%3C/svg%3E%0A',
           //'COLOR' => '#1900ff',
           //Возможно
           'SIZE' => '90%',
           'POSITION' => 'center'
        ),
        //ID компонент
        'COMPONENT' => 'bitrix:imconnector.baseconnector',
        //Можно ли удалять пришедшие сообщения
        'DEL_EXTERNAL_MESSAGES' => true,
        //Может ли оператор редактировать свои сообщения
        'EDIT_INTERNAL_MESSAGES' => true,
        //Может ли оператор удалять свои сообщения
        'DEL_INTERNAL_MESSAGES' => true,
        //Можно ли использовать канал для рассылки?
        'NEWSLETTER' => true,
        //Можно ли отправлять системные сообщения в канал?
        'NEED_SYSTEM_MESSAGES' => true,
        //Стоит ли отправлять в канал подпись в самом тексте сообщения?
        'NEED_SIGNATURE' => true,
        //Является ли чат групповым?
        'CHAT_GROUP' => false,
     );
  }
}

Обработчик должен вернуть массив со следующими параметрами:

Возвращаемые параметры
Параметр | Описание
ID | ID коннектора, который будет уникальный на всю систему. Обязательный. Лучше предварять своим префиксом дабы избежать пересечения с текущими и возможными будущими ID коннекторов. Можно использовать: цифры, буквы и знак подчеркивания.
NAME | Отображаемое имя коннектора. Обязательный.
ICON Массив описания иконки коннектора. Обязательный. Ключи массива:
  • DATA_IMAGE - DATA представление иконки SVG. Можно использовать сервис http://www.grumpicon.com/ для конвертации. Обязательный
  • COLOR - цвет
  • SIZE - размер
  • POSITION - позиция svg
COMPONENT | ID компонента с указанием имени пространства имен компонентов. Обязательный.
DEL_EXTERNAL_MESSAGES | Можно ли удалять входящие сообщения? По умолчанию: да.
EDIT_INTERNAL_MESSAGES | Можно ли редактировать свои сообщения? По умолчанию: да.
DEL_INTERNAL_MESSAGES | Можно ли удалять свои сообщения? По умолчанию: да.
NEWSLETTER | Можно ли использовать канал для CRM рассылки? По умолчанию: да.
NEED_SYSTEM_MESSAGES | Можно ли отправлять системные сообщения в канал? Например: приветствие, завершающая реплика и т. п. По умолчанию: да.
NEED_SIGNATURE | Можно ли отправлять подпись в самом сообщении? По умолчанию: да. Например: перед текстом сообщения добавляется строка с именем оператора.
CHAT_GROUP | Является ли чат данного канала с внешней стороны групповым, т. е. могут ли разные люди писать из вне в один чат? По умолчанию: нет.

Настройка канала:

Тип коннектора работает в рамках настроенной открытой линии. Со своей стороны необходимо хранить информацию об ID открытой линии, которая настроена.

В состав модуля включён компонент imconnector.baseconnector, который можно использовать как основу для кастомизации и создания собственного компонента настройки.

Собственный компонент должен работать в режиме ajax и не приводить к перезагрузке страницы. Также в компонент передается параметр $this->arParams['LINE'], в котором передается ID открытой линии.

В компоненте производится настройка, которая важна и нужна для вашего кода, запрашиваются дополнительные параметры (либо же не запрашиваются, а вы просто при включении канала регистрируете еще одну ОЛ.

Системе важно, чтобы вы правильно установили статусы. За это отвечает класс \Bitrix\ImConnector\Status.

Получить объект статуса можно вызовом:

 $this->status = \Bitrix\ImConnector\Status::getInstance($this->connector, $this->arParams['LINE']);

$this->status->isStatus(); - метод возвращает, готов ли коннектор к работе.
$this->status->getActive() - активирован ли канал.
$this->status->getConnection() - успешно ли прошло соединение.
$this->status->getRegister() - успешно ли прошла регистрация.
$this->status->getError() - есть ли ошибка в работе (блокирующая).

Канал считается готовым к работе, если канал для данной Открытой Линии активен, успешно прошло тестовое соединение и успешно зарегистрирован. А так же отсутствует ошибка.

Активировать канал можно вызовом $this->status->setActive(true);
Установить статус успешной проверки подключения: $this->status->setConnection(true);
Установить статус успешной регистрации: $this->status->setRegister(true);
Сбросить ошибку (чтобы канал возобновил работу) можно с помощью $this->status->setError(false);.

При удалении коннектора (отключении) нужно вызвать статический метод:

\Bitrix\ImConnector\Status::delete($this->connector, $this->arParams['LINE']);

При любых изменениях настроек нужно сбрасывать кеш информации о каналах:

$cache = \Bitrix\Main\Data\Cache::createInstance();
$cache->clean($this->arParams['LINE'], \Bitrix\ImConnector\Library::CACHE_DIR_INFO_CONNECTORS_LINE);

Либо можно использовать метод cleanCache из примера в компоненте.

Работа с сообщениями

После настройки канала для работы с сообщениями используйте методы класса CustomConnectors.

Так же используйте события для новых сообщений, их изменений или удаления.


Контроллер сайтов
489 / 694
Контроллер - модуль, который предназначен для группового централизованного администрирования, обновления, мониторинга большого количества сайтов, расположенных как на этом же сервере, так и на удаленных серверах доступных через Интернет. Контролируемых сайтов может быть любое количество и они должны быть разработаны на базе продукта «1С-Битрикс: Управление сайтом» (любой редакции).


Возможности и функционал Контроллера сайтов
490 / 694

Возможности модуля по управлению подчиненными сайтами:

Возможности модуля по управлению подчиненными сайтами

  1. Управление множеством независимых веб-сайтов.

    Контроллер сайтов позволит вам централизованно управлять веб-сайтами, даже если они:

    • физически размещены на различных хостинг-площадках;
    • каждый сайт полностью независим и администрируется отдельной группой сотрудников;
    • сайты разработаны на различных редакциях «1С-Битрикс: Управление сайтом» и обладают различным функционалом.

  2. Администрирование подчиненных сайтов без необходимости знать параметры учетных записей на каждом сайте.

    Администратор контроллера может зайти на любой подчиненный сайт и выполнить необходимые действия. При этом неважно, какие права на веб-сайт установят локальные администраторы. Кроме этого, администратор контроллера может централизованно запустить любую операцию, которая будет выполнена на подчиненных проектах: изменение прав, обновление ядра и т.п.

  3. Централизованная раздача (трансляция) контента на подчиненные сайты.

    С помощью контроллера можно транслировать на подчиненные сайты:

    • единый каталог товаров, который подготовлен и оформлен в головном офисе;
    • единый шаблон дизайна веб-ресурса, выполненный в соответствии с фирменным стилем компании;
    • единую ленту новостей/событий/мероприятий;
    • общую функциональность (конфигуратор, система расчета, калькулятор);
    • и многое другое.

  4. Единая система авторизации и разграничения доступа между всеми веб-сайтами, связанными контроллером.

    Контроллер позволяет объединить списки групп пользователей между всеми подчиненными веб-сайтами и обеспечить работу с ними в режиме единой авторизации (Single Sign On). Если все сайты - независимые интернет-магазины, сообщества, социальные сети или любые другие веб-ресурсы, то посетителям достаточно знать только один логин и пароль для работы с ними.

Функционал по работе с модулем Контроллер сайтов расположен в секции Сервисы административного раздела.

Сайты - функционал по работе с сайтами, добавленными в контроллер: включение, исключение сайтов, управление активностью и другими настройками.

Группы - операции по управлению групповыми настройками сайтов, подключенных к контроллеру. Ограничение функционала подчиненных сайтов и прав локальных администраторов. Настройки модулей подчиненных сайтов.

Задачи - планировщик задач. Содержит список задач, выполненных или ожидающих исполнения в ближайшее время на подчиненных контроллеру сайтах.

Журнал - полный отчет по действиям администратора контроллера над подчиненными сайтами.

Удаленное выполнение команд - функционал по выполнению произвольного PHP кода на заданном множестве подчиненных сайтов.

Передача файла - передачи файлов на подчиненные сайты.

Счётчики - инструмент для выполнения на удалённых сайтах определённого php-кода в заданный период времени.

Авторизация - настройка авторизации пользователей на подчинённых сайтах.

Документация по теме:

  • Контроллер


Настройки модуля
491 / 694
Глобальные параметры модуля определяются на странице настроек Контроллер (Настройки > Настройки продукта > Настройки модулей > Контроллер):
  • на закладке Настройки указываются общие параметры модуля:

    Настройки модуля Контроллер

    Опция Интервал для автоматической установки групповых настроек на клиентские сайты, по умолчанию, минут позволяет задать интервал времени в минутах для автоматической установки групповых настроек на клиентские сайты по умолчанию. Если указано 0, то настройки клиентов не будут обновляться автоматически.

    Примечание: Если имеются клиенты, использующие общее с контроллером ядро (например, редакция Платформа аренды приложений продукта или Бизнес веб-кластер), то дополнительно будет доступна опция Путь к папке с общим ядром (относительно корня сайта-контроллера).

    Подробнее про общее ядро можно посмотреть в статье Установка платформы аренды приложений, раздел 5.6 Выделяем из нашей установки общее ядро.

  • на закладке Доступ можно настроить права на доступ к модулю для всех имеющихся в системе групп пользователей.

Документация по теме:

  • Настройки модуля


Сайты
492 / 694
На странице Сайты (Сервисы > Контроллер > Сайты) администратору контроллера отображается список всех сайтов, подчиненных контроллеру.

Сайт может присутствовать в списке, но быть отключенным от контроллера, если это потребовалось администратору.

Администратор может деактивировать сайт вручную или задать период его активности, когда контроллер автоматически будет сверять период с текущей датой и временем на сервере.

Поддерживается неограниченное количество подчиненных сайтов.

Внимание! Если подчиненный сайт подключен к контроллеру и неактивен, значит, он недоступен для любых посетителей.

Меню действий

Основные операции с подчиненными сайтами выполняются через меню действий.

Примечание: Некоторые пункты меню доступны только для подключенного сайта.

  • Редактировать - переход к форме редактирования параметров сайта;

    Примечание: Для изменения параметров уже подключенного сайта используется форма схожая с формой Регистрация нового клиента , но в ней будет доступна дополнительная вкладка Счетчики.

  • Войти как Администратор - переход в публичный раздел сайта-клиента в качестве администратора.
  • Обновить сайт - установка обновлений на сайт клиента. При использовании этой функции автоматически создастся задача на обновление. Запуск процесса обновления производится со страницы Задачи. Результат обновления виден в Журнале.
  • Обновить настройки - выполнение установки настроек на сайт клиента.
  • Обновить счётчики - обновление счётчиков, заданных для группы сайтов , к которой относится выбранный клиент.
  • Выполнить PHP - переход на страницу удаленного выполнения команды для данного сайта.
  • Лог операций - переход на страницу журнала работы контроллера с установленным фильтром на данном клиенте.
  • Отсоединить - отключение клиента от контроллера. (Отсоединение так же возможно и в форме редактирования клиента с помощью кнопки Отсоединить на контекстной панели.)
  • Удалить - удаление записи данного клиента.

    Примечание:

    Если при удалении клиент не был отсоединен, то запись об этом клиенте из контроллера будет удалена, а сам сайт будет работать с теми настройками, которые были установлены контроллером.

    Если же перед удалением клиент был отсоединен, то на сайте будут возвращены настройки, установленные до подключения к контроллеру.

Подключение подчиненного сайта к контроллеру

Для подключения сайта к контроллеру необходимо выполнить следующее:

  • Нажать кнопку Добавить на контекстной панели страницы Сайты
  • Заполнить поля формы Регистрация нового клиента

    Регистрация нового клиента

    • URL-адрес сайта и его название

      Именно по URL-адресу контроллер впоследствии обращается к удаленному сайту и выполняет все настройки, ограничения и команды. Название и описание помогают ориентироваться в списке сайтов.

    • Логин и пароль администратора

      Знание параметров учетной записи администратора - это первичное условие для подключения самостоятельного сайта к контроллеру. Иными словами, владельцы удаленного сайта, предоставляя административные права администратору контроллера, фактически дают свое согласие на удаленный режим управления их веб-проектом. Тем не менее, рекомендуется дополнительно оформлять данное соглашение юридически.

    • Группа

      Привязка сайта к определенной группе означает автоматическое применение к нему всех групповых настроек и политик безопасности, которыми эта группа обладает.

      По умолчанию сайт привязывается к группе, указанной в настройках модуля.

      Примечание: Если сайт привязывается к новой группе, то соответствующая ей политика безопасности будет применена к сайту на основании настроек заданной группы.
    • Активность

      Администратор контроллера может управлять активностью подключаемого сайта. Активность сайта фактически означает его работоспособность, т.е. возможность принимать и обрабатывать запросы клиентов. Активность может быть установлена на заданный период времени, если, например, предполагается оплачиваемый период удаленного управления или решаются другие задачи.

    • Чтобы сайт-клиент был открыт для доступа посетителям, необходимо отметить опцию Активен (открыт для доступа посетителям).
    • С помощью опции Период активности можно задать период, в течение которого подключаемый сайт будет активен.
  • Нажать кнопку Сохранить. В случае удачного подключения к сайту, он будет отображен в списке сайтов.
Примечание: При редактировании параметров сайта будет доступна еще одна закладка - Счетчики, на которой отображается следующая информация о подчиненном сайте:

Обновление данных происходит как вручную (с помощью ссылки [обновить]), так и автоматически, но при условии, что в настройках группы (Сервисы > Контроллер > Группы) на закладке Счетчики отмечены опции для получения соответствующей информации.

Подробное описание всех полей формы можно посмотреть в пользовательской документации.

Также возможен вариант подключения сайта к контроллеру непосредственно из административной части подчиненного сайта (если на нем не установлен модуль Контроллер).

Для этого:
  • Перейдите на страницу настроек Главного модуля подчиненного сайта, секция Служебные процедуры, закладка Контроллер:

    Cекция Служебные процедуры

    • Примечание: Закладка отображается только в случае, если в системе не установлен модуль Контроллер.

  • Укажите параметры подключения к сайту-контроллеру: URL контроллера, Логин администратора контроллера и Пароль администратора контроллера;
  • Укажите параметры подключаемого сайта: Название текущего сайта и URL сайта;
  • Задайте Настройки прокси (если требуется) и нажмите кнопку Сохранить настройку прокси;
  • Нажмите кнопку Добавить этот сайт к контроллеру.

Если неверно или не полностью заполнены данные, будет выведено соответствующее уведомление.

Важно! Если на управляющем сайте включена Защита административной части , то не забудьте внести IP подчиненного сайта в список разрешенных, иначе при работе с подчиненным сайтом через контроллер может возникнуть ошибка Ответ контроллера подписан некорректно.

Документация по теме:

  • Управление подчиненными сайтами


Группы
493 / 694
Для облегчения управления множествами подчиненных сайтов администратору контроллера предлагается возможность их размещения в группах, для каждой из которых можно установить требуемую групповую политику.

На странице Группы (Сервисы > Контроллер > Группы) находится список всех групп, присутствующих в контроллере.

Меню действий

Для каждой группы в меню действий доступны следующие пункты:

  • Редактировать - переход к форме редактирования параметров группы сайтов;
  • Копировать - копирование группы сайтов;
  • Удалить - удаление группы.

    Примечание: Удаление группы, к которой относится хотя бы один сайт, а также группы, используемой по умолчанию, невозможно.

Создание группы

Для создания новой группы необходимо выполнить нажать кнопку Добавить на контекстной панели страницы Группы и заполнить поля формы:

  • Закладка Параметры

    На вкладке Параметры, помимо названия и описания группы, доступна группа параметров Обновление настроек у сайтов данной группы.

    Дело в том, что многие настройки группы подразумевают соответствующее изменение настроек на удаленном сайте. Например, права доступа локальных групп пользователей или список активных модулей. В этой связи изменение настроек группы заставляет модуль Контроллер сайтов обратиться к каждому из удаленных веб-проектов, авторизоваться, установить сеанс удаленного управления и выполнить необходимые команды. Поэтому если к группе привязано большое количество веб-проектов, то изменение ее настроек может инициировать очень ресурсоемкий процесс, сопряженный с большой нагрузкой на сам контроллер.

    Для решения этой проблемы был предусмотрен механизм отложенного применения групповых настроек. При сохранении группы с новыми настройками, задачи перенастройки параметров каждого сайта помещаются в планировщик задач и исполняются с равномерной нагрузкой на сервер в течение указанного в параметре Период автоматического обновления установок на клиенте, минут значения.

  • Закладка Модули

    В данном диалоге можно управлять списком модулей, которые будут активны на подчиненных сайтах текущей группы.

    Термин Неактивный модуль означает, что данный модуль на удаленном сайте исключен из функциональности. Это не означает его деинсталляцию в продукте, включая удаление связанных с ним данных. Модуль просто исключается из визуализации в административной панели и прекращает свою работу (не отвечает на запросы ядра).

    Зачастую не все модули приобретенной редакции используются в интернет-проекте и в этом случае исключение этих модулей из административной части избавляет техническую поддержку от массы лишних вопросов, а веб-проект - от непреднамеренного внесения ошибок.

  • Закладка Настройки модулей

    Данная закладка позволяет задать некоторые параметры настройки Главного модуля и настройки модуля Управление структурой на подчиненном веб-проекте:

    • Автокеширование компонентов - не позволяет локальному администратору переключать настройку автокеширования в компонентах, тем самым влияя на производительность и визуализацию динамического контента.
    • Режим вывода ошибок - настройка визуализации ошибок на удаленном сайте. Поставив Ошибки и предупреждения, локальный администратор может инициировать вызов служебных сообщений PHP в публичной части сайта, что нецелесообразно. Данная настройка может этому воспрепятствовать. Возможны и другие примеры использования этой настройки.
    • E-mail адреса для дублирования исходящих писем - используется при необходимости администратору контроллера получать на заданный e-mail все почтовые сообщения, генерируемые веб-проектами, отнесенными к данной группе.
    • Дисковая квота - максимальный размер дискового пространства, занимаемый веб-сайтами, отнесенными к данной группе. В рассмотрение включается и размер публичных файлов, включая содержимое папок /bitrix/ и /upload/, и размер базы данных веб-проекта. При превышении дисковой квоты удаленный веб-сайт будет генерировать сообщения об ошибках при операциях добавления новых данных.
    • Настройки регистрации новых пользователей в удаленных проектах позволяют администратору контроллера разрешить или запретить самостоятельную регистрацию новых пользователей на удаленном сайте, разрешить/запретить запоминание авторизации, принудительно включить CAPTCHA для защиты от автоматических регистраций и др. настройки.
    • Настройки системы обновлений позволяют указать настройки обращения к серверу обновлений для сайтов, отнесенных к данной группе. Это может быть стандартный сервер обновлений компании «1С-Битрикс» либо произвольный сервер (например, сам контроллер), с которого локальные веб-сайты будут скачивать обновления ядра и модулей продукта.
    • Список Доступные компоненты в визуальном редакторе дает возможность администратору контроллера указать список компонентов, которыми могут оперировать пользователи подчиненного сайта. Минимально необходимый список компонентов исключит возможность ошибок и некорректного отображения страниц удаленного веб-сайта.

    Внимание! Перечисленные настройки контроллера имеют приоритет над локальными настройками сайтов, подключенных к контроллеру. Пока сайт подключён к контроллеру, будут действовать настройки контроллера. При отключении сайта от контроллера вступят в силу локальные настройки.

    Примечание: Недостающие настройки можно реализовать с помощью PHP-скриптов инсталляции/деинсталляции групповой политики на закладке Дополнительно.

  • Закладка Права доступа.

    На данной закладке администратору контроллера предоставляется возможность внести изменения в стандартную систему разграничения прав доступа на сайте, включенном в контроллер.

    Все эти настройки помогают исключить возможность внесения нежелательных изменений локальными пользователями при управлении сайтом.

    При установленном флаге Отнимать полный доступ у администраторов можно задать для администраторов локальных сайтов иные права на модули, чем предусмотрено локальными настройками сайтов.

    Аналогичным образом администратор контроллера может переопределить права и для других групп на подчиненном сайте.

  • Закладка Счетчики

    На данной закладке можно выбрать счетчики и указать период их автоматического обновления.

    Примечание: Кроме периодического обновления счётчики могут обновляться вручную, а также при смене группы.

    Информация по ним будет доступна в режиме редактирования сайта (Сервисы > Контроллер > Сайты) на закладке Счетчики.

  • Закладка Дополнительно

    На данной вкладке предоставляется возможность указать PHP-скрипты, которые будут выполнены на подчиненных сайтах при установке или отмене данной групповой политики.

    Данная закладка - это расширение настроек групповой политики, которые были перечислены выше. Технический специалист, используя документацию к продукту, может самостоятельно разработать любой функционал, который будет выполнен на удаленном сайте при установке или отмене этой групповой политики.

  • Закладка Доп. поля.

    На закладке создаются пользовательские поля для группы сайтов. При копировании группы пользовательские поля так же копируются.

Документация по теме:

  • Управление группами сайтов
  • Создание и редактирование группы сайтов


Задачи
494 / 694

Какие задачи могут быть запланированы и выполнены?

Планировщик задач - это специализированный инструмент, который накапливает задания, формируемые остальным функционалом контроллера, и выполняет их в ручном или автоматическом режиме.

Могут быть выполнены следующие задачи:
  • установка групповых настроек;
  • обновление сайта;
  • обновление счетчика;
  • выполнение команды;
  • закрытие/открытие клиентов.

В случае если к моменту обращения к данной странице в планировщике есть невыполненные задачи, они немедленно будут запущены на выполнение на удаленных сайтах.

Также возможно использование агентов (или cron), которые будут исполнять задачи на основании заданного расписания (например, в ночное время, при минимальной нагрузке на подчиненные веб-проекты).

Документация по теме:

  • Задачи для выполнения на клиентах контроллера сайтов


Журнал и история
495 / 694
Функционал Журнал (Сервисы > Контроллер > Журнал) предназначен для отладки работы.

В нём фиксируются результаты выполнения всех операций над сайтами, включенными в контроллер, в том числе: журналирование примечаний при смене группы и обновление счетчиков при занесении заметки в журнал.

Для просмотра изменений по конкретному сайту можно воспользоваться функционалом История с помощью одноимённой кнопки на контекстной панели в форме редактирования клиента.

По этой команде откроется список операций, совершённых над сайтом:

Доступна история событий:

  • изменение активности сайта;
  • изменение группы сайта.

Документация по теме:

  • Журнал работы контроллера сайтов
  • История изменений на клиенте


Удаленное выполнение команд
496 / 694
Интерфейс удаленного выполнения произвольных команд на удаленных сайтах (Сервисы > Контроллер > Удаленное выполнение команд) представлен в виде следующей формы:

Администратор контроллера может указать произвольный PHP скрипт, который должен быть исполнен на удаленном проекте (в фильтре предоставляется возможность указать группу сайтов или конкретный сайт).

Операции, выполняемые скриптом, могут быть совершенно произвольными. Все то, что возможно выполнить с помощью API, доступно для выполнения на удаленном проекте:

  • изменение параметров сайта;
  • изменение структуры сайта;
  • добавление произвольного контента: разделы и страницы, новости, каталог и другая динамическая информация;
  • и т.п.

Опция Выполнить команду через планировщик задач дает возможность исполнения скрипта не непосредственно после нажатия кнопки Выполнить, а посредством планировщика задач. Общая задача будет разбита на множество задач для каждого сайта и выполнена последовательно на каждом удаленном веб-проекте.

Выполнение команд для числа сайтов более 50 требует подтверждения. Возможно изменение числа сайтов, подачу команд для которых надо подтверждать:

Option::SetOptionString("controller", "safe_count", 9999999);

Документация по теме:

  • Удаленное выполнение команд


Передача файла
497 / 694
Страница Передача файла на подключенные сайты (Сервисы > Контроллер > Передача файла) служит для отправки файлов на сайты-клиенты контроллера. Файл можно передать на какой-то конкретный сайт, на сайты определенной группы или же на все подчиненные сайты сразу.

Передача файла на подключенные сайты

Для передачи файла:

  • Выберите в фильтре подчиненный сайт, на который необходимо передать файл;

    Примечание: В расширенном фильтре можно также выбрать и группу сайтов, на которые будет происходить передача файлов.

  • В поле Откуда укажите путь к файлу, расположенному на сайте-контроллере;
  • В поле Куда укажите путь на подчиненном сайте, куда будет скопирован файл;

    • Примечание: Если на подчиненных сайтах нет указанного каталога, то он будет создан автоматически.

  • Нажмите кнопу Передать.

После операции передачи файла под таблицей будет отображено название сайта, для которого она выполнялась или же, в случае неудачной передачи, текст ошибки.

Документация по теме:

  • Передача файлов


Счётчики
498 / 694
Модуль Контроллер позволяет создавать и применять на сайтах счётчики.

Счётчик - инструмент для выполнения на удалённых сайтах определённого php-кода в заданный период времени.

В системе созданы и могут быть применены к группам сайтов 4 штатных счётчика:

  • Размер свободного дискового пространства
  • Количество сайтов
  • Количество пользователей
  • Дата последней авторизации

На странице Сервисы > Контроллер > Счётчики можно создать и отредактировать собственные счётчики.

Параметры счётчика настраиваются на странице редактирования конкретного счётчика, параметры запуска - на странице редактирования группы сайтов.

Создание и настройка запуска

Открыв форму создания счётчика, заполните его поля:

Для настройки запуска счётчика откройте форму редактирования группы сайтов (Сервисы > Контроллер > Группы) на закладке Счётчики:

Отметьте нужные для данной группы сайтов счётчики и установите периодичность их запуска. Результаты работы отображаются в форме сайта, подчиненного контроллеру, на закладке Счётчики.

История изменений

Каждый счётчик ведёт свою историю изменений. Для её просмотра воспользуйтесь кнопкой История в форме редактирования Счётчика. Откровется история изменений счётчиков:

Примеры кодов счётчиков

Пользователи экстранета

$counter = 0;
$rsUsers = CUser::GetList($o="ID", $b="asc", array("ACTIVE"=>"Y","=UF_DEPARTMENT"=>false), array("SELECT"=>array("ID")));
while($arUser = $rsUsers->Fetch())
  if($arUser["EXTERNAL_AUTH_ID"] !== "__controller")
    $counter++;
return $counter;

Выставление лимита в 5GB (Тип - Число, формат - как размер файла)

$max_size = 5*1024*1024*1024;
COption::SetOptionString("main_size", "~max_size", $max_size);
return $max_size;

Объем файлов в облаке (Тип - Число, формат - как размер файла)

$file_size = 0.0;
if(CModule::IncludeModule('clouds'))
{
  $rsBuckets = CCloudStorageBucket::GetList();
  while($arBucket = $rsBuckets->Fetch())
    $file_size += $arBucket["FILE_SIZE"];
}

COption::SetOptionString("main_size", "~cloud", $file_size);
$params = array("status" => "d", "time" => time());
COption::SetOptionString("main_size", "~cloud_params", serialize($params));

return $file_size;

Документация по теме:

  • Счетчики
  • Создание счетчика


Авторизация
499 / 694
Страница Авторизация (Сервисы > Контроллер > Авторизация) позволяет настроить авторизацию пользователей на подчинённых сайтах, между подчинёнными сайтами и на контроллере.

Для задания параметров авторизации необходимо выбрать нужный вид авторизации, установить флажок, разрешающий авторизацию и задать соответствие групп между сайтами с помощью Символьных идентификаторов. Символьный идентификатор группы задаётся в настройках группы, в одноимённом поле.

Примечание: даже если Символьные идентификаторы не заданы, то группу Администраторы и Все пользователи (в том числе не авторизованные) всегда можно задать используя коды administrators и everyone соответственно.

Кроме того, необходимо выполнить настройки авторизации и на подчиненных сайтах. В настройках главного модуля подчиненного сайта на закладке Журнал событий доступны следующие параметры:

  • Префикс для авторизации на контроллере - указывается префикс, который будет использоваться для авторизации пользователей контроллера на этом подчиненном сайте.
  • Авторизовывать на этом сайте пользователей других сайтов контроллера - при отмеченной опции пользователи других сайтов контроллера смогут авторизовываться на этом сайте, причем обязательно должна быть разрешена авторизация между подчиненными сайтами на контроллере и настроено соответствие групп (см. выше).

Если разрешена авторизация пользователей контроллера на подчиненных сайтах, задано соответствие групп пользователей и указан префикс для авторизации на контроллере, например controller, то при заходе на подчиненный сайт пользователь должен указать в качестве логина controller\логин_на_контроллере и в качестве пароля пароль_на_контроллере. Пользователь авторизуется, причем на подчиненном сайте будет создан локальный пользователь с соответствующими именем и правами.

Если разрешена авторизация пользователей подчиненных сайтов на контроллере и задано соответствие групп пользователей, то при заходе на контроллер пользователь должен указать в качестве логина доменное_имя_подчиненного_сайта\логин_на_сайте и в качестве пароля пароль_на_сайте. На контроллере будет создан локальный пользователь с соответствующими именем и правами.

Пример

Пользователь, принадлежит группе Сотрудники техподдержки на сайте-контроллере. На странице Авторизация сайта-контроллера, на закладке На подчинённых сайтах задано, что группа Сотрудники ТП соответствует группе Администраторы магазина на подчинённом сайте.

В результате, пользователь, авторизуясь на подчинённом сайте под логином сайта-контроллера (даже если он и не имеет аккаунта на этом сайте), приобретает права группы Администраторы магазина, даже если он и не входит в эту группу.

Примечание: администраторы контроллера всегда могут авторизовываться на подчиненных сайтах с наивысшими правами. При подключении сайта к контроллеру на подключенном сайте создается локальный пользователь-администратор, пароль от которого в зашифрованном виде хранится на контроллере.

Документация по теме:

  • Авторизация


Публикация новостей с контроллера на подключенных сайтах
500 / 694
Идея публикации новостей заключается в формировании на контроллере xml файла, передаче его на подключенные к контроллеру сайты и импорте метаданных инфоблока и значений полей/свойств элемента.

Внимание! Есть вероятность того, что большие по объему новости не будут опубликованы на подчиненном сайте. Это зависит от настроек сайта и хостинга, так как вся новость передается в большом POST запросе.

Внимание! Действие по публикации новостей требует на клиенте версию главного модуля не ниже 11.0.9.

Для публикации новостей с контроллера на подключенных сайтах выполните следующее:

  • Подключите к контроллеру сайт, на который будут транслироваться новости
  • На контроллере и на подключенных сайтах в настройках модуля инфоблоков (по крайней мере, на время) отметьте опцию Показывать код загрузки из внешних источников

    Показывать код загрузки из внешних источников

  • Настройте инфоблок на контроллере:

    Укажите Символьный код - именно по нему будет выполняться синхронизация элементов;

    В поле Участвует в документообороте или бизнес процессах выберите опцию Бизнес процессы;

    Настройка инфоблока на контроллере

    Затем нажмите кнопку Применить.

    На появившейся вкладке Шаблоны бизнес-процессов для бизнес-процесса Публикация на подключенных сайтах отметьте опции Создание и Изменение и сохраните изменения настроек инфоблока.

  • На подключенном сайте создайте инфоблок с таким же значением внешнего кода, как и на контроллере. Кроме привязки к сайту, названия и внешнего кода настройте и права доступа к инфоблоку.

    Создайте страницу, если необходимо, и разместите на ней компонент Новости, в настройках которого укажите созданный инфоблок.

  • На сайте контроллера добавьте новость

  • После чего на подключенном сайте появится новость


Частые вопросы
501 / 694

Компании необходимо несколько интернет-проектов по различным тематикам. Необходимо использовать "контроллер сайтов" или воспользоваться "многосайтовостью" стандартных редакций?

Если управление всеми интернет-проектами будет сосредоточено в "одних руках" и все проекты могут быть размещены на единой хостинг-площадке, то выгоднее использовать "Многосайтовость".

Если каждым веб-проектом управляют отдельные структуры, и требуется полная независимость одного сайта от другого, но при этом существует необходимость глобального централизованного управления ими, то единственным решением будет использование "контроллера сайтов". Кроме того, контроллер необходим, если проекты физически размещаются на различных хостинг-площадках (например, региональные веб-ресурсы, которые работают с локальным трафиком).

Если сайт, на котором размещен "контроллер", прекратит свою работу, скажется ли это на подчиненных ему проектах? И наоборот?

Нет, все сайты независимы друг от друга. Если выйдет из строя контроллер, сайты продолжат работу в обычном режиме с теми настройками, которые были установлены администратором контроллера. Если выйдет из строя подчиненный сайт, то на работе контроллера это также не скажется.

Есть два инфоблока на контроллере: первый с элементами, которые нужно будет реплицировать на подчиненный сайт, и второй - с разделами, к которым привязаны эти же элементы первого инфоблока (свойство привязки к разделам инфоблока). Возможно ли сделать так, чтобы элементы первого инфоблока не теряли привязки к разделам второго инфоблока на подчиненном сайте?

Для этого достаточно совпадения внешних кодов (xml_id) разделов второго инфоблока на контроллере и подчиненном сайте. Необходимо выполнить xml экспорт разделов второго инфоблока на контроллере и импортировать этот файл на подчиненный сайт.

Если на контроллере добавляется новое свойство инфоблока, то будет ли оно при обмене автоматически создано на подчиненном сайте?

Да, будет.


Масштабирование
502 / 694

Масштабирование сервера позволяет добиться отказоустойчивой системы в условиях возрастающей нагрузки.


Управление масштабированием
503 / 694

Масштабирование сервера позволяет добиться отказоустойчивой системы в условиях возрастающей нагрузки.

Внимание! Для работы модуля Управление масштабированием установите «1С-Битрикс» версии 14.5 и выше на одно из специальных Битрикс VM-решений:
  1. 1C-Битрикс: Виртуальная машина в версии не ниже 5.х. Рекомендуется 7.х.
  2. 1С-Битрикс: Веб-окружение - Linux в версии не ниже 5.x. Рекомендуется 7.х.
  3. Virtuozzo Application Template для запуска оптимизированного VPS «Битрикс».
  4. AMI-образ BitrixVM для быстрого запуска приложений «1С-Битрикс» в Amazon EC2.

Где производится управление

Панель управления (Настройки > Управление масштабированием > Панель управления) - инструмент непосредственного управления масштабированием системы.

Для начала работы системы масштабирования добавьте сервер , после чего система готова к работе:

Нажмите на рисунок, чтобы увеличить


Добавление нового сервера
504 / 694

Добавление сервера на локальной машине

Для добавления новых серверов в пул нужно кликнуть на область Новый сервер , указать сетевой адрес, пароль пользователя root и имя хоста добавляемого сервера:

Внимание! Если на подключаемом сервере, работающем на одном из специальных Битрикс VM-решений, не был сменен пароль по умолчанию для root, то система предложит это сделать .

После этого нужно будет повторно ввести данные сервера для включения его в пул.

Добавление сервера на хостинге

Если виртуальная машина или окружение «1C-Битрикс» уже настроены и располагаются на площадке провайдера, то в меню добавления сервера появится возможность выбора сервера из предлагаемых хостером:

Далее уже можно отслеживать статусы заказа сервера у провайдера на странице Список заказов VPS (Настройки > Управление масштабированием > Список заказов).


Глобальные действия
505 / 694

Самые общие команды

В меню Глобальные действия собраны команды, чьё действие распространяется на все серверы, входящие в пул:

  • Включить мониторинг
  • Добавить сайт
  • Удалить сайт
  • Настроить e-mail
  • Отключить cron
  • Отключить http
  • Настройка сертификатов
  • Команды обновлений
    •

    Внимание! Команды могут выполняться довольно длительное время (от одной минуты до 2-3 часов и более) в зависимости от сложности задачи, объема данных, используемых в этих задачах, мощности и загруженности сервера. Во время выполнения команды другой функционал будет недоступен, о чем будет выведено сообщение .

    Включить мониторинг

    Пункт меню Включить мониторинг позволяет включить инструмент визуального мониторинга для каждого сервера в пуле:

    Нажмите на рисунок, чтобы увеличить

    Примечание: Подробные графики нагрузки для каждого сервера в пуле можно увидеть на странице Графики нагрузки .

    Добавить сайт

    Сайт можно добавлять как ссылку и как сайт на отдельном ядре. Сайт в виде ссылки подходит для большинства случаев. Сайт в виде отдельного ядра рекомендуется добавлять если у вас много сайтов на одном ядре.

    Для добавления сайта-ссылки нужно ввести Ядро, Название сайта и Путь к сайту

    Для добавления сайта на отдельном ядре нужно ввести дополнительные данные по типу сайта, базе данных и кодировке сайта. Тип сайта kernel - это ядро с файлами веб конфигурации. Тип сайта ext_kernel - когда ядро расположено вне папки сайта и к нему обращаются по символическим ссылкам .

    После отработки команды на сервере будет создана директория /home/bitrix/ext_www/{путь к сайту} с символическими линками на текущее ядро сайта и общей базой данных с основным сайтом (аналогично установке с ключом link из меню BitrixVM v7.x).

    Удалить сайт

    При удалении нужно выбрать сайт из списка пула. После отработки команды сайт будет удален из системы.

    Внимание! Мастер удаления дополнительного сайта удаляет папку /home/bitrix/ext_www/{путь к сайту} и базу данных дополнительного сайта, поэтому необходимо предварительно сделать бекап важных данных.

    Настроить e-mail

    Для настройки почты выберите сайт из списка пула и ввести необходимые данные для smtp-сервера:

    Отключить cron

    Для отключения cron выберите сайт из списка пула. Теперь все события на данном сайте будут выполняться на агентах. Для включения cron для этого сайта используйте появившейся пункт меню [Установить cron].

    Отключить http

    По умолчанию доступ к сайтам разрешен по протоколам http и https. Для отключения протокола http просто выберите сайт из списка пула. Теперь все данные на сайте будут передаваться только по защищенному протоколу https.

    Чтобы включить снова http для этого сайта, выберите появившейся пункт меню Включить http

    Настройка сертификатов

    Для настроек сертификатов выберите тип сертификата и сайт , для которого устанавливается сертификат. Далее введите нtобходимые данные для самоподписного либо Let's Encrypt сертификата.

    Команды обновлений

    Команды обновлений :

    • Обновить Битрикс окружение - обновление серверного ПО «Битрикс Веб-окружения» одновременно на всех серверах пула.
    • Обновить систему на серверах - обновление одновременно на всех серверах пула как серверного ПО, так и "1С-Битрикс: Управление сайтом".

    Внимание! Обновления - сложная операция, в процессе которой происходит обновление системных файлов операционной системы сервера. Перед запуском обновления рекомендуется сделать полный бекап.


Действия над сервером
506 / 694

Управление отдельным сервером

Меню Действия сервера распространяется только на текущий сервер, входящий в пул:

Описание значений некоторых действий:

  • Удалить из пула - позволяет исключить сервер из пула.
  • Обновить Битрикс-окружение и Обновить систему - команды, аналогичные одноимённым Глобальным командам .

    Внимание! Обновления - сложная операция, в процессе которой происходит обновление системных файлов операционной системы сервера. Перед запуском обновления рекомендуется сделать полный бекап.

  • Команды Смены паролей пользователей root или bitrix- позволяет сменить пароль пользователя.

    Внимание! При смене пароля суперпользователя root будьте внимательны!


Графики нагрузки
507 / 694

Наглядное отображение

Детальные графики нагрузок различных сервисов на каждом сервере отображаются на странице Графики нагрузки (Настройки > Управление масштабированием > Графики нагрузки). Выберите с помощью фильтра нужный сервер, категорию и период для вывода графиков:

Система мониторинга позволяет выводить графики сервисов за день, неделю, месяц и год для каждого сервера пула, используя панель фильтра:

Apache:
  • CPU usage by httpd
  • Apache accesses
  • Apache processes
  • Apache volume
MySQL:
  • CPU usage by mysqld
  • MySQL queries
  • MySQL slow queries
  • MySQL threads
  • MySQL throughtput
Nginx:
  • CPU usage by nginx
  • Nginx status
  • Nginx requests
Сеть:
  • Connections through firewall
  • Firewall Throughtput
  • Netstat
  • ipconntrack
Система:
  • CPU usage
  • File table usage
  • Inode table usage
  • Load average
  • Memory usage
  • Swap in/out
  • Uptime
Диски:
  • Disk IOs per device
  • Disk latency per device
  • Disk usage per persent
  • IOstat
  • Inode usage per persent
  • Throughtput per device
Процессы:
  • Forkrate
  • Number of threads
  • Processes
  • VMstat

Внимание: Для вывода графиков нагрузок предварительно включите мониторинг в меню Глобальные действия пула.


Роли
508 / 694

Службы сервера

Ролями в модуле Масштабирования являются службы сервера:

  • Apache - веб-сервер;
  • Memcached - кеширование данных;
  • MySQL - база данных;
  • Sphinx - полнотекстовый поиск;
  • Push - отправка push-уведомлений.

Примечание: На главном сервере пула есть еще одна роль - Балансировщик, которая является системной и управляет всеми серверами и службами пула.

Внимание! Перед созданием ролей необходимо поменять пароль виртуальной машины. Часть операций (например, создание роли Apache вообще не может быть выполнена без смены пароля.)

Добавление, удаление роли

При наведении указателя мыши на роль всплывет меню, в котором можно Добавить роль . После того, как отработает мастер добавления ролей (это может занять продолжительное время), страница загрузится и будет показана выбранная роль на данном сервере:

Аналогично можно Удалить роль .

MySQL

При создании роли MySQL slave система предложит создать резервную копию базы данных. Если согласиться, то откроется страница Резервного копирования ; если выбрать Отмена, то создание роли MySQL slave будет продолжено.

После добавления роли MySQL, эта база будет выполнять роль slave-базы. Чтобы изменить роль MySQL slave на MySQL master, нужно выбрать Сделать мастером в меню действий роли MySQL slave:

В этом же меню с помощью соответствующих команд можно либо остановить сервис, либо сменить пароль Mysql.

Важно помнить!

В инструменте Масштабирование описанными выше несложными манипуляциями создаётся пул серверов с нужными ролями, мониторингом и распределением нагрузки.

Внимание! Команды могут выполняться довольно длительное время (от одной минуты до 2-3 часов и более) в зависимости от сложности задачи, объема данных, используемых в этих задачах, мощности и загруженности сервера. Во время выполнения команды другой функционал будет недоступен, о чем будет выведено сообщение .


Список заказов
509 / 694

Новые сервера

Внимание: Выбор сервера от провайдера появится, если хостер предлагает настроенную виртуальную машину или окружение «1С-Битрикс» у себя на площадке.

В разделе Список заказов VPS осуществляется просмотр заказов серверов от партнеров «1С-Битрикс», присоединенных в пул.

Для заказа сервера у провайдера нужно при добавлении нового сервера в пул выбрать из списка нужного провайдера. Далее уже выбрать из списка предлагаемых провайдером серверов машину нужной конфигурации .

После отработки команды машина появится в списке серверов со статусом Сервер предоставлен . Для добавления сервера в пул нужно выбрать в меню действий соответствующий пункт:

Спустя некоторое время сервер будет добавлен в пул:

Внимание! Команды могут выполняться довольно длительное время (от одной минуты до 2-3 часов и более) в зависимости от сложности задачи, объема данных, используемых в этих задачах, мощности и загруженности сервера.


Менеджер идей
510 / 694

Менеджер идей (второе название Есть идея!) — это сервис, позволяющий предложить свою идею для развития бизнеса компании, оценить идеи своих коллег. Каждая идея имеет свой рейтинг, который строится на основе мнения сотрудников компании.
Для удобства поиска в Менеджере идей все идеи сортируются по категориям и статусам.


Возможности Менеджера идей
511 / 694
Модуль позволяет:
  • Добавлять новые идеи и прикреплять файлы.
  • Располагать на сайте всплывающую форму добавления идеи. Требуется установка компонента Форма добавления идеи (popup).
  • Добавлять категории для сортировки идей.
  • Просматривать предложенные идеи в зависимости от интересующей категории и комментировать их.
  • Голосовать за понравившуюся идею и выводить рейтинги.


Создание сервиса
512 / 694
Менеджер идей настраивается и работает через компонент

Сами идеи, как и комментарии к ним, функционируют на основе блогов, а категории идей являются разделами соответствующего инфоблока . Поэтому необходимо сначала создать соответствующий блог, а далее создать инфоблок и подключить в публичной части компонент.

Настройки Блога, выполняемые Администратором сайта.

  • Если комментирование будущих Идей разрешается, то:
    • на закладке Параметры блога отметьте опцию Разрешить комментарии в блоге
    • на закладке Права на доступ настройте права доступа к блогу, чтобы пользователи могли создавать идеи и комментировать их.

  • По умолчанию модерировать сервис Менеджер идей (Есть идея!) могут только пользователи группы Администраторы. Чтобы разрешить другим группам пользователей модерировать сервис, необходимо в настройках прав доступа к блогу идей задать уровень Администрирование к сообщениям и комментариям для авторизованных посетителей.

    Конкретную же группу лиц, имеющих право модерировать сервис, указывает Контент-менеджер в настройках комплексного компонента идей (bitrix:idea) в параметре Группы пользователей, которые могут добавлять специальный ответ

  • Чтобы пользователи смогли голосовать за идеи, необходимо в административной части (Сервисы > Рейтинги > Список рейтингов, Рейтинг) во вкладке Блог отметить пункты :
    • Голосование за сообщения пользователя в блогах
    • Голосование за комментарии пользователя в блогах

    Подробнее с настройками рейтинга можно ознакомиться в уроке Рейтинги (курс Администратор. Базовый)

Подробнее о создании и управлении Менеджером идей можно ознакомиться в уроке Менеджер идей (курс Контент-менеджер)


Создание и редактирование статусов
513 / 694

Создание и редактирование статусов

Каждой предложенной идее присваивается свой статус. Статус - характеристика объекта, отражающая его состояние в настоящий момент. В модуле Менеджер идей статус служит идентификатором этапа, на котором сейчас находится идея. По умолчанию задано три типа статусов :

  • новые
  • в работе
  • внедрено
Эти статусы при желании можно легко отредактировать, либо не менее легко создать новые (это делает Администратор сайта).
Давайте добавим новый статус:

  1. Перейдите на страницу Пользовательские поля (Настройки > Настройки продукта > Пользовательские поля)

  2. В закладке Список откройте форму редактирования пользовательского поля UF_STATUS. С помощью кнопки Еще добавьте новую строку и заполните строки Значение и XML_ID:

  3. Сохраните внесенные изменения.
  4. И в заключении для вступления настроек в силу перейдите в публичную часть сайта на страницу со списком идей и сбросьте кеш.


Монитор производительности
514 / 694

В данной главе рассказывается, как правильно настроить серверное программное обеспечение на хостинге, а также о поиске проблем с производительностью на портале с помощью инструментов, входящих в состав коробочной версии продукта «Битрикс24».

Примечание: В данной главе описывается лишь инструмент Монитор производительности, который показывает скорость работы портала на хостинге, выявляет узкие места и даёт советы по оптимизации.

Ссылки по теме:

  • Пользовательская документация по модулю "Монитор производительности"
  • Низкая оценка производительности на мощном железе (Блог)
  • "Монитор производительности" в работе (Блог)
  • Производительность сайта в картинках (Блог)
  • График времени генерации страниц сайта (Блог)
  • Модуль Производительности на практике. Оптимизация настроек сервера (Блог)
  • Оптимизация времени генерации страницы (Блог)


Настройки модуля
515 / 694

Настройки модуля

Глобальные параметры модуля определяются на странице настроек Монитор производительности (Настройки > Настройки продукта > Настройки модулей > Монитор производительности).

Нажмите на рисунок, чтобы увеличить

Для настройки модуля доступны следующие опции:

  • Максимальная длина URL при отображении - опция позволяет указать максимальное количество символов, которое будет использоваться для отображения URL'ов на административных страницах, относящихся к модулю.
  • Вести журнал предупреждений PHP - регистрирация ошибок PHP, отображение ошибок на странице Ошибки PHP .
  • Вести журнал кеширования - регистрация информации о файлах кеша, просмотр информации - на странице Кеширование .
  • Записывать только операции с большими файлами кеша - сохранение операций только с файлами кеша, размер которых больше, чем указано в поле Размер файла кеша больше которого считать его большим.
  • Вести журнал SQL запросов - регистрация SQL запросы, просмотр записей на странице SQL Запросы .
  • Сохранять стек вызова для SQL запросов - сохранение стека запросов ,просмотр на странице SQL Запросы.
  • Записывать только медленные SQL запросы: - запись запросов с продолжительностью более чем указанные в поле Время исполнения после которого считать запрос медленным.
  • Включить монитор - запуск монитора производительности в выбранное время. Действие аналогично опции Тестировать производительность на странице Панель производительности (Настройки > Производительность > Панель производительности).

    Если монитор включен, то в поле Активность монитора будет отображен статус Работает, при этом ниже будет выведена информация: До окончания активности осталось: (часов:минут:секунд).

Настройка прав доступа производится типовым для Bitrix Framework способом. Подробнее про настройку доступа к модулям.

Документация по теме:

  • Пользовательская документация по модулю "Монитор производительности"
  • Низкая оценка производительности на мощном железе (Блог)
  • "Монитор производительности" в работе (Блог)
  • Производительность сайта в картинках (Блог)
  • График времени генерации страниц сайта (Блог)
  • Модуль Производительности на практике. Оптимизация настроек сервера (Блог)
  • Оптимизация времени генерации страницы (Блог)


Публичная часть модуля
516 / 694

Просмотр статистики "с лица"

Для оценки производительности в публичной части сайта используется кнопка Отладка , которая позволяет отображать статистику прямо на странице:

Нажмите на рисунок, чтобы увеличить

Примечание: Для административной части сайта также доступна Статистика SQL-запросов, Время исполнения страницы и Статистика компрессии. Отображение статистики включается с помощью меню кнопки Отладка в публичной части сайта.

Что отображается в статистике

Статистика в целом по странице отображается внизу страницы:

  • Информация для опций Время исполнения страницы и Статистика компрессии
  • Информация для опции Статистика SQL-запросов .

    Ссылка Всего SQL запросов позволяет отобразить более подробную информацию обо всех запросах на странице в специальной форме (см. ниже).

  • При одновременно отмеченных опциях Время исполнения страницы и Статистика SQL-запросов внизу страницы будет доступна ссылка Время создания страницы , которая позволит отобразить статистику страницы в специальной форме:

    Примечание: При отмеченной опции Суммарная статистика по ссылке Время создания страницы будет доступна более подробная информация .

Информация о запросах

Для просмотра информации о запросах компонента, необходимо выбрать пункт меню Статистика включаемых областей и затем использовать ссылку вида Запросов: n, отображаемую в информационной области, которая расположена рядом с компонентом:

Откроется форма, в которой будет отображена информация о запросах :

Кеш

Данные о кеше выводятся во всплывающем окне:


Административные страницы модуля
517 / 694
В административной части сайта к модулю Монитор производительности относятся следующие страницы, расположенные в разделе Производительность (Настройки > Производительность).


Страницы и компоненты
518 / 694

Страницы

На странице Монитор производительности: страницы (Настройки > Производительность > Страницы) можно просмотреть отчет по нагружаемости страниц:

Монитор производительности: страницы

Переход по ссылке с названием страницы позволяет просмотреть все её хиты на странице Хиты.

Компоненты

На странице Монитор производительности: компоненты (Настройки > Производительность > Компоненты) можно просмотреть отчет по используемым на страницах сайта компонентам или включаемым областям:

Монитор производительности: компоненты

Переход по ссылке в графе Запросы позволяет просмотреть все SQL Запросы компонента на странице SQL Запросы.

Кроме того на странице можно включить группировку по компонентам, если необходимо увидеть общую картину по использованию того или иного компонента.


Хиты
519 / 694

Учёт хитов

На странице Монитор производительности: хиты (Настройки > Производительность > Хиты) выводится отчет по хитам:

Монитор производительности: хиты

Переход по ссылке >> позволяет перейти на желаемую страницу в публичную часть сайта и просмотреть детальную статистику .

Примечание: Нажав кнопку Отладка или выбрав пункт меню Суммарная статистика (Отладка > Суммарная статистика) на Панели управления в публичной части сайта и перейдя по ссылке >> со страницы Монитор производительности: хиты (Настройки > Производительность > Хиты), можно просмотреть более детальную статистику .

Переход по ссылке с названием страницы (или по ссылке в графе Запросы) позволяет просмотреть все SQL запросы хита на странице SQL Запросы.

Переход по ссылке в графе Компоненты позволяет просмотреть отчет по используемым компонентам для хита на странице Компоненты.


SQL запросы
520 / 694

Отчёт по SQL запросам

Отчёты по запросам отображаются если в настройках модуля включены опции Вести журнал запросов и Сохранять стек вызова для SQL запросов.

На странице Монитор производительности: запросы (Настройки > Производительность > SQL запросы) отображается отчет по запросам SQL:

Двойной клик по строке таблицы с запросом или пункт меню действий План исполнения позволит просмотреть план исполнения запроса в новом окне .

После проведения теста в панели производительности наведение указателя мыши на текст запроса вызовет стек запроса. В первой строке отображается исходная функция, вызвавшая запрос:


Кеширование
521 / 694

Файлы кеша

Информация о файлах кеша доступна при включённой в настройках модуля Монитор производительности опции Вести журнал кеширования . В этом случае эта информация отобразится на странице Кеширование (Настройки > Производительность > Кеширование).

Кнопка Группировка позволяет выбрать режим отображения данных в таблице:

  • Без группировки - отображается вся информация о кеше, без каких-либо группировок;
  • Группировка по компонентам - информация о кеше сгруппирована по названию компонентов;
  • Группировка по типу - информация о кеше сгруппирована по типу кеша (управляемый / неуправляемый);
  • Группировка по каталогу - информация о кеше сгруппирована по каталогам, в которых хранятся файлы кеша;
  • Группировка по файлу - информация о кеше сгруппирована по файлам, в которых хранятся кеш.

Ссылки в таблице позволяют применять фильтр, согласно выбранному полю. Для полей таблицы в колонке Файл ссылка с названием позволяет перейти к просмотру содержимого этого файла.

Документация по теме:

  • Пользовательская документация


Таблицы в базе данных
522 / 694

Таблицы БД

На странице Таблицы в базе данных (Настройки > Производительность > Таблицы) можно просмотреть таблицы базы данных:

Таблицы в базе данных

При переходе по ссылке с именем таблицы позволяет просмотреть её содержимое.

Примечание: Система запоминает просмотренные таблицы и для удобства, в режиме просмотра данных таблицы, на контекстной панели будет доступно меню Последние таблицы (n), которое позволяет быстро переключаться между последними таблицами. На странице Таблицы также будут отображены Последние просмотренные таблицы .

Работа со страницей

Для таблиц доступны:

  • Групповые действия . Аналогичные действия также доступны и в меню действий для отдельных таблиц.
  • Фильтры. При введении текста в списке останутся только те таблицы, что содержат указанный текст .
  • Для таблиц модуля Инфоблоки, Поиск и Мгновенные сообщения реализована выборка строк с фильтром по текущему значению в связанных таблицах. Например, выберем таблицу b_search_content и в контекстом меню конкретной записи (в примере: ID=41) укажем выборку нужной строки . Произойдет выборка строк по таблице b_search_content, где SEARCH_CONTENT_ID=41.

    Навигация по связям таблиц базы данных

  • Вывод для значений подсказок с информацией , полученной из связанной таблицы.
  • По команде Изменить - редактирование записи в таблицах и сброс управляемого кеша после сохранения записи.
  • Редактирование сериализованных значений в альтернативном представлении.
  • Создание новых записей в таблицах с автоинкрементным первичным ключом.


Индексы
523 / 694

Индексы

Заочно нельзя сказать какие индексы необходимо создавать, надо всегда рассматривать конкретную ситуацию. Индексы нужны для конкретных выборок на конкретных проектах. В зависимости от архитектуры и логики проекта медленные запросы получаются у каждого свои, и для них нужны свои индексы, часто составные.

Страницы Анализ индексов и Список индексов - инструмент анализа и рекомендаций по созданию индексов.

Анализ индексов

Анализ индексов лучше производить после получения списка медленных запросов. Для этого в настройках модуля включите соответствующую опцию и установите время, после которого запрос будет считаться медленным. Рекомендуемое время работы монитора - сутки, но, опять же, надо учитывать реалии конкретного проекта.

После получения списка медленных запросов на странице Анализ индексов (Настройки > Производительность > Индексы > Анализ индексов) необходимо воспользоваться кнопкой Выполнить анализ собранных SQL запросов и отобразится список всех запросов, которые были совершены за это время, отсортированных по имени таблицы:

В общем списке в первую очередь нужно обращать внимание на запросы с большей продолжительностью и на большое их количество. Но и в случае больших величин у этих параметров не на каждый запрос стоит создавать индекс (возможно нужно просто исправить код компонента). Косвенным критерием успешности создания индекса служит время выполнения запроса до и после создания индекса.

При необходимости можно посмотреть план выполнения любого запроса. Команда Детальный анализ позволяет перейти к анализу конкретного запроса и созданию его индекса.

На этой странице жирным шрифтом выделяются таблица и колонки, к которым обращается запрос.

Структура таблицы - информационная закладка. Главное в ней - размер таблицы. И если размер большой (к примеру, больше 100 мегабайт), то построение и удаление индексов лучше проводить в часы наименьшей нагрузки на сайт.

Анализ запросов - закладка с собственно анализом запроса. При принятия решения о создании индекса учитывайте селективен ли этот запрос и процент селективности. Информация об этом выводится в таблице.

Создание индекса - закладка, на которой непосредственно принимается решение о создании (или нет) индекса. Те запросы, по которым не нужно создавать индекс можно внести в список Не предлагать создавать.

Запросы, по которым принято решение, пропадают из списка запросов и появляются на странице Список индексов.

Список индексов

Страница Список индексов (Настройки > Производительность > Индексы > Список индексов) отображает результаты ваших решений по анализу тех или иных запросов. "Зелёный" статус - индекс создан, "красный" статус - индекс не будет создаваться.


Настройки и ошибки PHP
524 / 694

Настройки

На странице Монитор производительности: настройки PHP (Настройки > Производительность > PHP) отображается сводная таблица Параметры окружения с анализом параметров PHP.

Монитор производительности: настройки PHP

С помощью ссылки Настройки PHP можно перейти на страницу с подробной информацией о PHP (phpinfo).

Ошибки

На странице Монитор производительности: журнал ошибок PHP (Настройки > Производительность > Ошибки PHP (N)) можно просмотреть журнал регистрации ошибок PHP, где N - общее количество ошибок.

Монитор производительности: сервер БД

Примечание: Данная страница отображается, только если в настройках модуля Монитор производительности указана опция Вести журнал предупреждений PHP.

Журнал ошибок PHP ошибок хранится в базе. Удалить журнал ошибок PHP можно с помощью опции Удалить собранные ранее данные в настройках модуля Монитор производительности.


Сервер БД
525 / 694

Наблюдаем за сервером

На странице Монитор производительности: сервер БД (Настройки > Производительность > Сервер БД) отображается сводная статистика производительности сервера базы данных и рекомендации:

Монитор производительности: сервер БД

Значения, отличающиеся от рекомендуемых, выделяются цветом:


История замеров производительности
526 / 694

История работы над производительностью

На странице История замеров производительности (Настройки > Производительность > История) выводятся результаты прошлых замеров производительности.

В таблице отображается производительность системы с указанием даты замера.


Панель производительности
527 / 694

Вы узнаете, как протестировать производительность, определить проблему и поправить "узкие" места сайта.


Панель производительности: поиск "узких" мест сайта
528 / 694

Поиск "узких" мест сайта

Для оценки производительности перейдите в раздел Монитор производительности (Настройки > Производительность > Панель производительности).

Нажмите на рисунок, чтобы увеличить

Нажатие кнопки Тестировать производительность позволит вам определить слабые места настройки хостинга. Важно понимать, что цифры в строке Конфигурация могут отличаться в разы при изменении нагрузки на сервер: если нагрузки нет, производительность может быть высокой, если есть – она сможет снизиться. Это связано с тем, что данные цифры показывают скорость открытия пустой страницы сайта и, естественно, зависят от общей загрузки сервера.

Однако далеко не всегда проблема кроется в хостинге - она может быть и в самом сайте. С помощью модуля это можно определить в чем именно проблема и поправить "узкие" места сайта. Для этого требуется запустить тест производительности в течение некоторого времени – для малопосещаемых проектов – час, для посещаемых можно выбрать меньшее время. Система будет фиксировать посещения и собирать статистику о времени выполнения каждой страницы, числе SQL запросов и других параметров.

Показатель производительности - величина, обратная времени исполнения ядра продукта (среднему на 10 измерений).

Если Производительность = 18,66 , то публичная страница сайта с пустым шаблоном (например, версия для печати), с пустой рабочей областью будет создаваться за 1/18,66 или 0,0536 сек. Если говорить проще, то сервер сгенерирует 18 (пустых, но с подключением ядра) страниц в секунду. То есть чем выше число, тем производительнее работает сайт.

Умножив 18 (страниц в секунду) на 60 получим, что сервер может генерировать около 1080 пустых, но с подключением ядра, страниц в минуту. Так, если посещаемость ресурса составляет всего 1000 человек в день, то производительность сервера будет на пределе. Естественно, в реальных условиях производительность будет ниже, в зависимости от "нагруженности" различных страниц сайта, нагрузки на сам сервер и других условий.

Показатель производительности не вычисляется на основе производительности файловой системы, работы базы, сессий и почты. Эти цифры нужны для того, чтобы помочь системному администратору найти узкое место (если такое есть). Величина производительности всегда обратна величине среднего времени отклика.

Что важно знать:
  • Оценка зависит от редакции продукта.
    Раз мы замеряем время работы ядра, очевидно, оно будет зависеть от размера ядра. Для редакции «Бизнес» со всеми включенными модулями оценка всегда будет ниже, чем на «Старте» на том же оборудовании. Эталонная оценка в Мониторе производительности продукта делалась на редакции «Бизнес».
  • Результат зависит от пользовательских функций в /bitrix/php_interface/init.php.
    Указанный файл подключается на каждый хит, в том числе и при работе административной части. Файл /bitrix/php_interface/init.php не должен содержать запросы к БД и любые другие ресурсоемкие операции.
  • Оценка будет меняться в зависимости от нагрузки.
    Чем больше нагружен сервер, тем ниже будет оценка. Но даже при пиковой нагрузке она не должна опускаться ниже приемлемого уровня, чтобы можно было говорить, что сервер справляется (например, не ниже 10 единиц, т.е. 0,1 сек. на страницу).
  • Показатель производительности не показывает возможности масштабирования системы.
    Процесс веб-сервера работает на одном ядре, а значит, когда измеряется производительность без нагрузки, число ядер процессора не влияет на результат. Другое дело под нагрузкой: многоядерная система в состоянии сохранить высокие показатели.
  • Для базы данных на отдельном сервере оценка производительности будет ниже.
    Когда речь идет о кластере, мы имеем масштабируемую систему: при увеличении нагрузки она должна сохранять хорошие показатели. Но при моментальном замере времени открытия страниц без нагрузки мы неизбежно увидим небольшое замедление за счет межсерверных коммуникаций.


Закладка Конфигурация
529 / 694

В закладке отображается текущие показатели производительности подсистем сервера и сравнение их с показателями эталонной системы.

Нажмите на рисунок, чтобы увеличить

Если какая-то подсистема не удовлетворяет оптимальным условиям, то будет выведена ссылка с рекомендациями по исправлению в колонке Примечание.

Основные ошибки конфигурации

  • Не установлен акселератор php.
    Наличие акселератора php просто жизненно необходимо, даже без дополнительных настроек страницы открываются в три раза быстрее, во столько же раз снижается нагрузка на процессор. Рекомендуется Zend Server CE - быстрее любого акселератора в два раза. К сожалению, на некоторых конфигурациях он работает нестабильно, тогда ставьте (в порядке приоритета) OPcache, APC, XCache.

    Внимание: eAccelerator не совместим с PHP v5.3+ и больше не поддерживается в продуктах «1C-Битрикс» с версии ядра 15.0.13. Подробнее см. в блоге разработчиков.

  • Включено ограничение open_basedir.
    На shared хостинге сложно отделить клиентов друг от друга. Самый простой вариант: включить open_basedir, тогда на все операции с файлами происходит дополнительная проверка пути. Это существенно снижает производительность. Решением будет использовать собственный экземпляр Apache для каждого пользователя или установка дополнительных модулей на сервер для ограничения доступа. В этом случае ограничение open_basedir ставить не нужно! Доступ ограничивается системой для пользователя веб-сервера.
  • Не установлен или не настроен NGINX.
    Хоть это напрямую не влияет на оценку производительности, но чрезвычайно важно для нагруженных проектов: лучше когда статика (картинки, стили, ява скрипты) отдаётся NGINX'ом и не обрабатываться Apache. Посмотрите логи доступа Apache: там не должно быть ни одного запроса к статике!
  • Не настроена база данных.
    По возможности всегда используйте формат данных InnoDB, рекомендуемые настройки смотрите на странице монитора производительности Сервер БД.
  • Стоят не оригинальные драйвера оборудования.
    Особенно актуально для RAID контроллеров: при установке на Linux системах обычно предлагает к установке open source драйвера, которые не всегда достаточно эффективно работают с оборудованием. Всегда ставьте оригинальные драйвера с сайта разработчика.
  • PHP как CGI.
    PHP, запускаемый как CGI (не FastCGI) – плохая схема.
    На каждое обращение к php-скрипту запускается новый процесс интерпретатора PHP. Все это работает очень медленно, производительность сайта будет крайне низкой.

Как читать оценку подсистем

Монитор производительности не имеет прямого доступа к системным ресурсам, поэтому оценки, полученные средствами PHP, в большей степени отражают работу PHP, чем сервера.

  • Конфигурация - собственно, оценка производительности.
  • Среднее время отклика - цифра, обратная оценке производительности.
  • Процессор (CPU). Делается большое число простых математических вычислений. Задача не распараллеливается, поэтому идет оценка работы одного ядра процессора. Когда сайт работает на VPS, здесь часто можно увидеть, что "зажат" процессор.
  • Файловая система. Этот тест показывает не столько работу диска, сколько работу PHP с файлами: создается, исполняется, удаляется большое число простых файлов. Данный показатель зависит от производительности файловой системы и эффективности работы PHP акселератора. В целом хорошо показывает, как работает PHP на данной конфигурации (без учета работы базы).
  • Почтовая система. Отправляется тестовое письмо на hosting_test@bitrix.ru. Содержимое письма: "This is test message. Delete it." Никакая служебная информация не передается! Если настроена отправка почты на cron, этот показатель можно игнорировать.
  • Время старта сессии. Сессия стартует на каждый хит, поэтому это время будет прибавляться к работе каждой страницы. Проблемы обычно возникают, когда меняются настройки хранения сессий PHP так, что скапливаются сотни тысяч файлов сессий.
  • База данных (чтение/запись/удаление). Отправляется большое число простых запросов в базу. Это очень утрированный тест: он не показывает, как база будет работать со сложными запросами на больших объемах данных. Очевидно, что для базы данных на локальной машине цифры будут выше, чем для базы на отдельном сервере. Это нормально.


Закладка Битрикс
530 / 694

На закладке отображаются текущие настройки продукта, непосредственно влияющие на производительность, с соответствующими рекомендациями для оптимальной настройки.

Нажмите на рисунок, чтобы увеличить

Клик по рекомендации - переход на страницу системы, где выполняются эти настройки.


Закладка Разработка
531 / 694

В этой закладке отображается список страниц сайта, среднего времени выполнения и предполагаемых ошибок разработчика.

Нажмите на рисунок, чтобы увеличить

Например, ошибка, которую предлагается исправить, - некэшированные компоненты.

Примечание: Для просмотра информации об ошибках используйте ссылку в колонке Ошибки разработки.

Чтобы увидеть причину ошибки нажмите на адрес страницы в колонке 20 самых нагружающих страниц.

Пример анализа

Список адресов и статистики выполнения для страницы /catalog/index.php:

Нажмите на рисунок, чтобы увеличить

Обратите внимание – на странице /catalog/index.php размещён комплексный компонент Каталог с включенным ЧПУ, поэтому реальные URL для этой страницы – разные. Приведенная таблица отсортирована по уменьшению времени выполнения страницы, и хорошо видно, что если в первый раз страница открывалась 1,5 секунды, то в последующие разы с постоянным уменьшением времени. При этом сработало кэширование компонентов, и, как следствие - уменьшение времени на выполнение SQL-запросов.

Проверим, какие компоненты выполняются на этой странице. Для этого нажмите на число в колонке Компоненты нужной страницы. Список компонентов и их характеристики для хита 14 по адресу /catalog/t-shirts/t-shirt-men-s-fire/.

Вы увидите список компонентов, подключаемых на странице, число SQL-запросов из них и тип кэширования. В этом списке ищутся те некэшированное компоненты, о которых сообщал монитор производительности.

Аналогичным образом просматривается список SQL-запросов на этой странице (для данного хита). Для определения, какой из компонентов не кэшируется вернитесь на страницу Монитор производительности: хиты и нажмите на ссылку >> перед адресом страницы, откроется сводная статистика по странице. Здесь вы увидите, на каком именно этапе построения страницы сайта затрачивается максимальное время .

Если на Панели управления нажата кнопка Отладка (Отладка > Суммарная статистика), то в этом окне будет отображён и список компонентов страницы . Любой из компонентов можно настроить, выбрав его из этого списка. Как правило, компоненты расположены в том же порядке, что и на странице диагностики.

Примечание: Подробнее про работу с монитором производительности в публичной части сайта смотрите в уроке Публичная часть модуля.


Закладка Масштабируемость
532 / 694

Получаем количественные данные

В модуле Монитор производительности доступен встроенный инструмент тестирования нагрузки многопоточных и веб-кластерных систем (Настройки > Производительность > Панель производительности, вкладка Масштабируемость).

Для проведения теста настройте форму. Поясним некоторые поля.

  • Сервер, который будет тестироваться. Для минимизации влияния самого тестирующего скрипта на результаты тестов рекомендуется запускать его не на тестируемых серверах, а на отдельном хосте.

    Также на тестируемом сайте необходимо на время проведения теста отключить опцию блокировки пользователя при большом количестве соединений ( Блокировать? ) в настройках модуля Веб-аналитика, закладка Настройки, секция Ограничение активности.

  • Страница (оставьте пустым для системного теста). В поле указывается адрес страницы, к которой будут происходить обращения во время теста, например, к индексной странице. При пустом поле обращение будет происходить к системной странице;
  • Максимальная продолжительность теста (минут). Задаётся время в течение которого продолжается тест по достижению числа соединений, указанных в поле Конечное количество одновременных соединений, причем в каждом последующем шаге теста количество одновременных соединений будет одно и то же.

Нажмите Начать тестирование, и в реальном времени будут строиться: таблица с результатами, графики генерации Страниц в секунду и Время генерации/получения страницы.

Таблица Результаты

Помимо колонок № теста и Соединений, пояснения к которым не требуются, в таблице также присутствуют следующие колонки:

  • Хитов - общее количество хитов произведенных за тест;
  • Ошибок - в данном случае под ошибками понимается ответ сервера, отличающийся от 200 ОК;
  • Страниц в секунду - количество страниц отданных тестируемым сервером за секунду;
  • Время генерации страницы - время генерации страницы на тестируемом сервере;
  • Время получения страницы - время получения страницы от тестируемого сервера.

График Страниц в секунду

С увеличением количества одновременных соединений сервер должен отдавать больше страниц, поэтому при нормальных условиях график должен иметь тенденцию к росту. Если при росте нагрузки график имеет горизонтальный вид, то это значит, что настройки не оптимальны или сервер начинает уже не справляться.

В тесте с одинаковом количеством соединений график не должен иметь провалов.

График Время генерации/получения страницы

С увеличением количества одновременных соединений время отдачи страниц клиентам будет также увеличиваться (синий график), а время генерации не должно меняться в широких пределах (красный график).

Документация по теме:

  • Нагрузочное тестирование кластера, анализ различных сценариев и выводы


Пример нахождения мелких ошибок в производительности
533 / 694

Мелкие ошибки в производительности сайта

Перед сдачей проекта протестируйте сайт и найдите ошибки в верстке, неправильно настроенного кэширования и другие мелкие недочеты. Для этого скачайте два-три раза все страницы на жесткий диск. Для этой цели хорошо подходит бесплатная программа wget, работающая под управлением Linux/Unix систем и встроенная в виртуальную машину VMBitrix.

В случае, если вы разрабатываете сайт на этой же виртуальной машине, вы получите полноценное тестирование с минимальными сетевыми задержками. Запуск тестирования несколько раз требуется для того, чтобы на каждой странице был создан кэш и повторный хит брался уже из кэша.

Для тестирования включите режим тестирования производительности, затем перейдите в виртуальную машину и выполните такие команды:

cd /tmp
mkdir test1
cd test1
rm -rf localhost
wget -m http://localhost
rm -rf localhost
wget -m http://localhost
rm -rf localhost
wget -m http://localhost

Для повтора теста повторите 2 последние команды. Если тестирование затянулось, прервать его можно, нажав CTRL+C.

Внимание! При большом числе обращений с одного адреса проактивная защита не позволит выполнить тестирование. Отключите контроль активности на странице Проактивный фильтр (Настройки > Проактивная защита > Проактивный фильтр).

Низкая скорость работы сайта и низкая оценка производительности

В первую очередь необходимо проверить наличие акселератора php . Это специальный модуль, который выполняет прекомпиляцию php скриптов, что позволяет уменьшить время работы скриптов в среднем в три раза.

Затем проверить, не включено ли расширение open_basedir .

Медленное открытие страниц

Наиболее просты в определении и легки для детектирования две проблемы:

  • все или значительная часть страниц сайта открывается не очень быстро;
  • некоторые разделы сайта почти не открываются или открываются очень медленно.

Причины могут быть разные, но, пожалуй, одни из самых частых:

Для первой проблемы. В коде страниц сайта имеются битые ссылки, которые переадресуются на индексную или на 404 страницу. Такие несуществующие адреса легко отлавливаются после получасового теста Монитора производительности.

Для второй проблемы: после сбоя некоторые таблицы базы данных оказались повреждены. В результате нагрузка на MySQL возросла в сотни раз. 5-ти минутный тест Монитора производительности показал, что причина – в нескольких поврежденных таблицах в разделе Каталог.


Облачные хранилища - настройка модуля
534 / 694

Настройка модуля

Для настройки модуля Облачные хранилища перейдите на страницу Настройки > Настройка Продукта > Настройки модулей > Облачные хранилища:

На вкладке Настройки указывается, следует ли Записывать 404 ошибки на перемещенных в облака файлах в журнал событий.

На вкладке Доступ настраиваются права доступа к модулю Облачные хранилища для групп пользователей. Работа на вкладке аналогична таковой для модуля Веб-формы.

Настройки облачных хранилищ

Документация по теме:

  • Описание модуля


Облако 1С-Битрикс
535 / 694

Сохранять бэкап в "облаках" можно непосредственно из административного раздела вашего сайта. Модуль Облако 1С-Битрикс предоставляет пользователям доступ к практически безграничному объему хранилища в Amazon S3 (Simple Storage Service).

Примечание: Резервное копирование сайта в облако 1С-Битрикс, ускорение загрузки сайта CDN и инспектор сайтов недоступны в ограниченной лицензии .


Возможности штатных средств модуля
536 / 694

Штатные средства модуля содержат такие продвинутые функции, как:

  • Инспектирование сайта. Периодическая автоматическая проверка доступности и работоспособности сайта. Инспектор сообщит обо всех неполадках через E-mail или push-уведомления для мобильных устройств.
  • CDN. Раздача статического контента (картинки, файлы стилей css, скрипты js) через сеть дистрибуции контента (Content Delivery Network или Content Distribution Network, CDN). При этом значительная часть ресурсов сайта загружается посетителем с ближайшего к нему сервера. Это позволяет увеличить скорость загрузки страниц до нескольких раз!
  • Работа с резервными копиями. Создание и просмотр резервных копий непосредственно в административном разделе вашего сайта.

Схема работы резервного копирования с модулями Облако "1С-Битрикс" и Облачные хранилища:

Нажмите на рисунок, чтобы увеличить


Инспектор сайтов
537 / 694

Инспектор сайтов периодически проверяет доступность и работоспособность сайта и сообщает обо всех неполадках через E-mail или push-уведомления для мобильных устройств.

Примечание: Проверка осуществляется со стороны серверов компании "1С-Битрикс", поэтому сайт должен быть доступен "снаружи".

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Инспектор сайтов отслеживает 4 параметра, очень важных для работы любого веб-проекта, и особенно интернет-магазина:

  • раз в 5 минут проверяет доступность сайта из двух географических точек;
  • раз в день проверяет срок действия домена.

    Инспектор сайта напомнит за 30 дней о необходимости продлить домен. Повторяться напоминания будут раз в неделю, пока домен не будет продлен.
  • раз в день проверяет срок SSL-сертификата;
  • раз в день проверяет срок действия лицензионного ключа.

    Инспектор сайта напомнит за 30 дней об окончании срока активности обновлений и технической поддержки для вашей лицензии.

Способы получения информации

Предусмотрены следующие способы получения информации от Инспектора сайта:

  • Гаджет на рабочем столе вашего сайта

    Гаджет покажет процент простоев вашего сайта или, если это магазин, потери в деньгах (высчитывается по средней сумме заказов за аналогичный промежуток времени при работоспособности сайта).

    Примечание: Из-за кеширования и проверок, что сайт точно восстановил свою работоспособность, статус сайта в "Гаджете на рабочем столе сайта" и "Мобильном приложении" обновляется не сразу, а лишь через некоторое время.

  • Страница Инспектор сайтов (Настройки > Облако 1С-Битрикс > Инспектор сайтов), на которой отображается детальная информация по всем параметрам инспектирования:

  • Письма на адрес электронной почты, указанный при добавлении сайта в инспектор:

    После обнаружения проблемы инспектором, на указанный почтовый адрес придет соответствующее уведомление в течение 3-9 минут.

    Примечание: После установки обновления сайт(ы) автоматически добавляется в список инспектируемых сайтов. E-mail для оповещения берется из настроек Главного модуля, а если там адрес не указан, то из настроек сайта.

  • Мобильное приложение для администрирования сайтов, в котором можно просматривать статистику инспектора по сайту и получать push-уведомления (с версии модуля bitrixcloud 14.0.1).

    Соответственно, доступны настройки для редактирования записей о сайтах (какие сайты, что проверять) и включение/выключение push-нотификаций.

Настройка

  1. Для корректной работы сервиса для инспектируемого сайта должен быть указан домен на странице Редактирования сайта (Настройки продукта > Сайты > Список сайтов > требуемый_сайт) или в поле URL сайта настроек Главного модуля (Настройки > Настройки продукта > Настройки модулей > Главный модуль).
  2. После чего необходимо перейти на страницу Инспектор сайтов (Настройки > Облако 1С-Битрикс > Инспектор сайтов) и с помощью соответствующей кнопки Добавить сайт для инспектирования .

Примечание: На странице настроек модуля Облако 1С-Битрикс можно указывать период времени, который будет использован для расчета и отображения информации на странице Инспектор сайтов (Настройки > Облако 1С-Битрикс > Инспектор сайтов).

Документация по теме:

  • Инспектор сайтов 1С-Битрикс (Блог)
  • «1С-Битрикс Администрирование» - мобильное приложение для управления заказами (Блог)
  • Облако 1С-Битрикс (пользовательская документация)


Ускорение сайта CDN
538 / 694

Новый модуль Ускорение сайта (CDN) доступен с версии 12. Он позволяет загружать весь статический контент вашего сайта (картинки, файлы стилей css, скрипты js) через сеть дистрибуции контента ( Content Delivery Network или Content Distribution Network, CDN ).

Для пользователя это значит, что значительная часть ресурсов сайта загружается с ближайшего к нему сервера. Это позволяет увеличить скорость загрузки страниц в несколько раз.

Также подключение CDN снижает количество подключений и нагрузку непосредственно на сервера сайта. Так как всё статическое содержимое загружается пользователю не напрямую с ваших основных серверов, а с узлов CDN, которые умеют очень эффективно кэшировать контент.

Все современные браузеры имеют лимит на количество одновременных соединений к одному домену (обычно - не более 6). Таким образом, даже если ваш сервер может отдавать страницы с максимальной скоростью, а скорость клиентского подключения достаточно высока, все равно загрузка всех элементов страницы (картинок, скриптов, файлов стилей) будет осуществляться максимум в 6 потоков.

При включении модуля Ускорение сайта (CDN) ссылки заменяются на разные домены, и уже лишь каждый отдельный домен имеет ограничение на число соединений. Их же реальное максимальное число становится в несколько раз больше (по числу доменов, с которых осуществляется загрузка файлов).

Внимание! Модуль является бесплатной дополнительной опцией для любой лицензии на «1С-Битрикс: Управление сайтом» (кроме редакции «Первый сайт»). Функционал модуля доступен для сайтов с активной коммерческой лицензией (технической поддержкой) и имеющим доступ из интернета.

Подробнее про условия использования сервиса смотрите на сайте.

Схема работы

Схема работы CDN при подключении одного сайта выглядит примерно так:

После включения поддержки CDN ссылки на статические файлы сайта (картинки, файлы стилей css, скрипты js) будут заменены. Вместо локальных URL'ов будут использоваться служебные имена серверов сети CDN.

Каждое обращение любого посетителя сайта к статическому контенту направляется на ближайший к нему узел CDN. При первом обращении нужные файлы загружаются с исходного сайта или специально для этого выделенного узла, а при последующих обращениях они будут отдаваться из кеша сервера CDN.

Примечание: В случае отсутствия ресурсов в CDN он их автоматически подгружает с сайта, указанного на закладке Дополнительно (Настройки > Облако 1С-Битрикс > Ускорение сайта (CDN)).

Размещение контента на многих серверах CDN и отдача его посетителям из ближайшей к нему точки сокращает сетевой маршрут передачи данных и делает загрузку сайта быстрее с точки зрения пользователя.

Примечание: Источником данных о статическом контенте, который автоматически будет загружаться в CDN, будет являться HTML, возвращаемый сервером.

Примечание: На данный момент загрузка статических данных в сеть CDN осуществляется только из папок /bitrix и /upload.

Частые вопросы
  • Что происходит с сайтом, если не продлена лицензия на продукт?

    • Ускорение отключается. Сам сайт продолжает работать.

  • Что делать, если необходимо заменить тот или иной статический файл? Как узлы CDN «узнают», что надо загрузить новую версию, а не продолжать отдавать из кеша старую?

    • Модуль "Ускорение сайта (CDN)" всегда формирует ссылки на файлы с уникальным идентификатором, который изменится при изменении файла. Таким образом, узлы CDN всегда будут отдавать актуальный контент. С точки зрения пользователя никаких дополнительных действий не требуется. Работайте с контентом сайта привычным для вас образом.

  • А как модуль "узнаёт", что надо перезалить тот или иной файл в CDN? Вот, например, поменял я в дизайне какую-нибудь CSS и залил её по FTP, когда в CDN она попадёт обновлённая?

    • Сразу окажется в CDN. Обратите внимание, у всех файлов в облаке после параметра идет число - это дата изменения. Мы просто вставляем дату модификации и CDN построен так, что он считает это разными файлами. Т.е. вам не нужно скидывать кеш CDN, он будет всегда актуальным. А старые файлы со временем удалятся.

  • Как быть если необходимо поменять картинку в шаблоне сайта?

    • Когда изменяется картинка в шаблоне сайта, то в файле стиля им надо добавить метку времени возле ссылки на картинку. Пример: test.jpg?123. Где ?123 - метка времени изменения. С такой меткой картинка будет загружена в CDN и обновится там.

  • Чем CDN отличается от двухуровневой конфигурации веб-сервера?

    • Это разные виды ускорения работы сайта. Двухуровневая конфигурация (Front-End + Back-End) стабилизирует сервер по нагрузке. CDN - ускоряет загрузку контента браузером путем распределения по доменам и географически близким узлам. Технологии не противоречат друг другу, а взаимно дополняют.

    CDN не может являться заменой двухуровневой системе. К тому же CDN имеет ограничения:

    • У серверов CDN бывают временные проблемы и функционал приходится временно отключать.
    • Не все статические файлы отдаются в CDN.

Документация по теме:

  • CDN для 70 000 сайтов одной кнопкой (habrahabr)
  • Пользовательская документация
  • 1С-Битрикс 12: CDN Как ускорить сайт на 1С-Битрикс (youtube)


Настройки CDN
539 / 694

Настройка сервиса

Включение и настройки сервиса Ускорение сайта CDN осуществляются на странице Настройки > Облако 1С-Битрикс > Ускорение сайта (CDN).

Нажмите на рисунок, чтобы увеличить

На закладке Ускорение производится непосредственное включение сервиса.

После включения поддержки CDN ссылки на статические файлы сайта (картинки, файлы стилей css, скрипты js) будут заменены. Вместо локальных URL'ов будут использоваться служебные имена серверов сети CDN. При этом не потребуется вносить никакие изменения в DNS и не нужно заботиться о сбросе кеша CDN при обновлении файлов.

На закладке Что ускорять можно указать, для каких статических файлов публичной части сайта будет включена поддержка CDN.

При отмеченной опции Контент сайта будет производиться загрузка в сеть CDN файлов, расположенных в папке /upload.

На закладке Сайты можно указать, для каких сайтов загружать ресурсы и делать замену ссылок. Например, при использовании многосайтовости.

Отдельно можно указать, чтоб производилась загрузка статических файлов административного раздела.

На закладке Дополнительно можно указать альтернативный источник оригинальных файлов, откуда забирают контент узлы CDN. По умолчанию используется адрес основного сайта. Это может быть полезно, например, в случае использования разных доменов (многосайтовости). Так же укажите протокол HTTPS, если он вами используется.

Примечание: В поле url сайта с которого CDN будет брать ресурсы (css, js, изображения и т.п.) нельзя писать http://.
Написание домена сайта в этом поле должно совпадать с тем, что выводится на странице странице проверки лицензионного ключа.


Облако 1С-Битрикс - настройки модуля
540 / 694

Настройка модуля

Для настройки модуля Облако 1С-Битрикс перейдите на страницу Настройки > Настройка Продукта > Настройки модулей > Облако 1С-Битрикс:

На вкладке Настройки указывается период времени, который будет использован для расчета и отображения информации на странице Инспектор сайтов (Настройки > Облако 1С-Битрикс > Инспектор сайтов).

На вкладке Доступ настраиваются права доступа к модулю Облачные хранилища для групп пользователей. Работа на вкладке аналогична таковой для модуля Веб-формы.

Документация по теме:

  • Описание модуля


Обучение
541 / 694

Администратор системы может выполнить публикацию курсов, используя визуальные компоненты модуля Обучение.


Публикация курса
542 / 694

Публикация списка курсов

Страница со списком курсов создается с помощью компонента Список курсов (learning.course.list).

Важно! В настройках компонента указывается адрес страницы для детального просмотра курса. Если страница с указанным именем не существует, то ее необходимо создать.

Публикация курса

Публичный интерфейс для детального просмотра курса создается с помощью комплексного компонента Учебный курс (learning.course). С помощью данного комплексного компонента осуществляется показ не только глав и уроков курса, но и созданных к курсу итоговых тестов.

Примечание: размещение компонента выполняется на странице с именем, указанным в настройках компонента Список курсов.

Обратите внимание, если в настройках компонента отмечена опция Включить поддержку ЧПУ, то необходимо указать адреса всех страниц курса. В противном случае следует задать переменные, которым будут передаваться идентификаторы страниц. Без особой необходимости не рекомендуется менять используемые по умолчанию значения переменных.

В обучающем разделе вашего Bitrix Framework вы можете опубликовать дополнительную информацию для пользователей, используя такие компоненты как Отчет по курсам (learning.student.certificates), Журнал студента (learning.student.gradebook) и др.

Важно! Показ детального описания, разделов, страниц и тестов курса выполняется на основе отдельного шаблона дизайна. Условия применения шаблона дизайна, используемого для просмотра курсов, задаются также как и для других шаблонов. Т.е. на странице настроек Bitrix Framework следует указать, к каким страницам или страницам какого раздела будет применяться шаблон.


Опросы, голосования
543 / 694

Модуль Опросы, голосования позволяет организовывать различные голосования, опросы и публиковать их результаты на корпоративном портале.

Для работы в административном режиме с модулем Опросы, голосования, достаточно иметь права администратора портала. Для публикации опроса в публичном разделе нужно быть администратором системы.


Открытые линии
544 / 694

Открытые линии - способ коммуникации с клиентами компании, посетителями сайта, с помощью которого собираются сообщения из разных каналов (мессенджеры, соцсети) в Битрикс24, распределяются по правилам очереди между сотрудниками и незаметно сохраняются в CRM.


Настройка Открытых линий для коробочной версии «Битрикс24»
545 / 694

Чтобы Открытые линии заработали

Для «Битрикс24 в коробке» необходимо сделать дополнительные настройки сервера и модулей портала.

Внимание! Данные настройки должен выполнять Администратор системы.

  • Общие серверные настройки
  • Настройка модулей:
    • Коннекторы для внешних мессенджеров
    • Открытые линии
    • Чат-боты Битрикс24

Общие серверные настройки

  1. Полный доступ из вне к http://адрес сайта/pub/imconnector/, к корню и всем файлам и поддиректориям.
  2. Действующий лицензионный ключ.
  3. Доступ со стороны портала ко всем внешним адресам, в частности к соцсетям Facebook, Вконтакте и т.п. по http и https.
  4. Настройка параметра Nginx: nginx proxy_ignore_client_abort on. Эту настройку необходимо включать для конкретного location.
  5. Если используется php-fpm, вместо nginx proxy_ignore_client_abort on используется параметр fastcgi_ignore_client_abort on.
  6. Для работы коннектора Онлайн-чат:
    • для location /online/(/?)([^/]*) разрешить X-Frame-Options SAMEORIGIN (открывать эту страницу как фрейм из любого сайта или только того, где будет расположен фрейм). Такие настройки могут быть в Nginx и в модуле Проактивная защита в разделе Защита от фреймов (Настройки > Проактивная защита > Защита от фреймов);
  7. Для работы коннектора Битрикс24.Нетворк:
    • установленный и настроенный модуль Чат-боты Битрикс24 (imbot);
    • доступ без авторизации к странице /pub/imbot.php;
    • если возникают проблемы с прохождением сообщений даже при таких настройках, необходимо включить опцию Долгое ожидания ответа в опциях модуля Чат-боты Битрикс24.

Примечание: В некоторых случаях может потребоваться отключить редиректы для файла коннектора вида ~/index.php на /.

Настройка модуля Коннекторы для внешних мессенджеров

Настройка модуля Коннекторы для внешних мессенджеров (Настройки > Настройки продукта > Настройки модулей > Коннекторы для внешних мессенджеров) проста:

  • Публичный адрес сайта - нужно убедиться, что после установки был верно определен адрес портала. Он должен быть указан вместе с адресом портала и протоколом. Закрывающий слэш не обязателен.
  • Включить режим отладки - эта опция включает лог ошибок работы коннекторов в файл /bitrix/modules/imconnector_error.log.

    Примечание: В файл пишется только лог ошибок, включать данную опцию имеет смысл только для отладки, лог трассировки сообщений в этот файл не пишется.

  • Список используемых коннекторов - здесь выбираются коннекторы (каналы), доступные к подключению.

Внимание! Если не удается подключить каналы и происходит ошибка, то нужно в первую очередь в настройках модуля проверить верность указания доменного имени с протоколом и убедиться, что данный адрес доступен из интернета.

Настройка модуля Открытые линии

Для ведения лога ошибок самого модуля Открытые линии (Настройки > Настройки продукта >Настройки модулей > Открытые линии) можно также включить Режим отладки:

Лог ошибок пишется в файл /bitrix/modules/imopenlines.log.

Примечание: В файл пишется только лог ошибок, включать данную опцию имеет смысл только для отладки, лог трассировки сообщений в этот файл не пишется.

Внимание! При работе Открытых линий для каждого внешнего клиента на портале создается пользователь типа экстранет. Обнаружив таких пользователей в списке пользователей , не пугайтесь, вас не взломали. Это системные пользователи.

Настройка модуля Чат-боты Битрикс24

Настройки модуля Чат-боты Битрикс24 (Настройки > Настройки продукта >Настройки модулей > Чат-боты Битрикс24) также особой сложности не вызывают:

  • Публичный адрес сайта - также должен быть правильно определен адрес портала. Он должен быть указан вместе с адресом портала и протоколом. Закрывающий слэш не обязателен.
  • Режим отладки - опция включает логгирование работы модуля в файле /bitrix/modules/imbot.log.

    Примечание: В файл пишется только лог ошибок, включать данную опцию имеет смысл только для отладки, лог трассировки сообщений в этот файл не пишется.

  • Долгое ожидание ответа - опция появляется после включения Режима отладки. Включение влияет на количество занятых worker-ов хостинга. Без активации этой опции сообщение чат-боту отправляется и worker освобождается. В случае активации опции worker будет занят до момента ответа чат-ботом (а это может занимать десятки секунд). Поэтому включать эту опцию нужно, только если не получилось корректно настроить окружение, и оно блокирует входящие запросы от marta.bitrix.info.
  • Чат боты - опции включения чат-ботов. По умолчанию есть возможность включить чат-боты Giphy, Реквизиты контрагента и Поддержка Битрикс24 в коробке.

    Примечание: Подробнее про чат-бот Поддержка Битрикс24 в коробке можно прочитать в одноименной статье.


Планерки и собрания
546 / 694

Модуль настроек не имеет.

При обновлении системы необходимо установить модуль и публичную часть к нему. При установке нового дистрибутива модуль устанавливается автоматически.

При удалении модуля можно сохранить данные, либо удалить модуль без сохранения данных.


Подписка, рассылки
547 / 694

Редактирование шаблона подписки и создание нового - операция недоступная Администратору портала. Это может делать только Администратор системы.


Шаблон рассылки
548 / 694

Создание и модификация шаблона рассылки

В каждом дистрибутиве продукта есть образец шаблона рассылки. Как любая универсальная вещь, он нуждается в адаптации шаблона под конкретный сайт. Администратор может отредактировать шаблон по умолчанию или создать свой шаблон.

Действия при редактировании шаблона

  1. Из формы создания рассылки перейдите по ссылке с названием шаблона .
  2. Затем на открывшейся странице Менеджера файлов перейдите к редактированию файла шаблона .
  3. В шаблоне сообщения может быть размещена как статическая информация (например, приветствие), так и программный скрипт или визуальные компоненты, использованием которых будет выполняться выборка информации.

    Нажмите на рисунок, чтобы увеличить

Создание шаблона

Создание нового шаблона заключается в копировании папки с текущим шаблоном (в дистрибутиве он называется news и расположен по пути: /bitrix/php_interface/subscribe/templates/ и редактированием его под свои потребности.

Внимание! По умолчанию шаблоны для автоматической генерации выпусков лежат в директории /bitrix/php_interface/subscribe/templates. Для поддержки версионности при разработке сайта в ядре 14.0.1 была введена поддержка папки /local, что облегчает совместную разработку сайта. А с версии 16.5 модуля Подписка, Рассылки шаблоны для автоматической генерации выпусков можно хранить в папке /local/php_interface/subscribe/templates.

Приоритет всегда у папки /local перед /bitrix, т.е если в /local/php_interface/subscribe/templates и в /bitrix/php_interface/subscribe/templates будут находиться шаблоны с одинаковым названием, то шаблон будет выбираться из папки /local.


Поиск
549 / 694

Модуль Поиск используется для индексирования и организации поиска информации на портале. Модуль позволяет осуществлять поиск как статической, так и динамической информации. Таким образом, пользователи портала могут осуществлять поиск информации в новостях, сообщениях форума, социальной сети и в любом статическом разделе портала. Исключение на данный момент составляет модуль Обучение.

Важно! При проведении поиска учитывается уровень прав пользователя, создавшего запрос. Т.е. поиск информации по запросу пользователя будет осуществляться в разделах и на страницах портала, правом на доступ к которым обладает данный пользователь.

При организации поиска возможна установка ограничений на область поиска: разделы портала, форматы файлов, типы информации, участвующей в поиске. Также можно выбирать данные, которые будут индексироваться для поиска.

Для нормальной работы системы поиска по содержимому документов, созданных в MS Office версий ранее 2007 (форматы doc, xls и ppt), необходимо произвести соответствующие настройки.

Дополнительная информация

  • Пользовательская документация по модулю "Поиск"


Основные сведения
550 / 694

Средства системы «Битрикс24 в коробке» позволяют выполнять поиск информации по различным элементам портала: по содержимому статических страниц портала, офисным документам, учебным курсам, пользователям, рабочим группам и по информации, хранящейся в инфоблоках, форумах и блогах.

На портале можно выполнить два вида поиска:

  • поиск сотрудников и рабочих групп;
  • поиск информации по всему порталу.

Поиск информации на портале выполняется с помощью специальной формы и страницы поиска. Расположение формы поиска определяется в шаблоне дизайна портала.

Страница поиска по порталу создается с помощью стандартного визуального компонента Стандартная страница поиска (bitrix:search.page).

С помощью настроек компонента осуществляется управление внешним видом страницы и областью поиска информации.

Примечание: поиск возможен не только по документам MS Office, но и по документам других форматов. Для такого поиска необходимо произвести дополнительную настройку как это указано в главе Настройка поиска документов.

По умолчанию в продукте поддерживается поиск документов MS Office 2007. Для поиска всех документов необходимо выполнить ряд настроек, описанных в главе Поиск документов MS Office более ранних версий.


Настройки модуля "Поиск"
551 / 694

Настройка модуля

Важные замечания:
  • При проведении поиска учитывается уровень прав пользователя, создавшего запрос.
  • Содержимое включаемых областей не индексируется поиском.
  • Слова, состоящие из одного символа, не индексируются поиском.
  • В системе нет полного соответствия морфологии русского языка. Например, не учитываются беглые гласные при склонении слова по падежам.

Наладка на сайте поиска начинается с настройки параметров модуля. В административном разделе сайта откройте страницу Настройки > Настройки продукта > Настройки модулей > Поиск:

Нажмите на рисунок, чтобы увеличить

Для удобства заполнения форма разбита на закладки:

  1. Индексация - настраивается ограничение поиска по целому ряду параметров. Например, по размеру файлов, типу файлов, папкам, которые не нужно индексировать.
    • Максимальный размер индексируемого документа в килобайтах - позволяет ограничить документы, участвующие в поиске, по их размеру. Пустое значение означает отсутствие ограничения.
    • Маска включения - позволяет задать маску, по которой будут выбираться документы, участвующие в поиске.
    • Маска исключения - определяется условие, на основе которого документы будут исключаться из индекса и поиска.
    • Код свойства страницы в котором хранятся теги - указывается код свойства страницы, в котором хранятся теги.

  2. Морфология - можно разрешить/запретить морфологический поиск на сайте и настроить его параметры.

    Морфологический поиск - возможность поисковой системы искать слово в документах во всех его морфологических формах.

    При морфологическом анализе модуль Поиск разбивает предложения на слова, используя стандартные символы-разделители (пробел, точка, запятая и т.п.). Однако, существуют символы, которые, не будучи буквами, все же являются частями слов (например, дефисы). Чтобы в подобных случаях разбивка слов не выполнялась, в поле Cимволы, по которым не производится разделение документа на слова укажите символы, которые морфологический анализатор должен рассматривать как части слов. По умолчанию там стоит дефис.

    При желании отложите выполнение морфологического анализа на агентов с помощью соответствующей опции.

    Морфологический поиск поддерживает работу со всеми языками, установленными в системе.

    В поле Полнотекстовый поиск с помощью вы выбираете подходящую вам поисковую систему:

    • Bitrix
    • Sphinx (доступен с версии 14.0.0)

      Примечание: полнотекстовый поиск Sphinx можно подключить в том случае, если на сервере установлен и настроен Sphinx, кроме того, к нему можно подключиться из PHP.

      Ручная настройка поискового механизма Sphinx описана в данном уроке .

      При выборе системы Sphinx необходимо указать строку подключения к серверу Sphinx и задать произвольный идентификатор индекса.

      Начиная с версии 2.2.2 в Sphinx поддерживается только кодировка UTF-8. На сайтах с кодировкой Windows-1251 поиск Sphinx'ом работать не будет.

    • Полнотекстовый поиск MySql (доступен с версии 17.0.1)

  3. Поиск - задаются собственно параметры поиска:
    • Для некоторых проектов вполне допустимо и использование опции Использовать быстрый поиск (с ухудшенным ранжированием). В этом случае поиск по сайту будет работать быстрее, но ранжирование не будет оптимальным, то есть документы, максимально точно отвечающие запросам, не будут собираться в начале первой страницы, а будут выводиться по мере нахождения.

      Ранжирование (англ. ranking) – это процесс выстраивания найденных по запросу пользователя страниц в порядке наибольшего соответствия искомому запросу.
    • С помощью поля Максимальное количество документов в результатах поиска можно ограничить количество документов, которые будут показаны из всего результата поиска.
    • Опция При ранжировании результатов учитывать расстояние между словами позволяет в поисковой выдаче выводить выше те материалы, искомые слова в которых расположены ближе друг к другу в тексте.
    • Опция При ранжировании результатов учитывать рейтинг позволяет в поисковой выдаче выводить выше те материалы, за которые больше проголосовали.

      Примечание: для включения настроек При ранжировании результатов учитывать расстояние между словами и При ранжировании результатов учитывать рейтинг требуется переустановка модуля без сохранения таблиц с последующей полной переиндексацией.
    • Поле Сколько дней хранить поисковые запросы для подсказки определяет время, в течение которого будут храниться поисковые запросы, выводимые в подсказке.
  4. Статистика - задаются параметры хранения статистики поисковых фраз и запросов.

    Статистика - это инструмент для сбора и анализа информации с целью дальнейшей корректировки контента сайта под типовые поисковые запросы.

Документация по теме:

  • Поиск. Настройки модуля (пользовательская документация)


Настройки инфоблока для корректного поиска элементов
552 / 694

Настройки инфоблока для корректного поиска элементов

Посетители пользуются формой поиска на сайте, чтобы максимально быстро найти требуемую информацию. Но они не увидят подробную информацию по найденным элементам, если настройки инфоблока выполнены некорректно. Не огорчайте клиентов, настройте пути к страницам инфоблока правильно.

В форме редактирования инфоблока укажите правильные пути к просмотру элемента инфоблока и раздела (если используются):

Нажмите на рисунок, чтобы увеличить

То есть в параметрах:

  • URL страницы информационного блока,
  • URL страницы раздела,
  • URL страницы детального просмотра

задайте шаблоны путей, которые ведут на существующие на сайте страницы инфоблока.

Примечание: чтобы разделы и элементы инфоблока могли участвовать в поиске, в форме настройки инфоблока также следует отметить опции Индексировать разделы для модуля поиска и Индексировать элементы для модуля поиска.

Пример корректной настройки

Допустим, у нас есть новостной инфоблок. Опубликуем его правильно:

  1. Создайте на сайте раздел, скажем, /content/news и страницу /content/news/index.php.
  2. На странице разместите и настройте комплексный компонент bitrix:news.
  3. Проверьте, чтобы адреса страниц в компоненте и в инфоблоке совпадали (в примере для адресов используется поддержка ЧПУ):

    Нажмите на рисунок, чтобы увеличить

    4. Теперь найденные через поиск новости открываются правильно.

    Заключение

    После того, как вы опубликовали информацию из инфоблоков на сайте, проверьте правильность адресов страниц. Адреса страниц в настройках инфоблока должны совпадать с адресами в компоненте.


Индексация
553 / 694

Индексирование – процесс сбора, классификации и сохранения данных с целью облегчить быстрый и точный поиск информации.

Поиск информации на сайте выполняется на основе поискового индекса (индексных таблиц). В индексе участвуют:

  • статические файлы;
  • форумы;
  • блоги;
  • информационные блоки;
  • учебные курсы;
  • социальная сеть.

Что индексируется вручную, а что автоматически?

  • Вся текстовая информация, которая попадает на сайт в виде статических HTML страниц или через интерфейс модулей (например, модуль Информационные блоки, модуль Форум и т.д.) индексируется автоматически.

    Важно!

    В индексе, а, следовательно, и в поиске участвуют только те статические файлы, для которых задан заголовок ($APPLICATION -> SetTitle();) или есть метатег TITLE.

    В индексе, а, следовательно, и в поиске участвуют только те информационные блоки, для которых в настройках указано соответствующее разрешение. Разрешение можно задать по разделам и по элементам.
  • Во всех случаях, когда происходит добавление информации не штатными средствами (минуя интерфейс системы), либо информация изменена без изменения даты, требуется ручная переиндексация. Например, после загрузки файлов по FTP понадобится ручная переиндексация сайта.
  • Инфоблоки переиндексируются автоматически при внесении элементов или разделов, а также при их последующем редактировании. Важно то, что настройки инфоблока и настройки соответствующего компонента должны обязательно совпадать, иначе поиск будет выдавать неправильные URL найденных страниц.
  • При работе с учебными курсами (т.е. при добавлении и редактировании курсов, глав, уроков или импорте курсов) всегда требуется ручная переиндексация.
  • Изменения адресов в настройках компонентов при использовании инфоблоков фиксируются также автоматически. А вот изменения адресов форумов, блогов требуют ручной переиндексации.

Как обновить поисковый индекс?

Обновление индексных таблиц выполняется на странице Переиндексация сайта (Настройки > Поиск > Переиндексация):

  • Так как на сайте может быть представлен значительный объем информации, процедура переиндексации может занять довольно продолжительное время. Чтобы сократить затраты времени, можно выполнить переиндексацию только измененных файлов (опция Переиндексировать только измененные), либо выбрать сайт и/или модуль, данные которых будут участвовать в переиндексации (поля Сайт и Модуль).

    Примечание:

    в некоторых случаях есть смысл не использовать функцию Переиндексировать только измененные, а прибегнуть к радикальному методу: удаление и восстановление модуля Поиск. Определенные операции по обновлению данных могут выполняться дольше, чем создание нового индекса. В частности это касается случаев использования таблиц InnoDB и большой базы данных.

    Например, вы создали большое число элементов инфоблока (скажем, 50 000). Во время этой работы в свойствах инфоблока не были включены опции Индексировать разделы (элементы) с целью снижения нагрузки на сайт. Затем вы активируете эти опции. Автоматически этот инфоблок в поиск не попадет, нужна ручная индексация. Вот в таком случае и лучше использовать прием удаления модуля Поиск из системы (с удалением файлов поискового индекса) и восстановление его обратно.

  • Индексирование производится поэтапно, продолжительность выполнения одного шага задается в поле Шаг.

    Чем больше время – тем лучше (при незаполненном поле переиндексация выполняется в один шаг, что и рекомендуется делать на локальной установке при разработке проекта). Но на время выполнения операции индексирования на удаленном сервере накладывает ограничения хостинг. Установку времени выполнения шага рекомендуется назначать не больше, чем время выполнения скрипта, задаваемое хостинговой кампанией. В большинстве случаев подходит значение параметров в 50 секунд на один шаг.

  • В процессе индексации можно также удалить все фразы, которые будут отображаться в подсказке при наборе слова в поле поиска. Для этого служит опция Удалить поисковые фразы для подсказки.
Внимание! Несмотря на то, что в показанной выше форме в выпадающем списке поля Модуль есть Социальная сеть переиндексация этого модуля производится отдельно и только из публичного раздела.

Для этого:

  • Перейдите в разделы социальной сети (где установлены компоненты Социальная сеть (socialnetwork), Социальная сеть – группы (socialnetwork_group), Социальная сеть – пользователь (socialnetwork_user))
  • Нажмите кнопку Индексация на панели управления (Режим правки должен быть включен):

Документация по теме:

  • Переиндексация


Что ищется?
554 / 694

По каким параметрам можно искать

Приведём список параметров некоторых сущностей, которые включаются в поисковый индекс модуля Поиск для "Битрикс24 в коробке".

Задачи

Обычный и быстрый поиск для задач не отличаются, поля по которым ищется:

  • id - Идентификатор
  • Название
  • Описание
  • Теги
  • Участники
  • Проект
  • Связанные CRM сущности
  • Пункты чек-листа

Пользователи

Обычный и быстрый поиск по пользователям не отличаются, поля по которым ищется:

  • ID - Идентификатор
  • Имя
  • Отчество
  • Фамилия
  • Должность
  • Профессия
  • Мобильный телефон
  • Телефон
  • Логин
  • Сайт
  • Город
  • Регион
  • Страна
  • Адрес
  • Почтовый индекс
  • Почтовый ящик
  • Город работы
  • Адрес работы
  • Регион работы
  • Страна работы
  • Почтовый индекс работы
  • Почтовый ящик работы
  • Рабочий телефон
  • Компания
  • Названия подразделений
  • E-mail
  • Пользовательские поля с флагом "Разрешать редактирование пользователем"

Рабочие группы

Обычный поиск:

  • название
  • описание
  • теги
  • владелец

Быстрый поиск: только по названию

Диск

В обычном и быстром поисках используется только имена файлов/папок и автор.

Если в настройках модуля Диск включена настройка Индексировать контент документов, то в быстром поиске можно использовать контент документов. Для этого в фильтре выбрать В содержимом документов .


Правила сортировки
555 / 694

Как происходит поиск? Пользователь вводит поисковый запрос и после нажатия кнопки Поиск система отбирает из поискового индекса страницы, соответствующие запросу. Перед показом пользователю результаты поиска сортируются по следующим параметрам:

  • по релевантности - степень релевантности документа поисковому запросу определяется исходя из наличия на странице слов, участвующих в поиске, и их удаленности друг от друга;
  • по дате изменения (последнего обновления) страницы.

Пользователь сам выбирает режим сортировки на странице с результатами поиска с помощью ссылок в конце списка найденных документов: Сортировать по релевантности или Сортировать по дате .

Вместе с тем, очень часто требуется при выводе результатов поиска отдать предпочтение документам той или иной тематики. Например, может потребоваться «поднять» в результатах поиска товары, которые требуют скорейшего сбыта. Такие цели достигаются с помощью специального механизма: желаемым страницам задается требуемый вес (ранг, page rank). При отображении результатов поиска, страницы, соответствующие заданным правилам сортировки, будут отображены в самом начале списка, в соответствии с весами, указанными в правилах.

Для чего может быть присвоен фиксированный вес?

Фиксированный вес может быть присвоен:

  • статическим файлам (требует указания полного пути к таким файлам);
  • информационным блокам (дополнительно могут быть указаны тип информационных блоков, информационный блок и элемент, которым следует отдать предпочтение);
  • форумам (могут быть указаны форум, тема выбранного форума и сообщение).
  • блогам (должен быть указан ID блога).
  • обучению (могут быть указаны ID курса или главы/урока, причем перед идентификатором для курса приписывается C, а для глав/урока - U (например, C5 или U278)).
  • социальной сети (могут быть указаны ID группы или ID пользователя).

Управление правилами сортировки

Управление правилами сортировки осуществляется на странице Список правил сортировки (Настройки > Поиск > Правила сортировки):

Назначение или изменение правил сортировки делится на два этапа:

  • Первый этап: управление правилами сортировки - создание, правка или удаление правил.

    В форме создания/редактирования правила выберите модуль, для элемента которого будет настроено правило сортировки.

    • для статических файлов можно указать приоритет для конкретного файла;
    • для информационных блоков можно указать приоритет для типа инфоблоков, отдельного инфоблока и элемента инфоблока;
    • для модуля форумов можно создать правило для форума, темы на форуме или отдельного сообщения.

    Примечание: при заполнении полей параметров можно остановиться на любом уровне. Например, можно при настройке правил для информационного блока указать только тип и сам инфоблок. Или даже на типе инфоблока.

    Кроме того, укажите вес (ранг) правила. Документы, соответствующие критериям правила, будут расположены в списке результатов поиска в соответствии с рангом сортировки. Чем больше значение веса, тем выше в списке будет отображен документ.
  • Второй этап: обновление поискового индекса для вступления новых правил в силу.

    Обновление поискового индекса выполняется по кнопке Обновить . По окончании процедуры обновления индекса будет выведено сообщение о ее результатах.

    Примечание: обновление индекса нужно выполнять после любого действия с правилами: создания, редактирования и удаления.

Документация по теме:

  • Создание и редактирование правила сортировки результатов поиска
  • Правила сортировки результатов поиска


Морфологический поиск
556 / 694

Модуль Поиск позволяет осуществлять морфологический поиск на сайте. В этом случае при создании индекса (и, соответственно, при поиске) учитываются все формы индексируемых слов. Морфологический поиск поддерживает работу со всеми языками, установленными в системе.

Например, при индексации слова телефон, база данных индекса будет учитывать различие в падежных окончаниях (телефона, телефону и т.д.), а также его множественное число (телефоны, телефонов, телефонам и т.д.).

Соответственно, при поиске по запросу телефон будут найдены страницы, содержащие не только слово телефон, но и слова телефона, телефону, телефоны, телефонов, телефонам и т.д.

Внимание!: в системе нет полного соответствия морфологии русского языка. Например, не учитываются беглые гласные при склонении слова по падежам. Если в каталоге есть товары: Ремень Радуга, Ремень Элегантность, Ремень Плетение, то при вводе запроса "Ремень" они находятся. Но другие формы этого слова, например "Ремни", "Ремней", "Ремня", уже не находят товар, так как поисковое ядро считает корнем "Ремен" и будет искать "ремени", а не "ремни".

Настройка морфологического поиска

Активизация морфологического поиска выполняется путем установки флага в настройках модуля Поиск (Настройки > Настройки продукта > Настройки модулей > Поиск) и выбора поисковой системы: Bitrix, Sphinx (доступен с версии 14.0.0) или Полнотекстовый поиск MySql (доступен с версии 17.0.1):

Примечание: полнотекстовый поиск Sphinx можно подключить в том случае, если на сервере установлен и настроен Sphinx, кроме того, к нему можно подключиться из PHP.

Ручная настройка поискового механизма Sphinx описана в данном уроке.

Если вы выбрали систему Sphinx, то необходимо указать строку подключения к серверу Sphinx и задать произвольный идентификатор индекса. Внешний полнотекстовый поиск Sphinx позволяет сделать быстрым и качественным поиск на вашем сайте, снизить нагрузку на сервер, а также он полностью интегрирован с компонентами модуля Поиск.

Если вам подходит обычный поиск (Bitrix), то в настройках параметров морфологии вам будет доступен параметр Cимволы, по которым не производится разделение документа на слова (при морфологическом анализе) .

Алгоритм морфологического анализа разбивает предложения на слова, используя в качестве разделителя все знаки, не являющиеся буквами алфавита (пробел, точка, запятая и т.п.). В то же время, существуют символы, которые, не будучи буквами, все же являются частями слов (например, дефис в слове: южно-африканский). Поэтому с помощью данного параметра вы можете указать символы, которые морфологический анализатор должен рассматривать как части слов.

Важно! После выбора системы полнотекстового поиска и сохранения настроек не забудьте выполнить полную переиндексацию сайта.

Примечание: рекомендуется не отключать морфологический поиск.

Документация по теме:

  • Пользовательская документация по модулю "Поиск"


Статистика
557 / 694

Не знаете, что ищут чаще всего посетители на вашем сайте? Обратите свой взор в административной части сайта на раздел Настройки > Поиск > Статистика. В нем собрана вся поисковая статистика.

Виды поисковой статистики

Статистику можно рассматривать в 3 разрезах:

Нажмите на рисунок, чтобы увеличить

  • Статистика переходов - развернутый отчет о поисковых фразах, времени ввода, места перехода, количества найденных документов и т.д.;
  • Список фраз - позволяет просмотреть список поисковых фраз, используемых людьми на сайте;
  • Список тегов - перечень установленных тегов сайта.

Документация по теме:

  • Список переходов
  • Список фраз
  • Список тегов


Логические операторы
558 / 694

Облегчайте поиск информации вместе с логическими операторами. Система допускает использование пяти видов логических операторов. Давайте их рассмотрим.

Операторы языка запросов

Оператор | Синонимы | Описание
и | And, &, + | Оператор логическое и. Подразумевается, что его можно опускать: запрос свежая рыба полностью эквивалентен запросу свежая и рыба.
или | Or, > | Оператор логическое или позволяет искать элементы, содержащие хотя бы один из операндов.
не | Not, ~ | Оператор логическое не ограничивает поиск элементами, не содержащими слово, указанное после оператора.
( ) |  | Круглые скобки задают порядок действия логических операторов. При формировании строки запроса убедитесь, что для каждой открывающейся скобки есть парная закрывающаяся.
"" |  | Поиск точной фразы. Обычно используется для поиска цитат.

Примеры использования логических операторов

  • свежая рыба или пылесос
    По такому запросу находится информация, в которой встречаются либо слова "свежая" и "рыба", либо слово "пылесос".
  • свежая рыба не скумбрия
    По такому запросу находится информация, в которой встречаются слова "свежая" и "рыба" и не встречается слово "скумбрия".
  • свежая рыба не (селедка или ставрида)
    По такому запросу система найдет все страницы сайта, где упоминается "свежая рыба" любых сортов, кроме "селедки" или "ставриды".

Дополнительно

  • Сложная логика в фильтре в документации для разработчиков.


Полезные советы
559 / 694

Знаете ли вы, что эффективность полнотекстового поиска можно значительно увеличить, если исключить из индекса слова встречающиеся очень часто? Например, если в каждом сообщении на форуме встречается слово "привет", то поиск по этому слову выдаст все сообщения, что не может удовлетворить инициатора такого запроса. Такие слова называются "СТОП" словами.

Практика показывает, что при использовании списка стоп-слов размер индекса уменьшается примерно на 10-15%, а возможный прирост скорости поиска бывает в десятки раз (20-50).

Задача по увеличению эффективности полнотекстового поиска решается в 3 этапа.

Этап 1. Определение наиболее "популярных" слов

Чтобы определить стоп-слова, выполните следующее:

  • Перейдите на страницу SQL запрос (Настройки > Инструменты > SQL запрос).
  • Выполните запрос:
    select ss.STEM,count(*) from b_search_content_stem cs inner join b_search_stem ss on ss.ID = cs.STEM group by STEM order by count(*) desc limit 100

    Примечание: до 11-й версии модуля необходимо использовать другой запрос:
    select STEM,count(*) from b_search_content_stem group by STEM order by count(*) desc limit 100

    В результате на странице будут отражены 100 самых популярных терминов на сайте.

    Внимание! Этот запрос может быть очень "тяжелым". Не торопитесь и выполните его во время наименьшей нагрузки на сайт. А если вдруг есть актуальная резервная копия на тестовом сайте, то лучше выполнить запрос на ней.

Есть и немного другой вариант получения списка стоп-слов:

  • Создайте страницу со следующим содержимым:
    <?
require($_SERVER["DOCUMENT_ROOT"]."/bitrix/header.php");
$query = $DB->Query("select ss.STEM,count(*) from b_search_content_stem cs inner join b_search_stem ss on ss.ID = cs.STEM group by STEM order by count(*) desc limit 100");
while($ar = $query->Fetch())
   echo " ,",$ar["STEM"];
require($_SERVER["DOCUMENT_ROOT"]."/bitrix/footer.php");
?>

    Так, вы быстро скопируете список самых популярных слов.

    Внимание: Обязательно удалите эту страницу после ее выполнения!

Этап 2. Исключение слов из полнотекстового индекса

Для исключения слов из полнотекстового индекса и поисковых запросов добавьте в init.php через запятую слова, которые необходимо исключить:

define("STEMMING_STOP_RU", "ЗДЕСЬ, СПИСОК, СТОП, СЛОВ");
Примечание: Система поддерживает стемминг 2-х языков: русского и английского. Для первого обрабатывается константа STEMMING_STOP_RU, для второго - STEMMING_STOP_EN.

Этап 3. Переиндексация

После внесенных изменений выполните полную переиндексацию для обновления поискового индекса. Используйте форму Переиндексация сайта (Настройки > Поиск > Переиндексация).

Примечание: подробнее про индексацию читайте в уроке Индексация.

Обратите внимание:

  • Наиболее эффективным будет удаление/установка модуля поиска без сохранения таблиц.
  • Начиная с версии форума 5.9.3, у модуля появилась настройка, значительно ускоряющая переиндексацию - Количество документов, переиндексируемых за шаг. Разумное значение 2-3 тысячи.
  • По окончании переиндексации обязательно выполните оптимизацию БД на странице Проверка/восстановление таблиц (Настройки > Инструменты > Диагностика > Оптимизация БД).


Типичные ошибки
560 / 694

В уроке рассмотрим решение ошибок поискового характера:

  • Поиск выдаёт ссылки на несуществующие страницы
  • "Зависает" переиндексация статических файлов
    •

    Поиск выдаёт ссылки на несуществующие страницы (404 - HTTP not found)

    • Ошибки поиска элементов инфоблока связаны с неправильно указанным URL'ом страницы детального просмотра элемента . Этот URL используется при формировании страницы результатов поиска. Соответственно, если он проставлен неправильно или указывает на несуществующую страницу, то пользователь по ссылке попадет не на страницу просмотра найденного элемента, а на 404-ю.

      Кроме того, похожая ситуация возникает, если компонент работает в режиме ЧПУ, а URL в настройках инфоблока прописан не в ЧПУ. В данной ситуации следует указать URL по правилам ЧПУ.

      Примечание: чтобы разделы и элементы инфоблока могли участвовать в поиске, в форме настройки инфоблока также следует отметить опции Индексировать разделы для модуля поиска и Индексировать элементы для модуля поиска. Подробнее читайте в уроке Настройки инфоблока для корректного поиска элементов.
    • Проблема может возникать со ссылками на страницы форума и блога. Проверьте корректность шаблонов путей к сообщениям форума, блога.

    Внимание! После изменения путей обязательно выполните переиндексацию сайта.

    "Зависает" переиндексация статических файлов

    Проблема: информационные блоки индексируются нормально, а статические файлы - нет. Переиндексация зависает и изменение шага индексации на странице Настройки > Поиск > Переиндексация не помогает.

    Решение: причиной является большой файл на сайте, который не успевает проиндексироваться за шаг. В настройках модуля Поиска установите ограничение на размер в поле Максимальный размер индексируемого документа в килобайтах.


Поиск элементов инфоблока по их свойствам
561 / 694

Знаете ли вы, что поиск элементов инфоблока можно выполнять не только по названию, но и по значениям их свойств? Такой поиск будет работать у вас на сайте, если в свойствах отмечена всего лишь специальная галочка. Давайте вместе разберем данную настройку.

Настройка поиска элементов по значениям их свойств

  • Откройте форму с настройками требуемого инфоблока (Контент > Инфоблоки > Типы инфоблоков > [ваш_инфоблок]) и перейдите на закладку Свойства.
  • Нажмите кнопку [...] напротив интересующего свойства.
  • В открывшейся форме отметьте опцию Значения свойства участвуют в поиске .
  • Сохраните внесенные данные.
  • Выполните полную переиндексацию инфоблока.

Теперь поиск элементов инфоблока будет осуществляться и по названиям, и по значениям свойств.

Документация по теме:

  • Создание и редактирование свойств инфоблока
  • Переиндексация


Почта
562 / 694
Процесс управления корпоративным порталом предполагает общение посредством электронной почты с рядом респондентов, так или иначе связанных с функционированием веб-портала. Среди них могут быть:
  • посетители, клиенты;
  • контрагенты, поставщики товаров;
  • сотрудники компании, ответственные за информационное наполнение сайта;
  • другие группы респондентов.

Модуль Почта предназначен для получения и обработки почтовых сообщений. При этом применение почтового модуля дает такие преимущества в управлении почтовыми сообщениями, как:

  • централизованное хранение почтовых сообщений, относящихся к функционированию портала;
  • неограниченное количество определяемых почтовых ящиков (учетных записей);
  • создание и применение правил к входящим сообщениям в автоматическом и ручном режиме;
  • самообучающаяся система фильтрации спама;
  • возможность доставки сообщений без удаления их с почтового сервера и т.д.

Дополнительная информация

  • Пользовательская документация по модулю "Почта"


Настройки модуля
563 / 694

Настройка модуля производится на странице Настройки > Настройки продукта > Настройки модулей > Почта. Настройка не сложна и в большинстве своем значения полей ясны из их названия.

Если не используется Виртуальная машина VMBitrix , то в настройках модуля почты необходимо указать командную строку запуска php-скрипта.

Есть системные ограничения:

  • На сервере не должно быть приложений, "слушающих" этот же адрес и порт.
  • В Linux "слушать" 25 порт (вернее 1-1024) могут только приложения, запущенные от пользователя root, что не всегда возможно. Поэтому приходится обходить это ограничение при помощи настройки, например, authbind, при этом командная строка будет выглядеть примерно так: authbind php -c /etc/php.ini. Иногда удобнее настроить переадресацию на файрволе , то есть запустить сервер на порту, например, 20225, а перенаправление сделать с внешнего 25 на внутренний 20225.
  • Чтобы внешние почтовые серверы могли достучаться до вашего, необходимо открыть этот порт в файрволе.
  • Домены, выбранные в настройках почтового ящика, должны иметь DNS запись "MX" (или "A") на IP-адрес, на котором "слушает" SMTP -сервер. Обычно сервер, который отвечает по заданному домену по протоколу http, содержит включенный на этом же адресе SMTP. Поэтому в большинстве случаев ничего настраивать не придется.

Если платформа и окружение настроены верно, то при нажатии на Запустить SMTP-сервер будет запущен php-скрипт, который будет слушать заданный порт на указанных хостах. И в случае входящих соединений он будет принимать входящие сообщения при помощи правил фильтрации модуля почты, а также будет сортировать и обрабатывать их.

Примечание: некоторые проблемы в работе почтовой системы (почта отправляется медленно; функция mail подвисает при отправке на некорректные адреса) решаются вынесением почты на cron.

Документация по теме:

  • Настройки модуля
  • Пользовательская документация по модулю "Почта"


Почтовые ящики
564 / 694

Ящики для почты

Управление учетными записями электронной почты осуществляется на странице Почтовые ящики (Сервисы > Почта > Почтовые ящики). Отметим что система Bitrix Framework позволяет создавать неограниченное число учетных записей электронной почты.

Для добавления новой учетной записи служит кнопка Добавить, расположенная на контекстной панели. Переход к редактированию существующей записи осуществляется с помощью меню действий (пункт Изменить) либо с помощью двойного клика по соответствующей записи. Откроется форма:

Вкладка Почтовый ящик

Пояснения к некоторым полям:

  • Тип - тип почтового сервера, на котором размещен почтовый ящик. При выборе типа Внутренний SMTP сервер сменится ряд полей, и станут неактивными часть прежних.

    Внимание! При настройке параметров запуска при выборе Внутренний сервер желательно заполнить поле Доменные имена, обслуживаемые сервером. Если их не ограничить и сервер находится в интернете, то можно запросто попасть в спам-лист (хотя реально рассылаться ничего не будет).

  • Почтовый сервер (POP3) / порт - имя почтового сервера, на котором размещен почтовый ящик и номер порта, через который пересылаются данные;
  • Параметры получения почтовых сообщений: в автоматическом или ручном режимах .

Дополнительно при создании новой учетной записи вы можете сразу перейти к настройке списка почтовых правил для данного ящика . Созданные правила будут применяться к почтовым сообщениям, получаемым на данный ящик (например, для определения СПАМ-коэффициента, уровня важности сообщения, удаления ненужных сообщений и т.п.).

Правила дают возможность сортировать сообщения в обсуждениях соцсетей. При отправке сообщения на заданный EMail, сообщение автоматически будет публиковаться на форуме. При этом все подписавшиеся на этот форум, будут получать сообщения, на которые можно будет просто отвечать в почтовом клиенте. Т.е. нечто похожее на листы рассылок google или yahoo groups, когда все обсуждения можно вести по почте, а история будет сохраняться в форумах, с возможностью общения и непосредственно на самом форуме через веб.

Вкладка Дополнительные настройки

Здесь указываются дополнительные параметры получения сообщений.

Документация по теме:

  • Почтовые ящики
  • Создание и редактирование почтового ящика


Письма
565 / 694

Читаем письма

Список всех полученных почтовых сообщений хранится на странице Письма (Сервисы > Почта > Письма).

Для получения сообщений в ручном режиме служит поле Получить почту, расположенное на контекстной панели. Выберите почтовый ящик, письма которого хотите получить, и нажмите кнопку OK. Отобразится информация о доставке почты.

С помощью кнопок, расположенных на контекстной панели, вы можете перейти к просмотру списка полученных сообщений либо записей журнала работы. В списке сообщений иконки сообщений так же говорят о состоянии писем.

Просмотр письма осуществляется в такой форме:

С помощью полей формы вы можете:

  • обучить систему фильтрации спама (поле Обучить);
  • применить к письму созданное ранее правило (поле Применить ручные правила);
  • пометить прочитанное сообщение на удаление.

Примечание: аналогичные действия могут быть выполнены для каждого сообщения с помощью его меню действий на странице Письма.

Документация по теме:

  • Письма


Правила
566 / 694

Как обрабатывать письма

Управление правилами обработки почтовых сообщений осуществляется на странице Правила обработки почты (Сервисы > Почта > Правила).

Для создания нового правила служит кнопка контекстной панели Добавить правило, в выпадающем меню которой необходимо выбрать тип создаваемого правила:

  • ручная настройка - все параметры правила доступны для изменения и настройки;
  • добавление сообщений в форумы соцсети - правило создается на основе специального шаблона (шаблон предназначен для облегчения создания правил фильтрации сообщений, адресованных в форумы соцсети);
  • добавление сообщения в техподдержку - правило создается на основе специального шаблона (шаблон предназначен для облегчения создания правил фильтрации сообщений, адресованных в службу технической поддержки);

    • Для коробочной версии Битрикс24 есть дополнительный тип правила
    добавление события в CRM - правило создается для добавления письма от клиентов в систему CRM в качестве события сущности

Форма создания (редактирования) правила обработки почты разбита на три закладки. На закладке Параметры указываются основные параметры правила:

Большая часть полей ясна из названия, поясним только одно поле. Применять при событиях - выберите события, при которых следует применять это правило:

  • При получении почты - правило будет применяться автоматически при получении почты;
  • При принудительном вызове правила - правило будет применяться при его вызове (например, правило может быть применено вручную при просмотре почтового сообщения).

На закладке Условия задаются условия, при выполнении которых данное правило будет применено к сообщению.

При создании правила с шаблоном Добавление сообщения в техподдержку на данной закладке отображается дополнительная группа настроек.

  • Определять по E-Mail ранее зарегистрированного пользователя – если это условие установлено в да, пытаться привязать обращение к пользователю, то при получении нового сообщения правило будет предпринимать попытки найти зарегистрированного пользователя с таким адресом в базе данных и привязать сообщение к нему. В противном случае, при получении писем с любых адресов сообщения в модуле техподдержки будут создаваться как анонимные.
  • Добавлять новое сообщение в уже открытое обращение – условие определяет, сообщения с какого адреса могут быть добавлены в открытое обращение в техподдержку. При установке флага как скрытое сообщение будет доступно только сотрудникам техподдержки.
  • Шаблоны темы для определения ответа на обращение – регулярные выражения, применяемые для сортировки входящих сообщений. Поле предназначено для разработчиков; не рекомендуется изменять его значение без надобности.
  • Привязывать новое обращение к сайту – указание на сайт, к которому будет привязано вновь создаваемое обращение.
  • Привязывать новое обращение к категории – указание на тематическую категорию, к которой будет привязано вновь создаваемое обращение.
  • Назначить новому обращению критичность – позволяет указать критичность вновь создаваемого обращения.

Если параметры сообщения удовлетворяют условиям правила, то к сообщению будут применены действия, заданные на закладке Действия.

  • Установить статус прочтенности – позволяет отметить все сообщения, к которым будет применяться это правило, как прочитанные.
  • Установить пометку спам – позволяет отметить все сообщения, к которым будет применяться это правило, как сообщения массовой рассылки.
  • Действие на PHP-скрипте – опциональный PHP-скрипт, который исполняется во время применения правила к сообщению.
  • Удалить сообщение – удаляет сообщения, к которым применяется правило.
  • Не обрабатывать другими правилами – указывает, что после применения этого правила к конкретному сообщению остальные правила не будут применены к нему, даже если сообщение удовлетворяет условиям правила.

Документация по теме:

  • Правила


Журнал работы
567 / 694

Где фиксируется работа с почтой

Журнал обработки почты (Сервисы > Почта > Журнал работы) отображает все события, связанные с функционированием модуля почты и получением сообщений:

  • запросы системы к почтовому серверу;
  • ответы почтового сервера;
  • применение правил и действий.

В записях журнала цветом выделены записи о следующих событиях:

  • зеленым цветом - запросы к серверу;
  • синим цветом - ответы от сервера;
  • красным цветом - описание возникших ошибок.

Документация по теме:

  • Журнал работы


Почтовые сервисы
568 / 694

Управление списком сервисов электронной почты, доступных на странице портала /company/personal/mail/?page=home в блоке "Почтовые сервисы", осуществляется на административной странице Сервисы > Почта > Почтовые сервисы. Пользователи могут подключать почтовые ящики только в сервисах из этого списка. Администратор портала может настраивать этот список, и, тем самым, запрещать или разрешать пользоваться почтой на портале в определенных сервисах.

Примечание: количество доступных почтовых сервисов не ограничено.

Для добавления нового сервиса служит кнопка Добавить, расположенная на контекстной панели. Переход к редактированию существующего сервиса осуществляется с помощью меню действий (пункт Изменить) либо с помощью двойного клика по соответствующей записи.

Работа с параметрами открывающейся формы добавления/изменения аналогична работе в других формах модуля Почта.

Документация по теме:

  • Почтовые сервисы
  • Создание и редактирование почтового сервиса


Настройка почты
569 / 694

Работа через «Битрикс24 в коробке» требует настройки отправки и приема электронной почты. Возможны три варианта отправки:

  • через локальный sendmail или postfix (Если портал на Linux);
  • через внешний SMTP сервер без авторизации (если на Windows);
  • через внешний сервер с авторизацией путем замены функции отправки почты.

Самый простой способ - отправка без авторизации. Если у вас портал установлен на Windows, настройте PHP (в конфигурационном файле) адрес smtp сервера, а в MS Exchange настройте прием почты с ip портала без авторизации.

Если же портал на Linux, то либо настройте msmtp (идет в комплекте с виртуальной машиной), либо почтовый сервер. Больше всего сложностей возникает при настройке сервера при использовании виртуальной машины и при установке «Битрикс24 в коробке» на *nix системы.


Настройка почты на Linux
570 / 694

Рассмотрим вариант настройки почты на примере CentOS 5 (для других ОС команды и пути могут отличаться).

  1. Удалите sendmail:
    # rpm -e --nodeps sendmail
  2. Установите postfix:
    # yum install postfix
# /etc/postfix/post-install upgrade-package
  3. Перекомпилируйте базу алиасов:
    # cd /etc
# newaliases
  4. Измените sendmail_path в /etc/php.ini:
    sendmail_path = /usr/sbin/sendmail -t -i
  5. Запустите postfix:
    # service postfix restart
  6. Перезапустите apache:
    # service zend-server restart
  7. Проверьте наличие postfix в автозагрузке
    # chkсonfig --list|grep postfix

    (по умолчанию есть):

    postfix         0:off   1:off   2:on    3:on    4:on    5:on    6:off

    если нет:

    # chkconfig postfix on
  8. Проверьте работу:
    <?
if (mail("moe_mylo@gmail.com","test subject", "test body","From: otpravitel@bitrix.ru"))
echo "Сообщение передано функции mail, проверьте почту в ящике.";
else
echo "Функция mail не работает, свяжитесь с администрацией хостинга.";
?>

Материалы по теме:

  • Настройка Postfix для отправки почты (блог разработчика)


Настройка почты на VMBitrix
571 / 694

Запустите виртуальную машину.

В первом окне нажмите Login, войдите под root (это обязательно). Войдите в пункт меню: 6. Управление сайтами (6. Manage sites in the pool). В этом пункте, в свою очередь, выберите пункт 4. Настройка почтового сервера (4. Change e-mail settings on site).

Для настройки интегрированного почтового сервера выполните следующее:

  1. Перейти в главном меню в 6. Manage sites in the pool > 4. Change e-mail settings on site и ввести имя хоста, для которого нужно настроить отправку почты:

  2. Далее ввести необходимые данные для почтового сервера:

    • from address - адрес отправителя, от которого будет осуществляться пересылка писем.
    • server address or DNS - ip- или dns-адрес почтового сервера. Если нажать Enter, то будет использован адрес по умолчанию (127.0.0.1)
    • server port - порт сервера. Порт зависит от типа соединения, 25 - для обычного и 465 - для зашифрованного (с использованием SSL). Если нажать Enter, то будет использован порт по умолчанию (25).
    • Если необходима SMTP-авторизация, то в строке SMTP authentication наберите y и введите логин и пароль для доступа к SMTP-серверу, в противном случае - n.
    • Если выбрана опция SMTP-авторизации, то понадобится ввести тип авторизации type of authentication method: auto, plain, scrum-sha-1, scrum-md5, gssapi, external, digest-md5, login, ntlm (например для yandex.ru достаточно auto, а для mail.ru - plain).
    • Если необходим TLS-протокол защищенной передачи данных, то в строке TLS enabled наберите y, в противном случае - n.

    Примечание: При настройке укажите данные своего или публичного почтового сервиса.

  3. Дождаться пока задача по настройке почтового сервера будет закончена.
  4. Убедиться в правильности введенных данных настройки почтового сервера можно снова в 6. Manage sites in the pool > 4. Change e-mail settings on site:

Внимание! Задачи могут выполняться довольно длительное время (до 2-3 часов и более) в зависимости от сложности задачи, объема данных, используемых в этих задачах, мощности и загруженности сервера. Проверить текущие выполняемые задачи можно с помощью меню 5. Background tasks in the pool > 1. View running tasks. Если по каким-либо причинам нужно посмотреть лог-файлы выполнения задач, то они находятся в директории /opt/webdir/temp.


Частые проблемы
572 / 694

Частой причиной сообщения Есть ошибки при отправке системных почтовых сообщений на странице Настройки > Инструменты > Проверка сайта является указание отправки почты через cron.

Для исправления этой ошибки отключите отправку через cron в файле /bitrix/php_interface/dbconn.php. Установите:
define("BX_CRONTAB_SUPPORT", false).


Сайты 24
573 / 694

Начиная с версии 18.0.0, в продукте доступен модуль Сайты 24. Это конструктор сайтов. Он позволяет создавать веб-страницы без программирования, просто кастомизируя готовые шаблоны и блоки из обширной коллекции.

Этот модуль используется, чтобы:

  • Быстро создать и запустить ваш собственный сайт - лендинг, визитку, рекламный или другой.
  • Создать собственные шаблоны.
  • Работать с включаемыми областями шаблонов как с отдельными страницами.
  • Использовать готовые блоки из каталога.
  • Редактировать блоки - менять палитру, шрифты, кнопки, добавлять анимацию и др.
  • Выводить на сайт данные из "1С-Битрикс: Управление сайтом", в том числе товары каталогов и др.
  • Адаптировать сайт к мобильным устройствам сразу в процессе создания.
  • Хранить создаваемый сайт на своем хостинге и домене.

Примечание:
  • В редакции CRM доступно создание 10 сайтов.
  • В редакции Корпоративный портал - 100 сайтов.
  • В редакции Энтерпрайз - неограниченно.


Установка модуля
574 / 694

Модуль Сайты 24 устанавливается в Административном разделе в Настройки > Настройки продукта > Модули. Найдите на странице строку Сайты 24 (landing) и нажмите кнопку Установить.


Настройки модуля
575 / 694

Настройка модуля

Сайты 24 - встроенный конструктор сайтов, позволяющий создавать веб-страницы без программирования.

Для настройки модуля Сайты 24 перейдите на страницу Настройки > Настройка Продукта > Настройки модулей > Сайты 24.

На закладке Настройки указываются пути к лендингам относительно вашего домена, т.е. сайта главного модуля. Именно по такому адресу созданная страница будет доступна после публикации:

На закладке Доступ настраиваются права работы групп пользователей с модулем Сайты 24.

Выберите группу пользователей и назначьте ей право доступа. Для того чтобы добавить право доступа для какой-либо группы пользователей, нажмите кнопку Добавить право доступа. В противном случае ко всем группам пользователей будет применено право доступа По умолчанию.

Примечание: подробное описание полей формы приведено в пользовательской документации к продукту.


Социальные сервисы
576 / 694
В настоящий момент модуль предоставляет аутентификацию посетителей сайта на внешних сервисах авторизации. Внешняя авторизация облегчает посетителям регистрацию на сайте: не нужно заводить еще один логин/пароль, можно воспользоваться уже имеющимся на одном из известных сервисов.

Полный и актуальный список поддерживаемых социальных сервисов можно увидеть на странице настроек модуля Социальные сервисы (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы).


Настройка модуля
577 / 694

Настраиваем модуль Социальные сервисы

Для управления сервисами необходимо перейти в настройки модуля Социальные сервисы (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы).

Нажмите на рисунок, чтобы увеличить

Настройка параметров модуля

Рассмотрим закладку Настройки:

  • Разрешить отправку активностей пользователей в социальные сети - отправка в соцсети активности пользователей, например при начале или завершении рабочего дня;

    Примечание: Указанная настройка только для Битрикс24 .

  • Транслировать твиты пользователей с хештегом в живую ленту - указываются twitter-хештег, с которым будут транслироваться твиты пользователя в Живую ленту;
  • Далее из списка выбираются необходимые социальные сервисы, с помощью которых будет доступна авторизация;
  • Ниже под каждым сервисом есть рекомендации и ссылки для регистрации сайта в своей системе получения соответствующих уникальных идентификаторов и секретных ключей.

    Примечание: Сервисы OpenID не требуют дополнительных настроек.

Если требуется использовать разные социальные сервисы авторизации на дополнительных сайтах, то перейдите на вкладку нужного сайта и включите их с помощью опции Применить индивидуальные настройки для этого сайта . Дальнейшие настройки аналогичны общим, указанным выше.

На что еще требуется обратить внимание при настройке проекта:
  • Некоторые сервисы требуют обращения только по HTTPS. Поэтому крайне желательно, чтобы PHP был собран с библиотекой openssl.
  • Если на проекте используются различного вида редиректы (mod_rewrite), убедитесь, что при редиректе не перекодируются параметры GET.

Регистрация и авторизация

На вкладке Авторизация разрешите, если необходимо, регистрацию новых пользователей через соцсети . Также определите группы пользователей сайта, для которых запрещена авторизация через соцсервисы и привязка соцсервисов к своим аккаунтам:

Примечание: В опции Регистрация новых пользователей указывается разрешено ли посетителям самостоятельно регистрироваться на сайте. За это отвечает опция Позволять ли пользователям регистрироваться самостоятельно? в настройках главного модуля на вкладке Авторизация (Настройки > Настройки продукта > Настройки модулей > Главный модуль).

Шифрование токенов авторизации

Примечание: Шифрование токенов авторизации доступно с версии 19.0.100 модуля Социальные сервисы.

Нажатие кнопки Включить шифрование токенов авторизации включает хранение авторизационных токенов пользователей социальных сервисов в зашифрованном виде.

После включения функции, а также на всех новых установках продукта , на закладке Шифрование отобразится статус: Шифрование токенов авторизации активировано

Как выглядит форма авторизации

Если модуль установлен и настроен, то посетитель в закрытом разделе увидит стандартную форму авторизации с кнопками социальных сервисов.

Сервисы условно поделим на две группы:

  1. Являются провайдерами OpenID: если сервис использует OpenID, то при нажатии на кнопки соц. сервиса выводится форма, куда пользователь вводит свой openid identity .

  2. Работают по собственным протоколам авторизации: для социальных сетей при нажатии на кнопку открывается окно с собственным диалогом авторизации внешнего сервиса.

После успешной аутентификации пользователь возвращается на сайт и авторизуется. Если это первый вход пользователя, то он добавляется в список пользователей сайта. При этом на вкладке Пользователь (Настройки > Пользователи > Список пользователей > [пользователь]) в поле Тип авторизации указывается сервис авторизации.

Документация по теме:

  • Настройки модуля


Примеры настройки некоторых сервисов
578 / 694


Общие примечания
579 / 694

Внимание: для некоторых сервисов, например: LiveID, Office365, Google, Одноклассники, ВКонтакте, Мой мир@mail.ru, Twitter и Facebook, необходимо зарегистрировать на этих сервисах приложение (ссылки и рекомендации указаны в каждой группе настроек для этих сервисов).

Важно! При настройке приложений обращайте внимание на параметры адрес сайта, домен - они чрезвычайно важны для правильной работы сервисов. Чаще всего авторизация будет работать и для поддоменов.

Примечание: Со временем социальные сервисы могут изменять внешний вид мастеров регистрации приложений.


Яндекс
580 / 694

Яндекс

  • Получение ID приложения и Пароля приложения
  • Настройка работы Битрикс24.Диск и Яндекс.Диск

Получение ID приложения и Пароля приложения

Для Яндекса необходимо указать в настройках модуля Социальные сервисы (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы) параметры ID приложения и Пароль приложения, а в настройках сервиса специальную ссылку.

Получить уникальные ID приложения и Пароль приложения нужно на сайте Яндекс OAuth.

Для этого необходимо:

  1. Зарегистрировать новое приложение по одноименной ссылке в настройках модуля Социальные сервисы продукта «1С-Битрикс» (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы). При регистрации приложения обязательно указать название приложения в поле Название:

  2. В поле Права выставить права для API Яндекс.Паспорта:
    • Доступ к портрету пользователя
    • Доступ к дате рождения
    • Доступ к логину, имени и фамилии, полу
    • Доступ к адресу электронной почты
  3. Ввести в поле Callback URL адрес из настроек модуля Социальные сервисы (в примере - www.mysite.ru - ваш адрес сайта) и нажать кнопку Сохранить:
  4. Далее откроется страница, где будут указаны ID приложения и Пароль приложения , которые нужно вписать в соответствующие поля в настройках модуля Социальные сервисы продукта «1С-Битрикс» (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы) :

Настройка работы Битрикс24.Диск и Яндекс.Диск

Для работы Битрикс24.Диск с Яндекс.Диск нужно в поле Права выставить права для Яндекс.Диск REST API :

  • Чтение всего Диска
  • Доступ к папке приложения на Диске
  • Доступ к информации о Диске

Примечание: Со временем социальные сервисы могут менять внешний вид интерфейса настройки своих продуктов.


Box.com
581 / 694

Box.com

Внимание! Сервис Box.com поддерживает работу только по протоколу https.

Для Box.com необходимо указать в настройках модуля Социальные сервисы (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы) параметры Идентификатор (client_id) и Секретный код (client_secret), а в настройках сервиса специальную ссылку.

Получить уникальные Идентификатор (client_id) и Секретный код (client_secret) нужно на сайте Box Developers.

Для этого необходимо:

  1. Создать новое приложение по одноименной ссылке в настройках модуля Социальные сервисы продукта «1С-Битрикс» (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы). Вы можете создать Пользовательское приложение (Custom App) или Корпоративную интеграцию (Enterprise Integration).

    Нажмите на рисунок, чтобы увеличить

  2. При выборе метода идентификации нужно выбрать Пользовательскую идентификацию Standard OAuth 2.0 (User Authentication) .
  3. Далее задайте уникальное имя вашему приложению.
  4. После создания приложения вы сможете перейти к просмотру конфигурации. На странице конфигурации можно скопировать параметры Client ID и Client Secret и вписать их в соответствующие поля в настройках модуля Социальные сервисы продукта «1С-Битрикс» (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы) .

    Нажмите на рисунок, чтобы увеличить

  5. И в поле Redirest URI ввести адрес из настроек модуля Социальные сервисы (в примере - www.mysite.ru - ваш адрес сайта) и нажать кнопку Save Changes.

Примечание: Со временем социальные сервисы могут менять внешний вид интерфейса настройки своих продуктов.


Google
582 / 694

Google

Получение Идентификатора (Client ID) и Секретного кода (Client secret)

Для Google OAuth 2.0 необходимо указать в настройках модуля Социальные сервисы (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы) параметры Идентификатор (Client ID) и Секретный код (Client secret), а в настройках сервиса специальную ссылку.

Получить уникальные Идентификатор (Client ID) и Секретный код (Client secret) нужно на сайте Google Developers Console.

Для этого необходимо:

  1. Создать новый проект с помощью кнопки Создать проект на странице Управление ресурсами.

  2. Выбрать в списке нужный проект, если автоматически не произошло перенаправление в созданный проект:
  3. Затем нужно перейти в раздел Учетные данные, нажать на кнопку Создать учетные данные и выбрать Идентификатор клиента OAuth
  4. Чтобы создать идентификатор клиента OAuth, будет предложено указать название продукта для окна запроса доступа. Делается это с помощью кнопки Настроить окно запроса доступа .
  5. На вкладке Окно запроса доступа OAuth нужно ввести необходимые данные для проекта - обязательные Адрес электронной почты и название проекта Название продукта, которое видят пользователи. Остальные поля являются необязательными. Для сохранения нажать кнопку Сохранить.
  6. Далее нужно выбрать тип приложения - в нашем случае это Веб-приложение, вписать необходимые данные для своего сайта (в примере - https://www.mysite.ru - ваш адрес сайта) в поля:
    • Название - может быть любым,
    • Разрешенные источники JavaScript - ваш адрес сайта,
    • Разрешенные URl перенаправления - адрес из настроек модуля Социальные сервисы и адрес редиректа .

    Примечание: Обратите внимание, что можно указать несколько адресов Разрешенные URl перенаправления (Authorized redirect URls), это позволяет использовать одно приложение на разных сайтах/доменах.

  7. После нажатия кнопки Создать на странице появятся необходимые уникальные Ваш идентификатор клиента (Client ID) и Ваш секрет клиента (Client secret) , которые нужно вписать в настройках модуля Социальные сервисы продукта «1С-Битрикс» (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы).
  8. Позже Секрет клиента (Client secret) можно найти, кликнув на нужном Идентификатор клиента (Client ID) в списке

Примечание: Со временем социальные сервисы могут менять внешний вид интерфейса настройки своих продуктов.


Google+
583 / 694

Google+

Для подключения Google+ используются параметры приложения Google.

Перейти в меню Библиотека

и найти опцию Google+ API либо быстрым поиском, либо из списка Популярных API:

В настройках приложения необходимо разрешить доступ к Google+ API c помощью кнопки Включить .

Примечание: Со временем социальные сервисы могут менять внешний вид интерфейса настройки своих продуктов.


LiveID
584 / 694

LiveID

  • Получение Live ID Application ID и Live ID Secret Key
  • Настройка работы с документами через MS Office Web Apps

Получение Live ID Application ID и Live ID Secret Key

Примечание: В настройках модуля Социальные сервисы в секции Внешние сервисы не забудьте отметить сервис LiveID как разрешённый.

Для LiveID необходимо указать в настройках модуля Социальные сервисы (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы) параметры Live ID Application ID и Live ID Secret Key.

Для этого необходимо:

  1. На платформе Microsoft для разработчиков Microsoft Graph перейти в раздел Мои приложения (потребуется учетная запись Майкрософт) и нажать кнопку Добавить приложение:

  2. Задать имя приложения и нажать кнопку Create.
  3. После создания приложения Код приложения используется как Live ID Application ID в настройках модуля Социальные сервисы - LiveID продукта «1С-Битрикс» (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы)
  4. Далее создайте новый пароль , скопируйте и вставьте его в поле Live ID Secret Key в настройках модуля.
  5. Добавьте платформу Веб и вставьте в поле URL-адреса перенаправления адрес из настроек модуля.

Настройка работы с документами через MS Office Web Apps

Для функционала работы с документами через MS Office Web Apps нужно активировать опцию Включить работу с документами через внешние службы (Google Docs, MS Office Web Apps и другие) в настройках модуля Библиотека документов (Настройки > Настройки продукта > Настройки модулей > Библиотека документов).

Примечание: Со временем социальные сервисы могут менять внешний вид интерфейса настройки своих продуктов.


Office365
585 / 694

Office365

Важно! Чтобы можно настроить интеграцию вашего портала с Office365, вы должны быть авторизованным или иметь рабочую учетную запись Office365 (xxxx@xxxx.onmicrosoft.com) с подпиской Office365 для Бизнеса. Частные учетные записи LiveID с подпиской Офис365 для Дома не подходят! Для заведения рабочей учетной записи Office365 обратитесь к администратору вашего Битрикс24.

Получение ИД клиента (Client ID) и Ключа (Key)

Для Office 365 необходимо указать в настройках модуля Социальные сервисы (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы) параметры ИД клиента (Client ID) и Ключ (Key).

Для этого необходимо:

  1. В Центре администрирования Azure Active Directory перейти в раздел Все службы (потребуется рабочая учетная запись Майкрософт - xxxx@xxxx.onmicrosoft.com, простой логин LiveID не подходит), выбрать раздел Регистрация приложений перейти по кнопке Новая регистрация:

  2. При регистрации приложения нужно задать отображаемое имя и поддерживаемые типы учетных записей. В поле URI перенаправления задайте тот адрес, который прописан в настройках модуля Социальные сервисы. Некоторые параметры можно будет изменить впоследствии.
  3. В настройках приложения выбираем раздел Разрешения API и выбираем разрешения.
  4. Далее в настройках приложения выбираем раздел Сертификаты и секреты, нажимаем кнопку +Новый секрет клиента, заполняем Описание , назначаем срок действия ключа и нажимаем кнопку Добавить .

    После добавления ключа, сам ключ появится в графе Значение .

    Значение ключа вводится в поле Ключ (Key) в разделе Социальные сервисы - Office365 продукта «1С-Битрикс» (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы) - в примере: mg?2fPjt]v_TT3LOO7f3oK/bQaEu=wOs

    Важно! Значение создаваемого ключа показывается только один раз, если вы не скопируете значение ключа и перейдете в другой раздел, то придется создавать ключ заново.

  5. Значение поля ИД клиента (Client ID) для приложения можно взять в разделе Обзор .
  6. Поле Домен организации (Tenant) - необязательное, представялет собой возможность ограничения на стороне портала для редактирования документов "только для своих" - тех, кто состоит в компании рабочей учетной записи. Также такое ограничение владелец тенанта может сделать еще и на стороне Office365.

    Рабочий аккаунт Office365, как правило, имеет вид user@company.onmicrosoft.com, где: user - имя пользователя, а company - название компании в бизнес-аккаунте Office365.

    Таким образом, Домен организации (Tenant) в нашем случае будет company.onmicrosoft.com.

Многофакторная идентификация

Многофакторная идентификация Azure (MFA) помогает защитить доступ к данным и приложениям. В Azure Active Directory её возможности доступны для защиты учетных записей глобальных администраторов, а в Microsoft 365 бизнес можно полнофункционально использовать MFA с применением политик условного доступа, чтобы требовать многофакторную проверку подлинности.

Развертывание Многофакторной идентификации Azure (Azure MFA) для приложений подробно описано в документации Microsoft.


Одноклассники
586 / 694

Одноклассники

Для Одноклассников необходимо указать в настройках модуля Социальные сервисы (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы) параметры ID приложения, Ключ приложенияи Секретный код приложения, а в настройках сервиса специальную ссылку:

Получить уникальные ID приложения, Ключ приложенияи Секретный код приложения нужно на сайте разработчиков Одноклассников.

Для этого необходимо:

  1. Получить права разработчика по адресу: http://ok.ru/devaccess.
  2. Добавить приложение по ссылке.
  3. Далее на странице Настройки приложения указать название и нажать кнопку Подключить OAuth .
  4. В Список разрешённых redirect_uri вставить адрес из настроек модуля Социальные сервисы (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы):
  5. После нажатия кнопки Сохранить на почту, указанную в аккаунте разработчика, придет письмо с данными ID приложения, Ключ приложенияи Секретный код приложения, которые нужно вписать в соответствующие поля в настройках модуля Социальные сервисы продукта «1С-Битрикс»:
Примечание: По умолчанию сервис Одноклассники не имеет доступа к email пользователя.

Для запроса прав (в частности, GET_EMAIL - доступ к email адресу пользователя) необходимо прислать id приложения и перечень нужных разрешений с описанием кейса их использования на адрес api-support@ok.ru.

Примечание: Со временем социальные сервисы могут менять внешний вид интерфейса настройки своих продуктов.


Dropbox
587 / 694

Dropbox

Внимание! Сервис Dropbox поддерживает работу только по протоколу https.

Для Dropbox необходимо указать в настройках модуля Социальные сервисы (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы) параметры App key и App secret, а в настройках сервиса специальную ссылку:

Получить уникальные App key и App secret нужно на сайте Dropbox Developer.

Для этого необходимо:

  1. Cоздать приложение Dropbox по одноименной ссылке в настройках модуля Социальные сервисы продукта «1С-Битрикс» (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы). При регистрации приложения в центре разработчиков нужно выбрать Dropbox API и указать название приложения в поле Name your app:

  2. После нажатия кнопки Create app откроется страница с настройками приложения , где ввести в поле Redirect URIs необходимые данные - адрес из настроек модуля Социальные сервисы (в примере - www.mysite.ru - ваш адрес сайта) и нажать кнопку Add:
  3. На этой же странице получить App key и App secret, которые нужно вписать в соответствующие поля в настройках модуля Социальные сервисы продукта «1С-Битрикс» (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы) :

Примечание: Со временем социальные сервисы могут менять внешний вид интерфейса настройки своих продуктов.


Facebook
588 / 694

Facebook

Для подключения возможности авторизации через социальную сеть Facebook необходимо указать:

    В настройках модуля Социальные сервисы (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы):
  1. Идентификатор приложения (App ID);
  2. Секретный код приложения (App Secret);
    3. В настройках приложения Facebook:
  3. В поле "Действительные URL-адреса для перенаправления OAuth" специальную ссылку вида https://ваш_сайт/bitrix/tools/oauth/facebook.php.

Подключение пошагово

Прежде всего зарегистрируемся в качестве разработчика на сайте Facebook for developers. В открывшемся окне введем название приложения и e-mail для связи, и далее нажмем кнопку «Создайте ID приложения».

Далее поработаем во вкладке Настройки > Основное:

Нажмите на рисунок, чтобы увеличить

1 скопируем идентификатор приложения и вставим его в соответствующее окно настройки параметров модуля Социальные сервисы;
2 в поле Секрет приложения нажмем кнопку Показать и скопируем код в соответствующее окно настройки параметров модуля Социальные сервисы;
3 укажем домен приложения (адрес нашего сайта), URL-адрес страницы Пользовательского соглашения и Политики конфиденциальности (это может быть одна и та же страница). Укажем категорию «Бизнес и страницы» и цель использования - для нужд своей компании. При желании можно загрузить иконку приложения (1024x1024 px на прозрачном фоне);
4 сохраним внесенные изменения;
5 добавим продукт. По умолчанию добавится продукт Вход через Facebook.

Теперь перейдем на страницу Вход через Facebook > Настройки:

Нажмите на рисунок, чтобы увеличить

6 пропишем адрес, указанный в подсказках настройки модуля Социальные сервисы;
7 переключим слайдер в положение ВКЛ., подтвердив свой выбор.

Готово! Теперь на сайте можно будет авторизоваться и через социальную сеть Facebook!

Примечание: Со временем социальные сервисы могут менять внешний вид интерфейса настройки своих продуктов.


Twitter
589 / 694

Twitter
  1. Для получения кодов необходимо зарегистрировать приложение Twitter по ссылке .
  2. При регистрации приложения указать в поле Callback URL путь из настроек модуля.
  3. После регистрации приложения в закладке Keys and Access Tokens получить Ключ приложения (Consumer key) и Секретный код приложения (Consumer secret).
  4. По ссылке modify app permissions или в закладке Permissions изменить Access Level на Read, Write and Access direct messages.
  5. Указать выданные сервисом Ключ приложения (Consumer key) и Секретный код приложения (Consumer secret) в соответствующих полях в настройках модуля Социальные сервисы продукта «1С-Битрикс» (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы):

Примечание: Со временем социальные сервисы могут менять внешний вид интерфейса настройки своих продуктов.


ВКонтакте
590 / 694

ВКонтакте

  1. Пройти по ссылке Зарегистрировать приложение на сайт ВКонтакте для разработчиков:
  2. Выбрать тип нового приложения Веб-сайт, заполнить необходимые данные .
  3. Из раздела Настройки приложения вписать нужные ID приложения и Защищенный ключ в настройках модуля Социальные сервисы продукта «1С-Битрикс» (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы):

Примечание: Со временем социальные сервисы могут менять внешний вид интерфейса настройки своих продуктов.


Битрикс24.Network
591 / 694

Битрикс24.Network

  1. Кликнуть на ссылку Зарегистрировать сайт в Битрикс24.Network .
  2. В всплывающем окошке ввести адрес сайта .
  3. Автоматически будут получены Идентификатор портала и Секретный код портала .
  4. Нажав на кнопку Вставить, полученные идентификаторы автоматически вставятся в нужные поля формы.


Мой Мир@mail.ru
592 / 694

Мой Мир@mail.ru
  1. По ссылке подключить сайт зарегистрировать свой сайт в системе api.mail.ru.
  2. На первом шаге согласиться с правилами использования Платформы@Mail.ru.
  3. На втором шаге задать название и адрес главной страницы вашего сайта.
  4. Скачать файл receiver.html по одноименной ссылке, загрузить на свой сайт и указать путь к нему:

  5. Указать выданные сервисом ID сайта, Приватный ключ, Секретный ключ в соответствующих полях в настройках модуля Социальные сервисы продукта «1С-Битрикс» (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы):

Примечание: Со временем социальные сервисы могут менять внешний вид интерфейса настройки своих продуктов.


Mail.ru
593 / 694

Mail.ru
  1. Создать новое приложение по ссылке.

    Название проекта придумайте сами, загрузите изображение в поле Добавить фото.

    В поле Все redirect_uri внесите адрес из настроек модуля Социальные сервисы (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы):

  2. Нажать кнопку Подключить сайт, при необходимости отредактировать приложение . Можно отметить, на каких платформах будет установлено ваше приложение, сконфигурировать кнопку входа или скопировать её код, выдать права доступа пользователям, пройти модерацию и др.
  3. Указать выданные сервисом ID приложения и Секрет в соответствующих полях в настройках модуля Социальные сервисы продукта «1С-Битрикс» (Настройки > Настройки продукта > Настройки модулей > Социальные сервисы):

Примечание: Со временем социальные сервисы могут менять внешний вид интерфейса настройки своих продуктов.


Телефония
594 / 694
Внимание! Телефония работает только на активной лицензии. Кроме этого, на номер лицензии завязываются лицензии SIP-коннектора и оплата телефонии. При смене лицензии телефонией по старым подключениям пользоваться будет невозможно.

Перед сменой лицензии необходимо отключить арендованные и привязанные номера, АТС.

Сервис Битрикс24 даёт возможность использовать телефонию для решения производственных задач. Телефония в Битрикс24 реализована с помощью технологии WebRTC позволяющей совершать/принимать звонки прямо из браузера. Эта технология поддерживается браузерами в версиях не ниже: Google Chrome v29, Mozilla Firefox v27, Opera v18, Яндекс.Браузер v13. (К сожалению Internet Explorer не поддерживает WebRTC.)

В силу разных, зависимых от разработчиков браузеров, причин IP-телефония гарантированно корректно функционирует только в Google Chrome и Mozilla Firefox. В Opera и Яндекс.Браузер работа нестабильная от версии к версии браузеров.

Ограничение на использование звонков на сайтах без SSL-сертификата для Битрикс24 в коробке
Google Chrome с версии 47 отключает WebRTC на всех сайтах, кто не использует протокол HTTPS. Это означает что для всех коробочных версий Битрикс24, у кого не стоит HTTPS сертификат, перестанет работать телефония и внутренние звонки. Для пользователей это будет выглядеть, как "Невозможно получить доступ к веб-камере или микрофону".

Для решения проблемы, необходимо будет приобрести и настроить HTTPS сертификат для сайта. Либо использовать другие браузеры.

Для клиентов Битрикс24 облачной версии - это предупреждение не актуально.

Как работает телефония в Битрикс24

Для понимания работы Телефонии схематично поясним её алгоритм.

Основой работы всей телефонии является Контроллер, расположенный на сервере "1С-Битрикс". Именно он производит управление всеми звонками, контроль за лицензиями.

При начале звонка с портала (телефонного аппарата), клиент сначала подключается к голосовым серверам Voixplant. Затем голосовые сервера подключаются к Контроллеру что бы проверить лицензию. После проверки Контроллер передаёт настройки подключения обратно в звонок.

Коротко это можно описать так: Voixplant -> Контроллер -> Voixplant. Эта цепочка занимает не много времени.

В случае если контроллер в данный момент не доступен, то реализуется возможность работы телефонии без контроллера. Раз в сутки в аккаунт телефонии (на голосовых серверах Voixplant) Контроллер сохраняет секретный ключ и адрес портала. Если с Контроллером телефонии все в порядке то работа осуществляется по обычной схеме. (Надо проверять лицензию и сохранять статистику для аналитики.) Но если до Контроллера не получилось достучаться по каким-то причинам, то происходит переход на режим прямого доступа через упомянутые ключи. Для клиента же обычный звонок и звонок в режиме прямого доступа - ничем не отличается, он даже не будет знать что что-то было не так.

В логе звонка, при работе без контроллера, будет вот такая запись:

Техническая особенность телефонии в коробочной версии: для корректной работы телефонии необходимо чтобы агенты были настроены на cron, а не на хитах.
Особенность запуска агентов на cron для телефонии: частота запуска не менее 1 раза в 2 минуты, рекомендуется запускать каждую минуту.

Настройки локальной сети

Использование телефонии требует правильной настройки локальной сети, откуда совершаются звонки. Для каждого из видов звонков есть свои требования по настройкам, которые указаны на страницах с описанием конкретного способа. Но есть и общие требования. Для корректной работы необходимо, чтобы в вашей сети были открыты определённые порты и адреса.

Внимание! Часть требуемых для открытия адресов выставляются оператором связи Voximplant. Эти адреса могут меняться. В текущей документации отслеживаются эти изменения. Администраторам порталов рекомендуется при возникновении проблем со связью первым делом проверять актуальность открытых в вашей сети адресов.
  • порты: 443 TCP, 1935 TCP, 5060 UDP, 5060 TCP, 1935 UDP, 3478 UDP, 8000-48000 UDP.
  • адреса:
    46.137.125.240 | 46.137.97.175 | 46.137.123.236 | 69.167.178.6 | 176.34.103.175
    46.235.53.93 | 46.235.53.68 | 34.240.122.254 | 52.17.35.151 | 195.208.184.173
    Требования по адресам от компании Voximplant:
    149.11.34.27,
    149.11.44.91,
    149.56.83.166,
    149.202.24.238,
    149.56.83.167,
            38.122.236.126,
    173.237.15.28,
    173.237.12.68,
    173.237.16.194,
    173.237.12.69,
            173.0.146.133,
    173.0.146.163,
    89.184.82.92,
    89.184.83.146,
    89.184.82.7,
    89.187.182.201,
    89.187.182.203,
    89.187.182.220,
    89.184.82.139,
    89.184.83.207,
            89.184.65.247,
    89.219.34.163,
    95.213.221.98,
    95.213.228.3,
    95.213.198.99,
            198.27.75.221,
    185.164.148.247,
    185.164.148.249,
    185.164.148.245,
    185.164.148.237,
    185.164.149.11,
    185.164.149.13,
    185.164.149.15,
    185.164.149.17,
    185.164.149.19,
            185.164.149.21,
    185.164.148.234,
    185.164.148.232,
    185.164.149.26,
    185.164.149.28,
            185.164.148.228,
    185.164.148.226,
    185.164.148.231,
    185.164.149.20,
    185.164.148.244,
    185.164.148.233,
    185.164.149.22,
    185.164.148.236,
    185.164.149.12,
    185.164.149.18,
            185.164.149.29,
    185.164.148.227,
    185.164.148.229,
    185.164.148.246,
    185.164.149.16,
            185.164.149.14,
    185.164.148.248,
    185.164.149.27,
    185.164.149.100,
    185.164.148.1,
    82.202.208.156,
    82.202.208.157,
    5.255.230.141,
    80.93.190.218,
    80.93.190.219,
            80.93.190.220,
    141.8.185.5,
    141.8.185.3,
    142.0.192.196,
    142.0.198.236,
            142.0.198.244,
    142.0.196.148,
    66.242.15.141,
    66.242.15.143,
    66.242.4.112,
    86.62.123.138,
    203.195.120.44,
    203.195.121.227,
    161.202.172.211,
    188.42.189.51,
            188.42.37.36,
    84.201.156.10,
    84.201.161.148,
    84.201.164.10,
    84.201.132.230,
            84.17.63.66,
    84.17.41.62,
    84.17.41.63,
    88.212.245.252,
    88.212.234.226,
    169.57.161.232,
    169.45.66.184,
    35.198.89.233,
    35.224.221.105,
    35.188.10.140,
            35.197.173.8,
    35.199.91.11,
    35.187.244.139,
    35.199.101.147,
    177.54.157.36,
            104.198.170.178,
    23.105.225.156,
    23.105.225.158,
    23.105.225.131,
    51.77.43.137,
    51.77.43.45,
    51.83.36.23,
    51.75.155.142,
    51.77.246.95,
    51.83.214.197,
            51.83.214.198,
    51.77.85.41,
    96.46.191.68,
    96.46.191.76,
    96.46.186.133,
            193.176.181.241,
    130.193.37.201,
    79.137.19.50,
    178.159.33.225,
    69.167.178.6,
    18.229.108.9,
    18.140.111.54,
    13.48.50.139,
    13.55.250.61,
    3.123.246.217,

Примечание: Данные требования распространяются на firewall и антивирус.

Для корректной работы телефонии (мобильная телефония, телефония в браузере и десктоп клиенте) необходимо что бы в операционной системе пользователя было актуально время. Администратору следует проверить включена ли синхронизация времени в настройках операционных систем пользователей или синхронизировать локальный сервер времени.

Внимание! Если администратор обнаружил, что корпоративный портал не ведёт истории звонков, то необходимо проверить настройки сервера NGINX на сайте или на балансировщике. Как правило, отсутствует включение proxy_ignore_client_abort on;. Эту настройку необходимо включать для конкретного location.

Звонки с Битрикс24 можно осуществлять разными способами:

  • IP телефония на стационарные и мобильные телефоны
  • IP телефония с помощью офисных АТС
  • Голосовые и видео звонки с Бизнес-чата или Десктопного приложения внутри компании
    •

    IP телефония

    IP телефония позволяет звонить на любые стационарные и мобильные телефоны. В отличие от голосовых звонков, IP-телефония - платная услуга, реализуемая с помощью оператора связи Voximplant.

    Без аренды отдельного телефонного номера возможны только исходящие звонки. Если нужно осуществлять и входящие, то необходимо арендовать телефонный номер. Есть возможность скрывать арендованный номер и заменять его для ваших клиентов на любой существующий офисный номер. (Либо таким образом можно скрыть номер базовой станции.) Арендовав номер для приема входящих звонков и привязав его в качестве обратного получается полноценное телефонное решение.

    Используя эту телефонию вы имеете возможность создать удобные правила обработки звонков: маршрутизацию и сохранение записи разговоров. Настройка маршрутизации позволяет:

    • Перенаправить входящий звонок на конкретного сотрудника.
    • Перенаправить звонок менеджеру, закреплённому за этим номером.
    • Задать очередь сотрудников и число гудков, которые должны пройти до переадресации к следующему в очереди сотруднику.
    • Указать сервису что делать, если никто из очереди сотрудников не ответил на входящий звонок.

    Тарифы установлены отдельно для России, СНГ, Европы и США. Оплата за трафик производится оператору VoxImplant через Битрикс24.

    Битрикс24 позволяет вам вести детализацию звонков с просмотром даты, времени, стоимости звонка, а так же с файлом записи. Возможность записи звонков управляется администратором портала. Большой архив записей может существенно уменьшить свободное место на диске.

    Пользователи Экстранета не могут звонить через ваш портал.

    Подробнее об IP телефонии. (Внимание, ссылка уводит на другой курс!)

    IP телефония с помощью офисных АТС

    Есть возможность подключить к вашему порталу офисные или облачные АТС. В этом случае используются уже имеющиеся у вас офисные номера, которые отображаются для ваших клиентов так же как раньше. Пользователи портала после такой интеграции перестают применять IP-телефоны и используют вместо них микрофоны на компьютерах.

    Этот вид телефонии так же позволяет осуществлять бесплатные входящие звонки. Платная ежемесячная лицензия требуется только на исходящие звонки, оплата за трафик осуществляется по расценкам ваших операторов связи через системы оплаты самих операторов связи.

    IP телефония с помощью офисных АТС позволяет:

    • Все входящие звонки перенаправлять в портал Битрикс24. Звонки идентифицируются, обрабатываются по вашим правилам, фиксируются в CRM, записываются. К ним всегда можно вернуться при необходимости.
    • Совершать исходящие звонки из Битрикс24 через каналы присоединенные к вашей IP-АТС с фиксацией и обработкой, как и в случае со входящими.

    Минусы такой интеграции:

    • Полностью выводится из эксплуатации внутренняя часть имеющейся IP-АТС. (Она рассматривается только с точки зрения некоего блока ответственного за внешние линии.)
    • Необходимость дополнительных платежей.

    Примечание: Настройка SIP подключения различна для облачных и офисных АТС. Для тестирования функционала вам доступны бесплатные минуты для исходящих звонков..

    Голосовые и видео звонки с Бизнес-чата или Десктопного приложения внутри компании

    Самый простой и доступный способ общения. Не требует никаких настроек со стороны пользователя или администратора портала. Всё работает "из коробки" и бесплатно. Для осуществления голосового и видеозвонка необходим микрофон и видеокамера. Возможны групповые видеозвонки (до 4-х участников).

    К недостаткам способа можно отнести ограниченность числа возможных абонентов: пользователи вашего портала (в том числе и пользователи экстранета) и контакты из сети Битрикс24Network. Для звонков по этому способу нет возможности вести запись разговора штатными методами Битрикс24.

    Подробнее о звонках с Бизнес-чата или Десктопного приложения. (Внимание, ссылка уводит на другой курс!)


Баланс и статистика
595 / 694

На странице Телефония > Баланс и статистика можно отслеживать состояние счёта и контролировать расходы.

Баланс

С помощью кнопки Пополнить можно перейти к форме пополнения счёта. Пополнить счёт можно только суммой, кратной 1000 рублей. Заполните поля формы, нажмите Оформить заказ и оплатите заказ.

Если по каким-то причинам не была произведена оплата аренды номера в нужный срок, то работа номера блокируется. Блокировка номера означает, что не будут приниматься/отправляться входящие и исходящие звонки. Но номер не снимается с арендатора в течение двух месяцев.

Внеся оплату в течение этого времени можно подключить к своему Битрикс24 старый номер. В этом случае отсчёт аренды номера пойдёт с даты фактической оплаты.

Оплата услуг работает по принципу автопродления, то есть, если у пользователя истёк номер по времени аренды, то новые добавленные деньги пойдут на его продление в первую очередь, а только потом на оплату трафика.

Виджет Регулярные платежи выводит информацию о сроке, до которого произведена оплата арендованных номеров.

Виджет SIP Коннектор информирует о количестве имеющихся в распоряжении бесплатных минут, а также о сроке окончания аренды после оплаты:

Статистика

На странице также доступна обобщённая (по месяцам) и детальная (по каждому звонку) статистика звонков. Гаджет Расходы показывает три последних месяца, когда использовалась телефония.

По ссылке Детализация откроется список всех осуществлённых звонков:

При просмотре детальной статистики, если администратором было разрешено производить запись звонка, можно прослушать файл с записью разговора (колонка Запись).

Если кликнуть по фамилии сотрудника, то включится фильтр и будут выведены только звонки этого сотрудника. Аналогичную фильтрацию можно провести по статусам звонков, либо по обоим параметрам вместе.

При просмотре детальной статистики также можно обратиться к логу каждого конкретного звонка (колонка Журнал). Эта опция очень полезна администраторам при настройке АТС на работу через сервис Битрикс24.

Примечание: Если звонок был сброшен до того как система успела определить сотрудника, ответственного за этот звонок, в колонке Сотрудник будет прочерк.

Данные, выводимые на странице можно отфильтровать и экспортировать в формате Excel (доступно только на платных тарифах сервиса и в коробочной версии):


Управление номерами
596 / 694

На странице Телефония > Управление номерами производятся настройки портала на использование телефонии.

Привязка номера

Привязка номера - это указание номера, который будет высвечиваться у абонента в качестве номера, с которого ему звонят. Чтобы не было соблазна указывать номер "от фонаря" предусмотрена процедура проверки, при которой система совершает звонок на этот номер, диктует цифровой код который надо вводить при регистрации линии.

Привязанный номер позволяет осуществлять обратные звонки.

Если не будет привязан ни какой номер, то в качестве исходящего будет отображаться базовый номер станции.

Настройка номера производится по аналогии с настройкой арендованного номера за исключением опции переадресации и обработки добавочного номера. При этом учтите, что на привязанный номер не может быть входящих звонков. Например, настройка Очереди - для арендованного это очередь для входящих и обратных, а для привязанного - только для обратных.

Арендовать номер

Компания может взять в аренду "красивый" номер, который может привязать к своему порталу. Для этого достаточно выбрать страну, регион и один из предложенных номеров. Список стран и регионов постоянно расширяется.

Выбрав и подключив номер произведите настройку маршрутизации и обработки входящих звонков.

Если в номере отпала необходимость, его можно удалить. Удаление номера отложенное по времени, он отключается через сутки. Это сделано специально чтобы спасать владельцев компании от необдуманных решений или случайных ошибочных действий. Об отключении номера сообщается письмом на контактный e-mail портала.

Текст письма об отключении номера
Вы отправили запрос на отключение телефонного номера +74951340483 от вашего Битрикс24. Номер будет отключен через 24 часа.

Если вы отключили номер по ошибке, пожалуйста, отмените отключение в настройках телефонии (в течение суток после запроса на отключение): https://******.bitrix24.ru/settings/telephony/settings.php?MODE=RENT

Обратите внимание, если к моменту отключения номера у вас остается оплаченный период аренды, эти деньги возвращены не будут. Повторно арендовать этот номер можно будет не раньше, чем через 3 месяца после отключения

Пока номер не отключен из интерфейса, он все еще активен и с него можно делать звонки, принимать и оплачивать.

Примечание: Оплачивая номер только на один месяц его можно использовать для какой-то рекламной компании, не обременяя обычные рабочие номера. А после компании - отключить.

Примечание: Битрикс24 поддерживает звонки на номера в международном формате. Для России автоматически заменяется ведущая 8 на +7 и поддерживается звонок на короткий номер в некоторых городах.

Подключить SIP АТС

Функционал подключения офисной или облачной АТС.

Настройка номеров

После аренды номера или подключения SIP АТС можно произвести настройку этих номеров на работу с Битрикс24: маршрутизацию звонков и мелодии для звонка.

Маршрутизация звонков позволяет выстроить очередь из сотрудников, по которым будет распределяться входящие звонки. Мелодии для звонков можно задать свои для каждого вида операций со звонком.

Значения полей при настройке маршрутизации:

  • Обработка добавочного номера - установленный флажок в поле даст указание сервису Битрикс24 перенаправлять входящий звонок на конкретного сотрудника, если был набран номер этого сотрудника, а так же что делать, если сотрудник не отвечает на звонок.
  • Проверять номер по базе CRM - установленный флажок включит проверку входящего номера по базе CRM и перенаправит звонок менеджеру, закреплённому за этим номером. Так же можно задать действия на случай, если сотрудник не отвечает на звонок и что делать, если номер не найден в базе CRM.

    Чтобы при ручном перенаправлении звонка лид создавался на имя ответственного сотрудника, а не сотрудника, принявшего звонок, используйте опцию Автоматически менять ответственного за лид, при ручном перенаправлении звонка на другого сотрудника.

    Для платных тарифов доступна опция Источник для нового лида. При аренде отдельного номера для каких-либо целей (например, для рекламной компании на веб-сайте) можно указать источник лида. Таким образом можно выявлять самые успешные каналы для лидов.

  • Очередь - задание собственно очереди сотрудников и задание числа гудков, которые должны пройти до переадресации к следующему в очереди сотруднику. Возможны два вида очереди: Равномерно и Строго по очереди.
    • Равномерно: порядок следования сотрудников в списке не имеет значения, звонки будут распределяться между сотрудниками в очереди: если предыдущий звонок был сотруднику А, то следующий придет сотруднику Б и так далее.

      Особенность работы очереди в режиме Равномерно

      Звонок распределяется по пользователям в зависимости от времени их последнего звонка:

      • оператор1 - отвечал в 15-10
      • оператор2 - отвечал в 13-20
      • оператор3 - отвечал в 14-40

      Следующий звонок поступит на оператора 2, а не на оператора 1, т.к. он отвечал самым последним, следующий на оператора 3, а только потом на первого.

    • Строго по очереди: порядок следования сотрудников в списке имеет значение, все звонки направляются на первого сотрудника, если он не отвечает, то на второго и так далее по очереди. Если нужно поменять порядок следования, то нужно удалить старый список сотрудников и добавить их заново в нужной очерёдности. Бесконечная очередь в этом режиме не доступна, связь прервётся после окончания списка сотрудников.
    • Одновременно всем - звонок поступит одновременно всем свободным сотрудникам из очереди, и клиенту ответит тот, кто первым примет звонок. (Выбор этой опции недоступен для бесплатного тарифа.)

    Примечание: Опция Не направлять звонок на сотрудника, если не начат рабочий день или установлен перерыв позволяет направлять звонки только реально работающим сотрудникам. Она доступна только на тарифах с учётом рабочего времени.

  • Обработка неотвеченного вызова - указание что делать если никто из очереди сотрудников не ответил на входящий звонок. Значение Вернуть обратно в очередь этого поля зацикливает входящий звонок до ответа на него сотрудником.
  • Сохранять запись всех разговоров - при установленном флажке все разговоры будут доступны в статистике звонков и сохранены в папке Общем диске > Телефония: записи звонков. Объём этой папки учитывается в рамках общего места на портале, то есть хранение бесплатно пока не исчерпано бесплатное место.

    Имя файла записи формируется по шаблону: дата_время_номер. Например: 2014-06-10_01-55-19__7************.flv.

    Примечание: доступ к этой папке ограничен администраторами портала, и если есть необходимость можно в настройках папки открыть доступ и другим сотрудникам.

    Сам факт записи разговора согласно законодательству РФ не является незаконным. Под действие запрещающих статей законодательства может попасть использование записи в каких либо целях. Законность использования записи будет определяться исходя из конкретной ситуации. Во избежание возможных проблем лучше предупреждать клиента о том, что ведётся запись с помощью опции Проигрывать предупреждение о начале записи при входящем звонке. (Обратите внимание, что предупреждение автоматически срабатывает только при входящем звонке. При исходящем менеджер должен предупредить о записи лично.)

    Внимание! Имеется ограничение на количество записей разговоров для бесплатного тарифа. Будут записаны 100 первых звонков в каждый календарный месяц. Для платных тарифов такого ограничения нет.
  • Оценка качества обслуживания - инструмент оценки работы менеджера клиентом. При включении опции после завершения звонка клиенту будет предложено дать оценку работе менеджера. Голосовые сообщения этой опции настраиваются в разделе Мелодии. (Выбор этой опции недоступен для бесплатного тарифа.)

    Примечание: Просмотр оценок возможен на странице Детализация звонков.

Настройка времени

В нерабочее время клиентам выводится звуковое сообщение, заданное в разделе Настройка времени. Этот сигнал будет выводиться в соответствии с настройками, заданными в этом же разделе.

Поля настроек интуитивно понятны и в комментариях нуждается только поле Обработка звонка во внерабочее время. Оно предлагает на выбор:

  • Включить автоответчик по умолчанию, включается указанная мелодия.
  • Перенаправить на указанный номер - появится поле для ввода номера.
  • Завершить звонок - данный вызов не тарифицируется, это важно для 8-800, которые платят деньги за входящие. Выбор этого значения позволяет спасти владельца федерального номера от мошеничества.

Голосовое сопровождение мелодии звонка автоматически выставляется на язык портала. При необходимости его можно поменять.

Номер для перенаправления

Опция доступна только для SIP-телефонии и используется, когда подключенная sip-телефония не может совершать исходящие вызовы (например, просрочена оплата). В этом случае не работает перенаправление на мобильный или стационарные телефоны. Опция позволяет перенаправить звонки на другую SIP-телефонию или арендованный или привязанный номер.

Внимание! В перенаправленном вызове определяется номер, который указан для перенаправления, а не номер звонящего. Битрикс24 не является оператором связи и не имеет возможности подменять номер на любой другой. Подмена возможна только на подтверждённый через привязку номер, а в случае перевода звонка с одного sip на другой подмена вообще не представляется возможной.


Права доступа
597 / 694
Внимание! Управление правами доступно в коробочной версии Битрикс24 и на платных тарифах (кроме Проект+) облачной версии.

Администратор портала имеет возможность настроить права доступа к Телефонии. Управление доступом осуществляется по ролям на странице Телефония > Права доступа:

По умолчанию имеются роли: Администратор, Директор, Начальник отдела и Менеджер. Администратор обладает максимальным количеством прав, Менеджер - минимальным.

Примечание: для сохранения обратной совместимости, администраторы портала всегда имеют максимальные права доступа, независимо от назначенной им роли.

При необходимости по ссылке Добавить в Списке ролей можно создать свою роль со своими параметрами (либо отредактировать имеющуюся роль) :

Для создания роли введите её название в поле Роль и укажите права, необходимые для этой роли.

По умолчанию для всех сотрудников компании заданы права роли Менеджер и только администраторам установлено право Администратор. При необходимости можно задать своё распределение ролей с помощью ссылки Добавить право доступа. Если пользователю назначено несколько ролей, то реальные права доступа строятся по принципу объединения прав ролей, а не пересечения.

Для прослушивания записей еще учитываются права доступа сотрудника к папке Общего диска Телефония - записи звонков.

Внимание администраторов и разработчиков! При использовании REST API телефонии имеют значение заданные на этой странице права. То есть внешнее приложение может работать для одних пользователей, но не работать для других.


Пользователи
598 / 694

Примечание: Страница доступна только администратору сервиса.

На странице Телефония > Пользователи производится настройка внутренних номеров для переадресации звонков в компанию на конкретных сотрудников.

Для этого достаточно воспользоваться ссылкой Изменить в строке нужного сотрудника. Откроется форма настройки, в которой нужно указать конкретный номер переадресации:

Примечание: если одинаковый номер привязан для звонков и через Битрикс24 и через свою АТС, то звонить через свою АТС не получится, звонки будут уходить через Битрикс24.

Также переадресовать звонок другому сотруднику можно непосредственно из панели Бизнес-чата при приеме входящего звонка.

Клиент может звонить сразу своему менеджеру по внутреннему номеру. Чтобы такое было возможно необходимо:

  • назначить сотруднику внутренний номер;
  • включить опцию Обработка добавочного номера в настройках маршрутизации звонков.

Если сотрудник будет работать через телефонный аппарат, а не звонить с компьютера, то необходимо установить Вкл в опции Подключить телефонный аппарат и использовать появившиеся данные для настройки телефонного аппарата. Значение поля Пароль можно поменять.

При увольнении сотрудника у его учётной записи будет деактивироваться привязка к телефонному аппарату. Добавочный номер не будет активен, его можно будет выдать другому сотруднику. Звонок на него не будет направляться ни по правилам СРМ, ни по правилам маршрутизации звонков. Но, тем не менее, администратору необходимо сменить в СРМ ответственного и удалить уволенного из очереди.


Телефония (voximplant)
599 / 694

Модуль для работы с облачной телефонией Телефония (voximplant) - базовый при любом варианте использования телефонии. Он необходим как при использовании телефонии от VoxImplant, так и при использовании АТС, так как производит конвертацию телефонного сигнала в формат WebRTC, понятный для браузеров. В работе модуля используются сервисы VoxImplant.

Установка модуля выполняется обычным для коробочной версии Битрикс24 способом, на странице Настройки> Настройки продукта > Модули. При установке проверяются версии модулей Главный (main), Интранет (intranet), Push & Pull (pull) с активным сервером очередей и Веб-мессенджер (im).

Примечание: для работы модуля необходима активная лицензия на коробочную версию Битрикс24. При обращении в ТП сервиса Битрикс24 по поводу проблем с телефонией нужно сообщать имя аккаунта.

При установке необходимо ввести адрес портала:

Примечание: Для корректной работы модуля требуется, что бы обработчики событий запускались через cron.

Внимание! Если на портале стоит редирект на https версию портала, то в настройках модуля телефонии сервер обязательно должен быть прописан через https.

Настройка локальной сети

Работа модуля требует настройки файерволла локальной сети.

В обязательном порядке должен быть разрешён доступ из Сети к странице портала http://<ваш_домен>/bitrix/tools/voximplant/receiver.php (до версии 17.0.7 файл назывался - http://<ваш_домен>/services/telephony/info_receiver.php). Так как IP-адреса провайдера телефонии могут меняться, то к этой странице не должно быть никаких ограничений доступа. Однако, если по политике безопасности ограничения требуются, то должен быть разрешён минимальный доступ к этой странице с IP:

46.137.125.240 46.137.97.175 46.137.123.236 69.167.178.6 176.34.103.175
Требования по адресам от компании Voximplant:

149.11.34.27, 149.11.44.91, 149.56.83.166, 149.202.24.238, 149.56.83.167, | 38.122.236.126, 173.237.15.28, 173.237.12.68, 173.237.16.194, 173.237.12.69, | 173.0.146.133, 173.0.146.163, 89.184.82.92, 89.184.83.146, 89.184.82.7,
89.187.182.201, 89.187.182.203, 89.187.182.220, 89.184.82.139, 89.184.83.207, | 89.184.65.247, 89.219.34.163, 95.213.221.98, 95.213.228.3, 95.213.198.99, | 198.27.75.221, 185.164.148.247, 185.164.148.249, 185.164.148.245, 185.164.148.237,
185.164.149.11, 185.164.149.13, 185.164.149.15, 185.164.149.17, 185.164.149.19, | 185.164.149.21, 185.164.148.234, 185.164.148.232, 185.164.149.26, 185.164.149.28, | 185.164.148.228, 185.164.148.226, 185.164.148.231, 185.164.149.20, 185.164.148.244,
185.164.148.233, 185.164.149.22, 185.164.148.236, 185.164.149.12, 185.164.149.18, | 185.164.149.29, 185.164.148.227, 185.164.148.229, 185.164.148.246, 185.164.149.16, | 185.164.149.14, 185.164.148.248, 185.164.149.27, 185.164.149.100, 185.164.148.1,
82.202.208.156, 82.202.208.157, 5.255.230.141, 80.93.190.218, 80.93.190.219, | 80.93.190.220, 141.8.185.5, 141.8.185.3, 142.0.192.196, 142.0.198.236, | 142.0.198.244, 142.0.196.148, 66.242.15.141, 66.242.15.143, 66.242.4.112,
86.62.123.138, 203.195.120.44, 203.195.121.227, 161.202.172.211, 188.42.189.51, | 188.42.37.36, 84.201.156.10, 84.201.161.148, 84.201.164.10, 84.201.132.230, | 84.17.63.66, 84.17.41.62, 84.17.41.63, 88.212.245.252, 88.212.234.226,
169.57.161.232, 169.45.66.184, 35.198.89.233, 35.224.221.105, 35.188.10.140, | 35.197.173.8, 35.199.91.11, 35.187.244.139, 35.199.101.147, 177.54.157.36, | 104.198.170.178, 23.105.225.156, 23.105.225.158, 23.105.225.131, 51.77.43.137,
51.77.43.45, 51.83.36.23, 51.75.155.142, 51.77.246.95, 51.83.214.197, | 51.83.214.198, 51.77.85.41, 96.46.191.68, 96.46.191.76, 96.46.186.133, | 193.176.181.241, 130.193.37.201, 79.137.19.50, 178.159.33.225, 69.167.178.6,
18.229.108.9, 18.140.111.54, 13.48.50.139, 13.55.250.61, 3.123.246.217,

По этим же адресам должен быть открыть доступ из портала. При этом при смене IP-адреса провайдером у вас могут возникнуть проблемы с работой телефонии.

Настройка модуля

В Административной части, в форме настроек модуля можно включить режим отладки:

После включения этого режима в файле /modules/voximplant.log будет вестись лог всех событий, связанных с работой модуля. Для настроек критична ошибка вида:

2014.09.14 10:31:48
PORTAL GET INCOMING CONFIG
Array
(
[ERROR] => Config is`t found for number: 9003
)

Ошибка связана с расхождением номера, на который идёт запрос на портал и номером, на который отвечает модуль SIP коннектор. В приведённом выше примере это номер 9003. В этом случае рекомендуется в блоке Исходящие настройки настроек SIP АТС в поле Номер телефона указать номер, выводимый в этой ошибке.


Настройки телефонии
600 / 694

Страница для настройки параметров телефонии.

Загрузка документов

В соответствии с законодательством некоторых стран, телефонный оператор требует предоставить юридические документы для работы с арендованными номерами. Если в вашей стране есть такое законодательно требование, то будет активна кнопка Загрузить документы. По нажатию на кнопку откроется форма для загрузки документов. Для физических и юридических лиц формы и требования к документам разные.

Внимание! Компания "1С-Битрикс" не собирает и не хранит загружаемые документы. Эти данные передаются вашему оператору связи.

Настройка номеров по-умолчанию

При настройке пользователей нужно заполнять поле Номер для исходящего звонка. Это тот номер, который отобразится у клиента как исходящий. Для упрощения работы при настройках пользователей можно использовать Номер по умолчанию, который будет отображаться сразу у всех пользователей. А при необходимости, заменять его на другой в настройках конкретного сотрудника.

Настройка интерфейса звонков

В зависимости от условий работы и привычек пользователей можно настроить вид чата для телефонных звонков. Возможны варианты: не отображать звонки вообще, отображать в едином или в отдельном для каждого номера чатах.

Интеграция с CRM

Выбор момента для запуска бизнес-процесса по созданию лида. Если выбрать В момент поступления звонка, то ответсвенным за лид будет тот, кто снял трубку. Если выбрать В момент окончания звонка, то ответственным будет последний говоривший с клиентом.

Чёрный список

Битрикс24 позволяет блокировать звонки телефонных хулиганов. Для этого необходимо активизировать опцию Автоматически блокировать телефонные номера злоумышленников в нерабочее время на странице Телефония > Чёрный список и задать для этой опции параметры.

Блокировка номера постоянная и не снимается. Поэтому очень важно дать правильное сообщение в автоответчике для нерабочего времени, чтобы избежать ошибочной блокировки номеров клиентов. При блокировании номера администратор будет уведомлён об этом.

Если известны конкретные телефонные номера, приём звонков с которых нежелателен, то их можно включить в "Черный список".


Телефонные аппараты и софтфон
601 / 694

Настольные аппараты

Сотрудники компании могут при звонках с сервиса Битрикс24 использовать привычные настольные телефонные аппараты. Использование аппаратов ускоряет работу телефонии на сервисе. Для этого необходимо настроить эти устройства на работу с Битрикс24.

В настройках пользователя после включения опции поддержки телефонных аппаратов выдается адрес сервера, логин и пароль. Эти данные нужно указать в телефоне. После этого, аппарат регистрируется на серверах телефонии и начнёт работать.

Работать в Битрикс24 может любой SIP телефон. Число моделей таких телефонов велико, протестировать все их на работу в сервисе крайне сложно. Список проверенных на работу телефонов - в таблице ниже.

DECT телефоны можно подключать через SIP шлюз (VoIP SIP адаптеры). Протестирована работа на Linksys PAP2T.

При использовании аппарата сотрудник не обязательно должен быть онлайн на портале, но в этом случае ему не будет доступна карточка звонка.

Так же возможно использование телефонии на софтфонах под Windows, iOS, Android: Media-5, Zoiper, CSipSimple и другие.

Внимание! Поддержка софтфонов находится в бета-режиме, стабильная работа гарантируется только с телефонными аппаратами .

Список проверенных аппаратов
Производитель | Модель | Производитель | Модель | Производитель | Модель
Linksys | SPA3102 | Siemens Gigaset | C610A | Panasonic | KX_TGP-500
 | PAP2T |  | A510IP |  | KX-UT113RU
 | SPA921 |  | al110 |  | KX-TGP600RUB
Grandstream | GXP-2140 | Escene | ES290 | SkypеMate | USB-W1DL
 | DP715 |  | ES320 | Jabra | PRO™ 930
 | GXP1405 | D-Link | DHP-150S |  |
 | GXP1400 | Cisco | SPA 303 |  |
 | GXV3175 |  | SPA122 |  |

Внимание! Возможны ситуации, когда в каких-то конкретных условиях не работают указанные выше аппараты вообще или на отдельных рабочих местах. Эта проблема может возникать по множеству причин: от неисправности механической или электронной частей конкретного аппарата до проблем конкретной телефонной линии или локальной сети. (Например, настройки локальной сети позволяют выходить с интернет строго с определенных IP адресов, и те адреса, которые выдаются на подключаемых аппаратах, просто не прописаны в фаерволле.)
В силу этого компания Битрикс не гарантирует 100% работу телефонных аппаратов и не решает проблем с такими конкретными подключениями.

Если есть проблемы при переводе звонка через sip-аппарат,
то в решении этих проблем может помочь знание того, как происходит переадресация звонка через аппарат.

В переадресации участвуют три стороны:

  1. Тот, кто переводит (Transferor)
  2. Кого переводит (Transferee)
  3. На кого переводят (Transfer target)

В момент совершения переадресации sip-аппарат обменивается рядом sip-сообщений с оператором связи Voximplant. По результатам этого обмена Voximplant:

  • объединяет медиа-потоки Transferree и Transfer target
  • разъединяет медиа-потоки Transferree и Transferor
  • во все три плеча отправляет событие CallEvents.TransferComplete с указание роли этого плеча в переводе.

Если в журнале звонка данное событие отсутствует (и клиент нажимает правильные кнопки для перевода), то:

  • либо у клиента аппарат формирует нестандартные сип-команды,
  • либо у клиента какие-то сетевые проблемы.

В этом случае, лог такого звонка надо отправлять в техподдержку Битрикс24, разобраться что именно приходило от аппарата клиента, может только оператор связи Voximplant.

Битрикс софтфон

Телефонию можно использовать и с мобильных устройств. Для этого лучше всего использовать Мобильное приложение с его возможностями софтфона.


Примеры настроек телефонов
602 / 694

Ниже представлены примеры для конкретных телефонных аппаратов. Настройки других телефонов можно проводить по аналогии с этими примерами.

DLink DPH-150S

Необходимые поля:

  1. Адрес сервера - это значение поля Сервер в карточке пользователя.
  2. Порт сервера - стандартный 5060.
  3. Имя учётной записи - это значение поля Логин в карточке пользователя.
  4. Пароль - значение поля Пароль в карточке пользователя
  5. Номер телефона - это значение поля Логин в карточке пользователя.

Сisco SPA303

Настройки осуществляются в режиме администратора

Необходимые поля:

  1. SIP PORT - стандартный 5060.
  2. Proxy - это значение поля Сервер в карточке пользователя.
  3. USER ID, AUTH ID - это значение поля Логин в карточке пользователя.
  4. Password - значение поля Пароль в карточке пользователя
  5. USE AUTH ID - в положении Вкл.

Gigaset C610A

Настройки осуществляются на двух формах:

и по нажатию на Показать доп. настройки откроется форма:

Необходимые поля:

  1. Имя входа в систему, Имя пользователя - это значение поля Логин в карточке пользователя.
  2. Пароль для входа в систему - значение поля Пароль в карточке пользователя
  3. Домен, Адрес прокси сервера - это значение поля Сервер в карточке пользователя.
  4. Порт прокси сервера, Порт сервера регистрации - стандартный 5060.

Gigaset A510IP

Настройки осуществляются на двух формах:

Необходимые поля:

  1. Имя входа в систему, Имя пользователя - это значение поля Логин в карточке пользователя.
  2. Пароль для входа в систему - значение поля Пароль в карточке пользователя
  3. Домен, Адрес прокси сервера - это значение поля Сервер в карточке пользователя.
  4. Порт прокси сервера, Порт сервера регистрации - стандартный 5060.

Linksys SPA921

Необходимые поля:

  1. Порт сервера - стандартный 5060.
  2. Адрес сервера - это значение поля Сервер в карточке пользователя.
  3. Имя учётной записи и пароль - это значение поля Логин в карточке пользователя и пароль.
  4. Номер телефона - это значение поля Логин в карточке пользователя.

Panasonic, аппараты серии KX
  1. Подключить телефонный аппарат к интернету.
  2. Зайти в настройках: Сервис IP > Настройки сети > Настройки IP и запомнить присвоенный аппарату IP адрес (например: 192.168.0.101).
  3. Зайти в настройках: Сервис IP > Настройки сети > Встроен.Web и выбрать Вкл..
  4. Ввести присвоенный телефону IP-адрес в адресную строку и указать реквизиты доступа по умолчанию:
    • пользователь: admin
    • пароль: adminpass
  5. Задать настройки как на изображении:
    1. Номер телефона - указывается внутренний номер сотрудника (только цифры) из карточки пользователя.
    2. ID - это значение поля Логин в карточке пользователя.
    3. Пароль - это значение поля Пароль в карточке пользователя и пароль.
    4. Адреса серверов - это значение поля Сервер в карточке пользователя.
    5. Порты серверов - стандартный 5060.

Внимание! Русскоязычный и англоязычный интерфейсы настроек могут отличаться порядком следования полей и их набором по группам. Поэтому механическое заполнение полей "по порядку следования" не обеспечивает правильных настроек. Ниже даны названия полей в англоязычном интерфейсе и значения для их заполнения.

Все поля, в названиях которых есть server address, service domain должны заполняться значением из поля Сервер в карточке пользователя.

Все поля, в названиях которых есть server port заполняются стандартным значением 5060.

Все поля вида phone numder, sip uri и authentification id должны заполняться значением из поля Логин.

Все поля с password должны заполняться значением из поля Пароль.

Yealink, все модели

Примечание: Перед настройкой аппаратов рекомендуется сбрасывать настройки до заводских.

  1. Настройка аккаунта осуществляется через веб-интерфейс. Для входа в веб-интерфейс необходимо знать IP-адрес телефона, для этого нужно нажать кнопку ОК на телефонном аппарате. На экране телефона появится следующее окно:

  2. IP-адрес из первой строки нужно ввести в адресной строке браузера и ввести логин и пароль пользователя, по умолчанию:
    • логин - admin
    • пароль - admin
  3. В открывшемся окне настройки SIP-регистрации осуществляются в разделе Аккаунт:

  4. Заполните необходимые поля:
    1. Аккаунт должен быть включён
    2. Поля Лейбл и Отображаемое имя не используются в регистрации, поэтому в них можно записать любую информацию.
    3. Имя регистрации и Имя пользователя - значение берется из поля Логин в карточке пользователя.
    4. Пароль - значение берется из поля Пароль в карточке пользователя
    5. Адрес SIP-сервера - значение берется из поля Сервер в карточке пользователя.
    6. Порт - порт используется стандартный 5060

Escene
  1. На телефонном аппарате нажимаем Меню и, затем, цифру 1. Во второй строке будет указан IP адрес, к которому подключен данный телефон.
  2. IP-адрес нужно ввести в адресной строке браузера и ввести логин и пароль пользователя, по умолчанию:
    • логин - root
    • пароль - root
  3. Переходим во вкладку SIP аккаунты и выбираем, какую линию настроим. Телефон поддерживает привязку 2-х аккаунтов, выбираем любой, например, Аккаунт 1:

  4. В открывшейся форме заполните необходимые поля:

    1. Отображаемое имя - вводим имя пользователя телефона
    2. Имя и Имя пользователя - значение берется из поля Логин в карточке пользователя.
    3. Пароль - значение берется из поля Пароль в карточке пользователя
    4. SIP-сервер - значение берется из поля Сервер в карточке пользователя.
    5. Остальные настройки установлены по умолчанию.

Примечание: Клавиши горячего набора настраиваются во вкладке Настройки телефона >Горячая линия.

Cisco SPA122

Тестирование настроек производилось для сети MTT. Для работы с вашей сетью замените параметры настроек из примера на параметры вашей сети.

Откройте интерфейс настроек Cisco SPA122 по адресу 192.168.15.1 используя ваш логин и пароль для администратора устройства.

Примечание: Не рекомендуется использовать режим настроек Quick Setup, так как он не заполняет некоторые необходимые поля.

Заведите в Сisco SPA122 параметры вашей локальной сети. Делается это в Network Setup > Internet Settings в поле Default Gateway. В разделе DNS укажите укажите используемые вами DNS сервера. На иллюстрации пример для локальной сети 192.168.0.1:

Примечание: На иллюстрации адрес устройства сменён с 192.168.15.1 на 192.168.0.22. В результате этого можно отказаться от настройки NAT в локальной сети.

В разделе Network Setup > Network Service в поле Networking Service параметр NAT замените на Bridge.

В разделе Voice > SIP в блоке RTP Parameters указываем порты:
RTP Port Min: 1024,
RTP Port Max: 65455.

В вашем Bitrix24 получите данные для настройки (Телефония > Пользователи).

В разделе Voice > Line1 устанавливаем параметры:

В блоке SIP Settings
SIP Transport: UPD,
SIP Port: 5060,
EXT SIP Port: 5060.

В блоке Proxy and Registration:
Proxy: ip.наш_набор_цифр.bitrixphone.com (значение поля Сервер формы настроек пользователя),
Register Expires: 3600,
Proxy Fallback Intvl: 3600.

В блоке Subscriber Information:
Display Name: ваш логин (значение поля Логин формы настроек пользователя, на иллюстрации - phone15, у вас будет другой)
Password: вводите свой пароль (значение поля Пароль формы настроек пользователя)
Auth ID: ваш логин (значение поля Логин формы настроек пользователя)
User ID: ваш логин (значение поля Логин формы настроек пользователя)
Use Auth ID: yes.

В блоке Audio Configuration:
Preferred Codec: G711u
Second Preferred Codec: G711a
Third Preferred Codec: G729a.

Примечание: Дополнительно можно настроить Dial Plan, это позволит не набирать постоянно код своего города.


Настройка облачной АТС
603 / 694
Внимание! Настройка АТС (для коробочной версии Битрикс24) должна производиться после настройки модуля для работы с облачной телефонией Телефония (voximplant).

К Битрикс24 можно подключить облачные АТС (не более 10). Под подключением понимается использование одного sip-логина. То есть, если в рамках подключения 4-х АТС имеется по 15 номеров на каждую АТС, но в рамках одной АТС все они обращаются к одному sip-логину, то такие подключения будут работать.

Каждое подключение облачной АТС не ограничено по количеству входящих линий, то есть на это подключение можно направлять неограниченное количество звонков (но число звонков может быть ограничено вашим оператором).

Для тестирования функционала вам доступны бесплатные минуты для исходящих звонков. Число бесплатных минут и срок активной лицензии выводится на странице Баланс и статистика в разделе Телефония.

Внимание! Если после тестирования вас устроила работа сервиса и вы собираетесь использовать АТС для исходящих звонков, необходимо оплатить лицензию по кнопке Оплатить подключение модуля для исходящей связи.

На текущий момент протестирована и проверена работа следующих АТС:

SIPNET | Tekmi | Telphin (только "Телфин.Офис") | MANGO
zadarma.com | Youmagic.pro | Интертелеком | telecom.kz
Дом.ру | MTT Бизнес |  |

Для обработки звонков, кроме настроек в Битрикс24, необходимо будет выполнить настройки на сетевом экране (firewall) вашей локальной сети.

  • Настройки в Битрикс24
  • Настройки Firewall локальной сети
    •

    Настройка облачной и офисных АТС различаются. Для настройки каждой из них нужно использовать свою кнопку:

    Настройки в Битрикс24

    Воспользуйтесь кнопкой Подключить облачную АТС. И заполните поля формы для подключения:

    Где:

    • Название подключения - Произвольное название соединения. Необязательное поле.

      Исключение: Для SIPNET это поле - обязательное. В нём должен быть указан номер, привязанный к порталу. Этот номер должен обязательно быть в международном 11-изначном формате: некоторые национальные операторы могут присылать номер в национальном формате.
    • Адрес сервера - это IP адрес вашей АТС.
    • Логин и Пароль - данные для доступ к АТС.

    Примечание. Для подключения некоторых облачных АТС требуется указание дополнительных параметров авторизации. Они доступны по ссылке Дополнительные поля: пользователь для авторизации (указываются данные из поля auth user в настройках облачной АТС) и прокси-сервер (указываются данные из поля sip outbound proxy в настройках облачной АТС).

    Нажмите Подключить. Данные сохранятся, система перейдёт к настройкам маршрутизации.

    Подключение АТС происходит не сразу, оно проходит несколько статусов:

    • в обработке: Идет процесс подключения, через несколько минут вы сможете принимать входящие вызовы.
    • получение данных: Идет процесс получения данных о текущем статусе, пожалуйста, подождите.
    • ошибка: Во время подключения произошла ошибка. В первую очередь, проверьте корректность указанных вами параметров подключения. Причину ошибки можно увидеть, если навести курсор мыши на слово ошибка. Появится сноска с информацией. Вам необходимо передать эту информацию своему оператору АТС, чтобы решить проблему.

    Примечание: Настройка телефонии через MANGO требует изменения настроек в личном кабинете Манго Офис. Подключение Мегафона, требует использование услуги Мультифон.

    Настройки Firewall локальной сети

    По умолчанию для SIP используется порт 5060, а для медиа (RTP) 10000-20000 порты. Однако универсальную рекомендацию дать сложно, так как порт 5060 может быть как TCP, так и UDP. Это зависит от существующих настроек локальной сети.

    Обычно для SIP важно, чтобы исходящий трафик был разрешен (с АТС например), а входящие коннекты будут работать автоматически. RTP обычно используется как UDP (чтобы могли теряться пакеты и при этом данные продолжали передаваться)

    Сами порты можно настраивать в свойствах АТС: какой там задан, такой нужно открывать и в Firewall.


Подключение Mango АТС
604 / 694

Использование облачной АТС Mango в Битрикс24 требует дополнительных настроек в личном кабинете Манго Офис.

  1. Зайдите в личный кабинет Манго Офис и в разделе Мои продукты и выберите виртуальную АТС, которую необходимо подключить к вашему порталу.

  2. В настройках АТС, в разделе Настройка SIP > Безопасность установить флажок в Свободный доступ. Соединения по протоколу SIP возможны с любых IP-адресов.

  3. Необходимо создать нового сотрудника (ссылка Сотрудники и группы).

    В открывшейся форме:

      нажимаем Добавить сотрудника и заполняем форму:

    • Фамилия и имя сотрудника - любое название, например, Интеграция с Битрикс24;
    • Внутренний номер - присваивается автоматически;
    • Выберите на что принимать звонки - значение на софтфон (компьютер) и не создавать учетную запись, я настрою ее самостоятельно;
    • Выберите линию для исходящих звонков - в выпадающем меню выберите ту линию, которая будет подключена к Битрикс24, т.е. на которую будут приходить звонки.
    И сохраните запись.
  4. В списке Сотрудники и группы появится только что созданная запись. Нажмите по этой записи для создания учетной записи SIP.

    В открывшейся форме:

    • Разрешать вход в личный кабинет по учетным записям SIP - отключить флажок
    • Нажать Создать в Учётные записи SIP. Откроется форма настроек записи SIP:

    • Адрес - произвольное значение.
    • сервер - выбрать используемый сервер.
    • пароль - произвольный пароль.
      • Внимание! указанные данные, нужно запомнить. Их нужно будет указать их на странице подключения АТС в Битрикс24.

      Сохраните запись

    В закладке Телефония выберите исходящий номер для совершения звонков.

    Сохраните все настройки.
  5. Вернитесь на главную страницу Личного кабинета и выберите Обработка входящих звонков > Распределение звонков, приветствие, голосовое меню.

  6. На вкладке Настройки для входящих линий укажите номер, выбранный раннее при настройке учетной записи SIP.
  7. Здесь же удалите все правила обработки кроме Отбой.
  8. Создайте новое правило (Добавить) типа Переадресация.

    В форме создания правила нужно указать ранее созданного сотрудника Интеграция с Битрикс24:

    Сохраните правило.

Настройки в Манго офис завершены.

При настройке облачной АТС в Битрикс24:

  • Название подключения - любое значение, которое будет отображаться в списке доступных номеров при настройке.
  • Адрес сервера - значение, которое было выбрано на 6 шаге в поле SIP-адрес после знака @.
  • Логин - значение, которое было указано в поле SIP-адрес перед знаком @
  • Пароль - пароль для учетной записи SIP.

Если все данные указаны корректно и статус подключения подтверждает, что интеграция настроена , вы можете приступить к детальной настройке: маршрутизации звонков, очереди, проверке номера по базе CRM и т.д.


Подключение Новой телефонии (Ростелеком)
605 / 694

Перед подключением необходимо настроить Asterisk (freepbx, Elastiks) на работу в локальной сети.

Для подключения Новой телефонии от Ростелеком как облачную АТС создайте Extension с произвольным именем. например 101. В этом Extention, если используется NAT, пропишите в NAT Mode или Force Rport или Automatic Force boot.DTMF Signaling - пропишите auto.

Создайте транк (Trunks), где пропишите:

Trunk Name +7ХХХХХХХХХХ
Outbound CallerID +7ХХХХХХХХХХ

Где ХХХХХХХ ваш номер.

В секции Outgoing имя транка 8ХХХХХХХХХХ.

В секции Pear Details укажите:

username=пользователь в Ростелекоме
type=peer
trustrpid=yes
sendrpid=no
secret=ваш пароль от пользователя в Ростелекоме
insecure=port,invite
host=адрес сервера
fromuser=пользователь в Ростелекоме
fromdomain=адрес сервера Ростелекома
dtmfmode=auto
disallow=all
context=from-trunk
allow=alaw&ulaw&gsm

В секции incoming укажите имя from-trunk.

В секции User Details всё удалите.

В секции Registration поле Register string укажите: пароль от пользователя в Ростелекоме@адрес сервера/7номер телефона.
Пример:
user1:password@******.**.rt.ru/7ХХХХХХХХХХ.

В настройках телефонии Битрикс24, создайте подключение к облачной АТС, где:

  • Название подключения - любое;
  • Адрес сервера - IP Extension Asterisk'а;
  • Логин - логин Extension;
  • Пароль - пароль Extension.

Примечание: Если будут проблемы при использовании NAT - проверьте iptables и ваш роутер.


Подключение Мегафона
606 / 694

Услуга Мультифон

Подключение телефонии от Мегафона возможно с помощью сервиса Мультифон от этого провайдера. Эта услуга представляет собой, фактически, многоканальную IP-телефонию для клиентов Мегафон.

Настройки Мегафона

Прежде всего, необходимо подключить услугу Мультифон к вашему существующему номеру Мегафон. Как это сделать узнайте на странице этой услуги на сайте Мегафона. Рекомендуется способ подключения через USSD-команду *137#. В ответной sms прийдёт пароль для дальнейшей настройки.

Настройки в Битрикс24

Воспользуйтесь кнопкой Подключить облачную АТС. И заполните поля формы для подключения, используя данные из настроек SIP Мультифона (отображены в инструкции Мегафона):

Где:

  • Название подключения - Произвольное название соединения. Необязательное поле.
  • Адрес сервера - это IP адрес вашей АТС.
  • Логин - номер подключаемого телефона.
  • Пароль - пароль, полученный по sms.

Нажмите Подключить. Данные сохранятся, система перейдёт к настройкам маршрутизации.

Подключение АТС происходит не сразу, оно проходит несколько статусов:

  • в обработке: Идет процесс подключения, через несколько минут вы сможете принимать входящие вызовы.
  • получение данных: Идет процесс получения данных о текущем статусе, пожалуйста, подождите.
  • ошибка: Во время подключения произошла ошибка. В первую очередь, проверьте корректность указанных вами параметров подключения. Причину ошибки можно увидеть, если навести курсор мыши на слово ошибка. Появится сноска с информацией. Вам необходимо передать эту информацию своему оператору АТС, чтобы решить проблему.

Корпоративная услуга Виртуальная АТС

Необходимо активировать корпоративную услугу Виртуальная АТС от Мегафона.

АТС создается со своим поддоменом: domain.megapbx.ru. При создании логина (вида login@domain.megapbx.ru) используйте минимум 2 символа. На данный момент проверка при авторизации "Виртуальная АТС" не даст авторизоваться пользователям с логином длиной менее чем в 2 символа (например, x@domain.megapbx.ru).

Для настройки телефонии в Битрикс24 используйте следующие данные:

  • адрес сервера: domain.megapbx.ru
  • логин: login (без @domain.megapbx.ru)
  • пароль: password

Cтандартный виджет МегаФона

Для интеграции с телефонией Битрикс24 можно также подключить виджет Виртуальная АТС от МегаФон.

Для этого нужно его установить из Маркетплейс24 и следовать дальнейшим инструкциям.

После подключения вы сможете пользоваться всем функционалом интеграции:

  • всплывающие карточки клиентов при входящих
  • звонки в один клик
  • вся активность автоматически фиксируется в карточках клиентов
  • автоматическое создание лидов, сделок и задач на пропущенный звонок

Большое преимущество данной интеграции в том, что она работает даже при звонке на мобильный номер телефона. Такой звонок будет фиксироваться в Битрикс24.


Подключение SIPNET
607 / 694

Настройки на SIPNET

В кабинете SIPNET перейдите в раздел меню Мои услуги > Управление звонками и выставите пункт Никогда не переадресовывать звонки, после чего сохраните внесенные изменения.

После этого перейти в раздел меню Мои услуги > Запись звонков и проверить отсутствие галок пунктов исходящих и входящих звонков. После этого сохраните изменения.

Внимание! При подключении SIPNET к Bitrix24 никогда не включайте в настройках SIPNET запись звонков. Это является причиной некорректной связи, а именно, при входящей связи звонящий не услышит ни голос менеджера, ни даже автоответчика. При этом в детализации звонков Битрикс24 аудиозапись будет вполне нормальной и с голосами обеих сторон.

Настройки в Битрикс24

Для настройки подключения используйте следующие данные:

  • Название подключения - любое
  • Адрес сервера - sipnet.ru
  • Логин - ваш логин от SIPNET (SIP-номер)
  • Пароль - пароль от учетной записи SIPNET


Подключение Дом.ru
608 / 694

Действия по подключению облачной АТС Дом.ru имеет свои особенности.

  • Необходимо написать заявление в Дом.ru с просьбой зарегистрировать IP-адрес 69.167.178.6. Это IP-адрес оператора Voixplant, через который осуществляется связь с Битрикс24. Как правило, доступ к облачной АТС имеет только ваш офисный IP-адрес, а подключение через стороннюю программу облачная АТС блокирует. Это делается через вашего курирующего менеджера Дом ру.

    Внимание! Указанный IP-адрес может быть изменён компанией Voixplant без каких либо уведомлений.

  • Обратиться после этого в техподдержку Дом.ru и попросить подключить одну или несколько внутренних линий к звонкам через данный IP.

    Внимание! Одна внутренняя линия не может быть зарегистрирована на два разных IP.

  • Далее необходимо получить данные для настройки облачной АТС в Битрикс24.

    Адрес сервера. В информационном листке (Облачная АТС > Настройки > Информационный листок) есть ссылка на файл, в котором указаны IP-адреса вашего региона. Из всего списка выберите любой из них и используйте его при настройке облачной АТС в Битрикс24.

    Пароль - значение для этого поля - это поле Пин-код в Учётных данных сотрудника:

    Логин - значение для поля составное, вида: _внутренний_номер_$_название_атс_. Где "внутренний номер" - это трёхзначный код с одноимённого поля в Учётных данных сотрудника, "название атс" - это значение поля АТС в вашем личном кабинете:

    Например: 201$erteleko_4606812.

  • Используйте эти данные при настройке облачной АТС


Подключение МТТ Бизнес
609 / 694

Настройки МТТ Бизнес

Для интеграции с Битрикс24 можно использовать существующее рабочее место (SIP ID), либо создать для этих целей новое.

  • В Личном Кабинете администратора выберите: Настройки > Рабочие места > Создать рабочее место.
  • В открывшемся окне задайте имя (в примере: Битрикс24), и выберите номер, который будет определяться при звонке из вашего портала.
    • По умолчанию - номер определяется настройками лицевого счета.
    • конкретный номер - один из приобретенных на лицевой счет или добавленных в качестве определяемых по запросу.

Для настройки входящих звонков перейдите в раздел «Входящая связь» и настройте переадресацию номера, который вы хотите использовать в Битрикс24:

  • Выберите пункт На рабочее место:

  • Выберите рабочее место, настройки которого вы будете использовать при интеграции с сервисом Битрикс24, например, созданное выше рабочее место Битрикс24.
Внимание! Для использования исходящей телефонии в Битрикс24 необходимо оплатить подключение SIP Коннектора.

Настройки Битрикс24

При настройке Облачной АТС в вашем портале используйте данные, полученные в настройках рабочего места МТТ Бизнес. Из настроек рабочего места:

в Битрикс24:


Настройка офисной АТС
610 / 694
Внимание! Настройка АТС (для коробочной версии Битрикс24) должна производиться после настройки модуля для работы с облачной телефонией Телефония (voximplant).

SIP Коннектор позволит подключить к Битрикс24 офисные АТС. (Число подключаемых АТС не ограничено.) Для тестирования функционала вам доступны бесплатные минуты. Если вы собираетесь использовать АТС для исходящих звонков, необходимо оплатить лицензию по кнопке Оплатить подключение модуля для исходящей связи. Число бесплатных минут и срок активной лицензии выводится на странице Баланс и статистика в разделе Телефония.

Логика работы SIP Коннектор'а следующая:

  • При совершении исходящего звонка из портала, Битрикс24 попытается присоединится к серверу, указанному вами в разделе Исходящие звонки формы настроек, и, авторизовавшись с логином/паролем, совершить звонок
  • Для приема в портал входящего звонка необходимо создать на своей IP-АТС транк с параметрами, которые вам предоставлены в разделе Входящие звонки формы настроек, и отправлять в этот транк все поступающие в АТС звонки.

Для обработки звонков, кроме настроек в Битрикс24, необходимо будет выполнить настройки на стороне офисной АТС и на сетевом экране (firewall) вашей локальной сети.

  • Настройки офисной АТС
  • Настройки Firewall локальной сети
    •

    Настройка облачной и офисных АТС различаются. Для настройки каждой из них нужно использовать свою кнопку:

    Настройки в Битрикс24

    Воспользуйтесь кнопкой Подключить офисную АТС. И заполните поля формы для подключения:

    Где:

    • Название подключения - Произвольное название соединения. Необязательное поле.
    • Адрес сервера - это IP адрес вашей АТС.
    • Логин и Пароль - данные для доступ к АТС.

    Нажмите Подключить. Данные сохраняться, система перейдёт к настройкам маршрутизации.

    Настройка офисных АТС

    Рассмотрим настройку офисной АТС на примере Asterisk. Для настройки АТС данные берутся из блока Входящие звонки:

    • Создание транка. В файле sip.conf необходимо создать запись следующего вида:

      [voximplant]
dtmfmode=rfc2833
;далее вместо youraccount необходимо использовать имя Вашей учетной записи в поле Сервер (см. иллюстрацию выше).
fromdomain= youraccount
type=friend
host= youraccount
; в качестве значения полей типа user используется значение поля Логин
fromuser=asterisk
username=asterisk
; в качестве значения пароля используется значение из поля Пароль
secret=mypass
insecure=port,invite
contex=contex-internal
disallow=all
nat=yes
allow=ulaw&alaw

      В этой записи нужно менять значения только у домена, пароля и параметра nat, который ставится в yes/no, в зависимости от того используется ли у вас сеть NAT или нет.

      В качестве примера приведём образец настроек по данным с иллюстрации выше:

      [voximplant]

dtmfmode=rfc2833
fromdomain=ip.b24-6864-1386141129.bitrixphone.com
type=friend
host=ip.b24-6864-1386141129.bitrixphone.com
fromuser=sip1
username=sip1
secret=1fe00170274c5a6151a11553df7618d8
insecure=port,invite
contex=contex-internal
disallow=all
nat=yes
allow=ulaw&alaw
      Внимание! До версии модуля 15.1.3 в настройках вашей офисной АТС использовалось в поле Адрес сервера incoming вместо ip (например: incoming.b24-6864-1386141129.bitrixphone.com). Вы можете продолжать использовать это обозначение и далее, но модуль будет работать значительно медленнее.

      Настройки применяются командой в консоли Asterisk:

      sip reload

    • Настройка звонков из Asterisk в VoxImplant. Звонки осуществляются с помощью следующей команды, которую необходимо прописать в файле extensions.conf:

      Dial(SIP/voximplant/${EXTEN})

      В таком случае он поступит в Битрикс24 как звонок на тот номер, на который он изначально пришел в Asterisk.

      Настройки применяются командой в консоли Asterisk:

      dialplan reload

    Настройки Firewall локальной сети

    По умолчанию для SIP используется порт 5060, а для медиа (протокол RTP) порты с 8000. Однако универсальную рекомендацию дать сложно, так как порт 5060 может быть как TCP, так и UDP. Это зависит от существующих настроек локальной сети.

    Обычно для SIP важно, чтобы исходящий трафик был разрешен (с АТС например), а входящие коннекты будут работать автоматически. RTP обычно используется как UDP (чтобы могли теряться пакеты и при этом данные продолжали передаваться)

    Сами порты можно настраивать в свойствах АТС: какой там задан, такой нужно открывать и в Firewall.

    Список ссылок по теме:

    • Интеграция 3CX Phone System и Bitrix24 (статья на Хабре)


Настройки для работы с Билайном через Asterisk
611 / 694

Из-за технических особенностей платформы, используемой оператором связи Билайн, при подключении SIP-коннектора с данными АТС Билайн имеется ряд ограничений:

  • Невозможно совершать исходящие звонки
  • Завершение звонка в Битрикс24 не приводит к завершению звонка в трубке клиента портала.

Чтобы обойти эти ограничения, необходимо использовать промежуточную АТС Asterisk. Рассмотрим пример настройки. Допустим, Билайн выдал телефонный номер 4951234567 на прокси sip.beeline.ru и пароль qwerty.

После установки завершение звонка в Б24 (коробка) не приводит к завершению звонка в трубке клиента портала. необходимо произвести ее конфигурацию:

  1. Регистрируем Asterisk как пользователя Билайн. Для этого добавляем в файл sip.conf, обычно находящийся в папке /etc/asterisk/, следующую строку:
    register => 4951234567:qwerty:4951234567@sip.beeline.ru@sip.beeline.ru/4951234567

    Добавить эту строку нужно строго сразу после строки [general].

  2. Создаем транки для Битрикс24 и Билайн. Для этого в том же файле sip.conf (в самом конце) необходимо прописать следующие настройки:
    [bitrix24-in]

type=user
context=bitrix24
secret=thepassword
diasllow=all
allow=ulaw
allow=alaw

[bitrix24-out]
type=peer
host=ip.b24-xxxx-yyyyyyyyyyy.bitrixphone.com ← значения этого и последующего параметров берутся из конфигурации Офисной АТС Битрикс24 (настройки для входящих звонков)
secret=c8ba30344aa1241e653ce05e56c66d53
username=sipZZ
fromuser=sipZZ
fromdomain=ip.b24-xxxx-yyyyyyyyyyy.bitrixphone.com

[4951234567]
type=peer
insecure=invite
deny=0.0.0.0/0.0.0.0
permit=195.239.174.100/255.255.255.255
host=sip.beeline.ru
username=4951234567
secret=qwerty
fromuser=4951234567
fromdomain=sip.beeline.ru
context=beeline
  3. Настроим прохождение звонков из Битрикс24 в Билайн. В файле extensions.conf в папке /etc/asterisk/ прописываем следующие строки:
    [bitrix24]

exten => _X.,1,Set(CALLERID(num)=4951234567)
exten => _X.,2,Dial(SIP/${EXTEN}@4951234567)

[beeline]
exten => _X.,1,Dial(SIP/4951234567@bitrix24-out)
  4. Вводим настройки для исходящих звонков в SIP-коннектор Битрикс (режим Офисная АТС):
    • Название подключения - Beeline
    • Адрес сервера: публичный IP-адрес сервера, на котором установлен Asterisk
    • Логин - bitrix24-in
    • Пароль - thepassword (он задавался в пункте 2)
  5. Перезапуск Asterisk.


Настройки FreePBX
612 / 694

Рассмотрим пример настройки FreePBX для телефонии через Битрикс24.

Для работы FreePBX достаточно в настройках создать:

  1. Транк с настройками из Битрикс24;
  2. Входящий маршрут, перенаправляющий звонки в этот транк.

Создание транка

При создании транка обязательными являются поля Trunk Name и Outbound CallerID. При этом название транка обязательно должно быть: voximplant. А в качестве номера указывается номер, привязанный к порталу в 11-изначном формате.

Код самого транка (поле PEER Details) аналогичен коду, используемому при настройке SIP, с указанием ваших параметров:

disallow=all
allow=ulaw&alaw
dtmfmode=rfc2833
fromdomain=ip.*.bitrixphone.com
type=friend
host=ip.*.bitrixphone.com
fromuser=sip*
username=sip*
secret=*
insecute=port,invite
conext=contex-internal
nat=yes
qualify=yes

Создание входящего маршрута

При создании маршрута нужно указать номер телефона, привязанный к порталу (поле DID Number) и выбрать созданный ранее транк voximplant (поле Set Destination).


Решение проблем с телефонией и видеозвонками
613 / 694

При решении проблем с видео и аудио связью нужно понимать что связь - многофакторная система, проблема может быть на самом разном уровне. Виноваты могут быть и оператор связи (Voixplant), и сети (локальные и Web), и конечное оборудование клиента и так далее. Оптимальный способ поиска проблемы - поочерёдная проверка всех составляющих этого процесса.

Примечание: Компания 1c-Битрикс не является оператором связи и не отвечает за качество работы IP-телефонии.

Ниже приведены несколько методов проверки элементов связи и описание процессов, происходящих при звонках. Надеемся, что это поможет при решении проблем.

Проверка настроек локальной сети

В любом случае нужно начать поиск проблем с проверки настроек локальной сети, файерволлов и антивирусов. Важно помнить, что в случае телефонии нужно отслеживать актуальность IP-адресов по требованиям от Voximplant'а. Эти требования периодически меняются, компания Битрикс отслеживает эти изменения. Таблица адресов и портов, которые должны быть открыты на главной странице раздела Телефония всегда актуальна.

Логи Битрикс24

Одним из инструментов анализа связи могут быть логи, которые ведёт Битрикс24. Логи можно просмотреть в колонке Журнал по ссылке Детализация на странице Баланс и статистика.

Примечание: При использовании Битрикс24 в коробке необходимо для ведения логов в настройках NGINX установить параметр proxy_ignore_client_abort on;.

Как проверить качество связи между двумя конкретными пирами в реальной сетевой обстановке

Иногда при выяснении причин плохой связи при видеозвонках подозрение падает на особенности клиентского оборудования - гарнитуру, камеру, особенности драйверов и тому подобного. Например, клиент жалуется: "со временем звук начинает хрипеть, а затем и вовсе пропадает, хотя видео едет". Одна из возможных причин: проблемы гарнитуры пользователя. Вот в этом случае можно запустить у того же клиента Десктопное приложение в тестовом режиме с тестовым медиа (исключающим влияние не корректно работающей гарнитуры) и запустить ещё один сеанс связи с тем же собеседником. Если в этом режиме связь не пропадает, то подозрение укрепляется. Если пропадает все равно, то дело скорее всего в NAT/Firewall, некорректно работе WebRTC, TURN и так далее, и гарнитуру менять бесполезно.

Есть способ протестировать связь теми же участниками, но с "виртуальными" медиаустройствами, исключающими влияние реального медиа-оборудования, и таким образом подтвердить или опровергнуть подозрения.

Для этого запустите Bitrix24.exe (десктопное приложение) с ключом --use-fake-device-for-media-stream:

Bitrix24.exe --use-fake-device-for-media-stream

При запуске с ключом встроенный Chrome будет сам генерировать тестовое видео и аудио. Видео покажет динамически закрашиваемый круг и счетчики, а аудио будет передавать периодический тоновый сигнал.

Либо можно организовать трансляцию аудио и видео из файлов для тестирования с более сложным медиа-потоком:

Bitrix24.exe --use-fake-device-for-media-stream --use-file-for-fake-video-capture="waterfall_cif.y4m" --use-file-for-fake-audio-capture="a2002011001-e02.wav"

К тестовым файлам есть особые требования: видео в формате y4m, аудио в формате wav с дискретизацией 44.1 КГц.

Если тестовые файлы отображаются и озвучиваются хорошо, то это говорит о проблемах с оборудованием.

Настройки мессенджера

Кроме технических проблем с оборудованием возможна некорректная настройка мессенджера. В этом случае:

  • Нужно зайти в настройки мессенжера, вкладка Оборудование.
  • Явно выбрать нужную гарнитуру и нажать сохранить изменения.
  • Либо попробовать убрать флажок Автоматически регулировать параметры микрофона и сохранить изменения.

Проблемы при переводе звонка через sip-аппарат

Если есть проблемы при переводе звонка через sip-аппарат, то в решении этих проблем может помочь знание того, как происходит переадресация звонка через аппарат.

В переадресации участвуют три стороны:

  1. Тот, кто переводит (Transferor)
  2. Кого переводит (Transferee)
  3. На кого переводят (Transfer target)

В момент совершения переаресации sip-аппарат обменивается рядом sip-сообщений с оператором связи Voximplant. По результатам этого обмена Voximplant:

  • объединяет медиа-потоки Transferree и Transfer target
  • разъединяет медиа-потоки Transferree и Transferor
  • во все три плеча отправляет событие CallEvents.TransferComplete с указание роли этого плеча в переводе.

Если в журнале звонка данное событие отсутствует (и клиент нажимает правильные кнопки для перевода), то:

  • либо у клиента аппарат формирует нестандартные сип-команды,
  • либо у клиента какие-то сетевые проблемы.

В этом случае, лог такого звонка надо отправлять в техподдержку Битрикс24, разобраться что именно приходило от аппарата клиента, может только оператор связи Voximplant.


Техподдержка
614 / 694

Современный корпоративный портал насыщен разнообразными функциями, сориентироваться в которых сотрудникам компании бывает порой непросто. Кроме того, многие производственные компании хотели бы иметь возможность оперативно отвечать на вопросы сотрудников. Особенно это касается порталов, ориентированных на консультирование сотрудников в онлайновом режиме по вопросам использования программного обеспечения, технических устройств и т.п.

Для решения перечисленных задач разработан модуль Техподдержка.

Модуль технической поддержки позволяет:

  • организовать на сайте систему обращений сотрудников компании к группе сотрудников, отвечающих за консультирование и техподдержку;
  • назначать ответственных за решение тех или иных вопросов;
  • управлять уровнями технической поддержки;
  • отслеживать время и эффективность рассмотрения обращений;
  • анализировать оценку получаемых ответов.

Для полноценного управления модулем Техподдержка необходимо обладать правами группы Администраторы.

Дополнительная информация

  • Техподдержка (документация)


Организация работы службы поддержки
615 / 694

Процесс создания и обработки обращений, поступающих в службу технической поддержки, регламентируется соглашением об уровне поддержки (SLA).

SLA – это описание обязательств компании по предоставлению определенного уровня сервиса (в данном случае технической поддержки) тем или иным пользователям. Уровни сервиса используются для управления приоритетами пользователей на получение поддержки.

  • Каждой группе пользователей, обладающей правом на создание обращений в службу поддержки, назначается определенный SLA. Уровень поддержки определяет время реакции на сообщения пользователей данных групп, а также некоторые параметры сообщений.
  • Пользователи могут создавать обращения в службу поддержки следующими способами:
    • через стандартные формы на сайте;
    • посредством электронного письма;
    • посредством телефонного звонка.

    Также некоторые сообщения пользователей на форуме, например, имеющие технический характер или выходящие за рамки тематики форума, могут быть перенесены в службу поддержки. Сообщение может быть перемещено администратором Bitrix Framework или администратором форума с помощью специального интерфейса.

    Каждому сообщению присваивается уникальный номер, что позволяет вести строгий учет поступивших обращений и следить за процессом их обработки.

  • Обращение в службу поддержки рассматривается в соответствии с параметрами SLA. Ответ на обращение публикуется в Bitrix Framework, а также отсылается пользователю по электронной почте. При этом просмотр обсуждения проблемы на Bitrix Framework доступен только пользователю, создавшему обращение, и сотрудникам службы поддержки.

Интерфейс техподдержки состоит из двух частей:

  • публичной:

  • административной:

Обычно клиенты техподдержки получают доступ к публичному интерфейсу службы, а сотрудники техподдержки ведут работу из административного интерфейса. В связи с этим административный и публичный интерфейс различаются по внешнему виду и доступному функционалу.

Для регулирования уровня доступа пользователей к модулю технической поддержки предусмотрено использование ролей:

  • Клиент техподдержки - доступ к административному меню Обращения открыт, в административных и публичных файлах разрешено создание и редактирование своих обращений.

    Клиент техподдержки получает почтовые извещения обо всех событиях, связанных с созданным им обращением (об изменении статуса сообщения, назначении ответственного, ответе на обращение и т.д.). Также при создании обращения пользователь получает извещение, содержащее исходную информацию об обращении (номер обращения, имя ответственного по умолчанию и т.д.)

  • Сотрудник техподдержки - доступ ко всем пунктам меню и страницам модуля открыт. Пользователь работает с теми обращениями, в параметрах которых он указан как сотрудник, ответственный за решение проблемы.

    Сотрудник техподдержки получает почтовые извещения обо всех событиях, связанных с обращениями, за рассмотрение которых он отвечает. При назначении сотрудника ответственным за какое-либо обращение ему также направляется извещение с параметрами данного обращения.

    • Примечание: доступ к чему-либо в административном режиме будет открыт если пользователь имеет право доступа минимум Чтение к папке bitrix/admin.

  • Администратор техподдержки - пользователь может редактировать справочник техподдержки и любое обращение, а также назначать ответственных за решение проблем. Администратор получает почтовые извещение обо всех обращениях, создаваемых в службу поддержки.


Создание мастера
616 / 694

С помощью средств модуля Информационные блоки в продукте реализована возможность создания мастера техподдержки.

Для этого необходимо создать тип инфоблока, например Сервисы, и инфоблок Мастер, в котором будут храниться вопросы мастера.

Создание вопросов мастера

Для создания шага мастера с указанием проблемы нажмите кнопку Добавить раздел, расположенную на контекстной панели. Причина обращения в техподдержку указывается в поле Название:

Форма создания шага мастера

Примечание: Количество разделов, подразделов каждого раздела зависит от конкретного вопроса. Таким образом, количество шагов мастера создания обращения зависит от вложенности разделов (разделы могут иметь разный уровень вложенности).

Перейдите в созданный раздел. Нажмите кнопку Добавить вопрос, расположенную на контекстной панели, для создания описания проблемы. В открывшейся форме обязательно заполните поле Вопрос, выберите Тип вопроса (например, текстовое поле):

Форма создания описания проблемы

В результате на странице Мастер (Контент > Сервисы > Мастер) будут содержаться созданные шаги мастера.

При переходе по любой из ссылок отобразятся вопросы для детального описания проблемы.


Справочники
617 / 694

Справочники – группы свойств, относящихся к обращениям в службу поддержки. Данные свойства носят информационный характер и не влияют на общий процесс обработки обращений.

Перед началом работы выполните настройку необходимых справочников. Это позволит:

  • автоматизировать процесс назначения ответственных за рассмотрение обращений в зависимости от их параметров;
  • выполнять группировку поступающих обращений;
  • отслеживать уровни сложности проблем и эффективность их решения.

Основные типы справочников используемые в системе:

  • Категории
  • Критичности
  • Статусы
  • Оценки ответов
  • Частые ответы
  • Источники
  • Сложность

Категории

Категории обращений – это справочник сообщений, характеризующих область, к которой относится обращение (например, «Оформление заказа», «Оплата заказа», «Ошибки установки»).

Настройка категорий выполняется на странице Категории (Сервисы > Техподдержка > Справочники > Категории):

При создании обращения пользователь может выбрать подходящую категорию (из числа доступных), к которой, по его мнению, относится описываемая проблема.

Список доступных пользователю категорий определяется SLA.

Критичности

Критичность обращений – это справочник сообщений, отражающих уровень критичности (необходимость срочного решения) описываемой пользователем проблемы. Например, «Низкая», «Средняя», «Высокая».

Управление справочником осуществляется на странице Критичности (Сервисы > Техподдержка > Справочники > Критичности):

Уровни критичности обращений

Уровень критичности назначается пользователем при создании обращения и носит исключительно информационный характер.

Перечень доступных пользователю уровней критичности определяется SLA.

При более детальном рассмотрении проблемы сотрудник техподдержки может изменить критичность обращения.

Статусы

Статусы – это информационные сообщения, характеризующие этап обработки (или состояние) обращения. Например, «Принято к рассмотрению», «В стадии решения», «Успешно решено» и т.п.

Справочник статусов создается на странице Статусы (Сервисы > Техподдержка > Справочники > Статусы):

Статус обращения назначается при его рассмотрении сотрудником техподдержки.

Оценки ответов

Оценки ответов - справочник содержит список оценок, которые клиент техподдержки может выставить за предоставленный ему ответ.

Управление справочником осуществляется на странице Оценки ответов (Сервисы > Техподдержка > Справочники > Оценки ответов):

Список доступных пользователю оценок определяется SLA.

Оценки ответов используются для контроля качества работы службы технической поддержки.

Частые ответы

Наиболее часто даваемые ответы могут быть сохранены в справочнике Частые ответы (Сервисы > Техподдержка > Справочники > Частые ответы):

Далее типовые ответы могут быть использованы при создании ответов на обращения.

Это позволит сократить затраты времени на обработку часто задаваемых вопросов.

Источники

Источники - справочник содержит список источников, характеризующий откуда или от кого пришло обращение.

Управление справочником осуществляется на странице Источники (Сервисы > Техподдержка > Справочники > Источники):

Источник обращения указывается сотрудником техподдержки при его рассмотрении.

Сложность

Сложность - справочник содержит описание уровней сложности обращений. Уровень сложности обращения может использоваться, например, для контроля времени, затрачиваемого на решение проблемы сотрудниками техподдержки, а также при контроле общего уровня поступающих запросов.

Управление справочником осуществляется на странице Сложность (Сервисы > Техподдержка > Справочники > Сложность):

Уровни сложности обращений

Сложность обращения оценивается сотрудником техподдержки при его рассмотрении.

Документация по теме:

  • Типы справочников техподдержки
  • Создание и редактирование записи справочника


Назначение ответственного за обращение
618 / 694

Администратор техподдержки - сотрудник, имеющий полный доступ к модулю техподдержки. Может выполнять обязанности ответственного по обращению.

Ответственный по умолчанию - сотрудник, назначаемый автоматически согласно настройкам модуля. Может выполнять обязанности ответственного по обращению.

Ответственный за обращение – это сотрудники, отвечающие за рассмотрение и решение того или иного конкретного обращения.

Назначение ответственного сотрудника может быть выполнено:

  • автоматически, в соответствии с установленными параметрами, назначается ответственный по умолчанию;
  • вручную администратором техподдержки (или ответственным по умолчанию) при просмотре конкретного обращения.

Примечание: Чтобы можно было выбрать сотрудников в поле Ответственный, в случаях, описанных ниже, необходимо присвоить им права сотрудник техподдержки на доступ к модулю техподдержки.

Проще всего для этого создать отдельную группу пользователей (Настройки > Пользователи > Группы пользователей) и на закладке Доступ указать соответствующие права.

Автоматическое назначение ответственного сотрудника выполняется исходя из следующих параметров:

  • в соответствии с настройками следующих Справочников: Категория, Критичность, Источник (Сервисы > Техподдержка > Справочники > Категории, Сервисы > Техподдержка > Справочники > Критичность, Сервисы > Техподдержка > Справочники > Источник), в зависимости от типа, к которому было отнесено обращение.

    Параметры категории обращений

  • если ответственный в Справочнике не установлен, то назначается сотрудник, ответственный по умолчанию за решение обращения с тем или иным SLA.

    В соответствии с правами пользователя, каждому сообщению присваивается определенный SLA. В настройках SLA (Сервисы > Техподдержка > Уровни поддержки) может быть указан сотрудник техподдержки, ответственный по умолчанию за решение вопросов с указанным уровнем поддержки.

  • если и ответственный для SLA не установлен, то ответственный по умолчанию сотрудник назначается исходя из настроек модуля техподдержки (Настройки > Настройки продукта > Настройки модулей > Техподдержка).

При просмотре обращения администратор техподдержки (или Ответственный по умолчанию/Ответственный за обращение) может назначить или изменить ответственного за решение проблемы.


Уровни поддержки (SLA)
619 / 694

Настройка уровней сервиса выполняется на странице Уровни техподдержки (SLA) (Сервисы > Техподдержка > Уровни поддержки):

SLA определяет:

  • время реакции на обращение пользователя (т.е. время, в течение которого сотрудник службы поддержки должен отреагировать на обращение пользователя);

    Время реакции на обращение

    Параметр Считать крайний срок от определяет момент, с которого следует отсчитывать время реакции на обращение клиента: с даты его создания, либо даты последнего ответа клиента. Во втором случае счетчик крайнего срока обнуляется после каждого ответа сотрудника техподдержки. Первым ответом считается само обращение клиента.

  • группы, пользователи которых имеют право на создание обращений с данным уровнем поддержки;

    Настройка прав на SLA

    Примечание: Доступные группы определяются в настройках модуля Техподдержка (Настройки > Настройки продукта > Настройки модулей > Техподдержка), закладка Доступ.

  • доступные категории и уровни критичности обращений, а также оценки ответов на обращение.

    Например, пользователям с обычным SLA может быть предоставлено право на создание обращений с низкой критичностью, а клиентам с SLA «Партнеры» – с низкой, средней и высокой.

  • другие параметры.

Документация по теме:

  • Уровни поддержки
  • Создание и редактирование уровня поддержки


Создание публичного интерфейса
620 / 694

Создание интерфейса техподдержки в публичном разделе Bitrix Framework выполняется с помощью компонентов модуля Техподдержка:

  1. комплексный компонент Техподдержка (support.ticket) позволяет создать полноценную систему техподдержки, с помощью которой можно просмотреть список обращений, добавить своё сообщение или написать новое обращение;

  2. комплексный компонент Техподдержка с мастером (support.wizard) служит для организации полноценного публичного интерфейса технической поддержки, создание обращения в котором выполняется с помощью специального мастера.

    Мастер представляет собой информационный блок, а вопросы мастера являются разделами и элементами этого инфоблока.

    3. Примечание: Настройки компонента Техподдержка с мастером позволяют задать привязку разделов мастера к категориям техподдержки. Для этого необходимо в соответствующей секции настроек компонента отметить опцию Включить привязки, выбрать желаемые разделы в списке (после чего необходимо нажать кнопку OK) и указать соответствующие категории для них:

    Привязка разделов мастера к категориям техподдержки

    Таким образом, можно выполнить настройки, чтобы при выборе вопроса в мастере для обращения назначалась соответствующая категория и ответственный (если он задан для конкретной категории).

Документация по теме:

  • Описание компонентов модуля "Техподдержка"


Механизм для создания обращений по почте
621 / 694

Пользователь может создать обращение в техническую поддержку несколькими способами, например, написав электронное письмо на адрес технической поддержки компании.

Чтобы данный механизм получения обращений работал, необходимо выполнить следующие настройки в системе:

  • со стороны модуля "Техподдержка"
  • со стороны модуля "Почта"

Настройки со стороны модуля "Техподдержка"

  • на странице Источники (Сервисы > Техподдержка > Справочники > Источники) создайте источник E-Mail (если он еще не создан), причем в поле Символьный идентификатор должно быть указано email:

    Создание нового источника

  • на странице Категории (Сервисы > Техподдержка > Справочники > Категории) создайте категорию, которая будет использоваться для обращений, поступающих в техподдержку по почте. В поле Символьный идентификатор обязательно укажите значение email:

    Создание категории обращений

Настройки со стороны модуля "Почта"

  • на странице Почтовые ящики (Сервисы > Почта > Почтовые ящики) должна быть заведена учетная запись электронной почты службы технической поддержки:

    Список учетных записей (почтовых ящиков)

    Примечание: Подробная информацию по добавлению почтовых ящиков представлена в главе Почта, урок Почтовые ящики.

  • на странице Правила обработки почты (Сервисы > Почта > Правила) добавьте новое правило обработки почтовых сообщений. При создании правила выберите тип добавление сообщения в техподдержку.
  • В форме создания правила на закладке Параметры обязательно укажите название правила и выберите почтовый ящик, к сообщениям которого будет применяться правило.
  • На закладке Условия укажите условия, при которых почтовое сообщение будет добавлено в техподдержку:

  • Кроме того, в поле Определять по EMail ранее зарегистрированного пользователя отметьте опцию да, пытаться привязать обращение к пользователю. Затем укажите, к какому сайту привязывать обращение, и выберите категорию, при создании которой в качестве символьного идентификатора было указано значение email (см. вышеизложенное описание по созданию категории Обращения по почте).

    Условия применения правила

    При необходимости можно назначить уровень критичности для новых обращений, полученных по почте (уровни критичности должны быть созданы заранее на странице Сервисы > Техподдержка > Справочники > Критичности.

В результате, если пользователь напишет письмо на адрес технической поддержки компании, то оно будет добавлено в список обращений.


Административный интерфейс
622 / 694

Функционал административного раздела позволяет выполнять следующие операции:

  • настраивать доступные параметры обращений (уровень критичности, статусы обращений, оценки ответов и т.д.);
  • просматривать и отвечать на обращения пользователей в службу технической поддержки.

Административный интерфейс включает:

  • рабочий стол;
  • список обращений;
  • графики;
  • инструменты настройки справочников и SLA.


Рабочий стол
623 / 694

Общая статистика по поступившим обращениям, а также набор сводных отчетов по работе службы техподдержки доступны в форме, представленной на странице Рабочий стол (Сервисы > Техподдержка > Рабочий стол ТП):

Сводные отчеты реализованы при помощи обзорных таблиц, отображающих количество назначенных, закрытых и открытых обращений:

  • по ответственным сотрудникам службы;
  • по критичности;
  • по текущему статусу;
  • по уровню сложности;
  • по категории;
  • по источнику обращения;
  • по оценкам ответов на обращения;
  • по уровню поддержки.


Обращения
624 / 694

На странице Обращения (Сервисы > Техподдержка > Обращения) представлен список всех обращений, поступивших в службу технической поддержки. Специальные индикаторы помогают пользователю наглядно оценить текущее состояние обращений:

- последний раз в обращение писал клиент техподдержки (вы ответственный);
- последний раз в обращение писал клиент техподдержки (вы не ответственный);
- последний раз в обращение писали вы;
- последний раз в обращение писал сотрудник техподдержки;
- обращение закрыто.

Кроме того, рядом с индикатором может отображаться служебная надпись:

  • Пора отвечать! – заканчивается период, в течение которого на данное сообщение должен быть дан ответ (в соответствии с параметрами SLA);
  • Просрочено! – срок ответа на сообщение истек.

Фильтр страницы настроен таким образом, что по умолчанию для сотрудника техподдержки отображаются обращения, за рассмотрение которых он отвечает:

  • вверху списка отображаются просроченные сообщения (Просрочено!);
  • затем идут сообщения, для которых подошел срок ответа (Пора отвечать!)
  • далее следуют все остальные сообщения в порядке очереди. Очередность обращений устанавливается исходя из даты ответа (в соответствии с параметрами SLA).

Если сотрудник службы поддержки ответил на обращение, то обращение отмечается зеленым индикатором и перемещается в конец списка.

Примечание: Положение обращения в очереди не изменится, если:
  • автор изменил либо выполнил последовательное дополнение созданного им обращения новыми сообщениями;
  • сотрудник службы поддержки добавил в обращение комментарий или скрытое сообщение.

Для администратора техподдержки по умолчанию отображаются все обращения, на которые в ближайшее время должен быть дан ответ (т.е. с желтым и красным индикатором).


Работа с обращениями
625 / 694

Чтобы ответить на обращение, нужно перейти к его изменению с помощью двойного клика по записи в списке либо через соответствующий пункт контекстного меню:

Примечание: администраторам техподдержки отображаются все сообщения, сотрудникам – только те обращения, за рассмотрение которых они отвечают.

Форма просмотра обращения состоит из трех частей:

  • Информационная часть
  • Обсуждение
  • Ответ

Информационная часть

Данная часть содержит следующие данные:

  • сайт, на котором было создано обращение;
  • источник обращения (е-mail, телефон, web (форма на сайте), форум) и автор обращения;

    Примечание: обращение пользователя в службу поддержки (например, если пользователь создал обращение посредством телефонного звонка) может быть зарегистрировано администратором либо сотрудником техподдержки. При этом с помощью поля Автор обращение привязывается к конкретному пользователю в системе. Таким образом, дальнейшее обсуждение вопроса может проходить в рамках обращения.

  • дату создания и изменения обращения;
  • дату и время последнего результативного ответа на обращение (т.е. ответа, приведшего к изменению индикатора обращения на зеленый).
  • ссылку на историю заказов пользователя - автора обращения. Отображается при условии наличия установленного модуля Интернет-магазин.

Обсуждение

Данная часть содержит:

  • список всех сообщений в рамках обращения;
  • записи (логи) о действиях сотрудников техподдержки и создателя обращения (выделяются желтым фоном). Например, об ответе на обращение, изменении или дополнении обращения, назначении ответственного и т.д.;
  • записи о действиях системы (отображаются розовым цветом). Например, об изменении индикатора обращения, истечение даты ответа, автоматическом закрытии обращения и т.п.

Ответ

Данная часть служит для создания ответа на обращение. Сообщение открывается в одном из следующих режимов:

  • Просмотр;
  • Ответ.
Примечание: выбор режима работы с сообщением по умолчанию осуществляется в настройках модуля Техподдержка (Настройки > Настройки продукта > Настройки модулей > Техподдержка):

Если сообщение открыто в режиме Просмотр, то для того чтобы начать отвечать на обращение, нужно переключиться в режим ответа.

Примечание: кнопка режима, в котором ведется работа с обращением, является неактивной.

В специальной области, расположенной в левой части формы, отображается список пользователей, открывших сообщение.

Для каждого пользователя отображается иконка режима, в котором выполняется просмотр сообщения:

- режим просмотра;
- режим ответа.

Это позволяет организовать коллективную работу над обращениями и избежать ответа на сообщение одновременно несколькими сотрудниками.

Примечание: обновление списка пользователей, просматривающих сообщение, выполняется автоматически в соответствии с настройками модуля Техподдержка:

Иконка [image] позволяет обновить список пользователей, просматривающих сообщение в данный момент, вручную.

При переключении в режим ответа начинается учет времени, затрачиваемый сотрудником на ответ на обращение.

Таким образом, если по умолчанию обращение открывается в режиме Ответ, то подсчет времени начинается немедленно.

При работе с сообщением сотрудник техподдержки может:

  • Создать ответ на обращение.

    • Примечание: если созданный ответ не является окончательным или является пояснением, например, к текущим действиям сотрудников, то может возникнуть необходимость в сохранении текущего статуса обращения. Для этого нужно установить флажок в поле Не изменять статус обращения.

  • Создать скрытое сообщение в рамках обращения.

    Скрытое обращение будет доступно для просмотра только сотрудникам техподдержки.

  • Определить статус, критичность, сложность, категорию, уровень поддержки для обращения, а также назначить сотрудника, ответственного за решение проблемы.
    Примечание: при изменении уровня поддержки или категории, в качестве сотрудника, ответственного за решение проблемы, может быть назначен сотрудник, установленный в параметрах категории или уровня поддержки по умолчанию. Для этого служит иконка [image], расположенная рядом с соответствующим полем.
  • Если ответ на обращение не может быть дан в ближайшее время либо необходимо поддерживать его актуальность, то сообщение может быть сохранено в качестве отложенного. При этом текущий статус (индикатор сообщения) изменен не будет.
  • Для того чтобы закрыть сообщение, следует установить флаг в поле Закрыть сообщение.
  • Использование поля Закрыть при отсутствии ответа через позволяет определить период, по истечении которого обращение будет закрыто автоматически:
    Обращение закрывается автоматически при условии, что после ответа сотрудника техподдержки автор не добавлял в это обращение новые сообщения.

    Примечание: значение поля Закрыть при отсутствии ответа через по умолчанию задается на странице настроек модуля Техподдержка:

В соответствии с настройками почтовых шаблонов сообщения обо всех изменениях в рамках обращения (ответе на вопрос, изменении ответственного или статуса обращения и т.д.) дублируются на электронный адрес создателя обращения, ответственного сотрудника и администратора службы поддержки.

Документация по теме:

  • Обращения
  • Создание и редактирование обращения


Графики
626 / 694

На странице Графики (Сервисы > Техподдержка > Графики) можно построить отчет в виде графика или диаграммы по следующим показателям:

  • по нагрузке на техподдержку. График отображает количество обращений и сообщений в системе техподдержки по дням. График отражает загрузку службы техподдержки на конкретную дату и может использоваться для принятия управленческих решений по функционированию службы техподдержки:

    График нагрузки на техподдержку

  • по длительности решения проблем. Круговая диаграмма наглядно показывает типичное количество времени (в днях), которое тратится на решение проблем службой техподдержки:

    График длительности решения проблем

  • по количеству сообщений, необходимых для решения проблемы. На данной диаграмме представлено процентное соотношение количеств сообщений в закрытых обращениях:

    График количества сообщений, необходимых для решения проблем

Документация по теме:

  • Графики


Расписания и исключения
627 / 694

Настройка расписаний, в соответствии с которыми будет оказываться техническая поддержка, выполняется на странице Расписания (Сервисы > Техподдержка > Расписания > Расписания):

В форме создания/редактирования расписания указывается название расписания, например, 5-дневная рабочая неделя:

На закладке Часы выполняется детальная настройка режима работы:

Расписание работы задается для каждого дня недели.Возможны следующие режимы работы техподдержки:

  • 24 часа - круглосуточный режим работы;
  • не работает;
  • часы работы (HH24:MI) - позволяет задать интервалы времени работы техподдержки (используется 24-х часовой формат). Ведется проверка корректности указанных дат.

    Кнопка Копировать служит для копирования текущего значения времени работы в нижнее поле.

Созданные в системе расписания используются при настройке уровней техподдержки (SLA).

Для уровней техподдержки можно настроить некоторые исключения в оказании технической поддержки (например, техподдержка по некоторому уровню оказывается с понедельника по пятницу, но в связи с переносом праздничного дня необходимо сделать субботу рабочим днем). Настройка исключений осуществляется на странице Исключения (Сервисы > Техподдержка > Расписания > Исключения):

В форме создания/редактирования исключения указывается название, действие исключения (отдых или работа), период действия исключения и выбираются уровни поддержки, для которых будет использоваться это исключение:

Документация по теме:

  • Расписания
  • Создание и редактирование расписания
  • Исключения
  • Создание и редактирование исключения


Группы
628 / 694

Группы созданы для облегчения коллективной работы с обращениями. Они могут быть как клиентскими, так и для сотрудников поддержки. Клиентские группы включают, как правило, пользователей от одного клиента компании. Группы техподдержки включают в себя, как правило, сотрудников одного отдела.

Например, у компании есть сотрудники техподдержки. К ним поступают обращения от сотрудников клиента.

Каждый сотрудник техподдержки работает только лишь с теми обращениями, в параметрах которых он указан как сотрудник, ответственный за решение проблемы. Но как быть, если необходимо для упрощения работы отдела техподдержки обеспечить лёгкий доступ всех или части сотрудников к общим обращениям?

Для этого достаточно создать группу (Сервисы > Техподдержка > Группы), отметить в настройках опцию Группа сотрудников техподдержки

Группа сотрудников техподдержки

а на закладке Пользователи включить в неё нужных сотрудников и указать, смогут ли они видеть сообщения группы или получать уведомления

Тогда обращения для любого члена группы станут видны его соседям по группе (другим сотрудникам техподдержки).

Примечание: В состав такой группы могут входить только сотрудники техподдержки.

В свою очередь, у клиента есть сотрудники, которые обращаются в техподдержку компании. Там аналогичная ситуация: обращение, отправленное в техподдержку, видит только его автор, что не всегда удобно. Если, к примеру, сотрудник ушёл в отпуск, то его обращения должен вести кто-то другой, при этом передавать логин/пароль, естественно, некорректно. Поэтому клиент обращается в компанию с просьбой дать доступ к обращениям сотрудника, ушедшего в отпуск, например, всем другим его сотрудникам, зарегистрированным на сайте.

Для этого администратору техподдержки необходимо лишь объединить сотрудников клиента в одну группу и убрать опцию Группа сотрудников техподдержки в настройках:

Документация по теме:

  • Группы
  • Создание и редактирование группы


Спецобращения
629 / 694

На странице административного раздела Сервисы > Техподдержка > Купоны спецобращений вы можете сгенерировать купоны спецобращений для ваших клиентов.

Спецобращение - обращение в техподдержку, время реакции на которое ограничено одним часом вне зависимости от времени суток.

Для добавления купона нажмите Добавить купон на контекстной панели, откроется форма добавления:

О полях данной формы читайте в документации.

После того, как купон будет создан, его последовательность символов можно узнать либо в форме его редактирования, либо в общем списке купонов:

Данную последовательность клиенту следует вводить в специальное поле при создании обращения:

Важно! В настройках компонента должна быть отмечена опция Показывать поле ввода купона.

На странице Сервисы > Техподдержка > Журнал использования купонов показана информация об использовании купонов:

Документация по теме:

  • Купоны спецобращений
  • Создание и редактирование купона
  • Журнал использования купонов


Фотогалерея
630 / 694

Повседневное управление фотогалереями выполняется Администратором КП. Администратор системы организовывает вывод фотогалерей в публичной части.


Публикация фотогалерей
631 / 694

Выводим фотогалереи на сайте

Публикация фотогалерей выполняется с использованием визуальных компонентов модуля Фотогалерея 2.0, традиционным для сайтов на CMS "1С-Битрикс: Управление сайтом" способом и, затем, компонент настраивается на нужный инфоблок .

Рассмотрим примеры публикации разных типов фотогалерей.

Простая фотогалерея.

Простая фотогалерея - это галерея, которой управляет один пользователь. Только он может загружать в неё изображения и определять права доступа к ним.

Публичный интерфейс такой фотогалереи создается с помощью комплексного компонента Фотогалерея 2.0 . Создайте новую страницу и разместите на ней этот компонент. При настройке параметров компонента укажите Тип инфоблока и Инфоблок:

Многопользовательская фотогалерея

Такая фотогалерея отображает все фотографии и альбомы пользователей (или групп) социальной сети на одной физической странице. Создайте страницу и разместите на ней комплексный компонент Фотогалерея 2.0 (многопользовательская) .

В настройках компонента укажите Тип инфоблока и Инфоблок (см. иллюстрацию выше). Например, чтобы на странице отображались галереи пользователей, выберите Фотогалерея для всех. В результате все персональные галереи пользователей будут отображаться в виде соответствующих ссылок с именами пользователей.

Аналогично выполняются настройки для фотогалерей групп.

Фотогалерея Социальной сети

Страницы фотогалерей пользователей и групп выполняется аналогично размещением соответствующих комплексных компонентов: Социальная сеть - пользователь и Социальная сеть - группы .

После этого в настройках компонентов укажите Тип инфоблока и Инфоблок (см. иллюстрацию выше).

В результате в публичном разделе:

  • на личной странице пользователя будет доступна вкладка Фото, с помощью которой пользователь может хранить персональные альбомы и фотографии;
  • на странице группы будет доступна закладка Фото, на которой организована фотогалерея группы.

Управление доступом к личным фотогалереям выполняется пользователем/модератором группы в персональных настройках.

Документация по теме:

  • Описание компонентов модуля


Форум
632 / 694

Всю основную работу с форумами может провести администратор портала. Администратор системы отвечает за настройку модуля форумов.


Настройка модуля
633 / 694

Системная настройка модуля Форум

Управление настройками выполняется на странице настройки модуля Форум (Настройки > Настройки продукта > Настройки модулей > Форум).

Нажмите на рисунок, чтобы увеличить

На закладке Настройки задаются глобальные настройки параметров, которые определяют:

  • выбор галереи смайлов форума (Начиная с версии 15.5.2 модуля Форум используются смайлы ядра системы;
  • возможность редактирования личных сообщений;
  • отображение имени пользователя и ограничения размера его аватара;
  • настройки персональных сообщений;
  • количество документов, индексируемых за один шаг.

Примечание: подробное описание каждого параметра приведено в пользовательской документации по модулю Форум.

На закладке Доступ настраиваются уровни прав доступа к модулю для групп пользователей.

Примечание: чтобы пользователи имели возможность редактировать профиль на форуме, дайте группе пользователей форума права не ниже [Р] Изменение профайла в настройках Главного модуля.

Для фильтрации нецензурных слов на страницах форума включите опцию Включить фильтр нецензурных слов, расположенную на закладке Фильтр нецензурных слов .

При включенном фильтре указывается действие, которое выполнится с найденными словами:

  • ничего – никакие действия над нецензурными словами выполняться не будут;
  • удалить – нецензурные слова будут удалены из текста;
  • заменить – слова будут заменены на значение, заданное в поле Замена.

Кроме того, для каждого языка необходим Словарь слов и регулярных выражений, в которых хранятся нецензурные слова. Фильтрация текста сообщений выполняется на основании словаря.

Примечание: подробнее о настройке фильтра рассказано в уроке Фильтр нецензурных слов.

Документация по теме:

  • Настройки модуля


Чат-боты Битрикс24
634 / 694

Установка модуля

Модуль Чат-боты Битрикс24 включён во все редакции коробочной версии Битрикс24. После его установки и настройки пользователям становится доступным функционал штатных Чат-ботов.

Модуль не устанавливается автоматически при установке дистрибутива портала или при обновлении Битрикс24. Устанавливать его нужно вручную на странице Настройки > Настройки продукта > Модули. Кроме этого, необходимо произвести настройки локальной сети для его работы.

Модуль не установится, если:

  • Не установлен или не настроен модуль Push&Pull с сервером очередей.
  • Не установлен модуль Веб-мессенджер (im) в версии не ниже 16.1.0.
  • Лицензия портала не активна.

Во время установки нужно будет указать публичный адрес для доступа из Интернета к порталу.

Настройки локальной сети

Если ваш портал размещён за файерволлом или роутером, то в них должен быть открыт доступ к странице портала /pub/imbot.php с сервера marta.bitrix.info.

Внешним признаком недоступности портала из Интернета является то, что бот реагирует на ваш запрос (появляется текст [image]), но не выводит ответа.


Настройка модуля
635 / 694

Настройка модуля Чат-Боты

Настройка производится на странице Настройки > Настройки продукта >Настройки модулей > Чат-боты Битрикс24:

Нажмите на рисунок, чтобы увеличить

  • Публичный адрес сайта - также должен быть правильно определен адрес портала. Он должен быть указан вместе с адресом портала и протоколом. Закрывающий слэш не обязателен.
  • Режим отладки - опция включает логгирование работы модуля в файле /bitrix/modules/imbot.log.

    Примечание: В файл пишется только лог ошибок, включать данную опцию имеет смысл только для отладки, лог трассировки сообщений в этот файл не пишется.

  • Долгое ожидание ответа - опция появляется после включения Режима отладки. Включение влияет на количество занятых worker-ов хостинга. Без активации этой опции сообщение чат-боту отправляется и worker освобождается. В случае активации опции worker будет занят до момента ответа чат-ботом (а это может занимать десятки секунд). Поэтому включать эту опцию нужно, только если не получилось корректно настроить окружение, и оно блокирует входящие запросы от marta.bitrix.info.
  • Чат боты - опции включения чат-ботов. По умолчанию включён только чат-бот Giphy (показ картинок по запросу).

Примечание: Если возникают проблемы с прохождением сообщений, необходимо включить опцию Долгое ожидания ответа в опциях модуля.

Настройка чат-бота обращений к Техподдержки

Для облегчения общения администратора и разработчика с Техподдержкой "1С-Битрикс" рекомендуется использовать чат-бот Поддержка Битрикс24 в коробке. Включение этого бота имеет некоторые особенности, помимо установки флажка в списке чат-ботов.

  1. Адрес, указанный в поле Публичный адрес сайта должен быть доступен из интернета.
  2. Сертификат SSL должен быть валидным.
  3. Лицензия на портал должна быть активна.


Экстранет
636 / 694

Экстранет - расширение корпоративного портала, которое позволяет компании осуществлять конфиденциальную связь с поставщиками, дистрибьюторами и другими внешними пользователями без доступа их к внутрикорпоративной информации.

Модуль входит в редакции Корпоративный портал и Холдинг продукта «Битрикс24 в коробке». Количество внешних пользователей в модуле Экстранет не ограничивается и не зависит от лицензии, приобретенной на пользователей корпоративного портала.

Для настройки модуля Экстранет необходимо обладать правами Администратора системы. Администратор портала будет иметь доступ к экстранету в случае, если он еще входит как минимум в группу Пользователи экстранета. Для текущей административной работы с сайтом экстранета создается специальная группа Администратор сайта экстранета.

Дополнительная информация

  • Экстранет (документация)


Установка модуля и настройка сайта экстранета
637 / 694

Установка модуля

При установке продукта «Битрикс24 в коробке» выполняется автоматическая установка модуля Экстранет. Администратору нужно только пройти Мастер настройки сайта экстранета. Если в силу каких-то причин (например, переход с младшей редакции на старшую) модуль не был установлен, то для установки модуля перейдите на страницу Управление модулями (Настройки > Настройки продукта > Модули).

Найдите в общем списке модуль Экстранет и нажмите на кнопку Установить. По окончании установки будет выведено соответствующее сообщение и ссылка для запуска мастера настройки сайта экстранета:

Мастер настройки сайта экстранета

Примечание: Кроме описанного ниже способа настройки сайта экстранета в общем списке мастеров доступен мастер настройки сайта экстранета (Настройки > Настройки продукта > Список мастеров).

Выполните запуск мастера. Первый шаг мастера информирует о начале процесса установки и выводит основную информацию о мастере. Нажмите кнопку Далее.

На последующих двух шагах выберите дизайн сайта и цветовую схему. Нажмите кнопку Далее.

На следующем шаге выполняется настройка основных параметров сайта экстранета.

  • Название компании - введите название компании или фразу, которая будет отображаться на сайте экстранета.
  • Идентификатор сайта экстранета - двухсимвольный код сайта на латинице (первым символом обязательно должна быть буква).
  • Папка для сайта экстранета - имя папки, в которой будет размещен сайт экстранета.

Нажмите кнопку Установить. Начнется процесс установки и настройки данных сайта экстранета.

По окончании процесса установки система автоматически перейдет к последнему шагу, уведомляющему об успешном окончании работы мастера настройки сайта экстранета. Для выхода из мастера служит кнопка Перейти на сайт. При ее нажатии будет открыта главная страница сайта экстранета, представляющая собой персональный рабочий стол.

Нажмите на рисунок, чтобы увеличить

Примечание: Идеология работы с Экстранетом не требует перехода на него как на отдельный сайт. Все работы сотрудники компании (пользователи корпоративного портала) могут выполнять из самого корпоративного портала. Если по каким-то причинам потребовался переход на сайт Экстранета, то для этого достаточно дописать в адресной строке: /extranet. Собственно в Экстранете работают только приглашённые со стороны на корпортал пользователи.

Перейдя в административный раздел, вы можете убедиться, что экстранет реализуется на основе многосайтовости первого типа:

и на странице Список сайтов (Настройки > Настройки продукта > Сайты > Список сайтов):

Кроме того, в процессе работы мастера создаются все необходимые объекты сайта экстранета: информационные блоки, форумы и группа блогов для блогов пользователей экстранета.

Примечание: дополнительная информация по структуре сайта экстранета представлена в Курсе Пользователь корпоративного портала.


Настройки модуля
638 / 694

Настройка параметров модуля производится автоматически в процессе работы мастера настройки сайта экстранета. Впоследствии изменять значение параметров не рекомендуется.

Исключением является случай, если администратор системы самостоятельно настраивает сайт экстранета без помощи мастера. При этом данные сайта эктранета необходимо указать в настройках модуля Экстранет (Настройки > Настройки продукта > Настройки модулей > Экстранет):

  • Код сайта экстранета - из созданных в системе сайтов выбирается сайт, который будет являться сайтом экстранета.
  • Символьный код пользовательского свойства признака публичности сотрудника - задается код пользовательского свойства для признака публичности сотрудника.
  • Группа пользователей экстранет - выбирается группа, пользователи которой будут являться пользователями сайта экстранета.

Важно! Пользовательское свойство публичности сотрудника и группа пользователей, обладающая доступом к экстранету, должны быть созданы предварительно.


Права доступа пользователей экстранета
639 / 694

Примечание: обычно в целях безопасности доступ к корпоративному порталу для неавторизованных пользователей запрещен. Данная возможность настраивается при установке портала:

Если опция Разрешить неавторизованным посетителям просматривать портал будет отмечена, то неавторизованным пользователям будет доступен внутренний портал компании в рамках прав группы Все пользователи (в том числе неавторизованные).

Поскольку и сотрудники компании, и внешние пользователи имеют ограниченный доступ к сайту экстранета, то для этого в системе должны быть созданы соответствующие группы пользователей.

Если сайт экстранета настраивался с помощью мастера, то все необходимые группы пользователей были созданы автоматически (Настройки > Пользователи > Группы пользователей):

  • Пользователи экстранета - группа пользователей экстранета.

    Примечание: чтобы иметь возможность просматривать сайт экстранета, и внешние пользователи, и сотрудники компании должны иметь привязку как минимум к этой группе.
  • Могут создавать рабочие группы в экстранете - пользователи данной группы обладают правом создания рабочих групп в экстранете.
  • Администраторы сайта экстранета - имеют полный доступ к экстранету.

Если сайт экстранета настраивается вручную, то все необходимые группы пользователей необходимо создать самостоятельно.

Примечание: вся необходимая информация по работе с группами доступна в уроке Группы пользователей.


Публичный сотрудник
640 / 694

Для сайта экстранета вводится понятие публичный сотрудник, которое отсутствует на корпоративном портале.

Публичный сотрудник - это обязательно сотрудник компании, обладающий свойством публичности на сайте экстранета, т.е данный сотрудник всегда доступен для общения и включения в любую рабочую группу экстранета.

Если сайт экстранета был настроен с помощью мастера, то свойство публичности UF_PUBLIC было создано в процессе его работы. В противном случае необходимо перейти на страницу Пользовательские поля (Настройки > Настройки продукта > Пользовательские поля) и создать данное свойство:

Примечание: при деинсталляции и повторной установке модуля данное свойство остается в прежнем виде.

Чтобы некоторого пользователя назначить публичным сотрудником экстранета, необходимо выполнить следующие действия:

  • Перейдите на страницу Список пользователей (Настройки > Пользователи > Список пользователей).
  • Откройте форму редактирования необходимого пользователя и перейдите на закладку Доп. свойства.
  • Отметьте опцию Публичный сотрудник.
  • Сохраните внесенные изменения.

В результате пользователям экстранета всегда будет доступен публичный сотрудник:


Универсальные списки
641 / 694
Иногда функционала информационных блоков не хватает для работы с необходимой информацией. В этом случае на помощь приходит модуль 1С-Битрикс Универсальные списки.


Возможности модуля
642 / 694

Модуль может:

  • Сконструировать произвольные хранилища информационных объектов;
  • Предоставить доступ к функционалу из публичной части сайта;
  • Создать произвольную иерархию хранения объектов;
  • Фильтровать и сортировать данные, настраивать колонки и поля карточки элемента и списков элемента, выполнять групповое редактирование, управлять правами доступа и другое.

Универсальные списки используются в следующих сценариях:

  • FAQ (часто задаваемые вопросы);
  • Cправочники и базы знаний;
  • Cписки контрагентов;
  • Cтруктурированные архивы;
  • Библиотеки и файловые хранилища;

Примечание: Подробнее о работе с модулем Универсальные списки читайте в курсе Контент-менеджер.

Документация по теме:

  • Универсальные списки
  • Настройки модуля


Настройка модуля Универсальные списки
643 / 694

Настройка модуля Универсальные списки производится в Административном разделе на странице Настройки > Настройки продукта > Настройки модулей > Универсальные списки.

Нажмите на рисунок, чтобы увеличить

Закладка "Права доступа"

Внимание! Универсальные списки имеют расширенные права задания прав независимо от настроек информационных блоков в Административной части.

На закладке Права доступа определяется, какие группы пользователей имеют доступ к инфоблокам, используемыми в качестве списков. Для настройки доступа нужно в столбце Группы пользователей выбрать нужную группу пользователей, а в столбце Типы инфоблоков - назначить соответствующий тип инфоблока для выбранной группы.

Группы пользователей, указанные на данной закладке, смогут создавать свои собственные списки (инфоблоки) в указанном типе инфоблоков или редактировать существующие, в отличие от остальных групп.

Закладка "Социальная сеть"

Установив флажок в поле Включить поддержку социальной сети, вы дадите разрешение на то, чтобы Универсальные списки появились в Рабочих группах.

В поле Тип инфоблока необходимо выбрать нужный тип инфоблока, который будет использован в качестве списков в Соцсети. Допустимо использование разных типов инфоблоков в качестве источника данных для Соцсети и для списков на других страницах проекта.

Закладка "Живая лента"

Снятие флажка в поле Включить функционал работы с живой лентой отключает отображение Бизнес-процессов списков в Живой ленте. Также отключается отображение пунктов меню Мои процессы и Процессы. Но только отображение, зная прямой URL до этих страниц пользователь может открыть эти страницы. Если флажок отмечен, то необходимо отметить тип инфоблока для работы с живой лентой, а также папку, в которой работает компонент.

Документация по теме:

  • Пользовательская документация по модулю "Универсальные списки"


Учет рабочего времени
644 / 694

Модуль Учет рабочего времени предназначен для организации контроля за количеством рабочего времени, затраченным сотрудником, и задачами, решенными им за этот период.

Настройка параметров модуля производится на странице Настройки > Настройки продукта > Настройки модулей > Учет рабочего времени, на вкладке Рабочий день:

Разъяснения значений всех полей даётся в подсказке рядом с полем: . Для задания параметров времени можно использовать инструмент Указать время:

Настройка рабочего дня

Настройка параметров рабочего дня производится на на вкладке Рабочий день. Установленные параметры будут являться параметрами по умолчанию для всей компании, однако могут быть переопределены в настройках подразделения или сотрудника. Такие настройки доступны пользователям, входящим в группу Отдел кадров.

Настройки доступа

Настройка параметров субординации и доступа к модулю производится на вкладке Доступ.

В группе полей Общие права доступа указывается доступ к модулю различных групп сотрудников портала.

Примечание: Познакомится с уровнем доступа группы и, при необходимости, создать новые уровни доступа можно на странице Уровни доступа.

В группе полей Субординация настраиваются права доступа к управлению записями о рабочих днях и чтению отчетов.

Сотрудники могут редактировать текущий рабочий день - отмеченная опция дает право сотрудникам вносить изменения в уже отмеченное время начала и конца рабочего дня.

Примечание: в записи о рабочем дне отображается факт внесения сотрудником изменений.

Управление рабочим днем и чтение отчетов - укажите доступ всех сотрудников и руководителей подразделений к чтению отчетов и управлению рабочим днем.

Изменение и подтверждение записей - укажите права доступа руководителей подразделений на изменение и подтверждение записей о рабочих днях своих подчиненных.

Настройка отчётов

На закладке Рабочие отчеты можно настроить форум, в котором будут храниться комментарии к отчетам. Если в этом нет особой необходимости не рекомендуется менять форум, установленный по умолчанию.

Если используется штатный дизайн, то нет необходимости и изменять пути для страниц отчётов.

Дополнительная информация

  • Учёт рабочего времени (документация)


Многодепартаментность
645 / 694

Многодепартаментность - возможность запустить отдельную версию корпоративного портала для подразделения компании или отдела. Функционал доступен только в редакции Холдинг.

Этот функционал будет полезен для компаний с несколькими офисами или филиалами, которым необходимо обеспечить каждую из структур своим корпоративным порталом и работать с общим порталом для координации деятельности. Так каждое подразделение будет иметь собственный портал для размещения информации, касающейся данного подразделения.

Используя многодепартаментность, создается еще один сайт, в котором часть данных будет общей с главным порталом, но большая часть - индивидуальна для филиала.

Примечание: Количество порталов для подразделений организации не ограничено.

Сквозной функционал, общий для всех порталов организации:

  • персональный календарь, задачи, файлы, фотогалерея и сообщения пользователя;
  • весь раздел Сотрудники;
  • весь раздел CRM.

Индивидуальные данные портала подразделения:

  • группы, блог (и микроблог), форум и живая лента пользователя;
  • раздел Компания;
  • раздел Документы;
  • раздел Cервисы;
  • раздел Группы.

Примечание: Для портала отдела создается дополнительный сайт, файлы которого располагаются в подкаталоге от корня сайта. Многодепартаментность строится по первому методу многосайтовости ( многосайтовость на одном домене ).

Включение поддержки многодепортаментности с помощью мастера настройки портала

Младшие редакции позволяют включить в тестовом режиме (на 90 дней) весь функционал вышестоящих редакций. Включить поддержку многодепортаментности также возможно потребуется после смены лицензии или обновления портала старой редакции на редакцию Холдинг.

Для этого необходимо запустить мастер настройки портала:

Кнопка "Мастер настройки портала"

Включение поддержки многодепортаментности осуществляется на 8-м шаге:

8й шаг мастера настройки портала

После прохождения мастера в панели появится новая кнопка Добавить подразделение

Cоздание портала для подразделения организации

Для создания портала подразделения компании используется кнопка Добавить подразделение

Кнопка "Добавить подразделение"

Она, по сути, запустит тот же мастер настройки портала, только на 9 шаге необходимо указать подразделение, для которого создается портал:

После прохождения мастера откроется портал подразделения.

Переход между порталами осуществляется либо:

  • по команде Перейти на сайт кнопки Добавить подразделение

  • либо через меню:

Демо-данные портала департамента могут быть также удалены, используя мастер удаления демо-данных.

Добавление сотрудников на портал подразделения

После создания портала подразделения компании для него автоматически будут созданы отдельные группы пользователей.

При запуске мастера добавления подразделения, сотрудники выбранного департамента будут автоматически приписаны к соответствующей группе.

В случае добавления новых пользователей на портал подразделения компании уже после его создания для них необходимо указать:

  • принадлежность к группам на закладке Группы страницы редактирования пользователя.

    Примечание: Для того чтобы сотрудник имел доступ к главному порталу и порталу подразделения он должен состоять в обеих группах Сотрудники.

  • и подразделение на закладке Пользователь той же страницы:

Примечание: Подробнее про управление пользователями смотрите в главе Управление пользователями.


Примеры решения типовых задач
646 / 694

В разделе собран список типовых действий и задач администратора, которые встречаются в разных разделах курса.

Создание:

  • Создание рассылки
  • Создание и публикация веб-формы
  • Создание и публикация опроса
  • Создание личной страницы сотрудника
  • Создание страницы группы
  • Создание списка нужного типа
  • Создание библиотеки документов

Настройка:

  • Постановка уровня защиты веб-проекта на высокий уровень
  • Настройка вида форм
  • Настройка доступа к файлам и папкам
  • Размещение гаджетов, настройка рабочего стола
  • Настройка вида меню

Другое:

  • Перенос сайта
  • Запуск отдельной версии корпоративного портала для подразделения компании
  • Импорт/экспорт курсов
  • Редактирование почтового шаблона
  • Очистка кэша
  • Резервное копирование
  • Экспорт/импорт данных и пользователей
  • Восстановление базы данных
  • Удаление демо-данных
  • Работа со списком элементов
  • Добавление нового языка в систему
  • Добавление информационных блоков
  • Работа с результатами прохождения тестов
  • Включение сервиса "Зарплата и отпуск"
  • Публикация кадровых изменений в компании
  • Рейтинги. Примеры работы
  • Добавление пользовательских полей для задач
  • Добавление пользовательского свойства
  • Работа с комментариями многопользовательской галереи

Список ссылок по теме:

  • Инструкция: Управление пользователями корпоративного портала (блог)


Десктопное приложение - работа администратора
647 / 694

Десктопное приложение имеет дистрибутивы для всех операционных систем. Функционал приложения для разных операционных систем может различаться.

Технические требования

Параметры клиент-серверного взаимодействия: протокол HTTP, порт 443 или 80, порт для Push and Pull.

Специальных технических требований для ПК для работы приложения нет, кроме как Windows 7 или выше (клиент приложения для Windows XP SP3 больше не поддерживается). Подойдёт любой ПК, на котором может работать Windows и Chrome.

Внимание! Для Битрикс24 в коробке, работающем по протоколу HTTPS в ОС Windows XP может не работать подключение к порталу. В Windows XP могут не работать новые шифры SSL, то есть если на сервере отключают поддержку старых шифров, то у XP-клиентов может не работать приложение.

Так же не поддерживается macOS 10.9 и 10.9.5 в силу особенностей встраиваемого Chrome.

Установленное Десктопное приложение само по себе (без пользовательских данных) занимает около 100 МБ. В RAM при запуске тоже занимает примерно столько же. Дальнейший трафик и рост потребления памяти зависят от реальной ситуации на портале. Чем больше пользователей, тем больше размеры и того и другого.

Внимание! Десктопное приложение на ARM не работает. Оно рассчитано только платформу Intel x86\x64.

Параметры запуска приложения

Для для установки удаленно десктопного приложения используйте msi дистрибутив. Ключи командной строки для установки - стандартные.

Десктопное приложение через прокси-сервер

Для корректной работы приложения с использованием прокси-сервера необходимо выполнить настройки локальной сети и браузеров пользователей:

Настройки браузера

Откройте свойства браузера: Панель управления > Свойства обозревателя или через настройки самого браузера:

Во вкладке Подключения и перейти по кнопке Настройка сети. В появившемся окне активировать галочку Использовать прокси-сервер... и ставших активными полях ввести необходимую информацию о прокси сервере: ip и порт.

Настройки локальной сети

Windows XP/2003:

Запустите командную консоль под администратором на компьютере, выполните команду:

proxycfg -p http://192.168.0.1:3128 "<local>"

Эта команда перенаправляет весь ваш HTTP и HTTPS трафик (за исключением локального) через прокси-сервер.

Если нужно удалить все настройки созданные утилитой proxycfg.exe нужно удалить ключ WinHttpSettings из ветки реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\WinHttpSettings

Windows Vista/7/2008 и выше:

Запустите командную консоль под администратором на компьютере, выполните команду:

netsh.exe winhttp show proxy

Если отобразится сообщение: Прямой доступ (без прокси-сервера), тогда нужно настроить WinHTTP на тот же прокси, что и в IE. Можно это сделать автоматически:

netsh.exe winhttp import proxy source=ie

Сбросить же настройки прокси сервера можно при помощи команды:

netsh.exe winhttp reset proxy

Для работы с Диском необходима дополнительная настройка прокси, так как в Диске используется не winhttp, а curl. Поэтому необходимо настроить системные переменные окружения http_proxy и https_proxy (Панель управления > Система > Дополнительно).

Для Mac OS:

launchctl setenv http_proxy http://192.168.0.1:3128
launchctl setenv https_proxy http://192.168.0.1:3128


Реализация сценария использования абонементов на посещения
648 / 694

Рассмотрим реализацию продажи абонементов на посещения с помощью инструментов Битрикс24.

  • Постановка задачи
  • Создание сделки
  • Бизнес-процесс
  • Оповещение клиента
  • Подготовка отчета

Постановка задачи

В рассматриваемом сценарии необходимо реализовать продажу двух видов абонементов, различающихся по стоимости - на месяц и на две недели. При этом нужно вести учет посещений и отправлять ответственному менеджеру напоминания о заканчивающемся абонементе какого-либо клиента.

В данном примере, средствами Битрикс24, это сделано следующим образом. Для каждого клиента в CRM создается контакт, а под каждый абонемент - товар в каталоге CRM. При продаже абонемента контакту - создается сделка. После создания сделки запускается бизнес-процесс, который отчитывает время до окончания срока действия абонемента, и за несколько дней до его наступления ставит задачу ответственному за данную продажу менеджеру.

Создание сделки

Рассмотрим поэтапно процедуру реализации данной схемы.

В разделе товары создается абонемент:

Аналогично создается товар Двухнедельный абонемент.

Для клиента, при покупке абонемента, создается сделка:

Заполненная форма создания сделки

Заполните необходимые поля в форме создания сделки:

  • указывается название и обязательно заполняетcя поле Сумма.
  • При необходимости выбирается другой ответственный.
  • Привязка с контакту будет установлена автоматически.
  • Выбирается товар сделки.

Бизнес-процесс

Затем запускается заранее созданный бизнес-процесс с автоматическим запуском при добавлении сделки:

При создании любой сделки проверяется условие выполнения бизнес-процесса (Покупка абонемента), в котором сверяется значение поля Сумма. Рассмотрим пример ветки для месячного абонемента (для двухнедельного абонемента все сделано аналогично):

Бизнес-процесс будет выполняться дальше по данной ветке только в случае, если в поле Сумма созданной сделки прописано значение 5800. Соответственно, для двухнедельного абонемента это значение меньше.

Затем ставится пауза в выполнении на 27 дней:

Для двухнедельного абонемента пауза равна 12 дням.

По прошествии 27 дней, менеджеру, заключившему данную сделку (предполагается, что он - ответственный) ставится задача об уведомлении клиента о скором истечении срока действия его абонемента:

  • В крайнем сроке указано выражение
    =Dateadd({=System:Date}, "1 d")
    Оно устанавливает в качестве крайнего срока один день от текущей системной даты.
  • В качестве постановщика выбирается начальник отдела.
  • В описании задачи будет выведен идентификатор контакта, привязанного к сделке:
    {=Document:CONTACT_ID}
  • Вы можете прикрепить задачу к сделке, установив значение Да в поле Привязать к текущей сущности CRM.

Оповещение клиента

После окончания заданного в бизнес-процессе периода, ответственному за сделку менеджеру придет уведомление о том, что на него поставлена задача:

Найдя по ID в списке контактов нужного клиента, менеджер уведомляет его об истечении срока действия абонемента и предлагает продление.

Подготовка отчета

Учет посещений можно вести, создав отчет по делам:

В данном отчете будет учитываться любое дело (кроме события), в названии которого есть посещение. То есть, к каждому клиенту, при его визите, ответственному за него менеджеру следует добавлять дело, в названии которого будет слово посещение. В результате можно будет вести учет общего числа визитов по абонементам:


Сценарий автоматизации контроля оказания услуг
649 / 694

Последовательно рассмотрим, как с помощью бизнес-процесса, использующего инструменты Битрикс24, может быть реализован возможный вариант автоматизации контроля исполнения работ.

Примечание: данный сценарий для своего использования подразумевает как минимум базовые знания о бизнес-процессах и других инструментах вашего портала.

Подойдет для компаний, схема работы которых выглядит ориентировочно следующим образом:

  • продажа менеджером услуги, клиент оплачивает счет;
  • руководитель получает необходимую информацию об объекте заказчика и выбирает исполнителя;
  • передача исполнителю перечня документов для заполнения;
  • выполнение работы на объекте клиента;
  • проверка менеджером документов;
  • подготовка акта и отчета, уведомление заказчика о завершении работы;
  • менеджер доставляет клиенту акт и отчет.

Менеджер, являясь ответственным за сделку, ведет ее в CRM и после того, как клиент оплачивает счет по ней, переводит ее в стадию Оплачено.

Примечание: для создания такой стадии сделки воспользуйтесь справочниками CRM:

После смены стадии запускается бизнес-процесс на изменение сделки:

Сначала бизнес-процесс проверяет, является ли стадия сделки равной Оплачено (действие Проверка стадии сделки). Для избежания выполнения бизнес-процесса при каком-либо редактировании сделки со статусом Оплачено, предварительно было создано пользовательское поле Изменялась стадия сделки? со значением по умолчанию 0, при котором бизнес-процесс пойдет по своей основной ветке, в конце которой значение данного поля меняется на 1.

Чтобы предусмотреть ситуацию, при которой стадия сделки откатывается от Оплачено, а затем снова в нее возвращается (что требует повторного запуска бизнес-процесса), было задействовано уравнивание нулю значения поля Изменялась стадия сделки? в случае, если после изменения сделка находится в стадии, отличной от Оплачено (действие Изменение значения пользовательского поля в ветке Не оплачено).

Далее в главной ветке бизнес-процесса идет запрос дополнительной информации от начальника отдела (действие Выбор сотрудника для осмотра объекта), которому следует выбрать своего сотрудника для выезда к заказчику. Данное действие при детальном просмотре выглядит следующим образом:

В описании добавлены необходимые для руководителя данные из сделки, такие как комментарий, контакт, компания. Добавлено поле типа Привязка к пользователю, через которое идентификатор выбранного сотрудника будет сохранен в переменной Сотрудник.

При переходе бизнес-процесса к данному действию, требующему ответа от руководителя отдела, у последнего появится запрос об этом в виде цифры рядом с пунктом бизнес-процессы основного меню:

При просмотре задания руководитель будет видеть следующую форму:

В следующем действии стадия сделки меняется на В обработке (действие Сделка - "В обработке"), а руководителю, аналогично запросу на выбор сотрудника, посылается задание (действие Первичное формирование ведомости документов) на формирование ведомости документов, которые необходимо забрать у заказчика:

Составленная ведомость сохранится в переменной Список документов, созданной в форме создания запроса дополнительной информации:

Затем в бизнес-процессе ставится задача подчиненному (выбранному сотруднику):

  • бизнес-процесс приостанавливается на время выполнения задачи;
  • в качестве ответственного ставится выбранный руководителем сотрудник (переменная Сотрудник);
  • с помощью выражения =Dateadd({=System:Date}, "2 days") крайним сроком указано 2 дня от текущей даты;
  • в описание задачи перенесен список документов, составленный руководителем (переменная Список документов) и поля сделки, такие как идентификатор контакта\компании, комментарий;
  • наблюдателем выбран ответственный по сделке менеджер;
  • задача находится в группе Продажи, что позволит в дальнейшем отследить выполнение задач через данную группу;
  • задача привязывается к текущей сущности CRM (сделке).

Для ответственного задача будет выглядеть следующим образом:

После выполнения своего задания ответственный сотрудник может вложить отсканированные документы в комментарии к задаче, либо принести их лично менеджеру на проверку.

После завершения задачи запускается цикл утверждения документов менеджером:

Специально для данного цикла в параметрах шаблона бизнес-процесса была предварительно создана переменная Утверждение документов типа Да\Нет. Цикл будет выполняться до тех пор, пока значение данной переменной не изменится (т.е. произойдет утверждение документов). В случае, если менеджер не утверждает документы, ответственному сотруднику ставится задача Забрать документы на заполнение, в которой будет отображен комментарий менеджера о том, что следует исправить, внесенный им при отклонении документа (Дополнительные результаты > Утверждение документов > Комментарий).

После утверждения документов руководителю отдела ставится задача о подготовке отчета, а менеджеру, не останавливая бизнес-процесс на время выполнения задачи - о передаче акта.

Затем заказчику от имени менеджера (ответственный за сделку) отсылается письмо на электронный адрес с сообщением о завершении работы:

В в качестве адреса получателя указывается значение пользовательского поля email, предварительно созданного для сделок.

После этого следуют действия Изменение полей документа, с помощью которых меняется стадия сделки на Сделка заключена и значение пользовательского поля Изменялась стадия сделки?, о котором было сказано выше.

В нашем случае менеджер и руководитель постоянно в курсе стадии работы с клиентом, являясь либо ответственными\постановщиками, либо наблюдателями всех задач по сделке. Отследить события, текущие дела и задачи по сделке можно в форме ее просмотра (закладки Лента, Дела, История):

Примечание: вы можете скачать шаблон данного бизнес-процесса.


Автоматизация исполнения проекта
650 / 694

Рассмотрим возможный сценарий использования вашего Bitrix Framework для работы над проектом после закрытия сделки.

В нашем случае работа начинается после оплаты и закрытия сделки. После того, как менеджер перевел сделку в стадию Сделка заключена, на руководителя департамента и аналитика ставятся соответствующие их должностям типовые задачи с установленными сроками выполнения, в которые должна быть перенесена первичная информация из сделки. Менеджер должен проследить за корректным выполнением этих задач.

Для реализации такого сценария мы будем использовать бизнес-процесс на изменение сделки. Чтобы исключить случаи постановки задач при изменении каких-либо других данных сделки со статусом Сделка заключена, нами будет создано пользовательское поле, в которое записывается факт перевода сделки в конечную стадию.

Создадим пользовательское поле для сделок:

Значение поля по умолчанию - 0. При переводе сделки в нужную нам стадию и постановки задач нужно будет менять его на 1. Значение 1 и будет означать факт заключения сделки.

На странице CRM > Настройки > Бизнес-процессы добавьте шаблон на изменение для сделок. Откроется форма настройки параметров шаблона:

Создадим следующую схему шаблона бизнес-процесса:

Разберем основные моменты его структуры. Сначала проверяется стадия сделки. Если она равна Сделка заключена, то осуществляется переход к проверке значения пользовательского поля Изменялась стадия сделки:

В случае, когда значение данного поля 0, переходим к постановке задач:

Постановщиком выбран ответственный за сделку менеджер, что позволит ему быть в курсе работы над проектом.

В качестве крайнего срока указано выражение =Dateadd({=System:Date}, "2 days"), которое выставляет дату крайнего срока равной текущая дата + 2 дня.

В Описание задачи копируются поля сделки, такие как Сумма в указанной валюте, Комментарий, Контакт, Компания. Это позволит ответственному за задачу руководителю департамента сразу быть в курсе дел по данной задаче:

Далее выставлены другие параметры задачи, в том числе привязка к текущей сущности CRM, то есть сделке, что может пригодиться для контроля ведущейся с ней работы.

Аналогично ставится задача аналитику, затем в действии Изменение пользовательского поля выполняется смена значения пользовательского поля Изменялась стадия сделки на 1.

Такое же действие, только с присваиванием значения 0, применено в случае, если проверка стадии сделки выявила, что стадия не является Сделка заключена. Это сделано для случая, когда сделку переводят из конечного статуса в предварительный, а затем опять в Сделка заключена. Если бы такого действия не было, то в этом случае постановка задач снова не совершилась бы, поскольку значение поля оставалось бы 1.


Сценарий для работы службы техподдержки
651 / 694

Рассмотрим, как можно организовать работу технической службы, в которую поступают заявки от клиентов на проведение работ и исправление неисправностей.

Клиенты заполняют форму на сайте, в которой указывают свои данные и выбирают причину обращения. Данная информация, путем настроенной интеграции, передается в CRM в виде лида, к которому автоматически привязывается задача под ответственность соответствующего задаче специалиста.

Далее лид администратором конвертируется в контакт и сделку, клиенту выставляется счет. По всем необходимым вопросам с ним ведется общение по телефону или email, что автоматизированно фиксируется в CRM. После того, как работа завершена, задача и сделка закрываются.

Клиент заполняет веб-форму на вашем сайте:

При настроенной интеграции, данные из веб-формы автоматически будут отправлены в CRM в качестве лида.

Для автоматизированной обработки поступившего в CRM лида, нами предварительно был создан бизнес-процесс:

Согласно данному бизнес-процессу, в зависимости от названия создаваемого в системе лида (подключение, замена кабеля, смена тарифного плана), создается задача на соответствующего каждой услуге ответственного, в которую переносятся данные лида (имя, адрес, email) и прикрепляется сам лид.

Примечание: вы можете скачать данный шаблон, а затем импортировать, однако вам необходимо будет настроить его под себя.

Специалисту придет уведомление о поступившей на его имя задаче:

Когда ответственный освобождается, он запускает ее выполнение, о чем администратору, указанному в бизнес-процессе как постановщик, придет уведомление.

После того, как задача начала выполняться, администратор конвертирует лид данной заявки в контакт (новый, либо уже существующий), за который назначает ответственным соответствующего специалиста, и в сделку (где ответственным остается он сам). Назначение специалиста ответственным необходимо для того, чтобы при дальнейшем общении с контактом по email, уведомления об ответных письмах приходили в его центр нотификаций, а не администратора. Затем администратор выставляет счет и отправляет его по e-mail:

После поступления оплаты, ответственный за задачу специалист начинает работу. Из задачи он может перейти к лиду данной заявки:

Из лида можно перейти к сделке или контакту:

Сотрудник может вести общение с клиентом по email или с помощью телефона, добавляя звонки к сущности:

Ответные письма будут привязываться к контакту, в который был сконвертирован лид:

Как только работа по оказанию требуемой услуги клиенту будет выполнена, специалист закрывает задачу, о чем постановщик (администратор) будет проинформирован уведомлением. Сделка закрывается.

Историю изменений сущности, а также выполненных дел и задач, вы можете просмотреть на закладке История.


Работа с комментариями многопользовательской галереи
652 / 694

Как в одном месте редактировать все комментарии

Модерировать комментарии к фотографиям, если фотогалерея развитая, трудозатратно. Приходится открывать все фотографии, смотреть есть ли комментарии. Гораздо удобнее модерировать всё в одном месте. Сделать это не сложно.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Операции с форумом

Отзывы в Фотогалерее реализуются через функционал модуля Форум. Как узнать, какой именно форум для нее используется? Перейдите к настройкам компонента Многопользовательская фотогалерея и в группе параметров Настройки отзывов вы увидите ID форума для отзывов:

Задайте для модераторов необходимые права доступа к этому форуму. Перейдите на страницу административного раздела Сервисы > Форумы > Список форумов > ваш_форум. Далее, в форме редактирования форума, на закладке Доступ, для группы модераторов задайте право доступа Редактирование :

Создание страницы для модерации

Создайте страницу и закройте страницу от всех, кроме группы модераторов комментариев к галерее. Затем разместите на странице комплексный компонент Форум. В настройках компонента, среди прочего, укажите форум многопользовательской галереи в опции Показывать только выбранные форумы:

В результате модераторы будут видеть форум многопользовательской галереи, в темы которого будут добавляться комментарии. Непосредственно в теме можно модерировать комментарии.


Модератор форума
653 / 694

Модерирование форума - одна из задач, которую поручают контент-менеджеру. Он должен следить за текстами пользователей, чтобы не было оскорблений, нецензурой лексики и так далее. Для этого ему даются расширенные, по отношению к обычному посетителю сайта права. Пользователь с правами модератора форума может скрывать\показывать сообщения и темы, переносить их в другие форумы, закрывать\прикреплять темы.

Видео-пример работы модератора форума

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Как работает модератор

У контент-менеджера есть два инструмента модерации: Управление темами и Управление сообщениями:

Меню Управление темой представлено следующими пунктами :

  • Скрыть тему - делает тему недоступной для просмотра всем, кроме модераторов и администраторов. Для них она будет выделена другим цветом среди других тем. Для возврата выберите в меню управления темой пункт Показать тему.
  • Прикрепить тему - прикрепленная тема всегда будет в верхней части списка тем и не будет смещаться вниз обновленными и новыми темами. В таких темах, как правило, размещают какую-то управляющую информацию, к примеру, правила форума. Для открепления темы выберите в меню управления темой пункт Открепить тему.
  • Закрыть тему - в закрытую тему нельзя добавлять сообщения, но можно прочитать. Для открытия темы выберите в меню управления темой пункт Открыть тему.
  • Перенести тему - выберите данный пункт если хотите переместить тему в другой форум. После того, как вы нажмете OK, появится форма переноса темы:

    Выберите нужный форум, куда следует поместить тему , и нажмите Перенести выбранные темы.

Примечание: Темами можно управлять не только внутри самой темы, но и на странице форума. Этот способ удобен для групповой работы с темами: выделяются галочками нужные темы и выбирается нужный пунт меню .

Управление сообщениями

Для управления сообщениями отметьте нужные из них галочками и выберите нужную команду из меню :

  • Скрыть сообщения - сообщения станут недоступными для просмотра всем, кроме тех, кто имеет право на модерирование форума. Для модераторов скрытые сообщения будут видны и выделены другим цветом. Скрытые сообщения можно опять показать в теме при необходимости.
  • Перенести сообщения - перемещает выбранные сообщения в другую тему с помощью формы:

    Чтобы перенести сообщения в существующую тему, вам нужно указать ее ID . После этого нажмите Перенести и сообщения будут перенесены в конец выбранной темы.

    Чтобы перенести сообщения в новую, ещё не созданную тему, отметьте новую тему, введите заголовок, описание новой темы, теги и нажмите Перенести. Новая тема будет создана в том же форуме, а перенесенные сообщения будут в ней первыми.

Как быстро найти изменения в форуме

Модератору удобно просматривать изменения на форумах с помощью поискового запроса по ссылке Обновления, где можно указать форумы, активность на которых интересует данного модератора, и период времени, за который эту активность следует показать:

Дополнительная информация

  • Форум (документация)


Пользовательские поля
654 / 694

Пользовательские поля, их создание и настройка. Что это такое и как использовать.


Что такое Пользовательские поля
655 / 694

Если в системе нет поля для нужных данных

Пользовательское поле - функционал системы, позволяющий добавлять к объектам системы поля, не предусмотренные штатным функционалом.

Необходимо отличать Пользовательские поля в модулях системы и свойства, используемые в рамках инфоблоков , хотя в формах системы (форма создания/редактирования пользователя, форме создания/редактирования раздела инфоблока и другие) используется термин пользовательские свойства.

Пользовательские поля это сущность:

  • более универсальная, в отличие от свойств инфоблока, так как их можно задать для разных объектов системы,
  • ограниченная по возможностям, так как имеет небольшое число типов объектов и данных.

Пользовательские поля могут создаваться в неограниченном количестве для каждого объекта. При выборе того или иного типа пользовательского поля становятся доступными дополнительные поля настройки для соответствующего типа .

Применение пользовательских полей в системе к тем или иным модулям задаётся с помощью объектов, которые необходимо указать при создании поля:

Штатные объекты пользовательских полей
Модуль | Объект | Описание
Главный модуль | USER | для пользователя
Блоги | BLOG_BLOG | для блога
 | BLOG_POST | для сообщения в блоге
 | BLOG_COMMENT | для комментария сообщения
Задачи | TASKS_TASK | для задач
Информационные блоки | IBLOCK_N_SECTION | для секций инфоблока с ID = N
 | IBLOCK_N | Для инфоблока с ID = N
Календарь | CALENDAR_EVENT | для событий календаря
Обучение | LEARN_ATTEMPT | для попыток теста
Социальная сеть | SONET_GROUP | для групп соцсети
Библиотека документов | WEBDAV | для библиотек документов
Форум | FORUM_MESSAGE | для сообщений форума
Highload-блоки | HLBLOCK_N | для highload-блока с ID=N

Не все модули имеют объекты для пользовательских полей по умолчанию. Разработчик сайта может создать собственные объекты .

Примечание: Модули, использующие информационные блоки, могут работать с объектами пользовательских полей модуля Информационные блоки.

Документация по теме:

  • Создание и редактирование пользовательского поля


Создание Пользовательских полей
656 / 694

Новые поля

Создавать Пользовательские поля можно через интерфейс и с помощью АПИ . Создание пользовательских полей из Административной части выполняется на странице Настройки > Настройки продукта > Пользовательские поля либо, что предпочтительнее, с использованием ссылки Добавить пользовательское свойство в тех формах системы, в которых предусмотрено штатное добавление пользовательских свойств:

  • форма добавления/редактирования пользователя;
  • форма добавления/редактирования раздела информационного блока;
  • форма добавления/редактирования блога

Работа со списком и формой создания не должна вызвать затруднений, но есть несколько нюансов.

Установка флажка в поле Не разрешать редактирование пользователем исключит возможность редактирования свойства не только пользователем, но и администратором через административный интерфейс. Значение таких свойств нужно устанавливать используя API. Это нужно для служебных полей, которые не должны использовать пользователи.

Пользовательские поля могут создаваться с разными типами данных. Как правило, этих типов вполне хватает для работы. Если есть необходимость создания собственных типов данных, то это можно сделать самостоятельно. Пример добавления типов данных "Связь с элементом" и "Связь с элементом в виде списка" (блог).

По умолчанию в системе предусмотрены следующие типы пользовательских полей:

  • Число;
  • Да/Нет;
  • Видео;
  • Шаблон;
  • Список;
  • Строка;
  • Дата;
  • Дата со временем;
  • Привязка к элементам highload-блоков;
  • Привязка к разделам инф. блоков;
  • Привязка к элементам инф. блоков;
  • Привязка к элементам CRM;
  • Привязка к справочникам CRM;
  • Файл;
  • Целое число;
  • Документ из библиотеки документов;
  • Привязка к сотруднику;
  • Документ истории из библиотеки документов;
  • Опрос.

Документация по теме:

  • Создание и редактирование пользовательского поля


Пример добавления поля
657 / 694

Создание поля Скайп

Опишем пример создания поля Скайп в форме добавления нового пользователя. Это поле будет относиться к сущности USER Главного модуля.

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

На закладке Доп. поля формы добавления нового пользователя (Настройки > Пользователи > Список пользователей > Добавить пользователя) кликните по единственной имеющейся там ссылке и откроется форма добавления пользовательского свойства, сразу привязанного к нужной нам форме (поле Объект уже с заданным значением):

Заполните минимально необходимые поля :

  • Тип данных - для ввода логина скайпа удобно значение Строка.
  • Код поля - введите UF_SKYPE (код обязательно должен начинаться с UF_).
  • Для возможности поиска по вашему пользовательскому полю отметьте галочкой Значения поля участвуют в поиске.
  • В языковых настройках укажите как будет называться ваше поле: для русского языка - Скайп, для английского - Skype.

Сохраните внесенные изменения.

Затем снова перейдите к форме добавления нового пользователя и нажмите кнопку Настроить на контекстной панели. Появится окно настройки формы редактирования/добавления нового пользователя.

Настройте форму, перенеся созданное свойство из вкладки Доп. свойства на вкладку Личные данные, т.к. именно на нее необходимо добавить поле Скайп. После того, как поле будет перенесено в список выбранных полей, с помощью кнопок Выше и Ниже выберите его расположение среди других полей секции Телефоны .

Пометьте галочкой опцию Установить данные настройки по умолчанию для всех пользователей и нажмите Сохранить.

Теперь новое поле будет доступно для заполнения при добавлении новых пользователей и в формах настройки текущих:

Название нового поля выведено в виде гиперссылки, нажав на которую вы перейдете в форму редактирования данного поля.

Документация по теме:

  • Создание и редактирование пользовательского поля


Запретить показ пункта меню
658 / 694

На примере главного меню портала рассмотрим, как можно запретить показ какого-либо его пункта.

Запретим вывод пункта меню Общение для группы сотрудников Техподдержка.

В режиме правки наведите курсор на главное меню портала и кликните по всплывающей кнопке Редактировать пункты меню:

Откроется окно редактирования меню:

Пройдите по ссылке Редактировать меню в Панели управления, откроется форма параметров меню. Найдите в ней параметры пункта Общение:

В опции Тип условия выберите Для групп пользователей, после чего изменится вид опции Условие:

Выберите группу Техподдержка и отныне сотрудники, входящие в нее, не будут видеть пункт главного меню портала Общение.

Сохраните внесенные изменения


Модерация блогов
659 / 694

Отделяем зерна от плевел..

На сайте, имеющим блоги, одна из распространенных задач контент-менеджера - модерирование этих самых блогов. Модерация - контроль соблюдения пользователями правил сайта. Модератор следит, чтобы дискуссия соответствовала заданной теме (если таковая имеется), а также установленным правилам и этическим принципам. При необходимости модератор может применить к участникам административные меры - от предупреждения пользователя до удаления каких-то сообщений или даже запрета доступа для некоторых пользователей.

Различают постмодерацию (или еще еще называют просто модерацией) и премодерацию. Наиболее распространена постмодерация, при которой сообщения от участников публикуются постепенно по мере поступления, а модератор лишь иногда просматривает блог и удаляет лишнее.

Премодерация используется реже, поскольку требует постоянной работы модератора - каждое поступившее сообщение сначала должно быть подтвеждено (разрешено) модератором, и только после этого публикуется.

Если в блоге включена премодерация, то при написании сообщения/комментария пользователю будет демонстрироваться сообщение об этом:

Видео-пример работы модератора блога

Просмотр видео в наших курсах в формате CHM невозможен. Ролик можно просмотреть на сайте компании «1С-Битрикс».

Как работает модератор

Находясь в своем блоге, Вы можете работать с его сообщениями с помощью ссылок Скрыть\Опубликовать, Редактировать, Удалить. В меню блога, рядом с пунктом Модерация, в скобочках указано число сообщений, требующих премодерации:

Ссылка Скрыть делает сообщение недоступным для просмотра посетителями блога и переносит его в раздел Модерация для дальнейшей обработки. Перейдите в данный раздел, чтобы отредактировать\опубликовать или удалить сообщение:

Модерация комментариев осуществляется в режиме детального просмотра сообщения:

Комментарии можно скрывать от показа, публиковать и удалять. Скрытые комментарии затемнены.

Примечание: у модератора могут быть два уровня прав:
  • стандартный (скрывать/публиковать сообщения, редактировать комментарии);
  • расширенный (помимо стандартных прав можно редактировать/удалять сообщения).
Для задания стандартных прав нужно в Настройке блога установить уровень доступа "Модерирование", для задания расширенных прав - уровень доступа "Администрирование".


Система "Вопрос-ответ" на базе веб-форм
660 / 694

В данной главе рассматривается пример создания системы Вопрос-ответ на базе модуля Веб-формы.

Учебные материалы по работе модуля Веб-формы представлены в главе Веб-формы, а также в документации по продукту.

В нашем примере система Вопрос-ответ будет устроена следующим образом:

  • На главной ее странице будет представлен список вопросов с ответами на них. Причем для администраторов сайта и модераторов системы (будет создана специальная группа пользователей) будут отображаться и вопросы без ответов.

    Для быстрого поиска необходимых вопросов и ответов можно будет использовать специальную форму фильтра.

    В зависимости от прав пользователя, просматривающего список вопросов, будут доступны следующие действия с вопросами: ответить на вопрос и удалить вопрос. Администраторы сайта могут отвечать на вопросы, изменять ответы и удалять вопросы. Модераторы могут отвечать на вопросы только один раз.

  • Для создания нового вопроса будет использоваться специальная форма, расположенная на отдельной странице.
  • Составление ответа на вопрос также будет выполняться на отдельной странице с помощью специальной формы.

Примечание: работа с веб-формами должна осуществляться в расширенном режиме.


Настройка веб-формы
661 / 694

Создадим саму веб-форму, её шаблон, вопросы, поля, настроим статусы.


Что должно быть в веб-форме
662 / 694

Что должно быть в веб-форме

Пусть в нашей системе Вопрос-ответ при создании вопроса посетитель сайта укажет следующие данные, которые будут являться вопросами формы :

  • фамилию, имя, отчество;
  • электронный адрес;
  • номер телефона;
  • текст вопроса.

Кроме того, при создании вопроса пользователь должен будет заполнить поле защиты от роботов (CAPTCHA). Возможность использования CAPTCHA определяется настройками самой формы.

Чтобы модератор системы мог ответить на вопрос, нам следует создать также поле формы для хранения ответа.

Требование законодательства РФ

И последнее требование - это требование законодательства РФ: ФЗ-152 о персональных данных. Страница с Веб-формой должна обязательно содержать чекбокс подтверждения посетителем своего согласия на обработку персональных данных, если такие данные запрашиваются. А мы запрашиваем: e-mail и телефон.

На данный момент, к сожалению, штатно этот функционал в компонентах модуля Веб-формы не реализован. Добавить чекбокс подтверждения согласия можно, но потребуется привлечение разработчиков.


Создание веб-формы, вопросов и полей
663 / 694

Создание веб-формы

Для создания формы перейдите в административный раздел на страницу Сервисы > Веб-Формы > Настройка форм и нажмите кнопку Создать. На закладке Свойства заполните все необходимые поля . Подпись кнопки, сохраняющей результаты формы, замените на Отправить и отметьте опцию Использовать CAPTCHA:

На закладке Доступ для групп Все пользователи и Модераторы системы "Вопрос-ответ" укажите право доступа работа со всеми результатами в соответствии с их статусами:

Сохраните веб-форму. К настройке шаблона веб-формы и почтового шаблона вернемся после того, как создадим вопросы, поле и статусы.

Создание вопросов

Последовательно создайте все вопросы, указанные в Техзадании:

Символьный идентификатор | Обязателен | Текст вопроса | Ответ, тип поля | Поля в фильтре
name | да | Фамилия, имя, отчество | пустое значение, тип text | отмечаем текстовое поле в поле для вводимого значения
text | да | Вопрос | пустое значение, тип textarea | отмечаем текстовое поле в поле для вводимого значения
email | да | Адрес электронной почты | пустое значение, тип email | не указываем
phone | нет | Номер телефона | пустое значение, тип text | не указываем

Рекомендуется выставить сортировку вопросам, чтобы они отображались в верной последовательности, например, в фильтре. В результате на странице со списком вопросов веб-формы у нас будет представлена следующая таблица:

Создание поля

Теперь создайте поле, в котором будет хранить ответ на вопрос.

На закладке Свойства задайте параметры:

  • символьный идентификатор - our_answer;
  • типа поля - текст;
  • заголовок - Ответ.

Чтобы создаваемое поле не просто отображалось в фильтре поиска, а обязательно после полей Фамилия, имя, отчество и Вопрос:

  • задайте значение сортировки больше, чем у вопроса Фамилия, имя, отчество и больше, чем у вопроса Вопрос. Например, равной 300 (см. настройки сортировки вопросов выше).
  • на закладке Фильтр отметьте текстовое поле в поле Поля в фильтре .

Сохраните созданное поле.


Настройка статусов
664 / 694

Создаём статусы для вебформы

Нам понадобятся два статуса для результатов заполнения веб-формы:

  1. Статус Вопрос - устанавливается по умолчанию сразу после заполнения формы.

    Чтобы созданный вопрос был виден только его создателю и пользователям группы Модераторы системы "Вопрос-ответ", а также чтобы модераторы могли отвечать на вопрос в настройках доступа статуса Вопрос необходимо выставить права доступа :

    • Имеют право на перевод результатов в данный статус [MOVE] - здесь выбираем создатель результата.
    • Имеют право на просмотр результатов в данном статусе [VIEW] - выбираем создатель результата и Модераторы системы "Вопрос-ответ", чтобы остальные пользователи не видели неотвеченных вопросов в списке.
    • Имеют право на редактирование результатов в данном статусе [EDIT] - выбираем группу Модераторы системы "Вопрос-ответ", поскольку только пользователи этой группы смогут отвечать на вопросы.
    • Имеют право на удаление результатов в данном статусе [DELETE] - здесь ничего не выбираем, т.к. удалять неотвеченные вопросы модераторы не могут. Это право оставляем за администратором сайта.
  2. Статус Ответ - устанавливается вручную когда модератор дал ответ на вопрос.

    На закладке Свойства указываем заголовок статуса и переходим на закладку Доступ, чтобы настроить права доступа к результатам в этом статусе:

    • Имеют право на перевод результатов в данный статус [MOVE] - когда модератор отвечает на вопрос, то результат сразу переводится в данный статус, поэтому здесь выбираем группу Модераторы системы "Вопрос-ответ".
    • Имеют право на просмотр результатов в данном статусе [VIEW] - выбираем группу Все пользователи, поскольку все пользователи могут просматривать систему Вопрос-ответ.
    • Имеют право на редактирование результатов в данном статусе [EDIT] - ничего не выбираем, т.к. никто, кроме администраторов сайта, не может изменять уже отвеченные вопросы.
    • Имеют право на удаление результатов в данном статусе [DELETE] - ничего не выбираем, т.к. никто, кроме администраторов сайта, не может удалять вопросы из системы.


Создание шаблона формы
665 / 694

Как будет выглядеть ваша форма

Внешний вид формы добавления нового вопроса в систему Вопрос-ответ зависит от того, как вы настроите шаблон веб-формы. Пусть шаблон выглядит, например, так:

На закладке Шаблон формы в визуальном редакторе добавьте элемент Название формы, а под ним задайте таблицу из 2-х столбцов и 5-и строк. В строках разместите элементы: Название вопроса (первый столбец) и сам вопрос (второй столбец). В последней строке разместите элементы для вывода CAPTCHA:

Всё, шаблон готов.

Для любопытных: HTML-код формы выглядит так

 <?=$FORM->ShowFormErrors()?>
<table width="323" height="257" class="data-table">
  <tbody>
    <tr><td valign="middle" align="right"><?=$FORM->ShowInputCaption("name","")?></td><td><?=$FORM->ShowInput('name')?></td></tr>
    <tr><td valign="middle" align="right"><?=$FORM->ShowInputCaption("email","")?></td><td><?=$FORM->ShowInput('email')?></td></tr>
    <tr><td valign="middle" align="right"><?=$FORM->ShowInputCaption("phone","")?></td><td><?=$FORM->ShowInput('phone')?></td></tr>
    <tr><td valign="top" align="right"><?=$FORM->ShowInputCaption("text","")?></td> <td><?=$FORM->ShowInput('text')?></td></tr>
    <tr><td><?=$FORM->ShowCaptchaImage()?></td><td> Введите символы с картинки <?=$FORM->ShowRequired()?>
        <br />
       <?=$FORM->ShowCaptchaField()?></td></tr>
    <tr><td colspan="2"><?=$FORM->ShowSubmitButton("","")?></td></tr>
   </tbody>
 </table>


Почтовый шаблон
666 / 694

Шаблон для e-mail сообщений

После заполнения веб-формы отправляется письмо с уведомлением модераторам и администратору сайта.

В форме редактирования веб-формы Вопрос-ответ переходим на закладку Дополнительно и нажимаем ссылку создать . В результате сразу создается почтовый шаблон и почтовое событие Заполнена web-форма "Question_answer" для нашей веб-формы.

По ссылке с идентификатором шаблона переходим к его редактированию:

  • В поле Кому указываем email модератора.
  • В поле Копия указываем email администратора сайта, чтобы он мог контролировать работу модератора.
  • Отредактируем текст сообщения, оставив только данные о посетителе и сам вопрос, а также добавим ссылку для перехода к форме ответа на вопрос:

Примечание: все параметры, которые могут быть использованы при создании почтового шаблона, указаны внизу формы под полем Сообщение.


Вопросы и ответы
667 / 694

Создадим место на сайте для Вопросов и ответов.


Раздел на сайте для Вопросов и ответов
668 / 694

Создаём место на сайте для Вопросов и ответов

Создайте отдельный раздел Вопрос - ответ (имя папки - /question_answer) для публичных страниц системы, например, на верхнем уровне и разместите его в нижнем меню последним пунктом:

Создайте в папке Вопрос - ответ страницы:

  • Вопрос - ответ (название файла index.php) - главная страница раздела со списком вопросов и ответами на них.
  • Задать вопрос (название файла ask_question.php) - страница создания нового вопроса, то есть страница для заполнения веб-формы.
  • Ваш вопрос принят (название файла mess_send.php) - страница с сообщением об успешном создании нового вопроса. На эту страницу пользователь будет перенаправляться после заполнения формы на странице Задать вопрос.
  • Дать ответ (название файла answer.php) - страница составления ответа на вопрос, то есть страница с формой редактирования результата заполнения веб-формы.

Осталось разместить на этих страницах компоненты и настроить их на работу.


Список вопросов и ответов
669 / 694

Настраиваем вывод данных

Интерфейс главной страницы раздела со списком вопросов создается с помощью компонента Список результатов. Но разместить и настроить компонент - этого мало, вам предстоит ещё настроить вывод данных, то есть изменить шаблон компонента.

Размещение компонента

Откройте страницу Вопрос - ответ на редактирование и в теле страницы разместите компонент Список результатов:

Настройте параметры компонента:

  • В поле ID веб-формы укажите форму Вопрос-ответ.
  • Поле Страница просмотра результата оставьте пустым, оно использоваться не будет.
  • В поле Страница редактирования результата вводите название страницы составления ответа - answer.php.
  • В поле Страница добавления результата указывате название страницы заполнения формы - ask_question.php.
  • Опцию Показать дополнительные поля веб-формы отметьте, чтобы на странице отображались ответы на вопросы.
  • Опцию Показать текущий статус результата снимите, т.к. эта информация использоваться не будет.

Результат:

Штатный внешний вид врядли подойдёт под дизайн вашего сайта. Отредактируйте шаблон компонента, чтобы изменить внешний вид выводимой информации.

Редактирование шаблона компонента

Скопируйте шаблон компонента Список результатов (bitrix:form.result.list). Откроется форма копирования шаблона компонента. Укажите название нового шаблона и шаблон сайта, в который копировать шаблон компонента. Отметьте опции Применить новый шаблон компонента и Перейти к редактированию шаблона, чтобы сразу новый шаблон использовался в компоненте и открылась форма редактирования шаблона.

После сохранения откроется окно для редактирования шаблона компонента.

Сначала отредактируем ту часть, которая отвечает за вывод формы фильтра. В фильтре оставим только следующие поля:

  • дату создания вопроса (хранится в переменной FORM_F_DATE_CREATE);
  • вопросы формы Фамилия, имя, отчество и Вопрос, а также поле Ответ, которые хранятся в arrFORM_FILTER (при создании этих вопросов и поля были выполнены соответствующие настройки на закладке Фильтр ).

Заменяем код таблицы формы фильтра на следующий:

<table class="form-filter-table data-table">
    <thead>
        <tr>
            <th colspan="2"> </th>
        </tr>
    </thead>
    <tbody>
        <?
        if (strlen($arResult["str_error"]) > 0)
        {
        ?>
        <tr>
            <td class="errortext" colspan="2"><?=$arResult["str_error"]?></td>
        </tr>
        <?
        } // endif (strlen($str_error) > 0)
        ?>
        <tr>
            <td><?=GetMessage("FORM_F_DATE_CREATE")." (".CSite::GetDateFormat("SHORT")."):"?></td>
            <td><?=CForm::GetDateFilter("date_create", "form1", "Y", "", "")?></td>
        </tr>

        <?
        if (is_array($arResult["arrFORM_FILTER"]) && count($arResult["arrFORM_FILTER"])>0)
        {
            foreach ($arResult["arrFORM_FILTER"] as $arrFILTER)
            {
                $prev_fname = "";

                foreach ($arrFILTER as $arrF)
                {
                    if ($arParams["SHOW_ADDITIONAL"] == "Y" || $arrF["ADDITIONAL"] != "Y")
                    {
                        $i++;
                        if ($arrF["SID"]!=$prev_fname)
                        {
                            if ($i>1)
                            {
                            ?>
                            </td>
                            </tr>
                            <?
                            } //endif($i>1);
                            ?>
        <tr>
            <td>
                <?=$arrF["FILTER_TITLE"] ? $arrF['FILTER_TITLE'] : $arrF['TITLE']?>
                <?=($arrF["FILTER_TYPE"]=="date" ? " (".CSite::GetDateFormat("SHORT").")" : "")?>
            </td>
            <td>
            <?
                        } //endif ($fname!=$prev_fname) ;
                        ?>
                        <?
                        switch($arrF["FILTER_TYPE"]){
                            case "text":
                                echo CForm::GetTextFilter($arrF["FID"]);
                                break;
                            case "date":
                                echo CForm::GetDateFilter($arrF["FID"]);
                                break;
                            case "integer":
                                echo CForm::GetNumberFilter($arrF["FID"]);
                                break;
                            case "dropdown":
                                echo CForm::GetDropDownFilter($arrF["ID"], $arrF["PARAMETER_NAME"], $arrF["FID"]);
                                break;
                            case "exist":
                            ?>
                                <?=CForm::GetExistFlagFilter($arrF["FID"])?>
                                <?=GetMessage("FORM_F_EXISTS")?>
                            <?
                                break;
                        } // endswitch
                        ?>
                        <?
                        if ($arrF["PARAMETER_NAME"]=="ANSWER_TEXT")
                        {
                        ?>
                 [<span class='form-anstext'>...</span>]
                        <?
                        }
                        elseif ($arrF["PARAMETER_NAME"]=="ANSWER_VALUE")
                        {
                        ?>
                 (<span class='form-ansvalue'>...</span>)
                        <?
                        }
                        ?>
                <br />
                        <?
                        $prev_fname = $arrF["SID"];
                    } //endif (($arrF["ADDITIONAL"]=="Y" && $SHOW_ADDITIONAL=="Y") || $arrF["ADDITIONAL"]!="Y");

                } // endwhile (list($key, $arrF) = each($arrFILTER));

            } // endwhile (list($key, $arrFILTER) = each($arrFORM_FILTER));
        } // endif(is_array($arrFORM_FILTER) && count($arrFORM_FILTER)>0);
        ?></td>
        </tr>
    </tbody>
    <tfoot>
        <tr>
            <th colspan="2">
                <input type="submit" name="set_filter" value="<?=GetMessage("FORM_F_SET_FILTER")?>" /><input type="hidden" name="set_filter" value="Y" />  <input type="submit" name="del_filter" value="<?=GetMessage("FORM_F_DEL_FILTER")?>" />
            </th>
        </tr>
    </tfoot>
</table>

Отредактируем ссылку Заполнить форму >>. Для этого в строке:

<p>
<b><a href="<?=$arParams["NEW_URL"]?><?=$arParams["SEF_MODE"] != "Y" ? (strpos($arParams["NEW_URL"], "?") === false ? "?" : "&")."WEB_FORM_ID=".$arParams["WEB_FORM_ID"] : ""?>"><?=GetMessage("FORM_ADD")?>  >></a></b>
</p>

параметр FORM_ADD заменяем на FORM_NEW_QUESTION. После чего в языковом файле /bitrix/templates/.default/components/bitrix/form.result.list/qa_template/lang/ru/template.php добавляем следующее сообщение:

$MESS ['FORM_NEW_QUESTION'] = "Задать свой вопрос";

Функции OnSelectAll_ и OnDelete_ можно удалить, поскольку в коде для нашей формы списка вопросов и ответов они использоваться не будут.

Теперь можно приступать к редактированию формы списка вопросов и ответов.

Для списка вопросов добавим механизм постраничной навигации, чтобы страница не была очень большой. В связи с этим нам потребуется параметр постраничной навигации, определяющий количество вопросов на одной странице. Также нам еще необходимо знать идентификатор статуса Ответ. Мы не будем усложнять задачу и зададим эти параметры явно в шаблоне компонента:

$status = "4";   //в нашем пример идентификатор статуса Ответ равен 4;
$ques_count = "10";  //параметр постраничной навигации;

Примечание: вы можете определить настройку этих параметров через параметры компонента.

Форма вопросов и ответов будет представлять из себя таблицу, в которой будут отображаться:

  • вопрос;
  • ответ;
  • дата создания вопроса;
  • фамилия, имя, отчество пользователя, создавшего вопрос;
  • ссылки Ответить на вопрос и Удалить вопрос с учетом прав доступа пользователей к системе Вопрос-ответ.

Поэтому код формы делаем следующим:

<form name="rform_<?=$arResult["filter_id"]?>" method="post" action="<?=POST_FORM_ACTION_URI?>#nav_start">
    <input type="hidden" name="WEB_FORM_ID" value="<?=$arParams["WEB_FORM_ID"]?>" />
    <?=bitrix_sessid_post()?>

    <?
    if ($arResult["res_counter"] > 0 && $arParams["SHOW_STATUS"] == "Y" && $arParams["F_RIGHT"] >= 15)
    {
    ?>
    <p><input type="submit" name="save" value="<?=GetMessage("FORM_SAVE")?>" /><input type="hidden" name="save" value="Y" /> <input type="reset" value="<?=GetMessage("FORM_RESET")?>" /></p>
    <?
    } //endif(intval($res_counter)>0 && $SHOW_STATUS=="Y" && $F_RIGHT>=15);
    ?>
    <p>
    <?=$arResult["pager"]?>
    </p>

<?

if(count($arResult["arrResults"]) > 0)
{
    $arPerm = CFormStatus::GetPermissions($status);
    $rsContent = new CDBResult;
    $rsContent -> InitFromArray($arResult["arrResults"]);
    $rsContent -> NavStart($ques_count);
    $j=0;
    ?>
    <table class="data-table form-table">
    <?
    while ($arRes=$rsContent->Fetch())
    {
        $j++;
        $user_date = $arRes["DATE_CREATE"];
        $res_id=$arRes["ID"];
        $arAns = CFormResult::GetDataByID($res_id, array());
        if ($j>1)
            {
            ?>
                <tr><td colspan="3" class="form-results-delimiter"> </td></tr>
            <?
            }
            ?>
        <tr>
        <td><b><?=$arAns["text"][0]["TITLE"]?></b></td><td><?=$arAns["text"][0]["USER_TEXT"]?></td>
        <td rowspan="2"><b><?=substr($user_date,0,10)."";?></b><br/><b><?=$arAns["name"][0]["USER_TEXT"]?></b>
            <br/>
            <?
            if ($arRes["STATUS_ID"]!=$status && in_array("MOVE", $arPerm) || $USER->IsAdmin())
                {
                $href = $arParams["SEF_MODE"] == "Y" ? str_replace("#RESULT_ID#", $arRes["ID"], $arParams["EDIT_URL"]) : $arParams["EDIT_URL"].(strpos($arParams["EDIT_URL"], "?") === false ? "?" : "&")."RESULT_ID=".$arRes["ID"]."&WEB_FORM_ID=".$arParams["WEB_FORM_ID"];
                ?>
                [ <a title="<?=GetMessage("FORM_EDIT_ALT")?>" href="<?=$href?>"><?=GetMessage("FORM_EDIT")?></a> ]
                <?
                }
                ?>
            <br/>
            <?
            if ($USER->IsAdmin())
                {
                $href = $arParams["LIST_URL"].(strpos($arParams["LIST_URL"], "?") === false ? "?" : "&").($arParams["SEF_MODE"] == "Y" ? "" : "WEB_FORM_ID=".$arParams["WEB_FORM_ID"]."&")."del_id=".$arRes["ID"]."&".bitrix_sessid_get()."#nav_start";
                ?>[ <a title="<?=GetMessage("FORM_DELETE_ALT")?>" href="javascript:if(confirm('<?=GetMessage("FORM_CONFIRM_DELETE")?>')) window.location='<?=$href?>'"><?=GetMessage("FORM_DELETE")?></a> ]
                <?
                }
                ?>
        </td>
        </tr>
        <tr>
            <?
        if ($arRes["STATUS_ID"]!=$status)
            {
            ?>
        <td colspan="2"><i><?=GetMessage("FORM_NEW_ANSWER")?></i></td>
        <?
            }
        else
            {
        ?>
        <td><b><?=$arAns["our_answer"][0]["TITLE"]?></b></td>
        <td><?=$arAns["our_answer"][0]["USER_TEXT"]?></td>
        <?
            }
        ?>
        </tr>
    <?
    }
    ?>
    </table>
<br />
    <?
echo $rsContent->NavPrint('Вопросы');
}
?>
</form>

Важно! Встречающиеся в коде name, text и our_answer - это символьные идентификаторы вопроса Фамилия, имя, отчество, вопроса Вопрос и поля Ответ.

Для используемого параметра FORM_NEW_ANSWER необходимо в языковом файле /bitrix/templates/.default/components/bitrix/form.result.list/qa_template/lang/ru/template.php добавить следующее сообщение:

$MESS ['FORM_NEW_ANSWER'] = "Вопрос ожидает ответа";

А для параметров FORM_EDIT, FORM_EDIT_ALT, FORM_DELETE_ALT и FORM_DELETE отредактировать их языковые сообщения:

$MESS ['FORM_EDIT_ALT'] = "Дать ответ на вопрос";
$MESS ['FORM_EDIT'] = "Ответить на вопрос";
$MESS ['FORM_DELETE_ALT'] = "Удалить вопрос";
$MESS ['FORM_DELETE'] = "Удалить вопрос";

В результате после сохранения шаблона и добавления нескольких вопросов главная страница системы Вопрос-ответ будет представлена в следующем виде для обычных пользователей:

Причем для авторизованных создателей вопросов будут отображаться и те вопросы, которые еще ожидают ответа.

Пользователям группы Модератор системы "Вопрос-ответ" дополнительно в списке будут отображаться все неотвеченные вопросы со ссылкой Ответить на вопрос.

Администратору сайта всегда доступны все вопросы. По ссылке Ответить на вопрос он может дать ответ на новый вопрос или изменить уже существующий ответ, а по ссылке Удалить вопрос - удалить любой вопрос.


Добавление вопроса
670 / 694

Настраиваем страницу добавления вопроса

Выполните следующие действия:

  • Откройте страницу Задать вопрос (ask_question.php) на редактирование в визуальном редакторе.
  • При желании добавьте некоторый поясняющий текст, например, Заполните поля формы.
  • Разместите на странице компонент Заполнение веб-формы.
  • В настройках параметров компонента укажите следующие данные:
    • ID веб-формы - выбрать из списка веб-форму Вопрос-ответ;
    • Включить поддержку ЧПУ и в параметре Каталог ЧПУ указать каталог системы /question_answer/;
    • В параметре Страница с сообщением об успешной отправке задать адрес к странице Ваш вопрос принят (mess_send.php);

      адреса остальных страниц задавать не нужно.

В результате выполненных действий страница создания вопроса будет иметь следующий вид:


Сообщение об успешном создании
671 / 694

Уведомим посетителя о том, что вопрос принят

Страница Ваш вопрос принят (mess_send.php) уведомляет посетителя о том, что вопрос создан. Откройте ее на редактирование в режиме html-кода и добавьте:

<p><font color="#005824">Спасибо, ваш вопрос принят.</font></p>
<p>Наши специалисты постараются ответить на него максимально оперативно.</p>
<br />
<table>
  <tbody>
    <tr><td> <a href="/question_answer/ask_question.php" ><b>Задать новый вопрос</b></a> </td><td></td><td>
             <a href="/question_answer/index.php" ><b>Вернуться к списку вопросов</b></a> </td></tr>
   </tbody>
 </table>

После сохранения изменений страница будет иметь следующий вид:

Ссылки Задать новый вопрос и Вернуться к списку вопросов ведут на страницы ask_question.php и index.php соответственно.


Ответ на вопрос
672 / 694

Настраиваем страницу ответа

Интерфейс страницы Дать ответ (answer.php) создается с помощью компонента Редактирование результата. Однако стандартный компонент для наших целей не подходит, поскольку нам необходимо вносить изменения только в поле Ответ. Поэтому нам необходимо скопировать полностью компонент в собственное пространство имен , чтобы отредактировать и код компонента, и шаблон компонента под наши нужды.

Копирование и размещение компонента

Выполним копирование компонента Редактирование результата в пространство demo, т.е. папка компонента /form.result.edit будет располагаться в папке /bitrix/components/demo.

Теперь откроем на редактирование страницу answer.php в визуальном редакторе и разместим скопированный компонент Редактирование результата (demo: form.result.edit ):

Настраиваем компонент следующим образом:

  • В поле ID результата оставляем код ={$_REQUEST[RESULT_ID]}, предложенный по умолчанию.
  • В поле Выводить на редактирование дополнительные поля обязательно указываем Да.
  • В обоих параметрах Страница со списком результатов и Страница просмотра результата указываем index.php, чтобы со страницы составления ответа осуществлялся переход только на главную страницу системы Вопрос-ответ.
  • Параметры Игнорировать свой шаблон и Выводить форму смены статуса можно не настраивать, поскольку они не будут использоваться в компоненте и мы их потом удалим за ненадобностью.

Сохраняем компонент и переходим к редактированию файла компонента /bitrix/components/demo/form.result.edit/.parameters.php.

Редактирование параметров компонента

В форме добавления ответа на вопрос не будет поля для смены статуса. При нажатии на кнопку Отправить, расположенной на форме, статус меняется автоматически на Ответ. Поэтому в параметры компонента необходимо добавить возможность указания этого статуса (чтобы компонент "знал", с каким статусом работать). В связи с этим в файле .parameters.php перед строкой:

$arComponentParameters = array(...

добавляем код формирования списка веб-форм сайта и списка статусов веб-формы, зависящего от выбранной впоследствии в параметрах компонента веб-формы:

$arrForms = array();
$rsForm = CForm::GetList($by='s_sort', $order='asc', array("SITE" => $_REQUEST["site"]), $v3);
while ($arForm = $rsForm->Fetch())
{
    $arrForms[$arForm["ID"]] = "[".$arForm["ID"]."] ".$arForm["NAME"];
}

$arrStatuses = array();
$rsStat = CFormStatus::GetList($arCurrentValues["WEB_FORM_ID"], $by='s_sort', $order='asc');
while ($arStatus = $rsStat->Fetch())
{
    $arrStatuses[$arStatus["ID"]] = "[".$arStatus["ID"]."] ".$arStatus["TITLE"];
}

В массив PARAMETERS добавляем код для отображения параметров веб-формы и статуса:

        "WEB_FORM_ID" => array(
            "NAME" => GetMessage("COMP_FORM_PARAMS_WEB_FORM_ID"),
            "TYPE" => "LIST",
            "VALUES" => $arrForms,
            "DEFAULT" => "={\$_REQUEST[WEB_FORM_ID]}",
            "PARENT" => "DATA_SOURCE",
            "REFRESH" => "Y",
        ),
        "STATUS_ID" => array(
            "NAME" => GetMessage("COMP_FORM_PARAMS_STATUS_ID"),
            "TYPE" => "LIST",
            "VALUES" => $arrStatuses,
            "DEFAULT" => '',
            "PARENT" => "DATA_SOURCE",
        ),

Для новых параметров COMP_FORM_PARAMS_WEB_FORM_ID и COMP_FORM_PARAMS_STATUS_ID задаем языковые сообщения в файле /bitrix/components/demo/form.result.edit/lang/ru/.parameters.php:

$MESS ['COMP_FORM_PARAMS_WEB_FORM_ID'] = "ID веб-формы системы \"Вопрос-ответ\"(используется только для проверки)";
$MESS ['COMP_FORM_PARAMS_STATUS_ID'] = "ID статуса, когда дан ответ на вопрос";

Теперь параметры компонента полностью готовы под наши нужды. Форма настройки параметров компонента приобретает следующий вид:

В настройках компонента указываем нашу веб-форму Вопрос-ответ и статус Ответ.

Переходим к изменению логики компонента, т.е к редактированию файла /bitrix/components/demo/form.result.edit/component.php.

Изменение логики компонента

Необходимо сформировать массив данных компонента так, чтобы только в поле ответа можно было вносить данные, а сами вопросы формы не были доступны для редактирования. Публикация вопроса (т.е. смена его статуса на Ответ) должна происходить сразу же по нажатии кнопки Отправить. Поэтому изменяем код компонента:

Код компонента

<?if(!defined("B_PROLOG_INCLUDED") || B_PROLOG_INCLUDED!==true)die();?><?

if (CModule::IncludeModule("form"))
{
    $GLOBALS['strError'] = '';

    $arDefaultComponentParameters = array(
        "RESULT_ID" => $_REQUEST["RESULT_ID"],
        "EDIT_ADDITIONAL" => "N",
        "WEB_FORM_ID" => $_REQUEST["WEB_FORM_ID"],
        "STATUS_ID" => $_REQUEST["STATUS_ID"],
        "USE_EXTENDED_ERRORS" => "N",
    );

    $arParams['NAME_TEMPLATE'] = empty($arParams['NAME_TEMPLATE'])
        ? (method_exists('CSite', 'GetNameFormat') ? CSite::GetNameFormat() : "#NAME# #LAST_NAME#")
        : $arParams["NAME_TEMPLATE"];

    foreach ($arDefaultComponentParameters as $key => $value) if (!is_set($arParams, $key)) $arParams[$key] = $value;

    $arDefaultUrl = array(
        'LIST' => $arParams["SEF_MODE"] == "Y" ? "list/" : "result_list.php",
        'VIEW' => $arParams["SEF_MODE"] == "Y" ? "view/#RESULT_ID#/" : "result_view.php",
    );

    foreach ($arDefaultUrl as $action => $url)
    {
        if (strlen($arParams[$action.'_URL']) <= 0)
        {
            if (!is_set($arParams, 'SHOW_'.$action.'_PAGE') || $arParams['SHOW_'.$action.'_PAGE'] == 'Y')
                $arParams[$action.'_URL'] = $url;
        }
    }

    if ($arParams["SEF_MODE"] == "Y" && empty($arParams["RESULT_ID"]))
    {
        $arDefaultUrlTemplates404 = array(
            "edit" => "#RESULT_ID#/",
        );

        $arDefaultVariableAliases404 = array(
        );

        $arDefaultVariableAliases = array();

        $arComponentVariables = array("RESULT_ID");

        $arUrlTemplates = CComponentEngine::MakeComponentUrlTemplates($arDefaultUrlTemplates404, $arParams["SEF_URL_TEMPLATES"]);
        $arVariableAliases = CComponentEngine::MakeComponentVariableAliases($arDefaultVariableAliases404, $arParams["VARIABLE_ALIASES"]);
        CComponentEngine::ParseComponentPath($arParams["SEF_FOLDER"], $arUrlTemplates, $arVariables);

        $arParams["RESULT_ID"] = intval($arVariables["RESULT_ID"]);
    }

    $arResult["FORM_SIMPLE"] = COption::GetOptionString("form", "SIMPLE", "N") == "N" ? "N" : "Y";
    $arResult["bAdmin"] = defined("ADMIN_SECTION") && ADMIN_SECTION===true ? "Y" : "N";

    // if form taken from admin interface - check rights to form module
    if ($arResult["bAdmin"] == "Y")
    {
        $FORM_RIGHT = $APPLICATION->GetGroupRight("form");
        if($FORM_RIGHT<="D") $APPLICATION->AuthForm(GetMessage("ACCESS_DENIED"));
    }

    /****************************************************************************/

    // if there's result ID try to get form ID
    if (intval($arParams["RESULT_ID"] > 0))
    {
        $DBRes = CFormResult::GetByID($arParams["RESULT_ID"]);

        if ($arResultData = $DBRes->Fetch())
        {
            $arParams["WEB_FORM_ID"] = intval($arResultData["FORM_ID"]);
        }
    }

    if (intval($arParams["RESULT_ID"]) <= 0 || intval($arParams["WEB_FORM_ID"]) <= 0)
    {
        $arResult["ERROR"] = "FORM_RECORD_NOT_FOUND";
    }

    if (strlen($arResult["ERROR"]) <= 0)
    {
        // check WEB_FORM_ID and get web form data
        $arParams["WEB_FORM_ID"] = CForm::GetDataByID($arParams["WEB_FORM_ID"], $arResult["arForm"],
                                                                $arResult["arQuestions"], $arResult["arAnswers"], $arResult["arDropDown"], $arResult["arMultiSelect"],
                                                                $arResult["bAdmin"] || $arParams["SHOW_ADDITIONAL"] == "Y" || $arParams["EDIT_ADDITIONAL"] == "Y" ? "ALL" : "N");
    $arResult["WEB_FORM_NAME"] = $arResult["arForm"]["SID"];

        // if wrong WEB_FORM_ID return error;
        if ($arParams["WEB_FORM_ID"] > 0)
        {
            //  insert chain item
            if (strlen($arParams["CHAIN_ITEM_TEXT"]) > 0)
            {
                $APPLICATION->AddChainItem($arParams["CHAIN_ITEM_TEXT"], $arParams["CHAIN_ITEM_LINK"]);
            }

            // check web form rights;
            $arResult["F_RIGHT"] = intval(CForm::GetPermission($arParams["WEB_FORM_ID"]));

            // in no form access - return error
            if ($arResult["F_RIGHT"] >= 15)
            {
                //if (!empty($_REQUEST["strFormNote"])) $arResult["FORM_NOTE"] = $_REQUEST["strFormNote"];
                if (!empty($_REQUEST["formresult"]))
                {
                    $formResult = strtoupper($_REQUEST['formresult']);
                    switch ($formResult)
                    {
                        case 'ADDOK':
                            $arResult['FORM_NOTE'] = str_replace("#RESULT_ID#", $arParams["RESULT_ID"], GetMessage('FORM_NOTE_ADDOK'));
                        break;
                        default:
                            $arResult['FORM_NOTE'] = str_replace("#RESULT_ID#", $arParams["RESULT_ID"], GetMessage('FORM_NOTE_EDITOK'));
                    }
                }

                if ($arResult["F_RIGHT"]>=20 || ($arResult["F_RIGHT"]>=15 && $USER->GetID()==$arResultData["USER_ID"]))
                {
                    $arResult["arrRESULT_PERMISSION"] = CFormResult::GetPermissions($arParams["RESULT_ID"], $v);

                    // check result rights
                    if (!in_array("EDIT", $arResult["arrRESULT_PERMISSION"]))
                    {
                        $arResult["ERROR"] = "FORM_RESULT_ACCESS_DENIED";
                    }
                    else
                    {
                        if (!$arResultData)
                        {
                            $z = CFormResult::GetByID($arParams["RESULT_ID"]);
                            $arResult["arResultData"] = $z->Fetch();
                        }
                        else
                        {
                            $arResult["arResultData"] = $arResultData;
                        }

                        if ($arResult["arResultData"])
                        {
                            $arResult["arrVALUES"] = CFormResult::GetDataByIDForHTML($arParams["RESULT_ID"], $arParams["EDIT_ADDITIONAL"]);
                        }
                        else
                        {
                            $arResult["ERROR"] = "FORM_RECORD_NOT_FOUND";
                        }
                    }
                }
                else
                {
                    $arResult["ERROR"] = "FORM_ACCESS_DENIED";
                }

                $arResult["arForm"]["USE_CAPTCHA"] = "N";
            }
            else
            {
                $arResult["ERROR"] = "FORM_RESULT_ACCESS_DENIED";
            }
        }
        else
        {
            $arResult["ERROR"] = "FORM_NOT_FOUND";
        }
    }

    // if there's no error
    if (strlen($arResult["ERROR"]) <= 0)
    {
        // ************************************************************* //
        //                                             get/post processing                                             //
        // ************************************************************* //

        if (strlen($_REQUEST["web_form_submit"])>0 || strlen($_REQUEST["web_form_apply"])>0)
        {
                reset($arResult["arQuestions"]);
                foreach ($arResult["arQuestions"] as $key => $arQuestion)
                {
                    $FIELD_SID = $arQuestion["SID"];
                    if (is_array($arResult["arQuestions"][$FIELD_SID]) && $arResult["arQuestions"][$FIELD_SID]["ADDITIONAL"] == "Y")
                    {
                        $temp="form_";
                        switch ($arResult["arQuestions"][$FIELD_SID]["FIELD_TYPE"])
                        {
                        case "text":
                            $temp.="textarea_ADDITIONAL_";
                            break;
                        case "integer":
                            $temp.="text_ADDITIONAL_";
                            break;
                        case "date":
                            $temp.="date_ADDITIONAL_";
                            break;
                        }
                        $temp.=$arResult["arQuestions"][$FIELD_SID]["ID"];
                        $arResult["arrVALUES"][$temp]= $_REQUEST[$temp];
                    }
                }
            // check errors
                $arResult["FORM_ERRORS"] = CForm::Check($arParams["WEB_FORM_ID"], $arResult["arrVALUES"], $arParams["RESULT_ID"], "Y", $arParams['USE_EXTENDED_ERRORS']);

            if (
                $arParams['USE_EXTENDED_ERRORS'] == 'Y' && (!is_array($arResult["FORM_ERRORS"]) || count($arResult["FORM_ERRORS"]) <= 0)
                ||
                $arParams['USE_EXTENDED_ERRORS'] != 'Y' && strlen($arResult["FORM_ERRORS"]) <= 0
            )
            {//echo "<pre>error "; print_r("enter"); echo "</pre>";
                // check session id
                if (check_bitrix_sessid())
                {
                    $return = false;

                    if (CFormResult::Update($arParams["RESULT_ID"], $arResult["arrVALUES"], $arParams["EDIT_ADDITIONAL"]))
                    {
                        CFormResult::SetStatus($arParams["RESULT_ID"],$arParams["STATUS_ID"],"Y");
                        $arResult["FORM_RESULT"] = 'editok';

                        if (strlen($_REQUEST["web_form_submit"])>0 && !(defined("ADMIN_SECTION") && ADMIN_SECTION===true))
                        {
                            if ($arParams["SEF_MODE"] == "Y")
                            {
                                //LocalRedirect($arParams["LIST_URL"]."?strFormNote=".urlencode($arResult["FORM_NOTE"]));
                                LocalRedirect(
                                    str_replace(
                                        array('#WEB_FORM_ID#', '#RESULT_ID#'),
                                        array($arParams['WEB_FORM_ID'], $arParams["RESULT_ID"]),
                                        $arParams["LIST_URL"]
                                    )."?formresult=".urlencode($arResult["FORM_RESULT"])
                                );
                            }
                            else
                            {
                                //LocalRedirect($arParams["LIST_URL"].(strpos($arParams["LIST_URL"], "?") === false ? "?" : "&")."WEB_FORM_ID=".$arParams["WEB_FORM_ID"]."&strFormNote=".urlencode($arResult["FORM_NOTE"]));
                                LocalRedirect(
                                    $arParams["LIST_URL"]
                                    .(strpos($arParams["LIST_URL"], "?") === false ? "?" : "&")
                                    ."WEB_FORM_ID=".$arParams["WEB_FORM_ID"]
                                    ."&RESULT_ID=".$arParams["RESULT_ID"]
                                    ."&formresult=".urlencode($arResult["FORM_RESULT"])
                                );
                            }

                            die();
                        }

                        if (strlen($_REQUEST["web_form_apply"])>0 && !(defined("ADMIN_SECTION") && ADMIN_SECTION===true))
                        {
                            if ($arParams["SEF_MODE"] == "Y")
                            {
                                LocalRedirect(
                                    $APPLICATION->GetCurPageParam(
                                        "formresult=".urlencode($arResult["FORM_RESULT"]),
                                        array('formresult', 'SEF_APPLICATION_CUR_PAGE_URL')
                                    )
                                );
                            }
                            else
                            {
                                LocalRedirect(
                                    $APPLICATION->GetCurPageParam(
                                        "WEB_FORM_ID=".$arParams["WEB_FORM_ID"]
                                        ."&RESULT_ID=".$arParams["RESULT_ID"]
                                        ."&formresult=".urlencode($arResult["FORM_RESULT"]),
                                        array('WEB_FORM_ID', 'RESULT_ID', 'formresult')
                                    )
                                );
                            }
                            die();
                        }

                        if (defined("ADMIN_SECTION") && ADMIN_SECTION === true)
                        {
                            if (strlen($_REQUEST["web_form_submit"])>0)
                            {
                                LocalRedirect(BX_ROOT."/admin/form_result_list.php?lang=".LANG."&WEB_FORM_ID=".$arParams["WEB_FORM_ID"]."&formresult=".urlencode($arResult["FORM_RESULT"]));
                            }
                            elseif (strlen($_REQUEST["web_form_apply"])>0)
                            {
                                LocalRedirect(BX_ROOT."/admin/form_result_edit.php?lang=".LANG."&WEB_FORM_ID=".$arParams["WEB_FORM_ID"]."&RESULT_ID=".$arParams["RESULT_ID"]."&form_result=".urlencode($arResult["FORM_RESULT"]));
                            }
                            die();
                        }
                    }
                    else
                        $arResult['FORM_ERRORS'] = $GLOBALS['strError'];
                }
            }
        }

        /*
if (is_array($arResult["FORM_ERRORS"]))*/

        $arResult["isFormErrors"] =
            (
                is_array($arResult["FORM_ERRORS"]) && count($arResult["FORM_ERRORS"]) > 0
                ||
                !is_array($arResult['FORM_ERRORS']) && strlen($arResult["FORM_ERRORS"]) > 0
            )
            ? "Y" : "N";

        //echo "<pre>ar "; print_r($arResult); echo "</pre>";
        if ($arResult['isFormErrors'] == 'Y')
        {
            unset($arResult['FORM_RESULT']);
            unset($arResult['FORM_NOTE']);
        }

        // ************************************************************* //
        //                                             output                                                                    //
        // ************************************************************* //
        // include CSS with additional icons for Site Edit mode
        if ($APPLICATION->GetShowIncludeAreas() && $USER->IsAdmin())
        {
            // define additional icons for Site Edit mode
            $arIcons = array(
                array(
                    'URL' => "javascript:".$APPLICATION->GetPopupLink(
                        array(
                            'URL' => "/bitrix/admin/form_edit.php?bxpublic=Y&from_module=form&lang=".LANGUAGE_ID."&ID=".$arParams['WEB_FORM_ID']."&back_url=".urlencode($_SERVER["REQUEST_URI"]),
                            'PARAMS' => array(
                                'width' => 700,
                                'height' => 500,
                                'resize' => false,
                            )
                        )
                    ),
                    'ICON' => 'bx-context-toolbar-edit-icon',
                    'TITLE' => GetMessage("FORM_PUBLIC_ICON_EDIT"),
                ),
            );

            $this->AddIncludeAreaIcons($arIcons);
        }

        if (intval($arResult["arResultData"]["USER_ID"])>0)
        {
            $rsUser = CUser::GetByID($arResult["arResultData"]["USER_ID"]);
            $arUser = $rsUser->Fetch();

            $arResult["RESULT_USER_ID"] = $arResult["arResultData"]["USER_ID"];
            $arResult["RESULT_USER_LOGIN"] = $arUser["LOGIN"];
            $arResult["RESULT_USER_EMAIL"] = $arUser["USER_EMAIL"];
            $arResult["RESULT_USER_FIRST_NAME"] = $arUser["NAME"];
            $arResult["RESULT_USER_LAST_NAME"] = $arUser["LAST_NAME"];
            $arResult["RESULT_USER_SECOND_NAME"] = $arUser["SECOND_NAME"];
        }

        // define variables to assign
        $arResult = array_merge(
            $arResult,
            array(
                "RESULT_ID" => $arParams["RESULT_ID"],
                "WEB_FORM_ID" => $arParams["WEB_FORM_ID"],
                "RESULT_USER_AUTH" => $arResult["arResultData"]["USER_AUTH"] == "Y" ? "Y" : "N",
                "RESULT_DATE_CREATE" => $arResult["arResultData"]["DATE_CREATE"],
                "RESULT_TIMESTAMP_X" => $arResult["arResultData"]["TIMESTAMP_X"],
                "RESULT_STAT_GUEST_ID" => $arResult["arResultData"]["STAT_GUEST_ID"],
                "RESULT_STAT_SESSION_ID" => $arResult["arResultData"]["STAT_SESSION_ID"],
                "isFormNote"			=> strlen($arResult["FORM_NOTE"]) ? "Y" : "N", // flag "is there a form note"
                "isAccessFormParams"	=> $arResult["F_RIGHT"] >= 25 ? "Y" : "N", // flag "does current user have access to form params"
                "isStatisticIncluded"	=> CModule::IncludeModule('statistic') ? "Y" : "N", // flag "is statistic module included"

                "FORM_HEADER" => sprintf( // form header (<form> tag and hidden inputs)
                    "<form name=\"%s\" action=\"%s\" method=\"%s\" enctype=\"multipart/form-data\">",
                    $arResult["arForm"]["SID"], POST_FORM_ACTION_URI, "POST"
                ),

                "FORM_TITLE"			=> trim(htmlspecialcharsbx($arResult["arForm"]["NAME"])), // form title

                "FORM_DESCRIPTION" => // form description
                    $arResult["arForm"]["DESCRIPTION_TYPE"] == "html" ?
                    trim($arResult["arForm"]["DESCRIPTION"]) :
                    nl2br(htmlspecialcharsbx(trim($arResult["arForm"]["DESCRIPTION"]))),

                "isFormTitle"			=> strlen($arResult["arForm"]["NAME"]) > 0 ? "Y" : "N", // flag "does form have title"
                "isFormDescription"		=> strlen($arResult["arForm"]["DESCRIPTION"]) > 0 ? "Y" : "N", // flag "does form have description"
                "isFormImage"			=> intval($arResult["arForm"]["IMAGE_ID"]) > 0 ? "Y" : "N", // flag "does form have image"
                "isUseCaptcha"			=> $arResult["arForm"]["USE_CAPTCHA"] == "Y", // flag "does form use captcha"
                "DATE_FORMAT"			=> CLang::GetDateFormat("SHORT"), // current site date format
                "REQUIRED_SIGN"			=> CForm::ShowRequired("Y"), // "required" sign
                "FORM_FOOTER"			=> "</form>", // form footer (close <form> tag)
            )
        );

        // get template vars for form image
        if ($arResult["isFormImage"] == "Y")
        {
            $arResult["FORM_IMAGE"]["ID"] = $arResult["arForm"]["IMAGE_ID"];
            // assign form image url
            $arImage = CFile::GetFileArray($arResult["arForm"]["IMAGE_ID"]);
            $arResult["FORM_IMAGE"]["URL"] = $arImage["SRC"];

            // check image file existance and assign image data
            if (substr($arImage["SRC"], 0, 1) == "/")
            {
                $arSize = CFile::GetImageSize($_SERVER["DOCUMENT_ROOT"].$arImage["SRC"]);
                if (is_array($arSize))
                {
                    list(
                        $arResult["FORM_IMAGE"]["WIDTH"],
                        $arResult["FORM_IMAGE"]["HEIGHT"],
                        $arResult["FORM_IMAGE"]["TYPE"],
                        $arResult["FORM_IMAGE"]["ATTR"]
                    ) = $arSize;
                }
            }
            else
            {
                $arResult["FORM_IMAGE"]["WIDTH"] = $arImage["WIDTH"];
                $arResult["FORM_IMAGE"]["HEIGHT"] = $arImage["HEIGHT"];
                $arResult["FORM_IMAGE"]["TYPE"] = false;
                $arResult["FORM_IMAGE"]["ATTR"] = false;
            }

            $arResult["FORM_IMAGE"]["HTML_CODE"] = CFile::ShowImage($arResult["arForm"]["IMAGE_ID"]);
        }

        $arResult["QUESTIONS"] = array();
        reset($arResult["arQuestions"]);

        // assign questions data
        foreach ($arResult["arQuestions"] as $key => $arQuestion)
        {
            $FIELD_SID = $arQuestion["SID"];
            $arResult["QUESTIONS"][$FIELD_SID] = array(
                "CAPTION" => // field caption
                    $arResult["arQuestions"][$FIELD_SID]["TITLE_TYPE"] == "html" ?
                    $arResult["arQuestions"][$FIELD_SID]["TITLE"] :
                    nl2br(htmlspecialcharsbx($arResult["arQuestions"][$FIELD_SID]["TITLE"])),

                "IS_HTML_CAPTION"			=> $arResult["arQuestions"][$FIELD_SID]["TITLE_TYPE"] == "html" ? "Y" : "N",
                "REQUIRED"					=> $arResult["arQuestions"][$FIELD_SID]["REQUIRED"] == "Y" ? "Y" : "N",
                "IS_INPUT_CAPTION_IMAGE"	=> intval($arResult["arQuestions"][$FIELD_SID]["IMAGE_ID"]) > 0 ? "Y" : "N",
            );

            // ******************************** customize answers ***************************** //

            $arResult["QUESTIONS"][$FIELD_SID]["HTML_CODE"] = array();
            if (is_array($arResult["arQuestions"][$FIELD_SID]) && $arResult["arQuestions"][$FIELD_SID]["ADDITIONAL"] == "Y")
            {
                $res = "";
                switch ($arResult["arQuestions"][$FIELD_SID]["FIELD_TYPE"])
                {
                    case "text":
                        $value = CForm::GetTextAreaValue("ADDITIONAL_".$arResult["arQuestions"][$FIELD_SID]["ID"], array(), $arResult["arrVALUES"]);
                        $res .= CForm::GetTextAreaField(
                            "ADDITIONAL_".$arResult["arQuestions"][$FIELD_SID]["ID"],
                            "60",
                            "5",
                            "",
                            $value
                            );

                        $arResult["QUESTIONS"][$FIELD_SID]["HTML_CODE"][] = $res;

                        break;
                    case "integer":
                        $value = CForm::GetTextValue("ADDITIONAL_".$arResult["arQuestions"][$FIELD_SID]["ID"], array(), $arResult["arrVALUES"]);
                        $res .= CForm::GetTextField(
                            "ADDITIONAL_".$arResult["arQuestions"][$FIELD_SID]["ID"],
                            $value);

                        $arResult["QUESTIONS"][$FIELD_SID]["HTML_CODE"][] = $res;

                        break;
                    case "date":
                        $value = CForm::GetDateValue("ADDITIONAL_".$arResult["arQuestions"][$FIELD_SID]["ID"], array(), $arResult["arrVALUES"]);
                        $res .= CForm::GetDateField(
                            "ADDITIONAL_".$arResult["arQuestions"][$FIELD_SID]["ID"],
                            $arResult["arForm"]["SID"],
                            $value);

                        $arResult["QUESTIONS"][$FIELD_SID]["HTML_CODE"][] = $res." (".CSite::GetDateFormat("SHORT").")";

                        break;
                } //endswitch;
            }

            $arResult["QUESTIONS"][$FIELD_SID]["HTML_CODE"] = implode("<br />", $arResult["QUESTIONS"][$FIELD_SID]["HTML_CODE"]);

            // ******************************************************************************* //

            if ($arResult["QUESTIONS"][$FIELD_SID]["IS_INPUT_CAPTION_IMAGE"] == "Y")
            {
                $arResult["QUESTIONS"][$FIELD_SID]["IMAGE"]["ID"] = $arResult["arQuestions"][$FIELD_SID]["IMAGE_ID"];
                // assign field image path
                $arImage = CFile::GetFileArray($arResult["QUESTIONS"][$FIELD_SID]["IMAGE"]["ID"]);
                $arResult["QUESTIONS"][$FIELD_SID]["IMAGE"]["URL"] = $arImage["SRC"];

                // check image file existance and assign image data
                if (substr($arImage["SRC"], 0, 1) == "/")
                {
                    $arSize = CFile::GetImageSize($_SERVER["DOCUMENT_ROOT"].$arImage["SRC"]);
                    if (is_array($arSize))
                    {
                        list(
                            $arResult["QUESTIONS"][$FIELD_SID]["IMAGE"]["WIDTH"],
                            $arResult["QUESTIONS"][$FIELD_SID]["IMAGE"]["HEIGHT"],
                            $arResult["QUESTIONS"][$FIELD_SID]["IMAGE"]["TYPE"],
                            $arResult["QUESTIONS"][$FIELD_SID]["IMAGE"]["ATTR"]
                        ) = $arSize;
                    }
                }
                else
                {
                    $arResult["QUESTIONS"][$FIELD_SID]["IMAGE"]["WIDTH"] = $arImage["WIDTH"];
                    $arResult["QUESTIONS"][$FIELD_SID]["IMAGE"]["HEIGHT"] = $arImage["HEIGHT"];
                    $arResult["QUESTIONS"][$FIELD_SID]["IMAGE"]["TYPE"] = false;
                    $arResult["QUESTIONS"][$FIELD_SID]["IMAGE"]["ATTR"] = false;
                }

                $arResult["QUESTIONS"][$FIELD_SID]["IMAGE"]["HTML_CODE"] = CFile::ShowImage($arResult["arQuestions"][$FIELD_SID]["IMAGE_ID"]);
            }

            // get answers raw structure
            $arResult["QUESTIONS"][$FIELD_SID]["STRUCTURE"] = $arResult["arAnswers"][$FIELD_SID];
            // nullify value
            $arResult["QUESTIONS"][$FIELD_SID]["VALUE"] = "";
        }

        if ($arResult["isFormErrors"] == "Y")
        {
            ob_start();
            if ($arParams['USE_EXTENDED_ERRORS'] == 'N' || !is_array($arResult['FORM_ERRORS']))
                ShowError($arResult["FORM_ERRORS"]);
            else
                ShowError(implode('<br />', $arResult["FORM_ERRORS"]));

            $arResult["FORM_ERRORS_TEXT"] = ob_get_contents();
            ob_end_clean();
        }

        $arResult["SUBMIT_BUTTON"] = "<input ".(intval($arResult["F_RIGHT"]) < 10 ?
                           "disabled=\"disabled\"" : "")." type=\"submit\" name=\"web_form_submit\" value=\"".(strlen(trim($arResult["arForm"]["BUTTON"])) <= 0 ?
                           GetMessage("FORM_ADD") : $arResult["arForm"]["BUTTON"])."\" />";
        $arResult["RESET_BUTTON"] = "<input type=\"reset\" value=\"".GetMessage("FORM_RESET")."\" />";
        $arResult["REQUIRED_STAR"] = $arResult["REQUIRED_SIGN"];

        // include default template
        $this->IncludeComponentTemplate();
    }
    else
    {
        echo ShowError(GetMessage($arResult["ERROR"]));
    }
}
else
{
    echo ShowError(GetMessage("FORM_MODULE_NOT_INSTALLED"));
}
?>

Теперь необходимо изменить шаблон компонента под нашу логику.

Редактирование шаблона компонента

В форме ответа на вопрос помимо поля ввода ответа должны отображаться следующие данные: фамилия, имя, отчество пользователя, создавшего вопрос, текст вопроса, дата создания и дата ответа на вопрос. В связи с этим код шаблона компонента будет следующим:

Код шаблона компонента

<?
if(!defined("B_PROLOG_INCLUDED") || B_PROLOG_INCLUDED!==true)die();
?>

<?
if ($arParams["VIEW_URL"])
{
    $href = $arParams["SEF_MODE"] == "Y" ? str_replace("#RESULT_ID#", $arParams["RESULT_ID"], $arParams["VIEW_URL"]) :
                $arParams["VIEW_URL"].(strpos($arParams["VIEW_URL"], "?") === false ?
                "?" : "&")."RESULT_ID=".$arParams["RESULT_ID"]."&WEB_FORM_ID=".$arParams["WEB_FORM_ID"];
?>
<p>[ <a href="<?=$href?>"><?=GetMessage("FORM_VIEW")?></a> ]</p>
<?
}
?>

<?=$arResult["FORM_HEADER"]?>
<?=bitrix_sessid_post()?>

<br />
<?

/***********************************************************************************
                    Form questions
***********************************************************************************/
        ?>
<?if ($arResult["FORM_NOTE"]):?><?=$arResult["FORM_NOTE"]?><?endif?>
<?if ($arResult["isFormErrors"] == "Y"):?><?=$arResult["FORM_ERRORS_TEXT"];?><?endif;?>
<table class="form-table data-table">
    <thead>
        <tr>
            <th colspan="2"> </th>
        </tr>
    </thead>
    <tbody>
<tr>
            <td><b><?=GetMessage("FORM_DATE_CREATE")?></b></td>
            <td><?=FormatDateFromDB($arResult["RESULT_DATE_CREATE"])?></td>
        </tr>
        <tr>
            <td><b><?=GetMessage("FORM_TIMESTAMP")?></b></td>
            <td><?=FormatDateFromDB($arResult["RESULT_TIMESTAMP_X"])?></td>
        </tr>
        <tr>
            <td><b><?=$arResult["arQuestions"]["name"]["TITLE"]?></b></td>
            <td><?=$arResult["arrVALUES"]["form_text_29"]?></td>
        </tr>
        <tr>
            <td><b><?=$arResult["arQuestions"]["text"]["TITLE"]?></b></td>
            <td><?=$arResult["arrVALUES"]["form_textarea_30"]?></td>
        </tr>
    <?
    foreach ($arResult["QUESTIONS"] as $FIELD_SID => $arQuestion)
    {
    if ($FIELD_SID == "our_answer")
    {
    ?>
    <tr>
        <td>
            <?if (is_array($arResult["FORM_ERRORS"]) && array_key_exists($FIELD_SID, $arResult['FORM_ERRORS'])):?>
            <span class="error-fld" title="<?=$arResult["FORM_ERRORS"][$FIELD_SID]?>"></span>
            <?endif;?>
            <b><?=$arQuestion["CAPTION"]?></b>
            </td>
        <td><?=$arQuestion["HTML_CODE"]?></td>
    </tr>
    <?
    }
} //endwhile

    ?>
    </tbody>
    <tfoot>
    <tr>
        <th colspan="2">
            <input type="submit" name="web_form_submit" value="<?=htmlspecialcharsbx(strlen(trim($arResult["arForm"]["BUTTON"])) <= 0 ? GetMessage("FORM_ADD") : $arResult["arForm"]["BUTTON"]);?>" />
             <input type="reset" value="<?=GetMessage("FORM_RESET");?>" />
        </th>
    </tr>
    </tfoot>
</table>

<?=$arResult["FORM_FOOTER"]?>

Чтобы отобразить введенные пользователем значения вопросов Фамилия, имя, отчество и Вопрос, необходимо знать названия их html-полей . Например, если вопрос имеет ответ типа text, то поле формы будет иметь имя form_text_id, где id - это идентификатор значения ответа, который можно посмотреть в форме настройки вопроса:

Таким образом, поля формы Фамилия, имя, отчество и Вопрос имеют имена form_text_29 и form_textarea_30 соответственно, которые и используются в коде шаблона компонента.

Примечание: если в параметры компонента добавить настройку выбора отображаемых полей формы, то в коде не придется указывать имена полей явно (см. пример выше по добавлению параметров идентификаторов веб-формы и статуса).

В файле языковых сообщений шаблона компонента вносим изменения:

$MESS ['FORM_VIEW'] = "Вернуться к списку вопросов";
$MESS ['FORM_DATE_CREATE'] = "Дата создания вопроса";
$MESS ['FORM_TIMESTAMP'] = "Дата ответа на вопрос";

В результате проделанных операций, когда модератор системы или администратор сайта со страницы со списком вопросов переходят по ссылке Ответить, открывается страница ответа на вопрос:


Об интеграции с 1С
673 / 694

Внимание! Для успешного выполнения обмена между 1С и Битрикс24, должен быть указан активный лицензионный ключ Битрикс24. На демо ключе выполнить обмен через модуль "1С: Синхронизация Битрикс24" не получится, так как этот ключ имеет ограничения и запросы REST не будут проходить. При попытке выполнить обмен с демо-ключом выводится сообщение "aplication not found".


Интеграция с помощью модуля экспорта печатных форм и отчетов в Битрикс24
674 / 694

В данной главе рассмотрены вопросы по интеграции коробочной версии сервиса Битрикс24 и 1С:ЗУП, ред. 3.0.

Используется модуль экспорта печатных форм и отчетов в Битрикс24 .

Примечание: дополнительно вы можете ознакомиться с записью вебинара по интеграции с 1С:ЗУП.


Установка модуля обмена
675 / 694

В данном уроке рассмотрим порядок установки модуля обмена в 1С:Зарплата и управление персоналом, ред. 3.0:

  • Установите скаченный дистрибутив модуля обмена согласно прилагаемой к нему инструкции.
  • Запустите систему 1С:Предприятие в режиме Конфигуратор.
  • Сделайте архивную копию информационной базы. Для этого в меню Администрирование выберите пункт Выгрузить информационную базу:

    Затем в открывшемся диалоге укажите имя файла, в который будут записаны данные.
  • Откройте конфигурацию (Конфигурация > Открыть конфигурацию).
  • Включите возможность изменения объектов конфигурации (Конфигурация > Поддержка > Настройка поддержки, в открывшемся окне нажмите кнопку Включить возможность изменения).
  • В окне Настройка правил поддержки выберите дважды Объект поставщика редактируется с сохранением поддержки и нажмите кнопку ОК.
  • Сохраните конфигурацию.
  • Вызовите режим Сравнить, объединить с конфигурацией из файла из меню Конфигурация. В этом режиме будут показаны только различающиеся объекты дополнения и используемой конфигурации, поэтому полностью идентичные объекты могут отсутствовать в окне сравнения-объединения. Также может отсутствовать флажок включения таких объектов в объединение.
  • В диалоге выбора укажите файл конфигурации XXX.cf. По умолчанию он лежит по следующему адресу: C:\Users\...\AppData\Roaming\1C\1Cv82\tmplts\1С-Битрикс\ОбменССайтом\(конфигурация 1С).
  • Исключите из объединения все объекты конфигурации.
  • Нажмите кнопку Действия, затем Отметить по подсистемам файла. Отобразится окно, в котором будут все подсистемы модуля обмена:
    • если нужен функционал экспорта кадровой информации, то установите флаг ЭкспортКадровойИнформации;
    • если нужен функционал просмотра расчетных листков и остатков отпуска на КП, то установите флаг ВебСервисРасчетныхЛистков;
    • если нужен функционал отправки сообщений в живую ленту на КП, то установите флаг ВыгрузкаВЖЛ.

    Важно! Обязательно должна быть отмечена опция Включать объекты родительских подсистем .

  • Включите в объединение (установите флажок) подсистему Битрикс : Конфигурация > Общие > Подсистемы > Администрирование > Битрикс.
  • Выполните сравнение и объединение конфигураций (кнопка Выполнить).
  • Сохраните конфигурацию и обновите конфигурацию базы данных (Конфигурация > Обновить конфигурацию базы данных).
  • Запустите 1С с параметром ЗапуститьОбновлениеИнформационнойБазы для того, чтобы 1С заполнил все служебные данные в 1С. Запуск с параметром осуществите через командную строку или из конфигуратора.
    • чтобы запустить из командной строки, укажите следующие параметры:
      "<Адрес к 1cv8.exe>" ENTERPRISE (/F или /S в зависимости от типа базы) ""<Адрес к базе> " /N"<Логин>" /P"<Пароль>" /C ЗапуститьОбновлениеИнформационнойБазы
    • чтобы запустить из конфигуратора, откройте Сервис > Параметры. На вкладке Запуск 1С:Предприятия укажите параметр запуска .
    Из конфигуратора запустите 1С: Предприятие. Отладка > Начало отладки. После обновления информационной базы 1С нужно очистить этот параметр запуска, чтобы он каждый раз не запускался.


Работа с модулем обмена
676 / 694

При первом запуске происходит обновление данных базы 1С. Обновление версии запустится только, если запустить базу 1С с ключом ЗапуститьОбновлениеИнформационнойБазы или при обновлении базы 1С.


Общая панель модуля обмена
677 / 694

Если модуль обмена был корректно установлен, то в 1С появляется раздел 1С-Битрикс, в котором настраивается обмен с порталом и выгрузка данных.

Из группы Веб сервис расчетных листков можно перейти на объекты 1С, использующиеся для функционала расчетных листков:

  • При нажатии на Документы выдачи кода активации открывается форма, в которой можно посмотреть документы по выдаче кодов активации сотрудников на портале, а также выдать новый код активации сотруднику.
  • При нажатии на Документы формирования расчетных листков и остатков отпуска открывается форма, в которой можно посмотреть документы , хранящие сформированные расчетные листки и остатки отпуска, которые потом по запросу сотрудника высылаются на портал.
  • При нажатии на Журнал запросов Веб-Сервиса 1С-Битрикс открывается форма, в которой можно посмотреть историю запросов портала к 1С по получению расчетных листков и остатков отпуска.

Из группы Экспорт кадровой информации можно перейти в узел обмена , хранящий настройки обмена предназначенные для экспорта кадровой информации на портал. Чтобы зайти в список узлов настроек необходимо нажать на Обмен с корпоративным порталом.

Группа Сервис содержит элементы по переходу на формы служебных данных и настроек:

  • При нажатии на Версии модуля обмена открывается форма, в которой можно посмотреть текущую версию модуля обмена с порталом.
  • При нажатии на Настройки уведомлений корпоративного портала открывается форма , в которой указываются константы, требующиеся для отправки уведомлений на портал.
  • При нажатии на Тест запросов Веб-Сервиса 1С-Битрикс запускается обработка, позволяющая тестировать работу функционала расчетных листков.
  • При нажатии на Публикация в "Живую ленту" корпоративного портала запускается форма, позволяющая отправлять информацию в живую ленту портала.


Экспорт кадровой информации
678 / 694

Из «1С» на корпоративный портал можно выгрузить актуальную полную информацию по сотрудникам, кадровым перестановкам и структуре компании.


Узлы обмена
679 / 694

Экспорт кадровой информации осуществляется с помощью узлов обмена с корпоративным порталом. Список узлов доступен по следующему адресу: 1С-Битрикс > Экспорт кадровой информации > Обмен с корпоративным порталом.

В списке всегда есть предопределенный узел обмена, который нельзя использовать. Он с незаполненным наименованием.

При нажатии на кнопку Синхронизация данных отобразится всплывающее меню со следующими пунктами меню:

  • Выполнить обмен данными - будет выполнен обмен данными для выбранного в списке узла.
  • Показать зарегистрированные изменения - для выбранного в списке узла обмена откроется форма, в которой можно просмотреть все зарегистрированные изменения узла.
  • Информация о версии модуля обмена 1С-Битрикс - отобразится информация о номере версии используемого модуля обмена.
  • Открыть лог - откроется файл с логами обмена для выбранного узла за указанную дату.


Настройка экспорта кадровой информации
680 / 694

Форма создания/редактирования узла обмена имеет следующий вид:

Наименование и Код заполнятся автоматически при сохранении настройки. Но вы можете задать их вручную при необходимости.

На вкладке Основные настройки задаются базовые настройки параметров обмена:

Режим обмена данными (Контроль изменений)

  • Если выбрана Полная выгрузка, тогда выгружаться из 1С будут все данные, удовлетворяющие заданным отборам. Если данных в базе много, то обмен может выполняться продолжительное время.
  • При отмеченной опции Только изменения будут выгружаться только те данные, которые изменились. В этом случае скорость обмена существенно повышается.

Назначение
  • При выборе опции Выгружать на сайт данные будут выгружаться на портал, настройки подключения к которому задаются в соответствующих полях:
    • Адрес сайта – адрес вашего портала, содержащий путь до файла /bitrix/admin/1c_intranet.php.
    • Пользователь – логин пользователя портала (пользователь должен обладать правом на выполнение обмена данными).
    • Пароль – пароль пользователя.
    При нажатии на кнопку Проверить соединение, происходит проверка подключения к порталу.
  • Если отмечена опция Выгружать в каталог на диске, то данные будут выгружаться в каталог на диске.

В поле Каталог лога задается каталог, в котором будет храниться лог-файл обмена. Логи хранятся в разрезе дня в подчиненной папке reports.

Настройка автообмена

Если отмечена опция Использовать периодический обмен данными то обмен будет выполняться по заданному расписанию. В зависимости от того, база 1С в файловом или клиент-серверном варианте, настройка автообмена отличается.

При установке флажка автоматически откроется форма настройки расписания обмена, в которой задается время начала и завершения обмена, дата начала и дата завершения, периодичность.

На вкладке Дополнительно устанавливаются отборы выгружаемой кадровой информации:

В поле Организация указывается, из какой организации экспортируются данные. Поле должно быть заполнено.

В списке Должности руководителей подразделений указывается, какие должности являются начальниками выгружаемых отделов. Данные необходимы для идентификации руководителей подразделений.

В таблице значений Отборы выгружаемых данных указываются отборы экспортируемой информации.

Выполнение экспорта кадровой информации

Автоматическая выгрузка кадровой информации осуществляется в соответствии с настройками автообмена. Для ручного запуска процесса выгрузки необходимо:

  • в форме создания/редактирования настройки обмена нажать кнопку Выполнить обмен данными;
  • либо в форме списка узлов обмена выбрать нужный узел и нажать пункт Выполнить обмен данными в меню кнопки Синхронизация данных.


Выдача расчетных листков по зарплате и остатков отпусков
681 / 694
Сформированные в 1С: ЗУП расчетные листки и остатки отпусков можно выгрузить в Живую ленту Битрикс24.


Настройки веб-сервиса 1С
682 / 694

Для функционала требуется web-сервис 1С.

URL web-сервиса указывается при публикации из 1С. Подробно публикация web-сервисов описана в документации к 1С. Кратко о необходимых действиях (нужен доступ в Конфигуратор и административные права):

  • Откройте пункт меню Администрирование > Публикация на веб-сервере:

  • Установите флажки на тех веб-сервисах, которые нужны. Web-сервис, который используется для расчетных листков называется Б_ВебСервисКП.
  • Нажмите кнопку Опубликовать.
    В показанном выше примере нужный нам далее URL такого вида: http://(адрес к серверу)/zupws/ws/zupws.
  • Помимо этого нужно настроить права пользователя, который будет отвечать за работу нашего web-сервиса для работы с корпоративным порталом. Нужно создать или отредактировать пользователя, добавив ему роль Роль для корпоративного портала.


Настройки в корпоративном портале
683 / 694

Для настройки сервиса Зарплата и отпуск необходимо настроить компонент Расчетные листки сотрудников ( bitrix:payroll.1c ), размещенный на странице портала Сервисы > Зарплата и отпуск.

Детальное описание полей дано в пользовательской документации по Битрикс24 в коробке. Минимально достаточная настройка заключается в следующем:

  • В поле Список организации создайте новую организацию, если их несколько. Если организация одна, то можно просто переименовать имеющуюся по умолчанию. Обязательно нажмите на кнопку ОК. Форма перезагрузится.
  • В группе полей Настройки для организации *** заполните поля:
    • URL веб-сервиса - адрес сервиса, полученный от администратора программы 1С:ЗУП (см. урок Настройки веб-сервиса 1С). Можно настроить таким образом, чтобы разные организации подключались к разным базам 1С;
    • Порт - порт сервиса, полученный от администратора программы 1С:ЗУП;
    • Логин и Пароль пользователя 1С, от имени которого будет производиться доступ к программе 1С:ЗУП.
  • Сохраните внесенные изменения.


Выдача кодов активации сотрудникам
684 / 694

Выдача кода активации сотрудникам производится в документе Выдача кода активации. Активируется код в корпоративном портале, в результате чего сотрудник получает ПИН-код, с помощью которого можно посмотреть сформированные расчетные листки и остатки отпуска. Активировать код можно всего лишь один раз. Для повторной активации кода необходимо снова создавать новый документ выдачи кодов активации.

Форма со списком документов выдачи кодов активации доступна по следующему адресу: 1С-Битрикс > Веб сервис расчетных листков > Документы выдачи кода активации:

При нажатии на кнопку Задать длину кодов появляется форма, где задается длина кодов для кода активации и ПИН-кода.

Если документ уже был создан и проведен, то его нельзя изменить, пока не нажата кнопка Разрешить редактирование.

В табличной части Физические лица указываются сотрудники, которые должны получить код активации. Сотрудников можно добавить в таблицу как вручную, так и с помощью подбора, форма которого открывается при нажатии на кнопку Подбор.

Код активации генерируется автоматически при добавлении сотрудника. Но и можно его сгенерировать автоматически как для выделенного сотрудника, так и для всех в табличной части сразу.

При нажатии на кнопку Печать будет сформирован табличный документ с распиской в получении кода активации:


Формирование расчетных листков и остатков отпуска сотрудникам
685 / 694

Формирование расчетных листков и остатков отпуска сотрудников производится в документе Формирование расчетных листков и остатков отпуска. Для физического лица всего 1 раз в месяц может быть сформирован расчетный листок и остаток отпуска.

Форма со списком документов формирования расчетных листков и остатка отпусков доступна по следующему адресу: 1С-Битрикс > Веб сервис расчетных листков > Документы формирования расчетных листков и остатков отпуска:

Если документ уже был создан и проведен, то его нельзя изменить, пока не нажата кнопка Разрешить редактирование.

При нажатии на кнопку Отправить уведомление будет отправлено сообщение в живую ленту портала о том, что расчетные листки и остатки отпуска сформированы.

В табличной части Физические лица указываются физические лица, для которых нужно сформировать расчетные листки или остатки отпуска. Физические лица можно добавить в таблицу как вручную, так и с помощью подбора, форма которого открывается при нажатии на кнопку Подбор.

В колонке Список организаций указывается для каких организаций нужно сформировать данные.

При нажатии на кнопку Сформировать высвечивается всплывающее меню с командами, при нажатии которых формируются расчетные листки и остатки отпуска, как для выбранного сотрудника, так и для всех сразу.

Если в колонке Расчетные листки или Остатки отпуска появилась ссылка Просмотр, тогда при нажатии на эту ссылку можно посмотреть сформированный расчетный листок или остаток отпуска.


Журнал запросов Веб-Сервиса 1С-Битрикс
686 / 694

Журнал запросов Веб-Сервиса 1С-Битрикс необходим для просмотра и анализа запросов из корпоративного портала в 1С.


Выгрузка данных в Живую ленту
687 / 694
Модуль обмена дает возможность всего в несколько кликов опубликовать любой отчет или печатную форму документа из 1С в ваш Битрикс24 или настроить регулярные публикации, которые будут публиковать отчеты автоматически, в заданные дни и время.


Настройки в корпоративном портале
688 / 694

Настройки для выгрузки данных в живую ленту расположены в административной части портала в разделе Сервисы (Сервисы > Внешние источники данных > Публикация в Живую ленту). Всего с порталом может работать неограниченное количество внешних источников.

Для выгрузки данных из 1С в живую ленту используется режим POST.

Примечание: подробное описание настроек для режима POST представлено в уроке Публикация в Живую ленту.


Настройки со стороны 1С
689 / 694

Чтобы настроить работу с живой лентой портала, следует выполнить настройки в форме использования уведомлений (1С-Битрикс > Сервис > Настройки уведомлений корпоративного портала):

  • При отмеченной опции Использовать уведомления КП можно будет отправлять сообщение в живую ленту из документа формирования расчетных листков и отпусков, о том, что расчетные листки сформированы и их можно посмотреть на КП.
  • В поле Адрес сайта КП задается адрес, на который отсылается сообщение. Как правило он следующего формата: http://адрес_сайта/bitrix/tools/xdi_livefeed.php.
  • Поле Hash хранит хеш авторизации, чтобы портал разрешил импорт данных.
  • Поле Заголовок события КП для веб сервиса 1С-Битрикс хранит название заголовка сообщения, которое отправляется в живую ленту портала, когда из 1С отправляется уведомление о том, что расчетные листки и отпуска сформированы.


Отправка сообщений в живую ленту
690 / 694

Форма для отправки сообщений в живую ленту корпоративного портала доступна по следующему адресу: 1С-Битрикс > Сервис > Публикация в "Живую ленту" корпоративного портала.

На закладке Отправка сообщения указываются:

  • в поле Заголовок сообщения - заголовок сообщения, которое отобразится в живой ленте на портале;
  • в поле Текст сообщение - само сообщение.

На закладке Настройки устанавливаются настройки для отправки сообщений в живую ленту:

По умолчанию настройки берутся из констант, которые устанавливаются в форме Настройки уведомлений корпоративного портала , но при необходимости их можно отредактировать в самой форме отправки сообщений.


Обмен с помощью модуля 1С: Синхронизация Битрикс24
691 / 694

В данной главе рассмотрены вопросы по интеграции коробочной версии сервиса Битрикс24 и 1С:УНФ, ред. 1.6 (Управление нашей фирмой).

Модуль обмена нельзя установить в базовую конфигурацию 1С. Модуль работает с помощью дополнений, а в базовых конфигурациях 1С установка дополнений невозможна.


Чем можно обмениваться?
692 / 694

Какие же данные из Битрикс24 и 1С:УНФ синхронизируются?

Обмен между Битрикс24 и 1С двусторонний. В процессе обмена синхронизируются:

  • Компании, Контакты.
    Из 1С выгружаются Контрагенты, на стороне Битрикс24 создаются Компании и/или Контакты. Выгружаются Контактные лица Контрагентов (Контакты, привязанные к Компаниям).
    В обратном направлении работает аналогично - выгружаются из Битрикс24 Контакты, Компании, Контакты, привязанные к Компаниям, а создаются на стороне 1С Контрагенты и Контактные лица контрагентов.
  • Реквизиты.
  • Адреса.
  • Счета или сделки
  • Заказы и документы заказов (оплаты и отгрузки).
  • Товары и свойства товаров.
  • Единицы измерения.
  • Товары и группы товаров.
  • Документы (печатные формы) - только из 1С в Битрикс24.

Модуль 1С: Синхронизация Битрикс24 может работать:

  • В ручном режиме - обмен данными запускается вручную на стороне 1С.
  • По расписанию - обмен происходит с выбранной вами периодичностью. Например, один раз в день.
  • В режиме реального времени - любые изменения на стороне 1С или Битрикс24 запускают процесс синхронизации.


Помощник ручного слияния данных
693 / 694

Самый частый, но и самый сложный вариант синхронизации - когда имеется множество записей о Контрагентах в 1С и о Компаниях/Контактах в Битрикс24.

Порядок синхронизации по умолчанию такой: сначала из Битрикс24 загружаются данные в 1С, потом из 1С выгружаются в Битрикс24.

И допустим, выполняется такой кейс - установлена синхронизация по внешнему коду, в Битрикс24 XML-идентификаторы не заполнены. Получится, что сначала в 1С будут загружены Компании/Контакты, потом они же из 1С выгрузятся. Возникнет множество дублей. Как же правильно сопоставить данные? В этом случае поможет обработка слияния, то есть Помощник ручного слияния данных.

Нажмите на рисунок, чтобы увеличить

На странице этого пункта меню нужно будет ввести Ключ подключения и выбрать, что именно будем синхронизировать - Контакты и компании или Пользовательские поля (Компаний, Контактов, Счетов и Сделок):

Начнем с Контактов и компаний. Нажимаем кнопку, из Битрикс24 загружается вся информация по Контактам, Компаниям - реквизиты, банковские счета и др. На странице Слияние контактов и компаний можно посмотреть не слившиеся компании, либо все загруженные (если проставить галочку в окошке В том числе уже слившиеся). Слияние производится по настройкам в кнопке Поиск совпадений , по умолчанию - по Внешнему идентификатору. Информация выстраивается иерархически, к каждой Компании присоединяется ИНН, КПП, Контактное лицо, Номер счета и т.д.:

Нажмите на рисунок, чтобы увеличить

Для того, чтобы слить автоматически как можно больше объектов, можно менять настройки в кнопке Поиск совпадений, т.е. сопоставлять объекты по разным идентификаторам - Телефону, Номеру счета и т.д. При нажатии на кнопку Сохранить изменения сопоставленные сущности из списка исчезают.

В конце концов, на странице останутся только те Контакты и компании, которым не нашлось соответствия среди сущностей 1С. То есть те, у которых нет никаких заполненных реквизитов.

Таким Компаниям и контактам нужно будет сопоставить сущность 1С вручную. При изменении информации запись будет подсвечена зеленым цветом, после сохранения - желтым.

Когда соответствия будут проставлены, записи нужно сохранить и в дальнейшем эти сущности уже не будут синхронизирваться.

Таким образом все объекты 1С и Битрикс24 сопоставятся и мы избежим дублирования информации.

Пользовательские поля тоже можно сопоставить. Искать совпадения можно по двум параметрам - Наименованию и Внешнему идентификатору .


Создание нового интернет-магазина в Битрикс24
694 / 694

Создание нового интернет-магазина в Битрикс24

В этом уроке рассмотрим, как установить новый интернет-магазин в коробочной версии Битрикс24.

В ноябре 2019 г. (с версии Главного модуля v20.0) во все редакции «1С-Битрикс24: Корпоративный портал» были добавлены модули, необходимые для работы такого же Интернет-магазина, как в продукте «1С-Битрикс: Управление сайтом» редакции Бизнес. Таким образом, обладатели коробочных Битрикс24 (кроме «1С-Битрикс24: CRM») с активной лицензией могут установить последние обновления и создавать полноценные интернет-магазины совершенно бесплатно!

Начальные требования:

  • Активный лицензионный ключ - подойдет ключ любой редакции «1С-Битрикс24: Корпоративный портал» (кроме редакции CRM) или «1С-Битрикс24: Интернет-магазин+CRM»
  • Организованная на сайте многосайтовость на разных доменах

Подготовка:

Обязательно перед началом работ по переходу на новый продукт создайте резервную копию сайта, чтобы при появлении возможных ошибок иметь возможность восстановить сайт.

Примечание: убедитесь, что у Вас достаточно места на хостинге (для резервной копии и для загрузки обновлений).

Проведение работ:

  1. Первым делом необходимо установить обновления (главный модуль версии v20.0.0) (Рабочий стол > Marketplace > Обновление платформы). Загрузятся модули, необходимые для работы Интернет-магазина (модули продукта «1С-Битрикс: Управление сайтом»).
  2. После загрузки обновлений перейдите в раздел Сайты и добавьте Девелоперский сайт:

    Нажмите на рисунок, чтобы увеличить

  3. В открывшемся окне запустите Мастер установки девелоперского сайта (этот мастер добавит в корень нового сайта установочный файл Интернет-магазина), нажав кнопку Продолжить.
  4. Подтвердите наличие резервной копии сайта и продолжите установку.
  5. На следующем этапе Мастер укажет, какие модули еще необходимо установить. Перейдите по указанной ссылке.
  6. В каталоге Marketplace выберите и установите одно из готовых решений сайта (например, Интернет-магазин):

    Нажмите на рисунок, чтобы увеличить

  7. После установки модуля вернитесь в Мастер установки девелоперского сайта (Мастер пропустит уже выполненные шаги). Подтвердите, что на Вашем сайте настроена многосайтовость на разных доменах:

    Нажмите на рисунок, чтобы увеличить

  8. Далее укажите данные сайта, куда необходимо установить Интернет-магазин, и нажмите кнопку Продолжить:

  9. Дождитесь завершения работы Мастера, и нажмите кнопку Перейти на сайт. В автоматически запустившемся Мастере установки «1C-Битрикс: Управление сайтом» настройте нужные Вам параметры нового Интернет-магазина:

    Нажмите на рисунок, чтобы увеличить

В дальнейшем для перехода на сайт Интернет-магазина введите в адресной строке доменное имя этого сайта, или же воспользуйтесь кнопками перехода.

Важно! Если новый сайт интернет-магазина развёрнут на поддомене домена вашего портала Битрикс24, то проверьте и откорректируйте сортировку сайтов (Настройки > Настройки продукта > Сайты > Список сайтов):
  • индекс сортировки сайта на поддомене должен быть меньше, чем индекс сортировки сайта на домене (иначе сайты могут некорректно отображаться).
Для случаев, когда сайты находятся на разных доменах или разных поддоменах, сортировка может быть любой.


Администратор сервиса Битрикс24 (коробочная версия)
0 / 694

Для кого этот курс?

Курс предназначен для базовой подготовки пользователей, осуществляющих администрирование порталов, созданных на коробочной версии сервиса Битрикс24. Изучение курса позволяет освоить основные методы администрирования системы. Если вы хотите ознакомится с тем как внедрить наш сервис в работу вашей компании, то для вас создан курс Внедрение корпоративного портала.

Курс предусматривает обучение по двум ролям администраторов: Администратор корпоративного портала и Администратор системы.

Администратор корпоративного портала - пользователь, осуществляющий текущее администрирование уже настроенного и сданного в эксплуатацию портала.

Администратор системы - пользователь имеющий полный доступ к настройке системы.

Разные роли созданы в связи с тем, что для администрирования настроенного и отлаженного корпоративного портала нет необходимости в работе профессионала высокого уровня. Вполне достаточно пользователя успешно изучившего данный курс в рамках роли Администратор КП.

При условии качественного изучения материалов курса, по его окончании специалист должен уметь:

  • настраивать модули системы;
  • использовать возможности интерфейса по управлению системой;
  • управлять доступом к системе, сайтами, пользователями, группами пользователей;
  • управлять содержимым портала;
  • работать с инструментами системы;

Начальные требования

Для прохождения курса необходимо:

  • наличие базовых навыков компьютерной грамотности и навыков работы с ОС Windows;
  • наличие представлений о WWW и организации доступа к веб-серверу.

Если вам предстоит самостоятельная установка системы, то рекомендуется к изучению курс Установка и настройка.

Администратору системы будет полезно ознакомится с курсом Разработчик Bitrix Framework, рассказывающем о принципах работы Bitrix Framework.

Примечание. Битрикс24 создан на основе платформы Bitrix Framework на которой ранее был создан другой продукт "1С-Битрикс: Управление сайтом". В административной части системы сохранена терминология, относящаяся к этому продукту. Поэтому в текущем курсе понятие "сайт" нужно рассматривать как синоним слова "портал".

Тесты и сертификат

После изучения курса вам будет предложено пройти тесты на сертификацию. При успешной сдаче линейки тестов на странице Моё обучение можно просмотреть результат обучения и загрузить сертификат в формате PDF.

На каждой странице курса авторизованный на сайте посетитель может дать комментарий к содержимому страницы. Комментарий - не форум, там не ведётся обсуждений или разъяснений. Это инструмент для сообщений нам об ошибках, неточностях. Для отправки комментария воспользуйтесь расположенной в правом нижнем углу окна браузера кнопкой:

Для преподавания оффлайн

Если данный курс берётся в качестве основы для оффлайного преподавания, то рекомендуемая продолжительность: 10 дней (70 академических часов).

Если нет интернета

Если изучать курс приходится там, где нет интернета, то используйте файл формата CHM. Файлы формата CHM обновляются ежемесячно, тем не менее, возможно некоторое отставание их от онлайновой версии курса.

Скачать материалы курса в формате CHM .

Если не видно содержание файла CHM
Внимание! Если вы не видите содержимое файла формата .chm, то причина - настройки безопасности операционной системы: скачанные из интернета файлы находятся под наблюдением системы, которая ограничивает доступ к ним.

Чтобы отключить подобное отношение к файлу необходимо:

  • перейти в свойства файла на вкладку Общие. Внизу у Вас отобразится сообщение о том, что этот файл был заблокирован системой с целью защиты компьютера.

  • нажать кнопку Разблокировать.

Отсутствие кнопки Разблокировать возможно в двух случаях:

  1. Файл лежит не локально, а на сетевом ресурсе.
  2. Если файл лежит на локальном диске, но путь к нему содержит спецсимволы (# и прочие).