Настройки для печати чеков

Урок 121 из 149
Автор: Ольга Пичужкина
Сложность урока:
3 уровень - средняя сложность. Необходимо внимание и немного подумать.
3 из 5
Просмотров: 3802
Ограничения по редакциям: Старт, Стандарт, Энтерпрайз

Если вам необходимо печатать чеки для интернет-магазина, то необходимо внести несколько доработок в установленный Порядок установки модуля обмена:
- Установите скачанный установщик модуля обмена согласно прилагаемой к нему инструкции.
- Запустите систему 1С:Предприятие в режиме Конфигуратор
- Сделайте архивную копию информационной базы.
Подробнее...
модуль обмена 7.х.

Внимание! Функционал автоматической печати чеков работает пока только для российских конфигураций.

Нужно доработать объект типовой конфигурации «Модуль управляемого приложения» следующим образом:

  1. В режиме конфигуратора выбрать узел «Управление торговлей», нажать на правую кнопку мыши и выбрать пункт «Открыть модуль управляемого приложения»:

    upr_prilog.jpg

  2. Найти процедуру ПриНачалеРаботыСистемы() Нажмите на рисунок, чтобы увеличить и добавить в конец строку:

    ПодключитьОбработчикОжидания("БитриксПроверкаЧеков", 300);

  3. Добавить процедуру БитриксПроверкаЧеков() Нажмите на рисунок, чтобы увеличить

    Процедура БитриксПроверкаЧеков() Экспорт
    лКоличествоДоков = Б_ПечатьЧековСервер.КоличествоДокументовДляЧеков();
    Если лКоличествоДоков > 0 тогда
    Если Б_ПечатьЧековСервер.ЭтоНужноеРабочееМесто() тогда
    Б_ПечатьЧековКлиент.ПечатьЧеков();
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры


Не забудьте! При обновлении конфигураций 1С нужно следить, чтобы обновление не затерло это изменение.


Курсы разработаны в компании «1С-Битрикс»
Спасибо, мы рады что смогли помочь Вам. Ниже Вы можете оставить свой отзыв или пожелание :)
Нам жаль это слышать… Но мы постараемся быть лучше! Поясните, пожалуйста, свой выбор:

Мы благодарны Вам за помощь в улучшении документации.

Мы стараемся сделать документацию понятнее и доступнее,
и Ваше мнение важно для нас