Настройки для печати чеков

Урок 124 из 170
Автор: Ольга Пичужкина
Сложность урока:
2 уровень - несложные понятия и действия, но не расслабляйтесь.
2 из 5
Дата изменения: 27.05.2022
Просмотров: 8062
Недоступно в лицензиях:
Текущую редакцию Вашего 1С-Битрикс можно просмотреть на странице Обновление платформы (Marketplace > Обновление платформы).
Старт, Стандарт, Энтерпрайз

Если вам необходимо печатать чеки для интернет-магазина, то нужно внести несколько доработок в установленный Порядок установки модуля обмена:
- Установите скачанный установщик модуля обмена согласно прилагаемой к нему инструкции.
- Запустите систему 1С:Предприятие в режиме Конфигуратор
- Сделайте архивную копию информационной базы.
Подробнее...
модуль обмена 7.х.

Внимание! Функционал автоматической печати чеков работает пока только для российских конфигураций.

Нужно доработать объект типовой конфигурации «Модуль управляемого приложения» следующим образом:

  1. В режиме конфигуратора развернуть дерево конфигурации konfig1.png , выбрать узел «Управление торговлей», нажать на правую кнопку мыши и выбрать пункт «Открыть модуль управляемого приложения»:

    upr_prilog.jpg

  2. Найти процедуру ПриНачалеРаботыСистемы() Нажмите на рисунок, чтобы увеличить и:
    • если конфигурация 1С – УТ, ERP 2 или КА 2, то добавить в конец 3 строки konfig2.png :
      Если Б_ПечатьЧековСервер.ЭтоНужноеРабочееМесто() тогда
      ПодключитьОбработчикОжидания("БитриксПроверкаЧеков", 300);
      КонецЕсли;
    • если модуль УНФ, то добавляем в конец 1 строку:
      ПодключитьОбработчикОжидания("БитриксПроверкаЧеков", 300);

  3. Добавить процедуру БитриксПроверкаЧеков() Нажмите на рисунок, чтобы увеличить

    Процедура БитриксПроверкаЧеков() Экспорт
    лКоличествоДоков = Б_ПечатьЧековСервер.КоличествоДокументовДляЧеков();
    Если лКоличествоДоков > 0 тогда
    Если Б_ПечатьЧековСервер.ЭтоНужноеРабочееМесто() тогда
    Б_ПечатьЧековКлиент.ПечатьЧеков();
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры


Не забудьте! При обновлении конфигураций 1С нужно следить, чтобы обновление не затерло это изменение.

А также не забудьте в форме настроек параметров обмена на вкладке Оплаты отметить "птичкой" параметр Загружать оплаты

oplaty.png



Курсы разработаны в компании «1С-Битрикс»
Спасибо, мы рады что смогли помочь Вам. Ниже Вы можете оставить свой отзыв или пожелание :)
Нам жаль это слышать… Но мы постараемся быть лучше!

Мы благодарны Вам за помощь в улучшении документации.

Мы стараемся сделать документацию понятнее и доступнее,
и Ваше мнение важно для нас